Introduction to fcSDK | fcSDK Documentation

Introduction to fcSDK

Welcome to the Dovetail Software Development Kit for Clarify (fcSDK ) SDK Documentation. The fcSDK is Dovetail Software's next-generation technology, based on Microsoft™'s .NET framework, that allows you to write Clarify-based customizations and programs easily and quickly.

The fcSDK contains libraries, utilities, documentation, examples, and sample applications. Among the list of libraries included is the First Choice Foundation Layer for .NET (FCFL.NET). FCFL.NET is based on and emulates the successful Dovetail FCFL platform. FCFL.NET provides most of the same concepts and employs the same basic paradigms as FCFL. If you know how to write FCFL programs, it will be very easy to move up to FCFL.NET and the fcSDK. For more information about FCFL, please see the FCFL Installation and User Guide.

Another set of libraries worth noting are the new Microsoft™ .NET-based FCFL.NET Toolkits. These toolkits allow you to perform, quickly and easily, almost every action that can be performed in the Clarify thick-client using familiar .NET object-oriented patterns. The FCFL.NET Toolkits are based on the popular Dovetail FCFL Toolkits (such as the FCFL API Toolkit for ClearSupport).

NOTE: For information about the latest version of the fcSDK and previous ones, please view the version history.

In the fcSDK Documentation:

  • Installation Guide
    Provides a step-by-step guide on installing the fcSDK and the programmer demo applications.
  • Getting Started
    Provides a quick checklist for getting started navigating the documentation and using the fcSDK
  • Overview of the fcSDK
    Describes the basic architecture and features of the fcSDK
  • Guide to the features in the fcSDK
    Highlights the features of the fcSDK and advantages over previous versions
  • What's New in the fcSDK
    What has changed in the latest version of the fcSDK
  • fcSDK Version History
    Describes the changes from one version to another of the fcSDK
  • Using and Configuring the fcSDK
    • Developer Walkthrough - FCFL.NET Objects
    • Developer Walkthrough - Toolkit Fundamentals
    • Accessing Data with ClarifyGeneric
    • Using the Caching Features of the fcSDK
    • Application Logging
    • Data Restrictions
    • fcSDK Configuration
    • Time Zones
    • Enabling Storage of Unicode Data
    • Making World-Ready Applications With the fcSDK
    • Using the fcSDK Utilities
  • fcSDK System Requirements
    Provides the minimum and recommended system requirements for both the computer the fcSDK is on as well as the database server software and platform
  • Product Support Options
    Provides information for receiving technical assistance with the fcSDK
  • About Dovetail Software
    Contains information about the history of Dovetail Software, legal notifications, and credits

The fcSDK Compatibility Guide

The fcSDK includes a COM "Compatibility Layer" which allows it to appear as and behave similar to the original Dovetail FCFL and Dovetail Toolkit API products. This allows the fcSDK to be used "plug and play" with existing applications written for FCFL and the FCFL-based toolkit APIs.

  • The fcSDK COM Compatibility Guide

API Reference

Supplies syntax, code samples, and related information for each class in the fcSDK namespaces.

  • FChoice.Common Namespace
    Provides basic supporting services like configuration, logging, and error management services to Dovetail .NET-based products.
  • FChoice.Foundation.Clarify Namespace
    Provides Clarify-specific authentication, business logic, and data access for Clarify databases.
  • Individual Toolkit Namespaces:
    • [FChoice.Toolkits.Clarify.Contracts](sdk/ FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Contracts_namespace.md) - API Toolkit for ClearContracts operations
    • [FChoice.Toolkits.Clarify.DepotRepair](sdk/ FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.DepotRepair_namespace.md) - API Toolkit for Depot Repair operations
    • FChoice.Toolkits.Clarify.FieldOps - API Toolkit for Field Operations
    • FChoice.Toolkits.Clarify.Interfaces - API Toolkit for core operations such as sites and contact manipulation
    • FChoice.Toolkits.Clarify.Logistics - API Toolkit for ClearLogistics operations
    • FChoice.Toolkits.Clarify.Quality - API Toolkit for ClearQuality operations
    • FChoice.Toolkits.Clarify.Sales - API Toolkit for ClearSales operations
    • FChoice.Toolkits.Clarify.Support - API Toolkit for ClearSupport operations
Back to top © 2022 Dovetail Software, Inc. - All rights reserved.
Clarify, Amdocs, and related products and names are copyright and trademark of Amdocs, Inc.
.NET, Visual Studio.NET, C#, Visual Basic and related products are trademark of Microsoft corporation.


fcSDK Installation Guide | fcSDK Documentation

Show / Hide Table of Contents

fcSDK Installation Guide

Requirements

The fcSDK environment requirements can be found in the section titled 'fcSDK Environment Requirements'.

Packaging

The fcSDK ships as a single ZIP file, containing the installation package for the fcSDK itself as well as a separate compiled help module (CHM) documentation file in which this installation guide exists.

Upgrading from FCFL/COM

FCFL/COM and the fcSDK can run side-by-side on the same computer. Each can be configured to run against the same or different Clarify™ database instances without issue. The fcSDK requires a few schema modifications in addition to those required by the FCFL/COM installation. Please read the Schema Modification section later in this document for more information on what these extra requirements are.

Installing the fcSDK using the Installation Package

NOTE: The fcSDK installer requires a user with Administrative privileges on the local machine to execute the installation. Please ensure that you are logged on as a user with such privileges before starting.

Start the installation process of the fcSDK by extracting the contents of the ZIP file to a temporary directory on the machine on which the fcSDK is to be installed. Start the installation by double-clicking on the fcsdk.exe file. The installer wizard will start and will take you through the following steps:

  1. Welcome Screen
  2. Choose Setup Type - Select from Typical or Developer installations. You may also select Custom to control in detail what features are installed and what location they are installed. By default software is installed to C:\Program Files\Dovetail Software\fcSDK. When selecting a Custom setup type you will be presented with a treeview containing the available features of the installer. Here is a brief summary of each feature.
    • Typical
      • fcSDK Documentation - The documentation you are currently reading.
        • Data Verifier - Verifies fcSDK installation and integrity of data in your Clarify database.
        • fcSDK Support Utilities
          • License Installer - For installing Dovetail Software licenses.
          • Configuration Protector - Assists will creating encrypted application configurations.
          • Configuration Editor - Edits application configurations for database connection settings.
    • Developer
      • VS.NET Support - Adds Dovetail assemblies to the .Net tab in Visual Studio
  3. Confirmation - This step confirms that you are ready to begin the actual install procedure of the fcSDK on this computer.
  4. Ready to Install - When all information has been collected you will see this step. Clicking Next will begin the install process.
  5. Installation Progress - As the installer copies files and performs other actions on the computer, you will see the progress bar showing the percentage complete for the current task or overall installation.
  6. Installation Complete - This step confirms that the installation was successful. You can safely click the Finish button to exit the installer. To perform a spot-check confirmation that the install performed its tasks correctly, open the Start Menu and browse to All Programs -> Dovetail Software -> fcSDK. There should be several shortcuts to various utilities, the documentation, etc.

Special Information About Performance Counters Security Settings

The fcSDK exposes performance counters that can be monitored using the Windows Performance Monitor utility (perfmon). In order for the fcSDK to connect to its performance counters and be able to update their values, certain permissions are required to access a few registry keys.

Normal Windows users have this privilege and no special permissions are required. However, if the fcSDK is to be run from a low-privileged app (such as a Windows Service running as the NETWORK SERVICE user or as an ASP/ASP.NET web application like Dovetail's Agent software, it will require extra permissions for these users on specific keys.

Important: To make the performance counters available the fcSDK installer sets the following registry keys to be read accessible to Everyone.

  • HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\PerfLib : Read Access
  • HKLM\SYSTEM\CurrentControlSet\Services\FChoice.Common : Read Access

It is easiest to use the Everyone user when setting these permissions since there is little security threat posed by these registry keys. However, if you do not wish to use the Everyone use and wish to use specific users, please see below for specific information about which user(s) are required.

Which user(s) require the permissions mentioned above depends on the application. If you have a custom applications, the application developers should know which user or users require the permissions. For Dovetail products, see below:

  • SEC.NET and other similar Windows Service software: NETWORK SERVICE (Windows XP, Windows 2003 Server only), otherwise, whatever user the service is configured to run as. For more information on how to configure SEC.NET or other software, please contact Dovetail Software.
  • fcClient: IUSR_MACHINENAME and IWAM_MACHINENAME

NOTE: It is possible to disable the performance counter functionality in the fcSDK and thus avoid the need for special permissions. For more information, please see the section titled Basic fcSDK Configuration.

The fcSDK Installation Tree

The paths mentioned below are relative to the installation path specified when using the installer. By default, this path is C:\Program Files\Dovetail Software\fcSDK. The following directories are created under the installation root:

Directory Name | Purpose
bin | All the binaries and assemblies for the fcSDK product.
docs | User and developer documentation
files | Support files such as data import files
icons | Icons used for the Start Menu shortcuts and applications
samples | Sample scripts, configuration files, and other files
schema | Schema file(s) for installing required and optional schema changes for the fcSDK
sprocs | SQL scripts used for installing stored procedures required by the fcSDK

Post-Installation Tasks

Schema Modification

The fcSDK requires certain schema modifications and can benefit from certain optional modifications.

In order to modify the schema of your Clarify™ database, you must have Dovetail SchemaEditor or the correct database administration tools for your specific Clarify™ version and database platform. Files needed for Schema Modification are in the schema folder located in the fcSDK installation directory.

Using Dovetail SchemaEditor for Schema Modifications

To make the required schema changes using Dovetail SchemaEditor, perform the following steps:

  • If this is your first time using SchemaEditor you need to generate a .SchemaEditor file - SchemaEditor -g
  1. Edit the Default.SchemaEditor file
    • Set the database connection information in the Default.SchemaEditor file
    • Set the inputFilePath element in the Default.SchemaEditor file to fcSDK_schemascript.xml
  2. Preview the changes - SchemaEditor.exe -p
  3. Apply the changes - SchemaEditor.exe -a

If desired repeat steps 1 thru 3 for the following optional schema script files.

  • fcSDK_data_restrictions_schemascript.xml - Adds Data Restriction
  • fcSDK_i18n_lists.schemascript.xml - Adds support for localized GBST and HGBST (customer and user-defined pop-up lists)

Using DDEditor for Schema Modifications

To make the required and optional schema changes using Clarify's DD Editor, follow these steps:

  1. Start the DD Editor program.
  2. Use the "Save" or "Export Schema" functionality (this varies from version to version of DD Editor) to save a copy of the database to disk.
  3. Open the newly saved schema file in a text editor as well as the fcflnet_schema.sch file mentioned above and manually merge the required changes and any optional changes you decide to incorporate. See DDEditor Schema Changes Details below for the required changes for each installation type.
  4. Use the DD Editor program to apply the schema changes (the details of how this is done varies from version to version of DD Editor)
  5. Exit DD Editor.

Below are the required and optional schema changes for the two modes of installation: Upgrade from FCFL/COM or Fresh Install of the fcSDK.

Using Amdocs Schema Manager for Schema Modifications

To make the required and optional schema changes using Amdocs Schema Manager, follow these steps:

  1. Use Schema Manager to export your schema file from the database. Use the -schema schema.xml parameter to dump the schema to a file.
  2. Edit your schema file, incorporating the required changes (and any optional changes you decide to) from the fcSDK_schema6.sch file. See Schema Changes for more details.
  3. Use Schema Manager to apply the schema changes to your database. Use the -modify schema.xml parameter to apply the changes.
  4. Refer to your Amdocs documentation for more details on using Schema Manager.

Schema Changes

Required:

  • Add "site_status" field to the "rol_contct" view
  • Add "work_group" field to the "empl_user" view
  • Add table "fc_licensing"
  • Add table "fc_licensegrace"

Optional:

  • Add the "fc_string" table

For Data Restriction functionality:

  • Add "user2restriction" and "curr_user2restriction" relations to table "user"
  • Add table "res_tbls"
  • Add table "res_sql_clause"
  • Add table "restriction"

For localized GBST and HGBST (custom and user-defined pop-up list) lists

  • Add relation to "hgbst_elm" table
  • Add relation to "gbst_elm" table
  • Add "fc_loc_elm" table

Install Required Stored Procedures

MSSQL Database

Open Query Analyzer and connect to your Clarify database as a user with database administrator privileges. Select the correct database from the database drop-down list. Next, open the file called "mssql_sprocs.sql" in the 'sprocs' folder in the fcSDK installation directory and execute it. When the execution is finished, the results window in Query Analyzer should say:

The command(s) completed successfully.

Alternatively, the "isql" command-line utility can be used to execute the creation of the stored procedures. Ensure that the MSSQL installation "binn" directory is in your system PATH environment variable by typing "isql /?" at the command prompt. You should see the usage help text for the isql command. If you get an error, please add the "binn" (note the extra 'n') folder in your MSSQL installation directory to your PATH environment variable. From a command-line, change directory to the fcSDK installation path and then again to the 'sql' folder.

Next, execute the following command-line syntax, replacing the <xxxxx> tokens as appropriate:

isql -S <server> -d <dbname> -U <username> -P <password> -i mssql_sprocs.sql

Token | Description
<server> | MSSQL server/host name (i.e. DB1, DBSVR1, etc)
<dbname> | Database name on the SQL server instance (i.e. cl12, clarify, etc)
<username> | SQL Authentication username (i.e. sa)
<password> | SQL Authentication password

If no errors are returned, the stored procedure was created successfully. The result output should look similar to this:

1> 2> 3> 4> 5> 6> 7> 8> 9> 10> 11> 12> 13> 14> 15> 16> 17> 18> 19> 20> 21> 22> 23> 24> 25> 26> 27> 28> 29> 1> 2> 3> 4> 5> 6> 7> 1> 2> 1> 2> 3> 4> 5> 6> 7> 8> 1> 2> 1> 2> 1>

ORACLE Database

Compile and install the special Oracle stored procedures defined in the "oracle_sprocs.sql" file located in the 'sprocs' folder underneath the fcSDK installation path.

NOTE: There are two different Oracle stored procedure files: oracle_sprocs_pre9.sql and oracle_sprocs_post9.sql. The "pre9" file is for Oracle databases running Clarify versions earlier than v9 (NOT the Oracle version, just the Clarify version). The "post9" file is for Oracle databases running Clarify versions 9 or above. Please select the correct file for the example below.

From a command-line, change directory to the 'sql' folder. Execute sqlplus with the following syntax, replacing the <xxxxx> tokens as appropriate:

Clarify versions earlier than 9:

sqlplus <user>/<pass>@<sid> @oracle_sprocs_pre9.sql

-OR-

Clarify versions later than 9:

sqlplus <user>/<pass>@<sid> @oracle_sprocs_post9.sql

Token | Description
<user> | Username of a user with DBA/admin privileges on this database
<pass> | Password for the user
<sid> | ORACLE database instance SID

A series of output statements from SQL*Plus will be displayed to the console listing successful compilations and creations or errors. If there were no errors, the stored procedures were created successfully. The output from a successful installation will look similar to this example:

SQL*Plus: Release 9.2.0.1.0 - Production on Wed Mar 9 17:46:52 2005

Copyright (c) 1982, 2002, Oracle Corporation.  All rights reserved.

Connected to:
Oracle9i Enterprise Edition Release 9.2.0.1.0 - Production
With the Partitioning, OLAP and Oracle Data Mining options
JServer Release 9.2.0.1.0 - Production

Procedure created.

No errors.

Procedure created.

No errors.

Grant succeeded.

PL/SQL procedure successfully completed.

Synonym created.

Grant succeeded.

PL/SQL procedure successfully completed.

Synonym created.

Disconnected from Oracle9i Enterprise Edition Release 9.2.0.1.0 - Production
With the Partitioning, OLAP and Oracle Data Mining options
JServer Release 9.2.0.1.0 - Production

Set Server Time Zone

It is important to make sure you have the time zone of your Clarify instance set correctly. To verify and correct this setting you simply need to connect to your Clarify database using your favorite database query utility and execute the following query.

select * from table_time_zone where is_default = 1

If the full_name field returns a value of No Time Zone Specified or has a time zone specified that is incorrect you can correct the issue by setting the is_default field of the appropriate row to 1.

update table_time_zone SET is_default = 0
update table_time_zone SET is_default = 1 WHERE name = {Your Database Server's timezone}\'

Optional Installation Steps

If you wish to customize or localize the fcSDK's error messages, you may wish to import the "fcerrors.dat" file. This file is located in the "files" directory underneath the fcSDK installation path. Once imported, the errors for the default (EN_US) locale can be customized, or copied to another locale and translated.

If you wish to use fcSDK's remote session feature please follow the guide on Configuring Remote Sessions.

License Installation

For information on how to use the FC License Installer to install your fcSDK and other licenses, please see the section titled "Overview of the fcSDK License Installer"

Running the Data Verifier

Data Verifier is a utility that can be run against a Clarify database to ensure that there are no inconsistencies or bad data that might prevent the fcSDK from initializing properly.

After installing the fcSDK and applying the necessary schema changes, it is recommended that you run Data Verifier to confirm the installation was successful.

To learn how to run and use the Data Verifier, please see the section titled Overview of fcSDK Data Verifier.

Review SDK Documentation

After installation, the next step to getting started with the fcSDK is to review the SDK documentation in this document. A good place to start is the Introduction Section.

The SDK documentation includes information on getting started programming with the fcSDK, working with the same applications, limitations and known issues, API reference, and specifics on many of the features included with the fcSDK.


Getting Started with fcSDK | fcSDK Documentation

Getting Started with fcSDK

General

For an accelerated introduction to the First Choice Foundation Library for .NET (fcSDK), please follow these steps in sequence:

  1. Read the Overview of the fcSDK topic.
  2. Read the Developer Walkthroughs for FCFL.NET and the API Toolkits.
  3. Install the fcSDK. See the section titled "Installation Guide" for information on how to install these applications.
  4. Scan the API reference topics as you browse the source for the examples and run them.
  5. Create your own sample application using the fcSDK samples as a guide and referring frequently to the API Reference.
  6. Read how to Access Data using ClarifyGeneric for more in-depth information on using FCFL.NET and ClarifyGeneric to manipulate data in your database.

Uses of the fcSDK

The fcSDK can be used for virtually any task you might have that requires that data be read from or written to a supported database.

The fcSDK supports a great many environments. You can write web-based ASP.NET applications, Web Services, Windows Forms applications, console applications and almost any other type of application.

The fcSDK programs can be written in any .NET CLS-compliant language. The .NET-based languages (C#, VB.NET, Jscript.NET) are the most common, and provide the quickest path to writing fcSDK programs. But other languages and environments are possible. Older COM-based languages, as well as older web environments (JScript or VBScript) are also possible using the fcSDK COM Compatibility Layer.

About Java™ Support

The fcSDK is based on the Microsoft™ .NET Framework environment. As such, it does not natively support Java™ programs and environments.


Overview of the fcSDK | fcSDK Documentation

Overview of the fcSDK

What is the fcSDK?

The fcSDK is a software development kit for writing applications, using .NET, to access Clarify™ databases. This kit includes code libraries, documentation, examples, sample applications, and utilities to help with configuration and database management. The core of the fcSDK is comprised of two main sets of libraries: the FCFL.NET libraries and the API Toolkit libraries.

FCFL.NET

FCFL.NET provides a number of basic application services such as configuration, logging, provider-independent data access, licensing, etc. The main purpose of FCFL.NET, however, is to provide low-level, direct access to a Clarify database without having to involve any other Clarify products. Using FCFL.NET, you can query, insert, update, and delete data from your database without worrying about corrupting data or interferring with the use of other software attached to your database. FCFL.NET uses the same semantics that the Clarify Classic Client uses for performing database operations. FCFL.NET can peacefully coexist at the same time against the same database with other Clarify applications as well as other First Choice appplications. FCFL.NET is a completely rewritten, rearchitected, and fully .NET library based on the concepts and ideas used in the original FCFL for COM product, but without any of the limitations.

FCFL.NET is based on and emulates the successful First Choice FCFL platform. FCFL.NET provides most of the same concepts and employs the same basic paradigms as FCFL. If you know how to write FCFL programs, it will be very easy to move up to FCFL.NET.

FCFL.NET has two major components: The FChoice.Common assembly and the FChoice.Foundation.Clarify assembly.

The FChoice.Common assembly is designed to provide basic application services such as configuration, logging, cross-platform database access, and structured, localized error handling. FChoice.Common will be used by multiple First Choice products and can be used independently of First Choice products by First Choice customers directly.

The FChoice.Foundation.Clarify assembly provides a specific implementation of the FChoice.Foundation abstraction layer for Amdocs Clarify™ CRM systems. This assembly adds extra functionality above FChoice.Foundation that is specific to Clarify systems. For example, object-oriented access to cached frequently-used data allows easy access to user-defined lists (HGBST's) and global string lists (GBST's) via the ListCache property of ClarifyApplication, country, state, and time zone information via the LocaleCache property, and ADP schema information via the SchemaCache property, and much more. For more specific inforamtion on Clarify-specific features in the FChoice.Foundation.Clarify assembly, see the API reference for the FChoice.Foundation.Clarify namespace.

API Toolkits

The API Toolkits provide convenient business logic wrappers for most of the common tasks performed by the Clarify Classic Client. These include, but are not limited to: Creating cases, solutions, contacts, change requests, and site parts, performing workflow operations like assigning cases and dispatching change requests, and performing logistical operations such as moving and installing parts.

The toolkits cover some or all of the functionality in the Classic Client that are associated with ClearSupport, ClearLogistics, ClearQuality, and several others.

The API Toolkits in the fcSDK are divided into functional areas that map closely to Clarify™ products. For example, the FChoice.Toolkits.Clarify.Support namespace and, specifically, the SupportToolkit object reflect most or all of the functionality in the ClearSupport product for Clarify™.

For more information on how to get started writing applications using the API Toolkits, please see the developer walkthrough of Toolkit Fundamentals.

FCFL and API Toolkit COM Compatibility Layer

For current First Choice customers perhaps the most important feature included with the fcSDK, is the COM Compatibility Layer. This set of COM objects included with the fcSDK emulate the existing FCFL interface. Allowing you to use the FCFL and API Toolkit COM Compatibility Layer instead of FCFL or the original FCFL-based COM API Toolkits.

By doing this you will gain most of the benefits of the fcSDK without having to change a single line of code. This means, for example, that current fcClient or fcSelfService thin client users can see performance and scalability improvements simply by substituting the fcSDK for FCFL and the FCFL-based API Toolkits.

Later, when you are ready, you can start to add new features to your system with native fcSDK programming. This can be either for writing new, general programs, or to take advantage of specific features of fcSDK that are not available with the FCFL-based platform.

It should be noted that there is a small amount of overhead added when using the compatibility layer as compared to using the fcSDK directly. The COM to .NET translations do take a very small amount of time. But the overall the underlying improvements in the fcSDK are so significant that it is well worth your time to upgrade to the fcSDK, even if you don't write any native fcSDK programming for a long while.

Any new programming projects you start (for example, a new web application) should be written with the fcSDK – the advantages available to you in this new system are numerous and significant, justifying a migration to the new platform. Also, the fcSDK is faster in the native mode than in the compatibility mode, and there is no additional penalty in using both modes in the same code module.

For a sampling of some of the great new features in the fcSDK, please the the Guide to the features in the fcSDK.

Web Services

The Web Services provide a web service interface into many of the fcSDK features such as querying and modifiying data as well as invoking API Toolkit methods. These web services are built using the SOAP standards defined by the W3C, which means you can use them with any langauge or platform that supports the HTTP protocol such as Java™. The fcSDK ships with a client assembly for .NET which makes calling the web services very similar to native FCFL.NET and API Toolkit calls.

Note: The Web Services have been moved to to a public GitHub repository: Dovetail SDK Web Services. Please use the services there to view the code, fork it, etc. The documentation provided here is still applicable, but Web Services are not included as part of the fcSDK installation.

For more information on how to get started writing applications using the Web Services, please see the developer walkthrough of Web Services Fundamentals.

Utilities

The fcSDK ships with several utilities to help you manage your Clarify database, configure the fcSDK and other tasks. For more information on these utilities, see the Utilities Overview section of this documentation.

Samples and Examples

Throughout the fcSDK documentation you will see helpful, working examples of how to use the system.

If you copy and paste these examples into your solutions, you will quickly get a head start on your application based on the fcSDK.

Getting More Information

For more information about FCFL.NET, or any other Dovetail Software product, please contact us at sales@dovetailsoftware.com or support@dovetailsoftware.com, or visit our website at http://www.dovetailsoftware.com/.


Guide to the features in the fcSDK | fcSDK Documentation

Guide to the features in the fcSDK

The fcSDK provides some impressive features as well as a solid architecture from which to build new or upgrade existing applications. Please view the following sections for more information about the features that fcSDK provides.

Clarify Compatibility and Multi-version Support

The fcSDK has been written to be 100% Clarify compliant for Clarify versions 7 and later. All of the conventions you expect and require for a working Clarify system are implemented with the fcSDK. Some of the more common of these are support for:

Objid generation Numbering scheme generation Relation support (relate from either side of a table) MTM table support Change date/change fields Cached common data available Cached schema (available in the fcSDK, but not in Clarify's system) Case sensitive fields (s_ fields) – Oracle™ only Exclusive relations Mandatory relations When you commit multiple objects in a single transaction, the condition object is committed first, and then the objects are committed in order of their table number. This is done to minimize deadlock issues NULL field values Starting date in 1753 support (needed for ?/?/? dates in thick client) The crucial design point for the fcSDK is that you should not (and will not) be able to tell if data were written or read from Clarify with the fcSDK or with a Clarify tool.

NOTE: The current version of the fcSDK has not been validated against Clarify's Traveler product.

.NET Object Oriented and Managed Code Environment

Since fcSDK is based on the Microsoft™ .NET Framework, it inherently gains powerful features such as an object-oriented, managed code, highly secure operating environment. The features and advantages of the Microsoft™ .NET Framework are too numerous to list here, but a few of the major ones are:

  • Common Language Runtime (CLR)

    The CLR is a language-neutral development and execution environment that provides modern features such as memory management, Just In Time (JIT) compilation performance enhancements, strongly typed code enforcement, and code access security (CAS) among many others.

    The CLR executes code compiled from any standard Common Language System (CLS) compiler. This means code written in C# can interoperate 100% with code written in Visual Basic.NET or C++ with Managed Extensions and vice versa.

  • Framework Class Libraries (FCL)

    A consistent, object-oriented set of libraries with prepackaged functionality such as data access, XML technologies (XML, XSD, XPath, XSLT, etc), IO access, managed threading, etc.

    This allows fcSDK to take advantage of many features already provided for in the .NET Framework. These features are already well tested and used widely so they help make fcSDK a more stable and major product out-of-the-box.

  • Garbage Collection -With FCFL, the programmer is responsible for manually cleaning up and disposing of all objects (particularly FCGeneric objects). It is not uncommon to find FCFL programs that are not as well written as they could be. They usually have memory leaks because not all FCGeneric objects were closed properly.

    With fcSDK this is no longer an issue. The .NET framework contains a robust garbage collector. When objects are no longer needed, and are no longer referenced they are automatically reclaimed for you.

  • Support for modern technologies such as XML and Web Services

    The .NET FCL provides standardized access to modern technologies and standards such as XML, SOAP (Web Services), TCP/IP, HTTP, and other networking protocols, etc. This allows the fcSDK to support more features and standards out-of-the-box by taking advantage of the standard features in the .NET Framework which is well tested and widely used in the development community.

  • Multi-threaded runtime - Microsoft™ .NET was written from the ground up and does not inherit any of the design restrictions imposed by previous Microsoft™ technologies such as COM. This means that .NET components are fully multithreaded and able to be used from multiple threads without any restrictions from the Framework itself as was true in a COM environment (STA, MTA, etc).

    The fcSDK engine is built to be completely thread safe and to take advantage of the .NET multi-threaded paradigm. This yields large gains in both scalability and performance. The single-threaded nature of the FCApplication was perhaps the largest performance bottleneck with FCFL, due to limitations in the base COM subsystem. This meant that cached item requests were all passed in a serialized manner to the cache management routines.

    With fcSDK, all such requests are able to be processed in parallel. Our tests show an asymptotic improvement in performance for such caching requests.

  • Open, standardized, and multi-platform

    The Microsoft™ .NET Common Language Infrastructure (CLI) which defines all the core operating principles behind how the CLR works was published by Microsoft™ as a standard to the ECMA International standards body in December of 2002. Along with this standard, Microsoft™ submitted a standard for C# as a language to accompany the CLI. Later, both standards were later adopted by the International Standards Organization (ISO) as ISO 23270 - C# Language Specification and ISO 23271 - Common Language Infrastructure.

    Microsoft™ officially supports .NET on Windows 98, Windows 2000, Windows XP, and Windows 2003 Server. Since .NET is an open standard, there have been several 3rd party implementations on other platforms such as Microsoft™'s own Shared Source CLI implementation for Windows and FreeBSD (which has been adapted for other platforms including Linux).

    There have been several open source implementations of the CLI and C# standards, most notable are the Mono Project by Ximian and Novell and the DotGNU/Portable.NET Project by the GNU Project/Free Software Foundation.

    Dovetail Software is considering the possibility of releasing a version of fcSDK for the Mono platform. This could potentially allow fcSDK to run on Sun Microsystems™ Solaris™, Hewlett Packard™ HP-UX™, and several Linux distributions in addition to Microsoft™ Windows™. Support for fcSDK for the Mono platform will be based on customer demand. If this is of interest to you, please contact Dovetail Software.

Performance Enhancements

Several inherent design features of the .NET runtime give the fcSDK a performance boost naturally. In addition to this, great care has been taken during the development of the fcSDK to ensure that, at least, no major bottlenecks or inefficiencies exist and, at best, various data access and processing functions are optimized as much as possible.

Here are some of the inherent and designed performance enhancements in the fcSDK:

  • Multi-threading. All .NET objects, when called from a COM client, are seen as 'Free-Threaded', 'Multi-Threaded Apartment' (MTA), or 'Both'. Previous products were either 'Apartment' or 'Single-Threaded Apartment' which could cause blocking in a multi-user system (like a Web Application).
  • The fcSDK benefits from the well-designed, well-tested, and high-performing data structures and objects that are provided natively in the .NET Framework Base Class Library (BCL).
  • All major data access used by or through the fcSDK uses SQL prepared statements and bind variable support. This allows Microsoft™ SQL Server™ and Oracle™ to cache the execution plan of a statement, allowing it to execute faster on subsequent calls.
  • Support for batching of SQL INSERT and UPDATE Statements (for Microsoft™ SQL Server™ only)
  • Other SQL improvements have been made in the base SQL generated by fcSDK More objects are cached than in previous products. This allows for faster access and fewer database round-trips.

Object Oriented Libraries Design

The fcSDK is a pure object oriented environment. Every useful artifact is defined as an object, and many objects may be overridden to allow you to customize in your own desired behavior. A good example of this is the new CacheManager and CacheBase objects. While fcSDK ships with a variety of predefined objects (that are cached on the application server), it is trivial for you to define your own user-defined cache for some commonly-used, user-specific data. For example, suppose that your implementation contained a new, user-defined, table for common product configurations. You might desire to have these configurations cached, so that they did not need to be queried from the database each time they were used. By adding a few lines of XML to the fcSDK configuration file, the fcSDK will create an indexed cache based on the specified table.

The API in the fcSDK has been greatly refined. Many naming and calling convention inconsistencies have been eliminated. Various inconsistent or non-standard concepts have been removed or changed to fall in line with generally accepted practices and good design. For example, the concept of a "Bulk" no longer exists in FCFL.NET since it provided ambiguity and confusion of purpose and overlap of functionality. Its functionality has been consolidated into other areas and new usage patterns have replaced its use.

Another example of this refinement is the calling of API toolkits. Previously, to create a case, you might call the create_case API on the FCCS API Toolkit for FCFL. This method took more than two dozen required or optional parameters. All the APIs have been replaced with a consistent and well-designed pattern. Every API can be called one of two ways: A minimal way with only the required parameters, or an Advanced way where you can create a "Setup" object (i.e. CreateCaseSetup) and set many different options for advanced functionality and pass that to the particular API method.

Caching of Frequently Used Data

FCFL.NET provides a new multi-threaded cache manager. This manager allows access to cached data. The cached data includes user-defined lists, string lists, countries/states/time-zones, and the ADP schema itself.

All of the cached data is indexed and quickly accessible. It can be accessed in a consistent, standard, and object-oriented way making it easy to use, for example, DataBinding in WinForms or ASP.NET. Since the CacheManager can be accessed from multiple threads, cached data access is now much faster with FCFL.NET. The CacheManager is flexible and configurable, easily allowing for custom data to be cached and accessed the same way as other cached data.

Advanced Instrumentation and Logging

FCFL.NET provides a new logging framework that allows for dynamic configuration of logging on-the-fly (while a program is running), among other features. Log entries can be configured to send emails, write to a database, write to a syslog server, to a rolling file set, and several other locations. In addition to configuring where the log entries are written, you can control what is written and how it appears in the log destination. New log filters allow you to configure SQL statements to go to one log file, warnings to another, and errors to an email address, for example. It is also possible to log entries related to a particular user to a separate log destination. Large or lengthy SQL queries can be sent to a database administrator to alert him/her of problems in the database.

FCFL.NET also includes integration with the Windows Performance Monitor utility. Specific aspects of FCFL.NET's performance can be monitored while an application is running such as "Average Query Duration", "Queries / Sec", "# Errors Total", and "# Active Sessions". There is also a PerfManager class that assists developers in instrumenting their own applications with Performance Monitor counters.

Flexible Licensing Framework

FCFL.NET provides a flexible and comprehensive licensing framework to allow maximum flexibility and customization to match the needs of customers. Multiple products can be licensed differently under different conditions with different restrictions or provisions. There is now a new concept of "grace periods" and "grace logons". If the number of licensed users is exceeded, a few more can still log on and warnings are logged to alert the administrator about a potential problem.

This new framework allows First Chocie to be more flexible with respect to customer needs and gives the customer more options and choices.

Unicode Support

Since the fcSDK is based on the inherently Unicode-based .NET Framework, Unicode support is native and natural. The fcSDK allows for Unicode support even in Clarify versions earlier than 11.5 (which is when the first official support of Unicode was offered by Amdocs).

For more information on working with Unicode data using the fcSDK, please see the Unicode Storage Guide in this documentation.

Localization and Internationalization

The fcSDK also gains another out-of-the-box advantage by being based on the .NET Framework. The .NET Framework is internationally-aware and provides support for over 200 different, distinct cultures. FCFL.NET provides extra functionality that helps application developers write localized applications, such as localized error messages, localized string resource storage and retrieval, date/time format handling, and currency to name a few.

Compatibility With Existing Applications

The fcSDK includes a COM "Compatibility Layer" which allows it to appear as and behave similar to the original Dovetail FCFL and FCFL-based API Toolkit products. This allows fcSDK to be used "plug and play" with existing applications written for FCFL and FCFL-based API Toolkits.


What's New - Version 3.7.0 | fcSDK Documentation

What's New - Version 3.7.0

  • Core:

    • Support for Oracle 19c Database has been added.
      • odp.net.managed.121.1.2 library has been replaced with oracle.manageddataaccess.19.14.0.
      • Deprecated System.Data.OracleClient class by Microsoft has been replaced with Oracle.ManagedDataAccess.Client class by Oracle.
    • A problem with fc_next_num_scheme stored procedure returning invalid object identifiers while using Oracle database has been fixed.

  • Foundation:

    • New property TimeZoneConversions has been added to facilitate column exclusion from being converted to local time zone.
    • New connection string parameters: Integrated Security=SSPI; and Persist Security Info=True; can be used to log into the database using current Windows login credentials.
    • New property Username has been added to FCApplication class to allow setting user name for login instead of specifying it via database connection string.

  • API Toolkits:

    • Support Toolkit:
      • Fixed a breaking change in 3.6.0 that added an extra property to the modify_case, modify_subcase, and change_contact APIs. The OnlyOpen property was supposed to be added only to the .Net APIs via the UpdateCaseSetup, UpdateSubcaseSetup, and ChangeCaseContactSetup objects. The COM APIs should not have been changed.

  • Workflow:

    • Workflow Manager actions now set Impersonator's User Name on activity entry when user impersonation is engaged.

  • Installer:

    • Oracle.ManagedDataAccess.dll gets installed into Windows GAC during fcSDK installation. This library gets uninstalled from GAC when fcSDK is uninstalled.
    • Important for Oracle database users: the fc_next_num_scheme stored procedure must be replaced with the one included in the "oracle_sprocs_post9.sql" file located in the 'sprocs' folder underneath the fcSDK installation path, see fcSDK Installation Guide.

What's New in Previous Versions


fcSDK Version History | fcSDK Documentation

fcSDK Version History

Version 3.6.0

Enhancements

  • Core:

    • Added better handling of DBNull values during SDK initialization.
    • Fixed timezone conversion issue for DST border dates.

  • API Toolkits:

    • Support Toolkit:
      • Added a property to the UpdateCase, UpdateSubcase, ChangeCaseSite, and ChangeCaseContact APIs. The OnlyOpen property, which defaults to true, is checked before updating the case, subcase, or case site/contact. If the property is set to true, only Open cases/subcases can be updated.
      • Added support for two new email templates, to allow distinction and customization for outgoing case and subcase emails individually.
        • send_email_about_case
        • send_email_about_subcase If these templates are not found, the email will still be based on the send_email_about_obj template.
      • For all of the toolkits, the impersonatorUserName property was added to APIs to record the login name of the user that performed the activity on behalf of another user.

  • DataVerifier:

    • Corrected a few error/failure messages that can be seen when verifying states.
    • Added a new Dovetail Ready category, which contains:
      • FC String Locale Verifier
      • Stored Procedure Verifier
      • Verify License Table (broken out from sdk com compatibility test)
      • Verify SDK License (broken out from sdk verifier test)
      • SDK Verifier (COM)
      • SDK Verifier (.NET)
      • Schema Verifier
    • Added new tests under Schema Verifier:
      • Test for columns declared in the system but missing in Clarify schema.
      • Test for columns declared in Clarify schema but missing in the system.
      • ORACLE only - Look for db type of LONG for any table. While not an issue by itself, give a warning that another LONG column cannot be added to such a table. If table_commit_log.cmit_history is of db type LONG the schema changes for Agent cannot be applied and Schema Editor fails with Oracle error.
      • Test for missing non-exclusive relations.

Version 3.5.0

  • API Toolkits:
    • Sales Toolkit:
      • Added LogActionItemEmailIn API.
      • change_task_cond API:
        • included closing status in activity entry text.
        • added "Reopened" activity handling.
        • changed activity entry text for "Status Change" action.
        • after "Reopen", the task will be put into the default wipbin.
      • update_action_item API:
        • changed activity entry text for "Status Change" action.
        • proper values for action item timebombs are being used.
      • UpdatePartRevision API:
        • fixed a bug in which part revision was being cleared if it was not being changed to a new revision.
    • Clear Logistics Field Operations Toolkit:
      • made StartTime property public for UpdateTimeLogSetup class.
  • Cache Manager:
    • Added cache locale cleansing for duplicate states/provinces.
  • DataVerifier:
    • Modified error messages to better communicate issues with blank or duplicate states/provinces.

Version 3.4.3

  • API Toolkits:
    • Modified create_employee API to use new SQL statements: CREATE LOGIN and CREATE USER instead of sp_adduser and sp_addlogin system stored procedures in order to create new user login names - MS SQL databases only.
      IMPORTANT NOTE: Please see create_employee API notes for explanation of the implications regarding certain versions of MS SQL RDBMS.
    • Fixed an error occurring when a new case phone log was added while case history was returned as null because no initial notes are required at the time of case creation.
  • Logging:
    • All passwords are obfuscated with \'********\' for all set, reset, and update actions. This also applies to custom columns containing passwords for as long as they are named like \'%password'.
    • For parametrized SQL statements, when column mapping information is available, all parameter names are derived from column names. This allows for easy identification of the value used for each column.
    • Actual names of database tables are reported in the output regarding datasets used, if such information is available.
  • Security:
    • The encryption algorithm for user passwords has changed to better match with Clarify's encryption algorithm.
      This will affect users whose password contains one of these 7 characters: ! (exclamation mark), @ (at sign), # (hash/pound sign), $ (dollar sign), ^ (caret sign), & (ampersand), * (asterisk).
      IMPORTANT NOTE: For these users, their password will need to be reset, either by using the Forgot Password process, or by having it reset by an administrator. This only affects employees (users), not contacts (web_users).

Version 3.4.2

  • API Toolkits:
    • Added a new capability to create user login names with special characters - MS SQL databases only.
    • Added a test to ensure that new user login names conform to syntax rules for unquoted object names - Oracle databases only.
    • Fixed a bug in which the same data could be selected multiple times for a complex bulk query traversing many tables.
    • Fixed bugs within FCFO methods pertaining to Service Interruptions in which case record was referred to even if it was not available.

Version 3.4.1

  • API Toolkits:
    • Added a property to the SupportToolkit for the Create Case API. The UseDenormalizedCaseTypeLevels property, which defaults to true, is checked before populating the case_type_lvl[1,2,3] fields on the new case record. If the property is set to false, these fields are not populated.
    • Added a new .NET QualityToolkit API. This new API is not exposed via COM compatibility.
      • LogCREmailIn
    • Fixed bugs within FCFO methods pertaining to Service Interruptions and Employee Appointments in which wrong Application Lists were used and only the default values for Class and Type were recorded in Activity Log.

Version 3.4.0

  • API Toolkits:
    • IMPORTANT CHANGE: Subcase ID Number generation is now handled by a new stored procedure (fc_next_subcase_seq). This stored procedure needs to be compiled to your database. The Create Subcase API will not operate properly without this stored procedure being loaded into the database. See the
  • License Installer:
    • Added Dovetail Task Manager as a new product.

Upgrading from previous versions

  • Uninstall the old version of fcSDK .
  • Install the new version of fcSDK .
  • Install the required stored procedures, which includes the new fc_next_subcase_seq procedure for subcase ID generation.

Version 3.3.8

  • DataVerifier:
    • Added a test for CLOB/LONG columns inconsistency in Oracle database.
  • Core:
    • Added configuration item fchoice.setstringparameterdbtypeandsize to allow control whether the type and size of SQL parameter should be set by SDK or database driver.
    • Fixed a bug resulting with type and size of SQL parameter not being set for Oracle database.
    • Added a test and a warning for CLOB/LONG columns inconsistency in Oracle database.
    • Note: compatibility with and support for Oracle 12c has been tested and confirmed. See System Requirements and Dovetail Software Platform Guide for details.

Version 3.3.7

  • API Toolkits:
    • For CloseCase, when closing a case, if there are open Administraion type subcases, the Close Case API now sets the case's condition to 68 with a condition title of "Closed-Admin Pending".
    • For ReopenCase, if the case has a status of "Closed-Admin Pending", then it now gets reopened. It was failing with a "Case is not Closed." message.
    • For LogCaseEmailIn and LogSubcaseEmailIn, the email subject is now added to the email log record.
  • Installer:
    • Updated the required Microsoft .NET Framework to version 4.0 (Full). If this version has not been installed, the installer will stop.

Version 3.3.6

  • DataVerifier:
    • Added a new State/Prov test to make sure no entries have a blank/null name or full name.
    • Added a new Strings test to make sure no duplicate entries exist for each locale.
  • API Toolkits:
    • Fixed the activity time for UpdatePartRequestDetail to use the session current time.
    • For Site Parts - the site part objid is now returned in the toolkit result for the Move, Deinstall, and Reinstall APIs.
    • Added UseDatabaseLogins property to InterfacesToolkit. When set to False, a database user is not created by the CreateEmployee API.
  • Web Services:
    • The Web Services have been moved to to a public GitHub repository: dovetail-sdk-web-services. The documentation provided here is still applicable, but Web Services are not included as part of the fcSDK installation.
  • Demos:
    • The Demos have been moved to to a public GitHub repository: dovetail-sdk-demos. The documentation provided here is still applicable, but Demos are not included as part of the fcSDK installation.

Version 3.3.5

  • Core:
    • Improved performance for AppendFilterInList queries against non-unicode string fields, allowing the database to optimize the query.
    • Fixed bug where the field size for web user login_name was based on the user login_name size when used as a parameter for contact login.
  • API Toolkits:
    • Added remove child entity APIs for Contracts.
      • RemoveSiteFromContract
      • RemoveSitePartFromContract
      • RemoveContactFromContract
    • Adding an attachment will now update the parent objects timestamp when possible.
    • Fixed validation used when calculating a Contract's available units.
    • CreateAccount now correctly handles an empty or null Territory argument.
    • Fixed an issue where the timestamps written to the case_history field could be incorrect if the user's session timezone was different than the server time zone. This affected Forward, Reject, and Change Status activities. Note that the act_entry timestamps were written correctly.
    • Fixed a bug causing incorrect level_to_bin and level_to_part values stored for nested BOM parts being reinstalled.
    • Check Logistics and Quality transition operations now throw an exception when table_transition.rank value is higher than the table_privclass.trans_mask length.
    • Added missing information about the recipients to case history for Email In action.
    • Added missing information about the action type and the recipients to case history for Email Out action.
    • Added missing information about the user performing an action to case history.
    • Fixed a bug about setting incorrect value on time bomb flag for Action Item Change Status action.

Version 3.3.4

  • Core:
    • Fixed bugs in CreateAttachmentRecord to properly use metadata from WorkflowObjectInfo. It is now possible to use worflow objects which have been aliased.
  • API Toolkits:
    • Wrap password in quotes when setting/changing a user's password on Oracle databases.
    • Fixed a bug causing nested BOM parts being installed at a wrong site-part-to-site-part level.
    • Fixed bugs with CaseTimeAndExpenses object properties being ignored or improperly handled.

Version 3.3.3

  • Core:
    • Added SqlHelper configuration setting fchoice.sqlcommandtimeout which controls how long a SQL query is allowed to run. The .Net default (30 seconds) is used unless this specified.
  • API Toolkits:
    • Wrap password in quotes when setting/changing a user's password on Oracle databases.

Version 3.3.2

  • Core:
    • Fixed problem with incorrect activity entry additional information for \'Add Appointment\' operation for an employee.
    • Fixed ClarifyGeneric bug where multiple traversals against the same MTO relation would select the relation foreign-key field multiple times. This was mostly harmless on SQL Server but caused an exception on Oracle.
  • API Toolkits:
    • Create Case: Add support for multi-level case types in Amdocs 13.
    • Update Case and Subcase Commitment APIs:
      • Commitment due date will now only be updated when the given commitment date does not match what is already in the database.
      • Time bombs for sending email notifications are now correctly created when changing the Commitment due date or the warning interval.

Version 3.3.1

  • Core:
    • Fixed problem populating the SchemaCache on SQL Server systems where ADP tables have indexes.

Version 3.3.0

  • Requirement Change The fcSDK is now built on the .Net 4.0 framework. It is now required that the .Net 4.0 framework is installed.

  • Core:
    • ISchemaField now exposes type divination helpers: IsString, IsDate, IsInteger, IsNumeric.
    • Corrected the id field used for Workflow operations on Workaround objects.
    • Oracle Data Provider for .NET (ODP.NET) support has been added.
    • Fixed a bug leading to incorrect SQL being generated for traversing operations.
    • Fixed a bug in StateManager.LoadState which was causing the session timeout to get updated. Consumers of load state should now call ResetTimeout to up date the state timeout if desired.
    • Added StateManager.IsStateExpired method to better detect expired session states.
    • Remote state managers have been marked obsolete.
  • API Toolkits:
    • Some activity entry additional information fields containing date strings were not being converted to server time.
    • Fixed an Update Site issue where secondary support employee could only be cleared when updating a site by database identifier.
    • Fixed the history headings of Internal Note Logs for cases and subcases.

Version 3.2.9

  • API Toolkits:
    • Added new .Net APIs to allow objids to be used for contact identification.
    • The .Net UpdateContactByObjidSetup has a contactObjid property that can be set for use in the new UpdateContactByObjid API.

Version 3.2.8

  • API Toolkits:
    • FCCL - Updated Fulfill APIs to improve performance when updating part request information.
    • FCCL - Ship API now returns database identifier of the ship_parts record it creates.

Version 3.2.7

  • Core:
    • LocaleCache: Improved handling of daylight savings periods to support periods which span multiple years. For example, in New Zealand, daylight savings starts in September and ends in April.
    • BREAKING API CHANGE to the DaylightSavingsCollection. This collection had a string based indexer by year which has been replaced with the GetPeriod method.
  • Data Verifier:
    • Updated to check for overlapping daylight savings periods.

Version 3.2.6

  • API Toolkits:
    • FCINTER - Updated change_contact API to allowing objids to be used for contact and site identification.
  • Core:
    • DatabaseParameterFactory overload now accepts a schema field object in place of table and field names.
    • ISchemaField now exposes CommonType and helper IsSearchable method.

Version 3.2.5

  • API Toolkits:
    • Added new .Net APIs to allow large internal note and phone logs to cases and subcases. The APIs use a unlimited text field to allow larger internal notes to be recorded. All other capabilities of Not/Phone logs are also available.
    • The .Net ChangeCaseContactSetup object now has a SiteIDNum property that can be set for use in the ChangeCaseContact API.
  • Core:
    • Auto destination now supports db transactions.
    • Fixed a bug so that the proper default element for HGBST list level is returned.
      • If no default element is designated - return an active element with the lowest rank.
      • If no default element is designated and there are no active elements - return an inactive element with the lowest rank.

Version 3.2.4

  • Core:
    • To workaround a bug in how the .Net Oracle client handles decimal values with high precision, we now truncate (via SQL) decimal fields to a precision matching what is specified in the Clarify schema.
    • The result of a DateTime conversion to a timezone with no GMT offset now has DateTime.Kind value set to Utc
    • Resolved a rare configuration issue that could occur during SDK initialization if DBProviderFactory was used before the SDK initialization.
    • API change: To facilitate testing Hgbst and Gbst lists types are now exposed via Interfaces rather than concrete classes.
  • API Toolkits:
    • Added a schema update for a participant table index which on pre Clarify 11 databases is missing a field.
    • Fixed a bug in UpdateSite that would cause the site name to be overwritten with the siteId if the site name input parameter was blank.

Version 3.2.3

  • API Toolkits:

    • A few of our APIs do multiple database updates breaking our convention that APIs should have transactional atomicity. These multi-update APIs are now invoked in a single transaction.

      The following APIs are affected:

      Logistics Toolkit
      • PartTransfer
      • BackorderPartRequest
      • FulfillPartRequest
      • CreatePartRequestDetail
      • ReceivePartRequest
      FieldOps Toolkit
      • PartTransfer
      • LogPartsUsedExchange
      • LogPartsUsedConsume
      • LogPartsUsedInstall
      • LogPartsUsedRemove
      • LogPartsUsedUpgrade

      Note: When calling the overload of these APIs having a transaction argument, as always, the API will use the given transaction.
  • Core:
    • Fixed a bug in ClarifyGeneric where inserting or updating a row on a table who schema has change fields present but no change date field would throw an error.
  • Installer:
    • Symbols for Dovetail SDK assemblies (.pdb files) are now packaged with the installer. Symbol files can be used to provide Dovetail Support with more context about unexpected exceptions when they occur. They are not normally needed and do not have to be deployed with your code but they are good to have around in case of emergency.

Version 3.2.2

  • API Toolkits:
    • Fixed a bug in APIs which increment part request header sequence numbers within a transaction. Sequence incrementation is now enlisted in the current transaction.

      Important: Oracle users should reapply the stored procedures. Part of this fix involves an update to the fc_next_pr_seq stored procedure.

Version 3.2.1

  • Core:
    • Compatibility generic UpdateAll calls are now enlisted in the current session transaction when present. This problem affected some Toolkit APIs.
  • API Toolkits:
    • Fixed a bug in CreateContactLineItem caused by a poorly constrained database query when the serial number argument was blank.
  • Demos:
    • Fixed log4net version details in the web demo application configuration.

Version 3.2.0

  • Developers: We've added Nuget support

    NuGet is a Visual Studio extension that makes it easy to install and update libraries and tools in Visual Studio.

    Dovetail SDK now ships a .nupkg file which you can deploy to your company's local nuget package source. The main idea behind shipping a Nuget package with the installer is to make it easy easy for .Net developers to install and update references to Dovetail SDK .Net assemblies.

  • Core:
    • Fixed a bug on Oracle where contact and user login names were case sensitive. This has been fixed and login names are now case insensitive on Oracle.
    • Legacy support for Sybase has been removed.
    • Logging library log4net has been updated to Yank API so that it creates a participant record for the user from which the workflow object was yanked. This enables for creation of a business rule to notify the user when an object was yanked from them. Note this requires the optional exclusive relation from participant2user be added to your schema.
    • When Creating an Attachment Record the doc_inst record created is now related to the activity entry generated for that attachment activity.
  • Core:
    • ClarifyGenerics have a new property DataRestrictionGroup which now allows generic level control of the data restriction group used. Previously the restiction group was only settable at the ClarifySession level. When a ClarifyGeneric is created it will default to the session's restriction group. There is also a new convenience method on ClarifyGeneric for changing restriction group by name.

Version 3.0.0

  • Requirement Change

    • The Dovetail SDK is now built on the .Net 3.5 framework. It is now a requirement that the .Net 3.5 framework is installed.

  • Dovetail SDK now has 32 bit and 64 bit installers available.

    • The primary reason this is necessary is for applications using COM Compatibility (e.g. Dovetail Agent and Dovetail Admin, and Dovetail SelfService) to have the correct native COM registration settings. Previously, applications that use the COM interfaces were required to run in a 32 bit (SysWow64) mode.

      Customers using Dovetail Agent version 4.4 should use the 32bit installer as attachment uploading in those versions has a dependency on a 32bit COM object requiring them to be run in 32bit mode.

      It is currently possible to install both 32 and 64 bit installers side by side.

      For existing 64 bit SDK users - Migrating from the 32 bit installer to the new 64 bit navtive installer:

      If running command-line applications that use COM Compatibility (such as JavaScript or VBScript using cscript.exe) on a 64 bit machine, they should be executed from the standard 64 bit command prompt. This is a change, as previous versions of the SDK only supported 32 bit COM applications.

      Additionally, contact (web_user) authentication is now supported in 64 bit environments. This is commonly used in SelfService/eSupport applications. The non-managed fc_crypt2.dll library is used for contact password encryption and decryption. The correct version of this library (either 32 or 64 bit) will be installed as part of the Dovetail SDK installation process.

  • API Toolkits:
    • Changed fulfill and receive APIs - when doing partial request processing, new part request detail will default to the status/condition of the original.
    • For partial Receive actions - the new part request detail objid and detail number are now returned in the toolkit result.
    • Fixed a bug in Receive API where the AutoClose was generating an exception when creating the activity log.
    • Fixed documentation for modify_case to have the correct method signature.

Version 2.4.12

  • Installer Fixes:
    • Deploying demo web applications to servers with multiple IIS web sites is now supported.
  • .Net API:
    • Added utilty method to StringCache to find supported locales.
    • Factored user authentication support into ClarifyAuthenticationService. Simplifying non session user authentication.
  • API Toolkits:
    • Added an error check to prevent exception being thrown during a part transfer where the part instance detail could not be found.
  • Core:
    • Corrected a bug in ListCache and LocaleCache detection of objects with bad data.
    • Fixed a bug in conversion of datetimes between timezones. This issue would only occur if either the source or the destination did not participate in daylight savings time, and only if the destination timezone had a greater GMT offset than the source timezone.

Version 2.4.11

  • Workflow:
    • Fixed a regression when finding the next available file name for an attachment.
  • Core:
    • Contact authentication now requires that the contact have active contact and web_user records
    • Added new Generic filter creation overloads for AND and OR filters. These new over loads allow you to give an array of Filters which you need to be ANDed or ORed together. Previously you could only apply AND and OR to two filters at a time.
    • Added better error prevention for LocaleCache and ListCache. This will prevent most cache-releated Application start-up errors.
    • API added for making it easier to generate ClarifyGeneric filters. See the FilterExpression class.
  • Data Verifier:
    • Added grouping for data verifier tests to add context for test categories.
    • Added data verifier test to check for duplicate country-timezone MTM table entries.

Version 2.4.10

  • Core:
    • Interfaces for the LocaleCache and ListCache are now provided to make all caches more testable.
    • Fixed Workflow Move operation so it would work non-transactionally.
  • API Toolkits:
    • FCINTER - Added new update_contact_objid_list API to allow a specific contact to be updated. This allows the correct contact to be updated if duplicate contacts (by name/phone) are allowed.
    • FCCS - Removed the extraneous ", State = Open" from additional info when closing a case.

Version 2.4.9

  • Installer:
    • Dovetail SDK assemblies are now correctly registered with Visual Studio .Net to on 64bit versions of Windows.

Version 2.4.8

  • Data Verifier:
    • Fixed crash when saving test results in the Data Verifier application (only applies to .Net 3.5 environments.)
    • Added data verifier test to check for duplicate view fields.
    • Explicitly setting Data Verifier to build as a 32 bit application so that COM features can be verified in a 64 bit environment.
  • API Toolkits:
    • Fixed the CreateSubcase API: Added transaction support for the GetNextSubcaseNumber - this method was not correctly enlisting the current transaction if available.

Version 2.4.7

  • Core:
    • Fixed an Oracle performance issue with the SQL generated when querying empty strings as NULL (the default behavior.)
    • File caching is now disabled by default. This feature does not significantly boost startup time on modern computers and often causes confusion about cache freshness after schema changes.
    • Creating sessions without a username and password no longer causes failed logins.
    • Fixed another Generic usage scenario related to distinct queries against tables or views ordered by searchable fields.
  • API Toolkits:
    • Fixed an Oracle performance issue with the SQL generated when querying empty strings as NULL (the default behavior.)
    • Fixed the RelateCaseToParentCase API - Now enforcing that a case must be designated as a parent case before a child case can be related to it.
    • Fixed the UpdateCaseCommitment and UpdateSubcaseCommitment APIs - Now enforcing that the specified Commitment must be related to the specified Case/Subcase to be updated.
    • Fixed the ForwardSolution and RejectSolution APIs - The notes field is not appended to the Solution description field.
    • Fixed the Reject<object> APIs - The activity entry for a Reject action now uses the "RETURN" keyword instead of "FORWARD".
    • Fixed the Accept<object> APIs - The performing user must be a member of the specified queue to perform an Accept.
    • Fixed the Workflow APIs - Acting and target users now need to be active in order for workflow operations to be successful. For example only active users can Assign a case to another active user.

Version 2.4.6

  • API Toolkits:
    • Fixed database transaction support for toolkit workflow APIs and the Log Email In API. These APIs were not correctly enlisting workflow operations into the current transaction.
  • Core:
    • Changed the order of how authentication is ordered during application initialization. Dovetail SDK will now attempt to use Clarify encrypted credentials based on the connection string first and then if that fails unencrypted credentials.
    • Fixed an Generic usage scenario which resulted in bad SQL when doing distinct queries against views ordered by searchable fields.
    • Fixed a localization issue that prevented creating Clarify or Compatiblity sessions when the computer or session culture is set to Turkish.
    • Workflow Manager GetNextFileName now truncates the filename to fit within the attachment title field.
    • Fixed a bug related to distinct generic queries being sorted by searchable fields that were not also in the list of data fields selected.

Version 2.4.5

  • API Toolkits:
    • Removed dependency on VisualBasic.Compatibility.

Version 2.4.4

  • API Toolkits:
    • Updating a dialogue or communication whose dialogue is closed is now allowed.

Version 2.4.3

  • API Toolkits:
    • Corrected bugs related to the status and act entries created when using the new Dialogue and Communication APIs.
  • Core:
    • Workflow Manager now creates all related participant records for operations on object types using the fact/participant model.
    • Workflow Manager now supports database transactions.

Version 2.4.2

  • API Toolkits:
    • Added three new .NET InterfacesToolkit APIs. These new APIs are not exposed via COM compatibility.
      • CreateDialogue
      • UpdateDialogue
      • CreateCommunication
      • UpdateCommunication
  • Core:
    • Fixed a bug in the SchemaCache where IsTimeZone would throw an exception if there are duplicate time zones.
    • Updated GetSafeBooleanFieldValue to return False for DBNull.Value
    • Correct problem where on Sql Server generics doing parameterized queries against sql view fields were being typed as text.
  • Compatibility:
    • Security Support Added
      To help avoid SQL Injection attacks we have added support to FCSqlExec for binding parameters (via AddSqlParameter). We recommend that all SQL queries built using user input should executed with FCSqlExec using bind parameters. For more information see the Execute and ExecuteReturnRows for examples.

Version 2.4.1

  • Core:
    • Fixed a bug in the SchemaCache where IsValidField would return true when given a field name that is a many to many relation name. Relation names will still return true if the schema table contains the foreign key for that relation.
    • When APIs are building case history additions that exceed the maximum case history size limit (~32K) will cause the history to be slightly changed in order to trigger the change date field. This change allows for API calls to consistently update the case's last modified timestamp.
    • Updated ClarifyVersion to support schema revisions newer than Clarify 12.5.
    • Added better logging of Session Manager configuration settings.
  • Compatibility:
    • Corrected a bug in FCFO: modify_time_log and modify_expense_log were replacing entire case history with the most recent entry.

Version 2.4.0

In this release we focused on adding support for Amdocs 6 thru Amdocs 7.5.
  • Core:
    • Generics now support inserting records for tables having a guid field. New records created for a type having a guid field present will have a globally unique value assigned to that field.
    • Generics will ignore and not allow manipulation of identity fields. Identity fields are rarely used in the baseline schema and are defined as table fields having a generic field id of 154.
    • Fixed a bug caused by the maximum datetime value being slightly too early. It is now 12/31/4712 11:59:59PM.
  • Toolkits:
    • The create contact API now sets, when present, the contact_id field using the Contact ID numbering scheme.

Version 2.3.20

  • API Toolkits:
    • Updated the Time & Expense APIs to improve the Case History interaction. The notes for the onsite log will be included in the history text when the notes get updated thru a create or update Time or Expense API call.

Version 2.3.19

  • Core:
    • Corrected regression where lookups of missing strings in the StringCache would throw exceptions.
    • Corrected a configuration problem with the Dovetail SDK Web Service and demos web application configuration files. The reference to the Log4Net configuration handler is now fully qualified.
  • Compatibility:
    • Corrected a bug in FCCL: receive_pr and receive_pr_no_trans were backwards in respect to finalizing the transition for the Receive process.
  • API Toolkits:
    • Errors occurring when creating cases and subcases and employees were not getting logged and would be thrown even when the session ThrowErrors property was false.

Version 2.3.18

  • API Toolkits:
    • Corrected a bug in the Before and After Case/Subcase Status relations for an Email Log in LogCaseEmailIn and LogSubCaseEmailIn.
    • Corrected the Case/Subcase history note that gets generated during LogCaseEmailIn and LogSubCaseEmailIn.

Version 2.3.17

  • API Toolkits:
    • Added four new .NET SupportToolkit APIs. These new APIs are not exposed via COM compatibility.
      • LogCaseEmailIn
      • LogSubCaseEmailIn
      • AppendCaseHistory
      • AppendSubCaseHistory

Version 2.3.16

  • API Toolkits:
    • LogPartsUsed APIs now create time bombs in the correct order so that update inventory events occur last.

Version 2.3.15

  • API Toolkits:
    • Added capability in create_time_bomb to specify the escalation time. This will allow APIs to be clear which order the time bombs that get generated should be processed.

Version 2.3.14

  • API Toolkits:
    • Corrected a bug for the UpdatePartRequestDetail API where it did not related the time bomb to the current employee

Version 2.3.13

  • API Toolkits:
    • Corrected a bug for the LogPartsUsedConsume API where it incorrectly related the Consume act_entry to the demand_dtl record - now it correctly relates it to the site
  • General:
    • Oracle Session Manager now checks to see if sessions exist before retiring expired sessions.

Version 2.3.12

  • Core:
    • Corrected a bug for Ms Sql Server unicode databases that was introduced in version 2.3.9 causing NText fields to be treated as non-unicode data.
    • Oracle queries involving large text fields (Long, CLOB) now set the field's data type based on existing fields in the database rather than the version of the database platform.
    • Dovetail SDK performance counters are now disabled by default. The configuration documentation has been updated to reflect this.
  • Compatibility:
    • Corrected an issue where methods that return ADO Recordsets such as FCSqlExec or GetTimezoneList could throw an error when returning unicode data.

Version 2.3.11

  • API Toolkits:
    • FieldOps toolkit LogPartsUsed API - The session user is now related to the part_trans record when no user is specified. Also, the correct timebombs and activity entries for part request details were not always being created.
    • Logistics toolkit CreatePartRequestDetail API - A case modified timebomb is now created when a case id is specified.

Version 2.3.10

  • Core:
    • Fixed issue where AppendFilterInList could generate SQL that was not compatible with the database for large lists.

Version 2.3.9

  • Core:
    • Fixed Oracle issue with inserting or updating more that 4000 bytes to Clob fields.

Version 2.3.8

  • General:
    • Fixed problem with how additional fields to some API calls were being processed.
    • Error messages for exceptions thrown by Dovetail SDK were not being retrieved properly. Error messages not found in the StringCache are now retrieved from the \'ErrorStrings\' resource in the thrown exception's assembly.
    • Fixed a problem with the installer where it was adding incorrect database connection settings on configuration files without existing settings.

Version 2.3.7

  • General:
    • A dependency issue was fixed with the License Installer.

Version 2.3.6

  • Core:
    • The fchoice.clarify.ignoredatetimemilliseconds configuration setting was not being honored for change date fields and for normal DateTime fields when the ConvertTimeZone session property was false.
  • Compatibility:
    • Fixed problem with GetHgbstList failing for list elements having titles with leading or trailing spaces.

Version 2.3.5

  • Core:
    • Clarify SQL Views were not being added to the Schema Cache.
    • The Schema Cache failed to load integer and double fields when they contained NULL values. They now default to zero when a NULL is in the database.

Version 2.3.4

  • API Toolkits : The following bugs have been fixed:
    • FCFO - The activity logs created by log_parts_used are now consistent with the Clarify client.
  • Core:
    • The installer was not adding the fcSDK bin directory to the system path. Classic asp web applications require that fc_crypt2.dll be in the path.
    • 2.3.3 introduced a bug in the ListCache for Global Application Lists causing elements with duplicate titles to be excluded from the cache.

Version 2.3.3

  • API Toolkits : The following bugs have been fixed:
    • FCFO - create_onsite_log was validating the resolution against the wrong resolution list.
    • FCFO - modify_expense_log was not properly updating the onsite_log if the expense rate was changed from non-zero to zero.
    • FCFO - modify_expense_log could throw an error: exp_type is not a valid field.
    • FCFO - modify_expense_log was not properly updating the onsite_log if the billable flag was changed.
    • FCFO - modify_time_log was not properly updating the onsite_log if the duration was changed from non-zero to zero.
    • FCFO - modify_time_log was not properly updating the onsite_log if the billable flag was changed.
    • FCFO - log_parts_used was not properly updating existing non serialized site parts. It had been creating additional site part records.
    • FCFO - log_parts_used consume no longer updates the site config.
    • FCFO - log_parts_used consume now moves the inventory part into the Service COGS expense GL location rather than the Part Used Variance expense GL location.
    • FCFO - log_parts_used could throw a null reference exception when setting the from location and that site configuration was not being updated.
  • Core:
    • ClarifyApplication initialization no longer fails when Hierarchical Lists, and Restriction Groups have entries with duplicate names. A warning is now logged when the duplicate item is encountered during initialization.

Version 2.3.2

  • API Toolkits:
    • FCFO - The LogPartsUsed methods weren't properly setting the hdr_ind column on the part_inst record when the quantity of quantity-tracked parts was negative. It now correctly sets the hdr_ind to 2 if the quantity is negative, and to 3 if the good and bad quantity are both zero.
  • Compatibility:
    • FCSession.LoginTime had a bug that could cause a Stack Overflow error. This has been fixed.

Version 2.3.1

  • Requirement Change The fcSDK is now built on the .Net 2.0 framework. It is now required that the .Net 2.0 framework is installed.

  • Assembly Structure Change The assemblies related to COM compatibility and the API Toolkits have been moved into their own assemblies. This change will not affect COM users. If you are using the FChoice.Toolkits.Clarify namespace your projects will need a reference to FChoice.Toolkits.Clarify.dll.

  • API Toolkits:
    • FCFO - The LogPartsUsed methods were not creating the proper activity logs when an inventory transaction occurred. It was creating an activity entry of \'Transfer\'. It now correctly creates an activity entry of \'Update Inventory\'.
    • FCFO - LogPartsUsedRemove now allows specifying a RemoveQuantity.
    • FCFO - The LogPartsUsed methods have been modified so as to allow the quantity of an inventory location to go negative.
    • FCCL - A bug was fixed in UpdatePartRequestDetail. Previously, if a user didn't specify a value of an optional parameter, the value was over-written. This has been fixed.
    • FCFO - LogPartsUsed was not properly relating the part_used and part_trans records. This has been fixed.
    • FCFO - LogPartsUsed was not properly updating the PartRequestDetail condition. This has been fixed.
    • FCCL - The Receive and Fulfill methods were creating an extra activity entry and time bomb. This has been fixed.
  • Compatibility:
    • Methods that return an ADO recordset (such as GetTimeZoneList) could throw an error if a custom column had been added to the table with a datatype of Guid or byte array. These datatypes are now handled properly.
  • Core:
    • ClarifyApplication can now be removed from the AppDomain using DeInitialize

Version 2.2.6

  • API Toolkits:
    • FCCL, FCFO - An unnecessary potentially lengthy query was removed from PartTransfer.
    • FCFO - LogPartsUsedRemoveSetup property InstallAtSite has no effect and has been marked obsolete.
    • FCFO and FCCL APIS that performed a part transfer: Fulfill, PartTransfer, Receive, LogPartsUsed - could have exceptions that did not bubble up to the caller.
    • FCFO - LogPartsUsed was not always querying for the "From Inventory Location" which could cause a null reference exception.
  • Compatibility:
    • FCApplication: Added GetLocalizedGbstElmById and GetLocalizedGbstDefault methods.

Version 2.2.5

  • API Toolkits:
    • Fixed bug involving improperly formatted datetimes when using the AdditionalFields property in Toolkit APIs. The FCSession's CurrentCulture is now used to properly format the datetime.
    • FCCL - FullfillPartRequest result now includes the objid and id_number of the PartRequestDetail created when a partial fulfill occurs.

Version 2.2.4

  • API Toolkits:
    • FCINTER and FCCL - Creating and updating contacts and modifying a part request detail now output timebomb information for Rulemanager to use.

Version 2.2.3

  • Core:
    • SqlHelper - Corrected bug in batching mechanism for INLIST queries.
  • General:
    • The fcSDK installer now requires that .Net 1.1 Service Pack 1 be present. This is due to a breaking change in .Net 2.0 that affects Performance Counter support. Please see this solution for more details.

Version 2.2.2

  • Core:
    • Fixed a bug when using FCGeneric.NOW_DATE that would use the application host DateTime rather than the database's. This problem would only exibit when Application Host and Database server timezones were different.
    • Fixed issue with an Sql Server 7 when grace license events occurred.
  • API Toolkits:
    • FCSFA and FCCC - Create Contract Line Item : Two validations have been eliminated for Clarify compatibilty. It is now allowed to create Contract Line Items for tracked non serial numbered parts (Error code -11) and serial numbered parts with quantity greater than 1 (Error code -12).

Version 2.2.1

  • Core:
    • FCGeneric.CloseGenerics() now correctly clears data from the generic's DataTable.
    • Fixed a multithreaded locking issue during StateManager initialization.
    • Loading of the SchemaCache could fail in rare situations due to non unique keys for schema view information objects.
    • Fixed bug where Workflow's Yank operation would create the wrong kind of time_bomb object.
  • Compatibilty:
    • FCSession.CloseAllGenerics() had a bug preventing it from working correctly.

Version 2.2

  • Core

    • BREAKING API CHANGE (.NET APIs only, Compatibility unaffected): FCGeneric.Filter has been renamed to FCGeneric.RawFilter. This was done to make room for the new Query Filtering mechansim.

    • There is a new Query Filtering mechanism in place that allows for more complex filters against Generic objects. Please take a look at the (walkthroughs/filtering.html">Developer Walkthrough - Advanced Filtering for more information.

    • New optional fchoice.clarify.ignoredatetimemilliseconds configration setting added to better support compatiblity with older versions of Clarify Classic Client.

    • Fixed login bug where an Employee's last_login was being incorrectly updated during a Contact login of the same login_name.
    • On MSSQL ClarifySession.SetPassword() no longer requires that the application user have sysadmin rights.

    • BREAKING API CHANGE (.NET APIs only, Compatibility unaffected): The string/name overloads (as opposed to the ID overloads) of the GetFCString method on StringCache now require another parameter: applicationName since application name is a required parameter to generate unique name identifiers for individual FC Strings. The lack of an applicationName argument was an oversight in previous versions of the fcSDK.

      IMPORTANT NOTE FOR CUSTOMERS USING CUSTOMIZED fcSDK ERROR MESSAGES:

      Any existing strings that were imported via the fcerrors.dat and/or customized will have to be updated to have a proper application name. The default application name for all errors in the fcSDK is "fcSDK". If you wish to have multiple customized error messages for multiple instances of the fcSDK, you can override the application name using the _fchoice.fcstringappnameforerrors_ configuration setting. For more information, see the Basic Configuration Guide.

  • Auto Destination
    • Rules with the <> operator were not being parsed properly.
    • Stricter validation is now present for badly formed Rule Clauses.
  • Compatibility
    • Fixed the interaction between FCGeneric.Delete() and cursor movement methods (MoveNext, EOF).
    • FCApplication.InitializeFull() was not utilizing settings contained in fc.env. Configuration settings from the fc.env file are now pulled in but database authentication settings like fchoice.dbtype and fchoice.connectionstring are ignored.
  • API Toolkits
    • All Toolkit setup objects that require a User session now have a UserName property which if present is required when the ClarifySession's login type is Contact.
    • Fixed datetime localization issues when APIs are invoked using non-US cultures.

Version 2.1.3

  • Compatibilty: Fixed Compatibility issues when GetHgbst methods return no elements.

Version 2.1.2

  • Core
    • Licensing is now more strictly enforced for Session lifetime.
    • Improved performance for parameterized queries against non-unicode string fields, allowing the database to optimize the query.
  • Auto Destination
    • Fixed bug with AUTO_DISPATCH not being handled properly.
    • Fixed bug with line returns in rule clauses causing rules to fail.
    • BREAKING API CHANGE (.NET APIs only, Compatibility unaffected): Classes: Path2Sql and AutoDestRuleClause have been marked internal.
  • Upgrading from fcSDK 2.1.1 and earlier:
    If your implementation of fcSDK is using the Data Restriction feature, it is recommended to update your schema. The following change will allow the Data Restriction feature to benefit from improved performance.
    1. Add the \'fld_name\' field to table res_sql_clause. Refer to the {install dir}\schema\fcSDK_schema.sch file for the exact field definition.
    2. Populate \'fld_name\' with the name of the field being restricted in the data restriction's \'clause\' data field.
      For example, if your clause entry is 'x_res1 = |restriction1|' you would populate the fld_name data field with 'x_res1'.

Version 2.1.1

  • Core
    • Fixed a bug in the GetAttachmentFilePath method on WorkflowManager that resulted in a non-unique file name being returned.
    • Fixed ClarifySession timeout bug causing the default (Memory) session state manager to timeout sessions even if they were being retrieved.
  • Compatiblity
    • The installer was missing the COM ADO Primary Interop Assembly. It is now installed to the GAC.

Version 2.1

  • Caches
    • Streamlined loading of cache data, reduced memory footprint during lifetime of fcSDK based applications.
    • Added better support to ListCache for retrieving active or inactive list items.
    • Renamed the throwErrors variant of ListCache.GetHgbstList to ListCache.TryGetHgbstList
    • BREAKING API CHANGE (.NET APIs only, Compatibility unaffected): The signature of ListCache.GetHgbstList() has changed.
    • Added optional support for localized GBST and HGBST (custom and user-defined pop-up) lists. Note that new schema changes are necessary to use this feature. Please see the install guide for more information.
  • Core
    • Refactored handling of text data to be more CPU and memory efficient as well as culturally-aware for internationalization purposes.
    • FCSession performance counters were not decrementing properly.
    • Large Query count threshold (fchoice.sqlbigquerycountthreshold) was only working if with the time threshold was set (fchoice.sqlbigquerytimethreshold).
    • A short-term session leak was happening when using the fcSDK .NET interfaces (Compatibility was not affected) and an exception was thrown during login.
    • Implemented the IDisposable pattern for ClarifySession and FCSession. This makes it easier to manage the lifetime of short-term and/or one-off sessions.
    • Fixed a bug when using a user with an encrypted password (such as a Clarify \'employee\' user) as the application user for the fcSDK (the one that appears in the fchoice.connectionstring parameter) which caused an exception to appear in the log incorrectly saying the login failed.
    • BREAKING API CHANGE (.NET APIs only, Compatibility unaffected): The SetPassword method on ClarifySession is now static (Shared in Visual Basic).
    • Added new functionality to the WorkflowManager (in the FChoice.Foundation.Clarify.Workflow namespace):
      • New Method: CreateActivityLogEntry - Assists in creating an activity log entry for a particular object.
      • New Method: CreateCasePhoneLogActivityLogEntry - Assists in creating the special phone_log entry when logging phone notes to a case.
      • New Method: CreateAttachmentRecord - Creates doc_inst and doc_path records for file attachments on various objects.
      • New Method: GetAttachmentFilePath - Generates a unique file name according to a configurable pathing scheme for storing of file attachments.
      • New Method: GetNextFileName - Generates a unique file name given a folder path and a base file name.
  • Compatibility
    • FCSession Item collection now allows adding or updating items in the collection via COM.
    • Toolkits: Fixed issue with many non-list Compatibility Toolkit methods not handling additional fields.
    • Fixed issue with generics that are setup via FCGeneric.TraverseFromParent not being properly added to the parent Generic's bulk. generic.Bulk.UpdateAll() operations were not working correctly for this scenario.
    • Fixed issue with FCGeneric.Delete for generics involved in a Traversal. The row Position was not being set correctly after the Delete operation.
    • New method LogEx added to FCSession and FCApplication to allow access to different log levels in FCFL.NET.
    • List Cache methods now have improved Compatibility with FCFL for error handling.
    • create_act_entry and AddAttachment on FCSession now use the new methods on WorkflowManager (see above).
  • General
    • Installer updated, integrating demos and allowing administrators better control over the install process.
    • DataVerifier: Added a new HGBST test to determine whether there are any elements that reference more than two shows.
    • The FChoice.Common, fcSDK, and log4net assemblies are now registered into the Global Assembly Cache (GAC) during install. These assemblies will appear in the \'Add Reference\' dialog in Visual Studio.NET.
    • License Installer: Fixed crash when the Database login failed.
  • Web Services
    • The Web Services server application, client libraries, and demos are now included as part of this package.

Version 2.0

Special:

  • FCFL.NET is no longer a separate product. It has been grouped together with new .NET-based API Toolkits to form the new fcSDK product.

Fixes and Additions:

  • Core fcSDK:
    • ClarifyGeneric.AppendFilter overload added for filtering integer fields known to be booleans.
    • WorkflowManager.ChangeStatus now supports the Open-Reject status for Part Requests.
    • The DataFields property on ClarifyGeneric no longer has any effect during an Update operation. DataFields will only constrain Query operations. It is still the case, however, that only fields whose values have changed will be included in the UPDATE statement to the database to increase performance of update statements.
    • Data: SqlHelper now catches exceptions thrown by the database client and ensures that they are logged (which used to not happen in all cases when FCFL.NET was used through the Compatibility layer). Also, error information will appear in the query summary to allow log filtering.
    • BREAKING API CHANGE (.NET APIs only, Compatibility unaffected): The concept of a bulk has been completely removed from the .NET core APIs (FChoice.Foundation and FChoice.Foundation.Clarify). The compatibility layer (FChoice.Foundation.Clarify.Compatibility, or FCFLCompat.dll) is unaffected and will still behave like normal. Existing applications written to the COM layer WILL NOT be affected by this change. In order to work with ClarifyGeneric, you must first create a new ClarifyDataSet object. The CreateGeneric method has been moved from ClarifySession to ClarifyDataSet.
      For more information on how to make the move from using ClarifyBulk and ClarifySession.CreateGeneric to ClarifyDataSet, please see the updated (walkthroughs/fcfl-net-objects.html">FCFL.NET Developer Walkthrough of fundamental objects in FCFL.NET as well as the API documentation for the ClarifyDataSet object.
    • LogManager was not handling invalid configurations well. A stack overflow would occur when attempting to alert the user about the bad configuration.
    • On Oracle 8.0.x and earlier databases, strings with non ascii or extended ascii charcters non ASCII strings would cause garbage data to be inserted into the database. This setting effectively disables Unicode support for Oracle 8.0.x or earlier databases. Non-ASCII charcters are converted to question marks (?). There is an application configuration setting fchoice.oracle.forceascii7bit to control this behavior.
    • Multiline text fields do not always display properly in the Clarify windows client if there are carriage returns present. CRLF is now converted to LF. An application config setting < href="/articles/basic-configuration.html">fchoice.clarify.convertcarriagereturns was added to control this behavior.
  • Compatibility
    • FCBulk
      • FCGeneric.CloseGeneric was putting generics into the DefaultBulk causing scenarios where if the DefaultBulk was then queried, long running queries could result. Now, after CloseGeneric() is called the generic does not belong to a Bulk and should subsequently not be used.
      • FCSession.create_act_entry now ensures that the act_entry generic and the generic of the related object are in the same bulk.
      • FCBulk.Update would not always relate records correctly.
    • FCGeneric.DBObjectName
      Note: for best performance do not use FCGeneric.DBObjectName to set a Generic's object name. Pass the object name to CreateGeneric().
      • When using FCGeneric.DBObjectName to set the object name of an FCGeneric compatibility object, not recommended, the bulk membership of that Generic wasn't getting set up properly. The Generic would not get queried or updated during bulk.UpdateAll or Query operations.
      • Better compatibility when using FCGeneric.DBObjectName with a previously used Generic.
    • FCGeneric's RowLimit and MaxRecords properties
      • Compatibility FCGeneric.RowLimit was not working properly (throwing errors when there should not be any error) against Oracle 7 and Oracle 8.0.x databases.
      • Compatibility FCGeneric.MaxRecords is not supported on Oracle 7 and 8.0.x databases. Setting this property will not throw an error. A warning will be logged to the log file and the query will proceed as normal, returning all possible rows.
      • Please see the System Requirements page and the updated documentation for the FCGeneric compatibility class for more information on the MaxRecords issue.
    • For FC.env files, application configuration settings will now override classic FC.env database parameters. The Configuration Changes document discusses this feature.
    • GetState and GetCountry methods were not throwing exceptions for invalid states or countries.
  • AutoDestination
    • Rules with trailing whitespace could fail.
  • DataVerifier
    • The Daylight Hour verifier now properly checks for duplicate time zones.
    • Added a new test to check for HGBST (User defined) lists which are not related properly to child shows/elements
    • The Login form now respects the fact that the Database Name is not required for Oracle databases.
    • Added better logging in general, and better trapping of unexpected errors thrown by the FCFL.NET and Compatibility verifiers
    • Stored procedure requirements are no longer checked on Oracle pre-9 to match the requirements specified in the fcSDK documentation.

Logging:

  • Logging library (log4net) version updated to 1.2.9.
  • The logging samples were updated to remove the c-style escape sequences (such as \t and \\) as they are no longer necessary.

Installation:

  • Web and Windows Forms demos were missing required assemblies.
  • Sql Server Stored procedures were missing proper permission granting statements.

Version 1.2.1

Fixes and Additions:

  • Core FCFL.NET:

    • IMPORTANT CHANGE: ObjID and Numbering Scheme value generation is now handled by two new custom First Choice stored procedures (fc_new_oid and fc_next_num_scheme). This makes objid and num_scheme generation consistent across all Clarify™ versions on all database platforms (except pre-9 Clarify™ instances running on Oracle™, see note below). These stored procedures are now a requirement of installation for fcSDK. fcSDK will not operate properly without these stored procedures loaded into the database (all objid and num_scheme generation will fail).

      PLEASE REVIEW THE INSTALLATION GUIDE BEFORE INSTALLING THIS VERSION. The install guide has been updated to reflect this and other new changes.

      NOTE: The fc_new_oid stored procedure is not required for versions of Clarify™ before 9 on Oracle™ databases.

    • BREAKING API CHANGE (.NET APIs only, Compatibility unaffected): CacheManager.UpdateDataCache() and CacheManager.UpdateSchemaCache() have been replaced by CacheManager.UpdateCaches(CacheType). CacheType is a new enum with the following values: Data, Schema, All. If you wish to update a group of caches, call UpdateCache( CacheType.Data ) for example.
    • BREAKING API CHANGE (.NET APIs only, Compatibility unaffected): Custom caches (subclasses of CacheBase) no longer have an IsSchemaCache property. It has been replaced by a CacheType property which returns a CacheType enum value signifying which type of cache is it.
    • BREAKING API CHANGE (.NET APIs only, Compatibility unaffected): Oracle 7 support for the ClarifyGeneric.MaximumRows property has been limited to throwing an exception when the maximum number of rows in a query result is exceeded. All other supported databases automatically constrain the query to the MaximumRows limit. Please see the SDK documentation for more details.
    • Fixed a race condition bug in GetNextNumScheme that occurred under very high stress conditions.
    • GenericDataRow:Unrelate() : Fixed bug causing Unrelate to fail for Mandatory relations.
    • ClarifyBulk.Remove() was not setting the generic's bulk to the session default bulk.
    • Hierarchical Lists: Default elements for a list level could possibly be set to an InActive element if no Default element was present. Now, when no Default element is present the first Active element will be selected.
    • ClarifyGeneric.AppendFilter() Fixed scenarios where AppendFilter would not work properly in concert with Filter property.
    • FCGeneric and ClarifyGeneric weren't tolerating nullable database date fields. Calls to Fields-Get and Duplicate would throw an error if one of the date fields was DBNull.
    • Fixed a bug that caused unnecessary error statements to be logged when there were rows in the fc_string table with an empty string or null in the \'name\' column.
  • Compatibility
    • Setting FCGeneric fields was not handling coercion of strings to non-integers types containing number formatting.
      For example setting strings like: "$1.23", "$2,032.41" to a decimal generic field now works.
    • FCApplication.is_it_date_field did not process fields on views correctly. It now supports fields on views.
    • Fixed an error related to setting the BulkName of a FCGeneric before calling TraverseFromRoot.
    • error_handler will no longer invert the error_num parameter if the message starts with "WARNING"
    • Session Portability: It is now possible to call ClarifyApplication.GetSession( sessionID ) with a session Id that was created via Compatibility.
  • AutoDestination
    • Fixed a bug with rules containing dates in constraints.
    • SQL statements generated to resolve paths now uses parameter bindings for better performance.
  • Performance Counters
    • Performance counter functionality can now be disabled for individual applications. See the Basic Configuration guide for more information.
    • Installer now prompts to set required performance counter permissions for all operating systems.
  • Data Verifier now supports Oracle 7 and 8.0 databases.
  • Data: SqlHelper now logs whether a query is considered "large" to allow filtering of large and small queries. Please see the new logging config sample documentation which shows how to redirect logging output for large queries.

Installation:

  • The Installation Guide is no longer present as a PDF. It is now embedded in the API Documentation.

Version 1.2

Fixes and Additions:

  • Windows Demo Installer:
    • Fixed the missing FChoice.Common.dll for the Console Demo.
    • Added shortcuts to demo executables and the URL of the web demo.
  • AutoDestination:
    • MTM and OTM relation traversals are now fully supported. Where clauses can be appended to relation path items to constrain related rows. Example:
      contract2site(name starts with "Joe"):cust_loc2act_entry(act_code = 8100):act_entry2user:login_name = "sa" -> "Email";
    • Much work has been done to make the parsing of rules more robust.
    • Multiword rule operators were not being parsed correctly. (starts with, ends with, earlier than, later than)
  • Compatibility:
    • FCSession.use_list Fixed support for setting date fields to -999 or "-999" to represent the current date.
    • FCApplication was requiring the db_name parameter in the FC.ENV even for Oracle. Added a property to DbProvider called "RequiresDbNameParameter" to allow utilities and FCFL.NET to determine whether a given provider (i.e. Oracle) needs the db_name parameter or not.
  • Logging :
    • LogManager now looks for the log config file in the AppDomain's BaseDirectory. Previously it was looking in the current working directory.
    • Added more verbose logging to SqlHelper.Execute<x> methods.
  • Oracle : SchemaCache's schema queries for View Join Info records uses a CASE statement which isn't supported in Oracle 8.0.x or earlier this was thought to be only an Oracle 7 issue.
  • Schema: Support for data type \'6\' was missing (char array)
  • Foundation: ConfigItems in the database containing non-standard values for the data type would fail. Added a new ConfigItemValueType enumeration \'Unknown\' to represent these types and expose access to their value via the ConfigItem.ValueTypeRaw property.

Version 1.1

Fixes:

  • ClarifyGeneric.Update() of tables with change date fields in a certain order could throw an exception.
  • Navigation of related rows was not possible when traversing OTM relations from a parent generic to a child generic of the same table.
  • Users with encrypted passwords can now be used as the application user.
  • Some default error messages were not being loaded properly.
  • SchemaCache.IsIntegerField did not properly handle invalid fields on views (an proper exception was thrown, but with an incorrect error message).
  • Data Restriction fixes.
  • Compatibility : Incorrect datatype values returned by MockAdoField.DataType for Date and TinyInt types.
  • Compatiblity: MockAdoField now supports -999 or "-999" when setting a datetime field to be the current time.
  • Compatiblity: build_lists was not checking for null or empty field parameters.
  • Auto Destination had an issue with multiple rule clauses having bad SQL queries
  • Installer: corrected installer issues and added uninstall shortcuts.

Version 1.0

Initial Release


System Requirements - fcSDK | fcSDK Documentation

System Requirements - fcSDK

For the latest information on requirements, refer to the Dovetail Software Platform Guide.

fcSDK Environment Requirements

This version of fcSDK requires the following prerequisites:

  • Operating System:
    • Microsoft Windows 7
    • Microsoft Windows 8
    • Microsoft Windows 10
    • Microsoft Windows Server 2008, 2008 R2, 2012, 2016, 2022
    • Both 32 and 64 bit versions of Dovetail SDK are available.
  • Microsoft .NET Framework 4.5.x
    • Install through Windows Update
    • Or Download from: Microsoft
  • Hardware
    • Intel Pentium II (or compatible) 400MHz or faster
    • 1 GB RAM or higher
    • 30MB (estimate) free hard disk space or more

Database

  • Microsoft SQL Server versions 2005, 2008, 2012, 2014 -OR-
  • Oracle Database Server versions 9i, 10g, 11g, 12c, 19c ([1])

Clarify/Amdocs System Environment

  • Clarify 7 through Clarify 12.x
  • Amdocs 6.x
  • Amdocs 7.x

[1] - Setting the MaxRecords property on the Compatibility FCGeneric object is not supported on Oracle 7.x and Oracle 8.0.x. For more details, please see the FCGeneric Changes in the Compatibility Guide.


Product Support - fcSDK | fcSDK Documentation

Product Support - fcSDK

Product Support Options

Self Service Product Support

Customers can submit support requests through our SelfService support web site.

Product Feedback

fcSDK Product Feeback

Dovetail Software wants to ensure that the fcSDK technologies and documentation enable you to build great applications. Your feedback is extremely valuable. Please send your comments and suggestions.

Documentation Feedback

To provide feedback about the documentation, send email to support@dovetailsoftware.com. Each page of the fcSDK documentation contains a link to this email address with context-specific information so that we can see which particular section of the documentation is being referenced. Please use these links to refer to a specific documentation issue if possible.


About Dovetail Software | fcSDK Documentation

About Dovetail Software

Dovetail Software (formerly First Choice Software, Inc.) is the premier supplier of add-on software and customizations to the Clarify Front Office suite. Founded in 1995, Dovetail Software is the first and only company to focus on writing applications to enhance the value of your Clarify investment. You can see our extensive product line on our website: www.dovetailsoftware.com.

Clarify/Amdocs

Dovetail Software develops and supplies software and customizations to the following Clarify products:

  • ClearSupport
  • ClearHelpDesk
  • Policies and Customers
  • Product Manager
  • ClearLogistics
  • ClearQuality
  • ClearContracts
  • ClearSales
  • ClearCallCenter

Many Dovetail Software products use the following Clarify tools:

  • User Interface Editor
  • Data Dictionary Editor
  • Data Exchange
  • Rule Manager
  • ClearBasic
  • ClearBasic Exchange
  • ClearBasic Batch
  • Clarify Business Objects
  • eBusiness Framework
  • Clarify Low-Level API©

Clarify, its product names, and tools are trademarks of Amdocs. Amdocs' trademarks may include the following:

  • ClearConfigurator
  • ClearConfigurator Workshop
  • eSupport
  • eOrder
  • eResponse Manager
  • e.link
  • Flexible Deployment
  • SalesBasic
  • Notifier
  • Classification Engine
  • Routing Server
  • ClearEnterprise Traveler
  • Diagnosis Engine

log4net

This Dovetail Software product references the log4net assembly. Log4net is part of the Apache Logging Services project. More information about log4net can be found on the log4net Project Home Page.

log4net is Copyright © 1999 The Apache Software Foundation. All rights reserved.


Overview of the fcSDK Utilities | fcSDK Documentation

Overview of the fcSDK Utilities

fcSDK Utilities Overview

The fcSDK ships with a few different utility programs to assist you in configurating your fcSDK installation:

  • License Installer - Installs First Choice license key(s) into the database.
  • Data Verifier - Verifies the integrity of certain data in the database.
  • Configuration Protector - Encrypts configuration parameters, such as login name and password.
  • Configuration Editor - An editor for an application XML configuration file.


Overview of the fcSDK License Installer | fcSDK Documentation

Overview of the fcSDK License Installer

The fcSDK License Installer

The fcSDK ships with a License Installer program that will install license key(s) into your database.

License keys are provided to you from Dovetail Software, typically via email.

Before running the license installer, make sure you have added the fc_licensing and fc_licensegrace tables to your database.

To install a license key:

  • Start the License Installer application
  • Fill in the login parameters and click the Login button
    verifier
  • Click the Install New License(s) button
    verifier
  • Either browse to a First Choice License File on your system -OR-
  • Paste the license key into the text box
    verifier
  • Click the Install button
  • Your new license is now installed


Overview of the fcSDK Data Verifier | fcSDK Documentation

Overview of the fcSDK Data Verifier

The fcSDK Data Verifier

The fcSDK ships with a Data Verifier program that will validate the integrity of certain data in the database.

In order to prevent unexpected errors when using the fcSDK, it is best to verify the integrity of your data using the Data Verifier.

If any issues are found, it is recommended that you correct them before trying to use an fcSDK based application.

Data Verifier:

  • Verifies that the licensing schema is loaded in the database and that at least one license is present in the table
  • Verifies that FCFL.NET can be initialized, create a new session, and log in
  • Verifies that FCFL.NET can create a new generic and query data
  • Tests to check to make sure no GBST or HGBST elements are orphaned from their lists
  • Tests to make sure all HGBST elements have unique titles among their respective list levels
  • Verifies that all table and view fields are properly related to a table or view
    (EXC: Union Views have fields that are not related to tables or views. These are not reported as errors.)
  • Verifies that all relations are properly related to a table
  • Tests to make sure all states/provinces are not orphaned from their countries
  • Tests to check to make sure all countries are pointed to valid time zones
  • And more!

To run the Data Verifier:

  • Start the Data Verifier application
  • Fill in the login parameters and click the Connect button
    login
  • Click the Start button
    verifier
  • If any tests return an error, double-click the test for more details
    error
    error2
  • If any issues are found, it is recommended that you correct them before trying to use an fcSDK based application


Configuring fcSDK | fcSDK Documentation

Configuring fcSDK

Basic fcSDK Configuration

Application Configuration Settings

What is a .config file?

It is standard in .Net applications to use an application configuration file to provide a flexible and standardized location for configuration settings.

  • Web Applications - there will be a web.config file present in the root directory of your web application.
  • .exe - If your application is called MyApp.exe the configuration file would be called MyApp.exe.config

Configuring the fcSDK

Most of the configurable options for fcSDK are specified in the <appSettings> section of the config file. This is a simple key/value pair configuration section.

There is only one required but several optional appSettings keys that fcSDK can take advantage of.

At its most basic, your config file should look like:

<?xml version="1.0" encoding="utf-8" ?>
<configuration>
    <appSettings>
        <add
            key="fchoice.connectionstring"
            value="Data Source=server;Initial Catalog=database;uid=user;pwd=pass;" />
    </appSettings>
</configuration>

Compatibility Configuration

All application configuration settings can also be used when using fcSDK Compatibility which classically uses an fc.env file for configuration.

;begin fc.env file...
fchoice.connectionstring=Data Source=server;Initial Catalog=database;uid=user;pwd=pass;

fcSDK Configuration Keys

Key | Required | Default | Description
fchoice.cachefilepath | No | ".\fc_cache" | A full or relative file path which specifies the folder into which fcSDK should save it's cache files (if nocachefile is set to "false", otherwise this value is ignored). If the folder does not exist, it will be created. NOTE: The user under which the application is running must have the appropriate permissions to create and modify files in this folder and, if necessary, create the folder itself.
fchoice.connectionstring | Yes | N/A | An ADO.NET connection string to use with the specified DB type (or default if none is specified). The default provider is MSSQL and the connection string must be useable by the System.Data.SqlClient.SqlConnection class. Consult the SqlConnection.ConnectionString property documentation for specifics about what parameters are allowed in the connnection string. Please consult the documentation for other ADO.NET providers if you plan on using a different data provider type (e.g. Sybase).
fchoice.dbtype | No | "MSSQL" | Specifies the type of provider ClarifyApplication should to connect to the DB. Standard values are "MSSQL", "ORACLE", or "ODPNET".
fchoice.disableloginfromfcapp | No | "true" | Specifies whether ClarifySession should allow sessions to be created without a username or password (similar to LoginFromFCApp in FCFL/COM). If this value is default, a call to create a session without any parameters will result in an exception being thrown. Administrators must knowingly enable this functionality after understanding the consequences of this action.
fchoice.enablebatch | No | "true" | Determines whether the current DB provider (specified by 'fchoice.dbtype' above) should batch SQL statements. This parameter is ignored if the provider cannot batch SQL statments in the first place (like Oracle, for example). NOTE: It is not recommended that this setting be changed unless you're having a specific problem with batching.
fchoice.logconfigfile | No | (not specified) | Specifies an external configuration file that LogManager should use to configure logging for this application. The config file will be monitored and changes to it will be reflected immediately in logging output of the application. See Application Logging in the fcSDK for more information on how to configure logging for fcSDK.
fchoice.nocachefile | No | "true" | Determines whether fcSDK creates cache files on disk after ClarifyApplication is initialized. If set to "true", the cache will be reloaded from the database every time the app is run or the web server restarted. Loading the cache from files is significantly faster than reloading from the database every app startup, however it needs to be manually updated after schema changes.
fchoice.perfcountersenabled | No | "false" | Allows disabling of performance counter functionality. If set to false First Choice applications will not interact with Windows performance monitoring capabilitites. Note: Please see the install guide for more information about security settings required for Performance Counters.
fchoice.perfmoninstancename | No | processname-processid | Specifies the name of the Performance Monitor instance to use when logging performance counters. This value shows up in Performance Monitor when adding counters under the "Instance" list. By default it is the name of the process (myapp.exe) followed by a hypen then the process id: myapp.exe-8124.
fchoice.sessionpasswordrequired | No | "true" | Specifies whether ClarifySession will allow passwordless logins. By default passwords are required and if a new ClarifySession is created without a password specified, an exception will be thrown. This setting is set default for security reasons. Administrators must knowingly enable it after understanding the consequences of this action.
fchoice.fcstringappnameforerrors | No | "fcSDK" | Specifies the application name to use when loading customized/localized error messages from the FC String table (table_fc_string).
fchoice.sqlbigquerytimethreshold | No | 0.0 | Specifies the minimum time (in seconds and fractions of seconds) a query must take before being considered a "Large Query". Large queries will be marked as such in the log file ("Large Query: True"). This allows filters to be placed on the log appender to log large query details to a separate appender. For more information on configuring logging to catch large queries, please see the largesql_log.config example documentation.
fchoice.sqlbigquerycountthreshold | No | 0 | Specifies the minimum number of records a query must return before being considered a "Large Query". Large queries will be marked as such in the log file ("Large Query: True"). This allows filters to be placed on the log appender to log large query details to a separate appender. For more information on configuring logging to catch large queries, please see the largesql_log.config example documentation.
fchoice.setstringparameterdbtypeandsize | No | "true" | Allows disabling of the type and size of SQL parameter being set by SDK. If set to "false", type and size of SQL parameter will be set by database driver. Note: This parameter is intended to allow the database driver defaults to be used in case of compatibility problems with older versions of database systems.
fchoice.statemanager.configurationfile | No | N/A | Specifies an alternative xml configuration file for Configuring Remote Sessions. This is often used by ASP applications wishing to use Remote StateManagers but cannot easily use the normal application configuration file format.
fchoice.oracle.forceascii7bit | No | "true" | On Oracle 8.0.x and earlier databases, strings with non ascii or extended ascii charcters non ASCII strings would cause garbage data to be inserted into the database. This switch effectively removes Unicode support for strings on Oracle 8.0.x or earlier systems.
fchoice.clarify.convertcarriagereturns | No | "true" | To have the Clarify Windows client properly display multiline strings carriage return line feeds (CRLF) need to be converted to line feeds (LF)
fchoice.clarify.ignoredatetimemilliseconds | No | false | DateTime fields will not have millisecond resolution with this setting enabled. This setting is solely provided to maintain compatibility with Clarify Classic Client versions before 12.5 which did not save millisecond details.

Data Protection

Some configuration settings can contain sensitive information such as usernames and passwords. fcSDK can protect such sensitive settings in just two steps using Data Protection.

  1. Encrypt the configuration parameter using the First Choice Configuration Protector Utility

  2. Copy the encrypted parameter string into your .Net application's configuration file.

    <appSettings>
<add key="fchoice.dbtype" value="MSSQL"/>
<add key="fchoice.connectionstring" value="{encrypted text goes here}"/>
</appSettings>

Important!

The encrypted key can only be decrypted on the same machine from which it was encrypted on. For example, if you want to use this encrypted key on your web server, then you should run the Configuration Protector application on your web server.

Entropy

When you encrypt your parameter settings you can optionally specify an Entropy value which is used as a key to furthur secure the encrypted text.

fcSDK Users

If you use an Entropy value the FCConfiguration.DataProtectionEntropy property must match the Entropy key you used to encrypt your parameters.

[C#]

FCConfiguration.DataProtectionsEntropy = "...Optional Key...";
ClarifyApplication.Initialize();

Compatibilty

If you use an Entropy value the FCApplication.DataProtectionEntropy property must match the Entropy key you used to encrypt your parameters.

[Javascript]

var FCApp = new ActiveXObject("FCFLCompat.FCApplication");
FCApp.DataProtectionsEntropy = "...Optional Key...";
FCApp.Initialize();


Overview of the fcSDK Configuration Editor | fcSDK Documentation

Overview of the fcSDK Configuration Editor

The fcSDK ships with a Configuration Editor program to assist you in editing your fcSDK application XML configuration file. Specifically, it allows you to set the fchoice.connectionstring and fchoice.dbtype keys in the appSettings section of the configuration.

For more information on the configuration file, and the key/value pairs, refer to Application Configuration Settings.

To run the Configuration Editor:

  • Start the Configuration Editor application
  • Use the File - Open menu to open an existing configuration file
  • Choose an Edit Mode:
    • Simple - Enter the connection parameters and the Configuration Editor will build the Connection String for you
    • Raw - Allows you to manually edit the Connection String
  • If using Edit Mode, fill in the connection parameters (DB Type, Login Name, Password, Server Name and Database Name)
  • If using Raw Mode, edit the Connection String Config Editor
  • If you would like to use Integrated Security, click the Integrated Security checkbox
    • If unchecked, User ID and Password are specified in the connection string
    • If checked, the current Windows account credentials are used for authentication
  • Click the Test Connection button to verify the connection information
  • Use the File - Save menu to save the configuration file


Configuration in .NET | fcSDK Documentation

Configuration in .NET

The .NET Framework provides a standardized way of configuring .NET applications using ".config" or "application configuration" files. For Windows EXE executables, this file is usually named (app).exe.config. For ASP.NET web applications, this file is called "web.config" and lives in the root directory of your ASP.NET application. This file can contain configuration for both the .NET Framework itself and the application. For more information on application configuration basics in .NET, please read the section entitled Configuring Applications in the .NET Framework SDK Documentation.

Application configuration files are in an XML format. .NET expects the XML to be formatted according to a specific tag schema. This is outlined in the .NET Framework SDK documentation under the heading Configuration File Schema.

Configuring fcSDK

The fcSDK uses the .NET Application Configuration mechanism to read load-time configurable settings. There are several load-time configurable options supported by fcSDK. These are:

  • Database type and connection string
  • Behavioral settings such as security, cache file control, database provider update batching, etc.
  • Custom cache providers
  • Custom database providers
  • Logging


Configuring Custom Cache Providers | fcSDK Documentation

Configuring Custom Cache Providers

Configuring CacheManager to load a custom cache object

CacheManager looks in the .NET configuration file for a specific configuration section called "customCaches". You must define this section at the top (it must be at the top) of the configuration file in the "configSections" element.

For example:

<?xml version="1.0" encoding="utf-8" ?>
<configuration>
    <configSections>
        <section name="customCaches" type="FChoice.Foundation.CacheSectionHandler, FChoice.Foundation"/>
    </configSections>

    ... (rest of config file) ...
</configuration>

Once you have defined the "customCaches" section, you can specify any number of custom caches using the "customCache" element.

For example:

    ... (start of config file referenced above) ...

    <customCaches>
        <customCache
            name="myCustomCache"
            type="MyNamespace.ClassName, MyAssemblyName"
            parameters="any optional initialization parameters here"  />
        <customCache
            name="anotherCustomCache"
            type="MyNamespace.AnotherClassName, MyAssemblyName"
            parameters="1, 2, 3, 4"  />
    </customCaches>

    ... (rest of config file) ...

</configuration>

customCache Element Schema

This table describes the attributes required for the customCache element.

Attribute | Required | Description
name Yes A key used by CacheManager to distinguish this cache. The instance of the cache created and loaded by CacheManager can be retrieved using this key with the CacheManager.GetCache method.
NOTE: CacheManager will load hard-coded caches such as the ListCache and LocaleCache before loading custom caches. These caches have specific names. If you specify a custom cache name that conflicts with one of these hard-coded cache names, an error will be thrown. These names are:
  • configitem_cache
  • list_cache
  • locale_cache
  • schema_cache
  • string_cache
type Yes The fully qualified type name of a class which derrives from FChoice.Foundation.CacheBase.
NOTE: Please refer to the Type.GetType method documentation for information for the specific format of the value of this attribute.
parameters | (see description) | Specifies any initialization parameters to pass to the custom cache object during initialization. Whether or not this attribute is required depends on the specific implementation of the custom cache object. For example, the CustomCache object which ships with the fcSDK requires this parameter to be a comma-delimited list of tables in the database to cache in memory and on disk.

Simple table caching using the CustomCache object

The fcSDK includes a simple "CustomCache" object which can cache one or more tables into a dataset. It executes a simple "SELECT * FROM" sql query for each of the table you specify. This is useful if you want to cache a small table or tables of static values.

In your config file, include the customCaches config section as mentioned above and define a custom cache with whatever name you wish to assign it. For the type attribute, use "FChoice.Foundation.CustomCache, FChoice.Foundation". The parameters attribute must contain at least one table name (the full SQL table name including the table_ prefix). Multiple tables can be specified separated by a comma.

For Example, if you wanted to cache the fc_string table (even though it's already cached):

    ... (start of config file referenced above) ...

    <customCaches>
        <customCache
            name="fcStringCache"
            type="FChoice.Foundation.CustomCache, FChoice.Foundation"
            parameters="table_fc_string"  />
    </customCaches>

    ... (rest of config file) ...

</configuration>

Creating your own custom cache object

In order to have CacheManager load your custom cache object, you must derrive from FChoice.Foundation.CacheBase. At the very least, you must override the "InitCacheData" method.

Cache load lifecycle

During Initialization:

  • ReadCacheData
  • (if persisted cache data found) LoadCacheData
  • (else)
    • InitCacheData
    • PersistCacheData

During Cache Update (UpdateCache called)

  • InitCacheData
  • PersistCacheData

NOTE: ReadCacheData and PersistCacheData are not called if the "nocachefile" configuration value is set to "true". Please consult the Basic Configuration Guide for more details on this value.

InitCacheData

This method will be called when CacheManager cannot find any existing persisted cache data (on disk) for your object. The implementation of this method is expected to perform whatever steps are necessary to produce a data object. This object will be returned back to CacheManager which will then save it to disk. The default implementation expects this object to be a System.Data.DataSet object. CacheManager has a specific optimized binary serializer for DataSets. Generally, the implementation of this method will make a SQL query to a database and return a DataSet.

Optionally, you can override the LoadCacheData method

This method will be called after the cache data has been loaded from the data source or read from the cache persistance (usually files on the disk). In this method is where you might create strongly-typed objects based on the data such as what the various fcSDK caches do with their objects (such as with the LocaleCache and the Country, FCTimeZone, and StateProvince objects).

It is not a requirement that this method do anything at all.

Using a custom data object type (other than DataSet)

If you plan on working with a cache object of a type other than DataSet, you MUST override the PersistCacheData and ReadCacheData methods to handle the custom serialization of the data.

  • PersistCacheData: This method takes two parameters: The object to persist and the recommended filename to use when saving the data of the object. It is not a requirement that this filename be used. If you choose not to use this filename, you must have a mechanism of producing consistent filenames based on the data source. For example, the default implementation produces a hash based on the database connection string. Data caches are tied to the database, so this is a unique identifying key for these caches. If your implementation depends on, for example, a web service, a hash of the URL would be a good unique identifying key for that datasource. Whatever the implementation, it must be consistent and reproducible from one run of the application to the next to ensure that the correct cache file gets loaded for the current data source.

    NOTE: If you manually generate a file name, ensure that you combine your file name with the value of the CacheManager.CacheFilePath property.

    NOTE: It is not even a requirement that you use a file to persist the cache data or even persist the data at all. However, you must ensure that if you do persist data to a medium other than the disk you be able to locate that data on subsequent runs of the application.

  • ReadCacheData: This method takes only one parameter: The default file name from which to load the cache data. If you did not use the file name for persisting the cache data in PersistCacheData, do not use this file name. Your file name generation should consistently produce the same file name for a given data source. Use the new file name, instead, in this situation.

    If the cache data could not be found (i.e. someone manually deleted the file or there is a new base cache file path), simply return null signifying that the data could not be loaded. At this point CacheManager will call InitCacheData to load the cache data direct from the data source.

    NOTE: If you manually generate a file name, ensure that you combine your file name with the value of the CacheManager.CacheFilePath property.


Application Logging in the fcSDK | fcSDK Documentation

Application Logging in the fcSDK

The fcSDK has a robust, comprehensive, and dynamic logging framework. This framework allows developers and administrators a high degree of flexibility to control the quality and detail of the information the fcSDK itself and any applications built upon the fcSDK generate.

The fcSDK uses a much more sophisticated and highly configurable logging mechanism with more features than previous First Choice products. Here is a sample of some of the features:

  • Different log levels: Debug, Info, Warning, Error, and Fatal
  • Can log to: File, Database, Windows Event Log, Email, several other sources, or any combination of these
  • Set maximum log file size, number of file rollovers, etc
  • Configurable log output (date/time format, log source, etc)
  • Dynamic configuration: Make changes on-the-fly, without re-starting your application

The Log Manager uses an XML Configuration file. The configuration is easily readable and updateable while retaining the flexibility to express all configurations. fcSDK ships with several sample logging configuration files.

Setting up Log Manager:

Copy one of the sample logging configuration files from your fcSDK installation directory to an appropriate working directory. Edit the sample logging configuration file as appropriate for your needs.

For example, if you are logging to a file, you'll probably want to set the File param of the RollingFileAppender entry to tell the Log Manager the path and filename of where you want your log file to be located.

Refer to the Logging Config File Samples documentation for more details on and examples of logging configuration files.

Tell LogManager which logging config file to use. This can be accomplished in one of two ways:

  • Set the fchoice.logconfigfile application setting in your application configuration (.config) file (see Configuring fcSDK for more information on configuring fcSDK).
  • Programmatically set the LogConfigFilePath property of LogManager before initializing ClarifyApplication Restart your application

From here on, you can make changes to the logging configuration file, and these changes will automatically be picked up by the Log Manager - there's no need to restart your app just to make a logging configuration change.

See Also

  • Logging Config File Samples
  • Configuring fcSDK


Configuring Session State Managers | fcSDK Documentation

Configuring Session State Managers

When a new user is logged in using CreateSession there is a session management mechanism present to keep track of this relatively expensive object across web application requests (web applications being the bulk of fcSDK deployments.) This session management mechanism is pluggable and is handled by objects called State Managers. Out of the box, fcSDK provides two main types of State Managers: in-memory and remote state managers.

Memory State Manager

The most common and default session provider is the MemoryStateManager. Nothing special needs to be done to use this manager. The only setting you may wish to change is the session timeout which is talked about in Configuring a State Manager below. The rest of this document will discuss the other, more complex, type of manager Remote State Managers.

Remote State Managers

Remote State Managers allow sessions to be shared across many different web servers in an enterprise environment. The user's session object is serialized to a centralized repository, usually a database, using one of the Remote State Manager objects. The object used depends on the type of datastore into which the session is being serialized.

The ability to use a single session across multiple web servers allows your application to scale on demand. If the number of users hitting your current web server are starting to hurt performance with Remote State Managers enabled you can easily throw more web servers at the problem.

  • Database Setup
  • State Managers
  • Classic Web Application Configuration
  • <stateManager> Element Schema

Database Setup

Remote state managers use a database to persist their state information. A new database table is used to store each user's state information. On MSSQL databases, there are also new stored procedures that need to be created. A SQL script template is provided to assist in setting up the required database table and stored procedures. Be aware that it is not required that the database used as a repository for state management be the same database server or instance being used for Clarify. In fact, using a separate database instance may be desirable to reduce the load on your Clarify database instance.

The following database setup is required for Remote Sessions:

  1. The required SQL table (and stored procedures for MSSQL databases) needs to be created.
  2. The database login being used needs to be granted ALL access to the FCStateManager table, and for stored procedures on MSSQL.
  3. A connection string using this database login needs to be constructed for use in the configuration file.

There are SQL scripts for each supported database system in the fcSDK install directory that assist in accomplishing these steps:

  • MSSQL- <fcSDK Install Directory>/sql/remotesession/mssql_remotesession.sql
  • Oracle - <fcSDK Install Directory>/sql/remotesession/oracle_remotesession.sql

Important - The SQL scripts are designed to be edited before execution. Please read the script comments in the individual files for further assistance. If you need help on how to execute SQL scripts please see the fcSDK Installation Guide.

State Managers

The StateManager object abstracts the act of storing and retrieving the user's session data. In order to take advantage of Remote Sessions you need to configure your application to use an appropriate state manager. You also need to do the following configuration if you wish to set the timeout of the MemoryStateManager.

The fcSDK provides the following state managers:

fcSDK State Managers

Name | Fully Qualified Type Name (type=...) | Description
Memory | FChoice.Common.State.MemoryStateManager, FChoice.Common, Version=x.x.x.x, Culture=neutral, PublicKeyToken=48c955ba8dfd90d8 | Default state manager if none is specified in the configuration file.
MSSQL | FChoice.Common.State.MsSqlStateManager, FChoice.Common, Version=x.x.x.x, Culture=neutral, PublicKeyToken=48c955ba8dfd90d8 | MSSQL state manager.
Oracle | FChoice.Common.State.OracleStateManager, FChoice.Common, Version=x.x.x.x, Culture=neutral, PublicKeyToken=48c955ba8dfd90d8 | Oracle state manager. If Oracle is used as a state repository it is recommended that you use this state manager.
ODP.Net | FChoice.DataProviders.ODPNet.ODPNetStateManager, FChoice.DataProviders.ODPNet, Version=x.x.x.x, Culture=neutral, PublicKeyToken=48c955ba8dfd90d8 | Alternative Oracle state manager supporting Oracle 8i databases and above.

Configuring a State Manager

The first time that the StateManager is accessed it looks in the .NET configuration file for a specific configuration section called "stateManager".

You must define this section at the top of the configuration file in the "configSections" element. Following the configSection comes the "stateManager" element which will contain the details of the state manager configuration. See the stateManager schema for more details.

For example:

<?xml version="1.0" encoding="utf-8" ?>
<configuration>
  <configSections>
    <section name="stateManager" type="FChoice.Common.State.StateManagerSectionHandler, FChoice.Common"/>
    <!-- other config sections if present -->
  </configSections>

  <stateManager timeout="20" applicationName="fcClient" type="FChoice.Common.State.OracleStateManager, FChoice.Common" >
    <database connectionstring="Data Source=MYOracleSID; User Id=user;Password=pass;" />
  </stateManager>

  <!-- rest of config file -->

</configuration>

If no state manager configuration information is present, StateManager will use the in-memory state manager effectively disabling the remote session feature.

<stateManager> Element Schema

This table describes the attributes required for the stateManager element within the configuration.

Element | Attribute | Required | Description
stateManager | timeout | Yes | Timeout (in minutes) of the state. State that is not loaded within the timeout period is subject to removal when RemoveExpiredStates is called. Note: the fcSDK calls RemoveExpiredStates when creating a session.
stateManager | applicationName | Yes | Name of the application (e.g. "fcClient") being remoted. Sessions are grouped by the application name value, allowing you to view which sessions are associated with a specific application. For example this is used by fcClient to view the current sessions for the application.
stateManager | type | Yes | The fully qualified type name of a class which derives from FChoice.Common.State.IStateManager. Please see State Managers. NOTE: Please refer to the Type.GetType method documentation for more information on .Net type naming conventions.
Only applies to Remote Managers |  |  |
database | connectionstring | Yes | The connection string used to connect to the database being used as a state repository.

Classic Web Application Configuration

When configuring state managers for ASP web applications using the fcSDK via the Compatibility layer, configuration becomes difficult as ASP was not designed with .Net in mind and does not support an application configuration file in the traditional sense. For this scenario we have provided an alternative way of configuring database Providers via a separate configuration file.

Specifying the statemanager configuration file.

There is a special application configuration setting, "fchoice.statemanager.configurationfile", which allows the fcSDK to bypass the application configuration file and directly use another xml file to configure the state managers.

This example shows an example fc.env used by many Dovetail Software applications to tell the fcSDK where to look for the custom dbprovider configuration file.

;begin fc.env file...
; ... other settings ...
fchoice.statemanager.configurationfile=c:\app\fcclient\remotesession.config

Fully qualified state manager type names

To facilitate extensibility the fcSDK state manager is a plug-in type mechanism which depends on loading classes at runtime. In the examples above a "partially qualified" class name is used, only specifying the name of the class and the assembly (dll) where that class can be found. This usually works fine for pure dotnet scenarios. When running Compatiblity layer applications requiring a remote state manager the configuration file must use fully qualified class names. You can find a list of the fully qualified state manager type names above in State Managers.

Example alternative configuration file

The following example shows the contents of a configuration file using fully qualified names.

<!-- begin remotesession.config -->
<stateManager timeout="20"
              applicationName="fcClient"
              type="FChoice.DataProviders.ODPNet.ODPOracleProvider, FChoice.DataProviders.ODPNet, Version=2.0.2.1, Culture=neutral, PublicKeyToken=48c955ba8dfd90d8" >
  <database connectionstring="Data Source=MYOracleSID; User Id=user;Password=pass;" />
</stateManager>


Developer Walkthrough - Fundamental FCFL.NET Objects | fcSDK Documentation

Developer Walkthrough - Fundamental FCFL.NET Objects

This walkthrough will cover four of the fundamental objects in FCFL.NET:

  • ClarifyApplication - Only one instance is present per application.
  • ClarifySession - Represents a user's connection to the database.
  • ClarifyGeneric - Workhorse object for doing data retrieval, insertion and modification.
  • ClarifyDataSet - Allows grouping ClarifyGeneric object database operations.

Clarify Application

The ClarifyApplication object instance represents an application that will connect to the Clarify database. ClarifyApplication is a Singleton and only one instance is ever in the runtime. After having been initialized (see below), the Singleton instance of ClarifyApplication can be accessed using the Instance static (Shared in Visual Basic) property.

Initializing the Application Object

Before you can call any FCFL.NET methods the application object needs to be initialized. This is done using the Initialize method. The Initialize method readies the ClarifyApplication instance by performing actions such as:

  • Loading application configuration
  • Caching schema and application data
  • Validating licenses

Basic Initialization

For Initialize to work correctly you must have your configuration file set up with the minimum required application configuration settings. Please see the Generic Example below to view a basic Initialization in action.

Manual Configuration Initialization

If, for some reason, you cannot or do not wish to use a configuration file for configuration -- if you need to select application settings at runtime, for example -- the application can be "manually" initialized using a NameValueCollection populated with configuration settings.

Manual Initialization

[C#]

// Create and populate configuration collection
NameValueCollection config = new NameValueCollection();
config.Add( "fchoice.dbtype", "MSSQL");
config.Add( "fchoice.connectionstring", "Data Source=.;Initial Catalog=clarify; User Id=sa; Password=sa;" );
config.Add( "fchoice.sessionpasswordrequired", "false");

// Create and manually initialize the ClarifyApplication instance
ClarifyApplication app = ClarifyApplication.Initialize( config );

[Visual Basic]

' Create and populate configuration collection
Dim config As New NameValueCollection
config.Add( "fchoice.dbtype", "MSSQL");
config.Add( "fchoice.connectionstring", "Data Source=.;Initial Catalog=clarify; User Id=sa; Password=sa;");
config.Add( "fchoice.sessionpasswordrequired", "false");

' Create and manually initialize the ClarifyApplication instance
ClarifyApplication app = ClarifyApplication.Initialize( config );

Clarify Session

The ClarifySession object represents a single user's connection to the database. All session operations or objects created from the session do so as the session user. The session can also be used as storage similar to ASP or ASP.NET's Session object. ClarifySession objects are created using the CreateSession method on ClarifyApplication.

In a single session application, such as a Windows Forms application, you would initialize the application object and create a single session object for use throughout your application.

In a multi-session application, such as a web application, the application object would be initialized at a global level with one session object being created per user.

Sessions in a Web Environment

In a web application, creating and destroying session objects for each request is expensive. CreateSession avoids this by caching the session's data for you at the application level.

The session object exposes a SessionID property for you to use to uniquely identify the session and to later retrieve it. The SessionID can be saved in the web application's session object or as a cookie in the browser. When the web page loads the application will retrieve the SessionID and pass it to the CreateSession method to retrieve a reference to the already-existing ClarifySession object instance.

When the web user's session ends CloseSession should be called to remove the session from the application.

Clarify Generic

The ClarifyGeneric object provides functionality to retrieve, update and insert data against a Clarify instance -- respecting the special requirements imposed by the Clarify system and thick client. Each generic object represents a single table or view in the Clarify database. Generics are created using the CreateGeneric method on a ClarifyDataSet instance.

The normal lifecycle of a generic is:

  • Generic creation
  • Append filters or sort order
  • Query data
  • View and/or modify the rows returned by the query
  • Add new rows to the generic

See the Generic Example below to see a basic sample of data retrieval using a generic.

Generic DataRows

Generics are representations of database tables or views. As database tables or views contain rows of data so do generics. A generic has a Rows property that exposes a collection of ClarifyDataRow objects.

When executing a query, a generic object builds and executes a SQL query and places the results in the Rows collection. This collection can be enumerated (using for each in C# or For Each in Visual Basic), or indexed directly by row number.

Index the row by fieldname to access or modify data for a field within the row.

To add a row to the generic and schedule it for insertion into the database, call the AddNew method.

Accessing Generic DataRows

[C#]

//First, create the dataset which will contain the generics
ClarifyDataSet dataSet = new ClarifyDataSet(session);

//create an address generic and add a row to it
ClarifyGeneric gAddress = dataSet.CreateGeneric("address");

//add a new address and commit it using Update()
ClarifyDataRow row = gAddress.AddNew();
row["address"] = "8900 Business Park Drive";
row["city"] = "Austin";
row["state"] = "TX";
row.Update();

//on purpose we forgot to add the zip code

//now we query for all rows with the same address (there will be at least one)
gAddress.AppendFilter("address", StringOps.Equals, "8900 Business Park Drive");
gAddress.Query();

//get a reference to the first row in the address generic
row = gAddress[0];

//you can also get a reference to the same row via the Rows collection
row = gAddress.Rows[0];

//update rows by iterating through the Rows collection
foreach(ClarifyDataRow addressRow in gAddress.Rows)
{
    addressRow["zipcode"] = "78759";
}

gAddress.UpdateAll();

[Visual Basic]

'First, create the dataset which will contain the generics
Dim dataSet As New ClarifyDataSet(session)

'create an address generic and add a row to it
Dim gAddress As ClarifyGeneric = dataSet.CreateGeneric(quot;address")

Dim row As ClarifyDataRow

'add a new address and commit it using Update()
row = gAddress.AddNew()
row("address") = "8900 Business Park Drive"
row("city") = "Austin"
row("state") = "TX"
row.Update()

'on purpose we forgot to add the zip code

'now we query for all rows with the same address (there will be at least one)
gAddress.AppendFilter("address", FChoice.Foundation.StringOps.Equals, "8900 Business Park Drive")
gAddress.Query()

'get a reference to the first row in the address generic
row = gAddress(0)

'you can also get a reference to the same row via the Rows collection
row = gAddress.Rows(0)

'update rows by iterating through the Rows collection
For Each row In gAddress.Rows
    row("zipcode") = "78759"
Next

gAddress.UpdateAll()

Generic Hierarchies

It is often the case that you will want to query a table (for example, the case table), and then find some related rows in another table. These related tables are called child generics. The set of generics related to each other are a generic hierarchy. Generics engaged in a hierarchy have slightly different behavior than standalone generics.

NOTE: The concepts of "child" and "parent", when referring to generics, is not necessarily the same as the natural "child" and "parent" concepts in terms of the database. For example, one might think of an OTM relation as a "parent"->"children" relationship where the "O" is the parent. Generics can be linked OTM or MTO. The concept of a "parent" generic or "child" generic doesn't refer to the relationship cardinality, it refers to which generic traversed from which and in what order they will be processed during a Query or Update operation.

  • Child generics are created via Traverse, TraverseFromParent, or TraverseFromRoot
  • It is possible for a generic to be both a parent generic and have child generics related to it, thus creating a generic hierarchy.
  • Querying a generic in a hierarchy actually queries the top most parent generic in the hierarchy, which in turn populates all the generics in the hierarchy. You only need to call Query once on the hierarchy.
  • After the Generic Hierarchy is populated, it is easy to navigate to the related child or parent generic's rows using ClarifyDataRow.RelatedRows.

The following example shows how to relate a case generic to a site and iterate through their rows.

Traversing Related Generics

[C#]

//First, create the dataset which will contain the generics
ClarifyDataSet dataSet = new ClarifyDataSet(session);

// Create the 'case' generic and traverse to site
ClarifyGeneric gCase = dataSet.CreateGeneric("case");
ClarifyGeneric gSite = gCase.Traverse("case_reporter2site");
gCase.Query();

// Iterate through each case and emit the related site
foreach( ClarifyDataRow caseRow in gCase.Rows )
{
  System.Console.WriteLine("Case Title: " + caseRow["title"]);

  foreach( ClarifyDataRow siteRow in caseRow.RelatedRows(gSite) )
  {
    System.Console.WriteLine("Site: " + siteRow["name"]);
  }
}

[Visual Basic]

//First, create the dataset which will contain the generics
Dim dataSet As New ClarifyDataSet(session)

' Create the 'case' generic and traverse to site
Dim gCase As ClarifyGeneric = dataSet.CreateGeneric("case")
Dim gSite As ClarifyGeneric = gCase.Traverse("case_reporter2site")
gCase.Query()

' Iterate through each case and emit the related site
For Each caseRow As ClarifyDataRow In gCase.Rows

  System.Console.WriteLine("Case Title: " + caseRow("title"))
  For Each siteRow As ClarifyDataRow In caseRow.RelatedRows(gSite)

    System.Console.WriteLine("Site: " + siteRow("name"))

  Next
Next

Generic Example:

The following is a basic working fcSDK application. It does the following:

  • Initializes the ClarifyApplication
  • Creates a ClarifySession
  • Retrieves the data

[C#]

// using FChoice.Foundation.Clarify

// Initialize the ClarifyApplication instance
ClarifyApplication app = ClarifyApplication.Initialize();

// Create a session
ClarifySession session = app.CreateSession("sa", "sa", ClarifyLoginType.User);

// Create the dataset which will contain the generics
ClarifyDataSet dataSet = new ClarifyDataSet(session);

// Now view all the case objids in the system
ClarifyGeneric gCase = dataSet.CreateGeneric("case");
gCase.Query();

foreach( ClarifyDataRow row in gCase.Rows )
{
    System.Console.WriteLine( gCase.UniqueId.ToString() );
}

[Visual Basic]

// using FChoice.Foundation.Clarify

' Initialize the ClarifyApplication instance
Dim app As ClarifyApplication = ClarifyApplication.Initialize()

' Create a session using a different time zone
Dim session As ClarifySession = app.CreateSession( "sa", "sa", ClarifyLoginType.User)

// Create the dataset which will contain the generics
Dim dataSet As New ClarifyDataSet(session)

' Now use fcSDK as normal
Dim gCase As ClarifyGeneric = dataSet.CreateGeneric("case")
gCase.Query()

For Each row As ClarifyDataRow In gCase.Rows
    System.Console.WriteLine( row.UniqueID.ToString() )
Next

Clarify DataSet

ClarifyDataSet objects are responsible for storing the data of as well as producing generics. Also, ClarifyDataSet provides methods which allow a group of ClarifyGenerics to be Queried or Updated at the same time within the same database transaction. ClarifyDataSets can be created by using the new operator and passing an instance of a ClarifySession to the constructor.

Convenience and Integrity

It is often necessary to do multiple operations on a set of generics at the same time for convenience and database integrity.

For example, when querying three unrelated tables you would normally have to call Query on each generic. ClarifyDataSet provides the convenient Query method which can take a list of ClarifyGenerics to query as a transaction.

Maintaining application integrity when updating the database is paramount when inserting or updating multiple generic rows. It is important that all updates take place or none of them do. This is known as a transaction. The Update method on a ClarifyDataSet acts as a transactional wrapper for generic operations. It is similar to the Query method in that it takes a list of ClarifyGeneric objects to update and performs the update operations on them in a single transaction.

Update/Insert Statement Batching

On database platforms that support statement batching (i.e. Microsoft SQL Server, but not Oracle), the ClarifyDataSet can submit all update and insert statements as a single batch/round-trip to the database. Select statements cannot be batched efficiently due to the complexity of Generic child/parent relationships.

Generic DataSet Membership

Generics created via the CreateGeneric method on an instance of ClarifyDataSet. The underlying data of the ClarifyGenerics are stored in the ClarifyDataSet. ClarifyGenerics from different ClarifyDataSets cannot be related. ClarifyGenerics created via Traversal methods are always members of their parent generic's ClarifyDataSet. A ClarifyGeneric cannot be moved or removed from its containing ClarifyDataSet.

Using ClarifyDataSets

[C#]

// Create the dataset which will contain the generics
ClarifyDataSet dataSet = new ClarifyDataSet(session);

// create a case generic
ClarifyGeneric gCase = dataSet.CreateGeneric( "case" );
gCase.AppendFilter("title", StringOps.Equals, "my case");

// create a site generic
ClarifyGeneric gSite = dataSet.CreateGeneric( "site" );
gSite.AppendFilter("name", StringOps.Equals, "my site");

// create a contact generic
ClarifyGeneric gContact = dataSet.CreateGeneric( "contact" );
gContact.AppendFilter("e_mail", StringOps.Equals, "test@foo.com");

//all queries done at once
dataSet.Query( gCase, gSite, gContact );

ClarifyDataRow caseRow = gCase.Rows[0];
ClarifyDataRow siteRow = gSite.Rows[0];
ClarifyDataRow contactRow = gContact.Rows[0];

caseRow.RelateRecord( siteRow, "case_reporter2site");
contactRow["e_mail"] = "bar@foo.com";

//all updates done within a transaction
dataSet.Update( gCase, gSite, gContact );

[Visual Basic]

// Create the dataset which will contain the generics
Dim dataSet As New ClarifyDataSet(session)

'create a case generic
Dim gCase As ClarifyGeneric = dataSet.CreateGeneric("case")
gCase.AppendFilter("title", FChoice.Foundation.StringOps.Equals, "my case")

'create a site generic
Dim gSite As ClarifyGeneric = dataSet.CreateGeneric("site")
gSite.AppendFilter("name", StringOps.Equals, "my site")

'create a contact generic
Dim gContact As ClarifyGeneric = dataSet.CreateGeneric("contact")
gContact.AppendFilter("e_mail", StringOps.Equals, "test@foo.com")

'all queries done at once
dataSet.Query( gCase, gSite, gContact );

Dim caseRow As ClarifyDataRow = gCase.Rows(0)
Dim siteRow As ClarifyDataRow = gSite.Rows(0)
Dim contactRow As ClarifyDataRow = gContact.Rows(0)

caseRow.RelateRecord(siteRow, "case_reporter2site")
contactRow("e_mail") = "bar@foo.com"

'all updates done within a transaction
dataSet.Update( gCase, gSite, gContact );

Basic fcSDK Configuration


Developer Walkthrough - Toolkit Fundamentals | fcSDK Documentation

Developer Walkthrough - Toolkit Fundamentals

This walkthrough will provide an overview of the basic usage pattern involved in using the Toolkit APIs.

Toolkit Namespaces

The Toolkit APIs are split up into logical groupings with each group of APIs having their own namespace.

  • Contracts FChoice.Toolkits.Clarify.Contracts
  • Depot Repair FChoice.Toolkits.Clarify.DepotRepair
  • Field Operations FChoice.Toolkits.Clarify.FieldOps
  • Interfaces FChoice.Toolkits.Clarify.Interfaces
  • Logistics FChoice.Toolkits.Clarify.Logistics
  • Quality FChoice.Toolkits.Clarify.Quality
  • Sales FChoice.Toolkits.Clarify.Sales
  • Support FChoice.Toolkits.Clarify.Support

Using API methods

Each Toolkit object has many methods each intended to encapsulate a Clarify operation or 'API'.

API method overloads

Each API call has two overloaded methods:

  1. Required parameters only - This overload takes the bare minimum required parameters for the API call to work. This overload is the simplest possible way to invoke the API but limits what parameters can be set.
  2. A single Setup object parameter - Each and every API has a setup object that is used to configure the API's possible parameters. The setup object's constructor will always take the required parameters for the API. Once the setup object is created, its properties can be set to control all of the possible actions the API can take.

Toolkit Results

Each API method returns at minimum a ToolkitResult object which contains the ReturnCode of the operation and relavant Objid and Identifier of objects created if applicable. Some APIs have specialized Result objects for when more information is returned.

Result Return Code

The value of the ReturnCode will always be zero, no error occurred, unless the application is using Compatiblity and the Session has ThrowErrors set to false. Only if ThrowErrors is false will no exception be thrown and a non-zero value will be returned. Note: It is recommended that you do not set ThrowErrors to false and use structured error handling via try/catch statements.

Specialized Results

There are some APIs that return more information than the basic ToolkitResult object. These APIs return a custom result object, derived from ToolkitResult, that contains read-only Properties with the extra result information.

For example, the Support toolkit API PreCloseCase returns a PrecloseCaseResult object.

Additional Fields

Many API setup objects have an AdditionalFields property which allows callers to set user defined fields ('x_fields') in a customized Clarify environment. It is also possible to use AdditionalFields to override the fields that are set by the API.

To set an additional field simply call the Append method on the API's AdditionalField property.

Toolkit Example

The following example demonstrates use of ToolkitResults, both API calling conventions, and setting of AdditionalFields.

Using the Interfaces and Support Toolkits to create a case

[C#]

//using the Interfaces toolkit create an address and a site
InterfacesToolkit interToolkit = new InterfacesToolkit( session );

//only required parameters are entered for these APIs so we do not require a setup object
ToolkitResult addressResult = interToolkit.CreateAddress(string'>"123 Lower Wacker Dr.", string'>"Chicago", string'>"IL", string'>"60601", string'>"USA", string'>"CST" );
ToolkitResult siteResult    = interToolkit.CreateSite(SiteType.Customer, SiteStatus.Active, addressResult.Objid);

//using the Support toolkit create a case using the handy CreateCaseSetup object.
SupportToolkit supportToolkit= new SupportToolkit( session );

//the setup class is created with the required case parameters. Then the optional properties we need are set.
CreateCaseSetup caseSetup = new CreateCaseSetup(siteResult.IDNum, string'>"Ferris", string'>"Bueller", string'>"(224) 555-1212");
caseSetup.CreateDate = DateTime.Now.AddDays(-1);
caseSetup.Title = string'>"Claim for Ferrari destroyed due to jack failure";
caseSetup.PhoneLogNotes = string'>"Life moves pretty fast. If you don't stop and look around once in awhile, you could miss it.";
caseSetup.Queue = string'>"Italian Auto Repair";
caseSetup.AdditionalFields.Append(string'>"x_Cameron_Freakout_Level", 90.2, string'>"Double");

//finally create the case using the setup object
ToolkitResult caseResult = supportToolkit.CreateCase( caseSetup );

//the results of the case creation are available from the ToolkitResult object
int caseObjid = caseResult.Objid;
string caseIDNum = caseResult.IDNum;

[Visual Basic]

'using the Interfaces toolkit create an address and a site
Dim interToolkit As New InterfacesToolkit(session)

'only required parameters are entered for these APIs so we do not require a setup object
Dim addressResult, siteResult As ToolkitResult
addressResult = interToolkit.CreateAddress("123 Lower Wacker Dr.", "Chicago", "IL", "60601", "USA", "CST")
siteResult = interToolkit.CreateSite(SiteType.Customer, SiteStatus.Active, addressResult.Objid)

'using the Support toolkit create a case using the handy CreateCaseSetup object.
Dim supportToolkit As New SupportToolkit(session)

'the setup class is created with the required case parameters. Then the optional properties we need are set.
Dim caseSetup As New CreateCaseSetup(siteResult.IDNum, "Ferris", "Bueller", "(224) 555-1212")
caseSetup.CreateDate = DateTime.Now.AddDays(-1)
caseSetup.Title = "Claim for Ferrari destroyed due to jack failure"
caseSetup.PhoneLogNotes = "Life moves pretty fast. If you don't stop and look around once in awhile, you could miss it."
caseSetup.Queue = "Italian Auto Repair"
caseSetup.AdditionalFields.Append("x_Cameron_Freakout_Level", 90.2, "Double")

'finally create the case using the setup object
Dim caseResult as ToolkitResult
caseResult = supportToolkit.CreateCase(caseSetup)

'the results of the case creation are available from the ToolkitResult object
Dim caseObjid as Integer
Dim caseIDNum as String
caseObjid = caseResult.Objid;
caseIDNum = caseResult.IDNum;


Developer Walkthrough - Web Services Fundamentals | fcSDK Documentation

Developer Walkthrough - Web Services Fundamentals

Web Services Fundamentals

NOTE: The Web Services have been moved to to a public GitHub repository: Dovetail SDK Web Services. Please use the services there to view the code, fork it, etc. The documentation provided here is still applicable, but Web Services are not included as part of the fcSDK installation.

NOTE: Dovetail Bootstrap, also available as a public GitHub repository, (Dovetail Bootstrap) can also be used to create applications to provide whatever information or user experiences you wish to expose for your Dovetail/Clarify applications. This project includes examples for building Web Applications and Windows Services, including exposing Dovetail SDK API calls as RESTful web service APIs.

Overview

This walkthrough will provide an overview of the basic usage pattern involved in using the fcSDK Web Services.

A typical web service scenario is composed of two parts: the server which hosts the web services and the client or clients who will make request and receive responses from those web services. The web service server will be the machine where the fcSDK is installed which is also typically a web application server. The fcSDK Web Services is an ASP.NET web application runing under IIS.

Making web service calls is not unlike making browser request to a web page. The main difference being that web service calls are generally made from applications instead of a client browser. Just as a web application can provide a user interface into fcSDK, the fcSDK Web Services provides a programmatically way to interface with fcSDK from a remote machine.

Web services may be consumed by any language or platform that can send requests and receive responses over HTTP. This makes it possible to use Java to call .NET web services such as the fcSDK Web Services.

The fcSDK Web Services are implemented as typical ASP.NET Web Services. The following web service pages are installed as part of the fcSDK Web Services installation.

  • ClarifyApplicationSrv.asmx - contains web methods for dealing with application level information such as schema cache and string cache
  • ClarifySessionSrv.asmx - an abstraction of a ClarifySession which deals with session level information
  • ClarifyDataAccessSrv.asmx - an abstraction of a ClarifyGeneric which allows querying and data modifications
  • ContractsToolkitSrv.asmx - an abstraction of the API ContractsToolkit
  • DepotRepairToolkitSrv.asmx - an abstraction of the API DepotRepairToolkit
  • FieldOpsToolkitSrv.asmx - an abstraction of the API FieldOpsToolkit
  • InterfacesToolkitSrv.asmx - an abstraction of the API InterfacesToolkit
  • LogisticsToolkitSrv.asmx - an abstraction of the API LogisticsToolkit
  • QualityToolkitSrv.asmx - an abstraction of the API QualityToolkit
  • SalesToolkitSrv.asmx - an abstraction of the API SalesToolkit
  • SupportToolkitSrv.asmx - an abstraction of the API SupportToolkit

WSDL

To retrieve the WSDL (Web Service Description Language) for a particular web service, all you have to do is make an HTTP request to the web service page with '?WSDL' appended to the end of the URL. For example, if you would like the WSDL for the ClarifyApplicationSrv web service you would do something like the following:

Replace 'localhost' with the fcSDK Web Services server and 'FChoice.WebServices.Clarify' with the correct virtual directory where the web services are installed.

If you are using the fcSDK Web Services Client for .NET to access the web services, then you probably will not need to use the WSDLs for the web services.

Protocol Classes

Web services are composed of requests and responses. Each of these is a XML message which is transported over HTTP using the SOAP protocol. Many of the messages contain nested data structures (called complex types) which define the data needed for a particular request or response. The client and server components of these web services generally transform these data structures into a hierarchy of classes which make them easier to deal with programmatically. The process of converting classes to XML data structures is call serialization and the process of converting the XML data structures back to classes is called deserialization. When using modern languages like .NET and Java, this is all handled for you. If you are using a platform that does not provide tools to do serialization, then you may need to write your own.

Because there are limits on what types may be serialized, it is often necessary to create a class that its sole purpose is to be used to transport data in requests and responses for web services. This is the case for many of the types in fcSDK Web Services.

For example, in the FChoice.Toolkit.Clarify.Support namespaces there are setup objects for each of the toolkit APIs that allow one to specify invocation data for a particular API. To extend this behavior to a web service implementation, protocol classes where created for each of these setup object. The fcSDK Web Services use these protocol objects for input parameters and for return results.

[C#]

// Signature for standard SupportToolkit.CreateCase()
public ToolkitResult CreateCase(CreateCaseSetup setupParam)

// Signature for SupportToolkitWS.CreateCase()
public ToolkitResultProtocol CreateCase(CreateCaseSetupProtocol setupParam)

The web services convert these protocol classes to the real type counterparts which are passed in to the underlying fcSDK API during invocation. As shown in the previous example, many results are returned as protocol objects which contain properties that are nearly identical to there non-protocol counterpart.

Web Service Sessions and Authentication

The ClarifyApplication Web Service ( ClarifyApplicationSrv ) is the starting point for all client applications consuming the fcSDK Web Services. From here CreateSession() is called to create a ClarifySession on the web services server which will live until either Logout() is called on the ClarifySessionSrv, or a configurable timeout period is reached. This method returns an authentication token which will be passed in the SOAP header of each web service call which requires authentication. The server will read the authentication token from the SOAP header and match it back up to a ClarifySession that was previously created using ClarifyApplicationWS.CreateSession(). If it can not find a ClarifySession to match to due to invalid authentication token or an expired session, the API will throw an exception. Each ClarifySession consumes a fcSDK license, so it's important to call Logout() on the Clarify Session Web Service after use so that the license can be released. If you are using the fcSDK Web Services Client for .NET, then the SOAP headers and the controlling of authentication token is handled for you.

fcSDK Web Services Client for .NET

Web Services Client Overview

The recommended way to use the fcSDK Web Services in a .NET environment is to use the provided client which ships with the fcSDK. The client makes writing code to use the web services very similar to writing code to use native fcSDK.

The client classes completely hide the complexities of the SOAP headers and the session authentication token. They also provide required state information to the web services such as which properties have been changed from their original values on the toolkit setup objects.

Protocol classes only have default public constructor with no parameters (requirement for serialization) which makes it difficult to determine which values of a complex type are required before invocation. The fcSDK Web Services Client solves this problem by providing the user with a client side API (which looks nearly identical to server side fcSDK code) which handles the creation and transport of the protocol classes under the hood.

Client Protocol Classes

The client contains all the protocol classes needed to transport data to and from the server. Each web service page (each asmx page) has it's own version of a protocol class. These protocol classes live in the following namespaces:

  • FChoice.WebServices.Clarify.Client.Protocols.ClarifyApplicationSrv
  • FChoice.WebServices.Clarify.Client.Protocols.ClarifySessionSrv
  • FChoice.WebServices.Clarify.Client.Protocols.ClarifyDataAccessSrv
  • FChoice.WebServices.Clarify.Client.Protocols.ContractsToolkitSrv
  • FChoice.WebServices.Clarify.Client.Protocols.FieldOpsToolkitSrv
  • FChoice.WebServices.Clarify.Client.Protocols.InterfacesToolkitSrv
  • FChoice.WebServices.Clarify.Client.Protocols.LogisticsToolkitSrv
  • FChoice.WebServices.Clarify.Client.Protocols.QualityToolkitSrv
  • FChoice.WebServices.Clarify.Client.Protocols.SalesToolkitSrv
  • FChoice.WebServices.Clarify.Client.Protocols.SupportToolkitSrv

When using a client class that corresponds to a particular web service page, it may also be necessary to use some of the protocol class for that service. In some cases, such as the setup objects for the web services for the API Toolkits, the will be not be used. Instead client versions of these classes are provided to provide the necessary constructors and state information needed to invoke the server side API correctly. You can look at the signature of the APIs to see their inputs and outputs to determine the types need. Please refer to the FChoice.WebServices.Clarify.Client API documentation for details.

Working with Application and Session Information

The base client classes live in the FChoice.WebServices.Clarify.Client namespace.

The starting point in engaging the web service client is to create an instance of the ClarifyApplicationWS class which takes a single parameter that is the URL of the location where the fcSDK Web Services were installed.

[C#]

ClarifyApplicationWS application = new ClarifyApplicationWS("http://myserver/FChoice.WebServices.Clarify/");

There are several methods that can be called on ClarifyApplicationWS for getting application related information such as retrieve list from the ListCache. Please see ClarifyApplicationWS for more details.

As with standard fcSDK, you create a session object by calling CreateSession().

[C#]

ClarifyApplicationWS application = new ClarifyApplicationWS("http://myserver/FChoice.WebServices.Clarify/");

ClarifySessionWS session = application.CreateSession( username, password );

There are several methods that can be called on ClarifySessionWS for getting session related information such as getting the current time zone.

Accessing and Modifying Data using the Web Services Client

The ClarifyDataAccessWS class provides a means of doing ClarifyGeneric queries and data modifications. Please refer to the Accessing Data with the Web Services guide for more details.

Accessing the API Toolkits using the Web Services Client

The fcSDK Web Services Client contains toolkit classes for each of the fcSDK API Toolkit classes which live under their own namespaces as follows:

  • FChoice.WebServices.Clarify.Client.Contracts.ContractsToolkitWS
  • FChoice.WebServices.Clarify.Client.DepotRepair.DepotRepairToolkitWS
  • FChoice.WebServices.Clarify.Client.FieldOps.FieldOpsToolkitWS
  • FChoice.WebServices.Clarify.Client.Interfaces.InterfacesToolkitWS
  • FChoice.WebServices.Clarify.Client.Logistics.LogisticsToolkitWS
  • FChoice.WebServices.Clarify.Client.Quality.QualityToolkitWS
  • FChoice.WebServices.Clarify.Client.Support.SupportToolkitWS

Each of these toolkit classes can be instantiated by passing a valid ClarifySessionWS.

[C#]

SupportToolkitWS supportWS = new SupportToolkitWS( session );

You may then call the non setup APIs directly.

[C#]

ToolkitResultProtocol result = supportWS.CreateCase(siteIDNum, firstName, lastName, phone);

The toolkit API result will contain the same properties as the result of the equivalent fcSDK toolkit API.

[C#]

Console.WriteLine( "IDNum : {0}", result.IDNum );
Console.WriteLine( "Objid : {0}", result.Objid );
Console.WriteLine( "ReturnCode : {0}", result.ReturnCode );

The output should look something like the following:

IDNum : 123456
Objid : 268435499
ReturnCode : 0

You may also choose to create a setup object to pass into the API just as you would with the native fcSDK API Toolkits. The following is a more complete example:

[C#]

// Create ClarifyApplicationWS
ClarifyApplicationWS application = new ClarifyApplicationWS("http://myserver/FChoice.WebServices.Clarify/");

// Create ClarifySessionWS
ClarifySessionWS session = application.CreateSession( username, password );

// Create toolkit
SupportToolkitWS supportWS = new SupportToolkitWS( session );

// Create setup
CreateCaseSetupWS setup = new CreateCaseSetupWS( siteIDNum, firstName, lastName, phone );

// Supply additional data
setup.Title = "This is a test title";

// Invoke API
ToolkitResultProtocol result = supportWS.CreateCase( setup );

// Output results
Console.WriteLine( "IDNum : {0}", result.IDNum );
Console.WriteLine( "Objid : {0}", result.Objid );
Console.WriteLine( "ReturnCode : {0}", result.ReturnCode );

// Release the ClarifySession from the web service server
session.Logout();

The output should look something like the following:

IDNum : 123456
Objid : 268435499
ReturnCode : 0

For more information on the API Toolkits and how they should be used, please refer to the Developer Walkthrough - Toolkit Fundamentals.


Developer Walkthrough - Transaction support | fcSDK Documentation

Developer Walkthrough - Transaction support

The fcSDK supports transactional database operations within FCFL.NET and the FCFL and API Toolkit COM Compatibility Layer. This support is easy to use and maps well to the classic transactional operations of Begin, Commit, and Rollback.

API Toolkit / Generic Transaction Operations

Here is an example of a typical usage scenario where the developer uses some API Toolkit operations mixed with some ClarifyGeneric updates:

[C#]

using System.Data;
using FChoice.Common.Data;
using FChoice.Foundation;
using FChoice.Foundation.Clarify;
using FChoice.Toolkits.Clarify;
using FChoice.Toolkits.Clarify.Interfaces;
using FChoice.Toolkits.Clarify.Support;

...

InterfacesToolkit interfaceToolkit = new InterfacesToolkit(session);
SupportToolkit supportToolkit = new SupportToolkit(session);

using( IDbConnection connection = DbProviderFactory.Provider.GetConnection() )
{
   connection.Open();

   using(IDbTransaction transaction = connection.BeginTransaction())
   {
      try
      {
         string addr1 = "123 Street";
         string city = "Austin";
         string state = "TX";
         string zip = "78759";
         string country = "USA";
         string timeZone = "CST";

         //unique test identifier (first, last, phone) for a contact
         string firstName = Guid.NewGuid().ToString().Substring(0,10);
         string lastName = Guid.NewGuid().ToString().Substring(0,10);
         string phone = Guid.NewGuid().ToString().Substring(0,10);

         CreateAddressSetup addressSetup = new CreateAddressSetup( addr1, city, state, zip, country, timeZone);
         ToolkitResult addressResult = interfaceToolkit.CreateAddress( addressSetup, transaction );

         CreateSiteSetup siteSetup = new CreateSiteSetup(SiteType.Customer, SiteStatus.Active, addressResult.Objid);
         ToolkitResult siteResult = interfaceToolkit.CreateSite( siteSetup, transaction );

         CreateContactSetup contactSetup = new CreateContactSetup( firstName, lastName, phone, siteResult.IDNum);
         ToolkitResult contactResult = interfaceToolkit.CreateContact( contactSetup, transaction );

         ClarifyDataSet dataset = new ClarifyDataSet(session);
         ClarifyGeneric generic = dataset.CreateGeneric("phone");
         ClarifyDataRow row = generic.AddNew();
         row["phone"] = "512-555-1212";
         row["name"] = "Soft Cell";
         row.RelateByID(siteResult.Objid, "phone2site");
         row.Update(transaction);

         transaction.Commit();
      }
      catch
      {
         transaction.Rollback();
         throw;
      }
   }
}

Transactions using Compatibilty

This JavaScript example shows how to use the transaction support that is now exposed to the COM clients via the Compatibility layer. The FCSession object holds the context of the transaction.

[JavaScript]

try
{
   FCSession.StartTransaction(null);

   var ret_int = fcinter.create_contact_list( first_name, last_name, phone, primary_site_id,
      role_name, fax_number, e_mail, mail_stop, title,
      hours, salutation,
      fld_list,type_list,val_list);

   var genMonitor = FCSession.CreateGeneric("monitor");
   genMonitor.BulkName = "transaction sample";
   genMonitor.AddNew();
   genMonitor("title") = "Monitor Name";

   var genModem = FCSession.CreateGeneric("modem");
   genModem.BulkName = "transaction sample";
   genModem.AddNew();
   genModem("device_name") = "Modem Device Name";

   genMonitor.Bulk.UpdateAll();
   FCSession.CommitTransaction();
}
catch(e)
{
   FCSession.RollbackTransaction();
   ErrorHandler("An error occured and the transaction was rolled back. Error: " + e.description)
}


Developer Walkthrough - Advanced Filtering | fcSDK Documentation

Developer Walkthrough - Advanced Filtering

The fcSDK now supports filtering ClarifyGenerics using nested And and Or operators. In the past fcSDK only supported And filtering via the AppendFilter methods. Limiting filtering to simple And filtering made the FCGeneric class easier to use but limited the flexibility with which you could select records from your Clarify database.

The Generic Filter Property

fcSDK developers have a new starting place for filtering - ClarifyGeneric.Filter. This is the root filter for the ClarifyGeneric and it starts out empty. To add constraints to the records returned by a query AddFilter() needs to be called passing in a filter. Filters are easily created using the FilterType factory object. The following example shows some basic AND filtering against the root filter:

[C#]

ClarifyDataSet ds = new ClarifyDataSet(session);
ClarifyGeneric caseGeneric = ds.CreateGeneric("case");

//typical AND filtering

caseGeneric.Filter.AddFilter( FilterType.Equals( "id_number", "case 1" ));
caseGeneric.Filter.AddFilter( FilterType.StartsWith( "title", "ERROR:" ));
caseGeneric.Query();

//result filter
//WHERE ( ( id_number = {0} ) AND ( title LIKE {1} ) )

Moving beyond simple AND filtering

The generic's root filter property exposes an AndFilter. Thus all filters added to the root filter will be separated by AND keywords as in the example above. OR filtering is done in a similar fashion but an OrFilter must first be created and added to the root filter. The following example shows a simple OrFilter in action:

[C#]

ClarifyDataSet ds = new ClarifyDataSet(session);
ClarifyGeneric caseGeneric = ds.CreateGeneric("case");

//An example OR filter
OrFilter orFilter = FilterType.Or( FilterType.Equals( "id_number", "case 1" ),
    FilterType.StartsWith( "title", "ERROR:" ));
caseGeneric.Filter.AddFilter( orFilter ); //Note: this could all be on one line
caseGeneric.Query();

//result
//( ( ( id_number = {0} ) OR ( title LIKE {1} ) ) )

Logical filters support AddFilter

Currently only AndFilter and OrFilter objects support the AddFilter method. The following example shows creation of an OrFilter with four filters added.

[C#]

ClarifyDataSet ds = new ClarifyDataSet(session);
ClarifyGeneric caseGeneric = ds.CreateGeneric("case");

OrFilter orFilter2 = FilterType.Or( FilterType.Equals( "id_number", "case 1" ),
   FilterType.StartsWith( "title", "ERROR:" ));

orFilter2.AddFilter( FilterType.IsNull("phone_num") );
orFilter2.AddFilter( FilterType.IsIn("objid", 268435457, 268435458, 268435459));

caseGeneric.Filter.AddFilter( orFilter2 );
caseGeneric.Query();

//result
//( ( ( id_number = {0} ) OR ( title LIKE {1} ) OR ( phone_num IS NULL ) OR ( ( objid IN ({2},{3},{4}) ) )

More complex filter groupings

AndFilters can easily be added to OrFilters to allow complex grouping of query constraints.

[C#]

ClarifyDataSet ds = new ClarifyDataSet(session);
ClarifyGeneric caseGeneric = ds.CreateGeneric("case");

//mix in AND with OR filter groupings

AndFilter andFilter = FilterType.And( FilterType.Equals( "id_number", "case 1" ), FilterType.StartsWith( "title", "ERROR:" ));
OrFilter orFilter3 = FilterType.Or( FilterType.Equals( "id_number", "case 1" ), andFilter );

caseGeneric.Filter.AddFilter( orFilter3 );
caseGeneric.Query();

//result
//( ( ( id_number = {0} ) OR ( ( id_number = {1} ) AND ( title LIKE {2} ) ) ) )


Developer Walkthrough - Workflow Event Handling | fcSDK Documentation

Developer Walkthrough - Workflow Event Handling

Workflow Event Handling

One of the more common requirements for objects created for Clarify is performing workflow operations on those objects, such as assigning cases or dispatching change requests. Dovetail SDK provides a powerful set of tools to make workflow operations easy to implement. This guide explains how to get started.

Using WorkflowManager for Workflow Actions

Dovetail SDK supports the following Workflow Methods for Queueable Objects in Clarify with the WorkflowManager object:

  • Accept
  • Assign
  • Dispatch
  • Forward
  • Move
  • Reject
  • Yank
  • ChangeStatus

Queueable Object Types that are currently supported:

CASE, SUBCASE, DEMAND_DTL, TASK, OPPORTUNITY, CONTRACT, BUG, PROBDESC, DIALOGUE

All of these methods follow the same basic model for parameters. For example, the Dispatch method takes

  • id number of the object being dispatched
  • type of object being dispatched
  • queue that the object is being dispatched to
  • time that the dispatch occurred
  • login name of the user performing the dispatch
  • boolean indicating to generate time bombs

Here is the signature for the Dispatch method:

public WorkFlowInfo Dispatch(string idNum, string objectName, string queueName, DateTime dispatchDate, string userName, bool generateTimeBomb)

Examples of using WorkflowManager:

The following examples demonstrate use of WorkflowManager APIs. The first example dispatches the case to the queue, and the second example accepts the case into the userís wipbin.

[C#]

// Dispatch Case 1 to the Support queue

string caseId = "1";
string queueName = "Support";
string userName = "sa";
bool generateTimeBombs = true;
DateTime eventTime = DateTime.Now;

ClarifyDataSet ds = new ClarifyDataSet(session);

WorkflowManager workflowManager = new WorkflowManager(ds);
workflowManager.Dispatch(caseId, "case", queueName, eventTime, userName, generateTimeBombs);

// Accept Case 1 into the default wipbin

string caseId = "1";
string wipbinTitle = "default";
string userName = "sa";
bool generateTimeBombs = true;
DateTime eventTime = DateTime.Now;

ClarifyDataSet ds = new ClarifyDataSet(session);

WorkflowManager workflowManager = new WorkflowManager(ds);
workflowManager.Accept(caseId, "case", wipbinTitle, eventTime, userName, generateTimeBombs);

Using .Net Version of Compatibility Toolkits for Workflow Actions

Dovetail SDK also support workflow methods for queueable objects through the Compatibility Toolkits. These APIs are grouped by the toolkit which govern the objects primary functions. For example, the Case workflow APIs are found in the Support Toolkit. At this time, all of the queueable objects except Dialogue have compatibility versions of the workflow APIs.

Since the Compatibility Toolkits were originally developed in VB, all of the Compatibility Toolkit APIs are also provided for use in .Net applications. These APIs have names similar to the VB versions. Each one has a name with the pattern of , i.e. DispatchCase. These APIs have a different signature, and all use a matching setup object, i.e. DispatchCaseSetup. The setup objects are created first, and have parameters for each required property.

Looking at the DispatchCase API, the only required properties are the case id number and the queue name. Correspondingly, the setup object only has two parameters:

[C#]

DispatchCaseSetup( string caseIdNum, string queue )

Once the setup object is created, then the other properties can also be set. This allows less code to be required to perform the operation, which makes it easier to use. It also allows the API to be easily modified if necessary. Here is an example of setting the optional properties:

[C#]

string caseId = "1";
string queueName = "Support";

DispatchCaseSetup setup = new DispatchCaseSetup(caseId, queueName);
setup.DispatchDate = DateTime.Now;
setup.UserName = "sa";
setup.GenerateTimeBombs = false;

At this point, the setup object is ready for use. The corresponding API uses its setup object as input, and the API is invoked:

[C#]

SupportToolkit supportToolkit = new SupportToolkit(fcApplication, fcSession);
ToolkitResult result = supportToolkit.DispatchCase(setup);

The ToolkitResult will have all of the details from executing the API. Any error code would be in the ReturnCode property.

[C#]

int returnCode = result.ReturnCode;

Summary

The APIs for the workflow events can be implemented in multiple environments. Dovetail SDK executes the same code to perform a workflow action, regardless of how the API is called. All of the necessary validation of the input parameters is done, and the appropriate activity logs and time bombs will be generated as required.


Accessing Data With ClarifyGeneric | fcSDK Documentation

Accessing Data With ClarifyGeneric

One of the basic and most important services the fcSDK offers (through FCFL.NET) is data access. You can use FCFL.NET to query, insert, update, and delete data in your Clarify™ database. fcSDK is designed to work within the rules of the Clarify™ system. This means that, if used properly, the fcSDK will read data written by other Clarify™ clients and also write data that is compatibile with them.

Querying Data

To query data with FCFL.NET, define a ClarifyGeneric for each table or view from which you wish to query, specify the relations that connect them (if at all) and then, if necessary, specify which fields to return, filters, and sorts to restrict the query.

Once the ClarifyGenerics are set up, they can be queried individually, or together as part of a single transaction using a ClarifyDataSet object.

In order to create a new ClarifyGeneric, you must first create a new instance of a ClarifyDataSet object (use the new operator (New in Visual Basic). Once the ClarifyDataSet instance is created, call the CreateGeneric method on the ClarifyDataSet instance.

ClarifyGeneric contains many methods for customizing how it queries or updates data, relates to other ClarifyGeneric instances, or relates to data in other tables in the database. Please consult the API reference for ClarifyGeneric for more information.

The following example will query for sites whose type is 1, sorted by ID Number descending. The example will then print out each site queried.

[C#]

//First, create the dataset which will contain the generics
ClarifyDataSet dataSet = new ClarifyDataSet(session);

// Get all sites whose 'type' is 1 and sort by site ID, descending
ClarifyGeneric gSite = dataSet.CreateGeneric("site");
gSite.AppendFilter( "type", NumberOps.Equals, 1 );
gSite.AppendSort("site_id", false);

// Now query the data
gSite.Query();

// While there are more sites...
//  Print out the ID and name
foreach( ClarifyDataRow siteRow in gSite )
{
   Console.WriteLine("Site ID, Name: {0}, {1}", siteRow["site_id"], siteRow["name"]);
}

[Visual Basic]

'First, create the dataset which will contain the generics
Dim dataSet As New ClarifyDataSet(session)

' Get all sites whose 'type' is 1 and sort by site ID, descending
Dim gSite As ClarifyGeneric = dataSet.CreateGeneric("site")
gSite.AppendFilter( "type", NumberOps.Equals, 1 )
gSite.AppendSort("site_id", false)

' Now query the data
gSite.Query()

' While there are more sites...
'  Print out the ID and name
For Each siteRow As ClarifyDataRow In gSite

   Console.WriteLine("Site ID, Name: {0}, {1}", siteRow("site_id"), siteRow("name"))

Next

In the above example, the site table query is setup to find the proper rows and sort them in the proper order -- sites whose type is 1 and sort them by their ID, descending. Next, the ClarifyGeneric is queried. Note that most of the queries that are done involve multiple ClarifyGenerics in which case the Query method on the ClarifyDataSet object is used to query them all as part of a single transaction. Once the query is executed, the results are displayed to the console. For each site row returned by the query, this example prints out some information about that site.

Query Limitation

In most cases, queries will be unconstrained. That is, the query will return back as many rows as is possible. All of the records will be returned and put into the ClarifyGeneric's Rows collection.

There are certain circumstances, however, where limiting the number of records return is a requirement (for example, queries entered by end users through a 'Case Query' web page). If the table being queried has a large number of records (such as the Case table), it may be desirable to limit the number of results to, for example, 500 rows or less.

By default, all FCFL.NET queries are unconstrained. In order to constrain queries, set the MaximumRows property on a ClarifyGeneric instance. Setting this property will cause 2 things to happen:

The number of rows returned will be the number specified or less.

If the number of rows that can be returned is greater than the specified MaximumRows value, the MaximumRowsExceeded event will be fired during a Query operation. This allows the default behavior (mentioned in [1] above) to be optionally overriden. Handling this event is not required unless special logic is desired.

The following example shows how to use the MaximumRows property and how to use the MaximumRowsExceeded event to control how ClarifyGeneric behaves:

[C#]

  // Get 2 cases
  ClarifyGeneric gCase = session.CreateGeneric("case");
  gCase.MaximumRows = 2;
  gCase.MaximumRowsExceeded += new MaximumRowsExceededEventHandler(gCase_MaximumRowsExceeded);

  // Now query the data
  gCase.Query();

  // While there are more cases
  //  Print out the case info
  foreach( ClarifyDataRow caseRow in gCase )
  {
     Console.WriteLine("Case ID, Title: {0}, {1}", caseRow["id_number"], caseRow["title"]);
  }
}

private static void gCase_MaximumRowsExceeded(FCGeneric sender, MaximumRowsExceededEventArgs args)
{
  // Get the total rows that could be returned by this query if unconstrained
  int totalRows = args.TotalPossibleRows;

  // To re-constrain the query
  args.RowsToReturn = 6;

  // -OR-

  // To cancel the query
  args.CancelQuery = true;
}

[Visual Basic] ...vbnet

' Get 2 cases
Dim gCase As ClarifyGeneric = session.CreateGeneric("case")
gCase.MaximumRows = 2
AddHandler gCase.MaximumRowsExceeded, AddressOf gCase_MaximumRowsExceeded

' Now query the data gCase.Query()

' While there are more cases ' Print out the case info For Each caseRow As ClarifyDataRow In gCase Console.WriteLine("Case ID, Title: {0}, {1}", caseRow("id_number"), caseRow("title")) Next End Sub

Private Sub gCase_MaximumRowsExceeded( ByVal sender As FCGeneric, ByVal args As MaximumRowsExceededEventArgs )

' Get the total rows that could be returned by this query if unconstrained Dim totalRows As Integer = args.TotalPossibleRows

' To re-constrain the query args.RowsToReturn = 6

' -OR-

' To cancel the query
args.CancelQuery = True
End Sub

This example demonstrates how to constrain queries using the MaximumRows property. To gain finer-grained control over the behavior exhibited when the MaximumRows limit is exceeded, add an event handler to the MaximumRowsExceeded event. In this event handler, the total rows that would be returned if this were an unconstrained query can be retrieved using the TotalPossibleRows property on the MaximumRowsExceededEventArgs object instance. Likewise, the event handler can tell ClarifyGeneric to cancel the query altogether (using the CancelQuery property), or to redefine the row limit on the query (using the RowsToReturn property). Redefining the query is useful, for example, if the row limit is 100 rows and 101 rows are returned. Since there is only one extra row, it would be helpful to just return all 101 rows instead of hard-limiting the results to 100 rows.

Writing Data

FCFL.NET's ClarifyGeneric object can also write data. There are three basic operations which write data to the database:

Update Data
Insert Data
Delete Data

There are two main ways of performing these operations using ClarifyGeneric:

Modifying previously-queried data
Setting data on new rows flagged for updating an existing row in the database (covered later in the "Updating A Row Without Querying First" section). Once the data is modified, the data in a single row, data in all the rows in a ClarifyGeneric, or data in all the rows in all the generics in a ClarifyDataSet can be committed to the database. For more information on how to do this, see the "Committing Your Changes" section.
IMPORTANT: Updates, Deletes, and Inserts are not valid on view-based ClarifyGenerics or ClarifyGenerics queried using the IsDistinct flag.

Updating Data
There are two main patterns which are used to modify the data in a ClarifyGeneric:

Change a data field
Relate/Unrelate this record to/from a record in another ClarifyGeneric
The first pattern used to modify a ClarifyGeneric is similar to the way the DataSet, DataTable, and DataRow pattern works in ADO.NET. ClarifyGeneric (similar to a DataTable) contains a collection of ClarifyDataRow objects (similar to DataRow). Each row has an indexer for the field, or column, in that row. To modify a particular field's value in a row, use the indexer (or Item property) and pass in the field's 0-based index or the name of the field. For example:

[C#]
```csharp
// Get the desired row (the first one, in this example)
ClarifyDataRow row = gCase[0];

// Set the alt_address field
row["alt_address"] = "Hello!";

[Visual Basic]

' Get the desired row (the first one, in this example)
Dim row As ClarifyDataRow = gCase(0)

' Set the alt_address field
row("alt_address") = "Hello!"

The second pattern used to modify data in a ClarifyGeneric is to relate or unrelate records. There are several convenience methods on ClarifyGeneric and ClarifyDataRow which help with setting up or removing different types of relations. The most common of these methods is the RelateRecord method on the ClarifyDataRow object. This method allows two records to be related using a specified relation name. For example, to relate a specific case to a site:

[C#]

// Relate a specific case row to a site row
caseRow.RelateRecord(siteRow, "case_reporter2site");

[Visual Basic]

' Relate a specific case row to a site row

caseRow.RelateRecord(siteRow, "case_reporter2site")

Relations can be called from either side, FCFL.NET will relate the records correctly regardless of which side of the relation is being related. For example, a case row can be related to a site row, or a site row can be related to a case row and FCFL.NET will write the correct records to the database to ensure that the two records are related properly, according to the rules of the Clarify™ system.

NOTE: It is possible to relate two new records (that do not yet have assigned objids). FCFL.NET will assign the objids and resolve the relationships when updates are committed. See below for more information on adding new records and committing changes.

RelateRecord requires both rows to already exist in memory. This means that both rows were queried previously. There are occasions, however, where the objid of the record to relate is already known (for example, it was passed in the querystring of a page in an ASP web application). It would be inefficient to query the database just to have a record to that RelateRecords can be called. In this circumstance, the RelateByID method should be used. This method allows an already-queried record to be related to a previously-known objid.

NOTE: In order to call any of the "Relate*" methods on a particular ClarifyDataRow, the row's parent ClarifyGeneric cannot have been queried using the IsDistinct flag. Also, if using RelateRecord on two ClarifyDataRows, the rows' parent ClarifyGenerics must belong to the same ClarifyDataSet.

IMPORTANT: Updates, Deletes, and Inserts are not valid on view-based ClarifyGenerics or ClarifyGenerics queried using the IsDistinct flag.

Inserting Data

To add a new row to the database, use the AddNew method. This method returns a new ClarifyDataRow instance initialized with all the fields for the table to which it belongs. The data on the fields can be set using this object in the same manner in which existing rows are updated (see Updating Data).

NOTE: It is not necessary to set the "objid" field on a new record. FCFL.NET will take care of objid generation automatically. Also, if two new rows are related, FCFL.NET will assign the objids and resolve the relationships between the two new records properly.

WARNING: FCFL.NET ensures that the basic minimum data requirements are met when inserting or updating records. However, business logic such as required relations (i.e. a case must be related to a site, etc) are NOT enforced by FCFL.NET. This is the responsibility of the application using FCFL.NET.

The following example adds a new contact_role:

[C#]

//First, create the dataset which will contain the generics
ClarifyDataSet dataSet = new ClarifyDataSet(session);

// Get one specific contact
ClarifyGeneric gContact = dataSet.CreateGeneric("contact");
gContact.AppendFilter("objid", NumberOps.Equals, 268435457);

// Get one specific site
ClarifyGeneric gSite = dataSet.CreateGeneric("site");
gSite.AppendFilter("objid", NumberOps.Equals, 268435457);

// Query both via the ClarifyDataSet
dataSet.Query(gContact, gSite);

// Now create a new contact role
// Set it as a secondary role and relate it to the contact
// and site
// NOTE: In order for RelateRecord to work, the two generics
//    must be in the same ClarifyDataSet
ClarifyGeneric gRole = dataSet.CreateGeneric("contact_role");
ClarifyDataRow row = gRole.AddNew();
row["primary_site"] = 2;
row["role_name"] = "Default";
row.RelateRecord( gContact[0], "contact_role2contact" );
row.RelateRecord( gSite[0], "contact_role2site" );
row.Update();

[Visual Basic]

'First, create the dataset which will contain the generics

Dim dataSet As New ClarifyDataSet(session)

' Get one specific contact
Dim gContact As ClarifyGeneric = dataSet.CreateGeneric("contact")
gContact.AppendFilter("objid", NumberOps.Equals, 268435457)

' Get one specific site
Dim gSite As ClarifyGeneric = dataSet.CreateGeneric("site")
gSite.AppendFilter("objid", NumberOps.Equals, 268435457)

' Query both via the ClarifyDataSet
dataSet.Query(gContact, gSite)

' Now create a new contact role
' Set it as a secondary role and relate it to the contact
' and site
' NOTE: In order for RelateRecord to work, the two generics
'    must be in the same ClarifyDataSet
Dim gRole As ClarifyGeneric = dataSet.CreateGeneric("contact_role")
Dim row As ClarifyDataRow = gRole.AddNew()
row("primary_site") = 2
row("role_name") = "Default"
row.RelateRecord( gContact(0), "contact_role2contact" )
row.RelateRecord( gSite(0), "contact_role2site" )
row.Update()

WARNING: The above example is not complete and is for illustration purposes only. It may leave your contact_role table in an invalid state and may cause other application using this database (such as the Clarify™ thick client) to fail.

IMPORTANT: Updates, Deletes, and Inserts are not valid on view-based ClarifyGenerics or ClarifyGenerics queried using the IsDistinct flag.

Updating A Row Without Querying First

For instances where the objid of a particular record is known and only a small bit of data needs to be updated (a few fields), it would be inefficient to query the row for the sole purpose of updating one or a few fields. This would involve two database round trips. It would be more efficient to create a new row in memory which reprepsents the real row in the database, change only the fields necessary, and then update the database using only a single database round trip. The AddForUpdate method on a ClarifyGeneric instance provides a convenient way to do this. This method will return a special row with no data in it. No query is executed to produce the row, it is created according to cached ADP/Schema data. The row's field values can then be changed as necessary. Only fields whose values have changed will be updated in the database when committing the operation.

Deleting Data

There are two main ways to delete a record in the database using FCFL.NET:

  • Call the Delete method on an existing ClarifyDataRow
  • Call the DeleteById method on ClarifyGeneric if the objid for the row is already known.

The changes caused by Delete or DeleteById will not happen until the operation is committed. For more information about committing operations, see the section on Committing Changes.

NOTE: After calling the Delete method on a row, the row will be invalid. No further methods or properties should be called on that row. Setting the row reference variable to null (Nothing in Visual Basic) is the safest way to ensure that the row will not get accessed again.

When a row is deleted, all relations that point to that record (rows in other tables including MTM tables) will be NULL'd out (or the MTM row deleted in the case of MTM relationships). Nothing will point to that record any longer. If the related rows have mandatory relations, they will be pointed to the mandatory (-2) row.

WARNING: Deleting records may leave your Clarify™ data in an inconsistent state and could cause other clients to fail when operating against the same database. Deleting data can leave required relationships unfulfilled, among other problems. For mass deletions/purges, please use a special Purge/Archive tool.

NOTE: If Delete is called on a row that was just created as a result of the AddNew method, the row will become invalidated and will not be inserted or deleted. The row will no longer be valid and cannot be manipulated further. See above warning about deleting rows for for more information.

IMPORTANT: Updates, Deletes, and Inserts are not valid on view-based ClarifyGenerics or ClarifyGenerics queried using the IsDistinct flag.

Committing Your Changes When all the desired changes have been performed on a row, ClarifyGeneric, or generics in a ClarifyDataSet, the operation must be committed to the database. There are three methods available depending on how large of scope of update is required:

  • Single Row: Call Update on the specific ClarifyDataRow (NOTE: Except for rows which have been deleted. These rows are no longer valid and cannot be accessed. Deletions can only take affect by calling Update on the ClarifyGeneric or Update on the ClarifyDataSet).
  • Multiple Rows, Single Table: Call Update on the specific ClarifyGeneric.
  • Multiple Rows, Multiple Tables in the same ClarifyDataSet: Call Update on the specific ClarifyDataSet.

Once one of these methods is called, the changes are immediately made to the database. Calling Update on a ClarifyGeneric or Update on a ClarifyDataSet processes all the rows as part of a single database transaction.

Handling NULL Values

In the Clarify™ system, most fields are non-NULLable. There are a few exceptions, but non-null is generally the case. In the rare instances when NULL values must be dealt with, this section will cover how to use NULL values with ClarifyGeneric.

It is important to understand that NULL is not the same thing as an empty string (''). The empty string is a non-null value which simply has no string data in it. If you attempt to use one for the other, it will fail. In Microsoft™ SQL Server™ and Sybase™, for example, (with a non-nullable field), an empty or populated string are the only two valid values. The database will not allow a NULL value.

There are four major circumstances in which NULL values will be a concern. The first is querying data, the second is testing for a NULL value in a field, the third is converting NULLs to empty strings, and the fourth is writing data.

Querying NULL Data

ClarifyGeneric provides a convient way to filter on NULL values by using the AppendFilterIsNull method. This method allows a given field to be filtered on its NULL or non-NULL state. Alternatively, the QueryEmptyToNull property on a ClarifyGeneric can be set before the Query method is called. Next, call AppendFilter and use the StringOps.Equal operation and a value of String.Empty. ClarifyGeneric will then process the empty string appropriately according to the rules of the underlying database. Either way is acceptable and depends on the specific circumstance and usage pattern.

Testing NULL Data

To test a specific field in a ClarifyDataRow for a NULL value, compare it to the System.DBNull.Value object from the .NET Framework.

Converting NULL Strings to Empty Strings

To have ClarifyGeneric automatically convert all NULL values to String.Empty, set the SetNullStringsToEmpty property to true. When accessing a field on a specific ClarifyDataRow, which is actually NULL underneath, String.Empty will be returned instead. If Update is later called, ClarifyGeneric will recognize that the field is still NULL (NOT String.Empty, assuming it was not directly modified) and not update the database.

NOTE: To have this behavior be the default for all ClarifyGenerics in the session, set the SetNullStringsToEmpty property on the current ClarifySession. instance.

Writing NULL Data

To set a field on a ClarifyDataRow to NULL and have it saved to the database as NULL, simply set the value of the field to DBNull.Value. For more information on updating the value of a field in a ClarifyDataRow, see the section above called Updating Data


Using the Caching Features of the fcSDK | fcSDK Documentation

Using the Caching Features of the fcSDK

During FCFL.NET initialization, frequently used and seldom updated data is pulled into memory as cache objects. The cached data is exposed as read only strongly typed objects.

fcSDK-based applications utilize cached objects to avoid extra round trips to the database which results in a dramatic application performance boost. They also make it easier to write fcSDK-based applications as commonly used data is readily available through strongly typed objects.

Cache Lifecycle

The cached objects are loaded during ClarifyApplication initialization. If enabled, cache objects will be persisted to the file system (cache files) as it is much faster to load the cache objects directly from the file system rather than the database.

During initialization:

  • If up-to-date cache files are found to be already on the system the application is initialized from the cache files.
  • If cache files are present but found to be out-of-date they are refreshed from the database. For example, this happens to the SchemaCache when the Clarify Schema has been updated.
  • If cache files are not present data is cached from the database and saved to cache files.
  • Custom caches loaded.

Creation of cache files can be disabled using a configuration setting (fchoice.nocachefile). The location of the cache files is also configurable (fchoice.cachefilepath).

Refreshing the Cache

Cache information can get out of date. Currently the only built-in cache object that will automatically detect if it is out-of-date is the Schema Cache. If you update non-schema data that you know to be cached you have two options.

  • Manually delete the cache files on the file system.
  • Programmatically update the cache using CacheManager

Refreshing Caches

[C#]

//update the Schema Cache
CacheManager.UpdateCaches( CacheType.Schema );

//update all caches except the Schema Cache
CacheManager.UpdateCaches( CacheType.Data );

//update all Caches
CacheManager.UpdateCaches( CacheType.All );
[Visual Basic]

'updates the Schema Cache
CacheManager.UpdateCaches( CacheType.Schema )

'updates the all caches except the Schema Cache
CacheManager.UpdateCaches( CacheType.Data )

'update all Caches
CacheManager.UpdateCaches( CacheType.All );

Built-In fcSDK caches

The fcSDK comes with four built-in caches available through properties on ClarifyApplication. Each cache has some common characteristics:

  • They contain collections of strongly typed read-only cache objects providing access to the cache data.
  • Each cache object may be related to child cache objects. For example, in the SchemaCache the Tables object contains a Relationships property.
  • Each cache provides two access pathways to cached objects.
    • Collections index-able by an identifier.
    • Accessor methods (start with Get) allowing you to explicitly lookup a cached object.
  • Caches also have validation methods (start with Is) that allow you to quickly check that an object is in the cache.

Schema Cache

The SchemaCache allows you to programmatically browse the Clarify Schema at runtime. You can find out what Fields are in a View or what Relationships are present for a Table.

Schema Cache Usage Example

[C#]

//get a reference to the case table
SchemaTable caseTable = ClarifyApplication.Instance.SchemaCache.Tables["case"];

//print out some details about each case relation
foreach(SchemaRelation relation in caseTable.Relationships)
{
    Console.WriteLine("Case Relation : {0}, Target Table {1}, Cardinality {2}",
        relation.Name, relation.TargetName, relation.Cardinality);
}

//print out some details about each case field
foreach(SchemaTableField field in caseTable.Fields)
{
    Console.WriteLine("Case Field : {0}, Field Default {1}",
        field.Name, field.FieldDefault);
}

[Visual Basic]

'get a reference to the case table
Dim caseTable As SchemaTable = ClarifyApplication.Instance.SchemaCache.Tables("case")

'print out some details about each case relation
For Each relation As SchemaRelation In caseTable.Relationships
    Console.WriteLine("Case Relation : {0}, Target Table {1}, Cardinality {2}", _
        relation.Name, relation.TargetName, relation.Cardinality)
Next

'print out some details about each case field
For Each field As SchemaTableField In caseTable.Fields
    Console.WriteLine("Case Field : {0}, Field Default {1}", _
        field.Name, field.FieldDefault)
Next

List Cache

The ListCache provides access to user defined (HierarchicalStrings) and global (GlobalStrings) lists.

Locale Cache

The LocaleCache provides access to Country, State and TimeZone information.

For more information on how TimeZones are used in fcSDK see also Time Zone Handling.

String Cache

The StringCache allows access to all the localizable application strings present in the string_db or fc_string tables.

This cache is slightly different in that it does not expose a collection and its accessor methods start with “Find”.

Custom Caches

Data that is often accessed and seldom updated can benefit from caching. fcSDK's built-in caches attempt to cover basic Clarify and Dovetail database objects that meet this criteria. However, custom Clarify implementations may data that could also benefit from caching. By editing the application configuration file one or more Custom Cache Providers can be added and automatically put into memory during initialization.

While caching of often used, read-only data can greatly boost application performance please be aware that there are downsides to caching:

  • Application memory utilization will grow proportionally with the amount of data that is being cached.
  • If data being cached is modified the cache must be updated or the application restarted to refresh the cache.
  • Custom Caches do not save cache files to the file system. Application start up time will be affected when loading large amounts of data from the database into the cache.

  • Basic Configuration
  • Time Zone Handling


Application Logging | fcSDK Documentation

Application Logging

Application Logging in the fcSDK

The fcSDK has a robust, comprehensive, and dynamic logging framework. This framework allows developers and administrators a high degree of flexibility to control the quality and detail of the information the fcSDK itself and any applications built upon the fcSDK generate.

The fcSDK uses a much more sophisticated and highly configurable logging mechanism with more features than previous Dovetail Software products. Here is a sample of some of the features:

  • Different log levels: Debug, Info, Warning, Error, and Fatal
  • Can log to: File, Database, Windows Event Log, Email, several other sources, or any combination of these
  • Set maximum log file size, number of file rollovers, etc
  • Configurable log output (date/time format, log source, etc)
  • Dynamic configuration: Make changes on-the-fly, without re-starting your application

The Log Manager uses an XML Configuration file. The configuration is easily readable and updateable while retaining the flexibility to express all configurations. fcSDK ships with several sample logging configuration files.

Setting up Log Manager

  1. Copy one of the sample logging configuration files from your fcSDK installation directory to an appropriate working directory.
  2. Edit the sample logging configuration file as appropriate for your needs. For example, if you are logging to a file, you'll probably want to set the File param of the RollingFileAppender entry to tell the Log Manager the path and filename of where you want your log file to be located.

    Refer to the Logging Config File Samples documentation for more details on and examples of logging configuration files.
  3. Tell LogManager which logging config file to use. This can be accomplished in one of two ways:
    1. Set the fchoice.logconfigfile application setting in your application configuration (.config) file (see Configuring fcSDK for more information on configuring fcSDK).
    2. Programmatically set the LogConfigFilePath property of LogManager before initializing ClarifyApplication
  4. Restart your application From here on, you can make changes to the logging configuration file, and these changes will automatically be picked up by the Log Manager - there's no need to restart your app just to make a logging configuration change.

  • Logging Config File Samples
  • Configuring fcSDK


Logging Config File Samples | fcSDK Documentation

Logging Config File Samples

The fcSDK ships with multiple logging configuration sample files. The sample files are located in your fcSDK installation directory, in the /samples/logging/ directory. Each of these sample files is described in more detail below.

Logging Config File Samples

  • file_log.config Log all information to a rolling log file.
  • sql_log.config Only log SQL statements to a rolling log file.
  • largesql_log.config Only log information about large/lengthy SQL queries to a rolling log file.
  • email_log.config Send errors to an administrator via email (SMTP).
  • eventlog_log.config Log Errors to the Windows Event Log
  • single_user_log.config Log all information for one user to a rolling log file.
  • mssql_database_log.config Log all information to a custom Microsoft SQL Server database table.
  • oracle_database_log.config Log all information to a custom Oracle database table.
  • combo1_log.config Log all information to a rolling log file, log errors to the Windows Event Log, and send errors to an administrator via email (SMTP).
  • combo2_log.config Log all information to a rolling log file, and log all information for one user to a different rolling log file.

log4net Reference

Please visit the Apache Logging Services: log4net Homepage for documentation on log4net. The most important links are the Manual, the FAQ, and the Configuration Examples.


Rolling Log File | fcSDK Documentation

Rolling Log File

file_log.config

This is a very common logging configuration - log all information to a rolling log file. It uses the RollingFileAppender Appender. It will log all information to the file C:\TEMP\logs\fcflnet.log. The file written to will always be called fcflnet.log because the StaticLogFileName param is set to true. The file will be rolled based on a size constraint (RollingStyle). Up to 100 (MaxSizeRollBackups) old files of 1024 KB each (MaximumFileSize) will be kept. These rolled files will be named: fcflnet.log.1, fcflnet.log.2, fcflnet.log.3, etc...

The format of the output will be:

<timestamp> [user: <user_name>] [fcsessionid: <fcsession id>] [<level>] [<class file where error originated from>] <newline>
<tab><message><newline><newline>

Example Output:

2004-11-15 14:21:31,469 [user: joe] [fcsessionid: 1636fbda-6bbf-463d-afcc-d24a8f113da6] [INFO ] [FChoice.Common.Data.SqlHelper]
    Fill DataSet query (e592af81-14fb-48b3-ae19-0ae77b4ca457) took 0.0022 seconds.

Sample Configuration:

<log4net>
   <appender name="RollingFileAppender" type="log4net.Appender.RollingFileAppender" >
      <param name="File" value="C:\TEMP\logs\fcflnet.log" />
      <param name="AppendToFile" value="true" />
      <param name="RollingStyle" value="Size" />
      <param name="MaxSizeRollBackups" value="100" />
      <param name="MaximumFileSize" value="1024KB" />
      <param name="StaticLogFileName" value="true" />

      <layout type="log4net.Layout.PatternLayout">
         <param name="ConversionPattern" value="%d [user: %X{user}] [fcsessionid: %X{session}] [%-5p] [%c]%n	%m%n%n" />
      </layout>

   </appender>

   <root>
      <level value="all" />
      <appender-ref ref="RollingFileAppender" />
   </root>
</log4net>


Only SQL Statements | fcSDK Documentation

Only SQL Statements

sql_log.config

This configuration will log all SQL statements to a rolling log file. It uses the RollingFileAppender Appender. It will log all information from the FChoice.Common.Data namespace (which is responsible for generating SQL) to the file C:\TEMP\logs\fcflnet.log. The file written to will always be called fcflnet.log because the StaticLogFileName param is set to true. The file will be rolled based on a size constraint (RollingStyle). Up to 100 (MaxSizeRollBackups) old files of 1024 KB each (MaximumFileSize) will be kept. These rolled files will be named: fcflnet.log.1, fcflnet.log.2, fcflnet.log.3, etc...

The format of the output will be:

<timestamp> [user: <user_name>] [fcsessionid: <fcsession id>] [<level>] [<class file where error originated from>] <newline>
<tab><message><newline><newline>

Example Output:

2004-11-15 14:21:31,469 [user: joe] [fcsessionid: 1636fbda-6bbf-463d-afcc-d24a8f113da6] [INFO ] [FChoice.Common.Data.SqlHelper]
    Fill DataSet query (e592af81-14fb-48b3-ae19-0ae77b4ca457) took 0.0022 seconds.

Sample Configuration:

<log4net>
   <appender name="RollingFileAppender" type="log4net.Appender.RollingFileAppender" >
      <param name="File" value="C:\TEMP\logs\fcflnet.log" />
      <param name="AppendToFile" value="true" />
      <param name="RollingStyle" value="Size" />
      <param name="MaxSizeRollBackups" value="100" />
      <param name="MaximumFileSize" value="1024KB" />
      <param name="StaticLogFileName" value="true" />

      <layout type="log4net.Layout.PatternLayout">
         <param name="ConversionPattern" value="%d [user: %X{user}] [fcsessionid: %X{session}] [%-5p] [%c]%n	%m%n%n" />
      </layout>

   </appender>

   <root>
      <level value="OFF" />
   </root>

   <logger name="FChoice.Common.Data" additivity="false">
      <level value="info" />
      <appender-ref ref="RollingFileAppender" />
   </logger>
</log4net>


Logging Config File Samples | fcSDK Documentation

Logging Config File Samples

largesql_log.config

This configuration will log all SQL queries which meet or exceed the "Large Query" thresholds set in the configuration. For more information on how to define what constitutes a "Large Query", please see the Basic Configuration documentation. This sample uses the RollingFileAppender Appender. It will log only information related to large queries to the file c:\temp\logs\fcflnet.log. The file written to will always be called fcflnet.log because the StaticLogFileName param is set to true. The file will be rolled based on a size constraint (RollingStyle). Up to 100 (MaxSizeRollBackups) old files of 1024 KB each (MaximumFileSize) will be kept. These rolled files will be named: fcflnet.log.1, fcflnet.log.2, fcflnet.log.3, etc...

The format of the output will be:

<timestamp> [user: <user_name>] [fcsessionid: <fcsession id>] [<level>] [<class file where error originated from>] <newline>
<tab><message><newline><newline>

Example Output

2004-11-15 14:21:31,469 [user: joe] [fcsessionid: 1636fbda-6bbf-463d-afcc-d24a8f113da6] [INFO ] [FChoice.Common.Data.SqlHelper]
    Fill DataSet query (e592af81-14fb-48b3-ae19-0ae77b4ca457) took 0.0022 seconds.

Sample Configuration

<log4net>
   <appender name="RollingFileAppender" type="log4net.Appender.RollingFileAppender" >
      <param name="File" value="C:\TEMP\logs\fcflnet.log" />
      <param name="AppendToFile" value="true" />
      <param name="RollingStyle" value="Size" />
      <param name="MaxSizeRollBackups" value="100" />
      <param name="MaximumFileSize" value="1024KB" />
      <param name="StaticLogFileName" value="true" />

      <layout type="log4net.Layout.PatternLayout">
         <param name="ConversionPattern" value="%d [user: %X{user}] [fcsessionid: %X{session}] [%-5p] [%c]%n	%m%n%n" />
      </layout>

      <!-- Only large query information -->
      <filter type="log4net.Filter.StringMatchFilter">
         <param name="StringToMatch" value="Large Query: True"/>
      </filter>
      <filter type="log4net.Filter.DenyAllFilter" />

   </appender>

   <root>
      <level value="INFO" />
      <appender-ref ref="RollingFileAppender" />
   </root>
</log4net>


Logging Config File Samples | fcSDK Documentation

Logging Config File Samples

email_log.config

This configuration will send any errors statements to an administrator as an email (using SMTP). It uses the SMTPAppender Appender. The To, From, Subject and SMTPHost are required parameters. A LevelEvaluator is specified with a threshold of ERROR. This means that an email will be sent for each ERROR or higher level message that is logged.

Sample Configuration:

<log4net>
  <appender name="SMTPAppender" type="log4net.Appender.SMTPAppender">
    <param name="To" value="someone@company.com" />
    <param name="From" value="someone@company.com" />
    <param name="Subject" value="Message from First Choice Log Manager" />
    <param name="SMTPHost" value="smtp_server_name" />
    <param name="LocationInfo" value="false" />
    <param name="BufferSize" value="1" />
    <param name="Lossy" value="true" />

    <!-- only email out errors -->
    <evaluator type="log4net.spi.LevelEvaluator">
      <param name="Threshold" value="ERROR"/>
    </evaluator>

    <layout type="log4net.Layout.PatternLayout">
      <param name="ConversionPattern" value="%d [user: %X{user}] [fcsessionid: %X{session}] [%-5p] [%c]%n	%m%n%n" />
    </layout>
  </appender>

  <root>
    <level value="info" />
    <appender-ref ref="SMTPAppender" />
  </root>
</log4net>

log4net Reference

Please visit the Apache Logging Services: log4net Homepage for documentation on log4net. The most important links are the Manual, the FAQ, and the Configuration Examples.


Logging Config File Samples | fcSDK Documentation

Logging Config File Samples

eventlog_log.config

This configuration will log any errors to the Application event log on the local machine. It uses the EventLogAppender Appender. The Threshold is set to ERROR. This means that an event will be logged for each ERROR or higher level message that is logged.

Sample Configuration:

<log4net>
   <appender name="EventLogAppender" type="log4net.Appender.EventLogAppender" >
      <param name="ApplicationName" value="Dovetail Software" />
      <param name="Threshold" value="error"/>

      <layout type="log4net.Layout.PatternLayout">
         <param name="ConversionPattern" value="%d [user: %X{user}] [fcsessionid: %X{session}] [%-5p] [%c]%n	%m%n%n" />
      </layout>
   </appender>

   <root>
      <level value="all" />
      <appender-ref ref="EventLogAppender" />
   </root>
</log4net>

Setting up the event source:

If you are not getting events delivered to the event log this usually indicates a permissions problem. Basically if the event log does not exist the EventLogAppender tries to create it, but you need local administrator permissions to create event logs (just to write into the right bit of the registry). You don't need administrator permissions to log to an existing event log, but it must exist. If you are using the event log from a web application or service using the event log can be a little tricky.

A web application will run as the user account ASPNET. This account deliberately has few permissions to reduce the chances of someone hacking into the web server. While the account has permission to write to the event log it does not have permission to create event sources (registry create and write access), which are needed to write to the event log.

fcSDK ships with a sample script that will create the Event Source for you.

  • Log into Windows as an administrator
  • Edit the fc.env file in the /samples/logging/setup_event_source directory
  • Run the setup_event_source bat file

Then look in the Application Log of the Windows Event Viewer, and you should see a new error logged there.

Now that the event source has been created, web applications will be able to write to the Event Log.

log4net Reference

Please visit the Apache Logging Services: log4net Homepage for documentation on log4net. The most important links are the Manual, the FAQ, and the Configuration Examples.


Logging Config File Samples | fcSDK Documentation

Logging Config File Samples

single_user_log.config

This example will log all information for a single user to a rolling log file. It uses the RollingFileAppender Appender. It filters on the user key, so only entyries from that user will be logged. It will log all information from that user to the file c:\temp\logs\fcflnet.log. The file written to will always be called fcflnet.log because the StaticLogFileName param is set to true. The file will be rolled based on a size constraint (RollingStyle). Up to 100 (MaxSizeRollBackups) old files of 1024 KB each (MaximumFileSize) will be kept. These rolled files will be named: fcflnet.log.1, fcflnet.log.2, fcflnet.log.3, etc...

The format of the output will be:

<timestamp> [user: <user_name>] [fcsessionid: <fcsession id>] [<level>] [<class file where error originated from>] <newline>
<tab><message><newline><newline>

Example Output:

2004-11-15 14:21:31,469 [user: joe] [fcsessionid: 1636fbda-6bbf-463d-afcc-d24a8f113da6] [INFO ] [FChoice.Common.Data.SqlHelper]
    Fill DataSet query (e592af81-14fb-48b3-ae19-0ae77b4ca457) took 0.0022 seconds.

Sample Configuration:

<log4net>
  <appender name="RollingFileAppender" type="log4net.Appender.RollingFileAppender" >
    <param name="File" value="C:\TEMP\logs\fcflnet.log" />
    <param name="AppendToFile" value="true" />
    <param name="RollingStyle" value="Size" />
    <param name="MaxSizeRollBackups" value="100" />
    <param name="MaximumFileSize" value="1024KB" />
    <param name="StaticLogFileName" value="true" />

    <layout type="log4net.Layout.PatternLayout">
      <param name="ConversionPattern" value="%d [user: %X{user}] [fcsessionid: %X{session}] [%-5p] [%c]%n	%m%n%n" />
    </layout>

    <!-- Only show entries for a particular user -->
    <filter type="log4net.Filter.MDCFilter">
     <param name="StringToMatch" value="user_name_goes_here"/>
     <param name="Key" value="user"/>
    </filter>
    <filter type="log4net.Filter.DenyAllFilter" />
  </appender>

  <root>
    <level value="all" />
    <appender-ref ref="RollingFileAppender" />
  </root>
</log4net>

log4net Reference

Please visit the Apache Logging Services: log4net Homepage for documentation on log4net. The most important links are the Manual, the FAQ, and the Configuration Examples.


Logging Config File Samples | fcSDK Documentation

Logging Config File Samples

mssql_database_log.config

This will log all information to a custom Microsoft SQL Server database table. It uses the ADONetAppender Appender. It will log all information to the Log table. The events are written in batches of 100 (BufferSize). You should set the following parameters in the ConnectionString parameter:

  • database server
  • database name
  • user
  • password

Keep in mind that this is a direct database connection - it does not use the Application (Clarify or fcCRM) encrypted password.

You will need to first create this custom database table - refer to the ADONetAppender Appender documentation for the database table definition.

Sample Configuration:

<log4net>
  <appender name="ADONetAppender" type="log4net.Appender.ADONetAppender">
    <param name="BufferSize" value="100" />
    <param name="ConnectionType" value="System.Data.SqlClient.SqlConnection, System.Data, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
    <param name="ConnectionString" value="data source=[database server];initial catalog=[database name];integrated security=false;persist security info=True;User ID=[user];Password=[password]" />

    <param name="CommandText" value="INSERT INTO Log ([Date],[Thread],[Level],[Logger],[Message],[Exception]) VALUES (@log_date, @thread, @log_level, @logger, @message, @exception)" />
    <param name="Parameter">
      <param name="ParameterName" value="@log_date" />
      <param name="DbType" value="DateTime" />
      <param name="Layout" type="log4net.Layout.RawTimeStampLayout" />
    </param>
    <param name="Parameter">
      <param name="ParameterName" value="@thread" />
      <param name="DbType" value="String" />
      <param name="Size" value="255" />
      <param name="Layout" type="log4net.Layout.PatternLayout">
        <param name="ConversionPattern" value="%t" />
      </param>
    </param>
    <param name="Parameter">
      <param name="ParameterName" value="@log_level" />
      <param name="DbType" value="String" />
      <param name="Size" value="50" />
      <param name="Layout" type="log4net.Layout.PatternLayout">
        <param name="ConversionPattern" value="%p" />
      </param>
    </param>
    <param name="Parameter">
      <param name="ParameterName" value="@logger" />
      <param name="DbType" value="String" />
      <param name="Size" value="255" />
      <param name="Layout" type="log4net.Layout.PatternLayout">
        <param name="ConversionPattern" value="%c" />
      </param>
    </param>
    <param name="Parameter">
      <param name="ParameterName" value="@message" />
      <param name="DbType" value="String" />
      <param name="Size" value="4000" />
      <param name="Layout" type="log4net.Layout.PatternLayout">
        <param name="ConversionPattern" value="%m" />
      </param>
    </param>
    <param name="Parameter">
      <param name="ParameterName" value="@exception" />
      <param name="DbType" value="String" />
      <param name="Size" value="2000" />
      <param name="Layout" type="log4net.Layout.ExceptionLayout" />
    </param>
  </appender>

  <root>
    <level value="all" />
    <appender-ref ref="ADONetAppender" />
  </root>
</log4net>

log4net Reference

Please visit the Apache Logging Services: log4net Homepage for documentation on log4net. The most important links are the Manual, the FAQ, and the Configuration Examples.


Logging Config File Samples | fcSDK Documentation

Logging Config File Samples

oracle_database_log.config

This will log all information to a custom Oracle database table. It uses the ADONetAppender Appender. It will log all information to the Log table. You should set the following parameters in the ConnectionString parameter:

  • database
  • user
  • password

Keep in mind that this is a direct database connection - it does not use the Application (Clarify or fcCRM) encrypted password.

You will need to first create this custom database table - refer to the ADONetAppender Appender documentation for the database table definition.

Sample Configuration:

<log4net>
    <appender name="ADONetAppender_Oracle" type="log4net.Appender.ADONetAppender">
        <param name="ConnectionType" value="System.Data.OracleClient.OracleConnection, System.Data.OracleClient, Version=1.0.3300.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
        <param name="ConnectionString" value="data source=[mydatabase];User ID=[user];Password=[password]" />
        <param name="CommandText" value="INSERT INTO Log (Datetime,Thread,Log_Level,Logger,Message) VALUES (:log_date, :thread, :log_level, :logger, :message)" />
        <param name="BufferSize" value="128" />
        <param name="Parameter">
        <param name="ParameterName" value=":log_date" />
        <param name="DbType" value="DateTime" />
        <param name="Layout" type="log4net.Layout.RawTimeStampLayout" />
        </param>
        <param name="Parameter">
        <param name="ParameterName" value=":thread" />
        <param name="DbType" value="String" />
        <param name="Size" value="255" />
        <param name="Layout" type="log4net.Layout.PatternLayout">
         <param name="ConversionPattern" value="%t" />
        </param>
        </param>
        <param name="Parameter">
        <param name="ParameterName" value=":log_level" />
        <param name="DbType" value="String" />
        <param name="Size" value="50" />
        <param name="Layout" type="log4net.Layout.PatternLayout">
         <param name="ConversionPattern" value="%p" />
        </param>
        </param>
        <param name="Parameter">
        <param name="ParameterName" value=":logger" />
        <param name="DbType" value="String" />
        <param name="Size" value="255" />
        <param name="Layout" type="log4net.Layout.PatternLayout">
         <param name="ConversionPattern" value="%c" />
        </param>
        </param>
        <param name="Parameter">
        <param name="ParameterName" value=":message" />
        <param name="DbType" value="String" />
        <param name="Size" value="4000" />
        <param name="Layout" type="log4net.Layout.PatternLayout">
         <param name="ConversionPattern" value="%m" />
        </param>
        </param>
    </appender>

    <root>
        <level value="all" />
        <appender-ref ref="ADONetAppender_Oracle" />
    </root>
</log4net>

log4net Reference

Please visit the Apache Logging Services: log4net Homepage for documentation on log4net. The most important links are the Manual, the FAQ, and the Configuration Examples.


Logging Config File Samples | fcSDK Documentation

Logging Config File Samples

combo1_log.config

This example shows how to log to multiple appenders:

  • Log everything to a rolling log file
  • Log errors to the Windows Event Log
  • Send errors to an administrator via email

Sample Configuration:

<log4net>
  <appender name="RollingFileAppender" type="log4net.Appender.RollingFileAppender" >
    <param name="File" value="C:\TEMP\fcfl.net.compat\fcflnet.log" />
    <param name="AppendToFile" value="true" />
    <param name="RollingStyle" value="Size" />
    <param name="MaxSizeRollBackups" value="100" />
    <param name="MaximumFileSize" value="1024KB" />
    <param name="StaticLogFileName" value="true" />

    <layout type="log4net.Layout.PatternLayout">
      <param name="ConversionPattern" value="%d [user: %X{user}] [fcsessionid: %X{session}] [%-5p] [%c]%n  %m%n%n" />
    </layout>

  </appender>

  <appender name="EventLogAppender" type="log4net.Appender.EventLogAppender" >
    <param name="ApplicationName" value="Dovetail Software" />
    <param name="Threshold" value="error"/>

    <layout type="log4net.Layout.PatternLayout">
      <param name="ConversionPattern" value="%d [user: %X{user}] [fcsessionid: %X{session}] [%-5p] [%c]%n  %m%n%n" />
    </layout>
  </appender>

  <appender name="SMTPAppender" type="log4net.Appender.SMTPAppender">
    <param name="To" value="someone@company.com" />
    <param name="From" value="someone@company.com" />
    <param name="Subject" value="Message from First Choice Log Manager" />
    <param name="SMTPHost" value="smtp_server_name" />
    <param name="LocationInfo" value="false" />
    <param name="BufferSize" value="1" />
    <param name="Lossy" value="true" />

    <!-- only email out errors -->
    <evaluator type="log4net.spi.LevelEvaluator">
      <param name="Threshold" value="error"/>
    </evaluator>

    <layout type="log4net.Layout.PatternLayout">
      <param name="ConversionPattern" value="%d [user: %X{user}] [fcsessionid: %X{session}] [%-5p] [%c]%n  %m%n%n" />
    </layout>
  </appender>

  <root>
    <level value="all" />
    <appender-ref ref="RollingFileAppender" />
    <appender-ref ref="EventLogAppender" />
    <appender-ref ref="SMTPAppender" />
  </root>
</log4net>

log4net Reference

Please visit the Apache Logging Services: log4net Homepage for documentation on log4net. The most important links are the Manual, the FAQ, and the Configuration Examples.


Logging Config File Samples | fcSDK Documentation

Logging Config File Samples

combo2_log.config

This example shows how to log to multiple appenders:

  • Log everything to a rolling log file
  • For one particular user, log to a different rolling log file

Sample Configuration:

<log4net>
  <appender name="RollingFileAppenderUser" type="log4net.Appender.RollingFileAppender" >
    <param name="File" value="C:\TEMP\fcflnet_user.log" />
    <param name="AppendToFile" value="true" />
    <param name="RollingStyle" value="Size" />
    <param name="MaxSizeRollBackups" value="100" />
    <param name="MaximumFileSize" value="1024KB" />
    <param name="StaticLogFileName" value="true" />

    <layout type="log4net.Layout.PatternLayout">
      <param name="ConversionPattern" value="%d [user: %X{user}] [fcsessionid: %X{session}] [%-5p] [%c]%n	%m%n%n" />
    </layout>

    <!-- Only show entries for a particular user -->
    <filter type="log4net.Filter.MDCFilter">
      <param name="StringToMatch" value="user_name_goes_here"/>
      <param name="Key" value="user"/>
    </filter>

    <filter type="log4net.Filter.DenyAllFilter" />
  </appender>

  <appender name="RollingFileAppender" type="log4net.Appender.RollingFileAppender" >
    <param name="File" value="C:\TEMP\fcflnet.log" />
    <param name="AppendToFile" value="true" />
    <param name="RollingStyle" value="Size" />
    <param name="MaxSizeRollBackups" value="100" />
    <param name="MaximumFileSize" value="1024KB" />
    <param name="StaticLogFileName" value="true" />

    <layout type="log4net.Layout.PatternLayout">
      <param name="ConversionPattern" value="%d [user: %X{user}] [fcsessionid: %X{session}] [%-5p] [%c]%n	%m%n%n" />
    </layout>
  </appender>

  <root>
    <level value="all" />
    <appender-ref ref="RollingFileAppender" />
    <appender-ref ref="RollingFileAppenderUser" />
  </root>
</log4net>

log4net Reference

Please visit the Apache Logging Services: log4net Homepage for documentation on log4net. The most important links are the Manual, the FAQ, and the Configuration Examples.


Data Restrictions | fcSDK Documentation

Data Restrictions

Introduction

The fcSDK includes the Dovetail Data Restriction Technology. Dovetail Software has shipped a thick client product called "Data Restriction Tool," (RES). RES is a product that allows you to segregate your Clarify database so that different sets of users can use the same forms (and customizations) to see different sets of data in the database. This can include any Clarify items such as cases, sites, contacts, parts, etc.

For example, suppose you have two different groups that support different product lines. You might set up RES so that the users in group 1 can only see group 1's sites, contacts, solutions, cases, and parts. Likewise, group 2 would only see their data. For any of the users, they seem to be using base Clarify, but the data that comes up in the forms is based on their restriction group.

The problem with the thick client product is that it has to be implemented with a large number of small customizations on the various Clarify forms. It works well, but it is a very large and complex product.

RES had to be implemented the way it was because there is no other way to implement it (given Clarify's thick client implementation). Further, RES cannot use Clarify's Secure Query, as that technology is far too limited to be useful for a full data restriction.

NOTE: The thick-client version of RES is a separate product that you must purchase from Dovetail Software if you wish to use it.

Restriction in The fcSDK

The fcSDK fully addresses these problems. Using a simple database-based scheme, fcSDK allows you to put restrictions on any database table or view. When you place these restrictions, they are entered once (in new database tables provided with this product).

This means that every time you perform a query or an update using the fcSDK, it determines if that table or view is restricted, and automatically modifies the SQL for you. This has one very profound consequence: No form customization is required to use restrictions.

Basically, if you enter restrictions (once) in the database, every time you use the fcSDK, you will automatically have data restriction working for you. This makes it simple, and easy to use.

NOTE: If you do not wish to use data restriction, do not import the data restriction tables into the schema. The fcSDK is smart enough to detect this. If you do this, you will not occur any additional RES overhead as you use the fcSDK.

NOTE: You must login to the fcSDK as a user to use data restriction. If you log in as a contact, data restriction is automatically turned off.

Restriction Architecture

A restriction set is defined as a set of up to five levels of restriction for an object. The objects with restriction sets are commonly the following:

  • employee
  • site
  • queue
  • part number
  • script
  • action item (task)
  • lead
  • opportunity
  • dialogue
  • literature request
  • solution

However, you can restrict any objects you want, in any way that you want. It should be noted that many objects in Clarify (such as case and contact), can be best restricted by using a common object (site in this situation). If you do not understand how to model your restrictions, please contact Dovetail Software.

An administrator starts by creating, using the supplied GUI, a set of restrictions that will be given to the users of Clarify. There can be as many restriction groups as desired, or only a few. It is solely dependent on how each administrator wishes to partition their data as to how restriction groups are set up. Setting up restriction groups well is the key to this product!! If you need help with setting up these groups, please contact Dovetail Software. The supplied Data Restriction GUIs are found in the fcAdmin module shipped with the fcSDK.

Most employees/users will be placed in just one restriction group. That is, the data they should be able to view and modify. But there are times (for examples, managers) where an employee may need to spend time working on different sets of data. In this case, they should be added to multipile restriction groups. But even when a user is placed in multiple groups, only one of those groups can be active at a time. The user can only view/modify data for one restriction group, and if they want to modify/view data from a different group, they have to switch the group they are in (via the provided GUI).

An administrator will assign the restriction group(s) for each user on the More Information page of the Employee form in Policies & Customers. The administrator can set the group(s) for the user, and the current (default) group for that user. For most users that will be just one group.

While only a small number of objects are restricted (see above), all of the objects in Clarify are essentially restricted – using the base restricted objects. For example, contacts are restricted based on the site(s) at which they are located. So even though the product does not place restriction fields on the contact (or case) objects directly, the end-user will still see those as a restricted object.

As mentioned before, RES works “under the covers.” So, a user who creates a new site will automatically give that site their current restrictions just as a part of creating that site. After that, the site will only be visible to people who have restrictions to see the site.

RES and fcQuery

Data Restriction is also used within fcQuery. Each time a query is executed, the fcQuery application determines if that table or view is restricted, and automatically modifies the SQL for you. See the section title Manage fcQuery Objects later in this docuemtn for more information on fcQuery.

A RES Example

Suppose you have two customer service representatives in your company; emp1, who takes care of customers for Joe's Clam Shack (JCS) and emp2, who takes care of customers for company Bubba's Bait Shop (BBS).

Now suppose that in your database, you want sites s1, s2, and s3 as customer sites for JCS , and sites s4, s5, and s6 as customer sites for BBS.

The administrator can set the first level restriction of emp1 to be JCS, and the first level restriction of emp2 to be BBS. When emp1 creates new sites s1, s2, s3, their level 1 restrictions will automatically be set to JCS (because a site gets the same restriction set as its creator). Likewise for sites s4, s5, s6 for emp2 and BBS.

Now when emp1 presses the Find Caller button on the new case screen he will only see contacts for sites s1, s2, s3. If emp2 performs the same operation, he will only see contacts from sites s4, s5, and s6.

Now you may have a manager (emp3) who wants to be able to switch back and forth, and see data from either emp1's or emp2's customers from time to time. The system administration can set up emp3's account so that he (emp3) has two restriction sets (one set has level 1 = JCS and the other set has level 1 = BBS) and can switch back and forth between them. Only one set can be active at any time.

It is also possible to break down the restriction sets into finer distinctions by using levels two and three of the restriction sets. Say you have another employee (emp4) who only deals with people from Joe's Clam Shack eastern region. His restriction set would look like level 1 = JCS, level 2 = East. You may have yet another employee, emp5, who deals with Joe's Clam Shack western region. His restriction set would be level 1 = JCS, level 2 = West. There might be a site s7 with restriction set JSC/East. emp4 has access to that site but no others. emp1 also would have access to site7 because he has access to any objects whose level 1 restriction is JCS.

Administration Support

The administration of RES has traditionally been performed in the Clarify Classic Client. These traditional forms are now incorporated into the fcAdmin web application. For more information on these GUIs, please see the fcAdmin sections below.

If a user belongs to multiple restriction groups, you can use the FCSession method ChangeResGroup to change the current restriction group for that user.

Restricting Your Database

The mechanism for modifying your restrictions is to modify the two restriction tables provided with this product. A sample restriction file is provided with this product. It can be modified, and imported (using dataex).

There are two fundemental operations that the fcSDK must perform for restriction to work. The first is that when new rows are added to restricted tables, the fcSDK must automatically add restrictions to that new row for you. For example, if the site table is restricted, you want the fcSDK to add the current user's restriction to each new site row added to the database.

This is accomplished with the “table_res_tbls” table. Each Clarify table that is to be restricted must have one row added to this table. In the “table_res_tbls” row you will enter the table name and number, as well as the names of the 1-5 restriction fields.

Dovetail Software recommends that you use our convention of “x_res1, x_res2…”, but you may choose your own.

For example, the following is a sample dataex object to restrict the site table:

OBJECT TYPE = "res_tbls", NAME = "site_tbl"
UNIQUE_FIELD = tbl_num
  FIELDS
    tbl_num = 52;
    tbl_name = "site";
    res1 = "x_res1";
    res2 = "x_res2";
    res3 = "x_res3";
    res4 = "x_res4";
    res5 = "x_res5";
  END_FIELDS
END_OBJECT NAME = "site_tbl"

NOTE: For each table you restrict, you MUST add the corresponding columns to the Clarify database table.
NOTE: You can enter restrictions for tables (such as the one above) either in the fcAdmin GUI, or with DataEx (or Dovetail's DIET product).

The other operation that the fcSDK res-enables is querying. For each table or view (you often will data-restrict your views), you will enter one or more rows to the “table_res_sql_clause” table. Again, a sample file is provided, and you must edit it and import it with data exchange.

Each row in this table refers to one “where” clause that will be added to the SQL statement every time you query that table or view. Each of these clauses will be “Anded” to whatever SQL the user generates via their FCGeneric object.

You must use valid SQL syntax. For example, if you wanted all site_view queries to only show sites in states that start with 'New', you could add a clause such as “state like 'New%'”.

The table only has four columns: table name, table number, field name, and the SQL clause. In addition to using any of the columns of the table, you may use five special reserved words to represent the user's current restriction levels. They are (with pipes surrounding them), “|RESTRICTION1|, |RESTRICTION2|…”. When the fcSDK sees one of these keywords, it substitutes the current user's restriction level for the keyword. If the user doesn't have a particular restriction level (it is empty), the fcSDK will not add the clause for you.

The field name (fld_name) is optional and simply provides a cue, for optimization purposes, to the fcSDK about what fieldname is involved in the replacement done within the clause.

For example, suppose that Joe is in a restriction group that only has two levels of restriction, and we only want to restrict for him queries on the site table.

OBJECT TYPE = "res_sql_clause", NAME = "site_clause1"
  FIELDS
    tbl_num = 52;
    tbl_name = "site";
    fld_name = "x_res1";
    clause = "x_res1 = |RESTRICTION1|";
  END_FIELDS
END_OBJECT NAME = "site_clause1"

OBJECT TYPE = "res_sql_clause", NAME = "site_clause2"
  FIELDS
    tbl_num = 52;
    tbl_name = "site";
    fld_name = "x_res2";
    clause = "x_res2 = |RESTRICTION2|";
  END_FIELDS
END_OBJECT NAME = "site_clause2"

The above rows tell the fcSDK that any query on the site table should add 1st and 2nd level restriction clauses, assuming that the user is currently in a restriction group.

To best use the fcSDK and RES, you would add rows to the res_sql_clause table for any and all tables and views that your application queries for data.

NOTE: Neither the SqlHelper nor the FCSqlExec compatibility objects are RES-enabled. These objects are used for direct queries to the database without any business logic or Clarify semantics.
NOTE: For more information about RES, please request the RES end-user document (for the thick client product) from Dovetail Software.


Time Zone Handling in the fcSDK | fcSDK Documentation

Time Zone Handling in the fcSDK

The fcSDK is "time zone aware" and can automatically convert date and time values into various time zones for you. In this mode, all time zones that you see (in your generic objects) are in the local time zone. The fcSDK automatically converts all date/time fields so that they are written to the database in the server's time zone. This way, different clients in different parts of the country (or world) will all write consistent date/times to the database. When you retrieve data via the fcSDK, all of the date/time fields will be converted to your local time zone, so that it appears correct to the application user.

Setting up time zone conversion is easy. There are three steps necessary for the fcSDK to display dates and times in the correct time zone for users using different time zones:

  • ClarifyApplication.ConvertTimeZone Property ClarifySession has a property: ConvertTimeZone. If this property is set to "true" (which is the default), the fcSDK will perform time zone conversions for you any time date values are read from or stored to a ClarifyGeneric instance.

  • ClarifyApplication.ServerTimeZone Represents the time zone the server will use for time zone conversion operations. By default the database default time zone will be used.

    The default ServerTimeZone can be changed by updating the time_zone record and refreshing the application cache:

    1. Update table_time_zone set is_default = 0
    2. Update table_time_zone set is_default = 1 where name = '<default_time_zone_name>'

    If you wish override the ServerTimeZone it is recommended that you do so before creating any ClarifySession objects.

  • ClarifySession.LocalTimeZone When using the fcSDK, your application can specify on each session which time zone the user is in (usually this is done on the login form/web page). Simply set the LocalTimeZone property on the session to the appropriate time zone and date values will get converted according to the setting in the ConvertTimeZone property.

The date/time conversion handles all aspects of the fcSDK. For example, you can use the "NOW" date/time constant (ClarifyGeneric.NOW_DATE), and it will be converted properly. In addition, if you modify a "Change Field", the "Change Date" field will also be updated to the database properly converted.

For example, the following C# and Visual Basic.NET code illustrates the process.

Example

This example shows how to set the server time zone and the user session time zone.

[C#]

// Create and initialize the ClarifyApplication instance
ClarifyApplication app = ClarifyApplication.Initialize();
app.ServerTimeZone = app.LocaleCache.TimeZones[ "Pacific Standard Time", true ];

// Create a session using a different time zone
ClarifySession session = app.CreateSession("sa", "sa", ClarifyLoginType.User);
session.LocalTimeZone = app.LocaleCache.TimeZones[ "Eastern Standard Time", true ];

//Next, create the dataset which will contain the generics
ClarifyDataSet dataSet = new ClarifyDataSet(session);

// Now use **fcSDK** as normal
ClarifyGeneric gCase = dataSet.CreateGeneric("case");
gCase.AppendFilter( "id_number", StringOps.Equals, "55" );
gCase.Query();

// Will be shown in EST, 3 hours off of the time in the DB field
Debug.WriteLine( gCase[0]["creation_time"] );

ClarifyDataRow row = gCase.AddNew();

// This will be stored in the database three hours earlier (9:00)
row["x_date_field"] = new DateTime(2002, 1, 1, 12, 0, 0);
row.Update();

// You wouldn't do this normally, but now the date/time written to the
// db would be 12:00 (unconverted). Again, this is not recommended!
session.ConvertTimeZone = false;
ClarifyDataRow noConvertRow = gCase.AddNew();
noConvertRow["x_date_field"] = new DateTime(2002, 1, 1, 12, 0, 0);
noConvertRow.Update();

[Visual Basic]

' Create an initialize the ClarifyApplication instance
Dim app As ClarifyApplication = ClarifyApplication.Initialize()
app.ServerTimeZone = app.LocaleCache.TimeZones("Pacific Standard Time", True)

' Create a session using a different time zone
Dim session As ClarifySession = app.CreateSession( "sa", "sa", ClarifyLoginType.User)
session.LocalTimeZone = app.LocaleCache.TimeZones( "Eastern Standard Time", True )

'Create the dataset which will contain the generics
Dim dataSet As New ClarifyDataSet(session)

' Now use **fcSDK** as normal
Dim gCase As ClarifyGeneric = dataSet.CreateGeneric("case")
gCase.AppendFilter( "id_number", StringOps.Equals, "55" )
gCase.Query()

' Will be shown in EST, 3 hours off of the time in the DB field
Debug.WriteLine( gCase(0)("creation_time") )

Dim row As ClarifyDataRow = gCase.AddNew()

' This will be stored in the database three hours earlier (9:00)
row("x_date_field") = New DateTime(2002, 1, 1, 12, 0, 0)
row.Update()

' You wouldn't do this normally, but now the date/time written to the
' db would be 12:00 (unconverted). Again, this is not recommended!
session.ConvertTimeZone = false
Dim noConvertRow As ClarifyDataRow = gCase.AddNew()
noConvertRow("x_date_field") = New DateTime(2002, 1, 2002, 12, 0, 0)
noConvertRow.Update()


Enabling Storage of Unicode Data | fcSDK Documentation

Enabling Storage of Unicode Data

Introduction to Unicode and the fcSDK

The fcSDK is fully Unicode-ready. Fields in your database can be flagged as Unicode fields and the fcSDK will process data in these columns correctly. Having Unicode-enabled columns adds several important features to your application, such as:

  • Displaying forms/pages/messages in each user's native language.
  • Allowing users to enter data in key fields (such as log fields, or name/address fields) in the specific language that is appropriate.
  • Displaying unicode data on web pages

Once configured, having Unicode-enabled columns could allow a user in France to see a “french” version of your web pages (including labels, lists, messages, etc), and enter log data in French. Another user, in Japan, can use Kanjii, a user in Germany can do the same in German, and a user in Israel can do the same in Hebrew (Unicode supports double-byte and/or right-to-left languages as well). They can do this at the same time against the same database. This can be a very powerful feature, and very useful to your users.

Unicode is not a one-shot solution, however. There are many complex issues involved in a Unicode-enabled system, and enabling the system is not appropriate for every customer. Below is a short list of some of the short-comings of such a system:

  • Unicode fields are a bit slower than non-Unicode ones. You should only add this functionality to fields that need it. A shotgun approach is not necessarily best
  • Most Clarify applications, including the thick client, are not currently Unicode-enabled. Thus, if you enter a note log (for example) in Kanjii, it will show up as question marks in the thick client
  • Not all of your users will be able to read the data entered by other users. Remember that Unicode is not a translation service. What the customers enter is what is stored in the database, and later displayed to others as it was entered.

Thus, it is important to carefully decide what data should be Unicode-enabled, and which should not be. For help on this, please feel free to contact Dovetail Software.

NOTE: It is very important to realize that Unicode is completely optional. There is no requirement to use this feature. We recommend that you use it only if you need it, and sparingly.

Configuring the Database for Unicode Columns

The following sections detail the steps you must follow to install Unicode support on your database. It is crucial that you read and understand all of the sections, and follow each of the steps listed.

Set Up a Test Database

Since this is a major change to an existing database, Dovetail highly recommends you make a backup of your current database and create a seperate test database on a seperate server if possible. All changes should be practiced on this test database before making another backup of and applying the changes to the production database.

Verifying Your Database Server

Before you can perform any of the steps below you must verify that your database server will allow storing Unicode characters. You must check the codepage/character set of your database server. The process for this is different with different database systems, and even different versions of the same DB system. You must insure that the database can handle a Unicode "code page". This is usually UTF-8.

Please see the documentation for your database server for more details.

Add Unicode Flag Column to ADP Schema

Before you can change any fields to be Unicode fields, you must first set the database up to be an fcSDK Unicode-enabled database. This is very easy to do, and is performed as follows:

  • You must execute two SQL statement to add a new column to the adp_sch_info table (and initialize it). The fcSDK uses the existence of this column to determine if the database is Unicode-enabled, or not. If the column is not added then the fcSDK will not perform Unicode processing. Dovetail Software chose to add this new adp column to allow you the flexibility to have only certain columns be unicode strings. There is simply no reason (as Clarify does with Version 11.1+) to make all of the strings in your database be Unicode.
  • Execute the following SQL statements against the current database (test or production depending upon how far along in the process you are):
alter table adp_sch_info add fc_flags int

-and-

update adp_sch_info set fc_flags = 0

NOTES:

  • These statements will work against both Microsoft™ SQL Server and Oracle™.
  • Adding this column will NOT affect the functioning of base Clarify in any way. The column will be ignored by all Clarify applications.
  • As of version 11.1, Clarify offers you the option of creating a "Unicode" database. Even if you take that option you must still execute the above statements.

Convert Specific Columns

Now that the database itself is enabled for Unicode processing you must convert individual columns to support Unicode data. For each column to be converted, you must perform the following two steps:

  • Alter the column definition in the database [see NOTE]
  • Mark it as a Unicode column in adp_sch_info

NOTE: As of Clarify version 11.1, you can create a database (with the makedb utility) to be a "Unicode" database. If you follow this process, all of your string fields will be Unicode fields. The fcSDK has been designed to work with this type of database. If you have built your database in this manner, you do not have to do the first step above for each unicode field. However, the second step is still required.

Step 1: Altering the column definition

For each string column that you wish to make a Unicode field, you must execute the following SQL statement:

  • For SQL Server:

alter table table_xxxx alter column yyyy nvarchar(length)

  • For Oracle:

alter table table_xxxx modify yyyy nvarchar2(length)

where:

  • table_xxxx Is the name of the table
  • yyyy Is the name of the column to modify
  • length Is the original length of the column

For example, suppopse that you wish to convert the table_contact first_name and last_name fields to be Unicode enabled. You would enter the following statements to alter the column definitions:

  • For SQL Server:

alter table table_contact alter column first_name nvarchar(30) alter table table_contact alter column last_name nvarchar(30)

  • For Oracle:

alter table table_contact modify first_name nvarchar2(30) alter table table_contact modify last_name nvarchar2(30)

NOTE: Even though the columns will be bigger to handle the Unicode data you do not change the size of the column definition – the database will handle that for you. The column still holds only 30 characters of data, even though some of them may take multiple bytes for the database to store.

NOTE: Long varchar columns (text columns, in Clarify parlance), are a bit trickier to modify. You may not use an alter statement with them. To modify those columns you must perform the following steps:

  • Create a temporary table with the same column definitions as the original table, except that the data type for the text columns is now an “ntext” data type. Make sure that indexes are defined for the new table as well
  • With SQL, copy all of the data from the old table to the new table
  • Delete the old table
  • Rename the new table to the name of the old table
  • (For Oracle only). Make sure that the public synonyms are correct

Step 2: Mark as a Unicode Column

Once you have converted the column in the database it is very easy to mark a given column as a Unicode column. Perform the following SQL for each column you are converting:

update adp_sch_info set fc_flags = 1 where field_name = 'yyyy'
and type_id = (select type_id from adp_tbl_name_map where type_name = 'xxxx')

Where:

  • yyyy is the column name
  • xxxx is the table name (without the "table_" prefix)

Test Specific Columns

Test your new columns to insure that they handle Unicode data. For a sample of how to do this, please see the strings.asp and grid_string.asp pages included with the fcSDK.

Also, make sure that your machine is capable of entering and displaying the Unicode characters you wish to display. For Windows users, please see the Regional Sections/Regional Keyborards help items for more details.

Using Your Unicode-enabled fcSDK Database

The fcSDK can support Unicode data transparently. No code changes are necessary to enable the fcSDK to work with Unicode data.

There are other considerations to take when working with Unicode data within your application:

  • If you are writing ASP web pages that will include Unicode characters, it is recommended that you properly code the pages to handle Unicode. For example, in the ASP pages that Dovetail Software ships, the following is the first line of each web page (to insure that it is using the proper codepage):

<%@ Language="JavaScript" codepage=65001 %>

The following tag is included right after the tag to insure that the proper character set is used:<p> <p><code><meta http-equiv="Content-Type" content="text/html; charset=UTF-8"></code></p> <ul> <li>If you are writing web pages using the Microsoft ASP.NET Framework, you should include the following parameters in your "@ Page" directive at the top of the ASPX pages:</li> </ul> <p><code><%@ Page ... CodePage="65001" ResponseEncoding="utf-8" %></code></p> <ul> <li>If you are using a programming language that does not properly support Unicode (such as ClearBasic) to access the <strong>fcSDK</strong> Compatibility Layer, then it does not matter what you do with the <strong>fcSDK</strong> – the characters will not display properly.</li> </ul> <p><strong>NOTE:</strong> All .NET languages (such as C# and Visual Basic.NET) use the .NET Framework which is Unicode-enabled throughout. This problem is only a concern when using the Compatibility Layer with legacy programming environments.</p>


Making World-Ready Applications with the fcSDK | fcSDK Documentation

Making World-Ready Applications with the fcSDK

Introduction to Internationalization and the fcSDK

The fcSDK is globally aware. It takes advantage of the comprehensive globalization/internationalization support in the Microsoft™ .NET Framework (for more information on the globalization and localization support in the .NET Framework, please read the guide 'Developing World-Ready Applications' in the .NET Framework SDK documentation). This allows the fcSDK to easily support multiple cultures and locales.

When developing world-ready applications, one of the primary concern that developers face is interpreting user input string/text data into strongly typed data types. This is especially important with number and date/time formats. A good guideline for developing a world-ready application is to handle these conversions and interpretations as soon as possible after the user has submitted the data. This usually means processing the conversion in the UI layer (web application or windows application) before passing the data further down into libraries and the data access layer.

The fcSDK follows this design guidelines and only takes strongly-typed data structures such as the .NET Framework intrinsic types "Int32", "DateTime", "Decimal", etc. It is the responsibility of the application using the fcSDK to handle the culturally-sensitive conversions of these values.

Since the fcSDK does not do any conversions of types from strings, there are no internationalization issues caused by the fcSDK itself in terms of storing or retrieving values to or from the database. Since the fcSDK works directly with the Clarify™ database and trusts that the data is consistent and culturally sensitive, it is possible that bad data in the database could be returned in a culturally insensitive way. If you input data into your database using means other than the fcSDK, you must be sure that these other means are doing so in a culturally-sensitive way.

Using the fcSDK to help build world-ready applications

The fcSDK provides some convenience features and some customizability to assist you in developing world-ready applications.

  • Persist the Culture Setting for each User's Session The ClarifySession object has a property, CurrentCulture, which allows you to store which culture the user selected to use for the current UI. The application using the fcSDK is required to manage this value. The fcSDK does not use this value for anything except when called through the Compatibility Layer. In this case, all strings passed in for number and date fields will be converted to real values according to the format of the culture specified by the CurrentCulture property.

  • Customizing Exception Messages Thrown by the fcSDK By default, the fcSDK will throw U.S. English (en-US) error messages in the format of: "(errnum) Description" where errnum is the unique error number for this exception and description is an explanation of the reason the exception was thrown.

      These error messages can be customized by using the fc_string table. The **fcSDK** install guide details installing optional schema modifications. One of these involves adding a 'name' column to the fc_string table. If you apply this schema change, you can begin adding customized versions of error messages for individual cultures. You can customize the default en-US messages and/or add messages for other cultures as well. The **fcSDK** will attempt to load an error message for the user according to the setting of the CurrentCulture property on the Session. If an error message cannot be found for this locale and error number combination, an attempt will be made to load a custom en-US message. If no custom en-US message is found, then the default hard-coded en-US message will be used.<br><br>Each error message has a unique error number and error string identifier such as 17248 and "FOUND_LOGIN_FROM_FCAPP_DISABLED". The fcSDK ships with a DAT file containing all the error messages. You can load all the messages or just the ones you wish to customize. Locate the one in the fc_string table you wish to modify and change the message as appropriate.<br><br>Assuming the entire DAT file was loaded into the database, you can customize a particular message by issuing a simple SQL statement. For example, to customize error ID 17248:

  ```
  update table_fc_string set string = 'My Custom Message', nstring = 'My
  Custom Message' where id = 17248
  ```

  Alternatively, you can edit the DAT file before importing and then import many changes at once.<br><br>**NOTE:** The error message ID will always appear in the exception message. This cannot be customized or removed. This is to assist First Choice Support troubleshoot error messages which might be in languages other than English. Given the error number, the English message can be retrieved from the DAT file of all the error messages.

  • Localizing Strings Using the StringCache If your database has the 'fc_strings' table loaded, you can use the StringCache class to access localized strings from this table. The fcSDK itself uses this table and the StringCache class to localize its own exception messages. If you do not have this table, the schema is located in the "fcflnet_schema.sch" file located in the "schema" folder in the fcSDK installation path.

    In order to start using StringCache to load localized messages, the fc_string schema must be added to your Clarify database instance. Once the new schema is loaded, the localized strings can be entered or imported using normal Clarify tools (like dataex). Next, delete the fc_cache dir before restarting your application to ensure that the fcSDK will detect the new schema changes. When the application is restarted, the fcSDK will then automatically detect the presence of the fc_string table and cache the contents.

    NOTE: The fcSDK expects the format of the 'locale' field in the fc_string table to be XX_YY, xx_YY, or xx_yy where ''xx' is the two-letter ISO 639-1 country/regoincode2 of the country or region for which this string is intended and 'yy' is the two-letter code derived from the ISO 3166 specification. In cases where a two-letter language code is not available, the three-letter code derived from ISO 639-2 is used; for example, the three-letter code 'div' is used for cultures that use the Dhivehi language. For more information on what are acceptable culture specifiers, please consult the .NET Framework SDK documentation on the CultureInfo class.

    Once the schema is properly loaded, the strings are entered, and the fcSDK has reloaded its cache, the strings can be accessed by using one of the overloads of the FindFCString method on the StringCache object. These methods will attempt to locate the string with the specified ID or NAME for the specified culture. If none exists for that culture, it will try to locate the same string for culture 'en_US'. If none is found, it will finally try for culture 'en'. If no string was found in either the desired culture or in any of the fallback cultures, $$NULL$$ will be returned. The caller to this method must be prepared to deal with the possibility that a string may be missing. The fcSDK will log a warning when it cannot find a requested string to help track down missing string resources.


Overview of the fcSDK Compatibility Layer | fcSDK Documentation

Overview of the fcSDK Compatibility Layer

General

For the last few years, many customers have been successfully using the First Choice Foundation Library (FCFL) and the FCFL API Toolkits for their Clarify programming needs. The fcSDK is the next generation framework for the Clarify environment - built on top of Microsoft's .NET Framework. The fcSDK has been written, from the ground up, to use the .NET framework to maximize your performance, scalability, and ease of programming.

We understand that many existing First Choice customers will not be able to switch over to the fcSDK immediately, due to the large number of applications already written to FCFL and the FCFL API Toolkits. For example, the web pages in our fcClient thin client are written to the FCFL API.

To address these issues, the fcSDK has been written with a special "Compatibility Layer", which allows existing code that uses FCFL and the FCFL API Toolkits (such as fcClient) to work with the fcSDK with virtually no code changes -- essentially allowing fcSDK to be a "plug and play" replacement for FCFL and the toolkits. There are very few changes that will affect existing FCFL/toolkit code. Most of the changes are minor, and should not affect users at all.

This section of the FCFL.NET documentation captures the differences between FCFL and the FCFL.NET Compatibility Layer.

Notable exceptions

ProgID, CoClass ID (CLSID), and Interface ID (IID) changes: As the compatibility objects are actually new objects with a different ProgID, CLSID, and IID, any references an object's ProgID, CLSID, or IID directly will be affected.

Web applications typically only reference the FCApplication and individual toolkit objects' ProgIDs

Compiled windows applications (such as programs written in Visual Basic or in C/C++) typically reference the FCFL and toolkit type libraries (typelib, TLB) directly and will be affected by the fcSDK's new type libraries and GUIDs. See the detail sections for more details on the new type libraries and their new CLSID's and IID's.

Use of the FCGeneric.Records property, although still compatible, is not recommended. Refer to the FCGeneric section of this document for more details on the caveats and limitations.

Differences between FCFL and FCFL.NET Compatibility Layer:

  • FCFL/FCFL.NET Type Library Changes
  • FCApplication Object Changes
  • FCSession Object Changes
  • FCGeneric Object Changes
  • FCBulk Object Changes
  • FCSQLExec Object Changes
  • FCList Object Changes
  • MockAdoField
  • Configuration Changes

Differences between FCFL API Toolkits and fcSDK API Toolkit Compatibility Layer:

  • First Choice API Toolkit for ClearContracts
  • First Choice API Toolkit for ClearLogistics
  • First Choice API Toolkit for ClearLogistics Field Operations
  • First Choice API Toolkit for ClearQuality
  • First Choice API Toolkit for ClearSupport
  • First Choice API Toolkit for Depot Repair
  • First Choice API Toolkit for Interfaces
  • First Choice API Toolkit for ClearSales


Configuration Changes | fcSDK Documentation

Configuration Changes

fc.env Configuration

Applications using FCFL have used an fc.env file to control database and logging configuration settings. Here is an example of a classic fc.env file:

;begin fc.env file...
db_type=Oracle
db_server=Clarify
db_name=Clarify
login_name=sa
db_password=sa

While the Compatibility Layer can still be configured using an fc.env file like the one above, in the compatibility layer you can use all of the fcSDK application configuration settings for better control of the application and database settings. For example, the following fc.env file effectively replaces the previous example and disables performance counters.

;begin fc.env file...
fchoice.dbtype=Oracle
fchoice.connectionstring=Data Source=Clarify;uid=sa;pwd=sa;
fchoice.perfcountersenabled=false

Logging

Previously, FCFL employed a simple logging mechanism. The fcSDK uses a much more sophisticated logging mechanism with many more features, including:

  • Different log levels: Debug, Info, Warning, Error, and Fatal
  • Can log to: File, Database, Windows Event Log, Email, several other sources, or any combination of these
  • Set maximum log file size, number of file rollovers, etc
  • Configurable log output (date/time format, log source, etc)
  • Dynamic configuration: Make changes on-the-fly, without re-starting your application

The Log Manager uses an XML Configuration file. The configuration is easily readable and updateable while retaining the flexibility to express all configurations. The fcSDK ships with several sample logging configuration files.

Setting up Log Manager:

  1. Copy one of the sample logging configuration files from your fcSDK installation directory to an appropriate working directory.
  2. Edit the sample logging configuration file as appropriate for your needs. For example, if you are logging to a file, you'll probably want to set the File param of the RollingFileAppender entry to tell the Log Manager the path and filename of where you want your log file to be located.

    Refer to the Logging Config File Samples documentation for more details on and examples of logging configuration files.
  3. If your application uses an fc.env file, add a new entry to the fc.env file: compat_logconfigfile - The path and filename of a valid logging configuration file.

    Example:
    compat_logconfigfile=C:\fcClient\fcclient_logging.config
    Note that the FCFL logging fc.env parameters are no longer used. It doesn't hurt to leave these entries in the fc.env file - they will be ignored by the fcSDK.
    fc.env logging entries not used by fcSDK
    log_file
    sql_log_file
    sql_logging
    log_fcapp
    log_fcsession
    log_fcgeneric
    log_fcbulk
    log_fcsqlexec
  4. If your application uses FCApplication.InitializeFull rather than an fc.env file, simply set a new property on the FCFLCompat.FCApplication object: LoggingConfigFilePath - The path and filename of a valid logging configuration file

    Example:
    FCApplication.LoggingConfigFilePath = "C:\fcClient\log.config" FCApplication.InitializeFull(...)
  5. Restart your application. From here on, you can make changes to the logging configuration file, and these changes will automatically be picked up by the Log Manager - there's no need to restart your app just to make a logging configuration change.


fcSDK - FCFL.NET Compatibility Layer | fcSDK Documentation

fcSDK - FCFL.NET Compatibility Layer

MockAdoField Object

In the past, code accessing FCFL Generic Fields was in fact being returned a ADO Field object. Most developers were not aware of this as by default the return value of the ADO Field object is the field value. However, for whatever reason, some applications would use other properties of the ADO Field. To maintain compatibility we have implemented a subset of the ADO Field object called MockADOField. For more information on this matter please see FCGeneric Object Changes.

ProgID

FCFL | FCFL.NET Compatibility
N/A | FCFLCompat.MockAdoField

Interface Name, IID

FCFL | FCFL.NET Compatibility
N/A | IMockAdoField F7AED485-957A-4ad6-90C8-7D475C87F9C7

CoClass Name, CLSID

FCFL | FCFL.NET Compatibility
N/A | MockAdoField 78A3320B-100C-4225-A3C1-58C2A3E73A86

Properties

The following properties are available on the FCFLCompat.MockAdoField object.

Property | Comments
DefinedSize | The Size of the Field
Name | The Name of the Field
Type | The Type of the Field Textual fields will always return type 200 - VARCHAR even if they are non VARCHAR types such as CHAR, TEXT.
Value | The Value of the Field. This is the default property.

Example of using the MockAdoField Object

[JavaScript]

var genContact = FCSession.CreateGeneric('contact');
genContact.AppendFilter('first_name','=',"Roger");
genContact.Query();

field_value = genContact("first_name");
length = new String(genContact("first_name")).length;

WScript.Echo('Length of "' + field_value + '" = ' + length);
WScript.Echo('DefinedSize of "first_name" = ' + genContact("first_name").DefinedSize);
WScript.Echo('Field Name of "first_name"= ' + genContact("first_name").Name);
WScript.Echo('Type of "first_name" = ' + genContact("first_name").Type);
WScript.Echo('Value of "first_name" = ' + genContact("first_name").Value);

Example output:

Length of "Roger" = 5
DefinedSize of "first_name" = 30
Field Name of "first_name"= first_name
Type of "first_name" = 200
Value of "first_name" = Roger


FCApplication Changes | fcSDK Documentation

FCApplication Changes

ProgID

FCFL | FCFL.NET Compatibility
FCFL.FCApplication | FCFLCompat.FCApplication

Interface Name, IID

FCFL | FCFL.NET Compatibility
_FCApplication C32E188E-EEBC-43B4-A977-BA0D63CF9BC3 | IFCApplication 76778FF4-8666-4eba-A60A-DA8D9F743A64

CoClass Name, CLSID

FCFL | FCFL.NET Compatibility
FCApplication 6CBF6E43-D667-4A01-AE0E-D25C24F2F67D | FCApplication 96EFBAF6-4FA0-4f71-A012-910F6CF61120

Object Creation in FCFL

Using FCFL, your code would look something like the following:

[JavaScript]

var FCApp = Server.CreateObject("FCFL.fcapplication");

[Visual Basic]

Dim FCApp
Set FCApp = CreateObject("FCFL.fcapplication")

Object Creation in FCFL.NET Compatibility

Using FCFL.NET Compatibility, your code would look something like the following:

[JavaScript]

var FCApp = Server.CreateObject("FCFLCompat.fcapplication");

[Visual Basic]

Dim FCApp
Set FCApp = CreateObject("FCFLCompat.fcapplication")

Changed Properties

The following properties have changed between FCFL.FCApplication and FCFLCompat.FCApplication.

Changed Property | FCFL.FCApplication | FCFLCompat.FCApplication
base_objid | read/write | read-only
clarify_ver | read/write | read-only
ConnectionString | read/write | read-only
db_name | read/write | read-only
db_type | read/write | read-only
IsDBTraveler | read/write | read-only
IsDBUnicode | read/write | read-only
schema_rev | read/write | read-only
site_id | read/write | read-only
ServerTimeZone | FCFL sets the ServerTimeZone to the schema's default timezone during FCApp.Initialize and when UpdateCache is called. | In FCFL.NET the ServerTimeZone is set to the schema's default timezone only during application initialization.

Changed Methods

The following methods have changed between FCFL.FCApplication and FCFLCompat.FCApplication.

Changed Method | FCFL.FCApplication | FCFLCompat.FCApplication
InitializeFull The following logging parameters are ignored:
  • LogFile
  • SqlLogFile
  • fcAppLogging
  • fcSessionLogging
  • fcGenericLogging
  • fcBulkLogging
  • fcSqlExecLogging
  • NoCacheFile

Refer to the Configuration Changes section of this document for more details on configuring logging.
is_it_a_field | Parameters are ByRef | Parameters are ByVal
is_it_a_table | Parameters are ByRef | Parameters are ByVal
is_it_change_field | Parameters are ByRef | Parameters are ByVal
is_it_int_field | Parameters are ByRef | Parameters are ByVal
is_it_searchable | Parameters are ByRef | Parameters are ByVal
is_it_string_fld | Parameters are ByRef | Parameters are ByVal
is_it_unicode | Parameters are ByRef | Parameters are ByVal
is_rel_exclusive | Parameters are ByRef | Parameters are ByVal
is_rel_mandatory | Parameters are ByRef | Parameters are ByVal

New Properties

The following properties are new in FCFLCompat.FCApplication.

New Property | Comments
LoggingConfigFilePath | The path and filename of a valid logging configuration file. Refer to the Configuration Changes section of this document for more details. Note: You must set this property before calling FCApplication.Initialize for it to take effect.
DataProtectorEntropy | Essentially the "password" that was used to encrypt data protected configuration parameters. Please see Basic Configuration for Data Protection details. Note: You must set this property before calling FCApplication.Initialize for it to take effect.

New Methods

The following methods are new in FCFLCompat.FCApplication.

New Method | Comments
LogEx(string logLevel, string logMessage) | Alternate logging method that allows setting the log level. This method is similar to Logger.Log except that the log level is a string representation of the LogLevel enumeration (e.g "DEBUG", "INFO", "ERROR").


FCSession Changes | fcSDK Documentation

FCSession Changes

ProgID

FCFL | FCFL.NET Compatibility
FCFL.FCSession | FCFLCompat.FCSession

Interface Name, IID

FCFL | FCFL.NET Compatibility
_FCSession B7AEFF84-DFE5-40A5-985B-9888E2CF6949 | IFCSession 772CB7F1-F6D6-4783-9390-979DE87386C9

CoClass Name, CLSID

FCFL | FCFL.NET Compatibility
FCSession 78F7F24A-EF27-4934-8277-EEDEC1F3A684 | FCSession 906C1CC2-5CE2-456b-BF53-129336DAA394

Changed Properties

The following propertiess have changed between FCFL.FCSession and FCFLCompat.FCSession.

Changed Property | FCFL.FCSession | FCFLCompat.FCSession
Item('config_itm..') | Retrieves configuration item from database | Retrieves configuration item from FCSession cache

Changed Methods

The following methods have changed between FCFL.FCSession and FCFLCompat.FCSession.

Changed Method | FCFL.FCSession | FCFLCompat.FCSession
ChangeResGroup | Parameters are ByRef | Parameters are ByVal
CreateBulk | Parameters are ByRef | Parameters are ByVal
CreateGeneric | Parameters are ByRef | Parameters are ByVal
GetColor | Parameters are ByRef | Parameters are ByVal
GetConfigItem | Retrieves configuration item from database | Retrieves configuration item from FCApplication cache
GetItem | Parameters are ByRef | Parameters are ByVal
GetUserVersion | Parameters are ByRef | Parameters are ByVal
IsUnicode | Parameters are ByRef | Parameters are ByVal
Item | Parameters are ByRef | Parameters are ByVal
ItemCount | Parameters are ByRef | Parameters are ByVal
LoadColor | Parameters are ByRef | Parameters are ByVal
LoadUserVersions | Parameters are ByRef | Parameters are ByVal
Log | Parameters are ByRef | Parameters are ByVal
Login | Parameters are ByRef | Parameters are ByVal
RemoveAllGenericsInABulk | Parameters are ByRef | Parameters are ByVal

New Properties

The following properties are new in FCFLCompat.FCSession.

New Property | Comments
CurrentCulture | The culture to use for converting or displaying numbers, dates, and other culturally-sensitive data. This value must be a valid RFC 1766 culture/locale specifier (i.e. en-US - a lower-case two-or-three-letter ISO-639 or ISO 639-2 language code followed by a hyphen "-" then a two or three letter subculture code as defined by ISO-3166 Alpha 2). For more information on what culture specifiers are allowed and how to deal with conflict cultures and neutral cultures, please see the .NET Framework SDK documentation for the CultureInfo class.

New Methods

The following methods are new in FCFLCompat.FCApplication.

New Method | Comments
LogEx(string logLevel, string logMessage) | Alternate logging method that allows setting the log level. This method is similar to Logger.Log except that the log level is a string representation of the LogLevel enumeration (e.g "DEBUG", "INFO", "ERROR").
StartTransacion(optional string isolationLevel) | Call this method when it is desired to have FCGeneric updates and queries be under the context of a transaction. When all database operations for the transaction are complete, call CommitTransaction. Care should be taken using exception handling to invoke RollbackTransaction in the case of an error. Valid IsolationLevel parameter strings match the .Net Framework Isolation Level Enumeration
CommitTransaction() | After calling StartTransaction() this method is called when all database operations for this trasaction are complete.
RollbackTransaction() | If StartTransaction() has previously been called. This method needs to be called if for some reason the transaction cannot be committed. A rollback is necessary when an exception occurs during the lifetime of the transaction or some condition such that it is desired to return the database back to its pre-transaction state. Care should be made when using database transactions to make sure all possible paths of code protect for thrown exceptions to avoid leaving an uncompleted transactions hanging around.


FCGeneric Changes | fcSDK Documentation

FCGeneric Changes

ProgID

FCFL | FCFL.NET Compatibility
FCFL.FCGeneric | FCFLCompat.FCGeneric

Interface Name, IID

FCFL | FCFL.NET Compatibility
_FCGeneric 582D426C-696F-44A2-897C-DC6767BF29C9 | IFCGeneric 545582EE-2D64-4869-AC88-7D1B5031A960

CoClass Name, CLSID

FCFL | FCFL.NET Compatibility
FCGeneric DD53D6F2-A7D9-45BC-AB5F-4222D6016E06 | FCGeneric 2888C9FF-F557-4CEA-BDDF-08DF16715D6E

Changed Properties

The following properties have changed between FCFL.FCGeneric and FCFLCompat.FCGeneric.

Changed Property | FCFL.FCGeneric | FCFLCompat.FCGeneric
RowsReturned | read/write | read-only
Records Returns an ADO Recordset that is a pointer to the actual data. FCFL.Net uses ADO.NET DataSets, replacing ADO RecordSets. This property now returns a snapshot of the FCGeneric's current contents. Any changes to this recordset will NOT be reflected by the FCGeneric. Please note that the snapshot creation occurs every time this property is accessed.

It is highly recommended that any code that uses the Records property be re-coded to not use this property. At a minimum, the code should be examined so that the Records property is called as few times as possible. See the example below.

One common use of the Records property is setting the maximum records returned from a query.

Example:

genCase.records.MaxRecords=10;

Instead of this, use the MaxRecords property of the fcGeneric object directly.

Example:

genCase.MaxRecords=10;

WARNING: The use of the MaxRecords property is NOT supported on Oracle 7.x and Oracle 8.0.x. Setting this property will only cause an entry to be logged to the log file. The query will proceed normally, but all rows will be returned (unconstrained).

The data type of the recordset's Field objects that are textual (e.g. CHAR, TEXT, VARCHAR) will alway return the type VARCHAR. See MockAdoField's Type property for more details.
Item (Default) Returns an ADO Field class instance As ADO is no longer used within FCGeneric (ADO.NET is used instead), this method returns an object that emulates the ADO Field class behavior. The class is actually an MockAdoField object.

In FCFL after querying a generic with a limited number of datafields. If you attempt to access a field that is present in the database table but was not present in the generic's datafields property. FCFL will throw an error. In fcSDK it will return the default value that is specified by the schema, no error will be thrown.

Changed Methods

The following methods have changed between FCFL.FCGeneric and FCFLCompat.FCGeneric.

Changed Method | FCFL.FCGeneric | FCFLCompat.FCGeneric
RelateRecords | Parameters are ByRef | Parameters are ByVal

Deleted Properties

The following properties are no longer available in FCFLCompat.FCGeneric.

Deleted Property | Comments
QuerySQL | No longer supported

Use of the Records Property

Here is an example of improper use of the Records property:

[JavaScript]

var genContact = FCSession.CreateGeneric('contact');
genContact.Query();

while (!genContact.Records.EOF){
  //A new ADO recordset is created here:
    field = genContact.Records.Fields("first_name");

  //A new ADO recordset is created here:
    length = genContact.Records.Fields("first_name").ActualSize;

  WScript.Echo('Length of ' + field + " = " + length);
  genContact.Records.MoveNext;
}

The example above is bad because each time the records property is accessed, a new ADO recordset object is created. So, if your query returned 100 records, you would actually be creating 200 ADO recordsets.

Here is the same example re-coded for better performance:

[JavaScript]

var genContact = FCSession.CreateGeneric('contact');
genContact.Query();
//A new ADO recordset is created here:
  var records = genContact.Records;

while (!records.EOF){
  field = records.Fields("first_name");
  length = records.Fields("first_name").ActualSize;
  WScript.Echo('Length of ' + field + " = " + length);
  records.MoveNext;
}

Notice that in the re-coded example, only one ADO recordset is created.

Here is the same example re-coded again completely eliminating use of the Records property:

[JavaScript]

var genContact = FCSession.CreateGeneric('contact');
genContact.Query();

while (!genContact.EOF){
  field = genContact("first_name");
  length = new String(genContact("first_name")).length;
  WScript.Echo('Length of ' + field + " = " + length);
  genContact.MoveNext();
}

Notice that in the re-coded example, an ADO recordset is not created at all.


FCBulk Changes | fcSDK Documentation

FCBulk Changes

ProgID

FCFL | FCFL.NET Compatibility
FCFL.FCBulk | FCFLCompat.FCBulk

Interface Name, IID

FCFL | FCFL.NET Compatibility
_FCBulk BEE4D5F3-9D2D-409F-A1AB-D2BAF433598C | IFCBulk 3D860A38-CDDA-4653-88DC-F7BB6AD46E94

CoClass Name, CLSID

FCFL | FCFL.NET Compatibility
FCBulk 19CC67FC-065F-4B0C-9C48-03CF5AB5F120 | FCBulk DDBC0BE8-F58D-4bde-B658-6FB1E0851C4C

Changed Properties

None

Changed Methods

None


FCSQLExec Changes | fcSDK Documentation

FCSQLExec Changes

ProgID

FCFL | FCFL.NET Compatibility
FCFL.FCSQLExec | FCFLCompat.FCSQLExec

Interface Name, IID

FCFL | FCFL.NET Compatibility
_FCSQLExec 1BB28948-D4BD-4F6A-B8D5-C151EF2EB540 | IFCSQLExec 3D860A38-CDDA-4653-88DC-F7BB6AD46E94

CoClass Name, CLSID

FCFL | FCFL.NET Compatibility
FCSQLExec 19CC67FC-065F-4B0C-9C48-03CF5AB5F120 | FCSQLExec 07C3B514-FB94-4ED3-A796-F2BD57A3C7C2

Changed Properties

Changed Property | FCFL.FCGeneric | FCFLCompat.FCGeneric
Records | read/write | read-only

Changed Methods

None


FCList Changes | fcSDK Documentation

FCList Changes

ProgID | FCFL | FCFL.NET Compatibility | |:--- |:--- | | FCFL.FCList | FCFLCompat.FCList |

Interface Name, IID

FCFL | FCFL.NET Compatibility
_FCList 36574644-F9D9-4480-90F9-2001C3B1CAB8 | IFCList 6AFFB191-74AD-4d5f-A2B5-2456A3F5AA9F

CoClass Name, CLSID

FCFL | FCFL.NET Compatibility
FCList 7BEBEADF-9B37-4BD4-9251-40055A5A00C1 | FCList 007EE1DD-6614-4833-BB7F-2AB543B42CE9

Changed Properties

The following properties have changed between FCFL.FCList and FCFLCompat.FCList.

Changed Property | FCFL.FCList | FCFLCompat.FCList
Count | read/write | read-only
Sorted | read/write | read-only

Changed Methods

The following methods have changed between FCFL.FCList and FCFLCompat.FCList.

Changed Method | FCFL.FCList | FCFLCompat.FCList
AppendItem | Parameters are ByRef | Parameters are ByVal
Contains | Parameters are ByRef | Parameters are ByVal
FindFirstIndex | Parameters are ByRef | Parameters are ByVal

Deleted methods

The following methods are no longer available in FCFLCompat.FCList.

Deleted Method
Concat
CopyList
Down
ListByIndex
PrintList
RemoveByIndex
ReplaceByIndex
Up


FCFL/FCFL.NET Type Library Changes | fcSDK Documentation

FCFL/FCFL.NET Type Library Changes

TypeLib Name

(appears in Add Reference dialog in VB6)

FCFL | FCFL.Net compatibility
First Choice Foundation Library | First Choice Foundation For Clarify Compatibility Library

TypeLib ID

FCFL | FCFL.Net compatibility
5D9470B1-D520-41BC-BDA7-E57A25D37085 | D0F70B26-F359-44AC-B0AE-20AAD0847D13


First Choice API Toolkit for ClearContracts Changes | fcSDK Documentation

First Choice API Toolkit for ClearContracts Changes

TypeLib Name

(appears in Add Reference dialog in VB6)

FCFL | fcSDK Compatibility
FCFL API Toolkit for Clear Contracts | First Choice SDK for Clarify Library

TypeLib ID

FCFL | fcSDK Compatibility
D4C8ABE1-95E7-4B5E-BD26-60ED202D93E2 | D0F70B26-F359-44AC-B0AE-20AAD0847D13

ProgID

FCFL | fcSDK Compatibility
fccc.cc | FCCompatToolkit.CC

Interface Name, IID

FCFL | fcSDK Compatibility
_CC D4C8ABE1-95E7-4B5E-BD26-60ED202D93E2 | IFCCC 6C0FD17C-AF19-4ef0-BD32-B9D796EC519B

CoClass Name, CLSID

FCFL | fcSDK Compatibility
CC 322B6863-BEE9-4FAD-B6C7-8962F92E6066 | FCCC 7345AC26-5DA2-4127-9464-2E3A942C14EB

Changed Properties

None

Changed Methods

None


First Choice API Toolkit for ClearLogistics Changes | fcSDK Documentation

First Choice API Toolkit for ClearLogistics Changes

TypeLib Name

(appears in Add Reference dialog in VB6)

FCFL | fcSDK Compatibility
FCCL | First Choice SDK for Clarify Library

TypeLib ID

FCFL | fcSDK Compatibility
F3980C9E-2C9D-42A6-B511-5D65263ACAE1 | D0F70B26-F359-44AC-B0AE-20AAD0847D13

ProgID

FCFL | fcSDK Compatibility
fccl.cl | FCCompatToolkit.CL

Interface Name, IID

FCFL | fcSDK Compatibility
_CL D477FD3C-CF2C-4BF6-85FE-3C3D932BFCA6 | IFCCL ADFCFB46-442B-475B-B906-6CEDC5EF397F

CoClass Name, CLSID

FCFL | fcSDK Compatibility
CL 23083BF1-2A25-43E3-B2C1-1BB961C51AA3 | FCCL FB9E2A48-FE03-405A-A34C-94FF5974BB53

Changed Properties

None

Changed Methods

None


First Choice API Toolkit for ClearQuality Changes | fcSDK Documentation

First Choice API Toolkit for ClearQuality Changes

TypeLib Name

(appears in Add Reference dialog in VB6)

FCFL | fcSDK Compatibility
First Choice ClearQuality API Toolkit | First Choice SDK for Clarify Library

TypeLib ID

FCFL | fcSDK Compatibility
CE281E78-DEAD-46B8-836C-D142518E723B | D0F70B26-F359-44AC-B0AE-20AAD0847D13

ProgID

FCFL | fcSDK Compatibility
fccq.cq | FCCompatToolkit.CQ

Interface Name, IID

FCFL | fcSDK Compatibility
_CQ 418D5809-A443-4D72-9150-B6A1E5508317 | IFCCQ 7530FF07-C99D-4882-91BC-A1B3FE1D99AD

CoClass Name, CLSID

FCFL | fcSDK Compatibility
CQ 05AC1FB1-C92A-41FB-86B3-A77567DB5CAF | FCCQ 559A7F0D-E334-4A6D-A870-98D8D16217DA

Changed Properties

None

Changed Methods

None


First Choice API Toolkit for ClearSupport Changes | fcSDK Documentation

First Choice API Toolkit for ClearSupport Changes

TypeLib Name

(appears in Add Reference dialog in VB6)

FCFL | fcSDK Compatibility
FCCS | First Choice SDK for Clarify Library

TypeLib ID

FCFL | fcSDK Compatibility
AF29F2E4-750D-4E53-B95C-2EB997F7DDFB | D0F70B26-F359-44AC-B0AE-20AAD0847D13

ProgID

FCFL | fcSDK Compatibility
fccs.cs | FCCompatToolkit.CS

Interface Name, IID

FCFL | fcSDK Compatibility
_CS 95C9475D-BF8C-4898-91D6-009053E3507F | IFCCS C13AAB7B-E3BE-4387-84A4-86F78D119D6A

CoClass Name, CLSID

FCFL | fcSDK Compatibility
CS A02FF197-6568-4BD5-834E-EB30AF226868 | FCCS 3A5AC0C4-04A2-4BB6-96C9-7033979EC7FD

Changed Properties

None

Changed Methods

None


First Choice API Toolkit for Depot Repair Changes | fcSDK Documentation

First Choice API Toolkit for Depot Repair Changes

TypeLib Name

(appears in Add Reference dialog in VB6)

FCFL | fcSDK Compatibility
FCFL API Toolkit for Depot Repair | First Choice SDK for Clarify Library

TypeLib ID

FCFL | fcSDK Compatibility
821CA918-E824-4FC5-AD57-36961847B7C9 | D0F70B26-F359-44AC-B0AE-20AAD0847D13

ProgID

FCFL | fcSDK Compatibility
fcdr.dr | FCCompatToolkit.DR

Interface Name, IID

FCFL | fcSDK Compatibility
_DR 03A33BDF-679F-472F-BB77-BB70A2B5B2F4 | IFCDR 6B68AF21-47DD-45C4-8D85-374B238584EF

CoClass Name, CLSID

FCFL | fcSDK Compatibility
DR 5DD58AED-25B1-46C7-8D8E-0506D205E26B | FCDR E3D1915E-3932-4075-B65F-74B8C71FFCB9

Changed Properties

None

Changed Methods

None


First Choice API Toolkit for Interfaces Changes | fcSDK Documentation

First Choice API Toolkit for Interfaces Changes

TypeLib Name

(appears in Add Reference dialog in VB6)

FCFL | fcSDK Compatibility
First Choice Software FCFL API Toolkit for Interfaces | First Choice SDK for Clarify Library

TypeLib ID

FCFL | fcSDK Compatibility
3BF0B58E-9255-474A-B1B4-08CEC9A71458 | D0F70B26-F359-44AC-B0AE-20AAD0847D13

ProgID

FCFL | fcSDK Compatibility
fcinter.inter | FCCompatToolkit.INTER

Interface Name, IID

FCFL | fcSDK Compatibility
_INTER 7914ED9A-5403-47FF-8970-053B97766CCF | IFCINTER 690BCCF2-8400-4724-8354-8AB700E4DC51

CoClass Name, CLSID

FCFL | fcSDK Compatibility
INTER AA7AF06C-80ED-4345-800D-9E3D47AB54DD | FCINTER DC0E1117-672D-4D99-9B3F-0ABDA24BFF59

Changed Properties

None

Changed Methods

None


First Choice API Toolkit for ClearSales Changes | fcSDK Documentation

First Choice API Toolkit for ClearSales Changes

TypeLib Name

(appears in Add Reference dialog in VB6)

FCFL | FcSdk compatibility
FCSFA | First Choice SDK for Clarify Library

TypeLib ID

FCFL FcSdk compatibility

| 1F025766-9B82-46FF-8354-19D96AD9050E | D0F70B26-F359-44AC-B0AE-20AAD0847D13 ProgID | FCFL | FcSdk compatibility | |:--- |:--- | | fcsfa.sfa | FCCompatToolkit.SFA |

Interface Name, IID

FCFL | FcSdk compatibility
_SFA 4E5A3646-AAB7-4D62-8911-086A7E668732 | IFCSFA 31BFCC5F-1E05-44FA-BBDC-CB1B96070BC8

CoClass Name, CLSID

FCFL | FcSdk compatibility
SFA AEE2760E-AF70-487C-A696-0FBA28F85A57 | FCSFA 3EDF925A-1AC8-4116-9D51-7547AD12C47B

Changed Properties

None

Changed Methods

None


First Choice API Toolkit for ClearLogistics Field Operations Changes | fcSDK Documentation

First Choice API Toolkit for ClearLogistics Field Operations Changes

TypeLib Name

(appears in Add Reference dialog in VB6)

FCFL | fcSDK Compatibility
First Choice Software COM Field Operations API Toolkit | First Choice SDK for Clarify Library

TypeLib ID

FCFL | fcSDK Compatibility
78AC1807-B164-4DA8-86AA-A4DFA25240BE | D0F70B26-F359-44AC-B0AE-20AAD0847D13

ProgID

FCFL | fcSDK Compatibility
FCFO.FO | FCCompatToolkit.FO

Interface Name, IID

FCFL | fcSDK Compatibility
_FO F468C129-897F-484F-A2AE-14A71FC63EA1 | IFCFO 53BEA621-C158-448b-B9F9-33B3A18084E8

CoClass Name, CLSID

FCFL | fcSDK Compatibility
FO AC1C149C-165E-4A9B-8F35-DBDCBAD18152 | FCFO 1D515A33-E701-4bfb-9BD2-EB12CA55790E

Changed Properties

None

Changed Methods

None


(Global) Namespace | fcSDK Documentation

(Global) Namespace

Reference

fcSDK Assembly


FChoice.Common Namespace | fcSDK Documentation

FChoice.Common Namespace

The FChoice.Common namespace provides configuration, logging, and error management services to First Choice .NET-based products.

Classes

 | Class | Description
Class | CommonException | CommonException is the exception class used throughout the FChoice.Common and FChoice.Common.Data namespaces. It provides localized error messages with unique error identifiers.
Class | ConfigValues | ConfigValues is a collection of string constants used for strongly-typing the keys used to access the common configuration items in the FCConfiguration collection.
Class | DataProtector | Provides easy access to the Windows Data Protection API (DPAPI) for encrypting and decrypting data values
Class | FCArgumentException | FCArgumentException is used to signify that parameters passed into APIs are invalid. It has several static (Shared in Visual Basic) methods that make handling required parameters easier.
Class | FCConfiguration | The FCConfiguration class provides access to the application configuration and ensures that basic required configuration parameters are present.
Class | FCExceptionBase | FCExceptionBase is the base exception from which all other First Choice exception classes derive. It provides pluggable error message strings which allows for easy runtime customization and localization of error messages.
Class | FCInvalidConfigurationException | FCInvalidConfigurationException is used when required parameters are missing from the application configuration file, or the parameters specified are invalid for some reason.
Class | FCLicenseException | FCLicenseException is used when a licensed product attempts to obtain a license key from the installed set of keys and either cannot find its key or an error occurs retreiving the list of licenses.
Class | InvalidLoggingConfigException |
Class | Logger | Logger is used by classes throughout First Choice .NET-based products to write logging entries.
Class | LogManager | LogManager provides access to the logging subsystem so that classes and write log entries and allow those entries to be processed according to the application logging configuration.
Class | PerfManager | Provides basic convenience services for instrumenting performance counters in an application
Class | StringUtil |

Interfaces

 | Interface | Description
Interface | IErrorMessageProvider | The IErrorMessageProvider is the interface used by FCExceptionBase to allow other assemblies to provide custom error message resolution.

Enumerations

 | Enumeration | Description
Enumeration | DataProtectionStore | DataProtectionStore is used with the DataProtector when encrypting or decrypting data. DataProtectionStore tells the DataProtector which key store to use.
Enumeration | FCLicenseException.LoadFailReasons | LoadFailReasons is used by FCLicenseException to provide a specific reason why license procurement failed for the product.
Enumeration | LogLevel | LogLevel is an enumeration of supported logging levels. This is used in conjunction with LogManager and Logger to control how log messages are filtered or written to the output appender.

Remarks

The FChoice.Common namespace is largely intended to be used by First Choice .NET products only. While public for your convenience, usage of any of these classes directly (except for Configuration or Logging) is discouraged.

Reference

FChoice.Common Assembly


CommonException Class | fcSDK Documentation

CommonException Class

CommonException Class

CommonException is the exception class used throughout the FChoice.Common and FChoice.Common.Data namespaces. It provides localized error messages with unique error identifiers.

Syntax

'Declaration

<SerializableAttribute()>
Public Class CommonException
   Inherits FCExceptionBase

[SerializableAttribute()]
public class CommonException : FCExceptionBase

Remarks

This exception is thrown whenever the FChoice.Common classes encounter problems. They should generally be rare and are usually related to invalid configuration settings or some type of major error from which .NET or First Choice products cannot recover.

Inheritance Hierarchy

System.Object System.Exception System.ApplicationException FChoice.Common.FCExceptionBase

[FChoice.Common.CommonException** FChoice.Common.FCArgumentException

Requirements

Namespace: FChoice.Common

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

CommonException Members FChoice.Common Namespace FChoice.Common.CommonException FChoice.Common.FCArgumentException

Requirements

Namespace: FChoice.Common

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

CommonException Members FChoice.Common Namespace


CommonException Class Members | fcSDK Documentation

CommonException Class Members

The following tables list the members exposed by CommonException.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorCode | Gets the unique error code for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | ErrorMessageID | Gets the message identifier for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Assert | Assert it used internally by First Choice products to ensure that internal state and data is consistent with expected norms.
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | Sets the SerializationInfo object with the parameter name and additional exception information. (Inherited from FChoice.Common.FCExceptionBase)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)

Reference

CommonException Class
FChoice.Common Namespace


Assert Method | fcSDK Documentation

Assert Method

The unique error ID of the exception that will be thrown if the assertion fails.

A boolean which is the result of an assertion. If false, a CommonException will be thrown using the errorId specified.

A description of what the assertion represents and why it is important.

Assert it used internally by First Choice products to ensure that internal state and data is consistent with expected norms.

Syntax

'Declaration

Public Shared Sub Assert( _
   ByVal _errorId_ As Integer, _
   ByVal _assertionResult_ As Boolean, _
   ByVal _reason_ As String _
)

public static void Assert(
   int _errorId_,
   bool _assertionResult_,
   string _reason_
)

Parameters

errorId

The unique error ID of the exception that will be thrown if the assertion fails.

assertionResult

A boolean which is the result of an assertion. If false, a CommonException will be thrown using the errorId specified.

reason

A description of what the assertion represents and why it is important.

Exceptions

Exception | Description
CommonException | The assertion failed.

Remarks

Note that the reason parameter is not localized. Assertions are generally internal state monitors used by programmers and are not intended to be viewed by end users. The reason should be encoded in the language of the developer to aid in troubleshooting.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CommonException Class
CommonException Members


ConfigValues Class | fcSDK Documentation

ConfigValues Class

ConfigValues Class

ConfigValues is a collection of string constants used for strongly-typing the keys used to access the common configuration items in the FCConfiguration collection.

Syntax

'Declaration

Public MustInherit NotInheritable Class ConfigValues

public static class ConfigValues

Remarks

ConfigValues is used similar to .NET enumeration type.

Example

string connStr = FCConfiguration.Current[ConfigValues.CONNECT_STRING];

Dim connStr As String = FCConfiguration.Current(ConfigValues.CONNECT_STRING)

Inheritance Hierarchy

System.Object

[FChoice.Common.ConfigValues**

Requirements

Namespace: FChoice.Common

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

ConfigValues Members FChoice.Common Namespace FChoice.Common.ConfigValues

Requirements

Namespace: FChoice.Common

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

ConfigValues Members FChoice.Common Namespace


ConfigValues Class Members | fcSDK Documentation

ConfigValues Class Members

The following tables list the members exposed by ConfigValues.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | CACHE_FILE_PATH |
static (Shared in Visual Basic) | CONNECT_STRING | The key to the FCConfiguration collection which contains the configured database connection string.
static (Shared in Visual Basic) | DB_TYPE | The key to the FCConfiguration collection which contains the configured database provider type.
static (Shared in Visual Basic) | DBPROVIDER_CONFIGFILE |
static (Shared in Visual Basic) | ENABLE_BATCH | The key to the FCConfiguration collection which contains the configured switch for enabling or disabling database query batching.
static (Shared in Visual Basic) | LOG_CONFIG_FILE_PATH |
static (Shared in Visual Basic) | NO_CACHE_FILE | The key to the FCConfiguration collection which contains the configured switch which controls whether First Choice applications will cache application data.
static (Shared in Visual Basic) | PERF_ENABLED |
static (Shared in Visual Basic) | PERF_INSTANCE_NAME |
static (Shared in Visual Basic) | SQL_BIG_QUERY_COUNT_THRESHOLD |
static (Shared in Visual Basic) | SQL_BIG_QUERY_TIME_THRESHOLD |
static (Shared in Visual Basic) | SQL_COMMAND_TIMEOUT |
static (Shared in Visual Basic) | STATEMANAGER_CONFIGFILE |

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetConditionalString | Overloaded.
static (Shared in Visual Basic) | GetOptBool | Overloaded.
static (Shared in Visual Basic) | GetOptInt32 | Overloaded.
static (Shared in Visual Basic) | GetOptString | Overloaded.
static (Shared in Visual Basic) | GetReqString | Overloaded.
static (Shared in Visual Basic) | VerifyPositive |

Reference

ConfigValues Class
FChoice.Common Namespace


GetConditionalString Method | fcSDK Documentation

GetConditionalString Method

Overload List

Overload | Description
GetConditionalString(Boolean,String,String,String) |
GetConditionalString(Boolean,String,String,NameValueCollection) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigValues Class
ConfigValues Members


GetConditionalString(Boolean,String,String,String) Method | fcSDK Documentation

GetConditionalString(Boolean,String,String,String) Method

Syntax

'Declaration

Public Overloads Shared Function GetConditionalString( _
   ByVal _isRequired_ As Boolean, _
   ByVal _defaultVal_ As String, _
   ByVal _val_ As String, _
   ByVal _keyName_ As String _
) As String

public static string GetConditionalString(
   bool _isRequired_,
   string _defaultVal_,
   string _val_,
   string _keyName_
)

Parameters

isRequired defaultVal val keyName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigValues Class
ConfigValues Members
Overload List


GetConditionalString(Boolean,String,String,NameValueCollection) Method | fcSDK Documentation

GetConditionalString(Boolean,String,String,NameValueCollection) Method

Syntax

'Declaration

Public Overloads Shared Function GetConditionalString( _
   ByVal _isRequired_ As Boolean, _
   ByVal _defaultVal_ As String, _
   ByVal _keyName_ As String, _
   ByVal _settingsCol_ As NameValueCollection _
) As String

public static string GetConditionalString(
   bool _isRequired_,
   string _defaultVal_,
   string _keyName_,
   NameValueCollection _settingsCol_
)

Parameters

isRequired

defaultVal

keyName

settingsCol

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigValues Class
ConfigValues Members
Overload List


GetOptBool Method | fcSDK Documentation

GetOptBool Method

Overload List

Overload | Description
GetOptBool(Boolean,String,NameValueCollection) |
GetOptBool(Boolean,String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigValues Class
ConfigValues Members


GetOptBool(Boolean,String,NameValueCollection) Method | fcSDK Documentation

GetOptBool(Boolean,String,NameValueCollection) Method

Syntax

'Declaration

Public Overloads Shared Function GetOptBool( _
   ByVal _defaultVal_ As Boolean, _
   ByVal _keyName_ As String, _
   ByVal _settingsCol_ As NameValueCollection _
) As Boolean

public static bool GetOptBool(
   bool _defaultVal_,
   string _keyName_,
   NameValueCollection _settingsCol_
)

Parameters

defaultVal

keyName

settingsCol

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigValues Class
ConfigValues Members
Overload List


GetOptBool(Boolean,String) Method | fcSDK Documentation

GetOptBool(Boolean,String) Method

Syntax

'Declaration

Public Overloads Shared Function GetOptBool( _
   ByVal _defaultVal_ As Boolean, _
   ByVal _val_ As String _
) As Boolean

public static bool GetOptBool(
   bool _defaultVal_,
   string _val_
)

Parameters

defaultVal

val

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigValues Class
ConfigValues Members
Overload List


GetOptInt32 Method | fcSDK Documentation

GetOptInt32 Method

Overload List

Overload | Description
GetOptInt32(Int32,String,NameValueCollection) |
GetOptInt32(Int32,String,String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigValues Class
ConfigValues Members


GetOptInt32(Int32,String,NameValueCollection) Method | fcSDK Documentation

GetOptInt32(Int32,String,NameValueCollection) Method

Syntax

'Declaration

Public Overloads Shared Function GetOptInt32( _
   ByVal _defaultVal_ As Integer, _
   ByVal _keyName_ As String, _
   ByVal _settingsCol_ As NameValueCollection _
) As Integer

public static int GetOptInt32(
   int _defaultVal_,
   string _keyName_,
   NameValueCollection _settingsCol_
)

Parameters

defaultVal

keyName

settingsCol

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigValues Class
ConfigValues Members
Overload List


GetOptInt32(Int32,String,String) Method | fcSDK Documentation

GetOptInt32(Int32,String,String) Method

Syntax

'Declaration

Public Overloads Shared Function GetOptInt32( _
   ByVal _defaultVal_ As Integer, _
   ByVal _val_ As String, _
   ByVal _keyName_ As String _
) As Integer

public static int GetOptInt32(
   int _defaultVal_,
   string _val_,
   string _keyName_
)

Parameters

defaultVal

val

keyName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigValues Class
ConfigValues Members
Overload List


GetOptString Method | fcSDK Documentation

GetOptString Method

Overload List

Overload | Description
GetOptString(String,String,NameValueCollection) |
GetOptString(String,String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigValues Class
ConfigValues Members


GetOptString(String,String,NameValueCollection) Method | fcSDK Documentation

GetOptString(String,String,NameValueCollection) Method

Syntax

'Declaration

Public Overloads Shared Function GetOptString( _
   ByVal _defaultVal_ As String, _
   ByVal _keyName_ As String, _
   ByVal _settingsCol_ As NameValueCollection _
) As String

public static string GetOptString(
   string _defaultVal_,
   string _keyName_,
   NameValueCollection _settingsCol_
)

Parameters

defaultVal

keyName

settingsCol

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigValues Class
ConfigValues Members
Overload List


GetOptString(String,String) Method | fcSDK Documentation

GetOptString(String,String) Method

Syntax

'Declaration

Public Overloads Shared Function GetOptString( _
   ByVal _defaultVal_ As String, _
   ByVal _val_ As String _
) As String

public static string GetOptString(
   string _defaultVal_,
   string _val_
)

Parameters

defaultVal

val

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigValues Class
ConfigValues Members
Overload List


GetReqString Method | fcSDK Documentation

GetReqString Method

Overload List

Overload | Description
GetReqString(String,NameValueCollection) |
GetReqString(String,String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigValues Class
ConfigValues Members


GetReqString(String,NameValueCollection) Method | fcSDK Documentation

GetReqString(String,NameValueCollection) Method

Syntax

'Declaration

Public Overloads Shared Function GetReqString( _
   ByVal _keyName_ As String, _
   ByVal _settingsCol_ As NameValueCollection _
) As String

public static string GetReqString(
   string _keyName_,
   NameValueCollection _settingsCol_
)

Parameters

keyName

settingsCol

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigValues Class
ConfigValues Members
Overload List


GetReqString(String,String) Method | fcSDK Documentation

GetReqString(String,String) Method

Syntax

'Declaration

Public Overloads Shared Function GetReqString( _
   ByVal _val_ As String, _
   ByVal _keyName_ As String _
) As String

public static string GetReqString(
   string _val_,
   string _keyName_
)

Parameters

val

keyName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigValues Class
ConfigValues Members
Overload List


VerifyPositive Method | fcSDK Documentation

VerifyPositive Method

Syntax

'Declaration

Public Shared Sub VerifyPositive( _
   ByVal _value_ As Object, _
   ByVal _keyName_ As String _
)

public static void VerifyPositive(
   object _value_,
   string _keyName_
)

Parameters

value

keyName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigValues Class
ConfigValues Members


CACHE_FILE_PATH Field | fcSDK Documentation

CACHE_FILE_PATH Field

CACHE_FILE_PATH Field

Syntax

'Declaration

Public Shared ReadOnly CACHE_FILE_PATH As String

public static readonly string CACHE_FILE_PATH

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigValues Class
ConfigValues Members


CONNECT_STRING Field | fcSDK Documentation

CONNECT_STRING Field

The key to the FCConfiguration collection which contains the configured database connection string.

Syntax

'Declaration

Public Shared ReadOnly CONNECT_STRING As String

public static readonly string CONNECT_STRING

Field Value

A key used by the FCConfiguration collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigValues Class
ConfigValues Members


DB_TYPE Field | fcSDK Documentation

DB_TYPE Field

The key to the FCConfiguration collection which contains the configured database provider type.

Syntax

'Declaration

Public Shared ReadOnly DB_TYPE As String

public static readonly string DB_TYPE

Field Value

A key used by the FCConfiguration collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigValues Class
ConfigValues Members


DBPROVIDER_CONFIGFILE Field | fcSDK Documentation

DBPROVIDER_CONFIGFILE Field

Syntax

'Declaration

Public Shared ReadOnly DBPROVIDER_CONFIGFILE As String

public static readonly string DBPROVIDER_CONFIGFILE

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigValues Class
ConfigValues Members


ENABLE_BATCH Field | fcSDK Documentation

ENABLE_BATCH Field

The key to the FCConfiguration collection which contains the configured switch for enabling or disabling database query batching.

Syntax

'Declaration

Public Shared ReadOnly ENABLE_BATCH As String

public static readonly string ENABLE_BATCH

Field Value

A key used by the FCConfiguration collection.

Remarks

Note that the value returned from the FCConfiguration collection using this key will override whatever the default setting of the database provider is. However, if the database provider does not support batching (e.g. Oracle), setting this value will not affect batching behavior.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigValues Class
ConfigValues Members


LOG_CONFIG_FILE_PATH Field | fcSDK Documentation

LOG_CONFIG_FILE_PATH Field

Syntax

'Declaration

Public Shared ReadOnly LOG_CONFIG_FILE_PATH As String

public static readonly string LOG_CONFIG_FILE_PATH

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigValues Class
ConfigValues Members


NO_CACHE_FILE Field | fcSDK Documentation

NO_CACHE_FILE Field

The key to the FCConfiguration collection which contains the configured switch which controls whether First Choice applications will cache application data.

Syntax

'Declaration

Public Shared ReadOnly NO_CACHE_FILE As String

public static readonly string NO_CACHE_FILE

Field Value

A key used by the FCConfiguration collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigValues Class
ConfigValues Members


PERF_ENABLED Field | fcSDK Documentation

PERF_ENABLED Field

Syntax

'Declaration

Public Shared ReadOnly PERF_ENABLED As String

public static readonly string PERF_ENABLED

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigValues Class
ConfigValues Members


PERF_INSTANCE_NAME Field | fcSDK Documentation

PERF_INSTANCE_NAME Field

Syntax

'Declaration

Public Shared ReadOnly PERF_INSTANCE_NAME As String

public static readonly string PERF_INSTANCE_NAME

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigValues Class
ConfigValues Members


SQL_BIG_QUERY_COUNT_THRESHOLD Field | fcSDK Documentation

SQL_BIG_QUERY_COUNT_THRESHOLD Field

Syntax

'Declaration

Public Shared ReadOnly SQL_BIG_QUERY_COUNT_THRESHOLD As String

public static readonly string SQL_BIG_QUERY_COUNT_THRESHOLD

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigValues Class
ConfigValues Members


SQL_BIG_QUERY_TIME_THRESHOLD Field | fcSDK Documentation

SQL_BIG_QUERY_TIME_THRESHOLD Field

Syntax

'Declaration

Public Shared ReadOnly SQL_BIG_QUERY_TIME_THRESHOLD As String

public static readonly string SQL_BIG_QUERY_TIME_THRESHOLD

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigValues Class
ConfigValues Members


SQL_COMMAND_TIMEOUT Field | fcSDK Documentation

SQL_COMMAND_TIMEOUT Field

Syntax

'Declaration

Public Shared ReadOnly SQL_COMMAND_TIMEOUT As String

public static readonly string SQL_COMMAND_TIMEOUT

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigValues Class
ConfigValues Members


STATEMANAGER_CONFIGFILE Field | fcSDK Documentation

STATEMANAGER_CONFIGFILE Field

Syntax

'Declaration

Public Shared ReadOnly STATEMANAGER_CONFIGFILE As String

public static readonly string STATEMANAGER_CONFIGFILE

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigValues Class
ConfigValues Members


DataProtector Class | fcSDK Documentation

DataProtector Class

Provides easy access to the Windows Data Protection API (DPAPI) for encrypting and decrypting data values

Syntax

'Declaration

Public NotInheritable Class DataProtector

public sealed class DataProtector

Remarks

warning WARNING: The encryption produced by this class is only usable from the machine on which the encryption occurred. The encrypted text cannot be used by a different computer.

For more information on Windows Data Protection, please see this technical article on MSDN called Windows Data Protection.

Inheritance Hierarchy

System.Object FChoice.Common.DataProtector

Requirements

Namespace: FChoice.Common

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

DataProtector Members FChoice.Common Namespace


DataProtector Class Members | fcSDK Documentation

DataProtector Class Members

The following tables list the members exposed by DataProtector.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Decrypt | Overloaded. Decrypts a byte array of data into a new byte array of unencrypted data
static (Shared in Visual Basic) | DecryptString | Overloaded. Decrypts data which was encoded into a string using the Base64 encoding scheme
static (Shared in Visual Basic) | Encrypt | Overloaded. Encrypts a byte array
static (Shared in Visual Basic) | EncryptString | Overloaded. Encrypts a string and returns a Base64-encoded string representing the encrypted output

Reference

DataProtector Class
FChoice.Common Namespace


Decrypt Method | fcSDK Documentation

Decrypt Method

Overload List

Overload | Description
Decrypt(DataProtectionStore,Byte[]) | Decrypts a byte array of data into a new byte array of unencrypted data
Decrypt(DataProtectionStore,Byte[],Byte[]) | Decrypts a byte array of data, using the specified entropy, into a new byte array of unencrypted data

Remarks

warning ** WARNING**: The encryption produced by this class is only usable from the machine on which the encryption occurred. The encrypted text cannot be used by a different computer.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataProtector Class DataProtector Members


Decrypt(DataProtectionStore,Byte[]) Method | fcSDK Documentation

Decrypt(DataProtectionStore,Byte[]) Method

Specifies which key store to use (User or Machine)

The encrypted bytes to decrypt

Decrypts a byte array of data into a new byte array of unencrypted data

Syntax

'Declaration

Public Overloads Shared Function Decrypt( _
   ByVal _keyStore_ As DataProtectionStore, _
   ByVal _cipherBytes_() As Byte _
) As Byte()

public static byte[] Decrypt(
   DataProtectionStore _keyStore_,
   byte[] _cipherBytes_
)

Parameters

keyStore

Specifies which key store to use (User or Machine)

cipherBytes

The encrypted bytes to decrypt

Remarks

warning ** WARNING**: The encryption produced by this class is only usable from the machine on which the encryption occurred. The encrypted text cannot be used by a different computer.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataProtector Class DataProtector Members Overload List


Decrypt(DataProtectionStore,Byte[],Byte[]) Method | fcSDK Documentation

Decrypt(DataProtectionStore,Byte[],Byte[]) Method

Specifies which key store to use (User or Machine)

The encrypted bytes to decrypt

The entropy, or "password" to use to decrypt this data. The value must be the same as was used to originally encrypt the data

Decrypts a byte array of data, using the specified entropy, into a new byte array of unencrypted data

Syntax

'Declaration

Public Overloads Shared Function Decrypt( _
   ByVal _keyStore_ As DataProtectionStore, _
   ByVal _cipherBytes_() As Byte, _
   ByVal _entropy_() As Byte _
) As Byte()

public static byte[] Decrypt(
   DataProtectionStore _keyStore_,
   Byte[] _cipherBytes_,
   Byte[] _entropy_
)

Parameters

keyStore

Specifies which key store to use (User or Machine)

cipherBytes

The encrypted bytes to decrypt

entropy

The entropy, or "password" to use to decrypt this data. The value must be the same as was used to originally encrypt the data

Remarks

warning ** WARNING**: The encryption produced by this class is only usable from the machine on which the encryption occurred. The encrypted text cannot be used by a different computer.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataProtector Class DataProtector Members Overload List


DecryptString Method | fcSDK Documentation

DecryptString Method

Overload List

Overload | Description
DecryptString(DataProtectionStore,String) | Decrypts data which was encoded into a string using the Base64 encoding scheme
DecryptString(DataProtectionStore,String,String) | Decrypts, using the specified entropy, data which was encoded into a string using the Base64 encoding scheme

Remarks

warning ** WARNING**: The encryption produced by this class is only usable from the machine on which the encryption occurred. The encrypted text cannot be used by a different computer.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataProtector Class DataProtector Members


DecryptString(DataProtectionStore,String) Method | fcSDK Documentation

DecryptString(DataProtectionStore,String) Method

Specifies which key store to use (User or Machine)

A Base64 encoded string representing the encrypted bytes to decrypt

Decrypts data which was encoded into a string using the Base64 encoding scheme

Syntax

'Declaration

Public Overloads Shared Function DecryptString( _
   ByVal _keyStore_ As DataProtectionStore, _
   ByVal _encryptedText_ As String _
) As String

public static string DecryptString(
   DataProtectionStore _keyStore_,
   string _encryptedText_
)

Parameters

keyStore

Specifies which key store to use (User or Machine)

encryptedText

A Base64 encoded string representing the encrypted bytes to decrypt

Return Value

The decrypted contents of this message as a string

Remarks

This method expects the payload to be a byte array which contains the UTF8-encoded bytes of a string that was encrypted using the EncryptString Method.

warning ** WARNING**: The encryption produced by this class is only usable from the machine on which the encryption occurred. The encrypted text cannot be used by a different computer.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataProtector Class DataProtector Members Overload List


DecryptString(DataProtectionStore,String,String) Method | fcSDK Documentation

DecryptString(DataProtectionStore,String,String) Method

Specifies which key store to use (User or Machine)

A Base64 encoded string representing the encrypted bytes to decrypt

The entropy, or "password" to use to decrypt this data. The value must be the same as was used to originally encrypt the data

Decrypts, using the specified entropy, data which was encoded into a string using the Base64 encoding scheme

Syntax

'Declaration

Public Overloads Shared Function DecryptString( _
   ByVal _keyStore_ As DataProtectionStore, _
   ByVal _encryptedText_ As String, _
   ByVal _entropy_ As String _
) As String

public static string DecryptString(
   DataProtectionStore _keyStore_,
   string _encryptedText_,
   string _entropy_
)

Parameters

keyStore

Specifies which key store to use (User or Machine)

encryptedText

A Base64 encoded string representing the encrypted bytes to decrypt

entropy

The entropy, or "password" to use to decrypt this data. The value must be the same as was used to originally encrypt the data

Return Value

The decrypted contents of this message as a string

Remarks

This method expects the payload to be a byte array which contains the UTF8-encoded bytes of a string that was encrypted using the EncryptString Method.

warning ** WARNING**: The encryption produced by this class is only usable from the machine on which the encryption occurred. The encrypted text cannot be used by a different computer.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataProtector Class DataProtector Members Overload List


Encrypt Method | fcSDK Documentation

Encrypt Method

Overload List

Overload | Description
Encrypt(DataProtectionStore,Byte[]) | Encrypts a byte array
Encrypt(DataProtectionStore,Byte[],Byte[]) | Encrypts a byte array using the specified entropy

Remarks

warning ** WARNING**: The encryption produced by this class is only usable from the machine on which the encryption occurred. The encrypted text cannot be used by a different computer.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataProtector Class DataProtector Members


Encrypt(DataProtectionStore,Byte[]) Method | fcSDK Documentation

Encrypt(DataProtectionStore,Byte[]) Method

Specifies which key store to use (User or Machine)

The plain, or unencrypted, bytes to encrypt

Encrypts a byte array

Syntax

'Declaration

Public Overloads Shared Function Encrypt( _
   ByVal _keyStore_ As DataProtectionStore, _
   ByVal _plainBytes_() As Byte _
) As Byte()

public static byte[] Encrypt(
   DataProtectionStore _keyStore_,
   Byte[] _plainBytes_
)

Parameters

keyStore

Specifies which key store to use (User or Machine)

plainBytes

The plain, or unencrypted, bytes to encrypt

Return Value

A byte array representing the encrypted version of the original plainBytes payload

Remarks

warning ** WARNING**: The encryption produced by this class is only usable from the machine on which the encryption occurred. The encrypted text cannot be used by a different computer.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataProtector Class DataProtector Members Overload List


Encrypt(DataProtectionStore,Byte[],Byte[]) Method | fcSDK Documentation

Encrypt(DataProtectionStore,Byte[],Byte[]) Method

Specifies which key store to use (User or Machine)

The plain, or unencrypted, bytes to encrypt

The entropy, or "password" to use to encryptthis data. The value must be used to decrypt the data.

Encrypts a byte array using the specified entropy

Syntax

'Declaration

Public Overloads Shared Function Encrypt( _
   ByVal _keyStore_ As DataProtectionStore, _
   ByVal _plainBytes_() As Byte, _
   ByVal _entropy_() As Byte _
) As Byte()

public static byte[] Encrypt(
   DataProtectionStore _keyStore_,
   byte[] _plainBytes_,
   byte[] _entropy_
)

Parameters

keyStore

Specifies which key store to use (User or Machine)

plainBytes

The plain, or unencrypted, bytes to encrypt

entropy

The entropy, or "password" to use to encryptthis data. The value must be used to decrypt the data.

Return Value

A byte array representing the encrypted version of the original plainBytes payload

Remarks

It is important not to lose the entropy used to encrypt this data. If the entropy is lost, the data cannot be decrypted. If the entropy must be stored, do not store it with the encrypted payload.

warning ** WARNING**: The encryption produced by this class is only usable from the machine on which the encryption occurred. The encrypted text cannot be used by a different computer.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataProtector Class DataProtector Members Overload List


EncryptString Method | fcSDK Documentation

EncryptString Method

Overload List

Overload | Description
EncryptString(DataProtectionStore,String) | Encrypts a string and returns a Base64-encoded string representing the encrypted output
EncryptString(DataProtectionStore,String,String) | Encrypts a string, using the specified entropy, and returns a Base64-encoded string representing the encrypted output

Remarks

warning ** WARNING**: The encryption produced by this class is only usable from the machine on which the encryption occurred. The encrypted text cannot be used by a different computer.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataProtector Class DataProtector Members


EncryptString(DataProtectionStore,String) Method | fcSDK Documentation

EncryptString(DataProtectionStore,String) Method

Specifies which key store to use (User or Machine)

A string of text to encrypt

Encrypts a string and returns a Base64-encoded string representing the encrypted output

Syntax

'Declaration

Public Overloads Shared Function EncryptString( _
   ByVal _keyStore_ As DataProtectionStore, _
   ByVal _plainText_ As String _
) As String

public static string EncryptString(
   DataProtectionStore _keyStore_,
   string _plainText_
)

Parameters

keyStore

Specifies which key store to use (User or Machine)

plainText

A string of text to encrypt

Remarks

warning ** WARNING**: The encryption produced by this class is only usable from the machine on which the encryption occurred. The encrypted text cannot be used by a different computer.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataProtector Class DataProtector Members Overload List


EncryptString(DataProtectionStore,String,String) Method | fcSDK Documentation

EncryptString(DataProtectionStore,String,String) Method

Specifies which key store to use (User or Machine)

A string of text to encrypt

The entropy, or "password" to use to decrypt this data. The value must be the same as was used to originally encrypt the data

Encrypts a string, using the specified entropy, and returns a Base64-encoded string representing the encrypted output

Syntax

'Declaration

Public Overloads Shared Function EncryptString( _
   ByVal _keyStore_ As DataProtectionStore, _
   ByVal _plainText_ As String, _
   ByVal _entropy_ As String _
) As String

public static string EncryptString(
   DataProtectionStore _keyStore_,
   string _plainText_,
   string _entropy_
)

Parameters

keyStore

Specifies which key store to use (User or Machine)

plainText

A string of text to encrypt

entropy

The entropy, or "password" to use to decrypt this data. The value must be the same as was used to originally encrypt the data

Remarks

It is important not to lose the entropy used to encrypt this data. If the entropy is lost, the data cannot be decrypted. If the entropy must be stored, do not store it with the encrypted payload.

warning ** WARNING**: The encryption produced by this class is only usable from the machine on which the encryption occurred. The encrypted text cannot be used by a different computer.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataProtector Class DataProtector Members Overload List


FCArgumentException Class | fcSDK Documentation

FCArgumentException Class

FCArgumentException is used to signify that parameters passed into APIs are invalid. It has several static (Shared in Visual Basic) methods that make handling required parameters easier.

Syntax

'Declaration

<SerializableAttribute()>
Public Class FCArgumentException
   Inherits CommonException

[SerializableAttribute()]
public class FCArgumentException : CommonException

Remarks

Please see the three main static (Shared in Visual Basic) on this class for information on how to help protect your APIs against invalid input data: CheckIndexBounds, CheckIsEmpty, CheckIsNull.

Inheritance Hierarchy

System.Object System.Exception System.ApplicationException FChoice.Common.FCExceptionBase FChoice.Common.CommonException FChoice.Common.FCArgumentException

Requirements

Namespace: FChoice.Common

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

FCArgumentException Members FChoice.Common Namespace FChoice.Common.FCArgumentException

Requirements

Namespace: FChoice.Common

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

FCArgumentException Members FChoice.Common Namespace


FCArgumentException Class Members | fcSDK Documentation

FCArgumentException Class Members

The following tables list the members exposed by FCArgumentException.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorCode | Gets the unique error code for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | ErrorMessageID | Gets the message identifier for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CheckIndexBounds | Used to verify that an indexer property get on a collection object contains an index that is within the bounds of collection.
static (Shared in Visual Basic) | CheckIsEmpty | Checks whether or not the supplied string value is null (Nothing in Visual Basic) or empty (trimmed length equals zero).
static (Shared in Visual Basic) | CheckIsNull | Checks to see whether the given parameter is null (Nothing in Visual Basic).
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | Sets the SerializationInfo object with the parameter name and additional exception information. (Inherited from FChoice.Common.FCExceptionBase)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)

Reference

FCArgumentException Class
FChoice.Common Namespace


CheckIndexBounds Method | fcSDK Documentation

CheckIndexBounds Method

The unique error ID to use if an exception needs to be thrown.

The name of the parameter that contains the index value to check.

The actual index value to verify.

The current total of elements in the collection against which to verify the index value.

Used to verify that an indexer property get on a collection object contains an index that is within the bounds of collection.

Syntax

'Declaration

Public Shared Sub CheckIndexBounds( _
   ByVal _errorId_ As Integer, _
   ByVal _paramName_ As String, _
   ByVal _index_ As Integer, _
   ByVal _maxBound_ As Integer _
)

public static void CheckIndexBounds(
   int _errorId_,
   string _paramName_,
   int _index_,
   int _maxBound_
)

Parameters

errorId

The unique error ID to use if an exception needs to be thrown.

paramName

The name of the parameter that contains the index value to check.

index

The actual index value to verify.

maxBound

The current total of elements in the collection against which to verify the index value.

Exceptions

Exception | Description
FCArgumentException | index was greater than or equal to maxBound.

Remarks

Index is expected to be a zero-based index value into the collection. If index is greater than or equal to maxBound, an FCArgumentException will be thrown using the error ID supplied.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCArgumentException Class
FCArgumentException Members


CheckIsEmpty Method | fcSDK Documentation

CheckIsEmpty Method

The unique error ID to use if an exception needs to be thrown.

The name of the parameter that contains the index value to check.

The value of the string parameter to verify.

Checks whether or not the supplied string value is null (Nothing in Visual Basic) or empty (trimmed length equals zero).

Syntax

'Declaration

Public Shared Sub CheckIsEmpty( _
   ByVal _errorId_ As Integer, _
   ByVal _paramName_ As String, _
   ByVal _val_ As String _
)

public static void CheckIsEmpty(
   int _errorId_,
   string _paramName_,
   string _val_
)

Parameters

errorId

The unique error ID to use if an exception needs to be thrown.

paramName

The name of the parameter that contains the index value to check.

val

The value of the string parameter to verify.

Exceptions

Exception | Description
FCArgumentException | The string value is null or empty.

Remarks

If the val parameter is null (Nothing in Visual Basic) or empty (trimmed length equals zero) an FCArgumentException will be thrown using the supplied errorId.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCArgumentException Class
FCArgumentException Members


CheckIsNull Method | fcSDK Documentation

CheckIsNull Method

The unique error ID to use if an exception needs to be thrown.

The name of the parameter that contains the index value to check.

The value of the parameter to be verified.

Checks to see whether the given parameter is null (Nothing in Visual Basic).

Syntax

'Declaration

Public Shared Sub CheckIsNull( _
   ByVal _errorId_ As Integer, _
   ByVal _paramName_ As String, _
   ByVal _val_ As Object _
)

public static void CheckIsNull(
   int _errorId_,
   string _paramName_,
   object _val_
)

Parameters

errorId

The unique error ID to use if an exception needs to be thrown.

paramName

The name of the parameter that contains the index value to check.

val

The value of the parameter to be verified.

Exceptions

Exception | Description
FCArgumentException | The value is null.

Remarks

If val is null (Nothing in Visual Basic), and FCArgumentException is thrown using the supplied errorId.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCArgumentException Class
FCArgumentException Members


FCConfiguration Class | fcSDK Documentation

FCConfiguration Class

The FCConfiguration class provides access to the application configuration and ensures that basic required configuration parameters are present.

Syntax

'Declaration

Public NotInheritable Class FCConfiguration

public sealed class FCConfiguration

Remarks

Values stored in the collection can be modified and new values can be added and removed.

NOTE: changing required application configuration values like ConfigValues.CONNECT_STRING may cause the current application to crash.

Inheritance Hierarchy

System.Object
FChoice.Common.FCConfiguration

Requirements

Namespace: FChoice.Common

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

FCConfiguration Members
FChoice.Common Namespace


FCConfiguration Class Members | fcSDK Documentation

FCConfiguration Class Members

The following tables list the members exposed by FCConfiguration.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Current | Gets or sets the current configuration settings or null if none are currently configured.
static (Shared in Visual Basic) | DataProtectionEntropy |

Public Methods

 | Name | Description
static (Shared in Visual Basic) | LoadEnvironmentSettings | Overloaded. Retrieves the current configuration values or loads new ones if no current ones are available.
static (Shared in Visual Basic) | ParseFcEnvFile | Provided for legacy compatibility support, this method will parse an FC.ENV-style configuration file from the specified file path.

Reference

FCConfiguration Class
FChoice.Common Namespace


LoadEnvironmentSettings Method | fcSDK Documentation

LoadEnvironmentSettings Method

Retrieves the current configuration values or loads new ones if no current ones are available.

Causes FCConfiguration to reload it's current configuration values (if forced) or return the current values.

Overload List

Overload | Description
LoadEnvironmentSettings() | Retrieves the current configuration values or loads new ones if no current ones are available.
LoadEnvironmentSettings(NameValueCollection) | Forces a load of new configuration values, using the supplied collection if possible.
LoadEnvironmentSettings(NameValueCollection,Boolean,Boolean) | Retrieves the current configuration values or loads new ones if no current ones are available, using the specified collection if possible.

Remarks

This should generally be called once per application by the "Main" method or class which initializes the application.

NOTE: It is not advisable to call this method after application initialization has occurred. It could potentially crash the application or cause unusual behavior.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCConfiguration Class
FCConfiguration Members


LoadEnvironmentSettings() Method | fcSDK Documentation

LoadEnvironmentSettings() Method

Retrieves the current configuration values or loads new ones if no current ones are available.

Syntax

'Declaration

Public Overloads Shared Function LoadEnvironmentSettings() As NameValueCollection

public static NameValueCollection LoadEnvironmentSettings()

Return Value

A NameValueCollection of values produced by loading the environment settings either from the provided collection, from the current application configuration, or a merge of both.

Remarks

This method will not force a reload of configuration values and will check for required parameters

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCConfiguration Class
FCConfiguration Members
Overload List


LoadEnvironmentSettings(NameValueCollection) Method | fcSDK Documentation

LoadEnvironmentSettings(NameValueCollection) Method

A NameValueCollection of values with which to attempt a load configuration values.

Forces a load of new configuration values, using the supplied collection if possible.

Syntax

'Declaration

Public Overloads Shared Function LoadEnvironmentSettings( _
   ByVal _initialValues_ As NameValueCollection _
) As NameValueCollection

public static NameValueCollection LoadEnvironmentSettings(
   NameValueCollection _initialValues_
)

Parameters

initialValues

A NameValueCollection of values with which to attempt a load configuration values.

Return Value

A NameValueCollection of values produced by loading the environment settings either from the provided collection, from the current application configuration, or a merge of both.

Exceptions

Exception | Description
FCInvalidConfigurationException | One or more required configuration values was not found in the specified initialValues collection.

Remarks

Required parameters will be checked and a FCConfiguration will force a reload of settings based on the supplied values when this method is called.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCConfiguration Class
FCConfiguration Members
Overload List


LoadEnvironmentSettings(NameValueCollection,Boolean,Boolean) Method | fcSDK Documentation

LoadEnvironmentSettings(NameValueCollection,Boolean,Boolean) Method

A NameValueCollection of values with which to attempt a load configuration values.

Specifies whether or not to check for quired values in the collection (like ConfigValues.CONNECT_STRING).

Specifies whether or not to retrieve the current configuration values (if available), or discard the current and load new settings.

Retrieves the current configuration values or loads new ones if no current ones are available, using the specified collection if possible.

Syntax

'Declaration

Public Overloads Shared Function LoadEnvironmentSettings( _
   ByVal _initialValues_ As NameValueCollection, _
   ByVal _checkRequired_ As Boolean, _
   ByVal _forceLoad_ As Boolean _
) As NameValueCollection

public static NameValueCollection LoadEnvironmentSettings(
   NameValueCollection _initialValues_,
   bool _checkRequired_,
   bool _forceLoad_
)

Parameters

initialValues

A NameValueCollection of values with which to attempt a load configuration values.

checkRequired

Specifies whether or not to check for quired values in the collection (like ConfigValues.CONNECT_STRING).

forceLoad

Specifies whether or not to retrieve the current configuration values (if available), or discard the current and load new settings.

Return Value

A NameValueCollection of values produced by loading the environment settings either from the provided collection, from the current application configuration, or a merge of both.

Exceptions

Exception | Description
FCInvalidConfigurationException | One or more required configuration values was not found either in the provided initialValues collection or in the application configuration settings and checkRequired is set to true.

Remarks

If initialValues is null (Nothing in Visual Basic), an attempt will be made to load the settings from the application configuration settings. If the collection is not null, does not contain all the required values, and checkRequired is true, an exception will be thrown.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCConfiguration Class
FCConfiguration Members
Overload List


ParseFcEnvFile Method | fcSDK Documentation

ParseFcEnvFile Method

The relative or absolute file system path to the text file which contains FCFL(COM) FC.ENV-style contents.

Provided for legacy compatibility support, this method will parse an FC.ENV-style configuration file from the specified file path.

Syntax

'Declaration

Public Shared Function ParseFcEnvFile( _
   ByVal _filePath_ As String _
) As NameValueCollection

public static NameValueCollection ParseFcEnvFile(
   string _filePath_
)

Parameters

filePath

The relative or absolute file system path to the text file which contains FCFL(COM) FC.ENV-style contents.

Return Value

A NameValueCollection of values read from the file.

Exceptions

Exception | Description
FCInvalidConfigurationException | The file cannot be accessed (see InnerException) or the file contains syntax errors.

Remarks

If you wish to use an FC.ENV-style file to configure your application, you can use this file to produce a set of configuration values. If you wish to then pass them to LoadEnvironmentSettings, you must first construct the connection string and assign the value with the key ConfigValues.CONNECT_STRING. To produce a provider-specific connection string from a set of values (db_type, db_server, db_name, etc), use the CreateConnectionString method on the current provider: DbProviderFactory.Provider.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCConfiguration Class
FCConfiguration Members


Current Property | fcSDK Documentation

Current Property

Gets or sets the current configuration settings or null if none are currently configured.

Syntax

'Declaration

Public Shared Property Current As NameValueCollection

public static NameValueCollection Current {get; set;}

Property Value

The current configuration settings.

Remarks

If none are loaded, call LoadEnvironmentSettings to load values.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCConfiguration Class
FCConfiguration Members


DataProtectionEntropy Property | fcSDK Documentation

DataProtectionEntropy Property

Syntax

'Declaration

Public Shared Property DataProtectionEntropy As String

public static string DataProtectionEntropy {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCConfiguration Class
FCConfiguration Members


FCExceptionBase Class | fcSDK Documentation

FCExceptionBase Class

FCExceptionBase is the base exception from which all other First Choice exception classes derive. It provides pluggable error message strings which allows for easy runtime customization and localization of error messages.

Syntax

'Declaration

<SerializableAttribute()>
Public MustInherit Class FCExceptionBase
   Inherits System.ApplicationException

[SerializableAttribute()]
public abstract class FCExceptionBase : System.ApplicationException

Remarks

Notes to implementors:

  • FCExceptionBase will attempt to load default string resources from an embedded resource in your derived class' assembly called "Your.Assembly.Name.ErrorStrings.txt". The format of this file is:

    MESSAGEID = This would be your error message with {0} replacement variables

    If you wish to override this behavior and manage the resource loading manually, you can override the GetResourceData() and GetErrorMessageFormat() protected methods.

  • It is recommended that you use unique error numbers every time you throw an exception based on FCExceptionBase. You should choose a range of error numbers and stay consistent in using them.

  • First Choice has reserved error numbers 0 to 1,073,741,824 (0x4000000 hex). Customers should use positive numbers above this range. An easy way to assure this is to always OR your error numbers with 0x4000000.

IMPORTANT: It is important to note that even if you override GetErrorMessageFormat, if a custom message provider is set using SetMessageProvider, the custom message provider will be used before your override of GetErrorMessageFormat. If the custom message provider is unable to load a message, GetErrorMessageFormat will be called next.

Inheritance Hierarchy

System.Object System.Exception System.ApplicationException FChoice.Common.FCExceptionBase FChoice.Common.CommonException FChoice.Common.FCInvalidConfigurationException FChoice.Common.FCLicenseException FChoice.Common.InvalidLoggingConfigException FChoice.Common.State.StateManagerException FChoice.Foundation.Clarify.ClarifyException FChoice.Foundation.Clarify.Compatibility.CompatibilityException FChoice.Foundation.Clarify.Workflow.WorkflowException FChoice.Foundation.FoundationException

Requirements

Namespace: FChoice.Common

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

FCExceptionBase Members FChoice.Common Namespace FChoice.Common.FCExceptionBase FChoice.Common.CommonException FChoice.Common.FCInvalidConfigurationException FChoice.Common.FCLicenseException FChoice.Common.InvalidLoggingConfigException FChoice.Common.State.StateManagerException FChoice.Foundation.Clarify.ClarifyException FChoice.Foundation.Clarify.Compatibility.CompatibilityException FChoice.Foundation.Clarify.Workflow.WorkflowException FChoice.Foundation.FoundationException

Requirements

Namespace: FChoice.Common

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

FCExceptionBase Members FChoice.Common Namespace


FCExceptionBase Class Members | fcSDK Documentation

FCExceptionBase Class Members

The following tables list the members exposed by FCExceptionBase.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorCode | Gets the unique error code for this exception.
Public Property | ErrorMessageID | Gets the message identifier for this exception.
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | Overridden. Gets a message that describes the current exception.
static (Shared in Visual Basic) | MessageProvider | Gets the custom IErrorMessageProvider if one is specified.
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | Overridden. Sets the SerializationInfo object with the parameter name and additional exception information.
Public Method | GetType | (Inherited from System.Exception)
static (Shared in Visual Basic) | SetMessageProvider | Sets the IErrorMessageProvider that FCExceptionBase will use for loading custom exception error message strings for localization or customization.
Public Method | ToString | (Inherited from System.Exception)

Reference

FCExceptionBase Class
FChoice.Common Namespace


GetObjectData Method | fcSDK Documentation

GetObjectData Method

The object that holds the serialized object data.

The contextual information about the source or destination.

Sets the SerializationInfo object with the parameter name and additional exception information.

Syntax

'Declaration
Public Overrides Sub GetObjectData( _
   ByVal _info_ As SerializationInfo, _
   ByVal _context_ As StreamingContext _
)

public override void GetObjectData(
   SerializationInfo _info_,
   StreamingContext _context_
)

Parameters

info

The object that holds the serialized object data.

context

The contextual information about the source or destination.

Remarks

GetObjectData sets a SerializationInfo with all the exception object data targeted for serialization. During deserialization, the exception object is reconstituted from the SerializationInfo transmitted over the stream.

For more information, see SerializationInfo.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCExceptionBase Class
FCExceptionBase Members
Base Implementation in GetObjectData


SetMessageProvider Method | fcSDK Documentation

SetMessageProvider Method

An implementation of IErrorMessageProvider.

Sets the IErrorMessageProvider that FCExceptionBase will use for loading custom exception error message strings for localization or customization.

Syntax

'Declaration

Public Shared Sub SetMessageProvider( _
   ByVal _provider_ As IErrorMessageProvider _
)

public static void SetMessageProvider(
   IErrorMessageProvider _provider_
)

Parameters

provider

An implementation of IErrorMessageProvider.

Remarks

Setting this property will override all error message resolution in for all exceptions deriving from this class. Please see the documentation for IErrorMessageProvider on the details of providing custom error messages.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCExceptionBase Class
FCExceptionBase Members
IErrorMessageProvider Interface


ErrorCode Property | fcSDK Documentation

ErrorCode Property

Gets the unique error code for this exception.

Syntax

'Declaration

Public ReadOnly Property ErrorCode As Integer

public int ErrorCode {get;}

Property Value

A unique integer that identifies this exception instance.

Remarks

Note to implementors:

  • It is recommended that you use unique error numbers every time you throw an exception based on FCExceptionBase. You should choose a range of error numbers and stay consistent in using them.
  • First Choice has reserved error numbers 0 to 1,073,741,824 (0x4000000 hex). Customers should use positive numbers above this range. An easy way to assure this is to always OR your error numbers with 0x4000000.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCExceptionBase Class
FCExceptionBase Members


ErrorMessageID Property | fcSDK Documentation

ErrorMessageID Property

Gets the message identifier for this exception.

Syntax

'Declaration

Public ReadOnly Property ErrorMessageID As String

public string ErrorMessageID {get;}

Property Value

The message identifier for this exception.

Remarks

The error message identifier is used by FCExceptionBase to look up actual user-friendly, localized and/or implementation-customized messages. This is the key used to look up a resource string.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCExceptionBase Class
FCExceptionBase Members


Message Property (FCExceptionBase) | fcSDK Documentation

Message Property (FCExceptionBase)

Gets a message that describes the current exception.

Syntax

'Declaration

Public Overrides ReadOnly Property Message As String

public override string Message {get;}

Property Value

The error message that explains the reason for the exception, or an empty string("").

Remarks

FCExceptionBase will first use the custom IErrorMessageProvider that was set using the SetMessageProvider method. If no custom message provider is specified, FCExceptionBase will then call the protected GetErrorMessageFormat method which can be overridden by derived classes. This method will, by default, attempt to load a full message string from an embedded resource in the current class' assembly manifest. If none is present, then FCExceptionBase will simply return the ErrorMessageID.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCExceptionBase Class
FCExceptionBase Members
Base Implementation in Message


MessageProvider Property | fcSDK Documentation

MessageProvider Property

Gets the custom IErrorMessageProvider if one is specified.

Syntax

'Declaration

Public Shared ReadOnly Property MessageProvider As IErrorMessageProvider

public static IErrorMessageProvider MessageProvider {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCExceptionBase Class
FCExceptionBase Members


FCInvalidConfigurationException Class | fcSDK Documentation

FCInvalidConfigurationException Class

FCInvalidConfigurationException is used when required parameters are missing from the application configuration file, or the parameters specified are invalid for some reason.

Syntax

'Declaration

<SerializableAttribute()>
Public Class FCInvalidConfigurationException
   Inherits FCExceptionBase

[SerializableAttribute()]
public class FCInvalidConfigurationException : FCExceptionBase

Inheritance Hierarchy

System.Object System.Exception System.ApplicationException FChoice.Common.FCExceptionBase FChoice.Common.FCInvalidConfigurationException

Requirements

Namespace: FChoice.Common

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

FCInvalidConfigurationException Members FChoice.Common Namespace FChoice.Common.FCInvalidConfigurationException

Requirements

Namespace: FChoice.Common

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

FCInvalidConfigurationException Members FChoice.Common Namespace


FCInvalidConfigurationException Class Members | fcSDK Documentation

FCInvalidConfigurationException Class Members

The following tables list the members exposed by FCInvalidConfigurationException.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorCode | Gets the unique error code for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | ErrorMessageID | Gets the message identifier for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | Sets the SerializationInfo object with the parameter name and additional exception information. (Inherited from FChoice.Common.FCExceptionBase)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)

Reference

FCInvalidConfigurationException Class
FChoice.Common Namespace


FCLicenseException Class | fcSDK Documentation

FCLicenseException Class

FCLicenseException is used when a licensed product attempts to obtain a license key from the installed set of keys and either cannot find its key or an error occurs retreiving the list of licenses.

Syntax

'Declaration

<SerializableAttribute()>
Public Class FCLicenseException
   Inherits FCExceptionBase

[SerializableAttribute()]
public class FCLicenseException : FCExceptionBase

Inheritance Hierarchy

System.Object System.Exception System.ApplicationException FChoice.Common.FCExceptionBase [FChoice.Common.FCLicenseException**

Requirements

Namespace: FChoice.Common

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

FCLicenseException Members FChoice.Common Namespace FChoice.Common.FCLicenseException

Requirements

Namespace: FChoice.Common

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

FCLicenseException Members FChoice.Common Namespace


FCLicenseException Class Members | fcSDK Documentation

FCLicenseException Class Members

The following tables list the members exposed by FCLicenseException.

Public Constructors

 | Name | Description
Public Constructor | FCLicenseException Constructor | Overloaded.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorCode | Gets the unique error code for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | ErrorMessageID | Gets the message identifier for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
static (Shared in Visual Basic) | GetLicenseLoadError | This method is intended to be used internally by First Choice .NET products.
Public Method | GetObjectData | Sets the SerializationInfo object with the parameter name and additional exception information. (Inherited from FChoice.Common.FCExceptionBase)
static (Shared in Visual Basic) | GetProductLicenseError | This method is intended to be used internally by First Choice .NET products.
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)

Reference

FCLicenseException Class
FChoice.Common Namespace


FCLicenseException Constructor | fcSDK Documentation

FCLicenseException Constructor

Overload List

Overload | Description
FCLicenseException Constructor(Int32,String,Object[]) |
FCLicenseException Constructor(Boolean,Int32,String,Object[]) |
FCLicenseException Constructor(Exception,Int32,String,Object[]) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCLicenseException Class
FCLicenseException Members


FCLicenseException Constructor(Int32,String,Object[]) | fcSDK Documentation

FCLicenseException Constructor(Int32,String,Object[])

Syntax

'Declaration

Public Function New( _
   ByVal _errorId_ As Integer, _
   ByVal _messageId_ As String, _
   ByVal ParamArray _args_() As Object _
)

public FCLicenseException(
   int _errorId_,
   string _messageId_,
   params object\[\] _args_
)

Parameters

errorId

messageId

args

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCLicenseException Class
FCLicenseException Members
Overload List


FCLicenseException Constructor(Boolean,Int32,String,Object[]) | fcSDK Documentation

FCLicenseException Constructor(Boolean,Int32,String,Object[])

Syntax

'Declaration

Public Function New( _
   ByVal _loggingEnabled_ As Boolean, _
   ByVal _errorId_ As Integer, _
   ByVal _messageId_ As String, _
   ByVal ParamArray _args_() As Object _
)

public FCLicenseException(
   bool _loggingEnabled_,
   int _errorId_,
   string _messageId_,
   params object[] _args_
)

Parameters

loggingEnabled

errorId

messageId

args

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCLicenseException Class
FCLicenseException Members
Overload List


FCLicenseException Constructor(Exception,Int32,String,Object[]) | fcSDK Documentation

FCLicenseException Constructor(Exception,Int32,String,Object[])

Syntax

'Declaration

Public Function New( _
   ByVal _innerEx_ As Exception, _
   ByVal _errorId_ As Integer, _
   ByVal _messageId_ As String, _
   ByVal ParamArray _args_() As Object _
)

public FCLicenseException(
   Exception _innerEx_,
   int _errorId_,
   string _messageId_,
   params object[] _args_
)

Parameters

innerEx

errorId

messageId

args

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCLicenseException Class
FCLicenseException Members
Overload List


GetLicenseLoadError Method | fcSDK Documentation

GetLicenseLoadError Method

This method is intended to be used internally by First Choice .NET products.

Syntax

'Declaration

Public Shared Function GetLicenseLoadError( _
   ByVal _ex_ As Exception, _
   ByVal _errorId_ As Integer, _
   ByVal _reason_ As FCLicenseException.LoadFailReasons _
) As FCLicenseException

public static FCLicenseException GetLicenseLoadError(
   Exception _ex_,
   int _errorId_,
   FCLicenseException.LoadFailReasons _reason_
)

Parameters

ex

errorId

reason

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCLicenseException Class
FCLicenseException Members


GetProductLicenseError Method | fcSDK Documentation

GetProductLicenseError Method

This method is intended to be used internally by First Choice .NET products.

Syntax

'Declaration

Public Shared Function GetProductLicenseError( _
   ByVal _errorId_ As Integer, _
   ByVal _productId_ As Integer _
) As FCLicenseException

public static FCLicenseException GetProductLicenseError(
   int _errorId_,
   int _productId_
)

Parameters

errorId

productId

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCLicenseException Class
FCLicenseException Members


InvalidLoggingConfigException Class | fcSDK Documentation

InvalidLoggingConfigException Class

Syntax

'Declaration

<SerializableAttribute()>
Public Class InvalidLoggingConfigException
   Inherits FCExceptionBase

[SerializableAttribute()]
public class InvalidLoggingConfigException : FCExceptionBase

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
FChoice.Common.FCExceptionBase
FChoice.Common.InvalidLoggingConfigException

Requirements

Namespace: FChoice.Common

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

InvalidLoggingConfigException Members
FChoice.Common Namespace


InvalidLoggingConfigException Class Members | fcSDK Documentation

InvalidLoggingConfigException Class Members

The following tables list the members exposed by InvalidLoggingConfigException.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorCode | Gets the unique error code for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | ErrorMessageID | Gets the message identifier for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | Sets the SerializationInfo object with the parameter name and additional exception information. (Inherited from FChoice.Common.FCExceptionBase)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)

Reference

InvalidLoggingConfigException Class
FChoice.Common Namespace


Logger Class | fcSDK Documentation

Logger Class

Logger is used by classes throughout First Choice .NET-based products to write logging entries.

Syntax

'Declaration

Public Class Logger

public class Logger

Remarks

Use LogManager.GetLogger to retrieve a specific logger. Once an instance is obtained, use the various Log methods to write logging events to configured logging appenders.

Inheritance Hierarchy

System.Object
FChoice.Common.Logger

Requirements

Namespace: FChoice.Common

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

Logger Members
FChoice.Common Namespace


Logger Class Members | fcSDK Documentation

Logger Class Members

The following tables list the members exposed by Logger.

Public Properties

 | Name | Description
Public Property | IsDebugEnabled |
Public Property | IsErrorEnabled |
Public Property | IsFatalEnabled |
Public Property | IsInfoEnabled |
Public Property | IsWarnEnabled |

Public Methods

 | Name | Description
Public Method | Log | Overloaded. Writes a log entry with the specified level (if logging for that level is enabled).
Public Method | LogDebug | Overloaded. Writes a DEBUG-level log entry if DEBUG-level logging is enabled.
Public Method | LogError | Overloaded. Writes a ERROR-level log entry if ERROR-level logging is enabled.
Public Method | LogInfo | Overloaded. Writes a INFO-level log entry if INFO-level logging is enabled.
Public Method | LogWarn | Overloaded. Writes a WARN-level log entry if WARN-level logging is enabled.

Reference

Logger Class
FChoice.Common Namespace


Log Method (Logger) | fcSDK Documentation

Log Method (Logger)

Overload List

Overload | Description
Log(LogLevel,String,Object[]) | Writes a log entry with the specified level (if logging for that level is enabled).
Log(LogLevel,Exception,String,Object[]) | Writes a log entry with the specified level (if logging for that level is enabled) with details about an exception that was caught.

Remarks

It is recommended that you use the individual Log* methods rather than this general method. This method is only provided for rare circumstances where the log level at which to write a specific entry is not known until runtime.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Logger Class Logger Members


Log(LogLevel,String,Object[]) Method | fcSDK Documentation

Log(LogLevel,String,Object[]) Method

The level at which to write this entry (if configured).

A format string with replacement parameters that will be replaced by the args parameters.

Arguments to use in replacing variables in the format string.

Writes a log entry with the specified level (if logging for that level is enabled).

Syntax

'Declaration

Public Overloads Sub Log( _
   ByVal _level_ As LogLevel, _
   ByVal _format_ As String, _
   ByVal ParamArray _args_() As Object _
)

public void Log(
   LogLevel _level_,
   string _format_,
   params object\[\] _args_
)

Parameters

level

The level at which to write this entry (if configured).

format

A format string with replacement parameters that will be replaced by the args parameters.

args

Arguments to use in replacing variables in the format string.

Remarks

For details of how string formatting works, please see the details of the String.Format method.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Logger Class
Logger Members
Overload List


Log(LogLevel,Exception,String,Object[]) Method | fcSDK Documentation

Log(LogLevel,Exception,String,Object[]) Method

The level at which to write this entry (if configured).

The exception that is related to this entry. The details of the exception will be written to the configured appender(s).

A format string with replacement parameters that will be replaced by the args parameters.

Arguments to use in replacing variables in the format string.

Writes a log entry with the specified level (if logging for that level is enabled) with details about an exception that was caught.

Syntax

'Declaration

Public Overloads Sub Log( _
   ByVal _level_ As LogLevel, _
   ByVal _ex_ As Exception, _
   ByVal _format_ As String, _
   ByVal ParamArray _args_() As Object _
)

public void Log(
   LogLevel _level_,
   Exception _ex_,
   string _format_,
   params object[] _args_
)

Parameters

level

The level at which to write this entry (if configured).

ex

The exception that is related to this entry. The details of the exception will be written to the configured appender(s).

format

A format string with replacement parameters that will be replaced by the args parameters.

args

Arguments to use in replacing variables in the format string.

Remarks

For details of how string formatting works, please see the details of the String.Format method.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Logger Class
Logger Members
Overload List


LogDebug Method (Logger) | fcSDK Documentation

LogDebug Method (Logger)

Overload List

Overload | Description
LogDebug(String,Object[]) | Writes a DEBUG-level log entry if DEBUG-level logging is enabled.
LogDebug(Exception,String,Object[]) | Writes a DEBUG-level log entry if DEBUG-level logging is enabled with details of an exception that was caught.

Remarks

If the current logger is not configured for DEBUG-level logging, these methods will do nothing.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Logger Class Logger Members


LogDebug(String,Object[]) Method | fcSDK Documentation

LogDebug(String,Object[]) Method

A format string with replacement parameters that will be replaced by the args parameters.

Arguments to use in replacing variables in the format string.

Writes a DEBUG-level log entry if DEBUG-level logging is enabled.

Syntax

'Declaration

Public Overloads Sub LogDebug( _
   ByVal _format_ As String, _
   ByVal ParamArray _args_() As Object _
)

public void LogDebug(
   string _format_,
   params object\[\] _args_
)

Parameters

format

A format string with replacement parameters that will be replaced by the args parameters.

args

Arguments to use in replacing variables in the format string.

Remarks

If the current logger is not configured for DEBUG-level logging, this method will do nothing.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Logger Class
Logger Members
Overload List


LogDebug(Exception,String,Object[]) Method | fcSDK Documentation

LogDebug(Exception,String,Object[]) Method

The exception that is related to this entry. The details of the exception will be written to the configured appender(s).

A format string with replacement parameters that will be replaced by the args parameters.

Arguments to use in replacing variables in the format string.

Writes a DEBUG-level log entry if DEBUG-level logging is enabled with details of an exception that was caught.

Syntax

'Declaration

Public Overloads Sub LogDebug( _
   ByVal _ex_ As Exception, _
   ByVal _format_ As String, _
   ByVal ParamArray _args_() As Object _
)

public void LogDebug(
   Exception _ex_,
   string _format_,
   params object[] _args_
)

Parameters

ex

The exception that is related to this entry. The details of the exception will be written to the configured appender(s).

format

A format string with replacement parameters that will be replaced by the args parameters.

args

Arguments to use in replacing variables in the format string.

Remarks

If the current logger is not configured for DEBUG-level logging, this method will do nothing.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Logger Class
Logger Members
Overload List


LogError Method (Logger) | fcSDK Documentation

LogError Method (Logger)

Overload List

Overload | Description
LogError(String,Object[]) | Writes a ERROR-level log entry if ERROR-level logging is enabled.
LogError(Exception,String,Object[]) | Writes a ERROR-level log entry if ERROR-level logging is enabled as well as the details of an exception that was caught.

Remarks

If the current logger is not configured for ERROR-level logging or lower, these methods will do nothing.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Logger Class Logger Members


LogError(String,Object[]) Method | fcSDK Documentation

LogError(String,Object[]) Method

A format string with replacement parameters that will be replaced by the args parameters.

Arguments to use in replacing variables in the format string.

Writes a ERROR-level log entry if ERROR-level logging is enabled.

Syntax

'Declaration

Public Overloads Sub LogError( _
   ByVal _format_ As String, _
   ByVal ParamArray _args_() As Object _
)

public void LogError(
   string _format_,
   params object\[\] _args_
)

Parameters

format

A format string with replacement parameters that will be replaced by the args parameters.

args

Arguments to use in replacing variables in the format string.

Remarks

If the current logger is not configured for ERROR-level logging or lower, this method will do nothing.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Logger Class
Logger Members
Overload List


LogError(Exception,String,Object[]) Method | fcSDK Documentation

LogError(Exception,String,Object[]) Method

The exception that is related to this entry. The details of the exception will be written to the configured appender(s).

A format string with replacement parameters that will be replaced by the args parameters.

Arguments to use in replacing variables in the format string.

Writes a ERROR-level log entry if ERROR-level logging is enabled as well as the details of an exception that was caught.

Syntax

'Declaration

Public Overloads Sub LogError( _
   ByVal _ex_ As Exception, _
   ByVal _format_ As String, _
   ByVal ParamArray _args_() As Object _
)

public void LogError(
   Exception _ex_,
   string _format_,
   params object[] _args_
)

Parameters

ex

The exception that is related to this entry. The details of the exception will be written to the configured appender(s).

format

A format string with replacement parameters that will be replaced by the args parameters.

args

Arguments to use in replacing variables in the format string.

Remarks

If the current logger is not configured for ERROR-level logging or lower, this method will do nothing.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Logger Class
Logger Members
Overload List


LogInfo Method (Logger) | fcSDK Documentation

LogInfo Method (Logger)

Overload List

Overload | Description
LogInfo(String,Object[]) | Writes a INFO-level log entry if INFO-level logging is enabled.
LogInfo(Exception,String,Object[]) | Writes a INFO-level log entry if INFO-level logging is enabled as well as the details of an exception that was caught.

Remarks

If the current logger is not configured for INFO-level logging or lower, these methods will do nothing.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Logger Class Logger Members


LogInfo(String,Object[]) Method | fcSDK Documentation

LogInfo(String,Object[]) Method

A format string with replacement parameters that will be replaced by the args parameters.

Arguments to use in replacing variables in the format string.

Writes a INFO-level log entry if INFO-level logging is enabled.

Syntax

'Declaration

Public Overloads Sub LogInfo( _
   ByVal _format_ As String, _
   ByVal ParamArray _args_() As Object _
)

public void LogInfo(
   string _format_,
   params object\[\] _args_
)

Parameters

format

A format string with replacement parameters that will be replaced by the args parameters.

args

Arguments to use in replacing variables in the format string.

Remarks

If the current logger is not configured for INFO-level logging or lower, this method will do nothing.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Logger Class
Logger Members
Overload List


LogInfo(Exception,String,Object[]) Method | fcSDK Documentation

LogInfo(Exception,String,Object[]) Method

The exception that is related to this entry. The details of the exception will be written to the configured appender(s).

A format string with replacement parameters that will be replaced by the args parameters.

Arguments to use in replacing variables in the format string.

Writes a INFO-level log entry if INFO-level logging is enabled as well as the details of an exception that was caught.

Syntax

'Declaration

Public Overloads Sub LogInfo( _
   ByVal _ex_ As Exception, _
   ByVal _format_ As String, _
   ByVal ParamArray _args_() As Object _
)

public void LogInfo(
   Exception _ex_,
   string _format_,
   params object[] _args_
)

Parameters

ex

The exception that is related to this entry. The details of the exception will be written to the configured appender(s).

format

A format string with replacement parameters that will be replaced by the args parameters.

args

Arguments to use in replacing variables in the format string.

Remarks

If the current logger is not configured for INFO-level logging or lower, this method will do nothing.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Logger Class
Logger Members
Overload List


LogWarn Method (Logger) | fcSDK Documentation

LogWarn Method (Logger)

Overload List

Overload | Description
LogWarn(String,Object[]) | Writes a WARN-level log entry if WARN-level logging is enabled.
LogWarn(Exception,String,Object[]) | Writes a WARN-level log entry if WARN-level logging is enabled as well as the details of an exception that was caught.

Remarks

If the current logger is not configured for WARN-level logging or lower, these methods will do nothing.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Logger Class Logger Members


LogWarn(String,Object[]) Method | fcSDK Documentation

LogWarn(String,Object[]) Method

A format string with replacement parameters that will be replaced by the args parameters.

Arguments to use in replacing variables in the format string.

Writes a WARN-level log entry if WARN-level logging is enabled.

Syntax

'Declaration

Public Overloads Sub LogWarn( _
   ByVal _format_ As String, _
   ByVal ParamArray _args_() As Object _
)

public void LogWarn(
   string _format_,
   params object\[\] _args_
)

Parameters

format

A format string with replacement parameters that will be replaced by the args parameters.

args

Arguments to use in replacing variables in the format string.

Remarks

If the current logger is not configured for WARN-level logging or lower, this method will do nothing.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Logger Class
Logger Members
Overload List


LogWarn(Exception,String,Object[]) Method | fcSDK Documentation

LogWarn(Exception,String,Object[]) Method

The exception that is related to this entry. The details of the exception will be written to the configured appender(s).

A format string with replacement parameters that will be replaced by the args parameters.

Arguments to use in replacing variables in the format string.

Writes a WARN-level log entry if WARN-level logging is enabled as well as the details of an exception that was caught.

Syntax

'Declaration

Public Overloads Sub LogWarn( _
   ByVal _ex_ As Exception, _
   ByVal _format_ As String, _
   ByVal ParamArray _args_() As Object _
)

public void LogWarn(
   Exception _ex_,
   string _format_,
   params object[] _args_
)

Parameters

ex

The exception that is related to this entry. The details of the exception will be written to the configured appender(s).

format

A format string with replacement parameters that will be replaced by the args parameters.

args

Arguments to use in replacing variables in the format string.

Remarks

If the current logger is not configured for WARN-level logging or lower, this method will do nothing.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Logger Class
Logger Members
Overload List


IsDebugEnabled Property | fcSDK Documentation

IsDebugEnabled Property

Syntax

'Declaration

Public ReadOnly Property IsDebugEnabled As Boolean

public bool IsDebugEnabled {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Logger Class
Logger Members


IsErrorEnabled Property | fcSDK Documentation

IsErrorEnabled Property

Syntax

'Declaration

Public ReadOnly Property IsErrorEnabled As Boolean

public bool IsErrorEnabled {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Logger Class
Logger Members


IsFatalEnabled Property | fcSDK Documentation

IsFatalEnabled Property

Syntax

'Declaration

Public ReadOnly Property IsFatalEnabled As Boolean

public bool IsFatalEnabled {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Logger Class
Logger Members


IsInfoEnabled Property | fcSDK Documentation

IsInfoEnabled Property

Syntax

'Declaration

Public ReadOnly Property IsInfoEnabled As Boolean

public bool IsInfoEnabled {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Logger Class
Logger Members


IsWarnEnabled Property | fcSDK Documentation

IsWarnEnabled Property

Syntax

'Declaration

Public ReadOnly Property IsWarnEnabled As Boolean

public bool IsWarnEnabled {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Logger Class
Logger Members


LogManager Class | fcSDK Documentation

LogManager Class

LogManager provides access to the logging subsystem so that classes and write log entries and allow those entries to be processed according to the application logging configuration.

Syntax

'Declaration

Public NotInheritable Class LogManager

public sealed class LogManager

Remarks

LogManager provides classes with access to the logging subsystem, as well as some basic ability to programmatically control it's behavior at runtime.

NOTE: Changing logging configuration at runtime is an expensive operation and should not be done frequently. The main use case for runtime configuration is occasional changes driven by a human system administrator or developer troubleshooting a problem.

Inheritance Hierarchy

System.Object
FChoice.Common.LogManager

Requirements

Namespace: FChoice.Common

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

LogManager Members
FChoice.Common Namespace


LogManager Class Members | fcSDK Documentation

LogManager Class Members

The following tables list the members exposed by LogManager.

Public Constructors

 | Name | Description
Public Constructor | LogManager Constructor |

Public Fields

 | Name | Description
static (Shared in Visual Basic) | SyncRoot | Gets an object that can be used to synchronize access to LogManager.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Instance | Gets the singleton instance of LogManager.
static (Shared in Visual Basic) | IsInitialized | Gets whether or not LogManager has been properly initialized.
static (Shared in Visual Basic) | LogConfigFilePath | Gets or sets the full path to the file LogManager should attempt to use to configure itself.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | AddAppenderToLogger | Overloaded. Links a given appender to the specified .NET type-identified logger.
static (Shared in Visual Basic) | AddAppenderToRoot | Adds an already-prepared appender to the root level (affecting all loggers).
static (Shared in Visual Basic) | AddLogFileAppender | Creates a new rolling log file appender and adds it to the configuration for use elsewhere.
static (Shared in Visual Basic) | FindFile |
static (Shared in Visual Basic) | GetLogger | Overloaded. Retrieves a logger for the given type name.
static (Shared in Visual Basic) | Initialize | Initializes the LogManager.
static (Shared in Visual Basic) | Reconfigure |
static (Shared in Visual Basic) | ResetConfiguration | Resets the log configuration and configuration file back to defaults (root level set to INFO with no appenders).
static (Shared in Visual Basic) | SetLoggerLevel | Overloaded. Changes a specific logger's (specified by type) logging level.
static (Shared in Visual Basic) | SetRootLoggerLevel | Changes the root's logging level (affecting all loggers)
static (Shared in Visual Basic) | SetThreadContextValue | Sets a context variable for this thread.

Reference

LogManager Class
FChoice.Common Namespace


LogManager Constructor | fcSDK Documentation

LogManager Constructor

Syntax

'Declaration

Public Function New()

public LogManager()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogManager Class
LogManager Members


AddAppenderToLogger Method | fcSDK Documentation

AddAppenderToLogger Method

Overload List

Overload | Description
AddAppenderToLogger(String,Type) | Links a given appender to the specified .NET type-identified logger.
AddAppenderToLogger(String,String) | Links a given appender to the specified logger name.

Remarks

This will not clear out any existing appenders that may be configured for that logger, it will merely add it to the list. The only way to clear the appenders for a logger is to call ResetConfiguration and reconfigure all the loggers again.

To prepare a rolling file-based appender, see the AddLogFileAppender method.

NOTE: After you are finished configuring LogManager, you must call Reconfigure in order for the changes to fully take effect.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogManager Class LogManager Members


AddAppenderToLogger(String,Type) Method | fcSDK Documentation

AddAppenderToLogger(String,Type) Method

The name of an existing appender to associate with this logger.

The type which represents the name of the logger that is to start using the appender.

Links a given appender to the specified .NET type-identified logger.

Syntax

'Declaration

Public Overloads Shared Sub AddAppenderToLogger( _
   ByVal _appenderName_ As String, _
   ByVal _typeBeingLogged_ As Type _
)

public static void AddAppenderToLogger(
   string _appenderName_,
   Type _typeBeingLogged_
)

Parameters

appenderName

The name of an existing appender to associate with this logger.

typeBeingLogged

The type which represents the name of the logger that is to start using the appender.

Remarks

This will not clear out any existing appenders that may be configured for that logger, it will merely add it to the list. The only way to clear the appenders for a logger is to call ResetConfiguration and reconfigure all the loggers again.

To prepare a rolling file-based appender, see the AddLogFileAppender method.

NOTE: After you are finished configuring LogManager, you must call Reconfigure in order for the changes to fully take effect.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogManager Class
LogManager Members
Overload List


AddAppenderToLogger(String,String) Method | fcSDK Documentation

AddAppenderToLogger(String,String) Method

The name of an existing appender to associate with this logger.

The name of the logger that is to start using the appender.

Links a given appender to the specified logger name.

Syntax

'Declaration

Public Overloads Shared Sub AddAppenderToLogger( _
   ByVal _appenderName_ As String, _
   ByVal _loggerName_ As String _
)

public static void AddAppenderToLogger(
   string _appenderName_,
   string _loggerName_
)

Parameters

appenderName

The name of an existing appender to associate with this logger.

loggerName

The name of the logger that is to start using the appender.

Remarks

This will not clear out any existing appenders that may be configured for that logger, it will merely add it to the list. The only way to clear the appenders for a logger is to call ResetConfiguration and reconfigure all the loggers again.

To prepare a rolling file-based appender, see the AddLogFileAppender method.

NOTE: After you are finished configuring LogManager, you must call Reconfigure in order for the changes to fully take effect.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogManager Class
LogManager Members
Overload List


AddAppenderToRoot Method | fcSDK Documentation

AddAppenderToRoot Method

The name of an existing appender to associate with this logger.

Adds an already-prepared appender to the root level (affecting all loggers).

Syntax

'Declaration

Public Shared Sub AddAppenderToRoot( _
   ByVal _appenderName_ As String _
)

public static void AddAppenderToRoot(
   string _appenderName_
)

Parameters

appenderName

The name of an existing appender to associate with this logger.

Remarks

This will not clear out any existing appenders that may be configured for the root, it will merely add it to the list. The only way to clear the appenders for a logger (including the root) is to call ResetConfiguration and reconfigure all the loggers again.

To prepare a rolling file-based appender, see the AddLogFileAppender method.

NOTE: After you are finished configuring LogManager, you must call Reconfigure in order for the changes to fully take effect.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogManager Class
LogManager Members


AddLogFileAppender Method | fcSDK Documentation

AddLogFileAppender Method

A unique name to use for this appender for reference later.

The full or relative path to the file to create or use for logging. If one exists, it will be appended to.

Creates a new rolling log file appender and adds it to the configuration for use elsewhere.

Syntax

'Declaration

Public Shared Sub AddLogFileAppender( _
   ByVal _appenderName_ As String, _
   ByVal _fileName_ As String _
)

public static void AddLogFileAppender(
   string _appenderName_,
   string _fileName_
)

Parameters

appenderName

A unique name to use for this appender for reference later.

fileName

The full or relative path to the file to create or use for logging. If one exists, it will be appended to.

Remarks

This will create an initialize the appender. Nothing will be written to the file until this appender is associated with the root logger or any loggers in the hierarchy. See the AddAppenderToRoot and AddAppenderToLogger methods for more information on how to do this association.

NOTE: After you are finished configuring LogManager, you must call Reconfigure in order for the changes to fully take effect.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogManager Class
LogManager Members


FindFile Method | fcSDK Documentation

FindFile Method

Syntax

'Declaration

Public Shared Function FindFile( _
   ByVal _suggestedFilePath_ As String _
) As String

public static string FindFile(
   string _suggestedFilePath_
)

Parameters

suggestedFilePath

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogManager Class
LogManager Members


GetLogger Method | fcSDK Documentation

GetLogger Method

Overload List

Overload | Description
GetLogger(Type) | Retrieves a logger for the given type name.
GetLogger(String) | Retrieves a logger for the given logger name.

Example

This example shows a variety of ways in which to create a logger. The reccommended way is to declare a static (Shared in Visual Basic) Logger member at the top of your class and use Reflection to get the current type as demonstrated. This way is reusable in that you can copy and paste it into the top of every class.

// Reusable (cut-n-paste) declaration you can put at the top of every class (recommended).
private static Logger log = LogManager.GetLogger( System.Reflection.MethodBase.GetCurrentMethod().DeclaringType );

// Will retieve a logger named the same as the full type name (i.e. "Your.Assembly.TypeName").
Logger log = LogManager.GetLogger( this.GetType() );

// Will retrieve a logger by a specific name (not recommended).
Logger log = LogManager.GetLogger("some_unique_name");

' Reusable (cut-n-paste) declaration you can put at the top of every class (recommended).
Private Shared log As Logger = LogManager.GetLogger(System.Reflection.MethodBase.GetCurrentMethod().DeclaringType )

' Will retieve a logger named the same as the full type name (i.e. "Your.Assembly.TypeName").
Dim log As Logger = LogManager.GetLogger( this.GetType() )

' Will retrieve a logger by a specific name (not recommended).
Dim log As Logger = LogManager.GetLogger("some_unique_name")

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogManager Class LogManager Members


GetLogger(Type) Method | fcSDK Documentation

GetLogger(Type) Method

GetLogger(Type) Method

The type which represents the name of the logger to retrieve.

Retrieves a logger for the given type name.

Syntax

'Declaration

Public Overloads Shared Function GetLogger( _
   ByVal _loggerType_ As Type _
) As Logger

public static Logger GetLogger(
   Type _loggerType_
)

Parameters

loggerType

The type which represents the name of the logger to retrieve.

Return Value

The logger configured for the specified logger type.

Remarks

It is generally a good idea to declare a logger once at the top of your class as a static member. Though this method does very little and has very little impact on performance, it makes the code easier to read by having access to the log whenever and wherever rather than being forced to retrieve it every time it's needed.

Example

This example shows a variety of ways in which to create a logger. The reccommended way is to declare a static (Shared in Visual Basic) Logger member at the top of your class and use Reflection to get the current type as demonstrated. This way is reusable in that you can copy and paste it into the top of every class.

// Reusable (cut-n-paste) declaration you can put at the top of every class (recommended).
private static Logger log = LogManager.GetLogger( System.Reflection.MethodBase.GetCurrentMethod().DeclaringType );

// Will retrieve a logger named the same as the full type name (i.e. "Your.Assembly.TypeName").
Logger log = LogManager.GetLogger( this.GetType() );

// Will retrieve a logger by a specific name (not recommended).
Logger log = LogManager.GetLogger("some_unique_name");

' Reusable (cut-n-paste) declaration you can put at the top of every class (recommended).
Private Shared log As Logger = LogManager.GetLogger( System.Reflection.MethodBase.GetCurrentMethod().DeclaringType )

' Will retrieve a logger named the same as the full type name (i.e. "Your.Assembly.TypeName").
Dim log As Logger = LogManager.GetLogger( this.GetType() )

' Will retrieve a logger by a specific name (not recommended).
Dim log As Logger = LogManager.GetLogger("some_unique_name")

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogManager Class
LogManager Members
Overload List


GetLogger(String) Method | fcSDK Documentation

GetLogger(String) Method

GetLogger(String) Method

The name of the logger to retrieve.

Retrieves a logger for the given logger name.

Syntax

'Declaration

Public Overloads Shared Function GetLogger( _
   ByVal _loggerName_ As String _
) As Logger

public static Logger GetLogger(
   string _loggerName_
)

Parameters

loggerName

The name of the logger to retrieve.

Return Value

The logger configured for the specified logger name.

Remarks

It is generally a good idea to declare a logger once at the top of your class as a static member. Though this method does very little and has very little impact on performance, it makes the code easier to read by having access to the log whenever and wherever rather than being forced to retrieve it every time it's needed.

Example

This example shows a variety of ways in which to create a logger. The reccommended way is to declare a static (Shared in Visual Basic) Logger member at the top of your class and use Reflection to get the current type as demonstrated. This way is reusable in that you can copy and paste it into the top of every class.

// Reusable (cut-n-paste) declaration you can put at the top of every class (recommended).
private static Logger log = LogManager.GetLogger( System.Reflection.MethodBase.GetCurrentMethod().DeclaringType );

// Will retieve a logger named the same as the full type name (i.e. "Your.Assembly.TypeName").
Logger log = LogManager.GetLogger( this.GetType() );

// Will retrieve a logger by a specific name (not recommended).
Logger log = LogManager.GetLogger("some_unique_name");

' Reusable (cut-n-paste) declaration you can put at the top of every class (recommended). Private Shared log As Logger = LogManager.GetLogger( System.Reflection.MethodBase.GetCurrentMethod().DeclaringType )

' Will retieve a logger named the same as the full type name (i.e. "Your.Assembly.TypeName"). Dim log As Logger = LogManager.GetLogger( this.GetType() )

' Will retrieve a logger by a specific name (not recommended). Dim log As Logger = LogManager.GetLogger("some_unique_name")

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogManager Class
LogManager Members
Overload List


Initialize Method (LogManager) | fcSDK Documentation

Initialize Method (LogManager)

Initializes the LogManager.

Syntax

'Declaration

Public Shared Sub Initialize()

public static void Initialize()

Remarks

It is not necessary to call this method as LogManager will initialize itself. This method is provided for special circumstances where LogManager's initialization must be delayed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogManager Class
LogManager Members


Reconfigure() Method | fcSDK Documentation

Reconfigure() Method

Syntax

'Declaration

Public Shared Sub Reconfigure()

public static void Reconfigure()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogManager Class
LogManager Members


ResetConfiguration Method | fcSDK Documentation

ResetConfiguration Method

Resets the log configuration and configuration file back to defaults (root level set to INFO with no appenders).

Syntax

'Declaration

Public Shared Sub ResetConfiguration()

public static void ResetConfiguration()

Remarks

WARNING: Call this only if you're sure you wish to lose all logging configuration and reset back to nothing.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogManager Class
LogManager Members


SetLoggerLevel Method | fcSDK Documentation

SetLoggerLevel Method

Overload List

Overload | Description
SetLoggerLevel(Type,LogLevel) | Changes a specific logger's (specified by type) logging level.
SetLoggerLevel(String,LogLevel) | Changes a specific logger's (specified by name) logging level.

Remarks

NOTE: After you are finished configuring LogManager, you must call Reconfigure in order for the changes to fully take effect.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogManager Class LogManager Members


SetLoggerLevel(Type,LogLevel) Method | fcSDK Documentation

SetLoggerLevel(Type,LogLevel) Method

The type which represents the name of the logger whose level is to be set.

The level at which the logger should start logging.

Changes a specific logger's (specified by type) logging level.

Syntax

'Declaration

Public Overloads Shared Sub SetLoggerLevel( _
   ByVal _loggerType_ As Type, _
   ByVal _level_ As LogLevel _
)

public static void SetLoggerLevel(
   Type _loggerType_,
   LogLevel _level_
)

Parameters

loggerType

The type which represents the name of the logger whose level is to be set.

level

The level at which the logger should start logging.

Remarks

NOTE: After you are finished configuring LogManager, you must call Reconfigure in order for the changes to fully take effect.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogManager Class
LogManager Members
Overload List


SetLoggerLevel(String,LogLevel) Method | fcSDK Documentation

SetLoggerLevel(String,LogLevel) Method

The name of the logger whose level is to be set.

The level at which the logger should start logging.

Changes a specific logger's (specified by name) logging level.

Syntax

'Declaration

Public Overloads Shared Sub SetLoggerLevel( _
   ByVal _loggerName_ As String, _
   ByVal _level_ As LogLevel _
)

public static void SetLoggerLevel(
   string _loggerName_,
   LogLevel _level_
)

Parameters

loggerName

The name of the logger whose level is to be set.

level

The level at which the logger should start logging.

Remarks

NOTE: After you are finished configuring LogManager, you must call Reconfigure in order for the changes to fully take effect.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogManager Class
LogManager Members
Overload List


SetRootLoggerLevel Method | fcSDK Documentation

SetRootLoggerLevel Method

The level at which the root should start logging.

Changes the root's logging level (affecting all loggers)

Syntax

'Declaration

Public Shared Sub SetRootLoggerLevel( _
   ByVal _level_ As LogLevel _
)

public static void SetRootLoggerLevel(
   LogLevel _level_
)

Parameters

level

The level at which the root should start logging.

Remarks

NOTE: After you are finished configuring LogManager, you must call Reconfigure in order for the changes to fully take effect.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogManager Class
LogManager Members


SetThreadContextValue Method | fcSDK Documentation

SetThreadContextValue Method

The key or name to use for this variable.

The current value to assign to this variable for this thread.

Sets a context variable for this thread.

Syntax

'Declaration

Public Shared Sub SetThreadContextValue( _
   ByVal _key_ As String, _
   ByVal _value_ As String _
)

public static void SetThreadContextValue(
   string _key_,
   string _value_
)

Parameters

key

The key or name to use for this variable.

value

The current value to assign to this variable for this thread.

Remarks

This variable allows you to add contextual information to your log entries (like the session ID or username of the currently logged-in user, etc. This applies only when using manual configuration of LogManager through configuration file. In the section of an appender, you can add the value of a thread context variable using the following syntax:

[%X{user} %X{session}]

You can then set two thread context values for key "user" and key "session" and they will print out in the log file.

For more information on configuring LogManager and defining appenders and layouts, please consult the user guide for your application.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogManager Class
LogManager Members


Instance Property (LogManager) | fcSDK Documentation

Instance Property (LogManager)

Gets the singleton instance of LogManager.

Syntax

'Declaration

Public Shared ReadOnly Property Instance As LogManager

public static LogManager Instance {get;}

Property Value

The singleton instance of LogManager.

Remarks

It is not necessary to do anything with the instance of LogManager. This is provided only for internal use in First Choice .NET products.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogManager Class
LogManager Members


IsInitialized Property (LogManager) | fcSDK Documentation

IsInitialized Property (LogManager)

Gets whether or not LogManager has been properly initialized.

Syntax

'Declaration

Public Shared ReadOnly Property IsInitialized As Boolean

public static bool IsInitialized {get;}

Property Value

Whether or not LogManager has been properly initialized.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogManager Class
LogManager Members


LogConfigFilePath Property | fcSDK Documentation

LogConfigFilePath Property

Gets or sets the full path to the file LogManager should attempt to use to configure itself.

Syntax

'Declaration

Public Shared Property LogConfigFilePath As String

public static string LogConfigFilePath {get; set;}

Property Value

The full path to the file LogManager will use for configuration.

Remarks

Setting this value will not cause LogManager to reconfigure itself immediately. You must call Reconfigure in order for the changes to take effect.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogManager Class
LogManager Members


SyncRoot Field (LogManager) | fcSDK Documentation

SyncRoot Field (LogManager)

Gets an object that can be used to synchronize access to LogManager.

Syntax

'Declaration

Public Shared ReadOnly SyncRoot As Object

public static readonly object SyncRoot

Field Value

An object that can be used to synchronize access to LogManager.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogManager Class
LogManager Members


PerfManager Class | fcSDK Documentation

PerfManager Class

Provides basic convenience services for instrumenting performance counters in an application

Syntax

'Declaration

Public NotInheritable Class PerfManager

public sealed class PerfManager

Inheritance Hierarchy

System.Object
FChoice.Common.PerfManager

Requirements

Namespace: FChoice.Common

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

PerfManager Members
FChoice.Common Namespace


PerfManager Class Members | fcSDK Documentation

PerfManager Class Members

The following tables list the members exposed by PerfManager.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Instance | Retreives a reference to the singleton instance of PerfManager
Public Property | InstanceName | Gets the instance name for this application as it will appear in the PerfMon utility
static (Shared in Visual Basic) | IsEnabled |
static (Shared in Visual Basic) | IsInitialized |

Public Methods

 | Name | Description
static (Shared in Visual Basic) | DeInitialize |
Public Method | GetCounter |
static (Shared in Visual Basic) | GetPerfDurationSecs | Returns the number of seconds that have elapsed since a specified time
static (Shared in Visual Basic) | GetPerfTimer | Gets the current value of the high-resolution performance counter
static (Shared in Visual Basic) | Initialize | Allows PerfManager to initialize itself by creating a new PerfMon instance name and preparing all the PerformanceCounter instances

Reference

PerfManager Class
FChoice.Common Namespace


DeInitialize Method (PerfManager) | fcSDK Documentation

DeInitialize Method (PerfManager)

Syntax

'Declaration

Public Shared Sub DeInitialize()

public static void DeInitialize()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PerfManager Class
PerfManager Members


GetCounter Method | fcSDK Documentation

GetCounter Method

Syntax

'Declaration

Public Function GetCounter( _
   ByVal _counterName_ As String _
) As PerformanceCounter

public PerformanceCounter GetCounter(
   string _counterName_
)

Parameters

counterName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PerfManager Class
PerfManager Members


GetPerfDurationSecs Method | fcSDK Documentation

GetPerfDurationSecs Method

The number of ticks representing a point in time from which this duration started. See the GetPerfTimer Method for more information on how to obtain a valid tick count value

Returns the number of seconds that have elapsed since a specified time

Syntax

'Declaration

Public Shared Function GetPerfDurationSecs( _
   ByVal _startTicks_ As Long _
) As Decimal

public static decimal GetPerfDurationSecs(
   long _startTicks_
)

Parameters

startTicks

The number of ticks representing a point in time from which this duration started. See the GetPerfTimer Method for more information on how to obtain a valid tick count value

Return Value

The number of seconds (or fraction of seconds) that have elapsed since the moment in time represented by the startTicks parameter.

See the GetPerfTimer Method for more information on how to obtain a valid tick count value.

For more information on instrumenting code to performing timing and performance testing, please see MSKB Article 172338 entitled "How to use QueryPerformanceCounter to Time Code."

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PerfManager Class
PerfManager Members


GetPerfTimer Method | fcSDK Documentation

GetPerfTimer Method

Gets the current value of the high-resolution performance counter

Syntax

'Declaration

Public Shared Function GetPerfTimer() As Long

public static long GetPerfTimer()

Return Value

A value representing the number of "ticks" since a specific time in history. The start time may vary from system to system and is only intended to be used from measuring from one recent instant in time to another recent instant in time with great accuracy for the purpose of timing the duration of operations in code.

Remarks

This method wraps the Win32 API function QueryPerformanceCounter.

For more information on instrumenting code to performing timing and performance testing, please see MSKB Article 172338 entitled "How to use QueryPerformanceCounter to Time Code."

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PerfManager Class
PerfManager Members


Initialize Method (PerfManager) | fcSDK Documentation

Initialize Method (PerfManager)

Allows PerfManager to initialize itself by creating a new PerfMon instance name and preparing all the PerformanceCounter instances

Syntax

'Declaration

Public Shared Sub Initialize()

public static void Initialize()

Remarks

This method retrieves configuration from the FCConfiguration Class. The application should ensure that the proper configuration has been loaded (either via configuration file, or through supplied programmatic values) before calling this method.

Performance counter events that fire before PerfManager is initialized will be discarded and no error will be thrown.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PerfManager Class
PerfManager Members


Instance Property (PerfManager) | fcSDK Documentation

Instance Property (PerfManager)

Retreives a reference to the singleton instance of PerfManager

Syntax

'Declaration

Public Shared ReadOnly Property Instance As PerfManager

public static PerfManager Instance {get;}

Property Value

A reference to the singleton instance of PerfManager

Remarks

Most of the methods on PerfManager are instance methods and require a reference to a specific instance. There is only one singleton instance of PerfManager available. Use this property to retrieve a reference to it.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PerfManager Class
PerfManager Members


InstanceName Property (PerfManager) | fcSDK Documentation

InstanceName Property (PerfManager)

Gets the instance name for this application as it will appear in the PerfMon utility

Syntax

'Declaration

Public ReadOnly Property InstanceName As String

public string InstanceName {get;}

Property Value

The instance name for this application as it will appear in the PerfMon utility.

Remarks

This value can be set in the application configuration by specifying the "fchoice.perfmoninstancename" appSetting, or by specifying a value in the configuration programmatically using ConfigValues.PERF_INSTANCE_NAME constant as the key name.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PerfManager Class
PerfManager Members


IsEnabled Property | fcSDK Documentation

IsEnabled Property

Syntax

'Declaration

Public Shared ReadOnly Property IsEnabled As Boolean

public static bool IsEnabled {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PerfManager Class
PerfManager Members


IsInitialized Property (PerfManager) | fcSDK Documentation

IsInitialized Property (PerfManager)

Syntax

'Declaration

Public Shared ReadOnly Property IsInitialized As Boolean

public static bool IsInitialized {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PerfManager Class
PerfManager Members


StringUtil Class | fcSDK Documentation

StringUtil Class

Syntax

'Declaration

Public MustInherit NotInheritable Class StringUtil

public static class StringUtil

Inheritance Hierarchy

System.Object

[FChoice.Common.StringUtil**

Requirements

Namespace: FChoice.Common

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

StringUtil Members FChoice.Common Namespace FChoice.Common.StringUtil

Requirements

Namespace: FChoice.Common

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

StringUtil Members FChoice.Common Namespace


StringUtil Class Members | fcSDK Documentation

StringUtil Class Members

The following tables list the members exposed by StringUtil.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | AreEqual | Overloaded.
static (Shared in Visual Basic) | IsNonEmptyString |
static (Shared in Visual Basic) | StartsWith | Overloaded.

Reference

StringUtil Class
FChoice.Common Namespace


AreEqual Method | fcSDK Documentation

AreEqual Method

Overload List

Overload | Description
AreEqual(String,String) |
AreEqual(String,String,Boolean) |
AreEqual(String,String,Boolean,Boolean) |
AreEqual(String,String,Boolean,CultureInfo) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StringUtil Class
StringUtil Members


AreEqual(String,String) Method | fcSDK Documentation

AreEqual(String,String) Method

Syntax

'Declaration

Public Overloads Shared Function AreEqual( _
   ByVal _firstVal_ As String, _
   ByVal _secondVal_ As String _
) As Boolean

public static bool AreEqual(
   string _firstVal_,
   string _secondVal_
)

Parameters

firstVal

secondVal

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StringUtil Class
StringUtil Members
Overload List


AreEqual(String,String,Boolean) Method | fcSDK Documentation

AreEqual(String,String,Boolean) Method

Syntax

'Declaration

Public Overloads Shared Function AreEqual( _
   ByVal _firstVal_ As String, _
   ByVal _secondVal_ As String, _
   ByVal _ignoreCase_ As Boolean _
) As Boolean

public static bool AreEqual(
   string _firstVal_,
   string _secondVal_,
   bool _ignoreCase_
)

Parameters

firstVal

secondVal

ignoreCase

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StringUtil Class
StringUtil Members
Overload List


AreEqual(String,String,Boolean,Boolean) Method | fcSDK Documentation

AreEqual(String,String,Boolean,Boolean) Method

Syntax

'Declaration

Public Overloads Shared Function AreEqual( _
   ByVal _firstVal_ As String, _
   ByVal _secondVal_ As String, _
   ByVal _ignoreCase_ As Boolean, _
   ByVal _cultureNeutral_ As Boolean _
) As Boolean

public static bool AreEqual(
   string _firstVal_,
   string _secondVal_,
   bool _ignoreCase_,
   bool _cultureNeutral_
)

Parameters

firstVal

secondVal

ignoreCase

cultureNeutral

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StringUtil Class
StringUtil Members
Overload List


AreEqual(String,String,Boolean,CultureInfo) Method | fcSDK Documentation

AreEqual(String,String,Boolean,CultureInfo) Method

Syntax

'Declaration

Public Overloads Shared Function AreEqual( _
   ByVal _firstVal_ As String, _
   ByVal _secondVal_ As String, _
   ByVal _ignoreCase_ As Boolean, _
   ByVal _culture_ As CultureInfo _
) As Boolean

public static bool AreEqual(
   string _firstVal_,
   string _secondVal_,
   bool _ignoreCase_,
   CultureInfo _culture_
)

Parameters

firstVal

secondVal

ignoreCase

culture

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StringUtil Class
StringUtil Members
Overload List


IsNonEmptyString Method | fcSDK Documentation

IsNonEmptyString Method

Syntax

'Declaration

Public Shared Function IsNonEmptyString( _
   ByVal _val_ As String _
) As Boolean

public static bool IsNonEmptyString(
   string _val_
)

Parameters

val

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StringUtil Class
StringUtil Members


StartsWith Method (StringUtil) | fcSDK Documentation

StartsWith Method (StringUtil)

Overload List

Overload | Description
StartsWith(String,String) |
StartsWith(String,String,Boolean) |
StartsWith(String,String,Boolean,Boolean) |
StartsWith(String,String,Boolean,CultureInfo) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StringUtil Class
StringUtil Members


StartsWith(String,String) Method | fcSDK Documentation

StartsWith(String,String) Method

Syntax

'Declaration

Public Overloads Shared Function StartsWith( _
   ByVal _origVal_ As String, _
   ByVal _startVal_ As String _
) As Boolean

public static bool StartsWith(
   string _origVal_,
   string _startVal_
)

Parameters

origVal

startVal

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StringUtil Class
StringUtil Members
Overload List


StartsWith(String,String,Boolean) Method | fcSDK Documentation

StartsWith(String,String,Boolean) Method

Syntax

'Declaration

Public Overloads Shared Function StartsWith( _
   ByVal _origVal_ As String, _
   ByVal _startVal_ As String, _
   ByVal _ignoreCase_ As Boolean _
) As Boolean

public static bool StartsWith(
   string _origVal_,
   string _startVal_,
   bool _ignoreCase_
)

Parameters

origVal

startVal

ignoreCase

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StringUtil Class
StringUtil Members
Overload List


StartsWith(String,String,Boolean,Boolean) Method | fcSDK Documentation

StartsWith(String,String,Boolean,Boolean) Method

Syntax

'Declaration

Public Overloads Shared Function StartsWith( _
   ByVal _origVal_ As String, _
   ByVal _startVal_ As String, _
   ByVal _ignoreCase_ As Boolean, _
   ByVal _cultureNeutral_ As Boolean _
) As Boolean

public static bool StartsWith(
   string _origVal_,
   string _startVal_,
   bool _ignoreCase_,
   bool _cultureNeutral_
)

Parameters

origVal

startVal

ignoreCase

cultureNeutral

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StringUtil Class
StringUtil Members
Overload List


StartsWith(String,String,Boolean,CultureInfo) Method | fcSDK Documentation

StartsWith(String,String,Boolean,CultureInfo) Method

Syntax

'Declaration

Public Overloads Shared Function StartsWith( _
   ByVal _origVal_ As String, _
   ByVal _startVal_ As String, _
   ByVal _ignoreCase_ As Boolean, _
   ByVal _culture_ As CultureInfo _
) As Boolean

public static bool StartsWith(
   string _origVal_,
   string _startVal_,
   bool _ignoreCase_,
   CultureInfo _culture_
)

Parameters

origVal

startVal

ignoreCase

culture

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StringUtil Class
StringUtil Members
Overload List


DataProtectionStore Enumeration | fcSDK Documentation

DataProtectionStore Enumeration

DataProtectionStore is used with the DataProtector when encrypting or decrypting data. DataProtectionStore tells the DataProtector which key store to use.

Syntax

'Declaration

Public Enum DataProtectionStore
   Inherits System.Enum

public enum DataProtectionStore : System.Enum

Members

Member | Description
UseMachineStore | Specifies that the DataProtector should use the machine key store. This means that data encrypted with this key can be decrypted by any user on this machine. The key will not work on any other computer.
UseUserStore | Specifies that the DataProtector should use the user key store. This means that data encrypted with this key can be decrypted by ONLY this user and ONLY on this computer.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
FChoice.Common.DataProtectionStore

Requirements

Namespace: FChoice.Common

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

FChoice.Common Namespace


FCLicenseException.LoadFailReasons Enumeration | fcSDK Documentation

FCLicenseException.LoadFailReasons Enumeration

LoadFailReasons is used by FCLicenseException to provide a specific reason why license procurement failed for the product.

Syntax

'Declaration

Public Enum FCLicenseException.LoadFailReasons
   Inherits System.Enum

public enum FCLicenseException.LoadFailReasons : System.Enum

Members

Member | Description
GeneralError | An unknown error has occurred while retrieving
InvalidGraceLimit | The license requested is invalid because its grace period is not within an acceptable range.
InvalidLicenseDate | The license requested is invalid because its expiration date is not within an acceptable range.
InvalidUserLimit | The license requested is invalid because its user limit value is not within the acceptable range.
MissingSiteId | The license requested does not contain a valid site ID.
MissingTables | The license tables required by First Choice Licensing are not installed in the database.

Remarks

If you encounter an FCLicenseException during operation of a First Choice product, please contact First Choice support immediately at support@fchoice.com.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
FChoice.Common.FCLicenseException.LoadFailReasons

Requirements

Namespace: FChoice.Common

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

FChoice.Common Namespace


LogLevel Enumeration | fcSDK Documentation

LogLevel Enumeration

LogLevel is an enumeration of supported logging levels. This is used in conjunction with LogManager and Logger to control how log messages are filtered or written to the output appender.

Syntax

'Declaration

Public Enum LogLevel
   Inherits System.Enum

public enum LogLevel : System.Enum

Members

Member | Description
DEBUG | The DEBUG level symbolizes the most detailed and exhaustive level. This should only be used for troubleshooting or debugging information not necessary during normal operation or even basic troubleshooting.
ERROR | The ERROR level symbolizes events in the system from which the application cannot continue processing the current task (note that this doesn't necessarily mean the application will crash). The system could be in a potentially dangerous state and steps should be taken to immediately resolve the problem.
FATAL | The FATAL level symbolizes an unrecoverable error that is causing the application to cease execution to prevent data loss or corruption. FATAL messages should be resolved immediately and are of the highest importance.
INFO | The INFO level symbolizes normal logging that details major events in the systems and perhaps some informational or status messages that might be useful to a systems administrator monitoring the system or troubleshooting a basic problem.
UNDEFINED | This level is provided only for compatibility and is not used.
WARN | The WARN level symbolizes events in the system that systems administrators and developers should be aware of and should probably be fixed soon.

Inheritance Hierarchy

System.Object System.ValueType System.Enum FChoice.Common.LogLevel

Requirements

Namespace: FChoice.Common

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

FChoice.Common Namespace FChoice.Common.LogLevel

Requirements

Namespace: FChoice.Common

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

FChoice.Common Namespace


IErrorMessageProvider Interface | fcSDK Documentation

IErrorMessageProvider Interface

The IErrorMessageProvider is the interface used by FCExceptionBase to allow other assemblies to provide custom error message resolution.

Syntax

'Declaration

Public Interface IErrorMessageProvider

public interface IErrorMessageProvider

Remarks

You can implement your own error message provider to load error message resources from other sources. If you implement this interface and wish to use it, simply call the SetMessageProvider static (Shared in Visual Basic) method on the FCExceptionBase class.

Requirements

Namespace: FChoice.Common

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

IErrorMessageProvider Members
FChoice.Common Namespace


IErrorMessageProvider Interface Members | fcSDK Documentation

IErrorMessageProvider Interface Members

The following tables list the members exposed by IErrorMessageProvider.

Public Methods

 | Name | Description
Method | GetMessageFormat | Called by FCExceptionBase Class when a specific error message string resource is required.

Reference

IErrorMessageProvider Interface
FChoice.Common Namespace


GetMessageFormat Method | fcSDK Documentation

GetMessageFormat Method

The message ID whose string value to load.

Called by FCExceptionBase Class when a specific error message string resource is required.

Syntax

'Declaration

Function GetMessageFormat( _
   ByVal _messageId_ As String _
) As String

string GetMessageFormat(
   string _messageId_
)

Parameters

messageId

The message ID whose string value to load.

Return Value

The value of the string resource for this message ID and current culture.

Remarks

If you wish to provide internationalized culture-specific error messages, use the CultureInfo.CurrentCulture property to determine which culture's resource to return.

NOTE: If a message string cannot be loaded for this message ID, simple return null (Nothing in Visual Basic) and an attempt will be made by FCExceptionBase to load a default string in the default culture (en-US).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IErrorMessageProvider Interface
IErrorMessageProvider Members
CultureInfo class
Developing World-Ready Applications


FChoice.Common.Data Namespace | fcSDK Documentation

FChoice.Common.Data Namespace

The FChoice.Common.Data namespace provides data access services to First Choice .NET-based products.

Classes

 | Class | Description
Class | DataAccessSectionHandler | Provides configuration information from the .NET application configuration file for the DbProviderFactory to load data providers.
Class | DataParameterCollection | Contains a collection of IDbDataParameter objects for use in a database query.
Class | DataSetSurrogate | Reads or writes a DataSet as a compact binary stream.
Class | DbProvider | Abstract base class for database providers used by SqlHelper and applications.
Class | DbProviderFactory | Provides a way of customized data access using DbProvider objects that abstract database access
Class | FCTypes | This class is not currently used and is intended for future products.
Class | ODPOracleProvider |
Class | OleDbDataProviderBase | Abstract base class for OleDb-based data providers
Class | OracleProviderBase | Abstract base class for Oracle-based data providers
Class | SqlHelper | Provides a convenience and data provider-agnostic wrapper around ADO.NET
Class | TypeMapper | This class is not currently used and is intended for future products.
Class | UpdateQueryBatch | Helper class for grouping INSERT and UPDATE statements together into a single batch without concern for the underlying database type's support for statement batching

Interfaces

 | Interface | Description
Interface | IDbExtension | IDbExtension allows applications to specify database-specific extensions to the DbProvider

Reference

FChoice.Common Assembly


DataAccessSectionHandler Class | fcSDK Documentation

DataAccessSectionHandler Class

Provides configuration information from the .NET application configuration file for the DbProviderFactory.

Syntax

'Declaration

Public Class DataAccessSectionHandler

public class DataAccessSectionHandler

Remarks

This class is used by and should not be used by other classes.

Inheritance Hierarchy

System.Object

FChoice.Common.Data.DataAccessSectionHandler

Requirements

Namespace: FChoice.Common.Data

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

DataAccessSectionHandler Members FChoice.Common.Data Namespace DbProvider Class DbProviderFactory Class FChoice.Common.Data.DataAccessSectionHandler

Requirements

Namespace: FChoice.Common.Data

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

DataAccessSectionHandler Members FChoice.Common.Data Namespace DbProvider Class DbProviderFactory Class


DataAccessSectionHandler Class Members | fcSDK Documentation

DataAccessSectionHandler Class Members

The following tables list the members exposed by DataAccessSectionHandler.

Public Constructors

 | Name | Description
Public Constructor | DataAccessSectionHandler Constructor |

Public Methods

 | Name | Description
Public Method | Create | Creates a new configuration handler and adds it to the section handler collection.

Reference

DataAccessSectionHandler Class
FChoice.Common.Data Namespace
DbProvider Class
DbProviderFactory Class


DataAccessSectionHandler Constructor | fcSDK Documentation

DataAccessSectionHandler Constructor

Creates a new instance of the DataAccessSectionHandler. This is usually only called by the .NET Configuration facility.

Syntax

'Declaration

Public Function New()

public DataAccessSectionHandler()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataAccessSectionHandler Class
DataAccessSectionHandler Members


Create Method (DataAccessSectionHandler) | fcSDK Documentation

Create Method (DataAccessSectionHandler)

The configuration settings in a corresponding parent configuration section.

The virtual path for which the configuration section handler computes configuration values. Normally this parameter is reserved and is a null reference (Nothing in Visual Basic).

The System.Xml.XmlNode that contains the configuration information to be handled. Provides direct access to the XML contents of the configuration section.

Creates a new configuration handler and adds it to the section handler collection.

Syntax

'Declaration

Public Function Create( _
   ByVal _parent_ As Object, _
   ByVal _configContext_ As Object, _
   ByVal _section_ As XmlNode _
) As Object

public object Create (
   object _parent_,
   object _configContext_,
   XmlNode _section_
)

Parameters

parent

The configuration settings in a corresponding parent configuration section.

configContext

The virtual path for which the configuration section handler computes configuration values. Normally this parameter is reserved and is a null reference (Nothing in Visual Basic).

section

The System.Xml.XmlNode that contains the configuration information to be handled. Provides direct access to the XML contents of the configuration section.

Return Value

Always null (Nothing in Visual Basic). This method initializes DbProviderFactory with the specified providers.

Remarks

This method should only be used by the .NET Configuration infrastructure. You should not call this method manually.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataAccessSectionHandler Class
DataAccessSectionHandler Members


DataParameterCollection Class | fcSDK Documentation

DataParameterCollection Class

Contains a collection of IDbDataParameter objects for use in a database query.

Syntax

'Declaration

<DefaultMemberAttribute("Item")>
Public Class DataParameterCollection

[DefaultMemberAttribute("Item")]
public class DataParameterCollection

Remarks

Note that the parameters are keyed in the dictionary by their natural name, but the IDataParameter.ParameterName will contain the database-specific name. For example, a parameter's natural name (i.e. "name") will actually be "@name" in the IDataParameter if the data provider is Microsoft SQL Server, or ":name" for Oracle.

This allows implementors to not have to worry about the differences in parameter passing of the underlying database and refer to parameters by their natural, unaltered names.

Inheritance Hierarchy

System.Object

[FChoice.Common.Data.DataParameterCollection**

Requirements

Namespace: FChoice.Common.Data

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

DataParameterCollection Members FChoice.Common.Data Namespace FChoice.Common.Data.DataParameterCollection

Requirements

Namespace: FChoice.Common.Data

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

DataParameterCollection Members FChoice.Common.Data Namespace


DataParameterCollection Class Members | fcSDK Documentation

DataParameterCollection Class Members

The following tables list the members exposed by DataParameterCollection.

Public Constructors

 | Name | Description
Public Constructor | DataParameterCollection Constructor | Overloaded.

Public Properties

 | Name | Description
Public Property | Count | Retrieves the number of parameters actually contained in the DataParameterCollection.
Public Property | IsFixedSize | Retrieves a value indicating whether or not this collection has a fixed size.
Public Property | IsReadOnly | Retrieves a value indicating whether this collection is read-only.
Public Property | IsSynchronized | Retrieves a value indicating whether access to the DataParameterCollection is synchronized (thread-safe).
Public Property | Item | Overloaded. Gets or sets the IDbDataParameter associated with the specific name in the collection.
Public Property | Parameters | Retrieves a collection of the IDbDataParameter objects in this collection.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to this instance of the DataParameterCollection.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds a parameter to this collection for use as a bind variable in the SQL statement.
Public Method | Clear | Removes all parameters from this collection.
Public Method | Clone | Creates a new collection using the same parameters.
Public Method | Contains | Determines whether or not this collection contains the specified parameter.
Public Method | CopyTo | Overloaded. Copies the parameters in this collection to the specified collection.
Public Method | DeepClone | Performs a deep clone of the entire collection and clones (not just a reference copy) each individual parameter
Public Method | GetEnumerator | Returns an enumerator for the entire collection
Public Method | IndexOf | Returns the index at which this object exists in the collection.
Public Method | Insert | Inserts the parameter at the specified index in the collection.
Public Method | Remove | Overloaded. Removes a parameter with the specified name from the collection.
Public Method | RemoveAt | Removes the parameter at the specified index from the collection.

Reference

DataParameterCollection Class
FChoice.Common.Data Namespace


DataParameterCollection Constructor | fcSDK Documentation

DataParameterCollection Constructor

Creates a new instance of DataParameterCollection with or without default settings.

Overload List

Overload | Description
DataParameterCollection Constructor() | Creates an empty new instance of DataParameterCollection using the default DbProvider with a default initial capacity.
DataParameterCollection Constructor(DbProvider) | Creates an empty new instance of DataParameterCollection with a default initial capacity based on the specified DbProvider.
DataParameterCollection Constructor(IDbDataParameter[]) | Creates a new instance of DataParameterCollection using the default DbProvider and populated with an initial array of data parameters.
DataParameterCollection Constructor(Int32) | Creates a new instance of DataParameterCollection based on the default DbProvider with the specified initial capacity.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataParameterCollection Class
DataParameterCollection Members


DataParameterCollection Constructor() | fcSDK Documentation

DataParameterCollection Constructor()

Creates an empty new instance of DataParameterCollection using the default DbProvider with a default initial capacity.

Syntax

'Declaration

Public Function New()

public DataParameterCollection()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataParameterCollection Class
DataParameterCollection Members
Overload List


DataParameterCollection Constructor(DbProvider) | fcSDK Documentation

DataParameterCollection Constructor(DbProvider)

The DbProvider to use instead of the default provider.

Creates an empty new instance of DataParameterCollection with a default initial capacity based on the specified DbProvider.

Syntax

'Declaration

Public Function New( _
   ByVal _accessProvider_ As DbProvider _
)

public DataParameterCollection(
   DbProvider _accessProvider_
)

Parameters

accessProvider

The DbProvider to use instead of the default provider.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataParameterCollection Class
DataParameterCollection Members
Overload List


DataParameterCollection Constructor(IDbDataParameter[]) | fcSDK Documentation

DataParameterCollection Constructor(IDbDataParameter[])

An array of IDbDataParameter classes which will be used to initially populate the new collection.

Creates a new instance of DataParameterCollection using the default DbProvider and populated with an initial array of data parameters.

Syntax

'Declaration

Public Function New( _
   ByVal _parameters_() As IDbDataParameter _
)

public DataParameterCollection(
   IDbDataParameter\[\] _parameters_
)

Parameters

parameters

An array of IDbDataParameter classes which will be used to initially populate the new collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataParameterCollection Class
DataParameterCollection Members
Overload List


DataParameterCollection Constructor(Int32) | fcSDK Documentation

DataParameterCollection Constructor(Int32)

The initial capacity for this collection.

Creates a new instance of DataParameterCollection based on the default DbProvider with the specified initial capacity.

Syntax

'Declaration

Public Function New( _
   ByVal _capacity_ As Integer _
)

public DataParameterCollection(
   int _capacity_
)

Parameters

capacity

The initial capacity for this collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataParameterCollection Class
DataParameterCollection Members
Overload List


Add Method (DataParameterCollection) | fcSDK Documentation

Add Method (DataParameterCollection)

Adds a parameter to this collection for use as a bind variable in the SQL statement.

Overload List

Overload | Description
Add(String,Object) | Adds a parameter to this collection for use as a bind variable in the SQL statement.
Add(String,Object,ParameterDirection) | Adds a parameter to this collection for passing to the database and in replacing parameters in the SQL statement, using a specific parameter direction.
Add(String,Object,IDbDataParameter) |
Add(String,IDbDataParameter) | Adds a parameter to this collection for passing to the database and in replacing parameters in the SQL statement.

Remarks

The parameters added to this collection are stored in order and are used by SqlHelper to replace the parameter tokens in the SQL statement in the order in which they appear.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataParameterCollection Class DataParameterCollection Members


Add(String,Object) Method | fcSDK Documentation

Add(String,Object) Method

The name of the parameter to add (without the database-specific bind variable prefix such as @ for Microsoft SQL Server or : for Oracle)

The value of the parameter that will be passed to the database as part of the query

Adds a parameter to this collection for use as a bind variable in the SQL statement.

Syntax

'Declaration

Public Overloads Function Add( _
   ByVal _name_ As String, _
   ByVal _value_ As Object _
) As Integer

public int Add(
   string _name_,
   object _value_
)

Parameters

name

The name of the parameter to add (without the database-specific bind variable prefix such as @ for Microsoft SQL Server or : for Oracle)

value

The value of the parameter that will be passed to the database as part of the query

Return Value

The index in the collection at which the new parameters was added.

Remarks

This method will create a new instance of an IDataParameter of the underlying type that matches the data provider specified by the default DbProvider, or the one passed into the constructor. For example, if the data provider is Microsoft SQL Server, this method will add a SqlParameter to the collection.

The name parameter should be a simple name without any database-specific prefix such as "@" for SQL Server or ":" for Oracle. The SqlHelper will take care of adding the specific prefix.

The rules for the value parameter are dictated by the underlying data provider type. In general, basic types will be supported without problems, but database-specific values such as large binary arrays or text fields might require extra preparation. Consult the database vendor's documentation or the .NET Framework SDK documentation for these special considerations.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataParameterCollection Class
DataParameterCollection Members
Overload List


Add(String,Object,ParameterDirection) Method | fcSDK Documentation

Add(String,Object,ParameterDirection) Method

The name of the parameter to add (without the database-specific bind variable prefix such as @ for Microsoft SQL Server or : for Oracle)

The value of the parameter that will be passed to the database as part of the query

Specifies a direction for the parameter. By default this is ParameterDirection.Input.

Adds a parameter to this collection for passing to the database and in replacing parameters in the SQL statement, using a specific parameter direction.

Syntax

'Declaration

Public Overloads Function Add( _
   ByVal _name_ As String, _
   ByVal _value_ As Object, _
   ByVal _direction_ As ParameterDirection _
) As Integer

public int Add(
   string _name_,
   object _value_,
   ParameterDirection _direction_
)

Parameters

name

The name of the parameter to add (without the database-specific bind variable prefix such as @ for Microsoft SQL Server or : for Oracle)

value

The value of the parameter that will be passed to the database as part of the query

direction

Specifies a direction for the parameter. By default this is ParameterDirection.Input.

Return Value

The index in the collection at which the new parameters was added.

Remarks

This method will create a new instance of an IDataParameter of the underlying type that matches the data provider specified by the default DbProvider, or the one passed into the constructor. For example, if the data provider is Microsoft SQL Server, this method will add a SqlParameter to the collection.

The name parameter should be a simple name without any database-specific prefix such as "@" for SQL Server or ":" for Oracle. The SqlHelper will take care of adding the specific prefix.

The rules for the value parameter are dictated by the underlying data provider type. In general, basic types will be supported without problems, but database-specific values such as large binary arrays or text fields might require extra preparation. You can access the parameter collection via the Parameters property to perform database-specific work or add a custom parameter to the collection. Consult the database vendor's documentation or the .NET Framework SDK documentation for these special considerations.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataParameterCollection Class
DataParameterCollection Members
Overload List


Add(String,Object,IDbDataParameter) Method | fcSDK Documentation

Add(String,Object,IDbDataParameter) Method

Syntax

'Declaration

Public Overloads Function Add( _
   ByVal _name_ As String, _
   ByVal _value_ As Object, _
   ByVal _parameterTemplate_ As IDbDataParameter _
) As Integer

public int Add(
   string _name_,
   object _value_,
   IDbDataParameter _parameterTemplate_
)

Parameters

name

value

parameterTemplate

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataParameterCollection Class
DataParameterCollection Members
Overload List


Add(String,IDbDataParameter) Method | fcSDK Documentation

Add(String,IDbDataParameter) Method

The name of the parameter to add (without the database-specific bind variable prefix such as @ for Microsoft SQL Server or : for Oracle)

An instance of IDbDataParameter to add to this collection.

Adds a parameter to this collection for passing to the database and in replacing parameters in the SQL statement.

Syntax

'Declaration

Public Overloads Function Add( _
   ByVal _name_ As String, _
   ByVal _param_ As IDbDataParameter _
) As Integer

public int Add(
   string _name_,
   IDbDataParameter _param_
)

Parameters

name

The name of the parameter to add (without the database-specific bind variable prefix such as @ for Microsoft SQL Server or : for Oracle)

param

An instance of IDbDataParameter to add to this collection.

Remarks

The name parameter should be a simple name without any database-specific prefix such as "@" for SQL Server or ":" for Oracle. The SqlHelper will take care of adding the specific prefix.

NOTE: The instance of IDbDataParameter to add must match the same underlying type of parameter as that provided by the DbProvider associated with this collection (either the default provider or the one passed into the constructor for this collection). If they do not match, an error will be thrown when the query is executed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataParameterCollection Class
DataParameterCollection Members
Overload List


Clear Method (DataParameterCollection) | fcSDK Documentation

Clear Method (DataParameterCollection)

Removes all parameters from this collection.

Syntax

'Declaration

Public Sub Clear()

public void Clear()

Remarks

All parameters will be removed from the collection and the Count property will be set to zero.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataParameterCollection Class
DataParameterCollection Members


Clone Method (DataParameterCollection) | fcSDK Documentation

Clone Method (DataParameterCollection)

Creates a new collection using the same parameters.

Syntax

'Declaration

Public Function Clone() As DataParameterCollection

public DataParameterCollection Clone()

Return Value

A new collection with copies of the references to the same parameters.

Remarks

Note that this is not a deep clone. A new collection is created with new references pointing to the same underlying parameter objects. For a true deep clone (both the collection AND the parameters, see the DeepClone method).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataParameterCollection Class
DataParameterCollection Members


Contains Method (DataParameterCollection) | fcSDK Documentation

Contains Method (DataParameterCollection)

The IDbDataParameter to search for.

Determines whether or not this collection contains the specified parameter.

Syntax

'Declaration

Public Function Contains( _
   ByVal _value_ As Object _
) As Boolean

public bool Contains(
   object _value_
)

Parameters

value

The IDbDataParameter to search for.

Return Value

Whether or not this collection contains the specified parameter.

Remarks

If the value specified is not an instance of IDbDataParameter, or is null (Nothing in Visual Basic), it will be ignored and the result will be false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataParameterCollection Class
DataParameterCollection Members


CopyTo Method (DataParameterCollection) | fcSDK Documentation

CopyTo Method (DataParameterCollection)

Overload List

Overload | Description
CopyTo(DataParameterCollection) | Copies the parameters in this collection to the specified collection.
CopyTo(Array,Int32) | Copies the parameters in this collection to the specified array.

Remarks

The overload that takes a destination DataParameterCollection performs a shallow copy. That is, each element is NOT cloned, but a reference to the same parameter is copied into the destination collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataParameterCollection Class DataParameterCollection Members


CopyTo(DataParameterCollection) Method | fcSDK Documentation

CopyTo(DataParameterCollection) Method

The destination parameter collection which will receive the contents of this parameter collection.

Copies the parameters in this collection to the specified collection.

Syntax

'Declaration

Public Overloads Sub CopyTo( _
   ByVal _otherCol_ As DataParameterCollection _
)

public void CopyTo(
   DataParameterCollection _otherCol_
)

Parameters

otherCol

The destination parameter collection which will receive the contents of this parameter collection.

Remarks

This method performs a shallow copy. That is, each element is NOT cloned, but a reference to the same parameter is copied into the destination collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataParameterCollection Class
DataParameterCollection Members
Overload List


CopyTo(Array,Int32) Method | fcSDK Documentation

CopyTo(Array,Int32) Method

The array to copy the parameters into

The index in the array at which to start copying parameters

Copies the parameters in this collection to the specified array.

Syntax

'Declaration

Public Overloads Sub CopyTo( _
   ByVal _array_ As Array, _
   ByVal _index_ As Integer _
)

public void CopyTo(
   Array _array_,
   int _index_
)

Parameters

array

The array to copy the parameters into

index

The index in the array at which to start copying parameters

Remarks

The specified array's element type must be compatible with IDbDataParameter.

This method uses Array.Copy to copy the elements.

The elements are copied to the array in the same order in which they exist in this collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataParameterCollection Class
DataParameterCollection Members
Overload List


DeepClone Method | fcSDK Documentation

DeepClone Method

Performs a deep clone of the entire collection and clones (not just a reference copy) each individual parameter

Syntax

'Declaration

Public Function DeepClone() As DataParameterCollection

public DataParameterCollection DeepClone()

Return Value

The newly cloned collection

Remarks

The cloned collection will be a complete clone that will be completely disassociated from the original. Any changes made to either collection will NOT be reflected in the other collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataParameterCollection Class
DataParameterCollection Members


GetEnumerator Method (DataParameterCollection) | fcSDK Documentation

GetEnumerator Method (DataParameterCollection)

Returns an enumerator for the entire collection

Syntax

'Declaration

Public Function GetEnumerator() As IEnumerator

public IEnumerator GetEnumerator()

Return Value

An IEnumerator for the collection

Remarks

This returns an enumerator of each parameter in the collection, not the name/parameter pairs.

Enumerators only allow reading the data in the collection. Enumerators cannot be used to modify the underlying collection.

Initially, the enumerator is positioned before the first element in the collection. Reset also brings the enumerator back to this position. At this position, calling Current throws an exception. Therefore, you must call MoveNext to advance the enumerator to the first element of the collection before reading the value of Current.

Current returns the same object until either MoveNext or Reset is called. MoveNext sets Current to the next element.

After the end of the collection is passed, the enumerator is positioned after the last element in the collection, and calling MoveNext returns false. If the last call to MoveNext returned false, calling Current throws an exception. To set Current to the first element of the collection again, you can call Reset followed by MoveNext.

An enumerator remains valid as long as the collection remains unchanged. If changes are made to the collection, such as adding, modifying or deleting elements, the enumerator is irrecoverably invalidated and the next call to MoveNext or Reset throws an InvalidOperationException. If the collection is modified between MoveNext and Current, Current will return the element that it is set to, even if the enumerator is already invalidated.

The enumerator does not have exclusive access to the collection; therefore, enumerating through a collection is intrinsically not a thread-safe procedure. Even when a collection is synchronized, other threads could still modify the collection, which causes the enumerator to throw an exception. To guarantee thread safety during enumeration, you can either lock the collection during the entire enumeration or catch the exceptions resulting from changes made by other threads.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataParameterCollection Class
DataParameterCollection Members


IndexOf Method (DataParameterCollection) | fcSDK Documentation

IndexOf Method (DataParameterCollection)

The IDbDataParameter whose index to retrieve.

Returns the index at which this object exists in the collection.

Syntax

'Declaration

Public Function IndexOf( _
   ByVal _value_ As Object _
) As Integer

public int IndexOf(
   object _value_
)

Parameters

value

The IDbDataParameter whose index to retrieve.

Return Value

The zero-based index of the first occurrence of value within the entire DataParameterCollection, if found; otherwise, -1.

Remarks

The DataParameterCollection is searched forward starting at the first element and ending at the last element.

This method performs a linear search; therefore, the average execution time is proportional to Count. That is, this method is an O(n) operation, where n is Count.

This method determines equality by calling Object.Equals.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataParameterCollection Class
DataParameterCollection Members


Insert Method (DataParameterCollection) | fcSDK Documentation

Insert Method (DataParameterCollection)

The index at which to insert the parameter

The IDbDataParameter to insert into the collection

Inserts the parameter at the specified index in the collection.

Syntax

'Declaration

Public Sub Insert( _
   ByVal _index_ As Integer, _
   ByVal _value_ As Object _
)

public void Insert(
   int _index_,
   object _value_
)

Parameters

index

The index at which to insert the parameter

value

The IDbDataParameter to insert into the collection

Remarks

All parameters with higher indexes then this parameter will be shifted down one in index to accomodates the new parameter.

Only instances of IDbDataParameter can be added to this collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataParameterCollection Class
DataParameterCollection Members


Remove Method (DataParameterCollection) | fcSDK Documentation

Remove Method (DataParameterCollection)

Overload List

Overload | Description
Remove(String) | Removes a parameter with the specified name from the collection.
Remove(IDbDataParameter) | Removes a parameter from the collection.
Remove(Object) | Removes a parameter from the collection.

Remarks

The name parameter is the natural name of the parameter. That is, the unaltered non-provider-specific name. For example, it would be the "name" value, not the "@name" value (for MS SQL Server) or ":name" (for Oracle).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataParameterCollection Class DataParameterCollection Members


Remove(String) Method | fcSDK Documentation

Remove(String) Method

The natural name of the parameter to remove from the collection.

Removes a parameter with the specified name from the collection.

Syntax

'Declaration

Public Overloads Sub Remove( _
   ByVal _name_ As String _
)

public void Remove(
   string _name_
)

Parameters

name

The natural name of the parameter to remove from the collection.

Remarks

The name parameter is the natural name of the parameter. That is, the unaltered non-provider-specific name. For example, it would be the "name" value, not the "@name" value (for MS SQL Server) or ":name" (for Oracle).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataParameterCollection Class
DataParameterCollection Members
Overload List


Remove(IDbDataParameter) Method | fcSDK Documentation

Remove(IDbDataParameter) Method

The parameter to remove from the collection.

Removes a parameter from the collection.

Syntax

'Declaration

Public Overloads Sub Remove( _
   ByVal _param_ As IDbDataParameter _
)

public void Remove(
   IDbDataParameter _param_
)

Parameters

param

The parameter to remove from the collection.

Remarks

If the parameter passed in is null or does not already exist in the collection, nothing will happen and no error will be thrown. Otherwise, the parameter will be removed from the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataParameterCollection Class
DataParameterCollection Members
Overload List


Remove(Object) Method | fcSDK Documentation

Remove(Object) Method

The parameter to remove from the collection.

Removes a parameter from the collection.

Syntax

'Declaration

Public Overloads Sub Remove( _
   ByVal _value_ As Object _
)

public void Remove(
   object _value_
)

Parameters

value

he parameter to remove from the collection.

Remarks

If the parameter passed in is not an IDbDataParameter, is null (Nothing in Visual Basic), or does not already exist in the collection, nothing will happen and no error will be thrown. Otherwise, the parameter will be removed from the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataParameterCollection Class
DataParameterCollection Members
Overload List


RemoveAt Method (DataParameterCollection) | fcSDK Documentation

RemoveAt Method (DataParameterCollection)

The index of the parameter to remove.

Removes the parameter at the specified index from the collection.

Syntax

'Declaration

Public Sub RemoveAt( _
   ByVal _index_ As Integer _
)

public void RemoveAt(
   int _index_
)

Parameters

index

The index of the parameter to remove.

Remarks

All parameters with higher indexes then this parameter will be shifted down one in index to fill the gap.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataParameterCollection Class
DataParameterCollection Members


Count Property (DataParameterCollection) | fcSDK Documentation

Count Property (DataParameterCollection)

Retrieves the number of parameters actually contained in the DataParameterCollection.

Syntax

'Declaration

Public ReadOnly Property Count As Integer

public int Count {get;}

Property Value

Count is always the actual number of parameters in the collection, not it's capacity. The Capacity is managed internally and will increase as necessary to handle new parameters.

Remarks

The number of parameters actually contained in the DataParameterCollection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataParameterCollection Class
DataParameterCollection Members


IsFixedSize Property (DataParameterCollection) | fcSDK Documentation

IsFixedSize Property (DataParameterCollection)

Retrieves a value indicating whether or not this collection has a fixed size.

Syntax

'Declaration

Public ReadOnly Property IsFixedSize As Boolean

public bool IsFixedSize {get;}

Property Value

False. This value is always false because DataParameterCollection does not support being fixed-size.

Remarks

This value is always false since DataParameterCollection does not support being fixed in size.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataParameterCollection Class
DataParameterCollection Members


IsReadOnly Property (DataParameterCollection) | fcSDK Documentation

IsReadOnly Property (DataParameterCollection)

Retrieves a value indicating whether this collection is read-only.

Syntax

'Declaration

Public ReadOnly Property IsReadOnly As Boolean

public bool IsReadOnly {get;}

Property Value

False. This collection is not read-only.

Remarks

This property always returns false since read-only DataParameterCollections are not supported.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataParameterCollection Class
DataParameterCollection Members


IsSynchronized Property (DataParameterCollection) | fcSDK Documentation

IsSynchronized Property (DataParameterCollection)

Retrieves a value indicating whether access to the DataParameterCollection is synchronized (thread-safe).

Syntax

'Declaration

Public ReadOnly Property IsSynchronized As Boolean

public bool IsSynchronized {get;}

Property Value

This is always false. There is no synchronized implementation of the DataParameterCollection.

Enumerating through a collection is intrinsically not a thread-safe procedure. Even when a collection is synchronized, other threads could still modify the collection, which causes the enumerator to throw an exception. To guarantee thread safety during enumeration, you can either lock the collection during the entire enumeration or catch the exceptions resulting from changes made by other threads.

Remarks

False. This collection is always non-synchronized.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataParameterCollection Class
DataParameterCollection Members


Item Property (DataParameterCollection) | fcSDK Documentation

Item Property (DataParameterCollection)

Overload List

Overload | Description
Item(String) | Gets or sets the IDbDataParameter associated with the specific name in the collection.
Item(Int32) | Gets or sets the IDbDataParameter associated with index in the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataParameterCollection Class DataParameterCollection Members


Item(String) Property | fcSDK Documentation

Item(String) Property

The name of the parameter whose value to get or set.

Gets or sets the IDbDataParameter associated with the specific name in the collection.

Syntax

'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal _name_ As String _
) As IDbDataParameter

public IDbDataParameter Item(
   string _name_
) {get;}

Parameters

name

The name of the parameter whose value to get or set.

Property Value

The IDbDataParameter associated with the specific name.

Remarks

The name argument is the natural name of the parameter. That is, it does not have any data provider-specific prefixes such as "@" for Microsoft SQL Server, or ":" for Oracle.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataParameterCollection Class
DataParameterCollection Members
Overload List


Item(Int32) Property | fcSDK Documentation

Item(Int32) Property

The zero-based index of the element to get or set.

Gets or sets the IDbDataParameter associated with index in the collection.

Syntax

'Declaration

Public Overloads Property Item( _
   ByVal _index_ As Integer _
) As IDbDataParameter

public IDbDataParameter Item(
   int _index_
) {get; set;}

Parameters

index

The zero-based index of the element to get or set.

Property Value

The IDbDataParameter associated with the specific index in the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataParameterCollection Class
DataParameterCollection Members
Overload List


Parameters Property (DataParameterCollection) | fcSDK Documentation

Parameters Property (DataParameterCollection)

Retrieves a collection of the IDbDataParameter objects in this collection.

Syntax

'Declaration

Public ReadOnly Property Parameters As ICollection

public ICollection Parameters {get;}

Property Value

A collection of the IDbDataParameter objects in this collection.

Remarks

This property retrieves a collection of just the parameters, not the names.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataParameterCollection Class
DataParameterCollection Members


SyncRoot Property (DataParameterCollection) | fcSDK Documentation

SyncRoot Property (DataParameterCollection)

Gets an object that can be used to synchronize access to this instance of the DataParameterCollection.

Syntax

'Declaration

Public ReadOnly Property SyncRoot As Object

public object SyncRoot {get;}

Property Value

An object that can be used to synchronize access to this instance of the DataParameterCollection.

Remarks

Enumerating through a collection is intrinsically not a thread-safe procedure. Even when a collection is synchronized, other threads could still modify the collection, which causes the enumerator to throw an exception. To guarantee thread safety during enumeration, you can either lock the collection during the entire enumeration or catch the exceptions resulting from changes made by other threads.

Lock on SyncRoot before enumerating through this collection to ensure thread safety.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataParameterCollection Class
DataParameterCollection Members


DataSetSurrogate Class | fcSDK Documentation

DataSetSurrogate Class

Reads or writes a DataSet as a compact binary stream.

Syntax

'Declaration

Public Class DataSetSurrogate

public class DataSetSurrogate

Remarks

IMPORTANT: The ReadBinary and WriteBinary methods only support simple DataSets with tables, columns, rows (with data) and relationships. All other information will be lost. This includes keys, constraints, extended properties, etc.

Inheritance Hierarchy

System.Object
FChoice.Common.Data.DataSetSurrogate

Requirements

Namespace: FChoice.Common.Data

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

DataSetSurrogate Members
FChoice.Common.Data Namespace


DataSetSurrogate Class Members | fcSDK Documentation

DataSetSurrogate Class Members

The following tables list the members exposed by DataSetSurrogate.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ReadBinary | Reads a DataSet from a binary stream
static (Shared in Visual Basic) | WriteBinary | Writes a DataSet to a binary stream

Reference

DataSetSurrogate Class
FChoice.Common.Data Namespace


ReadBinary Method | fcSDK Documentation

ReadBinary Method

The stream from which to read the DataSet

Reads a DataSet from a binary stream

Syntax

'Declaration

Public Shared Function ReadBinary( _
   ByVal _str_ As Stream _
) As DataSet

public static DataSet ReadBinary(
   Stream _str_
)

Parameters

str

The stream from which to read the DataSet

Return Value

A populated DataSet, or null (Nothing in Visual Basic) if the stream was invalid or written using an older version of DataSetSurrogate

Remarks

The binary stream must have been written using the WriteBinary method as it uses a specific binary encoding scheme.

WriteBinary encodes the version of DataSetSurrogate that was used to produce the stream so as to avoid version and binary format conflicts with newer or older versions. If ReadBinary encounters a newer or older stream, it will return null (Nothing in Visual Basic) signifying that the cache data is no longer valid and needs to be refreshed.

IMPORTANT: The ReadBinary and WriteBinary methods only support simple DataSets with tables, columns, rows (with data) and relationships. All other information will be lost. This includes keys, constraints, extended properties, etc

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataSetSurrogate Class
DataSetSurrogate Members


WriteBinary Method | fcSDK Documentation

WriteBinary Method

The DataSet to write to the stream

The stream which will receive the binary from the DataSet

Writes a DataSet to a binary stream

Syntax

'Declaration

Public Shared Sub WriteBinary( _
   ByVal _ds_ As DataSet, _
   ByVal _str_ As Stream _
)

public static void WriteBinary(
   DataSet _ds_,
   Stream _str_
)

Parameters

ds

The DataSet to write to the stream

str

The stream which will receive the binary from the DataSet

Remarks

WriteBinary writes the DataSet using a specific binary encoding scheme which can only be read by ReadBinary.

WriteBinary encodes the version of DataSetSurrogate that was used to produce the stream so as to avoid version and binary format conflicts with newer or older versions. If ReadBinary encounters a newer or older stream, it will return null signifying that the cache data is no longer valid and needs to be refreshed.

IMPORTANT: The ReadBinary and WriteBinary methods only support simple DataSets with tables, columns, rows (with data) and relationships. All other information will be lost. This includes keys, constraints, extended properties, etc

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataSetSurrogate Class
DataSetSurrogate Members


DbProvider Class | fcSDK Documentation

DbProvider Class

Abstract base class for database providers used by SqlHelper and applications.

Syntax

'Declaration
Public MustInherit Class DbProvider

public abstract class DbProvider

Remarks

Inherit from this class to provide custom database access to an unsupported database type, or to replace the behavior of a built-in/supported database type.

IMPORTANT: This abstract base class and all intrinsic providers are thread safe. Custom provider implementations should also be thread safe.

Inheritance Hierarchy

System.Object
FChoice.Common.Data.DbProvider
FChoice.Common.Data.OleDbDataProviderBase
FChoice.Common.Data.OracleProviderBase

Requirements

Namespace: FChoice.Common.Data

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

DbProvider Members
FChoice.Common.Data Namespace


DbProvider Class Members | fcSDK Documentation

DbProvider Class Members

The following tables list the members exposed by DbProvider.

Public Properties

 | Name | Description
Public Property | CanBatchQueries | Specifies whether the underlying database type for this provider can support multiple SQL statements per database round-trip
Public Property | ConnectionString | Gets or sets the connection string this provider will use for database connections
Public Property | MaxInListItems | Gets the maximum number of items the underlying database type supports in an IN() or NOT IN() SQL clause
Public Property | ProviderName | A general provider type or key to classify this provider
Public Property | RequiresDbNameParameter | Gets whether or not this provider requires the "dbname" argument for the CreateConnectionString Method
Public Property | TypeMapper | This property is intended for future use and is not currently used.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ConstructConnectionString | Constructs a valid ADO.NET-compliant connection string from the supplied key/value pairs.
Public Method | CreateCommand |
Public Method | CreateConnectionString | Creates a basic connection string from the basic common required elements according the rules of the specific database type
Public Method | CreateParameter | Creates a new IDbDataParameter of the specific underlying type for this database provider type (i.e. SqlHelper for MSSQL, etc)
Public Method | FormatDateLiteral | Converts a DateTime value to a string according to the specific format of the underlying database type
Public Method | GetAdapter | Overloaded. Gets a database type-specific DbDataAdapter instance for this provider type (i.e. SqlDataAdapter for MSSQL) without any options set yet.
Public Method | GetAsStatement | Qualifies a column or table alias according to this provider's database type's rules regarding use of the AS keyword
Public Method | GetBitwiseAndStatement | Formats a bitwise AND statement according to the language features of the underlying database type
Public Method | GetConnection | Overloaded. Gets an IDbConnection object instance of the correct type for the underlying database (i.e. SqlConnection for MSSQL) that is prepared to connect to the specified database using the default connection string specified in the application configuration file.
Public Method | GetDateStatement | Gets a SQL statement fragment for the database-specific syntax of retrieving the current date (i.e. SYSDATE on Oracle or GETDATE() on MSSQL).
Public Method | GetDBDate | Executes a statement against the database to retrieve the current date/time on the database
Public Method | GetDbVersion | Overloaded. Executes a statement against the database to retrieve the database software's version number
Public Method | GetParameterNamePrefix | Gets the prefix used by the underlying database type for parameters in a parameterized query
static (Shared in Visual Basic) | ParseConnectionString | Parses a connection string into name-value pairs
Public Method | PrepareParameter | Prepares a parameter for the specified type of query according to the rules of the underlying database type
Public Method | PrepareSQLStatement | Prepares and formats a SQL statement according to the rules of the underlying database type
Public Method | RemoveParameterNamePrefix | Removes, if necessary, the parameter name prefix on a given parameter name
Public Method | SetDatabaseParameterTypeForClobText |
Public Method | TestConnection | Overloaded. Executes a test to connect to the database using the default connection string
Public Method | ValidateConnectionParams | Validates the supplied connection parameters against the rules of the underlying provider

Reference

DbProvider Class
FChoice.Common.Data Namespace


ConstructConnectionString Method | fcSDK Documentation

ConstructConnectionString Method

The set of keys and values that will make up the connection string where key and value are: key=value;

Constructs a valid ADO.NET-compliant connection string from the supplied key/value pairs.

Syntax

'Declaration
Public Shared Function ConstructConnectionString( _
   ByVal _keyValues_ As NameValueCollection _
) As String

public static string ConstructConnectionString(
   NameValueCollection _keyValues_
)

Parameters

keyValues

The set of keys and values that will make up the connection string where key and value are: key=value;

Return Value

A properly formatted ADO.NET-compliant connection string.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProvider Class
DbProvider Members


CreateCommand Method (DbProvider) | fcSDK Documentation

CreateCommand Method (DbProvider)

Syntax

'Declaration

Public Overridable Function CreateCommand( _
   ByVal _dbConnection_ As IDbConnection _
) As IDbCommand

public virtual IDbCommand CreateCommand(
   IDbConnection _dbConnection_
)

Parameters

dbConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProvider Class
DbProvider Members


CreateConnectionString Method (DbProvider) | fcSDK Documentation

CreateConnectionString Method (DbProvider)

The hostname, IP, or unique identifier name for the database (i.e. host name for MSSQL or SID for Oracle)

The catalog or database name for the database (for MSSQL and Sybase, not required for Oracle-based providers)

The user name for database authentication

The password for the user for database authentication

Additional key/value pairs separated by a semi-colon (;).

Creates a basic connection string from the basic common required elements according the rules of the specific database type

Syntax

'Declaration

Public MustOverride Function CreateConnectionString( _
   ByVal _dbServer_ As String, _
   ByVal _dbName_ As String, _
   ByVal _dbUser_ As String, _
   ByVal _dbPass_ As String, _
   ByVal _extraParams_ As String _
) As String

public abstract string CreateConnectionString(
   string _dbServer_,
   string _dbName_,
   string _dbUser_,
   string _dbPass_,
   string _extraParams_
)

Parameters

dbServer

The hostname, IP, or unique identifier name for the database (i.e. host name for MSSQL or SID for Oracle)

dbName

The catalog or database name for the database (for MSSQL and Sybase, not required for Oracle-based providers)

dbUser

The user name for database authentication

dbPass

The password for the user for database authentication

extraParams

Additional key/value pairs separated by a semi-colon (;).

Return Value

A properly formatted, ADO.NET-compliant connection string.

Remarks

NOTE: This method does not validate the format of the extraParams argument. If the the value of extraParams is invalid, the connection string may not work properly.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProvider Class
DbProvider Members


CreateParameter Method (DbProvider) | fcSDK Documentation

CreateParameter Method (DbProvider)

The name of the parameter to add (without the database-specific bind variable prefix such as @ for Microsoft SQL Server or : for Oracle)

The value of the parameter that will be passed to the database as part of the query

Creates a new IDbDataParameter of the specific underlying type for this database provider type (i.e. SqlHelper for MSSQL, etc)

Syntax

'Declaration

Public MustOverride Function CreateParameter( _
   ByVal _name_ As String, _
   ByVal _value_ As Object _
) As IDbDataParameter

public abstract IDbDataParameter CreateParameter(
   string _name_,
   object _value_
)

Parameters

name

The name of the parameter to add (without the database-specific bind variable prefix such as @ for Microsoft SQL Server or : for Oracle)

value

The value of the parameter that will be passed to the database as part of the query

Return Value

An IDbDataParameter instance which can be added to a parameter collection for a query

Remarks

See DataParameterCollection for more information on how to use data parameters.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProvider Class
DbProvider Members
DataParameterCollection Class


FormatDateLiteral Method (DbProvider) | fcSDK Documentation

FormatDateLiteral Method (DbProvider)

The DateTime value to convert

Converts a DateTime value to a string according to the specific format of the underlying database type

Syntax

'Declaration

Public MustOverride Function FormatDateLiteral( _
   ByVal _value_ As Date _
) As String

public abstract string FormatDateLiteral(
   DateTime _value_
)

Parameters

value

The DateTime value to convert

Return Value

A literal string that is compatible with the underlying database.

Remarks

The resultant string can be used directly in a SQL statement. For example, the date will be formatted as 'yyyy-MM-dd HH:mm:ss.fff' for MSSQL or a TO_DATE(yourdate, 'yyyy-mm-dd hh24:mi:ss') function call will be returned for Oracle.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProvider Class
DbProvider Members


GetAdapter Method (DbProvider) | fcSDK Documentation

GetAdapter Method (DbProvider)

Overload List

Overload | Description
GetAdapter() | Gets a database type-specific DbDataAdapter instance for this provider type (i.e. SqlDataAdapter for MSSQL) without any options set yet.
GetAdapter(IDbConnection) | Gets a database type-specific DbDataAdapter instance for this provider type (i.e. SqlDataAdapter for MSSQL) initialized to use the specified connection to the database.
GetAdapter(IDbConnection,String) | Gets a database type-specific DbDataAdapter instance for this provider type (i.e. SqlDataAdapter for MSSQL) initialized to use the specified connection to the database and the specified SQL statement to execute.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProvider Class DbProvider Members


GetAdapter() Method | fcSDK Documentation

GetAdapter() Method

Gets a database type-specific DbDataAdapter instance for this provider type (i.e. SqlDataAdapter for MSSQL) without any options set yet.

Syntax

'Declaration

Public Overloads MustOverride Function GetAdapter() As DbDataAdapter

public abstract DbDataAdapter GetAdapter()

Return Value

A DbDataAdapter instance for this provider type (i.e. SqlDataAdapter for MSSQL)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProvider Class
DbProvider Members
Overload List


GetAdapter(IDbConnection) Method | fcSDK Documentation

GetAdapter(IDbConnection) Method

The database connection this adapter should use when performing database operations

Gets a database type-specific DbDataAdapter instance for this provider type (i.e. SqlDataAdapter for MSSQL) initialized to use the specified connection to the database.

Syntax

'Declaration

Public Overloads MustOverride Function GetAdapter( _
   ByVal _conn_ As IDbConnection _
) As DbDataAdapter

public abstract DbDataAdapter GetAdapter(
   IDbConnection _conn_
)

Parameters

conn

The database connection this adapter should use when performing database operations

Return Value

A DbDataAdapter instance for this provider type (i.e. SqlDataAdapter for MSSQL), initialized to use the specified connection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProvider Class
DbProvider Members
Overload List


GetAdapter(IDbConnection,String) Method | fcSDK Documentation

GetAdapter(IDbConnection,String) Method

The database connection this adapter should use when performing database operations

The SQL statement to use as the SELECT command for this adapter

Gets a database type-specific DbDataAdapter instance for this provider type (i.e. SqlDataAdapter for MSSQL) initialized to use the specified connection to the database and the specified SQL statement to execute.

Syntax

'Declaration

Public Overloads MustOverride Function GetAdapter( _
   ByVal _conn_ As IDbConnection, _
   ByVal _sqlStmt_ As String _
) As DbDataAdapter

public abstract DbDataAdapter GetAdapter(
   IDbConnection _conn_,
   string _sqlStmt_
)

Parameters

conn

The database connection this adapter should use when performing database operations

sqlStmt

The SQL statement to use as the SELECT command for this adapter

Return Value

A DbDataAdapter instance for this provider type (i.e. SqlDataAdapter for MSSQL), initialized to use the specified connection and SELECT SQL statement

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProvider Class
DbProvider Members
Overload List


GetAsStatement Method (DbProvider) | fcSDK Documentation

GetAsStatement Method (DbProvider)

The name of the column or table alias

Qualifies a column or table alias according to this provider's database type's rules regarding use of the AS keyword

Syntax

'Declaration

Public MustOverride Function GetAsStatement( _
   ByVal _name_ As String _
) As String

public abstract string GetAsStatement(
   string _name_
)

Parameters

name

The name of the column or table alias

Return Value

A string with or without the "AS" keyword as necessary for the underlying database type

Remarks

In MSSQL, the "AS" keyword is not always required, but can help to resolve ambiguity in SQL statements and is recommended. Oracle 8i and earlier do not support the use of the "AS" keyword. This method helps statement writers use column and table aliases without having to worry about underlying support for "AS".

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProvider Class
DbProvider Members


GetBitwiseAndStatement Method (DbProvider) | fcSDK Documentation

GetBitwiseAndStatement Method (DbProvider)

The first operand in a bitwise AND equation (the 'x' in the statement 'x & y')

The second operand in a bitwise AND equation (the 'y' in the statement 'x & y')

Formats a bitwise AND statement according to the language features of the underlying database type

Syntax

'Declaration

Public MustOverride Function GetBitwiseAndStatement( _
   ByVal _operand1_ As Object, _
   ByVal _operand2_ As Object _
) As String

public abstract string GetBitwiseAndStatement(
   object _operand1_,
   object _operand2_
)

Parameters

operand1

The first operand in a bitwise AND equation (the 'x' in the statement 'x & y')

operand2

The second operand in a bitwise AND equation (the 'y' in the statement 'x & y')

Return Value

A properly formatted bitwise AND equation that will be recognized by the underlying database type.

Remarks

MSSQL and Oracle 9 and later recognize the standard C-style bitwise AND statement syntax (x & y). However, Oracle 8i and earlier required the use of the bitand() function to evaluate bitwise AND statements. This method helps SQL statement writers use AND syntax in their queries without concerns of the differences in database types.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProvider Class
DbProvider Members


GetConnection Method (DbProvider) | fcSDK Documentation

GetConnection Method (DbProvider)

Overload List

Overload | Description
GetConnection() | Gets an IDbConnection object instance of the correct type for the underlying database (i.e. SqlConnection for MSSQL) that is prepared to connect to the specified database using the default connection string specified in the application configuration file.
GetConnection(String) | Gets an IDbConnection object instance of the correct type for the underlying database (i.e. SqlConnection for MSSQL) that is prepared to connect to the specified database using the specified connection string.

Remarks

The connection instance is not open by default. In order to open the connection, use the Open method on the IDbConnection reference returned by this method.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProvider Class DbProvider Members


GetConnection() Method | fcSDK Documentation

GetConnection() Method

Gets an IDbConnection object instance of the correct type for the underlying database (i.e. SqlConnection for MSSQL) that is prepared to connect to the specified database using the default connection string specified in the application configuration file.

Syntax

'Declaration

Public Overloads MustOverride Function GetConnection() As IDbConnection

public abstract IDbConnection GetConnection()

Return Value

An IDbConnection object instance of the correct type for the underlying database (i.e. SqlConnection for MSSQL).

Remarks

The connection instance is not open by default. In order to open the connection, use the Open method on the IDbConnection reference returned by this method.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProvider Class
DbProvider Members
Overload List


GetConnection(String) Method | fcSDK Documentation

GetConnection(String) Method

A full connection string that is compatible with the underlying database type. See the remarks for information on how to generate safe connection strings.

Gets an IDbConnection object instance of the correct type for the underlying database (i.e. SqlConnection for MSSQL) that is prepared to connect to the specified database using the specified connection string.

Syntax

'Declaration

Public Overloads MustOverride Function GetConnection( _
   ByVal _conStr_ As String _
) As IDbConnection

public abstract IDbConnection GetConnection(
   string _conStr_
)

Parameters

conStr

A full connection string that is compatible with the underlying database type. See the remarks for information on how to generate safe connection strings.

Return Value

An IDbConnection object instance of the correct type for the underlying database (i.e. SqlConnection for MSSQL).

Remarks

The connection instance is not open by default. In order to open the connection, use the Open method on the IDbConnection reference returned by this method.

To generate connection strings in a database-agnostic fashion, please see the ConstructConnectionString and the CreateConnectionString methods.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProvider Class
DbProvider Members
Overload List


GetDateStatement Method (DbProvider) | fcSDK Documentation

GetDateStatement Method (DbProvider)

Gets a SQL statement fragment for the database-specific syntax of retrieving the current date (i.e. SYSDATE on Oracle or GETDATE() on MSSQL).

Syntax

'Declaration

Public MustOverride Function GetDateStatement() As String

public abstract string GetDateStatement()

Return Value

A SQL statement fragment for the database-specific syntax of retrieving the current date

Remarks

The returned string is a fragment of a statement, not an entire statement. It cannot be executed independently

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProvider Class
DbProvider Members


GetDBDate Method (DbProvider) | fcSDK Documentation

GetDBDate Method (DbProvider)

Executes a statement against the database to retrieve the current date/time on the database

Syntax

'Declaration

Public MustOverride Function GetDBDate() As Date

public abstract DateTime GetDBDate()

Return Value

The current date and time on the database server

Remarks

The date and time returned by this method will be in the database's time zone. If the application is configured for a different time zone, conversion must be done manually. For information on performing time zone conversions using FCFL.NET, please see the following methods on the FCSession class: ChangeDate, ConvertFromLocalToServerDate, and ConvertFromServerToLocalDate.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProvider Class
DbProvider Members
FCSession Class


GetDbVersion Method | fcSDK Documentation

GetDbVersion Method

Executes a statement against the database to retrieve the database software's version number

Overload List

Overload | Description
GetDbVersion() |
GetDbVersion(Boolean) |

Remarks

NOTE: Oracle databases use a five-digit version numbering scheme. The .NET Version object only supports a four-digit numbering scheme. In most Oracle database versions, the fifth digit is zero. However, in the cases where it is not, the fifth digit will be dropped.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProvider Class
DbProvider Members


GetDbVersion() Method | fcSDK Documentation

GetDbVersion() Method

Syntax

'Declaration

Public Overloads Function GetDbVersion() As Version

public Version GetDbVersion()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProvider Class
DbProvider Members
Overload List


GetDbVersion(Boolean) Method | fcSDK Documentation

GetDbVersion(Boolean) Method

Syntax

'Declaration

Public Overloads Function GetDbVersion( _
   ByVal _force_ As Boolean _
) As Version

public Version GetDbVersion(
   bool _force_
)

Parameters

force

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProvider Class
DbProvider Members
Overload List


GetParameterNamePrefix Method (DbProvider) | fcSDK Documentation

GetParameterNamePrefix Method (DbProvider)

Gets the prefix used by the underlying database type for parameters in a parameterized query

Syntax

'Declaration

Public MustOverride Function GetParameterNamePrefix() As String

public abstract string GetParameterNamePrefix()

Return Value

The prefix used by the underlying database type for parameters in a parameterized query (i.e. "@" for MSSQL) or String.Empty for providers which do not use prefixes or parameter names

Remarks

Some database and/or provider types do not use prefixes for parameters, or do not use parameter names at all. One example of this is the OleDb provider uses "?" for all parameters instead of a prefix + name. In this case, String.Empty will be returned.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProvider Class
DbProvider Members


ParseConnectionString Method | fcSDK Documentation

ParseConnectionString Method

A valid ADO.NET connection string to parse (in the format of name=value;name2=value2;)

Parses a connection string into name-value pairs

Syntax

'Declaration

Public Shared Function ParseConnectionString( _
   ByVal _connectStr_ As String _
) As NameValueCollection

public static NameValueCollection ParseConnectionString(
   string _connectStr_
)

Parameters

connectStr

A valid ADO.NET connection string to parse (in the format of name=value;name2=value2;)

Return Value

A NameValueCollection of the name-value pairs contained in the connection string

Remarks

A trailing semi-colon is not required. For more information about the format of the connection string and possible parameters, please see the SqlConnection.ConnectionString property documentation. Oracle and other connection strings follow the same general rules and expose most of the same parameters as a SqlConnection connection string.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProvider Class
DbProvider Members
SqlConnection Class
ConnectionString property


PrepareParameter Method (DbProvider) | fcSDK Documentation

PrepareParameter Method (DbProvider)

The parameter to prepare for the query

The type of query being performed

Prepares a parameter for the specified type of query according to the rules of the underlying database type

Syntax

'Declaration

Public Overridable Sub PrepareParameter( _
   ByVal _param_ As IDbDataParameter, _
   ByVal _cmdType_ As CommandType _
)

public virtual void PrepareParameter(
   IDbDataParameter _param_,
   CommandType _cmdType_
)

Parameters

param

The parameter to prepare for the query

cmdType

The type of query being performed

Remarks

Different database types and even different query types within the same database type have different requirements for how parameters must be named or formatted. This method allows the specific DbProvider to prepare the parameter as appropriate.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProvider Class
DbProvider Members


PrepareSQLStatement Method (DbProvider) | fcSDK Documentation

PrepareSQLStatement Method (DbProvider)

The statement to prepare and format

The type of query being executed

Parameters for the parameterized query or stored procedure

Prepares and formats a SQL statement according to the rules of the underlying database type

Syntax

'Declaration

Public MustOverride Function PrepareSQLStatement( _
   ByVal _sqlStmt_ As String, _
   ByVal _cmdType_ As CommandType, _
   ByVal _commandParams_ As DataParameterCollection _
) As String

public abstract string PrepareSQLStatement(
   string _sqlStmt_,
   CommandType _cmdType_,
   DataParameterCollection _commandParams_
)

Parameters

sqlStmt

The statement to prepare and format

cmdType

The type of query being executed

commandParams

Parameters for the parameterized query or stored procedure

Return Value

A formatted and prepared string, ready to be executed against the database

Remarks

This method will replace special tokens with statements or parameter names according to the type of query and parameters passed in. For example, the {DATE} token will be replaced with the database type's special date statement (as returned by the GetDateStatement Method). Parameters are specified using the {n} syntax where n is an ascending number. The number of {n} parameters must match the number of parameters specified in the commandParams argument.

For example, the string:

SELECT {DATE} AS CurDate FROM some_table WHERE name = {0} AND id = {1}

with the parameters named "nameVal" and "idVal" will be formatted as such with an MSSQL provider:

SELECT GETDATE() AS CurDate FROM some_table WHERE name = @nameVal AND id = @idVal

This statement can then be executed against the database using an ADO.NET IDbCommand instance, or the SqlHelper class.

NOTE: SqlHelper will automatically call this method during Execute* methods like ExecuteNonQuery or ExecuteDataSet. Generally, this method should not be called directly, only through SqlHelper.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProvider Class
DbProvider Members


RemoveParameterNamePrefix Method (DbProvider) | fcSDK Documentation

RemoveParameterNamePrefix Method (DbProvider)

The parameter name with an optional parameter name prefix

Removes, if necessary, the parameter name prefix on a given parameter name

Syntax

'Declaration

Public MustOverride Function RemoveParameterNamePrefix( _
   ByVal _name_ As String _
) As String

public abstract string RemoveParameterNamePrefix(
   string _name_
)

Parameters

name

The parameter name with an optional parameter name prefix

Return Value

The parameter name without any name prefix

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProvider Class
DbProvider Members


SetDatabaseParameterTypeForClobText Method (DbProvider) | fcSDK Documentation

SetDatabaseParameterTypeForClobText Method (DbProvider)

Syntax

'Declaration

Public Overridable Sub SetDatabaseParameterTypeForClobText( _
   ByVal _dbParameter_ As IDbDataParameter, _
   ByVal _isParameterUnicode_ As Boolean _
)

public virtual void SetDatabaseParameterTypeForClobText(
   IDbDataParameter _dbParameter_,
   bool _isParameterUnicode_
)

Parameters

dbParameter

isParameterUnicode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProvider Class
DbProvider Members


TestConnection Method | fcSDK Documentation

TestConnection Method

Executes a test to connect to the database using the default connection string

Overload List

Overload | Description
TestConnection() |
TestConnection(Exception) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProvider Class
DbProvider Members


TestConnection() Method | fcSDK Documentation

TestConnection() Method

Syntax

'Declaration

Public Overloads Function TestConnection() As Boolean

public bool TestConnection()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProvider Class
DbProvider Members
Overload List


TestConnection(Exception) Method | fcSDK Documentation

TestConnection(Exception) Method

Syntax

'Declaration

Public Overloads Function TestConnection( _
   ByRef _outEx_ As Exception _
) As Boolean

public bool TestConnection(
   out Exception _outEx_
)

Parameters

outEx

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProvider Class
DbProvider Members
Overload List


ValidateConnectionParams Method (DbProvider) | fcSDK Documentation

ValidateConnectionParams Method (DbProvider)

The host name, IP address, or Oracle SID of the database server

The catalog or database to use (not required for Oracle)

The user or login name to use for authentication

The password to use for authentication

Validates the supplied connection parameters against the rules of the underlying provider

Syntax

'Declaration

Public MustOverride Function ValidateConnectionParams( _
   ByVal _dbServer_ As String, _
   ByVal _dbName_ As String, _
   ByVal _dbUser_ As String, _
   ByVal _dbPass_ As String _
) As Boolean

public abstract bool ValidateConnectionParams(
   string _dbServer_,
   string _dbName_,
   string _dbUser_,
   string _dbPass_
)

Parameters

dbServer

The host name, IP address, or Oracle SID of the database server

dbName

The catalog or database to use (not required for Oracle)

dbUser

The user or login name to use for authentication

dbPass

The password to use for authentication

Return Value

True if the parameters are valid according to the provider, or False if they are not

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProvider Class
DbProvider Members


CanBatchQueries Property | fcSDK Documentation

CanBatchQueries Property

Specifies whether the underlying database type for this provider can support multiple SQL statements per database round-trip

Syntax

'Declaration

Public Overridable ReadOnly Property CanBatchQueries As Boolean

public virtual bool CanBatchQueries {get;}

Property Value

Whether the underlying database type for this provider can support multiple SQL statements per database round-trip

Remarks

This value is normally the natural value according to the provider, but can be overridden by using the "fchoice.enablebatch" (or ConfigValues.ENABLE_BATCH Field) configuration parameter.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProvider Class
DbProvider Members


ConnectionString Property (DbProvider) | fcSDK Documentation

ConnectionString Property (DbProvider)

Gets or sets the connection string this provider will use for database connections

Syntax

'Declaration
Public Overridable Property ConnectionString As String

public virtual string ConnectionString {get; set;}

Property Value

The connection string this provider will use for database connections

Remarks

This value is normally the value specified in the application configuration file. However, it can be set to another connection string at which point the provider will use the newly specified value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProvider Class
DbProvider Members


MaxInListItems Property (DbProvider) | fcSDK Documentation

MaxInListItems Property (DbProvider)

Gets the maximum number of items the underlying database type supports in an IN() or NOT IN() SQL clause

Syntax

'Declaration

Public MustOverride ReadOnly Property MaxInListItems As Integer

public abstract int MaxInListItems {get;}

Property Value

The maximum number of items the underlying database type supports in an IN() or NOT IN() SQL clause

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProvider Class
DbProvider Members


ProviderName Property (DbProvider) | fcSDK Documentation

ProviderName Property (DbProvider)

A general provider type or key to classify this provider

Syntax

'Declaration

Public MustOverride ReadOnly Property ProviderName As String

public abstract string ProviderName {get;}

Property Value

A general provider type or key to classify this provider

Remarks

This value may be different than the key specified in the application configuration file. For example, the ODP.NET provider for Oracle can use the key "ODPNET", however, its provider name is equivalent to the DbProviderFactory.ORACLE_PROVIDER_NAME Constant value. This is so that providers can be put into general types or categorizations which makes it easier for application developers to formulate proper SQL statements for that database type.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProvider Class
DbProvider Members


RequiresDbNameParameter Property (DbProvider) | fcSDK Documentation

RequiresDbNameParameter Property (DbProvider)

Gets whether or not this provider requires the "dbname" argument for the CreateConnectionString Method

Syntax

'Declaration

Public MustOverride ReadOnly Property RequiresDbNameParameter As Boolean

public abstract bool RequiresDbNameParameter {get;}

Property Value

Whether or not this provider requires the "dbname" argument for the CreateConnectionString Method

Remarks

This property is helpful for application developers writing utilities and user interfaces for collecting database connection information from a user in a database-agnostic way. This allows programmatic control on whether a "DB Name:" field should be displayed or not.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProvider Class
DbProvider Members


TypeMapper Property (DbProvider) | fcSDK Documentation

TypeMapper Property (DbProvider)

This property is intended for future use and is not currently used.

Syntax

'Declaration

Public MustOverride ReadOnly Property TypeMapper As TypeMapper

public abstract TypeMapper TypeMapper {get;}

Remarks

This property is intended for future use and is not currently used.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProvider Class
DbProvider Members


DbProviderFactory Class | fcSDK Documentation

DbProviderFactory Class

Provides a way of customized data access using DbProvider objects that abstract database access

Syntax

'Declaration

Public NotInheritable Class DbProviderFactory

public sealed class DbProviderFactory

Remarks

This class and all its methods and properties are thread safe.

Inheritance Hierarchy

System.Object
FChoice.Common.Data.DbProviderFactory

Requirements

Namespace: FChoice.Common.Data

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

DbProviderFactory Members
FChoice.Common.Data Namespace


DbProviderFactory Class Members | fcSDK Documentation

DbProviderFactory Class Members

The following tables list the members exposed by DbProviderFactory.

Public Fields

 | Name | Description
Public Field | CONFIGURATION_SECTION_NAME | The name of the configuration section that DbProviderFactory expects in the application configuration file
Public Field | MSSQL_PROVIDER_NAME | The default provider name of MSSQL-based data providers
Public Field | ODPNET_PROVIDER_NAME |
Public Field | ORACLE_PROVIDER_NAME | The default provider name of Oracle-based data providers

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Provider | Gets a reference to the default configured DbProvider instance
static (Shared in Visual Basic) | ProviderNames | Gets the list of available provider names/alias that can be used for displaying to the user or as an argument for the CreateProvider method.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ConfigureProviders | Overloaded.
static (Shared in Visual Basic) | CreateProvider | Overloaded. Creates a new instance of a DbProvider object from the default configured provider
static (Shared in Visual Basic) | IsOracle |
Public Method | IsValidProvider | Gets whether or not the specified alias or name is a valid alias/name for a configured or intrinsic data access provider

Reference

DbProviderFactory Class
FChoice.Common.Data Namespace


ConfigureProviders Method | fcSDK Documentation

ConfigureProviders Method

Overload List

Overload | Description
ConfigureProviders() |
ConfigureProviders(String) |
ConfigureProviders(XmlElement) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProviderFactory Class
DbProviderFactory Members


ConfigureProviders() Method | fcSDK Documentation

ConfigureProviders() Method

Syntax

'Declaration

Public Overloads Shared Sub ConfigureProviders()

public static void ConfigureProviders()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProviderFactory Class
DbProviderFactory Members
Overload List


ConfigureProviders(String) Method | fcSDK Documentation

ConfigureProviders(String) Method

Syntax

'Declaration

Public Overloads Shared Sub ConfigureProviders( _
   ByVal _configFilePath_ As String _
)

public static void ConfigureProviders(
   string _configFilePath_
)

Parameters

configFilePath

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProviderFactory Class
DbProviderFactory Members
Overload List


ConfigureProviders(XmlElement) Method | fcSDK Documentation

ConfigureProviders(XmlElement) Method

Syntax

'Declaration

Public Overloads Shared Sub ConfigureProviders( _
   ByVal _parentElm_ As XmlElement _
)

public static void ConfigureProviders(
   XmlElement _parentElm_
)

Parameters

parentElm

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProviderFactory Class
DbProviderFactory Members
Overload List


CreateProvider Method | fcSDK Documentation

CreateProvider Method

Overload List

Overload | Description
CreateProvider() | Creates a new instance of a DbProvider object from the default configured provider
CreateProvider(String) | Creates a new instance of a DbProvider object from the specified provider alias

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProviderFactory Class DbProviderFactory Members


CreateProvider() Method | fcSDK Documentation

CreateProvider() Method

Creates a new instance of a DbProvider object from the default configured provider

Syntax

'Declaration

Public Overloads Shared Function CreateProvider() As DbProvider

public static DbProvider CreateProvider()

Return Value

A new DbProvider instance for the configured default alias

Remarks

It is not necessary to create a new instance of the default DbProvider every time it is used. Instead, see the Provider property to get a reference to the common instance of the default DbProvider.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProviderFactory Class
DbProviderFactory Members
Overload List


CreateProvider(String) Method | fcSDK Documentation

CreateProvider(String) Method

A provider alias that matches one of the intrinsic provider aliases, one configured in the application configuration file, or a null reference (Nothing in Visual Basic) for the default alias

Creates a new instance of a DbProvider object from the specified provider alias

Syntax

'Declaration

Public Overloads Shared Function CreateProvider( _
   ByVal _providerAlias_ As String _
) As DbProvider

public static DbProvider CreateProvider(
   string _providerAlias_
)

Parameters

providerAlias

A provider alias that matches one of the intrinsic provider aliases, one configured in the application configuration file, or a null reference (Nothing in Visual Basic) for the default alias

Return Value

A new DbProvider instance configured for the given alias

Exceptions

Exception | Description
CommonException | Error Code 5012 No provider with the specified alias is configured

Remarks

The three intrinsic aliases are the values for the these constants: DbProviderFactory.MSSQL_PROVIDER_NAME, DbProviderFactory.ORACLE_PROVIDER_NAME, and DbProviderFactory.ODPNET_PROVIDER_NAME.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProviderFactory Class
DbProviderFactory Members
Overload List


IsOracle Method | fcSDK Documentation

IsOracle Method

Syntax

'Declaration

Public Shared Function IsOracle() As Boolean

public static bool IsOracle()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProviderFactory Class
DbProviderFactory Members


IsValidProvider Method | fcSDK Documentation

IsValidProvider Method

The provider name or alias to verify

Gets whether or not the specified alias or name is a valid alias/name for a configured or intrinsic data access provider

Syntax

'Declaration

Public Function IsValidProvider( _
   ByVal _providerName_ As String _
) As Boolean

public bool IsValidProvider(
   string _providerName_
)

Parameters

providerName

The provider name or alias to verify

Return Value

Whether or not the specified alias or name is a valid alias/name for a configured or intrinsic data access provider

Exceptions

Exception | Description
ArgumentNullException | key is a null reference (Nothing in Visual Basic)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProviderFactory Class
DbProviderFactory Members


Provider Property (DbProviderFactory) | fcSDK Documentation

Provider Property (DbProviderFactory)

Gets a reference to the default configured DbProvider instance

Syntax

'Declaration
Public Shared Property Provider As DbProvider

public static DbProvider Provider {get; set;}

Property Value

A reference to the default configured DbProvider instance

Remarks

While the CreateProvider Method will return a new default provider instance, it creates a new one every time. It is more efficient to use the primary default provider instance. DbProvider implementations are required to be thread safe, so it is OK to use a single instance in this fashion.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProviderFactory Class
DbProviderFactory Members


ProviderNames Property | fcSDK Documentation

ProviderNames Property

Gets the list of available provider names/alias that can be used for displaying to the user or as an argument for the CreateProvider method.

Syntax

'Declaration

Public Shared ReadOnly Property ProviderNames As String()

public static string[] ProviderNames {get;}

Property Value

An array of strings where each element is a valid provider name/alias such as "MSSQL", "ORACLE", or "ODPNET".

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProviderFactory Class
DbProviderFactory Members


CONFIGURATION_SECTION_NAME Field (DbProviderFactory) | fcSDK Documentation

CONFIGURATION_SECTION_NAME Field (DbProviderFactory)

The name of the configuration section that DbProviderFactory expects in the application configuration file

Syntax

'Declaration

Public Const CONFIGURATION_SECTION_NAME As String

public const string CONFIGURATION_SECTION_NAME

Remarks

The value of this constant is "dataAccess".

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProviderFactory Class
DbProviderFactory Members


MSSQL_PROVIDER_NAME Field | fcSDK Documentation

MSSQL_PROVIDER_NAME Field

The default provider name of MSSQL-based data providers

Syntax

'Declaration

Public Const MSSQL_PROVIDER_NAME As String

public const string MSSQL_PROVIDER_NAME

Remarks

Please see remarks section of the DbProvider.ProviderName property documentation for more information on the significance of this value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProviderFactory Class
DbProviderFactory Members


ODPNET_PROVIDER_NAME Field | fcSDK Documentation

ODPNET_PROVIDER_NAME Field

Syntax

'Declaration

Public Const ODPNET_PROVIDER_NAME As String

public const string ODPNET_PROVIDER_NAME

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProviderFactory Class
DbProviderFactory Members


ORACLE_PROVIDER_NAME Field | fcSDK Documentation

ORACLE_PROVIDER_NAME Field

The default provider name of Oracle-based data providers

Syntax

'Declaration

Public Const ORACLE_PROVIDER_NAME As String

public const string ORACLE_PROVIDER_NAME

Remarks

Please see remarks section of the DbProvider.ProviderName property documentation for more information on the significance of this value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DbProviderFactory Class
DbProviderFactory Members


FCTypes Class | fcSDK Documentation

FCTypes Class

This class is not currently used and is intended for future products.

Syntax

'Declaration

Public NotInheritable Class FCTypes

public sealed class FCTypes

Inheritance Hierarchy

System.Object
FChoice.Common.Data.FCTypes

Requirements

Namespace: FChoice.Common.Data

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

FCTypes Members
FChoice.Common.Data Namespace


FCTypes Class Members | fcSDK Documentation

FCTypes Class Members

The following tables list the members exposed by FCTypes.

Public Fields

 | Name | Description
Public Field | Date |
Public Field | DateNumber |
Public Field | Decimal |
Public Field | DecimalNumber |
Public Field | Float |
Public Field | FloatNumber |
Public Field | Guid |
Public Field | GuidNumber |
Public Field | LongInt |
Public Field | LongIntNumber |
Public Field | NText |
Public Field | NTextNumber |
Public Field | NVarchar |
Public Field | NVarcharNumber |
Public Field | Text |
Public Field | TextNumber |
Public Field | TinyInt |
Public Field | TinyIntNumber |
Public Field | Varchar |
Public Field | VarcharNumber |

Reference

FCTypes Class
FChoice.Common.Data Namespace


Date Field | fcSDK Documentation

Date Field

Syntax

'Declaration

Public Const Date As String

public const string Date

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCTypes Class
FCTypes Members


DateNumber Field | fcSDK Documentation

DateNumber Field

Syntax

'Declaration

Public Const DateNumber As Integer

public const int DateNumber

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCTypes Class
FCTypes Members


Decimal Field | fcSDK Documentation

Decimal Field

Syntax

'Declaration

Public Const Decimal As String

public const string Decimal

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCTypes Class
FCTypes Members


DecimalNumber Field | fcSDK Documentation

DecimalNumber Field

Syntax

'Declaration

Public Const DecimalNumber As Integer

public const int DecimalNumber

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCTypes Class
FCTypes Members


Float Field | fcSDK Documentation

Float Field

Syntax

'Declaration

Public Const Float As String

public const string Float

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCTypes Class
FCTypes Members


FloatNumber Field | fcSDK Documentation

FloatNumber Field

Syntax

'Declaration

Public Const FloatNumber As Integer

public const int FloatNumber

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCTypes Class
FCTypes Members


Guid Field | fcSDK Documentation

Guid Field

Syntax

'Declaration

Public Const Guid As String

public const string Guid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCTypes Class
FCTypes Members


GuidNumber Field | fcSDK Documentation

GuidNumber Field

Syntax

'Declaration

Public Const GuidNumber As Integer

public const int GuidNumber

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCTypes Class
FCTypes Members


LongInt Field | fcSDK Documentation

LongInt Field

Syntax

'Declaration

Public Const LongInt As String

public const string LongInt

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCTypes Class
FCTypes Members


LongIntNumber Field | fcSDK Documentation

LongIntNumber Field

Syntax

'Declaration

Public Const LongIntNumber As Integer

public const int LongIntNumber

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCTypes Class
FCTypes Members


NText Field | fcSDK Documentation

NText Field

Syntax

'Declaration

Public Const NText As String

public const string NText

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCTypes Class
FCTypes Members


NTextNumber Field | fcSDK Documentation

NTextNumber Field

Syntax

'Declaration

Public Const NTextNumber As Integer

public const int NTextNumber

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCTypes Class
FCTypes Members


NVarchar Field | fcSDK Documentation

NVarchar Field

Syntax

'Declaration

Public Const NVarchar As String

public const string NVarchar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCTypes Class
FCTypes Members


NVarcharNumber Field | fcSDK Documentation

NVarcharNumber Field

Syntax

'Declaration

Public Const NVarcharNumber As Integer

public const int NVarcharNumber

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCTypes Class
FCTypes Members


Text Field | fcSDK Documentation

Text Field

Syntax

'Declaration

Public Const Text As String

public const string Text

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCTypes Class
FCTypes Members


TextNumber Field | fcSDK Documentation

TextNumber Field

Syntax

'Declaration

Public Const TextNumber As Integer

public const int TextNumber

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCTypes Class
FCTypes Members


TinyInt Field | fcSDK Documentation

TinyInt Field

Syntax

'Declaration

Public Const TinyInt As String

public const string TinyInt

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCTypes Class
FCTypes Members


TinyIntNumber Field | fcSDK Documentation

TinyIntNumber Field

Syntax

'Declaration

Public Const TinyIntNumber As Integer

public const int TinyIntNumber

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCTypes Class
FCTypes Members


Varchar Field | fcSDK Documentation

Varchar Field

Syntax

'Declaration

Public Const Varchar As String

public const string Varchar

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCTypes Class
FCTypes Members


VarcharNumber Field | fcSDK Documentation

VarcharNumber Field

Syntax

'Declaration

Public Const VarcharNumber As Integer

public const int VarcharNumber

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCTypes Class
FCTypes Members


ODPOracleProvider Class | fcSDK Documentation

ODPOracleProvider Class

Syntax

'Declaration

Public Class ODPOracleProvider
   Inherits OracleProviderBase

public class ODPOracleProvider : OracleProviderBase

Inheritance Hierarchy

System.Object
FChoice.Common.Data.DbProvider
FChoice.Common.Data.OracleProviderBase
FChoice.Common.Data.ODPOracleProvider

Requirements

Namespace: FChoice.Common.Data

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

ODPOracleProvider Members
FChoice.Common.Data Namespace


ODPOracleProvider Class Members | fcSDK Documentation

ODPOracleProvider Class Members

The following tables list the members exposed by ODPOracleProvider.

Public Constructors

 | Name | Description
Public Constructor | ODPOracleProvider Constructor |

Public Properties

 | Name | Description
Public Property | CanBatchQueries | Specifies whether the underlying database type for this provider can support multiple SQL statements per database round-trip (Inherited from FChoice.Common.Data.DbProvider)
Public Property | ConnectionString | Gets or sets the connection string this provider will use for database connections (Inherited from FChoice.Common.Data.DbProvider)
Public Property | MaxInListItems | (Inherited from FChoice.Common.Data.OracleProviderBase)
Public Property | ProviderName | (Inherited from FChoice.Common.Data.OracleProviderBase)
Public Property | RequiresDbNameParameter | (Inherited from FChoice.Common.Data.OracleProviderBase)
Public Property | TypeMapper | (Inherited from FChoice.Common.Data.OracleProviderBase)

Public Methods

 | Name | Description
Public Method | AreLargeTextFieldsClobs | (Inherited from FChoice.Common.Data.OracleProviderBase)
Public Method | CreateCommand | Overridden.
Public Method | CreateConnectionString | (Inherited from FChoice.Common.Data.OracleProviderBase)
Public Method | CreateParameter | Overridden.
Public Method | FormatDateLiteral | (Inherited from FChoice.Common.Data.OracleProviderBase)
Public Method | GetAdapter | Overloaded. Overridden.
Public Method | GetAsStatement | (Inherited from FChoice.Common.Data.OracleProviderBase)
Public Method | GetBitwiseAndStatement | (Inherited from FChoice.Common.Data.OracleProviderBase)
Public Method | GetConnection | Overloaded. Overridden.
Public Method | GetDateStatement | (Inherited from FChoice.Common.Data.OracleProviderBase)
Public Method | GetDBDate | (Inherited from FChoice.Common.Data.OracleProviderBase)
Public Method | GetDbVersion | Overloaded. (Inherited from FChoice.Common.Data.DbProvider)
Public Method | GetParameterNamePrefix | (Inherited from FChoice.Common.Data.OracleProviderBase)
Public Method | PrepareParameter | (Inherited from FChoice.Common.Data.OracleProviderBase)
Public Method | PrepareSQLStatement | (Inherited from FChoice.Common.Data.OracleProviderBase)
Public Method | RemoveParameterNamePrefix | (Inherited from FChoice.Common.Data.OracleProviderBase)
Public Method | SetDatabaseParameterTypeForClobText | Overridden.
Public Method | TestConnection | Overloaded. (Inherited from FChoice.Common.Data.DbProvider)
Public Method | ValidateConnectionParams | (Inherited from FChoice.Common.Data.OracleProviderBase)

Reference

ODPOracleProvider Class
FChoice.Common.Data Namespace


ODPOracleProvider Constructor | fcSDK Documentation

ODPOracleProvider Constructor

Syntax

'Declaration

Public Function New()

public ODPOracleProvider()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ODPOracleProvider Class
ODPOracleProvider Members


CreateCommand Method (ODPOracleProvider) | fcSDK Documentation

CreateCommand Method (ODPOracleProvider)

Syntax

'Declaration

Public Overrides Function CreateCommand( _
   ByVal _dbConnection_ As IDbConnection _
) As IDbCommand

public override IDbCommand CreateCommand(
   IDbConnection _dbConnection_
)

Parameters

dbConnection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ODPOracleProvider Class
ODPOracleProvider Members
Base Implementation in CreateCommand


CreateParameter Method (ODPOracleProvider) | fcSDK Documentation

CreateParameter Method (ODPOracleProvider)

Syntax

'Declaration

Public Overrides Function CreateParameter( _
   ByVal _name_ As String, _
   ByVal _value_ As Object _
) As IDbDataParameter

public override IDbDataParameter CreateParameter(
   string _name_,
   object _value_
)

Parameters

name

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ODPOracleProvider Class
ODPOracleProvider Members
Base Implementation in CreateParameter


GetAdapter Method (ODPOracleProvider) | fcSDK Documentation

GetAdapter Method (ODPOracleProvider)

Overload List

Overload | Description
GetAdapter() |
GetAdapter(IDbConnection) |
GetAdapter(IDbConnection,String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ODPOracleProvider Class
ODPOracleProvider Members
Base Implementation in GetAdapter


GetAdapter() Method | fcSDK Documentation

GetAdapter() Method

Syntax

'Declaration

Public Overloads Overrides Function GetAdapter() As DbDataAdapter

public override DbDataAdapter GetAdapter()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ODPOracleProvider Class
ODPOracleProvider Members
Overload List
Base Implementation in GetAdapter()


GetAdapter(IDbConnection) Method | fcSDK Documentation

GetAdapter(IDbConnection) Method

Syntax

'Declaration

Public Overloads Overrides Function GetAdapter( _
   ByVal _conn_ As IDbConnection _
) As DbDataAdapter

public override DbDataAdapter GetAdapter(
   IDbConnection _conn_
)

Parameters

conn

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ODPOracleProvider Class
ODPOracleProvider Members
Overload List
Base Implementation in GetAdapter(IDbConnection)


GetAdapter(IDbConnection,String) Method | fcSDK Documentation

GetAdapter(IDbConnection,String) Method

Syntax

'Declaration

Public Overloads Overrides Function GetAdapter( _
   ByVal _conn_ As IDbConnection, _
   ByVal _sqlStmt_ As String _
) As DbDataAdapter

public override DbDataAdapter GetAdapter(
   IDbConnection _conn_,
   string _sqlStmt_
)

Parameters

conn

sqlStmt

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ODPOracleProvider Class
ODPOracleProvider Members
Overload List
Base Implementation in GetAdapter(IDbConnection,String)


GetConnection Method (ODPOracleProvider) | fcSDK Documentation

GetConnection Method (ODPOracleProvider)

Overload List

Overload | Description
GetConnection() |
GetConnection(String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ODPOracleProvider Class
ODPOracleProvider Members
Base Implementation in GetConnection


GetConnection() Method | fcSDK Documentation

GetConnection() Method

Syntax

'Declaration

Public Overloads Overrides Function GetConnection() As IDbConnection

public override IDbConnection GetConnection()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ODPOracleProvider Class
ODPOracleProvider Members
Overload List
Base Implementation in GetConnection()


GetConnection(String) Method | fcSDK Documentation

GetConnection(String) Method

Syntax

'Declaration

Public Overloads Overrides Function GetConnection( _
   ByVal _newConStr_ As String _
) As IDbConnection

public override IDbConnection GetConnection(
   string _newConStr_
)

Parameters

newConStr

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ODPOracleProvider Class
ODPOracleProvider Members
Overload List
Base Implementation in GetConnection(String)


SetDatabaseParameterTypeForClobText Method (ODPOracleProvider) | fcSDK Documentation

SetDatabaseParameterTypeForClobText Method (ODPOracleProvider)

Syntax

'Declaration

Public Overrides Sub SetDatabaseParameterTypeForClobText( _
   ByVal _dbParameter_ As IDbDataParameter, _
   ByVal _isParameterUnicode_ As Boolean _
)

public override void SetDatabaseParameterTypeForClobText(
   IDbDataParameter _dbParameter_,
   bool _isParameterUnicode_
)

Parameters

dbParameter

isParameterUnicode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ODPOracleProvider Class
ODPOracleProvider Members
Base Implementation in SetDatabaseParameterTypeForClobText


OleDbDataProviderBase Class | fcSDK Documentation

OleDbDataProviderBase Class

Abstract base class for OleDb-based data providers

Syntax

'Declaration

Public MustInherit Class OleDbDataProviderBase
   Inherits DbProvider

public abstract class OleDbDataProviderBase : DbProvider

Remarks

Inherit from this class to implement a data provider based on the OleDb client in ADO.NET.

Inheritance Hierarchy

System.Object
FChoice.Common.Data.DbProvider
FChoice.Common.Data.OleDbDataProviderBase

Requirements

Namespace: FChoice.Common.Data

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

OleDbDataProviderBase Members
FChoice.Common.Data Namespace


OleDbDataProviderBase Class Members | fcSDK Documentation

OleDbDataProviderBase Class Members

The following tables list the members exposed by OleDbDataProviderBase.

Public Properties

 | Name | Description
Public Property | CanBatchQueries | Specifies whether the underlying database type for this provider can support multiple SQL statements per database round-trip (Inherited from FChoice.Common.Data.DbProvider)
Public Property | ConnectionString | Gets or sets the connection string this provider will use for database connections (Inherited from FChoice.Common.Data.DbProvider)
Public Property | MaxInListItems | Gets the maximum number of items the underlying database type supports in an IN() or NOT IN() SQL clause (Inherited from FChoice.Common.Data.DbProvider)
Public Property | ProviderName | A general provider type or key to classify this provider (Inherited from FChoice.Common.Data.DbProvider)
Public Property | RequiresDbNameParameter | Gets whether or not this provider requires the "dbname" argument for the CreateConnectionString Method (Inherited from FChoice.Common.Data.DbProvider)
Public Property | TypeMapper | This property is intended for future use and is not currently used. (Inherited from FChoice.Common.Data.DbProvider)

Public Methods

 | Name | Description
Public Method | CreateCommand | (Inherited from FChoice.Common.Data.DbProvider)
Public Method | CreateConnectionString | Overridden.
Public Method | CreateParameter | Overridden.
Public Method | FormatDateLiteral | Converts a DateTime value to a string according to the specific format of the underlying database type (Inherited from FChoice.Common.Data.DbProvider)
Public Method | GetAdapter | Overloaded. Overridden.
Public Method | GetAsStatement | Qualifies a column or table alias according to this provider's database type's rules regarding use of the AS keyword (Inherited from FChoice.Common.Data.DbProvider)
Public Method | GetBitwiseAndStatement | Overridden.
Public Method | GetConnection | Overloaded. Overridden.
Public Method | GetDateStatement | Gets a SQL statement fragment for the database-specific syntax of retrieving the current date (i.e. SYSDATE on Oracle or GETDATE() on MSSQL). (Inherited from FChoice.Common.Data.DbProvider)
Public Method | GetDBDate | Executes a statement against the database to retrieve the current date/time on the database (Inherited from FChoice.Common.Data.DbProvider)
Public Method | GetDbVersion | Overloaded. (Inherited from FChoice.Common.Data.DbProvider)
Public Method | GetParameterNamePrefix | Overridden.
Public Method | PrepareParameter | Prepares a parameter for the specified type of query according to the rules of the underlying database type (Inherited from FChoice.Common.Data.DbProvider)
Public Method | PrepareSQLStatement | Overridden.
Public Method | RemoveParameterNamePrefix | Overridden.
Public Method | SetDatabaseParameterTypeForClobText | (Inherited from FChoice.Common.Data.DbProvider)
Public Method | TestConnection | Overloaded. (Inherited from FChoice.Common.Data.DbProvider)
Public Method | ValidateConnectionParams | Overridden.

Reference

OleDbDataProviderBase Class
FChoice.Common.Data Namespace


CreateConnectionString Method (OleDbDataProviderBase) | fcSDK Documentation

CreateConnectionString Method (OleDbDataProviderBase)

Syntax

'Declaration

Public Overrides Function CreateConnectionString( _
   ByVal _dbServer_ As String, _
   ByVal _dbName_ As String, _
   ByVal _dbUser_ As String, _
   ByVal _dbPass_ As String, _
   ByVal _extraParams_ As String _
) As String

public override string CreateConnectionString(
   string _dbServer_,
   string _dbName_,
   string _dbUser_,
   string _dbPass_,
   string _extraParams_
)

Parameters

dbServer

dbName

dbUser

dbPass

extraParams

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OleDbDataProviderBase Class
OleDbDataProviderBase Members
Base Implementation in CreateConnectionString


CreateParameter Method (OleDbDataProviderBase) | fcSDK Documentation

CreateParameter Method (OleDbDataProviderBase)

Syntax

'Declaration

Public Overrides Function CreateParameter( _
   ByVal _name_ As String, _
   ByVal _value_ As Object _
) As IDbDataParameter

public override IDbDataParameter CreateParameter(
   string _name_,
   object _value_
)

Parameters

name

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OleDbDataProviderBase Class
OleDbDataProviderBase Members
Base Implementation in CreateParameter


GetAdapter Method (OleDbDataProviderBase) | fcSDK Documentation

GetAdapter Method (OleDbDataProviderBase)

Overload List

Overload | Description
GetAdapter(IDbConnection) |
GetAdapter() |
GetAdapter(IDbConnection,String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OleDbDataProviderBase Class
OleDbDataProviderBase Members
Base Implementation in GetAdapter


GetAdapter(IDbConnection) Method | fcSDK Documentation

GetAdapter(IDbConnection) Method

Syntax

'Declaration

Public Overloads Overrides Function GetAdapter( _
   ByVal _conn_ As IDbConnection _
) As DbDataAdapter

public override DbDataAdapter GetAdapter(
   IDbConnection _conn_
)

Parameters

conn

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OleDbDataProviderBase Class
OleDbDataProviderBase Members
Overload List
Base Implementation in GetAdapter(IDbConnection)


GetAdapter() Method | fcSDK Documentation

GetAdapter() Method

Syntax

'Declaration

Public Overloads Overrides Function GetAdapter() As DbDataAdapter

public override DbDataAdapter GetAdapter()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OleDbDataProviderBase Class
OleDbDataProviderBase Members
Overload List
Base Implementation in GetAdapter()


GetAdapter(IDbConnection,String) Method | fcSDK Documentation

GetAdapter(IDbConnection,String) Method

Syntax

'Declaration

Public Overloads Overrides Function GetAdapter( _
   ByVal _conn_ As IDbConnection, _
   ByVal _sqlStmt_ As String _
) As DbDataAdapter

public override DbDataAdapter GetAdapter(
   IDbConnection _conn_,
   string _sqlStmt_
)

Parameters

conn

sqlStmt

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OleDbDataProviderBase Class
OleDbDataProviderBase Members
Overload List
Base Implementation in GetAdapter(IDbConnection,String)


GetBitwiseAndStatement Method (OleDbDataProviderBase) | fcSDK Documentation

GetBitwiseAndStatement Method (OleDbDataProviderBase)

Syntax

'Declaration

Public Overrides Function GetBitwiseAndStatement( _
   ByVal _operand1_ As Object, _
   ByVal _operand2_ As Object _
) As String

public override string GetBitwiseAndStatement(
   object _operand1_,
   object _operand2_
)

Parameters

operand1

operand2

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OleDbDataProviderBase Class
OleDbDataProviderBase Members
Base Implementation in GetBitwiseAndStatement


GetConnection Method (OleDbDataProviderBase) | fcSDK Documentation

GetConnection Method (OleDbDataProviderBase)

Overload List

Overload | Description
GetConnection() |
GetConnection(String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OleDbDataProviderBase Class
OleDbDataProviderBase Members
Base Implementation in GetConnection


GetConnection() Method | fcSDK Documentation

GetConnection() Method

Syntax

'Declaration

Public Overloads Overrides Function GetConnection() As IDbConnection

public override IDbConnection GetConnection()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OleDbDataProviderBase Class
OleDbDataProviderBase Members
Overload List
Base Implementation in GetConnection()


GetConnection(String) Method | fcSDK Documentation

GetConnection(String) Method

Syntax

'Declaration

Public Overloads Overrides Function GetConnection( _
   ByVal _newConStr_ As String _
) As IDbConnection

public override IDbConnection GetConnection(
   string _newConStr_
)

Parameters

newConStr

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OleDbDataProviderBase Class
OleDbDataProviderBase Members
Overload List
Base Implementation in GetConnection(String)


GetParameterNamePrefix Method (OleDbDataProviderBase) | fcSDK Documentation

GetParameterNamePrefix Method (OleDbDataProviderBase)

Syntax

'Declaration

Public Overrides Function GetParameterNamePrefix() As String

public override string GetParameterNamePrefix()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OleDbDataProviderBase Class
OleDbDataProviderBase Members
Base Implementation in GetParameterNamePrefix


PrepareSQLStatement Method (OleDbDataProviderBase) | fcSDK Documentation

PrepareSQLStatement Method (OleDbDataProviderBase)

Syntax

'Declaration

Public Overrides Function PrepareSQLStatement( _
   ByVal _sqlStmt_ As String, _
   ByVal _cmdType_ As CommandType, _
   ByVal _commandParams_ As DataParameterCollection _
) As String

public override string PrepareSQLStatement(
   string _sqlStmt_,
   CommandType _cmdType_,
   DataParameterCollection _commandParams_
)

Parameters

sqlStmt

cmdType

commandParams

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OleDbDataProviderBase Class
OleDbDataProviderBase Members
Base Implementation in PrepareSQLStatement


RemoveParameterNamePrefix Method (OleDbDataProviderBase) | fcSDK Documentation

RemoveParameterNamePrefix Method (OleDbDataProviderBase)

Syntax

'Declaration

Public Overrides Function RemoveParameterNamePrefix( _
   ByVal _name_ As String _
) As String

public override string RemoveParameterNamePrefix(
   string _name_
)

Parameters

name

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OleDbDataProviderBase Class
OleDbDataProviderBase Members
Base Implementation in RemoveParameterNamePrefix


ValidateConnectionParams Method (OleDbDataProviderBase) | fcSDK Documentation

ValidateConnectionParams Method (OleDbDataProviderBase)

Syntax

'Declaration

Public Overrides Function ValidateConnectionParams( _
   ByVal _dbServer_ As String, _
   ByVal _dbName_ As String, _
   ByVal _dbUser_ As String, _
   ByVal _dbPass_ As String _
) As Boolean

public override bool ValidateConnectionParams(
   string _dbServer_,
   string _dbName_,
   string _dbUser_,
   string _dbPass_
)

Parameters

dbServer

dbName

dbUser

dbPass

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OleDbDataProviderBase Class
OleDbDataProviderBase Members
Base Implementation in ValidateConnectionParams


OracleProviderBase Class | fcSDK Documentation

OracleProviderBase Class

Abstract base class for Oracle-based data providers

Syntax

'Declaration

Public MustInherit Class OracleProviderBase
   Inherits DbProvider

public abstract class OracleProviderBase : DbProvider

Remarks

Inherit from this class to implement a data provider based on the OracleClient in ADO.NET or other Oracle ADO.NET implementations (such as Oracle's ODP.NET).

Inheritance Hierarchy

System.Object
FChoice.Common.Data.DbProvider
FChoice.Common.Data.OracleProviderBase
FChoice.Common.Data.ODPOracleProvider

Requirements

Namespace: FChoice.Common.Data

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

OracleProviderBase Members
FChoice.Common.Data Namespace


OracleProviderBase Class Members | fcSDK Documentation

OracleProviderBase Class Members

The following tables list the members exposed by OracleProviderBase.

Public Properties

 | Name | Description
Public Property | CanBatchQueries | Specifies whether the underlying database type for this provider can support multiple SQL statements per database round-trip (Inherited from FChoice.Common.Data.DbProvider)
Public Property | ConnectionString | Gets or sets the connection string this provider will use for database connections (Inherited from FChoice.Common.Data.DbProvider)
Public Property | MaxInListItems | Overridden.
Public Property | ProviderName | Overridden.
Public Property | RequiresDbNameParameter | Overridden.
Public Property | TypeMapper | Overridden.

Public Methods

 | Name | Description
Public Method | AreLargeTextFieldsClobs |
Public Method | CreateCommand | (Inherited from FChoice.Common.Data.DbProvider)
Public Method | CreateConnectionString | Overridden.
Public Method | CreateParameter | Overridden.
Public Method | FormatDateLiteral | Overridden.
Public Method | GetAdapter | Overloaded. Overridden.
Public Method | GetAsStatement | Overridden.
Public Method | GetBitwiseAndStatement | Overridden.
Public Method | GetConnection | Overloaded. Overridden.
Public Method | GetDateStatement | Overridden.
Public Method | GetDBDate | Overridden.
Public Method | GetDbVersion | Overloaded. (Inherited from FChoice.Common.Data.DbProvider)
static (Shared in Visual Basic) | GetNlsFormat | Executes a query to retrieve the database user's configured NLS format
Public Method | GetParameterNamePrefix | Overridden.
Public Method | PrepareParameter | Overridden.
Public Method | PrepareSQLStatement | Overridden.
Public Method | RemoveParameterNamePrefix | Overridden.
Public Method | SetDatabaseParameterTypeForClobText | (Inherited from FChoice.Common.Data.DbProvider)
Public Method | TestConnection | Overloaded. (Inherited from FChoice.Common.Data.DbProvider)
Public Method | ValidateConnectionParams | Overridden.

Reference

OracleProviderBase Class
FChoice.Common.Data Namespace


AreLargeTextFieldsClobs Method | fcSDK Documentation

AreLargeTextFieldsClobs Method

Syntax

'Declaration

Public Overridable Function AreLargeTextFieldsClobs() As Boolean

public virtual bool AreLargeTextFieldsClobs()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OracleProviderBase Class
OracleProviderBase Members


CreateConnectionString Method (OracleProviderBase) | fcSDK Documentation

CreateConnectionString Method (OracleProviderBase)

Syntax

'Declaration

Public Overrides Function CreateConnectionString( _
   ByVal _dbServer_ As String, _
   ByVal _dbName_ As String, _
   ByVal _dbUser_ As String, _
   ByVal _dbPass_ As String, _
   ByVal _extraParams_ As String _
) As String

public override string CreateConnectionString(
   string _dbServer_,
   string _dbName_,
   string _dbUser_,
   string _dbPass_,
   string _extraParams_
)

Parameters

dbServer

dbName

dbUser

dbPass

extraParams

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OracleProviderBase Class
OracleProviderBase Members
Base Implementation in CreateConnectionString


CreateParameter Method (OracleProviderBase) | fcSDK Documentation

CreateParameter Method (OracleProviderBase)

Syntax

'Declaration

Public Overrides Function CreateParameter( _
   ByVal _name_ As String, _
   ByVal _value_ As Object _
) As IDbDataParameter

public override IDbDataParameter CreateParameter(
   string _name_,
   object _value_
)

Parameters

name

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OracleProviderBase Class
OracleProviderBase Members
Base Implementation in CreateParameter


FormatDateLiteral Method (OracleProviderBase) | fcSDK Documentation

FormatDateLiteral Method (OracleProviderBase)

Syntax

'Declaration

Public Overrides Function FormatDateLiteral( _
   ByVal _value_ As Date _
) As String

public override string FormatDateLiteral(
   DateTime _value_
)

Parameters

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OracleProviderBase Class
OracleProviderBase Members
Base Implementation in FormatDateLiteral


GetAdapter Method (OracleProviderBase) | fcSDK Documentation

GetAdapter Method (OracleProviderBase)

Overload List

Overload | Description
GetAdapter() |
GetAdapter(IDbConnection) |
GetAdapter(IDbConnection,String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OracleProviderBase Class
OracleProviderBase Members
Base Implementation in GetAdapter


GetAdapter() Method | fcSDK Documentation

GetAdapter() Method

Syntax

'Declaration

Public Overloads Overrides Function GetAdapter() As DbDataAdapter

public override DbDataAdapter GetAdapter()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OracleProviderBase Class
OracleProviderBase Members
Overload List
Base Implementation in GetAdapter()


GetAdapter(IDbConnection) Method | fcSDK Documentation

GetAdapter(IDbConnection) Method

Syntax

'Declaration

Public Overloads Overrides Function GetAdapter( _
   ByVal _conn_ As IDbConnection _
) As DbDataAdapter

public override DbDataAdapter GetAdapter(
   IDbConnection _conn_
)

Parameters

conn

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OracleProviderBase Class
OracleProviderBase Members
Overload List
Base Implementation in GetAdapter(IDbConnection)


GetAdapter(IDbConnection,String) Method | fcSDK Documentation

GetAdapter(IDbConnection,String) Method

Syntax

'Declaration

Public Overloads Overrides Function GetAdapter( _
   ByVal _conn_ As IDbConnection, _
   ByVal _sqlStmt_ As String _
) As DbDataAdapter

public override DbDataAdapter GetAdapter(
   IDbConnection _conn_,
   string _sqlStmt_
)

Parameters

conn

sqlStmt

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OracleProviderBase Class
OracleProviderBase Members
Overload List
Base Implementation in GetAdapter(IDbConnection,String)


GetAsStatement Method (OracleProviderBase) | fcSDK Documentation

GetAsStatement Method (OracleProviderBase)

Syntax

'Declaration

Public Overrides Function GetAsStatement( _
   ByVal _name_ As String _
) As String

public override string GetAsStatement(
   string _name_
)

Parameters

name

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OracleProviderBase Class
OracleProviderBase Members
Base Implementation in GetAsStatement


GetBitwiseAndStatement Method (OracleProviderBase) | fcSDK Documentation

GetBitwiseAndStatement Method (OracleProviderBase)

Syntax

'Declaration

Public Overrides Function GetBitwiseAndStatement( _
   ByVal _operand1_ As Object, _
   ByVal _operand2_ As Object _
) As String

public override string GetBitwiseAndStatement(
   object _operand1_,
   object _operand2_
)

Parameters

operand1

operand2

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OracleProviderBase Class
OracleProviderBase Members
Base Implementation in GetBitwiseAndStatement


GetConnection Method (OracleProviderBase) | fcSDK Documentation

GetConnection Method (OracleProviderBase)

Overload List

Overload | Description
GetConnection() |
GetConnection(String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OracleProviderBase Class
OracleProviderBase Members
Base Implementation in GetConnection


GetConnection() Method | fcSDK Documentation

GetConnection() Method

Syntax

'Declaration

Public Overloads Overrides Function GetConnection() As IDbConnection

public override IDbConnection GetConnection()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OracleProviderBase Class
OracleProviderBase Members
Overload List
Base Implementation in GetConnection()


GetConnection(String) Method | fcSDK Documentation

GetConnection(String) Method

Syntax

'Declaration

Public Overloads Overrides Function GetConnection( _
   ByVal _newConStr_ As String _
) As IDbConnection

public override IDbConnection GetConnection(
   string _newConStr_
)

Parameters

newConStr

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OracleProviderBase Class
OracleProviderBase Members
Overload List
Base Implementation in GetConnection(String)


GetDateStatement Method (OracleProviderBase) | fcSDK Documentation

GetDateStatement Method (OracleProviderBase)

Syntax

'Declaration

Public Overrides Function GetDateStatement() As String

public override string GetDateStatement()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OracleProviderBase Class
OracleProviderBase Members
Base Implementation in GetDateStatement


GetDBDate Method (OracleProviderBase) | fcSDK Documentation

GetDBDate Method (OracleProviderBase)

Syntax

'Declaration

Public Overrides Function GetDBDate() As Date

public override DateTime GetDBDate()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OracleProviderBase Class
OracleProviderBase Members
Base Implementation in GetDBDate


GetNlsFormat Method | fcSDK Documentation

GetNlsFormat Method

An instance of an OracleProviderBase implementation that will be used for connecting to the database and retrieving the NLS format.

Executes a query to retrieve the database user's configured NLS format

Syntax

'Declaration

Public Shared Function GetNlsFormat( _
   ByVal _provider_ As OracleProviderBase _
) As String

public static string GetNlsFormat(
   OracleProviderBase _provider_
)

Parameters

provider

An instance of an OracleProviderBase implementation that will be used for connecting to the database and retrieving the NLS format.

Return Value

The NLS format string

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OracleProviderBase Class
OracleProviderBase Members


GetParameterNamePrefix Method (OracleProviderBase) | fcSDK Documentation

GetParameterNamePrefix Method (OracleProviderBase)

Syntax

'Declaration

Public Overrides Function GetParameterNamePrefix() As String

public override string GetParameterNamePrefix()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OracleProviderBase Class
OracleProviderBase Members
Base Implementation in GetParameterNamePrefix


PrepareParameter Method (OracleProviderBase) | fcSDK Documentation

PrepareParameter Method (OracleProviderBase)

Syntax

'Declaration

Public Overrides Sub PrepareParameter( _
   ByVal _param_ As IDbDataParameter, _
   ByVal _cmdType_ As CommandType _
)

public override void PrepareParameter(
   IDbDataParameter _param_,
   CommandType _cmdType_
)

Parameters

param

cmdType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OracleProviderBase Class
OracleProviderBase Members
Base Implementation in PrepareParameter


PrepareSQLStatement Method (OracleProviderBase) | fcSDK Documentation

PrepareSQLStatement Method (OracleProviderBase)

Syntax

'Declaration

Public Overrides Function PrepareSQLStatement( _
   ByVal _sqlStmt_ As String, _
   ByVal _cmdType_ As CommandType, _
   ByVal _commandParams_ As DataParameterCollection _
) As String

public override string PrepareSQLStatement(
   string _sqlStmt_,
   CommandType _cmdType_,
   DataParameterCollection _commandParams_
)

Parameters

sqlStmt

cmdType

commandParams

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OracleProviderBase Class
OracleProviderBase Members
Base Implementation in PrepareSQLStatement


RemoveParameterNamePrefix Method (OracleProviderBase) | fcSDK Documentation

RemoveParameterNamePrefix Method (OracleProviderBase)

Syntax

'Declaration

Public Overrides Function RemoveParameterNamePrefix( _
   ByVal _name_ As String _
) As String

public override string RemoveParameterNamePrefix(
   string _name_
)

Parameters

name

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OracleProviderBase Class
OracleProviderBase Members
Base Implementation in RemoveParameterNamePrefix


ValidateConnectionParams Method (OracleProviderBase) | fcSDK Documentation

ValidateConnectionParams Method (OracleProviderBase)

Syntax

'Declaration

Public Overrides Function ValidateConnectionParams( _
   ByVal _dbServer_ As String, _
   ByVal _dbName_ As String, _
   ByVal _dbUser_ As String, _
   ByVal _dbPass_ As String _
) As Boolean

public override bool ValidateConnectionParams(
   string _dbServer_,
   string _dbName_,
   string _dbUser_,
   string _dbPass_
)

Parameters

dbServer

dbName

dbUser

dbPass

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OracleProviderBase Class
OracleProviderBase Members
Base Implementation in ValidateConnectionParams


MaxInListItems Property (OracleProviderBase) | fcSDK Documentation

MaxInListItems Property (OracleProviderBase)

Syntax

'Declaration

Public Overrides ReadOnly Property MaxInListItems As Integer

public override int MaxInListItems {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OracleProviderBase Class
OracleProviderBase Members
Base Implementation in MaxInListItems


ProviderName Property (OracleProviderBase) | fcSDK Documentation

ProviderName Property (OracleProviderBase)

Syntax

'Declaration

Public Overrides ReadOnly Property ProviderName As String

public override string ProviderName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OracleProviderBase Class
OracleProviderBase Members
Base Implementation in ProviderName


RequiresDbNameParameter Property (OracleProviderBase) | fcSDK Documentation

RequiresDbNameParameter Property (OracleProviderBase)

Syntax

'Declaration

Public Overrides ReadOnly Property RequiresDbNameParameter As Boolean

public override bool RequiresDbNameParameter {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OracleProviderBase Class
OracleProviderBase Members
Base Implementation in RequiresDbNameParameter


TypeMapper Property (OracleProviderBase) | fcSDK Documentation

TypeMapper Property (OracleProviderBase)

Syntax

'Declaration

Public Overrides ReadOnly Property TypeMapper As TypeMapper

public override TypeMapper TypeMapper {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OracleProviderBase Class
OracleProviderBase Members
Base Implementation in TypeMapper


SqlHelper Class | fcSDK Documentation

SqlHelper Class

Provides a convenience and data provider-agnostic wrapper around ADO.NET

Syntax

'Declaration

Public Class SqlHelper

public class SqlHelper

Remarks

SqlHelper can be used either as an instance or statically.

When used statically, SqlHelper is thread safe. Concurrent threads can call the same method at the same time and will experience no ill-effect.

When used as an instance, however, SqlHelper is NOT thread safe. Multiple threads should not use the same instance of SqlHelper.

Inheritance Hierarchy

System.Object
FChoice.Common.Data.SqlHelper

Requirements

Namespace: FChoice.Common.Data

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

SqlHelper Members
FChoice.Common.Data Namespace


SqlHelper Class Members | fcSDK Documentation

SqlHelper Class Members

The following tables list the members exposed by SqlHelper.

Public Constructors

 | Name | Description
Public Constructor | SqlHelper Constructor | Overloaded.

Public Fields

 | Name | Description
Public Field | IN_LIST_TOKEN |

Public Properties

 | Name | Description
Public Property | CommandText |
Public Property | CommandType |
Public Property | Connection |
Public Property | DataProvider |
static (Shared in Visual Basic) | Log |
Public Property | Parameters |
Public Property | Transaction |

Public Methods

 | Name | Description
Public Method | ExecuteDataSet | Overloaded. Executes the the SQL specified in the CommandText Property against the database using the provider specified in the DataProvider Property and returns the results as a DataSet
Public Method | ExecuteDataSetInList | Executes a specially formatted SQL statement specified in the CommandText Property
Public Method | ExecuteNonQuery | Overloaded.
Public Method | ExecuteNonQueryInList |
Public Method | ExecuteReader | Overloaded.
Public Method | ExecuteReaderInList |
Public Method | ExecuteScalar | Overloaded.
Public Method | ExecuteScalarInList |
Public Method | FillDataSet | Overloaded.
Public Method | FillDataSetInList | Overloaded.
static (Shared in Visual Basic) | FillDataSetRaw | Overloaded.
static (Shared in Visual Basic) | GetTableAsDataSet | Overloaded.
Public Method | PrepareInListStatement | Overloaded.
Public Method | PrepareIntegerListStatement |

Reference

SqlHelper Class
FChoice.Common.Data Namespace


SqlHelper Constructor | fcSDK Documentation

SqlHelper Constructor

Creates a new instance of SqlHelper with optional initialization parameters

Overload List

Overload | Description
SqlHelper Constructor() | Creates a new instance of SqlHelper using the default DbProvider instance
SqlHelper Constructor(DbProvider) | Creates a new instance of SqlHelper with the specified DbProvider instance
SqlHelper Constructor(String) | Creates a new instance of SqlHelper using the specified command text (SQL statement) with the CommandType set to Text
SqlHelper Constructor(CommandType,String) | Creates a new instance of SqlHelper with the specified CommandType and command text (SQL statement)
SqlHelper Constructor(DbProvider,String) | Creates a new instance of SqlHelper using the specified DbProvider instance and command text (SQL statement) and the CommandType set to Text
SqlHelper Constructor(DbProvider,CommandType,String) | Creates a new instance of SqlHelper with the specified DbProvider instance, CommandType and command text (SQL statement)

Remarks

All of the optional arguments passed into the constructor can be changed later using the similarly named properties on the SqlHelper instance. These constructor overloads are provided simply for convenience.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members


SqlHelper Constructor() | fcSDK Documentation

SqlHelper Constructor()

Creates a new instance of SqlHelper using the default DbProvider instance

Syntax

'Declaration

Public Function New()

public SqlHelper()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


SqlHelper Constructor(DbProvider) | fcSDK Documentation

SqlHelper Constructor(DbProvider)

The specific DbProvider instance that this instance of SqlHelper should use when performing database operations

Creates a new instance of SqlHelper with the specified DbProvider instance

Syntax

'Declaration

Public Function New( _
   ByVal _dataProvider_ As DbProvider _
)

public SqlHelper(
   DbProvider _dataProvider_
)

Parameters

dataProvider

The specific DbProvider instance that this instance of SqlHelper should use when performing database operations

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


SqlHelper Constructor(String) | fcSDK Documentation

SqlHelper Constructor(String)

The text command to execute. The default value is an empty string ("").

Creates a new instance of SqlHelper using the specified command text (SQL statement) with the CommandType set to Text

Syntax

'Declaration

Public Function New( _
   ByVal _cmdTxt_ As String _
)

public SqlHelper(
   string _cmdTxt_
)

Parameters

cmdTxt

The text command to execute. The default value is an empty string ("").

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


SqlHelper Constructor(CommandType,String) | fcSDK Documentation

SqlHelper Constructor(CommandType,String)

The CommandType this instance of SqlHelper should use when executing the cmdTxt statement.

The text command to execute. The default value is an empty string ("").

Creates a new instance of SqlHelper with the specified CommandType and command text (SQL statement)

Syntax

'Declaration

Public Function New( _
   ByVal _inCmdType_ As CommandType, _
   ByVal _cmdTxt_ As String _
)

public SqlHelper(
   CommandType _inCmdType_,
   string _cmdTxt_
)

Parameters

inCmdType

The CommandType this instance of SqlHelper should use when executing the cmdTxt statement.

cmdTxt

The text command to execute. The default value is an empty string ("").

Remarks

When the inCmdType parameter is set to StoredProcedure, set the cmdText parameter to the name of the stored procedure. The user may be required to use escape character syntax if the stored procedure name contains any special characters. The command will call this stored procedure when you call one of the Execute methods.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


SqlHelper Constructor(DbProvider,String) | fcSDK Documentation

SqlHelper Constructor(DbProvider,String)

The specific DbProvider instance that this instance of SqlHelper should use when performing database operations

The text command to execute. The default value is an empty string ("").

Creates a new instance of SqlHelper using the specified DbProvider instance and command text (SQL statement) and the CommandType set to Text

Syntax

'Declaration

Public Function New( _
   ByVal _dataProvider_ As DbProvider, _
   ByVal _cmdTxt_ As String _
)

public SqlHelper(
   DbProvider _dataProvider_,
   string _cmdTxt_
)

Parameters

dataProvider

The specific DbProvider instance that this instance of SqlHelper should use when performing database operations

cmdTxt

The text command to execute. The default value is an empty string ("").

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


SqlHelper Constructor(DbProvider,CommandType,String) | fcSDK Documentation

SqlHelper Constructor(DbProvider,CommandType,String)

The specific DbProvider instance that this instance of SqlHelper should use when performing database operations

The CommandType this instance of SqlHelper should use when executing the cmdTxt statement.

The text command to execute. The default value is an empty string ("").

Creates a new instance of SqlHelper with the specified DbProvider instance, CommandType and command text (SQL statement)

Syntax

'Declaration

Public Function New( _
   ByVal _dataProvider_ As DbProvider, _
   ByVal _inCmdType_ As CommandType, _
   ByVal _cmdTxt_ As String _
)

public SqlHelper(
   DbProvider _dataProvider_,
   CommandType _inCmdType_,
   string _cmdTxt_
)

Parameters

dataProvider

The specific DbProvider instance that this instance of SqlHelper should use when performing database operations

inCmdType

The CommandType this instance of SqlHelper should use when executing the cmdTxt statement.

cmdTxt

The text command to execute. The default value is an empty string ("").

Remarks

When the inCmdType parameter is set to StoredProcedure, set the cmdTxt parameter to the name of the stored procedure. The user may be required to use escape character syntax if the stored procedure name contains any special characters. The command will call this stored procedure when you call one of the Execute methods.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


ExecuteDataSet Method | fcSDK Documentation

ExecuteDataSet Method

Overload List

Overload | Description
ExecuteDataSet() | Executes the the SQL specified in the CommandText Property against the database using the provider specified in the DataProvider Property and returns the results as a DataSet
ExecuteDataSet(String) | Executes the the specified SQL using the default DbProvider and returns the results as a DataSet
ExecuteDataSet(CommandType,String) | Executes the the specified SQL against the database using the default DbProvider and returns the results as a DataSet
ExecuteDataSet(CommandType,String,DataParameterCollection) | Executes the the specified parameterized SQL command with the specified parameters against the database using the default DbProvider and returns the results as a DataSet
ExecuteDataSet(IDbConnection,CommandType,String) | Executes the the specified SQL using the provided database connection and returns the results as a DataSet
ExecuteDataSet(IDbConnection,CommandType,String,DataParameterCollection) | Executes the the specified parameterized SQL with the specified parameters using the provided database connection and returns the results as a DataSet
ExecuteDataSet(IDbTransaction,CommandType,String) | Executes the the specified SQL using the provided database transaction and returns the results as a DataSet
ExecuteDataSet(IDbTransaction,CommandType,String,DataParameterCollection) | Executes the the specified SQL with the specified parameters using the provided database transaction and returns the results as a DataSet

Remarks

Not all providers return a DataSet with the same structure if no results are returned by the query. Some providers return an empty DataSet. Some providers return a DataSet with a single DataTable which contains zero rows. Test for tables and rows using the Count property on the DataSet and any DataTables before assuming any Tables or Rows exist.

In no case will the DataSet returned be a null reference (Nothing in Visual Basic).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class SqlHelper Members


ExecuteDataSet() Method | fcSDK Documentation

ExecuteDataSet() Method

Executes the the SQL specified in the CommandText Property against the database using the provider specified in the DataProvider Property and returns the results as a DataSet

Syntax

'Declaration

Public Overloads Function ExecuteDataSet() As DataSet

public DataSet ExecuteDataSet()

Return Value

A DataSet with zero or more DataTable objects each containing zero or more rows.

Remarks

Not all providers return a DataSet with the same structure if no results are returned by the query. Some providers return an empty DataSet. Some providers return a DataSet with a single DataTable which contains zero rows. Test for tables and rows using the Count property on the DataSet and any DataTables before assuming any Tables or Rows exist.

In no case will the DataSet returned be a null reference (Nothing in Visual Basic).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


ExecuteDataSet(String) Method | fcSDK Documentation

ExecuteDataSet(String) Method

The text command to execute. The default value is an empty string ("").

Executes the the specified SQL using the default DbProvider and returns the results as a DataSet

Syntax

'Declaration

Public Overloads Shared Function ExecuteDataSet( _
   ByVal _commandText_ As String _
) As DataSet

public static DataSet ExecuteDataSet(
   string _commandText_
)

Parameters

commandText

The text command to execute. The default value is an empty string ("").

Return Value

A DataSet with zero or more DataTable objects each containing zero or more rows.

Remarks

Not all providers return a DataSet with the same structure if no results are returned by the query. Some providers return an empty DataSet. Some providers return a DataSet with a single DataTable which contains zero rows. Test for tables and rows using the Count property on the DataSet and any DataTables before assuming any Tables or Rows exist.

In no case will the DataSet returned be a null reference (Nothing in Visual Basic).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


ExecuteDataSet(CommandType,String) Method | fcSDK Documentation

ExecuteDataSet(CommandType,String) Method

The CommandType to use when executing the commandText statement.

The text command to execute. The default value is an empty string ("").

Executes the the specified SQL against the database using the default DbProvider and returns the results as a DataSet

Syntax

'Declaration

Public Overloads Shared Function ExecuteDataSet( _
   ByVal _commandType_ As CommandType, _
   ByVal _commandText_ As String _
) As DataSet

public static DataSet ExecuteDataSet(
   CommandType _commandType_,
   string _commandText_
)

Parameters

commandType

The CommandType to use when executing the commandText statement.

commandText

The text command to execute. The default value is an empty string ("").

Return Value

A DataSet with zero or more DataTable objects each containing zero or more rows.

Remarks

Not all providers return a DataSet with the same structure if no results are returned by the query. Some providers return an empty DataSet. Some providers return a DataSet with a single DataTable which contains zero rows. Test for tables and rows using the Count property on the DataSet and any DataTables before assuming any Tables or Rows exist.

In no case will the DataSet returned be a null reference (Nothing in Visual Basic).

When the commandType parameter is set to StoredProcedure, set the commandText parameter to the name of the stored procedure. The user may be required to use escape character syntax if the stored procedure name contains any special characters. The command will call this stored procedure when you call one of the Execute methods.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


ExecuteDataSet(CommandType,String,DataParameterCollection) Method | fcSDK Documentation

ExecuteDataSet(CommandType,String,DataParameterCollection) Method

The CommandType to use when executing the commandText statement.

The text command to execute. The default value is an empty string ("").

A collection of parameters to use as replacements for the parameterized sections of the commandText

Executes the the specified parameterized SQL command with the specified parameters against the database using the default DbProvider and returns the results as a DataSet

Syntax

'Declaration

Public Overloads Shared Function ExecuteDataSet( _
   ByVal _commandType_ As CommandType, _
   ByVal _commandText_ As String, _
   ByVal _commandParams_ As DataParameterCollection _
) As DataSet

public static DataSet ExecuteDataSet(
   CommandType _commandType_,
   string _commandText_,
   DataParameterCollection _commandParams_
)

Parameters

commandType

The CommandType to use when executing the commandText statement.

commandText

The text command to execute. The default value is an empty string ("").

commandParams

A collection of parameters to use as replacements for the parameterized sections of the commandText

Return Value

A DataSet with zero or more DataTable objects each containing zero or more rows.

Remarks

The parameters in the commandParams parameter must be in the same ordinal number as the parameters specified in the commandText parameter. For example, if the "nameVal" parameter is to replace the {0} parameter in the commandText, it must be the first (zero position) parameter in the commandParams collection.

Not all providers return a DataSet with the same structure if no results are returned by the query. Some providers return an empty DataSet. Some providers return a DataSet with a single DataTable which contains zero rows. Test for tables and rows using the Count property on the DataSet and any DataTables before assuming any Tables or Rows exist.

In no case will the DataSet returned be a null reference (Nothing in Visual Basic).

When the commandType parameter is set to StoredProcedure, set the commandText parameter to the name of the stored procedure. The user may be required to use escape character syntax if the stored procedure name contains any special characters. The command will call this stored procedure when you call one of the Execute methods.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


ExecuteDataSet(IDbConnection,CommandType,String) Method | fcSDK Documentation

ExecuteDataSet(IDbConnection,CommandType,String) Method

A configured connection to the database

The CommandType to use when executing the commandText statement.

The text command to execute. The default value is an empty string ("").

Executes the the specified SQL using the provided database connection and returns the results as a DataSet

Syntax

'Declaration

Public Overloads Shared Function ExecuteDataSet( _
   ByVal _connection_ As IDbConnection, _
   ByVal _commandType_ As CommandType, _
   ByVal _commandText_ As String _
) As DataSet

public static DataSet ExecuteDataSet(
   IDbConnection _connection_,
   CommandType _commandType_,
   string _commandText_
)

Parameters

connection

A configured connection to the database

commandType

The CommandType to use when executing the commandText statement.

commandText

The text command to execute. The default value is an empty string ("").

Return Value

A DataSet with zero or more DataTable objects each containing zero or more rows.

Remarks

The connection parameter is not required to be an open connection. If it is not open when passed to this method, it will be opened and will be closed when the method is finished. If it is passed in open, or live, it will remain open when this method completes.

Not all providers return a DataSet with the same structure if no results are returned by the query. Some providers return an empty DataSet. Some providers return a DataSet with a single DataTable which contains zero rows. Test for tables and rows using the Count property on the DataSet and any DataTables before assuming any Tables or Rows exist.

In no case will the DataSet returned be a null reference (Nothing in Visual Basic).

When the commandType parameter is set to StoredProcedure, set the commandText parameter to the name of the stored procedure. The user may be required to use escape character syntax if the stored procedure name contains any special characters. The command will call this stored procedure when you call one of the Execute methods.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


ExecuteDataSet(IDbConnection,CommandType,String,DataParameterCollection) Method | fcSDK Documentation

ExecuteDataSet(IDbConnection,CommandType,String,DataParameterCollection) Method

A configured connection to the database

The CommandType to use when executing the commandText statement.

The text command to execute. The default value is an empty string ("").

A collection of parameters to use as replacements for the parameterized sections of the commandText

Executes the the specified parameterized SQL with the specified parameters using the provided database connection and returns the results as a DataSet

Syntax

'Declaration

Public Overloads Shared Function ExecuteDataSet( _
   ByVal _connection_ As IDbConnection, _
   ByVal _commandType_ As CommandType, _
   ByVal _commandText_ As String, _
   ByVal _commandParams_ As DataParameterCollection _
) As DataSet

public static DataSet ExecuteDataSet(
   IDbConnection _connection_,
   CommandType _commandType_,
   string _commandText_,
   DataParameterCollection _commandParams_
)

Parameters

connection

A configured connection to the database

commandType

The CommandType to use when executing the commandText statement.

commandText

The text command to execute. The default value is an empty string ("").

commandParams

A collection of parameters to use as replacements for the parameterized sections of the commandText

Return Value

A DataSet with zero or more DataTable objects each containing zero or more rows.

Remarks

The connection parameter is not required to be an open connection. If it is not open when passed to this method, it will be opened and will be closed when the method is finished. If it is passed in open, or live, it will remain open when this method completes.

The parameters in the commandParams parameter must be in the same ordinal number as the parameters specified in the commandText parameter. For example, if the "nameVal" parameter is to replace the {0} parameter in the commandText, it must be the first (zero position) parameter in the commandParams collection.

Not all providers return a DataSet with the same structure if no results are returned by the query. Some providers return an empty DataSet. Some providers return a DataSet with a single DataTable which contains zero rows. Test for tables and rows using the Count property on the DataSet and any DataTables before assuming any Tables or Rows exist.

In no case will the DataSet returned be a null reference (Nothing in Visual Basic).

When the commandType parameter is set to StoredProcedure, set the commandText parameter to the name of the stored procedure. The user may be required to use escape character syntax if the stored procedure name contains any special characters. The command will call this stored procedure when you call one of the Execute methods.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


ExecuteDataSet(IDbTransaction,CommandType,String) Method | fcSDK Documentation

ExecuteDataSet(IDbTransaction,CommandType,String) Method

A live transaction connected to the database

The CommandType to use when executing the commandText statement.

The text command to execute. The default value is an empty string ("").

Executes the the specified SQL using the provided database transaction and returns the results as a DataSet

Syntax

'Declaration

Public Overloads Shared Function ExecuteDataSet( _
   ByVal _transaction_ As IDbTransaction, _
   ByVal _commandType_ As CommandType, _
   ByVal _commandText_ As String _
) As DataSet

public static DataSet ExecuteDataSet(
   IDbTransaction _transaction_,
   CommandType _commandType_,
   string _commandText_
)

Parameters

transaction

A live transaction connected to the database

commandType

The CommandType to use when executing the commandText statement.

commandText

The text command to execute. The default value is an empty string ("").

Return Value

A DataSet with zero or more DataTable objects each containing zero or more rows.

Remarks

The transaction parameter must be an open and live transaction. After the call to this method, the transaction will remain live and open.

Not all providers return a DataSet with the same structure if no results are returned by the query. Some providers return an empty DataSet. Some providers return a DataSet with a single DataTable which contains zero rows. Test for tables and rows using the Count property on the DataSet and any DataTables before assuming any Tables or Rows exist.

In no case will the DataSet returned be a null reference (Nothing in Visual Basic).

When the commandType parameter is set to StoredProcedure, set the commandText parameter to the name of the stored procedure. The user may be required to use escape character syntax if the stored procedure name contains any special characters. The command will call this stored procedure when you call one of the Execute methods.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


ExecuteDataSet(IDbTransaction,CommandType,String,DataParameterCollection) Method | fcSDK Documentation

ExecuteDataSet(IDbTransaction,CommandType,String,DataParameterCollection) Method

A live transaction connected to the database

The CommandType to use when executing the commandText statement.

The text command to execute. The default value is an empty string ("").

A collection of parameters to use as replacements for the parameterized sections of the commandText

Executes the the specified SQL with the specified parameters using the provided database transaction and returns the results as a DataSet

Syntax

'Declaration

Public Overloads Shared Function ExecuteDataSet( _
   ByVal _transaction_ As IDbTransaction, _
   ByVal _commandType_ As CommandType, _
   ByVal _commandText_ As String, _
   ByVal _commandParams_ As DataParameterCollection _
) As DataSet

public static DataSet ExecuteDataSet(
   IDbTransaction _transaction_,
   CommandType _commandType_,
   string _commandText_,
   DataParameterCollection _commandParams_
)

Parameters

transaction

A live transaction connected to the database

commandType

The CommandType to use when executing the commandText statement.

commandText

The text command to execute. The default value is an empty string ("").

commandParams

A collection of parameters to use as replacements for the parameterized sections of the commandText

Return Value

A DataSet with zero or more DataTable objects each containing zero or more rows.

Remarks

The transaction parameter must be an open and live transaction. After the call to this method, the transaction will remain live and open.

The parameters in the commandParams parameter must be in the same ordinal number as the parameters specified in the commandText parameter. For example, if the "nameVal" parameter is to replace the {0} parameter in the commandText, it must be the first (zero position) parameter in the commandParams collection.

Not all providers return a DataSet with the same structure if no results are returned by the query. Some providers return an empty DataSet. Some providers return a DataSet with a single DataTable which contains zero rows. Test for tables and rows using the Count property on the DataSet and any DataTables before assuming any Tables or Rows exist.

In no case will the DataSet returned be a null reference (Nothing in Visual Basic).

When the commandType parameter is set to StoredProcedure, set the commandText parameter to the name of the stored procedure. The user may be required to use escape character syntax if the stored procedure name contains any special characters. The command will call this stored procedure when you call one of the Execute methods.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


ExecuteDataSetInList Method | fcSDK Documentation

ExecuteDataSetInList Method

Executes a specially formatted SQL statement specified in the CommandText Property

Syntax

'Declaration

Public Function ExecuteDataSetInList( _
   ByVal _inList_() As Object, _
   ByVal _columnName_ As String _
) As DataSet

public DataSet ExecuteDataSetInList(
   object\[\] _inList_,
   string _columnName_
)

Parameters

inList

columnName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members


ExecuteNonQuery Method | fcSDK Documentation

ExecuteNonQuery Method

Overload List

Overload | Description
ExecuteNonQuery() |
ExecuteNonQuery(String) |
ExecuteNonQuery(CommandType,String) |
ExecuteNonQuery(CommandType,String,DataParameterCollection) |
ExecuteNonQuery(IDbConnection,CommandType,String) |
ExecuteNonQuery(IDbConnection,CommandType,String,DataParameterCollection) |
ExecuteNonQuery(IDbTransaction,CommandType,String) |
ExecuteNonQuery(IDbTransaction,CommandType,String,DataParameterCollection) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members


ExecuteNonQuery() Method | fcSDK Documentation

ExecuteNonQuery() Method

Syntax

'Declaration

Public Overloads Function ExecuteNonQuery() As Integer

public int ExecuteNonQuery()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


ExecuteNonQuery(String) Method | fcSDK Documentation

ExecuteNonQuery(String) Method

Syntax

'Declaration

Public Overloads Shared Function ExecuteNonQuery( _
   ByVal _commandText_ As String _
) As Integer

public static int ExecuteNonQuery(
   string _commandText_
)

Parameters

commandText

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


ExecuteNonQuery(CommandType,String) Method | fcSDK Documentation

ExecuteNonQuery(CommandType,String) Method

Syntax

'Declaration

Public Overloads Shared Function ExecuteNonQuery( _
   ByVal _commandType_ As CommandType, _
   ByVal _commandText_ As String _
) As Integer

public static int ExecuteNonQuery(
   CommandType _commandType_,
   string _commandText_
)

Parameters

commandType

commandText

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


ExecuteNonQuery(CommandType,String,DataParameterCollection) Method | fcSDK Documentation

ExecuteNonQuery(CommandType,String,DataParameterCollection) Method

Syntax

'Declaration

Public Overloads Shared Function ExecuteNonQuery( _
   ByVal _commandType_ As CommandType, _
   ByVal _commandText_ As String, _
   ByVal _commandParams_ As DataParameterCollection _
) As Integer

public static int ExecuteNonQuery(
   CommandType _commandType_,
   string _commandText_,
   DataParameterCollection _commandParams_
)

Parameters

commandType

commandText

commandParams

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


ExecuteNonQuery(IDbConnection,CommandType,String) Method | fcSDK Documentation

ExecuteNonQuery(IDbConnection,CommandType,String) Method

Syntax

'Declaration

Public Overloads Shared Function ExecuteNonQuery( _
   ByVal _connection_ As IDbConnection, _
   ByVal _commandType_ As CommandType, _
   ByVal _commandText_ As String _
) As Integer

public static int ExecuteNonQuery(
   IDbConnection _connection_,
   CommandType _commandType_,
   string _commandText_
)

Parameters

connection

commandType

commandText

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


ExecuteNonQuery(IDbConnection,CommandType,String,DataParameterCollection) Method | fcSDK Documentation

ExecuteNonQuery(IDbConnection,CommandType,String,DataParameterCollection) Method

Syntax

'Declaration

Public Overloads Shared Function ExecuteNonQuery( _
   ByVal _connection_ As IDbConnection, _
   ByVal _commandType_ As CommandType, _
   ByVal _commandText_ As String, _
   ByVal _commandParams_ As DataParameterCollection _
) As Integer

public static int ExecuteNonQuery(
   IDbConnection _connection_,
   CommandType _commandType_,
   string _commandText_,
   DataParameterCollection _commandParams_
)

Parameters

connection

commandType

commandText

commandParams

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


ExecuteNonQuery(IDbTransaction,CommandType,String) Method | fcSDK Documentation

ExecuteNonQuery(IDbTransaction,CommandType,String) Method

Syntax

'Declaration

Public Overloads Shared Function ExecuteNonQuery( _
   ByVal _transaction_ As IDbTransaction, _
   ByVal _commandType_ As CommandType, _
   ByVal _commandText_ As String _
) As Integer

public static int ExecuteNonQuery(
   IDbTransaction _transaction_,
   CommandType _commandType_,
   string _commandText_
)

Parameters

transaction

commandType

commandText

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


ExecuteNonQuery(IDbTransaction,CommandType,String,DataParameterCollection) Method | fcSDK Documentation

ExecuteNonQuery(IDbTransaction,CommandType,String,DataParameterCollection) Method

Syntax

'Declaration

Public Overloads Shared Function ExecuteNonQuery( _
   ByVal _transaction_ As IDbTransaction, _
   ByVal _commandType_ As CommandType, _
   ByVal _commandText_ As String, _
   ByVal _commandParams_ As DataParameterCollection _
) As Integer

public static int ExecuteNonQuery(
   IDbTransaction _transaction_,
   CommandType _commandType_,
   string _commandText_,
   DataParameterCollection _commandParams_
)

Parameters

transaction

commandType

commandText

commandParams

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


ExecuteNonQueryInList Method | fcSDK Documentation

ExecuteNonQueryInList Method

Syntax

'Declaration

Public Function ExecuteNonQueryInList( _
   ByVal _inList_() As Object, _
   ByVal _columnName_ As String _
) As Integer

public int ExecuteNonQueryInList(
   object\[\] _inList_,
   string _columnName_
)

Parameters

inList

columnName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members


ExecuteReader Method | fcSDK Documentation

ExecuteReader Method

Overload List

Overload | Description
ExecuteReader() |
ExecuteReader(String) |
ExecuteReader(CommandType,String) |
ExecuteReader(CommandType,String,DataParameterCollection) |
ExecuteReader(IDbConnection,CommandType,String) |
ExecuteReader(IDbConnection,CommandType,String,DataParameterCollection) |
ExecuteReader(IDbTransaction,CommandType,String) |
ExecuteReader(IDbTransaction,CommandType,String,DataParameterCollection) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members


ExecuteReader() Method | fcSDK Documentation

ExecuteReader() Method

Syntax

'Declaration

Public Overloads Function ExecuteReader() As IDataReader

public IDataReader ExecuteReader()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


ExecuteReader(String) Method | fcSDK Documentation

ExecuteReader(String) Method

Syntax

'Declaration

Public Overloads Shared Function ExecuteReader( _
   ByVal _commandText_ As String _
) As IDataReader

public static IDataReader ExecuteReader(
   string _commandText_
)

Parameters

commandText

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


ExecuteReader(CommandType,String) Method | fcSDK Documentation

ExecuteReader(CommandType,String) Method

Syntax

'Declaration

Public Overloads Shared Function ExecuteReader( _
   ByVal _commandType_ As CommandType, _
   ByVal _commandText_ As String _
) As IDataReader

public static IDataReader ExecuteReader(
   CommandType _commandType_,
   string _commandText_
)

Parameters

commandType

commandText

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


ExecuteReader(CommandType,String,DataParameterCollection) Method | fcSDK Documentation

ExecuteReader(CommandType,String,DataParameterCollection) Method

Syntax

'Declaration

Public Overloads Shared Function ExecuteReader( _
   ByVal _commandType_ As CommandType, _
   ByVal _commandText_ As String, _
   ByVal _commandParams_ As DataParameterCollection _
) As IDataReader

public static IDataReader ExecuteReader(
   CommandType _commandType_,
   string _commandText_,
   DataParameterCollection _commandParams_
)

Parameters

commandType

commandText

commandParams

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


ExecuteReader(IDbConnection,CommandType,String) Method | fcSDK Documentation

ExecuteReader(IDbConnection,CommandType,String) Method

Syntax

'Declaration

Public Overloads Shared Function ExecuteReader( _
   ByVal _connection_ As IDbConnection, _
   ByVal _commandType_ As CommandType, _
   ByVal _commandText_ As String _
) As IDataReader

public static IDataReader ExecuteReader(
   IDbConnection _connection_,
   CommandType _commandType_,
   string _commandText_
)

Parameters

connection

commandType

commandText

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


ExecuteReader(IDbConnection,CommandType,String,DataParameterCollection) Method | fcSDK Documentation

ExecuteReader(IDbConnection,CommandType,String,DataParameterCollection) Method

Syntax

'Declaration

Public Overloads Shared Function ExecuteReader( _
   ByVal _connection_ As IDbConnection, _
   ByVal _commandType_ As CommandType, _
   ByVal _commandText_ As String, _
   ByVal _commandParams_ As DataParameterCollection _
) As IDataReader

public static IDataReader ExecuteReader(
   IDbConnection _connection_,
   CommandType _commandType_,
   string _commandText_,
   DataParameterCollection _commandParams_
)

Parameters

connection

commandType

commandText

commandParams

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


ExecuteReader(IDbTransaction,CommandType,String) Method | fcSDK Documentation

ExecuteReader(IDbTransaction,CommandType,String) Method

Syntax

'Declaration

Public Overloads Shared Function ExecuteReader( _
   ByVal _transaction_ As IDbTransaction, _
   ByVal _commandType_ As CommandType, _
   ByVal _commandText_ As String _
) As IDataReader

public static IDataReader ExecuteReader(
   IDbTransaction _transaction_,
   CommandType _commandType_,
   string _commandText_
)

Parameters

transaction

commandType

commandText

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


ExecuteReader(IDbTransaction,CommandType,String,DataParameterCollection) Method | fcSDK Documentation

ExecuteReader(IDbTransaction,CommandType,String,DataParameterCollection) Method

Syntax

'Declaration

Public Overloads Shared Function ExecuteReader( _
   ByVal _transaction_ As IDbTransaction, _
   ByVal _commandType_ As CommandType, _
   ByVal _commandText_ As String, _
   ByVal _commandParams_ As DataParameterCollection _
) As IDataReader

public static IDataReader ExecuteReader(
   IDbTransaction _transaction_,
   CommandType _commandType_,
   string _commandText_,
   DataParameterCollection _commandParams_
)

Parameters

transaction

commandType

commandText

commandParams

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


ExecuteReaderInList Method | fcSDK Documentation

ExecuteReaderInList Method

Syntax

'Declaration

Public Function ExecuteReaderInList( _
   ByVal _inList_() As Object, _
   ByVal _columnName_ As String _
) As IDataReader

public IDataReader ExecuteReaderInList(
   object\[\] _inList_,
   string _columnName_
)

Parameters

inList

columnName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members


ExecuteScalar Method | fcSDK Documentation

ExecuteScalar Method

Overload List

Overload | Description
ExecuteScalar() |
ExecuteScalar(String) |
ExecuteScalar(CommandType,String) |
ExecuteScalar(CommandType,String,DataParameterCollection) |
ExecuteScalar(IDbConnection,CommandType,String) |
ExecuteScalar(IDbConnection,CommandType,String,DataParameterCollection) |
ExecuteScalar(IDbTransaction,CommandType,String) |
ExecuteScalar(IDbTransaction,CommandType,String,DataParameterCollection) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members


ExecuteScalar() Method | fcSDK Documentation

ExecuteScalar() Method

Syntax

'Declaration

Public Overloads Function ExecuteScalar() As Object

public object ExecuteScalar()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


ExecuteScalar(String) Method | fcSDK Documentation

ExecuteScalar(String) Method

Syntax

'Declaration

Public Overloads Shared Function ExecuteScalar( _
   ByVal _commandText_ As String _
) As Object

public static object ExecuteScalar(
   string _commandText_
)

Parameters

commandText

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


ExecuteScalar(CommandType,String) Method | fcSDK Documentation

ExecuteScalar(CommandType,String) Method

Syntax

'Declaration

Public Overloads Shared Function ExecuteScalar( _
   ByVal _commandType_ As CommandType, _
   ByVal _commandText_ As String _
) As Object

public static object ExecuteScalar(
   CommandType _commandType_,
   string _commandText_
)

Parameters

commandType

commandText

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


ExecuteScalar(CommandType,String,DataParameterCollection) Method | fcSDK Documentation

ExecuteScalar(CommandType,String,DataParameterCollection) Method

Syntax

'Declaration

Public Overloads Shared Function ExecuteScalar( _
   ByVal _commandType_ As CommandType, _
   ByVal _commandText_ As String, _
   ByVal _commandParams_ As DataParameterCollection _
) As Object

public static object ExecuteScalar(
   CommandType _commandType_,
   string _commandText_,
   DataParameterCollection _commandParams_
)

Parameters

commandType

commandText

commandParams

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


ExecuteScalar(IDbConnection,CommandType,String) Method | fcSDK Documentation

ExecuteScalar(IDbConnection,CommandType,String) Method

Syntax

'Declaration

Public Overloads Shared Function ExecuteScalar( _
   ByVal _connection_ As IDbConnection, _
   ByVal _commandType_ As CommandType, _
   ByVal _commandText_ As String _
) As Object

public static object ExecuteScalar(
   IDbConnection _connection_,
   CommandType _commandType_,
   string _commandText_
)

Parameters

connection

commandType

commandText

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


ExecuteScalar(IDbConnection,CommandType,String,DataParameterCollection) Method | fcSDK Documentation

ExecuteScalar(IDbConnection,CommandType,String,DataParameterCollection) Method

Syntax

'Declaration

Public Overloads Shared Function ExecuteScalar( _
   ByVal _connection_ As IDbConnection, _
   ByVal _commandType_ As CommandType, _
   ByVal _commandText_ As String, _
   ByVal _commandParams_ As DataParameterCollection _
) As Object

public static object ExecuteScalar(
   IDbConnection _connection_,
   CommandType _commandType_,
   string _commandText_,
   DataParameterCollection _commandParams_
)

Parameters

connection

commandType

commandText

commandParams

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


ExecuteScalar(IDbTransaction,CommandType,String) Method | fcSDK Documentation

ExecuteScalar(IDbTransaction,CommandType,String) Method

Syntax

'Declaration

Public Overloads Shared Function ExecuteScalar( _
   ByVal _transaction_ As IDbTransaction, _
   ByVal _commandType_ As CommandType, _
   ByVal _commandText_ As String _
) As Object

public static object ExecuteScalar(
   IDbTransaction _transaction_,
   CommandType _commandType_,
   string _commandText_
)

Parameters

transaction

commandType

commandText

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


ExecuteScalar(IDbTransaction,CommandType,String,DataParameterCollection) Method | fcSDK Documentation

ExecuteScalar(IDbTransaction,CommandType,String,DataParameterCollection) Method

Syntax

'Declaration

Public Overloads Shared Function ExecuteScalar( _
   ByVal _transaction_ As IDbTransaction, _
   ByVal _commandType_ As CommandType, _
   ByVal _commandText_ As String, _
   ByVal _commandParams_ As DataParameterCollection _
) As Object

public static object ExecuteScalar(
   IDbTransaction _transaction_,
   CommandType _commandType_,
   string _commandText_,
   DataParameterCollection _commandParams_
)

Parameters

transaction

commandType

commandText

commandParams

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


ExecuteScalarInList Method | fcSDK Documentation

ExecuteScalarInList Method

Syntax

'Declaration

Public Function ExecuteScalarInList( _
   ByVal _inList_() As Object, _
   ByVal _columnName_ As String _
) As Object

public object ExecuteScalarInList(
   object\[\] _inList_,
   string _columnName_
)

Parameters

inList

columnName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members


FillDataSet Method | fcSDK Documentation

FillDataSet Method

Overload List

Overload | Description
FillDataSet(DataSet,String[]) |
FillDataSet(DataSet,Boolean,String[]) |
FillDataSet(DataSet,String,String[]) |
FillDataSet(DataSet,String,String[],Boolean) |
FillDataSet(DataSet,String[],CommandType,String,Boolean) |
FillDataSet(DataSet,String[],CommandType,String,DataParameterCollection,Boolean) |
FillDataSet(DataSet,String[],IDbConnection,CommandType,String,Boolean) |
FillDataSet(DataSet,String[],IDbConnection,CommandType,String,DataParameterCollection,Boolean) |
FillDataSet(DataSet,String[],IDbTransaction,CommandType,String,Boolean) |
FillDataSet(DataSet,String[],IDbTransaction,CommandType,String,DataParameterCollection,Boolean) |
FillDataSet(DbDataAdapter,DataSet,String[],IDbTransaction,CommandType,String,DataParameterCollection,Boolean) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members


FillDataSet(DataSet,String[]) Method | fcSDK Documentation

FillDataSet(DataSet,String[]) Method

Syntax

'Declaration

Public Overloads Sub FillDataSet( _
   ByVal _ds_ As DataSet, _
   ByVal ParamArray _tableNames_() As String _
)

public void FillDataSet(
   DataSet _ds_,
   params string[] _tableNames_
)

Parameters

ds

tableNames

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


FillDataSet(DataSet,Boolean,String[]) Method | fcSDK Documentation

FillDataSet(DataSet,Boolean,String[]) Method

Syntax

'Declaration

Public Overloads Sub FillDataSet( _
   ByVal _ds_ As DataSet, _
   ByVal _fillSchema_ As Boolean, _
   ByVal ParamArray _tableNames_() As String _
)

public void FillDataSet(
   DataSet _ds_,
   bool _fillSchema_,
   params string[] _tableNames_
)

Parameters

ds

fillSchema

tableNames

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


FillDataSet(DataSet,String,String[]) Method | fcSDK Documentation

FillDataSet(DataSet,String,String[]) Method

Syntax

'Declaration

Public Overloads Shared Sub FillDataSet( _
   ByVal _ds_ As DataSet, _
   ByVal _sqlStmt_ As String, _
   ByVal _tableNames_() As String _
)

public static void FillDataSet(
   DataSet _ds_,
   string _sqlStmt_,
   string[] _tableNames_
)

Parameters

ds

sqlStmt

tableNames

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


FillDataSet(DataSet,String,String[],Boolean) Method | fcSDK Documentation

FillDataSet(DataSet,String,String[],Boolean) Method

Syntax

'Declaration

Public Overloads Shared Sub FillDataSet( _
   ByVal _ds_ As DataSet, _
   ByVal _sqlStmt_ As String, _
   ByVal _tableNames_() As String, _
   ByVal _fillSchema_ As Boolean _
)

public static void FillDataSet(
   DataSet _ds_,
   string _sqlStmt_,
   string[] _tableNames_,
   bool _fillSchema_
)

Parameters

ds

sqlStmt

tableNames

fillSchema

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


FillDataSet(DataSet,String[],CommandType,String,Boolean) Method | fcSDK Documentation

FillDataSet(DataSet,String[],CommandType,String,Boolean) Method

Syntax

'Declaration

Public Overloads Shared Sub FillDataSet( _
   ByVal _ds_ As DataSet, _
   ByVal _tableNames_() As String, _
   ByVal _cmdType_ As CommandType, _
   ByVal _cmdText_ As String, _
   ByVal _fillSchema_ As Boolean _
)

public static void FillDataSet(
   DataSet _ds_,
   string[] _tableNames_,
   CommandType _cmdType_,
   string _cmdText_,
   bool _fillSchema_
)

Parameters

ds

tableNames

cmdType

cmdText

fillSchema

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


FillDataSet(DataSet,String[],CommandType,String,DataParameterCollection,Boolean) Method | fcSDK Documentation

FillDataSet(DataSet,String[],CommandType,String,DataParameterCollection,Boolean) Method

Syntax

'Declaration

Public Overloads Shared Sub FillDataSet( _
   ByVal _ds_ As DataSet, _
   ByVal _tableNames_() As String, _
   ByVal _cmdType_ As CommandType, _
   ByVal _cmdText_ As String, _
   ByVal _dataParams_ As DataParameterCollection, _
   ByVal _fillSchema_ As Boolean _
)

public static void FillDataSet(
   DataSet _ds_,
   string[] _tableNames_,
   CommandType _cmdType_,
   string _cmdText_,
   DataParameterCollection _dataParams_,
   bool _fillSchema_
)

Parameters

ds

tableNames

cmdType

cmdText

dataParams

fillSchema

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


FillDataSet(DataSet,String[],IDbConnection,CommandType,String,Boolean) Method | fcSDK Documentation

FillDataSet(DataSet,String[],IDbConnection,CommandType,String,Boolean) Method

Syntax

'Declaration

Public Overloads Shared Sub FillDataSet( _
   ByVal _ds_ As DataSet, _
   ByVal _tableNames_() As String, _
   ByVal _conn_ As IDbConnection, _
   ByVal _cmdType_ As CommandType, _
   ByVal _cmdText_ As String, _
   ByVal _fillSchema_ As Boolean _
)

public static void FillDataSet(
   DataSet _ds_,
   string[] _tableNames_,
   IDbConnection _conn_,
   CommandType _cmdType_,
   string _cmdText_,
   bool _fillSchema_
)

Parameters

ds

tableNames

conn

cmdType

cmdText

fillSchema

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


FillDataSet(DataSet,String[],IDbConnection,CommandType,String,DataParameterCollection,Boolean) Method | fcSDK Documentation

FillDataSet(DataSet,String[],IDbConnection,CommandType,String,DataParameterCollection,Boolean) Method

Syntax

'Declaration

Public Overloads Shared Sub FillDataSet( _
   ByVal _ds_ As DataSet, _
   ByVal _tableNames_() As String, _
   ByVal _conn_ As IDbConnection, _
   ByVal _cmdType_ As CommandType, _
   ByVal _cmdText_ As String, _
   ByVal _dataParams_ As DataParameterCollection, _
   ByVal _fillSchema_ As Boolean _
)

public static void FillDataSet(
   DataSet _ds_,
   string[] _tableNames_,
   IDbConnection _conn_,
   CommandType _cmdType_,
   string _cmdText_,
   DataParameterCollection _dataParams_,
   bool _fillSchema_
)

Parameters

ds

tableNames

conn

cmdType

cmdText

dataParams

fillSchema

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


| fcSDK Documentation

###FillDataSet(DataSet,String[],IDbTransaction,CommandType,String,Boolean) Method

Syntax

'Declaration

Public Overloads Shared Sub FillDataSet( _
   ByVal _ds_ As DataSet, _
   ByVal _tableNames_() As String, _
   ByVal _trans_ As IDbTransaction, _
   ByVal _cmdType_ As CommandType, _
   ByVal _cmdText_ As String, _
   ByVal _fillSchema_ As Boolean _
)

public static void FillDataSet(
   DataSet _ds_,
   string[] _tableNames_,
   IDbTransaction _trans_,
   CommandType _cmdType_,
   string _cmdText_,
   bool _fillSchema_
)

Parameters

ds

tableNames

trans

cmdType

cmdText

fillSchema

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


FillDataSet(DataSet,String[],IDbTransaction,CommandType,String,DataParameterCollection,Boolean) Method | fcSDK Documentation

FillDataSet(DataSet,String[],IDbTransaction,CommandType,String,DataParameterCollection,Boolean) Method

Syntax

'Declaration

Public Overloads Shared Sub FillDataSet( _
   ByVal _ds_ As DataSet, _
   ByVal _tableNames_() As String, _
   ByVal _transaction_ As IDbTransaction, _
   ByVal _cmdType_ As CommandType, _
   ByVal _cmdText_ As String, _
   ByVal _dataParams_ As DataParameterCollection, _
   ByVal _fillSchema_ As Boolean _
)

public static void FillDataSet(
   DataSet _ds_,
   string[] _tableNames_,
   IDbTransaction _transaction_,
   CommandType _cmdType_,
   string _cmdText_,
   DataParameterCollection _dataParams_,
   bool _fillSchema_
)

Parameters

ds

tableNames

transaction

cmdType

cmdText

dataParams

fillSchema

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


FillDataSet(DbDataAdapter,DataSet,String[],IDbTransaction,CommandType,String,DataParameterCollection,Boolean) Method | fcSDK Documentation

FillDataSet(DbDataAdapter,DataSet,String[],IDbTransaction,CommandType,String,DataParameterCollection,Boolean) Method

Syntax

'Declaration

Public Overloads Shared Sub FillDataSet( _
   ByVal _adapter_ As DbDataAdapter, _
   ByVal _ds_ As DataSet, _
   ByVal _tableNames_() As String, _
   ByVal _transaction_ As IDbTransaction, _
   ByVal _cmdType_ As CommandType, _
   ByVal _cmdText_ As String, _
   ByVal _dataParams_ As DataParameterCollection, _
   ByVal _fillSchema_ As Boolean _
)

public static void FillDataSet(
   DbDataAdapter _adapter_,
   DataSet _ds_,
   string[] _tableNames_,
   IDbTransaction _transaction_,
   CommandType _cmdType_,
   string _cmdText_,
   DataParameterCollection _dataParams_,
   bool _fillSchema_
)

Parameters

adapter

ds

tableNames

transaction

cmdType

cmdText

dataParams

fillSchema

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


FillDataSetInList Method | fcSDK Documentation

FillDataSetInList Method

Overload List

Overload | Description
FillDataSetInList(DataSet,Object[],String) |
FillDataSetInList(DataSet,Object[],String,String,Boolean) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members


FillDataSetInList(DataSet,Object[],String) Method | fcSDK Documentation

FillDataSetInList(DataSet,Object[],String) Method

Syntax

'Declaration

Public Overloads Sub FillDataSetInList( _
   ByVal _ds_ As DataSet, _
   ByVal _inList_() As Object, _
   ByVal _columnName_ As String _
)

public void FillDataSetInList(
   DataSet _ds_,
   object\[\] _inList_,
   string _columnName_
)

Parameters

ds

inList

columnName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


FillDataSetInList(DataSet,Object[],String,String,Boolean) Method | fcSDK Documentation

FillDataSetInList(DataSet,Object[],String,String,Boolean) Method

Syntax

'Declaration

Public Overloads Sub FillDataSetInList( _
   ByVal _ds_ As DataSet, _
   ByVal _inList_() As Object, _
   ByVal _columnName_ As String, _
   ByVal _tableName_ As String, _
   ByVal _fillSchema_ As Boolean _
)

public void FillDataSetInList(
   DataSet _ds_,
   object\[\] _inList_,
   string _columnName_,
   string _tableName_,
   bool _fillSchema_
)

Parameters

ds

inList

columnName

tableName

fillSchema

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


FillDataSetRaw Method | fcSDK Documentation

FillDataSetRaw Method

Overload List

Overload | Description
FillDataSetRaw(DataSet,String[]) |
FillDataSetRaw(DataSet,Boolean,String[]) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members


FillDataSetRaw(DataSet,String[]) Method | fcSDK Documentation

FillDataSetRaw(DataSet,String[]) Method

Syntax

'Declaration

Public Overloads Shared Sub FillDataSetRaw( _
   ByVal _ds_ As DataSet, _
   ByVal ParamArray _tableNames_() As String _
)

public static void FillDataSetRaw(
   DataSet _ds_,
   params string[] _tableNames_
)

Parameters

ds

tableNames

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


FillDataSetRaw(DataSet,Boolean,String[]) Method | fcSDK Documentation

FillDataSetRaw(DataSet,Boolean,String[]) Method

Syntax

'Declaration

Public Overloads Shared Sub FillDataSetRaw( _
   ByVal _ds_ As DataSet, _
   ByVal _fillSchema_ As Boolean, _
   ByVal ParamArray _tableNames_() As String _
)

public static void FillDataSetRaw(
   DataSet _ds_,
   bool _fillSchema_,
   params string[] _tableNames_
)

Parameters

ds

fillSchema

tableNames

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


GetTableAsDataSet Method | fcSDK Documentation

GetTableAsDataSet Method

Overload List

Overload | Description
GetTableAsDataSet(String) |
GetTableAsDataSet(String,String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members


GetTableAsDataSet(String) Method | fcSDK Documentation

GetTableAsDataSet(String) Method

Syntax

'Declaration

Public Overloads Shared Function GetTableAsDataSet( _
   ByVal _tableName_ As String _
) As DataSet

public static DataSet GetTableAsDataSet(
   string _tableName_
)

Parameters

tableName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


GetTableAsDataSet(String,String) Method | fcSDK Documentation

GetTableAsDataSet(String,String) Method

Syntax

'Declaration

Public Overloads Shared Function GetTableAsDataSet( _
   ByVal _tableName_ As String, _
   ByVal _orderBy_ As String _
) As DataSet

public static DataSet GetTableAsDataSet(
   string _tableName_,
   string _orderBy_
)

Parameters

tableName

orderBy

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


PrepareInListStatement Method | fcSDK Documentation

PrepareInListStatement Method

Overload List

Overload | Description
PrepareInListStatement(Object[],String,String) |
PrepareInListStatement(Int32,DataParameterCollection,Object[],String,String) |
PrepareInListStatement(Int32[],String,String) |
PrepareInListStatement(Int32,DataParameterCollection,Object[],String,String,IDbDataParameter) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members


PrepareInListStatement(Object[],String,String) Method | fcSDK Documentation

PrepareInListStatement(Object[],String,String) Method

Syntax

'Declaration

Public Overloads Function PrepareInListStatement( _
   ByVal _inList_() As Object, _
   ByVal _columnName_ As String, _
   ByVal _text_ As String _
) As String

public string PrepareInListStatement(
   object\[\] _inList_,
   string _columnName_,
   string _text_
)

Parameters

inList

columnName

text

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


PrepareInListStatement(Int32,DataParameterCollection,Object[],String,String) Method | fcSDK Documentation

PrepareInListStatement(Int32,DataParameterCollection,Object[],String,String) Method

Syntax

'Declaration

Public Overloads Function PrepareInListStatement( _
   ByVal _paramBaseNum_ As Integer, _
   ByVal _dataParams_ As DataParameterCollection, _
   ByVal _inList_() As Object, _
   ByVal _columnName_ As String, _
   ByVal _text_ As String _
) As String

public string PrepareInListStatement(
   int _paramBaseNum_,
   DataParameterCollection _dataParams_,
   object\[\] _inList_,
   string _columnName_,
   string _text_
)

Parameters

paramBaseNum

dataParams

inList

columnName

text

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


PrepareInListStatement(Int32[],String,String) Method | fcSDK Documentation

PrepareInListStatement(Int32[],String,String) Method

Syntax

'Declaration

Public Overloads Function PrepareInListStatement( _
   ByVal _inList_() As Integer, _
   ByVal _columnName_ As String, _
   ByVal _text_ As String _
) As String

public string PrepareInListStatement(
   int[] _inList_,
   string _columnName_,
   string _text_
)

Parameters

inList

columnName

text

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


PrepareInListStatement(Int32,DataParameterCollection,Object[],String,String,IDbDataParameter) Method | fcSDK Documentation

PrepareInListStatement(Int32,DataParameterCollection,Object[],String,String,IDbDataParameter) Method

Syntax

'Declaration

Public Overloads Function PrepareInListStatement( _
   ByVal _paramBaseNum_ As Integer, _
   ByVal _dataParams_ As DataParameterCollection, _
   ByVal _inList_() As Object, _
   ByVal _columnName_ As String, _
   ByVal _text_ As String, _
   ByVal _parameterTemplate_ As IDbDataParameter _
) As String

public string PrepareInListStatement(
   int _paramBaseNum_,
   DataParameterCollection _dataParams_,
   object[] _inList_,
   string _columnName_,
   string _text_,
   IDbDataParameter _parameterTemplate_
)

Parameters

paramBaseNum

dataParams

inList

columnName

text

parameterTemplate

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members
Overload List


PrepareIntegerListStatement Method | fcSDK Documentation

PrepareIntegerListStatement Method

Syntax

'Declaration

Public Function PrepareIntegerListStatement( _
   ByVal _intList_() As Integer, _
   ByVal _columnName_ As String, _
   ByVal _text_ As String _
) As String

public string PrepareIntegerListStatement(
   int\[\] _intList_,
   string _columnName_,
   string _text_
)

Parameters

intList

columnName

text

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members


CommandText Property (SqlHelper) | fcSDK Documentation

CommandText Property (SqlHelper)

Syntax

'Declaration

Public Property CommandText As String

public string CommandText {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members


CommandType Property | fcSDK Documentation

CommandType Property

Syntax

'Declaration

Public Property CommandType As CommandType

public CommandType CommandType {get; set;}

Remarks

When the CommandType property is set to StoredProcedure, set the CommandText property to the name of the stored procedure. The user may be required to use escape character syntax if the stored procedure name contains any special characters. The command will call this stored procedure when you call one of the Execute methods.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members


Connection Property | fcSDK Documentation

Connection Property

Syntax

'Declaration

Public Property Connection As IDbConnection

public IDbConnection Connection {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members


DataProvider Property | fcSDK Documentation

DataProvider Property

Syntax

'Declaration

Public Property DataProvider As DbProvider

public DbProvider DataProvider {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members


Log Property (SqlHelper) | fcSDK Documentation

Log Property (SqlHelper)

Syntax

'Declaration

Public Shared ReadOnly Property Log As Logger

public static Logger Log {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members


Parameters Property (SqlHelper) | fcSDK Documentation

Parameters Property (SqlHelper)

Syntax

'Declaration

Public ReadOnly Property Parameters As DataParameterCollection

public DataParameterCollection Parameters {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members


Transaction Property (SqlHelper) | fcSDK Documentation

Transaction Property (SqlHelper)

Syntax

'Declaration

Public Property Transaction As IDbTransaction

public IDbTransaction Transaction {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members


IN_LIST_TOKEN Field | fcSDK Documentation

IN_LIST_TOKEN Field

Syntax

'Declaration

Public Const IN_LIST_TOKEN As String

public const string IN_LIST_TOKEN

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SqlHelper Class
SqlHelper Members


TypeMapper Class | fcSDK Documentation

TypeMapper Class

This class is not currently used and is intended for future products.

Syntax

'Declaration

Public MustInherit Class TypeMapper

public abstract class TypeMapper

Inheritance Hierarchy

System.Object
FChoice.Common.Data.TypeMapper

Requirements

Namespace: FChoice.Common.Data

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

TypeMapper Members
FChoice.Common.Data Namespace


TypeMapper Class Members | fcSDK Documentation

TypeMapper Class Members

The following tables list the members exposed by TypeMapper.

Public Methods

 | Name | Description
Public Method | MapDbNameToDbNumber |
Public Method | MapDbNameToFCName |
Public Method | MapDbNameToFCNumber |
Public Method | MapDbNumberToDbName |
Public Method | MapDbNumberToFCName |
Public Method | MapDbNumberToFCNumber |
Public Method | MapFCNameToDbName |
Public Method | MapFCNameToDbNumber |
static (Shared in Visual Basic) | MapFCNameToFCNumber |
Public Method | MapFCNumberToDbName |
Public Method | MapFCNumberToDbNumber |
static (Shared in Visual Basic) | MapFCNumberToFCName |
Public Method | MapTypeToDbType |

Reference

TypeMapper Class
FChoice.Common.Data Namespace


MapDbNameToDbNumber Method | fcSDK Documentation

MapDbNameToDbNumber Method

Syntax

'Declaration

Public MustOverride Function MapDbNameToDbNumber( _
   ByVal _dbName_ As String _
) As Integer

public abstract int MapDbNameToDbNumber(
   string _dbName_
)

Parameters

dbName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

TypeMapper Class
TypeMapper Members


MapDbNameToFCName Method | fcSDK Documentation

MapDbNameToFCName Method

Syntax

'Declaration

Public MustOverride Function MapDbNameToFCName( _
   ByVal _dbName_ As String _
) As String

public abstract string MapDbNameToFCName(
   string _dbName_
)

Parameters

dbName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

TypeMapper Class
TypeMapper Members


MapDbNameToFCNumber Method | fcSDK Documentation

MapDbNameToFCNumber Method

Syntax

'Declaration

Public MustOverride Function MapDbNameToFCNumber( _
   ByVal _dbName_ As String _
) As Integer

public abstract int MapDbNameToFCNumber(
   string _dbName_
)

Parameters

dbName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

TypeMapper Class
TypeMapper Members


MapDbNumberToDbName Method | fcSDK Documentation

MapDbNumberToDbName Method

Syntax

'Declaration

Public MustOverride Function MapDbNumberToDbName( _
   ByVal _dbNumber_ As Integer _
) As String

public abstract string MapDbNumberToDbName(
   int _dbNumber_
)

Parameters

dbNumber

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

TypeMapper Class
TypeMapper Members


MapDbNumberToFCName Method | fcSDK Documentation

MapDbNumberToFCName Method

Syntax

'Declaration

Public MustOverride Function MapDbNumberToFCName( _
   ByVal _dbNumber_ As Integer _
) As String

public abstract string MapDbNumberToFCName(
   int _dbNumber_
)

Parameters

dbNumber

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

TypeMapper Class
TypeMapper Members


MapDbNumberToFCNumber Method | fcSDK Documentation

MapDbNumberToFCNumber Method

Syntax

'Declaration

Public MustOverride Function MapDbNumberToFCNumber( _
   ByVal _dbNumber_ As Integer _
) As Integer

public abstract int MapDbNumberToFCNumber(
   int _dbNumber_
)

Parameters

dbNumber

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

TypeMapper Class
TypeMapper Members


MapFCNameToDbName Method | fcSDK Documentation

MapFCNameToDbName Method

Syntax

'Declaration

Public MustOverride Function MapFCNameToDbName( _
   ByVal _fcName_ As String _
) As String

public abstract string MapFCNameToDbName(
   string _fcName_
)

Parameters

fcName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

TypeMapper Class
TypeMapper Members


MapFCNameToDbNumber Method | fcSDK Documentation

MapFCNameToDbNumber Method

Syntax

'Declaration

Public MustOverride Function MapFCNameToDbNumber( _
   ByVal _fcName_ As String _
) As Integer

public abstract int MapFCNameToDbNumber(
   string _fcName_
)

Parameters

fcName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

TypeMapper Class
TypeMapper Members


MapFCNameToFCNumber Method | fcSDK Documentation

MapFCNameToFCNumber Method

Syntax

'Declaration

Public Shared Function MapFCNameToFCNumber( _
   ByVal _fcName_ As String _
) As Integer

public static int MapFCNameToFCNumber(
   string _fcName_
)

Parameters

fcName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

TypeMapper Class
TypeMapper Members


MapFCNumberToDbName Method | fcSDK Documentation

MapFCNumberToDbName Method

Syntax

'Declaration

Public MustOverride Function MapFCNumberToDbName( _
   ByVal _fcNumber_ As Integer _
) As String

public abstract string MapFCNumberToDbName(
   int _fcNumber_
)

Parameters

fcNumber

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

TypeMapper Class
TypeMapper Members


MapFCNumberToDbNumber Method | fcSDK Documentation

MapFCNumberToDbNumber Method

Syntax

'Declaration

Public MustOverride Function MapFCNumberToDbNumber( _
   ByVal _fcNumber_ As Integer _
) As Integer

public abstract int MapFCNumberToDbNumber(
   int _fcNumber_
)

Parameters

fcNumber

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

TypeMapper Class
TypeMapper Members


MapFCNumberToFCName Method | fcSDK Documentation

MapFCNumberToFCName Method

Syntax

'Declaration

Public Shared Function MapFCNumberToFCName( _
   ByVal _fcNumber_ As Integer _
) As String

public static string MapFCNumberToFCName(
   int _fcNumber_
)

Parameters

fcNumber

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

TypeMapper Class
TypeMapper Members


MapTypeToDbType Method | fcSDK Documentation

MapTypeToDbType Method

Syntax

'Declaration

Public Overridable Function MapTypeToDbType( _
   ByVal _type_ As Type _
) As Type

public virtual Type MapTypeToDbType(
   Type _type_
)

Parameters

type

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

TypeMapper Class
TypeMapper Members


UpdateQueryBatch Class | fcSDK Documentation

UpdateQueryBatch Class

Helper class for grouping INSERT and UPDATE statements together into a single batch without concern for the underlying database type's support for statement batching

Syntax

'Declaration

Public Class UpdateQueryBatch

public class UpdateQueryBatch

Remarks

Grouping a number of statements into a single batch can present a challenge if those statements are parameterized query/update/insert statements. This class helps keep the parameter names unique as well as abstracting the execution details of executing all the statements in a single transaction and single database round-trip. If the provider does not support statement batching, statements will be executed one-by-one.

Inheritance Hierarchy

System.Object
FChoice.Common.Data.UpdateQueryBatch

Requirements

Namespace: FChoice.Common.Data

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

UpdateQueryBatch Members
FChoice.Common.Data Namespace


UpdateQueryBatch Class Members | fcSDK Documentation

UpdateQueryBatch Class Members

The following tables list the members exposed by UpdateQueryBatch.

Public Constructors

 | Name | Description
Public Constructor | UpdateQueryBatch Constructor | Overloaded.

Public Properties

 | Name | Description
Public Property | CommandText | Gets the current command text that will be executed when the Execute Method is called
Public Property | Parameters | Gets the collection of all parameters for all queries to be executed by this batch
Public Property | Provider | Gets the provider that this batch is using
Public Property | SqlHelper | Gets the instance of a SqlHelper class that is used by this batch to manage parameters and execute statements
Public Property | Transaction | Gets the transaction specified when this UpdateQueryBatch instance was created

Public Methods

 | Name | Description
Public Method | AddStatement | Adds an unprepared SQL statement (with the {n} and {DATE} parameters still present) to the list of statements to execute during the batch or executes it immediately if batching is not available or disabled
Public Method | Execute | Executes the batch if the provider supports statement batching, or nothing if it doesn't
Public Method | GetUniqueParamName | Gets a unique parameter name among all the parameters for all the queries in this batch based off a suggested base name

Reference

UpdateQueryBatch Class
FChoice.Common.Data Namespace


UpdateQueryBatch Constructor | fcSDK Documentation

UpdateQueryBatch Constructor

Creates a new instance of a query batch using the specified transaction and optional provider

Overload List

Overload | Description
UpdateQueryBatch Constructor(IDbTransaction,DbProvider) | Creates a new instance of a query batch using the specified transaction and a specific provider
UpdateQueryBatch Constructor(IDbTransaction) | Creates a new instance of a query batch using the specified transaction and the default provider

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateQueryBatch Class
UpdateQueryBatch Members


UpdateQueryBatch Constructor(IDbTransaction,DbProvider) | fcSDK Documentation

UpdateQueryBatch Constructor(IDbTransaction,DbProvider)

An open, live transaction in which this batch will participate

The provider to use for any database-type-specific operations that UpdateQueryBatch may need to perform

Creates a new instance of a query batch using the specified transaction and a specific provider

Syntax

'Declaration

Public Function New( _
   ByVal _trans_ As IDbTransaction, _
   ByVal _prov_ As DbProvider _
)

public UpdateQueryBatch(
   IDbTransaction _trans_,
   DbProvider _prov_
)

Parameters

trans

An open, live transaction in which this batch will participate

prov

The provider to use for any database-type-specific operations that UpdateQueryBatch may need to perform

Remarks

The transaction must be open and ready against an open database connection.

IMPORTANT: The UpdateQueryBatch does not commit or rollback the transaction instance. It is the responsibility of the caller to ensure that the transaction is properly set up and finished after the batch is executed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateQueryBatch Class
UpdateQueryBatch Members
Overload List


UpdateQueryBatch Constructor(IDbTransaction) | fcSDK Documentation

UpdateQueryBatch Constructor(IDbTransaction)

An open, live transaction in which this batch will participate

Creates a new instance of a query batch using the specified transaction and the default provider

Syntax

'Declaration

Public Function New( _
   ByVal _trans_ As IDbTransaction _
)

public UpdateQueryBatch(
   IDbTransaction _trans_
)

Parameters

trans

An open, live transaction in which this batch will participate

Remarks

The transaction must be open and ready against an open database connection

IMPORTANT: The UpdateQueryBatch does not commit or rollback the transaction instance. It is the responsibility of the caller to ensure that the transaction is properly set up and finished after the batch is executed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateQueryBatch Class
UpdateQueryBatch Members
Overload List


AddStatement Method | fcSDK Documentation

AddStatement Method

An unprepared SQL statement (with the {n} and {DATE} parameters still present)

A collection of parameters to use with the supplied sqlStmt parameter. The number of parameters must match the number of {n} arguments in the SQL statement. Each parameter in the collection must have a unique name with respect to all the other parameters in all the other queries in this batch. To guarantee uniqueness among parameters, see the GetUniqueParamName Method.

Adds an unprepared SQL statement (with the {n} and {DATE} parameters still present) to the list of statements to execute during the batch or executes it immediately if batching is not available or disabled

Syntax

'Declaration

Public Sub AddStatement( _
   ByVal _sqlStmt_ As String, _
   ByVal _cmdParams_ As DataParameterCollection _
)

public void AddStatement(
   string _sqlStmt_,
   DataParameterCollection _cmdParams_
)

Parameters

sqlStmt

An unprepared SQL statement (with the {n} and {DATE} parameters still present)

cmdParams

A collection of parameters to use with the supplied sqlStmt parameter. The number of parameters must match the number of {n} arguments in the SQL statement. Each parameter in the collection must have a unique name with respect to all the other parameters in all the other queries in this batch. To guarantee uniqueness among parameters, see the GetUniqueParamName Method.

Remarks

Once added, the statement is rewritten to make the parameter names unique among all the statements. Once added a statement cannot be removed. The entire batch must be discarded and rebuilt.

If the specified provider for this batch returns false from its CanBatchQueries property, the statement will be executed immediately and not added to a batch. No statement will be added to a "batch". Subsequent calls to the Execute Method will not perform any operations against the database and return a -2 for number of rows affected.

If the specified provider returns true from its CanBatchQueries property, this statement will be added to the list of statements to execute in the batch when the Execute Method is called.

IMPORTANT: The UpdateQueryBatch does not commit or rollback the transaction instance. It is the responsibility of the caller to ensure that the transaction is properly set up and finished after the batch is executed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateQueryBatch Class
UpdateQueryBatch Members


Execute Method (UpdateQueryBatch) | fcSDK Documentation

Execute Method (UpdateQueryBatch)

Executes the batch if the provider supports statement batching, or nothing if it doesn't

Syntax

'Declaration

Public Function Execute() As Integer

public int Execute()

Return Value

The number of rows affected, if available, or -2 if no statements were executed

Remarks

Not all providers support returning the number of rows affected in all circumstances. Different providers return different results in this case. Usually the number is -1 or 0. Otherwise, the number should be a positive number indicating the number of rows inserted and/or updated.

IMPORTANT: The UpdateQueryBatch does not commit or rollback the transaction instance. It is the responsibility of the caller to ensure that the transaction is properly set up and finished after the batch is executed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateQueryBatch Class
UpdateQueryBatch Members


GetUniqueParamName Method | fcSDK Documentation

GetUniqueParamName Method

The desired name for the parameter

Gets a unique parameter name among all the parameters for all the queries in this batch based off a suggested base name

Syntax

'Declaration

Public Function GetUniqueParamName( _
   ByVal _baseName_ As String _
) As String

public string GetUniqueParamName(
   string _baseName_
)

Parameters

baseName

The desired name for the parameter

Return Value

The desired name with numbers appended as necessary to guarantee uniqueness

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateQueryBatch Class
UpdateQueryBatch Members


CommandText Property (UpdateQueryBatch) | fcSDK Documentation

CommandText Property (UpdateQueryBatch)

Gets the current command text that will be executed when the Execute Method is called

Syntax

'Declaration

Public ReadOnly Property CommandText As StringBuilder

public StringBuilder CommandText {get;}

Property Value

The current command text that will be executed when the Execute Method is called or a concatenation of all statements that were executed during calls to the AddStatement Method if the provider does not support batching

Remarks

Calls to the AddStatement Method will modify the value of this property. Statements cannot be removed or changed once they are added. The batch must be discarded and rebuilt in order to change any of the statements.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateQueryBatch Class
UpdateQueryBatch Members


Parameters Property (UpdateQueryBatch) | fcSDK Documentation

Parameters Property (UpdateQueryBatch)

Gets the collection of all parameters for all queries to be executed by this batch

Syntax

'Declaration

Public ReadOnly Property Parameters As DataParameterCollection

public DataParameterCollection Parameters {get;}

Property Value

The collection of all parameters for all queries to be executed by this batch or the parameters used by the last query executed during the last call to the AddStatement Method if the provider does not support batching.

Remarks

While the parameters in this collection can be manipulated, this could cause instability during the batching process and is not recommended.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateQueryBatch Class
UpdateQueryBatch Members


Provider Property (UpdateQueryBatch) | fcSDK Documentation

Provider Property (UpdateQueryBatch)

Gets the provider that this batch is using

Syntax

'Declaration

Public ReadOnly Property Provider As DbProvider

public DbProvider Provider {get;}

Property Value

The provider that this batch is using

Remarks

This value is read-only to prevent changing providers in the middle of a batch process. Note that the provider on the SqlHelper Property can be changed. This might have adverse effects on the batching process and is not recommended.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateQueryBatch Class
UpdateQueryBatch Members


SqlHelper Property | fcSDK Documentation

SqlHelper Property

Gets the instance of a SqlHelper class that is used by this batch to manage parameters and execute statements

Syntax

'Declaration

Public ReadOnly Property SqlHelper As SqlHelper

public SqlHelper SqlHelper {get;}

Property Value

The instance of a SqlHelper class that is used by this batch to manage parameters and execute statements

Remarks

While it is possible to change properties, add/remove parameters, and change providers and other properties on this instance, it could cause instability during the batching process and is not recommended.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateQueryBatch Class
UpdateQueryBatch Members


Transaction Property (UpdateQueryBatch) | fcSDK Documentation

Transaction Property (UpdateQueryBatch)

Gets the transaction specified when this UpdateQueryBatch instance was created

Syntax

'Declaration

Public ReadOnly Property Transaction As IDbTransaction

public IDbTransaction Transaction {get;}

Property Value

The transaction specified when this UpdateQueryBatch instance was created

Remarks

IMPORTANT: The UpdateQueryBatch does not commit or rollback the transaction instance. It is the responsibility of the caller to ensure that the transaction is properly set up and finished after the batch is executed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateQueryBatch Class
UpdateQueryBatch Members


IDbExtension Interface | fcSDK Documentation

IDbExtension Interface

IDbExtension allows applications to specify database-specific extensions to the DbProvider

Syntax

'Declaration

Public Interface IDbExtension

public interface IDbExtension

Requirements

Namespace: FChoice.Common.Data

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

IDbExtension Members
FChoice.Common.Data Namespace


IDbExtension Interface Members | fcSDK Documentation

IDbExtension Interface Members

The following tables list the members exposed by IDbExtension.

Public Methods

 | Name | Description
Method | Initialize | Initialize is called by the DbProvider when loading extensions. This method allows extensions to have a chance to perform initialization and start-up tasks.

Reference

IDbExtension Interface
FChoice.Common.Data Namespace


Initialize Method (IDbExtension) | fcSDK Documentation

Initialize Method (IDbExtension)

The provider this extension is extending

The XML configuration specified for this extension in the application configuration file

Initialize is called by the DbProvider when loading extensions. This method allows extensions to have a chance to perform initialization and start-up tasks.

Syntax

'Declaration

Sub Initialize( _
   ByVal _provider_ As DbProvider, _
   ByVal _extensionConfig_ As XmlNode _
)

void Initialize(
   DbProvider _provider_,
   XmlNode _extensionConfig_
)

Parameters

provider

The provider this extension is extending

extensionConfig

The XML configuration specified for this extension in the application configuration file

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IDbExtension Interface
IDbExtension Members


FChoice.Common.Licensing Namespace | fcSDK Documentation

FChoice.Common.Licensing Namespace

Classes

 | Class | Description
Class | LicenseCollection | Collection of LicensesHolds a collection of valid licenses.
Class | LicenseInfo | License Details
Class | LicenseManager | Singleton providing access to the current collection of valid First Choice licenses
Class | XmlClarifyLicenseTool |
Class | XmlLicenseTool |

Interfaces

 | Interface | Description
Interface | ILicenseInfo |
Interface | ILicenseTool | Supports First Choice licensing.

Enumerations

 | Enumeration | Description
Enumeration | GracePeriodTimeSpan |
Enumeration | LicenseUserRestrictionType |

Remarks

This namespace is for First Choice Software use only. API stability is not guaranteed.

Reference

FChoice.Common Assembly


LicenseCollection Class | fcSDK Documentation

LicenseCollection Class

Collection of LicensesHolds a collection of valid licenses.

Syntax

'Declaration
<DefaultMemberAttribute("Item")>
Public NotInheritable Class LicenseCollection
   Inherits System.Collections.CollectionBase

[DefaultMemberAttribute("Item")]
public sealed class LicenseCollection : System.Collections.CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
FChoice.Common.Licensing.LicenseCollection

Requirements

Namespace: FChoice.Common.Licensing

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

LicenseCollection Members
FChoice.Common.Licensing Namespace


LicenseCollection Class Members | fcSDK Documentation

LicenseCollection Class Members

The following tables list the members exposed by LicenseCollection.

Public Constructors

 | Name | Description
Public Constructor | LicenseCollection Constructor | Overloaded.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)

Public Methods

 | Name | Description
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)

Reference

LicenseCollection Class
FChoice.Common.Licensing Namespace


LicenseCollection Constructor | fcSDK Documentation

LicenseCollection Constructor

Overload List

Overload | Description
LicenseCollection Constructor() |
LicenseCollection Constructor(IDataReader) |
LicenseCollection Constructor(XmlDocument) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LicenseCollection Class
LicenseCollection Members


LicenseCollection Constructor() | fcSDK Documentation

LicenseCollection Constructor()

Syntax

'Declaration

Public Function New()

public LicenseCollection()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LicenseCollection Class
LicenseCollection Members
Overload List


LicenseCollection Constructor(IDataReader) | fcSDK Documentation

LicenseCollection Constructor(IDataReader)

Syntax

'Declaration

Public Function New( _
   ByVal _licenseReader_ As IDataReader _
)

public LicenseCollection(
   IDataReader _licenseReader_
)

Parameters

licenseReader

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LicenseCollection Class
LicenseCollection Members
Overload List


LicenseCollection Constructor(XmlDocument) | fcSDK Documentation

LicenseCollection Constructor(XmlDocument)

Syntax

'Declaration

Public Function New( _
   ByVal _xmlDocument_ As XmlDocument _
)

public LicenseCollection(
   XmlDocument _xmlDocument_
)

Parameters

xmlDocument

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LicenseCollection Class
LicenseCollection Members
Overload List


LicenseInfo Class | fcSDK Documentation

LicenseInfo Class

License Details

Syntax

'Declaration

Public Class LicenseInfo
   Implements ILicenseInfo

public class LicenseInfo : ILicenseInfo

Inheritance Hierarchy

System.Object
FChoice.Common.Licensing.LicenseInfo

Requirements

Namespace: FChoice.Common.Licensing

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

LicenseInfo Members
FChoice.Common.Licensing Namespace


LicenseInfo Class Members | fcSDK Documentation

LicenseInfo Class Members

The following tables list the members exposed by LicenseInfo.

Public Properties

 | Name | Description
Public Property | ExpirationDate |
Public Property | GraceEventLimit |
Public Property | GraceEventsRemaining |
Public Property | GraceLicensesRemaining |
Public Property | GraceLoginLimit |
Public Property | GraceTimeSpan |
Public Property | ProductId |
Public Property | UserLicenseLimit |
Public Property | UserLicensesRemaining |
Public Property | UserRestriction |

Reference

LicenseInfo Class
FChoice.Common.Licensing Namespace


ExpirationDate Property (LicenseInfo) | fcSDK Documentation

ExpirationDate Property (LicenseInfo)

Syntax

'Declaration

Public ReadOnly Property ExpirationDate As Date

public DateTime ExpirationDate {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LicenseInfo Class
LicenseInfo Members


GraceEventLimit Property (LicenseInfo) | fcSDK Documentation

GraceEventLimit Property (LicenseInfo)

Syntax

'Declaration

Public ReadOnly Property GraceEventLimit As Integer

public int GraceEventLimit {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LicenseInfo Class
LicenseInfo Members


GraceEventsRemaining Property (LicenseInfo) | fcSDK Documentation

GraceEventsRemaining Property (LicenseInfo)

Syntax

'Declaration

Public ReadOnly Property GraceEventsRemaining As Integer

public int GraceEventsRemaining {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LicenseInfo Class
LicenseInfo Members


GraceLicensesRemaining Property (LicenseInfo) | fcSDK Documentation

GraceLicensesRemaining Property (LicenseInfo)

Syntax

'Declaration

Public ReadOnly Property GraceLicensesRemaining As Integer

public int GraceLicensesRemaining {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LicenseInfo Class
LicenseInfo Members


GraceLoginLimit Property (LicenseInfo) | fcSDK Documentation

GraceLoginLimit Property (LicenseInfo)

Syntax

'Declaration

Public ReadOnly Property GraceLoginLimit As Integer

public int GraceLoginLimit {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LicenseInfo Class
LicenseInfo Members


GraceTimeSpan Property (LicenseInfo) | fcSDK Documentation

GraceTimeSpan Property (LicenseInfo)

Syntax

'Declaration

Public ReadOnly Property GraceTimeSpan As GracePeriodTimeSpan

public GracePeriodTimeSpan GraceTimeSpan {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LicenseInfo Class
LicenseInfo Members


ProductId Property (LicenseInfo) | fcSDK Documentation

ProductId Property (LicenseInfo)

Syntax

'Declaration

Public ReadOnly Property ProductId As Integer

public int ProductId {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LicenseInfo Class
LicenseInfo Members


UserLicenseLimit Property (LicenseInfo) | fcSDK Documentation

UserLicenseLimit Property (LicenseInfo)

Syntax

'Declaration

Public ReadOnly Property UserLicenseLimit As Integer

public int UserLicenseLimit {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LicenseInfo Class
LicenseInfo Members


UserLicensesRemaining Property (LicenseInfo) | fcSDK Documentation

UserLicensesRemaining Property (LicenseInfo)

Syntax

'Declaration

Public ReadOnly Property UserLicensesRemaining As Integer

public int UserLicensesRemaining {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LicenseInfo Class
LicenseInfo Members


UserRestriction Property (LicenseInfo) | fcSDK Documentation

UserRestriction Property (LicenseInfo)

Syntax

'Declaration

Public ReadOnly Property UserRestriction As LicenseUserRestrictionType

public LicenseUserRestrictionType UserRestriction {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LicenseInfo Class
LicenseInfo Members


LicenseManager Class | fcSDK Documentation

LicenseManager Class

Singleton providing access to the current collection of valid First Choice licenses

Syntax

'Declaration

Public NotInheritable Class LicenseManager

public sealed class LicenseManager

Remarks

Please access the License Manager via the Instance property.

If multiple licenses for the same product are present the manager does its best to load the best license available (most available users, longest time until key is expired.)

If you install new licenses you will need to re-initialize your application to have the new licenses become available.

Inheritance Hierarchy

System.Object
FChoice.Common.Licensing.LicenseManager

Requirements

Namespace: FChoice.Common.Licensing

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

LicenseManager Members
FChoice.Common.Licensing Namespace


LicenseManager Class Members | fcSDK Documentation

LicenseManager Class Members

The following tables list the members exposed by LicenseManager.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Instance | Since this class is a Singleton you must use this property to call instance methods.
static (Shared in Visual Basic) | IsInitialized | True if the singleton has been initialized.

Public Methods

 | Name | Description
Public Method | GetAllLicenseInformation |
Public Method | GetAllLicenseInformationXml |
Public Method | GetLicenseInformation |
static (Shared in Visual Basic) | Initialize | Overloaded. License Manager is initialized automatically during application initialization.
Public Method | RefreshLicensing |
Public Method | ReleaseLicenses |
Public Method | ReserveLicense | Overloaded.
Public Method | VerifyLicense |

Reference

LicenseManager Class
FChoice.Common.Licensing Namespace


GetAllLicenseInformation Method | fcSDK Documentation

GetAllLicenseInformation Method

Syntax

'Declaration

Public Function GetAllLicenseInformation() As ILicenseInfo()

public ILicenseInfo[] GetAllLicenseInformation()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LicenseManager Class
LicenseManager Members


GetAllLicenseInformationXml Method | fcSDK Documentation

GetAllLicenseInformationXml Method

Syntax

'Declaration

Public Function GetAllLicenseInformationXml() As String

public string GetAllLicenseInformationXml()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LicenseManager Class
LicenseManager Members


GetLicenseInformation Method | fcSDK Documentation

GetLicenseInformation Method

Syntax

'Declaration

Public Function GetLicenseInformation( _
   ByVal _productId_ As Integer _
) As ILicenseInfo

public ILicenseInfo GetLicenseInformation(
   int _productId_
)

Parameters

productId

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LicenseManager Class
LicenseManager Members


Initialize Method (LicenseManager) | fcSDK Documentation

Initialize Method (LicenseManager)

License Manager is initialized automatically during application initialization.

Overload List

Overload | Description
Initialize() |
Initialize(ILicenseTool) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LicenseManager Class
LicenseManager Members


Initialize() Method | fcSDK Documentation

Initialize() Method

Syntax

'Declaration

Public Overloads Shared Sub Initialize()

public static void Initialize()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LicenseManager Class
LicenseManager Members
Overload List


Initialize(ILicenseTool) Method | fcSDK Documentation

Initialize(ILicenseTool) Method

Syntax

'Declaration

Public Overloads Shared Sub Initialize( _
   ByVal _licenseTool_ As ILicenseTool _
)

public static void Initialize(
   ILicenseTool _licenseTool_
)

Parameters

licenseTool

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LicenseManager Class
LicenseManager Members
Overload List


RefreshLicensing Method | fcSDK Documentation

RefreshLicensing Method

Syntax

'Declaration

Public Sub RefreshLicensing()

public void RefreshLicensing()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LicenseManager Class
LicenseManager Members


ReleaseLicenses Method | fcSDK Documentation

ReleaseLicenses Method

Syntax

'Declaration

Public Sub ReleaseLicenses( _
   ByVal _context_ As Object _
)

public void ReleaseLicenses(
   object _context_
)

Parameters

context

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LicenseManager Class
LicenseManager Members


ReserveLicense Method | fcSDK Documentation

ReserveLicense Method

Overload List

Overload | Description
ReserveLicense(Object,Int32) |
ReserveLicense(Object,Int32[]) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LicenseManager Class
LicenseManager Members


ReserveLicense(Object,Int32) Method | fcSDK Documentation

ReserveLicense(Object,Int32) Method

Syntax

'Declaration

Public Overloads Sub ReserveLicense( _
   ByVal _context_ As Object, _
   ByVal _productId_ As Integer _
)

public void ReserveLicense(
   object _context_,
   int _productId_
)

Parameters

context

productId

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LicenseManager Class
LicenseManager Members
Overload List


ReserveLicense(Object,Int32[]) Method | fcSDK Documentation

ReserveLicense(Object,Int32[]) Method

Syntax

'Declaration

Public Overloads Sub ReserveLicense( _
   ByVal _context_ As Object, _
   ByVal _productIds_() As Integer _
)

public void ReserveLicense(
   object _context_,
   int[] _productIds_
)

Parameters

context

productIds

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LicenseManager Class
LicenseManager Members
Overload List


VerifyLicense Method | fcSDK Documentation

VerifyLicense Method

Syntax

'Declaration

Public Function VerifyLicense( _
   ByVal _productId_ As Integer _
) As Boolean

public bool VerifyLicense(
   int _productId_
)

Parameters

productId

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LicenseManager Class
LicenseManager Members


Instance Property (LicenseManager) | fcSDK Documentation

Instance Property (LicenseManager)

Since this class is a Singleton you must use this property to call instance methods.

Syntax

'Declaration

Public Shared ReadOnly Property Instance As LicenseManager

public static LicenseManager Instance {get;}

Remarks

Please use this property to access the Licenses property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LicenseManager Class
LicenseManager Members


IsInitialized Property (LicenseManager) | fcSDK Documentation

IsInitialized Property (LicenseManager)

True if the singleton has been initialized.

Syntax

'Declaration

Public Shared ReadOnly Property IsInitialized As Boolean

public static bool IsInitialized {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LicenseManager Class
LicenseManager Members


XmlClarifyLicenseTool Class | fcSDK Documentation

XmlClarifyLicenseTool Class

Syntax

'Declaration

Public Class XmlClarifyLicenseTool
   Implements ILicenseTool

public class XmlClarifyLicenseTool : ILicenseTool

Inheritance Hierarchy

System.Object
FChoice.Common.Licensing.XmlClarifyLicenseTool

Requirements

Namespace: FChoice.Common.Licensing

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

XmlClarifyLicenseTool Members
FChoice.Common.Licensing Namespace


XmlClarifyLicenseTool Class Members | fcSDK Documentation

XmlClarifyLicenseTool Class Members

The following tables list the members exposed by XmlClarifyLicenseTool.

Public Constructors

 | Name | Description
Public Constructor | XmlClarifyLicenseTool Constructor |

Public Properties

 | Name | Description
Public Property | XmlFilePath |

Public Methods

 | Name | Description
Public Method | GraceEventInfo |
Public Method | LogGraceEvent |
Public Method | RetrieveLicenses |
Public Method | ValidateLockdownData |

Reference

XmlClarifyLicenseTool Class
FChoice.Common.Licensing Namespace


XmlClarifyLicenseTool Constructor | fcSDK Documentation

XmlClarifyLicenseTool Constructor

Syntax

'Declaration

Public Function New( _
   ByVal _xmlFilePath_ As String, _
   ByVal _dbProvider_ As DbProvider _
)

public XmlClarifyLicenseTool(
   string _xmlFilePath_,
   DbProvider _dbProvider_
)

Parameters

xmlFilePath

dbProvider

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

XmlClarifyLicenseTool Class
XmlClarifyLicenseTool Members


GraceEventInfo Method (XmlClarifyLicenseTool) | fcSDK Documentation

GraceEventInfo Method (XmlClarifyLicenseTool)

Syntax

'Declaration

Public Function GraceEventInfo( _
   ByVal _licenseKey_ As String _
) As Date()

public DateTime[] GraceEventInfo(
   string _licenseKey_
)

Parameters

licenseKey

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

XmlClarifyLicenseTool Class
XmlClarifyLicenseTool Members


LogGraceEvent Method (XmlClarifyLicenseTool) | fcSDK Documentation

LogGraceEvent Method (XmlClarifyLicenseTool)

Syntax

'Declaration

Public Sub LogGraceEvent( _
   ByVal _licenseKey_ As String _
)

public void LogGraceEvent(
   string _licenseKey_
)

Parameters

licenseKey

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

XmlClarifyLicenseTool Class
XmlClarifyLicenseTool Members


RetrieveLicenses Method (XmlClarifyLicenseTool) | fcSDK Documentation

RetrieveLicenses Method (XmlClarifyLicenseTool)

Syntax

'Declaration

Public Function RetrieveLicenses() As LicenseCollection

public LicenseCollection RetrieveLicenses()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

XmlClarifyLicenseTool Class
XmlClarifyLicenseTool Members


ValidateLockdownData Method (XmlClarifyLicenseTool) | fcSDK Documentation

ValidateLockdownData Method (XmlClarifyLicenseTool)

Syntax

'Declaration

Public Function ValidateLockdownData( _
   ByVal _lockdownData_ As String _
) As Boolean

public bool ValidateLockdownData(
   string _lockdownData_
)

Parameters

lockdownData

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

XmlClarifyLicenseTool Class
XmlClarifyLicenseTool Members


XmlFilePath Property (XmlClarifyLicenseTool) | fcSDK Documentation

XmlFilePath Property (XmlClarifyLicenseTool)

Syntax

'Declaration

Public ReadOnly Property XmlFilePath As String

public string XmlFilePath {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

XmlClarifyLicenseTool Class
XmlClarifyLicenseTool Members


XmlLicenseTool Class | fcSDK Documentation

XmlLicenseTool Class

Syntax

'Declaration

Public Class XmlLicenseTool
   Implements ILicenseTool

public class XmlLicenseTool : ILicenseTool

Inheritance Hierarchy

System.Object
FChoice.Common.Licensing.XmlLicenseTool

Requirements

Namespace: FChoice.Common.Licensing

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

XmlLicenseTool Members
FChoice.Common.Licensing Namespace


XmlLicenseTool Class Members | fcSDK Documentation

XmlLicenseTool Class Members

The following tables list the members exposed by XmlLicenseTool.

Public Constructors

 | Name | Description
Public Constructor | XmlLicenseTool Constructor |

Public Properties

 | Name | Description
Public Property | XmlFilePath |

Public Methods

 | Name | Description
Public Method | GraceEventInfo |
Public Method | LogGraceEvent |
Public Method | RetrieveLicenses |
Public Method | ValidateLockdownData |

Reference

XmlLicenseTool Class
FChoice.Common.Licensing Namespace


XmlLicenseTool Constructor | fcSDK Documentation

XmlLicenseTool Constructor

Syntax

'Declaration

Public Function New( _
   ByVal _xmlFilePath_ As String _
)

public XmlLicenseTool(
   string _xmlFilePath_
)

Parameters

xmlFilePath

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

XmlLicenseTool Class
XmlLicenseTool Members


GraceEventInfo Method (XmlLicenseTool) | fcSDK Documentation

GraceEventInfo Method (XmlLicenseTool)

Syntax

'Declaration

Public Function GraceEventInfo( _
   ByVal _licenseKey_ As String _
) As Date()

public DateTime[] GraceEventInfo(
   string _licenseKey_
)

Parameters

licenseKey

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

XmlLicenseTool Class
XmlLicenseTool Members


LogGraceEvent Method (XmlLicenseTool) | fcSDK Documentation

LogGraceEvent Method (XmlLicenseTool)

Syntax

'Declaration

Public Sub LogGraceEvent( _
   ByVal _licenseKey_ As String _
)

public void LogGraceEvent(
   string _licenseKey_
)

Parameters

licenseKey

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

XmlLicenseTool Class
XmlLicenseTool Members


RetrieveLicenses Method (XmlLicenseTool) | fcSDK Documentation

RetrieveLicenses Method (XmlLicenseTool)

Syntax

'Declaration

Public Function RetrieveLicenses() As LicenseCollection

public LicenseCollection RetrieveLicenses()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

XmlLicenseTool Class
XmlLicenseTool Members


ValidateLockdownData Method (XmlLicenseTool) | fcSDK Documentation

ValidateLockdownData Method (XmlLicenseTool)

Syntax

'Declaration

Public Function ValidateLockdownData( _
   ByVal _lockdownData_ As String _
) As Boolean

public bool ValidateLockdownData(
   string _lockdownData_
)

Parameters

lockdownData

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

XmlLicenseTool Class
XmlLicenseTool Members


XmlFilePath Property (XmlLicenseTool) | fcSDK Documentation

XmlFilePath Property (XmlLicenseTool)

Syntax

'Declaration

Public ReadOnly Property XmlFilePath As String

public string XmlFilePath {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

XmlLicenseTool Class
XmlLicenseTool Members


GracePeriodTimeSpan Enumeration | fcSDK Documentation

GracePeriodTimeSpan Enumeration

Syntax

'Declaration

Public Enum GracePeriodTimeSpan
   Inherits System.Enum

public enum GracePeriodTimeSpan : System.Enum

Members

Member | Description
Day |
Month |
Week |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
FChoice.Common.Licensing.GracePeriodTimeSpan

Requirements

Namespace: FChoice.Common.Licensing

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

FChoice.Common.Licensing Namespace


LicenseUserRestrictionType Enumeration | fcSDK Documentation

LicenseUserRestrictionType Enumeration

Syntax

'Declaration

Public Enum LicenseUserRestrictionType
   Inherits System.Enum

public enum LicenseUserRestrictionType : System.Enum

Members

Member | Description
ConcurrentUsers |
None |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
FChoice.Common.Licensing.LicenseUserRestrictionType

Requirements

Namespace: FChoice.Common.Licensing

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

FChoice.Common.Licensing Namespace


ILicenseInfo Interface | fcSDK Documentation

ILicenseInfo Interface

Syntax

'Declaration

Public Interface ILicenseInfo

public interface ILicenseInfo

Requirements

Namespace: FChoice.Common.Licensing

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

ILicenseInfo Members
FChoice.Common.Licensing Namespace


ILicenseInfo Interface Members | fcSDK Documentation

ILicenseInfo Interface Members

The following tables list the members exposed by ILicenseInfo.

Public Properties

 | Name | Description
Property | ExpirationDate |
Property | GraceEventLimit |
Property | GraceEventsRemaining |
Property | GraceLicensesRemaining |
Property | GraceLoginLimit |
Property | GraceTimeSpan |
Property | ProductId |
Property | UserLicenseLimit |
Property | UserLicensesRemaining |
Property | UserRestriction |

Reference

ILicenseInfo Interface
FChoice.Common.Licensing Namespace


ExpirationDate Property (ILicenseInfo) | fcSDK Documentation

ExpirationDate Property (ILicenseInfo)

Syntax

'Declaration

ReadOnly Property ExpirationDate As Date

DateTime ExpirationDate {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILicenseInfo Interface
ILicenseInfo Members


GraceEventLimit Property (ILicenseInfo) | fcSDK Documentation

GraceEventLimit Property (ILicenseInfo)

Syntax

'Declaration

ReadOnly Property GraceEventLimit As Integer

int GraceEventLimit {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILicenseInfo Interface
ILicenseInfo Members


GraceEventsRemaining Property (ILicenseInfo) | fcSDK Documentation

GraceEventsRemaining Property (ILicenseInfo)

Syntax

'Declaration
ReadOnly Property GraceEventsRemaining As Integer

int GraceEventsRemaining {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILicenseInfo Interface
ILicenseInfo Members


GraceLicensesRemaining Property (ILicenseInfo) | fcSDK Documentation

GraceLicensesRemaining Property (ILicenseInfo)

Syntax

'Declaration
ReadOnly Property GraceLicensesRemaining As Integer

int GraceLicensesRemaining {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILicenseInfo Interface
ILicenseInfo Members


GraceLoginLimit Property (ILicenseInfo) | fcSDK Documentation

GraceLoginLimit Property (ILicenseInfo)

Syntax

'Declaration

ReadOnly Property GraceLoginLimit As Integer

int GraceLoginLimit {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILicenseInfo Interface
ILicenseInfo Members


GraceTimeSpan Property (ILicenseInfo) | fcSDK Documentation

GraceTimeSpan Property (ILicenseInfo)

Syntax

'Declaration
ReadOnly Property GraceTimeSpan As GracePeriodTimeSpan

GracePeriodTimeSpan GraceTimeSpan {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILicenseInfo Interface
ILicenseInfo Members


ProductId Property (ILicenseInfo) | fcSDK Documentation

ProductId Property (ILicenseInfo)

Syntax

'Declaration
ReadOnly Property ProductId As Integer

int ProductId {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILicenseInfo Interface
ILicenseInfo Members


UserLicenseLimit Property (ILicenseInfo) | fcSDK Documentation

UserLicenseLimit Property (ILicenseInfo)

Syntax

'Declaration

ReadOnly Property UserLicenseLimit As Integer

int UserLicenseLimit {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILicenseInfo Interface
ILicenseInfo Members


UserLicensesRemaining Property (ILicenseInfo) | fcSDK Documentation

UserLicensesRemaining Property (ILicenseInfo)

Syntax

'Declaration
ReadOnly Property UserLicensesRemaining As Integer

int UserLicensesRemaining {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILicenseInfo Interface
ILicenseInfo Members


UserRestriction Property (ILicenseInfo) | fcSDK Documentation

UserRestriction Property (ILicenseInfo)

Syntax

'Declaration
ReadOnly Property UserRestriction As LicenseUserRestrictionType

LicenseUserRestrictionType UserRestriction {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILicenseInfo Interface
ILicenseInfo Members


ILicenseTool Interface | fcSDK Documentation

ILicenseTool Interface

Supports First Choice licensing.

Syntax

'Declaration

Public Interface ILicenseTool

public interface ILicenseTool

Remarks

For internal First Choice use only.

Requirements

Namespace: FChoice.Common.Licensing

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

ILicenseTool Members
FChoice.Common.Licensing Namespace


ILicenseTool Interface Members | fcSDK Documentation

ILicenseTool Interface Members

The following tables list the members exposed by ILicenseTool.

Public Methods

 | Name | Description
Method | GraceEventInfo | Returns details of the current state of GraceEvents for a given license
Method | LogGraceEvent | Logs the occurrence of a grace event.
Method | RetrieveLicenses |
Method | ValidateLockdownData | Validates lock down data.

Reference

ILicenseTool Interface
FChoice.Common.Licensing Namespace


GraceEventInfo Method (ILicenseTool) | fcSDK Documentation

GraceEventInfo Method (ILicenseTool)

Key that identifies a valid First Choice license.

Returns details of the current state of GraceEvents for a given license

Syntax

'Declaration

Function GraceEventInfo( _
   ByVal _licenseKey_ As String _
) As Date()

DateTime[] GraceEventInfo(
   string _licenseKey_
)

Parameters

licenseKey

Key that identifies a valid First Choice license.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILicenseTool Interface
ILicenseTool Members


LogGraceEvent Method (ILicenseTool) | fcSDK Documentation

LogGraceEvent Method (ILicenseTool)

Key that identifies a valid First Choice license.

Logs the occurrence of a grace event.

Syntax

'Declaration

Sub LogGraceEvent( _
   ByVal _licenseKey_ As String _
)

void LogGraceEvent(
   string _licenseKey_
)

Parameters

licenseKey

Key that identifies a valid First Choice license.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILicenseTool Interface
ILicenseTool Members


RetrieveLicenses Method (ILicenseTool) | fcSDK Documentation

RetrieveLicenses Method (ILicenseTool)

Syntax

'Declaration

Function RetrieveLicenses() As LicenseCollection

LicenseCollection RetrieveLicenses()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILicenseTool Interface
ILicenseTool Members


ValidateLockdownData Method (ILicenseTool) | fcSDK Documentation

ValidateLockdownData Method (ILicenseTool)

Lock down data used for licensing.

Validates lock down data.

Syntax

'Declaration
Function ValidateLockdownData( _
   ByVal _lockdownData_ As String _
) As Boolean

bool ValidateLockdownData(
   string _lockdownData_
)

Parameters

lockdownData

Lock down data used for licensing.

Return Value

Returns true only if lock down data is valid.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILicenseTool Interface
ILicenseTool Members


FChoice.Common.State Namespace | fcSDK Documentation

FChoice.Common.State Namespace

Classes

 | Class | Description
Class | MemoryStateManager |
Class | MsSqlStateManager |
Class | OracleStateManager |
Class | RemoteStateManager |
Class | StateManager |
Class | StateManagerException |
Class | StateManagerSectionHandler |

Interfaces

 | Interface | Description
Interface | IStateManager |

Reference

FChoice.Common Assembly


MemoryStateManager Class | fcSDK Documentation

MemoryStateManager Class

Syntax

'Declaration

Public Class MemoryStateManager
   Implements IStateManager

public class MemoryStateManager : IStateManager

Inheritance Hierarchy

System.Object
FChoice.Common.State.MemoryStateManager

Requirements

Namespace: FChoice.Common.State

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

MemoryStateManager Members
FChoice.Common.State Namespace


MemoryStateManager Class Members | fcSDK Documentation

MemoryStateManager Class Members

The following tables list the members exposed by MemoryStateManager.

Public Constructors

 | Name | Description
Public Constructor | MemoryStateManager Constructor |

Public Properties

 | Name | Description
Public Property | ApplicationName |
Public Property | IsStateSerialized |
Public Property | StateTimeout |

Public Methods

 | Name | Description
Public Method | GetApplicationStates | Overloaded.
Public Method | InitializeManager |
Public Method | InitializeState |
Public Method | IsStateExpired |
Public Method | LoadState |
Public Method | RemoveExpiredStates |
Public Method | RemoveState |
Public Method | ResetTimeout |
Public Method | SaveState | Overloaded.

Reference

MemoryStateManager Class
FChoice.Common.State Namespace


MemoryStateManager Constructor | fcSDK Documentation

MemoryStateManager Constructor

Syntax

'Declaration

Public Function New()

public MemoryStateManager()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MemoryStateManager Class
MemoryStateManager Members


GetApplicationStates Method (MemoryStateManager) | fcSDK Documentation

GetApplicationStates Method (MemoryStateManager)

Overload List

Overload | Description
GetApplicationStates() |
GetApplicationStates(Type) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MemoryStateManager Class
MemoryStateManager Members


GetApplicationStates() Method | fcSDK Documentation

GetApplicationStates() Method

Syntax

'Declaration

Public Overloads Function GetApplicationStates() As Object()

public object[] GetApplicationStates()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MemoryStateManager Class
MemoryStateManager Members
Overload List


GetApplicationStates(Type) Method | fcSDK Documentation

GetApplicationStates(Type) Method

Syntax

'Declaration

Public Overloads Function GetApplicationStates( _
   ByVal _stateType_ As Type _
) As Object()

public object[] GetApplicationStates(
   Type _stateType_
)

Parameters

stateType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MemoryStateManager Class
MemoryStateManager Members
Overload List


InitializeManager Method (MemoryStateManager) | fcSDK Documentation

InitializeManager Method (MemoryStateManager)

Syntax

'Declaration

Public Sub InitializeManager( _
   ByVal _applicationName_ As String, _
   ByVal _timeoutLength_ As TimeSpan, _
   ByVal _configNode_ As XmlNode _
)

public void InitializeManager(
   string _applicationName_,
   TimeSpan _timeoutLength_,
   XmlNode _configNode_
)

Parameters

applicationName

timeoutLength

configNode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MemoryStateManager Class
MemoryStateManager Members


InitializeState Method (MemoryStateManager) | fcSDK Documentation

InitializeState Method (MemoryStateManager)

Syntax

'Declaration

Public Sub InitializeState( _
   ByVal _id_ As Guid _
)

public void InitializeState(
   Guid _id_
)

Parameters

id

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MemoryStateManager Class
MemoryStateManager Members


IsStateExpired Method (MemoryStateManager) | fcSDK Documentation

IsStateExpired Method (MemoryStateManager)

Syntax

'Declaration

Public Function IsStateExpired( _
   ByVal _id_ As Guid _
) As Boolean

public bool IsStateExpired(
   Guid _id_
)

Parameters

id

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MemoryStateManager Class
MemoryStateManager Members


LoadState Method (MemoryStateManager) | fcSDK Documentation

LoadState Method (MemoryStateManager)

Syntax

'Declaration

Public Function LoadState( _
   ByVal _id_ As Guid, _
   ByVal _stateType_ As Type _
) As Object

public object LoadState(
   Guid _id_,
   Type _stateType_
)

Parameters

id

stateType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MemoryStateManager Class
MemoryStateManager Members


RemoveExpiredStates Method (MemoryStateManager) | fcSDK Documentation

RemoveExpiredStates Method (MemoryStateManager)

Syntax

'Declaration

Public Function RemoveExpiredStates() As Guid()

public Guid[] RemoveExpiredStates()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MemoryStateManager Class
MemoryStateManager Members


RemoveState Method (MemoryStateManager) | fcSDK Documentation

RemoveState Method (MemoryStateManager)

Syntax

'Declaration

Public Sub RemoveState( _
   ByVal _id_ As Guid _
)

public void RemoveState(
   Guid _id_
)

Parameters

id

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MemoryStateManager Class
MemoryStateManager Members


ResetTimeout Method (MemoryStateManager) | fcSDK Documentation

ResetTimeout Method (MemoryStateManager)

Syntax

'Declaration

Public Sub ResetTimeout( _
   ByVal _id_ As Guid _
)

public void ResetTimeout(
   Guid _id_
)

Parameters

id

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MemoryStateManager Class
MemoryStateManager Members


SaveState Method (MemoryStateManager) | fcSDK Documentation

SaveState Method (MemoryStateManager)

Overload List

Overload | Description
SaveState(Guid,Object) |
SaveState(Guid,Byte[]) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MemoryStateManager Class
MemoryStateManager Members


SaveState(Guid,Object) Method | fcSDK Documentation

SaveState(Guid,Object) Method

Syntax

'Declaration

Public Overloads Sub SaveState( _
   ByVal _id_ As Guid, _
   ByVal _state_ As Object _
)

public void SaveState(
   Guid _id_,
   object _state_
)

Parameters

id

state

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MemoryStateManager Class
MemoryStateManager Members
Overload List


SaveState(Guid,Byte[]) Method | fcSDK Documentation

SaveState(Guid,Byte[]) Method

Syntax

'Declaration

Public Overloads Sub SaveState( _
   ByVal _id_ As Guid, _
   ByVal _state_() As Byte _
)

public void SaveState(
   Guid _id_,
   byte[] _state_
)

Parameters

id

state

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MemoryStateManager Class
MemoryStateManager Members
Overload List


ApplicationName Property (MemoryStateManager) | fcSDK Documentation

ApplicationName Property (MemoryStateManager)

Syntax

'Declaration

Public Property ApplicationName As String

public string ApplicationName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MemoryStateManager Class
MemoryStateManager Members


IsStateSerialized Property (MemoryStateManager) | fcSDK Documentation

IsStateSerialized Property (MemoryStateManager)

Syntax

'Declaration

Public ReadOnly Property IsStateSerialized As Boolean

public bool IsStateSerialized {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MemoryStateManager Class
MemoryStateManager Members


StateTimeout Property (MemoryStateManager) | fcSDK Documentation

StateTimeout Property (MemoryStateManager)

Syntax

'Declaration

Public Property StateTimeout As TimeSpan

public TimeSpan StateTimeout {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MemoryStateManager Class
MemoryStateManager Members


MsSqlStateManager Class | fcSDK Documentation

MsSqlStateManager Class

Syntax

'Declaration

Public Class MsSqlStateManager
   Inherits RemoteStateManager
   Implements IStateManager

public class MsSqlStateManager : RemoteStateManager, IStateManager

Inheritance Hierarchy

System.Object
FChoice.Common.State.RemoteStateManager
FChoice.Common.State.MsSqlStateManager

Requirements

Namespace: FChoice.Common.State

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

MsSqlStateManager Members
FChoice.Common.State Namespace


MsSqlStateManager Class Members | fcSDK Documentation

MsSqlStateManager Class Members

The following tables list the members exposed by MsSqlStateManager.

Public Constructors

 | Name | Description
Public Constructor | MsSqlStateManager Constructor |

Public Properties

 | Name | Description
Public Property | ApplicationName | (Inherited from FChoice.Common.State.RemoteStateManager)
Public Property | ConnectionString | (Inherited from FChoice.Common.State.RemoteStateManager)
Public Property | IsStateSerialized | (Inherited from FChoice.Common.State.RemoteStateManager)
Public Property | Provider | (Inherited from FChoice.Common.State.RemoteStateManager)
Public Property | StateTimeout | (Inherited from FChoice.Common.State.RemoteStateManager)

Public Methods

 | Name | Description
Public Method | GetApplicationStates | Overloaded. (Inherited from FChoice.Common.State.RemoteStateManager)
Public Method | GetCurrentStates | Overridden.
Public Method | InitializeManager | (Inherited from FChoice.Common.State.RemoteStateManager)
Public Method | InitializeState | Overridden.
Public Method | IsStateExpired | Overridden.
Public Method | LoadState | Overloaded. Overridden.
Public Method | RemoveExpiredStates | Overridden.
Public Method | RemoveState | Overridden.
Public Method | ResetTimeout | Overridden.
Public Method | SaveState | Overloaded. Overridden.

Reference

MsSqlStateManager Class
FChoice.Common.State Namespace


MsSqlStateManager Constructor | fcSDK Documentation

MsSqlStateManager Constructor

Syntax

'Declaration

Public Function New()

public MsSqlStateManager()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MsSqlStateManager Class
MsSqlStateManager Members


GetCurrentStates Method (MsSqlStateManager) | fcSDK Documentation

GetCurrentStates Method (MsSqlStateManager)

Syntax

'Declaration

Public Overrides Function GetCurrentStates() As Object()

public override object[] GetCurrentStates()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MsSqlStateManager Class
MsSqlStateManager Members
Base Implementation in GetCurrentStates


InitializeState Method (MsSqlStateManager) | fcSDK Documentation

InitializeState Method (MsSqlStateManager)

Syntax

'Declaration

Public Overrides Sub InitializeState( _
   ByVal _id_ As Guid _
)

public override void InitializeState(
   Guid _id_
)

Parameters

id

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MsSqlStateManager Class
MsSqlStateManager Members
Base Implementation in InitializeState


IsStateExpired Method (MsSqlStateManager) | fcSDK Documentation

IsStateExpired Method (MsSqlStateManager)

Syntax

'Declaration

Public Overrides Function IsStateExpired( _
   ByVal _id_ As Guid _
) As Boolean

public override bool IsStateExpired(
   Guid _id_
)

Parameters

id

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MsSqlStateManager Class
MsSqlStateManager Members
Base Implementation in IsStateExpired


LoadState Method (MsSqlStateManager) | fcSDK Documentation

LoadState Method (MsSqlStateManager)

Overload List

Overload | Description
LoadState(Guid) |
LoadState(Guid,Type) | (Inherited from FChoice.Common.State.RemoteStateManager)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MsSqlStateManager Class
MsSqlStateManager Members
Base Implementation in LoadState


LoadState(Guid) Method | fcSDK Documentation

LoadState(Guid) Method

Syntax

'Declaration

Public Overloads Overrides Function LoadState( _
   ByVal _id_ As Guid _
) As Byte()

public override byte[] LoadState(
   Guid _id_
)

Parameters

id

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MsSqlStateManager Class
MsSqlStateManager Members
Overload List
Base Implementation in LoadState(Guid)


RemoveExpiredStates Method (MsSqlStateManager) | fcSDK Documentation

RemoveExpiredStates Method (MsSqlStateManager)

Syntax

'Declaration

Public Overrides Function RemoveExpiredStates() As Guid()

public override Guid[] RemoveExpiredStates()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MsSqlStateManager Class
MsSqlStateManager Members
Base Implementation in RemoveExpiredStates


RemoveState Method (MsSqlStateManager) | fcSDK Documentation

RemoveState Method (MsSqlStateManager)

Syntax

'Declaration

Public Overrides Sub RemoveState( _
   ByVal _id_ As Guid _
)

public override void RemoveState(
   Guid _id_
)

Parameters

id

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MsSqlStateManager Class
MsSqlStateManager Members
Base Implementation in RemoveState


ResetTimeout Method (MsSqlStateManager) | fcSDK Documentation

ResetTimeout Method (MsSqlStateManager)

Syntax

'Declaration

Public Overrides Sub ResetTimeout( _
   ByVal _id_ As Guid _
)

public override void ResetTimeout(
   Guid _id_
)

Parameters

id

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MsSqlStateManager Class
MsSqlStateManager Members
Base Implementation in ResetTimeout


SaveState Method (MsSqlStateManager) | fcSDK Documentation

SaveState Method (MsSqlStateManager)

Overload List

Overload | Description
SaveState(Guid,Byte[]) |
SaveState(Guid,Object) | (Inherited from FChoice.Common.State.RemoteStateManager)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MsSqlStateManager Class
MsSqlStateManager Members
Base Implementation in SaveState


SaveState(Guid,Byte[]) Method | fcSDK Documentation

SaveState(Guid,Byte[]) Method

Syntax

'Declaration

Public Overloads Overrides Sub SaveState( _
   ByVal _id_ As Guid, _
   ByVal _state_() As Byte _
)

public override void SaveState(
   Guid _id_,
   byte[] _state_
)

Parameters

id

state

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MsSqlStateManager Class
MsSqlStateManager Members
Overload List
Base Implementation in SaveState(Guid,Byte[])


OracleStateManager Class | fcSDK Documentation

OracleStateManager Class

Syntax

'Declaration

<ObsoleteAttribute("Remote state management support has been marked obsolete.")>
Public Class OracleStateManager
   Inherits RemoteStateManager
   Implements IStateManager

[ObsoleteAttribute("Remote state management support has been marked obsolete.")]
public class OracleStateManager : RemoteStateManager, IStateManager

Inheritance Hierarchy

System.Object
FChoice.Common.State.RemoteStateManager
FChoice.Common.State.OracleStateManager

Requirements

Namespace: FChoice.Common.State

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

OracleStateManager Members
FChoice.Common.State Namespace


OracleStateManager Class Members | fcSDK Documentation

OracleStateManager Class Members

The following tables list the members exposed by OracleStateManager.

Public Constructors

 | Name | Description
Public Constructor | OracleStateManager Constructor |

Public Properties

 | Name | Description
Public Property | ApplicationName | (Inherited from FChoice.Common.State.RemoteStateManager)
Public Property | ConnectionString | (Inherited from FChoice.Common.State.RemoteStateManager)
Public Property | IsStateSerialized | (Inherited from FChoice.Common.State.RemoteStateManager)
Public Property | Provider | (Inherited from FChoice.Common.State.RemoteStateManager)
Public Property | StateTimeout | (Inherited from FChoice.Common.State.RemoteStateManager)

Public Methods

 | Name | Description
Public Method | GetApplicationStates | Overloaded. (Inherited from FChoice.Common.State.RemoteStateManager)
Public Method | GetCurrentStates | Overridden.
Public Method | InitializeManager | (Inherited from FChoice.Common.State.RemoteStateManager)
Public Method | InitializeState | Overridden.
Public Method | IsStateExpired | Overridden.
Public Method | LoadState | Overloaded. Overridden.
Public Method | RemoveExpiredStates | Overridden.
Public Method | RemoveState | Overridden.
Public Method | ResetTimeout | Overridden.
Public Method | SaveState | Overloaded. Overridden.

Reference

OracleStateManager Class
FChoice.Common.State Namespace


OracleStateManager Constructor | fcSDK Documentation

OracleStateManager Constructor

Syntax

'Declaration

Public Function New()

public OracleStateManager()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OracleStateManager Class
OracleStateManager Members


GetCurrentStates Method (OracleStateManager) | fcSDK Documentation

GetCurrentStates Method (OracleStateManager)

Syntax

'Declaration

Public Overrides Function GetCurrentStates() As Object()

public override object[] GetCurrentStates()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OracleStateManager Class
OracleStateManager Members
Base Implementation in GetCurrentStates


InitializeState Method (OracleStateManager) | fcSDK Documentation

InitializeState Method (OracleStateManager)

Syntax

'Declaration

Public Overrides Sub InitializeState( _
   ByVal _id_ As Guid _
)

public override void InitializeState(
   Guid _id_
)

Parameters

id

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OracleStateManager Class
OracleStateManager Members
Base Implementation in InitializeState


IsStateExpired Method (OracleStateManager) | fcSDK Documentation

IsStateExpired Method (OracleStateManager)

Syntax

'Declaration

Public Overrides Function IsStateExpired( _
   ByVal _id_ As Guid _
) As Boolean

public override bool IsStateExpired(
   Guid _id_
)

Parameters

id

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OracleStateManager Class
OracleStateManager Members
Base Implementation in IsStateExpired


LoadState Method (OracleStateManager) | fcSDK Documentation

LoadState Method (OracleStateManager)

Overload List

Overload | Description
LoadState(Guid) |
LoadState(Guid,Type) | (Inherited from FChoice.Common.State.RemoteStateManager)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OracleStateManager Class
OracleStateManager Members
Base Implementation in LoadState


LoadState(Guid) Method | fcSDK Documentation

LoadState(Guid) Method

Syntax

'Declaration

Public Overloads Overrides Function LoadState( _
   ByVal _id_ As Guid _
) As Byte()

public override byte[] LoadState(
   Guid _id_
)

Parameters

id

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OracleStateManager Class
OracleStateManager Members
Overload List
Base Implementation in LoadState(Guid)


RemoveExpiredStates Method (OracleStateManager) | fcSDK Documentation

RemoveExpiredStates Method (OracleStateManager)

Syntax

'Declaration

Public Overrides Function RemoveExpiredStates() As Guid()

public override Guid[] RemoveExpiredStates()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OracleStateManager Class
OracleStateManager Members
Base Implementation in RemoveExpiredStates


RemoveState Method (OracleStateManager) | fcSDK Documentation

RemoveState Method (OracleStateManager)

Syntax

'Declaration

Public Overrides Sub RemoveState( _
   ByVal _id_ As Guid _
)

public override void RemoveState(
   Guid _id_
)

Parameters

id

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OracleStateManager Class
OracleStateManager Members
Base Implementation in RemoveState


ResetTimeout Method (OracleStateManager) | fcSDK Documentation

ResetTimeout Method (OracleStateManager)

Syntax

'Declaration

Public Overrides Sub ResetTimeout( _
   ByVal _id_ As Guid _
)

public override void ResetTimeout(
   Guid _id_
)

Parameters

id

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OracleStateManager Class
OracleStateManager Members
Base Implementation in ResetTimeout


SaveState Method (OracleStateManager) | fcSDK Documentation

SaveState Method (OracleStateManager)

Overload List

Overload | Description
SaveState(Guid,Byte[]) |
SaveState(Guid,Object) | (Inherited from FChoice.Common.State.RemoteStateManager)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OracleStateManager Class
OracleStateManager Members
Base Implementation in SaveState


SaveState(Guid,Byte[]) Method | fcSDK Documentation

SaveState(Guid,Byte[]) Method

Syntax

'Declaration

Public Overloads Overrides Sub SaveState( _
   ByVal _id_ As Guid, _
   ByVal _state_() As Byte _
)

public override void SaveState(
   Guid _id_,
   byte[] _state_
)

Parameters

id

state

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OracleStateManager Class
OracleStateManager Members
Overload List
Base Implementation in SaveState(Guid,Byte[])


RemoteStateManager Class | fcSDK Documentation

RemoteStateManager Class

Syntax

'Declaration

Public MustInherit Class RemoteStateManager
   Implements IStateManager

public abstract class RemoteStateManager : IStateManager

Inheritance Hierarchy

System.Object
FChoice.Common.State.RemoteStateManager
FChoice.Common.State.MsSqlStateManager
FChoice.Common.State.OracleStateManager

Requirements

Namespace: FChoice.Common.State

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

RemoteStateManager Members
FChoice.Common.State Namespace


RemoteStateManager Class Members | fcSDK Documentation

RemoteStateManager Class Members

The following tables list the members exposed by RemoteStateManager.

Public Properties

 | Name | Description
Public Property | ApplicationName |
Public Property | ConnectionString |
Public Property | IsStateSerialized |
Public Property | Provider |
Public Property | StateTimeout |

Public Methods

 | Name | Description
Public Method | GetApplicationStates | Overloaded.
Public Method | GetCurrentStates |
Public Method | InitializeManager |
Public Method | InitializeState |
Public Method | IsStateExpired |
Public Method | LoadState | Overloaded.
Public Method | RemoveExpiredStates |
Public Method | RemoveState |
Public Method | ResetTimeout |
Public Method | SaveState | Overloaded.

Reference

RemoteStateManager Class
FChoice.Common.State Namespace


GetApplicationStates Method (RemoteStateManager) | fcSDK Documentation

GetApplicationStates Method (RemoteStateManager)

Overload List

Overload | Description
GetApplicationStates() |
GetApplicationStates(Type) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RemoteStateManager Class
RemoteStateManager Members


GetApplicationStates() Method | fcSDK Documentation

GetApplicationStates() Method

Syntax

'Declaration

Public Overloads Function GetApplicationStates() As Object()

public object[] GetApplicationStates()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RemoteStateManager Class
RemoteStateManager Members
Overload List


GetApplicationStates(Type) Method | fcSDK Documentation

GetApplicationStates(Type) Method

Syntax

'Declaration

Public Overloads Function GetApplicationStates( _
   ByVal _stateType_ As Type _
) As Object()

public object[] GetApplicationStates(
   Type _stateType_
)

Parameters

stateType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RemoteStateManager Class
RemoteStateManager Members
Overload List


GetCurrentStates Method (RemoteStateManager) | fcSDK Documentation

GetCurrentStates Method (RemoteStateManager)

Syntax

'Declaration

Public MustOverride Function GetCurrentStates() As Object()

public abstract object[] GetCurrentStates()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RemoteStateManager Class
RemoteStateManager Members


InitializeManager Method (RemoteStateManager) | fcSDK Documentation

InitializeManager Method (RemoteStateManager)

Syntax

'Declaration

Public Sub InitializeManager( _
   ByVal _applicationName_ As String, _
   ByVal _timeoutLength_ As TimeSpan, _
   ByVal _configNode_ As XmlNode _
)

public void InitializeManager(
   string _applicationName_,
   TimeSpan _timeoutLength_,
   XmlNode _configNode_
)

Parameters

applicationName

timeoutLength

configNode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RemoteStateManager Class
RemoteStateManager Members


InitializeState Method (RemoteStateManager) | fcSDK Documentation

InitializeState Method (RemoteStateManager)

Syntax

'Declaration

Public MustOverride Sub InitializeState( _
   ByVal _id_ As Guid _
)

public abstract void InitializeState(
   Guid _id_
)

Parameters

id

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RemoteStateManager Class
RemoteStateManager Members


IsStateExpired Method (RemoteStateManager) | fcSDK Documentation

IsStateExpired Method (RemoteStateManager)

Syntax

'Declaration

Public MustOverride Function IsStateExpired( _
   ByVal _id_ As Guid _
) As Boolean

public abstract bool IsStateExpired(
   Guid _id_
)

Parameters

id

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RemoteStateManager Class
RemoteStateManager Members


LoadState Method (RemoteStateManager) | fcSDK Documentation

LoadState Method (RemoteStateManager)

Overload List

Overload | Description
LoadState(Guid) |
LoadState(Guid,Type) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RemoteStateManager Class
RemoteStateManager Members


LoadState(Guid) Method | fcSDK Documentation

LoadState(Guid) Method

Syntax

'Declaration

Public Overloads MustOverride Function LoadState( _
   ByVal _id_ As Guid _
) As Byte()

public abstract byte[] LoadState(
   Guid _id_
)

Parameters

id

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RemoteStateManager Class
RemoteStateManager Members
Overload List


LoadState(Guid,Type) Method | fcSDK Documentation

LoadState(Guid,Type) Method

Syntax

'Declaration

Public Overloads Function LoadState( _
   ByVal _id_ As Guid, _
   ByVal _stateType_ As Type _
) As Object

public object LoadState(
   Guid _id_,
   Type _stateType_
)

Parameters

id

stateType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RemoteStateManager Class
RemoteStateManager Members
Overload List


RemoveExpiredStates Method (RemoteStateManager) | fcSDK Documentation

RemoveExpiredStates Method (RemoteStateManager)

Syntax

'Declaration

Public MustOverride Function RemoveExpiredStates() As Guid()

public abstract Guid[] RemoveExpiredStates()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RemoteStateManager Class
RemoteStateManager Members


RemoveState Method (RemoteStateManager) | fcSDK Documentation

RemoveState Method (RemoteStateManager)

Syntax

'Declaration

Public MustOverride Sub RemoveState( _
   ByVal _id_ As Guid _
)

public abstract void RemoveState(
   Guid _id_
)

Parameters

id

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RemoteStateManager Class
RemoteStateManager Members


ResetTimeout Method (RemoteStateManager) | fcSDK Documentation

ResetTimeout Method (RemoteStateManager)

Syntax

'Declaration

Public MustOverride Sub ResetTimeout( _
   ByVal _id_ As Guid _
)

public abstract void ResetTimeout(
   Guid _id_
)

Parameters

id

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RemoteStateManager Class
RemoteStateManager Members


SaveState Method (RemoteStateManager) | fcSDK Documentation

SaveState Method (RemoteStateManager)

Overload List

Overload | Description
SaveState(Guid,Byte[]) |
SaveState(Guid,Object) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RemoteStateManager Class
RemoteStateManager Members


SaveState(Guid,Byte[]) Method | fcSDK Documentation

SaveState(Guid,Byte[]) Method

Syntax

'Declaration

Public Overloads MustOverride Sub SaveState( _
   ByVal _id_ As Guid, _
   ByVal _state_() As Byte _
)

public abstract void SaveState(
   Guid _id_,
   byte[] _state_
)

Parameters

id

state

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RemoteStateManager Class
RemoteStateManager Members
Overload List


SaveState(Guid,Object) Method | fcSDK Documentation

SaveState(Guid,Object) Method

Syntax

'Declaration

Public Overloads Sub SaveState( _
   ByVal _id_ As Guid, _
   ByVal _state_ As Object _
)

public void SaveState(
   Guid _id_,
   object _state_
)

Parameters

id

state

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RemoteStateManager Class
RemoteStateManager Members
Overload List


ApplicationName Property (RemoteStateManager) | fcSDK Documentation

ApplicationName Property (RemoteStateManager)

Syntax

'Declaration

Public Property ApplicationName As String

public string ApplicationName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RemoteStateManager Class
RemoteStateManager Members


ConnectionString Property (RemoteStateManager) | fcSDK Documentation

ConnectionString Property (RemoteStateManager)

Syntax

'Declaration

Public ReadOnly Property ConnectionString As String

public string ConnectionString {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RemoteStateManager Class
RemoteStateManager Members


IsStateSerialized Property (RemoteStateManager) | fcSDK Documentation

IsStateSerialized Property (RemoteStateManager)

Syntax

'Declaration

Public ReadOnly Property IsStateSerialized As Boolean

public bool IsStateSerialized {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RemoteStateManager Class
RemoteStateManager Members


Provider Property (RemoteStateManager) | fcSDK Documentation

Provider Property (RemoteStateManager)

Syntax

'Declaration

Public ReadOnly Property Provider As DbProvider

public DbProvider Provider {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RemoteStateManager Class
RemoteStateManager Members


StateTimeout Property (RemoteStateManager) | fcSDK Documentation

StateTimeout Property (RemoteStateManager)

Syntax

'Declaration

Public Property StateTimeout As TimeSpan

public TimeSpan StateTimeout {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RemoteStateManager Class
RemoteStateManager Members


StateManager Class | fcSDK Documentation

StateManager Class

Syntax

'Declaration

Public NotInheritable Class StateManager

public sealed class StateManager

Inheritance Hierarchy

System.Object
FChoice.Common.State.StateManager

Requirements

Namespace: FChoice.Common.State

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

StateManager Members
FChoice.Common.State Namespace


StateManager Class Members | fcSDK Documentation

StateManager Class Members

The following tables list the members exposed by StateManager.

Public Fields

 | Name | Description
Public Field | CONFIGURATION_SECTION_NAME |
Public Field | DEFAULT_APPLICATION_NAME |
static (Shared in Visual Basic) | SyncRoot |

Public Properties

 | Name | Description
static (Shared in Visual Basic) | ApplicationName |
static (Shared in Visual Basic) | IsStateSerialized |
static (Shared in Visual Basic) | StateTimeout |

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetApplicationStates | Overloaded.
static (Shared in Visual Basic) | Initialize |
static (Shared in Visual Basic) | InitializeState |
static (Shared in Visual Basic) | IsStateExpired |
static (Shared in Visual Basic) | LoadState | Overloaded.
static (Shared in Visual Basic) | RemoveExpiredStates |
static (Shared in Visual Basic) | RemoveState |
static (Shared in Visual Basic) | ResetTimeout |
static (Shared in Visual Basic) | SaveState | Overloaded.

Reference

StateManager Class
FChoice.Common.State Namespace


GetApplicationStates Method (StateManager) | fcSDK Documentation

GetApplicationStates Method (StateManager)

Overload List

Overload | Description
GetApplicationStates() |
GetApplicationStates(Type) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StateManager Class
StateManager Members


GetApplicationStates() Method | fcSDK Documentation

GetApplicationStates() Method

Syntax

'Declaration

Public Overloads Shared Function GetApplicationStates() As Object()

public static object[] GetApplicationStates()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StateManager Class
StateManager Members
Overload List


GetApplicationStates(Type) Method | fcSDK Documentation

GetApplicationStates(Type) Method

Syntax

'Declaration

Public Overloads Shared Function GetApplicationStates( _
   ByVal _stateType_ As Type _
) As Object()

public static object[] GetApplicationStates(
   Type _stateType_
)

Parameters

stateType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StateManager Class
StateManager Members
Overload List


Initialize Method (StateManager) | fcSDK Documentation

Initialize Method (StateManager)

Syntax

'Declaration

Public Shared Sub Initialize()

public static void Initialize()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StateManager Class
StateManager Members


InitializeState Method (StateManager) | fcSDK Documentation

InitializeState Method (StateManager)

Syntax

'Declaration

Public Shared Sub InitializeState( _
   ByVal _id_ As Guid _
)

public static void InitializeState(
   Guid _id_
)

Parameters

id

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StateManager Class
StateManager Members


IsStateExpired Method (StateManager) | fcSDK Documentation

IsStateExpired Method (StateManager)

Syntax

'Declaration

Public Shared Function IsStateExpired( _
   ByVal _id_ As Guid _
) As Boolean

public static bool IsStateExpired(
   Guid _id_
)

Parameters

id

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StateManager Class
StateManager Members


LoadState Method (StateManager) | fcSDK Documentation

LoadState Method (StateManager)

Overload List

Overload | Description
LoadState(Guid) |
LoadState(Guid,Type) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StateManager Class
StateManager Members


LoadState(Guid) Method | fcSDK Documentation

LoadState(Guid) Method

Syntax

'Declaration

Public Overloads Shared Function LoadState( _
   ByVal _id_ As Guid _
) As Byte()

public static byte[] LoadState(
   Guid _id_
)

Parameters

id

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StateManager Class
StateManager Members
Overload List


LoadState(Guid,Type) Method | fcSDK Documentation

LoadState(Guid,Type) Method

Syntax

'Declaration

Public Overloads Shared Function LoadState( _
   ByVal _id_ As Guid, _
   ByVal _stateType_ As Type _
) As Object

public static object LoadState(
   Guid _id_,
   Type _stateType_
)

Parameters

id

stateType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StateManager Class
StateManager Members
Overload List


RemoveExpiredStates Method (StateManager) | fcSDK Documentation

RemoveExpiredStates Method (StateManager)

Syntax

'Declaration

Public Shared Function RemoveExpiredStates() As Guid()

public static Guid[] RemoveExpiredStates()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StateManager Class
StateManager Members


RemoveState Method (StateManager) | fcSDK Documentation

RemoveState Method (StateManager)

Syntax

'Declaration

Public Shared Sub RemoveState( _
   ByVal _id_ As Guid _
)

public static void RemoveState(
   Guid _id_
)

Parameters

id

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StateManager Class
StateManager Members


ResetTimeout Method (StateManager) | fcSDK Documentation

ResetTimeout Method (StateManager)

Syntax

'Declaration

Public Shared Sub ResetTimeout( _
   ByVal _id_ As Guid _
)

public static void ResetTimeout(
   Guid _id_
)

Parameters

id

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StateManager Class
StateManager Members


SaveState Method (StateManager) | fcSDK Documentation

SaveState Method (StateManager)

Overload List

Overload | Description
SaveState(Guid,Byte[]) |
SaveState(Guid,Object) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StateManager Class
StateManager Members


SaveState(Guid,Byte[]) Method | fcSDK Documentation

SaveState(Guid,Byte[]) Method

Syntax

'Declaration

Public Overloads Shared Sub SaveState( _
   ByVal _id_ As Guid, _
   ByVal _state_() As Byte _
)

public static void SaveState(
   Guid _id_,
   byte[] _state_
)

Parameters

id

state

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StateManager Class
StateManager Members
Overload List


SaveState(Guid,Object) Method | fcSDK Documentation

SaveState(Guid,Object) Method

Syntax

'Declaration

Public Overloads Shared Sub SaveState( _
   ByVal _id_ As Guid, _
   ByVal _state_ As Object _
)

public static void SaveState(
   Guid _id_,
   object _state_
)

Parameters

id

state

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StateManager Class
StateManager Members
Overload List


ApplicationName Property (StateManager) | fcSDK Documentation

ApplicationName Property (StateManager)

Syntax

'Declaration

Public Shared ReadOnly Property ApplicationName As String

public static string ApplicationName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StateManager Class
StateManager Members


IsStateSerialized Property (StateManager) | fcSDK Documentation

IsStateSerialized Property (StateManager)

Syntax

'Declaration

Public Shared ReadOnly Property IsStateSerialized As Boolean

public static bool IsStateSerialized {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StateManager Class
StateManager Members


StateTimeout Property (StateManager) | fcSDK Documentation

StateTimeout Property (StateManager)

Syntax

'Declaration

Public Shared Property StateTimeout As TimeSpan

public static TimeSpan StateTimeout {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StateManager Class
StateManager Members


CONFIGURATION_SECTION_NAME Field (StateManager) | fcSDK Documentation

CONFIGURATION_SECTION_NAME Field (StateManager)

Syntax

'Declaration

Public Const CONFIGURATION_SECTION_NAME As String

public const string CONFIGURATION_SECTION_NAME

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StateManager Class
StateManager Members


DEFAULT_APPLICATION_NAME Field | fcSDK Documentation

DEFAULT_APPLICATION_NAME Field

DEFAULT_APPLICATION_NAME Field

Syntax

'Declaration

Public Const DEFAULT_APPLICATION_NAME As String

public const string DEFAULT_APPLICATION_NAME

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StateManager Class
StateManager Members


SyncRoot Field (StateManager) | fcSDK Documentation

SyncRoot Field (StateManager)

Syntax

'Declaration

Public Shared ReadOnly SyncRoot As Object

public static readonly object SyncRoot

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StateManager Class
StateManager Members


StateManagerException Class | fcSDK Documentation

StateManagerException Class

Syntax

'Declaration

<SerializableAttribute()>
Public Class StateManagerException
   Inherits FChoice.Common.FCExceptionBase

[SerializableAttribute()]
public class StateManagerException : FChoice.Common.FCExceptionBase

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
FChoice.Common.FCExceptionBase
FChoice.Common.State.StateManagerException

Requirements

Namespace: FChoice.Common.State

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

StateManagerException Members
FChoice.Common.State Namespace


StateManagerException Class Members | fcSDK Documentation

StateManagerException Class Members

The following tables list the members exposed by StateManagerException.

Public Constructors

 | Name | Description
Public Constructor | StateManagerException Constructor | Overloaded.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorCode | Gets the unique error code for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | ErrorMessageID | Gets the message identifier for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | Sets the SerializationInfo object with the parameter name and additional exception information. (Inherited from FChoice.Common.FCExceptionBase)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)

Reference

StateManagerException Class
FChoice.Common.State Namespace


StateManagerException Constructor | fcSDK Documentation

StateManagerException Constructor

Overload List

Overload | Description
StateManagerException Constructor(Int32,String,Object[]) |
StateManagerException Constructor(Exception,Int32,String,Object[]) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StateManagerException Class
StateManagerException Members


StateManagerException Constructor(Int32,String,Object[]) | fcSDK Documentation

StateManagerException Constructor(Int32,String,Object[])

Syntax

'Declaration

Public Function New( _
   ByVal _errorId_ As Integer, _
   ByVal _messageId_ As String, _
   ByVal ParamArray _args_() As Object _
)

public StateManagerException(
   int _errorId_,
   string _messageId_,
   params object[] _args_
)

Parameters

errorId

messageId

args

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StateManagerException Class
StateManagerException Members
Overload List


StateManagerException Constructor(Exception,Int32,String,Object[]) | fcSDK Documentation

StateManagerException Constructor(Exception,Int32,String,Object[])

Syntax

'Declaration

Public Function New( _
   ByVal _innerEx_ As Exception, _
   ByVal _errorId_ As Integer, _
   ByVal _messageId_ As String, _
   ByVal ParamArray _args_() As Object _
)

public StateManagerException(
   Exception _innerEx_,
   int _errorId_,
   string _messageId_,
   params object[] _args_
)

Parameters

innerEx

errorId

messageId

args

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StateManagerException Class
StateManagerException Members
Overload List


StateManagerSectionHandler Class | fcSDK Documentation

StateManagerSectionHandler Class

Syntax

'Declaration

Public Class StateManagerSectionHandler

public class StateManagerSectionHandler

Inheritance Hierarchy

System.Object
FChoice.Common.State.StateManagerSectionHandler

Requirements

Namespace: FChoice.Common.State

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

StateManagerSectionHandler Members
FChoice.Common.State Namespace


StateManagerSectionHandler Class Members | fcSDK Documentation

StateManagerSectionHandler Class Members

The following tables list the members exposed by StateManagerSectionHandler.

Public Constructors

 | Name | Description
Public Constructor | StateManagerSectionHandler Constructor |

Public Methods

 | Name | Description
Public Method | Create |

Reference

StateManagerSectionHandler Class
FChoice.Common.State Namespace


StateManagerSectionHandler Constructor | fcSDK Documentation

StateManagerSectionHandler Constructor

Syntax

'Declaration

Public Function New()

public StateManagerSectionHandler()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StateManagerSectionHandler Class
StateManagerSectionHandler Members


Create Method (StateManagerSectionHandler) | fcSDK Documentation

Create Method (StateManagerSectionHandler)

Syntax

'Declaration

Public Function Create( _
   ByVal _parent_ As Object, _
   ByVal _configContext_ As Object, _
   ByVal _section_ As XmlNode _
) As Object

public object Create(
   object _parent_,
   object _configContext_,
   XmlNode _section_
)

Parameters

parent

configContext

section

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StateManagerSectionHandler Class
StateManagerSectionHandler Members


IStateManager Interface | fcSDK Documentation

IStateManager Interface

Syntax

'Declaration

Public Interface IStateManager

public interface IStateManager

Requirements

Namespace: FChoice.Common.State

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Common (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Common.dll)

Reference

IStateManager Members
FChoice.Common.State Namespace


IStateManager Interface Members | fcSDK Documentation

IStateManager Interface Members

The following tables list the members exposed by IStateManager.

Public Properties

 | Name | Description
Property | ApplicationName |
Property | IsStateSerialized |
Property | StateTimeout |

Public Methods

 | Name | Description
Method | GetApplicationStates | Overloaded.
Method | InitializeManager |
Method | InitializeState |
Method | IsStateExpired |
Method | LoadState | Overloaded.
Method | RemoveExpiredStates |
Method | RemoveState |
Method | ResetTimeout |
Method | SaveState | Overloaded.

Reference

IStateManager Interface
FChoice.Common.State Namespace


GetApplicationStates Method (IStateManager) | fcSDK Documentation

GetApplicationStates Method (IStateManager)

Overload List

Overload | Description
GetApplicationStates() |
GetApplicationStates(Type) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStateManager Interface
IStateManager Members


GetApplicationStates() Method | fcSDK Documentation

GetApplicationStates() Method

Syntax

'Declaration

Overloads Function GetApplicationStates() As Object()

object[] GetApplicationStates()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStateManager Interface
IStateManager Members
Overload List


GetApplicationStates(Type) Method | fcSDK Documentation

GetApplicationStates(Type) Method

Syntax

'Declaration

Overloads Function GetApplicationStates( _
   ByVal _stateType_ As Type _
) As Object()

object[] GetApplicationStates(
   Type _stateType_
)

Parameters

stateType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStateManager Interface
IStateManager Members
Overload List


InitializeManager Method (IStateManager) | fcSDK Documentation

InitializeManager Method (IStateManager)

Syntax

'Declaration

Sub InitializeManager( _
   ByVal _applicationName_ As String, _
   ByVal _timeoutLength_ As TimeSpan, _
   ByVal _configNode_ As XmlNode _
)

void InitializeManager(
   string _applicationName_,
   TimeSpan _timeoutLength_,
   XmlNode _configNode_
)

Parameters

applicationName

timeoutLength

configNode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStateManager Interface
IStateManager Members


InitializeState Method (IStateManager) | fcSDK Documentation

InitializeState Method (IStateManager)

Syntax

'Declaration

Sub InitializeState( _
   ByVal _id_ As Guid _
)

void InitializeState(
   Guid _id_
)

Parameters

id

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStateManager Interface
IStateManager Members


IsStateExpired Method (IStateManager) | fcSDK Documentation

IsStateExpired Method (IStateManager)

Syntax

'Declaration

Function IsStateExpired( _
   ByVal _id_ As Guid _
) As Boolean

bool IsStateExpired(
   Guid _id_
)

Parameters

id

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStateManager Interface
IStateManager Members


LoadState Method (IStateManager) | fcSDK Documentation

LoadState Method (IStateManager)

Overload List

Overload | Description
LoadState(Guid) |
LoadState(Guid,Type) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStateManager Interface
IStateManager Members


LoadState(Guid) Method | fcSDK Documentation

LoadState(Guid) Method

Syntax

'Declaration

Overloads Function LoadState( _
   ByVal _id_ As Guid _
) As Byte()

byte[] LoadState(
   Guid _id_
)

Parameters

id

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStateManager Interface
IStateManager Members
Overload List


LoadState(Guid,Type) Method | fcSDK Documentation

LoadState(Guid,Type) Method

Syntax

'Declaration

Overloads Function LoadState( _
   ByVal _id_ As Guid, _
   ByVal _stateType_ As Type _
) As Object

object LoadState(
   Guid _id_,
   Type _stateType_
)

Parameters

id

stateType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStateManager Interface
IStateManager Members
Overload List


RemoveExpiredStates Method (IStateManager) | fcSDK Documentation

RemoveExpiredStates Method (IStateManager)

Syntax

'Declaration

Function RemoveExpiredStates() As Guid()

Guid[] RemoveExpiredStates()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStateManager Interface
IStateManager Members


RemoveState Method (IStateManager) | fcSDK Documentation

RemoveState Method (IStateManager)

Syntax

'Declaration

Sub RemoveState( _
   ByVal _id_ As Guid _
)

void RemoveState(
   Guid _id_
)

Parameters

id

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStateManager Interface
IStateManager Members


ResetTimeout Method (IStateManager) | fcSDK Documentation

ResetTimeout Method (IStateManager)

Syntax

'Declaration

Sub ResetTimeout( _
   ByVal _id_ As Guid _
)

void ResetTimeout(
   Guid _id_
)

Parameters

id

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStateManager Interface
IStateManager Members


SaveState Method (IStateManager) | fcSDK Documentation

SaveState Method (IStateManager)

Overload List

Overload | Description
SaveState(Guid,Byte[]) |
SaveState(Guid,Object) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStateManager Interface
IStateManager Members


SaveState(Guid,Byte[]) Method | fcSDK Documentation

SaveState(Guid,Byte[]) Method

Syntax

'Declaration

Overloads Sub SaveState( _
   ByVal _id_ As Guid, _
   ByVal _state_() As Byte _
)

void SaveState(
   Guid _id_,
   byte[] _state_
)

Parameters

id

state

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStateManager Interface
IStateManager Members
Overload List


SaveState(Guid,Object) Method | fcSDK Documentation

SaveState(Guid,Object) Method

Syntax

'Declaration

Overloads Sub SaveState( _
   ByVal _id_ As Guid, _
   ByVal _state_ As Object _
)

void SaveState(
   Guid _id_,
   object _state_
)

Parameters

id

state

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStateManager Interface
IStateManager Members
Overload List


ApplicationName Property (IStateManager) | fcSDK Documentation

ApplicationName Property (IStateManager)

Syntax

'Declaration

Property ApplicationName As String

string ApplicationName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStateManager Interface
IStateManager Members


IsStateSerialized Property (IStateManager) | fcSDK Documentation

IsStateSerialized Property (IStateManager)

Syntax

'Declaration

ReadOnly Property IsStateSerialized As Boolean

bool IsStateSerialized {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStateManager Interface
IStateManager Members


StateTimeout Property (IStateManager) | fcSDK Documentation

StateTimeout Property (IStateManager)

Syntax

'Declaration

Property StateTimeout As TimeSpan

TimeSpan StateTimeout {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStateManager Interface
IStateManager Members


FChoice.Foundation Namespace | fcSDK Documentation

FChoice.Foundation Namespace

Base implementation of core CRM capabilities.

Classes

 | Class | Description
Class | CacheBase |
Class | CacheManager |
Class | CacheSectionHandler |
Class | CustomCache |
Class | DataFieldNameCollection |
Class | DictionaryExtensions |
Class | FCApplication |
Class | FCGeneric | Provides core CRM business logic and managed access to data.
Class | FCInvalidLoginException | Thrown when credentials for a Session cannot be authenticated
Class | FCSession | FCSession contains session information for a logged-in user and allows for manipulation of data in the CRM system as that user.
Class | FCSessionData | Repository for session data which is retained by the FCApplication between session uses.
Class | FCSessionSummary | Represents a summary view of the session for reporting purposes.
Class | FoundationException | The exception that is thrown when an error occurs in Foundation.
Class | GenericDataRow | Represents a row of data in a GenericDataTable.
Class | GenericDataRowCollection | Represents a collection of rows for a GenericDataTable.
Class | GenericDataSet |
Class | GenericDataTable | Provides a Generic with data storage that integrates with DataSets.
Class | GenericException | The exception that is thrown when an error occurs in the Generic classes in Foundation.
Class | MaximumRowsExceededEventArgs | Delegates handling the MaximumRowsExceeded event will return this object to cue FCGeneric on how to handle large queries.
Class | RelationNameCollection | Collection of Relations
Class | ValidatedNameCollection |

Delegates

 | Delegate | Description
Delegate | CacheLoadedEventHandler |
Delegate | CachesUpdatedEventHandler |
Delegate | MaximumRowsExceededEventHandler |

Enumerations

 | Enumeration | Description
Enumeration | CacheType |
Enumeration | DateOps | Valid date filtering operations for methods such as AppendFilter.
Enumeration | NumberOps | Valid numeric filtering operations for methods such as AppendFilter.
Enumeration | StringOps | Valid string filtering operations for methods such as AppendFilter.

Reference

fcSDK Assembly


CacheBase Class | fcSDK Documentation

CacheBase Class

Syntax

'Declaration

Public MustInherit Class CacheBase

public abstract class CacheBase

Inheritance Hierarchy

System.Object
FChoice.Foundation.CacheBase
FChoice.Foundation.Clarify.ClarifyCacheBase
FChoice.Foundation.CustomCache

Requirements

Namespace: FChoice.Foundation

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

CacheBase Members
FChoice.Foundation Namespace


CacheBase Class Members | fcSDK Documentation

CacheBase Class Members

The following tables list the members exposed by CacheBase.

Public Properties

 | Name | Description
Public Property | CacheSetName |
Public Property | CacheType |

Public Methods

 | Name | Description
Public Method | UpdateCache |

Public Events

 | Name | Description
Public Event | AnyCacheUpdated |
Public Event | CacheUpdated |

Reference

CacheBase Class
FChoice.Foundation Namespace


UpdateCache Method (CacheBase) | fcSDK Documentation

UpdateCache Method (CacheBase)

Syntax

'Declaration

Public Overridable Sub UpdateCache()

public virtual void UpdateCache()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CacheBase Class
CacheBase Members


CacheSetName Property (CacheBase) | fcSDK Documentation

CacheSetName Property (CacheBase)

Syntax

'Declaration

Public MustOverride ReadOnly Property CacheSetName As String

public abstract string CacheSetName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CacheBase Class
CacheBase Members


CacheType Property (CacheBase) | fcSDK Documentation

CacheType Property (CacheBase)

Syntax

'Declaration

Public MustOverride ReadOnly Property CacheType As CacheType

public abstract CacheType CacheType {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CacheBase Class
CacheBase Members


AnyCacheUpdated Event | fcSDK Documentation

AnyCacheUpdated Event

Syntax

'Declaration

Public Event AnyCacheUpdated As EventHandler

public event EventHandler AnyCacheUpdated

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CacheBase Class
CacheBase Members


CacheUpdated Event (CacheBase) | fcSDK Documentation

CacheUpdated Event (CacheBase)

Syntax

'Declaration

Public Event CacheUpdated As EventHandler

public event EventHandler CacheUpdated

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CacheBase Class
CacheBase Members


CacheManager Class | fcSDK Documentation

CacheManager Class

Syntax

'Declaration

Public Class CacheManager

public class CacheManager

Inheritance Hierarchy

System.Object
FChoice.Foundation.CacheManager

Requirements

Namespace: FChoice.Foundation

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

CacheManager Members
FChoice.Foundation Namespace


CacheManager Class Members | fcSDK Documentation

CacheManager Class Members

The following tables list the members exposed by CacheManager.

Public Fields

 | Name | Description
Public Field | FC_CACHE_PATH_SUFFIX |

Public Properties

 | Name | Description
static (Shared in Visual Basic) | CacheFilePath |
static (Shared in Visual Basic) | ConnectionStringHashValue |
static (Shared in Visual Basic) | IsInitialized |
static (Shared in Visual Basic) | SchemaCache |

Public Methods

 | Name | Description
static (Shared in Visual Basic) | AddCache |
static (Shared in Visual Basic) | GetCache |
static (Shared in Visual Basic) | UpdateCaches |

Public Events

 | Name | Description
Public Event | CacheLoaded |
Public Event | CachesUpdated |

Reference

CacheManager Class
FChoice.Foundation Namespace


AddCache Method | fcSDK Documentation

AddCache Method

Syntax

'Declaration

Public Shared Sub AddCache( _
   ByVal _cache_ As CacheBase _
)

public static void AddCache(
   CacheBase _cache_
)

Parameters

cache

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CacheManager Class
CacheManager Members


GetCache Method | fcSDK Documentation

GetCache Method

Syntax

'Declaration

Public Shared Function GetCache( _
   ByVal _name_ As String _
) As CacheBase

public static CacheBase GetCache(
   string _name_
)

Parameters

name

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CacheManager Class
CacheManager Members


UpdateCaches Method | fcSDK Documentation

UpdateCaches Method

Syntax

'Declaration

Public Shared Sub UpdateCaches( _
   ByVal _cacheType_ As CacheType _
)

public static void UpdateCaches(
   CacheType _cacheType_
)

Parameters

cacheType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CacheManager Class
CacheManager Members


CacheFilePath Property | fcSDK Documentation

CacheFilePath Property

Syntax

'Declaration

Public Shared ReadOnly Property CacheFilePath As String

public static string CacheFilePath {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CacheManager Class
CacheManager Members


ConnectionStringHashValue Property | fcSDK Documentation

ConnectionStringHashValue Property

Syntax

'Declaration

Public Shared ReadOnly Property ConnectionStringHashValue As String

public static string ConnectionStringHashValue {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CacheManager Class
CacheManager Members


IsInitialized Property (CacheManager) | fcSDK Documentation

IsInitialized Property (CacheManager)

Syntax

'Declaration

Public Shared ReadOnly Property IsInitialized As Boolean

public static bool IsInitialized {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CacheManager Class
CacheManager Members


SchemaCache Property (CacheManager) | fcSDK Documentation

SchemaCache Property (CacheManager)

Syntax

'Declaration

Public Shared ReadOnly Property SchemaCache As ISchemaCache

public static ISchemaCache SchemaCache {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CacheManager Class
CacheManager Members


FC_CACHE_PATH_SUFFIX Field | fcSDK Documentation

FC_CACHE_PATH_SUFFIX Field

Syntax

'Declaration

Public Const FC_CACHE_PATH_SUFFIX As String

public const string FC_CACHE_PATH_SUFFIX

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CacheManager Class
CacheManager Members


CacheLoaded Event | fcSDK Documentation

CacheLoaded Event

Syntax

'Declaration

Public Event CacheLoaded As CacheLoadedEventHandler

public event CacheLoadedEventHandler CacheLoaded

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CacheManager Class
CacheManager Members


CachesUpdated Event | fcSDK Documentation

CachesUpdated Event

Syntax

'Declaration

Public Event CachesUpdated As CachesUpdatedEventHandler

public event CachesUpdatedEventHandler CachesUpdated

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CacheManager Class
CacheManager Members


CacheSectionHandler Class | fcSDK Documentation

CacheSectionHandler Class

Syntax

'Declaration

Public Class CacheSectionHandler

public class CacheSectionHandler

Inheritance Hierarchy

System.Object
FChoice.Foundation.CacheSectionHandler

Requirements

Namespace: FChoice.Foundation

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

CacheSectionHandler Members
FChoice.Foundation Namespace


CacheSectionHandler Class Members | fcSDK Documentation

CacheSectionHandler Class Members

The following tables list the members exposed by CacheSectionHandler.

Public Constructors

 | Name | Description
Public Constructor | CacheSectionHandler Constructor |

Reference

CacheSectionHandler Class
FChoice.Foundation Namespace


CacheSectionHandler Constructor | fcSDK Documentation

CacheSectionHandler Constructor

Syntax

'Declaration

Public Function New()

public CacheSectionHandler()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CacheSectionHandler Class
CacheSectionHandler Members


CustomCache Class | fcSDK Documentation

CustomCache Class

Syntax

'Declaration

Public Class CustomCache
   Inherits CacheBase

public class CustomCache : CacheBase

Inheritance Hierarchy

System.Object
FChoice.Foundation.CacheBase
FChoice.Foundation.CustomCache

Requirements

Namespace: FChoice.Foundation

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

CustomCache Members
FChoice.Foundation Namespace


CustomCache Class Members | fcSDK Documentation

CustomCache Class Members

The following tables list the members exposed by CustomCache.

Public Properties

 | Name | Description
Public Property | CacheSetName | Overridden.
Public Property | CacheType | Overridden.
Public Property | Data |

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetInstance |
Public Method | UpdateCache | (Inherited from FChoice.Foundation.CacheBase)

Public Events

 | Name | Description
Public Event | CacheUpdated | (Inherited from FChoice.Foundation.CacheBase)

Reference

CustomCache Class
FChoice.Foundation Namespace


GetInstance Method | fcSDK Documentation

GetInstance Method

Syntax

'Declaration

Public Shared Function GetInstance( _
   ByVal _cacheSetName_ As String _
) As CustomCache

public static CustomCache GetInstance(
   string _cacheSetName_
)

Parameters

cacheSetName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CustomCache Class
CustomCache Members


CacheSetName Property (CustomCache) | fcSDK Documentation

CacheSetName Property (CustomCache)

Syntax

'Declaration

Public Overrides ReadOnly Property CacheSetName As String

public override string CacheSetName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CustomCache Class
CustomCache Members
Base Implementation in CacheSetName


CacheType Property (CustomCache) | fcSDK Documentation

CacheType Property (CustomCache)

Syntax

'Declaration

Public Overrides ReadOnly Property CacheType As CacheType

public override CacheType CacheType {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CustomCache Class
CustomCache Members
Base Implementation in CacheType


Data Property | fcSDK Documentation

Data Property

Syntax

'Declaration

Public ReadOnly Property Data As DataSet

public DataSet Data {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CustomCache Class
CustomCache Members


DataFieldNameCollection Class | fcSDK Documentation

DataFieldNameCollection Class

Syntax

'Declaration

Public Class DataFieldNameCollection
   Inherits ValidatedNameCollection

public class DataFieldNameCollection : ValidatedNameCollection

Inheritance Hierarchy

System.Object
FChoice.Foundation.ValidatedNameCollection
FChoice.Foundation.DataFieldNameCollection

Requirements

Namespace: FChoice.Foundation

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

DataFieldNameCollection Members
FChoice.Foundation Namespace


DataFieldNameCollection Class Members | fcSDK Documentation

DataFieldNameCollection Class Members

The following tables list the members exposed by DataFieldNameCollection.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Property | IsFixedSize | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Property | IsReadOnly | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Property | IsSynchronized | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Property | Item | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Property | SyncRoot | (Inherited from FChoice.Foundation.ValidatedNameCollection)

Public Methods

 | Name | Description
Public Method | Add | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | AddRange | Overridden.
Public Method | Clear | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | Contains | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | CopyTo | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | GetEnumerator | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | IndexOf | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | Insert | Overridden.
Public Method | Remove | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | RemoveAt | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | SetList | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | ToString | (Inherited from FChoice.Foundation.ValidatedNameCollection)

Reference

DataFieldNameCollection Class
FChoice.Foundation Namespace


AddRange Method (DataFieldNameCollection) | fcSDK Documentation

AddRange Method (DataFieldNameCollection)

Syntax

'Declaration

Public Overrides Function AddRange( _
   ByVal ParamArray _addNames_() As String _
) As Integer()

public override int[] AddRange(
   params string[] _addNames_
)

Parameters

addNames

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataFieldNameCollection Class
DataFieldNameCollection Members
Base Implementation in AddRange


Insert Method (DataFieldNameCollection) | fcSDK Documentation

Insert Method (DataFieldNameCollection)

Syntax

'Declaration

Public Overrides Sub Insert( _
   ByVal _index_ As Integer, _
   ByVal _name_ As String _
)

public override void Insert(
   int _index_,
   string _name_
)

Parameters

index

name

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataFieldNameCollection Class
DataFieldNameCollection Members
Base Implementation in Insert


DictionaryExtensions Class | fcSDK Documentation

DictionaryExtensions Class

Syntax

'Declaration

<ExtensionAttribute()>
Public MustInherit NotInheritable Class DictionaryExtensions

[ExtensionAttribute()]
public static class DictionaryExtensions

Inheritance Hierarchy

System.Object
FChoice.Foundation.DictionaryExtensions

Requirements

Namespace: FChoice.Foundation

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

DictionaryExtensions Members
FChoice.Foundation Namespace


DictionaryExtensions Class Members | fcSDK Documentation

DictionaryExtensions Class Members

The following tables list the members exposed by DictionaryExtensions.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Get<T,V> |

Reference

DictionaryExtensions Class
FChoice.Foundation Namespace


Get<T,V> Method | fcSDK Documentation

Get<T,V> Method

Syntax

'Declaration

<ExtensionAttribute()>
Public Shared Function Get
    (Of T,V)( _
   ByVal _dictionary_ As IDictionary(Of T,V), _
   ByVal _key_ As T _
) As V

[ExtensionAttribute()]
public static V Get<T,V>(
   IDictionary<T,V> _dictionary_,
   T _key_
)

Parameters

dictionary

key

Type Parameters

T

V

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DictionaryExtensions Class
DictionaryExtensions Members


FCApplication Class | fcSDK Documentation

FCApplication Class

Syntax

'Declaration

Public MustInherit Class FCApplication

public abstract class FCApplication

Inheritance Hierarchy

System.Object
FChoice.Foundation.FCApplication
FChoice.Foundation.Clarify.ClarifyApplication

Requirements

Namespace: FChoice.Foundation

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FCApplication Members
FChoice.Foundation Namespace


FCApplication Class Members | fcSDK Documentation

FCApplication Class Members

The following tables list the members exposed by FCApplication.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | SyncRoot |

Public Properties

 | Name | Description
Public Property | DatabaseVersion |
static (Shared in Visual Basic) | IsInitialized |

Public Methods

 | Name | Description
Public Method | CurrentSessions | Provides a view into the FCApplication's currently running sessions.
static (Shared in Visual Basic) | Deinitialize | Unloads the FCApplication singleton from the current AppDomain.
static (Shared in Visual Basic) | Log | Overloaded.
static (Shared in Visual Basic) | LogDebug | Overloaded.
static (Shared in Visual Basic) | LogError | Overloaded.
static (Shared in Visual Basic) | LogInfo | Overloaded.
static (Shared in Visual Basic) | LogWarn | Overloaded.

Reference

FCApplication Class
FChoice.Foundation Namespace


CurrentSessions Method (FCApplication) | fcSDK Documentation

CurrentSessions Method (FCApplication)

Provides a view into the FCApplication's currently running sessions.

Syntax

'Declaration

Public Function CurrentSessions() As FCSessionSummary()

public FCSessionSummary[] CurrentSessions()

Return Value

An Array of FCSessionSummary objects representing the current running sessions.

Remarks

This method is present for administrative purposes. It could be used to find out how many users are logged into the system or to Retrieve and call CloseSession on unused session objects.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


Deinitialize Method (FCApplication) | fcSDK Documentation

Deinitialize Method (FCApplication)

Unloads the FCApplication singleton from the current AppDomain.

Syntax

'Declaration

Public Shared Sub Deinitialize()

public static void Deinitialize()

Return Value

FCApplication is a singleton. This method allows you to reset the singleton to an uninitialized state. After calling this method you will need to Initialize the FCApplication.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


Log Method (FCApplication) | fcSDK Documentation

Log Method (FCApplication)

Log an error or warning message

Overload List

Overload | Description
Log(LogLevel,String,Object[]) |
Log(LogLevel,Exception,String,Object[]) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


Log(LogLevel,String,Object[]) Method | fcSDK Documentation

Log(LogLevel,String,Object[]) Method

Syntax

'Declaration

Public Overloads Shared Sub Log( _
   ByVal _level_ As LogLevel, _
   ByVal _format_ As String, _
   ByVal ParamArray _args_() As Object _
)

public static void Log(
   LogLevel _level_,
   string _format_,
   params object\[\] _args_
)

Parameters

level

format

args

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members
Overload List


Log(LogLevel,Exception,String,Object[]) Method | fcSDK Documentation

Log(LogLevel,Exception,String,Object[]) Method

Syntax

'Declaration

Public Overloads Shared Sub Log( _
   ByVal _level_ As LogLevel, _
   ByVal _ex_ As Exception, _
   ByVal _format_ As String, _
   ByVal ParamArray _args_() As Object _
)

public static void Log(
   LogLevel _level_,
   Exception _ex_,
   string _format_,
   params object[] _args_
)

Parameters

level

ex

format

args

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members
Overload List


LogDebug Method (FCApplication) | fcSDK Documentation

LogDebug Method (FCApplication)

Overload List

Overload | Description
LogDebug(String,Object[]) |
LogDebug(Exception,String,Object[]) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


LogDebug(String,Object[]) Method | fcSDK Documentation

LogDebug(String,Object[]) Method

Syntax

'Declaration

Public Overloads Shared Sub LogDebug( _
   ByVal _format_ As String, _
   ByVal ParamArray _args_() As Object _
)

public static void LogDebug(
   string _format_,
   params object\[\] _args_
)

Parameters

format

args

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members
Overload List


LogDebug(Exception,String,Object[]) Method | fcSDK Documentation

LogDebug(Exception,String,Object[]) Method

Syntax

'Declaration

Public Overloads Shared Sub LogDebug( _
   ByVal _ex_ As Exception, _
   ByVal _format_ As String, _
   ByVal ParamArray _args_() As Object _
)

public static void LogDebug(
   Exception _ex_,
   string _format_,
   params object[] _args_
)

Parameters

ex

format

args

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members
Overload List


LogError Method (FCApplication) | fcSDK Documentation

LogError Method (FCApplication)

Overload List

Overload | Description
LogError(String,Object[]) |
LogError(Exception,String,Object[]) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


LogError(String,Object[]) Method | fcSDK Documentation

LogError(String,Object[]) Method

Syntax

'Declaration

Public Overloads Shared Sub LogError( _
   ByVal _format_ As String, _
   ByVal ParamArray _args_() As Object _
)

public static void LogError(
   string _format_,
   params object\[\] _args_
)

Parameters

format

args

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members
Overload List


LogError(Exception,String,Object[]) Method | fcSDK Documentation

LogError(Exception,String,Object[]) Method

Syntax

'Declaration

Public Overloads Shared Sub LogError( _
   ByVal _ex_ As Exception, _
   ByVal _format_ As String, _
   ByVal ParamArray _args_() As Object _
)

public static void LogError(
   Exception _ex_,
   string _format_,
   params object[] _args_
)

Parameters

ex

format

args

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members
Overload List


LogInfo Method (FCApplication) | fcSDK Documentation

LogInfo Method (FCApplication)

Overload List

Overload | Description
LogInfo(String,Object[]) |
LogInfo(Exception,String,Object[]) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


LogInfo(String,Object[]) Method | fcSDK Documentation

LogInfo(String,Object[]) Method

Syntax

'Declaration

Public Overloads Shared Sub LogInfo( _
   ByVal _format_ As String, _
   ByVal ParamArray _args_() As Object _
)

public static void LogInfo(
   string _format_,
   params object\[\] _args_
)

Parameters

format

args

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members
Overload List


LogInfo(Exception,String,Object[]) Method | fcSDK Documentation

LogInfo(Exception,String,Object[]) Method

Syntax

'Declaration

Public Overloads Shared Sub LogInfo( _
   ByVal _ex_ As Exception, _
   ByVal _format_ As String, _
   ByVal ParamArray _args_() As Object _
)

public static void LogInfo(
   Exception _ex_,
   string _format_,
   params object[] _args_
)

Parameters

ex

format

args

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members
Overload List


LogWarn Method (FCApplication) | fcSDK Documentation

LogWarn Method (FCApplication)

Overload List

Overload | Description
LogWarn(String,Object[]) |
LogWarn(Exception,String,Object[]) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


LogWarn(String,Object[]) Method | fcSDK Documentation

LogWarn(String,Object[]) Method

Syntax

'Declaration

Public Overloads Shared Sub LogWarn( _
   ByVal _format_ As String, _
   ByVal ParamArray _args_() As Object _
)

public static void LogWarn(
   string _format_,
   params object\[\] _args_
)

Parameters

format

args

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members
Overload List


LogWarn(Exception,String,Object[]) Method | fcSDK Documentation

LogWarn(Exception,String,Object[]) Method

Syntax

'Declaration

Public Overloads Shared Sub LogWarn( _
   ByVal _ex_ As Exception, _
   ByVal _format_ As String, _
   ByVal ParamArray _args_() As Object _
)

public static void LogWarn(
   Exception _ex_,
   string _format_,
   params object[] _args_
)

Parameters

ex

format

args

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members
Overload List


DatabaseVersion Property (FCApplication) | fcSDK Documentation

DatabaseVersion Property (FCApplication)

Syntax

'Declaration

Public ReadOnly Property DatabaseVersion As Version

public Version DatabaseVersion {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


IsInitialized Property (FCApplication) | fcSDK Documentation

IsInitialized Property (FCApplication)

Syntax

'Declaration

Public Shared ReadOnly Property IsInitialized As Boolean

public static bool IsInitialized {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


SyncRoot Field (FCApplication) | fcSDK Documentation

SyncRoot Field (FCApplication)

Syntax

'Declaration

Public Shared ReadOnly SyncRoot As Object

public static readonly object SyncRoot

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


FCGeneric Class | fcSDK Documentation

FCGeneric Class

Provides core CRM business logic and managed access to data.

Syntax

'Declaration

Public MustInherit Class FCGeneric

public abstract class FCGeneric

Inheritance Hierarchy

System.Object
FChoice.Foundation.FCGeneric
FChoice.Foundation.Clarify.ClarifyGeneric

Requirements

Namespace: FChoice.Foundation

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FCGeneric Members
FChoice.Foundation Namespace


FCGeneric Class Members | fcSDK Documentation

FCGeneric Class Members

The following tables list the members exposed by FCGeneric.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | MAX_DATE | Maximum possible date that is allowed to be entered for a date field.
static (Shared in Visual Basic) | MIN_DATE | Minimum possible date that is allowed to be entered for a date field.
static (Shared in Visual Basic) | NOW_DATE | When date fields are set to this value the current server datetime will be entered instead.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | ChildGenerics | Returns a dictionary (keyed by parent to child relation name) of child generics belonging to this FCGeneric. | | Public Property | Count | Returns the number of rows currently populated by the Query or AddNew methods. | | Public Property | DataFields | Collection of data fields that will be returned when Query is invoked. If no fields are selected all fields are returned. | | Public Property | DataRestrictionsEnabled | Sets whether or not this FCGeneric will have the DataRestrictions feature enabled if available.

| | Public Property | DeleteRelationsToUnrelate | | | Public Property | Filter | This is the root filter used to constrain rows returned during Query operations. Initially there are no filters present with filters being added using the AddFilter method. | | Public Property | IncludeRelations | Queries will retrieve all relation fields for the Generic | | Public Property | IsDistinct | Is this a Generic that should query for only discinct rows. | | Public Property | IsSynchronized | Gets a value indicating whether access to the FCGeneric is synchronized (thread-safe). | | Public Property | MaximumRows | Controls the maximum number of rows to be returned by the Genric Query. | | Public Property | QueryEmptyToNull |

Sets whether or not this FCGeneric will convert filters on empty strings into filters on Queries that check IS NULL or IS NOT NULL.

| | Public Property | RawFilter |

Sets an optional WHERE clause constraint. (WARNING: See remarks for potential security implications)

| | Public Property | RestrictionGroup | Override the Session Data Restriction Group of this Generic. The ChangeRestrictionGroup method is available as a helper. | | Public Property | SearchableFieldPrefix | | | Public Property | SetNullStringsToEmpty | Sets whether or not this FCGeneric will convert a null reference (Nothing in Visual Basic) to empty strings. | | Public Property | SyncRoot | Gets an object that can be used to synchronize access to the FCGeneric. | | Public Property | TableName | Returns the name of the database table this FCGeneric is based on. |

Public Methods

 | Name | Description
Public Method | AppendFilter | Overloaded. Adds a filter to constrain the results of an FCGeneric Query against a numeric DataField.
Public Method | AppendFilterBetween | Overloaded. Adds a specialized filter to constrain the results of an FCGeneric Query to be between two Integer values.
Public Method | AppendFilterInList | Overloaded. Adds a filter to constrain the results of an FCGeneric Query against a list of possible Integer values**.**
Public Method | AppendFilterIsNull | Adds a filter to constrain the results of an FCGeneric Query against NULL or NOT NULL fields.
Public Method | AppendSort | Overloaded. Adds a field by which the results of an FCGeneric Query will be sorted.
Public Method | AssignObjID |
Public Method | ChangeRestrictionGroup | Change the Data Restriction Group of this generic instance overriding the Session default. This method is a helper for when you only know the name of the restriction group.
Public Method | ClearFilters | Clears all filters that have been appended to this generic.
Public Method | ClearSorts | Clears all sort operations that have been appended to this generic.
Public Method | CopyTo | Copies all the rows of the current FCGeneric into to a one-dimensional Array.
Public Method | DeleteAll | Delete all rows present in this FCGeneric.
Public Method | GetEnumerator | Returns an IEnumerator for the FCGeneric.
Public Method | Query | Overloaded. Causes the generic object to query the database table or view using the optionally specified data fields, filters, and sort orders
Public Method | Update | Overloaded. Updates changes to a single GenericDataRow
Public Method | UpdateAll | Overloaded. Updates all modified rows of the FCGeneric.

Public Events

 | Name | Description
Public Event | MaximumRowsExceeded | This event is fired when the MaximumRows property is set and a Query operation has returned too many rows.

Reference

FCGeneric Class
FChoice.Foundation Namespace


AppendFilter Method (FCGeneric) | fcSDK Documentation

AppendFilter Method (FCGeneric)

Adds a filter to constrain the results of an FCGeneric Query against a numeric DataField.

Adds a filter to constrain the results of an FCGeneric Query.

Overload List

Overload | Description
AppendFilter(String,Boolean) |
AppendFilter(String,NumberOps,Int32) | Adds a filter to constrain the results of an FCGeneric Query against a numeric DataField.
AppendFilter(String,NumberOps,Decimal) | Adds a filter to constrain the results of an FCGeneric Query against a numeric DataField.
AppendFilter(String,DateOps,DateTime) | Adds a filter to constrain the results of an FCGeneric Query against a DateTime DataField.
AppendFilter(String,StringOps,String) | Adds a filter to constrain the results of an FCGeneric Query against a String DataField.

Remarks

Filters are a powerful feature that make it easy to limit the rows returned by a Query. You may call filter methods multiple times resulting in each successive filter further constraining the rows returned.

You can call ClearFilters to remove all the filters being applied to a FCGeneric

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


AppendFilter(String,Boolean) Method | fcSDK Documentation

AppendFilter(String,Boolean) Method

Syntax

'Declaration

Public Overloads Sub AppendFilter( _
   ByVal _fieldName_ As String, _
   ByVal _value_ As Boolean _
)

public void AppendFilter(
   string _fieldName_,
   bool _value_
)

Parameters

fieldName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members
Overload List


AppendFilter(String,NumberOps,Int32) Method | fcSDK Documentation

AppendFilter(String,NumberOps,Int32) Method

Name of the field the filter will be constraining.

The type of filter being applied. See the NumberOps enumeration.

The filter is being applied against this value.

Adds a filter to constrain the results of an FCGeneric Query against a numeric DataField.

Syntax

'Declaration

Public Overloads Sub AppendFilter( _
   ByVal _fieldName_ As String, _
   ByVal _operation_ As NumberOps, _
   ByVal _value_ As Integer _
)

public void AppendFilter(
   string _fieldName_,
   NumberOps _operation_,
   int _value_
)

Parameters

fieldName

Name of the field the filter will be constraining.

operation

The type of filter being applied. See the NumberOps enumeration.

value

The filter is being applied against this value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members
Overload List


AppendFilter(String,NumberOps,Decimal) Method | fcSDK Documentation

AppendFilter(String,NumberOps,Decimal) Method

Name of the field the filter will be constraining.

The type of filter being applied. See the NumberOps enumeration.

The filter is being applied against this value.

Adds a filter to constrain the results of an FCGeneric Query against a numeric DataField.

Syntax

'Declaration

Public Overloads Sub AppendFilter( _
   ByVal _fieldName_ As String, _
   ByVal _operation_ As NumberOps, _
   ByVal _value_ As Decimal _
)

public void AppendFilter(
   string _fieldName_,
   NumberOps _operation_,
   decimal _value_
)

Parameters

fieldName

Name of the field the filter will be constraining.

operation

The type of filter being applied. See the NumberOps enumeration.

value

The filter is being applied against this value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members
Overload List


AppendFilter(String,DateOps,DateTime) Method | fcSDK Documentation

AppendFilter(String,DateOps,DateTime) Method

Name of the field the filter will be constraining.

The type of filter being applied. See the DateOps enumeration.

The filter is being applied against this DateTime.

Adds a filter to constrain the results of an FCGeneric Query against a DateTime DataField.

Syntax

'Declaration

Public Overloads Sub AppendFilter( _
   ByVal _fieldName_ As String, _
   ByVal _operation_ As DateOps, _
   ByVal _value_ As Date _
)

public void AppendFilter(
   string _fieldName_,
   DateOps _operation_,
   DateTime _value_
)

Parameters

fieldName

Name of the field the filter will be constraining.

operation

The type of filter being applied. See the DateOps enumeration.

value

The filter is being applied against this DateTime.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members
Overload List


AppendFilter(String,StringOps,String) Method | fcSDK Documentation

AppendFilter(String,StringOps,String) Method

Name of the field the filter will be constraining.

The type of filter being applied. See the StringOps enumeration.

The filter is being applied against this value.

Adds a filter to constrain the results of an FCGeneric Query against a String DataField.

Syntax

'Declaration

Public Overloads Sub AppendFilter( _
   ByVal _fieldName_ As String, _
   ByVal _operation_ As StringOps, _
   ByVal _value_ As String _
)

public void AppendFilter(
   string _fieldName_,
   StringOps _operation_,
   string _value_
)

Parameters

fieldName

Name of the field the filter will be constraining.

operation

The type of filter being applied. See the StringOps enumeration.

value

The filter is being applied against this value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members
Overload List


AppendFilterBetween Method | fcSDK Documentation

AppendFilterBetween Method

Adds a specialized filter to constrain the results of an FCGeneric Query to be between two Integer values.

Adds a specialized filter to constrain the results of an FCGeneric Query to be between two values.

Overload List

Overload | Description
AppendFilterBetween(String,Boolean,Int32,Int32) | Adds a specialized filter to constrain the results of an FCGeneric Query to be between two Integer values.
AppendFilterBetween(String,Boolean,Decimal,Decimal) | Adds a specialized filter to constrain the results of an FCGeneric Query to be between two Decimal values.
AppendFilterBetween(String,Boolean,DateTime,DateTime) | Adds a specialized filter to constrain the results of an FCGeneric Query to be between two DateTime values.

Remarks

Filters are a powerful feature that make it easy to limit the rows returned by a Query. You may call filter methods multiple times resulting in each successive filter further constraining the rows returned.

You can call ClearFilters to remove all the filters being applied to a FCGeneric

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


AppendFilterBetween(String,Boolean,Int32,Int32) Method | fcSDK Documentation

AppendFilterBetween(String,Boolean,Int32,Int32) Method

Name of the field the filter will be constraining.

true if desired rows fall between the two values

value on the left side of the between clause

value on the right side of the between clause

Adds a specialized filter to constrain the results of an FCGeneric Query to be between two Integer values.

Syntax

'Declaration

Public Overloads Sub AppendFilterBetween( _
   ByVal _fieldName_ As String, _
   ByVal _isBetween_ As Boolean, _
   ByVal _value1_ As Integer, _
   ByVal _value2_ As Integer _
)

public void AppendFilterBetween(
   string _fieldName_,
   bool _isBetween_,
   int _value1_,
   int _value2_
)

Parameters

fieldName

Name of the field the filter will be constraining.

isBetween

true if desired rows fall between the two values

value1

value on the left side of the between clause

value2

value on the right side of the between clause

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members
Overload List


AppendFilterBetween(String,Boolean,Decimal,Decimal) Method | fcSDK Documentation

AppendFilterBetween(String,Boolean,Decimal,Decimal) Method

Adds a specialized filter to constrain the results of an FCGeneric Query to be between two Decimal values.

Syntax

'Declaration

Public Overloads Sub AppendFilterBetween( _
   ByVal _fieldName_ As String, _
   ByVal _isBetween_ As Boolean, _
   ByVal _value1_ As Decimal, _
   ByVal _value2_ As Decimal _
)

public void AppendFilterBetween(
   string _fieldName_,
   bool _isBetween_,
   decimal _value1_,
   decimal _value2_
)

Parameters

fieldName

isBetween

value1

value2

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members
Overload List


AppendFilterBetween(String,Boolean,DateTime,DateTime) Method | fcSDK Documentation

AppendFilterBetween(String,Boolean,DateTime,DateTime) Method

Name of the field the filter will be constraining.

true if desired rows fall between the two values

value on the left side of the between clause

value on the right side of the between clause

Adds a specialized filter to constrain the results of an FCGeneric Query to be between two DateTime values.

Syntax

'Declaration

Public Overloads Sub AppendFilterBetween( _
   ByVal _fieldName_ As String, _
   ByVal _isBetween_ As Boolean, _
   ByVal _value1_ As Date, _
   ByVal _value2_ As Date _
)

public void AppendFilterBetween(
   string _fieldName_,
   bool _isBetween_,
   DateTime _value1_,
   DateTime _value2_
)

Parameters

fieldName

Name of the field the filter will be constraining.

isBetween

true if desired rows fall between the two values

value1

value on the left side of the between clause

value2

value on the right side of the between clause

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members
Overload List


AppendFilterInList Method | fcSDK Documentation

AppendFilterInList Method

Adds a filter to constrain the results of an FCGeneric Query against a list of possible Integer values**.**

Adds a filter to constrain the results of an FCGeneric Query against a list of possible values**.**

Overload List

Overload | Description
AppendFilterInList(String,Boolean,Int32[]) | Adds a filter to constrain the results of an FCGeneric Query against a list of possible Integer values**.**
AppendFilterInList(String,Boolean,Decimal[]) | Adds a filter to constrain the results of an FCGeneric Query against a list of possible Decimal values**.**
AppendFilterInList(String,Boolean,DateTime[]) | Adds a filter to constrain the results of an FCGeneric Query against a list of possible DateTime values**.**
AppendFilterInList(String,Boolean,String[]) | Adds a filter to constrain the results of an FCGeneric Query against a list of possible String values**.**

Remarks

Filters are a powerful feature that make it easy to limit the rows returned by a Query. You may call filter methods multiple times resulting in each successive filter further constraining the rows returned.

You can call ClearFilters to remove all the filters being applied to a FCGeneric.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


AppendFilterInList(String,Boolean,Int32[]) Method | fcSDK Documentation

AppendFilterInList(String,Boolean,Int32[]) Method

Name of the field the filter will be constraining.

true if desired values are in the List

Array of values to filter on

Adds a filter to constrain the results of an FCGeneric Query against a list of possible Integer values**.**

Syntax

'Declaration

Public Overloads Sub AppendFilterInList( _
   ByVal _fieldName_ As String, _
   ByVal _isIn_ As Boolean, _
   ByVal ParamArray _list_() As Integer _
)

public void AppendFilterInList(
   string _fieldName_,
   bool _isIn_,
   params int\[\] _list_
)

Parameters

fieldName

Name of the field the filter will be constraining.

isIn

true if desired values are in the List

list

Array of values to filter on

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members
Overload List


AppendFilterInList(String,Boolean,Decimal[]) Method | fcSDK Documentation

AppendFilterInList(String,Boolean,Decimal[]) Method

Name of the field the filter will be constraining.

true if desired values are in the List

Array of values to filter on

Adds a filter to constrain the results of an FCGeneric Query against a list of possible Decimal values**.**

Syntax

'Declaration

Public Overloads Sub AppendFilterInList( _
   ByVal _fieldName_ As String, _
   ByVal _isIn_ As Boolean, _
   ByVal ParamArray _list_() As Decimal _
)

public void AppendFilterInList(
   string _fieldName_,
   bool _isIn_,
   params decimal\[\] _list_
)

Parameters

fieldName

Name of the field the filter will be constraining.

isIn

true if desired values are in the List

list

Array of values to filter on

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members
Overload List


AppendFilterInList(String,Boolean,DateTime[]) Method | fcSDK Documentation

AppendFilterInList(String,Boolean,DateTime[]) Method

Name of the field the filter will be constraining.

true if desired values are in the List

Array of values to filter on

Adds a filter to constrain the results of an FCGeneric Query against a list of possible DateTime values**.**

Syntax

'Declaration

Public Overloads Sub AppendFilterInList( _
   ByVal _fieldName_ As String, _
   ByVal _isIn_ As Boolean, _
   ByVal ParamArray _list_() As Date _
)

public void AppendFilterInList(
   string _fieldName_,
   bool _isIn_,
   params DateTime\[\] _list_
)

Parameters

fieldName

Name of the field the filter will be constraining.

isIn

true if desired values are in the List

list

Array of values to filter on

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members
Overload List


AppendFilterInList(String,Boolean,String[]) Method | fcSDK Documentation

AppendFilterInList(String,Boolean,String[]) Method

Name of the field the filter will be constraining.

true if desired values are in the List

Array of values to filter on

Adds a filter to constrain the results of an FCGeneric Query against a list of possible String values**.**

Syntax

'Declaration

Public Overloads Sub AppendFilterInList( _
   ByVal _fieldName_ As String, _
   ByVal _isIn_ As Boolean, _
   ByVal ParamArray _list_() As String _
)

public void AppendFilterInList(
   string _fieldName_,
   bool _isIn_,
   params string[] _list_
)

Parameters

fieldName

Name of the field the filter will be constraining.

isIn

true if desired values are in the List

list

Array of values to filter on

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members
Overload List


AppendFilterIsNull Method | fcSDK Documentation

AppendFilterIsNull Method

Name of the field the filter will be constraining.

true if searching for NULLvalues

Adds a filter to constrain the results of an FCGeneric Query against NULL or NOT NULL fields.

Syntax

'Declaration

Public Sub AppendFilterIsNull( _
   ByVal _fieldName_ As String, _
   ByVal _isNull_ As Boolean _
)

public void AppendFilterIsNull(
   string _fieldName_,
   bool _isNull_
)

Parameters

fieldName

Name of the field the filter will be constraining.

isNull

true if searching for NULLvalues

Remarks

Filters are a powerful feature that make it easy to limit the rows returned by a Query. You may call filter methods multiple times resulting in each successive filter further constraining the rows returned.

You can call ClearFilters to remove all the filters being applied to a FCGeneric.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


AppendSort Method (FCGeneric) | fcSDK Documentation

AppendSort Method (FCGeneric)

Adds a field by which the results of an FCGeneric Query will be sorted.

Overload List

Overload | Description
AppendSort(String,Boolean) |
AppendSort(String,Boolean,Boolean) |

Remarks

If you wish to clear all the sort fields currently appended to the FCGeneric call ClearSorts.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


AppendSort(String,Boolean) Method | fcSDK Documentation

AppendSort(String,Boolean) Method

Name of the field to sort by

true if the sort order is Ascending. false if it is Descending.

Syntax

'Declaration

Public Overloads Sub AppendSort( _
   ByVal _fieldName_ As String, _
   ByVal _isAscending_ As Boolean _
)

public void AppendSort(
   string _fieldName_,
   bool _isAscending_
)

Parameters

fieldName

Name of the field to sort by

isAscending

true if the sort order is Ascending. false if it is Descending.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members
Overload List


AppendSort(String,Boolean,Boolean) Method | fcSDK Documentation

AppendSort(String,Boolean,Boolean) Method

Name of the field to sort by

true if the sort order is Ascending. false if it is Descending.

true to validate whether the field specified in fieldName is a valid field on this table. false to add the fieldName without any verification.

Syntax

'Declaration

Public Overloads Sub AppendSort( _
   ByVal _fieldName_ As String, _
   ByVal _isAscending_ As Boolean, _
   ByVal _checkField_ As Boolean _
)

public void AppendSort(
   string _fieldName_,
   bool _isAscending_,
   bool _checkField_
)

Parameters

fieldName

Name of the field to sort by

isAscending

true if the sort order is Ascending. false if it is Descending.

checkField

true to validate whether the field specified in fieldName is a valid field on this table. false to add the fieldName without any verification.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members
Overload List


AssignObjID Method (FCGeneric) | fcSDK Documentation

AssignObjID Method (FCGeneric)

Syntax

'Declaration

Public Sub AssignObjID( _
   ByVal _row_ As GenericDataRow _
)

public void AssignObjID(
   GenericDataRow _row_
)

Parameters

row

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


ChangeRestrictionGroup Method (FCGeneric) | fcSDK Documentation

ChangeRestrictionGroup Method (FCGeneric)

Change the Data Restriction Group of this generic instance overriding the Session default. This method is a helper for when you only know the name of the restriction group.

Syntax

'Declaration

Public Sub ChangeRestrictionGroup( _
   ByVal _groupName_ As String _
)

public void ChangeRestrictionGroup(
   string _groupName_
)

Parameters

groupName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


ClearFilters Method | fcSDK Documentation

ClearFilters Method

Clears all filters that have been appended to this generic.

Syntax

'Declaration

Public Sub ClearFilters()

public void ClearFilters()

Remarks

This method will clear all filters that have been appended via AppendFitler, AppendFilterBetween, AppendFilterInList, AppendFilterIsNull, and the Filter property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


ClearSorts Method | fcSDK Documentation

ClearSorts Method

Clears all sort operations that have been appended to this generic.

Syntax

'Declaration

Public Sub ClearSorts()

public void ClearSorts()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


CopyTo Method (FCGeneric) | fcSDK Documentation

CopyTo Method (FCGeneric)

A one-dimensional Array to copy the current rows collection into

The destination Array index to start copying into.

Copies all the rows of the current FCGeneric into to a one-dimensional Array.

Syntax

'Declaration

Public Sub CopyTo( _
   ByVal _array_ As Array, _
   ByVal _index_ As Integer _
)

public void CopyTo(
   Array _array_,
   int _index_
)

Parameters

array

A one-dimensional Array to copy the current rows collection into

index

The destination Array index to start copying into.

Remarks

Please see the GenericDataRowCollection's CopyTo

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


DeleteAll Method (FCGeneric) | fcSDK Documentation

DeleteAll Method (FCGeneric)

Delete all rows present in this FCGeneric.

Syntax

'Declaration

Public Sub DeleteAll()

public void DeleteAll()

Remarks

Calls Delete on every row present in the Rows collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


GetEnumerator Method (FCGeneric) | fcSDK Documentation

GetEnumerator Method (FCGeneric)

Returns an IEnumerator for the FCGeneric.

Syntax

'Declaration

Public Function GetEnumerator() As IEnumerator

public IEnumerator GetEnumerator()

Return Value

Returns an IEnumerator for the FCGeneric.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


Query Method (FCGeneric) | fcSDK Documentation

Query Method (FCGeneric)

Causes the generic object to query the database table or view using the optionally specified data fields, filters, and sort orders

Causes the generic object to query the database table or view using the optionally specified data fields, filters, and sort orders

Overload List

Overload | Description
Query() | Causes the generic object to query the database table or view using the optionally specified data fields, filters, and sort orders
Query(IDbTransaction) | Causes the generic object to query the database table or view using the specified active transaction and, optionally, specified data fields, filters, and sort orders

Remarks

This method causes the generic object to query the database table or view using any specified data fields, filters, and/or sort orders. The query retrieves 0 or more rows.

For more information on controlling the number and type of fields returned, see the DataFields property documentation. To restrict a query by adding filters, see the documentation for the AppendFilter method overloads. To control the order in which rows are sorted, see the AppendSort method documentation.

NOTE: If you have traversed child objects from this generic, all children in the hierarchy will also be queried when this method is called. For example, if you wish to query the case object for one specific case, but also wish to get all related activity logs and the related contact, you would set up the case, activity_log, and contact generic objects (see example), and would only have to query the case generic object.

If more than one object that is to be queried at the same time and are not related, use the Query Method on the ClarifyDataSet instance from which this generate was created to ensure that the queries are optimized and are executed in the same transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


Query() Method | fcSDK Documentation

Query() Method

Causes the generic object to query the database table or view using the optionally specified data fields, filters, and sort orders

Syntax

'Declaration

Public Overloads MustOverride Sub Query()

public abstract void Query()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members
Overload List


Query(IDbTransaction) Method | fcSDK Documentation

Query(IDbTransaction) Method

An active/open database IDbTransaction object in which this query will participate.

Causes the generic object to query the database table or view using the specified active transaction and, optionally, specified data fields, filters, and sort orders

Syntax

'Declaration

Public Overloads MustOverride Sub Query( _
   ByVal _transaction_ As IDbTransaction _
)

public abstract void Query(
   IDbTransaction _transaction_
)

Parameters

transaction

An active/open database IDbTransaction object in which this query will participate.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members
Overload List


Update Method (FCGeneric) | fcSDK Documentation

Update Method (FCGeneric)

Updates changes to a single GenericDataRow

Update methods commit changes to the database.

Overload List

Overload | Description
Update(GenericDataRow) | Updates changes to a single GenericDataRow
Update(GenericDataRow,IDbTransaction) | Updates changes to a single GenericDataRow under the context of a Transaction
Update(GenericDataRow,UpdateQueryBatch) | Updates changes to a single GenericDataRow as part of a batch operation.

Remarks

If no changes have been made these methods will do nothing.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


Update(GenericDataRow) Method | fcSDK Documentation

Update(GenericDataRow) Method

Row being updated.

Updates changes to a single GenericDataRow

Syntax

'Declaration

Public Overloads Sub Update( _
   ByVal _row_ As GenericDataRow _
)

public void Update(
   GenericDataRow _row_
)

Parameters

row

Row being updated.

Remarks

This method commits any changes to this to the database.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members
Overload List


Update(GenericDataRow,IDbTransaction) Method | fcSDK Documentation

Update(GenericDataRow,IDbTransaction) Method

Row being updated.

Transaction under which to do this update

Updates changes to a single GenericDataRow under the context of a Transaction

Syntax

'Declaration

Public Overloads Sub Update( _
   ByVal _row_ As GenericDataRow, _
   ByVal _transaction_ As IDbTransaction _
)

public void Update(
   GenericDataRow _row_,
   IDbTransaction _transaction_
)

Parameters

row

Row being updated.

transaction

Transaction under which to do this update

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members
Overload List


Update(GenericDataRow,UpdateQueryBatch) Method | fcSDK Documentation

Update(GenericDataRow,UpdateQueryBatch) Method

Row being updated.

Batch under which to do this update.

Updates changes to a single GenericDataRow as part of a batch operation.

Syntax

'Declaration

Public Overloads Sub Update( _
   ByVal _row_ As GenericDataRow, _
   ByVal _batch_ As UpdateQueryBatch _
)

public void Update(
   GenericDataRow _row_,
   UpdateQueryBatch _batch_
)

Parameters

row

Row being updated.

batch

Batch under which to do this update.

Remarks

This method commits any changes to this to the database.

When it is desirable to consolidate many database operations in one round trip to the database this method can be used in conjunction with a UpdateQueryBatch object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members
Overload List


UpdateAll Method (FCGeneric) | fcSDK Documentation

UpdateAll Method (FCGeneric)

Updates all modified rows of the FCGeneric.

Updates all modified rows of the FCGeneric.

Overload List

Overload | Description
UpdateAll() | Updates all modified rows of the FCGeneric.
UpdateAll(UpdateQueryBatch) | Updates all modified rows of the FCGeneric as part of a batch operation.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


UpdateAll() Method | fcSDK Documentation

UpdateAll() Method

Updates all modified rows of the FCGeneric.

Syntax

'Declaration

Public Overloads Sub UpdateAll()

public void UpdateAll()

Remarks

This method commits all modified rows to the database and is equivalent to calling Update on each row of the FCGeneric.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members
Overload List


UpdateAll(UpdateQueryBatch) Method | fcSDK Documentation

UpdateAll(UpdateQueryBatch) Method

Batch under which to do this update.

Updates all modified rows of the FCGeneric as part of a batch operation.

Syntax

'Declaration

Public Overloads Sub UpdateAll( _
   ByVal _batch_ As UpdateQueryBatch _
)

public void UpdateAll(
   UpdateQueryBatch _batch_
)

Parameters

batch

Batch under which to do this update.

Remarks

This method commits all modified rows to the database and is equivalent to calling Update on each row of the FCGeneric.

When it is desirable to consolidate many database operations in one round trip to the database this method can be used in conjunction with a UpdateQueryBatch object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members
Overload List


ChildGenerics Property | fcSDK Documentation

ChildGenerics Property

Returns a dictionary (keyed by parent to child relation name) of child generics belonging to this FCGeneric.

Syntax

'Declaration

Public ReadOnly Property ChildGenerics As ICollection(Of FCGeneric)

public ICollection<FCGeneric> ChildGenerics {get;}

Property Value

Returns a dictionary (keyed by parent to child relation name) of child generics belonging to this FCGeneric.

Remarks

Changes to the dictionary will have no effect on the FCGeneric.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


Count Property (FCGeneric) | fcSDK Documentation

Count Property (FCGeneric)

Returns the number of rows currently populated by the Query or AddNew methods.

Syntax

'Declaration

Public ReadOnly Property Count As Integer

public int Count {get;}

Property Value

Returns the number of rows currently populated by the Query or AddNew methods.

Remarks

This value is the same as calling Rows.Count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


DataFields Property (FCGeneric) | fcSDK Documentation

DataFields Property (FCGeneric)

Collection of data fields that will be returned when Query is invoked. If no fields are selected all fields are returned.

Syntax

'Declaration

Public ReadOnly Property DataFields As DataFieldNameCollection

public DataFieldNameCollection DataFields {get;}

Property Value

Collection of data fields that will be returned when Query is invoked.

Remarks

To add a field to be selected during Query call the AddRange method.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


DataRestrictionsEnabled Property (FCGeneric) | fcSDK Documentation

DataRestrictionsEnabled Property (FCGeneric)

Sets whether or not this FCGeneric will have the DataRestrictions feature enabled if available.

Syntax

'Declaration

Public Property DataRestrictionsEnabled As Boolean

public bool DataRestrictionsEnabled {get; set;}

Property Value

Returns whether or not this FCGeneric will have the DataRestrictions feature enabled if available.

Remarks

Setting this value to true will only work if the DataRestriction support schema is present. Setting this value to false will disable DataRestriction support.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


DeleteRelationsToUnrelate Property | fcSDK Documentation

DeleteRelationsToUnrelate Property

Syntax

'Declaration

Public ReadOnly Property DeleteRelationsToUnrelate As RelationNameCollection

public RelationNameCollection DeleteRelationsToUnrelate {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


Filter Property (FCGeneric) | fcSDK Documentation

Filter Property (FCGeneric)

This is the root filter used to constrain rows returned during Query operations. Initially there are no filters present with filters being added using the AddFilter method.

Syntax

'Declaration

Public ReadOnly Property Filter As AndFilter

public AndFilter Filter {get;}

Remarks

Since the root filter is an AndFilter all filters added to it will be seperated with ANDs.

Example

Developer Walkthrough - Advanced Filtering

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members
Security Best Practices


IncludeRelations Property (FCGeneric) | fcSDK Documentation

IncludeRelations Property (FCGeneric)

Queries will retrieve all relation fields for the Generic

Syntax

'Declaration

Public Property IncludeRelations As Boolean

public bool IncludeRelations {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


IsDistinct Property | fcSDK Documentation

IsDistinct Property

Is this a Generic that should query for only discinct rows.

Syntax

'Declaration

Public Property IsDistinct As Boolean

public bool IsDistinct {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


IsSynchronized Property (FCGeneric) | fcSDK Documentation

IsSynchronized Property (FCGeneric)

Gets a value indicating whether access to the FCGeneric is synchronized (thread-safe).

Syntax

'Declaration

Public ReadOnly Property IsSynchronized As Boolean

public bool IsSynchronized {get;}

Property Value

true if access to the FCGeneric is synchronized (thread-safe); otherwise, false.

Remarks

This is a common .NET Framework pattern please see this example.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


MaximumRows Property (FCGeneric) | fcSDK Documentation

MaximumRows Property (FCGeneric)

Controls the maximum number of rows to be returned by the Generic Query.

Syntax

'Declaration

Public Property MaximumRows As Integer

public int MaximumRows {get; set;}

[!include[Requirements]emarks

The default value of this property is set by the Generic's Session.MaximumRows.

When this value is set the default operation will result in the number of rows returned by every Query to MaximumRows.

Alternatively the MaximumRowsExceeded event can give greater control of how Queries returning too many rows are handled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


QueryEmptyToNull Property (FCGeneric) | fcSDK Documentation

QueryEmptyToNull Property (FCGeneric)

Sets whether or not this FCGeneric will convert filters on empty strings into filters on Queries that check IS NULL or IS NOT NULL.

Syntax

'Declaration

Public Property QueryEmptyToNull As Boolean

public bool QueryEmptyToNull {get; set;}

Property Value

Returns whether or not this FCGeneric will convert filters on empty strings into filters on Queries that check IS NULL or IS NOT NULL.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


RawFilter Property | fcSDK Documentation

RawFilter Property

Sets an optional WHERE clause constraint. (WARNING: See remarks for potential security implications)

Syntax

'Declaration

Public Property RawFilter As String

public string RawFilter {get; set;}

Property Value

Returns an optional WHERE clause constraint.

Remarks

WARNING: Setting this property can expose your application to SQL injection attacks. Please read this best practices guide published by Microsoft.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


RestrictionGroup Property (FCGeneric) | fcSDK Documentation

RestrictionGroup Property (FCGeneric)

Override the Session Data Restriction Group of this Generic. The ChangeRestrictionGroup method is available as a helper.

Syntax

'Declaration

Public Property RestrictionGroup As RestrictionGroup

public RestrictionGroup RestrictionGroup {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


SearchableFieldPrefix Property (FCGeneric) | fcSDK Documentation

SearchableFieldPrefix Property (FCGeneric)

Syntax

'Declaration

Public MustOverride ReadOnly Property SearchableFieldPrefix As String

public abstract string SearchableFieldPrefix {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


SetNullStringsToEmpty Property (FCGeneric) | fcSDK Documentation

SetNullStringsToEmpty Property (FCGeneric)

Sets whether or not this FCGeneric will convert a null reference (Nothing in Visual Basic) to empty strings.

Syntax

'Declaration

Public Property SetNullStringsToEmpty As Boolean

public bool SetNullStringsToEmpty {get; set;}

Property Value

Returns whether or not this FCGeneric will convert a null reference (Nothing in Visual Basic) to empty strings.

Remarks

This setting only affects Oracle DbProviders.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


SyncRoot Property (FCGeneric) | fcSDK Documentation

SyncRoot Property (FCGeneric)

Gets an object that can be used to synchronize access to the FCGeneric.

Syntax

'Declaration

Public ReadOnly Property SyncRoot As Object

public object SyncRoot {get;}

Property Value

Gets an object that can be used to synchronize access to the FCGeneric.

Remarks

This is a common .NET Framework pattern please see check out this example.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


TableName Property (FCGeneric) | fcSDK Documentation

TableName Property (FCGeneric)

Returns the name of the database table this FCGeneric is based on.

Syntax

'Declaration

Public ReadOnly Property TableName As String

public string TableName {get;}

Property Value

Returns the name of the database table this FCGeneric is based on.

Remarks

The TableName is set when the FCGeneric is constructed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


MAX_DATE Field | fcSDK Documentation

MAX_DATE Field

Maximum possible date that is allowed to be entered for a date field.

Syntax

'Declaration

Public Shared ReadOnly MAX_DATE As Date

public static readonly DateTime MAX_DATE

Field Value

Maximum possible date that is allowed to be entered for a date field.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


MIN_DATE Field | fcSDK Documentation

MIN_DATE Field

Minimum possible date that is allowed to be entered for a date field.

Syntax

'Declaration

Public Shared ReadOnly MIN_DATE As Date

public static readonly DateTime MIN_DATE

Field Value

Minimum possible date that is allowed to be entered for a date field.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


NOW_DATE Field (FCGeneric) | fcSDK Documentation

NOW_DATE Field (FCGeneric)

When date fields are set to this value the current server datetime will be entered instead.

Syntax

'Declaration

Public Shared ReadOnly NOW_DATE As Date

public static readonly DateTime NOW_DATE

Field Value

When date fields are set to this value the current server datetime will be entered instead.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


MaximumRowsExceeded Event | fcSDK Documentation

MaximumRowsExceeded Event

This event is fired when the MaximumRows property is set and a Query operation has returned too many rows.

Syntax

'Declaration

Public Event MaximumRowsExceeded As MaximumRowsExceededEventHandler

public event MaximumRowsExceededEventHandler MaximumRowsExceeded

Event Data

The event handler receives an argument of type MaximumRowsExceededEventArgs containing data related to this event. The following MaximumRowsExceededEventArgs properties provide information specific to this event.

Property | Description
CancelQuery | When set to true the query will be canceled.
RowsToReturn | This value will control the number of rows to be returned from a large query.
TotalPossibleRows | Readonly count of rows to be returned by the large query that caused this event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


FCInvalidLoginException Class | fcSDK Documentation

FCInvalidLoginException Class

Thrown when credentials for a Session cannot be authenticated

Syntax

'Declaration

<SerializableAttribute()>
Public Class FCInvalidLoginException
   Inherits FoundationException

[SerializableAttribute()]
public class FCInvalidLoginException : FoundationException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
FChoice.Common.FCExceptionBase
FChoice.Foundation.FoundationException
FChoice.Foundation.FCInvalidLoginException

Requirements

Namespace: FChoice.Foundation

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FCInvalidLoginException Members
FChoice.Foundation Namespace


FCInvalidLoginException Class Members | fcSDK Documentation

FCInvalidLoginException Class Members

The following tables list the members exposed by FCInvalidLoginException.

Public Constructors

 | Name | Description
Public Constructor | FCInvalidLoginException Constructor |

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorCode | Gets the unique error code for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | ErrorMessageID | Gets the message identifier for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | Sets the SerializationInfo object with the parameter name and additional exception information. (Inherited from FChoice.Common.FCExceptionBase)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)

Reference

FCInvalidLoginException Class
FChoice.Foundation Namespace


FCInvalidLoginException Constructor | fcSDK Documentation

FCInvalidLoginException Constructor

Syntax

'Declaration

Public Function New( _
   ByVal _errorId_ As Integer, _
   ByVal _username_ As String _
)

public FCInvalidLoginException(
   int _errorId_,
   string _username_
)

Parameters

errorId

username

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCInvalidLoginException Class
FCInvalidLoginException Members


FCSession Class | fcSDK Documentation

FCSession Class

FCSession contains session information for a logged-in user and allows for manipulation of data in the CRM system as that user.

Syntax

'Declaration

<DefaultMemberAttribute("Item")>
Public MustInherit Class FCSession

[DefaultMemberAttribute("Item")]
public abstract class FCSession

Remarks

To create a session, see FCApplication.CreateSession.

FCFL.NET sessions are stateful containers that are used to remember information about a user during their session using the system. They also provide access to manipulate data and settings in the CRM system.

Inheritance Hierarchy

System.Object [FChoice.Foundation.FCSession** FChoice.Foundation.Clarify.ClarifySession

Requirements

Namespace: FChoice.Foundation

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FCSession Members FChoice.Foundation Namespace FChoice.Foundation.FCSession FChoice.Foundation.Clarify.ClarifySession

Requirements

Namespace: FChoice.Foundation

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FCSession Members FChoice.Foundation Namespace


FCSession Class Members | fcSDK Documentation

FCSession Class Members

The following tables list the members exposed by FCSession.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | ConfigItems | Collection of CRM session configuration items. | | Public Property | ConvertTimeZone | Sets whether or not any DateTimes will be translated to and from ServerTimeZone and LocalTimeZone. Default value is false. | | Public Property | CreationTime | Timestamp when the session was created. | | Public Property | CurrentCulture | Returns the Culture being used by the session. | | Public Property | DataRestrictionsEnabled | | | Public Property | DefaultCulture | Returns the default Culture being used by the session. | | Public Property | DefaultDistinctGenerics | Sets whether or not newly created generic objects will have IsDistinct set to include all relation data fields during Queries.

| | Public Property | DisableDataConversions | Sets whether data conversions happen when GenericDataRow fields are modified. | | Public Property | IncludeRelations | Sets whether or not newly created generic objects will include all relation data fields during Queries. | | Public Property | Item | Get or set session data indexed by specified key. | | Public Property | Items | | | Public Property | LastLoadTime | Timestamp when the session was last loaded via FCApplication.GetSession | | Public Property | LocalTimeZone | The TimeZone being used by the session. | | Public Property | Log | Returns a Logger useful for logging application events or errors to the logging system. | | Public Property | LoginType | Returns the login type of the logged-in user. | | Public Property | MaximumRows | | | Public Property | PasswordRequired | Gets whether or not a password was used when CreateSession was called. | | Public Property | QueryEmptyToNull |

Sets whether or not new newly created generic objects convert filters on empty strings into filters on Queries that check Is NULL or IS NOT NULL.

| | Public Property | RestrictionGroup | Returns the data restriction group being used by the session. | | Public Property | SessionData | | | Public Property | SessionID |

Returns the session's unique identifier.

| | Public Property | SetNullStringsToEmpty | Sets whether or not newly created generic objects will convert a null reference (Nothing in Visual Basic) to empty strings. | | Public Property | TruncateStringFields | Sets whether or not newly created generic objects will truncate string fields if they are too long. | | Public Property | UserID | Returns the unique identifier for the session's logged-in user. | | Public Property | UserName | Returns the login name for the session's logged-in user. |

Public Methods

| | Name | Description | | --- | --- | --- | | Public Method | ChangePassword | Change the password for the session user. | | Public Method | ChangeRestrictionGroup | Changes the RestrictionGroup the session is currently using. The change can be made permanent. | | Public Method | CloseSession | | | Public Method | ConvertDate | Overloaded. Converts a DateTime from one TimeZone to another. | | Public Method | ConvertFromLocalToServerDate | Converts a DateTime from the session timezone to the server timezone. | | Public Method | ConvertFromServerToLocalDate | Converts a DateTime from the server timezone to the session timezone.

| | Public Method | Dispose | | | Public Method | FormatElapsedTime | Overloaded. Formats an numeric value in seconds into a string "DDD HH MMM" where: D=Days, H=Hours, M=Minutes | | Public Method | GetAssignedPermissions | | | Public Method | GetCurrentDate | Retrieves the DateTime of the CRM database. | | Public Method | GetCurrentServerDate | Retrieves the DateTime of the CRM database. | | Public Method | HasPermission | | | Public Method | RefreshContext | Refresh the session information for the logged-in user. | | Public Method | RegisterLicenseRequirements | | | Public Method | SaveSession | | | Public Method | SetPassword | Change a user's password |

Reference

FCSession Class
FChoice.Foundation Namespace


ChangePassword Method (FCSession) | fcSDK Documentation

ChangePassword Method (FCSession)

The new password for the FCSession user

Change the password for the session user.

Syntax

'Declaration

Public Sub ChangePassword( _
   ByVal _newPassword_ As String _
)

public void ChangePassword(
   string _newPassword_
)

Parameters

newPassword

The new password for the FCSession user

Remarks

SetPassword allows changing the password of a non session user.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


ChangeRestrictionGroup Method (FCSession) | fcSDK Documentation

ChangeRestrictionGroup Method (FCSession)

Name of the RestrictionGroupthe session should start using.

Make the new RestrictionGroup permanent.

Changes the RestrictionGroup the session is currently using. The change can be made permanent.

Syntax

'Declaration

Public Overridable Sub ChangeRestrictionGroup( _
   ByVal _newGroupName_ As String, _
   ByVal _saveChange_ As Boolean _
)

public virtual void ChangeRestrictionGroup(
   string _newGroupName_,
   bool _saveChange_
)

Parameters

newGroupName

Name of the RestrictionGroupthe session should start using.

saveChange

Make the new RestrictionGroup permanent.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


CloseSession() Method | fcSDK Documentation

CloseSession() Method

Syntax

'Declaration

Public Sub CloseSession()

public void CloseSession()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


ConvertDate Method (FCSession) | fcSDK Documentation

ConvertDate Method (FCSession)

Converts a DateTime from one TimeZone to another.

Converts a DateTime from one TimeZone to another.

Overload List

Overload | Description
ConvertDate(DateTime,String,String) | Converts a DateTime from one TimeZone to another.
ConvertDate(DateTime,ITimeZone,ITimeZone) | Converts a DateTime from one TimeZone to another.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


ConvertDate(DateTime,String,String) Method | fcSDK Documentation

ConvertDate(DateTime,String,String) Method

date to convert

Timezone name input date is currently in

Timezone name input date is being converted to

Converts a DateTime from one TimeZone to another.

Syntax

'Declaration

Public Overloads Overridable Function ConvertDate( _
   ByVal _date_ As Date, _
   ByVal _fromTZName_ As String, _
   ByVal _toTZName_ As String _
) As Date

public virtual DateTime ConvertDate(
   DateTime _date_,
   string _fromTZName_,
   string _toTZName_
)

Parameters

date

date to convert

fromTZName

Timezone name input date is currently in

toTZName

Timezone name input date is being converted to

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members
Overload List


ConvertDate(DateTime,ITimeZone,ITimeZone) Method | fcSDK Documentation

ConvertDate(DateTime,ITimeZone,ITimeZone) Method

date to convert

Timezone input date is currently in

Timezone input date is being converted to

Converts a DateTime from one TimeZone to another.

Syntax

'Declaration

Public Overloads Overridable Function ConvertDate( _
   ByVal _date_ As Date, _
   ByVal _fromTZ_ As ITimeZone, _
   ByVal _toTZ_ As ITimeZone _
) As Date

public virtual DateTime ConvertDate(
   DateTime _date_,
   ITimeZone _fromTZ_,
   ITimeZone _toTZ_
)

Parameters

date

date to convert

fromTZ

Timezone input date is currently in

toTZ

Timezone input date is being converted to

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members
Overload List


ConvertFromLocalToServerDate Method | fcSDK Documentation

ConvertFromLocalToServerDate Method

date to convert

Converts a DateTime from the session timezone to the server timezone.

Syntax

'Declaration

Public Overridable Function ConvertFromLocalToServerDate( _
   ByVal _date_ As Date _
) As Date

public virtual DateTime ConvertFromLocalToServerDate(
   DateTime _date_
)

Parameters

date

date to convert

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


ConvertFromServerToLocalDate Method | fcSDK Documentation

ConvertFromServerToLocalDate Method

date to convert

Converts a DateTime from the server timezone to the session timezone.

Syntax

'Declaration

Public Overridable Function ConvertFromServerToLocalDate( _
   ByVal _date_ As Date _
) As Date

public virtual DateTime ConvertFromServerToLocalDate(
   DateTime _date_
)

Parameters

date

date to convert

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


Dispose Method (FCSession) | fcSDK Documentation

Dispose Method (FCSession)

Syntax

'Declaration

Public Overridable Sub Dispose()

public virtual void Dispose()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


FormatElapsedTime Method | fcSDK Documentation

FormatElapsedTime Method

Formats an numeric value in seconds into a string "DDD HH MMM" where: D=Days, H=Hours, M=Minutes

Formats a given span of time into the string "DDD HH MMM" where: D=Days, H=Hours, M=Minutes

Overload List

Overload | Description
FormatElapsedTime(Int32) | Formats an numeric value in seconds into a string "DDD HH MMM" where: D=Days, H=Hours, M=Minutes
FormatElapsedTime(Double) | Formats an numeric value in seconds into a string "DDD HH MMM" where: D=Days, H=Hours, M=Minutes
FormatElapsedTime(TimeSpan) | Formats a TimeSpan into a string "DDD HH MMM" where: D=Days, H=Hours, M=Minutes

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


FormatElapsedTime(Int32) Method | fcSDK Documentation

FormatElapsedTime(Int32) Method

Numeric value in seconds to be formatted

Formats an numeric value in seconds into a string "DDD HH MMM" where: D=Days, H=Hours, M=Minutes

Syntax

'Declaration

Public Overloads Overridable Function FormatElapsedTime( _
   ByVal _elapsedTime_ As Integer _
) As String

public virtual string FormatElapsedTime(
   int _elapsedTime_
)

Parameters

elapsedTime

Numeric value in seconds to be formatted

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members
Overload List


FormatElapsedTime(Double) Method | fcSDK Documentation

FormatElapsedTime(Double) Method

Numeric value in seconds to be formatted

Formats an numeric value in seconds into a string "DDD HH MMM" where: D=Days, H=Hours, M=Minutes

Syntax

'Declaration

Public Overloads Overridable Function FormatElapsedTime( _
   ByVal _elapsedTime_ As Double _
) As String

public virtual string FormatElapsedTime(
   double _elapsedTime_
)

Parameters

elapsedTime

Numeric value in seconds to be formatted

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members
Overload List


FormatElapsedTime(TimeSpan) Method | fcSDK Documentation

FormatElapsedTime(TimeSpan) Method

TimeSpan to be formatted

Formats a TimeSpan into a string "DDD HH MMM" where: D=Days, H=Hours, M=Minutes

Syntax

'Declaration

Public Overloads Overridable Function FormatElapsedTime( _
   ByVal _ts_ As TimeSpan _
) As String

public virtual string FormatElapsedTime(
   TimeSpan _ts_
)

Parameters

ts

TimeSpan to be formatted

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members
Overload List


GetAssignedPermissions Method | fcSDK Documentation

GetAssignedPermissions Method

Syntax

'Declaration

Public Overridable Function GetAssignedPermissions() As String()

public virtual string[] GetAssignedPermissions()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


GetCurrentDate Method (FCSession) | fcSDK Documentation

GetCurrentDate Method (FCSession)

Retrieves the DateTime of the CRM database.

Syntax

'Declaration

Public Overridable Function GetCurrentDate() As Date

public virtual DateTime GetCurrentDate()

Return Value

Current DateTime of the CRM database.

Remarks

When ConvertTimeZone is enabled the return value will be converted to the LocalTimeZone.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


GetCurrentServerDate Method (FCSession) | fcSDK Documentation

GetCurrentServerDate Method (FCSession)

Retrieves the DateTime of the CRM database.

Syntax

'Declaration

Public Overridable Function GetCurrentServerDate() As Date

public virtual DateTime GetCurrentServerDate()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


HasPermission Method | fcSDK Documentation

HasPermission Method

Syntax

'Declaration

Public Overridable Function HasPermission( _
   ByVal _permission_ As String _
) As Boolean

public virtual bool HasPermission(
   string _permission_
)

Parameters

permission

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


RefreshContext Method (FCSession) | fcSDK Documentation

RefreshContext Method (FCSession)

Refresh the session information for the logged-in user.

Syntax

'Declaration

Public Overridable Sub RefreshContext()

public virtual void RefreshContext()

Remarks

FCFL.NET sessions are stateful containers that are used to remember information about a user during their session using the system. If session information changes in the database you will need to **RefreshContext **to access those changes from the session.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


RegisterLicenseRequirements Method (FCSession) | fcSDK Documentation

RegisterLicenseRequirements Method (FCSession)

Called by First Choice Software applications to notify the session that a License is required.

Syntax

'Declaration

Public Sub RegisterLicenseRequirements( _
   ByVal _productId_ As Integer _
)

public void RegisterLicenseRequirements(
   int _productId_
)

Parameters

productId

Remarks

NOTE: These methods are for First Choice Software use only.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


SaveSession Method (FCSession) | fcSDK Documentation

SaveSession Method (FCSession)

Syntax

'Declaration

Public Sub SaveSession()

public void SaveSession()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


SetPassword Method (FCSession) | fcSDK Documentation

SetPassword Method (FCSession)

Username whose password is being changed

new password

The login type of the user. This value is CRM specific.

Change a user's password

Syntax

'Declaration

Public Sub SetPassword( _
   ByVal _inUsername_ As String, _
   ByVal _newPass_ As String, _
   ByVal _LoginType_ As Integer _
)

public void SetPassword(
   string _inUsername_,
   string _newPass_,
   int _LoginType_
)

Parameters

inUsername

Username whose password is being changed

newPass

new password

LoginType

The login type of the user. This value is CRM specific.

Remarks

ChangePassword allows changing the password of the session user.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


ConfigItems Property (FCSession) | fcSDK Documentation

ConfigItems Property (FCSession)

Collection of CRM session configuration items.

Syntax

'Declaration

Public ReadOnly Property ConfigItems As ConfigItemCollection

public ConfigItemCollection ConfigItems {get;}

Property Value

A ClarifyConfigItemCollection which contains instances of ClarifyConfigItem which represent each config item for the specified user in the Clarify database.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


ConvertTimeZone Property (FCSession) | fcSDK Documentation

ConvertTimeZone Property (FCSession)

Sets whether or not any DateTimes will be translated to and from ServerTimeZone and LocalTimeZone. Default value is false.

Syntax

'Declaration

Public Property ConvertTimeZone As Boolean

public bool ConvertTimeZone {get; set;}

Property Value

Sets whether or not any DateTimes will be translated to and from ServerTimeZone and LocalTimeZone. Default value is false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


CreationTime Property (FCSession) | fcSDK Documentation

CreationTime Property (FCSession)

Timestamp when the session was created.

Syntax

'Declaration

Public ReadOnly Property CreationTime As Date

public DateTime CreationTime {get;}

Property Value

Timestamp when the session was created.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


CurrentCulture Property (FCSession) | fcSDK Documentation

CurrentCulture Property (FCSession)

Returns the Culture being used by the session.

Syntax

'Declaration

Public Property CurrentCulture As CultureInfo

public CultureInfo CurrentCulture {get; set;}

Property Value

Returns the Culture being used by the session.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


DataRestrictionsEnabled Property (FCSession) | fcSDK Documentation

DataRestrictionsEnabled Property (FCSession)

Syntax

'Declaration

Public Property DataRestrictionsEnabled As Boolean

public bool DataRestrictionsEnabled {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


DefaultCulture Property | fcSDK Documentation

DefaultCulture Property

Returns the default Culture being used by the session.

Syntax

'Declaration

Public ReadOnly Property DefaultCulture As CultureInfo

public CultureInfo DefaultCulture {get;}

Property Value

Returns the default Culture being used by the session.

Remarks

This is the CultureInfo that is used unless the CurrentCulture property is set.

This value currently defaults to the InstalledUICulture.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


DefaultDistinctGenerics Property (FCSession) | fcSDK Documentation

DefaultDistinctGenerics Property (FCSession)

Sets whether or not newly created generic objects will have IsDistinct set to include all relation data fields during Queries.

Syntax

'Declaration

Public Property DefaultDistinctGenerics As Boolean

public bool DefaultDistinctGenerics {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


DisableDataConversions Property | fcSDK Documentation

DisableDataConversions Property

Sets whether data conversions happen when GenericDataRow fields are modified.

Syntax

'Declaration

Public Property DisableDataConversions As Boolean

public bool DisableDataConversions {get; set;}

Property Value

Sets whether data conversions happen when GenericDataRow fields are modified.

Remarks

This property overrides ConvertTimeZone and SetNullStringsToEmpty

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


IncludeRelations Property (FCSession) | fcSDK Documentation

IncludeRelations Property (FCSession)

Sets whether or not newly created generic objects will include all relation data fields during Queries.

Syntax

'Declaration

Public Property IncludeRelations As Boolean

public bool IncludeRelations {get; set;}

Property Value

Sets whether or not new newly created generic objects will include all relation data fields during Queries.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


Item Property (FCSession) | fcSDK Documentation

Item Property (FCSession)

Session data indexer

Get or set session data indexed by specified key.

Syntax

'Declaration

Public Default Property Item( _
   ByVal _key_ As String _
) As Object

public object this\[
   string _key_
\]; {get; set;}

Parameters

key

Session data indexer

Remarks

Details about the logged-in user are populated into this collection during CreateSession.

Note: Application developers can use this repository to store session specific data which will last across session lifetimes until CloseSession is called. You can retrieve a session using FCApplication.GetSession.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


Items Property | fcSDK Documentation

Items Property

Syntax

'Declaration

Public ReadOnly Property Items As IDictionary

public IDictionary Items {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


LastLoadTime Property (FCSession) | fcSDK Documentation

LastLoadTime Property (FCSession)

Timestamp when the session was last loaded via FCApplication.GetSession

Syntax

'Declaration

Public ReadOnly Property LastLoadTime As Date

public DateTime LastLoadTime {get;}

Property Value

Timestamp when the session was last loaded via FCApplication.GetSession

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


LocalTimeZone Property (FCSession) | fcSDK Documentation

LocalTimeZone Property (FCSession)

The TimeZone being used by the session.

Syntax

'Declaration

Public Property LocalTimeZone As ITimeZone

public ITimeZone LocalTimeZone {get; set;}

Property Value

The TimeZone being used by the session.

Remarks

This setting works together with ConvertTimeZone and ServerTimeZone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


Log Property (FCSession) | fcSDK Documentation

Log Property (FCSession)

Returns a Logger useful for logging application events or errors to the logging system.

Syntax

'Declaration

Public ReadOnly Property Log As Logger

public Logger Log {get;}

Property Value

Returns a Logger useful for logging application events or errors to the logging system.

Remarks

Optionally you can use the LogManager to create your own logger objects.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


LoginType Property (FCSession) | fcSDK Documentation

LoginType Property (FCSession)

Returns the login type of the logged-in user.

Syntax

'Declaration

Public ReadOnly Property LoginType As Integer

public int LoginType {get;}

Property Value

Returns the login type of the logged-in user.

Remarks

Login type is a CRM specific value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


MaximumRows Property (FCSession) | fcSDK Documentation

MaximumRows Property (FCSession)

Syntax

'Declaration

Public Property MaximumRows As Integer

public int MaximumRows {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


PasswordRequired Property (FCSession) | fcSDK Documentation

PasswordRequired Property (FCSession)

Gets whether or not a password was used when CreateSession was called.

Syntax

'Declaration

Public ReadOnly Property PasswordRequired As Boolean

public bool PasswordRequired {get;}

Property Value

Gets whether or not a password was used when CreateSession was called.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


QueryEmptyToNull Property (FCSession) | fcSDK Documentation

QueryEmptyToNull Property (FCSession)

Sets whether or not new newly created generic objects convert filters on empty strings into filters on Queries that check Is NULL or IS NOT NULL.

Syntax

'Declaration

Public Property QueryEmptyToNull As Boolean

public bool QueryEmptyToNull {get; set;}

Property Value

Sets whether or not new newly created generic objects convert filters on empty strings into filters on Queries that check Is NULL or IS NOT NULL.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


RestrictionGroup Property (FCSession) | fcSDK Documentation

RestrictionGroup Property (FCSession)

Returns the data restriction group being used by the session.

Syntax

'Declaration

Public ReadOnly Property RestrictionGroup As RestrictionGroup

public RestrictionGroup RestrictionGroup {get;}

Property Value

Returns the data restriction group being used by the session.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


SessionData Property (FCSession) | fcSDK Documentation

SessionData Property (FCSession)

Syntax

'Declaration

Public ReadOnly Property SessionData As FCSessionData

public FCSessionData SessionData {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


SessionID Property (FCSession) | fcSDK Documentation

SessionID Property (FCSession)

Returns the session's unique identifier.

Syntax

'Declaration

Public ReadOnly Property SessionID As Guid

public Guid SessionID {get;}

Property Value

Returns the session's unique identifier.

Remarks

This identifier is used to re-use a session that has already been created via GetSession

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


SetNullStringsToEmpty Property (FCSession) | fcSDK Documentation

SetNullStringsToEmpty Property (FCSession)

Sets whether or not newly created generic objects will convert a null reference (Nothing in Visual Basic) to empty strings.

Syntax

'Declaration

Public Property SetNullStringsToEmpty As Boolean

public bool SetNullStringsToEmpty {get; set;}

Property Value

Sets whether or not newly created generic objects will convert a null reference (Nothing in Visual Basic) to empty strings.

Remarks

This setting only affects Oracle DbProviders.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


TruncateStringFields Property (FCSession) | fcSDK Documentation

TruncateStringFields Property (FCSession)

Sets whether or not newly created generic objects will truncate string fields if they are too long.

Syntax

'Declaration

Public Property TruncateStringFields As Boolean

public bool TruncateStringFields {get; set;}

Property Value

Returns whether or not newly created generic objects will truncate string fields if they are too long.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


UserID Property (FCSession) | fcSDK Documentation

UserID Property (FCSession)

Returns the unique identifier for the session's logged-in user.

Syntax

'Declaration

Public ReadOnly Property UserID As Object

public object UserID {get;}

Property Value

Returns the unique identifier for the session's logged-in user.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


UserName Property (FCSession) | fcSDK Documentation

UserName Property (FCSession)

Returns the login name for the session's logged-in user.

Syntax

'Declaration

Public ReadOnly Property UserName As String

public string UserName {get;}

Property Value

Returns the login name for the session's logged-in user.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


FCSessionData Class | fcSDK Documentation

FCSessionData Class

Repository for session data which is retained by the FCApplication between session uses.

Syntax

'Declaration

<SerializableAttribute()>
Public MustInherit Class FCSessionData

[SerializableAttribute()]
public abstract class FCSessionData

Remarks

Users do not use this object directly but through the FCSession the CRM specific implementation. Session lifetime is maintained by the FCApplication.

All session related information is stored in the FCSessionData object for use across individual FCSession uses.

Inheritance Hierarchy

System.Object
FChoice.Foundation.FCSessionData
FChoice.Foundation.Clarify.ClarifySessionData

Requirements

Namespace: FChoice.Foundation

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FCSessionData Members
FChoice.Foundation Namespace


FCSessionData Class Members | fcSDK Documentation

FCSessionData Class Members

The following tables list the members exposed by FCSessionData.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | DefaultCulture | Default culture of the user session.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | ConfigItems | Collection of CRM session configuration items. | | Public Property | ConvertTimeZone | Session option: Gets whether or not any DateTimes will be translated to and from ServerTimeZone and LocalTimeZone. Default value is false. | | Public Property | CreationTime | Timestamp when the session was created. | | Public Property | CurrentCulture | The Culture being used by the session. | | Public Property | CurResGroup | The restriction group being used by the session. | | Public Property | DefaultDistinctGenerics | Session option which makes Generics have IsDistinct enable by default. | | Public Property | DisableDataConversion | Session option which disables data conversions when values are set for GenericDataRow fields. | | Public Property | DisableRestrictions | Returns whether or not the DataRestrictions feature is enabled or disabled. | | Public Property | EmptyNullStrings | Session option that cues Generics to make Null fields be empty strings. Specifically for Oracle. | | Public Property | IncludeRelations | Session option that cues Generics to include all relation data fields during Queries | | Public Property | IsDirty | | | Public Property | LastLoadTime | Timestamp when the session was last loaded via GetSession | | Public Property | LocalTimeZone | The TimeZone being used by the session. | | Public Property | LoginTime | | | Public Property | LoginType | User login type | | Public Property | MaximumRows | | | Public Property | NewSession | | | Public Property | PasswordRequired | Session option denoting whether a password was used to create a session. | | Public Property | Permissions | | | Public Property | QueryEmptyToNull | Session option that cues Generics to convert filters on empty strings into filters on Queries that check Is NULL or IS NOT NULL. | | Public Property | SessionData | CRM configurable session data populates this property during CreateSession | | Public Property | SessionID | A session's unique identifier.

| | Public Property | TruncateStringFields | Session option that cues Generics to truncate strings that exceed database field lengths when assigned to a GenericDataRow | | Public Property | UserID | UniqueID of the user that created the Session. | | Public Property | UserName | Name of the user that created the Session. |

Public Methods

 | Name | Description
Public Method | CopyTo |

Reference

FCSessionData Class
FChoice.Foundation Namespace


CopyTo Method (FCSessionData) | fcSDK Documentation

CopyTo Method (FCSessionData)

Syntax

'Declaration

Public Overridable Sub CopyTo( _
   ByVal _newData_ As FCSessionData _
)

public virtual void CopyTo(
   FCSessionData _newData_
)

Parameters

newData

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSessionData Class
FCSessionData Members


ConfigItems Property (FCSessionData) | fcSDK Documentation

ConfigItems Property (FCSessionData)

Collection of CRM session configuration items.

Syntax

'Declaration

Public Property ConfigItems As ConfigItemCollection

public ConfigItemCollection ConfigItems {get; set;}

Property Value

A ClarifyConfigItemCollection which contains instances of ClarifyConfigItem which represent each config item for the specified user in the Clarify database.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSessionData Class
FCSessionData Members


ConvertTimeZone Property (FCSessionData) | fcSDK Documentation

ConvertTimeZone Property (FCSessionData)

Session option: Gets whether or not any DateTimes will be translated to and from ServerTimeZone and LocalTimeZone. Default value is false.

Syntax

'Declaration

Public Property ConvertTimeZone As Boolean

public bool ConvertTimeZone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSessionData Class
FCSessionData Members


CreationTime Property (FCSessionData) | fcSDK Documentation

CreationTime Property (FCSessionData)

Timestamp when the session was created.

Syntax

'Declaration

Public ReadOnly Property CreationTime As Date

public DateTime CreationTime {get;}

Property Value

Timestamp when the session was created.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSessionData Class
FCSessionData Members


CurrentCulture Property (FCSessionData) | fcSDK Documentation

CurrentCulture Property (FCSessionData)

The Culture being used by the session.

Syntax

'Declaration

Public Property CurrentCulture As CultureInfo

public CultureInfo CurrentCulture {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSessionData Class
FCSessionData Members


CurResGroup Property | fcSDK Documentation

CurResGroup Property

The restriction group being used by the session.

Syntax

'Declaration

Public Property CurResGroup As RestrictionGroup

public RestrictionGroup CurResGroup {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSessionData Class
FCSessionData Members


DefaultDistinctGenerics Property (FCSessionData) | fcSDK Documentation

DefaultDistinctGenerics Property (FCSessionData)

Session option which makes Generics have IsDistinct enable by default.

Syntax

'Declaration

Public Property DefaultDistinctGenerics As Boolean

public bool DefaultDistinctGenerics {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSessionData Class
FCSessionData Members


DisableDataConversion Property | fcSDK Documentation

DisableDataConversion Property

Session option which disables data conversions when values are set for GenericDataRow fields.

Syntax

'Declaration

Public Property DisableDataConversion As Boolean

public bool DisableDataConversion {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSessionData Class
FCSessionData Members


DisableRestrictions Property | fcSDK Documentation

DisableRestrictions Property

Returns whether or not the DataRestrictions feature is enabled or disabled.

Syntax

'Declaration

Public Property DisableRestrictions As Boolean

public bool DisableRestrictions {get; set;}

Property Value

Returns whether or not the DataRestrictions feature is enabled or disabled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSessionData Class
FCSessionData Members


EmptyNullStrings Property | fcSDK Documentation

EmptyNullStrings Property

Session option that cues Generics to make Null fields be empty strings. Specifically for Oracle.

Syntax

'Declaration

Public Property EmptyNullStrings As Boolean

public bool EmptyNullStrings {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSessionData Class
FCSessionData Members


IncludeRelations Property (FCSessionData) | fcSDK Documentation

IncludeRelations Property (FCSessionData)

Session option that cues Generics to include all relation data fields during Queries

Syntax

'Declaration

Public Property IncludeRelations As Boolean

public bool IncludeRelations {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSessionData Class
FCSessionData Members


IsDirty Property (FCSessionData) | fcSDK Documentation

IsDirty Property (FCSessionData)

Syntax

'Declaration

Public Property IsDirty As Boolean

public bool IsDirty {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSessionData Class
FCSessionData Members


LastLoadTime Property (FCSessionData) | fcSDK Documentation

LastLoadTime Property (FCSessionData)

Timestamp when the session was last loaded via GetSession

Syntax

'Declaration

Public Property LastLoadTime As Date

public DateTime LastLoadTime {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSessionData Class
FCSessionData Members


LocalTimeZone Property (FCSessionData) | fcSDK Documentation

LocalTimeZone Property (FCSessionData)

The TimeZone being used by the session.

Syntax

'Declaration

Public Property LocalTimeZone As ITimeZone

public ITimeZone LocalTimeZone {get; set;}

Property Value

The TimeZone being used by the session.

Remarks

This setting works together with ConvertTimeZone and ServerTimeZone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSessionData Class
FCSessionData Members


LoginTime Property (FCSessionData) | fcSDK Documentation

LoginTime Property (FCSessionData)

Syntax

'Declaration

Public Property LoginTime As Nullable(Of Date)

public Nullable<DateTime> LoginTime {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSessionData Class
FCSessionData Members


LoginType Property (FCSessionData) | fcSDK Documentation

LoginType Property (FCSessionData)

User login type

Syntax

'Declaration

Public Property LoginType As Integer

public int LoginType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSessionData Class
FCSessionData Members


MaximumRows Property (FCSessionData) | fcSDK Documentation

MaximumRows Property (FCSessionData)

Syntax

'Declaration

Public Property MaximumRows As Integer

public int MaximumRows {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSessionData Class
FCSessionData Members


NewSession Property | fcSDK Documentation

NewSession Property

Syntax

'Declaration

Public Property NewSession As Boolean

public bool NewSession {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSessionData Class
FCSessionData Members


PasswordRequired Property (FCSessionData) | fcSDK Documentation

PasswordRequired Property (FCSessionData)

Session option denoting whether a password was used to create a session.

Syntax

'Declaration

Public Property PasswordRequired As Boolean

public bool PasswordRequired {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSessionData Class
FCSessionData Members


Permissions Property | fcSDK Documentation

Permissions Property

Syntax

'Declaration

Public ReadOnly Property Permissions As IDictionary(Of String,Boolean)

public IDictionary<string,bool> Permissions {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSessionData Class
FCSessionData Members


QueryEmptyToNull Property (FCSessionData) | fcSDK Documentation

QueryEmptyToNull Property (FCSessionData)

Session option that cues Generics to convert filters on empty strings into filters on Queries that check Is NULL or IS NOT NULL.

Syntax

'Declaration

Public Property QueryEmptyToNull As Boolean

public bool QueryEmptyToNull {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSessionData Class
FCSessionData Members


SessionData Property (FCSessionData) | fcSDK Documentation

SessionData Property (FCSessionData)

CRM configurable session data populates this property during CreateSession

Syntax

'Declaration

Public ReadOnly Property SessionData As Hashtable

public Hashtable SessionData {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSessionData Class
FCSessionData Members


SessionID Property (FCSessionData) | fcSDK Documentation

SessionID Property (FCSessionData)

A session's unique identifier.

Syntax

'Declaration

Public Property SessionID As Guid

public Guid SessionID {get; set;}

Remarks

This identifier is used to re-use a session that has already been created via GetSession

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSessionData Class
FCSessionData Members


TruncateStringFields Property (FCSessionData) | fcSDK Documentation

TruncateStringFields Property (FCSessionData)

Session option that cues Generics to truncate strings that exceed database field lengths when assigned to a GenericDataRow

Syntax

'Declaration

Public Property TruncateStringFields As Boolean

public bool TruncateStringFields {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSessionData Class
FCSessionData Members


UserID Property (FCSessionData) | fcSDK Documentation

UserID Property (FCSessionData)

UniqueID of the user that created the Session.

Syntax

'Declaration

Public Property UserID As Object

public object UserID {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSessionData Class
FCSessionData Members


UserName Property (FCSessionData) | fcSDK Documentation

UserName Property (FCSessionData)

Name of the user that created the Session.

Syntax

'Declaration

Public Property UserName As String

public string UserName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSessionData Class
FCSessionData Members


DefaultCulture Field | fcSDK Documentation

DefaultCulture Field

Default culture of the user session.

Syntax

'Declaration

Public Shared ReadOnly DefaultCulture As CultureInfo

public static readonly CultureInfo DefaultCulture

Remarks

This currently defaults to the InstalledUICulture.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSessionData Class
FCSessionData Members


FCSessionSummary Class | fcSDK Documentation

FCSessionSummary Class

Represents a summary view of the session for reporting purposes.

Syntax

'Declaration

Public Class FCSessionSummary

public class FCSessionSummary

Remarks

FCApplication.CurrentSessions returns an Array of FCSessionSummary objects for viewing basic information about the sessions currently running.

Inheritance Hierarchy

System.Object
FChoice.Foundation.FCSessionSummary

Requirements

Namespace: FChoice.Foundation

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FCSessionSummary Members
FChoice.Foundation Namespace


FCSessionSummary Class Members | fcSDK Documentation

FCSessionSummary Class Members

The following tables list the members exposed by FCSessionSummary.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | CreationTime | Timestamp when the session was created. | | Public Property | LastLoadTime | Timestamp when the session was last loaded via FCApplication.GetSession | | Public Property | LoginType | | | Public Property | SessionID | Returns the session's unique identifier.

| | Public Property | UserID | Returns the unique identifier for the session's logged-in user. | | Public Property | UserName | Returns the login name for the session's logged-in user. |

Reference

FCSessionSummary Class
FChoice.Foundation Namespace


CreationTime Property (FCSessionSummary) | fcSDK Documentation

CreationTime Property (FCSessionSummary)

Timestamp when the session was created.

Syntax

'Declaration

Public ReadOnly Property CreationTime As Date

public DateTime CreationTime {get;}

Property Value

Timestamp when the session was created.

Remarks

Based on FCSession.CreationTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSessionSummary Class
FCSessionSummary Members


LastLoadTime Property (FCSessionSummary) | fcSDK Documentation

LastLoadTime Property (FCSessionSummary)

Timestamp when the session was last loaded via FCApplication.GetSession

Syntax

'Declaration

Public ReadOnly Property LastLoadTime As Date

public DateTime LastLoadTime {get;}

Property Value

Timestamp when the session was last loaded via FCApplication.GetSession

Remarks

Based on FCSession.LastLoadTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSessionSummary Class
FCSessionSummary Members


LoginType Property (FCSessionSummary) | fcSDK Documentation

LoginType Property (FCSessionSummary)

Syntax

'Declaration

Public ReadOnly Property LoginType As Integer

public int LoginType {get;}

[!include[Requirements]emarks

Based on FCSession.LoginType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSessionSummary Class
FCSessionSummary Members


SessionID Property (FCSessionSummary) | fcSDK Documentation

SessionID Property (FCSessionSummary)

Returns the session's unique identifier.

Syntax

'Declaration

Public ReadOnly Property SessionID As Guid

public Guid SessionID {get;}

Property Value

Returns the session's unique identifier.

Remarks

Based on FCSession.SessionID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSessionSummary Class
FCSessionSummary Members


UserID Property (FCSessionSummary) | fcSDK Documentation

UserID Property (FCSessionSummary)

Returns the unique identifier for the session's logged-in user.

Syntax

'Declaration

Public ReadOnly Property UserID As Object

public object UserID {get;}

Property Value

Returns the unique identifier for the session's logged-in user.

Remarks

Based on FCSession.UserID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSessionSummary Class
FCSessionSummary Members


UserName Property (FCSessionSummary) | fcSDK Documentation

UserName Property (FCSessionSummary)

Returns the login name for the session's logged-in user.

Syntax

'Declaration

Public ReadOnly Property UserName As String

public string UserName {get;}

Property Value

Returns the login name for the session's logged-in user.

Remarks

Based on FCSession.Username

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSessionSummary Class
FCSessionSummary Members


FoundationException Class | fcSDK Documentation

FoundationException Class

The exception that is thrown when an error occurs in Foundation.

Syntax

'Declaration

<SerializableAttribute()>
Public Class FoundationException
   Inherits FChoice.Common.FCExceptionBase

[SerializableAttribute()]
public class FoundationException : FChoice.Common.FCExceptionBase

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
FChoice.Common.FCExceptionBase
FChoice.Foundation.FoundationException
FChoice.Foundation.FCInvalidLoginException
FChoice.Foundation.GenericException

Requirements

Namespace: FChoice.Foundation

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FoundationException Members
FChoice.Foundation Namespace


FoundationException Class Members | fcSDK Documentation

FoundationException Class Members

The following tables list the members exposed by FoundationException.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorCode | Gets the unique error code for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | ErrorMessageID | Gets the message identifier for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | Sets the SerializationInfo object with the parameter name and additional exception information. (Inherited from FChoice.Common.FCExceptionBase)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)

Reference

FoundationException Class
FChoice.Foundation Namespace


GenericDataRow Class | fcSDK Documentation

GenericDataRow Class

Represents a row of data in a GenericDataTable.

Syntax

'Declaration

<DefaultMemberAttribute("Item")>
Public MustInherit Class GenericDataRow
   Inherits System.Data.DataRow

[DefaultMemberAttribute("Item")]
public abstract class GenericDataRow : System.Data.DataRow

Remarks

GenericDataRow

Inheritance Hierarchy

System.Object System.Data.DataRow [FChoice.Foundation.GenericDataRow** FChoice.Foundation.Clarify.ClarifyDataRow

Requirements

Namespace: FChoice.Foundation

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

GenericDataRow Members FChoice.Foundation Namespace FChoice.Foundation.GenericDataRow FChoice.Foundation.Clarify.ClarifyDataRow

Requirements

Namespace: FChoice.Foundation

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

GenericDataRow Members FChoice.Foundation Namespace


GenericDataRow Class Members | fcSDK Documentation

GenericDataRow Class Members

The following tables list the members exposed by GenericDataRow.

Public Properties

 | Name | Description
Public Property | ForcedUpdateColumns |
Public Property | HasErrors | (Inherited from System.Data.DataRow)
Public Property | IsAddForUpdate | Gets a value indicating whether this GenericDataRow was added via AddForUpdate.
Public Property | IsNew | Gets a value indicating whether the current GenericDataRow was added and not yet committed.
Public Property | Item |
Public Property | ItemArray | (Inherited from System.Data.DataRow)
Public Property | RowError | (Inherited from System.Data.DataRow)
Public Property | RowGuid | Unique row identifier
Public Property | RowState | (Inherited from System.Data.DataRow)
Public Property | Table | (Inherited from System.Data.DataRow)
Public Property | UniqueID | Returns Unique Identifier of this row in the database.

Public Methods

 | Name | Description
Public Method | AcceptChanges | (Inherited from System.Data.DataRow)
static (Shared in Visual Basic) | AreIDsEqual | Used to compare the UniqueIDs of two GenericDataRows.
Public Method | BeginEdit | (Inherited from System.Data.DataRow)
Public Method | CancelEdit | (Inherited from System.Data.DataRow)
Public Method | ClearErrors | (Inherited from System.Data.DataRow)
Public Method | Delete | (Inherited from System.Data.DataRow)
Public Method | EndEdit | (Inherited from System.Data.DataRow)
Public Method | GetChildRows | Overloaded. (Inherited from System.Data.DataRow)
Public Method | GetColumnError | Overloaded. (Inherited from System.Data.DataRow)
Public Method | GetColumnsInError | (Inherited from System.Data.DataRow)
Public Method | GetParentRow | Overloaded. (Inherited from System.Data.DataRow)
Public Method | GetParentRows | Overloaded. (Inherited from System.Data.DataRow)
Public Method | HasVersion | (Inherited from System.Data.DataRow)
Public Method | IsForcedUpdateColumn |
Public Method | IsNull | Overloaded. (Inherited from System.Data.DataRow)
Public Method | RejectChanges | (Inherited from System.Data.DataRow)
Public Method | RelateByID | Relate a unique identifier to this GenericDataRow via a SchemaRelation name.
Public Method | RelateRecord | Relate a given row to this GenericDataRow via a SchemaRelation name.
Public Method | RelateToIntField | Relate a given row's identifier to an Integer field present on this GenericDataRow.
Public Method | SetAdded | (Inherited from System.Data.DataRow)
Public Method | SetColumnError | Overloaded. (Inherited from System.Data.DataRow)
Public Method | SetModified | (Inherited from System.Data.DataRow)
Public Method | SetParentRow | Overloaded. (Inherited from System.Data.DataRow)
Public Method | Unrelate | UnRelate this GenericDataRow from a single row related to it via the given relation name.
Public Method | UnrelateFromAll | UnRelate this GenericDataRow from all other rows related to it via the given relation name.
Public Method | Update | Overloaded. Commits the row to the database. See FCGeneric's Update for details.

Reference

GenericDataRow Class
FChoice.Foundation Namespace


AreIDsEqual Method | fcSDK Documentation

AreIDsEqual Method

Id of the first object being compared.

Id of the second object being compared.

Used to compare the UniqueIDs of two GenericDataRows.

Syntax

'Declaration

Public Shared Function AreIDsEqual( _
   ByVal _id1_ As Object, _
   ByVal _id2_ As Object _
) As Boolean

public static bool AreIDsEqual(
   object _id1_,
   object _id2_
)

Parameters

id1

Id of the first object being compared.

id2

Id of the second object being compared.

Return Value

The result indicates if the two Unique Identifies are the same.

Remarks

In the Foundation namespace we do not know how the Unique Identifiers of a GenericDataRow are implemented. Use this method whenever comparing GenericDataRows in the Foundation namespace.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataRow Class
GenericDataRow Members


IsForcedUpdateColumn Method | fcSDK Documentation

IsForcedUpdateColumn Method

Syntax

'Declaration

Public Function IsForcedUpdateColumn( _
   ByVal _col_ As DataColumn _
) As Boolean

public bool IsForcedUpdateColumn(
   DataColumn _col_
)

Parameters

col

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataRow Class
GenericDataRow Members


RelateByID Method (GenericDataRow) | fcSDK Documentation

RelateByID Method (GenericDataRow)

Unique Id of a row you wish to relate to this GenericDataRow.

The relation name

Relate a unique identifier to this GenericDataRow via a SchemaRelation name.

Syntax

'Declaration

Public Sub RelateByID( _
   ByVal _uniqueId_ As Object, _
   ByVal _relationName_ As String _
)

public void RelateByID(
   object _uniqueId_,
   string _relationName_
)

Parameters

uniqueId

Unique Id of a row you wish to relate to this GenericDataRow.

relationName

The relation name

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataRow Class
GenericDataRow Members


RelateRecord Method | fcSDK Documentation

RelateRecord Method

The row which the current GenericDataRow is being related to.

The relation name

Relate a given row to this GenericDataRow via a SchemaRelation name.

Syntax

'Declaration

Public Sub RelateRecord( _
   ByVal _otherRow_ As GenericDataRow, _
   ByVal _relationName_ As String _
)

public void RelateRecord(
   GenericDataRow _otherRow_,
   string _relationName_
)

Parameters

otherRow

The row which the current GenericDataRow is being related to.

relationName

The relation name

Remarks

The relationName must be a valid relation available between the two Generic's object types.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataRow Class
GenericDataRow Members


RelateToIntField Method | fcSDK Documentation

RelateToIntField Method

The row whose unique Id will be put into the current row's Integer field.

Name of the Integer field which will receive the unique identifier of the otherRow.

Relate a given row's identifier to an Integer field present on this GenericDataRow.

Syntax

'Declaration

Public Sub RelateToIntField( _
   ByVal _otherRow_ As GenericDataRow, _
   ByVal _intFieldName_ As String _
)

public void RelateToIntField(
   GenericDataRow _otherRow_,
   string _intFieldName_
)

Parameters

otherRow

The row whose unique Id will be put into the current row's Integer field.

intFieldName

Name of the Integer field which will receive the unique identifier of the otherRow.

Remarks

This relation method does not require that there be a relation present between the two rows being related. It is recommended that you use RelateRecord whenever possible.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataRow Class
GenericDataRow Members


Unrelate Method | fcSDK Documentation

Unrelate Method

Row to unrelate from the current GenericDataRow

Name of the relation being unrelated from the given row.

UnRelate this GenericDataRow from a single row related to it via the given relation name.

Syntax

'Declaration

Public Sub Unrelate( _
   ByVal _otherRow_ As GenericDataRow, _
   ByVal _relationName_ As String _
)

public void Unrelate(
   GenericDataRow _otherRow_,
   string _relationName_
)

Parameters

otherRow

Row to unrelate from the current GenericDataRow

relationName

Name of the relation being unrelated from the given row.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataRow Class
GenericDataRow Members


UnrelateFromAll Method | fcSDK Documentation

UnrelateFromAll Method

Name of the relation being unrelated.

UnRelate this GenericDataRow from all other rows related to it via the given relation name.

Syntax

'Declaration

Public Sub UnrelateFromAll( _
   ByVal _relationName_ As String _
)

public void UnrelateFromAll(
   string _relationName_
)

Parameters

relationName

Name of the relation being unrelated.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataRow Class
GenericDataRow Members


Update Method (GenericDataRow) | fcSDK Documentation

Update Method (GenericDataRow)

Commits the row to the database. See FCGeneric's Update for details.

Commits the row to the database. See FCGeneric's Update for details.

Overload List

Overload | Description
Update() | Commits the row to the database. See FCGeneric's Update for details.
Update(UpdateQueryBatch) | Commits the row to the database. See FCGeneric's Update for details.
Update(IDbTransaction) | Commits the row to the database. See FCGeneric's Update for details.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataRow Class
GenericDataRow Members


Update() Method | fcSDK Documentation

Update() Method

Commits the row to the database. See FCGeneric's Update for details.

Syntax

'Declaration

Public Overloads Sub Update()

public void Update()

Remarks

NOTE: This method calls FCGeneric.Update

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataRow Class
GenericDataRow Members
Overload List


Update(UpdateQueryBatch) Method | fcSDK Documentation

Update(UpdateQueryBatch) Method

Batch under which to do this update.

Commits the row to the database. See FCGeneric's Update for details.

Syntax

'Declaration

Public Overloads Sub Update( _
   ByVal _batch_ As UpdateQueryBatch _
)

public void Update(
   UpdateQueryBatch _batch_
)

Parameters

batch

Batch under which to do this update.

Remarks

NOTE: This method calls FCGeneric.Update

When it is desirable to consolidate many database operations in one round trip to the database this method can be used in conjunction with a UpdateQueryBatch object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataRow Class
GenericDataRow Members
Overload List


Update(IDbTransaction) Method | fcSDK Documentation

Update(IDbTransaction) Method

Transaction under which to do this update.

Commits the row to the database. See FCGeneric's Update for details.

Syntax

'Declaration

Public Overloads Sub Update( _
   ByVal _trans_ As IDbTransaction _
)

public void Update(
   IDbTransaction _trans_
)

Parameters

trans

Transaction under which to do this update.

Remarks

NOTE: This method calls FCGeneric.Update

Use this method when it is desired to execute database actions under the context of a Transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataRow Class
GenericDataRow Members
Overload List


ForcedUpdateColumns Property | fcSDK Documentation

ForcedUpdateColumns Property

Syntax

'Declaration

Public ReadOnly Property ForcedUpdateColumns As DataColumn()

public DataColumn[] ForcedUpdateColumns {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataRow Class
GenericDataRow Members


IsAddForUpdate Property | fcSDK Documentation

IsAddForUpdate Property

Gets a value indicating whether this GenericDataRow was added via AddForUpdate.

Syntax

'Declaration

Public ReadOnly Property IsAddForUpdate As Boolean

public bool IsAddForUpdate {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataRow Class
GenericDataRow Members


IsNew Property | fcSDK Documentation

IsNew Property

Gets a value indicating whether the current GenericDataRow was added and not yet committed.

Syntax

'Declaration

Public ReadOnly Property IsNew As Boolean

public bool IsNew {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataRow Class
GenericDataRow Members


Item Property (GenericDataRow) | fcSDK Documentation

Item Property (GenericDataRow)

Gets or sets data stored in a specified column.

In C#, this property is the indexer for the GenericDataRow class.

Syntax

'Declaration

Public Shadows Default Property Item( _
   ByVal _column_ As DataColumn, _
   ByVal _version_ As DataRowVersion _
) As Object

public new object this\[
   DataColumn _column_,
   DataRowVersion _version_
\]; {get; set;}

Parameters

column

version

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataRow Class
GenericDataRow Members


RowGuid Property | fcSDK Documentation

RowGuid Property

Unique row identifier

Syntax

'Declaration

Public ReadOnly Property RowGuid As Guid

public Guid RowGuid {get;}

Property Value

Unique row identifier

Remarks

Used internally for reconciling rows after updates are complete.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataRow Class
GenericDataRow Members


UniqueID Property (GenericDataRow) | fcSDK Documentation

UniqueID Property (GenericDataRow)

Returns Unique Identifier of this row in the database.

Syntax

'Declaration

Public ReadOnly Property UniqueID As Object

public object UniqueID {get;}

Property Value

Returns Unique Identifier of this row in the database.

Remarks

The actual type of the object returned will vary on the CRM being implemented. For example in Clarify this value is the objId field and is an Int32.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataRow Class
GenericDataRow Members


GenericDataRowCollection Class | fcSDK Documentation

GenericDataRowCollection Class

Represents a collection of rows for a GenericDataTable.

Syntax

'Declaration

<DefaultMemberAttribute("Item")>
Public MustInherit Class GenericDataRowCollection

[DefaultMemberAttribute("Item")]
public abstract class GenericDataRowCollection

Remarks

Inheritance Hierarchy

System.Object [FChoice.Foundation.GenericDataRowCollection** FChoice.Foundation.Clarify.ClarifyRowCollection

Requirements

Namespace: FChoice.Foundation

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

GenericDataRowCollection Members FChoice.Foundation Namespace FChoice.Foundation.GenericDataRowCollection FChoice.Foundation.Clarify.ClarifyRowCollection

Requirements

Namespace: FChoice.Foundation

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

GenericDataRowCollection Members FChoice.Foundation Namespace


GenericDataRowCollection Class Members | fcSDK Documentation

GenericDataRowCollection Class Members

The following tables list the members exposed by GenericDataRowCollection.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | Count | Gets the total number of elements in a collection. | | Public Property | IsSynchronized | Gets a value indicating whether the GenericDataRowCollection is synchronized. | | Public Property | Item | Gets the row at the specified index.

[C#] In C#, this property is the indexer for the GenericDataRowCollection class.

| | Public Property | SyncRoot | Gets an object that can be used to synchronize the collection. | | Public Property | Table | Reference to the GenericDataTable this collection belongs to. |

Public Methods

 | Name | Description
Public Method | Add | Adds the specified GenericDataRow to the collection.
Public Method | Contains | Overloaded. Test if one ore more GenericDataRows are already in the collection.
Public Method | CopyTo | Copies all the elements of the current GenericDataRowCollection to a one-dimensional Array, starting at the specified index.
Public Method | Find | Overloaded. Gets the row containing the specified primary key values.
Public Method | GetEnumerator | Gets an IEnumerator for the collection.

Reference

GenericDataRowCollection Class
FChoice.Foundation Namespace


Add Method (GenericDataRowCollection) | fcSDK Documentation

Add Method (GenericDataRowCollection)

The GenericDataRow to add.

Adds the specified GenericDataRow to the collection.

Syntax

'Declaration

Public Sub Add( _
   ByVal _row_ As GenericDataRow _
)

public void Add(
   GenericDataRow _row_
)

Parameters

row

The GenericDataRow to add.

Remarks

Add's implementation is delegated to DataRowCollection's Add

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataRowCollection Class
GenericDataRowCollection Members


Contains Method (GenericDataRowCollection) | fcSDK Documentation

Contains Method (GenericDataRowCollection)

Test if one ore more GenericDataRows are already in the collection.

Test if GenericDataRow is already in the collection.

Overload List

Overload | Description
Contains(Object[]) | Test if one ore more GenericDataRows are already in the collection.
Contains(Object) | Test if a single GenericDataRow is already in the collection.

Remarks

The implementation of Contains is delegated to DataRowCollection's Contains.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataRowCollection Class
GenericDataRowCollection Members


Contains(Object[]) Method | fcSDK Documentation

Contains(Object[]) Method

The value of the primary key to test for.

Test if one ore more GenericDataRows are already in the collection.

Syntax

'Declaration

Public Overloads Function Contains( _
   ByVal _keys_() As Object _
) As Boolean

public bool Contains(
   object\[\] _keys_
)

Parameters

keys

The value of the primary key to test for.

Remarks

The implementation of Contains is delegated to DataRowCollection's Contains.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataRowCollection Class
GenericDataRowCollection Members
Overload List


Contains(Object) Method | fcSDK Documentation

Contains(Object) Method

The value of the primary key to test for.

Test if a single GenericDataRow is already in the collection.

Syntax

'Declaration

Public Overloads Function Contains( _
   ByVal _key_ As Object _
) As Boolean

public bool Contains(
   object _key_
)

Parameters

key

The value of the primary key to test for.

Remarks

The implementation of Contains is delegated to DataRowCollection's Contains.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataRowCollection Class
GenericDataRowCollection Members
Overload List


CopyTo Method (GenericDataRowCollection) | fcSDK Documentation

CopyTo Method (GenericDataRowCollection)

The one-dimensional Array to copy the current object's elements into.

The destination Array index to start copying into.

Copies all the elements of the current GenericDataRowCollection to a one-dimensional Array, starting at the specified index.

Syntax

'Declaration

Public Sub CopyTo( _
   ByVal _array_ As Array, _
   ByVal _index_ As Integer _
)

public void CopyTo(
   Array _array_,
   int _index_
)

Parameters

array

The one-dimensional Array to copy the current object's elements into.

index

The destination Array index to start copying into.

Remarks

The implementation of CopyTo is delegated to DataRowCollection's CopyTo

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataRowCollection Class
GenericDataRowCollection Members


Find Method (GenericDataRowCollection) | fcSDK Documentation

Find Method (GenericDataRowCollection)

Gets the row containing the specified primary key values.

Gets a specified GenericDataRow.

Overload List

Overload | Description
Find(Object[]) | Gets the row containing the specified primary key values.
Find(Object) | Gets the row specified by the primary key value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataRowCollection Class
GenericDataRowCollection Members


Find(Object[]) Method | fcSDK Documentation

Find(Object[]) Method

An array of primary key values to find. The type of the array is Object.

Gets the row containing the specified primary key values.

Syntax

'Declaration

Public Overloads Function Find( _
   ByVal _keys_() As Object _
) As GenericDataRow

public GenericDataRow Find(
   object\[\] _keys_
)

Parameters

keys

An array of primary key values to find. The type of the array is Object.

Remarks

The implementation of Find is delegated to DataRowCollection's Find.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataRowCollection Class
GenericDataRowCollection Members
Overload List


Find(Object) Method | fcSDK Documentation

Find(Object) Method

The primary key value of the GenericDataRow to find.

Gets the row specified by the primary key value.

Syntax

'Declaration

Public Overloads Function Find( _
   ByVal _key_ As Object _
) As GenericDataRow

public GenericDataRow Find(
   object _key_
)

Parameters

key

The primary key value of the GenericDataRow to find.

Remarks

The implementation of Find is delegated to DataRowCollection's Find.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataRowCollection Class
GenericDataRowCollection Members
Overload List


GetEnumerator Method (GenericDataRowCollection) | fcSDK Documentation

GetEnumerator Method (GenericDataRowCollection)

Gets an IEnumerator for the collection.

Syntax

'Declaration

Public Function GetEnumerator() As IEnumerator

public IEnumerator GetEnumerator()

Return Value

An IEnumerator for the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataRowCollection Class
GenericDataRowCollection Members


Count Property (GenericDataRowCollection) | fcSDK Documentation

Count Property (GenericDataRowCollection)

Gets the total number of elements in a collection.

Syntax

'Declaration

Public ReadOnly Property Count As Integer

public int Count {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataRowCollection Class
GenericDataRowCollection Members


IsSynchronized Property (GenericDataRowCollection) | fcSDK Documentation

IsSynchronized Property (GenericDataRowCollection)

Gets a value indicating whether the GenericDataRowCollection is synchronized.

Syntax

'Declaration

Public ReadOnly Property IsSynchronized As Boolean

public bool IsSynchronized {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataRowCollection Class
GenericDataRowCollection Members


Item Property (GenericDataRowCollection) | fcSDK Documentation

Item Property (GenericDataRowCollection)

The zero-based index of the row to return.

Gets the row at the specified index.

In C#, this property is the indexer for the GenericDataRowCollection class.

Syntax

'Declaration

Public ReadOnly Default Property Item( _
   ByVal _index_ As Integer _
) As GenericDataRow

public GenericDataRow this[
   int _index_
]; {get;}

Parameters

index

The zero-based index of the row to return.

Property Value

The specified GenericDataRow.

Remarks

Use the Contains method to determine if a given value exists in the key column of a row.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataRowCollection Class
GenericDataRowCollection Members


SyncRoot Property (GenericDataRowCollection) | fcSDK Documentation

SyncRoot Property (GenericDataRowCollection)

Gets an object that can be used to synchronize the collection.

Syntax

'Declaration

Public ReadOnly Property SyncRoot As Object

public object SyncRoot {get;}

Property Value

The object used to synchronize the collection.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataRowCollection Class
GenericDataRowCollection Members


Table Property (GenericDataRowCollection) | fcSDK Documentation

Table Property (GenericDataRowCollection)

Reference to the GenericDataTable this collection belongs to.

Syntax

'Declaration

Public ReadOnly Property Table As GenericDataTable

public GenericDataTable Table {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataRowCollection Class
GenericDataRowCollection Members


GenericDataSet Class | fcSDK Documentation

GenericDataSet Class

Syntax

'Declaration

Public MustInherit Class GenericDataSet

public abstract class GenericDataSet

Inheritance Hierarchy

System.Object
FChoice.Foundation.GenericDataSet
FChoice.Foundation.Clarify.ClarifyDataSet

Requirements

Namespace: FChoice.Foundation

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

GenericDataSet Members
FChoice.Foundation Namespace


GenericDataSet Class Members | fcSDK Documentation

GenericDataSet Class Members

The following tables list the members exposed by GenericDataSet.

Public Properties

 | Name | Description
Public Property | DataSet |
Public Property | RestrictionGroup |
Public Property | SortGenerics |
Public Property | UniqueID |

Public Methods

 | Name | Description
Public Method | Query | Overloaded.
Public Method | Update | Overloaded.

Reference

GenericDataSet Class
FChoice.Foundation Namespace


Query Method (GenericDataSet) | fcSDK Documentation

Query Method (GenericDataSet)

Overload List

Overload | Description
Query(FCGeneric[]) |
Query(IDbTransaction,FCGeneric[]) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataSet Class
GenericDataSet Members


Query(FCGeneric[]) Method | fcSDK Documentation

Query(FCGeneric[]) Method

Syntax

'Declaration

Public Overloads Sub Query( _
   ByVal ParamArray _generics_() As FCGeneric _
)

public void Query(
   params FCGeneric\[\] _generics_
)

Parameters

generics

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataSet Class
GenericDataSet Members
Overload List


Query(IDbTransaction,FCGeneric[]) Method | fcSDK Documentation

Query(IDbTransaction,FCGeneric[]) Method

Syntax

'Declaration

Public Overloads Sub Query( _
   ByVal _trans_ As IDbTransaction, _
   ByVal ParamArray _generics_() As FCGeneric _
)

public void Query(
   IDbTransaction _trans_,
   params FCGeneric\[\] _generics_
)

Parameters

trans

generics

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataSet Class
GenericDataSet Members
Overload List


Update Method (GenericDataSet) | fcSDK Documentation

Update Method (GenericDataSet)

Overload List

Overload | Description
Update(FCGeneric[]) |
Update(IDbTransaction,FCGeneric[]) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataSet Class
GenericDataSet Members


Update(FCGeneric[]) Method | fcSDK Documentation

Update(FCGeneric[]) Method

Syntax

'Declaration

Public Overloads Sub Update( _
   ByVal ParamArray _generics_() As FCGeneric _
)

public void Update(
   params FCGeneric\[\] _generics_
)

Parameters

generics

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataSet Class
GenericDataSet Members
Overload List


Update(IDbTransaction,FCGeneric[]) Method | fcSDK Documentation

Update(IDbTransaction,FCGeneric[]) Method

Syntax

'Declaration

Public Overloads Sub Update( _
   ByVal _transaction_ As IDbTransaction, _
   ByVal ParamArray _generics_() As FCGeneric _
)

public void Update(
   IDbTransaction _transaction_,
   params FCGeneric[] _generics_
)

Parameters

transaction

generics

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataSet Class
GenericDataSet Members
Overload List


DataSet Property (GenericDataSet) | fcSDK Documentation

DataSet Property (GenericDataSet)

Syntax

'Declaration

Public ReadOnly Property DataSet As DataSet

public DataSet DataSet {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataSet Class
GenericDataSet Members


RestrictionGroup Property (GenericDataSet) | fcSDK Documentation

RestrictionGroup Property (GenericDataSet)

Syntax

'Declaration

Public Property RestrictionGroup As RestrictionGroup

public RestrictionGroup RestrictionGroup {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataSet Class
GenericDataSet Members


SortGenerics Property | fcSDK Documentation

SortGenerics Property

Syntax

'Declaration

Public Property SortGenerics As Boolean

public bool SortGenerics {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataSet Class
GenericDataSet Members


UniqueID Property (GenericDataSet) | fcSDK Documentation

UniqueID Property (GenericDataSet)

Syntax

'Declaration

Public ReadOnly Property UniqueID As Guid

public Guid UniqueID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataSet Class
GenericDataSet Members


GenericDataTable Class | fcSDK Documentation

GenericDataTable Class

Provides a Generic with data storage that integrates with DataSets.

Syntax

'Declaration

<DefaultMemberAttribute("Item")>
Public MustInherit Class GenericDataTable
   Inherits System.Data.DataTable

[DefaultMemberAttribute("Item")]
public abstract class GenericDataTable : System.Data.DataTable

Inheritance Hierarchy

System.Object System.ComponentModel.MarshalByValueComponent System.Data.DataTable [FChoice.Foundation.GenericDataTable** FChoice.Foundation.Clarify.ClarifyDataTable

Requirements

Namespace: FChoice.Foundation

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

GenericDataTable Members FChoice.Foundation Namespace FChoice.Foundation.GenericDataTable FChoice.Foundation.Clarify.ClarifyDataTable

Requirements

Namespace: FChoice.Foundation

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

GenericDataTable Members FChoice.Foundation Namespace


GenericDataTable Class Members | fcSDK Documentation

GenericDataTable Class Members

The following tables list the members exposed by GenericDataTable.

Public Properties

 | Name | Description
Public Property | CaseSensitive | (Inherited from System.Data.DataTable)
Public Property | ChildRelations | (Inherited from System.Data.DataTable)
Public Property | Columns | (Inherited from System.Data.DataTable)
Public Property | Constraints | (Inherited from System.Data.DataTable)
Public Property | Container | (Inherited from System.ComponentModel.MarshalByValueComponent)
Public Property | Count | Number of GenericDataRows currently in the table.
Public Property | DataSet | (Inherited from System.Data.DataTable)
Public Property | DefaultView | (Inherited from System.Data.DataTable)
Public Property | DesignMode | (Inherited from System.ComponentModel.MarshalByValueComponent)
Public Property | DisplayExpression | (Inherited from System.Data.DataTable)
Public Property | ExtendedProperties | (Inherited from System.Data.DataTable)
Public Property | FCGeneric |
Public Property | HasErrors | (Inherited from System.Data.DataTable)
Public Property | IsInitialized | (Inherited from System.Data.DataTable)
Public Property | IsMtmTable | Is this table an Many To Many mapping table?
Public Property | Item | Returns the row found at the given index.
Public Property | Locale | (Inherited from System.Data.DataTable)
Public Property | MinimumCapacity | (Inherited from System.Data.DataTable)
Public Property | Namespace | (Inherited from System.Data.DataTable)
Public Property | ParentRelations | (Inherited from System.Data.DataTable)
Public Property | Prefix | (Inherited from System.Data.DataTable)
Public Property | PrimaryKey | (Inherited from System.Data.DataTable)
Public Property | RemotingFormat | (Inherited from System.Data.DataTable)
Public Property | Rows |
Public Property | Site | (Inherited from System.Data.DataTable)
Public Property | TableName | (Inherited from System.Data.DataTable)

Public Methods

 | Name | Description
Public Method | AcceptChanges | (Inherited from System.Data.DataTable)
Public Method | BeginInit | (Inherited from System.Data.DataTable)
Public Method | BeginLoadData | (Inherited from System.Data.DataTable)
Public Method | Clear | (Inherited from System.Data.DataTable)
Public Method | Clone | (Inherited from System.Data.DataTable)
Public Method | Compute | (Inherited from System.Data.DataTable)
Public Method | Copy | (Inherited from System.Data.DataTable)
Public Method | CreateDataReader | (Inherited from System.Data.DataTable)
Public Method | Dispose | (Inherited from System.ComponentModel.MarshalByValueComponent)
Public Method | EndInit | (Inherited from System.Data.DataTable)
Public Method | EndLoadData | (Inherited from System.Data.DataTable)
Public Method | GetChanges() | (Inherited from System.Data.DataTable)
Public Method | GetEnumerator | Returns an enumerator that can iterate through the GenericDataTable.
Public Method | GetErrors | (Inherited from System.Data.DataTable)
Public Method | GetObjectData | (Inherited from System.Data.DataTable)
Public Method | GetService | (Inherited from System.ComponentModel.MarshalByValueComponent)
Public Method | ImportRow | (Inherited from System.Data.DataTable)
Public Method | Load | Overloaded. (Inherited from System.Data.DataTable)
Public Method | LoadDataRow | Overloaded. (Inherited from System.Data.DataTable)
Public Method | Merge | Overloaded. (Inherited from System.Data.DataTable)
Public Method | NewRow | (Inherited from System.Data.DataTable)
Public Method | ReadXml | Overloaded. (Inherited from System.Data.DataTable)
Public Method | ReadXmlSchema | Overloaded. (Inherited from System.Data.DataTable)
Public Method | RejectChanges | (Inherited from System.Data.DataTable)
Public Method | Reset | (Inherited from System.Data.DataTable)
Public Method | Select | Overloaded. (Inherited from System.Data.DataTable)
Public Method | ToString | (Inherited from System.Data.DataTable)
Public Method | WriteXml | Overloaded. (Inherited from System.Data.DataTable)
Public Method | WriteXmlSchema | Overloaded. (Inherited from System.Data.DataTable)

Public Events

 | Name | Description
Public Event | ColumnChanged | (Inherited from System.Data.DataTable)
Public Event | ColumnChanging | (Inherited from System.Data.DataTable)
Public Event | Disposed | (Inherited from System.ComponentModel.MarshalByValueComponent)
Public Event | Initialized | (Inherited from System.Data.DataTable)
Public Event | RowChanged | (Inherited from System.Data.DataTable)
Public Event | RowChanging | (Inherited from System.Data.DataTable)
Public Event | RowDeleted | (Inherited from System.Data.DataTable)
Public Event | RowDeleting | (Inherited from System.Data.DataTable)
Public Event | TableCleared | (Inherited from System.Data.DataTable)
Public Event | TableClearing | (Inherited from System.Data.DataTable)
Public Event | TableNewRow | (Inherited from System.Data.DataTable)

Reference

GenericDataTable Class
FChoice.Foundation Namespace


GetEnumerator Method (GenericDataTable) | fcSDK Documentation

GetEnumerator Method (GenericDataTable)

Returns an enumerator that can iterate through the GenericDataTable.

Syntax

'Declaration

Public Function GetEnumerator() As IEnumerator

public IEnumerator GetEnumerator()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataTable Class
GenericDataTable Members


Count Property (GenericDataTable) | fcSDK Documentation

Count Property (GenericDataTable)

Number of GenericDataRows currently in the table.

Syntax

'Declaration

Public ReadOnly Property Count As Integer

public int Count {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataTable Class
GenericDataTable Members


FCGeneric Property | fcSDK Documentation

FCGeneric Property

Syntax

'Declaration

Public ReadOnly Property FCGeneric As FCGeneric

public FCGeneric FCGeneric {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataTable Class
GenericDataTable Members


IsMtmTable Property | fcSDK Documentation

IsMtmTable Property

Is this table an Many To Many mapping table?

Syntax

'Declaration

Public ReadOnly Property IsMtmTable As Boolean

public bool IsMtmTable {get;}

[!include[Requirements]emarks

Many to many mapping tables are used internally by Generics to navigate from either side of a Many To Many relation.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataTable Class
GenericDataTable Members


Item Property (GenericDataTable) | fcSDK Documentation

Item Property (GenericDataTable)

The zero-based index of the element to get.

Returns the row found at the given index.

Syntax

'Declaration

Public ReadOnly Default Property Item( _
   ByVal _index_ As Integer _
) As GenericDataRow

public GenericDataRow this[
   int _index_
]; {get;}

Parameters

index

The zero-based index of the element to get.

Property Value

The element at the specified index.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataTable Class
GenericDataTable Members


Rows Property (GenericDataTable) | fcSDK Documentation

Rows Property (GenericDataTable)

Gets the collection of rows that belong to this table.

Syntax

'Declaration

Public Shadows ReadOnly Property Rows As GenericDataRowCollection

public new GenericDataRowCollection Rows {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataTable Class
GenericDataTable Members


GenericException Class | fcSDK Documentation

GenericException Class

The exception that is thrown when an error occurs in the Generic classes in Foundation.

Syntax

'Declaration

<SerializableAttribute()>
Public Class GenericException
   Inherits FoundationException

[SerializableAttribute()]
public class GenericException : FoundationException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
FChoice.Common.FCExceptionBase
FChoice.Foundation.FoundationException
FChoice.Foundation.GenericException
FChoice.Foundation.Clarify.ClarifyGenericException

Requirements

Namespace: FChoice.Foundation

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

GenericException Members
FChoice.Foundation Namespace


GenericException Class Members | fcSDK Documentation

GenericException Class Members

The following tables list the members exposed by GenericException.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorCode | Gets the unique error code for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | ErrorMessageID | Gets the message identifier for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | Sets the SerializationInfo object with the parameter name and additional exception information. (Inherited from FChoice.Common.FCExceptionBase)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)

Reference

GenericException Class
FChoice.Foundation Namespace


MaximumRowsExceededEventArgs Class | fcSDK Documentation

MaximumRowsExceededEventArgs Class

Delegates handling the MaximumRowsExceeded event will return this object to cue FCGeneric on how to handle large queries.

Syntax

'Declaration

Public Class MaximumRowsExceededEventArgs

public class MaximumRowsExceededEventArgs

Inheritance Hierarchy

System.Object
FChoice.Foundation.MaximumRowsExceededEventArgs

Requirements

Namespace: FChoice.Foundation

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

MaximumRowsExceededEventArgs Members
FChoice.Foundation Namespace


MaximumRowsExceededEventArgs Class Members | fcSDK Documentation

MaximumRowsExceededEventArgs Class Members

The following tables list the members exposed by MaximumRowsExceededEventArgs.

Public Constructors

 | Name | Description
Public Constructor | MaximumRowsExceededEventArgs Constructor |

Public Properties

 | Name | Description
Public Property | CancelQuery | When set to true the query will be canceled.
Public Property | RowsToReturn | This value will control the number of rows to be returned from a large query.
Public Property | TotalPossibleRows | Readonly count of rows to be returned by the large query that caused this event.

Reference

MaximumRowsExceededEventArgs Class
FChoice.Foundation Namespace


MaximumRowsExceededEventArgs Constructor | fcSDK Documentation

MaximumRowsExceededEventArgs Constructor

Syntax

'Declaration

Public Function New( _
   ByVal _totalPossibleRows_ As Integer, _
   ByVal _maxRowsToReturn_ As Integer _
)

public MaximumRowsExceededEventArgs(
   int _totalPossibleRows_,
   int _maxRowsToReturn_
)

Parameters

totalPossibleRows

maxRowsToReturn

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MaximumRowsExceededEventArgs Class
MaximumRowsExceededEventArgs Members


CancelQuery Property | fcSDK Documentation

CancelQuery Property

When set to true the query will be canceled.

Syntax

'Declaration

Public Property CancelQuery As Boolean

public bool CancelQuery {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MaximumRowsExceededEventArgs Class
MaximumRowsExceededEventArgs Members


RowsToReturn Property | fcSDK Documentation

RowsToReturn Property

This value will control the number of rows to be returned from a large query.

Syntax

'Declaration

Public Property RowsToReturn As Integer

public int RowsToReturn {get; set;}

Remarks

This value will default to the MaximumRows property of FCGeneric.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MaximumRowsExceededEventArgs Class
MaximumRowsExceededEventArgs Members


TotalPossibleRows Property | fcSDK Documentation

TotalPossibleRows Property

Readonly count of rows to be returned by the large query that caused this event.

Syntax

'Declaration

Public ReadOnly Property TotalPossibleRows As Integer

public int TotalPossibleRows {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MaximumRowsExceededEventArgs Class
MaximumRowsExceededEventArgs Members


RelationNameCollection Class | fcSDK Documentation

RelationNameCollection Class

Collection of Relations

Syntax

'Declaration

Public Class RelationNameCollection
   Inherits ValidatedNameCollection

public class RelationNameCollection : ValidatedNameCollection

Inheritance Hierarchy

System.Object
FChoice.Foundation.ValidatedNameCollection
FChoice.Foundation.RelationNameCollection

Requirements

Namespace: FChoice.Foundation

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

RelationNameCollection Members
FChoice.Foundation Namespace


RelationNameCollection Class Members | fcSDK Documentation

RelationNameCollection Class Members

The following tables list the members exposed by RelationNameCollection.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Property | IsFixedSize | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Property | IsReadOnly | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Property | IsSynchronized | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Property | Item | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Property | SyncRoot | (Inherited from FChoice.Foundation.ValidatedNameCollection)

Public Methods

 | Name | Description
Public Method | Add | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | AddRange | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | Clear | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | Contains | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | CopyTo | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | GetEnumerator | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | IndexOf | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | Insert | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | Remove | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | RemoveAt | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | SetList | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | ToString | (Inherited from FChoice.Foundation.ValidatedNameCollection)

Reference

RelationNameCollection Class
FChoice.Foundation Namespace


ValidatedNameCollection Class | fcSDK Documentation

ValidatedNameCollection Class

Syntax

'Declaration

<DefaultMemberAttribute("Item")>
Public MustInherit Class ValidatedNameCollection

[DefaultMemberAttribute("Item")]
public abstract class ValidatedNameCollection

Inheritance Hierarchy

System.Object
FChoice.Foundation.ValidatedNameCollection
FChoice.Foundation.DataFieldNameCollection
FChoice.Foundation.RelationNameCollection

Requirements

Namespace: FChoice.Foundation

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ValidatedNameCollection Members
FChoice.Foundation Namespace


ValidatedNameCollection Class Members | fcSDK Documentation

ValidatedNameCollection Class Members

The following tables list the members exposed by ValidatedNameCollection.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | IsFixedSize |
Public Property | IsReadOnly |
Public Property | IsSynchronized |
Public Property | Item |
Public Property | SyncRoot |

Public Methods

 | Name | Description
Public Method | Add |
Public Method | AddRange |
Public Method | Clear |
Public Method | Contains |
Public Method | CopyTo |
Public Method | GetEnumerator |
Public Method | IndexOf |
Public Method | Insert |
Public Method | Remove |
Public Method | RemoveAt |
Public Method | SetList |
Public Method | ToString |

Reference

ValidatedNameCollection Class
FChoice.Foundation Namespace


Add Method (ValidatedNameCollection) | fcSDK Documentation

Add Method (ValidatedNameCollection)

Syntax

'Declaration

Public Overridable Function Add( _
   ByVal _name_ As String _
) As Integer

public virtual int Add(
   string _name_
)

Parameters

name

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ValidatedNameCollection Class
ValidatedNameCollection Members


AddRange Method (ValidatedNameCollection) | fcSDK Documentation

AddRange Method (ValidatedNameCollection)

Syntax

'Declaration

Public Overridable Function AddRange( _
   ByVal ParamArray _addNames_() As String _
) As Integer()

public virtual int[] AddRange(
   params string[] _addNames_
)

Parameters

addNames

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ValidatedNameCollection Class
ValidatedNameCollection Members


Clear Method (ValidatedNameCollection) | fcSDK Documentation

Clear Method (ValidatedNameCollection)

Syntax

'Declaration

Public Overridable Sub Clear()

public virtual void Clear()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ValidatedNameCollection Class
ValidatedNameCollection Members


Contains Method (ValidatedNameCollection) | fcSDK Documentation

Contains Method (ValidatedNameCollection)

Syntax

'Declaration

Public Overridable Function Contains( _
   ByVal _name_ As String _
) As Boolean

public virtual bool Contains(
   string _name_
)

Parameters

name

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ValidatedNameCollection Class
ValidatedNameCollection Members


CopyTo Method (ValidatedNameCollection) | fcSDK Documentation

CopyTo Method (ValidatedNameCollection)

Syntax

'Declaration

Public Overridable Sub CopyTo( _
   ByVal _array_() As String, _
   ByVal _index_ As Integer _
)

public virtual void CopyTo(
   string _array_,
   int _index_
)

Parameters

array index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ValidatedNameCollection Class
ValidatedNameCollection Members


GetEnumerator Method (ValidatedNameCollection) | fcSDK Documentation

GetEnumerator Method (ValidatedNameCollection)

Syntax

'Declaration

Public Function GetEnumerator() As IEnumerator

public IEnumerator GetEnumerator()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ValidatedNameCollection Class
ValidatedNameCollection Members


IndexOf Method (ValidatedNameCollection) | fcSDK Documentation

IndexOf Method (ValidatedNameCollection)

Syntax

'Declaration

Public Overridable Function IndexOf( _
   ByVal _name_ As String _
) As Integer

public virtual int IndexOf(
   string _name_
)

Parameters

name

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ValidatedNameCollection Class
ValidatedNameCollection Members


Insert Method (ValidatedNameCollection) | fcSDK Documentation

Insert Method (ValidatedNameCollection)

Syntax

'Declaration

Public Overridable Sub Insert( _
   ByVal _index_ As Integer, _
   ByVal _name_ As String _
)

public virtual void Insert(
   int _index_,
   string _name_
)

Parameters

index name

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ValidatedNameCollection Class
ValidatedNameCollection Members


Remove Method (ValidatedNameCollection) | fcSDK Documentation

Remove Method (ValidatedNameCollection)

Syntax

'Declaration

Public Overridable Sub Remove( _
   ByVal _name_ As String _
)

public virtual void Remove(
   string _name_
)

Parameters

name

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ValidatedNameCollection Class
ValidatedNameCollection Members


RemoveAt Method (ValidatedNameCollection) | fcSDK Documentation

RemoveAt Method (ValidatedNameCollection)

Syntax

'Declaration

Public Overridable Sub RemoveAt( _
   ByVal _index_ As Integer _
)

public virtual void RemoveAt(
   int _index_
)

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ValidatedNameCollection Class
ValidatedNameCollection Members


SetList Method | fcSDK Documentation

SetList Method

Syntax

'Declaration

Public Overridable Sub SetList( _
   ByVal _commaList_ As String _
)

public virtual void SetList(
   string _commaList_
)

Parameters

commaList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ValidatedNameCollection Class
ValidatedNameCollection Members


ToString Method (ValidatedNameCollection) | fcSDK Documentation

ToString Method (ValidatedNameCollection)

Syntax

'Declaration

Public Overrides Function ToString() As String

public override string ToString()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ValidatedNameCollection Class
ValidatedNameCollection Members

Base Implementation in ToString


Count Property (ValidatedNameCollection) | fcSDK Documentation

Count Property (ValidatedNameCollection)

Syntax

'Declaration

Public ReadOnly Property Count As Integer

public int Count {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ValidatedNameCollection Class
ValidatedNameCollection Members


IsFixedSize Property (ValidatedNameCollection) | fcSDK Documentation

IsFixedSize Property (ValidatedNameCollection)

Syntax

'Declaration

Public ReadOnly Property IsFixedSize As Boolean

public bool IsFixedSize {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ValidatedNameCollection Class
ValidatedNameCollection Members


IsReadOnly Property (ValidatedNameCollection) | fcSDK Documentation

IsReadOnly Property (ValidatedNameCollection)

Syntax

'Declaration

Public ReadOnly Property IsReadOnly As Boolean

public bool IsReadOnly {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ValidatedNameCollection Class
ValidatedNameCollection Members


IsSynchronized Property (ValidatedNameCollection) | fcSDK Documentation

IsSynchronized Property (ValidatedNameCollection)

Syntax

'Declaration

Public ReadOnly Property IsSynchronized As Boolean

public bool IsSynchronized {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ValidatedNameCollection Class
ValidatedNameCollection Members


Item Property (ValidatedNameCollection) | fcSDK Documentation

Item Property (ValidatedNameCollection)

Syntax

'Declaration

Public Overridable Default Property Item(ByVal _index_ As Integer) As String

public virtual string this[
    int _index_
    ]; {get; set;}

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ValidatedNameCollection Class
ValidatedNameCollection Members


SyncRoot Property (ValidatedNameCollection) | fcSDK Documentation

SyncRoot Property (ValidatedNameCollection)

Syntax

'Declaration

Public ReadOnly Property SyncRoot As Object

public object SyncRoot {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ValidatedNameCollection Class
ValidatedNameCollection Members


CacheType Enumeration | fcSDK Documentation

CacheType Enumeration

Syntax

'Declaration

<FlagsAttribute()>
Public Enum CacheType
   Inherits System.Enum

[FlagsAttribute()]
public enum CacheType : System.Enum

Members

Member | Description
All |
Data |
Schema |

Inheritance Hierarchy

System.Object System.ValueType System.Enum FChoice.Foundation.CacheType

Requirements

Namespace: FChoice.Foundation

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FChoice.Foundation Namespace FChoice.Foundation.CacheType

Requirements

Namespace: FChoice.Foundation

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FChoice.Foundation Namespace


DateOps Enumeration | fcSDK Documentation

DateOps Enumeration

Valid date filtering operations for methods such as AppendFilter.

Syntax

'Declaration

Public Enum DateOps
   Inherits System.Enum

public enum DateOps : System.Enum

Members

Member | Description
After | Return rows that occur after the given DateTime.
Before | Return rows that occur before the given DateTime.
Equals |
LessThan | Return rows that occur before the given DateTime.
LessThanOrEqual | Return rows that occur on or before the given DateTime.
MoreThan | Return rows that occur after the given DateTime.
MoreThanOrEqual | Return rows that occur on or after the given DateTime.
NotEquals | Return rows that do NOT occur on the given DateTime.
On | Return rows that occur exactly on the given DateTime.
Today | Return rows that occur on this date.
Tomorrow | Return rows that occur tomorrow.
Yesterday | Return rows that occurred yesterday.

Inheritance Hierarchy

System.Object System.ValueType System.Enum FChoice.Foundation.DateOps

Requirements

Namespace: FChoice.Foundation

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FChoice.Foundation Namespace FChoice.Foundation.DateOps

Requirements

Namespace: FChoice.Foundation

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FChoice.Foundation Namespace


NumberOps Enumeration | fcSDK Documentation

NumberOps Enumeration

Valid numeric filtering operations for methods such as AppendFilter.

Syntax

'Declaration

Public Enum NumberOps
   Inherits System.Enum

public enum NumberOps : System.Enum

Members

Member | Description
Equals |
LessThan | Return rows where the selected field is less than the given number.
LessThanOrEqual | Return rows where the selected field is less than or equal to the given number.
MoreThan | Return rows where the selected field is more than the given number.
MoreThanOrEqual | Return rows where the selected field is more than or equal to the given number.
NotEquals | Return rows where the selected field does not equal the given number.
OlderThanDays | The selected field must be a datetime. The filter will return rows that are days or older. Where is the given number.
OlderThanHours | The selected field must be a datetime. The filter will return rows that are hours or older. Where is the given number.
WithinDays | The selected field must be a datetime. The filter will return rows that occurred are within the given number of days before or after.
WithinHours | The selected field must be a datetime. The filter will return rows that occurred are within the given number of hours before or after.

Inheritance Hierarchy

System.Object System.ValueType System.Enum [FChoice.Foundation.NumberOps**

Requirements

Namespace: FChoice.Foundation

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FChoice.Foundation Namespace FChoice.Foundation.NumberOps

Requirements

Namespace: FChoice.Foundation

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FChoice.Foundation Namespace


StringOps Enumeration | fcSDK Documentation

StringOps Enumeration

Valid string filtering operations for methods such as AppendFilter.

Syntax

'Declaration

Public Enum StringOps
   Inherits System.Enum

public enum StringOps : System.Enum

Members

Member | Description
Contains | Return rows where the selected field contains the given string.
EndsWith | Return rows where the selected field ends with the given string.
Equals |
LessThan | Return rows where the selected field is alphabetically before the given string.
LessThanOrEqual | Return rows where the selected field is alphabetically before or equal to the given string.
Like | Return rows where the selected field is Like the the given string. You can use SQL LIKE expressions but be aware that their behavior may depend on the database you are using.
MoreThan | Return rows where the selected field is alphabetically after the given string.
MoreThanOrEqual | Return rows where the selected field is alphabetically after or equal to the given string.
NotContains | Return rows where the selected field does not contain the given string.
NotEndsWith | Return rows where the selected field is does not end with the given string.
NotEquals | Return rows where the selected field is not the given string.
NotLike | Return rows where the selected field is not Like the the given string. You can use SQL LIKE expressions but be aware that their behavior may depend on the database you are using.
NotStartsWith | Return rows where the selected field does not start with the given string.
SoundsLike | Return rows where the selected field sounds like the given string.
StartsWith | Return rows where the selected field starts with the given string.

Inheritance Hierarchy

System.Object System.ValueType System.Enum FChoice.Foundation.StringOps

Requirements

Namespace: FChoice.Foundation

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FChoice.Foundation Namespace


CacheLoadedEventHandler Delegate | fcSDK Documentation

CacheLoadedEventHandler Delegate

Syntax

'Declaration

Public Delegate Sub CacheLoadedEventHandler( _
   ByVal _cacheName_ As String, _
   ByVal _isCustom_ As Boolean _
)

public delegate void CacheLoadedEventHandler(
   string _cacheName_,
   bool _isCustom_
)

Parameters

cacheName

isCustom

Requirements

Namespace: FChoice.Foundation

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

CacheLoadedEventHandler Members
FChoice.Foundation Namespace


CachesUpdatedEventHandler Delegate | fcSDK Documentation

CachesUpdatedEventHandler Delegate

Syntax

'Declaration

Public Delegate Sub CachesUpdatedEventHandler( _
   ByVal _cacheNames_() As String, _
   ByVal _cacheType_ As CacheType _
)

public delegate void CachesUpdatedEventHandler(
   string[] _cacheNames_,
   CacheType _cacheType_
)

Parameters

cacheNames

cacheType

Requirements

Namespace: FChoice.Foundation

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

CachesUpdatedEventHandler Members
FChoice.Foundation Namespace


MaximumRowsExceededEventHandler Delegate | fcSDK Documentation

MaximumRowsExceededEventHandler Delegate

Syntax

'Declaration

Public Delegate Sub MaximumRowsExceededEventHandler( _
   ByVal _sender_ As FCGeneric, _
   ByVal _args_ As MaximumRowsExceededEventArgs _
)

public delegate void MaximumRowsExceededEventHandler(
   FCGeneric _sender_,
   MaximumRowsExceededEventArgs _args_
)

Parameters

sender

args

Requirements

Namespace: FChoice.Foundation

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

MaximumRowsExceededEventHandler Members
FChoice.Foundation Namespace


FChoice.Foundation.Clarify Namespace | fcSDK Documentation

FChoice.Foundation.Clarify Namespace

The FChoice.Foundation.Clarify namespace provides the main classes for data and application access to Clarify systems.

The FChoice.Foundation.Clarify assembly contains classes that provide low-level access to Clarify database systems. FChoice.Foundation.Clarify is part of the First Choice FCFL.NET product.

Classes

 | Class | Description
Class | ClarifyApplication ClarifyApplication is the starting point for using FCFL.NET against a Clarify database system. |
Class | ClarifyAuthenticationResult |
Class | ClarifyAuthenticationService |
Class | ClarifyCacheBase |
Class | ClarifyDataRow |
Class | ClarifyDataSet |
Class | ClarifyDataTable |
Class | ClarifyException |
Class | ClarifyGeneric | Provides core Clarify business logic and managed access to Clarify data.
Class | ClarifyGenericException |
Class | ClarifyRowCollection |
Class | ClarifySession | ClarifySession contains session information for a logged-in user and allows for manipulation of data in the Clarify system as that user.
Class | ClarifySessionData |
Class | ConfigItemCache | Caches global config items and provides access to the global ClarifyConfigItemCollection
Class | ConfigurationHelper |
Class | DatabaseParameterFactory |
Class | ListCache | Caches and provides convenient access methods for GBST and HGBST list structures
Class | LocaleCache | Caches and provides convenient access to country, state, and time zone information
Class | SchemaCache | Caches and provides convenient access to ADP Schema information
Class | SchemaCacheHelper |
Class | StringCache | Caches and provides convenient access to string_db and fc_string values
Class | WorkflowObjectInfo |

Interfaces

 | Interface | Description
Interface | IClarifyApplication |
Interface | IListCache |
Interface | ILocaleCache |
Interface | IStringCache |

Delegates

 | Delegate | Description
Delegate | InitializeStatusChangeEventHandler |
Delegate | SchemaLoadStatusEventHandler |

Enumerations

 | Enumeration | Description
Enumeration | ClarifyLoginType | Provides enumerated values which determine how a given user is logged in when calling ClarifyApplication.CreateSession
Enumeration | InitStatusChangeType |
Enumeration | SchemaLoadStatusType |

Remarks

To get started using FCFL.NET and the FChoice.Foundation.Clarify assembly read the Getting Started guide or the class documentation for ClarifyApplication.

Reference

fcSDK Assembly


ClarifyApplication Class | fcSDK Documentation

ClarifyApplication Class

ClarifyApplication is the starting point for using FCFL.NET against a Clarify database system.

Syntax

'Declaration

Public Class ClarifyApplication
   Inherits FChoice.Foundation.FCApplication
   Implements IClarifyApplication

public class ClarifyApplication : FChoice.Foundation.FCApplication, IClarifyApplication

Remarks

Initialize connects ClarifyApplication to the Clarify database and loads the cache and data object hierarchy.

Once the application is initialized, you can access cache data like the SchemaCache, ConfigItemCache, LocaleCache, ListCache, and StringCache, or you can create session using CreateSession and access the managed data access functionality using ClarifyGeneric.

Inheritance Hierarchy

System.Object FChoice.Foundation.FCApplication FChoice.Foundation.Clarify.ClarifyApplication

Requirements

Namespace: FChoice.Foundation.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ClarifyApplication Members FChoice.Foundation.Clarify Namespace FChoice.Foundation.Clarify.ClarifyApplication

Requirements

Namespace: FChoice.Foundation.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ClarifyApplication Members FChoice.Foundation.Clarify Namespace


ClarifyApplication Class Members | fcSDK Documentation

ClarifyApplication Class Members

The following tables list the members exposed by ClarifyApplication.

Public Properties

 | Name | Description
Public Property | ClarifyVersion | Gets a string which describes the version of Clarify that ClarifyApplication is currently running against.
Public Property | ConfigItemCache | Gets a reference to the ConfigItemCache for accessing Clarify config items.
Public Property | ConfigItems | Returns a dictionary that contains Clarify config item key/value pairs
Public Property | Configuration | Collection of application parameters being used by the application object.
Public Property | ConvertTimeZone | Gets or sets whether or not to perform time zone conversions when operating with date/time values
Public Property | DatabaseVersion | (Inherited from FChoice.Foundation.FCApplication)
Public Property | DataRestrictionsEnabled | Gets whether or not First Choice Data Restriction technology is enabled for this Clarify database.
Public Property | DBUserName | Name of the database user the application object is using to connect to the database.
static (Shared in Visual Basic) | Instance | Returns the singleton instance of ClarifyApplication if initialized.
Public Property | IsDbUnicode | Gets whether or not any columns in the Clarify database are flagged as supporting Unicode characters.
Public Property | IsTravelerEnabled | Gets whether or not the Clarify Traveler product is installed and enabled for this database.
Public Property | ListCache | Gets a reference to the ListCache which provides access to Clarify user defined and global lists
Public Property | LocaleCache | Gets a reference to the LocaleCache which provides access to city/state/country/time zone information.
Public Property | SchemaCache | Gets a reference to the SchemaCache which provides access to the Clarify ADP schema information
Public Property | ServerTimeZone | Timezone being used by the application.
Public Property | StringCache | Gets a reference to the StringCache which provides access to the Clarify string DB table and First Choice FCStrings
Public Property | TruncateStringFields | Gets or sets whether or not to truncate string values if they are too large for the field or throw an error

Public Methods

 | Name | Description
static (Shared in Visual Basic) | BeginInitialize | Begins an asynchronous ClarifyApplication initialization.
Public Method | CreateSession | Overloaded. Creates a new ClarifySession and logs in using the username and password for the application.
Public Method | CurrentSessions | Provides a view into the FCApplication's currently running sessions. (Inherited from FChoice.Foundation.FCApplication)
Public Method | EncryptClarifyPassword | Generates a string using the same obfuscation algorithm that is compatible with the Clarify Thin Client.
Public Method | EncryptDBPassword | Obfuscates a database password using the Clarify DB password obfuscation algorithm.
static (Shared in Visual Basic) | EndInitialize | Ends an asynchronous ClarifyApplication initialization.
Public Method | GetMtmTableName | Returns the name of the physical MTM table for a given MTM relationship using the Clarify MTM naming conventions
Public Method | GetObjID | Gets the next objid for the given table
static (Shared in Visual Basic) | GetObjIdsFromFCStoredProcedure |
Public Method | GetSession | Retrieves an ClarifySession previously created by CreateSession.
static (Shared in Visual Basic) | Initialize | Overloaded. Initializes ClarifyApplication using the application configuration.
Public Method | IsSessionValid |
static (Shared in Visual Basic) | ValidateEncryptedPassword |

Public Events

 | Name | Description
Public Event | InitializeStatusChange | Event fired during Initialization, relaying information about the current status of the initialization process.

Reference

ClarifyApplication Class
FChoice.Foundation.Clarify Namespace


BeginInitialize Method | fcSDK Documentation

BeginInitialize Method

The method to be called when the asynchronous initialization is completed.

A user-provided object that distinguishes this particular asynchronous request from other requests.

Begins an asynchronous ClarifyApplication initialization.

Syntax

'Declaration

Public Shared Function BeginInitialize( _
   ByVal _callback_ As AsyncCallback, _
   ByVal _state_ As Object _
) As IAsyncResult

public static IAsyncResult BeginInitialize(
   AsyncCallback _callback_,
   object _state_
)

Parameters

callback

The method to be called when the asynchronous initialization is completed.

state

A user-provided object that distinguishes this particular asynchronous request from other requests.

Return Value

An IAsyncResult that references the asynchronous initialization.

Remarks

The BeginInitialize method starts an asynchronous initialization of the ClarifyApplication.

Your callback method should call EndInitialize to complete the operation. Please see the Asynchronous Design Pattern Overview for more details on using asynchronous methods.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyApplication Class
ClarifyApplication Members
Asynchronous Design Pattern Overview


CreateSession Method (ClarifyApplication) | fcSDK Documentation

CreateSession Method (ClarifyApplication)

Creates a new ClarifySession and logs in using the username and password for the application.

Creates a new ClarifySession object through which most access to the Clarify System occurs.

Overload List

Overload | Description
CreateSession() | Creates a new ClarifySession and logs in using the username and password for the application.
CreateSession(String,ClarifyLoginType) | Creates a new ClarifySession and performs a passwordless login for the specified user and ClarifyLoginType.
CreateSession(String,String,ClarifyLoginType) | Creates a new ClarifySession and performs a login using the specified username, password, and ClarifyLoginType.

Remarks

There is no way to create a ClarifySession that is not already logged in.

Specific inheritable properties, such as TruncateStringFields, are copied to the new sessions created via this method.

IMPORTANT: By default, using the overload without any parameters, or the overload that takes only a username will throw an exception. This is to help prevent potential security problems that might arise from passwordless or full-access session logins. If you wish to override the security check enable this functionality despite the security implications, please contact First Choice support at support@fchoice.com and request information on how to enable it.

.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyApplication Class
ClarifyApplication Members


CreateSession() Method | fcSDK Documentation

CreateSession() Method

Creates a new ClarifySession and logs in using the username and password for the application.

Syntax

'Declaration

Public Overloads Function CreateSession() As ClarifySession

public ClarifySessionCreateSession()

Return Value

A new ClarifySession instance that is logged in using the application username and password.

Remarks

This method will log in the session using the username and password specified in the application connection string configuration variable.

WARNING: This method has potential security implications. If enabled, this method would allow users to log in as a high-privileged user without knowledge of the username or password (assuming your application user is high-privileged). Once these privileges are obtained, the user could perform damaging (either accidental or malicious) actions which might disable your Clarify installation.

IMPORTANT: First Choice has disabled this functionality by default. If you decide that you are willing to assume the risk of enabling this functionality, you must add an appSettings entry into your application configuration file with the key "fchoice.disableLoginFromFCApp" with the value of "false".

The general use case for this method is if you are writing a simple application that performs some type of repetitive, batch, or behind-the-scenes process and requires no user input. Rather than hard-coding a username and password into your application, you can simply use the application user.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyApplication Class
ClarifyApplication Members
Overload List


CreateSession(String,ClarifyLoginType) Method | fcSDK Documentation

CreateSession(String,ClarifyLoginType) Method

The user or login name of the user

The type of login to perform using the specified userName.

Creates a new ClarifySession and performs a passwordless login for the specified user and ClarifyLoginType.

Syntax

'Declaration

Public Overloads Overridable Function CreateSession( _
   ByVal _userName_ As String, _
   ByVal _loginType_ As ClarifyLoginType _
) As ClarifySession

public virtual ClarifySession CreateSession(
   string _userName_,
   ClarifyLoginType _loginType_
)

Parameters

userName

The user or login name of the user

loginType

The type of login to perform using the specified userName.

Return Value

A ClarifySession logged in using the specified userName.

Remarks

This method will log in the session using the given username and no password.

WARNING: This method has potential security implications. If enabled, this functionality could allow users to log in as any user without knowledge of the password and perform any action on behalf of that user. This creates an audit trail problem because you cannot accurately trace which user performed which action.

IMPORTANT: First Choice has disabled this functionality by default. If you decide that you are willing to assume the risk of enabling this functionality, you must add an appSettings entry into your application configuration file with the key "fchoice.sessionPasswordRequired" with the value of "false".

The general use case for this method is if you're using your Clarify system to support another application that already provides authentication and authorization services. It is assumed that you have properly validated that the current user is authorized to log in and does not need to go through the Clarify authentication process and incur a performance delay.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyApplication Class
ClarifyApplication Members
Overload List


CreateSession(String,String,ClarifyLoginType) Method | fcSDK Documentation

CreateSession(String,String,ClarifyLoginType) Method

The user or login name of the user

The password for the user

The type of login to perform using the specified userName

Creates a new ClarifySession and performs a login using the specified username, password, and ClarifyLoginType.

Syntax

'Declaration

Public Overloads Overridable Function CreateSession( _
   ByVal _userName_ As String, _
   ByVal _password_ As String, _
   ByVal _loginType_ As ClarifyLoginType _
) As ClarifySession

public virtual ClarifySession CreateSession(
   string _userName_,
   string _password_,
   ClarifyLoginType _loginType_
)

Parameters

userName

The user or login name of the user

password

The password for the user

loginType

The type of login to perform using the specified userName

Return Value

A ClarifySession logged in using the specified userName and password

Remarks

This method will log in the session using the given username, password, and login type before returning.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyApplication Class
ClarifyApplication Members
Overload List


EncryptClarifyPassword Method (ClarifyApplication) | fcSDK Documentation

EncryptClarifyPassword Method (ClarifyApplication)

The plain-text password to obfuscate

Generates a string using the same obfuscation algorithm that is compatible with the Clarify Thin Client.

Syntax

'Declaration

Public Function EncryptClarifyPassword( _
   ByVal _password_ As String _
) As String

public string EncryptClarifyPassword(
   string _password_
)

Parameters

password

The plain-text password to obfuscate

Return Value

A password obfuscated using the Clarify obfuscation algorithm

Remarks

This string can be used for password comparison and authentication of users and web users in the Clarify system.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyApplication Class
ClarifyApplication Members


EncryptDBPassword Method (ClarifyApplication) | fcSDK Documentation

EncryptDBPassword Method (ClarifyApplication)

The password to obfuscate

Obfuscates a database password using the Clarify DB password obfuscation algorithm.

Syntax

'Declaration

Public Function EncryptDBPassword( _
   ByVal _password_ As String _
) As String

public string EncryptDBPassword(
   string _password_
)

Parameters

password

The password to obfuscate

Return Value

A password obfuscated using the Clarify DB password obfuscation algorithm

Remarks

This password can be used in a connection string to log a user directly into the database.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyApplication Class
ClarifyApplication Members


EndInitialize Method | fcSDK Documentation

EndInitialize Method

An IAsyncResult that stores state information and any user defined data for this asynchronous operation.

Ends an asynchronous ClarifyApplication initialization.

Syntax

'Declaration

Public Shared Function EndInitialize( _
   ByVal _result_ As IAsyncResult _
) As ClarifyApplication

public static ClarifyApplication EndInitialize(
   IAsyncResult _result_
)

Parameters

result

An IAsyncResult that stores state information and any user defined data for this asynchronous operation.

Remarks

EndInitialize completes the asynchronous initialization operation started in BeginInitialize.

Please see the Asynchronous Design Pattern Overview for more details on using asynchronous methods.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyApplication Class
ClarifyApplication Members
Asynchronous Design Pattern Overview


GetMtmTableName Method (ClarifyApplication) | fcSDK Documentation

GetMtmTableName Method (ClarifyApplication)

The MTM relation from which the MTM table name is to be generated

Returns the name of the physical MTM table for a given MTM relationship using the Clarify MTM naming conventions

Syntax

'Declaration

Public Function GetMtmTableName( _
   ByVal _relation_ As SchemaRelation _
) As String

public string GetMtmTableName(
   SchemaRelation _relation_
)

Parameters

relation

The MTM relation from which the MTM table name is to be generated

Return Value

The name of the physical MTM table for a given MTM relationship using the Clarify MTM naming conventions

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyApplication Class
ClarifyApplication Members


GetObjID Method (ClarifyApplication) | fcSDK Documentation

GetObjID Method (ClarifyApplication)

The name of the table whose next objid to retreive.

Gets the next objid for the given table

Syntax

'Declaration

Public Function GetObjID( _
   ByVal _tableName_ As String _
) As Integer

public int GetObjID(
   string _tableName_
)

Parameters

tableName

The name of the table whose next objid to retreive.

Return Value

The next objid for this table.

Exceptions

Exception | Description
ClarifyException | The table with the specified name could not be found or it is a view.

Remarks

If caching of objids is enabled, the next objid will be retrieved from the local cache. If caching is disabled, a database query will be executed to retrieve the next id.

To configure caching, set the OBJID_CACHE_SIZE config item to the quantity of objid values to be reserved at a time, and then restart the application.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyApplication Class
ClarifyApplication Members


GetObjIdsFromFCStoredProcedure Method | fcSDK Documentation

GetObjIdsFromFCStoredProcedure Method

Syntax

'Declaration

Public Shared Function GetObjIdsFromFCStoredProcedure( _
   ByVal _numberOfIdRequested_ As Integer, _
   ByVal _clarifyBaseObjId_ As Integer, _
   ByVal _objectTypeId_ As Integer _
) As Integer()

public static int[] GetObjIdsFromFCStoredProcedure(
   int _numberOfIdRequested_,
   int _clarifyBaseObjId_,
   int _objectTypeId_
)

Parameters

numberOfIdRequested

clarifyBaseObjId

objectTypeId

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyApplication Class
ClarifyApplication Members


GetSession Method (ClarifyApplication) | fcSDK Documentation

GetSession Method (ClarifyApplication)

The globally unique identifier for the desired session.

Retrieves an ClarifySession previously created by CreateSession.

Syntax

'Declaration

Public Overridable Function GetSession( _
   ByVal _sessionID_ As Guid _
) As ClarifySession

public virtual ClarifySession GetSession(
   Guid _sessionID_
)

Parameters

sessionID

The globally unique identifier for the desired session.

Return Value

The ClarifySession with the specified sessionID.

Exceptions

Exception | Description
ClarifyException | A session with the specified ID does not exist or has been closed.

Remarks

The ID of a session is accessible via the SessionID property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyApplication Class
ClarifyApplication Members


Initialize Method (ClarifyApplication) | fcSDK Documentation

Initialize Method (ClarifyApplication)

Initializes ClarifyApplication using the application configuration.

Initializes ClarifyApplication using the application configuration or the specified NameValueCollection

Overload List

Overload | Description
Initialize() | Initializes ClarifyApplication using the application configuration.
Initialize(NameValueCollection) | Initializes ClarifyApplication using values in the specified NameValueCollection

Remarks

Initialize can only be called once per application domain. Once initialized, ClarifyApplication cannot be uninitialized or reinitialized in that application domain.

Initialize requires one configuration parameter: The database connection string. The key for this value in the NameValueCollection or in the appSettings section of the application configuration file must be the value specified in the ConfigValues.CONNECT_STRING field.

For more information on configuring .NET applications via configuration file, see Configuration Applications in the .NET Framework SDK documentation.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyApplication Class
ClarifyApplication Members


Initialize() Method | fcSDK Documentation

Initialize() Method

Initializes ClarifyApplication using the application configuration.

Syntax

'Declaration

Public Overloads Shared Function Initialize() As ClarifyApplication

public static ClarifyApplication Initialize()

Return Value

The newly created and initialized singleton instance of ClarifyApplication

Remarks

Initialize can only be called once per application domain. Once initialized, ClarifyApplication cannot be uninitialized or reinitialized in that application domain.

Initialize requires one configuration parameter: The database connection string. The key for this value in the appSettings section of the application configuration file must be the value specified in the ConfigValues.CONNECT_STRING field.

For more information on configuring .NET applications via configuration file, see Configuration Applications in the .NET Framework SDK documentation.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyApplication Class
ClarifyApplication Members
Overload List


Initialize(NameValueCollection) Method | fcSDK Documentation

Initialize(NameValueCollection) Method

The configuration values to use for ClarifyApplication

Initializes ClarifyApplication using values in the specified NameValueCollection

Syntax

'Declaration

Public Overloads Shared Function Initialize( _
   ByVal _configValues_ As NameValueCollection _
) As ClarifyApplication

public static ClarifyApplication Initialize(
   NameValueCollection _configValues_
)

Parameters

configValues

The configuration values to use for ClarifyApplication

Return Value

The newly created and initialized singleton instance of ClarifyApplication

Remarks

Initialize can only be called once per application domain. Once initialized, ClarifyApplication cannot be uninitialized or reinitialized in that application domain.

Initialize requires one configuration parameter: The database connection string. The key for this value in the configValues collection must be the value specified in the ConfigValues.CONNECT_STRING field.

For more information on configuring .NET applications via configuration file, see Configuration Applications in the .NET Framework SDK documentation.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyApplication Class
ClarifyApplication Members
Overload List


IsSessionValid Method (ClarifyApplication) | fcSDK Documentation

IsSessionValid Method (ClarifyApplication)

Syntax

'Declaration

Public Function IsSessionValid( _
   ByVal _sessionID_ As Guid _
) As Boolean

public bool IsSessionValid(
   Guid _sessionID_
)

Parameters

sessionID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyApplication Class
ClarifyApplication Members


ValidateEncryptedPassword Method (ClarifyApplication) | fcSDK Documentation

ValidateEncryptedPassword Method (ClarifyApplication)

Password to validate against the hashed password.

Hashed password to validate against.

True if the Clarify instance is less than version 9.

Syntax

'Declaration

Public Shared Function ValidateEncryptedPassword( _
   ByVal _password_ As String, _
   ByVal _passHash_ As String, _
   ByVal _pre9_ As Boolean _
) As Boolean

public static bool ValidateEncryptedPassword(
   string _password_,
   string _passHash_,
   bool _pre9_
)

Parameters

password

Password to validate against the hashed password.

passHash

Hashed password to validate against.

pre9

True if the Clarify instance is less than version 9.

Return Value

True if the password validates.

Remarks

This method reproduces Clarify style authentication. Normally you would pull the hashed password out of a database and compare it against the password entered by the user.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyApplication Class
ClarifyApplication Members


ClarifyVersion Property (ClarifyApplication) | fcSDK Documentation

ClarifyVersion Property (ClarifyApplication)

Gets a string which describes the version of Clarify that ClarifyApplication is currently running against.

Syntax

'Declaration

Public ReadOnly Property ClarifyVersion As String

public string ClarifyVersion {get;}

Property Value

A string which describes the Clarify version installed in the database to which ClarifyApplication is connected.

Remarks

If the database is Clarify 9, "9" is returned, Clarify CFO98 returns "CFO98", and Clarify 12.5 returns "12.5". If the version of Clarify is not known or is of a newer version than was available when FCFL.NET was released, "Unknown" will be returned.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyApplication Class
ClarifyApplication Members


ConfigItemCache Property (ClarifyApplication) | fcSDK Documentation

ConfigItemCache Property (ClarifyApplication)

Gets a reference to the ConfigItemCache for accessing Clarify config items.

Syntax

'Declaration

Public ReadOnly Property ConfigItemCache As ConfigItemCache

public ConfigItemCache ConfigItemCache {get;}

Property Value

A reference to the ConfigItemCache

Remarks

To quickly access config item values, use the ConfigItems property on ClarifyApplication.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyApplication Class
ClarifyApplication Members
ConfigItemCache Class


ConfigItems Property (ClarifyApplication) | fcSDK Documentation

ConfigItems Property (ClarifyApplication)

Returns a dictionary that contains Clarify config item key/value pairs

Syntax

'Declaration

Public ReadOnly Property ConfigItems As ClarifyConfigItemCollection

public ClarifyConfigItemCollection ConfigItems {get;}

Property Value

A dictionary that contains Clarify config item key/value pairs.

Remarks

To access more information about config items besides just their values, use the ConfigItemCache property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyApplication Class
ClarifyApplication Members


Configuration Property (ClarifyApplication) | fcSDK Documentation

Configuration Property (ClarifyApplication)

Collection of application parameters being used by the application object.

Syntax

'Declaration

Public ReadOnly Property Configuration As NameValueCollection

public NameValueCollection Configuration {get;}

Property Value

Collection of application parameters being used by the application object.

Remarks

The values in this collection are populated by the application configuration file.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyApplication Class
ClarifyApplication Members
Basic Configuration
FCConfiguration


ConvertTimeZone Property (ClarifyApplication) | fcSDK Documentation

ConvertTimeZone Property (ClarifyApplication)

Gets or sets whether or not to perform time zone conversions when operating with date/time values

Syntax

'Declaration

Public Property ConvertTimeZone As Boolean

public bool ConvertTimeZone {get; set;}

Property Value

Whether or not to perform time zone conversions when operating with date/time values

Remarks

This value is true by default.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyApplication Class
ClarifyApplication Members


DataRestrictionsEnabled Property (ClarifyApplication) | fcSDK Documentation

DataRestrictionsEnabled Property (ClarifyApplication)

Gets whether or not First Choice Data Restriction technology is enabled for this Clarify database.

Syntax

'Declaration

Public ReadOnly Property DataRestrictionsEnabled As Boolean

public bool DataRestrictionsEnabled {get;}

Property Value

Whether or not First Choice Data Restriction technology is enabled for this Clarify database.

Remarks

When ClarifyApplication is initializing, it determines whether the data restriction tables and configuration is loaded and will set this value to true, otherwise it is always false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyApplication Class
ClarifyApplication Members


DBUserName Property (ClarifyApplication) | fcSDK Documentation

DBUserName Property (ClarifyApplication)

Name of the database user the application object is using to connect to the database.

Syntax

'Declaration

Public ReadOnly Property DBUserName As String

public string DBUserName {get;}

Property Value

Application database username

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyApplication Class
ClarifyApplication Members


Instance Property (ClarifyApplication) | fcSDK Documentation

Instance Property (ClarifyApplication)

Returns the singleton instance of ClarifyApplication if initialized.

Syntax

'Declaration

Public Shared ReadOnly Property Instance As ClarifyApplication

public static ClarifyApplication Instance {get;}

Property Value

The singleton instance of ClarifyApplication if initialized.

Exceptions

Exception | Description
FoundationException | The application is not yet initialized. Call ClarifyApplication.Initialize first.

Remarks

If not already initialized, an exception will be thrown. First call Initialize.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyApplication Class
ClarifyApplication Members


IsDbUnicode Property (ClarifyApplication) | fcSDK Documentation

IsDbUnicode Property (ClarifyApplication)

Gets whether or not any columns in the Clarify database are flagged as supporting Unicode characters.

Syntax

'Declaration

<ObsoleteAttribute("Use the SchemaCache IsDatabaseUnicode property")>
Public ReadOnly Property IsDbUnicode As Boolean

[ObsoleteAttribute("Use the SchemaCache IsDatabaseUnicode property")]
public bool IsDbUnicode {get;}

Property Value

Whether or not any columns in the Clarify database are flagged as supporting Unicode characters.

Remarks

For more information on what constitutes a column that supports Unicode or how to configure your database to support unicode input, consult the FCFL.NET Installation and User guides.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyApplication Class
ClarifyApplication Members


IsTravelerEnabled Property (ClarifyApplication) | fcSDK Documentation

IsTravelerEnabled Property (ClarifyApplication)

Gets whether or not the Clarify Traveler product is installed and enabled for this database.

Syntax

'Declaration

Public ReadOnly Property IsTravelerEnabled As Boolean

public bool IsTravelerEnabled {get;}

Property Value

Whether or not the Clarify Traveler product is installed and enabled for this database.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyApplication Class
ClarifyApplication Members


ListCache Property (ClarifyApplication) | fcSDK Documentation

ListCache Property (ClarifyApplication)

Gets a reference to the ListCache which provides access to Clarify user defined and global lists

Syntax

'Declaration

Public ReadOnly Property ListCache As IListCache

public IListCache ListCache {get;}

Property Value

A reference to the ListCache

Remarks

See the documentation for ListCache for more information on how to access and work with Clarify lists in FCFL.NET.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyApplication Class
ClarifyApplication Members
ListCache Class


LocaleCache Property (ClarifyApplication) | fcSDK Documentation

LocaleCache Property (ClarifyApplication)

Gets a reference to the LocaleCache which provides access to city/state/country/time zone information.

Syntax

'Declaration

Public ReadOnly Property LocaleCache As ILocaleCache

public ILocaleCache LocaleCache {get;}

Property Value

A reference to the LocaleCache

Remarks

See the documentation for LocaleCache for more information on how to access and work with locale information in FCFL.NET.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyApplication Class
ClarifyApplication Members


SchemaCache Property (ClarifyApplication) | fcSDK Documentation

SchemaCache Property (ClarifyApplication)

Gets a reference to the SchemaCache which provides access to the Clarify ADP schema information

Syntax

'Declaration

Public ReadOnly Property SchemaCache As SchemaCache

public SchemaCache SchemaCache {get;}

Property Value

A reference to the SchemaCache

Remarks

See the documentation for SchemaCache for more information on how to access and work with Clarify ADP schema information in FCFL.NET.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyApplication Class
ClarifyApplication Members


ServerTimeZone Property (ClarifyApplication) | fcSDK Documentation

ServerTimeZone Property (ClarifyApplication)

Timezone being used by the application.

Syntax

'Declaration

Public Property ServerTimeZone As ITimeZone

public ITimeZone ServerTimeZone {get; set;}

Property Value

Timezone being used by the application.

Remarks

This timezone is used when converting from session to server time

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyApplication Class
ClarifyApplication Members


StringCache Property (ClarifyApplication) | fcSDK Documentation

StringCache Property (ClarifyApplication)

Gets a reference to the StringCache which provides access to the Clarify string DB table and First Choice FCStrings

Syntax

'Declaration

Public ReadOnly Property StringCache As IStringCache

public IStringCache StringCache {get;}

Property Value

A reference to the StringCache

Remarks

See the documentation for StringCache for more information on how to access and work with Clarify strings and First Choice FCStrings in FCFL.NET.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyApplication Class
ClarifyApplication Members


TruncateStringFields Property (ClarifyApplication) | fcSDK Documentation

TruncateStringFields Property (ClarifyApplication)

Gets or sets whether or not to truncate string values if they are too large for the field or throw an error

Syntax

'Declaration

Public Property TruncateStringFields As Boolean

public bool TruncateStringFields {get; set;}

Property Value

Whether or not to truncate string values if they are too large for the field or throw an error

Remarks

When setting a string value to a string field using ClarifyDataRow, this property will determine what to do if the value specified is longer than the allowable length for the field.

This is an inheritable property. New sessions created will inherit the value of this property.

Changes made to this property will not be reflected in already existing sessions.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyApplication Class
ClarifyApplication Members


InitializeStatusChange Event | fcSDK Documentation

InitializeStatusChange Event

Event fired during Initialization, relaying information about the current status of the initialization process.

Syntax

'Declaration

Public Event InitializeStatusChange As InitializeStatusChangeEventHandler

public event InitializeStatusChangeEventHandler InitializeStatusChange

Remarks

Add an event handler to this event to receive feedback on where in the initialization process ClarifyApplication currently is. The InitStatusChangeType enumeration contains the initialization states.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyApplication Class
ClarifyApplication Members
InitStatusChangeType Enumeration


ClarifyAuthenticationResult Class | fcSDK Documentation

ClarifyAuthenticationResult Class

Syntax

'Declaration

Public Class ClarifyAuthenticationResult

public class ClarifyAuthenticationResult

Inheritance Hierarchy

System.Object
FChoice.Foundation.Clarify.ClarifyAuthenticationResult

Requirements

Namespace: FChoice.Foundation.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ClarifyAuthenticationResult Members
FChoice.Foundation.Clarify Namespace


ClarifyAuthenticationResult Class Members | fcSDK Documentation

ClarifyAuthenticationResult Class Members

The following tables list the members exposed by ClarifyAuthenticationResult.

Public Constructors

 | Name | Description
Public Constructor | ClarifyAuthenticationResult Constructor |

Public Properties

 | Name | Description
Public Property | PasswordUsed |
Public Property | Success |

Reference

ClarifyAuthenticationResult Class
FChoice.Foundation.Clarify Namespace


ClarifyAuthenticationResult Constructor | fcSDK Documentation

ClarifyAuthenticationResult Constructor

Syntax

'Declaration

Public Function New()

public ClarifyAuthenticationResult()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyAuthenticationResult Class
ClarifyAuthenticationResult Members


PasswordUsed Property | fcSDK Documentation

PasswordUsed Property

Syntax

'Declaration

Public Property PasswordUsed As String

public string PasswordUsed {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyAuthenticationResult Class
ClarifyAuthenticationResult Members


Success Property | fcSDK Documentation

Success Property

Syntax

'Declaration

Public Property Success As Boolean

public bool Success {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyAuthenticationResult Class
ClarifyAuthenticationResult Members


ClarifyAuthenticationService Class | fcSDK Documentation

ClarifyAuthenticationService Class

Syntax

'Declaration

Public Class ClarifyAuthenticationService

public class ClarifyAuthenticationService

Inheritance Hierarchy

System.Object
FChoice.Foundation.Clarify.ClarifyAuthenticationService

Requirements

Namespace: FChoice.Foundation.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ClarifyAuthenticationService Members
FChoice.Foundation.Clarify Namespace


ClarifyAuthenticationService Class Members | fcSDK Documentation

ClarifyAuthenticationService Class Members

The following tables list the members exposed by ClarifyAuthenticationService.

Public Constructors

 | Name | Description
Public Constructor | ClarifyAuthenticationService Constructor |

Public Methods

 | Name | Description
Public Method | AuthenticateUser |
static (Shared in Visual Basic) | ReconstructConnectString |

Reference

ClarifyAuthenticationService Class
FChoice.Foundation.Clarify Namespace


ClarifyAuthenticationService Constructor | fcSDK Documentation

ClarifyAuthenticationService Constructor

Syntax

'Declaration

Public Function New()

public ClarifyAuthenticationService()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyAuthenticationService Class
ClarifyAuthenticationService Members


AuthenticateUser Method | fcSDK Documentation

AuthenticateUser Method

Syntax

'Declaration

Public Function AuthenticateUser( _
   ByVal _username_ As String, _
   ByVal _password_ As String _
) As ClarifyAuthenticationResult

public ClarifyAuthenticationResult AuthenticateUser(
   string _username_,
   string _password_
)

Parameters

username

password

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyAuthenticationService Class
ClarifyAuthenticationService Members


ReconstructConnectString Method | fcSDK Documentation

ReconstructConnectString Method

Syntax

'Declaration

Public Shared Function ReconstructConnectString( _
   ByVal _inUsername_ As String, _
   ByVal _encPassword_ As String _
) As String

public static string ReconstructConnectString(
   string _inUsername_,
   string _encPassword_
)

Parameters

inUsername

encPassword

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyAuthenticationService Class
ClarifyAuthenticationService Members


ClarifyCacheBase Class | fcSDK Documentation

ClarifyCacheBase Class

Syntax

'Declaration

Public MustInherit Class ClarifyCacheBase
   Inherits FChoice.Foundation.CacheBase

public abstract class ClarifyCacheBase : FChoice.Foundation.CacheBase

Inheritance Hierarchy

System.Object
FChoice.Foundation.CacheBase
FChoice.Foundation.Clarify.ClarifyCacheBase
FChoice.Foundation.Clarify.ConfigItemCache
FChoice.Foundation.Clarify.ListCache
FChoice.Foundation.Clarify.LocaleCache
FChoice.Foundation.Clarify.SchemaCache
FChoice.Foundation.Clarify.StringCache

Requirements

Namespace: FChoice.Foundation.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ClarifyCacheBase Members
FChoice.Foundation.Clarify Namespace


ClarifyCacheBase Class Members | fcSDK Documentation

ClarifyCacheBase Class Members

The following tables list the members exposed by ClarifyCacheBase.

Public Properties

 | Name | Description
Public Property | CacheSetName | (Inherited from FChoice.Foundation.CacheBase)
Public Property | CacheType | (Inherited from FChoice.Foundation.CacheBase)

Public Methods

 | Name | Description
Public Method | UpdateCache | (Inherited from FChoice.Foundation.CacheBase)

Public Events

 | Name | Description
Public Event | CacheUpdated | (Inherited from FChoice.Foundation.CacheBase)

Reference

ClarifyCacheBase Class
FChoice.Foundation.Clarify Namespace


ClarifyDataRow Class | fcSDK Documentation

ClarifyDataRow Class

Syntax

'Declaration

Public Class ClarifyDataRow
   Inherits FChoice.Foundation.GenericDataRow

public class ClarifyDataRow : FChoice.Foundation.GenericDataRow

Inheritance Hierarchy

System.Object
System.Data.DataRow
FChoice.Foundation.GenericDataRow
FChoice.Foundation.Clarify.ClarifyDataRow

Requirements

Namespace: FChoice.Foundation.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ClarifyDataRow Members
FChoice.Foundation.Clarify Namespace


ClarifyDataRow Class Members | fcSDK Documentation

ClarifyDataRow Class Members

The following tables list the members exposed by ClarifyDataRow.

Public Properties

 | Name | Description
Public Property | ForcedUpdateColumns | (Inherited from FChoice.Foundation.GenericDataRow)
Public Property | HasErrors | (Inherited from System.Data.DataRow)
Public Property | IsAddForUpdate | Gets a value indicating whether this GenericDataRow was added via AddForUpdate. (Inherited from FChoice.Foundation.GenericDataRow)
Public Property | IsNew | Gets a value indicating whether the current GenericDataRow was added and not yet committed. (Inherited from FChoice.Foundation.GenericDataRow)
Public Property | Item | Overloaded. (Inherited from FChoice.Foundation.GenericDataRow)
Public Property | ItemArray | (Inherited from System.Data.DataRow)
Public Property | ParentGeneric |
Public Property | RowError | (Inherited from System.Data.DataRow)
Public Property | RowGuid | Unique row identifier (Inherited from FChoice.Foundation.GenericDataRow)
Public Property | RowState | (Inherited from System.Data.DataRow)
Public Property | Table |
Public Property | UniqueID | Returns Unique Identifier of this row in the database. (Inherited from FChoice.Foundation.GenericDataRow)

Public Methods

 | Name | Description
Public Method | AcceptChanges | (Inherited from System.Data.DataRow)
Public Method | BeginEdit | (Inherited from System.Data.DataRow)
Public Method | CancelEdit | (Inherited from System.Data.DataRow)
Public Method | ClearErrors | (Inherited from System.Data.DataRow)
Public Method | Delete | (Inherited from System.Data.DataRow)
Public Method | EndEdit | (Inherited from System.Data.DataRow)
Public Method | GetChildRows | Overloaded. (Inherited from System.Data.DataRow)
Public Method | GetColumnError | Overloaded. (Inherited from System.Data.DataRow)
Public Method | GetColumnsInError | (Inherited from System.Data.DataRow)
Public Method | GetParentRow | Overloaded. (Inherited from System.Data.DataRow)
Public Method | GetParentRows | Overloaded. (Inherited from System.Data.DataRow)
Public Method | HasVersion | (Inherited from System.Data.DataRow)
Public Method | IsForcedUpdateColumn | (Inherited from FChoice.Foundation.GenericDataRow)
Public Method | IsNull | Overloaded. (Inherited from System.Data.DataRow)
Public Method | RejectChanges | (Inherited from System.Data.DataRow)
Public Method | RelateByID | Relate a unique identifier to this GenericDataRow via a SchemaRelation name. (Inherited from FChoice.Foundation.GenericDataRow)
Public Method | RelatedRows |
Public Method | RelateRecord | Relate a given row to this GenericDataRow via a SchemaRelation name. (Inherited from FChoice.Foundation.GenericDataRow)
Public Method | RelateToIntField | Relate a given row's identifier to an Integer field present on this GenericDataRow. (Inherited from FChoice.Foundation.GenericDataRow)
Public Method | SetAdded | (Inherited from System.Data.DataRow)
Public Method | SetColumnError | Overloaded. (Inherited from System.Data.DataRow)
Public Method | SetModified | (Inherited from System.Data.DataRow)
Public Method | SetParentRow | Overloaded. (Inherited from System.Data.DataRow)
Public Method | Unrelate | UnRelate this GenericDataRow from a single row related to it via the given relation name. (Inherited from FChoice.Foundation.GenericDataRow)
Public Method | UnrelateFromAll | UnRelate this GenericDataRow from all other rows related to it via the given relation name. (Inherited from FChoice.Foundation.GenericDataRow)
Public Method | Update | Overloaded. Commits the row to the database. See FCGeneric's Update for details. (Inherited from FChoice.Foundation.GenericDataRow)

Reference

ClarifyDataRow Class
FChoice.Foundation.Clarify Namespace


RelatedRows Method | fcSDK Documentation

RelatedRows Method

Syntax

'Declaration

Public Function RelatedRows( _
   ByVal _otherGen_ As ClarifyGeneric _
) As ClarifyDataRow()

public ClarifyDataRow[] RelatedRows(
   ClarifyGeneric _otherGen_
)

Parameters

otherGen

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyDataRow Class
ClarifyDataRow Members


ParentGeneric Property (ClarifyDataRow) | fcSDK Documentation

ParentGeneric Property (ClarifyDataRow)

Syntax

'Declaration

Public ReadOnly Property ParentGeneric As ClarifyGeneric

public ClarifyGeneric ParentGeneric {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyDataRow Class
ClarifyDataRow Members


Table Property (ClarifyDataRow) | fcSDK Documentation

Table Property (ClarifyDataRow)

Syntax

'Declaration

Public Shadows ReadOnly Property Table As ClarifyDataTable

public new ClarifyDataTable Table {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyDataRow Class
ClarifyDataRow Members


ClarifyDataSet Class | fcSDK Documentation

ClarifyDataSet Class

Syntax

'Declaration

Public Class ClarifyDataSet
   Inherits FChoice.Foundation.GenericDataSet

public class ClarifyDataSet : FChoice.Foundation.GenericDataSet

Inheritance Hierarchy

System.Object
FChoice.Foundation.GenericDataSet
FChoice.Foundation.Clarify.ClarifyDataSet

Requirements

Namespace: FChoice.Foundation.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ClarifyDataSet Members
FChoice.Foundation.Clarify Namespace


ClarifyDataSet Class Members | fcSDK Documentation

ClarifyDataSet Class Members

The following tables list the members exposed by ClarifyDataSet.

Public Constructors

 | Name | Description
Public Constructor | ClarifyDataSet Constructor |

Public Properties

 | Name | Description
Public Property | DataSet | (Inherited from FChoice.Foundation.GenericDataSet)
Public Property | RestrictionGroup | (Inherited from FChoice.Foundation.GenericDataSet)
Public Property | Session |
Public Property | SortGenerics | (Inherited from FChoice.Foundation.GenericDataSet)
Public Property | UniqueID | (Inherited from FChoice.Foundation.GenericDataSet)

Public Methods

 | Name | Description
Public Method | CreateGeneric | Overloaded. Creates a new ClarifyGeneric based on the specified table or view name
Public Method | Query | Overloaded. (Inherited from FChoice.Foundation.GenericDataSet)
Public Method | Update | Overloaded. (Inherited from FChoice.Foundation.GenericDataSet)

Reference

ClarifyDataSet Class
FChoice.Foundation.Clarify Namespace


ClarifyDataSet Constructor | fcSDK Documentation

ClarifyDataSet Constructor

Syntax

'Declaration

Public Function New( _
   ByVal _session_ As ClarifySession _
)

public ClarifyDataSet(
   ClarifySession _session_
)

Parameters

session

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyDataSet Class
ClarifyDataSet Members


CreateGeneric Method (ClarifyDataSet) | fcSDK Documentation

CreateGeneric Method (ClarifyDataSet)

Creates a new ClarifyGeneric based on the specified table or view name

Creates a new ClarifyGeneric, the main class for accessing data in the Clarify system, from this ClarifyDataSet.

Overload List

Overload | Description
CreateGeneric(String) | Creates a new ClarifyGeneric based on the specified table or view name
CreateGeneric(Int32,String,String) | Creates a new ClarifyGeneric, traversing from a specified root object type and objid using the specified relation

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyDataSet Class
ClarifyDataSet Members


CreateGeneric(String) Method | fcSDK Documentation

CreateGeneric(String) Method

The name of the table or view on which the new generic will be based.

Creates a new ClarifyGeneric based on the specified table or view name

Syntax

'Declaration

Public Overloads Overridable Function CreateGeneric( _
   ByVal _tableName_ As String _
) As ClarifyGeneric

public virtual ClarifyGeneric CreateGeneric(
   string _tableName_
)

Parameters

tableName

The name of the table or view on which the new generic will be based.

Return Value

A new ClarifyGeneric based on the specified table or view name

Remarks

NOTE: Generics based on views cannot be updated, modified, or related to other generics, rows, or values.

Example

This example shows how to create a generic from the session (it assumes that the application is already initialized and that a session has been created in the variable 'session'), traverse to children generics and iterate over rows.

// Create a dataset ClarifyDataSet dataSet = new ClarifyDataSet(session);

// Get all cases, activity logs, and contact. ClarifyGeneric gCase = dataSet.CreateGeneric("case");

ClarifyGeneric gAct = gCase.Traverse("case_act2act_entry");

ClarifyGeneric gContact = gCase.Traverse("case_reporter2contact");

// Now query the data gCase.Query();

// Display return data to the console. First the case, then all
// activity logs then the one contact for the case foreach( ClarifyDataRow caseRow in gCase )
{
    Console.WriteLine("Case ID: {0}", caseRow\["id_number"\]);

    // Show each act entry
    foreach( ClarifyDataRow actRow in caseRow.RelatedRows(gAct) )
    {
        Console.WriteLine("  Activity: {0}", actRow\["objid"\]);
    }

    // Show each contact
    foreach( ClarifyDataRow conRow in caseRow.RelatedRows(gContact) )
    {
        Console.WriteLine("  Contact: {0} {1}", conRow\["first_name"\], conRow\["last_name"\]);
    }
}

' Create a dataset Dim dataSet As New ClarifyDataSet(session)

' Get all cases, activity logs, and contact. Dim gCase As ClarifyGeneric = dataSet.CreateGeneric("case")

Dim gAct As ClarifyGeneric = gCase.Traverse("case_act2act_entry")

Dim gContact As ClarifyGeneric = gCase.Traverse("case_reporter2contact")

' Now query the data gCase.Query()

' Display return data to the console. First the case, then all
' activity logs then the one contact for the case For Each caseRow As ClarifyDataRow In gCase

    Console.WriteLine("Case ID: {0}", caseRow("id_number"))

    ' Show each act entry
    For Each actRow As ClarifyDataRow In caseRow.RelatedRows(gAct)
        Console.WriteLine("  Activity: {0}", actRow("objid"))
    Next

    ' Show each contact
    For Each conRow As ClarifyDataRow In caseRow.RelatedRows(gContact)
        Console.WriteLine("  Contact: {0} {1}", conRow("first_name"), conRow("last_name"))
    Next
Next

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyDataSet Class
ClarifyDataSet Members
Overload List


CreateGeneric(Int32,String,String) Method | fcSDK Documentation

CreateGeneric(Int32,String,String) Method

The objid of the object from which this generic will traverse

The object type (table name) of the object from which to traverse

The relation from the parent to use when traversing this generic from the specified root

Creates a new ClarifyGeneric, traversing from a specified root object type and objid using the specified relation

Syntax

'Declaration

Public Overloads Overridable Function CreateGeneric( _
   ByVal _rootObjID_ As Integer, _
   ByVal _rootObject_ As String, _
   ByVal _relFromParent_ As String _
) As ClarifyGeneric

public virtual ClarifyGeneric CreateGeneric(
   int _rootObjID_,
   string _rootObject_,
   string _relFromParent_
)

Parameters

rootObjID

The objid of the object from which this generic will traverse

rootObject

The object type (table name) of the object from which to traverse

relFromParent

The relation from the parent to use when traversing this generic from the specified root

Return Value

A new ClarifyGeneric initialized with the specified table (child of the specified relation) and related to the specified parent root object

Remarks

This method sets a query for a generic object, given a root object table name, the objid for a row in that table, and the relation to follow from that row to this generic obj. This method saves querying the root object (as a parent object) when it is not needed otherwise. This method requires that you already have the objid of the object from which you wish to traverse. For example, the current user's objid is cached in the current ClarifySession data. It would be inefficient to make a special query to the user table to retrieve the row simply to retrieve the objid when it's already available in the session data. Instead, this method will allow you to traverse straight to child objects knowing only the user's objid.

NOTE: There is no parent/child relationship set up since there is no parent generic available.

Example

The following example retrieves all of the queues that the current user is assigned to. This example assumes that Initialize has already been called on ClarifyApplication and a new ClarifySession has been created using CreateSession.

// Create the DataSet ClarifyDataSet dataSet = new ClarifyDataSet(session);

// Traverse from the user's objid ClarifyGeneric gQueue = dataSet.CreateGeneric(
    (int)session\["user.id"\], "user", "user_assigned2queue" );

// Query the data and print it to the console gQueue.Query();

foreach( ClarifyDataRow row in gQueue )
{
    Console.WriteLine("Queue title: {0}",
        row\["title"\] );
}

' Create the DataSet Dim dataSet As New ClarifyDataSet(session)

' Traverse from the user's objid Dim gQueue As ClarifyGeneric = session.CreateGeneric( _
    session("user.id"), "user", "user_assigned2queue" )

' Query the data and print it to the console gQueue.Query()

For Each row As ClarifyDataRow In gQueue
    Console.WriteLine("Queue title: {0}", row("title") )
Next

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyDataSet Class
ClarifyDataSet Members
Overload List


Session Property (ClarifyDataSet) | fcSDK Documentation

Session Property (ClarifyDataSet)

Syntax

'Declaration

Public ReadOnly Property Session As ClarifySession

public ClarifySessionSession {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyDataSet Class
ClarifyDataSet Members


ClarifyDataTable Class | fcSDK Documentation

ClarifyDataTable Class

Syntax

'Declaration

<DefaultMemberAttribute("Item")>
Public Class ClarifyDataTable
   Inherits FChoice.Foundation.GenericDataTable

[DefaultMemberAttribute("Item")]
public class ClarifyDataTable : FChoice.Foundation.GenericDataTable

Inheritance Hierarchy

System.Object
System.ComponentModel.MarshalByValueComponent
System.Data.DataTable
FChoice.Foundation.GenericDataTable
FChoice.Foundation.Clarify.ClarifyDataTable

Requirements

Namespace: FChoice.Foundation.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ClarifyDataTable Members
FChoice.Foundation.Clarify Namespace


ClarifyDataTable Class Members | fcSDK Documentation

ClarifyDataTable Class Members

The following tables list the members exposed by ClarifyDataTable.

Public Properties

 | Name | Description
Public Property | CaseSensitive | (Inherited from System.Data.DataTable)
Public Property | ChildRelations | (Inherited from System.Data.DataTable)
Public Property | Columns | (Inherited from System.Data.DataTable)
Public Property | Constraints | (Inherited from System.Data.DataTable)
Public Property | Container | (Inherited from System.ComponentModel.MarshalByValueComponent)
Public Property | Count | Number of GenericDataRows currently in the table. (Inherited from FChoice.Foundation.GenericDataTable)
Public Property | DataSet | (Inherited from System.Data.DataTable)
Public Property | DefaultView | (Inherited from System.Data.DataTable)
Public Property | DesignMode | (Inherited from System.ComponentModel.MarshalByValueComponent)
Public Property | DisplayExpression | (Inherited from System.Data.DataTable)
Public Property | ExtendedProperties | (Inherited from System.Data.DataTable)
Public Property | FCGeneric | (Inherited from FChoice.Foundation.GenericDataTable)
Public Property | Generic |
Public Property | HasErrors | (Inherited from System.Data.DataTable)
Public Property | IsInitialized | (Inherited from System.Data.DataTable)
Public Property | IsMtmTable | Is this table an Many To Many mapping table? (Inherited from FChoice.Foundation.GenericDataTable)
Public Property | Item |
Public Property | Locale | (Inherited from System.Data.DataTable)
Public Property | MinimumCapacity | (Inherited from System.Data.DataTable)
Public Property | Namespace | (Inherited from System.Data.DataTable)
Public Property | ParentRelations | (Inherited from System.Data.DataTable)
Public Property | Prefix | (Inherited from System.Data.DataTable)
Public Property | PrimaryKey | (Inherited from System.Data.DataTable)
Public Property | RemotingFormat | (Inherited from System.Data.DataTable)
Public Property | Rows |
Public Property | Site | (Inherited from System.Data.DataTable)
Public Property | TableName | (Inherited from System.Data.DataTable)

Public Methods

 | Name | Description
Public Method | AcceptChanges | (Inherited from System.Data.DataTable)
Public Method | BeginInit | (Inherited from System.Data.DataTable)
Public Method | BeginLoadData | (Inherited from System.Data.DataTable)
Public Method | Clear | (Inherited from System.Data.DataTable)
Public Method | Clone | (Inherited from System.Data.DataTable)
Public Method | Compute | (Inherited from System.Data.DataTable)
Public Method | Copy | (Inherited from System.Data.DataTable)
Public Method | CreateDataReader | (Inherited from System.Data.DataTable)
Public Method | Dispose | (Inherited from System.ComponentModel.MarshalByValueComponent)
Public Method | EndInit | (Inherited from System.Data.DataTable)
Public Method | EndLoadData | (Inherited from System.Data.DataTable)
Public Method | GetChanges | (Inherited from System.Data.DataTable)
Public Method | GetEnumerator | Returns an enumerator that can iterate through the GenericDataTable. (Inherited from FChoice.Foundation.GenericDataTable)
Public Method | GetErrors | (Inherited from System.Data.DataTable)
Public Method | GetObjectData | (Inherited from System.Data.DataTable)
Public Method | GetService | (Inherited from System.ComponentModel.MarshalByValueComponent)
Public Method | ImportRow | (Inherited from System.Data.DataTable)
Public Method | Load | Overloaded. (Inherited from System.Data.DataTable)
Public Method | LoadDataRow | Overloaded. (Inherited from System.Data.DataTable)
Public Method | Merge | Overloaded. (Inherited from System.Data.DataTable)
Public Method | NewRow | (Inherited from System.Data.DataTable)
Public Method | ReadXml | Overloaded. (Inherited from System.Data.DataTable)
Public Method | ReadXmlSchema | Overloaded. (Inherited from System.Data.DataTable)
Public Method | RejectChanges | (Inherited from System.Data.DataTable)
Public Method | Reset | (Inherited from System.Data.DataTable)
Public Method | Select | Overloaded. (Inherited from System.Data.DataTable)
Public Method | ToString | (Inherited from System.Data.DataTable)
Public Method | WriteXml | Overloaded. (Inherited from System.Data.DataTable)
Public Method | WriteXmlSchema | Overloaded. (Inherited from System.Data.DataTable)

Public Events

 | Name | Description
Public Event | ColumnChanged | (Inherited from System.Data.DataTable)
Public Event | ColumnChanging | (Inherited from System.Data.DataTable)
Public Event | Disposed | (Inherited from System.ComponentModel.MarshalByValueComponent)
Public Event | Initialized | (Inherited from System.Data.DataTable)
Public Event | RowChanged | (Inherited from System.Data.DataTable)
Public Event | RowChanging | (Inherited from System.Data.DataTable)
Public Event | RowDeleted | (Inherited from System.Data.DataTable)
Public Event | RowDeleting | (Inherited from System.Data.DataTable)
Public Event | TableCleared | (Inherited from System.Data.DataTable)
Public Event | TableClearing | (Inherited from System.Data.DataTable)
Public Event | TableNewRow | (Inherited from System.Data.DataTable)

Reference

ClarifyDataTable Class
FChoice.Foundation.Clarify Namespace


Generic Property | fcSDK Documentation

Generic Property

Syntax

'Declaration

Public ReadOnly Property Generic As ClarifyGeneric

public ClarifyGeneric Generic {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyDataTable Class
ClarifyDataTable Members


Item Property (ClarifyDataTable) | fcSDK Documentation

Item Property (ClarifyDataTable)

Syntax

'Declaration

Public Shadows ReadOnly Default Property Item( _
   ByVal _index_ As Integer _
) As ClarifyDataRow

public new ClarifyDataRow this[
   int _index_
]; {get;}

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyDataTable Class
ClarifyDataTable Members


Rows Property | fcSDK Documentation

Rows Property

Syntax

'Declaration

Public Shadows ReadOnly Property Rows As ClarifyRowCollection

public new ClarifyRowCollection Rows {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyDataTable Class
ClarifyDataTable Members


ClarifyException Class | fcSDK Documentation

ClarifyException Class

Syntax

'Declaration

<SerializableAttribute()>
Public Class ClarifyException
   Inherits FChoice.Common.FCExceptionBase

[SerializableAttribute()]
public class ClarifyException : FChoice.Common.FCExceptionBase

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
FChoice.Common.FCExceptionBase
FChoice.Foundation.Clarify.ClarifyException

Requirements

Namespace: FChoice.Foundation.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ClarifyException Members
FChoice.Foundation.Clarify Namespace


ClarifyException Class Members | fcSDK Documentation

ClarifyException Class Members

The following tables list the members exposed by ClarifyException.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorCode | Gets the unique error code for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | ErrorMessageID | Gets the message identifier for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | Sets the SerializationInfo object with the parameter name and additional exception information. (Inherited from FChoice.Common.FCExceptionBase)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)

Reference

ClarifyException Class
FChoice.Foundation.Clarify Namespace


ClarifyGeneric Class | fcSDK Documentation

ClarifyGeneric Class

Provides core Clarify business logic and managed access to Clarify data.

Syntax

'Declaration

<DefaultMemberAttribute("Item")>
Public Class ClarifyGeneric
   Inherits FChoice.Foundation.FCGeneric

[DefaultMemberAttribute("Item")]
public class ClarifyGeneric : FChoice.Foundation.FCGeneric

Remarks

This is the core business object in FCFL.NET. Each instance of ClarifyGeneric represents records from tables and views in the Clarify database. The generic object allows you to query the database for rows in the table or view, add new table rows, or update or delete existing table rows (NOTE: updates are only available for tables, views are read-only).

Generics are created from a ClarifyDataSet object using CreateGeneric, or by traversing from a parent generic (using Traverse). Generics inherit properties from their session such as whether or not they are distinct by default (DefaultDistinctGenerics) or whether First Choice Data Restrictions are enabled (RestrictionsEnabled).

Generics created using Traverse from a parent generic always belong to the same ClarifyDataSet as the parent generic.

Example

This example shows the various ways to create a generic.

// First, create a new ClarifyDataSet ClarifyDataSet dataSet = new ClarifyDataSet(session);

// Create a generic from the ClarifyDataSet based on the site table ClarifyGeneric gSite = dataSet.CreateGeneric("site");
gSite.Query();

// Also, generics can be created by traversing from a parent
// In this example, gAddr is a child of gSite using the cust_primaddr2address
// relation ClarifyGeneric gAddr = gSite.Traverse("cust_primaddr2address");

// This queries both gSite and gAddr gSite.Query()

' First, create a new ClarifyDataSet Dim dataSet As New ClarifyDataSet(session)

' Create a generic from the ClarifyDataSet based on the site table Dim gSite As ClarifyGeneric = dataSet.CreateGeneric("site")
gSite.Query()

' Also, generics can be created by traversing from a parent
' In this example, gAddr is a child of gSite using the cust_primaddr2address
' relation Dim gAddr As ClarifyGeneric = gSite.Traverse("cust_primaddr2address")

' This queries both gSite and gAddr gSite.Query()

Inheritance Hierarchy

System.Object
FChoice.Foundation.FCGeneric
FChoice.Foundation.Clarify.ClarifyGeneric

Requirements

Namespace: FChoice.Foundation.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ClarifyGeneric Members
FChoice.Foundation.Clarify Namespace


ClarifyGeneric Class Members | fcSDK Documentation

ClarifyGeneric Class Members

The following tables list the members exposed by ClarifyGeneric.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | GuidColumnName |

Public Properties

 | Name | Description
Public Property | ChildGenerics | Gets an IDictionary of associated child generics keyed by their relation from the parent (Inherited from FChoice.Foundation.FCGeneric)
Public Property | Count | Returns the number of rows currently populated by the Query or AddNew methods. (Inherited from FChoice.Foundation.FCGeneric)
Public Property | DataFields | Collection of data fields that will be returned when Query is invoked. If no fields are selected all fields are returned. (Inherited from FChoice.Foundation.FCGeneric)
Public Property | DataRestrictionsEnabled |
Sets whether or not this FCGeneric will have the DataRestrictions feature enabled if available. (Inherited from FChoice.Foundation.FCGeneric) |  |
Public Property | DataSet |
Public Property | DeleteRelationsToUnrelate | (Inherited from FChoice.Foundation.FCGeneric)
Public Property | Filter | This is the root filter used to constrain rows returned during Query operations. Initially there are no filters present with filters being added using the AddFilter method. (Inherited from FChoice.Foundation.FCGeneric)
Public Property | IncludeRelations | Queries will retrieve all relation fields for the Generic (Inherited from FChoice.Foundation.FCGeneric)
Public Property | IsDistinct | Is this a Generic that should query for only discinct rows. (Inherited from FChoice.Foundation.FCGeneric)
Public Property | IsSynchronized | Gets a value indicating whether access to the FCGeneric is synchronized (thread-safe). (Inherited from FChoice.Foundation.FCGeneric)
Public Property | Item | Gets the ClarifyDataRow at the specified index in this ClarifyGeneric
Public Property | MaximumRows | Controls the maximum number of rows to be returned by the Genric Query. (Inherited from FChoice.Foundation.FCGeneric)
Public Property | ParentGeneric | Gets a reference to the parent ClarifyGeneric if this generic is a child
Public Property | ParentRelation | Gets a reference to the ISchemaRelation schema object which represents the relation used to traverse from the ParentGeneric
Public Property | QueryEmptyToNull | Sets whether or not this FCGeneric will convert filters on empty strings into filters on Queries that check IS NULL or IS NOT NULL. (Inherited from FChoice.Foundation.FCGeneric)
Public Property | RawFilter | Sets an optional WHERE clause constraint. (WARNING: See remarks for potential security implications) (Inherited from FChoice.Foundation.FCGeneric)
Public Property | RestrictionGroup | Override the Session Data Restriction Group of this Generic. The ChangeRestrictionGroup method is available as a helper. (Inherited from FChoice.Foundation.FCGeneric)
Public Property | Rows | Gets a reference to the ClarifyRowCollection which contains all the rows queried for this generic
Public Property | SchemaTable |
Public Property | SearchableFieldPrefix | Overridden.
Public Property | Session | Gets a reference to the parent ClarifySession of this generic.
Public Property | SetNullStringsToEmpty | Sets whether or not this FCGeneric will convert a null reference (Nothing in Visual Basic) to empty strings. (Inherited from FChoice.Foundation.FCGeneric)
Public Property | SyncRoot | Gets an object that can be used to synchronize access to the FCGeneric. (Inherited from FChoice.Foundation.FCGeneric)
Public Property | TableName | Returns the name of the database table this FCGeneric is based on. (Inherited from FChoice.Foundation.FCGeneric)

Public Methods

 | Name | Description
Public Method | AddForUpdate |
Creates a new row in the ClarifyGeneric with the specified objId which will be used to update an existing row in the database rather than inserting a new one. |  |
Public Method | AddNew | Overloaded. Adds a new row and schedules it for creation in the database when Update is called
Public Method | AppendFilter | Overloaded. Adds a filter to constrain the results of an FCGeneric Query against a numeric DataField. (Inherited from FChoice.Foundation.FCGeneric)
Public Method | AppendFilterBetween | Overloaded. Adds a specialized filter to constrain the results of an FCGeneric Query to be between two Integer values. (Inherited from FChoice.Foundation.FCGeneric)
Public Method | AppendFilterInList | Overloaded. Adds a filter to constrain the results of an FCGeneric Query against a list of possible Integer values**.** (Inherited from FChoice.Foundation.FCGeneric)
Public Method | AppendFilterIsNull | Adds a filter to constrain the results of an FCGeneric Query against NULL or NOT NULL fields. (Inherited from FChoice.Foundation.FCGeneric)
Public Method | AppendSort | Overloaded. (Inherited from FChoice.Foundation.FCGeneric)
Public Method | AssignAllObjIDs |
Public Method | AssignObjID | (Inherited from FChoice.Foundation.FCGeneric)
Public Method | ChangeRestrictionGroup | Change the Data Restriction Group of this generic instance overriding the Session default. This method is a helper for when you only know the name of the restriction group. (Inherited from FChoice.Foundation.FCGeneric)
Public Method | ClearFilters | Clears all filters that have been appended to this generic. (Inherited from FChoice.Foundation.FCGeneric)
Public Method | ClearSorts | Clears all sort operations that have been appended to this generic. (Inherited from FChoice.Foundation.FCGeneric)
Public Method | CopyTo | Copies all the rows of the current FCGeneric into to a one-dimensional Array. (Inherited from FChoice.Foundation.FCGeneric)
Public Method | DeleteAll | Delete all rows present in this FCGeneric. (Inherited from FChoice.Foundation.FCGeneric)
Public Method | DeleteById | Deletes the row in the table with the specified objid
Public Method | GetEnumerator | Returns an IEnumerator for the FCGeneric. (Inherited from FChoice.Foundation.FCGeneric)
Public Method | Query | Overloaded. Overridden. Causes the generic object to query the database table or view using the optionally specified data fields, filters, and sort orders
Public Method | Traverse | Creates a child generic that is related to this generic through the specified relation
Public Method | TraverseFromParent | Makes this generic a child that is related to the specified parent generic through the specified relation
Public Method | TraverseFromRoot |
Public Method | Update | Overloaded. Updates changes to a single GenericDataRow (Inherited from FChoice.Foundation.FCGeneric)
Public Method | UpdateAll | Overloaded. Updates all modified rows of the FCGeneric. (Inherited from FChoice.Foundation.FCGeneric)

Public Events

 | Name | Description
Public Event | MaximumRowsExceeded | This event is fired when the MaximumRows property is set and a Query operation has returned too many rows. (Inherited from FChoice.Foundation.FCGeneric)

Reference

ClarifyGeneric Class
FChoice.Foundation.Clarify Namespace


AddForUpdate(Int32) Method | fcSDK Documentation

AddForUpdate(Int32) Method

The objid of the row to use for updating

Creates a new row in the ClarifyGeneric with the specified objId which will be used to update an existing row in the database rather than inserting a new one.

Syntax

'Declaration

Public Function AddForUpdate( _
   ByVal _objId_ As Integer _
) As ClarifyDataRow

public ClarifyDataRow AddForUpdate(
   int _objId_
)

Parameters

objId

The objid of the row to use for updating

Return Value

A newly created row populated with the specified objid

Remarks

Use this method when you know the uniqueId of an object in the database and making a database query to retrieve the row would be inefficient. Use the GenericDataRow returned to update the generic. When you are finished calling one of the Update methods on the FCGeneric or GenericDataRow will commit the changes to the database.

Note: The objId must be a legal identifier for the Table the Generic belongs to.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyGeneric Class
ClarifyGeneric Members


AddNew Method (ClarifyGeneric) | fcSDK Documentation

AddNew Method (ClarifyGeneric)

Adds a new row and schedules it for creation in the database when Update is called

Adds a new row, optionally copying values from an existing row, and schedules it for creation in the database when Update is called.

Overload List

Overload | Description
AddNew() | Adds a new row and schedules it for creation in the database when Update is called
AddNew(ClarifyDataRow) | Adds a new row, copying values from the specified original row, and schedules it for creation in the database when Update is called.

Remarks

All fields are initialized with their default values (i.e. NULL for relations, 0 for integer fields, etc). You can set individual fields using the ClarifyDataRow indexer and relate rows using one of the relate methods, such as RelateRecord. You can relate newly-added rows to other rows (even other newly-added rows). ClarifyGeneric will resolve the objids of new records properly when Update or UpdateAll is called.

If you do not supply an objid, ClarifyGeneric will generate a proper objid for the newly-added row. A custom objid can be provided and ClarifyGeneric will not tamper with the objid. It is the responsibility of the caller to ensure that the custom objid is unique within the system, otherwise data corruption could occur.

NOTE: If you have previously executed a query on this generic using a list of specific data fields, calling this method will fill in the rest of the columns for this table. This is different than previous functionality in FCFL(COM) which would throw an error if data fields were used to query originally.

Example

This example shows how to add a new row, associate it with other rows and update it to the database. In this example, the objid is generated automatically for the row.

// First, create a new ClarifyDataSet ClarifyDataSet dataSet = new ClarifyDataSet(session);

// Get one specific contact ClarifyGeneric gContact = dataSet.CreateGeneric("contact");
gContact.AppendFilter("objid", NumberOps.Equals, 268435457);

// Get one specific site ClarifyGeneric gSite = dataSet.CreateGeneric("site");
gSite.AppendFilter("objid", NumberOps.Equals, 268435457);

// Query both via the ClarifyDataSet dataSet.Query(gContact, gSite);

// Now create a new contact role
// Set it as a secondary role and relate it to the contact
// and site
// NOTE: In order for RelateRecord to work, the two generics
//    must be in the same ClarifyDataSet ClarifyGeneric gRole = dataSet.CreateGeneric("contact_role");
ClarifyDataRow row = gRole.AddNew();
row\["primary_site"\] = 2;
row\["role_name"\] = "Default";
row.RelateRecord( gContact\[0\], "contact_role2contact" );
row.RelateRecord( gSite\[0\], "contact_role2site" );
row.Update();

' First, create a new ClarifyDataSet Dim dataSet As New ClarifyDataSet(session)

' Get one specific contact Dim gContact As ClarifyGeneric = dataSet.CreateGeneric("contact")
gContact.AppendFilter("objid", NumberOps.Equals, 268435457)

' Get one specific site Dim gSite As ClarifyGeneric = dataSet.CreateGeneric("site")
gSite.AppendFilter("objid", NumberOps.Equals, 268435457)

' Query both via the ClarifyDataSet dataSet.Query(gContact, gSite)

' Now create a new contact role
' Set it as a secondary role and relate it to the contact
' and site
' NOTE: In order for RelateRecord to work, the two generics
'    must be in the same ClarifyDataSet Dim gRole As ClarifyGeneric = dataSet.CreateGeneric("contact_role")
Dim row As ClarifyDataRow = gRole.AddNew()
row("primary_site") = 2
row("role_name") = "Default"
row.RelateRecord( gContact(0), "contact_role2contact" )
row.RelateRecord( gSite(0), "contact_role2site" )
row.Update()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyGeneric Class
ClarifyGeneric Members


AddNew() Method | fcSDK Documentation

AddNew() Method

Adds a new row and schedules it for creation in the database when Update is called

Syntax

'Declaration

Public Overloads Function AddNew() As ClarifyDataRow

public ClarifyDataRow AddNew()

Return Value

A new ClarifyDataRow with the same fields as the current ClarifyGeneric present.

Remarks

All fields are initialized with their default values (i.e. NULL for relations, 0 for integer fields, etc). You can set individual fields using the ClarifyDataRow indexer and relate rows using one of the relate methods, such as RelateRecord. You can relate newly-added rows to other rows (even other newly-added rows). ClarifyGeneric will resolve the objIds of new records properly when Update or UpdateAll is called.

If you do not supply an objId, ClarifyGeneric will generate a proper objId for the newly-added row. A custom objId can be provided and ClarifyGeneric will not tamper with the objId. It is the responsibility of the caller to ensure that the custom objId is unique within the system, otherwise data corruption could occur.

NOTE: If you have previously executed a query on this generic using a list of specific data fields, only those fields will be available to set. This is different than previous functionality in FCFL(COM) which would throw an error if data fields were used to query originally.

Example

This example shows how to add a new row, associate it with other rows and update it to the database. In this example, the objId is generated automatically for the row.

// First, create a new ClarifyDataSet ClarifyDataSet dataSet = new ClarifyDataSet(session);

// Get one specific contact ClarifyGeneric gContact = dataSet.CreateGeneric("contact");
gContact.AppendFilter("objid", NumberOps.Equals, 268435457);

// Get one specific site ClarifyGeneric gSite = dataSet.CreateGeneric("site");
gSite.AppendFilter("objid", NumberOps.Equals, 268435457);

// Query both via the ClarifyDataSet dataSet.Query(gContact, gSite);

// Now create a new contact role
// Set it as a secondary role and relate it to the contact
// and site
// NOTE: In order for RelateRecord to work, the two generics
//    must be in the same ClarifyDataSet ClarifyGeneric gRole = dataSet.CreateGeneric("contact_role");
ClarifyDataRow row = gRole.AddNew();
row\["primary_site"\] = 2;
row\["role_name"\] = "Default";
row.RelateRecord( gContact\[0\], "contact_role2contact" );
row.RelateRecord( gSite\[0\], "contact_role2site" );
row.Update();

' First, create a new ClarifyDataSet Dim dataSet As New ClarifyDataSet(session)

' Get one specific contact Dim gContact As ClarifyGeneric = dataSet.CreateGeneric("contact")
gContact.AppendFilter("objid", NumberOps.Equals, 268435457)

' Get one specific site Dim gSite As ClarifyGeneric = dataSet.CreateGeneric("site")
gSite.AppendFilter("objid", NumberOps.Equals, 268435457)

' Query both via the ClarifyDataSet dataSet.Query(gContact, gSite)

' Now create a new contact role
' Set it as a secondary role and relate it to the contact
' and site
' NOTE: In order for RelateRecord to work, the two generics
'    must be in the same ClarifyDataSet Dim gRole As ClarifyGeneric = dataSet.CreateGeneric("contact_role")
Dim row As ClarifyDataRow = gRole.AddNew()
row("primary_site") = 2
row("role_name") = "Default"
row.RelateRecord( gContact(0), "contact_role2contact" )
row.RelateRecord( gSite(0), "contact_role2site" )
row.Update()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyGeneric Class
ClarifyGeneric Members
Overload List


AddNew(ClarifyDataRow) Method | fcSDK Documentation

AddNew(ClarifyDataRow) Method

Row to be duplicated that is based on the same Table.

Adds a new row, copying values from the specified original row, and schedules it for creation in the database when Update is called.

Syntax

'Declaration

Public Overloads Function AddNew( _
   ByVal _rowToDuplicate_ As ClarifyDataRow _
) As ClarifyDataRow

public ClarifyDataRow AddNew(
   ClarifyDataRow _rowToDuplicate_
)

Parameters

rowToDuplicate

Row to be duplicated that is based on the same Table.

Return Value

A new ClarifyDataRow with the same fields and values as the rowToDuplicate.

Remarks

This method effectively copies a ClarifyDataRow. All available fields from the rowToDuplicate parameter are copied into the new row even if the field is not currently populated in this ClarifyGeneric.

The new row added to the ClarifyGeneric will be at the end of the Rows collection.

If you do not supply an objId, ClarifyGeneric will generate a proper objId for the newly-added row. A custom objId can be provided and ClarifyGeneric will not tamper with the objId. It is the responsibility of the caller to ensure that the custom objId is unique within the system, otherwise data corruption could occur.

NOTE: If you have previously executed a query on this generic using a list of specific data fields, only those fields will be available to set. This is different than previous functionality in FCFL(COM) which would throw an error if data fields were used to query originally.

Example

This example shows how to add a new row with the values copied from an existing row and update it to the database. In this example, the objId is generated automatically for the row.

// First, create a new ClarifyDataSet ClarifyDataSet dataSet = new ClarifyDataSet(session);

// Get one specific contact ClarifyGeneric gContact = dataSet.CreateGeneric("contact");
gContact.AppendFilter("objid", NumberOps.Equals, 268435457);

// Get one specific site ClarifyGeneric gSite = dataSet.CreateGeneric("site");
gSite.AppendFilter("objid", NumberOps.Equals, 268435457);

// Query both via the ClarifyDataSet dataSet.Query(gContact, gSite);

// Query for the primary role at this site ClarifyGeneric gRole = dataSet.CreateGeneric("contact_role");
gRole.AppendFilter("primary_site", NumberOps.Equals, 1);
gRole.Query();

// Create a new secondary role for this site by duplicating the primary ClarifyDataRow newRow = gRole.AddNew( gRole\[0\] );
// Make it the secondary site newRow\["primary_site"\] = 2;
newRow.Update();

' First, create a new ClarifyDataSet Dim dataSet As New ClarifyDataSet(session)

' Get one specific contact Dim gContact As ClarifyGeneric = dataSet.CreateGeneric("contact")
gContact.AppendFilter("objid", NumberOps.Equals, 268435457)

' Get one specific site Dim gSite As ClarifyGeneric = dataSet.CreateGeneric("site")
gSite.AppendFilter("objid", NumberOps.Equals, 268435457)

' Query both via the ClarifyDataSet dataSet.Query(gContact, gSite)

' Query for the primary role at this site Dim gRole As ClarifyGeneric = dataSet.CreateGeneric("contact_role")
gRole.AppendFilter("primary_site", NumberOps.Equals, 1)
gRole.Query()

' Create a new secondary role for this site by duplicating the primary Dim newRow As ClarifyDataRow = gRole.AddNew( gRole(0) )
' Make it the secondary site newRow("primary_site") = 2
newRow.Update()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyGeneric Class
ClarifyGeneric Members
Overload List


AssignAllObjIDs(ClarifyDataRow[]) Method | fcSDK Documentation

AssignAllObjIDs(ClarifyDataRow[]) Method

Syntax

'Declaration

Public Sub AssignAllObjIDs( _
   ByVal _rows_() As ClarifyDataRow _
)

public void AssignAllObjIDs(
   ClarifyDataRow\[\] _rows_
)

Parameters

rows

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyGeneric Class
ClarifyGeneric Members


DeleteById Method | fcSDK Documentation

DeleteById Method

The objid of the row to delete

Deletes the row in the table with the specified objid

Syntax

'Declaration

Public Sub DeleteById( _
   ByVal _objId_ As Integer _
)

public void DeleteById(
   int _objId_
)

Parameters

objId

The objid of the row to delete

Remarks

This method will flag a specific objid in the current generic's table for deletion. No action is taken until Update or UpdateAll is called.

During an update, a blind DELETE statement to the database with a WHERE clause limiting it to deleting only the row with the specified objid.

NOTE: No error or other feedback is given if the specified row does not exist.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyGeneric Class
ClarifyGeneric Members


Query Method (ClarifyGeneric) | fcSDK Documentation

Query Method (ClarifyGeneric)

Query Method (ClarifyGeneric)

Causes the generic object to query the database table or view using the optionally specified data fields, filters, and sort orders

Causes the generic object to query the database table or view using the optionally specified data fields, filters, and sort orders

Overload List

Overload | Description
Query() | Causes the generic object to query the database table or view using the optionally specified data fields, filters, and sort orders
Query(IDbTransaction) | Causes the generic object to query the database table or view using the specified active transaction and, optionally, specified data fields, filters, and sort orders

Remarks

This method causes the generic object to query the database table or view using any specified data fields, filters, and/or sort orders. The query retrieves 0 or more rows.

For more information on controlling the number and type of fields returned, see the DataFields property documentation. To restrict a query by adding filters, see the documentation for the AppendFilter method overloads. To control the order in which rows are sorted, see the AppendSort method documentation.

NOTE: If you have traversed child objects from this generic, all children in the hierarchy will also be queried when this method is called. For example, if you wish to query the case object for one specific case, but also wish to get all related activity logs and the related contact, you would set up the case, activity_log, and contact generic objects (see example), and would only have to query the case generic object.

If more than one object that is to be queried at the same time and are not related, use the Query Method on the ClarifyDataSet instance from which this generate was created to ensure that the queries are optimized and are executed in the same transaction.

Example

This example shows how to traverse several generics into a hierarchy, query the parent and then iterate through the rows and display the results of the query.

// Create a dataset ClarifyDataSet dataSet = new ClarifyDataSet(session);

// Get all cases, activity logs, and contact. ClarifyGeneric gCase = dataSet.CreateGeneric("case");

ClarifyGeneric gAct = gCase.Traverse("case_act2act_entry");

ClarifyGeneric gContact = gCase.Traverse("case_reporter2contact");

// Now query the data gCase.Query();

// Display return data to the console. First the case, then all
// activity logs then the one contact for the case foreach( ClarifyDataRow caseRow in gCase )
{
    Console.WriteLine("Case ID: {0}", caseRow\["id_number"\]);

    // Show each act entry
    foreach( ClarifyDataRow actRow in caseRow.RelatedRows(gAct) )
    {
        Console.WriteLine("  Activity: {0}", actRow\["objid"\]);
    }

    // Show each contact
    foreach( ClarifyDataRow conRow in caseRow.RelatedRows(gContact) )
    {
        Console.WriteLine("  Contact: {0} {1}", conRow\["first_name"\], conRow\["last_name"\]);
    }
}

' Create a dataset Dim dataSet As New ClarifyDataSet(session)

' Get all cases, activity logs, and contact. Dim gCase As ClarifyGeneric = dataSet.CreateGeneric("case")

Dim gAct As ClarifyGeneric = gCase.Traverse("case_act2act_entry")

Dim gContact As ClarifyGeneric = gCase.Traverse("case_reporter2contact")

' Now query the data gCase.Query()

' Display return data to the console. First the case, then all
' activity logs then the one contact for the case For Each caseRow As ClarifyDataRow In gCase

    Console.WriteLine("Case ID: {0}", caseRow("id_number"))

    ' Show each act entry
    For Each actRow As ClarifyDataRow In caseRow.RelatedRows(gAct)
        Console.WriteLine("  Activity: {0}", actRow("objid"))
    Next

    ' Show each contact
    For Each conRow As ClarifyDataRow In caseRow.RelatedRows(gContact)
        Console.WriteLine("  Contact: {0} {1}", conRow("first_name"), conRow("last_name"))
    Next
Next

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyGeneric Class
ClarifyGeneric Members
Base Implementation in Query


Query() Method | fcSDK Documentation

Query() Method

Causes the generic object to query the database table or view using the optionally specified data fields, filters, and sort orders

Syntax

'Declaration

Public Overloads Overrides Sub Query()

public override void Query()

Remarks

This method causes the generic object to query the database table or view using any specified data fields, filters, and/or sort orders. The query retrieves 0 or more rows.

For more information on controlling the number and type of fields returned, see the DataFields property documentation. To restrict a query by adding filters, see the documentation for the AppendFilter method overloads. To control the order in which rows are sorted, see the AppendSort method documentation.

NOTE: If you have traversed child objects from this generic, all children in the hierarchy will also be queried when this method is called. For example, if you wish to query the case object for one specific case, but also wish to get all related activity logs and the related contact, you would set up the case, activity_log, and contact generic objects (see example), and would only have to query the case generic object.

If more than one object that is to be queried at the same time and are not related, use the Query Method on the ClarifyDataSet instance from which this generate was created to ensure that the queries are optimized and are executed in the same transaction.

Example

This example shows how to traverse several generics into a hierarchy, query the parent and then iterate through the rows and display the results of the query.

// Create a dataset ClarifyDataSet dataSet = new ClarifyDataSet(session);

// Get all cases, activity logs, and contact. ClarifyGeneric gCase = dataSet.CreateGeneric("case");

ClarifyGeneric gAct = gCase.Traverse("case_act2act_entry");

ClarifyGeneric gContact = gCase.Traverse("case_reporter2contact");

// Now query the data gCase.Query();

// Display return data to the console. First the case, then all
// activity logs then the one contact for the case foreach( ClarifyDataRow caseRow in gCase )
{
    Console.WriteLine("Case ID: {0}", caseRow\["id_number"\]);

    // Show each act entry
    foreach( ClarifyDataRow actRow in caseRow.RelatedRows(gAct) )
    {
        Console.WriteLine("  Activity: {0}", actRow\["objid"\]);
    }

    // Show each contact
    foreach( ClarifyDataRow conRow in caseRow.RelatedRows(gContact) )
    {
        Console.WriteLine("  Contact: {0} {1}", conRow\["first_name"\], conRow\["last_name"\]);
    }
}

' Create a dataset Dim dataSet As New ClarifyDataSet(session)

' Get all cases, activity logs, and contact. Dim gCase As ClarifyGeneric = dataSet.CreateGeneric("case")

Dim gAct As ClarifyGeneric = gCase.Traverse("case_act2act_entry")

Dim gContact As ClarifyGeneric = gCase.Traverse("case_reporter2contact")

' Now query the data gCase.Query()

' Display return data to the console. First the case, then all
' activity logs then the one contact for the case For Each caseRow As ClarifyDataRow In gCase

    Console.WriteLine("Case ID: {0}", caseRow("id_number"))

    ' Show each act entry
    For Each actRow As ClarifyDataRow In caseRow.RelatedRows(gAct)
        Console.WriteLine("  Activity: {0}", actRow("objid"))
    Next

    ' Show each contact
    For Each conRow As ClarifyDataRow In caseRow.RelatedRows(gContact)
        Console.WriteLine("  Contact: {0} {1}", conRow("first_name"), conRow("last_name"))
    Next
Next

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyGeneric Class
ClarifyGeneric Members
Overload List
Base Implementation in Query()


Query(IDbTransaction) Method | fcSDK Documentation

Query(IDbTransaction) Method

An active/open database IDbTransaction object in which this query will participate.

Causes the generic object to query the database table or view using the specified active transaction and, optionally, specified data fields, filters, and sort orders

Syntax

'Declaration

Public Overloads Overrides Sub Query( _
   ByVal _transaction_ As IDbTransaction _
)

public override void Query(
   IDbTransaction _transaction_
)

Parameters

transaction

An active/open database IDbTransaction object in which this query will participate.

Remarks

NOTE: This method is provided to support the Query Method on ClarifyDataSet and is not intended for direct use. However, if needed, please consider the following information about specifying a transaction. The provided IDbTransaction is expected to be open, connected, and live. Once this generic's query is complete, the transaction will NOT be closed or committed. If an error occurs, the transaction will be rolled back and an exception thrown.

This method causes the generic object to query the database table or view using any specified data fields, filters, and/or sort orders. The query retrieves 0 or more rows.

For more information on controlling the number and type of fields returned, see the DataFields property documentation. To restrict a query by adding filters, see the documentation for the AppendFilter method overloads. To control the order in which rows are sorted, see the AppendSort method documentation.

NOTE: If you have traversed child objects from this generic, all children in the hierarchy will also be queried when this method is called. For example, if you wish to query the case object for one specific case, but also wish to get all related activity logs and the related contact, you would set up the case, activity_log, and contact generic objects (see example), and would only have to query the case generic object.

If more than one object that is to be queried at the same time and are not related, use the Query Method on the ClarifyDataSet instance from which this generate was created to ensure that the queries are optimized and are executed in the same transaction.

Example

This example shows how to set up several generics in a hierarchy, query the parent and then iterate through the rows and display the results of the query.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyGeneric Class
ClarifyGeneric Members
Overload List
Base Implementation in Query(IDbTransaction)


Traverse(String) Method | fcSDK Documentation

Traverse(String) Method

fcSDK Documentation

Traverse(String) Method

The name of the relation on the parent that points to the desired child object

Creates a child generic that is related to this generic through the specified relation

Syntax

'Declaration

Public Function Traverse( _
   ByVal _relationName_ As String _
) As ClarifyGeneric

public ClarifyGeneric Traverse(
   string _relationName_
)

Parameters

relationName

The name of the relation on the parent that points to the desired child object

Return Value

The newly-created and related child generic

Remarks

The new child generic is related and linked to the parent. When the parent is queried or updated, the new generic will be queried or updated as well.

To retrieve the related rows for a given row in either generic after a query, call the RelatedRows method on that row and pass in the opposite generic (see example).

Example

This example shows how to traverse several generics into a hierarchy, query the parent and then iterate through the rows and display the results of the query.

// Create a dataset ClarifyDataSet dataSet = new ClarifyDataSet(session);

// Get all cases, activity logs, and contact. ClarifyGeneric gCase = dataSet.CreateGeneric("case");

ClarifyGeneric gAct = gCase.Traverse("case_act2act_entry");

ClarifyGeneric gContact = gCase.Traverse("case_reporter2contact");

// Now query the data gCase.Query();

// Display return data to the console. First the case, then all
// activity logs then the one contact for the case foreach( ClarifyDataRow caseRow in gCase )
{
    Console.WriteLine("Case ID: {0}", caseRow\["id_number"\]);

    // Show each act entry
    foreach( ClarifyDataRow actRow in caseRow.RelatedRows(gAct) )
    {
        Console.WriteLine("  Activity: {0}", actRow\["objid"\]);
    }

    // Show each contact
    foreach( ClarifyDataRow conRow in caseRow.RelatedRows(gContact) )
    {
        Console.WriteLine("  Contact: {0} {1}", conRow\["first_name"\], conRow\["last_name"\]);
    }
}

' Create a dataset Dim dataSet As New ClarifyDataSet(session)

' Get all cases, activity logs, and contact. Dim gCase As ClarifyGeneric = dataSet.CreateGeneric("case")

Dim gAct As ClarifyGeneric = gCase.Traverse("case_act2act_entry")

Dim gContact As ClarifyGeneric = gCase.Traverse("case_reporter2contact")

' Now query the data gCase.Query()

' Display return data to the console. First the case, then all
' activity logs then the one contact for the case For Each caseRow As ClarifyDataRow In gCase

    Console.WriteLine("Case ID: {0}", caseRow("id_number"))

    ' Show each act entry
    For Each actRow As ClarifyDataRow In caseRow.RelatedRows(gAct)
        Console.WriteLine("  Activity: {0}", actRow("objid"))
    Next

    ' Show each contact
    For Each conRow As ClarifyDataRow In caseRow.RelatedRows(gContact)
        Console.WriteLine("  Contact: {0} {1}", conRow("first_name"), conRow("last_name"))
    Next

Next

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyGeneric Class
ClarifyGeneric Members


TraverseFromParent Method (ClarifyGeneric) | fcSDK Documentation

TraverseFromParent Method (ClarifyGeneric)

Makes this generic a child that is related to the specified parent generic through the specified relation

Syntax

'Declaration

Public Sub TraverseFromParent( _
   ByVal _parentGeneric_ As ClarifyGeneric, _
   ByVal _relationName_ As String _
)

public void TraverseFromParent(
   ClarifyGeneric _parentGeneric_,
   string _relationName_
)

Parameters

parentGeneric

relationName

Remarks

This generic will be related and linked to the parent. When the parent is queried or updated, this generic will be queried or updated as well.

To retrieve the related rows for a given row in either generic after a query, call the RelatedRows method on that row and pass in the opposite generic.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyGeneric Class
ClarifyGeneric Members


TraverseFromRoot Method (ClarifyGeneric) | fcSDK Documentation

TraverseFromRoot Method (ClarifyGeneric)

Syntax

'Declaration

Public Sub TraverseFromRoot( _
   ByVal _rootObjID_ As Integer, _
   ByVal _rootObject_ As String, _
   ByVal _relationName_ As String _
)

public void TraverseFromRoot(
   int _rootObjID_,
   string _rootObject_,
   string _relationName_
)

Parameters

rootObjID

rootObject

relationName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyGeneric Class
ClarifyGeneric Members


DataSet Property (ClarifyGeneric) | fcSDK Documentation

DataSet Property (ClarifyGeneric)

Syntax

'Declaration

Public ReadOnly Property DataSet As ClarifyDataSet

public ClarifyDataSet DataSet {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyGeneric Class
ClarifyGeneric Members


Item Property (ClarifyGeneric) | fcSDK Documentation

Item Property (ClarifyGeneric)

Item Property (ClarifyGeneric)

The zero-based index of the ClarifyDataRow to get

Gets the ClarifyDataRow at the specified index in this ClarifyGeneric

Syntax

'Declaration

Public ReadOnly Default Property Item( _
   ByVal _index_ As Integer _
) As ClarifyDataRow

public ClarifyDataRow this[
   int _index_
]; {get;}

Parameters

index

The zero-based index of the ClarifyDataRow to get

Property Value

The ClarifyDataRow at the specified index in the collection

Remarks

This property provides the ability to access a specific ClarifyDataRow in the collection by using the following syntax: gCase[0] (gCase(0) in Visual Basic).

To iterate over the collection of rows in a generic, use the more efficient foreach() syntax (For Each in Visual Basic). Please see the example for more details.

This property provides the ability to access a specific ClarifyDataRow in the collection by using the following syntax: gCase[0] (gCase(0) in Visual Basic).

To iterate over the collection of rows in a generic, use the more efficient foreach() syntax (For Each in Visual Basic). Please see the example for more details.

Example

This example demonstrates how to query a generic and iterate over the rows returned from the query.

// Create the DataSet ClarifyDataSet dataSet = new ClarifyDataSet(session);

// Traverse from the user's objid ClarifyGeneric gQueue = dataSet.CreateGeneric(
    (int)session\["user.id"\], "user", "user_assigned2queue" );

// Query the data and print it to the console gQueue.Query();

foreach( ClarifyDataRow row in gQueue )
{
    Console.WriteLine("Queue title: {0}",
        row\["title"\] );
}

' Create the DataSet Dim dataSet As New ClarifyDataSet(session)

' Traverse from the user's objid Dim gQueue As ClarifyGeneric = session.CreateGeneric( _
    session("user.id"), "user", "user_assigned2queue" )

' Query the data and print it to the console gQueue.Query()

For Each row As ClarifyDataRow In gQueue
    Console.WriteLine("Queue title: {0}", row("title") )
Next

// Create the DataSet ClarifyDataSet dataSet = new ClarifyDataSet(session);

// Traverse from the user's objid ClarifyGeneric gQueue = dataSet.CreateGeneric(
    (int)session\["user.id"\], "user", "user_assigned2queue" );

// Query the data and print it to the console gQueue.Query();

foreach( ClarifyDataRow row in gQueue )
{
    Console.WriteLine("Queue title: {0}",
        row\["title"\] );
}

' Create the DataSet Dim dataSet As New ClarifyDataSet(session)

' Traverse from the user's objid Dim gQueue As ClarifyGeneric = session.CreateGeneric( _
    session("user.id"), "user", "user_assigned2queue" )

' Query the data and print it to the console gQueue.Query()

For Each row As ClarifyDataRow In gQueue
    Console.WriteLine("Queue title: {0}", row("title") )
Next

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyGeneric Class
ClarifyGeneric Members


ParentGeneric Property (ClarifyGeneric) | fcSDK Documentation

ParentGeneric Property (ClarifyGeneric)

Gets a reference to the parent ClarifyGeneric if this generic is a child

Syntax

'Declaration

Public ReadOnly Property ParentGeneric As ClarifyGeneric

public ClarifyGeneric ParentGeneric {get;}

Property Value

A reference to the parent ClarifyGeneric if this is a child generic, otherwise a null reference (Nothing in Visual Basic) if this is a parent or an individual generic.

Remarks

For more examples and information on how to create parent/child generic hierarchies, see the Traverse and TraverseFromParent methods.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyGeneric Class
ClarifyGeneric Members


ParentRelation Property (ClarifyGeneric) | fcSDK Documentation

ParentRelation Property (ClarifyGeneric)

Gets a reference to the ISchemaRelation schema object which represents the relation used to traverse from the ParentGeneric

Syntax

'Declaration

Public ReadOnly Property ParentRelation As SchemaRelation

public SchemaRelation ParentRelation {get;}

Property Value

A reference to the ISchemaRelation schema object which represents the relation used to traverse from the ParentGeneric or a null reference (Nothing in Visual Basic) if this a parent or individual generic.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyGeneric Class
ClarifyGeneric Members


Rows Property (ClarifyGeneric) | fcSDK Documentation

Rows Property (ClarifyGeneric)

Gets a reference to the ClarifyRowCollection which contains all the rows queried for this generic

Syntax

'Declaration

Public ReadOnly Property Rows As ClarifyRowCollection

public ClarifyRowCollection Rows {get;}

Property Value

A ClarifyRowCollection containing the rows for this generic

Remarks

This property is similar to the Item property of ClarifyGeneric. The rows for this generic can be accessed using either property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyGeneric Class
ClarifyGeneric Members


SchemaTable Property | fcSDK Documentation

SchemaTable Property

Syntax

'Declaration

Public ReadOnly Property SchemaTable As SchemaTableBase

public SchemaTableBase SchemaTable {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyGeneric Class
ClarifyGeneric Members


SearchableFieldPrefix Property (ClarifyGeneric) | fcSDK Documentation

SearchableFieldPrefix Property (ClarifyGeneric)

Syntax

'Declaration

Public Overrides ReadOnly Property SearchableFieldPrefix As String

public override string SearchableFieldPrefix {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyGeneric Class
ClarifyGeneric Members
Base Implementation in SearchableFieldPrefix


Session Property (ClarifyGeneric) | fcSDK Documentation

Session Property (ClarifyGeneric)

Gets a reference to the parent ClarifySession of this generic.

Syntax

'Declaration

Public ReadOnly Property Session As ClarifySession

public ClarifySession Session {get;}

Property Value

The parent ClarifySession of this generic.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyGeneric Class
ClarifyGeneric Members


GuidColumnName Field | fcSDK Documentation

GuidColumnName Field

Syntax

'Declaration

Public Shared ReadOnly GuidColumnName As String

public static readonly string GuidColumnName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyGeneric Class
ClarifyGeneric Members


ClarifyGenericException Class | fcSDK Documentation

ClarifyGenericException Class

Syntax

'Declaration

<SerializableAttribute()>
Public Class ClarifyGenericException
   Inherits FChoice.Foundation.GenericException

[SerializableAttribute()]
public class ClarifyGenericException : FChoice.Foundation.GenericException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
FChoice.Common.FCExceptionBase
FChoice.Foundation.FoundationException
FChoice.Foundation.GenericException
FChoice.Foundation.Clarify.ClarifyGenericException

Requirements

Namespace: FChoice.Foundation.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ClarifyGenericException Members
FChoice.Foundation.Clarify Namespace


ClarifyGenericException Class Members | fcSDK Documentation

ClarifyGenericException Class Members

The following tables list the members exposed by ClarifyGenericException.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorCode | Gets the unique error code for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | ErrorMessageID | Gets the message identifier for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | Sets the SerializationInfo object with the parameter name and additional exception information. (Inherited from FChoice.Common.FCExceptionBase)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)

Reference

ClarifyGenericException Class
FChoice.Foundation.Clarify Namespace


ClarifyRowCollection Class | fcSDK Documentation

ClarifyRowCollection Class

Syntax

'Declaration

<DefaultMemberAttribute("Item")>
Public Class ClarifyRowCollection
   Inherits FChoice.Foundation.GenericDataRowCollection

[DefaultMemberAttribute("Item")]
public class ClarifyRowCollection : FChoice.Foundation.GenericDataRowCollection

Inheritance Hierarchy

System.Object
FChoice.Foundation.GenericDataRowCollection
FChoice.Foundation.Clarify.ClarifyRowCollection

Requirements

Namespace: FChoice.Foundation.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ClarifyRowCollection Members
FChoice.Foundation.Clarify Namespace


ClarifyRowCollection Class Members | fcSDK Documentation

ClarifyRowCollection Class Members

The following tables list the members exposed by ClarifyRowCollection.

Public Properties

 | Name | Description
Public Property | Count | Gets the total number of elements in a collection. (Inherited from FChoice.Foundation.GenericDataRowCollection)
Public Property | IsSynchronized | Gets a value indicating whether the GenericDataRowCollection is synchronized. (Inherited from FChoice.Foundation.GenericDataRowCollection)
Public Property | Item |
Public Property | SyncRoot | Gets an object that can be used to synchronize the collection. (Inherited from FChoice.Foundation.GenericDataRowCollection)
Public Property | Table |

Public Methods

 | Name | Description
Public Method | Add | Adds the specified GenericDataRow to the collection. (Inherited from FChoice.Foundation.GenericDataRowCollection)
Public Method | Contains | Overloaded. Test if one ore more GenericDataRows are already in the collection. (Inherited from FChoice.Foundation.GenericDataRowCollection)
Public Method | CopyTo | Copies all the elements of the current GenericDataRowCollection to a one-dimensional Array, starting at the specified index. (Inherited from FChoice.Foundation.GenericDataRowCollection)
Public Method | Find | Overloaded. Gets the row containing the specified primary key values. (Inherited from FChoice.Foundation.GenericDataRowCollection)
Public Method | GetEnumerator | Gets an IEnumerator for the collection. (Inherited from FChoice.Foundation.GenericDataRowCollection)

Reference

ClarifyRowCollection Class
FChoice.Foundation.Clarify Namespace


Item Property (ClarifyRowCollection) | fcSDK Documentation

Item Property (ClarifyRowCollection)

Syntax

'Declaration

Public Shadows ReadOnly Default Property Item( _
   ByVal _index_ As Integer _
) As ClarifyDataRow

public new ClarifyDataRow this[
   int _index_
]; {get;}

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyRowCollection Class
ClarifyRowCollection Members


Table Property (ClarifyRowCollection) | fcSDK Documentation

Table Property (ClarifyRowCollection)

Syntax

'Declaration

Public Shadows ReadOnly Property Table As ClarifyDataTable

public new ClarifyDataTable Table {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyRowCollection Class
ClarifyRowCollection Members


ClarifySession Class | fcSDK Documentation

ClarifySession Class

ClarifySession contains session information for a logged-in user and allows for manipulation of data in the Clarify system as that user.

Syntax

'Declaration

Public Class ClarifySession
   Inherits FChoice.Foundation.FCSession

public class ClarifySession : FChoice.Foundation.FCSession

Remarks

To create a session, see ClarifyApplication.CreateSession.

To start accessing data, see the CreateGeneric method.

FCFL.NET sessions are stateful containers that are used to remember information about a user during their session using the system. They also provide access to manipulate data and settings in the Clarify system.

Inheritance Hierarchy

System.Object
FChoice.Foundation.FCSession
FChoice.Foundation.Clarify.ClarifySession

Requirements

Namespace: FChoice.Foundation.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ClarifySession Members
FChoice.Foundation.Clarify Namespace


ClarifySession Class Members | fcSDK Documentation

ClarifySession Class Members

The following tables list the members exposed by ClarifySession.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | ConfigItems | | | Public Property | ConvertTimeZone | Sets whether or not any DateTimes will be translated to and from ServerTimeZone and LocalTimeZone. Default value is false. (Inherited from FChoice.Foundation.FCSession) | | Public Property | CreationTime | Timestamp when the session was created. (Inherited from FChoice.Foundation.FCSession) | | Public Property | CurrentCulture | Returns the Culture being used by the session. (Inherited from FChoice.Foundation.FCSession) | | Public Property | DataRestrictionsEnabled | (Inherited from FChoice.Foundation.FCSession) | | Public Property | DefaultCulture | Returns the default Culture being used by the session. (Inherited from FChoice.Foundation.FCSession) | | Public Property | DefaultDistinctGenerics | Sets whether or not newly created generic objects will have IsDistinct set to include all relation data fields during Queries.

(Inherited from FChoice.Foundation.FCSession) | | Public Property | DisableDataConversions | Sets whether data conversions happen when GenericDataRow fields are modified. (Inherited from FChoice.Foundation.FCSession) | | Public Property | IncludeRelations | Sets whether or not newly created generic objects will include all relation data fields during Queries. (Inherited from FChoice.Foundation.FCSession) | | Public Property | Item | Get or set session data indexed by specified key. (Inherited from FChoice.Foundation.FCSession) | | Public Property | Items | (Inherited from FChoice.Foundation.FCSession) | | Public Property | LastLoadTime | Timestamp when the session was last loaded via FCApplication.GetSession (Inherited from FChoice.Foundation.FCSession) | | Public Property | LocalTimeZone | The TimeZone being used by the session. (Inherited from FChoice.Foundation.FCSession) | | Public Property | Log | Returns a Logger useful for logging application events or errors to the logging system. (Inherited from FChoice.Foundation.FCSession) | | Public Property | LoginType | | | Public Property | MaximumRows | (Inherited from FChoice.Foundation.FCSession) | | Public Property | PasswordRequired | Gets whether or not a password was used when CreateSession was called. (Inherited from FChoice.Foundation.FCSession) | | Public Property | QueryEmptyToNull |

Sets whether or not new newly created generic objects convert filters on empty strings into filters on Queries that check Is NULL or IS NOT NULL.

(Inherited from FChoice.Foundation.FCSession) | | Public Property | RestrictionGroup | Returns the data restriction group being used by the session. (Inherited from FChoice.Foundation.FCSession) | | Public Property | SessionData | (Inherited from FChoice.Foundation.FCSession) | | Public Property | SessionID |

Returns the session's unique identifier.

(Inherited from FChoice.Foundation.FCSession) | | Public Property | SetNullStringsToEmpty | Sets whether or not newly created generic objects will convert a null reference (Nothing in Visual Basic) to empty strings. (Inherited from FChoice.Foundation.FCSession) | | Public Property | TruncateStringFields | Sets whether or not newly created generic objects will truncate string fields if they are too long. (Inherited from FChoice.Foundation.FCSession) | | Public Property | UserID | Returns the unique identifier for the session's logged-in user. (Inherited from FChoice.Foundation.FCSession) | | Public Property | UserName | Returns the login name for the session's logged-in user. (Inherited from FChoice.Foundation.FCSession) |

Public Methods

| | Name | Description | | --- | --- | --- | | Public Method static (Shared in Visual Basic) | AuthenticateContact | | | Public Method | ChangePassword | Change the password for the session user. (Inherited from FChoice.Foundation.FCSession) | | Public Method | ChangeRestrictionGroup | Changes the RestrictionGroup the session is currently using. The change can be made permanent. (Inherited from FChoice.Foundation.FCSession) | | Public Method | ChangeUserConfigItem | Overloaded. | | Public Method | CloseSession | Remove the session from FCApplication and any Licenses it may be holding. (Inherited from FChoice.Foundation.FCSession) | | Public Method | ConvertDate | Overloaded. Converts a DateTime from one TimeZone to another. (Inherited from FChoice.Foundation.FCSession) | | Public Method | ConvertFromLocalToServerDate | Converts a DateTime from the session timezone to the server timezone. (Inherited from FChoice.Foundation.FCSession) | | Public Method | ConvertFromServerToLocalDate | Converts a DateTime from the server timezone to the session timezone.

(Inherited from FChoice.Foundation.FCSession) | | Public Method | Dispose | (Inherited from FChoice.Foundation.FCSession) | | Public Method | FormatElapsedTime | Overloaded. Formats an numeric value in seconds into a string "DDD HH MMM" where: D=Days, H=Hours, M=Minutes (Inherited from FChoice.Foundation.FCSession) | | Public Method | GetAssignedPermissions | (Inherited from FChoice.Foundation.FCSession) | | Public Method | GetCurrentDate | Retrieves the DateTime of the CRM database. (Inherited from FChoice.Foundation.FCSession) | | Public Method | GetCurrentServerDate | Retrieves the DateTime of the CRM database. (Inherited from FChoice.Foundation.FCSession) | | Public Method | GetNextNumScheme | Overloaded. | | Public Method | HasPermission | (Inherited from FChoice.Foundation.FCSession) | | Public Method | RefreshContext | Refresh the session information for the logged-in user. (Inherited from FChoice.Foundation.FCSession) | | Public Method | RegisterLicenseRequirements | (Inherited from FChoice.Foundation.FCSession) | | Public Method | SaveSession | (Inherited from FChoice.Foundation.FCSession) | | Public Method static (Shared in Visual Basic) | SetContactUserPassword | | | Public Method | SetPassword | Change a user's password (Inherited from FChoice.Foundation.FCSession) |

Reference

ClarifySession Class
FChoice.Foundation.Clarify Namespace


AuthenticateContact Method | fcSDK Documentation

AuthenticateContact Method

Syntax

'Declaration

Public Shared Function AuthenticateContact( _
   ByVal _username_ As String, _
   ByVal _password_ As String _
) As Boolean

public static bool AuthenticateContact(
   string _username_,
   string _password_
)

Parameters

username

password

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifySession Class
ClarifySession Members


ChangeUserConfigItem Method | fcSDK Documentation

ChangeUserConfigItem Method

Overload List

Overload | Description
ChangeUserConfigItem(String,Int32) |
ChangeUserConfigItem(String,Double) |
ChangeUserConfigItem(String,String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifySession Class
ClarifySession Members


ChangeUserConfigItem(String,Int32) Method | fcSDK Documentation

ChangeUserConfigItem(String,Int32) Method

Syntax

'Declaration

Public Overloads Sub ChangeUserConfigItem( _
   ByVal _configItemName_ As String, _
   ByVal _newValue_ As Integer _
)

public void ChangeUserConfigItem(
   string _configItemName_,
   int _newValue_
)

Parameters

configItemName

newValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifySession Class
ClarifySession Members
Overload List


ChangeUserConfigItem(String,Double) Method | fcSDK Documentation

ChangeUserConfigItem(String,Double) Method

Syntax

'Declaration

Public Overloads Sub ChangeUserConfigItem( _
   ByVal _configItemName_ As String, _
   ByVal _newValue_ As Double _
)

public void ChangeUserConfigItem(
   string _configItemName_,
   double _newValue_
)

Parameters

configItemName

newValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifySession Class
ClarifySession Members
Overload List


ChangeUserConfigItem(String,String) Method | fcSDK Documentation

ChangeUserConfigItem(String,String) Method

Syntax

'Declaration

Public Overloads Sub ChangeUserConfigItem( _
   ByVal _configItemName_ As String, _
   ByVal _newValue_ As String _
)

public void ChangeUserConfigItem(
   string _configItemName_,
   string _newValue_
)

Parameters

configItemName

newValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifySession Class
ClarifySession Members
Overload List


GetNextNumScheme Method (ClarifySession) | fcSDK Documentation

GetNextNumScheme Method (ClarifySession)

Overload List

Overload | Description
GetNextNumScheme(String) |
GetNextNumScheme(String,IDbTransaction) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifySession Class
ClarifySession Members


GetNextNumScheme(String) Method | fcSDK Documentation

GetNextNumScheme(String) Method

Syntax

'Declaration

Public Overloads Function GetNextNumScheme( _
   ByVal _schemeName_ As String _
) As String

public string GetNextNumScheme(
   string _schemeName_
)

Parameters

schemeName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifySession Class
ClarifySession Members
Overload List


GetNextNumScheme(String,IDbTransaction) Method | fcSDK Documentation

GetNextNumScheme(String,IDbTransaction) Method

Syntax

'Declaration

Public Overloads Function GetNextNumScheme( _
   ByVal _schemeName_ As String, _
   ByVal _trans_ As IDbTransaction _
) As String

public string GetNextNumScheme(
   string _schemeName_,
   IDbTransaction _trans_
)

Parameters

schemeName

trans

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifySession Class
ClarifySession Members
Overload List


SetContactUserPassword Method | fcSDK Documentation

SetContactUserPassword Method

Syntax

'Declaration

Public Shared Sub SetContactUserPassword( _
   ByVal _username_ As String, _
   ByVal _newPassword_ As String _
)

public static void SetContactUserPassword(
   string _username_,
   string _newPassword_
)

Parameters

username

newPassword

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifySession Class
ClarifySession Members


ConfigItems Property (ClarifySession) | fcSDK Documentation

ConfigItems Property (ClarifySession)

Syntax

'Declaration

Public Shadows ReadOnly Property ConfigItems As ClarifyConfigItemCollection

public new ClarifyConfigItemCollection ConfigItems {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifySession Class
ClarifySession Members


LoginType Property (ClarifySession) | fcSDK Documentation

LoginType Property (ClarifySession)

Gets the login type used when the session user was logged in

Syntax

'Declaration

Public Shadows ReadOnly Property LoginType As ClarifyLoginType

public new ClarifyLoginType LoginType {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifySession Class
ClarifySession Members


ClarifySessionData Class | fcSDK Documentation

ClarifySessionData Class

Syntax

'Declaration

<SerializableAttribute()>
Public Class ClarifySessionData
   Inherits FChoice.Foundation.FCSessionData

[SerializableAttribute()]
public class ClarifySessionData : FChoice.Foundation.FCSessionData

Inheritance Hierarchy

System.Object
FChoice.Foundation.FCSessionData
FChoice.Foundation.Clarify.ClarifySessionData

Requirements

Namespace: FChoice.Foundation.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ClarifySessionData Members
FChoice.Foundation.Clarify Namespace


ClarifySessionData Class Members | fcSDK Documentation

ClarifySessionData Class Members

The following tables list the members exposed by ClarifySessionData.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | ConfigItems | Collection of CRM session configuration items. (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | ConvertTimeZone | Session option: Gets whether or not any DateTimes will be translated to and from ServerTimeZone and LocalTimeZone. Default value is false. (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | CreationTime | Timestamp when the session was created. (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | CurrentCulture | The Culture being used by the session. (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | CurResGroup | The restriction group being used by the session. (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | DefaultDistinctGenerics | Session option which makes Generics have IsDistinct enable by default. (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | DisableDataConversion | Session option which disables data conversions when values are set for GenericDataRow fields. (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | DisableRestrictions | Returns whether or not the DataRestrictions feature is enabled or disabled. (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | EmptyNullStrings | Session option that cues Generics to make Null fields be empty strings. Specifically for Oracle. (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | IncludeRelations | Session option that cues Generics to include all relation data fields during Queries (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | IsDirty | (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | LastLoadTime | Timestamp when the session was last loaded via GetSession (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | LocalTimeZone | The TimeZone being used by the session. (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | LoginTime | (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | LoginType | User login type (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | MaximumRows | (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | NewSession | (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | PasswordRequired | Session option denoting whether a password was used to create a session. (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | Permissions | (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | PrivatePassword | | | Public Property | QueryEmptyToNull | Session option that cues Generics to convert filters on empty strings into filters on Queries that check Is NULL or IS NOT NULL. (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | SessionData | CRM configurable session data populates this property during CreateSession (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | SessionID | A session's unique identifier.

(Inherited from FChoice.Foundation.FCSessionData) | | Public Property | TruncateStringFields | Session option that cues Generics to truncate strings that exceed database field lengths when assigned to a GenericDataRow (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | UserID | UniqueID of the user that created the Session. (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | UserName | Name of the user that created the Session. (Inherited from FChoice.Foundation.FCSessionData) |

Public Methods

 | Name | Description
Public Method | CopyTo | Overridden.

Reference

ClarifySessionData Class
FChoice.Foundation.Clarify Namespace


CopyTo Method (ClarifySessionData) | fcSDK Documentation

CopyTo Method (ClarifySessionData)

Syntax

'Declaration

Public Overrides Sub CopyTo( _
   ByVal _newData_ As FCSessionData _
)

public override void CopyTo(
   FCSessionData _newData_
)

Parameters

newData

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifySessionData Class
ClarifySessionData Members
Base Implementation in CopyTo


PrivatePassword Property | fcSDK Documentation

PrivatePassword Property

Syntax

'Declaration

Public Property PrivatePassword As String

public string PrivatePassword {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifySessionData Class
ClarifySessionData Members


ConfigItemCache Class | fcSDK Documentation

ConfigItemCache Class

Caches global config items and provides access to the global ClarifyConfigItemCollection

Syntax

'Declaration

<DefaultMemberAttribute("Item")>
Public Class ConfigItemCache
   Inherits ClarifyCacheBase

[DefaultMemberAttribute("Item")]
public class ConfigItemCache : ClarifyCacheBase

Inheritance Hierarchy

System.Object
FChoice.Foundation.CacheBase
FChoice.Foundation.Clarify.ClarifyCacheBase
FChoice.Foundation.Clarify.ConfigItemCache

Requirements

Namespace: FChoice.Foundation.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ConfigItemCache Members
FChoice.Foundation.Clarify Namespace


ConfigItemCache Class Members | fcSDK Documentation

ConfigItemCache Class Members

The following tables list the members exposed by ConfigItemCache.

Public Properties

 | Name | Description
Public Property | CacheSetName | Overridden.
Public Property | CacheType | Overridden.
Public Property | ConfigItems | Gets the collection of global config items
Public Property | Item |

Public Methods

 | Name | Description
Public Method | UpdateCache | (Inherited from FChoice.Foundation.CacheBase)

Public Events

 | Name | Description
Public Event | CacheUpdated | (Inherited from FChoice.Foundation.CacheBase)

Reference

ConfigItemCache Class
FChoice.Foundation.Clarify Namespace


CacheSetName Property (ConfigItemCache) | fcSDK Documentation

CacheSetName Property (ConfigItemCache)

Syntax

'Declaration

Public Overrides ReadOnly Property CacheSetName As String

public override string CacheSetName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigItemCache Class
ConfigItemCache Members
Base Implementation in CacheSetName


CacheType Property (ConfigItemCache) | fcSDK Documentation

CacheType Property (ConfigItemCache)

Syntax

'Declaration

Public Overrides ReadOnly Property CacheType As CacheType

public override CacheType CacheType {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigItemCache Class
ConfigItemCache Members
Base Implementation in CacheType


ConfigItems Property (ConfigItemCache) | fcSDK Documentation

ConfigItems Property (ConfigItemCache)

Gets the collection of global config items

Syntax

'Declaration

Public ReadOnly Property ConfigItems As ClarifyConfigItemCollection

public ClarifyConfigItemCollection ConfigItems {get;}

Property Value

A ClarifyConfigItemCollection of ClarifyConfigItem objects which represent config items in the database

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigItemCache Class
ConfigItemCache Members


Item Property (ConfigItemCache) | fcSDK Documentation

Item Property (ConfigItemCache)

Syntax

'Declaration

Public ReadOnly Default Property Item( _
   ByVal _key_ As String _
) As ClarifyConfigItem

public ClarifyConfigItem this[
   string _key_
]; {get;}

Parameters

key

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigItemCache Class
ConfigItemCache Members


ConfigurationHelper Class | fcSDK Documentation

ConfigurationHelper Class

Syntax

'Declaration

Public MustInherit NotInheritable Class ConfigurationHelper

public static class ConfigurationHelper

Inheritance Hierarchy

System.Object
FChoice.Foundation.Clarify.ConfigurationHelper

Requirements

Namespace: FChoice.Foundation.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ConfigurationHelper Members
FChoice.Foundation.Clarify Namespace


ConfigurationHelper Class Members | fcSDK Documentation

ConfigurationHelper Class Members

The following tables list the members exposed by ConfigurationHelper.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | IsClarifyClassicClientLineReturnCompatible |
static (Shared in Visual Basic) | IsOracleAscii7bit |
static (Shared in Visual Basic) | RemoveDateTimeMilliseconds |

Reference

ConfigurationHelper Class
FChoice.Foundation.Clarify Namespace


IsClarifyClassicClientLineReturnCompatible Field | fcSDK Documentation

IsClarifyClassicClientLineReturnCompatible Field

Syntax

'Declaration

Public Shared ReadOnly IsClarifyClassicClientLineReturnCompatible As Boolean

public static readonly bool IsClarifyClassicClientLineReturnCompatible

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigurationHelper Class
ConfigurationHelper Members


IsOracleAscii7bit Field | fcSDK Documentation

IsOracleAscii7bit Field

Syntax

'Declaration

Public Shared ReadOnly IsOracleAscii7bit As Boolean

public static readonly bool IsOracleAscii7bit

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigurationHelper Class
ConfigurationHelper Members


RemoveDateTimeMilliseconds Field | fcSDK Documentation

RemoveDateTimeMilliseconds Field

Syntax

'Declaration

Public Shared ReadOnly RemoveDateTimeMilliseconds As Boolean

public static readonly bool RemoveDateTimeMilliseconds

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigurationHelper Class
ConfigurationHelper Members


DatabaseParameterFactory Class | fcSDK Documentation

DatabaseParameterFactory Class

Syntax

'Declaration

Public Class DatabaseParameterFactory

public class DatabaseParameterFactory

Inheritance Hierarchy

System.Object
FChoice.Foundation.Clarify.DatabaseParameterFactory

Requirements

Namespace: FChoice.Foundation.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

DatabaseParameterFactory Members
FChoice.Foundation.Clarify Namespace


DatabaseParameterFactory Class Members | fcSDK Documentation

DatabaseParameterFactory Class Members

The following tables list the members exposed by DatabaseParameterFactory.

Public Constructors

 | Name | Description
Public Constructor | DatabaseParameterFactory Constructor | Overloaded.

Public Fields

 | Name | Description
Public Field | EnableSettingStringParameterTypeAndSize |

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ConfigureStringDatabaseParameter |
Public Method | Create | Overloaded.
Public Method | ShouldStringParameterTypeAndSizeBeSet |

Reference

DatabaseParameterFactory Class
FChoice.Foundation.Clarify Namespace


DatabaseParameterFactory Constructor | fcSDK Documentation

DatabaseParameterFactory Constructor

Overload List

Overload | Description
DatabaseParameterFactory Constructor(DbProvider) |
DatabaseParameterFactory Constructor(ISchemaCache,DbProvider) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DatabaseParameterFactory Class
DatabaseParameterFactory Members


DatabaseParameterFactory Constructor(DbProvider) | fcSDK Documentation

DatabaseParameterFactory Constructor(DbProvider)

Syntax

'Declaration

Public Function New( _
   ByVal _dbProvider_ As DbProvider _
)

public DatabaseParameterFactory(
   DbProvider _dbProvider_
)

Parameters

dbProvider

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DatabaseParameterFactory Class
DatabaseParameterFactory Members
Overload List


DatabaseParameterFactory Constructor(ISchemaCache,DbProvider) | fcSDK Documentation

DatabaseParameterFactory Constructor(ISchemaCache,DbProvider)

Syntax

'Declaration

Public Function New( _
   ByVal _schemaCache_ As ISchemaCache, _
   ByVal _dbProvider_ As DbProvider _
)```

```csharp
public DatabaseParameterFactory(
   ISchemaCache _schemaCache_,
   DbProvider _dbProvider_
)

Parameters

schemaCache

dbProvider

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DatabaseParameterFactory Class
DatabaseParameterFactory Members
Overload List


ConfigureStringDatabaseParameter Method | fcSDK Documentation

ConfigureStringDatabaseParameter Method

Syntax

'Declaration

Public Shared Sub ConfigureStringDatabaseParameter( _
   ByVal _databaseParameter_ As IDbDataParameter, _
   ByVal _schemaCache_ As ISchemaCache, _
   ByVal _dbProvider_ As DbProvider, _
   ByVal _schemaField_ As ISchemaField _
)

public static void ConfigureStringDatabaseParameter(
   IDbDataParameter _databaseParameter_,
   ISchemaCache _schemaCache_,
   DbProvider _dbProvider_,
   ISchemaField _schemaField_
)

Parameters

databaseParameter

schemaCache

dbProvider

schemaField

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DatabaseParameterFactory Class
DatabaseParameterFactory Members


Create Method (DatabaseParameterFactory) | fcSDK Documentation

Create Method (DatabaseParameterFactory)

Overload List

Overload | Description
Create(String,ISchemaField,Object) |
Create(String,String,String,Object) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DatabaseParameterFactory Class
DatabaseParameterFactory Members


Create(String,ISchemaField,Object) Method | fcSDK Documentation

Create(String,ISchemaField,Object) Method

Syntax

'Declaration

Public Overloads Function Create( _
   ByVal _paramName_ As String, _
   ByVal _schemaField_ As ISchemaField, _
   ByVal _paramValue_ As Object _
) As IDbDataParameter

public IDbDataParameter Create(
   string _paramName_,
   ISchemaField _schemaField_,
   object _paramValue_
)

Parameters

paramName

schemaField

paramValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DatabaseParameterFactory Class
DatabaseParameterFactory Members
Overload List


Create(String,String,String,Object) Method | fcSDK Documentation

Create(String,String,String,Object) Method

Syntax

'Declaration

Public Overloads Function Create( _
   ByVal _paramName_ As String, _
   ByVal _tableName_ As String, _
   ByVal _fieldName_ As String, _
   ByVal _paramValue_ As Object _
) As IDbDataParameter

public IDbDataParameter Create(
   string _paramName_,
   string _tableName_,
   string _fieldName_,
   object _paramValue_
)

Parameters

paramName

tableName

fieldName

paramValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DatabaseParameterFactory Class
DatabaseParameterFactory Members
Overload List


ShouldStringParameterTypeAndSizeBeSet Method | fcSDK Documentation

ShouldStringParameterTypeAndSizeBeSet Method

Syntax

'Declaration

Public Overridable Function ShouldStringParameterTypeAndSizeBeSet() As Boolean

public virtual bool ShouldStringParameterTypeAndSizeBeSet()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DatabaseParameterFactory Class
DatabaseParameterFactory Members


EnableSettingStringParameterTypeAndSize Field | fcSDK Documentation

EnableSettingStringParameterTypeAndSize Field

Syntax

'Declaration

Public Const EnableSettingStringParameterTypeAndSize As String

public const string EnableSettingStringParameterTypeAndSize

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DatabaseParameterFactory Class
DatabaseParameterFactory Members


ListCache Class | fcSDK Documentation

ListCache Class

Caches and provides convenient access methods for GBST and HGBST list structures

Syntax

'Declaration

Public Class ListCache
   Inherits ClarifyCacheBase
   Implements IListCache

public class ListCache : ClarifyCacheBase, IListCache

Inheritance Hierarchy

System.Object
FChoice.Foundation.CacheBase
FChoice.Foundation.Clarify.ClarifyCacheBase
FChoice.Foundation.Clarify.ListCache

Requirements

Namespace: FChoice.Foundation.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ListCache Members
FChoice.Foundation.Clarify Namespace


ListCache Class Members | fcSDK Documentation

ListCache Class Members

The following tables list the members exposed by ListCache.

Public Properties

 | Name | Description
Public Property | CacheSetName | Overridden.
Public Property | CacheType | Overridden.
Public Property | GlobalStrings | Gets a reference to the GlobalStringListCollection cache of all application pop-up lists in the database
Public Property | HierarchicalStrings | Gets a reference to the HierarchicalStringListCollection cache of all user-defined lists in the database

Public Methods

 | Name | Description
Public Method | GetGbstDefault | Gets the default string value for a given application pop-up list.
Public Method | GetGbstDefaultObjID | Gets the objid of the default element for a given application pop-up list.
Public Method | GetGbstElmByID | Gets the value of an element with the specified objid in the specified application pop-up list
Public Method | GetGbstElmObjID | Gets the objid of the specified element in the specified application pop-up list
Public Method | GetGbstElmRankObjID | Gets the objid of the specified element by rank in the specified application pop-up list
Public Method | GetGbstList | Gets a reference to a GlobalStringList object representing an application pop-up list in the database
Public Method | GetGbstListElements |
Public Method | GetHgbstElmDefault | Gets the title of the default element for the given level in a user-defined list (HGBST).
Public Method | GetHgbstElmDefaultElement | Overloaded. Gets a reference to an HierarchicalStringElement object which represents an element at the specified level in the specified list
Public Method | GetHgbstElmDefaultObjID | Overloaded. Gets the objid of the default element for the given level in a user-defined list (HGBST).
Public Method | GetHgbstElmObjID | Overloaded. Gets the objid of an element at a specific level in a user-defined list (HGBST)
Public Method | GetHgbstList | Overloaded. Gets a reference to a HierarchicalStringElementCollection collection of list elements at the specified level in the given user-defined list
Public Method | IsInGbstList | Gets whether or not the specified element value exists in a given application pop-up list
Public Method | IsInHgbstList | Overloaded. Gets whether or not an element with the specified title exists in a given application pop-up list
Public Method | RankIsInGbstList | Gets whether or not an element with the specified rank exists in an application pop-up list
Public Method | TryGetHgbstList | Overloaded.
Public Method | UpdateCache | (Inherited from FChoice.Foundation.CacheBase)

Public Events

 | Name | Description
Public Event | CacheUpdated | (Inherited from FChoice.Foundation.CacheBase)

Reference

ListCache Class
FChoice.Foundation.Clarify Namespace


GetGbstDefault Method (ListCache) | fcSDK Documentation

GetGbstDefault Method (ListCache)

The name of the GBST/Application Pop-up list

Gets the default string value for a given application pop-up list.

Syntax

'Declaration

Public Function GetGbstDefault( _
   ByVal _listTitle_ As String _
) As String

public string GetGbstDefault(
   string _listTitle_
)

Parameters

listTitle

The name of the GBST/Application Pop-up list

Return Value

The default value for this GBST/Application Pop-up list

Remarks

If the no list exists with the specified listTitle, an exception will be thrown.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ListCache Class
ListCache Members


GetGbstDefaultObjID Method (ListCache) | fcSDK Documentation

GetGbstDefaultObjID Method (ListCache)

The name of the GBST/application pop-up list

Gets the objid of the default element for a given application pop-up list.

Syntax

'Declaration

Public Function GetGbstDefaultObjID( _
   ByVal _listTitle_ As String _
) As Integer

public int GetGbstDefaultObjID(
   string _listTitle_
)

Parameters

listTitle

The name of the GBST/application pop-up list

Return Value

The objid of the default element for this list

Remarks

If the no list exists with the specified listTitle, an exception will be thrown.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ListCache Class
ListCache Members


GetGbstElmByID Method (ListCache) | fcSDK Documentation

GetGbstElmByID Method (ListCache)

The name of the GBST/application pop-up list

The objid of the element to retrieve

Gets the value of an element with the specified objid in the specified application pop-up list

Syntax

'Declaration

Public Function GetGbstElmByID( _
   ByVal _listTitle_ As String, _
   ByVal _elmObjID_ As Integer _
) As String

public string GetGbstElmByID(
   string _listTitle_,
   int _elmObjID_
)

Parameters

listTitle

The name of the GBST/application pop-up list

elmObjID

The objid of the element to retrieve

Return Value

The value of the specified element

Remarks

If the no list exists with the specified listTitle, an exception will be thrown.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ListCache Class
ListCache Members


GetGbstElmObjID Method (ListCache) | fcSDK Documentation

GetGbstElmObjID Method (ListCache)

The name of the GBST/application pop-up list

The title of the element whose objid to retrieve

Gets the objid of the specified element in the specified application pop-up list

Syntax

'Declaration

Public Function GetGbstElmObjID( _
   ByVal _listTitle_ As String, _
   ByVal _elementTitle_ As String _
) As Integer

public int GetGbstElmObjID(
   string _listTitle_,
   string _elementTitle_
)

Parameters

listTitle

The name of the GBST/application pop-up list

elementTitle

The title of the element whose objid to retrieve

Return Value

The objid of the specified element

Remarks

If the no list exists with the specified listTitle, an exception will be thrown.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ListCache Class
ListCache Members


GetGbstElmRankObjID Method (ListCache) | fcSDK Documentation

GetGbstElmRankObjID Method (ListCache)

The name of the GBST/application pop-up list

The rank of the element whose objid to retrieve

Gets the objid of the specified element by rank in the specified application pop-up list

Syntax

'Declaration

Public Function GetGbstElmRankObjID( _
   ByVal _listTitle_ As String, _
   ByVal _elementRank_ As Integer _
) As Integer

public int GetGbstElmRankObjID(
   string _listTitle_,
   int _elementRank_
)

Parameters

listTitle

The name of the GBST/application pop-up list

elementRank

The rank of the element whose objid to retrieve

Return Value

The objid of the specified element

Remarks

If the no list exists with the specified listTitle, an exception will be thrown.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ListCache Class
ListCache Members


GetGbstList Method (ListCache) | fcSDK Documentation

GetGbstList Method (ListCache)

The name of the GBST/application pop-up list

Gets a reference to a GlobalStringList object representing an application pop-up list in the database

Syntax

'Declaration

Public Function GetGbstList( _
   ByVal _listTitle_ As String _
) As IGlobalStringList

public IGlobalStringList GetGbstList(
   string _listTitle_
)

Parameters

listTitle

The name of the GBST/application pop-up list

Return Value

A GlobalStringList representing the specified application pop-up list or a null reference (Nothing in Visual Basic) if no list exists with that listTitle.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ListCache Class
ListCache Members


GetGbstListElements Method (ListCache) | fcSDK Documentation

GetGbstListElements Method (ListCache)

Syntax

'Declaration

Public Function GetGbstListElements( _
   ByVal _listTitle_ As String, _
   ByVal _includeInactive_ As Boolean _
) As IGlobalStringElementCollection

public IGlobalStringElementCollection GetGbstListElements(
   string _listTitle_,
   bool _includeInactive_
)

Parameters

listTitle

includeInactive

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ListCache Class
ListCache Members


GetHgbstElmDefault Method (ListCache) | fcSDK Documentation

GetHgbstElmDefault Method (ListCache)

The title of the user-defined list (HGBST)

One or more element titles which define the level in the list to retrieve

Gets the title of the default element for the given level in a user-defined list (HGBST).

Syntax

'Declaration

Public Function GetHgbstElmDefault( _
   ByVal _listTitle_ As String, _
   ByVal ParamArray _elementTitles_() As String _
) As String

public string GetHgbstElmDefault(
   string _listTitle_,
   params string[] _elementTitles_
)

Parameters

listTitle

The title of the user-defined list (HGBST)

elementTitles

One or more element titles which define the level in the list to retrieve

Return Value

The title of the default element for the given level in the specified user-defined list

Remarks

If the specified listTitle or any of the elements specified elementTitles does not exist, an exception will be thrown.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ListCache Class
ListCache Members


GetHgbstElmDefaultElement Method (ListCache) | fcSDK Documentation

GetHgbstElmDefaultElement Method (ListCache)

Gets a reference to an HierarchicalStringElement object which represents an element at the specified level in the specified list

Overload List

Overload | Description
GetHgbstElmDefaultElement(String,String[]) |
GetHgbstElmDefaultElement(String,Boolean,String[]) |

Remarks

If the specified listTitle or any of the elements specified elementTitles does not exist, an exception will be thrown.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ListCache Class
ListCache Members


GetHgbstElmDefaultElement(String,String[]) Method | fcSDK Documentation

GetHgbstElmDefaultElement(String,String[]) Method

The title of the user-defined list (HGBST)

One or more element titles which define the level in the list to retrieve

Syntax

'Declaration

Public Overloads Function GetHgbstElmDefaultElement( _
   ByVal _listTitle_ As String, _
   ByVal ParamArray _elementTitles_() As String _
) As IHierarchicalStringElement

public IHierarchicalStringElement GetHgbstElmDefaultElement(
   string _listTitle_,
   params string[] _elementTitles_
)

Parameters

listTitle

The title of the user-defined list (HGBST)

elementTitles

One or more element titles which define the level in the list to retrieve

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ListCache Class
ListCache Members
Overload List


GetHgbstElmDefaultElement(String,Boolean,String[]) Method | fcSDK Documentation

GetHgbstElmDefaultElement(String,Boolean,String[]) Method

The title of the user-defined list (HGBST)

One or more element titles which define the level in the list to retrieve

Syntax

'Declaration

Public Overloads Function GetHgbstElmDefaultElement( _
   ByVal _listTitle_ As String, _
   ByVal _throwErrors_ As Boolean, _
   ByVal ParamArray _elementTitles_() As String _
) As IHierarchicalStringElement

public IHierarchicalStringElement GetHgbstElmDefaultElement(
   string _listTitle_,
   bool _throwErrors_,
   params string[] _elementTitles_
)

Parameters

listTitle

The title of the user-defined list (HGBST)

throwErrors

elementTitles

One or more element titles which define the level in the list to retrieve

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ListCache Class
ListCache Members
Overload List


GetHgbstElmDefaultObjID Method (ListCache) | fcSDK Documentation

GetHgbstElmDefaultObjID Method (ListCache)

Gets the objid of the default element for the given level in a user-defined list (HGBST).

Overload List

Overload | Description
GetHgbstElmDefaultObjID(String,String[]) |
GetHgbstElmDefaultObjID(String,Boolean,String[]) |

Remarks

If the specified listTitle or any of the elements specified elementTitles does not exist, an exception will be thrown.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ListCache Class
ListCache Members


GetHgbstElmDefaultObjID(String,String[]) Method | fcSDK Documentation

GetHgbstElmDefaultObjID(String,String[]) Method

The title of the user-defined list (HGBST)

One or more element titles which define the level in the list to retrieve

Syntax

'Declaration

Public Overloads Function GetHgbstElmDefaultObjID( _
   ByVal _listTitle_ As String, _
   ByVal ParamArray _elementTitles_() As String _
) As Integer

public int GetHgbstElmDefaultObjID(
   string _listTitle_,
   params string[] _elementTitles_
)

Parameters

listTitle

The title of the user-defined list (HGBST)

elementTitles

One or more element titles which define the level in the list to retrieve

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ListCache Class
ListCache Members
Overload List


GetHgbstElmDefaultObjID(String,Boolean,String[]) Method | fcSDK Documentation

GetHgbstElmDefaultObjID(String,Boolean,String[]) Method

The title of the user-defined list (HGBST)

One or more element titles which define the level in the list to retrieve

Syntax

'Declaration

Public Overloads Function GetHgbstElmDefaultObjID( _
   ByVal _listTitle_ As String, _
   ByVal _throwErrors_ As Boolean, _
   ByVal ParamArray _elementTitles_() As String _
) As Integer

public int GetHgbstElmDefaultObjID(
   string _listTitle_,
   bool _throwErrors_,
   params string[] _elementTitles_
)

Parameters

listTitle

The title of the user-defined list (HGBST)

throwErrors

elementTitles

One or more element titles which define the level in the list to retrieve

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ListCache Class
ListCache Members
Overload List


GetHgbstElmObjID Method (ListCache) | fcSDK Documentation

GetHgbstElmObjID Method (ListCache)

Gets the objid of an element at a specific level in a user-defined list (HGBST)

Overload List

Overload | Description
GetHgbstElmObjID(String,String,String[]) |
GetHgbstElmObjID(String,String,Boolean,String[]) |

Remarks

If the specified listTitle or any of the elements specified elementTitles or elementTitle does not exist, an exception will be thrown.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ListCache Class
ListCache Members


GetHgbstElmObjID(String,String,String[]) Method | fcSDK Documentation

GetHgbstElmObjID(String,String,String[]) Method

The title of the user-defined list (HGBST)

The title of the element whose objid to get

One or more element titles which define the level in the list to retrieve

Syntax

'Declaration

Public Overloads Function GetHgbstElmObjID( _
   ByVal _listTitle_ As String, _
   ByVal _elementTitle_ As String, _
   ByVal ParamArray _elementTitles_() As String _
) As Integer

public int GetHgbstElmObjID(
   string _listTitle_,
   string _elementTitle_,
   params string[] _elementTitles_
)

Parameters

listTitle

The title of the user-defined list (HGBST)

elementTitle

The title of the element whose objid to get

elementTitles

One or more element titles which define the level in the list to retrieve

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ListCache Class
ListCache Members
Overload List


GetHgbstElmObjID(String,String,Boolean,String[]) Method | fcSDK Documentation

GetHgbstElmObjID(String,String,Boolean,String[]) Method

The title of the user-defined list (HGBST)

The title of the element whose objid to get

One or more element titles which define the level in the list to retrieve

Syntax

'Declaration

Public Overloads Function GetHgbstElmObjID( _
   ByVal _listTitle_ As String, _
   ByVal _elementTitle_ As String, _
   ByVal _throwErrors_ As Boolean, _
   ByVal ParamArray _elementTitles_() As String _
) As Integer

public int GetHgbstElmObjID(
   string _listTitle_,
   string _elementTitle_,
   bool _throwErrors_,
   params string[] _elementTitles_
)

Parameters

listTitle

The title of the user-defined list (HGBST)

elementTitle

The title of the element whose objid to get

throwErrors

elementTitles

One or more element titles which define the level in the list to retrieve

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ListCache Class
ListCache Members
Overload List


GetHgbstList Method (ListCache) | fcSDK Documentation

GetHgbstList Method (ListCache)

Gets a reference to a HierarchicalStringElementCollection collection of list elements at the specified level in the given user-defined list

Overload List

Overload | Description
GetHgbstList(String,String[]) |
GetHgbstList(String,Boolean,String[]) |
GetHgbstList(String,Boolean,Boolean,String[]) |

Remarks

If the specified listTitle or any of the elements specified elementTitles does not exist, an exception will be thrown.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ListCache Class
ListCache Members


GetHgbstList(String,String[]) Method | fcSDK Documentation

GetHgbstList(String,String[]) Method

The title of the user-defined list (HGBST)

An optional list of element titles specifying the level in the user-defined list to retrieve

Syntax

'Declaration

Public Overloads Function GetHgbstList( _
   ByVal _listTitle_ As String, _
   ByVal ParamArray _elementTitles_() As String _
) As IHierarchicalStringElementCollection

public IHierarchicalStringElementCollection GetHgbstList(
   string _listTitle_,
   params string[] _elementTitles_
)

Parameters

listTitle

The title of the user-defined list (HGBST)

elementTitles

An optional list of element titles specifying the level in the user-defined list to retrieve

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ListCache Class
ListCache Members
Overload List


GetHgbstList(String,Boolean,String[]) Method | fcSDK Documentation

GetHgbstList(String,Boolean,String[]) Method

The title of the user-defined list (HGBST)

An optional list of element titles specifying the level in the user-defined list to retrieve

Syntax

'Declaration

Public Overloads Function GetHgbstList( _
   ByVal _listTitle_ As String, _
   ByVal _includeInactive_ As Boolean, _
   ByVal ParamArray _elementTitles_() As String _
) As IHierarchicalStringElementCollection

public IHierarchicalStringElementCollection GetHgbstList(
   string _listTitle_,
   bool _includeInactive_,
   params string[] _elementTitles_
)

Parameters

listTitle

The title of the user-defined list (HGBST)

includeInactive

elementTitles

An optional list of element titles specifying the level in the user-defined list to retrieve

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ListCache Class
ListCache Members
Overload List


GetHgbstList(String,Boolean,Boolean,String[]) Method | fcSDK Documentation

GetHgbstList(String,Boolean,Boolean,String[]) Method

Syntax

'Declaration

Public Overloads Function GetHgbstList( _
   ByVal _listTitle_ As String, _
   ByVal _includeInactive_ As Boolean, _
   ByVal _throwErrors_ As Boolean, _
   ByVal ParamArray _elementTitles_() As String _
) As IHierarchicalStringElementCollection

public IHierarchicalStringElementCollection GetHgbstList(
   string _listTitle_,
   bool _includeInactive_,
   bool _throwErrors_,
   params string[] _elementTitles_
)

Parameters

listTitle

includeInactive

throwErrors

elementTitles

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ListCache Class
ListCache Members
Overload List


IsInGbstList Method (ListCache) | fcSDK Documentation

IsInGbstList Method (ListCache)

The name of the GBST/application pop-up list

The value of the element to verify

Gets whether or not the specified element value exists in a given application pop-up list

Syntax

'Declaration

Public Function IsInGbstList( _
   ByVal _listTitle_ As String, _
   ByVal _element_ As String _
) As Boolean

public bool IsInGbstList(
   string _listTitle_,
   string _element_
)

Parameters

listTitle

The name of the GBST/application pop-up list

element

The value of the element to verify

Return Value

Whether not the specified element value exists in this application pop-up list

Remarks

If no list is found with the title of listTitle, or the value does not exist in this list, false is returned. Otherwise, true is returned.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ListCache Class
ListCache Members


IsInHgbstList Method (ListCache) | fcSDK Documentation

IsInHgbstList Method (ListCache)

Gets whether or not an element with the specified title exists in a given application pop-up list

Overload List

Overload | Description
IsInHgbstList(String,String,String[]) |
IsInHgbstList(String,String,Boolean,String[]) |

Remarks

If no list with the specified listTitle exists or any of the levels specified by elementTitles do not exist , an exception will be thrown. Otherwise, true or false is returned depending on whether the specified elementTitle exists in the list at the specified level.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ListCache Class
ListCache Members


IsInHgbstList(String,String,String[]) Method | fcSDK Documentation

IsInHgbstList(String,String,String[]) Method

The title of the user-defined list (HGBST)

The title of the element to verify

An optional list of element titles that defines what level in the user-defined list to search

Syntax

'Declaration

Public Overloads Function IsInHgbstList( _
   ByVal _listTitle_ As String, _
   ByVal _elementTitle_ As String, _
   ByVal ParamArray _elementTitles_() As String _
) As Boolean

public bool IsInHgbstList(
   string _listTitle_,
   string _elementTitle_,
   params string[] _elementTitles_
)

Parameters

listTitle

The title of the user-defined list (HGBST)

elementTitle

The title of the element to verify

elementTitles

An optional list of element titles that defines what level in the user-defined list to search

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ListCache Class
ListCache Members
Overload List


IsInHgbstList(String,String,Boolean,String[]) Method | fcSDK Documentation

IsInHgbstList(String,String,Boolean,String[]) Method

The title of the user-defined list (HGBST)

The title of the element to verify

An optional list of element titles that defines what level in the user-defined list to search

Syntax

'Declaration

Public Overloads Function IsInHgbstList( _
   ByVal _listTitle_ As String, _
   ByVal _elementTitle_ As String, _
   ByVal _throwErrors_ As Boolean, _
   ByVal ParamArray _elementTitles_() As String _
) As Boolean

public bool IsInHgbstList(
   string _listTitle_,
   string _elementTitle_,
   bool _throwErrors_,
   params string[] _elementTitles_
)

Parameters

listTitle

The title of the user-defined list (HGBST)

elementTitle

The title of the element to verify

throwErrors

elementTitles

An optional list of element titles that defines what level in the user-defined list to search

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ListCache Class
ListCache Members
Overload List


RankIsInGbstList Method (ListCache) | fcSDK Documentation

RankIsInGbstList Method (ListCache)

The name of the GBST/application pop-up list

The rank of the element to verify

Gets whether or not an element with the specified rank exists in an application pop-up list

Syntax

'Declaration

Public Function RankIsInGbstList( _
   ByVal _listTitle_ As String, _
   ByVal _rank_ As Integer _
) As Boolean

public bool RankIsInGbstList(
   string _listTitle_,
   int _rank_
)

Parameters

listTitle

The name of the GBST/application pop-up list

rank

The rank of the element to verify

Return Value

Whether or not an element with the specified rank exists in an application pop-up list

Remarks

If no list with title listTitle exists, false is returned. Otherwise, true or false is returned depending on whether an element with the specified rank exists in the specified list.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ListCache Class
ListCache Members


TryGetHgbstList Method (ListCache) | fcSDK Documentation

TryGetHgbstList Method (ListCache)

Overload List

Overload | Description
TryGetHgbstList(String,Boolean,String[]) |
TryGetHgbstList(String,Boolean,Boolean,String[]) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ListCache Class
ListCache Members


TryGetHgbstList(String,Boolean,String[]) Method | fcSDK Documentation

TryGetHgbstList(String,Boolean,String[]) Method

Syntax

'Declaration

Public Overloads Function TryGetHgbstList( _
   ByVal _listTitle_ As String, _
   ByVal _throwErrors_ As Boolean, _
   ByVal ParamArray _elementTitles_() As String _
) As IHierarchicalStringElementCollection

public IHierarchicalStringElementCollection TryGetHgbstList(
   string _listTitle_,
   bool _throwErrors_,
   params string[] _elementTitles_
)

Parameters

listTitle

throwErrors

elementTitles

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ListCache Class
ListCache Members
Overload List


TryGetHgbstList(String,Boolean,Boolean,String[]) Method | fcSDK Documentation

TryGetHgbstList(String,Boolean,Boolean,String[]) Method

Syntax

'Declaration

Public Overloads Function TryGetHgbstList( _
   ByVal _listTitle_ As String, _
   ByVal _throwErrors_ As Boolean, _
   ByVal _includeInactive_ As Boolean, _
   ByVal ParamArray _elementTitles_() As String _
) As IHierarchicalStringElementCollection

public IHierarchicalStringElementCollection TryGetHgbstList(
   string _listTitle_,
   bool _throwErrors_,
   bool _includeInactive_,
   params string[] _elementTitles_
)

Parameters

listTitle

throwErrors

includeInactive

elementTitles

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ListCache Class
ListCache Members
Overload List


CacheSetName Property (ListCache) | fcSDK Documentation

CacheSetName Property (ListCache)

Syntax

'Declaration

Public Overrides ReadOnly Property CacheSetName As String

public override string CacheSetName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ListCache Class
ListCache Members
Base Implementation in CacheSetName


CacheType Property (ListCache) | fcSDK Documentation

CacheType Property (ListCache)

Syntax

'Declaration

Public Overrides ReadOnly Property CacheType As CacheType

public override CacheType CacheType {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ListCache Class
ListCache Members
Base Implementation in CacheType


GlobalStrings Property (ListCache) | fcSDK Documentation

GlobalStrings Property (ListCache)

Gets a reference to the GlobalStringListCollection cache of all application pop-up lists in the database

Syntax

'Declaration

Public ReadOnly Property GlobalStrings As IGlobalStringListCollection

public IGlobalStringListCollection GlobalStrings {get;}

Property Value

A reference to the GlobalStringListCollection cache of all application pop-up lists in the database

Remarks

The GetGgbst* methods provide an easy-to-use API for accessing user-defined lists. It is recommend that these be used instead of directly accessing the master GBST collection itself.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ListCache Class
ListCache Members


HierarchicalStrings Property (ListCache) | fcSDK Documentation

HierarchicalStrings Property (ListCache)

Gets a reference to the HierarchicalStringListCollection cache of all user-defined lists in the database

Syntax

'Declaration

Public ReadOnly Property HierarchicalStrings As IHierarchicalStringListCollection

public IHierarchicalStringListCollection HierarchicalStrings {get;}

Property Value

A reference to the HierarchicalStringListCollection cache of all user-defined lists in the database

Remarks

The GetHgbst* methods provide an easy-to-use API for accessing user-defined lists. It is recommend that these be used instead of directly accessing the master HGBST collection itself.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ListCache Class
ListCache Members


LocaleCache Class | fcSDK Documentation

LocaleCache Class

Caches and provides convenient access to country, state, and time zone information

Syntax

'Declaration

Public Class LocaleCache
   Inherits ClarifyCacheBase
   Implements ILocaleCache

public class LocaleCache : ClarifyCacheBase, ILocaleCache

Inheritance Hierarchy

System.Object
FChoice.Foundation.CacheBase
FChoice.Foundation.Clarify.ClarifyCacheBase
FChoice.Foundation.Clarify.LocaleCache

Requirements

Namespace: FChoice.Foundation.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

LocaleCache Members
FChoice.Foundation.Clarify Namespace


LocaleCache Class Members | fcSDK Documentation

LocaleCache Class Members

The following tables list the members exposed by LocaleCache.

Public Properties

 | Name | Description
Public Property | CacheSetName | Overridden.
Public Property | CacheType | Overridden.
Public Property | Countries |
Public Property | DefaultTimeZone |
Public Property | ServerTimeZone |
Public Property | TimeZones |

Public Methods

 | Name | Description
Public Method | GetCountryObjID |
Public Method | GetDefaultCountry |
Public Method | GetDefaultCountryObjID |
Public Method | GetDefaultState | Overloaded.
Public Method | GetDefaultStateObjID |
Public Method | GetDefaultTimeZone |
Public Method | GetDefaultTimeZoneObjID |
Public Method | GetFullStateObjID |
Public Method | GetServerTimeZoneOffset |
Public Method | GetShortTimeZoneObjID |
Public Method | GetStateObjID |
Public Method | GetStates | Overloaded.
Public Method | GetTimeZoneObjID |
Public Method | GetTimeZoneOffset |
Public Method | GetTimeZonesInCountry |
Public Method | IsCountry |
Public Method | IsFullState |
Public Method | IsOnDST |
Public Method | IsState | Overloaded.
Public Method | IsTimeZone |
Public Method | IsTimeZoneInCountry | Overloaded.
Public Method | SetServerTimeZoneToMachineTimeZone |
Public Method | UpdateCache | (Inherited from FChoice.Foundation.CacheBase)

Public Events

 | Name | Description
Public Event | CacheUpdated | (Inherited from FChoice.Foundation.CacheBase)

Reference

LocaleCache Class
FChoice.Foundation.Clarify Namespace


GetCountryObjID Method (LocaleCache) | fcSDK Documentation

GetCountryObjID Method (LocaleCache)

Syntax

'Declaration

Public Function GetCountryObjID( _
   ByVal _countryName_ As String _
) As Integer

public int GetCountryObjID(
   string _countryName_
)

Parameters

countryName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocaleCache Class
LocaleCache Members


GetDefaultCountry Method (LocaleCache) | fcSDK Documentation

GetDefaultCountry Method (LocaleCache)

Syntax

'Declaration

Public Function GetDefaultCountry() As Country

public Country GetDefaultCountry()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocaleCache Class
LocaleCache Members


GetDefaultCountryObjID Method (LocaleCache) | fcSDK Documentation

GetDefaultCountryObjID Method (LocaleCache)

Syntax

'Declaration

Public Function GetDefaultCountryObjID() As Integer

public int GetDefaultCountryObjID()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocaleCache Class
LocaleCache Members


GetDefaultState Method (LocaleCache) | fcSDK Documentation

GetDefaultState Method (LocaleCache)

Overload List

Overload | Description
GetDefaultState() |
GetDefaultState(String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocaleCache Class
LocaleCache Members


GetDefaultState() Method | fcSDK Documentation

GetDefaultState() Method

Syntax

'Declaration

Public Overloads Function GetDefaultState() As StateProvince

public StateProvince GetDefaultState()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocaleCache Class
LocaleCache Members
Overload List


GetDefaultState(String) Method | fcSDK Documentation

GetDefaultState(String) Method

Syntax

'Declaration

Public Overloads Function GetDefaultState( _
   ByVal _countryName_ As String _
) As StateProvince

public StateProvince GetDefaultState(
   string _countryName_
)

Parameters

countryName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocaleCache Class
LocaleCache Members
Overload List


GetDefaultStateObjID Method (LocaleCache) | fcSDK Documentation

GetDefaultStateObjID Method (LocaleCache)

Syntax

'Declaration

Public Function GetDefaultStateObjID( _
   ByVal _countryName_ As String _
) As Integer

public int GetDefaultStateObjID(
   string _countryName_
)

Parameters

countryName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocaleCache Class
LocaleCache Members


GetDefaultTimeZone Method (LocaleCache) | fcSDK Documentation

GetDefaultTimeZone Method (LocaleCache)

Syntax

'Declaration

Public Function GetDefaultTimeZone() As ITimeZone

public ITimeZone GetDefaultTimeZone()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocaleCache Class
LocaleCache Members


GetDefaultTimeZoneObjID Method (LocaleCache) | fcSDK Documentation

GetDefaultTimeZoneObjID Method (LocaleCache)

Syntax

'Declaration

Public Function GetDefaultTimeZoneObjID() As Integer

public int GetDefaultTimeZoneObjID()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocaleCache Class
LocaleCache Members


GetFullStateObjID Method (LocaleCache) | fcSDK Documentation

GetFullStateObjID Method (LocaleCache)

Syntax

'Declaration

Public Function GetFullStateObjID( _
   ByVal _countryName_ As String, _
   ByVal _fullStateName_ As String _
) As Integer

public int GetFullStateObjID(
   string _countryName_,
   string _fullStateName_
)

Parameters

countryName

fullStateName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocaleCache Class
LocaleCache Members


GetServerTimeZoneOffset Method (LocaleCache) | fcSDK Documentation

GetServerTimeZoneOffset Method (LocaleCache)

Syntax

'Declaration

Public Function GetServerTimeZoneOffset() As Integer

public int GetServerTimeZoneOffset()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocaleCache Class
LocaleCache Members


GetShortTimeZoneObjID Method (LocaleCache) | fcSDK Documentation

GetShortTimeZoneObjID Method (LocaleCache)

Syntax

'Declaration

Public Function GetShortTimeZoneObjID( _
   ByVal _shortName_ As String _
) As Integer

public int GetShortTimeZoneObjID(
   string _shortName_
)

Parameters

shortName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocaleCache Class
LocaleCache Members


GetStateObjID Method (LocaleCache) | fcSDK Documentation

GetStateObjID Method (LocaleCache)

Syntax

'Declaration

Public Function GetStateObjID( _
   ByVal _countryName_ As String, _
   ByVal _stateName_ As String _
) As Integer

public int GetStateObjID(
   string _countryName_,
   string _stateName_
)

Parameters

countryName

stateName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocaleCache Class
LocaleCache Members


GetStates Method (LocaleCache) | fcSDK Documentation

GetStates Method (LocaleCache)

Overload List

Overload | Description
GetStates() |
GetStates(String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocaleCache Class
LocaleCache Members


GetStates() Method | fcSDK Documentation

GetStates() Method

Syntax

'Declaration

Public Overloads Function GetStates() As StateCollection

public StateCollection GetStates()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocaleCache Class
LocaleCache Members
Overload List


GetStates(String) Method | fcSDK Documentation

GetStates(String) Method

Syntax

'Declaration

Public Overloads Function GetStates( _
   ByVal _countryName_ As String _
) As StateCollection

public StateCollection GetStates(
   string _countryName_
)

Parameters

countryName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocaleCache Class
LocaleCache Members
Overload List


GetTimeZoneObjID Method (LocaleCache) | fcSDK Documentation

GetTimeZoneObjID Method (LocaleCache)

Syntax

'Declaration

Public Function GetTimeZoneObjID( _
   ByVal _fullTimeZoneName_ As String _
) As Integer

public int GetTimeZoneObjID(
   string _fullTimeZoneName_
)

Parameters

fullTimeZoneName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocaleCache Class
LocaleCache Members


GetTimeZoneOffset Method (LocaleCache) | fcSDK Documentation

GetTimeZoneOffset Method (LocaleCache)

Syntax

'Declaration

Public Function GetTimeZoneOffset( _
   ByVal _fullTimeZoneName_ As String _
) As Integer

public int GetTimeZoneOffset(
   string _fullTimeZoneName_
)

Parameters

fullTimeZoneName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocaleCache Class
LocaleCache Members


GetTimeZonesInCountry Method (LocaleCache) | fcSDK Documentation

GetTimeZonesInCountry Method (LocaleCache)

Syntax

'Declaration

Public Function GetTimeZonesInCountry( _
   ByVal _countryName_ As String _
) As FCTimeZoneCollection

public FCTimeZoneCollection GetTimeZonesInCountry(
   string _countryName_
)

Parameters

countryName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocaleCache Class
LocaleCache Members


IsCountry Method (LocaleCache) | fcSDK Documentation

IsCountry Method (LocaleCache)

Syntax

'Declaration

Public Function IsCountry( _
   ByVal _countryName_ As String _
) As Boolean

public bool IsCountry(
   string _countryName_
)

Parameters

countryName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocaleCache Class
LocaleCache Members


IsFullState Method (LocaleCache) | fcSDK Documentation

IsFullState Method (LocaleCache)

Syntax

'Declaration

Public Function IsFullState( _
   ByVal _countryName_ As String, _
   ByVal _stateName_ As String _
) As Boolean

public bool IsFullState(
   string _countryName_,
   string _stateName_
)

Parameters

countryName

stateName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocaleCache Class
LocaleCache Members


IsOnDST Method (LocaleCache) | fcSDK Documentation

IsOnDST Method (LocaleCache)

Syntax

'Declaration

Public Function IsOnDST( _
   ByVal _fullTimeZoneName_ As String, _
   ByVal _checkDate_ As Date _
) As Boolean

public bool IsOnDST(
   string _fullTimeZoneName_,
   DateTime _checkDate_
)

Parameters

fullTimeZoneName

checkDate

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocaleCache Class
LocaleCache Members


IsState Method (LocaleCache) | fcSDK Documentation

IsState Method (LocaleCache)

Overload List

Overload | Description
IsState(String,String) |
IsState(String,String,Boolean) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocaleCache Class
LocaleCache Members


IsState(String,String) Method | fcSDK Documentation

IsState(String,String) Method

Syntax

'Declaration

Public Overloads Function IsState( _
   ByVal _countryName_ As String, _
   ByVal _stateName_ As String _
) As Boolean

public bool IsState(
   string _countryName_,
   string _stateName_
)

Parameters

countryName

stateName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocaleCache Class
LocaleCache Members
Overload List


IsState(String,String,Boolean) Method | fcSDK Documentation

IsState(String,String,Boolean) Method

Syntax

'Declaration

Public Overloads Function IsState( _
   ByVal _countryName_ As String, _
   ByVal _stateName_ As String, _
   ByVal _isFullStateName_ As Boolean _
) As Boolean

public bool IsState(
   string _countryName_,
   string _stateName_,
   bool _isFullStateName_
)

Parameters

countryName

stateName

isFullStateName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocaleCache Class
LocaleCache Members
Overload List


IsTimeZone Method (LocaleCache) | fcSDK Documentation

IsTimeZone Method (LocaleCache)

Syntax

'Declaration

Public Function IsTimeZone( _
   ByVal _tzName_ As String _
) As Boolean

public bool IsTimeZone(
   string _tzName_
)

Parameters

tzName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocaleCache Class
LocaleCache Members


IsTimeZoneInCountry Method (LocaleCache) | fcSDK Documentation

IsTimeZoneInCountry Method (LocaleCache)

Overload List

Overload | Description
IsTimeZoneInCountry(String,String) |
IsTimeZoneInCountry(String,String,Boolean) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocaleCache Class
LocaleCache Members


IsTimeZoneInCountry(String,String) Method | fcSDK Documentation

IsTimeZoneInCountry(String,String) Method

Syntax

'Declaration

Public Overloads Function IsTimeZoneInCountry( _
   ByVal _countryName_ As String, _
   ByVal _tzName_ As String _
) As Boolean

public bool IsTimeZoneInCountry(
   string _countryName_,
   string _tzName_
)

Parameters

countryName

tzName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocaleCache Class
LocaleCache Members
Overload List


IsTimeZoneInCountry(String,String,Boolean) Method | fcSDK Documentation

IsTimeZoneInCountry(String,String,Boolean) Method

Syntax

'Declaration

Public Overloads Function IsTimeZoneInCountry( _
   ByVal _countryName_ As String, _
   ByVal _tzName_ As String, _
   ByVal _isFullTzName_ As Boolean _
) As Boolean

public bool IsTimeZoneInCountry(
   string _countryName_,
   string _tzName_,
   bool _isFullTzName_
)

Parameters

countryName

tzName

isFullTzName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocaleCache Class
LocaleCache Members
Overload List


SetServerTimeZoneToMachineTimeZone Method (LocaleCache) | fcSDK Documentation

SetServerTimeZoneToMachineTimeZone Method (LocaleCache)

Syntax

'Declaration

Public Sub SetServerTimeZoneToMachineTimeZone()

public void SetServerTimeZoneToMachineTimeZone()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocaleCache Class
LocaleCache Members


CacheSetName Property (LocaleCache) | fcSDK Documentation

CacheSetName Property (LocaleCache)

Syntax

'Declaration

Public Overrides ReadOnly Property CacheSetName As String

public override string CacheSetName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocaleCache Class
LocaleCache Members
Base Implementation in CacheSetName


CacheType Property (LocaleCache) | fcSDK Documentation

CacheType Property (LocaleCache)

Syntax

'Declaration

Public Overrides ReadOnly Property CacheType As CacheType

public override CacheType CacheType {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocaleCache Class
LocaleCache Members
Base Implementation in CacheType


Countries Property (LocaleCache) | fcSDK Documentation

Countries Property (LocaleCache)

Syntax

'Declaration

Public ReadOnly Property Countries As CountryCollection

public CountryCollection Countries {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocaleCache Class
LocaleCache Members


DefaultTimeZone Property (LocaleCache) | fcSDK Documentation

DefaultTimeZone Property (LocaleCache)

Syntax

'Declaration

Public ReadOnly Property DefaultTimeZone As ITimeZone

public ITimeZone DefaultTimeZone {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocaleCache Class
LocaleCache Members


ServerTimeZone Property (LocaleCache) | fcSDK Documentation

ServerTimeZone Property (LocaleCache)

Syntax

'Declaration

Public ReadOnly Property ServerTimeZone As ITimeZone

public ITimeZone ServerTimeZone {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocaleCache Class
LocaleCache Members


TimeZones Property (LocaleCache) | fcSDK Documentation

TimeZones Property (LocaleCache)

Syntax

'Declaration

Public ReadOnly Property TimeZones As FCTimeZoneCollection

public FCTimeZoneCollection TimeZones {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocaleCache Class
LocaleCache Members


SchemaCache Class | fcSDK Documentation

SchemaCache Class

Caches and provides convenient access to ADP Schema information

Syntax

'Declaration

Public Class SchemaCache
   Inherits ClarifyCacheBase
   Implements FChoice.Foundation.Schema.ISchemaCache

public class SchemaCache : ClarifyCacheBase, FChoice.Foundation.Schema.ISchemaCache

Inheritance Hierarchy

System.Object
FChoice.Foundation.CacheBase
FChoice.Foundation.Clarify.ClarifyCacheBase
FChoice.Foundation.Clarify.SchemaCache

Requirements

Namespace: FChoice.Foundation.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

SchemaCache Members
FChoice.Foundation.Clarify Namespace


SchemaCache Class Members | fcSDK Documentation

SchemaCache Class Members

The following tables list the members exposed by SchemaCache.

Public Constructors

 | Name | Description
Public Constructor | SchemaCache Constructor |

Public Fields

 | Name | Description
Public Field | Amdocs65 |
Public Field | Amdocs75 |
Public Field | CLARIFY_10 |
Public Field | CLARIFY_11 |
Public Field | CLARIFY_115 |
Public Field | CLARIFY_12 |
Public Field | CLARIFY_125 |
Public Field | CLARIFY_13 |
Public Field | CLARIFY_4 |
Public Field | CLARIFY_45 |
Public Field | CLARIFY_5 |
Public Field | CLARIFY_6 |
Public Field | CLARIFY_6X |
Public Field | CLARIFY_7 |
Public Field | CLARIFY_8 |
Public Field | CLARIFY_9 |
Public Field | CLARIFY_CFO98 |

Public Properties

 | Name | Description
Public Property | CacheSetName | Overridden.
Public Property | CacheType | Overridden.
Public Property | CustomSchemaDate |
Public Property | DatabaseName |
Public Property | DataRestrictionsEnabled |
Public Property | Flags |
Public Property | IsDatabaseUnicode |
Public Property | LastModifiedDate |
Public Property | RestrictionGroups |
Public Property | SchemaRevision |
Public Property | SiteID |
Public Property | Tables |
Public Property | VendorSchemaDate |
Public Property | Views |

Public Methods

 | Name | Description
Public Method | GetChangeDateField |
Public Method | GetDateFields |
Public Method | GetField |
Public Method | GetRelation |
Public Method | GetTableField |
Public Method | GetTableID |
Public Method | GetTableName |
Public Method | GetTableOrView |
Public Method | GetTableOrViewByID |
Public Method | GetTableOrViewID |
Public Method | GetTypeForSchemaType | Overloaded.
Public Method | GetViewField |
Public Method | GetViewID |
Public Method | IsChangeField |
Public Method | IsDateField |
Public Method | IsFieldSearchable |
Public Method | IsFieldUnicode |
Public Method | IsIntegerField |
Public Method | IsNumericField |
Public Method | IsRelationExclusive |
Public Method | IsRelationMandatory |
Public Method | IsStringField |
Public Method | IsStringOrDateField |
Public Method | IsValidField | Overloaded.
Public Method | IsValidRelation |
Public Method | IsValidTable |
Public Method | IsValidTableOrView | Overloaded.
Public Method | IsValidView |
Public Method | TryGetField |
Public Method | TryIsFieldSearchable |
Public Method | TryIsStringField |
Public Method | UpdateCache | Overridden.

Public Events

 | Name | Description
Public Event | CacheUpdated | (Inherited from FChoice.Foundation.CacheBase)
Public Event | SchemaLoadStatusChanged |

Reference

SchemaCache Class
FChoice.Foundation.Clarify Namespace


SchemaCache Constructor | fcSDK Documentation

SchemaCache Constructor

Syntax

'Declaration

Public Function New( _
   ByVal _isSolo_ As Boolean _
)

public SchemaCache(
   bool _isSolo_
)

Parameters

isSolo

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


GetChangeDateField Method (SchemaCache) | fcSDK Documentation

GetChangeDateField Method (SchemaCache)

Syntax

'Declaration

Public Function GetChangeDateField( _
   ByVal _tableName_ As String _
) As SchemaTableField

public SchemaTableField GetChangeDateField(
   string _tableName_
)

Parameters

tableName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


GetDateFields Method (SchemaCache) | fcSDK Documentation

GetDateFields Method (SchemaCache)

Syntax

'Declaration

Public Function GetDateFields( _
   ByVal _objectName_ As String _
) As SchemaFieldBase()

public SchemaFieldBase[] GetDateFields(
   string _objectName_
)

Parameters

objectName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


GetField Method (SchemaCache) | fcSDK Documentation

GetField Method (SchemaCache)

Syntax

'Declaration

Public Function GetField( _
   ByVal _objectName_ As String, _
   ByVal _fieldName_ As String _
) As SchemaFieldBase

public SchemaFieldBase GetField(
   string _objectName_,
   string _fieldName_
)

Parameters

objectName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


GetRelation Method (SchemaCache) | fcSDK Documentation

GetRelation Method (SchemaCache)

Syntax

'Declaration

Public Function GetRelation( _
   ByVal _tableName_ As String, _
   ByVal _relationName_ As String _
) As SchemaRelation

public SchemaRelation GetRelation(
   string _tableName_,
   string _relationName_
)

Parameters

tableName

relationName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


GetTableField Method | fcSDK Documentation

GetTableField Method

Syntax

'Declaration

Public Function GetTableField( _
   ByVal _tableName_ As String, _
   ByVal _fieldName_ As String _
) As SchemaTableField

public SchemaTableField GetTableField(
   string _tableName_,
   string _fieldName_
)

Parameters

tableName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


GetTableID Method (SchemaCache) | fcSDK Documentation

GetTableID Method (SchemaCache)

Syntax

'Declaration

Public Function GetTableID( _
   ByVal _tableName_ As String _
) As Integer

public int GetTableID(
   string _tableName_
)

Parameters

tableName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


GetTableName Method (SchemaCache) | fcSDK Documentation

GetTableName Method (SchemaCache)

Syntax

'Declaration

Public Function GetTableName( _
   ByVal _tableID_ As Integer _
) As String

public string GetTableName(
   int _tableID_
)

Parameters

tableID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


GetTableOrView Method | fcSDK Documentation

GetTableOrView Method

Syntax

'Declaration

Public Function GetTableOrView( _
   ByVal _tableName_ As String _
) As SchemaTableBase

public SchemaTableBase GetTableOrView(
   string _tableName_
)

Parameters

tableName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


GetTableOrViewByID Method | fcSDK Documentation

GetTableOrViewByID Method

Syntax

'Declaration

Public Function GetTableOrViewByID( _
   ByVal _typeID_ As Integer _
) As SchemaTableBase

public SchemaTableBase GetTableOrViewByID(
   int _typeID_
)

Parameters

typeID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


GetTableOrViewID Method | fcSDK Documentation

GetTableOrViewID Method

Syntax

'Declaration

Public Function GetTableOrViewID( _
   ByVal _objectName_ As String _
) As Integer

public int GetTableOrViewID(
   string _objectName_
)

Parameters

objectName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


GetTypeForSchemaType Method | fcSDK Documentation

GetTypeForSchemaType Method

Overload List

Overload | Description
GetTypeForSchemaType(SchemaFieldBase) |
GetTypeForSchemaType(SchemaFieldBase,DbProvider) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


GetTypeForSchemaType(SchemaFieldBase) Method | fcSDK Documentation

GetTypeForSchemaType(SchemaFieldBase) Method

Syntax

'Declaration

Public Overloads Function GetTypeForSchemaType( _
   ByVal _field_ As SchemaFieldBase _
) As Type

public Type GetTypeForSchemaType(
   SchemaFieldBase _field_
)

Parameters

field

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members
Overload List


GetTypeForSchemaType(SchemaFieldBase,DbProvider) Method | fcSDK Documentation

GetTypeForSchemaType(SchemaFieldBase,DbProvider) Method

Syntax

'Declaration

Public Overloads Function GetTypeForSchemaType( _
   ByVal _field_ As SchemaFieldBase, _
   ByVal _provider_ As DbProvider _
) As Type

public Type GetTypeForSchemaType(
   SchemaFieldBase _field_,
   DbProvider _provider_
)

Parameters

field

provider

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members
Overload List


GetViewField Method | fcSDK Documentation

GetViewField Method

Syntax

'Declaration

Public Function GetViewField( _
   ByVal _viewName_ As String, _
   ByVal _fieldName_ As String _
) As SchemaViewField

public SchemaViewField GetViewField(
   string _viewName_,
   string _fieldName_
)

Parameters

viewName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


GetViewID Method | fcSDK Documentation

GetViewID Method

Syntax

'Declaration

Public Function GetViewID( _
   ByVal _viewName_ As String _
) As Integer

public int GetViewID(
   string _viewName_
)

Parameters

viewName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


IsChangeField Method (SchemaCache) | fcSDK Documentation

IsChangeField Method (SchemaCache)

Syntax

'Declaration

Public Function IsChangeField( _
   ByVal _tableName_ As String, _
   ByVal _fieldName_ As String _
) As Boolean

public bool IsChangeField(
   string _tableName_,
   string _fieldName_
)

Parameters

tableName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


IsDateField Method (SchemaCache) | fcSDK Documentation

IsDateField Method (SchemaCache)

Syntax

'Declaration

Public Function IsDateField( _
   ByVal _tableName_ As String, _
   ByVal _fieldName_ As String _
) As Boolean

public bool IsDateField(
   string _tableName_,
   string _fieldName_
)

Parameters

tableName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


IsFieldSearchable Method (SchemaCache) | fcSDK Documentation

IsFieldSearchable Method (SchemaCache)

Syntax

'Declaration

Public Function IsFieldSearchable( _
   ByVal _tableName_ As String, _
   ByVal _fieldName_ As String _
) As Boolean

public bool IsFieldSearchable(
   string _tableName_,
   string _fieldName_
)

Parameters

tableName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


IsFieldUnicode Method (SchemaCache) | fcSDK Documentation

IsFieldUnicode Method (SchemaCache)

Syntax

'Declaration

Public Function IsFieldUnicode( _
   ByVal _tableName_ As String, _
   ByVal _fieldName_ As String _
) As Boolean

public bool IsFieldUnicode(
   string _tableName_,
   string _fieldName_
)

Parameters

tableName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


IsIntegerField Method (SchemaCache) | fcSDK Documentation

IsIntegerField Method (SchemaCache)

Syntax

'Declaration

Public Function IsIntegerField( _
   ByVal _tableName_ As String, _
   ByVal _fieldName_ As String _
) As Boolean

public bool IsIntegerField(
   string _tableName_,
   string _fieldName_
)

Parameters

tableName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


IsNumericField Method (SchemaCache) | fcSDK Documentation

IsNumericField Method (SchemaCache)

Syntax

'Declaration

Public Function IsNumericField( _
   ByVal _tableName_ As String, _
   ByVal _fieldName_ As String _
) As Boolean

public bool IsNumericField(
   string _tableName_,
   string _fieldName_
)

Parameters

tableName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


IsRelationExclusive Method (SchemaCache) | fcSDK Documentation

IsRelationExclusive Method (SchemaCache)

Syntax

'Declaration

Public Function IsRelationExclusive( _
   ByVal _tableName_ As String, _
   ByVal _relationName_ As String, _
   ByRef _objIDField_ As SchemaTableField, _
   ByRef _tableField_ As SchemaTableField _
) As Boolean

public bool IsRelationExclusive(
   string _tableName_,
   string _relationName_,
   out SchemaTableField _objIDField_,
   out SchemaTableField _tableField_
)

Parameters

tableName

relationName

objIDField

tableField

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


IsRelationMandatory Method | fcSDK Documentation

IsRelationMandatory Method

Syntax

'Declaration

Public Function IsRelationMandatory( _
   ByVal _tableName_ As String, _
   ByVal _relationName_ As String _
) As Boolean

public bool IsRelationMandatory(
   string _tableName_,
   string _relationName_
)

Parameters

tableName

relationName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


IsStringField Method (SchemaCache) | fcSDK Documentation

IsStringField Method (SchemaCache)

Syntax

'Declaration

Public Function IsStringField( _
   ByVal _tableName_ As String, _
   ByVal _fieldName_ As String _
) As Boolean

public bool IsStringField(
   string _tableName_,
   string _fieldName_
)

Parameters

tableName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


IsStringOrDateField Method (SchemaCache) | fcSDK Documentation

IsStringOrDateField Method (SchemaCache)

Syntax

'Declaration

Public Function IsStringOrDateField( _
   ByVal _tableName_ As String, _
   ByVal _fieldName_ As String _
) As Boolean

public bool IsStringOrDateField(
   string _tableName_,
   string _fieldName_
)

Parameters

tableName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


IsValidField Method (SchemaCache) | fcSDK Documentation

IsValidField Method (SchemaCache)

Overload List

Overload | Description
IsValidField(String,String) |
IsValidField(String,String,Boolean) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


IsValidField(String,String) Method | fcSDK Documentation

IsValidField(String,String) Method

Syntax

'Declaration

Public Overloads Function IsValidField( _
   ByVal _objectName_ As String, _
   ByVal _fieldName_ As String _
) As Boolean

public bool IsValidField(
   string _objectName_,
   string _fieldName_
)

Parameters

objectName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members
Overload List


IsValidField(String,String,Boolean) Method | fcSDK Documentation

IsValidField(String,String,Boolean) Method

Syntax

'Declaration

Public Overloads Function IsValidField( _
   ByVal _objectName_ As String, _
   ByVal _fieldName_ As String, _
   ByRef _isRelation_ As Boolean _
) As Boolean

public bool IsValidField(
   string _objectName_,
   string _fieldName_,
   out bool _isRelation_
)

Parameters

objectName

fieldName

isRelation

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members
Overload List


IsValidRelation Method (SchemaCache) | fcSDK Documentation

IsValidRelation Method (SchemaCache)

Syntax

'Declaration

Public Function IsValidRelation( _
   ByVal _tableName_ As String, _
   ByVal _relName_ As String _
) As Boolean

public bool IsValidRelation(
   string _tableName_,
   string _relName_
)

Parameters

tableName

relName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


IsValidTable Method (SchemaCache) | fcSDK Documentation

IsValidTable Method (SchemaCache)

Syntax

'Declaration

Public Function IsValidTable( _
   ByVal _tableName_ As String _
) As Boolean

public bool IsValidTable(
   string _tableName_
)

Parameters

tableName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


IsValidTableOrView Method (SchemaCache) | fcSDK Documentation

IsValidTableOrView Method (SchemaCache)

Overload List

Overload | Description
IsValidTableOrView(String) |
IsValidTableOrView(Int32) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


IsValidTableOrView(String) Method | fcSDK Documentation

IsValidTableOrView(String) Method

Syntax

'Declaration

Public Overloads Function IsValidTableOrView( _
   ByVal _objectName_ As String _
) As Boolean

public bool IsValidTableOrView(
   string _objectName_
)

Parameters

objectName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members
Overload List


IsValidTableOrView(Int32) Method | fcSDK Documentation

IsValidTableOrView(Int32) Method

Syntax

'Declaration

Public Overloads Function IsValidTableOrView( _
   ByVal _typeID_ As Integer _
) As Boolean

public bool IsValidTableOrView(
   int _typeID_
)

Parameters

typeID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members
Overload List


IsValidView Method (SchemaCache) | fcSDK Documentation

IsValidView Method (SchemaCache)

Syntax

'Declaration

Public Function IsValidView( _
   ByVal _viewName_ As String _
) As Boolean

public bool IsValidView(
   string _viewName_
)

Parameters

viewName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


TryGetField Method | fcSDK Documentation

TryGetField Method

Syntax

'Declaration

Public Function TryGetField( _
   ByVal _objectName_ As String, _
   ByVal _fieldName_ As String _
) As SchemaFieldBase

public SchemaFieldBase TryGetField(
   string _objectName_,
   string _fieldName_
)

Parameters

objectName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


TryIsFieldSearchable Method | fcSDK Documentation

TryIsFieldSearchable Method

Syntax

'Declaration

Public Function TryIsFieldSearchable( _
   ByVal _tableName_ As String, _
   ByVal _fieldName_ As String _
) As Boolean

public bool TryIsFieldSearchable(
   string _tableName_,
   string _fieldName_
)

Parameters

tableName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


TryIsStringField Method | fcSDK Documentation

TryIsStringField Method

Syntax

'Declaration

Public Function TryIsStringField( _
   ByVal _tableName_ As String, _
   ByVal _fieldName_ As String _
) As Boolean

public bool TryIsStringField(
   string _tableName_,
   string _fieldName_
)

Parameters

tableName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


UpdateCache Method (SchemaCache) | fcSDK Documentation

UpdateCache Method (SchemaCache)

Syntax

'Declaration

Public Overrides Sub UpdateCache()

public override void UpdateCache()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members
Base Implementation in UpdateCache


CacheSetName Property (SchemaCache) | fcSDK Documentation

CacheSetName Property (SchemaCache)

Syntax

'Declaration

Public Overrides ReadOnly Property CacheSetName As String

public override string CacheSetName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members
Base Implementation in CacheSetName


CacheType Property (SchemaCache) | fcSDK Documentation

CacheType Property (SchemaCache)

Syntax

'Declaration

Public Overrides ReadOnly Property CacheType As CacheType

public override CacheType CacheType {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members
Base Implementation in CacheType


CustomSchemaDate Property | fcSDK Documentation

CustomSchemaDate Property

Syntax

'Declaration

Public ReadOnly Property CustomSchemaDate As Date

public DateTime CustomSchemaDate {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


DatabaseName Property | fcSDK Documentation

DatabaseName Property

Syntax

'Declaration

Public ReadOnly Property DatabaseName As String

public string DatabaseName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


DataRestrictionsEnabled Property (SchemaCache) | fcSDK Documentation

DataRestrictionsEnabled Property (SchemaCache)

Syntax

'Declaration

Public ReadOnly Property DataRestrictionsEnabled As Boolean

public bool DataRestrictionsEnabled {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


Flags Property (SchemaCache) | fcSDK Documentation

Flags Property (SchemaCache)

Syntax

'Declaration

Public ReadOnly Property Flags As Integer

public int Flags {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


IsDatabaseUnicode Property (SchemaCache) | fcSDK Documentation

IsDatabaseUnicode Property (SchemaCache)

Syntax

'Declaration

Public ReadOnly Property IsDatabaseUnicode As Boolean

public bool IsDatabaseUnicode {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


LastModifiedDate Property (SchemaCache) | fcSDK Documentation

LastModifiedDate Property (SchemaCache)

Syntax

'Declaration

Public ReadOnly Property LastModifiedDate As Date

public DateTime LastModifiedDate {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


RestrictionGroups Property (SchemaCache) | fcSDK Documentation

RestrictionGroups Property (SchemaCache)

Syntax

'Declaration

Public ReadOnly Property RestrictionGroups As RestrictionGroupCollection

public RestrictionGroupCollection RestrictionGroups {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


SchemaRevision Property | fcSDK Documentation

SchemaRevision Property

Syntax

'Declaration

Public ReadOnly Property SchemaRevision As String

public string SchemaRevision {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


SiteID Property | fcSDK Documentation

SiteID Property

Syntax

'Declaration

Public ReadOnly Property SiteID As String

public string SiteID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


Tables Property (SchemaCache) | fcSDK Documentation

Tables Property (SchemaCache)

Syntax

'Declaration

Public ReadOnly Property Tables As SchemaTableCollection

public SchemaTableCollection Tables {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


VendorSchemaDate Property | fcSDK Documentation

VendorSchemaDate Property

Syntax

'Declaration

Public ReadOnly Property VendorSchemaDate As Date

public DateTime VendorSchemaDate {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


Views Property (SchemaCache) | fcSDK Documentation

Views Property (SchemaCache)

Syntax

'Declaration

Public ReadOnly Property Views As SchemaViewCollection

public SchemaViewCollection Views {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


Amdocs65 Field | fcSDK Documentation

Amdocs65 Field

Syntax

'Declaration

Public Const Amdocs65 As Integer

public const int Amdocs65

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


Amdocs75 Field | fcSDK Documentation

Amdocs75 Field

Syntax

'Declaration

Public Const Amdocs75 As Integer

public const int Amdocs75

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


CLARIFY_10 Field | fcSDK Documentation

CLARIFY_10 Field

Syntax

'Declaration

Public Const CLARIFY_10 As Integer

public const int CLARIFY_10

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


CLARIFY_11 Field | fcSDK Documentation

CLARIFY_11 Field

Syntax

'Declaration

Public Const CLARIFY_11 As Integer

public const int CLARIFY_11

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


CLARIFY_115 Field | fcSDK Documentation

CLARIFY_115 Field

Syntax

'Declaration

Public Const CLARIFY_115 As Integer

public const int CLARIFY_115

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


CLARIFY_12 Field | fcSDK Documentation

CLARIFY_12 Field

Syntax

'Declaration

Public Const CLARIFY_12 As Integer

public const int CLARIFY_12

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


CLARIFY_125 Field | fcSDK Documentation

CLARIFY_125 Field

Syntax

'Declaration

Public Const CLARIFY_125 As Integer

public const int CLARIFY_125

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


CLARIFY_13 Field | fcSDK Documentation

CLARIFY_13 Field

Syntax

'Declaration

Public Const CLARIFY_13 As Integer

public const int CLARIFY_13

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


CLARIFY_4 Field | fcSDK Documentation

CLARIFY_4 Field

Syntax

'Declaration

Public Const CLARIFY_4 As Integer

public const int CLARIFY_4

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


CLARIFY_45 Field | fcSDK Documentation

CLARIFY_45 Field

Syntax

'Declaration

Public Const CLARIFY_45 As Integer

public const int CLARIFY_45

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


CLARIFY_5 Field | fcSDK Documentation

CLARIFY_5 Field

Syntax

'Declaration

Public Const CLARIFY_5 As Integer

public const int CLARIFY_5

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


CLARIFY_6 Field | fcSDK Documentation

CLARIFY_6 Field

Syntax

'Declaration

Public Const CLARIFY_6 As Integer

public const int CLARIFY_6

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


CLARIFY_6X Field | fcSDK Documentation

CLARIFY_6X Field

Syntax

'Declaration

Public Const CLARIFY_6X As Integer

public const int CLARIFY_6X

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


CLARIFY_7 Field | fcSDK Documentation

CLARIFY_7 Field

Syntax

'Declaration

Public Const CLARIFY_7 As Integer

public const int CLARIFY_7

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


CLARIFY_8 Field | fcSDK Documentation

CLARIFY_8 Field

Syntax

'Declaration

Public Const CLARIFY_8 As Integer

public const int CLARIFY_8

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


CLARIFY_9 Field | fcSDK Documentation

CLARIFY_9 Field

Syntax

'Declaration

Public Const CLARIFY_9 As Integer

public const int CLARIFY_9

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


CLARIFY_CFO98 Field | fcSDK Documentation

CLARIFY_CFO98 Field

Syntax

'Declaration

Public Const CLARIFY_CFO98 As Integer

public const int CLARIFY_CFO98

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


SchemaLoadStatusChanged Event | fcSDK Documentation

SchemaLoadStatusChanged Event

Syntax

'Declaration

Public Event SchemaLoadStatusChanged As SchemaLoadStatusEventHandler

public event SchemaLoadStatusEventHandler SchemaLoadStatusChanged

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCache Class
SchemaCache Members


SchemaCacheHelper Class | fcSDK Documentation

SchemaCacheHelper Class

Syntax

'Declaration

Public MustInherit NotInheritable Class SchemaCacheHelper

public static class SchemaCacheHelper

Inheritance Hierarchy

System.Object
FChoice.Foundation.Clarify.SchemaCacheHelper

Requirements

Namespace: FChoice.Foundation.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

SchemaCacheHelper Members
FChoice.Foundation.Clarify Namespace


SchemaCacheHelper Class Members | fcSDK Documentation

SchemaCacheHelper Class Members

The following tables list the members exposed by SchemaCacheHelper.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | DoesColumnExist |
static (Shared in Visual Basic) | DoesMsSqlColumnExist |
static (Shared in Visual Basic) | DoesOracleColumnExist |

Reference

SchemaCacheHelper Class
FChoice.Foundation.Clarify Namespace


DoesColumnExist Method | fcSDK Documentation

DoesColumnExist Method

Syntax

'Declaration

Public Shared Function DoesColumnExist( _
   ByVal _tableName_ As String, _
   ByVal _columnName_ As String _
) As Boolean

public static bool DoesColumnExist(
   string _tableName_,
   string _columnName_
)

Parameters

tableName

columnName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCacheHelper Class
SchemaCacheHelper Members


DoesMsSqlColumnExist Method | fcSDK Documentation

DoesMsSqlColumnExist Method

Syntax

'Declaration

Public Shared Function DoesMsSqlColumnExist( _
   ByVal _tableName_ As String, _
   ByVal _columnName_ As String _
) As Boolean

public static bool DoesMsSqlColumnExist(
   string _tableName_,
   string _columnName_
)

Parameters

tableName

columnName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCacheHelper Class
SchemaCacheHelper Members


DoesOracleColumnExist Method | fcSDK Documentation

DoesOracleColumnExist Method

Syntax

'Declaration

Public Shared Function DoesOracleColumnExist( _
   ByVal _tableName_ As String, _
   ByVal _columnName_ As String _
) As Boolean

public static bool DoesOracleColumnExist(
   string _tableName_,
   string _columnName_
)

Parameters

tableName

columnName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaCacheHelper Class
SchemaCacheHelper Members


StringCache Class | fcSDK Documentation

StringCache Class

Caches and provides convenient access to string_db and fc_string values

Syntax

'Declaration

Public Class StringCache
   Inherits ClarifyCacheBase
   Implements IStringCache

public class StringCache : ClarifyCacheBase, IStringCache

Inheritance Hierarchy

System.Object
FChoice.Foundation.CacheBase
FChoice.Foundation.Clarify.ClarifyCacheBase
FChoice.Foundation.Clarify.StringCache

Requirements

Namespace: FChoice.Foundation.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

StringCache Members
FChoice.Foundation.Clarify Namespace


StringCache Class Members | fcSDK Documentation

StringCache Class Members

The following tables list the members exposed by StringCache.

Public Properties

 | Name | Description
Public Property | CacheSetName | Overridden.
Public Property | CacheType | Overridden.

Public Methods

 | Name | Description
Public Method | FindFCString | Overloaded.
Public Method | FindFCStringObject | Overloaded.
Public Method | FindString | Overloaded.
Public Method | SupportedLocales | Returns list of supported locales. Each fc_string has a locale, so all distinct locales are returned by this method.
Public Method | UpdateCache | (Inherited from FChoice.Foundation.CacheBase)

Public Events

 | Name | Description
Public Event | CacheUpdated | (Inherited from FChoice.Foundation.CacheBase)

Reference

StringCache Class
FChoice.Foundation.Clarify Namespace


FindFCString Method (StringCache) | fcSDK Documentation

FindFCString Method (StringCache)

Overload List

Overload | Description
FindFCString(Int32) |
FindFCString(String,String) |
FindFCString(Int32,CultureInfo) |
FindFCString(String,String,CultureInfo) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StringCache Class
StringCache Members


FindFCString(Int32) Method | fcSDK Documentation

FindFCString(Int32) Method

Syntax

'Declaration

Public Overloads Function FindFCString( _
   ByVal _stringID_ As Integer _
) As String

public string FindFCString(
   int _stringID_
)

Parameters

stringID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StringCache Class
StringCache Members
Overload List


FindFCString(String,String) Method | fcSDK Documentation

FindFCString(String,String) Method

Syntax

'Declaration

Public Overloads Function FindFCString( _
   ByVal _applicationName_ As String, _
   ByVal _stringName_ As String _
) As String

public string FindFCString(
   string _applicationName_,
   string _stringName_
)

Parameters

applicationName

stringName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StringCache Class
StringCache Members
Overload List


FindFCString(Int32,CultureInfo) Method | fcSDK Documentation

FindFCString(Int32,CultureInfo) Method

Syntax

'Declaration

Public Overloads Function FindFCString( _
   ByVal _stringID_ As Integer, _
   ByVal _culture_ As CultureInfo _
) As String

public string FindFCString(
   int _stringID_,
   CultureInfo _culture_
)

Parameters

stringID

culture

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StringCache Class
StringCache Members
Overload List


FindFCString(String,String,CultureInfo) Method | fcSDK Documentation

FindFCString(String,String,CultureInfo) Method

Syntax

'Declaration

Public Overloads Function FindFCString( _
   ByVal _applicationName_ As String, _
   ByVal _stringName_ As String, _
   ByVal _culture_ As CultureInfo _
) As String

public string FindFCString(
   string _applicationName_,
   string _stringName_,
   CultureInfo _culture_
)

Parameters

applicationName

stringName

culture

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StringCache Class
StringCache Members
Overload List


FindFCStringObject Method (StringCache) | fcSDK Documentation

FindFCStringObject Method (StringCache)

Overload List

Overload | Description
FindFCStringObject(Int32,CultureInfo) |
FindFCStringObject(String,String,CultureInfo) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StringCache Class
StringCache Members


FindFCStringObject(Int32,CultureInfo) Method | fcSDK Documentation

FindFCStringObject(Int32,CultureInfo) Method

Syntax

'Declaration

Public Overloads Function FindFCStringObject( _
   ByVal _stringID_ As Integer, _
   ByVal _culture_ As CultureInfo _
) As FCString

public FCString FindFCStringObject(
   int _stringID_,
   CultureInfo _culture_
)

Parameters

stringID

culture

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StringCache Class
StringCache Members
Overload List


FindFCStringObject(String,String,CultureInfo) Method | fcSDK Documentation

FindFCStringObject(String,String,CultureInfo) Method

Syntax

'Declaration

Public Overloads Function FindFCStringObject( _
   ByVal _applicationName_ As String, _
   ByVal _stringName_ As String, _
   ByVal _culture_ As CultureInfo _
) As FCString

public FCString FindFCStringObject(
   string _applicationName_,
   string _stringName_,
   CultureInfo _culture_
)

Parameters

applicationName

stringName

culture

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StringCache Class
StringCache Members
Overload List


FindString Method (StringCache) | fcSDK Documentation

FindString Method (StringCache)

Overload List

Overload | Description
FindString(Int32) |
FindString(Int32,String) |
FindString(Int32,Int32) |
FindString(Int32,CultureInfo) |
FindString(String) |
FindString(String,String) |
FindString(String,Int32) |
FindString(String,CultureInfo) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StringCache Class
StringCache Members


FindString(Int32) Method | fcSDK Documentation

FindString(Int32) Method

Syntax

'Declaration

Public Overloads Function FindString( _
   ByVal _stringID_ As Integer _
) As String

public string FindString(
   int _stringID_
)

Parameters

stringID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StringCache Class
StringCache Members
Overload List


FindString(Int32,String) Method | fcSDK Documentation

FindString(Int32,String) Method

Syntax

'Declaration

Public Overloads Function FindString( _
   ByVal _stringID_ As Integer, _
   ByVal _culture_ As String _
) As String

public string FindString(
   int _stringID_,
   string _culture_
)

Parameters

stringID

culture

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StringCache Class
StringCache Members
Overload List


FindString(Int32,Int32) Method | fcSDK Documentation

FindString(Int32,Int32) Method

Syntax

'Declaration

Public Overloads Function FindString( _
   ByVal _stringID_ As Integer, _
   ByVal _localeID_ As Integer _
) As String

public string FindString(
   int _stringID_,
   int _localeID_
)

Parameters

stringID

localeID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StringCache Class
StringCache Members
Overload List


FindString(Int32,CultureInfo) Method | fcSDK Documentation

FindString(Int32,CultureInfo) Method

Syntax

'Declaration

Public Overloads Function FindString( _
   ByVal _stringID_ As Integer, _
   ByVal _culture_ As CultureInfo _
) As String

public string FindString(
   int _stringID_,
   CultureInfo _culture_
)

Parameters

stringID

culture

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StringCache Class
StringCache Members
Overload List


FindString(String) Method | fcSDK Documentation

FindString(String) Method

Syntax

'Declaration

Public Overloads Function FindString( _
   ByVal _stringName_ As String _
) As String

public string FindString(
   string _stringName_
)

Parameters

stringName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StringCache Class
StringCache Members
Overload List


FindString(String,String) Method | fcSDK Documentation

FindString(String,String) Method

Syntax

'Declaration

Public Overloads Function FindString( _
   ByVal _stringName_ As String, _
   ByVal _culture_ As String _
) As String

public string FindString(
   string _stringName_,
   string _culture_
)

Parameters

stringName

culture

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StringCache Class
StringCache Members
Overload List


FindString(String,Int32) Method | fcSDK Documentation

FindString(String,Int32) Method

Syntax

'Declaration

Public Overloads Function FindString( _
   ByVal _stringName_ As String, _
   ByVal _localeID_ As Integer _
) As String

public string FindString(
   string _stringName_,
   int _localeID_
)

Parameters

stringName

localeID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StringCache Class
StringCache Members
Overload List


FindString(String,CultureInfo) Method | fcSDK Documentation

FindString(String,CultureInfo) Method

Syntax

'Declaration

Public Overloads Function FindString( _
   ByVal _stringName_ As String, _
   ByVal _culture_ As CultureInfo _
) As String

public string FindString(
   string _stringName_,
   CultureInfo _culture_
)

Parameters

stringName

culture

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StringCache Class
StringCache Members
Overload List


SupportedLocales Method (StringCache) | fcSDK Documentation

SupportedLocales Method (StringCache)

Returns list of supported locales. Each fc_string has a locale, so all distinct locales are returned by this method.

Syntax

'Declaration

Public Function SupportedLocales() As IEnumerable(Of CultureInfo)

public IEnumerable<CultureInfo> SupportedLocales()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StringCache Class
StringCache Members


CacheSetName Property (StringCache) | fcSDK Documentation

CacheSetName Property (StringCache)

Syntax

'Declaration

Public Overrides ReadOnly Property CacheSetName As String

public override string CacheSetName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StringCache Class
StringCache Members
Base Implementation in CacheSetName


CacheType Property (StringCache) | fcSDK Documentation

CacheType Property (StringCache)

Syntax

'Declaration

Public Overrides ReadOnly Property CacheType As CacheType

public override CacheType CacheType {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StringCache Class
StringCache Members
Base Implementation in CacheType


WorkflowObjectInfo Class | fcSDK Documentation

WorkflowObjectInfo Class

Syntax

'Declaration

Public Class WorkflowObjectInfo

public class WorkflowObjectInfo

Inheritance Hierarchy

System.Object
FChoice.Foundation.Clarify.WorkflowObjectInfo

Requirements

Namespace: FChoice.Foundation.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

WorkflowObjectInfo Members
FChoice.Foundation.Clarify Namespace


WorkflowObjectInfo Class Members | fcSDK Documentation

WorkflowObjectInfo Class Members

The following tables list the members exposed by WorkflowObjectInfo.

Public Constructors

 | Name | Description
Public Constructor | WorkflowObjectInfo Constructor |

Public Properties

 | Name | Description
Public Property | ActivityRelation |
Public Property | AttachmentRelation |
Public Property | ConditionRelation |
Public Property | DatabaseTable |
Public Property | HasIDFieldName |
Public Property | HistoryFieldName |
Public Property | IDFieldName |
Public Property | IsAllowedCheckFieldName |
Public Property | IsQueueableObject |
Public Property | ObjectName |
Public Property | OldRejectRelation |
Public Property | OldStatusRelation |
Public Property | OwnerRelation |
Public Property | ParentRelation |
Public Property | PreviousQueueRelation |
Public Property | QueueRelation |
Public Property | RejectRelation |
Public Property | StatusCode |
Public Property | StatusRelation |
Public Property | TimeStampFieldName |
Public Property | UseParticipantActEntryModel |
Public Property | WipBinRelation |

Public Methods

 | Name | Description
static (Shared in Visual Basic) | AddToCache | Overloaded.
static (Shared in Visual Basic) | CreateCustomQueueableObjectInfo |
static (Shared in Visual Basic) | GetObjectInfo |
static (Shared in Visual Basic) | GetQueueableObjectInfo | Overloaded.
static (Shared in Visual Basic) | ObjectTypeExists |

Reference

WorkflowObjectInfo Class
FChoice.Foundation.Clarify Namespace


WorkflowObjectInfo Constructor | fcSDK Documentation

WorkflowObjectInfo Constructor

Syntax

'Declaration

Public Function New( _
   ByVal _objectName_ As String _
)

public WorkflowObjectInfo(
   string _objectName_
)

Parameters

objectName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowObjectInfo Class
WorkflowObjectInfo Members


AddToCache Method | fcSDK Documentation

AddToCache Method

Overload List

Overload | Description
AddToCache(WorkflowObjectInfo) |
AddToCache(WorkflowObjectInfo,String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowObjectInfo Class
WorkflowObjectInfo Members


AddToCache(WorkflowObjectInfo) Method | fcSDK Documentation

AddToCache(WorkflowObjectInfo) Method

Syntax

'Declaration

Public Overloads Shared Sub AddToCache( _
   ByVal _info_ As WorkflowObjectInfo _
)

public static void AddToCache(
   WorkflowObjectInfo _info_
)

Parameters

info

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowObjectInfo Class
WorkflowObjectInfo Members
Overload List


AddToCache(WorkflowObjectInfo,String) Method | fcSDK Documentation

AddToCache(WorkflowObjectInfo,String) Method

Syntax

'Declaration

Public Overloads Shared Sub AddToCache( _
   ByVal _info_ As WorkflowObjectInfo, _
   ByVal _objectName_ As String _
)

public static void AddToCache(
   WorkflowObjectInfo _info_,
   string _objectName_
)

Parameters

info

objectName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowObjectInfo Class
WorkflowObjectInfo Members
Overload List


CreateCustomQueueableObjectInfo Method | fcSDK Documentation

CreateCustomQueueableObjectInfo Method

Syntax

'Declaration

Public Shared Function CreateCustomQueueableObjectInfo( _
   ByVal _objName_ As String, _
   ByVal _useCache_ As Boolean _
) As WorkflowObjectInfo

public static WorkflowObjectInfo CreateCustomQueueableObjectInfo(
   string _objName_,
   bool _useCache_
)

Parameters

objName

useCache

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowObjectInfo Class
WorkflowObjectInfo Members


GetObjectInfo Method | fcSDK Documentation

GetObjectInfo Method

Syntax

'Declaration

Public Shared Function GetObjectInfo( _
   ByVal _objectName_ As String _
) As WorkflowObjectInfo

public static WorkflowObjectInfo GetObjectInfo(
   string _objectName_
)

Parameters

objectName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowObjectInfo Class
WorkflowObjectInfo Members


GetQueueableObjectInfo Method | fcSDK Documentation

GetQueueableObjectInfo Method

Overload List

Overload | Description
GetQueueableObjectInfo(String) |
GetQueueableObjectInfo(String,Boolean) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowObjectInfo Class
WorkflowObjectInfo Members


GetQueueableObjectInfo(String) Method | fcSDK Documentation

GetQueueableObjectInfo(String) Method

Syntax

'Declaration

Public Overloads Shared Function GetQueueableObjectInfo( _
   ByVal _objectName_ As String _
) As WorkflowObjectInfo```

```csharp
public static WorkflowObjectInfo GetQueueableObjectInfo(
   string _objectName_
)

Parameters

objectName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowObjectInfo Class
WorkflowObjectInfo Members
Overload List


GetQueueableObjectInfo(String,Boolean) Method | fcSDK Documentation

GetQueueableObjectInfo(String,Boolean) Method

Syntax

'Declaration

Public Overloads Shared Function GetQueueableObjectInfo( _
   ByVal _objectName_ As String, _
   ByVal _createCustomIfNotFound_ As Boolean _
) As WorkflowObjectInfo```

```csharp
public static WorkflowObjectInfo GetQueueableObjectInfo(
   string _objectName_,
   bool _createCustomIfNotFound_
)

Parameters

objectName

createCustomIfNotFound

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowObjectInfo Class
WorkflowObjectInfo Members
Overload List


ObjectTypeExists Method | fcSDK Documentation

ObjectTypeExists Method

Syntax

'Declaration

Public Shared Function ObjectTypeExists( _
   ByVal _objectName_ As String _
) As Boolean

public static bool ObjectTypeExists(
   string _objectName_
)

Parameters

objectName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowObjectInfo Class
WorkflowObjectInfo Members


ActivityRelation Property (WorkflowObjectInfo) | fcSDK Documentation

ActivityRelation Property (WorkflowObjectInfo)

Syntax

'Declaration

Public Property ActivityRelation As String

public string ActivityRelation {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowObjectInfo Class
WorkflowObjectInfo Members


AttachmentRelation Property | fcSDK Documentation

AttachmentRelation Property

Syntax

'Declaration

Public Property AttachmentRelation As String

public string AttachmentRelation {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowObjectInfo Class
WorkflowObjectInfo Members


ConditionRelation Property (WorkflowObjectInfo) | fcSDK Documentation

ConditionRelation Property (WorkflowObjectInfo)

Syntax

'Declaration

Public Property ConditionRelation As String

public string ConditionRelation {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowObjectInfo Class
WorkflowObjectInfo Members


DatabaseTable Property (WorkflowObjectInfo) | fcSDK Documentation

DatabaseTable Property (WorkflowObjectInfo)

Syntax

'Declaration

Public Property DatabaseTable As String

public string DatabaseTable {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowObjectInfo Class
WorkflowObjectInfo Members


HasIDFieldName Property | fcSDK Documentation

HasIDFieldName Property

Syntax

'Declaration

Public ReadOnly Property HasIDFieldName As Boolean

public bool HasIDFieldName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowObjectInfo Class
WorkflowObjectInfo Members


HistoryFieldName Property (WorkflowObjectInfo) | fcSDK Documentation

HistoryFieldName Property (WorkflowObjectInfo)

Syntax

'Declaration

Public Property HistoryFieldName As String

public string HistoryFieldName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowObjectInfo Class
WorkflowObjectInfo Members


IDFieldName Property (WorkflowObjectInfo) | fcSDK Documentation

IDFieldName Property (WorkflowObjectInfo)

Syntax

'Declaration

Public Property IDFieldName As String

public string IDFieldName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowObjectInfo Class
WorkflowObjectInfo Members


IsAllowedCheckFieldName Property (WorkflowObjectInfo) | fcSDK Documentation

IsAllowedCheckFieldName Property (WorkflowObjectInfo)

Syntax

'Declaration

Public Property IsAllowedCheckFieldName As String

public string IsAllowedCheckFieldName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowObjectInfo Class
WorkflowObjectInfo Members


IsQueueableObject Property | fcSDK Documentation

IsQueueableObject Property

Syntax

'Declaration

Public Property IsQueueableObject As Boolean

public bool IsQueueableObject {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowObjectInfo Class
WorkflowObjectInfo Members


ObjectName Property (WorkflowObjectInfo) | fcSDK Documentation

ObjectName Property (WorkflowObjectInfo)

Syntax

'Declaration

Public Property ObjectName As String

public string ObjectName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowObjectInfo Class
WorkflowObjectInfo Members


OldRejectRelation Property (WorkflowObjectInfo) | fcSDK Documentation

OldRejectRelation Property (WorkflowObjectInfo)

Syntax

'Declaration

Public Property OldRejectRelation As String

public string OldRejectRelation {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowObjectInfo Class
WorkflowObjectInfo Members


OldStatusRelation Property (WorkflowObjectInfo) | fcSDK Documentation

OldStatusRelation Property (WorkflowObjectInfo)

Syntax

'Declaration

Public Property OldStatusRelation As String

public string OldStatusRelation {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowObjectInfo Class
WorkflowObjectInfo Members


OwnerRelation Property (WorkflowObjectInfo) | fcSDK Documentation

OwnerRelation Property (WorkflowObjectInfo)

Syntax

'Declaration

Public Property OwnerRelation As String

public string OwnerRelation {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowObjectInfo Class
WorkflowObjectInfo Members


ParentRelation Property (WorkflowObjectInfo) | fcSDK Documentation

ParentRelation Property (WorkflowObjectInfo)

Syntax

'Declaration

Public Property ParentRelation As String

public string ParentRelation {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowObjectInfo Class
WorkflowObjectInfo Members


PreviousQueueRelation Property (WorkflowObjectInfo) | fcSDK Documentation

PreviousQueueRelation Property (WorkflowObjectInfo)

Syntax

'Declaration

Public Property PreviousQueueRelation As String

public string PreviousQueueRelation {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowObjectInfo Class
WorkflowObjectInfo Members


QueueRelation Property (WorkflowObjectInfo) | fcSDK Documentation

QueueRelation Property (WorkflowObjectInfo)

Syntax

'Declaration

Public Property QueueRelation As String

public string QueueRelation {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowObjectInfo Class
WorkflowObjectInfo Members


RejectRelation Property (WorkflowObjectInfo) | fcSDK Documentation

RejectRelation Property (WorkflowObjectInfo)

Syntax

'Declaration

Public Property RejectRelation As String

public string RejectRelation {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowObjectInfo Class
WorkflowObjectInfo Members


StatusCode Property (WorkflowObjectInfo) | fcSDK Documentation

StatusCode Property (WorkflowObjectInfo)

Syntax

'Declaration

Public Property StatusCode As Integer

public int StatusCode {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowObjectInfo Class
WorkflowObjectInfo Members


StatusRelation Property (WorkflowObjectInfo) | fcSDK Documentation

StatusRelation Property (WorkflowObjectInfo)

Syntax

'Declaration

Public Property StatusRelation As String

public string StatusRelation {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowObjectInfo Class
WorkflowObjectInfo Members


TimeStampFieldName Property | fcSDK Documentation

TimeStampFieldName Property

Syntax

'Declaration

Public Property TimeStampFieldName As String

public string TimeStampFieldName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowObjectInfo Class
WorkflowObjectInfo Members


UseParticipantActEntryModel Property (WorkflowObjectInfo) | fcSDK Documentation

UseParticipantActEntryModel Property (WorkflowObjectInfo)

Syntax

'Declaration

Public Property UseParticipantActEntryModel As Boolean

public bool UseParticipantActEntryModel {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowObjectInfo Class
WorkflowObjectInfo Members


WipBinRelation Property (WorkflowObjectInfo) | fcSDK Documentation

WipBinRelation Property (WorkflowObjectInfo)

Syntax

'Declaration

Public Property WipBinRelation As String

public string WipBinRelation {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowObjectInfo Class
WorkflowObjectInfo Members


ClarifyLoginType Enumeration | fcSDK Documentation

ClarifyLoginType Enumeration

Provides enumerated values which determine how a given user is logged in when calling ClarifyApplication.CreateSession

Syntax

'Declaration

Public Enum ClarifyLoginType
   Inherits System.Enum

public enum ClarifyLoginType : System.Enum

Members

Member | Description
Contact | Specifies that a Contact or "web user" login should be attempted.
User | Specifies that a regular user login should be attempted.

Remarks

For more information on how login behavior works, see the ClarifyApplication.CreateSession method.

Inheritance Hierarchy

System.Object System.ValueType System.Enum FChoice.Foundation.Clarify.ClarifyLoginType

Requirements

Namespace: FChoice.Foundation.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FChoice.Foundation.Clarify Namespace FChoice.Foundation.Clarify.ClarifyLoginType

Requirements

Namespace: FChoice.Foundation.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FChoice.Foundation.Clarify Namespace


InitStatusChangeType Enumeration | fcSDK Documentation

InitStatusChangeType Enumeration

Syntax

'Declaration

Public Enum InitStatusChangeType
   Inherits System.Enum

public enum InitStatusChangeType : System.Enum

Members

Member | Description
CacheLoaded | Caches have been loaded.
Completed | Initialization is complete.
Started | Initialization has started

Inheritance Hierarchy

System.Object System.ValueType System.Enum FChoice.Foundation.Clarify.InitStatusChangeType

Requirements

Namespace: FChoice.Foundation.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FChoice.Foundation.Clarify Namespace FChoice.Foundation.Clarify.InitStatusChangeType

Requirements

Namespace: FChoice.Foundation.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FChoice.Foundation.Clarify Namespace


SchemaLoadStatusType Enumeration | fcSDK Documentation

SchemaLoadStatusType Enumeration

Syntax

'Declaration

Public Enum SchemaLoadStatusType
   Inherits System.Enum

public enum SchemaLoadStatusType : System.Enum

Members

Member | Description
Completed |
QueryExecuted |
RestrictionsLoaded |
Starting |
TablesLoaded |
ViewsLoaded |

Inheritance Hierarchy

System.Object System.ValueType System.Enum FChoice.Foundation.Clarify.SchemaLoadStatusType

Requirements

Namespace: FChoice.Foundation.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FChoice.Foundation.Clarify Namespace FChoice.Foundation.Clarify.SchemaLoadStatusType

Requirements

Namespace: FChoice.Foundation.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FChoice.Foundation.Clarify Namespace


IClarifyApplication Interface | fcSDK Documentation

IClarifyApplication Interface

Syntax

'Declaration

Public Interface IClarifyApplication

public interface IClarifyApplication

Requirements

Namespace: FChoice.Foundation.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

IClarifyApplication Members
FChoice.Foundation.Clarify Namespace


IClarifyApplication Interface Members | fcSDK Documentation

IClarifyApplication Interface Members

The following tables list the members exposed by IClarifyApplication.

Public Properties

 | Name | Description
Property | ClarifyVersion |
Property | ConfigItemCache |
Property | ConfigItems |
Property | Configuration |
Property | ConvertTimeZone |
Property | DatabaseVersion |
Property | DataRestrictionsEnabled |
Property | DBUserName |
Property | IsDbUnicode |
Property | IsTravelerEnabled |
Property | ListCache |
Property | LocaleCache |
Property | SchemaCache |
Property | ServerTimeZone |
Property | StringCache |
Property | TruncateStringFields |

Public Methods

 | Name | Description
Method | CreateSession | Overloaded.
Method | CurrentSessions |
Method | EncryptClarifyPassword |
Method | EncryptDBPassword |
Method | GetMtmTableName |
Method | GetObjID |
Method | GetSession |
Method | IsSessionValid |

Reference

IClarifyApplication Interface
FChoice.Foundation.Clarify Namespace


CreateSession Method (IClarifyApplication) | fcSDK Documentation

CreateSession Method (IClarifyApplication)

Overload List

Overload | Description
CreateSession() |
CreateSession(String,ClarifyLoginType) |
CreateSession(String,String,ClarifyLoginType) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IClarifyApplication Interface
IClarifyApplication Members


CreateSession() Method | fcSDK Documentation

CreateSession() Method

Syntax

'Declaration

Overloads Function CreateSession() As ClarifySession

ClarifySession CreateSession()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IClarifyApplication Interface
IClarifyApplication Members
Overload List


CreateSession(String,ClarifyLoginType) Method | fcSDK Documentation

CreateSession(String,ClarifyLoginType) Method

Syntax

'Declaration

Overloads Function CreateSession( _
   ByVal _userName_ As String, _
   ByVal _loginType_ As ClarifyLoginType _
) As ClarifySession

ClarifySession CreateSession(
   string _userName_,
   ClarifyLoginType _loginType_
)

Parameters

userName

loginType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IClarifyApplication Interface
IClarifyApplication Members
Overload List


CreateSession(String,String,ClarifyLoginType) Method | fcSDK Documentation

CreateSession(String,String,ClarifyLoginType) Method

Syntax

'Declaration

Overloads Function CreateSession( _
   ByVal _userName_ As String, _
   ByVal _password_ As String, _
   ByVal _loginType_ As ClarifyLoginType _
) As ClarifySession

ClarifySession CreateSession(
   string _userName_,
   string _password_,
   ClarifyLoginType _loginType_
)

Parameters

userName

password

loginType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IClarifyApplication Interface
IClarifyApplication Members
Overload List


CurrentSessions Method (IClarifyApplication) | fcSDK Documentation

CurrentSessions Method (IClarifyApplication)

Syntax

'Declaration

Function CurrentSessions() As FCSessionSummary()

FCSessionSummary[] CurrentSessions()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IClarifyApplication Interface
IClarifyApplication Members


EncryptClarifyPassword Method (IClarifyApplication) | fcSDK Documentation

EncryptClarifyPassword Method (IClarifyApplication)

Syntax

'Declaration
Function EncryptClarifyPassword( _
   ByVal _password_ As String _
) As String

string EncryptClarifyPassword(
   string _password_
)

Parameters

password

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IClarifyApplication Interface
IClarifyApplication Members


EncryptDBPassword Method (IClarifyApplication) | fcSDK Documentation

EncryptDBPassword Method (IClarifyApplication)

Syntax

'Declaration
Function EncryptDBPassword( _
   ByVal _password_ As String _
) As String

string EncryptDBPassword(
   string _password_
)

Parameters

password

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IClarifyApplication Interface
IClarifyApplication Members


GetMtmTableName Method (IClarifyApplication) | fcSDK Documentation

GetMtmTableName Method (IClarifyApplication)

Syntax

'Declaration

Function GetMtmTableName( _
   ByVal _relation_ As SchemaRelation _
) As String

string GetMtmTableName(
  SchemaRelation _relation_
)

Parameters

relation

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IClarifyApplication Interface
IClarifyApplication Members


GetObjID Method (IClarifyApplication) | fcSDK Documentation

GetObjID Method (IClarifyApplication)

Syntax

'Declaration
Function GetObjID( _
   ByVal _tableName_ As String _
) As Integer

int GetObjID(
   string _tableName_
)

Parameters

tableName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IClarifyApplication Interface
IClarifyApplication Members


GetSession Method (IClarifyApplication) | fcSDK Documentation

GetSession Method (IClarifyApplication)

Syntax

'Declaration
Function GetSession( _
   ByVal _sessionID_ As Guid _
) As ClarifySession

ClarifySession GetSession(
   Guid _sessionID_
)

Parameters

sessionID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IClarifyApplication Interface
IClarifyApplication Members


IsSessionValid Method (IClarifyApplication) | fcSDK Documentation

IsSessionValid Method (IClarifyApplication)

Syntax

'Declaration
Function IsSessionValid( _
   ByVal _sessionID_ As Guid _
) As Boolean

bool IsSessionValid(
   Guid _sessionID_
)

Parameters

sessionID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IClarifyApplication Interface
IClarifyApplication Members


ClarifyVersion Property (IClarifyApplication) | fcSDK Documentation

ClarifyVersion Property (IClarifyApplication)

Syntax

'Declaration
ReadOnly Property ClarifyVersion As String

string ClarifyVersion {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IClarifyApplication Interface
IClarifyApplication Members


ConfigItemCache Property (IClarifyApplication) | fcSDK Documentation

ConfigItemCache Property (IClarifyApplication)

Syntax

'Declaration

ReadOnly Property ConfigItemCache As ConfigItemCache

ConfigItemCache ConfigItemCache {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IClarifyApplication Interface
IClarifyApplication Members


ConfigItems Property (IClarifyApplication) | fcSDK Documentation

ConfigItems Property (IClarifyApplication)

Syntax

'Declaration

ReadOnly Property ConfigItems As ClarifyConfigItemCollection

ClarifyConfigItemCollection ConfigItems {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IClarifyApplication Interface
IClarifyApplication Members


Configuration Property (IClarifyApplication) | fcSDK Documentation

Configuration Property (IClarifyApplication)

Syntax

'Declaration
ReadOnly Property Configuration As NameValueCollection

NameValueCollection Configuration {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IClarifyApplication Interface
IClarifyApplication Members


ConvertTimeZone Property (IClarifyApplication) | fcSDK Documentation

ConvertTimeZone Property (IClarifyApplication)

Syntax

'Declaration

Property ConvertTimeZone As Boolean

bool ConvertTimeZone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IClarifyApplication Interface
IClarifyApplication Members


DatabaseVersion Property (IClarifyApplication) | fcSDK Documentation

DatabaseVersion Property (IClarifyApplication)

Syntax

'Declaration

ReadOnly Property DatabaseVersion As Version

Version DatabaseVersion {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IClarifyApplication Interface
IClarifyApplication Members


DataRestrictionsEnabled Property (IClarifyApplication) | fcSDK Documentation

DataRestrictionsEnabled Property (IClarifyApplication)

Syntax

'Declaration

ReadOnly Property DataRestrictionsEnabled As Boolean

bool DataRestrictionsEnabled {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IClarifyApplication Interface
IClarifyApplication Members


DBUserName Property (IClarifyApplication) | fcSDK Documentation

DBUserName Property (IClarifyApplication)

Syntax

'Declaration

ReadOnly Property DBUserName As String

string DBUserName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IClarifyApplication Interface
IClarifyApplication Members


IsDbUnicode Property (IClarifyApplication) | fcSDK Documentation

IsDbUnicode Property (IClarifyApplication)

Syntax

'Declaration

<ObsoleteAttribute("Use the SchemaCache IsDatabaseUnicode property")>
ReadOnly Property IsDbUnicode As Boolean

[ObsoleteAttribute("Use the SchemaCache IsDatabaseUnicode property")]
bool IsDbUnicode {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IClarifyApplication Interface
IClarifyApplication Members


IsTravelerEnabled Property (IClarifyApplication) | fcSDK Documentation

IsTravelerEnabled Property (IClarifyApplication)

Syntax

'Declaration

ReadOnly Property IsTravelerEnabled As Boolean

bool IsTravelerEnabled {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IClarifyApplication Interface
IClarifyApplication Members


ListCache Property (IClarifyApplication) | fcSDK Documentation

ListCache Property (IClarifyApplication)

Syntax

'Declaration

ReadOnly Property ListCache As IListCache

IListCache ListCache {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IClarifyApplication Interface
IClarifyApplication Members


LocaleCache Property (IClarifyApplication) | fcSDK Documentation

LocaleCache Property (IClarifyApplication)

Syntax

'Declaration

ReadOnly Property LocaleCache As ILocaleCache

ILocaleCache LocaleCache {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IClarifyApplication Interface
IClarifyApplication Members


SchemaCache Property (IClarifyApplication) | fcSDK Documentation

SchemaCache Property (IClarifyApplication)

Syntax

'Declaration

ReadOnly Property SchemaCache As SchemaCache

SchemaCache SchemaCache {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IClarifyApplication Interface
IClarifyApplication Members


ServerTimeZone Property (IClarifyApplication) | fcSDK Documentation

ServerTimeZone Property (IClarifyApplication)

Syntax

'Declaration

Property ServerTimeZone As ITimeZone

ITimeZone ServerTimeZone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IClarifyApplication Interface
IClarifyApplication Members


StringCache Property (IClarifyApplication) | fcSDK Documentation

StringCache Property (IClarifyApplication)

Syntax

'Declaration

ReadOnly Property StringCache As IStringCache

IStringCache StringCache {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IClarifyApplication Interface
IClarifyApplication Members


TruncateStringFields Property (IClarifyApplication) | fcSDK Documentation

TruncateStringFields Property (IClarifyApplication)

Syntax

'Declaration

Property TruncateStringFields As Boolean

bool TruncateStringFields {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IClarifyApplication Interface
IClarifyApplication Members


IListCache Interface | fcSDK Documentation

IListCache Interface

Syntax

'Declaration

Public Interface IListCache

public interface IListCache

Requirements

Namespace: FChoice.Foundation.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

IListCache Members
FChoice.Foundation.Clarify Namespace


IListCache Interface Members | fcSDK Documentation

IListCache Interface Members

The following tables list the members exposed by IListCache.

Public Properties

 | Name | Description
Property | CacheSetName |
Property | CacheType |
Property | GlobalStrings |
Property | HierarchicalStrings |

Public Methods

 | Name | Description
Method | GetGbstDefault |
Method | GetGbstDefaultObjID |
Method | GetGbstElmByID |
Method | GetGbstElmObjID |
Method | GetGbstElmRankObjID |
Method | GetGbstList |
Method | GetGbstListElements |
Method | GetHgbstElmDefault |
Method | GetHgbstElmDefaultElement | Overloaded.
Method | GetHgbstElmDefaultObjID | Overloaded.
Method | GetHgbstElmObjID | Overloaded.
Method | GetHgbstList | Overloaded.
Method | IsInGbstList |
Method | IsInHgbstList | Overloaded.
Method | RankIsInGbstList |
Method | TryGetHgbstList | Overloaded.
Method | UpdateCache |

Public Events

 | Name | Description
Event | CacheUpdated |

Reference

IListCache Interface
FChoice.Foundation.Clarify Namespace


GetGbstDefault Method (IListCache) | fcSDK Documentation

GetGbstDefault Method (IListCache)

Syntax

'Declaration

Function GetGbstDefault( _
   ByVal _listTitle_ As String _
) As String

string GetGbstDefault(
   string _listTitle_
)

Parameters

listTitle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IListCache Interface
IListCache Members


GetGbstDefaultObjID Method (IListCache) | fcSDK Documentation

GetGbstDefaultObjID Method (IListCache)

Syntax

'Declaration
Function GetGbstDefaultObjID( _
   ByVal _listTitle_ As String _
) As Integer

int GetGbstDefaultObjID(
   string _listTitle_
)

Parameters

listTitle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IListCache Interface
IListCache Members


GetGbstElmByID Method (IListCache) | fcSDK Documentation

GetGbstElmByID Method (IListCache)

Syntax

'Declaration
Function GetGbstElmByID( _
   ByVal _listTitle_ As String, _
   ByVal _elmObjID_ As Integer _
) As String

string GetGbstElmByID(
   string _listTitle_,
   int _elmObjID_
)

Parameters

listTitle

elmObjID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IListCache Interface
IListCache Members


GetGbstElmObjID Method (IListCache) | fcSDK Documentation

GetGbstElmObjID Method (IListCache)

Syntax

'Declaration
Function GetGbstElmObjID( _
   ByVal _listTitle_ As String, _
   ByVal _elementTitle_ As String _
) As Integer

int GetGbstElmObjID(
   string _listTitle_,
   string _elementTitle_
)

Parameters

listTitle

elementTitle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IListCache Interface
IListCache Members


GetGbstElmRankObjID Method (IListCache) | fcSDK Documentation

GetGbstElmRankObjID Method (IListCache)

Syntax

'Declaration
Function GetGbstElmRankObjID( _
   ByVal _listTitle_ As String, _
   ByVal _elementRank_ As Integer _
) As Integer

int GetGbstElmRankObjID(
   string _listTitle_,
   int _elementRank_
)

Parameters

listTitle

elementRank

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IListCache Interface
IListCache Members


GetGbstList Method (IListCache) | fcSDK Documentation

GetGbstList Method (IListCache)

Syntax

'Declaration

Function GetGbstList( _
   ByVal _listTitle_ As String _
) As IGlobalStringList

IGlobalStringList GetGbstList(
   string _listTitle_
)

Parameters

listTitle

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IListCache Interface
IListCache Members


GetGbstListElements Method (IListCache) | fcSDK Documentation

GetGbstListElements Method (IListCache)

Syntax

'Declaration

Function GetGbstListElements( _
   ByVal _listTitle_ As String, _
   ByVal _includeInactive_ As Boolean _
) As IGlobalStringElementCollection

IGlobalStringElementCollection GetGbstListElements(
   string _listTitle_,
   bool _includeInactive_
)

Parameters

listTitle

includeInactive

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IListCache Interface
IListCache Members


GetHgbstElmDefault Method (IListCache) | fcSDK Documentation

GetHgbstElmDefault Method (IListCache)

Syntax

'Declaration

Function GetHgbstElmDefault( _
   ByVal _listTitle_ As String, _
   ByVal ParamArray _elementTitles_() As String _
) As String

string GetHgbstElmDefault(
   string _listTitle_,
   params string[] _elementTitles_
)

Parameters

listTitle

elementTitles

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IListCache Interface
IListCache Members


GetHgbstElmDefaultElement Method (IListCache) | fcSDK Documentation

GetHgbstElmDefaultElement Method (IListCache)

Overload List

Overload | Description
GetHgbstElmDefaultElement(String,String[]) |
GetHgbstElmDefaultElement(String,Boolean,String[]) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IListCache Interface
IListCache Members


GetHgbstElmDefaultElement(String,String[]) Method | fcSDK Documentation

GetHgbstElmDefaultElement(String,String[]) Method

Syntax

'Declaration

Overloads Function GetHgbstElmDefaultElement( _
   ByVal _listTitle_ As String, _
   ByVal ParamArray _elementTitles_() As String _
) As IHierarchicalStringElement

IHierarchicalStringElement GetHgbstElmDefaultElement(
   string _listTitle_,
   params string[] _elementTitles_
)

Parameters

listTitle

elementTitles

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IListCache Interface
IListCache Members
Overload List


GetHgbstElmDefaultElement(String,Boolean,String[]) Method | fcSDK Documentation

GetHgbstElmDefaultElement(String,Boolean,String[]) Method

Syntax

'Declaration

Overloads Function GetHgbstElmDefaultElement( _
   ByVal _listTitle_ As String, _
   ByVal _throwErrors_ As Boolean, _
   ByVal ParamArray _elementTitles_() As String _
) As IHierarchicalStringElement

IHierarchicalStringElement GetHgbstElmDefaultElement(
   string _listTitle_,
   bool _throwErrors_,
   params string[] _elementTitles_
)

Parameters

listTitle

throwErrors

elementTitles

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IListCache Interface
IListCache Members
Overload List


GetHgbstElmDefaultObjID Method (IListCache) | fcSDK Documentation

GetHgbstElmDefaultObjID Method (IListCache)

Overload List

Overload | Description
GetHgbstElmDefaultObjID(String,String[]) |
GetHgbstElmDefaultObjID(String,Boolean,String[]) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IListCache Interface
IListCache Members


GetHgbstElmDefaultObjID(String,String[]) Method | fcSDK Documentation

GetHgbstElmDefaultObjID(String,String[]) Method

Syntax

'Declaration

Overloads Function GetHgbstElmDefaultObjID( _
   ByVal _listTitle_ As String, _
   ByVal ParamArray _elementTitles_() As String _
) As Integer

int GetHgbstElmDefaultObjID(
   string _listTitle_,
   params string[] _elementTitles_
)

Parameters

listTitle

elementTitles

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IListCache Interface
IListCache Members
Overload List


GetHgbstElmDefaultObjID(String,Boolean,String[]) Method | fcSDK Documentation

GetHgbstElmDefaultObjID(String,Boolean,String[]) Method

Syntax

'Declaration

Overloads Function GetHgbstElmDefaultObjID( _
   ByVal _listTitle_ As String, _
   ByVal _throwErrors_ As Boolean, _
   ByVal ParamArray _elementTitles_() As String _
) As Integer

int GetHgbstElmDefaultObjID(
   string _listTitle_,
   bool _throwErrors_,
   params string[] _elementTitles_
)

Parameters

listTitle

throwErrors

elementTitles

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IListCache Interface
IListCache Members
Overload List


GetHgbstElmObjID Method (IListCache) | fcSDK Documentation

GetHgbstElmObjID Method (IListCache)

Overload List

Overload | Description
GetHgbstElmObjID(String,String,String[]) |
GetHgbstElmObjID(String,String,Boolean,String[]) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IListCache Interface
IListCache Members


GetHgbstElmObjID(String,String,String[]) Method | fcSDK Documentation

GetHgbstElmObjID(String,String,String[]) Method

Syntax

'Declaration

Overloads Function GetHgbstElmObjID( _
   ByVal _listTitle_ As String, _
   ByVal _elementTitle_ As String, _
   ByVal ParamArray _elementTitles_() As String _
) As Integer

int GetHgbstElmObjID(
   string _listTitle_,
   string _elementTitle_,
   params string[] _elementTitles_
)

Parameters

listTitle

elementTitle

elementTitles

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IListCache Interface
IListCache Members
Overload List


GetHgbstElmObjID(String,String,Boolean,String[]) Method | fcSDK Documentation

GetHgbstElmObjID(String,String,Boolean,String[]) Method

Syntax

'Declaration

Overloads Function GetHgbstElmObjID( _
   ByVal _listTitle_ As String, _
   ByVal _elementTitle_ As String, _
   ByVal _throwErrors_ As Boolean, _
   ByVal ParamArray _elementTitles_() As String _
) As Integer

int GetHgbstElmObjID(
   string _listTitle_,
   string _elementTitle_,
   bool _throwErrors_,
   params string[] _elementTitles_
)

Parameters

listTitle

elementTitle

throwErrors

elementTitles

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IListCache Interface
IListCache Members
Overload List


GetHgbstList Method (IListCache) | fcSDK Documentation

GetHgbstList Method (IListCache)

Overload List

Overload | Description
GetHgbstList(String,String[]) |
GetHgbstList(String,Boolean,String[]) |
GetHgbstList(String,Boolean,Boolean,String[]) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IListCache Interface
IListCache Members


GetHgbstList(String,String[]) Method | fcSDK Documentation

GetHgbstList(String,String[]) Method

Syntax

'Declaration

Overloads Function GetHgbstList( _
   ByVal _listTitle_ As String, _
   ByVal ParamArray _elementTitles_() As String _
) As IHierarchicalStringElementCollection

IHierarchicalStringElementCollection GetHgbstList(
   string _listTitle_,
   params string[] _elementTitles_
)

Parameters

listTitle

elementTitles

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IListCache Interface
IListCache Members
Overload List


GetHgbstList(String,Boolean,String[]) Method | fcSDK Documentation

GetHgbstList(String,Boolean,String[]) Method

Syntax

'Declaration

Overloads Function GetHgbstList( _
   ByVal _listTitle_ As String, _
   ByVal _includeInactive_ As Boolean, _
   ByVal ParamArray _elementTitles_() As String _
) As IHierarchicalStringElementCollection

IHierarchicalStringElementCollection GetHgbstList(
   string _listTitle_,
   bool _includeInactive_,
   params string[] _elementTitles_
)

Parameters

listTitle

includeInactive

elementTitles

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IListCache Interface
IListCache Members
Overload List


GetHgbstList(String,Boolean,Boolean,String[]) Method | fcSDK Documentation

GetHgbstList(String,Boolean,Boolean,String[]) Method

Syntax

'Declaration

Overloads Function GetHgbstList( _
   ByVal _listTitle_ As String, _
   ByVal _includeInactive_ As Boolean, _
   ByVal _throwErrors_ As Boolean, _
   ByVal ParamArray _elementTitles_() As String _
) As IHierarchicalStringElementCollection

IHierarchicalStringElementCollection GetHgbstList(
   string _listTitle_,
   bool _includeInactive_,
   bool _throwErrors_,
   params string[] _elementTitles_
)

Parameters

listTitle

includeInactive

throwErrors

elementTitles

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IListCache Interface
IListCache Members
Overload List


IsInGbstList Method (IListCache) | fcSDK Documentation

IsInGbstList Method (IListCache)

Syntax

'Declaration

Function IsInGbstList( _
   ByVal _listTitle_ As String, _
   ByVal _element_ As String _
) As Boolean

bool IsInGbstList(
   string _listTitle_,
   string _element_
)

Parameters

listTitle

element

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IListCache Interface
IListCache Members


IsInHgbstList Method (IListCache) | fcSDK Documentation

IsInHgbstList Method (IListCache)

Overload List

Overload | Description
IsInHgbstList(String,String,String[]) |
IsInHgbstList(String,String,Boolean,String[]) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IListCache Interface
IListCache Members


IsInHgbstList(String,String,String[]) Method | fcSDK Documentation

IsInHgbstList(String,String,String[]) Method

Syntax

'Declaration

Overloads Function IsInHgbstList( _
   ByVal _listTitle_ As String, _
   ByVal _elementTitle_ As String, _
   ByVal ParamArray _elementTitles_() As String _
) As Boolean

bool IsInHgbstList(
   string _listTitle_,
   string _elementTitle_,
   params string[] _elementTitles_
)

Parameters

listTitle

elementTitle

elementTitles

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IListCache Interface
IListCache Members
Overload List


IsInHgbstList(String,String,Boolean,String[]) Method | fcSDK Documentation

IsInHgbstList(String,String,Boolean,String[]) Method

Syntax

'Declaration

Overloads Function IsInHgbstList( _
   ByVal _listTitle_ As String, _
   ByVal _elementTitle_ As String, _
   ByVal _throwErrors_ As Boolean, _
   ByVal ParamArray _elementTitles_() As String _
) As Boolean

bool IsInHgbstList(
   string _listTitle_,
   string _elementTitle_,
   bool _throwErrors_,
   params string[] _elementTitles_
)

Parameters

listTitle

elementTitle

throwErrors

elementTitles

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IListCache Interface
IListCache Members
Overload List


RankIsInGbstList Method (IListCache) | fcSDK Documentation

RankIsInGbstList Method (IListCache)

Syntax

'Declaration

Function RankIsInGbstList( _
   ByVal _listTitle_ As String, _
   ByVal _rank_ As Integer _
) As Boolean

bool RankIsInGbstList(
   string _listTitle_,
   int _rank_
)

Parameters

listTitle

rank

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IListCache Interface
IListCache Members


TryGetHgbstList Method (IListCache) | fcSDK Documentation

TryGetHgbstList Method (IListCache)

Overload List

Overload | Description
TryGetHgbstList(String,Boolean,String[]) |
TryGetHgbstList(String,Boolean,Boolean,String[]) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IListCache Interface
IListCache Members


TryGetHgbstList(String,Boolean,String[]) Method | fcSDK Documentation

TryGetHgbstList(String,Boolean,String[]) Method

Syntax

'Declaration

Overloads Function TryGetHgbstList( _
   ByVal _listTitle_ As String, _
   ByVal _throwErrors_ As Boolean, _
   ByVal ParamArray _elementTitles_() As String _
) As IHierarchicalStringElementCollection

IHierarchicalStringElementCollection TryGetHgbstList(
   string _listTitle_,
   bool _throwErrors_,
   params string[] _elementTitles_
)

Parameters

listTitle

throwErrors

elementTitles

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IListCache Interface
IListCache Members
Overload List


TryGetHgbstList(String,Boolean,Boolean,String[]) Method | fcSDK Documentation

TryGetHgbstList(String,Boolean,Boolean,String[]) Method

Syntax

'Declaration

Overloads Function TryGetHgbstList( _
   ByVal _listTitle_ As String, _
   ByVal _throwErrors_ As Boolean, _
   ByVal _includeInactive_ As Boolean, _
   ByVal ParamArray _elementTitles_() As String _
) As IHierarchicalStringElementCollection

IHierarchicalStringElementCollection TryGetHgbstList(
   string _listTitle_,
   bool _throwErrors_,
   bool _includeInactive_,
   params string[] _elementTitles_
)

Parameters

listTitle

throwErrors

includeInactive

elementTitles

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IListCache Interface
IListCache Members
Overload List


UpdateCache Method (IListCache) | fcSDK Documentation

UpdateCache Method (IListCache)

Syntax

'Declaration

Sub UpdateCache()

void UpdateCache()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IListCache Interface
IListCache Members


CacheSetName Property (IListCache) | fcSDK Documentation

CacheSetName Property (IListCache)

Syntax

'Declaration

ReadOnly Property CacheSetName As String

string CacheSetName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IListCache Interface
IListCache Members


CacheType Property (IListCache) | fcSDK Documentation

CacheType Property (IListCache)

Syntax

'Declaration

ReadOnly Property CacheType As CacheType

CacheType CacheType {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IListCache Interface
IListCache Members


GlobalStrings Property (IListCache) | fcSDK Documentation

GlobalStrings Property (IListCache)

Syntax

'Declaration

ReadOnly Property GlobalStrings As IGlobalStringListCollection

IGlobalStringListCollection GlobalStrings {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IListCache Interface
IListCache Members


HierarchicalStrings Property (IListCache) | fcSDK Documentation

HierarchicalStrings Property (IListCache)

Syntax

'Declaration

ReadOnly Property HierarchicalStrings As IHierarchicalStringListCollection

IHierarchicalStringListCollection HierarchicalStrings {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IListCache Interface
IListCache Members


CacheUpdated Event (IListCache) | fcSDK Documentation

CacheUpdated Event (IListCache)

Syntax

'Declaration

Event CacheUpdated As EventHandler

event EventHandler CacheUpdated

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IListCache Interface
IListCache Members


ILocaleCache Interface | fcSDK Documentation

ILocaleCache Interface

Syntax

'Declaration

Public Interface ILocaleCache

public interface ILocaleCache

Requirements

Namespace: FChoice.Foundation.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ILocaleCache Members
FChoice.Foundation.Clarify Namespace


ILocaleCache Interface Members | fcSDK Documentation

ILocaleCache Interface Members

The following tables list the members exposed by ILocaleCache.

Public Properties

 | Name | Description
Property | CacheSetName |
Property | CacheType |
Property | Countries |
Property | DefaultTimeZone |
Property | ServerTimeZone |
Property | TimeZones |

Public Methods

 | Name | Description
Method | GetCountryObjID |
Method | GetDefaultCountry |
Method | GetDefaultCountryObjID |
Method | GetDefaultState | Overloaded.
Method | GetDefaultStateObjID |
Method | GetDefaultTimeZone |
Method | GetDefaultTimeZoneObjID |
Method | GetFullStateObjID |
Method | GetServerTimeZoneOffset |
Method | GetShortTimeZoneObjID |
Method | GetStateObjID |
Method | GetStates | Overloaded.
Method | GetTimeZoneObjID |
Method | GetTimeZoneOffset |
Method | GetTimeZonesInCountry |
Method | IsCountry |
Method | IsFullState |
Method | IsOnDST |
Method | IsState | Overloaded.
Method | IsTimeZone |
Method | IsTimeZoneInCountry | Overloaded.
Method | SetServerTimeZoneToMachineTimeZone |
Method | UpdateCache |

Public Events

 | Name | Description
Event | CacheUpdated |

Reference

ILocaleCache Interface
FChoice.Foundation.Clarify Namespace


GetCountryObjID Method (ILocaleCache) | fcSDK Documentation

GetCountryObjID Method (ILocaleCache)

Syntax

'Declaration
Function GetCountryObjID( _
   ByVal _countryName_ As String _
) As Integer

int GetCountryObjID(
   string _countryName_
)

Parameters

countryName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILocaleCache Interface
ILocaleCache Members


GetDefaultCountry Method (ILocaleCache) | fcSDK Documentation

GetDefaultCountry Method (ILocaleCache)

Syntax

'Declaration

Function GetDefaultCountry() As Country

Country GetDefaultCountry()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILocaleCache Interface
ILocaleCache Members


GetDefaultCountryObjID Method (ILocaleCache) | fcSDK Documentation

GetDefaultCountryObjID Method (ILocaleCache)

Syntax

'Declaration
Function GetDefaultCountryObjID() As Integer

int GetDefaultCountryObjID()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILocaleCache Interface
ILocaleCache Members


GetDefaultState Method (ILocaleCache) | fcSDK Documentation

GetDefaultState Method (ILocaleCache)

Overload List

Overload | Description
GetDefaultState() |
GetDefaultState(String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILocaleCache Interface
ILocaleCache Members


GetDefaultState() Method | fcSDK Documentation

GetDefaultState() Method

Syntax

'Declaration

Overloads Function GetDefaultState() As StateProvince

StateProvince GetDefaultState()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILocaleCache Interface
ILocaleCache Members
Overload List


GetDefaultState(String) Method | fcSDK Documentation

GetDefaultState(String) Method

Syntax

'Declaration

Overloads Function GetDefaultState( _
   ByVal _countryName_ As String _
) As StateProvince

StateProvince GetDefaultState(
   string _countryName_
)

Parameters

countryName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILocaleCache Interface
ILocaleCache Members
Overload List


GetDefaultStateObjID Method (ILocaleCache) | fcSDK Documentation

GetDefaultStateObjID Method (ILocaleCache)

Syntax

'Declaration
Function GetDefaultStateObjID( _
   ByVal _countryName_ As String _
) As Integer

int GetDefaultStateObjID(
   string _countryName_
)

Parameters

countryName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILocaleCache Interface
ILocaleCache Members


GetDefaultTimeZone Method (ILocaleCache) | fcSDK Documentation

GetDefaultTimeZone Method (ILocaleCache)

Syntax

'Declaration

Function GetDefaultTimeZone() As ITimeZone

ITimeZone GetDefaultTimeZone()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILocaleCache Interface
ILocaleCache Members


GetDefaultTimeZoneObjID Method (ILocaleCache) | fcSDK Documentation

GetDefaultTimeZoneObjID Method (ILocaleCache)

Syntax

'Declaration
Function GetDefaultTimeZoneObjID() As Integer

int GetDefaultTimeZoneObjID()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILocaleCache Interface
ILocaleCache Members


GetFullStateObjID Method (ILocaleCache) | fcSDK Documentation

GetFullStateObjID Method (ILocaleCache)

Syntax

'Declaration
Function GetFullStateObjID( _
   ByVal _countryName_ As String, _
   ByVal _fullStateName_ As String _
) As Integer

int GetFullStateObjID(
   string _countryName_,
   string _fullStateName_
)

Parameters

countryName

fullStateName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILocaleCache Interface
ILocaleCache Members


GetServerTimeZoneOffset Method (ILocaleCache) | fcSDK Documentation

GetServerTimeZoneOffset Method (ILocaleCache)

Syntax

'Declaration

Function GetServerTimeZoneOffset() As Integer

int GetServerTimeZoneOffset()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILocaleCache Interface
ILocaleCache Members


GetShortTimeZoneObjID Method (ILocaleCache) | fcSDK Documentation

GetShortTimeZoneObjID Method (ILocaleCache)

Syntax

'Declaration
Function GetShortTimeZoneObjID( _
   ByVal _shortName_ As String _
) As Integer

int GetShortTimeZoneObjID(
   string _shortName_
)

Parameters

shortName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILocaleCache Interface
ILocaleCache Members


GetStateObjID Method (ILocaleCache) | fcSDK Documentation

GetStateObjID Method (ILocaleCache)

Syntax

'Declaration
Function GetStateObjID( _
   ByVal _countryName_ As String, _
   ByVal _stateName_ As String _
) As Integer

int GetStateObjID(
   string _countryName_,
   string _stateName_
)

Parameters

countryName

stateName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILocaleCache Interface
ILocaleCache Members


GetStates Method (ILocaleCache) | fcSDK Documentation

GetStates Method (ILocaleCache)

Overload List

Overload | Description
GetStates() |
GetStates(String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILocaleCache Interface
ILocaleCache Members


GetStates() Method | fcSDK Documentation

GetStates() Method

Syntax

'Declaration

Overloads Function GetStates() As StateCollection

StateCollection GetStates()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILocaleCache Interface
ILocaleCache Members
Overload List


GetStates(String) Method | fcSDK Documentation

GetStates(String) Method

Syntax

'Declaration

Overloads Function GetStates( _
   ByVal _countryName_ As String _
) As StateCollection

StateCollection GetStates(
   string _countryName_
)

Parameters

countryName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILocaleCache Interface
ILocaleCache Members
Overload List


GetTimeZoneObjID Method (ILocaleCache) | fcSDK Documentation

GetTimeZoneObjID Method (ILocaleCache)

Syntax

'Declaration
Function GetTimeZoneObjID( _
   ByVal _fullTimeZoneName_ As String _
) As Integer

int GetTimeZoneObjID(
   string _fullTimeZoneName_
)

Parameters

fullTimeZoneName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILocaleCache Interface
ILocaleCache Members


GetTimeZoneOffset Method (ILocaleCache) | fcSDK Documentation

GetTimeZoneOffset Method (ILocaleCache)

Syntax

'Declaration

Function GetTimeZoneOffset( _
   ByVal _fullTimeZoneName_ As String _
) As Integer

int GetTimeZoneOffset(
   string _fullTimeZoneName_
)

Parameters

fullTimeZoneName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILocaleCache Interface
ILocaleCache Members


GetTimeZonesInCountry Method (ILocaleCache) | fcSDK Documentation

GetTimeZonesInCountry Method (ILocaleCache)

Syntax

'Declaration

Function GetTimeZonesInCountry( _
   ByVal _countryName_ As String _
) As FCTimeZoneCollection

FCTimeZoneCollection GetTimeZonesInCountry(
   string _countryName_
)

Parameters

countryName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILocaleCache Interface
ILocaleCache Members


IsCountry Method (ILocaleCache) | fcSDK Documentation

IsCountry Method (ILocaleCache)

Syntax

'Declaration

Function IsCountry( _
   ByVal _countryName_ As String _
) As Boolean

bool IsCountry(
   string _countryName_
)

Parameters

countryName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILocaleCache Interface
ILocaleCache Members


IsFullState Method (ILocaleCache) | fcSDK Documentation

IsFullState Method (ILocaleCache)

Syntax

'Declaration

Function IsFullState( _
   ByVal _countryName_ As String, _
   ByVal _stateName_ As String _
) As Boolean

bool IsFullState(
   string _countryName_,
   string _stateName_
)

Parameters

countryName

stateName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILocaleCache Interface
ILocaleCache Members


IsOnDST Method (ILocaleCache) | fcSDK Documentation

IsOnDST Method (ILocaleCache)

Syntax

'Declaration

Function IsOnDST( _
   ByVal _fullTimeZoneName_ As String, _
   ByVal _checkDate_ As Date _
) As Boolean

bool IsOnDST(
   string _fullTimeZoneName_,
   DateTime _checkDate_
)

Parameters

fullTimeZoneName

checkDate

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILocaleCache Interface
ILocaleCache Members


IsState Method (ILocaleCache) | fcSDK Documentation

IsState Method (ILocaleCache)

Overload List

Overload | Description
IsState(String,String) |
IsState(String,String,Boolean) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILocaleCache Interface
ILocaleCache Members


IsState(String,String) Method | fcSDK Documentation

IsState(String,String) Method

Syntax

'Declaration

Overloads Function IsState( _
   ByVal _countryName_ As String, _
   ByVal _stateName_ As String _
) As Boolean

bool IsState(
   string _countryName_,
   string _stateName_
)

Parameters

countryName

stateName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILocaleCache Interface
ILocaleCache Members
Overload List


IsState(String,String,Boolean) Method | fcSDK Documentation

IsState(String,String,Boolean) Method

Syntax

'Declaration

Overloads Function IsState( _
   ByVal _countryName_ As String, _
   ByVal _stateName_ As String, _
   ByVal _isFullStateName_ As Boolean _
) As Boolean

bool IsState(
   string _countryName_,
   string _stateName_,
   bool _isFullStateName_
)

Parameters

countryName

stateName

isFullStateName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILocaleCache Interface
ILocaleCache Members
Overload List


IsTimeZone Method (ILocaleCache) | fcSDK Documentation

IsTimeZone Method (ILocaleCache)

Syntax

'Declaration

Function IsTimeZone( _
   ByVal _tzName_ As String _
) As Boolean

bool IsTimeZone(
   string _tzName_
)

Parameters

tzName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILocaleCache Interface
ILocaleCache Members


IsTimeZoneInCountry Method (ILocaleCache) | fcSDK Documentation

IsTimeZoneInCountry Method (ILocaleCache)

Overload List

Overload | Description
IsTimeZoneInCountry(String,String) |
IsTimeZoneInCountry(String,String,Boolean) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILocaleCache Interface
ILocaleCache Members


IsTimeZoneInCountry(String,String) Method | fcSDK Documentation

IsTimeZoneInCountry(String,String) Method

Syntax

'Declaration

Overloads Function IsTimeZoneInCountry( _
   ByVal _countryName_ As String, _
   ByVal _tzName_ As String _
) As Boolean

bool IsTimeZoneInCountry(
   string _countryName_,
   string _tzName_
)

Parameters

countryName

tzName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILocaleCache Interface
ILocaleCache Members
Overload List


IsTimeZoneInCountry(String,String,Boolean) Method | fcSDK Documentation

IsTimeZoneInCountry(String,String,Boolean) Method

Syntax

'Declaration

Overloads Function IsTimeZoneInCountry( _
   ByVal _countryName_ As String, _
   ByVal _tzName_ As String, _
   ByVal _isFullTzName_ As Boolean _
) As Boolean

bool IsTimeZoneInCountry(
   string _countryName_,
   string _tzName_,
   bool _isFullTzName_
)

Parameters

countryName

tzName

isFullTzName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILocaleCache Interface
ILocaleCache Members
Overload List


SetServerTimeZoneToMachineTimeZone Method (ILocaleCache) | fcSDK Documentation

SetServerTimeZoneToMachineTimeZone Method (ILocaleCache)

Syntax

'Declaration

Sub SetServerTimeZoneToMachineTimeZone()

void SetServerTimeZoneToMachineTimeZone()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILocaleCache Interface
ILocaleCache Members


UpdateCache Method (ILocaleCache) | fcSDK Documentation

UpdateCache Method (ILocaleCache)

Syntax

'Declaration

Sub UpdateCache()

void UpdateCache()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILocaleCache Interface
ILocaleCache Members


CacheSetName Property (ILocaleCache) | fcSDK Documentation

CacheSetName Property (ILocaleCache)

Syntax

'Declaration

ReadOnly Property CacheSetName As String

string CacheSetName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILocaleCache Interface
ILocaleCache Members


CacheType Property (ILocaleCache) | fcSDK Documentation

CacheType Property (ILocaleCache)

Syntax

'Declaration

ReadOnly Property CacheType As CacheType

CacheType CacheType {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILocaleCache Interface
ILocaleCache Members


Countries Property (ILocaleCache) | fcSDK Documentation

Countries Property (ILocaleCache)

Syntax

'Declaration

ReadOnly Property Countries As CountryCollection

CountryCollection Countries {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILocaleCache Interface
ILocaleCache Members


DefaultTimeZone Property (ILocaleCache) | fcSDK Documentation

DefaultTimeZone Property (ILocaleCache)

Syntax

'Declaration

ReadOnly Property DefaultTimeZone As ITimeZone

ITimeZone DefaultTimeZone {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILocaleCache Interface
ILocaleCache Members


ServerTimeZone Property (ILocaleCache) | fcSDK Documentation

ServerTimeZone Property (ILocaleCache)

Syntax

'Declaration

ReadOnly Property ServerTimeZone As ITimeZone

ITimeZone ServerTimeZone {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILocaleCache Interface
ILocaleCache Members


TimeZones Property (ILocaleCache) | fcSDK Documentation

TimeZones Property (ILocaleCache)

Syntax

'Declaration

ReadOnly Property TimeZones As FCTimeZoneCollection

FCTimeZoneCollection TimeZones {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILocaleCache Interface
ILocaleCache Members


CacheUpdated Event (ILocaleCache) | fcSDK Documentation

CacheUpdated Event (ILocaleCache)

Syntax

'Declaration

Event CacheUpdated As EventHandler

event EventHandler CacheUpdated

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ILocaleCache Interface
ILocaleCache Members


IStringCache Interface | fcSDK Documentation

IStringCache Interface

Syntax

'Declaration

Public Interface IStringCache

public interface IStringCache

Requirements

Namespace: FChoice.Foundation.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

IStringCache Members
FChoice.Foundation.Clarify Namespace


IStringCache Interface Members | fcSDK Documentation

IStringCache Interface Members

The following tables list the members exposed by IStringCache.

Public Properties

 | Name | Description
Property | CacheSetName |
Property | CacheType |

Public Methods

 | Name | Description
Method | FindFCString | Overloaded.
Method | FindFCStringObject | Overloaded.
Method | FindString | Overloaded.
Method | SupportedLocales |
Method | UpdateCache |

Public Events

 | Name | Description
Event | CacheUpdated |

Reference

IStringCache Interface
FChoice.Foundation.Clarify Namespace


FindFCString Method (IStringCache) | fcSDK Documentation

FindFCString Method (IStringCache)

Overload List

Overload | Description
FindFCString(Int32) |
FindFCString(String,String) |
FindFCString(Int32,CultureInfo) |
FindFCString(String,String,CultureInfo) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStringCache Interface
IStringCache Members


FindFCString(Int32) Method | fcSDK Documentation

FindFCString(Int32) Method

Syntax

'Declaration

Overloads Function FindFCString( _
   ByVal _stringID_ As Integer _
) As String

string FindFCString(
   int _stringID_
)

Parameters

stringID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStringCache Interface
IStringCache Members
Overload List


FindFCString(String,String) Method | fcSDK Documentation

FindFCString(String,String) Method

Syntax

'Declaration

Overloads Function FindFCString( _
   ByVal _applicationName_ As String, _
   ByVal _stringName_ As String _
) As String

string FindFCString(
   string _applicationName_,
   string _stringName_
)

Parameters

applicationName

stringName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStringCache Interface
IStringCache Members
Overload List


FindFCString(Int32,CultureInfo) Method | fcSDK Documentation

FindFCString(Int32,CultureInfo) Method

Syntax

'Declaration

Overloads Function FindFCString( _
   ByVal _stringID_ As Integer, _
   ByVal _culture_ As CultureInfo _
) As String

string FindFCString(
   int _stringID_,
   CultureInfo _culture_
)

Parameters

stringID

culture

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStringCache Interface
IStringCache Members
Overload List


FindFCString(String,String,CultureInfo) Method | fcSDK Documentation

FindFCString(String,String,CultureInfo) Method

Syntax

'Declaration

Overloads Function FindFCString( _
   ByVal _applicationName_ As String, _
   ByVal _stringName_ As String, _
   ByVal _culture_ As CultureInfo _
) As String

string FindFCString(
   string _applicationName_,
   string _stringName_,
   CultureInfo _culture_
)

Parameters

applicationName

stringName

culture

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStringCache Interface
IStringCache Members
Overload List


FindFCStringObject Method (IStringCache) | fcSDK Documentation

FindFCStringObject Method (IStringCache)

Overload List

Overload | Description
FindFCStringObject(Int32,CultureInfo) |
FindFCStringObject(String,String,CultureInfo) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStringCache Interface
IStringCache Members


FindFCStringObject(Int32,CultureInfo) Method | fcSDK Documentation

FindFCStringObject(Int32,CultureInfo) Method

Syntax

'Declaration

Overloads Function FindFCStringObject( _
   ByVal _stringID_ As Integer, _
   ByVal _culture_ As CultureInfo _
) As FCString

FCString FindFCStringObject(
   int _stringID_,
   CultureInfo _culture_
)

Parameters

stringID

culture

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStringCache Interface
IStringCache Members
Overload List


FindFCStringObject(String,String,CultureInfo) Method | fcSDK Documentation

FindFCStringObject(String,String,CultureInfo) Method

Syntax

'Declaration

Overloads Function FindFCStringObject( _
   ByVal _applicationName_ As String, _
   ByVal _stringName_ As String, _
   ByVal _culture_ As CultureInfo _
) As FCString

FCString FindFCStringObject(
   string _applicationName_,
   string _stringName_,
   CultureInfo _culture_
)

Parameters

applicationName

stringName

culture

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStringCache Interface
IStringCache Members
Overload List


FindString Method (IStringCache) | fcSDK Documentation

FindString Method (IStringCache)

Overload List

Overload | Description
FindString(Int32) |
FindString(Int32,String) |
FindString(Int32,Int32) |
FindString(Int32,CultureInfo) |
FindString(String) |
FindString(String,String) |
FindString(String,Int32) |
FindString(String,CultureInfo) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStringCache Interface
IStringCache Members


FindString(Int32) Method | fcSDK Documentation

FindString(Int32) Method

Syntax

'Declaration

Overloads Function FindString( _
   ByVal _stringID_ As Integer _
) As String

string FindString(
   int _stringID_
)

Parameters

stringID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStringCache Interface
IStringCache Members
Overload List


FindString(Int32,String) Method | fcSDK Documentation

FindString(Int32,String) Method

Syntax

'Declaration

Overloads Function FindString( _
   ByVal _stringID_ As Integer, _
   ByVal _culture_ As String _
) As String

string FindString(
   int _stringID_,
   string _culture_
)

Parameters

stringID

culture

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStringCache Interface
IStringCache Members
Overload List


FindString(Int32,Int32) Method | fcSDK Documentation

FindString(Int32,Int32) Method

Syntax

'Declaration

Overloads Function FindString( _
   ByVal _stringID_ As Integer, _
   ByVal _localeID_ As Integer _
) As String

string FindString(
   int _stringID_,
   int _localeID_
)

Parameters

stringID

localeID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStringCache Interface
IStringCache Members
Overload List


FindString(Int32,CultureInfo) Method | fcSDK Documentation

FindString(Int32,CultureInfo) Method

Syntax

'Declaration

Overloads Function FindString( _
   ByVal _stringID_ As Integer, _
   ByVal _culture_ As CultureInfo _
) As String

string FindString(
   int _stringID_,
   CultureInfo _culture_
)

Parameters

stringID

culture

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStringCache Interface
IStringCache Members
Overload List


FindString(String) Method | fcSDK Documentation

FindString(String) Method

Syntax

'Declaration

Overloads Function FindString( _
   ByVal _stringName_ As String _
) As String

string FindString(
   string _stringName_
)

Parameters

stringName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStringCache Interface
IStringCache Members
Overload List


FindString(String,String) Method | fcSDK Documentation

FindString(String,String) Method

Syntax

'Declaration

Overloads Function FindString( _
   ByVal _stringName_ As String, _
   ByVal _culture_ As String _
) As String

string FindString(
   string _stringName_,
   string _culture_
)

Parameters

stringName

culture

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStringCache Interface
IStringCache Members
Overload List


FindString(String,Int32) Method | fcSDK Documentation

FindString(String,Int32) Method

Syntax

'Declaration

Overloads Function FindString( _
   ByVal _stringName_ As String, _
   ByVal _localeID_ As Integer _
) As String

string FindString(
   string _stringName_,
   int _localeID_
)

Parameters

stringName

localeID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStringCache Interface
IStringCache Members
Overload List


FindString(String,CultureInfo) Method | fcSDK Documentation

FindString(String,CultureInfo) Method

Syntax

'Declaration

Overloads Function FindString( _
   ByVal _stringName_ As String, _
   ByVal _culture_ As CultureInfo _
) As String

string FindString(
   string _stringName_,
   CultureInfo _culture_
)

Parameters

stringName

culture

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStringCache Interface
IStringCache Members
Overload List


SupportedLocales Method (IStringCache) | fcSDK Documentation

SupportedLocales Method (IStringCache)

Syntax

'Declaration

Function SupportedLocales() As IEnumerable(Of CultureInfo)

IEnumerable<CultureInfo> SupportedLocales()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStringCache Interface
IStringCache Members


UpdateCache Method (IStringCache) | fcSDK Documentation

UpdateCache Method (IStringCache)

Syntax

'Declaration

Sub UpdateCache()

void UpdateCache()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStringCache Interface
IStringCache Members


CacheSetName Property (IStringCache) | fcSDK Documentation

CacheSetName Property (IStringCache)

Syntax

'Declaration

ReadOnly Property CacheSetName As String

string CacheSetName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStringCache Interface
IStringCache Members


CacheType Property (IStringCache) | fcSDK Documentation

CacheType Property (IStringCache)

Syntax

'Declaration

ReadOnly Property CacheType As CacheType

CacheType CacheType {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStringCache Interface
IStringCache Members


CacheUpdated Event (IStringCache) | fcSDK Documentation

CacheUpdated Event (IStringCache)

Syntax

'Declaration

Event CacheUpdated As EventHandler

event EventHandler CacheUpdated

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IStringCache Interface
IStringCache Members


InitializeStatusChangeEventHandler Delegate | fcSDK Documentation

InitializeStatusChangeEventHandler Delegate

Syntax

'Declaration

Public Delegate Sub InitializeStatusChangeEventHandler( _
   ByVal _statusType_ As InitStatusChangeType _
)

public delegate void InitializeStatusChangeEventHandler(
   InitStatusChangeType _statusType_
)

Parameters

statusType

Requirements

Namespace: FChoice.Foundation.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

InitializeStatusChangeEventHandler Members
FChoice.Foundation.Clarify Namespace


SchemaLoadStatusEventHandler Delegate | fcSDK Documentation

SchemaLoadStatusEventHandler Delegate

Syntax

'Declaration

Public Delegate Sub SchemaLoadStatusEventHandler( _
   ByVal _sender_ As Object, _
   ByVal _newStatus_ As SchemaLoadStatusType _
)

public delegate void SchemaLoadStatusEventHandler(
   object _sender_,
   SchemaLoadStatusType _newStatus_
)

Parameters

sender

newStatus

Requirements

Namespace: FChoice.Foundation.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

SchemaLoadStatusEventHandler Members
FChoice.Foundation.Clarify Namespace


FChoice.Foundation.Clarify.Attributes Namespace | fcSDK Documentation

FChoice.Foundation.Clarify.Attributes Namespace

Classes

 | Class | Description
Class | AltNameAttribute |
Class | AltTypeAttribute |
Class | CheckIsNullAttribute |
Class | FacadePropertyAttribute |
Class | FacadeVoidAttribute |
Class | OutputPropertyAttribute |
Class | ParameterDefaultValueAttribute |
Class | ParameterReadOnlyAttribute |
Class | ParameterRequiredAttribute |
Class | ParameterVoidAttribute |
Class | SplitMethodAttribute |
Class | ToolkitVisibleAttribute |

Reference

fcSDK Assembly


AltNameAttribute Class | fcSDK Documentation

AltNameAttribute Class

Syntax

'Declaration

<AttributeUsageAttribute(ValidOn=AttributeTargets.Class Or  _
    AttributeTargets.Method Or  _
    AttributeTargets.Parameter,
   AllowMultiple=False,
   Inherited=True)>
Public Class AltNameAttribute
   Inherits System.Attribute

[AttributeUsageAttribute(ValidOn=AttributeTargets.Class |
    AttributeTargets.Method |
    AttributeTargets.Parameter,
   AllowMultiple=false,
   Inherited=true)]
public class AltNameAttribute : System.Attribute

Inheritance Hierarchy

System.Object
System.Attribute
FChoice.Foundation.Clarify.Attributes.AltNameAttribute

Requirements

Namespace: FChoice.Foundation.Clarify.Attributes

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

AltNameAttribute Members
FChoice.Foundation.Clarify.Attributes Namespace


AltNameAttribute Class Members | fcSDK Documentation

AltNameAttribute Class Members

The following tables list the members exposed by AltNameAttribute.

Public Constructors

 | Name | Description
Public Constructor | AltNameAttribute Constructor |

Public Fields

 | Name | Description
Public Field | AltName |

Public Properties

 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)

Reference

AltNameAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


AltNameAttribute Constructor | fcSDK Documentation

AltNameAttribute Constructor

Syntax

'Declaration

Public Function New( _
   ByVal _name_ As String _
)

public AltNameAttribute(
   string _name_
)

Parameters

name

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AltNameAttribute Class
AltNameAttribute Members


AltName Field | fcSDK Documentation

AltName Field

Syntax

'Declaration

Public ReadOnly AltName As String

public readonly string AltName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AltNameAttribute Class
AltNameAttribute Members


AltTypeAttribute Class | fcSDK Documentation

AltTypeAttribute Class

Syntax

'Declaration

<AttributeUsageAttribute(ValidOn=AttributeTargets.Parameter,
   AllowMultiple=False,
   Inherited=True)>
Public Class AltTypeAttribute
   Inherits System.Attribute

[AttributeUsageAttribute(ValidOn=AttributeTargets.Parameter,
   AllowMultiple=false,
   Inherited=true)]
public class AltTypeAttribute : System.Attribute

Inheritance Hierarchy

System.Object
System.Attribute
FChoice.Foundation.Clarify.Attributes.AltTypeAttribute

Requirements

Namespace: FChoice.Foundation.Clarify.Attributes

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

AltTypeAttribute Members
FChoice.Foundation.Clarify.Attributes Namespace


AltTypeAttribute Class Members | fcSDK Documentation

AltTypeAttribute Class Members

The following tables list the members exposed by AltTypeAttribute.

Public Constructors

 | Name | Description
Public Constructor | AltTypeAttribute Constructor | Overloaded.

Public Fields

 | Name | Description
Public Field | AltType |
Public Field | ConversionExpression |

Public Properties

 | Name | Description
Public Property | Method |
Public Property | TypeId | (Inherited from System.Attribute)

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)

Reference

AltTypeAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


AltTypeAttribute Constructor | fcSDK Documentation

AltTypeAttribute Constructor

Overload List

Overload | Description
AltTypeAttribute Constructor(String) |
AltTypeAttribute Constructor(String,String) |
AltTypeAttribute Constructor(String,String,String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AltTypeAttribute Class
AltTypeAttribute Members


AltTypeAttribute Constructor(String) | fcSDK Documentation

AltTypeAttribute Constructor(String)

Syntax

'Declaration

Public Function New( _
   ByVal _type_ As String _
)

public AltTypeAttribute(
   string _type_
)

Parameters

type

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AltTypeAttribute Class
AltTypeAttribute Members
Overload List


AltTypeAttribute Constructor(String,String) | fcSDK Documentation

AltTypeAttribute Constructor(String,String)

Syntax

'Declaration

Public Function New( _
   ByVal _type_ As String, _
   ByVal _conversionExpression_ As String _
)

public AltTypeAttribute(
   string _type_,
   string _conversionExpression_
)

Parameters

type

conversionExpression

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AltTypeAttribute Class
AltTypeAttribute Members
Overload List


AltTypeAttribute Constructor(String,String,String) | fcSDK Documentation

AltTypeAttribute Constructor(String,String,String)

Syntax

'Declaration

Public Function New( _
   ByVal _type_ As String, _
   ByVal _conversionExpression_ As String, _
   ByVal _method_ As String _
)

public AltTypeAttribute(
   string _type_,
   string _conversionExpression_,
   string _method_
)

Parameters

type

conversionExpression

method

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AltTypeAttribute Class
AltTypeAttribute Members
Overload List


Method Property (AltTypeAttribute) | fcSDK Documentation

Method Property (AltTypeAttribute)

Syntax

'Declaration

Public ReadOnly Property Method As String

public string Method {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AltTypeAttribute Class
AltTypeAttribute Members


AltType Field | fcSDK Documentation

AltType Field

Syntax

'Declaration

Public ReadOnly AltType As String

public readonly string AltType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AltTypeAttribute Class
AltTypeAttribute Members


ConversionExpression Field | fcSDK Documentation

ConversionExpression Field

Syntax

'Declaration

Public ReadOnly ConversionExpression As String

public readonly string ConversionExpression

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AltTypeAttribute Class
AltTypeAttribute Members


CheckIsNullAttribute Class | fcSDK Documentation

CheckIsNullAttribute Class

Syntax

'Declaration

<AttributeUsageAttribute(ValidOn=AttributeTargets.Parameter,
   AllowMultiple=False,
   Inherited=True)>
Public Class CheckIsNullAttribute
   Inherits System.Attribute

[AttributeUsageAttribute(ValidOn=AttributeTargets.Parameter,
   AllowMultiple=false,
   Inherited=true)]
public class CheckIsNullAttribute : System.Attribute

Inheritance Hierarchy

System.Object
System.Attribute
FChoice.Foundation.Clarify.Attributes.CheckIsNullAttribute

Requirements

Namespace: FChoice.Foundation.Clarify.Attributes

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

CheckIsNullAttribute Members
FChoice.Foundation.Clarify.Attributes Namespace


CheckIsNullAttribute Class Members | fcSDK Documentation

CheckIsNullAttribute Class Members

The following tables list the members exposed by CheckIsNullAttribute.

Public Constructors

 | Name | Description
Public Constructor | CheckIsNullAttribute Constructor |

Public Fields

 | Name | Description
Public Field | ErrorNumber |

Public Properties

 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)

Reference

CheckIsNullAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


CheckIsNullAttribute Constructor | fcSDK Documentation

CheckIsNullAttribute Constructor

Syntax

'Declaration

Public Function New( _
   ByVal _errorNumber_ As Integer _
)

public CheckIsNullAttribute(
   int _errorNumber_
)

Parameters

errorNumber

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CheckIsNullAttribute Class
CheckIsNullAttribute Members


ErrorNumber Field | fcSDK Documentation

ErrorNumber Field

Syntax

'Declaration

Public ReadOnly ErrorNumber As Integer

public readonly int ErrorNumber

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CheckIsNullAttribute Class
CheckIsNullAttribute Members


FacadePropertyAttribute Class | fcSDK Documentation

FacadePropertyAttribute Class

Syntax

'Declaration

<AttributeUsageAttribute(ValidOn=AttributeTargets.Method,
   AllowMultiple=True,
   Inherited=True)>
Public Class FacadePropertyAttribute
   Inherits System.Attribute

[AttributeUsageAttribute(ValidOn=AttributeTargets.Method,
   AllowMultiple=true,
   Inherited=true)]
public class FacadePropertyAttribute : System.Attribute

Inheritance Hierarchy

System.Object
System.Attribute
FChoice.Foundation.Clarify.Attributes.FacadePropertyAttribute

Requirements

Namespace: FChoice.Foundation.Clarify.Attributes

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FacadePropertyAttribute Members
FChoice.Foundation.Clarify.Attributes Namespace


FacadePropertyAttribute Class Members | fcSDK Documentation

FacadePropertyAttribute Class Members

The following tables list the members exposed by FacadePropertyAttribute.

Public Constructors

 | Name | Description
Public Constructor | FacadePropertyAttribute Constructor | Overloaded.

Public Properties

 | Name | Description
Public Property | CheckIsNullErrorNumber |
Public Property | DefaultValue |
Public Property | IsParamArray |
Public Property | MethodName |
Public Property | PropertyName |
Public Property | PropertyType |
Public Property | ReadOnly |
Public Property | Required |
Public Property | SetupExpression |
Public Property | TypeId | (Inherited from System.Attribute)

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | GetParameterIndex |
Public Method | HasConstructorIndex |
Public Method | HasConstructorParameterPair |
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)

Reference

FacadePropertyAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


FacadePropertyAttribute Constructor | fcSDK Documentation

FacadePropertyAttribute Constructor

Overload List

Overload | Description
FacadePropertyAttribute Constructor(String,String,String,String) |
FacadePropertyAttribute Constructor(String,String,String,String,Boolean) |
FacadePropertyAttribute Constructor(String,String,String,String,Boolean,Boolean) |
FacadePropertyAttribute Constructor(String,String,String,String,Boolean,Boolean,String) |
FacadePropertyAttribute Constructor(String,String,String,String,Boolean,Boolean,String,String) |
FacadePropertyAttribute Constructor(String,String,String,String,Boolean,Boolean,String,String,Int32) |
FacadePropertyAttribute Constructor(String,String,String,String,Boolean,Boolean,String,String,Int32,Boolean) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FacadePropertyAttribute Class
FacadePropertyAttribute Members


FacadePropertyAttribute Constructor(String,String,String,String) | fcSDK Documentation

FacadePropertyAttribute Constructor(String,String,String,String)

Syntax

'Declaration

Public Function New( _
   ByVal _propertyName_ As String, _
   ByVal _propertyType_ As String, _
   ByVal _defaultValue_ As String, _
   ByVal _setupExpression_ As String _
)

public FacadePropertyAttribute(
   string _propertyName_,
   string _propertyType_,
   string _defaultValue_,
   string _setupExpression_
)

Parameters

propertyName

propertyType

defaultValue

setupExpression

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FacadePropertyAttribute Class
FacadePropertyAttribute Members
Overload List


FacadePropertyAttribute Constructor(String,String,String,String,Boolean) | fcSDK Documentation

FacadePropertyAttribute Constructor(String,String,String,String,Boolean)

Syntax

'Declaration

Public Function New( _
   ByVal _propertyName_ As String, _
   ByVal _propertyType_ As String, _
   ByVal _defaultValue_ As String, _
   ByVal _setupExpression_ As String, _
   ByVal _required_ As Boolean _
)

public FacadePropertyAttribute(
   string _propertyName_,
   string _propertyType_,
   string _defaultValue_,
   string _setupExpression_,
   bool _required_
)

Parameters

propertyName

propertyType

defaultValue

setupExpression

required

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FacadePropertyAttribute Class
FacadePropertyAttribute Members
Overload List


FacadePropertyAttribute Constructor(String,String,String,String,Boolean,Boolean) | fcSDK Documentation

FacadePropertyAttribute Constructor(String,String,String,String,Boolean,Boolean)

Syntax

'Declaration

Public Function New( _
   ByVal _propertyName_ As String, _
   ByVal _propertyType_ As String, _
   ByVal _defaultValue_ As String, _
   ByVal _setupExpression_ As String, _
   ByVal _required_ As Boolean, _
   ByVal _isParamArray_ As Boolean _
)

public FacadePropertyAttribute(
   string _propertyName_,
   string _propertyType_,
   string _defaultValue_,
   string _setupExpression_,
   bool _required_,
   bool _isParamArray_
)

Parameters

propertyName

propertyType

defaultValue

setupExpression

required

isParamArray

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FacadePropertyAttribute Class
FacadePropertyAttribute Members
Overload List


FacadePropertyAttribute Constructor(String,String,String,String,Boolean,Boolean,String) | fcSDK Documentation

FacadePropertyAttribute Constructor(String,String,String,String,Boolean,Boolean,String)

Syntax

'Declaration

Public Function New( _
   ByVal _propertyName_ As String, _
   ByVal _propertyType_ As String, _
   ByVal _defaultValue_ As String, _
   ByVal _setupExpression_ As String, _
   ByVal _required_ As Boolean, _
   ByVal _isParamArray_ As Boolean, _
   ByVal _methodName_ As String _
)

public FacadePropertyAttribute(
   string _propertyName_,
   string _propertyType_,
   string _defaultValue_,
   string _setupExpression_,
   bool _required_,
   bool _isParamArray_,
   string _methodName_
)

Parameters

propertyName

propertyType

defaultValue

setupExpression

required

isParamArray

methodName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FacadePropertyAttribute Class
FacadePropertyAttribute Members
Overload List


FacadePropertyAttribute Constructor(String,String,String,String,Boolean,Boolean,String,String) | fcSDK Documentation

FacadePropertyAttribute Constructor(String,String,String,String,Boolean,Boolean,String,String)

Syntax

'Declaration

Public Function New( _
   ByVal _propertyName_ As String, _
   ByVal _propertyType_ As String, _
   ByVal _defaultValue_ As String, _
   ByVal _setupExpression_ As String, _
   ByVal _required_ As Boolean, _
   ByVal _isParamArray_ As Boolean, _
   ByVal _methodName_ As String, _
   ByVal _indexes_ As String _
)

public FacadePropertyAttribute(
   string _propertyName_,
   string _propertyType_,
   string _defaultValue_,
   string _setupExpression_,
   bool _required_,
   bool _isParamArray_,
   string _methodName_,
   string _indexes_
)

Parameters

propertyName

propertyType

defaultValue

setupExpression

required

isParamArray

methodName

indexes

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FacadePropertyAttribute Class
FacadePropertyAttribute Members
Overload List


FacadePropertyAttribute Constructor(String,String,String,String,Boolean,Boolean,String,String,Int32) | fcSDK Documentation

FacadePropertyAttribute Constructor(String,String,String,String,Boolean,Boolean,String,String,Int32)

Syntax

'Declaration

Public Function New( _
   ByVal _propertyName_ As String, _
   ByVal _propertyType_ As String, _
   ByVal _defaultValue_ As String, _
   ByVal _setupExpression_ As String, _
   ByVal _required_ As Boolean, _
   ByVal _isParamArray_ As Boolean, _
   ByVal _methodName_ As String, _
   ByVal _indexes_ As String, _
   ByVal _checkIsNullErrorNumber_ As Integer _
)

public FacadePropertyAttribute(
   string _propertyName_,
   string _propertyType_,
   string _defaultValue_,
   string _setupExpression_,
   bool _required_,
   bool _isParamArray_,
   string _methodName_,
   string _indexes_,
   int _checkIsNullErrorNumber_
)

Parameters

propertyName

propertyType

defaultValue

setupExpression

required

isParamArray

methodName

indexes

checkIsNullErrorNumber

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FacadePropertyAttribute Class
FacadePropertyAttribute Members
Overload List


FacadePropertyAttribute Constructor(String,String,String,String,Boolean,Boolean,String,String,Int32,Boolean) | fcSDK Documentation

FacadePropertyAttribute Constructor(String,String,String,String,Boolean,Boolean,String,String,Int32,Boolean)

Syntax

'Declaration

Public Function New( _
   ByVal _propertyName_ As String, _
   ByVal _propertyType_ As String, _
   ByVal _defaultValue_ As String, _
   ByVal _setupExpression_ As String, _
   ByVal _required_ As Boolean, _
   ByVal _isParamArray_ As Boolean, _
   ByVal _methodName_ As String, _
   ByVal _indexes_ As String, _
   ByVal _checkIsNullErrorNumber_ As Integer, _
   ByVal _readOnly_ As Boolean _
)

public FacadePropertyAttribute(
   string _propertyName_,
   string _propertyType_,
   string _defaultValue_,
   string _setupExpression_,
   bool _required_,
   bool _isParamArray_,
   string _methodName_,
   string _indexes_,
   int _checkIsNullErrorNumber_,
   bool _readOnly_
)

Parameters

propertyName

propertyType

defaultValue

setupExpression

required

isParamArray

methodName

indexes

checkIsNullErrorNumber

readOnly

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FacadePropertyAttribute Class
FacadePropertyAttribute Members
Overload List


GetParameterIndex Method | fcSDK Documentation

GetParameterIndex Method

Syntax

'Declaration

Public Function GetParameterIndex( _
   ByVal _constructorIndex_ As Integer _
) As Integer

public int GetParameterIndex(
   int _constructorIndex_
)

Parameters

constructorIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FacadePropertyAttribute Class
FacadePropertyAttribute Members


HasConstructorIndex Method | fcSDK Documentation

HasConstructorIndex Method

Syntax

'Declaration

Public Function HasConstructorIndex( _
   ByVal _constructorIndex_ As Integer _
) As Boolean

public bool HasConstructorIndex(
   int _constructorIndex_
)

Parameters

constructorIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FacadePropertyAttribute Class
FacadePropertyAttribute Members


HasConstructorParameterPair Method | fcSDK Documentation

HasConstructorParameterPair Method

Syntax

'Declaration

Public Function HasConstructorParameterPair( _
   ByVal _constructorIndex_ As Integer, _
   ByVal _parameterIndex_ As Integer _
) As Boolean

public bool HasConstructorParameterPair(
   int _constructorIndex_,
   int _parameterIndex_
)

Parameters

constructorIndex

parameterIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FacadePropertyAttribute Class
FacadePropertyAttribute Members


CheckIsNullErrorNumber Property | fcSDK Documentation

CheckIsNullErrorNumber Property

Syntax

'Declaration

Public ReadOnly Property CheckIsNullErrorNumber As Integer

public int CheckIsNullErrorNumber {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FacadePropertyAttribute Class
FacadePropertyAttribute Members


DefaultValue Property (FacadePropertyAttribute) | fcSDK Documentation

DefaultValue Property (FacadePropertyAttribute)

Syntax

'Declaration

Public ReadOnly Property DefaultValue As String

public string DefaultValue {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FacadePropertyAttribute Class
FacadePropertyAttribute Members


IsParamArray Property (FacadePropertyAttribute) | fcSDK Documentation

IsParamArray Property (FacadePropertyAttribute)

Syntax

'Declaration

Public ReadOnly Property IsParamArray As Boolean

public bool IsParamArray {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FacadePropertyAttribute Class
FacadePropertyAttribute Members


MethodName Property (FacadePropertyAttribute) | fcSDK Documentation

MethodName Property (FacadePropertyAttribute)

Syntax

'Declaration

Public ReadOnly Property MethodName As String

public string MethodName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FacadePropertyAttribute Class
FacadePropertyAttribute Members


PropertyName Property (FacadePropertyAttribute) | fcSDK Documentation

PropertyName Property (FacadePropertyAttribute)

Syntax

'Declaration

Public ReadOnly Property PropertyName As String

public string PropertyName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FacadePropertyAttribute Class
FacadePropertyAttribute Members


PropertyType Property | fcSDK Documentation

PropertyType Property

Syntax

'Declaration

Public ReadOnly Property PropertyType As String

public string PropertyType {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FacadePropertyAttribute Class
FacadePropertyAttribute Members


ReadOnly Property | fcSDK Documentation

ReadOnly Property

Syntax

'Declaration

Public ReadOnly Property ReadOnly As Boolean

public bool ReadOnly {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FacadePropertyAttribute Class
FacadePropertyAttribute Members


Required Property | fcSDK Documentation

Required Property

Syntax

'Declaration

Public ReadOnly Property Required As Boolean

public bool Required {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FacadePropertyAttribute Class
FacadePropertyAttribute Members


SetupExpression Property | fcSDK Documentation

SetupExpression Property

Syntax

'Declaration

Public ReadOnly Property SetupExpression As String

public string SetupExpression {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FacadePropertyAttribute Class
FacadePropertyAttribute Members


FacadeVoidAttribute Class | fcSDK Documentation

FacadeVoidAttribute Class

Syntax

'Declaration

<AttributeUsageAttribute(ValidOn=AttributeTargets.Method,
   AllowMultiple=False,
   Inherited=True)>
Public Class FacadeVoidAttribute
   Inherits System.Attribute

[AttributeUsageAttribute(ValidOn=AttributeTargets.Method,
   AllowMultiple=false,
   Inherited=true)]
public class FacadeVoidAttribute : System.Attribute

Inheritance Hierarchy

System.Object
System.Attribute
FChoice.Foundation.Clarify.Attributes.FacadeVoidAttribute

Requirements

Namespace: FChoice.Foundation.Clarify.Attributes

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FacadeVoidAttribute Members
FChoice.Foundation.Clarify.Attributes Namespace


FacadeVoidAttribute Class Members | fcSDK Documentation

FacadeVoidAttribute Class Members

The following tables list the members exposed by FacadeVoidAttribute.

Public Constructors

 | Name | Description
Public Constructor | FacadeVoidAttribute Constructor | Overloaded.

Public Fields

 | Name | Description
Public Field | IsVoid |

Public Properties

 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)

Reference

FacadeVoidAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


FacadeVoidAttribute Constructor | fcSDK Documentation

FacadeVoidAttribute Constructor

Overload List

Overload | Description
FacadeVoidAttribute Constructor(Boolean) |
FacadeVoidAttribute Constructor() |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FacadeVoidAttribute Class
FacadeVoidAttribute Members


FacadeVoidAttribute Constructor(Boolean) | fcSDK Documentation

FacadeVoidAttribute Constructor(Boolean)

Syntax

'Declaration

Public Function New( _
   ByVal _isVoid_ As Boolean _
)

public FacadeVoidAttribute(
   bool _isVoid_
)

Parameters

isVoid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FacadeVoidAttribute Class
FacadeVoidAttribute Members
Overload List


FacadeVoidAttribute Constructor() | fcSDK Documentation

FacadeVoidAttribute Constructor()

Syntax

'Declaration

Public Function New()

public FacadeVoidAttribute()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FacadeVoidAttribute Class
FacadeVoidAttribute Members
Overload List


IsVoid Field (FacadeVoidAttribute) | fcSDK Documentation

IsVoid Field (FacadeVoidAttribute)

Syntax

'Declaration

Public ReadOnly IsVoid As Boolean

public readonly bool IsVoid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FacadeVoidAttribute Class
FacadeVoidAttribute Members


OutputPropertyAttribute Class | fcSDK Documentation

OutputPropertyAttribute Class

Syntax

'Declaration

<AttributeUsageAttribute(ValidOn=AttributeTargets.Method,
   AllowMultiple=True,
   Inherited=True)>
Public Class OutputPropertyAttribute
   Inherits System.Attribute

[AttributeUsageAttribute(ValidOn=AttributeTargets.Method,
   AllowMultiple=true,
   Inherited=true)]
public class OutputPropertyAttribute : System.Attribute

Inheritance Hierarchy

System.Object
System.Attribute
FChoice.Foundation.Clarify.Attributes.OutputPropertyAttribute

Requirements

Namespace: FChoice.Foundation.Clarify.Attributes

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

OutputPropertyAttribute Members
FChoice.Foundation.Clarify.Attributes Namespace


OutputPropertyAttribute Class Members | fcSDK Documentation

OutputPropertyAttribute Class Members

The following tables list the members exposed by OutputPropertyAttribute.

Public Constructors

 | Name | Description
Public Constructor | OutputPropertyAttribute Constructor | Overloaded.

Public Properties

 | Name | Description
Public Property | DocSummary |
Public Property | FacadeDefaultValue |
Public Property | FacadePropertyName |
Public Property | FacadeType |
Public Property | MethodName |
Public Property | PropertyName |
Public Property | TypeConversionExpression |
Public Property | TypeId | (Inherited from System.Attribute)

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)

Reference

OutputPropertyAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


OutputPropertyAttribute Constructor | fcSDK Documentation

OutputPropertyAttribute Constructor

Overload List

Overload | Description
OutputPropertyAttribute Constructor(String) |
OutputPropertyAttribute Constructor(String,String) |
OutputPropertyAttribute Constructor(String,String,String,String,String) |
OutputPropertyAttribute Constructor(String,String,String,String,String,String) |
OutputPropertyAttribute Constructor(String,String,String,String,String,String,String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OutputPropertyAttribute Class
OutputPropertyAttribute Members


OutputPropertyAttribute Constructor(String) | fcSDK Documentation

OutputPropertyAttribute Constructor(String)

Syntax

'Declaration

Public Function New( _
   ByVal _propertyName_ As String _
)

public OutputPropertyAttribute(
   string _propertyName_
)

Parameters

propertyName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OutputPropertyAttribute Class
OutputPropertyAttribute Members
Overload List


OutputPropertyAttribute Constructor(String,String) | fcSDK Documentation

OutputPropertyAttribute Constructor(String,String)

Syntax

'Declaration

Public Function New( _
   ByVal _propertyName_ As String, _
   ByVal _docSummary_ As String _
)

public OutputPropertyAttribute(
   string _propertyName_,
   string _docSummary_
)

Parameters

propertyName

docSummary

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OutputPropertyAttribute Class
OutputPropertyAttribute Members
Overload List


OutputPropertyAttribute Constructor(String,String,String,String,String) | fcSDK Documentation

OutputPropertyAttribute Constructor(String,String,String,String,String)

Syntax

'Declaration

Public Function New( _
   ByVal _propertyName_ As String, _
   ByVal _facadePropertyName_ As String, _
   ByVal _facadeType_ As String, _
   ByVal _facadeDefaultValue_ As String, _
   ByVal _docSummary_ As String _
)

public OutputPropertyAttribute(
   string _propertyName_,
   string _facadePropertyName_,
   string _facadeType_,
   string _facadeDefaultValue_,
   string _docSummary_
)

Parameters

propertyName

facadePropertyName

facadeType

facadeDefaultValue

docSummary

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OutputPropertyAttribute Class
OutputPropertyAttribute Members
Overload List


OutputPropertyAttribute Constructor(String,String,String,String,String,String) | fcSDK Documentation

OutputPropertyAttribute Constructor(String,String,String,String,String,String)

Syntax

'Declaration

Public Function New( _
   ByVal _propertyName_ As String, _
   ByVal _facadePropertyName_ As String, _
   ByVal _facadeType_ As String, _
   ByVal _facadeDefaultValue_ As String, _
   ByVal _docSummary_ As String, _
   ByVal _typeConversionExpression_ As String _
)

public OutputPropertyAttribute(
   string _propertyName_,
   string _facadePropertyName_,
   string _facadeType_,
   string _facadeDefaultValue_,
   string _docSummary_,
   string _typeConversionExpression_
)

Parameters

propertyName

facadePropertyName

facadeType

facadeDefaultValue

docSummary

typeConversionExpression

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OutputPropertyAttribute Class
OutputPropertyAttribute Members
Overload List


OutputPropertyAttribute Constructor(String,String,String,String,String,String,String) | fcSDK Documentation

OutputPropertyAttribute Constructor(String,String,String,String,String,String,String)

Syntax

'Declaration

Public Function New( _
   ByVal _propertyName_ As String, _
   ByVal _facadePropertyName_ As String, _
   ByVal _facadeType_ As String, _
   ByVal _facadeDefaultValue_ As String, _
   ByVal _docSummary_ As String, _
   ByVal _typeConversionExpression_ As String, _
   ByVal _methodName_ As String _
)

public OutputPropertyAttribute(
   string _propertyName_,
   string _facadePropertyName_,
   string _facadeType_,
   string _facadeDefaultValue_,
   string _docSummary_,
   string _typeConversionExpression_,
   string _methodName_
)

Parameters

propertyName

facadePropertyName

facadeType

facadeDefaultValue

docSummary

typeConversionExpression

methodName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OutputPropertyAttribute Class
OutputPropertyAttribute Members
Overload List


DocSummary Property (OutputPropertyAttribute) | fcSDK Documentation

DocSummary Property (OutputPropertyAttribute)

Syntax

'Declaration

Public ReadOnly Property DocSummary As String

public string DocSummary {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OutputPropertyAttribute Class
OutputPropertyAttribute Members


FacadeDefaultValue Property | fcSDK Documentation

FacadeDefaultValue Property

Syntax

'Declaration

Public ReadOnly Property FacadeDefaultValue As String

public string FacadeDefaultValue {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OutputPropertyAttribute Class
OutputPropertyAttribute Members


FacadePropertyName Property | fcSDK Documentation

FacadePropertyName Property

Syntax

'Declaration

Public ReadOnly Property FacadePropertyName As String

public string FacadePropertyName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OutputPropertyAttribute Class
OutputPropertyAttribute Members


FacadeType Property | fcSDK Documentation

FacadeType Property

Syntax

'Declaration

Public ReadOnly Property FacadeType As String

public string FacadeType {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OutputPropertyAttribute Class
OutputPropertyAttribute Members


MethodName Property (OutputPropertyAttribute) | fcSDK Documentation

MethodName Property (OutputPropertyAttribute)

Syntax

'Declaration

Public ReadOnly Property MethodName As String

public string MethodName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OutputPropertyAttribute Class
OutputPropertyAttribute Members


PropertyName Property (OutputPropertyAttribute) | fcSDK Documentation

PropertyName Property (OutputPropertyAttribute)

Syntax

'Declaration

Public ReadOnly Property PropertyName As String

public string PropertyName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OutputPropertyAttribute Class
OutputPropertyAttribute Members


TypeConversionExpression Property | fcSDK Documentation

TypeConversionExpression Property

Syntax

'Declaration

Public ReadOnly Property TypeConversionExpression As String

public string TypeConversionExpression {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OutputPropertyAttribute Class
OutputPropertyAttribute Members


ParameterDefaultValueAttribute Class | fcSDK Documentation

ParameterDefaultValueAttribute Class

Syntax

'Declaration

<AttributeUsageAttribute(ValidOn=AttributeTargets.Parameter,
   AllowMultiple=True,
   Inherited=True)>
Public Class ParameterDefaultValueAttribute
   Inherits System.Attribute

[AttributeUsageAttribute(ValidOn=AttributeTargets.Parameter,
   AllowMultiple=true,
   Inherited=true)]
public class ParameterDefaultValueAttribute : System.Attribute

Inheritance Hierarchy

System.Object
System.Attribute
FChoice.Foundation.Clarify.Attributes.ParameterDefaultValueAttribute

Requirements

Namespace: FChoice.Foundation.Clarify.Attributes

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ParameterDefaultValueAttribute Members
FChoice.Foundation.Clarify.Attributes Namespace


ParameterDefaultValueAttribute Class Members | fcSDK Documentation

ParameterDefaultValueAttribute Class Members

The following tables list the members exposed by ParameterDefaultValueAttribute.

Public Constructors

 | Name | Description
Public Constructor | ParameterDefaultValueAttribute Constructor | Overloaded.

Public Fields

 | Name | Description
Public Field | method |
Public Field | parameterDefaultValue |

Public Properties

 | Name | Description
Public Property | Method |
Public Property | ParameterDefaultValue |
Public Property | TypeId | (Inherited from System.Attribute)

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)

Reference

ParameterDefaultValueAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


ParameterDefaultValueAttribute Constructor | fcSDK Documentation

ParameterDefaultValueAttribute Constructor

Overload List

Overload | Description
ParameterDefaultValueAttribute Constructor(String) |
ParameterDefaultValueAttribute Constructor(String,String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ParameterDefaultValueAttribute Class
ParameterDefaultValueAttribute Members


ParameterDefaultValueAttribute Constructor(String) | fcSDK Documentation

ParameterDefaultValueAttribute Constructor(String)

Syntax

'Declaration

Public Function New( _
   ByVal _defaultValue_ As String _
)

public ParameterDefaultValueAttribute(
   string _defaultValue_
)

Parameters

defaultValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ParameterDefaultValueAttribute Class
ParameterDefaultValueAttribute Members
Overload List


ParameterDefaultValueAttribute Constructor(String,String) | fcSDK Documentation

ParameterDefaultValueAttribute Constructor(String,String)

Syntax

'Declaration

Public Function New( _
   ByVal _defaultValue_ As String, _
   ByVal _method_ As String _
)

public ParameterDefaultValueAttribute(
   string _defaultValue_,
   string _method_
)

Parameters

defaultValue

method

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ParameterDefaultValueAttribute Class
ParameterDefaultValueAttribute Members
Overload List


method Field (ParameterDefaultValueAttribute) | fcSDK Documentation

method Field (ParameterDefaultValueAttribute)

Syntax

'Declaration

Public ReadOnly method As String

public readonly string method

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ParameterDefaultValueAttribute Class
ParameterDefaultValueAttribute Members


parameterDefaultValue Field | fcSDK Documentation

parameterDefaultValue Field

Syntax

'Declaration

Public ReadOnly parameterDefaultValue As String

public readonly string parameterDefaultValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ParameterDefaultValueAttribute Class
ParameterDefaultValueAttribute Members


ParameterReadOnlyAttribute Class | fcSDK Documentation

ParameterReadOnlyAttribute Class

Syntax

'Declaration

<AttributeUsageAttribute(ValidOn=AttributeTargets.Parameter,
   AllowMultiple=False,
   Inherited=True)>
Public Class ParameterReadOnlyAttribute
   Inherits System.Attribute

[AttributeUsageAttribute(ValidOn=AttributeTargets.Parameter,
   AllowMultiple=false,
   Inherited=true)]
public class ParameterReadOnlyAttribute : System.Attribute

Inheritance Hierarchy

System.Object
System.Attribute
FChoice.Foundation.Clarify.Attributes.ParameterReadOnlyAttribute

Requirements

Namespace: FChoice.Foundation.Clarify.Attributes

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ParameterReadOnlyAttribute Members
FChoice.Foundation.Clarify.Attributes Namespace


ParameterReadOnlyAttribute Class Members | fcSDK Documentation

ParameterReadOnlyAttribute Class Members

The following tables list the members exposed by ParameterReadOnlyAttribute.

Public Constructors

 | Name | Description
Public Constructor | ParameterReadOnlyAttribute Constructor |

Public Properties

 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)

Reference

ParameterReadOnlyAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


ParameterReadOnlyAttribute Constructor | fcSDK Documentation

ParameterReadOnlyAttribute Constructor

Syntax

'Declaration

Public Function New()

public ParameterReadOnlyAttribute()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ParameterReadOnlyAttribute Class
ParameterReadOnlyAttribute Members


ParameterRequiredAttribute Class | fcSDK Documentation

ParameterRequiredAttribute Class

Syntax

'Declaration

<AttributeUsageAttribute(ValidOn=AttributeTargets.Parameter,
   AllowMultiple=True,
   Inherited=True)>
Public Class ParameterRequiredAttribute
   Inherits System.Attribute

[AttributeUsageAttribute(ValidOn=AttributeTargets.Parameter,
   AllowMultiple=true,
   Inherited=true)]
public class ParameterRequiredAttribute : System.Attribute

Inheritance Hierarchy

System.Object
System.Attribute
FChoice.Foundation.Clarify.Attributes.ParameterRequiredAttribute

Requirements

Namespace: FChoice.Foundation.Clarify.Attributes

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ParameterRequiredAttribute Members
FChoice.Foundation.Clarify.Attributes Namespace


ParameterRequiredAttribute Class Members | fcSDK Documentation

ParameterRequiredAttribute Class Members

The following tables list the members exposed by ParameterRequiredAttribute.

Public Constructors

 | Name | Description
Public Constructor | ParameterRequiredAttribute Constructor | Overloaded.

Public Fields

 | Name | Description
Public Field | constructorIndex |
Public Field | isParamArray |
Public Field | positionIndex |

Public Properties

 | Name | Description
Public Property | ConstructorIndex |
Public Property | IsParamArray |
Public Property | IsRequired |
Public Property | Method |
Public Property | PositionIndex |
Public Property | TypeId | (Inherited from System.Attribute)

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)

Reference

ParameterRequiredAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


ParameterRequiredAttribute Constructor | fcSDK Documentation

ParameterRequiredAttribute Constructor

Overload List

Overload | Description
ParameterRequiredAttribute Constructor() |
ParameterRequiredAttribute Constructor(Boolean) |
ParameterRequiredAttribute Constructor(String) |
ParameterRequiredAttribute Constructor(Boolean,String) |
ParameterRequiredAttribute Constructor(Boolean,String,Int32) |
ParameterRequiredAttribute Constructor(String,Int32) |
ParameterRequiredAttribute Constructor(Boolean,String,Int32,Int32) |
ParameterRequiredAttribute Constructor(Boolean,String,Int32,Int32,Boolean) |
ParameterRequiredAttribute Constructor(String,Int32,Int32) |
ParameterRequiredAttribute Constructor(String,Int32,Int32,Boolean) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ParameterRequiredAttribute Class
ParameterRequiredAttribute Members


ParameterRequiredAttribute Constructor() | fcSDK Documentation

ParameterRequiredAttribute Constructor()

Syntax

'Declaration

Public Function New()

public ParameterRequiredAttribute()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ParameterRequiredAttribute Class
ParameterRequiredAttribute Members
Overload List


ParameterRequiredAttribute Constructor(Boolean) | fcSDK Documentation

ParameterRequiredAttribute Constructor(Boolean)

Syntax

'Declaration

Public Function New( _
   ByVal _isRequired_ As Boolean _
)

public ParameterRequiredAttribute(
   bool _isRequired_
)

Parameters

isRequired

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ParameterRequiredAttribute Class
ParameterRequiredAttribute Members
Overload List


ParameterRequiredAttribute Constructor(String) | fcSDK Documentation

ParameterRequiredAttribute Constructor(String)

Syntax

'Declaration

Public Function New( _
   ByVal _method_ As String _
)

public ParameterRequiredAttribute(
   string _method_
)

Parameters

method

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ParameterRequiredAttribute Class
ParameterRequiredAttribute Members
Overload List


ParameterRequiredAttribute Constructor(Boolean,String) | fcSDK Documentation

ParameterRequiredAttribute Constructor(Boolean,String)

Syntax

'Declaration

Public Function New( _
   ByVal _isReq_ As Boolean, _
   ByVal _method_ As String _
)

public ParameterRequiredAttribute(
   bool _isReq_,
   string _method_
)

Parameters

isReq

method

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ParameterRequiredAttribute Class
ParameterRequiredAttribute Members
Overload List


ParameterRequiredAttribute Constructor(Boolean,String,Int32) | fcSDK Documentation

ParameterRequiredAttribute Constructor(Boolean,String,Int32)

Syntax

'Declaration

Public Function New( _
   ByVal _isReq_ As Boolean, _
   ByVal _method_ As String, _
   ByVal _constructorIndex_ As Integer _
)

public ParameterRequiredAttribute(
   bool _isReq_,
   string _method_,
   int _constructorIndex_
)

Parameters

isReq

method

constructorIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ParameterRequiredAttribute Class
ParameterRequiredAttribute Members
Overload List


ParameterRequiredAttribute Constructor(String,Int32) | fcSDK Documentation

ParameterRequiredAttribute Constructor(String,Int32)

```csharp
#### Syntax

```vbnet
'Declaration

Public Function New( _
   ByVal _method_ As String, _
   ByVal _constructorIndex_ As Integer _
)

public ParameterRequiredAttribute(
   string _method_,
   int _constructorIndex_
)

Parameters

method

constructorIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ParameterRequiredAttribute Class
ParameterRequiredAttribute Members
Overload List


ParameterRequiredAttribute Constructor(Boolean,String,Int32,Int32) | fcSDK Documentation

ParameterRequiredAttribute Constructor(Boolean,String,Int32,Int32)

Syntax

'Declaration

Public Function New( _
   ByVal _isReq_ As Boolean, _
   ByVal _method_ As String, _
   ByVal _constructorIndex_ As Integer, _
   ByVal _positionIndex_ As Integer _
)

public ParameterRequiredAttribute(
   bool _isReq_,
   string _method_,
   int _constructorIndex_,
   int _positionIndex_
)

Parameters

isReq

method

constructorIndex

positionIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ParameterRequiredAttribute Class
ParameterRequiredAttribute Members
Overload List


ParameterRequiredAttribute Constructor(Boolean,String,Int32,Int32,Boolean) | fcSDK Documentation

ParameterRequiredAttribute Constructor(Boolean,String,Int32,Int32,Boolean)

Syntax

'Declaration

Public Function New( _
   ByVal _isReq_ As Boolean, _
   ByVal _method_ As String, _
   ByVal _constructorIndex_ As Integer, _
   ByVal _positionIndex_ As Integer, _
   ByVal _isParamArray_ As Boolean _
)

public ParameterRequiredAttribute(
   bool _isReq_,
   string _method_,
   int _constructorIndex_,
   int _positionIndex_,
   bool _isParamArray_
)

Parameters

isReq

method

constructorIndex

positionIndex

isParamArray

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ParameterRequiredAttribute Class
ParameterRequiredAttribute Members
Overload List


ParameterRequiredAttribute Constructor(String,Int32,Int32) | fcSDK Documentation

ParameterRequiredAttribute Constructor(String,Int32,Int32)

```csharp
#### Syntax

```vbnet
'Declaration

Public Function New( _
   ByVal _method_ As String, _
   ByVal _constructorIndex_ As Integer, _
   ByVal _positionIndex_ As Integer _
)

public ParameterRequiredAttribute(
   string _method_,
   int _constructorIndex_,
   int _positionIndex_
)

Parameters

method

constructorIndex

positionIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ParameterRequiredAttribute Class
ParameterRequiredAttribute Members
Overload List


ParameterRequiredAttribute Constructor(String,Int32,Int32,Boolean) | fcSDK Documentation

ParameterRequiredAttribute Constructor(String,Int32,Int32,Boolean)

Syntax

'Declaration

Public Function New( _
   ByVal _method_ As String, _
   ByVal _constructorIndex_ As Integer, _
   ByVal _positionIndex_ As Integer, _
   ByVal _isParamArray_ As Boolean _
)

public ParameterRequiredAttribute(
   string _method_,
   int _constructorIndex_,
   int _positionIndex_,
   bool _isParamArray_
)

Parameters

method

constructorIndex

positionIndex

isParamArray

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ParameterRequiredAttribute Class
ParameterRequiredAttribute Members
Overload List


constructorIndex Field | fcSDK Documentation

constructorIndex Field

Syntax

'Declaration

Public ReadOnly constructorIndex As Integer

public readonly int constructorIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ParameterRequiredAttribute Class
ParameterRequiredAttribute Members


isParamArray Field | fcSDK Documentation

isParamArray Field

Syntax

'Declaration

Public ReadOnly isParamArray As Boolean

public readonly bool isParamArray

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ParameterRequiredAttribute Class
ParameterRequiredAttribute Members


IsRequired Property (ParameterRequiredAttribute) | fcSDK Documentation

IsRequired Property (ParameterRequiredAttribute)

Syntax

'Declaration

Public ReadOnly Property IsRequired As Boolean

public bool IsRequired {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ParameterRequiredAttribute Class
ParameterRequiredAttribute Members


Method Property (ParameterRequiredAttribute) | fcSDK Documentation

Method Property (ParameterRequiredAttribute)

Syntax

'Declaration

Public ReadOnly Property Method As String

public string Method {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ParameterRequiredAttribute Class
ParameterRequiredAttribute Members


positionIndex Field | fcSDK Documentation

positionIndex Field

Syntax

'Declaration

Public ReadOnly positionIndex As Integer

public readonly int positionIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ParameterRequiredAttribute Class
ParameterRequiredAttribute Members


ParameterVoidAttribute Class | fcSDK Documentation

ParameterVoidAttribute Class

Syntax

'Declaration

<AttributeUsageAttribute(ValidOn=AttributeTargets.Parameter,
   AllowMultiple=True,
   Inherited=True)>
Public Class ParameterVoidAttribute
   Inherits System.Attribute

[AttributeUsageAttribute(ValidOn=AttributeTargets.Parameter,
   AllowMultiple=true,
   Inherited=true)]
public class ParameterVoidAttribute : System.Attribute

Inheritance Hierarchy

System.Object
System.Attribute
FChoice.Foundation.Clarify.Attributes.ParameterVoidAttribute

Requirements

Namespace: FChoice.Foundation.Clarify.Attributes

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ParameterVoidAttribute Members
FChoice.Foundation.Clarify.Attributes Namespace


ParameterVoidAttribute Class Members | fcSDK Documentation

ParameterVoidAttribute Class Members

The following tables list the members exposed by ParameterVoidAttribute.

Public Constructors

 | Name | Description
Public Constructor | ParameterVoidAttribute Constructor | Overloaded.

Public Fields

 | Name | Description
Public Field | isVoid |
Public Field | method |

Public Properties

 | Name | Description
Public Property | IsVoid |
Public Property | Method |
Public Property | TypeId | (Inherited from System.Attribute)

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)

Reference

ParameterVoidAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


ParameterVoidAttribute Constructor | fcSDK Documentation

ParameterVoidAttribute Constructor

Overload List

Overload | Description
ParameterVoidAttribute Constructor() |
ParameterVoidAttribute Constructor(Boolean) |
ParameterVoidAttribute Constructor(String) |
ParameterVoidAttribute Constructor(Boolean,String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ParameterVoidAttribute Class
ParameterVoidAttribute Members


ParameterVoidAttribute Constructor() | fcSDK Documentation

ParameterVoidAttribute Constructor()

Syntax

'Declaration

Public Function New()

public ParameterVoidAttribute()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ParameterVoidAttribute Class
ParameterVoidAttribute Members
Overload List


ParameterVoidAttribute Constructor(Boolean) | fcSDK Documentation

ParameterVoidAttribute Constructor(Boolean)

Syntax

'Declaration

Public Function New( _
   ByVal _isVoid_ As Boolean _
)

public ParameterVoidAttribute(
   bool _isVoid_
)

Parameters

isVoid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ParameterVoidAttribute Class
ParameterVoidAttribute Members
Overload List


ParameterVoidAttribute Constructor(String) | fcSDK Documentation

ParameterVoidAttribute Constructor(String)

Syntax

'Declaration

Public Function New( _
   ByVal _method_ As String _
)

public ParameterVoidAttribute(
   string _method_
)

Parameters

method

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ParameterVoidAttribute Class
ParameterVoidAttribute Members
Overload List


ParameterVoidAttribute Constructor(Boolean,String) | fcSDK Documentation

ParameterVoidAttribute Constructor(Boolean,String)

Syntax

'Declaration

Public Function New( _
   ByVal _isVoid_ As Boolean, _
   ByVal _method_ As String _
)

public ParameterVoidAttribute(
   bool _isVoid_,
   string _method_
)

Parameters

isVoid

method

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ParameterVoidAttribute Class
ParameterVoidAttribute Members
Overload List


isVoid Field (ParameterVoidAttribute) | fcSDK Documentation

isVoid Field (ParameterVoidAttribute)

Syntax

'Declaration

Public ReadOnly isVoid As Boolean

public readonly bool isVoid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ParameterVoidAttribute Class
ParameterVoidAttribute Members


method Field (ParameterVoidAttribute) | fcSDK Documentation

method Field (ParameterVoidAttribute)

Syntax

'Declaration

Public ReadOnly method As String

public readonly string method

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ParameterVoidAttribute Class
ParameterVoidAttribute Members


SplitMethodAttribute Class | fcSDK Documentation

SplitMethodAttribute Class

Syntax

'Declaration

<AttributeUsageAttribute(ValidOn=AttributeTargets.Method,
   AllowMultiple=True,
   Inherited=True)>
Public Class SplitMethodAttribute
   Inherits System.Attribute

[AttributeUsageAttribute(ValidOn=AttributeTargets.Method,
   AllowMultiple=true,
   Inherited=true)]
public class SplitMethodAttribute : System.Attribute

Inheritance Hierarchy

System.Object
System.Attribute
FChoice.Foundation.Clarify.Attributes.SplitMethodAttribute

Requirements

Namespace: FChoice.Foundation.Clarify.Attributes

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

SplitMethodAttribute Members
FChoice.Foundation.Clarify.Attributes Namespace


SplitMethodAttribute Class Members | fcSDK Documentation

SplitMethodAttribute Class Members

The following tables list the members exposed by SplitMethodAttribute.

Public Constructors

 | Name | Description
Public Constructor | SplitMethodAttribute Constructor | Overloaded.

Public Properties

 | Name | Description
Public Property | MethodName |
Public Property | NumOfConstructors |
Public Property | TypeId | (Inherited from System.Attribute)

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)

Reference

SplitMethodAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


SplitMethodAttribute Constructor | fcSDK Documentation

SplitMethodAttribute Constructor

Overload List

Overload | Description
SplitMethodAttribute Constructor(String) |
SplitMethodAttribute Constructor(String,Int32) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SplitMethodAttribute Class
SplitMethodAttribute Members


SplitMethodAttribute Constructor(String) | fcSDK Documentation

SplitMethodAttribute Constructor(String)

Syntax

'Declaration

Public Function New( _
   ByVal _methodName_ As String _
)

public SplitMethodAttribute(
   string _methodName_
)

Parameters

methodName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SplitMethodAttribute Class
SplitMethodAttribute Members
Overload List


SplitMethodAttribute Constructor(String,Int32) | fcSDK Documentation

SplitMethodAttribute Constructor(String,Int32)

Syntax

'Declaration

Public Function New( _
   ByVal _methodName_ As String, _
   ByVal _numOfConstructors_ As Integer _
)

public SplitMethodAttribute(
   string _methodName_,
   int _numOfConstructors_
)

Parameters

methodName

numOfConstructors

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SplitMethodAttribute Class
SplitMethodAttribute Members
Overload List


MethodName Property (SplitMethodAttribute) | fcSDK Documentation

MethodName Property (SplitMethodAttribute)

Syntax

'Declaration

Public ReadOnly Property MethodName As String

public string MethodName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SplitMethodAttribute Class
SplitMethodAttribute Members


NumOfConstructors Property | fcSDK Documentation

NumOfConstructors Property

Syntax

'Declaration

Public ReadOnly Property NumOfConstructors As Integer

public int NumOfConstructors {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SplitMethodAttribute Class
SplitMethodAttribute Members


ToolkitVisibleAttribute Class | fcSDK Documentation

ToolkitVisibleAttribute Class

Syntax

'Declaration

<AttributeUsageAttribute(ValidOn=AttributeTargets.Class Or  _
    AttributeTargets.Struct Or  _
    AttributeTargets.Method,
   AllowMultiple=False,
   Inherited=True)>
Public Class ToolkitVisibleAttribute
   Inherits System.Attribute

[AttributeUsageAttribute(ValidOn=AttributeTargets.Class |
    AttributeTargets.Struct |
    AttributeTargets.Method,
   AllowMultiple=false,
   Inherited=true)]
public class ToolkitVisibleAttribute : System.Attribute

Inheritance Hierarchy

System.Object
System.Attribute
FChoice.Foundation.Clarify.Attributes.ToolkitVisibleAttribute

Requirements

Namespace: FChoice.Foundation.Clarify.Attributes

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ToolkitVisibleAttribute Members
FChoice.Foundation.Clarify.Attributes Namespace


ToolkitVisibleAttribute Class Members | fcSDK Documentation

ToolkitVisibleAttribute Class Members

The following tables list the members exposed by ToolkitVisibleAttribute.

Public Constructors

 | Name | Description
Public Constructor | ToolkitVisibleAttribute Constructor |

Public Fields

 | Name | Description
Public Field | IsVisible |

Public Properties

 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)

Reference

ToolkitVisibleAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


ToolkitVisibleAttribute Constructor | fcSDK Documentation

ToolkitVisibleAttribute Constructor

Syntax

'Declaration

Public Function New( _
   ByVal _isVisible_ As Boolean _
)

public ToolkitVisibleAttribute(
   bool _isVisible_
)

Parameters

isVisible

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ToolkitVisibleAttribute Class
ToolkitVisibleAttribute Members


IsVisible Field | fcSDK Documentation

IsVisible Field

Syntax

'Declaration

Public ReadOnly IsVisible As Boolean

public readonly bool IsVisible

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ToolkitVisibleAttribute Class
ToolkitVisibleAttribute Members


FChoice.Foundation.Clarify.AutoDest Namespace | fcSDK Documentation

FChoice.Foundation.Clarify.AutoDest Namespace

The FChoice.Foundation.Clarify.AutoDest namespace provides Auto Destination rule processing support which is used frequently within the Clarify system.

Classes

 | Class | Description
Class | AutoDestRule |

Reference

fcSDK Assembly


AutoDestRule Class | fcSDK Documentation

AutoDestRule Class

Syntax

'Declaration

Public Class AutoDestRule

public class AutoDestRule

Inheritance Hierarchy

System.Object
FChoice.Foundation.Clarify.AutoDest.AutoDestRule

Requirements

Namespace: FChoice.Foundation.Clarify.AutoDest

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

AutoDestRule Members
FChoice.Foundation.Clarify.AutoDest Namespace


AutoDestRule Class Members | fcSDK Documentation

AutoDestRule Class Members

The following tables list the members exposed by AutoDestRule.

Public Properties

 | Name | Description
Public Property | IsAutoDispatch |
Public Property | Operation |
Public Property | RootTable |
Public Property | RuleText |
Public Property | SuccessfulRuleClause |

Public Methods

 | Name | Description
Public Method | EvaluateRule | Overloaded.
static (Shared in Visual Basic) | RetrieveRule |
static (Shared in Visual Basic) | RunRule | Overloaded.

Reference

AutoDestRule Class
FChoice.Foundation.Clarify.AutoDest Namespace


EvaluateRule Method | fcSDK Documentation

EvaluateRule Method

Overload List

Overload | Description
EvaluateRule(String,IDbTransaction) |
EvaluateRule(String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AutoDestRule Class
AutoDestRule Members


EvaluateRule(String,IDbTransaction) Method | fcSDK Documentation

EvaluateRule(String,IDbTransaction) Method

Syntax

'Declaration

Public Overloads Function EvaluateRule( _
   ByVal _rootIdentifier_ As String, _
   ByVal _transaction_ As IDbTransaction _
) As String()

public string[] EvaluateRule(
   string _rootIdentifier_,
   IDbTransaction _transaction_
)

Parameters

rootIdentifier

transaction

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AutoDestRule Class
AutoDestRule Members
Overload List


EvaluateRule(String) Method | fcSDK Documentation

EvaluateRule(String) Method

Syntax

'Declaration

Public Overloads Function EvaluateRule( _
   ByVal _rootIdentifier_ As String _
) As String()

public string[] EvaluateRule(
   string _rootIdentifier_
)

Parameters

rootIdentifier

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AutoDestRule Class
AutoDestRule Members
Overload List


RetrieveRule Method | fcSDK Documentation

RetrieveRule Method

Syntax

'Declaration

Public Shared Function RetrieveRule( _
   ByVal _ruleTitle_ As String, _
   ByVal _ruleOperation_ As String _
) As AutoDestRule

public static AutoDestRule RetrieveRule(
   string _ruleTitle_,
   string _ruleOperation_
)

Parameters

ruleTitle

ruleOperation

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AutoDestRule Class
AutoDestRule Members


RunRule Method | fcSDK Documentation

RunRule Method

Overload List

Overload | Description
RunRule(String,String,String) |
RunRule(String,String,String,IDbTransaction) |
RunRule(String,String,String,Boolean) |
RunRule(String,String,String,Boolean,IDbTransaction) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AutoDestRule Class
AutoDestRule Members


RunRule(String,String,String) Method | fcSDK Documentation

RunRule(String,String,String) Method

Syntax

'Declaration

Public Overloads Shared Function RunRule( _
   ByVal _ruleTitle_ As String, _
   ByVal _ruleText_ As String, _
   ByVal _rootObjectId_ As String _
) As String()

public static string[] RunRule(
   string _ruleTitle_,
   string _ruleText_,
   string _rootObjectId_
)

Parameters

ruleTitle

ruleText

rootObjectId

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AutoDestRule Class
AutoDestRule Members
Overload List


RunRule(String,String,String,IDbTransaction) Method | fcSDK Documentation

RunRule(String,String,String,IDbTransaction) Method

Syntax

'Declaration

Public Overloads Shared Function RunRule( _
   ByVal _ruleTitle_ As String, _
   ByVal _ruleText_ As String, _
   ByVal _rootObjectId_ As String, _
   ByVal _transaction_ As IDbTransaction _
) As String()

public static string[] RunRule(
   string _ruleTitle_,
   string _ruleText_,
   string _rootObjectId_,
   IDbTransaction _transaction_
)

Parameters

ruleTitle

ruleText

rootObjectId

transaction

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AutoDestRule Class
AutoDestRule Members
Overload List


RunRule(String,String,String,Boolean) Method | fcSDK Documentation

RunRule(String,String,String,Boolean) Method

Syntax

'Declaration

Public Overloads Shared Function RunRule( _
   ByVal _ruleTitle_ As String, _
   ByVal _ruleText_ As String, _
   ByVal _rootObjectId_ As String, _
   ByRef _isAutoDispatch_ As Boolean _
) As String()

public static string[] RunRule(
   string _ruleTitle_,
   string _ruleText_,
   string _rootObjectId_,
   out bool _isAutoDispatch_
)

Parameters

ruleTitle

ruleText

rootObjectId

isAutoDispatch

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AutoDestRule Class
AutoDestRule Members
Overload List


RunRule(String,String,String,Boolean,IDbTransaction) Method | fcSDK Documentation

RunRule(String,String,String,Boolean,IDbTransaction) Method

Syntax

'Declaration

Public Overloads Shared Function RunRule( _
   ByVal _ruleTitle_ As String, _
   ByVal _ruleText_ As String, _
   ByVal _rootObjectId_ As String, _
   ByRef _isAutoDispatch_ As Boolean, _
   ByVal _transaction_ As IDbTransaction _
) As String()

public static string[] RunRule(
   string _ruleTitle_,
   string _ruleText_,
   string _rootObjectId_,
   out bool _isAutoDispatch_,
   IDbTransaction _transaction_
)

Parameters

ruleTitle

ruleText

rootObjectId

isAutoDispatch

transaction

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AutoDestRule Class
AutoDestRule Members
Overload List


IsAutoDispatch Property | fcSDK Documentation

IsAutoDispatch Property

Syntax

'Declaration

Public ReadOnly Property IsAutoDispatch As Boolean

public bool IsAutoDispatch {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AutoDestRule Class
AutoDestRule Members


Operation Property | fcSDK Documentation

Operation Property

Syntax

'Declaration

Public Property Operation As String

public string Operation {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AutoDestRule Class
AutoDestRule Members


RootTable Property | fcSDK Documentation

RootTable Property

Syntax

'Declaration

Public Property RootTable As SchemaTable

public SchemaTable RootTable {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AutoDestRule Class
AutoDestRule Members


RuleText Property | fcSDK Documentation

RuleText Property

Syntax

'Declaration

Public Property RuleText As String

public string RuleText {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AutoDestRule Class
AutoDestRule Members


SuccessfulRuleClause Property | fcSDK Documentation

SuccessfulRuleClause Property

Syntax

'Declaration

Public ReadOnly Property SuccessfulRuleClause As String

public string SuccessfulRuleClause {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AutoDestRule Class
AutoDestRule Members


FChoice.Foundation.Clarify.Compatibility Namespace | fcSDK Documentation

FChoice.Foundation.Clarify.Compatibility Namespace

Classes

 | Class | Description
Class | AdoField |
Class | AdoFieldInformationProvider |
Class | CompatibilityException |
Class | FCApplication |
Class | FCBulk |
Class | FCGeneric |
Class | FCList |
Class | FCNotLoggedInException |
Class | FCSession |
Class | FCSqlExec |
Class | MockAdoField |
Class | MockCollection |

Interfaces

 | Interface | Description
Interface | IFCApplication |
Interface | IFCBulk |
Interface | IFCGeneric |
Interface | IFCList |
Interface | IFCSession |
Interface | IFCSqlExec |
Interface | IMockAdoField |
Interface | IMockCollection |

Reference

FChoice.Foundation.Clarify.Compatibility Assembly


AdoField Class | fcSDK Documentation

AdoField Class

Syntax

'Declaration

<ComVisibleAttribute(False)>
Public Class AdoField

[ComVisibleAttribute(false)]
public class AdoField

Inheritance Hierarchy

System.Object
FChoice.Foundation.Clarify.Compatibility.AdoField

Requirements

Namespace: FChoice.Foundation.Clarify.Compatibility

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Foundation.Clarify.Compatibility (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Foundation.Clarify.Compatibility.dll)

Reference

AdoField Members
FChoice.Foundation.Clarify.Compatibility Namespace


AdoField Class Members | fcSDK Documentation

AdoField Class Members

The following tables list the members exposed by AdoField.

Public Constructors

 | Name | Description
Public Constructor | AdoField Constructor |

Public Properties

 | Name | Description
Public Property | DataType |
Public Property | Length |
Public Property | Name |

Reference

AdoField Class
FChoice.Foundation.Clarify.Compatibility Namespace


AdoField Constructor | fcSDK Documentation

AdoField Constructor

Syntax

'Declaration

Public Function New( _
   ByVal _fieldName_ As String, _
   ByVal _type_ As ADODB.DataTypeEnum, _
   ByVal _length_ As Integer _
)

public AdoField(
   string _fieldName_,
   ADODB.DataTypeEnum _type_,
   int _length_
)

Parameters

fieldName

type

length

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AdoField Class
AdoField Members


DataType Property (AdoField) | fcSDK Documentation

DataType Property (AdoField)

Syntax

'Declaration

Public Property DataType As ADODB.DataTypeEnum

public ADODB.DataTypeEnum DataType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AdoField Class
AdoField Members


Length Property (AdoField) | fcSDK Documentation

Length Property (AdoField)

Syntax

'Declaration

Public Property Length As Integer

public int Length {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AdoField Class
AdoField Members


Name Property (AdoField) | fcSDK Documentation

Name Property (AdoField)

Syntax

'Declaration

Public Property Name As String

public string Name {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AdoField Class
AdoField Members


AdoFieldInformationProvider Class | fcSDK Documentation

AdoFieldInformationProvider Class

Syntax

'Declaration

<ComVisibleAttribute(False)>
<GuidAttribute("EFCE1EFA-CE35-3D45-9722-07CF53F13778")>
Public Class AdoFieldInformationProvider

[ComVisibleAttribute(false)]
[GuidAttribute("EFCE1EFA-CE35-3D45-9722-07CF53F13778")]
public class AdoFieldInformationProvider

Inheritance Hierarchy

System.Object
FChoice.Foundation.Clarify.Compatibility.AdoFieldInformationProvider

Requirements

Namespace: FChoice.Foundation.Clarify.Compatibility

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Foundation.Clarify.Compatibility (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Foundation.Clarify.Compatibility.dll)

Reference

AdoFieldInformationProvider Members
FChoice.Foundation.Clarify.Compatibility Namespace


AdoFieldInformationProvider Class Members | fcSDK Documentation

AdoFieldInformationProvider Class Members

The following tables list the members exposed by AdoFieldInformationProvider.

Public Constructors

 | Name | Description
Public Constructor | AdoFieldInformationProvider Constructor | Overloaded.

Public Fields

 | Name | Description
Public Field | MaximumFieldSizeForSortableAdoStringFields |

Public Methods

 | Name | Description
Public Method | GetAdoFieldInformation |

Reference

AdoFieldInformationProvider Class
FChoice.Foundation.Clarify.Compatibility Namespace


AdoFieldInformationProvider Constructor | fcSDK Documentation

AdoFieldInformationProvider Constructor

Overload List

Overload | Description
AdoFieldInformationProvider Constructor(Boolean) |
AdoFieldInformationProvider Constructor() |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AdoFieldInformationProvider Class
AdoFieldInformationProvider Members


AdoFieldInformationProvider Constructor(Boolean) | fcSDK Documentation

AdoFieldInformationProvider Constructor(Boolean)

Syntax

'Declaration

Public Function New( _
   ByVal _isUnicode_ As Boolean _
)

public AdoFieldInformationProvider(
   bool _isUnicode_
)

Parameters

isUnicode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AdoFieldInformationProvider Class
AdoFieldInformationProvider Members
Overload List


AdoFieldInformationProvider Constructor() | fcSDK Documentation

AdoFieldInformationProvider Constructor()

Syntax

'Declaration

Public Function New()

public AdoFieldInformationProvider()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AdoFieldInformationProvider Class
AdoFieldInformationProvider Members
Overload List


GetAdoFieldInformation Method | fcSDK Documentation

GetAdoFieldInformation Method

Syntax

'Declaration

Public Function GetAdoFieldInformation( _
   ByVal _fieldName_ As String, _
   ByVal _dataType_ As Type, _
   ByVal _maxLength_ As Integer _
) As AdoField

public AdoField GetAdoFieldInformation(
   string _fieldName_,
   Type _dataType_,
   int _maxLength_
)

Parameters

fieldName

dataType

maxLength

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AdoFieldInformationProvider Class
AdoFieldInformationProvider Members


MaximumFieldSizeForSortableAdoStringFields Field | fcSDK Documentation

MaximumFieldSizeForSortableAdoStringFields Field

Syntax

'Declaration

Public Const MaximumFieldSizeForSortableAdoStringFields As Integer

public const int MaximumFieldSizeForSortableAdoStringFields

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AdoFieldInformationProvider Class
AdoFieldInformationProvider Members


CompatibilityException Class | fcSDK Documentation

CompatibilityException Class

Syntax

'Declaration

<ComVisibleAttribute(False)>
<GuidAttribute("4EC21DC6-3E55-3633-B289-FCC59D5AF61C")>
<SerializableAttribute()>
Public Class CompatibilityException
   Inherits FChoice.Common.FCExceptionBase

[ComVisibleAttribute(false)]
[GuidAttribute("4EC21DC6-3E55-3633-B289-FCC59D5AF61C")]
[SerializableAttribute()]
public class CompatibilityException : FChoice.Common.FCExceptionBase

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
FChoice.Common.FCExceptionBase
FChoice.Foundation.Clarify.Compatibility.CompatibilityException
FChoice.Foundation.Clarify.Compatibility.FCNotLoggedInException

Requirements

Namespace: FChoice.Foundation.Clarify.Compatibility

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Foundation.Clarify.Compatibility (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Foundation.Clarify.Compatibility.dll)

Reference

CompatibilityException Members
FChoice.Foundation.Clarify.Compatibility Namespace


CompatibilityException Class Members | fcSDK Documentation

CompatibilityException Class Members

The following tables list the members exposed by CompatibilityException.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorCode | Gets the unique error code for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | ErrorMessageID | Gets the message identifier for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | Sets the SerializationInfo object with the parameter name and additional exception information. (Inherited from FChoice.Common.FCExceptionBase)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)

Reference

CompatibilityException Class
FChoice.Foundation.Clarify.Compatibility Namespace


FCApplication Class | fcSDK Documentation

FCApplication Class

Syntax

'Declaration

<ComVisibleAttribute(True)>
<GuidAttribute("96EFBAF6-4FA0-4f71-A012-910F6CF61120")>
<IDispatchImplAttribute(IDispatchImplType.CompatibleImpl)>
<ProgIdAttribute("FCFLCompat.FCApplication")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public NotInheritable Class FCApplication
   Implements IFCApplication

[ComVisibleAttribute(true)]
[GuidAttribute("96EFBAF6-4FA0-4f71-A012-910F6CF61120")]
[IDispatchImplAttribute(IDispatchImplType.CompatibleImpl)]
[ProgIdAttribute("FCFLCompat.FCApplication")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public sealed class FCApplication : IFCApplication

Inheritance Hierarchy

System.Object
FChoice.Foundation.Clarify.Compatibility.FCApplication

Requirements

Namespace: FChoice.Foundation.Clarify.Compatibility

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Foundation.Clarify.Compatibility (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Foundation.Clarify.Compatibility.dll)

Reference

FCApplication Members
FChoice.Foundation.Clarify.Compatibility Namespace


FCApplication Class Members | fcSDK Documentation

FCApplication Class Members

The following tables list the members exposed by FCApplication.

Public Constructors

 | Name | Description
Public Constructor | FCApplication Constructor |

Public Fields

 | Name | Description
Public Field | LOGDIRNAME |
Public Field | LOGFILENAME |
Public Field | SQLLOGFILENAME |

Public Properties

 | Name | Description
Public Property | base_objid |
Public Property | clarify_ver |
Public Property | ConnectionString |
Public Property | ConvertTimeZone |
Public Property | DataProtectorEntropy |
Public Property | db_name |
Public Property | db_type |
Public Property | GetMachineTimeZone |
Public Property | IsDBTraveler |
Public Property | IsDBUnicode |
Public Property | IsFcflNet |
Public Property | LicenseExpirationDate |
Public Property | LoggingConfigFilePath |
Public Property | Midnight |
Public Property | schema_rev |
Public Property | ServerTimeZone |
Public Property | site_id |
Public Property | TruncateStringFields |
Public Property | WorkingDirectory |

Public Methods

 | Name | Description
Public Method | build_mtm_name |
Public Method | CreateSession |
Public Method | CurrentSessions |
Public Method | EncryptClarifyPassword |
Public Method | EncryptDBPassword |
Public Method | FileExists |
Public Method | FindString |
Public Method | get_change_date_field |
Public Method | get_dt_fields |
Public Method | get_fields_types_lens |
Public Method | GetADPObjects |
Public Method | GetCountryList |
Public Method | GetCountryObjid |
Public Method | GetDefaultCountry |
Public Method | GetDefaultCountryObjId |
Public Method | GetDefaultState |
Public Method | GetDefaultStateObjid |
Public Method | GetDefaultTimeZone |
Public Method | GetDefaultTimeZoneObjid |
Public Method | GetFullStateObjid |
Public Method | GetGbstDefault |
Public Method | GetGbstDefaultObjid |
Public Method | GetGbstElmById |
Public Method | GetGbstElmObjid |
Public Method | GetGbstElmRankObjid |
Public Method | GetGbstList |
Public Method | GetHgbstElmDefault |
Public Method | GetHgbstElmDefaultObjid |
Public Method | GetHgbstElmObjId |
Public Method | GetHgbstList |
Public Method | GetLocalizedGbstDefault |
Public Method | GetLocalizedGbstElmById |
Public Method | GetRelationData |
Public Method | GetResClauses |
Public Method | GetResClausesStr |
Public Method | GetResTbl |
Public Method | GetServerTimeZoneOffset |
Public Method | GetShortTimeZoneObjId |
Public Method | GetStateObjid |
Public Method | GetStates |
Public Method | GetTableFields |
Public Method | GetTableID |
Public Method | GetTableName |
Public Method | GetTableRels |
Public Method | GetTablesAndViews |
Public Method | GetTimeZoneList |
Public Method | GetTimeZoneObjid |
Public Method | GetTimeZoneOffset |
Public Method | GetTimeZonesInCountry |
Public Method | Initialize |
Public Method | InitializeFull |
Public Method | InitializeWithParams |
Public Method | is_it_a_field |
Public Method | is_it_a_table |
Public Method | is_it_change_field |
Public Method | is_it_date_field |
Public Method | is_it_int_field |
Public Method | is_it_searchable |
Public Method | is_it_string_fld |
Public Method | is_it_unicode |
Public Method | is_rel_exclusive |
Public Method | is_rel_mandatory |
Public Method | IsCountry |
Public Method | IsFullState |
Public Method | IsInGbstLst |
Public Method | IsInHgbstList |
Public Method | IsOnDST |
Public Method | IsState |
Public Method | IsTimeZone |
Public Method | IsTimeZoneInCountry |
Public Method | Log |
Public Method | LogEx |
Public Method | RankIsInGbstLst |
Public Method | SetServerTimeZoneToMachineTimeZone |
Public Method | sprintf |
Public Method | UpdateCache |
Public Method | UpdateSchemaCache |
Public Method | ValidateEncryptedPassword |

Reference

FCApplication Class
FChoice.Foundation.Clarify.Compatibility Namespace


FCApplication Constructor | fcSDK Documentation

FCApplication Constructor

Syntax

'Declaration

Public Function New()

public FCApplication()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


build_mtm_name Method (FCApplication) | fcSDK Documentation

build_mtm_name Method (FCApplication)

Syntax

'Declaration

Public Function build_mtm_name( _
   ByVal _tableName_ As String, _
   ByVal _relationName_ As String, _
   ByVal _inverseRelationName_ As String _
) As String

public string build_mtm_name(
   string _tableName_,
   string _relationName_,
   string _inverseRelationName_
)

Parameters

tableName

relationName

inverseRelationName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


CreateSession Method (FCApplication) | fcSDK Documentation

CreateSession Method (FCApplication)

Syntax

'Declaration

Public Function CreateSession( _
   Optional ByVal _sessIdValue_ As Object _
) As FCSession

public FCSession CreateSession(
   object _sessIdValue_
)

Parameters

sessIdValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


CurrentSessions Method (FCApplication) | fcSDK Documentation

CurrentSessions Method (FCApplication)

Syntax

'Declaration

Public Function CurrentSessions() As String

public string CurrentSessions()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


EncryptClarifyPassword Method (FCApplication) | fcSDK Documentation

EncryptClarifyPassword Method (FCApplication)

Syntax

'Declaration

Public Function EncryptClarifyPassword( _
   ByVal _password_ As String, _
   ByVal _fc_session_id_ As String _
) As String

public string EncryptClarifyPassword(
   string _password_,
   string _fc_session_id_
)

Parameters

password

fc_session_id

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


EncryptDBPassword Method (FCApplication) | fcSDK Documentation

EncryptDBPassword Method (FCApplication)

Syntax

'Declaration

Public Function EncryptDBPassword( _
   ByVal _password_ As String _
) As String

public string EncryptDBPassword(
   string _password_
)

Parameters

password

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


FileExists Method (FCApplication) | fcSDK Documentation

FileExists Method (FCApplication)

Syntax

'Declaration

Public Function FileExists( _
   ByVal _path_ As String _
) As Boolean

public bool FileExists(
   string _path_
)

Parameters

path

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


FindString Method (FCApplication) | fcSDK Documentation

FindString Method (FCApplication)

Syntax

'Declaration

Public Function FindString( _
   ByVal _StringID_ As Object _
) As String

public string FindString(
   object _StringID_
)

Parameters

StringID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


get_change_date_field Method (FCApplication) | fcSDK Documentation

get_change_date_field Method (FCApplication)

Syntax

'Declaration

Public Function get_change_date_field( _
   ByVal _tableName_ As String _
) As String

public string get_change_date_field(
   string _tableName_
)

Parameters

tableName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


get_dt_fields Method (FCApplication) | fcSDK Documentation

get_dt_fields Method (FCApplication)

Syntax

'Declaration

Public Function get_dt_fields( _
   ByVal _tableName_ As String _
) As String

public string get_dt_fields(
   string _tableName_
)

Parameters

tableName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


get_fields_types_lens Method (FCApplication) | fcSDK Documentation

get_fields_types_lens Method (FCApplication)

Syntax

'Declaration

Public Function get_fields_types_lens( _
   ByVal _tableName_ As String, _
   ByVal _includeRelations_ As Boolean _
) As String

public string get_fields_types_lens(
   string _tableName_,
   bool _includeRelations_
)

Parameters

tableName

includeRelations

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetADPObjects Method (FCApplication) | fcSDK Documentation

GetADPObjects Method (FCApplication)

Syntax

'Declaration

Public Function GetADPObjects( _
   Optional ByVal _ObjectTypes_ As Object _
) As ADODB.Recordset

public ADODB.Recordset GetADPObjects(
   object _ObjectTypes_
)

Parameters

ObjectTypes

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetCountryList Method (FCApplication) | fcSDK Documentation

GetCountryList Method (FCApplication)

Syntax

'Declaration

Public Function GetCountryList() As ADODB.Recordset

public ADODB.Recordset GetCountryList()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetCountryObjid Method (FCApplication) | fcSDK Documentation

GetCountryObjid Method (FCApplication)

Syntax

'Declaration

Public Function GetCountryObjid( _
   ByVal _Country_ As String _
) As Integer

public int GetCountryObjid(
   string _Country_
)

Parameters

Country

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetDefaultCountry Method (FCApplication) | fcSDK Documentation

GetDefaultCountry Method (FCApplication)

Syntax

'Declaration

Public Function GetDefaultCountry() As String

public string GetDefaultCountry()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetDefaultCountryObjId Method (FCApplication) | fcSDK Documentation

GetDefaultCountryObjId Method (FCApplication)

Syntax

'Declaration

Public Function GetDefaultCountryObjId() As Integer

public int GetDefaultCountryObjId()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetDefaultState Method (FCApplication) | fcSDK Documentation

GetDefaultState Method (FCApplication)

Syntax

'Declaration

Public Function GetDefaultState( _
   ByVal _country_ As String _
) As String

public string GetDefaultState(
   string _country_
)

Parameters

country

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetDefaultStateObjid Method (FCApplication) | fcSDK Documentation

GetDefaultStateObjid Method (FCApplication)

Syntax

'Declaration

Public Function GetDefaultStateObjid( _
   ByVal _country_ As String _
) As Integer

public int GetDefaultStateObjid(
   string _country_
)

Parameters

country

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetDefaultTimeZone Method (FCApplication) | fcSDK Documentation

GetDefaultTimeZone Method (FCApplication)

Syntax

'Declaration

Public Function GetDefaultTimeZone() As String

public string GetDefaultTimeZone()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetDefaultTimeZoneObjid Method (FCApplication) | fcSDK Documentation

GetDefaultTimeZoneObjid Method (FCApplication)

Syntax

'Declaration

Public Function GetDefaultTimeZoneObjid() As Integer

public int GetDefaultTimeZoneObjid()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetFullStateObjid Method (FCApplication) | fcSDK Documentation

GetFullStateObjid Method (FCApplication)

Syntax

'Declaration

Public Function GetFullStateObjid( _
   ByVal _country_ As String, _
   ByVal _state_ As String _
) As Integer

public int GetFullStateObjid(
   string _country_,
   string _state_
)

Parameters

country

state

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetGbstDefault Method (FCApplication) | fcSDK Documentation

GetGbstDefault Method (FCApplication)

Syntax

'Declaration

Public Function GetGbstDefault( _
   ByVal _listName_ As String _
) As String

public string GetGbstDefault(
   string _listName_
)

Parameters

listName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetGbstDefaultObjid Method (FCApplication) | fcSDK Documentation

GetGbstDefaultObjid Method (FCApplication)

Syntax

'Declaration

Public Function GetGbstDefaultObjid( _
   ByVal _listName_ As String _
) As Integer

public int GetGbstDefaultObjid(
   string _listName_
)

Parameters

listName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetGbstElmById Method (FCApplication) | fcSDK Documentation

GetGbstElmById Method (FCApplication)

Syntax

'Declaration

Public Function GetGbstElmById( _
   ByVal _listName_ As String, _
   ByVal _elmObjID_ As Integer _
) As String

public string GetGbstElmById(
   string _listName_,
   int _elmObjID_
)

Parameters

listName

elmObjID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetGbstElmObjid Method (FCApplication) | fcSDK Documentation

GetGbstElmObjid Method (FCApplication)

Syntax

'Declaration

Public Function GetGbstElmObjid( _
   ByVal _listName_ As String, _
   ByVal _element_ As String _
) As Integer

public int GetGbstElmObjid(
   string _listName_,
   string _element_
)

Parameters

listName

element

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetGbstElmRankObjid Method (FCApplication) | fcSDK Documentation

GetGbstElmRankObjid Method (FCApplication)

Syntax

'Declaration

Public Function GetGbstElmRankObjid( _
   ByVal _listName_ As String, _
   ByVal _elementRank_ As Integer _
) As Integer

public int GetGbstElmRankObjid(
   string _listName_,
   int _elementRank_
)

Parameters

listName

elementRank

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetGbstList(String,Object) Method | fcSDK Documentation

GetGbstList(String,Object) Method

Syntax

'Declaration

Public Function GetGbstList( _
   ByVal _listName_ As String, _
   Optional ByVal _includeInactive_ As Object _
) As ADODB.Recordset

public ADODB.Recordset GetGbstList(
   string _listName_,
   object _includeInactive_
)

Parameters

listName

includeInactive

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetHgbstElmDefault Method (FCApplication) | fcSDK Documentation

GetHgbstElmDefault Method (FCApplication)

Syntax

'Declaration

Public Function GetHgbstElmDefault( _
   ByVal _listName_ As String, _
   Optional ByVal _element1_ As Object, _
   Optional ByVal _element2_ As Object, _
   Optional ByVal _element3_ As Object, _
   Optional ByVal _element4_ As Object _
) As String

public string GetHgbstElmDefault(
   string _listName_,
   object _element1_,
   object _element2_,
   object _element3_,
   object _element4_
)

Parameters

listName

element1

element2

element3

element4

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetHgbstElmDefaultObjid Method (FCApplication) | fcSDK Documentation

GetHgbstElmDefaultObjid Method (FCApplication)

Syntax

'Declaration

Public Function GetHgbstElmDefaultObjid( _
   ByVal _listName_ As String, _
   Optional ByVal _Element1_ As Object, _
   Optional ByVal _Element2_ As Object, _
   Optional ByVal _Element3_ As Object, _
   Optional ByVal _Element4_ As Object _
) As Integer

public int GetHgbstElmDefaultObjid(
   string _listName_,
   object _Element1_,
   object _Element2_,
   object _Element3_,
   object _Element4_
)

Parameters

listName

Element1

Element2

Element3

Element4

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetHgbstElmObjId Method (FCApplication) | fcSDK Documentation

GetHgbstElmObjId Method (FCApplication)

Syntax

'Declaration

Public Function GetHgbstElmObjId( _
   ByVal _element_ As String, _
   ByVal _listName_ As String, _
   Optional ByVal _Element1_ As Object, _
   Optional ByVal _Element2_ As Object, _
   Optional ByVal _Element3_ As Object, _
   Optional ByVal _Element4_ As Object _
) As Integer

public int GetHgbstElmObjId(
   string _element_,
   string _listName_,
   object _Element1_,
   object _Element2_,
   object _Element3_,
   object _Element4_
)

Parameters

element

listName

Element1

Element2

Element3

Element4

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetHgbstList Method (FCApplication) | fcSDK Documentation

GetHgbstList Method (FCApplication)

Syntax

'Declaration

Public Function GetHgbstList( _
   ByVal _listName_ As String, _
   Optional ByVal _Element1_ As Object, _
   Optional ByVal _Element2_ As Object, _
   Optional ByVal _Element3_ As Object, _
   Optional ByVal _Element4_ As Object, _
   Optional ByVal _includeInactive_ As Object _
) As ADODB.Recordset

public ADODB.Recordset GetHgbstList(
   string _listName_,
   object _Element1_,
   object _Element2_,
   object _Element3_,
   object _Element4_,
   object _includeInactive_
)

Parameters

listName

Element1

Element2

Element3

Element4

includeInactive

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetLocalizedGbstDefault Method (FCApplication) | fcSDK Documentation

GetLocalizedGbstDefault Method (FCApplication)

Syntax

'Declaration

Public Function GetLocalizedGbstDefault( _
   ByVal _listName_ As String _
) As String

public string GetLocalizedGbstDefault(
   string _listName_
)

Parameters

listName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetLocalizedGbstElmById Method (FCApplication) | fcSDK Documentation

GetLocalizedGbstElmById Method (FCApplication)

Syntax

'Declaration

Public Function GetLocalizedGbstElmById( _
   ByVal _listName_ As String, _
   ByVal _elmObjID_ As Integer _
) As String

public string GetLocalizedGbstElmById(
   string _listName_,
   int _elmObjID_
)

Parameters

listName

elmObjID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetRelationData Method (FCApplication) | fcSDK Documentation

GetRelationData Method (FCApplication)

Syntax

'Declaration
Public Function GetRelationData( _
   ByVal _relationName_ As String, _
   ByVal _tableName_ As String _
) As ADODB.Recordset

public ADODB.Recordset GetRelationData(
   string _relationName_,
   string _tableName_
)

Parameters

relationName

tableName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetResClauses Method (FCApplication) | fcSDK Documentation

GetResClauses Method (FCApplication)

Syntax

'Declaration

Public Function GetResClauses( _
   ByVal _tblNum_ As Integer, _
   ByRef _clauses_ As String _
) As Boolean

public bool GetResClauses(
   int _tblNum_,
   ref string _clauses_
)

Parameters

tblNum

clauses

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetResClausesStr Method (FCApplication) | fcSDK Documentation

GetResClausesStr Method (FCApplication)

Syntax

'Declaration

Public Function GetResClausesStr( _
   ByVal _tblNum_ As Integer _
) As String

public string GetResClausesStr(
   int _tblNum_
)

Parameters

tblNum

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetResTbl Method (FCApplication) | fcSDK Documentation

GetResTbl Method (FCApplication)

Syntax

'Declaration

Public Function GetResTbl( _
   ByVal _tblNum_ As Integer, _
   ByRef _restructionFieldNames_ As String() _
) As Boolean

public bool GetResTbl(
   int _tblNum_,
   ref string[] _restructionFieldNames_
)

Parameters

tblNum

restructionFieldNames

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetServerTimeZoneOffset Method (FCApplication) | fcSDK Documentation

GetServerTimeZoneOffset Method (FCApplication)

Syntax

'Declaration

Public Function GetServerTimeZoneOffset() As Integer

public int GetServerTimeZoneOffset()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetShortTimeZoneObjId Method (FCApplication) | fcSDK Documentation

GetShortTimeZoneObjId Method (FCApplication)

Syntax

'Declaration

Public Function GetShortTimeZoneObjId( _
   ByVal _timeZoneName_ As String _
) As Integer

public int GetShortTimeZoneObjId(
   string _timeZoneName_
)

Parameters

timeZoneName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetStateObjid Method (FCApplication) | fcSDK Documentation

GetStateObjid Method (FCApplication)

Syntax

'Declaration

Public Function GetStateObjid( _
   ByVal _country_ As String, _
   ByVal _state_ As String _
) As Integer

public int GetStateObjid(
   string _country_,
   string _state_
)

Parameters

country

state

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetStates Method (FCApplication) | fcSDK Documentation

GetStates Method (FCApplication)

Syntax

'Declaration

Public Function GetStates( _
   ByVal _country_ As String _
) As ADODB.Recordset

public ADODB.Recordset GetStates(
   string _country_
)

Parameters

country

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetTableFields Method (FCApplication) | fcSDK Documentation

GetTableFields Method (FCApplication)

Syntax

'Declaration

Public Function GetTableFields( _
   ByVal _tableName_ As String _
) As ADODB.Recordset

public ADODB.Recordset GetTableFields(
   string _tableName_
)

Parameters

tableName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetTableID Method (FCApplication) | fcSDK Documentation

GetTableID Method (FCApplication)

Syntax

'Declaration

Public Function GetTableID( _
   ByVal _tableName_ As String _
) As Integer

public int GetTableID(
   string _tableName_
)

Parameters

tableName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetTableName Method (FCApplication) | fcSDK Documentation

GetTableName Method (FCApplication)

Syntax

'Declaration

Public Function GetTableName( _
   ByVal _TableNum_ As Integer _
) As String

public string GetTableName(
   int _TableNum_
)

Parameters

TableNum

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetTableRels Method (FCApplication) | fcSDK Documentation

GetTableRels Method (FCApplication)

Syntax

'Declaration

Public Function GetTableRels( _
   ByVal _tableName_ As String, _
   ByVal _allowOneToMany_ As Boolean _
) As ADODB.Recordset

public ADODB.Recordset GetTableRels(
   string _tableName_,
   bool _allowOneToMany_
)

Parameters

tableName

allowOneToMany

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetTablesAndViews Method (FCApplication) | fcSDK Documentation

GetTablesAndViews Method (FCApplication)

Syntax

'Declaration

Public Function GetTablesAndViews( _
   Optional ByVal _TablesOnly_ As Object _
) As ADODB.Recordset

public ADODB.Recordset GetTablesAndViews(
   object _TablesOnly_
)

Parameters

TablesOnly

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetTimeZoneList Method (FCApplication) | fcSDK Documentation

GetTimeZoneList Method (FCApplication)

Syntax

'Declaration

Public Function GetTimeZoneList() As ADODB.Recordset

public ADODB.Recordset GetTimeZoneList()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetTimeZoneObjid Method (FCApplication) | fcSDK Documentation

GetTimeZoneObjid Method (FCApplication)

Syntax

'Declaration

Public Function GetTimeZoneObjid( _
   ByVal _timeZoneName_ As String _
) As Integer

public int GetTimeZoneObjid(
   string _timeZoneName_
)

Parameters

timeZoneName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetTimeZoneOffset Method (FCApplication) | fcSDK Documentation

GetTimeZoneOffset Method (FCApplication)

Syntax

'Declaration

Public Function GetTimeZoneOffset( _
   ByVal _timeZoneName_ As String _
) As Integer

public int GetTimeZoneOffset(
   string _timeZoneName_
)

Parameters

timeZoneName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetTimeZonesInCountry Method (FCApplication) | fcSDK Documentation

GetTimeZonesInCountry Method (FCApplication)

Syntax

'Declaration

Public Function GetTimeZonesInCountry( _
   ByVal _Country_ As String _
) As ADODB.Recordset

public ADODB.Recordset GetTimeZonesInCountry(
   string _Country_
)

Parameters

Country

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


Initialize Method (FCApplication) | fcSDK Documentation

Initialize Method (FCApplication)

Syntax

'Declaration

Public Sub Initialize()

public void Initialize()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


InitializeFull Method (FCApplication) | fcSDK Documentation

InitializeFull Method (FCApplication)

Syntax

'Declaration

Public Sub InitializeFull( _
   ByVal _LoginName_ As String, _
   ByVal _password_ As String, _
   ByVal _DBServer_ As String, _
   ByVal _DBName_ As String, _
   Optional ByVal _DBType_ As Object, _
   Optional ByVal _LogFile_ As Object, _
   Optional ByVal _SqlLogFile_ As Object, _
   Optional ByVal _SQLLogging_ As Object, _
   Optional ByVal _fcAppLogging_ As Object, _
   Optional ByVal _fcSessionLogging_ As Object, _
   Optional ByVal _fcGenericLogging_ As Object, _
   Optional ByVal _fcBulkLogging_ As Object, _
   Optional ByVal _fcSqlExecLogging_ As Object, _
   Optional ByVal _NoCacheFile_ As Object _
)

public void InitializeFull(
   string _LoginName_,
   string _password_,
   string _DBServer_,
   string _DBName_,
   object _DBType_,
   object _LogFile_,
   object _SqlLogFile_,
   object _SQLLogging_,
   object _fcAppLogging_,
   object _fcSessionLogging_,
   object _fcGenericLogging_,
   object _fcBulkLogging_,
   object _fcSqlExecLogging_,
   object _NoCacheFile_
)

Parameters

LoginName

password

DBServer

DBName

DBType

LogFile

SqlLogFile

SQLLogging

fcAppLogging

fcSessionLogging

fcGenericLogging

fcBulkLogging

fcSqlExecLogging

NoCacheFile

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


InitializeWithParams Method | fcSDK Documentation

InitializeWithParams Method

Syntax

'Declaration

<ComVisibleAttribute(False)>
Public Sub InitializeWithParams( _
   ByVal _envParams_ As NameValueCollection _
)

[ComVisibleAttribute(false)]
public void InitializeWithParams(
   NameValueCollection _envParams_
)

Parameters

envParams

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


is_it_a_field Method (FCApplication) | fcSDK Documentation

is_it_a_field Method (FCApplication)

Syntax

'Declaration

Public Function is_it_a_field( _
   ByVal _tableName_ As String, _
   ByVal _fieldName_ As String _
) As Boolean

public bool is_it_a_field(
   string _tableName_,
   string _fieldName_
)

Parameters

tableName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


is_it_a_table Method (FCApplication) | fcSDK Documentation

is_it_a_table Method (FCApplication)

Syntax

'Declaration

Public Function is_it_a_table( _
   ByVal _tableName_ As String _
) As Boolean

public bool is_it_a_table(
   string _tableName_
)

Parameters

tableName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


is_it_change_field Method (FCApplication) | fcSDK Documentation

is_it_change_field Method (FCApplication)

Syntax

'Declaration

Public Function is_it_change_field( _
   ByVal _tableName_ As String, _
   ByVal _fieldName_ As String _
) As Boolean

public bool is_it_change_field(
   string _tableName_,
   string _fieldName_
)

Parameters

tableName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


is_it_date_field Method (FCApplication) | fcSDK Documentation

is_it_date_field Method (FCApplication)

Syntax

'Declaration

Public Function is_it_date_field( _
   ByVal _tableName_ As String, _
   ByVal _fieldName_ As String _
) As Boolean

public bool is_it_date_field(
   string _tableName_,
   string _fieldName_
)

Parameters

tableName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


is_it_int_field Method (FCApplication) | fcSDK Documentation

is_it_int_field Method (FCApplication)

Syntax

'Declaration

Public Function is_it_int_field( _
   ByVal _tableName_ As String, _
   ByVal _fieldName_ As String _
) As Boolean

public bool is_it_int_field(
   string _tableName_,
   string _fieldName_
)

Parameters

tableName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


is_it_searchable Method (FCApplication) | fcSDK Documentation

is_it_searchable Method (FCApplication)

Syntax

'Declaration

Public Function is_it_searchable( _
   ByVal _tableName_ As String, _
   ByVal _fieldName_ As String _
) As Boolean

public bool is_it_searchable(
   string _tableName_,
   string _fieldName_
)

Parameters

tableName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


is_it_string_fld Method (FCApplication) | fcSDK Documentation

is_it_string_fld Method (FCApplication)

Syntax

'Declaration

Public Function is_it_string_fld( _
   ByVal _tableName_ As String, _
   ByVal _fieldName_ As String _
) As Boolean

public bool is_it_string_fld(
   string _tableName_,
   string _fieldName_
)

Parameters

tableName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


is_it_unicode Method (FCApplication) | fcSDK Documentation

is_it_unicode Method (FCApplication)

Syntax

'Declaration

Public Function is_it_unicode( _
   ByVal _tableName_ As String, _
   ByVal _fieldName_ As String _
) As Boolean

public bool is_it_unicode(
   string _tableName_,
   string _fieldName_
)

Parameters

tableName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


is_rel_exclusive Method (FCApplication) | fcSDK Documentation

is_rel_exclusive Method (FCApplication)

Syntax

'Declaration

Public Function is_rel_exclusive( _
   ByVal _tbl_num_ As Integer, _
   ByVal _relationName_ As String, _
   ByRef _tbl_fld_ As String, _
   ByRef _objid_fld_ As String _
) As Boolean

public bool is_rel_exclusive(
   int _tbl_num_,
   string _relationName_,
   ref string _tbl_fld_,
   ref string _objid_fld_
)

Parameters

tbl_num

relationName

tbl_fld

objid_fld

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


is_rel_mandatory Method (FCApplication) | fcSDK Documentation

is_rel_mandatory Method (FCApplication)

Syntax

'Declaration

Public Function is_rel_mandatory( _
   ByVal _tableNum_ As Integer, _
   ByVal _relationName_ As String _
) As Boolean

public bool is_rel_mandatory(
   int _tableNum_,
   string _relationName_
)

Parameters

tableNum

relationName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


IsCountry Method (FCApplication) | fcSDK Documentation

IsCountry Method (FCApplication)

Syntax

'Declaration

Public Function IsCountry( _
   ByVal _Country_ As String _
) As Boolean

public bool IsCountry(
   string _Country_
)

Parameters

Country

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


IsFullState Method (FCApplication) | fcSDK Documentation

IsFullState Method (FCApplication)

Syntax

'Declaration

Public Function IsFullState( _
   ByVal _country_ As String, _
   ByVal _state_ As String _
) As Boolean

public bool IsFullState(
   string _country_,
   string _state_
)

Parameters

country

state

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


IsInGbstLst Method (FCApplication) | fcSDK Documentation

IsInGbstLst Method (FCApplication)

Syntax

'Declaration

Public Function IsInGbstLst( _
   ByVal _listName_ As String, _
   ByVal _element_ As String _
) As Boolean

public bool IsInGbstLst(
   string _listName_,
   string _element_
)

Parameters

listName

element

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


IsInHgbstList Method (FCApplication) | fcSDK Documentation

IsInHgbstList Method (FCApplication)

Syntax

'Declaration

Public Function IsInHgbstList( _
   ByVal _element_ As String, _
   ByVal _listName_ As String, _
   Optional ByVal _Element1_ As Object, _
   Optional ByVal _Element2_ As Object, _
   Optional ByVal _Element3_ As Object, _
   Optional ByVal _Element4_ As Object _
) As Boolean

public bool IsInHgbstList(
   string _element_,
   string _listName_,
   object _Element1_,
   object _Element2_,
   object _Element3_,
   object _Element4_
)

Parameters

element

listName

Element1

Element2

Element3

Element4

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


IsOnDST Method (FCApplication) | fcSDK Documentation

IsOnDST Method (FCApplication)

Syntax

'Declaration

Public Function IsOnDST( _
   ByVal _timeZoneName_ As String, _
   ByVal _date_ As Date _
) As Boolean

public bool IsOnDST(
   string _timeZoneName_,
   DateTime _date_
)

Parameters

timeZoneName

date

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


IsState Method (FCApplication) | fcSDK Documentation

IsState Method (FCApplication)

Syntax

'Declaration

Public Function IsState( _
   ByVal _country_ As String, _
   ByVal _state_ As String _
) As Boolean

public bool IsState(
   string _country_,
   string _state_
)

Parameters

country

state

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


IsTimeZone Method (FCApplication) | fcSDK Documentation

IsTimeZone Method (FCApplication)

Syntax

'Declaration

Public Function IsTimeZone( _
   ByVal _timeZoneName_ As String _
) As Boolean

public bool IsTimeZone(
   string _timeZoneName_
)

Parameters

timeZoneName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


IsTimeZoneInCountry Method (FCApplication) | fcSDK Documentation

IsTimeZoneInCountry Method (FCApplication)

Syntax

'Declaration

Public Function IsTimeZoneInCountry( _
   ByVal _country_ As String, _
   ByVal _timeZone_ As String, _
   ByVal _IsFullName_ As Boolean _
) As Boolean

public bool IsTimeZoneInCountry(
   string _country_,
   string _timeZone_,
   bool _IsFullName_
)

Parameters

country

timeZone

IsFullName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


Log Method (FCApplication) | fcSDK Documentation

Log Method (FCApplication)

Syntax

'Declaration

Public Sub Log( _
   ByVal _TheMessageType_ As Object, _
   ByVal _TheMessage_ As Object _
)

public void Log(
   object _TheMessageType_,
   object _TheMessage_
)

Parameters

TheMessageType

TheMessage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


LogEx Method (FCApplication) | fcSDK Documentation

LogEx Method (FCApplication)

Syntax

'Declaration

Public Sub LogEx( _
   ByVal _logLevel_ As String, _
   ByVal _logMessage_ As String _
)

public void LogEx(
   string _logLevel_,
   string _logMessage_
)

Parameters

logLevel

logMessage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


RankIsInGbstLst Method (FCApplication) | fcSDK Documentation

RankIsInGbstLst Method (FCApplication)

Syntax

'Declaration

Public Function RankIsInGbstLst( _
   ByVal _listName_ As String, _
   ByVal _rank_ As Integer _
) As Boolean

public bool RankIsInGbstLst(
   string _listName_,
   int _rank_
)

Parameters

listName

rank

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


SetServerTimeZoneToMachineTimeZone Method (FCApplication) | fcSDK Documentation

SetServerTimeZoneToMachineTimeZone Method (FCApplication)

Syntax

'Declaration

Public Sub SetServerTimeZoneToMachineTimeZone()

public void SetServerTimeZoneToMachineTimeZone()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


sprintf Method (FCApplication) | fcSDK Documentation

sprintf Method (FCApplication)

Syntax

'Declaration

Public Function sprintf( _
   ByVal _inputString_ As String, _
   Optional ByVal _arg1_ As Object, _
   Optional ByVal _arg2_ As Object, _
   Optional ByVal _arg3_ As Object, _
   Optional ByVal _arg4_ As Object, _
   Optional ByVal _arg5_ As Object, _
   Optional ByVal _arg6_ As Object _
) As String

public string sprintf(
   string _inputString_,
   object _arg1_,
   object _arg2_,
   object _arg3_,
   object _arg4_,
   object _arg5_,
   object _arg6_
)

Parameters

inputString

arg1

arg2

arg3

arg4

arg5

arg6

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


UpdateCache Method (FCApplication) | fcSDK Documentation

UpdateCache Method (FCApplication)

Syntax

'Declaration

Public Sub UpdateCache()

public void UpdateCache()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


UpdateSchemaCache Method (FCApplication) | fcSDK Documentation

UpdateSchemaCache Method (FCApplication)

Syntax

'Declaration

Public Sub UpdateSchemaCache()

public void UpdateSchemaCache()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


ValidateEncryptedPassword Method (FCApplication) | fcSDK Documentation

ValidateEncryptedPassword Method (FCApplication)

Syntax

'Declaration

Public Function ValidateEncryptedPassword( _
   ByVal _str_ As String, _
   ByVal _encr_ As String, _
   ByVal _pre9_ As Short _
) As Boolean

public bool ValidateEncryptedPassword(
   string _str_,
   string _encr_,
   short _pre9_
)

Parameters

str

encr

pre9

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


base_objid Property (FCApplication) | fcSDK Documentation

base_objid Property (FCApplication)

Syntax

'Declaration

Public ReadOnly Property base_objid As Integer

public int base_objid {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


clarify_ver Property (FCApplication) | fcSDK Documentation

clarify_ver Property (FCApplication)

Syntax

'Declaration

Public ReadOnly Property clarify_ver As String

public string clarify_ver {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


ConnectionString Property (FCApplication) | fcSDK Documentation

ConnectionString Property (FCApplication)

Syntax

'Declaration

Public ReadOnly Property ConnectionString As String

public string ConnectionString {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


ConvertTimeZone Property (FCApplication) | fcSDK Documentation

ConvertTimeZone Property (FCApplication)

Syntax

'Declaration

Public Property ConvertTimeZone As Boolean

public bool ConvertTimeZone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


DataProtectorEntropy Property (FCApplication) | fcSDK Documentation

DataProtectorEntropy Property (FCApplication)

Syntax

'Declaration

Public WriteOnly Property DataProtectorEntropy As String

public string DataProtectorEntropy {set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


db_name Property (FCApplication) | fcSDK Documentation

db_name Property (FCApplication)

Syntax

'Declaration

Public ReadOnly Property db_name As String

public string db_name {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


db_type Property (FCApplication) | fcSDK Documentation

db_type Property (FCApplication)

Syntax

'Declaration

Public ReadOnly Property db_type As String

public string db_type {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


GetMachineTimeZone Property (FCApplication) | fcSDK Documentation

GetMachineTimeZone Property (FCApplication)

Syntax

'Declaration

Public ReadOnly Property GetMachineTimeZone As String

public string GetMachineTimeZone {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


IsDBTraveler Property (FCApplication) | fcSDK Documentation

IsDBTraveler Property (FCApplication)

Syntax

'Declaration

Public ReadOnly Property IsDBTraveler As Boolean

public bool IsDBTraveler {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


IsDBUnicode Property (FCApplication) | fcSDK Documentation

IsDBUnicode Property (FCApplication)

Syntax

'Declaration

Public ReadOnly Property IsDBUnicode As Boolean

public bool IsDBUnicode {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


IsFcflNet Property (FCApplication) | fcSDK Documentation

IsFcflNet Property (FCApplication)

Syntax

'Declaration

Public ReadOnly Property IsFcflNet As Boolean

public bool IsFcflNet {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


LicenseExpirationDate Property (FCApplication) | fcSDK Documentation

LicenseExpirationDate Property (FCApplication)

Syntax

'Declaration

Public ReadOnly Property LicenseExpirationDate As String

public string LicenseExpirationDate {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


LoggingConfigFilePath Property (FCApplication) | fcSDK Documentation

LoggingConfigFilePath Property (FCApplication)

Syntax

'Declaration

Public Property LoggingConfigFilePath As String

public string LoggingConfigFilePath {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


Midnight Property (FCApplication) | fcSDK Documentation

Midnight Property (FCApplication)

Syntax

'Declaration

Public Property Midnight As String

public string Midnight {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


schema_rev Property (FCApplication) | fcSDK Documentation

schema_rev Property (FCApplication)

Syntax

'Declaration

Public ReadOnly Property schema_rev As Short

public short schema_rev {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


ServerTimeZone Property (FCApplication) | fcSDK Documentation

ServerTimeZone Property (FCApplication)

Syntax

'Declaration

Public Property ServerTimeZone As String

public string ServerTimeZone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


site_id Property (FCApplication) | fcSDK Documentation

site_id Property (FCApplication)

Syntax

'Declaration

Public ReadOnly Property site_id As Short

public short site_id {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


TruncateStringFields Property (FCApplication) | fcSDK Documentation

TruncateStringFields Property (FCApplication)

Syntax

'Declaration

Public Property TruncateStringFields As Boolean

public bool TruncateStringFields {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


WorkingDirectory Property (FCApplication) | fcSDK Documentation

WorkingDirectory Property (FCApplication)

Syntax

'Declaration

Public Property WorkingDirectory As String

public string WorkingDirectory {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


LOGDIRNAME Field | fcSDK Documentation

LOGDIRNAME Field

Syntax

'Declaration

Public Const LOGDIRNAME As String

public const string LOGDIRNAME

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


LOGFILENAME Field | fcSDK Documentation

LOGFILENAME Field

Syntax

'Declaration

Public Const LOGFILENAME As String

public const string LOGFILENAME

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


SQLLOGFILENAME Field | fcSDK Documentation

SQLLOGFILENAME Field

Syntax

'Declaration

Public Const SQLLOGFILENAME As String

public const string SQLLOGFILENAME

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


FCBulk Class | fcSDK Documentation

FCBulk Class

Syntax

'Declaration

<ClassInterfaceAttribute(ClassInterfaceType.None)>
<GuidAttribute("DDBC0BE8-F58D-4bde-B658-6FB1E0851C4C")>
<ProgIdAttribute("FCFLCompat.FCBulk")>
<ComVisibleAttribute(True)>
<IDispatchImplAttribute(IDispatchImplType.CompatibleImpl)>
Public NotInheritable Class FCBulk
   Implements IFCBulk

[ClassInterfaceAttribute(ClassInterfaceType.None)]
[GuidAttribute("DDBC0BE8-F58D-4bde-B658-6FB1E0851C4C")]
[ProgIdAttribute("FCFLCompat.FCBulk")]
[ComVisibleAttribute(true)]
[IDispatchImplAttribute(IDispatchImplType.CompatibleImpl)]
public sealed class FCBulk : IFCBulk

Inheritance Hierarchy

System.Object
FChoice.Foundation.Clarify.Compatibility.FCBulk

Requirements

Namespace: FChoice.Foundation.Clarify.Compatibility

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Foundation.Clarify.Compatibility (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Foundation.Clarify.Compatibility.dll)

Reference

FCBulk Members
FChoice.Foundation.Clarify.Compatibility Namespace


FCBulk Class Members | fcSDK Documentation

FCBulk Class Members

The following tables list the members exposed by FCBulk.

Public Properties

 | Name | Description
Public Property | BulkID |
Public Property | Name |
Public Property | NoSorting |

Public Methods

 | Name | Description
Public Method | AddGeneric |
Public Method | ChangeGenericsOrdering |
Public Method | GenericCount |
Public Method | NewEnum |
Public Method | Query |
Public Method | RemoveAllGenerics |
Public Method | RemoveGeneric |
Public Method | Update |
Public Method | UpdateAll |

Reference

FCBulk Class
FChoice.Foundation.Clarify.Compatibility Namespace


AddGeneric Method (FCBulk) | fcSDK Documentation

AddGeneric Method (FCBulk)

Syntax

'Declaration

Public Sub AddGeneric( _
   ByVal _generic_ As IFCGeneric _
)

public void AddGeneric(
   IFCGeneric _generic_
)

Parameters

generic

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCBulk Class
FCBulk Members


ChangeGenericsOrdering Method (FCBulk) | fcSDK Documentation

ChangeGenericsOrdering Method (FCBulk)

Syntax

'Declaration

Public Sub ChangeGenericsOrdering( _
   ByVal _generic_ As IFCGeneric _
)

public void ChangeGenericsOrdering(
   IFCGeneric _generic_
)

Parameters

generic

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCBulk Class
FCBulk Members


GenericCount Method | fcSDK Documentation

GenericCount Method

Syntax

'Declaration

Public Function GenericCount() As Integer

public int GenericCount()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCBulk Class
FCBulk Members


NewEnum Method (FCBulk) | fcSDK Documentation

NewEnum Method (FCBulk)

Syntax

'Declaration
<DispIdAttribute(-4)>
Public Function NewEnum() As IEnumerator

[DispIdAttribute(-4)]
public IEnumerator NewEnum()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCBulk Class
FCBulk Members


Query Method (FCBulk) | fcSDK Documentation

Query Method (FCBulk)

Syntax

'Declaration

Public Sub Query()

public void Query()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCBulk Class
FCBulk Members


RemoveAllGenerics Method (FCBulk) | fcSDK Documentation

RemoveAllGenerics Method (FCBulk)

Syntax

'Declaration

Public Sub RemoveAllGenerics()

public void RemoveAllGenerics()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCBulk Class
FCBulk Members


RemoveGeneric Method (FCBulk) | fcSDK Documentation

RemoveGeneric Method (FCBulk)

Syntax

'Declaration

Public Sub RemoveGeneric( _
   ByVal _generic_ As IFCGeneric _
)

public void RemoveGeneric(
   IFCGeneric _generic_
)

Parameters

generic

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCBulk Class
FCBulk Members


Update Method (FCBulk) | fcSDK Documentation

Update Method (FCBulk)

Syntax

'Declaration

Public Sub Update()

public void Update()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCBulk Class
FCBulk Members


UpdateAll Method (FCBulk) | fcSDK Documentation

UpdateAll Method (FCBulk)

Syntax

'Declaration

Public Sub UpdateAll()

public void UpdateAll()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCBulk Class
FCBulk Members


BulkID Property (FCBulk) | fcSDK Documentation

BulkID Property (FCBulk)

Syntax

'Declaration

Public Property BulkID As Short

public short BulkID {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCBulk Class
FCBulk Members


Name Property (FCBulk) | fcSDK Documentation

Name Property (FCBulk)

Syntax

'Declaration

Public Property Name As String

public string Name {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCBulk Class
FCBulk Members


NoSorting Property (FCBulk) | fcSDK Documentation

NoSorting Property (FCBulk)

Syntax

'Declaration

Public Property NoSorting As Boolean

public bool NoSorting {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCBulk Class
FCBulk Members


FCGeneric Class | fcSDK Documentation

FCGeneric Class

Syntax

'Declaration

<GuidAttribute("2888C9FF-F557-4CEA-BDDF-08DF16715D6E")>
<IDispatchImplAttribute(IDispatchImplType.CompatibleImpl)>
<ComVisibleAttribute(True)>
<DefaultMemberAttribute("Item")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
<ProgIdAttribute("FCFLCompat.FCGeneric")>
Public NotInheritable Class FCGeneric
   Implements IFCGeneric

[GuidAttribute("2888C9FF-F557-4CEA-BDDF-08DF16715D6E")]
[IDispatchImplAttribute(IDispatchImplType.CompatibleImpl)]
[ComVisibleAttribute(true)]
[DefaultMemberAttribute("Item")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
[ProgIdAttribute("FCFLCompat.FCGeneric")]
public sealed class FCGeneric : IFCGeneric

Inheritance Hierarchy

System.Object
FChoice.Foundation.Clarify.Compatibility.FCGeneric

Requirements

Namespace: FChoice.Foundation.Clarify.Compatibility

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Foundation.Clarify.Compatibility (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Foundation.Clarify.Compatibility.dll)

Reference

FCGeneric Members
FChoice.Foundation.Clarify.Compatibility Namespace


FCGeneric Class Members | fcSDK Documentation

FCGeneric Class Members

The following tables list the members exposed by FCGeneric.

Public Properties

 | Name | Description
Public Property | BOF |
Public Property | Bulk |
Public Property | BulkName |
Public Property | child_objects |
Public Property | DataFields |
Public Property | DbObjectName |
Public Property | DbObjectNum |
Public Property | DelRelList |
Public Property | Distinct |
Public Property | EOF |
Public Property | ErrorOnQueryTooBig |
Public Property | Filter |
Public Property | GenericId |
Public Property | Id |
Public Property | IncludeRelations |
Public Property | Item |
Public Property | MaxRecords |
Public Property | NoRes |
Public Property | ParentBO |
Public Property | ParentRelation |
Public Property | Position |
Public Property | QueryEmptyToNull |
Public Property | records |
Public Property | rel_from_parent |
Public Property | rel_to_parent |
Public Property | rel_type |
Public Property | rowLimit |
Public Property | rowsReturned |
Public Property | SetNullStringsToEmpty |
Public Property | SortOrder |

Public Methods

 | Name | Description
Public Method | AddForUpdate |
Public Method | AddNew |
Public Method | AppendFilter |
Public Method | AppendSort |
Public Method | AssignAllObjids |
Public Method | AssignObjid |
Public Method | ClearRoot |
Public Method | CloseGeneric |
Public Method | copy |
Public Method | Count |
Public Method | Delete |
Public Method | DeleteAll |
Public Method | Duplicate |
Public Method | get_Fields |
Public Method | GetField |
Public Method | GetFieldValue |
Public Method | let_Fields |
Public Method | MoveFirst |
Public Method | MoveFirstAbsolute |
Public Method | MoveLast |
Public Method | MoveLastAbsolute |
Public Method | MoveNext |
Public Method | MoveNextAbsolute |
Public Method | MovePrevious |
Public Method | MovePreviousAbsolute |
Public Method | MoveRelative |
Public Method | Query |
Public Method | RelateByID |
Public Method | RelateIntFldByID |
Public Method | RelateIntFldToRecord |
Public Method | RelateRecords |
Public Method | set_Fields |
Public Method | SimpleQuery |
Public Method | TotalCount |
Public Method | TraverseFromParent |
Public Method | TraverseFromRoot |
Public Method | UnRelateAll |
Public Method | UnRelateRecordFromAll |
Public Method | UnRelateRecords |
Public Method | Untraverse |
Public Method | Update |
Public Method | UpdateAll |

Reference

FCGeneric Class
FChoice.Foundation.Clarify.Compatibility Namespace


AddForUpdate Method (FCGeneric) | fcSDK Documentation

AddForUpdate Method (FCGeneric)

Syntax

'Declaration

Public Sub AddForUpdate( _
   ByVal _TheObjid_ As Integer _
)

public void AddForUpdate(
   int _TheObjid_
)

Parameters

TheObjid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


AddNew Method (FCGeneric) | fcSDK Documentation

AddNew Method (FCGeneric)

Syntax

'Declaration

Public Sub AddNew()

public void AddNew()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


AppendFilter Method (FCGeneric) | fcSDK Documentation

AppendFilter Method (FCGeneric)

Syntax

'Declaration

Public Sub AppendFilter( _
   ByVal _fieldName_ As String, _
   ByVal _operation_ As String, _
   ByVal _filterValue_ As Object _
)

public void AppendFilter(
   string _fieldName_,
   string _operation_,
   object _filterValue_
)

Parameters

fieldName

operation

filterValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


AppendSort Method (FCGeneric) | fcSDK Documentation

AppendSort Method (FCGeneric)

Syntax

'Declaration

Public Sub AppendSort( _
   ByVal _fieldName_ As String, _
   ByVal _ascending_ As String _
)

public void AppendSort(
   string _fieldName_,
   string _ascending_
)

Parameters

fieldName

ascending

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


AssignAllObjids Method (FCGeneric) | fcSDK Documentation

AssignAllObjids Method (FCGeneric)

Syntax

'Declaration

Public Sub AssignAllObjids()

public void AssignAllObjids()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


AssignObjid Method (FCGeneric) | fcSDK Documentation

AssignObjid Method (FCGeneric)

Syntax

'Declaration

Public Sub AssignObjid()

public void AssignObjid()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


ClearRoot Method (FCGeneric) | fcSDK Documentation

ClearRoot Method (FCGeneric)

Syntax

'Declaration

Public Sub ClearRoot()

public void ClearRoot()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


CloseGeneric Method (FCGeneric) | fcSDK Documentation

CloseGeneric Method (FCGeneric)

Syntax

'Declaration

Public Sub CloseGeneric()

public void CloseGeneric()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


copy Method (FCGeneric) | fcSDK Documentation

copy Method (FCGeneric)

Syntax

'Declaration

Public Function copy( _
   Optional ByVal _use_generic_ As Object _
) As IFCGeneric

public IFCGeneric copy(
   object _use_generic_
)

Parameters

use_generic

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


Count Method (FCGeneric) | fcSDK Documentation

Count Method (FCGeneric)

Syntax

'Declaration

Public Function Count() As Integer

public int Count()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


Delete Method (FCGeneric) | fcSDK Documentation

Delete Method (FCGeneric)

Syntax

'Declaration

Public Sub Delete()

public void Delete()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


DeleteAll Method (FCGeneric) | fcSDK Documentation

DeleteAll Method (FCGeneric)

Syntax

'Declaration

Public Sub DeleteAll()

public void DeleteAll()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


Duplicate Method (FCGeneric) | fcSDK Documentation

Duplicate Method (FCGeneric)

Syntax

'Declaration

Public Function Duplicate( _
   Optional ByVal _use_generic_ As Object _
) As IFCGeneric

public IFCGeneric Duplicate(
   object _use_generic_
)

Parameters

use_generic

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


get_Fields Method (FCGeneric) | fcSDK Documentation

get_Fields Method (FCGeneric)

Syntax

'Declaration

Public Function get_Fields( _
   ByVal _index_ As Object _
) As Object

public object get_Fields(
   object _index_
)

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


GetField Method (FCGeneric) | fcSDK Documentation

GetField Method (FCGeneric)

Syntax

'Declaration

Public Function GetField( _
   ByVal _fieldName_ As String _
) As Object

public object GetField(
   string _fieldName_
)

Parameters

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


GetFieldValue Method (FCGeneric) | fcSDK Documentation

GetFieldValue Method (FCGeneric)

Syntax

'Declaration

Public Function GetFieldValue( _
   ByVal _index_ As Object _
) As Object

public object GetFieldValue(
   object _index_
)

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


let_Fields Method | fcSDK Documentation

let_Fields Method

Syntax

'Declaration

<ComVisibleAttribute(False)>
Public Sub let_Fields( _
   ByVal _index_ As Object, _
   ByVal _newValue_ As Object _
)

[ComVisibleAttribute(false)]
public void let_Fields(
   object _index_,
   object _newValue_
)

Parameters

index

newValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


MoveFirst Method (FCGeneric) | fcSDK Documentation

MoveFirst Method (FCGeneric)

Syntax

'Declaration

Public Sub MoveFirst()

public void MoveFirst()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


MoveFirstAbsolute Method (FCGeneric) | fcSDK Documentation

MoveFirstAbsolute Method (FCGeneric)

Syntax

'Declaration

Public Sub MoveFirstAbsolute()

public void MoveFirstAbsolute()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


MoveLast Method (FCGeneric) | fcSDK Documentation

MoveLast Method (FCGeneric)

Syntax

'Declaration

Public Sub MoveLast()

public void MoveLast()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


MoveLastAbsolute Method (FCGeneric) | fcSDK Documentation

MoveLastAbsolute Method (FCGeneric)

Syntax

'Declaration

Public Sub MoveLastAbsolute()

public void MoveLastAbsolute()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


MoveNext Method (FCGeneric) | fcSDK Documentation

MoveNext Method (FCGeneric)

Syntax

'Declaration

Public Sub MoveNext()

public void MoveNext()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


MoveNextAbsolute Method (FCGeneric) | fcSDK Documentation

MoveNextAbsolute Method (FCGeneric)

Syntax

'Declaration

Public Sub MoveNextAbsolute()

public void MoveNextAbsolute()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


MovePrevious Method (FCGeneric) | fcSDK Documentation

MovePrevious Method (FCGeneric)

Syntax

'Declaration

Public Sub MovePrevious()

public void MovePrevious()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


MovePreviousAbsolute Method (FCGeneric) | fcSDK Documentation

MovePreviousAbsolute Method (FCGeneric)

Syntax

'Declaration

Public Sub MovePreviousAbsolute()

public void MovePreviousAbsolute()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


MoveRelative Method (FCGeneric) | fcSDK Documentation

MoveRelative Method (FCGeneric)

Syntax

'Declaration

Public Sub MoveRelative( _
   ByVal _NumToMove_ As Short _
)

public void MoveRelative(
   short _NumToMove_
)

Parameters

NumToMove

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


Query Method (FCGeneric) | fcSDK Documentation

Query Method (FCGeneric)

Syntax

'Declaration

Public Sub Query()

public void Query()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


RelateByID Method (FCGeneric) | fcSDK Documentation

RelateByID Method (FCGeneric)

Syntax

'Declaration

Public Sub RelateByID( _
   ByVal _objId_ As Integer, _
   ByVal _relationName_ As String _
)

public void RelateByID(
   int _objId_,
   string _relationName_
)

Parameters

objId

relationName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


RelateIntFldByID Method (FCGeneric) | fcSDK Documentation

RelateIntFldByID Method (FCGeneric)

Syntax

'Declaration

Public Sub RelateIntFldByID( _
   ByVal _objId_ As Integer, _
   ByVal _fieldName_ As String _
)

public void RelateIntFldByID(
   int _objId_,
   string _fieldName_
)

Parameters

objId

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


RelateIntFldToRecord Method (FCGeneric) | fcSDK Documentation

RelateIntFldToRecord Method (FCGeneric)

Syntax

'Declaration

Public Sub RelateIntFldToRecord( _
   ByVal _otherGeneric_ As IFCGeneric, _
   ByVal _myIntFieldName_ As String _
)

public void RelateIntFldToRecord(
   IFCGeneric _otherGeneric_,
   string _myIntFieldName_
)

Parameters

otherGeneric

myIntFieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


RelateRecords Method (FCGeneric) | fcSDK Documentation

RelateRecords Method (FCGeneric)

Syntax

'Declaration

Public Sub RelateRecords( _
   ByVal _otherGeneric_ As IFCGeneric, _
   ByVal _relationName_ As String _
)

public void RelateRecords(
   IFCGeneric _otherGeneric_,
   string _relationName_
)

Parameters

otherGeneric

relationName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


set_Fields Method (FCGeneric) | fcSDK Documentation

set_Fields Method (FCGeneric)

Syntax

'Declaration

Public Sub set_Fields( _
   ByVal _index_ As Object, _
   ByVal _newValue_ As Object _
)

public void set_Fields(
   object _index_,
   object _newValue_
)

Parameters

index

newValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


SimpleQuery Method (FCGeneric) | fcSDK Documentation

SimpleQuery Method (FCGeneric)

Syntax

'Declaration

Public Sub SimpleQuery( _
   ByVal _dbObjectName_ As String _
)

public void SimpleQuery(
   string _dbObjectName_
)

Parameters

dbObjectName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


TotalCount Method (FCGeneric) | fcSDK Documentation

TotalCount Method (FCGeneric)

Syntax

'Declaration

Public Function TotalCount() As Integer

public int TotalCount()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


TraverseFromParent Method (FCGeneric) | fcSDK Documentation

TraverseFromParent Method (FCGeneric)

Syntax

'Declaration

Public Sub TraverseFromParent( _
   ByVal _parentGeneric_ As IFCGeneric, _
   ByVal _traverseRelation_ As String _
)

public void TraverseFromParent(
   IFCGeneric _parentGeneric_,
   string _traverseRelation_
)

Parameters

parentGeneric

traverseRelation

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


TraverseFromRoot Method (FCGeneric) | fcSDK Documentation

TraverseFromRoot Method (FCGeneric)

Syntax

'Declaration

Public Sub TraverseFromRoot( _
   ByVal _RootObjid_ As Integer, _
   ByVal _TblName_ As String, _
   ByVal _RootRel_ As String _
)

public void TraverseFromRoot(
   int _RootObjid_,
   string _TblName_,
   string _RootRel_
)

Parameters

RootObjid

TblName

RootRel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


UnRelateAll Method (FCGeneric) | fcSDK Documentation

UnRelateAll Method (FCGeneric)

Syntax

'Declaration

Public Sub UnRelateAll( _
   ByVal _relationName_ As String _
)

public void UnRelateAll(
   string _relationName_
)

Parameters

relationName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


UnRelateRecordFromAll Method (FCGeneric) | fcSDK Documentation

UnRelateRecordFromAll Method (FCGeneric)

Syntax

'Declaration

Public Sub UnRelateRecordFromAll( _
   ByVal _relationName_ As String _
)

public void UnRelateRecordFromAll(
   string _relationName_
)

Parameters

relationName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


UnRelateRecords Method (FCGeneric) | fcSDK Documentation

UnRelateRecords Method (FCGeneric)

Syntax

'Declaration

Public Sub UnRelateRecords( _
   ByVal _o_obj_ As IFCGeneric, _
   ByVal _relationName_ As String _
)

public void UnRelateRecords(
   IFCGeneric _o_obj_,
   string _relationName_
)

Parameters

o_obj

relationName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


Untraverse Method (FCGeneric) | fcSDK Documentation

Untraverse Method (FCGeneric)

Syntax

'Declaration

Public Sub Untraverse()

public void Untraverse()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


Update Method (FCGeneric) | fcSDK Documentation

Update Method (FCGeneric)

Syntax

'Declaration

Public Sub Update()

public void Update()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


UpdateAll Method (FCGeneric) | fcSDK Documentation

UpdateAll Method (FCGeneric)

Syntax

'Declaration

Public Sub UpdateAll()

public void UpdateAll()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


BOF Property (FCGeneric) | fcSDK Documentation

BOF Property (FCGeneric)

Syntax

'Declaration

Public ReadOnly Property BOF As Boolean

public bool BOF {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


Bulk Property (FCGeneric) | fcSDK Documentation

Bulk Property (FCGeneric)

Syntax

'Declaration

Public Property Bulk As IFCBulk

public IFCBulk Bulk {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


BulkName Property (FCGeneric) | fcSDK Documentation

BulkName Property (FCGeneric)

Syntax

'Declaration

Public Property BulkName As String

public string BulkName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


child_objects Property (FCGeneric) | fcSDK Documentation

child_objects Property (FCGeneric)

Syntax

'Declaration

Public ReadOnly Property child_objects As IMockCollection

public IMockCollection child_objects {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


DataFields Property (FCGeneric) | fcSDK Documentation

DataFields Property (FCGeneric)

Syntax

'Declaration

Public Property DataFields As String

public string DataFields {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


DbObjectName Property (FCGeneric) | fcSDK Documentation

DbObjectName Property (FCGeneric)

Syntax

'Declaration

Public Property DbObjectName As String

public string DbObjectName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


DbObjectNum Property (FCGeneric) | fcSDK Documentation

DbObjectNum Property (FCGeneric)

Syntax

'Declaration

Public ReadOnly Property DbObjectNum As Integer

public int DbObjectNum {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


DelRelList Property (FCGeneric) | fcSDK Documentation

DelRelList Property (FCGeneric)

Syntax

'Declaration

Public Property DelRelList As String

public string DelRelList {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


Distinct Property (FCGeneric) | fcSDK Documentation

Distinct Property (FCGeneric)

Syntax

'Declaration

Public Property Distinct As Boolean

public bool Distinct {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


EOF Property (FCGeneric) | fcSDK Documentation

EOF Property (FCGeneric)

Syntax

'Declaration

Public ReadOnly Property EOF As Boolean

public bool EOF {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


ErrorOnQueryTooBig Property (FCGeneric) | fcSDK Documentation

ErrorOnQueryTooBig Property (FCGeneric)

Syntax

'Declaration

Public Property ErrorOnQueryTooBig As Boolean

public bool ErrorOnQueryTooBig {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


Filter Property (FCGeneric) | fcSDK Documentation

Filter Property (FCGeneric)

Syntax

'Declaration

Public Property Filter As String

public string Filter {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


GenericId Property (FCGeneric) | fcSDK Documentation

GenericId Property (FCGeneric)

Syntax

'Declaration

Public Property GenericId As String

public string GenericId {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


Id Property (FCGeneric) | fcSDK Documentation

Id Property (FCGeneric)

Syntax

'Declaration

Public ReadOnly Property Id As Integer

public int Id {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


IncludeRelations Property (FCGeneric) | fcSDK Documentation

IncludeRelations Property (FCGeneric)

Syntax

'Declaration

Public Property IncludeRelations As Boolean

public bool IncludeRelations {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


Item Property (FCGeneric) | fcSDK Documentation

Item Property (FCGeneric)

Syntax

'Declaration

<ComVisibleAttribute(False)>
Public Default Property Item( _
   ByVal _colIndex_ As Object _
) As IMockAdoField

[ComVisibleAttribute(false)]
public IMockAdoField this[
   object _colIndex_
]; {get; set;}

Parameters

colIndex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


MaxRecords Property (FCGeneric) | fcSDK Documentation

MaxRecords Property (FCGeneric)

Syntax

'Declaration

Public Property MaxRecords As Integer

public int MaxRecords {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


NoRes Property (FCGeneric) | fcSDK Documentation

NoRes Property (FCGeneric)

Syntax

'Declaration

Public Property NoRes As Boolean

public bool NoRes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


ParentBO Property (FCGeneric) | fcSDK Documentation

ParentBO Property (FCGeneric)

Syntax

'Declaration

Public Property ParentBO As IFCGeneric

public IFCGeneric ParentBO {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


ParentRelation Property (FCGeneric) | fcSDK Documentation

ParentRelation Property (FCGeneric)

Syntax

'Declaration

Public Property ParentRelation As String

public string ParentRelation {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


Position Property (FCGeneric) | fcSDK Documentation

Position Property (FCGeneric)

Syntax

'Declaration

Public Property Position As Short

public short Position {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


QueryEmptyToNull Property (FCGeneric) | fcSDK Documentation

QueryEmptyToNull Property (FCGeneric)

Syntax

'Declaration

Public Property QueryEmptyToNull As Boolean

public bool QueryEmptyToNull {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


records Property (FCGeneric) | fcSDK Documentation

records Property (FCGeneric)

Syntax

'Declaration

Public ReadOnly Property records As ADODB.Recordset

public ADODB.Recordset records {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


rel_from_parent Property (FCGeneric) | fcSDK Documentation

rel_from_parent Property (FCGeneric)

Syntax

'Declaration

Public ReadOnly Property rel_from_parent As String

public string rel_from_parent {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


rel_to_parent Property (FCGeneric) | fcSDK Documentation

rel_to_parent Property (FCGeneric)

Syntax

'Declaration

Public ReadOnly Property rel_to_parent As String

public string rel_to_parent {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


rel_type Property (FCGeneric) | fcSDK Documentation

rel_type Property (FCGeneric)

Syntax

'Declaration

Public ReadOnly Property rel_type As Short

public short rel_type {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


rowLimit Property (FCGeneric) | fcSDK Documentation

rowLimit Property (FCGeneric)

Syntax

'Declaration

Public Property rowLimit As Integer

public int rowLimit {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


rowsReturned Property (FCGeneric) | fcSDK Documentation

rowsReturned Property (FCGeneric)

Syntax

'Declaration

Public ReadOnly Property rowsReturned As Integer

public int rowsReturned {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


SetNullStringsToEmpty Property (FCGeneric) | fcSDK Documentation

SetNullStringsToEmpty Property (FCGeneric)

Syntax

'Declaration

Public Property SetNullStringsToEmpty As Boolean

public bool SetNullStringsToEmpty {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


SortOrder Property (FCGeneric) | fcSDK Documentation

SortOrder Property (FCGeneric)

Syntax

'Declaration

Public Property SortOrder As String

public string SortOrder {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCGeneric Class
FCGeneric Members


FCList Class | fcSDK Documentation

FCList Class

Syntax

'Declaration

<GuidAttribute("007EE1DD-6614-4833-BB7F-2AB543B42CE9")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
<ComVisibleAttribute(True)>
<IDispatchImplAttribute(IDispatchImplType.CompatibleImpl)>
<ProgIdAttribute("FCFLCompat.FCList")>
Public NotInheritable Class FCList
   Implements IFCList

[GuidAttribute("007EE1DD-6614-4833-BB7F-2AB543B42CE9")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
[ComVisibleAttribute(true)]
[IDispatchImplAttribute(IDispatchImplType.CompatibleImpl)]
[ProgIdAttribute("FCFLCompat.FCList")]
public sealed class FCList : IFCList

Inheritance Hierarchy

System.Object
FChoice.Foundation.Clarify.Compatibility.FCList

Requirements

Namespace: FChoice.Foundation.Clarify.Compatibility

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Foundation.Clarify.Compatibility (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Foundation.Clarify.Compatibility.dll)

Reference

FCList Members
FChoice.Foundation.Clarify.Compatibility Namespace


FCList Class Members | fcSDK Documentation

FCList Class Members

The following tables list the members exposed by FCList.

Public Constructors

 | Name | Description
Public Constructor | FCList Constructor |

Public Properties

 | Name | Description
Public Property | AllowDuplicates |
Public Property | Count |
Public Property | ItemType |
Public Property | Sorted |

Public Methods

 | Name | Description
Public Method | AppendItem |
Public Method | AppendSingleItem |
Public Method | Clear |
Public Method | Contains |
Public Method | FindFirstindex |
Public Method | GetItemByIndex |
Public Method | ItemByIndex |
Public Method | Sort |

Reference

FCList Class
FChoice.Foundation.Clarify.Compatibility Namespace


FCList Constructor | fcSDK Documentation

FCList Constructor

Syntax

'Declaration

Public Function New()

public FCList()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCList Class
FCList Members


AppendItem Method (FCList) | fcSDK Documentation

AppendItem Method (FCList)

Syntax

'Declaration

Public Sub AppendItem( _
   ByVal _param1_ As Object, _
   Optional ByVal _param2_ As Object, _
   Optional ByVal _param3_ As Object, _
   Optional ByVal _param4_ As Object, _
   Optional ByVal _param5_ As Object, _
   Optional ByVal _param6_ As Object, _
   Optional ByVal _param7_ As Object, _
   Optional ByVal _param8_ As Object, _
   Optional ByVal _param9_ As Object _
)

public void AppendItem(
   object _param1_,
   object _param2_,
   object _param3_,
   object _param4_,
   object _param5_,
   object _param6_,
   object _param7_,
   object _param8_,
   object _param9_
)

Parameters

param1

param2

param3

param4

param5

param6

param7

param8

param9

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCList Class
FCList Members


AppendSingleItem Method (FCList) | fcSDK Documentation

AppendSingleItem Method (FCList)

Syntax

'Declaration

Public Sub AppendSingleItem( _
   ByVal _appendItem_ As Object _
)

public void AppendSingleItem(
   object _appendItem_
)

Parameters

appendItem

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCList Class
FCList Members


Clear Method (FCList) | fcSDK Documentation

Clear Method (FCList)

Syntax

'Declaration

Public Sub Clear()

public void Clear()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCList Class
FCList Members


Contains Method (FCList) | fcSDK Documentation

Contains Method (FCList)

Syntax

'Declaration

Public Function Contains( _
   ByVal _item_ As Object _
) As Boolean

public bool Contains(
   object _item_
)

Parameters

item

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCList Class
FCList Members


FindFirstindex Method (FCList) | fcSDK Documentation

FindFirstindex Method (FCList)

Syntax

'Declaration

Public Function FindFirstindex( _
   ByVal _param1_ As Object _
) As Short

public short FindFirstindex(
   object _param1_
)

Parameters

param1

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCList Class
FCList Members


GetItemByIndex Method (FCList) | fcSDK Documentation

GetItemByIndex Method (FCList)

Syntax

'Declaration

Public Sub GetItemByIndex( _
   ByVal _index_ As Short, _
   ByRef _item_ As Object _
)

public void GetItemByIndex(
   short _index_,
   ref object _item_
)

Parameters

index

item

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCList Class
FCList Members


ItemByIndex Method (FCList) | fcSDK Documentation

ItemByIndex Method (FCList)

Syntax

'Declaration

Public Function ItemByIndex( _
   ByVal _index_ As Short _
) As Object

public object ItemByIndex(
   short _index_
)

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCList Class
FCList Members


Sort Method (FCList) | fcSDK Documentation

Sort Method (FCList)

Syntax

'Declaration

Public Sub Sort()

public void Sort()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCList Class
FCList Members


AllowDuplicates Property (FCList) | fcSDK Documentation

AllowDuplicates Property (FCList)

Syntax

'Declaration

Public Property AllowDuplicates As Boolean

public bool AllowDuplicates {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCList Class
FCList Members


Count Property (FCList) | fcSDK Documentation

Count Property (FCList)

Syntax

'Declaration

Public ReadOnly Property Count As Short

public short Count {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCList Class
FCList Members


ItemType Property (FCList) | fcSDK Documentation

ItemType Property (FCList)

Syntax

'Declaration

Public Property ItemType As String

public string ItemType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCList Class
FCList Members


Sorted Property (FCList) | fcSDK Documentation

Sorted Property (FCList)

Syntax

'Declaration

Public ReadOnly Property Sorted As Boolean

public bool Sorted {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCList Class
FCList Members


FCNotLoggedInException Class | fcSDK Documentation

FCNotLoggedInException Class

Syntax

'Declaration

<ComVisibleAttribute(False)>
<SerializableAttribute()>
Public Class FCNotLoggedInException
   Inherits CompatibilityException

[ComVisibleAttribute(false)]
[SerializableAttribute()]
public class FCNotLoggedInException : CompatibilityException

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
FChoice.Common.FCExceptionBase
FChoice.Foundation.Clarify.Compatibility.CompatibilityException
FChoice.Foundation.Clarify.Compatibility.FCNotLoggedInException

Requirements

Namespace: FChoice.Foundation.Clarify.Compatibility

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Foundation.Clarify.Compatibility (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Foundation.Clarify.Compatibility.dll)

Reference

FCNotLoggedInException Members
FChoice.Foundation.Clarify.Compatibility Namespace


FCNotLoggedInException Class Members | fcSDK Documentation

FCNotLoggedInException Class Members

The following tables list the members exposed by FCNotLoggedInException.

Public Constructors

 | Name | Description
Public Constructor | FCNotLoggedInException Constructor |

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorCode | Gets the unique error code for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | ErrorMessageID | Gets the message identifier for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | Sets the SerializationInfo object with the parameter name and additional exception information. (Inherited from FChoice.Common.FCExceptionBase)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)

Reference

FCNotLoggedInException Class
FChoice.Foundation.Clarify.Compatibility Namespace


FCNotLoggedInException Constructor | fcSDK Documentation

FCNotLoggedInException Constructor

Syntax

'Declaration

Public Function New( _
   ByVal _errorId_ As Integer _
)

public FCNotLoggedInException(
   int _errorId_
)

Parameters

errorId

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCNotLoggedInException Class
FCNotLoggedInException Members


FCSession Class | fcSDK Documentation

FCSession Class

Syntax

'Declaration
<GuidAttribute("906C1CC2-5CE2-456b-BF53-129336DAA394")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
<ComVisibleAttribute(True)>
<IDispatchImplAttribute(IDispatchImplType.CompatibleImpl)>
<ProgIdAttribute("FCFLCompat.FCSession")>
<DefaultMemberAttribute("Item")>
Public NotInheritable Class FCSession
   Implements IFCSession

[GuidAttribute("906C1CC2-5CE2-456b-BF53-129336DAA394")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
[ComVisibleAttribute(true)]
[IDispatchImplAttribute(IDispatchImplType.CompatibleImpl)]
[ProgIdAttribute("FCFLCompat.FCSession")]
[DefaultMemberAttribute("Item")]
public sealed class FCSession : IFCSession

Inheritance Hierarchy

System.Object
FChoice.Foundation.Clarify.Compatibility.FCSession

Requirements

Namespace: FChoice.Foundation.Clarify.Compatibility

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Foundation.Clarify.Compatibility (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Foundation.Clarify.Compatibility.dll)

Reference

FCSession Members
FChoice.Foundation.Clarify.Compatibility Namespace


FCSession Class Members | fcSDK Documentation

FCSession Class Members

The following tables list the members exposed by FCSession.

Public Properties

 | Name | Description
Public Property | ad_auto |
Public Property | ad_list |
Public Property | BulkCollection |
Public Property | ConvertTimeZone |
Public Property | cur_res |
Public Property | CurrentCulture |
Public Property | CurrentNetTransaction |
Public Property | DbHelper |
Public Property | Distinct |
Public Property | ErrorMessage |
Public Property | ErrorNumber |
Public Property | ErrorSource |
Public Property | hist_change |
Public Property | IncludeRelations |
Public Property | IsInTransaction |
Public Property | IsLoggedIn |
Public Property | Item |
Public Property | LocalTimeZone |
Public Property | LocalTimeZoneOffset |
Public Property | LoginTime |
Public Property | NoRes |
Public Property | num_ad |
Public Property | PasswordRequired |
Public Property | QueryEmptyToNull |
Public Property | RESEnabled |
Public Property | rowLimit |
Public Property | SessionID |
Public Property | SetNullStringsToEmpty |
Public Property | ThrowErrors |
Public Property | TruncateStringFields |
Public Property | UpdateTime |

Public Methods

 | Name | Description
Public Method | accept_object |
Public Method | active_connection |
Public Method | AddAttachment |
Public Method | AppendFilter |
Public Method | assign_object |
Public Method | auto_dest |
Public Method | AutoDest |
Public Method | build_hist |
Public Method | build_lists |
Public Method | BuildUserVersionProc |
Public Method | change_obj_status |
Public Method | ChangePassword |
Public Method | ChangeResGroup |
Public Method | check_cl_trans |
Public Method | CloseAllGenerics |
Public Method | CloseGenerics |
Public Method | CloseSession |
Public Method | CommitTransaction |
Public Method | ConvertDate |
Public Method | ConvertFromLocalToServerTZ |
Public Method | ConvertFromServerToLocalTZ |
Public Method | create_act_entry | Overloaded.
Public Method | create_time_bomb | Overloaded.
Public Method | createBulk |
Public Method | CreateGeneric |
Public Method | CreateSqlExec |
Public Method | dispatch_object |
Public Method | Dispose |
Public Method | error_handler | Overloaded.
Public Method | ExecuteSQL |
Public Method | ExecuteSQLNoReturn |
Public Method | format_time |
Public Method | forward_object |
Public Method | FreeConnection |
Public Method | get_item |
Public Method | get_next_sn |
Public Method | GetColor |
Public Method | GetConfigItem |
Public Method | GetCurrentDate |
Public Method | GetCurrentServerDate |
Public Method | GetItem |
Public Method | GetNextNumScheme |
Public Method | GetNextSubcaseID | Overloaded.
Public Method | GetNumGenerics |
Public Method | GetObjid |
Public Method | GetUserVersion |
Public Method | Init_Object |
Public Method | IsUnicode |
Public Method | ItemCount |
Public Method | LoadColors |
Public Method | LoadUserVersions |
Public Method | Log |
Public Method | LogEx |
Public Method | Login |
Public Method | LoginFromFCApp |
Public Method | Logout |
Public Method | move_object |
Public Method | NewEnum |
Public Method | RefreshContext |
Public Method | RegisterLicenseRequirements |
Public Method | reject_object |
Public Method | RemoveAllGenericsInABulk |
Public Method | RollbackTransaction |
Public Method | SaveSession |
Public Method | set_item |
Public Method | SetNullStringToEmpty |
Public Method | SetPassword |
Public Method | SimpleQuery |
Public Method | single_quotify |
Public Method | sprintf |
Public Method | StartTransaction |
Public Method | TraverseFromParent |
Public Method | turn_off |
Public Method | use_list |
Public Method | yank_object |

Reference

FCSession Class
FChoice.Foundation.Clarify.Compatibility Namespace


accept_object Method (FCSession) | fcSDK Documentation

accept_object Method (FCSession)

Syntax

'Declaration

Public Function accept_object( _
   ByVal _objId_ As String, _
   ByRef _acceptDate_ As String, _
   ByRef _wipBin_ As String, _
   ByRef _localUserName_ As String, _
   ByVal _generateTimeBombs_ As Boolean, _
   ByVal _objectType_ As String _
) As Short

public short accept_object(
   string _objId_,
   out string _acceptDate_,
   out string _wipBin_,
   out string _localUserName_,
   bool _generateTimeBombs_,
   string _objectType_
)

Parameters

objId

acceptDate

wipBin

localUserName

generateTimeBombs

objectType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


active_connection Method (FCSession) | fcSDK Documentation

active_connection Method (FCSession)

Syntax

'Declaration

Public Function active_connection() As ADODB.Connection

public ADODB.Connection active_connection()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


AddAttachment Method (FCSession) | fcSDK Documentation

AddAttachment Method (FCSession)

Syntax

'Declaration

Public Function AddAttachment( _
   ByVal _attachmentName_ As String, _
   ByVal _filePath_ As String, _
   ByVal _objectType_ As String, _
   ByVal _idNumber_ As String, _
   Optional ByVal _objectObjId_ As Object, _
   Optional ByVal _attachmentType_ As Object _
) As Short

public short AddAttachment(
   string _attachmentName_,
   string _filePath_,
   string _objectType_,
   string _idNumber_,
   object _objectObjId_,
   object _attachmentType_
)

Parameters

attachmentName

filePath

objectType

idNumber

objectObjId

attachmentType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


AppendFilter Method (FCSession) | fcSDK Documentation

AppendFilter Method (FCSession)

Syntax

'Declaration

Public Sub AppendFilter( _
   ByVal _fcGeneric_ As Object, _
   ByVal _fieldName_ As String, _
   ByVal _filterOperator_ As String, _
   ByVal _filterValue_ As Object, _
   Optional ByVal _isAndOr_ As Object _
)

public void AppendFilter(
   object _fcGeneric_,
   string _fieldName_,
   string _filterOperator_,
   object _filterValue_,
   object _isAndOr_
)

Parameters

fcGeneric

fieldName

filterOperator

filterValue

isAndOr

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


assign_object Method (FCSession) | fcSDK Documentation

assign_object Method (FCSession)

Syntax

'Declaration

Public Function assign_object( _
   ByVal _objId_ As String, _
   ByRef _newUser_ As String, _
   ByVal _wipBin_ As String, _
   ByRef _assignDate_ As String, _
   ByRef _localUserName_ As String, _
   ByVal _generateTimeBombs_ As Boolean, _
   ByVal _objectType_ As String _
) As Short

public short assign_object(
   string _objId_,
   out string _newUser_,
   string _wipBin_,
   out string _assignDate_,
   out string _localUserName_,
   bool _generateTimeBombs_,
   string _objectType_
)

Parameters

objId

newUser

wipBin

assignDate

localUserName

generateTimeBombs

objectType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


auto_dest Method (FCSession) | fcSDK Documentation

auto_dest Method (FCSession)

Syntax

'Declaration

Public Function auto_dest( _
   ByVal _objId_ As String, _
   ByVal _operation_ As String, _
   ByVal _idNumber_ As String _
) As Short

public short auto_dest(
   string _objId_,
   string _operation_,
   string _idNumber_
)

Parameters

objId

operation

idNumber

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


AutoDest Method (FCSession) | fcSDK Documentation

AutoDest Method (FCSession)

Syntax

'Declaration

Public Function AutoDest( _
   ByVal _the_object_ As String, _
   ByVal _operation_ As String, _
   ByVal _idNumber_ As String _
) As Short

public short AutoDest(
   string _the_object_,
   string _operation_,
   string _idNumber_
)

Parameters

the_object

operation

idNumber

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


build_hist Method (FCSession) | fcSDK Documentation

build_hist Method (FCSession)

Syntax

'Declaration

Public Function build_hist( _
   ByVal _currentHistory_ As String, _
   ByVal _appendHistory_ As String _
) As String

public string build_hist(
   string _currentHistory_,
   string _appendHistory_
)

Parameters

currentHistory

appendHistory

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


build_lists Method (FCSession) | fcSDK Documentation

build_lists Method (FCSession)

Syntax

'Declaration

Public Sub build_lists( _
   ByVal _int_fld1_ As String, _
   ByVal _int_val1_ As Integer, _
   ByVal _int_fld2_ As String, _
   ByVal _int_val2_ As Integer, _
   ByVal _str_fld1_ As String, _
   ByVal _str_val1_ As String, _
   ByVal _str_fld2_ As String, _
   ByVal _str_val2_ As String, _
   ByVal _date_fld1_ As String, _
   ByVal _date_val1_ As String, _
   ByRef _fld_list_ As IFCList, _
   ByRef _type_list_ As IFCList, _
   ByRef _val_list_ As IFCList, _
   ByRef _list_used_ As Short _
)

public void build_lists(
   string _int_fld1_,
   int _int_val1_,
   string _int_fld2_,
   int _int_val2_,
   string _str_fld1_,
   string _str_val1_,
   string _str_fld2_,
   string _str_val2_,
   string _date_fld1_,
   string _date_val1_,
   ref IFCList _fld_list_,
   ref IFCList _type_list_,
   ref IFCList _val_list_,
   ref short _list_used_
)

Parameters

int_fld1

int_val1

int_fld2

int_val2

str_fld1

str_val1

str_fld2

str_val2

date_fld1

date_val1

fld_list

type_list

val_list

list_used

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


BuildUserVersionProc Method (FCSession) | fcSDK Documentation

BuildUserVersionProc Method (FCSession)

Syntax

'Declaration

Public Function BuildUserVersionProc() As String

public string BuildUserVersionProc()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


change_obj_status Method (FCSession) | fcSDK Documentation

change_obj_status Method (FCSession)

Syntax

'Declaration

Public Function change_obj_status( _
   ByVal _objId_ As String, _
   ByRef _newStatus_ As String, _
   ByRef _changeDate_ As String, _
   ByVal _notes_ As String, _
   ByRef _localUserName_ As String, _
   ByVal _generateTimeBombs_ As Boolean, _
   ByVal _objectType_ As String _
) As Short

public short change_obj_status(
   string _objId_,
   out string _newStatus_,
   out string _changeDate_,
   string _notes_,
   out string _localUserName_,
   bool _generateTimeBombs_,
   string _objectType_
)

Parameters

objId

newStatus

changeDate

notes

localUserName

generateTimeBombs

objectType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


ChangePassword Method (FCSession) | fcSDK Documentation

ChangePassword Method (FCSession)

Syntax

'Declaration

Public Sub ChangePassword( _
   ByVal _password_ As String _
)

public void ChangePassword(
   string _password_
)

Parameters

password

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


ChangeResGroup Method (FCSession) | fcSDK Documentation

ChangeResGroup Method (FCSession)

Syntax

'Declaration

Public Sub ChangeResGroup( _
   ByVal _newGroup_ As String, _
   Optional ByVal _saveToDB_ As Object _
)

public void ChangeResGroup(
   string _newGroup_,
   object _saveToDB_
)

Parameters

newGroup

saveToDB

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


check_cl_trans Method (FCSession) | fcSDK Documentation

check_cl_trans Method (FCSession)

Syntax

'Declaration

Public Function check_cl_trans( _
   ByVal _oldCondition_ As String, _
   ByVal _newCondition_ As String, _
   ByVal _reqType_ As String, _
   ByVal _userName_ As String _
) As Short

public short check_cl_trans(
   string _oldCondition_,
   string _newCondition_,
   string _reqType_,
   string _userName_
)

Parameters

oldCondition

newCondition

reqType

userName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


CloseAllGenerics Method (FCSession) | fcSDK Documentation

CloseAllGenerics Method (FCSession)

Syntax

'Declaration

Public Sub CloseAllGenerics()

public void CloseAllGenerics()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


CloseGenerics Method (FCSession) | fcSDK Documentation

CloseGenerics Method (FCSession)

Syntax

'Declaration

Public Sub CloseGenerics( _
   ByVal _NumGenerics_ As Short, _
   Optional ByVal _Generic1_ As Object, _
   Optional ByVal _Generic2_ As Object, _
   Optional ByVal _Generic3_ As Object, _
   Optional ByVal _Generic4_ As Object, _
   Optional ByVal _Generic5_ As Object, _
   Optional ByVal _Generic6_ As Object, _
   Optional ByVal _Generic7_ As Object, _
   Optional ByVal _Generic8_ As Object, _
   Optional ByVal _Generic9_ As Object, _
   Optional ByVal _Generic10_ As Object _
)

public void CloseGenerics(
   short _NumGenerics_,
   object _Generic1_,
   object _Generic2_,
   object _Generic3_,
   object _Generic4_,
   object _Generic5_,
   object _Generic6_,
   object _Generic7_,
   object _Generic8_,
   object _Generic9_,
   object _Generic10_
)

Parameters

NumGenerics

Generic1

Generic2

Generic3

Generic4

Generic5

Generic6

Generic7

Generic8

Generic9

Generic10

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


CloseSession Method (FCSession) | fcSDK Documentation

CloseSession Method (FCSession)

Syntax

'Declaration

Public Sub CloseSession()

public void CloseSession()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


CommitTransaction Method (FCSession) | fcSDK Documentation

CommitTransaction Method (FCSession)

Syntax

'Declaration

Public Sub CommitTransaction()

public void CommitTransaction()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


ConvertDate Method (FCSession) | fcSDK Documentation

ConvertDate Method (FCSession)

Syntax

'Declaration

Public Function ConvertDate( _
   ByVal _convertDate_ As Date, _
   ByVal _fromTimeZone_ As String, _
   ByVal _toTimeZone_ As String _
) As Date

public DateTime ConvertDate(
   DateTime _convertDate_,
   string _fromTimeZone_,
   string _toTimeZone_
)

Parameters

convertDate

fromTimeZone

toTimeZone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


ConvertFromLocalToServerTZ Method (FCSession) | fcSDK Documentation

ConvertFromLocalToServerTZ Method (FCSession)

Syntax

'Declaration

Public Function ConvertFromLocalToServerTZ( _
   ByVal _convertDate_ As Date _
) As Date

public DateTime ConvertFromLocalToServerTZ(
   DateTime _convertDate_
)

Parameters

convertDate

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


ConvertFromServerToLocalTZ Method (FCSession) | fcSDK Documentation

ConvertFromServerToLocalTZ Method (FCSession)

Syntax

'Declaration

Public Function ConvertFromServerToLocalTZ( _
   ByVal _convertDate_ As Date _
) As Date

public DateTime ConvertFromServerToLocalTZ(
   DateTime _convertDate_
)

Parameters

convertDate

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


create_act_entry Method (FCSession) | fcSDK Documentation

create_act_entry Method (FCSession)

Overload List

Overload | Description
create_act_entry(IFCGeneric,String,Int32,Int32,String,IFCGeneric,String,String,Object) |
create_act_entry(IFCGeneric,String,Int32,Int32,String,IFCGeneric,String,String,String,Object) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


create_act_entry(IFCGeneric,String,Int32,Int32,String,IFCGeneric,String,String,Object) Method | fcSDK Documentation

create_act_entry(IFCGeneric,String,Int32,Int32,String,IFCGeneric,String,String,Object) Method

Syntax

'Declaration

Public Overloads Sub create_act_entry( _
   ByVal _mainRecord_ As IFCGeneric, _
   ByVal _actName_ As String, _
   ByVal _userId_ As Integer, _
   ByVal _actCode_ As Integer, _
   ByVal _currentDateTime_ As String, _
   ByVal _activityRecord_ As IFCGeneric, _
   ByVal _additionalInfo_ As String, _
   ByVal _objectType_ As String, _
   Optional ByVal _optLinkRecord_ As Object _
)

public void create_act_entry(
   IFCGeneric _mainRecord_,
   string _actName_,
   int _userId_,
   int _actCode_,
   string _currentDateTime_,
   IFCGeneric _activityRecord_,
   string _additionalInfo_,
   string _objectType_,
   object _optLinkRecord_
)

Parameters

mainRecord

actName

userId

actCode

currentDateTime

activityRecord

additionalInfo

objectType

optLinkRecord

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members
Overload List


create_act_entry(IFCGeneric,String,Int32,Int32,String,IFCGeneric,String,String,String,Object) Method | fcSDK Documentation

create_act_entry(IFCGeneric,String,Int32,Int32,String,IFCGeneric,String,String,String,Object) Method

Syntax

'Declaration

Public Overloads Sub create_act_entry( _
   ByVal _mainRecord_ As IFCGeneric, _
   ByVal _actName_ As String, _
   ByVal _userId_ As Integer, _
   ByVal _actCode_ As Integer, _
   ByVal _currentDateTime_ As String, _
   ByVal _activityRecord_ As IFCGeneric, _
   ByVal _additionalInfo_ As String, _
   ByVal _objectType_ As String, _
   ByVal _impersonatorUserName_ As String, _
   Optional ByVal _optLinkRecord_ As Object _
)

public void create_act_entry(
   IFCGeneric _mainRecord_,
   string _actName_,
   int _userId_,
   int _actCode_,
   string _currentDateTime_,
   IFCGeneric _activityRecord_,
   string _additionalInfo_,
   string _objectType_,
   string _impersonatorUserName_,
   object _optLinkRecord_
)

Parameters

mainRecord

actName

userId

actCode

currentDateTime

activityRecord

additionalInfo

objectType

impersonatorUserName

optLinkRecord

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members
Overload List


create_time_bomb Method (FCSession) | fcSDK Documentation

create_time_bomb Method (FCSession)

Overload List

Overload | Description
create_time_bomb(IFCGeneric,IFCGeneric,String,IFCGeneric,String,Int32,String,String,Object) |
create_time_bomb(IFCGeneric,IFCGeneric,String,IFCGeneric,String,Int32,String,String,String,Object) |
create_time_bomb(Int32,IFCGeneric,IFCGeneric,String,IFCGeneric,Int32,String,String,Object) |
create_time_bomb(Int32,IFCGeneric,IFCGeneric,String,IFCGeneric,Int32,String,String,String,Object) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class FCSession Members


create_time_bomb(IFCGeneric,IFCGeneric,String,IFCGeneric,String,Int32,String,String,Object) Method | fcSDK Documentation

create_time_bomb(IFCGeneric,IFCGeneric,String,IFCGeneric,String,Int32,String,String,Object) Method

Syntax

'Declaration

Public Overloads Sub create_time_bomb( _
   ByRef _timeBombRecord_ As IFCGeneric, _
   ByVal _mainRecord_ As IFCGeneric, _
   ByVal _t_save_ As String, _
   ByVal _activityRecord_ As IFCGeneric, _
   ByVal _the_type_ As String, _
   ByVal _emp_rec_ As Integer, _
   ByVal _t_date_ As String, _
   ByVal _focus_obj_ As String, _
   Optional ByVal _new_generic_ As Object _
)

public void create_time_bomb(
   ref IFCGeneric _timeBombRecord_,
   IFCGeneric _mainRecord_,
   string _t_save_,
   IFCGeneric _activityRecord_,
   string _the_type_,
   int _emp_rec_,
   string _t_date_,
   string _focus_obj_,
   object _new_generic_
)

Parameters

timeBombRecord

mainRecord

t_save

activityRecord

the_type

emp_rec

t_date

focus_obj

new_generic

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members
Overload List


create_time_bomb(IFCGeneric,IFCGeneric,String,IFCGeneric,String,Int32,String,String,String,Object) Method | fcSDK Documentation

create_time_bomb(IFCGeneric,IFCGeneric,String,IFCGeneric,String,Int32,String,String,String,Object) Method

Syntax

'Declaration

Public Overloads Sub create_time_bomb( _
   ByRef _timeBombRecord_ As IFCGeneric, _
   ByVal _mainRecord_ As IFCGeneric, _
   ByVal _t_save_ As String, _
   ByVal _activityRecord_ As IFCGeneric, _
   ByVal _the_type_ As String, _
   ByVal _emp_rec_ As Integer, _
   ByVal _t_date_ As String, _
   ByVal _focus_obj_ As String, _
   ByVal _escalate_time_ As String, _
   Optional ByVal _new_generic_ As Object _
)

public void create_time_bomb(
   ref IFCGeneric _timeBombRecord_,
   IFCGeneric _mainRecord_,
   string _t_save_,
   IFCGeneric _activityRecord_,
   string _the_type_,
   int _emp_rec_,
   string _t_date_,
   string _focus_obj_,
   string _escalate_time_,
   object _new_generic_
)

Parameters

timeBombRecord

mainRecord

t_save

activityRecord

the_type

emp_rec

t_date

focus_obj

escalate_time

new_generic

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members
Overload List


create_time_bomb(Int32,IFCGeneric,IFCGeneric,String,IFCGeneric,Int32,String,String,Object) Method | fcSDK Documentation

create_time_bomb(Int32,IFCGeneric,IFCGeneric,String,IFCGeneric,Int32,String,String,Object) Method

Syntax

'Declaration

<ComVisibleAttribute(False)>
Public Overloads Sub create_time_bomb( _
   ByVal _timeBombFlag_ As Integer, _
   ByRef _timeBombRecord_ As IFCGeneric, _
   ByVal _mainRecord_ As IFCGeneric, _
   ByVal _t_save_ As String, _
   ByVal _activityRecord_ As IFCGeneric, _
   ByVal _emp_rec_ As Integer, _
   ByVal _t_date_ As String, _
   ByVal _focus_obj_ As String, _
   Optional ByVal _new_generic_ As Object _
)

[ComVisibleAttribute(false)]
public void create_time_bomb(
   int _timeBombFlag_,
   ref IFCGeneric _timeBombRecord_,
   IFCGeneric _mainRecord_,
   string _t_save_,
   IFCGeneric _activityRecord_,
   int _emp_rec_,
   string _t_date_,
   string _focus_obj_,
   object _new_generic_
)

Parameters

timeBombFlag

timeBombRecord

mainRecord

t_save

activityRecord

emp_rec

t_date

focus_obj

new_generic

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members
Overload List


create_time_bomb(Int32,IFCGeneric,IFCGeneric,String,IFCGeneric,Int32,String,String,String,Object) Method | fcSDK Documentation

create_time_bomb(Int32,IFCGeneric,IFCGeneric,String,IFCGeneric,Int32,String,String,String,Object) Method

Syntax

'Declaration

<ComVisibleAttribute(False)>
Public Overloads Sub create_time_bomb( _
   ByVal _timeBombFlag_ As Integer, _
   ByRef _timeBombRecord_ As IFCGeneric, _
   ByVal _mainRecord_ As IFCGeneric, _
   ByVal _t_save_ As String, _
   ByVal _activityRecord_ As IFCGeneric, _
   ByVal _emp_rec_ As Integer, _
   ByVal _t_date_ As String, _
   ByVal _focus_obj_ As String, _
   ByVal _escalate_time_ As String, _
   Optional ByVal _new_generic_ As Object _
)

[ComVisibleAttribute(false)]
public void create_time_bomb(
   int _timeBombFlag_,
   ref IFCGeneric _timeBombRecord_,
   IFCGeneric _mainRecord_,
   string _t_save_,
   IFCGeneric _activityRecord_,
   int _emp_rec_,
   string _t_date_,
   string _focus_obj_,
   string _escalate_time_,
   object _new_generic_
)

Parameters

timeBombFlag

timeBombRecord

mainRecord

t_save

activityRecord

emp_rec

t_date

focus_obj

escalate_time

new_generic

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members
Overload List


createBulk Method (FCSession) | fcSDK Documentation

createBulk Method (FCSession)

Syntax

'Declaration

Public Function createBulk( _
   ByVal _bulkName_ As String _
) As IFCBulk

public IFCBulk createBulk(
   string _bulkName_
)

Parameters

bulkName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


CreateGeneric Method (FCSession) | fcSDK Documentation

CreateGeneric Method (FCSession)

Syntax

'Declaration

Public Function CreateGeneric( _
   Optional ByVal _dbObjectName_ As Object _
) As IFCGeneric

public IFCGeneric CreateGeneric(
   object _dbObjectName_
)

Parameters

dbObjectName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


CreateSqlExec Method (FCSession) | fcSDK Documentation

CreateSqlExec Method (FCSession)

Syntax

'Declaration

Public Function CreateSqlExec() As IFCSqlExec

public IFCSqlExec CreateSqlExec()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


dispatch_object Method (FCSession) | fcSDK Documentation

dispatch_object Method (FCSession)

Syntax

'Declaration

Public Function dispatch_object( _
   ByVal _objId_ As String, _
   ByVal _queueName_ As String, _
   ByRef _dispatchDate_ As String, _
   ByRef _localUserName_ As String, _
   ByVal _generateTimeBombs_ As Boolean, _
   ByVal _objectType_ As String _
) As Short

public short dispatch_object(
   string _objId_,
   string _queueName_,
   out string _dispatchDate_,
   out string _localUserName_,
   bool _generateTimeBombs_,
   string _objectType_
)

Parameters

objId

queueName

dispatchDate

localUserName

generateTimeBombs

objectType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


Dispose() Method | fcSDK Documentation

Dispose() Method

Syntax

'Declaration

Public Sub Dispose()

public void Dispose()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


error_handler Method (FCSession) | fcSDK Documentation

error_handler Method (FCSession)

Overload List

Overload | Description
error_handler(Int16,String,String,String) |
error_handler(Int16,String,String,FCExceptionBase) |
error_handler(Int32,String,String,String,Exception) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


error_handler(Int16,String,String,String) Method | fcSDK Documentation

error_handler(Int16,String,String,String) Method

Syntax

'Declaration

Public Overloads Function error_handler( _
   ByVal _error_num_ As Short, _
   ByVal _objId_ As String, _
   ByVal _source_ As String, _
   ByVal _message_ As String _
) As Short

public short error_handler(
   short _error_num_,
   string _objId_,
   string _source_,
   string _message_
)

Parameters

error_num

objId

source

message

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members
Overload List


error_handler(Int16,String,String,FCExceptionBase) Method | fcSDK Documentation

error_handler(Int16,String,String,FCExceptionBase) Method

Syntax

'Declaration

<ComVisibleAttribute(False)>
Public Overloads Function error_handler( _
   ByVal _errorNum_ As Short, _
   ByVal _objId_ As String, _
   ByVal _source_ As String, _
   ByVal _exception_ As FCExceptionBase _
) As Short

[ComVisibleAttribute(false)]
public short error_handler(
   short _errorNum_,
   string _objId_,
   string _source_,
   FCExceptionBase _exception_
)

Parameters

errorNum

objId

source

exception

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members
Overload List


error_handler(Int32,String,String,String,Exception) Method | fcSDK Documentation

error_handler(Int32,String,String,String,Exception) Method

Syntax

'Declaration

<ComVisibleAttribute(False)>
Public Overloads Function error_handler( _
   ByVal _error_num_ As Integer, _
   ByVal _objId_ As String, _
   ByVal _source_ As String, _
   ByVal _message_ As String, _
   ByVal _ex_ As Exception _
) As Short

[ComVisibleAttribute(false)]
public short error_handler(
   int _error_num_,
   string _objId_,
   string _source_,
   string _message_,
   Exception _ex_
)

Parameters

error_num

objId

source

message

ex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members
Overload List


ExecuteSQL Method (FCSession) | fcSDK Documentation

ExecuteSQL Method (FCSession)

Syntax

'Declaration

Public Sub ExecuteSQL( _
   ByVal _sql_ As String, _
   ByRef _records_ As ADODB.Recordset _
)

public void ExecuteSQL(
   string _sql_,
   out ADODB.Recordset _records_
)

Parameters

sql

records

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


ExecuteSQLNoReturn Method (FCSession) | fcSDK Documentation

ExecuteSQLNoReturn Method (FCSession)

Syntax

'Declaration

Public Sub ExecuteSQLNoReturn( _
   ByVal _sql_ As String _
)

public void ExecuteSQLNoReturn(
   string _sql_
)

Parameters

sql

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


format_time Method (FCSession) | fcSDK Documentation

format_time Method (FCSession)

Syntax

'Declaration

Public Function format_time( _
   ByVal _totalTime_ As Integer _
) As String

public string format_time(
   int _totalTime_
)

Parameters

totalTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


forward_object Method (FCSession) | fcSDK Documentation

forward_object Method (FCSession)

Syntax

'Declaration

Public Function forward_object( _
   ByVal _objId_ As String, _
   ByVal _newQueue_ As String, _
   ByRef _forwardDate_ As String, _
   ByVal _notes_ As String, _
   ByRef _localUserName_ As String, _
   ByVal _generateTimeBombs_ As Boolean, _
   ByVal _objectType_ As String _
) As Short

public short forward_object(
   string _objId_,
   string _newQueue_,
   out string _forwardDate_,
   string _notes_,
   out string _localUserName_,
   bool _generateTimeBombs_,
   string _objectType_
)

Parameters

objId

newQueue

forwardDate

notes

localUserName

generateTimeBombs

objectType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


FreeConnection Method (FCSession) | fcSDK Documentation

FreeConnection Method (FCSession)

Syntax

'Declaration

Public Sub FreeConnection()

public void FreeConnection()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


get_item Method (FCSession) | fcSDK Documentation

get_item Method (FCSession)

Syntax

'Declaration

Public Function get_item( _
   ByVal _key_ As String _
) As Object

public object get_item(
   string _key_
)

Parameters

key

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


get_next_sn Method (FCSession) | fcSDK Documentation

get_next_sn Method (FCSession)

Syntax

'Declaration

Public Function get_next_sn( _
   ByVal _the_ind_ As Short _
) As Object

public object get_next_sn(
   short _the_ind_
)

Parameters

the_ind

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


GetColor Method (FCSession) | fcSDK Documentation

GetColor Method (FCSession)

Syntax

'Declaration

Public Function GetColor( _
   ByVal _purpose_ As String _
) As String

public string GetColor(
   string _purpose_
)

Parameters

purpose

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


GetConfigItem Method (FCSession) | fcSDK Documentation

GetConfigItem Method (FCSession)

Syntax

'Declaration

Public Function GetConfigItem( _
   ByVal _configItem_ As String, _
   ByVal _fieldName_ As String, _
   Optional ByVal _loginName_ As Object _
) As Object

public object GetConfigItem(
   string _configItem_,
   string _fieldName_,
   object _loginName_
)

Parameters

configItem

fieldName

loginName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


GetCurrentDate Method (FCSession) | fcSDK Documentation

GetCurrentDate Method (FCSession)

Syntax

'Declaration

Public Function GetCurrentDate() As Date

public DateTime GetCurrentDate()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


GetCurrentServerDate Method (FCSession) | fcSDK Documentation

GetCurrentServerDate Method (FCSession)

Syntax

'Declaration

Public Function GetCurrentServerDate() As Date

public DateTime GetCurrentServerDate()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


GetItem Method (FCSession) | fcSDK Documentation

GetItem Method (FCSession)

Syntax

'Declaration

Public Function GetItem( _
   ByVal _path_ As String, _
   ByVal _startItem_ As Short, _
   ByVal _stopItem_ As Short, _
   ByVal _separator_ As String _
) As String

public string GetItem(
   string _path_,
   short _startItem_,
   short _stopItem_,
   string _separator_
)

Parameters

path

startItem

stopItem

separator

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


GetNextNumScheme Method (FCSession) | fcSDK Documentation

GetNextNumScheme Method (FCSession)

Syntax

'Declaration

Public Function GetNextNumScheme( _
   ByVal _numSchemaName_ As String _
) As String

public string GetNextNumScheme(
   string _numSchemaName_
)

Parameters

numSchemaName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


GetNextSubcaseID Method (FCSession) | fcSDK Documentation

GetNextSubcaseID Method (FCSession)

Overload List

Overload | Description
GetNextSubcaseID(String,Int32) |
GetNextSubcaseID(String,Int32,IDbTransaction) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


GetNextSubcaseID(String,Int32) Method | fcSDK Documentation

GetNextSubcaseID(String,Int32) Method

Syntax

'Declaration

Public Overloads Function GetNextSubcaseID( _
   ByVal _caseId_ As String, _
   ByVal _caseConditionId_ As Integer _
) As String

public string GetNextSubcaseID(
   string _caseId_,
   int _caseConditionId_
)

Parameters

caseId

caseConditionId

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members
Overload List


GetNextSubcaseID(String,Int32,IDbTransaction) Method | fcSDK Documentation

GetNextSubcaseID(String,Int32,IDbTransaction) Method

Syntax

'Declaration

Public Overloads Function GetNextSubcaseID( _
   ByVal _caseId_ As String, _
   ByVal _caseConditionId_ As Integer, _
   ByVal _transaction_ As IDbTransaction _
) As String

public string GetNextSubcaseID(
   string _caseId_,
   int _caseConditionId_,
   IDbTransaction _transaction_
)

Parameters

caseId

caseConditionId

transaction

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members
Overload List


GetNumGenerics Method (FCSession) | fcSDK Documentation

GetNumGenerics Method (FCSession)

Syntax

'Declaration

Public Function GetNumGenerics() As Integer

public int GetNumGenerics()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


GetObjid Method (FCSession) | fcSDK Documentation

GetObjid Method (FCSession)

Syntax

'Declaration

Public Function GetObjid( _
   ByVal _tableName_ As String _
) As Integer

public int GetObjid(
   string _tableName_
)

Parameters

tableName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


GetUserVersion Method (FCSession) | fcSDK Documentation

GetUserVersion Method (FCSession)

Syntax

'Declaration

Public Function GetUserVersion( _
   ByVal _formName_ As String _
) As String

public string GetUserVersion(
   string _formName_
)

Parameters

formName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


Init_Object Method (FCSession) | fcSDK Documentation

Init_Object Method (FCSession)

Syntax

'Declaration

Public Function Init_Object( _
   ByRef _generic_ As IFCGeneric, _
   ByVal _objectType_ As String, _
   ByVal _dataFields_ As String, _
   ByVal _bulkName_ As String _
) As IFCGeneric

public IFCGeneric Init_Object(
   ref IFCGeneric _generic_,
   string _objectType_,
   string _dataFields_,
   string _bulkName_
)

Parameters

generic

objectType

dataFields

bulkName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


IsUnicode Method (FCSession) | fcSDK Documentation

IsUnicode Method (FCSession)

Syntax

'Declaration

Public Function IsUnicode( _
   ByVal _testString_ As String _
) As Object

public object IsUnicode(
   string _testString_
)

Parameters

testString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


ItemCount Method (FCSession) | fcSDK Documentation

ItemCount Method (FCSession)

Syntax

'Declaration

Public Function ItemCount( _
   ByVal _path_ As String, _
   ByVal _separator_ As String _
) As Short

public short ItemCount(
   string _path_,
   string _separator_
)

Parameters

path

separator

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


LoadColors Method (FCSession) | fcSDK Documentation

LoadColors Method (FCSession)

Syntax

'Declaration

Public Sub LoadColors( _
   ByVal _userName_ As String _
)

public void LoadColors(
   string _userName_
)

Parameters

userName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


LoadUserVersions Method (FCSession) | fcSDK Documentation

LoadUserVersions Method (FCSession)

Syntax

'Declaration

Public Sub LoadUserVersions( _
   Optional ByVal _userName_ As Object _
)

public void LoadUserVersions(
   object _userName_
)

Parameters

userName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


Log Method (FCSession) | fcSDK Documentation

Log Method (FCSession)

Syntax

'Declaration

Public Sub Log( _
   ByVal _messageType_ As String, _
   ByVal _message_ As String _
)

public void Log(
   string _messageType_,
   string _message_
)

Parameters

messageType

message

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


LogEx Method (FCSession) | fcSDK Documentation

LogEx Method (FCSession)

Syntax

'Declaration

Public Sub LogEx( _
   ByVal _logLevel_ As String, _
   ByVal _logMessage_ As String _
)

public void LogEx(
   string _logLevel_,
   string _logMessage_
)

Parameters

logLevel

logMessage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


Login Method (FCSession) | fcSDK Documentation

Login Method (FCSession)

Syntax

'Declaration

Public Sub Login( _
   ByVal _username_ As String, _
   ByVal _password_ As String, _
   ByVal _loginType_ As String _
)

public void Login(
   string _username_,
   string _password_,
   string _loginType_
)

Parameters

username

password

loginType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


LoginFromFCApp Method (FCSession) | fcSDK Documentation

LoginFromFCApp Method (FCSession)

Syntax

'Declaration

Public Sub LoginFromFCApp()

public void LoginFromFCApp()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


Logout Method (FCSession) | fcSDK Documentation

Logout Method (FCSession)

Syntax

'Declaration

Public Sub Logout()

public void Logout()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


move_object Method (FCSession) | fcSDK Documentation

move_object Method (FCSession)

Syntax

'Declaration

Public Function move_object( _
   ByVal _objId_ As String, _
   ByVal _newWipBin_ As String, _
   ByVal _objectType_ As String _
) As Short

public short move_object(
   string _objId_,
   string _newWipBin_,
   string _objectType_
)

Parameters

objId

newWipBin

objectType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


NewEnum Method (FCSession) | fcSDK Documentation

NewEnum Method (FCSession)

Syntax

'Declaration
<DispIdAttribute(-4)>
Public Function NewEnum() As IEnumerator

[DispIdAttribute(-4)]
public IEnumerator NewEnum()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


RefreshContext Method (FCSession) | fcSDK Documentation

RefreshContext Method (FCSession)

Syntax

'Declaration

Public Sub RefreshContext()

public void RefreshContext()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


RegisterLicenseRequirements Method (FCSession) | fcSDK Documentation

RegisterLicenseRequirements Method (FCSession)

Syntax

'Declaration

<ComVisibleAttribute(False)>
Public Sub RegisterLicenseRequirements( _
   ByVal _productId_ As Integer _
)

[ComVisibleAttribute(false)]
public void RegisterLicenseRequirements(
   int _productId_
)

Parameters

productId

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


reject_object Method (FCSession) | fcSDK Documentation

reject_object Method (FCSession)

Syntax

'Declaration

Public Function reject_object( _
   ByVal _objId_ As String, _
   ByRef _rejectDate_ As String, _
   ByVal _wipBin_ As String, _
   ByVal _notes_ As String, _
   ByRef _localUserName_ As String, _
   ByVal _generateTimeBombs_ As Boolean, _
   ByVal _objectType_ As String _
) As Short

public short reject_object(
   string _objId_,
   out string _rejectDate_,
   string _wipBin_,
   string _notes_,
   out string _localUserName_,
   bool _generateTimeBombs_,
   string _objectType_
)

Parameters

objId

rejectDate

wipBin

notes

localUserName

generateTimeBombs

objectType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


RemoveAllGenericsInABulk Method (FCSession) | fcSDK Documentation

RemoveAllGenericsInABulk Method (FCSession)

Syntax

'Declaration

Public Sub RemoveAllGenericsInABulk( _
   ByVal _bulkName_ As String _
)

public void RemoveAllGenericsInABulk(
   string _bulkName_
)

Parameters

bulkName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


RollbackTransaction Method (FCSession) | fcSDK Documentation

RollbackTransaction Method (FCSession)

Syntax

'Declaration

Public Sub RollbackTransaction()

public void RollbackTransaction()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


set_item Method (FCSession) | fcSDK Documentation

set_item Method (FCSession)

Syntax

'Declaration

Public Sub set_item( _
   ByVal _key_ As String, _
   ByVal _newValue_ As Object _
)

public void set_item(
   string _key_,
   object _newValue_
)

Parameters

key

newValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


SetNullStringToEmpty Method (FCSession) | fcSDK Documentation

SetNullStringToEmpty Method (FCSession)

Syntax

'Declaration

Public Function SetNullStringToEmpty( _
   ByVal _inputString_ As Object _
) As Object

public object SetNullStringToEmpty(
   object _inputString_
)

Parameters

inputString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


SetPassword Method (FCSession) | fcSDK Documentation

SetPassword Method (FCSession)

Syntax

'Declaration

Public Sub SetPassword( _
   ByVal _loginName_ As String, _
   ByVal _password_ As String, _
   ByVal _loginType_ As String _
)

public void SetPassword(
   string _loginName_,
   string _password_,
   string _loginType_
)

Parameters

loginName

password

loginType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


SimpleQuery Method (FCSession) | fcSDK Documentation

SimpleQuery Method (FCSession)

Syntax

'Declaration

Public Sub SimpleQuery( _
   ByRef _generic_ As IFCGeneric, _
   ByVal _objectType_ As String, _
   ByVal _dataFields_ As String, _
   ByVal _bulkName_ As String _
)

public void SimpleQuery(
   ref IFCGeneric _generic_,
   string _objectType_,
   string _dataFields_,
   string _bulkName_
)

Parameters

generic

objectType

dataFields

bulkName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


single_quotify Method (FCSession) | fcSDK Documentation

single_quotify Method (FCSession)

Syntax

'Declaration

Public Function single_quotify( _
   ByVal _inputString_ As String _
) As String

public string single_quotify(
   string _inputString_
)

Parameters

inputString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


sprintf Method (FCSession) | fcSDK Documentation

sprintf Method (FCSession)

Syntax

'Declaration

Public Function sprintf( _
   ByVal _inputString_ As String, _
   Optional ByVal _arg1_ As Object, _
   Optional ByVal _arg2_ As Object, _
   Optional ByVal _arg3_ As Object, _
   Optional ByVal _arg4_ As Object, _
   Optional ByVal _arg5_ As Object, _
   Optional ByVal _arg6_ As Object _
) As String

public string sprintf(
   string _inputString_,
   object _arg1_,
   object _arg2_,
   object _arg3_,
   object _arg4_,
   object _arg5_,
   object _arg6_
)

Parameters

inputString

arg1

arg2

arg3

arg4

arg5

arg6

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


StartTransaction Method (FCSession) | fcSDK Documentation

StartTransaction Method (FCSession)

Syntax

'Declaration

Public Sub StartTransaction( _
   Optional ByVal _isolationLevel_ As Object _
)

public void StartTransaction(
   object _isolationLevel_
)

Parameters

isolationLevel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


TraverseFromParent Method (FCSession) | fcSDK Documentation

TraverseFromParent Method (FCSession)

Syntax

'Declaration

Public Function TraverseFromParent( _
   ByRef _generic_ As IFCGeneric, _
   ByVal _objectType_ As String, _
   ByVal _dataFields_ As String, _
   ByVal _bulkName_ As String, _
   ByVal _parentGeneric_ As IFCGeneric, _
   ByVal _relationName_ As String _
) As IFCGeneric

public IFCGeneric TraverseFromParent(
   ref IFCGeneric _generic_,
   string _objectType_,
   string _dataFields_,
   string _bulkName_,
   IFCGeneric _parentGeneric_,
   string _relationName_
)

Parameters

generic

objectType

dataFields

bulkName

parentGeneric

relationName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


turn_off Method (FCSession) | fcSDK Documentation

turn_off Method (FCSession)

Syntax

'Declaration

Public Function turn_off( _
   ByVal _bigNum_ As Integer, _
   ByVal _smallNum_ As Integer _
) As Integer

public int turn_off(
   int _bigNum_,
   int _smallNum_
)

Parameters

bigNum

smallNum

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


use_list Method (FCSession) | fcSDK Documentation

use_list Method (FCSession)

Syntax

'Declaration

Public Sub use_list( _
   ByVal _generic_ As IFCGeneric, _
   ByVal _fieldList_ As Object, _
   ByVal _typeList_ As Object, _
   ByVal _valueList_ As Object _
)

public void use_list(
   IFCGeneric _generic_,
   object _fieldList_,
   object _typeList_,
   object _valueList_
)

Parameters

generic

fieldList

typeList

valueList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


yank_object Method (FCSession) | fcSDK Documentation

yank_object Method (FCSession)

Syntax

'Declaration

Public Function yank_object( _
   ByVal _objId_ As String, _
   ByVal _wipBin_ As String, _
   ByRef _yankDate_ As String, _
   ByRef _localUserName_ As String, _
   ByVal _generateTimeBombs_ As Boolean, _
   ByVal _objectType_ As String _
) As Short

public short yank_object(
   string _objId_,
   string _wipBin_,
   out string _yankDate_,
   out string _localUserName_,
   bool _generateTimeBombs_,
   string _objectType_
)

Parameters

objId

wipBin

yankDate

localUserName

generateTimeBombs

objectType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


ad_auto Property (FCSession) | fcSDK Documentation

ad_auto Property (FCSession)

Syntax

'Declaration

Public Property ad_auto As Boolean

public bool ad_auto {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


ad_list Property (FCSession) | fcSDK Documentation

ad_list Property (FCSession)

Syntax

'Declaration

Public Property ad_list As String

public string ad_list {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


BulkCollection Property (FCSession) | fcSDK Documentation

BulkCollection Property (FCSession)

Syntax

'Declaration

Public ReadOnly Property BulkCollection As IMockCollection

public IMockCollection BulkCollection {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


ConvertTimeZone Property (FCSession) | fcSDK Documentation

ConvertTimeZone Property (FCSession)

Syntax

'Declaration

Public Property ConvertTimeZone As Boolean

public bool ConvertTimeZone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


cur_res Property (FCSession) | fcSDK Documentation

cur_res Property (FCSession)

Syntax

'Declaration

Public Property cur_res As IMockCollection

public IMockCollection cur_res {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


CurrentCulture Property (FCSession) | fcSDK Documentation

CurrentCulture Property (FCSession)

Syntax

'Declaration

Public Property CurrentCulture As String

public string CurrentCulture {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


CurrentNetTransaction Property | fcSDK Documentation

CurrentNetTransaction Property

Syntax

'Declaration

<ComVisibleAttribute(False)>
Public Property CurrentNetTransaction As IDbTransaction

[ComVisibleAttribute(false)]
public IDbTransaction CurrentNetTransaction {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


DbHelper Property | fcSDK Documentation

DbHelper Property

Syntax

'Declaration

<ComVisibleAttribute(False)>
Public ReadOnly Property DbHelper As SqlHelper

[ComVisibleAttribute(false)]
public SqlHelper DbHelper {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


Distinct Property (FCSession) | fcSDK Documentation

Distinct Property (FCSession)

Syntax

'Declaration

Public Property Distinct As Boolean

public bool Distinct {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


ErrorMessage Property (FCSession) | fcSDK Documentation

ErrorMessage Property (FCSession)

Syntax

'Declaration

Public Property ErrorMessage As String

public string ErrorMessage {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


ErrorNumber Property (FCSession) | fcSDK Documentation

ErrorNumber Property (FCSession)

Syntax

'Declaration

Public Property ErrorNumber As Short

public short ErrorNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


ErrorSource Property (FCSession) | fcSDK Documentation

ErrorSource Property (FCSession)

Syntax

'Declaration

Public Property ErrorSource As String

public string ErrorSource {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


hist_change Property (FCSession) | fcSDK Documentation

hist_change Property (FCSession)

Syntax

'Declaration

Public ReadOnly Property hist_change As Boolean

public bool hist_change {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


IncludeRelations Property (FCSession) | fcSDK Documentation

IncludeRelations Property (FCSession)

Syntax

'Declaration

Public Property IncludeRelations As Boolean

public bool IncludeRelations {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


IsInTransaction Property (FCSession) | fcSDK Documentation

IsInTransaction Property (FCSession)

Syntax

'Declaration

Public ReadOnly Property IsInTransaction As Boolean

public bool IsInTransaction {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


IsLoggedIn Property (FCSession) | fcSDK Documentation

IsLoggedIn Property (FCSession)

Syntax

'Declaration

Public ReadOnly Property IsLoggedIn As Boolean

public bool IsLoggedIn {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


Item Property (FCSession) | fcSDK Documentation

Item Property (FCSession)

Syntax

'Declaration

<ComVisibleAttribute(False)>
Public Default Property Item( _
   ByVal _key_ As String _
) As Object

[ComVisibleAttribute(false)]
public object this[
   string _key_
]; {get; set;}

Parameters

key

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


LocalTimeZone Property (FCSession) | fcSDK Documentation

LocalTimeZone Property (FCSession)

Syntax

'Declaration

Public Property LocalTimeZone As String

public string LocalTimeZone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


LocalTimeZoneOffset Property (FCSession) | fcSDK Documentation

LocalTimeZoneOffset Property (FCSession)

Syntax

'Declaration

Public ReadOnly Property LocalTimeZoneOffset As Integer

public int LocalTimeZoneOffset {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


LoginTime Property (FCSession) | fcSDK Documentation

LoginTime Property (FCSession)

Syntax

'Declaration

Public ReadOnly Property LoginTime As Date

public DateTime LoginTime {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


NoRes Property (FCSession) | fcSDK Documentation

NoRes Property (FCSession)

Syntax

'Declaration

Public Property NoRes As Boolean

public bool NoRes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


num_ad Property (FCSession) | fcSDK Documentation

num_ad Property (FCSession)

Syntax

'Declaration

Public Property num_ad As Short

public short num_ad {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


PasswordRequired Property (FCSession) | fcSDK Documentation

PasswordRequired Property (FCSession)

Syntax

'Declaration

Public Property PasswordRequired As Boolean

public bool PasswordRequired {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


QueryEmptyToNull Property (FCSession) | fcSDK Documentation

QueryEmptyToNull Property (FCSession)

Syntax

'Declaration

Public Property QueryEmptyToNull As Boolean

public bool QueryEmptyToNull {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


RESEnabled Property (FCSession) | fcSDK Documentation

RESEnabled Property (FCSession)

Syntax

'Declaration

Public Property RESEnabled As Boolean

public bool RESEnabled {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


rowLimit Property (FCSession) | fcSDK Documentation

rowLimit Property (FCSession)

Syntax

'Declaration

Public Property rowLimit As Integer

public int rowLimit {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


SessionID Property (FCSession) | fcSDK Documentation

SessionID Property (FCSession)

Syntax

'Declaration

Public ReadOnly Property SessionID As String

public string SessionID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


SetNullStringsToEmpty Property (FCSession) | fcSDK Documentation

SetNullStringsToEmpty Property (FCSession)

Syntax

'Declaration

Public Property SetNullStringsToEmpty As Boolean

public bool SetNullStringsToEmpty {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


ThrowErrors Property (FCSession) | fcSDK Documentation

ThrowErrors Property (FCSession)

Syntax

'Declaration

Public Property ThrowErrors As Boolean

public bool ThrowErrors {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


TruncateStringFields Property (FCSession) | fcSDK Documentation

TruncateStringFields Property (FCSession)

Syntax

'Declaration

Public Property TruncateStringFields As Boolean

public bool TruncateStringFields {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


UpdateTime Property (FCSession) | fcSDK Documentation

UpdateTime Property (FCSession)

Syntax

'Declaration

Public ReadOnly Property UpdateTime As Date

public DateTime UpdateTime {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


FCSqlExec Class | fcSDK Documentation

FCSqlExec Class

Syntax

'Declaration

<ClassInterfaceAttribute(ClassInterfaceType.None)>
<IDispatchImplAttribute(IDispatchImplType.CompatibleImpl)>
<GuidAttribute("DA8E45C3-FD13-4ab4-8CCD-8E3DF8635519")>
<ProgIdAttribute("FCFLCompat.FCSqlExec")>
<ComVisibleAttribute(True)>
Public NotInheritable Class FCSqlExec
   Implements IFCSqlExec

[ClassInterfaceAttribute(ClassInterfaceType.None)]
[IDispatchImplAttribute(IDispatchImplType.CompatibleImpl)]
[GuidAttribute("DA8E45C3-FD13-4ab4-8CCD-8E3DF8635519")]
[ProgIdAttribute("FCFLCompat.FCSqlExec")]
[ComVisibleAttribute(true)]
public sealed class FCSqlExec : IFCSqlExec

Inheritance Hierarchy

System.Object
FChoice.Foundation.Clarify.Compatibility.FCSqlExec

Requirements

Namespace: FChoice.Foundation.Clarify.Compatibility

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Foundation.Clarify.Compatibility (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Foundation.Clarify.Compatibility.dll)

Reference

FCSqlExec Members
FChoice.Foundation.Clarify.Compatibility Namespace


FCSqlExec Class Members | fcSDK Documentation

FCSqlExec Class Members

The following tables list the members exposed by FCSqlExec.

Public Properties

 | Name | Description
Public Property | CurrentConnection |
Public Property | Records |
Public Property | StayConnected |

Public Methods

 | Name | Description
Public Method | AddSqlParameter |
Public Method | CloseConnection |
Public Method | Execute |
Public Method | ExecuteReturnRows |
Public Method | FreeConnection |
Public Method | OpenConnection |

Reference

FCSqlExec Class
FChoice.Foundation.Clarify.Compatibility Namespace


AddSqlParameter Method (FCSqlExec) | fcSDK Documentation

AddSqlParameter Method (FCSqlExec)

Syntax

'Declaration

Public Sub AddSqlParameter( _
   ByVal _value_ As Object _
)

public void AddSqlParameter(
   object _value_
)

Parameters

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSqlExec Class
FCSqlExec Members


CloseConnection Method (FCSqlExec) | fcSDK Documentation

CloseConnection Method (FCSqlExec)

Syntax

'Declaration

Public Sub CloseConnection()

public void CloseConnection()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSqlExec Class
FCSqlExec Members


Execute Method (FCSqlExec) | fcSDK Documentation

Execute Method (FCSqlExec)

Syntax

'Declaration

Public Sub Execute( _
   ByVal _SqlStr_ As String _
)

public void Execute(
   string _SqlStr_
)

Parameters

SqlStr

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSqlExec Class
FCSqlExec Members


ExecuteReturnRows Method (FCSqlExec) | fcSDK Documentation

ExecuteReturnRows Method (FCSqlExec)

Syntax

'Declaration

Public Sub ExecuteReturnRows( _
   ByVal _sqlStatement_ As String _
)

public void ExecuteReturnRows(
   string _sqlStatement_
)

Parameters

sqlStatement

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSqlExec Class
FCSqlExec Members


FreeConnection Method (FCSqlExec) | fcSDK Documentation

FreeConnection Method (FCSqlExec)

Syntax

'Declaration

Public Sub FreeConnection()

public void FreeConnection()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSqlExec Class
FCSqlExec Members


OpenConnection Method (FCSqlExec) | fcSDK Documentation

OpenConnection Method (FCSqlExec)

Syntax

'Declaration

Public Sub OpenConnection( _
   ByVal _TheDB_ As String, _
   ByVal _UserName_ As String, _
   ByVal _password_ As String, _
   ByVal _DBServer_ As String, _
   ByVal _DBName_ As String _
)

public void OpenConnection(
   string _TheDB_,
   string _UserName_,
   string _password_,
   string _DBServer_,
   string _DBName_
)

Parameters

TheDB

UserName

password

DBServer

DBName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSqlExec Class
FCSqlExec Members


CurrentConnection Property | fcSDK Documentation

CurrentConnection Property

Syntax

'Declaration

<ComVisibleAttribute(False)>
Public ReadOnly Property CurrentConnection As IDbConnection

[ComVisibleAttribute(false)]
public IDbConnection CurrentConnection {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSqlExec Class
FCSqlExec Members


Records Property (FCSqlExec) | fcSDK Documentation

Records Property (FCSqlExec)

Syntax

'Declaration

Public ReadOnly Property Records As ADODB.Recordset

public ADODB.Recordset Records {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSqlExec Class
FCSqlExec Members


StayConnected Property (FCSqlExec) | fcSDK Documentation

StayConnected Property (FCSqlExec)

Syntax

'Declaration

Public Property StayConnected As Boolean

public bool StayConnected {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSqlExec Class
FCSqlExec Members


MockAdoField Class | fcSDK Documentation

MockAdoField Class

Syntax

'Declaration

<GuidAttribute("78A3320B-100C-4225-A3C1-58C2A3E73A86")>
<IDispatchImplAttribute(IDispatchImplType.CompatibleImpl)>
<ComVisibleAttribute(True)>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class MockAdoField
   Implements IMockAdoField

[GuidAttribute("78A3320B-100C-4225-A3C1-58C2A3E73A86")]
[IDispatchImplAttribute(IDispatchImplType.CompatibleImpl)]
[ComVisibleAttribute(true)]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class MockAdoField : IMockAdoField

Inheritance Hierarchy

System.Object
FChoice.Foundation.Clarify.Compatibility.MockAdoField

Requirements

Namespace: FChoice.Foundation.Clarify.Compatibility

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Foundation.Clarify.Compatibility (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Foundation.Clarify.Compatibility.dll)

Reference

MockAdoField Members
FChoice.Foundation.Clarify.Compatibility Namespace


MockAdoField Class Members | fcSDK Documentation

MockAdoField Class Members

The following tables list the members exposed by MockAdoField.

Public Properties

 | Name | Description
Public Property | DefinedSize |
Public Property | Name |
Public Property | NetValue |
Public Property | Type |

Public Methods

 | Name | Description
Public Method | get_Value |
Public Method | set_Value |

Reference

MockAdoField Class
FChoice.Foundation.Clarify.Compatibility Namespace


get_Value Method (MockAdoField) | fcSDK Documentation

get_Value Method (MockAdoField)

Syntax

'Declaration

Public Function get_Value() As Object

public object get_Value()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MockAdoField Class
MockAdoField Members


set_Value Method (MockAdoField) | fcSDK Documentation

set_Value Method (MockAdoField)

Syntax

'Declaration

Public Sub set_Value( _
   ByVal _newValue_ As Object _
)

public void set_Value(
   object _newValue_
)

Parameters

newValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MockAdoField Class
MockAdoField Members


DefinedSize Property (MockAdoField) | fcSDK Documentation

DefinedSize Property (MockAdoField)

Syntax

'Declaration

Public ReadOnly Property DefinedSize As Integer

public int DefinedSize {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MockAdoField Class
MockAdoField Members


Name Property (MockAdoField) | fcSDK Documentation

Name Property (MockAdoField)

Syntax

'Declaration

Public ReadOnly Property Name As String

public string Name {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MockAdoField Class
MockAdoField Members


NetValue Property (MockAdoField) | fcSDK Documentation

NetValue Property (MockAdoField)

Syntax

'Declaration

<ComVisibleAttribute(False)>
Public Property NetValue As Object

[ComVisibleAttribute(false)]
public object NetValue {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MockAdoField Class
MockAdoField Members


Type Property (MockAdoField) | fcSDK Documentation

Type Property (MockAdoField)

Syntax

'Declaration

Public ReadOnly Property Type As Integer

public int Type {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MockAdoField Class
MockAdoField Members


MockCollection Class | fcSDK Documentation

MockCollection Class

Syntax

'Declaration

<ComVisibleAttribute(True)>
<GuidAttribute("9D9620BB-8673-4265-B6BC-A6EF0A536F60")>
<ClassInterfaceAttribute(ClassInterfaceType.None)>
Public Class MockCollection
   Implements IMockCollection

[ComVisibleAttribute(true)]
[GuidAttribute("9D9620BB-8673-4265-B6BC-A6EF0A536F60")]
[ClassInterfaceAttribute(ClassInterfaceType.None)]
public class MockCollection : IMockCollection

Inheritance Hierarchy

System.Object
FChoice.Foundation.Clarify.Compatibility.MockCollection

Requirements

Namespace: FChoice.Foundation.Clarify.Compatibility

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Foundation.Clarify.Compatibility (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Foundation.Clarify.Compatibility.dll)

Reference

MockCollection Members
FChoice.Foundation.Clarify.Compatibility Namespace


MockCollection Class Members | fcSDK Documentation

MockCollection Class Members

The following tables list the members exposed by MockCollection.

Public Methods

 | Name | Description
Public Method | _NewEnum |
Public Method | Add |
Public Method | Count |
Public Method | Item |
Public Method | Remove |

Reference

MockCollection Class
FChoice.Foundation.Clarify.Compatibility Namespace


_NewEnum Method (MockCollection) | fcSDK Documentation

_NewEnum Method (MockCollection)

Syntax

'Declaration

Public Function _NewEnum() As IEnumerator

public IEnumerator _NewEnum()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MockCollection Class
MockCollection Members


Add Method (MockCollection) | fcSDK Documentation

Add Method (MockCollection)

Syntax

'Declaration

Public Sub Add( _
   ByRef _Item_ As Object, _
   ByRef _Key_ As Object, _
   ByRef _Before_ As Object, _
   ByRef _After_ As Object _
)

public void Add(
   ref object _Item_,
   ref object _Key_,
   ref object _Before_,
   ref object _After_
)

Parameters

Item

Key

Before

After

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MockCollection Class
MockCollection Members


Count Method (MockCollection) | fcSDK Documentation

Count Method (MockCollection)

Syntax

'Declaration

Public Function Count() As Integer

public int Count()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MockCollection Class
MockCollection Members


Item Method (MockCollection) | fcSDK Documentation

Item Method (MockCollection)

Syntax

'Declaration

Public Function Item( _
   ByRef _Index_ As Object _
) As Object

public object Item(
   ref object _Index_
)

Parameters

Index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MockCollection Class
MockCollection Members


Remove Method (MockCollection) | fcSDK Documentation

Remove Method (MockCollection)

Syntax

'Declaration

Public Sub Remove( _
   ByRef _Index_ As Object _
)

public void Remove(
   ref object _Index_
)

Parameters

Index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MockCollection Class
MockCollection Members


IFCApplication Interface | fcSDK Documentation

IFCApplication Interface

Syntax

'Declaration

<GuidAttribute("76778FF4-8666-4eba-A60A-DA8D9F743A64")>
<ComVisibleAttribute(True)>
Public Interface IFCApplication

[GuidAttribute("76778FF4-8666-4eba-A60A-DA8D9F743A64")]
[ComVisibleAttribute(true)]
public interface IFCApplication

Requirements

Namespace: FChoice.Foundation.Clarify.Compatibility

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Foundation.Clarify.Compatibility (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Foundation.Clarify.Compatibility.dll)

Reference

IFCApplication Members
FChoice.Foundation.Clarify.Compatibility Namespace


IFCApplication Interface Members | fcSDK Documentation

IFCApplication Interface Members

The following tables list the members exposed by IFCApplication.

Public Properties

 | Name | Description
Property | base_objid |
Property | clarify_ver |
Property | ConnectionString |
Property | ConvertTimeZone |
Property | DataProtectorEntropy |
Property | db_name |
Property | db_type |
Property | GetMachineTimeZone |
Property | IsDBTraveler |
Property | IsDBUnicode |
Property | IsFcflNet |
Property | LicenseExpirationDate |
Property | LoggingConfigFilePath |
Property | Midnight |
Property | schema_rev |
Property | ServerTimeZone |
Property | site_id |
Property | TruncateStringFields |
Property | WorkingDirectory |

Public Methods

 | Name | Description
Method | build_mtm_name |
Method | CreateSession |
Method | CurrentSessions |
Method | EncryptClarifyPassword |
Method | EncryptDBPassword |
Method | FileExists |
Method | FindString |
Method | get_change_date_field |
Method | get_dt_fields |
Method | get_fields_types_lens |
Method | GetADPObjects |
Method | GetCountryList |
Method | GetCountryObjid |
Method | GetDefaultCountry |
Method | GetDefaultCountryObjId |
Method | GetDefaultState |
Method | GetDefaultStateObjid |
Method | GetDefaultTimeZone |
Method | GetDefaultTimeZoneObjid |
Method | GetFullStateObjid |
Method | GetGbstDefault |
Method | GetGbstDefaultObjid |
Method | GetGbstElmById |
Method | GetGbstElmObjid |
Method | GetGbstElmRankObjid |
Method | GetGbstList |
Method | GetHgbstElmDefault |
Method | GetHgbstElmDefaultObjid |
Method | GetHgbstElmObjId |
Method | GetHgbstList |
Method | GetLocalizedGbstDefault |
Method | GetLocalizedGbstElmById |
Method | GetRelationData |
Method | GetResClauses |
Method | GetResClausesStr |
Method | GetResTbl |
Method | GetServerTimeZoneOffset |
Method | GetShortTimeZoneObjId |
Method | GetStateObjid |
Method | GetStates |
Method | GetTableFields |
Method | GetTableID |
Method | GetTableName |
Method | GetTableRels |
Method | GetTablesAndViews |
Method | GetTimeZoneList |
Method | GetTimeZoneObjid |
Method | GetTimeZoneOffset |
Method | GetTimeZonesInCountry |
Method | Initialize |
Method | InitializeFull |
Method | is_it_a_field |
Method | is_it_a_table |
Method | is_it_change_field |
Method | is_it_date_field |
Method | is_it_int_field |
Method | is_it_searchable |
Method | is_it_string_fld |
Method | is_it_unicode |
Method | is_rel_exclusive |
Method | is_rel_mandatory |
Method | IsCountry |
Method | IsFullState |
Method | IsInGbstLst |
Method | IsInHgbstList |
Method | IsOnDST |
Method | IsState |
Method | IsTimeZone |
Method | IsTimeZoneInCountry |
Method | Log |
Method | LogEx |
Method | RankIsInGbstLst |
Method | SetServerTimeZoneToMachineTimeZone |
Method | sprintf |
Method | UpdateCache |
Method | UpdateSchemaCache |
Method | ValidateEncryptedPassword |

Reference

IFCApplication Interface
FChoice.Foundation.Clarify.Compatibility Namespace


build_mtm_name Method (IFCApplication) | fcSDK Documentation

build_mtm_name Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743878)>
Function build_mtm_name( _
   ByVal _tableName_ As String, _
   ByVal _relationName_ As String, _
   ByVal _inverseRelatioName_ As String _
) As String

[DispIdAttribute(1610743878)]
string build_mtm_name(
   string _tableName_,
   string _relationName_,
   string _inverseRelatioName_
)

Parameters

tableName

relationName

inverseRelatioName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


CreateSession Method (IFCApplication) | fcSDK Documentation

CreateSession Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743837)>
Function CreateSession( _
   Optional ByVal _sessionId_ As Object _
) As FCSession

[DispIdAttribute(1610743837)]
FCSession CreateSession(
   object _sessionId_
)

Parameters

sessionId

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


CurrentSessions Method (IFCApplication) | fcSDK Documentation

CurrentSessions Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743834)>
Function CurrentSessions() As String

[DispIdAttribute(1610743834)]
string CurrentSessions()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


EncryptClarifyPassword Method (IFCApplication) | fcSDK Documentation

EncryptClarifyPassword Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743903)>
Function EncryptClarifyPassword( _
   ByVal _password_ As String, _
   ByVal _fc_session_id_ As String _
) As String

[DispIdAttribute(1610743903)]
string EncryptClarifyPassword(
   string _password_,
   string _fc_session_id_
)

Parameters

password

fc_session_id

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


EncryptDBPassword Method (IFCApplication) | fcSDK Documentation

EncryptDBPassword Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743902)>
Function EncryptDBPassword( _
   ByVal _password_ As String _
) As String

[DispIdAttribute(1610743902)]
string EncryptDBPassword(
   string _password_
)

Parameters

password

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


FileExists Method (IFCApplication) | fcSDK Documentation

FileExists Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743839)>
Function FileExists( _
   ByVal _path_ As String _
) As Boolean

[DispIdAttribute(1610743839)]
bool FileExists(
   string _path_
)

Parameters

path

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


FindString Method (IFCApplication) | fcSDK Documentation

FindString Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743838)>
Function FindString( _
   ByVal _StringID_ As Object _
) As String

[DispIdAttribute(1610743838)]
string FindString(
   object _StringID_
)

Parameters

StringID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


get_change_date_field Method (IFCApplication) | fcSDK Documentation

get_change_date_field Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743888)>
Function get_change_date_field( _
   ByVal _tableName_ As String _
) As String

[DispIdAttribute(1610743888)]
string get_change_date_field(
   string _tableName_
)

Parameters

tableName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


get_dt_fields Method (IFCApplication) | fcSDK Documentation

get_dt_fields Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743897)>
Function get_dt_fields( _
   ByVal _tableName_ As String _
) As String

[DispIdAttribute(1610743897)]
string get_dt_fields(
   string _tableName_
)

Parameters

tableName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


get_fields_types_lens Method (IFCApplication) | fcSDK Documentation

get_fields_types_lens Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743882)>
Function get_fields_types_lens( _
   ByVal _tableName_ As String, _
   ByVal _includeRelations_ As Boolean _
) As String

[DispIdAttribute(1610743882)]
string get_fields_types_lens(
   string _tableName_,
   bool _includeRelations_
)

Parameters

tableName

includeRelations

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetADPObjects Method (IFCApplication) | fcSDK Documentation

GetADPObjects Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743906)>
Function GetADPObjects( _
   Optional ByVal _ObjectTypes_ As Object _
) As ADODB.Recordset

[DispIdAttribute(1610743906)]
ADODB.Recordset GetADPObjects(
   object _ObjectTypes_
)

Parameters

ObjectTypes

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetCountryList Method (IFCApplication) | fcSDK Documentation

GetCountryList Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743852)>
Function GetCountryList() As ADODB.Recordset

[DispIdAttribute(1610743852)]
ADODB.Recordset GetCountryList()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetCountryObjid Method (IFCApplication) | fcSDK Documentation

GetCountryObjid Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743851)>
Function GetCountryObjid( _
   ByVal _Country_ As String _
) As Integer

[DispIdAttribute(1610743851)]
int GetCountryObjid(
   string _Country_
)

Parameters

Country

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetDefaultCountry Method (IFCApplication) | fcSDK Documentation

GetDefaultCountry Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743848)>
Function GetDefaultCountry() As String

[DispIdAttribute(1610743848)]
string GetDefaultCountry()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetDefaultCountryObjId Method (IFCApplication) | fcSDK Documentation

GetDefaultCountryObjId Method (IFCApplication)

Syntax

'Declaration
<DispIdAttribute(1610743850)>
Function GetDefaultCountryObjId() As Integer

[DispIdAttribute(1610743850)]
int GetDefaultCountryObjId()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetDefaultState Method (IFCApplication) | fcSDK Documentation

GetDefaultState Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743856)>
Function GetDefaultState( _
   ByVal _Country_ As String _
) As String

[DispIdAttribute(1610743856)]
string GetDefaultState(
   string _Country_
)

Parameters

Country

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetDefaultStateObjid Method (IFCApplication) | fcSDK Documentation

GetDefaultStateObjid Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743857)>
Function GetDefaultStateObjid( _
   ByVal _Country_ As String _
) As Integer

[DispIdAttribute(1610743857)]
int GetDefaultStateObjid(
   string _Country_
)

Parameters

Country

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetDefaultTimeZone Method (IFCApplication) | fcSDK Documentation

GetDefaultTimeZone Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743871)>
Function GetDefaultTimeZone() As String

[DispIdAttribute(1610743871)]
string GetDefaultTimeZone()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetDefaultTimeZoneObjid Method (IFCApplication) | fcSDK Documentation

GetDefaultTimeZoneObjid Method (IFCApplication)

Syntax

'Declaration
<DispIdAttribute(1610743865)>
Function GetDefaultTimeZoneObjid() As Integer

[DispIdAttribute(1610743865)]
int GetDefaultTimeZoneObjid()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetFullStateObjid Method (IFCApplication) | fcSDK Documentation

GetFullStateObjid Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743861)>
Function GetFullStateObjid( _
   ByVal _Country_ As String, _
   ByVal _State_ As String _
) As Integer

[DispIdAttribute(1610743861)]
int GetFullStateObjid(
   string _Country_,
   string _State_
)

Parameters

Country

State

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetGbstDefault Method (IFCApplication) | fcSDK Documentation

GetGbstDefault Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743840)>
Function GetGbstDefault( _
   ByVal _ListName_ As String _
) As String

[DispIdAttribute(1610743840)]
string GetGbstDefault(
   string _ListName_
)

Parameters

ListName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetGbstDefaultObjid Method (IFCApplication) | fcSDK Documentation

GetGbstDefaultObjid Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743842)>
Function GetGbstDefaultObjid( _
   ByVal _ListName_ As String _
) As Integer

[DispIdAttribute(1610743842)]
int GetGbstDefaultObjid(
   string _ListName_
)

Parameters

ListName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetGbstElmById Method (IFCApplication) | fcSDK Documentation

GetGbstElmById Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743841)>
Function GetGbstElmById( _
   ByVal _ListName_ As String, _
   ByVal _ElmObjid_ As Integer _
) As String

[DispIdAttribute(1610743841)]
string GetGbstElmById(
   string _ListName_,
   int _ElmObjid_
)

Parameters

ListName

ElmObjid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetGbstElmObjid Method (IFCApplication) | fcSDK Documentation

GetGbstElmObjid Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743845)>
Function GetGbstElmObjid( _
   ByVal _ListName_ As String, _
   ByVal _Element_ As String _
) As Integer

[DispIdAttribute(1610743845)]
int GetGbstElmObjid(
   string _ListName_,
   string _Element_
)

Parameters

ListName

Element

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetGbstElmRankObjid Method (IFCApplication) | fcSDK Documentation

GetGbstElmRankObjid Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743846)>
Function GetGbstElmRankObjid( _
   ByVal _ListName_ As String, _
   ByVal _Rank_ As Integer _
) As Integer

[DispIdAttribute(1610743846)]
int GetGbstElmRankObjid(
   string _ListName_,
   int _Rank_
)

Parameters

ListName

Rank

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetGbstList Method (IFCApplication) | fcSDK Documentation

GetGbstList Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743847)>
Function GetGbstList( _
   ByVal _ListName_ As String, _
   Optional ByVal _IncludeInactive_ As Object _
) As ADODB.Recordset

[DispIdAttribute(1610743847)]
ADODB.Recordset GetGbstList(
   string _ListName_,
   object _IncludeInactive_
)

Parameters

ListName

IncludeInactive

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetHgbstElmDefault Method (IFCApplication) | fcSDK Documentation

GetHgbstElmDefault Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743876)>
Function GetHgbstElmDefault( _
   ByVal _ListName_ As String, _
   Optional ByVal _Element1_ As Object, _
   Optional ByVal _Element2_ As Object, _
   Optional ByVal _Element3_ As Object, _
   Optional ByVal _Element4_ As Object _
) As String

[DispIdAttribute(1610743876)]
string GetHgbstElmDefault(
   string _ListName_,
   object _Element1_,
   object _Element2_,
   object _Element3_,
   object _Element4_
)

Parameters

ListName

Element1

Element2

Element3

Element4

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetHgbstElmDefaultObjid Method (IFCApplication) | fcSDK Documentation

GetHgbstElmDefaultObjid Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743875)>
Function GetHgbstElmDefaultObjid( _
   ByVal _ListName_ As String, _
   Optional ByVal _Element1_ As Object, _
   Optional ByVal _Element2_ As Object, _
   Optional ByVal _Element3_ As Object, _
   Optional ByVal _Element4_ As Object _
) As Integer

[DispIdAttribute(1610743875)]
int GetHgbstElmDefaultObjid(
   string _ListName_,
   object _Element1_,
   object _Element2_,
   object _Element3_,
   object _Element4_
)

Parameters

ListName

Element1

Element2

Element3

Element4

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetHgbstElmObjId Method (IFCApplication) | fcSDK Documentation

GetHgbstElmObjId Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743874)>
Function GetHgbstElmObjId( _
   ByVal _TheElement_ As String, _
   ByVal _ListName_ As String, _
   Optional ByVal _Element1_ As Object, _
   Optional ByVal _Element2_ As Object, _
   Optional ByVal _Element3_ As Object, _
   Optional ByVal _Element4_ As Object _
) As Integer

[DispIdAttribute(1610743874)]
int GetHgbstElmObjId(
   string _TheElement_,
   string _ListName_,
   object _Element1_,
   object _Element2_,
   object _Element3_,
   object _Element4_
)

Parameters

TheElement

ListName

Element1

Element2

Element3

Element4

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetHgbstList Method (IFCApplication) | fcSDK Documentation

GetHgbstList Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743877)>
Function GetHgbstList( _
   ByVal _ListName_ As String, _
   Optional ByVal _Element1_ As Object, _
   Optional ByVal _Element2_ As Object, _
   Optional ByVal _Element3_ As Object, _
   Optional ByVal _Element4_ As Object, _
   Optional ByVal _includeInactive_ As Object _
) As ADODB.Recordset

[DispIdAttribute(1610743877)]
ADODB.Recordset GetHgbstList(
   string _ListName_,
   object _Element1_,
   object _Element2_,
   object _Element3_,
   object _Element4_,
   object _includeInactive_
)

Parameters

ListName

Element1

Element2

Element3

Element4

includeInactive

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetLocalizedGbstDefault Method (IFCApplication) | fcSDK Documentation

GetLocalizedGbstDefault Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743908)>
Function GetLocalizedGbstDefault( _
   ByVal _listName_ As String _
) As String

[DispIdAttribute(1610743908)]
string GetLocalizedGbstDefault(
   string _listName_
)

Parameters

listName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetLocalizedGbstElmById Method (IFCApplication) | fcSDK Documentation

GetLocalizedGbstElmById Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743909)>
Function GetLocalizedGbstElmById( _
   ByVal _listName_ As String, _
   ByVal _elmObjID_ As Integer _
) As String

[DispIdAttribute(1610743909)]
string GetLocalizedGbstElmById(
   string _listName_,
   int _elmObjID_
)

Parameters

listName

elmObjID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetRelationData Method (IFCApplication) | fcSDK Documentation

GetRelationData Method (IFCApplication)

Syntax

'Declaration
<DispIdAttribute(1610743893)>
Function GetRelationData( _
   ByVal _relationName_ As String, _
   ByVal _tableName_ As String _
) As ADODB.Recordset

[DispIdAttribute(1610743893)]
ADODB.Recordset GetRelationData(
   string _relationName_,
   string _tableName_
)

Parameters

relationName

tableName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetResClauses Method (IFCApplication) | fcSDK Documentation

GetResClauses Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743854)>
Function GetResClauses( _
   ByVal _tblNum_ As Integer, _
   ByRef _clauses_ As String _
) As Boolean

[DispIdAttribute(1610743854)]
bool GetResClauses(
   int _tblNum_,
   ref string _clauses_
)

Parameters

tblNum

clauses

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetResClausesStr Method (IFCApplication) | fcSDK Documentation

GetResClausesStr Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743905)>
Function GetResClausesStr( _
   ByVal _tblNum_ As Integer _
) As String

[DispIdAttribute(1610743905)]
string GetResClausesStr(
   int _tblNum_
)

Parameters

tblNum

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetResTbl Method (IFCApplication) | fcSDK Documentation

GetResTbl Method (IFCApplication)

Syntax

'Declaration
<DispIdAttribute(1610743853)>
Function GetResTbl( _
   ByVal _tblNum_ As Integer, _
   ByRef _the_res_ As String() _
) As Boolean

[DispIdAttribute(1610743853)]
bool GetResTbl(
   int _tblNum_,
   ref string[] _the_res_
)

Parameters

tblNum

the_res

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetServerTimeZoneOffset Method (IFCApplication) | fcSDK Documentation

GetServerTimeZoneOffset Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743869)>
Function GetServerTimeZoneOffset() As Integer

[DispIdAttribute(1610743869)]
int GetServerTimeZoneOffset()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetShortTimeZoneObjId Method (IFCApplication) | fcSDK Documentation

GetShortTimeZoneObjId Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743867)>
Function GetShortTimeZoneObjId( _
   ByVal _TimeZone_ As String _
) As Integer

[DispIdAttribute(1610743867)]
int GetShortTimeZoneObjId(
   string _TimeZone_
)

Parameters

TimeZone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetStateObjid Method (IFCApplication) | fcSDK Documentation

GetStateObjid Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743859)>
Function GetStateObjid( _
   ByVal _Country_ As String, _
   ByVal _State_ As String _
) As Integer

[DispIdAttribute(1610743859)]
int GetStateObjid(
   string _Country_,
   string _State_
)

Parameters

Country

State

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetStates Method (IFCApplication) | fcSDK Documentation

GetStates Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743855)>
Function GetStates( _
   ByVal _Country_ As String _
) As ADODB.Recordset

[DispIdAttribute(1610743855)]
ADODB.Recordset GetStates(
   string _Country_
)

Parameters

Country

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetTableFields Method (IFCApplication) | fcSDK Documentation

GetTableFields Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743899)>
Function GetTableFields( _
   ByVal _tableName_ As String _
) As ADODB.Recordset

[DispIdAttribute(1610743899)]
ADODB.Recordset GetTableFields(
   string _tableName_
)

Parameters

tableName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetTableID Method (IFCApplication) | fcSDK Documentation

GetTableID Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743863)>
Function GetTableID( _
   ByVal _TableName_ As String _
) As Integer

[DispIdAttribute(1610743863)]
int GetTableID(
   string _TableName_
)

Parameters

TableName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetTableName Method (IFCApplication) | fcSDK Documentation

GetTableName Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743862)>
Function GetTableName( _
   ByVal _TableNum_ As Integer _
) As String

[DispIdAttribute(1610743862)]
string GetTableName(
   int _TableNum_
)

Parameters

TableNum

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetTableRels Method (IFCApplication) | fcSDK Documentation

GetTableRels Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743900)>
Function GetTableRels( _
   ByVal _tableName_ As String, _
   ByVal _allowOneToMany_ As Boolean _
) As ADODB.Recordset

[DispIdAttribute(1610743900)]
ADODB.Recordset GetTableRels(
   string _tableName_,
   bool _allowOneToMany_
)

Parameters

tableName

allowOneToMany

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetTablesAndViews Method (IFCApplication) | fcSDK Documentation

GetTablesAndViews Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743896)>
Function GetTablesAndViews( _
   Optional ByVal _TablesOnly_ As Object _
) As ADODB.Recordset

[DispIdAttribute(1610743896)]
ADODB.Recordset GetTablesAndViews(
   object _TablesOnly_
)

Parameters

TablesOnly

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetTimeZoneList Method (IFCApplication) | fcSDK Documentation

GetTimeZoneList Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743870)>
Function GetTimeZoneList() As ADODB.Recordset

[DispIdAttribute(1610743870)]
ADODB.Recordset GetTimeZoneList()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetTimeZoneObjid Method (IFCApplication) | fcSDK Documentation

GetTimeZoneObjid Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743866)>
Function GetTimeZoneObjid( _
   ByVal _TimeZone_ As String _
) As Integer

[DispIdAttribute(1610743866)]
int GetTimeZoneObjid(
   string _TimeZone_
)

Parameters

TimeZone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetTimeZoneOffset Method (IFCApplication) | fcSDK Documentation

GetTimeZoneOffset Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743868)>
Function GetTimeZoneOffset( _
   ByVal _TimeZone_ As String _
) As Integer

[DispIdAttribute(1610743868)]
int GetTimeZoneOffset(
   string _TimeZone_
)

Parameters

TimeZone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetTimeZonesInCountry Method (IFCApplication) | fcSDK Documentation

GetTimeZonesInCountry Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743895)>
Function GetTimeZonesInCountry( _
   ByVal _Country_ As String _
) As ADODB.Recordset

[DispIdAttribute(1610743895)]
ADODB.Recordset GetTimeZonesInCountry(
   string _Country_
)

Parameters

Country

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


Initialize Method (IFCApplication) | fcSDK Documentation

Initialize Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743833)>
Sub Initialize()

[DispIdAttribute(1610743833)]
void Initialize()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


InitializeFull Method (IFCApplication) | fcSDK Documentation

InitializeFull Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743836)>
Sub InitializeFull( _
   ByVal _LoginName_ As String, _
   ByVal _password_ As String, _
   ByVal _DBServer_ As String, _
   ByVal _DBName_ As String, _
   Optional ByVal _DBType_ As Object, _
   Optional ByVal _LogFile_ As Object, _
   Optional ByVal _SqlLogFile_ As Object, _
   Optional ByVal _SQLLogging_ As Object, _
   Optional ByVal _fcAppLogging_ As Object, _
   Optional ByVal _fcSessionLogging_ As Object, _
   Optional ByVal _fcGenericLogging_ As Object, _
   Optional ByVal _fcBulkLogging_ As Object, _
   Optional ByVal _fcSqlExecLogging_ As Object, _
   Optional ByVal _NoCacheFile_ As Object _
)

[DispIdAttribute(1610743836)]
void InitializeFull(
   string _LoginName_,
   string _password_,
   string _DBServer_,
   string _DBName_,
   object _DBType_,
   object _LogFile_,
   object _SqlLogFile_,
   object _SQLLogging_,
   object _fcAppLogging_,
   object _fcSessionLogging_,
   object _fcGenericLogging_,
   object _fcBulkLogging_,
   object _fcSqlExecLogging_,
   object _NoCacheFile_
)

Parameters

LoginName

password

DBServer

DBName

DBType

LogFile

SqlLogFile

SQLLogging

fcAppLogging

fcSessionLogging

fcGenericLogging

fcBulkLogging

fcSqlExecLogging

NoCacheFile

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


is_it_a_field Method (IFCApplication) | fcSDK Documentation

is_it_a_field Method (IFCApplication)

Syntax

'Declaration
<DispIdAttribute(1610743885)>
Function is_it_a_field( _
   ByVal _tableName_ As String, _
   ByVal _fieldName_ As String _
) As Boolean

[DispIdAttribute(1610743885)]
bool is_it_a_field(
   string _tableName_,
   string _fieldName_
)

Parameters

tableName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


is_it_a_table Method (IFCApplication) | fcSDK Documentation

is_it_a_table Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743884)>
Function is_it_a_table( _
   ByVal _tableName_ As String _
) As Boolean

[DispIdAttribute(1610743884)]
bool is_it_a_table(
   string _tableName_
)

Parameters

tableName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


is_it_change_field Method (IFCApplication) | fcSDK Documentation

is_it_change_field Method (IFCApplication)

Syntax

'Declaration
<DispIdAttribute(1610743887)>
Function is_it_change_field( _
   ByVal _tableName_ As String, _
   ByVal _fieldName_ As String _
) As Boolean

[DispIdAttribute(1610743887)]
bool is_it_change_field(
   string _tableName_,
   string _fieldName_
)

Parameters

tableName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


is_it_date_field Method (IFCApplication) | fcSDK Documentation

is_it_date_field Method (IFCApplication)

Syntax

'Declaration
<DispIdAttribute(1610743901)>
Function is_it_date_field( _
   ByVal _tableName_ As String, _
   ByVal _fieldName_ As String _
) As Boolean

[DispIdAttribute(1610743901)]
bool is_it_date_field(
   string _tableName_,
   string _fieldName_
)

Parameters

tableName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


is_it_int_field Method (IFCApplication) | fcSDK Documentation

is_it_int_field Method (IFCApplication)

Syntax

'Declaration
<DispIdAttribute(1610743883)>
Function is_it_int_field( _
   ByVal _tableName_ As String, _
   ByVal _fieldName_ As String _
) As Boolean

[DispIdAttribute(1610743883)]
bool is_it_int_field(
   string _tableName_,
   string _fieldName_
)

Parameters

tableName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


is_it_searchable Method (IFCApplication) | fcSDK Documentation

is_it_searchable Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743879)>
Function is_it_searchable( _
   ByVal _tableName_ As String, _
   ByVal _fieldName_ As String _
) As Boolean

[DispIdAttribute(1610743879)]
bool is_it_searchable(
   string _tableName_,
   string _fieldName_
)

Parameters

tableName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


is_it_string_fld Method (IFCApplication) | fcSDK Documentation

is_it_string_fld Method (IFCApplication)

Syntax

'Declaration
<DispIdAttribute(1610743880)>
Function is_it_string_fld( _
   ByVal _tableName_ As String, _
   ByVal _fieldName_ As String _
) As Boolean

[DispIdAttribute(1610743880)]
bool is_it_string_fld(
   string _tableName_,
   string _fieldName_
)

Parameters

tableName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


is_it_unicode Method (IFCApplication) | fcSDK Documentation

is_it_unicode Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743898)>
Function is_it_unicode( _
   ByVal _tableName_ As String, _
   ByVal _fieldName_ As String _
) As Boolean

[DispIdAttribute(1610743898)]
bool is_it_unicode(
   string _tableName_,
   string _fieldName_
)

Parameters

tableName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


is_rel_exclusive Method (IFCApplication) | fcSDK Documentation

is_rel_exclusive Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743889)>
Function is_rel_exclusive( _
   ByVal _tbl_num_ As Integer, _
   ByVal _relationName_ As String, _
   ByRef _tbl_fld_ As String, _
   ByRef _objid_fld_ As String _
) As Boolean

[DispIdAttribute(1610743889)]
bool is_rel_exclusive(
   int _tbl_num_,
   string _relationName_,
   ref string _tbl_fld_,
   ref string _objid_fld_
)

Parameters

tbl_num

relationName

tbl_fld

objid_fld

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


is_rel_mandatory Method (IFCApplication) | fcSDK Documentation

is_rel_mandatory Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743890)>
Function is_rel_mandatory( _
   ByVal _tbl_num_ As Integer, _
   ByVal _relationName_ As String _
) As Boolean

[DispIdAttribute(1610743890)]
bool is_rel_mandatory(
   int _tbl_num_,
   string _relationName_
)

Parameters

tbl_num

relationName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


IsCountry Method (IFCApplication) | fcSDK Documentation

IsCountry Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743849)>
Function IsCountry( _
   ByVal _Country_ As String _
) As Boolean

[DispIdAttribute(1610743849)]
bool IsCountry(
   string _Country_
)

Parameters

Country

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


IsFullState Method (IFCApplication) | fcSDK Documentation

IsFullState Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743860)>
Function IsFullState( _
   ByVal _Country_ As String, _
   ByVal _State_ As String _
) As Boolean

[DispIdAttribute(1610743860)]
bool IsFullState(
   string _Country_,
   string _State_
)

Parameters

Country

State

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


IsInGbstLst Method (IFCApplication) | fcSDK Documentation

IsInGbstLst Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743843)>
Function IsInGbstLst( _
   ByVal _ListName_ As String, _
   ByVal _Element_ As String _
) As Boolean

[DispIdAttribute(1610743843)]
bool IsInGbstLst(
   string _ListName_,
   string _Element_
)

Parameters

ListName

Element

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


IsInHgbstList Method (IFCApplication) | fcSDK Documentation

IsInHgbstList Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743873)>
Function IsInHgbstList( _
   ByVal _TheElement_ As String, _
   ByVal _ListName_ As String, _
   Optional ByVal _Element1_ As Object, _
   Optional ByVal _Element2_ As Object, _
   Optional ByVal _Element3_ As Object, _
   Optional ByVal _Element4_ As Object _
) As Boolean

[DispIdAttribute(1610743873)]
bool IsInHgbstList(
   string _TheElement_,
   string _ListName_,
   object _Element1_,
   object _Element2_,
   object _Element3_,
   object _Element4_
)

Parameters

TheElement

ListName

Element1

Element2

Element3

Element4

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


IsOnDST Method (IFCApplication) | fcSDK Documentation

IsOnDST Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743886)>
Function IsOnDST( _
   ByVal _TheTimeZone_ As String, _
   ByVal _TheDate_ As Date _
) As Boolean

[DispIdAttribute(1610743886)]
bool IsOnDST(
   string _TheTimeZone_,
   DateTime _TheDate_
)

Parameters

TheTimeZone

TheDate

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


IsState Method (IFCApplication) | fcSDK Documentation

IsState Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743858)>
Function IsState( _
   ByVal _Country_ As String, _
   ByVal _State_ As String _
) As Boolean

[DispIdAttribute(1610743858)]
bool IsState(
   string _Country_,
   string _State_
)

Parameters

Country

State

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


IsTimeZone Method (IFCApplication) | fcSDK Documentation

IsTimeZone Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743864)>
Function IsTimeZone( _
   ByVal _TImeZone_ As String _
) As Boolean

[DispIdAttribute(1610743864)]
bool IsTimeZone(
   string _TImeZone_
)

Parameters

TImeZone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


IsTimeZoneInCountry Method (IFCApplication) | fcSDK Documentation

IsTimeZoneInCountry Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743894)>
Function IsTimeZoneInCountry( _
   ByVal _Country_ As String, _
   ByVal _TimeZone_ As String, _
   ByVal _IsFullName_ As Boolean _
) As Boolean

[DispIdAttribute(1610743894)]
bool IsTimeZoneInCountry(
   string _Country_,
   string _TimeZone_,
   bool _IsFullName_
)

Parameters

Country

TimeZone

IsFullName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


Log Method (IFCApplication) | fcSDK Documentation

Log Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743832)>
Sub Log( _
   ByVal _TheMessageType_ As Object, _
   ByVal _TheMessage_ As Object _
)

[DispIdAttribute(1610743832)]
void Log(
   object _TheMessageType_,
   object _TheMessage_
)

Parameters

TheMessageType

TheMessage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


LogEx Method (IFCApplication) | fcSDK Documentation

LogEx Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743907)>
Sub LogEx( _
   ByVal _logLevel_ As String, _
   ByVal _logMessage_ As String _
)

[DispIdAttribute(1610743907)]
void LogEx(
   string _logLevel_,
   string _logMessage_
)

Parameters

logLevel

logMessage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


RankIsInGbstLst Method (IFCApplication) | fcSDK Documentation

RankIsInGbstLst Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743844)>
Function RankIsInGbstLst( _
   ByVal _ListName_ As String, _
   ByVal _Rank_ As Integer _
) As Boolean

[DispIdAttribute(1610743844)]
bool RankIsInGbstLst(
   string _ListName_,
   int _Rank_
)

Parameters

ListName

Rank

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


SetServerTimeZoneToMachineTimeZone Method (IFCApplication) | fcSDK Documentation

SetServerTimeZoneToMachineTimeZone Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743872)>
Sub SetServerTimeZoneToMachineTimeZone()

[DispIdAttribute(1610743872)]
void SetServerTimeZoneToMachineTimeZone()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


sprintf Method (IFCApplication) | fcSDK Documentation

sprintf Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743881)>
Function sprintf( _
   ByVal _inputString_ As String, _
   Optional ByVal _arg1_ As Object, _
   Optional ByVal _arg2_ As Object, _
   Optional ByVal _arg3_ As Object, _
   Optional ByVal _arg4_ As Object, _
   Optional ByVal _arg5_ As Object, _
   Optional ByVal _arg6_ As Object _
) As String

[DispIdAttribute(1610743881)]
string sprintf(
   string _inputString_,
   object _arg1_,
   object _arg2_,
   object _arg3_,
   object _arg4_,
   object _arg5_,
   object _arg6_
)

Parameters

inputString

arg1

arg2

arg3

arg4

arg5

arg6

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


UpdateCache Method (IFCApplication) | fcSDK Documentation

UpdateCache Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743891)>
Sub UpdateCache()

[DispIdAttribute(1610743891)]
void UpdateCache()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


UpdateSchemaCache Method (IFCApplication) | fcSDK Documentation

UpdateSchemaCache Method (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743892)>
Sub UpdateSchemaCache()

[DispIdAttribute(1610743892)]
void UpdateSchemaCache()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


ValidateEncryptedPassword Method (IFCApplication) | fcSDK Documentation

ValidateEncryptedPassword Method (IFCApplication)

Syntax

'Declaration
<DispIdAttribute(1610743904)>
Function ValidateEncryptedPassword( _
   ByVal _str_ As String, _
   ByVal _encr_ As String, _
   ByVal _pre9_ As Short _
) As Boolean

[DispIdAttribute(1610743904)]
bool ValidateEncryptedPassword(
   string _str_,
   string _encr_,
   short _pre9_
)

Parameters

str

encr

pre9

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


base_objid Property (IFCApplication) | fcSDK Documentation

base_objid Property (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743816)>
ReadOnly Property base_objid As Integer

[DispIdAttribute(1610743816)]
int base_objid {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


clarify_ver Property (IFCApplication) | fcSDK Documentation

clarify_ver Property (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743812)>
ReadOnly Property clarify_ver As String

[DispIdAttribute(1610743812)]
string clarify_ver {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


ConnectionString Property (IFCApplication) | fcSDK Documentation

ConnectionString Property (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743813)>
ReadOnly Property ConnectionString As String

[DispIdAttribute(1610743813)]
string ConnectionString {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


ConvertTimeZone Property (IFCApplication) | fcSDK Documentation

ConvertTimeZone Property (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743817)>
Property ConvertTimeZone As Boolean

[DispIdAttribute(1610743817)]
bool ConvertTimeZone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


DataProtectorEntropy Property (IFCApplication) | fcSDK Documentation

DataProtectorEntropy Property (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743831)>
WriteOnly Property DataProtectorEntropy As String

[DispIdAttribute(1610743831)]
string DataProtectorEntropy {set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


db_name Property (IFCApplication) | fcSDK Documentation

db_name Property (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743810)>
ReadOnly Property db_name As String

[DispIdAttribute(1610743810)]
string db_name {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


db_type Property (IFCApplication) | fcSDK Documentation

db_type Property (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743809)>
ReadOnly Property db_type As String

[DispIdAttribute(1610743809)]
string db_type {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


GetMachineTimeZone Property (IFCApplication) | fcSDK Documentation

GetMachineTimeZone Property (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743824)>
ReadOnly Property GetMachineTimeZone As String

[DispIdAttribute(1610743824)]
string GetMachineTimeZone {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


IsDBTraveler Property (IFCApplication) | fcSDK Documentation

IsDBTraveler Property (IFCApplication)

Syntax

'Declaration
<DispIdAttribute(1610743819)>
ReadOnly Property IsDBTraveler As Boolean

[DispIdAttribute(1610743819)]
bool IsDBTraveler {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


IsDBUnicode Property (IFCApplication) | fcSDK Documentation

IsDBUnicode Property (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743823)>
ReadOnly Property IsDBUnicode As Boolean

[DispIdAttribute(1610743823)]
bool IsDBUnicode {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


IsFcflNet Property (IFCApplication) | fcSDK Documentation

IsFcflNet Property (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743808)>
ReadOnly Property IsFcflNet As Boolean

[DispIdAttribute(1610743808)]
bool IsFcflNet {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


LicenseExpirationDate Property (IFCApplication) | fcSDK Documentation

LicenseExpirationDate Property (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743835)>
ReadOnly Property LicenseExpirationDate As String

[DispIdAttribute(1610743835)]
string LicenseExpirationDate {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


LoggingConfigFilePath Property (IFCApplication) | fcSDK Documentation

LoggingConfigFilePath Property (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743829)>
Property LoggingConfigFilePath As String

[DispIdAttribute(1610743829)]
string LoggingConfigFilePath {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


Midnight Property (IFCApplication) | fcSDK Documentation

Midnight Property (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743825)>
Property Midnight As String

[DispIdAttribute(1610743825)]
string Midnight {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


schema_rev Property (IFCApplication) | fcSDK Documentation

schema_rev Property (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743811)>
ReadOnly Property schema_rev As Short

[DispIdAttribute(1610743811)]
short schema_rev {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


ServerTimeZone Property (IFCApplication) | fcSDK Documentation

ServerTimeZone Property (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743827)>
Property ServerTimeZone As String

[DispIdAttribute(1610743827)]
string ServerTimeZone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


site_id Property (IFCApplication) | fcSDK Documentation

site_id Property (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743820)>
ReadOnly Property site_id As Short

[DispIdAttribute(1610743820)]
short site_id {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


TruncateStringFields Property (IFCApplication) | fcSDK Documentation

TruncateStringFields Property (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743821)>
Property TruncateStringFields As Boolean

[DispIdAttribute(1610743821)]
bool TruncateStringFields {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


WorkingDirectory Property (IFCApplication) | fcSDK Documentation

WorkingDirectory Property (IFCApplication)

Syntax

'Declaration

<DispIdAttribute(1610743814)>
Property WorkingDirectory As String

[DispIdAttribute(1610743814)]
string WorkingDirectory {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCApplication Interface
IFCApplication Members


IFCBulk Interface | fcSDK Documentation

IFCBulk Interface

Syntax

'Declaration

<GuidAttribute("3D860A38-CDDA-4653-88DC-F7BB6AD46E94")>
<ComVisibleAttribute(True)>
Public Interface IFCBulk

[GuidAttribute("3D860A38-CDDA-4653-88DC-F7BB6AD46E94")]
[ComVisibleAttribute(true)]
public interface IFCBulk

Requirements

Namespace: FChoice.Foundation.Clarify.Compatibility

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Foundation.Clarify.Compatibility (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Foundation.Clarify.Compatibility.dll)

Reference

IFCBulk Members
FChoice.Foundation.Clarify.Compatibility Namespace


IFCBulk Interface Members | fcSDK Documentation

IFCBulk Interface Members

The following tables list the members exposed by IFCBulk.

Public Properties

 | Name | Description
Property | BulkID |
Property | Name |
Property | NoSorting |

Public Methods

 | Name | Description
Method | AddGeneric |
Method | ChangeGenericsOrdering |
Method | NewEnum |
Method | Query |
Method | RemoveAllGenerics |
Method | RemoveGeneric |
Method | Update |
Method | UpdateAll |

Reference

IFCBulk Interface
FChoice.Foundation.Clarify.Compatibility Namespace


AddGeneric Method (IFCBulk) | fcSDK Documentation

AddGeneric Method (IFCBulk)

Syntax

'Declaration

<DispIdAttribute(1610743815)>
Sub AddGeneric( _
   ByVal _generic_ As IFCGeneric _
)

[DispIdAttribute(1610743815)]
void AddGeneric(
   IFCGeneric _generic_
)

Parameters

generic

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCBulk Interface
IFCBulk Members


ChangeGenericsOrdering Method (IFCBulk) | fcSDK Documentation

ChangeGenericsOrdering Method (IFCBulk)

Syntax

'Declaration
<DispIdAttribute(1610743814)>
Sub ChangeGenericsOrdering( _
   ByVal _generic_ As IFCGeneric _
)

[DispIdAttribute(1610743814)]
void ChangeGenericsOrdering(
   IFCGeneric _generic_
)

Parameters

generic

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCBulk Interface
IFCBulk Members


NewEnum Method (IFCBulk) | fcSDK Documentation

NewEnum Method (IFCBulk)

Syntax

'Declaration

<DispIdAttribute(-4)>
Function NewEnum() As IEnumerator

[DispIdAttribute(-4)]
IEnumerator NewEnum()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCBulk Interface
IFCBulk Members


Query Method (IFCBulk) | fcSDK Documentation

Query Method (IFCBulk)

Syntax

'Declaration

<DispIdAttribute(1610743818)>
Sub Query()

[DispIdAttribute(1610743818)]
void Query()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCBulk Interface
IFCBulk Members


RemoveAllGenerics Method (IFCBulk) | fcSDK Documentation

RemoveAllGenerics Method (IFCBulk)

Syntax

'Declaration

<DispIdAttribute(1610743816)>
Sub RemoveAllGenerics()

[DispIdAttribute(1610743816)]
void RemoveAllGenerics()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCBulk Interface
IFCBulk Members


RemoveGeneric Method (IFCBulk) | fcSDK Documentation

RemoveGeneric Method (IFCBulk)

Syntax

'Declaration

<DispIdAttribute(1610743817)>
Sub RemoveGeneric( _
   ByVal _generic_ As IFCGeneric _
)

[DispIdAttribute(1610743817)]
void RemoveGeneric(
   IFCGeneric _generic_
)

Parameters

generic

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCBulk Interface
IFCBulk Members


Update Method (IFCBulk) | fcSDK Documentation

Update Method (IFCBulk)

Syntax

'Declaration

<DispIdAttribute(1610743819)>
Sub Update()

[DispIdAttribute(1610743819)]
void Update()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCBulk Interface
IFCBulk Members


UpdateAll Method (IFCBulk) | fcSDK Documentation

UpdateAll Method (IFCBulk)

Syntax

'Declaration

<DispIdAttribute(1610743820)>
Sub UpdateAll()

[DispIdAttribute(1610743820)]
void UpdateAll()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCBulk Interface
IFCBulk Members


BulkID Property (IFCBulk) | fcSDK Documentation

BulkID Property (IFCBulk)

Syntax

'Declaration

<DispIdAttribute(1610743812)>
Property BulkID As Short

[DispIdAttribute(1610743812)]
short BulkID {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCBulk Interface
IFCBulk Members


Name Property (IFCBulk) | fcSDK Documentation

Name Property (IFCBulk)

Syntax

'Declaration

<DispIdAttribute(1610743810)>
Property Name As String

[DispIdAttribute(1610743810)]
string Name {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCBulk Interface
IFCBulk Members


NoSorting Property (IFCBulk) | fcSDK Documentation

NoSorting Property (IFCBulk)

Syntax

'Declaration
<DispIdAttribute(1610743808)>
Property NoSorting As Boolean

[DispIdAttribute(1610743808)]
bool NoSorting {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCBulk Interface
IFCBulk Members


IFCGeneric Interface | fcSDK Documentation

IFCGeneric Interface

Syntax

'Declaration

<ComVisibleAttribute(True)>
<DefaultMemberAttribute("Item")>
<GuidAttribute("545582EE-2D64-4869-AC88-7D1B5031A960")>
Public Interface IFCGeneric

[ComVisibleAttribute(true)]
[DefaultMemberAttribute("Item")]
[GuidAttribute("545582EE-2D64-4869-AC88-7D1B5031A960")]
public interface IFCGeneric

Requirements

Namespace: FChoice.Foundation.Clarify.Compatibility

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Foundation.Clarify.Compatibility (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Foundation.Clarify.Compatibility.dll)

Reference

IFCGeneric Members
FChoice.Foundation.Clarify.Compatibility Namespace


IFCGeneric Interface Members | fcSDK Documentation

IFCGeneric Interface Members

The following tables list the members exposed by IFCGeneric.

Public Properties

 | Name | Description
Property | BOF |
Property | Bulk |
Property | BulkName |
Property | child_objects |
Property | DataFields |
Property | DbObjectName |
Property | DbObjectNum |
Property | DelRelList |
Property | Distinct |
Property | EOF |
Property | ErrorOnQueryTooBig |
Property | Filter |
Property | GenericId |
Property | Id |
Property | IncludeRelations |
Property | Item |
Property | MaxRecords |
Property | NoRes |
Property | ParentBO |
Property | ParentRelation |
Property | Position |
Property | QueryEmptyToNull |
Property | records |
Property | rel_from_parent |
Property | rel_to_parent |
Property | rel_type |
Property | rowLimit |
Property | rowsReturned |
Property | SetNullStringsToEmpty |
Property | SortOrder |

Public Methods

 | Name | Description
Method | AddForUpdate |
Method | AddNew |
Method | AppendFilter |
Method | AppendSort |
Method | AssignAllObjids |
Method | AssignObjid |
Method | ClearRoot |
Method | CloseGeneric |
Method | copy |
Method | Count |
Method | Delete |
Method | DeleteAll |
Method | Duplicate |
Method | get_Fields |
Method | GetField |
Method | GetFieldValue |
Method | MoveFirst |
Method | MoveFirstAbsolute |
Method | MoveLast |
Method | MoveLastAbsolute |
Method | MoveNext |
Method | MoveNextAbsolute |
Method | MovePrevious |
Method | MovePreviousAbsolute |
Method | MoveRelative |
Method | Query |
Method | RelateByID |
Method | RelateIntFldByID |
Method | RelateIntFldToRecord |
Method | RelateRecords |
Method | set_Fields |
Method | SimpleQuery |
Method | TotalCount |
Method | TraverseFromParent |
Method | TraverseFromRoot |
Method | UnRelateAll |
Method | UnRelateRecordFromAll |
Method | UnRelateRecords |
Method | Untraverse |
Method | Update |
Method | UpdateAll |

Reference

IFCGeneric Interface
FChoice.Foundation.Clarify.Compatibility Namespace


AddForUpdate Method (IFCGeneric) | fcSDK Documentation

AddForUpdate Method (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743880)>
Sub AddForUpdate( _
   ByVal _TheObjid_ As Integer _
)

[DispIdAttribute(1610743880)]
void AddForUpdate(
   int _TheObjid_
)

Parameters

TheObjid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


AddNew Method (IFCGeneric) | fcSDK Documentation

AddNew Method (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743879)>
Sub AddNew()

[DispIdAttribute(1610743879)]
void AddNew()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


AppendFilter Method (IFCGeneric) | fcSDK Documentation

AppendFilter Method (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743858)>
Sub AppendFilter( _
   ByVal _field_name_ As String, _
   ByVal _operation_ As String, _
   ByVal _value_ As Object _
)

[DispIdAttribute(1610743858)]
void AppendFilter(
   string _field_name_,
   string _operation_,
   object _value_
)

Parameters

field_name

operation

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


AppendSort Method (IFCGeneric) | fcSDK Documentation

AppendSort Method (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743859)>
Sub AppendSort( _
   ByVal _field_name_ As String, _
   ByVal _ascending_ As String _
)

[DispIdAttribute(1610743859)]
void AppendSort(
   string _field_name_,
   string _ascending_
)

Parameters

field_name

ascending

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


AssignAllObjids Method (IFCGeneric) | fcSDK Documentation

AssignAllObjids Method (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743884)>
Sub AssignAllObjids()

[DispIdAttribute(1610743884)]
void AssignAllObjids()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


AssignObjid Method (IFCGeneric) | fcSDK Documentation

AssignObjid Method (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743883)>
Sub AssignObjid()

[DispIdAttribute(1610743883)]
void AssignObjid()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


ClearRoot Method (IFCGeneric) | fcSDK Documentation

ClearRoot Method (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743896)>
Sub ClearRoot()

[DispIdAttribute(1610743896)]
void ClearRoot()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


CloseGeneric Method (IFCGeneric) | fcSDK Documentation

CloseGeneric Method (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743892)>
Sub CloseGeneric()

[DispIdAttribute(1610743892)]
void CloseGeneric()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


copy Method (IFCGeneric) | fcSDK Documentation

copy Method (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743894)>
Function copy( _
   Optional ByVal _use_generic_ As Object _
) As IFCGeneric

[DispIdAttribute(1610743894)]
IFCGeneric copy(
   object _use_generic_
)

Parameters

use_generic

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


Count Method (IFCGeneric) | fcSDK Documentation

Count Method (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743864)>
Function Count() As Integer

[DispIdAttribute(1610743864)]
int Count()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


Delete Method (IFCGeneric) | fcSDK Documentation

Delete Method (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743877)>
Sub Delete()

[DispIdAttribute(1610743877)]
void Delete()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


DeleteAll Method (IFCGeneric) | fcSDK Documentation

DeleteAll Method (IFCGeneric)

Syntax

'Declaration
<DispIdAttribute(1610743878)>
Sub DeleteAll()

[DispIdAttribute(1610743878)]
void DeleteAll()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


Duplicate Method (IFCGeneric) | fcSDK Documentation

Duplicate Method (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743893)>
Function Duplicate( _
   Optional ByVal _use_generic_ As Object _
) As IFCGeneric

[DispIdAttribute(1610743893)]
IFCGeneric Duplicate(
   object _use_generic_
)

Parameters

use_generic

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


get_Fields Method (IFCGeneric) | fcSDK Documentation

get_Fields Method (IFCGeneric)

Syntax

'Declaration

Function get_Fields( _
   ByVal _index_ As Object _
) As Object

object get_Fields(
   object _index_
)

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


GetField Method (IFCGeneric) | fcSDK Documentation

GetField Method (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743875)>
Function GetField( _
   ByVal _fieldName_ As String _
) As Object

[DispIdAttribute(1610743875)]
object GetField(
   string _fieldName_
)

Parameters

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


GetFieldValue Method (IFCGeneric) | fcSDK Documentation

GetFieldValue Method (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743876)>
Function GetFieldValue( _
   ByVal _index_ As Object _
) As Object

[DispIdAttribute(1610743876)]
object GetFieldValue(
   object _index_
)

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


MoveFirst Method (IFCGeneric) | fcSDK Documentation

MoveFirst Method (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743872)>
Sub MoveFirst()

[DispIdAttribute(1610743872)]
void MoveFirst()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


MoveFirstAbsolute Method (IFCGeneric) | fcSDK Documentation

MoveFirstAbsolute Method (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743868)>
Sub MoveFirstAbsolute()

[DispIdAttribute(1610743868)]
void MoveFirstAbsolute()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


MoveLast Method (IFCGeneric) | fcSDK Documentation

MoveLast Method (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743873)>
Sub MoveLast()

[DispIdAttribute(1610743873)]
void MoveLast()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


MoveLastAbsolute Method (IFCGeneric) | fcSDK Documentation

MoveLastAbsolute Method (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743870)>
Sub MoveLastAbsolute()

[DispIdAttribute(1610743870)]
void MoveLastAbsolute()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


MoveNext Method (IFCGeneric) | fcSDK Documentation

MoveNext Method (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743866)>
Sub MoveNext()

[DispIdAttribute(1610743866)]
void MoveNext()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


MoveNextAbsolute Method (IFCGeneric) | fcSDK Documentation

MoveNextAbsolute Method (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743869)>
Sub MoveNextAbsolute()

[DispIdAttribute(1610743869)]
void MoveNextAbsolute()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


MovePrevious Method (IFCGeneric) | fcSDK Documentation

MovePrevious Method (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743867)>
Sub MovePrevious()

[DispIdAttribute(1610743867)]
void MovePrevious()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


MovePreviousAbsolute Method (IFCGeneric) | fcSDK Documentation

MovePreviousAbsolute Method (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743871)>
Sub MovePreviousAbsolute()

[DispIdAttribute(1610743871)]
void MovePreviousAbsolute()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


MoveRelative Method (IFCGeneric) | fcSDK Documentation

MoveRelative Method (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743874)>
Sub MoveRelative( _
   ByVal _NumToMove_ As Short _
)

[DispIdAttribute(1610743874)]
void MoveRelative(
   short _NumToMove_
)

Parameters

NumToMove

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


Query Method (IFCGeneric) | fcSDK Documentation

Query Method (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743863)>
Sub Query()

[DispIdAttribute(1610743863)]
void Query()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


RelateByID Method (IFCGeneric) | fcSDK Documentation

RelateByID Method (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743887)>
Sub RelateByID( _
   ByVal _objId_ As Integer, _
   ByVal _relationName_ As String _
)

[DispIdAttribute(1610743887)]
void RelateByID(
   int _objId_,
   string _relationName_
)

Parameters

objId

relationName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


RelateIntFldByID Method (IFCGeneric) | fcSDK Documentation

RelateIntFldByID Method (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743886)>
Sub RelateIntFldByID( _
   ByVal _objId_ As Integer, _
   ByVal _the_field_ As String _
)

[DispIdAttribute(1610743886)]
void RelateIntFldByID(
   int _objId_,
   string _the_field_
)

Parameters

objId

the_field

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


RelateIntFldToRecord Method (IFCGeneric) | fcSDK Documentation

RelateIntFldToRecord Method (IFCGeneric)

Syntax

'Declaration
<DispIdAttribute(1610743885)>
Sub RelateIntFldToRecord( _
   ByVal _o_obj_ As IFCGeneric, _
   ByVal _the_field_ As String _
)

[DispIdAttribute(1610743885)]
void RelateIntFldToRecord(
   IFCGeneric _o_obj_,
   string _the_field_
)

Parameters

o_obj

the_field

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


RelateRecords Method (IFCGeneric) | fcSDK Documentation

RelateRecords Method (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743888)>
Sub RelateRecords( _
   ByVal _o_obj_ As IFCGeneric, _
   ByVal _relationName_ As String _
)

[DispIdAttribute(1610743888)]
void RelateRecords(
   IFCGeneric _o_obj_,
   string _relationName_
)

Parameters

o_obj

relationName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


set_Fields Method (IFCGeneric) | fcSDK Documentation

set_Fields Method (IFCGeneric)

Syntax

'Declaration

Sub set_Fields( _
   ByVal _index_ As Object, _
   ByVal _newValue_ As Object _
)

void set_Fields(
   object _index_,
   object _newValue_
)

Parameters

index

newValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


SimpleQuery Method (IFCGeneric) | fcSDK Documentation

SimpleQuery Method (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743861)>
Sub SimpleQuery( _
   ByVal _obj_name_ As String _
)

[DispIdAttribute(1610743861)]
void SimpleQuery(
   string _obj_name_
)

Parameters

obj_name

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


TotalCount Method (IFCGeneric) | fcSDK Documentation

TotalCount Method (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743865)>
Function TotalCount() As Integer

[DispIdAttribute(1610743865)]
int TotalCount()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


TraverseFromParent Method (IFCGeneric) | fcSDK Documentation

TraverseFromParent Method (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743862)>
Sub TraverseFromParent( _
   ByVal _the_parent_ As IFCGeneric, _
   ByVal _trav_rel_ As String _
)

[DispIdAttribute(1610743862)]
void TraverseFromParent(
   IFCGeneric _the_parent_,
   string _trav_rel_
)

Parameters

the_parent

trav_rel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


TraverseFromRoot Method (IFCGeneric) | fcSDK Documentation

TraverseFromRoot Method (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743895)>
Sub TraverseFromRoot( _
   ByVal _RootObjid_ As Integer, _
   ByVal _TblName_ As String, _
   ByVal _RootRel_ As String _
)

[DispIdAttribute(1610743895)]
void TraverseFromRoot(
   int _RootObjid_,
   string _TblName_,
   string _RootRel_
)

Parameters

RootObjid

TblName

RootRel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


UnRelateAll Method (IFCGeneric) | fcSDK Documentation

UnRelateAll Method (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743889)>
Sub UnRelateAll( _
   ByVal _relationName_ As String _
)

[DispIdAttribute(1610743889)]
void UnRelateAll(
   string _relationName_
)

Parameters

relationName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


UnRelateRecordFromAll Method (IFCGeneric) | fcSDK Documentation

UnRelateRecordFromAll Method (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743890)>
Sub UnRelateRecordFromAll( _
   ByVal _relationName_ As String _
)

[DispIdAttribute(1610743890)]
void UnRelateRecordFromAll(
   string _relationName_
)

Parameters

relationName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


UnRelateRecords Method (IFCGeneric) | fcSDK Documentation

UnRelateRecords Method (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743891)>
Sub UnRelateRecords( _
   ByVal _o_obj_ As IFCGeneric, _
   ByVal _relationName_ As String _
)

[DispIdAttribute(1610743891)]
void UnRelateRecords(
   IFCGeneric _o_obj_,
   string _relationName_
)

Parameters

o_obj

relationName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


Untraverse Method (IFCGeneric) | fcSDK Documentation

Untraverse Method (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743860)>
Sub Untraverse()

[DispIdAttribute(1610743860)]
void Untraverse()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


Update Method (IFCGeneric) | fcSDK Documentation

Update Method (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743881)>
Sub Update()

[DispIdAttribute(1610743881)]
void Update()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


UpdateAll Method (IFCGeneric) | fcSDK Documentation

UpdateAll Method (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743882)>
Sub UpdateAll()

[DispIdAttribute(1610743882)]
void UpdateAll()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


BOF Property (IFCGeneric) | fcSDK Documentation

BOF Property (IFCGeneric)

Syntax

'Declaration
<DispIdAttribute(1610743837)>
ReadOnly Property BOF As Boolean

[DispIdAttribute(1610743837)]
bool BOF {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


Bulk Property (IFCGeneric) | fcSDK Documentation

Bulk Property (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743851)>
Property Bulk As IFCBulk

[DispIdAttribute(1610743851)]
IFCBulk Bulk {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


BulkName Property (IFCGeneric) | fcSDK Documentation

BulkName Property (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743849)>
Property BulkName As String

[DispIdAttribute(1610743849)]
string BulkName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


child_objects Property (IFCGeneric) | fcSDK Documentation

child_objects Property (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743821)>
ReadOnly Property child_objects As IMockCollection

[DispIdAttribute(1610743821)]
IMockCollection child_objects {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


DataFields Property (IFCGeneric) | fcSDK Documentation

DataFields Property (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743810)>
Property DataFields As String

[DispIdAttribute(1610743810)]
string DataFields {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


DbObjectName Property (IFCGeneric) | fcSDK Documentation

DbObjectName Property (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743855)>
Property DbObjectName As String

[DispIdAttribute(1610743855)]
string DbObjectName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


DbObjectNum Property (IFCGeneric) | fcSDK Documentation

DbObjectNum Property (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743857)>
ReadOnly Property DbObjectNum As Integer

[DispIdAttribute(1610743857)]
int DbObjectNum {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


DelRelList Property (IFCGeneric) | fcSDK Documentation

DelRelList Property (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743832)>
Property DelRelList As String

[DispIdAttribute(1610743832)]
string DelRelList {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


Distinct Property (IFCGeneric) | fcSDK Documentation

Distinct Property (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743808)>
Property Distinct As Boolean

[DispIdAttribute(1610743808)]
bool Distinct {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


EOF Property (IFCGeneric) | fcSDK Documentation

EOF Property (IFCGeneric)

Syntax

'Declaration
<DispIdAttribute(1610743836)>
ReadOnly Property EOF As Boolean

[DispIdAttribute(1610743836)]
bool EOF {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


ErrorOnQueryTooBig Property (IFCGeneric) | fcSDK Documentation

ErrorOnQueryTooBig Property (IFCGeneric)

Syntax

'Declaration
<DispIdAttribute(1610743830)>
Property ErrorOnQueryTooBig As Boolean

[DispIdAttribute(1610743830)]
bool ErrorOnQueryTooBig {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


Filter Property (IFCGeneric) | fcSDK Documentation

Filter Property (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743812)>
Property Filter As String

[DispIdAttribute(1610743812)]
string Filter {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


GenericId Property (IFCGeneric) | fcSDK Documentation

GenericId Property (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743853)>
Property GenericId As String

[DispIdAttribute(1610743853)]
string GenericId {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


Id Property (IFCGeneric) | fcSDK Documentation

Id Property (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743838)>
ReadOnly Property Id As Integer

[DispIdAttribute(1610743838)]
int Id {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


IncludeRelations Property (IFCGeneric) | fcSDK Documentation

IncludeRelations Property (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743817)>
Property IncludeRelations As Boolean

[DispIdAttribute(1610743817)]
bool IncludeRelations {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


Item Property (IFCGeneric) | fcSDK Documentation

Item Property (IFCGeneric)

Syntax

'Declaration
<ComVisibleAttribute(False)>
Default Property Item( _
   ByVal _index_ As Object _
) As IMockAdoField

[ComVisibleAttribute(false)]
IMockAdoField this[
   object _index_
]; {get; set;}

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


MaxRecords Property (IFCGeneric) | fcSDK Documentation

MaxRecords Property (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610744064)>
Property MaxRecords As Integer

[DispIdAttribute(1610744064)]
int MaxRecords {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


NoRes Property (IFCGeneric) | fcSDK Documentation

NoRes Property (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743825)>
Property NoRes As Boolean

[DispIdAttribute(1610743825)]
bool NoRes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


ParentBO Property (IFCGeneric) | fcSDK Documentation

ParentBO Property (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743847)>
Property ParentBO As IFCGeneric

[DispIdAttribute(1610743847)]
IFCGeneric ParentBO {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


ParentRelation Property (IFCGeneric) | fcSDK Documentation

ParentRelation Property (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743845)>
Property ParentRelation As String

[DispIdAttribute(1610743845)]
string ParentRelation {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


Position Property (IFCGeneric) | fcSDK Documentation

Position Property (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743843)>
Property Position As Short

[DispIdAttribute(1610743843)]
short Position {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


QueryEmptyToNull Property (IFCGeneric) | fcSDK Documentation

QueryEmptyToNull Property (IFCGeneric)

Syntax

'Declaration
<DispIdAttribute(1610743819)>
Property QueryEmptyToNull As Boolean

[DispIdAttribute(1610743819)]
bool QueryEmptyToNull {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


records Property (IFCGeneric) | fcSDK Documentation

records Property (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743822)>
ReadOnly Property records As ADODB.Recordset

[DispIdAttribute(1610743822)]
ADODB.Recordset records {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


rel_from_parent Property (IFCGeneric) | fcSDK Documentation

rel_from_parent Property (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743815)>
ReadOnly Property rel_from_parent As String

[DispIdAttribute(1610743815)]
string rel_from_parent {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


rel_to_parent Property (IFCGeneric) | fcSDK Documentation

rel_to_parent Property (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743814)>
ReadOnly Property rel_to_parent As String

[DispIdAttribute(1610743814)]
string rel_to_parent {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


rel_type Property (IFCGeneric) | fcSDK Documentation

rel_type Property (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743816)>
ReadOnly Property rel_type As Short

[DispIdAttribute(1610743816)]
short rel_type {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


rowLimit Property (IFCGeneric) | fcSDK Documentation

rowLimit Property (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743827)>
Property rowLimit As Integer

[DispIdAttribute(1610743827)]
int rowLimit {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


rowsReturned Property (IFCGeneric) | fcSDK Documentation

rowsReturned Property (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743829)>
ReadOnly Property rowsReturned As Integer

[DispIdAttribute(1610743829)]
int rowsReturned {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


SetNullStringsToEmpty Property (IFCGeneric) | fcSDK Documentation

SetNullStringsToEmpty Property (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743823)>
Property SetNullStringsToEmpty As Boolean

[DispIdAttribute(1610743823)]
bool SetNullStringsToEmpty {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


SortOrder Property (IFCGeneric) | fcSDK Documentation

SortOrder Property (IFCGeneric)

Syntax

'Declaration

<DispIdAttribute(1610743834)>
Property SortOrder As String

[DispIdAttribute(1610743834)]
string SortOrder {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCGeneric Interface
IFCGeneric Members


IFCList Interface | fcSDK Documentation

IFCList Interface

Syntax

'Declaration

<ComVisibleAttribute(True)>
<GuidAttribute("6AFFB191-74AD-4d5f-A2B5-2456A3F5AA9F")>
Public Interface IFCList

[ComVisibleAttribute(true)]
[GuidAttribute("6AFFB191-74AD-4d5f-A2B5-2456A3F5AA9F")]
public interface IFCList

Requirements

Namespace: FChoice.Foundation.Clarify.Compatibility

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Foundation.Clarify.Compatibility (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Foundation.Clarify.Compatibility.dll)

Reference

IFCList Members
FChoice.Foundation.Clarify.Compatibility Namespace


IFCList Interface Members | fcSDK Documentation

IFCList Interface Members

The following tables list the members exposed by IFCList.

Public Properties

 | Name | Description
Property | AllowDuplicates |
Property | Count |
Property | ItemType |
Property | Sorted |

Public Methods

 | Name | Description
Method | AppendItem |
Method | AppendSingleItem |
Method | Clear |
Method | Contains |
Method | FindFirstindex |
Method | GetItemByIndex |
Method | ItemByIndex |
Method | Sort |

Reference

IFCList Interface
FChoice.Foundation.Clarify.Compatibility Namespace


AppendItem Method (IFCList) | fcSDK Documentation

AppendItem Method (IFCList)

Syntax

'Declaration

<DispIdAttribute(1610743816)>
Sub AppendItem( _
   ByVal _param1_ As Object, _
   Optional ByVal _param2_ As Object, _
   Optional ByVal _param3_ As Object, _
   Optional ByVal _param4_ As Object, _
   Optional ByVal _param5_ As Object, _
   Optional ByVal _param6_ As Object, _
   Optional ByVal _param7_ As Object, _
   Optional ByVal _param8_ As Object, _
   Optional ByVal _param9_ As Object _
)

[DispIdAttribute(1610743816)]
void AppendItem(
   object _param1_,
   object _param2_,
   object _param3_,
   object _param4_,
   object _param5_,
   object _param6_,
   object _param7_,
   object _param8_,
   object _param9_
)

Parameters

param1

param2

param3

param4

param5

param6

param7

param8

param9

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCList Interface
IFCList Members


AppendSingleItem Method (IFCList) | fcSDK Documentation

AppendSingleItem Method (IFCList)

Syntax

'Declaration

<DispIdAttribute(1610743817)>
Sub AppendSingleItem( _
   ByVal _param1_ As Object _
)

[DispIdAttribute(1610743817)]
void AppendSingleItem(
   object _param1_
)

Parameters

param1

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCList Interface
IFCList Members


Clear Method (IFCList) | fcSDK Documentation

Clear Method (IFCList)

Syntax

'Declaration

<DispIdAttribute(1610743818)>
Sub Clear()

[DispIdAttribute(1610743818)]
void Clear()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCList Interface
IFCList Members


Contains Method (IFCList) | fcSDK Documentation

Contains Method (IFCList)

Syntax

'Declaration

<DispIdAttribute(1610743814)>
Function Contains( _
   ByVal _item_ As Object _
) As Boolean

[DispIdAttribute(1610743814)]
bool Contains(
   object _item_
)

Parameters

item

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCList Interface
IFCList Members


FindFirstindex Method (IFCList) | fcSDK Documentation

FindFirstindex Method (IFCList)

Syntax

'Declaration

<DispIdAttribute(1610743819)>
Function FindFirstindex( _
   ByVal _param1_ As Object _
) As Short

[DispIdAttribute(1610743819)]
short FindFirstindex(
   object _param1_
)

Parameters

param1

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCList Interface
IFCList Members


GetItemByIndex Method (IFCList) | fcSDK Documentation

GetItemByIndex Method (IFCList)

Syntax

'Declaration

<DispIdAttribute(1610743820)>
Sub GetItemByIndex( _
   ByVal _index_ As Short, _
   ByRef _item_ As Object _
)

[DispIdAttribute(1610743820)]
void GetItemByIndex(
   short _index_,
   ref object _item_
)

Parameters

index

item

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCList Interface
IFCList Members


ItemByIndex Method (IFCList) | fcSDK Documentation

ItemByIndex Method (IFCList)

Syntax

'Declaration

<DispIdAttribute(1610743815)>
Function ItemByIndex( _
   ByVal _index_ As Short _
) As Object

[DispIdAttribute(1610743815)]
object ItemByIndex(
   short _index_
)

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCList Interface
IFCList Members


Sort Method (IFCList) | fcSDK Documentation

Sort Method (IFCList)

Syntax

'Declaration

<DispIdAttribute(1610743821)>
Sub Sort()

[DispIdAttribute(1610743821)]
void Sort()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCList Interface
IFCList Members


AllowDuplicates Property (IFCList) | fcSDK Documentation

AllowDuplicates Property (IFCList)

Syntax

'Declaration

<DispIdAttribute(1610743808)>
Property AllowDuplicates As Boolean

[DispIdAttribute(1610743808)]
bool AllowDuplicates {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCList Interface
IFCList Members


Count Property (IFCList) | fcSDK Documentation

Count Property (IFCList)

Syntax

'Declaration

<DispIdAttribute(1610743813)>
ReadOnly Property Count As Short

[DispIdAttribute(1610743813)]
short Count {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCList Interface
IFCList Members


ItemType Property (IFCList) | fcSDK Documentation

ItemType Property (IFCList)

Syntax

'Declaration

<DispIdAttribute(1610743810)>
Property ItemType As String

[DispIdAttribute(1610743810)]
string ItemType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCList Interface
IFCList Members


Sorted Property (IFCList) | fcSDK Documentation

Sorted Property (IFCList)

Syntax

'Declaration

<DispIdAttribute(1610743812)>
ReadOnly Property Sorted As Boolean

[DispIdAttribute(1610743812)]
bool Sorted {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCList Interface
IFCList Members


IFCSession Interface | fcSDK Documentation

IFCSession Interface

Syntax

'Declaration

<DefaultMemberAttribute("Item")>
<GuidAttribute("772CB7F1-F6D6-4783-9390-979DE87386C9")>
<ComVisibleAttribute(True)>
Public Interface IFCSession

[DefaultMemberAttribute("Item")]
[GuidAttribute("772CB7F1-F6D6-4783-9390-979DE87386C9")]
[ComVisibleAttribute(true)]
public interface IFCSession

Requirements

Namespace: FChoice.Foundation.Clarify.Compatibility

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Foundation.Clarify.Compatibility (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Foundation.Clarify.Compatibility.dll)

Reference

IFCSession Members
FChoice.Foundation.Clarify.Compatibility Namespace


IFCSession Interface Members | fcSDK Documentation

IFCSession Interface Members

The following tables list the members exposed by IFCSession.

Public Properties

 | Name | Description
Property | ad_auto |
Property | ad_list |
Property | BulkCollection |
Property | ConvertTimeZone |
Property | cur_res |
Property | CurrentCulture |
Property | Distinct |
Property | ErrorMessage |
Property | ErrorNumber |
Property | ErrorSource |
Property | hist_change |
Property | IncludeRelations |
Property | IsInTransaction |
Property | IsLoggedIn |
Property | Item |
Property | LocalTimeZone |
Property | LocalTimeZoneOffset |
Property | LoginTime |
Property | NoRes |
Property | num_ad |
Property | PasswordRequired |
Property | QueryEmptyToNull |
Property | RESEnabled |
Property | rowLimit |
Property | SessionID |
Property | SetNullStringsToEmpty |
Property | ThrowErrors |
Property | TruncateStringFields |
Property | UpdateTime |

Public Methods

 | Name | Description
Method | accept_object |
Method | active_connection |
Method | AddAttachment |
Method | AppendFilter |
Method | assign_object |
Method | auto_dest |
Method | AutoDest |
Method | build_hist |
Method | build_lists |
Method | BuildUserVersionProc |
Method | change_obj_status |
Method | ChangePassword |
Method | ChangeResGroup |
Method | check_cl_trans |
Method | CloseAllGenerics |
Method | CloseGenerics |
Method | CloseSession |
Method | CommitTransaction |
Method | ConvertDate |
Method | ConvertFromLocalToServerTZ |
Method | ConvertFromServerToLocalTZ |
Method | create_act_entry | Overloaded.
Method | create_time_bomb | Overloaded.
Method | createBulk |
Method | CreateGeneric |
Method | CreateSqlExec |
Method | dispatch_object |
Method | error_handler | Overloaded.
Method | ExecuteSQL |
Method | ExecuteSQLNoReturn |
Method | format_time |
Method | forward_object |
Method | FreeConnection |
Method | get_item |
Method | get_next_sn |
Method | GetColor |
Method | GetConfigItem |
Method | GetCurrentDate |
Method | GetCurrentServerDate |
Method | GetItem |
Method | GetNextNumScheme |
Method | GetNextSubcaseID |
Method | GetNumGenerics |
Method | GetObjid |
Method | GetUserVersion |
Method | Init_Object |
Method | IsUnicode |
Method | ItemCount |
Method | LoadColors |
Method | LoadUserVersions |
Method | Log |
Method | LogEx |
Method | Login |
Method | LoginFromFCApp |
Method | Logout |
Method | move_object |
Method | NewEnum |
Method | RefreshContext |
Method | reject_object |
Method | RemoveAllGenericsInABulk |
Method | RollbackTransaction |
Method | SaveSession |
Method | set_item |
Method | SetNullStringToEmpty |
Method | SetPassword |
Method | SimpleQuery |
Method | single_quotify |
Method | sprintf |
Method | StartTransaction |
Method | TraverseFromParent |
Method | turn_off |
Method | use_list |
Method | yank_object |

Reference

IFCSession Interface
FChoice.Foundation.Clarify.Compatibility Namespace


accept_object Method (IFCSession) | fcSDK Documentation

accept_object Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743895)>
Function accept_object( _
   ByVal _objId_ As String, _
   ByRef _acceptDate_ As String, _
   ByRef _wipBin_ As String, _
   ByRef _localUserName_ As String, _
   ByVal _generateTimebombs_ As Boolean, _
   ByVal _objectType_ As String _
) As Short

[DispIdAttribute(1610743895)]
short accept_object(
   string _objId_,
   out string _acceptDate_,
   out string _wipBin_,
   out string _localUserName_,
   bool _generateTimebombs_,
   string _objectType_
)

Parameters

objId

acceptDate

wipBin

localUserName

generateTimebombs

objectType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


active_connection Method (IFCSession) | fcSDK Documentation

active_connection Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743869)>
Function active_connection() As ADODB.Connection

[DispIdAttribute(1610743869)]
ADODB.Connection active_connection()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


AddAttachment Method (IFCSession) | fcSDK Documentation

AddAttachment Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743898)>
Function AddAttachment( _
   ByVal _attachmentName_ As String, _
   ByVal _filePath_ As String, _
   ByVal _objectType_ As String, _
   ByVal _idNumber_ As String, _
   Optional ByVal _objectObjId_ As Object, _
   Optional ByVal _attachmentType_ As Object _
) As Short

[DispIdAttribute(1610743898)]
short AddAttachment(
   string _attachmentName_,
   string _filePath_,
   string _objectType_,
   string _idNumber_,
   object _objectObjId_,
   object _attachmentType_
)

Parameters

attachmentName

filePath

objectType

idNumber

objectObjId

attachmentType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


AppendFilter Method (IFCSession) | fcSDK Documentation

AppendFilter Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743896)>
Sub AppendFilter( _
   ByVal _fcGeneric_ As Object, _
   ByVal _fieldName_ As String, _
   ByVal _filterOperator_ As String, _
   ByVal _filterValue_ As Object, _
   Optional ByVal _isAndOr_ As Object _
)

[DispIdAttribute(1610743896)]
void AppendFilter(
   object _fcGeneric_,
   string _fieldName_,
   string _filterOperator_,
   object _filterValue_,
   object _isAndOr_
)

Parameters

fcGeneric

fieldName

filterOperator

filterValue

isAndOr

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


assign_object Method (IFCSession) | fcSDK Documentation

assign_object Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743897)>
Function assign_object( _
   ByVal _objId_ As String, _
   ByRef _newUser_ As String, _
   ByVal _wipBin_ As String, _
   ByRef _assignDate_ As String, _
   ByRef _localUserName_ As String, _
   ByVal _generateTimeBombs_ As Boolean, _
   ByVal _objectType_ As String _
) As Short

[DispIdAttribute(1610743897)]
short assign_object(
   string _objId_,
   out string _newUser_,
   string _wipBin_,
   out string _assignDate_,
   out string _localUserName_,
   bool _generateTimeBombs_,
   string _objectType_
)

Parameters

objId

newUser

wipBin

assignDate

localUserName

generateTimeBombs

objectType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


auto_dest Method (IFCSession) | fcSDK Documentation

auto_dest Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743906)>
Function auto_dest( _
   ByVal _objId_ As String, _
   ByVal _operation_ As String, _
   ByVal _idNumber_ As String _
) As Short

[DispIdAttribute(1610743906)]
short auto_dest(
   string _objId_,
   string _operation_,
   string _idNumber_
)

Parameters

objId

operation

idNumber

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


AutoDest Method (IFCSession) | fcSDK Documentation

AutoDest Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743907)>
Function AutoDest( _
   ByVal _objId_ As String, _
   ByVal _operation_ As String, _
   ByVal _idNumber_ As String _
) As Short

[DispIdAttribute(1610743907)]
short AutoDest(
   string _objId_,
   string _operation_,
   string _idNumber_
)

Parameters

objId

operation

idNumber

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


build_hist Method (IFCSession) | fcSDK Documentation

build_hist Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743890)>
Function build_hist( _
   ByVal _objectHistory_ As String, _
   ByVal _appendHistory_ As String _
) As String

[DispIdAttribute(1610743890)]
string build_hist(
   string _objectHistory_,
   string _appendHistory_
)

Parameters

objectHistory

appendHistory

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


build_lists Method (IFCSession) | fcSDK Documentation

build_lists Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743883)>
Sub build_lists( _
   ByVal _int_fld1_ As String, _
   ByVal _int_val1_ As Integer, _
   ByVal _int_fld2_ As String, _
   ByVal _int_val2_ As Integer, _
   ByVal _str_fld1_ As String, _
   ByVal _str_val1_ As String, _
   ByVal _str_fld2_ As String, _
   ByVal _str_val2_ As String, _
   ByVal _date_fld1_ As String, _
   ByVal _date_val1_ As String, _
   ByRef _fld_list_ As IFCList, _
   ByRef _type_list_ As IFCList, _
   ByRef _val_list_ As IFCList, _
   ByRef _list_used_ As Short _
)

[DispIdAttribute(1610743883)]
void build_lists(
   string _int_fld1_,
   int _int_val1_,
   string _int_fld2_,
   int _int_val2_,
   string _str_fld1_,
   string _str_val1_,
   string _str_fld2_,
   string _str_val2_,
   string _date_fld1_,
   string _date_val1_,
   ref IFCList _fld_list_,
   ref IFCList _type_list_,
   ref IFCList _val_list_,
   ref short _list_used_
)

Parameters

int_fld1

int_val1

int_fld2

int_val2

str_fld1

str_val1

str_fld2

str_val2

date_fld1

date_val1

fld_list

type_list

val_list

list_used

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


BuildUserVersionProc Method (IFCSession) | fcSDK Documentation

BuildUserVersionProc Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743918)>
Function BuildUserVersionProc() As String

[DispIdAttribute(1610743918)]
string BuildUserVersionProc()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


change_obj_status Method (IFCSession) | fcSDK Documentation

change_obj_status Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743892)>
Function change_obj_status( _
   ByVal _objId_ As String, _
   ByRef _newStatus_ As String, _
   ByRef _changeDate_ As String, _
   ByVal _notes_ As String, _
   ByRef _localUserName_ As String, _
   ByVal _generateTimeBombs_ As Boolean, _
   ByVal _objectType_ As String _
) As Short

[DispIdAttribute(1610743892)]
short change_obj_status(
   string _objId_,
   out string _newStatus_,
   out string _changeDate_,
   string _notes_,
   out string _localUserName_,
   bool _generateTimeBombs_,
   string _objectType_
)

Parameters

objId

newStatus

changeDate

notes

localUserName

generateTimeBombs

objectType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


ChangePassword Method (IFCSession) | fcSDK Documentation

ChangePassword Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743876)>
Sub ChangePassword( _
   ByVal _password_ As String _
)

[DispIdAttribute(1610743876)]
void ChangePassword(
   string _password_
)

Parameters

password

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


ChangeResGroup Method (IFCSession) | fcSDK Documentation

ChangeResGroup Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743859)>
Sub ChangeResGroup( _
   ByVal _newGroup_ As String, _
   Optional ByVal _saveToDB_ As Object _
)

[DispIdAttribute(1610743859)]
void ChangeResGroup(
   string _newGroup_,
   object _saveToDB_
)

Parameters

newGroup

saveToDB

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


check_cl_trans Method (IFCSession) | fcSDK Documentation

check_cl_trans Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743904)>
Function check_cl_trans( _
   ByVal _oldCondition_ As String, _
   ByVal _newCondition_ As String, _
   ByVal _reqType_ As String, _
   ByVal _userName_ As String _
) As Short

[DispIdAttribute(1610743904)]
short check_cl_trans(
   string _oldCondition_,
   string _newCondition_,
   string _reqType_,
   string _userName_
)

Parameters

oldCondition

newCondition

reqType

userName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


CloseAllGenerics Method (IFCSession) | fcSDK Documentation

CloseAllGenerics Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743867)>
Sub CloseAllGenerics()

[DispIdAttribute(1610743867)]
void CloseAllGenerics()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


CloseGenerics Method (IFCSession) | fcSDK Documentation

CloseGenerics Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743887)>
Sub CloseGenerics( _
   ByVal _NumGenerics_ As Short, _
   ByVal _Generic1_ As Object, _
   Optional ByVal _Generic2_ As Object, _
   Optional ByVal _Generic3_ As Object, _
   Optional ByVal _Generic4_ As Object, _
   Optional ByVal _Generic5_ As Object, _
   Optional ByVal _Generic6_ As Object, _
   Optional ByVal _Generic7_ As Object, _
   Optional ByVal _Generic8_ As Object, _
   Optional ByVal _Generic9_ As Object, _
   Optional ByVal _Generic10_ As Object _
)

[DispIdAttribute(1610743887)]
void CloseGenerics(
   short _NumGenerics_,
   object _Generic1_,
   object _Generic2_,
   object _Generic3_,
   object _Generic4_,
   object _Generic5_,
   object _Generic6_,
   object _Generic7_,
   object _Generic8_,
   object _Generic9_,
   object _Generic10_
)

Parameters

NumGenerics

Generic1

Generic2

Generic3

Generic4

Generic5

Generic6

Generic7

Generic8

Generic9

Generic10

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


CloseSession Method (IFCSession) | fcSDK Documentation

CloseSession Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743870)>
Sub CloseSession()

[DispIdAttribute(1610743870)]
void CloseSession()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


CommitTransaction Method (IFCSession) | fcSDK Documentation

CommitTransaction Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610747765)>
Sub CommitTransaction()

[DispIdAttribute(1610747765)]
void CommitTransaction()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


ConvertDate Method (IFCSession) | fcSDK Documentation

ConvertDate Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743871)>
Function ConvertDate( _
   ByVal _convertDate_ As Date, _
   ByVal _fromTimeZone_ As String, _
   ByVal _toTimeZone_ As String _
) As Date

[DispIdAttribute(1610743871)]
DateTime ConvertDate(
   DateTime _convertDate_,
   string _fromTimeZone_,
   string _toTimeZone_
)

Parameters

convertDate

fromTimeZone

toTimeZone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


ConvertFromLocalToServerTZ Method (IFCSession) | fcSDK Documentation

ConvertFromLocalToServerTZ Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743873)>
Function ConvertFromLocalToServerTZ( _
   ByVal _convertDate_ As Date _
) As Date

[DispIdAttribute(1610743873)]
DateTime ConvertFromLocalToServerTZ(
   DateTime _convertDate_
)

Parameters

convertDate

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


ConvertFromServerToLocalTZ Method (IFCSession) | fcSDK Documentation

ConvertFromServerToLocalTZ Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743872)>
Function ConvertFromServerToLocalTZ( _
   ByVal _convertDate_ As Date _
) As Date

[DispIdAttribute(1610743872)]
DateTime ConvertFromServerToLocalTZ(
   DateTime _convertDate_
)

Parameters

convertDate

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


create_act_entry Method (IFCSession) | fcSDK Documentation

create_act_entry Method (IFCSession)

Overload List

Overload | Description
create_act_entry(IFCGeneric,String,Int32,Int32,String,IFCGeneric,String,String,Object) |
create_act_entry(IFCGeneric,String,Int32,Int32,String,IFCGeneric,String,String,String,Object) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


create_act_entry(IFCGeneric,String,Int32,Int32,String,IFCGeneric,String,String,Object) Method | fcSDK Documentation

create_act_entry(IFCGeneric,String,Int32,Int32,String,IFCGeneric,String,String,Object) Method

Syntax

'Declaration

<DispIdAttribute(1610743885)>
Overloads Sub create_act_entry( _
   ByVal _mainRecord_ As IFCGeneric, _
   ByVal _actName_ As String, _
   ByVal _userId_ As Integer, _
   ByVal _actCode_ As Integer, _
   ByVal _currentDateTime_ As String, _
   ByVal _activityRecord_ As IFCGeneric, _
   ByVal _additionalInfo_ As String, _
   ByVal _objectType_ As String, _
   Optional ByVal _linkRecord_ As Object _
)

[DispIdAttribute(1610743885)]
void create_act_entry(
   IFCGeneric _mainRecord_,
   string _actName_,
   int _userId_,
   int _actCode_,
   string _currentDateTime_,
   IFCGeneric _activityRecord_,
   string _additionalInfo_,
   string _objectType_,
   object _linkRecord_
)

Parameters

mainRecord

actName

userId

actCode

currentDateTime

activityRecord

additionalInfo

objectType

linkRecord

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members
Overload List


create_act_entry(IFCGeneric,String,Int32,Int32,String,IFCGeneric,String,String,String,Object) Method | fcSDK Documentation

create_act_entry(IFCGeneric,String,Int32,Int32,String,IFCGeneric,String,String,String,Object) Method

Syntax

'Declaration

<ComVisibleAttribute(False)>
Overloads Sub create_act_entry( _
   ByVal _mainRecord_ As IFCGeneric, _
   ByVal _actName_ As String, _
   ByVal _userId_ As Integer, _
   ByVal _actCode_ As Integer, _
   ByVal _currentDateTime_ As String, _
   ByVal _activityRecord_ As IFCGeneric, _
   ByVal _additionalInfo_ As String, _
   ByVal _objectType_ As String, _
   ByVal _impersonatorUserName_ As String, _
   Optional ByVal _linkRecord_ As Object _
)

[ComVisibleAttribute(false)]
void create_act_entry(
   IFCGeneric _mainRecord_,
   string _actName_,
   int _userId_,
   int _actCode_,
   string _currentDateTime_,
   IFCGeneric _activityRecord_,
   string _additionalInfo_,
   string _objectType_,
   string _impersonatorUserName_,
   object _linkRecord_
)

Parameters

mainRecord

actName

userId

actCode

currentDateTime

activityRecord

additionalInfo

objectType

impersonatorUserName

linkRecord

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members
Overload List


create_time_bomb Method (IFCSession) | fcSDK Documentation

create_time_bomb Method (IFCSession)

Overload List

Overload | Description
create_time_bomb(IFCGeneric,IFCGeneric,String,IFCGeneric,String,Int32,String,String,Object) |
create_time_bomb(Int32,IFCGeneric,IFCGeneric,String,IFCGeneric,Int32,String,String,Object) |
create_time_bomb(Int32,IFCGeneric,IFCGeneric,String,IFCGeneric,Int32,String,String,String,Object) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface IFCSession Members


create_time_bomb(IFCGeneric,IFCGeneric,String,IFCGeneric,String,Int32,String,String,Object) Method | fcSDK Documentation

create_time_bomb(IFCGeneric,IFCGeneric,String,IFCGeneric,String,Int32,String,String,Object) Method

Syntax

'Declaration

<DispIdAttribute(1610743886)>
Overloads Sub create_time_bomb( _
   ByRef _timeBombRecord_ As IFCGeneric, _
   ByVal _mainRecord_ As IFCGeneric, _
   ByVal _t_save_ As String, _
   ByVal _activityRecord_ As IFCGeneric, _
   ByVal _the_type_ As String, _
   ByVal _emp_rec_ As Integer, _
   ByVal _t_date_ As String, _
   ByVal _focus_obj_ As String, _
   Optional ByVal _new_generic_ As Object _
)

[DispIdAttribute(1610743886)]
void create_time_bomb(
   ref IFCGeneric _timeBombRecord_,
   IFCGeneric _mainRecord_,
   string _t_save_,
   IFCGeneric _activityRecord_,
   string _the_type_,
   int _emp_rec_,
   string _t_date_,
   string _focus_obj_,
   object _new_generic_
)

Parameters

timeBombRecord

mainRecord

t_save

activityRecord

the_type

emp_rec

t_date

focus_obj

new_generic

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members
Overload List


create_time_bomb(Int32,IFCGeneric,IFCGeneric,String,IFCGeneric,Int32,String,String,Object) Method | fcSDK Documentation

create_time_bomb(Int32,IFCGeneric,IFCGeneric,String,IFCGeneric,Int32,String,String,Object) Method

Syntax

'Declaration

<ComVisibleAttribute(False)>
Overloads Sub create_time_bomb( _
   ByVal _timeBombFlag_ As Integer, _
   ByRef _timeBombRecord_ As IFCGeneric, _
   ByVal _mainRecord_ As IFCGeneric, _
   ByVal _t_save_ As String, _
   ByVal _activityRecord_ As IFCGeneric, _
   ByVal _emp_rec_ As Integer, _
   ByVal _t_date_ As String, _
   ByVal _focus_obj_ As String, _
   Optional ByVal _new_generic_ As Object _
)

[ComVisibleAttribute(false)]
void create_time_bomb(
   int _timeBombFlag_,
   ref IFCGeneric _timeBombRecord_,
   IFCGeneric _mainRecord_,
   string _t_save_,
   IFCGeneric _activityRecord_,
   int _emp_rec_,
   string _t_date_,
   string _focus_obj_,
   object _new_generic_
)

Parameters

timeBombFlag

timeBombRecord

mainRecord

t_save

activityRecord

emp_rec

t_date

focus_obj

new_generic

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members
Overload List


create_time_bomb(Int32,IFCGeneric,IFCGeneric,String,IFCGeneric,Int32,String,String,String,Object) Method | fcSDK Documentation

create_time_bomb(Int32,IFCGeneric,IFCGeneric,String,IFCGeneric,Int32,String,String,String,Object) Method

Syntax

'Declaration

<ComVisibleAttribute(False)>
Overloads Sub create_time_bomb( _
   ByVal _timeBombFlag_ As Integer, _
   ByRef _timeBombRecord_ As IFCGeneric, _
   ByVal _mainRecord_ As IFCGeneric, _
   ByVal _t_save_ As String, _
   ByVal _activityRecord_ As IFCGeneric, _
   ByVal _emp_rec_ As Integer, _
   ByVal _t_date_ As String, _
   ByVal _focus_obj_ As String, _
   ByVal _escalate_time_ As String, _
   Optional ByVal _new_generic_ As Object _
)

[ComVisibleAttribute(false)]
void create_time_bomb(
   int _timeBombFlag_,
   ref IFCGeneric _timeBombRecord_,
   IFCGeneric _mainRecord_,
   string _t_save_,
   IFCGeneric _activityRecord_,
   int _emp_rec_,
   string _t_date_,
   string _focus_obj_,
   string _escalate_time_,
   object _new_generic_
)

Parameters

timeBombFlag

timeBombRecord

mainRecord

t_save

activityRecord

emp_rec

t_date

focus_obj

escalate_time

new_generic

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members
Overload List


createBulk Method (IFCSession) | fcSDK Documentation

createBulk Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743874)>
Function createBulk( _
   ByVal _bulkName_ As String _
) As IFCBulk

[DispIdAttribute(1610743874)]
IFCBulk createBulk(
   string _bulkName_
)

Parameters

bulkName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


CreateGeneric Method (IFCSession) | fcSDK Documentation

CreateGeneric Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743866)>
Function CreateGeneric( _
   Optional ByVal _dbObjectName_ As Object _
) As IFCGeneric

[DispIdAttribute(1610743866)]
IFCGeneric CreateGeneric(
   object _dbObjectName_
)

Parameters

dbObjectName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


CreateSqlExec Method (IFCSession) | fcSDK Documentation

CreateSqlExec Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743875)>
Function CreateSqlExec() As IFCSqlExec

[DispIdAttribute(1610743875)]
IFCSqlExec CreateSqlExec()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


dispatch_object Method (IFCSession) | fcSDK Documentation

dispatch_object Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743899)>
Function dispatch_object( _
   ByVal _objId_ As String, _
   ByVal _queueName_ As String, _
   ByRef _dispatchDate_ As String, _
   ByRef _localUserName_ As String, _
   ByVal _generateTimeBombs_ As Boolean, _
   ByVal _objectType_ As String _
) As Short

[DispIdAttribute(1610743899)]
short dispatch_object(
   string _objId_,
   string _queueName_,
   out string _dispatchDate_,
   out string _localUserName_,
   bool _generateTimeBombs_,
   string _objectType_
)

Parameters

objId

queueName

dispatchDate

localUserName

generateTimeBombs

objectType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


error_handler Method (IFCSession) | fcSDK Documentation

error_handler Method (IFCSession)

Overload List

Overload | Description
error_handler(Int16,String,String,String) |
error_handler(Int32,String,String,String,Exception) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


error_handler(Int16,String,String,String) Method | fcSDK Documentation

error_handler(Int16,String,String,String) Method

Syntax

'Declaration

<DispIdAttribute(1610743882)>
Overloads Function error_handler( _
   ByVal _errorNum_ As Short, _
   ByVal _objId_ As String, _
   ByVal _source_ As String, _
   ByVal _message_ As String _
) As Short

[DispIdAttribute(1610743882)]
short error_handler(
   short _errorNum_,
   string _objId_,
   string _source_,
   string _message_
)

Parameters

errorNum

objId

source

message

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members
Overload List


error_handler(Int32,String,String,String,Exception) Method | fcSDK Documentation

error_handler(Int32,String,String,String,Exception) Method

Syntax

'Declaration

<ComVisibleAttribute(False)>
Overloads Function error_handler( _
   ByVal _errorNum_ As Integer, _
   ByVal _objId_ As String, _
   ByVal _source_ As String, _
   ByVal _message_ As String, _
   ByVal _ex_ As Exception _
) As Short

[ComVisibleAttribute(false)]
short error_handler(
   int _errorNum_,
   string _objId_,
   string _source_,
   string _message_,
   Exception _ex_
)

Parameters

errorNum

objId

source

message

ex

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members
Overload List


ExecuteSQL Method (IFCSession) | fcSDK Documentation

ExecuteSQL Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743864)>
Sub ExecuteSQL( _
   ByVal _sql_ As String, _
   ByRef _records_ As ADODB.Recordset _
)

[DispIdAttribute(1610743864)]
void ExecuteSQL(
   string _sql_,
   out ADODB.Recordset _records_
)

Parameters

sql

records

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


ExecuteSQLNoReturn Method (IFCSession) | fcSDK Documentation

ExecuteSQLNoReturn Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743915)>
Sub ExecuteSQLNoReturn( _
   ByVal _sql_ As String _
)

[DispIdAttribute(1610743915)]
void ExecuteSQLNoReturn(
   string _sql_
)

Parameters

sql

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


format_time Method (IFCSession) | fcSDK Documentation

format_time Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743891)>
Function format_time( _
   ByVal _totalTime_ As Integer _
) As String

[DispIdAttribute(1610743891)]
string format_time(
   int _totalTime_
)

Parameters

totalTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


forward_object Method (IFCSession) | fcSDK Documentation

forward_object Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743900)>
Function forward_object( _
   ByVal _objId_ As String, _
   ByVal _newQueue_ As String, _
   ByRef _forwardDate_ As String, _
   ByVal _notes_ As String, _
   ByRef _localuserName_ As String, _
   ByVal _genearateTimeBombs_ As Boolean, _
   ByVal _objectType_ As String _
) As Short

[DispIdAttribute(1610743900)]
short forward_object(
   string _objId_,
   string _newQueue_,
   out string _forwardDate_,
   string _notes_,
   out string _localuserName_,
   bool _genearateTimeBombs_,
   string _objectType_
)

Parameters

objId

newQueue

forwardDate

notes

localuserName

genearateTimeBombs

objectType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


FreeConnection Method (IFCSession) | fcSDK Documentation

FreeConnection Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743916)>
Sub FreeConnection()

[DispIdAttribute(1610743916)]
void FreeConnection()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


get_item Method (IFCSession) | fcSDK Documentation

get_item Method (IFCSession)

Syntax

'Declaration
Function get_item( _
   ByVal _key_ As String _
) As Object

object get_item(
   string _key_
)

Parameters

key

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


get_next_sn Method (IFCSession) | fcSDK Documentation

get_next_sn Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743894)>
Function get_next_sn( _
   ByVal _the_ind_ As Short _
) As Object

[DispIdAttribute(1610743894)]
object get_next_sn(
   short _the_ind_
)

Parameters

the_ind

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


GetColor Method (IFCSession) | fcSDK Documentation

GetColor Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743911)>
Function GetColor( _
   ByVal _purpose_ As String _
) As String

[DispIdAttribute(1610743911)]
string GetColor(
   string _purpose_
)

Parameters

purpose

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


GetConfigItem Method (IFCSession) | fcSDK Documentation

GetConfigItem Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743863)>
Function GetConfigItem( _
   ByVal _configItem_ As String, _
   ByVal _fieldName_ As String, _
   Optional ByVal _loginName_ As Object _
) As Object

[DispIdAttribute(1610743863)]
object GetConfigItem(
   string _configItem_,
   string _fieldName_,
   object _loginName_
)

Parameters

configItem

fieldName

loginName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


GetCurrentDate Method (IFCSession) | fcSDK Documentation

GetCurrentDate Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743861)>
Function GetCurrentDate() As Date

[DispIdAttribute(1610743861)]
DateTime GetCurrentDate()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


GetCurrentServerDate Method (IFCSession) | fcSDK Documentation

GetCurrentServerDate Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743862)>
Function GetCurrentServerDate() As Date

[DispIdAttribute(1610743862)]
DateTime GetCurrentServerDate()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


GetItem Method (IFCSession) | fcSDK Documentation

GetItem Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743888)>
Function GetItem( _
   ByVal _path_ As String, _
   ByVal _startItem_ As Short, _
   ByVal _stopItem_ As Short, _
   ByVal _separator_ As String _
) As String

[DispIdAttribute(1610743888)]
string GetItem(
   string _path_,
   short _startItem_,
   short _stopItem_,
   string _separator_
)

Parameters

path

startItem

stopItem

separator

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


GetNextNumScheme Method (IFCSession) | fcSDK Documentation

GetNextNumScheme Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743878)>
Function GetNextNumScheme( _
   ByVal _numSchemaName_ As String _
) As String

[DispIdAttribute(1610743878)]
string GetNextNumScheme(
   string _numSchemaName_
)

Parameters

numSchemaName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


GetNextSubcaseID Method (IFCSession) | fcSDK Documentation

GetNextSubcaseID Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743905)>
Function GetNextSubcaseID( _
   ByVal _caseId_ As String, _
   ByVal _caseConditionId_ As Integer _
) As String

[DispIdAttribute(1610743905)]
string GetNextSubcaseID(
   string _caseId_,
   int _caseConditionId_
)

Parameters

caseId

caseConditionId

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


GetNumGenerics Method (IFCSession) | fcSDK Documentation

GetNumGenerics Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743909)>
Function GetNumGenerics() As Integer

[DispIdAttribute(1610743909)]
int GetNumGenerics()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


GetObjid Method (IFCSession) | fcSDK Documentation

GetObjid Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743877)>
Function GetObjid( _
   ByVal _tableName_ As String _
) As Integer

[DispIdAttribute(1610743877)]
int GetObjid(
   string _tableName_
)

Parameters

tableName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


GetUserVersion Method (IFCSession) | fcSDK Documentation

GetUserVersion Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743919)>
Function GetUserVersion( _
   ByVal _formName_ As String _
) As String

[DispIdAttribute(1610743919)]
string GetUserVersion(
   string _formName_
)

Parameters

formName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


Init_Object Method (IFCSession) | fcSDK Documentation

Init_Object Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743879)>
Function Init_Object( _
   ByRef _generic_ As IFCGeneric, _
   ByVal _objectType_ As String, _
   ByVal _dataFields_ As String, _
   ByVal _bulkName_ As String _
) As IFCGeneric

[DispIdAttribute(1610743879)]
IFCGeneric Init_Object(
   out IFCGeneric _generic_,
   string _objectType_,
   string _dataFields_,
   string _bulkName_
)

Parameters

generic

objectType

dataFields

bulkName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


IsUnicode Method (IFCSession) | fcSDK Documentation

IsUnicode Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743921)>
Function IsUnicode( _
   ByVal _inputString_ As String _
) As Object

[DispIdAttribute(1610743921)]
object IsUnicode(
   string _inputString_
)

Parameters

inputString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


ItemCount Method (IFCSession) | fcSDK Documentation

ItemCount Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743889)>
Function ItemCount( _
   ByVal _path_ As String, _
   ByVal _separator_ As String _
) As Short

[DispIdAttribute(1610743889)]
short ItemCount(
   string _path_,
   string _separator_
)

Parameters

path

separator

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


LoadColors Method (IFCSession) | fcSDK Documentation

LoadColors Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743910)>
Sub LoadColors( _
   ByVal _userName_ As String _
)

[DispIdAttribute(1610743910)]
void LoadColors(
   string _userName_
)

Parameters

userName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


LoadUserVersions Method (IFCSession) | fcSDK Documentation

LoadUserVersions Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743917)>
Sub LoadUserVersions( _
   Optional ByVal _userName_ As Object _
)

[DispIdAttribute(1610743917)]
void LoadUserVersions(
   object _userName_
)

Parameters

userName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


Log Method (IFCSession) | fcSDK Documentation

Log Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743920)>
Sub Log( _
   ByVal _messageType_ As String, _
   ByVal _message_ As String _
)

[DispIdAttribute(1610743920)]
void Log(
   string _messageType_,
   string _message_
)

Parameters

messageType

message

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


LogEx Method (IFCSession) | fcSDK Documentation

LogEx Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610747763)>
Sub LogEx( _
   ByVal _logLevel_ As String, _
   ByVal _logMessage_ As String _
)

[DispIdAttribute(1610747763)]
void LogEx(
   string _logLevel_,
   string _logMessage_
)

Parameters

logLevel

logMessage

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


Login Method (IFCSession) | fcSDK Documentation

Login Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743858)>
Sub Login( _
   ByVal _username_ As String, _
   ByVal _password_ As String, _
   ByVal _loginType_ As String _
)

[DispIdAttribute(1610743858)]
void Login(
   string _username_,
   string _password_,
   string _loginType_
)

Parameters

username

password

loginType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


LoginFromFCApp Method (IFCSession) | fcSDK Documentation

LoginFromFCApp Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743857)>
Sub LoginFromFCApp()

[DispIdAttribute(1610743857)]
void LoginFromFCApp()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


Logout Method (IFCSession) | fcSDK Documentation

Logout Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743860)>
Sub Logout()

[DispIdAttribute(1610743860)]
void Logout()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


move_object Method (IFCSession) | fcSDK Documentation

move_object Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743901)>
Function move_object( _
   ByVal _objId_ As String, _
   ByVal _newWipBin_ As String, _
   ByVal _objectType_ As String _
) As Short

[DispIdAttribute(1610743901)]
short move_object(
   string _objId_,
   string _newWipBin_,
   string _objectType_
)

Parameters

objId

newWipBin

objectType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


NewEnum Method (IFCSession) | fcSDK Documentation

NewEnum Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(-4)>
Function NewEnum() As IEnumerator

[DispIdAttribute(-4)]
IEnumerator NewEnum()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


RefreshContext Method (IFCSession) | fcSDK Documentation

RefreshContext Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743865)>
Sub RefreshContext()

[DispIdAttribute(1610743865)]
void RefreshContext()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


reject_object Method (IFCSession) | fcSDK Documentation

reject_object Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743902)>
Function reject_object( _
   ByVal _objId_ As String, _
   ByRef _rejectDate_ As String, _
   ByVal _wipBin_ As String, _
   ByVal _notes_ As String, _
   ByRef _localuserName_ As String, _
   ByVal _genearateTimeBombs_ As Boolean, _
   ByVal _objectType_ As String _
) As Short

[DispIdAttribute(1610743902)]
short reject_object(
   string _objId_,
   out string _rejectDate_,
   string _wipBin_,
   string _notes_,
   out string _localuserName_,
   bool _genearateTimeBombs_,
   string _objectType_
)

Parameters

objId

rejectDate

wipBin

notes

localuserName

genearateTimeBombs

objectType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


RemoveAllGenericsInABulk Method (IFCSession) | fcSDK Documentation

RemoveAllGenericsInABulk Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743913)>
Sub RemoveAllGenericsInABulk( _
   ByVal _bulkName_ As String _
)

[DispIdAttribute(1610743913)]
void RemoveAllGenericsInABulk(
   string _bulkName_
)

Parameters

bulkName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


RollbackTransaction Method (IFCSession) | fcSDK Documentation

RollbackTransaction Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610747766)>
Sub RollbackTransaction()

[DispIdAttribute(1610747766)]
void RollbackTransaction()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


SaveSession Method (IFCSession) | fcSDK Documentation

SaveSession Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610747762)>
Sub SaveSession()

[DispIdAttribute(1610747762)]
void SaveSession()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


set_item Method (IFCSession) | fcSDK Documentation

set_item Method (IFCSession)

Syntax

'Declaration
Sub set_item( _
   ByVal _key_ As String, _
   ByVal _newValue_ As Object _
)

void set_item(
   string _key_,
   object _newValue_
)

Parameters

key

newValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


SetNullStringToEmpty Method (IFCSession) | fcSDK Documentation

SetNullStringToEmpty Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743914)>
Function SetNullStringToEmpty( _
   ByVal _inputString_ As Object _
) As Object

[DispIdAttribute(1610743914)]
object SetNullStringToEmpty(
   object _inputString_
)

Parameters

inputString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


SetPassword Method (IFCSession) | fcSDK Documentation

SetPassword Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743908)>
Sub SetPassword( _
   ByVal _loginName_ As String, _
   ByVal _password_ As String, _
   ByVal _loginType_ As String _
)

[DispIdAttribute(1610743908)]
void SetPassword(
   string _loginName_,
   string _password_,
   string _loginType_
)

Parameters

loginName

password

loginType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


SimpleQuery Method (IFCSession) | fcSDK Documentation

SimpleQuery Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743880)>
Sub SimpleQuery( _
   ByRef _generic_ As IFCGeneric, _
   ByVal _objectType_ As String, _
   ByVal _dataFields_ As String, _
   ByVal _bulkName_ As String _
)

[DispIdAttribute(1610743880)]
void SimpleQuery(
   out IFCGeneric _generic_,
   string _objectType_,
   string _dataFields_,
   string _bulkName_
)

Parameters

generic

objectType

dataFields

bulkName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


single_quotify Method (IFCSession) | fcSDK Documentation

single_quotify Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743912)>
Function single_quotify( _
   ByVal _inputString_ As String _
) As String

[DispIdAttribute(1610743912)]
string single_quotify(
   string _inputString_
)

Parameters

inputString

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


sprintf Method (IFCSession) | fcSDK Documentation

sprintf Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743868)>
Function sprintf( _
   ByVal _inputString_ As String, _
   Optional ByVal _arg1_ As Object, _
   Optional ByVal _arg2_ As Object, _
   Optional ByVal _arg3_ As Object, _
   Optional ByVal _arg4_ As Object, _
   Optional ByVal _arg5_ As Object, _
   Optional ByVal _arg6_ As Object _
) As String

[DispIdAttribute(1610743868)]
string sprintf(
   string _inputString_,
   object _arg1_,
   object _arg2_,
   object _arg3_,
   object _arg4_,
   object _arg5_,
   object _arg6_
)

Parameters

inputString

arg1

arg2

arg3

arg4

arg5

arg6

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


StartTransaction Method (IFCSession) | fcSDK Documentation

StartTransaction Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610747764)>
Sub StartTransaction( _
   Optional ByVal _isolationLevel_ As Object _
)

[DispIdAttribute(1610747764)]
void StartTransaction(
   object _isolationLevel_
)

Parameters

isolationLevel

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


TraverseFromParent Method (IFCSession) | fcSDK Documentation

TraverseFromParent Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743881)>
Function TraverseFromParent( _
   ByRef _generic_ As IFCGeneric, _
   ByVal _objectType_ As String, _
   ByVal _dataFields_ As String, _
   ByVal _bulkName_ As String, _
   ByVal _the_parent_ As IFCGeneric, _
   ByVal _relation_ As String _
) As IFCGeneric

[DispIdAttribute(1610743881)]
IFCGeneric TraverseFromParent(
   out IFCGeneric _generic_,
   string _objectType_,
   string _dataFields_,
   string _bulkName_,
   IFCGeneric _the_parent_,
   string _relation_
)

Parameters

generic

objectType

dataFields

bulkName

the_parent

relation

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


turn_off Method (IFCSession) | fcSDK Documentation

turn_off Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743893)>
Function turn_off( _
   ByVal _bigNum_ As Integer, _
   ByVal _smallNum_ As Integer _
) As Integer

[DispIdAttribute(1610743893)]
int turn_off(
   int _bigNum_,
   int _smallNum_
)

Parameters

bigNum

smallNum

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


use_list Method (IFCSession) | fcSDK Documentation

use_list Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743884)>
Sub use_list( _
   ByVal _tempRecord_ As IFCGeneric, _
   ByVal _fieldList_ As Object, _
   ByVal _typeList_ As Object, _
   ByVal _valueList_ As Object _
)

[DispIdAttribute(1610743884)]
void use_list(
   IFCGeneric _tempRecord_,
   object _fieldList_,
   object _typeList_,
   object _valueList_
)

Parameters

tempRecord

fieldList

typeList

valueList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


yank_object Method (IFCSession) | fcSDK Documentation

yank_object Method (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743903)>
Function yank_object( _
   ByVal _objId_ As String, _
   ByVal _wipBin_ As String, _
   ByRef _yankDate_ As String, _
   ByRef _localuserName_ As String, _
   ByVal _genearateTimeBombs_ As Boolean, _
   ByVal _objectType_ As String _
) As Short

[DispIdAttribute(1610743903)]
short yank_object(
   string _objId_,
   string _wipBin_,
   out string _yankDate_,
   out string _localuserName_,
   bool _genearateTimeBombs_,
   string _objectType_
)

Parameters

objId

wipBin

yankDate

localuserName

genearateTimeBombs

objectType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


ad_auto Property (IFCSession) | fcSDK Documentation

ad_auto Property (IFCSession)

Syntax

'Declaration
<DispIdAttribute(1610743839)>
Property ad_auto As Boolean

[DispIdAttribute(1610743839)]
bool ad_auto {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


ad_list Property (IFCSession) | fcSDK Documentation

ad_list Property (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743837)>
Property ad_list As String

[DispIdAttribute(1610743837)]
string ad_list {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


BulkCollection Property (IFCSession) | fcSDK Documentation

BulkCollection Property (IFCSession)

Syntax

'Declaration
<DispIdAttribute(1610743854)>
ReadOnly Property BulkCollection As IMockCollection

[DispIdAttribute(1610743854)]
IMockCollection BulkCollection {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


ConvertTimeZone Property (IFCSession) | fcSDK Documentation

ConvertTimeZone Property (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743812)>
Property ConvertTimeZone As Boolean

[DispIdAttribute(1610743812)]
bool ConvertTimeZone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


cur_res Property (IFCSession) | fcSDK Documentation

cur_res Property (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743824)>
Property cur_res As IMockCollection

[DispIdAttribute(1610743824)]
IMockCollection cur_res {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


CurrentCulture Property (IFCSession) | fcSDK Documentation

CurrentCulture Property (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743818)>
Property CurrentCulture As String

[DispIdAttribute(1610743818)]
string CurrentCulture {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


Distinct Property (IFCSession) | fcSDK Documentation

Distinct Property (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743855)>
Property Distinct As Boolean

[DispIdAttribute(1610743855)]
bool Distinct {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


ErrorMessage Property (IFCSession) | fcSDK Documentation

ErrorMessage Property (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743826)>
Property ErrorMessage As String

[DispIdAttribute(1610743826)]
string ErrorMessage {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


ErrorNumber Property (IFCSession) | fcSDK Documentation

ErrorNumber Property (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743832)>
Property ErrorNumber As Short

[DispIdAttribute(1610743832)]
short ErrorNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


ErrorSource Property (IFCSession) | fcSDK Documentation

ErrorSource Property (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743830)>
Property ErrorSource As String

[DispIdAttribute(1610743830)]
string ErrorSource {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


hist_change Property (IFCSession) | fcSDK Documentation

hist_change Property (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743834)>
ReadOnly Property hist_change As Boolean

[DispIdAttribute(1610743834)]
bool hist_change {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


IncludeRelations Property (IFCSession) | fcSDK Documentation

IncludeRelations Property (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743810)>
Property IncludeRelations As Boolean

[DispIdAttribute(1610743810)]
bool IncludeRelations {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


IsInTransaction Property (IFCSession) | fcSDK Documentation

IsInTransaction Property (IFCSession)

Syntax

'Declaration
<DispIdAttribute(1610743853)>
ReadOnly Property IsInTransaction As Boolean

[DispIdAttribute(1610743853)]
bool IsInTransaction {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


IsLoggedIn Property (IFCSession) | fcSDK Documentation

IsLoggedIn Property (IFCSession)

Syntax

'Declaration
<DispIdAttribute(1610743844)>
ReadOnly Property IsLoggedIn As Boolean

[DispIdAttribute(1610743844)]
bool IsLoggedIn {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


Item Property (IFCSession) | fcSDK Documentation

Item Property (IFCSession)

Syntax

'Declaration

<ComVisibleAttribute(False)>
Default Property Item( _
   ByVal _index_ As String _
) As Object

[ComVisibleAttribute(false)]
object this\[
   string _index_
\]; {get; set;}

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


LocalTimeZone Property (IFCSession) | fcSDK Documentation

LocalTimeZone Property (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743846)>
Property LocalTimeZone As String

[DispIdAttribute(1610743846)]
string LocalTimeZone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


LocalTimeZoneOffset Property (IFCSession) | fcSDK Documentation

LocalTimeZoneOffset Property (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743848)>
ReadOnly Property LocalTimeZoneOffset As Integer

[DispIdAttribute(1610743848)]
int LocalTimeZoneOffset {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


LoginTime Property (IFCSession) | fcSDK Documentation

LoginTime Property (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743808)>
ReadOnly Property LoginTime As Date

[DispIdAttribute(1610743808)]
DateTime LoginTime {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


NoRes Property (IFCSession) | fcSDK Documentation

NoRes Property (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743822)>
Property NoRes As Boolean

[DispIdAttribute(1610743822)]
bool NoRes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


num_ad Property (IFCSession) | fcSDK Documentation

num_ad Property (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743835)>
Property num_ad As Short

[DispIdAttribute(1610743835)]
short num_ad {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


PasswordRequired Property (IFCSession) | fcSDK Documentation

PasswordRequired Property (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743849)>
Property PasswordRequired As Boolean

[DispIdAttribute(1610743849)]
bool PasswordRequired {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


QueryEmptyToNull Property (IFCSession) | fcSDK Documentation

QueryEmptyToNull Property (IFCSession)

Syntax

'Declaration
<DispIdAttribute(1610743851)>
Property QueryEmptyToNull As Boolean

[DispIdAttribute(1610743851)]
bool QueryEmptyToNull {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


RESEnabled Property (IFCSession) | fcSDK Documentation

RESEnabled Property (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743820)>
Property RESEnabled As Boolean

[DispIdAttribute(1610743820)]
bool RESEnabled {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


rowLimit Property (IFCSession) | fcSDK Documentation

rowLimit Property (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743841)>
Property rowLimit As Integer

[DispIdAttribute(1610743841)]
int rowLimit {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


SessionID Property (IFCSession) | fcSDK Documentation

SessionID Property (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743843)>
ReadOnly Property SessionID As String

[DispIdAttribute(1610743843)]
string SessionID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


SetNullStringsToEmpty Property (IFCSession) | fcSDK Documentation

SetNullStringsToEmpty Property (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743816)>
Property SetNullStringsToEmpty As Boolean

[DispIdAttribute(1610743816)]
bool SetNullStringsToEmpty {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


ThrowErrors Property (IFCSession) | fcSDK Documentation

ThrowErrors Property (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743828)>
Property ThrowErrors As Boolean

[DispIdAttribute(1610743828)]
bool ThrowErrors {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


TruncateStringFields Property (IFCSession) | fcSDK Documentation

TruncateStringFields Property (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743814)>
Property TruncateStringFields As Boolean

[DispIdAttribute(1610743814)]
bool TruncateStringFields {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


UpdateTime Property (IFCSession) | fcSDK Documentation

UpdateTime Property (IFCSession)

Syntax

'Declaration

<DispIdAttribute(1610743809)>
ReadOnly Property UpdateTime As Date

[DispIdAttribute(1610743809)]
DateTime UpdateTime {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSession Interface
IFCSession Members


IFCSqlExec Interface | fcSDK Documentation

IFCSqlExec Interface

Syntax

'Declaration

<GuidAttribute("F2455264-5491-4c13-89E9-15CF44F2C75A")>
<ComVisibleAttribute(True)>
Public Interface IFCSqlExec

[GuidAttribute("F2455264-5491-4c13-89E9-15CF44F2C75A")]
[ComVisibleAttribute(true)]
public interface IFCSqlExec

Requirements

Namespace: FChoice.Foundation.Clarify.Compatibility

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Foundation.Clarify.Compatibility (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Foundation.Clarify.Compatibility.dll)

Reference

IFCSqlExec Members
FChoice.Foundation.Clarify.Compatibility Namespace


IFCSqlExec Interface Members | fcSDK Documentation

IFCSqlExec Interface Members

The following tables list the members exposed by IFCSqlExec.

Public Properties

 | Name | Description
Property | Records |
Property | StayConnected |

Public Methods

 | Name | Description
Method | AddSqlParameter |
Method | CloseConnection |
Method | Execute |
Method | ExecuteReturnRows |
Method | FreeConnection |
Method | OpenConnection |

Reference

IFCSqlExec Interface
FChoice.Foundation.Clarify.Compatibility Namespace


AddSqlParameter Method (IFCSqlExec) | fcSDK Documentation

AddSqlParameter Method (IFCSqlExec)

Syntax

'Declaration

<DispIdAttribute(1610743816)>
Sub AddSqlParameter( _
   ByVal _value_ As Object _
)

[DispIdAttribute(1610743816)]
void AddSqlParameter(
   object _value_
)

Parameters

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSqlExec Interface
IFCSqlExec Members


CloseConnection Method (IFCSqlExec) | fcSDK Documentation

CloseConnection Method (IFCSqlExec)

Syntax

'Declaration
<DispIdAttribute(1610743814)>
Sub CloseConnection()

[DispIdAttribute(1610743814)]
void CloseConnection()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSqlExec Interface
IFCSqlExec Members


Execute Method (IFCSqlExec) | fcSDK Documentation

Execute Method (IFCSqlExec)

Syntax

'Declaration

<DispIdAttribute(1610743811)>
Sub Execute( _
   ByVal _SqlStr_ As String _
)

[DispIdAttribute(1610743811)]
void Execute(
   string _SqlStr_
)

Parameters

SqlStr

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSqlExec Interface
IFCSqlExec Members


ExecuteReturnRows Method (IFCSqlExec) | fcSDK Documentation

ExecuteReturnRows Method (IFCSqlExec)

Syntax

'Declaration

<DispIdAttribute(1610743812)>
Sub ExecuteReturnRows( _
   ByVal _sqlStatement_ As String _
)

[DispIdAttribute(1610743812)]
void ExecuteReturnRows(
   string _sqlStatement_
)

Parameters

sqlStatement

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSqlExec Interface
IFCSqlExec Members


FreeConnection Method (IFCSqlExec) | fcSDK Documentation

FreeConnection Method (IFCSqlExec)

Syntax

'Declaration
<DispIdAttribute(1610743815)>
Sub FreeConnection()

[DispIdAttribute(1610743815)]
void FreeConnection()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSqlExec Interface
IFCSqlExec Members


OpenConnection Method (IFCSqlExec) | fcSDK Documentation

OpenConnection Method (IFCSqlExec)

Syntax

'Declaration

<DispIdAttribute(1610743813)>
Sub OpenConnection( _
   ByVal _TheDB_ As String, _
   ByVal _UserName_ As String, _
   ByVal _password_ As String, _
   ByVal _DBServer_ As String, _
   ByVal _DBName_ As String _
)

[DispIdAttribute(1610743813)]
void OpenConnection(
   string _TheDB_,
   string _UserName_,
   string _password_,
   string _DBServer_,
   string _DBName_
)

Parameters

TheDB

UserName

password

DBServer

DBName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSqlExec Interface
IFCSqlExec Members


Records Property (IFCSqlExec) | fcSDK Documentation

Records Property (IFCSqlExec)

Syntax

'Declaration

<DispIdAttribute(1610743808)>
ReadOnly Property Records As ADODB.Recordset

[DispIdAttribute(1610743808)]
ADODB.Recordset Records {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSqlExec Interface
IFCSqlExec Members


StayConnected Property (IFCSqlExec) | fcSDK Documentation

StayConnected Property (IFCSqlExec)

Syntax

'Declaration

<DispIdAttribute(1610743809)>
Property StayConnected As Boolean

[DispIdAttribute(1610743809)]
bool StayConnected {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IFCSqlExec Interface
IFCSqlExec Members


IMockAdoField Interface | fcSDK Documentation

IMockAdoField Interface

Syntax

'Declaration
<ComVisibleAttribute(True)>
<GuidAttribute("F7AED485-957A-4ad6-90C8-7D475C87F9C7")>
Public Interface IMockAdoField

[ComVisibleAttribute(true)]
[GuidAttribute("F7AED485-957A-4ad6-90C8-7D475C87F9C7")]
public interface IMockAdoField

Requirements

Namespace: FChoice.Foundation.Clarify.Compatibility

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Foundation.Clarify.Compatibility (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Foundation.Clarify.Compatibility.dll)

Reference

IMockAdoField Members
FChoice.Foundation.Clarify.Compatibility Namespace


IMockAdoField Interface Members | fcSDK Documentation

IMockAdoField Interface Members

The following tables list the members exposed by IMockAdoField.

Public Properties

 | Name | Description
Property | DefinedSize |
Property | Name |
Property | NetValue |
Property | Type |

Public Methods

 | Name | Description
Method | get_Value |
Method | set_Value |

Reference

IMockAdoField Interface
FChoice.Foundation.Clarify.Compatibility Namespace


get_Value Method (IMockAdoField) | fcSDK Documentation

get_Value Method (IMockAdoField)

Syntax

'Declaration

Function get_Value() As Object

object get_Value()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IMockAdoField Interface
IMockAdoField Members


set_Value Method (IMockAdoField) | fcSDK Documentation

set_Value Method (IMockAdoField)

Syntax

'Declaration

Sub set_Value( _
   ByVal _newValue_ As Object _
)

void set_Value(
   object _newValue_
)

Parameters

newValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IMockAdoField Interface
IMockAdoField Members


DefinedSize Property (IMockAdoField) | fcSDK Documentation

DefinedSize Property (IMockAdoField)

Syntax

'Declaration

<DispIdAttribute(1610743813)>
ReadOnly Property DefinedSize As Integer

[DispIdAttribute(1610743813)]
int DefinedSize {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IMockAdoField Interface
IMockAdoField Members


Name Property (IMockAdoField) | fcSDK Documentation

Name Property (IMockAdoField)

Syntax

'Declaration

<DispIdAttribute(1610743814)>
ReadOnly Property Name As String

[DispIdAttribute(1610743814)]
string Name {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IMockAdoField Interface
IMockAdoField Members


NetValue Property (IMockAdoField) | fcSDK Documentation

NetValue Property (IMockAdoField)

Syntax

'Declaration

<ComVisibleAttribute(False)>
Property NetValue As Object

[ComVisibleAttribute(false)]
object NetValue {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IMockAdoField Interface
IMockAdoField Members


Type Property (IMockAdoField) | fcSDK Documentation

Type Property (IMockAdoField)

Syntax

'Declaration

<DispIdAttribute(1610743812)>
ReadOnly Property Type As Integer

[DispIdAttribute(1610743812)]
int Type {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IMockAdoField Interface
IMockAdoField Members


IMockCollection Interface | fcSDK Documentation

IMockCollection Interface

Syntax

'Declaration

<GuidAttribute("E56DD62E-5282-4ca0-8AE5-9B40D173B39E")>
<ComVisibleAttribute(True)>
Public Interface IMockCollection

[GuidAttribute("E56DD62E-5282-4ca0-8AE5-9B40D173B39E")]
[ComVisibleAttribute(true)]
public interface IMockCollection

Requirements

Namespace: FChoice.Foundation.Clarify.Compatibility

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Foundation.Clarify.Compatibility (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Foundation.Clarify.Compatibility.dll)

Reference

IMockCollection Members
FChoice.Foundation.Clarify.Compatibility Namespace


IMockCollection Interface Members | fcSDK Documentation

IMockCollection Interface Members

The following tables list the members exposed by IMockCollection.

Public Methods

 | Name | Description
Method | _NewEnum |
Method | Add |
Method | Count |
Method | Item |
Method | Remove |

Reference

IMockCollection Interface
FChoice.Foundation.Clarify.Compatibility Namespace


_NewEnum Method (IMockCollection) | fcSDK Documentation

_NewEnum Method (IMockCollection)

Syntax

'Declaration
<DispIdAttribute(-4)>
Function _NewEnum() As IEnumerator

[DispIdAttribute(-4)]
IEnumerator _NewEnum()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IMockCollection Interface
IMockCollection Members


Add Method (IMockCollection) | fcSDK Documentation

Add Method (IMockCollection)

Syntax

'Declaration

<DispIdAttribute(1)>
Sub Add( _
   ByRef _Item_ As Object, _
   Optional ByRef _Key_ As Object, _
   Optional ByRef _Before_ As Object, _
   Optional ByRef _After_ As Object _
)

[DispIdAttribute(1)]
void Add(
   ref object _Item_,
   ref object _Key_,
   ref object _Before_,
   ref object _After_
)

Parameters

Item

Key

Before

After

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IMockCollection Interface
IMockCollection Members


Count Method (IMockCollection) | fcSDK Documentation

Count Method (IMockCollection)

Syntax

'Declaration

<DispIdAttribute(2)>
Function Count() As Integer

[DispIdAttribute(2)]
int Count()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IMockCollection Interface
IMockCollection Members


Item Method (IMockCollection) | fcSDK Documentation

Item Method (IMockCollection)

Syntax

'Declaration

<DispIdAttribute(0)>
Function Item( _
   ByRef _Index_ As Object _
) As Object

[DispIdAttribute(0)]
object Item(
   ref object _Index_
)

Parameters

Index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IMockCollection Interface
IMockCollection Members


Remove Method (IMockCollection) | fcSDK Documentation

Remove Method (IMockCollection)

Syntax

'Declaration

<DispIdAttribute(3)>
Sub Remove( _
   ByRef _Index_ As Object _
)

[DispIdAttribute(3)]
void Remove(
   ref object _Index_
)

Parameters

Index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IMockCollection Interface
IMockCollection Members


FChoice.Foundation.Clarify.DataObjects Namespace | fcSDK Documentation

FChoice.Foundation.Clarify.DataObjects Namespace

The FChoice.Foundation.Clarify.DataObjects namespace contains classes which represent commonly used objects in the Clarify system such as user-defined lists, countries/states/timezones, and localized strings.

Classes

 | Class | Description
Class | ClarifyConfigItem |
Class | ClarifyConfigItemCollection |
Class | ClarifyDataObject |
Class | Country |
Class | CountryCollection |
Class | DaylightSavingsCollection |
Class | DaylightSavingsPeriod |
Class | FCString |
Class | FCTimeZone |
Class | FCTimeZoneCollection |
Class | GlobalStringElement |
Class | GlobalStringElementCollection |
Class | GlobalStringList |
Class | GlobalStringListCollection |
Class | HierarchicalStringElement |
Class | HierarchicalStringElementCollection |
Class | HierarchicalStringList |
Class | HierarchicalStringListCollection |
Class | HierarchicalStringShow |
Class | LocalizedString |
Class | StateCollection |
Class | StateProvince |

Interfaces

 | Interface | Description
Interface | IGlobalStringElement |
Interface | IGlobalStringElementCollection |
Interface | IGlobalStringList |
Interface | IGlobalStringListCollection |
Interface | IHierarchicalStringElement |
Interface | IHierarchicalStringElementCollection |
Interface | IHierarchicalStringList |
Interface | IHierarchicalStringListCollection |

Reference

fcSDK Assembly


ClarifyConfigItem Class | fcSDK Documentation

ClarifyConfigItem Class

Syntax

'Declaration

Public Class ClarifyConfigItem
   Inherits FChoice.Foundation.DataObjects.ConfigItem
   Implements FChoice.Foundation.DataObjects.IDataObject

public class ClarifyConfigItem : FChoice.Foundation.DataObjects.ConfigItem, FChoice.Foundation.DataObjects.IDataObject

Inheritance Hierarchy

System.Object
FChoice.Foundation.DataObjects.DataObject
FChoice.Foundation.DataObjects.ConfigItem
FChoice.Foundation.Clarify.DataObjects.ClarifyConfigItem

Requirements

Namespace: FChoice.Foundation.Clarify.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ClarifyConfigItem Members
FChoice.Foundation.Clarify.DataObjects Namespace


ClarifyConfigItem Class Members | fcSDK Documentation

ClarifyConfigItem Class Members

The following tables list the members exposed by ClarifyConfigItem.

Public Properties

 | Name | Description
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | DateValue | (Inherited from FChoice.Foundation.DataObjects.ConfigItem)
Public Property | DecimalValue | (Inherited from FChoice.Foundation.DataObjects.ConfigItem)
Public Property | Description | (Inherited from FChoice.Foundation.DataObjects.ConfigItem)
Public Property | DoubleValue | (Inherited from FChoice.Foundation.DataObjects.ConfigItem)
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | IntegerValue | (Inherited from FChoice.Foundation.DataObjects.ConfigItem)
Public Property | LastModTime |
Public Property | LongValue | (Inherited from FChoice.Foundation.DataObjects.ConfigItem)
Public Property | Name | (Inherited from FChoice.Foundation.DataObjects.ConfigItem)
Public Property | Scope | (Inherited from FChoice.Foundation.DataObjects.ConfigItem)
Public Property | StringValue | (Inherited from FChoice.Foundation.DataObjects.ConfigItem)
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | ValueType | (Inherited from FChoice.Foundation.DataObjects.ConfigItem)
Public Property | ValueTypeRaw | (Inherited from FChoice.Foundation.DataObjects.ConfigItem)

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

ClarifyConfigItem Class
FChoice.Foundation.Clarify.DataObjects Namespace


LastModTime Property | fcSDK Documentation

LastModTime Property

Syntax

'Declaration

Public ReadOnly Property LastModTime As Date

public DateTime LastModTime {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyConfigItem Class
ClarifyConfigItem Members


ClarifyConfigItemCollection Class | fcSDK Documentation

ClarifyConfigItemCollection Class

Syntax

'Declaration

<DefaultMemberAttribute("Item")>
Public Class ClarifyConfigItemCollection
   Inherits FChoice.Foundation.DataObjects.ConfigItemCollection

[DefaultMemberAttribute("Item")]
public class ClarifyConfigItemCollection : FChoice.Foundation.DataObjects.ConfigItemCollection

Inheritance Hierarchy

System.Object
System.Collections.Generic.List
FChoice.Foundation.DataObjects.DataObjectCollection
FChoice.Foundation.DataObjects.ConfigItemCollection
FChoice.Foundation.Clarify.DataObjects.ClarifyConfigItemCollection

Requirements

Namespace: FChoice.Foundation.Clarify.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ClarifyConfigItemCollection Members
FChoice.Foundation.Clarify.DataObjects Namespace


ClarifyConfigItemCollection Class Members | fcSDK Documentation

ClarifyConfigItemCollection Class Members

The following tables list the members exposed by ClarifyConfigItemCollection.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | Item | Overloaded.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex | (Inherited from FChoice.Foundation.DataObjects.DataObjectCollection)
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

ClarifyConfigItemCollection Class
FChoice.Foundation.Clarify.DataObjects Namespace


Item Property (ClarifyConfigItemCollection) | fcSDK Documentation

Item Property (ClarifyConfigItemCollection)

Overload List

Overload | Description
Item(String) |
Item(Int32) | (Inherited from System.Collections.Generic.List)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyConfigItemCollection Class
ClarifyConfigItemCollection Members


Item(String) Property | fcSDK Documentation

Item(String) Property

Syntax

'Declaration

Public Overloads Shadows ReadOnly Property Item( _
   ByVal _itemName_ As String _
) As ClarifyConfigItem```

```csharp
public new ClarifyConfigItem Item(
   string _itemName_
) {get;}

Parameters

itemName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyConfigItemCollection Class
ClarifyConfigItemCollection Members
Overload List


ClarifyDataObject Class | fcSDK Documentation

ClarifyDataObject Class

Syntax

'Declaration

Public MustInherit Class ClarifyDataObject
   Inherits FChoice.Foundation.DataObjects.DataObject
   Implements FChoice.Foundation.DataObjects.IDataObject

public abstract class ClarifyDataObject : FChoice.Foundation.DataObjects.DataObject, FChoice.Foundation.DataObjects.IDataObject

Inheritance Hierarchy

System.Object
FChoice.Foundation.DataObjects.DataObject
FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject
FChoice.Foundation.Clarify.DataObjects.Country
FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod
FChoice.Foundation.Clarify.DataObjects.FCString
FChoice.Foundation.Clarify.DataObjects.FCTimeZone
FChoice.Foundation.Clarify.DataObjects.GlobalStringElement
FChoice.Foundation.Clarify.DataObjects.GlobalStringList
FChoice.Foundation.Clarify.DataObjects.HierarchicalStringElement
FChoice.Foundation.Clarify.DataObjects.HierarchicalStringList
FChoice.Foundation.Clarify.DataObjects.HierarchicalStringShow
FChoice.Foundation.Clarify.DataObjects.LocalizedString
FChoice.Foundation.Clarify.DataObjects.StateProvince
FChoice.Foundation.Clarify.Schema.SchemaFieldBase
FChoice.Foundation.Clarify.Schema.SchemaRelation
FChoice.Foundation.Clarify.Schema.SchemaTableBase
FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo
FChoice.Foundation.Clarify.Schema.SchemaViewJoin

Requirements

Namespace: FChoice.Foundation.Clarify.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ClarifyDataObject Members
FChoice.Foundation.Clarify.DataObjects Namespace


ClarifyDataObject Class Members | fcSDK Documentation

ClarifyDataObject Class Members

The following tables list the members exposed by ClarifyDataObject.

Public Properties

 | Name | Description
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
static (Shared in Visual Basic) | CommentFieldName |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | ObjectID |
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

ClarifyDataObject Class
FChoice.Foundation.Clarify.DataObjects Namespace


CommentFieldName Property | fcSDK Documentation

CommentFieldName Property

Syntax

'Declaration

Public Shared ReadOnly Property CommentFieldName As String

public static string CommentFieldName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyDataObject Class
ClarifyDataObject Members


ObjectID Property (ClarifyDataObject) | fcSDK Documentation

ObjectID Property (ClarifyDataObject)

Syntax

'Declaration

Public ReadOnly Property ObjectID As Integer

public int ObjectID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyDataObject Class
ClarifyDataObject Members


Country Class | fcSDK Documentation

Country Class

Syntax

'Declaration

Public Class Country
   Inherits ClarifyDataObject
   Implements FChoice.Foundation.DataObjects.IDataObject

public class Country : ClarifyDataObject, FChoice.Foundation.DataObjects.IDataObject

Inheritance Hierarchy

System.Object
FChoice.Foundation.DataObjects.DataObject
FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject
FChoice.Foundation.Clarify.DataObjects.Country

Requirements

Namespace: FChoice.Foundation.Clarify.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

Country Members
FChoice.Foundation.Clarify.DataObjects Namespace


Country Class Members | fcSDK Documentation

Country Class Members

The following tables list the members exposed by Country.

Public Properties

 | Name | Description
Public Property | Code |
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | DefaultState |
Public Property | DefaultTimeZone |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | IsDefault |
Public Property | Name |
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | States |
Public Property | TimeZones |
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

Country Class
FChoice.Foundation.Clarify.DataObjects Namespace


Code Property | fcSDK Documentation

Code Property

Syntax

'Declaration

Public ReadOnly Property Code As Integer

public int Code {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Country Class
Country Members


DefaultState Property (Country) | fcSDK Documentation

DefaultState Property (Country)

Syntax

'Declaration

Public ReadOnly Property DefaultState As StateProvince

public StateProvince DefaultState {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Country Class
Country Members


DefaultTimeZone Property (Country) | fcSDK Documentation

DefaultTimeZone Property (Country)

Syntax

'Declaration

Public ReadOnly Property DefaultTimeZone As FCTimeZone

public FCTimeZone DefaultTimeZone {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Country Class
Country Members


IsDefault Property (Country) | fcSDK Documentation

IsDefault Property (Country)

Syntax

'Declaration

Public ReadOnly Property IsDefault As Boolean

public bool IsDefault {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Country Class
Country Members


Name Property (Country) | fcSDK Documentation

Name Property (Country)

Syntax

'Declaration

Public ReadOnly Property Name As String

public string Name {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Country Class
Country Members


States Property | fcSDK Documentation

States Property

Syntax

'Declaration

Public ReadOnly Property States As StateCollection

public StateCollection States {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Country Class
Country Members


TimeZones Property (Country) | fcSDK Documentation

TimeZones Property (Country)

Syntax

'Declaration

Public ReadOnly Property TimeZones As FCTimeZoneCollection

public FCTimeZoneCollection TimeZones {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Country Class
Country Members


CountryCollection Class | fcSDK Documentation

CountryCollection Class

Syntax

'Declaration

<DefaultMemberAttribute("Item")>
Public Class CountryCollection
   Inherits FChoice.Foundation.DataObjects.DataObjectCollection(Of Country)

[DefaultMemberAttribute("Item")]
public class CountryCollection : FChoice.Foundation.DataObjects.DataObjectCollection<Country>

Inheritance Hierarchy

System.Object
System.Collections.Generic.List
FChoice.Foundation.DataObjects.DataObjectCollection
FChoice.Foundation.Clarify.DataObjects.CountryCollection

Requirements

Namespace: FChoice.Foundation.Clarify.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

CountryCollection Members
FChoice.Foundation.Clarify.DataObjects Namespace


CountryCollection Class Members | fcSDK Documentation

CountryCollection Class Members

The following tables list the members exposed by CountryCollection.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | DefaultCountry |
Public Property | Item |

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex | (Inherited from FChoice.Foundation.DataObjects.DataObjectCollection)
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

CountryCollection Class
FChoice.Foundation.Clarify.DataObjects Namespace


DefaultCountry Property | fcSDK Documentation

DefaultCountry Property

Syntax

'Declaration

Public ReadOnly Property DefaultCountry As Country

public Country DefaultCountry {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CountryCollection Class
CountryCollection Members


Item Property (CountryCollection) | fcSDK Documentation

Item Property (CountryCollection)

Syntax

'Declaration

Public Shadows ReadOnly Default Property Item( _
   ByVal _countryName_ As String _
) As Country

public new Country this[
   string _countryName_
]; {get;}

Parameters

countryName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CountryCollection Class
CountryCollection Members


DaylightSavingsCollection Class | fcSDK Documentation

DaylightSavingsCollection Class

Syntax

'Declaration

Public Class DaylightSavingsCollection
   Inherits FChoice.Foundation.DataObjects.DataObjectCollection(Of DaylightSavingsPeriod)

public class DaylightSavingsCollection : FChoice.Foundation.DataObjects.DataObjectCollection<DaylightSavingsPeriod>

Inheritance Hierarchy

System.Object
System.Collections.Generic.List
FChoice.Foundation.DataObjects.DataObjectCollection
FChoice.Foundation.Clarify.DataObjects.DaylightSavingsCollection

Requirements

Namespace: FChoice.Foundation.Clarify.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

DaylightSavingsCollection Members
FChoice.Foundation.Clarify.DataObjects Namespace


DaylightSavingsCollection Class Members | fcSDK Documentation

DaylightSavingsCollection Class Members

The following tables list the members exposed by DaylightSavingsCollection.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | Item | (Inherited from System.Collections.Generic.List)

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex | (Inherited from FChoice.Foundation.DataObjects.DataObjectCollection)
Public Method | GetPeriod |
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

DaylightSavingsCollection Class
FChoice.Foundation.Clarify.DataObjects Namespace


GetPeriod Method | fcSDK Documentation

GetPeriod Method

Syntax

'Declaration

Public Function GetPeriod( _
   ByVal _date_ As Date _
) As DaylightSavingsPeriod

public DaylightSavingsPeriod GetPeriod(
   DateTime _date_
)

Parameters

date

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DaylightSavingsCollection Class
DaylightSavingsCollection Members


DaylightSavingsPeriod Class | fcSDK Documentation

DaylightSavingsPeriod Class

Syntax

'Declaration

Public Class DaylightSavingsPeriod
   Inherits ClarifyDataObject
   Implements FChoice.Foundation.DataObjects.IDataObject

public class DaylightSavingsPeriod : ClarifyDataObject, FChoice.Foundation.DataObjects.IDataObject

Inheritance Hierarchy

System.Object
FChoice.Foundation.DataObjects.DataObject
FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject
FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod

Requirements

Namespace: FChoice.Foundation.Clarify.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

DaylightSavingsPeriod Members
FChoice.Foundation.Clarify.DataObjects Namespace


DaylightSavingsPeriod Class Members | fcSDK Documentation

DaylightSavingsPeriod Class Members

The following tables list the members exposed by DaylightSavingsPeriod.

Public Properties

 | Name | Description
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | EndDate |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | StartDate |
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | Intersects |
Public Method | IsDateInRange |

Reference

DaylightSavingsPeriod Class
FChoice.Foundation.Clarify.DataObjects Namespace


Intersects Method | fcSDK Documentation

Intersects Method

Syntax

'Declaration

Public Function Intersects( _
   ByVal _input_ As DaylightSavingsPeriod _
) As Boolean

public bool Intersects(
   DaylightSavingsPeriod _input_
)

Parameters

input

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DaylightSavingsPeriod Class
DaylightSavingsPeriod Members


IsDateInRange Method | fcSDK Documentation

IsDateInRange Method

Syntax

'Declaration

Public Function IsDateInRange( _
   ByVal _testDate_ As Date _
) As Boolean

public bool IsDateInRange(
   DateTime _testDate_
)

Parameters

testDate

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DaylightSavingsPeriod Class
DaylightSavingsPeriod Members


EndDate Property (DaylightSavingsPeriod) | fcSDK Documentation

EndDate Property (DaylightSavingsPeriod)

Syntax

'Declaration

Public ReadOnly Property EndDate As Date

public DateTime EndDate {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DaylightSavingsPeriod Class
DaylightSavingsPeriod Members


StartDate Property (DaylightSavingsPeriod) | fcSDK Documentation

StartDate Property (DaylightSavingsPeriod)

Syntax

'Declaration

Public ReadOnly Property StartDate As Date

public DateTime StartDate {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DaylightSavingsPeriod Class
DaylightSavingsPeriod Members


FCString Class | fcSDK Documentation

FCString Class

Syntax

'Declaration

Public Class FCString
   Inherits ClarifyDataObject
   Implements FChoice.Foundation.DataObjects.IDataObject

public class FCString : ClarifyDataObject, FChoice.Foundation.DataObjects.IDataObject

Inheritance Hierarchy

System.Object
FChoice.Foundation.DataObjects.DataObject
FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject
FChoice.Foundation.Clarify.DataObjects.FCString

Requirements

Namespace: FChoice.Foundation.Clarify.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FCString Members
FChoice.Foundation.Clarify.DataObjects Namespace


FCString Class Members | fcSDK Documentation

FCString Class Members

The following tables list the members exposed by FCString.

Public Properties

 | Name | Description
Public Property | Application |
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Culture |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | IDKey |
Public Property | LocaleName |
Public Property | NameKey |
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | StringID |
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Value |

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
static (Shared in Visual Basic) | GetCultureForCultureName |
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

FCString Class
FChoice.Foundation.Clarify.DataObjects Namespace


GetCultureForCultureName Method | fcSDK Documentation

GetCultureForCultureName Method

Syntax

'Declaration

Public Shared Function GetCultureForCultureName( _
   ByVal _cultureName_ As String, _
   ByVal _requestingObjType_ As String, _
   ByVal _itemID_ As String _
) As CultureInfo

public static CultureInfo GetCultureForCultureName(
   string _cultureName_,
   string _requestingObjType_,
   string _itemID_
)

Parameters

cultureName

requestingObjType

itemID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCString Class
FCString Members


Application Property | fcSDK Documentation

Application Property

Syntax

'Declaration

Public ReadOnly Property Application As String

public string Application {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCString Class
FCString Members


Culture Property (FCString) | fcSDK Documentation

Culture Property (FCString)

Syntax

'Declaration

Public ReadOnly Property Culture As CultureInfo

public CultureInfo Culture {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCString Class
FCString Members


IDKey Property (FCString) | fcSDK Documentation

IDKey Property (FCString)

Syntax

'Declaration

Public ReadOnly Property IDKey As String

public string IDKey {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCString Class
FCString Members


LocaleName Property | fcSDK Documentation

LocaleName Property

Syntax

'Declaration

Public ReadOnly Property LocaleName As String

public string LocaleName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCString Class
FCString Members


NameKey Property (FCString) | fcSDK Documentation

NameKey Property (FCString)

Syntax

'Declaration

Public ReadOnly Property NameKey As String

public string NameKey {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCString Class
FCString Members


StringID Property (FCString) | fcSDK Documentation

StringID Property (FCString)

Syntax

'Declaration

Public ReadOnly Property StringID As Integer

public int StringID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCString Class
FCString Members


Value Property (FCString) | fcSDK Documentation

Value Property (FCString)

Syntax

'Declaration

Public ReadOnly Property Value As String

public string Value {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCString Class
FCString Members


FCTimeZone Class | fcSDK Documentation

FCTimeZone Class

Syntax

'Declaration

Public Class FCTimeZone
   Inherits ClarifyDataObject
   Implements FChoice.Foundation.DataObjects.IDataObject, FChoice.Foundation.DataObjects.ITimeZone

public class FCTimeZone : ClarifyDataObject, FChoice.Foundation.DataObjects.IDataObject, FChoice.Foundation.DataObjects.ITimeZone

Inheritance Hierarchy

System.Object
FChoice.Foundation.DataObjects.DataObject
FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject
FChoice.Foundation.Clarify.DataObjects.FCTimeZone
FChoice.Foundation.DataObjects.FakeTimeZone

Requirements

Namespace: FChoice.Foundation.Clarify.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FCTimeZone Members
FChoice.Foundation.Clarify.DataObjects Namespace


FCTimeZone Class Members | fcSDK Documentation

FCTimeZone Class Members

The following tables list the members exposed by FCTimeZone.

Public Properties

 | Name | Description
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | DaylightSavingsPeriods |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | FullName |
Public Property | IsDefault |
Public Property | Name |
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | UtcOffsetSeconds |

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
static (Shared in Visual Basic) | ConvertDate | Overloaded.
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | IsDaylightSavingsTime |

Reference

FCTimeZone Class
FChoice.Foundation.Clarify.DataObjects Namespace


ConvertDate Method (FCTimeZone) | fcSDK Documentation

ConvertDate Method (FCTimeZone)

Overload List

Overload | Description
ConvertDate(DateTime,ITimeZone,ITimeZone) |
ConvertDate(DateTime,ITimeZone) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCTimeZone Class
FCTimeZone Members


ConvertDate(DateTime,ITimeZone,ITimeZone) Method | fcSDK Documentation

ConvertDate(DateTime,ITimeZone,ITimeZone) Method

Syntax

'Declaration

Public Overloads Shared Function ConvertDate( _
   ByVal _date_ As Date, _
   ByVal _fromZone_ As ITimeZone, _
   ByVal _toZone_ As ITimeZone _
) As Date

public static DateTime ConvertDate(
   DateTime _date_,
   ITimeZone _fromZone_,
   ITimeZone _toZone_
)

Parameters

date

fromZone

toZone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCTimeZone Class
FCTimeZone Members
Overload List


ConvertDate(DateTime,ITimeZone) Method | fcSDK Documentation

ConvertDate(DateTime,ITimeZone) Method

Syntax

'Declaration

Public Overloads Function ConvertDate( _
   ByVal _date_ As Date, _
   ByVal _toZone_ As ITimeZone _
) As Date

public DateTime ConvertDate(
   DateTime _date_,
   ITimeZone _toZone_
)

Parameters

date

toZone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCTimeZone Class
FCTimeZone Members
Overload List


IsDaylightSavingsTime Method (FCTimeZone) | fcSDK Documentation

IsDaylightSavingsTime Method (FCTimeZone)

Syntax

'Declaration

Public Function IsDaylightSavingsTime( _
   ByVal _testDate_ As Date _
) As Boolean

public bool IsDaylightSavingsTime(
   DateTime _testDate_
)

Parameters

testDate

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCTimeZone Class
FCTimeZone Members


DaylightSavingsPeriods Property | fcSDK Documentation

DaylightSavingsPeriods Property

Syntax

'Declaration

Public ReadOnly Property DaylightSavingsPeriods As DaylightSavingsCollection

public DaylightSavingsCollection DaylightSavingsPeriods {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCTimeZone Class
FCTimeZone Members


FullName Property (FCTimeZone) | fcSDK Documentation

FullName Property (FCTimeZone)

Syntax

'Declaration

Public ReadOnly Property FullName As String

public string FullName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCTimeZone Class
FCTimeZone Members


IsDefault Property (FCTimeZone) | fcSDK Documentation

IsDefault Property (FCTimeZone)

Syntax

'Declaration

Public ReadOnly Property IsDefault As Boolean

public bool IsDefault {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCTimeZone Class
FCTimeZone Members


Name Property (FCTimeZone) | fcSDK Documentation

Name Property (FCTimeZone)

Syntax

'Declaration

Public ReadOnly Property Name As String

public string Name {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCTimeZone Class
FCTimeZone Members


UtcOffsetSeconds Property (FCTimeZone) | fcSDK Documentation

UtcOffsetSeconds Property (FCTimeZone)

Syntax

'Declaration

Public ReadOnly Property UtcOffsetSeconds As Integer

public int UtcOffsetSeconds {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCTimeZone Class
FCTimeZone Members


FCTimeZoneCollection Class | fcSDK Documentation

FCTimeZoneCollection Class

Syntax

'Declaration

<DefaultMemberAttribute("Item")>
Public Class FCTimeZoneCollection
   Inherits FChoice.Foundation.DataObjects.DataObjectCollection(Of FCTimeZone)

[DefaultMemberAttribute("Item")]
public class FCTimeZoneCollection : FChoice.Foundation.DataObjects.DataObjectCollection<FCTimeZone>

Inheritance Hierarchy

System.Object
System.Collections.Generic.List
FChoice.Foundation.DataObjects.DataObjectCollection
FChoice.Foundation.Clarify.DataObjects.FCTimeZoneCollection

Requirements

Namespace: FChoice.Foundation.Clarify.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FCTimeZoneCollection Members
FChoice.Foundation.Clarify.DataObjects Namespace


FCTimeZoneCollection Class Members | fcSDK Documentation

FCTimeZoneCollection Class Members

The following tables list the members exposed by FCTimeZoneCollection.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | DefaultTimeZone |
Public Property | Item |

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | Overloaded.
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex | (Inherited from FChoice.Foundation.DataObjects.DataObjectCollection)
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

FCTimeZoneCollection Class
FChoice.Foundation.Clarify.DataObjects Namespace


Contains Method (FCTimeZoneCollection) | fcSDK Documentation

Contains Method (FCTimeZoneCollection)

Overload List

Overload | Description
Contains(String,Boolean) |
Contains(FCTimeZone) | (Inherited from System.Collections.Generic.List)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCTimeZoneCollection Class
FCTimeZoneCollection Members


Contains(String,Boolean) Method | fcSDK Documentation

Contains(String,Boolean) Method

Syntax

'Declaration

Public Overloads Function Contains( _
   ByVal _name_ As String, _
   ByVal _isFullName_ As Boolean _
) As Boolean

public bool Contains(
   string _name_,
   bool _isFullName_
)

Parameters

name

isFullName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCTimeZoneCollection Class
FCTimeZoneCollection Members
Overload List


DefaultTimeZone Property (FCTimeZoneCollection) | fcSDK Documentation

DefaultTimeZone Property (FCTimeZoneCollection)

Syntax

'Declaration

Public Property DefaultTimeZone As FCTimeZone

public FCTimeZone DefaultTimeZone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCTimeZoneCollection Class
FCTimeZoneCollection Members


Item Property (FCTimeZoneCollection) | fcSDK Documentation

Item Property (FCTimeZoneCollection)

Syntax

'Declaration

Public Shadows ReadOnly Default Property Item( _
   ByVal _name_ As String, _
   ByVal _isFullName_ As Boolean _
) As FCTimeZone

public new FCTimeZone this[
   string _name_,
   bool _isFullName_
]; {get;}

Parameters

name

isFullName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCTimeZoneCollection Class
FCTimeZoneCollection Members


GlobalStringElement Class | fcSDK Documentation

GlobalStringElement Class

Syntax

'Declaration

Public Class GlobalStringElement
   Inherits ClarifyDataObject
   Implements IGlobalStringElement, FChoice.Foundation.DataObjects.IDataObject

public class GlobalStringElement : ClarifyDataObject, IGlobalStringElement, FChoice.Foundation.DataObjects.IDataObject

Inheritance Hierarchy

System.Object
FChoice.Foundation.DataObjects.DataObject
FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject
FChoice.Foundation.Clarify.DataObjects.GlobalStringElement

Requirements

Namespace: FChoice.Foundation.Clarify.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

GlobalStringElement Members
FChoice.Foundation.Clarify.DataObjects Namespace


GlobalStringElement Class Members | fcSDK Documentation

GlobalStringElement Class Members

The following tables list the members exposed by GlobalStringElement.

Public Properties

 | Name | Description
Public Property | AdditionalInfo |
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Description |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | LocalizedTitle |
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | Rank |
Public Property | State |
Public Property | Title |
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetLocalizedTitle |
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

GlobalStringElement Class
FChoice.Foundation.Clarify.DataObjects Namespace


GetLocalizedTitle Method (GlobalStringElement) | fcSDK Documentation

GetLocalizedTitle Method (GlobalStringElement)

Syntax

'Declaration

Public Function GetLocalizedTitle( _
   ByVal _specificCulture_ As CultureInfo _
) As String

public string GetLocalizedTitle(
   CultureInfo _specificCulture_
)

Parameters

specificCulture

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GlobalStringElement Class
GlobalStringElement Members


AdditionalInfo Property (GlobalStringElement) | fcSDK Documentation

AdditionalInfo Property (GlobalStringElement)

Syntax

'Declaration

Public ReadOnly Property AdditionalInfo As String

public string AdditionalInfo {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GlobalStringElement Class
GlobalStringElement Members


Description Property (GlobalStringElement) | fcSDK Documentation

Description Property (GlobalStringElement)

Syntax

'Declaration

Public ReadOnly Property Description As String

public string Description {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GlobalStringElement Class
GlobalStringElement Members


LocalizedTitle Property (GlobalStringElement) | fcSDK Documentation

LocalizedTitle Property (GlobalStringElement)

Syntax

'Declaration

Public ReadOnly Property LocalizedTitle As String

public string LocalizedTitle {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GlobalStringElement Class
GlobalStringElement Members


Rank Property (GlobalStringElement) | fcSDK Documentation

Rank Property (GlobalStringElement)

Syntax

'Declaration

Public ReadOnly Property Rank As Integer

public int Rank {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GlobalStringElement Class
GlobalStringElement Members


State Property (GlobalStringElement) | fcSDK Documentation

State Property (GlobalStringElement)

Syntax

'Declaration

Public ReadOnly Property State As Integer

public int State {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GlobalStringElement Class
GlobalStringElement Members


Title Property (GlobalStringElement) | fcSDK Documentation

Title Property (GlobalStringElement)

Syntax

'Declaration

Public ReadOnly Property Title As String

public string Title {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GlobalStringElement Class
GlobalStringElement Members


GlobalStringElementCollection Class | fcSDK Documentation

GlobalStringElementCollection Class

Syntax

'Declaration

<DefaultMemberAttribute("Item")>
Public Class GlobalStringElementCollection
   Inherits FChoice.Foundation.DataObjects.DataObjectCollection(Of IGlobalStringElement)
   Implements IGlobalStringElementCollection

[DefaultMemberAttribute("Item")]
public class GlobalStringElementCollection : FChoice.Foundation.DataObjects.DataObjectCollection<IGlobalStringElement>, IGlobalStringElementCollection

Inheritance Hierarchy

System.Object
System.Collections.Generic.List
FChoice.Foundation.DataObjects.DataObjectCollection
FChoice.Foundation.Clarify.DataObjects.GlobalStringElementCollection

Requirements

Namespace: FChoice.Foundation.Clarify.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

GlobalStringElementCollection Members
FChoice.Foundation.Clarify.DataObjects Namespace


GlobalStringElementCollection Class Members | fcSDK Documentation

GlobalStringElementCollection Class Members

The following tables list the members exposed by GlobalStringElementCollection.

Public Properties

 | Name | Description
Public Property | ActiveElements |
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | DefaultElement |
Public Property | InactiveElements |
Public Property | Item |

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddElement |
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetElementByObjectId |
Public Method | GetElementByRank |
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex | (Inherited from FChoice.Foundation.DataObjects.DataObjectCollection)
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

GlobalStringElementCollection Class
FChoice.Foundation.Clarify.DataObjects Namespace


AddElement Method (GlobalStringElementCollection) | fcSDK Documentation

AddElement Method (GlobalStringElementCollection)

Syntax

'Declaration

Public Sub AddElement( _
   ByVal _element_ As IGlobalStringElement, _
   ByVal _addToList_ As Boolean _
)

public void AddElement(
   IGlobalStringElement _element_,
   bool _addToList_
)

Parameters

element

addToList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GlobalStringElementCollection Class
GlobalStringElementCollection Members


GetElementByObjectId Method (GlobalStringElementCollection) | fcSDK Documentation

GetElementByObjectId Method (GlobalStringElementCollection)

Syntax

'Declaration

Public Function GetElementByObjectId( _
   ByVal _objectId_ As Integer _
) As IGlobalStringElement

public IGlobalStringElement GetElementByObjectId(
   int _objectId_
)

Parameters

objectId

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GlobalStringElementCollection Class
GlobalStringElementCollection Members


GetElementByRank Method (GlobalStringElementCollection) | fcSDK Documentation

GetElementByRank Method (GlobalStringElementCollection)

Syntax

'Declaration

Public Function GetElementByRank( _
   ByVal _rank_ As Integer _
) As IGlobalStringElement

public IGlobalStringElement GetElementByRank(
   int _rank_
)

Parameters

rank

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GlobalStringElementCollection Class
GlobalStringElementCollection Members


ActiveElements Property (GlobalStringElementCollection) | fcSDK Documentation

ActiveElements Property (GlobalStringElementCollection)

Syntax

'Declaration

Public ReadOnly Property ActiveElements As IGlobalStringElementCollection

public IGlobalStringElementCollection ActiveElements {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GlobalStringElementCollection Class
GlobalStringElementCollection Members


DefaultElement Property (GlobalStringElementCollection) | fcSDK Documentation

DefaultElement Property (GlobalStringElementCollection)

Syntax

'Declaration

Public ReadOnly Property DefaultElement As IGlobalStringElement

public IGlobalStringElement DefaultElement {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GlobalStringElementCollection Class
GlobalStringElementCollection Members


InactiveElements Property (GlobalStringElementCollection) | fcSDK Documentation

InactiveElements Property (GlobalStringElementCollection)

Syntax

'Declaration

Public ReadOnly Property InactiveElements As IGlobalStringElementCollection

public IGlobalStringElementCollection InactiveElements {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GlobalStringElementCollection Class
GlobalStringElementCollection Members


Item Property (GlobalStringElementCollection) | fcSDK Documentation

Item Property (GlobalStringElementCollection)

Syntax

'Declaration

Public Shadows ReadOnly Default Property Item( _
   ByVal _title_ As String _
) As IGlobalStringElement

public new IGlobalStringElement this[
   string _title_
]; {get;}

Parameters

title

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GlobalStringElementCollection Class
GlobalStringElementCollection Members


GlobalStringList Class | fcSDK Documentation

GlobalStringList Class

Syntax

'Declaration

Public Class GlobalStringList
   Inherits ClarifyDataObject
   Implements IGlobalStringList, FChoice.Foundation.DataObjects.IDataObject

public class GlobalStringList : ClarifyDataObject, IGlobalStringList, FChoice.Foundation.DataObjects.IDataObject

Inheritance Hierarchy

System.Object
FChoice.Foundation.DataObjects.DataObject
FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject
FChoice.Foundation.Clarify.DataObjects.GlobalStringList

Requirements

Namespace: FChoice.Foundation.Clarify.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

GlobalStringList Members
FChoice.Foundation.Clarify.DataObjects Namespace


GlobalStringList Class Members | fcSDK Documentation

GlobalStringList Class Members

The following tables list the members exposed by GlobalStringList.

Public Properties

 | Name | Description
Public Property | ActiveElements |
Public Property | AdditionalInfo |
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | DefaultElement |
Public Property | Elements |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | InactiveElements |
Public Property | ListID |
Public Property | LocaleID |
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | Title |
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

GlobalStringList Class
FChoice.Foundation.Clarify.DataObjects Namespace


ActiveElements Property (GlobalStringList) | fcSDK Documentation

ActiveElements Property (GlobalStringList)

Syntax

'Declaration

Public ReadOnly Property ActiveElements As IGlobalStringElementCollection

public IGlobalStringElementCollection ActiveElements {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GlobalStringList Class
GlobalStringList Members


AdditionalInfo Property (GlobalStringList) | fcSDK Documentation

AdditionalInfo Property (GlobalStringList)

Syntax

'Declaration

Public ReadOnly Property AdditionalInfo As String

public string AdditionalInfo {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GlobalStringList Class
GlobalStringList Members


DefaultElement Property (GlobalStringList) | fcSDK Documentation

DefaultElement Property (GlobalStringList)

Syntax

'Declaration

Public ReadOnly Property DefaultElement As IGlobalStringElement

public IGlobalStringElement DefaultElement {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GlobalStringList Class
GlobalStringList Members


Elements Property (GlobalStringList) | fcSDK Documentation

Elements Property (GlobalStringList)

Syntax

'Declaration

Public ReadOnly Property Elements As IGlobalStringElementCollection

public IGlobalStringElementCollection Elements {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GlobalStringList Class
GlobalStringList Members


InactiveElements Property (GlobalStringList) | fcSDK Documentation

InactiveElements Property (GlobalStringList)

Syntax

'Declaration

Public ReadOnly Property InactiveElements As IGlobalStringElementCollection

public IGlobalStringElementCollection InactiveElements {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GlobalStringList Class
GlobalStringList Members


ListID Property (GlobalStringList) | fcSDK Documentation

ListID Property (GlobalStringList)

Syntax

'Declaration

Public ReadOnly Property ListID As Integer

public int ListID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GlobalStringList Class
GlobalStringList Members


LocaleID Property (GlobalStringList) | fcSDK Documentation

LocaleID Property (GlobalStringList)

Syntax

'Declaration

Public ReadOnly Property LocaleID As Integer

public int LocaleID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GlobalStringList Class
GlobalStringList Members


Title Property (GlobalStringList) | fcSDK Documentation

Title Property (GlobalStringList)

Syntax

'Declaration

Public ReadOnly Property Title As String

public string Title {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GlobalStringList Class
GlobalStringList Members


GlobalStringListCollection Class | fcSDK Documentation

GlobalStringListCollection Class

Syntax

'Declaration

<DefaultMemberAttribute("Item")>
Public Class GlobalStringListCollection
   Inherits FChoice.Foundation.DataObjects.DataObjectCollection(Of IGlobalStringList)
   Implements IGlobalStringListCollection

[DefaultMemberAttribute("Item")]
public class GlobalStringListCollection : FChoice.Foundation.DataObjects.DataObjectCollection<IGlobalStringList>, IGlobalStringListCollection

Inheritance Hierarchy

System.Object
System.Collections.Generic.List
FChoice.Foundation.DataObjects.DataObjectCollection
FChoice.Foundation.Clarify.DataObjects.GlobalStringListCollection

Requirements

Namespace: FChoice.Foundation.Clarify.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

GlobalStringListCollection Members
FChoice.Foundation.Clarify.DataObjects Namespace


GlobalStringListCollection Class Members | fcSDK Documentation

GlobalStringListCollection Class Members

The following tables list the members exposed by GlobalStringListCollection.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | Item |

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex | (Inherited from FChoice.Foundation.DataObjects.DataObjectCollection)
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

GlobalStringListCollection Class
FChoice.Foundation.Clarify.DataObjects Namespace


Item Property (GlobalStringListCollection) | fcSDK Documentation

Item Property (GlobalStringListCollection)

Syntax

'Declaration

Public Shadows ReadOnly Default Property Item( _
   ByVal _title_ As String _
) As IGlobalStringList

public new IGlobalStringList this[
   string _title_
]; {get;}

Parameters

title

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GlobalStringListCollection Class
GlobalStringListCollection Members


HierarchicalStringElement Class | fcSDK Documentation

HierarchicalStringElement Class

Syntax

'Declaration

Public Class HierarchicalStringElement
   Inherits ClarifyDataObject
   Implements IHierarchicalStringElement, FChoice.Foundation.DataObjects.IDataObject

public class HierarchicalStringElement : ClarifyDataObject, IHierarchicalStringElement, FChoice.Foundation.DataObjects.IDataObject

Inheritance Hierarchy

System.Object
FChoice.Foundation.DataObjects.DataObject
FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject
FChoice.Foundation.Clarify.DataObjects.HierarchicalStringElement

Requirements

Namespace: FChoice.Foundation.Clarify.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

HierarchicalStringElement Members
FChoice.Foundation.Clarify.DataObjects Namespace


HierarchicalStringElement Class Members | fcSDK Documentation

HierarchicalStringElement Class Members

The following tables list the members exposed by HierarchicalStringElement.

Public Fields

 | Name | Description
Public Field | ACTIVE_STATE |
Public Field | DEFAULT_STATE |
Public Field | INACTIVE_STATE |

Public Properties

 | Name | Description
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Elements |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | IsActive |
Public Property | IsDefault |
Public Property | LocalizedTitle |
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | Rank |
Public Property | State |
Public Property | Title |
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetLocalizedTitle |
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

HierarchicalStringElement Class
FChoice.Foundation.Clarify.DataObjects Namespace


GetLocalizedTitle Method (HierarchicalStringElement) | fcSDK Documentation

GetLocalizedTitle Method (HierarchicalStringElement)

Syntax

'Declaration

Public Function GetLocalizedTitle( _
   ByVal _specificCulture_ As CultureInfo _
) As String

public string GetLocalizedTitle(
   CultureInfo _specificCulture_
)

Parameters

specificCulture

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

HierarchicalStringElement Class
HierarchicalStringElement Members


Elements Property (HierarchicalStringElement) | fcSDK Documentation

Elements Property (HierarchicalStringElement)

Syntax

'Declaration

Public ReadOnly Property Elements As IHierarchicalStringElementCollection

public IHierarchicalStringElementCollection Elements {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

HierarchicalStringElement Class
HierarchicalStringElement Members


IsActive Property (HierarchicalStringElement) | fcSDK Documentation

IsActive Property (HierarchicalStringElement)

Syntax

'Declaration

Public ReadOnly Property IsActive As Boolean

public bool IsActive {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

HierarchicalStringElement Class
HierarchicalStringElement Members


IsDefault Property (HierarchicalStringElement) | fcSDK Documentation

IsDefault Property (HierarchicalStringElement)

Syntax

'Declaration

Public ReadOnly Property IsDefault As Boolean

public bool IsDefault {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

HierarchicalStringElement Class
HierarchicalStringElement Members


LocalizedTitle Property (HierarchicalStringElement) | fcSDK Documentation

LocalizedTitle Property (HierarchicalStringElement)

Syntax

'Declaration

Public ReadOnly Property LocalizedTitle As String

public string LocalizedTitle {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

HierarchicalStringElement Class
HierarchicalStringElement Members


Rank Property (HierarchicalStringElement) | fcSDK Documentation

Rank Property (HierarchicalStringElement)

Syntax

'Declaration

Public ReadOnly Property Rank As Integer

public int Rank {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

HierarchicalStringElement Class
HierarchicalStringElement Members


State Property (HierarchicalStringElement) | fcSDK Documentation

State Property (HierarchicalStringElement)

Syntax

'Declaration

Public ReadOnly Property State As String

public string State {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

HierarchicalStringElement Class
HierarchicalStringElement Members


Title Property (HierarchicalStringElement) | fcSDK Documentation

Title Property (HierarchicalStringElement)

Syntax

'Declaration

Public ReadOnly Property Title As String

public string Title {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

HierarchicalStringElement Class
HierarchicalStringElement Members


ACTIVE_STATE Field | fcSDK Documentation

ACTIVE_STATE Field

Syntax

'Declaration

Public Const ACTIVE_STATE As String

public const string ACTIVE_STATE

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

HierarchicalStringElement Class
HierarchicalStringElement Members


DEFAULT_STATE Field | fcSDK Documentation

DEFAULT_STATE Field

Syntax

'Declaration

Public Const DEFAULT_STATE As String

public const string DEFAULT_STATE

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

HierarchicalStringElement Class
HierarchicalStringElement Members


INACTIVE_STATE Field | fcSDK Documentation

INACTIVE_STATE Field

Syntax

'Declaration

Public Const INACTIVE_STATE As String

public const string INACTIVE_STATE

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

HierarchicalStringElement Class
HierarchicalStringElement Members


HierarchicalStringElementCollection Class | fcSDK Documentation

HierarchicalStringElementCollection Class

Syntax

'Declaration

<DefaultMemberAttribute("Item")>
Public Class HierarchicalStringElementCollection
   Inherits FChoice.Foundation.DataObjects.DataObjectCollection(Of IHierarchicalStringElement)
   Implements IHierarchicalStringElementCollection

[DefaultMemberAttribute("Item")]
public class HierarchicalStringElementCollection : FChoice.Foundation.DataObjects.DataObjectCollection<IHierarchicalStringElement>, IHierarchicalStringElementCollection

Inheritance Hierarchy

System.Object
System.Collections.Generic.List
FChoice.Foundation.DataObjects.DataObjectCollection
FChoice.Foundation.Clarify.DataObjects.HierarchicalStringElementCollection

Requirements

Namespace: FChoice.Foundation.Clarify.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

HierarchicalStringElementCollection Members
FChoice.Foundation.Clarify.DataObjects Namespace


HierarchicalStringElementCollection Class Members | fcSDK Documentation

HierarchicalStringElementCollection Class Members

The following tables list the members exposed by HierarchicalStringElementCollection.

Public Properties

 | Name | Description
Public Property | ActiveElements |
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | DefaultElement |
Public Property | Item |

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetByObjID |
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex | (Inherited from FChoice.Foundation.DataObjects.DataObjectCollection)
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

HierarchicalStringElementCollection Class
FChoice.Foundation.Clarify.DataObjects Namespace


GetByObjID Method (HierarchicalStringElementCollection) | fcSDK Documentation

GetByObjID Method (HierarchicalStringElementCollection)

Syntax

'Declaration

Public Function GetByObjID( _
   ByVal _objectID_ As Integer _
) As IHierarchicalStringElement

public IHierarchicalStringElement GetByObjID(
   int _objectID_
)

Parameters

objectID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

HierarchicalStringElementCollection Class
HierarchicalStringElementCollection Members


ActiveElements Property (HierarchicalStringElementCollection) | fcSDK Documentation

ActiveElements Property (HierarchicalStringElementCollection)

Syntax

'Declaration

Public ReadOnly Property ActiveElements As HierarchicalStringElementCollection

public HierarchicalStringElementCollection ActiveElements {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

HierarchicalStringElementCollection Class
HierarchicalStringElementCollection Members


DefaultElement Property (HierarchicalStringElementCollection) | fcSDK Documentation

DefaultElement Property (HierarchicalStringElementCollection)

Syntax

'Declaration

Public Property DefaultElement As IHierarchicalStringElement

public IHierarchicalStringElement DefaultElement {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

HierarchicalStringElementCollection Class
HierarchicalStringElementCollection Members


Item Property (HierarchicalStringElementCollection) | fcSDK Documentation

Item Property (HierarchicalStringElementCollection)

Syntax

'Declaration

Public Shadows ReadOnly Default Property Item( _
   ByVal _title_ As String _
) As IHierarchicalStringElement

public new IHierarchicalStringElement this[
   string _title_
]; {get;}

Parameters

title

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

HierarchicalStringElementCollection Class
HierarchicalStringElementCollection Members


HierarchicalStringList Class | fcSDK Documentation

HierarchicalStringList Class

Syntax

'Declaration

Public Class HierarchicalStringList
   Inherits ClarifyDataObject
   Implements IHierarchicalStringList, FChoice.Foundation.DataObjects.IDataObject

public class HierarchicalStringList : ClarifyDataObject, IHierarchicalStringList, FChoice.Foundation.DataObjects.IDataObject

Inheritance Hierarchy

System.Object
FChoice.Foundation.DataObjects.DataObject
FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject
FChoice.Foundation.Clarify.DataObjects.HierarchicalStringList

Requirements

Namespace: FChoice.Foundation.Clarify.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

HierarchicalStringList Members
FChoice.Foundation.Clarify.DataObjects Namespace


HierarchicalStringList Class Members | fcSDK Documentation

HierarchicalStringList Class Members

The following tables list the members exposed by HierarchicalStringList.

Public Properties

 | Name | Description
Public Property | ActiveElements |
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Description |
Public Property | Elements |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | InactiveElements |
Public Property | ListID |
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | Title |
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

HierarchicalStringList Class
FChoice.Foundation.Clarify.DataObjects Namespace


ActiveElements Property (HierarchicalStringList) | fcSDK Documentation

ActiveElements Property (HierarchicalStringList)

Syntax

'Declaration

Public ReadOnly Property ActiveElements As IHierarchicalStringElementCollection

public IHierarchicalStringElementCollection ActiveElements {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

HierarchicalStringList Class
HierarchicalStringList Members


Description Property (HierarchicalStringList) | fcSDK Documentation

Description Property (HierarchicalStringList)

Syntax

'Declaration

Public ReadOnly Property Description As String

public string Description {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

HierarchicalStringList Class
HierarchicalStringList Members


Elements Property (HierarchicalStringList) | fcSDK Documentation

Elements Property (HierarchicalStringList)

Syntax

'Declaration

Public ReadOnly Property Elements As IHierarchicalStringElementCollection

public IHierarchicalStringElementCollection Elements {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

HierarchicalStringList Class
HierarchicalStringList Members


InactiveElements Property (HierarchicalStringList) | fcSDK Documentation

InactiveElements Property (HierarchicalStringList)

Syntax

'Declaration

Public ReadOnly Property InactiveElements As IHierarchicalStringElementCollection

public IHierarchicalStringElementCollection InactiveElements {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

HierarchicalStringList Class
HierarchicalStringList Members


ListID Property (HierarchicalStringList) | fcSDK Documentation

ListID Property (HierarchicalStringList)

Syntax

'Declaration

Public ReadOnly Property ListID As Integer

public int ListID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

HierarchicalStringList Class
HierarchicalStringList Members


Title Property (HierarchicalStringList) | fcSDK Documentation

Title Property (HierarchicalStringList)

Syntax

'Declaration

Public ReadOnly Property Title As String

public string Title {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

HierarchicalStringList Class
HierarchicalStringList Members


HierarchicalStringListCollection Class | fcSDK Documentation

HierarchicalStringListCollection Class

Syntax

'Declaration

<DefaultMemberAttribute("Item")>
Public Class HierarchicalStringListCollection
   Inherits FChoice.Foundation.DataObjects.DataObjectCollection(Of IHierarchicalStringList)
   Implements IHierarchicalStringListCollection

[DefaultMemberAttribute("Item")]
public class HierarchicalStringListCollection : FChoice.Foundation.DataObjects.DataObjectCollection<IHierarchicalStringList>, IHierarchicalStringListCollection

Inheritance Hierarchy

System.Object
System.Collections.Generic.List
FChoice.Foundation.DataObjects.DataObjectCollection
FChoice.Foundation.Clarify.DataObjects.HierarchicalStringListCollection

Requirements

Namespace: FChoice.Foundation.Clarify.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

HierarchicalStringListCollection Members
FChoice.Foundation.Clarify.DataObjects Namespace


HierarchicalStringListCollection Class Members | fcSDK Documentation

HierarchicalStringListCollection Class Members

The following tables list the members exposed by HierarchicalStringListCollection.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | Item |

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex | (Inherited from FChoice.Foundation.DataObjects.DataObjectCollection)
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

HierarchicalStringListCollection Class
FChoice.Foundation.Clarify.DataObjects Namespace


Item Property (HierarchicalStringListCollection) | fcSDK Documentation

Item Property (HierarchicalStringListCollection)

Syntax

'Declaration

Public Shadows ReadOnly Default Property Item( _
   ByVal _title_ As String _
) As IHierarchicalStringList

public new IHierarchicalStringList this[
   string _title_
]; {get;}

Parameters

title

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

HierarchicalStringListCollection Class
HierarchicalStringListCollection Members


HierarchicalStringShow Class | fcSDK Documentation

HierarchicalStringShow Class

Syntax

'Declaration

Public Class HierarchicalStringShow
   Inherits ClarifyDataObject
   Implements FChoice.Foundation.DataObjects.IDataObject

public class HierarchicalStringShow : ClarifyDataObject, FChoice.Foundation.DataObjects.IDataObject

Inheritance Hierarchy

System.Object
FChoice.Foundation.DataObjects.DataObject
FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject
FChoice.Foundation.Clarify.DataObjects.HierarchicalStringShow

Requirements

Namespace: FChoice.Foundation.Clarify.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

HierarchicalStringShow Members
FChoice.Foundation.Clarify.DataObjects Namespace


HierarchicalStringShow Class Members | fcSDK Documentation

HierarchicalStringShow Class Members

The following tables list the members exposed by HierarchicalStringShow.

Public Properties

 | Name | Description
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | DefaultElement |
Public Property | Elements |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | LastModifiedTime |
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | Title |
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

HierarchicalStringShow Class
FChoice.Foundation.Clarify.DataObjects Namespace


DefaultElement Property (HierarchicalStringShow) | fcSDK Documentation

DefaultElement Property (HierarchicalStringShow)

Syntax

'Declaration

Public ReadOnly Property DefaultElement As IHierarchicalStringElement

public IHierarchicalStringElement DefaultElement {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

HierarchicalStringShow Class
HierarchicalStringShow Members


Elements Property (HierarchicalStringShow) | fcSDK Documentation

Elements Property (HierarchicalStringShow)

Syntax

'Declaration

Public ReadOnly Property Elements As HierarchicalStringElementCollection

public HierarchicalStringElementCollection Elements {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

HierarchicalStringShow Class
HierarchicalStringShow Members


LastModifiedTime Property | fcSDK Documentation

LastModifiedTime Property

Syntax

'Declaration

Public ReadOnly Property LastModifiedTime As Date

public DateTime LastModifiedTime {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

HierarchicalStringShow Class
HierarchicalStringShow Members


Title Property (HierarchicalStringShow) | fcSDK Documentation

Title Property (HierarchicalStringShow)

Syntax

'Declaration

Public ReadOnly Property Title As String

public string Title {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

HierarchicalStringShow Class
HierarchicalStringShow Members


LocalizedString Class | fcSDK Documentation

LocalizedString Class

Syntax

'Declaration

Public Class LocalizedString
   Inherits ClarifyDataObject
   Implements FChoice.Foundation.DataObjects.IDataObject

public class LocalizedString : ClarifyDataObject, FChoice.Foundation.DataObjects.IDataObject

Inheritance Hierarchy

System.Object
FChoice.Foundation.DataObjects.DataObject
FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject
FChoice.Foundation.Clarify.DataObjects.LocalizedString

Requirements

Namespace: FChoice.Foundation.Clarify.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

LocalizedString Members
FChoice.Foundation.Clarify.DataObjects Namespace


LocalizedString Class Members | fcSDK Documentation

LocalizedString Class Members

The following tables list the members exposed by LocalizedString.

Public Properties

 | Name | Description
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Culture |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | IDKey |
Public Property | LocaleID |
Public Property | Name |
Public Property | NameKey |
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | StringID |
Public Property | StringType |
Public Property | TranslateIndicator |
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Value |

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

LocalizedString Class
FChoice.Foundation.Clarify.DataObjects Namespace


Culture Property (LocalizedString) | fcSDK Documentation

Culture Property (LocalizedString)

Syntax

'Declaration

Public ReadOnly Property Culture As CultureInfo

public CultureInfo Culture {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocalizedString Class
LocalizedString Members


IDKey Property (LocalizedString) | fcSDK Documentation

IDKey Property (LocalizedString)

Syntax

'Declaration

Public ReadOnly Property IDKey As String

public string IDKey {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocalizedString Class
LocalizedString Members


LocaleID Property (LocalizedString) | fcSDK Documentation

LocaleID Property (LocalizedString)

Syntax

'Declaration

Public ReadOnly Property LocaleID As Integer

public int LocaleID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocalizedString Class
LocalizedString Members


Name Property (LocalizedString) | fcSDK Documentation

Name Property (LocalizedString)

Syntax

'Declaration

Public ReadOnly Property Name As String

public string Name {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocalizedString Class
LocalizedString Members


NameKey Property (LocalizedString) | fcSDK Documentation

NameKey Property (LocalizedString)

Syntax

'Declaration

Public ReadOnly Property NameKey As String

public string NameKey {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocalizedString Class
LocalizedString Members


StringID Property (LocalizedString) | fcSDK Documentation

StringID Property (LocalizedString)

Syntax

'Declaration

Public ReadOnly Property StringID As Integer

public int StringID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocalizedString Class
LocalizedString Members


StringType Property | fcSDK Documentation

StringType Property

Syntax

'Declaration

Public ReadOnly Property StringType As Integer

public int StringType {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocalizedString Class
LocalizedString Members


TranslateIndicator Property | fcSDK Documentation

TranslateIndicator Property

Syntax

'Declaration

Public ReadOnly Property TranslateIndicator As Integer

public int TranslateIndicator {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocalizedString Class
LocalizedString Members


Value Property (LocalizedString) | fcSDK Documentation

Value Property (LocalizedString)

Syntax

'Declaration

Public ReadOnly Property Value As String

public string Value {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocalizedString Class
LocalizedString Members


StateCollection Class | fcSDK Documentation

StateCollection Class

Syntax

'Declaration

<DefaultMemberAttribute("Item")>
Public Class StateCollection
   Inherits FChoice.Foundation.DataObjects.DataObjectCollection(Of StateProvince)

[DefaultMemberAttribute("Item")]
public class StateCollection : FChoice.Foundation.DataObjects.DataObjectCollection<StateProvince>

Inheritance Hierarchy

System.Object
System.Collections.Generic.List
FChoice.Foundation.DataObjects.DataObjectCollection
FChoice.Foundation.Clarify.DataObjects.StateCollection

Requirements

Namespace: FChoice.Foundation.Clarify.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

StateCollection Members
FChoice.Foundation.Clarify.DataObjects Namespace


StateCollection Class Members | fcSDK Documentation

StateCollection Class Members

The following tables list the members exposed by StateCollection.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | DefaultState |
Public Property | Item |

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex | (Inherited from FChoice.Foundation.DataObjects.DataObjectCollection)
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

StateCollection Class
FChoice.Foundation.Clarify.DataObjects Namespace


DefaultState Property (StateCollection) | fcSDK Documentation

DefaultState Property (StateCollection)

Syntax

'Declaration

Public ReadOnly Property DefaultState As StateProvince

public StateProvince DefaultState {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StateCollection Class
StateCollection Members


Item Property (StateCollection) | fcSDK Documentation

Item Property (StateCollection)

Syntax

'Declaration

Public Shadows ReadOnly Default Property Item( _
   ByVal _name_ As String, _
   ByVal _isFullName_ As Boolean _
) As StateProvince

public new StateProvince this[
   string _name_,
   bool _isFullName_
]; {get;}

Parameters

name

isFullName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StateCollection Class
StateCollection Members


StateProvince Class | fcSDK Documentation

StateProvince Class

Syntax

'Declaration

Public Class StateProvince
   Inherits ClarifyDataObject
   Implements FChoice.Foundation.DataObjects.IDataObject

public class StateProvince : ClarifyDataObject, FChoice.Foundation.DataObjects.IDataObject

Inheritance Hierarchy

System.Object
FChoice.Foundation.DataObjects.DataObject
FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject
FChoice.Foundation.Clarify.DataObjects.StateProvince

Requirements

Namespace: FChoice.Foundation.Clarify.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

StateProvince Members
FChoice.Foundation.Clarify.DataObjects Namespace


StateProvince Class Members | fcSDK Documentation

StateProvince Class Members

The following tables list the members exposed by StateProvince.

Public Properties

 | Name | Description
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | DisplayOrder |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | FullName |
Public Property | IsDefault |
Public Property | Name |
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

StateProvince Class
FChoice.Foundation.Clarify.DataObjects Namespace


DisplayOrder Property | fcSDK Documentation

DisplayOrder Property

Syntax

'Declaration

Public ReadOnly Property DisplayOrder As Integer

public int DisplayOrder {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StateProvince Class
StateProvince Members


FullName Property (StateProvince) | fcSDK Documentation

FullName Property (StateProvince)

Syntax

'Declaration

Public ReadOnly Property FullName As String

public string FullName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StateProvince Class
StateProvince Members


IsDefault Property (StateProvince) | fcSDK Documentation

IsDefault Property (StateProvince)

Syntax

'Declaration

Public ReadOnly Property IsDefault As Boolean

public bool IsDefault {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StateProvince Class
StateProvince Members


Name Property (StateProvince) | fcSDK Documentation

Name Property (StateProvince)

Syntax

'Declaration

Public ReadOnly Property Name As String

public string Name {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StateProvince Class
StateProvince Members


IGlobalStringElement Interface | fcSDK Documentation

IGlobalStringElement Interface

Syntax

'Declaration

Public Interface IGlobalStringElement
   Inherits FChoice.Foundation.DataObjects.IDataObject

public interface IGlobalStringElement : FChoice.Foundation.DataObjects.IDataObject

Requirements

Namespace: FChoice.Foundation.Clarify.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

IGlobalStringElement Members
FChoice.Foundation.Clarify.DataObjects Namespace


IGlobalStringElement Interface Members | fcSDK Documentation

IGlobalStringElement Interface Members

The following tables list the members exposed by IGlobalStringElement.

Public Properties

 | Name | Description
Property | AdditionalInfo |
Property | Description |
Property | LocalizedTitle |
Property | ObjectID |
Property | Rank |
Property | State |
Property | Title |

Public Methods

 | Name | Description
Method | GetLocalizedTitle |

Reference

IGlobalStringElement Interface
FChoice.Foundation.Clarify.DataObjects Namespace


GetLocalizedTitle Method (IGlobalStringElement) | fcSDK Documentation

GetLocalizedTitle Method (IGlobalStringElement)

Syntax

'Declaration

Function GetLocalizedTitle( _
   ByVal _specificCulture_ As CultureInfo _
) As String

string GetLocalizedTitle(
   CultureInfo _specificCulture_
)

Parameters

specificCulture

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElement Interface
IGlobalStringElement Members


AdditionalInfo Property (IGlobalStringElement) | fcSDK Documentation

AdditionalInfo Property (IGlobalStringElement)

Syntax

'Declaration
ReadOnly Property AdditionalInfo As String

string AdditionalInfo {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElement Interface
IGlobalStringElement Members


Description Property (IGlobalStringElement) | fcSDK Documentation

Description Property (IGlobalStringElement)

Syntax

'Declaration
ReadOnly Property Description As String

string Description {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElement Interface
IGlobalStringElement Members


LocalizedTitle Property (IGlobalStringElement) | fcSDK Documentation

LocalizedTitle Property (IGlobalStringElement)

Syntax

'Declaration

ReadOnly Property LocalizedTitle As String

string LocalizedTitle {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElement Interface
IGlobalStringElement Members


ObjectID Property (IGlobalStringElement) | fcSDK Documentation

ObjectID Property (IGlobalStringElement)

Syntax

'Declaration
ReadOnly Property ObjectID As Integer

int ObjectID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElement Interface
IGlobalStringElement Members


Rank Property (IGlobalStringElement) | fcSDK Documentation

Rank Property (IGlobalStringElement)

Syntax

'Declaration
ReadOnly Property Rank As Integer

int Rank {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElement Interface
IGlobalStringElement Members


State Property (IGlobalStringElement) | fcSDK Documentation

State Property (IGlobalStringElement)

Syntax

'Declaration

ReadOnly Property State As Integer

int State {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElement Interface
IGlobalStringElement Members


Title Property (IGlobalStringElement) | fcSDK Documentation

Title Property (IGlobalStringElement)

Syntax

'Declaration

ReadOnly Property Title As String

string Title {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElement Interface
IGlobalStringElement Members


IGlobalStringElementCollection Interface | fcSDK Documentation

IGlobalStringElementCollection Interface

Syntax

'Declaration

<DefaultMemberAttribute("Item")>
Public Interface IGlobalStringElementCollection

[DefaultMemberAttribute("Item")]
public interface IGlobalStringElementCollection

Requirements

Namespace: FChoice.Foundation.Clarify.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

IGlobalStringElementCollection Members
FChoice.Foundation.Clarify.DataObjects Namespace


IGlobalStringElementCollection Interface Members | fcSDK Documentation

IGlobalStringElementCollection Interface Members

The following tables list the members exposed by IGlobalStringElementCollection.

Public Properties

 | Name | Description
Property | ActiveElements |
Property | Capacity |
Property | DefaultElement |
Property | InactiveElements |
Property | Item |

Public Methods

 | Name | Description
Method | AddElement |
Method | AddRange |
Method | AsReadOnly |
Method | BinarySearch | Overloaded.
Method | CopyTo | Overloaded.
Method | Exists |
Method | Find |
Method | FindAll |
Method | FindIndex | Overloaded.
Method | FindLast |
Method | FindLastIndex | Overloaded.
Method | ForEach |
Method | GetElementByObjectId |
Method | GetElementByRank |
Method | GetItemByIndex |
Method | GetRange |
Method | IndexOf | Overloaded.
Method | InsertRange |
Method | LastIndexOf | Overloaded.
Method | RemoveAll |
Method | RemoveRange |
Method | Reverse | Overloaded.
Method | Sort | Overloaded.
Method | ToArray |
Method | TrimExcess |
Method | TrueForAll |

Reference

IGlobalStringElementCollection Interface
FChoice.Foundation.Clarify.DataObjects Namespace


AddElement Method (IGlobalStringElementCollection) | fcSDK Documentation

AddElement Method (IGlobalStringElementCollection)

Syntax

'Declaration

Sub AddElement( _
   ByVal _element_ As IGlobalStringElement, _
   ByVal _addToList_ As Boolean _
)

void AddElement(
   IGlobalStringElement _element_,
   bool _addToList_
)

Parameters

element

addToList

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members


AddRange Method (IGlobalStringElementCollection) | fcSDK Documentation

AddRange Method (IGlobalStringElementCollection)

Syntax

'Declaration

Sub AddRange( _
   ByVal _collection_ As IEnumerable(Of IGlobalStringElement) _
)

void AddRange(
   IEnumerable<IGlobalStringElement> _collection_
)

Parameters

collection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members


AsReadOnly Method (IGlobalStringElementCollection) | fcSDK Documentation

AsReadOnly Method (IGlobalStringElementCollection)

Syntax

'Declaration

Function AsReadOnly() As ReadOnlyCollection(Of IGlobalStringElement)

ReadOnlyCollection<IGlobalStringElement> AsReadOnly()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members


BinarySearch Method (IGlobalStringElementCollection) | fcSDK Documentation

BinarySearch Method (IGlobalStringElementCollection)

Overload List

Overload | Description
BinarySearch(Int32,Int32,IGlobalStringElement,IComparer) |
BinarySearch(IGlobalStringElement) |
BinarySearch(IGlobalStringElement,IComparer) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members


BinarySearch(Int32,Int32,IGlobalStringElement,IComparer) Method | fcSDK Documentation

BinarySearch(Int32,Int32,IGlobalStringElement,IComparer) Method

Syntax

'Declaration

Overloads Function BinarySearch( _
   ByVal _index_ As Integer, _
   ByVal _count_ As Integer, _
   ByVal _item_ As IGlobalStringElement, _
   ByVal _comparer_ As IComparer(Of IGlobalStringElement) _
) As Integer

int BinarySearch(
   int _index_,
   int _count_,
   IGlobalStringElement _item_,
   IComparer<IGlobalStringElement> _comparer_
)

Parameters

index

count

item

comparer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members
Overload List


BinarySearch(IGlobalStringElement) Method | fcSDK Documentation

BinarySearch(IGlobalStringElement) Method

Syntax

'Declaration

Overloads Function BinarySearch( _
   ByVal _item_ As IGlobalStringElement _
) As Integer

int BinarySearch(
   IGlobalStringElement _item_
)

Parameters

item

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members
Overload List


BinarySearch(IGlobalStringElement,IComparer) Method | fcSDK Documentation

BinarySearch(IGlobalStringElement,IComparer) Method

Syntax

'Declaration

Overloads Function BinarySearch( _
   ByVal _item_ As IGlobalStringElement, _
   ByVal _comparer_ As IComparer(Of IGlobalStringElement) _
) As Integer

int BinarySearch(
   IGlobalStringElement _item_,
   IComparer<IGlobalStringElement> _comparer_
)

Parameters

item

comparer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members
Overload List


CopyTo Method (IGlobalStringElementCollection) | fcSDK Documentation

CopyTo Method (IGlobalStringElementCollection)

Overload List

Overload | Description
CopyTo(IGlobalStringElement[]) |
CopyTo(Int32,IGlobalStringElement[],Int32,Int32) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members


CopyTo(IGlobalStringElement[]) Method | fcSDK Documentation

CopyTo(IGlobalStringElement[]) Method

Syntax

'Declaration

Overloads Sub CopyTo( _
   ByVal _array_() As IGlobalStringElement _
)

void CopyTo(
   IGlobalStringElement[] _array_
)

Parameters

array

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members
Overload List


CopyTo(Int32,IGlobalStringElement[],Int32,Int32) Method | fcSDK Documentation

CopyTo(Int32,IGlobalStringElement[],Int32,Int32) Method

Syntax

'Declaration

Overloads Sub CopyTo( _
   ByVal _index_ As Integer, _
   ByVal _array_() As IGlobalStringElement, _
   ByVal _arrayIndex_ As Integer, _
   ByVal _count_ As Integer _
)

void CopyTo(
   int _index_,
   IGlobalStringElement[] _array_,
   int _arrayIndex_,
   int _count_
)

Parameters

index

array

arrayIndex

count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members
Overload List


Exists Method (IGlobalStringElementCollection) | fcSDK Documentation

Exists Method (IGlobalStringElementCollection)

Syntax

'Declaration

Function Exists( _
   ByVal _match_ As Predicate(Of IGlobalStringElement) _
) As Boolean

bool Exists(
   Predicate<IGlobalStringElement> _match_
)

Parameters

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members


Find Method (IGlobalStringElementCollection) | fcSDK Documentation

Find Method (IGlobalStringElementCollection)

Syntax

'Declaration
Function Find( _
   ByVal _match_ As Predicate(Of IGlobalStringElement) _
) As IGlobalStringElement

IGlobalStringElement Find(
   Predicate<IGlobalStringElement> _match_
)

Parameters

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members


FindAll Method (IGlobalStringElementCollection) | fcSDK Documentation

FindAll Method (IGlobalStringElementCollection)

Syntax

'Declaration
Function FindAll( _
   ByVal _match_ As Predicate(Of IGlobalStringElement) _
) As List(Of IGlobalStringElement)

List<IGlobalStringElement> FindAll(
   Predicate<IGlobalStringElement> _match_
)

Parameters

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members


FindIndex Method (IGlobalStringElementCollection) | fcSDK Documentation

FindIndex Method (IGlobalStringElementCollection)

Overload List

Overload | Description
FindIndex(Predicate) |
FindIndex(Int32,Predicate) |
FindIndex(Int32,Int32,Predicate) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members


FindIndex(Predicate) Method | fcSDK Documentation

FindIndex(Predicate) Method

Syntax

'Declaration

Overloads Function FindIndex( _
   ByVal _match_ As Predicate(Of IGlobalStringElement) _
) As Integer

int FindIndex(
   Predicate<IGlobalStringElement> _match_
)

Parameters

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members
Overload List


FindIndex(Int32,Predicate) Method | fcSDK Documentation

FindIndex(Int32,Predicate) Method

Syntax

'Declaration

Overloads Function FindIndex( _
   ByVal _startIndex_ As Integer, _
   ByVal _match_ As Predicate(Of IGlobalStringElement) _
) As Integer

int FindIndex(
   int _startIndex_,
   Predicate<IGlobalStringElement> _match_
)

Parameters

startIndex

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members
Overload List


FindIndex(Int32,Int32,Predicate) Method | fcSDK Documentation

FindIndex(Int32,Int32,Predicate) Method

Syntax

'Declaration

Overloads Function FindIndex( _
   ByVal _startIndex_ As Integer, _
   ByVal _count_ As Integer, _
   ByVal _match_ As Predicate(Of IGlobalStringElement) _
) As Integer

int FindIndex(
   int _startIndex_,
   int _count_,
   Predicate<IGlobalStringElement> _match_
)

Parameters

startIndex

count

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members
Overload List


FindLast Method (IGlobalStringElementCollection) | fcSDK Documentation

FindLast Method (IGlobalStringElementCollection)

Syntax

'Declaration

Function FindLast( _
   ByVal _match_ As Predicate(Of IGlobalStringElement) _
) As IGlobalStringElement

IGlobalStringElement FindLast(
   Predicate<IGlobalStringElement> _match_
)

Parameters

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members


FindLastIndex Method (IGlobalStringElementCollection) | fcSDK Documentation

FindLastIndex Method (IGlobalStringElementCollection)

Overload List

Overload | Description
FindLastIndex(Predicate) |
FindLastIndex(Int32,Predicate) |
FindLastIndex(Int32,Int32,Predicate) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members


FindLastIndex(Predicate) Method | fcSDK Documentation

FindLastIndex(Predicate) Method

Syntax

'Declaration

Overloads Function FindLastIndex( _
   ByVal _match_ As Predicate(Of IGlobalStringElement) _
) As Integer

int FindLastIndex(
   Predicate<IGlobalStringElement> _match_
)

Parameters

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members
Overload List


FindLastIndex(Int32,Predicate) Method | fcSDK Documentation

FindLastIndex(Int32,Predicate) Method

Syntax

'Declaration

Overloads Function FindLastIndex( _
   ByVal _startIndex_ As Integer, _
   ByVal _match_ As Predicate(Of IGlobalStringElement) _
) As Integer

int FindLastIndex(
   int _startIndex_,
   Predicate<IGlobalStringElement> _match_
)

Parameters

startIndex

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members
Overload List


FindLastIndex(Int32,Int32,Predicate) Method | fcSDK Documentation

FindLastIndex(Int32,Int32,Predicate) Method

Syntax

'Declaration

Overloads Function FindLastIndex( _
   ByVal _startIndex_ As Integer, _
   ByVal _count_ As Integer, _
   ByVal _match_ As Predicate(Of IGlobalStringElement) _
) As Integer

int FindLastIndex(
   int _startIndex_,
   int _count_,
   Predicate<IGlobalStringElement> _match_
)

Parameters

startIndex

count

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members
Overload List


ForEach Method (IGlobalStringElementCollection) | fcSDK Documentation

ForEach Method (IGlobalStringElementCollection)

Syntax

'Declaration
Sub ForEach( _
   ByVal _action_ As Action(Of IGlobalStringElement) _
)

void ForEach(
   Action<IGlobalStringElement> _action_
)

Parameters

action

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members


GetElementByObjectId Method (IGlobalStringElementCollection) | fcSDK Documentation

GetElementByObjectId Method (IGlobalStringElementCollection)

Syntax

'Declaration
Function GetElementByObjectId( _
   ByVal _objectId_ As Integer _
) As IGlobalStringElement

IGlobalStringElement GetElementByObjectId(
   int _objectId_
)

Parameters

objectId

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members


GetElementByRank Method (IGlobalStringElementCollection) | fcSDK Documentation

GetElementByRank Method (IGlobalStringElementCollection)

Syntax

'Declaration
Function GetElementByRank( _
   ByVal _rank_ As Integer _
) As IGlobalStringElement

IGlobalStringElement GetElementByRank(
   int _rank_
)

Parameters

rank

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members


GetItemByIndex Method (IGlobalStringElementCollection) | fcSDK Documentation

GetItemByIndex Method (IGlobalStringElementCollection)

Syntax

'Declaration

Function GetItemByIndex( _
   ByVal _index_ As Integer _
) As IGlobalStringElement

IGlobalStringElement GetItemByIndex(
   int _index_
)

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members


GetRange Method (IGlobalStringElementCollection) | fcSDK Documentation

GetRange Method (IGlobalStringElementCollection)

Syntax

'Declaration

Function GetRange( _
   ByVal _index_ As Integer, _
   ByVal _count_ As Integer _
) As List(Of IGlobalStringElement)

List<IGlobalStringElement> GetRange(
   int _index_,
   int _count_
)

Parameters

index

count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members


IndexOf Method (IGlobalStringElementCollection) | fcSDK Documentation

IndexOf Method (IGlobalStringElementCollection)

Overload List

Overload | Description
IndexOf(IGlobalStringElement,Int32) |
IndexOf(IGlobalStringElement,Int32,Int32) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members


IndexOf(IGlobalStringElement,Int32) Method | fcSDK Documentation

IndexOf(IGlobalStringElement,Int32) Method

Syntax

'Declaration

Overloads Function IndexOf( _
   ByVal _item_ As IGlobalStringElement, _
   ByVal _index_ As Integer _
) As Integer

int IndexOf(
   IGlobalStringElement _item_,
   int _index_
)

Parameters

item

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members
Overload List


IndexOf(IGlobalStringElement,Int32,Int32) Method | fcSDK Documentation

IndexOf(IGlobalStringElement,Int32,Int32) Method

Syntax

'Declaration

Overloads Function IndexOf( _
   ByVal _item_ As IGlobalStringElement, _
   ByVal _index_ As Integer, _
   ByVal _count_ As Integer _
) As Integer

int IndexOf(
   IGlobalStringElement _item_,
   int _index_,
   int _count_
)

Parameters

item

index

count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members
Overload List


InsertRange Method (IGlobalStringElementCollection) | fcSDK Documentation

InsertRange Method (IGlobalStringElementCollection)

Syntax

'Declaration

Sub InsertRange( _
   ByVal _index_ As Integer, _
   ByVal _collection_ As IEnumerable(Of IGlobalStringElement) _
)

void InsertRange(
   int _index_,
   IEnumerable<IGlobalStringElement> _collection_
)

Parameters

index

collection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members


LastIndexOf Method (IGlobalStringElementCollection) | fcSDK Documentation

LastIndexOf Method (IGlobalStringElementCollection)

Overload List

Overload | Description
LastIndexOf(IGlobalStringElement) |
LastIndexOf(IGlobalStringElement,Int32) |
LastIndexOf(IGlobalStringElement,Int32,Int32) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members


LastIndexOf(IGlobalStringElement) Method | fcSDK Documentation

LastIndexOf(IGlobalStringElement) Method

Syntax

'Declaration

Overloads Function LastIndexOf( _
   ByVal _item_ As IGlobalStringElement _
) As Integer

int LastIndexOf(
   IGlobalStringElement _item_
)

Parameters

item

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members
Overload List


LastIndexOf(IGlobalStringElement,Int32) Method | fcSDK Documentation

LastIndexOf(IGlobalStringElement,Int32) Method

Syntax

'Declaration

Overloads Function LastIndexOf( _
   ByVal _item_ As IGlobalStringElement, _
   ByVal _index_ As Integer _
) As Integer

int LastIndexOf(
   IGlobalStringElement _item_,
   int _index_
)

Parameters

item

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members
Overload List


LastIndexOf(IGlobalStringElement,Int32,Int32) Method | fcSDK Documentation

LastIndexOf(IGlobalStringElement,Int32,Int32) Method

Syntax

'Declaration

Overloads Function LastIndexOf( _
   ByVal _item_ As IGlobalStringElement, _
   ByVal _index_ As Integer, _
   ByVal _count_ As Integer _
) As Integer

int LastIndexOf(
   IGlobalStringElement _item_,
   int _index_,
   int _count_
)

Parameters

item

index

count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members
Overload List


RemoveAll Method (IGlobalStringElementCollection) | fcSDK Documentation

RemoveAll Method (IGlobalStringElementCollection)

Syntax

'Declaration
Function RemoveAll( _
   ByVal _match_ As Predicate(Of IGlobalStringElement) _
) As Integer

int RemoveAll(
   Predicate<IGlobalStringElement> _match_
)

Parameters

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members


RemoveRange Method (IGlobalStringElementCollection) | fcSDK Documentation

RemoveRange Method (IGlobalStringElementCollection)

Syntax

'Declaration

Sub RemoveRange( _
   ByVal _index_ As Integer, _
   ByVal _count_ As Integer _
)

void RemoveRange(
   int _index_,
   int _count_
)

Parameters

index

count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members


Reverse Method (IGlobalStringElementCollection) | fcSDK Documentation

Reverse Method (IGlobalStringElementCollection)

Overload List

Overload | Description
Reverse() |
Reverse(Int32,Int32) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members


Reverse() Method | fcSDK Documentation

Reverse() Method

Syntax

'Declaration

Overloads Sub Reverse()

void Reverse()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members
Overload List


Reverse(Int32,Int32) Method | fcSDK Documentation

Reverse(Int32,Int32) Method

Syntax

'Declaration

Overloads Sub Reverse( _
   ByVal _index_ As Integer, _
   ByVal _count_ As Integer _
)

void Reverse(
   int _index_,
   int _count_
)

Parameters

index

count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members
Overload List


Sort Method (IGlobalStringElementCollection) | fcSDK Documentation

Sort Method (IGlobalStringElementCollection)

Overload List

Overload | Description
Sort() |
Sort(IComparer) |
Sort(Int32,Int32,IComparer) |
Sort(Comparison) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members


Sort() Method | fcSDK Documentation

Sort() Method

Syntax

'Declaration

Overloads Sub Sort()

void Sort()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members
Overload List


Sort(IComparer) Method | fcSDK Documentation

Sort(IComparer) Method

Syntax

'Declaration

Overloads Sub Sort( _
   ByVal _comparer_ As IComparer(Of IGlobalStringElement) _
)

void Sort(
   IComparer<IGlobalStringElement> _comparer_
)

Parameters

comparer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members
Overload List


Sort(Int32,Int32,IComparer) Method | fcSDK Documentation

Sort(Int32,Int32,IComparer) Method

Syntax

'Declaration

Overloads Sub Sort( _
   ByVal _index_ As Integer, _
   ByVal _count_ As Integer, _
   ByVal _comparer_ As IComparer(Of IGlobalStringElement) _
)

void Sort(
   int _index_,
   int _count_,
   IComparer<IGlobalStringElement> _comparer_
)

Parameters

index

count

comparer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members
Overload List


Sort(Comparison) Method | fcSDK Documentation

Sort(Comparison) Method

Syntax

'Declaration

Overloads Sub Sort( _
   ByVal _comparison_ As Comparison(Of IGlobalStringElement) _
)

void Sort(
   Comparison<IGlobalStringElement> _comparison_
)

Parameters

comparison

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members
Overload List


ToArray Method (IGlobalStringElementCollection) | fcSDK Documentation

ToArray Method (IGlobalStringElementCollection)

Syntax

'Declaration

Function ToArray() As IGlobalStringElement()

IGlobalStringElement[] ToArray()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members


TrimExcess Method (IGlobalStringElementCollection) | fcSDK Documentation

TrimExcess Method (IGlobalStringElementCollection)

Syntax

'Declaration

Sub TrimExcess()

void TrimExcess()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members


TrueForAll Method (IGlobalStringElementCollection) | fcSDK Documentation

TrueForAll Method (IGlobalStringElementCollection)

Syntax

'Declaration
Function TrueForAll( _
   ByVal _match_ As Predicate(Of IGlobalStringElement) _
) As Boolean

bool TrueForAll(
   Predicate<IGlobalStringElement> _match_
)

Parameters

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members


ActiveElements Property (IGlobalStringElementCollection) | fcSDK Documentation

ActiveElements Property (IGlobalStringElementCollection)

Syntax

'Declaration

ReadOnly Property ActiveElements As IGlobalStringElementCollection

IGlobalStringElementCollection ActiveElements {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members


Capacity Property (IGlobalStringElementCollection) | fcSDK Documentation

Capacity Property (IGlobalStringElementCollection)

Syntax

'Declaration

Property Capacity As Integer

int Capacity {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members


DefaultElement Property (IGlobalStringElementCollection) | fcSDK Documentation

DefaultElement Property (IGlobalStringElementCollection)

Syntax

'Declaration

ReadOnly Property DefaultElement As IGlobalStringElement

IGlobalStringElement DefaultElement {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members


InactiveElements Property (IGlobalStringElementCollection) | fcSDK Documentation

InactiveElements Property (IGlobalStringElementCollection)

Syntax

'Declaration

ReadOnly Property InactiveElements As IGlobalStringElementCollection

IGlobalStringElementCollection InactiveElements {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members


Item Property (IGlobalStringElementCollection) | fcSDK Documentation

Item Property (IGlobalStringElementCollection)

Syntax

'Declaration
ReadOnly Default Property Item( _
   ByVal _title_ As String _
) As IGlobalStringElement

IGlobalStringElement this[
   string _title_
]; {get;}

Parameters

title

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringElementCollection Interface
IGlobalStringElementCollection Members


IGlobalStringList Interface | fcSDK Documentation

IGlobalStringList Interface

Syntax

'Declaration

Public Interface IGlobalStringList
   Inherits FChoice.Foundation.DataObjects.IDataObject

public interface IGlobalStringList : FChoice.Foundation.DataObjects.IDataObject

Requirements

Namespace: FChoice.Foundation.Clarify.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

IGlobalStringList Members
FChoice.Foundation.Clarify.DataObjects Namespace


IGlobalStringList Interface Members | fcSDK Documentation

IGlobalStringList Interface Members

The following tables list the members exposed by IGlobalStringList.

Public Properties

 | Name | Description
Property | ActiveElements |
Property | AdditionalInfo |
Property | DefaultElement |
Property | Elements |
Property | InactiveElements |
Property | ListID |
Property | LocaleID |
Property | ObjectID |
Property | Title |

Reference

IGlobalStringList Interface
FChoice.Foundation.Clarify.DataObjects Namespace


ActiveElements Property (IGlobalStringList) | fcSDK Documentation

ActiveElements Property (IGlobalStringList)

Syntax

'Declaration

ReadOnly Property ActiveElements As IGlobalStringElementCollection

IGlobalStringElementCollection ActiveElements {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringList Interface
IGlobalStringList Members


AdditionalInfo Property (IGlobalStringList) | fcSDK Documentation

AdditionalInfo Property (IGlobalStringList)

Syntax

'Declaration
ReadOnly Property AdditionalInfo As String

string AdditionalInfo {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringList Interface
IGlobalStringList Members


DefaultElement Property (IGlobalStringList) | fcSDK Documentation

DefaultElement Property (IGlobalStringList)

Syntax

'Declaration

ReadOnly Property DefaultElement As IGlobalStringElement

IGlobalStringElement DefaultElement {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringList Interface
IGlobalStringList Members


Elements Property (IGlobalStringList) | fcSDK Documentation

Elements Property (IGlobalStringList)

Syntax

'Declaration

ReadOnly Property Elements As IGlobalStringElementCollection

IGlobalStringElementCollection Elements {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringList Interface
IGlobalStringList Members


InactiveElements Property (IGlobalStringList) | fcSDK Documentation

InactiveElements Property (IGlobalStringList)

Syntax

'Declaration

ReadOnly Property InactiveElements As IGlobalStringElementCollection

IGlobalStringElementCollection InactiveElements {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringList Interface
IGlobalStringList Members


ListID Property (IGlobalStringList) | fcSDK Documentation

ListID Property (IGlobalStringList)

Syntax

'Declaration
ReadOnly Property ListID As Integer

int ListID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringList Interface
IGlobalStringList Members


LocaleID Property (IGlobalStringList) | fcSDK Documentation

LocaleID Property (IGlobalStringList)

Syntax

'Declaration
ReadOnly Property LocaleID As Integer

int LocaleID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringList Interface
IGlobalStringList Members


ObjectID Property (IGlobalStringList) | fcSDK Documentation

ObjectID Property (IGlobalStringList)

Syntax

'Declaration
ReadOnly Property ObjectID As Integer

int ObjectID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringList Interface
IGlobalStringList Members


Title Property (IGlobalStringList) | fcSDK Documentation

Title Property (IGlobalStringList)

Syntax

'Declaration

ReadOnly Property Title As String

string Title {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringList Interface
IGlobalStringList Members


IGlobalStringListCollection Interface | fcSDK Documentation

IGlobalStringListCollection Interface

Syntax

'Declaration

<DefaultMemberAttribute("Item")>
Public Interface IGlobalStringListCollection

[DefaultMemberAttribute("Item")]
public interface IGlobalStringListCollection

Requirements

Namespace: FChoice.Foundation.Clarify.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

IGlobalStringListCollection Members
FChoice.Foundation.Clarify.DataObjects Namespace


IGlobalStringListCollection Interface Members | fcSDK Documentation

IGlobalStringListCollection Interface Members

The following tables list the members exposed by IGlobalStringListCollection.

Public Properties

 | Name | Description
Property | Capacity |
Property | Item | Overloaded.

Public Methods

 | Name | Description
Method | AddRange |
Method | AsReadOnly |
Method | BinarySearch | Overloaded.
Method | CopyTo | Overloaded.
Method | Exists |
Method | Find |
Method | FindAll |
Method | FindIndex | Overloaded.
Method | FindLast |
Method | FindLastIndex | Overloaded.
Method | ForEach |
Method | GetItemByIndex |
Method | GetRange |
Method | IndexOf | Overloaded.
Method | Insert |
Method | InsertRange |
Method | LastIndexOf | Overloaded.
Method | RemoveAll |
Method | RemoveAt |
Method | RemoveRange |
Method | Reverse | Overloaded.
Method | Sort | Overloaded.
Method | ToArray |
Method | TrimExcess |
Method | TrueForAll |

Reference

IGlobalStringListCollection Interface
FChoice.Foundation.Clarify.DataObjects Namespace


AddRange Method (IGlobalStringListCollection) | fcSDK Documentation

AddRange Method (IGlobalStringListCollection)

Syntax

'Declaration

Sub AddRange( _
   ByVal _collection_ As IEnumerable(Of IGlobalStringList) _
)

void AddRange(
   IEnumerable<IGlobalStringList> _collection_
)

Parameters

collection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members


AsReadOnly Method (IGlobalStringListCollection) | fcSDK Documentation

AsReadOnly Method (IGlobalStringListCollection)

Syntax

'Declaration

Function AsReadOnly() As ReadOnlyCollection(Of IGlobalStringList)

ReadOnlyCollection<IGlobalStringList> AsReadOnly()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members


BinarySearch Method (IGlobalStringListCollection) | fcSDK Documentation

BinarySearch Method (IGlobalStringListCollection)

Overload List

Overload | Description
BinarySearch(Int32,Int32,IGlobalStringList,IComparer) |
BinarySearch(IGlobalStringList) |
BinarySearch(IGlobalStringList,IComparer) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members


BinarySearch(Int32,Int32,IGlobalStringList,IComparer) Method | fcSDK Documentation

BinarySearch(Int32,Int32,IGlobalStringList,IComparer) Method

Syntax

'Declaration

Overloads Function BinarySearch( _
   ByVal _index_ As Integer, _
   ByVal _count_ As Integer, _
   ByVal _item_ As IGlobalStringList, _
   ByVal _comparer_ As IComparer(Of IGlobalStringList) _
) As Integer

int BinarySearch(
   int _index_,
   int _count_,
   IGlobalStringList _item_,
   IComparer<IGlobalStringList> _comparer_
)

Parameters

index

count

item

comparer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members
Overload List


BinarySearch(IGlobalStringList) Method | fcSDK Documentation

BinarySearch(IGlobalStringList) Method

Syntax

'Declaration

Overloads Function BinarySearch( _
   ByVal _item_ As IGlobalStringList _
) As Integer

int BinarySearch(
   IGlobalStringList _item_
)

Parameters

item

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members
Overload List


BinarySearch(IGlobalStringList,IComparer) Method | fcSDK Documentation

BinarySearch(IGlobalStringList,IComparer) Method

Syntax

'Declaration

Overloads Function BinarySearch( _
   ByVal _item_ As IGlobalStringList, _
   ByVal _comparer_ As IComparer(Of IGlobalStringList) _
) As Integer

int BinarySearch(
   IGlobalStringList _item_,
   IComparer<IGlobalStringList> _comparer_
)

Parameters

item

comparer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members
Overload List


CopyTo Method (IGlobalStringListCollection) | fcSDK Documentation

CopyTo Method (IGlobalStringListCollection)

Overload List

Overload | Description
CopyTo(IGlobalStringList[]) |
CopyTo(Int32,IGlobalStringList[],Int32,Int32) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members


CopyTo(IGlobalStringList[]) Method | fcSDK Documentation

CopyTo(IGlobalStringList[]) Method

Syntax

'Declaration

Overloads Sub CopyTo( _
   ByVal _array_() As IGlobalStringList _
)

void CopyTo(
   IGlobalStringList[] _array_
)

Parameters

array

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members
Overload List


CopyTo(Int32,IGlobalStringList[],Int32,Int32) Method | fcSDK Documentation

CopyTo(Int32,IGlobalStringList[],Int32,Int32) Method

Syntax

'Declaration

Overloads Sub CopyTo( _
   ByVal _index_ As Integer, _
   ByVal _array_() As IGlobalStringList, _
   ByVal _arrayIndex_ As Integer, _
   ByVal _count_ As Integer _
)

void CopyTo(
   int _index_,
   IGlobalStringList[] _array_,
   int _arrayIndex_,
   int _count_
)

Parameters

index

array

arrayIndex

count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members
Overload List


Exists Method (IGlobalStringListCollection) | fcSDK Documentation

Exists Method (IGlobalStringListCollection)

Syntax

'Declaration

Function Exists( _
   ByVal _match_ As Predicate(Of IGlobalStringList) _
) As Boolean

bool Exists(
   Predicate<IGlobalStringList> _match_
)

Parameters

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members


Find Method (IGlobalStringListCollection) | fcSDK Documentation

Find Method (IGlobalStringListCollection)

Syntax

'Declaration
Function Find( _
   ByVal _match_ As Predicate(Of IGlobalStringList) _
) As IGlobalStringList

IGlobalStringList Find(
   Predicate<IGlobalStringList> _match_
)

Parameters

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members


FindAll Method (IGlobalStringListCollection) | fcSDK Documentation

FindAll Method (IGlobalStringListCollection)

Syntax

'Declaration
Function FindAll( _
   ByVal _match_ As Predicate(Of IGlobalStringList) _
) As List(Of IGlobalStringList)

List<IGlobalStringList> FindAll(
   Predicate<IGlobalStringList> _match_
)

Parameters

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members


FindIndex Method (IGlobalStringListCollection) | fcSDK Documentation

FindIndex Method (IGlobalStringListCollection)

Overload List

Overload | Description
FindIndex(Predicate) |
FindIndex(Int32,Predicate) |
FindIndex(Int32,Int32,Predicate) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members


FindIndex(Predicate) Method | fcSDK Documentation

FindIndex(Predicate) Method

Syntax

'Declaration

Overloads Function FindIndex( _
   ByVal _match_ As Predicate(Of IGlobalStringList) _
) As Integer

int FindIndex(
   Predicate<IGlobalStringList> _match_
)

Parameters

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members
Overload List


FindIndex(Int32,Predicate) Method | fcSDK Documentation

FindIndex(Int32,Predicate) Method

Syntax

'Declaration

Overloads Function FindIndex( _
   ByVal _startIndex_ As Integer, _
   ByVal _match_ As Predicate(Of IGlobalStringList) _
) As Integer

int FindIndex(
   int _startIndex_,
   Predicate<IGlobalStringList> _match_
)

Parameters

startIndex

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members
Overload List


FindIndex(Int32,Int32,Predicate) Method | fcSDK Documentation

FindIndex(Int32,Int32,Predicate) Method

Syntax

'Declaration

Overloads Function FindIndex( _
   ByVal _startIndex_ As Integer, _
   ByVal _count_ As Integer, _
   ByVal _match_ As Predicate(Of IGlobalStringList) _
) As Integer

int FindIndex(
   int _startIndex_,
   int _count_,
   Predicate<IGlobalStringList> _match_
)

Parameters

startIndex

count

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members
Overload List


FindLast Method (IGlobalStringListCollection) | fcSDK Documentation

FindLast Method (IGlobalStringListCollection)

Syntax

'Declaration

Function FindLast( _
   ByVal _match_ As Predicate(Of IGlobalStringList) _
) As IGlobalStringList

IGlobalStringList FindLast(
   Predicate<IGlobalStringList> _match_
)

Parameters

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members


FindLastIndex Method (IGlobalStringListCollection) | fcSDK Documentation

FindLastIndex Method (IGlobalStringListCollection)

Overload List

Overload | Description
FindLastIndex(Predicate) |
FindLastIndex(Int32,Predicate) |
FindLastIndex(Int32,Int32,Predicate) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members


FindLastIndex(Predicate) Method | fcSDK Documentation

FindLastIndex(Predicate) Method

Syntax

'Declaration

Overloads Function FindLastIndex( _
   ByVal _match_ As Predicate(Of IGlobalStringList) _
) As Integer

int FindLastIndex(
   Predicate<IGlobalStringList> _match_
)

Parameters

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members
Overload List


FindLastIndex(Int32,Predicate) Method | fcSDK Documentation

FindLastIndex(Int32,Predicate) Method

Syntax

'Declaration

Overloads Function FindLastIndex( _
   ByVal _startIndex_ As Integer, _
   ByVal _match_ As Predicate(Of IGlobalStringList) _
) As Integer

int FindLastIndex(
   int _startIndex_,
   Predicate<IGlobalStringList> _match_
)

Parameters

startIndex

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members
Overload List


FindLastIndex(Int32,Int32,Predicate) Method | fcSDK Documentation

FindLastIndex(Int32,Int32,Predicate) Method

Syntax

'Declaration

Overloads Function FindLastIndex( _
   ByVal _startIndex_ As Integer, _
   ByVal _count_ As Integer, _
   ByVal _match_ As Predicate(Of IGlobalStringList) _
) As Integer

int FindLastIndex(
   int _startIndex_,
   int _count_,
   Predicate<IGlobalStringList> _match_
)

Parameters

startIndex

count

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members
Overload List


ForEach Method (IGlobalStringListCollection) | fcSDK Documentation

ForEach Method (IGlobalStringListCollection)

Syntax

'Declaration
Sub ForEach( _
   ByVal _action_ As Action(Of IGlobalStringList) _
)

void ForEach(
   Action<IGlobalStringList> _action_
)

Parameters

action

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members


GetItemByIndex Method (IGlobalStringListCollection) | fcSDK Documentation

GetItemByIndex Method (IGlobalStringListCollection)

Syntax

'Declaration

Function GetItemByIndex( _
   ByVal _index_ As Integer _
) As IGlobalStringList

IGlobalStringList GetItemByIndex(
   int _index_
)

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members


GetRange Method (IGlobalStringListCollection) | fcSDK Documentation

GetRange Method (IGlobalStringListCollection)

Syntax

'Declaration

Function GetRange( _
   ByVal _index_ As Integer, _
   ByVal _count_ As Integer _
) As List(Of IGlobalStringList)

List<IGlobalStringList> GetRange(
   int _index_,
   int _count_
)

Parameters

index

count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members


IndexOf Method (IGlobalStringListCollection) | fcSDK Documentation

IndexOf Method (IGlobalStringListCollection)

Overload List

Overload | Description
IndexOf(IGlobalStringList) |
IndexOf(IGlobalStringList,Int32) |
IndexOf(IGlobalStringList,Int32,Int32) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members


IndexOf(IGlobalStringList) Method | fcSDK Documentation

IndexOf(IGlobalStringList) Method

Syntax

'Declaration

Overloads Function IndexOf( _
   ByVal _item_ As IGlobalStringList _
) As Integer

int IndexOf(
   IGlobalStringList _item_
)

Parameters

item

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members
Overload List


IndexOf(IGlobalStringList,Int32) Method | fcSDK Documentation

IndexOf(IGlobalStringList,Int32) Method

Syntax

'Declaration

Overloads Function IndexOf( _
   ByVal _item_ As IGlobalStringList, _
   ByVal _index_ As Integer _
) As Integer

int IndexOf(
   IGlobalStringList _item_,
   int _index_
)

Parameters

item

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members
Overload List


IndexOf(IGlobalStringList,Int32,Int32) Method | fcSDK Documentation

IndexOf(IGlobalStringList,Int32,Int32) Method

Syntax

'Declaration

Overloads Function IndexOf( _
   ByVal _item_ As IGlobalStringList, _
   ByVal _index_ As Integer, _
   ByVal _count_ As Integer _
) As Integer

int IndexOf(
   IGlobalStringList _item_,
   int _index_,
   int _count_
)

Parameters

item

index

count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members
Overload List


Insert Method (IGlobalStringListCollection) | fcSDK Documentation

Insert Method (IGlobalStringListCollection)

Syntax

'Declaration

Sub Insert( _
   ByVal _index_ As Integer, _
   ByVal _item_ As IGlobalStringList _
)

void Insert(
   int _index_,
   IGlobalStringList _item_
)

Parameters

index

item

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members


InsertRange Method (IGlobalStringListCollection) | fcSDK Documentation

InsertRange Method (IGlobalStringListCollection)

Syntax

'Declaration

Sub InsertRange( _
   ByVal _index_ As Integer, _
   ByVal _collection_ As IEnumerable(Of IGlobalStringList) _
)

void InsertRange(
   int _index_,
   IEnumerable<IGlobalStringList> _collection_
)

Parameters

index

collection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members


LastIndexOf Method (IGlobalStringListCollection) | fcSDK Documentation

LastIndexOf Method (IGlobalStringListCollection)

Overload List

Overload | Description
LastIndexOf(IGlobalStringList) |
LastIndexOf(IGlobalStringList,Int32) |
LastIndexOf(IGlobalStringList,Int32,Int32) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members


LastIndexOf(IGlobalStringList) Method | fcSDK Documentation

LastIndexOf(IGlobalStringList) Method

Syntax

'Declaration

Overloads Function LastIndexOf( _
   ByVal _item_ As IGlobalStringList _
) As Integer

int LastIndexOf(
   IGlobalStringList _item_
)

Parameters

item

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members
Overload List


LastIndexOf(IGlobalStringList,Int32) Method | fcSDK Documentation

LastIndexOf(IGlobalStringList,Int32) Method

Syntax

'Declaration

Overloads Function LastIndexOf( _
   ByVal _item_ As IGlobalStringList, _
   ByVal _index_ As Integer _
) As Integer

int LastIndexOf(
   IGlobalStringList _item_,
   int _index_
)

Parameters

item

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members
Overload List


LastIndexOf(IGlobalStringList,Int32,Int32) Method | fcSDK Documentation

LastIndexOf(IGlobalStringList,Int32,Int32) Method

Syntax

'Declaration

Overloads Function LastIndexOf( _
   ByVal _item_ As IGlobalStringList, _
   ByVal _index_ As Integer, _
   ByVal _count_ As Integer _
) As Integer

int LastIndexOf(
   IGlobalStringList _item_,
   int _index_,
   int _count_
)

Parameters

item

index

count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members
Overload List


RemoveAll Method (IGlobalStringListCollection) | fcSDK Documentation

RemoveAll Method (IGlobalStringListCollection)

Syntax

'Declaration
Function RemoveAll( _
   ByVal _match_ As Predicate(Of IGlobalStringList) _
) As Integer

int RemoveAll(
   Predicate<IGlobalStringList> _match_
)

Parameters

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members


RemoveAt Method (IGlobalStringListCollection) | fcSDK Documentation

RemoveAt Method (IGlobalStringListCollection)

Syntax

'Declaration

Sub RemoveAt( _
   ByVal _index_ As Integer _
)

void RemoveAt(
   int _index_
)

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members


RemoveRange Method (IGlobalStringListCollection) | fcSDK Documentation

RemoveRange Method (IGlobalStringListCollection)

Syntax

'Declaration

Sub RemoveRange( _
   ByVal _index_ As Integer, _
   ByVal _count_ As Integer _
)

void RemoveRange(
   int _index_,
   int _count_
)

Parameters

index

count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members


Reverse Method (IGlobalStringListCollection) | fcSDK Documentation

Reverse Method (IGlobalStringListCollection)

Overload List

Overload | Description
Reverse() |
Reverse(Int32,Int32) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members


Reverse() Method | fcSDK Documentation

Reverse() Method

Syntax

'Declaration

Overloads Sub Reverse()

void Reverse()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members
Overload List


Reverse(Int32,Int32) Method | fcSDK Documentation

Reverse(Int32,Int32) Method

Syntax

'Declaration

Overloads Sub Reverse( _
   ByVal _index_ As Integer, _
   ByVal _count_ As Integer _
)

void Reverse(
   int _index_,
   int _count_
)

Parameters

index

count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members
Overload List


Sort Method (IGlobalStringListCollection) | fcSDK Documentation

Sort Method (IGlobalStringListCollection)

Overload List

Overload | Description
Sort() |
Sort(IComparer) |
Sort(Int32,Int32,IComparer) |
Sort(Comparison) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members


Sort() Method | fcSDK Documentation

Sort() Method

Syntax

'Declaration

Overloads Sub Sort()

void Sort()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members
Overload List


Sort(IComparer) Method | fcSDK Documentation

Sort(IComparer) Method

Syntax

'Declaration

Overloads Sub Sort( _
   ByVal _comparer_ As IComparer(Of IGlobalStringList) _
)

void Sort(
   IComparer<IGlobalStringList> _comparer_
)

Parameters

comparer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members
Overload List


Sort(Int32,Int32,IComparer) Method | fcSDK Documentation

Sort(Int32,Int32,IComparer) Method

Syntax

'Declaration

Overloads Sub Sort( _
   ByVal _index_ As Integer, _
   ByVal _count_ As Integer, _
   ByVal _comparer_ As IComparer(Of IGlobalStringList) _
)

void Sort(
   int _index_,
   int _count_,
   IComparer<IGlobalStringList> _comparer_
)

Parameters

index

count

comparer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members
Overload List


Sort(Comparison) Method | fcSDK Documentation

Sort(Comparison) Method

Syntax

'Declaration

Overloads Sub Sort( _
   ByVal _comparison_ As Comparison(Of IGlobalStringList) _
)

void Sort(
   Comparison<IGlobalStringList> _comparison_
)

Parameters

comparison

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members
Overload List


ToArray Method (IGlobalStringListCollection) | fcSDK Documentation

ToArray Method (IGlobalStringListCollection)

Syntax

'Declaration

Function ToArray() As IGlobalStringList()

IGlobalStringList[] ToArray()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members


TrimExcess Method (IGlobalStringListCollection) | fcSDK Documentation

TrimExcess Method (IGlobalStringListCollection)

Syntax

'Declaration

Sub TrimExcess()

void TrimExcess()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members


TrueForAll Method (IGlobalStringListCollection) | fcSDK Documentation

TrueForAll Method (IGlobalStringListCollection)

Syntax

'Declaration
Function TrueForAll( _
   ByVal _match_ As Predicate(Of IGlobalStringList) _
) As Boolean

bool TrueForAll(
   Predicate<IGlobalStringList> _match_
)

Parameters

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members


Capacity Property (IGlobalStringListCollection) | fcSDK Documentation

Capacity Property (IGlobalStringListCollection)

Syntax

'Declaration

Property Capacity As Integer

int Capacity {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members


Item Property (IGlobalStringListCollection) | fcSDK Documentation

Item Property (IGlobalStringListCollection)

Overload List

Overload | Description
Item(String) |
Item(Int32) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members


Item(String) Property | fcSDK Documentation

Item(String) Property

Syntax

'Declaration

Overloads ReadOnly Property Item( _
   ByVal _title_ As String _
) As IGlobalStringList

IGlobalStringList Item(
   string _title_
) {get;}

Parameters

title

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members
Overload List


Item(Int32) Property | fcSDK Documentation

Item(Int32) Property

Syntax

'Declaration

Overloads Property Item( _
   ByVal _index_ As Integer _
) As IGlobalStringList

IGlobalStringList Item(
   int _index_
) {get; set;}

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IGlobalStringListCollection Interface
IGlobalStringListCollection Members
Overload List


IHierarchicalStringElement Interface | fcSDK Documentation

IHierarchicalStringElement Interface

Syntax

'Declaration

Public Interface IHierarchicalStringElement
   Inherits FChoice.Foundation.DataObjects.IDataObject

public interface IHierarchicalStringElement : FChoice.Foundation.DataObjects.IDataObject

Requirements

Namespace: FChoice.Foundation.Clarify.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

IHierarchicalStringElement Members
FChoice.Foundation.Clarify.DataObjects Namespace


IHierarchicalStringElement Interface Members | fcSDK Documentation

IHierarchicalStringElement Interface Members

The following tables list the members exposed by IHierarchicalStringElement.

Public Properties

 | Name | Description
Property | Elements |
Property | IsActive |
Property | IsDefault |
Property | LocalizedTitle |
Property | ObjectID |
Property | Rank |
Property | State |
Property | Title |

Public Methods

 | Name | Description
Method | GetLocalizedTitle |

Reference

IHierarchicalStringElement Interface
FChoice.Foundation.Clarify.DataObjects Namespace


GetLocalizedTitle Method (IHierarchicalStringElement) | fcSDK Documentation

GetLocalizedTitle Method (IHierarchicalStringElement)

Syntax

'Declaration

Function GetLocalizedTitle( _
   ByVal _specificCulture_ As CultureInfo _
) As String

string GetLocalizedTitle(
   CultureInfo _specificCulture_
)

Parameters

specificCulture

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElement Interface
IHierarchicalStringElement Members


Elements Property (IHierarchicalStringElement) | fcSDK Documentation

Elements Property (IHierarchicalStringElement)

Syntax

'Declaration

ReadOnly Property Elements As IHierarchicalStringElementCollection

IHierarchicalStringElementCollection Elements {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElement Interface
IHierarchicalStringElement Members


IsActive Property (IHierarchicalStringElement) | fcSDK Documentation

IsActive Property (IHierarchicalStringElement)

Syntax

'Declaration

ReadOnly Property IsActive As Boolean

bool IsActive {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElement Interface
IHierarchicalStringElement Members


IsDefault Property (IHierarchicalStringElement) | fcSDK Documentation

IsDefault Property (IHierarchicalStringElement)

Syntax

'Declaration

ReadOnly Property IsDefault As Boolean

bool IsDefault {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElement Interface
IHierarchicalStringElement Members


LocalizedTitle Property (IHierarchicalStringElement) | fcSDK Documentation

LocalizedTitle Property (IHierarchicalStringElement)

Syntax

'Declaration

ReadOnly Property LocalizedTitle As String

string LocalizedTitle {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElement Interface
IHierarchicalStringElement Members


ObjectID Property (IHierarchicalStringElement) | fcSDK Documentation

ObjectID Property (IHierarchicalStringElement)

Syntax

'Declaration
ReadOnly Property ObjectID As Integer

int ObjectID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElement Interface
IHierarchicalStringElement Members


Rank Property (IHierarchicalStringElement) | fcSDK Documentation

Rank Property (IHierarchicalStringElement)

Syntax

'Declaration
ReadOnly Property Rank As Integer

int Rank {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElement Interface
IHierarchicalStringElement Members


State Property (IHierarchicalStringElement) | fcSDK Documentation

State Property (IHierarchicalStringElement)

Syntax

'Declaration

ReadOnly Property State As String

string State {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElement Interface
IHierarchicalStringElement Members


Title Property (IHierarchicalStringElement) | fcSDK Documentation

Title Property (IHierarchicalStringElement)

Syntax

'Declaration

ReadOnly Property Title As String

string Title {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElement Interface
IHierarchicalStringElement Members


IHierarchicalStringElementCollection Interface | fcSDK Documentation

IHierarchicalStringElementCollection Interface

Syntax

'Declaration

<DefaultMemberAttribute("Item")>
Public Interface IHierarchicalStringElementCollection

[DefaultMemberAttribute("Item")]
public interface IHierarchicalStringElementCollection

Requirements

Namespace: FChoice.Foundation.Clarify.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

IHierarchicalStringElementCollection Members
FChoice.Foundation.Clarify.DataObjects Namespace


IHierarchicalStringElementCollection Interface Members | fcSDK Documentation

IHierarchicalStringElementCollection Interface Members

The following tables list the members exposed by IHierarchicalStringElementCollection.

Public Properties

 | Name | Description
Property | ActiveElements |
Property | Capacity |
Property | DefaultElement |
Property | Item |

Public Methods

 | Name | Description
Method | AddRange |
Method | AsReadOnly |
Method | BinarySearch | Overloaded.
Method | CopyTo | Overloaded.
Method | Exists |
Method | Find |
Method | FindAll |
Method | FindIndex | Overloaded.
Method | FindLast |
Method | FindLastIndex | Overloaded.
Method | ForEach |
Method | GetByObjID |
Method | GetItemByIndex |
Method | GetRange |
Method | IndexOf | Overloaded.
Method | InsertRange |
Method | LastIndexOf | Overloaded.
Method | RemoveAll |
Method | RemoveRange |
Method | Reverse | Overloaded.
Method | Sort | Overloaded.
Method | ToArray |
Method | TrimExcess |
Method | TrueForAll |

Reference

IHierarchicalStringElementCollection Interface
FChoice.Foundation.Clarify.DataObjects Namespace


AddRange Method (IHierarchicalStringElementCollection) | fcSDK Documentation

AddRange Method (IHierarchicalStringElementCollection)

Syntax

'Declaration

Sub AddRange( _
   ByVal _collection_ As IEnumerable(Of IHierarchicalStringElement) _
)

void AddRange(
   IEnumerable<IHierarchicalStringElement> _collection_
)

Parameters

collection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members


AsReadOnly Method (IHierarchicalStringElementCollection) | fcSDK Documentation

AsReadOnly Method (IHierarchicalStringElementCollection)

Syntax

'Declaration

Function AsReadOnly() As ReadOnlyCollection(Of IHierarchicalStringElement)

ReadOnlyCollection<IHierarchicalStringElement> AsReadOnly()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members


BinarySearch Method (IHierarchicalStringElementCollection) | fcSDK Documentation

BinarySearch Method (IHierarchicalStringElementCollection)

Overload List

Overload | Description
BinarySearch(Int32,Int32,IHierarchicalStringElement,IComparer) |
BinarySearch(IHierarchicalStringElement) |
BinarySearch(IHierarchicalStringElement,IComparer) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members


BinarySearch(Int32,Int32,IHierarchicalStringElement,IComparer) Method | fcSDK Documentation

BinarySearch(Int32,Int32,IHierarchicalStringElement,IComparer) Method

Syntax

'Declaration

Overloads Function BinarySearch( _
   ByVal _index_ As Integer, _
   ByVal _count_ As Integer, _
   ByVal _item_ As IHierarchicalStringElement, _
   ByVal _comparer_ As IComparer(Of IHierarchicalStringElement) _
) As Integer

int BinarySearch(
   int _index_,
   int _count_,
   IHierarchicalStringElement _item_,
   IComparer<IHierarchicalStringElement> _comparer_
)

Parameters

index

count

item

comparer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members
Overload List


BinarySearch(IHierarchicalStringElement) Method | fcSDK Documentation

BinarySearch(IHierarchicalStringElement) Method

Syntax

'Declaration

Overloads Function BinarySearch( _
   ByVal _item_ As IHierarchicalStringElement _
) As Integer

int BinarySearch(
   IHierarchicalStringElement _item_
)

Parameters

item

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members
Overload List


BinarySearch(IHierarchicalStringElement,IComparer) Method | fcSDK Documentation

BinarySearch(IHierarchicalStringElement,IComparer) Method

Syntax

'Declaration

Overloads Function BinarySearch( _
   ByVal _item_ As IHierarchicalStringElement, _
   ByVal _comparer_ As IComparer(Of IHierarchicalStringElement) _
) As Integer

int BinarySearch(
   IHierarchicalStringElement _item_,
   IComparer<IHierarchicalStringElement> _comparer_
)

Parameters

item

comparer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members
Overload List


CopyTo Method (IHierarchicalStringElementCollection) | fcSDK Documentation

CopyTo Method (IHierarchicalStringElementCollection)

Overload List

Overload | Description
CopyTo(IHierarchicalStringElement[]) |
CopyTo(Int32,IHierarchicalStringElement[],Int32,Int32) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members


CopyTo(IHierarchicalStringElement[]) Method | fcSDK Documentation

CopyTo(IHierarchicalStringElement[]) Method

Syntax

'Declaration

Overloads Sub CopyTo( _
   ByVal _array_() As IHierarchicalStringElement _
)

void CopyTo(
   IHierarchicalStringElement[] _array_
)

Parameters

array

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members
Overload List


CopyTo(Int32,IHierarchicalStringElement[],Int32,Int32) Method | fcSDK Documentation

CopyTo(Int32,IHierarchicalStringElement[],Int32,Int32) Method

Syntax

'Declaration

Overloads Sub CopyTo( _
   ByVal _index_ As Integer, _
   ByVal _array_() As IHierarchicalStringElement, _
   ByVal _arrayIndex_ As Integer, _
   ByVal _count_ As Integer _
)

void CopyTo(
   int _index_,
   IHierarchicalStringElement\[\] _array_,
   int _arrayIndex_,
   int _count_
)

Parameters

index

array

arrayIndex

count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members
Overload List


Exists Method (IHierarchicalStringElementCollection) | fcSDK Documentation

Exists Method (IHierarchicalStringElementCollection)

Syntax

'Declaration

Function Exists( _
   ByVal _match_ As Predicate(Of IHierarchicalStringElement) _
) As Boolean

bool Exists(
   Predicate<IHierarchicalStringElement> _match_
)

Parameters

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members


Find Method (IHierarchicalStringElementCollection) | fcSDK Documentation

Find Method (IHierarchicalStringElementCollection)

Syntax

'Declaration
Function Find( _
   ByVal _match_ As Predicate(Of IHierarchicalStringElement) _
) As IHierarchicalStringElement

IHierarchicalStringElement Find(
   Predicate<IHierarchicalStringElement> _match_
)

Parameters

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members


FindAll Method (IHierarchicalStringElementCollection) | fcSDK Documentation

FindAll Method (IHierarchicalStringElementCollection)

Syntax

'Declaration
Function FindAll( _
   ByVal _match_ As Predicate(Of IHierarchicalStringElement) _
) As List(Of IHierarchicalStringElement)

List<IHierarchicalStringElement> FindAll(
   Predicate<IHierarchicalStringElement> _match_
)

Parameters

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members


FindIndex Method (IHierarchicalStringElementCollection) | fcSDK Documentation

FindIndex Method (IHierarchicalStringElementCollection)

Overload List

Overload | Description
FindIndex(Predicate) |
FindIndex(Int32,Predicate) |
FindIndex(Int32,Int32,Predicate) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members


FindIndex(Predicate) Method | fcSDK Documentation

FindIndex(Predicate) Method

Syntax

'Declaration

Overloads Function FindIndex( _
   ByVal _match_ As Predicate(Of IHierarchicalStringElement) _
) As Integer

int FindIndex(
   Predicate<IHierarchicalStringElement> _match_
)

Parameters

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members
Overload List


FindIndex(Int32,Predicate) Method | fcSDK Documentation

FindIndex(Int32,Predicate) Method

Syntax

'Declaration

Overloads Function FindIndex( _
   ByVal _startIndex_ As Integer, _
   ByVal _match_ As Predicate(Of IHierarchicalStringElement) _
) As Integer

int FindIndex(
   int _startIndex_,
   Predicate<IHierarchicalStringElement> _match_
)

Parameters

startIndex

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members
Overload List


FindIndex(Int32,Int32,Predicate) Method | fcSDK Documentation

FindIndex(Int32,Int32,Predicate) Method

Syntax

'Declaration

Overloads Function FindIndex( _
   ByVal _startIndex_ As Integer, _
   ByVal _count_ As Integer, _
   ByVal _match_ As Predicate(Of IHierarchicalStringElement) _
) As Integer

int FindIndex(
   int _startIndex_,
   int _count_,
   Predicate<IHierarchicalStringElement> _match_
)

Parameters

startIndex

count

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members
Overload List


FindLast Method (IHierarchicalStringElementCollection) | fcSDK Documentation

FindLast Method (IHierarchicalStringElementCollection)

Syntax

'Declaration

Function FindLast( _
   ByVal _match_ As Predicate(Of IHierarchicalStringElement) _
) As IHierarchicalStringElement

IHierarchicalStringElement FindLast(
   Predicate<IHierarchicalStringElement> _match_
)

Parameters

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members


FindLastIndex Method (IHierarchicalStringElementCollection) | fcSDK Documentation

FindLastIndex Method (IHierarchicalStringElementCollection)

Overload List

Overload | Description
FindLastIndex(Predicate) |
FindLastIndex(Int32,Predicate) |
FindLastIndex(Int32,Int32,Predicate) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members


FindLastIndex(Predicate) Method | fcSDK Documentation

FindLastIndex(Predicate) Method

Syntax

'Declaration

Overloads Function FindLastIndex( _
   ByVal _match_ As Predicate(Of IHierarchicalStringElement) _
) As Integer

int FindLastIndex(
   Predicate<IHierarchicalStringElement> _match_
)

Parameters

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members
Overload List


FindLastIndex(Int32,Predicate) Method | fcSDK Documentation

FindLastIndex(Int32,Predicate) Method

Syntax

'Declaration

Overloads Function FindLastIndex( _
   ByVal _startIndex_ As Integer, _
   ByVal _match_ As Predicate(Of IHierarchicalStringElement) _
) As Integer

int FindLastIndex(
   int _startIndex_,
   Predicate<IHierarchicalStringElement> _match_
)

Parameters

startIndex

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members
Overload List


FindLastIndex(Int32,Int32,Predicate) Method | fcSDK Documentation

FindLastIndex(Int32,Int32,Predicate) Method

Syntax

'Declaration

Overloads Function FindLastIndex( _
   ByVal _startIndex_ As Integer, _
   ByVal _count_ As Integer, _
   ByVal _match_ As Predicate(Of IHierarchicalStringElement) _
) As Integer

int FindLastIndex(
   int _startIndex_,
   int _count_,
   Predicate<IHierarchicalStringElement> _match_
)

Parameters

startIndex

count

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members
Overload List


ForEach Method (IHierarchicalStringElementCollection) | fcSDK Documentation

ForEach Method (IHierarchicalStringElementCollection)

Syntax

'Declaration
Sub ForEach( _
   ByVal _action_ As Action(Of IHierarchicalStringElement) _
)

void ForEach(
   Action<IHierarchicalStringElement> _action_
)

Parameters

action

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members


GetByObjID Method (IHierarchicalStringElementCollection) | fcSDK Documentation

GetByObjID Method (IHierarchicalStringElementCollection)

Syntax

'Declaration
Function GetByObjID( _
   ByVal _objectID_ As Integer _
) As IHierarchicalStringElement

IHierarchicalStringElement GetByObjID(
   int _objectID_
)

Parameters

objectID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members


GetItemByIndex Method (IHierarchicalStringElementCollection) | fcSDK Documentation

GetItemByIndex Method (IHierarchicalStringElementCollection)

Syntax

'Declaration

Function GetItemByIndex( _
   ByVal _index_ As Integer _
) As IHierarchicalStringElement

IHierarchicalStringElement GetItemByIndex(
   int _index_
)

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members


GetRange Method (IHierarchicalStringElementCollection) | fcSDK Documentation

GetRange Method (IHierarchicalStringElementCollection)

Syntax

'Declaration

Function GetRange( _
   ByVal _index_ As Integer, _
   ByVal _count_ As Integer _
) As List(Of IHierarchicalStringElement)

List<IHierarchicalStringElement> GetRange(
   int _index_,
   int _count_
)

Parameters

index

count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members


IndexOf Method (IHierarchicalStringElementCollection) | fcSDK Documentation

IndexOf Method (IHierarchicalStringElementCollection)

Overload List

Overload | Description
IndexOf(IHierarchicalStringElement,Int32) |
IndexOf(IHierarchicalStringElement,Int32,Int32) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members


IndexOf(IHierarchicalStringElement,Int32) Method | fcSDK Documentation

IndexOf(IHierarchicalStringElement,Int32) Method

Syntax

'Declaration

Overloads Function IndexOf( _
   ByVal _item_ As IHierarchicalStringElement, _
   ByVal _index_ As Integer _
) As Integer

int IndexOf(
   IHierarchicalStringElement _item_,
   int _index_
)

Parameters

item

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members
Overload List


IndexOf(IHierarchicalStringElement,Int32,Int32) Method | fcSDK Documentation

IndexOf(IHierarchicalStringElement,Int32,Int32) Method

Syntax

'Declaration

Overloads Function IndexOf( _
   ByVal _item_ As IHierarchicalStringElement, _
   ByVal _index_ As Integer, _
   ByVal _count_ As Integer _
) As Integer

int IndexOf(
   IHierarchicalStringElement _item_,
   int _index_,
   int _count_
)

Parameters

item

index

count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members
Overload List


InsertRange Method (IHierarchicalStringElementCollection) | fcSDK Documentation

InsertRange Method (IHierarchicalStringElementCollection)

Syntax

'Declaration

Sub InsertRange( _
   ByVal _index_ As Integer, _
   ByVal _collection_ As IEnumerable(Of IHierarchicalStringElement) _
)

void InsertRange(
   int _index_,
   IEnumerable<IHierarchicalStringElement> _collection_
)

Parameters

index

collection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members


LastIndexOf Method (IHierarchicalStringElementCollection) | fcSDK Documentation

LastIndexOf Method (IHierarchicalStringElementCollection)

Overload List

Overload | Description
LastIndexOf(IHierarchicalStringElement) |
LastIndexOf(IHierarchicalStringElement,Int32) |
LastIndexOf(IHierarchicalStringElement,Int32,Int32) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members


LastIndexOf(IHierarchicalStringElement) Method | fcSDK Documentation

LastIndexOf(IHierarchicalStringElement) Method

Syntax

'Declaration

Overloads Function LastIndexOf( _
   ByVal _item_ As IHierarchicalStringElement _
) As Integer

int LastIndexOf(
   IHierarchicalStringElement _item_
)

Parameters

item

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members
Overload List


LastIndexOf(IHierarchicalStringElement,Int32) Method | fcSDK Documentation

LastIndexOf(IHierarchicalStringElement,Int32) Method

Syntax

'Declaration

Overloads Function LastIndexOf( _
   ByVal _item_ As IHierarchicalStringElement, _
   ByVal _index_ As Integer _
) As Integer

int LastIndexOf(
   IHierarchicalStringElement _item_,
   int _index_
)

Parameters

item

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members
Overload List


LastIndexOf(IHierarchicalStringElement,Int32,Int32) Method | fcSDK Documentation

LastIndexOf(IHierarchicalStringElement,Int32,Int32) Method

Syntax

'Declaration

Overloads Function LastIndexOf( _
   ByVal _item_ As IHierarchicalStringElement, _
   ByVal _index_ As Integer, _
   ByVal _count_ As Integer _
) As Integer

int LastIndexOf(
   IHierarchicalStringElement _item_,
   int _index_,
   int _count_
)

Parameters

item

index

count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members
Overload List


RemoveAll Method (IHierarchicalStringElementCollection) | fcSDK Documentation

RemoveAll Method (IHierarchicalStringElementCollection)

Syntax

'Declaration
Function RemoveAll( _
   ByVal _match_ As Predicate(Of IHierarchicalStringElement) _
) As Integer

int RemoveAll(
   Predicate<IHierarchicalStringElement> _match_
)

Parameters

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members


RemoveRange Method (IHierarchicalStringElementCollection) | fcSDK Documentation

RemoveRange Method (IHierarchicalStringElementCollection)

Syntax

'Declaration

Sub RemoveRange( _
   ByVal _index_ As Integer, _
   ByVal _count_ As Integer _
)

void RemoveRange(
   int _index_,
   int _count_
)

Parameters

index

count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members


Reverse Method (IHierarchicalStringElementCollection) | fcSDK Documentation

Reverse Method (IHierarchicalStringElementCollection)

Overload List

Overload | Description
Reverse() |
Reverse(Int32,Int32) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members


Reverse() Method | fcSDK Documentation

Reverse() Method

Syntax

'Declaration

Overloads Sub Reverse()

void Reverse()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members
Overload List


Reverse(Int32,Int32) Method | fcSDK Documentation

Reverse(Int32,Int32) Method

Syntax

'Declaration

Overloads Sub Reverse( _
   ByVal _index_ As Integer, _
   ByVal _count_ As Integer _
)

void Reverse(
   int _index_,
   int _count_
)

Parameters

index

count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members
Overload List


Sort Method (IHierarchicalStringElementCollection) | fcSDK Documentation

Sort Method (IHierarchicalStringElementCollection)

Overload List

Overload | Description
Sort() |
Sort(IComparer) |
Sort(Int32,Int32,IComparer) |
Sort(Comparison) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members


Sort() Method | fcSDK Documentation

Sort() Method

Syntax

'Declaration

Overloads Sub Sort()

void Sort()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members
Overload List


Sort(IComparer) Method | fcSDK Documentation

Sort(IComparer) Method

Syntax

'Declaration

Overloads Sub Sort( _
   ByVal _comparer_ As IComparer(Of IHierarchicalStringElement) _
)

void Sort(
   IComparer<IHierarchicalStringElement> _comparer_
)

Parameters

comparer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members
Overload List


Sort(Int32,Int32,IComparer) Method | fcSDK Documentation

Sort(Int32,Int32,IComparer) Method

Syntax

'Declaration

Overloads Sub Sort( _
   ByVal _index_ As Integer, _
   ByVal _count_ As Integer, _
   ByVal _comparer_ As IComparer(Of IHierarchicalStringElement) _
)

void Sort(
   int _index_,
   int _count_,
   IComparer<IHierarchicalStringElement> _comparer_
)

Parameters

index

count

comparer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members
Overload List


Sort(Comparison) Method | fcSDK Documentation

Sort(Comparison) Method

Syntax

'Declaration

Overloads Sub Sort( _
   ByVal _comparison_ As Comparison(Of IHierarchicalStringElement) _
)

void Sort(
   Comparison<IHierarchicalStringElement> _comparison_
)

Parameters

comparison

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members
Overload List


ToArray Method (IHierarchicalStringElementCollection) | fcSDK Documentation

ToArray Method (IHierarchicalStringElementCollection)

Syntax

'Declaration

Function ToArray() As IHierarchicalStringElement()

IHierarchicalStringElement[] ToArray()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members


TrimExcess Method (IHierarchicalStringElementCollection) | fcSDK Documentation

TrimExcess Method (IHierarchicalStringElementCollection)

Syntax

'Declaration

Sub TrimExcess()

void TrimExcess()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members


TrueForAll Method (IHierarchicalStringElementCollection) | fcSDK Documentation

TrueForAll Method (IHierarchicalStringElementCollection)

Syntax

'Declaration

Function TrueForAll( _
   ByVal _match_ As Predicate(Of IHierarchicalStringElement) _
) As Boolean

bool TrueForAll(
   Predicate<IHierarchicalStringElement> _match_
)

Parameters

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members


ActiveElements Property (IHierarchicalStringElementCollection) | fcSDK Documentation

ActiveElements Property (IHierarchicalStringElementCollection)

Syntax

'Declaration

ReadOnly Property ActiveElements As HierarchicalStringElementCollection

HierarchicalStringElementCollection ActiveElements {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members


Capacity Property (IHierarchicalStringElementCollection) | fcSDK Documentation

Capacity Property (IHierarchicalStringElementCollection)

Syntax

'Declaration

Property Capacity As Integer

int Capacity {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members


DefaultElement Property (IHierarchicalStringElementCollection) | fcSDK Documentation

DefaultElement Property (IHierarchicalStringElementCollection)

Syntax

'Declaration

ReadOnly Property DefaultElement As IHierarchicalStringElement

IHierarchicalStringElement DefaultElement {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members


Item Property (IHierarchicalStringElementCollection) | fcSDK Documentation

Item Property (IHierarchicalStringElementCollection)

Syntax

'Declaration

ReadOnly Default Property Item( _
   ByVal _title_ As String _
) As IHierarchicalStringElement

IHierarchicalStringElement this[
   string _title_
]; {get;}

Parameters

title

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringElementCollection Interface
IHierarchicalStringElementCollection Members


IHierarchicalStringList Interface | fcSDK Documentation

IHierarchicalStringList Interface

Syntax

'Declaration

Public Interface IHierarchicalStringList
   Inherits FChoice.Foundation.DataObjects.IDataObject

public interface IHierarchicalStringList : FChoice.Foundation.DataObjects.IDataObject

Requirements

Namespace: FChoice.Foundation.Clarify.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

IHierarchicalStringList Members
FChoice.Foundation.Clarify.DataObjects Namespace


IHierarchicalStringList Interface Members | fcSDK Documentation

IHierarchicalStringList Interface Members

The following tables list the members exposed by IHierarchicalStringList.

Public Properties

 | Name | Description
Property | ActiveElements |
Property | Description |
Property | Elements |
Property | InactiveElements |
Property | ListID |
Property | ObjectID |
Property | Title |

Reference

IHierarchicalStringList Interface
FChoice.Foundation.Clarify.DataObjects Namespace


ActiveElements Property (IHierarchicalStringList) | fcSDK Documentation

ActiveElements Property (IHierarchicalStringList)

Syntax

'Declaration

ReadOnly Property ActiveElements As IHierarchicalStringElementCollection

IHierarchicalStringElementCollection ActiveElements {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringList Interface
IHierarchicalStringList Members


Description Property (IHierarchicalStringList) | fcSDK Documentation

Description Property (IHierarchicalStringList)

Syntax

'Declaration
ReadOnly Property Description As String

string Description {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringList Interface
IHierarchicalStringList Members


Elements Property (IHierarchicalStringList) | fcSDK Documentation

Elements Property (IHierarchicalStringList)

Syntax

'Declaration

ReadOnly Property Elements As IHierarchicalStringElementCollection

IHierarchicalStringElementCollection Elements {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringList Interface
IHierarchicalStringList Members


InactiveElements Property (IHierarchicalStringList) | fcSDK Documentation

InactiveElements Property (IHierarchicalStringList)

Syntax

'Declaration

ReadOnly Property InactiveElements As IHierarchicalStringElementCollection

IHierarchicalStringElementCollection InactiveElements {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringList Interface
IHierarchicalStringList Members


ListID Property (IHierarchicalStringList) | fcSDK Documentation

ListID Property (IHierarchicalStringList)

Syntax

'Declaration
ReadOnly Property ListID As Integer

int ListID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringList Interface
IHierarchicalStringList Members


ObjectID Property (IHierarchicalStringList) | fcSDK Documentation

ObjectID Property (IHierarchicalStringList)

Syntax

'Declaration
ReadOnly Property ObjectID As Integer

int ObjectID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringList Interface
IHierarchicalStringList Members


Title Property (IHierarchicalStringList) | fcSDK Documentation

Title Property (IHierarchicalStringList)

Syntax

'Declaration

ReadOnly Property Title As String

string Title {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringList Interface
IHierarchicalStringList Members


IHierarchicalStringListCollection Interface | fcSDK Documentation

IHierarchicalStringListCollection Interface

Syntax

'Declaration

<DefaultMemberAttribute("Item")>
Public Interface IHierarchicalStringListCollection

[DefaultMemberAttribute("Item")]
public interface IHierarchicalStringListCollection

Requirements

Namespace: FChoice.Foundation.Clarify.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

IHierarchicalStringListCollection Members
FChoice.Foundation.Clarify.DataObjects Namespace


IHierarchicalStringListCollection Interface Members | fcSDK Documentation

IHierarchicalStringListCollection Interface Members

The following tables list the members exposed by IHierarchicalStringListCollection.

Public Properties

 | Name | Description
Property | Capacity |
Property | Item |

Public Methods

 | Name | Description
Method | AddRange |
Method | AsReadOnly |
Method | BinarySearch | Overloaded.
Method | CopyTo | Overloaded.
Method | Exists |
Method | Find |
Method | FindAll |
Method | FindIndex | Overloaded.
Method | FindLast |
Method | FindLastIndex | Overloaded.
Method | ForEach |
Method | GetItemByIndex |
Method | GetRange |
Method | IndexOf | Overloaded.
Method | InsertRange |
Method | LastIndexOf | Overloaded.
Method | RemoveAll |
Method | RemoveRange |
Method | Reverse | Overloaded.
Method | Sort | Overloaded.
Method | ToArray |
Method | TrimExcess |
Method | TrueForAll |

Reference

IHierarchicalStringListCollection Interface
FChoice.Foundation.Clarify.DataObjects Namespace


AddRange Method (IHierarchicalStringListCollection) | fcSDK Documentation

AddRange Method (IHierarchicalStringListCollection)

Syntax

'Declaration

Sub AddRange( _
   ByVal _collection_ As IEnumerable(Of IHierarchicalStringList) _
)

void AddRange(
   IEnumerable<IHierarchicalStringList> _collection_
)

Parameters

collection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members


AsReadOnly Method (IHierarchicalStringListCollection) | fcSDK Documentation

AsReadOnly Method (IHierarchicalStringListCollection)

Syntax

'Declaration

Function AsReadOnly() As ReadOnlyCollection(Of IHierarchicalStringList)

ReadOnlyCollection<IHierarchicalStringList> AsReadOnly()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members


BinarySearch Method (IHierarchicalStringListCollection) | fcSDK Documentation

BinarySearch Method (IHierarchicalStringListCollection)

Overload List

Overload | Description
BinarySearch(Int32,Int32,IHierarchicalStringList,IComparer) |
BinarySearch(IHierarchicalStringList) |
BinarySearch(IHierarchicalStringList,IComparer) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members


BinarySearch(Int32,Int32,IHierarchicalStringList,IComparer) Method | fcSDK Documentation

BinarySearch(Int32,Int32,IHierarchicalStringList,IComparer) Method

Syntax

'Declaration

Overloads Function BinarySearch( _
   ByVal _index_ As Integer, _
   ByVal _count_ As Integer, _
   ByVal _item_ As IHierarchicalStringList, _
   ByVal _comparer_ As IComparer(Of IHierarchicalStringList) _
) As Integer

int BinarySearch(
   int _index_,
   int _count_,
   IHierarchicalStringList _item_,
   IComparer<IHierarchicalStringList> _comparer_
)

Parameters

index

count

item

comparer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members
Overload List


BinarySearch(IHierarchicalStringList) Method | fcSDK Documentation

BinarySearch(IHierarchicalStringList) Method

Syntax

'Declaration

Overloads Function BinarySearch( _
   ByVal _item_ As IHierarchicalStringList _
) As Integer

int BinarySearch(
   IHierarchicalStringList _item_
)

Parameters

item

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members
Overload List


BinarySearch(IHierarchicalStringList,IComparer) Method | fcSDK Documentation

BinarySearch(IHierarchicalStringList,IComparer) Method

Syntax

'Declaration

Overloads Function BinarySearch( _
   ByVal _item_ As IHierarchicalStringList, _
   ByVal _comparer_ As IComparer(Of IHierarchicalStringList) _
) As Integer

int BinarySearch(
   IHierarchicalStringList _item_,
   IComparer<IHierarchicalStringList> _comparer_
)

Parameters

item

comparer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members
Overload List


CopyTo Method (IHierarchicalStringListCollection) | fcSDK Documentation

CopyTo Method (IHierarchicalStringListCollection)

Overload List

Overload | Description
CopyTo(IHierarchicalStringList[]) |
CopyTo(Int32,IHierarchicalStringList[],Int32,Int32) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members


CopyTo(IHierarchicalStringList[]) Method | fcSDK Documentation

CopyTo(IHierarchicalStringList[]) Method

Syntax

'Declaration

Overloads Sub CopyTo( _
   ByVal _array_() As IHierarchicalStringList _
)

void CopyTo(
   IHierarchicalStringList[] _array_
)

Parameters

array

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members
Overload List


CopyTo(Int32,IHierarchicalStringList[],Int32,Int32) Method | fcSDK Documentation

CopyTo(Int32,IHierarchicalStringList[],Int32,Int32) Method

Syntax

'Declaration

Overloads Sub CopyTo( _
   ByVal _index_ As Integer, _
   ByVal _array_() As IHierarchicalStringList, _
   ByVal _arrayIndex_ As Integer, _
   ByVal _count_ As Integer _
)

void CopyTo(
   int _index_,
   IHierarchicalStringList\[\] _array_,
   int _arrayIndex_,
   int _count_
)

Parameters

index

array

arrayIndex

count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members
Overload List


Exists Method (IHierarchicalStringListCollection) | fcSDK Documentation

Exists Method (IHierarchicalStringListCollection)

Syntax

'Declaration

Function Exists( _
   ByVal _match_ As Predicate(Of IHierarchicalStringList) _
) As Boolean

bool Exists(
   Predicate<IHierarchicalStringList> _match_
)

Parameters

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members


Find Method (IHierarchicalStringListCollection) | fcSDK Documentation

Find Method (IHierarchicalStringListCollection)

Syntax

'Declaration
Function Find( _
   ByVal _match_ As Predicate(Of IHierarchicalStringList) _
) As IHierarchicalStringList

IHierarchicalStringList Find(
   Predicate<IHierarchicalStringList> _match_
)

Parameters

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members


FindAll Method (IHierarchicalStringListCollection) | fcSDK Documentation

FindAll Method (IHierarchicalStringListCollection)

Syntax

'Declaration
Function FindAll( _
   ByVal _match_ As Predicate(Of IHierarchicalStringList) _
) As List(Of IHierarchicalStringList)

List<IHierarchicalStringList> FindAll(
   Predicate<IHierarchicalStringList> _match_
)

Parameters

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members


FindIndex Method (IHierarchicalStringListCollection) | fcSDK Documentation

FindIndex Method (IHierarchicalStringListCollection)

Overload List

Overload | Description
FindIndex(Predicate) |
FindIndex(Int32,Predicate) |
FindIndex(Int32,Int32,Predicate) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members


FindIndex(Predicate) Method | fcSDK Documentation

FindIndex(Predicate) Method

Syntax

'Declaration

Overloads Function FindIndex( _
   ByVal _match_ As Predicate(Of IHierarchicalStringList) _
) As Integer

int FindIndex(
   Predicate<IHierarchicalStringList> _match_
)

Parameters

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members
Overload List


FindIndex(Int32,Predicate) Method | fcSDK Documentation

FindIndex(Int32,Predicate) Method

Syntax

'Declaration

Overloads Function FindIndex( _
   ByVal _startIndex_ As Integer, _
   ByVal _match_ As Predicate(Of IHierarchicalStringList) _
) As Integer

int FindIndex(
   int _startIndex_,
   Predicate<IHierarchicalStringList> _match_
)

Parameters

startIndex

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members
Overload List


FindIndex(Int32,Int32,Predicate) Method | fcSDK Documentation

FindIndex(Int32,Int32,Predicate) Method

Syntax

'Declaration

Overloads Function FindIndex( _
   ByVal _startIndex_ As Integer, _
   ByVal _count_ As Integer, _
   ByVal _match_ As Predicate(Of IHierarchicalStringList) _
) As Integer

int FindIndex(
   int _startIndex_,
   int _count_,
   Predicate<IHierarchicalStringList> _match_
)

Parameters

startIndex

count

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members
Overload List


FindLast Method (IHierarchicalStringListCollection) | fcSDK Documentation

FindLast Method (IHierarchicalStringListCollection)

Syntax

'Declaration

Function FindLast( _
   ByVal _match_ As Predicate(Of IHierarchicalStringList) _
) As IHierarchicalStringList

IHierarchicalStringList FindLast(
   Predicate<IHierarchicalStringList> _match_
)

Parameters

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members


FindLastIndex Method (IHierarchicalStringListCollection) | fcSDK Documentation

FindLastIndex Method (IHierarchicalStringListCollection)

Overload List

Overload | Description
FindLastIndex(Predicate) |
FindLastIndex(Int32,Predicate) |
FindLastIndex(Int32,Int32,Predicate) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members


FindLastIndex(Predicate) Method | fcSDK Documentation

FindLastIndex(Predicate) Method

Syntax

'Declaration

Overloads Function FindLastIndex( _
   ByVal _match_ As Predicate(Of IHierarchicalStringList) _
) As Integer

int FindLastIndex(
   Predicate<IHierarchicalStringList> _match_
)

Parameters

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members
Overload List


FindLastIndex(Int32,Predicate) Method | fcSDK Documentation

FindLastIndex(Int32,Predicate) Method

Syntax

'Declaration

Overloads Function FindLastIndex( _
   ByVal _startIndex_ As Integer, _
   ByVal _match_ As Predicate(Of IHierarchicalStringList) _
) As Integer

int FindLastIndex(
   int _startIndex_,
   Predicate<IHierarchicalStringList> _match_
)

Parameters

startIndex

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members
Overload List


FindLastIndex(Int32,Int32,Predicate) Method | fcSDK Documentation

FindLastIndex(Int32,Int32,Predicate) Method

Syntax

'Declaration

Overloads Function FindLastIndex( _
   ByVal _startIndex_ As Integer, _
   ByVal _count_ As Integer, _
   ByVal _match_ As Predicate(Of IHierarchicalStringList) _
) As Integer

int FindLastIndex(
   int _startIndex_,
   int _count_,
   Predicate<IHierarchicalStringList> _match_
)

Parameters

startIndex

count

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members
Overload List


ForEach Method (IHierarchicalStringListCollection) | fcSDK Documentation

ForEach Method (IHierarchicalStringListCollection)

Syntax

'Declaration
Sub ForEach( _
   ByVal _action_ As Action(Of IHierarchicalStringList) _
)

void ForEach(
   Action<IHierarchicalStringList> _action_
)

Parameters

action

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members


GetItemByIndex Method (IHierarchicalStringListCollection) | fcSDK Documentation

GetItemByIndex Method (IHierarchicalStringListCollection)

Syntax

'Declaration

Function GetItemByIndex( _
   ByVal _index_ As Integer _
) As IHierarchicalStringList

IHierarchicalStringList GetItemByIndex(
   int _index_
)

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members


GetRange Method (IHierarchicalStringListCollection) | fcSDK Documentation

GetRange Method (IHierarchicalStringListCollection)

Syntax

'Declaration

Function GetRange( _
   ByVal _index_ As Integer, _
   ByVal _count_ As Integer _
) As List(Of IHierarchicalStringList)

List<IHierarchicalStringList> GetRange(
   int _index_,
   int _count_
)

Parameters

index

count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members


IndexOf Method (IHierarchicalStringListCollection) | fcSDK Documentation

IndexOf Method (IHierarchicalStringListCollection)

Overload List

Overload | Description
IndexOf(IHierarchicalStringList,Int32) |
IndexOf(IHierarchicalStringList,Int32,Int32) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members


IndexOf(IHierarchicalStringList,Int32) Method | fcSDK Documentation

IndexOf(IHierarchicalStringList,Int32) Method

Syntax

'Declaration

Overloads Function IndexOf( _
   ByVal _item_ As IHierarchicalStringList, _
   ByVal _index_ As Integer _
) As Integer

int IndexOf(
   IHierarchicalStringList _item_,
   int _index_
)

Parameters

item

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members
Overload List


IndexOf(IHierarchicalStringList,Int32,Int32) Method | fcSDK Documentation

IndexOf(IHierarchicalStringList,Int32,Int32) Method

Syntax

'Declaration

Overloads Function IndexOf( _
   ByVal _item_ As IHierarchicalStringList, _
   ByVal _index_ As Integer, _
   ByVal _count_ As Integer _
) As Integer

int IndexOf(
   IHierarchicalStringList _item_,
   int _index_,
   int _count_
)

Parameters

item

index

count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members
Overload List


InsertRange Method (IHierarchicalStringListCollection) | fcSDK Documentation

InsertRange Method (IHierarchicalStringListCollection)

Syntax

'Declaration

Sub InsertRange( _
   ByVal _index_ As Integer, _
   ByVal _collection_ As IEnumerable(Of IHierarchicalStringList) _
)

void InsertRange(
   int _index_,
   IEnumerable<IHierarchicalStringList> _collection_
)

Parameters

index

collection

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members


LastIndexOf Method (IHierarchicalStringListCollection) | fcSDK Documentation

LastIndexOf Method (IHierarchicalStringListCollection)

Overload List

Overload | Description
LastIndexOf(IHierarchicalStringList) |
LastIndexOf(IHierarchicalStringList,Int32) |
LastIndexOf(IHierarchicalStringList,Int32,Int32) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members


LastIndexOf(IHierarchicalStringList) Method | fcSDK Documentation

LastIndexOf(IHierarchicalStringList) Method

Syntax

'Declaration

Overloads Function LastIndexOf( _
   ByVal _item_ As IHierarchicalStringList _
) As Integer

int LastIndexOf(
   IHierarchicalStringList _item_
)

Parameters

item

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members
Overload List


LastIndexOf(IHierarchicalStringList,Int32) Method | fcSDK Documentation

LastIndexOf(IHierarchicalStringList,Int32) Method

Syntax

'Declaration

Overloads Function LastIndexOf( _
   ByVal _item_ As IHierarchicalStringList, _
   ByVal _index_ As Integer _
) As Integer

int LastIndexOf(
   IHierarchicalStringList _item_,
   int _index_
)

Parameters

item

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members
Overload List


LastIndexOf(IHierarchicalStringList,Int32,Int32) Method | fcSDK Documentation

LastIndexOf(IHierarchicalStringList,Int32,Int32) Method

Syntax

'Declaration

Overloads Function LastIndexOf( _
   ByVal _item_ As IHierarchicalStringList, _
   ByVal _index_ As Integer, _
   ByVal _count_ As Integer _
) As Integer

int LastIndexOf(
   IHierarchicalStringList _item_,
   int _index_,
   int _count_
)

Parameters

item

index

count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members
Overload List


RemoveAll Method (IHierarchicalStringListCollection) | fcSDK Documentation

RemoveAll Method (IHierarchicalStringListCollection)

Syntax

'Declaration
Function RemoveAll( _
   ByVal _match_ As Predicate(Of IHierarchicalStringList) _
) As Integer

int RemoveAll(
   Predicate<IHierarchicalStringList> _match_
)

Parameters

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members


RemoveRange Method (IHierarchicalStringListCollection) | fcSDK Documentation

RemoveRange Method (IHierarchicalStringListCollection)

Syntax

'Declaration

Sub RemoveRange( _
   ByVal _index_ As Integer, _
   ByVal _count_ As Integer _
)

void RemoveRange(
   int _index_,
   int _count_
)

Parameters

index

count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members


Reverse Method (IHierarchicalStringListCollection) | fcSDK Documentation

Reverse Method (IHierarchicalStringListCollection)

Overload List

Overload | Description
Reverse() |
Reverse(Int32,Int32) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members


Reverse() Method | fcSDK Documentation

Reverse() Method

Syntax

'Declaration

Overloads Sub Reverse()

void Reverse()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members
Overload List


Reverse(Int32,Int32) Method | fcSDK Documentation

Reverse(Int32,Int32) Method

Syntax

'Declaration

Overloads Sub Reverse( _
   ByVal _index_ As Integer, _
   ByVal _count_ As Integer _
)

void Reverse(
   int _index_,
   int _count_
)

Parameters

index

count

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members
Overload List


Sort Method (IHierarchicalStringListCollection) | fcSDK Documentation

Sort Method (IHierarchicalStringListCollection)

Overload List

Overload | Description
Sort() |
Sort(IComparer) |
Sort(Int32,Int32,IComparer) |
Sort(Comparison) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members


Sort() Method | fcSDK Documentation

Sort() Method

Syntax

'Declaration

Overloads Sub Sort()

void Sort()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members
Overload List


Sort(IComparer) Method | fcSDK Documentation

Sort(IComparer) Method

Syntax

'Declaration

Overloads Sub Sort( _
   ByVal _comparer_ As IComparer(Of IHierarchicalStringList) _
)

void Sort(
   IComparer<IHierarchicalStringList> _comparer_
)

Parameters

comparer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members
Overload List


Sort(Int32,Int32,IComparer) Method | fcSDK Documentation

Sort(Int32,Int32,IComparer) Method

Syntax

'Declaration

Overloads Sub Sort( _
   ByVal _index_ As Integer, _
   ByVal _count_ As Integer, _
   ByVal _comparer_ As IComparer(Of IHierarchicalStringList) _
)

void Sort(
   int _index_,
   int _count_,
   IComparer<IHierarchicalStringList> _comparer_
)

Parameters

index

count

comparer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members
Overload List


Sort(Comparison) Method | fcSDK Documentation

Sort(Comparison) Method

Syntax

'Declaration

Overloads Sub Sort( _
   ByVal _comparison_ As Comparison(Of IHierarchicalStringList) _
)

void Sort(
   Comparison<IHierarchicalStringList> _comparison_
)

Parameters

comparison

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members
Overload List


ToArray Method (IHierarchicalStringListCollection) | fcSDK Documentation

ToArray Method (IHierarchicalStringListCollection)

Syntax

'Declaration

Function ToArray() As IHierarchicalStringList()

IHierarchicalStringList[] ToArray()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members


TrimExcess Method (IHierarchicalStringListCollection) | fcSDK Documentation

TrimExcess Method (IHierarchicalStringListCollection)

Syntax

'Declaration

Sub TrimExcess()

void TrimExcess()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members


TrueForAll Method (IHierarchicalStringListCollection) | fcSDK Documentation

TrueForAll Method (IHierarchicalStringListCollection)

Syntax

'Declaration
Function TrueForAll( _
   ByVal _match_ As Predicate(Of IHierarchicalStringList) _
) As Boolean

bool TrueForAll(
   Predicate<IHierarchicalStringList> _match_
)

Parameters

match

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members


Capacity Property (IHierarchicalStringListCollection) | fcSDK Documentation

Capacity Property (IHierarchicalStringListCollection)

Syntax

'Declaration

Property Capacity As Integer

int Capacity {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members


Item Property (IHierarchicalStringListCollection) | fcSDK Documentation

Item Property (IHierarchicalStringListCollection)

Syntax

'Declaration
ReadOnly Default Property Item( _
   ByVal _title_ As String _
) As IHierarchicalStringList

IHierarchicalStringList this[
   string _title_
]; {get;}

Parameters

title

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IHierarchicalStringListCollection Interface
IHierarchicalStringListCollection Members


FChoice.Foundation.Clarify.Schema Namespace | fcSDK Documentation

FChoice.Foundation.Clarify.Schema Namespace

The FChoice.Foundation.Clarify.Schema namespace contains classes which allow object-oriented access to the Clarify system Schema (ADP) objects.

Classes

 | Class | Description
Class | RestrictionClause |
Class | SchemaFieldBase |
Class | SchemaFieldCollectionBase |
Class | SchemaRelation |
Class | SchemaRelationCollection |
Class | SchemaTable |
Class | SchemaTableBase |
Class | SchemaTableCollection |
Class | SchemaTableField |
Class | SchemaTableFieldCollection |
Class | SchemaView |
Class | SchemaViewCollection |
Class | SchemaViewField |
Class | SchemaViewFieldCollection |
Class | SchemaViewFieldInfo |
Class | SchemaViewFieldInfoCollection |
Class | SchemaViewJoin |
Class | SchemaViewJoinCollection |

Enumerations

 | Enumeration | Description
Enumeration | SchemaCommonType |
Enumeration | SchemaDataType |

Reference

fcSDK Assembly


RestrictionClause Class | fcSDK Documentation

RestrictionClause Class

Syntax

'Declaration

Public Class RestrictionClause

public class RestrictionClause

Inheritance Hierarchy

System.Object
FChoice.Foundation.Clarify.Schema.RestrictionClause

Requirements

Namespace: FChoice.Foundation.Clarify.Schema

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

RestrictionClause Members
FChoice.Foundation.Clarify.Schema Namespace


RestrictionClause Class Members | fcSDK Documentation

RestrictionClause Class Members

The following tables list the members exposed by RestrictionClause.

Public Constructors

 | Name | Description
Public Constructor | RestrictionClause Constructor |

Public Properties

 | Name | Description
Public Property | Clause |
Public Property | FieldName |
Public Property | TableName |

Reference

RestrictionClause Class
FChoice.Foundation.Clarify.Schema Namespace


RestrictionClause Constructor | fcSDK Documentation

RestrictionClause Constructor

Syntax

'Declaration

Public Function New( _
   ByVal _tableName_ As String, _
   ByVal _fieldName_ As String, _
   ByVal _clause_ As String _
)

public RestrictionClause(
   string _tableName_,
   string _fieldName_,
   string _clause_
)

Parameters

tableName

fieldName

clause

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RestrictionClause Class
RestrictionClause Members


Clause Property | fcSDK Documentation

Clause Property

Syntax

'Declaration

Public ReadOnly Property Clause As String

public string Clause {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RestrictionClause Class
RestrictionClause Members


FieldName Property (RestrictionClause) | fcSDK Documentation

FieldName Property (RestrictionClause)

Syntax

'Declaration

Public ReadOnly Property FieldName As String

public string FieldName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RestrictionClause Class
RestrictionClause Members


TableName Property (RestrictionClause) | fcSDK Documentation

TableName Property (RestrictionClause)

Syntax

'Declaration

Public ReadOnly Property TableName As String

public string TableName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RestrictionClause Class
RestrictionClause Members


SchemaFieldBase Class | fcSDK Documentation

SchemaFieldBase Class

Syntax

'Declaration

Public MustInherit Class SchemaFieldBase
   Inherits FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject
   Implements FChoice.Foundation.DataObjects.IDataObject, FChoice.Foundation.Schema.ISchemaField

public abstract class SchemaFieldBase : FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject, FChoice.Foundation.DataObjects.IDataObject, FChoice.Foundation.Schema.ISchemaField

Inheritance Hierarchy

System.Object
FChoice.Foundation.DataObjects.DataObject
FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject
FChoice.Foundation.Clarify.Schema.SchemaFieldBase
FChoice.Foundation.Clarify.Schema.SchemaTableField
FChoice.Foundation.Clarify.Schema.SchemaViewField

Requirements

Namespace: FChoice.Foundation.Clarify.Schema

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

SchemaFieldBase Members
FChoice.Foundation.Clarify.Schema Namespace


SchemaFieldBase Class Members | fcSDK Documentation

SchemaFieldBase Class Members

The following tables list the members exposed by SchemaFieldBase.

Public Properties

 | Name | Description
Public Property | ArraySize |
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | CommonType |
Public Property | DatabaseType |
Public Property | DecimalPrecision |
Public Property | DecimalScale |
Public Property | Default |
Public Property | DefaultString |
Public Property | FCFlags |
Public Property | FieldDefault |
Public Property | FieldDefaultString |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Flags |
Public Property | GenFieldID |
Public Property | IsSearchable |
Public Property | IsUnicode |
Public Property | Name |
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | ObjectType |
Public Property | Parent |
Public Property | ParentTypeID |
Public Property | SpecificFieldID |
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | IsDate |
Public Method | IsInteger |
Public Method | IsNumeric |
Public Method | IsString |

Reference

SchemaFieldBase Class
FChoice.Foundation.Clarify.Schema Namespace


IsDate Method (SchemaFieldBase) | fcSDK Documentation

IsDate Method (SchemaFieldBase)

Syntax

'Declaration

Public Function IsDate() As Boolean

public bool IsDate()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaFieldBase Class
SchemaFieldBase Members


IsInteger Method (SchemaFieldBase) | fcSDK Documentation

IsInteger Method (SchemaFieldBase)

Syntax

'Declaration

Public Function IsInteger() As Boolean

public bool IsInteger()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaFieldBase Class
SchemaFieldBase Members


IsNumeric Method (SchemaFieldBase) | fcSDK Documentation

IsNumeric Method (SchemaFieldBase)

Syntax

'Declaration

Public Function IsNumeric() As Boolean

public bool IsNumeric()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaFieldBase Class
SchemaFieldBase Members


IsString Method (SchemaFieldBase) | fcSDK Documentation

IsString Method (SchemaFieldBase)

Syntax

'Declaration

Public Function IsString() As Boolean

public bool IsString()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaFieldBase Class
SchemaFieldBase Members


ArraySize Property | fcSDK Documentation

ArraySize Property

Syntax

'Declaration

Public ReadOnly Property ArraySize As Integer

public int ArraySize {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaFieldBase Class
SchemaFieldBase Members


CommonType Property (SchemaFieldBase) | fcSDK Documentation

CommonType Property (SchemaFieldBase)

Syntax

'Declaration

Public ReadOnly Property CommonType As Integer

public int CommonType {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaFieldBase Class
SchemaFieldBase Members


DatabaseType Property (SchemaFieldBase) | fcSDK Documentation

DatabaseType Property (SchemaFieldBase)

Syntax

'Declaration

Public ReadOnly Property DatabaseType As Integer

public int DatabaseType {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaFieldBase Class
SchemaFieldBase Members


DecimalPrecision Property | fcSDK Documentation

DecimalPrecision Property

Syntax

'Declaration

Public ReadOnly Property DecimalPrecision As Integer

public int DecimalPrecision {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaFieldBase Class
SchemaFieldBase Members


DecimalScale Property | fcSDK Documentation

DecimalScale Property

Syntax

'Declaration

Public ReadOnly Property DecimalScale As Integer

public int DecimalScale {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaFieldBase Class
SchemaFieldBase Members


Default Property (SchemaFieldBase) | fcSDK Documentation

Default Property (SchemaFieldBase)

Syntax

'Declaration

Public ReadOnly Property Default As Object

public object Default {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaFieldBase Class
SchemaFieldBase Members


DefaultString Property (SchemaFieldBase) | fcSDK Documentation

DefaultString Property (SchemaFieldBase)

Syntax

'Declaration

Public ReadOnly Property DefaultString As String

public string DefaultString {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaFieldBase Class
SchemaFieldBase Members


FCFlags Property | fcSDK Documentation

FCFlags Property

Syntax

'Declaration

Public ReadOnly Property FCFlags As Integer

public int FCFlags {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaFieldBase Class
SchemaFieldBase Members


FieldDefault Property | fcSDK Documentation

FieldDefault Property

Syntax

'Declaration

Public ReadOnly Property FieldDefault As Object

public object FieldDefault {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaFieldBase Class
SchemaFieldBase Members


FieldDefaultString Property | fcSDK Documentation

FieldDefaultString Property

Syntax

'Declaration

Public ReadOnly Property FieldDefaultString As String

public string FieldDefaultString {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaFieldBase Class
SchemaFieldBase Members


Flags Property (SchemaFieldBase) | fcSDK Documentation

Flags Property (SchemaFieldBase)

Syntax

'Declaration

Public ReadOnly Property Flags As Integer

public int Flags {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaFieldBase Class
SchemaFieldBase Members


GenFieldID Property | fcSDK Documentation

GenFieldID Property

Syntax

'Declaration

Public ReadOnly Property GenFieldID As Integer

public int GenFieldID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaFieldBase Class
SchemaFieldBase Members


IsSearchable Property (SchemaFieldBase) | fcSDK Documentation

IsSearchable Property (SchemaFieldBase)

Syntax

'Declaration

Public ReadOnly Property IsSearchable As Boolean

public bool IsSearchable {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaFieldBase Class
SchemaFieldBase Members


IsUnicode Property (SchemaFieldBase) | fcSDK Documentation

IsUnicode Property (SchemaFieldBase)

Syntax

'Declaration

Public ReadOnly Property IsUnicode As Boolean

public bool IsUnicode {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaFieldBase Class
SchemaFieldBase Members


Name Property (SchemaFieldBase) | fcSDK Documentation

Name Property (SchemaFieldBase)

Syntax

'Declaration

Public ReadOnly Property Name As String

public string Name {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaFieldBase Class
SchemaFieldBase Members


ObjectType Property (SchemaFieldBase) | fcSDK Documentation

ObjectType Property (SchemaFieldBase)

Syntax

'Declaration

Public ReadOnly Property ObjectType As Type

public Type ObjectType {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaFieldBase Class
SchemaFieldBase Members


Parent Property | fcSDK Documentation

Parent Property

Syntax

'Declaration

Public ReadOnly Property Parent As SchemaTableBase

public SchemaTableBase Parent {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaFieldBase Class
SchemaFieldBase Members


ParentTypeID Property (SchemaFieldBase) | fcSDK Documentation

ParentTypeID Property (SchemaFieldBase)

Syntax

'Declaration

Public ReadOnly Property ParentTypeID As Integer

public int ParentTypeID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaFieldBase Class
SchemaFieldBase Members


SpecificFieldID Property | fcSDK Documentation

SpecificFieldID Property

Syntax

'Declaration

Public ReadOnly Property SpecificFieldID As Integer

public int SpecificFieldID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaFieldBase Class
SchemaFieldBase Members


SchemaFieldCollectionBase Class | fcSDK Documentation

SchemaFieldCollectionBase Class

Syntax

'Declaration

<DefaultMemberAttribute("Item")>
Public MustInherit Class SchemaFieldCollectionBase
   Inherits FChoice.Foundation.DataObjects.DataObjectCollection(Of SchemaFieldBase)
   Implements FChoice.Foundation.Schema.ISchemaFieldCollection

[DefaultMemberAttribute("Item")]
public abstract class SchemaFieldCollectionBase : FChoice.Foundation.DataObjects.DataObjectCollection<SchemaFieldBase>, FChoice.Foundation.Schema.ISchemaFieldCollection

Inheritance Hierarchy

System.Object
System.Collections.Generic.List
FChoice.Foundation.DataObjects.DataObjectCollection
FChoice.Foundation.Clarify.Schema.SchemaFieldCollectionBase
FChoice.Foundation.Clarify.Schema.SchemaTableFieldCollection
FChoice.Foundation.Clarify.Schema.SchemaViewFieldCollection

Requirements

Namespace: FChoice.Foundation.Clarify.Schema

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

SchemaFieldCollectionBase Members
FChoice.Foundation.Clarify.Schema Namespace


SchemaFieldCollectionBase Class Members | fcSDK Documentation

SchemaFieldCollectionBase Class Members

The following tables list the members exposed by SchemaFieldCollectionBase.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | Item |

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex | (Inherited from FChoice.Foundation.DataObjects.DataObjectCollection)
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

SchemaFieldCollectionBase Class
FChoice.Foundation.Clarify.Schema Namespace


Item Property (SchemaFieldCollectionBase) | fcSDK Documentation

Item Property (SchemaFieldCollectionBase)

Syntax

'Declaration

Public Shadows ReadOnly Default Property Item( _
   ByVal _name_ As String _
) As SchemaFieldBase

public new SchemaFieldBase this[
   string _name_
]; {get;}

Parameters

name

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaFieldCollectionBase Class
SchemaFieldCollectionBase Members


SchemaRelation Class | fcSDK Documentation

SchemaRelation Class

Syntax

'Declaration

Public Class SchemaRelation
   Inherits FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject
   Implements FChoice.Foundation.DataObjects.IDataObject, FChoice.Foundation.Schema.ISchemaRelation

public class SchemaRelation : FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject, FChoice.Foundation.DataObjects.IDataObject, FChoice.Foundation.Schema.ISchemaRelation

Inheritance Hierarchy

System.Object
FChoice.Foundation.DataObjects.DataObject
FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject
FChoice.Foundation.Clarify.Schema.SchemaRelation

Requirements

Namespace: FChoice.Foundation.Clarify.Schema

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

SchemaRelation Members
FChoice.Foundation.Clarify.Schema Namespace


SchemaRelation Class Members | fcSDK Documentation

SchemaRelation Class Members

The following tables list the members exposed by SchemaRelation.

Public Fields

 | Name | Description
Public Field | MANDATORY_REL_OBJID |

Public Properties

 | Name | Description
Public Property | Cardinality |
Public Property | ChildTable |
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Comments |
Public Property | ExclusiveSet |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Flags |
Public Property | FocusFieldName |
Public Property | GenericRelationID |
Public Property | InverseRelation |
Public Property | InverseRelationName |
Public Property | IsExclusive |
Public Property | IsMandatory |
Public Property | IsMtm |
Public Property | MandatoryObjectID |
Public Property | MtmTableName |
Public Property | Name |
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | ParentTable |
Public Property | ParentTypeID |
Public Property | RelationFlags |
Public Property | RelationPhysicalName |
Public Property | SourceTable |
Public Property | SpecificRelationID |
Public Property | TargetName |
Public Property | TargetTable |
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

SchemaRelation Class
FChoice.Foundation.Clarify.Schema Namespace


Cardinality Property (SchemaRelation) | fcSDK Documentation

Cardinality Property (SchemaRelation)

Syntax

'Declaration

Public ReadOnly Property Cardinality As SchemaRelationCardinality

public SchemaRelationCardinality Cardinality {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaRelation Class
SchemaRelation Members


ChildTable Property (SchemaRelation) | fcSDK Documentation

ChildTable Property (SchemaRelation)

Syntax

'Declaration

Public ReadOnly Property ChildTable As SchemaTable

public SchemaTable ChildTable {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaRelation Class
SchemaRelation Members


Comments Property (SchemaRelation) | fcSDK Documentation

Comments Property (SchemaRelation)

Syntax

'Declaration

Public ReadOnly Property Comments As String

public string Comments {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaRelation Class
SchemaRelation Members


ExclusiveSet Property | fcSDK Documentation

ExclusiveSet Property

Syntax

'Declaration

Public ReadOnly Property ExclusiveSet As String

public string ExclusiveSet {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaRelation Class
SchemaRelation Members


Flags Property (SchemaRelation) | fcSDK Documentation

Flags Property (SchemaRelation)

Syntax

'Declaration

Public ReadOnly Property Flags As Integer

public int Flags {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaRelation Class
SchemaRelation Members


FocusFieldName Property | fcSDK Documentation

FocusFieldName Property

Syntax

'Declaration

Public ReadOnly Property FocusFieldName As String

public string FocusFieldName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaRelation Class
SchemaRelation Members


GenericRelationID Property | fcSDK Documentation

GenericRelationID Property

Syntax

'Declaration

Public ReadOnly Property GenericRelationID As Integer

public int GenericRelationID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaRelation Class
SchemaRelation Members


InverseRelation Property (SchemaRelation) | fcSDK Documentation

InverseRelation Property (SchemaRelation)

Syntax

'Declaration

Public ReadOnly Property InverseRelation As SchemaRelation

public SchemaRelation InverseRelation {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaRelation Class
SchemaRelation Members


InverseRelationName Property | fcSDK Documentation

InverseRelationName Property

Syntax

'Declaration

Public ReadOnly Property InverseRelationName As String

public string InverseRelationName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaRelation Class
SchemaRelation Members


IsExclusive Property (SchemaRelation) | fcSDK Documentation

IsExclusive Property (SchemaRelation)

Syntax

'Declaration

Public ReadOnly Property IsExclusive As Boolean

public bool IsExclusive {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaRelation Class
SchemaRelation Members


IsMandatory Property (SchemaRelation) | fcSDK Documentation

IsMandatory Property (SchemaRelation)

Syntax

'Declaration

Public ReadOnly Property IsMandatory As Boolean

public bool IsMandatory {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaRelation Class
SchemaRelation Members


IsMtm Property (SchemaRelation) | fcSDK Documentation

IsMtm Property (SchemaRelation)

Syntax

'Declaration

Public ReadOnly Property IsMtm As Boolean

public bool IsMtm {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaRelation Class
SchemaRelation Members


MandatoryObjectID Property (SchemaRelation) | fcSDK Documentation

MandatoryObjectID Property (SchemaRelation)

Syntax

'Declaration

Public ReadOnly Property MandatoryObjectID As Object

public object MandatoryObjectID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaRelation Class
SchemaRelation Members


MtmTableName Property (SchemaRelation) | fcSDK Documentation

MtmTableName Property (SchemaRelation)

Syntax

'Declaration

Public ReadOnly Property MtmTableName As String

public string MtmTableName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaRelation Class
SchemaRelation Members


Name Property (SchemaRelation) | fcSDK Documentation

Name Property (SchemaRelation)

Syntax

'Declaration

Public ReadOnly Property Name As String

public string Name {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaRelation Class
SchemaRelation Members


ParentTable Property (SchemaRelation) | fcSDK Documentation

ParentTable Property (SchemaRelation)

Syntax

'Declaration

Public ReadOnly Property ParentTable As SchemaTable

public SchemaTable ParentTable {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaRelation Class
SchemaRelation Members


ParentTypeID Property (SchemaRelation) | fcSDK Documentation

ParentTypeID Property (SchemaRelation)

Syntax

'Declaration

Public ReadOnly Property ParentTypeID As Integer

public int ParentTypeID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaRelation Class
SchemaRelation Members


RelationFlags Property | fcSDK Documentation

RelationFlags Property

Syntax

'Declaration

Public ReadOnly Property RelationFlags As Integer

public int RelationFlags {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaRelation Class
SchemaRelation Members


RelationPhysicalName Property | fcSDK Documentation

RelationPhysicalName Property

Syntax

'Declaration

Public ReadOnly Property RelationPhysicalName As String

public string RelationPhysicalName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaRelation Class
SchemaRelation Members


SourceTable Property (SchemaRelation) | fcSDK Documentation

SourceTable Property (SchemaRelation)

Syntax

'Declaration

Public ReadOnly Property SourceTable As SchemaTable

public SchemaTable SourceTable {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaRelation Class
SchemaRelation Members


SpecificRelationID Property (SchemaRelation) | fcSDK Documentation

SpecificRelationID Property (SchemaRelation)

Syntax

'Declaration

Public ReadOnly Property SpecificRelationID As Integer

public int SpecificRelationID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaRelation Class
SchemaRelation Members


TargetName Property | fcSDK Documentation

TargetName Property

Syntax

'Declaration

Public ReadOnly Property TargetName As String

public string TargetName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaRelation Class
SchemaRelation Members


TargetTable Property (SchemaRelation) | fcSDK Documentation

TargetTable Property (SchemaRelation)

Syntax

'Declaration

Public ReadOnly Property TargetTable As SchemaTable

public SchemaTable TargetTable {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaRelation Class
SchemaRelation Members


MANDATORY_REL_OBJID Field | fcSDK Documentation

MANDATORY_REL_OBJID Field

Syntax

'Declaration
Public Const MANDATORY_REL_OBJID As Integer

public const int MANDATORY_REL_OBJID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaRelation Class
SchemaRelation Members


SchemaRelationCollection Class | fcSDK Documentation

SchemaRelationCollection Class

Syntax

'Declaration

<DefaultMemberAttribute("Item")>
Public Class SchemaRelationCollection
   Inherits FChoice.Foundation.DataObjects.DataObjectCollection(Of SchemaRelation)
   Implements FChoice.Foundation.Schema.ISchemaRelationCollection

[DefaultMemberAttribute("Item")]
public class SchemaRelationCollection : FChoice.Foundation.DataObjects.DataObjectCollection<SchemaRelation>, FChoice.Foundation.Schema.ISchemaRelationCollection

Inheritance Hierarchy

System.Object
System.Collections.Generic.List
FChoice.Foundation.DataObjects.DataObjectCollection
FChoice.Foundation.Clarify.Schema.SchemaRelationCollection

Requirements

Namespace: FChoice.Foundation.Clarify.Schema

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

SchemaRelationCollection Members
FChoice.Foundation.Clarify.Schema Namespace


SchemaRelationCollection Class Members | fcSDK Documentation

SchemaRelationCollection Class Members

The following tables list the members exposed by SchemaRelationCollection.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | Item |
Public Property | OtmOtofAndMtmRelations |

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex | (Inherited from FChoice.Foundation.DataObjects.DataObjectCollection)
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

SchemaRelationCollection Class
FChoice.Foundation.Clarify.Schema Namespace


Item Property (SchemaRelationCollection) | fcSDK Documentation

Item Property (SchemaRelationCollection)

Syntax

'Declaration

Public Shadows ReadOnly Default Property Item( _
   ByVal _relationName_ As String _
) As SchemaRelation

public new SchemaRelation this[
   string _relationName_
]; {get;}

Parameters

relationName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaRelationCollection Class
SchemaRelationCollection Members


OtmOtofAndMtmRelations Property | fcSDK Documentation

OtmOtofAndMtmRelations Property

Syntax

'Declaration

Public ReadOnly Property OtmOtofAndMtmRelations As ICollection(Of SchemaRelation)

public ICollection<SchemaRelation> OtmOtofAndMtmRelations {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaRelationCollection Class
SchemaRelationCollection Members


SchemaTable Class | fcSDK Documentation

SchemaTable Class

Syntax

'Declaration

Public Class SchemaTable
   Inherits SchemaTableBase
   Implements FChoice.Foundation.DataObjects.IDataObject, FChoice.Foundation.Schema.ISchemaTable, FChoice.Foundation.Schema.ISchemaTableBase

public class SchemaTable : SchemaTableBase, FChoice.Foundation.DataObjects.IDataObject, FChoice.Foundation.Schema.ISchemaTable, FChoice.Foundation.Schema.ISchemaTableBase

Inheritance Hierarchy

System.Object
FChoice.Foundation.DataObjects.DataObject
FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject
FChoice.Foundation.Clarify.Schema.SchemaTableBase
FChoice.Foundation.Clarify.Schema.SchemaTable

Requirements

Namespace: FChoice.Foundation.Clarify.Schema

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

SchemaTable Members
FChoice.Foundation.Clarify.Schema Namespace


SchemaTable Class Members | fcSDK Documentation

SchemaTable Class Members

The following tables list the members exposed by SchemaTable.

Public Properties

 | Name | Description
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Comments | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaTableBase)
Public Property | Fields |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Flags | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaTableBase)
Public Property | IsDataRestricted | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaTableBase)
Public Property | IsUnicode | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaTableBase)
Public Property | Name | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaTableBase)
Public Property | ObjectGroup | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaTableBase)
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | Relationships |
Public Property | RestrictedFields | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaTableBase)
Public Property | RestrictionClauses | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaTableBase)
Public Property | TypeID | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaTableBase)
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Views |

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

SchemaTable Class
FChoice.Foundation.Clarify.Schema Namespace


Fields Property (SchemaTable) | fcSDK Documentation

Fields Property (SchemaTable)

Syntax

'Declaration

Public Shadows ReadOnly Property Fields As SchemaTableFieldCollection

public new SchemaTableFieldCollection Fields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaTable Class
SchemaTable Members


Relationships Property (SchemaTable) | fcSDK Documentation

Relationships Property (SchemaTable)

Syntax

'Declaration

Public ReadOnly Property Relationships As SchemaRelationCollection

public SchemaRelationCollection Relationships {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaTable Class
SchemaTable Members


Views Property (SchemaTable) | fcSDK Documentation

Views Property (SchemaTable)

Syntax

'Declaration

Public ReadOnly Property Views As SchemaViewCollection

public SchemaViewCollection Views {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaTable Class
SchemaTable Members


SchemaTableBase Class | fcSDK Documentation

SchemaTableBase Class

Syntax

'Declaration

Public MustInherit Class SchemaTableBase
   Inherits FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject
   Implements FChoice.Foundation.DataObjects.IDataObject, FChoice.Foundation.Schema.ISchemaTableBase

public abstract class SchemaTableBase : FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject, FChoice.Foundation.DataObjects.IDataObject, FChoice.Foundation.Schema.ISchemaTableBase

Inheritance Hierarchy

System.Object
FChoice.Foundation.DataObjects.DataObject
FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject
FChoice.Foundation.Clarify.Schema.SchemaTableBase
FChoice.Foundation.Clarify.Schema.SchemaTable
FChoice.Foundation.Clarify.Schema.SchemaView

Requirements

Namespace: FChoice.Foundation.Clarify.Schema

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

SchemaTableBase Members
FChoice.Foundation.Clarify.Schema Namespace


SchemaTableBase Class Members | fcSDK Documentation

SchemaTableBase Class Members

The following tables list the members exposed by SchemaTableBase.

Public Properties

 | Name | Description
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Comments |
Public Property | Fields |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Flags |
Public Property | IsDataRestricted |
Public Property | IsUnicode |
Public Property | Name |
Public Property | ObjectGroup |
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | RestrictedFields |
Public Property | RestrictionClauses |
Public Property | TypeID |
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

SchemaTableBase Class
FChoice.Foundation.Clarify.Schema Namespace


Comments Property (SchemaTableBase) | fcSDK Documentation

Comments Property (SchemaTableBase)

Syntax

'Declaration

Public ReadOnly Property Comments As String

public string Comments {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaTableBase Class
SchemaTableBase Members


Fields Property (SchemaTableBase) | fcSDK Documentation

Fields Property (SchemaTableBase)

Syntax

'Declaration

Public ReadOnly Property Fields As SchemaFieldCollectionBase

public SchemaFieldCollectionBase Fields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaTableBase Class
SchemaTableBase Members


Flags Property (SchemaTableBase) | fcSDK Documentation

Flags Property (SchemaTableBase)

Syntax

'Declaration

Public ReadOnly Property Flags As Integer

public int Flags {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaTableBase Class
SchemaTableBase Members


IsDataRestricted Property (SchemaTableBase) | fcSDK Documentation

IsDataRestricted Property (SchemaTableBase)

Syntax

'Declaration

Public ReadOnly Property IsDataRestricted As Boolean

public bool IsDataRestricted {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaTableBase Class
SchemaTableBase Members


IsUnicode Property (SchemaTableBase) | fcSDK Documentation

IsUnicode Property (SchemaTableBase)

Syntax

'Declaration

Public ReadOnly Property IsUnicode As Boolean

public bool IsUnicode {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaTableBase Class
SchemaTableBase Members


Name Property (SchemaTableBase) | fcSDK Documentation

Name Property (SchemaTableBase)

Syntax

'Declaration

Public ReadOnly Property Name As String

public string Name {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaTableBase Class
SchemaTableBase Members


ObjectGroup Property | fcSDK Documentation

ObjectGroup Property

Syntax

'Declaration

Public ReadOnly Property ObjectGroup As String

public string ObjectGroup {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaTableBase Class
SchemaTableBase Members


RestrictedFields Property | fcSDK Documentation

RestrictedFields Property

Syntax

'Declaration

Public ReadOnly Property RestrictedFields As SchemaFieldBase()

public SchemaFieldBase[] RestrictedFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaTableBase Class
SchemaTableBase Members


RestrictionClauses Property | fcSDK Documentation

RestrictionClauses Property

Syntax

'Declaration

Public ReadOnly Property RestrictionClauses As RestrictionClause()

public RestrictionClause[] RestrictionClauses {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaTableBase Class
SchemaTableBase Members


TypeID Property | fcSDK Documentation

TypeID Property

Syntax

'Declaration

Public ReadOnly Property TypeID As Integer

public int TypeID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaTableBase Class
SchemaTableBase Members


SchemaTableCollection Class | fcSDK Documentation

SchemaTableCollection Class

Syntax

'Declaration

<DefaultMemberAttribute("Item")>
Public Class SchemaTableCollection
   Inherits FChoice.Foundation.DataObjects.DataObjectCollection(Of SchemaTable)
   Implements FChoice.Foundation.Schema.ISchemaTableCollection

[DefaultMemberAttribute("Item")]
public class SchemaTableCollection : FChoice.Foundation.DataObjects.DataObjectCollection<SchemaTable>, FChoice.Foundation.Schema.ISchemaTableCollection

Inheritance Hierarchy

System.Object
System.Collections.Generic.List
FChoice.Foundation.DataObjects.DataObjectCollection
FChoice.Foundation.Clarify.Schema.SchemaTableCollection

Requirements

Namespace: FChoice.Foundation.Clarify.Schema

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

SchemaTableCollection Members
FChoice.Foundation.Clarify.Schema Namespace


SchemaTableCollection Class Members | fcSDK Documentation

SchemaTableCollection Class Members

The following tables list the members exposed by SchemaTableCollection.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | Item |

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetByNumber |
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex | (Inherited from FChoice.Foundation.DataObjects.DataObjectCollection)
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

SchemaTableCollection Class
FChoice.Foundation.Clarify.Schema Namespace


GetByNumber Method (SchemaTableCollection) | fcSDK Documentation

GetByNumber Method (SchemaTableCollection)

Syntax

'Declaration

Public Function GetByNumber( _
   ByVal _tableID_ As Integer _
) As SchemaTable

public SchemaTable GetByNumber(
   int _tableID_
)

Parameters

tableID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaTableCollection Class
SchemaTableCollection Members


Item Property (SchemaTableCollection) | fcSDK Documentation

Item Property (SchemaTableCollection)

Syntax

'Declaration

Public Shadows ReadOnly Default Property Item( _
   ByVal _tableName_ As String _
) As SchemaTable

public new SchemaTable this[
   string _tableName_
]; {get;}

Parameters

tableName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaTableCollection Class
SchemaTableCollection Members


SchemaTableField Class | fcSDK Documentation

SchemaTableField Class

Syntax

'Declaration

Public Class SchemaTableField
   Inherits SchemaFieldBase
   Implements FChoice.Foundation.DataObjects.IDataObject, FChoice.Foundation.Schema.ISchemaField

public class SchemaTableField : SchemaFieldBase, FChoice.Foundation.DataObjects.IDataObject, FChoice.Foundation.Schema.ISchemaField

Inheritance Hierarchy

System.Object
FChoice.Foundation.DataObjects.DataObject
FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject
FChoice.Foundation.Clarify.Schema.SchemaFieldBase
FChoice.Foundation.Clarify.Schema.SchemaTableField

Requirements

Namespace: FChoice.Foundation.Clarify.Schema

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

SchemaTableField Members
FChoice.Foundation.Clarify.Schema Namespace


SchemaTableField Class Members | fcSDK Documentation

SchemaTableField Class Members

The following tables list the members exposed by SchemaTableField.

Public Properties

 | Name | Description
Public Property | ArraySize | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | CommonType | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | DatabaseType | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | DecimalPrecision | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | DecimalScale | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | Default | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | DefaultString | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | FCFlags | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | FieldDefault | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | FieldDefaultString | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Flags | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | GenFieldID | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | IsSearchable | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | IsUnicode | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | Name | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | ObjectType | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | Parent | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | ParentTypeID | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | SpecificFieldID | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | Table |
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | ViewFieldInfos |

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | IsDate | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Method | IsInteger | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Method | IsNumeric | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Method | IsString | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)

Reference

SchemaTableField Class
FChoice.Foundation.Clarify.Schema Namespace


Table Property (SchemaTableField) | fcSDK Documentation

Table Property (SchemaTableField)

Syntax

'Declaration

Public ReadOnly Property Table As SchemaTable

public SchemaTable Table {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaTableField Class
SchemaTableField Members


ViewFieldInfos Property | fcSDK Documentation

ViewFieldInfos Property

Syntax

'Declaration

Public ReadOnly Property ViewFieldInfos As SchemaViewFieldInfoCollection

public SchemaViewFieldInfoCollection ViewFieldInfos {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaTableField Class
SchemaTableField Members


SchemaTableFieldCollection Class | fcSDK Documentation

SchemaTableFieldCollection Class

Syntax

'Declaration

<DefaultMemberAttribute("Item")>
Public Class SchemaTableFieldCollection
   Inherits SchemaFieldCollectionBase
   Implements FChoice.Foundation.Schema.ISchemaFieldCollection

[DefaultMemberAttribute("Item")]
public class SchemaTableFieldCollection : SchemaFieldCollectionBase, FChoice.Foundation.Schema.ISchemaFieldCollection

Inheritance Hierarchy

System.Object
System.Collections.Generic.List
FChoice.Foundation.DataObjects.DataObjectCollection
FChoice.Foundation.Clarify.Schema.SchemaFieldCollectionBase
FChoice.Foundation.Clarify.Schema.SchemaTableFieldCollection

Requirements

Namespace: FChoice.Foundation.Clarify.Schema

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

SchemaTableFieldCollection Members
FChoice.Foundation.Clarify.Schema Namespace


SchemaTableFieldCollection Class Members | fcSDK Documentation

SchemaTableFieldCollection Class Members

The following tables list the members exposed by SchemaTableFieldCollection.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | Item | Overloaded.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex | (Inherited from FChoice.Foundation.DataObjects.DataObjectCollection)
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

SchemaTableFieldCollection Class
FChoice.Foundation.Clarify.Schema Namespace


Item Property (SchemaTableFieldCollection) | fcSDK Documentation

Item Property (SchemaTableFieldCollection)

Overload List

Overload | Description
Item(String) |
Item(Int32) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaTableFieldCollection Class
SchemaTableFieldCollection Members


Item(String) Property | fcSDK Documentation

Item(String) Property

Syntax

'Declaration

Public Overloads Shadows ReadOnly Property Item( _
   ByVal _fieldName_ As String _
) As SchemaTableField

public new SchemaTableField Item(
   string _fieldName_
) {get;}

Parameters

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaTableFieldCollection Class
SchemaTableFieldCollection Members
Overload List


Item(Int32) Property | fcSDK Documentation

Item(Int32) Property

Syntax

'Declaration

Public Overloads Shadows ReadOnly Property Item( _
   ByVal _fieldID_ As Integer _
) As SchemaTableField

public new SchemaTableField Item(
   int _fieldID_
) {get;}

Parameters

fieldID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaTableFieldCollection Class
SchemaTableFieldCollection Members
Overload List


SchemaView Class | fcSDK Documentation

SchemaView Class

Syntax

'Declaration

Public Class SchemaView
   Inherits SchemaTableBase
   Implements FChoice.Foundation.DataObjects.IDataObject, FChoice.Foundation.Schema.ISchemaTableBase, FChoice.Foundation.Schema.ISchemaView

public class SchemaView : SchemaTableBase, FChoice.Foundation.DataObjects.IDataObject, FChoice.Foundation.Schema.ISchemaTableBase, FChoice.Foundation.Schema.ISchemaView

Inheritance Hierarchy

System.Object
FChoice.Foundation.DataObjects.DataObject
FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject
FChoice.Foundation.Clarify.Schema.SchemaTableBase
FChoice.Foundation.Clarify.Schema.SchemaView

Requirements

Namespace: FChoice.Foundation.Clarify.Schema

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

SchemaView Members
FChoice.Foundation.Clarify.Schema Namespace


SchemaView Class Members | fcSDK Documentation

SchemaView Class Members

The following tables list the members exposed by SchemaView.

Public Properties

 | Name | Description
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Comments | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaTableBase)
Public Property | Fields |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Flags | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaTableBase)
Public Property | IsDataRestricted | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaTableBase)
Public Property | IsSqlView |
Public Property | IsUnicode | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaTableBase)
Public Property | Joins |
Public Property | Name | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaTableBase)
Public Property | ObjectGroup | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaTableBase)
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | RestrictedFields | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaTableBase)
Public Property | RestrictionClauses | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaTableBase)
Public Property | TypeID | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaTableBase)
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

SchemaView Class
FChoice.Foundation.Clarify.Schema Namespace


Fields Property (SchemaView) | fcSDK Documentation

Fields Property (SchemaView)

Syntax

'Declaration

Public Shadows ReadOnly Property Fields As SchemaViewFieldCollection

public new SchemaViewFieldCollection Fields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaView Class
SchemaView Members


IsSqlView Property | fcSDK Documentation

IsSqlView Property

Syntax

'Declaration

Public ReadOnly Property IsSqlView As Boolean

public bool IsSqlView {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaView Class
SchemaView Members


Joins Property (SchemaView) | fcSDK Documentation

Joins Property (SchemaView)

Syntax

'Declaration

Public ReadOnly Property Joins As SchemaViewJoinCollection

public SchemaViewJoinCollection Joins {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaView Class
SchemaView Members


SchemaViewCollection Class | fcSDK Documentation

SchemaViewCollection Class

Syntax

'Declaration

<DefaultMemberAttribute("Item")>
Public Class SchemaViewCollection
   Inherits FChoice.Foundation.DataObjects.DataObjectCollection(Of SchemaView)
   Implements FChoice.Foundation.Schema.ISchemaViewCollection

[DefaultMemberAttribute("Item")]
public class SchemaViewCollection : FChoice.Foundation.DataObjects.DataObjectCollection<SchemaView>, FChoice.Foundation.Schema.ISchemaViewCollection

Inheritance Hierarchy

System.Object
System.Collections.Generic.List
FChoice.Foundation.DataObjects.DataObjectCollection
FChoice.Foundation.Clarify.Schema.SchemaViewCollection

Requirements

Namespace: FChoice.Foundation.Clarify.Schema

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

SchemaViewCollection Members
FChoice.Foundation.Clarify.Schema Namespace


SchemaViewCollection Class Members | fcSDK Documentation

SchemaViewCollection Class Members

The following tables list the members exposed by SchemaViewCollection.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | Item |

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetByNumber |
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex | (Inherited from FChoice.Foundation.DataObjects.DataObjectCollection)
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

SchemaViewCollection Class
FChoice.Foundation.Clarify.Schema Namespace


GetByNumber Method (SchemaViewCollection) | fcSDK Documentation

GetByNumber Method (SchemaViewCollection)

Syntax

'Declaration

Public Function GetByNumber( _
   ByVal _viewID_ As Integer _
) As SchemaView

public SchemaView GetByNumber(
   int _viewID_
)

Parameters

viewID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaViewCollection Class
SchemaViewCollection Members


Item Property (SchemaViewCollection) | fcSDK Documentation

Item Property (SchemaViewCollection)

Syntax

'Declaration

Public Shadows ReadOnly Default Property Item( _
   ByVal _viewName_ As String _
) As SchemaView

public new SchemaView this[
   string _viewName_
]; {get;}

Parameters

viewName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaViewCollection Class
SchemaViewCollection Members


SchemaViewField Class | fcSDK Documentation

SchemaViewField Class

Syntax

'Declaration

Public Class SchemaViewField
   Inherits SchemaFieldBase
   Implements FChoice.Foundation.DataObjects.IDataObject, FChoice.Foundation.Schema.ISchemaField

public class SchemaViewField : SchemaFieldBase, FChoice.Foundation.DataObjects.IDataObject, FChoice.Foundation.Schema.ISchemaField

Inheritance Hierarchy

System.Object
FChoice.Foundation.DataObjects.DataObject
FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject
FChoice.Foundation.Clarify.Schema.SchemaFieldBase
FChoice.Foundation.Clarify.Schema.SchemaViewField

Requirements

Namespace: FChoice.Foundation.Clarify.Schema

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

SchemaViewField Members
FChoice.Foundation.Clarify.Schema Namespace


SchemaViewField Class Members | fcSDK Documentation

SchemaViewField Class Members

The following tables list the members exposed by SchemaViewField.

Public Properties

 | Name | Description
Public Property | ArraySize | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | CommonType | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | DatabaseType | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | DecimalPrecision | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | DecimalScale | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | Default | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | DefaultString | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | FCFlags | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | FieldDefault | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | FieldDefaultString | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | FieldInfo |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Flags | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | GenFieldID | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | IsSearchable | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | IsUnicode | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | Name | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | ObjectType | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | Parent | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | ParentTypeID | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | SpecificFieldID | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | View |

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | IsDate | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Method | IsInteger | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Method | IsNumeric | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Method | IsString | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)

Reference

SchemaViewField Class
FChoice.Foundation.Clarify.Schema Namespace


FieldInfo Property | fcSDK Documentation

FieldInfo Property

Syntax

'Declaration

Public ReadOnly Property FieldInfo As SchemaViewFieldInfo

public SchemaViewFieldInfo FieldInfo {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaViewField Class
SchemaViewField Members


View Property | fcSDK Documentation

View Property

Syntax

'Declaration

Public ReadOnly Property View As SchemaView

public SchemaView View {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaViewField Class
SchemaViewField Members


SchemaViewFieldCollection Class | fcSDK Documentation

SchemaViewFieldCollection Class

Syntax

'Declaration

<DefaultMemberAttribute("Item")>
Public Class SchemaViewFieldCollection
   Inherits SchemaFieldCollectionBase
   Implements FChoice.Foundation.Schema.ISchemaFieldCollection

[DefaultMemberAttribute("Item")]
public class SchemaViewFieldCollection : SchemaFieldCollectionBase, FChoice.Foundation.Schema.ISchemaFieldCollection

Inheritance Hierarchy

System.Object
System.Collections.Generic.List
FChoice.Foundation.DataObjects.DataObjectCollection
FChoice.Foundation.Clarify.Schema.SchemaFieldCollectionBase
FChoice.Foundation.Clarify.Schema.SchemaViewFieldCollection

Requirements

Namespace: FChoice.Foundation.Clarify.Schema

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

SchemaViewFieldCollection Members
FChoice.Foundation.Clarify.Schema Namespace


SchemaViewFieldCollection Class Members | fcSDK Documentation

SchemaViewFieldCollection Class Members

The following tables list the members exposed by SchemaViewFieldCollection.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | Item | Overloaded.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex | (Inherited from FChoice.Foundation.DataObjects.DataObjectCollection)
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

SchemaViewFieldCollection Class
FChoice.Foundation.Clarify.Schema Namespace


Item Property (SchemaViewFieldCollection) | fcSDK Documentation

Item Property (SchemaViewFieldCollection)

Overload List

Overload | Description
Item(String) |
Item(Int32) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaViewFieldCollection Class
SchemaViewFieldCollection Members


Item(String) Property | fcSDK Documentation

Item(String) Property

Syntax

'Declaration

Public Overloads Shadows ReadOnly Property Item( _
   ByVal _fieldName_ As String _
) As SchemaViewField

public new SchemaViewField Item(
   string _fieldName_
) {get;}

Parameters

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaViewFieldCollection Class
SchemaViewFieldCollection Members
Overload List


Item(Int32) Property | fcSDK Documentation

Item(Int32) Property

Syntax

'Declaration

Public Overloads Shadows ReadOnly Property Item( _
   ByVal _fieldID_ As Integer _
) As SchemaViewField

public new SchemaViewField Item(
   int _fieldID_
) {get;}

Parameters

fieldID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaViewFieldCollection Class
SchemaViewFieldCollection Members
Overload List


SchemaViewFieldInfo Class | fcSDK Documentation

SchemaViewFieldInfo Class

Syntax

'Declaration

Public Class SchemaViewFieldInfo
   Inherits FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject
   Implements FChoice.Foundation.DataObjects.IDataObject

public class SchemaViewFieldInfo : FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject, FChoice.Foundation.DataObjects.IDataObject

Inheritance Hierarchy

System.Object
FChoice.Foundation.DataObjects.DataObject
FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject
FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo

Requirements

Namespace: FChoice.Foundation.Clarify.Schema

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

SchemaViewFieldInfo Members
FChoice.Foundation.Clarify.Schema Namespace


SchemaViewFieldInfo Class Members | fcSDK Documentation

SchemaViewFieldInfo Class Members

The following tables list the members exposed by SchemaViewFieldInfo.

Public Properties

 | Name | Description
Public Property | Alias |
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Comments |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Flags |
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | TableField |
Public Property | TableFieldID |
Public Property | TableTypeID |
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | ViewField |
Public Property | ViewID |

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

SchemaViewFieldInfo Class
FChoice.Foundation.Clarify.Schema Namespace


Alias Property | fcSDK Documentation

Alias Property

Syntax

'Declaration

Public ReadOnly Property Alias As String

public string Alias {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaViewFieldInfo Class
SchemaViewFieldInfo Members


Comments Property (SchemaViewFieldInfo) | fcSDK Documentation

Comments Property (SchemaViewFieldInfo)

Syntax

'Declaration

Public ReadOnly Property Comments As String

public string Comments {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaViewFieldInfo Class
SchemaViewFieldInfo Members


Flags Property (SchemaViewFieldInfo) | fcSDK Documentation

Flags Property (SchemaViewFieldInfo)

Syntax

'Declaration

Public ReadOnly Property Flags As Integer

public int Flags {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaViewFieldInfo Class
SchemaViewFieldInfo Members


TableField Property | fcSDK Documentation

TableField Property

Syntax

'Declaration

Public ReadOnly Property TableField As SchemaTableField

public SchemaTableField TableField {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaViewFieldInfo Class
SchemaViewFieldInfo Members


TableFieldID Property | fcSDK Documentation

TableFieldID Property

Syntax

'Declaration

Public ReadOnly Property TableFieldID As Integer

public int TableFieldID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaViewFieldInfo Class
SchemaViewFieldInfo Members


TableTypeID Property | fcSDK Documentation

TableTypeID Property

Syntax

'Declaration

Public ReadOnly Property TableTypeID As Integer

public int TableTypeID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaViewFieldInfo Class
SchemaViewFieldInfo Members


ViewField Property | fcSDK Documentation

ViewField Property

Syntax

'Declaration

Public ReadOnly Property ViewField As SchemaViewField

public SchemaViewField ViewField {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaViewFieldInfo Class
SchemaViewFieldInfo Members


ViewID Property | fcSDK Documentation

ViewID Property

Syntax

'Declaration

Public ReadOnly Property ViewID As Integer

public int ViewID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaViewFieldInfo Class
SchemaViewFieldInfo Members


SchemaViewFieldInfoCollection Class | fcSDK Documentation

SchemaViewFieldInfoCollection Class

Syntax

'Declaration

Public Class SchemaViewFieldInfoCollection
   Inherits FChoice.Foundation.DataObjects.DataObjectCollection(Of SchemaViewFieldInfo)

public class SchemaViewFieldInfoCollection : FChoice.Foundation.DataObjects.DataObjectCollection<SchemaViewFieldInfo>

Inheritance Hierarchy

System.Object
System.Collections.Generic.List
FChoice.Foundation.DataObjects.DataObjectCollection
FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfoCollection

Requirements

Namespace: FChoice.Foundation.Clarify.Schema

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

SchemaViewFieldInfoCollection Members
FChoice.Foundation.Clarify.Schema Namespace


SchemaViewFieldInfoCollection Class Members | fcSDK Documentation

SchemaViewFieldInfoCollection Class Members

The following tables list the members exposed by SchemaViewFieldInfoCollection.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | Item | (Inherited from System.Collections.Generic.List)

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
static (Shared in Visual Basic) | CreateViewFieldInfoKey |
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex | (Inherited from FChoice.Foundation.DataObjects.DataObjectCollection)
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | GetViewFieldInfoByID |
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

SchemaViewFieldInfoCollection Class
FChoice.Foundation.Clarify.Schema Namespace


CreateViewFieldInfoKey Method | fcSDK Documentation

CreateViewFieldInfoKey Method

Syntax

'Declaration

Public Shared Function CreateViewFieldInfoKey( _
   ByVal _viewID_ As Integer, _
   ByVal _fieldID_ As Integer _
) As String

public static string CreateViewFieldInfoKey(
   int _viewID_,
   int _fieldID_
)

Parameters

viewID

fieldID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaViewFieldInfoCollection Class
SchemaViewFieldInfoCollection Members


GetViewFieldInfoByID Method | fcSDK Documentation

GetViewFieldInfoByID Method

Syntax

'Declaration

Public Function GetViewFieldInfoByID( _
   ByVal _viewID_ As Integer, _
   ByVal _fieldID_ As Integer _
) As SchemaViewFieldInfo

public SchemaViewFieldInfo GetViewFieldInfoByID(
   int _viewID_,
   int _fieldID_
)

Parameters

viewID

fieldID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaViewFieldInfoCollection Class
SchemaViewFieldInfoCollection Members


SchemaViewJoin Class | fcSDK Documentation

SchemaViewJoin Class

Syntax

'Declaration

Public Class SchemaViewJoin
   Inherits FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject
   Implements FChoice.Foundation.DataObjects.IDataObject, FChoice.Foundation.Schema.ISchemaViewJoin

public class SchemaViewJoin : FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject, FChoice.Foundation.DataObjects.IDataObject, FChoice.Foundation.Schema.ISchemaViewJoin

Inheritance Hierarchy

System.Object
FChoice.Foundation.DataObjects.DataObject
FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject
FChoice.Foundation.Clarify.Schema.SchemaViewJoin

Requirements

Namespace: FChoice.Foundation.Clarify.Schema

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

SchemaViewJoin Members
FChoice.Foundation.Clarify.Schema Namespace


SchemaViewJoin Class Members | fcSDK Documentation

SchemaViewJoin Class Members

The following tables list the members exposed by SchemaViewJoin.

Public Properties

 | Name | Description
Public Property | BaseRelation |
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Comments |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Flags |
Public Property | JoinFlag |
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | PrimaryAlias |
Public Property | SecondaryAlias |
Public Property | SpecificRelationID |
Public Property | TableID |
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

SchemaViewJoin Class
FChoice.Foundation.Clarify.Schema Namespace


BaseRelation Property | fcSDK Documentation

BaseRelation Property

Syntax

'Declaration

Public ReadOnly Property BaseRelation As SchemaRelation

public SchemaRelation BaseRelation {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaViewJoin Class
SchemaViewJoin Members


Comments Property (SchemaViewJoin) | fcSDK Documentation

Comments Property (SchemaViewJoin)

Syntax

'Declaration

Public ReadOnly Property Comments As String

public string Comments {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaViewJoin Class
SchemaViewJoin Members


Flags Property (SchemaViewJoin) | fcSDK Documentation

Flags Property (SchemaViewJoin)

Syntax

'Declaration

Public ReadOnly Property Flags As Integer

public int Flags {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaViewJoin Class
SchemaViewJoin Members


JoinFlag Property | fcSDK Documentation

JoinFlag Property

Syntax

'Declaration

Public ReadOnly Property JoinFlag As Integer

public int JoinFlag {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaViewJoin Class
SchemaViewJoin Members


PrimaryAlias Property (SchemaViewJoin) | fcSDK Documentation

PrimaryAlias Property (SchemaViewJoin)

Syntax

'Declaration

Public ReadOnly Property PrimaryAlias As String

public string PrimaryAlias {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaViewJoin Class
SchemaViewJoin Members


SecondaryAlias Property (SchemaViewJoin) | fcSDK Documentation

SecondaryAlias Property (SchemaViewJoin)

Syntax

'Declaration

Public ReadOnly Property SecondaryAlias As String

public string SecondaryAlias {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaViewJoin Class
SchemaViewJoin Members


SpecificRelationID Property (SchemaViewJoin) | fcSDK Documentation

SpecificRelationID Property (SchemaViewJoin)

Syntax

'Declaration

Public ReadOnly Property SpecificRelationID As Integer

public int SpecificRelationID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaViewJoin Class
SchemaViewJoin Members


TableID Property | fcSDK Documentation

TableID Property

Syntax

'Declaration

Public ReadOnly Property TableID As Integer

public int TableID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SchemaViewJoin Class
SchemaViewJoin Members


SchemaViewJoinCollection Class | fcSDK Documentation

SchemaViewJoinCollection Class

Syntax

'Declaration

Public Class SchemaViewJoinCollection
   Inherits FChoice.Foundation.DataObjects.DataObjectCollection(Of SchemaViewJoin)
   Implements FChoice.Foundation.Schema.ISchemaViewJoinCollection

public class SchemaViewJoinCollection : FChoice.Foundation.DataObjects.DataObjectCollection<SchemaViewJoin>, FChoice.Foundation.Schema.ISchemaViewJoinCollection

Inheritance Hierarchy

System.Object
System.Collections.Generic.List
FChoice.Foundation.DataObjects.DataObjectCollection
FChoice.Foundation.Clarify.Schema.SchemaViewJoinCollection

Requirements

Namespace: FChoice.Foundation.Clarify.Schema

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

SchemaViewJoinCollection Members
FChoice.Foundation.Clarify.Schema Namespace


SchemaViewJoinCollection Class Members | fcSDK Documentation

SchemaViewJoinCollection Class Members

The following tables list the members exposed by SchemaViewJoinCollection.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | Item | (Inherited from System.Collections.Generic.List)

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex | (Inherited from FChoice.Foundation.DataObjects.DataObjectCollection)
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

SchemaViewJoinCollection Class
FChoice.Foundation.Clarify.Schema Namespace


SchemaCommonType Enumeration | fcSDK Documentation

SchemaCommonType Enumeration

Syntax

'Declaration

Public Enum SchemaCommonType
   Inherits System.Enum

public enum SchemaCommonType : System.Enum

Members

Member | Description
Date |
Decimal |
Double |
Float |
Integer |
String |

Inheritance Hierarchy

System.Object System.ValueType System.Enum FChoice.Foundation.Clarify.Schema.SchemaCommonType

Requirements

Namespace: FChoice.Foundation.Clarify.Schema

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FChoice.Foundation.Clarify.Schema Namespace FChoice.Foundation.Clarify.Schema.SchemaCommonType

Requirements

Namespace: FChoice.Foundation.Clarify.Schema

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FChoice.Foundation.Clarify.Schema Namespace


SchemaDataType Enumeration | fcSDK Documentation

SchemaDataType Enumeration

Syntax

'Declaration

Public Enum SchemaDataType
   Inherits System.Enum

public enum SchemaDataType : System.Enum

Members

Member | Description
CharArray |
ClobOrText |
DateTime |
Decimal |
Double |
Integer |
Real |
SmallInt |
TinyInt |
VarChar |

Inheritance Hierarchy

System.Object System.ValueType System.Enum FChoice.Foundation.Clarify.Schema.SchemaDataType

Requirements

Namespace: FChoice.Foundation.Clarify.Schema

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FChoice.Foundation.Clarify.Schema Namespace FChoice.Foundation.Clarify.Schema.SchemaDataType

Requirements

Namespace: FChoice.Foundation.Clarify.Schema

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FChoice.Foundation.Clarify.Schema Namespace


FChoice.Foundation.Clarify.Workflow Namespace | fcSDK Documentation

FChoice.Foundation.Clarify.Workflow Namespace

Classes

 | Class | Description
Class | WorkflowException |
Class | WorkFlowInfo |
Class | WorkflowManager |

Enumerations

 | Enumeration | Description
Enumeration | AttachmentFolderMode |

Reference

fcSDK Assembly


WorkflowException Class | fcSDK Documentation

WorkflowException Class

Syntax

'Declaration

<SerializableAttribute()>
Public Class WorkflowException
   Inherits FChoice.Common.FCExceptionBase

[SerializableAttribute()]
public class WorkflowException : FChoice.Common.FCExceptionBase

Inheritance Hierarchy

System.Object
System.Exception
System.ApplicationException
FChoice.Common.FCExceptionBase
FChoice.Foundation.Clarify.Workflow.WorkflowException

Requirements

Namespace: FChoice.Foundation.Clarify.Workflow

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

WorkflowException Members
FChoice.Foundation.Clarify.Workflow Namespace


WorkflowException Class Members | fcSDK Documentation

WorkflowException Class Members

The following tables list the members exposed by WorkflowException.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorCode | Gets the unique error code for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | ErrorMessageID | Gets the message identifier for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | Sets the SerializationInfo object with the parameter name and additional exception information. (Inherited from FChoice.Common.FCExceptionBase)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)

Reference

WorkflowException Class
FChoice.Foundation.Clarify.Workflow Namespace


WorkFlowInfo Class | fcSDK Documentation

WorkFlowInfo Class

Syntax

'Declaration

Public Class WorkFlowInfo

public class WorkFlowInfo

Inheritance Hierarchy

System.Object
FChoice.Foundation.Clarify.Workflow.WorkFlowInfo

Requirements

Namespace: FChoice.Foundation.Clarify.Workflow

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

WorkFlowInfo Members
FChoice.Foundation.Clarify.Workflow Namespace


WorkFlowInfo Class Members | fcSDK Documentation

WorkFlowInfo Class Members

The following tables list the members exposed by WorkFlowInfo.

Public Constructors

 | Name | Description
Public Constructor | WorkFlowInfo Constructor |

Public Properties

 | Name | Description
Public Property | ActivityDate |
Public Property | ActivityRelation |
Public Property | ConditionRelation |
Public Property | DatabaseTable |
Public Property | EmployeeID |
Public Property | GenerateTimeBomb |
Public Property | HistoryFieldName |
Public Property | IDFieldName |
Public Property | IDNum |
Public Property | IsAllowedCheckFieldName |
Public Property | IsApplicationUser |
Public Property | IsSessionUser |
Public Property | IsWipBinDefault |
Public Property | NewStatus |
Public Property | NewUserID |
Public Property | NewUserName |
Public Property | ObjectName |
Public Property | OldRejectRelation |
Public Property | OldStatusRelation |
Public Property | OwnerRelation |
Public Property | PreviousQueueRelation |
Public Property | QueueId |
Public Property | QueueName |
Public Property | QueueRelation |
Public Property | RejectRelation |
Public Property | StatusCode |
Public Property | StatusRelation |
Public Property | UseParticipantActEntryModel |
Public Property | UserID |
Public Property | UserName |
Public Property | WipBin |
Public Property | WipBinID |
Public Property | WipBinRelation |

Reference

WorkFlowInfo Class
FChoice.Foundation.Clarify.Workflow Namespace


WorkFlowInfo Constructor | fcSDK Documentation

WorkFlowInfo Constructor

Syntax

'Declaration

Public Function New( _
   ByVal _objectName_ As String _
)

public WorkFlowInfo(
   string _objectName_
)

Parameters

objectName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkFlowInfo Class
WorkFlowInfo Members


ActivityDate Property | fcSDK Documentation

ActivityDate Property

Syntax

'Declaration

Public ReadOnly Property ActivityDate As Date

public DateTime ActivityDate {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkFlowInfo Class
WorkFlowInfo Members


ActivityRelation Property (WorkFlowInfo) | fcSDK Documentation

ActivityRelation Property (WorkFlowInfo)

Syntax

'Declaration

Public ReadOnly Property ActivityRelation As String

public string ActivityRelation {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkFlowInfo Class
WorkFlowInfo Members


ConditionRelation Property (WorkFlowInfo) | fcSDK Documentation

ConditionRelation Property (WorkFlowInfo)

Syntax

'Declaration

Public ReadOnly Property ConditionRelation As String

public string ConditionRelation {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkFlowInfo Class
WorkFlowInfo Members


DatabaseTable Property (WorkFlowInfo) | fcSDK Documentation

DatabaseTable Property (WorkFlowInfo)

Syntax

'Declaration

Public ReadOnly Property DatabaseTable As String

public string DatabaseTable {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkFlowInfo Class
WorkFlowInfo Members


EmployeeID Property | fcSDK Documentation

EmployeeID Property

Syntax

'Declaration

Public ReadOnly Property EmployeeID As Integer

public int EmployeeID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkFlowInfo Class
WorkFlowInfo Members


GenerateTimeBomb Property | fcSDK Documentation

GenerateTimeBomb Property

Syntax

'Declaration

Public ReadOnly Property GenerateTimeBomb As Boolean

public bool GenerateTimeBomb {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkFlowInfo Class
WorkFlowInfo Members


HistoryFieldName Property (WorkFlowInfo) | fcSDK Documentation

HistoryFieldName Property (WorkFlowInfo)

Syntax

'Declaration

Public ReadOnly Property HistoryFieldName As String

public string HistoryFieldName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkFlowInfo Class
WorkFlowInfo Members


IDFieldName Property (WorkFlowInfo) | fcSDK Documentation

IDFieldName Property (WorkFlowInfo)

Syntax

'Declaration

Public ReadOnly Property IDFieldName As String

public string IDFieldName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkFlowInfo Class
WorkFlowInfo Members


IDNum Property (WorkFlowInfo) | fcSDK Documentation

IDNum Property (WorkFlowInfo)

Syntax

'Declaration

Public ReadOnly Property IDNum As String

public string IDNum {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkFlowInfo Class
WorkFlowInfo Members


IsAllowedCheckFieldName Property (WorkFlowInfo) | fcSDK Documentation

IsAllowedCheckFieldName Property (WorkFlowInfo)

Syntax

'Declaration

Public ReadOnly Property IsAllowedCheckFieldName As String

public string IsAllowedCheckFieldName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkFlowInfo Class
WorkFlowInfo Members


IsApplicationUser Property | fcSDK Documentation

IsApplicationUser Property

Syntax

'Declaration

Public ReadOnly Property IsApplicationUser As Boolean

public bool IsApplicationUser {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkFlowInfo Class
WorkFlowInfo Members


IsSessionUser Property | fcSDK Documentation

IsSessionUser Property

Syntax

'Declaration

Public ReadOnly Property IsSessionUser As Boolean

public bool IsSessionUser {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkFlowInfo Class
WorkFlowInfo Members


IsWipBinDefault Property | fcSDK Documentation

IsWipBinDefault Property

Syntax

'Declaration

Public ReadOnly Property IsWipBinDefault As Boolean

public bool IsWipBinDefault {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkFlowInfo Class
WorkFlowInfo Members


NewStatus Property (WorkFlowInfo) | fcSDK Documentation

NewStatus Property (WorkFlowInfo)

Syntax

'Declaration

Public ReadOnly Property NewStatus As String

public string NewStatus {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkFlowInfo Class
WorkFlowInfo Members


NewUserID Property | fcSDK Documentation

NewUserID Property

Syntax

'Declaration

Public ReadOnly Property NewUserID As Integer

public int NewUserID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkFlowInfo Class
WorkFlowInfo Members


NewUserName Property | fcSDK Documentation

NewUserName Property

Syntax

'Declaration

Public ReadOnly Property NewUserName As String

public string NewUserName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkFlowInfo Class
WorkFlowInfo Members


ObjectName Property (WorkFlowInfo) | fcSDK Documentation

ObjectName Property (WorkFlowInfo)

Syntax

'Declaration

Public ReadOnly Property ObjectName As String

public string ObjectName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkFlowInfo Class
WorkFlowInfo Members


OldRejectRelation Property (WorkFlowInfo) | fcSDK Documentation

OldRejectRelation Property (WorkFlowInfo)

Syntax

'Declaration

Public ReadOnly Property OldRejectRelation As String

public string OldRejectRelation {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkFlowInfo Class
WorkFlowInfo Members


OldStatusRelation Property (WorkFlowInfo) | fcSDK Documentation

OldStatusRelation Property (WorkFlowInfo)

Syntax

'Declaration

Public ReadOnly Property OldStatusRelation As String

public string OldStatusRelation {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkFlowInfo Class
WorkFlowInfo Members


OwnerRelation Property (WorkFlowInfo) | fcSDK Documentation

OwnerRelation Property (WorkFlowInfo)

Syntax

'Declaration

Public ReadOnly Property OwnerRelation As String

public string OwnerRelation {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkFlowInfo Class
WorkFlowInfo Members


PreviousQueueRelation Property (WorkFlowInfo) | fcSDK Documentation

PreviousQueueRelation Property (WorkFlowInfo)

Syntax

'Declaration

Public ReadOnly Property PreviousQueueRelation As String

public string PreviousQueueRelation {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkFlowInfo Class
WorkFlowInfo Members


QueueId Property | fcSDK Documentation

QueueId Property

Syntax

'Declaration

Public ReadOnly Property QueueId As Integer

public int QueueId {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkFlowInfo Class
WorkFlowInfo Members


QueueName Property | fcSDK Documentation

QueueName Property

Syntax

'Declaration

Public ReadOnly Property QueueName As String

public string QueueName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkFlowInfo Class
WorkFlowInfo Members


QueueRelation Property (WorkFlowInfo) | fcSDK Documentation

QueueRelation Property (WorkFlowInfo)

Syntax

'Declaration

Public ReadOnly Property QueueRelation As String

public string QueueRelation {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkFlowInfo Class
WorkFlowInfo Members


RejectRelation Property (WorkFlowInfo) | fcSDK Documentation

RejectRelation Property (WorkFlowInfo)

Syntax

'Declaration

Public ReadOnly Property RejectRelation As String

public string RejectRelation {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkFlowInfo Class
WorkFlowInfo Members


StatusCode Property (WorkFlowInfo) | fcSDK Documentation

StatusCode Property (WorkFlowInfo)

Syntax

'Declaration

Public ReadOnly Property StatusCode As Integer

public int StatusCode {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkFlowInfo Class
WorkFlowInfo Members


StatusRelation Property (WorkFlowInfo) | fcSDK Documentation

StatusRelation Property (WorkFlowInfo)

Syntax

'Declaration

Public ReadOnly Property StatusRelation As String

public string StatusRelation {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkFlowInfo Class
WorkFlowInfo Members


UseParticipantActEntryModel Property (WorkFlowInfo) | fcSDK Documentation

UseParticipantActEntryModel Property (WorkFlowInfo)

Syntax

'Declaration

Public ReadOnly Property UseParticipantActEntryModel As Boolean

public bool UseParticipantActEntryModel {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkFlowInfo Class
WorkFlowInfo Members


UserID Property (WorkFlowInfo) | fcSDK Documentation

UserID Property (WorkFlowInfo)

Syntax

'Declaration

Public ReadOnly Property UserID As Integer

public int UserID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkFlowInfo Class
WorkFlowInfo Members


UserName Property (WorkFlowInfo) | fcSDK Documentation

UserName Property (WorkFlowInfo)

Syntax

'Declaration

Public ReadOnly Property UserName As String

public string UserName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkFlowInfo Class
WorkFlowInfo Members


WipBin Property (WorkFlowInfo) | fcSDK Documentation

WipBin Property (WorkFlowInfo)

Syntax

'Declaration

Public ReadOnly Property WipBin As String

public string WipBin {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkFlowInfo Class
WorkFlowInfo Members


WipBinID Property | fcSDK Documentation

WipBinID Property

Syntax

'Declaration

Public ReadOnly Property WipBinID As Integer

public int WipBinID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkFlowInfo Class
WorkFlowInfo Members


WipBinRelation Property (WorkFlowInfo) | fcSDK Documentation

WipBinRelation Property (WorkFlowInfo)

Syntax

'Declaration

Public ReadOnly Property WipBinRelation As String

public string WipBinRelation {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkFlowInfo Class
WorkFlowInfo Members


WorkflowManager Class | fcSDK Documentation

WorkflowManager Class

Syntax

'Declaration

Public Class WorkflowManager

public class WorkflowManager

Inheritance Hierarchy

System.Object
FChoice.Foundation.Clarify.Workflow.WorkflowManager

Requirements

Namespace: FChoice.Foundation.Clarify.Workflow

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

WorkflowManager Members
FChoice.Foundation.Clarify.Workflow Namespace


WorkflowManager Class Members | fcSDK Documentation

WorkflowManager Class Members

The following tables list the members exposed by WorkflowManager.

Public Constructors

 | Name | Description
Public Constructor | WorkflowManager Constructor | Overloaded.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | EndOfHistoryMagicText |
Public Field | ImpersonatorUserName |

Public Methods

 | Name | Description
Public Method | Accept |
Public Method | Assign |
static (Shared in Visual Basic) | BuildClarifyHistory |
Public Method | ChangeStatus |
Public Method | CreateActivityEntryRow |
Public Method | CreateActivityLogEntry |
Public Method | CreateAttachmentRecord | Overloaded.
Public Method | CreateCasePhoneLogActivityEntry |
Public Method | CreateParticipantActivityEntry |
Public Method | CreateTimeBomb | Overloaded.
Public Method | Dispatch |
Public Method | Forward |
Public Method | GetAttachmentFilePath |
Public Method | GetNextFileName |
Public Method | GetNextFileNameIgnoringExistence |
Public Method | GetWipDetails |
Public Method | IsFilenameAlreadyInUseOnTheWorkflowObject |
static (Shared in Visual Basic) | MakeFullHistoryDirty |
static (Shared in Visual Basic) | MapObjectNameToTableID |
static (Shared in Visual Basic) | MapTimeBombActionToFlag |
Public Method | Move |
Public Method | Reject |
Public Method | Yank |

Reference

WorkflowManager Class
FChoice.Foundation.Clarify.Workflow Namespace


WorkflowManager Constructor | fcSDK Documentation

WorkflowManager Constructor

Overload List

Overload | Description
WorkflowManager Constructor(ClarifyDataSet) |
WorkflowManager Constructor(IDbTransaction,ClarifyDataSet) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowManager Class
WorkflowManager Members


WorkflowManager Constructor(ClarifyDataSet) | fcSDK Documentation

WorkflowManager Constructor(ClarifyDataSet)

Syntax

'Declaration

Public Function New( _
   ByVal _ds_ As ClarifyDataSet _
)```

```csharp
public WorkflowManager(
   ClarifyDataSet _ds_
)

Parameters

ds

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowManager Class
WorkflowManager Members
Overload List


WorkflowManager Constructor(IDbTransaction,ClarifyDataSet) | fcSDK Documentation

WorkflowManager Constructor(IDbTransaction,ClarifyDataSet)

Syntax

'Declaration

Public Function New( _
   ByVal _transaction_ As IDbTransaction, _
   ByVal _ds_ As ClarifyDataSet _
)```

```csharp
public WorkflowManager(
   IDbTransaction _transaction_,
   ClarifyDataSet _ds_
)

Parameters

transaction

ds

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowManager Class
WorkflowManager Members
Overload List


Accept Method | fcSDK Documentation

Accept Method

Syntax

'Declaration

Public Function Accept( _
   ByVal _idNum_ As String, _
   ByVal _objectName_ As String, _
   ByVal _wipBin_ As String, _
   ByVal _acceptDate_ As Date, _
   ByVal _userName_ As String, _
   ByVal _generateTimeBomb_ As Boolean _
) As WorkFlowInfo

public WorkFlowInfo Accept(
   string _idNum_,
   string _objectName_,
   string _wipBin_,
   DateTime _acceptDate_,
   string _userName_,
   bool _generateTimeBomb_
)

Parameters

idNum

objectName

wipBin

acceptDate

userName

generateTimeBomb

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowManager Class
WorkflowManager Members


Assign Method | fcSDK Documentation

Assign Method

Syntax

'Declaration

Public Function Assign( _
   ByVal _idNum_ As String, _
   ByVal _objectName_ As String, _
   ByVal _newUserName_ As String, _
   ByVal _wipBin_ As String, _
   ByVal _assignDate_ As Date, _
   ByVal _currentUserName_ As String, _
   ByVal _generateTimeBomb_ As Boolean _
) As WorkFlowInfo

public WorkFlowInfo Assign(
   string _idNum_,
   string _objectName_,
   string _newUserName_,
   string _wipBin_,
   DateTime _assignDate_,
   string _currentUserName_,
   bool _generateTimeBomb_
)

Parameters

idNum

objectName

newUserName

wipBin

assignDate

currentUserName

generateTimeBomb

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowManager Class
WorkflowManager Members


BuildClarifyHistory Method | fcSDK Documentation

BuildClarifyHistory Method

Syntax

'Declaration

Public Shared Function BuildClarifyHistory( _
   ByVal _currentHistory_ As String, _
   ByVal _appendHistory_ As String _
) As String

public static string BuildClarifyHistory(
   string _currentHistory_,
   string _appendHistory_
)

Parameters

currentHistory

appendHistory

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowManager Class
WorkflowManager Members


ChangeStatus Method | fcSDK Documentation

ChangeStatus Method

Syntax

'Declaration

Public Function ChangeStatus( _
   ByVal _idNum_ As String, _
   ByVal _objectName_ As String, _
   ByVal _newStatus_ As String, _
   ByVal _changeDate_ As Date, _
   ByVal _userName_ As String, _
   ByVal _generateTimeBomb_ As Boolean, _
   ByVal _notes_ As String _
) As WorkFlowInfo

public WorkFlowInfo ChangeStatus(
   string _idNum_,
   string _objectName_,
   string _newStatus_,
   DateTime _changeDate_,
   string _userName_,
   bool _generateTimeBomb_,
   string _notes_
)

Parameters

idNum

objectName

newStatus

changeDate

userName

generateTimeBomb

notes

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowManager Class
WorkflowManager Members


CreateActivityEntryRow Method | fcSDK Documentation

CreateActivityEntryRow Method

Syntax

'Declaration

Public Function CreateActivityEntryRow( _
   ByVal _activityCode_ As Integer, _
   ByVal _activityName_ As String, _
   ByVal _userObjid_ As Integer, _
   ByVal _activityDate_ As Date, _
   ByVal _addnl_info_ As String, _
   ByVal _objectRow_ As ClarifyDataRow, _
   ByVal _clarifyGenericsToUpdate_ As IList(Of ClarifyGeneric) _
) As ClarifyDataRow

public ClarifyDataRow CreateActivityEntryRow(
   int _activityCode_,
   string _activityName_,
   int _userObjid_,
   DateTime _activityDate_,
   string _addnl_info_,
   ClarifyDataRow _objectRow_,
   IList<ClarifyGeneric> _clarifyGenericsToUpdate_
)

Parameters

activityCode

activityName

userObjid

activityDate

addnl_info

objectRow

clarifyGenericsToUpdate

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowManager Class
WorkflowManager Members


CreateActivityLogEntry(Int32,Int32,DateTime,String,ClarifyDataRow,ClarifyDataRow,WorkflowObjectInfo) Method | fcSDK Documentation

CreateActivityLogEntry(Int32,Int32,DateTime,String,ClarifyDataRow,ClarifyDataRow,WorkflowObjectInfo) Method

Syntax

'Declaration

Public Sub CreateActivityLogEntry( _
   ByVal _activityCode_ As Integer, _
   ByVal _userObjid_ As Integer, _
   ByVal _activityDate_ As Date, _
   ByVal _addlInfo_ As String, _
   ByVal _objectRow_ As ClarifyDataRow, _
   ByVal _actEntryRow_ As ClarifyDataRow, _
   Optional ByVal _objInfo_ As WorkflowObjectInfo _
)

public void CreateActivityLogEntry(
   int _activityCode_,
   int _userObjid_,
   DateTime _activityDate_,
   string _addlInfo_,
   ClarifyDataRow _objectRow_,
   ClarifyDataRow _actEntryRow_,
   WorkflowObjectInfo _objInfo_
)

Parameters

activityCode

userObjid

activityDate

addlInfo

objectRow

actEntryRow

objInfo

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowManager Class
WorkflowManager Members


CreateAttachmentRecord Method | fcSDK Documentation

CreateAttachmentRecord Method

Overload List

Overload | Description
CreateAttachmentRecord(String,String,String,String,Boolean,Boolean) |
CreateAttachmentRecord(String,String,String,String,Boolean,Boolean,IDictionary<String,Object>) |
CreateAttachmentRecord(Int32,String,String,String,Boolean,Boolean) |
CreateAttachmentRecord(Int32,String,String,String,Boolean,Boolean,IDictionary<String,Object>) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowManager Class
WorkflowManager Members


CreateAttachmentRecord(String,String,String,String,Boolean,Boolean) Method | fcSDK Documentation

CreateAttachmentRecord(String,String,String,String,Boolean,Boolean) Method

Syntax

'Declaration

Public Overloads Function CreateAttachmentRecord( _
   ByVal _idNumber_ As String, _
   ByVal _attachmentName_ As String, _
   ByVal _filePath_ As String, _
   ByVal _objectType_ As String, _
   ByVal _attachmentsAnywhere_ As Boolean, _
   ByVal _createActEntry_ As Boolean _
) As Integer

public int CreateAttachmentRecord(
   string _idNumber_,
   string _attachmentName_,
   string _filePath_,
   string _objectType_,
   bool _attachmentsAnywhere_,
   bool _createActEntry_
)

Parameters

idNumber

attachmentName

filePath

objectType

attachmentsAnywhere

createActEntry

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowManager Class
WorkflowManager Members
Overload List


CreateAttachmentRecord(String,String,String,String,Boolean,Boolean,IDictionary<String,Object>) Method | fcSDK Documentation

CreateAttachmentRecord(String,String,String,String,Boolean,Boolean,IDictionary<String,Object>) Method

Syntax

'Declaration

Public Overloads Function CreateAttachmentRecord( _
   ByVal _idNumber_ As String, _
   ByVal _attachmentName_ As String, _
   ByVal _filePath_ As String, _
   ByVal _objectType_ As String, _
   ByVal _attachmentsAnywhere_ As Boolean, _
   ByVal _createActEntry_ As Boolean, _
   ByVal _docPathFields_ As IDictionary(Of String,Object) _
) As Integer

public int CreateAttachmentRecord(
   string _idNumber_,
   string _attachmentName_,
   string _filePath_,
   string _objectType_,
   bool _attachmentsAnywhere_,
   bool _createActEntry_,
   IDictionary<string,object> _docPathFields_
)

Parameters

idNumber

attachmentName

filePath

objectType

attachmentsAnywhere

createActEntry

docPathFields

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowManager Class
WorkflowManager Members
Overload List


CreateAttachmentRecord(Int32,String,String,String,Boolean,Boolean) Method | fcSDK Documentation

CreateAttachmentRecord(Int32,String,String,String,Boolean,Boolean) Method

Syntax

'Declaration

Public Overloads Function CreateAttachmentRecord( _
   ByVal _objectObjId_ As Integer, _
   ByVal _attachmentName_ As String, _
   ByVal _filePath_ As String, _
   ByVal _objectType_ As String, _
   ByVal _attachmentsAnywhere_ As Boolean, _
   ByVal _createActEntry_ As Boolean _
) As Integer

public int CreateAttachmentRecord(
   int _objectObjId_,
   string _attachmentName_,
   string _filePath_,
   string _objectType_,
   bool _attachmentsAnywhere_,
   bool _createActEntry_
)

Parameters

objectObjId

attachmentName

filePath

objectType

attachmentsAnywhere

createActEntry

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowManager Class
WorkflowManager Members
Overload List


CreateAttachmentRecord(Int32,String,String,String,Boolean,Boolean,IDictionary<String,Object>) Method | fcSDK Documentation

CreateAttachmentRecord(Int32,String,String,String,Boolean,Boolean,IDictionary<String,Object>) Method

Syntax

'Declaration

Public Overloads Function CreateAttachmentRecord( _
   ByVal _objectObjId_ As Integer, _
   ByVal _attachmentName_ As String, _
   ByVal _filePath_ As String, _
   ByVal _objectType_ As String, _
   ByVal _attachmentsAnywhere_ As Boolean, _
   ByVal _createActEntry_ As Boolean, _
   ByVal _docPathFields_ As IDictionary(Of String,Object) _
) As Integer

public int CreateAttachmentRecord(
   int _objectObjId_,
   string _attachmentName_,
   string _filePath_,
   string _objectType_,
   bool _attachmentsAnywhere_,
   bool _createActEntry_,
   IDictionary<string,object> _docPathFields_
)

Parameters

objectObjId

attachmentName

filePath

objectType

attachmentsAnywhere

createActEntry

docPathFields

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowManager Class
WorkflowManager Members
Overload List


CreateCasePhoneLogActivityEntry Method | fcSDK Documentation

CreateCasePhoneLogActivityEntry Method

Syntax

'Declaration

Public Sub CreateCasePhoneLogActivityEntry( _
   ByVal _userObjid_ As Integer, _
   ByVal _activityDate_ As Date, _
   ByVal _addlInfo_ As String, _
   ByVal _objectRow_ As ClarifyDataRow, _
   ByVal _actEntryRow_ As ClarifyDataRow, _
   ByVal _phoneLogRow_ As ClarifyDataRow _
)

public void CreateCasePhoneLogActivityEntry(
   int _userObjid_,
   DateTime _activityDate_,
   string _addlInfo_,
   ClarifyDataRow _objectRow_,
   ClarifyDataRow _actEntryRow_,
   ClarifyDataRow _phoneLogRow_
)

Parameters

userObjid

activityDate

addlInfo

objectRow

actEntryRow

phoneLogRow

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowManager Class
WorkflowManager Members


CreateParticipantActivityEntry Method | fcSDK Documentation

CreateParticipantActivityEntry Method

Syntax

'Declaration

Public Sub CreateParticipantActivityEntry( _
   ByVal _activityCode_ As Integer, _
   ByVal _userObjid_ As Integer, _
   ByVal _activityDate_ As Date, _
   ByVal _additionalInfo_ As String, _
   ByVal _objectRow_ As ClarifyDataRow, _
   ByVal _actEntryRow_ As ClarifyDataRow, _
   ByVal _clarifyGenericsToUpdate_ As IList(Of ClarifyGeneric), _
   ByVal _parentRelation_ As String _
)

public void CreateParticipantActivityEntry(
   int _activityCode_,
   int _userObjid_,
   DateTime _activityDate_,
   string _additionalInfo_,
   ClarifyDataRow _objectRow_,
   ClarifyDataRow _actEntryRow_,
   IList<ClarifyGeneric> _clarifyGenericsToUpdate_,
   string _parentRelation_
)

Parameters

activityCode

userObjid

activityDate

additionalInfo

objectRow

actEntryRow

clarifyGenericsToUpdate

parentRelation

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowManager Class
WorkflowManager Members


CreateTimeBomb Method | fcSDK Documentation

CreateTimeBomb Method

Overload List

Overload | Description
CreateTimeBomb(ClarifyDataRow,ClarifyDataRow,String,Int32,DateTime,String) |
CreateTimeBomb(ClarifyDataRow,ClarifyDataRow,Int32,Int32,DateTime,String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowManager Class
WorkflowManager Members


CreateTimeBomb(ClarifyDataRow,ClarifyDataRow,String,Int32,DateTime,String) Method | fcSDK Documentation

CreateTimeBomb(ClarifyDataRow,ClarifyDataRow,String,Int32,DateTime,String) Method

Syntax

'Declaration

Public Overloads Function CreateTimeBomb( _
   ByVal _mainRecord_ As ClarifyDataRow, _
   ByVal _activityRecord_ As ClarifyDataRow, _
   ByVal _action_ As String, _
   ByVal _employeeId_ As Integer, _
   ByVal _timebombDate_ As Date, _
   ByVal _focusObjectName_ As String _
) As ClarifyGeneric```

```csharp
public ClarifyGeneric CreateTimeBomb(
   ClarifyDataRow _mainRecord_,
   ClarifyDataRow _activityRecord_,
   string _action_,
   int _employeeId_,
   DateTime _timebombDate_,
   string _focusObjectName_
)

Parameters

mainRecord

activityRecord

action

employeeId

timebombDate

focusObjectName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowManager Class
WorkflowManager Members
Overload List


CreateTimeBomb(ClarifyDataRow,ClarifyDataRow,Int32,Int32,DateTime,String) Method | fcSDK Documentation

CreateTimeBomb(ClarifyDataRow,ClarifyDataRow,Int32,Int32,DateTime,String) Method

Syntax

'Declaration

Public Overloads Function CreateTimeBomb( _
   ByVal _mainRecord_ As ClarifyDataRow, _
   ByVal _activityRecord_ As ClarifyDataRow, _
   ByVal _timeBombFlag_ As Integer, _
   ByVal _employeeId_ As Integer, _
   ByVal _timebombDate_ As Date, _
   ByVal _focusObjectName_ As String _
) As ClarifyGeneric```

```csharp
public ClarifyGeneric CreateTimeBomb(
   ClarifyDataRow _mainRecord_,
   ClarifyDataRow _activityRecord_,
   int _timeBombFlag_,
   int _employeeId_,
   DateTime _timebombDate_,
   string _focusObjectName_
)

Parameters

mainRecord

activityRecord

timeBombFlag

employeeId

timebombDate

focusObjectName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowManager Class
WorkflowManager Members
Overload List


Dispatch Method | fcSDK Documentation

Dispatch Method

Syntax

'Declaration

Public Function Dispatch( _
   ByVal _idNum_ As String, _
   ByVal _objectName_ As String, _
   ByVal _queueName_ As String, _
   ByVal _dispatchDate_ As Date, _
   ByVal _userName_ As String, _
   ByVal _generateTimeBomb_ As Boolean _
) As WorkFlowInfo

public WorkFlowInfo Dispatch(
   string _idNum_,
   string _objectName_,
   string _queueName_,
   DateTime _dispatchDate_,
   string _userName_,
   bool _generateTimeBomb_
)

Parameters

idNum

objectName

queueName

dispatchDate

userName

generateTimeBomb

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowManager Class
WorkflowManager Members


Forward Method | fcSDK Documentation

Forward Method

Syntax

'Declaration

Public Function Forward( _
   ByVal _idNum_ As String, _
   ByVal _objectName_ As String, _
   ByVal _newQueueName_ As String, _
   ByVal _forwardDate_ As Date, _
   ByVal _userName_ As String, _
   ByVal _generateTimeBomb_ As Boolean, _
   ByVal _notes_ As String _
) As WorkFlowInfo

public WorkFlowInfo Forward(
   string _idNum_,
   string _objectName_,
   string _newQueueName_,
   DateTime _forwardDate_,
   string _userName_,
   bool _generateTimeBomb_,
   string _notes_
)

Parameters

idNum

objectName

newQueueName

forwardDate

userName

generateTimeBomb

notes

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowManager Class
WorkflowManager Members


GetAttachmentFilePath Method | fcSDK Documentation

GetAttachmentFilePath Method

Syntax

'Declaration

Public Function GetAttachmentFilePath( _
   ByVal _idNumber_ As String, _
   ByVal _basePath_ As String, _
   ByVal _fileName_ As String, _
   ByVal _attachMode_ As AttachmentFolderMode _
) As String

public string GetAttachmentFilePath(
   string _idNumber_,
   string _basePath_,
   string _fileName_,
   AttachmentFolderMode _attachMode_
)

Parameters

idNumber

basePath

fileName

attachMode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowManager Class
WorkflowManager Members


GetNextFileName Method | fcSDK Documentation

GetNextFileName Method

Syntax

'Declaration

Public Function GetNextFileName( _
   ByVal _fileName_ As String, _
   ByVal _basePath_ As String _
) As String

public string GetNextFileName(
   string _fileName_,
   string _basePath_
)

Parameters

fileName

basePath

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowManager Class
WorkflowManager Members


GetNextFileNameIgnoringExistence Method | fcSDK Documentation

GetNextFileNameIgnoringExistence Method

Syntax

'Declaration

Public Function GetNextFileNameIgnoringExistence( _
   ByVal _fileName_ As String, _
   ByVal _basePath_ As String _
) As String

public string GetNextFileNameIgnoringExistence(
   string _fileName_,
   string _basePath_
)

Parameters

fileName

basePath

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowManager Class
WorkflowManager Members


GetWipDetails Method | fcSDK Documentation

GetWipDetails Method

Syntax

'Declaration

Public Sub GetWipDetails( _
   ByVal _wipGen_ As ClarifyGeneric, _
   ByVal _info_ As WorkFlowInfo _
)

public void GetWipDetails(
   ClarifyGeneric _wipGen_,
   WorkFlowInfo _info_
)

Parameters

wipGen

info

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowManager Class
WorkflowManager Members


IsFilenameAlreadyInUseOnTheWorkflowObject Method | fcSDK Documentation

IsFilenameAlreadyInUseOnTheWorkflowObject Method

Syntax

'Declaration

Public Function IsFilenameAlreadyInUseOnTheWorkflowObject( _
   ByVal _fileName_ As String, _
   ByVal _idNumber_ As String, _
   ByVal _workflowObjectName_ As String _
) As Boolean

public bool IsFilenameAlreadyInUseOnTheWorkflowObject(
   string _fileName_,
   string _idNumber_,
   string _workflowObjectName_
)

Parameters

fileName

idNumber

workflowObjectName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowManager Class
WorkflowManager Members


MakeFullHistoryDirty Method | fcSDK Documentation

MakeFullHistoryDirty Method

Syntax

'Declaration

Public Shared Function MakeFullHistoryDirty( _
   ByVal _currentHistory_ As String _
) As String

public static string MakeFullHistoryDirty(
   string _currentHistory_
)

Parameters

currentHistory

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowManager Class
WorkflowManager Members


MapObjectNameToTableID Method | fcSDK Documentation

MapObjectNameToTableID Method

Syntax

'Declaration

Public Shared Function MapObjectNameToTableID( _
   ByVal _objectName_ As String _
) As Integer

public static int MapObjectNameToTableID(
   string _objectName_
)

Parameters

objectName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowManager Class
WorkflowManager Members


MapTimeBombActionToFlag Method | fcSDK Documentation

MapTimeBombActionToFlag Method

Syntax

'Declaration

Public Shared Function MapTimeBombActionToFlag( _
   ByVal _timeBombAction_ As String _
) As Integer

public static int MapTimeBombActionToFlag(
   string _timeBombAction_
)

Parameters

timeBombAction

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowManager Class
WorkflowManager Members


Move Method | fcSDK Documentation

Move Method

Syntax

'Declaration

Public Function Move( _
   ByVal _idNum_ As String, _
   ByVal _objectName_ As String, _
   ByVal _newWipBin_ As String _
) As WorkFlowInfo

public WorkFlowInfo Move(
   string _idNum_,
   string _objectName_,
   string _newWipBin_
)

Parameters

idNum

objectName

newWipBin

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowManager Class
WorkflowManager Members


Reject Method | fcSDK Documentation

Reject Method

Syntax

'Declaration

Public Function Reject( _
   ByVal _idNum_ As String, _
   ByVal _objectName_ As String, _
   ByVal _newWipBin_ As String, _
   ByVal _rejectDate_ As Date, _
   ByVal _userName_ As String, _
   ByVal _generateTimeBomb_ As Boolean, _
   ByVal _notes_ As String _
) As WorkFlowInfo

public WorkFlowInfo Reject(
   string _idNum_,
   string _objectName_,
   string _newWipBin_,
   DateTime _rejectDate_,
   string _userName_,
   bool _generateTimeBomb_,
   string _notes_
)

Parameters

idNum

objectName

newWipBin

rejectDate

userName

generateTimeBomb

notes

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowManager Class
WorkflowManager Members


Yank Method | fcSDK Documentation

Yank Method

Syntax

'Declaration

Public Function Yank( _
   ByVal _idNum_ As String, _
   ByVal _objectName_ As String, _
   ByVal _wipBin_ As String, _
   ByVal _yankDate_ As Date, _
   ByVal _userName_ As String, _
   ByVal _generateTimeBomb_ As Boolean _
) As WorkFlowInfo

public WorkFlowInfo Yank(
   string _idNum_,
   string _objectName_,
   string _wipBin_,
   DateTime _yankDate_,
   string _userName_,
   bool _generateTimeBomb_
)

Parameters

idNum

objectName

wipBin

yankDate

userName

generateTimeBomb

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowManager Class
WorkflowManager Members


EndOfHistoryMagicText Field | fcSDK Documentation

EndOfHistoryMagicText Field

Syntax

'Declaration

Public Shared ReadOnly EndOfHistoryMagicText As String

public static readonly string EndOfHistoryMagicText

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowManager Class
WorkflowManager Members


ImpersonatorUserName Field | fcSDK Documentation

ImpersonatorUserName Field

Syntax

'Declaration

Public ImpersonatorUserName As String

public string ImpersonatorUserName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowManager Class
WorkflowManager Members


| fcSDK Documentation

AttachmentFolderMode Enumeration

Syntax

'Declaration

Public Enum AttachmentFolderMode
   Inherits System.Enum

public enum AttachmentFolderMode : System.Enum

Members

Member | Description
ModeA |
ModeB |
ModeC |

Inheritance Hierarchy

System.Object System.ValueType System.Enum [FChoice.Foundation.Clarify.Workflow.AttachmentFolderMode**

Requirements

Namespace: FChoice.Foundation.Clarify.Workflow

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FChoice.Foundation.Clarify.Workflow Namespace FChoice.Foundation.Clarify.Workflow.AttachmentFolderMode

Requirements

Namespace: FChoice.Foundation.Clarify.Workflow

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FChoice.Foundation.Clarify.Workflow Namespace


FChoice.Foundation.DataObjects Namespace | fcSDK Documentation

FChoice.Foundation.DataObjects Namespace

Collections and support classes that wrap access to database tables.

Classes

 | Class | Description
Class | ColumnInfo |
Class | ConfigItem |
Class | ConfigItemCollection |
Class | DataObject |
Class | DataObjectCollection |
Class | FakeTimeZone |
Class | RestrictionGroup |
Class | RestrictionGroupCollection |

Interfaces

 | Interface | Description
Interface | IDataObject |
Interface | ITimeZone |

Enumerations

 | Enumeration | Description
Enumeration | ConfigItemScope |
Enumeration | ConfigItemValueType |

Reference

fcSDK Assembly


ColumnInfo Class | fcSDK Documentation

ColumnInfo Class

Syntax

'Declaration

Public Class ColumnInfo

public class ColumnInfo

Inheritance Hierarchy

System.Object
FChoice.Foundation.DataObjects.ColumnInfo

Requirements

Namespace: FChoice.Foundation.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ColumnInfo Members
FChoice.Foundation.DataObjects Namespace


ColumnInfo Class Members | fcSDK Documentation

ColumnInfo Class Members

The following tables list the members exposed by ColumnInfo.

Public Constructors

 | Name | Description
Public Constructor | ColumnInfo Constructor | Overloaded.

Public Properties

 | Name | Description
Public Property | DataType |
Public Property | DefaultValue |
Public Property | MaxLength |
Public Property | Name |
Public Property | Ordinal |
Public Property | TableName |

Public Methods

 | Name | Description
Public Method | CompareTo |

Reference

ColumnInfo Class
FChoice.Foundation.DataObjects Namespace


ColumnInfo Constructor | fcSDK Documentation

ColumnInfo Constructor

Overload List

Overload | Description
ColumnInfo Constructor() |
ColumnInfo Constructor(DataColumn) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ColumnInfo Class
ColumnInfo Members


ColumnInfo Constructor() | fcSDK Documentation

ColumnInfo Constructor()

Syntax

'Declaration

Public Function New()

public ColumnInfo()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ColumnInfo Class
ColumnInfo Members
Overload List


ColumnInfo Constructor(DataColumn) | fcSDK Documentation

ColumnInfo Constructor(DataColumn)

Syntax

'Declaration

Public Function New( _
   ByVal _col_ As DataColumn _
)

public ColumnInfo(
   DataColumn _col_
)

Parameters

col

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ColumnInfo Class
ColumnInfo Members
Overload List


CompareTo Method | fcSDK Documentation

CompareTo Method

Syntax

'Declaration

Public Function CompareTo( _
   ByVal _obj_ As Object _
) As Integer

public int CompareTo(
   object _obj_
)

Parameters

obj

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ColumnInfo Class
ColumnInfo Members


DataType Property (ColumnInfo) | fcSDK Documentation

DataType Property (ColumnInfo)

Syntax

'Declaration

Public ReadOnly Property DataType As Type

public Type DataType {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ColumnInfo Class
ColumnInfo Members


DefaultValue Property (ColumnInfo) | fcSDK Documentation

DefaultValue Property (ColumnInfo)

Syntax

'Declaration

Public ReadOnly Property DefaultValue As Object

public object DefaultValue {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ColumnInfo Class
ColumnInfo Members


MaxLength Property | fcSDK Documentation

MaxLength Property

Syntax

'Declaration

Public ReadOnly Property MaxLength As Integer

public int MaxLength {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ColumnInfo Class
ColumnInfo Members


Name Property (ColumnInfo) | fcSDK Documentation

Name Property (ColumnInfo)

Syntax

'Declaration

Public ReadOnly Property Name As String

public string Name {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ColumnInfo Class
ColumnInfo Members


Ordinal Property | fcSDK Documentation

Ordinal Property

Syntax

'Declaration

Public ReadOnly Property Ordinal As Integer

public int Ordinal {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ColumnInfo Class
ColumnInfo Members


TableName Property (ColumnInfo) | fcSDK Documentation

TableName Property (ColumnInfo)

Syntax

'Declaration

Public ReadOnly Property TableName As String

public string TableName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ColumnInfo Class
ColumnInfo Members


ConfigItem Class | fcSDK Documentation

ConfigItem Class

Syntax

'Declaration

Public MustInherit Class ConfigItem
   Inherits DataObject
   Implements IDataObject

public abstract class ConfigItem : DataObject, IDataObject

Inheritance Hierarchy

System.Object
FChoice.Foundation.DataObjects.DataObject
FChoice.Foundation.DataObjects.ConfigItem
FChoice.Foundation.Clarify.DataObjects.ClarifyConfigItem

Requirements

Namespace: FChoice.Foundation.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ConfigItem Members
FChoice.Foundation.DataObjects Namespace


ConfigItem Class Members | fcSDK Documentation

ConfigItem Class Members

The following tables list the members exposed by ConfigItem.

Public Properties

 | Name | Description
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | DateValue |
Public Property | DecimalValue |
Public Property | Description |
Public Property | DoubleValue |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | IntegerValue |
Public Property | LongValue |
Public Property | Name |
Public Property | Scope |
Public Property | StringValue |
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | ValueType |
Public Property | ValueTypeRaw |

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

ConfigItem Class
FChoice.Foundation.DataObjects Namespace


DateValue Property | fcSDK Documentation

DateValue Property

Syntax

'Declaration

Public ReadOnly Property DateValue As Date

public DateTime DateValue {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigItem Class
ConfigItem Members


DecimalValue Property | fcSDK Documentation

DecimalValue Property

Syntax

'Declaration

Public ReadOnly Property DecimalValue As Decimal

public decimal DecimalValue {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigItem Class
ConfigItem Members


Description Property (ConfigItem) | fcSDK Documentation

Description Property (ConfigItem)

Syntax

'Declaration

Public ReadOnly Property Description As String

public string Description {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigItem Class
ConfigItem Members


DoubleValue Property | fcSDK Documentation

DoubleValue Property

Syntax

'Declaration

Public ReadOnly Property DoubleValue As Double

public double DoubleValue {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigItem Class
ConfigItem Members


IntegerValue Property | fcSDK Documentation

IntegerValue Property

Syntax

'Declaration

Public ReadOnly Property IntegerValue As Integer

public int IntegerValue {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigItem Class
ConfigItem Members


LongValue Property | fcSDK Documentation

LongValue Property

Syntax

'Declaration

Public ReadOnly Property LongValue As Long

public long LongValue {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigItem Class
ConfigItem Members


Name Property (ConfigItem) | fcSDK Documentation

Name Property (ConfigItem)

Syntax

'Declaration

Public ReadOnly Property Name As String

public string Name {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigItem Class
ConfigItem Members


Scope Property | fcSDK Documentation

Scope Property

Syntax

'Declaration

Public ReadOnly Property Scope As ConfigItemScope

public ConfigItemScope Scope {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigItem Class
ConfigItem Members


StringValue Property | fcSDK Documentation

StringValue Property

Syntax

'Declaration

Public ReadOnly Property StringValue As String

public string StringValue {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigItem Class
ConfigItem Members


ValueType Property | fcSDK Documentation

ValueType Property

Syntax

'Declaration

Public ReadOnly Property ValueType As ConfigItemValueType

public ConfigItemValueType ValueType {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigItem Class
ConfigItem Members


ValueTypeRaw Property | fcSDK Documentation

ValueTypeRaw Property

Syntax

'Declaration

Public ReadOnly Property ValueTypeRaw As Integer

public int ValueTypeRaw {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigItem Class
ConfigItem Members


ConfigItemCollection Class | fcSDK Documentation

ConfigItemCollection Class

Syntax

'Declaration

<DefaultMemberAttribute("Item")>
<SerializableAttribute()>
Public MustInherit Class ConfigItemCollection
   Inherits FChoice.Foundation.DataObjects.DataObjectCollection(Of ConfigItem)

[DefaultMemberAttribute("Item")]
[SerializableAttribute()]
public abstract class ConfigItemCollection : FChoice.Foundation.DataObjects.DataObjectCollection<ConfigItem>

Inheritance Hierarchy

System.Object System.Collections.Generic.List FChoice.Foundation.DataObjects.DataObjectCollection [FChoice.Foundation.DataObjects.ConfigItemCollection** FChoice.Foundation.Clarify.DataObjects.ClarifyConfigItemCollection

Requirements

Namespace: FChoice.Foundation.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ConfigItemCollection Members FChoice.Foundation.DataObjects Namespace FChoice.Foundation.DataObjects.ConfigItemCollection FChoice.Foundation.Clarify.DataObjects.ClarifyConfigItemCollection

Requirements

Namespace: FChoice.Foundation.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ConfigItemCollection Members FChoice.Foundation.DataObjects Namespace


ConfigItemCollection Class Members | fcSDK Documentation

ConfigItemCollection Class Members

The following tables list the members exposed by ConfigItemCollection.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | Item |

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex | (Inherited from FChoice.Foundation.DataObjects.DataObjectCollection)
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

ConfigItemCollection Class
FChoice.Foundation.DataObjects Namespace


Item Property (ConfigItemCollection) | fcSDK Documentation

Item Property (ConfigItemCollection)

Syntax

'Declaration

Public Shadows ReadOnly Default Property Item( _
   ByVal _itemName_ As String _
) As ConfigItem

public new ConfigItem this[
   string _itemName_
]; {get;}

Parameters

itemName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConfigItemCollection Class
ConfigItemCollection Members


DataObject Class | fcSDK Documentation

DataObject Class

Syntax

'Declaration

Public MustInherit Class DataObject
   Implements IDataObject

public abstract class DataObject : IDataObject

Inheritance Hierarchy

System.Object
FChoice.Foundation.DataObjects.DataObject
FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject
FChoice.Foundation.DataObjects.ConfigItem
FChoice.Foundation.DataObjects.RestrictionGroup

Requirements

Namespace: FChoice.Foundation.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

DataObject Members
FChoice.Foundation.DataObjects Namespace


DataObject Class Members | fcSDK Documentation

DataObject Class Members

The following tables list the members exposed by DataObject.

Public Properties

 | Name | Description
Public Property | ColumnMap |
Public Property | FieldValues |
Public Property | UniqueID |

Public Methods

 | Name | Description
Public Method | ContainsColumn |
Public Method | GetFieldValue | Overloaded.
Public Method | GetSafeBooleanFieldValue | Overloaded.
Public Method | GetSafeDoubleFieldValue | Overloaded.
Public Method | GetSafeInt32FieldValue | Overloaded.
Public Method | GetSafeStringFieldValue |

Reference

DataObject Class
FChoice.Foundation.DataObjects Namespace


ContainsColumn Method (DataObject) | fcSDK Documentation

ContainsColumn Method (DataObject)

Syntax

'Declaration

Public Function ContainsColumn( _
   ByVal _columnName_ As String _
) As Boolean

public bool ContainsColumn(
   string _columnName_
)

Parameters

columnName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataObject Class
DataObject Members


GetFieldValue Method (DataObject) | fcSDK Documentation

GetFieldValue Method (DataObject)

Overload List

Overload | Description
GetFieldValue(String) |
GetFieldValue(Int32) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataObject Class
DataObject Members


GetFieldValue(String) Method | fcSDK Documentation

GetFieldValue(String) Method

Syntax

'Declaration

Public Overloads Function GetFieldValue( _
   ByVal _colName_ As String _
) As Object

public object GetFieldValue(
   string _colName_
)

Parameters

colName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataObject Class
DataObject Members
Overload List


GetFieldValue(Int32) Method | fcSDK Documentation

GetFieldValue(Int32) Method

Syntax

'Declaration

Public Overloads Function GetFieldValue( _
   ByVal _ordinal_ As Integer _
) As Object

public object GetFieldValue(
   int _ordinal_
)

Parameters

ordinal

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataObject Class
DataObject Members
Overload List


GetSafeBooleanFieldValue Method (DataObject) | fcSDK Documentation

GetSafeBooleanFieldValue Method (DataObject)

Overload List

Overload | Description
GetSafeBooleanFieldValue(String) |
GetSafeBooleanFieldValue(String,Dictionary<String,ColumnInfo>,Object[]) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataObject Class
DataObject Members


GetSafeBooleanFieldValue(String) Method | fcSDK Documentation

GetSafeBooleanFieldValue(String) Method

Syntax

'Declaration

Public Overloads Function GetSafeBooleanFieldValue( _
   ByVal _columnName_ As String _
) As Boolean

public bool GetSafeBooleanFieldValue(
   string _columnName_
)

Parameters

columnName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataObject Class
DataObject Members
Overload List


GetSafeBooleanFieldValue(String,Dictionary<String,ColumnInfo>,Object[]) Method | fcSDK Documentation

GetSafeBooleanFieldValue(String,Dictionary<String,ColumnInfo>,Object[]) Method

Syntax

'Declaration

Public Overloads Shared Function GetSafeBooleanFieldValue( _
   ByVal _columnName_ As String, _
   ByVal _columnMap_ As Dictionary(Of String,ColumnInfo), _
   ByVal _values_() As Object _
) As Boolean

public static bool GetSafeBooleanFieldValue(
   string _columnName_,
   Dictionary<string,ColumnInfo> _columnMap_,
   object[] _values_
)

Parameters

columnName

columnMap

values

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataObject Class
DataObject Members
Overload List


GetSafeDoubleFieldValue Method (DataObject) | fcSDK Documentation

GetSafeDoubleFieldValue Method (DataObject)

Overload List

Overload | Description
GetSafeDoubleFieldValue(String) |
GetSafeDoubleFieldValue(String,Dictionary<String,ColumnInfo>,Object[]) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataObject Class
DataObject Members


GetSafeDoubleFieldValue(String) Method | fcSDK Documentation

GetSafeDoubleFieldValue(String) Method

Syntax

'Declaration

Public Overloads Function GetSafeDoubleFieldValue( _
   ByVal _columnName_ As String _
) As Double

public double GetSafeDoubleFieldValue(
   string _columnName_
)

Parameters

columnName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataObject Class
DataObject Members
Overload List


GetSafeDoubleFieldValue(String,Dictionary<String,ColumnInfo>,Object[]) Method | fcSDK Documentation

GetSafeDoubleFieldValue(String,Dictionary<String,ColumnInfo>,Object[]) Method

Syntax

'Declaration

Public Overloads Shared Function GetSafeDoubleFieldValue( _
   ByVal _columnName_ As String, _
   ByVal _columnMap_ As Dictionary(Of String,ColumnInfo), _
   ByVal _values_() As Object _
) As Double

public static double GetSafeDoubleFieldValue(
   string _columnName_,
   Dictionary<string,ColumnInfo> _columnMap_,
   object\[\] _values_
)

Parameters

columnName

columnMap

values

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataObject Class
DataObject Members
Overload List


GetSafeInt32FieldValue Method (DataObject) | fcSDK Documentation

GetSafeInt32FieldValue Method (DataObject)

Overload List

Overload | Description
GetSafeInt32FieldValue(String) |
GetSafeInt32FieldValue(String,Dictionary<String,ColumnInfo>,Object[]) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataObject Class
DataObject Members


GetSafeInt32FieldValue(String) Method | fcSDK Documentation

GetSafeInt32FieldValue(String) Method

Syntax

'Declaration

Public Overloads Function GetSafeInt32FieldValue( _
   ByVal _colName_ As String _
) As Integer

public int GetSafeInt32FieldValue(
   string _colName_
)

Parameters

colName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataObject Class
DataObject Members
Overload List


GetSafeInt32FieldValue(String,Dictionary<String,ColumnInfo>,Object[]) Method | fcSDK Documentation

GetSafeInt32FieldValue(String,Dictionary<String,ColumnInfo>,Object[]) Method

Syntax

'Declaration

Public Overloads Shared Function GetSafeInt32FieldValue( _
   ByVal _columnName_ As String, _
   ByVal _columnMap_ As Dictionary(Of String,ColumnInfo), _
   ByVal _values_() As Object _
) As Integer

public static int GetSafeInt32FieldValue(
   string _columnName_,
   Dictionary<string,ColumnInfo> _columnMap_,
   object\[\] _values_
)

Parameters

columnName

columnMap

values

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataObject Class
DataObject Members
Overload List


GetSafeStringFieldValue Method (DataObject) | fcSDK Documentation

GetSafeStringFieldValue Method (DataObject)

Syntax

'Declaration

Public Function GetSafeStringFieldValue( _
   ByVal _colName_ As String _
) As String

public string GetSafeStringFieldValue(
   string _colName_
)

Parameters

colName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataObject Class
DataObject Members


ColumnMap Property (DataObject) | fcSDK Documentation

ColumnMap Property (DataObject)

Syntax

'Declaration

Public ReadOnly Property ColumnMap As IDictionary

public IDictionary ColumnMap {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataObject Class
DataObject Members


FieldValues Property (DataObject) | fcSDK Documentation

FieldValues Property (DataObject)

Syntax

'Declaration

Public ReadOnly Property FieldValues As Object()

public object[] FieldValues {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataObject Class
DataObject Members


UniqueID Property (DataObject) | fcSDK Documentation

UniqueID Property (DataObject)

Syntax

'Declaration

Public ReadOnly Property UniqueID As Object

public object UniqueID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataObject Class
DataObject Members


DataObjectCollection Class | fcSDK Documentation

DataObjectCollection Class

Syntax

'Declaration

Public MustInherit Class DataObjectCollection(Of T As IDataObject)
   Inherits System.Collections.Generic.List(Of T)

public abstract class DataObjectCollection<T\> : System.Collections.Generic.List<T>
where T: [IDataObject

Type Parameters

T

Inheritance Hierarchy

System.Object
System.Collections.Generic.List
FChoice.Foundation.DataObjects.DataObjectCollection
FChoice.Foundation.Clarify.DataObjects.CountryCollection
FChoice.Foundation.Clarify.DataObjects.DaylightSavingsCollection
FChoice.Foundation.Clarify.DataObjects.FCTimeZoneCollection
FChoice.Foundation.Clarify.DataObjects.GlobalStringElementCollection
FChoice.Foundation.Clarify.DataObjects.GlobalStringListCollection
FChoice.Foundation.Clarify.DataObjects.HierarchicalStringElementCollection
FChoice.Foundation.Clarify.DataObjects.HierarchicalStringListCollection
FChoice.Foundation.Clarify.DataObjects.StateCollection
FChoice.Foundation.Clarify.Schema.SchemaFieldCollectionBase
FChoice.Foundation.Clarify.Schema.SchemaRelationCollection
FChoice.Foundation.Clarify.Schema.SchemaTableCollection
FChoice.Foundation.Clarify.Schema.SchemaViewCollection
FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfoCollection
FChoice.Foundation.Clarify.Schema.SchemaViewJoinCollection
FChoice.Foundation.DataObjects.ConfigItemCollection
FChoice.Foundation.DataObjects.RestrictionGroupCollection

Requirements

Namespace: FChoice.Foundation.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

DataObjectCollection Members
FChoice.Foundation.DataObjects Namespace


DataObjectCollection Class Members | fcSDK Documentation

DataObjectCollection Class Members

The following tables list the members exposed by DataObjectCollection.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | Item | (Inherited from System.Collections.Generic.List)

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex |
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

DataObjectCollection Class
FChoice.Foundation.DataObjects Namespace


GetItemByIndex Method (DataObjectCollection) | fcSDK Documentation

GetItemByIndex Method (DataObjectCollection)

Syntax

'Declaration

Public Function GetItemByIndex( _
   ByVal _index_ As Integer) As T

public T GetItemByIndex(
   int _index_
)

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DataObjectCollection Class
DataObjectCollection Members


FakeTimeZone Class | fcSDK Documentation

FakeTimeZone Class

Syntax

'Declaration

Public Class FakeTimeZone
   Inherits FChoice.Foundation.Clarify.DataObjects.FCTimeZone
   Implements IDataObject, ITimeZone

public class FakeTimeZone : FChoice.Foundation.Clarify.DataObjects.FCTimeZone, IDataObject, ITimeZone

Inheritance Hierarchy

System.Object
FChoice.Foundation.DataObjects.DataObject
FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject
[FChoice.Foundation.Clarify.DataObjects.FCTimeZone
FChoice.Foundation.DataObjects.FakeTimeZone

Requirements

Namespace: FChoice.Foundation.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FakeTimeZone Members
FChoice.Foundation.DataObjects Namespace


FakeTimeZone Class Members | fcSDK Documentation

FakeTimeZone Class Members

The following tables list the members exposed by FakeTimeZone.

Public Properties

 | Name | Description
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | DaylightSavingsPeriods | (Inherited from FChoice.Foundation.Clarify.DataObjects.FCTimeZone)
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | FullName | (Inherited from FChoice.Foundation.Clarify.DataObjects.FCTimeZone)
Public Property | IsDefault | (Inherited from FChoice.Foundation.Clarify.DataObjects.FCTimeZone)
Public Property | Name | (Inherited from FChoice.Foundation.Clarify.DataObjects.FCTimeZone)
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | UtcOffsetSeconds | (Inherited from FChoice.Foundation.Clarify.DataObjects.FCTimeZone)

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | ConvertDate | (Inherited from FChoice.Foundation.Clarify.DataObjects.FCTimeZone)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | IsDaylightSavingsTime | (Inherited from FChoice.Foundation.Clarify.DataObjects.FCTimeZone)

Reference

FakeTimeZone Class
FChoice.Foundation.DataObjects Namespace


RestrictionGroup Class | fcSDK Documentation

RestrictionGroup Class

Syntax

'Declaration

Public Class RestrictionGroup
   Inherits DataObject
   Implements IDataObject

public class RestrictionGroup : DataObject, IDataObject

Inheritance Hierarchy

System.Object
FChoice.Foundation.DataObjects.DataObject
FChoice.Foundation.DataObjects.RestrictionGroup

Requirements

Namespace: FChoice.Foundation.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

RestrictionGroup Members
FChoice.Foundation.DataObjects Namespace


RestrictionGroup Class Members | fcSDK Documentation

RestrictionGroup Class Members

The following tables list the members exposed by RestrictionGroup.

Public Properties

 | Name | Description
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Name |
Public Property | Restrictions |
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

RestrictionGroup Class
FChoice.Foundation.DataObjects Namespace


Name Property (RestrictionGroup) | fcSDK Documentation

Name Property (RestrictionGroup)

Syntax

'Declaration

Public ReadOnly Property Name As String

public string Name {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RestrictionGroup Class
RestrictionGroup Members


Restrictions Property | fcSDK Documentation

Restrictions Property

Syntax

'Declaration

Public ReadOnly Property Restrictions As String()

public string[] Restrictions {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RestrictionGroup Class
RestrictionGroup Members


RestrictionGroupCollection Class | fcSDK Documentation

RestrictionGroupCollection Class

Syntax

'Declaration

<DefaultMemberAttribute("Item")>
Public Class RestrictionGroupCollection
   Inherits FChoice.Foundation.DataObjects.DataObjectCollection(Of RestrictionGroup)

[DefaultMemberAttribute("Item")]
public class RestrictionGroupCollection : FChoice.Foundation.DataObjects.DataObjectCollection<RestrictionGroup>

Inheritance Hierarchy

System.Object System.Collections.Generic.List FChoice.Foundation.DataObjects.DataObjectCollection FChoice.Foundation.DataObjects.RestrictionGroupCollection

Requirements

Namespace: FChoice.Foundation.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

RestrictionGroupCollection Members FChoice.Foundation.DataObjects Namespace](FChoice.Foundation.DataObjects.RestrictionGroupCollection**

Requirements

Namespace: FChoice.Foundation.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

RestrictionGroupCollection Members FChoice.Foundation.DataObjects Namespace


RestrictionGroupCollection Class Members | fcSDK Documentation

RestrictionGroupCollection Class Members

The following tables list the members exposed by RestrictionGroupCollection.

Public Constructors

 | Name | Description
Public Constructor | RestrictionGroupCollection Constructor | Overloaded.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | Item |

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex | (Inherited from FChoice.Foundation.DataObjects.DataObjectCollection)
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

RestrictionGroupCollection Class
FChoice.Foundation.DataObjects Namespace


RestrictionGroupCollection Constructor | fcSDK Documentation

RestrictionGroupCollection Constructor

Overload List

Overload | Description
RestrictionGroupCollection Constructor() |
RestrictionGroupCollection Constructor(DataTable) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RestrictionGroupCollection Class
RestrictionGroupCollection Members


RestrictionGroupCollection Constructor() | fcSDK Documentation

RestrictionGroupCollection Constructor()

Syntax

'Declaration

Public Function New()

public RestrictionGroupCollection()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RestrictionGroupCollection Class
RestrictionGroupCollection Members
Overload List


RestrictionGroupCollection Constructor(DataTable) | fcSDK Documentation

RestrictionGroupCollection Constructor(DataTable)

Syntax

'Declaration

Public Function New( _
   ByVal _table_ As DataTable _
)

public RestrictionGroupCollection(
   DataTable _table_
)

Parameters

table

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RestrictionGroupCollection Class
RestrictionGroupCollection Members
Overload List


Item Property (RestrictionGroupCollection) | fcSDK Documentation

Item Property (RestrictionGroupCollection)

Syntax

'Declaration

Public Shadows ReadOnly Default Property Item( _
   ByVal _name_ As String _
) As RestrictionGroup

public new RestrictionGroup this[
   string _name_
]; {get;}

Parameters

name

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RestrictionGroupCollection Class
RestrictionGroupCollection Members


ConfigItemScope Enumeration | fcSDK Documentation

ConfigItemScope Enumeration

Syntax

'Declaration

Public Enum ConfigItemScope
   Inherits System.Enum

public enum ConfigItemScope : System.Enum

Members

Member | Description
Global |
Person |
Workgroup |

Inheritance Hierarchy

System.Object System.ValueType System.Enum FChoice.Foundation.DataObjects.ConfigItemScope

Requirements

Namespace: FChoice.Foundation.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FChoice.Foundation.DataObjects Namespace FChoice.Foundation.DataObjects.ConfigItemScope

Requirements

Namespace: FChoice.Foundation.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FChoice.Foundation.DataObjects Namespace


ConfigItemValueType Enumeration | fcSDK Documentation

ConfigItemValueType Enumeration

Syntax

'Declaration

Public Enum ConfigItemValueType
   Inherits System.Enum

public enum ConfigItemValueType : System.Enum

Members

Member | Description
All |
Double |
Integer |
String |
Unknown |

Inheritance Hierarchy

System.Object System.ValueType System.Enum [FChoice.Foundation.DataObjects.ConfigItemValueType**

Requirements

Namespace: FChoice.Foundation.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FChoice.Foundation.DataObjects Namespace FChoice.Foundation.DataObjects.ConfigItemValueType

Requirements

Namespace: FChoice.Foundation.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FChoice.Foundation.DataObjects Namespace


IDataObject Interface | fcSDK Documentation

IDataObject Interface

Syntax

'Declaration

Public Interface IDataObject

public interface IDataObject

Requirements

Namespace: FChoice.Foundation.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

IDataObject Members
FChoice.Foundation.DataObjects Namespace


IDataObject Interface Members | fcSDK Documentation

IDataObject Interface Members

The following tables list the members exposed by IDataObject.

Public Properties

 | Name | Description
Property | ColumnMap |
Property | FieldValues |
Property | UniqueID |

Public Methods

 | Name | Description
Method | ContainsColumn |
Method | GetFieldValue | Overloaded.
Method | GetSafeBooleanFieldValue |
Method | GetSafeDoubleFieldValue |
Method | GetSafeInt32FieldValue |
Method | GetSafeStringFieldValue |

Reference

IDataObject Interface
FChoice.Foundation.DataObjects Namespace


ContainsColumn Method (IDataObject) | fcSDK Documentation

ContainsColumn Method (IDataObject)

Syntax

'Declaration
Function ContainsColumn( _
   ByVal _columnName_ As String _
) As Boolean

bool ContainsColumn(
   string _columnName_
)

Parameters

columnName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IDataObject Interface
IDataObject Members


GetFieldValue Method (IDataObject) | fcSDK Documentation

GetFieldValue Method (IDataObject)

Overload List

Overload | Description
GetFieldValue(String) |
GetFieldValue(Int32) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IDataObject Interface
IDataObject Members


GetFieldValue(String) Method | fcSDK Documentation

GetFieldValue(String) Method

Syntax

'Declaration

Overloads Function GetFieldValue( _
   ByVal _colName_ As String _
) As Object

object GetFieldValue(
   string _colName_
)

Parameters

colName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IDataObject Interface
IDataObject Members
Overload List


GetFieldValue(Int32) Method | fcSDK Documentation

GetFieldValue(Int32) Method

Syntax

'Declaration

Overloads Function GetFieldValue( _
   ByVal _ordinal_ As Integer _
) As Object

object GetFieldValue(
   int _ordinal_
)

Parameters

ordinal

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IDataObject Interface
IDataObject Members
Overload List


GetSafeBooleanFieldValue Method (IDataObject) | fcSDK Documentation

GetSafeBooleanFieldValue Method (IDataObject)

Syntax

'Declaration

Function GetSafeBooleanFieldValue( _
   ByVal _columnName_ As String _
) As Boolean

bool GetSafeBooleanFieldValue(
   string _columnName_
)

Parameters

columnName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IDataObject Interface
IDataObject Members


GetSafeDoubleFieldValue Method (IDataObject) | fcSDK Documentation

GetSafeDoubleFieldValue Method (IDataObject)

Syntax

'Declaration

Function GetSafeDoubleFieldValue( _
   ByVal _columnName_ As String _
) As Double

double GetSafeDoubleFieldValue(
   string _columnName_
)

Parameters

columnName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IDataObject Interface
IDataObject Members


GetSafeInt32FieldValue Method (IDataObject) | fcSDK Documentation

GetSafeInt32FieldValue Method (IDataObject)

Syntax

'Declaration

Function GetSafeInt32FieldValue( _
   ByVal _colName_ As String _
) As Integer

int GetSafeInt32FieldValue(
   string _colName_
)

Parameters

colName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IDataObject Interface
IDataObject Members


GetSafeStringFieldValue Method (IDataObject) | fcSDK Documentation

GetSafeStringFieldValue Method (IDataObject)

Syntax

'Declaration

Function GetSafeStringFieldValue( _
   ByVal _colName_ As String _
) As String

string GetSafeStringFieldValue(
   string _colName_
)

Parameters

colName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IDataObject Interface
IDataObject Members


ColumnMap Property (IDataObject) | fcSDK Documentation

ColumnMap Property (IDataObject)

Syntax

'Declaration
ReadOnly Property ColumnMap As IDictionary

IDictionary ColumnMap {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IDataObject Interface
IDataObject Members


FieldValues Property (IDataObject) | fcSDK Documentation

FieldValues Property (IDataObject)

Syntax

'Declaration

ReadOnly Property FieldValues As Object()

object[] FieldValues {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IDataObject Interface
IDataObject Members


UniqueID Property (IDataObject) | fcSDK Documentation

UniqueID Property (IDataObject)

Syntax

'Declaration
ReadOnly Property UniqueID As Object

object UniqueID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IDataObject Interface
IDataObject Members


ITimeZone Interface | fcSDK Documentation

ITimeZone Interface

Syntax

'Declaration

Public Interface ITimeZone

public interface ITimeZone

Requirements

Namespace: FChoice.Foundation.DataObjects

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ITimeZone Members
FChoice.Foundation.DataObjects Namespace


ITimeZone Interface Members | fcSDK Documentation

ITimeZone Interface Members

The following tables list the members exposed by ITimeZone.

Public Properties

 | Name | Description
Property | FullName |
Property | Name |
Property | UtcOffsetSeconds |

Public Methods

 | Name | Description
Method | IsDaylightSavingsTime |

Reference

ITimeZone Interface
FChoice.Foundation.DataObjects Namespace


IsDaylightSavingsTime Method (ITimeZone) | fcSDK Documentation

IsDaylightSavingsTime Method (ITimeZone)

Syntax

'Declaration

Function IsDaylightSavingsTime( _
   ByVal _date_ As Date _
) As Boolean

bool IsDaylightSavingsTime(
   DateTime _date_
)

Parameters

date

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ITimeZone Interface
ITimeZone Members


FullName Property (ITimeZone) | fcSDK Documentation

FullName Property (ITimeZone)

Syntax

'Declaration

ReadOnly Property FullName As String

string FullName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ITimeZone Interface
ITimeZone Members


Name Property (ITimeZone) | fcSDK Documentation

Name Property (ITimeZone)

Syntax

'Declaration

ReadOnly Property Name As String

string Name {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ITimeZone Interface
ITimeZone Members


UtcOffsetSeconds Property (ITimeZone) | fcSDK Documentation

UtcOffsetSeconds Property (ITimeZone)

Syntax

'Declaration

ReadOnly Property UtcOffsetSeconds As Integer

int UtcOffsetSeconds {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ITimeZone Interface
ITimeZone Members


FChoice.Foundation.DynamicBinding Namespace | fcSDK Documentation

FChoice.Foundation.DynamicBinding Namespace

Support for updating relations between objects that require information that is not yet loaded or available.

Classes

 | Class | Description
Class | DynamicBindingCollection |

Interfaces

 | Interface | Description
Interface | IDynamicBinding |

Reference

fcSDK Assembly


DynamicBindingCollection Class | fcSDK Documentation

DynamicBindingCollection Class

Syntax

'Declaration

Public Class DynamicBindingCollection
   Inherits System.Collections.ObjectModel.Collection(Of IDynamicBinding)

public class DynamicBindingCollection : System.Collections.ObjectModel.Collection<IDynamicBinding>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection
FChoice.Foundation.DynamicBinding.DynamicBindingCollection

Requirements

Namespace: FChoice.Foundation.DynamicBinding

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

DynamicBindingCollection Members
FChoice.Foundation.DynamicBinding Namespace


DynamicBindingCollection Class Members | fcSDK Documentation

DynamicBindingCollection Class Members

The following tables list the members exposed by DynamicBindingCollection.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection)

Public Methods

 | Name | Description
Public Method | Add(IDynamicBinding) | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | Remove(IDynamicBinding) | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection)

Reference

DynamicBindingCollection Class
FChoice.Foundation.DynamicBinding Namespace


IDynamicBinding Interface | fcSDK Documentation

IDynamicBinding Interface

Syntax

'Declaration

Public Interface IDynamicBinding

public interface IDynamicBinding

Requirements

Namespace: FChoice.Foundation.DynamicBinding

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

IDynamicBinding Members
FChoice.Foundation.DynamicBinding Namespace


IDynamicBinding Interface Members | fcSDK Documentation

IDynamicBinding Interface Members

The following tables list the members exposed by IDynamicBinding.

Public Properties

 | Name | Description
Property | Processed |
Property | Relation |

Public Methods

 | Name | Description
Method | ProcessBinding |

Reference

IDynamicBinding Interface
FChoice.Foundation.DynamicBinding Namespace


ProcessBinding Method | fcSDK Documentation

ProcessBinding Method

Syntax

'Declaration

Sub ProcessBinding( _
   ByVal _changedRows_ As IDictionary(Of FCGeneric,IDictionary(Of Guid,GenericDataRow)), _
   ByVal _batch_ As UpdateQueryBatch _
)

void ProcessBinding(
   IDictionary<FCGeneric,IDictionary<Guid,GenericDataRow>> _changedRows_,
   UpdateQueryBatch _batch_
)

Parameters

changedRows

batch

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IDynamicBinding Interface
IDynamicBinding Members


Processed Property | fcSDK Documentation

Processed Property

Syntax

'Declaration

ReadOnly Property Processed As Boolean

bool Processed {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IDynamicBinding Interface
IDynamicBinding Members


Relation Property | fcSDK Documentation

Relation Property

Syntax

'Declaration
ReadOnly Property Relation As ISchemaRelation

ISchemaRelation Relation {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IDynamicBinding Interface
IDynamicBinding Members


FChoice.Foundation.Filters Namespace | fcSDK Documentation

FChoice.Foundation.Filters Namespace

Classes

 | Class | Description
Class | AfterFilter | Filter field on dates coming after the input to this filter
Class | AndFilter | Logical filter allowing 2 AND (inclusive) filters.
Class | AndManyFilter | Alternative filter to AndFilter which allows for more than two sub filters.
Class | BeforeFilter | Filter field on dates coming before the input to this filter
Class | BetweenFilter | Filter field for values that occur between the two filter inputs
Class | ColumnBasedFilter | Abstract filter type that maps to a column.
Class | ContainsFilter | Filter field on strings that contain the input to this filter
Class | EndsWithFilter | Filter on strings that end with the input to this filter
Class | EqualsFilter | Filter field on data that equals the input to this filter
Class | Filter | Abstract base of all filters.
Class | FilterCollection | Holds one or more filters. This collection is used by filters that allow children such as OrFilter and AndFilter
Class | FilterExpression | Filter expressions offer on non static alternative to FilterType for construction of Filter objects.
Class | FilterType | This is a helper factory for creation of Filter objects.
Class | IsInFilter | Filter on fields that are in the input array
Class | IsNullFilter | Filter on fields that are null
Class | LessThanFilter | Filter field that are less than filter input
Class | LessThanOrEqualFilter | Filter field that are less than or equal to the filter input
Class | LikeFilter | Filter field on strings that are like the filter input
Class | LogicalFilter | Abstract filter for logical filter types.
Class | MoreThanFilter | Filter field that are more than the filter input
Class | MoreThanOrEqualFilter | Filter field that are more than or equal to the filter input
Class | NotContainsFilter | Filter field on strings that do not contain the input to this filter
Class | NotEndsWithFilter | Filter field on strings that do end with the input to this filter
Class | NotLikeFilter | Filter field on strings that are not like the filter input
Class | NotStartsWithFilter | Filter field on strings that do start with the input to this filter
Class | OlderThanDaysFilter | Filter field on dates that are older than a number of days
Class | OlderThanHoursFilter | Filter field on dates that are older than a number of hours
Class | OnFilter | Filter field on dates occuring on the the input to this filter
Class | OperationFilter | Abstract filter for operation type filters.
Class | OrFilter | Logical filter allowing 2 OR (exclusive) filters.
Class | OrManyFilter | Alternative filter to OrFilter which allows for more than two sub filters.
Class | SoundsLikeFilter | Filter field on strings sound like the input to this filter
Class | StartsWithFilter | Filter field on strings that do not contain the input to this filter
Class | TodayFilter | Filter field on today's date
Class | TomorrowFilter | Filter field on tomorrow's date
Class | WithinDaysFilter | Filter field on dates that have occurred within a number of days
Class | WithinHoursFilter | Filter field on dates that have occurred within a number of hours
Class | YesterdayFilter | Filter

Reference

fcSDK Assembly


AfterFilter Class | fcSDK Documentation

AfterFilter Class

Filter field on dates coming after the input to this filter

Syntax

'Declaration

Public Class AfterFilter
   Inherits MoreThanFilter

public class AfterFilter : MoreThanFilter

Example

Developer Walkthrough - Advanced Filtering

Inheritance Hierarchy

System.Object
FChoice.Foundation.Filters.Filter
FChoice.Foundation.Filters.ColumnBasedFilter
FChoice.Foundation.Filters.OperationFilter
FChoice.Foundation.Filters.MoreThanFilter
FChoice.Foundation.Filters.AfterFilter

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

AfterFilter Members
FChoice.Foundation.Filters Namespace


AfterFilter Class Members | fcSDK Documentation

AfterFilter Class Members

The following tables list the members exposed by AfterFilter.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | Operator | (Inherited from FChoice.Foundation.Filters.MoreThanFilter)
Public Property | Value | (Inherited from FChoice.Foundation.Filters.OperationFilter)

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

AfterFilter Class
FChoice.Foundation.Filters Namespace


AndFilter Class | fcSDK Documentation

AndFilter Class

Logical filter allowing 2 AND (inclusive) filters.

Syntax

'Declaration

Public Class AndFilter
   Inherits LogicalFilter

public class AndFilter : LogicalFilter

Example

Developer Walkthrough - Advanced Filtering

Inheritance Hierarchy

System.Object
FChoice.Foundation.Filters.Filter
FChoice.Foundation.Filters.LogicalFilter
FChoice.Foundation.Filters.AndFilter

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

AndFilter Members
FChoice.Foundation.Filters Namespace


AndFilter Class Members | fcSDK Documentation

AndFilter Class Members

The following tables list the members exposed by AndFilter.

Public Properties

 | Name | Description
Public Property | Filters | Collection of Filters that belong to this logical grouping. (Inherited from FChoice.Foundation.Filters.LogicalFilter)

Public Methods

 | Name | Description
Public Method | AddFilter | This method is called to add a filter to a logical grouping (Inherited from FChoice.Foundation.Filters.LogicalFilter)
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

AndFilter Class
FChoice.Foundation.Filters Namespace


AndManyFilter Class | fcSDK Documentation

AndManyFilter Class

Alternative filter to AndFilter which allows for more than two sub filters.

Syntax

'Declaration

Public Class AndManyFilter
   Inherits LogicalFilter

public class AndManyFilter : LogicalFilter

Inheritance Hierarchy

System.Object
FChoice.Foundation.Filters.Filter
FChoice.Foundation.Filters.LogicalFilter
FChoice.Foundation.Filters.AndManyFilter

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

AndManyFilter Members
FChoice.Foundation.Filters Namespace


AndManyFilter Class Members | fcSDK Documentation

AndManyFilter Class Members

The following tables list the members exposed by AndManyFilter.

Public Properties

 | Name | Description
Public Property | Filters | Collection of Filters that belong to this logical grouping. (Inherited from FChoice.Foundation.Filters.LogicalFilter)

Public Methods

 | Name | Description
Public Method | AddFilter | This method is called to add a filter to a logical grouping (Inherited from FChoice.Foundation.Filters.LogicalFilter)
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

AndManyFilter Class
FChoice.Foundation.Filters Namespace


BeforeFilter Class | fcSDK Documentation

BeforeFilter Class

Filter field on dates coming before the input to this filter

Syntax

'Declaration

Public Class BeforeFilter
   Inherits LessThanFilter

public class BeforeFilter : LessThanFilter

Example

Developer Walkthrough - Advanced Filtering

Inheritance Hierarchy

System.Object
FChoice.Foundation.Filters.Filter
FChoice.Foundation.Filters.ColumnBasedFilter
FChoice.Foundation.Filters.OperationFilter
FChoice.Foundation.Filters.LessThanFilter
FChoice.Foundation.Filters.BeforeFilter

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

BeforeFilter Members
FChoice.Foundation.Filters Namespace


BeforeFilter Class Members | fcSDK Documentation

BeforeFilter Class Members

The following tables list the members exposed by BeforeFilter.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | Operator | (Inherited from FChoice.Foundation.Filters.LessThanFilter)
Public Property | Value | (Inherited from FChoice.Foundation.Filters.OperationFilter)

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

BeforeFilter Class
FChoice.Foundation.Filters Namespace


BetweenFilter Class | fcSDK Documentation

BetweenFilter Class

Filter field for values that occur between the two filter inputs

Syntax

'Declaration

Public Class BetweenFilter
   Inherits ColumnBasedFilter

public class BetweenFilter : ColumnBasedFilter

Example

Developer Walkthrough - Advanced Filtering

Inheritance Hierarchy

System.Object
FChoice.Foundation.Filters.Filter
FChoice.Foundation.Filters.ColumnBasedFilter
FChoice.Foundation.Filters.BetweenFilter
FChoice.Foundation.Filters.OnFilter
FChoice.Foundation.Filters.WithinDaysFilter
FChoice.Foundation.Filters.WithinHoursFilter
FChoice.Foundation.Filters.YesterdayFilter

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

BetweenFilter Members
FChoice.Foundation.Filters Namespace


BetweenFilter Class Members | fcSDK Documentation

BetweenFilter Class Members

The following tables list the members exposed by BetweenFilter.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | IsBetween |
Public Property | Value1 |
Public Property | Value1Present |
Public Property | Value2 |
Public Property | Value2Present |

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

BetweenFilter Class
FChoice.Foundation.Filters Namespace


IsBetween Property | fcSDK Documentation

IsBetween Property

Syntax

'Declaration

Public ReadOnly Property IsBetween As Boolean

public bool IsBetween {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

BetweenFilter Class
BetweenFilter Members


Value1 Property | fcSDK Documentation

Value1 Property

Syntax

'Declaration

Public ReadOnly Property Value1 As Object

public object Value1 {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

BetweenFilter Class
BetweenFilter Members


Value1Present Property | fcSDK Documentation

Value1Present Property

Syntax

'Declaration

Public ReadOnly Property Value1Present As Boolean

public bool Value1Present {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

BetweenFilter Class
BetweenFilter Members


Value2 Property | fcSDK Documentation

Value2 Property

Syntax

'Declaration

Public ReadOnly Property Value2 As Object

public object Value2 {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

BetweenFilter Class
BetweenFilter Members


Value2Present Property | fcSDK Documentation

Value2Present Property

Syntax

'Declaration

Public ReadOnly Property Value2Present As Boolean

public bool Value2Present {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

BetweenFilter Class
BetweenFilter Members


ColumnBasedFilter Class | fcSDK Documentation

ColumnBasedFilter Class

Abstract filter type that maps to a column.

Syntax

'Declaration

Public MustInherit Class ColumnBasedFilter
   Inherits Filter

public abstract class ColumnBasedFilter : Filter

Example

Developer Walkthrough - Advanced Filtering

Inheritance Hierarchy

System.Object FChoice.Foundation.Filters.Filter FChoice.Foundation.Filters.ColumnBasedFilter FChoice.Foundation.Filters.BetweenFilter FChoice.Foundation.Filters.IsInFilter FChoice.Foundation.Filters.IsNullFilter FChoice.Foundation.Filters.OperationFilter FChoice.Foundation.Filters.SoundsLikeFilter

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ColumnBasedFilter Members FChoice.Foundation.Filters Namespace](FChoice.Foundation.Filters.ColumnBasedFilter** FChoice.Foundation.Filters.BetweenFilter FChoice.Foundation.Filters.IsInFilter FChoice.Foundation.Filters.IsNullFilter FChoice.Foundation.Filters.OperationFilter FChoice.Foundation.Filters.SoundsLikeFilter

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ColumnBasedFilter Members FChoice.Foundation.Filters Namespace


ColumnBasedFilter Class Members | fcSDK Documentation

ColumnBasedFilter Class Members

The following tables list the members exposed by ColumnBasedFilter.

Public Properties

 | Name | Description
Public Property | ColumnName |

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

ColumnBasedFilter Class
FChoice.Foundation.Filters Namespace


ColumnName Property | fcSDK Documentation

ColumnName Property

Syntax

'Declaration

Public ReadOnly Property ColumnName As String

public string ColumnName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ColumnBasedFilter Class
ColumnBasedFilter Members


ContainsFilter Class | fcSDK Documentation

ContainsFilter Class

Filter field on strings that contain the input to this filter

Syntax

'Declaration

Public Class ContainsFilter
   Inherits LikeFilter

public class ContainsFilter : LikeFilter

Example

Developer Walkthrough - Advanced Filtering

Inheritance Hierarchy

System.Object
FChoice.Foundation.Filters.Filter
FChoice.Foundation.Filters.ColumnBasedFilter
FChoice.Foundation.Filters.OperationFilter
FChoice.Foundation.Filters.LikeFilter
FChoice.Foundation.Filters.ContainsFilter

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ContainsFilter Members
FChoice.Foundation.Filters Namespace


ContainsFilter Class Members | fcSDK Documentation

ContainsFilter Class Members

The following tables list the members exposed by ContainsFilter.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | Operator | (Inherited from FChoice.Foundation.Filters.LikeFilter)
Public Property | Value | (Inherited from FChoice.Foundation.Filters.OperationFilter)

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

ContainsFilter Class
FChoice.Foundation.Filters Namespace


EndsWithFilter Class | fcSDK Documentation

EndsWithFilter Class

Filter on strings that end with the input to this filter

Syntax

'Declaration

Public Class EndsWithFilter
   Inherits LikeFilter

public class EndsWithFilter : LikeFilter

Example

Developer Walkthrough - Advanced Filtering

Inheritance Hierarchy

System.Object
FChoice.Foundation.Filters.Filter
FChoice.Foundation.Filters.ColumnBasedFilter
FChoice.Foundation.Filters.OperationFilter
FChoice.Foundation.Filters.LikeFilter
FChoice.Foundation.Filters.EndsWithFilter

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

EndsWithFilter Members
FChoice.Foundation.Filters Namespace


EndsWithFilter Class Members | fcSDK Documentation

EndsWithFilter Class Members

The following tables list the members exposed by EndsWithFilter.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | Operator | (Inherited from FChoice.Foundation.Filters.LikeFilter)
Public Property | Value | (Inherited from FChoice.Foundation.Filters.OperationFilter)

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

EndsWithFilter Class
FChoice.Foundation.Filters Namespace


EqualsFilter Class | fcSDK Documentation

EqualsFilter Class

Filter field on data that equals the input to this filter

Syntax

'Declaration

Public Class EqualsFilter
   Inherits OperationFilter

public class EqualsFilter : OperationFilter

Example

Developer Walkthrough - Advanced Filtering

Inheritance Hierarchy

System.Object
FChoice.Foundation.Filters.Filter
FChoice.Foundation.Filters.ColumnBasedFilter
FChoice.Foundation.Filters.OperationFilter
FChoice.Foundation.Filters.EqualsFilter

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

EqualsFilter Members
FChoice.Foundation.Filters Namespace


EqualsFilter Class Members | fcSDK Documentation

EqualsFilter Class Members

The following tables list the members exposed by EqualsFilter.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | Operator | Overridden.
Public Property | Value | (Inherited from FChoice.Foundation.Filters.OperationFilter)

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

EqualsFilter Class
FChoice.Foundation.Filters Namespace


Operator Property (EqualsFilter) | fcSDK Documentation

Operator Property (EqualsFilter)

Syntax

'Declaration

Public Overrides ReadOnly Property Operator As String

public override string Operator {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

EqualsFilter Class
EqualsFilter Members
Base Implementation in Operator


Filter Class | fcSDK Documentation

Filter Class

Abstract base of all filters.

Syntax

'Declaration

Public MustInherit Class Filter

public abstract class Filter

Example

Developer Walkthrough - Advanced Filtering

Inheritance Hierarchy

System.Object
FChoice.Foundation.Filters.Filter
FChoice.Foundation.Filters.ColumnBasedFilter
FChoice.Foundation.Filters.LogicalFilter

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

Filter Members
FChoice.Foundation.Filters Namespace


Filter Class Members | fcSDK Documentation

Filter Class Members

The following tables list the members exposed by Filter.

Public Methods

 | Name | Description
Public Method | Render |
Public Method | ValidateFilter |

Reference

Filter Class
FChoice.Foundation.Filters Namespace


Render Method | fcSDK Documentation

Render Method

Syntax

'Declaration

Public Overridable Function Render( _
   ByVal _fcSession_ As FCSession, _
   ByVal _gen_ As FCGeneric, _
   ByVal _dbHelper_ As SqlHelper _
) As String

public virtual string Render(
   FCSession _fcSession_,
   FCGeneric _gen_,
   SqlHelper _dbHelper_
)

Parameters

fcSession

gen

dbHelper

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Filter Class
Filter Members


ValidateFilter Method | fcSDK Documentation

ValidateFilter Method

Syntax

'Declaration

Public Overridable Sub ValidateFilter( _
   ByVal _fcSession_ As FCSession, _
   ByVal _gen_ As FCGeneric _
)

public virtual void ValidateFilter(
   FCSession _fcSession_,
   FCGeneric _gen_
)

Parameters

fcSession

gen

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Filter Class
Filter Members


FilterCollection Class | fcSDK Documentation

FilterCollection Class

Holds one or more filters. This collection is used by filters that allow children such as OrFilter and AndFilter

Syntax

'Declaration

Public Class FilterCollection
   Inherits System.Collections.ObjectModel.Collection(Of Filter)

public class FilterCollection : System.Collections.ObjectModel.Collection<Filter>

Example

Developer Walkthrough - Advanced Filtering

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection
FChoice.Foundation.Filters.FilterCollection

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FilterCollection Members
FChoice.Foundation.Filters Namespace


FilterCollection Class Members | fcSDK Documentation

FilterCollection Class Members

The following tables list the members exposed by FilterCollection.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection)

Public Methods

 | Name | Description
Public Method | Add |
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | Contains |
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection)

Reference

FilterCollection Class
FChoice.Foundation.Filters Namespace


Add Method (FilterCollection) | fcSDK Documentation

Add Method (FilterCollection)

Syntax

'Declaration

Public Shadows Function Add( _
   ByVal _filter_ As Filter _
) As Filter

public new Filter Add(
   Filter _filter_
)

Parameters

filter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterCollection Class
FilterCollection Members


Contains Method (FilterCollection) | fcSDK Documentation

Contains Method (FilterCollection)

Syntax

'Declaration

Public Shadows Function Contains( _
   ByVal _filter_ As Filter _
) As Boolean

public new bool Contains(
   Filter _filter_
)

Parameters

filter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterCollection Class
FilterCollection Members


FilterExpression Class | fcSDK Documentation

FilterExpression Class

Filter expressions offer on non static alternative to FilterType for construction of Filter objects.

Syntax

'Declaration

Public Class FilterExpression

public class FilterExpression

Inheritance Hierarchy

System.Object
FChoice.Foundation.Filters.FilterExpression

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FilterExpression Members
FChoice.Foundation.Filters Namespace


FilterExpression Class Members | fcSDK Documentation

FilterExpression Class Members

The following tables list the members exposed by FilterExpression.

Public Constructors

 | Name | Description
Public Constructor | FilterExpression Constructor |

Public Methods

 | Name | Description
Public Method | After |
Public Method | And | Overloaded.
Public Method | Before |
Public Method | Between | Overloaded.
Public Method | Contains |
Public Method | EndsWith |
Public Method | Equals | Overloaded.
Public Method | IsIn | Overloaded.
Public Method | IsNotIn | Overloaded.
Public Method | IsNotNull |
Public Method | IsNull |
Public Method | LessThan | Overloaded.
Public Method | LessThanOrEqual | Overloaded.
Public Method | Like |
Public Method | MoreThan | Overloaded.
Public Method | MoreThanOrEqual | Overloaded.
Public Method | NotBetween | Overloaded.
Public Method | NotContains |
Public Method | NotEndsWith |
Public Method | NotEqual | Overloaded.
Public Method | NotLike |
Public Method | NotStartsWith |
Public Method | OlderThanDays | Overloaded.
Public Method | OlderThanHours | Overloaded.
Public Method | On |
Public Method | Or | Overloaded.
Public Method | SoundsLike |
Public Method | StartsWith |
Public Method | Today |
Public Method | Tomorrow |
Public Method | WithinDays | Overloaded.
Public Method | WithinHours | Overloaded.
Public Method | Yesterday |

Reference

FilterExpression Class
FChoice.Foundation.Filters Namespace


FilterExpression Constructor | fcSDK Documentation

FilterExpression Constructor

Syntax

'Declaration

Public Function New()

public FilterExpression()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members


After Method (FilterExpression) | fcSDK Documentation

After Method (FilterExpression)

Syntax

'Declaration

Public Function After( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Date _
) As AfterFilter

public AfterFilter After(
   string _columnName_,
   DateTime _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members


And Method (FilterExpression) | fcSDK Documentation

And Method (FilterExpression)

Overload List

Overload | Description
And(Filter,Filter) |
And(Filter[]) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members


And(Filter,Filter) Method | fcSDK Documentation

And(Filter,Filter) Method

Syntax

'Declaration

Public Overloads Function And( _
   ByVal _filter1_ As Filter, _
   ByVal _filter2_ As Filter _
) As AndFilter

public AndFilter And(
   Filter _filter1_,
   Filter _filter2_
)

Parameters

filter1

filter2

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


And(Filter[]) Method | fcSDK Documentation

And(Filter[]) Method

Syntax

'Declaration

Public Overloads Function And( _
   ByVal ParamArray _filters_() As Filter _
) As AndManyFilter

public AndManyFilter And(
   params Filter\[\] _filters_
)

Parameters

filters

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


Before Method (FilterExpression) | fcSDK Documentation

Before Method (FilterExpression)

Syntax

'Declaration

Public Function Before( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Date _
) As BeforeFilter

public BeforeFilter Before(
   string _columnName_,
   DateTime _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members


Between Method (FilterExpression) | fcSDK Documentation

Between Method (FilterExpression)

Overload List

Overload | Description
Between(String,Int32,Int32) |
Between(String,Decimal,Decimal) |
Between(String,String,String) |
Between(String,DateTime,DateTime) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members


Between(String,Int32,Int32) Method | fcSDK Documentation

Between(String,Int32,Int32) Method

Syntax

'Declaration

Public Overloads Function Between( _
   ByVal _columnName_ As String, _
   ByVal _value1_ As Integer, _
   ByVal _value2_ As Integer _
) As BetweenFilter

public BetweenFilter Between(
   string _columnName_,
   int _value1_,
   int _value2_
)

Parameters

columnName

value1

value2

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


Between(String,Decimal,Decimal) Method | fcSDK Documentation

Between(String,Decimal,Decimal) Method

Syntax

'Declaration

Public Overloads Function Between( _
   ByVal _columnName_ As String, _
   ByVal _value1_ As Decimal, _
   ByVal _value2_ As Decimal _
) As BetweenFilter

public BetweenFilter Between(
   string _columnName_,
   decimal _value1_,
   decimal _value2_
)

Parameters

columnName

value1

value2

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


Between(String,String,String) Method | fcSDK Documentation

Between(String,String,String) Method

Syntax

'Declaration

Public Overloads Function Between( _
   ByVal _columnName_ As String, _
   ByVal _value1_ As String, _
   ByVal _value2_ As String _
) As BetweenFilter

public BetweenFilter Between(
   string _columnName_,
   string _value1_,
   string _value2_
)

Parameters

columnName

value1

value2

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


Between(String,DateTime,DateTime) Method | fcSDK Documentation

Between(String,DateTime,DateTime) Method

Syntax

'Declaration

Public Overloads Function Between( _
   ByVal _columnName_ As String, _
   ByVal _value1_ As Date, _
   ByVal _value2_ As Date _
) As BetweenFilter

public BetweenFilter Between(
   string _columnName_,
   DateTime _value1_,
   DateTime _value2_
)

Parameters

columnName

value1

value2

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


Contains Method (FilterExpression) | fcSDK Documentation

Contains Method (FilterExpression)

Syntax

'Declaration

Public Function Contains( _
   ByVal _columnName_ As String, _
   ByVal _value_ As String _
) As ContainsFilter

public ContainsFilter Contains(
   string _columnName_,
   string _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members


EndsWith Method (FilterExpression) | fcSDK Documentation

EndsWith Method (FilterExpression)

Syntax

'Declaration

Public Function EndsWith( _
   ByVal _columnName_ As String, _
   ByVal _value_ As String _
) As EndsWithFilter

public EndsWithFilter EndsWith(
   string _columnName_,
   string _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members


Equals Method (FilterExpression) | fcSDK Documentation

Equals Method (FilterExpression)

Overload List

Overload | Description
Equals(String,Boolean) |
Equals(String,Int32) |
Equals(String,Decimal) |
Equals(String,String) |
Equals(String,DateTime) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members


Equals(String,Boolean) Method | fcSDK Documentation

Equals(String,Boolean) Method

Syntax

'Declaration

Public Overloads Function Equals( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Boolean _
) As EqualsFilter

public EqualsFilter Equals(
   string _columnName_,
   bool _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


Equals(String,Int32) Method | fcSDK Documentation

Equals(String,Int32) Method

Syntax

'Declaration

Public Overloads Function Equals( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Integer _
) As EqualsFilter

public EqualsFilter Equals(
   string _columnName_,
   int _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


Equals(String,Decimal) Method | fcSDK Documentation

Equals(String,Decimal) Method

Syntax

'Declaration

Public Overloads Function Equals( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Decimal _
) As EqualsFilter

public EqualsFilter Equals(
   string _columnName_,
   decimal _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


Equals(String,String) Method | fcSDK Documentation

Equals(String,String) Method

Syntax

'Declaration

Public Overloads Function Equals( _
   ByVal _columnName_ As String, _
   ByVal _value_ As String _
) As EqualsFilter

public EqualsFilter Equals(
   string _columnName_,
   string _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


Equals(String,DateTime) Method | fcSDK Documentation

Equals(String,DateTime) Method

Syntax

'Declaration

Public Overloads Function Equals( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Date _
) As EqualsFilter

public EqualsFilter Equals(
   string _columnName_,
   DateTime _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


IsIn Method (FilterExpression) | fcSDK Documentation

IsIn Method (FilterExpression)

Overload List

Overload | Description
IsIn(String,Int32[]) |
IsIn(String,Decimal[]) |
IsIn(String,String[]) |
IsIn(String,DateTime[]) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members


IsIn(String,Int32[]) Method | fcSDK Documentation

IsIn(String,Int32[]) Method

Syntax

'Declaration

Public Overloads Function IsIn( _
   ByVal _columnName_ As String, _
   ByVal ParamArray _values_() As Integer _
) As IsInFilter

public IsInFilter IsIn(
   string _columnName_,
   params int\[\] _values_
)

Parameters

columnName

values

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


IsIn(String,Decimal[]) Method | fcSDK Documentation

IsIn(String,Decimal[]) Method

Syntax

'Declaration

Public Overloads Function IsIn( _
   ByVal _columnName_ As String, _
   ByVal ParamArray _values_() As Decimal _
) As IsInFilter

public IsInFilter IsIn(
   string _columnName_,
   params decimal[] _values_
)

Parameters

columnName

values

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


IsIn(String,String[]) Method | fcSDK Documentation

IsIn(String,String[]) Method

Syntax

'Declaration

Public Overloads Function IsIn( _
   ByVal _columnName_ As String, _
   ByVal ParamArray _values_() As String _
) As IsInFilter

public IsInFilter IsIn(
   string _columnName_,
   params string[] _values_
)

Parameters

columnName

values

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class FilterExpression Members
Overload List


IsIn(String,DateTime[]) Method | fcSDK Documentation

IsIn(String,DateTime[]) Method

Syntax

'Declaration

Public Overloads Function IsIn( _
   ByVal _columnName_ As String, _
   ByVal ParamArray _values_() As Date _
) As IsInFilter

public IsInFilter IsIn(
   string _columnName_,
   params DateTime\[\] _values_
)

Parameters

columnName

values

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


IsNotIn Method (FilterExpression) | fcSDK Documentation

IsNotIn Method (FilterExpression)

Overload List

Overload | Description
IsNotIn(String,Int32[]) |
IsNotIn(String,Decimal[]) |
IsNotIn(String,String[]) |
IsNotIn(String,DateTime[]) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members


IsNotIn(String,Int32[]) Method | fcSDK Documentation

IsNotIn(String,Int32[]) Method

Syntax

'Declaration

Public Overloads Function IsNotIn( _
   ByVal _columnName_ As String, _
   ByVal ParamArray _values_() As Integer _
) As IsInFilter

public IsInFilter IsNotIn(
   string _columnName_,
   params int\[\] _values_
)

Parameters

columnName

values

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


IsNotIn(String,Decimal[]) Method | fcSDK Documentation

IsNotIn(String,Decimal[]) Method

Syntax

'Declaration

Public Overloads Function IsNotIn( _
   ByVal _columnName_ As String, _
   ByVal ParamArray _values_() As Decimal _
) As IsInFilter

public IsInFilter IsNotIn(
   string _columnName_,
   params decimal\[\] _values_
)

Parameters

columnName

values

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


IsNotIn(String,String[]) Method | fcSDK Documentation

IsNotIn(String,String[]) Method

Syntax

'Declaration

Public Overloads Function IsNotIn( _
   ByVal _columnName_ As String, _
   ByVal ParamArray _values_() As String _
) As IsInFilter

public IsInFilter IsNotIn(
   string _columnName_,
   params string[] _values_
)

Parameters

columnName

values

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class FilterExpression Members
Overload List


IsNotIn(String,DateTime[]) Method | fcSDK Documentation

IsNotIn(String,DateTime[]) Method

Syntax

'Declaration

Public Overloads Function IsNotIn( _
   ByVal _columnName_ As String, _
   ByVal ParamArray _values_() As Date _
) As IsInFilter

public IsInFilter IsNotIn(
   string _columnName_,
   params DateTime\[\] _values_
)

Parameters

columnName

values

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


IsNotNull Method (FilterExpression) | fcSDK Documentation

IsNotNull Method (FilterExpression)

Syntax

'Declaration

Public Function IsNotNull( _
   ByVal _columnName_ As String _
) As IsNullFilter

public IsNullFilter IsNotNull(
   string _columnName_
)

Parameters

columnName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members


IsNull Method (FilterExpression) | fcSDK Documentation

IsNull Method (FilterExpression)

Syntax

'Declaration

Public Function IsNull( _
   ByVal _columnName_ As String _
) As IsNullFilter

public IsNullFilter IsNull(
   string _columnName_
)

Parameters

columnName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members


LessThan Method (FilterExpression) | fcSDK Documentation

LessThan Method (FilterExpression)

Overload List

Overload | Description
LessThan(String,Int32) |
LessThan(String,Decimal) |
LessThan(String,String) |
LessThan(String,DateTime) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members


LessThan(String,Int32) Method | fcSDK Documentation

LessThan(String,Int32) Method

Syntax

'Declaration

Public Overloads Function LessThan( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Integer _
) As LessThanFilter

public LessThanFilter LessThan(
   string _columnName_,
   int _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


LessThan(String,Decimal) Method | fcSDK Documentation

LessThan(String,Decimal) Method

Syntax

'Declaration

Public Overloads Function LessThan( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Decimal _
) As LessThanFilter

public LessThanFilter LessThan(
   string _columnName_,
   decimal _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


LessThan(String,String) Method | fcSDK Documentation

LessThan(String,String) Method

Syntax

'Declaration

Public Overloads Function LessThan( _
   ByVal _columnName_ As String, _
   ByVal _value_ As String _
) As LessThanFilter

public LessThanFilter LessThan(
   string _columnName_,
   string _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


LessThan(String,DateTime) Method | fcSDK Documentation

LessThan(String,DateTime) Method

Syntax

'Declaration

Public Overloads Function LessThan( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Date _
) As LessThanFilter

public LessThanFilter LessThan(
   string _columnName_,
   DateTime _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


LessThanOrEqual Method (FilterExpression) | fcSDK Documentation

LessThanOrEqual Method (FilterExpression)

Overload List

Overload | Description
LessThanOrEqual(String,Int32) |
LessThanOrEqual(String,Decimal) |
LessThanOrEqual(String,String) |
LessThanOrEqual(String,DateTime) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members


LessThanOrEqual(String,Int32) Method | fcSDK Documentation

LessThanOrEqual(String,Int32) Method

Syntax

'Declaration

Public Overloads Function LessThanOrEqual( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Integer _
) As LessThanOrEqualFilter

public LessThanOrEqualFilter LessThanOrEqual(
   string _columnName_,
   int _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


LessThanOrEqual(String,Decimal) Method | fcSDK Documentation

LessThanOrEqual(String,Decimal) Method

Syntax

'Declaration

Public Overloads Function LessThanOrEqual( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Decimal _
) As LessThanOrEqualFilter

public LessThanOrEqualFilter LessThanOrEqual(
   string _columnName_,
   decimal _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


LessThanOrEqual(String,String) Method | fcSDK Documentation

LessThanOrEqual(String,String) Method

Syntax

'Declaration

Public Overloads Function LessThanOrEqual( _
   ByVal _columnName_ As String, _
   ByVal _value_ As String _
) As Filter

public Filter LessThanOrEqual(
   string _columnName_,
   string _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


LessThanOrEqual(String,DateTime) Method | fcSDK Documentation

LessThanOrEqual(String,DateTime) Method

Syntax

'Declaration

Public Overloads Function LessThanOrEqual( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Date _
) As Filter

public Filter LessThanOrEqual(
   string _columnName_,
   DateTime _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


Like Method (FilterExpression) | fcSDK Documentation

Like Method (FilterExpression)

Syntax

'Declaration

Public Function Like( _
   ByVal _columnName_ As String, _
   ByVal _value_ As String _
) As LikeFilter

public LikeFilter Like(
   string _columnName_,
   string _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members


MoreThan Method (FilterExpression) | fcSDK Documentation

MoreThan Method (FilterExpression)

Overload List

Overload | Description
MoreThan(String,Int32) |
MoreThan(String,Decimal) |
MoreThan(String,String) |
MoreThan(String,DateTime) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members


MoreThan(String,Int32) Method | fcSDK Documentation

MoreThan(String,Int32) Method

Syntax

'Declaration

Public Overloads Function MoreThan( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Integer _
) As MoreThanFilter

public MoreThanFilter MoreThan(
   string _columnName_,
   int _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


MoreThan(String,Decimal) Method | fcSDK Documentation

MoreThan(String,Decimal) Method

Syntax

'Declaration

Public Overloads Function MoreThan( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Decimal _
) As MoreThanFilter

public MoreThanFilter MoreThan(
   string _columnName_,
   decimal _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


MoreThan(String,String) Method | fcSDK Documentation

MoreThan(String,String) Method

Syntax

'Declaration

Public Overloads Function MoreThan( _
   ByVal _columnName_ As String, _
   ByVal _value_ As String _
) As MoreThanFilter

public MoreThanFilter MoreThan(
   string _columnName_,
   string _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


MoreThan(String,DateTime) Method | fcSDK Documentation

MoreThan(String,DateTime) Method

Syntax

'Declaration

Public Overloads Function MoreThan( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Date _
) As MoreThanFilter

public MoreThanFilter MoreThan(
   string _columnName_,
   DateTime _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


MoreThanOrEqual Method (FilterExpression) | fcSDK Documentation

MoreThanOrEqual Method (FilterExpression)

Overload List

Overload | Description
MoreThanOrEqual(String,Int32) |
MoreThanOrEqual(String,Decimal) |
MoreThanOrEqual(String,String) |
MoreThanOrEqual(String,DateTime) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members


MoreThanOrEqual(String,Int32) Method | fcSDK Documentation

MoreThanOrEqual(String,Int32) Method

Syntax

'Declaration

Public Overloads Function MoreThanOrEqual( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Integer _
) As MoreThanOrEqualFilter

public MoreThanOrEqualFilter MoreThanOrEqual(
   string _columnName_,
   int _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


MoreThanOrEqual(String,Decimal) Method | fcSDK Documentation

MoreThanOrEqual(String,Decimal) Method

Syntax

'Declaration

Public Overloads Function MoreThanOrEqual( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Decimal _
) As MoreThanOrEqualFilter

public MoreThanOrEqualFilter MoreThanOrEqual(
   string _columnName_,
   decimal _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


MoreThanOrEqual(String,String) Method | fcSDK Documentation

MoreThanOrEqual(String,String) Method

Syntax

'Declaration

Public Overloads Function MoreThanOrEqual( _
   ByVal _columnName_ As String, _
   ByVal _value_ As String _
) As MoreThanOrEqualFilter

public MoreThanOrEqualFilter MoreThanOrEqual(
   string _columnName_,
   string _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


MoreThanOrEqual(String,DateTime) Method | fcSDK Documentation

MoreThanOrEqual(String,DateTime) Method

Syntax

'Declaration

Public Overloads Function MoreThanOrEqual( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Date _
) As MoreThanOrEqualFilter

public MoreThanOrEqualFilter MoreThanOrEqual(
   string _columnName_,
   DateTime _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


NotBetween Method (FilterExpression) | fcSDK Documentation

NotBetween Method (FilterExpression)

Overload List

Overload | Description
NotBetween(String,Int32,Int32) |
NotBetween(String,Decimal,Decimal) |
NotBetween(String,String,String) |
NotBetween(String,DateTime,DateTime) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members


NotBetween(String,Int32,Int32) Method | fcSDK Documentation

NotBetween(String,Int32,Int32) Method

Syntax

'Declaration

Public Overloads Function NotBetween( _
   ByVal _columnName_ As String, _
   ByVal _value1_ As Integer, _
   ByVal _value2_ As Integer _
) As BetweenFilter

public BetweenFilter NotBetween(
   string _columnName_,
   int _value1_,
   int _value2_
)

Parameters

columnName

value1

value2

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


NotBetween(String,Decimal,Decimal) Method | fcSDK Documentation

NotBetween(String,Decimal,Decimal) Method

Syntax

'Declaration

Public Overloads Function NotBetween( _
   ByVal _columnName_ As String, _
   ByVal _value1_ As Decimal, _
   ByVal _value2_ As Decimal _
) As BetweenFilter

public BetweenFilter NotBetween(
   string _columnName_,
   decimal _value1_,
   decimal _value2_
)

Parameters

columnName

value1

value2

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


NotBetween(String,String,String) Method | fcSDK Documentation

NotBetween(String,String,String) Method

Syntax

'Declaration

Public Overloads Function NotBetween( _
   ByVal _columnName_ As String, _
   ByVal _value1_ As String, _
   ByVal _value2_ As String _
) As BetweenFilter

public BetweenFilter NotBetween(
   string _columnName_,
   string _value1_,
   string _value2_
)

Parameters

columnName

value1

value2

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


NotBetween(String,DateTime,DateTime) Method | fcSDK Documentation

NotBetween(String,DateTime,DateTime) Method

Syntax

'Declaration

Public Overloads Function NotBetween( _
   ByVal _columnName_ As String, _
   ByVal _value1_ As Date, _
   ByVal _value2_ As Date _
) As BetweenFilter

public BetweenFilter NotBetween(
   string _columnName_,
   DateTime _value1_,
   DateTime _value2_
)

Parameters

columnName

value1

value2

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


NotContains Method (FilterExpression) | fcSDK Documentation

NotContains Method (FilterExpression)

Syntax

'Declaration

Public Function NotContains( _
   ByVal _columnName_ As String, _
   ByVal _value_ As String _
) As NotContainsFilter

public NotContainsFilter NotContains(
   string _columnName_,
   string _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members


NotEndsWith Method (FilterExpression) | fcSDK Documentation

NotEndsWith Method (FilterExpression)

Syntax

'Declaration

Public Function NotEndsWith( _
   ByVal _columnName_ As String, _
   ByVal _value_ As String _
) As NotEndsWithFilter

public NotEndsWithFilter NotEndsWith(
   string _columnName_,
   string _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members


NotEqual Method (FilterExpression) | fcSDK Documentation

NotEqual Method (FilterExpression)

Overload List

Overload | Description
NotEqual(String,Boolean) |
NotEqual(String,Int32) |
NotEqual(String,Decimal) |
NotEqual(String,String) |
NotEqual(String,DateTime) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members


NotEqual(String,Boolean) Method | fcSDK Documentation

NotEqual(String,Boolean) Method

Syntax

'Declaration

Public Overloads Function NotEqual( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Boolean _
) As EqualsFilter

public EqualsFilter NotEqual(
   string _columnName_,
   bool _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


NotEqual(String,Int32) Method | fcSDK Documentation

NotEqual(String,Int32) Method

Syntax

'Declaration

Public Overloads Function NotEqual( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Integer _
) As EqualsFilter

public EqualsFilter NotEqual(
   string _columnName_,
   int _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


NotEqual(String,Decimal) Method | fcSDK Documentation

NotEqual(String,Decimal) Method

Syntax

'Declaration

Public Overloads Function NotEqual( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Decimal _
) As Filter

public Filter NotEqual(
   string _columnName_,
   decimal _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


NotEqual(String,String) Method | fcSDK Documentation

NotEqual(String,String) Method

Syntax

'Declaration

Public Overloads Function NotEqual( _
   ByVal _columnName_ As String, _
   ByVal _value_ As String _
) As Filter

public Filter NotEqual(
   string _columnName_,
   string _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


NotEqual(String,DateTime) Method | fcSDK Documentation

NotEqual(String,DateTime) Method

Syntax

'Declaration

Public Overloads Function NotEqual( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Date _
) As Filter

public Filter NotEqual(
   string _columnName_,
   DateTime _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


NotLike Method (FilterExpression) | fcSDK Documentation

NotLike Method (FilterExpression)

Syntax

'Declaration

Public Function NotLike( _
   ByVal _columnName_ As String, _
   ByVal _value_ As String _
) As NotLikeFilter

public NotLikeFilter NotLike(
   string _columnName_,
   string _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members


NotStartsWith Method (FilterExpression) | fcSDK Documentation

NotStartsWith Method (FilterExpression)

Syntax

'Declaration

Public Function NotStartsWith( _
   ByVal _columnName_ As String, _
   ByVal _value_ As String _
) As NotStartsWithFilter

public NotStartsWithFilter NotStartsWith(
   string _columnName_,
   string _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members


OlderThanDays Method (FilterExpression) | fcSDK Documentation

OlderThanDays Method (FilterExpression)

Overload List

Overload | Description
OlderThanDays(String,Int32) |
OlderThanDays(String,Decimal) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members


OlderThanDays(String,Int32) Method | fcSDK Documentation

OlderThanDays(String,Int32) Method

Syntax

'Declaration

Public Overloads Function OlderThanDays( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Integer _
) As OlderThanDaysFilter
``

```csharp
public OlderThanDaysFilter OlderThanDays(
   string _columnName_,
   int _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


OlderThanDays(String,Decimal) Method | fcSDK Documentation

OlderThanDays(String,Decimal) Method

Syntax

'Declaration

Public Overloads Function OlderThanDays( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Decimal _
) As OlderThanDaysFilter

public OlderThanDaysFilter OlderThanDays(
   string _columnName_,
   decimal _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


OlderThanHours Method (FilterExpression) | fcSDK Documentation

OlderThanHours Method (FilterExpression)

Overload List

Overload | Description
OlderThanHours(String,Int32) |
OlderThanHours(String,Decimal) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members


OlderThanHours(String,Int32) Method | fcSDK Documentation

OlderThanHours(String,Int32) Method

Syntax

'Declaration

Public Overloads Function OlderThanHours( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Integer _
) As OlderThanHoursFilter

public OlderThanHoursFilter OlderThanHours(
   string _columnName_,
   int _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


OlderThanHours(String,Decimal) Method | fcSDK Documentation

OlderThanHours(String,Decimal) Method

Syntax

'Declaration

Public Overloads Function OlderThanHours( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Decimal _
) As OlderThanHoursFilter

public OlderThanHoursFilter OlderThanHours(
   string _columnName_,
   decimal _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


On Method (FilterExpression) | fcSDK Documentation

On Method (FilterExpression)

Syntax

'Declaration

Public Function On( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Date _
) As OnFilter

public OnFilter On(
   string _columnName_,
   DateTime _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members


Or Method (FilterExpression) | fcSDK Documentation

Or Method (FilterExpression)

Overload List

Overload | Description
Or(Filter,Filter) |
Or(Filter[]) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members


Or(Filter,Filter) Method | fcSDK Documentation

Or(Filter,Filter) Method

Syntax

'Declaration

Public Overloads Function Or( _
   ByVal _filter1_ As Filter, _
   ByVal _filter2_ As Filter _
) As OrFilter

public OrFilter Or(
   Filter _filter1_,
   Filter _filter2_
)

Parameters

filter1

filter2

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


Or(Filter[]) Method | fcSDK Documentation

Or(Filter[]) Method

Syntax

'Declaration

Public Overloads Function Or( _
   ByVal ParamArray _filters_() As Filter _
) As OrManyFilter

public OrManyFilter Or(
   params Filter\[\] _filters_
)

Parameters

filters

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


SoundsLike Method (FilterExpression) | fcSDK Documentation

SoundsLike Method (FilterExpression)

Syntax

'Declaration

Public Function SoundsLike( _
   ByVal _columnName_ As String, _
   ByVal _value_ As String _
) As SoundsLikeFilter

public SoundsLikeFilter SoundsLike(
   string _columnName_,
   string _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members


StartsWith Method (FilterExpression) | fcSDK Documentation

StartsWith Method (FilterExpression)

Syntax

'Declaration

Public Function StartsWith( _
   ByVal _columnName_ As String, _
   ByVal _value_ As String _
) As StartsWithFilter

public StartsWithFilter StartsWith(
   string _columnName_,
   string _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members


Today Method (FilterExpression) | fcSDK Documentation

Today Method (FilterExpression)

Syntax

'Declaration

Public Function Today( _
   ByVal _columnName_ As String _
) As TodayFilter

public TodayFilter Today(
   string _columnName_
)

Parameters

columnName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members


Tomorrow Method (FilterExpression) | fcSDK Documentation

Tomorrow Method (FilterExpression)

Syntax

'Declaration

Public Function Tomorrow( _
   ByVal _columnName_ As String _
) As TomorrowFilter

public TomorrowFilter Tomorrow(
   string _columnName_
)

Parameters

columnName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members


WithinDays Method (FilterExpression) | fcSDK Documentation

WithinDays Method (FilterExpression)

Overload List

Overload | Description
WithinDays(String,Int32) |
WithinDays(String,Decimal) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members


WithinDays(String,Int32) Method | fcSDK Documentation

WithinDays(String,Int32) Method

Syntax

'Declaration

Public Overloads Function WithinDays( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Integer _
) As WithinDaysFilter

public WithinDaysFilter WithinDays(
   string _columnName_,
   int _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


WithinDays(String,Decimal) Method | fcSDK Documentation

WithinDays(String,Decimal) Method

Syntax

'Declaration

Public Overloads Function WithinDays( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Decimal _
) As WithinDaysFilter

public WithinDaysFilter WithinDays(
   string _columnName_,
   decimal _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


WithinHours Method (FilterExpression) | fcSDK Documentation

WithinHours Method (FilterExpression)

Overload List

Overload | Description
WithinHours(String,Int32) |
WithinHours(String,Decimal) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members


WithinHours(String,Int32) Method | fcSDK Documentation

WithinHours(String,Int32) Method

Syntax

'Declaration

Public Overloads Function WithinHours( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Integer _
) WithinHoursFilter

public WithinHoursFilter WithinHours(
   string _columnName_,
   int _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


WithinHours(String,Decimal) Method | fcSDK Documentation

WithinHours(String,Decimal) Method

Syntax

'Declaration

Public Overloads Function WithinHours( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Decimal _
) As WithinHoursFilter

public WithinHoursFilter WithinHours(
   string _columnName_,
   decimal _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class
FilterExpression Members
Overload List


Yesterday Method (FilterExpression) | fcSDK Documentation

Yesterday Method (FilterExpression)

Syntax

'Declaration

Public Function Yesterday( _
   ByVal _columnName_ As String _
) As YesterdayFilter

public YesterdayFilter Yesterday(
   string _columnName_
)

Parameters

columnName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterExpression Class FilterExpression Members


FilterType Class | fcSDK Documentation

FilterType Class

This is a helper factory for creation of Filter objects.

Syntax

'Declaration

Public MustInherit NotInheritable Class FilterType

public static class FilterType

Example

Developer Walkthrough - Advanced Filtering

Inheritance Hierarchy

System.Object
FChoice.Foundation.Filters.FilterType

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FilterType Members
FChoice.Foundation.Filters Namespace


FilterType Class Members | fcSDK Documentation

FilterType Class Members

The following tables list the members exposed by FilterType.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | After | Filter field on dates coming after the input to this filter
static (Shared in Visual Basic) | And | Overloaded. Logical filter allowing 2 or more AND (inclusive) filters.
static (Shared in Visual Basic) | Before | Filter field on dates coming before the input to this filter
static (Shared in Visual Basic) | Between | Overloaded.
static (Shared in Visual Basic) | Contains | Filter field on strings that contain the input to this filter
static (Shared in Visual Basic) | EndsWith | Filter on strings that end with the input to this filter
static (Shared in Visual Basic) | Equals | Overloaded.
static (Shared in Visual Basic) | IsIn | Overloaded.
static (Shared in Visual Basic) | IsNotIn | Overloaded.
static (Shared in Visual Basic) | IsNotNull | Filter on fields that are not null
static (Shared in Visual Basic) | IsNull | Filter on fields that are null
static (Shared in Visual Basic) | LessThan | Overloaded.
static (Shared in Visual Basic) | LessThanOrEqual | Overloaded.
static (Shared in Visual Basic) | Like | Filter field on strings that are like the filter input
static (Shared in Visual Basic) | MoreThan | Overloaded.
static (Shared in Visual Basic) | MoreThanOrEqual | Overloaded.
static (Shared in Visual Basic) | NotBetween | Overloaded.
static (Shared in Visual Basic) | NotContains | Filter field on strings that do not contain the input to this filter
static (Shared in Visual Basic) | NotEndsWith | Filter field on strings that do end with the input to this filter
static (Shared in Visual Basic) | NotEqual | Overloaded.
static (Shared in Visual Basic) | NotLike | Filter field on strings that are not like the filter input
static (Shared in Visual Basic) | NotStartsWith | Filter field on strings that do start with the input to this filter
static (Shared in Visual Basic) | OlderThanDays | Overloaded.
static (Shared in Visual Basic) | OlderThanHours | Overloaded.
static (Shared in Visual Basic) | On | Filter field on dates occuring on the the input to this filter
static (Shared in Visual Basic) | Or | Overloaded. Logical filter allowing 2 or more OR (exclusive) filters.
static (Shared in Visual Basic) | SoundsLike | Filter field on strings sound like the input to this filter
static (Shared in Visual Basic) | StartsWith | Filter field on strings that start with the input to this filter
static (Shared in Visual Basic) | Today | Filter field on today's date
static (Shared in Visual Basic) | Tomorrow | Filter field on tomorrow's date
static (Shared in Visual Basic) | WithinDays | Overloaded.
static (Shared in Visual Basic) | WithinHours | Overloaded.
static (Shared in Visual Basic) | Yesterday | Filter field on yesterday's date

Reference

FilterType Class
FChoice.Foundation.Filters Namespace


After Method (FilterType) | fcSDK Documentation

After Method (FilterType)

Filter field on dates coming after the input to this filter

Syntax

'Declaration

Public Shared Function After( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Date _
) As AfterFilter

public static AfterFilter After(
   string _columnName_,
   DateTime _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members


And Method (FilterType) | fcSDK Documentation

And Method (FilterType)

Logical filter allowing 2 or more AND (inclusive) filters.

Overload List

Overload | Description
And(Filter,Filter) |
And(Filter[]) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members


And(Filter,Filter) Method | fcSDK Documentation

And(Filter,Filter) Method

Syntax

'Declaration

Public Overloads Shared Function And( _
   ByVal _filter1_ As Filter, _
   ByVal _filter2_ As Filter _
) As AndFilter

public static AndFilter And(
   Filter _filter1_,
   Filter _filter2_
)

Parameters

filter1

filter2

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


And(Filter[]) Method | fcSDK Documentation

And(Filter[]) Method

Syntax

'Declaration

Public Overloads Shared Function And( _
   ByVal ParamArray _filters_() As Filter _
) As AndManyFilter

public static AndManyFilter And(
   params Filter\[\] _filters_
)

Parameters

filters

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


Before Method (FilterType) | fcSDK Documentation

Before Method (FilterType)

Filter field on dates coming before the input to this filter

Syntax

'Declaration

Public Shared Function Before( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Date _
) As BeforeFilter

public static BeforeFilter Before(
   string _columnName_,
   DateTime _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members


Between Method (FilterType) | fcSDK Documentation

Between Method (FilterType)

Filter field for values that occur between the two filter inputs

Overload List

Overload | Description
Between(String,Int32,Int32) |
Between(String,Decimal,Decimal) |
Between(String,String,String) |
Between(String,DateTime,DateTime) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members


Between(String,Int32,Int32) Method | fcSDK Documentation

Between(String,Int32,Int32) Method

Syntax

'Declaration

Public Overloads Shared Function Between( _
   ByVal _columnName_ As String, _
   ByVal _value1_ As Integer, _
   ByVal _value2_ As Integer _
) As BetweenFilter

public static BetweenFilter Between(
   string _columnName_,
   int _value1_,
   int _value2_
)

Parameters

columnName

value1

value2

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


Between(String,Decimal,Decimal) Method | fcSDK Documentation

Between(String,Decimal,Decimal) Method

Syntax

'Declaration

Public Overloads Shared Function Between( _
   ByVal _columnName_ As String, _
   ByVal _value1_ As Decimal, _
   ByVal _value2_ As Decimal _
) As BetweenFilter

public static BetweenFilter Between(
   string _columnName_,
   decimal _value1_,
   decimal _value2_
)

Parameters

columnName

value1

value2

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


Between(String,String,String) Method | fcSDK Documentation

Between(String,String,String) Method

Syntax

'Declaration

Public Overloads Shared Function Between( _
   ByVal _columnName_ As String, _
   ByVal _value1_ As String, _
   ByVal _value2_ As String _
) As BetweenFilter

public static BetweenFilter Between(
   string _columnName_,
   string _value1_,
   string _value2_
)

Parameters

columnName

value1

value2

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


Between(String,DateTime,DateTime) Method | fcSDK Documentation

Between(String,DateTime,DateTime) Method

Syntax

'Declaration

Public Overloads Shared Function Between( _
   ByVal _columnName_ As String, _
   ByVal _value1_ As Date, _
   ByVal _value2_ As Date _
) As BetweenFilter

public static BetweenFilter Between(
   string _columnName_,
   DateTime _value1_,
   DateTime _value2_
)

Parameters

columnName

value1

value2

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


Contains Method (FilterType) | fcSDK Documentation

Contains Method (FilterType)

Filter field on strings that contain the input to this filter

Syntax

'Declaration

Public Shared Function Contains( _
   ByVal _columnName_ As String, _
   ByVal _value_ As String _
) As ContainsFilter

public static ContainsFilter Contains(
   string _columnName_,
   string _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members


EndsWith Method (FilterType) | fcSDK Documentation

EndsWith Method (FilterType)

Filter on strings that end with the input to this filter

Syntax

'Declaration

Public Shared Function EndsWith( _
   ByVal _columnName_ As String, _
   ByVal _value_ As String _
) As EndsWithFilter

public static EndsWithFilter EndsWith(
   string _columnName_,
   string _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members


Equals Method (FilterType) | fcSDK Documentation

Equals Method (FilterType)

Filter field on data that equals the input to this filter

Overload List

Overload | Description
Equals(String,Boolean) |
Equals(String,Int32) |
Equals(String,Decimal) |
Equals(String,String) |
Equals(String,DateTime) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members


Equals(String,Boolean) Method | fcSDK Documentation

Equals(String,Boolean) Method

Syntax

'Declaration

Public Overloads Shared Function Equals( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Boolean _
) As EqualsFilter

public static EqualsFilter Equals(
   string _columnName_,
   bool _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


Equals(String,Int32) Method | fcSDK Documentation

Equals(String,Int32) Method

Syntax

'Declaration

Public Overloads Shared Function Equals( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Integer _
) As EqualsFilter

public static EqualsFilter Equals(
   string _columnName_,
   int _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


Equals(String,Decimal) Method | fcSDK Documentation

Equals(String,Decimal) Method

Syntax

'Declaration

Public Overloads Shared Function Equals( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Decimal _
) As EqualsFilter

public static EqualsFilter Equals(
   string _columnName_,
   decimal _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


Equals(String,String) Method | fcSDK Documentation

Equals(String,String) Method

Syntax

'Declaration

Public Overloads Shared Function Equals( _
   ByVal _columnName_ As String, _
   ByVal _value_ As String _
) As EqualsFilter

public static EqualsFilter Equals(
   string _columnName_,
   string _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


Equals(String,DateTime) Method | fcSDK Documentation

Equals(String,DateTime) Method

Syntax

'Declaration

Public Overloads Shared Function Equals( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Date _
) As EqualsFilter

public static EqualsFilter Equals(
   string _columnName_,
   DateTime _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


IsIn Method (FilterType) | fcSDK Documentation

IsIn Method (FilterType)

Filter on fields that are in the input array

Overload List

Overload | Description
IsIn(String,Int32[]) |
IsIn(String,Decimal[]) |
IsIn(String,String[]) |
IsIn(String,DateTime[]) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members


IsIn(String,Int32[]) Method | fcSDK Documentation

IsIn(String,Int32[]) Method

Syntax

'Declaration

Public Overloads Shared Function IsIn( _
   ByVal _columnName_ As String, _
   ByVal ParamArray _values_() As Integer _
) As IsInFilter

public static IsInFilter IsIn(
   string _columnName_,
   params int\[\] _values_
)

Parameters

columnName

values

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


IsIn(String,Decimal[]) Method | fcSDK Documentation

IsIn(String,Decimal[]) Method

Syntax

'Declaration

Public Overloads Shared Function IsIn( _
   ByVal _columnName_ As String, _
   ByVal ParamArray _values_() As Decimal _
) As IsInFilter

public static IsInFilter IsIn(
   string _columnName_,
   params decimal\[\] _values_
)

Parameters

columnName

values

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


IsIn(String,String[]) Method | fcSDK Documentation

IsIn(String,String[]) Method

Syntax

'Declaration

Public Overloads Shared Function IsIn( _
   ByVal _columnName_ As String, _
   ByVal ParamArray _values_() As String _
) As IsInFilter

public static IsInFilter IsIn(
   string _columnName_,
   params string[] _values_
)

Parameters

columnName

values

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


IsIn(String,DateTime[]) Method | fcSDK Documentation

IsIn(String,DateTime[]) Method

Syntax

'Declaration

Public Overloads Shared Function IsIn( _
   ByVal _columnName_ As String, _
   ByVal ParamArray _values_() As Date _
) As IsInFilter

public static IsInFilter IsIn(
   string _columnName_,
   params DateTime\[\] _values_
)

Parameters

columnName

values

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


IsNotIn Method (FilterType) | fcSDK Documentation

IsNotIn Method (FilterType)

Filter on fields that are not in the input array

Overload List

Overload | Description
IsNotIn(String,Int32[]) |
IsNotIn(String,Decimal[]) |
IsNotIn(String,String[]) |
IsNotIn(String,DateTime[]) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members


IsNotIn(String,Int32[]) Method | fcSDK Documentation

IsNotIn(String,Int32[]) Method

Syntax

'Declaration

Public Overloads Shared Function IsNotIn( _
   ByVal _columnName_ As String, _
   ByVal ParamArray _values_() As Integer _
) As IsInFilter

public static IsInFilter IsNotIn(
   string _columnName_,
   params int\[\] _values_
)

Parameters

columnName

values

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


IsNotIn(String,Decimal[]) Method | fcSDK Documentation

IsNotIn(String,Decimal[]) Method

Syntax

'Declaration

Public Overloads Shared Function IsNotIn( _
   ByVal _columnName_ As String, _
   ByVal ParamArray _values_() As Decimal _
) As IsInFilter

public static IsInFilter IsNotIn(
   string _columnName_,
   params decimal\[\] _values_
)

Parameters

columnName

values

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


IsNotIn(String,String[]) Method | fcSDK Documentation

IsNotIn(String,String[]) Method

Syntax

'Declaration

Public Overloads Shared Function IsNotIn( _
   ByVal _columnName_ As String, _
   ByVal ParamArray _values_() As String _
) As IsInFilter

public static IsInFilter IsNotIn(string _columnName_, params string[] _values_)

Parameters

columnName

values

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


IsNotIn(String,DateTime[]) Method | fcSDK Documentation

IsNotIn(String,DateTime[]) Method

Syntax

'Declaration

Public Overloads Shared Function IsNotIn( _
   ByVal _columnName_ As String, _
   ByVal ParamArray _values_() As Date _
) As IsInFilter

public static IsInFilter IsNotIn(
   string _columnName_,
   params DateTime\[\] _values_
)

Parameters

columnName

values

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


IsNotNull Method (FilterType) | fcSDK Documentation

IsNotNull Method (FilterType)

Filter on fields that are not null

Syntax

'Declaration

Public Shared Function IsNotNull( _
   ByVal _columnName_ As String _
) As IsNullFilter

public static IsNullFilter IsNotNull(
   string _columnName_
)

Parameters

columnName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members


IsNull Method (FilterType) | fcSDK Documentation

IsNull Method (FilterType)

Filter on fields that are null

Syntax

'Declaration

Public Shared Function IsNull( _
   ByVal _columnName_ As String _
) As IsNullFilter

public static IsNullFilter IsNull(
   string _columnName_
)

Parameters

columnName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members


LessThan Method (FilterType) | fcSDK Documentation

LessThan Method (FilterType)

Filter field that are less than the filter input

Overload List

Overload | Description
LessThan(String,Int32) |
LessThan(String,Decimal) |
LessThan(String,String) |
LessThan(String,DateTime) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members


LessThan(String,Int32) Method | fcSDK Documentation

LessThan(String,Int32) Method

Syntax

'Declaration

Public Overloads Shared Function LessThan( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Integer _
) As LessThanFilter

public static LessThanFilter LessThan(
   string _columnName_,
   int _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


LessThan(String,Decimal) Method | fcSDK Documentation

LessThan(String,Decimal) Method

Syntax

'Declaration

Public Overloads Shared Function LessThan( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Decimal _
) As LessThanFilter

public static LessThanFilter LessThan(
   string _columnName_,
   decimal _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


LessThan(String,String) Method | fcSDK Documentation

LessThan(String,String) Method

Syntax

'Declaration

Public Overloads Shared Function LessThan( _
   ByVal _columnName_ As String, _
   ByVal _value_ As String _
) As LessThanFilter

public static LessThanFilter LessThan(
   string _columnName_,
   string _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


LessThan(String,DateTime) Method | fcSDK Documentation

LessThan(String,DateTime) Method

Syntax

'Declaration

Public Overloads Shared Function LessThan( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Date _
) As LessThanFilter

public static LessThanFilter LessThan(
   string _columnName_,
   DateTime _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


LessThanOrEqual Method (FilterType) | fcSDK Documentation

LessThanOrEqual Method (FilterType)

Filter field that are less than or equal to the filter input

Overload List

Overload | Description
LessThanOrEqual(String,Int32) |
LessThanOrEqual(String,Decimal) |
LessThanOrEqual(String,String) |
LessThanOrEqual(String,DateTime) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members


LessThanOrEqual(String,Int32) Method | fcSDK Documentation

LessThanOrEqual(String,Int32) Method

Syntax

'Declaration

Public Overloads Shared Function LessThanOrEqual( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Integer _
) As LessThanOrEqualFilter
``

```csharp
public static LessThanOrEqualFilter LessThanOrEqual(
   string _columnName_,
   int _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


LessThanOrEqual(String,Decimal) Method | fcSDK Documentation

LessThanOrEqual(String,Decimal) Method

Syntax

'Declaration

Public Overloads Shared Function LessThanOrEqual( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Decimal _
) As LessThanOrEqualFilter

public static LessThanOrEqualFilter LessThanOrEqual(
   string _columnName_,
   decimal _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


LessThanOrEqual(String,String) Method | fcSDK Documentation

LessThanOrEqual(String,String) Method

Syntax

'Declaration

Public Overloads Shared Function LessThanOrEqual( _
   ByVal _columnName_ As String, _
   ByVal _value_ As String _
) As Filter

public static Filter LessThanOrEqual(
   string _columnName_,
   string _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


LessThanOrEqual(String,DateTime) Method | fcSDK Documentation

LessThanOrEqual(String,DateTime) Method

Syntax

'Declaration

Public Overloads Shared Function LessThanOrEqual( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Date _
) As Filter

public static Filter LessThanOrEqual(
   string _columnName_,
   DateTime _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


Like Method (FilterType) | fcSDK Documentation

Like Method (FilterType)

Filter field on strings that are like the filter input

Syntax

'Declaration

Public Shared Function Like( _
   ByVal _columnName_ As String, _
   ByVal _value_ As String _
) As LikeFilter

public static LikeFilter Like(
   string _columnName_,
   string _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members


MoreThan Method (FilterType) | fcSDK Documentation

MoreThan Method (FilterType)

Filter field that are more than the filter input

Overload List

Overload | Description
MoreThan(String,Int32) |
MoreThan(String,Decimal) |
MoreThan(String,String) |
MoreThan(String,DateTime) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members


MoreThan(String,Int32) Method | fcSDK Documentation

MoreThan(String,Int32) Method

Syntax

'Declaration

Public Overloads Shared Function MoreThan( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Integer _
) As MoreThanFilter

public static MoreThanFilter MoreThan(
   string _columnName_,
   int _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


MoreThan(String,Decimal) Method | fcSDK Documentation

MoreThan(String,Decimal) Method

Syntax

'Declaration

Public Overloads Shared Function MoreThan( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Decimal _
) As MoreThanFilter

public static MoreThanFilter MoreThan(
   string _columnName_,
   decimal _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


MoreThan(String,String) Method | fcSDK Documentation

MoreThan(String,String) Method

Syntax

'Declaration

Public Overloads Shared Function MoreThan( _
   ByVal _columnName_ As String, _
   ByVal _value_ As String _
) As MoreThanFilter

public static MoreThanFilter MoreThan(
   string _columnName_,
   string _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


MoreThan(String,DateTime) Method | fcSDK Documentation

MoreThan(String,DateTime) Method

Syntax

'Declaration

Public Overloads Shared Function MoreThan( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Date _
) As MoreThanFilter

public static MoreThanFilter MoreThan(
   string _columnName_,
   DateTime _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


MoreThanOrEqual Method (FilterType) | fcSDK Documentation

MoreThanOrEqual Method (FilterType)

Filter field that are more than or equal to the filter input

Overload List

Overload | Description
MoreThanOrEqual(String,Int32) |
MoreThanOrEqual(String,Decimal) |
MoreThanOrEqual(String,String) |
MoreThanOrEqual(String,DateTime) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members


MoreThanOrEqual(String,Int32) Method | fcSDK Documentation

MoreThanOrEqual(String,Int32) Method

Syntax

'Declaration

Public Overloads Shared Function MoreThanOrEqual( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Integer _
) As MoreThanOrEqualFilter

public static MoreThanOrEqualFilter MoreThanOrEqual(
   string _columnName_,
   int _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


MoreThanOrEqual(String,Decimal) Method | fcSDK Documentation

MoreThanOrEqual(String,Decimal) Method

Syntax

'Declaration

Public Overloads Shared Function MoreThanOrEqual( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Decimal _
) As MoreThanOrEqualFilter

public static MoreThanOrEqualFilter MoreThanOrEqual(
   string _columnName_,
   decimal _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


MoreThanOrEqual(String,String) Method | fcSDK Documentation

MoreThanOrEqual(String,String) Method

Syntax

'Declaration

Public Overloads Shared Function MoreThanOrEqual( _
   ByVal _columnName_ As String, _
   ByVal _value_ As String _
) As MoreThanOrEqualFilter

public static MoreThanOrEqualFilter MoreThanOrEqual(
   string _columnName_,
   string _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


MoreThanOrEqual(String,DateTime) Method | fcSDK Documentation

MoreThanOrEqual(String,DateTime) Method

Syntax

'Declaration

Public Overloads Shared Function MoreThanOrEqual( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Date _
) As MoreThanOrEqualFilter

public static MoreThanOrEqualFilter MoreThanOrEqual(
   string _columnName_,
   DateTime _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


NotBetween Method (FilterType) | fcSDK Documentation

NotBetween Method (FilterType)

Filter field for values that do not occur between the two filter inputs

Overload List

Overload | Description
NotBetween(String,Int32,Int32) |
NotBetween(String,Decimal,Decimal) |
NotBetween(String,String,String) |
NotBetween(String,DateTime,DateTime) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members


NotBetween(String,Int32,Int32) Method | fcSDK Documentation

NotBetween(String,Int32,Int32) Method

Syntax

'Declaration

Public Overloads Shared Function NotBetween( _
   ByVal _columnName_ As String, _
   ByVal _value1_ As Integer, _
   ByVal _value2_ As Integer _
) As BetweenFilter

public static BetweenFilter NotBetween(
   string _columnName_,
   int _value1_,
   int _value2_
)

Parameters

columnName

value1

value2

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


NotBetween(String,Decimal,Decimal) Method | fcSDK Documentation

NotBetween(String,Decimal,Decimal) Method

Syntax

'Declaration

Public Overloads Shared Function NotBetween( _
   ByVal _columnName_ As String, _
   ByVal _value1_ As Decimal, _
   ByVal _value2_ As Decimal _
) As BetweenFilter

public static BetweenFilter NotBetween(
   string _columnName_,
   decimal _value1_,
   decimal _value2_
)

Parameters

columnName

value1

value2

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


NotBetween(String,String,String) Method | fcSDK Documentation

NotBetween(String,String,String) Method

Syntax

'Declaration

Public Overloads Shared Function NotBetween( _
   ByVal _columnName_ As String, _
   ByVal _value1_ As String, _
   ByVal _value2_ As String _
) As BetweenFilter

public static BetweenFilter NotBetween(
   string _columnName_,
   string _value1_,
   string _value2_
)

Parameters

columnName

value1

value2

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


NotBetween(String,DateTime,DateTime) Method | fcSDK Documentation

NotBetween(String,DateTime,DateTime) Method

Syntax

'Declaration

Public Overloads Shared Function NotBetween( _
   ByVal _columnName_ As String, _
   ByVal _value1_ As Date, _
   ByVal _value2_ As Date _
) As BetweenFilter

public static BetweenFilter NotBetween(
   string _columnName_,
   DateTime _value1_,
   DateTime _value2_
)

Parameters

columnName

value1

value2

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


NotContains Method (FilterType) | fcSDK Documentation

NotContains Method (FilterType)

Filter field on strings that do not contain the input to this filter

Syntax

'Declaration

Public Shared Function NotContains( _
   ByVal _columnName_ As String, _
   ByVal _value_ As String _
) As NotContainsFilter

public static NotContainsFilter NotContains(
   string _columnName_,
   string _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members


NotEndsWith Method (FilterType) | fcSDK Documentation

NotEndsWith Method (FilterType)

Filter field on strings that do end with the input to this filter

Syntax

'Declaration

Public Shared Function NotEndsWith( _
   ByVal _columnName_ As String, _
   ByVal _value_ As String _
) As NotEndsWithFilter

public static NotEndsWithFilter NotEndsWith(
   string _columnName_,
   string _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members


NotEqual Method (FilterType) | fcSDK Documentation

NotEqual Method (FilterType)

Filter field on data that does not equal the input to this filter

Overload List

Overload | Description
NotEqual(String,Boolean) |
NotEqual(String,Int32) |
NotEqual(String,Decimal) |
NotEqual(String,String) |
NotEqual(String,DateTime) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members


NotEqual(String,Boolean) Method | fcSDK Documentation

NotEqual(String,Boolean) Method

Syntax

'Declaration

Public Overloads Shared Function NotEqual( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Boolean _
) As EqualsFilter

public static EqualsFilter NotEqual(
   string _columnName_,
   bool _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


NotEqual(String,Int32) Method | fcSDK Documentation

NotEqual(String,Int32) Method

Syntax

'Declaration

Public Overloads Shared Function NotEqual( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Integer _
) As EqualsFilter

public static EqualsFilter NotEqual(
   string _columnName_,
   int _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


NotEqual(String,Decimal) Method | fcSDK Documentation

NotEqual(String,Decimal) Method

Syntax

'Declaration

Public Overloads Shared Function NotEqual( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Decimal _
) As Filter

public static Filter NotEqual(
   string _columnName_,
   decimal _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


NotEqual(String,String) Method | fcSDK Documentation

NotEqual(String,String) Method

Syntax

'Declaration

Public Overloads Shared Function NotEqual( _
   ByVal _columnName_ As String, _
   ByVal _value_ As String _
) As Filter

public static Filter NotEqual(
   string _columnName_,
   string _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


NotEqual(String,DateTime) Method | fcSDK Documentation

NotEqual(String,DateTime) Method

Syntax

'Declaration

Public Overloads Shared Function NotEqual( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Date _
) As Filter

public static Filter NotEqual(
   string _columnName_,
   DateTime _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


NotLike Method (FilterType) | fcSDK Documentation

NotLike Method (FilterType)

Filter field on strings that are not like the filter input

Syntax

'Declaration

Public Shared Function NotLike( _
   ByVal _columnName_ As String, _
   ByVal _value_ As String _
) As NotLikeFilter

public static NotLikeFilter NotLike(
   string _columnName_,
   string _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members


NotStartsWith Method (FilterType) | fcSDK Documentation

NotStartsWith Method (FilterType)

Filter field on strings that do start with the input to this filter

Syntax

'Declaration

Public Shared Function NotStartsWith( _
   ByVal _columnName_ As String, _
   ByVal _value_ As String _
) As NotStartsWithFilter

public static NotStartsWithFilter NotStartsWith(
   string _columnName_,
   string _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members


OlderThanDays Method (FilterType) | fcSDK Documentation

OlderThanDays Method (FilterType)

Filter field on dates that are older than a number of days

Overload List

Overload | Description
OlderThanDays(String,Int32) |
OlderThanDays(String,Decimal) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members


OlderThanDays(String,Int32) Method | fcSDK Documentation

OlderThanDays(String,Int32) Method

Syntax

'Declaration

Public Overloads Shared Function OlderThanDays( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Integer _
) As OlderThanDaysFilter

public static OlderThanDaysFilter OlderThanDays(
   string _columnName_,
   int _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


OlderThanDays(String,Decimal) Method | fcSDK Documentation

OlderThanDays(String,Decimal) Method

Syntax

'Declaration

Public Overloads Shared Function OlderThanDays( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Decimal _
) As OlderThanDaysFilter

public static OlderThanDaysFilter OlderThanDays(
   string _columnName_,
   decimal _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


OlderThanHours Method (FilterType) | fcSDK Documentation

OlderThanHours Method (FilterType)

Filter field on dates that are older than a number of hours

Overload List

Overload | Description
OlderThanHours(String,Int32) |
OlderThanHours(String,Decimal) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members


OlderThanHours(String,Int32) Method | fcSDK Documentation

OlderThanHours(String,Int32) Method

Syntax

'Declaration

Public Overloads Shared Function OlderThanHours( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Integer _
) As OlderThanHoursFilter

public static OlderThanHoursFilter OlderThanHours(
   string _columnName_,
   int _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


OlderThanHours(String,Decimal) Method | fcSDK Documentation

OlderThanHours(String,Decimal) Method

Syntax

'Declaration

Public Overloads Shared Function OlderThanHours( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Decimal _
) As OlderThanHoursFilter

public static OlderThanHoursFilter OlderThanHours(
   string _columnName_,
   decimal _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


On Method (FilterType) | fcSDK Documentation

On Method (FilterType)

Filter field on dates occuring on the the input to this filter

Syntax

'Declaration

Public Shared Function On( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Date _
) As OnFilter

public static OnFilter On(
   string _columnName_,
   DateTime _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members


Or Method (FilterType) | fcSDK Documentation

Or Method (FilterType)

Logical filter allowing 2 or more OR (exclusive) filters.

Overload List

Overload | Description
Or(Filter,Filter) |
Or(Filter[]) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members


Or(Filter,Filter) Method | fcSDK Documentation

Or(Filter,Filter) Method

Syntax

'Declaration

Public Overloads Shared Function Or( _
   ByVal _filter1_ As Filter, _
   ByVal _filter2_ As Filter _
) As OrFilter

public static OrFilter Or(
   Filter _filter1_,
   Filter _filter2_
)

Parameters

filter1

filter2

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


Or(Filter[]) Method | fcSDK Documentation

Or(Filter[]) Method

Syntax

'Declaration

Public Overloads Shared Function Or( _
   ByVal ParamArray _filters_() As Filter _
) As OrManyFilter

public static OrManyFilter Or(
   params Filter\[\] _filters_
)

Parameters

filters

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


SoundsLike Method (FilterType) | fcSDK Documentation

SoundsLike Method (FilterType)

Filter field on strings sound like the input to this filter

Syntax

'Declaration

Public Shared Function SoundsLike( _
   ByVal _columnName_ As String, _
   ByVal _value_ As String _
) As SoundsLikeFilter

public static SoundsLikeFilter SoundsLike(
   string _columnName_,
   string _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members


StartsWith Method (FilterType) | fcSDK Documentation

StartsWith Method (FilterType)

Filter field on strings that start with the input to this filter

Syntax

'Declaration

Public Shared Function StartsWith( _
   ByVal _columnName_ As String, _
   ByVal _value_ As String _
) As StartsWithFilter

public static StartsWithFilter StartsWith(
   string _columnName_,
   string _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members


Today Method (FilterType) | fcSDK Documentation

Today Method (FilterType)

Filter field on today's date

Syntax

'Declaration

Public Shared Function Today( _
   ByVal _columnName_ As String _
) As TodayFilter

public static TodayFilter Today(
   string _columnName_
)

Parameters

columnName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members


Tomorrow Method (FilterType) | fcSDK Documentation

Tomorrow Method (FilterType)

Filter field on tomorrow's date

Syntax

'Declaration

Public Shared Function Tomorrow( _
   ByVal _columnName_ As String _
) As TomorrowFilter

public static TomorrowFilter Tomorrow(
   string _columnName_
)

Parameters

columnName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members


WithinDays Method (FilterType) | fcSDK Documentation

WithinDays Method (FilterType)

Filter field on dates that have occurred within a number of days

Overload List

Overload | Description
WithinDays(String,Int32) |
WithinDays(String,Decimal) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members


WithinDays(String,Int32) Method | fcSDK Documentation

WithinDays(String,Int32) Method

Syntax

'Declaration

Public Overloads Shared Function WithinDays( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Integer _
) As WithinDaysFilter

public static WithinDaysFilter WithinDays(
   string _columnName_,
   int _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


WithinDays(String,Decimal) Method | fcSDK Documentation

WithinDays(String,Decimal) Method

Syntax

'Declaration

Public Overloads Shared Function WithinDays( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Decimal _
) As WithinDaysFilter

public static WithinDaysFilter WithinDays(
   string _columnName_,
   decimal _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


WithinHours Method (FilterType) | fcSDK Documentation

WithinHours Method (FilterType)

Filter field on dates that have occurred within a number of hours

Overload List

Overload | Description
WithinHours(String,Int32) |
WithinHours(String,Decimal) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members


WithinHours(String,Int32) Method | fcSDK Documentation

WithinHours(String,Int32) Method

Syntax

'Declaration

Public Overloads Shared Function WithinHours( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Integer _
) WithinHoursFilter

public static WithinHoursFilter WithinHours(
   string _columnName_,
   int _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


WithinHours(String,Decimal) Method | fcSDK Documentation

WithinHours(String,Decimal) Method

Syntax

'Declaration

Public Overloads Shared Function WithinHours( _
   ByVal _columnName_ As String, _
   ByVal _value_ As Decimal _
) As WithinHoursFilter

public static WithinHoursFilter WithinHours(
   string _columnName_,
   decimal _value_
)

Parameters

columnName

value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members
Overload List


Yesterday Method (FilterType) | fcSDK Documentation

Yesterday Method (FilterType)

Filter field on yesterday's date

Syntax

'Declaration

Public Shared Function Yesterday( _
   ByVal _columnName_ As String _
) As YesterdayFilter

public static YesterdayFilter Yesterday(
   string _columnName_
)

Parameters

columnName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FilterType Class
FilterType Members


IsInFilter Class | fcSDK Documentation

IsInFilter Class

Filter on fields that are in the input array

Syntax

'Declaration

Public Class IsInFilter
   Inherits ColumnBasedFilter

public class IsInFilter : ColumnBasedFilter

Example

Developer Walkthrough - Advanced Filtering

Inheritance Hierarchy

System.Object FChoice.Foundation.Filters.Filter FChoice.Foundation.Filters.ColumnBasedFilter

[FChoice.Foundation.Filters.IsInFilter**

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

IsInFilter Members FChoice.Foundation.Filters Namespace FChoice.Foundation.Filters.IsInFilter

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

IsInFilter Members FChoice.Foundation.Filters Namespace


IsInFilter Class Members | fcSDK Documentation

IsInFilter Class Members

The following tables list the members exposed by IsInFilter.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | IsIn |
Public Property | ObjectList |

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

IsInFilter Class
FChoice.Foundation.Filters Namespace


IsIn Property | fcSDK Documentation

IsIn Property

Syntax

'Declaration

Public ReadOnly Property IsIn As Boolean

public bool IsIn {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IsInFilter Class
IsInFilter Members


ObjectList Property | fcSDK Documentation

ObjectList Property

Syntax

'Declaration

Public ReadOnly Property ObjectList As Array

public Array ObjectList {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IsInFilter Class
IsInFilter Members


IsNullFilter Class | fcSDK Documentation

IsNullFilter Class

Filter on fields that are null

Syntax

'Declaration

Public Class IsNullFilter
   Inherits ColumnBasedFilter

public class IsNullFilter : ColumnBasedFilter

Example

Developer Walkthrough - Advanced Filtering

Inheritance Hierarchy

System.Object
FChoice.Foundation.Filters.Filter
FChoice.Foundation.Filters.ColumnBasedFilter
FChoice.Foundation.Filters.IsNullFilter

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

IsNullFilter Members
FChoice.Foundation.Filters Namespace


IsNullFilter Class Members | fcSDK Documentation

IsNullFilter Class Members

The following tables list the members exposed by IsNullFilter.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | IsNull |

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

IsNullFilter Class
FChoice.Foundation.Filters Namespace


IsNull Property | fcSDK Documentation

IsNull Property

Syntax

'Declaration

Public ReadOnly Property IsNull As Boolean

public bool IsNull {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IsNullFilter Class
IsNullFilter Members


LessThanFilter Class | fcSDK Documentation

LessThanFilter Class

Filter field that are less than filter input

Syntax

'Declaration

Public Class LessThanFilter
   Inherits OperationFilter

public class LessThanFilter : OperationFilter

Example

Developer Walkthrough - Advanced Filtering

Inheritance Hierarchy

System.Object
FChoice.Foundation.Filters.Filter
FChoice.Foundation.Filters.ColumnBasedFilter
FChoice.Foundation.Filters.OperationFilter
FChoice.Foundation.Filters.LessThanFilter
FChoice.Foundation.Filters.BeforeFilter
FChoice.Foundation.Filters.OlderThanDaysFilter
FChoice.Foundation.Filters.OlderThanHoursFilter

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

LessThanFilter Members
FChoice.Foundation.Filters Namespace


LessThanFilter Class Members | fcSDK Documentation

LessThanFilter Class Members

The following tables list the members exposed by LessThanFilter.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | Operator | Overridden.
Public Property | Value | (Inherited from FChoice.Foundation.Filters.OperationFilter)

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

LessThanFilter Class
FChoice.Foundation.Filters Namespace


Operator Property (LessThanFilter) | fcSDK Documentation

Operator Property (LessThanFilter)

Syntax

'Declaration

Public Overrides ReadOnly Property Operator As String

public override string Operator {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LessThanFilter Class
LessThanFilter Members
Base Implementation in Operator


LessThanOrEqualFilter Class | fcSDK Documentation

LessThanOrEqualFilter Class

Filter field that are less than or equal to the filter input

Syntax

'Declaration

Public Class LessThanOrEqualFilter
   Inherits OperationFilter

public class LessThanOrEqualFilter : OperationFilter

Example

Developer Walkthrough - Advanced Filtering

Inheritance Hierarchy

System.Object
FChoice.Foundation.Filters.Filter
FChoice.Foundation.Filters.ColumnBasedFilter
FChoice.Foundation.Filters.OperationFilter
FChoice.Foundation.Filters.LessThanOrEqualFilter

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

LessThanOrEqualFilter Members
FChoice.Foundation.Filters Namespace


LessThanOrEqualFilter Class Members | fcSDK Documentation

LessThanOrEqualFilter Class Members

The following tables list the members exposed by LessThanOrEqualFilter.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | Operator | Overridden.
Public Property | Value | (Inherited from FChoice.Foundation.Filters.OperationFilter)

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

LessThanOrEqualFilter Class
FChoice.Foundation.Filters Namespace


Operator Property (LessThanOrEqualFilter) | fcSDK Documentation

Operator Property (LessThanOrEqualFilter)

Syntax

'Declaration

Public Overrides ReadOnly Property Operator As String

public override string Operator {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LessThanOrEqualFilter Class
LessThanOrEqualFilter Members
Base Implementation in Operator


LikeFilter Class | fcSDK Documentation

LikeFilter Class

Filter field on strings that are like the filter input

Syntax

'Declaration

Public Class LikeFilter
   Inherits OperationFilter

public class LikeFilter : OperationFilter

Example

Developer Walkthrough - Advanced Filtering

Inheritance Hierarchy

System.Object
FChoice.Foundation.Filters.Filter
FChoice.Foundation.Filters.ColumnBasedFilter
FChoice.Foundation.Filters.OperationFilter
FChoice.Foundation.Filters.LikeFilter
FChoice.Foundation.Filters.ContainsFilter
FChoice.Foundation.Filters.EndsWithFilter
FChoice.Foundation.Filters.NotLikeFilter
FChoice.Foundation.Filters.StartsWithFilter

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

LikeFilter Members
FChoice.Foundation.Filters Namespace


LikeFilter Class Members | fcSDK Documentation

LikeFilter Class Members

The following tables list the members exposed by LikeFilter.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | Operator | Overridden.
Public Property | Value | (Inherited from FChoice.Foundation.Filters.OperationFilter)

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

LikeFilter Class
FChoice.Foundation.Filters Namespace


Operator Property (LikeFilter) | fcSDK Documentation

Operator Property (LikeFilter)

Syntax

'Declaration

Public Overrides ReadOnly Property Operator As String

public override string Operator {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LikeFilter Class
LikeFilter Members
Base Implementation in Operator


LogicalFilter Class | fcSDK Documentation

LogicalFilter Class

Abstract filter for logical filter types.

Syntax

'Declaration

Public MustInherit Class LogicalFilter
   Inherits Filter

public abstract class LogicalFilter : Filter

Example

Developer Walkthrough - Advanced Filtering

Inheritance Hierarchy

System.Object
FChoice.Foundation.Filters.Filter
FChoice.Foundation.Filters.LogicalFilter
FChoice.Foundation.Filters.AndFilter
FChoice.Foundation.Filters.AndManyFilter
FChoice.Foundation.Filters.OrFilter
FChoice.Foundation.Filters.OrManyFilter

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

LogicalFilter Members
FChoice.Foundation.Filters Namespace


LogicalFilter Class Members | fcSDK Documentation

LogicalFilter Class Members

The following tables list the members exposed by LogicalFilter.

Public Properties

 | Name | Description
Public Property | Filters | Collection of Filters that belong to this logical grouping.

Public Methods

 | Name | Description
Public Method | AddFilter | This method is called to add a filter to a logical grouping
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

LogicalFilter Class
FChoice.Foundation.Filters Namespace


AddFilter Method | fcSDK Documentation

AddFilter Method

Input filter to the grouping

This method is called to add a filter to a logical grouping

Syntax

'Declaration

Public Function AddFilter( _
   ByVal _filter_ As Filter _
) As Filter

public Filter AddFilter(
   Filter _filter_
)

Parameters

filter

Input filter to the grouping

Example

Developer Walkthrough - Advanced Filtering

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogicalFilter Class
LogicalFilter Members


Filters Property | fcSDK Documentation

Filters Property

Collection of Filters that belong to this logical grouping.

Syntax

'Declaration

Public ReadOnly Property Filters As FilterCollection

public FilterCollection Filters {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogicalFilter Class
LogicalFilter Members


MoreThanFilter Class | fcSDK Documentation

MoreThanFilter Class

Filter field that are more than the filter input

Syntax

'Declaration

Public Class MoreThanFilter
   Inherits OperationFilter

public class MoreThanFilter : OperationFilter

Example

Developer Walkthrough - Advanced Filtering

Inheritance Hierarchy

System.Object
FChoice.Foundation.Filters.Filter
FChoice.Foundation.Filters.ColumnBasedFilter
FChoice.Foundation.Filters.OperationFilter
FChoice.Foundation.Filters.MoreThanFilter
FChoice.Foundation.Filters.AfterFilter

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

MoreThanFilter Members
FChoice.Foundation.Filters Namespace


MoreThanFilter Class Members | fcSDK Documentation

MoreThanFilter Class Members

The following tables list the members exposed by MoreThanFilter.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | Operator | Overridden.
Public Property | Value | (Inherited from FChoice.Foundation.Filters.OperationFilter)

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

MoreThanFilter Class
FChoice.Foundation.Filters Namespace


Operator Property (MoreThanFilter) | fcSDK Documentation

Operator Property (MoreThanFilter)

Syntax

'Declaration

Public Overrides ReadOnly Property Operator As String

public override string Operator {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoreThanFilter Class
MoreThanFilter Members
Base Implementation in Operator


MoreThanOrEqualFilter Class | fcSDK Documentation

MoreThanOrEqualFilter Class

Filter field that are more than or equal to the filter input

Syntax

'Declaration

Public Class MoreThanOrEqualFilter
   Inherits OperationFilter

public class MoreThanOrEqualFilter : OperationFilter

Example

Developer Walkthrough - Advanced Filtering

Inheritance Hierarchy

System.Object
FChoice.Foundation.Filters.Filter
FChoice.Foundation.Filters.ColumnBasedFilter
FChoice.Foundation.Filters.OperationFilter
FChoice.Foundation.Filters.MoreThanOrEqualFilter

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

MoreThanOrEqualFilter Members
FChoice.Foundation.Filters Namespace


MoreThanOrEqualFilter Class Members | fcSDK Documentation

MoreThanOrEqualFilter Class Members

The following tables list the members exposed by MoreThanOrEqualFilter.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | Operator | Overridden.
Public Property | Value | (Inherited from FChoice.Foundation.Filters.OperationFilter)

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

MoreThanOrEqualFilter Class
FChoice.Foundation.Filters Namespace


Operator Property (MoreThanOrEqualFilter) | fcSDK Documentation

Operator Property (MoreThanOrEqualFilter)

Syntax

'Declaration

Public Overrides ReadOnly Property Operator As String

public override string Operator {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoreThanOrEqualFilter Class
MoreThanOrEqualFilter Members
Base Implementation in Operator


NotContainsFilter Class | fcSDK Documentation

NotContainsFilter Class

Filter field on strings that do not contain the input to this filter

Syntax

'Declaration

Public Class NotContainsFilter
   Inherits NotLikeFilter

public class NotContainsFilter : NotLikeFilter

Example

Developer Walkthrough - Advanced Filtering

Inheritance Hierarchy

System.Object
FChoice.Foundation.Filters.Filter
FChoice.Foundation.Filters.ColumnBasedFilter
FChoice.Foundation.Filters.OperationFilter
FChoice.Foundation.Filters.LikeFilter
FChoice.Foundation.Filters.NotLikeFilter
FChoice.Foundation.Filters.NotContainsFilter

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

NotContainsFilter Members
FChoice.Foundation.Filters Namespace


NotContainsFilter Class Members | fcSDK Documentation

NotContainsFilter Class Members

The following tables list the members exposed by NotContainsFilter.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | Operator | (Inherited from FChoice.Foundation.Filters.NotLikeFilter)
Public Property | Value | (Inherited from FChoice.Foundation.Filters.OperationFilter)

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

NotContainsFilter Class
FChoice.Foundation.Filters Namespace


NotEndsWithFilter Class | fcSDK Documentation

NotEndsWithFilter Class

Filter field on strings that do end with the input to this filter

Syntax

'Declaration

Public Class NotEndsWithFilter
   Inherits NotLikeFilter

public class NotEndsWithFilter : NotLikeFilter

Example

Developer Walkthrough - Advanced Filtering

Inheritance Hierarchy

System.Object
FChoice.Foundation.Filters.Filter
FChoice.Foundation.Filters.ColumnBasedFilter
FChoice.Foundation.Filters.OperationFilter
FChoice.Foundation.Filters.LikeFilter
FChoice.Foundation.Filters.NotLikeFilter
FChoice.Foundation.Filters.NotEndsWithFilter

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

NotEndsWithFilter Members
FChoice.Foundation.Filters Namespace


NotEndsWithFilter Class Members | fcSDK Documentation

NotEndsWithFilter Class Members

The following tables list the members exposed by NotEndsWithFilter.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | Operator | (Inherited from FChoice.Foundation.Filters.NotLikeFilter)
Public Property | Value | (Inherited from FChoice.Foundation.Filters.OperationFilter)

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

NotEndsWithFilter Class
FChoice.Foundation.Filters Namespace


NotLikeFilter Class | fcSDK Documentation

NotLikeFilter Class

Filter field on strings that are not like the filter input

Syntax

'Declaration

Public Class NotLikeFilter
   Inherits LikeFilter

public class NotLikeFilter : LikeFilter

Example

Developer Walkthrough - Advanced Filtering

Inheritance Hierarchy

System.Object
FChoice.Foundation.Filters.Filter
FChoice.Foundation.Filters.ColumnBasedFilter
FChoice.Foundation.Filters.OperationFilter
FChoice.Foundation.Filters.LikeFilter
FChoice.Foundation.Filters.NotLikeFilter
FChoice.Foundation.Filters.NotContainsFilter
FChoice.Foundation.Filters.NotEndsWithFilter
FChoice.Foundation.Filters.NotStartsWithFilter

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

NotLikeFilter Members
FChoice.Foundation.Filters Namespace


NotLikeFilter Class Members | fcSDK Documentation

NotLikeFilter Class Members

The following tables list the members exposed by NotLikeFilter.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | Operator | Overridden.
Public Property | Value | (Inherited from FChoice.Foundation.Filters.OperationFilter)

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

NotLikeFilter Class
FChoice.Foundation.Filters Namespace


Operator Property (NotLikeFilter) | fcSDK Documentation

Operator Property (NotLikeFilter)

Syntax

'Declaration

Public Overrides ReadOnly Property Operator As String

public override string Operator {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

NotLikeFilter Class
NotLikeFilter Members
Base Implementation in Operator


NotStartsWithFilter Class | fcSDK Documentation

NotStartsWithFilter Class

Filter field on strings that do start with the input to this filter

Syntax

'Declaration

Public Class NotStartsWithFilter
   Inherits NotLikeFilter

public class NotStartsWithFilter : NotLikeFilter

Example

Developer Walkthrough - Advanced Filtering

Inheritance Hierarchy

System.Object
FChoice.Foundation.Filters.Filter
FChoice.Foundation.Filters.ColumnBasedFilter
FChoice.Foundation.Filters.OperationFilter
FChoice.Foundation.Filters.LikeFilter
FChoice.Foundation.Filters.NotLikeFilter
FChoice.Foundation.Filters.NotStartsWithFilter

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

NotStartsWithFilter Members
FChoice.Foundation.Filters Namespace


NotStartsWithFilter Class Members | fcSDK Documentation

NotStartsWithFilter Class Members

The following tables list the members exposed by NotStartsWithFilter.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | Operator | (Inherited from FChoice.Foundation.Filters.NotLikeFilter)
Public Property | Value | (Inherited from FChoice.Foundation.Filters.OperationFilter)

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

NotStartsWithFilter Class
FChoice.Foundation.Filters Namespace


OlderThanDaysFilter Class | fcSDK Documentation

OlderThanDaysFilter Class

Filter field on dates that are older than a number of days

Syntax

'Declaration

Public Class OlderThanDaysFilter
   Inherits LessThanFilter

public class OlderThanDaysFilter : LessThanFilter

Example

Developer Walkthrough - Advanced Filtering

Inheritance Hierarchy

System.Object
FChoice.Foundation.Filters.Filter
FChoice.Foundation.Filters.ColumnBasedFilter
FChoice.Foundation.Filters.OperationFilter
FChoice.Foundation.Filters.LessThanFilter
FChoice.Foundation.Filters.OlderThanDaysFilter

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

OlderThanDaysFilter Members
FChoice.Foundation.Filters Namespace


OlderThanDaysFilter Class Members | fcSDK Documentation

OlderThanDaysFilter Class Members

The following tables list the members exposed by OlderThanDaysFilter.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | Operator | (Inherited from FChoice.Foundation.Filters.LessThanFilter)
Public Property | Value | (Inherited from FChoice.Foundation.Filters.OperationFilter)

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

OlderThanDaysFilter Class
FChoice.Foundation.Filters Namespace


OlderThanHoursFilter Class | fcSDK Documentation

OlderThanHoursFilter Class

Filter field on dates that are older than a number of hours

Syntax

'Declaration

Public Class OlderThanHoursFilter
   Inherits LessThanFilter

public class OlderThanHoursFilter : LessThanFilter

Example

Developer Walkthrough - Advanced Filtering

Inheritance Hierarchy

System.Object
FChoice.Foundation.Filters.Filter
FChoice.Foundation.Filters.ColumnBasedFilter
FChoice.Foundation.Filters.OperationFilter
FChoice.Foundation.Filters.LessThanFilter
FChoice.Foundation.Filters.OlderThanHoursFilter

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

OlderThanHoursFilter Members
FChoice.Foundation.Filters Namespace


OlderThanHoursFilter Class Members | fcSDK Documentation

OlderThanHoursFilter Class Members

The following tables list the members exposed by OlderThanHoursFilter.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | Operator | (Inherited from FChoice.Foundation.Filters.LessThanFilter)
Public Property | Value | (Inherited from FChoice.Foundation.Filters.OperationFilter)

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

OlderThanHoursFilter Class
FChoice.Foundation.Filters Namespace


OnFilter Class | fcSDK Documentation

OnFilter Class

Filter field on dates occuring on the the input to this filter

Syntax

'Declaration

Public Class OnFilter
   Inherits BetweenFilter

public class OnFilter : BetweenFilter

Example

Developer Walkthrough - Advanced Filtering

Inheritance Hierarchy

System.Object
FChoice.Foundation.Filters.Filter
FChoice.Foundation.Filters.ColumnBasedFilter
FChoice.Foundation.Filters.BetweenFilter
FChoice.Foundation.Filters.OnFilter
FChoice.Foundation.Filters.TodayFilter
FChoice.Foundation.Filters.TomorrowFilter

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

OnFilter Members
FChoice.Foundation.Filters Namespace


OnFilter Class Members | fcSDK Documentation

OnFilter Class Members

The following tables list the members exposed by OnFilter.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | IsBetween | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value1 | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value1Present | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value2 | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value2Present | (Inherited from FChoice.Foundation.Filters.BetweenFilter)

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

OnFilter Class
FChoice.Foundation.Filters Namespace


OperationFilter Class | fcSDK Documentation

OperationFilter Class

Abstract filter for operation type filters.

Syntax

'Declaration

Public MustInherit Class OperationFilter
   Inherits ColumnBasedFilter

public abstract class OperationFilter : ColumnBasedFilter

Example

Developer Walkthrough - Advanced Filtering

Inheritance Hierarchy

System.Object
FChoice.Foundation.Filters.Filter
FChoice.Foundation.Filters.ColumnBasedFilter
FChoice.Foundation.Filters.OperationFilter
FChoice.Foundation.Filters.EqualsFilter
FChoice.Foundation.Filters.LessThanFilter
FChoice.Foundation.Filters.LessThanOrEqualFilter
FChoice.Foundation.Filters.LikeFilter
FChoice.Foundation.Filters.MoreThanFilter
FChoice.Foundation.Filters.MoreThanOrEqualFilter

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

OperationFilter Members
FChoice.Foundation.Filters Namespace


OperationFilter Class Members | fcSDK Documentation

OperationFilter Class Members

The following tables list the members exposed by OperationFilter.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | Operator |
Public Property | Value |

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

OperationFilter Class
FChoice.Foundation.Filters Namespace


Operator Property (OperationFilter) | fcSDK Documentation

Operator Property (OperationFilter)

Syntax

'Declaration

Public MustOverride ReadOnly Property Operator As String

public abstract string Operator {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OperationFilter Class
OperationFilter Members


Value Property (OperationFilter) | fcSDK Documentation

Value Property (OperationFilter)

Syntax

'Declaration

Public ReadOnly Property Value As Object

public object Value {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OperationFilter Class
OperationFilter Members


OrFilter Class | fcSDK Documentation

OrFilter Class

Logical filter allowing 2 OR (exclusive) filters.

Syntax

'Declaration

Public Class OrFilter
   Inherits LogicalFilter

public class OrFilter : LogicalFilter

Example

Developer Walkthrough - Advanced Filtering

Inheritance Hierarchy

System.Object
FChoice.Foundation.Filters.Filter
FChoice.Foundation.Filters.LogicalFilter
FChoice.Foundation.Filters.OrFilter

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

OrFilter Members
FChoice.Foundation.Filters Namespace


OrFilter Class Members | fcSDK Documentation

OrFilter Class Members

The following tables list the members exposed by OrFilter.

Public Properties

 | Name | Description
Public Property | Filters | Collection of Filters that belong to this logical grouping. (Inherited from FChoice.Foundation.Filters.LogicalFilter)

Public Methods

 | Name | Description
Public Method | AddFilter | This method is called to add a filter to a logical grouping (Inherited from FChoice.Foundation.Filters.LogicalFilter)
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

OrFilter Class
FChoice.Foundation.Filters Namespace


OrManyFilter Class | fcSDK Documentation

OrManyFilter Class

Alternative filter to OrFilter which allows for more than two sub filters.

Syntax

'Declaration

Public Class OrManyFilter
   Inherits LogicalFilter

public class OrManyFilter : LogicalFilter

Inheritance Hierarchy

System.Object
FChoice.Foundation.Filters.Filter
FChoice.Foundation.Filters.LogicalFilter
FChoice.Foundation.Filters.OrManyFilter

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

OrManyFilter Members
FChoice.Foundation.Filters Namespace


OrManyFilter Class Members | fcSDK Documentation

OrManyFilter Class Members

The following tables list the members exposed by OrManyFilter.

Public Properties

 | Name | Description
Public Property | Filters | Collection of Filters that belong to this logical grouping. (Inherited from FChoice.Foundation.Filters.LogicalFilter)

Public Methods

 | Name | Description
Public Method | AddFilter | This method is called to add a filter to a logical grouping (Inherited from FChoice.Foundation.Filters.LogicalFilter)
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

OrManyFilter Class
FChoice.Foundation.Filters Namespace


SoundsLikeFilter Class | fcSDK Documentation

SoundsLikeFilter Class

Filter field on strings sound like the input to this filter

Syntax

'Declaration

Public Class SoundsLikeFilter
   Inherits ColumnBasedFilter

public class SoundsLikeFilter : ColumnBasedFilter

Example

Developer Walkthrough - Advanced Filtering

Inheritance Hierarchy

System.Object
FChoice.Foundation.Filters.Filter
FChoice.Foundation.Filters.ColumnBasedFilter
FChoice.Foundation.Filters.SoundsLikeFilter

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

SoundsLikeFilter Members
FChoice.Foundation.Filters Namespace


SoundsLikeFilter Class Members | fcSDK Documentation

SoundsLikeFilter Class Members

The following tables list the members exposed by SoundsLikeFilter.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | Value |

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

SoundsLikeFilter Class
FChoice.Foundation.Filters Namespace


Value Property (SoundsLikeFilter) | fcSDK Documentation

Value Property (SoundsLikeFilter)

Syntax

'Declaration

Public ReadOnly Property Value As String

public string Value { get; }

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SoundsLikeFilter Class
SoundsLikeFilter Members


StartsWithFilter Class | fcSDK Documentation

StartsWithFilter Class

Filter field on strings that do not contain the input to this filter

Syntax

'Declaration

Public Class StartsWithFilter
   Inherits LikeFilter

public class StartsWithFilter : LikeFilter

Example

Developer Walkthrough - Advanced Filtering

Inheritance Hierarchy

System.Object
FChoice.Foundation.Filters.Filter
FChoice.Foundation.Filters.ColumnBasedFilter
FChoice.Foundation.Filters.OperationFilter
FChoice.Foundation.Filters.LikeFilter
FChoice.Foundation.Filters.StartsWithFilter

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

StartsWithFilter Members
FChoice.Foundation.Filters Namespace


StartsWithFilter Class Members | fcSDK Documentation

StartsWithFilter Class Members

The following tables list the members exposed by StartsWithFilter.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | Operator | (Inherited from FChoice.Foundation.Filters.LikeFilter)
Public Property | Value | (Inherited from FChoice.Foundation.Filters.OperationFilter)

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

StartsWithFilter Class
FChoice.Foundation.Filters Namespace


TodayFilter Class | fcSDK Documentation

TodayFilter Class

Filter field on today's date

Syntax

'Declaration

Public Class TodayFilter
   Inherits OnFilter

public class TodayFilter : OnFilter

Example

Developer Walkthrough - Advanced Filtering

Inheritance Hierarchy

System.Object
FChoice.Foundation.Filters.Filter
FChoice.Foundation.Filters.ColumnBasedFilter
FChoice.Foundation.Filters.BetweenFilter
FChoice.Foundation.Filters.OnFilter
FChoice.Foundation.Filters.TodayFilter

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

TodayFilter Members
FChoice.Foundation.Filters Namespace


TodayFilter Class Members | fcSDK Documentation

TodayFilter Class Members

The following tables list the members exposed by TodayFilter.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | IsBetween | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value1 | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value1Present | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value2 | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value2Present | (Inherited from FChoice.Foundation.Filters.BetweenFilter)

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

TodayFilter Class
FChoice.Foundation.Filters Namespace


TomorrowFilter Class | fcSDK Documentation

TomorrowFilter Class

Filter field on tomorrow's date

Syntax

'Declaration

Public Class TomorrowFilter
   Inherits OnFilter

public class TomorrowFilter : OnFilter

Example

Developer Walkthrough - Advanced Filtering

Inheritance Hierarchy

System.Object
FChoice.Foundation.Filters.Filter
FChoice.Foundation.Filters.ColumnBasedFilter
FChoice.Foundation.Filters.BetweenFilter
FChoice.Foundation.Filters.OnFilter
FChoice.Foundation.Filters.TomorrowFilter

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

TomorrowFilter Members
FChoice.Foundation.Filters Namespace


TomorrowFilter Class Members | fcSDK Documentation

TomorrowFilter Class Members

The following tables list the members exposed by TomorrowFilter.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | IsBetween | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value1 | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value1Present | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value2 | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value2Present | (Inherited from FChoice.Foundation.Filters.BetweenFilter)

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

TomorrowFilter Class
FChoice.Foundation.Filters Namespace


WithinDaysFilter Class | fcSDK Documentation

WithinDaysFilter Class

Filter field on dates that have occurred within a number of days

Syntax

'Declaration

Public Class WithinDaysFilter
   Inherits BetweenFilter

public class WithinDaysFilter : BetweenFilter

Example

Developer Walkthrough - Advanced Filtering

Inheritance Hierarchy

System.Object
FChoice.Foundation.Filters.Filter
FChoice.Foundation.Filters.ColumnBasedFilter
FChoice.Foundation.Filters.BetweenFilter
FChoice.Foundation.Filters.WithinDaysFilter

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

WithinDaysFilter Members
FChoice.Foundation.Filters Namespace


WithinDaysFilter Class Members | fcSDK Documentation

WithinDaysFilter Class Members

The following tables list the members exposed by WithinDaysFilter.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | IsBetween | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value1 | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value1Present | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value2 | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value2Present | (Inherited from FChoice.Foundation.Filters.BetweenFilter)

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

WithinDaysFilter Class
FChoice.Foundation.Filters Namespace


WithinHoursFilter Class | fcSDK Documentation

WithinHoursFilter Class

Filter field on dates that have occurred within a number of hours

Syntax

'Declaration

Public Class WithinHoursFilter
   Inherits BetweenFilter

public class WithinHoursFilter : BetweenFilter

Example

Developer Walkthrough - Advanced Filtering

Inheritance Hierarchy

System.Object
FChoice.Foundation.Filters.Filter
FChoice.Foundation.Filters.ColumnBasedFilter
FChoice.Foundation.Filters.BetweenFilter
FChoice.Foundation.Filters.WithinHoursFilter

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

WithinHoursFilter Members
FChoice.Foundation.Filters Namespace


WithinHoursFilter Class Members | fcSDK Documentation

WithinHoursFilter Class Members

The following tables list the members exposed by WithinHoursFilter.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | IsBetween | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value1 | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value1Present | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value2 | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value2Present | (Inherited from FChoice.Foundation.Filters.BetweenFilter)

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

WithinHoursFilter Class
FChoice.Foundation.Filters Namespace


YesterdayFilter Class | fcSDK Documentation

YesterdayFilter Class

Filter

Syntax

'Declaration

Public Class YesterdayFilter
   Inherits BetweenFilter

public class YesterdayFilter : BetweenFilter

Example

Developer Walkthrough - Advanced Filtering

Inheritance Hierarchy

System.Object
FChoice.Foundation.Filters.Filter
FChoice.Foundation.Filters.ColumnBasedFilter
FChoice.Foundation.Filters.BetweenFilter
FChoice.Foundation.Filters.YesterdayFilter

Requirements

Namespace: FChoice.Foundation.Filters

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

YesterdayFilter Members
FChoice.Foundation.Filters Namespace


YesterdayFilter Class Members | fcSDK Documentation

YesterdayFilter Class Members

The following tables list the members exposed by YesterdayFilter.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | IsBetween | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value1 | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value1Present | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value2 | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value2Present | (Inherited from FChoice.Foundation.Filters.BetweenFilter)

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

YesterdayFilter Class
FChoice.Foundation.Filters Namespace


FChoice.Foundation.Schema Namespace | fcSDK Documentation

FChoice.Foundation.Schema Namespace

Interfaces used to access Schema metadata.

Interfaces

 | Interface | Description
Interface | ISchemaCache |
Interface | ISchemaField |
Interface | ISchemaFieldCollection |
Interface | ISchemaRelation |
Interface | ISchemaRelationCollection |
Interface | ISchemaTable |
Interface | ISchemaTableBase |
Interface | ISchemaTableCollection |
Interface | ISchemaView |
Interface | ISchemaViewCollection |
Interface | ISchemaViewJoin |
Interface | ISchemaViewJoinCollection |

Enumerations

 | Enumeration | Description
Enumeration | SchemaRelationCardinality |

Reference

fcSDK Assembly


SchemaRelationCardinality Enumeration | fcSDK Documentation

SchemaRelationCardinality Enumeration

Syntax

'Declaration

Public Enum SchemaRelationCardinality
   Inherits System.Enum

public enum SchemaRelationCardinality : System.Enum

Members

Member | Description
ManyToMany |
ManyToOne |
OneToMany |
OneToOneForeign |
OneToOnePrimary |

Inheritance Hierarchy

System.Object System.ValueType System.Enum FChoice.Foundation.Schema.SchemaRelationCardinality

Requirements

Namespace: FChoice.Foundation.Schema

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

FChoice.Foundation.Schema Namespace


ISchemaCache Interface | fcSDK Documentation

ISchemaCache Interface

Syntax

'Declaration

Public Interface ISchemaCache

public interface ISchemaCache

Requirements

Namespace: FChoice.Foundation.Schema

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ISchemaCache Members FChoice.Foundation.Schema Namespace


ISchemaCache Interface Members | fcSDK Documentation

ISchemaCache Interface Members

The following tables list the members exposed by ISchemaCache.

Public Properties

 | Name | Description
Property | IsDatabaseUnicode |
Property | RestrictionGroups |
Property | Tables |
Property | Views |

Public Methods

 | Name | Description
Method | GetChangeDateField |
Method | GetDateFields |
Method | GetField |
Method | GetRelation |
Method | GetTableName |
Method | GetTableNumber |
Method | IsChangeField |
Method | IsDateField |
Method | IsFieldSearchable |
Method | IsFieldUnicode |
Method | IsIntegerField |
Method | IsNumericField |
Method | IsRelationExclusive |
Method | IsStringField |
Method | IsStringOrDateField |
Method | IsValidField |
Method | IsValidRelation |
Method | IsValidTable |
Method | IsValidTableOrView |
Method | IsValidView |

Reference

ISchemaCache Interface
FChoice.Foundation.Schema Namespace


GetChangeDateField Method (ISchemaCache) | fcSDK Documentation

GetChangeDateField Method (ISchemaCache)

Syntax

'Declaration
Function GetChangeDateField( _
   ByVal _tableName_ As String _
) As ISchemaField

ISchemaField GetChangeDateField(
   string _tableName_
)

Parameters

tableName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaCache Interface
ISchemaCache Members


GetDateFields Method (ISchemaCache) | fcSDK Documentation

GetDateFields Method (ISchemaCache)

Syntax

'Declaration

Function GetDateFields( _
   ByVal _tableName_ As String _
) As IEnumerable

IEnumerable GetDateFields(
   string _tableName_
)

Parameters

tableName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaCache Interface
ISchemaCache Members


GetField Method (ISchemaCache) | fcSDK Documentation

GetField Method (ISchemaCache)

Syntax

'Declaration
Function GetField( _
   ByVal _objetName_ As String, _
   ByVal _fieldName_ As String _
) As ISchemaField

ISchemaField GetField(
   string _objetName_,
   string _fieldName_
)

Parameters

objetName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaCache Interface
ISchemaCache Members


GetRelation Method (ISchemaCache) | fcSDK Documentation

GetRelation Method (ISchemaCache)

Syntax

'Declaration
Function GetRelation( _
   ByVal _tableName_ As String, _
   ByVal _relationName_ As String _
) As ISchemaRelation

ISchemaRelation GetRelation(
   string _tableName_,
   string _relationName_
)

Parameters

tableName

relationName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaCache Interface
ISchemaCache Members


GetTableName Method (ISchemaCache) | fcSDK Documentation

GetTableName Method (ISchemaCache)

Syntax

'Declaration

Function GetTableName( _
   ByVal _tableNum_ As Integer _
) As String

string GetTableName(
   int _tableNum_
)

Parameters

tableNum

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaCache Interface
ISchemaCache Members


GetTableNumber Method | fcSDK Documentation

GetTableNumber Method

Syntax

'Declaration
Function GetTableNumber( _
   ByVal _tableName_ As String _
) As Integer

int GetTableNumber(
   string _tableName_
)

Parameters

tableName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaCache Interface
ISchemaCache Members


IsChangeField Method (ISchemaCache) | fcSDK Documentation

IsChangeField Method (ISchemaCache)

Syntax

'Declaration
Function IsChangeField( _
   ByVal _tableName_ As String, _
   ByVal _fieldName_ As String _
) As Boolean

bool IsChangeField(
   string _tableName_,
   string _fieldName_
)

Parameters

tableName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaCache Interface
ISchemaCache Members


IsDateField Method (ISchemaCache) | fcSDK Documentation

IsDateField Method (ISchemaCache)

Syntax

'Declaration
Function IsDateField( _
   ByVal _tableName_ As String, _
   ByVal _fieldName_ As String _
) As Boolean

bool IsDateField(
   string _tableName_,
   string _fieldName_
)

Parameters

tableName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaCache Interface
ISchemaCache Members


IsFieldSearchable Method (ISchemaCache) | fcSDK Documentation

IsFieldSearchable Method (ISchemaCache)

Syntax

'Declaration

Function IsFieldSearchable( _
   ByVal _tableName_ As String, _
   ByVal _fieldName_ As String _
) As Boolean

bool IsFieldSearchable(
   string _tableName_,
   string _fieldName_
)

Parameters

tableName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaCache Interface
ISchemaCache Members


IsFieldUnicode Method (ISchemaCache) | fcSDK Documentation

IsFieldUnicode Method (ISchemaCache)

Syntax

'Declaration

Function IsFieldUnicode( _
   ByVal _tableName_ As String, _
   ByVal _fieldName_ As String _
) As Boolean

bool IsFieldUnicode(
   string _tableName_,
   string _fieldName_
)

Parameters

tableName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaCache Interface
ISchemaCache Members


IsIntegerField Method (ISchemaCache) | fcSDK Documentation

IsIntegerField Method (ISchemaCache)

Syntax

'Declaration
Function IsIntegerField( _
   ByVal _tableName_ As String, _
   ByVal _fieldName_ As String _
) As Boolean

bool IsIntegerField(
   string _tableName_,
   string _fieldName_
)

Parameters

tableName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaCache Interface
ISchemaCache Members


IsNumericField Method (ISchemaCache) | fcSDK Documentation

IsNumericField Method (ISchemaCache)

Syntax

'Declaration
Function IsNumericField( _
   ByVal _tableName_ As String, _
   ByVal _fieldName_ As String _
) As Boolean

bool IsNumericField(
   string _tableName_,
   string _fieldName_
)

Parameters

tableName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaCache Interface
ISchemaCache Members


IsRelationExclusive Method (ISchemaCache) | fcSDK Documentation

IsRelationExclusive Method (ISchemaCache)

Syntax

'Declaration

Function IsRelationExclusive( _
   ByVal _tableName_ As String, _
   ByVal _relationName_ As String _
) As Boolean

bool IsRelationExclusive(
   string _tableName_,
   string _relationName_
)

Parameters

tableName

relationName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaCache Interface
ISchemaCache Members


IsStringField Method (ISchemaCache) | fcSDK Documentation

IsStringField Method (ISchemaCache)

Syntax

'Declaration
Function IsStringField( _
   ByVal _tableName_ As String, _
   ByVal _fieldName_ As String _
) As Boolean

bool IsStringField(
   string _tableName_,
   string _fieldName_
)

Parameters

tableName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaCache Interface
ISchemaCache Members


IsStringOrDateField Method (ISchemaCache) | fcSDK Documentation

IsStringOrDateField Method (ISchemaCache)

Syntax

'Declaration
Function IsStringOrDateField( _
   ByVal _tableName_ As String, _
   ByVal _fieldName_ As String _
) As Boolean

bool IsStringOrDateField(
   string _tableName_,
   string _fieldName_
)

Parameters

tableName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaCache Interface
ISchemaCache Members


IsValidField Method (ISchemaCache) | fcSDK Documentation

IsValidField Method (ISchemaCache)

Syntax

'Declaration
Function IsValidField( _
   ByVal _objectName_ As String, _
   ByVal _fieldName_ As String _
) As Boolean

bool IsValidField(
   string _objectName_,
   string _fieldName_
)

Parameters

objectName

fieldName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaCache Interface
ISchemaCache Members


IsValidRelation Method (ISchemaCache) | fcSDK Documentation

IsValidRelation Method (ISchemaCache)

Syntax

'Declaration
Function IsValidRelation( _
   ByVal _objectName_ As String, _
   ByVal _relationName_ As String _
) As Boolean

bool IsValidRelation(
   string _objectName_,
   string _relationName_
)

Parameters

objectName

relationName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaCache Interface
ISchemaCache Members


IsValidTable Method (ISchemaCache) | fcSDK Documentation

IsValidTable Method (ISchemaCache)

Syntax

'Declaration

Function IsValidTable( _
   ByVal _tableName_ As String _
) As Boolean

bool IsValidTable(
   string _tableName_
)

Parameters

tableName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaCache Interface
ISchemaCache Members


IsValidTableOrView Method (ISchemaCache) | fcSDK Documentation

IsValidTableOrView Method (ISchemaCache)

Syntax

'Declaration
Function IsValidTableOrView( _
   ByVal _objectName_ As String _
) As Boolean

bool IsValidTableOrView(
   string _objectName_
)

Parameters

objectName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaCache Interface
ISchemaCache Members


IsValidView Method (ISchemaCache) | fcSDK Documentation

IsValidView Method (ISchemaCache)

Syntax

'Declaration
Function IsValidView( _
   ByVal _viewName_ As String _
) As Boolean

bool IsValidView(
   string _viewName_
)

Parameters

viewName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaCache Interface
ISchemaCache Members


IsDatabaseUnicode Property (ISchemaCache) | fcSDK Documentation

IsDatabaseUnicode Property (ISchemaCache)

Syntax

'Declaration

ReadOnly Property IsDatabaseUnicode As Boolean

bool IsDatabaseUnicode {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaCache Interface
ISchemaCache Members


RestrictionGroups Property (ISchemaCache) | fcSDK Documentation

RestrictionGroups Property (ISchemaCache)

Syntax

'Declaration

ReadOnly Property RestrictionGroups As RestrictionGroupCollection

RestrictionGroupCollection RestrictionGroups {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaCache Interface
ISchemaCache Members


Tables Property (ISchemaCache) | fcSDK Documentation

Tables Property (ISchemaCache)

Syntax

'Declaration

ReadOnly Property Tables As ISchemaTableCollection

ISchemaTableCollection Tables {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaCache Interface
ISchemaCache Members


Views Property (ISchemaCache) | fcSDK Documentation

Views Property (ISchemaCache)

Syntax

'Declaration

ReadOnly Property Views As ISchemaViewCollection

ISchemaViewCollection Views {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaCache Interface
ISchemaCache Members


ISchemaField Interface | fcSDK Documentation

ISchemaField Interface

Syntax

'Declaration

Public Interface ISchemaField

public interface ISchemaField

Requirements

Namespace: FChoice.Foundation.Schema

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ISchemaField Members
FChoice.Foundation.Schema Namespace


ISchemaField Interface Members | fcSDK Documentation

ISchemaField Interface Members

The following tables list the members exposed by ISchemaField.

Public Properties

 | Name | Description
Property | CommonType |
Property | DatabaseType |
Property | DataType |
Property | Default |
Property | DefaultString |
Property | Description |
Property | Flags |
Property | IsSearchable |
Property | IsUnicode |
Property | Length |
Property | Name |
Property | Rank |

Public Methods

 | Name | Description
Method | IsDate |
Method | IsInteger |
Method | IsNumeric |
Method | IsString |

Reference

ISchemaField Interface
FChoice.Foundation.Schema Namespace


IsDate Method (ISchemaField) | fcSDK Documentation

IsDate Method (ISchemaField)

Syntax

'Declaration

Function IsDate() As Boolean

bool IsDate()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaField Interface
ISchemaField Members


IsInteger Method (ISchemaField) | fcSDK Documentation

IsInteger Method (ISchemaField)

Syntax

'Declaration
Function IsInteger() As Boolean

bool IsInteger()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaField Interface
ISchemaField Members


IsNumeric Method (ISchemaField) | fcSDK Documentation

IsNumeric Method (ISchemaField)

Syntax

'Declaration

Function IsNumeric() As Boolean

bool IsNumeric()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaField Interface
ISchemaField Members


IsString Method (ISchemaField) | fcSDK Documentation

IsString Method (ISchemaField)

Syntax

'Declaration

Function IsString() As Boolean

bool IsString()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaField Interface
ISchemaField Members


CommonType Property (ISchemaField) | fcSDK Documentation

CommonType Property (ISchemaField)

Syntax

'Declaration

ReadOnly Property CommonType As Integer

int CommonType {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaField Interface
ISchemaField Members


DatabaseType Property (ISchemaField) | fcSDK Documentation

DatabaseType Property (ISchemaField)

Syntax

'Declaration

ReadOnly Property DatabaseType As Integer

int DatabaseType {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaField Interface
ISchemaField Members


DataType Property (ISchemaField) | fcSDK Documentation

DataType Property (ISchemaField)

Syntax

'Declaration

ReadOnly Property DataType As Integer

int DataType {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaField Interface
ISchemaField Members


Default Property (ISchemaField) | fcSDK Documentation

Default Property (ISchemaField)

Syntax

'Declaration

ReadOnly Property Default As Object

object Default {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaField Interface
ISchemaField Members


DefaultString Property (ISchemaField) | fcSDK Documentation

DefaultString Property (ISchemaField)

Syntax

'Declaration

ReadOnly Property DefaultString As String

string DefaultString {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaField Interface
ISchemaField Members


Description Property (ISchemaField) | fcSDK Documentation

Description Property (ISchemaField)

Syntax

'Declaration
ReadOnly Property Description As String

string Description {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaField Interface
ISchemaField Members


Flags Property (ISchemaField) | fcSDK Documentation

Flags Property (ISchemaField)

Syntax

'Declaration

ReadOnly Property Flags As Object

object Flags {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaField Interface
ISchemaField Members


IsSearchable Property (ISchemaField) | fcSDK Documentation

IsSearchable Property (ISchemaField)

Syntax

'Declaration

ReadOnly Property IsSearchable As Boolean

bool IsSearchable {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaField Interface
ISchemaField Members


IsUnicode Property (ISchemaField) | fcSDK Documentation

IsUnicode Property (ISchemaField)

Syntax

As Boolean

boolaration

ReadOnly Property IsUnicode As Boolean

bool IsUnicode {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaField Interface
ISchemaField Members


Length Property (ISchemaField) | fcSDK Documentation

Length Property (ISchemaField)

Syntax

'Declaration
ReadOnly Property Length As Integer

int Length {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaField Interface
ISchemaField Members


Name Property (ISchemaField) | fcSDK Documentation

Name Property (ISchemaField)

Syntax

'Declaration

ReadOnly Property Name As String

string Name {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaField Interface
ISchemaField Members


Rank Property (ISchemaField) | fcSDK Documentation

Rank Property (ISchemaField)

Syntax

'Declaration
ReadOnly Property Rank As Integer

int Rank {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaField Interface
ISchemaField Members


ISchemaFieldCollection Interface | fcSDK Documentation

ISchemaFieldCollection Interface

Syntax

'Declaration

<DefaultMemberAttribute("Item")>
Public Interface ISchemaFieldCollection

[DefaultMemberAttribute("Item")]
public interface ISchemaFieldCollection

Requirements

Namespace: FChoice.Foundation.Schema

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ISchemaFieldCollection Members
FChoice.Foundation.Schema Namespace


ISchemaFieldCollection Interface Members | fcSDK Documentation

ISchemaFieldCollection Interface Members

The following tables list the members exposed by ISchemaFieldCollection.

Public Properties

 | Name | Description
Property | Item | Overloaded.

Reference

ISchemaFieldCollection Interface
FChoice.Foundation.Schema Namespace


Item Property (ISchemaFieldCollection) | fcSDK Documentation

Item Property (ISchemaFieldCollection)

Overload List

Overload | Description
Item(String) |
Item(Int32) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaFieldCollection Interface
ISchemaFieldCollection Members


Item(String) Property | fcSDK Documentation

Item(String) Property

Syntax

'Declaration

Overloads ReadOnly Property Item( _
   ByVal _name_ As String _
) As ISchemaField

ISchemaField Item(
   string _name_
) {get;}

Parameters

name

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaFieldCollection Interface
ISchemaFieldCollection Members
Overload List


Item(Int32) Property | fcSDK Documentation

Item(Int32) Property

Syntax

'Declaration

Overloads ReadOnly Property Item( _
   ByVal _rank_ As Integer _
) As ISchemaField

ISchemaField Item(
   int _rank_
) {get;}

Parameters

rank

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaFieldCollection Interface
ISchemaFieldCollection Members
Overload List


ISchemaRelation Interface | fcSDK Documentation

ISchemaRelation Interface

Syntax

'Declaration

Public Interface ISchemaRelation

public interface ISchemaRelation

Requirements

Namespace: FChoice.Foundation.Schema

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ISchemaRelation Members
FChoice.Foundation.Schema Namespace


ISchemaRelation Interface Members | fcSDK Documentation

ISchemaRelation Interface Members

The following tables list the members exposed by ISchemaRelation.

Public Properties

 | Name | Description
Property | Cardinality |
Property | ChildTable |
Property | Description |
Property | ExclusiveObjectIDField |
Property | ExclusiveTableField |
Property | Flags |
Property | InverseRelation |
Property | IsExclusive |
Property | IsMandatory |
Property | IsMtm |
Property | MandatoryObjectID |
Property | MtmTableName |
Property | Name |
Property | ObjectID |
Property | ParentTable |
Property | Rank |
Property | SourceTable |
Property | TargetTable |

Reference

ISchemaRelation Interface
FChoice.Foundation.Schema Namespace


Cardinality Property (ISchemaRelation) | fcSDK Documentation

Cardinality Property (ISchemaRelation)

Syntax

'Declaration

ReadOnly Property Cardinality As SchemaRelationCardinality

SchemaRelationCardinality Cardinality {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaRelation Interface
ISchemaRelation Members


ChildTable Property (ISchemaRelation) | fcSDK Documentation

ChildTable Property (ISchemaRelation)

Syntax

'Declaration

ReadOnly Property ChildTable As ISchemaTable

ISchemaTable ChildTable {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaRelation Interface
ISchemaRelation Members


Description Property (ISchemaRelation) | fcSDK Documentation

Description Property (ISchemaRelation)

Syntax

'Declaration
ReadOnly Property Description As String

string Description {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaRelation Interface
ISchemaRelation Members


ExclusiveObjectIDField Property | fcSDK Documentation

ExclusiveObjectIDField Property

Syntax

'Declaration
ReadOnly Property ExclusiveObjectIDField As ISchemaField

ISchemaField ExclusiveObjectIDField {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaRelation Interface
ISchemaRelation Members


ExclusiveTableField Property | fcSDK Documentation

ExclusiveTableField Property

Syntax

'Declaration
ReadOnly Property ExclusiveTableField As ISchemaField

ISchemaField ExclusiveTableField {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaRelation Interface
ISchemaRelation Members


Flags Property (ISchemaRelation) | fcSDK Documentation

Flags Property (ISchemaRelation)

Syntax

'Declaration

ReadOnly Property Flags As Object

object Flags {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaRelation Interface
ISchemaRelation Members


InverseRelation Property (ISchemaRelation) | fcSDK Documentation

InverseRelation Property (ISchemaRelation)

Syntax

'Declaration
ReadOnly Property InverseRelation As ISchemaRelation

ISchemaRelation InverseRelation {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaRelation Interface
ISchemaRelation Members


IsExclusive Property (ISchemaRelation) | fcSDK Documentation

IsExclusive Property (ISchemaRelation)

Syntax

'Declaration

ReadOnly Property IsExclusive As Boolean

bool IsExclusive {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaRelation Interface
ISchemaRelation Members


IsMandatory Property (ISchemaRelation) | fcSDK Documentation

IsMandatory Property (ISchemaRelation)

Syntax

'Declaration

ReadOnly Property IsMandatory As Boolean

bool IsMandatory {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaRelation Interface
ISchemaRelation Members


IsMtm Property (ISchemaRelation) | fcSDK Documentation

IsMtm Property (ISchemaRelation)

Syntax

'Declaration
ReadOnly Property IsMtm As Boolean

bool IsMtm {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaRelation Interface
ISchemaRelation Members


MandatoryObjectID Property (ISchemaRelation) | fcSDK Documentation

MandatoryObjectID Property (ISchemaRelation)

Syntax

'Declaration
ReadOnly Property MandatoryObjectID As Object

object MandatoryObjectID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaRelation Interface
ISchemaRelation Members


MtmTableName Property (ISchemaRelation) | fcSDK Documentation

MtmTableName Property (ISchemaRelation)

Syntax

'Declaration

ReadOnly Property MtmTableName As String

string MtmTableName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaRelation Interface
ISchemaRelation Members


Name Property (ISchemaRelation) | fcSDK Documentation

Name Property (ISchemaRelation)

Syntax

'Declaration

ReadOnly Property Name As String

string Name {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaRelation Interface
ISchemaRelation Members


ObjectID Property (ISchemaRelation) | fcSDK Documentation

ObjectID Property (ISchemaRelation)

Syntax

'Declaration
ReadOnly Property ObjectID As Object

object ObjectID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaRelation Interface
ISchemaRelation Members


ParentTable Property (ISchemaRelation) | fcSDK Documentation

ParentTable Property (ISchemaRelation)

Syntax

'Declaration

ReadOnly Property ParentTable As ISchemaTable

ISchemaTable ParentTable {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaRelation Interface
ISchemaRelation Members


Rank Property (ISchemaRelation) | fcSDK Documentation

Rank Property (ISchemaRelation)

Syntax

'Declaration
ReadOnly Property Rank As Integer

int Rank {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaRelation Interface
ISchemaRelation Members


SourceTable Property (ISchemaRelation) | fcSDK Documentation

SourceTable Property (ISchemaRelation)

Syntax

'Declaration

ReadOnly Property SourceTable As ISchemaTable

ISchemaTable SourceTable {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaRelation Interface
ISchemaRelation Members


TargetTable Property (ISchemaRelation) | fcSDK Documentation

TargetTable Property (ISchemaRelation)

Syntax

'Declaration

ReadOnly Property TargetTable As ISchemaTable

ISchemaTable TargetTable {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaRelation Interface
ISchemaRelation Members


ISchemaRelationCollection Interface | fcSDK Documentation

ISchemaRelationCollection Interface

Syntax

'Declaration

<DefaultMemberAttribute("Item")>
Public Interface ISchemaRelationCollection

[DefaultMemberAttribute("Item")]
public interface ISchemaRelationCollection

Requirements

Namespace: FChoice.Foundation.Schema

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ISchemaRelationCollection Members
FChoice.Foundation.Schema Namespace


ISchemaRelationCollection Interface Members | fcSDK Documentation

ISchemaRelationCollection Interface Members

The following tables list the members exposed by ISchemaRelationCollection.

Public Properties

 | Name | Description
Property | Item |

Reference

ISchemaRelationCollection Interface
FChoice.Foundation.Schema Namespace


Item Property (ISchemaRelationCollection) | fcSDK Documentation

Item Property (ISchemaRelationCollection)

Syntax

'Declaration
ReadOnly Default Property Item( _
   ByVal _name_ As String _
) As ISchemaRelation

ISchemaRelation this[
   string _name_
]; {get;}

Parameters

name

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaRelationCollection Interface
ISchemaRelationCollection Members


ISchemaTable Interface | fcSDK Documentation

ISchemaTable Interface

Syntax

'Declaration

Public Interface ISchemaTable
   Inherits ISchemaTableBase

public interface ISchemaTable : ISchemaTableBase

Requirements

Namespace: FChoice.Foundation.Schema

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ISchemaTable Members
FChoice.Foundation.Schema Namespace


ISchemaTable Interface Members | fcSDK Documentation

ISchemaTable Interface Members

The following tables list the members exposed by ISchemaTable.

Public Properties

 | Name | Description
Property | Relationships |
Property | Views |

Reference

ISchemaTable Interface
FChoice.Foundation.Schema Namespace


Relationships Property (ISchemaTable) | fcSDK Documentation

Relationships Property (ISchemaTable)

Syntax

'Declaration

ReadOnly Property Relationships As ISchemaRelationCollection

ISchemaRelationCollection Relationships {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaTable Interface
ISchemaTable Members


Views Property (ISchemaTable) | fcSDK Documentation

Views Property (ISchemaTable)

Syntax

'Declaration

ReadOnly Property Views As ISchemaViewCollection

ISchemaViewCollection Views {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaTable Interface
ISchemaTable Members


ISchemaTableBase Interface | fcSDK Documentation

ISchemaTableBase Interface

Syntax

'Declaration

Public Interface ISchemaTableBase

public interface ISchemaTableBase

Requirements

Namespace: FChoice.Foundation.Schema

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ISchemaTableBase Members
FChoice.Foundation.Schema Namespace


ISchemaTableBase Interface Members | fcSDK Documentation

ISchemaTableBase Interface Members

The following tables list the members exposed by ISchemaTableBase.

Public Properties

 | Name | Description
Property | Description |
Property | Fields |
Property | Flags |
Property | IsDataRestricted |
Property | Name |
Property | Number |
Property | ObjectID |
Property | Subsystem |

Reference

ISchemaTableBase Interface
FChoice.Foundation.Schema Namespace


Description Property (ISchemaTableBase) | fcSDK Documentation

Description Property (ISchemaTableBase)

Syntax

'Declaration
ReadOnly Property Description As String

string Description {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaTableBase Interface
ISchemaTableBase Members


Fields Property (ISchemaTableBase) | fcSDK Documentation

Fields Property (ISchemaTableBase)

Syntax

'Declaration

ReadOnly Property Fields As ISchemaFieldCollection

ISchemaFieldCollection Fields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaTableBase Interface
ISchemaTableBase Members


Flags Property (ISchemaTableBase) | fcSDK Documentation

Flags Property (ISchemaTableBase)

Syntax

'Declaration

ReadOnly Property Flags As Object

object Flags {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaTableBase Interface
ISchemaTableBase Members


IsDataRestricted Property (ISchemaTableBase) | fcSDK Documentation

IsDataRestricted Property (ISchemaTableBase)

Syntax

'Declaration

ReadOnly Property IsDataRestricted As Boolean

bool IsDataRestricted {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaTableBase Interface
ISchemaTableBase Members


Name Property (ISchemaTableBase) | fcSDK Documentation

Name Property (ISchemaTableBase)

Syntax

'Declaration

ReadOnly Property Name As String

string Name {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaTableBase Interface
ISchemaTableBase Members


Number Property | fcSDK Documentation

Number Property

Syntax

'Declaration
ReadOnly Property Number As Object

object Number {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaTableBase Interface
ISchemaTableBase Members


ObjectID Property (ISchemaTableBase) | fcSDK Documentation

ObjectID Property (ISchemaTableBase)

Syntax

'Declaration
ReadOnly Property ObjectID As Object

object ObjectID {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaTableBase Interface
ISchemaTableBase Members


Subsystem Property | fcSDK Documentation

Subsystem Property

Syntax

'Declaration
ReadOnly Property Subsystem As String

string Subsystem {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaTableBase Interface
ISchemaTableBase Members


ISchemaTableCollection Interface | fcSDK Documentation

ISchemaTableCollection Interface

Syntax

'Declaration

<DefaultMemberAttribute("Item")>
Public Interface ISchemaTableCollection

[DefaultMemberAttribute("Item")]
public interface ISchemaTableCollection

Requirements

Namespace: FChoice.Foundation.Schema

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ISchemaTableCollection Members
FChoice.Foundation.Schema Namespace


ISchemaTableCollection Interface Members | fcSDK Documentation

ISchemaTableCollection Interface Members

The following tables list the members exposed by ISchemaTableCollection.

Public Properties

 | Name | Description
Property | Item | Overloaded.

Public Methods

 | Name | Description
Method | GetByNumber |

Reference

ISchemaTableCollection Interface
FChoice.Foundation.Schema Namespace


GetByNumber Method (ISchemaTableCollection) | fcSDK Documentation

GetByNumber Method (ISchemaTableCollection)

Syntax

'Declaration
Function GetByNumber( _
   ByVal _num_ As Object _
) As ISchemaTable

ISchemaTable GetByNumber(
   object _num_
)

Parameters

num

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaTableCollection Interface
ISchemaTableCollection Members


Item Property (ISchemaTableCollection) | fcSDK Documentation

Item Property (ISchemaTableCollection)

Overload List

Overload | Description
Item(String) |
Item(Int32) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaTableCollection Interface
ISchemaTableCollection Members


Item(String) Property | fcSDK Documentation

Item(String) Property

Syntax

'Declaration

Overloads ReadOnly Property Item( _
   ByVal _name_ As String _
) As ISchemaTable

ISchemaTable Item(
   string _name_
) {get;}

Parameters

name

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaTableCollection Interface
ISchemaTableCollection Members
Overload List


Item(Int32) Property | fcSDK Documentation

Item(Int32) Property

Syntax

'Declaration

Overloads ReadOnly Property Item( _
   ByVal _index_ As Integer _
) As ISchemaTable

ISchemaTable Item(
   int _index_
) {get;}

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaTableCollection Interface
ISchemaTableCollection Members
Overload List


ISchemaView Interface | fcSDK Documentation

ISchemaView Interface

Syntax

'Declaration

Public Interface ISchemaView
   Inherits ISchemaTableBase

public interface ISchemaView : ISchemaTableBase

Requirements

Namespace: FChoice.Foundation.Schema

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ISchemaView Members
FChoice.Foundation.Schema Namespace


ISchemaView Interface Members | fcSDK Documentation

ISchemaView Interface Members

The following tables list the members exposed by ISchemaView.

Public Properties

 | Name | Description
Property | Joins |

Reference

ISchemaView Interface
FChoice.Foundation.Schema Namespace


Joins Property (ISchemaView) | fcSDK Documentation

Joins Property (ISchemaView)

Syntax

'Declaration

ReadOnly Property Joins As ISchemaViewJoinCollection

ISchemaViewJoinCollection Joins {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaView Interface
ISchemaView Members


ISchemaViewCollection Interface | fcSDK Documentation

ISchemaViewCollection Interface

Syntax

'Declaration

<DefaultMemberAttribute("Item")>
Public Interface ISchemaViewCollection

[DefaultMemberAttribute("Item")]
public interface ISchemaViewCollection

Requirements

Namespace: FChoice.Foundation.Schema

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ISchemaViewCollection Members
FChoice.Foundation.Schema Namespace


ISchemaViewCollection Interface Members | fcSDK Documentation

ISchemaViewCollection Interface Members

The following tables list the members exposed by ISchemaViewCollection.

Public Properties

 | Name | Description
Property | Item | Overloaded.

Public Methods

 | Name | Description
Method | GetByNumber |

Reference

ISchemaViewCollection Interface
FChoice.Foundation.Schema Namespace


GetByNumber Method (ISchemaViewCollection) | fcSDK Documentation

GetByNumber Method (ISchemaViewCollection)

Syntax

'Declaration
Function GetByNumber( _
   ByVal _number_ As Object _
) As ISchemaView

ISchemaView GetByNumber(
   object _number_
)

Parameters

number

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaViewCollection Interface
ISchemaViewCollection Members


Item Property (ISchemaViewCollection) | fcSDK Documentation

Item Property (ISchemaViewCollection)

Overload List

Overload | Description
Item(String) |
Item(Int32) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaViewCollection Interface
ISchemaViewCollection Members


Item(String) Property | fcSDK Documentation

Item(String) Property

Syntax

'Declaration

Overloads ReadOnly Property Item( _
   ByVal _name_ As String _
) As ISchemaView

ISchemaView Item(
   string _name_
) {get;}

Parameters

name

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaViewCollection Interface
ISchemaViewCollection Members
Overload List


Item(Int32) Property | fcSDK Documentation

Item(Int32) Property

Syntax

'Declaration

Overloads ReadOnly Property Item( _
   ByVal _number_ As Integer) As ISchemaView

ISchemaView Item(
   int _number_
) {get;}

Parameters

number

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaViewCollection Interface
ISchemaViewCollection Members
Overload List


ISchemaViewJoin Interface | fcSDK Documentation

ISchemaViewJoin Interface

Syntax

'Declaration

Public Interface ISchemaViewJoin

public interface ISchemaViewJoin

Requirements

Namespace: FChoice.Foundation.Schema

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ISchemaViewJoin Members
FChoice.Foundation.Schema Namespace


ISchemaViewJoin Interface Members | fcSDK Documentation

ISchemaViewJoin Interface Members

The following tables list the members exposed by ISchemaViewJoin.

Public Properties

 | Name | Description
Property | Description |
Property | Flags |
Property | IsPrimaryOuter |
Property | IsSecondaryOuter |
Property | PrimaryAlias |
Property | PrimaryTable |
Property | SecondaryAlias |
Property | SecondaryTable |

Reference

ISchemaViewJoin Interface
FChoice.Foundation.Schema Namespace


Description Property (ISchemaViewJoin) | fcSDK Documentation

Description Property (ISchemaViewJoin)

Syntax

'Declaration
ReadOnly Property Description As String

string Description {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaViewJoin Interface
ISchemaViewJoin Members


Flags Property (ISchemaViewJoin) | fcSDK Documentation

Flags Property (ISchemaViewJoin)

Syntax

'Declaration

ReadOnly Property Flags As Object

object Flags {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaViewJoin Interface
ISchemaViewJoin Members


IsPrimaryOuter Property | fcSDK Documentation

IsPrimaryOuter Property

Syntax

'Declaration
ReadOnly Property IsPrimaryOuter As Boolean

bool IsPrimaryOuter {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaViewJoin Interface
ISchemaViewJoin Members


IsSecondaryOuter Property | fcSDK Documentation

IsSecondaryOuter Property

Syntax

'Declaration

ReadOnly Property IsSecondaryOuter As Boolean

bool IsSecondaryOuter {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaViewJoin Interface
ISchemaViewJoin Members


PrimaryAlias Property (ISchemaViewJoin) | fcSDK Documentation

PrimaryAlias Property (ISchemaViewJoin)

Syntax

'Declaration

ReadOnly Property PrimaryAlias As String

string PrimaryAlias {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaViewJoin Interface
ISchemaViewJoin Members


PrimaryTable Property | fcSDK Documentation

PrimaryTable Property

Syntax

'Declaration

ReadOnly Property PrimaryTable As ISchemaTable

ISchemaTable PrimaryTable {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaViewJoin Interface
ISchemaViewJoin Members


SecondaryAlias Property (ISchemaViewJoin) | fcSDK Documentation

SecondaryAlias Property (ISchemaViewJoin)

Syntax

'Declaration

ReadOnly Property SecondaryAlias As String

string SecondaryAlias {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaViewJoin Interface
ISchemaViewJoin Members


SecondaryTable Property | fcSDK Documentation

SecondaryTable Property

Syntax

'Declaration

ReadOnly Property SecondaryTable As ISchemaTable

ISchemaTable SecondaryTable {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ISchemaViewJoin Interface
ISchemaViewJoin Members


ISchemaViewJoinCollection Interface | fcSDK Documentation

ISchemaViewJoinCollection Interface

Syntax

'Declaration

Public Interface ISchemaViewJoinCollection

public interface ISchemaViewJoinCollection

Requirements

Namespace: FChoice.Foundation.Schema

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: fcSDK (in C:\dovetail\dovetail-sdk\build\Release\fcSDK.dll)

Reference

ISchemaViewJoinCollection Members
FChoice.Foundation.Schema Namespace


ISchemaViewJoinCollection Interface Members | fcSDK Documentation

ISchemaViewJoinCollection Interface Members

The following tables list the members exposed by ISchemaViewJoinCollection.

Reference

ISchemaViewJoinCollection Interface
FChoice.Foundation.Schema Namespace


FChoice.Toolkits.Clarify Namespace | fcSDK Documentation

FChoice.Toolkits.Clarify Namespace

Root namespace for all the API Toolkit functionality contained in the fcSDK. Shared objects such as ToolkitResult and AdditionalFields are contained in this namespace. For more information about a particular toolkit, please consult its individual namespace.

Classes

 | Class | Description
Class | AdditionalFields | Many APIs exposes an instance of this class which is used to allow setting of user defined fields ('x_fields') in a customized Clarify environment. It is also possible to override the fields that are set by the API.
Class | ClarifyToolkitException |
Class | CommunicationAddress |
Class | ConstructorIndexAttribute |
Class | EmailIn |
Class | Location |
Class | LocationCollection |
Class | PartInfo |
Class | PartRequestInfo |
Class | PropertyBitValueAttribute |
Class | SimplifiedAdditionalField |
Class | SimplifiedAdditionalFields |
Class | ToolkitBase | This class is used internally and not meant to be created by end users.
Class | ToolkitResult | Every Toolkit API method will return this class or one derived from it as their result.
Class | ToolkitResultPropertyAttribute |
Class | Utility |

Enumerations

 | Enumeration | Description
Enumeration | AdditionalFieldType | The type of database field being updated by the AdditionalField property.
Enumeration | BillingFrequency | The billing frequency of the Contract Schedule being created or updated.
Enumeration | BillingOption | The billing option of the Contract Schedule being created or updated.
Enumeration | CaseObjectType | Which type of case object is being affected
Enumeration | CommunicationAutoExec |
Enumeration | CommunicationDeliveryStatus |
Enumeration | CommunicationDirection |
Enumeration | CommunicationPriority |
Enumeration | CommunicationRoleType |
Enumeration | CRCondition |
Enumeration | EcoItemAppliesTo | The type of object the ECO item being created or updated applies to.
Enumeration | LeadSiteType | What type of Site is being linked to the Lead
Enumeration | OpportunityStage | Stage the opportunity being created or modified is in.
Enumeration | PartAuthorizationLevel |
Enumeration | PartRepairType | Repair Type of the Part being created or modified.
Enumeration | PartRequestCondition |
Enumeration | PartRequestType |
Enumeration | PartRevisionStatus | Status of the Part Revision
Enumeration | PriceInstanceType | Type of Pricing being used for the Price Instance
Enumeration | RepairPartDisposition | What to do with the repair part when the repair is completed.
Enumeration | SiteStatus | The status of the Site being created or modified.
Enumeration | SiteType | The type of the Site being created of modified.

Reference

FChoice.Toolkits.Clarify Assembly


AdditionalFields Class | fcSDK Documentation

AdditionalFields Class

Many APIs exposes an instance of this class which is used to allow setting of user defined fields ('x_fields') in a customized Clarify environment. It is also possible to override the fields that are set by the API.

Syntax

'Declaration

Public Class AdditionalFields

public class AdditionalFields

Remarks

To set an additional field simply call the Append method on the API's AdditionalField property.

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.AdditionalFields

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

AdditionalFields Members
FChoice.Toolkits.Clarify Namespace


AdditionalFields Class Members | fcSDK Documentation

AdditionalFields Class Members

The following tables list the members exposed by AdditionalFields.

Public Methods

 | Name | Description
Public Method | Append | Adds a field to be updated during the API invocation.
Public Method | Clone | This method is used internally and not meant to be used by end users.

Reference

AdditionalFields Class
FChoice.Toolkits.Clarify Namespace


Append Method | fcSDK Documentation

Append Method

Name of the database field to update.

Data type of the field being updated.

Value to put into the database field. This must be the appropriate type

Adds a field to be updated during the API invocation.

Syntax

'Declaration

Public Sub Append( _
   ByVal _field_ As String, _
   ByVal _fieldType_ As AdditionalFieldType, _
   ByVal _val_ As Object _
)

public void Append(
   string _field_,
   AdditionalFieldType _fieldType_,
   object _val_
)

Parameters

field

Name of the database field to update.

fieldType

Data type of the field being updated.

val

Value to put into the database field. This must be the appropriate type

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AdditionalFields Class
AdditionalFields Members


Clone Method (AdditionalFields) | fcSDK Documentation

Clone Method (AdditionalFields)

This method is used internally and not meant to be used by end users.

Syntax

'Declaration

Public Function Clone() As Object

public object Clone()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AdditionalFields Class
AdditionalFields Members


ClarifyToolkitException Class | fcSDK Documentation

ClarifyToolkitException Class

Syntax

'Declaration

Public Class ClarifyToolkitException
   Inherits System.Exception

public class ClarifyToolkitException : System.Exception

Inheritance Hierarchy

System.Object
System.Exception
FChoice.Toolkits.Clarify.ClarifyToolkitException

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ClarifyToolkitException Members
FChoice.Toolkits.Clarify Namespace


ClarifyToolkitException Class Members | fcSDK Documentation

ClarifyToolkitException Class Members

The following tables list the members exposed by ClarifyToolkitException.

Public Constructors

 | Name | Description
Public Constructor | ClarifyToolkitException Constructor |

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)

Reference

ClarifyToolkitException Class
FChoice.Toolkits.Clarify Namespace


ClarifyToolkitException Constructor | fcSDK Documentation

ClarifyToolkitException Constructor

Syntax

'Declaration

Public Function New( _
   ByVal _message_ As String _
)

public ClarifyToolkitException(
   string _message_
)

Parameters

message

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyToolkitException Class
ClarifyToolkitException Members


CommunicationAddress Class | fcSDK Documentation

CommunicationAddress Class

Syntax

'Declaration

Public Class CommunicationAddress

public class CommunicationAddress

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.CommunicationAddress

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CommunicationAddress Members
FChoice.Toolkits.Clarify Namespace


CommunicationAddress Class Members | fcSDK Documentation

CommunicationAddress Class Members

The following tables list the members exposed by CommunicationAddress.

Public Constructors

 | Name | Description
Public Constructor | CommunicationAddress Constructor |

Public Properties

 | Name | Description
Public Property | CommunicationRoleType |
Public Property | EmailAddress |

Reference

CommunicationAddress Class
FChoice.Toolkits.Clarify Namespace


CommunicationAddress Constructor | fcSDK Documentation

CommunicationAddress Constructor

Syntax

'Declaration

Public Function New( _
   ByVal _communicationRoleType_ As CommunicationRoleType, _
   ByVal _emailAddress_ As String _
)

public CommunicationAddress(
   CommunicationRoleType _communicationRoleType_,
   string _emailAddress_
)

Parameters

communicationRoleType

emailAddress

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CommunicationAddress Class
CommunicationAddress Members


CommunicationRoleType Property | fcSDK Documentation

CommunicationRoleType Property

Syntax

'Declaration

Public Property CommunicationRoleType As CommunicationRoleType

public CommunicationRoleType CommunicationRoleType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CommunicationAddress Class
CommunicationAddress Members


EmailAddress Property | fcSDK Documentation

EmailAddress Property

Syntax

'Declaration

Public Property EmailAddress As String

public string EmailAddress {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CommunicationAddress Class
CommunicationAddress Members


ConstructorIndexAttribute Class | fcSDK Documentation

ConstructorIndexAttribute Class

Syntax

'Declaration

<AttributeUsageAttribute(ValidOn=AttributeTargets.Constructor,
   AllowMultiple=False,
   Inherited=True)>
Public Class ConstructorIndexAttribute
   Inherits System.Attribute

[AttributeUsageAttribute(ValidOn=AttributeTargets.Constructor,
   AllowMultiple=false,
   Inherited=true)]
public class ConstructorIndexAttribute : System.Attribute

Inheritance Hierarchy

System.Object
System.Attribute
FChoice.Toolkits.Clarify.ConstructorIndexAttribute

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ConstructorIndexAttribute Members
FChoice.Toolkits.Clarify Namespace


ConstructorIndexAttribute Class Members | fcSDK Documentation

ConstructorIndexAttribute Class Members

The following tables list the members exposed by ConstructorIndexAttribute.

Public Constructors

 | Name | Description
Public Constructor | ConstructorIndexAttribute Constructor |

Public Fields

 | Name | Description
Public Field | Index |

Public Properties

 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)

Reference

ConstructorIndexAttribute Class
FChoice.Toolkits.Clarify Namespace


ConstructorIndexAttribute Constructor | fcSDK Documentation

ConstructorIndexAttribute Constructor

Syntax

'Declaration

Public Function New( _
   ByVal _index_ As Integer _
)

public ConstructorIndexAttribute(
   int _index_
)

Parameters

index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConstructorIndexAttribute Class
ConstructorIndexAttribute Members


Index Field | fcSDK Documentation

Index Field

Syntax

'Declaration

Public Index As Integer

public int Index

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ConstructorIndexAttribute Class
ConstructorIndexAttribute Members


EmailIn Class | fcSDK Documentation

EmailIn Class

Syntax

'Declaration

Public Class EmailIn

public class EmailIn

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.EmailIn

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

EmailIn Members
FChoice.Toolkits.Clarify Namespace


EmailIn Class Members | fcSDK Documentation

EmailIn Class Members

The following tables list the members exposed by EmailIn.

Public Constructors

 | Name | Description
Public Constructor | EmailIn Constructor |

Reference

EmailIn Class
FChoice.Toolkits.Clarify Namespace


EmailIn Constructor | fcSDK Documentation

EmailIn Constructor

Syntax

'Declaration

Public Function New()

public EmailIn()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

EmailIn Class
EmailIn Members


Location Class | fcSDK Documentation

Location Class

Syntax

'Declaration

Public Class Location

public class Location

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Location

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

Location Members
FChoice.Toolkits.Clarify Namespace


Location Class Members | fcSDK Documentation

Location Class Members

The following tables list the members exposed by Location.

Public Constructors

 | Name | Description
Public Constructor | Location Constructor | Overloaded.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | EMPTY |
Public Field | PRIMARY_BIN_SUGGESTION_NAME |

Public Properties

 | Name | Description
Public Property | BinName |
Public Property | ContainerIDNum |
Public Property | IsPrimaryBinSuggestion |
Public Property | LocationName |

Public Methods

 | Name | Description
Public Method | ToString |

Reference

Location Class
FChoice.Toolkits.Clarify Namespace


Location Constructor | fcSDK Documentation

Location Constructor

Overload List

Overload | Description
Location Constructor() |
Location Constructor(String) |
Location Constructor(String,Boolean) |
Location Constructor(String,String) |
Location Constructor(String,String,String) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Location Class
Location Members


Location Constructor() | fcSDK Documentation

Location Constructor()

Syntax

'Declaration

Public Function New()

public Location()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Location Class
Location Members
Overload List


Location Constructor(String) | fcSDK Documentation

Location Constructor(String)

Syntax

'Declaration

Public Function New( _
   ByVal _locationName_ As String _
)

public Location(
   string _locationName_
)

Parameters

locationName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Location Class
Location Members
Overload List


Location Constructor(String,Boolean) | fcSDK Documentation

Location Constructor(String,Boolean)

Syntax

'Declaration

Public Function New( _
   ByVal _locationName_ As String, _
   ByVal _isPrimaryBinSuggestion_ As Boolean _
)

public Location(
   string _locationName_,
   bool _isPrimaryBinSuggestion_
)

Parameters

locationName

isPrimaryBinSuggestion

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Location Class
Location Members
Overload List


Location Constructor(String,String) | fcSDK Documentation

Location Constructor(String,String)

Syntax

'Declaration

Public Function New( _
   ByVal _locationName_ As String, _
   ByVal _binName_ As String _
)

public Location(
   string _locationName_,
   string _binName_
)

Parameters

locationName

binName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Location Class
Location Members
Overload List


Location Constructor(String,String,String) | fcSDK Documentation

Location Constructor(String,String,String)

Syntax

'Declaration

Public Function New( _
   ByVal _locationName_ As String, _
   ByVal _containerName_ As String, _
   ByVal _containerIDNum_ As String _
)

public Location(
   string _locationName_,
   string _containerName_,
   string _containerIDNum_
)

Parameters

locationName

containerName

containerIDNum

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Location Class
Location Members
Overload List


ToString Method (Location) | fcSDK Documentation

ToString Method (Location)

Syntax

'Declaration

Public Overrides Function ToString() As String

public override string ToString()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Location Class
Location Members
Base Implementation in ToString


BinName Property (Location) | fcSDK Documentation

BinName Property (Location)

Syntax

'Declaration

Public Property BinName As String

public string BinName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Location Class
Location Members


ContainerIDNum Property | fcSDK Documentation

ContainerIDNum Property

Syntax

'Declaration

Public Property ContainerIDNum As String

public string ContainerIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Location Class
Location Members


IsPrimaryBinSuggestion Property | fcSDK Documentation

IsPrimaryBinSuggestion Property

Syntax

'Declaration

Public Property IsPrimaryBinSuggestion As Boolean

public bool IsPrimaryBinSuggestion {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Location Class
Location Members


LocationName Property (Location) | fcSDK Documentation

LocationName Property (Location)

Syntax

'Declaration

Public Property LocationName As String

public string LocationName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Location Class
Location Members


EMPTY Field (Location) | fcSDK Documentation

EMPTY Field (Location)

Syntax

'Declaration

Public Shared ReadOnly EMPTY As Location

public static readonly Location EMPTY

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Location Class Location Members


PRIMARY_BIN_SUGGESTION_NAME Field | fcSDK Documentation

PRIMARY_BIN_SUGGESTION_NAME Field

Syntax

'Declaration

Public Const PRIMARY_BIN_SUGGESTION_NAME As String

public const string PRIMARY_BIN_SUGGESTION_NAME

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Location Class
Location Members


LocationCollection Class | fcSDK Documentation

LocationCollection Class

Syntax

'Declaration

Public Class LocationCollection
   Inherits System.Collections.ObjectModel.Collection(Of Location)

public class LocationCollection : System.Collections.ObjectModel.Collection<Location>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection
FChoice.Toolkits.Clarify.LocationCollection

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LocationCollection Members
FChoice.Toolkits.Clarify Namespace


LocationCollection Class Members | fcSDK Documentation

LocationCollection Class Members

The following tables list the members exposed by LocationCollection.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection)
Public Property | IsDirty |
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection)

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | ToLegacyString |

Reference

LocationCollection Class
FChoice.Toolkits.Clarify Namespace


Add Method (LocationCollection) | fcSDK Documentation

Add Method (LocationCollection)

Overload List

Overload | Description
Add(String) |
Add(String,String) |
Add(String,String,String) |
Add(Location) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocationCollection Class
LocationCollection Members


Add(String) Method | fcSDK Documentation

Add(String) Method

Syntax

'Declaration

Public Overloads Sub Add( _
   ByVal _location_ As String _
)

public void Add(
   string _location_
)

Parameters

location

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocationCollection Class
LocationCollection Members
Overload List


Add(String,String) Method | fcSDK Documentation

Add(String,String) Method

Syntax

'Declaration

Public Overloads Sub Add( _
   ByVal _location_ As String, _
   ByVal _binName_ As String _
)

public void Add(
   string _location_,
   string _binName_
)

Parameters

location

binName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocationCollection Class
LocationCollection Members
Overload List


Add(String,String,String) Method | fcSDK Documentation

Add(String,String,String) Method

Syntax

'Declaration

Public Overloads Sub Add( _
   ByVal _location_ As String, _
   ByVal _binName_ As String, _
   ByVal _containerID_ As String _
)

public void Add(
   string _location_,
   string _binName_,
   string _containerID_
)

Parameters

location

binName

containerID

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocationCollection Class
LocationCollection Members
Overload List


Add(Location) Method | fcSDK Documentation

Add(Location) Method

Syntax

'Declaration

Public Overloads Shadows Sub Add( _
   ByVal _loc_ As Location _
)

public new void Add(
   Location _loc_
)

Parameters

loc

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocationCollection Class
LocationCollection Members
Overload List


ToLegacyString Method | fcSDK Documentation

ToLegacyString Method

Syntax

'Declaration

Public Function ToLegacyString() As String

public string ToLegacyString()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocationCollection Class
LocationCollection Members


IsDirty Property (LocationCollection) | fcSDK Documentation

IsDirty Property (LocationCollection)

Syntax

'Declaration

Public ReadOnly Property IsDirty As Boolean

public bool IsDirty {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LocationCollection Class
LocationCollection Members


PartInfo Class | fcSDK Documentation

PartInfo Class

Syntax

'Declaration

Public Class PartInfo

public class PartInfo

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.PartInfo

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

PartInfo Members
FChoice.Toolkits.Clarify Namespace


PartInfo Class Members | fcSDK Documentation

PartInfo Class Members

The following tables list the members exposed by PartInfo.

Public Constructors

 | Name | Description
Public Constructor | PartInfo Constructor |

Public Fields

 | Name | Description
Public Field | modSetupResult |
Public Field | PartDomain |
Public Field | PartNotes |
Public Field | PartNumber |
Public Field | PartRevision |
Public Field | partSetupResult |
Public Field | Price |
Public Field | PriceProgram |
Public Field | priceSetupResult |
Public Field | PriceType |
Public Field | Quantity |
Public Field | RepairType |

Reference

PartInfo Class
FChoice.Toolkits.Clarify Namespace


PartInfo Constructor | fcSDK Documentation

PartInfo Constructor

Syntax

'Declaration

Public Function New()

public PartInfo()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartInfo Class
PartInfo Members


modSetupResult Field | fcSDK Documentation

modSetupResult Field

Syntax

'Declaration

Public modSetupResult As ToolkitResult

public ToolkitResult modSetupResult

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartInfo Class
PartInfo Members


PartDomain Field (PartInfo) | fcSDK Documentation

PartDomain Field (PartInfo)

Syntax

'Declaration

Public PartDomain As String

public string PartDomain

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartInfo Class
PartInfo Members


PartNotes Field | fcSDK Documentation

PartNotes Field

Syntax

'Declaration

Public PartNotes As String

public string PartNotes

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartInfo Class
PartInfo Members


PartNumber Field (PartInfo) | fcSDK Documentation

PartNumber Field (PartInfo)

Syntax

'Declaration

Public PartNumber As String

public string PartNumber

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartInfo Class
PartInfo Members


PartRevision Field (PartInfo) | fcSDK Documentation

PartRevision Field (PartInfo)

Syntax

'Declaration

Public PartRevision As String

public string PartRevision

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartInfo Class
PartInfo Members


partSetupResult Field | fcSDK Documentation

partSetupResult Field

Syntax

'Declaration

Public partSetupResult As ToolkitResult

public ToolkitResult partSetupResult

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartInfo Class
PartInfo Members


Price Field | fcSDK Documentation

Price Field

Syntax

'Declaration

Public Price As Decimal

public decimal Price

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartInfo Class
PartInfo Members


PriceProgram Field | fcSDK Documentation

PriceProgram Field

Syntax

'Declaration

Public PriceProgram As String

public string PriceProgram

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartInfo Class
PartInfo Members


priceSetupResult Field | fcSDK Documentation

priceSetupResult Field

Syntax

'Declaration

Public priceSetupResult As ToolkitResult

public ToolkitResult priceSetupResult

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartInfo Class
PartInfo Members


PriceType Field | fcSDK Documentation

PriceType Field

Syntax

'Declaration

Public PriceType As PriceInstanceType

public PriceInstanceType PriceType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartInfo Class
PartInfo Members


Quantity Field | fcSDK Documentation

Quantity Field

Syntax

'Declaration

Public Quantity As Integer

public int Quantity

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartInfo Class
PartInfo Members


RepairType Field | fcSDK Documentation

RepairType Field

Syntax

'Declaration

Public RepairType As PartRepairType

public PartRepairType RepairType

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartInfo Class
PartInfo Members


PartRequestInfo Class | fcSDK Documentation

PartRequestInfo Class

Syntax

'Declaration

Public Class PartRequestInfo

public class PartRequestInfo

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.PartRequestInfo

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

PartRequestInfo Members
FChoice.Toolkits.Clarify Namespace


PartRequestInfo Class Members | fcSDK Documentation

PartRequestInfo Class Members

The following tables list the members exposed by PartRequestInfo.

Public Constructors

 | Name | Description
Public Constructor | PartRequestInfo Constructor |

Public Fields

 | Name | Description
Public Field | ContactFirstName |
Public Field | ContactLastName |
Public Field | ContactPhone |
Public Field | ContactResult |
Public Field | PartDomain |
Public Field | PartNumber |
Public Field | PartQuantity |
Public Field | PartRequestDetailResult |
Public Field | PartRequestHeaderResult |
Public Field | PartRevision |
Public Field | PartRevisionResult |
Public Field | SiteResult |

Reference

PartRequestInfo Class
FChoice.Toolkits.Clarify Namespace


PartRequestInfo Constructor | fcSDK Documentation

PartRequestInfo Constructor

Syntax

'Declaration

Public Function New()

public PartRequestInfo()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartRequestInfo Class
PartRequestInfo Members


ContactFirstName Field | fcSDK Documentation

ContactFirstName Field

Syntax

'Declaration

Public ContactFirstName As String

public string ContactFirstName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartRequestInfo Class
PartRequestInfo Members


ContactLastName Field | fcSDK Documentation

ContactLastName Field

Syntax

'Declaration

Public ContactLastName As String

public string ContactLastName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartRequestInfo Class
PartRequestInfo Members


ContactPhone Field | fcSDK Documentation

ContactPhone Field

Syntax

'Declaration

Public ContactPhone As String

public string ContactPhone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartRequestInfo Class
PartRequestInfo Members


ContactResult Field | fcSDK Documentation

ContactResult Field

Syntax

'Declaration

Public ContactResult As ToolkitResult

public ToolkitResult ContactResult

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartRequestInfo Class
PartRequestInfo Members


PartDomain Field (PartRequestInfo) | fcSDK Documentation

PartDomain Field (PartRequestInfo)

Syntax

'Declaration

Public PartDomain As String

public string PartDomain

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartRequestInfo Class
PartRequestInfo Members


PartNumber Field (PartRequestInfo) | fcSDK Documentation

PartNumber Field (PartRequestInfo)

Syntax

'Declaration

Public PartNumber As String

public string PartNumber

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartRequestInfo Class
PartRequestInfo Members


PartQuantity Field | fcSDK Documentation

PartQuantity Field

Syntax

'Declaration

Public PartQuantity As Integer

public int PartQuantity

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartRequestInfo Class
PartRequestInfo Members


PartRequestDetailResult Field | fcSDK Documentation

PartRequestDetailResult Field

Syntax

'Declaration

Public PartRequestDetailResult As ToolkitResult

public ToolkitResult PartRequestDetailResult

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartRequestInfo Class
PartRequestInfo Members


PartRequestHeaderResult Field | fcSDK Documentation

PartRequestHeaderResult Field

Syntax

'Declaration

Public PartRequestHeaderResult As ToolkitResult

public ToolkitResult PartRequestHeaderResult

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartRequestInfo Class
PartRequestInfo Members


PartRevision Field (PartRequestInfo) | fcSDK Documentation

PartRevision Field (PartRequestInfo)

Syntax

'Declaration

Public PartRevision As String

public string PartRevision

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartRequestInfo Class
PartRequestInfo Members


PartRevisionResult Field | fcSDK Documentation

PartRevisionResult Field

Syntax

'Declaration

Public PartRevisionResult As ToolkitResult

public ToolkitResult PartRevisionResult

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartRequestInfo Class
PartRequestInfo Members


SiteResult Field | fcSDK Documentation

SiteResult Field

Syntax

'Declaration

Public SiteResult As ToolkitResult

public ToolkitResult SiteResult

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartRequestInfo Class
PartRequestInfo Members


PropertyBitValueAttribute Class | fcSDK Documentation

PropertyBitValueAttribute Class

Syntax

'Declaration

<AttributeUsageAttribute(ValidOn=AttributeTargets.Property,
   AllowMultiple=False,
   Inherited=True)>
Public Class PropertyBitValueAttribute
   Inherits System.Attribute

[AttributeUsageAttribute(ValidOn=AttributeTargets.Property,
   AllowMultiple=false,
   Inherited=true)]
public class PropertyBitValueAttribute : System.Attribute

Inheritance Hierarchy

System.Object
System.Attribute
FChoice.Toolkits.Clarify.PropertyBitValueAttribute

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

PropertyBitValueAttribute Members
FChoice.Toolkits.Clarify Namespace


PropertyBitValueAttribute Class Members | fcSDK Documentation

PropertyBitValueAttribute Class Members

The following tables list the members exposed by PropertyBitValueAttribute.

Public Constructors

 | Name | Description
Public Constructor | PropertyBitValueAttribute Constructor |

Public Fields

 | Name | Description
Public Field | Value |

Public Properties

 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)

Reference

PropertyBitValueAttribute Class
FChoice.Toolkits.Clarify Namespace


PropertyBitValueAttribute Constructor | fcSDK Documentation

PropertyBitValueAttribute Constructor

Syntax

'Declaration

Public Function New( _
   ByVal _val_ As Integer _
)

public PropertyBitValueAttribute(
   int _val_
)

Parameters

val

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PropertyBitValueAttribute Class
PropertyBitValueAttribute Members


Value Field | fcSDK Documentation

Value Field

Syntax

'Declaration

Public Value As Integer

public int Value

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PropertyBitValueAttribute Class
PropertyBitValueAttribute Members


SimplifiedAdditionalField Class | fcSDK Documentation

SimplifiedAdditionalField Class

Syntax

'Declaration

Public Class SimplifiedAdditionalField

public class SimplifiedAdditionalField

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.SimplifiedAdditionalField

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

SimplifiedAdditionalField Members
FChoice.Toolkits.Clarify Namespace


SimplifiedAdditionalField Class Members | fcSDK Documentation

SimplifiedAdditionalField Class Members

The following tables list the members exposed by SimplifiedAdditionalField.

Public Constructors

 | Name | Description
Public Constructor | SimplifiedAdditionalField Constructor |

Public Properties

 | Name | Description
Public Property | FieldName |
Public Property | FieldValue |

Reference

SimplifiedAdditionalField Class
FChoice.Toolkits.Clarify Namespace


SimplifiedAdditionalField Constructor | fcSDK Documentation

SimplifiedAdditionalField Constructor

Syntax

'Declaration

Public Function New( _
   ByVal _fieldName_ As String, _
   ByVal _fieldValue_ As Object _
)

public SimplifiedAdditionalField(
   string _fieldName_,
   object _fieldValue_
)

Parameters

fieldName

fieldValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SimplifiedAdditionalField Class
SimplifiedAdditionalField Members


FieldName Property (SimplifiedAdditionalField) | fcSDK Documentation

FieldName Property (SimplifiedAdditionalField)

Syntax

'Declaration

Public ReadOnly Property FieldName As String

public string FieldName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SimplifiedAdditionalField Class
SimplifiedAdditionalField Members


FieldValue Property | fcSDK Documentation

FieldValue Property

Syntax

'Declaration

Public ReadOnly Property FieldValue As Object

public object FieldValue {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SimplifiedAdditionalField Class
SimplifiedAdditionalField Members


SimplifiedAdditionalFields Class | fcSDK Documentation

SimplifiedAdditionalFields Class

Syntax

'Declaration

Public Class SimplifiedAdditionalFields
   Inherits System.Collections.Generic.List(Of SimplifiedAdditionalField)

public class SimplifiedAdditionalFields : System.Collections.Generic.List<SimplifiedAdditionalField>

Inheritance Hierarchy

System.Object
System.Collections.Generic.List
FChoice.Toolkits.Clarify.SimplifiedAdditionalFields

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

SimplifiedAdditionalFields Members
FChoice.Toolkits.Clarify Namespace


SimplifiedAdditionalFields Class Members | fcSDK Documentation

SimplifiedAdditionalFields Class Members

The following tables list the members exposed by SimplifiedAdditionalFields.

Public Constructors

 | Name | Description
Public Constructor | SimplifiedAdditionalFields Constructor |

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | Item | (Inherited from System.Collections.Generic.List)

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

SimplifiedAdditionalFields Class
FChoice.Toolkits.Clarify Namespace


SimplifiedAdditionalFields Constructor | fcSDK Documentation

SimplifiedAdditionalFields Constructor

Syntax

'Declaration

Public Function New()

public SimplifiedAdditionalFields()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SimplifiedAdditionalFields Class
SimplifiedAdditionalFields Members


Add Method (SimplifiedAdditionalFields) | fcSDK Documentation

Add Method (SimplifiedAdditionalFields)

Overload List

Overload | Description
Add(String,Object) |
Add(SimplifiedAdditionalField) | (Inherited from System.Collections.Generic.List)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SimplifiedAdditionalFields Class
SimplifiedAdditionalFields Members


Add(String,Object) Method | fcSDK Documentation

Add(String,Object) Method

Syntax

'Declaration

Public Overloads Function Add( _
   ByVal _fieldName_ As String, _
   ByVal _fieldValue_ As Object _
) As SimplifiedAdditionalField

public SimplifiedAdditionalField Add(
   string _fieldName_,
   object _fieldValue_
)

Parameters

fieldName

fieldValue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SimplifiedAdditionalFields Class
SimplifiedAdditionalFields Members
Overload List


ToolkitBase Class | fcSDK Documentation

ToolkitBase Class

This class is used internally and not meant to be created by end users.

Syntax

'Declaration

Public MustInherit Class ToolkitBase

public abstract class ToolkitBase

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.ToolkitBase
FChoice.Toolkits.Clarify.Contracts.ContractsToolkitBase
FChoice.Toolkits.Clarify.DepotRepair.DepotRepairToolkitBase
FChoice.Toolkits.Clarify.FieldOps.FieldOpsToolkitBase
FChoice.Toolkits.Clarify.Interfaces.InterfacesToolkitBase
FChoice.Toolkits.Clarify.Logistics.LogisticsToolkitBase
FChoice.Toolkits.Clarify.Quality.QualityToolkitBase
FChoice.Toolkits.Clarify.Sales.SalesToolkitBase
FChoice.Toolkits.Clarify.Support.SupportToolkitBase

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ToolkitBase Members
FChoice.Toolkits.Clarify Namespace


ToolkitBase Class Members | fcSDK Documentation

ToolkitBase Class Members

The following tables list the members exposed by ToolkitBase.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | NOW_DATE | Date constant that tells FCFL.NET to use the database's current DateTime.

Reference

ToolkitBase Class
FChoice.Toolkits.Clarify Namespace


NOW_DATE Field (ToolkitBase) | fcSDK Documentation

NOW_DATE Field (ToolkitBase)

Date constant that tells FCFL.NET to use the database's current DateTime.

Syntax

'Declaration

Public Shared ReadOnly NOW_DATE As Date

public static readonly DateTime NOW_DATE

Remarks

Use this constant when setting API properties of type DateTime. The API will use the database's current time the update was executed for the property's value.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ToolkitBase Class
ToolkitBase Members


ToolkitResult Class | fcSDK Documentation

ToolkitResult Class

Every Toolkit API method will return this class or one derived from it as their result.

Syntax

'Declaration

<SerializableAttribute()>
Public Class ToolkitResult

[SerializableAttribute()]
public class ToolkitResult

Inheritance Hierarchy

System.Object [FChoice.Toolkits.Clarify.ToolkitResult** FChoice.Toolkits.Clarify.FieldOps.AddServiceInterruptionResult FChoice.Toolkits.Clarify.FieldOps.CreateAppointmentResult FChoice.Toolkits.Clarify.FieldOps.CreateExpenseLogResult FChoice.Toolkits.Clarify.FieldOps.CreateTimeLogResult FChoice.Toolkits.Clarify.FieldOps.PartTransferResult FChoice.Toolkits.Clarify.Interfaces.CreateEmployeeResult FChoice.Toolkits.Clarify.Interfaces.CreateSolutionResult FChoice.Toolkits.Clarify.Logistics.CreatePartRequestDetailResult FChoice.Toolkits.Clarify.Logistics.GetAlternatePartsResult FChoice.Toolkits.Clarify.Logistics.GetLocationsServicingSiteResult FChoice.Toolkits.Clarify.Logistics.PartTransferResult FChoice.Toolkits.Clarify.Logistics.PickResult FChoice.Toolkits.Clarify.Support.GetCaseTimeAndExpensesResult FChoice.Toolkits.Clarify.Support.GetSubcaseTimeAndExpensesResult FChoice.Toolkits.Clarify.Support.LogCaseEmailResult FChoice.Toolkits.Clarify.Support.LogCaseNoteResult FChoice.Toolkits.Clarify.Support.LogCasePhoneResult FChoice.Toolkits.Clarify.Support.LogCaseResearchResult FChoice.Toolkits.Clarify.Support.LogSubcaseEmailResult FChoice.Toolkits.Clarify.Support.LogSubcaseNoteResult FChoice.Toolkits.Clarify.Support.LogSubcasePhoneResult FChoice.Toolkits.Clarify.Support.LogSubcaseResearchResult

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ToolkitResult Members FChoice.Toolkits.Clarify Namespace FChoice.Toolkits.Clarify.ToolkitResult FChoice.Toolkits.Clarify.FieldOps.AddServiceInterruptionResult FChoice.Toolkits.Clarify.FieldOps.CreateAppointmentResult FChoice.Toolkits.Clarify.FieldOps.CreateExpenseLogResult FChoice.Toolkits.Clarify.FieldOps.CreateTimeLogResult FChoice.Toolkits.Clarify.FieldOps.PartTransferResult FChoice.Toolkits.Clarify.Interfaces.CreateEmployeeResult FChoice.Toolkits.Clarify.Interfaces.CreateSolutionResult FChoice.Toolkits.Clarify.Logistics.CreatePartRequestDetailResult FChoice.Toolkits.Clarify.Logistics.GetAlternatePartsResult FChoice.Toolkits.Clarify.Logistics.GetLocationsServicingSiteResult FChoice.Toolkits.Clarify.Logistics.PartTransferResult FChoice.Toolkits.Clarify.Logistics.PickResult FChoice.Toolkits.Clarify.Support.GetCaseTimeAndExpensesResult FChoice.Toolkits.Clarify.Support.GetSubcaseTimeAndExpensesResult FChoice.Toolkits.Clarify.Support.LogCaseEmailResult FChoice.Toolkits.Clarify.Support.LogCaseNoteResult FChoice.Toolkits.Clarify.Support.LogCasePhoneResult FChoice.Toolkits.Clarify.Support.LogCaseResearchResult FChoice.Toolkits.Clarify.Support.LogSubcaseEmailResult FChoice.Toolkits.Clarify.Support.LogSubcaseNoteResult FChoice.Toolkits.Clarify.Support.LogSubcasePhoneResult FChoice.Toolkits.Clarify.Support.LogSubcaseResearchResult

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ToolkitResult Members FChoice.Toolkits.Clarify Namespace


ToolkitResult Class Members | fcSDK Documentation

ToolkitResult Class Members

The following tables list the members exposed by ToolkitResult.

Public Constructors

 | Name | Description
Public Constructor | ToolkitResult Constructor | Overloaded.

Public Properties

 | Name | Description
Public Property | IDNum | Identifier of the object modified by the API invocation.
Public Property | Objid | Objid of the object modified by the API invocation
Public Property | ReturnCode | Return code of the API call.

Reference

ToolkitResult Class
FChoice.Toolkits.Clarify Namespace


ToolkitResult Constructor | fcSDK Documentation

ToolkitResult Constructor

Overload List

Overload | Description
ToolkitResult Constructor() |
ToolkitResult Constructor(Int16,IToolkit) |
ToolkitResult Constructor(String,Int32) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ToolkitResult Class
ToolkitResult Members


ToolkitResult Constructor() | fcSDK Documentation

ToolkitResult Constructor()

Syntax

'Declaration

Public Function New()

public ToolkitResult()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ToolkitResult Class
ToolkitResult Members
Overload List


ToolkitResult Constructor(Int16,IToolkit) | fcSDK Documentation

ToolkitResult Constructor(Int16,IToolkit)

Syntax

'Declaration

Public Function New( _
   ByVal _retCode_ As Short, _
   ByVal _toolkit_ As FChoice.Foundation.Clarify.Compatibility.Toolkits.IToolkit _
)

public ToolkitResult(
   short _retCode_,
   FChoice.Foundation.Clarify.Compatibility.Toolkits.IToolkit _toolkit_
)

Parameters

retCode

toolkit

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ToolkitResult Class
ToolkitResult Members
Overload List


ToolkitResult Constructor(String,Int32) | fcSDK Documentation

ToolkitResult Constructor(String,Int32)

Syntax

'Declaration

Public Function New( _
   ByVal _IDNum_ As String, _
   ByVal _objid_ As Integer _
)

public ToolkitResult(
   string _IDNum_,
   int _objid_
)

Parameters

IDNum

objid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ToolkitResult Class
ToolkitResult Members
Overload List


IDNum Property (ToolkitResult) | fcSDK Documentation

IDNum Property (ToolkitResult)

Identifier of the object modified by the API invocation.

Syntax

'Declaration

Public Property IDNum As String

public string IDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ToolkitResult Class
ToolkitResult Members


Objid Property | fcSDK Documentation

Objid Property

Objid of the object modified by the API invocation

Syntax

'Declaration

Public Property Objid As Integer

public int Objid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ToolkitResult Class
ToolkitResult Members


ReturnCode Property | fcSDK Documentation

ReturnCode Property

Return code of the API call.

Syntax

'Declaration

Public Property ReturnCode As Short

public short ReturnCode {get; set;}

Property Value

Will usually be zero or a negative number representing an error condition.

Remarks

This property is provided primarily for compatibility with previous Toolkit coding practices that do not use structured error handling.

This value will always be zero unless an error occurred. However, if the application is using FCFL.Net Compatibility with Session.ThrowErrors set to false a non-zero result can occur. Note: It is recommended that you do not set ThrowErrors to false and use structured error handling via try/catch statements.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ToolkitResult Class
ToolkitResult Members


ToolkitResultPropertyAttribute Class | fcSDK Documentation

ToolkitResultPropertyAttribute Class

Syntax

'Declaration

<AttributeUsageAttribute(ValidOn=AttributeTargets.Method,
   AllowMultiple=True,
   Inherited=True)>
Public Class ToolkitResultPropertyAttribute
   Inherits System.Attribute

[AttributeUsageAttribute(ValidOn=AttributeTargets.Method,
   AllowMultiple=true,
   Inherited=true)]
public class ToolkitResultPropertyAttribute : System.Attribute

Inheritance Hierarchy

System.Object
System.Attribute
FChoice.Toolkits.Clarify.ToolkitResultPropertyAttribute

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ToolkitResultPropertyAttribute Members
FChoice.Toolkits.Clarify Namespace


ToolkitResultPropertyAttribute Class Members | fcSDK Documentation

ToolkitResultPropertyAttribute Class Members

The following tables list the members exposed by ToolkitResultPropertyAttribute.

Public Constructors

 | Name | Description
Public Constructor | ToolkitResultPropertyAttribute Constructor |

Public Properties

 | Name | Description
Public Property | DocSummary |
Public Property | PropertyName |
Public Property | TypeId | (Inherited from System.Attribute)

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)

Reference

ToolkitResultPropertyAttribute Class
FChoice.Toolkits.Clarify Namespace


ToolkitResultPropertyAttribute Constructor | fcSDK Documentation

ToolkitResultPropertyAttribute Constructor

Syntax

'Declaration

Public Function New( _
   ByVal _propertyName_ As String, _
   ByVal _docSummary_ As String _
)

public ToolkitResultPropertyAttribute(
   string _propertyName_,
   string _docSummary_
)

Parameters

propertyName

docSummary

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ToolkitResultPropertyAttribute Class
ToolkitResultPropertyAttribute Members


DocSummary Property (ToolkitResultPropertyAttribute) | fcSDK Documentation

DocSummary Property (ToolkitResultPropertyAttribute)

Syntax

'Declaration

Public ReadOnly Property DocSummary As String

public string DocSummary {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ToolkitResultPropertyAttribute Class
ToolkitResultPropertyAttribute Members


PropertyName Property (ToolkitResultPropertyAttribute) | fcSDK Documentation

PropertyName Property (ToolkitResultPropertyAttribute)

Syntax

'Declaration

Public ReadOnly Property PropertyName As String

public string PropertyName {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ToolkitResultPropertyAttribute Class
ToolkitResultPropertyAttribute Members


Utility Class | fcSDK Documentation

Utility Class

Syntax

'Declaration

Public Class Utility

public class Utility

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Utility

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

Utility Members
FChoice.Toolkits.Clarify Namespace


Utility Class Members | fcSDK Documentation

Utility Class Members

The following tables list the members exposed by Utility.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | AddExpenseGL |

Reference

Utility Class
FChoice.Toolkits.Clarify Namespace


AddExpenseGL Method | fcSDK Documentation

AddExpenseGL Method

Syntax

'Declaration

Public Shared Sub AddExpenseGL( _
   ByVal _logisticsToolkit_ As LogisticsToolkit, _
   ByVal _session_ As FCSession, _
   ByVal _accountName_ As String, _
   ByVal _siteIDNum_ As String _
)

public static void AddExpenseGL(
   LogisticsToolkit _logisticsToolkit_,
   FCSession _session_,
   string _accountName_,
   string _siteIDNum_
)

Parameters

logisticsToolkit

session

accountName

siteIDNum

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

Utility Class
Utility Members


AdditionalFieldType Enumeration | fcSDK Documentation

AdditionalFieldType Enumeration

The type of database field being updated by the AdditionalField property.

Syntax

'Declaration

Public Enum AdditionalFieldType
   Inherits System.Enum

public enum AdditionalFieldType : System.Enum

Members

Member | Description
Date | Database DateTime field
Double | Database non fixed type
Long | Database integer type
String | Database string type (Char, Varchar, Text)

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
FChoice.Toolkits.Clarify.AdditionalFieldType

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

FChoice.Toolkits.Clarify Namespace


BillingFrequency Enumeration | fcSDK Documentation

BillingFrequency Enumeration

The billing frequency of the Contract Schedule being created or updated.

Syntax

'Declaration

Public Enum BillingFrequency
   Inherits System.Enum

public enum BillingFrequency : System.Enum

Members

Member | Description
Annual | Billed annually
Monthly | Billed monthly
OneTime | One time billing
Quarterly | Billed every quarter
SemiAnnual | Billed twice annually

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
FChoice.Toolkits.Clarify.BillingFrequency

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

FChoice.Toolkits.Clarify Namespace


BillingOption Enumeration | fcSDK Documentation

BillingOption Enumeration

The billing option of the Contract Schedule being created or updated.

Syntax

'Declaration

Public Enum BillingOption
   Inherits System.Enum

public enum BillingOption : System.Enum

Members

Member | Description
InAdvance | Billed in advance
InArrears | Billed in arrears

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
FChoice.Toolkits.Clarify.BillingOption

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

FChoice.Toolkits.Clarify Namespace


CaseObjectType Enumeration | fcSDK Documentation

CaseObjectType Enumeration

Which type of case object is being affected

Syntax

'Declaration

Public Enum CaseObjectType
   Inherits System.Enum

public enum CaseObjectType : System.Enum

Members

Member | Description
Case | Case object
Subcase | Subcase object

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
FChoice.Toolkits.Clarify.CaseObjectType

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

FChoice.Toolkits.Clarify Namespace


CommunicationAutoExec Enumeration | fcSDK Documentation

CommunicationAutoExec Enumeration

Syntax

'Declaration

Public Enum CommunicationAutoExec
   Inherits System.Enum

public enum CommunicationAutoExec : System.Enum

Members

Member | Description
Automatic |
User |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
FChoice.Toolkits.Clarify.CommunicationAutoExec

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

FChoice.Toolkits.Clarify Namespace


CommunicationDeliveryStatus Enumeration | fcSDK Documentation

CommunicationDeliveryStatus Enumeration

Syntax

'Declaration

Public Enum CommunicationDeliveryStatus
   Inherits System.Enum

public enum CommunicationDeliveryStatus : System.Enum

Members

Member | Description
Bounced |
Draft |
Failed |
Pending |
Received |
Sent |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
FChoice.Toolkits.Clarify.CommunicationDeliveryStatus

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

FChoice.Toolkits.Clarify Namespace


CommunicationDirection Enumeration | fcSDK Documentation

CommunicationDirection Enumeration

Syntax

'Declaration

Public Enum CommunicationDirection
   Inherits System.Enum

public enum CommunicationDirection : System.Enum

Members

Member | Description
Both |
Inbound |
Outbound |
Unknown |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
FChoice.Toolkits.Clarify.CommunicationDirection

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

FChoice.Toolkits.Clarify Namespace


CommunicationPriority Enumeration | fcSDK Documentation

CommunicationPriority Enumeration

Syntax

'Declaration

Public Enum CommunicationPriority
   Inherits System.Enum

public enum CommunicationPriority : System.Enum

Members

Member | Description
High |
Normal |
Urgent |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
FChoice.Toolkits.Clarify.CommunicationPriority

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

FChoice.Toolkits.Clarify Namespace


CommunicationRoleType Enumeration | fcSDK Documentation

CommunicationRoleType Enumeration

Syntax

'Declaration

Public Enum CommunicationRoleType
   Inherits System.Enum

public enum CommunicationRoleType : System.Enum

Members

Member | Description
BCC |
CC |
Recipient |
ReplyTo |
Sender |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
FChoice.Toolkits.Clarify.CommunicationRoleType

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

FChoice.Toolkits.Clarify Namespace


CRCondition Enumeration | fcSDK Documentation

CRCondition Enumeration

Syntax

'Declaration

Public Enum CRCondition
   Inherits System.Enum

public enum CRCondition : System.Enum

Members

Member | Description
Closed |
Closed_Duplicate |
Fixed |
Open |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
FChoice.Toolkits.Clarify.CRCondition

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

FChoice.Toolkits.Clarify Namespace


EcoItemAppliesTo Enumeration | fcSDK Documentation

EcoItemAppliesTo Enumeration

The type of object the ECO item being created or updated applies to.

Syntax

'Declaration

Public Enum EcoItemAppliesTo
   Inherits System.Enum

public enum EcoItemAppliesTo : System.Enum

Members

Member | Description
EcoHeader | ECOHeader object
PartRevision | Part Revision object

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
FChoice.Toolkits.Clarify.EcoItemAppliesTo

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

FChoice.Toolkits.Clarify Namespace


LeadSiteType Enumeration | fcSDK Documentation

LeadSiteType Enumeration

What type of Site is being linked to the Lead

Syntax

'Declaration

Public Enum LeadSiteType
   Inherits System.Enum

public enum LeadSiteType : System.Enum

Members

Member | Description
Business | Business site
Individual | Individual site

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
FChoice.Toolkits.Clarify.LeadSiteType

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

FChoice.Toolkits.Clarify Namespace


OpportunityStage Enumeration | fcSDK Documentation

OpportunityStage Enumeration

Stage the opportunity being created or modified is in.

Syntax

'Declaration

Public Enum OpportunityStage
   Inherits System.Enum

public enum OpportunityStage : System.Enum

Members

Member | Description
Lead |
Lose |
Opportunity |
Win |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
FChoice.Toolkits.Clarify.OpportunityStage

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

FChoice.Toolkits.Clarify Namespace


PartAuthorizationLevel Enumeration | fcSDK Documentation

PartAuthorizationLevel Enumeration

Syntax

'Declaration

Public Enum PartAuthorizationLevel
   Inherits System.Enum

public enum PartAuthorizationLevel : System.Enum

Members

Member | Description
All |
AuthorizedPartsOnly |
None |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
FChoice.Toolkits.Clarify.PartAuthorizationLevel

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

FChoice.Toolkits.Clarify Namespace


PartRepairType Enumeration | fcSDK Documentation

PartRepairType Enumeration

Repair Type of the Part being created or modified.

Syntax

'Declaration

Public Enum PartRepairType
   Inherits System.Enum

public enum PartRepairType : System.Enum

Members

Member | Description
Expendable | Part cannot be repaired
Repairable | Part is repairable

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
FChoice.Toolkits.Clarify.PartRepairType

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

FChoice.Toolkits.Clarify Namespace


PartRequestCondition Enumeration | fcSDK Documentation

PartRequestCondition Enumeration

Syntax

'Declaration

Public Enum PartRequestCondition
   Inherits System.Enum

public enum PartRequestCondition : System.Enum

Members

Member | Description
Backordered |
Fulfilled |
InRepair |
PartUsed |
Picked |
Received |
RequestClosed |
RequestOpen |
RequestReopened |
Shipped |
Unpicked |
UpdateInventory |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
FChoice.Toolkits.Clarify.PartRequestCondition

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

FChoice.Toolkits.Clarify Namespace


PartRequestType Enumeration | fcSDK Documentation

PartRequestType Enumeration

Syntax

'Declaration

Public Enum PartRequestType
   Inherits System.Enum

public enum PartRequestType : System.Enum

Members

Member | Description
AdvanceExchange |
DepotRepair |
Order |
PleaseSpecify |
Replenishment |
ReturnForCredit |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
FChoice.Toolkits.Clarify.PartRequestType

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

FChoice.Toolkits.Clarify Namespace


PartRevisionStatus Enumeration | fcSDK Documentation

PartRevisionStatus Enumeration

Status of the Part Revision

Syntax

'Declaration

Public Enum PartRevisionStatus
   Inherits System.Enum

public enum PartRevisionStatus : System.Enum

Members

Member | Description
Active |
Inactive |
Obsolete |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
FChoice.Toolkits.Clarify.PartRevisionStatus

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

FChoice.Toolkits.Clarify Namespace


PriceInstanceType Enumeration | fcSDK Documentation

PriceInstanceType Enumeration

Type of Pricing being used for the Price Instance

Syntax

'Declaration

Public Enum PriceInstanceType
   Inherits System.Enum

public enum PriceInstanceType : System.Enum

Members

Member | Description
Fixed |
PercentOfOptionList |
PercentOfProduct |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
FChoice.Toolkits.Clarify.PriceInstanceType

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

FChoice.Toolkits.Clarify Namespace


RepairPartDisposition Enumeration | fcSDK Documentation

RepairPartDisposition Enumeration

What to do with the repair part when the repair is completed.

Syntax

'Declaration

Public Enum RepairPartDisposition
   Inherits System.Enum

public enum RepairPartDisposition : System.Enum

Members

Member | Description
Reference |
Removed |
Used |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
FChoice.Toolkits.Clarify.RepairPartDisposition

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

FChoice.Toolkits.Clarify Namespace


SiteStatus Enumeration | fcSDK Documentation

SiteStatus Enumeration

The status of the Site being created or modified.

Syntax

'Declaration

Public Enum SiteStatus
   Inherits System.Enum

public enum SiteStatus : System.Enum

Members

Member | Description
Active |
Inactive |
Obsolete |

Inheritance Hierarchy

System.Object System.ValueType System.Enum FChoice.Toolkits.Clarify.SiteStatus

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

FChoice.Toolkits.Clarify Namespace FChoice.Toolkits.Clarify.SiteStatus

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

FChoice.Toolkits.Clarify Namespace


SiteType Enumeration | fcSDK Documentation

SiteType Enumeration

The type of the Site being created of modified.

Syntax

'Declaration

Public Enum SiteType
   Inherits System.Enum

public enum SiteType : System.Enum

Members

Member | Description
Customer |
Individual |
Internal |
Reseller |
Vendor |

Inheritance Hierarchy

System.Object System.ValueType System.Enum FChoice.Toolkits.Clarify.SiteType

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

FChoice.Toolkits.Clarify Namespace FChoice.Toolkits.Clarify.SiteType

Requirements

Namespace: FChoice.Toolkits.Clarify

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

FChoice.Toolkits.Clarify Namespace


FChoice.Toolkits.Clarify.Contracts Namespace | fcSDK Documentation

FChoice.Toolkits.Clarify.Contracts Namespace

Provides APIs to allow you to modify ClearContracts objects, including contracts, schedules, and line items. Methods on the ContractsToolkit object allow you to create contracts, schedules, and line items as well as basic operations such as modify, dispatch, accept, reject, assign, yank, move, change status, log notes, reopen and more.

Classes

 | Class | Description
Class | AcceptQuoteSetup | Used by the AcceptQuote method as setup data for invocation.
Class | AddPOToScheduleSetup | Used by the AddPOToSchedule method as setup data for invocation.
Class | AssignQuoteSetup | Used by the AssignQuote method as setup data for invocation.
Class | ChangeQuoteStatusSetup | Used by the ChangeQuoteStatus method as setup data for invocation.
Class | ContractsToolkit | Provides APIs to allow you to modify ClearContracts objects, including contracts, schedules, and line items. These APIs allow you to create contracts, schedules, and line items as well as basic operations such as modify, dispatch, accept, reject, assign, yank, move, change status, log notes, reopen and more.
Class | ContractsToolkitBase |
Class | CreateContractLineItemSetup | Used by the CreateContractLineItem method as setup data for invocation.
Class | CreateContractSetup | Used by the CreateContract method as setup data for invocation.
Class | CreatePriceInstanceSetup | Used by the CreatePriceInstance method as setup data for invocation.
Class | CreateScheduleSetup | Used by the CreateSchedule method as setup data for invocation.
Class | DeleteSitePartSetup | Used by the DeleteSitePart method as setup data for invocation.
Class | DispatchQuoteSetup | Used by the DispatchQuote method as setup data for invocation.
Class | ForwardQuoteSetup | Used by the ForwardQuote method as setup data for invocation.
Class | LogContractNoteSetup | Used by the LogContractNote method as setup data for invocation.
Class | MoveQuoteSetup | Used by the MoveQuote method as setup data for invocation.
Class | RejectContractSetup | Used by the RejectContract method as setup data for invocation.
Class | RejectQuoteSetup | Used by the RejectQuote method as setup data for invocation.
Class | RelateContractItemToSitePartSetup | Used by the RelateContractItemToSitePart method as setup data for invocation.
Class | ReopenContractSetup | Used by the ReopenContract method as setup data for invocation.
Class | UnrelateContractItemFromSitePartSetup | Used by the UnrelateContractItemFromSitePart method as setup data for invocation.
Class | UpdateScheduleSetup | Used by the UpdateSchedule method as setup data for invocation.
Class | YankQuoteSetup | Used by the YankQuote method as setup data for invocation.

Reference

FChoice.Toolkits.Clarify Assembly


AcceptQuoteSetup Class | fcSDK Documentation

AcceptQuoteSetup Class

Used by the AcceptQuote method as setup data for invocation.

Syntax

'Declaration

Public Class AcceptQuoteSetup

public class AcceptQuoteSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Contracts.AcceptQuoteSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Contracts

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

AcceptQuoteSetup Members
FChoice.Toolkits.Clarify.Contracts Namespace
AcceptQuote(AcceptQuoteSetup) Method


AcceptQuoteSetup Class Members | fcSDK Documentation

AcceptQuoteSetup Class Members

The following tables list the members exposed by AcceptQuoteSetup.

Public Constructors

 | Name | Description
Public Constructor | AcceptQuoteSetup Constructor | Initializes a new instance of the AcceptQuoteSetup class.

Public Properties

 | Name | Description
Public Property | AcceptDate | DateTime the Quote was accepted. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | QuoteIDNum | Quote Identifier.
Public Property | UserName | The user who has accepted the Quote. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Quote. If not set, the UserName's default is used.

Reference

AcceptQuoteSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
AcceptQuote(AcceptQuoteSetup) Method


AcceptQuoteSetup Constructor | fcSDK Documentation

AcceptQuoteSetup Constructor

Quote Identifier

Initializes a new instance of the AcceptQuoteSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _quoteIDNum_ As String _
)

[ConstructorIndexAttribute()]
public AcceptQuoteSetup(
   string _quoteIDNum_
)

Parameters

quoteIDNum

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptQuoteSetup Class
AcceptQuoteSetup Members


AcceptDate Property (AcceptQuoteSetup) | fcSDK Documentation

AcceptDate Property (AcceptQuoteSetup)

DateTime the Quote was accepted. If not set, the current time is used.

Syntax

'Declaration

<AttributeUsageAttribute()>
Public Property AcceptDate As Date

[PropertyBitValueAttribute()]
public DateTime AcceptDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptQuoteSetup Class
AcceptQuoteSetup Members


GenerateTimeBombs Property (AcceptQuoteSetup) | fcSDK Documentation

GenerateTimeBombs Property (AcceptQuoteSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<AttributeUsageAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptQuoteSetup Class
AcceptQuoteSetup Members


QuoteIDNum Property (AcceptQuoteSetup) | fcSDK Documentation

QuoteIDNum Property (AcceptQuoteSetup)

Quote Identifier.

Syntax

'Declaration

<AttributeUsageAttribute()>
Public Property QuoteIDNum As String

[PropertyBitValueAttribute()]
public string QuoteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptQuoteSetup Class
AcceptQuoteSetup Members


UserName Property (AcceptQuoteSetup) | fcSDK Documentation

UserName Property (AcceptQuoteSetup)

The user who has accepted the Quote. If not set, the Toolkit session user is used.

Syntax

'Declaration

<AttributeUsageAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptQuoteSetup Class
AcceptQuoteSetup Members


WipBin Property (AcceptQuoteSetup) | fcSDK Documentation

WipBin Property (AcceptQuoteSetup)

User's WipBin in which to place the Quote. If not set, the UserName's default is used.

Syntax

'Declaration

<AttributeUsageAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptQuoteSetup Class
AcceptQuoteSetup Members


AddPOToScheduleSetup Class | fcSDK Documentation

AddPOToScheduleSetup Class

Used by the AddPOToSchedule method as setup data for invocation.

Syntax

'Declaration

Public Class AddPOToScheduleSetup

public class AddPOToScheduleSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Contracts.AddPOToScheduleSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Contracts

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

AddPOToScheduleSetup Members
FChoice.Toolkits.Clarify.Contracts Namespace
AddPOToSchedule(AddPOToScheduleSetup) Method


AddPOToScheduleSetup Class Members | fcSDK Documentation

AddPOToScheduleSetup Class Members

The following tables list the members exposed by AddPOToScheduleSetup.

Public Constructors

 | Name | Description
Public Constructor | AddPOToScheduleSetup Constructor | Initializes a new instance of the AddPOToScheduleSetup class.

Public Properties

 | Name | Description
Public Property | ContractIDNum | Contract Identifier.
Public Property | ExpireDate | The DateTime the Purchase Order will expire. If not set, the current time is used.
Public Property | PaymentOption | Element from the 'Payment Method' application list. If not set, the default list value is used.
Public Property | PaymentTerms | Element from the 'Contract Pay Terms' application list. If not set, the default list value is used.
Public Property | POAmount | The amount of the Purchase Order.
Public Property | PODate | The DateTime the Purchase Order will expire. If not set, the current time is used.
Public Property | POIDNum | Purchase Order Identifier.
Public Property | POStatus | Element from the 'PO Status' application list. If not set, the default list value is used.
Public Property | ScheduleIDNum | Schedule Identifier.

Reference

AddPOToScheduleSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
AddPOToSchedule(AddPOToScheduleSetup) Method


AddPOToScheduleSetup Constructor | fcSDK Documentation

AddPOToScheduleSetup Constructor

Contract Identifier.

Schedule Identifier.

Purchase Order Identifier.

The amount of the Purchase Order.

Initializes a new instance of the AddPOToScheduleSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _contractIDNum_ As String, _
   ByVal _scheduleIDNum_ As String, _
   ByVal _poIDNum_ As String, _
   ByVal _poAmount_ As Decimal _
)

[ConstructorIndexAttribute()]
public AddPOToScheduleSetup(
   string _contractIDNum_,
   string _scheduleIDNum_,
   string _poIDNum_,
   decimal _poAmount_
)

Parameters

contractIDNum

Contract Identifier.

scheduleIDNum

Schedule Identifier.

poIDNum

Purchase Order Identifier.

poAmount

The amount of the Purchase Order.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddPOToScheduleSetup Class
AddPOToScheduleSetup Members


ContractIDNum Property (AddPOToScheduleSetup) | fcSDK Documentation

ContractIDNum Property (AddPOToScheduleSetup)

Contract Identifier.

Syntax

'Declaration

<AttributeUsageAttribute()>
Public Property ContractIDNum As String

[PropertyBitValueAttribute()]
public string ContractIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddPOToScheduleSetup Class
AddPOToScheduleSetup Members


ExpireDate Property (AddPOToScheduleSetup) | fcSDK Documentation

ExpireDate Property (AddPOToScheduleSetup)

The DateTime the Purchase Order will expire. If not set, the current time is used.

Syntax

'Declaration

<AttributeUsageAttribute()>
Public Property ExpireDate As Date

[PropertyBitValueAttribute()]
public DateTime ExpireDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddPOToScheduleSetup Class
AddPOToScheduleSetup Members


PaymentOption Property | fcSDK Documentation

PaymentOption Property

Element from the 'Payment Method' application list. If not set, the default list value is used.

Syntax

'Declaration

<AttributeUsageAttribute()>
Public Property PaymentOption As String

[PropertyBitValueAttribute()]
public string PaymentOption {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddPOToScheduleSetup Class
AddPOToScheduleSetup Members


PaymentTerms Property (AddPOToScheduleSetup) | fcSDK Documentation

PaymentTerms Property (AddPOToScheduleSetup)

Element from the 'Contract Pay Terms' application list. If not set, the default list value is used.

Syntax

'Declaration

<AttributeUsageAttribute()>
Public Property PaymentTerms As String

[PropertyBitValueAttribute()]
public string PaymentTerms {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddPOToScheduleSetup Class
AddPOToScheduleSetup Members


POAmount Property | fcSDK Documentation

POAmount Property

The amount of the Purchase Order.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property POAmount As Decimal

[PropertyBitValueAttribute()]
public decimal POAmount {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddPOToScheduleSetup Class
AddPOToScheduleSetup Members


PODate Property | fcSDK Documentation

PODate Property

The DateTime the Purchase Order will expire. If not set, the current time is used.

Syntax

'Declaration

<AttributeUsageAttribute()>
Public Property PODate As Date

[PropertyBitValueAttribute()]
public DateTime PODate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddPOToScheduleSetup Class
AddPOToScheduleSetup Members


POIDNum Property (AddPOToScheduleSetup) | fcSDK Documentation

POIDNum Property (AddPOToScheduleSetup)

Purchase Order Identifier.

Syntax

'Declaration

<AttributeUsageAttribute()>
Public Property POIDNum As String

[PropertyBitValueAttribute()]
public string POIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddPOToScheduleSetup Class
AddPOToScheduleSetup Members


POStatus Property | fcSDK Documentation

POStatus Property

Element from the 'PO Status' application list. If not set, the default list value is used.

Syntax

'Declaration

<AttributeUsageAttribute()>
Public Property POStatus As String

[PropertyBitValueAttribute()]
public string POStatus {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddPOToScheduleSetup Class
AddPOToScheduleSetup Members


ScheduleIDNum Property (AddPOToScheduleSetup) | fcSDK Documentation

ScheduleIDNum Property (AddPOToScheduleSetup)

Schedule Identifier.

Syntax

'Declaration

<AttributeUsageAttribute()>
Public Property ScheduleIDNum As String

[PropertyBitValueAttribute()]
public string ScheduleIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddPOToScheduleSetup Class
AddPOToScheduleSetup Members


AssignQuoteSetup Class | fcSDK Documentation

AssignQuoteSetup Class

Used by the AssignQuote method as setup data for invocation.

Syntax

'Declaration

Public Class AssignQuoteSetup

public class AssignQuoteSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Contracts.AssignQuoteSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Contracts

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

AssignQuoteSetup Members
FChoice.Toolkits.Clarify.Contracts Namespace
AssignQuote(AssignQuoteSetup) Method


AssignQuoteSetup Class Members | fcSDK Documentation

AssignQuoteSetup Class Members

The following tables list the members exposed by AssignQuoteSetup.

Public Constructors

 | Name | Description
Public Constructor | AssignQuoteSetup Constructor | Initializes a new instance of the AssignQuoteSetup class.

Public Properties

 | Name | Description
Public Property | AssignDate | DateTime the Quote was assigned. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewUser | The new user to which the Quote is to be assigned.
Public Property | QuoteIDNum | Quote Identifier.
Public Property | UserName | The user who has assigned the Quote. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Quote. If not set, the UserName's default is used.

Reference

AssignQuoteSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
AssignQuote(AssignQuoteSetup) Method


AssignQuoteSetup Constructor | fcSDK Documentation

AssignQuoteSetup Constructor

Quote Identifier.

Initializes a new instance of the AssignQuoteSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _quoteIDNum_ As String _
)

[ConstructorIndexAttribute()]
public AssignQuoteSetup(
   string _quoteIDNum_
)

Parameters

quoteIDNum

Quote Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignQuoteSetup Class
AssignQuoteSetup Members


AssignDate Property (AssignQuoteSetup) | fcSDK Documentation

AssignDate Property (AssignQuoteSetup)

DateTime the Quote was assigned. If not set, the current time is used.

Syntax

'Declaration

<AttributeUsageAttribute()>
Public Property AssignDate As Date

[PropertyBitValueAttribute()]
public DateTime AssignDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignQuoteSetup Class
AssignQuoteSetup Members


GenerateTimeBombs Property (AssignQuoteSetup) | fcSDK Documentation

GenerateTimeBombs Property (AssignQuoteSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<AttributeUsageAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignQuoteSetup Class
AssignQuoteSetup Members


NewUser Property (AssignQuoteSetup) | fcSDK Documentation

NewUser Property (AssignQuoteSetup)

The new user to which the Quote is to be assigned.

Syntax

'Declaration

<AttributeUsageAttribute()>
Public Property NewUser As String

[PropertyBitValueAttribute()]
public string NewUser {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignQuoteSetup Class
AssignQuoteSetup Members


QuoteIDNum Property (AssignQuoteSetup) | fcSDK Documentation

QuoteIDNum Property (AssignQuoteSetup)

Quote Identifier.

Syntax

'Declaration

<AttributeUsageAttribute()>
Public Property QuoteIDNum As String

[PropertyBitValueAttribute()]
public string QuoteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignQuoteSetup Class
AssignQuoteSetup Members


UserName Property (AssignQuoteSetup) | fcSDK Documentation

UserName Property (AssignQuoteSetup)

The user who has assigned the Quote. If not set, the Toolkit session user is used.

Syntax

'Declaration

<AttributeUsageAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignQuoteSetup Class
AssignQuoteSetup Members


WipBin Property (AssignQuoteSetup) | fcSDK Documentation

WipBin Property (AssignQuoteSetup)

User's WipBin in which to place the Quote. If not set, the UserName's default is used.

Syntax

'Declaration

<AttributeUsageAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignQuoteSetup Class
AssignQuoteSetup Members


ChangeQuoteStatusSetup Class | fcSDK Documentation

ChangeQuoteStatusSetup Class

Used by the ChangeQuoteStatus method as setup data for invocation.

Syntax

'Declaration

Public Class ChangeQuoteStatusSetup

public class ChangeQuoteStatusSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Contracts.ChangeQuoteStatusSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Contracts

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ChangeQuoteStatusSetup Members
FChoice.Toolkits.Clarify.Contracts Namespace
ChangeQuoteStatus(ChangeQuoteStatusSetup) Method


ChangeQuoteStatusSetup Class Members | fcSDK Documentation

ChangeQuoteStatusSetup Class Members

The following tables list the members exposed by ChangeQuoteStatusSetup.

Public Constructors

 | Name | Description
Public Constructor | ChangeQuoteStatusSetup Constructor | Initializes a new instance of the ChangeQuoteStatusSetup class.

Public Properties

 | Name | Description
Public Property | ChangeDate | The DateTime the Quote Status was changed. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewStatus | Element from the 'Quote Status' application list. If not set, the default list value is used.
Public Property | Notes | Notes about the Quote Status change.
Public Property | QuoteIDNum | Quote Identifier.
Public Property | UserName | The username of the user who is changing the Quote status. If not set, the Toolkit session user is used.

Reference

ChangeQuoteStatusSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
ChangeQuoteStatus(ChangeQuoteStatusSetup) Method


ChangeQuoteStatusSetup Constructor | fcSDK Documentation

ChangeQuoteStatusSetup Constructor

Quote Identifier.

Initializes a new instance of the ChangeQuoteStatusSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _quoteIDNum_ As String _
)

[ConstructorIndexAttribute()]
public ChangeQuoteStatusSetup(
   string _quoteIDNum_
)

Parameters

quoteIDNum

Quote Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeQuoteStatusSetup Class
ChangeQuoteStatusSetup Members


ChangeDate Property (ChangeQuoteStatusSetup) | fcSDK Documentation

ChangeDate Property (ChangeQuoteStatusSetup)

The DateTime the Quote Status was changed. If not set, the current time is used.

Syntax

'Declaration

<AttributeUsageAttribute()>
Public Property ChangeDate As Date

[PropertyBitValueAttribute()]
public DateTime ChangeDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeQuoteStatusSetup Class
ChangeQuoteStatusSetup Members


GenerateTimeBombs Property (ChangeQuoteStatusSetup) | fcSDK Documentation

GenerateTimeBombs Property (ChangeQuoteStatusSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<AttributeUsageAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeQuoteStatusSetup Class
ChangeQuoteStatusSetup Members


NewStatus Property (ChangeQuoteStatusSetup) | fcSDK Documentation

NewStatus Property (ChangeQuoteStatusSetup)

Element from the 'Quote Status' application list. If not set, the default list value is used.

Syntax

'Declaration

<AttributeUsageAttribute()>
Public Property NewStatus As String

[PropertyBitValueAttribute()]
public string NewStatus {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeQuoteStatusSetup Class
ChangeQuoteStatusSetup Members


Notes Property (ChangeQuoteStatusSetup) | fcSDK Documentation

Notes Property (ChangeQuoteStatusSetup)

Notes about the Quote Status change.

Syntax

'Declaration

<AttributeUsageAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeQuoteStatusSetup Class
ChangeQuoteStatusSetup Members


QuoteIDNum Property (ChangeQuoteStatusSetup) | fcSDK Documentation

QuoteIDNum Property (ChangeQuoteStatusSetup)

Quote Identifier.

Syntax

'Declaration

<AttributeUsageAttribute()>
Public Property QuoteIDNum As String

[PropertyBitValueAttribute()]
public string QuoteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeQuoteStatusSetup Class
ChangeQuoteStatusSetup Members


UserName Property (ChangeQuoteStatusSetup) | fcSDK Documentation

UserName Property (ChangeQuoteStatusSetup)

The username of the user who is changing the Quote status. If not set, the Toolkit session user is used.

Syntax

'Declaration

<AttributeUsageAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeQuoteStatusSetup Class
ChangeQuoteStatusSetup Members


ContractsToolkit Class | fcSDK Documentation

ContractsToolkit Class

Provides APIs to allow you to modify ClearContracts objects, including contracts, schedules, and line items. These APIs allow you to create contracts, schedules, and line items as well as basic operations such as modify, dispatch, accept, reject, assign, yank, move, change status, log notes, reopen and more.

Syntax

'Declaration

Public Class ContractsToolkit
   Inherits ContractsToolkitBase

public class ContractsToolkit : ContractsToolkitBase

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.ToolkitBase
FChoice.Toolkits.Clarify.Contracts.ContractsToolkitBase
FChoice.Toolkits.Clarify.Contracts.ContractsToolkit

Requirements

Namespace: FChoice.Toolkits.Clarify.Contracts

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ContractsToolkit Members
FChoice.Toolkits.Clarify.Contracts Namespace


ContractsToolkit Class Members | fcSDK Documentation

ContractsToolkit Class Members

The following tables list the members exposed by ContractsToolkit.

Public Constructors

 | Name | Description
Public Constructor | ContractsToolkit Constructor | Overloaded.

Public Properties

 | Name | Description
Public Property | ImpersonatorUsername | (Inherited from FChoice.Toolkits.Clarify.Contracts.ContractsToolkitBase)

Public Methods

 | Name | Description
Public Method | AcceptQuote | Overloaded. Accept the specified Quote from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.
Public Method | AddPOToSchedule | Overloaded. Used to add purchase orders to schedules of contracts. This overload takes a set of required parameters for the API.
Public Method | AssignQuote | Overloaded. Assign the Quote to a new user. This overload takes a set of required parameters for the API.
Public Method | ChangeQuoteStatus | Overloaded. Causes the specified quote to have its status changed. This overload takes a set of required parameters for the API.
Public Method | CreateContract | Overloaded. Used to create a new contract. This overload takes a set of required parameters for the API.
Public Method | CreateContractLineItem | Overloaded. Used to create quote/contract line items. This overload takes a set of required parameters for the API.
Public Method | CreatePriceInstance | Overloaded. Used to create a new price instance for a support program. This overload takes a set of required parameters for the API.
Public Method | CreateSchedule | Overloaded. Used to create a contract schedule. This overload takes a set of required parameters for the API.
Public Method | DeleteSitePart | Overloaded. Used to delete a site_part in Clarify, and then unrelate the site_part from all other related records. This overload takes a set of required parameters for the API.
Public Method | DispatchQuote | Overloaded. Dispatch the Quote to the specified queue. This overload takes a set of required parameters for the API.
Public Method | ForwardQuote | Overloaded. Reject-forward the Quote from one queue to another. This overload takes a set of required parameters for the API.
Public Method | LogContractNote | Overloaded. Causes a note log to be created and added to the specified contract. This overload takes a set of required parameters for the API.
Public Method | MoveQuote | Overloaded. Move the Quote from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
Public Method | RejectContract | Overloaded. Reject the Contract from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.
Public Method | RejectQuote | Overloaded. Reject the Quote from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.
Public Method | RelateContractItemToSitePart | Overloaded. Used to relate (or unrelate) a Site Part from a contract line item. This overload takes a set of required parameters for the API.
Public Method | ReopenContract | Overloaded. Causes the specified contract to be reopened. This overload takes a set of required parameters for the API.
Public Method | UnrelateContractItemFromSitePart | Overloaded. Used to unrelate a Site Part from a contract line item. This overload takes a set of required parameters for the API.
Public Method | UpdateSchedule | Overloaded. Used to update a contract schedule. This overload takes a set of required parameters for the API.
Public Method | YankQuote | Overloaded. Yank the Quote from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.

Reference

ContractsToolkit Class
FChoice.Toolkits.Clarify.Contracts Namespace


ContractsToolkit Constructor | fcSDK Documentation

ContractsToolkit Constructor

Overload List

Overload | Description
ContractsToolkit Constructor(ClarifySession) | Initializes a new instance of the ContractsToolkit class using a ClarifySession object.
ContractsToolkit Constructor(IFCApplication,IFCSession) | Initializes a new instance of the ContractsToolkit class using a Compatibility application and session.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class ContractsToolkit Members


ContractsToolkit Constructor(ClarifySession) | fcSDK Documentation

ContractsToolkit Constructor(ClarifySession)

The session under which the toolkit APIs will be executed.

Initializes a new instance of the ContractsToolkit class using a ClarifySession object.

Syntax

'Declaration

Public Function New( _
   ByVal _session_ As ClarifySession _
)

public ContractsToolkit(
   ClarifySession _session_
)

Parameters

session

The session under which the toolkit APIs will be executed.

Remarks

If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


ContractsToolkit Constructor(IFCApplication,IFCSession) | fcSDK Documentation

ContractsToolkit Constructor(IFCApplication,IFCSession)

The compatibility application under which the toolkit APIs will be executed.

The compatibility session under which the toolkit APIs will be executed.

Initializes a new instance of the ContractsToolkit class using a Compatibility application and session.

Syntax

'Declaration

Public Function New( _
   ByVal _application_ As IFCApplication, _
   ByVal _session_ As IFCSession _
)

public ContractsToolkit(
   IFCApplication _application_,
   IFCSession _session_
)

Parameters

application

The compatibility application under which the toolkit APIs will be executed.

session

The compatibility session under which the toolkit APIs will be executed.

Remarks

If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


AcceptQuote Method (ContractsToolkit) | fcSDK Documentation

AcceptQuote Method (ContractsToolkit)

Overload List

Overload | Description
AcceptQuote(String) | Accept the specified Quote from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.
AcceptQuote(AcceptQuoteSetup) | Accept the specified Quote from the queue in which it is currently dispatched. This overload takes a setup object.
AcceptQuote(AcceptQuoteSetup,IDbTransaction) | Accept the specified Quote from the queue in which it is currently dispatched. This overload takes a setup object and a database transaction.

Remarks

The Quote must be currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class ContractsToolkit Members AcceptQuoteSetup Class


AcceptQuote(String) Method | fcSDK Documentation

AcceptQuote(String) Method

Quote Identifier.

Accept the specified Quote from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function AcceptQuote( _
   ByVal _quoteIDNum_ As String _
) As ToolkitResult

public ToolkitResult AcceptQuote(
   string _quoteIDNum_
)

Parameters

quoteIDNum

Quote Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Quote must be currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


AcceptQuote(AcceptQuoteSetup) Method | fcSDK Documentation

AcceptQuote(AcceptQuoteSetup) Method

Setup object for API invocation.

Accept the specified Quote from the queue in which it is currently dispatched. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function AcceptQuote( _
   ByVal _setupParam_ As AcceptQuoteSetup _
) As ToolkitResult

public ToolkitResult AcceptQuote(
   AcceptQuoteSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Quote must be currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List
AcceptQuoteSetup Class


AcceptQuote(AcceptQuoteSetup,IDbTransaction) Method | fcSDK Documentation

AcceptQuote(AcceptQuoteSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Accept the specified Quote from the queue in which it is currently dispatched. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function AcceptQuote( _
   ByVal _setupParam_ As AcceptQuoteSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult AcceptQuote(
   AcceptQuoteSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Quote must be currently dispatched to a queue.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


AddPOToSchedule Method | fcSDK Documentation

AddPOToSchedule Method

Overload List

Overload | Description
AddPOToSchedule(String,String,String,Decimal) | Used to add purchase orders to schedules of contracts. This overload takes a set of required parameters for the API.
AddPOToSchedule(AddPOToScheduleSetup) | Used to add purchase orders to schedules of contracts. This overload takes a setup object.
AddPOToSchedule(AddPOToScheduleSetup,IDbTransaction) | Used to add purchase orders to schedules of contracts. This overload takes a setup object and a database transaction.

Remarks

The PO number cannot be defined already for the schedule.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class ContractsToolkit Members AddPOToScheduleSetup Class


AddPOToSchedule(String,String,String,Decimal) Method | fcSDK Documentation

AddPOToSchedule(String,String,String,Decimal) Method

Contract Identifier.

Schedule Identifier.

Purchase Order Identifier.

The amount of the Purchase Order.

Used to add purchase orders to schedules of contracts. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function AddPOToSchedule( _
   ByVal _contractIDNum_ As String, _
   ByVal _scheduleIDNum_ As String, _
   ByVal _poIDNum_ As String, _
   ByVal _poAmount_ As Decimal _
) As ToolkitResult

public ToolkitResult AddPOToSchedule(
   string _contractIDNum_,
   string _scheduleIDNum_,
   string _poIDNum_,
   decimal _poAmount_
)

Parameters

contractIDNum

Contract Identifier.

scheduleIDNum

Schedule Identifier.

poIDNum

Purchase Order Identifier.

poAmount

The amount of the Purchase Order.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • IDNum - The IDNum of the PO.
  • Objid - The Objid of the PO.

Remarks

The PO number cannot be defined already for the schedule.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


AddPOToSchedule(AddPOToScheduleSetup) Method | fcSDK Documentation

AddPOToSchedule(AddPOToScheduleSetup) Method

Setup object for API invocation.

Used to add purchase orders to schedules of contracts. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function AddPOToSchedule( _
   ByVal _setupParam_ AddPOToScheduleSetup _
) As ToolkitResult

public ToolkitResult AddPOToSchedule(
   AddPOToScheduleSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • IDNum - The IDNum of the PO.
  • Objid - The Objid of the PO.

Remarks

The PO number cannot be defined already for the schedule.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List
AddPOToScheduleSetup Class


AddPOToSchedule(AddPOToScheduleSetup,IDbTransaction) Method | fcSDK Documentation

AddPOToSchedule(AddPOToScheduleSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to add purchase orders to schedules of contracts. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function AddPOToSchedule( _
   ByVal _setupParam_ As AddPOToScheduleSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult AddPOToSchedule(
   AddPOToScheduleSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The PO number cannot be defined already for the schedule.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


AssignQuote Method (ContractsToolkit) | fcSDK Documentation

AssignQuote Method (ContractsToolkit)

Overload List

Overload | Description
AssignQuote(String) | Assign the Quote to a new user. This overload takes a set of required parameters for the API.
AssignQuote(AssignQuoteSetup) | Assign the Quote to a new user. This overload takes a setup object.
AssignQuote(AssignQuoteSetup,IDbTransaction) | Assign the Quote to a new user. This overload takes a setup object and a database transaction.

Remarks

The Quote must be in the Open condition, and the user assigning the Quote does not have to be the owner of the Quote. In base Clarify, the assigner of a Quote must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the Quote in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class ContractsToolkit Members AssignQuoteSetup Class


AssignQuote(String) Method | fcSDK Documentation

AssignQuote(String) Method

Quote Identifier.

Assign the Quote to a new user. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function AssignQuote( _
   ByVal _quoteIDNum_ As String _
) As ToolkitResult

public ToolkitResult AssignQuote(
   string _quoteIDNum_
)

Parameters

quoteIDNum

Quote Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Quote must be in the Open condition, and the user assigning the Quote does not have to be the owner of the Quote. In base Clarify, the assigner of a Quote must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the Quote in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


AssignQuote(AssignQuoteSetup) Method | fcSDK Documentation

AssignQuote(AssignQuoteSetup) Method

Setup object for API invocation.

Assign the Quote to a new user. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function AssignQuote( _
   ByVal _setupParam_ AssignQuoteSetup _
) As ToolkitResult

public ToolkitResult AssignQuote(
   AssignQuoteSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Quote must be in the Open condition, and the user assigning the Quote does not have to be the owner of the Quote. In base Clarify, the assigner of a Quote must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the Quote in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List
AssignQuoteSetup Class


AssignQuote(AssignQuoteSetup,IDbTransaction) Method | fcSDK Documentation

AssignQuote(AssignQuoteSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Assign the Quote to a new user. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function AssignQuote( _
   ByVal _setupParam_ As AssignQuoteSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult AssignQuote(
   AssignQuoteSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Quote must be in the Open condition, and the user assigning the Quote does not have to be the owner of the Quote. In base Clarify, the assigner of a Quote must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the Quote in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


ChangeQuoteStatus Method (ContractsToolkit) | fcSDK Documentation

ChangeQuoteStatus Method (ContractsToolkit)

Overload List

Overload | Description
ChangeQuoteStatus(String) | Causes the specified quote to have its status changed. This overload takes a set of required parameters for the API.
ChangeQuoteStatus(ChangeQuoteStatusSetup) | Causes the specified quote to have its status changed. This overload takes a setup object.
ChangeQuoteStatus(ChangeQuoteStatusSetup,IDbTransaction) | Causes the specified quote to have its status changed. This overload takes a setup object and a database transaction.

Remarks

The quote may be in any valid condition, but the status selected MUST be valid for the current condition. In other words, you cannot assign an Active Contract condition status to a quote that is currently in Quote condition.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class ContractsToolkit Members ChangeQuoteStatusSetup Class


ChangeQuoteStatus(String) Method | fcSDK Documentation

ChangeQuoteStatus(String) Method

Quote Identifier.

Causes the specified quote to have its status changed. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function ChangeQuoteStatus( _
   ByVal _quoteIDNum_ As String _
) As ToolkitResult

public ToolkitResult ChangeQuoteStatus(
   string _quoteIDNum_
)

Parameters

quoteIDNum

Quote Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The quote may be in any valid condition, but the status selected MUST be valid for the current condition. In other words, you cannot assign an Active Contract condition status to a quote that is currently in Quote condition.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


ChangeQuoteStatus(ChangeQuoteStatusSetup) Method | fcSDK Documentation

ChangeQuoteStatus(ChangeQuoteStatusSetup) Method

Setup object for API invocation.

Causes the specified quote to have its status changed. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function ChangeQuoteStatus( _
   ByVal _setupParam_ ChangeQuoteStatusSetup _
) As ToolkitResult

public ToolkitResult ChangeQuoteStatus(
   ChangeQuoteStatusSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The quote may be in any valid condition, but the status selected MUST be valid for the current condition. In other words, you cannot assign an Active Contract condition status to a quote that is currently in Quote condition.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List
ChangeQuoteStatusSetup Class


ChangeQuoteStatus(ChangeQuoteStatusSetup,IDbTransaction) Method | fcSDK Documentation

ChangeQuoteStatus(ChangeQuoteStatusSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Causes the specified quote to have its status changed. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function ChangeQuoteStatus( _
   ByVal _setupParam_ As ChangeQuoteStatusSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult ChangeQuoteStatus(
   ChangeQuoteStatusSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The quote may be in any valid condition, but the status selected MUST be valid for the current condition. In other words, you cannot assign an Active Contract condition status to a quote that is currently in Quote condition.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


CreateContract Method (ContractsToolkit) | fcSDK Documentation

CreateContract Method (ContractsToolkit)

Overload List

Overload | Description
CreateContract(String) | Used to create a new contract. This overload takes a set of required parameters for the API.
CreateContract(CreateContractSetup) | Used to create a new contract. This overload takes a setup object.
CreateContract(CreateContractSetup,IDbTransaction) | Used to create a new contract. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class ContractsToolkit Members CreateContractSetup Class


CreateContract(String) Method | fcSDK Documentation

CreateContract(String) Method

Used to create a new contract.

Syntax

'Declaration

Public Overloads Function CreateContract( _
   ByVal _title_ As String _
) As ToolkitResult

public ToolkitResult CreateContract(
   string _title_
)

Parameters

title

The title of the Contract.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • IDNum - The IDNum of the Contract.
  • Objid - The Objid of the Contract.

Remarks

Each contract requires a unique, valid title. Everything else is optional. You may specify either an account or contact for a contract (or neither), you may specify a contract ID or let the API auto-generate the contract ID for you. You may specify the user who created the contract as well as the contract’s administrator, and you may specify additional fields. You may have a creation time bomb generated (for notifications). The objid of the contract created is returned. You may also specify a bill-to and ship-to site. These sites will be related to the default schedule. If empty, no site is related. If you do not wish to associate an account or contact against the contract, leave the account and contact parameters empty. You may also initially dispatch the contract. If you specify a queue name, the contract will be dispatched to that queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class ContractsToolkit Members Overload List


CreateContract(CreateContractSetup) Method | fcSDK Documentation

CreateContract(CreateContractSetup) Method

Setup object for API invocation.

Used to create a new contract. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreateContract( _
   ByVal _setupParam_ CreateContractSetup _
) As ToolkitResult

public ToolkitResult CreateContract(
   CreateContractSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Contract.
  • IDNum - The IDNum of the Contract.

Remarks

Each contract requires a unique, valid title. Everything else is optional. You may specify either an account or contact for a contract (or neither), you may specify a contract ID or let the API auto-generate the contract ID for you. You may specify the user who created the contract as well as the contract’s administrator, and you may specify additional fields. You may have a creation time bomb generated (for notifications). The objid of the contract created is returned. You may also specify a bill-to and ship-to site. These sites will be related to the default schedule. If empty, no site is related. If you do not wish to associate an account or contact against the contract, leave the account and contact parameters empty. You may also initially dispatch the contract. If you specify a queue name, the contract will be dispatched to that queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List
CreateContractSetup Class


CreateContract(CreateContractSetup,IDbTransaction) Method | fcSDK Documentation

CreateContract(CreateContractSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to create a new contract. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreateContract( _
   ByVal _setupParam_ As CreateContractSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreateContract(
   CreateContractSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


CreateContractLineItem Method | fcSDK Documentation

CreateContractLineItem Method

Overload List

Overload | Description
CreateContractLineItem(String,String,String,String,Int32,String,Int32) | Used to create quote/contract line items. This overload takes a set of required parameters for the API.
CreateContractLineItem(String,String,String,String,String,String,Int32) | Used to create quote/contract line items. This overload takes a set of required parameters for the API.
CreateContractLineItem(CreateContractLineItemSetup) | Used to create quote/contract line items. This overload takes a setup object.
CreateContractLineItem(CreateContractLineItemSetup,IDbTransaction) | Used to create quote/contract line items. This overload takes a setup object and a database transaction.

Remarks

The API requires that a valid quote already exist, and that it have at least one valid schedule. In addition, the supplied part/revision must have a price defined for it in the schedule, or you must provide an override.

The API will create a line item, add it to the proper contract/quote, and adjust all of the totals. In addition, the schedule adjustments (if any) for the schedule of the line item will be recalculated, given the new schedule totals.

The API does not do a few other items in the base GUI function. By and large, they are expected to be supplied with other API calls. For example, line item adjustments are not part of this API. If they are required, the line should be created, and then the adjustment should be applied. Parent/child line items are not provided for in the default API. Also, proration (ClearContracts) is currently hard-coded.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class ContractsToolkit Members CreateContractLineItemSetup Class


CreateContractLineItem(String,String,String,String,Int32,String,Int32) Method | fcSDK Documentation

CreateContractLineItem(String,String,String,String,Int32,String,Int32) Method

Contract Identifier.

The part number for the Line Item.

The domain of the part for the Line Item.

The revision of the part for the Line Item.

The quantity of the part for the Line Item.

Name of the schedule from the Contract to put the Line Item on.

The objid of the parent Line Item.

Used to create quote/contract line items. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreateContractLineItem( _
   ByVal _contractIDNum_ As String, _
   ByVal _partNumber_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _quantity_ As Integer, _
   ByVal _priceSchedule_ As String, _
   ByVal _parentLineItemObjid_ As Integer _
) As ToolkitResult

public ToolkitResult CreateContractLineItem(
   string _contractIDNum_,
   string _partNumber_,
   string _partDomain_,
   string _partRevision_,
   int _quantity_,
   string _priceSchedule_,
   int _parentLineItemObjid_
)

Parameters

contractIDNum

Contract Identifier.

partNumber

The part number for the Line Item.

partDomain

The domain of the part for the Line Item.

partRevision

The revision of the part for the Line Item.

quantity

The quantity of the part for the Line Item.

priceSchedule

Name of the schedule from the Contract to put the Line Item on.

parentLineItemObjid

The objid of the parent Line Item.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the ContractLineItem.

Remarks

The API requires that a valid quote already exist, and that it have at least one valid schedule. In addition, the supplied part/revision must have a price defined for it in the schedule, or you must provide an override.

The API will create a line item, add it to the proper contract/quote, and adjust all of the totals. In addition, the schedule adjustments (if any) for the schedule of the line item will be recalculated, given the new schedule totals.

The API does not do a few other items in the base GUI function. By and large, they are expected to be supplied with other API calls. For example, line item adjustments are not part of this API. If they are required, the line should be created, and then the adjustment should be applied. Parent/child line items are not provided for in the default API. Also, proration (ClearContracts) is currently hard-coded.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


CreateContractLineItem(String,String,String,String,String,String,Int32) Method | fcSDK Documentation

CreateContractLineItem(String,String,String,String,String,String,Int32) Method

Contract Identifier.

The part number for the Line Item.

The domain of the part for the Line Item.

The revision of the part for the Line Item.

Name of the schedule from the Contract to put the Line Item on.

The serial number of the part for the Line Item.

The objid of the parent Line Item.

Used to create quote/contract line items. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreateContractLineItem( _
   ByVal _contractIDNum_ As String, _
   ByVal _partNumber_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _priceSchedule_ As String, _
   ByVal _serialNumber_ As String, _
   ByVal _parentLineItemObjid_ As Integer _
) As ToolkitResult

public ToolkitResult CreateContractLineItem(
   string _contractIDNum_,
   string _partNumber_,
   string _partDomain_,
   string _partRevision_,
   string _priceSchedule_,
   string _serialNumber_,
   int _parentLineItemObjid_
)

Parameters

contractIDNum

Contract Identifier.

partNumber

The part number for the Line Item.

partDomain

The domain of the part for the Line Item.

partRevision

The revision of the part for the Line Item.

priceSchedule

Name of the schedule from the Contract to put the Line Item on.

serialNumber

The serial number of the part for the Line Item.

parentLineItemObjid

The objid of the parent Line Item.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the ContractLineItem.

Remarks

The API requires that a valid quote already exist, and that it have at least one valid schedule. In addition, the supplied part/revision must have a price defined for it in the schedule, or you must provide an override.

The API will create a line item, add it to the proper contract/quote, and adjust all of the totals. In addition, the schedule adjustments (if any) for the schedule of the line item will be recalculated, given the new schedule totals.

The API does not do a few other items in the base GUI function. By and large, they are expected to be supplied with other API calls. For example, line item adjustments are not part of this API. If they are required, the line should be created, and then the adjustment should be applied. Parent/child line items are not provided for in the default API. Also, proration (ClearContracts) is currently hard-coded.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


CreateContractLineItem(CreateContractLineItemSetup) Method | fcSDK Documentation

CreateContractLineItem(CreateContractLineItemSetup) Method

Setup object for API invocation.

Used to create quote/contract line items. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreateContractLineItem( _
   ByVal _setupParam_ CreateContractLineItemSetup _
) As ToolkitResult

public ToolkitResult CreateContractLineItem(
   CreateContractLineItemSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the ContractLineItem.

Remarks

The API requires that a valid quote already exist, and that it have at least one valid schedule. In addition, the supplied part/revision must have a price defined for it in the schedule, or you must provide an override.

The API will create a line item, add it to the proper contract/quote, and adjust all of the totals. In addition, the schedule adjustments (if any) for the schedule of the line item will be recalculated, given the new schedule totals.

The API does not do a few other items in the base GUI function. By and large, they are expected to be supplied with other API calls. For example, line item adjustments are not part of this API. If they are required, the line should be created, and then the adjustment should be applied. Parent/child line items are not provided for in the default API. Also, proration (ClearContracts) is currently hard-coded.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List
CreateContractLineItemSetup Class


CreateContractLineItem(CreateContractLineItemSetup,IDbTransaction) Method | fcSDK Documentation

CreateContractLineItem(CreateContractLineItemSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to create quote/contract line items. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreateContractLineItem( _
   ByVal _setupParam_ As CreateContractLineItemSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreateContractLineItem(
   CreateContractLineItemSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The API requires that a valid quote already exist, and that it have at least one valid schedule. In addition, the supplied part/revision must have a price defined for it in the schedule, or you must provide an override.

The API will create a line item, add it to the proper contract/quote, and adjust all of the totals. In addition, the schedule adjustments (if any) for the schedule of the line item will be recalculated, given the new schedule totals.

The API does not do a few other items in the base GUI function. By and large, they are expected to be supplied with other API calls. For example, line item adjustments are not part of this API. If they are required, the line should be created, and then the adjustment should be applied. Parent/child line items are not provided for in the default API. Also, proration (ClearContracts) is currently hard-coded.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


CreatePriceInstance Method (ContractsToolkit) | fcSDK Documentation

CreatePriceInstance Method (ContractsToolkit)

Overload List

Overload | Description
CreatePriceInstance(String,String,String,String,String,PriceInstanceType,Int32) | Used to create a new price instance for a support program. This overload takes a set of required parameters for the API.
CreatePriceInstance(CreatePriceInstanceSetup) | Used to create a new price instance for a support program. This overload takes a setup object.
CreatePriceInstance(CreatePriceInstanceSetup,IDbTransaction) | Used to create a new price instance for a support program. This overload takes a setup object and a database transaction.

Remarks

You may specify the part for product based support programs, or leave it blank when creating price instances for either site or independent support programs. If you do specify a part, you must include its domain and revision (mod level).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class ContractsToolkit Members CreatePriceInstanceSetup Class


CreatePriceInstance(String,String,String,String,String,PriceInstanceType,Int32) Method | fcSDK Documentation

CreatePriceInstance(String,String,String,String,String,PriceInstanceType,Int32) Method

The nuber of the part for the Price Instance.

The revision of the part for the Price Instance.

The domain of the part for the Price Instance.

The support program for which this Price Instance is being created.

The title of the Price Program for this Price Instance. If blank then "US Std Price List" will be used.

The price type for the Price Instance.

The quantity of the part for the Price Instance. If not set, it will default to a zero price quantity.

Used to create a new price instance for a support program. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreatePriceInstance( _
   ByVal _partNumber_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _supportProgram_ As String, _
   ByVal _priceProgram_ As String, _
   ByVal _priceType_ As PriceInstanceType, _
   ByVal _quantity_ As Integer _
) As ToolkitResult

public ToolkitResult CreatePriceInstance(
   string _partNumber_,
   string _partRevision_,
   string _partDomain_,
   string _supportProgram_,
   string _priceProgram_,
   PriceInstanceType _priceType_,
   int _quantity_
)

Parameters

partNumber

The nuber of the part for the Price Instance.

partRevision

The revision of the part for the Price Instance.

partDomain

The domain of the part for the Price Instance.

supportProgram

The support program for which this Price Instance is being created.

priceProgram

The title of the Price Program for this Price Instance. If blank then "US Std Price List" will be used.

priceType

The price type for the Price Instance.

quantity

The quantity of the part for the Price Instance. If not set, it will default to a zero price quantity.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - Objid of the Price Instance record.

Remarks

You may specify the part for product based support programs, or leave it blank when creating price instances for either site or independent support programs. If you do specify a part, you must include its domain and revision (mod level).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


CreatePriceInstance(CreatePriceInstanceSetup) Method | fcSDK Documentation

CreatePriceInstance(CreatePriceInstanceSetup) Method

Setup object for API invocation.

Used to create a new price instance for a support program. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreatePriceInstance( _
   ByVal _setupParam_ CreatePriceInstanceSetup _
) As ToolkitResult

public ToolkitResult CreatePriceInstance(
   CreatePriceInstanceSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - Objid of the Price Instance record.

Remarks

You may specify the part for product based support programs, or leave it blank when creating price instances for either site or independent support programs. If you do specify a part, you must include its domain and revision (mod level).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List
CreatePriceInstanceSetup Class


CreatePriceInstance(CreatePriceInstanceSetup,IDbTransaction) Method | fcSDK Documentation

CreatePriceInstance(CreatePriceInstanceSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to create a new price instance for a support program. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreatePriceInstance( _
   ByVal _setupParam_ As CreatePriceInstanceSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreatePriceInstance(
   CreatePriceInstanceSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

You may specify the part for product based support programs, or leave it blank when creating price instances for either site or independent support programs. If you do specify a part, you must include its domain and revision (mod level).

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


CreateSchedule Method | fcSDK Documentation

CreateSchedule Method

Overload List

Overload | Description
CreateSchedule(String) | Used to create a contract schedule. This overload takes a set of required parameters for the API.
CreateSchedule(CreateScheduleSetup) | Used to create a contract schedule. This overload takes a setup object.
CreateSchedule(CreateScheduleSetup,IDbTransaction) | Used to create a contract schedule. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class ContractsToolkit Members CreateScheduleSetup Class


CreateSchedule(String) Method | fcSDK Documentation

CreateSchedule(String) Method

Contract Identifier.

Used to create a contract schedule. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreateSchedule( _
   ByVal _contractIDNum_ As String _
) As ToolkitResult

public ToolkitResult CreateSchedule(
   string _contractIDNum_
)

Parameters

contractIDNum

Contract Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The contract ID must be specified, and the ID of the schedule is also specified. You may specify the bill-to or ship-to site, the price program, and the code list values. In addition, you may specify a variety of dates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


CreateSchedule(CreateScheduleSetup) Method | fcSDK Documentation

CreateSchedule(CreateScheduleSetup) Method

Setup object for API invocation.

Used to create a contract schedule. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreateSchedule( _
   ByVal _setupParam_ CreateScheduleSetup _
) As ToolkitResult

public ToolkitResult CreateSchedule(
   CreateScheduleSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The contract ID must be specified, and the ID of the schedule is also specified. You may specify the bill-to or ship-to site, the price program, and the code list values. In addition, you may specify a variety of dates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List
CreateScheduleSetup Class


CreateSchedule(CreateScheduleSetup,IDbTransaction) Method | fcSDK Documentation

CreateSchedule(CreateScheduleSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to create a contract schedule. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreateSchedule( _
   ByVal _setupParam_ As CreateScheduleSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreateSchedule(
   CreateScheduleSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


DeleteSitePart Method | fcSDK Documentation

DeleteSitePart Method

Overload List

Overload | Description
DeleteSitePart(Int32) | Used to delete a site_part in Clarify, and then unrelate the site_part from all other related records. This overload takes a set of required parameters for the API.
DeleteSitePart(DeleteSitePartSetup) | Used to delete a site_part in Clarify, and then unrelate the site_part from all other related records. This overload takes a setup object.
DeleteSitePart(DeleteSitePartSetup,IDbTransaction) | Used to delete a site_part in Clarify, and then unrelate the site_part from all other related records. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class ContractsToolkit Members DeleteSitePartSetup Class


DeleteSitePart(Int32) Method | fcSDK Documentation

DeleteSitePart(Int32) Method

The objid of the Site Part to be deleted.

Used to delete a site_part in Clarify, and then unrelate the site_part from all other related records. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function DeleteSitePart( _
   ByVal _sitePartObjid_ As Integer _
) As ToolkitResult

public ToolkitResult DeleteSitePart(
   int _sitePartObjid_
)

Parameters

sitePartObjid

The objid of the Site Part to be deleted.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


DeleteSitePart(DeleteSitePartSetup) Method | fcSDK Documentation

DeleteSitePart(DeleteSitePartSetup) Method

Setup object for API invocation.

Used to delete a site_part in Clarify, and then unrelate the site_part from all other related records. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function DeleteSitePart( _
   ByVal _setupParam_ DeleteSitePartSetup _
) As ToolkitResult

public ToolkitResult DeleteSitePart(
   DeleteSitePartSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List
DeleteSitePartSetup Class


DeleteSitePart(DeleteSitePartSetup,IDbTransaction) Method | fcSDK Documentation

DeleteSitePart(DeleteSitePartSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to delete a site_part in Clarify, and then unrelate the site_part from all other related records. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function DeleteSitePart( _
   ByVal _setupParam_ As DeleteSitePartSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult DeleteSitePart(
   DeleteSitePartSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


DispatchQuote Method (ContractsToolkit) | fcSDK Documentation

DispatchQuote Method (ContractsToolkit)

Overload List

Overload | Description
DispatchQuote(String,String) | Dispatch the Quote to the specified queue. This overload takes a set of required parameters for the API.
DispatchQuote(DispatchQuoteSetup) | Dispatch the Quote to the specified queue. This overload takes a setup object.
DispatchQuote(DispatchQuoteSetup,IDbTransaction) | Dispatch the Quote to the specified queue. This overload takes a setup object and a database transaction.

Remarks

The Quote must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class ContractsToolkit Members DispatchQuoteSetup Class


DispatchQuote(String,String) Method | fcSDK Documentation

DispatchQuote(String,String) Method

Quote Identifier.

The queue into which the Quote is to be dispatched.

Dispatch the Quote to the specified queue. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function DispatchQuote( _
   ByVal _quoteIDNum_ As String, _
   ByVal _queue_ As String _
) As ToolkitResult

public ToolkitResult DispatchQuote(
   string _quoteIDNum_,
   string _queue_
)

Parameters

quoteIDNum

Quote Identifier.

queue

The queue into which the Quote is to be dispatched.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Quote must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


DispatchQuote(DispatchQuoteSetup) Method | fcSDK Documentation

DispatchQuote(DispatchQuoteSetup) Method

Setup object for API invocation.

Dispatch the Quote to the specified queue. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function DispatchQuote( _
   ByVal _setupParam_ DispatchQuoteSetup _
) As ToolkitResult

public ToolkitResult DispatchQuote(
   DispatchQuoteSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Quote must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List
DispatchQuoteSetup Class


DispatchQuote(DispatchQuoteSetup,IDbTransaction) Method | fcSDK Documentation

DispatchQuote(DispatchQuoteSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Dispatch the Quote to the specified queue. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function DispatchQuote( _
   ByVal _setupParam_ As DispatchQuoteSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult DispatchQuote(
   DispatchQuoteSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Quote must be in open condition, and not currently dispatched to a queue.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


ForwardQuote Method (ContractsToolkit) | fcSDK Documentation

ForwardQuote Method (ContractsToolkit)

Overload List

Overload | Description
ForwardQuote(String,String) | Reject-forward the Quote from one queue to another. This overload takes a set of required parameters for the API.
ForwardQuote(ForwardQuoteSetup) | Reject-forward the Quote from one queue to another. This overload takes a setup object.
ForwardQuote(ForwardQuoteSetup,IDbTransaction) | Reject-forward the Quote from one queue to another. This overload takes a setup object and a database transaction.

Remarks

The Quote must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class ContractsToolkit Members ForwardQuoteSetup Class


ForwardQuote(String,String) Method | fcSDK Documentation

ForwardQuote(String,String) Method

Quote Identifier.

The new queue into which the Quote is to be forwarded.

Reject-forward the Quote from one queue to another. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function ForwardQuote( _
   ByVal _quoteIDNum_ As String, _
   ByVal _newQueue_ As String _
) As ToolkitResult

public ToolkitResult ForwardQuote(
   string _quoteIDNum_,
   string _newQueue_
)

Parameters

quoteIDNum

Quote Identifier.

newQueue

The new queue into which the Quote is to be forwarded.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Quote must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


ForwardQuote(ForwardQuoteSetup) Method | fcSDK Documentation

ForwardQuote(ForwardQuoteSetup) Method

Setup object for API invocation.

Reject-forward the Quote from one queue to another. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function ForwardQuote( _
   ByVal _setupParam_ ForwardQuoteSetup _
) As ToolkitResult

public ToolkitResult ForwardQuote(
   ForwardQuoteSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Quote must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List
ForwardQuoteSetup Class


ForwardQuote(ForwardQuoteSetup,IDbTransaction) Method | fcSDK Documentation

ForwardQuote(ForwardQuoteSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Reject-forward the Quote from one queue to another. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function ForwardQuote( _
   ByVal _setupParam_ As ForwardQuoteSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult ForwardQuote(
   ForwardQuoteSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Quote must be in open condition, and not currently dispatched to a queue.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


LogContractNote Method | fcSDK Documentation

LogContractNote Method

Overload List

Overload | Description
LogContractNote(String,String) | Causes a note log to be created and added to the specified contract. This overload takes a set of required parameters for the API.
LogContractNote(LogContractNoteSetup) | Causes a note log to be created and added to the specified contract. This overload takes a setup object.
LogContractNote(LogContractNoteSetup,IDbTransaction) | Causes a note log to be created and added to the specified contract. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class ContractsToolkit Members LogContractNoteSetup Class


LogContractNote(String,String) Method | fcSDK Documentation

LogContractNote(String,String) Method

Contract Identifier.

The notes being logged to the Contract.

Causes a note log to be created and added to the specified contract. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function LogContractNote( _
   ByVal _contractIDNum_ As String, _
   ByVal _notes_ As String _
) As ToolkitResult

public ToolkitResult LogContractNote(
   string _contractIDNum_,
   string _notes_
)

Parameters

contractIDNum

Contract Identifier.

notes

The notes being logged to the Contract.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the NotesLog.

Remarks

It logs the note with the user name specified. There can be Internal Use notes added. It allows the setting of optional fields on the notes_log record with the use of the AdditionalFields object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


LogContractNote(LogContractNoteSetup) Method | fcSDK Documentation

LogContractNote(LogContractNoteSetup) Method

Setup object for API invocation.

Causes a note log to be created and added to the specified contract. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function LogContractNote( _
   ByVal _setupParam_ LogContractNoteSetup _
) As ToolkitResult

public ToolkitResult LogContractNote(
   LogContractNoteSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the NotesLog.

Remarks

It logs the note with the user name specified. There can be Internal Use notes added. It allows the setting of optional fields on the notes_log record with the use of the AdditionalFields object.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List
LogContractNoteSetup Class


LogContractNote(LogContractNoteSetup,IDbTransaction) Method | fcSDK Documentation

LogContractNote(LogContractNoteSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Causes a note log to be created and added to the specified contract. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function LogContractNote( _
   ByVal _setupParam_ As LogContractNoteSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult LogContractNote(
   LogContractNoteSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


MoveQuote Method (ContractsToolkit) | fcSDK Documentation

MoveQuote Method (ContractsToolkit)

Overload List

Overload | Description
MoveQuote(String,String) | Move the Quote from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
MoveQuote(MoveQuoteSetup) | Move the Quote from one WipBin to another WipBin. This overload takes a setup object.
MoveQuote(MoveQuoteSetup,IDbTransaction) | Move the Quote from one WipBin to another WipBin. This overload takes a setup object and a database transaction.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the Quote, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class ContractsToolkit Members MoveQuoteSetup Class


MoveQuote(String,String) Method | fcSDK Documentation

MoveQuote(String,String) Method

Quote Identifier.

The new WipBin into which the Quote is to be moved.

Move the Quote from one WipBin to another WipBin. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function MoveQuote( _
   ByVal _quoteIDNum_ As String, _
   ByVal _newWipBin_ As String _
) As ToolkitResult

public ToolkitResult MoveQuote(
   string _quoteIDNum_,
   string _newWipBin_
)

Parameters

quoteIDNum

Quote Identifier.

newWipBin

The new WipBin into which the Quote is to be moved.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the Quote, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


MoveQuote(MoveQuoteSetup) Method | fcSDK Documentation

MoveQuote(MoveQuoteSetup) Method

Setup object for API invocation.

Move the Quote from one WipBin to another WipBin. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function MoveQuote( _
   ByVal _setupParam_ MoveQuoteSetup _
) As ToolkitResult

public ToolkitResult MoveQuote(
   MoveQuoteSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the Quote, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List
MoveQuoteSetup Class


MoveQuote(MoveQuoteSetup,IDbTransaction) Method | fcSDK Documentation

MoveQuote(MoveQuoteSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Move the Quote from one WipBin to another WipBin. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function MoveQuote( _
   ByVal _setupParam_ As MoveQuoteSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult MoveQuote(
   MoveQuoteSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the Quote, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


RejectContract Method | fcSDK Documentation

RejectContract Method

Overload List

Overload | Description
RejectContract(String) | Reject the Contract from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.
RejectContract(RejectContractSetup) | Reject the Contract from the queue in which it currently resides, and return it to the owner. This overload takes a setup object.
RejectContract(RejectContractSetup,IDbTransaction) | Reject the Contract from the queue in which it currently resides, and return it to the owner. This overload takes a setup object and a database transaction.

Remarks

The Contract must be in open condition, and currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class ContractsToolkit Members RejectContractSetup Class


RejectContract(String) Method | fcSDK Documentation

RejectContract(String) Method

Contract Identifier.

Reject the Contract from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function RejectContract( _
   ByVal _contractIDNum_ As String _
) As ToolkitResult

public ToolkitResult RejectContract(
   string _contractIDNum_
)

Parameters

contractIDNum

Contract Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Contract must be in open condition, and currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


RejectContract(RejectContractSetup) Method | fcSDK Documentation

RejectContract(RejectContractSetup) Method

Setup object for API invocation.

Reject the Contract from the queue in which it currently resides, and return it to the owner. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function RejectContract( _
   ByVal _setupParam_ RejectContractSetup _
) As ToolkitResult

public ToolkitResult RejectContract(
   RejectContractSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Contract must be in open condition, and currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List
RejectContractSetup Class


RejectContract(RejectContractSetup,IDbTransaction) Method | fcSDK Documentation

RejectContract(RejectContractSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Reject the Contract from the queue in which it currently resides, and return it to the owner. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function RejectContract( _
   ByVal _setupParam_ As RejectContractSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult RejectContract(
   RejectContractSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Contract must be in open condition, and currently dispatched to a queue.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


RejectQuote Method (ContractsToolkit) | fcSDK Documentation

RejectQuote Method (ContractsToolkit)

Overload List

Overload | Description
RejectQuote(String) | Reject the Quote from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.
RejectQuote(RejectQuoteSetup) | Reject the Quote from the queue in which it currently resides, and return it to the owner. This overload takes a setup object.
RejectQuote(RejectQuoteSetup,IDbTransaction) | Reject the Quote from the queue in which it currently resides, and return it to the owner. This overload takes a setup object and a database transaction.

Remarks

The Quote must be in open condition, and currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class ContractsToolkit Members RejectQuoteSetup Class


RejectQuote(String) Method | fcSDK Documentation

RejectQuote(String) Method

Quote Identifier.

Reject the Quote from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function RejectQuote( _
   ByVal _quoteIDNum_ As String _
) As ToolkitResult

public ToolkitResult RejectQuote(
   string _quoteIDNum_
)

Parameters

quoteIDNum

Quote Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Quote must be in open condition, and currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


RejectQuote(RejectQuoteSetup) Method | fcSDK Documentation

RejectQuote(RejectQuoteSetup) Method

Setup object for API invocation.

Reject the Quote from the queue in which it currently resides, and return it to the owner. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function RejectQuote( _
   ByVal _setupParam_ RejectQuoteSetup _
) As ToolkitResult

public ToolkitResult RejectQuote(
   RejectQuoteSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Quote must be in open condition, and currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List
RejectQuoteSetup Class


RejectQuote(RejectQuoteSetup,IDbTransaction) Method | fcSDK Documentation

RejectQuote(RejectQuoteSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Reject the Quote from the queue in which it currently resides, and return it to the owner. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function RejectQuote( _
   ByVal _setupParam_ As RejectQuoteSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult RejectQuote(
   RejectQuoteSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Quote must be in open condition, and currently dispatched to a queue.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


RelateContractItemToSitePart Method | fcSDK Documentation

RelateContractItemToSitePart Method

Overload List

Overload | Description
RelateContractItemToSitePart(Int32,String,String,String,String) | Used to relate (or unrelate) a Site Part from a contract line item. This overload takes a set of required parameters for the API.
RelateContractItemToSitePart(RelateContractItemToSitePartSetup) | Used to relate (or unrelate) a Site Part from a contract line item. This overload takes a setup object.
RelateContractItemToSitePart(RelateContractItemToSitePartSetup,IDbTransaction) | Used to relate (or unrelate) a Site Part from a contract line item. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class ContractsToolkit Members RelateContractItemToSitePartSetup Class


RelateContractItemToSitePart(Int32,String,String,String,String) Method | fcSDK Documentation

RelateContractItemToSitePart(Int32,String,String,String,String) Method

The objid of the Contract for this Line Item.

The number of the part for the Line Item.

The domain of the part for the Line Item.

The revision of the part for the Line Item.

The serial number of the site part for thie Line Item.

Used to relate (or unrelate) a Site Part from a contract line item. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function RelateContractItemToSitePart( _
   ByVal _contractObjid_ As Integer, _
   ByVal _partNumber_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _serialNumber_ As String _
) As ToolkitResult

public ToolkitResult RelateContractItemToSitePart(
   int _contractObjid_,
   string _partNumber_,
   string _partDomain_,
   string _partRevision_,
   string _serialNumber_
)

Parameters

contractObjid

The objid of the Contract for this Line Item.

partNumber

The number of the part for the Line Item.

partDomain

The domain of the part for the Line Item.

partRevision

The revision of the part for the Line Item.

serialNumber

The serial number of the site part for thie Line Item.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The line item’s objid is specified, along with the details for locating the site_part.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


RelateContractItemToSitePart(RelateContractItemToSitePartSetup) Method | fcSDK Documentation

RelateContractItemToSitePart(RelateContractItemToSitePartSetup) Method

Setup object for API invocation.

Used to relate (or unrelate) a Site Part from a contract line item. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function RelateContractItemToSitePart( _
   ByVal _setupParam_ RelateContractItemToSitePartSetup _
) As ToolkitResult

public ToolkitResult RelateContractItemToSitePart(
   RelateContractItemToSitePartSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The line item’s objid is specified, along with the details for locating the site_part.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List
RelateContractItemToSitePartSetup Class


RelateContractItemToSitePart(RelateContractItemToSitePartSetup,IDbTransaction) Method | fcSDK Documentation

RelateContractItemToSitePart(RelateContractItemToSitePartSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to relate (or unrelate) a Site Part from a contract line item. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function RelateContractItemToSitePart( _
   ByVal _setupParam_ As RelateContractItemToSitePartSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult RelateContractItemToSitePart(
   RelateContractItemToSitePartSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


ReopenContract Method | fcSDK Documentation

ReopenContract Method

Overload List

Overload | Description
ReopenContract(String,String) | Causes the specified contract to be reopened. This overload takes a set of required parameters for the API.
ReopenContract(ReopenContractSetup) | Causes the specified contract to be reopened. This overload takes a setup object.
ReopenContract(ReopenContractSetup,IDbTransaction) | Causes the specified contract to be reopened. This overload takes a setup object and a database transaction.

Remarks

This is augmented functionality from base Clarify, as a contract cannot be re-opened via the Clarify GUI. The date/time of the reopen, the person performing the reopen, the WIPBIN to place the contract in, and the new status of the contract can be specified. The person who reopens the contract becomes the new owner.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class ContractsToolkit Members ReopenContractSetup Class


ReopenContract(String,String) Method | fcSDK Documentation

ReopenContract(String,String) Method

Contract Identifier.

Element from the 'Quote Status' application list. If not set, the default status for the Active Contract condition is used.

Causes the specified contract to be reopened. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function ReopenContract( _
   ByVal _contractIDNum_ As String, _
   ByVal _status_ As String _
) As ToolkitResult

public ToolkitResult ReopenContract(
   string _contractIDNum_,
   string _status_
)

Parameters

contractIDNum

Contract Identifier.

status

Element from the 'Quote Status' application list. If not set, the default status for the Active Contract condition is used.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

This is augmented functionality from base Clarify, as a contract cannot be re-opened via the Clarify GUI. The date/time of the reopen, the person performing the reopen, the WIPBIN to place the contract in, and the new status of the contract can be specified. The person who reopens the contract becomes the new owner.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


ReopenContract(ReopenContractSetup) Method | fcSDK Documentation

ReopenContract(ReopenContractSetup) Method

Setup object for API invocation.

Causes the specified contract to be reopened. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function ReopenContract( _
   ByVal _setupParam_ ReopenContractSetup _
) As ToolkitResult

public ToolkitResult ReopenContract(
   ReopenContractSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

This is augmented functionality from base Clarify, as a contract cannot be re-opened via the Clarify GUI. The date/time of the reopen, the person performing the reopen, the WIPBIN to place the contract in, and the new status of the contract can be specified. The person who reopens the contract becomes the new owner.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List
ReopenContractSetup Class


ReopenContract(ReopenContractSetup,IDbTransaction) Method | fcSDK Documentation

ReopenContract(ReopenContractSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Causes the specified contract to be reopened. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function ReopenContract( _
   ByVal _setupParam_ As ReopenContractSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult ReopenContract(
   ReopenContractSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

This is augmented functionality from base Clarify, as a contract cannot be re-opened via the Clarify GUI. The date/time of the reopen, the person performing the reopen, the WIPBIN to place the contract in, and the new status of the contract can be specified. The person who reopens the contract becomes the new owner.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


UnrelateContractItemFromSitePart Method | fcSDK Documentation

UnrelateContractItemFromSitePart Method

Overload List

Overload | Description
UnrelateContractItemFromSitePart(Int32,String,String,String) | Used to unrelate a Site Part from a contract line item. This overload takes a set of required parameters for the API.
UnrelateContractItemFromSitePart(UnrelateContractItemFromSitePartSetup) | Used to unrelate a Site Part from a contract line item. This overload takes a setup object.
UnrelateContractItemFromSitePart(UnrelateContractItemFromSitePartSetup,IDbTransaction) | Used to unrelate a Site Part from a contract line item. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class ContractsToolkit Members UnrelateContractItemFromSitePartSetup Class


UnrelateContractItemFromSitePart(Int32,String,String,String) Method | fcSDK Documentation

UnrelateContractItemFromSitePart(Int32,String,String,String) Method

The objid of the Contract for this Line Item.

The part number for the Line Item.

The domain of the part for the Line Item.

The revision of the part for the Line Item.

Used to unrelate a Site Part from a contract line item. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function UnrelateContractItemFromSitePart( _
   ByVal _contractObjid_ As Integer, _
   ByVal _partNumber_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _partRevision_ As String _
) As ToolkitResult

public ToolkitResult UnrelateContractItemFromSitePart(
   int _contractObjid_,
   string _partNumber_,
   string _partDomain_,
   string _partRevision_
)

Parameters

contractObjid

The objid of the Contract for this Line Item.

partNumber

The part number for the Line Item.

partDomain

The domain of the part for the Line Item.

partRevision

The revision of the part for the Line Item.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The line item’s objid must be specified, along with the details for locating the site_part.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


UnrelateContractItemFromSitePart(UnrelateContractItemFromSitePartSetup) Method | fcSDK Documentation

UnrelateContractItemFromSitePart(UnrelateContractItemFromSitePartSetup) Method

Setup object for API invocation.

Used to unrelate a Site Part from a contract line item. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function UnrelateContractItemFromSitePart( _
   ByVal _setupParam_ UnrelateContractItemFromSitePartSetup _
) As ToolkitResult

public ToolkitResult UnrelateContractItemFromSitePart(
   UnrelateContractItemFromSitePartSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The line item’s objid must be specified, along with the details for locating the site_part.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List
UnrelateContractItemFromSitePartSetup Class


UnrelateContractItemFromSitePart(UnrelateContractItemFromSitePartSetup,IDbTransaction) Method | fcSDK Documentation

UnrelateContractItemFromSitePart(UnrelateContractItemFromSitePartSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to unrelate a Site Part from a contract line item. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UnrelateContractItemFromSitePart( _
   ByVal _setupParam_ As UnrelateContractItemFromSitePartSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UnrelateContractItemFromSitePart(
   UnrelateContractItemFromSitePartSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


UpdateSchedule Method | fcSDK Documentation

UpdateSchedule Method

Overload List

Overload | Description
UpdateSchedule(String,String) | Used to update a contract schedule. This overload takes a set of required parameters for the API.
UpdateSchedule(UpdateScheduleSetup) | Used to update a contract schedule. This overload takes a setup object.
UpdateSchedule(UpdateScheduleSetup,IDbTransaction) | Used to update a contract schedule. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class ContractsToolkit Members UpdateScheduleSetup Class


UpdateSchedule(String,String) Method | fcSDK Documentation

UpdateSchedule(String,String) Method

Contract Identifier.

Schedule Identifier.

Used to update a contract schedule. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function UpdateSchedule( _
   ByVal _contractIDNum_ As String, _
   ByVal _scheduleIDNum_ As String _
) As ToolkitResult

public ToolkitResult UpdateSchedule(
   string _contractIDNum_,
   string _scheduleIDNum_
)

Parameters

contractIDNum

Contract Identifier.

scheduleIDNum

Schedule Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The contract ID must be specified, and the ID of the schedule is also specified. You may specify the bill-to or ship-to site, the price program, and the code list values. In addition, you may specify a variety of dates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


UpdateSchedule(UpdateScheduleSetup) Method | fcSDK Documentation

UpdateSchedule(UpdateScheduleSetup) Method

Setup object for API invocation.

Used to update a contract schedule. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function UpdateSchedule( _
   ByVal _setupParam_ UpdateScheduleSetup _
) As ToolkitResult

public ToolkitResult UpdateSchedule(
   UpdateScheduleSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The contract ID must be specified, and the ID of the schedule is also specified. You may specify the bill-to or ship-to site, the price program, and the code list values. In addition, you may specify a variety of dates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List
UpdateScheduleSetup Class


UpdateSchedule(UpdateScheduleSetup,IDbTransaction) Method | fcSDK Documentation

UpdateSchedule(UpdateScheduleSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to update a contract schedule. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdateSchedule( _
   ByVal _setupParam_ As UpdateScheduleSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdateSchedule(
   UpdateScheduleSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


YankQuote Method (ContractsToolkit) | fcSDK Documentation

YankQuote Method (ContractsToolkit)

Overload List

Overload | Description
YankQuote(String) | Yank the Quote from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.
YankQuote(YankQuoteSetup) | Yank the Quote from its current location to a new owner's WipBin. This overload takes a setup object.
YankQuote(YankQuoteSetup,IDbTransaction) | Yank the Quote from its current location to a new owner's WipBin. This overload takes a setup object and a database transaction.

Remarks

The WipBin to place the Quote in may also be specified. This is augmented function from base Clarify, where the Quote is always placed in the default WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class ContractsToolkit Members YankQuoteSetup Class


YankQuote(String) Method | fcSDK Documentation

YankQuote(String) Method

Quote Identifier.

Yank the Quote from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function YankQuote( _
   ByVal _quoteIDNum_ As String _
) As ToolkitResult

public ToolkitResult YankQuote(
   string _quoteIDNum_
)

Parameters

quoteIDNum

Quote Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The WipBin to place the Quote in may also be specified. This is augmented function from base Clarify, where the Quote is always placed in the default WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


YankQuote(YankQuoteSetup) Method | fcSDK Documentation

YankQuote(YankQuoteSetup) Method

Setup object for API invocation.

Yank the Quote from its current location to a new owner's WipBin. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function YankQuote( _
   ByVal _setupParam_ YankQuoteSetup _
) As ToolkitResult

public ToolkitResult YankQuote(
   YankQuoteSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The WipBin to place the Quote in may also be specified. This is augmented function from base Clarify, where the Quote is always placed in the default WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List
YankQuoteSetup Class


YankQuote(YankQuoteSetup,IDbTransaction) Method | fcSDK Documentation

YankQuote(YankQuoteSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Yank the Quote from its current location to a new owner's WipBin. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function YankQuote( _
   ByVal _setupParam_ As YankQuoteSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult YankQuote(
   YankQuoteSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The WipBin to place the Quote in may also be specified. This is augmented function from base Clarify, where the Quote is always placed in the default WipBin.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkit Class
ContractsToolkit Members
Overload List


ContractsToolkitBase Class | fcSDK Documentation

ContractsToolkitBase Class

Syntax

'Declaration

Public MustInherit Class ContractsToolkitBase
   Inherits FChoice.Toolkits.Clarify.ToolkitBase

public abstract class ContractsToolkitBase : FChoice.Toolkits.Clarify.ToolkitBase

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.ToolkitBase
FChoice.Toolkits.Clarify.Contracts.ContractsToolkitBase
FChoice.Toolkits.Clarify.Contracts.ContractsToolkit

Requirements

Namespace: FChoice.Toolkits.Clarify.Contracts

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ContractsToolkitBase Members
FChoice.Toolkits.Clarify.Contracts Namespace


ContractsToolkitBase Class Members | fcSDK Documentation

ContractsToolkitBase Class Members

The following tables list the members exposed by ContractsToolkitBase.

Public Properties

 | Name | Description
Public Property | ImpersonatorUsername |

Reference

ContractsToolkitBase Class
FChoice.Toolkits.Clarify.Contracts Namespace


ImpersonatorUsername Property (ContractsToolkitBase) | fcSDK Documentation

ImpersonatorUsername Property (ContractsToolkitBase)

Syntax

'Declaration

Public Property ImpersonatorUsername As String

public string ImpersonatorUsername {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ContractsToolkitBase Class
ContractsToolkitBase Members


CreateContractLineItemSetup Class | fcSDK Documentation

CreateContractLineItemSetup Class

Used by the CreateContractLineItem method as setup data for invocation.

Syntax

'Declaration

Public Class CreateContractLineItemSetup

public class CreateContractLineItemSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Contracts.CreateContractLineItemSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Contracts

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateContractLineItemSetup Members
FChoice.Toolkits.Clarify.Contracts Namespace
CreateContractLineItem(CreateContractLineItemSetup) Method


CreateContractLineItemSetup Class Members | fcSDK Documentation

CreateContractLineItemSetup Class Members

The following tables list the members exposed by CreateContractLineItemSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateContractLineItemSetup Constructor | Overloaded.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | AutoInstall | Specifies whether to install the Line Item.
Public Property | Comments | Comments about the Line Item.
Public Property | ContractIDNum | Contract Identifier.
Public Property | CreateDate | The DateTime the Line Item was created. If not set, the current time is used.
Public Property | EndDate | The end DateTime for the Line Item. If not set, the CreateDate plus 1 year is used.
Public Property | IsTaxable | Indicates if the Line Item is taxable (true) or not (false).
Public Property | OverridePrice | If supplied, this is the per-unit price. If not set, price is taken from the price schedule.
Public Property | ParentLineItemObjid | The objid of the parent Line Item.
Public Property | PartDomain | The domain of the part for the Line Item.
Public Property | PartNumber | The part number for the Line Item.
Public Property | PartRevision | The revision of the part for the Line Item.
Public Property | POIDNum | Purchase Order Identifier.
Public Property | PriceSchedule | Name of the schedule from the Contract to put the Line Item on.
Public Property | Quantity | The quantity of the part for the Line Item.
Public Property | QuotedSiteIDNum | Site Identifier for the AutoInstall of this Line Item.
Public Property | SerialNumber | The serial number of the part for the Line Item.
Public Property | ServicedAtSiteIDNum | Site Identifier for servicing this Line Item.
Public Property | StartDate | The start DateTime for the Line Item. If not set, the CreateDate is used.
Public Property | UnitsUsed | The number of units used for the Line Item.
Public Property | UserName | The username of the user who is creating the Line Item. If not set, the Toolkit session user is used.

Reference

CreateContractLineItemSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
CreateContractLineItem(CreateContractLineItemSetup) Method


CreateContractLineItemSetup Constructor | fcSDK Documentation

CreateContractLineItemSetup Constructor

Overload List

Overload | Description
CreateContractLineItemSetup Constructor(String,String,String,String,Int32,String,Int32) | Initializes a new instance of the CreateContractLineItemSetup class. This overload takes a set of required parameters for the API.
CreateContractLineItemSetup Constructor(String,String,String,String,String,String,Int32) | Initializes a new instance of the CreateContractLineItemSetup class. This overload takes a set of required parameters for the API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractLineItemSetup Class CreateContractLineItemSetup Members


CreateContractLineItemSetup Constructor(String,String,String,String,Int32,String,Int32) | fcSDK Documentation

CreateContractLineItemSetup Constructor(String,String,String,String,Int32,String,Int32)

Contract Identifier.

The part number for the Line Item.

The domain of the part for the Line Item.

The revision of the part for the Line Item.

The quantity of the part for the Line Item.

Name of the schedule from the Contract to put the Line Item on.

The objid of the parent Line Item.

Initializes a new instance of the CreateContractLineItemSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _contractIDNum_ As String, _
   ByVal _partNumber_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _quantity_ As Integer, _
   ByVal _priceSchedule_ As String, _
   ByVal _parentLineItemObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public CreateContractLineItemSetup(
   string _contractIDNum_,
   string _partNumber_,
   string _partDomain_,
   string _partRevision_,
   int _quantity_,
   string _priceSchedule_,
   int _parentLineItemObjid_
)

Parameters

contractIDNum

Contract Identifier.

partNumber

The part number for the Line Item.

partDomain

The domain of the part for the Line Item.

partRevision

The revision of the part for the Line Item.

quantity

The quantity of the part for the Line Item.

priceSchedule

Name of the schedule from the Contract to put the Line Item on.

parentLineItemObjid

The objid of the parent Line Item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractLineItemSetup Class
CreateContractLineItemSetup Members
Overload List


CreateContractLineItemSetup Constructor(String,String,String,String,String,String,Int32) | fcSDK Documentation

CreateContractLineItemSetup Constructor(String,String,String,String,String,String,Int32)

Contract Identifier.

The part number for the Line Item.

The domain of the part for the Line Item.

The revision of the part for the Line Item.

Name of the schedule from the Contract to put the Line Item on.

The serial number of the part for the Line Item.

The objid of the parent Line Item.

Initializes a new instance of the CreateContractLineItemSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _contractIDNum_ As String, _
   ByVal _partNumber_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _priceSchedule_ As String, _
   ByVal _serialNumber_ As String, _
   ByVal _parentLineItemObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public CreateContractLineItemSetup(
   string _contractIDNum_,
   string _partNumber_,
   string _partDomain_,
   string _partRevision_,
   string _priceSchedule_,
   string _serialNumber_,
   int _parentLineItemObjid_
)

Parameters

contractIDNum

Contract Identifier.

partNumber

The part number for the Line Item.

partDomain

The domain of the part for the Line Item.

partRevision

The revision of the part for the Line Item.

priceSchedule

Name of the schedule from the Contract to put the Line Item on.

serialNumber

The serial number of the part for the Line Item.

parentLineItemObjid

The objid of the parent Line Item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractLineItemSetup Class
CreateContractLineItemSetup Members
Overload List


AdditionalFields Property (CreateContractLineItemSetup) | fcSDK Documentation

AdditionalFields Property (CreateContractLineItemSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractLineItemSetup Class
CreateContractLineItemSetup Members


AutoInstall Property (CreateContractLineItemSetup) | fcSDK Documentation

AutoInstall Property (CreateContractLineItemSetup)

Specifies whether to install the Line Item.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AutoInstall As Boolean

[PropertyBitValueAttribute()]
public bool AutoInstall {get; set;}

Remarks

If AutoInstall = True, a QuotedSiteIDNum must be supplied.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractLineItemSetup Class
CreateContractLineItemSetup Members


Comments Property (CreateContractLineItemSetup) | fcSDK Documentation

Comments Property (CreateContractLineItemSetup)

Comments about the Line Item.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Comments As String

[PropertyBitValueAttribute()]
public string Comments {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractLineItemSetup Class
CreateContractLineItemSetup Members


ContractIDNum Property (CreateContractLineItemSetup) | fcSDK Documentation

ContractIDNum Property (CreateContractLineItemSetup)

Contract Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContractIDNum As String

[PropertyBitValueAttribute()]
public string ContractIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractLineItemSetup Class
CreateContractLineItemSetup Members


CreateDate Property (CreateContractLineItemSetup) | fcSDK Documentation

CreateDate Property (CreateContractLineItemSetup)

The DateTime the Line Item was created. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractLineItemSetup Class
CreateContractLineItemSetup Members


EndDate Property (CreateContractLineItemSetup) | fcSDK Documentation

EndDate Property (CreateContractLineItemSetup)

The end DateTime for the Line Item. If not set, the CreateDate plus 1 year is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property EndDate As Date

[PropertyBitValueAttribute()]
public DateTime EndDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractLineItemSetup Class
CreateContractLineItemSetup Members


IsTaxable Property (CreateContractLineItemSetup) | fcSDK Documentation

IsTaxable Property (CreateContractLineItemSetup)

Indicates if the Line Item is taxable (true) or not (false).

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsTaxable As Boolean

[PropertyBitValueAttribute()]
public bool IsTaxable {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractLineItemSetup Class
CreateContractLineItemSetup Members


OverridePrice Property (CreateContractLineItemSetup) | fcSDK Documentation

OverridePrice Property (CreateContractLineItemSetup)

If supplied, this is the per-unit price. If not set, price is taken from the price schedule.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property OverridePrice As Double

[PropertyBitValueAttribute()]
public double OverridePrice {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractLineItemSetup Class
CreateContractLineItemSetup Members


ParentLineItemObjid Property (CreateContractLineItemSetup) | fcSDK Documentation

ParentLineItemObjid Property (CreateContractLineItemSetup)

The objid of the parent Line Item.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ParentLineItemObjid As Integer

[PropertyBitValueAttribute()]
public int ParentLineItemObjid {get; set;}

Remarks

If you wish to make this line item a parent line item, set this property's value to –1. Otherwise, put the objid of the parent line item in the field. It will be made a child of the parent line item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractLineItemSetup Class
CreateContractLineItemSetup Members


PartDomain Property (CreateContractLineItemSetup) | fcSDK Documentation

PartDomain Property (CreateContractLineItemSetup)

The domain of the part for the Line Item.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartDomain As String

[PropertyBitValueAttribute()]
public string PartDomain {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractLineItemSetup Class
CreateContractLineItemSetup Members


PartNumber Property (CreateContractLineItemSetup) | fcSDK Documentation

PartNumber Property (CreateContractLineItemSetup)

The part number for the Line Item.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartNumber As String

[PropertyBitValueAttribute()]
public string PartNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractLineItemSetup Class
CreateContractLineItemSetup Members


PartRevision Property (CreateContractLineItemSetup) | fcSDK Documentation

PartRevision Property (CreateContractLineItemSetup)

The revision of the part for the Line Item.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRevision As String

[PropertyBitValueAttribute()]
public string PartRevision {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractLineItemSetup Class
CreateContractLineItemSetup Members


POIDNum Property (CreateContractLineItemSetup) | fcSDK Documentation

POIDNum Property (CreateContractLineItemSetup)

Purchase Order Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property POIDNum As String

[PropertyBitValueAttribute()]
public string POIDNum {get; set;}

Remarks

Must be a valid purchase order for the contract schedule specified for this line item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractLineItemSetup Class
CreateContractLineItemSetup Members


PriceSchedule Property (CreateContractLineItemSetup) | fcSDK Documentation

PriceSchedule Property (CreateContractLineItemSetup)

Name of the schedule from the Contract to put the Line Item on.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PriceSchedule As String

[PropertyBitValueAttribute()]
public string PriceSchedule {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractLineItemSetup Class
CreateContractLineItemSetup Members


Quantity Property (CreateContractLineItemSetup) | fcSDK Documentation

Quantity Property (CreateContractLineItemSetup)

The quantity of the part for the Line Item.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Quantity As Integer

[PropertyBitValueAttribute()]
public int Quantity {get; set;}

Remarks

The units available is calcularted from this number.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractLineItemSetup Class
CreateContractLineItemSetup Members


QuotedSiteIDNum Property (CreateContractLineItemSetup) | fcSDK Documentation

QuotedSiteIDNum Property (CreateContractLineItemSetup)

Site Identifier for the AutoInstall of this Line Item.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property QuotedSiteIDNum As String

[PropertyBitValueAttribute()]
public string QuotedSiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractLineItemSetup Class
CreateContractLineItemSetup Members


SerialNumber Property (CreateContractLineItemSetup) | fcSDK Documentation

SerialNumber Property (CreateContractLineItemSetup)

The serial number of the part for the Line Item.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SerialNumber As String

[PropertyBitValueAttribute()]
public string SerialNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractLineItemSetup Class
CreateContractLineItemSetup Members


ServicedAtSiteIDNum Property (CreateContractLineItemSetup) | fcSDK Documentation

ServicedAtSiteIDNum Property (CreateContractLineItemSetup)

Site Identifier for servicing this Line Item.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ServicedAtSiteIDNum As String

[PropertyBitValueAttribute()]
public string ServicedAtSiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractLineItemSetup Class
CreateContractLineItemSetup Members


StartDate Property (CreateContractLineItemSetup) | fcSDK Documentation

StartDate Property (CreateContractLineItemSetup)

The start DateTime for the Line Item. If not set, the CreateDate is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property StartDate As Date

[PropertyBitValueAttribute()]
public DateTime StartDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractLineItemSetup Class
CreateContractLineItemSetup Members


UnitsUsed Property (CreateContractLineItemSetup) | fcSDK Documentation

UnitsUsed Property (CreateContractLineItemSetup)

The number of units used for the Line Item.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UnitsUsed As Double

[PropertyBitValueAttribute()]
public double UnitsUsed {get; set;}

Remarks

If = 0, then all of the parts are initially available.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractLineItemSetup Class
CreateContractLineItemSetup Members


UserName Property (CreateContractLineItemSetup) | fcSDK Documentation

UserName Property (CreateContractLineItemSetup)

The username of the user who is creating the Line Item. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractLineItemSetup Class
CreateContractLineItemSetup Members


CreateContractSetup Class | fcSDK Documentation

CreateContractSetup Class

Used by the CreateContract method as setup data for invocation.

Syntax

'Declaration

Public Class CreateContractSetup

public class CreateContractSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Contracts.CreateContractSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Contracts

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateContractSetup Members
FChoice.Toolkits.Clarify.Contracts Namespace
CreateContract(CreateContractSetup) Method


CreateContractSetup Class Members | fcSDK Documentation

CreateContractSetup Class Members

The following tables list the members exposed by CreateContractSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateContractSetup Constructor | Initializes a new instance of the CreateContractSetup class.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AccountIDNum | Account Identifier. | | Public Property | AccountName | Name of the Account that the Contract is related to. | | Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation. | | Public Property | AdminUserName | The username of the Administrator of the Contract. If not set, the Toolkit session user is used. | | Public Property | BillToSiteIDNum | Site Identifier for the billing of this Contract. If not set, no relation is added. | | Public Property | ContactFirstName | Contact's first name. | | Public Property | ContactLastName | Contact's last name. | | Public Property | ContactPhone | Contact's phone number. | | Public Property | ContractIDNum | Contract Identifier. | | Public Property | ContractType | Element from the 'Contract Type' user list. If not set, the default list value is used. | | Public Property | CreateDate | The DateTime the Contract was created. If not set, the current time is used. | | Public Property | DefaultExpirationDate | The default expiration DateTime for the Contract. If not set, the current time is used. | | Public Property | DefaultStartDate | The default starting DateTime for the Contract. If not set, the current time is used. | | Public Property | ExpireDate | The expiration DateTime for the Contract. If not set, the current time is used. | | Public Property | GenerateTimeBombs | Specifies if timebombs should be created. | | Public Property | IsEvergreen | Indicates that the Contract can be identified in queries or reports as being eligible for renewal (true) or not (false). | | Public Property | IsWarranty | Flag to set the contract line items' default start state to one day past the end of the part's warranty period (true) or not (false).

| | Public Property | PriceProgram | The title of the Price Program for this Contract. If not set, then "US Std Price List" will be used. | | Public Property | Queue | The title of the queue to dispatch the new Contract to. | | Public Property | RenewPriorDays | The number of days to renew the Contract before the ExpireDate. | | Public Property | ShipToSiteIDNum | Site Identifier for the shipment of this Contract. If not set, no relation is added. | | Public Property | StartDate | The starting DateTime for the Contract. If not set, the current time is used. | | Public Property | Status | Element from the 'Quote' application list. If not set, the default list value is used. | | Public Property | Terms | Element from the 'Terms and Conditions' user list. If not set, the default list value is used. | | Public Property | Title | The title of the Contract. | | Public Property | UserName | The username of the user who is creating the Contract. If not set, the Toolkit session user is used. |

Reference

CreateContractSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
CreateContract(CreateContractSetup) Method


CreateContractSetup Constructor | fcSDK Documentation

CreateContractSetup Constructor

The title of the Contract.

Initializes a new instance of the CreateContractSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _title_ As String _
)

[ConstructorIndexAttribute()]
public CreateContractSetup(
   string _title_
)

Parameters

title

The title of the Contract.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


AccountIDNum Property (CreateContractSetup) | fcSDK Documentation

AccountIDNum Property (CreateContractSetup)

Account Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AccountIDNum As String

[PropertyBitValueAttribute()]
public string AccountIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


AccountName Property (CreateContractSetup) | fcSDK Documentation

AccountName Property (CreateContractSetup)

Name of the Account that the Contract is related to.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AccountName As String

[PropertyBitValueAttribute()]
public string AccountName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


AdditionalFields Property (CreateContractSetup) | fcSDK Documentation

AdditionalFields Property (CreateContractSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


AdminUserName Property (CreateContractSetup) | fcSDK Documentation

AdminUserName Property (CreateContractSetup)

The username of the Administrator of the Contract. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AdminUserName As String

[PropertyBitValueAttribute()]
public string AdminUserName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


BillToSiteIDNum Property (CreateContractSetup) | fcSDK Documentation

BillToSiteIDNum Property (CreateContractSetup)

Site Identifier for the billing of this Contract. If not set, no relation is added.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property BillToSiteIDNum As String

[PropertyBitValueAttribute()]
public string BillToSiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


ContactFirstName Property (CreateContractSetup) | fcSDK Documentation

ContactFirstName Property (CreateContractSetup)

Contact's first name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactFirstName As String

[PropertyBitValueAttribute()]
public string ContactFirstName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


ContactLastName Property (CreateContractSetup) | fcSDK Documentation

ContactLastName Property (CreateContractSetup)

Contact's last name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactLastName As String

[PropertyBitValueAttribute()]
public string ContactLastName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


ContactPhone Property (CreateContractSetup) | fcSDK Documentation

ContactPhone Property (CreateContractSetup)

Contact's phone number.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactPhone As String

[PropertyBitValueAttribute()]
public string ContactPhone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


ContractIDNum Property (CreateContractSetup) | fcSDK Documentation

ContractIDNum Property (CreateContractSetup)

Contract Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContractIDNum As String

[PropertyBitValueAttribute()]
public string ContractIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


ContractType Property (CreateContractSetup) | fcSDK Documentation

ContractType Property (CreateContractSetup)

Element from the 'Contract Type' user list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContractType As String

[PropertyBitValueAttribute()]
public string ContractType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


CreateDate Property (CreateContractSetup) | fcSDK Documentation

CreateDate Property (CreateContractSetup)

The DateTime the Contract was created. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


DefaultExpirationDate Property | fcSDK Documentation

DefaultExpirationDate Property

The default expiration DateTime for the Contract. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property DefaultExpirationDate As Date

[PropertyBitValueAttribute()]
public DateTime DefaultExpirationDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


DefaultStartDate Property | fcSDK Documentation

DefaultStartDate Property

The default starting DateTime for the Contract. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property DefaultStartDate As Date

[PropertyBitValueAttribute()]
public DateTime DefaultStartDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


ExpireDate Property (CreateContractSetup) | fcSDK Documentation

ExpireDate Property (CreateContractSetup)

The expiration DateTime for the Contract. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ExpireDate As Date

[PropertyBitValueAttribute()]
public DateTime ExpireDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


GenerateTimeBombs Property (CreateContractSetup) | fcSDK Documentation

GenerateTimeBombs Property (CreateContractSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


IsEvergreen Property | fcSDK Documentation

IsEvergreen Property

Indicates that the Contract can be identified in queries or reports as being eligible for renewal (true) or not (false).

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsEvergreen As Boolean

[PropertyBitValueAttribute()]
public bool IsEvergreen {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


IsWarranty Property | fcSDK Documentation

IsWarranty Property

Flag to set the contract line items' default start state to one day past the end of the part's warranty period (true) or not (false).

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsWarranty As Boolean

[PropertyBitValueAttribute()]
public bool IsWarranty {get; set;}

Remarks

For service parts, the "end of warranty" is the service end date.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


PriceProgram Property (CreateContractSetup) | fcSDK Documentation

PriceProgram Property (CreateContractSetup)

The title of the Price Program for this Contract. If not set, then "US Std Price List" will be used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PriceProgram As String

[PropertyBitValueAttribute()]
public string PriceProgram {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


Queue Property (CreateContractSetup) | fcSDK Documentation

Queue Property (CreateContractSetup)

The title of the queue to dispatch the new Contract to.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Queue As String

[PropertyBitValueAttribute()]
public string Queue {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


RenewPriorDays Property | fcSDK Documentation

RenewPriorDays Property

The number of days to renew the Contract before the ExpireDate.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property RenewPriorDays As Integer

[PropertyBitValueAttribute()]
public int RenewPriorDays {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


ShipToSiteIDNum Property (CreateContractSetup) | fcSDK Documentation

ShipToSiteIDNum Property (CreateContractSetup)

Site Identifier for the shipment of this Contract. If not set, no relation is added.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ShipToSiteIDNum As String

[PropertyBitValueAttribute()]
public string ShipToSiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


StartDate Property (CreateContractSetup) | fcSDK Documentation

StartDate Property (CreateContractSetup)

The starting DateTime for the Contract. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property StartDate As Date

[PropertyBitValueAttribute()]
public DateTime StartDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


Status Property (CreateContractSetup) | fcSDK Documentation

Status Property (CreateContractSetup)

Element from the 'Quote' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Status As String

[PropertyBitValueAttribute()]
public string Status {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


Terms Property | fcSDK Documentation

Terms Property

Element from the 'Terms and Conditions' user list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Terms As String

[PropertyBitValueAttribute()]
public string Terms {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


Title Property (CreateContractSetup) | fcSDK Documentation

Title Property (CreateContractSetup)

The title of the Contract.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Title As String

[PropertyBitValueAttribute()]
public string Title {get; set;}

Remarks

The contract titles must be unique.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


UserName Property (CreateContractSetup) | fcSDK Documentation

UserName Property (CreateContractSetup)

The username of the user who is creating the Contract. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


CreatePriceInstanceSetup Class | fcSDK Documentation

CreatePriceInstanceSetup Class

Used by the CreatePriceInstance method as setup data for invocation.

Syntax

'Declaration

Public Class CreatePriceInstanceSetup

public class CreatePriceInstanceSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Contracts.CreatePriceInstanceSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Contracts

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreatePriceInstanceSetup Members
FChoice.Toolkits.Clarify.Contracts Namespace
CreatePriceInstance(CreatePriceInstanceSetup) Method


CreatePriceInstanceSetup Class Members | fcSDK Documentation

CreatePriceInstanceSetup Class Members

The following tables list the members exposed by CreatePriceInstanceSetup.

Public Constructors

 | Name | Description
Public Constructor | CreatePriceInstanceSetup Constructor | Initializes a new instance of the CreatePriceInstanceSetup class.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | EffectiveDate | The starting DateTime for the Price Instance. If not set, the starting date from the Price Program is used.
Public Property | ExpireDate | The ending DateTime for the Price Instance. If not set, the ending date from the Price Program is used.
Public Property | PartDomain | The domain of the part for the Price Instance.
Public Property | PartNumber | The nuber of the part for the Price Instance.
Public Property | PartRevision | The revision of the part for the Price Instance.
Public Property | Price | The price of the part for the Price Instance.
Public Property | PriceProgram | The title of the Price Program for this Price Instance. If blank then "US Std Price List" will be used.
Public Property | PriceType | The price type for the Price Instance.
Public Property | Quantity | The quantity of the part for the Price Instance. If not set, it will default to a zero price quantity.
Public Property | SupportProgram | The support program for which this Price Instance is being created.

Reference

CreatePriceInstanceSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
CreatePriceInstance(CreatePriceInstanceSetup) Method


CreatePriceInstanceSetup Constructor | fcSDK Documentation

CreatePriceInstanceSetup Constructor

The nuber of the part for the Price Instance.

The revision of the part for the Price Instance.

The domain of the part for the Price Instance.

The support program for which this Price Instance is being created.

The title of the Price Program for this Price Instance. If blank then "US Std Price List" will be used.

The price type for the Price Instance.

The quantity of the part for the Price Instance. If not set, it will default to a zero price quantity.

Initializes a new instance of the CreatePriceInstanceSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partNumber_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _supportProgram_ As String, _
   ByVal _priceProgram_ As String, _
   ByVal _priceType_ As PriceInstanceType, _
   ByVal _quantity_ As Integer _
)

[ConstructorIndexAttribute()]
public CreatePriceInstanceSetup(
   string _partNumber_,
   string _partRevision_,
   string _partDomain_,
   string _supportProgram_,
   string _priceProgram_,
   PriceInstanceType _priceType_,
   int _quantity_
)

Parameters

partNumber

The nuber of the part for the Price Instance.

partRevision

The revision of the part for the Price Instance.

partDomain

The domain of the part for the Price Instance.

supportProgram

The support program for which this Price Instance is being created.

priceProgram

The title of the Price Program for this Price Instance. If blank then "US Std Price List" will be used.

priceType

The price type for the Price Instance.

quantity

The quantity of the part for the Price Instance. If not set, it will default to a zero price quantity.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePriceInstanceSetup Class
CreatePriceInstanceSetup Members


AdditionalFields Property (CreatePriceInstanceSetup) | fcSDK Documentation

AdditionalFields Property (CreatePriceInstanceSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePriceInstanceSetup Class
CreatePriceInstanceSetup Members


EffectiveDate Property | fcSDK Documentation

EffectiveDate Property

The starting DateTime for the Price Instance. If not set, the starting date from the Price Program is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property EffectiveDate As Date

[PropertyBitValueAttribute()]
public DateTime EffectiveDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePriceInstanceSetup Class
CreatePriceInstanceSetup Members


ExpireDate Property (CreatePriceInstanceSetup) | fcSDK Documentation

ExpireDate Property (CreatePriceInstanceSetup)

The ending DateTime for the Price Instance. If not set, the ending date from the Price Program is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ExpireDate As Date

[PropertyBitValueAttribute()]
public DateTime ExpireDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePriceInstanceSetup Class
CreatePriceInstanceSetup Members


PartDomain Property (CreatePriceInstanceSetup) | fcSDK Documentation

PartDomain Property (CreatePriceInstanceSetup)

The domain of the part for the Price Instance.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartDomain As String

[PropertyBitValueAttribute()]
public string PartDomain {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePriceInstanceSetup Class
CreatePriceInstanceSetup Members


PartNumber Property (CreatePriceInstanceSetup) | fcSDK Documentation

PartNumber Property (CreatePriceInstanceSetup)

The nuber of the part for the Price Instance.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartNumber As String

[PropertyBitValueAttribute()]
public string PartNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePriceInstanceSetup Class
CreatePriceInstanceSetup Members


PartRevision Property (CreatePriceInstanceSetup) | fcSDK Documentation

PartRevision Property (CreatePriceInstanceSetup)

The revision of the part for the Price Instance.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRevision As String

[PropertyBitValueAttribute()]
public string PartRevision {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePriceInstanceSetup Class
CreatePriceInstanceSetup Members


Price Property (CreatePriceInstanceSetup) | fcSDK Documentation

Price Property (CreatePriceInstanceSetup)

The price of the part for the Price Instance.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Price As Double

[PropertyBitValueAttribute()]
public double Price {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePriceInstanceSetup Class
CreatePriceInstanceSetup Members


PriceProgram Property (CreatePriceInstanceSetup) | fcSDK Documentation

PriceProgram Property (CreatePriceInstanceSetup)

The title of the Price Program for this Price Instance. If blank then "US Std Price List" will be used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PriceProgram As String

[PropertyBitValueAttribute()]
public string PriceProgram {get; set;}

Remarks

Must be supplied and must be a valid Price Program.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePriceInstanceSetup Class
CreatePriceInstanceSetup Members


PriceType Property (CreatePriceInstanceSetup) | fcSDK Documentation

PriceType Property (CreatePriceInstanceSetup)

The price type for the Price Instance.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PriceType As PriceInstanceType

[PropertyBitValueAttribute()]
public PriceInstanceType PriceType {get; set;}

Remarks

The following values are used:

  • 0=fixed
  • 1=percent of product
  • 2=percent of option list (not supported at this time)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePriceInstanceSetup Class
CreatePriceInstanceSetup Members


Quantity Property (CreatePriceInstanceSetup) | fcSDK Documentation

Quantity Property (CreatePriceInstanceSetup)

The quantity of the part for the Price Instance. If not set, it will default to a zero price quantity.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Quantity As Integer

[PropertyBitValueAttribute()]
public int Quantity {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePriceInstanceSetup Class
CreatePriceInstanceSetup Members


SupportProgram Property | fcSDK Documentation

SupportProgram Property

The support program for which this Price Instance is being created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SupportProgram As String

[PropertyBitValueAttribute()]
public string SupportProgram {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePriceInstanceSetup Class
CreatePriceInstanceSetup Members


CreateScheduleSetup Class | fcSDK Documentation

CreateScheduleSetup Class

Used by the CreateSchedule method as setup data for invocation.

Syntax

'Declaration

Public Class CreateScheduleSetup

public class CreateScheduleSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Contracts.CreateScheduleSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Contracts

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateScheduleSetup Members
FChoice.Toolkits.Clarify.Contracts Namespace
CreateSchedule(CreateScheduleSetup) Method


CreateScheduleSetup Class Members | fcSDK Documentation

CreateScheduleSetup Class Members

The following tables list the members exposed by CreateScheduleSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateScheduleSetup Constructor | Initializes a new instance of the CreateScheduleSetup class.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | BillingATTN | The name of the Attention person at billing site.
Public Property | BillingFrequency | How often will this Schedule induce billing?
Public Property | BillingOption | For any Billing Frequency except "One Time," select whether the customer is billed in advance or after the fact.
Public Property | BillingPeriodStartDate | The billing period starting DateTime for the Schedule. If not set, the current time is used.
Public Property | BillSiteIDNum | Site Identifier for the billing of this Schedule.
Public Property | ChargeEndDate | The charging end DateTime for the Schedule. If not set, the current time is used.
Public Property | ChargeStartDate | The charging start DateTime for the Schedule. If not set, the current time is used.
Public Property | ContractIDNum | Contract Identifier.
Public Property | FirstBillingDate | The first billing DateTime for the Schedule. If not set, the current time is used.
Public Property | PriceProgram | The title of the Price Program for this Schedule. If blank then "US Std Price List" will be used.
Public Property | ScheduleIDNum | Schedule Identifier.
Public Property | ShipToSiteIDNum | Site Identifier for the shipment of this Schedule.

Reference

CreateScheduleSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
CreateSchedule(CreateScheduleSetup) Method


CreateScheduleSetup Constructor | fcSDK Documentation

CreateScheduleSetup Constructor

Contract Identifier.

Initializes a new instance of the CreateScheduleSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _contractIDNum_ As String _
)

[ConstructorIndexAttribute()]
public CreateScheduleSetup(
   string _contractIDNum_
)

Parameters

contractIDNum

Contract Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateScheduleSetup Class
CreateScheduleSetup Members


AdditionalFields Property (CreateScheduleSetup) | fcSDK Documentation

AdditionalFields Property (CreateScheduleSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateScheduleSetup Class
CreateScheduleSetup Members


BillingATTN Property (CreateScheduleSetup) | fcSDK Documentation

BillingATTN Property (CreateScheduleSetup)

The name of the Attention person at billing site.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property BillingATTN As String

[PropertyBitValueAttribute()]
public string BillingATTN {get; set;}

Remarks

If this field is set to “CLEAR”, the BillingATTN field is set to the empty string.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateScheduleSetup Class
CreateScheduleSetup Members


BillingFrequency Property (CreateScheduleSetup) | fcSDK Documentation

BillingFrequency Property (CreateScheduleSetup)

How often will this Schedule induce billing?

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property BillingFrequency As BillingFrequency

[PropertyBitValueAttribute()]
public BillingFrequency BillingFrequency {get; set;}

Remarks

These are the acceptable billing frequencies:

  • ANNUAL
  • SEMI_ANNUAL
  • QUARTERLY
  • MONTHLY
  • ONE_TIME

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateScheduleSetup Class
CreateScheduleSetup Members


BillingOption Property (CreateScheduleSetup) | fcSDK Documentation

BillingOption Property (CreateScheduleSetup)

For any Billing Frequency except "One Time," select whether the customer is billed in advance or after the fact.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property BillingOption As BillingOption

[PropertyBitValueAttribute()]
public BillingOption BillingOption {get; set;}

Remarks

These are the acceptable billing options:

  • IN_ADVANCE
  • IN_ARREARS

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateScheduleSetup Class
CreateScheduleSetup Members


BillingPeriodStartDate Property (CreateScheduleSetup) | fcSDK Documentation

BillingPeriodStartDate Property (CreateScheduleSetup)

The billing period starting DateTime for the Schedule. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property BillingPeriodStartDate As Date

[PropertyBitValueAttribute()]
public DateTime BillingPeriodStartDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateScheduleSetup Class
CreateScheduleSetup Members


BillSiteIDNum Property (CreateScheduleSetup) | fcSDK Documentation

BillSiteIDNum Property (CreateScheduleSetup)

Site Identifier for the billing of this Schedule.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property BillSiteIDNum As String

[PropertyBitValueAttribute()]
public string BillSiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateScheduleSetup Class
CreateScheduleSetup Members


ChargeEndDate Property (CreateScheduleSetup) | fcSDK Documentation

ChargeEndDate Property (CreateScheduleSetup)

The charging end DateTime for the Schedule. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ChargeEndDate As Date

[PropertyBitValueAttribute()]
public DateTime ChargeEndDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateScheduleSetup Class
CreateScheduleSetup Members


ChargeStartDate Property (CreateScheduleSetup) | fcSDK Documentation

ChargeStartDate Property (CreateScheduleSetup)

The charging start DateTime for the Schedule. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ChargeStartDate As Date

[PropertyBitValueAttribute()]
public DateTime ChargeStartDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateScheduleSetup Class
CreateScheduleSetup Members


ContractIDNum Property (CreateScheduleSetup) | fcSDK Documentation

ContractIDNum Property (CreateScheduleSetup)

Contract Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContractIDNum As String

[PropertyBitValueAttribute()]
public string ContractIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateScheduleSetup Class
CreateScheduleSetup Members


FirstBillingDate Property (CreateScheduleSetup) | fcSDK Documentation

FirstBillingDate Property (CreateScheduleSetup)

The first billing DateTime for the Schedule. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FirstBillingDate As Date

[PropertyBitValueAttribute()]
public DateTime FirstBillingDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateScheduleSetup Class
CreateScheduleSetup Members


PriceProgram Property (CreateScheduleSetup) | fcSDK Documentation

PriceProgram Property (CreateScheduleSetup)

The title of the Price Program for this Schedule. If blank then "US Std Price List" will be used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PriceProgram As String

[PropertyBitValueAttribute()]
public string PriceProgram {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateScheduleSetup Class
CreateScheduleSetup Members


ScheduleIDNum Property (CreateScheduleSetup) | fcSDK Documentation

ScheduleIDNum Property (CreateScheduleSetup)

Schedule Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ScheduleIDNum As String

[PropertyBitValueAttribute()]
public string ScheduleIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateScheduleSetup Class
CreateScheduleSetup Members


ShipToSiteIDNum Property (CreateScheduleSetup) | fcSDK Documentation

ShipToSiteIDNum Property (CreateScheduleSetup)

Site Identifier for the shipment of this Schedule.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ShipToSiteIDNum As String

[PropertyBitValueAttribute()]
public string ShipToSiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateScheduleSetup Class
CreateScheduleSetup Members


DeleteSitePartSetup Class | fcSDK Documentation

DeleteSitePartSetup Class

Used by the DeleteSitePart method as setup data for invocation.

Syntax

'Declaration

Public Class DeleteSitePartSetup

public class DeleteSitePartSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Contracts.DeleteSitePartSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Contracts

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

DeleteSitePartSetup Members
FChoice.Toolkits.Clarify.Contracts Namespace
DeleteSitePart(DeleteSitePartSetup) Method


DeleteSitePartSetup Class Members | fcSDK Documentation

DeleteSitePartSetup Class Members

The following tables list the members exposed by DeleteSitePartSetup.

Public Constructors

 | Name | Description
Public Constructor | DeleteSitePartSetup Constructor | Initializes a new instance of the DeleteSitePartSetup class.

Public Properties

 | Name | Description
Public Property | SitePartObjid | The objid of the Site Part to be deleted.

Reference

DeleteSitePartSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
DeleteSitePart(DeleteSitePartSetup) Method


DeleteSitePartSetup Constructor | fcSDK Documentation

DeleteSitePartSetup Constructor

The objid of the Site Part to be deleted.

Initializes a new instance of the DeleteSitePartSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _sitePartObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public DeleteSitePartSetup(
   int _sitePartObjid_
)

Parameters

sitePartObjid

The objid of the Site Part to be deleted.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteSitePartSetup Class
DeleteSitePartSetup Members


SitePartObjid Property (DeleteSitePartSetup) | fcSDK Documentation

SitePartObjid Property (DeleteSitePartSetup)

The objid of the Site Part to be deleted.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SitePartObjid As Integer

[PropertyBitValueAttribute()]
public int SitePartObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteSitePartSetup Class
DeleteSitePartSetup Members


DispatchQuoteSetup Class | fcSDK Documentation

DispatchQuoteSetup Class

Used by the DispatchQuote method as setup data for invocation.

Syntax

'Declaration

Public Class DispatchQuoteSetup

public class DispatchQuoteSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Contracts.DispatchQuoteSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Contracts

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

DispatchQuoteSetup Members
FChoice.Toolkits.Clarify.Contracts Namespace
DispatchQuote(DispatchQuoteSetup) Method


DispatchQuoteSetup Class Members | fcSDK Documentation

DispatchQuoteSetup Class Members

The following tables list the members exposed by DispatchQuoteSetup.

Public Constructors

 | Name | Description
Public Constructor | DispatchQuoteSetup Constructor | Initializes a new instance of the DispatchQuoteSetup class.

Public Properties

 | Name | Description
Public Property | DispatchDate | DateTime the Quote was dispatched. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Queue | The queue into which the Quote is to be dispatched.
Public Property | QuoteIDNum | Quote Identifier.
Public Property | UserName | The user who has dispatched the Quote. If not set, the Toolkit session user is used.

Reference

DispatchQuoteSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
DispatchQuote(DispatchQuoteSetup) Method


DispatchQuoteSetup Constructor | fcSDK Documentation

DispatchQuoteSetup Constructor

Quote Identifier.

The queue into which the Quote is to be dispatched.

Initializes a new instance of the DispatchQuoteSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _quoteIDNum_ As String, _
   ByVal _queue_ As String _
)

[ConstructorIndexAttribute()]
public DispatchQuoteSetup(
   string _quoteIDNum_,
   string _queue_
)

Parameters

quoteIDNum

Quote Identifier.

queue

The queue into which the Quote is to be dispatched.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchQuoteSetup Class
DispatchQuoteSetup Members


DispatchDate Property (DispatchQuoteSetup) | fcSDK Documentation

DispatchDate Property (DispatchQuoteSetup)

DateTime the Quote was dispatched. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property DispatchDate As Date

[PropertyBitValueAttribute()]
public DateTime DispatchDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchQuoteSetup Class
DispatchQuoteSetup Members


GenerateTimeBombs Property (DispatchQuoteSetup) | fcSDK Documentation

GenerateTimeBombs Property (DispatchQuoteSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchQuoteSetup Class
DispatchQuoteSetup Members


Queue Property (DispatchQuoteSetup) | fcSDK Documentation

Queue Property (DispatchQuoteSetup)

The queue into which the Quote is to be dispatched.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Queue As String

[PropertyBitValueAttribute()]
public string Queue {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchQuoteSetup Class
DispatchQuoteSetup Members


QuoteIDNum Property (DispatchQuoteSetup) | fcSDK Documentation

QuoteIDNum Property (DispatchQuoteSetup)

Quote Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property QuoteIDNum As String

[PropertyBitValueAttribute()]
public string QuoteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchQuoteSetup Class
DispatchQuoteSetup Members


UserName Property (DispatchQuoteSetup) | fcSDK Documentation

UserName Property (DispatchQuoteSetup)

The user who has dispatched the Quote. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchQuoteSetup Class
DispatchQuoteSetup Members


ForwardQuoteSetup Class | fcSDK Documentation

ForwardQuoteSetup Class

Used by the ForwardQuote method as setup data for invocation.

Syntax

'Declaration

Public Class ForwardQuoteSetup

public class ForwardQuoteSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Contracts.ForwardQuoteSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Contracts

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ForwardQuoteSetup Members
FChoice.Toolkits.Clarify.Contracts Namespace
ForwardQuote(ForwardQuoteSetup) Method


ForwardQuoteSetup Class Members | fcSDK Documentation

ForwardQuoteSetup Class Members

The following tables list the members exposed by ForwardQuoteSetup.

Public Constructors

 | Name | Description
Public Constructor | ForwardQuoteSetup Constructor | Initializes a new instance of the ForwardQuoteSetup class.

Public Properties

 | Name | Description
Public Property | ForwardDate | DateTime the Quote was forwarded. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewQueue | The new queue into which the Quote is to be forwarded.
Public Property | Notes | The reason the Quote was rejected from the queue into which it was dispatched.
Public Property | QuoteIDNum | Quote Identifier.
Public Property | UserName | The user who has forwarded the Quote. If not set, the Toolkit session user is used.

Reference

ForwardQuoteSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
ForwardQuote(ForwardQuoteSetup) Method


ForwardQuoteSetup Constructor | fcSDK Documentation

ForwardQuoteSetup Constructor

Quote Identifier.

The new queue into which the Quote is to be forwarded.

Initializes a new instance of the ForwardQuoteSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _quoteIDNum_ As String, _
   ByVal _newQueue_ As String _
)

[ConstructorIndexAttribute()]
public ForwardQuoteSetup(
   string _quoteIDNum_,
   string _newQueue_
)

Parameters

quoteIDNum

Quote Identifier.

newQueue

The new queue into which the Quote is to be forwarded.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardQuoteSetup Class
ForwardQuoteSetup Members


ForwardDate Property (ForwardQuoteSetup) | fcSDK Documentation

ForwardDate Property (ForwardQuoteSetup)

DateTime the Quote was forwarded. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ForwardDate As Date

[PropertyBitValueAttribute()]
public DateTime ForwardDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardQuoteSetup Class
ForwardQuoteSetup Members


GenerateTimeBombs Property (ForwardQuoteSetup) | fcSDK Documentation

GenerateTimeBombs Property (ForwardQuoteSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardQuoteSetup Class
ForwardQuoteSetup Members


NewQueue Property (ForwardQuoteSetup) | fcSDK Documentation

NewQueue Property (ForwardQuoteSetup)

The new queue into which the Quote is to be forwarded.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewQueue As String

[PropertyBitValueAttribute()]
public string NewQueue {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardQuoteSetup Class
ForwardQuoteSetup Members


Notes Property (ForwardQuoteSetup) | fcSDK Documentation

Notes Property (ForwardQuoteSetup)

The reason the Quote was rejected from the queue into which it was dispatched.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardQuoteSetup Class
ForwardQuoteSetup Members


QuoteIDNum Property (ForwardQuoteSetup) | fcSDK Documentation

QuoteIDNum Property (ForwardQuoteSetup)

Quote Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property QuoteIDNum As String

[PropertyBitValueAttribute()]
public string QuoteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardQuoteSetup Class
ForwardQuoteSetup Members


UserName Property (ForwardQuoteSetup) | fcSDK Documentation

UserName Property (ForwardQuoteSetup)

The user who has forwarded the Quote. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardQuoteSetup Class
ForwardQuoteSetup Members


LogContractNoteSetup Class | fcSDK Documentation

LogContractNoteSetup Class

Used by the LogContractNote method as setup data for invocation.

Syntax

'Declaration

Public Class LogContractNoteSetup

public class LogContractNoteSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Contracts.LogContractNoteSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Contracts

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LogContractNoteSetup Members
FChoice.Toolkits.Clarify.Contracts Namespace
LogContractNote(LogContractNoteSetup) Method


LogContractNoteSetup Class Members | fcSDK Documentation

LogContractNoteSetup Class Members

The following tables list the members exposed by LogContractNoteSetup.

Public Constructors

 | Name | Description
Public Constructor | LogContractNoteSetup Constructor | Initializes a new instance of the LogContractNoteSetup class.

Public Properties

 | Name | Description
Public Property | ActionType | Element from the 'Note Log Action Type' application list. If not set, the default list value is used.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | ContractIDNum | Contract Identifier.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | InternalUseOnlyNotes | Notes designated for Internal Use Only.
Public Property | LogDate | The DateTime the Contract Note was logged. If not set, the current time is used.
Public Property | Notes | The notes being logged to the Contract.
Public Property | UserName | The user who is logging the Contract Note. If not set, the Toolkit session user is used.

Reference

LogContractNoteSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
LogContractNote(LogContractNoteSetup) Method


LogContractNoteSetup Constructor | fcSDK Documentation

LogContractNoteSetup Constructor

Contract Identifier.

The notes being logged to the Contract.

Initializes a new instance of the LogContractNoteSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _contractIDNum_ As String, _
   ByVal _notes_ As String _
)

[ConstructorIndexAttribute()]
public LogContractNoteSetup(
   string _contractIDNum_,
   string _notes_
)

Parameters

contractIDNum

Contract Identifier.

notes

The notes being logged to the Contract.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogContractNoteSetup Class
LogContractNoteSetup Members


ActionType Property (LogContractNoteSetup) | fcSDK Documentation

ActionType Property (LogContractNoteSetup)

Element from the 'Note Log Action Type' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ActionType As String

[PropertyBitValueAttribute()]
public string ActionType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogContractNoteSetup Class
LogContractNoteSetup Members


AdditionalFields Property (LogContractNoteSetup) | fcSDK Documentation

AdditionalFields Property (LogContractNoteSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogContractNoteSetup Class
LogContractNoteSetup Members


ContractIDNum Property (LogContractNoteSetup) | fcSDK Documentation

ContractIDNum Property (LogContractNoteSetup)

Contract Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContractIDNum As String

[PropertyBitValueAttribute()]
public string ContractIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogContractNoteSetup Class
LogContractNoteSetup Members


GenerateTimeBombs Property (LogContractNoteSetup) | fcSDK Documentation

GenerateTimeBombs Property (LogContractNoteSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogContractNoteSetup Class
LogContractNoteSetup Members


InternalUseOnlyNotes Property (LogContractNoteSetup) | fcSDK Documentation

InternalUseOnlyNotes Property (LogContractNoteSetup)

Notes designated for Internal Use Only.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InternalUseOnlyNotes As String

[PropertyBitValueAttribute()]
public string InternalUseOnlyNotes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogContractNoteSetup Class
LogContractNoteSetup Members


LogDate Property (LogContractNoteSetup) | fcSDK Documentation

LogDate Property (LogContractNoteSetup)

The DateTime the Contract Note was logged. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LogDate As Date

[PropertyBitValueAttribute()]
public DateTime LogDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogContractNoteSetup Class
LogContractNoteSetup Members


Notes Property (LogContractNoteSetup) | fcSDK Documentation

Notes Property (LogContractNoteSetup)

The notes being logged to the Contract.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogContractNoteSetup Class
LogContractNoteSetup Members


UserName Property (LogContractNoteSetup) | fcSDK Documentation

UserName Property (LogContractNoteSetup)

The user who is logging the Contract Note. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogContractNoteSetup Class
LogContractNoteSetup Members


MoveQuoteSetup Class | fcSDK Documentation

MoveQuoteSetup Class

Used by the MoveQuote method as setup data for invocation.

Syntax

'Declaration

Public Class MoveQuoteSetup

public class MoveQuoteSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Contracts.MoveQuoteSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Contracts

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

MoveQuoteSetup Members
FChoice.Toolkits.Clarify.Contracts Namespace
MoveQuote(MoveQuoteSetup) Method


MoveQuoteSetup Class Members | fcSDK Documentation

MoveQuoteSetup Class Members

The following tables list the members exposed by MoveQuoteSetup.

Public Constructors

 | Name | Description
Public Constructor | MoveQuoteSetup Constructor | Initializes a new instance of the MoveQuoteSetup class.

Public Properties

 | Name | Description
Public Property | NewWipBin | The new WipBin into which the Quote is to be moved.
Public Property | QuoteIDNum | Quote Identifier.

Reference

MoveQuoteSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
MoveQuote(MoveQuoteSetup) Method


MoveQuoteSetup Constructor | fcSDK Documentation

MoveQuoteSetup Constructor

Quote Identifier.

The new WipBin into which the Quote is to be moved.

Initializes a new instance of the MoveQuoteSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _quoteIDNum_ As String, _
   ByVal _newWipBin_ As String _
)

[ConstructorIndexAttribute()]
public MoveQuoteSetup(
   string _quoteIDNum_,
   string _newWipBin_
)

Parameters

quoteIDNum

Quote Identifier.

newWipBin

The new WipBin into which the Quote is to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveQuoteSetup Class
MoveQuoteSetup Members


NewWipBin Property (MoveQuoteSetup) | fcSDK Documentation

NewWipBin Property (MoveQuoteSetup)

The new WipBin into which the Quote is to be moved.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewWipBin As String

[PropertyBitValueAttribute()]
public string NewWipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveQuoteSetup Class
MoveQuoteSetup Members


QuoteIDNum Property (MoveQuoteSetup) | fcSDK Documentation

QuoteIDNum Property (MoveQuoteSetup)

Quote Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property QuoteIDNum As String

[PropertyBitValueAttribute()]
public string QuoteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveQuoteSetup Class
MoveQuoteSetup Members


RejectContractSetup Class | fcSDK Documentation

RejectContractSetup Class

Used by the RejectContract method as setup data for invocation.

Syntax

'Declaration

Public Class RejectContractSetup

public class RejectContractSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Contracts.RejectContractSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Contracts

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

RejectContractSetup Members
FChoice.Toolkits.Clarify.Contracts Namespace
RejectContract(RejectContractSetup) Method


RejectContractSetup Class Members | fcSDK Documentation

RejectContractSetup Class Members

The following tables list the members exposed by RejectContractSetup.

Public Constructors

 | Name | Description
Public Constructor | RejectContractSetup Constructor | Initializes a new instance of the RejectContractSetup class.

Public Properties

 | Name | Description
Public Property | ContractIDNum | Contract Identifier.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Notes | The reason the Contract was rejected from the queue into which it was dispatched.
Public Property | RejectDate | DateTime the Contract was rejected. If not set, the current time is used.
Public Property | Status | Element from the 'Contract Status' application list. If not set, the default list value is used.
Public Property | UserName | The user who has rejected the Contract. If not set, the Toolkit session user is used.

Reference

RejectContractSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
RejectContract(RejectContractSetup) Method


RejectContractSetup Constructor | fcSDK Documentation

RejectContractSetup Constructor

Contract Identifier.

Initializes a new instance of the RejectContractSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _contractIDNum_ As String _
)

[ConstructorIndexAttribute()]
public RejectContractSetup(
   string _contractIDNum_
)

Parameters

contractIDNum

Contract Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectContractSetup Class
RejectContractSetup Members


ContractIDNum Property (RejectContractSetup) | fcSDK Documentation

ContractIDNum Property (RejectContractSetup)

Contract Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContractIDNum As String

[PropertyBitValueAttribute()]
public string ContractIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectContractSetup Class
RejectContractSetup Members


GenerateTimeBombs Property (RejectContractSetup) | fcSDK Documentation

GenerateTimeBombs Property (RejectContractSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectContractSetup Class
RejectContractSetup Members


Notes Property (RejectContractSetup) | fcSDK Documentation

Notes Property (RejectContractSetup)

The reason the Contract was rejected from the queue into which it was dispatched.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectContractSetup Class
RejectContractSetup Members


RejectDate Property (RejectContractSetup) | fcSDK Documentation

RejectDate Property (RejectContractSetup)

DateTime the Contract was rejected. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property RejectDate As Date

[PropertyBitValueAttribute()]
public DateTime RejectDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectContractSetup Class
RejectContractSetup Members


Status Property (RejectContractSetup) | fcSDK Documentation

Status Property (RejectContractSetup)

Element from the 'Contract Status' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Status As String

[PropertyBitValueAttribute()]
public string Status {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectContractSetup Class
RejectContractSetup Members


UserName Property (RejectContractSetup) | fcSDK Documentation

UserName Property (RejectContractSetup)

The user who has rejected the Contract. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectContractSetup Class
RejectContractSetup Members


RejectQuoteSetup Class | fcSDK Documentation

RejectQuoteSetup Class

Used by the RejectQuote method as setup data for invocation.

Syntax

'Declaration

Public Class RejectQuoteSetup

public class RejectQuoteSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Contracts.RejectQuoteSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Contracts

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

RejectQuoteSetup Members
FChoice.Toolkits.Clarify.Contracts Namespace
RejectQuote(RejectQuoteSetup) Method


RejectQuoteSetup Class Members | fcSDK Documentation

RejectQuoteSetup Class Members

The following tables list the members exposed by RejectQuoteSetup.

Public Constructors

 | Name | Description
Public Constructor | RejectQuoteSetup Constructor | Initializes a new instance of the RejectQuoteSetup class.

Public Properties

 | Name | Description
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Notes | The reason the Quote was rejected from the queue into which it was dispatched.
Public Property | QuoteIDNum | Quote Identifier.
Public Property | RejectDate | DateTime the Quote was rejected. If not set, the current time is used.
Public Property | UserName | The user who has rejected the Quote. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Quote. If not set, the UserName's default is used.

Reference

RejectQuoteSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
RejectQuote(RejectQuoteSetup) Method


RejectQuoteSetup Constructor | fcSDK Documentation

RejectQuoteSetup Constructor

Quote Identifier.

Initializes a new instance of the RejectQuoteSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _quoteIDNum_ As String _
)

[ConstructorIndexAttribute()]
public RejectQuoteSetup(
   string _quoteIDNum_
)

Parameters

quoteIDNum

Quote Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectQuoteSetup Class
RejectQuoteSetup Members


GenerateTimeBombs Property (RejectQuoteSetup) | fcSDK Documentation

GenerateTimeBombs Property (RejectQuoteSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectQuoteSetup Class
RejectQuoteSetup Members


Notes Property (RejectQuoteSetup) | fcSDK Documentation

Notes Property (RejectQuoteSetup)

The reason the Quote was rejected from the queue into which it was dispatched.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectQuoteSetup Class
RejectQuoteSetup Members


QuoteIDNum Property (RejectQuoteSetup) | fcSDK Documentation

QuoteIDNum Property (RejectQuoteSetup)

Quote Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property QuoteIDNum As String

[PropertyBitValueAttribute()]
public string QuoteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectQuoteSetup Class
RejectQuoteSetup Members


RejectDate Property (RejectQuoteSetup) | fcSDK Documentation

RejectDate Property (RejectQuoteSetup)

DateTime the Quote was rejected. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property RejectDate As Date

[PropertyBitValueAttribute()]
public DateTime RejectDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectQuoteSetup Class
RejectQuoteSetup Members


UserName Property (RejectQuoteSetup) | fcSDK Documentation

UserName Property (RejectQuoteSetup)

The user who has rejected the Quote. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectQuoteSetup Class
RejectQuoteSetup Members


WipBin Property (RejectQuoteSetup) | fcSDK Documentation

WipBin Property (RejectQuoteSetup)

User's WipBin in which to place the Quote. If not set, the UserName's default is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectQuoteSetup Class
RejectQuoteSetup Members


RelateContractItemToSitePartSetup Class | fcSDK Documentation

RelateContractItemToSitePartSetup Class

Used by the RelateContractItemToSitePart method as setup data for invocation.

Syntax

'Declaration

Public Class RelateContractItemToSitePartSetup

public class RelateContractItemToSitePartSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Contracts.RelateContractItemToSitePartSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Contracts

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

RelateContractItemToSitePartSetup Members
FChoice.Toolkits.Clarify.Contracts Namespace
RelateContractItemToSitePart(RelateContractItemToSitePartSetup) Method


RelateContractItemToSitePartSetup Class Members | fcSDK Documentation

RelateContractItemToSitePartSetup Class Members

The following tables list the members exposed by RelateContractItemToSitePartSetup.

Public Constructors

 | Name | Description
Public Constructor | RelateContractItemToSitePartSetup Constructor | Initializes a new instance of the RelateContractItemToSitePartSetup class.

Public Properties

 | Name | Description
Public Property | ContractObjid | The objid of the Contract for this Line Item.
Public Property | PartDomain | The domain of the part for the Line Item.
Public Property | PartNumber | The number of the part for the Line Item.
Public Property | PartRevision | The revision of the part for the Line Item.
Public Property | SerialNumber | The serial number of the site part for thie Line Item.

Reference

RelateContractItemToSitePartSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
RelateContractItemToSitePart(RelateContractItemToSitePartSetup) Method


RelateContractItemToSitePartSetup Constructor | fcSDK Documentation

RelateContractItemToSitePartSetup Constructor

The objid of the Contract for this Line Item.

The number of the part for the Line Item.

The domain of the part for the Line Item.

The revision of the part for the Line Item.

The serial number of the site part for thie Line Item.

Initializes a new instance of the RelateContractItemToSitePartSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _contractObjid_ As Integer, _
   ByVal _partNumber_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _serialNumber_ As String _
)

[ConstructorIndexAttribute()]
public RelateContractItemToSitePartSetup(
   int _contractObjid_,
   string _partNumber_,
   string _partDomain_,
   string _partRevision_,
   string _serialNumber_
)

Parameters

contractObjid

The objid of the Contract for this Line Item.

partNumber

The number of the part for the Line Item.

partDomain

The domain of the part for the Line Item.

partRevision

The revision of the part for the Line Item.

serialNumber

The serial number of the site part for thie Line Item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RelateContractItemToSitePartSetup Class
RelateContractItemToSitePartSetup Members


ContractObjid Property (RelateContractItemToSitePartSetup) | fcSDK Documentation

ContractObjid Property (RelateContractItemToSitePartSetup)

The objid of the Contract for this Line Item.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContractObjid As Integer

[PropertyBitValueAttribute()]
public int ContractObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RelateContractItemToSitePartSetup Class
RelateContractItemToSitePartSetup Members


PartDomain Property (RelateContractItemToSitePartSetup) | fcSDK Documentation

PartDomain Property (RelateContractItemToSitePartSetup)

The domain of the part for the Line Item.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartDomain As String

[PropertyBitValueAttribute()]
public string PartDomain {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RelateContractItemToSitePartSetup Class
RelateContractItemToSitePartSetup Members


PartNumber Property (RelateContractItemToSitePartSetup) | fcSDK Documentation

PartNumber Property (RelateContractItemToSitePartSetup)

The number of the part for the Line Item.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartNumber As String

[PropertyBitValueAttribute()]
public string PartNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RelateContractItemToSitePartSetup Class
RelateContractItemToSitePartSetup Members


PartRevision Property (RelateContractItemToSitePartSetup) | fcSDK Documentation

PartRevision Property (RelateContractItemToSitePartSetup)

The revision of the part for the Line Item.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRevision As String

[PropertyBitValueAttribute()]
public string PartRevision {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RelateContractItemToSitePartSetup Class
RelateContractItemToSitePartSetup Members


SerialNumber Property (RelateContractItemToSitePartSetup) | fcSDK Documentation

SerialNumber Property (RelateContractItemToSitePartSetup)

The serial number of the site part for thie Line Item.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SerialNumber As String

[PropertyBitValueAttribute()]
public string SerialNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RelateContractItemToSitePartSetup Class
RelateContractItemToSitePartSetup Members


ReopenContractSetup Class | fcSDK Documentation

ReopenContractSetup Class

Used by the ReopenContract method as setup data for invocation.

Syntax

'Declaration

Public Class ReopenContractSetup

public class ReopenContractSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Contracts.ReopenContractSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Contracts

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ReopenContractSetup Members
FChoice.Toolkits.Clarify.Contracts Namespace
ReopenContract(ReopenContractSetup) Method


ReopenContractSetup Class Members | fcSDK Documentation

ReopenContractSetup Class Members

The following tables list the members exposed by ReopenContractSetup.

Public Constructors

 | Name | Description
Public Constructor | ReopenContractSetup Constructor | Initializes a new instance of the ReopenContractSetup class.

Public Properties

 | Name | Description
Public Property | ContractIDNum | Contract Identifier.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | ReopenDate | The DateTime the Contract was reopened. If not set, the current time is used.
Public Property | Status | Element from the 'Quote Status' application list. If not set, the default status for the Active Contract condition is used.
Public Property | UserName | The user who is reopening the Contract. If not set, the Toolkit session user is used.
Public Property | WipBin | The WipBin to place the Contract in. If not set, the contract is placed in the user’s default WipBin.

Reference

ReopenContractSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
ReopenContract(ReopenContractSetup) Method


ReopenContractSetup Constructor | fcSDK Documentation

ReopenContractSetup Constructor

Contract Identifier.

Element from the 'Quote Status' application list. If not set, the default status for the Active Contract condition is used.

Initializes a new instance of the ReopenContractSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _contractIDNum_ As String, _
   ByVal _status_ As String _
)

[ConstructorIndexAttribute()]
public ReopenContractSetup(
   string _contractIDNum_,
   string _status_
)

Parameters

contractIDNum

Contract Identifier.

status

Element from the 'Quote Status' application list. If not set, the default status for the Active Contract condition is used.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenContractSetup Class
ReopenContractSetup Members


ContractIDNum Property (ReopenContractSetup) | fcSDK Documentation

ContractIDNum Property (ReopenContractSetup)

Contract Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContractIDNum As String

[PropertyBitValueAttribute()]
public string ContractIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenContractSetup Class
ReopenContractSetup Members


GenerateTimeBombs Property (ReopenContractSetup) | fcSDK Documentation

GenerateTimeBombs Property (ReopenContractSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenContractSetup Class
ReopenContractSetup Members


ReopenDate Property (ReopenContractSetup) | fcSDK Documentation

ReopenDate Property (ReopenContractSetup)

The DateTime the Contract was reopened. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ReopenDate As Date

[PropertyBitValueAttribute()]
public DateTime ReopenDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenContractSetup Class
ReopenContractSetup Members


Status Property (ReopenContractSetup) | fcSDK Documentation

Status Property (ReopenContractSetup)

Element from the 'Quote Status' application list. If not set, the default status for the Active Contract condition is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Status As String

[PropertyBitValueAttribute()]
public string Status {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenContractSetup Class
ReopenContractSetup Members


UserName Property (ReopenContractSetup) | fcSDK Documentation

UserName Property (ReopenContractSetup)

The user who is reopening the Contract. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenContractSetup Class
ReopenContractSetup Members


WipBin Property (ReopenContractSetup) | fcSDK Documentation

WipBin Property (ReopenContractSetup)

The WipBin to place the Contract in. If not set, the contract is placed in the user’s default WipBin.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Remarks

If left blank, the default WIPBin for the user is used.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenContractSetup Class
ReopenContractSetup Members


UnrelateContractItemFromSitePartSetup Class | fcSDK Documentation

UnrelateContractItemFromSitePartSetup Class

Used by the UnrelateContractItemFromSitePart method as setup data for invocation.

Syntax

'Declaration

Public Class UnrelateContractItemFromSitePartSetup

public class UnrelateContractItemFromSitePartSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Contracts.UnrelateContractItemFromSitePartSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Contracts

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UnrelateContractItemFromSitePartSetup Members
FChoice.Toolkits.Clarify.Contracts Namespace
UnrelateContractItemFromSitePart(UnrelateContractItemFromSitePartSetup) Method


UnrelateContractItemFromSitePartSetup Class Members | fcSDK Documentation

UnrelateContractItemFromSitePartSetup Class Members

The following tables list the members exposed by UnrelateContractItemFromSitePartSetup.

Public Constructors

 | Name | Description
Public Constructor | UnrelateContractItemFromSitePartSetup Constructor | Initializes a new instance of the UnrelateContractItemFromSitePartSetup class.

Public Properties

 | Name | Description
Public Property | ContractObjid | The objid of the Contract for this Line Item.
Public Property | PartDomain | The domain of the part for the Line Item.
Public Property | PartNumber | The part number for the Line Item.
Public Property | PartRevision | The revision of the part for the Line Item.

Reference

UnrelateContractItemFromSitePartSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
UnrelateContractItemFromSitePart(UnrelateContractItemFromSitePartSetup) Method


UnrelateContractItemFromSitePartSetup Constructor | fcSDK Documentation

UnrelateContractItemFromSitePartSetup Constructor

The objid of the Contract for this Line Item.

The part number for the Line Item.

The domain of the part for the Line Item.

The revision of the part for the Line Item.

Initializes a new instance of the UnrelateContractItemFromSitePartSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _contractObjid_ As Integer, _
   ByVal _partNumber_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _partRevision_ As String _
)

[ConstructorIndexAttribute()]
public UnrelateContractItemFromSitePartSetup(
   int _contractObjid_,
   string _partNumber_,
   string _partDomain_,
   string _partRevision_
)

Parameters

contractObjid

The objid of the Contract for this Line Item.

partNumber

The part number for the Line Item.

partDomain

The domain of the part for the Line Item.

partRevision

The revision of the part for the Line Item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UnrelateContractItemFromSitePartSetup Class
UnrelateContractItemFromSitePartSetup Members


ContractObjid Property (UnrelateContractItemFromSitePartSetup) | fcSDK Documentation

ContractObjid Property (UnrelateContractItemFromSitePartSetup)

The objid of the Contract for this Line Item.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContractObjid As Integer

[PropertyBitValueAttribute()]
public int ContractObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UnrelateContractItemFromSitePartSetup Class
UnrelateContractItemFromSitePartSetup Members


PartDomain Property (UnrelateContractItemFromSitePartSetup) | fcSDK Documentation

PartDomain Property (UnrelateContractItemFromSitePartSetup)

The domain of the part for the Line Item.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartDomain As String

[PropertyBitValueAttribute()]
public string PartDomain {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UnrelateContractItemFromSitePartSetup Class
UnrelateContractItemFromSitePartSetup Members


PartNumber Property (UnrelateContractItemFromSitePartSetup) | fcSDK Documentation

PartNumber Property (UnrelateContractItemFromSitePartSetup)

The part number for the Line Item.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartNumber As String

[PropertyBitValueAttribute()]
public string PartNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UnrelateContractItemFromSitePartSetup Class
UnrelateContractItemFromSitePartSetup Members


PartRevision Property (UnrelateContractItemFromSitePartSetup) | fcSDK Documentation

PartRevision Property (UnrelateContractItemFromSitePartSetup)

The revision of the part for the Line Item.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRevision As String

[PropertyBitValueAttribute()]
public string PartRevision {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UnrelateContractItemFromSitePartSetup Class
UnrelateContractItemFromSitePartSetup Members


UpdateScheduleSetup Class | fcSDK Documentation

UpdateScheduleSetup Class

Used by the UpdateSchedule method as setup data for invocation.

Syntax

'Declaration

Public Class UpdateScheduleSetup

public class UpdateScheduleSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Contracts.UpdateScheduleSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Contracts

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdateScheduleSetup Members
FChoice.Toolkits.Clarify.Contracts Namespace
UpdateSchedule(UpdateScheduleSetup) Method


UpdateScheduleSetup Class Members | fcSDK Documentation

UpdateScheduleSetup Class Members

The following tables list the members exposed by UpdateScheduleSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdateScheduleSetup Constructor | Initializes a new instance of the UpdateScheduleSetup class.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | BillingATTN | Specifies the to who's attention the billing is direct.
Public Property | BillingFrequency | Specifies how often will this Schedule induce billing.
Public Property | BillingOption | For any Billing Frequency except "OneTime," select whether the customer is billed in advance or after the fact.
Public Property | BillingPeriodStartDate | The billing period starting DateTime for the Schedule. If not set no change is made.
Public Property | BillSiteIDNum | Site Identifier for the billing of this Schedule.
Public Property | ChargeEndDate | The charging end DateTime for the Schedule. If not set, no change is made.
Public Property | ChargeStartDate | The charging start DateTime for the Schedule. If not set, no change is made.
Public Property | ContractIDNum | Contract Identifier.
Public Property | FirstBillingDate | The first billing DateTime for the Schedule. If not set, no change is made.
Public Property | PriceProgram | The title of the Price Program for this Schedule. If not set, then the value is not changed.
Public Property | ScheduleIDNum | Schedule Identifier.
Public Property | ShipToSiteIDNum | Site Identifier for the shipment of this Schedule.

Reference

UpdateScheduleSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
UpdateSchedule(UpdateScheduleSetup) Method


UpdateScheduleSetup Constructor | fcSDK Documentation

UpdateScheduleSetup Constructor

Contract Identifier.

Schedule Identifier.

Initializes a new instance of the UpdateScheduleSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _contractIDNum_ As String, _
   ByVal _scheduleIDNum_ As String _
)

[ConstructorIndexAttribute()]
public UpdateScheduleSetup(
   string _contractIDNum_,
   string _scheduleIDNum_
)

Parameters

contractIDNum

Contract Identifier.

scheduleIDNum

Schedule Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateScheduleSetup Class
UpdateScheduleSetup Members


AdditionalFields Property (UpdateScheduleSetup) | fcSDK Documentation

AdditionalFields Property (UpdateScheduleSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateScheduleSetup Class
UpdateScheduleSetup Members


BillingATTN Property (UpdateScheduleSetup) | fcSDK Documentation

BillingATTN Property (UpdateScheduleSetup)

Specifies the to who's attention the billing is direct.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property BillingATTN As String

[PropertyBitValueAttribute()]
public string BillingATTN {get; set;}

Remarks

If this property has not been set no change will occur. If the property is set, even to an empty string, that value reflected in the update.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateScheduleSetup Class
UpdateScheduleSetup Members


BillingFrequency Property (UpdateScheduleSetup) | fcSDK Documentation

BillingFrequency Property (UpdateScheduleSetup)

Specifies how often will this Schedule induce billing.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property BillingFrequency As BillingFrequency

[PropertyBitValueAttribute()]
public BillingFrequency BillingFrequency {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateScheduleSetup Class
UpdateScheduleSetup Members


BillingOption Property (UpdateScheduleSetup) | fcSDK Documentation

BillingOption Property (UpdateScheduleSetup)

For any Billing Frequency except "OneTime," select whether the customer is billed in advance or after the fact.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property BillingOption As BillingOption

[PropertyBitValueAttribute()]
public BillingOption BillingOption {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateScheduleSetup Class
UpdateScheduleSetup Members


BillingPeriodStartDate Property (UpdateScheduleSetup) | fcSDK Documentation

BillingPeriodStartDate Property (UpdateScheduleSetup)

The billing period starting DateTime for the Schedule. If not set no change is made.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property BillingPeriodStartDate As Date

[PropertyBitValueAttribute()]
public DateTime BillingPeriodStartDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateScheduleSetup Class
UpdateScheduleSetup Members


BillSiteIDNum Property (UpdateScheduleSetup) | fcSDK Documentation

BillSiteIDNum Property (UpdateScheduleSetup)

Site Identifier for the billing of this Schedule.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property BillSiteIDNum As String

[PropertyBitValueAttribute()]
public string BillSiteIDNum {get; set;}

Remarks

If this is set to the empty string (“”) or “IGNORE”, no change is made in the site.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateScheduleSetup Class
UpdateScheduleSetup Members


ChargeEndDate Property (UpdateScheduleSetup) | fcSDK Documentation

ChargeEndDate Property (UpdateScheduleSetup)

The charging end DateTime for the Schedule. If not set, no change is made.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ChargeEndDate As Date

[PropertyBitValueAttribute()]
public DateTime ChargeEndDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateScheduleSetup Class
UpdateScheduleSetup Members


ChargeStartDate Property (UpdateScheduleSetup) | fcSDK Documentation

ChargeStartDate Property (UpdateScheduleSetup)

The charging start DateTime for the Schedule. If not set, no change is made.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ChargeStartDate As Date

[PropertyBitValueAttribute()]
public DateTime ChargeStartDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateScheduleSetup Class
UpdateScheduleSetup Members


ContractIDNum Property (UpdateScheduleSetup) | fcSDK Documentation

ContractIDNum Property (UpdateScheduleSetup)

Contract Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContractIDNum As String

[PropertyBitValueAttribute()]
public string ContractIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateScheduleSetup Class
UpdateScheduleSetup Members


FirstBillingDate Property (UpdateScheduleSetup) | fcSDK Documentation

FirstBillingDate Property (UpdateScheduleSetup)

The first billing DateTime for the Schedule. If not set, no change is made.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FirstBillingDate As Date

[PropertyBitValueAttribute()]
public DateTime FirstBillingDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateScheduleSetup Class
UpdateScheduleSetup Members


PriceProgram Property (UpdateScheduleSetup) | fcSDK Documentation

PriceProgram Property (UpdateScheduleSetup)

The title of the Price Program for this Schedule. If not set, then the value is not changed.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PriceProgram As String

[PropertyBitValueAttribute()]
public string PriceProgram {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateScheduleSetup Class
UpdateScheduleSetup Members


ScheduleIDNum Property (UpdateScheduleSetup) | fcSDK Documentation

ScheduleIDNum Property (UpdateScheduleSetup)

Schedule Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ScheduleIDNum As String

[PropertyBitValueAttribute()]
public string ScheduleIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateScheduleSetup Class
UpdateScheduleSetup Members


ShipToSiteIDNum Property (UpdateScheduleSetup) | fcSDK Documentation

ShipToSiteIDNum Property (UpdateScheduleSetup)

Site Identifier for the shipment of this Schedule.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ShipToSiteIDNum As String

[PropertyBitValueAttribute()]
public string ShipToSiteIDNum {get; set;}

Remarks

If this is set to the empty string (“”) or “IGNORE”, no change is made in the site.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateScheduleSetup Class
UpdateScheduleSetup Members


YankQuoteSetup Class | fcSDK Documentation

YankQuoteSetup Class

Used by the YankQuote method as setup data for invocation.

Syntax

'Declaration

Public Class YankQuoteSetup

public class YankQuoteSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Contracts.YankQuoteSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Contracts

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

YankQuoteSetup Members
FChoice.Toolkits.Clarify.Contracts Namespace
YankQuote(YankQuoteSetup) Method


YankQuoteSetup Class Members | fcSDK Documentation

YankQuoteSetup Class Members

The following tables list the members exposed by YankQuoteSetup.

Public Constructors

 | Name | Description
Public Constructor | YankQuoteSetup Constructor | Initializes a new instance of the YankQuoteSetup class.

Public Properties

 | Name | Description
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | QuoteIDNum | Quote Identifier.
Public Property | UserName | The user who has yanked the Quote. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Quote. If not set, the UserName's default is used.
Public Property | YankDate | DateTime the Quote was yanked. If not set, the current time is used.

Reference

YankQuoteSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
YankQuote(YankQuoteSetup) Method


YankQuoteSetup Constructor | fcSDK Documentation

YankQuoteSetup Constructor

Quote Identifier.

Initializes a new instance of the YankQuoteSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _quoteIDNum_ As String _
)

[ConstructorIndexAttribute()]
public YankQuoteSetup(
   string _quoteIDNum_
)

Parameters

quoteIDNum

Quote Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankQuoteSetup Class
YankQuoteSetup Members


GenerateTimeBombs Property (YankQuoteSetup) | fcSDK Documentation

GenerateTimeBombs Property (YankQuoteSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankQuoteSetup Class
YankQuoteSetup Members


QuoteIDNum Property (YankQuoteSetup) | fcSDK Documentation

QuoteIDNum Property (YankQuoteSetup)

Quote Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property QuoteIDNum As String

[PropertyBitValueAttribute()]
public string QuoteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankQuoteSetup Class
YankQuoteSetup Members


UserName Property (YankQuoteSetup) | fcSDK Documentation

UserName Property (YankQuoteSetup)

The user who has yanked the Quote. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankQuoteSetup Class
YankQuoteSetup Members


WipBin Property (YankQuoteSetup) | fcSDK Documentation

WipBin Property (YankQuoteSetup)

User's WipBin in which to place the Quote. If not set, the UserName's default is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankQuoteSetup Class
YankQuoteSetup Members


YankDate Property (YankQuoteSetup) | fcSDK Documentation

YankDate Property (YankQuoteSetup)

DateTime the Quote was yanked. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property YankDate As Date

[PropertyBitValueAttribute()]
public DateTime YankDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankQuoteSetup Class
YankQuoteSetup Members


FChoice.Toolkits.Clarify.DepotRepair Namespace | fcSDK Documentation

FChoice.Toolkits.Clarify.DepotRepair Namespace

Provides APIs to allow you to modify Logistics Depot Repair objects such as Engineering Change Orders (ECOs), labor, and material costs. Methods on the DepotRepairToolkit object allow you to create, modify, and delete ECO headers and details, apply ECOs, create and modify labor records, and create/modify material records, and more.

Classes

 | Class | Description
Class | ApplyEcoSetup | Used by the ApplyEco method as setup data for invocation.
Class | CreateDepotRepairLaborSetup | Used by the CreateDepotRepairLabor method as setup data for invocation.
Class | CreateDepotRepairMaterialSetup | Used by the CreateDepotRepairMaterial method as setup data for invocation.
Class | CreateEcoHeaderSetup | Used by the CreateEcoHeader method as setup data for invocation.
Class | CreateEcoItemSetup | Used by the CreateEcoItem method as setup data for invocation.
Class | CreateEcoLaborDetailSetup | Used by the CreateEcoLaborDetail method as setup data for invocation.
Class | CreateEcoMaterialDetailSetup | Used by the CreateEcoMaterialDetail method as setup data for invocation.
Class | DeleteDepotRepairLaborSetup | Used by the DeleteDepotRepairLabor method as setup data for invocation.
Class | DeleteDepotRepairMaterialSetup | Used by the DeleteDepotRepairMaterial method as setup data for invocation.
Class | DeleteEcoDetailSetup | Used by the DeleteEcoDetail method as setup data for invocation.
Class | DeleteEcoItemSetup | Used by the DeleteEcoItem method as setup data for invocation.
Class | DepotRepairToolkit | Provides APIs to modify Logistics Depot Repair objects such as Engineering Change Orders (ECOs), labor, and material costs. For example, some of these APIs allow you to create, modify, and delete ECO headers and details, apply ECOs, create and modify labor records, and create/modify material records, and more.
Class | DepotRepairToolkitBase | Please see DepotRepairToolkit. This class is used internally and not meant to be created by end users.
Class | UpdateDepotRepairLaborSetup | Used by the UpdateDepotRepairLabor method as setup data for invocation.
Class | UpdateDepotRepairMaterialSetup | Used by the UpdateDepotRepairMaterial method as setup data for invocation.
Class | UpdateEcoItemSetup | Used by the UpdateEcoItem method as setup data for invocation.
Class | UpdateEcoLaborDetailSetup | Used by the UpdateEcoLaborDetail method as setup data for invocation.
Class | UpdateEcoMaterialDetailSetup | Used by the UpdateEcoMaterialDetail method as setup data for invocation.

Reference

FChoice.Toolkits.Clarify Assembly


ApplyEcoSetup Class | fcSDK Documentation

ApplyEcoSetup Class

Used by the ApplyEco method as setup data for invocation.

Syntax

'Declaration

Public Class ApplyEcoSetup

public class ApplyEcoSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.DepotRepair.ApplyEcoSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.DepotRepair

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ApplyEcoSetup Members
FChoice.Toolkits.Clarify.DepotRepair Namespace
ApplyEco(ApplyEcoSetup) Method


ApplyEcoSetup Class Members | fcSDK Documentation

ApplyEcoSetup Class Members

The following tables list the members exposed by ApplyEcoSetup.

Public Constructors

 | Name | Description
Public Constructor | ApplyEcoSetup Constructor | Initializes a new instance of the ApplyEcoSetup class.

Public Properties

 | Name | Description
Public Property | CreateDate | The DateTime the ECO is applied. If not set, the current time is used.
Public Property | DemandDetailObjid | Objid of the related Part Request Detail
Public Property | EcoHeaderIDNum | Identifier of the ECO header
Public Property | UserName | The user applying the ECO. If not set, the Toolkit session user is used.

Reference

ApplyEcoSetup Class
FChoice.Toolkits.Clarify.DepotRepair Namespace
ApplyEco(ApplyEcoSetup) Method


ApplyEcoSetup Constructor | fcSDK Documentation

ApplyEcoSetup Constructor

Objid of the related Part Request Detail

Identifier of the ECO header

Initializes a new instance of the ApplyEcoSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _demandDetailObjid_ As Integer, _
   ByVal _ecoHeaderIDNum_ As String _
)

[ConstructorIndexAttribute()]
public ApplyEcoSetup(
   int _demandDetailObjid_,
   string _ecoHeaderIDNum_
)

Parameters

demandDetailObjid

Objid of the related Part Request Detail

ecoHeaderIDNum

Identifier of the ECO header

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ApplyEcoSetup Class
ApplyEcoSetup Members


CreateDate Property (ApplyEcoSetup) | fcSDK Documentation

CreateDate Property (ApplyEcoSetup)

The DateTime the ECO is applied. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ApplyEcoSetup Class
ApplyEcoSetup Members


DemandDetailObjid Property (ApplyEcoSetup) | fcSDK Documentation

DemandDetailObjid Property (ApplyEcoSetup)

Objid of the related Part Request Detail

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property DemandDetailObjid As Integer

[PropertyBitValueAttribute()]
public int DemandDetailObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ApplyEcoSetup Class
ApplyEcoSetup Members


EcoHeaderIDNum Property (ApplyEcoSetup) | fcSDK Documentation

EcoHeaderIDNum Property (ApplyEcoSetup)

Identifier of the ECO header

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property EcoHeaderIDNum As String

[PropertyBitValueAttribute()]
public string EcoHeaderIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ApplyEcoSetup Class
ApplyEcoSetup Members


UserName Property (ApplyEcoSetup) | fcSDK Documentation

UserName Property (ApplyEcoSetup)

The user applying the ECO. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ApplyEcoSetup Class
ApplyEcoSetup Members


CreateDepotRepairLaborSetup Class | fcSDK Documentation

CreateDepotRepairLaborSetup Class

Used by the CreateDepotRepairLabor method as setup data for invocation.

Syntax

'Declaration

Public Class CreateDepotRepairLaborSetup

public class CreateDepotRepairLaborSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.DepotRepair.CreateDepotRepairLaborSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.DepotRepair

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateDepotRepairLaborSetup Members
FChoice.Toolkits.Clarify.DepotRepair Namespace
CreateDepotRepairLabor(CreateDepotRepairLaborSetup) Method


CreateDepotRepairLaborSetup Class Members | fcSDK Documentation

CreateDepotRepairLaborSetup Class Members

The following tables list the members exposed by CreateDepotRepairLaborSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateDepotRepairLaborSetup Constructor | Initializes a new instance of the CreateDepotRepairLaborSetup class.

Public Properties

 | Name | Description
Public Property | BillTo | Element from the 'BILL_TO_LABOR' application list. If not set, the default list value is used.
Public Property | CreateDate | The DateTime the Labor entry is created. If not set, the current time is used.
Public Property | DemandDetailObjid | Objid of the related Part Request Detail
Public Property | Duration | Length of time required to do the work, in seconds
Public Property | IsBillable | Indicates whether labor is billable.
Public Property | LaborRate | This is the labor rate for the employee performing the labor
Public Property | LaborType | Element from the 'Labor Type' application list. If not set, the default list value is used.
Public Property | StartDate | The DateTime the Labor began. If not set, the current time is used.
Public Property | UserName | The user creating the Labor entry. If not set, the Toolkit session user is used.
Public Property | WorkCenter | Indicates where labor was performed

Reference

CreateDepotRepairLaborSetup Class
FChoice.Toolkits.Clarify.DepotRepair Namespace
CreateDepotRepairLabor(CreateDepotRepairLaborSetup) Method


CreateDepotRepairLaborSetup Constructor | fcSDK Documentation

CreateDepotRepairLaborSetup Constructor

Objid of the related Part Request Detail

The DateTime the Labor began. If not set, the current time is used.

Length of time required to do the work, in seconds

Initializes a new instance of the CreateDepotRepairLaborSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _demandDetailObjid_ As Integer, _
   ByVal _startDate_ As Date, _
   ByVal _duration_ As TimeSpan _
)

[ConstructorIndexAttribute()]
public CreateDepotRepairLaborSetup(
   int _demandDetailObjid_,
   DateTime _startDate_,
   TimeSpan _duration_
)

Parameters

demandDetailObjid

Objid of the related Part Request Detail

startDate

The DateTime the Labor began. If not set, the current time is used.

duration

Length of time required to do the work, in seconds

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateDepotRepairLaborSetup Class
CreateDepotRepairLaborSetup Members


BillTo Property (CreateDepotRepairLaborSetup) | fcSDK Documentation

BillTo Property (CreateDepotRepairLaborSetup)

Element from the 'BILL_TO_LABOR' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property BillTo As String

[PropertyBitValueAttribute()]
public string BillTo {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateDepotRepairLaborSetup Class
CreateDepotRepairLaborSetup Members


CreateDate Property (CreateDepotRepairLaborSetup) | fcSDK Documentation

CreateDate Property (CreateDepotRepairLaborSetup)

The DateTime the Labor entry is created. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateDepotRepairLaborSetup Class
CreateDepotRepairLaborSetup Members


DemandDetailObjid Property (CreateDepotRepairLaborSetup) | fcSDK Documentation

DemandDetailObjid Property (CreateDepotRepairLaborSetup)

Objid of the related Part Request Detail

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property DemandDetailObjid As Integer

[PropertyBitValueAttribute()]
public int DemandDetailObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateDepotRepairLaborSetup Class
CreateDepotRepairLaborSetup Members


Duration Property (CreateDepotRepairLaborSetup) | fcSDK Documentation

Duration Property (CreateDepotRepairLaborSetup)

Length of time required to do the work, in seconds

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Duration As TimeSpan

[PropertyBitValueAttribute()]
public TimeSpan Duration {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateDepotRepairLaborSetup Class
CreateDepotRepairLaborSetup Members


IsBillable Property (CreateDepotRepairLaborSetup) | fcSDK Documentation

IsBillable Property (CreateDepotRepairLaborSetup)

Indicates whether labor is billable.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsBillable As Boolean

[PropertyBitValueAttribute()]
public bool IsBillable {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateDepotRepairLaborSetup Class
CreateDepotRepairLaborSetup Members


LaborRate Property (CreateDepotRepairLaborSetup) | fcSDK Documentation

LaborRate Property (CreateDepotRepairLaborSetup)

This is the labor rate for the employee performing the labor

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LaborRate As Double

[PropertyBitValueAttribute()]
public double LaborRate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateDepotRepairLaborSetup Class
CreateDepotRepairLaborSetup Members


LaborType Property (CreateDepotRepairLaborSetup) | fcSDK Documentation

LaborType Property (CreateDepotRepairLaborSetup)

Element from the 'Labor Type' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LaborType As String

[PropertyBitValueAttribute()]
public string LaborType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateDepotRepairLaborSetup Class
CreateDepotRepairLaborSetup Members


StartDate Property (CreateDepotRepairLaborSetup) | fcSDK Documentation

StartDate Property (CreateDepotRepairLaborSetup)

The DateTime the Labor began. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property StartDate As Date

[PropertyBitValueAttribute()]
public DateTime StartDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateDepotRepairLaborSetup Class
CreateDepotRepairLaborSetup Members


UserName Property (CreateDepotRepairLaborSetup) | fcSDK Documentation

UserName Property (CreateDepotRepairLaborSetup)

The user creating the Labor entry. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateDepotRepairLaborSetup Class
CreateDepotRepairLaborSetup Members


WorkCenter Property (CreateDepotRepairLaborSetup) | fcSDK Documentation

WorkCenter Property (CreateDepotRepairLaborSetup)

Indicates where labor was performed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WorkCenter As String

[PropertyBitValueAttribute()]
public string WorkCenter {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateDepotRepairLaborSetup Class
CreateDepotRepairLaborSetup Members


CreateDepotRepairMaterialSetup Class | fcSDK Documentation

CreateDepotRepairMaterialSetup Class

Used by the CreateDepotRepairMaterial method as setup data for invocation.

Syntax

'Declaration

Public Class CreateDepotRepairMaterialSetup

public class CreateDepotRepairMaterialSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.DepotRepair.CreateDepotRepairMaterialSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.DepotRepair

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateDepotRepairMaterialSetup Members
FChoice.Toolkits.Clarify.DepotRepair Namespace
CreateDepotRepairMaterial(CreateDepotRepairMaterialSetup) Method


CreateDepotRepairMaterialSetup Class Members | fcSDK Documentation

CreateDepotRepairMaterialSetup Class Members

The following tables list the members exposed by CreateDepotRepairMaterialSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateDepotRepairMaterialSetup Constructor | Initializes a new instance of the CreateDepotRepairMaterialSetup class.

Public Properties

 | Name | Description
Public Property | BillTo | Element from the 'BILL_TO_MATERIAL' application list. If not set, the default list value is used.
Public Property | CreateDate | The DateTime the Material entry is created. If not set, the current time is used.
Public Property | DemandDetailObjid | Objid of the related Part Request Detail
Public Property | Disposition | Indicates how the material relates to the depot repair part.
Public Property | FailureCode | Element from the 'Failure Code' application list. If not set, the default list value is used.
Public Property | IsBillable | Indicates whether material is billable.
Public Property | Notes | Description area for the material usage activity.
Public Property | PartRevisionObjid | The objid of the part revision of the material that was put in use.
Public Property | ReferenceDesignator | Describes a reference location or designation for the part.
Public Property | RepairCode | Element from the 'Repair Type' application list. If not set, the default list value is used.
Public Property | TransactionID | Indicates the id of the GL transaction associated with this material usage
Public Property | UserName | The user creating the Material entry. If not set the Toolkit session user is used.
Public Property | WorkCenter | Indicates where material was used

Reference

CreateDepotRepairMaterialSetup Class
FChoice.Toolkits.Clarify.DepotRepair Namespace
CreateDepotRepairMaterial(CreateDepotRepairMaterialSetup) Method


CreateDepotRepairMaterialSetup Constructor | fcSDK Documentation

CreateDepotRepairMaterialSetup Constructor

Objid of the related Part Request Detail

The objid of the part revision of the material that was put in use.

Indicates how the material relates to the depot repair part.

Initializes a new instance of the CreateDepotRepairMaterialSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _demandDetailObjid_ As Integer, _
   ByVal _partRevisionObjid_ As Integer, _
   ByVal _disposition_ As RepairPartDisposition _
)

[ConstructorIndexAttribute()]
public CreateDepotRepairMaterialSetup(
   int _demandDetailObjid_,
   int _partRevisionObjid_,
   RepairPartDisposition _disposition_
)

Parameters

demandDetailObjid

Objid of the related Part Request Detail

partRevisionObjid

The objid of the part revision of the material that was put in use.

disposition

Indicates how the material relates to the depot repair part.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateDepotRepairMaterialSetup Class
CreateDepotRepairMaterialSetup Members


BillTo Property (CreateDepotRepairMaterialSetup) | fcSDK Documentation

BillTo Property (CreateDepotRepairMaterialSetup)

Element from the 'BILL_TO_MATERIAL' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property BillTo As String

[PropertyBitValueAttribute()]
public string BillTo {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateDepotRepairMaterialSetup Class
CreateDepotRepairMaterialSetup Members


CreateDate Property (CreateDepotRepairMaterialSetup) | fcSDK Documentation

CreateDate Property (CreateDepotRepairMaterialSetup)

The DateTime the Material entry is created. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateDepotRepairMaterialSetup Class
CreateDepotRepairMaterialSetup Members


DemandDetailObjid Property (CreateDepotRepairMaterialSetup) | fcSDK Documentation

DemandDetailObjid Property (CreateDepotRepairMaterialSetup)

Objid of the related Part Request Detail

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property DemandDetailObjid As Integer

[PropertyBitValueAttribute()]
public int DemandDetailObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateDepotRepairMaterialSetup Class
CreateDepotRepairMaterialSetup Members


Disposition Property (CreateDepotRepairMaterialSetup) | fcSDK Documentation

Disposition Property (CreateDepotRepairMaterialSetup)

Indicates how the material relates to the depot repair part.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Disposition As RepairPartDisposition

[PropertyBitValueAttribute()]
public RepairPartDisposition Disposition {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateDepotRepairMaterialSetup Class
CreateDepotRepairMaterialSetup Members


FailureCode Property (CreateDepotRepairMaterialSetup) | fcSDK Documentation

FailureCode Property (CreateDepotRepairMaterialSetup)

Element from the 'Failure Code' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FailureCode As String

[PropertyBitValueAttribute()]
public string FailureCode {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateDepotRepairMaterialSetup Class
CreateDepotRepairMaterialSetup Members


IsBillable Property (CreateDepotRepairMaterialSetup) | fcSDK Documentation

IsBillable Property (CreateDepotRepairMaterialSetup)

Indicates whether material is billable.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsBillable As Boolean

[PropertyBitValueAttribute()]
public bool IsBillable {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateDepotRepairMaterialSetup Class
CreateDepotRepairMaterialSetup Members


Notes Property (CreateDepotRepairMaterialSetup) | fcSDK Documentation

Notes Property (CreateDepotRepairMaterialSetup)

Description area for the material usage activity.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateDepotRepairMaterialSetup Class
CreateDepotRepairMaterialSetup Members


PartRevisionObjid Property (CreateDepotRepairMaterialSetup) | fcSDK Documentation

PartRevisionObjid Property (CreateDepotRepairMaterialSetup)

The objid of the part revision of the material that was put in use.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRevisionObjid As Integer

[PropertyBitValueAttribute()]
public int PartRevisionObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateDepotRepairMaterialSetup Class
CreateDepotRepairMaterialSetup Members


ReferenceDesignator Property (CreateDepotRepairMaterialSetup) | fcSDK Documentation

ReferenceDesignator Property (CreateDepotRepairMaterialSetup)

Describes a reference location or designation for the part.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ReferenceDesignator As String

[PropertyBitValueAttribute()]
public string ReferenceDesignator {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateDepotRepairMaterialSetup Class
CreateDepotRepairMaterialSetup Members


RepairCode Property (CreateDepotRepairMaterialSetup) | fcSDK Documentation

RepairCode Property (CreateDepotRepairMaterialSetup)

Element from the 'Repair Type' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property RepairCode As String

[PropertyBitValueAttribute()]
public string RepairCode {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateDepotRepairMaterialSetup Class
CreateDepotRepairMaterialSetup Members


TransactionID Property (CreateDepotRepairMaterialSetup) | fcSDK Documentation

TransactionID Property (CreateDepotRepairMaterialSetup)

Indicates the id of the GL transaction associated with this material usage

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property TransactionID As String

[PropertyBitValueAttribute()]
public string TransactionID {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateDepotRepairMaterialSetup Class
CreateDepotRepairMaterialSetup Members


UserName Property (CreateDepotRepairMaterialSetup) | fcSDK Documentation

UserName Property (CreateDepotRepairMaterialSetup)

The user creating the Material entry. If not set the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateDepotRepairMaterialSetup Class
CreateDepotRepairMaterialSetup Members


WorkCenter Property (CreateDepotRepairMaterialSetup) | fcSDK Documentation

WorkCenter Property (CreateDepotRepairMaterialSetup)

Indicates where material was used

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WorkCenter As String

[PropertyBitValueAttribute()]
public string WorkCenter {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateDepotRepairMaterialSetup Class
CreateDepotRepairMaterialSetup Members


CreateEcoHeaderSetup Class | fcSDK Documentation

CreateEcoHeaderSetup Class

Used by the CreateEcoHeader method as setup data for invocation.

Syntax

'Declaration

Public Class CreateEcoHeaderSetup

public class CreateEcoHeaderSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.DepotRepair.CreateEcoHeaderSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.DepotRepair

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateEcoHeaderSetup Members
FChoice.Toolkits.Clarify.DepotRepair Namespace
CreateEcoHeader(CreateEcoHeaderSetup) Method


CreateEcoHeaderSetup Class Members | fcSDK Documentation

CreateEcoHeaderSetup Class Members

The following tables list the members exposed by CreateEcoHeaderSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateEcoHeaderSetup Constructor | Initializes a new instance of the CreateEcoHeaderSetup class.

Public Properties

 | Name | Description
Public Property | CreateDate | The DateTime the ECO header is created. If not set, the current time is used.
Public Property | Description | The text description of the ECO header.
Public Property | EcoTitle | The title of the new ECO header
Public Property | EcoType | Element from the 'ECO Type' application list. If not set, the default list value is used.
Public Property | EffectType | Element from the 'ECO Effect Type' application list. If not set, the default list value is used.
Public Property | EndDate | The DateTime the ECO header becomes obsolete. If not set, the current time is used.
Public Property | StartDate | The DateTime the ECO header goes into effect. If not set, the current time is used.
Public Property | Status | Element from the 'ECO Status' application list. If not set, the default list value is used.

Reference

CreateEcoHeaderSetup Class
FChoice.Toolkits.Clarify.DepotRepair Namespace
CreateEcoHeader(CreateEcoHeaderSetup) Method


CreateEcoHeaderSetup Constructor | fcSDK Documentation

CreateEcoHeaderSetup Constructor

The DateTime the ECO header goes into effect. If not set, the current time is used.

The DateTime the ECO header becomes obsolete. If not set, the current time is used.

Initializes a new instance of the CreateEcoHeaderSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _startDate_ As Date, _
   ByVal _endDate_ As Date _
)

[ConstructorIndexAttribute()]
public CreateEcoHeaderSetup(
   DateTime _startDate_,
   DateTime _endDate_
)

Parameters

startDate

The DateTime the ECO header goes into effect. If not set, the current time is used.

endDate

The DateTime the ECO header becomes obsolete. If not set, the current time is used.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEcoHeaderSetup Class
CreateEcoHeaderSetup Members


CreateDate Property (CreateEcoHeaderSetup) | fcSDK Documentation

CreateDate Property (CreateEcoHeaderSetup)

The DateTime the ECO header is created. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEcoHeaderSetup Class
CreateEcoHeaderSetup Members


Description Property (CreateEcoHeaderSetup) | fcSDK Documentation

Description Property (CreateEcoHeaderSetup)

The text description of the ECO header.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Description As String

[PropertyBitValueAttribute()]
public string Description {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEcoHeaderSetup Class
CreateEcoHeaderSetup Members


EcoTitle Property | fcSDK Documentation

EcoTitle Property

The title of the new ECO header

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property EcoTitle As String

[PropertyBitValueAttribute()]
public string EcoTitle {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEcoHeaderSetup Class
CreateEcoHeaderSetup Members


EcoType Property | fcSDK Documentation

EcoType Property

Element from the 'ECO Type' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property EcoType As String

[PropertyBitValueAttribute()]
public string EcoType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEcoHeaderSetup Class
CreateEcoHeaderSetup Members


EffectType Property | fcSDK Documentation

EffectType Property

Element from the 'ECO Effect Type' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property EffectType As String

[PropertyBitValueAttribute()]
public string EffectType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEcoHeaderSetup Class
CreateEcoHeaderSetup Members


EndDate Property (CreateEcoHeaderSetup) | fcSDK Documentation

EndDate Property (CreateEcoHeaderSetup)

The DateTime the ECO header becomes obsolete. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property EndDate As Date

[PropertyBitValueAttribute()]
public DateTime EndDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEcoHeaderSetup Class
CreateEcoHeaderSetup Members


StartDate Property (CreateEcoHeaderSetup) | fcSDK Documentation

StartDate Property (CreateEcoHeaderSetup)

The DateTime the ECO header goes into effect. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property StartDate As Date

[PropertyBitValueAttribute()]
public DateTime StartDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEcoHeaderSetup Class
CreateEcoHeaderSetup Members


Status Property (CreateEcoHeaderSetup) | fcSDK Documentation

Status Property (CreateEcoHeaderSetup)

Element from the 'ECO Status' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Status As String

[PropertyBitValueAttribute()]
public string Status {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEcoHeaderSetup Class
CreateEcoHeaderSetup Members


CreateEcoItemSetup Class | fcSDK Documentation

CreateEcoItemSetup Class

Used by the CreateEcoItem method as setup data for invocation.

Syntax

'Declaration

Public Class CreateEcoItemSetup

public class CreateEcoItemSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.DepotRepair.CreateEcoItemSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.DepotRepair

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateEcoItemSetup Members
FChoice.Toolkits.Clarify.DepotRepair Namespace
CreateEcoItem(CreateEcoItemSetup) Method


CreateEcoItemSetup Class Members | fcSDK Documentation

CreateEcoItemSetup Class Members

The following tables list the members exposed by CreateEcoItemSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateEcoItemSetup Constructor | Initializes a new instance of the CreateEcoItemSetup class.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AppliesTo | This must be either 5148 to apply the ECO item to an ECO header, or 329 to apply the ECO item to a part revision.

| | Public Property | ApplyPartRevisionObjid | The objid of part revision affected by the ECO, or 0 for no change. | | Public Property | EcoHeaderIDNum | Identifier of the ECO header | | Public Property | IsActive | Is the ECO item active (true) or inactive (false) | | Public Property | ResultPartRevisionObjid | The objid of resulting part revision after applying the ECO, or 0 for no change. |

Reference

CreateEcoItemSetup Class
FChoice.Toolkits.Clarify.DepotRepair Namespace
CreateEcoItem(CreateEcoItemSetup) Method


CreateEcoItemSetup Constructor | fcSDK Documentation

CreateEcoItemSetup Constructor

This must be either 5148 to apply the ECO item to an ECO header, or 329 to apply the ECO item to a part revision.

Is the ECO item active (true) or inactive (false)

Identifier of the ECO header

The objid of part revision affected by the ECO, or 0 for no change.

The objid of resulting part revision after applying the ECO, or 0 for no change.

Initializes a new instance of the CreateEcoItemSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _appliesTo_ As EcoItemAppliesTo, _
   ByVal _isActive_ As Boolean, _
   ByVal _ecoHeaderIDNum_ As String, _
   ByVal _applyPartRevisionObjid_ As Integer, _
   ByVal _resultPartRevisionObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public CreateEcoItemSetup(
   EcoItemAppliesTo _appliesTo_,
   bool _isActive_,
   string _ecoHeaderIDNum_,
   int _applyPartRevisionObjid_,
   int _resultPartRevisionObjid_
)

Parameters

appliesTo

This must be either 5148 to apply the ECO item to an ECO header, or 329 to apply the ECO item to a part revision.

isActive

Is the ECO item active (true) or inactive (false)

ecoHeaderIDNum

Identifier of the ECO header

applyPartRevisionObjid

The objid of part revision affected by the ECO, or 0 for no change.

resultPartRevisionObjid

The objid of resulting part revision after applying the ECO, or 0 for no change.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEcoItemSetup Class
CreateEcoItemSetup Members


AppliesTo Property (CreateEcoItemSetup) | fcSDK Documentation

AppliesTo Property (CreateEcoItemSetup)

This must be either 5148 to apply the ECO item to an ECO header, or 329 to apply the ECO item to a part revision.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AppliesTo As EcoItemAppliesTo

[PropertyBitValueAttribute()]
public EcoItemAppliesTo AppliesTo {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEcoItemSetup Class
CreateEcoItemSetup Members


ApplyPartRevisionObjid Property (CreateEcoItemSetup) | fcSDK Documentation

ApplyPartRevisionObjid Property (CreateEcoItemSetup)

The objid of part revision affected by the ECO, or 0 for no change.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ApplyPartRevisionObjid As Integer

[PropertyBitValueAttribute()]
public int ApplyPartRevisionObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEcoItemSetup Class
CreateEcoItemSetup Members


EcoHeaderIDNum Property (CreateEcoItemSetup) | fcSDK Documentation

EcoHeaderIDNum Property (CreateEcoItemSetup)

Identifier of the ECO header

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property EcoHeaderIDNum As String

[PropertyBitValueAttribute()]
public string EcoHeaderIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEcoItemSetup Class
CreateEcoItemSetup Members


IsActive Property (CreateEcoItemSetup) | fcSDK Documentation

IsActive Property (CreateEcoItemSetup)

Is the ECO item active (true) or inactive (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsActive As Boolean

[PropertyBitValueAttribute()]
public bool IsActive {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEcoItemSetup Class
CreateEcoItemSetup Members


ResultPartRevisionObjid Property (CreateEcoItemSetup) | fcSDK Documentation

ResultPartRevisionObjid Property (CreateEcoItemSetup)

The objid of resulting part revision after applying the ECO, or 0 for no change.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ResultPartRevisionObjid As Integer

[PropertyBitValueAttribute()]
public int ResultPartRevisionObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEcoItemSetup Class
CreateEcoItemSetup Members


CreateEcoLaborDetailSetup Class | fcSDK Documentation

CreateEcoLaborDetailSetup Class

Used by the CreateEcoLaborDetail method as setup data for invocation.

Syntax

'Declaration

Public Class CreateEcoLaborDetailSetup

public class CreateEcoLaborDetailSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.DepotRepair.CreateEcoLaborDetailSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.DepotRepair

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateEcoLaborDetailSetup Members
FChoice.Toolkits.Clarify.DepotRepair Namespace
CreateEcoLaborDetail(CreateEcoLaborDetailSetup) Method


CreateEcoLaborDetailSetup Class Members | fcSDK Documentation

CreateEcoLaborDetailSetup Class Members

The following tables list the members exposed by CreateEcoLaborDetailSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateEcoLaborDetailSetup Constructor | Initializes a new instance of the CreateEcoLaborDetailSetup class.

Public Properties

 | Name | Description
Public Property | Description | Description of the ECO labor detail
Public Property | EcoHeaderIDNum | Identifier of the ECO header
Public Property | ElapsedTime | Estimated amount of time required to perform the work in seconds.
Public Property | IsRequired | Indicates if this detail is required (true) or not (false)
Public Property | LaborType | Element from the 'Labor Type' application list. If not set, the default list value is used.
Public Property | PartRevisionObjid | The objid of the part revision of the material that was put in use.
Public Property | Status | Element from the 'ECO Status' application list. If not set, the default list value is used.

Reference

CreateEcoLaborDetailSetup Class
FChoice.Toolkits.Clarify.DepotRepair Namespace
CreateEcoLaborDetail(CreateEcoLaborDetailSetup) Method


CreateEcoLaborDetailSetup Constructor | fcSDK Documentation

CreateEcoLaborDetailSetup Constructor

Indicates if this detail is required (true) or not (false)

Estimated amount of time required to perform the work in seconds.

Identifier of the ECO header

Initializes a new instance of the CreateEcoLaborDetailSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _isRequired_ As Boolean, _
   ByVal _elapsedTime_ As TimeSpan, _
   ByVal _ecoHeaderIDNum_ As String _
)

[ConstructorIndexAttribute()]
public CreateEcoLaborDetailSetup(
   bool _isRequired_,
   TimeSpan _elapsedTime_,
   string _ecoHeaderIDNum_
)

Parameters

isRequired

Indicates if this detail is required (true) or not (false)

elapsedTime

Estimated amount of time required to perform the work in seconds.

ecoHeaderIDNum

Identifier of the ECO header

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEcoLaborDetailSetup Class
CreateEcoLaborDetailSetup Members


Description Property (CreateEcoLaborDetailSetup) | fcSDK Documentation

Description Property (CreateEcoLaborDetailSetup)

Description of the ECO labor detail

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Description As String

[PropertyBitValueAttribute()]
public string Description {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEcoLaborDetailSetup Class
CreateEcoLaborDetailSetup Members


EcoHeaderIDNum Property (CreateEcoLaborDetailSetup) | fcSDK Documentation

EcoHeaderIDNum Property (CreateEcoLaborDetailSetup)

Identifier of the ECO header

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property EcoHeaderIDNum As String

[PropertyBitValueAttribute()]
public string EcoHeaderIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEcoLaborDetailSetup Class
CreateEcoLaborDetailSetup Members


ElapsedTime Property (CreateEcoLaborDetailSetup) | fcSDK Documentation

ElapsedTime Property (CreateEcoLaborDetailSetup)

Estimated amount of time required to perform the work in seconds.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ElapsedTime As TimeSpan

[PropertyBitValueAttribute()]
public TimeSpan ElapsedTime {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEcoLaborDetailSetup Class
CreateEcoLaborDetailSetup Members


IsRequired Property (CreateEcoLaborDetailSetup) | fcSDK Documentation

IsRequired Property (CreateEcoLaborDetailSetup)

Indicates if this detail is required (true) or not (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsRequired As Boolean

[PropertyBitValueAttribute()]
public bool IsRequired {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEcoLaborDetailSetup Class
CreateEcoLaborDetailSetup Members


LaborType Property (CreateEcoLaborDetailSetup) | fcSDK Documentation

LaborType Property (CreateEcoLaborDetailSetup)

Element from the 'Labor Type' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LaborType As String

[PropertyBitValueAttribute()]
public string LaborType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEcoLaborDetailSetup Class
CreateEcoLaborDetailSetup Members


PartRevisionObjid Property (CreateEcoLaborDetailSetup) | fcSDK Documentation

PartRevisionObjid Property (CreateEcoLaborDetailSetup)

The objid of the part revision of the material that was put in use.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRevisionObjid As Integer

[PropertyBitValueAttribute()]
public int PartRevisionObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEcoLaborDetailSetup Class
CreateEcoLaborDetailSetup Members


Status Property (CreateEcoLaborDetailSetup) | fcSDK Documentation

Status Property (CreateEcoLaborDetailSetup)

Element from the 'ECO Status' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Status As String

[PropertyBitValueAttribute()]
public string Status {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEcoLaborDetailSetup Class
CreateEcoLaborDetailSetup Members


CreateEcoMaterialDetailSetup Class | fcSDK Documentation

CreateEcoMaterialDetailSetup Class

Used by the CreateEcoMaterialDetail method as setup data for invocation.

Syntax

'Declaration

Public Class CreateEcoMaterialDetailSetup

public class CreateEcoMaterialDetailSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.DepotRepair.CreateEcoMaterialDetailSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.DepotRepair

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateEcoMaterialDetailSetup Members
FChoice.Toolkits.Clarify.DepotRepair Namespace
CreateEcoMaterialDetail(CreateEcoMaterialDetailSetup) Method


CreateEcoMaterialDetailSetup Class Members | fcSDK Documentation

CreateEcoMaterialDetailSetup Class Members

The following tables list the members exposed by CreateEcoMaterialDetailSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateEcoMaterialDetailSetup Constructor | Initializes a new instance of the CreateEcoMaterialDetailSetup class.

Public Properties

 | Name | Description
Public Property | Description | Description of the ECO material detail
Public Property | EcoHeaderIDNum | Identifier of the ECO header
Public Property | IsRequired | Indicates if this detail is required (true) or not (false)
Public Property | Location | Indicates the location where the material belongs.
Public Property | PartRevisionObjid | The objid of the part revision of the material that was put in use.
Public Property | Status | Element from the 'ECO Status' application list. If not set, the default list value is used.

Reference

CreateEcoMaterialDetailSetup Class
FChoice.Toolkits.Clarify.DepotRepair Namespace
CreateEcoMaterialDetail(CreateEcoMaterialDetailSetup) Method


CreateEcoMaterialDetailSetup Constructor | fcSDK Documentation

CreateEcoMaterialDetailSetup Constructor

Indicates if this detail is required (true) or not (false)

Identifier of the ECO header

The objid of the part revision of the material that was put in use.

Initializes a new instance of the CreateEcoMaterialDetailSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _isRequired_ As Boolean, _
   ByVal _ecoHeaderIDNum_ As String, _
   ByVal _partRevisionObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public CreateEcoMaterialDetailSetup(
   bool _isRequired_,
   string _ecoHeaderIDNum_,
   int _partRevisionObjid_
)

Parameters

isRequired

Indicates if this detail is required (true) or not (false)

ecoHeaderIDNum

Identifier of the ECO header

partRevisionObjid

The objid of the part revision of the material that was put in use.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEcoMaterialDetailSetup Class
CreateEcoMaterialDetailSetup Members


Description Property (CreateEcoMaterialDetailSetup) | fcSDK Documentation

Description Property (CreateEcoMaterialDetailSetup)

Description of the ECO material detail

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Description As String

[PropertyBitValueAttribute()]
public string Description {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEcoMaterialDetailSetup Class
CreateEcoMaterialDetailSetup Members


EcoHeaderIDNum Property (CreateEcoMaterialDetailSetup) | fcSDK Documentation

EcoHeaderIDNum Property (CreateEcoMaterialDetailSetup)

Identifier of the ECO header

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property EcoHeaderIDNum As String

[PropertyBitValueAttribute()]
public string EcoHeaderIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEcoMaterialDetailSetup Class
CreateEcoMaterialDetailSetup Members


IsRequired Property (CreateEcoMaterialDetailSetup) | fcSDK Documentation

IsRequired Property (CreateEcoMaterialDetailSetup)

Indicates if this detail is required (true) or not (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsRequired As Boolean

[PropertyBitValueAttribute()]
public bool IsRequired {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEcoMaterialDetailSetup Class
CreateEcoMaterialDetailSetup Members


Location Property (CreateEcoMaterialDetailSetup) | fcSDK Documentation

Location Property (CreateEcoMaterialDetailSetup)

Indicates the location where the material belongs.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Location As String

[PropertyBitValueAttribute()]
public string Location {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEcoMaterialDetailSetup Class
CreateEcoMaterialDetailSetup Members


PartRevisionObjid Property (CreateEcoMaterialDetailSetup) | fcSDK Documentation

PartRevisionObjid Property (CreateEcoMaterialDetailSetup)

The objid of the part revision of the material that was put in use.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRevisionObjid As Integer

[PropertyBitValueAttribute()]
public int PartRevisionObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEcoMaterialDetailSetup Class
CreateEcoMaterialDetailSetup Members


Status Property (CreateEcoMaterialDetailSetup) | fcSDK Documentation

Status Property (CreateEcoMaterialDetailSetup)

Element from the 'ECO Status' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Status As String

[PropertyBitValueAttribute()]
public string Status {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEcoMaterialDetailSetup Class
CreateEcoMaterialDetailSetup Members


DeleteDepotRepairLaborSetup Class | fcSDK Documentation

DeleteDepotRepairLaborSetup Class

Used by the DeleteDepotRepairLabor method as setup data for invocation.

Syntax

'Declaration

Public Class DeleteDepotRepairLaborSetup

public class DeleteDepotRepairLaborSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.DepotRepair.DeleteDepotRepairLaborSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.DepotRepair

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

DeleteDepotRepairLaborSetup Members
FChoice.Toolkits.Clarify.DepotRepair Namespace
DeleteDepotRepairLabor(DeleteDepotRepairLaborSetup) Method


DeleteDepotRepairLaborSetup Class Members | fcSDK Documentation

DeleteDepotRepairLaborSetup Class Members

The following tables list the members exposed by DeleteDepotRepairLaborSetup.

Public Constructors

 | Name | Description
Public Constructor | DeleteDepotRepairLaborSetup Constructor | Initializes a new instance of the DeleteDepotRepairLaborSetup class.

Public Properties

 | Name | Description
Public Property | CreateDate | The DateTime the Labor entry is removed. If not set, the current time is used.
Public Property | TimeLogObjid | The objid of the time log object to be deleted

Reference

DeleteDepotRepairLaborSetup Class
FChoice.Toolkits.Clarify.DepotRepair Namespace
DeleteDepotRepairLabor(DeleteDepotRepairLaborSetup) Method


DeleteDepotRepairLaborSetup Constructor | fcSDK Documentation

DeleteDepotRepairLaborSetup Constructor

The objid of the time log object to be deleted

Initializes a new instance of the DeleteDepotRepairLaborSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _timeLogObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public DeleteDepotRepairLaborSetup(
   int _timeLogObjid_
)

Parameters

timeLogObjid

The objid of the time log object to be deleted

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteDepotRepairLaborSetup Class
DeleteDepotRepairLaborSetup Members


CreateDate Property (DeleteDepotRepairLaborSetup) | fcSDK Documentation

CreateDate Property (DeleteDepotRepairLaborSetup)

The DateTime the Labor entry is removed. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteDepotRepairLaborSetup Class
DeleteDepotRepairLaborSetup Members


TimeLogObjid Property (DeleteDepotRepairLaborSetup) | fcSDK Documentation

TimeLogObjid Property (DeleteDepotRepairLaborSetup)

The objid of the time log object to be deleted

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property TimeLogObjid As Integer

[PropertyBitValueAttribute()]
public int TimeLogObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteDepotRepairLaborSetup Class
DeleteDepotRepairLaborSetup Members


DeleteDepotRepairMaterialSetup Class | fcSDK Documentation

DeleteDepotRepairMaterialSetup Class

Used by the DeleteDepotRepairMaterial method as setup data for invocation.

Syntax

'Declaration

Public Class DeleteDepotRepairMaterialSetup

public class DeleteDepotRepairMaterialSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.DepotRepair.DeleteDepotRepairMaterialSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.DepotRepair

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

DeleteDepotRepairMaterialSetup Members
FChoice.Toolkits.Clarify.DepotRepair Namespace
DeleteDepotRepairMaterial(DeleteDepotRepairMaterialSetup) Method


DeleteDepotRepairMaterialSetup Class Members | fcSDK Documentation

DeleteDepotRepairMaterialSetup Class Members

The following tables list the members exposed by DeleteDepotRepairMaterialSetup.

Public Constructors

 | Name | Description
Public Constructor | DeleteDepotRepairMaterialSetup Constructor | Initializes a new instance of the DeleteDepotRepairMaterialSetup class.

Public Properties

 | Name | Description
Public Property | CreateDate | The DateTime the Material entry is removed. If not set, the current time is used.
Public Property | MaterialLogObjid | The objid of the material log object to be deleted

Reference

DeleteDepotRepairMaterialSetup Class
FChoice.Toolkits.Clarify.DepotRepair Namespace
DeleteDepotRepairMaterial(DeleteDepotRepairMaterialSetup) Method


DeleteDepotRepairMaterialSetup Constructor | fcSDK Documentation

DeleteDepotRepairMaterialSetup Constructor

The objid of the material log object to be deleted

Initializes a new instance of the DeleteDepotRepairMaterialSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _materialLogObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public DeleteDepotRepairMaterialSetup(
   int _materialLogObjid_
)

Parameters

materialLogObjid

The objid of the material log object to be deleted

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteDepotRepairMaterialSetup Class
DeleteDepotRepairMaterialSetup Members


CreateDate Property (DeleteDepotRepairMaterialSetup) | fcSDK Documentation

CreateDate Property (DeleteDepotRepairMaterialSetup)

The DateTime the Material entry is removed. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteDepotRepairMaterialSetup Class
DeleteDepotRepairMaterialSetup Members


MaterialLogObjid Property (DeleteDepotRepairMaterialSetup) | fcSDK Documentation

MaterialLogObjid Property (DeleteDepotRepairMaterialSetup)

The objid of the material log object to be deleted

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property MaterialLogObjid As Integer

[PropertyBitValueAttribute()]
public int MaterialLogObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteDepotRepairMaterialSetup Class
DeleteDepotRepairMaterialSetup Members


DeleteEcoDetailSetup Class | fcSDK Documentation

DeleteEcoDetailSetup Class

Used by the DeleteEcoDetail method as setup data for invocation.

Syntax

'Declaration

Public Class DeleteEcoDetailSetup

public class DeleteEcoDetailSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.DepotRepair.DeleteEcoDetailSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.DepotRepair

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

DeleteEcoDetailSetup Members
FChoice.Toolkits.Clarify.DepotRepair Namespace
DeleteEcoDetail(DeleteEcoDetailSetup) Method


DeleteEcoDetailSetup Class Members | fcSDK Documentation

DeleteEcoDetailSetup Class Members

The following tables list the members exposed by DeleteEcoDetailSetup.

Public Constructors

 | Name | Description
Public Constructor | DeleteEcoDetailSetup Constructor | Initializes a new instance of the DeleteEcoDetailSetup class.

Public Properties

 | Name | Description
Public Property | EcoDetailObjid | The objid of the ECO detail object to be deleted

Reference

DeleteEcoDetailSetup Class
FChoice.Toolkits.Clarify.DepotRepair Namespace
DeleteEcoDetail(DeleteEcoDetailSetup) Method


DeleteEcoDetailSetup Constructor | fcSDK Documentation

DeleteEcoDetailSetup Constructor

The objid of the ECO detail object to be deleted

Initializes a new instance of the DeleteEcoDetailSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _ecoDetailObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public DeleteEcoDetailSetup(
   int _ecoDetailObjid_
)

Parameters

ecoDetailObjid

The objid of the ECO detail object to be deleted

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteEcoDetailSetup Class
DeleteEcoDetailSetup Members


EcoDetailObjid Property (DeleteEcoDetailSetup) | fcSDK Documentation

EcoDetailObjid Property (DeleteEcoDetailSetup)

The objid of the ECO detail object to be deleted

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property EcoDetailObjid As Integer

[PropertyBitValueAttribute()]
public int EcoDetailObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteEcoDetailSetup Class
DeleteEcoDetailSetup Members


DeleteEcoItemSetup Class | fcSDK Documentation

DeleteEcoItemSetup Class

Used by the DeleteEcoItem method as setup data for invocation.

Syntax

'Declaration

Public Class DeleteEcoItemSetup

public class DeleteEcoItemSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.DepotRepair.DeleteEcoItemSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.DepotRepair

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

DeleteEcoItemSetup Members
FChoice.Toolkits.Clarify.DepotRepair Namespace
DeleteEcoItem(DeleteEcoItemSetup) Method


DeleteEcoItemSetup Class Members | fcSDK Documentation

DeleteEcoItemSetup Class Members

The following tables list the members exposed by DeleteEcoItemSetup.

Public Constructors

 | Name | Description
Public Constructor | DeleteEcoItemSetup Constructor | Initializes a new instance of the DeleteEcoItemSetup class.

Public Properties

 | Name | Description
Public Property | EcoItemObjid | The objid of the ECO item object to be deleted

Reference

DeleteEcoItemSetup Class
FChoice.Toolkits.Clarify.DepotRepair Namespace
DeleteEcoItem(DeleteEcoItemSetup) Method


DeleteEcoItemSetup Constructor | fcSDK Documentation

DeleteEcoItemSetup Constructor

The objid of the ECO item object to be deleted

Initializes a new instance of the DeleteEcoItemSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _ecoItemObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public DeleteEcoItemSetup(
   int _ecoItemObjid_
)

Parameters

ecoItemObjid

The objid of the ECO item object to be deleted

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteEcoItemSetup Class
DeleteEcoItemSetup Members


EcoItemObjid Property (DeleteEcoItemSetup) | fcSDK Documentation

EcoItemObjid Property (DeleteEcoItemSetup)

The objid of the ECO item object to be deleted

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property EcoItemObjid As Integer

[PropertyBitValueAttribute()]
public int EcoItemObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteEcoItemSetup Class
DeleteEcoItemSetup Members


DepotRepairToolkit Class | fcSDK Documentation

DepotRepairToolkit Class

Provides APIs to modify Logistics Depot Repair objects such as Engineering Change Orders (ECOs), labor, and material costs. For example, some of these APIs allow you to create, modify, and delete ECO headers and details, apply ECOs, create and modify labor records, and create/modify material records, and more.

Syntax

'Declaration

Public Class DepotRepairToolkit
   Inherits DepotRepairToolkitBase

public class DepotRepairToolkit : DepotRepairToolkitBase

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.ToolkitBase
FChoice.Toolkits.Clarify.DepotRepair.DepotRepairToolkitBase
FChoice.Toolkits.Clarify.DepotRepair.DepotRepairToolkit

Requirements

Namespace: FChoice.Toolkits.Clarify.DepotRepair

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

DepotRepairToolkit Members
FChoice.Toolkits.Clarify.DepotRepair Namespace


DepotRepairToolkit Class Members | fcSDK Documentation

DepotRepairToolkit Class Members

The following tables list the members exposed by DepotRepairToolkit.

Public Constructors

 | Name | Description
Public Constructor | DepotRepairToolkit Constructor | Overloaded.

Public Properties

 | Name | Description
Public Property | ImpersonatorUsername | (Inherited from FChoice.Toolkits.Clarify.DepotRepair.DepotRepairToolkitBase)

Public Methods

 | Name | Description
Public Method | ApplyEco | Overloaded. Apply an ECO to a Part Request Detail. This overload takes a set of required parameters for the API.
Public Method | CreateDepotRepairLabor | Overloaded. Create a Depot Repair Labor to be performed on a Part. This overload takes a set of required parameters for the API.
Public Method | CreateDepotRepairMaterial | Overloaded. Create a Depot Repair Material to be logged against a Part. This overload takes a set of required parameters for the API.
Public Method | CreateEcoHeader | Overloaded. Create an Engineering Change Order (ECO) Header. This overload takes a set of required parameters for the API.
Public Method | CreateEcoItem | Overloaded. Create an Engineering Change Order (ECO) Item. This overload takes a set of required parameters for the API.
Public Method | CreateEcoLaborDetail | Overloaded. Add a Labor Detail to a ECO Header. This overload takes a set of required parameters for the API.
Public Method | CreateEcoMaterialDetail | Overloaded. Add a Material Usage Detail to an ECO Header. This overload takes a set of required parameters for the API.
Public Method | DeleteDepotRepairLabor | Overloaded. Delete a Depot Repair Part. This overload takes a set of required parameters for the API.
Public Method | DeleteDepotRepairMaterial | Overloaded. Delete a Depot Repair Material. This overload takes a set of required parameters for the API.
Public Method | DeleteEcoDetail | Overloaded. Delete an ECO Detail. This overload takes a set of required parameters for the API.
Public Method | DeleteEcoItem | Overloaded. Delete an ECO Item. This overload takes a set of required parameters for the API.
Public Method | UpdateDepotRepairLabor | Overloaded. Update a Depot Repair Labor. This overload takes a setup object.
Public Method | UpdateDepotRepairMaterial | Overloaded. Update a Depot Repair Material. This overload takes a set of required parameters for the API.
Public Method | UpdateEcoItem | Overloaded. Update an ECO Item. This overload takes a set of required parameters for the API.
Public Method | UpdateEcoLaborDetail | Overloaded. Update an ECO Labor Detail. This overload takes a setup object.
Public Method | UpdateEcoMaterialDetail | Overloaded. Update an ECO Material Detail. This overload takes a set of required parameters for the API.

Reference

DepotRepairToolkit Class
FChoice.Toolkits.Clarify.DepotRepair Namespace


DepotRepairToolkit Constructor | fcSDK Documentation

DepotRepairToolkit Constructor

Overload List

Overload | Description
DepotRepairToolkit Constructor(ClarifySession) | Initializes a new instance of the DepotRepairToolkit class using a ClarifySession object.
DepotRepairToolkit Constructor(IFCApplication,IFCSession) | Initializes a new instance of the DepotRepairToolkit class using a Compatibility application and session.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class DepotRepairToolkit Members


DepotRepairToolkit Constructor(ClarifySession) | fcSDK Documentation

DepotRepairToolkit Constructor(ClarifySession)

The session under which the toolkit APIs will be executed.

Initializes a new instance of the DepotRepairToolkit class using a ClarifySession object.

Syntax

'Declaration

Public Function New( _
   ByVal _session_ As ClarifySession _
)

public DepotRepairToolkit(
   ClarifySession _session_
)

Parameters

session

The session under which the toolkit APIs will be executed.

Remarks

If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List


DepotRepairToolkit Constructor(IFCApplication,IFCSession) | fcSDK Documentation

DepotRepairToolkit Constructor(IFCApplication,IFCSession)

The compatibility application under which the toolkit APIs will be executed.

The compatibility session under which the toolkit APIs will be executed.

Initializes a new instance of the DepotRepairToolkit class using a Compatibility application and session.

Syntax

'Declaration

Public Function New( _
   ByVal _application_ As IFCApplication, _
   ByVal _session_ As IFCSession _
)

public DepotRepairToolkit(
   IFCApplication _application_,
   IFCSession _session_
)

Parameters

application

The compatibility application under which the toolkit APIs will be executed.

session

The compatibility session under which the toolkit APIs will be executed.

Remarks

If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List


ApplyEco Method | fcSDK Documentation

ApplyEco Method

Overload List

Overload | Description
ApplyEco(Int32,String) | Apply an ECO to a Part Request Detail. This overload takes a set of required parameters for the API.
ApplyEco(ApplyEcoSetup) | Apply an ECO to a Part Request Detail. This overload takes a setup object.
ApplyEco(ApplyEcoSetup,IDbTransaction) | Apply an ECO to a Part Request Detail. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class DepotRepairToolkit Members ApplyEcoSetup Class


ApplyEco(Int32,String) Method | fcSDK Documentation

ApplyEco(Int32,String) Method

Objid of the related Part Request Detail

Identifier of the ECO header

Apply an ECO to a Part Request Detail. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function ApplyEco( _
   ByVal _demandDetailObjid_ As Integer, _
   ByVal _ecoHeaderIDNum_ As String _
) As ToolkitResult

public ToolkitResult ApplyEco(
   int _demandDetailObjid_,
   string _ecoHeaderIDNum_
)

Parameters

demandDetailObjid

Objid of the related Part Request Detail

ecoHeaderIDNum

Identifier of the ECO header

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List


ApplyEco(ApplyEcoSetup) Method | fcSDK Documentation

ApplyEco(ApplyEcoSetup) Method

Setup object for API invocation.

Apply an ECO to a Part Request Detail. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function ApplyEco( _
   ByVal _setupParam_ ApplyEcoSetup _
) As ToolkitResult

public ToolkitResult ApplyEco(
   ApplyEcoSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List
ApplyEcoSetup Class


ApplyEco(ApplyEcoSetup,IDbTransaction) Method | fcSDK Documentation

ApplyEco(ApplyEcoSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Apply an ECO to a Part Request Detail. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function ApplyEco( _
   ByVal _setupParam_ As ApplyEcoSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult ApplyEco(
   ApplyEcoSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List


CreateDepotRepairLabor Method | fcSDK Documentation

CreateDepotRepairLabor Method

Overload List

Overload | Description
CreateDepotRepairLabor(Int32,DateTime,TimeSpan) | Create a Depot Repair Labor to be performed on a Part. This overload takes a set of required parameters for the API.
CreateDepotRepairLabor(CreateDepotRepairLaborSetup) | Create a Depot Repair Labor to be performed on a Part. This overload takes a setup object.
CreateDepotRepairLabor(CreateDepotRepairLaborSetup,IDbTransaction) | Create a Depot Repair Labor to be performed on a Part. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class DepotRepairToolkit Members CreateDepotRepairLaborSetup Class


CreateDepotRepairLabor(Int32,DateTime,TimeSpan) Method | fcSDK Documentation

CreateDepotRepairLabor(Int32,DateTime,TimeSpan) Method

Objid of the related Part Request Detail

The DateTime the Labor began. If not set, the current time is used.

Length of time required to do the work, in seconds

Create a Depot Repair Labor to be performed on a Part. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreateDepotRepairLabor( _
   ByVal _demandDetailObjid_ As Integer, _
   ByVal _startDate_ As Date, _
   ByVal _duration_ As TimeSpan _
) As ToolkitResult

public ToolkitResult CreateDepotRepairLabor(
   int _demandDetailObjid_,
   DateTime _startDate_,
   TimeSpan _duration_
)

Parameters

demandDetailObjid

Objid of the related Part Request Detail

startDate

The DateTime the Labor began. If not set, the current time is used.

duration

Length of time required to do the work, in seconds

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the TimeLog.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List


CreateDepotRepairLabor(CreateDepotRepairLaborSetup) Method | fcSDK Documentation

CreateDepotRepairLabor(CreateDepotRepairLaborSetup) Method

Setup object for API invocation.

Create a Depot Repair Labor to be performed on a Part. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreateDepotRepairLabor( _
   ByVal _setupParam_ CreateDepotRepairLaborSetup _
) As ToolkitResult

public ToolkitResult CreateDepotRepairLabor(
   CreateDepotRepairLaborSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the TimeLog.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List
CreateDepotRepairLaborSetup Class


CreateDepotRepairLabor(CreateDepotRepairLaborSetup,IDbTransaction) Method | fcSDK Documentation

CreateDepotRepairLabor(CreateDepotRepairLaborSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Create a Depot Repair Labor to be performed on a Part. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreateDepotRepairLabor( _
   ByVal _setupParam_ As CreateDepotRepairLaborSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreateDepotRepairLabor(
   CreateDepotRepairLaborSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List


CreateDepotRepairMaterial Method | fcSDK Documentation

CreateDepotRepairMaterial Method

Overload List

Overload | Description
CreateDepotRepairMaterial(Int32,Int32,RepairPartDisposition) | Create a Depot Repair Material to be logged against a Part. This overload takes a set of required parameters for the API.
CreateDepotRepairMaterial(CreateDepotRepairMaterialSetup) | Create a Depot Repair Material to be logged against a Part. This overload takes a setup object.
CreateDepotRepairMaterial(CreateDepotRepairMaterialSetup,IDbTransaction) | Create a Depot Repair Material to be logged against a Part. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class DepotRepairToolkit Members CreateDepotRepairMaterialSetup Class


CreateDepotRepairMaterial(Int32,Int32,RepairPartDisposition) Method | fcSDK Documentation

CreateDepotRepairMaterial(Int32,Int32,RepairPartDisposition) Method

Objid of the related Part Request Detail

The objid of the part revision of the material that was put in use.

Indicates how the material relates to the depot repair part.

Create a Depot Repair Material to be logged against a Part. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreateDepotRepairMaterial( _
   ByVal _demandDetailObjid_ As Integer, _
   ByVal _partRevisionObjid_ As Integer, _
   ByVal _disposition_ As RepairPartDisposition _
) As ToolkitResult

public ToolkitResult CreateDepotRepairMaterial(
   int _demandDetailObjid_,
   int _partRevisionObjid_,
   RepairPartDisposition _disposition_
)

Parameters

demandDetailObjid

Objid of the related Part Request Detail

partRevisionObjid

The objid of the part revision of the material that was put in use.

disposition

Indicates how the material relates to the depot repair part.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the MaterialLog.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List


CreateDepotRepairMaterial(CreateDepotRepairMaterialSetup) Method | fcSDK Documentation

CreateDepotRepairMaterial(CreateDepotRepairMaterialSetup) Method

Setup object for API invocation.

Create a Depot Repair Material to be logged against a Part. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreateDepotRepairMaterial( _
   ByVal _setupParam_ CreateDepotRepairMaterialSetup _
) As ToolkitResult

public ToolkitResult CreateDepotRepairMaterial(
   CreateDepotRepairMaterialSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the MaterialLog.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List
CreateDepotRepairMaterialSetup Class


CreateDepotRepairMaterial(CreateDepotRepairMaterialSetup,IDbTransaction) Method | fcSDK Documentation

CreateDepotRepairMaterial(CreateDepotRepairMaterialSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Create a Depot Repair Material to be logged against a Part. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreateDepotRepairMaterial( _
   ByVal _setupParam_ As CreateDepotRepairMaterialSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreateDepotRepairMaterial(
   CreateDepotRepairMaterialSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List


CreateEcoHeader Method | fcSDK Documentation

CreateEcoHeader Method

Overload List

Overload | Description
CreateEcoHeader(DateTime,DateTime) | Create an Engineering Change Order (ECO) Header. This overload takes a set of required parameters for the API.
CreateEcoHeader(CreateEcoHeaderSetup) | Create an Engineering Change Order (ECO) Header. This overload takes a setup object.
CreateEcoHeader(CreateEcoHeaderSetup,IDbTransaction) | Create an Engineering Change Order (ECO) Header. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class DepotRepairToolkit Members CreateEcoHeaderSetup Class


CreateEcoHeader(DateTime,DateTime) Method | fcSDK Documentation

CreateEcoHeader(DateTime,DateTime) Method

The DateTime the ECO header goes into effect. If not set, the current time is used.

The DateTime the ECO header becomes obsolete. If not set, the current time is used.

Create an Engineering Change Order (ECO) Header. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreateEcoHeader( _
   ByVal _startDate_ As Date, _
   ByVal _endDate_ As Date _
) As ToolkitResult

public ToolkitResult CreateEcoHeader(
   DateTime _startDate_,
   DateTime _endDate_
)

Parameters

startDate

The DateTime the ECO header goes into effect. If not set, the current time is used.

endDate

The DateTime the ECO header becomes obsolete. If not set, the current time is used.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List


CreateEcoHeader(CreateEcoHeaderSetup) Method | fcSDK Documentation

CreateEcoHeader(CreateEcoHeaderSetup) Method

Setup object for API invocation.

Create an Engineering Change Order (ECO) Header. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreateEcoHeader( _
   ByVal _setupParam_ CreateEcoHeaderSetup _
) As ToolkitResult

public ToolkitResult CreateEcoHeader(
   CreateEcoHeaderSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List
CreateEcoHeaderSetup Class


CreateEcoHeader(CreateEcoHeaderSetup,IDbTransaction) Method | fcSDK Documentation

CreateEcoHeader(CreateEcoHeaderSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Create an Engineering Change Order (ECO) Header. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreateEcoHeader( _
   ByVal _setupParam_ As CreateEcoHeaderSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreateEcoHeader(
   CreateEcoHeaderSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List


CreateEcoItem Method | fcSDK Documentation

CreateEcoItem Method

Overload List

Overload | Description
CreateEcoItem(EcoItemAppliesTo,Boolean,String,Int32,Int32) | Create an Engineering Change Order (ECO) Item. This overload takes a set of required parameters for the API.
CreateEcoItem(CreateEcoItemSetup) | Create an Engineering Change Order (ECO) Item. This overload takes a setup object.
CreateEcoItem(CreateEcoItemSetup,IDbTransaction) | Create an Engineering Change Order (ECO) Item. This overload takes a setup object and a database transaction.

Remarks

The objid of the ECO item created is returned in the object property ret_objid.

Requirements

A valid ECO Header be specified.

Reference

DepotRepairToolkit Class DepotRepairToolkit Members CreateEcoItemSetup Class


CreateEcoItem(EcoItemAppliesTo,Boolean,String,Int32,Int32) Method | fcSDK Documentation

CreateEcoItem(EcoItemAppliesTo,Boolean,String,Int32,Int32) Method

This must be either 5148 to apply the ECO item to an ECO header, or 329 to apply the ECO item to a part revision.

Is the ECO item active (true) or inactive (false)

Identifier of the ECO header

The objid of part revision affected by the ECO, or 0 for no change.

The objid of resulting part revision after applying the ECO, or 0 for no change.

Create an Engineering Change Order (ECO) Item. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreateEcoItem( _
   ByVal _appliesTo_ As EcoItemAppliesTo, _
   ByVal _isActive_ As Boolean, _
   ByVal _ecoHeaderIDNum_ As String, _
   ByVal _applyPartRevisionObjid_ As Integer, _
   ByVal _resultPartRevisionObjid_ As Integer _
) As ToolkitResult

public ToolkitResult CreateEcoItem(
   EcoItemAppliesTo _appliesTo_,
   bool _isActive_,
   string _ecoHeaderIDNum_,
   int _applyPartRevisionObjid_,
   int _resultPartRevisionObjid_
)

Parameters

appliesTo

This must be either 5148 to apply the ECO item to an ECO header, or 329 to apply the ECO item to a part revision.

isActive

Is the ECO item active (true) or inactive (false)

ecoHeaderIDNum

Identifier of the ECO header

applyPartRevisionObjid

The objid of part revision affected by the ECO, or 0 for no change.

resultPartRevisionObjid

The objid of resulting part revision after applying the ECO, or 0 for no change.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The objid of the ECO item created is returned in the object property ret_objid.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List


CreateEcoItem(CreateEcoItemSetup) Method | fcSDK Documentation

CreateEcoItem(CreateEcoItemSetup) Method

Setup object for API invocation.

Create an Engineering Change Order (ECO) Item. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreateEcoItem( _
   ByVal _setupParam_ CreateEcoItemSetup _
) As ToolkitResult

public ToolkitResult CreateEcoItem(
   CreateEcoItemSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The objid of the ECO item created is returned in the object property ret_objid.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List
CreateEcoItemSetup Class


CreateEcoItem(CreateEcoItemSetup,IDbTransaction) Method | fcSDK Documentation

CreateEcoItem(CreateEcoItemSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Create an Engineering Change Order (ECO) Item. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreateEcoItem( _
   ByVal _setupParam_ As CreateEcoItemSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreateEcoItem(
   CreateEcoItemSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The objid of the ECO item created is returned in the object property ret_objid.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List


CreateEcoLaborDetail Method | fcSDK Documentation

CreateEcoLaborDetail Method

Overload List

Overload | Description
CreateEcoLaborDetail(Boolean,TimeSpan,String) | Add a Labor Detail to a ECO Header. This overload takes a set of required parameters for the API.
CreateEcoLaborDetail(CreateEcoLaborDetailSetup) | Add a Labor Detail to a ECO Header. This overload takes a setup object.
CreateEcoLaborDetail(CreateEcoLaborDetailSetup,IDbTransaction) | Add a Labor Detail to a ECO Header. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class DepotRepairToolkit Members CreateEcoLaborDetailSetup Class


CreateEcoLaborDetail(Boolean,TimeSpan,String) Method | fcSDK Documentation

CreateEcoLaborDetail(Boolean,TimeSpan,String) Method

Indicates if this detail is required (true) or not (false)

Estimated amount of time required to perform the work in seconds.

Identifier of the ECO header

Add a Labor Detail to a ECO Header. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreateEcoLaborDetail( _
   ByVal _isRequired_ As Boolean, _
   ByVal _elapsedTime_ As TimeSpan, _
   ByVal _ecoHeaderIDNum_ As String _
) As ToolkitResult

public ToolkitResult CreateEcoLaborDetail(
   bool _isRequired_,
   TimeSpan _elapsedTime_,
   string _ecoHeaderIDNum_
)

Parameters

isRequired

Indicates if this detail is required (true) or not (false)

elapsedTime

Estimated amount of time required to perform the work in seconds.

ecoHeaderIDNum

Identifier of the ECO header

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List


CreateEcoLaborDetail(CreateEcoLaborDetailSetup) Method | fcSDK Documentation

CreateEcoLaborDetail(CreateEcoLaborDetailSetup) Method

Setup object for API invocation.

Add a Labor Detail to a ECO Header. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreateEcoLaborDetail( _
   ByVal _setupParam_ CreateEcoLaborDetailSetup _
) As ToolkitResult

public ToolkitResult CreateEcoLaborDetail(
   CreateEcoLaborDetailSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List
CreateEcoLaborDetailSetup Class


CreateEcoLaborDetail(CreateEcoLaborDetailSetup,IDbTransaction) Method | fcSDK Documentation

CreateEcoLaborDetail(CreateEcoLaborDetailSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Add a Labor Detail to a ECO Header. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreateEcoLaborDetail( _
   ByVal _setupParam_ As CreateEcoLaborDetailSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreateEcoLaborDetail(
   CreateEcoLaborDetailSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List


CreateEcoMaterialDetail Method | fcSDK Documentation

CreateEcoMaterialDetail Method

Overload List

Overload | Description
CreateEcoMaterialDetail(Boolean,String,Int32) | Add a Material Usage Detail to an ECO Header. This overload takes a set of required parameters for the API.
CreateEcoMaterialDetail(CreateEcoMaterialDetailSetup) | Add a Material Usage Detail to an ECO Header. This overload takes a setup object.
CreateEcoMaterialDetail(CreateEcoMaterialDetailSetup,IDbTransaction) | Add a Material Usage Detail to an ECO Header. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class DepotRepairToolkit Members CreateEcoMaterialDetailSetup Class


CreateEcoMaterialDetail(Boolean,String,Int32) Method | fcSDK Documentation

CreateEcoMaterialDetail(Boolean,String,Int32) Method

Indicates if this detail is required (true) or not (false)

Identifier of the ECO header

The objid of the part revision of the material that was put in use.

Add a Material Usage Detail to an ECO Header. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreateEcoMaterialDetail( _
   ByVal _isRequired_ As Boolean, _
   ByVal _ecoHeaderIDNum_ As String, _
   ByVal _partRevisionObjid_ As Integer _
) As ToolkitResult

public ToolkitResult CreateEcoMaterialDetail(
   bool _isRequired_,
   string _ecoHeaderIDNum_,
   int _partRevisionObjid_
)

Parameters

isRequired

Indicates if this detail is required (true) or not (false)

ecoHeaderIDNum

Identifier of the ECO header

partRevisionObjid

The objid of the part revision of the material that was put in use.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List


CreateEcoMaterialDetail(CreateEcoMaterialDetailSetup) Method | fcSDK Documentation

CreateEcoMaterialDetail(CreateEcoMaterialDetailSetup) Method

Setup object for API invocation.

Add a Material Usage Detail to an ECO Header. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreateEcoMaterialDetail( _
   ByVal _setupParam_ CreateEcoMaterialDetailSetup _
) As ToolkitResult

public ToolkitResult CreateEcoMaterialDetail(
   CreateEcoMaterialDetailSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List
CreateEcoMaterialDetailSetup Class


CreateEcoMaterialDetail(CreateEcoMaterialDetailSetup,IDbTransaction) Method | fcSDK Documentation

CreateEcoMaterialDetail(CreateEcoMaterialDetailSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Add a Material Usage Detail to an ECO Header. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreateEcoMaterialDetail( _
   ByVal _setupParam_ As CreateEcoMaterialDetailSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreateEcoMaterialDetail(
   CreateEcoMaterialDetailSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List


DeleteDepotRepairLabor Method | fcSDK Documentation

DeleteDepotRepairLabor Method

Overload List

Overload | Description
DeleteDepotRepairLabor(Int32) | Delete a Depot Repair Part. This overload takes a set of required parameters for the API.
DeleteDepotRepairLabor(DeleteDepotRepairLaborSetup) | Delete a Depot Repair Part. This overload takes a setup object.
DeleteDepotRepairLabor(DeleteDepotRepairLaborSetup,IDbTransaction) | Delete a Depot Repair Part. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class DepotRepairToolkit Members DeleteDepotRepairLaborSetup Class


DeleteDepotRepairLabor(Int32) Method | fcSDK Documentation

DeleteDepotRepairLabor(Int32) Method

The objid of the time log object to be deleted

Delete a Depot Repair Part. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function DeleteDepotRepairLabor( _
   ByVal _timeLogObjid_ As Integer _
) As ToolkitResult

public ToolkitResult DeleteDepotRepairLabor(
   int _timeLogObjid_
)

Parameters

timeLogObjid

The objid of the time log object to be deleted

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List


DeleteDepotRepairLabor(DeleteDepotRepairLaborSetup) Method | fcSDK Documentation

DeleteDepotRepairLabor(DeleteDepotRepairLaborSetup) Method

Setup object for API invocation.

Delete a Depot Repair Part. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function DeleteDepotRepairLabor( _
   ByVal _setupParam_ DeleteDepotRepairLaborSetup _
) As ToolkitResult

public ToolkitResult DeleteDepotRepairLabor(
   DeleteDepotRepairLaborSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List
DeleteDepotRepairLaborSetup Class


DeleteDepotRepairLabor(DeleteDepotRepairLaborSetup,IDbTransaction) Method | fcSDK Documentation

DeleteDepotRepairLabor(DeleteDepotRepairLaborSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Delete a Depot Repair Part. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function DeleteDepotRepairLabor( _
   ByVal _setupParam_ As DeleteDepotRepairLaborSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult DeleteDepotRepairLabor(
   DeleteDepotRepairLaborSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List


DeleteDepotRepairMaterial Method | fcSDK Documentation

DeleteDepotRepairMaterial Method

Overload List

Overload | Description
DeleteDepotRepairMaterial(Int32) | Delete a Depot Repair Material. This overload takes a set of required parameters for the API.
DeleteDepotRepairMaterial(DeleteDepotRepairMaterialSetup) | Delete a Depot Repair Material. This overload takes a setup object.
DeleteDepotRepairMaterial(DeleteDepotRepairMaterialSetup,IDbTransaction) | Delete a Depot Repair Material. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class DepotRepairToolkit Members DeleteDepotRepairMaterialSetup Class


DeleteDepotRepairMaterial(Int32) Method | fcSDK Documentation

DeleteDepotRepairMaterial(Int32) Method

The objid of the material log object to be deleted

Delete a Depot Repair Material. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function DeleteDepotRepairMaterial( _
   ByVal _materialLogObjid_ As Integer _
) As ToolkitResult

public ToolkitResult DeleteDepotRepairMaterial(
   int _materialLogObjid_
)

Parameters

materialLogObjid

The objid of the material log object to be deleted

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List


DeleteDepotRepairMaterial(DeleteDepotRepairMaterialSetup) Method | fcSDK Documentation

DeleteDepotRepairMaterial(DeleteDepotRepairMaterialSetup) Method

Setup object for API invocation.

Delete a Depot Repair Material. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function DeleteDepotRepairMaterial( _
   ByVal _setupParam_ DeleteDepotRepairMaterialSetup _
) As ToolkitResult

public ToolkitResult DeleteDepotRepairMaterial(
   DeleteDepotRepairMaterialSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List
DeleteDepotRepairMaterialSetup Class


DeleteDepotRepairMaterial(DeleteDepotRepairMaterialSetup,IDbTransaction) Method | fcSDK Documentation

DeleteDepotRepairMaterial(DeleteDepotRepairMaterialSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Delete a Depot Repair Material. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function DeleteDepotRepairMaterial( _
   ByVal _setupParam_ As DeleteDepotRepairMaterialSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult DeleteDepotRepairMaterial(
   DeleteDepotRepairMaterialSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List


DeleteEcoDetail Method | fcSDK Documentation

DeleteEcoDetail Method

Overload List

Overload | Description
DeleteEcoDetail(Int32) | Delete an ECO Detail. This overload takes a set of required parameters for the API.
DeleteEcoDetail(DeleteEcoDetailSetup) | Delete an ECO Detail. This overload takes a setup object.
DeleteEcoDetail(DeleteEcoDetailSetup,IDbTransaction) | Delete an ECO Detail. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class DepotRepairToolkit Members DeleteEcoDetailSetup Class


DeleteEcoDetail(Int32) Method | fcSDK Documentation

DeleteEcoDetail(Int32) Method

The objid of the ECO detail object to be deleted

Delete an ECO Detail. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function DeleteEcoDetail( _
   ByVal _ecoDetailObjid_ As Integer _
) As ToolkitResult

public ToolkitResult DeleteEcoDetail(
   int _ecoDetailObjid_
)

Parameters

ecoDetailObjid

The objid of the ECO detail object to be deleted

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List


DeleteEcoDetail(DeleteEcoDetailSetup) Method | fcSDK Documentation

DeleteEcoDetail(DeleteEcoDetailSetup) Method

Setup object for API invocation.

Delete an ECO Detail. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function DeleteEcoDetail( _
   ByVal _setupParam_ DeleteEcoDetailSetup _
) As ToolkitResult

public ToolkitResult DeleteEcoDetail(
   DeleteEcoDetailSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List
DeleteEcoDetailSetup Class


DeleteEcoDetail(DeleteEcoDetailSetup,IDbTransaction) Method | fcSDK Documentation

DeleteEcoDetail(DeleteEcoDetailSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Delete an ECO Detail. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function DeleteEcoDetail( _
   ByVal _setupParam_ As DeleteEcoDetailSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult DeleteEcoDetail(
   DeleteEcoDetailSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List


DeleteEcoItem Method | fcSDK Documentation

DeleteEcoItem Method

Overload List

Overload | Description
DeleteEcoItem(Int32) | Delete an ECO Item. This overload takes a set of required parameters for the API.
DeleteEcoItem(DeleteEcoItemSetup) | Delete an ECO Item. This overload takes a setup object.
DeleteEcoItem(DeleteEcoItemSetup,IDbTransaction) | Delete an ECO Item. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class DepotRepairToolkit Members DeleteEcoItemSetup Class


DeleteEcoItem(Int32) Method | fcSDK Documentation

DeleteEcoItem(Int32) Method

The objid of the ECO item object to be deleted

Delete an ECO Item. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function DeleteEcoItem( _
   ByVal _ecoItemObjid_ As Integer _
) As ToolkitResult

public ToolkitResult DeleteEcoItem(
   int _ecoItemObjid_
)

Parameters

ecoItemObjid

The objid of the ECO item object to be deleted

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List


DeleteEcoItem(DeleteEcoItemSetup) Method | fcSDK Documentation

DeleteEcoItem(DeleteEcoItemSetup) Method

Setup object for API invocation.

Delete an ECO Item. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function DeleteEcoItem( _
   ByVal _setupParam_ DeleteEcoItemSetup _
) As ToolkitResult

public ToolkitResult DeleteEcoItem(
   DeleteEcoItemSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List
DeleteEcoItemSetup Class


DeleteEcoItem(DeleteEcoItemSetup,IDbTransaction) Method | fcSDK Documentation

DeleteEcoItem(DeleteEcoItemSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Delete an ECO Item. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function DeleteEcoItem( _
   ByVal _setupParam_ As DeleteEcoItemSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult DeleteEcoItem(
   DeleteEcoItemSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List


UpdateDepotRepairLabor Method | fcSDK Documentation

UpdateDepotRepairLabor Method

Overload List

Overload | Description
UpdateDepotRepairLabor(UpdateDepotRepairLaborSetup) | Update a Depot Repair Labor. This overload takes a setup object.
UpdateDepotRepairLabor(UpdateDepotRepairLaborSetup,IDbTransaction) | Update a Depot Repair Labor. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class DepotRepairToolkit Members UpdateDepotRepairLaborSetup Class


UpdateDepotRepairLabor(UpdateDepotRepairLaborSetup) Method | fcSDK Documentation

UpdateDepotRepairLabor(UpdateDepotRepairLaborSetup) Method

Setup object for API invocation.

Update a Depot Repair Labor. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function UpdateDepotRepairLabor( _
   ByVal _setupParam_ UpdateDepotRepairLaborSetup _
) As ToolkitResult

public ToolkitResult UpdateDepotRepairLabor(
   UpdateDepotRepairLaborSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the TimeLog.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List
UpdateDepotRepairLaborSetup Class


UpdateDepotRepairLabor(UpdateDepotRepairLaborSetup,IDbTransaction) Method | fcSDK Documentation

UpdateDepotRepairLabor(UpdateDepotRepairLaborSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Update a Depot Repair Labor. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdateDepotRepairLabor( _
   ByVal _setupParam_ As UpdateDepotRepairLaborSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdateDepotRepairLabor(
   UpdateDepotRepairLaborSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List


UpdateDepotRepairMaterial Method | fcSDK Documentation

UpdateDepotRepairMaterial Method

Overload List

Overload | Description
UpdateDepotRepairMaterial(Int32,RepairPartDisposition) | Update a Depot Repair Material. This overload takes a set of required parameters for the API.
UpdateDepotRepairMaterial(UpdateDepotRepairMaterialSetup) | Update a Depot Repair Material. This overload takes a setup object.
UpdateDepotRepairMaterial(UpdateDepotRepairMaterialSetup,IDbTransaction) | Update a Depot Repair Material. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class DepotRepairToolkit Members UpdateDepotRepairMaterialSetup Class


UpdateDepotRepairMaterial(Int32,RepairPartDisposition) Method | fcSDK Documentation

UpdateDepotRepairMaterial(Int32,RepairPartDisposition) Method

The objid of the material log object to be updated

Indicates how the material relates to the depot repair part.

Update a Depot Repair Material. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function UpdateDepotRepairMaterial( _
   ByVal _materialLogObjid_ As Integer, _
   ByVal _disposition_ As RepairPartDisposition _
) As ToolkitResult

public ToolkitResult UpdateDepotRepairMaterial(
   int _materialLogObjid_,
   RepairPartDisposition _disposition_
)

Parameters

materialLogObjid

The objid of the material log object to be updated

disposition

Indicates how the material relates to the depot repair part.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the MaterialLog.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List


UpdateDepotRepairMaterial(UpdateDepotRepairMaterialSetup) Method | fcSDK Documentation

UpdateDepotRepairMaterial(UpdateDepotRepairMaterialSetup) Method

Setup object for API invocation.

Update a Depot Repair Material. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function UpdateDepotRepairMaterial( _
   ByVal _setupParam_ UpdateDepotRepairMaterialSetup _
) As ToolkitResult

public ToolkitResult UpdateDepotRepairMaterial(
   UpdateDepotRepairMaterialSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the MaterialLog.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List
UpdateDepotRepairMaterialSetup Class


UpdateDepotRepairMaterial(UpdateDepotRepairMaterialSetup,IDbTransaction) Method | fcSDK Documentation

UpdateDepotRepairMaterial(UpdateDepotRepairMaterialSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Update a Depot Repair Material. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdateDepotRepairMaterial( _
   ByVal _setupParam_ As UpdateDepotRepairMaterialSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdateDepotRepairMaterial(
   UpdateDepotRepairMaterialSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List


UpdateEcoItem Method | fcSDK Documentation

UpdateEcoItem Method

Overload List

Overload | Description
UpdateEcoItem(Int32,Boolean,String) | Update an ECO Item. This overload takes a set of required parameters for the API.
UpdateEcoItem(UpdateEcoItemSetup) | Update an ECO Item. This overload takes a setup object.
UpdateEcoItem(UpdateEcoItemSetup,IDbTransaction) | Update an ECO Item. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class DepotRepairToolkit Members UpdateEcoItemSetup Class


UpdateEcoItem(Int32,Boolean,String) Method | fcSDK Documentation

UpdateEcoItem(Int32,Boolean,String) Method

The objid of the ECO item object to be updated

Is the ECO item active (true) or inactive (false)

Identifier of the ECO header

Update an ECO Item. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function UpdateEcoItem( _
   ByVal _ecoItemObjid_ As Integer, _
   ByVal _isActive_ As Boolean, _
   ByVal _ecoHeaderIDNum_ As String _
) As ToolkitResult

public ToolkitResult UpdateEcoItem(
   int _ecoItemObjid_,
   bool _isActive_,
   string _ecoHeaderIDNum_
)

Parameters

ecoItemObjid

The objid of the ECO item object to be updated

isActive

Is the ECO item active (true) or inactive (false)

ecoHeaderIDNum

Identifier of the ECO header

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List


UpdateEcoItem(UpdateEcoItemSetup) Method | fcSDK Documentation

UpdateEcoItem(UpdateEcoItemSetup) Method

Setup object for API invocation.

Update an ECO Item. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function UpdateEcoItem( _
   ByVal _setupParam_ UpdateEcoItemSetup _
) As ToolkitResult

public ToolkitResult UpdateEcoItem(
   UpdateEcoItemSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List
UpdateEcoItemSetup Class


UpdateEcoItem(UpdateEcoItemSetup,IDbTransaction) Method | fcSDK Documentation

UpdateEcoItem(UpdateEcoItemSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Update an ECO Item. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdateEcoItem( _
   ByVal _setupParam_ As UpdateEcoItemSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdateEcoItem(
   UpdateEcoItemSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List


UpdateEcoLaborDetail Method | fcSDK Documentation

UpdateEcoLaborDetail Method

Overload List

Overload | Description
UpdateEcoLaborDetail(UpdateEcoLaborDetailSetup) | Update an ECO Labor Detail. This overload takes a setup object.
UpdateEcoLaborDetail(UpdateEcoLaborDetailSetup,IDbTransaction) | Update an ECO Labor Detail. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class DepotRepairToolkit Members UpdateEcoLaborDetailSetup Class


UpdateEcoLaborDetail(UpdateEcoLaborDetailSetup) Method | fcSDK Documentation

UpdateEcoLaborDetail(UpdateEcoLaborDetailSetup) Method

Setup object for API invocation.

Update an ECO Labor Detail. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function UpdateEcoLaborDetail( _
   ByVal _setupParam_ UpdateEcoLaborDetailSetup _
) As ToolkitResult

public ToolkitResult UpdateEcoLaborDetail(
   UpdateEcoLaborDetailSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List
UpdateEcoLaborDetailSetup Class


UpdateEcoLaborDetail(UpdateEcoLaborDetailSetup,IDbTransaction) Method | fcSDK Documentation

UpdateEcoLaborDetail(UpdateEcoLaborDetailSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Update an ECO Labor Detail. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdateEcoLaborDetail( _
   ByVal _setupParam_ As UpdateEcoLaborDetailSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdateEcoLaborDetail(
   UpdateEcoLaborDetailSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List


UpdateEcoMaterialDetail Method | fcSDK Documentation

UpdateEcoMaterialDetail Method

Update an ECO Material Detail. This overload takes a set of required parameters for the API.

Update an ECO Material Detail.

Overload List

Overload | Description
UpdateEcoMaterialDetail(Int32,Int32) | Update an ECO Material Detail. This overload takes a set of required parameters for the API.
UpdateEcoMaterialDetail(UpdateEcoMaterialDetailSetup) | Update an ECO Material Detail. This overload takes a setup object.
UpdateEcoMaterialDetail(UpdateEcoMaterialDetailSetup,IDbTransaction) | Update an ECO Material Detail. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
UpdateEcoMaterialDetailSetup Class


UpdateEcoMaterialDetail(Int32,Int32) Method | fcSDK Documentation

UpdateEcoMaterialDetail(Int32,Int32) Method

The objid of the ECO detail object to be updated

The objid of the part revision of the material that was put in use.

Update an ECO Material Detail. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function UpdateEcoMaterialDetail( _
   ByVal _ecoDetailObjid_ As Integer, _
   ByVal _partRevisionObjid_ As Integer _
) As ToolkitResult

public ToolkitResult UpdateEcoMaterialDetail(
   int _ecoDetailObjid_,
   int _partRevisionObjid_
)

Parameters

ecoDetailObjid

The objid of the ECO detail object to be updated

partRevisionObjid

The objid of the part revision of the material that was put in use.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List


UpdateEcoMaterialDetail(UpdateEcoMaterialDetailSetup) Method | fcSDK Documentation

UpdateEcoMaterialDetail(UpdateEcoMaterialDetailSetup) Method

Setup object for API invocation.

Update an ECO Material Detail. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function UpdateEcoMaterialDetail( _
   ByVal _setupParam_ UpdateEcoMaterialDetailSetup _
) As ToolkitResult

public ToolkitResult UpdateEcoMaterialDetail(
   UpdateEcoMaterialDetailSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List
UpdateEcoMaterialDetailSetup Class


UpdateEcoMaterialDetail(UpdateEcoMaterialDetailSetup,IDbTransaction) Method | fcSDK Documentation

UpdateEcoMaterialDetail(UpdateEcoMaterialDetailSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Update an ECO Material Detail. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdateEcoMaterialDetail( _
   ByVal _setupParam_ As UpdateEcoMaterialDetailSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdateEcoMaterialDetail(
   UpdateEcoMaterialDetailSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkit Class
DepotRepairToolkit Members
Overload List


DepotRepairToolkitBase Class | fcSDK Documentation

DepotRepairToolkitBase Class

Please see DepotRepairToolkit. This class is used internally and not meant to be created by end users.

Syntax

'Declaration

Public MustInherit Class DepotRepairToolkitBase
   Inherits FChoice.Toolkits.Clarify.ToolkitBase

public abstract class DepotRepairToolkitBase : FChoice.Toolkits.Clarify.ToolkitBase

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.ToolkitBase
FChoice.Toolkits.Clarify.DepotRepair.DepotRepairToolkitBase
FChoice.Toolkits.Clarify.DepotRepair.DepotRepairToolkit

Requirements

Namespace: FChoice.Toolkits.Clarify.DepotRepair

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

DepotRepairToolkitBase Members
FChoice.Toolkits.Clarify.DepotRepair Namespace


DepotRepairToolkitBase Class Members | fcSDK Documentation

DepotRepairToolkitBase Class Members

The following tables list the members exposed by DepotRepairToolkitBase.

Public Properties

 | Name | Description
Public Property | ImpersonatorUsername |

Reference

DepotRepairToolkitBase Class
FChoice.Toolkits.Clarify.DepotRepair Namespace


ImpersonatorUsername Property (DepotRepairToolkitBase) | fcSDK Documentation

ImpersonatorUsername Property (DepotRepairToolkitBase)

Syntax

'Declaration

Public Property ImpersonatorUsername As String

public string ImpersonatorUsername {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DepotRepairToolkitBase Class
DepotRepairToolkitBase Members


UpdateDepotRepairLaborSetup Class | fcSDK Documentation

UpdateDepotRepairLaborSetup Class

Used by the UpdateDepotRepairLabor method as setup data for invocation.

Syntax

'Declaration

Public Class UpdateDepotRepairLaborSetup

public class UpdateDepotRepairLaborSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.DepotRepair.UpdateDepotRepairLaborSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.DepotRepair

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdateDepotRepairLaborSetup Members
FChoice.Toolkits.Clarify.DepotRepair Namespace
UpdateDepotRepairLabor(UpdateDepotRepairLaborSetup) Method


UpdateDepotRepairLaborSetup Class Members | fcSDK Documentation

UpdateDepotRepairLaborSetup Class Members

The following tables list the members exposed by UpdateDepotRepairLaborSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdateDepotRepairLaborSetup Constructor | Initializes a new instance of the UpdateDepotRepairLaborSetup class.

Public Properties

 | Name | Description
Public Property | BillTo | Indicates who is billed for the labor. Will use default if not supplied.
Public Property | CreateDate | The DateTime the Labor entry is updated. If not set, the current time is used.
Public Property | Duration | Length of time required to do the work, in seconds
Public Property | IsBillable | Indicates whether labor is billable.
Public Property | LaborRate | This is the labor rate for the employee performing the labor
Public Property | LaborType | Element from the 'Labor Type' application list. If not set, the default list value is used.
Public Property | StartDate | The DateTime the Labor began. If not set, the current time is used.
Public Property | TimeLogObjid | The objid of the time log object to be updated
Public Property | UserName | The user updating the Labor entry. If not set, the Toolkit session user is used.
Public Property | WorkCenter | Indicates where labor was performed

Reference

UpdateDepotRepairLaborSetup Class
FChoice.Toolkits.Clarify.DepotRepair Namespace
UpdateDepotRepairLabor(UpdateDepotRepairLaborSetup) Method


UpdateDepotRepairLaborSetup Constructor | fcSDK Documentation

UpdateDepotRepairLaborSetup Constructor

The objid of the time log object to be updated

Initializes a new instance of the UpdateDepotRepairLaborSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _timeLogObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public UpdateDepotRepairLaborSetup(
   int _timeLogObjid_
)

Parameters

timeLogObjid

The objid of the time log object to be updated

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateDepotRepairLaborSetup Class
UpdateDepotRepairLaborSetup Members


BillTo Property (UpdateDepotRepairLaborSetup) | fcSDK Documentation

BillTo Property (UpdateDepotRepairLaborSetup)

Indicates who is billed for the labor. Will use default if not supplied.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property BillTo As String

[PropertyBitValueAttribute()]
public string BillTo {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateDepotRepairLaborSetup Class
UpdateDepotRepairLaborSetup Members


CreateDate Property (UpdateDepotRepairLaborSetup) | fcSDK Documentation

CreateDate Property (UpdateDepotRepairLaborSetup)

The DateTime the Labor entry is updated. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateDepotRepairLaborSetup Class
UpdateDepotRepairLaborSetup Members


Duration Property (UpdateDepotRepairLaborSetup) | fcSDK Documentation

Duration Property (UpdateDepotRepairLaborSetup)

Length of time required to do the work, in seconds

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Duration As TimeSpan

[PropertyBitValueAttribute()]
public TimeSpan Duration {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateDepotRepairLaborSetup Class
UpdateDepotRepairLaborSetup Members


IsBillable Property (UpdateDepotRepairLaborSetup) | fcSDK Documentation

IsBillable Property (UpdateDepotRepairLaborSetup)

Indicates whether labor is billable.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsBillable As Boolean

[PropertyBitValueAttribute()]
public bool IsBillable {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateDepotRepairLaborSetup Class
UpdateDepotRepairLaborSetup Members


LaborRate Property (UpdateDepotRepairLaborSetup) | fcSDK Documentation

LaborRate Property (UpdateDepotRepairLaborSetup)

This is the labor rate for the employee performing the labor

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LaborRate As Double

[PropertyBitValueAttribute()]
public double LaborRate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateDepotRepairLaborSetup Class
UpdateDepotRepairLaborSetup Members


LaborType Property (UpdateDepotRepairLaborSetup) | fcSDK Documentation

LaborType Property (UpdateDepotRepairLaborSetup)

Element from the 'Labor Type' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LaborType As String

[PropertyBitValueAttribute()]
public string LaborType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateDepotRepairLaborSetup Class
UpdateDepotRepairLaborSetup Members


StartDate Property (UpdateDepotRepairLaborSetup) | fcSDK Documentation

StartDate Property (UpdateDepotRepairLaborSetup)

The DateTime the Labor began. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property StartDate As Date

[PropertyBitValueAttribute()]
public DateTime StartDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateDepotRepairLaborSetup Class
UpdateDepotRepairLaborSetup Members


TimeLogObjid Property (UpdateDepotRepairLaborSetup) | fcSDK Documentation

TimeLogObjid Property (UpdateDepotRepairLaborSetup)

The objid of the time log object to be updated

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property TimeLogObjid As Integer

[PropertyBitValueAttribute()]
public int TimeLogObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateDepotRepairLaborSetup Class
UpdateDepotRepairLaborSetup Members


UserName Property (UpdateDepotRepairLaborSetup) | fcSDK Documentation

UserName Property (UpdateDepotRepairLaborSetup)

The user updating the Labor entry. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateDepotRepairLaborSetup Class
UpdateDepotRepairLaborSetup Members


WorkCenter Property (UpdateDepotRepairLaborSetup) | fcSDK Documentation

WorkCenter Property (UpdateDepotRepairLaborSetup)

Indicates where labor was performed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WorkCenter As String

[PropertyBitValueAttribute()]
public string WorkCenter {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateDepotRepairLaborSetup Class
UpdateDepotRepairLaborSetup Members


UpdateDepotRepairMaterialSetup Class | fcSDK Documentation

UpdateDepotRepairMaterialSetup Class

Used by the UpdateDepotRepairMaterial method as setup data for invocation.

Syntax

'Declaration

Public Class UpdateDepotRepairMaterialSetup

public class UpdateDepotRepairMaterialSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.DepotRepair.UpdateDepotRepairMaterialSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.DepotRepair

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdateDepotRepairMaterialSetup Members
FChoice.Toolkits.Clarify.DepotRepair Namespace
UpdateDepotRepairMaterial(UpdateDepotRepairMaterialSetup) Method


UpdateDepotRepairMaterialSetup Class Members | fcSDK Documentation

UpdateDepotRepairMaterialSetup Class Members

The following tables list the members exposed by UpdateDepotRepairMaterialSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdateDepotRepairMaterialSetup Constructor | Initializes a new instance of the UpdateDepotRepairMaterialSetup class.

Public Properties

 | Name | Description
Public Property | BillTo | Indicates who is billed for the material. Will use default if not supplied.
Public Property | CreateDate | The DateTime the Material entry is updated. If not set the current time is used.
Public Property | Disposition | Indicates how the material relates to the depot repair part.
Public Property | FailureCode | Element from the 'Failure Code' application list. If not set, the default list value is used.
Public Property | IsBillable | Indicates whether material is billable.
Public Property | MaterialLogObjid | The objid of the material log object to be updated
Public Property | Notes | Description area for the material usage activity.
Public Property | PartRevisionObjid | The objid of the part revision of the material that was put in use.
Public Property | ReferenceDesignator | Describes a reference location or designation for the part.
Public Property | RepairCode | Element from the 'Repair Type' application list. If not set, the default list value is used.
Public Property | TransactionID | Indicates the id of the GL transaction associated with this material usage
Public Property | UserName | The user updating the Material entry. If not set, the Toolkit session user is used.
Public Property | WorkCenter | Indicates where material was used

Reference

UpdateDepotRepairMaterialSetup Class
FChoice.Toolkits.Clarify.DepotRepair Namespace
UpdateDepotRepairMaterial(UpdateDepotRepairMaterialSetup) Method


UpdateDepotRepairMaterialSetup Constructor | fcSDK Documentation

UpdateDepotRepairMaterialSetup Constructor

The objid of the material log object to be updated

Indicates how the material relates to the depot repair part.

Initializes a new instance of the UpdateDepotRepairMaterialSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _materialLogObjid_ As Integer, _
   ByVal _disposition_ As RepairPartDisposition _
)

[ConstructorIndexAttribute()]
public UpdateDepotRepairMaterialSetup(
   int _materialLogObjid_,
   RepairPartDisposition _disposition_
)

Parameters

materialLogObjid

The objid of the material log object to be updated

disposition

Indicates how the material relates to the depot repair part.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateDepotRepairMaterialSetup Class
UpdateDepotRepairMaterialSetup Members


BillTo Property (UpdateDepotRepairMaterialSetup) | fcSDK Documentation

BillTo Property (UpdateDepotRepairMaterialSetup)

Indicates who is billed for the material. Will use default if not supplied.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property BillTo As String

[PropertyBitValueAttribute()]
public string BillTo {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateDepotRepairMaterialSetup Class
UpdateDepotRepairMaterialSetup Members


CreateDate Property (UpdateDepotRepairMaterialSetup) | fcSDK Documentation

CreateDate Property (UpdateDepotRepairMaterialSetup)

The DateTime the Material entry is updated. If not set the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateDepotRepairMaterialSetup Class
UpdateDepotRepairMaterialSetup Members


Disposition Property (UpdateDepotRepairMaterialSetup) | fcSDK Documentation

Disposition Property (UpdateDepotRepairMaterialSetup)

Indicates how the material relates to the depot repair part.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Disposition As RepairPartDisposition

[PropertyBitValueAttribute()]
public RepairPartDisposition Disposition {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateDepotRepairMaterialSetup Class
UpdateDepotRepairMaterialSetup Members


FailureCode Property (UpdateDepotRepairMaterialSetup) | fcSDK Documentation

FailureCode Property (UpdateDepotRepairMaterialSetup)

Element from the 'Failure Code' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FailureCode As String

[PropertyBitValueAttribute()]
public string FailureCode {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateDepotRepairMaterialSetup Class
UpdateDepotRepairMaterialSetup Members


IsBillable Property (UpdateDepotRepairMaterialSetup) | fcSDK Documentation

IsBillable Property (UpdateDepotRepairMaterialSetup)

Indicates whether material is billable.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsBillable As Boolean

[PropertyBitValueAttribute()]
public bool IsBillable {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateDepotRepairMaterialSetup Class
UpdateDepotRepairMaterialSetup Members


MaterialLogObjid Property (UpdateDepotRepairMaterialSetup) | fcSDK Documentation

MaterialLogObjid Property (UpdateDepotRepairMaterialSetup)

The objid of the material log object to be updated

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property MaterialLogObjid As Integer

[PropertyBitValueAttribute()]
public int MaterialLogObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateDepotRepairMaterialSetup Class
UpdateDepotRepairMaterialSetup Members


Notes Property (UpdateDepotRepairMaterialSetup) | fcSDK Documentation

Notes Property (UpdateDepotRepairMaterialSetup)

Description area for the material usage activity.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateDepotRepairMaterialSetup Class
UpdateDepotRepairMaterialSetup Members


PartRevisionObjid Property (UpdateDepotRepairMaterialSetup) | fcSDK Documentation

PartRevisionObjid Property (UpdateDepotRepairMaterialSetup)

The objid of the part revision of the material that was put in use.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRevisionObjid As Integer

[PropertyBitValueAttribute()]
public int PartRevisionObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateDepotRepairMaterialSetup Class
UpdateDepotRepairMaterialSetup Members


ReferenceDesignator Property (UpdateDepotRepairMaterialSetup) | fcSDK Documentation

ReferenceDesignator Property (UpdateDepotRepairMaterialSetup)

Describes a reference location or designation for the part.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ReferenceDesignator As String

[PropertyBitValueAttribute()]
public string ReferenceDesignator {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateDepotRepairMaterialSetup Class
UpdateDepotRepairMaterialSetup Members


RepairCode Property (UpdateDepotRepairMaterialSetup) | fcSDK Documentation

RepairCode Property (UpdateDepotRepairMaterialSetup)

Element from the 'Repair Type' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property RepairCode As String

[PropertyBitValueAttribute()]
public string RepairCode {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateDepotRepairMaterialSetup Class
UpdateDepotRepairMaterialSetup Members


TransactionID Property (UpdateDepotRepairMaterialSetup) | fcSDK Documentation

TransactionID Property (UpdateDepotRepairMaterialSetup)

Indicates the id of the GL transaction associated with this material usage

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property TransactionID As String

[PropertyBitValueAttribute()]
public string TransactionID {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateDepotRepairMaterialSetup Class
UpdateDepotRepairMaterialSetup Members


UserName Property (UpdateDepotRepairMaterialSetup) | fcSDK Documentation

UserName Property (UpdateDepotRepairMaterialSetup)

The user updating the Material entry. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateDepotRepairMaterialSetup Class
UpdateDepotRepairMaterialSetup Members


WorkCenter Property (UpdateDepotRepairMaterialSetup) | fcSDK Documentation

WorkCenter Property (UpdateDepotRepairMaterialSetup)

Indicates where material was used

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WorkCenter As String

[PropertyBitValueAttribute()]
public string WorkCenter {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateDepotRepairMaterialSetup Class
UpdateDepotRepairMaterialSetup Members


UpdateEcoItemSetup Class | fcSDK Documentation

UpdateEcoItemSetup Class

Used by the UpdateEcoItem method as setup data for invocation.

Syntax

'Declaration

Public Class UpdateEcoItemSetup

public class UpdateEcoItemSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.DepotRepair.UpdateEcoItemSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.DepotRepair

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdateEcoItemSetup Members
FChoice.Toolkits.Clarify.DepotRepair Namespace
UpdateEcoItem(UpdateEcoItemSetup) Method


UpdateEcoItemSetup Class Members | fcSDK Documentation

UpdateEcoItemSetup Class Members

The following tables list the members exposed by UpdateEcoItemSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdateEcoItemSetup Constructor | Initializes a new instance of the UpdateEcoItemSetup class.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AppliesTo | This must be either 5148 to apply the ECO item to an ECO header, or 329 to apply the ECO item to a part revision.

| | Public Property | ApplyPartRevisionObjid | The objid of part revision affected by the ECO, or 0 for no change. | | Public Property | EcoHeaderIDNum | Identifier of the ECO header | | Public Property | EcoItemObjid | The objid of the ECO item object to be updated | | Public Property | IsActive | Is the ECO item active (true) or inactive (false) | | Public Property | ResultPartRevisionObjid | The objid of resulting part revision after applying the ECO, or 0 for no change. |

Reference

UpdateEcoItemSetup Class
FChoice.Toolkits.Clarify.DepotRepair Namespace
UpdateEcoItem(UpdateEcoItemSetup) Method


UpdateEcoItemSetup Constructor | fcSDK Documentation

UpdateEcoItemSetup Constructor

The objid of the ECO item object to be updated

Is the ECO item active (true) or inactive (false)

Identifier of the ECO header

Initializes a new instance of the UpdateEcoItemSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _ecoItemObjid_ As Integer, _
   ByVal _isActive_ As Boolean, _
   ByVal _ecoHeaderIDNum_ As String _
)

[ConstructorIndexAttribute()]
public UpdateEcoItemSetup(
   int _ecoItemObjid_,
   bool _isActive_,
   string _ecoHeaderIDNum_
)

Parameters

ecoItemObjid

The objid of the ECO item object to be updated

isActive

Is the ECO item active (true) or inactive (false)

ecoHeaderIDNum

Identifier of the ECO header

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateEcoItemSetup Class
UpdateEcoItemSetup Members


AppliesTo Property (UpdateEcoItemSetup) | fcSDK Documentation

AppliesTo Property (UpdateEcoItemSetup)

This must be either 5148 to apply the ECO item to an ECO header, or 329 to apply the ECO item to a part revision.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AppliesTo As EcoItemAppliesTo

[PropertyBitValueAttribute()]
public EcoItemAppliesTo AppliesTo {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateEcoItemSetup Class
UpdateEcoItemSetup Members


ApplyPartRevisionObjid Property (UpdateEcoItemSetup) | fcSDK Documentation

ApplyPartRevisionObjid Property (UpdateEcoItemSetup)

The objid of part revision affected by the ECO, or 0 for no change.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ApplyPartRevisionObjid As Integer

[PropertyBitValueAttribute()]
public int ApplyPartRevisionObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateEcoItemSetup Class
UpdateEcoItemSetup Members


EcoHeaderIDNum Property (UpdateEcoItemSetup) | fcSDK Documentation

EcoHeaderIDNum Property (UpdateEcoItemSetup)

Identifier of the ECO header

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property EcoHeaderIDNum As String

[PropertyBitValueAttribute()]
public string EcoHeaderIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateEcoItemSetup Class
UpdateEcoItemSetup Members


EcoItemObjid Property (UpdateEcoItemSetup) | fcSDK Documentation

EcoItemObjid Property (UpdateEcoItemSetup)

The objid of the ECO item object to be updated

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property EcoItemObjid As Integer

[PropertyBitValueAttribute()]
public int EcoItemObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateEcoItemSetup Class
UpdateEcoItemSetup Members


IsActive Property (UpdateEcoItemSetup) | fcSDK Documentation

IsActive Property (UpdateEcoItemSetup)

Is the ECO item active (true) or inactive (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsActive As Boolean

[PropertyBitValueAttribute()]
public bool IsActive {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateEcoItemSetup Class
UpdateEcoItemSetup Members


ResultPartRevisionObjid Property (UpdateEcoItemSetup) | fcSDK Documentation

ResultPartRevisionObjid Property (UpdateEcoItemSetup)

The objid of resulting part revision after applying the ECO, or 0 for no change.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ResultPartRevisionObjid As Integer

[PropertyBitValueAttribute()]
public int ResultPartRevisionObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateEcoItemSetup Class
UpdateEcoItemSetup Members


UpdateEcoLaborDetailSetup Class | fcSDK Documentation

UpdateEcoLaborDetailSetup Class

Used by the UpdateEcoLaborDetail method as setup data for invocation.

Syntax

'Declaration

Public Class UpdateEcoLaborDetailSetup

public class UpdateEcoLaborDetailSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.DepotRepair.UpdateEcoLaborDetailSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.DepotRepair

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdateEcoLaborDetailSetup Members
FChoice.Toolkits.Clarify.DepotRepair Namespace
UpdateEcoLaborDetail(UpdateEcoLaborDetailSetup) Method


UpdateEcoLaborDetailSetup Class Members | fcSDK Documentation

UpdateEcoLaborDetailSetup Class Members

The following tables list the members exposed by UpdateEcoLaborDetailSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdateEcoLaborDetailSetup Constructor | Initializes a new instance of the UpdateEcoLaborDetailSetup class.

Public Properties

 | Name | Description
Public Property | Description | Description of the ECO labor detail
Public Property | EcoDetailObjid | The objid of the ECO detail object to be updated
Public Property | EcoHeaderIDNum | Identifier of the ECO header
Public Property | ElapsedTime | Estimated amount of time, in seconds, required to perform the work.
Public Property | IsRequired | Indicates if this detail is required (true) or not (false)
Public Property | LaborType | Element from the 'Labor Type' application list. If not set, the default list value is used.
Public Property | Status | Element from the 'ECO Status' application list. If not set, the default list value is used.

Reference

UpdateEcoLaborDetailSetup Class
FChoice.Toolkits.Clarify.DepotRepair Namespace
UpdateEcoLaborDetail(UpdateEcoLaborDetailSetup) Method


UpdateEcoLaborDetailSetup Constructor | fcSDK Documentation

UpdateEcoLaborDetailSetup Constructor

The objid of the ECO detail object to be updated

Initializes a new instance of the UpdateEcoLaborDetailSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _ecoDetailObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public UpdateEcoLaborDetailSetup(
   int _ecoDetailObjid_
)

Parameters

ecoDetailObjid

The objid of the ECO detail object to be updated

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateEcoLaborDetailSetup Class
UpdateEcoLaborDetailSetup Members


Description Property (UpdateEcoLaborDetailSetup) | fcSDK Documentation

Description Property (UpdateEcoLaborDetailSetup)

Description of the ECO labor detail

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Description As String

[PropertyBitValueAttribute()]
public string Description {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateEcoLaborDetailSetup Class
UpdateEcoLaborDetailSetup Members


EcoDetailObjid Property (UpdateEcoLaborDetailSetup) | fcSDK Documentation

EcoDetailObjid Property (UpdateEcoLaborDetailSetup)

The objid of the ECO detail object to be updated

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property EcoDetailObjid As Integer

[PropertyBitValueAttribute()]
public int EcoDetailObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateEcoLaborDetailSetup Class
UpdateEcoLaborDetailSetup Members


EcoHeaderIDNum Property (UpdateEcoLaborDetailSetup) | fcSDK Documentation

EcoHeaderIDNum Property (UpdateEcoLaborDetailSetup)

Identifier of the ECO header

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property EcoHeaderIDNum As String

[PropertyBitValueAttribute()]
public string EcoHeaderIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateEcoLaborDetailSetup Class
UpdateEcoLaborDetailSetup Members


ElapsedTime Property (UpdateEcoLaborDetailSetup) | fcSDK Documentation

ElapsedTime Property (UpdateEcoLaborDetailSetup)

Estimated amount of time, in seconds, required to perform the work.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ElapsedTime As TimeSpan

[PropertyBitValueAttribute()]
public TimeSpan ElapsedTime {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateEcoLaborDetailSetup Class
UpdateEcoLaborDetailSetup Members


IsRequired Property (UpdateEcoLaborDetailSetup) | fcSDK Documentation

IsRequired Property (UpdateEcoLaborDetailSetup)

Indicates if this detail is required (true) or not (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsRequired As Boolean

[PropertyBitValueAttribute()]
public bool IsRequired {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateEcoLaborDetailSetup Class
UpdateEcoLaborDetailSetup Members


LaborType Property (UpdateEcoLaborDetailSetup) | fcSDK Documentation

LaborType Property (UpdateEcoLaborDetailSetup)

Element from the 'Labor Type' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LaborType As String

[PropertyBitValueAttribute()]
public string LaborType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateEcoLaborDetailSetup Class
UpdateEcoLaborDetailSetup Members


Status Property (UpdateEcoLaborDetailSetup) | fcSDK Documentation

Status Property (UpdateEcoLaborDetailSetup)

Element from the 'ECO Status' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Status As String

[PropertyBitValueAttribute()]
public string Status {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateEcoLaborDetailSetup Class
UpdateEcoLaborDetailSetup Members


UpdateEcoMaterialDetailSetup Class | fcSDK Documentation

UpdateEcoMaterialDetailSetup Class

Used by the UpdateEcoMaterialDetail method as setup data for invocation.

Syntax

'Declaration

Public Class UpdateEcoMaterialDetailSetup

public class UpdateEcoMaterialDetailSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.DepotRepair.UpdateEcoMaterialDetailSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.DepotRepair

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdateEcoMaterialDetailSetup Members
FChoice.Toolkits.Clarify.DepotRepair Namespace
UpdateEcoMaterialDetail(UpdateEcoMaterialDetailSetup) Method


UpdateEcoMaterialDetailSetup Class Members | fcSDK Documentation

UpdateEcoMaterialDetailSetup Class Members

The following tables list the members exposed by UpdateEcoMaterialDetailSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdateEcoMaterialDetailSetup Constructor | Initializes a new instance of the UpdateEcoMaterialDetailSetup class.

Public Properties

 | Name | Description
Public Property | Description | Description of the ECO material detail
Public Property | EcoDetailObjid | The objid of the ECO detail object to be updated
Public Property | EcoHeaderIDNum | Identifier of the ECO header
Public Property | ElapsedTime | Estimated amount of time required to perform the work in seconds.
Public Property | IsRequired | Indicates if this detail is required (true) or not (false)
Public Property | Location | Indicates the location where the material belongs.
Public Property | PartRevisionObjid | The objid of the part revision of the material that was put in use.
Public Property | Status | Element from the 'ECO Status' application list. If not set, the default list value is used.

Reference

UpdateEcoMaterialDetailSetup Class
FChoice.Toolkits.Clarify.DepotRepair Namespace
UpdateEcoMaterialDetail(UpdateEcoMaterialDetailSetup) Method


UpdateEcoMaterialDetailSetup Constructor | fcSDK Documentation

UpdateEcoMaterialDetailSetup Constructor

The objid of the ECO detail object to be updated

The objid of the part revision of the material that was put in use.

Initializes a new instance of the UpdateEcoMaterialDetailSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _ecoDetailObjid_ As Integer, _
   ByVal _partRevisionObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public UpdateEcoMaterialDetailSetup(
   int _ecoDetailObjid_,
   int _partRevisionObjid_
)

Parameters

ecoDetailObjid

The objid of the ECO detail object to be updated

partRevisionObjid

The objid of the part revision of the material that was put in use.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateEcoMaterialDetailSetup Class
UpdateEcoMaterialDetailSetup Members


Description Property (UpdateEcoMaterialDetailSetup) | fcSDK Documentation

Description Property (UpdateEcoMaterialDetailSetup)

Description of the ECO material detail

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Description As String

[PropertyBitValueAttribute()]
public string Description {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateEcoMaterialDetailSetup Class
UpdateEcoMaterialDetailSetup Members


EcoDetailObjid Property (UpdateEcoMaterialDetailSetup) | fcSDK Documentation

EcoDetailObjid Property (UpdateEcoMaterialDetailSetup)

The objid of the ECO detail object to be updated

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property EcoDetailObjid As Integer

[PropertyBitValueAttribute()]
public int EcoDetailObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateEcoMaterialDetailSetup Class
UpdateEcoMaterialDetailSetup Members


EcoHeaderIDNum Property (UpdateEcoMaterialDetailSetup) | fcSDK Documentation

EcoHeaderIDNum Property (UpdateEcoMaterialDetailSetup)

Identifier of the ECO header

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property EcoHeaderIDNum As String

[PropertyBitValueAttribute()]
public string EcoHeaderIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateEcoMaterialDetailSetup Class
UpdateEcoMaterialDetailSetup Members


ElapsedTime Property (UpdateEcoMaterialDetailSetup) | fcSDK Documentation

ElapsedTime Property (UpdateEcoMaterialDetailSetup)

Estimated amount of time required to perform the work in seconds.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ElapsedTime As TimeSpan

[PropertyBitValueAttribute()]
public TimeSpan ElapsedTime {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateEcoMaterialDetailSetup Class
UpdateEcoMaterialDetailSetup Members


IsRequired Property (UpdateEcoMaterialDetailSetup) | fcSDK Documentation

IsRequired Property (UpdateEcoMaterialDetailSetup)

Indicates if this detail is required (true) or not (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsRequired As Boolean

[PropertyBitValueAttribute()]
public bool IsRequired {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateEcoMaterialDetailSetup Class
UpdateEcoMaterialDetailSetup Members


Location Property (UpdateEcoMaterialDetailSetup) | fcSDK Documentation

Location Property (UpdateEcoMaterialDetailSetup)

Indicates the location where the material belongs.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Location As String

[PropertyBitValueAttribute()]
public string Location {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateEcoMaterialDetailSetup Class
UpdateEcoMaterialDetailSetup Members


PartRevisionObjid Property (UpdateEcoMaterialDetailSetup) | fcSDK Documentation

PartRevisionObjid Property (UpdateEcoMaterialDetailSetup)

The objid of the part revision of the material that was put in use.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRevisionObjid As Integer

[PropertyBitValueAttribute()]
public int PartRevisionObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateEcoMaterialDetailSetup Class
UpdateEcoMaterialDetailSetup Members


Status Property (UpdateEcoMaterialDetailSetup) | fcSDK Documentation

Status Property (UpdateEcoMaterialDetailSetup)

Element from the 'ECO Status' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Status As String

[PropertyBitValueAttribute()]
public string Status {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateEcoMaterialDetailSetup Class
UpdateEcoMaterialDetailSetup Members


FChoice.Toolkits.Clarify.FieldOps Namespace | fcSDK Documentation

FChoice.Toolkits.Clarify.FieldOps Namespace

Provides APIs to allow you to modify Logistics Field Operations objects such as Time and Expense Logs, Dispatch Field Engineer Request, and Log Parts Used. Methods on the FieldOpsToolkit object allow you to create, modify, and delete time, expense, and on-site logs, handle Dispatch FE records, fully use the Log Parts Used functionality (including installing/deinstalling/moving site_parts, and affecting inventory), schedule appointments, and more.

Classes

 | Class | Description
Class | AddServiceInterruptionResult | Result from the AddServiceInterruption API.
Class | AddServiceInterruptionSetup | Used by the AddServiceInterruption method as setup data for invocation.
Class | CreateAppointmentResult | Result from the CreateAppointment API.
Class | CreateAppointmentSetup | Used by the CreateAppointment method as setup data for invocation.
Class | CreateExpenseLogResult | Result from the CreateExpenseLog API.
Class | CreateExpenseLogSetup | Used by the CreateExpenseLog method as setup data for invocation.
Class | CreateOnsiteLogSetup | Used by the CreateOnsiteLog method as setup data for invocation.
Class | CreateTimeLogResult | Result from the CreateTimeLog API.
Class | CreateTimeLogSetup | Used by the CreateTimeLog method as setup data for invocation.
Class | DeinstallSitePartSetup | Used by the DeinstallSitePart method as setup data for invocation.
Class | DeleteAppointmentSetup | Used by the DeleteAppointment method as setup data for invocation.
Class | DeleteExpenseLogSetup | Used by the DeleteExpenseLog method as setup data for invocation.
Class | DeleteOnsiteLogSetup | Used by the DeleteOnsiteLog method as setup data for invocation.
Class | DeleteServiceInterruptionSetup | Used by the DeleteServiceInterruption method as setup data for invocation.
Class | DeleteTimeLogSetup | Used by the DeleteTimeLog method as setup data for invocation.
Class | DispatchFieldEngineerSetup | Used by the DispatchFieldEngineer method as setup data for invocation.
Class | FieldOpsToolkit | Provides APIs to allow you to modify Logistics Field Operations objects such as Time and Expense Logs, Dispatch Field Engineer Request, and Log Parts Used. For example, you can create, modify, and delete time, expense, and on-site logs, handle Dispatch FE records, fully use the Log Parts Used functionality (including installing/deinstalling/moving site_parts, and affecting inventory), schedule appointments, and more.
Class | FieldOpsToolkitBase | This class is intended for internal use by the FieldOpsToolkit.
Class | InstallSitePartSetup | Used by the InstallSitePart method as setup data for invocation.
Class | LogPartsUsedConsumeSetup | Used by the LogPartsUsedConsume method as setup data for invocation.
Class | LogPartsUsedExchangeSetup | Used by the LogPartsUsedExchange method as setup data for invocation.
Class | LogPartsUsedInstallSetup | Used by the LogPartsUsedInstall method as setup data for invocation.
Class | LogPartsUsedRemoveSetup | Used by the LogPartsUsedRemove method as setup data for invocation.
Class | LogPartsUsedUpgradeSetup | Used by the LogPartsUsedUpgrade method as setup data for invocation.
Class | MoveSitePartToBinSetup | Used by the MoveSitePartToBin method as setup data for invocation.
Class | MoveSitePartToPartSetup | Used by the MoveSitePartToPart method as setup data for invocation.
Class | MoveSitePartToSiteSetup | Used by the MoveSitePartToSite method as setup data for invocation.
Class | PartTransferResult | Result from the PartTransfer API.
Class | PartTransferSetup | Used by the PartTransfer method as setup data for invocation.
Class | ReinstallSitePartSetup | Used by the ReinstallSitePart method as setup data for invocation.
Class | StageInventoryToolkit |
Class | UpdateAppointmentSetup | Used by the UpdateAppointment method as setup data for invocation.
Class | UpdateExpenseLogSetup | Used by the UpdateExpenseLog method as setup data for invocation.
Class | UpdateServiceInterruptionSetup | Used by the UpdateServiceInterruption method as setup data for invocation.
Class | UpdateSitePartSetup | Used by the UpdateSitePart method as setup data for invocation.
Class | UpdateTimeLogSetup | Used by the UpdateTimeLog method as setup data for invocation.

Reference

FChoice.Toolkits.Clarify Assembly


AddServiceInterruptionResult Class | fcSDK Documentation

AddServiceInterruptionResult Class

Result from the AddServiceInterruption API.

Syntax

'Declaration

Public Class AddServiceInterruptionResult
   Inherits FChoice.Toolkits.Clarify.ToolkitResult

public class AddServiceInterruptionResult : FChoice.Toolkits.Clarify.ToolkitResult

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.ToolkitResult
FChoice.Toolkits.Clarify.FieldOps.AddServiceInterruptionResult

Requirements

Namespace: FChoice.Toolkits.Clarify.FieldOps

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

AddServiceInterruptionResult Members
FChoice.Toolkits.Clarify.FieldOps Namespace


AddServiceInterruptionResult Class Members | fcSDK Documentation

AddServiceInterruptionResult Class Members

The following tables list the members exposed by AddServiceInterruptionResult.

Public Constructors

 | Name | Description
Public Constructor | AddServiceInterruptionResult Constructor |

Public Properties

 | Name | Description
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ScheduleObjid | The Objid of the Schedule.

Reference

AddServiceInterruptionResult Class
FChoice.Toolkits.Clarify.FieldOps Namespace


AddServiceInterruptionResult Constructor | fcSDK Documentation

AddServiceInterruptionResult Constructor

Syntax

'Declaration

Public Function New()

public AddServiceInterruptionResult()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddServiceInterruptionResult Class
AddServiceInterruptionResult Members


ScheduleObjid Property (AddServiceInterruptionResult) | fcSDK Documentation

ScheduleObjid Property (AddServiceInterruptionResult)

The Objid of the Schedule.

Syntax

'Declaration

Public Property ScheduleObjid As Integer

public int ScheduleObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddServiceInterruptionResult Class
AddServiceInterruptionResult Members


AddServiceInterruptionSetup Class | fcSDK Documentation

AddServiceInterruptionSetup Class

Used by the AddServiceInterruption method as setup data for invocation.

Syntax

'Declaration

Public Class AddServiceInterruptionSetup

public class AddServiceInterruptionSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.FieldOps.AddServiceInterruptionSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.FieldOps

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

AddServiceInterruptionSetup Members
FChoice.Toolkits.Clarify.FieldOps Namespace
AddServiceInterruption(AddServiceInterruptionSetup) Method


AddServiceInterruptionSetup Class Members | fcSDK Documentation

AddServiceInterruptionSetup Class Members

The following tables list the members exposed by AddServiceInterruptionSetup.

Public Constructors

 | Name | Description
Public Constructor | AddServiceInterruptionSetup Constructor | Initializes a new instance of the AddServiceInterruptionSetup class.

Public Properties

 | Name | Description
Public Property | CaseIDNum | The identifier of the Case with which this Service Interuption is associated
Public Property | CreateDate | The DateTime the Service Interput was created. If not set, the current time is used.
Public Property | Description | The description of the Service Interuption.
Public Property | Duration | The length (in seconds) of the Service Interuption. If not specified, it is calculated from the start and end times.
Public Property | EndDate | The DateTime the Service Interuption ends. If not set, the start time and duration is used to calculate the end time.
Public Property | ServiceClass | Element from the 'Installed Prod Sched Class' application list. If not set the default list value is used.
Public Property | ServiceType | Element from the 'Employee Sched Type' application list. If not set the default list value is used.
Public Property | SitePartObjid | The Objid of the Site Part if a part is being serviced.
Public Property | StartDate | The DateTime the Service Interuption starts. If not set, the current time is used.
Public Property | UserName | The user who is adding the Service Interuption. If not set, the session user is used.

Reference

AddServiceInterruptionSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
AddServiceInterruption(AddServiceInterruptionSetup) Method


AddServiceInterruptionSetup Constructor | fcSDK Documentation

AddServiceInterruptionSetup Constructor

The identifier of the Case with which this Service Interuption is associated

Initializes a new instance of the AddServiceInterruptionSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _caseIDNum_ As String _
)

[ConstructorIndexAttribute()]
public AddServiceInterruptionSetup(
   string _caseIDNum_
)

Parameters

caseIDNum

The identifier of the Case with which this Service Interuption is associated

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddServiceInterruptionSetup Class
AddServiceInterruptionSetup Members


CaseIDNum Property (AddServiceInterruptionSetup) | fcSDK Documentation

CaseIDNum Property (AddServiceInterruptionSetup)

The identifier of the Case with which this Service Interuption is associated

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddServiceInterruptionSetup Class
AddServiceInterruptionSetup Members


CreateDate Property (AddServiceInterruptionSetup) | fcSDK Documentation

CreateDate Property (AddServiceInterruptionSetup)

The DateTime the Service Interput was created. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddServiceInterruptionSetup Class
AddServiceInterruptionSetup Members


Description Property (AddServiceInterruptionSetup) | fcSDK Documentation

Description Property (AddServiceInterruptionSetup)

The description of the Service Interuption.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Description As String

[PropertyBitValueAttribute()]
public string Description {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddServiceInterruptionSetup Class
AddServiceInterruptionSetup Members


Duration Property (AddServiceInterruptionSetup) | fcSDK Documentation

Duration Property (AddServiceInterruptionSetup)

The length (in seconds) of the Service Interuption. If not specified, it is calculated from the start and end times.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Duration As TimeSpan

[PropertyBitValueAttribute()]
public TimeSpan Duration {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddServiceInterruptionSetup Class
AddServiceInterruptionSetup Members


EndDate Property (AddServiceInterruptionSetup) | fcSDK Documentation

EndDate Property (AddServiceInterruptionSetup)

The DateTime the Service Interuption ends. If not set, the start time and duration is used to calculate the end time.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property EndDate As Date

[PropertyBitValueAttribute()]
public DateTime EndDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddServiceInterruptionSetup Class
AddServiceInterruptionSetup Members


ServiceClass Property (AddServiceInterruptionSetup) | fcSDK Documentation

ServiceClass Property (AddServiceInterruptionSetup)

Element from the 'Installed Prod Sched Class' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ServiceClass As String

[PropertyBitValueAttribute()]
public string ServiceClass {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddServiceInterruptionSetup Class
AddServiceInterruptionSetup Members


ServiceType Property (AddServiceInterruptionSetup) | fcSDK Documentation

ServiceType Property (AddServiceInterruptionSetup)

Element from the 'Employee Sched Type' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ServiceType As String

[PropertyBitValueAttribute()]
public string ServiceType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddServiceInterruptionSetup Class
AddServiceInterruptionSetup Members


SitePartObjid Property (AddServiceInterruptionSetup) | fcSDK Documentation

SitePartObjid Property (AddServiceInterruptionSetup)

The Objid of the Site Part if a part is being serviced.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SitePartObjid As Integer

[PropertyBitValueAttribute()]
public int SitePartObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddServiceInterruptionSetup Class
AddServiceInterruptionSetup Members


StartDate Property (AddServiceInterruptionSetup) | fcSDK Documentation

StartDate Property (AddServiceInterruptionSetup)

The DateTime the Service Interuption starts. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property StartDate As Date

[PropertyBitValueAttribute()]
public DateTime StartDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddServiceInterruptionSetup Class
AddServiceInterruptionSetup Members


UserName Property (AddServiceInterruptionSetup) | fcSDK Documentation

UserName Property (AddServiceInterruptionSetup)

The user who is adding the Service Interuption. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddServiceInterruptionSetup Class
AddServiceInterruptionSetup Members


CreateAppointmentResult Class | fcSDK Documentation

CreateAppointmentResult Class

Result from the CreateAppointment API.

Syntax

'Declaration

Public Class CreateAppointmentResult
   Inherits FChoice.Toolkits.Clarify.ToolkitResult

public class CreateAppointmentResult : FChoice.Toolkits.Clarify.ToolkitResult

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.ToolkitResult
FChoice.Toolkits.Clarify.FieldOps.CreateAppointmentResult

Requirements

Namespace: FChoice.Toolkits.Clarify.FieldOps

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateAppointmentResult Members
FChoice.Toolkits.Clarify.FieldOps Namespace


CreateAppointmentResult Class Members | fcSDK Documentation

CreateAppointmentResult Class Members

The following tables list the members exposed by CreateAppointmentResult.

Public Constructors

 | Name | Description
Public Constructor | CreateAppointmentResult Constructor |

Public Properties

 | Name | Description
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ScheduleObjid | The Objid of the Schedule.

Reference

CreateAppointmentResult Class
FChoice.Toolkits.Clarify.FieldOps Namespace


CreateAppointmentResult Constructor | fcSDK Documentation

CreateAppointmentResult Constructor

Syntax

'Declaration

Public Function New()

public CreateAppointmentResult()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAppointmentResult Class
CreateAppointmentResult Members


ScheduleObjid Property (CreateAppointmentResult) | fcSDK Documentation

ScheduleObjid Property (CreateAppointmentResult)

The Objid of the Schedule.

Syntax

'Declaration

Public Property ScheduleObjid As Integer

public int ScheduleObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAppointmentResult Class
CreateAppointmentResult Members


CreateAppointmentSetup Class | fcSDK Documentation

CreateAppointmentSetup Class

Used by the CreateAppointment method as setup data for invocation.

Syntax

'Declaration

Public Class CreateAppointmentSetup

public class CreateAppointmentSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.FieldOps.CreateAppointmentSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.FieldOps

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateAppointmentSetup Members
FChoice.Toolkits.Clarify.FieldOps Namespace
CreateAppointment(CreateAppointmentSetup) Method


CreateAppointmentSetup Class Members | fcSDK Documentation

CreateAppointmentSetup Class Members

The following tables list the members exposed by CreateAppointmentSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateAppointmentSetup Constructor | Overloaded.

Public Properties

 | Name | Description
Public Property | AppointmentClass | Element from the 'Employee Sched Class' application list. If not set the default list value is used.
Public Property | AppointmentType | Element from the 'Employee Sched Type' application list. If not set the default list value is used.
Public Property | CaseIDNum | The identifier of the Case with which this Appointment is associated
Public Property | CellText | The short description of the Appointment.
Public Property | CreateDate | The DateTime the Appointment was created. If not set, the current time is used.
Public Property | Description | The description of the Appointment.
Public Property | Duration | The length (in seconds) of the appointment. If not specified, it is calculated from the start and end times.
Public Property | EmployeeFirstName | The first name of the Employee that the Appointment is for.
Public Property | EmployeeLastName | The last name of the Employee that the Appointment is for.
Public Property | EndDate | The DateTime the Appointment ends. If not set, the start time and duration is used to calculate the end time.
Public Property | SitePartObjid | The Objid of the Site Part if the appointment is for a part.
Public Property | StartDate | The DateTime the Appointment starts. If not set, the current time is used.
Public Property | UserName | The user who created the Appointment. If not set, the Toolkit session user is used.

Reference

CreateAppointmentSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
CreateAppointment(CreateAppointmentSetup) Method


CreateAppointmentSetup Constructor | fcSDK Documentation

CreateAppointmentSetup Constructor

Initializes a new instance of the CreateAppointmentSetup class.

Overload List

Overload | Description
CreateAppointmentSetup Constructor(DateTime,DateTime) | Initializes a new instance of the CreateAppointmentSetup class. This overload takes a set of required parameters for the API.
CreateAppointmentSetup Constructor(DateTime,TimeSpan) | Initializes a new instance of the CreateAppointmentSetup class. This overload takes a set of required parameters for the API.
CreateAppointmentSetup Constructor(TimeSpan,DateTime) | Initializes a new instance of the CreateAppointmentSetup class. This overload takes a set of required parameters for the API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAppointmentSetup Class
CreateAppointmentSetup Members


CreateAppointmentSetup Constructor(DateTime,DateTime) | fcSDK Documentation

CreateAppointmentSetup Constructor(DateTime,DateTime)

The DateTime the Appointment starts. If not set, the current time is used.

The DateTime the Appointment ends. If not set, the start time and duration is used to calculate the end time.

Initializes a new instance of the CreateAppointmentSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _startDate_ As Date, _
   ByVal _endDate_ As Date _
)

[ConstructorIndexAttribute()]
public CreateAppointmentSetup(
   DateTime _startDate_,
   DateTime _endDate_
)

Parameters

startDate

The DateTime the Appointment starts. If not set, the current time is used.

endDate

The DateTime the Appointment ends. If not set, the start time and duration is used to calculate the end time.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAppointmentSetup Class
CreateAppointmentSetup Members
Overload List


CreateAppointmentSetup Constructor(DateTime,TimeSpan) | fcSDK Documentation

CreateAppointmentSetup Constructor(DateTime,TimeSpan)

The DateTime the Appointment starts. If not set, the current time is used.

The length (in seconds) of the appointment. If not specified, it is calculated from the start and end times.

Initializes a new instance of the CreateAppointmentSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _startDate_ As Date, _
   ByVal _duration_ As TimeSpan _
)

[ConstructorIndexAttribute()]
public CreateAppointmentSetup(
   DateTime _startDate_,
   TimeSpan _duration_
)

Parameters

startDate

The DateTime the Appointment starts. If not set, the current time is used.

duration

The length (in seconds) of the appointment. If not specified, it is calculated from the start and end times.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAppointmentSetup Class
CreateAppointmentSetup Members
Overload List


CreateAppointmentSetup Constructor(TimeSpan,DateTime) | fcSDK Documentation

CreateAppointmentSetup Constructor(TimeSpan,DateTime)

The length (in seconds) of the appointment. If not specified, it is calculated from the start and end times.

The DateTime the Appointment ends. If not set, the start time and duration is used to calculate the end time.

Initializes a new instance of the CreateAppointmentSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _duration_ As TimeSpan, _
   ByVal _endDate_ As Date _
)

[ConstructorIndexAttribute()]
public CreateAppointmentSetup(
   TimeSpan _duration_,
   DateTime _endDate_
)

Parameters

duration

The length (in seconds) of the appointment. If not specified, it is calculated from the start and end times.

endDate

The DateTime the Appointment ends. If not set, the start time and duration is used to calculate the end time.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAppointmentSetup Class
CreateAppointmentSetup Members
Overload List


AppointmentClass Property (CreateAppointmentSetup) | fcSDK Documentation

AppointmentClass Property (CreateAppointmentSetup)

Element from the 'Employee Sched Class' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AppointmentClass As String

[PropertyBitValueAttribute()]
public string AppointmentClass {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAppointmentSetup Class
CreateAppointmentSetup Members


AppointmentType Property (CreateAppointmentSetup) | fcSDK Documentation

AppointmentType Property (CreateAppointmentSetup)

Element from the 'Employee Sched Type' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AppointmentType As String

[PropertyBitValueAttribute()]
public string AppointmentType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAppointmentSetup Class
CreateAppointmentSetup Members


CaseIDNum Property (CreateAppointmentSetup) | fcSDK Documentation

CaseIDNum Property (CreateAppointmentSetup)

The identifier of the Case with which this Appointment is associated

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAppointmentSetup Class
CreateAppointmentSetup Members


CellText Property (CreateAppointmentSetup) | fcSDK Documentation

CellText Property (CreateAppointmentSetup)

The short description of the Appointment.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CellText As String

[PropertyBitValueAttribute()]
public string CellText {get; set;}

Remarks

If not specified, it will default to the Appointment Type and the Appointment start and end dates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAppointmentSetup Class
CreateAppointmentSetup Members


CreateDate Property (CreateAppointmentSetup) | fcSDK Documentation

CreateDate Property (CreateAppointmentSetup)

The DateTime the Appointment was created. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAppointmentSetup Class
CreateAppointmentSetup Members


Description Property (CreateAppointmentSetup) | fcSDK Documentation

Description Property (CreateAppointmentSetup)

The description of the Appointment.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Description As String

[PropertyBitValueAttribute()]
public string Description {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAppointmentSetup Class
CreateAppointmentSetup Members


Duration Property (CreateAppointmentSetup) | fcSDK Documentation

Duration Property (CreateAppointmentSetup)

The length (in seconds) of the appointment. If not specified, it is calculated from the start and end times.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Duration As TimeSpan

[PropertyBitValueAttribute()]
public TimeSpan Duration {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAppointmentSetup Class
CreateAppointmentSetup Members


EmployeeFirstName Property | fcSDK Documentation

EmployeeFirstName Property

The first name of the Employee that the Appointment is for.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property EmployeeFirstName As String

[PropertyBitValueAttribute()]
public string EmployeeFirstName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAppointmentSetup Class
CreateAppointmentSetup Members


EmployeeLastName Property | fcSDK Documentation

EmployeeLastName Property

The last name of the Employee that the Appointment is for.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property EmployeeLastName As String

[PropertyBitValueAttribute()]
public string EmployeeLastName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAppointmentSetup Class
CreateAppointmentSetup Members


EndDate Property (CreateAppointmentSetup) | fcSDK Documentation

EndDate Property (CreateAppointmentSetup)

The DateTime the Appointment ends. If not set, the start time and duration is used to calculate the end time.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property EndDate As Date

[PropertyBitValueAttribute()]
public DateTime EndDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAppointmentSetup Class
CreateAppointmentSetup Members


SitePartObjid Property (CreateAppointmentSetup) | fcSDK Documentation

SitePartObjid Property (CreateAppointmentSetup)

The Objid of the Site Part if the appointment is for a part.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SitePartObjid As Integer

[PropertyBitValueAttribute()]
public int SitePartObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAppointmentSetup Class
CreateAppointmentSetup Members


StartDate Property (CreateAppointmentSetup) | fcSDK Documentation

StartDate Property (CreateAppointmentSetup)

The DateTime the Appointment starts. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property StartDate As Date

[PropertyBitValueAttribute()]
public DateTime StartDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAppointmentSetup Class
CreateAppointmentSetup Members


UserName Property (CreateAppointmentSetup) | fcSDK Documentation

UserName Property (CreateAppointmentSetup)

The user who created the Appointment. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAppointmentSetup Class
CreateAppointmentSetup Members


CreateExpenseLogResult Class | fcSDK Documentation

CreateExpenseLogResult Class

Result from the CreateExpenseLog API.

Syntax

'Declaration

Public Class CreateExpenseLogResult
   Inherits FChoice.Toolkits.Clarify.ToolkitResult

public class CreateExpenseLogResult : FChoice.Toolkits.Clarify.ToolkitResult

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.ToolkitResult](FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.ToolkitResult.md) [FChoice.Toolkits.Clarify.FieldOps.CreateExpenseLogResult

Requirements

Namespace: FChoice.Toolkits.Clarify.FieldOps

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateExpenseLogResult Members FChoice.Toolkits.Clarify.FieldOps Namespace FChoice.Toolkits.Clarify.FieldOps.CreateExpenseLogResult

Requirements

Namespace: FChoice.Toolkits.Clarify.FieldOps

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateExpenseLogResult Members FChoice.Toolkits.Clarify.FieldOps Namespace


CreateExpenseLogResult Class Members | fcSDK Documentation

CreateExpenseLogResult Class Members

The following tables list the members exposed by CreateExpenseLogResult.

Public Constructors

 | Name | Description
Public Constructor | CreateExpenseLogResult Constructor |

Public Properties

 | Name | Description
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | OnsiteLogObjid | The Objid of the OnsiteLog.
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)

Reference

CreateExpenseLogResult Class
FChoice.Toolkits.Clarify.FieldOps Namespace


CreateExpenseLogResult Constructor | fcSDK Documentation

CreateExpenseLogResult Constructor

Syntax

'Declaration

Public Function New()

public CreateExpenseLogResult()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateExpenseLogResult Class
CreateExpenseLogResult Members


OnsiteLogObjid Property (CreateExpenseLogResult) | fcSDK Documentation

OnsiteLogObjid Property (CreateExpenseLogResult)

The Objid of the OnsiteLog.

Syntax

'Declaration

Public Property OnsiteLogObjid As Integer
``

```csharp
public int OnsiteLogObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateExpenseLogResult Class
CreateExpenseLogResult Members


CreateExpenseLogSetup Class | fcSDK Documentation

CreateExpenseLogSetup Class

Used by the CreateExpenseLog method as setup data for invocation.

Syntax

'Declaration

Public Class CreateExpenseLogSetup

public class CreateExpenseLogSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.FieldOps.CreateExpenseLogSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.FieldOps

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateExpenseLogSetup Members
FChoice.Toolkits.Clarify.FieldOps Namespace
CreateExpenseLog(CreateExpenseLogSetup) Method


CreateExpenseLogSetup Class Members | fcSDK Documentation

CreateExpenseLogSetup Class Members

The following tables list the members exposed by CreateExpenseLogSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateExpenseLogSetup Constructor | Initializes a new instance of the CreateExpenseLogSetup class.

Public Properties

 | Name | Description
Public Property | BillTo | Element from the 'Bill To Time' application list. If not set the default list value is used.
Public Property | CaseIDNum | The identifier of the Case with which this Expense Log is associated
Public Property | CreateDate | The DateTime the Expense Log was created. If not set, the current time is used.
Public Property | ExpenseType | Element from the 'Expense Type' application list. If not set the default list value is used.
Public Property | IsBillable | Specifies if the Expense Log is billable.
Public Property | Notes | Notes about the Expense Log.
Public Property | OnsiteLogObjid | The Objid of the Onsite Log that this Expense Log is related to.
Public Property | PerformedByUserName | The user who is performed the action specified by the Expense Log. If not set, the session user is used.
Public Property | Quantity | The number of units that are being applied to the Onsite Log.
Public Property | Rate | The billing rate per unit. If no rate is specified, the labor rate of the performing employee is used.
Public Property | Resolution | Element from the 'Resolution' application list. If not set the default list value is used.
Public Property | UserName | The user who created the Expense Log. If not set, the Toolkit session user is used.

Reference

CreateExpenseLogSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
CreateExpenseLog(CreateExpenseLogSetup) Method


CreateExpenseLogSetup Constructor | fcSDK Documentation

CreateExpenseLogSetup Constructor

The Objid of the Onsite Log that this Expense Log is related to.

Initializes a new instance of the CreateExpenseLogSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _onsiteLogObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public CreateExpenseLogSetup(
   int _onsiteLogObjid_
)

Parameters

onsiteLogObjid

The Objid of the Onsite Log that this Expense Log is related to.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateExpenseLogSetup Class
CreateExpenseLogSetup Members


BillTo Property (CreateExpenseLogSetup) | fcSDK Documentation

BillTo Property (CreateExpenseLogSetup)

Element from the 'Bill To Time' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property BillTo As String

[PropertyBitValueAttribute()]
public string BillTo {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateExpenseLogSetup Class
CreateExpenseLogSetup Members


CaseIDNum Property (CreateExpenseLogSetup) | fcSDK Documentation

CaseIDNum Property (CreateExpenseLogSetup)

The identifier of the Case with which this Expense Log is associated

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateExpenseLogSetup Class
CreateExpenseLogSetup Members


CreateDate Property (CreateExpenseLogSetup) | fcSDK Documentation

CreateDate Property (CreateExpenseLogSetup)

The DateTime the Expense Log was created. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateExpenseLogSetup Class
CreateExpenseLogSetup Members


ExpenseType Property (CreateExpenseLogSetup) | fcSDK Documentation

ExpenseType Property (CreateExpenseLogSetup)

Element from the 'Expense Type' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ExpenseType As String

[PropertyBitValueAttribute()]
public string ExpenseType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateExpenseLogSetup Class
CreateExpenseLogSetup Members


IsBillable Property (CreateExpenseLogSetup) | fcSDK Documentation

IsBillable Property (CreateExpenseLogSetup)

Specifies if the Expense Log is billable.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsBillable As Boolean

[PropertyBitValueAttribute()]
public bool IsBillable {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateExpenseLogSetup Class
CreateExpenseLogSetup Members


Notes Property (CreateExpenseLogSetup) | fcSDK Documentation

Notes Property (CreateExpenseLogSetup)

Notes about the Expense Log.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateExpenseLogSetup Class
CreateExpenseLogSetup Members


OnsiteLogObjid Property (CreateExpenseLogSetup) | fcSDK Documentation

OnsiteLogObjid Property (CreateExpenseLogSetup)

The Objid of the Onsite Log that this Expense Log is related to.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property OnsiteLogObjid As Integer

[PropertyBitValueAttribute()]
public int OnsiteLogObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateExpenseLogSetup Class
CreateExpenseLogSetup Members


PerformedByUserName Property (CreateExpenseLogSetup) | fcSDK Documentation

PerformedByUserName Property (CreateExpenseLogSetup)

The user who is performed the action specified by the Expense Log. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PerformedByUserName As String

[PropertyBitValueAttribute()]
public string PerformedByUserName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateExpenseLogSetup Class
CreateExpenseLogSetup Members


Quantity Property (CreateExpenseLogSetup) | fcSDK Documentation

Quantity Property (CreateExpenseLogSetup)

The number of units that are being applied to the Onsite Log.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Quantity As Double

[PropertyBitValueAttribute()]
public double Quantity {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateExpenseLogSetup Class
CreateExpenseLogSetup Members


Rate Property (CreateExpenseLogSetup) | fcSDK Documentation

Rate Property (CreateExpenseLogSetup)

The billing rate per unit. If no rate is specified, the labor rate of the performing employee is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Rate As Double

[PropertyBitValueAttribute()]
public double Rate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateExpenseLogSetup Class
CreateExpenseLogSetup Members


Resolution Property (CreateExpenseLogSetup) | fcSDK Documentation

Resolution Property (CreateExpenseLogSetup)

Element from the 'Resolution' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Resolution As String

[PropertyBitValueAttribute()]
public string Resolution {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateExpenseLogSetup Class
CreateExpenseLogSetup Members


UserName Property (CreateExpenseLogSetup) | fcSDK Documentation

UserName Property (CreateExpenseLogSetup)

The user who created the Expense Log. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateExpenseLogSetup Class
CreateExpenseLogSetup Members


CreateOnsiteLogSetup Class | fcSDK Documentation

CreateOnsiteLogSetup Class

Used by the CreateOnsiteLog method as setup data for invocation.

Syntax

'Declaration

Public Class CreateOnsiteLogSetup

public class CreateOnsiteLogSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.FieldOps.CreateOnsiteLogSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.FieldOps

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateOnsiteLogSetup Members
FChoice.Toolkits.Clarify.FieldOps Namespace
CreateOnsiteLog(CreateOnsiteLogSetup) Method


CreateOnsiteLogSetup Class Members | fcSDK Documentation

CreateOnsiteLogSetup Class Members

The following tables list the members exposed by CreateOnsiteLogSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateOnsiteLogSetup Constructor | Initializes a new instance of the CreateOnsiteLogSetup class.

Public Properties

 | Name | Description
Public Property | CreateDate | The DateTime the Onsite Log was created. If not set, the current time is used.
Public Property | LastModifiedDate | The DateTime the Onsite Log was modified. If not set, the current time is used.
Public Property | Notes | Notes about the Onsite Log.
Public Property | ObjectIDNum | Specifies the Id Number of this Onsite Log's Case or Subcase.
Public Property | ObjectType | Specifies whether this Onsite Log is tied to a Case or Subcase.
Public Property | PerformedByUserName | The user who is performed the action specified by the Onsite Log. If not set, the session user is used.
Public Property | Resolution | Element from the 'Resolution' application list. If not set the default list value is used.
Public Property | UserName | The user who created the Onsite Log. If not set, the Toolkit session user is used.

Reference

CreateOnsiteLogSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
CreateOnsiteLog(CreateOnsiteLogSetup) Method


CreateOnsiteLogSetup Constructor | fcSDK Documentation

CreateOnsiteLogSetup Constructor

Specifies whether this Onsite Log is tied to a Case or Subcase.

Specifies the Id Number of this Onsite Log's Case or Subcase.

Initializes a new instance of the CreateOnsiteLogSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _objectType_ As CaseObjectType, _
   ByVal _objectIDNum_ As String _
)

[ConstructorIndexAttribute()]
public CreateOnsiteLogSetup(
   CaseObjectType _objectType_,
   string _objectIDNum_
)

Parameters

objectType

Specifies whether this Onsite Log is tied to a Case or Subcase.

objectIDNum

Specifies the Id Number of this Onsite Log's Case or Subcase.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateOnsiteLogSetup Class
CreateOnsiteLogSetup Members


CreateDate Property (CreateOnsiteLogSetup) | fcSDK Documentation

CreateDate Property (CreateOnsiteLogSetup)

The DateTime the Onsite Log was created. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateOnsiteLogSetup Class
CreateOnsiteLogSetup Members


LastModifiedDate Property (CreateOnsiteLogSetup) | fcSDK Documentation

LastModifiedDate Property (CreateOnsiteLogSetup)

The DateTime the Onsite Log was modified. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LastModifiedDate As Date

[PropertyBitValueAttribute()]
public DateTime LastModifiedDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateOnsiteLogSetup Class
CreateOnsiteLogSetup Members


Notes Property (CreateOnsiteLogSetup) | fcSDK Documentation

Notes Property (CreateOnsiteLogSetup)

Notes about the Onsite Log.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateOnsiteLogSetup Class
CreateOnsiteLogSetup Members


ObjectIDNum Property | fcSDK Documentation

ObjectIDNum Property

Specifies the Id Number of this Onsite Log's Case or Subcase.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ObjectIDNum As String

[PropertyBitValueAttribute()]
public string ObjectIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateOnsiteLogSetup Class
CreateOnsiteLogSetup Members


ObjectType Property (CreateOnsiteLogSetup) | fcSDK Documentation

ObjectType Property (CreateOnsiteLogSetup)

Specifies whether this Onsite Log is tied to a Case or Subcase.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ObjectType As CaseObjectType

[PropertyBitValueAttribute()]
public CaseObjectType ObjectType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateOnsiteLogSetup Class
CreateOnsiteLogSetup Members


PerformedByUserName Property (CreateOnsiteLogSetup) | fcSDK Documentation

PerformedByUserName Property (CreateOnsiteLogSetup)

The user who is performed the action specified by the Onsite Log. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PerformedByUserName As String

[PropertyBitValueAttribute()]
public string PerformedByUserName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateOnsiteLogSetup Class
CreateOnsiteLogSetup Members


Resolution Property (CreateOnsiteLogSetup) | fcSDK Documentation

Resolution Property (CreateOnsiteLogSetup)

Element from the 'Resolution' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Resolution As String

[PropertyBitValueAttribute()]
public string Resolution {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateOnsiteLogSetup Class
CreateOnsiteLogSetup Members


UserName Property (CreateOnsiteLogSetup) | fcSDK Documentation

UserName Property (CreateOnsiteLogSetup)

The user who created the Onsite Log. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateOnsiteLogSetup Class
CreateOnsiteLogSetup Members


CreateTimeLogResult Class | fcSDK Documentation

CreateTimeLogResult Class

Result from the CreateTimeLog API.

Syntax

'Declaration

Public Class CreateTimeLogResult
   Inherits FChoice.Toolkits.Clarify.ToolkitResult

public class CreateTimeLogResult : FChoice.Toolkits.Clarify.ToolkitResult

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.ToolkitResult
FChoice.Toolkits.Clarify.FieldOps.CreateTimeLogResult

Requirements

Namespace: FChoice.Toolkits.Clarify.FieldOps

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateTimeLogResult Members
FChoice.Toolkits.Clarify.FieldOps Namespace


CreateTimeLogResult Class Members | fcSDK Documentation

CreateTimeLogResult Class Members

The following tables list the members exposed by CreateTimeLogResult.

Public Constructors

 | Name | Description
Public Constructor | CreateTimeLogResult Constructor |

Public Properties

 | Name | Description
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | OnsiteLogObjid | The Objid of the OnsiteLog.
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)

Reference

CreateTimeLogResult Class
FChoice.Toolkits.Clarify.FieldOps Namespace


CreateTimeLogResult Constructor | fcSDK Documentation

CreateTimeLogResult Constructor

Syntax

'Declaration

Public Function New()

public CreateTimeLogResult()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateTimeLogResult Class
CreateTimeLogResult Members


OnsiteLogObjid Property (CreateTimeLogResult) | fcSDK Documentation

OnsiteLogObjid Property (CreateTimeLogResult)

The Objid of the OnsiteLog.

Syntax

'Declaration

Public Property OnsiteLogObjid As Integer

public int OnsiteLogObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateTimeLogResult Class
CreateTimeLogResult Members


CreateTimeLogSetup Class | fcSDK Documentation

CreateTimeLogSetup Class

Used by the CreateTimeLog method as setup data for invocation.

Syntax

'Declaration

Public Class CreateTimeLogSetup

public class CreateTimeLogSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.FieldOps.CreateTimeLogSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.FieldOps

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateTimeLogSetup Members
FChoice.Toolkits.Clarify.FieldOps Namespace
CreateTimeLog(CreateTimeLogSetup) Method


CreateTimeLogSetup Class Members | fcSDK Documentation

CreateTimeLogSetup Class Members

The following tables list the members exposed by CreateTimeLogSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateTimeLogSetup Constructor | Initializes a new instance of the CreateTimeLogSetup class.

Public Properties

 | Name | Description
Public Property | BillTo | Element from the 'Bill To Time' application list. If not set the default list value is used.
Public Property | CaseIDNum | The identifier of the Case with which this Time Log is associated
Public Property | CreateDate | The DateTime the Time Log was created. If not set, the current time is used.
Public Property | Duration | The length (in seconds) of the Time Log. If not specified, it is calculated from the start and end times.
Public Property | IsBillable | Specifies if the Time Log is billable.
Public Property | Notes | Notes about the Time Log.
Public Property | OnsiteLogObjid | The Objid of the Onsite Log that this Time Log is related to.
Public Property | PerformedByUserName | The user who is performed the action specified by the Time Log. If not set, the session user is used.
Public Property | Resolution | Element from the 'Resolution' application list. If not set the default list value is used.
Public Property | StartDate | The DateTime the Time Log starts. If not set, the current time is used.
Public Property | TimeType | Element from the 'Time Type' application list. If not set the default list value is used.
Public Property | UserName | The user who created the Time Log. If not set, the Toolkit session user is used.
Public Property | WorkCenter | Element from the 'Work Center' application list. If not set the default list value is used.

Reference

CreateTimeLogSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
CreateTimeLog(CreateTimeLogSetup) Method


CreateTimeLogSetup Constructor | fcSDK Documentation

CreateTimeLogSetup Constructor

The Objid of the Onsite Log that this Time Log is related to.

The DateTime the Time Log starts. If not set, the current time is used.

The length (in seconds) of the Time Log. If not specified, it is calculated from the start and end times.

Initializes a new instance of the CreateTimeLogSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _onsiteLogObjid_ As Integer, _
   ByVal _startDate_ As Date, _
   ByVal _duration_ As TimeSpan _
)

[ConstructorIndexAttribute()]
public CreateTimeLogSetup(
   int _onsiteLogObjid_,
   DateTime _startDate_,
   TimeSpan _duration_
)

Parameters

onsiteLogObjid

The Objid of the Onsite Log that this Time Log is related to.

startDate

The DateTime the Time Log starts. If not set, the current time is used.

duration

The length (in seconds) of the Time Log. If not specified, it is calculated from the start and end times.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateTimeLogSetup Class
CreateTimeLogSetup Members


BillTo Property (CreateTimeLogSetup) | fcSDK Documentation

BillTo Property (CreateTimeLogSetup)

Element from the 'Bill To Time' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property BillTo As String

[PropertyBitValueAttribute()]
public string BillTo {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateTimeLogSetup Class
CreateTimeLogSetup Members


CaseIDNum Property (CreateTimeLogSetup) | fcSDK Documentation

CaseIDNum Property (CreateTimeLogSetup)

The identifier of the Case with which this Time Log is associated

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateTimeLogSetup Class
CreateTimeLogSetup Members


CreateDate Property (CreateTimeLogSetup) | fcSDK Documentation

CreateDate Property (CreateTimeLogSetup)

The DateTime the Time Log was created. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateTimeLogSetup Class
CreateTimeLogSetup Members


Duration Property (CreateTimeLogSetup) | fcSDK Documentation

Duration Property (CreateTimeLogSetup)

The length (in seconds) of the Time Log. If not specified, it is calculated from the start and end times.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Duration As TimeSpan

[PropertyBitValueAttribute()]
public TimeSpan Duration {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateTimeLogSetup Class
CreateTimeLogSetup Members


IsBillable Property (CreateTimeLogSetup) | fcSDK Documentation

IsBillable Property (CreateTimeLogSetup)

Specifies if the Time Log is billable.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsBillable As Boolean

[PropertyBitValueAttribute()]
public bool IsBillable {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateTimeLogSetup Class
CreateTimeLogSetup Members


Notes Property (CreateTimeLogSetup) | fcSDK Documentation

Notes Property (CreateTimeLogSetup)

Notes about the Time Log.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateTimeLogSetup Class
CreateTimeLogSetup Members


OnsiteLogObjid Property (CreateTimeLogSetup) | fcSDK Documentation

OnsiteLogObjid Property (CreateTimeLogSetup)

The Objid of the Onsite Log that this Time Log is related to.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property OnsiteLogObjid As Integer

[PropertyBitValueAttribute()]
public int OnsiteLogObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateTimeLogSetup Class
CreateTimeLogSetup Members


PerformedByUserName Property (CreateTimeLogSetup) | fcSDK Documentation

PerformedByUserName Property (CreateTimeLogSetup)

The user who is performed the action specified by the Time Log. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PerformedByUserName As String

[PropertyBitValueAttribute()]
public string PerformedByUserName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateTimeLogSetup Class
CreateTimeLogSetup Members


Resolution Property (CreateTimeLogSetup) | fcSDK Documentation

Resolution Property (CreateTimeLogSetup)

Element from the 'Resolution' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Resolution As String

[PropertyBitValueAttribute()]
public string Resolution {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateTimeLogSetup Class
CreateTimeLogSetup Members


StartDate Property (CreateTimeLogSetup) | fcSDK Documentation

StartDate Property (CreateTimeLogSetup)

The DateTime the Time Log starts. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property StartDate As Date

[PropertyBitValueAttribute()]
public DateTime StartDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateTimeLogSetup Class
CreateTimeLogSetup Members


TimeType Property (CreateTimeLogSetup) | fcSDK Documentation

TimeType Property (CreateTimeLogSetup)

Element from the 'Time Type' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property TimeType As String

[PropertyBitValueAttribute()]
public string TimeType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateTimeLogSetup Class
CreateTimeLogSetup Members


UserName Property (CreateTimeLogSetup) | fcSDK Documentation

UserName Property (CreateTimeLogSetup)

The user who created the Time Log. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateTimeLogSetup Class
CreateTimeLogSetup Members


WorkCenter Property (CreateTimeLogSetup) | fcSDK Documentation

WorkCenter Property (CreateTimeLogSetup)

Element from the 'Work Center' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WorkCenter As String

[PropertyBitValueAttribute()]
public string WorkCenter {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateTimeLogSetup Class
CreateTimeLogSetup Members


DeinstallSitePartSetup Class | fcSDK Documentation

DeinstallSitePartSetup Class

Used by the DeinstallSitePart method as setup data for invocation.

Syntax

'Declaration

Public Class DeinstallSitePartSetup

public class DeinstallSitePartSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.FieldOps.DeinstallSitePartSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.FieldOps

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

DeinstallSitePartSetup Members
FChoice.Toolkits.Clarify.FieldOps Namespace
DeinstallSitePart(DeinstallSitePartSetup) Method


DeinstallSitePartSetup Class Members | fcSDK Documentation

DeinstallSitePartSetup Class Members

The following tables list the members exposed by DeinstallSitePartSetup.

Public Constructors

 | Name | Description
Public Constructor | DeinstallSitePartSetup Constructor | Initializes a new instance of the DeinstallSitePartSetup class.

Public Properties

 | Name | Description
Public Property | DeinstallDate | The DateTime the Site Part was deinstalled. If not set, the current time is used.
Public Property | SitePartObjid | The Objid of the Site Part being deinstalled.
Public Property | UseRemove | Specifies if activity entry records should be set to "Remove" (true) or "De-Installed" (false).
Public Property | UserName | The user who deinstalled the Site Part. If not set, the Toolkit session user is used.

Reference

DeinstallSitePartSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
DeinstallSitePart(DeinstallSitePartSetup) Method


DeinstallSitePartSetup Constructor | fcSDK Documentation

DeinstallSitePartSetup Constructor

The Objid of the Site Part being deinstalled.

Initializes a new instance of the DeinstallSitePartSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _sitePartObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public DeinstallSitePartSetup(
   int _sitePartObjid_
)

Parameters

sitePartObjid

The Objid of the Site Part being deinstalled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeinstallSitePartSetup Class
DeinstallSitePartSetup Members


DeinstallDate Property (DeinstallSitePartSetup) | fcSDK Documentation

DeinstallDate Property (DeinstallSitePartSetup)

The DateTime the Site Part was deinstalled. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property DeinstallDate As Date

[PropertyBitValueAttribute()]
public DateTime DeinstallDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeinstallSitePartSetup Class
DeinstallSitePartSetup Members


SitePartObjid Property (DeinstallSitePartSetup) | fcSDK Documentation

SitePartObjid Property (DeinstallSitePartSetup)

The Objid of the Site Part being deinstalled.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SitePartObjid As Integer

[PropertyBitValueAttribute()]
public int SitePartObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeinstallSitePartSetup Class
DeinstallSitePartSetup Members


UseRemove Property (DeinstallSitePartSetup) | fcSDK Documentation

UseRemove Property (DeinstallSitePartSetup)

Specifies if activity entry records should be set to "Remove" (true) or "De-Installed" (false).

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UseRemove As Boolean

[PropertyBitValueAttribute()]
public bool UseRemove {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeinstallSitePartSetup Class
DeinstallSitePartSetup Members


UserName Property (DeinstallSitePartSetup) | fcSDK Documentation

UserName Property (DeinstallSitePartSetup)

The user who deinstalled the Site Part. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeinstallSitePartSetup Class
DeinstallSitePartSetup Members


DeleteAppointmentSetup Class | fcSDK Documentation

DeleteAppointmentSetup Class

Used by the DeleteAppointment method as setup data for invocation.

Syntax

'Declaration

Public Class DeleteAppointmentSetup

public class DeleteAppointmentSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.FieldOps.DeleteAppointmentSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.FieldOps

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

DeleteAppointmentSetup Members
FChoice.Toolkits.Clarify.FieldOps Namespace
DeleteAppointment(DeleteAppointmentSetup) Method


DeleteAppointmentSetup Class Members | fcSDK Documentation

DeleteAppointmentSetup Class Members

The following tables list the members exposed by DeleteAppointmentSetup.

Public Constructors

 | Name | Description
Public Constructor | DeleteAppointmentSetup Constructor | Initializes a new instance of the DeleteAppointmentSetup class.

Public Properties

 | Name | Description
Public Property | AppointmentObjid | The Objid of the Appointment being deleted.
Public Property | CreateDate | The DateTime the Appointment was deleted. If not set, the current time is used.
Public Property | UserName | The user who deleted the Appointment. If not set, the Toolkit session user is used.

Reference

DeleteAppointmentSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
DeleteAppointment(DeleteAppointmentSetup) Method


DeleteAppointmentSetup Constructor | fcSDK Documentation

DeleteAppointmentSetup Constructor

The Objid of the Appointment being deleted.

Initializes a new instance of the DeleteAppointmentSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _appointmentObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public DeleteAppointmentSetup(
   int _appointmentObjid_
)

Parameters

appointmentObjid

The Objid of the Appointment being deleted.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteAppointmentSetup Class
DeleteAppointmentSetup Members


AppointmentObjid Property (DeleteAppointmentSetup) | fcSDK Documentation

AppointmentObjid Property (DeleteAppointmentSetup)

The Objid of the Appointment being deleted.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AppointmentObjid As Integer

[PropertyBitValueAttribute()]
public int AppointmentObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteAppointmentSetup Class
DeleteAppointmentSetup Members


CreateDate Property (DeleteAppointmentSetup) | fcSDK Documentation

CreateDate Property (DeleteAppointmentSetup)

The DateTime the Appointment was deleted. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteAppointmentSetup Class
DeleteAppointmentSetup Members


UserName Property (DeleteAppointmentSetup) | fcSDK Documentation

UserName Property (DeleteAppointmentSetup)

The user who deleted the Appointment. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteAppointmentSetup Class
DeleteAppointmentSetup Members


DeleteExpenseLogSetup Class | fcSDK Documentation

DeleteExpenseLogSetup Class

Used by the DeleteExpenseLog method as setup data for invocation.

Syntax

'Declaration

Public Class DeleteExpenseLogSetup

public class DeleteExpenseLogSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.FieldOps.DeleteExpenseLogSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.FieldOps

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

DeleteExpenseLogSetup Members
FChoice.Toolkits.Clarify.FieldOps Namespace
DeleteExpenseLog(DeleteExpenseLogSetup) Method


DeleteExpenseLogSetup Class Members | fcSDK Documentation

DeleteExpenseLogSetup Class Members

The following tables list the members exposed by DeleteExpenseLogSetup.

Public Constructors

 | Name | Description
Public Constructor | DeleteExpenseLogSetup Constructor | Initializes a new instance of the DeleteExpenseLogSetup class.

Public Properties

 | Name | Description
Public Property | ExpenseLogObjid | The Objid of the Expense Log being deleted.
Public Property | LastModifiedDate | The DateTime the Expense Log was deleted. If not set, the current time is used.
Public Property | UserName | The user who deleted the Expense Log. If not set, the Toolkit session user is used.

Reference

DeleteExpenseLogSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
DeleteExpenseLog(DeleteExpenseLogSetup) Method


DeleteExpenseLogSetup Constructor | fcSDK Documentation

DeleteExpenseLogSetup Constructor

The Objid of the Expense Log being deleted.

Initializes a new instance of the DeleteExpenseLogSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _expenseLogObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public DeleteExpenseLogSetup(
   int _expenseLogObjid_
)

Parameters

expenseLogObjid

The Objid of the Expense Log being deleted.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteExpenseLogSetup Class
DeleteExpenseLogSetup Members


ExpenseLogObjid Property (DeleteExpenseLogSetup) | fcSDK Documentation

ExpenseLogObjid Property (DeleteExpenseLogSetup)

The Objid of the Expense Log being deleted.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ExpenseLogObjid As Integer

[PropertyBitValueAttribute()]
public int ExpenseLogObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteExpenseLogSetup Class
DeleteExpenseLogSetup Members


LastModifiedDate Property (DeleteExpenseLogSetup) | fcSDK Documentation

LastModifiedDate Property (DeleteExpenseLogSetup)

The DateTime the Expense Log was deleted. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LastModifiedDate As Date

[PropertyBitValueAttribute()]
public DateTime LastModifiedDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteExpenseLogSetup Class
DeleteExpenseLogSetup Members


UserName Property (DeleteExpenseLogSetup) | fcSDK Documentation

UserName Property (DeleteExpenseLogSetup)

The user who deleted the Expense Log. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteExpenseLogSetup Class
DeleteExpenseLogSetup Members


DeleteOnsiteLogSetup Class | fcSDK Documentation

DeleteOnsiteLogSetup Class

Used by the DeleteOnsiteLog method as setup data for invocation.

Syntax

'Declaration

Public Class DeleteOnsiteLogSetup

public class DeleteOnsiteLogSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.FieldOps.DeleteOnsiteLogSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.FieldOps

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

DeleteOnsiteLogSetup Members
FChoice.Toolkits.Clarify.FieldOps Namespace
DeleteOnsiteLog(DeleteOnsiteLogSetup) Method


DeleteOnsiteLogSetup Class Members | fcSDK Documentation

DeleteOnsiteLogSetup Class Members

The following tables list the members exposed by DeleteOnsiteLogSetup.

Public Constructors

 | Name | Description
Public Constructor | DeleteOnsiteLogSetup Constructor | Initializes a new instance of the DeleteOnsiteLogSetup class.

Public Properties

 | Name | Description
Public Property | NoteDate | The DateTime the Onsite Log was deleted. If not set, the current time is used.
Public Property | OnsiteLogObjid | The Objid of the Onsite Log being deleted.
Public Property | UserName | The user who deleted the Onsite Log. If not set, the Toolkit session user is used.

Reference

DeleteOnsiteLogSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
DeleteOnsiteLog(DeleteOnsiteLogSetup) Method


DeleteOnsiteLogSetup Constructor | fcSDK Documentation

DeleteOnsiteLogSetup Constructor

The Objid of the Onsite Log being deleted.

Initializes a new instance of the DeleteOnsiteLogSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _onsiteLogObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public DeleteOnsiteLogSetup(
   int _onsiteLogObjid_
)

Parameters

onsiteLogObjid

The Objid of the Onsite Log being deleted.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteOnsiteLogSetup Class
DeleteOnsiteLogSetup Members


NoteDate Property | fcSDK Documentation

NoteDate Property

The DateTime the Onsite Log was deleted. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NoteDate As Date

[PropertyBitValueAttribute()]
public DateTime NoteDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteOnsiteLogSetup Class
DeleteOnsiteLogSetup Members


OnsiteLogObjid Property (DeleteOnsiteLogSetup) | fcSDK Documentation

OnsiteLogObjid Property (DeleteOnsiteLogSetup)

The Objid of the Onsite Log being deleted.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property OnsiteLogObjid As Integer

[PropertyBitValueAttribute()]
public int OnsiteLogObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteOnsiteLogSetup Class
DeleteOnsiteLogSetup Members


UserName Property (DeleteOnsiteLogSetup) | fcSDK Documentation

UserName Property (DeleteOnsiteLogSetup)

The user who deleted the Onsite Log. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteOnsiteLogSetup Class
DeleteOnsiteLogSetup Members


DeleteServiceInterruptionSetup Class | fcSDK Documentation

DeleteServiceInterruptionSetup Class

Used by the DeleteServiceInterruption method as setup data for invocation.

Syntax

'Declaration

Public Class DeleteServiceInterruptionSetup

public class DeleteServiceInterruptionSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.FieldOps.DeleteServiceInterruptionSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.FieldOps

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

DeleteServiceInterruptionSetup Members
FChoice.Toolkits.Clarify.FieldOps Namespace
DeleteServiceInterruption(DeleteServiceInterruptionSetup) Method


DeleteServiceInterruptionSetup Class Members | fcSDK Documentation

DeleteServiceInterruptionSetup Class Members

The following tables list the members exposed by DeleteServiceInterruptionSetup.

Public Constructors

 | Name | Description
Public Constructor | DeleteServiceInterruptionSetup Constructor | Initializes a new instance of the DeleteServiceInterruptionSetup class.

Public Properties

 | Name | Description
Public Property | AppointmentObjid | The Objid of the Service Interuption being deleted.
Public Property | CreateDate | The DateTime the Service Interuption was deleted. If not set, the current time is used.
Public Property | UserName | The user who is deleting the Service Interuption. If not set, the session user is used.

Reference

DeleteServiceInterruptionSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
DeleteServiceInterruption(DeleteServiceInterruptionSetup) Method


DeleteServiceInterruptionSetup Constructor | fcSDK Documentation

DeleteServiceInterruptionSetup Constructor

The Objid of the Service Interuption being deleted.

Initializes a new instance of the DeleteServiceInterruptionSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _appointmentObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public DeleteServiceInterruptionSetup(
   int _appointmentObjid_
)

Parameters

appointmentObjid

The Objid of the Service Interuption being deleted.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteServiceInterruptionSetup Class
DeleteServiceInterruptionSetup Members


AppointmentObjid Property (DeleteServiceInterruptionSetup) | fcSDK Documentation

AppointmentObjid Property (DeleteServiceInterruptionSetup)

The Objid of the Service Interuption being deleted.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AppointmentObjid As Integer

[PropertyBitValueAttribute()]
public int AppointmentObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteServiceInterruptionSetup Class
DeleteServiceInterruptionSetup Members


CreateDate Property (DeleteServiceInterruptionSetup) | fcSDK Documentation

CreateDate Property (DeleteServiceInterruptionSetup)

The DateTime the Service Interuption was deleted. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteServiceInterruptionSetup Class
DeleteServiceInterruptionSetup Members


UserName Property (DeleteServiceInterruptionSetup) | fcSDK Documentation

UserName Property (DeleteServiceInterruptionSetup)

The user who is deleting the Service Interuption. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteServiceInterruptionSetup Class
DeleteServiceInterruptionSetup Members


DeleteTimeLogSetup Class | fcSDK Documentation

DeleteTimeLogSetup Class

Used by the DeleteTimeLog method as setup data for invocation.

Syntax

'Declaration

Public Class DeleteTimeLogSetup

public class DeleteTimeLogSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.FieldOps.DeleteTimeLogSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.FieldOps

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

DeleteTimeLogSetup Members
FChoice.Toolkits.Clarify.FieldOps Namespace
DeleteTimeLog(DeleteTimeLogSetup) Method


DeleteTimeLogSetup Class Members | fcSDK Documentation

DeleteTimeLogSetup Class Members

The following tables list the members exposed by DeleteTimeLogSetup.

Public Constructors

 | Name | Description
Public Constructor | DeleteTimeLogSetup Constructor | Initializes a new instance of the DeleteTimeLogSetup class.

Public Properties

 | Name | Description
Public Property | LastModifiedDate | The DateTime the Time Log was deleted. If not set, the current time is used.
Public Property | TimeLogObjid | The Objid of the Time Log being deleted.
Public Property | UserName | The user who deleted the Time Log. If not set, the Toolkit session user is used.

Reference

DeleteTimeLogSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
DeleteTimeLog(DeleteTimeLogSetup) Method


DeleteTimeLogSetup Constructor | fcSDK Documentation

DeleteTimeLogSetup Constructor

The Objid of the Time Log being deleted.

Initializes a new instance of the DeleteTimeLogSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _timeLogObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public DeleteTimeLogSetup(
   int _timeLogObjid_
)

Parameters

timeLogObjid

The Objid of the Time Log being deleted.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteTimeLogSetup Class
DeleteTimeLogSetup Members


LastModifiedDate Property (DeleteTimeLogSetup) | fcSDK Documentation

LastModifiedDate Property (DeleteTimeLogSetup)

The DateTime the Time Log was deleted. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LastModifiedDate As Date

[PropertyBitValueAttribute()]
public DateTime LastModifiedDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteTimeLogSetup Class
DeleteTimeLogSetup Members


TimeLogObjid Property (DeleteTimeLogSetup) | fcSDK Documentation

TimeLogObjid Property (DeleteTimeLogSetup)

The Objid of the Time Log being deleted.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property TimeLogObjid As Integer

[PropertyBitValueAttribute()]
public int TimeLogObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteTimeLogSetup Class
DeleteTimeLogSetup Members


UserName Property (DeleteTimeLogSetup) | fcSDK Documentation

UserName Property (DeleteTimeLogSetup)

The user who deleted the Time Log. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteTimeLogSetup Class
DeleteTimeLogSetup Members


DispatchFieldEngineerSetup Class | fcSDK Documentation

DispatchFieldEngineerSetup Class

Used by the DispatchFieldEngineer method as setup data for invocation.

Syntax

'Declaration

Public Class DispatchFieldEngineerSetup

public class DispatchFieldEngineerSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.FieldOps.DispatchFieldEngineerSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.FieldOps

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

DispatchFieldEngineerSetup Members
FChoice.Toolkits.Clarify.FieldOps Namespace
DispatchFieldEngineer(DispatchFieldEngineerSetup) Method


DispatchFieldEngineerSetup Class Members | fcSDK Documentation

DispatchFieldEngineerSetup Class Members

The following tables list the members exposed by DispatchFieldEngineerSetup.

Public Constructors

 | Name | Description
Public Constructor | DispatchFieldEngineerSetup Constructor | Initializes a new instance of the DispatchFieldEngineerSetup class.

Public Properties

 | Name | Description
Public Property | Address1 | The address used to overide the default site address.
Public Property | Address2 | The secondary address used to overide the default site secondary address.
Public Property | AlternatePhone | The alternate phone used to overide the contact alternate phone.
Public Property | AppointmentConfirmed | Indicates if the Appointment confirmed.
Public Property | AppointmentDate | The DateTime of the Appointment. If not set, the current time is used.
Public Property | CaseIDNum | The identifier of the Case with which this Dispatch FE is associated
Public Property | CellText | The short description of the Appointment.
Public Property | City | The city used to overide the default site alternate city.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | Description | The description of the Dispatch FE. If left blank, it is set to the title of the Case or Subcase.
Public Property | DispatchDate | DateTime the FieldEngineer was dispatched. If not set, the current time is used.
Public Property | Duration | The length (in seconds) of the FE appointment. If not specified, it is calculated from the start and end times.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | MainPhone | The main phone used to overide the contact main phone.
Public Property | Notes | The reason the FieldEngineer was rejected from the queue into which it was dispatched.
Public Property | PaymentMethod | Element from the 'Payment Method' application list. If not set the default list value is used.
Public Property | Proxy | Specifies the proxy to use for the activity entry record.
Public Property | ReferenceNumber | The reference number for the work order.
Public Property | RequestedETADate | The DateTime of the Field Engineer arrival at the site. If not set, the current time is used.
Public Property | SiteIDNum | The Site Id of the site to respond to if the case/subcase site is different.
Public Property | State | The state used to overide the default site alternate state.
Public Property | UserName | The user who has dispatched the FieldEngineer. If not set, the Toolkit session user is used.
Public Property | WorkOrder | The Id Number of the work order. If blank, "." is used.
Public Property | ZipCode | The zipcode used to overide the default site alternate zipcode.

Reference

DispatchFieldEngineerSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
DispatchFieldEngineer(DispatchFieldEngineerSetup) Method


DispatchFieldEngineerSetup Constructor | fcSDK Documentation

DispatchFieldEngineerSetup Constructor

The identifier of the Case with which this Dispatch FE is associated

Initializes a new instance of the DispatchFieldEngineerSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _caseIDNum_ As String _
)

[ConstructorIndexAttribute()]
public DispatchFieldEngineerSetup(
   string _caseIDNum_
)

Parameters

caseIDNum

The identifier of the Case with which this Dispatch FE is associated

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchFieldEngineerSetup Class
DispatchFieldEngineerSetup Members


Address1 Property (DispatchFieldEngineerSetup) | fcSDK Documentation

Address1 Property (DispatchFieldEngineerSetup)

The address used to overide the default site address.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Address1 As String

[PropertyBitValueAttribute()]
public string Address1 {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchFieldEngineerSetup Class
DispatchFieldEngineerSetup Members


Address2 Property (DispatchFieldEngineerSetup) | fcSDK Documentation

Address2 Property (DispatchFieldEngineerSetup)

The secondary address used to overide the default site secondary address.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Address2 As String

[PropertyBitValueAttribute()]
public string Address2 {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchFieldEngineerSetup Class
DispatchFieldEngineerSetup Members


AlternatePhone Property | fcSDK Documentation

AlternatePhone Property

The alternate phone used to overide the contact alternate phone.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AlternatePhone As String

[PropertyBitValueAttribute()]
public string AlternatePhone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchFieldEngineerSetup Class
DispatchFieldEngineerSetup Members


AppointmentConfirmed Property | fcSDK Documentation

AppointmentConfirmed Property

Indicates if the Appointment confirmed.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AppointmentConfirmed As Integer

[PropertyBitValueAttribute()]
public int AppointmentConfirmed {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchFieldEngineerSetup Class
DispatchFieldEngineerSetup Members


AppointmentDate Property | fcSDK Documentation

AppointmentDate Property

The DateTime of the Appointment. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AppointmentDate As Date

[PropertyBitValueAttribute()]
public DateTime AppointmentDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchFieldEngineerSetup Class
DispatchFieldEngineerSetup Members


CaseIDNum Property (DispatchFieldEngineerSetup) | fcSDK Documentation

CaseIDNum Property (DispatchFieldEngineerSetup)

The identifier of the Case with which this Dispatch FE is associated

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchFieldEngineerSetup Class
DispatchFieldEngineerSetup Members


CellText Property (DispatchFieldEngineerSetup) | fcSDK Documentation

CellText Property (DispatchFieldEngineerSetup)

The short description of the Appointment.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CellText As String

[PropertyBitValueAttribute()]
public string CellText {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchFieldEngineerSetup Class
DispatchFieldEngineerSetup Members


City Property (DispatchFieldEngineerSetup) | fcSDK Documentation

City Property (DispatchFieldEngineerSetup)

The city used to overide the default site alternate city.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property City As String

[PropertyBitValueAttribute()]
public string City {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchFieldEngineerSetup Class
DispatchFieldEngineerSetup Members


ContactFirstName Property (DispatchFieldEngineerSetup) | fcSDK Documentation

ContactFirstName Property (DispatchFieldEngineerSetup)

Contact's first name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactFirstName As String

[PropertyBitValueAttribute()]
public string ContactFirstName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchFieldEngineerSetup Class
DispatchFieldEngineerSetup Members


ContactLastName Property (DispatchFieldEngineerSetup) | fcSDK Documentation

ContactLastName Property (DispatchFieldEngineerSetup)

Contact's last name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactLastName As String

[PropertyBitValueAttribute()]
public string ContactLastName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchFieldEngineerSetup Class
DispatchFieldEngineerSetup Members


Description Property (DispatchFieldEngineerSetup) | fcSDK Documentation

Description Property (DispatchFieldEngineerSetup)

The description of the Dispatch FE. If left blank, it is set to the title of the Case or Subcase.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Description As String

[PropertyBitValueAttribute()]
public string Description {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchFieldEngineerSetup Class
DispatchFieldEngineerSetup Members


DispatchDate Property (DispatchFieldEngineerSetup) | fcSDK Documentation

DispatchDate Property (DispatchFieldEngineerSetup)

DateTime the FieldEngineer was dispatched. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property DispatchDate As Date

[PropertyBitValueAttribute()]
public DateTime DispatchDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchFieldEngineerSetup Class
DispatchFieldEngineerSetup Members


Duration Property (DispatchFieldEngineerSetup) | fcSDK Documentation

Duration Property (DispatchFieldEngineerSetup)

The length (in seconds) of the FE appointment. If not specified, it is calculated from the start and end times.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Duration As TimeSpan

[PropertyBitValueAttribute()]
public TimeSpan Duration {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchFieldEngineerSetup Class
DispatchFieldEngineerSetup Members


GenerateTimeBombs Property (DispatchFieldEngineerSetup) | fcSDK Documentation

GenerateTimeBombs Property (DispatchFieldEngineerSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchFieldEngineerSetup Class
DispatchFieldEngineerSetup Members


MainPhone Property | fcSDK Documentation

MainPhone Property

The main phone used to overide the contact main phone.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property MainPhone As String

[PropertyBitValueAttribute()]
public string MainPhone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchFieldEngineerSetup Class
DispatchFieldEngineerSetup Members


Notes Property (DispatchFieldEngineerSetup) | fcSDK Documentation

Notes Property (DispatchFieldEngineerSetup)

The reason the FieldEngineer was rejected from the queue into which it was dispatched.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchFieldEngineerSetup Class
DispatchFieldEngineerSetup Members


PaymentMethod Property (DispatchFieldEngineerSetup) | fcSDK Documentation

PaymentMethod Property (DispatchFieldEngineerSetup)

Element from the 'Payment Method' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PaymentMethod As String

[PropertyBitValueAttribute()]
public string PaymentMethod {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchFieldEngineerSetup Class
DispatchFieldEngineerSetup Members


Proxy Property | fcSDK Documentation

Proxy Property

Specifies the proxy to use for the activity entry record.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Proxy As String

[PropertyBitValueAttribute()]
public string Proxy {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchFieldEngineerSetup Class
DispatchFieldEngineerSetup Members


ReferenceNumber Property | fcSDK Documentation

ReferenceNumber Property

The reference number for the work order.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ReferenceNumber As String

[PropertyBitValueAttribute()]
public string ReferenceNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchFieldEngineerSetup Class
DispatchFieldEngineerSetup Members


RequestedETADate Property | fcSDK Documentation

RequestedETADate Property

The DateTime of the Field Engineer arrival at the site. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property RequestedETADate As Date

[PropertyBitValueAttribute()]
public DateTime RequestedETADate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchFieldEngineerSetup Class
DispatchFieldEngineerSetup Members


SiteIDNum Property (DispatchFieldEngineerSetup) | fcSDK Documentation

SiteIDNum Property (DispatchFieldEngineerSetup)

The Site Id of the site to respond to if the case/subcase site is different.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteIDNum As String

[PropertyBitValueAttribute()]
public string SiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchFieldEngineerSetup Class
DispatchFieldEngineerSetup Members


State Property (DispatchFieldEngineerSetup) | fcSDK Documentation

State Property (DispatchFieldEngineerSetup)

The state used to overide the default site alternate state.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property State As String

[PropertyBitValueAttribute()]
public string State {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchFieldEngineerSetup Class
DispatchFieldEngineerSetup Members


UserName Property (DispatchFieldEngineerSetup) | fcSDK Documentation

UserName Property (DispatchFieldEngineerSetup)

The user who has dispatched the FieldEngineer. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchFieldEngineerSetup Class
DispatchFieldEngineerSetup Members


WorkOrder Property | fcSDK Documentation

WorkOrder Property

The Id Number of the work order. If blank, "." is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WorkOrder As String

[PropertyBitValueAttribute()]
public string WorkOrder {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchFieldEngineerSetup Class
DispatchFieldEngineerSetup Members


ZipCode Property (DispatchFieldEngineerSetup) | fcSDK Documentation

ZipCode Property (DispatchFieldEngineerSetup)

The zipcode used to overide the default site alternate zipcode.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ZipCode As String

[PropertyBitValueAttribute()]
public string ZipCode {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchFieldEngineerSetup Class
DispatchFieldEngineerSetup Members


FieldOpsToolkit Class | fcSDK Documentation

FieldOpsToolkit Class

Provides APIs to allow you to modify Logistics Field Operations objects such as Time and Expense Logs, Dispatch Field Engineer Request, and Log Parts Used. For example, you can create, modify, and delete time, expense, and on-site logs, handle Dispatch FE records, fully use the Log Parts Used functionality (including installing/deinstalling/moving site_parts, and affecting inventory), schedule appointments, and more.

Syntax

'Declaration

Public Class FieldOpsToolkit
   Inherits FieldOpsToolkitBase

public class FieldOpsToolkit : FieldOpsToolkitBase

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.ToolkitBase
FChoice.Toolkits.Clarify.FieldOps.FieldOpsToolkitBase
FChoice.Toolkits.Clarify.FieldOps.FieldOpsToolkit

Requirements

Namespace: FChoice.Toolkits.Clarify.FieldOps

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

FieldOpsToolkit Members
FChoice.Toolkits.Clarify.FieldOps Namespace


FieldOpsToolkit Class Members | fcSDK Documentation

FieldOpsToolkit Class Members

The following tables list the members exposed by FieldOpsToolkit.

Public Constructors

 | Name | Description
Public Constructor | FieldOpsToolkit Constructor | Overloaded.

Public Properties

 | Name | Description
Public Property | ImpersonatorUsername | (Inherited from FChoice.Toolkits.Clarify.FieldOps.FieldOpsToolkitBase)

Public Methods

 | Name | Description
Public Method | AddServiceInterruption | Overloaded. Adds a service interruption (and creates an appointment record). This overload takes a setup object and a database transaction.
Public Method | CreateAppointment | Overloaded. Used to create a new appointment. This overload takes a setup object and a database transaction.
Public Method | CreateExpenseLog | Overloaded. Used to create a new expense log that is related to an onsite log. This overload takes a setup object and a database transaction.
Public Method | CreateOnsiteLog | Overloaded. Used to create an onsite log that is related to a case or subcase. This overload takes a setup object and a database transaction.
Public Method | CreateTimeLog | Overloaded. Used to create a time log that is related to an onsite log. This overload takes a setup object and a database transaction.
Public Method | DeinstallSitePart | Overloaded. Used to de-install a site part (and the sub-parts installed underneath it) from a site. This overload takes a setup object and a database transaction.
Public Method | DeleteAppointment | Overloaded. Used to delete an existing appointment. This overload takes a setup object and a database transaction.
Public Method | DeleteExpenseLog | Overloaded. Used to delete an existing expense log. This overload takes a setup object and a database transaction.
Public Method | DeleteOnsiteLog | Overloaded. Used to delete an existing onsite log. This overload takes a setup object and a database transaction.
Public Method | DeleteServiceInterruption | Overloaded. Used to delete an existing service interuption (appointment). This overload takes a setup object and a database transaction.
Public Method | DeleteTimeLog | Overloaded. This API deletes an existing time log. This overload takes a setup object and a database transaction.
Public Method | DispatchFieldEngineer | Overloaded. Dispatch the FieldEngineer to the specified queue. This overload takes a set of required parameters for the API.
Public Method | InstallSitePart | Overloaded. Used to install a site part. This overload takes a setup object and a database transaction.
Public Method | LogPartsUsedConsume | Overloaded. Used to consume an existing site part or an inventory part. This overload takes a setup object and a database transaction.
Public Method | LogPartsUsedExchange | Overloaded. Used to replace an existing site part with a new site part. This overload takes a setup object and a database transaction.
Public Method | LogPartsUsedInstall | Overloaded. Used to install a new site part. This overload takes a setup object and a database transaction.
Public Method | LogPartsUsedRemove | Overloaded. Used to remove an existing site part. This overload takes a setup object and a database transaction.
Public Method | LogPartsUsedUpgrade | Overloaded. Used to upgrade an existing site part with a new site part. This overload takes a setup object and a database transaction.
Public Method | MoveSitePartToBin | Overloaded. Move the SitePartToBin from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
Public Method | MoveSitePartToPart | Overloaded. Move the SitePartToPart from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
Public Method | MoveSitePartToSite | Overloaded. Move the SitePartToSite from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
Public Method | PartTransfer | Overloaded. Initializes a new instance of the PartTransferSetup class. This overload takes a set of required parameters for the API.
Public Method | ReinstallSitePart | Overloaded. Used to re-install a site part (and the sub-parts installed underneath it) that have been deinstalled from a site. This overload takes a setup object and a database transaction.
Public Method | UpdateAppointment | Overloaded. Used to modify an existing appointment. This overload takes a setup object and a database transaction.
Public Method | UpdateExpenseLog | Overloaded. Used to modify an existing expense log. This overload takes a setup object and a database transaction.
Public Method | UpdateServiceInterruption | Overloaded. Used to modify an existing service interruption (appointment). This overload takes a setup object and a database transaction.
Public Method | UpdateSitePart | Overloaded. Used to modify an existing site part. This overload takes a setup object and a database transaction.
Public Method | UpdateTimeLog | Overloaded. Used to modify an existing time log. This overload takes a setup object and a database transaction.

Reference

FieldOpsToolkit Class
FChoice.Toolkits.Clarify.FieldOps Namespace


FieldOpsToolkit Constructor | fcSDK Documentation

FieldOpsToolkit Constructor

Initializes a new instance of the FieldOpsToolkit class.

Overload List

Overload | Description
FieldOpsToolkit Constructor(ClarifySession) | Initializes a new instance of the FieldOpsToolkit class using a ClarifySession object.
FieldOpsToolkit Constructor(IFCApplication,IFCSession) | Initializes a new instance of the FieldOpsToolkit class using a Compatibility application and session.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members


FieldOpsToolkit Constructor(ClarifySession) | fcSDK Documentation

FieldOpsToolkit Constructor(ClarifySession)

The session under which the toolkit APIs will be executed.

Initializes a new instance of the FieldOpsToolkit class using a ClarifySession object.

Syntax

'Declaration

Public Function New( _
   ByVal _session_ As ClarifySession _
)

public FieldOpsToolkit(
   ClarifySession _session_
)

Parameters

session

The session under which the toolkit APIs will be executed.

Remarks

If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


FieldOpsToolkit Constructor(IFCApplication,IFCSession) | fcSDK Documentation

FieldOpsToolkit Constructor(IFCApplication,IFCSession)

The compatibility application under which the toolkit APIs will be executed.

The compatibility session under which the toolkit APIs will be executed.

Initializes a new instance of the FieldOpsToolkit class using a Compatibility application and session.

Syntax

'Declaration

Public Function New( _
   ByVal _application_ As IFCApplication, _
   ByVal _session_ As IFCSession _
)

public FieldOpsToolkit(
   IFCApplication _application_,
   IFCSession _session_
)

Parameters

application

The compatibility application under which the toolkit APIs will be executed.

session

The compatibility session under which the toolkit APIs will be executed.

Remarks

If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


AddServiceInterruption Method | fcSDK Documentation

AddServiceInterruption Method

Overload List

Overload | Description
AddServiceInterruption(String) |
AddServiceInterruption(AddServiceInterruptionSetup) |
AddServiceInterruption(AddServiceInterruptionSetup,IDbTransaction) | Adds a service interruption (and creates an appointment record). This overload takes a setup object and a database transaction.

Remarks

The start/end time can be specified either with both times or with one time and a duration. The duration is specified in seconds.

Each appointment must be specified for a given case or a piece of equipment (site_part), but both cannot be specified. If a case is specified, the case must have a related site_part.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class FieldOpsToolkit Members AddServiceInterruptionSetup Class


AddServiceInterruption(String) Method | fcSDK Documentation

AddServiceInterruption(String) Method

The identifier of the Case with which this Service Interuption is associated

Syntax

'Declaration

Public Overloads Function AddServiceInterruption( _
   ByVal _caseIDNum_ As String _
) As AddServiceInterruptionResult

public AddServiceInterruptionResult AddServiceInterruption(
   string _caseIDNum_
)

Parameters

caseIDNum

The identifier of the Case with which this Service Interuption is associated

Return Value

The following values are populated in the AddServiceInterruptionResult object returned by the API method:

  • ScheduleObjid - The Objid of the Schedule.
  • Objid - The Objid of the Appointment.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


AddServiceInterruption(AddServiceInterruptionSetup) Method | fcSDK Documentation

AddServiceInterruption(AddServiceInterruptionSetup) Method

Setup object for API invocation.

Syntax

'Declaration

Public Overloads Function AddServiceInterruption( _
   ByVal _setupParam_ As AddServiceInterruptionSetup _
) As AddServiceInterruptionResult

public AddServiceInterruptionResult AddServiceInterruption(
   AddServiceInterruptionSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the AddServiceInterruptionResult object returned by the API method:

  • ScheduleObjid - The Objid of the Schedule.
  • Objid - The Objid of the Appointment.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List
AddServiceInterruptionSetup Class


AddServiceInterruption(AddServiceInterruptionSetup,IDbTransaction) Method | fcSDK Documentation

AddServiceInterruption(AddServiceInterruptionSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Adds a service interruption (and creates an appointment record). This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function AddServiceInterruption( _
   ByVal _setupParam_ As AddServiceInterruptionSetup, _
   ByVal _transaction_ As IDbTransaction _
) As AddServiceInterruptionResult

public AddServiceInterruptionResult AddServiceInterruption(
   AddServiceInterruptionSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A AddServiceInterruptionResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The start/end time can be specified either with both times or with one time and a duration. The duration is specified in seconds.

Each appointment must be specified for a given case or a piece of equipment (site_part), but both cannot be specified. If a case is specified, the case must have a related site_part.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


CreateAppointment Method | fcSDK Documentation

CreateAppointment Method

Overload List

Overload | Description
CreateAppointment(DateTime,DateTime) |
CreateAppointment(DateTime,TimeSpan) |
CreateAppointment(TimeSpan,DateTime) |
CreateAppointment(CreateAppointmentSetup) |
CreateAppointment(CreateAppointmentSetup,IDbTransaction) | Used to create a new appointment. This overload takes a setup object and a database transaction.

Remarks

The start/end time can be specified either with both times or with one time and a duration. The duration is specified in seconds.

Each appointment must be specified for a given employee or a piece of equipment (site_part). Both cannot be specified. A case ID number may be optionally specified.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class FieldOpsToolkit Members CreateAppointmentSetup Class


CreateAppointment(DateTime,DateTime) Method | fcSDK Documentation

CreateAppointment(DateTime,DateTime) Method

The DateTime the Appointment starts. If not set, the current time is used.

The DateTime the Appointment ends. If not set, the start time and duration is used to calculate the end time.

Syntax

'Declaration

Public Overloads Function CreateAppointment( _
   ByVal _startDate_ As Date, _
   ByVal _endDate_ As Date _
) As CreateAppointmentResult

public CreateAppointmentResult CreateAppointment(
   DateTime _startDate_,
   DateTime _endDate_
)

Parameters

startDate

The DateTime the Appointment starts. If not set, the current time is used.

endDate

The DateTime the Appointment ends. If not set, the start time and duration is used to calculate the end time.

Return Value

The following values are populated in the CreateAppointmentResult object returned by the API method:

  • ScheduleObjid - The Objid of the Schedule.
  • Objid - The Objid of the Appointment.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


CreateAppointment(DateTime,TimeSpan) Method | fcSDK Documentation

CreateAppointment(DateTime,TimeSpan) Method

The DateTime the Appointment starts. If not set, the current time is used.

The length (in seconds) of the appointment. If not specified, it is calculated from the start and end times.

Syntax

'Declaration

Public Overloads Function CreateAppointment( _
   ByVal _startDate_ As Date, _
   ByVal _duration_ As TimeSpan _
) As CreateAppointmentResult

public CreateAppointmentResult CreateAppointment(
   DateTime _startDate_,
   TimeSpan _duration_
)

Parameters

startDate

The DateTime the Appointment starts. If not set, the current time is used.

duration

The length (in seconds) of the appointment. If not specified, it is calculated from the start and end times.

Return Value

The following values are populated in the CreateAppointmentResult object returned by the API method:

  • ScheduleObjid - The Objid of the Schedule.
  • Objid - The Objid of the Appointment.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


CreateAppointment(TimeSpan,DateTime) Method | fcSDK Documentation

CreateAppointment(TimeSpan,DateTime) Method

The length (in seconds) of the appointment. If not specified, it is calculated from the start and end times.

The DateTime the Appointment ends. If not set, the start time and duration is used to calculate the end time.

Syntax

'Declaration

Public Overloads Function CreateAppointment( _
   ByVal _duration_ As TimeSpan, _
   ByVal _endDate_ As Date _
) As CreateAppointmentResult

public CreateAppointmentResult CreateAppointment(
   TimeSpan _duration_,
   DateTime _endDate_
)

Parameters

duration

The length (in seconds) of the appointment. If not specified, it is calculated from the start and end times.

endDate

The DateTime the Appointment ends. If not set, the start time and duration is used to calculate the end time.

Return Value

The following values are populated in the CreateAppointmentResult object returned by the API method:

  • ScheduleObjid - The Objid of the Schedule.
  • Objid - The Objid of the Appointment.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


CreateAppointment(CreateAppointmentSetup) Method | fcSDK Documentation

CreateAppointment(CreateAppointmentSetup) Method

Setup object for API invocation.

Syntax

'Declaration

Public Overloads Function CreateAppointment( _
   ByVal _setupParam_ As CreateAppointmentSetup _
) As CreateAppointmentResult

public CreateAppointmentResult CreateAppointment(
   CreateAppointmentSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the CreateAppointmentResult object returned by the API method:

  • Objid - The Objid of the Appointment.
  • ScheduleObjid - The Objid of the Schedule.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List
CreateAppointmentSetup Class


CreateAppointment(CreateAppointmentSetup,IDbTransaction) Method | fcSDK Documentation

CreateAppointment(CreateAppointmentSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to create a new appointment. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreateAppointment( _
   ByVal _setupParam_ As CreateAppointmentSetup, _
   ByVal _transaction_ As IDbTransaction _
) As CreateAppointmentResult

public CreateAppointmentResult CreateAppointment(
   CreateAppointmentSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A CreateAppointmentResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The start/end time can be specified either with both times or with one time and a duration. The duration is specified in seconds.

Each appointment must be specified for a given employee or a piece of equipment (site_part). Both cannot be specified. A case ID number may be optionally specified.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


CreateExpenseLog Method | fcSDK Documentation

CreateExpenseLog Method

Overload List

Overload | Description
CreateExpenseLog(Int32) |
CreateExpenseLog(CreateExpenseLogSetup) |
CreateExpenseLog(CreateExpenseLogSetup,IDbTransaction) | Used to create a new expense log that is related to an onsite log. This overload takes a setup object and a database transaction.

Remarks

The objid of the onsite log or a case/subcase id must be supplied (but not both). If you do not specify a billing rate, the employee’s labor rate will be used.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class FieldOpsToolkit Members CreateExpenseLogSetup Class


CreateExpenseLog(Int32) Method | fcSDK Documentation

CreateExpenseLog(Int32) Method

The Objid of the Onsite Log that this Expense Log is related to.

Syntax

'Declaration

Public Overloads Function CreateExpenseLog( _
   ByVal _onsiteLogObjid_ As Integer _
) As CreateExpenseLogResult

public CreateExpenseLogResult CreateExpenseLog(
   int _onsiteLogObjid_
)

Parameters

onsiteLogObjid

The Objid of the Onsite Log that this Expense Log is related to.

Return Value

The following values are populated in the CreateExpenseLogResult object returned by the API method:

  • OnsiteLogObjid - The Objid of the OnsiteLog.
  • Objid - The Objid of the ExpenseLog.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


CreateExpenseLog(CreateExpenseLogSetup) Method | fcSDK Documentation

CreateExpenseLog(CreateExpenseLogSetup) Method

Setup object for API invocation.

Syntax

'Declaration

Public Overloads Function CreateExpenseLog( _
   ByVal _setupParam_ As CreateExpenseLogSetup _
) As CreateExpenseLogResult

public CreateExpenseLogResult CreateExpenseLog(
   CreateExpenseLogSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the CreateExpenseLogResult object returned by the API method:

  • Objid - The Objid of the ExpenseLog.
  • OnsiteLogObjid - The Objid of the OnsiteLog.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List
CreateExpenseLogSetup Class


CreateExpenseLog(CreateExpenseLogSetup,IDbTransaction) Method | fcSDK Documentation

CreateExpenseLog(CreateExpenseLogSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to create a new expense log that is related to an onsite log. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreateExpenseLog( _
   ByVal _setupParam_ As CreateExpenseLogSetup, _
   ByVal _transaction_ As IDbTransaction _
) As CreateExpenseLogResult

public CreateExpenseLogResult CreateExpenseLog(
   CreateExpenseLogSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A CreateExpenseLogResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The objid of the onsite log or a case/subcase id must be supplied (but not both). If you do not specify a billing rate, the employee’s labor rate will be used.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


CreateOnsiteLog Method | fcSDK Documentation

CreateOnsiteLog Method

Overload List

Overload | Description
CreateOnsiteLog(CaseObjectType,String) |
CreateOnsiteLog(CreateOnsiteLogSetup) |
CreateOnsiteLog(CreateOnsiteLogSetup,IDbTransaction) | Used to create an onsite log that is related to a case or subcase. This overload takes a setup object and a database transaction.

Remarks

The object type and id of the focus object (the case or subcase) must be supplied.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class FieldOpsToolkit Members CreateOnsiteLogSetup Class


CreateOnsiteLog(CaseObjectType,String) Method | fcSDK Documentation

CreateOnsiteLog(CaseObjectType,String) Method

Specifies whether this Onsite Log is tied to a Case or Subcase.

Specifies the Id Number of this Onsite Log's Case or Subcase.

Syntax

'Declaration

Public Overloads Function CreateOnsiteLog( _
   ByVal _objectType_ As CaseObjectType, _
   ByVal _objectIDNum_ As String _
) As ToolkitResult

public ToolkitResult CreateOnsiteLog(
   CaseObjectType _objectType_,
   string _objectIDNum_
)

Parameters

objectType

Specifies whether this Onsite Log is tied to a Case or Subcase.

objectIDNum

Specifies the Id Number of this Onsite Log's Case or Subcase.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - Objid of the Onsite Log record.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


CreateOnsiteLog(CreateOnsiteLogSetup) Method | fcSDK Documentation

CreateOnsiteLog(CreateOnsiteLogSetup) Method

Setup object for API invocation.

Syntax

'Declaration

Public Overloads Function CreateOnsiteLog( _
   ByVal _setupParam_ CreateOnsiteLogSetup _
) As ToolkitResult

public ToolkitResult CreateOnsiteLog(
   CreateOnsiteLogSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - Objid of the Onsite Log record.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List
CreateOnsiteLogSetup Class


CreateOnsiteLog(CreateOnsiteLogSetup,IDbTransaction) Method | fcSDK Documentation

CreateOnsiteLog(CreateOnsiteLogSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to create an onsite log that is related to a case or subcase. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreateOnsiteLog( _
   ByVal _setupParam_ As CreateOnsiteLogSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreateOnsiteLog(
   CreateOnsiteLogSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The object type and id of the focus object (the case or subcase) must be supplied.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


CreateTimeLog Method | fcSDK Documentation

CreateTimeLog Method

Overload List

Overload | Description
CreateTimeLog(Int32,DateTime,TimeSpan) |
CreateTimeLog(CreateTimeLogSetup) |
CreateTimeLog(CreateTimeLogSetup,IDbTransaction) | Used to create a time log that is related to an onsite log. This overload takes a setup object and a database transaction.

Remarks

The objid of the onsite log or a case/subcase id must be supplied (but not both). The start time and duration must also be supplied.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class FieldOpsToolkit Members CreateTimeLogSetup Class


CreateTimeLog(Int32,DateTime,TimeSpan) Method | fcSDK Documentation

CreateTimeLog(Int32,DateTime,TimeSpan) Method

The Objid of the Onsite Log that this Time Log is related to.

The DateTime the Time Log starts. If not set, the current time is used.

The length (in seconds) of the Time Log. If not specified, it is calculated from the start and end times.

Syntax

'Declaration

Public Overloads Function CreateTimeLog( _
   ByVal _onsiteLogObjid_ As Integer, _
   ByVal _startDate_ As Date, _
   ByVal _duration_ As TimeSpan _
) As CreateTimeLogResult

public CreateTimeLogResult CreateTimeLog(
   int _onsiteLogObjid_,
   DateTime _startDate_,
   TimeSpan _duration_
)

Parameters

onsiteLogObjid

The Objid of the Onsite Log that this Time Log is related to.

startDate

The DateTime the Time Log starts. If not set, the current time is used.

duration

The length (in seconds) of the Time Log. If not specified, it is calculated from the start and end times.

Return Value

The following values are populated in the CreateTimeLogResult object returned by the API method:

  • OnsiteLogObjid - The Objid of the OnsiteLog.
  • Objid - The Objid of the TimeLog.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


CreateTimeLog(CreateTimeLogSetup) Method | fcSDK Documentation

CreateTimeLog(CreateTimeLogSetup) Method

Setup object for API invocation.

Syntax

'Declaration

Public Overloads Function CreateTimeLog( _
   ByVal _setupParam_ As CreateTimeLogSetup _
) As CreateTimeLogResult

public CreateTimeLogResult CreateTimeLog(
   CreateTimeLogSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the CreateTimeLogResult object returned by the API method:

  • OnsiteLogObjid - The Objid of the OnsiteLog.
  • Objid - The Objid of the TimeLog.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List
CreateTimeLogSetup Class


CreateTimeLog(CreateTimeLogSetup,IDbTransaction) Method | fcSDK Documentation

CreateTimeLog(CreateTimeLogSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to create a time log that is related to an onsite log. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreateTimeLog( _
   ByVal _setupParam_ As CreateTimeLogSetup, _
   ByVal _transaction_ As IDbTransaction _
) As CreateTimeLogResult

public CreateTimeLogResult CreateTimeLog(
   CreateTimeLogSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A CreateTimeLogResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The objid of the onsite log or a case/subcase id must be supplied (but not both). The start time and duration must also be supplied.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


DeinstallSitePart Method (FieldOpsToolkit) | fcSDK Documentation

DeinstallSitePart Method (FieldOpsToolkit)

Overload List

Overload | Description
DeinstallSitePart(Int32) |
DeinstallSitePart(DeinstallSitePartSetup) |
DeinstallSitePart(DeinstallSitePartSetup,IDbTransaction) | Used to de-install a site part (and the sub-parts installed underneath it) from a site. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class FieldOpsToolkit Members DeinstallSitePartSetup Class


DeinstallSitePart(Int32) Method | fcSDK Documentation

DeinstallSitePart(Int32) Method

The Objid of the Site Part being deinstalled.

Syntax

'Declaration

Public Overloads Function DeinstallSitePart( _
   ByVal _sitePartObjid_ As Integer _
) As ToolkitResult

public ToolkitResult DeinstallSitePart(
   int _sitePartObjid_
)

Parameters

sitePartObjid

The Objid of the Site Part being deinstalled.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


DeinstallSitePart(DeinstallSitePartSetup) Method | fcSDK Documentation

DeinstallSitePart(DeinstallSitePartSetup) Method

Setup object for API invocation.

Syntax

'Declaration

Public Overloads Function DeinstallSitePart( _
   ByVal _setupParam_ DeinstallSitePartSetup _
) As ToolkitResult

public ToolkitResult DeinstallSitePart(
   DeinstallSitePartSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List
DeinstallSitePartSetup Class


DeinstallSitePart(DeinstallSitePartSetup,IDbTransaction) Method | fcSDK Documentation

DeinstallSitePart(DeinstallSitePartSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to de-install a site part (and the sub-parts installed underneath it) from a site. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function DeinstallSitePart( _
   ByVal _setupParam_ As DeinstallSitePartSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult DeinstallSitePart(
   DeinstallSitePartSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


DeleteAppointment Method | fcSDK Documentation

DeleteAppointment Method

Overload List

Overload | Description
DeleteAppointment(Int32) |
DeleteAppointment(DeleteAppointmentSetup) |
DeleteAppointment(DeleteAppointmentSetup,IDbTransaction) | Used to delete an existing appointment. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class FieldOpsToolkit Members DeleteAppointmentSetup Class


DeleteAppointment(Int32) Method | fcSDK Documentation

DeleteAppointment(Int32) Method

The Objid of the Appointment being deleted.

Syntax

'Declaration

Public Overloads Function DeleteAppointment( _
   ByVal _appointmentObjid_ As Integer _
) As ToolkitResult

public ToolkitResult DeleteAppointment(
   int _appointmentObjid_
)

Parameters

appointmentObjid

The Objid of the Appointment being deleted.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


DeleteAppointment(DeleteAppointmentSetup) Method | fcSDK Documentation

DeleteAppointment(DeleteAppointmentSetup) Method

Setup object for API invocation.

Syntax

'Declaration

Public Overloads Function DeleteAppointment( _
   ByVal _setupParam_ DeleteAppointmentSetup _
) As ToolkitResult

public ToolkitResult DeleteAppointment(
   DeleteAppointmentSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List
DeleteAppointmentSetup Class


DeleteAppointment(DeleteAppointmentSetup,IDbTransaction) Method | fcSDK Documentation

DeleteAppointment(DeleteAppointmentSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to delete an existing appointment. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function DeleteAppointment( _
   ByVal _setupParam_ As DeleteAppointmentSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult DeleteAppointment(
   DeleteAppointmentSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


DeleteExpenseLog Method | fcSDK Documentation

DeleteExpenseLog Method

Overload List

Overload | Description
DeleteExpenseLog(Int32) |
DeleteExpenseLog(DeleteExpenseLogSetup) |
DeleteExpenseLog(DeleteExpenseLogSetup,IDbTransaction) | Used to delete an existing expense log. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class FieldOpsToolkit Members DeleteExpenseLogSetup Class


DeleteExpenseLog(Int32) Method | fcSDK Documentation

DeleteExpenseLog(Int32) Method

The Objid of the Expense Log being deleted.

Syntax

'Declaration

Public Overloads Function DeleteExpenseLog( _
   ByVal _expenseLogObjid_ As Integer _
) As ToolkitResult

public ToolkitResult DeleteExpenseLog(
   int _expenseLogObjid_
)

Parameters

expenseLogObjid

The Objid of the Expense Log being deleted.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


DeleteExpenseLog(DeleteExpenseLogSetup) Method | fcSDK Documentation

DeleteExpenseLog(DeleteExpenseLogSetup) Method

Setup object for API invocation.

Syntax

'Declaration

Public Overloads Function DeleteExpenseLog( _
   ByVal _setupParam_ DeleteExpenseLogSetup _
) As ToolkitResult

public ToolkitResult DeleteExpenseLog(
   DeleteExpenseLogSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List
DeleteExpenseLogSetup Class


DeleteExpenseLog(DeleteExpenseLogSetup,IDbTransaction) Method | fcSDK Documentation

DeleteExpenseLog(DeleteExpenseLogSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to delete an existing expense log. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function DeleteExpenseLog( _
   ByVal _setupParam_ As DeleteExpenseLogSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult DeleteExpenseLog(
   DeleteExpenseLogSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


DeleteOnsiteLog Method | fcSDK Documentation

DeleteOnsiteLog Method

Overload List

Overload | Description
DeleteOnsiteLog(Int32) |
DeleteOnsiteLog(DeleteOnsiteLogSetup) |
DeleteOnsiteLog(DeleteOnsiteLogSetup,IDbTransaction) | Used to delete an existing onsite log. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class FieldOpsToolkit Members DeleteOnsiteLogSetup Class


DeleteOnsiteLog(Int32) Method | fcSDK Documentation

DeleteOnsiteLog(Int32) Method

The Objid of the Onsite Log being deleted.

Syntax

'Declaration

Public Overloads Function DeleteOnsiteLog( _
   ByVal _onsiteLogObjid_ As Integer _
) As ToolkitResult

public ToolkitResult DeleteOnsiteLog(
   int _onsiteLogObjid_
)

Parameters

onsiteLogObjid

The Objid of the Onsite Log being deleted.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


DeleteOnsiteLog(DeleteOnsiteLogSetup) Method | fcSDK Documentation

DeleteOnsiteLog(DeleteOnsiteLogSetup) Method

Setup object for API invocation.

Syntax

'Declaration

Public Overloads Function DeleteOnsiteLog( _
   ByVal _setupParam_ DeleteOnsiteLogSetup _
) As ToolkitResult

public ToolkitResult DeleteOnsiteLog(
   DeleteOnsiteLogSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List
DeleteOnsiteLogSetup Class


DeleteOnsiteLog(DeleteOnsiteLogSetup,IDbTransaction) Method | fcSDK Documentation

DeleteOnsiteLog(DeleteOnsiteLogSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to delete an existing onsite log. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function DeleteOnsiteLog( _
   ByVal _setupParam_ As DeleteOnsiteLogSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult DeleteOnsiteLog(
   DeleteOnsiteLogSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


DeleteServiceInterruption Method | fcSDK Documentation

DeleteServiceInterruption Method

Overload List

Overload | Description
DeleteServiceInterruption(Int32) |
DeleteServiceInterruption(DeleteServiceInterruptionSetup) |
DeleteServiceInterruption(DeleteServiceInterruptionSetup,IDbTransaction) | Used to delete an existing service interuption (appointment). This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class FieldOpsToolkit Members DeleteServiceInterruptionSetup Class


DeleteServiceInterruption(Int32) Method | fcSDK Documentation

DeleteServiceInterruption(Int32) Method

The Objid of the Service Interuption being deleted.

Syntax

'Declaration

Public Overloads Function DeleteServiceInterruption( _
   ByVal _appointmentObjid_ As Integer _
) As ToolkitResult

public ToolkitResult DeleteServiceInterruption(
   int _appointmentObjid_
)

Parameters

appointmentObjid

The Objid of the Service Interuption being deleted.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


DeleteServiceInterruption(DeleteServiceInterruptionSetup) Method | fcSDK Documentation

DeleteServiceInterruption(DeleteServiceInterruptionSetup) Method

Setup object for API invocation.

Syntax

'Declaration

Public Overloads Function DeleteServiceInterruption( _
   ByVal _setupParam_ DeleteServiceInterruptionSetup _
) As ToolkitResult

public ToolkitResult DeleteServiceInterruption(
   DeleteServiceInterruptionSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List
DeleteServiceInterruptionSetup Class


DeleteServiceInterruption(DeleteServiceInterruptionSetup,IDbTransaction) Method | fcSDK Documentation

DeleteServiceInterruption(DeleteServiceInterruptionSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to delete an existing service interuption (appointment). This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function DeleteServiceInterruption( _
   ByVal _setupParam_ As DeleteServiceInterruptionSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult DeleteServiceInterruption(
   DeleteServiceInterruptionSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


DeleteTimeLog Method | fcSDK Documentation

DeleteTimeLog Method

Overload List

Overload | Description
DeleteTimeLog(Int32) |
DeleteTimeLog(DeleteTimeLogSetup) |
DeleteTimeLog(DeleteTimeLogSetup,IDbTransaction) | This API deletes an existing time log. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class FieldOpsToolkit Members DeleteTimeLogSetup Class


DeleteTimeLog(Int32) Method | fcSDK Documentation

DeleteTimeLog(Int32) Method

The Objid of the Time Log being deleted.

Syntax

'Declaration

Public Overloads Function DeleteTimeLog( _
   ByVal _timeLogObjid_ As Integer _
) As ToolkitResult

public ToolkitResult DeleteTimeLog(
   int _timeLogObjid_
)

Parameters

timeLogObjid

The Objid of the Time Log being deleted.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


DeleteTimeLog(DeleteTimeLogSetup) Method | fcSDK Documentation

DeleteTimeLog(DeleteTimeLogSetup) Method

Setup object for API invocation.

Syntax

'Declaration

Public Overloads Function DeleteTimeLog( _
   ByVal _setupParam_ DeleteTimeLogSetup _
) As ToolkitResult

public ToolkitResult DeleteTimeLog(
   DeleteTimeLogSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List
DeleteTimeLogSetup Class


DeleteTimeLog(DeleteTimeLogSetup,IDbTransaction) Method | fcSDK Documentation

DeleteTimeLog(DeleteTimeLogSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

This API deletes an existing time log. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function DeleteTimeLog( _
   ByVal _setupParam_ As DeleteTimeLogSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult DeleteTimeLog(
   DeleteTimeLogSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


DispatchFieldEngineer Method | fcSDK Documentation

DispatchFieldEngineer Method

Overload List

Overload | Description
DispatchFieldEngineer(String) | Dispatch the FieldEngineer to the specified queue. This overload takes a set of required parameters for the API.
DispatchFieldEngineer(DispatchFieldEngineerSetup) | Dispatch the FieldEngineer to the specified queue. This overload takes a setup object.
DispatchFieldEngineer(DispatchFieldEngineerSetup,IDbTransaction) | Used to create a work order to dispatch a field engineer to a site. This overload takes a setup object and a database transaction.

Remarks

The contact and site for the dispatch will be derived from the case/subcase. If this is not correct, the address for the site for the dispatch can be specified in the site id field. If some of the contact or site information need to be overridden, the phone and address fields are used to pass in the new information.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class FieldOpsToolkit Members DispatchFieldEngineerSetup Class


DispatchFieldEngineer(String) Method | fcSDK Documentation

DispatchFieldEngineer(String) Method

The identifier of the Case with which this Dispatch FE is associated

Dispatch the FieldEngineer to the specified queue. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function DispatchFieldEngineer( _
   ByVal _caseIDNum_ As String _
) As ToolkitResult

public ToolkitResult DispatchFieldEngineer(
   string _caseIDNum_
)

Parameters

caseIDNum

The identifier of the Case with which this Dispatch FE is associated

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - Objid of the Dispatch FE record.

Remarks

The FieldEngineer must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


DispatchFieldEngineer(DispatchFieldEngineerSetup) Method | fcSDK Documentation

DispatchFieldEngineer(DispatchFieldEngineerSetup) Method

Setup object for API invocation.

Dispatch the FieldEngineer to the specified queue. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function DispatchFieldEngineer( _
   ByVal _setupParam_ DispatchFieldEngineerSetup _
) As ToolkitResult

public ToolkitResult DispatchFieldEngineer(
   DispatchFieldEngineerSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - Objid of the Dispatch FE record.

Remarks

The FieldEngineer must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List
DispatchFieldEngineerSetup Class


DispatchFieldEngineer(DispatchFieldEngineerSetup,IDbTransaction) Method | fcSDK Documentation

DispatchFieldEngineer(DispatchFieldEngineerSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to create a work order to dispatch a field engineer to a site. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function DispatchFieldEngineer( _
   ByVal _setupParam_ As DispatchFieldEngineerSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult DispatchFieldEngineer(
   DispatchFieldEngineerSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The contact and site for the dispatch will be derived from the case/subcase. If this is not correct, the address for the site for the dispatch can be specified in the site id field. If some of the contact or site information need to be overridden, the phone and address fields are used to pass in the new information.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


InstallSitePart Method | fcSDK Documentation

InstallSitePart Method

Overload List

Overload | Description
InstallSitePart(String,String,String,String,Int32) |
InstallSitePart(String,String,String,String,String) |
InstallSitePart(InstallSitePartSetup) |
InstallSitePart(InstallSitePartSetup,IDbTransaction) | Used to install a site part. This overload takes a setup object and a database transaction.

Remarks

The part can be installed at the top level of the site, under another site part or in a bin. If the part revision to be installed has a bill of materials (BOM), that BOM will also be installed at the site under the new site part. If the sub-parts are serial tracked, the API will generate the proper new serial numbers for the sub-parts. If the part to be installed is serialized, and the quantity is > 1, the API will generate individual parts (sub-parts only).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class FieldOpsToolkit Members InstallSitePartSetup Class


InstallSitePart(String,String,String,String,Int32) Method | fcSDK Documentation

InstallSitePart(String,String,String,String,Int32) Method

The Site Id of the Parent Site where the Site Part is being installed.

Part Number of the Site Part

Part Revision of the Site Part

Part Domain of the Site Part

The Quantity of the Site Part being installed.

Syntax

'Declaration

Public Overloads Function InstallSitePart( _
   ByVal _siteIDNum_ As String, _
   ByVal _partNumber_ As String, _
   ByVal _partrevision_ As String, _
   ByVal _partdomain_ As String, _
   ByVal _quantity_ As Integer _
) As ToolkitResult

public ToolkitResult InstallSitePart(
   string _siteIDNum_,
   string _partNumber_,
   string _partrevision_,
   string _partdomain_,
   int _quantity_
)

Parameters

siteIDNum

The Site Id of the Parent Site where the Site Part is being installed.

partNumber

Part Number of the Site Part

partrevision

Part Revision of the Site Part

partdomain

Part Domain of the Site Part

quantity

The Quantity of the Site Part being installed.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the SitePart.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


InstallSitePart(String,String,String,String,String) Method | fcSDK Documentation

InstallSitePart(String,String,String,String,String) Method

The Site Id of the Parent Site where the Site Part is being installed.

Part Number of the Site Part

Part Revision of the Site Part

Part Domain of the Site Part

Serial Number of the Site Part

Syntax

'Declaration

Public Overloads Function InstallSitePart( _
   ByVal _siteIDNum_ As String, _
   ByVal _partNumber_ As String, _
   ByVal _partrevision_ As String, _
   ByVal _partdomain_ As String, _
   ByVal _serialNumber_ As String _
) As ToolkitResult

public ToolkitResult InstallSitePart(
   string _siteIDNum_,
   string _partNumber_,
   string _partrevision_,
   string _partdomain_,
   string _serialNumber_
)

Parameters

siteIDNum

The Site Id of the Parent Site where the Site Part is being installed.

partNumber

Part Number of the Site Part

partrevision

Part Revision of the Site Part

partdomain

Part Domain of the Site Part

serialNumber

Serial Number of the Site Part

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the SitePart.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


InstallSitePart(InstallSitePartSetup) Method | fcSDK Documentation

InstallSitePart(InstallSitePartSetup) Method

Setup object for API invocation.

Syntax

'Declaration

Public Overloads Function InstallSitePart( _
   ByVal _setupParam_ InstallSitePartSetup _
) As ToolkitResult

public ToolkitResult InstallSitePart(
   InstallSitePartSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the SitePart.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List
InstallSitePartSetup Class


InstallSitePart(InstallSitePartSetup,IDbTransaction) Method | fcSDK Documentation

InstallSitePart(InstallSitePartSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to install a site part. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function InstallSitePart( _
   ByVal _setupParam_ As InstallSitePartSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult InstallSitePart(
   InstallSitePartSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The part can be installed at the top level of the site, under another site part or in a bin. If the part revision to be installed has a bill of materials (BOM), that BOM will also be installed at the site under the new site part. If the sub-parts are serial tracked, the API will generate the proper new serial numbers for the sub-parts. If the part to be installed is serialized, and the quantity is > 1, the API will generate individual parts (sub-parts only).

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


LogPartsUsedConsume Method | fcSDK Documentation

LogPartsUsedConsume Method

Overload List

Overload | Description
LogPartsUsedConsume(String,String,String,String,String) |
LogPartsUsedConsume(String,String,String,String,Int32) |
LogPartsUsedConsume(String,String,String,String,String,String) |
LogPartsUsedConsume(String,String,String,String,String,Int32) |
LogPartsUsedConsume(LogPartsUsedConsumeSetup) |
LogPartsUsedConsume(LogPartsUsedConsumeSetup,IDbTransaction) | Used to consume an existing site part or an inventory part. This overload takes a setup object and a database transaction.

Remarks

Each log parts used transaction must be related to either a case or a part request detail. If it is related to both, the part request detail must be linked to the case.

Both serialized and quantity-tracked parts can be logged, and the API performs all of the correct operations, based on the serial number/quantity fields.

For the site part being installed, the part number, revision (mod_level), and domain must be specified. Also, the quantity and/or serial number should be supplied. Optionally, the installed part’s price can be specified, and the “InstallAtSite” should be specified to determine if it is installed at the top-level of the site, or under another site part. In the latter case, the objid of the parent site part must be specified. Optionally, the part to be installed can be pulled from inventory (or an Expense GL account) by specifying the “from” fields.

If a part is to be installed (serialized parts only), and already exists in the system as a site part, it will be moved (not installed). This assumes that the “allow_move” flag is set to True. If not, an error code is produced.

When the log parts used action occurs, the API will change the condition of the part request (if one is listed in the arguments) to either the condition of: Part Used or Update Inv. If there are no inventory movements, the former condition will be used. If either the install or remove part are moved to/from inventory, the condition will be set to Update Inv. In both cases, the API will set the status of the part request to the default status for the condition, and will validate the ClearLogistics transitions to make sure that the user who is logging the action can perform the state transition.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class FieldOpsToolkit Members LogPartsUsedConsumeSetup Class


LogPartsUsedConsume(String,String,String,String,String) Method | fcSDK Documentation

LogPartsUsedConsume(String,String,String,String,String) Method

The Id Number of the related Part Request Detail (if any)

The Part Number of the part being installed

The Part Revision of the part being installed

The Part Domain of the part being installed

The Serial Number of the part being installed

Syntax

'Declaration

Public Overloads Function LogPartsUsedConsume( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _installPartNumber_ As String, _
   ByVal _installPartRevision_ As String, _
   ByVal _installPartDomain_ As String, _
   ByVal _installSerialNumber_ As String _
) As ToolkitResult

public ToolkitResult LogPartsUsedConsume(
   string _partRequestDetailIDNum_,
   string _installPartNumber_,
   string _installPartRevision_,
   string _installPartDomain_,
   string _installSerialNumber_
)

Parameters

partRequestDetailIDNum

The Id Number of the related Part Request Detail (if any)

installPartNumber

The Part Number of the part being installed

installPartRevision

The Part Revision of the part being installed

installPartDomain

The Part Domain of the part being installed

installSerialNumber

The Serial Number of the part being installed

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the PartUsed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


LogPartsUsedConsume(String,String,String,String,Int32) Method | fcSDK Documentation

LogPartsUsedConsume(String,String,String,String,Int32) Method

The Id Number of the related Part Request Detail (if any)

The Part Number of the part being installed

The Part Revision of the part being installed

The Part Domain of the part being installed

The Quantity of the part being installed

Syntax

'Declaration

Public Overloads Function LogPartsUsedConsume( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _installPartNumber_ As String, _
   ByVal _installPartRevision_ As String, _
   ByVal _installPartDomain_ As String, _
   ByVal _installQuantity_ As Integer _
) As ToolkitResult

public ToolkitResult LogPartsUsedConsume(
   string _partRequestDetailIDNum_,
   string _installPartNumber_,
   string _installPartRevision_,
   string _installPartDomain_,
   int _installQuantity_
)

Parameters

partRequestDetailIDNum

The Id Number of the related Part Request Detail (if any)

installPartNumber

The Part Number of the part being installed

installPartRevision

The Part Revision of the part being installed

installPartDomain

The Part Domain of the part being installed

installQuantity

The Quantity of the part being installed

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the PartUsed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


LogPartsUsedConsume(String,String,String,String,String,String) Method | fcSDK Documentation

LogPartsUsedConsume(String,String,String,String,String,String) Method

The Id Number of the related Part Request Detail (if any)

The identifier of the Case with which this Part Usage is associated

The Part Number of the part being installed

The Part Revision of the part being installed

The Part Domain of the part being installed

The Serial Number of the part being installed

Syntax

'Declaration

Public Overloads Function LogPartsUsedConsume( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _caseIDNum_ As String, _
   ByVal _installPartNumber_ As String, _
   ByVal _installPartRevision_ As String, _
   ByVal _installPartDomain_ As String, _
   ByVal _installSerialNumber_ As String _
) As ToolkitResult

public ToolkitResult LogPartsUsedConsume(
   string _partRequestDetailIDNum_,
   string _caseIDNum_,
   string _installPartNumber_,
   string _installPartRevision_,
   string _installPartDomain_,
   string _installSerialNumber_
)

Parameters

partRequestDetailIDNum

The Id Number of the related Part Request Detail (if any)

caseIDNum

The identifier of the Case with which this Part Usage is associated

installPartNumber

The Part Number of the part being installed

installPartRevision

The Part Revision of the part being installed

installPartDomain

The Part Domain of the part being installed

installSerialNumber

The Serial Number of the part being installed

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the PartUsed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


LogPartsUsedConsume(String,String,String,String,String,Int32) Method | fcSDK Documentation

LogPartsUsedConsume(String,String,String,String,String,Int32) Method

The Id Number of the related Part Request Detail (if any)

The identifier of the Case with which this Part Usage is associated

The Part Number of the part being installed

The Part Revision of the part being installed

The Part Domain of the part being installed

The Quantity of the part being installed

Syntax

'Declaration

Public Overloads Function LogPartsUsedConsume( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _caseIDNum_ As String, _
   ByVal _installPartNumber_ As String, _
   ByVal _installPartRevision_ As String, _
   ByVal _installPartDomain_ As String, _
   ByVal _installQuantity_ As Integer _
) As ToolkitResult

public ToolkitResult LogPartsUsedConsume(
   string _partRequestDetailIDNum_,
   string _caseIDNum_,
   string _installPartNumber_,
   string _installPartRevision_,
   string _installPartDomain_,
   int _installQuantity_
)

Parameters

partRequestDetailIDNum

The Id Number of the related Part Request Detail (if any)

caseIDNum

The identifier of the Case with which this Part Usage is associated

installPartNumber

The Part Number of the part being installed

installPartRevision

The Part Revision of the part being installed

installPartDomain

The Part Domain of the part being installed

installQuantity

The Quantity of the part being installed

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the PartUsed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


LogPartsUsedConsume(LogPartsUsedConsumeSetup) Method | fcSDK Documentation

LogPartsUsedConsume(LogPartsUsedConsumeSetup) Method

Setup object for API invocation.

Syntax

'Declaration

Public Overloads Function LogPartsUsedConsume( _
   ByVal _setupParam_ LogPartsUsedConsumeSetup _
) As ToolkitResult

public ToolkitResult LogPartsUsedConsume(
   LogPartsUsedConsumeSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the PartUsed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List
LogPartsUsedConsumeSetup Class


LogPartsUsedConsume(LogPartsUsedConsumeSetup,IDbTransaction) Method | fcSDK Documentation

LogPartsUsedConsume(LogPartsUsedConsumeSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to consume an existing site part or an inventory part. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function LogPartsUsedConsume( _
   ByVal _setupParam_ As LogPartsUsedConsumeSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult LogPartsUsedConsume(
   LogPartsUsedConsumeSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

Each log parts used transaction must be related to either a case or a part request detail. If it is related to both, the part request detail must be linked to the case.

Both serialized and quantity-tracked parts can be logged, and the API performs all of the correct operations, based on the serial number/quantity fields.

For the site part being installed, the part number, revision (mod_level), and domain must be specified. Also, the quantity and/or serial number should be supplied. Optionally, the installed part’s price can be specified, and the “InstallAtSite” should be specified to determine if it is installed at the top-level of the site, or under another site part. In the latter case, the objid of the parent site part must be specified. Optionally, the part to be installed can be pulled from inventory (or an Expense GL account) by specifying the “from” fields.

If a part is to be installed (serialized parts only), and already exists in the system as a site part, it will be moved (not installed). This assumes that the “allow_move” flag is set to True. If not, an error code is produced.

When the log parts used action occurs, the API will change the condition of the part request (if one is listed in the arguments) to either the condition of: Part Used or Update Inv. If there are no inventory movements, the former condition will be used. If either the install or remove part are moved to/from inventory, the condition will be set to Update Inv. In both cases, the API will set the status of the part request to the default status for the condition, and will validate the ClearLogistics transitions to make sure that the user who is logging the action can perform the state transition.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


LogPartsUsedExchange Method | fcSDK Documentation

LogPartsUsedExchange Method

Overload List

Overload | Description
LogPartsUsedExchange(String,Int32,String,String,String,String) |
LogPartsUsedExchange(String,Int32,String,String,String,Int32) |
LogPartsUsedExchange(String,String,Int32,String,String,String,String) |
LogPartsUsedExchange(String,String,Int32,String,String,String,Int32) |
LogPartsUsedExchange(LogPartsUsedExchangeSetup) |
LogPartsUsedExchange(LogPartsUsedExchangeSetup,IDbTransaction) | Used to replace an existing site part with a new site part. This overload takes a setup object and a database transaction.

Remarks

Each log parts used transaction must be related to either a case or a part request detail. If it is related to both, the part request detail must be linked to the case.

Both serialized and quantity-tracked parts can be logged, and the API performs all of the correct operations, based on the serial number/quantity fields.

For the site part being installed, the part number, revision (mod_level), and domain must be specified. Also, the quantity and/or serial number should be supplied. Optionally, the installed part’s price can be specified, and the “InstallAtSite” should be specified to determine if it is installed at the top-level of the site, or under another site part. In the latter case, the objid of the parent site part must be specified. Optionally, the part to be installed can be pulled from inventory (or an Expense GL account) by specifying the “from” fields.

If a part is to be installed (serialized parts only), and already exists in the system as a site part, it will be moved (not installed). This assumes that the “allow_move” flag is set to True. If not, an error code is produced.

For the site part being removed, the objid of the part to be removed must be specified. Optionally, a removed part may be placed back in inventory. If the “to” fields for location, bin, and good/bad are specified, the part will be put back in inventory. It can also be transferred to an Expense GL account.

When the log parts used action occurs, the API will change the condition of the part request (if one is listed in the arguments) to either the condition of: Part Used or Update Inv. If there are no inventory movements, the former condition will be used. If either the install or remove part are moved to/from inventory, the condition will be set to Update Inv. In both cases, the API will set the status of the part request to the default status for the condition, and will validate the ClearLogistics transitions to make sure that the user who is logging the action can perform the state transition.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class FieldOpsToolkit Members LogPartsUsedExchangeSetup Class


LogPartsUsedExchange(String,Int32,String,String,String,String) Method | fcSDK Documentation

LogPartsUsedExchange(String,Int32,String,String,String,String) Method

The Id Number of the related Part Request Detail (if any)

The Objid of the Site Part being removed.

The Part Number of the part being installed

The Part Revision of the part being installed

The Part Domain of the part being installed

The Serial Number of the part being installed

Syntax

'Declaration

Public Overloads Function LogPartsUsedExchange( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _removeSitePartObjid_ As Integer, _
   ByVal _installPartNumber_ As String, _
   ByVal _installPartRevision_ As String, _
   ByVal _installPartDomain_ As String, _
   ByVal _installSerialNumber_ As String _
) As ToolkitResult

public ToolkitResult LogPartsUsedExchange(
   string _partRequestDetailIDNum_,
   int _removeSitePartObjid_,
   string _installPartNumber_,
   string _installPartRevision_,
   string _installPartDomain_,
   string _installSerialNumber_
)

Parameters

partRequestDetailIDNum

The Id Number of the related Part Request Detail (if any)

removeSitePartObjid

The Objid of the Site Part being removed.

installPartNumber

The Part Number of the part being installed

installPartRevision

The Part Revision of the part being installed

installPartDomain

The Part Domain of the part being installed

installSerialNumber

The Serial Number of the part being installed

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the PartUsed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


LogPartsUsedExchange(String,Int32,String,String,String,Int32) Method | fcSDK Documentation

LogPartsUsedExchange(String,Int32,String,String,String,Int32) Method

The Id Number of the related Part Request Detail (if any)

The Objid of the Site Part being removed.

The Part Number of the part being installed

The Part Revision of the part being installed

The Part Domain of the part being installed

The Quantity of the part being installed

Syntax

'Declaration

Public Overloads Function LogPartsUsedExchange( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _removeSitePartObjid_ As Integer, _
   ByVal _installPartNumber_ As String, _
   ByVal _installPartRevision_ As String, _
   ByVal _installPartDomain_ As String, _
   ByVal _installQuantity_ As Integer _
) As ToolkitResult

public ToolkitResult LogPartsUsedExchange(
   string _partRequestDetailIDNum_,
   int _removeSitePartObjid_,
   string _installPartNumber_,
   string _installPartRevision_,
   string _installPartDomain_,
   int _installQuantity_
)

Parameters

partRequestDetailIDNum

The Id Number of the related Part Request Detail (if any)

removeSitePartObjid

The Objid of the Site Part being removed.

installPartNumber

The Part Number of the part being installed

installPartRevision

The Part Revision of the part being installed

installPartDomain

The Part Domain of the part being installed

installQuantity

The Quantity of the part being installed

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the PartUsed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


LogPartsUsedExchange(String,String,Int32,String,String,String,String) Method | fcSDK Documentation

LogPartsUsedExchange(String,String,Int32,String,String,String,String) Method

The Id Number of the related Part Request Detail (if any)

The identifier of the Case with which this Part Usage is associated

The Objid of the Site Part being removed.

The Part Number of the part being installed

The Part Revision of the part being installed

The Part Domain of the part being installed

The Serial Number of the part being installed

Syntax

'Declaration

Public Overloads Function LogPartsUsedExchange( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _caseIDNum_ As String, _
   ByVal _removeSitePartObjid_ As Integer, _
   ByVal _installPartNumber_ As String, _
   ByVal _installPartRevision_ As String, _
   ByVal _installPartDomain_ As String, _
   ByVal _installSerialNumber_ As String _
) As ToolkitResult

public ToolkitResult LogPartsUsedExchange(
   string _partRequestDetailIDNum_,
   string _caseIDNum_,
   int _removeSitePartObjid_,
   string _installPartNumber_,
   string _installPartRevision_,
   string _installPartDomain_,
   string _installSerialNumber_
)

Parameters

partRequestDetailIDNum

The Id Number of the related Part Request Detail (if any)

caseIDNum

The identifier of the Case with which this Part Usage is associated

removeSitePartObjid

The Objid of the Site Part being removed.

installPartNumber

The Part Number of the part being installed

installPartRevision

The Part Revision of the part being installed

installPartDomain

The Part Domain of the part being installed

installSerialNumber

The Serial Number of the part being installed

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the PartUsed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


LogPartsUsedExchange(String,String,Int32,String,String,String,Int32) Method | fcSDK Documentation

LogPartsUsedExchange(String,String,Int32,String,String,String,Int32) Method

The Id Number of the related Part Request Detail (if any)

The identifier of the Case with which this Part Usage is associated

The Objid of the Site Part being removed.

The Part Number of the part being installed

The Part Revision of the part being installed

The Part Domain of the part being installed

The Quantity of the part being installed

Syntax

'Declaration

Public Overloads Function LogPartsUsedExchange( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _caseIDNum_ As String, _
   ByVal _removeSitePartObjid_ As Integer, _
   ByVal _installPartNumber_ As String, _
   ByVal _installPartRevision_ As String, _
   ByVal _installPartDomain_ As String, _
   ByVal _installQuantity_ As Integer _
) As ToolkitResult

public ToolkitResult LogPartsUsedExchange(
   string _partRequestDetailIDNum_,
   string _caseIDNum_,
   int _removeSitePartObjid_,
   string _installPartNumber_,
   string _installPartRevision_,
   string _installPartDomain_,
   int _installQuantity_
)

Parameters

partRequestDetailIDNum

The Id Number of the related Part Request Detail (if any)

caseIDNum

The identifier of the Case with which this Part Usage is associated

removeSitePartObjid

The Objid of the Site Part being removed.

installPartNumber

The Part Number of the part being installed

installPartRevision

The Part Revision of the part being installed

installPartDomain

The Part Domain of the part being installed

installQuantity

The Quantity of the part being installed

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the PartUsed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


LogPartsUsedExchange(LogPartsUsedExchangeSetup) Method | fcSDK Documentation

LogPartsUsedExchange(LogPartsUsedExchangeSetup) Method

Setup object for API invocation.

Syntax

'Declaration

Public Overloads Function LogPartsUsedExchange( _
   ByVal _setupParam_ LogPartsUsedExchangeSetup _
) As ToolkitResult

public ToolkitResult LogPartsUsedExchange(
   LogPartsUsedExchangeSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the PartUsed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List
LogPartsUsedExchangeSetup Class


LogPartsUsedExchange(LogPartsUsedExchangeSetup,IDbTransaction) Method | fcSDK Documentation

LogPartsUsedExchange(LogPartsUsedExchangeSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to replace an existing site part with a new site part. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function LogPartsUsedExchange( _
   ByVal _setupParam_ As LogPartsUsedExchangeSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult LogPartsUsedExchange(
   LogPartsUsedExchangeSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

Each log parts used transaction must be related to either a case or a part request detail. If it is related to both, the part request detail must be linked to the case.

Both serialized and quantity-tracked parts can be logged, and the API performs all of the correct operations, based on the serial number/quantity fields.

For the site part being installed, the part number, revision (mod_level), and domain must be specified. Also, the quantity and/or serial number should be supplied. Optionally, the installed part’s price can be specified, and the “InstallAtSite” should be specified to determine if it is installed at the top-level of the site, or under another site part. In the latter case, the objid of the parent site part must be specified. Optionally, the part to be installed can be pulled from inventory (or an Expense GL account) by specifying the “from” fields.

If a part is to be installed (serialized parts only), and already exists in the system as a site part, it will be moved (not installed). This assumes that the “allow_move” flag is set to True. If not, an error code is produced.

For the site part being removed, the objid of the part to be removed must be specified. Optionally, a removed part may be placed back in inventory. If the “to” fields for location, bin, and good/bad are specified, the part will be put back in inventory. It can also be transferred to an Expense GL account.

When the log parts used action occurs, the API will change the condition of the part request (if one is listed in the arguments) to either the condition of: Part Used or Update Inv. If there are no inventory movements, the former condition will be used. If either the install or remove part are moved to/from inventory, the condition will be set to Update Inv. In both cases, the API will set the status of the part request to the default status for the condition, and will validate the ClearLogistics transitions to make sure that the user who is logging the action can perform the state transition.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


LogPartsUsedInstall Method | fcSDK Documentation

LogPartsUsedInstall Method

Overload List

Overload | Description
LogPartsUsedInstall(String,String,String,String,String) |
LogPartsUsedInstall(String,String,String,String,Int32) |
LogPartsUsedInstall(String,String,String,String,String,String) |
LogPartsUsedInstall(String,String,String,String,String,Int32) |
LogPartsUsedInstall(LogPartsUsedInstallSetup) |
LogPartsUsedInstall(LogPartsUsedInstallSetup,IDbTransaction) | Used to install a new site part. This overload takes a setup object and a database transaction.

Remarks

Each log parts used transaction must be related to either a case or a part request detail. If it is related to both, the part request detail must be linked to the case.

Both serialized and quantity-tracked parts can be logged, and the API performs all of the correct operations, based on the serial number/quantity fields.

For the site part being installed, the part number, revision (mod_level), and domain must be specified. Also, the quantity and/or serial number should be supplied. Optionally, the installed part’s price can be specified, and the “InstallAtSite” should be specified to determine if it is installed at the top-level of the site, or under another site part. In the latter case, the objid of the parent site part must be specified. Optionally, the part to be installed can be pulled from inventory (or an Expense GL account) by specifying the “from” fields.

If a part is to be installed (serialized parts only), and already exists in the system as a site part, it will be moved (not installed). This assumes that the “allow_move” flag is set to True. If not, an error code is produced.

When the log parts used action occurs, the API will change the condition of the part request (if one is listed in the arguments) to either the condition of: Part Used or Update Inv. If there are no inventory movements, the former condition will be used. If either the install or remove part are moved to/from inventory, the condition will be set to Update Inv. In both cases, the API will set the status of the part request to the default status for the condition, and will validate the ClearLogistics transitions to make sure that the user who is logging the action can perform the state transition.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class FieldOpsToolkit Members LogPartsUsedInstallSetup Class


LogPartsUsedInstall(String,String,String,String,String) Method | fcSDK Documentation

LogPartsUsedInstall(String,String,String,String,String) Method

The Id Number of the related Part Request Detail (if any)

The Part Number of the part being installed

The Part Revision of the part being installed

The Part Domain of the part being installed

The Serial Number of the part being installed

Syntax

'Declaration

Public Overloads Function LogPartsUsedInstall( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _installPartNumber_ As String, _
   ByVal _installPartRevision_ As String, _
   ByVal _installPartDomain_ As String, _
   ByVal _installSerialNumber_ As String _
) As ToolkitResult

public ToolkitResult LogPartsUsedInstall(
   string _partRequestDetailIDNum_,
   string _installPartNumber_,
   string _installPartRevision_,
   string _installPartDomain_,
   string _installSerialNumber_
)

Parameters

partRequestDetailIDNum

The Id Number of the related Part Request Detail (if any)

installPartNumber

The Part Number of the part being installed

installPartRevision

The Part Revision of the part being installed

installPartDomain

The Part Domain of the part being installed

installSerialNumber

The Serial Number of the part being installed

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the PartUsed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


LogPartsUsedInstall(String,String,String,String,Int32) Method | fcSDK Documentation

LogPartsUsedInstall(String,String,String,String,Int32) Method

The Id Number of the related Part Request Detail (if any)

The Part Number of the part being installed

The Part Revision of the part being installed

The Part Domain of the part being installed

The Quantity of the part being installed

Syntax

'Declaration

Public Overloads Function LogPartsUsedInstall( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _installPartNumber_ As String, _
   ByVal _installPartRevision_ As String, _
   ByVal _installPartDomain_ As String, _
   ByVal _installQuantity_ As Integer _
) As ToolkitResult

public ToolkitResult LogPartsUsedInstall(
   string _partRequestDetailIDNum_,
   string _installPartNumber_,
   string _installPartRevision_,
   string _installPartDomain_,
   int _installQuantity_
)

Parameters

partRequestDetailIDNum

The Id Number of the related Part Request Detail (if any)

installPartNumber

The Part Number of the part being installed

installPartRevision

The Part Revision of the part being installed

installPartDomain

The Part Domain of the part being installed

installQuantity

The Quantity of the part being installed

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the PartUsed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


LogPartsUsedInstall(String,String,String,String,String,String) Method | fcSDK Documentation

LogPartsUsedInstall(String,String,String,String,String,String) Method

The Id Number of the related Part Request Detail (if any)

The identifier of the Case with which this Part Usage is associated

The Part Number of the part being installed

The Part Revision of the part being installed

The Part Domain of the part being installed

The Serial Number of the part being installed

Syntax

'Declaration

Public Overloads Function LogPartsUsedInstall( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _caseIDNum_ As String, _
   ByVal _installPartNumber_ As String, _
   ByVal _installPartRevision_ As String, _
   ByVal _installPartDomain_ As String, _
   ByVal _installSerialNumber_ As String _
) As ToolkitResult

public ToolkitResult LogPartsUsedInstall(
   string _partRequestDetailIDNum_,
   string _caseIDNum_,
   string _installPartNumber_,
   string _installPartRevision_,
   string _installPartDomain_,
   string _installSerialNumber_
)

Parameters

partRequestDetailIDNum

The Id Number of the related Part Request Detail (if any)

caseIDNum

The identifier of the Case with which this Part Usage is associated

installPartNumber

The Part Number of the part being installed

installPartRevision

The Part Revision of the part being installed

installPartDomain

The Part Domain of the part being installed

installSerialNumber

The Serial Number of the part being installed

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the PartUsed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


LogPartsUsedInstall(String,String,String,String,String,Int32) Method | fcSDK Documentation

LogPartsUsedInstall(String,String,String,String,String,Int32) Method

The Id Number of the related Part Request Detail (if any)

The identifier of the Case with which this Part Usage is associated

The Part Number of the part being installed

The Part Revision of the part being installed

The Part Domain of the part being installed

The Quantity of the part being installed

Syntax

'Declaration

Public Overloads Function LogPartsUsedInstall( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _caseIDNum_ As String, _
   ByVal _installPartNumber_ As String, _
   ByVal _installPartRevision_ As String, _
   ByVal _installPartDomain_ As String, _
   ByVal _installQuantity_ As Integer _
) As ToolkitResult

public ToolkitResult LogPartsUsedInstall(
   string _partRequestDetailIDNum_,
   string _caseIDNum_,
   string _installPartNumber_,
   string _installPartRevision_,
   string _installPartDomain_,
   int _installQuantity_
)

Parameters

partRequestDetailIDNum

The Id Number of the related Part Request Detail (if any)

caseIDNum

The identifier of the Case with which this Part Usage is associated

installPartNumber

The Part Number of the part being installed

installPartRevision

The Part Revision of the part being installed

installPartDomain

The Part Domain of the part being installed

installQuantity

The Quantity of the part being installed

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the PartUsed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


LogPartsUsedInstall(LogPartsUsedInstallSetup) Method | fcSDK Documentation

LogPartsUsedInstall(LogPartsUsedInstallSetup) Method

Setup object for API invocation.

Syntax

'Declaration

Public Overloads Function LogPartsUsedInstall( _
   ByVal _setupParam_ LogPartsUsedInstallSetup _
) As ToolkitResult

public ToolkitResult LogPartsUsedInstall(
   LogPartsUsedInstallSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the PartUsed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List
LogPartsUsedInstallSetup Class


LogPartsUsedInstall(LogPartsUsedInstallSetup,IDbTransaction) Method | fcSDK Documentation

LogPartsUsedInstall(LogPartsUsedInstallSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to install a new site part. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function LogPartsUsedInstall( _
   ByVal _setupParam_ As LogPartsUsedInstallSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult LogPartsUsedInstall(
   LogPartsUsedInstallSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

Each log parts used transaction must be related to either a case or a part request detail. If it is related to both, the part request detail must be linked to the case.

Both serialized and quantity-tracked parts can be logged, and the API performs all of the correct operations, based on the serial number/quantity fields.

For the site part being installed, the part number, revision (mod_level), and domain must be specified. Also, the quantity and/or serial number should be supplied. Optionally, the installed part’s price can be specified, and the “InstallAtSite” should be specified to determine if it is installed at the top-level of the site, or under another site part. In the latter case, the objid of the parent site part must be specified. Optionally, the part to be installed can be pulled from inventory (or an Expense GL account) by specifying the “from” fields.

If a part is to be installed (serialized parts only), and already exists in the system as a site part, it will be moved (not installed). This assumes that the “allow_move” flag is set to True. If not, an error code is produced.

When the log parts used action occurs, the API will change the condition of the part request (if one is listed in the arguments) to either the condition of: Part Used or Update Inv. If there are no inventory movements, the former condition will be used. If either the install or remove part are moved to/from inventory, the condition will be set to Update Inv. In both cases, the API will set the status of the part request to the default status for the condition, and will validate the ClearLogistics transitions to make sure that the user who is logging the action can perform the state transition.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


LogPartsUsedRemove Method | fcSDK Documentation

LogPartsUsedRemove Method

Overload List

Overload | Description
LogPartsUsedRemove(String,Int32) |
LogPartsUsedRemove(String,String,Int32) |
LogPartsUsedRemove(LogPartsUsedRemoveSetup) |
LogPartsUsedRemove(LogPartsUsedRemoveSetup,IDbTransaction) | Used to remove an existing site part. This overload takes a setup object and a database transaction.

Remarks

Each log parts used transaction must be related to either a case or a part request detail. If it is related to both, the part request detail must be linked to the case.

Both serialized and quantity-tracked parts can be logged, and the API performs all of the correct operations, based on the serial number/quantity fields.

For the site part being removed, the objid of the part to be removed must be specified. Optionally, a removed part may be placed back in inventory. If the “to” fields for location, bin, and good/bad are specified, the part will be put back in inventory. It can also be transferred to an Expense GL account.

When the log parts used action occurs, the API will change the condition of the part request (if one is listed in the arguments) to either the condition of: Part Used or Update Inv. If there are no inventory movements, the former condition will be used. If either the install or remove part are moved to/from inventory, the condition will be set to Update Inv. In both cases, the API will set the status of the part request to the default status for the condition, and will validate the ClearLogistics transitions to make sure that the user who is logging the action can perform the state transition.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class FieldOpsToolkit Members LogPartsUsedRemoveSetup Class


LogPartsUsedRemove(String,Int32) Method | fcSDK Documentation

LogPartsUsedRemove(String,Int32) Method

The Id Number of the related Part Request Detail (if any)

The Objid of the Site Part being removed.

Syntax

'Declaration

Public Overloads Function LogPartsUsedRemove( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _removeSitePartObjid_ As Integer _
) As ToolkitResult

public ToolkitResult LogPartsUsedRemove(
   string _partRequestDetailIDNum_,
   int _removeSitePartObjid_
)

Parameters

partRequestDetailIDNum

The Id Number of the related Part Request Detail (if any)

removeSitePartObjid

The Objid of the Site Part being removed.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the PartUsed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


LogPartsUsedRemove(String,String,Int32) Method | fcSDK Documentation

LogPartsUsedRemove(String,String,Int32) Method

The Id Number of the related Part Request Detail (if any)

The identifier of the Case with which this Part Usage is associated

The Objid of the Site Part being removed.

Syntax

'Declaration

Public Overloads Function LogPartsUsedRemove( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _caseIDNum_ As String, _
   ByVal _removeSitePartObjid_ As Integer _
) As ToolkitResult

public ToolkitResult LogPartsUsedRemove(
   string _partRequestDetailIDNum_,
   string _caseIDNum_,
   int _removeSitePartObjid_
)

Parameters

partRequestDetailIDNum

The Id Number of the related Part Request Detail (if any)

caseIDNum

The identifier of the Case with which this Part Usage is associated

removeSitePartObjid

The Objid of the Site Part being removed.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the PartUsed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


LogPartsUsedRemove(LogPartsUsedRemoveSetup) Method | fcSDK Documentation

LogPartsUsedRemove(LogPartsUsedRemoveSetup) Method

Setup object for API invocation.

Syntax

'Declaration

Public Overloads Function LogPartsUsedRemove( _
   ByVal _setupParam_ LogPartsUsedRemoveSetup _
) As ToolkitResult

public ToolkitResult LogPartsUsedRemove(
   LogPartsUsedRemoveSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the PartUsed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List
LogPartsUsedRemoveSetup Class


LogPartsUsedRemove(LogPartsUsedRemoveSetup,IDbTransaction) Method | fcSDK Documentation

LogPartsUsedRemove(LogPartsUsedRemoveSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to remove an existing site part. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function LogPartsUsedRemove( _
   ByVal _setupParam_ As LogPartsUsedRemoveSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult LogPartsUsedRemove(
   LogPartsUsedRemoveSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

Each log parts used transaction must be related to either a case or a part request detail. If it is related to both, the part request detail must be linked to the case.

Both serialized and quantity-tracked parts can be logged, and the API performs all of the correct operations, based on the serial number/quantity fields.

For the site part being removed, the objid of the part to be removed must be specified. Optionally, a removed part may be placed back in inventory. If the “to” fields for location, bin, and good/bad are specified, the part will be put back in inventory. It can also be transferred to an Expense GL account.

When the log parts used action occurs, the API will change the condition of the part request (if one is listed in the arguments) to either the condition of: Part Used or Update Inv. If there are no inventory movements, the former condition will be used. If either the install or remove part are moved to/from inventory, the condition will be set to Update Inv. In both cases, the API will set the status of the part request to the default status for the condition, and will validate the ClearLogistics transitions to make sure that the user who is logging the action can perform the state transition.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


LogPartsUsedUpgrade Method | fcSDK Documentation

LogPartsUsedUpgrade Method

Overload List

Overload | Description
LogPartsUsedUpgrade(String,Int32,String,String,String,String) |
LogPartsUsedUpgrade(String,Int32,String,String,String,Int32) |
LogPartsUsedUpgrade(String,String,Int32,String,String,String,String) |
LogPartsUsedUpgrade(String,String,Int32,String,String,String,Int32) |
LogPartsUsedUpgrade(LogPartsUsedUpgradeSetup) |
LogPartsUsedUpgrade(LogPartsUsedUpgradeSetup,IDbTransaction) | Used to upgrade an existing site part with a new site part. This overload takes a setup object and a database transaction.

Remarks

Each log parts used transaction must be related to either a case or a part request detail. If it is related to both, the part request detail must be linked to the case.

Both serialized and quantity-tracked parts can be logged, and the API performs all of the correct operations, based on the serial number/quantity fields.

For the site part being installed, the part number, revision (mod_level), and domain must be specified. Also, the quantity and/or serial number should be supplied. Optionally, the installed part’s price can be specified, and the “InstallAtSite” should be specified to determine if it is installed at the top-level of the site, or under another site part. In the latter case, the objid of the parent site part must be specified. Optionally, the part to be installed can be pulled from inventory (or an Expense GL account) by specifying the “from” fields.

If a part is to be installed (serialized parts only), and already exists in the system as a site part, it will be moved (not installed). This assumes that the “allow_move” flag is set to True. If not, an error code is produced.

For the site part being removed, the objid of the part to be removed must be specified. Optionally, a removed part may be placed back in inventory. If the “to” fields for location, bin, and good/bad are specified, the part will be put back in inventory. It can also be transferred to an Expense GL account.

When the log parts used action occurs, the API will change the condition of the part request (if one is listed in the arguments) to either the condition of: Part Used or Update Inv. If there are no inventory movements, the former condition will be used. If either the install or remove part are moved to/from inventory, the condition will be set to Update Inv. In both cases, the API will set the status of the part request to the default status for the condition, and will validate the ClearLogistics transitions to make sure that the user who is logging the action can perform the state transition.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class FieldOpsToolkit Members LogPartsUsedUpgradeSetup Class


LogPartsUsedUpgrade(String,Int32,String,String,String,String) Method | fcSDK Documentation

LogPartsUsedUpgrade(String,Int32,String,String,String,String) Method

The Id Number of the related Part Request Detail (if any)

The Objid of the Site Part being removed.

The Part Number of the part being installed

The Part Revision of the part being installed

The Part Domain of the part being installed

The Serial Number of the part being installed

Syntax

'Declaration

Public Overloads Function LogPartsUsedUpgrade( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _removeSitePartObjid_ As Integer, _
   ByVal _installPartNumber_ As String, _
   ByVal _installPartRevision_ As String, _
   ByVal _installPartDomain_ As String, _
   ByVal _installSerialNumber_ As String _
) As ToolkitResult

public ToolkitResult LogPartsUsedUpgrade(
   string _partRequestDetailIDNum_,
   int _removeSitePartObjid_,
   string _installPartNumber_,
   string _installPartRevision_,
   string _installPartDomain_,
   string _installSerialNumber_
)

Parameters

partRequestDetailIDNum

The Id Number of the related Part Request Detail (if any)

removeSitePartObjid

The Objid of the Site Part being removed.

installPartNumber

The Part Number of the part being installed

installPartRevision

The Part Revision of the part being installed

installPartDomain

The Part Domain of the part being installed

installSerialNumber

The Serial Number of the part being installed

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the PartUsed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


LogPartsUsedUpgrade(String,Int32,String,String,String,Int32) Method | fcSDK Documentation

LogPartsUsedUpgrade(String,Int32,String,String,String,Int32) Method

The Id Number of the related Part Request Detail (if any)

The Objid of the Site Part being removed.

The Part Number of the part being installed

The Part Revision of the part being installed

The Part Domain of the part being installed

The Quantity of the part being installed

Syntax

'Declaration

Public Overloads Function LogPartsUsedUpgrade( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _removeSitePartObjid_ As Integer, _
   ByVal _installPartNumber_ As String, _
   ByVal _installPartRevision_ As String, _
   ByVal _installPartDomain_ As String, _
   ByVal _installQuantity_ As Integer _
) As ToolkitResult

public ToolkitResult LogPartsUsedUpgrade(
   string _partRequestDetailIDNum_,
   int _removeSitePartObjid_,
   string _installPartNumber_,
   string _installPartRevision_,
   string _installPartDomain_,
   int _installQuantity_
)

Parameters

partRequestDetailIDNum

The Id Number of the related Part Request Detail (if any)

removeSitePartObjid

The Objid of the Site Part being removed.

installPartNumber

The Part Number of the part being installed

installPartRevision

The Part Revision of the part being installed

installPartDomain

The Part Domain of the part being installed

installQuantity

The Quantity of the part being installed

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the PartUsed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


LogPartsUsedUpgrade(String,String,Int32,String,String,String,String) Method | fcSDK Documentation

LogPartsUsedUpgrade(String,String,Int32,String,String,String,String) Method

The Id Number of the related Part Request Detail (if any)

The identifier of the Case with which this Part Usage is associated

The Objid of the Site Part being removed.

The Part Number of the part being installed

The Part Revision of the part being installed

The Part Domain of the part being installed

The Serial Number of the part being installed

Syntax

'Declaration

Public Overloads Function LogPartsUsedUpgrade( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _caseIDNum_ As String, _
   ByVal _removeSitePartObjid_ As Integer, _
   ByVal _installPartNumber_ As String, _
   ByVal _installPartRevision_ As String, _
   ByVal _installPartDomain_ As String, _
   ByVal _installSerialNumber_ As String _
) As ToolkitResult

public ToolkitResult LogPartsUsedUpgrade(
   string _partRequestDetailIDNum_,
   string _caseIDNum_,
   int _removeSitePartObjid_,
   string _installPartNumber_,
   string _installPartRevision_,
   string _installPartDomain_,
   string _installSerialNumber_
)

Parameters

partRequestDetailIDNum

The Id Number of the related Part Request Detail (if any)

caseIDNum

The identifier of the Case with which this Part Usage is associated

removeSitePartObjid

The Objid of the Site Part being removed.

installPartNumber

The Part Number of the part being installed

installPartRevision

The Part Revision of the part being installed

installPartDomain

The Part Domain of the part being installed

installSerialNumber

The Serial Number of the part being installed

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the PartUsed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


LogPartsUsedUpgrade(String,String,Int32,String,String,String,Int32) Method | fcSDK Documentation

LogPartsUsedUpgrade(String,String,Int32,String,String,String,Int32) Method

The Id Number of the related Part Request Detail (if any)

The identifier of the Case with which this Part Usage is associated

The Objid of the Site Part being removed.

The Part Number of the part being installed

The Part Revision of the part being installed

The Part Domain of the part being installed

The Quantity of the part being installed

Syntax

'Declaration

Public Overloads Function LogPartsUsedUpgrade( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _caseIDNum_ As String, _
   ByVal _removeSitePartObjid_ As Integer, _
   ByVal _installPartNumber_ As String, _
   ByVal _installPartRevision_ As String, _
   ByVal _installPartDomain_ As String, _
   ByVal _installQuantity_ As Integer _
) As ToolkitResult

public ToolkitResult LogPartsUsedUpgrade(
   string _partRequestDetailIDNum_,
   string _caseIDNum_,
   int _removeSitePartObjid_,
   string _installPartNumber_,
   string _installPartRevision_,
   string _installPartDomain_,
   int _installQuantity_
)

Parameters

partRequestDetailIDNum

The Id Number of the related Part Request Detail (if any)

caseIDNum

The identifier of the Case with which this Part Usage is associated

removeSitePartObjid

The Objid of the Site Part being removed.

installPartNumber

The Part Number of the part being installed

installPartRevision

The Part Revision of the part being installed

installPartDomain

The Part Domain of the part being installed

installQuantity

The Quantity of the part being installed

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the PartUsed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


LogPartsUsedUpgrade(LogPartsUsedUpgradeSetup) Method | fcSDK Documentation

LogPartsUsedUpgrade(LogPartsUsedUpgradeSetup) Method

Setup object for API invocation.

Syntax

'Declaration

Public Overloads Function LogPartsUsedUpgrade( _
   ByVal _setupParam_ LogPartsUsedUpgradeSetup _
) As ToolkitResult

public ToolkitResult LogPartsUsedUpgrade(
   LogPartsUsedUpgradeSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the PartUsed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List
LogPartsUsedUpgradeSetup Class


LogPartsUsedUpgrade(LogPartsUsedUpgradeSetup,IDbTransaction) Method | fcSDK Documentation

LogPartsUsedUpgrade(LogPartsUsedUpgradeSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to upgrade an existing site part with a new site part. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function LogPartsUsedUpgrade( _
   ByVal _setupParam_ As LogPartsUsedUpgradeSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult LogPartsUsedUpgrade(
   LogPartsUsedUpgradeSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

Each log parts used transaction must be related to either a case or a part request detail. If it is related to both, the part request detail must be linked to the case.

Both serialized and quantity-tracked parts can be logged, and the API performs all of the correct operations, based on the serial number/quantity fields.

For the site part being installed, the part number, revision (mod_level), and domain must be specified. Also, the quantity and/or serial number should be supplied. Optionally, the installed part’s price can be specified, and the “InstallAtSite” should be specified to determine if it is installed at the top-level of the site, or under another site part. In the latter case, the objid of the parent site part must be specified. Optionally, the part to be installed can be pulled from inventory (or an Expense GL account) by specifying the “from” fields.

If a part is to be installed (serialized parts only), and already exists in the system as a site part, it will be moved (not installed). This assumes that the “allow_move” flag is set to True. If not, an error code is produced.

For the site part being removed, the objid of the part to be removed must be specified. Optionally, a removed part may be placed back in inventory. If the “to” fields for location, bin, and good/bad are specified, the part will be put back in inventory. It can also be transferred to an Expense GL account.

When the log parts used action occurs, the API will change the condition of the part request (if one is listed in the arguments) to either the condition of: Part Used or Update Inv. If there are no inventory movements, the former condition will be used. If either the install or remove part are moved to/from inventory, the condition will be set to Update Inv. In both cases, the API will set the status of the part request to the default status for the condition, and will validate the ClearLogistics transitions to make sure that the user who is logging the action can perform the state transition.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


MoveSitePartToBin Method (FieldOpsToolkit) | fcSDK Documentation

MoveSitePartToBin Method (FieldOpsToolkit)

Overload List

Overload | Description
MoveSitePartToBin(Int32,Int32) | Move the SitePartToBin from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
MoveSitePartToBin(MoveSitePartToBinSetup) | Move the SitePartToBin from one WipBin to another WipBin. This overload takes a setup object.
MoveSitePartToBin(MoveSitePartToBinSetup,IDbTransaction) | Used to move an existing site part from its current location to a product bin within the Clarify site configuration. This overload takes a setup object and a database transaction.

Remarks

The site part to be moved must be current (not de-installed).

When a site_part is moved, all sub-site_parts underneath it are also moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class FieldOpsToolkit Members MoveSitePartToBinSetup Class


MoveSitePartToBin(Int32,Int32) Method | fcSDK Documentation

MoveSitePartToBin(Int32,Int32) Method

The Objid of the Site Part being moved.

The Objid of the Parent Site Bin where the Site Part is being moved.

Move the SitePartToBin from one WipBin to another WipBin. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function MoveSitePartToBin( _
   ByVal _sitePartObjid_ As Integer, _
   ByVal _parentBinObjid_ As Integer _
) As ToolkitResult

public ToolkitResult MoveSitePartToBin(
   int _sitePartObjid_,
   int _parentBinObjid_
)

Parameters

sitePartObjid

The Objid of the Site Part being moved.

parentBinObjid

The Objid of the Parent Site Bin where the Site Part is being moved.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the SitePartToBin, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


MoveSitePartToBin(MoveSitePartToBinSetup) Method | fcSDK Documentation

MoveSitePartToBin(MoveSitePartToBinSetup) Method

Setup object for API invocation.

Move the SitePartToBin from one WipBin to another WipBin. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function MoveSitePartToBin( _
   ByVal _setupParam_ MoveSitePartToBinSetup _
) As ToolkitResult

public ToolkitResult MoveSitePartToBin(
   MoveSitePartToBinSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the SitePartToBin, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List
MoveSitePartToBinSetup Class


MoveSitePartToBin(MoveSitePartToBinSetup,IDbTransaction) Method | fcSDK Documentation

MoveSitePartToBin(MoveSitePartToBinSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to move an existing site part from its current location to a product bin within the Clarify site configuration. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function MoveSitePartToBin( _
   ByVal _setupParam_ As MoveSitePartToBinSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult MoveSitePartToBin(
   MoveSitePartToBinSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The site part to be moved must be current (not de-installed).

When a site_part is moved, all sub-site_parts underneath it are also moved.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


MoveSitePartToPart Method (FieldOpsToolkit) | fcSDK Documentation

MoveSitePartToPart Method (FieldOpsToolkit)

Overload List

Overload | Description
MoveSitePartToPart(Int32,Int32) | Move the SitePartToPart from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
MoveSitePartToPart(MoveSitePartToPartSetup) | Move the SitePartToPart from one WipBin to another WipBin. This overload takes a setup object.
MoveSitePartToPart(MoveSitePartToPartSetup,IDbTransaction) | Used to move an existing site part from its current location to underneath another site part within the Clarify site configuration. This overload takes a setup object and a database transaction.

Remarks

The site part to be moved must be current (not de-installed).

When a site_part is moved, all sub-site_parts underneath it are also moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class FieldOpsToolkit Members MoveSitePartToPartSetup Class


MoveSitePartToPart(Int32,Int32) Method | fcSDK Documentation

MoveSitePartToPart(Int32,Int32) Method

The Objid of the Site Part being moved.

The Objid of the Parent Site where the Site Part is being moved.

Move the SitePartToPart from one WipBin to another WipBin. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function MoveSitePartToPart( _
   ByVal _sitePartObjid_ As Integer, _
   ByVal _parentSitePartObjid_ As Integer _
) As ToolkitResult

public ToolkitResult MoveSitePartToPart(
   int _sitePartObjid_,
   int _parentSitePartObjid_
)

Parameters

sitePartObjid

The Objid of the Site Part being moved.

parentSitePartObjid

The Objid of the Parent Site where the Site Part is being moved.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the SitePartToPart, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


MoveSitePartToPart(MoveSitePartToPartSetup) Method | fcSDK Documentation

MoveSitePartToPart(MoveSitePartToPartSetup) Method

Setup object for API invocation.

Move the SitePartToPart from one WipBin to another WipBin. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function MoveSitePartToPart( _
   ByVal _setupParam_ MoveSitePartToPartSetup _
) As ToolkitResult

public ToolkitResult MoveSitePartToPart(
   MoveSitePartToPartSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the SitePartToPart, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List
MoveSitePartToPartSetup Class


MoveSitePartToPart(MoveSitePartToPartSetup,IDbTransaction) Method | fcSDK Documentation

MoveSitePartToPart(MoveSitePartToPartSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to move an existing site part from its current location to underneath another site part within the Clarify site configuration. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function MoveSitePartToPart( _
   ByVal _setupParam_ As MoveSitePartToPartSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult MoveSitePartToPart(
   MoveSitePartToPartSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The site part to be moved must be current (not de-installed).

When a site_part is moved, all sub-site_parts underneath it are also moved.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


MoveSitePartToSite Method (FieldOpsToolkit) | fcSDK Documentation

MoveSitePartToSite Method (FieldOpsToolkit)

Overload List

Overload | Description
MoveSitePartToSite(Int32,String) | Move the SitePartToSite from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
MoveSitePartToSite(MoveSitePartToSiteSetup) | Move the SitePartToSite from one WipBin to another WipBin. This overload takes a setup object.
MoveSitePartToSite(MoveSitePartToSiteSetup,IDbTransaction) | Used to move an existing site part from its current location to the top-level at a site. This overload takes a setup object and a database transaction.

Remarks

The site part to be moved must be current (not de-installed).

When a site_part is moved, all sub-site_parts underneath it are also moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class FieldOpsToolkit Members MoveSitePartToSiteSetup Class


MoveSitePartToSite(Int32,String) Method | fcSDK Documentation

MoveSitePartToSite(Int32,String) Method

The Objid of the Site Part being moved.

The Site Id of the Site where the Site Part is being moved.

Move the SitePartToSite from one WipBin to another WipBin. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function MoveSitePartToSite( _
   ByVal _sitePartObjid_ As Integer, _
   ByVal _siteIDNum_ As String _
) As ToolkitResult

public ToolkitResult MoveSitePartToSite(
   int _sitePartObjid_,
   string _siteIDNum_
)

Parameters

sitePartObjid

The Objid of the Site Part being moved.

siteIDNum

The Site Id of the Site where the Site Part is being moved.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the SitePartToSite, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


MoveSitePartToSite(MoveSitePartToSiteSetup) Method | fcSDK Documentation

MoveSitePartToSite(MoveSitePartToSiteSetup) Method

Setup object for API invocation.

Move the SitePartToSite from one WipBin to another WipBin. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function MoveSitePartToSite( _
   ByVal _setupParam_ MoveSitePartToSiteSetup _
) As ToolkitResult

public ToolkitResult MoveSitePartToSite(
   MoveSitePartToSiteSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the SitePartToSite, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List
MoveSitePartToSiteSetup Class


MoveSitePartToSite(MoveSitePartToSiteSetup,IDbTransaction) Method | fcSDK Documentation

MoveSitePartToSite(MoveSitePartToSiteSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to move an existing site part from its current location to the top-level at a site. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function MoveSitePartToSite( _
   ByVal _setupParam_ As MoveSitePartToSiteSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult MoveSitePartToSite(
   MoveSitePartToSiteSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The site part to be moved must be current (not de-installed).

When a site_part is moved, all sub-site_parts underneath it are also moved.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


PartTransfer Method (FieldOpsToolkit) | fcSDK Documentation

PartTransfer Method (FieldOpsToolkit)

Initializes a new instance of the PartTransferSetup class. This overload takes a set of required parameters for the API.

Allows parts to be transferred independent of a part request to fix order errors, correct inventory variances, move parts from one inventory location (or account) to another (without having to relate that movement to a part request), and scrap parts out of inventory.

Overload List

| Overload | Description | | --- | --- | | PartTransfer(String,String,String,Int32,Location,Location) | Initializes a new instance of the PartTransferSetup class. This overload takes a set of required parameters for the API. | | PartTransfer(String,String,String,String,Location,Location) | Initializes a new instance of the PartTransferSetup class. This overload takes a set of required parameters for the API. | | PartTransfer(PartTransferSetup) | | | PartTransfer(PartTransferSetup,IDbTransaction) | Allows parts to be transferred independent of a part request to fix order errors, correct inventory variances, move parts from one inventory location (or account) to another (without having to relate that movement to a part request), and scrap parts out of inventory.

This overload takes a setup object and a database transaction. |

Remarks

As in Clarify, the transfer can be from good or bad stock and can be to good or bad stock.

This API checks part authorization levels for auto-replenishment, and will automatically work with that engine.

To use primary bin suggestions/recommendations, please see the remarks on the ToLocation and/or FromLocation properties on the PartTransferSetup object.

This API supports transferring parts by quantity or a specific serial number.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
PartTransferSetup Class


PartTransfer(String,String,String,Int32,Location,Location) Method | fcSDK Documentation

PartTransfer(String,String,String,Int32,Location,Location) Method

Part number for the Part Request

Part revision for the Part Request

Part domain for the Part Request

The number of parts being transferred

Inventory location (or expense GL) and bin from which to transfer the part

Inventory location and bin (or GL account) into which the part is being transferred

Initializes a new instance of the PartTransferSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function PartTransfer( _
   ByVal _partNumber_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _quantity_ As Integer, _
   ByVal _fromlocation_ As Location, _
   ByVal _tolocation_ As Location _
) As PartTransferResult

public PartTransferResult PartTransfer(
   string _partNumber_,
   string _partRevision_,
   string _partDomain_,
   int _quantity_,
   Location _fromlocation_,
   Location _tolocation_
)

Parameters

partNumber

Part number for the Part Request

partRevision

Part revision for the Part Request

partDomain

Part domain for the Part Request

quantity

The number of parts being transferred

fromlocation

Inventory location (or expense GL) and bin from which to transfer the part

tolocation

Inventory location and bin (or GL account) into which the part is being transferred

Return Value

The following values are populated in the PartTransferResult object returned by the API method:

  • StandardCost - Part Transfer Standard Cost.
  • Objid - Objid of the Part Transfer record.
  • TransactionIDNum - Part Transfer Transaction Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


PartTransfer(String,String,String,String,Location,Location) Method | fcSDK Documentation

PartTransfer(String,String,String,String,Location,Location) Method

Part number for the Part Request

Part revision for the Part Request

Part domain for the Part Request

The serial number of the part being transferred

Inventory location (or expense GL) and bin from which to transfer the part

Inventory location and bin (or GL account) into which the part is being transferred

Initializes a new instance of the PartTransferSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function PartTransfer( _
   ByVal _partNumber_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _serialNumber_ As String, _
   ByVal _fromlocation_ As Location, _
   ByVal _tolocation_ As Location _
) As PartTransferResult

public PartTransferResult PartTransfer(
   string _partNumber_,
   string _partRevision_,
   string _partDomain_,
   string _serialNumber_,
   Location _fromlocation_,
   Location _tolocation_
)

Parameters

partNumber

Part number for the Part Request

partRevision

Part revision for the Part Request

partDomain

Part domain for the Part Request

serialNumber

The serial number of the part being transferred

fromlocation

Inventory location (or expense GL) and bin from which to transfer the part

tolocation

Inventory location and bin (or GL account) into which the part is being transferred

Return Value

The following values are populated in the PartTransferResult object returned by the API method:

  • StandardCost - Part Transfer Standard Cost.
  • Objid - Objid of the Part Transfer record.
  • TransactionIDNum - Part Transfer Transaction Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


PartTransfer(PartTransferSetup) Method | fcSDK Documentation

PartTransfer(PartTransferSetup) Method

Setup object for API invocation.

Syntax

'Declaration

Public Overloads Function PartTransfer( _
   ByVal _setupParam_ As PartTransferSetup _
) As PartTransferResult

public PartTransferResult PartTransfer(
   PartTransferSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the PartTransferResult object returned by the API method:

  • StandardCost - Part Transfer Standard Cost.
  • TransactionIDNum - Part Transfer Transaction Identifier.
  • Objid - Objid of the Part Transfer record.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List
PartTransferSetup Class


PartTransfer(PartTransferSetup,IDbTransaction) Method | fcSDK Documentation

PartTransfer(PartTransferSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Allows parts to be transferred independent of a part request to fix order errors, correct inventory variances, move parts from one inventory location (or account) to another (without having to relate that movement to a part request), and scrap parts out of inventory.

This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function PartTransfer( _
   ByVal _setupParam_ As PartTransferSetup, _
   ByVal _transaction_ As IDbTransaction _
) As PartTransferResult

public PartTransferResult PartTransfer(
   PartTransferSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A PartTransferResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

As in Clarify, the transfer can be from good or bad stock and can be to good or bad stock.

This API checks part authorization levels for auto-replenishment, and will automatically work with that engine.

To use primary bin suggestions/recommendations, please see the remarks on the ToLocation and/or FromLocation properties on the PartTransferSetup object.

This API supports transferring parts by quantity or a specific serial number.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


ReinstallSitePart Method | fcSDK Documentation

ReinstallSitePart Method

Used to re-install a site part (and the sub-parts installed underneath it) that have been deinstalled from a site. This overload takes a setup object and a database transaction.

Used to re-install a site part (and the sub-parts installed underneath it) that have been deinstalled from a site.

Overload List

Overload | Description
ReinstallSitePart(Int32,String) |
ReinstallSitePart(ReinstallSitePartSetup) |
ReinstallSitePart(ReinstallSitePartSetup,IDbTransaction) | Used to re-install a site part (and the sub-parts installed underneath it) that have been deinstalled from a site. This overload takes a setup object and a database transaction.

Remarks

If the site part is to be reinstalled in a bin, the bin objid is specified. If it is to be installed under another part, the parent part objid is specified. If the site part is to be installed at the top-level of the site, neither objid is specified.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
ReinstallSitePartSetup Class


ReinstallSitePart(Int32,String) Method | fcSDK Documentation

ReinstallSitePart(Int32,String) Method

The Objid of the Site Part being reinstalled.

The Site Id of the Site where the Site Part is being moved.

Syntax

'Declaration

Public Overloads Function ReinstallSitePart( _
   ByVal _sitePartObjid_ As Integer, _
   ByVal _siteIDNum_ As String _
) As ToolkitResult

public ToolkitResult ReinstallSitePart(
   int _sitePartObjid_,
   string _siteIDNum_
)

Parameters

sitePartObjid

The Objid of the Site Part being reinstalled.

siteIDNum

The Site Id of the Site where the Site Part is being moved.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


ReinstallSitePart(ReinstallSitePartSetup) Method | fcSDK Documentation

ReinstallSitePart(ReinstallSitePartSetup) Method

Setup object for API invocation.

Syntax

'Declaration

Public Overloads Function ReinstallSitePart( _
   ByVal _setupParam_ ReinstallSitePartSetup _
) As ToolkitResult

public ToolkitResult ReinstallSitePart(
   ReinstallSitePartSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List
ReinstallSitePartSetup Class


ReinstallSitePart(ReinstallSitePartSetup,IDbTransaction) Method | fcSDK Documentation

ReinstallSitePart(ReinstallSitePartSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to re-install a site part (and the sub-parts installed underneath it) that have been deinstalled from a site. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function ReinstallSitePart( _
   ByVal _setupParam_ As ReinstallSitePartSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult ReinstallSitePart(
   ReinstallSitePartSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

If the site part is to be reinstalled in a bin, the bin objid is specified. If it is to be installed under another part, the parent part objid is specified. If the site part is to be installed at the top-level of the site, neither objid is specified.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


UpdateAppointment Method | fcSDK Documentation

UpdateAppointment Method

Used to modify an existing appointment. This overload takes a setup object and a database transaction.

Used to modify an existing appointment.

Overload List

Overload | Description
UpdateAppointment(UpdateAppointmentSetup) |
UpdateAppointment(UpdateAppointmentSetup,IDbTransaction) | Used to modify an existing appointment. This overload takes a setup object and a database transaction.

Remarks

The start/end time can be specified either with both times or with one time and a duration. The duration is specified in seconds.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
UpdateAppointmentSetup Class


UpdateAppointment(UpdateAppointmentSetup) Method | fcSDK Documentation

UpdateAppointment(UpdateAppointmentSetup) Method

Setup object for API invocation.

Syntax

'Declaration

Public Overloads Function UpdateAppointment( _
   ByVal _setupParam_ UpdateAppointmentSetup _
) As ToolkitResult

public ToolkitResult UpdateAppointment(
   UpdateAppointmentSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List
UpdateAppointmentSetup Class


UpdateAppointment(UpdateAppointmentSetup,IDbTransaction) Method | fcSDK Documentation

UpdateAppointment(UpdateAppointmentSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to modify an existing appointment. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdateAppointment( _
   ByVal _setupParam_ As UpdateAppointmentSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdateAppointment(
   UpdateAppointmentSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The start/end time can be specified either with both times or with one time and a duration. The duration is specified in seconds.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


UpdateExpenseLog Method | fcSDK Documentation

UpdateExpenseLog Method

Used to modify an existing expense log. This overload takes a setup object and a database transaction.

Used to modify an existing expense log.

Overload List

Overload | Description
UpdateExpenseLog(Int32,Double,Double) |
UpdateExpenseLog(UpdateExpenseLogSetup) |
UpdateExpenseLog(UpdateExpenseLogSetup,IDbTransaction) | Used to modify an existing expense log. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
UpdateExpenseLogSetup Class


UpdateExpenseLog(Int32,Double,Double) Method | fcSDK Documentation

UpdateExpenseLog(Int32,Double,Double) Method

The Objid of the Expense Log being modified.

The number of units that are being applied to the Onsite Log.

The billing rate per unit. If no rate is specified, the labor rate of the performing employee is used.

Syntax

'Declaration

Public Overloads Function UpdateExpenseLog( _
   ByVal _expenseLogObjid_ As Integer, _
   ByVal _quantity_ As Double, _
   ByVal _rate_ As Double _
) As ToolkitResult

public ToolkitResult UpdateExpenseLog(
   int _expenseLogObjid_,
   double _quantity_,
   double _rate_
)

Parameters

expenseLogObjid

The Objid of the Expense Log being modified.

quantity

The number of units that are being applied to the Onsite Log.

rate

The billing rate per unit. If no rate is specified, the labor rate of the performing employee is used.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


UpdateExpenseLog(UpdateExpenseLogSetup) Method | fcSDK Documentation

UpdateExpenseLog(UpdateExpenseLogSetup) Method

Setup object for API invocation.

Syntax

'Declaration

Public Overloads Function UpdateExpenseLog( _
   ByVal _setupParam_ UpdateExpenseLogSetup _
) As ToolkitResult

public ToolkitResult UpdateExpenseLog(
   UpdateExpenseLogSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List
UpdateExpenseLogSetup Class


UpdateExpenseLog(UpdateExpenseLogSetup,IDbTransaction) Method | fcSDK Documentation

UpdateExpenseLog(UpdateExpenseLogSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to modify an existing expense log. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdateExpenseLog( _
   ByVal _setupParam_ As UpdateExpenseLogSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdateExpenseLog(
   UpdateExpenseLogSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


UpdateServiceInterruption Method | fcSDK Documentation

UpdateServiceInterruption Method

Used to modify an existing service interruption (appointment). This overload takes a setup object and a database transaction.

Used to modify an existing service interruption (appointment).

Overload List

Overload | Description
UpdateServiceInterruption(UpdateServiceInterruptionSetup) |
UpdateServiceInterruption(UpdateServiceInterruptionSetup,IDbTransaction) | Used to modify an existing service interruption (appointment). This overload takes a setup object and a database transaction.

Remarks

A new description can be specified, or the current description can appended by using “+” as the first character of the text to add to the original description.

To use the original appointment time, don’t specify the start_time or end_time. To change the start/end time, specify either both times or specify one time and a duration specified in seconds.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
UpdateServiceInterruptionSetup Class


UpdateServiceInterruption(UpdateServiceInterruptionSetup) Method | fcSDK Documentation

UpdateServiceInterruption(UpdateServiceInterruptionSetup) Method

Setup object for API invocation.

Syntax

'Declaration

Public Overloads Function UpdateServiceInterruption( _
   ByVal _setupParam_ UpdateServiceInterruptionSetup _
) As ToolkitResult

public ToolkitResult UpdateServiceInterruption(
   UpdateServiceInterruptionSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List
UpdateServiceInterruptionSetup Class


UpdateServiceInterruption(UpdateServiceInterruptionSetup,IDbTransaction) Method | fcSDK Documentation

UpdateServiceInterruption(UpdateServiceInterruptionSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to modify an existing service interruption (appointment). This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdateServiceInterruption( _
   ByVal _setupParam_ As UpdateServiceInterruptionSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdateServiceInterruption(
   UpdateServiceInterruptionSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

A new description can be specified, or the current description can appended by using “+” as the first character of the text to add to the original description.

To use the original appointment time, don’t specify the start_time or end_time. To change the start/end time, specify either both times or specify one time and a duration specified in seconds.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


UpdateSitePart Method (FieldOpsToolkit) | fcSDK Documentation

UpdateSitePart Method (FieldOpsToolkit)

Used to modify an existing site part. This overload takes a setup object and a database transaction.

Used to modify an existing site part.

Overload List

Overload | Description
UpdateSitePart(UpdateSitePartSetup) |
UpdateSitePart(UpdateSitePartSetup,IDbTransaction) | Used to modify an existing site part. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
UpdateSitePartSetup Class


UpdateSitePart(UpdateSitePartSetup) Method | fcSDK Documentation

UpdateSitePart(UpdateSitePartSetup) Method

Setup object for API invocation.

Syntax

'Declaration

Public Overloads Function UpdateSitePart( _
   ByVal _setupParam_ UpdateSitePartSetup _
) As ToolkitResult

public ToolkitResult UpdateSitePart(
   UpdateSitePartSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the SitePart.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List
UpdateSitePartSetup Class


UpdateSitePart(UpdateSitePartSetup,IDbTransaction) Method | fcSDK Documentation

UpdateSitePart(UpdateSitePartSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to modify an existing site part. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdateSitePart( _
   ByVal _setupParam_ As UpdateSitePartSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdateSitePart(
   UpdateSitePartSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


UpdateTimeLog Method | fcSDK Documentation

UpdateTimeLog Method

Used to modify an existing time log. This overload takes a setup object and a database transaction.

Used to modify an existing time log.

Overload List

Overload | Description
UpdateTimeLog(UpdateTimeLogSetup) |
UpdateTimeLog(UpdateTimeLogSetup,IDbTransaction) | Used to modify an existing time log. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
UpdateTimeLogSetup Class


UpdateTimeLog(UpdateTimeLogSetup) Method | fcSDK Documentation

UpdateTimeLog(UpdateTimeLogSetup) Method

Setup object for API invocation.

Syntax

'Declaration

Public Overloads Function UpdateTimeLog( _
   ByVal _setupParam_ UpdateTimeLogSetup _
) As ToolkitResult

public ToolkitResult UpdateTimeLog(
   UpdateTimeLogSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List
UpdateTimeLogSetup Class


UpdateTimeLog(UpdateTimeLogSetup,IDbTransaction) Method | fcSDK Documentation

UpdateTimeLog(UpdateTimeLogSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to modify an existing time log. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdateTimeLog( _
   ByVal _setupParam_ As UpdateTimeLogSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdateTimeLog(
   UpdateTimeLogSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkit Class
FieldOpsToolkit Members
Overload List


FieldOpsToolkitBase Class | fcSDK Documentation

FieldOpsToolkitBase Class

This class is intended for internal use by the FieldOpsToolkit.

Syntax

'Declaration

Public MustInherit Class FieldOpsToolkitBase
   Inherits FChoice.Toolkits.Clarify.ToolkitBase

public abstract class FieldOpsToolkitBase : FChoice.Toolkits.Clarify.ToolkitBase

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.ToolkitBase
FChoice.Toolkits.Clarify.FieldOps.FieldOpsToolkitBase
FChoice.Toolkits.Clarify.FieldOps.FieldOpsToolkit

Requirements

Namespace: FChoice.Toolkits.Clarify.FieldOps

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

FieldOpsToolkitBase Members
FChoice.Toolkits.Clarify.FieldOps Namespace


FieldOpsToolkitBase Class Members | fcSDK Documentation

FieldOpsToolkitBase Class Members

The following tables list the members exposed by FieldOpsToolkitBase.

Public Properties

 | Name | Description
Public Property | ImpersonatorUsername |

Reference

FieldOpsToolkitBase Class
FChoice.Toolkits.Clarify.FieldOps Namespace


ImpersonatorUsername Property (FieldOpsToolkitBase) | fcSDK Documentation

ImpersonatorUsername Property (FieldOpsToolkitBase)

Syntax

'Declaration

Public Property ImpersonatorUsername As String

public string ImpersonatorUsername {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FieldOpsToolkitBase Class
FieldOpsToolkitBase Members


InstallSitePartSetup Class | fcSDK Documentation

InstallSitePartSetup Class

Used by the InstallSitePart method as setup data for invocation.

Syntax

'Declaration

Public Class InstallSitePartSetup

public class InstallSitePartSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.FieldOps.InstallSitePartSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.FieldOps

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

InstallSitePartSetup Members
FChoice.Toolkits.Clarify.FieldOps Namespace
InstallSitePart(InstallSitePartSetup) Method


InstallSitePartSetup Class Members | fcSDK Documentation

InstallSitePartSetup Class Members

The following tables list the members exposed by InstallSitePartSetup.

Public Constructors

 | Name | Description
Public Constructor | InstallSitePartSetup Constructor | Overloaded.

Public Properties

 | Name | Description
Public Property | AddActivityLog | Specifies if activity entry records should be created.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | Comments | Comments about the Site Part installation.
Public Property | InstallDate | The DateTime the Site Part was installed. If not set, the current time is used.
Public Property | InstanceName | Instance Name of the Site Part
Public Property | InvoiceNumber | The Invoice Number for the Site Part.
Public Property | ParentBinObjid | The Objid of the Parent Site Bin where the Site Part is being installed.
Public Property | ParentSitePartObjid | The Objid of the Parent Site Part where the Site Part is being installed.
Public Property | PartDomain | Part Domain of the Site Part
Public Property | PartNumber | Part Number of the Site Part
Public Property | PartRevision | Part Revision of the Site Part
Public Property | PartStatus | Element from the 'Part Status' application list. If not set the default list value is used.
Public Property | Quantity | The Quantity of the Site Part being installed.
Public Property | SerialNumber | Serial Number of the Site Part
Public Property | ShipDate | The DateTime the Site Part was shipped. If not set, the current time is used.
Public Property | SiteIDNum | The Site Id of the Parent Site where the Site Part is being installed.
Public Property | UserName | The user who installed the Site Part. If not set, the Toolkit session user is used.

Reference

InstallSitePartSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
InstallSitePart(InstallSitePartSetup) Method


InstallSitePartSetup Constructor | fcSDK Documentation

InstallSitePartSetup Constructor

Initializes a new instance of the InstallSitePartSetup class.

Overload List

Overload | Description
InstallSitePartSetup Constructor(String,String,String,String,Int32) | Initializes a new instance of the InstallSitePartSetup class. This overload takes a set of required parameters for the API.
InstallSitePartSetup Constructor(String,String,String,String,String) | Initializes a new instance of the InstallSitePartSetup class. This overload takes a set of required parameters for the API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartSetup Class
InstallSitePartSetup Members


InstallSitePartSetup Constructor(String,String,String,String,Int32) | fcSDK Documentation

InstallSitePartSetup Constructor(String,String,String,String,Int32)

The Site Id of the Parent Site where the Site Part is being installed.

Part Number of the Site Part

Part Revision of the Site Part

Part Domain of the Site Part

The Quantity of the Site Part being installed.

Initializes a new instance of the InstallSitePartSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _siteIDNum_ As String, _
   ByVal _partNumber_ As String, _
   ByVal _partrevision_ As String, _
   ByVal _partdomain_ As String, _
   ByVal _quantity_ As Integer _
)

[ConstructorIndexAttribute()]
public InstallSitePartSetup(
   string _siteIDNum_,
   string _partNumber_,
   string _partrevision_,
   string _partdomain_,
   int _quantity_
)

Parameters

siteIDNum

The Site Id of the Parent Site where the Site Part is being installed.

partNumber

Part Number of the Site Part

partrevision

Part Revision of the Site Part

partdomain

Part Domain of the Site Part

quantity

The Quantity of the Site Part being installed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartSetup Class
InstallSitePartSetup Members
Overload List


InstallSitePartSetup Constructor(String,String,String,String,String) | fcSDK Documentation

InstallSitePartSetup Constructor(String,String,String,String,String)

The Site Id of the Parent Site where the Site Part is being installed.

Part Number of the Site Part

Part Revision of the Site Part

Part Domain of the Site Part

Serial Number of the Site Part

Initializes a new instance of the InstallSitePartSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _siteIDNum_ As String, _
   ByVal _partNumber_ As String, _
   ByVal _partrevision_ As String, _
   ByVal _partdomain_ As String, _
   ByVal _serialNumber_ As String _
)

[ConstructorIndexAttribute()]
public InstallSitePartSetup(
   string _siteIDNum_,
   string _partNumber_,
   string _partrevision_,
   string _partdomain_,
   string _serialNumber_
)

Parameters

siteIDNum

The Site Id of the Parent Site where the Site Part is being installed.

partNumber

Part Number of the Site Part

partrevision

Part Revision of the Site Part

partdomain

Part Domain of the Site Part

serialNumber

Serial Number of the Site Part

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartSetup Class
InstallSitePartSetup Members
Overload List


AddActivityLog Property (InstallSitePartSetup) | fcSDK Documentation

AddActivityLog Property (InstallSitePartSetup)

Specifies if activity entry records should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AddActivityLog As Boolean

[PropertyBitValueAttribute()]
public bool AddActivityLog {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartSetup Class
InstallSitePartSetup Members


AdditionalFields Property (InstallSitePartSetup) | fcSDK Documentation

AdditionalFields Property (InstallSitePartSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartSetup Class
InstallSitePartSetup Members


Comments Property (InstallSitePartSetup) | fcSDK Documentation

Comments Property (InstallSitePartSetup)

Comments about the Site Part installation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Comments As String

[PropertyBitValueAttribute()]
public string Comments {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartSetup Class
InstallSitePartSetup Members


InstallDate Property (InstallSitePartSetup) | fcSDK Documentation

InstallDate Property (InstallSitePartSetup)

The DateTime the Site Part was installed. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallDate As Date

[PropertyBitValueAttribute()]
public DateTime InstallDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartSetup Class
InstallSitePartSetup Members


InstanceName Property (InstallSitePartSetup) | fcSDK Documentation

InstanceName Property (InstallSitePartSetup)

Instance Name of the Site Part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstanceName As String

[PropertyBitValueAttribute()]
public string InstanceName {get; set;}

Remarks

If this is left blank, the Instance Name is set to the PArt Number and the Part Revision of the Site Part.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartSetup Class
InstallSitePartSetup Members


InvoiceNumber Property (InstallSitePartSetup) | fcSDK Documentation

InvoiceNumber Property (InstallSitePartSetup)

The Invoice Number for the Site Part.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InvoiceNumber As String

[PropertyBitValueAttribute()]
public string InvoiceNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartSetup Class
InstallSitePartSetup Members


ParentBinObjid Property (InstallSitePartSetup) | fcSDK Documentation

ParentBinObjid Property (InstallSitePartSetup)

The Objid of the Parent Site Bin where the Site Part is being installed.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ParentBinObjid As Integer

[PropertyBitValueAttribute()]
public int ParentBinObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartSetup Class
InstallSitePartSetup Members


ParentSitePartObjid Property (InstallSitePartSetup) | fcSDK Documentation

ParentSitePartObjid Property (InstallSitePartSetup)

The Objid of the Parent Site Part where the Site Part is being installed.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ParentSitePartObjid As Integer

[PropertyBitValueAttribute()]
public int ParentSitePartObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartSetup Class
InstallSitePartSetup Members


PartDomain Property (InstallSitePartSetup) | fcSDK Documentation

PartDomain Property (InstallSitePartSetup)

Part Domain of the Site Part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartDomain As String

[PropertyBitValueAttribute()]
public string PartDomain {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartSetup Class
InstallSitePartSetup Members


PartNumber Property (InstallSitePartSetup) | fcSDK Documentation

PartNumber Property (InstallSitePartSetup)

Part Number of the Site Part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartNumber As String

[PropertyBitValueAttribute()]
public string PartNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartSetup Class
InstallSitePartSetup Members


PartRevision Property (InstallSitePartSetup) | fcSDK Documentation

PartRevision Property (InstallSitePartSetup)

Part Revision of the Site Part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRevision As String

[PropertyBitValueAttribute()]
public string PartRevision {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartSetup Class
InstallSitePartSetup Members


PartStatus Property (InstallSitePartSetup) | fcSDK Documentation

PartStatus Property (InstallSitePartSetup)

Element from the 'Part Status' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartStatus As String

[PropertyBitValueAttribute()]
public string PartStatus {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartSetup Class
InstallSitePartSetup Members


Quantity Property (InstallSitePartSetup) | fcSDK Documentation

Quantity Property (InstallSitePartSetup)

The Quantity of the Site Part being installed.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Quantity As Integer

[PropertyBitValueAttribute()]
public int Quantity {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartSetup Class
InstallSitePartSetup Members


SerialNumber Property (InstallSitePartSetup) | fcSDK Documentation

SerialNumber Property (InstallSitePartSetup)

Serial Number of the Site Part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SerialNumber As String

[PropertyBitValueAttribute()]
public string SerialNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartSetup Class
InstallSitePartSetup Members


ShipDate Property (InstallSitePartSetup) | fcSDK Documentation

ShipDate Property (InstallSitePartSetup)

The DateTime the Site Part was shipped. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ShipDate As Date

[PropertyBitValueAttribute()]
public DateTime ShipDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartSetup Class
InstallSitePartSetup Members


SiteIDNum Property (InstallSitePartSetup) | fcSDK Documentation

SiteIDNum Property (InstallSitePartSetup)

The Site Id of the Parent Site where the Site Part is being installed.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteIDNum As String

[PropertyBitValueAttribute()]
public string SiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartSetup Class
InstallSitePartSetup Members


UserName Property (InstallSitePartSetup) | fcSDK Documentation

UserName Property (InstallSitePartSetup)

The user who installed the Site Part. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartSetup Class
InstallSitePartSetup Members


LogPartsUsedConsumeSetup Class | fcSDK Documentation

LogPartsUsedConsumeSetup Class

Used by the LogPartsUsedConsume method as setup data for invocation.

Syntax

'Declaration

Public Class LogPartsUsedConsumeSetup

public class LogPartsUsedConsumeSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.FieldOps.LogPartsUsedConsumeSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.FieldOps

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LogPartsUsedConsumeSetup Members
FChoice.Toolkits.Clarify.FieldOps Namespace
LogPartsUsedConsume(LogPartsUsedConsumeSetup) Method


LogPartsUsedConsumeSetup Class Members | fcSDK Documentation

LogPartsUsedConsumeSetup Class Members

The following tables list the members exposed by LogPartsUsedConsumeSetup.

Public Constructors

 | Name | Description
Public Constructor | LogPartsUsedConsumeSetup Constructor | Overloaded.

Public Properties

 | Name | Description
Public Property | AllowMove | Indicates if a serialized part is to be moved if it already exists as an active Site Part
Public Property | CaseIDNum | The identifier of the Case with which this Part Usage is associated
Public Property | EngineerUserName | The user who has performed the Part usage. If not set, the Toolkit session user is used.
Public Property | FromBin | Inventory bin from which the part is being transferred
Public Property | FromContainer | Inventory container from which the part is being transferred
Public Property | FromGood | Specifies whether the part is being transferred from good stock (true) or bad stock (false)
Public Property | FromLocation | Inventory location from which the part is being transferred
Public Property | InstallAtSite | Indicates if the Part should be installed at the top-level of the Site
Public Property | InstallPartDomain | The Part Domain of the part being installed
Public Property | InstallPartNumber | The Part Number of the part being installed
Public Property | InstallPartRevision | The Part Revision of the part being installed
Public Property | InstallPrice | The Price of the part being installed
Public Property | InstallQuantity | The Quantity of the part being installed
Public Property | InstallSerialNumber | The Serial Number of the part being installed
Public Property | LogDate | The DateTime the Part Usage occurred. If not set, the current time is used.
Public Property | ParentSitePartObjid | The Objid of the Parent Site Part where the part is being installed.
Public Property | PartRequestDetailIDNum | The Id Number of the related Part Request Detail (if any)
Public Property | UserName | The user who has logged the Part usage. If not set, the Toolkit session user is used.

Reference

LogPartsUsedConsumeSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
LogPartsUsedConsume(LogPartsUsedConsumeSetup) Method


LogPartsUsedConsumeSetup Constructor | fcSDK Documentation

LogPartsUsedConsumeSetup Constructor

Initializes a new instance of the LogPartsUsedConsumeSetup class.

Overload List

Overload | Description
LogPartsUsedConsumeSetup Constructor(String,String,String,String,String) | Initializes a new instance of the LogPartsUsedConsumeSetup class. This overload takes a set of required parameters for the API.
LogPartsUsedConsumeSetup Constructor(String,String,String,String,Int32) | Initializes a new instance of the LogPartsUsedConsumeSetup class. This overload takes a set of required parameters for the API.
LogPartsUsedConsumeSetup Constructor(String,String,String,String,String,String) | Initializes a new instance of the LogPartsUsedConsumeSetup class. This overload takes a set of required parameters for the API.
LogPartsUsedConsumeSetup Constructor(String,String,String,String,String,Int32) | Initializes a new instance of the LogPartsUsedConsumeSetup class. This overload takes a set of required parameters for the API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedConsumeSetup Class
LogPartsUsedConsumeSetup Members


LogPartsUsedConsumeSetup Constructor(String,String,String,String,String) | fcSDK Documentation

LogPartsUsedConsumeSetup Constructor(String,String,String,String,String)

The Id Number of the related Part Request Detail (if any)

The Part Number of the part being installed

The Part Revision of the part being installed

The Part Domain of the part being installed

The Serial Number of the part being installed

Initializes a new instance of the LogPartsUsedConsumeSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _installPartNumber_ As String, _
   ByVal _installPartRevision_ As String, _
   ByVal _installPartDomain_ As String, _
   ByVal _installSerialNumber_ As String _
)

[ConstructorIndexAttribute()]
public LogPartsUsedConsumeSetup(
   string _partRequestDetailIDNum_,
   string _installPartNumber_,
   string _installPartRevision_,
   string _installPartDomain_,
   string _installSerialNumber_
)

Parameters

partRequestDetailIDNum

The Id Number of the related Part Request Detail (if any)

installPartNumber

The Part Number of the part being installed

installPartRevision

The Part Revision of the part being installed

installPartDomain

The Part Domain of the part being installed

installSerialNumber

The Serial Number of the part being installed

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedConsumeSetup Class
LogPartsUsedConsumeSetup Members
Overload List


LogPartsUsedConsumeSetup Constructor(String,String,String,String,Int32) | fcSDK Documentation

LogPartsUsedConsumeSetup Constructor(String,String,String,String,Int32)

The Id Number of the related Part Request Detail (if any)

The Part Number of the part being installed

The Part Revision of the part being installed

The Part Domain of the part being installed

The Quantity of the part being installed

Initializes a new instance of the LogPartsUsedConsumeSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _installPartNumber_ As String, _
   ByVal _installPartRevision_ As String, _
   ByVal _installPartDomain_ As String, _
   ByVal _installQuantity_ As Integer _
)

[ConstructorIndexAttribute()]
public LogPartsUsedConsumeSetup(
   string _partRequestDetailIDNum_,
   string _installPartNumber_,
   string _installPartRevision_,
   string _installPartDomain_,
   int _installQuantity_
)

Parameters

partRequestDetailIDNum

The Id Number of the related Part Request Detail (if any)

installPartNumber

The Part Number of the part being installed

installPartRevision

The Part Revision of the part being installed

installPartDomain

The Part Domain of the part being installed

installQuantity

The Quantity of the part being installed

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedConsumeSetup Class
LogPartsUsedConsumeSetup Members
Overload List


LogPartsUsedConsumeSetup Constructor(String,String,String,String,String,String) | fcSDK Documentation

LogPartsUsedConsumeSetup Constructor(String,String,String,String,String,String)

The Id Number of the related Part Request Detail (if any)

The identifier of the Case with which this Part Usage is associated

The Part Number of the part being installed

The Part Revision of the part being installed

The Part Domain of the part being installed

The Serial Number of the part being installed

Initializes a new instance of the LogPartsUsedConsumeSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _caseIDNum_ As String, _
   ByVal _installPartNumber_ As String, _
   ByVal _installPartRevision_ As String, _
   ByVal _installPartDomain_ As String, _
   ByVal _installSerialNumber_ As String _
)

[ConstructorIndexAttribute()]
public LogPartsUsedConsumeSetup(
   string _partRequestDetailIDNum_,
   string _caseIDNum_,
   string _installPartNumber_,
   string _installPartRevision_,
   string _installPartDomain_,
   string _installSerialNumber_
)

Parameters

partRequestDetailIDNum

The Id Number of the related Part Request Detail (if any)

caseIDNum

The identifier of the Case with which this Part Usage is associated

installPartNumber

The Part Number of the part being installed

installPartRevision

The Part Revision of the part being installed

installPartDomain

The Part Domain of the part being installed

installSerialNumber

The Serial Number of the part being installed

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedConsumeSetup Class
LogPartsUsedConsumeSetup Members
Overload List


LogPartsUsedConsumeSetup Constructor(String,String,String,String,String,Int32) | fcSDK Documentation

LogPartsUsedConsumeSetup Constructor(String,String,String,String,String,Int32)

The Id Number of the related Part Request Detail (if any)

The identifier of the Case with which this Part Usage is associated

The Part Number of the part being installed

The Part Revision of the part being installed

The Part Domain of the part being installed

The Quantity of the part being installed

Initializes a new instance of the LogPartsUsedConsumeSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _caseIDNum_ As String, _
   ByVal _installPartNumber_ As String, _
   ByVal _installPartRevision_ As String, _
   ByVal _installPartDomain_ As String, _
   ByVal _installQuantity_ As Integer _
)

[ConstructorIndexAttribute()]
public LogPartsUsedConsumeSetup(
   string _partRequestDetailIDNum_,
   string _caseIDNum_,
   string _installPartNumber_,
   string _installPartRevision_,
   string _installPartDomain_,
   int _installQuantity_
)

Parameters

partRequestDetailIDNum

The Id Number of the related Part Request Detail (if any)

caseIDNum

The identifier of the Case with which this Part Usage is associated

installPartNumber

The Part Number of the part being installed

installPartRevision

The Part Revision of the part being installed

installPartDomain

The Part Domain of the part being installed

installQuantity

The Quantity of the part being installed

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedConsumeSetup Class
LogPartsUsedConsumeSetup Members
Overload List


AllowMove Property (LogPartsUsedConsumeSetup) | fcSDK Documentation

AllowMove Property (LogPartsUsedConsumeSetup)

Indicates if a serialized part is to be moved if it already exists as an active Site Part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AllowMove As Boolean

[PropertyBitValueAttribute()]
public bool AllowMove {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedConsumeSetup Class
LogPartsUsedConsumeSetup Members


CaseIDNum Property (LogPartsUsedConsumeSetup) | fcSDK Documentation

CaseIDNum Property (LogPartsUsedConsumeSetup)

The identifier of the Case with which this Part Usage is associated

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedConsumeSetup Class
LogPartsUsedConsumeSetup Members


EngineerUserName Property (LogPartsUsedConsumeSetup) | fcSDK Documentation

EngineerUserName Property (LogPartsUsedConsumeSetup)

The user who has performed the Part usage. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property EngineerUserName As String

[PropertyBitValueAttribute()]
public string EngineerUserName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedConsumeSetup Class
LogPartsUsedConsumeSetup Members


FromBin Property (LogPartsUsedConsumeSetup) | fcSDK Documentation

FromBin Property (LogPartsUsedConsumeSetup)

Inventory bin from which the part is being transferred

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FromBin As String

[PropertyBitValueAttribute()]
public string FromBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedConsumeSetup Class
LogPartsUsedConsumeSetup Members


FromContainer Property (LogPartsUsedConsumeSetup) | fcSDK Documentation

FromContainer Property (LogPartsUsedConsumeSetup)

Inventory container from which the part is being transferred

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FromContainer As String

[PropertyBitValueAttribute()]
public string FromContainer {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedConsumeSetup Class
LogPartsUsedConsumeSetup Members


FromGood Property (LogPartsUsedConsumeSetup) | fcSDK Documentation

FromGood Property (LogPartsUsedConsumeSetup)

Specifies whether the part is being transferred from good stock (true) or bad stock (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FromGood As Boolean

[PropertyBitValueAttribute()]
public bool FromGood {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedConsumeSetup Class
LogPartsUsedConsumeSetup Members


FromLocation Property (LogPartsUsedConsumeSetup) | fcSDK Documentation

FromLocation Property (LogPartsUsedConsumeSetup)

Inventory location from which the part is being transferred

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FromLocation As String

[PropertyBitValueAttribute()]
public string FromLocation {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedConsumeSetup Class
LogPartsUsedConsumeSetup Members


InstallAtSite Property (LogPartsUsedConsumeSetup) | fcSDK Documentation

InstallAtSite Property (LogPartsUsedConsumeSetup)

Indicates if the Part should be installed at the top-level of the Site

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallAtSite As Boolean

[PropertyBitValueAttribute()]
public bool InstallAtSite {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedConsumeSetup Class
LogPartsUsedConsumeSetup Members


InstallPartDomain Property (LogPartsUsedConsumeSetup) | fcSDK Documentation

InstallPartDomain Property (LogPartsUsedConsumeSetup)

The Part Domain of the part being installed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallPartDomain As String

[PropertyBitValueAttribute()]
public string InstallPartDomain {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedConsumeSetup Class
LogPartsUsedConsumeSetup Members


InstallPartNumber Property (LogPartsUsedConsumeSetup) | fcSDK Documentation

InstallPartNumber Property (LogPartsUsedConsumeSetup)

The Part Number of the part being installed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallPartNumber As String

[PropertyBitValueAttribute()]
public string InstallPartNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedConsumeSetup Class
LogPartsUsedConsumeSetup Members


InstallPartRevision Property (LogPartsUsedConsumeSetup) | fcSDK Documentation

InstallPartRevision Property (LogPartsUsedConsumeSetup)

The Part Revision of the part being installed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallPartRevision As String

[PropertyBitValueAttribute()]
public string InstallPartRevision {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedConsumeSetup Class
LogPartsUsedConsumeSetup Members


InstallPrice Property (LogPartsUsedConsumeSetup) | fcSDK Documentation

InstallPrice Property (LogPartsUsedConsumeSetup)

The Price of the part being installed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallPrice As String

[PropertyBitValueAttribute()]
public string InstallPrice {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedConsumeSetup Class
LogPartsUsedConsumeSetup Members


InstallQuantity Property (LogPartsUsedConsumeSetup) | fcSDK Documentation

InstallQuantity Property (LogPartsUsedConsumeSetup)

The Quantity of the part being installed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallQuantity As Integer

[PropertyBitValueAttribute()]
public int InstallQuantity {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedConsumeSetup Class
LogPartsUsedConsumeSetup Members


InstallSerialNumber Property (LogPartsUsedConsumeSetup) | fcSDK Documentation

InstallSerialNumber Property (LogPartsUsedConsumeSetup)

The Serial Number of the part being installed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallSerialNumber As String

[PropertyBitValueAttribute()]
public string InstallSerialNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedConsumeSetup Class
LogPartsUsedConsumeSetup Members


LogDate Property (LogPartsUsedConsumeSetup) | fcSDK Documentation

LogDate Property (LogPartsUsedConsumeSetup)

The DateTime the Part Usage occurred. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LogDate As Date

[PropertyBitValueAttribute()]
public DateTime LogDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedConsumeSetup Class
LogPartsUsedConsumeSetup Members


ParentSitePartObjid Property (LogPartsUsedConsumeSetup) | fcSDK Documentation

ParentSitePartObjid Property (LogPartsUsedConsumeSetup)

The Objid of the Parent Site Part where the part is being installed.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ParentSitePartObjid As Integer

[PropertyBitValueAttribute()]
public int ParentSitePartObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedConsumeSetup Class
LogPartsUsedConsumeSetup Members


PartRequestDetailIDNum Property (LogPartsUsedConsumeSetup) | fcSDK Documentation

PartRequestDetailIDNum Property (LogPartsUsedConsumeSetup)

The Id Number of the related Part Request Detail (if any)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRequestDetailIDNum As String

[PropertyBitValueAttribute()]
public string PartRequestDetailIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedConsumeSetup Class
LogPartsUsedConsumeSetup Members


UserName Property (LogPartsUsedConsumeSetup) | fcSDK Documentation

UserName Property (LogPartsUsedConsumeSetup)

The user who has logged the Part usage. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedConsumeSetup Class
LogPartsUsedConsumeSetup Members


LogPartsUsedExchangeSetup Class | fcSDK Documentation

LogPartsUsedExchangeSetup Class

Used by the LogPartsUsedExchange method as setup data for invocation.

Syntax

'Declaration

Public Class LogPartsUsedExchangeSetup

public class LogPartsUsedExchangeSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.FieldOps.LogPartsUsedExchangeSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.FieldOps

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LogPartsUsedExchangeSetup Members
FChoice.Toolkits.Clarify.FieldOps Namespace
LogPartsUsedExchange(LogPartsUsedExchangeSetup) Method


LogPartsUsedExchangeSetup Class Members | fcSDK Documentation

LogPartsUsedExchangeSetup Class Members

The following tables list the members exposed by LogPartsUsedExchangeSetup.

Public Constructors

 | Name | Description
Public Constructor | LogPartsUsedExchangeSetup Constructor | Overloaded.

Public Properties

 | Name | Description
Public Property | AllowMove | Indicates if a serialized part is to be moved if it already exists as an active Site Part
Public Property | CaseIDNum | The identifier of the Case with which this Part Usage is associated
Public Property | EngineerUserName | The user who has performed the Part usage. If not set, the Toolkit session user is used.
Public Property | FailureCode | Element from the 'Failure Code' application list. If not set the default list value is used.
Public Property | FromBin | Inventory bin from which the part is being transferred
Public Property | FromContainer | Inventory container from which the part is being transferred
Public Property | FromGood | Specifies whether the part is being transferred from good stock (true) or bad stock (false)
Public Property | FromLocation | Inventory location from which the part is being transferred
Public Property | InstallAtSite | Indicates if the Part should be installed at the top-level of the Site
Public Property | InstallPartDomain | The Part Domain of the part being installed
Public Property | InstallPartNumber | The Part Number of the part being installed
Public Property | InstallPartRevision | The Part Revision of the part being installed
Public Property | InstallPrice | The Price of the part being installed
Public Property | InstallQuantity | The Quantity of the part being installed
Public Property | InstallSerialNumber | The Serial Number of the part being installed
Public Property | LogDate | The DateTime the Part Usage occurred. If not set, the current time is used.
Public Property | ParentSitePartObjid | The Objid of the Parent Site Part where the part is being installed.
Public Property | PartRequestDetailIDNum | The Id Number of the related Part Request Detail (if any)
Public Property | RemoveSitePartObjid | The Objid of the Site Part being removed.
Public Property | ToBin | Inventory bin into which the part is being transferred
Public Property | ToContainer | Inventory container into which the part is being transferred
Public Property | ToGood | Specifies whether the part is being transferred resulting in good stock (true) or bad stock (false)
Public Property | ToLocation | Inventory location into which the part is being transferred
Public Property | UserName | The user who has logged the Part usage. If not set, the Toolkit session user is used.

Reference

LogPartsUsedExchangeSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
LogPartsUsedExchange(LogPartsUsedExchangeSetup) Method


LogPartsUsedExchangeSetup Constructor | fcSDK Documentation

LogPartsUsedExchangeSetup Constructor

Initializes a new instance of the LogPartsUsedExchangeSetup class.

Overload List

Overload | Description
LogPartsUsedExchangeSetup Constructor(String,Int32,String,String,String,String) | Initializes a new instance of the LogPartsUsedExchangeSetup class. This overload takes a set of required parameters for the API.
LogPartsUsedExchangeSetup Constructor(String,Int32,String,String,String,Int32) | Initializes a new instance of the LogPartsUsedExchangeSetup class. This overload takes a set of required parameters for the API.
LogPartsUsedExchangeSetup Constructor(String,String,Int32,String,String,String,String) | Initializes a new instance of the LogPartsUsedExchangeSetup class. This overload takes a set of required parameters for the API.
LogPartsUsedExchangeSetup Constructor(String,String,Int32,String,String,String,Int32) | Initializes a new instance of the LogPartsUsedExchangeSetup class. This overload takes a set of required parameters for the API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedExchangeSetup Class
LogPartsUsedExchangeSetup Members


LogPartsUsedExchangeSetup Constructor(String,Int32,String,String,String,String) | fcSDK Documentation

LogPartsUsedExchangeSetup Constructor(String,Int32,String,String,String,String)

The Id Number of the related Part Request Detail (if any)

The Objid of the Site Part being removed.

The Part Number of the part being installed

The Part Revision of the part being installed

The Part Domain of the part being installed

The Serial Number of the part being installed

Initializes a new instance of the LogPartsUsedExchangeSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _removeSitePartObjid_ As Integer, _
   ByVal _installPartNumber_ As String, _
   ByVal _installPartRevision_ As String, _
   ByVal _installPartDomain_ As String, _
   ByVal _installSerialNumber_ As String _
)

[ConstructorIndexAttribute()]
public LogPartsUsedExchangeSetup(
   string _partRequestDetailIDNum_,
   int _removeSitePartObjid_,
   string _installPartNumber_,
   string _installPartRevision_,
   string _installPartDomain_,
   string _installSerialNumber_
)

Parameters

partRequestDetailIDNum

The Id Number of the related Part Request Detail (if any)

removeSitePartObjid

The Objid of the Site Part being removed.

installPartNumber

The Part Number of the part being installed

installPartRevision

The Part Revision of the part being installed

installPartDomain

The Part Domain of the part being installed

installSerialNumber

The Serial Number of the part being installed

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedExchangeSetup Class
LogPartsUsedExchangeSetup Members
Overload List


LogPartsUsedExchangeSetup Constructor(String,Int32,String,String,String,Int32) | fcSDK Documentation

LogPartsUsedExchangeSetup Constructor(String,Int32,String,String,String,Int32)

The Id Number of the related Part Request Detail (if any)

The Objid of the Site Part being removed.

The Part Number of the part being installed

The Part Revision of the part being installed

The Part Domain of the part being installed

The Quantity of the part being installed

Initializes a new instance of the LogPartsUsedExchangeSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _removeSitePartObjid_ As Integer, _
   ByVal _installPartNumber_ As String, _
   ByVal _installPartRevision_ As String, _
   ByVal _installPartDomain_ As String, _
   ByVal _installQuantity_ As Integer _
)

[ConstructorIndexAttribute()]
public LogPartsUsedExchangeSetup(
   string _partRequestDetailIDNum_,
   int _removeSitePartObjid_,
   string _installPartNumber_,
   string _installPartRevision_,
   string _installPartDomain_,
   int _installQuantity_
)

Parameters

partRequestDetailIDNum

The Id Number of the related Part Request Detail (if any)

removeSitePartObjid

The Objid of the Site Part being removed.

installPartNumber

The Part Number of the part being installed

installPartRevision

The Part Revision of the part being installed

installPartDomain

The Part Domain of the part being installed

installQuantity

The Quantity of the part being installed

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedExchangeSetup Class
LogPartsUsedExchangeSetup Members
Overload List


LogPartsUsedExchangeSetup Constructor(String,String,Int32,String,String,String,String) | fcSDK Documentation

LogPartsUsedExchangeSetup Constructor(String,String,Int32,String,String,String,String)

The Id Number of the related Part Request Detail (if any)

The identifier of the Case with which this Part Usage is associated

The Objid of the Site Part being removed.

The Part Number of the part being installed

The Part Revision of the part being installed

The Part Domain of the part being installed

The Serial Number of the part being installed

Initializes a new instance of the LogPartsUsedExchangeSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _caseIDNum_ As String, _
   ByVal _removeSitePartObjid_ As Integer, _
   ByVal _installPartNumber_ As String, _
   ByVal _installPartRevision_ As String, _
   ByVal _installPartDomain_ As String, _
   ByVal _installSerialNumber_ As String _
)

[ConstructorIndexAttribute()]
public LogPartsUsedExchangeSetup(
   string _partRequestDetailIDNum_,
   string _caseIDNum_,
   int _removeSitePartObjid_,
   string _installPartNumber_,
   string _installPartRevision_,
   string _installPartDomain_,
   string _installSerialNumber_
)

Parameters

partRequestDetailIDNum

The Id Number of the related Part Request Detail (if any)

caseIDNum

The identifier of the Case with which this Part Usage is associated

removeSitePartObjid

The Objid of the Site Part being removed.

installPartNumber

The Part Number of the part being installed

installPartRevision

The Part Revision of the part being installed

installPartDomain

The Part Domain of the part being installed

installSerialNumber

The Serial Number of the part being installed

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedExchangeSetup Class
LogPartsUsedExchangeSetup Members
Overload List


LogPartsUsedExchangeSetup Constructor(String,String,Int32,String,String,String,Int32) | fcSDK Documentation

LogPartsUsedExchangeSetup Constructor(String,String,Int32,String,String,String,Int32)

The Id Number of the related Part Request Detail (if any)

The identifier of the Case with which this Part Usage is associated

The Objid of the Site Part being removed.

The Part Number of the part being installed

The Part Revision of the part being installed

The Part Domain of the part being installed

The Quantity of the part being installed

Initializes a new instance of the LogPartsUsedExchangeSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _caseIDNum_ As String, _
   ByVal _removeSitePartObjid_ As Integer, _
   ByVal _installPartNumber_ As String, _
   ByVal _installPartRevision_ As String, _
   ByVal _installPartDomain_ As String, _
   ByVal _installQuantity_ As Integer _
)

[ConstructorIndexAttribute()]
public LogPartsUsedExchangeSetup(
   string _partRequestDetailIDNum_,
   string _caseIDNum_,
   int _removeSitePartObjid_,
   string _installPartNumber_,
   string _installPartRevision_,
   string _installPartDomain_,
   int _installQuantity_
)

Parameters

partRequestDetailIDNum

The Id Number of the related Part Request Detail (if any)

caseIDNum

The identifier of the Case with which this Part Usage is associated

removeSitePartObjid

The Objid of the Site Part being removed.

installPartNumber

The Part Number of the part being installed

installPartRevision

The Part Revision of the part being installed

installPartDomain

The Part Domain of the part being installed

installQuantity

The Quantity of the part being installed

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedExchangeSetup Class
LogPartsUsedExchangeSetup Members
Overload List


AllowMove Property (LogPartsUsedExchangeSetup) | fcSDK Documentation

AllowMove Property (LogPartsUsedExchangeSetup)

Indicates if a serialized part is to be moved if it already exists as an active Site Part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AllowMove As Boolean

[PropertyBitValueAttribute()]
public bool AllowMove {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedExchangeSetup Class
LogPartsUsedExchangeSetup Members


CaseIDNum Property (LogPartsUsedExchangeSetup) | fcSDK Documentation

CaseIDNum Property (LogPartsUsedExchangeSetup)

The identifier of the Case with which this Part Usage is associated

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedExchangeSetup Class
LogPartsUsedExchangeSetup Members


EngineerUserName Property (LogPartsUsedExchangeSetup) | fcSDK Documentation

EngineerUserName Property (LogPartsUsedExchangeSetup)

The user who has performed the Part usage. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property EngineerUserName As String

[PropertyBitValueAttribute()]
public string EngineerUserName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedExchangeSetup Class
LogPartsUsedExchangeSetup Members


FailureCode Property (LogPartsUsedExchangeSetup) | fcSDK Documentation

FailureCode Property (LogPartsUsedExchangeSetup)

Element from the 'Failure Code' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FailureCode As String

[PropertyBitValueAttribute()]
public string FailureCode {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedExchangeSetup Class
LogPartsUsedExchangeSetup Members


FromBin Property (LogPartsUsedExchangeSetup) | fcSDK Documentation

FromBin Property (LogPartsUsedExchangeSetup)

Inventory bin from which the part is being transferred

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FromBin As String

[PropertyBitValueAttribute()]
public string FromBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedExchangeSetup Class
LogPartsUsedExchangeSetup Members


FromContainer Property (LogPartsUsedExchangeSetup) | fcSDK Documentation

FromContainer Property (LogPartsUsedExchangeSetup)

Inventory container from which the part is being transferred

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FromContainer As String

[PropertyBitValueAttribute()]
public string FromContainer {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedExchangeSetup Class
LogPartsUsedExchangeSetup Members


FromGood Property (LogPartsUsedExchangeSetup) | fcSDK Documentation

FromGood Property (LogPartsUsedExchangeSetup)

Specifies whether the part is being transferred from good stock (true) or bad stock (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FromGood As Boolean

[PropertyBitValueAttribute()]
public bool FromGood {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedExchangeSetup Class
LogPartsUsedExchangeSetup Members


FromLocation Property (LogPartsUsedExchangeSetup) | fcSDK Documentation

FromLocation Property (LogPartsUsedExchangeSetup)

Inventory location from which the part is being transferred

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FromLocation As String

[PropertyBitValueAttribute()]
public string FromLocation {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedExchangeSetup Class
LogPartsUsedExchangeSetup Members


InstallAtSite Property (LogPartsUsedExchangeSetup) | fcSDK Documentation

InstallAtSite Property (LogPartsUsedExchangeSetup)

Indicates if the Part should be installed at the top-level of the Site

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallAtSite As Boolean

[PropertyBitValueAttribute()]
public bool InstallAtSite {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedExchangeSetup Class
LogPartsUsedExchangeSetup Members


InstallPartDomain Property (LogPartsUsedExchangeSetup) | fcSDK Documentation

InstallPartDomain Property (LogPartsUsedExchangeSetup)

The Part Domain of the part being installed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallPartDomain As String

[PropertyBitValueAttribute()]
public string InstallPartDomain {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedExchangeSetup Class
LogPartsUsedExchangeSetup Members


InstallPartNumber Property (LogPartsUsedExchangeSetup) | fcSDK Documentation

InstallPartNumber Property (LogPartsUsedExchangeSetup)

The Part Number of the part being installed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallPartNumber As String

[PropertyBitValueAttribute()]
public string InstallPartNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedExchangeSetup Class
LogPartsUsedExchangeSetup Members


InstallPartRevision Property (LogPartsUsedExchangeSetup) | fcSDK Documentation

InstallPartRevision Property (LogPartsUsedExchangeSetup)

The Part Revision of the part being installed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallPartRevision As String

[PropertyBitValueAttribute()]
public string InstallPartRevision {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedExchangeSetup Class
LogPartsUsedExchangeSetup Members


InstallPrice Property (LogPartsUsedExchangeSetup) | fcSDK Documentation

InstallPrice Property (LogPartsUsedExchangeSetup)

The Price of the part being installed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallPrice As String

[PropertyBitValueAttribute()]
public string InstallPrice {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedExchangeSetup Class
LogPartsUsedExchangeSetup Members


InstallQuantity Property (LogPartsUsedExchangeSetup) | fcSDK Documentation

InstallQuantity Property (LogPartsUsedExchangeSetup)

The Quantity of the part being installed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallQuantity As Integer

[PropertyBitValueAttribute()]
public int InstallQuantity {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedExchangeSetup Class
LogPartsUsedExchangeSetup Members


InstallSerialNumber Property (LogPartsUsedExchangeSetup) | fcSDK Documentation

InstallSerialNumber Property (LogPartsUsedExchangeSetup)

The Serial Number of the part being installed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallSerialNumber As String

[PropertyBitValueAttribute()]
public string InstallSerialNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedExchangeSetup Class
LogPartsUsedExchangeSetup Members


LogDate Property (LogPartsUsedExchangeSetup) | fcSDK Documentation

LogDate Property (LogPartsUsedExchangeSetup)

The DateTime the Part Usage occurred. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LogDate As Date

[PropertyBitValueAttribute()]
public DateTime LogDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedExchangeSetup Class
LogPartsUsedExchangeSetup Members


ParentSitePartObjid Property (LogPartsUsedExchangeSetup) | fcSDK Documentation

ParentSitePartObjid Property (LogPartsUsedExchangeSetup)

The Objid of the Parent Site Part where the part is being installed.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ParentSitePartObjid As Integer

[PropertyBitValueAttribute()]
public int ParentSitePartObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedExchangeSetup Class
LogPartsUsedExchangeSetup Members


PartRequestDetailIDNum Property (LogPartsUsedExchangeSetup) | fcSDK Documentation

PartRequestDetailIDNum Property (LogPartsUsedExchangeSetup)

The Id Number of the related Part Request Detail (if any)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRequestDetailIDNum As String

[PropertyBitValueAttribute()]
public string PartRequestDetailIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedExchangeSetup Class
LogPartsUsedExchangeSetup Members


RemoveSitePartObjid Property (LogPartsUsedExchangeSetup) | fcSDK Documentation

RemoveSitePartObjid Property (LogPartsUsedExchangeSetup)

The Objid of the Site Part being removed.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property RemoveSitePartObjid As Integer

[PropertyBitValueAttribute()]
public int RemoveSitePartObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedExchangeSetup Class
LogPartsUsedExchangeSetup Members


ToBin Property (LogPartsUsedExchangeSetup) | fcSDK Documentation

ToBin Property (LogPartsUsedExchangeSetup)

Inventory bin into which the part is being transferred

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ToBin As String

[PropertyBitValueAttribute()]
public string ToBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedExchangeSetup Class
LogPartsUsedExchangeSetup Members


ToContainer Property (LogPartsUsedExchangeSetup) | fcSDK Documentation

ToContainer Property (LogPartsUsedExchangeSetup)

Inventory container into which the part is being transferred

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ToContainer As String

[PropertyBitValueAttribute()]
public string ToContainer {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedExchangeSetup Class
LogPartsUsedExchangeSetup Members


ToGood Property (LogPartsUsedExchangeSetup) | fcSDK Documentation

ToGood Property (LogPartsUsedExchangeSetup)

Specifies whether the part is being transferred resulting in good stock (true) or bad stock (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ToGood As Boolean

[PropertyBitValueAttribute()]
public bool ToGood {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedExchangeSetup Class
LogPartsUsedExchangeSetup Members


ToLocation Property (LogPartsUsedExchangeSetup) | fcSDK Documentation

ToLocation Property (LogPartsUsedExchangeSetup)

Inventory location into which the part is being transferred

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ToLocation As String

[PropertyBitValueAttribute()]
public string ToLocation {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedExchangeSetup Class
LogPartsUsedExchangeSetup Members


UserName Property (LogPartsUsedExchangeSetup) | fcSDK Documentation

UserName Property (LogPartsUsedExchangeSetup)

The user who has logged the Part usage. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedExchangeSetup Class
LogPartsUsedExchangeSetup Members


LogPartsUsedInstallSetup Class | fcSDK Documentation

LogPartsUsedInstallSetup Class

Used by the LogPartsUsedInstall method as setup data for invocation.

Syntax

'Declaration

Public Class LogPartsUsedInstallSetup

public class LogPartsUsedInstallSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.FieldOps.LogPartsUsedInstallSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.FieldOps

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LogPartsUsedInstallSetup Members
FChoice.Toolkits.Clarify.FieldOps Namespace
LogPartsUsedInstall(LogPartsUsedInstallSetup) Method


LogPartsUsedInstallSetup Class Members | fcSDK Documentation

LogPartsUsedInstallSetup Class Members

The following tables list the members exposed by LogPartsUsedInstallSetup.

Public Constructors

 | Name | Description
Public Constructor | LogPartsUsedInstallSetup Constructor | Overloaded.

Public Properties

 | Name | Description
Public Property | AllowMove | Indicates if a serialized part is to be moved if it already exists as an active Site Part
Public Property | CaseIDNum | The identifier of the Case with which this Part Usage is associated
Public Property | EngineerUserName | The user who has performed the Part usage. If not set, the Toolkit session user is used.
Public Property | FromBin | Inventory bin from which the part is being transferred
Public Property | FromContainer | Inventory container from which the part is being transferred
Public Property | FromGood | Specifies whether the part is being transferred from good stock (true) or bad stock (false)
Public Property | FromLocation | Inventory location from which the part is being transferred
Public Property | InstallAtSite | Indicates if the Part should be installed at the top-level of the Site
Public Property | InstallPartDomain | The Part Domain of the part being installed
Public Property | InstallPartNumber | The Part Number of the part being installed
Public Property | InstallPartRevision | The Part Revision of the part being installed
Public Property | InstallPrice | The Price of the part being installed
Public Property | InstallQuantity | The Quantity of the part being installed
Public Property | InstallSerialNumber | The Serial Number of the part being installed
Public Property | LogDate | The DateTime the Part Usage occurred. If not set, the current time is used.
Public Property | ParentSitePartObjid | The Objid of the Parent Site Part where the part is being installed.
Public Property | PartRequestDetailIDNum | The Id Number of the related Part Request Detail (if any)
Public Property | UserName | The user who has logged the Part usage. If not set, the Toolkit session user is used.

Reference

LogPartsUsedInstallSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
LogPartsUsedInstall(LogPartsUsedInstallSetup) Method


LogPartsUsedInstallSetup Constructor | fcSDK Documentation

LogPartsUsedInstallSetup Constructor

Initializes a new instance of the LogPartsUsedInstallSetup class.

Overload List

Overload | Description
LogPartsUsedInstallSetup Constructor(String,String,String,String,String) | Initializes a new instance of the LogPartsUsedInstallSetup class. This overload takes a set of required parameters for the API.
LogPartsUsedInstallSetup Constructor(String,String,String,String,Int32) | Initializes a new instance of the LogPartsUsedInstallSetup class. This overload takes a set of required parameters for the API.
LogPartsUsedInstallSetup Constructor(String,String,String,String,String,String) | Initializes a new instance of the LogPartsUsedInstallSetup class. This overload takes a set of required parameters for the API.
LogPartsUsedInstallSetup Constructor(String,String,String,String,String,Int32) | Initializes a new instance of the LogPartsUsedInstallSetup class. This overload takes a set of required parameters for the API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedInstallSetup Class
LogPartsUsedInstallSetup Members


LogPartsUsedInstallSetup Constructor(String,String,String,String,String) | fcSDK Documentation

LogPartsUsedInstallSetup Constructor(String,String,String,String,String)

The Id Number of the related Part Request Detail (if any)

The Part Number of the part being installed

The Part Revision of the part being installed

The Part Domain of the part being installed

The Serial Number of the part being installed

Initializes a new instance of the LogPartsUsedInstallSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _installPartNumber_ As String, _
   ByVal _installPartRevision_ As String, _
   ByVal _installPartDomain_ As String, _
   ByVal _installSerialNumber_ As String _
)

[ConstructorIndexAttribute()]
public LogPartsUsedInstallSetup(
   string _partRequestDetailIDNum_,
   string _installPartNumber_,
   string _installPartRevision_,
   string _installPartDomain_,
   string _installSerialNumber_
)

Parameters

partRequestDetailIDNum

The Id Number of the related Part Request Detail (if any)

installPartNumber

The Part Number of the part being installed

installPartRevision

The Part Revision of the part being installed

installPartDomain

The Part Domain of the part being installed

installSerialNumber

The Serial Number of the part being installed

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedInstallSetup Class
LogPartsUsedInstallSetup Members
Overload List


LogPartsUsedInstallSetup Constructor(String,String,String,String,Int32) | fcSDK Documentation

LogPartsUsedInstallSetup Constructor(String,String,String,String,Int32)

The Id Number of the related Part Request Detail (if any)

The Part Number of the part being installed

The Part Revision of the part being installed

The Part Domain of the part being installed

The Quantity of the part being installed

Initializes a new instance of the LogPartsUsedInstallSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _installPartNumber_ As String, _
   ByVal _installPartRevision_ As String, _
   ByVal _installPartDomain_ As String, _
   ByVal _installQuantity_ As Integer _
)

[ConstructorIndexAttribute()]
public LogPartsUsedInstallSetup(
   string _partRequestDetailIDNum_,
   string _installPartNumber_,
   string _installPartRevision_,
   string _installPartDomain_,
   int _installQuantity_
)

Parameters

partRequestDetailIDNum

The Id Number of the related Part Request Detail (if any)

installPartNumber

The Part Number of the part being installed

installPartRevision

The Part Revision of the part being installed

installPartDomain

The Part Domain of the part being installed

installQuantity

The Quantity of the part being installed

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedInstallSetup Class
LogPartsUsedInstallSetup Members
Overload List


LogPartsUsedInstallSetup Constructor(String,String,String,String,String,String) | fcSDK Documentation

LogPartsUsedInstallSetup Constructor(String,String,String,String,String,String)

The Id Number of the related Part Request Detail (if any)

The identifier of the Case with which this Part Usage is associated

The Part Number of the part being installed

The Part Revision of the part being installed

The Part Domain of the part being installed

The Serial Number of the part being installed

Initializes a new instance of the LogPartsUsedInstallSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _caseIDNum_ As String, _
   ByVal _installPartNumber_ As String, _
   ByVal _installPartRevision_ As String, _
   ByVal _installPartDomain_ As String, _
   ByVal _installSerialNumber_ As String _
)

[ConstructorIndexAttribute()]
public LogPartsUsedInstallSetup(
   string _partRequestDetailIDNum_,
   string _caseIDNum_,
   string _installPartNumber_,
   string _installPartRevision_,
   string _installPartDomain_,
   string _installSerialNumber_
)

Parameters

partRequestDetailIDNum

The Id Number of the related Part Request Detail (if any)

caseIDNum

The identifier of the Case with which this Part Usage is associated

installPartNumber

The Part Number of the part being installed

installPartRevision

The Part Revision of the part being installed

installPartDomain

The Part Domain of the part being installed

installSerialNumber

The Serial Number of the part being installed

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedInstallSetup Class
LogPartsUsedInstallSetup Members
Overload List


LogPartsUsedInstallSetup Constructor(String,String,String,String,String,Int32) | fcSDK Documentation

LogPartsUsedInstallSetup Constructor(String,String,String,String,String,Int32)

The Id Number of the related Part Request Detail (if any)

The identifier of the Case with which this Part Usage is associated

The Part Number of the part being installed

The Part Revision of the part being installed

The Part Domain of the part being installed

The Quantity of the part being installed

Initializes a new instance of the LogPartsUsedInstallSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _caseIDNum_ As String, _
   ByVal _installPartNumber_ As String, _
   ByVal _installPartRevision_ As String, _
   ByVal _installPartDomain_ As String, _
   ByVal _installQuantity_ As Integer _
)

[ConstructorIndexAttribute()]
public LogPartsUsedInstallSetup(
   string _partRequestDetailIDNum_,
   string _caseIDNum_,
   string _installPartNumber_,
   string _installPartRevision_,
   string _installPartDomain_,
   int _installQuantity_
)

Parameters

partRequestDetailIDNum

The Id Number of the related Part Request Detail (if any)

caseIDNum

The identifier of the Case with which this Part Usage is associated

installPartNumber

The Part Number of the part being installed

installPartRevision

The Part Revision of the part being installed

installPartDomain

The Part Domain of the part being installed

installQuantity

The Quantity of the part being installed

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedInstallSetup Class
LogPartsUsedInstallSetup Members
Overload List


AllowMove Property (LogPartsUsedInstallSetup) | fcSDK Documentation

AllowMove Property (LogPartsUsedInstallSetup)

Indicates if a serialized part is to be moved if it already exists as an active Site Part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AllowMove As Boolean

[PropertyBitValueAttribute()]
public bool AllowMove {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedInstallSetup Class
LogPartsUsedInstallSetup Members


CaseIDNum Property (LogPartsUsedInstallSetup) | fcSDK Documentation

CaseIDNum Property (LogPartsUsedInstallSetup)

The identifier of the Case with which this Part Usage is associated

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedInstallSetup Class
LogPartsUsedInstallSetup Members


EngineerUserName Property (LogPartsUsedInstallSetup) | fcSDK Documentation

EngineerUserName Property (LogPartsUsedInstallSetup)

The user who has performed the Part usage. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property EngineerUserName As String

[PropertyBitValueAttribute()]
public string EngineerUserName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedInstallSetup Class
LogPartsUsedInstallSetup Members


FromBin Property (LogPartsUsedInstallSetup) | fcSDK Documentation

FromBin Property (LogPartsUsedInstallSetup)

Inventory bin from which the part is being transferred

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FromBin As String

[PropertyBitValueAttribute()]
public string FromBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedInstallSetup Class
LogPartsUsedInstallSetup Members


FromContainer Property (LogPartsUsedInstallSetup) | fcSDK Documentation

FromContainer Property (LogPartsUsedInstallSetup)

Inventory container from which the part is being transferred

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FromContainer As String

[PropertyBitValueAttribute()]
public string FromContainer {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedInstallSetup Class
LogPartsUsedInstallSetup Members


FromGood Property (LogPartsUsedInstallSetup) | fcSDK Documentation

FromGood Property (LogPartsUsedInstallSetup)

Specifies whether the part is being transferred from good stock (true) or bad stock (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FromGood As Boolean

[PropertyBitValueAttribute()]
public bool FromGood {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedInstallSetup Class
LogPartsUsedInstallSetup Members


FromLocation Property (LogPartsUsedInstallSetup) | fcSDK Documentation

FromLocation Property (LogPartsUsedInstallSetup)

Inventory location from which the part is being transferred

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FromLocation As String

[PropertyBitValueAttribute()]
public string FromLocation {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedInstallSetup Class
LogPartsUsedInstallSetup Members


InstallAtSite Property (LogPartsUsedInstallSetup) | fcSDK Documentation

InstallAtSite Property (LogPartsUsedInstallSetup)

Indicates if the Part should be installed at the top-level of the Site

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallAtSite As Boolean

[PropertyBitValueAttribute()]
public bool InstallAtSite {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedInstallSetup Class
LogPartsUsedInstallSetup Members


InstallPartDomain Property (LogPartsUsedInstallSetup) | fcSDK Documentation

InstallPartDomain Property (LogPartsUsedInstallSetup)

The Part Domain of the part being installed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallPartDomain As String

[PropertyBitValueAttribute()]
public string InstallPartDomain {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedInstallSetup Class
LogPartsUsedInstallSetup Members


InstallPartNumber Property (LogPartsUsedInstallSetup) | fcSDK Documentation

InstallPartNumber Property (LogPartsUsedInstallSetup)

The Part Number of the part being installed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallPartNumber As String

[PropertyBitValueAttribute()]
public string InstallPartNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedInstallSetup Class
LogPartsUsedInstallSetup Members


InstallPartRevision Property (LogPartsUsedInstallSetup) | fcSDK Documentation

InstallPartRevision Property (LogPartsUsedInstallSetup)

The Part Revision of the part being installed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallPartRevision As String

[PropertyBitValueAttribute()]
public string InstallPartRevision {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedInstallSetup Class
LogPartsUsedInstallSetup Members


InstallPrice Property (LogPartsUsedInstallSetup) | fcSDK Documentation

InstallPrice Property (LogPartsUsedInstallSetup)

The Price of the part being installed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallPrice As String

[PropertyBitValueAttribute()]
public string InstallPrice {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedInstallSetup Class
LogPartsUsedInstallSetup Members


InstallQuantity Property (LogPartsUsedInstallSetup) | fcSDK Documentation

InstallQuantity Property (LogPartsUsedInstallSetup)

The Quantity of the part being installed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallQuantity As Integer

[PropertyBitValueAttribute()]
public int InstallQuantity {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedInstallSetup Class
LogPartsUsedInstallSetup Members


InstallSerialNumber Property (LogPartsUsedInstallSetup) | fcSDK Documentation

InstallSerialNumber Property (LogPartsUsedInstallSetup)

The Serial Number of the part being installed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallSerialNumber As String

[PropertyBitValueAttribute()]
public string InstallSerialNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedInstallSetup Class
LogPartsUsedInstallSetup Members


LogDate Property (LogPartsUsedInstallSetup) | fcSDK Documentation

LogDate Property (LogPartsUsedInstallSetup)

The DateTime the Part Usage occurred. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LogDate As Date

[PropertyBitValueAttribute()]
public DateTime LogDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedInstallSetup Class
LogPartsUsedInstallSetup Members


ParentSitePartObjid Property (LogPartsUsedInstallSetup) | fcSDK Documentation

ParentSitePartObjid Property (LogPartsUsedInstallSetup)

The Objid of the Parent Site Part where the part is being installed.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ParentSitePartObjid As Integer

[PropertyBitValueAttribute()]
public int ParentSitePartObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedInstallSetup Class
LogPartsUsedInstallSetup Members


PartRequestDetailIDNum Property (LogPartsUsedInstallSetup) | fcSDK Documentation

PartRequestDetailIDNum Property (LogPartsUsedInstallSetup)

The Id Number of the related Part Request Detail (if any)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRequestDetailIDNum As String

[PropertyBitValueAttribute()]
public string PartRequestDetailIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedInstallSetup Class
LogPartsUsedInstallSetup Members


UserName Property (LogPartsUsedInstallSetup) | fcSDK Documentation

UserName Property (LogPartsUsedInstallSetup)

The user who has logged the Part usage. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedInstallSetup Class
LogPartsUsedInstallSetup Members


LogPartsUsedRemoveSetup Class | fcSDK Documentation

LogPartsUsedRemoveSetup Class

Used by the LogPartsUsedRemove method as setup data for invocation.

Syntax

'Declaration

Public Class LogPartsUsedRemoveSetup

public class LogPartsUsedRemoveSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.FieldOps.LogPartsUsedRemoveSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.FieldOps

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LogPartsUsedRemoveSetup Members
FChoice.Toolkits.Clarify.FieldOps Namespace
LogPartsUsedRemove(LogPartsUsedRemoveSetup) Method


LogPartsUsedRemoveSetup Class Members | fcSDK Documentation

LogPartsUsedRemoveSetup Class Members

The following tables list the members exposed by LogPartsUsedRemoveSetup.

Public Constructors

 | Name | Description
Public Constructor | LogPartsUsedRemoveSetup Constructor | Overloaded.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AllowMove | Indicates if a serialized part is to be moved if it already exists as an active Site Part | | Public Property | CaseIDNum | The identifier of the Case with which this Part Usage is associated | | Public Property | EngineerUserName | The user who has performed the Part usage. If not set, the Toolkit session user is used. | | Public Property | FailureCode | Element from the 'Failure Code' application list. If not set the default list value is used. | | Public Property | InstallAtSite | Indicates if the Part should be installed at the top-level of the Site

| | Public Property | LogDate | The DateTime the Part Usage occurred. If not set, the current time is used. | | Public Property | ParentSitePartObjid | The Objid of the Parent Site Part where the part is being installed. | | Public Property | PartRequestDetailIDNum | The Id Number of the related Part Request Detail (if any) | | Public Property | RemoveQuantity | The quantity of parts to be removed. If not set, then the entire quantity will be removed. | | Public Property | RemoveSitePartObjid | The Objid of the Site Part being removed. | | Public Property | ToBin | Inventory bin into which the part is being transferred | | Public Property | ToContainer | Inventory container into which the part is being transferred | | Public Property | ToGood | Specifies whether the part is being transferred resulting in good stock (true) or bad stock (false) | | Public Property | ToLocation | Inventory location into which the part is being transferred | | Public Property | UserName | The user who has logged the Part usage. If not set, the Toolkit session user is used. |

Reference

LogPartsUsedRemoveSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
LogPartsUsedRemove(LogPartsUsedRemoveSetup) Method


LogPartsUsedRemoveSetup Constructor | fcSDK Documentation

LogPartsUsedRemoveSetup Constructor

Initializes a new instance of the LogPartsUsedRemoveSetup class.

Overload List

Overload | Description
LogPartsUsedRemoveSetup Constructor(String,Int32) | Initializes a new instance of the LogPartsUsedRemoveSetup class. This overload takes a set of required parameters for the API.
LogPartsUsedRemoveSetup Constructor(String,String,Int32) | Initializes a new instance of the LogPartsUsedRemoveSetup class. This overload takes a set of required parameters for the API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedRemoveSetup Class
LogPartsUsedRemoveSetup Members


LogPartsUsedRemoveSetup Constructor(String,Int32) | fcSDK Documentation

LogPartsUsedRemoveSetup Constructor(String,Int32)

The Id Number of the related Part Request Detail (if any)

The Objid of the Site Part being removed.

Initializes a new instance of the LogPartsUsedRemoveSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _removeSitePartObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public LogPartsUsedRemoveSetup(
   string _partRequestDetailIDNum_,
   int _removeSitePartObjid_
)

Parameters

partRequestDetailIDNum

The Id Number of the related Part Request Detail (if any)

removeSitePartObjid

The Objid of the Site Part being removed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedRemoveSetup Class
LogPartsUsedRemoveSetup Members
Overload List


LogPartsUsedRemoveSetup Constructor(String,String,Int32) | fcSDK Documentation

LogPartsUsedRemoveSetup Constructor(String,String,Int32)

The Id Number of the related Part Request Detail (if any)

The identifier of the Case with which this Part Usage is associated

The Objid of the Site Part being removed.

Initializes a new instance of the LogPartsUsedRemoveSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _caseIDNum_ As String, _
   ByVal _removeSitePartObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public LogPartsUsedRemoveSetup(
   string _partRequestDetailIDNum_,
   string _caseIDNum_,
   int _removeSitePartObjid_
)

Parameters

partRequestDetailIDNum

The Id Number of the related Part Request Detail (if any)

caseIDNum

The identifier of the Case with which this Part Usage is associated

removeSitePartObjid

The Objid of the Site Part being removed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedRemoveSetup Class
LogPartsUsedRemoveSetup Members
Overload List


AllowMove Property (LogPartsUsedRemoveSetup) | fcSDK Documentation

AllowMove Property (LogPartsUsedRemoveSetup)

Indicates if a serialized part is to be moved if it already exists as an active Site Part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AllowMove As Boolean

[PropertyBitValueAttribute()]
public bool AllowMove {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedRemoveSetup Class
LogPartsUsedRemoveSetup Members


CaseIDNum Property (LogPartsUsedRemoveSetup) | fcSDK Documentation

CaseIDNum Property (LogPartsUsedRemoveSetup)

The identifier of the Case with which this Part Usage is associated

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedRemoveSetup Class
LogPartsUsedRemoveSetup Members


EngineerUserName Property (LogPartsUsedRemoveSetup) | fcSDK Documentation

EngineerUserName Property (LogPartsUsedRemoveSetup)

The user who has performed the Part usage. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property EngineerUserName As String

[PropertyBitValueAttribute()]
public string EngineerUserName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedRemoveSetup Class
LogPartsUsedRemoveSetup Members


FailureCode Property (LogPartsUsedRemoveSetup) | fcSDK Documentation

FailureCode Property (LogPartsUsedRemoveSetup)

Element from the 'Failure Code' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FailureCode As String

[PropertyBitValueAttribute()]
public string FailureCode {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedRemoveSetup Class
LogPartsUsedRemoveSetup Members


InstallAtSite Property (LogPartsUsedRemoveSetup) | fcSDK Documentation

InstallAtSite Property (LogPartsUsedRemoveSetup)

Indicates if the Part should be installed at the top-level of the Site

Syntax

'Declaration

<PropertyBitValueAttribute()>
<[ObsoleteAttribute](#)("This property has no effect")>
Public Property InstallAtSite As Boolean

[PropertyBitValueAttribute()]
\[[ObsoleteAttribute](#)("This property has no effect")\]
public bool InstallAtSite {get; set;}

Remarks

This property is obsolete as it has no effect on this API call.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedRemoveSetup Class
LogPartsUsedRemoveSetup Members


LogDate Property (LogPartsUsedRemoveSetup) | fcSDK Documentation

LogDate Property (LogPartsUsedRemoveSetup)

The DateTime the Part Usage occurred. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LogDate As Date

[PropertyBitValueAttribute()]
public DateTime LogDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedRemoveSetup Class
LogPartsUsedRemoveSetup Members


ParentSitePartObjid Property (LogPartsUsedRemoveSetup) | fcSDK Documentation

ParentSitePartObjid Property (LogPartsUsedRemoveSetup)

The Objid of the Parent Site Part where the part is being installed.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ParentSitePartObjid As Integer

[PropertyBitValueAttribute()]
public int ParentSitePartObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedRemoveSetup Class
LogPartsUsedRemoveSetup Members


PartRequestDetailIDNum Property (LogPartsUsedRemoveSetup) | fcSDK Documentation

PartRequestDetailIDNum Property (LogPartsUsedRemoveSetup)

The Id Number of the related Part Request Detail (if any)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRequestDetailIDNum As String

[PropertyBitValueAttribute()]
public string PartRequestDetailIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedRemoveSetup Class
LogPartsUsedRemoveSetup Members


RemoveQuantity Property | fcSDK Documentation

RemoveQuantity Property

The quantity of parts to be removed. If not set, then the entire quantity will be removed.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property RemoveQuantity As Integer

[PropertyBitValueAttribute()]
public int RemoveQuantity {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedRemoveSetup Class
LogPartsUsedRemoveSetup Members


RemoveSitePartObjid Property (LogPartsUsedRemoveSetup) | fcSDK Documentation

RemoveSitePartObjid Property (LogPartsUsedRemoveSetup)

The Objid of the Site Part being removed.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property RemoveSitePartObjid As Integer

[PropertyBitValueAttribute()]
public int RemoveSitePartObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedRemoveSetup Class
LogPartsUsedRemoveSetup Members


ToBin Property (LogPartsUsedRemoveSetup) | fcSDK Documentation

ToBin Property (LogPartsUsedRemoveSetup)

Inventory bin into which the part is being transferred

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ToBin As String

[PropertyBitValueAttribute()]
public string ToBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedRemoveSetup Class
LogPartsUsedRemoveSetup Members


ToContainer Property (LogPartsUsedRemoveSetup) | fcSDK Documentation

ToContainer Property (LogPartsUsedRemoveSetup)

Inventory container into which the part is being transferred

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ToContainer As String

[PropertyBitValueAttribute()]
public string ToContainer {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedRemoveSetup Class
LogPartsUsedRemoveSetup Members


ToGood Property (LogPartsUsedRemoveSetup) | fcSDK Documentation

ToGood Property (LogPartsUsedRemoveSetup)

Specifies whether the part is being transferred resulting in good stock (true) or bad stock (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ToGood As Boolean

[PropertyBitValueAttribute()]
public bool ToGood {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedRemoveSetup Class
LogPartsUsedRemoveSetup Members


ToLocation Property (LogPartsUsedRemoveSetup) | fcSDK Documentation

ToLocation Property (LogPartsUsedRemoveSetup)

Inventory location into which the part is being transferred

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ToLocation As String

[PropertyBitValueAttribute()]
public string ToLocation {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedRemoveSetup Class
LogPartsUsedRemoveSetup Members


UserName Property (LogPartsUsedRemoveSetup) | fcSDK Documentation

UserName Property (LogPartsUsedRemoveSetup)

The user who has logged the Part usage. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedRemoveSetup Class
LogPartsUsedRemoveSetup Members


LogPartsUsedUpgradeSetup Class | fcSDK Documentation

LogPartsUsedUpgradeSetup Class

Used by the LogPartsUsedUpgrade method as setup data for invocation.

Syntax

'Declaration

Public Class LogPartsUsedUpgradeSetup

public class LogPartsUsedUpgradeSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.FieldOps.LogPartsUsedUpgradeSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.FieldOps

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LogPartsUsedUpgradeSetup Members
FChoice.Toolkits.Clarify.FieldOps Namespace
LogPartsUsedUpgrade(LogPartsUsedUpgradeSetup) Method


LogPartsUsedUpgradeSetup Class Members | fcSDK Documentation

LogPartsUsedUpgradeSetup Class Members

The following tables list the members exposed by LogPartsUsedUpgradeSetup.

Public Constructors

 | Name | Description
Public Constructor | LogPartsUsedUpgradeSetup Constructor | Overloaded.

Public Properties

 | Name | Description
Public Property | AllowMove | Indicates if a serialized part is to be moved if it already exists as an active Site Part
Public Property | CaseIDNum | The identifier of the Case with which this Part Usage is associated
Public Property | EngineerUserName | The user who has performed the Part usage. If not set, the Toolkit session user is used.
Public Property | FailureCode | Element from the 'Failure Code' application list. If not set the default list value is used.
Public Property | FromBin | Inventory bin from which the part is being transferred
Public Property | FromContainer | Inventory container from which the part is being transferred
Public Property | FromGood | Specifies whether the part is being transferred from good stock (true) or bad stock (false)
Public Property | FromLocation | Inventory location from which the part is being transferred
Public Property | InstallAtSite | Indicates if the Part should be installed at the top-level of the Site
Public Property | InstallPartDomain | The Part Domain of the part being installed
Public Property | InstallPartNumber | The Part Number of the part being installed
Public Property | InstallPartRevision | The Part Revision of the part being installed
Public Property | InstallPrice | The Price of the part being installed
Public Property | InstallQuantity | The Quantity of the part being installed
Public Property | InstallSerialNumber | The Serial Number of the part being installed
Public Property | LogDate | The DateTime the Part Usage occurred. If not set, the current time is used.
Public Property | ParentSitePartObjid | The Objid of the Parent Site Part where the part is being installed.
Public Property | PartRequestDetailIDNum | The Id Number of the related Part Request Detail (if any)
Public Property | RemoveSitePartObjid | The Objid of the Site Part being removed.
Public Property | ToBin | Inventory bin into which the part is being transferred
Public Property | ToContainer | Inventory container into which the part is being transferred
Public Property | ToGood | Specifies whether the part is being transferred resulting in good stock (true) or bad stock (false)
Public Property | ToLocation | Inventory location into which the part is being transferred
Public Property | UserName | The user who has logged the Part usage. If not set, the Toolkit session user is used.

Reference

LogPartsUsedUpgradeSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
LogPartsUsedUpgrade(LogPartsUsedUpgradeSetup) Method


LogPartsUsedUpgradeSetup Constructor | fcSDK Documentation

LogPartsUsedUpgradeSetup Constructor

Initializes a new instance of the LogPartsUsedUpgradeSetup class.

Overload List

Overload | Description
LogPartsUsedUpgradeSetup Constructor(String,Int32,String,String,String,String) | Initializes a new instance of the LogPartsUsedUpgradeSetup class. This overload takes a set of required parameters for the API.
LogPartsUsedUpgradeSetup Constructor(String,Int32,String,String,String,Int32) | Initializes a new instance of the LogPartsUsedUpgradeSetup class. This overload takes a set of required parameters for the API.
LogPartsUsedUpgradeSetup Constructor(String,String,Int32,String,String,String,String) | Initializes a new instance of the LogPartsUsedUpgradeSetup class. This overload takes a set of required parameters for the API.
LogPartsUsedUpgradeSetup Constructor(String,String,Int32,String,String,String,Int32) | Initializes a new instance of the LogPartsUsedUpgradeSetup class. This overload takes a set of required parameters for the API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedUpgradeSetup Class
LogPartsUsedUpgradeSetup Members


LogPartsUsedUpgradeSetup Constructor(String,Int32,String,String,String,String) | fcSDK Documentation

LogPartsUsedUpgradeSetup Constructor(String,Int32,String,String,String,String)

The Id Number of the related Part Request Detail (if any)

The Objid of the Site Part being removed.

The Part Number of the part being installed

The Part Revision of the part being installed

The Part Domain of the part being installed

The Serial Number of the part being installed

Initializes a new instance of the LogPartsUsedUpgradeSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _removeSitePartObjid_ As Integer, _
   ByVal _installPartNumber_ As String, _
   ByVal _installPartRevision_ As String, _
   ByVal _installPartDomain_ As String, _
   ByVal _installSerialNumber_ As String _
)

[ConstructorIndexAttribute()]
public LogPartsUsedUpgradeSetup(
   string _partRequestDetailIDNum_,
   int _removeSitePartObjid_,
   string _installPartNumber_,
   string _installPartRevision_,
   string _installPartDomain_,
   string _installSerialNumber_
)

Parameters

partRequestDetailIDNum

The Id Number of the related Part Request Detail (if any)

removeSitePartObjid

The Objid of the Site Part being removed.

installPartNumber

The Part Number of the part being installed

installPartRevision

The Part Revision of the part being installed

installPartDomain

The Part Domain of the part being installed

installSerialNumber

The Serial Number of the part being installed

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedUpgradeSetup Class
LogPartsUsedUpgradeSetup Members
Overload List


LogPartsUsedUpgradeSetup Constructor(String,Int32,String,String,String,Int32) | fcSDK Documentation

LogPartsUsedUpgradeSetup Constructor(String,Int32,String,String,String,Int32)

The Id Number of the related Part Request Detail (if any)

The Objid of the Site Part being removed.

The Part Number of the part being installed

The Part Revision of the part being installed

The Part Domain of the part being installed

The Quantity of the part being installed

Initializes a new instance of the LogPartsUsedUpgradeSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _removeSitePartObjid_ As Integer, _
   ByVal _installPartNumber_ As String, _
   ByVal _installPartRevision_ As String, _
   ByVal _installPartDomain_ As String, _
   ByVal _installQuantity_ As Integer _
)

[ConstructorIndexAttribute()]
public LogPartsUsedUpgradeSetup(
   string _partRequestDetailIDNum_,
   int _removeSitePartObjid_,
   string _installPartNumber_,
   string _installPartRevision_,
   string _installPartDomain_,
   int _installQuantity_
)

Parameters

partRequestDetailIDNum

The Id Number of the related Part Request Detail (if any)

removeSitePartObjid

The Objid of the Site Part being removed.

installPartNumber

The Part Number of the part being installed

installPartRevision

The Part Revision of the part being installed

installPartDomain

The Part Domain of the part being installed

installQuantity

The Quantity of the part being installed

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedUpgradeSetup Class
LogPartsUsedUpgradeSetup Members
Overload List


LogPartsUsedUpgradeSetup Constructor(String,String,Int32,String,String,String,String) | fcSDK Documentation

LogPartsUsedUpgradeSetup Constructor(String,String,Int32,String,String,String,String)

The Id Number of the related Part Request Detail (if any)

The identifier of the Case with which this Part Usage is associated

The Objid of the Site Part being removed.

The Part Number of the part being installed

The Part Revision of the part being installed

The Part Domain of the part being installed

The Serial Number of the part being installed

Initializes a new instance of the LogPartsUsedUpgradeSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _caseIDNum_ As String, _
   ByVal _removeSitePartObjid_ As Integer, _
   ByVal _installPartNumber_ As String, _
   ByVal _installPartRevision_ As String, _
   ByVal _installPartDomain_ As String, _
   ByVal _installSerialNumber_ As String _
)

[ConstructorIndexAttribute()]
public LogPartsUsedUpgradeSetup(
   string _partRequestDetailIDNum_,
   string _caseIDNum_,
   int _removeSitePartObjid_,
   string _installPartNumber_,
   string _installPartRevision_,
   string _installPartDomain_,
   string _installSerialNumber_
)

Parameters

partRequestDetailIDNum

The Id Number of the related Part Request Detail (if any)

caseIDNum

The identifier of the Case with which this Part Usage is associated

removeSitePartObjid

The Objid of the Site Part being removed.

installPartNumber

The Part Number of the part being installed

installPartRevision

The Part Revision of the part being installed

installPartDomain

The Part Domain of the part being installed

installSerialNumber

The Serial Number of the part being installed

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedUpgradeSetup Class
LogPartsUsedUpgradeSetup Members
Overload List


LogPartsUsedUpgradeSetup Constructor(String,String,Int32,String,String,String,Int32) | fcSDK Documentation

LogPartsUsedUpgradeSetup Constructor(String,String,Int32,String,String,String,Int32)

The Id Number of the related Part Request Detail (if any)

The identifier of the Case with which this Part Usage is associated

The Objid of the Site Part being removed.

The Part Number of the part being installed

The Part Revision of the part being installed

The Part Domain of the part being installed

The Quantity of the part being installed

Initializes a new instance of the LogPartsUsedUpgradeSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _caseIDNum_ As String, _
   ByVal _removeSitePartObjid_ As Integer, _
   ByVal _installPartNumber_ As String, _
   ByVal _installPartRevision_ As String, _
   ByVal _installPartDomain_ As String, _
   ByVal _installQuantity_ As Integer _
)

[ConstructorIndexAttribute()]
public LogPartsUsedUpgradeSetup(
   string _partRequestDetailIDNum_,
   string _caseIDNum_,
   int _removeSitePartObjid_,
   string _installPartNumber_,
   string _installPartRevision_,
   string _installPartDomain_,
   int _installQuantity_
)

Parameters

partRequestDetailIDNum

The Id Number of the related Part Request Detail (if any)

caseIDNum

The identifier of the Case with which this Part Usage is associated

removeSitePartObjid

The Objid of the Site Part being removed.

installPartNumber

The Part Number of the part being installed

installPartRevision

The Part Revision of the part being installed

installPartDomain

The Part Domain of the part being installed

installQuantity

The Quantity of the part being installed

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedUpgradeSetup Class
LogPartsUsedUpgradeSetup Members
Overload List


AllowMove Property (LogPartsUsedUpgradeSetup) | fcSDK Documentation

AllowMove Property (LogPartsUsedUpgradeSetup)

Indicates if a serialized part is to be moved if it already exists as an active Site Part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AllowMove As Boolean

[PropertyBitValueAttribute()]
public bool AllowMove {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedUpgradeSetup Class
LogPartsUsedUpgradeSetup Members


CaseIDNum Property (LogPartsUsedUpgradeSetup) | fcSDK Documentation

CaseIDNum Property (LogPartsUsedUpgradeSetup)

The identifier of the Case with which this Part Usage is associated

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedUpgradeSetup Class
LogPartsUsedUpgradeSetup Members


EngineerUserName Property (LogPartsUsedUpgradeSetup) | fcSDK Documentation

EngineerUserName Property (LogPartsUsedUpgradeSetup)

The user who has performed the Part usage. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property EngineerUserName As String

[PropertyBitValueAttribute()]
public string EngineerUserName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedUpgradeSetup Class
LogPartsUsedUpgradeSetup Members


FailureCode Property (LogPartsUsedUpgradeSetup) | fcSDK Documentation

FailureCode Property (LogPartsUsedUpgradeSetup)

Element from the 'Failure Code' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FailureCode As String

[PropertyBitValueAttribute()]
public string FailureCode {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedUpgradeSetup Class
LogPartsUsedUpgradeSetup Members


FromBin Property (LogPartsUsedUpgradeSetup) | fcSDK Documentation

FromBin Property (LogPartsUsedUpgradeSetup)

Inventory bin from which the part is being transferred

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FromBin As String

[PropertyBitValueAttribute()]
public string FromBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedUpgradeSetup Class
LogPartsUsedUpgradeSetup Members


FromContainer Property (LogPartsUsedUpgradeSetup) | fcSDK Documentation

FromContainer Property (LogPartsUsedUpgradeSetup)

Inventory container from which the part is being transferred

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FromContainer As String

[PropertyBitValueAttribute()]
public string FromContainer {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedUpgradeSetup Class
LogPartsUsedUpgradeSetup Members


FromGood Property (LogPartsUsedUpgradeSetup) | fcSDK Documentation

FromGood Property (LogPartsUsedUpgradeSetup)

Specifies whether the part is being transferred from good stock (true) or bad stock (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FromGood As Boolean

[PropertyBitValueAttribute()]
public bool FromGood {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedUpgradeSetup Class
LogPartsUsedUpgradeSetup Members


FromLocation Property (LogPartsUsedUpgradeSetup) | fcSDK Documentation

FromLocation Property (LogPartsUsedUpgradeSetup)

Inventory location from which the part is being transferred

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FromLocation As String

[PropertyBitValueAttribute()]
public string FromLocation {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedUpgradeSetup Class
LogPartsUsedUpgradeSetup Members


InstallAtSite Property (LogPartsUsedUpgradeSetup) | fcSDK Documentation

InstallAtSite Property (LogPartsUsedUpgradeSetup)

Indicates if the Part should be installed at the top-level of the Site

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallAtSite As Boolean

[PropertyBitValueAttribute()]
public bool InstallAtSite {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedUpgradeSetup Class
LogPartsUsedUpgradeSetup Members


InstallPartDomain Property (LogPartsUsedUpgradeSetup) | fcSDK Documentation

InstallPartDomain Property (LogPartsUsedUpgradeSetup)

The Part Domain of the part being installed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallPartDomain As String

[PropertyBitValueAttribute()]
public string InstallPartDomain {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedUpgradeSetup Class
LogPartsUsedUpgradeSetup Members


InstallPartNumber Property (LogPartsUsedUpgradeSetup) | fcSDK Documentation

InstallPartNumber Property (LogPartsUsedUpgradeSetup)

The Part Number of the part being installed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallPartNumber As String

[PropertyBitValueAttribute()]
public string InstallPartNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedUpgradeSetup Class
LogPartsUsedUpgradeSetup Members


InstallPartRevision Property (LogPartsUsedUpgradeSetup) | fcSDK Documentation

InstallPartRevision Property (LogPartsUsedUpgradeSetup)

The Part Revision of the part being installed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallPartRevision As String

[PropertyBitValueAttribute()]
public string InstallPartRevision {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedUpgradeSetup Class
LogPartsUsedUpgradeSetup Members


InstallPrice Property (LogPartsUsedUpgradeSetup) | fcSDK Documentation

InstallPrice Property (LogPartsUsedUpgradeSetup)

The Price of the part being installed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallPrice As String

[PropertyBitValueAttribute()]
public string InstallPrice {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedUpgradeSetup Class
LogPartsUsedUpgradeSetup Members


InstallQuantity Property (LogPartsUsedUpgradeSetup) | fcSDK Documentation

InstallQuantity Property (LogPartsUsedUpgradeSetup)

The Quantity of the part being installed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallQuantity As Integer

[PropertyBitValueAttribute()]
public int InstallQuantity {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedUpgradeSetup Class
LogPartsUsedUpgradeSetup Members


InstallSerialNumber Property (LogPartsUsedUpgradeSetup) | fcSDK Documentation

InstallSerialNumber Property (LogPartsUsedUpgradeSetup)

The Serial Number of the part being installed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallSerialNumber As String

[PropertyBitValueAttribute()]
public string InstallSerialNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedUpgradeSetup Class
LogPartsUsedUpgradeSetup Members


LogDate Property (LogPartsUsedUpgradeSetup) | fcSDK Documentation

LogDate Property (LogPartsUsedUpgradeSetup)

The DateTime the Part Usage occurred. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LogDate As Date

[PropertyBitValueAttribute()]
public DateTime LogDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedUpgradeSetup Class
LogPartsUsedUpgradeSetup Members


ParentSitePartObjid Property (LogPartsUsedUpgradeSetup) | fcSDK Documentation

ParentSitePartObjid Property (LogPartsUsedUpgradeSetup)

The Objid of the Parent Site Part where the part is being installed.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ParentSitePartObjid As Integer

[PropertyBitValueAttribute()]
public int ParentSitePartObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedUpgradeSetup Class
LogPartsUsedUpgradeSetup Members


PartRequestDetailIDNum Property (LogPartsUsedUpgradeSetup) | fcSDK Documentation

PartRequestDetailIDNum Property (LogPartsUsedUpgradeSetup)

The Id Number of the related Part Request Detail (if any)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRequestDetailIDNum As String

[PropertyBitValueAttribute()]
public string PartRequestDetailIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedUpgradeSetup Class
LogPartsUsedUpgradeSetup Members


RemoveSitePartObjid Property (LogPartsUsedUpgradeSetup) | fcSDK Documentation

RemoveSitePartObjid Property (LogPartsUsedUpgradeSetup)

The Objid of the Site Part being removed.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property RemoveSitePartObjid As Integer

[PropertyBitValueAttribute()]
public int RemoveSitePartObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedUpgradeSetup Class
LogPartsUsedUpgradeSetup Members


ToBin Property (LogPartsUsedUpgradeSetup) | fcSDK Documentation

ToBin Property (LogPartsUsedUpgradeSetup)

Inventory bin into which the part is being transferred

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ToBin As String

[PropertyBitValueAttribute()]
public string ToBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedUpgradeSetup Class
LogPartsUsedUpgradeSetup Members


ToContainer Property (LogPartsUsedUpgradeSetup) | fcSDK Documentation

ToContainer Property (LogPartsUsedUpgradeSetup)

Inventory container into which the part is being transferred

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ToContainer As String

[PropertyBitValueAttribute()]
public string ToContainer {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedUpgradeSetup Class
LogPartsUsedUpgradeSetup Members


ToGood Property (LogPartsUsedUpgradeSetup) | fcSDK Documentation

ToGood Property (LogPartsUsedUpgradeSetup)

Specifies whether the part is being transferred resulting in good stock (true) or bad stock (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ToGood As Boolean

[PropertyBitValueAttribute()]
public bool ToGood {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedUpgradeSetup Class
LogPartsUsedUpgradeSetup Members


ToLocation Property (LogPartsUsedUpgradeSetup) | fcSDK Documentation

ToLocation Property (LogPartsUsedUpgradeSetup)

Inventory location into which the part is being transferred

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ToLocation As String

[PropertyBitValueAttribute()]
public string ToLocation {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedUpgradeSetup Class
LogPartsUsedUpgradeSetup Members


UserName Property (LogPartsUsedUpgradeSetup) | fcSDK Documentation

UserName Property (LogPartsUsedUpgradeSetup)

The user who has logged the Part usage. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogPartsUsedUpgradeSetup Class
LogPartsUsedUpgradeSetup Members


MoveSitePartToBinSetup Class | fcSDK Documentation

MoveSitePartToBinSetup Class

Used by the MoveSitePartToBin method as setup data for invocation.

Syntax

'Declaration

Public Class MoveSitePartToBinSetup

public class MoveSitePartToBinSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.FieldOps.MoveSitePartToBinSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.FieldOps

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

MoveSitePartToBinSetup Members
FChoice.Toolkits.Clarify.FieldOps Namespace
MoveSitePartToBin(MoveSitePartToBinSetup) Method


MoveSitePartToBinSetup Class Members | fcSDK Documentation

MoveSitePartToBinSetup Class Members

The following tables list the members exposed by MoveSitePartToBinSetup.

Public Constructors

 | Name | Description
Public Constructor | MoveSitePartToBinSetup Constructor | Initializes a new instance of the MoveSitePartToBinSetup class.

Public Properties

 | Name | Description
Public Property | AddActivityLog | Specifies if activity entry records should be created.
Public Property | InstallAndMove | Specifies if activity entry records should be set to "Install (Move)" (true) or "Move" (false).
Public Property | MoveDate | DateTime the SitePartToBin was moved. If not set, the current time is used.
Public Property | ParentBinObjid | The Objid of the Parent Site Bin where the Site Part is being moved.
Public Property | SitePartObjid | The Objid of the Site Part being moved.
Public Property | UserName | The user who has moved the SitePartToBin. If not set, the Toolkit session user is used.

Reference

MoveSitePartToBinSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
MoveSitePartToBin(MoveSitePartToBinSetup) Method


MoveSitePartToBinSetup Constructor | fcSDK Documentation

MoveSitePartToBinSetup Constructor

The Objid of the Site Part being moved.

The Objid of the Parent Site Bin where the Site Part is being moved.

Initializes a new instance of the MoveSitePartToBinSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _sitePartObjid_ As Integer, _
   ByVal _parentBinObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public MoveSitePartToBinSetup(
   int _sitePartObjid_,
   int _parentBinObjid_
)

Parameters

sitePartObjid

The Objid of the Site Part being moved.

parentBinObjid

The Objid of the Parent Site Bin where the Site Part is being moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSitePartToBinSetup Class
MoveSitePartToBinSetup Members


AddActivityLog Property (MoveSitePartToBinSetup) | fcSDK Documentation

AddActivityLog Property (MoveSitePartToBinSetup)

Specifies if activity entry records should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AddActivityLog As Boolean

[PropertyBitValueAttribute()]
public bool AddActivityLog {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSitePartToBinSetup Class
MoveSitePartToBinSetup Members


InstallAndMove Property (MoveSitePartToBinSetup) | fcSDK Documentation

InstallAndMove Property (MoveSitePartToBinSetup)

Specifies if activity entry records should be set to "Install (Move)" (true) or "Move" (false).

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallAndMove As Boolean

[PropertyBitValueAttribute()]
public bool InstallAndMove {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSitePartToBinSetup Class
MoveSitePartToBinSetup Members


MoveDate Property (MoveSitePartToBinSetup) | fcSDK Documentation

MoveDate Property (MoveSitePartToBinSetup)

DateTime the SitePartToBin was moved. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property MoveDate As Date

[PropertyBitValueAttribute()]
public DateTime MoveDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSitePartToBinSetup Class
MoveSitePartToBinSetup Members


ParentBinObjid Property (MoveSitePartToBinSetup) | fcSDK Documentation

ParentBinObjid Property (MoveSitePartToBinSetup)

The Objid of the Parent Site Bin where the Site Part is being moved.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ParentBinObjid As Integer

[PropertyBitValueAttribute()]
public int ParentBinObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSitePartToBinSetup Class
MoveSitePartToBinSetup Members


SitePartObjid Property (MoveSitePartToBinSetup) | fcSDK Documentation

SitePartObjid Property (MoveSitePartToBinSetup)

The Objid of the Site Part being moved.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SitePartObjid As Integer

[PropertyBitValueAttribute()]
public int SitePartObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSitePartToBinSetup Class
MoveSitePartToBinSetup Members


UserName Property (MoveSitePartToBinSetup) | fcSDK Documentation

UserName Property (MoveSitePartToBinSetup)

The user who has moved the SitePartToBin. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSitePartToBinSetup Class
MoveSitePartToBinSetup Members


MoveSitePartToPartSetup Class | fcSDK Documentation

MoveSitePartToPartSetup Class

Used by the MoveSitePartToPart method as setup data for invocation.

Syntax

'Declaration

Public Class MoveSitePartToPartSetup

public class MoveSitePartToPartSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.FieldOps.MoveSitePartToPartSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.FieldOps

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

MoveSitePartToPartSetup Members
FChoice.Toolkits.Clarify.FieldOps Namespace
MoveSitePartToPart(MoveSitePartToPartSetup) Method


MoveSitePartToPartSetup Class Members | fcSDK Documentation

MoveSitePartToPartSetup Class Members

The following tables list the members exposed by MoveSitePartToPartSetup.

Public Constructors

 | Name | Description
Public Constructor | MoveSitePartToPartSetup Constructor | Initializes a new instance of the MoveSitePartToPartSetup class.

Public Properties

 | Name | Description
Public Property | AddActivityLog | Specifies if activity entry records should be created.
Public Property | InstallAndMove | Specifies if activity entry records should be set to "Install (Move)" (true) or "Move" (false).
Public Property | MoveDate | DateTime the SitePartToPart was moved. If not set, the current time is used.
Public Property | ParentSitePartObjid | The Objid of the Parent Site where the Site Part is being moved.
Public Property | SitePartObjid | The Objid of the Site Part being moved.
Public Property | UserName | The user who has moved the SitePartToPart. If not set, the Toolkit session user is used.

Reference

MoveSitePartToPartSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
MoveSitePartToPart(MoveSitePartToPartSetup) Method


MoveSitePartToPartSetup Constructor | fcSDK Documentation

MoveSitePartToPartSetup Constructor

The Objid of the Site Part being moved.

The Objid of the Parent Site where the Site Part is being moved.

Initializes a new instance of the MoveSitePartToPartSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _sitePartObjid_ As Integer, _
   ByVal _parentSitePartObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public MoveSitePartToPartSetup(
   int _sitePartObjid_,
   int _parentSitePartObjid_
)

Parameters

sitePartObjid

The Objid of the Site Part being moved.

parentSitePartObjid

The Objid of the Parent Site where the Site Part is being moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSitePartToPartSetup Class
MoveSitePartToPartSetup Members


AddActivityLog Property (MoveSitePartToPartSetup) | fcSDK Documentation

AddActivityLog Property (MoveSitePartToPartSetup)

Specifies if activity entry records should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AddActivityLog As Boolean

[PropertyBitValueAttribute()]
public bool AddActivityLog {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSitePartToPartSetup Class
MoveSitePartToPartSetup Members


InstallAndMove Property (MoveSitePartToPartSetup) | fcSDK Documentation

InstallAndMove Property (MoveSitePartToPartSetup)

Specifies if activity entry records should be set to "Install (Move)" (true) or "Move" (false).

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallAndMove As Boolean

[PropertyBitValueAttribute()]
public bool InstallAndMove {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSitePartToPartSetup Class
MoveSitePartToPartSetup Members


MoveDate Property (MoveSitePartToPartSetup) | fcSDK Documentation

MoveDate Property (MoveSitePartToPartSetup)

DateTime the SitePartToPart was moved. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property MoveDate As Date

[PropertyBitValueAttribute()]
public DateTime MoveDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSitePartToPartSetup Class
MoveSitePartToPartSetup Members


ParentSitePartObjid Property (MoveSitePartToPartSetup) | fcSDK Documentation

ParentSitePartObjid Property (MoveSitePartToPartSetup)

The Objid of the Parent Site where the Site Part is being moved.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ParentSitePartObjid As Integer

[PropertyBitValueAttribute()]
public int ParentSitePartObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSitePartToPartSetup Class
MoveSitePartToPartSetup Members


SitePartObjid Property (MoveSitePartToPartSetup) | fcSDK Documentation

SitePartObjid Property (MoveSitePartToPartSetup)

The Objid of the Site Part being moved.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SitePartObjid As Integer

[PropertyBitValueAttribute()]
public int SitePartObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSitePartToPartSetup Class
MoveSitePartToPartSetup Members


UserName Property (MoveSitePartToPartSetup) | fcSDK Documentation

UserName Property (MoveSitePartToPartSetup)

The user who has moved the SitePartToPart. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSitePartToPartSetup Class
MoveSitePartToPartSetup Members


MoveSitePartToSiteSetup Class | fcSDK Documentation

MoveSitePartToSiteSetup Class

Used by the MoveSitePartToSite method as setup data for invocation.

Syntax

'Declaration

Public Class MoveSitePartToSiteSetup

public class MoveSitePartToSiteSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.FieldOps.MoveSitePartToSiteSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.FieldOps

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

MoveSitePartToSiteSetup Members
FChoice.Toolkits.Clarify.FieldOps Namespace
MoveSitePartToSite(MoveSitePartToSiteSetup) Method


MoveSitePartToSiteSetup Class Members | fcSDK Documentation

MoveSitePartToSiteSetup Class Members

The following tables list the members exposed by MoveSitePartToSiteSetup.

Public Constructors

 | Name | Description
Public Constructor | MoveSitePartToSiteSetup Constructor | Initializes a new instance of the MoveSitePartToSiteSetup class.

Public Properties

 | Name | Description
Public Property | AddActivityLog | Specifies if activity entry records should be created.
Public Property | InstallAndMove | Specifies if activity entry records should be set to "Install (Move)" (true) or "Move" (false).
Public Property | MoveDate | DateTime the SitePartToSite was moved. If not set, the current time is used.
Public Property | SiteIDNum | The Site Id of the Site where the Site Part is being moved.
Public Property | SitePartObjid | The Objid of the Site Part being moved.
Public Property | UserName | The user who has moved the SitePartToSite. If not set, the Toolkit session user is used.

Reference

MoveSitePartToSiteSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
MoveSitePartToSite(MoveSitePartToSiteSetup) Method


MoveSitePartToSiteSetup Constructor | fcSDK Documentation

MoveSitePartToSiteSetup Constructor

The Objid of the Site Part being moved.

The Site Id of the Site where the Site Part is being moved.

Initializes a new instance of the MoveSitePartToSiteSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _sitePartObjid_ As Integer, _
   ByVal _siteIDNum_ As String _
)

[ConstructorIndexAttribute()]
public MoveSitePartToSiteSetup(
   int _sitePartObjid_,
   string _siteIDNum_
)

Parameters

sitePartObjid

The Objid of the Site Part being moved.

siteIDNum

The Site Id of the Site where the Site Part is being moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSitePartToSiteSetup Class
MoveSitePartToSiteSetup Members


AddActivityLog Property (MoveSitePartToSiteSetup) | fcSDK Documentation

AddActivityLog Property (MoveSitePartToSiteSetup)

Specifies if activity entry records should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AddActivityLog As Boolean

[PropertyBitValueAttribute()]
public bool AddActivityLog {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSitePartToSiteSetup Class
MoveSitePartToSiteSetup Members


InstallAndMove Property (MoveSitePartToSiteSetup) | fcSDK Documentation

InstallAndMove Property (MoveSitePartToSiteSetup)

Specifies if activity entry records should be set to "Install (Move)" (true) or "Move" (false).

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallAndMove As Boolean

[PropertyBitValueAttribute()]
public bool InstallAndMove {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSitePartToSiteSetup Class
MoveSitePartToSiteSetup Members


MoveDate Property (MoveSitePartToSiteSetup) | fcSDK Documentation

MoveDate Property (MoveSitePartToSiteSetup)

DateTime the SitePartToSite was moved. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property MoveDate As Date

[PropertyBitValueAttribute()]
public DateTime MoveDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSitePartToSiteSetup Class
MoveSitePartToSiteSetup Members


SiteIDNum Property (MoveSitePartToSiteSetup) | fcSDK Documentation

SiteIDNum Property (MoveSitePartToSiteSetup)

The Site Id of the Site where the Site Part is being moved.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteIDNum As String

[PropertyBitValueAttribute()]
public string SiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSitePartToSiteSetup Class
MoveSitePartToSiteSetup Members


SitePartObjid Property (MoveSitePartToSiteSetup) | fcSDK Documentation

SitePartObjid Property (MoveSitePartToSiteSetup)

The Objid of the Site Part being moved.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SitePartObjid As Integer

[PropertyBitValueAttribute()]
public int SitePartObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSitePartToSiteSetup Class
MoveSitePartToSiteSetup Members


UserName Property (MoveSitePartToSiteSetup) | fcSDK Documentation

UserName Property (MoveSitePartToSiteSetup)

The user who has moved the SitePartToSite. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSitePartToSiteSetup Class
MoveSitePartToSiteSetup Members


PartTransferResult Class | fcSDK Documentation

PartTransferResult Class

Result from the PartTransfer API.

Syntax

'Declaration

Public Class PartTransferResult
   Inherits FChoice.Toolkits.Clarify.ToolkitResult

public class PartTransferResult : FChoice.Toolkits.Clarify.ToolkitResult

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.ToolkitResult
FChoice.Toolkits.Clarify.FieldOps.PartTransferResult

Requirements

Namespace: FChoice.Toolkits.Clarify.FieldOps

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

PartTransferResult Members
FChoice.Toolkits.Clarify.FieldOps Namespace


PartTransferResult Class Members | fcSDK Documentation

PartTransferResult Class Members

The following tables list the members exposed by PartTransferResult.

Public Constructors

 | Name | Description
Public Constructor | PartTransferResult Constructor |

Public Properties

 | Name | Description
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | StandardCost | Part Transfer Standard Cost.
Public Property | TransactionIDNum | Part Transfer Transaction Identifier.

Reference

PartTransferResult Class
FChoice.Toolkits.Clarify.FieldOps Namespace


PartTransferResult Constructor | fcSDK Documentation

PartTransferResult Constructor

Syntax

'Declaration

Public Function New()

public PartTransferResult()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartTransferResult Class
PartTransferResult Members


StandardCost Property (PartTransferResult) | fcSDK Documentation

StandardCost Property (PartTransferResult)

Part Transfer Standard Cost.

Syntax

'Declaration

Public Property StandardCost As Decimal

public decimal StandardCost {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartTransferResult Class
PartTransferResult Members


TransactionIDNum Property (PartTransferResult) | fcSDK Documentation

TransactionIDNum Property (PartTransferResult)

Part Transfer Transaction Identifier.

Syntax

'Declaration

Public Property TransactionIDNum As String

public string TransactionIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartTransferResult Class
PartTransferResult Members


PartTransferSetup Class | fcSDK Documentation

PartTransferSetup Class

Used by the PartTransfer method as setup data for invocation.

Syntax

'Declaration

Public Class PartTransferSetup

public class PartTransferSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.FieldOps.PartTransferSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.FieldOps

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

PartTransferSetup Members
FChoice.Toolkits.Clarify.FieldOps Namespace
PartTransfer(PartTransferSetup) Method


PartTransferSetup Class Members | fcSDK Documentation

PartTransferSetup Class Members

The following tables list the members exposed by PartTransferSetup.

Public Constructors

 | Name | Description
Public Constructor | PartTransferSetup Constructor | Overloaded.

Public Properties

 | Name | Description
Public Property | FromGood | Specifies whether the part is being transferred from good stock (true) or bad stock (false)
Public Property | FromLocation | Inventory location (or expense GL) and bin from which to transfer the part
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Notes | Notes about the Part Transfer
Public Property | PartDomain | Part domain for the Part Request
Public Property | PartNumber | Part number for the Part Request
Public Property | PartRevision | Part revision for the Part Request
Public Property | Quantity | The number of parts being transferred
Public Property | ReferenceIDNum | Optional reference number for this part transfer
Public Property | SerialNumber | The serial number of the part being transferred
Public Property | ToGood | Specifies whether the part is being transferred resulting in good stock (true) or bad stock (false)
Public Property | ToLocation | Inventory location and bin (or GL account) into which the part is being transferred.
Public Property | TransferDate | The DateTime the Part Transfer occurred. If not set, the current time is used.
Public Property | UserName | The user who is transferring the Part. If not set, the session user is used.

Reference

PartTransferSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
PartTransfer(PartTransferSetup) Method


PartTransferSetup Constructor | fcSDK Documentation

PartTransferSetup Constructor

Initializes a new instance of the PartTransferSetup class.

Overload List

Overload | Description
PartTransferSetup Constructor(String,String,String,Int32,Location,Location) | Initializes a new instance of the PartTransferSetup class. This overload takes a set of required parameters for the API.
PartTransferSetup Constructor(String,String,String,String,Location,Location) | Initializes a new instance of the PartTransferSetup class. This overload takes a set of required parameters for the API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartTransferSetup Class
PartTransferSetup Members


PartTransferSetup Constructor(String,String,String,Int32,Location,Location) | fcSDK Documentation

PartTransferSetup Constructor(String,String,String,Int32,Location,Location)

Part number for the Part Request

Part revision for the Part Request

Part domain for the Part Request

The number of parts being transferred

Inventory location (or expense GL) and bin from which to transfer the part

Inventory location and bin (or GL account) into which the part is being transferred

Initializes a new instance of the PartTransferSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partNumber_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _quantity_ As Integer, _
   ByVal _fromlocation_ As Location, _
   ByVal _tolocation_ As Location _
)

[ConstructorIndexAttribute()]
public PartTransferSetup(
   string _partNumber_,
   string _partRevision_,
   string _partDomain_,
   int _quantity_,
   Location _fromlocation_,
   Location _tolocation_
)

Parameters

partNumber

Part number for the Part Request

partRevision

Part revision for the Part Request

partDomain

Part domain for the Part Request

quantity

The number of parts being transferred

fromlocation

Inventory location (or expense GL) and bin from which to transfer the part

tolocation

Inventory location and bin (or GL account) into which the part is being transferred

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartTransferSetup Class
PartTransferSetup Members
Overload List


PartTransferSetup Constructor(String,String,String,String,Location,Location) | fcSDK Documentation

PartTransferSetup Constructor(String,String,String,String,Location,Location)

Part number for the Part Request

Part revision for the Part Request

Part domain for the Part Request

The serial number of the part being transferred

Inventory location (or expense GL) and bin from which to transfer the part

Inventory location and bin (or GL account) into which the part is being transferred

Initializes a new instance of the PartTransferSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partNumber_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _serialNumber_ As String, _
   ByVal _fromlocation_ As Location, _
   ByVal _tolocation_ As Location _
)

[ConstructorIndexAttribute()]
public PartTransferSetup(
   string _partNumber_,
   string _partRevision_,
   string _partDomain_,
   string _serialNumber_,
   Location _fromlocation_,
   Location _tolocation_
)

Parameters

partNumber

Part number for the Part Request

partRevision

Part revision for the Part Request

partDomain

Part domain for the Part Request

serialNumber

The serial number of the part being transferred

fromlocation

Inventory location (or expense GL) and bin from which to transfer the part

tolocation

Inventory location and bin (or GL account) into which the part is being transferred

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartTransferSetup Class
PartTransferSetup Members
Overload List


FromGood Property (PartTransferSetup) | fcSDK Documentation

FromGood Property (PartTransferSetup)

Specifies whether the part is being transferred from good stock (true) or bad stock (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FromGood As Boolean

[PropertyBitValueAttribute()]
public bool FromGood {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartTransferSetup Class
PartTransferSetup Members


FromLocation Property (PartTransferSetup) | fcSDK Documentation

FromLocation Property (PartTransferSetup)

Inventory location (or expense GL) and bin from which to transfer the part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FromLocation As Location

[PropertyBitValueAttribute()]
public Location FromLocation {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartTransferSetup Class
PartTransferSetup Members


GenerateTimeBombs Property (PartTransferSetup) | fcSDK Documentation

GenerateTimeBombs Property (PartTransferSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartTransferSetup Class
PartTransferSetup Members


Notes Property (PartTransferSetup) | fcSDK Documentation

Notes Property (PartTransferSetup)

Notes about the Part Transfer

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartTransferSetup Class
PartTransferSetup Members


PartDomain Property (PartTransferSetup) | fcSDK Documentation

PartDomain Property (PartTransferSetup)

Part domain for the Part Request

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartDomain As String

[PropertyBitValueAttribute()]
public string PartDomain {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartTransferSetup Class
PartTransferSetup Members


PartNumber Property (PartTransferSetup) | fcSDK Documentation

PartNumber Property (PartTransferSetup)

Part number for the Part Request

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartNumber As String

[PropertyBitValueAttribute()]
public string PartNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartTransferSetup Class
PartTransferSetup Members


PartRevision Property (PartTransferSetup) | fcSDK Documentation

PartRevision Property (PartTransferSetup)

Part revision for the Part Request

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRevision As String

[PropertyBitValueAttribute()]
public string PartRevision {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartTransferSetup Class
PartTransferSetup Members


Quantity Property (PartTransferSetup) | fcSDK Documentation

Quantity Property (PartTransferSetup)

The number of parts being transferred

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Quantity As Integer

[PropertyBitValueAttribute()]
public int Quantity {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartTransferSetup Class
PartTransferSetup Members


ReferenceIDNum Property (PartTransferSetup) | fcSDK Documentation

ReferenceIDNum Property (PartTransferSetup)

Optional reference number for this part transfer

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ReferenceIDNum As String

[PropertyBitValueAttribute()]
public string ReferenceIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartTransferSetup Class
PartTransferSetup Members


SerialNumber Property (PartTransferSetup) | fcSDK Documentation

SerialNumber Property (PartTransferSetup)

The serial number of the part being transferred

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SerialNumber As String

[PropertyBitValueAttribute()]
public string SerialNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartTransferSetup Class
PartTransferSetup Members


ToGood Property (PartTransferSetup) | fcSDK Documentation

ToGood Property (PartTransferSetup)

Specifies whether the part is being transferred resulting in good stock (true) or bad stock (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ToGood As Boolean

[PropertyBitValueAttribute()]
public bool ToGood {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartTransferSetup Class
PartTransferSetup Members


ToLocation Property (PartTransferSetup) | fcSDK Documentation

ToLocation Property (PartTransferSetup)

Inventory location and bin (or GL account) into which the part is being transferred.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ToLocation As Location

[PropertyBitValueAttribute()]
public Location ToLocation {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartTransferSetup Class
PartTransferSetup Members


TransferDate Property (PartTransferSetup) | fcSDK Documentation

TransferDate Property (PartTransferSetup)

The DateTime the Part Transfer occurred. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property TransferDate As Date

[PropertyBitValueAttribute()]
public DateTime TransferDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartTransferSetup Class
PartTransferSetup Members


UserName Property (PartTransferSetup) | fcSDK Documentation

UserName Property (PartTransferSetup)

The user who is transferring the Part. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartTransferSetup Class
PartTransferSetup Members


ReinstallSitePartSetup Class | fcSDK Documentation

ReinstallSitePartSetup Class

Used by the ReinstallSitePart method as setup data for invocation.

Syntax

'Declaration

Public Class ReinstallSitePartSetup

public class ReinstallSitePartSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.FieldOps.ReinstallSitePartSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.FieldOps

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ReinstallSitePartSetup Members
FChoice.Toolkits.Clarify.FieldOps Namespace
ReinstallSitePart(ReinstallSitePartSetup) Method


ReinstallSitePartSetup Class Members | fcSDK Documentation

ReinstallSitePartSetup Class Members

The following tables list the members exposed by ReinstallSitePartSetup.

Public Constructors

 | Name | Description
Public Constructor | ReinstallSitePartSetup Constructor | Initializes a new instance of the ReinstallSitePartSetup class.

Public Properties

 | Name | Description
Public Property | AddActivityLog | Specifies if activity entry records should be created.
Public Property | ParentBinObjid | The Objid of the Parent Site Bin where the Site Part is being moved.
Public Property | ParentSitePartObjid | The Objid of the Parent Site Part where the Site Part is being moved.
Public Property | ReinstallDate | The DateTime the Site Part was reinstalled. If not set, the current time is used.
Public Property | SiteIDNum | The Site Id of the Site where the Site Part is being moved.
Public Property | SitePartObjid | The Objid of the Site Part being reinstalled.
Public Property | UseInstall | Specifies if activity entry records should be set to "Install" (true) or "Re-Installed" (false).
Public Property | UserName | The user who is reinstalling the Site Part. If not set, the session user is used.

Reference

ReinstallSitePartSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
ReinstallSitePart(ReinstallSitePartSetup) Method


ReinstallSitePartSetup Constructor | fcSDK Documentation

ReinstallSitePartSetup Constructor

The Objid of the Site Part being reinstalled.

The Site Id of the Site where the Site Part is being moved.

Initializes a new instance of the ReinstallSitePartSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _sitePartObjid_ As Integer, _
   ByVal _siteIDNum_ As String _
)

[ConstructorIndexAttribute()]
public ReinstallSitePartSetup(
   int _sitePartObjid_,
   string _siteIDNum_
)

Parameters

sitePartObjid

The Objid of the Site Part being reinstalled.

siteIDNum

The Site Id of the Site where the Site Part is being moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReinstallSitePartSetup Class
ReinstallSitePartSetup Members


AddActivityLog Property (ReinstallSitePartSetup) | fcSDK Documentation

AddActivityLog Property (ReinstallSitePartSetup)

Specifies if activity entry records should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AddActivityLog As Boolean

[PropertyBitValueAttribute()]
public bool AddActivityLog {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReinstallSitePartSetup Class
ReinstallSitePartSetup Members


ParentBinObjid Property (ReinstallSitePartSetup) | fcSDK Documentation

ParentBinObjid Property (ReinstallSitePartSetup)

The Objid of the Parent Site Bin where the Site Part is being moved.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ParentBinObjid As Integer

[PropertyBitValueAttribute()]
public int ParentBinObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReinstallSitePartSetup Class
ReinstallSitePartSetup Members


ParentSitePartObjid Property (ReinstallSitePartSetup) | fcSDK Documentation

ParentSitePartObjid Property (ReinstallSitePartSetup)

The Objid of the Parent Site Part where the Site Part is being moved.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ParentSitePartObjid As Integer

[PropertyBitValueAttribute()]
public int ParentSitePartObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReinstallSitePartSetup Class
ReinstallSitePartSetup Members


ReinstallDate Property (ReinstallSitePartSetup) | fcSDK Documentation

ReinstallDate Property (ReinstallSitePartSetup)

The DateTime the Site Part was reinstalled. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ReinstallDate As Date

[PropertyBitValueAttribute()]
public DateTime ReinstallDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReinstallSitePartSetup Class
ReinstallSitePartSetup Members


SiteIDNum Property (ReinstallSitePartSetup) | fcSDK Documentation

SiteIDNum Property (ReinstallSitePartSetup)

The Site Id of the Site where the Site Part is being moved.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteIDNum As String

[PropertyBitValueAttribute()]
public string SiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReinstallSitePartSetup Class
ReinstallSitePartSetup Members


SitePartObjid Property (ReinstallSitePartSetup) | fcSDK Documentation

SitePartObjid Property (ReinstallSitePartSetup)

The Objid of the Site Part being reinstalled.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SitePartObjid As Integer

[PropertyBitValueAttribute()]
public int SitePartObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReinstallSitePartSetup Class
ReinstallSitePartSetup Members


UseInstall Property (ReinstallSitePartSetup) | fcSDK Documentation

UseInstall Property (ReinstallSitePartSetup)

Specifies if activity entry records should be set to "Install" (true) or "Re-Installed" (false).

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UseInstall As Boolean

[PropertyBitValueAttribute()]
public bool UseInstall {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReinstallSitePartSetup Class
ReinstallSitePartSetup Members


UserName Property (ReinstallSitePartSetup) | fcSDK Documentation

UserName Property (ReinstallSitePartSetup)

The user who is reinstalling the Site Part. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReinstallSitePartSetup Class
ReinstallSitePartSetup Members


StageInventoryToolkit Class | fcSDK Documentation

StageInventoryToolkit Class

Syntax

'Declaration

Public Class StageInventoryToolkit

public class StageInventoryToolkit

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.FieldOps.StageInventoryToolkit

Requirements

Namespace: FChoice.Toolkits.Clarify.FieldOps

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

StageInventoryToolkit Members
FChoice.Toolkits.Clarify.FieldOps Namespace


StageInventoryToolkit Class Members | fcSDK Documentation

StageInventoryToolkit Class Members

The following tables list the members exposed by StageInventoryToolkit.

Public Constructors

 | Name | Description
Public Constructor | StageInventoryToolkit Constructor |

Public Fields

 | Name | Description
static (Shared in Visual Basic) | StagedFrom |
static (Shared in Visual Basic) | StagedTo |

Public Methods

 | Name | Description
Public Method | StageInstallForInventoryBin |

Reference

StageInventoryToolkit Class
FChoice.Toolkits.Clarify.FieldOps Namespace


StageInventoryToolkit Constructor | fcSDK Documentation

StageInventoryToolkit Constructor

Syntax

'Declaration

Public Function New( _
   ByVal _clarifySession_ As ClarifySession _
)

public StageInventoryToolkit(
   ClarifySession _clarifySession_
)

Parameters

clarifySession

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StageInventoryToolkit Class
StageInventoryToolkit Members


StageInstallForInventoryBin Method | fcSDK Documentation

StageInstallForInventoryBin Method

Syntax

'Declaration

Public Sub StageInstallForInventoryBin( _
   ByVal _partUsedObjid_ As Integer, _
   ByVal _locationName_ As String, _
   ByVal _locationBinName_ As String, _
   ByVal _stagedAs_ As Integer _
)

public void StageInstallForInventoryBin(
   int _partUsedObjid_,
   string _locationName_,
   string _locationBinName_,
   int _stagedAs_
)

Parameters

partUsedObjid

locationName

locationBinName

stagedAs

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StageInventoryToolkit Class
StageInventoryToolkit Members


StagedFrom Field | fcSDK Documentation

StagedFrom Field

Syntax

'Declaration

Public Shared ReadOnly StagedFrom As Integer

public static readonly int StagedFrom

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StageInventoryToolkit Class
StageInventoryToolkit Members


StagedTo Field | fcSDK Documentation

StagedTo Field

Syntax

'Declaration

Public Shared ReadOnly StagedTo As Integer

public static readonly int StagedTo

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

StageInventoryToolkit Class
StageInventoryToolkit Members


UpdateAppointmentSetup Class | fcSDK Documentation

UpdateAppointmentSetup Class

Used by the UpdateAppointment method as setup data for invocation.

Syntax

'Declaration

Public Class UpdateAppointmentSetup

public class UpdateAppointmentSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.FieldOps.UpdateAppointmentSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.FieldOps

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdateAppointmentSetup Members
FChoice.Toolkits.Clarify.FieldOps Namespace
UpdateAppointment(UpdateAppointmentSetup) Method


UpdateAppointmentSetup Class Members | fcSDK Documentation

UpdateAppointmentSetup Class Members

The following tables list the members exposed by UpdateAppointmentSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdateAppointmentSetup Constructor | Initializes a new instance of the UpdateAppointmentSetup class.

Public Properties

 | Name | Description
Public Property | AppointmentClass | Element from the 'Employee Sched Class' application list. If not set the default list value is used.
Public Property | AppointmentObjid | The Objid of the Appointment being modified.
Public Property | AppointmentType | Element from the 'Employee Sched Type' application list. If not set the default list value is used.
Public Property | CellText | The short description of the Appointment.
Public Property | CreateDate | The DateTime the Appointment was modified. If not set, the current time is used.
Public Property | Description | The description of the Appointment.
Public Property | Duration | The length (in seconds) of the Appointment. If not specified, it is calculated from the start and end times.
Public Property | EndDate | The DateTime the Appointment ends. If not set, the start time and duration is used to calculate the end time.
Public Property | StartDate | The DateTime the Appointment starts. If not set, the current time is used.
Public Property | UserName | The user who is updating the Appointment. If not set, the session user is used.

Reference

UpdateAppointmentSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
UpdateAppointment(UpdateAppointmentSetup) Method


UpdateAppointmentSetup Constructor | fcSDK Documentation

UpdateAppointmentSetup Constructor

The Objid of the Appointment being modified.

Initializes a new instance of the UpdateAppointmentSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _appointmentObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public UpdateAppointmentSetup(
   int _appointmentObjid_
)

Parameters

appointmentObjid

The Objid of the Appointment being modified.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAppointmentSetup Class
UpdateAppointmentSetup Members


AppointmentClass Property (UpdateAppointmentSetup) | fcSDK Documentation

AppointmentClass Property (UpdateAppointmentSetup)

Element from the 'Employee Sched Class' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AppointmentClass As String

[PropertyBitValueAttribute()]
public string AppointmentClass {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAppointmentSetup Class
UpdateAppointmentSetup Members


AppointmentObjid Property (UpdateAppointmentSetup) | fcSDK Documentation

AppointmentObjid Property (UpdateAppointmentSetup)

The Objid of the Appointment being modified.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AppointmentObjid As Integer

[PropertyBitValueAttribute()]
public int AppointmentObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAppointmentSetup Class
UpdateAppointmentSetup Members


AppointmentType Property (UpdateAppointmentSetup) | fcSDK Documentation

AppointmentType Property (UpdateAppointmentSetup)

Element from the 'Employee Sched Type' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AppointmentType As String

[PropertyBitValueAttribute()]
public string AppointmentType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAppointmentSetup Class
UpdateAppointmentSetup Members


CellText Property (UpdateAppointmentSetup) | fcSDK Documentation

CellText Property (UpdateAppointmentSetup)

The short description of the Appointment.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CellText As String

[PropertyBitValueAttribute()]
public string CellText {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAppointmentSetup Class
UpdateAppointmentSetup Members


CreateDate Property (UpdateAppointmentSetup) | fcSDK Documentation

CreateDate Property (UpdateAppointmentSetup)

The DateTime the Appointment was modified. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAppointmentSetup Class
UpdateAppointmentSetup Members


Description Property (UpdateAppointmentSetup) | fcSDK Documentation

Description Property (UpdateAppointmentSetup)

The description of the Appointment.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Description As String

[PropertyBitValueAttribute()]
public string Description {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAppointmentSetup Class
UpdateAppointmentSetup Members


Duration Property (UpdateAppointmentSetup) | fcSDK Documentation

Duration Property (UpdateAppointmentSetup)

The length (in seconds) of the Appointment. If not specified, it is calculated from the start and end times.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Duration As TimeSpan

[PropertyBitValueAttribute()]
public TimeSpan Duration {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAppointmentSetup Class
UpdateAppointmentSetup Members


EndDate Property (UpdateAppointmentSetup) | fcSDK Documentation

EndDate Property (UpdateAppointmentSetup)

The DateTime the Appointment ends. If not set, the start time and duration is used to calculate the end time.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property EndDate As Date

[PropertyBitValueAttribute()]
public DateTime EndDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAppointmentSetup Class
UpdateAppointmentSetup Members


StartDate Property (UpdateAppointmentSetup) | fcSDK Documentation

StartDate Property (UpdateAppointmentSetup)

The DateTime the Appointment starts. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property StartDate As Date

[PropertyBitValueAttribute()]
public DateTime StartDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAppointmentSetup Class
UpdateAppointmentSetup Members


UserName Property (UpdateAppointmentSetup) | fcSDK Documentation

UserName Property (UpdateAppointmentSetup)

The user who is updating the Appointment. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAppointmentSetup Class
UpdateAppointmentSetup Members


UpdateExpenseLogSetup Class | fcSDK Documentation

UpdateExpenseLogSetup Class

Used by the UpdateExpenseLog method as setup data for invocation.

Syntax

'Declaration

Public Class UpdateExpenseLogSetup

public class UpdateExpenseLogSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.FieldOps.UpdateExpenseLogSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.FieldOps

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdateExpenseLogSetup Members
FChoice.Toolkits.Clarify.FieldOps Namespace
UpdateExpenseLog(UpdateExpenseLogSetup) Method


UpdateExpenseLogSetup Class Members | fcSDK Documentation

UpdateExpenseLogSetup Class Members

The following tables list the members exposed by UpdateExpenseLogSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdateExpenseLogSetup Constructor | Initializes a new instance of the UpdateExpenseLogSetup class.

Public Properties

 | Name | Description
Public Property | BillTo | Element from the 'Bill To Time' application list. If not set the default list value is used.
Public Property | CreateDate | The DateTime the Expense Log was modified. If not set, the current time is used.
Public Property | ExpenseLogObjid | The Objid of the Expense Log being modified.
Public Property | ExpenseType | Element from the 'Expense Type' application list. If not set the default list value is used.
Public Property | IsBillable | Specifies if the Expense Log is billable.
Public Property | Notes | Notes that will update the notes field on the onsite log
Public Property | PerformedByUserName | The user who is performed the action specified by the Expense Log. If not set, the session user is used.
Public Property | Quantity | The number of units that are being applied to the Onsite Log.
Public Property | Rate | The billing rate per unit. If no rate is specified, the labor rate of the performing employee is used.
Public Property | Resolution | Element from the 'Resolution' application list. If not set the default list value is used.
Public Property | UserName | The user who is updating the Expense Log. If not set, the session user is used.

Reference

UpdateExpenseLogSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
UpdateExpenseLog(UpdateExpenseLogSetup) Method


UpdateExpenseLogSetup Constructor | fcSDK Documentation

UpdateExpenseLogSetup Constructor

The Objid of the Expense Log being modified.

The number of units that are being applied to the Onsite Log.

The billing rate per unit. If no rate is specified, the labor rate of the performing employee is used.

Initializes a new instance of the UpdateExpenseLogSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _expenseLogObjid_ As Integer, _
   ByVal _quantity_ As Double, _
   ByVal _rate_ As Double _
)

[ConstructorIndexAttribute()]
public UpdateExpenseLogSetup(
   int _expenseLogObjid_,
   double _quantity_,
   double _rate_
)

Parameters

expenseLogObjid

The Objid of the Expense Log being modified.

quantity

The number of units that are being applied to the Onsite Log.

rate

The billing rate per unit. If no rate is specified, the labor rate of the performing employee is used.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateExpenseLogSetup Class
UpdateExpenseLogSetup Members


BillTo Property (UpdateExpenseLogSetup) | fcSDK Documentation

BillTo Property (UpdateExpenseLogSetup)

Element from the 'Bill To Time' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property BillTo As String

[PropertyBitValueAttribute()]
public string BillTo {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateExpenseLogSetup Class
UpdateExpenseLogSetup Members


CreateDate Property (UpdateExpenseLogSetup) | fcSDK Documentation

CreateDate Property (UpdateExpenseLogSetup)

The DateTime the Expense Log was modified. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateExpenseLogSetup Class
UpdateExpenseLogSetup Members


ExpenseLogObjid Property (UpdateExpenseLogSetup) | fcSDK Documentation

ExpenseLogObjid Property (UpdateExpenseLogSetup)

The Objid of the Expense Log being modified.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ExpenseLogObjid As Integer

[PropertyBitValueAttribute()]
public int ExpenseLogObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateExpenseLogSetup Class
UpdateExpenseLogSetup Members


ExpenseType Property (UpdateExpenseLogSetup) | fcSDK Documentation

ExpenseType Property (UpdateExpenseLogSetup)

Element from the 'Expense Type' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ExpenseType As String

[PropertyBitValueAttribute()]
public string ExpenseType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateExpenseLogSetup Class
UpdateExpenseLogSetup Members


IsBillable Property (UpdateExpenseLogSetup) | fcSDK Documentation

IsBillable Property (UpdateExpenseLogSetup)

Specifies if the Expense Log is billable.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsBillable As Boolean

[PropertyBitValueAttribute()]
public bool IsBillable {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateExpenseLogSetup Class
UpdateExpenseLogSetup Members


Notes Property (UpdateExpenseLogSetup) | fcSDK Documentation

Notes Property (UpdateExpenseLogSetup)

Notes that will update the notes field on the onsite log

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateExpenseLogSetup Class
UpdateExpenseLogSetup Members


PerformedByUserName Property (UpdateExpenseLogSetup) | fcSDK Documentation

PerformedByUserName Property (UpdateExpenseLogSetup)

The user who is performed the action specified by the Expense Log. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PerformedByUserName As String

[PropertyBitValueAttribute()]
public string PerformedByUserName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateExpenseLogSetup Class
UpdateExpenseLogSetup Members


Quantity Property (UpdateExpenseLogSetup) | fcSDK Documentation

Quantity Property (UpdateExpenseLogSetup)

The number of units that are being applied to the Onsite Log.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Quantity As Double

[PropertyBitValueAttribute()]
public double Quantity {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateExpenseLogSetup Class
UpdateExpenseLogSetup Members


Rate Property (UpdateExpenseLogSetup) | fcSDK Documentation

Rate Property (UpdateExpenseLogSetup)

The billing rate per unit. If no rate is specified, the labor rate of the performing employee is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Rate As Double

[PropertyBitValueAttribute()]
public double Rate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateExpenseLogSetup Class
UpdateExpenseLogSetup Members


Resolution Property (UpdateExpenseLogSetup) | fcSDK Documentation

Resolution Property (UpdateExpenseLogSetup)

Element from the 'Resolution' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Resolution As String

[PropertyBitValueAttribute()]
public string Resolution {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateExpenseLogSetup Class
UpdateExpenseLogSetup Members


UserName Property (UpdateExpenseLogSetup) | fcSDK Documentation

UserName Property (UpdateExpenseLogSetup)

The user who is updating the Expense Log. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateExpenseLogSetup Class
UpdateExpenseLogSetup Members


UpdateServiceInterruptionSetup Class | fcSDK Documentation

UpdateServiceInterruptionSetup Class

Used by the UpdateServiceInterruption method as setup data for invocation.

Syntax

'Declaration

Public Class UpdateServiceInterruptionSetup

public class UpdateServiceInterruptionSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.FieldOps.UpdateServiceInterruptionSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.FieldOps

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdateServiceInterruptionSetup Members
FChoice.Toolkits.Clarify.FieldOps Namespace
UpdateServiceInterruption(UpdateServiceInterruptionSetup) Method


UpdateServiceInterruptionSetup Class Members | fcSDK Documentation

UpdateServiceInterruptionSetup Class Members

The following tables list the members exposed by UpdateServiceInterruptionSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdateServiceInterruptionSetup Constructor | Initializes a new instance of the UpdateServiceInterruptionSetup class.

Public Properties

 | Name | Description
Public Property | AppointmentObjid | The Objid of the Appointment being modified.
Public Property | CreateDate | The DateTime the Service Interuption was modified. If not set, the current time is used.
Public Property | Description | The description of the Service Interuption.
Public Property | Duration | The length (in seconds) of the Service Interuption. If not specified, it is calculated from the start and end times.
Public Property | EndDate | The DateTime the Service Interuption ends. If not set, the start time and duration is used to calculate the end time.
Public Property | ServiceClass | Element from the 'Installed Prod Sched Class' application list. If not set the default list value is used.
Public Property | ServiceType | Element from the 'Employee Sched Type' application list. If not set the default list value is used.
Public Property | StartDate | The DateTime the Service Interuption starts. If not set, the current time is used.
Public Property | UserName | The user who is updating the Service Interuption. If not set, the session user is used.

Reference

UpdateServiceInterruptionSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
UpdateServiceInterruption(UpdateServiceInterruptionSetup) Method


UpdateServiceInterruptionSetup Constructor | fcSDK Documentation

UpdateServiceInterruptionSetup Constructor

The Objid of the Appointment being modified.

Initializes a new instance of the UpdateServiceInterruptionSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _appointmentObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public UpdateServiceInterruptionSetup(
   int _appointmentObjid_
)

Parameters

appointmentObjid

The Objid of the Appointment being modified.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateServiceInterruptionSetup Class
UpdateServiceInterruptionSetup Members


AppointmentObjid Property (UpdateServiceInterruptionSetup) | fcSDK Documentation

AppointmentObjid Property (UpdateServiceInterruptionSetup)

The Objid of the Appointment being modified.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AppointmentObjid As Integer

[PropertyBitValueAttribute()]
public int AppointmentObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateServiceInterruptionSetup Class
UpdateServiceInterruptionSetup Members


CreateDate Property (UpdateServiceInterruptionSetup) | fcSDK Documentation

CreateDate Property (UpdateServiceInterruptionSetup)

The DateTime the Service Interuption was modified. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateServiceInterruptionSetup Class
UpdateServiceInterruptionSetup Members


Description Property (UpdateServiceInterruptionSetup) | fcSDK Documentation

Description Property (UpdateServiceInterruptionSetup)

The description of the Service Interuption.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Description As String

[PropertyBitValueAttribute()]
public string Description {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateServiceInterruptionSetup Class
UpdateServiceInterruptionSetup Members


Duration Property (UpdateServiceInterruptionSetup) | fcSDK Documentation

Duration Property (UpdateServiceInterruptionSetup)

The length (in seconds) of the Service Interuption. If not specified, it is calculated from the start and end times.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Duration As TimeSpan

[PropertyBitValueAttribute()]
public TimeSpan Duration {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateServiceInterruptionSetup Class
UpdateServiceInterruptionSetup Members


EndDate Property (UpdateServiceInterruptionSetup) | fcSDK Documentation

EndDate Property (UpdateServiceInterruptionSetup)

The DateTime the Service Interuption ends. If not set, the start time and duration is used to calculate the end time.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property EndDate As Date

[PropertyBitValueAttribute()]
public DateTime EndDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateServiceInterruptionSetup Class
UpdateServiceInterruptionSetup Members


ServiceClass Property (UpdateServiceInterruptionSetup) | fcSDK Documentation

ServiceClass Property (UpdateServiceInterruptionSetup)

Element from the 'Installed Prod Sched Class' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ServiceClass As String

[PropertyBitValueAttribute()]
public string ServiceClass {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateServiceInterruptionSetup Class
UpdateServiceInterruptionSetup Members


ServiceType Property (UpdateServiceInterruptionSetup) | fcSDK Documentation

ServiceType Property (UpdateServiceInterruptionSetup)

Element from the 'Employee Sched Type' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ServiceType As String

[PropertyBitValueAttribute()]
public string ServiceType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateServiceInterruptionSetup Class
UpdateServiceInterruptionSetup Members


StartDate Property (UpdateServiceInterruptionSetup) | fcSDK Documentation

StartDate Property (UpdateServiceInterruptionSetup)

The DateTime the Service Interuption starts. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property StartDate As Date

[PropertyBitValueAttribute()]
public DateTime StartDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateServiceInterruptionSetup Class
UpdateServiceInterruptionSetup Members


UserName Property (UpdateServiceInterruptionSetup) | fcSDK Documentation

UserName Property (UpdateServiceInterruptionSetup)

The user who is updating the Service Interuption. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateServiceInterruptionSetup Class
UpdateServiceInterruptionSetup Members


UpdateSitePartSetup Class | fcSDK Documentation

UpdateSitePartSetup Class

Used by the UpdateSitePart method as setup data for invocation.

Syntax

'Declaration

Public Class UpdateSitePartSetup

public class UpdateSitePartSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.FieldOps.UpdateSitePartSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.FieldOps

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdateSitePartSetup Members
FChoice.Toolkits.Clarify.FieldOps Namespace
UpdateSitePart(UpdateSitePartSetup) Method


UpdateSitePartSetup Class Members | fcSDK Documentation

UpdateSitePartSetup Class Members

The following tables list the members exposed by UpdateSitePartSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdateSitePartSetup Constructor | Initializes a new instance of the UpdateSitePartSetup class.

Public Properties

 | Name | Description
Public Property | AddActivityLog | Specifies if activity entry records should be created.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | Comments | Comments for the Site Part
Public Property | InstallDate | The DateTime the Site Part was installed. If not set, the current time is used.
Public Property | InstanceName | Instance Name of the Site Part
Public Property | InvoiceNumber | The Invoice Number for the Site Part
Public Property | PartRevision | Part Revision of the Site Part
Public Property | PartStatus | The Part Status for the Site Part
Public Property | Quantity | The Quantity of the Site Part
Public Property | SerialNumber | Serial Number of the Site Part
Public Property | ServiceEndDate | The DateTime the Service ends for the Site Part.
Public Property | ShipDate | The DateTime the shipping occurs for the Site Part.
Public Property | SitePartObjid | The Objid of the Site Part being modified.
Public Property | UserName | The user who is updating the Site Part. If not set, the session user is used.
Public Property | WarrantyDate | The DateTime the warranty begins for the Site Part.

Reference

UpdateSitePartSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
UpdateSitePart(UpdateSitePartSetup) Method


UpdateSitePartSetup Constructor | fcSDK Documentation

UpdateSitePartSetup Constructor

The Objid of the Site Part being modified.

Initializes a new instance of the UpdateSitePartSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _sitePartObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public UpdateSitePartSetup(
   int _sitePartObjid_
)

Parameters

sitePartObjid

The Objid of the Site Part being modified.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSitePartSetup Class
UpdateSitePartSetup Members


AddActivityLog Property (UpdateSitePartSetup) | fcSDK Documentation

AddActivityLog Property (UpdateSitePartSetup)

Specifies if activity entry records should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AddActivityLog As Boolean

[PropertyBitValueAttribute()]
public bool AddActivityLog {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSitePartSetup Class
UpdateSitePartSetup Members


AdditionalFields Property (UpdateSitePartSetup) | fcSDK Documentation

AdditionalFields Property (UpdateSitePartSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSitePartSetup Class
UpdateSitePartSetup Members


Comments Property (UpdateSitePartSetup) | fcSDK Documentation

Comments Property (UpdateSitePartSetup)

Comments for the Site Part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Comments As String

[PropertyBitValueAttribute()]
public string Comments {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSitePartSetup Class
UpdateSitePartSetup Members


InstallDate Property (UpdateSitePartSetup) | fcSDK Documentation

InstallDate Property (UpdateSitePartSetup)

The DateTime the Site Part was installed. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallDate As Date

[PropertyBitValueAttribute()]
public DateTime InstallDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSitePartSetup Class
UpdateSitePartSetup Members


InstanceName Property (UpdateSitePartSetup) | fcSDK Documentation

InstanceName Property (UpdateSitePartSetup)

Instance Name of the Site Part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstanceName As String

[PropertyBitValueAttribute()]
public string InstanceName {get; set;}

Remarks

If this is "#default", the Instance Name is set to the PArt Number and the Part Revision of the Site Part.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSitePartSetup Class
UpdateSitePartSetup Members


InvoiceNumber Property (UpdateSitePartSetup) | fcSDK Documentation

InvoiceNumber Property (UpdateSitePartSetup)

The Invoice Number for the Site Part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InvoiceNumber As String

[PropertyBitValueAttribute()]
public string InvoiceNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSitePartSetup Class
UpdateSitePartSetup Members


PartRevision Property (UpdateSitePartSetup) | fcSDK Documentation

PartRevision Property (UpdateSitePartSetup)

Part Revision of the Site Part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRevision As String

[PropertyBitValueAttribute()]
public string PartRevision {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSitePartSetup Class
UpdateSitePartSetup Members


PartStatus Property (UpdateSitePartSetup) | fcSDK Documentation

PartStatus Property (UpdateSitePartSetup)

The Part Status for the Site Part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartStatus As String

[PropertyBitValueAttribute()]
public string PartStatus {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSitePartSetup Class
UpdateSitePartSetup Members


Quantity Property (UpdateSitePartSetup) | fcSDK Documentation

Quantity Property (UpdateSitePartSetup)

The Quantity of the Site Part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Quantity As Integer

[PropertyBitValueAttribute()]
public int Quantity {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSitePartSetup Class
UpdateSitePartSetup Members


SerialNumber Property (UpdateSitePartSetup) | fcSDK Documentation

SerialNumber Property (UpdateSitePartSetup)

Serial Number of the Site Part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SerialNumber As String

[PropertyBitValueAttribute()]
public string SerialNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSitePartSetup Class
UpdateSitePartSetup Members


ServiceEndDate Property (UpdateSitePartSetup) | fcSDK Documentation

ServiceEndDate Property (UpdateSitePartSetup)

The DateTime the Service ends for the Site Part.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ServiceEndDate As Date

[PropertyBitValueAttribute()]
public DateTime ServiceEndDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSitePartSetup Class
UpdateSitePartSetup Members


ShipDate Property (UpdateSitePartSetup) | fcSDK Documentation

ShipDate Property (UpdateSitePartSetup)

The DateTime the shipping occurs for the Site Part.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ShipDate As Date

[PropertyBitValueAttribute()]
public DateTime ShipDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSitePartSetup Class
UpdateSitePartSetup Members


SitePartObjid Property (UpdateSitePartSetup) | fcSDK Documentation

SitePartObjid Property (UpdateSitePartSetup)

The Objid of the Site Part being modified.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SitePartObjid As Integer

[PropertyBitValueAttribute()]
public int SitePartObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSitePartSetup Class
UpdateSitePartSetup Members


UserName Property (UpdateSitePartSetup) | fcSDK Documentation

UserName Property (UpdateSitePartSetup)

The user who is updating the Site Part. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSitePartSetup Class
UpdateSitePartSetup Members


WarrantyDate Property (UpdateSitePartSetup) | fcSDK Documentation

WarrantyDate Property (UpdateSitePartSetup)

The DateTime the warranty begins for the Site Part.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WarrantyDate As Date

[PropertyBitValueAttribute()]
public DateTime WarrantyDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSitePartSetup Class
UpdateSitePartSetup Members


UpdateTimeLogSetup Class | fcSDK Documentation

UpdateTimeLogSetup Class

Used by the UpdateTimeLog method as setup data for invocation.

Syntax

'Declaration

Public Class UpdateTimeLogSetup

public class UpdateTimeLogSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.FieldOps.UpdateTimeLogSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.FieldOps

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdateTimeLogSetup Members
FChoice.Toolkits.Clarify.FieldOps Namespace
UpdateTimeLog(UpdateTimeLogSetup) Method


UpdateTimeLogSetup Class Members | fcSDK Documentation

UpdateTimeLogSetup Class Members

The following tables list the members exposed by UpdateTimeLogSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdateTimeLogSetup Constructor | Initializes a new instance of the UpdateTimeLogSetup class.

Public Properties

 | Name | Description
Public Property | BillTo | Element from the 'Bill To Time' application list. If not set the default list value is used.
Public Property | CreateDate | The DateTime the Time Log was modified. If not set, the current time is used.The DateTime the Time Log starts. If not set, the current time is used.
Public Property | Duration | The length (in seconds) of the Time Log. If not specified, it is calculated from the start and end times.
Public Property | IsBillable | Specifies if the Time Log is billable.
Public Property | Notes | Notes that will update the notes field on the onsite log
Public Property | PerformedByUserName | The user who is performed the action specified by the Time Log. If not set, the session user is used.
Public Property | Resolution | Element from the 'Resolution' application list. If not set the default list value is used.
Public Property | StartTime |
Public Property | TimeLogObjid | The Objid of the Time Log being modified.
Public Property | TimeType | Element from the 'Time Type' application list. If not set the default list value is used.
Public Property | UserName | The user who is updating the Time Log. If not set, the session user is used.
Public Property | WorkCenter | Element from the 'Work Center' application list. If not set the default list value is used.

Reference

UpdateTimeLogSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
UpdateTimeLog(UpdateTimeLogSetup) Method


UpdateTimeLogSetup Constructor | fcSDK Documentation

UpdateTimeLogSetup Constructor

The Objid of the Time Log being modified.

Initializes a new instance of the UpdateTimeLogSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _timeLogObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public UpdateTimeLogSetup(
   int _timeLogObjid_
)

Parameters

timeLogObjid

The Objid of the Time Log being modified.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateTimeLogSetup Class
UpdateTimeLogSetup Members


BillTo Property (UpdateTimeLogSetup) | fcSDK Documentation

BillTo Property (UpdateTimeLogSetup)

Element from the 'Bill To Time' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property BillTo As String

[PropertyBitValueAttribute()]
public string BillTo {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateTimeLogSetup Class
UpdateTimeLogSetup Members


CreateDate Property (UpdateTimeLogSetup) | fcSDK Documentation

CreateDate Property (UpdateTimeLogSetup)

The DateTime the Time Log was modified. If not set, the current time is used.The DateTime the Time Log starts. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateTimeLogSetup Class
UpdateTimeLogSetup Members


Duration Property (UpdateTimeLogSetup) | fcSDK Documentation

Duration Property (UpdateTimeLogSetup)

The length (in seconds) of the Time Log. If not specified, it is calculated from the start and end times.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Duration As TimeSpan

[PropertyBitValueAttribute()]
public TimeSpan Duration {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateTimeLogSetup Class
UpdateTimeLogSetup Members


IsBillable Property (UpdateTimeLogSetup) | fcSDK Documentation

IsBillable Property (UpdateTimeLogSetup)

Specifies if the Time Log is billable.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsBillable As Boolean

[PropertyBitValueAttribute()]
public bool IsBillable {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateTimeLogSetup Class
UpdateTimeLogSetup Members


Notes Property (UpdateTimeLogSetup) | fcSDK Documentation

Notes Property (UpdateTimeLogSetup)

Notes that will update the notes field on the onsite log

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateTimeLogSetup Class
UpdateTimeLogSetup Members


PerformedByUserName Property (UpdateTimeLogSetup) | fcSDK Documentation

PerformedByUserName Property (UpdateTimeLogSetup)

The user who is performed the action specified by the Time Log. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PerformedByUserName As String

[PropertyBitValueAttribute()]
public string PerformedByUserName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateTimeLogSetup Class
UpdateTimeLogSetup Members


Resolution Property (UpdateTimeLogSetup) | fcSDK Documentation

Resolution Property (UpdateTimeLogSetup)

Element from the 'Resolution' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Resolution As String

[PropertyBitValueAttribute()]
public string Resolution {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateTimeLogSetup Class
UpdateTimeLogSetup Members


StartTime Property | fcSDK Documentation

StartTime Property

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property StartTime As Date

[PropertyBitValueAttribute()]
public DateTime StartTime {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateTimeLogSetup Class
UpdateTimeLogSetup Members


TimeLogObjid Property (UpdateTimeLogSetup) | fcSDK Documentation

TimeLogObjid Property (UpdateTimeLogSetup)

The Objid of the Time Log being modified.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property TimeLogObjid As Integer

[PropertyBitValueAttribute()]
public int TimeLogObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateTimeLogSetup Class
UpdateTimeLogSetup Members


TimeType Property (UpdateTimeLogSetup) | fcSDK Documentation

TimeType Property (UpdateTimeLogSetup)

Element from the 'Time Type' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property TimeType As String

[PropertyBitValueAttribute()]
public string TimeType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateTimeLogSetup Class
UpdateTimeLogSetup Members


UserName Property (UpdateTimeLogSetup) | fcSDK Documentation

UserName Property (UpdateTimeLogSetup)

The user who is updating the Time Log. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateTimeLogSetup Class
UpdateTimeLogSetup Members


WorkCenter Property (UpdateTimeLogSetup) | fcSDK Documentation

WorkCenter Property (UpdateTimeLogSetup)

Element from the 'Work Center' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WorkCenter As String

[PropertyBitValueAttribute()]
public string WorkCenter {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateTimeLogSetup Class
UpdateTimeLogSetup Members


FChoice.Toolkits.Clarify.Interfaces Namespace | fcSDK Documentation

FChoice.Toolkits.Clarify.Interfaces Namespace

Provides APIs to allow you to modify common Clarify objects such as Contacts, Sites, Addresses, Solutions, Contracts, Parts, and more. Methods on the InterfacesToolkit object allow you to create, modify, dispatch, accept, reject, assign, yank, and move, among many others operations.

Classes

 | Class | Description
Class | AcceptSolutionSetup | Used by the AcceptSolution method as setup data for invocation.
Class | AddContactToContractSetup | Used by the AddContactToContract method as setup data for invocation.
Class | AddEmployeeToAccountSetup | Used by the AddEmployeeToAccount method as setup data for invocation.
Class | AddSitePartToContractSetup | Used by the AddSitePartToContract method as setup data for invocation.
Class | AddSiteToAccountSetup | Used by the AddSiteToAccount method as setup data for invocation.
Class | AddSiteToContractSetup | Used by the AddSiteToContract method as setup data for invocation.
Class | AddUserToQueueSetup | Used by the AddUserToQueue method as setup data for invocation.
Class | AddWorkaroundSetup | Used by the AddWorkaround method as setup data for invocation.
Class | AssignSolutionSetup | Used by the AssignSolution method as setup data for invocation.
Class | CreateAccountSetup | Used by the CreateAccount method as setup data for invocation.
Class | CreateAddressSetup | Used by the CreateAddress method as setup data for invocation.
Class | CreateBOMSetup | Used by the CreateBOM method as setup data for invocation.
Class | CreateChannelSetup |
Class | CreateCommunicationSetup | Used by the CreateCommunication method as setup data for invocation.
Class | CreateContactSetup | Used by the CreateContact method as setup data for invocation.
Class | CreateContractSetup | Used by the CreateContract method as setup data for invocation.
Class | CreateCountrySetup | Used by the CreateCountry method as setup data for invocation.
Class | CreateDialogueSetup | Initializes a new instance of the CreateDialogueSetup class.
Class | CreateEmployeeResult | Result from the CreateEmployee API.
Class | CreateEmployeeSetup | Used by the CreateEmployee method as setup data for invocation.
Class | CreateInteractionSetup | Used by the CreateInteraction method as setup data for invocation.
Class | CreatePartRevisionSetup | Used by the CreatePartRevision method as setup data for invocation.
Class | CreatePartSetup | Used by the CreatePart method as setup data for invocation.
Class | CreatePriceInstanceSetup | Used by the CreatePriceInstance method as setup data for invocation.
Class | CreateProductBinSetup | Used by the CreateProductBin method as setup data for invocation.
Class | CreateQueueSetup | Used by the CreateQueue method as setup data for invocation.
Class | CreateSiteSetup | Used by the CreateSite method as setup data for invocation.
Class | CreateSolutionResult | Result from the CreateSolution API.
Class | CreateSolutionSetup | Used by the CreateSolution method as setup data for invocation.
Class | CreateStateSetup | Used by the CreateState method as setup data for invocation.
Class | CreateTimeZoneSetup | Used by the CreateTimeZone method as setup data for invocation.
Class | CreateWipBinSetup | Used by the CreateWipBin method as setup data for invocation.
Class | DeinstallSitePartSetup | Used by the DeinstallSitePart method as setup data for invocation.
Class | DeleteProductBinSetup | Used by the DeleteProductBin method as setup data for invocation.
Class | DispatchSolutionSetup | Used by the DispatchSolution method as setup data for invocation.
Class | ForwardSolutionSetup | Used by the ForwardSolution method as setup data for invocation.
Class | InstallSitePartToBinSetup | Used by the InstallSitePartToBin method as setup data for invocation.
Class | InstallSitePartToPartSetup | Used by the InstallSitePartToPart method as setup data for invocation.
Class | InstallSitePartToSiteSetup | Used by the InstallSitePartToSite method as setup data for invocation.
Class | InterfacesToolkit | Provides APIs to allow you to modify common Clarify objects such as Contacts, Sites, Addresses, Solutions, Contracts, Parts, and more. Methods on this object allow you to create, modify, dispatch, accept, reject, assign, yank, and move, among many others operations.
Class | InterfacesToolkitBase | Please see InterfacesToolkit. This class is used internally and not meant to be created by end users.
Class | LinkCaseToWorkaroundSetup | Used by the LinkCaseToWorkaround method as setup data for invocation.
Class | LinkCRToSolutionSetup | Used by the LinkCRToSolution method as setup data for invocation.
Class | MoveSitePartToBinSetup | Used by the MoveSitePartToBin method as setup data for invocation.
Class | MoveSitePartToPartSetup | Used by the MoveSitePartToPart method as setup data for invocation.
Class | MoveSitePartToSiteSetup | Used by the MoveSitePartToSite method as setup data for invocation.
Class | MoveSolutionSetup | Used by the MoveSolution method as setup data for invocation.
Class | ReinstallSitePartToBinSetup | Used by the ReinstallSitePartToBin method as setup data for invocation.
Class | ReinstallSitePartToPartSetup | Used by the ReinstallSitePartToPart method as setup data for invocation.
Class | ReinstallSitePartToSiteSetup | Used by the ReinstallSitePartToSite method as setup data for invocation.
Class | RejectSolutionSetup | Used by the RejectSolution method as setup data for invocation.
Class | RemoveContactFromContractSetup |
Class | RemoveEmployeeFromAccountSetup | Used by the RemoveEmployeeFromAccount method as setup data for invocation.
Class | RemoveSiteFromAccountSetup | Used by the RemoveSiteFromAccount method as setup data for invocation.
Class | RemoveSiteFromContractSetup |
Class | RemoveSitePartFromContractSetup |
Class | ReopenDialogueSetup |
Class | UnlinkCaseFromWorkaroundSetup | Used by the UnlinkCaseFromWorkaround method as setup data for invocation.
Class | UnlinkCRFromSolutionSetup | Used by the UnlinkCRFromSolution method as setup data for invocation.
Class | UpdateAccountSetup | Used by the UpdateAccount method as setup data for invocation.
Class | UpdateAddressSetup | Used by the UpdateAddress method as setup data for invocation.
Class | UpdateCommunicationSetup | Used by the UpdateCommunication method as setup data for invocation.
Class | UpdateContactByObjidSetup |
Class | UpdateContactSetup | Used by the UpdateContact method as setup data for invocation.
Class | UpdateContractSetup | Used by the UpdateContract method as setup data for invocation.
Class | UpdateDialogueSetup | Used by the UpdateDialogue method as setup data for invocation.
Class | UpdatePartRevisionSetup | Used by the UpdatePartRevision method as setup data for invocation.
Class | UpdatePartSetup | Used by the UpdatePart method as setup data for invocation.
Class | UpdatePriceInstanceSetup | Used by the UpdatePriceInstance method as setup data for invocation.
Class | UpdateProductBinSetup | Used by the UpdateProductBin method as setup data for invocation.
Class | UpdateQueueSetup | Used by the UpdateQueue method as setup data for invocation.
Class | UpdateSiteByObjidSetup | Used by the UpdateSiteByObjid method as setup data for invocation.
Class | UpdateSitePartSetup | Used by the UpdateSitePart method as setup data for invocation.
Class | UpdateSiteSetup | Used by the UpdateSite method as setup data for invocation.
Class | UpdateWipBinSetup | Used by the UpdateWipBin method as setup data for invocation.
Class | YankSolutionSetup | Used by the YankSolution method as setup data for invocation.

Reference

FChoice.Toolkits.Clarify Assembly


AcceptSolutionSetup Class | fcSDK Documentation

AcceptSolutionSetup Class

Used by the AcceptSolution method as setup data for invocation.

Syntax

'Declaration

Public Class AcceptSolutionSetup

public class AcceptSolutionSetup

Remarks

The solution must be currently dispatched to a queue.
The solution must be currently dispatched to a queue.

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.AcceptSolutionSetup

Requirements

The solution must be currently dispatched to a queue.
The solution must be currently dispatched to a queue.

Reference

AcceptSolutionSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
AcceptSolution(AcceptSolutionSetup) Method


AcceptSolutionSetup Class Members | fcSDK Documentation

AcceptSolutionSetup Class Members

The following tables list the members exposed by AcceptSolutionSetup.

Public Constructors

 | Name | Description
Public Constructor | AcceptSolutionSetup Constructor | Initializes a new instance of the AcceptSolutionSetup class.

Public Properties

 | Name | Description
Public Property | AcceptDate | DateTime the Solution was accepted. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | SolutionIDNum | Solution Identifier.
Public Property | UserName | The user who has accepted the Solution. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Solution. If not set, the UserName's default is used.

Reference

AcceptSolutionSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
AcceptSolution(AcceptSolutionSetup) Method


AcceptSolutionSetup Constructor | fcSDK Documentation

AcceptSolutionSetup Constructor

Solution Identifier.

Initializes a new instance of the AcceptSolutionSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _solutionIDNum_ As String _
)

[ConstructorIndexAttribute()]
public AcceptSolutionSetup(
   string _solutionIDNum_
)

Parameters

solutionIDNum

Solution Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptSolutionSetup Class
AcceptSolutionSetup Members


AcceptDate Property (AcceptSolutionSetup) | fcSDK Documentation

AcceptDate Property (AcceptSolutionSetup)

DateTime the Solution was accepted. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AcceptDate As Date

[PropertyBitValueAttribute()]
public DateTime AcceptDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptSolutionSetup Class
AcceptSolutionSetup Members


GenerateTimeBombs Property (AcceptSolutionSetup) | fcSDK Documentation

GenerateTimeBombs Property (AcceptSolutionSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptSolutionSetup Class
AcceptSolutionSetup Members


SolutionIDNum Property (AcceptSolutionSetup) | fcSDK Documentation

SolutionIDNum Property (AcceptSolutionSetup)

Solution Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SolutionIDNum As String

[PropertyBitValueAttribute()]
public string SolutionIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptSolutionSetup Class
AcceptSolutionSetup Members


UserName Property (AcceptSolutionSetup) | fcSDK Documentation

UserName Property (AcceptSolutionSetup)

The user who has accepted the Solution. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptSolutionSetup Class
AcceptSolutionSetup Members


WipBin Property (AcceptSolutionSetup) | fcSDK Documentation

WipBin Property (AcceptSolutionSetup)

User's WipBin in which to place the Solution. If not set, the UserName's default is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptSolutionSetup Class
AcceptSolutionSetup Members


AddContactToContractSetup Class | fcSDK Documentation

AddContactToContractSetup Class

Used by the AddContactToContract method as setup data for invocation.

Syntax

'Declaration

Public Class AddContactToContractSetup

public class AddContactToContractSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.AddContactToContractSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

AddContactToContractSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
AddContactToContract(AddContactToContractSetup) Method


AddContactToContractSetup Class Members | fcSDK Documentation

AddContactToContractSetup Class Members

The following tables list the members exposed by AddContactToContractSetup.

Public Constructors

 | Name | Description
Public Constructor | AddContactToContractSetup Constructor | Initializes a new instance of the AddContactToContractSetup class.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | ContactFirstName | Contact's first name. | | Public Property | ContactLastName | Contact's last name. | | Public Property | ContactPhone | Contact's phone number. | | Public Property | ContractIDNum | Identifies to which Contract the Contact will be added.

| | Public Property | SiteIDNum | Identifies the Site where the added Contact is located. |

Reference

AddContactToContractSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
AddContactToContract(AddContactToContractSetup) Method


AddContactToContractSetup Constructor | fcSDK Documentation

AddContactToContractSetup Constructor

Identifies to which Contract the Contact will be added.

Contact's first name.

Contact's last name.

Contact's phone number.

Identifies the Site where the added Contact is located.

Initializes a new instance of the AddContactToContractSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _contractIDNum_ As String, _
   ByVal _contactFirstName_ As String, _
   ByVal _contactLastName_ As String, _
   ByVal _contactPhone_ As String, _
   ByVal _siteIDNum_ As String _
)

[ConstructorIndexAttribute()]
public AddContactToContractSetup(
   string _contractIDNum_,
   string _contactFirstName_,
   string _contactLastName_,
   string _contactPhone_,
   string _siteIDNum_
)

Parameters

contractIDNum

Identifies to which Contract the Contact will be added.

contactFirstName

Contact's first name.

contactLastName

Contact's last name.

contactPhone

Contact's phone number.

siteIDNum

Identifies the Site where the added Contact is located.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddContactToContractSetup Class
AddContactToContractSetup Members


ContactFirstName Property (AddContactToContractSetup) | fcSDK Documentation

ContactFirstName Property (AddContactToContractSetup)

Contact's first name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactFirstName As String

[PropertyBitValueAttribute()]
public string ContactFirstName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddContactToContractSetup Class
AddContactToContractSetup Members


ContactLastName Property (AddContactToContractSetup) | fcSDK Documentation

ContactLastName Property (AddContactToContractSetup)

Contact's last name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactLastName As String

[PropertyBitValueAttribute()]
public string ContactLastName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddContactToContractSetup Class
AddContactToContractSetup Members


ContactPhone Property (AddContactToContractSetup) | fcSDK Documentation

ContactPhone Property (AddContactToContractSetup)

Contact's phone number.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactPhone As String

[PropertyBitValueAttribute()]
public string ContactPhone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddContactToContractSetup Class
AddContactToContractSetup Members


ContractIDNum Property (AddContactToContractSetup) | fcSDK Documentation

ContractIDNum Property (AddContactToContractSetup)

Identifies to which Contract the Contact will be added.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContractIDNum As String

[PropertyBitValueAttribute()]
public string ContractIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddContactToContractSetup Class
AddContactToContractSetup Members


SiteIDNum Property (AddContactToContractSetup) | fcSDK Documentation

SiteIDNum Property (AddContactToContractSetup)

Identifies the Site where the added Contact is located.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteIDNum As String

[PropertyBitValueAttribute()]
public string SiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddContactToContractSetup Class
AddContactToContractSetup Members


AddEmployeeToAccountSetup Class | fcSDK Documentation

AddEmployeeToAccountSetup Class

Used by the AddEmployeeToAccount method as setup data for invocation.

Syntax

'Declaration

Public Class AddEmployeeToAccountSetup

public class AddEmployeeToAccountSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.AddEmployeeToAccountSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

AddEmployeeToAccountSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
AddEmployeeToAccount(AddEmployeeToAccountSetup) Method


AddEmployeeToAccountSetup Class Members | fcSDK Documentation

AddEmployeeToAccountSetup Class Members

The following tables list the members exposed by AddEmployeeToAccountSetup.

Public Constructors

 | Name | Description
Public Constructor | AddEmployeeToAccountSetup Constructor | Initializes a new instance of the AddEmployeeToAccountSetup class.

Public Properties

 | Name | Description
Public Property | AccountIDNum | Identifier of the Account the Employee is being added to .
Public Property | RoleName | Role for User in the Account .
Public Property | UserName | Username of the Account team member .

Reference

AddEmployeeToAccountSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
AddEmployeeToAccount(AddEmployeeToAccountSetup) Method


AddEmployeeToAccountSetup Constructor | fcSDK Documentation

AddEmployeeToAccountSetup Constructor

Username of the Account team member .

Identifier of the Account the Employee is being added to .

Initializes a new instance of the AddEmployeeToAccountSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _userName_ As String, _
   ByVal _accountIDNum_ As String _
)

[ConstructorIndexAttribute()]
public AddEmployeeToAccountSetup(
   string _userName_,
   string _accountIDNum_
)

Parameters

userName

Username of the Account team member .

accountIDNum

Identifier of the Account the Employee is being added to .

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddEmployeeToAccountSetup Class
AddEmployeeToAccountSetup Members


AccountIDNum Property (AddEmployeeToAccountSetup) | fcSDK Documentation

AccountIDNum Property (AddEmployeeToAccountSetup)

Identifier of the Account the Employee is being added to .

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AccountIDNum As String

[PropertyBitValueAttribute()]
public string AccountIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddEmployeeToAccountSetup Class
AddEmployeeToAccountSetup Members


RoleName Property (AddEmployeeToAccountSetup) | fcSDK Documentation

RoleName Property (AddEmployeeToAccountSetup)

Role for User in the Account .

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property RoleName As String

[PropertyBitValueAttribute()]
public string RoleName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddEmployeeToAccountSetup Class
AddEmployeeToAccountSetup Members


UserName Property (AddEmployeeToAccountSetup) | fcSDK Documentation

UserName Property (AddEmployeeToAccountSetup)

Username of the Account team member .

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddEmployeeToAccountSetup Class
AddEmployeeToAccountSetup Members


AddSitePartToContractSetup Class | fcSDK Documentation

AddSitePartToContractSetup Class

Used by the AddSitePartToContract method as setup data for invocation.

Syntax

'Declaration

Public Class AddSitePartToContractSetup

public class AddSitePartToContractSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.AddSitePartToContractSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

AddSitePartToContractSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
AddSitePartToContract(AddSitePartToContractSetup) Method


AddSitePartToContractSetup Class Members | fcSDK Documentation

AddSitePartToContractSetup Class Members

The following tables list the members exposed by AddSitePartToContractSetup.

Public Constructors

 | Name | Description
Public Constructor | AddSitePartToContractSetup Constructor | Initializes a new instance of the AddSitePartToContractSetup class.

Public Properties

 | Name | Description
Public Property | ContractIDNum | Contract Identifier.
Public Property | SiteIDNum | Identifier of site where the site part is located.
Public Property | SitePartObjid | Objid of the SitePart to be added.

Reference

AddSitePartToContractSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
AddSitePartToContract(AddSitePartToContractSetup) Method


AddSitePartToContractSetup Constructor | fcSDK Documentation

AddSitePartToContractSetup Constructor

Contract Identifier.

Identifier of site where the site part is located.

Objid of the SitePart to be added.

Initializes a new instance of the AddSitePartToContractSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _contractIDNum_ As String, _
   ByVal _siteIDNum_ As String, _
   ByVal _sitePartObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public AddSitePartToContractSetup(
   string _contractIDNum_,
   string _siteIDNum_,
   int _sitePartObjid_
)

Parameters

contractIDNum

Contract Identifier.

siteIDNum

Identifier of site where the site part is located.

sitePartObjid

Objid of the SitePart to be added.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddSitePartToContractSetup Class
AddSitePartToContractSetup Members


ContractIDNum Property (AddSitePartToContractSetup) | fcSDK Documentation

ContractIDNum Property (AddSitePartToContractSetup)

Contract Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContractIDNum As String

[PropertyBitValueAttribute()]
public string ContractIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddSitePartToContractSetup Class
AddSitePartToContractSetup Members


SiteIDNum Property (AddSitePartToContractSetup) | fcSDK Documentation

SiteIDNum Property (AddSitePartToContractSetup)

Identifier of site where the site part is located.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteIDNum As String

[PropertyBitValueAttribute()]
public string SiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddSitePartToContractSetup Class
AddSitePartToContractSetup Members


SitePartObjid Property (AddSitePartToContractSetup) | fcSDK Documentation

SitePartObjid Property (AddSitePartToContractSetup)

Objid of the SitePart to be added.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SitePartObjid As Integer

[PropertyBitValueAttribute()]
public int SitePartObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddSitePartToContractSetup Class
AddSitePartToContractSetup Members


AddSiteToAccountSetup Class | fcSDK Documentation

AddSiteToAccountSetup Class

Used by the AddSiteToAccount method as setup data for invocation.

Syntax

'Declaration

Public Class AddSiteToAccountSetup

public class AddSiteToAccountSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.AddSiteToAccountSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

AddSiteToAccountSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
AddSiteToAccount(AddSiteToAccountSetup) Method


AddSiteToAccountSetup Class Members | fcSDK Documentation

AddSiteToAccountSetup Class Members

The following tables list the members exposed by AddSiteToAccountSetup.

Public Constructors

 | Name | Description
Public Constructor | AddSiteToAccountSetup Constructor | Initializes a new instance of the AddSiteToAccountSetup class.

Public Properties

 | Name | Description
Public Property | AccountIDNum | The identifier of the Account to which the site will be added.
Public Property | RoleName | Name of the Site Role the Site will play for the Account.
Public Property | SiteIDNum | Site Identifier of site to be added.

Reference

AddSiteToAccountSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
AddSiteToAccount(AddSiteToAccountSetup) Method


AddSiteToAccountSetup Constructor | fcSDK Documentation

AddSiteToAccountSetup Constructor

Site Identifier of site to be added.

The identifier of the Account to which the site will be added.

Name of the Site Role the Site will play for the Account.

Initializes a new instance of the AddSiteToAccountSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _siteIDNum_ As String, _
   ByVal _accountIDNum_ As String, _
   ByVal _roleName_ As String _
)

[ConstructorIndexAttribute()]
public AddSiteToAccountSetup(
   string _siteIDNum_,
   string _accountIDNum_,
   string _roleName_
)

Parameters

siteIDNum

Site Identifier of site to be added.

accountIDNum

The identifier of the Account to which the site will be added.

roleName

Name of the Site Role the Site will play for the Account.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddSiteToAccountSetup Class
AddSiteToAccountSetup Members


AccountIDNum Property (AddSiteToAccountSetup) | fcSDK Documentation

AccountIDNum Property (AddSiteToAccountSetup)

The identifier of the Account to which the site will be added.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AccountIDNum As String

[PropertyBitValueAttribute()]
public string AccountIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddSiteToAccountSetup Class
AddSiteToAccountSetup Members


RoleName Property (AddSiteToAccountSetup) | fcSDK Documentation

RoleName Property (AddSiteToAccountSetup)

Name of the Site Role the Site will play for the Account.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property RoleName As String

[PropertyBitValueAttribute()]
public string RoleName {get; set;}

Remarks

The rolename must be an Element from the 'Account Site Roles' user defined list or the value OWNER .

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddSiteToAccountSetup Class
AddSiteToAccountSetup Members


SiteIDNum Property (AddSiteToAccountSetup) | fcSDK Documentation

SiteIDNum Property (AddSiteToAccountSetup)

Site Identifier of site to be added.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteIDNum As String

[PropertyBitValueAttribute()]
public string SiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddSiteToAccountSetup Class
AddSiteToAccountSetup Members


AddSiteToContractSetup Class | fcSDK Documentation

AddSiteToContractSetup Class

Used by the AddSiteToContract method as setup data for invocation.

Syntax

'Declaration

Public Class AddSiteToContractSetup

public class AddSiteToContractSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.AddSiteToContractSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

AddSiteToContractSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
AddSiteToContract(AddSiteToContractSetup) Method


AddSiteToContractSetup Class Members | fcSDK Documentation

AddSiteToContractSetup Class Members

The following tables list the members exposed by AddSiteToContractSetup.

Public Constructors

 | Name | Description
Public Constructor | AddSiteToContractSetup Constructor | Initializes a new instance of the AddSiteToContractSetup class.

Public Properties

 | Name | Description
Public Property | ContractIDNum | Identifier of the Contract to which the Site will be added.
Public Property | SiteIDNum | Identifier of the Site to add to the Contract.

Reference

AddSiteToContractSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
AddSiteToContract(AddSiteToContractSetup) Method


AddSiteToContractSetup Constructor | fcSDK Documentation

AddSiteToContractSetup Constructor

Identifier of the Contract to which the Site will be added.

Identifier of the Site to add to the Contract.

Initializes a new instance of the AddSiteToContractSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _contractIDNum_ As String, _
   ByVal _siteIDNum_ As String _
)

[ConstructorIndexAttribute()]
public AddSiteToContractSetup(
   string _contractIDNum_,
   string _siteIDNum_
)

Parameters

contractIDNum

Identifier of the Contract to which the Site will be added.

siteIDNum

Identifier of the Site to add to the Contract.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddSiteToContractSetup Class
AddSiteToContractSetup Members


ContractIDNum Property (AddSiteToContractSetup) | fcSDK Documentation

ContractIDNum Property (AddSiteToContractSetup)

Identifier of the Contract to which the Site will be added.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContractIDNum As String

[PropertyBitValueAttribute()]
public string ContractIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddSiteToContractSetup Class
AddSiteToContractSetup Members


SiteIDNum Property (AddSiteToContractSetup) | fcSDK Documentation

SiteIDNum Property (AddSiteToContractSetup)

Identifier of the Site to add to the Contract.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteIDNum As String

[PropertyBitValueAttribute()]
public string SiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddSiteToContractSetup Class
AddSiteToContractSetup Members


AddUserToQueueSetup Class | fcSDK Documentation

AddUserToQueueSetup Class

Used by the AddUserToQueue method as setup data for invocation.

Syntax

'Declaration

Public Class AddUserToQueueSetup

public class AddUserToQueueSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.AddUserToQueueSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

AddUserToQueueSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
AddUserToQueue(AddUserToQueueSetup) Method


AddUserToQueueSetup Class Members | fcSDK Documentation

AddUserToQueueSetup Class Members

The following tables list the members exposed by AddUserToQueueSetup.

Public Constructors

 | Name | Description
Public Constructor | AddUserToQueueSetup Constructor | Initializes a new instance of the AddUserToQueueSetup class.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | IsSupervisor | Is the User a Queue supervisor? | | Public Property | Queue | Name of the Queue to which the User will be added.

| | Public Property | UserName | Username of the user being added to the Queue. |

Reference

AddUserToQueueSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
AddUserToQueue(AddUserToQueueSetup) Method


AddUserToQueueSetup Constructor | fcSDK Documentation

AddUserToQueueSetup Constructor

Name of the Queue to which the User will be added.

Username of the user being added to the Queue.

Initializes a new instance of the AddUserToQueueSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _queue_ As String, _
   ByVal _userName_ As String _
)

[ConstructorIndexAttribute()]
public AddUserToQueueSetup(
   string _queue_,
   string _userName_
)

Parameters

queue

Name of the Queue to which the User will be added.

userName

Username of the user being added to the Queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddUserToQueueSetup Class
AddUserToQueueSetup Members


IsSupervisor Property (AddUserToQueueSetup) | fcSDK Documentation

IsSupervisor Property (AddUserToQueueSetup)

Is the User a Queue supervisor?

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsSupervisor As Boolean

[PropertyBitValueAttribute()]
public bool IsSupervisor {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddUserToQueueSetup Class
AddUserToQueueSetup Members


Queue Property (AddUserToQueueSetup) | fcSDK Documentation

Queue Property (AddUserToQueueSetup)

Name of the Queue to which the User will be added.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Queue As String

[PropertyBitValueAttribute()]
public string Queue {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddUserToQueueSetup Class
AddUserToQueueSetup Members


UserName Property (AddUserToQueueSetup) | fcSDK Documentation

UserName Property (AddUserToQueueSetup)

Username of the user being added to the Queue.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddUserToQueueSetup Class
AddUserToQueueSetup Members


AddWorkaroundSetup Class | fcSDK Documentation

AddWorkaroundSetup Class

Used by the AddWorkaround method as setup data for invocation.

Syntax

'Declaration

Public Class AddWorkaroundSetup

public class AddWorkaroundSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.AddWorkaroundSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

AddWorkaroundSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
AddWorkaround(AddWorkaroundSetup) Method


AddWorkaroundSetup Class Members | fcSDK Documentation

AddWorkaroundSetup Class Members

The following tables list the members exposed by AddWorkaroundSetup.

Public Constructors

 | Name | Description
Public Constructor | AddWorkaroundSetup Constructor | Overloaded.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CreateDate | DateTime the Workaround was created. If not set, the current time is used.
Public Property | IsPublic | Is Workaround public?
Public Property | ResolutionCode | Element from the 'Resolution Code' application list. If not set, the default list value is used.
Public Property | SolutionIDNum | Identifier of the Solution to receive the Workaround.
Public Property | SolutionObjid | Objid of the Solution to receive the Workaround.
Public Property | Workaround | Text of the Workaround.

Reference

AddWorkaroundSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
AddWorkaround(AddWorkaroundSetup) Method


AddWorkaroundSetup Constructor | fcSDK Documentation

AddWorkaroundSetup Constructor

Initializes a new instance of the AddWorkaroundSetup class.

Overload List

Overload | Description
AddWorkaroundSetup Constructor(String,String) | Initializes a new instance of the AddWorkaroundSetup class. This overload takes a set of required parameters for the API.
AddWorkaroundSetup Constructor(Int32,String) | Initializes a new instance of the AddWorkaroundSetup class. This overload takes a set of required parameters for the API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddWorkaroundSetup Class
AddWorkaroundSetup Members


AddWorkaroundSetup Constructor(String,String) | fcSDK Documentation

AddWorkaroundSetup Constructor(String,String)

Identifier of the Solution to receive the Workaround.

Text of the Workaround.

Initializes a new instance of the AddWorkaroundSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _solutionIDNum_ As String, _
   ByVal _workaround_ As String _
)

[ConstructorIndexAttribute()]
public AddWorkaroundSetup(
   string _solutionIDNum_,
   string _workaround_
)

Parameters

solutionIDNum

Identifier of the Solution to receive the Workaround.

workaround

Text of the Workaround.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddWorkaroundSetup Class
AddWorkaroundSetup Members
Overload List


AddWorkaroundSetup Constructor(Int32,String) | fcSDK Documentation

AddWorkaroundSetup Constructor(Int32,String)

Objid of the Solution to receive the Workaround.

Text of the Workaround.

Initializes a new instance of the AddWorkaroundSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _solutionObjid_ As Integer, _
   ByVal _workaround_ As String _
)

[ConstructorIndexAttribute()]
public AddWorkaroundSetup(
   int _solutionObjid_,
   string _workaround_
)

Parameters

solutionObjid

Objid of the Solution to receive the Workaround.

workaround

Text of the Workaround.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddWorkaroundSetup Class
AddWorkaroundSetup Members
Overload List


AdditionalFields Property (AddWorkaroundSetup) | fcSDK Documentation

AdditionalFields Property (AddWorkaroundSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddWorkaroundSetup Class
AddWorkaroundSetup Members


CreateDate Property (AddWorkaroundSetup) | fcSDK Documentation

CreateDate Property (AddWorkaroundSetup)

DateTime the Workaround was created. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddWorkaroundSetup Class
AddWorkaroundSetup Members


IsPublic Property (AddWorkaroundSetup) | fcSDK Documentation

IsPublic Property (AddWorkaroundSetup)

Is Workaround public?

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsPublic As Boolean

[PropertyBitValueAttribute()]
public bool IsPublic {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddWorkaroundSetup Class
AddWorkaroundSetup Members


ResolutionCode Property (AddWorkaroundSetup) | fcSDK Documentation

ResolutionCode Property (AddWorkaroundSetup)

Element from the 'Resolution Code' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ResolutionCode As String

[PropertyBitValueAttribute()]
public string ResolutionCode {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddWorkaroundSetup Class
AddWorkaroundSetup Members


SolutionIDNum Property (AddWorkaroundSetup) | fcSDK Documentation

SolutionIDNum Property (AddWorkaroundSetup)

Identifier of the Solution to receive the Workaround.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SolutionIDNum As String

[PropertyBitValueAttribute()]
public string SolutionIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddWorkaroundSetup Class
AddWorkaroundSetup Members


SolutionObjid Property | fcSDK Documentation

SolutionObjid Property

Objid of the Solution to receive the Workaround.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SolutionObjid As Integer

[PropertyBitValueAttribute()]
public int SolutionObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddWorkaroundSetup Class
AddWorkaroundSetup Members


Workaround Property (AddWorkaroundSetup) | fcSDK Documentation

Workaround Property (AddWorkaroundSetup)

Text of the Workaround.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Workaround As String

[PropertyBitValueAttribute()]
public string Workaround {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddWorkaroundSetup Class
AddWorkaroundSetup Members


AssignSolutionSetup Class | fcSDK Documentation

AssignSolutionSetup Class

Used by the AssignSolution method as setup data for invocation.

Syntax

'Declaration

Public Class AssignSolutionSetup

public class AssignSolutionSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.AssignSolutionSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

AssignSolutionSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
AssignSolution(AssignSolutionSetup) Method


AssignSolutionSetup Class Members | fcSDK Documentation

AssignSolutionSetup Class Members

The following tables list the members exposed by AssignSolutionSetup.

Public Constructors

 | Name | Description
Public Constructor | AssignSolutionSetup Constructor | Initializes a new instance of the AssignSolutionSetup class.

Public Properties

 | Name | Description
Public Property | AssignDate | DateTime the Solution was assigned. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewUser | The new user to which the Solution is to be assigned.
Public Property | SolutionIDNum | Solution Identifier.
Public Property | UserName | The user who has assigned the Solution. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Solution. If not set, the UserName's default is used.

Reference

AssignSolutionSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
AssignSolution(AssignSolutionSetup) Method


AssignSolutionSetup Constructor | fcSDK Documentation

AssignSolutionSetup Constructor

Solution Identifier.

Initializes a new instance of the AssignSolutionSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _solutionIDNum_ As String _
)

[ConstructorIndexAttribute()]
public AssignSolutionSetup(
   string _solutionIDNum_
)

Parameters

solutionIDNum

Solution Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignSolutionSetup Class
AssignSolutionSetup Members


AssignDate Property (AssignSolutionSetup) | fcSDK Documentation

AssignDate Property (AssignSolutionSetup)

DateTime the Solution was assigned. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AssignDate As Date

[PropertyBitValueAttribute()]
public DateTime AssignDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignSolutionSetup Class
AssignSolutionSetup Members


GenerateTimeBombs Property (AssignSolutionSetup) | fcSDK Documentation

GenerateTimeBombs Property (AssignSolutionSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignSolutionSetup Class
AssignSolutionSetup Members


NewUser Property (AssignSolutionSetup) | fcSDK Documentation

NewUser Property (AssignSolutionSetup)

The new user to which the Solution is to be assigned.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewUser As String

[PropertyBitValueAttribute()]
public string NewUser {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignSolutionSetup Class
AssignSolutionSetup Members


SolutionIDNum Property (AssignSolutionSetup) | fcSDK Documentation

SolutionIDNum Property (AssignSolutionSetup)

Solution Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SolutionIDNum As String

[PropertyBitValueAttribute()]
public string SolutionIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignSolutionSetup Class
AssignSolutionSetup Members


UserName Property (AssignSolutionSetup) | fcSDK Documentation

UserName Property (AssignSolutionSetup)

The user who has assigned the Solution. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignSolutionSetup Class
AssignSolutionSetup Members


WipBin Property (AssignSolutionSetup) | fcSDK Documentation

WipBin Property (AssignSolutionSetup)

User's WipBin in which to place the Solution. If not set, the UserName's default is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignSolutionSetup Class
AssignSolutionSetup Members


CreateAccountSetup Class | fcSDK Documentation

CreateAccountSetup Class

Used by the CreateAccount method as setup data for invocation.

Syntax

'Declaration

Public Class CreateAccountSetup

public class CreateAccountSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.CreateAccountSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateAccountSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateAccount(CreateAccountSetup) Method


CreateAccountSetup Class Members | fcSDK Documentation

CreateAccountSetup Class Members

The following tables list the members exposed by CreateAccountSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateAccountSetup Constructor | Initializes a new instance of the CreateAccountSetup class.

Public Properties

 | Name | Description
Public Property | AccountName | Name of the Account.
Public Property | AccountType | Element from the 'Company Type' user defined list. If not set, the default list value is used.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CreateDate | DateTime the Account was created. If not set, the current time is used.
Public Property | Description | Account description.
Public Property | Fax | FAX number for the account.
Public Property | FiscalYear | Fiscal year the account was started.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Ownership | Element from the 'Company Ownership' user defined list. If not set, the default list value is used.
Public Property | Phone | Main phone number for the Account.
Public Property | Revenue | Element from the 'Company Revenue' user defined list. If not set, the default list value is used.
Public Property | Size | Element from the 'Company Size' user defined list. If not set, the default list value is used.
Public Property | Stock | Stock symbol for the Account.
Public Property | Territory | Territory of the Account.
Public Property | UserName | The User creating the Account.
Public Property | WebSite | URL of the web site for the Account.

Reference

CreateAccountSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateAccount(CreateAccountSetup) Method


CreateAccountSetup Constructor | fcSDK Documentation

CreateAccountSetup Constructor

Initializes a new instance of the CreateAccountSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New()

[ConstructorIndexAttribute()]
public CreateAccountSetup()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAccountSetup Class
CreateAccountSetup Members


AccountName Property (CreateAccountSetup) | fcSDK Documentation

AccountName Property (CreateAccountSetup)

Name of the Account.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AccountName As String

[PropertyBitValueAttribute()]
public string AccountName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAccountSetup Class
CreateAccountSetup Members


AccountType Property (CreateAccountSetup) | fcSDK Documentation

AccountType Property (CreateAccountSetup)

Element from the 'Company Type' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AccountType As String

[PropertyBitValueAttribute()]
public string AccountType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAccountSetup Class
CreateAccountSetup Members


AdditionalFields Property (CreateAccountSetup) | fcSDK Documentation

AdditionalFields Property (CreateAccountSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAccountSetup Class
CreateAccountSetup Members


CreateDate Property (CreateAccountSetup) | fcSDK Documentation

CreateDate Property (CreateAccountSetup)

DateTime the Account was created. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAccountSetup Class
CreateAccountSetup Members


Description Property (CreateAccountSetup) | fcSDK Documentation

Description Property (CreateAccountSetup)

Account description.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Description As String

[PropertyBitValueAttribute()]
public string Description {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAccountSetup Class
CreateAccountSetup Members


Fax Property (CreateAccountSetup) | fcSDK Documentation

Fax Property (CreateAccountSetup)

FAX number for the account.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Fax As String

[PropertyBitValueAttribute()]
public string Fax {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAccountSetup Class
CreateAccountSetup Members


FiscalYear Property (CreateAccountSetup) | fcSDK Documentation

FiscalYear Property (CreateAccountSetup)

Fiscal year the account was started.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FiscalYear As String

[PropertyBitValueAttribute()]
public string FiscalYear {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAccountSetup Class
CreateAccountSetup Members


GenerateTimeBombs Property (CreateAccountSetup) | fcSDK Documentation

GenerateTimeBombs Property (CreateAccountSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAccountSetup Class
CreateAccountSetup Members


Ownership Property (CreateAccountSetup) | fcSDK Documentation

Ownership Property (CreateAccountSetup)

Element from the 'Company Ownership' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Ownership As String

[PropertyBitValueAttribute()]
public string Ownership {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAccountSetup Class
CreateAccountSetup Members


Phone Property (CreateAccountSetup) | fcSDK Documentation

Phone Property (CreateAccountSetup)

Main phone number for the Account.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Phone As String

[PropertyBitValueAttribute()]
public string Phone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAccountSetup Class
CreateAccountSetup Members


Revenue Property (CreateAccountSetup) | fcSDK Documentation

Revenue Property (CreateAccountSetup)

Element from the 'Company Revenue' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Revenue As String

[PropertyBitValueAttribute()]
public string Revenue {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAccountSetup Class
CreateAccountSetup Members


Size Property (CreateAccountSetup) | fcSDK Documentation

Size Property (CreateAccountSetup)

Element from the 'Company Size' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Size As String

[PropertyBitValueAttribute()]
public string Size {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAccountSetup Class
CreateAccountSetup Members


Stock Property (CreateAccountSetup) | fcSDK Documentation

Stock Property (CreateAccountSetup)

Stock symbol for the Account.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Stock As String

[PropertyBitValueAttribute()]
public string Stock {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAccountSetup Class
CreateAccountSetup Members


Territory Property (CreateAccountSetup) | fcSDK Documentation

Territory Property (CreateAccountSetup)

Territory of the Account.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Territory As String

[PropertyBitValueAttribute()]
public string Territory {get; set;}

Remarks

Must be a valid Territory name from table 'territory'.

If the property is set to an empty string the relation to the current Territory will be removed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAccountSetup Class
CreateAccountSetup Members


UserName Property (CreateAccountSetup) | fcSDK Documentation

UserName Property (CreateAccountSetup)

The User creating the Account.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAccountSetup Class
CreateAccountSetup Members


WebSite Property (CreateAccountSetup) | fcSDK Documentation

WebSite Property (CreateAccountSetup)

URL of the web site for the Account.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WebSite As String

[PropertyBitValueAttribute()]
public string WebSite {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAccountSetup Class
CreateAccountSetup Members


CreateAddressSetup Class | fcSDK Documentation

CreateAddressSetup Class

Used by the CreateAddress method as setup data for invocation.

Syntax

'Declaration

Public Class CreateAddressSetup

public class CreateAddressSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.CreateAddressSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateAddressSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateAddress(CreateAddressSetup) Method


CreateAddressSetup Class Members | fcSDK Documentation

CreateAddressSetup Class Members

The following tables list the members exposed by CreateAddressSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateAddressSetup Constructor | Initializes a new instance of the CreateAddressSetup class.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | Address1 | Address Line 1.
Public Property | Address2 | Address Line 2.
Public Property | City | Address City.
Public Property | Country | Address Country
Public Property | IsShortState | Is the State property abbreviated or is it the full name of the State.
Public Property | State | Address State.
Public Property | TimeZone | Address Timezone.
Public Property | ZipCode | Address Zipcode.

Reference

CreateAddressSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateAddress(CreateAddressSetup) Method


CreateAddressSetup Constructor | fcSDK Documentation

CreateAddressSetup Constructor

Address Line 1.

Address City.

Address State.

Address Zipcode.

Address Country

Address Timezone.

Initializes a new instance of the CreateAddressSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _address1_ As String, _
   ByVal _city_ As String, _
   ByVal _state_ As String, _
   ByVal _zipCode_ As String, _
   ByVal _country_ As String, _
   ByVal _timeZone_ As String _
)

[ConstructorIndexAttribute()]
public CreateAddressSetup(
   string _address1_,
   string _city_,
   string _state_,
   string _zipCode_,
   string _country_,
   string _timeZone_
)

Parameters

address1

Address Line 1.

city

Address City.

state

Address State.

zipCode

Address Zipcode.

country

Address Country

timeZone

Address Timezone.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAddressSetup Class
CreateAddressSetup Members


AdditionalFields Property (CreateAddressSetup) | fcSDK Documentation

AdditionalFields Property (CreateAddressSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAddressSetup Class
CreateAddressSetup Members


Address1 Property (CreateAddressSetup) | fcSDK Documentation

Address1 Property (CreateAddressSetup)

Address Line 1.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Address1 As String

[PropertyBitValueAttribute()]
public string Address1 {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAddressSetup Class
CreateAddressSetup Members


Address2 Property (CreateAddressSetup) | fcSDK Documentation

Address2 Property (CreateAddressSetup)

Address Line 2.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Address2 As String

[PropertyBitValueAttribute()]
public string Address2 {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAddressSetup Class
CreateAddressSetup Members


City Property (CreateAddressSetup) | fcSDK Documentation

City Property (CreateAddressSetup)

Address City.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property City As String

[PropertyBitValueAttribute()]
public string City {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAddressSetup Class
CreateAddressSetup Members


Country Property (CreateAddressSetup) | fcSDK Documentation

Country Property (CreateAddressSetup)

Address Country

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Country As String

[PropertyBitValueAttribute()]
public string Country {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAddressSetup Class
CreateAddressSetup Members


IsShortState Property (CreateAddressSetup) | fcSDK Documentation

IsShortState Property (CreateAddressSetup)

Is the State property abbreviated or is it the full name of the State.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsShortState As Boolean

[PropertyBitValueAttribute()]
public bool IsShortState {get; set;}

Example

The State property is set to 'TX' thus IsShortState is true. When the State property is set to 'Texas' IsShortState should be false.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAddressSetup Class
CreateAddressSetup Members


State Property (CreateAddressSetup) | fcSDK Documentation

State Property (CreateAddressSetup)

Address State.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property State As String

[PropertyBitValueAttribute()]
public string State {get; set;}

Remarks

Please set IsShortState property depending on whether or not the state name is abbreviated.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAddressSetup Class
CreateAddressSetup Members


TimeZone Property (CreateAddressSetup) | fcSDK Documentation

TimeZone Property (CreateAddressSetup)

Address Timezone.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property TimeZone As String

[PropertyBitValueAttribute()]
public string TimeZone {get; set;}

Remarks

Must be an abbreviated timezone such as 'CST'

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAddressSetup Class
CreateAddressSetup Members


ZipCode Property (CreateAddressSetup) | fcSDK Documentation

ZipCode Property (CreateAddressSetup)

Address Zipcode.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ZipCode As String

[PropertyBitValueAttribute()]
public string ZipCode {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAddressSetup Class
CreateAddressSetup Members


CreateBOMSetup Class | fcSDK Documentation

CreateBOMSetup Class

Used by the CreateBOM method as setup data for invocation.

Syntax

'Declaration

Public Class CreateBOMSetup

public class CreateBOMSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.CreateBOMSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateBOMSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateBOM(CreateBOMSetup) Method


CreateBOMSetup Class Members | fcSDK Documentation

CreateBOMSetup Class Members

The following tables list the members exposed by CreateBOMSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateBOMSetup Constructor | Initializes a new instance of the CreateBOMSetup class.

Public Properties

 | Name | Description
Public Property | ChildPartDomain | Domain of the child part
Public Property | ChildPartNumber | Child Part Number
Public Property | ChildPartRevision | Child Part Revision
Public Property | ParentPartDomain | Parent Part Domain
Public Property | ParentPartNumber | Parent Part Number
Public Property | ParentPartRevision | Parent Part Revision
Public Property | Quantity | How many of the Child Part Revisions are in the Parent Part Revision.

Reference

CreateBOMSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateBOM(CreateBOMSetup) Method


CreateBOMSetup Constructor | fcSDK Documentation

CreateBOMSetup Constructor

Parent Part Number

Parent Part Domain

Parent Part Revision

Child Part Number

Domain of the child part

Child Part Revision

How many of the Child Part Revisions are in the Parent Part Revision.

Initializes a new instance of the CreateBOMSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _parentPartNumber_ As String, _
   ByVal _parentPartDomain_ As String, _
   ByVal _parentPartRevision_ As String, _
   ByVal _childPartNumber_ As String, _
   ByVal _childPartDomain_ As String, _
   ByVal _childPartRevision_ As String, _
   ByVal _quantity_ As Integer _
)

[ConstructorIndexAttribute()]
public CreateBOMSetup(
   string _parentPartNumber_,
   string _parentPartDomain_,
   string _parentPartRevision_,
   string _childPartNumber_,
   string _childPartDomain_,
   string _childPartRevision_,
   int _quantity_
)

Parameters

parentPartNumber

Parent Part Number

parentPartDomain

Parent Part Domain

parentPartRevision

Parent Part Revision

childPartNumber

Child Part Number

childPartDomain

Domain of the child part

childPartRevision

Child Part Revision

quantity

How many of the Child Part Revisions are in the Parent Part Revision.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateBOMSetup Class
CreateBOMSetup Members


ChildPartDomain Property | fcSDK Documentation

ChildPartDomain Property

Domain of the child part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ChildPartDomain As String

[PropertyBitValueAttribute()]
public string ChildPartDomain {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateBOMSetup Class
CreateBOMSetup Members


ChildPartNumber Property | fcSDK Documentation

ChildPartNumber Property

Child Part Number

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ChildPartNumber As String

[PropertyBitValueAttribute()]
public string ChildPartNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateBOMSetup Class
CreateBOMSetup Members


ChildPartRevision Property | fcSDK Documentation

ChildPartRevision Property

Child Part Revision

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ChildPartRevision As String

[PropertyBitValueAttribute()]
public string ChildPartRevision {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateBOMSetup Class
CreateBOMSetup Members


ParentPartDomain Property | fcSDK Documentation

ParentPartDomain Property

Parent Part Domain

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ParentPartDomain As String

[PropertyBitValueAttribute()]
public string ParentPartDomain {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateBOMSetup Class
CreateBOMSetup Members


ParentPartNumber Property | fcSDK Documentation

ParentPartNumber Property

Parent Part Number

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ParentPartNumber As String

[PropertyBitValueAttribute()]
public string ParentPartNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateBOMSetup Class
CreateBOMSetup Members


ParentPartRevision Property | fcSDK Documentation

ParentPartRevision Property

Parent Part Revision

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ParentPartRevision As String

[PropertyBitValueAttribute()]
public string ParentPartRevision {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateBOMSetup Class
CreateBOMSetup Members


Quantity Property (CreateBOMSetup) | fcSDK Documentation

Quantity Property (CreateBOMSetup)

How many of the Child Part Revisions are in the Parent Part Revision.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Quantity As Integer

[PropertyBitValueAttribute()]
public int Quantity {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateBOMSetup Class
CreateBOMSetup Members


CreateChannelSetup Class | fcSDK Documentation

CreateChannelSetup Class

Syntax

'Declaration

Public Class CreateChannelSetup

public class CreateChannelSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.CreateChannelSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateChannelSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace


CreateChannelSetup Class Members | fcSDK Documentation

CreateChannelSetup Class Members

The following tables list the members exposed by CreateChannelSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateChannelSetup Constructor |

Public Properties

 | Name | Description
Public Property | AdditionalFields |
Public Property | AllowInbound |
Public Property | AllowOutbound |
Public Property | Description |
Public Property | Designation |
Public Property | IsActive |
Public Property | Location |
Public Property | MediumObjid |
Public Property | Title |

Reference

CreateChannelSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace


CreateChannelSetup Constructor | fcSDK Documentation

CreateChannelSetup Constructor

Syntax

'Declaration

Public Function New( _
   ByVal _mediumObjid_ As Integer, _
   ByVal _designation_ As String _
)

public CreateChannelSetup(
   int _mediumObjid_,
   string _designation_
)

Parameters

mediumObjid

designation

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateChannelSetup Class
CreateChannelSetup Members


AdditionalFields Property (CreateChannelSetup) | fcSDK Documentation

AdditionalFields Property (CreateChannelSetup)

Syntax

'Declaration

Public ReadOnly Property AdditionalFields As SimplifiedAdditionalFields

public SimplifiedAdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateChannelSetup Class
CreateChannelSetup Members


AllowInbound Property | fcSDK Documentation

AllowInbound Property

Syntax

'Declaration

Public Property AllowInbound As Boolean

public bool AllowInbound {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateChannelSetup Class
CreateChannelSetup Members


AllowOutbound Property | fcSDK Documentation

AllowOutbound Property

Syntax

'Declaration

Public Property AllowOutbound As Boolean

public bool AllowOutbound {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateChannelSetup Class
CreateChannelSetup Members


Description Property (CreateChannelSetup) | fcSDK Documentation

Description Property (CreateChannelSetup)

Syntax

'Declaration

Public Property Description As String

public string Description {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateChannelSetup Class
CreateChannelSetup Members


Designation Property | fcSDK Documentation

Designation Property

Syntax

'Declaration

Public Property Designation As String

public string Designation {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateChannelSetup Class
CreateChannelSetup Members


IsActive Property (CreateChannelSetup) | fcSDK Documentation

IsActive Property (CreateChannelSetup)

Syntax

'Declaration

Public Property IsActive As Boolean

public bool IsActive {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateChannelSetup Class
CreateChannelSetup Members


Location Property (CreateChannelSetup) | fcSDK Documentation

Location Property (CreateChannelSetup)

Syntax

'Declaration

Public Property Location As String

public string Location {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateChannelSetup Class
CreateChannelSetup Members


MediumObjid Property | fcSDK Documentation

MediumObjid Property

Syntax

'Declaration

Public Property MediumObjid As Integer

public int MediumObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateChannelSetup Class
CreateChannelSetup Members


Title Property (CreateChannelSetup) | fcSDK Documentation

Title Property (CreateChannelSetup)

Syntax

'Declaration

Public Property Title As String

public string Title {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateChannelSetup Class
CreateChannelSetup Members


CreateCommunicationSetup Class | fcSDK Documentation

CreateCommunicationSetup Class

Used by the CreateCommunication method as setup data for invocation.

Syntax

'Declaration

Public Class CreateCommunicationSetup

public class CreateCommunicationSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.CreateCommunicationSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateCommunicationSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace


CreateCommunicationSetup Class Members | fcSDK Documentation

CreateCommunicationSetup Class Members

The following tables list the members exposed by CreateCommunicationSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateCommunicationSetup Constructor | Initializes a new instance of the CreateCommunicationSetup class.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | AutoExec | Indicator for user or automatic execution (CommunicationAutoExec).
Public Property | BCCRecipients | Array of addresses for BCC Recipients.
Public Property | CCRecipients | Array of addresses for CC Recipients.
Public Property | ChannelObjid |
Public Property | Created | The date and time that the communication was created.
Public Property | DeliveryStatus | The delivery status of the communication (CommunicationDeliveryStatus).
Public Property | DialogIDNumber | The ID of the parent dialogue.
Public Property | Direction | The direction of the message (CommunicationDirection).
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Message | The body text of the communication.
Public Property | MessageId | The ID of the message for the communication.
Public Property | MessageSent | The date and time that the communication was sent.
Public Property | Priority | The Priority of the communication.
Public Property | Recipients | Array of Recipient addresses (usually email addresses).
Public Property | ReplyTo | ReplyTo address (usually email address)
Public Property | Sender | Sender's address (usually email address)
Public Property | Title | The title or subject line of the communication.
Public Property | UserName | The Login Name of user creating the communication.

Reference

CreateCommunicationSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace


CreateCommunicationSetup Constructor | fcSDK Documentation

CreateCommunicationSetup Constructor

The ID of the parent dialogue.

The title or subject line of the communication.

The address of the sender of the communication.

The address of each receipient of the communication.

Initializes a new instance of the CreateCommunicationSetup class.

Syntax

'Declaration

Public Function New( _
   ByVal _dialogueIdNumber_ As String, _
   ByVal _title_ As String, _
   ByVal _channelObjid_ As Integer, _
   ByVal _sender_ As String, _
   ByVal _recipients_() As String _
)

public CreateCommunicationSetup(
   string _dialogueIdNumber_,
   string _title_,
   int _channelObjid_,
   string _sender_,
   string[] _recipients_
)

Parameters

dialogueIdNumber

The ID of the parent dialogue.

title

The title or subject line of the communication.

channelObjid

sender

The address of the sender of the communication.

recipients

The address of each receipient of the communication.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCommunicationSetup Class
CreateCommunicationSetup Members


AdditionalFields Property (CreateCommunicationSetup) | fcSDK Documentation

AdditionalFields Property (CreateCommunicationSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

Public ReadOnly Property AdditionalFields As SimplifiedAdditionalFields

public SimplifiedAdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCommunicationSetup Class
CreateCommunicationSetup Members


AutoExec Property (CreateCommunicationSetup) | fcSDK Documentation

AutoExec Property (CreateCommunicationSetup)

Indicator for user or automatic execution (CommunicationAutoExec).

Syntax

'Declaration

Public Property AutoExec As CommunicationAutoExec

public CommunicationAutoExec AutoExec {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCommunicationSetup Class
CreateCommunicationSetup Members


BCCRecipients Property (CreateCommunicationSetup) | fcSDK Documentation

BCCRecipients Property (CreateCommunicationSetup)

Array of addresses for BCC Recipients.

Syntax

'Declaration

Public Property BCCRecipients As String()

public string[] BCCRecipients {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCommunicationSetup Class
CreateCommunicationSetup Members


CCRecipients Property (CreateCommunicationSetup) | fcSDK Documentation

CCRecipients Property (CreateCommunicationSetup)

Array of addresses for CC Recipients.

Syntax

'Declaration

Public Property CCRecipients As String()

public string[] CCRecipients {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCommunicationSetup Class
CreateCommunicationSetup Members


ChannelObjid Property (CreateCommunicationSetup) | fcSDK Documentation

ChannelObjid Property (CreateCommunicationSetup)

Syntax

'Declaration

Public Property ChannelObjid As Integer

public int ChannelObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCommunicationSetup Class
CreateCommunicationSetup Members


Created Property (CreateCommunicationSetup) | fcSDK Documentation

Created Property (CreateCommunicationSetup)

The date and time that the communication was created.

Syntax

'Declaration

Public Property Created As Date

public DateTime Created {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCommunicationSetup Class
CreateCommunicationSetup Members


DeliveryStatus Property (CreateCommunicationSetup) | fcSDK Documentation

DeliveryStatus Property (CreateCommunicationSetup)

The delivery status of the communication (CommunicationDeliveryStatus).

Syntax

'Declaration

Public Property DeliveryStatus As CommunicationDeliveryStatus

public CommunicationDeliveryStatus DeliveryStatus {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCommunicationSetup Class
CreateCommunicationSetup Members


DialogIDNumber Property | fcSDK Documentation

DialogIDNumber Property

The ID of the parent dialogue.

Syntax

'Declaration

Public Property DialogIDNumber As String

public string DialogIDNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCommunicationSetup Class
CreateCommunicationSetup Members


Direction Property (CreateCommunicationSetup) | fcSDK Documentation

Direction Property (CreateCommunicationSetup)

The direction of the message (CommunicationDirection).

Syntax

'Declaration

Public Property Direction As CommunicationDirection

public CommunicationDirection Direction {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCommunicationSetup Class
CreateCommunicationSetup Members


GenerateTimeBombs Property (CreateCommunicationSetup) | fcSDK Documentation

GenerateTimeBombs Property (CreateCommunicationSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

Public Property GenerateTimeBombs As Boolean

public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCommunicationSetup Class
CreateCommunicationSetup Members


Message Property (CreateCommunicationSetup) | fcSDK Documentation

Message Property (CreateCommunicationSetup)

The body text of the communication.

Syntax

'Declaration

Public Property Message As String

public string Message {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCommunicationSetup Class
CreateCommunicationSetup Members


MessageId Property (CreateCommunicationSetup) | fcSDK Documentation

MessageId Property (CreateCommunicationSetup)

The ID of the message for the communication.

Syntax

'Declaration

Public Property MessageId As String

public string MessageId {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCommunicationSetup Class
CreateCommunicationSetup Members


MessageSent Property (CreateCommunicationSetup) | fcSDK Documentation

MessageSent Property (CreateCommunicationSetup)

The date and time that the communication was sent.

Syntax

'Declaration

Public Property MessageSent As Date

public DateTime MessageSent {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCommunicationSetup Class
CreateCommunicationSetup Members


Priority Property (CreateCommunicationSetup) | fcSDK Documentation

Priority Property (CreateCommunicationSetup)

The Priority of the communication.

Syntax

'Declaration

Public Property Priority As CommunicationPriority

public CommunicationPriority Priority {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCommunicationSetup Class
CreateCommunicationSetup Members


Recipients Property (CreateCommunicationSetup) | fcSDK Documentation

Recipients Property (CreateCommunicationSetup)

Array of Recipient addresses (usually email addresses).

Syntax

'Declaration

Public Property Recipients As String()

public string[] Recipients {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCommunicationSetup Class
CreateCommunicationSetup Members


ReplyTo Property (CreateCommunicationSetup) | fcSDK Documentation

ReplyTo Property (CreateCommunicationSetup)

ReplyTo address (usually email address)

Syntax

'Declaration

Public Property ReplyTo As String

public string ReplyTo {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCommunicationSetup Class
CreateCommunicationSetup Members


Sender Property (CreateCommunicationSetup) | fcSDK Documentation

Sender Property (CreateCommunicationSetup)

Sender's address (usually email address)

Syntax

'Declaration

Public Property Sender As String

public string Sender {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCommunicationSetup Class
CreateCommunicationSetup Members


Title Property (CreateCommunicationSetup) | fcSDK Documentation

Title Property (CreateCommunicationSetup)

The title or subject line of the communication.

Syntax

'Declaration

Public Property Title As String

public string Title {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCommunicationSetup Class
CreateCommunicationSetup Members


UserName Property (CreateCommunicationSetup) | fcSDK Documentation

UserName Property (CreateCommunicationSetup)

The Login Name of user creating the communication.

Syntax

'Declaration

Public Property UserName As String

public string UserName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCommunicationSetup Class
CreateCommunicationSetup Members


CreateContactSetup Class | fcSDK Documentation

CreateContactSetup Class

Used by the CreateContact method as setup data for invocation.

Syntax

'Declaration

Public Class CreateContactSetup

public class CreateContactSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.CreateContactSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateContactSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateContact(CreateContactSetup) Method


CreateContactSetup Class Members | fcSDK Documentation

CreateContactSetup Class Members

The following tables list the members exposed by CreateContactSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateContactSetup Constructor | Initializes a new instance of the CreateContactSetup class.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | Email | Contact email address
Public Property | Fax | Contact fax number
Public Property | FirstName | Contact first name
Public Property | Hours | Job hours for the contact
Public Property | LastName | Contact last name
Public Property | MailStop | Mail stop for Contact
Public Property | Phone | Phone number for the contact
Public Property | RoleName | Element from the 'Contact Role' application list. If not set, the default list value is used.
Public Property | Salutation | Salutation for the Contact
Public Property | SiteIDNum | Identifier of the site for the contact role to create.
Public Property | Title | Job title for the Contact

Reference

CreateContactSetup Class FChoice.Toolkits.Clarify.Interfaces Namespace CreateContact(CreateContactSetup) Method


CreateContactSetup Constructor | fcSDK Documentation

CreateContactSetup Constructor

Contact first name

Contact last name

Phone number for the contact

Identifier of the site for the contact role to create.

Initializes a new instance of the CreateContactSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _firstName_ As String, _
   ByVal _lastName_ As String, _
   ByVal _phone_ As String, _
   ByVal _siteIDNum_ As String _
)

[ConstructorIndexAttribute()]
public CreateContactSetup(
   string _firstName_,
   string _lastName_,
   string _phone_,
   string _siteIDNum_
)

Parameters

firstName

Contact first name

lastName

Contact last name

phone

Phone number for the contact

siteIDNum

Identifier of the site for the contact role to create.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContactSetup Class
CreateContactSetup Members


AdditionalFields Property (CreateContactSetup) | fcSDK Documentation

AdditionalFields Property (CreateContactSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContactSetup Class
CreateContactSetup Members


Email Property (CreateContactSetup) | fcSDK Documentation

Email Property (CreateContactSetup)

Contact email address

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Email As String

[PropertyBitValueAttribute()]
public string Email {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContactSetup Class
CreateContactSetup Members


Fax Property (CreateContactSetup) | fcSDK Documentation

Fax Property (CreateContactSetup)

Contact fax number

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Fax As String

[PropertyBitValueAttribute()]
public string Fax {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContactSetup Class
CreateContactSetup Members


FirstName Property (CreateContactSetup) | fcSDK Documentation

FirstName Property (CreateContactSetup)

Contact first name

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FirstName As String

[PropertyBitValueAttribute()]
public string FirstName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContactSetup Class
CreateContactSetup Members


Hours Property (CreateContactSetup) | fcSDK Documentation

Hours Property (CreateContactSetup)

Job hours for the contact

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Hours As String

[PropertyBitValueAttribute()]
public string Hours {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContactSetup Class
CreateContactSetup Members


LastName Property (CreateContactSetup) | fcSDK Documentation

LastName Property (CreateContactSetup)

Contact last name

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LastName As String

[PropertyBitValueAttribute()]
public string LastName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContactSetup Class
CreateContactSetup Members


MailStop Property (CreateContactSetup) | fcSDK Documentation

MailStop Property (CreateContactSetup)

Mail stop for Contact

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property MailStop As String

[PropertyBitValueAttribute()]
public string MailStop {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContactSetup Class
CreateContactSetup Members


Phone Property (CreateContactSetup) | fcSDK Documentation

Phone Property (CreateContactSetup)

Phone number for the contact

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Phone As String

[PropertyBitValueAttribute()]
public string Phone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContactSetup Class
CreateContactSetup Members


RoleName Property (CreateContactSetup) | fcSDK Documentation

RoleName Property (CreateContactSetup)

Element from the 'Contact Role' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property RoleName As String

[PropertyBitValueAttribute()]
public string RoleName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContactSetup Class
CreateContactSetup Members


Salutation Property (CreateContactSetup) | fcSDK Documentation

Salutation Property (CreateContactSetup)

Salutation for the Contact

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Salutation As String

[PropertyBitValueAttribute()]
public string Salutation {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContactSetup Class
CreateContactSetup Members


SiteIDNum Property (CreateContactSetup) | fcSDK Documentation

SiteIDNum Property (CreateContactSetup)

Identifier of the site for the contact role to create.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteIDNum As String

[PropertyBitValueAttribute()]
public string SiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContactSetup Class
CreateContactSetup Members


Title Property (CreateContactSetup) | fcSDK Documentation

Title Property (CreateContactSetup)

Job title for the Contact

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Title As String

[PropertyBitValueAttribute()]
public string Title {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContactSetup Class
CreateContactSetup Members


CreateContractSetup Class | fcSDK Documentation

CreateContractSetup Class

Used by the CreateContract method as setup data for invocation.

Syntax

'Declaration

Public Class CreateContractSetup

public class CreateContractSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.CreateContractSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateContractSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateContract(CreateContractSetup) Method


CreateContractSetup Class Members | fcSDK Documentation

CreateContractSetup Class Members

The following tables list the members exposed by CreateContractSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateContractSetup Constructor | Initializes a new instance of the CreateContractSetup class.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation. | | Public Property | BusinessHoursForPM | Specific hours when preventive maintainence is allowed. | | Public Property | ContractType | Element from the 'Contract Type' user defined list. If not set, the default list value is used. | | Public Property | ExpireDate | Contract expiration date

| | Public Property | Notes | Notes concerning the contract | | Public Property | OnsiteResponseDuration |

The maximum amount of time allowed by the Contract for a field engineer to arrive onsite.

| | Public Property | PayOptions | Method of payment for the Contract | | Public Property | PhoneResponseDuration |

The maximum amount of time allowed by the Contract for a customer service representative to contact the customer by telephone.

| | Public Property | PONumber | Purchase Order number | | Public Property | StartDate | Contract starting date | | Public Property | Status | Element from the 'Contract Status' user defined list. If not set, the default list value is used. | | Public Property | UnitsAvailable | Number of units currently available for use | | Public Property | UnitsPurchased | Number of units purchased | | Public Property | UnitsUsed | Number of units used | | Public Property | UnitType | The type of units the object is delivered in | | Public Property | UseSpecialConsiderations | Does Contract have special considerations? |

Reference

CreateContractSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateContract(CreateContractSetup) Method


CreateContractSetup Constructor | fcSDK Documentation

CreateContractSetup Constructor

Initializes a new instance of the CreateContractSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New()

[ConstructorIndexAttribute()]
public CreateContractSetup()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


BusinessHoursForPM Property (CreateContractSetup) | fcSDK Documentation

BusinessHoursForPM Property (CreateContractSetup)

Specific hours when preventive maintainence is allowed.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property BusinessHoursForPM As String

[PropertyBitValueAttribute()]
public string BusinessHoursForPM {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


ContractType Property (CreateContractSetup) | fcSDK Documentation

ContractType Property (CreateContractSetup)

Element from the 'Contract Type' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContractType As String

[PropertyBitValueAttribute()]
public string ContractType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


ExpireDate Property (CreateContractSetup) | fcSDK Documentation

ExpireDate Property (CreateContractSetup)

Contract expiration date

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ExpireDate As Date

[PropertyBitValueAttribute()]
public DateTime ExpireDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


Notes Property (CreateContractSetup) | fcSDK Documentation

Notes Property (CreateContractSetup)

Notes concerning the contract

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


OnsiteResponseDuration Property (CreateContractSetup) | fcSDK Documentation

OnsiteResponseDuration Property (CreateContractSetup)

The maximum amount of time allowed by the Contract for a field engineer to arrive onsite.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property OnsiteResponseDuration As TimeSpan

[PropertyBitValueAttribute()]
public TimeSpan OnsiteResponseDuration {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


PayOptions Property (CreateContractSetup) | fcSDK Documentation

PayOptions Property (CreateContractSetup)

Method of payment for the Contract

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PayOptions As String

[PropertyBitValueAttribute()]
public string PayOptions {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


PhoneResponseDuration Property (CreateContractSetup) | fcSDK Documentation

PhoneResponseDuration Property (CreateContractSetup)

The maximum amount of time allowed by the Contract for a customer service representative to contact the customer by telephone.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PhoneResponseDuration As TimeSpan

[PropertyBitValueAttribute()]
public TimeSpan PhoneResponseDuration {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


PONumber Property (CreateContractSetup) | fcSDK Documentation

PONumber Property (CreateContractSetup)

Purchase Order number

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PONumber As String

[PropertyBitValueAttribute()]
public string PONumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


StartDate Property (CreateContractSetup) | fcSDK Documentation

StartDate Property (CreateContractSetup)

Contract starting date

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property StartDate As Date

[PropertyBitValueAttribute()]
public DateTime StartDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


Status Property (CreateContractSetup) | fcSDK Documentation

Status Property (CreateContractSetup)

Element from the 'Contract Status' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Status As String

[PropertyBitValueAttribute()]
public string Status {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


UnitsAvailable Property (CreateContractSetup) | fcSDK Documentation

UnitsAvailable Property (CreateContractSetup)

Number of units currently available for use

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UnitsAvailable As Double

[PropertyBitValueAttribute()]
public double UnitsAvailable {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


UnitsPurchased Property (CreateContractSetup) | fcSDK Documentation

UnitsPurchased Property (CreateContractSetup)

Number of units purchased

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UnitsPurchased As Double

[PropertyBitValueAttribute()]
public double UnitsPurchased {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


UnitsUsed Property (CreateContractSetup) | fcSDK Documentation

UnitsUsed Property (CreateContractSetup)

Number of units used

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UnitsUsed As Double

[PropertyBitValueAttribute()]
public double UnitsUsed {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


UnitType Property (CreateContractSetup) | fcSDK Documentation

UnitType Property (CreateContractSetup)

The type of units the object is delivered in

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UnitType As String

[PropertyBitValueAttribute()]
public string UnitType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


UseSpecialConsiderations Property (CreateContractSetup) | fcSDK Documentation

UseSpecialConsiderations Property (CreateContractSetup)

Does Contract have special considerations?

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UseSpecialConsiderations As Boolean

[PropertyBitValueAttribute()]
public bool UseSpecialConsiderations {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContractSetup Class
CreateContractSetup Members


CreateCountrySetup Class | fcSDK Documentation

CreateCountrySetup Class

Used by the CreateCountry method as setup data for invocation.

Syntax

'Declaration

Public Class CreateCountrySetup

public class CreateCountrySetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.CreateCountrySetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateCountrySetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateCountry(CreateCountrySetup) Method


CreateCountrySetup Class Members | fcSDK Documentation

CreateCountrySetup Class Members

The following tables list the members exposed by CreateCountrySetup.

Public Constructors

 | Name | Description
Public Constructor | CreateCountrySetup Constructor | Initializes a new instance of the CreateCountrySetup class.

Public Properties

 | Name | Description
Public Property | Country | Name of the Country being created
Public Property | CountryCode | Telephone country code for the Country
Public Property | Currency | Name of the Currency used by the Country
Public Property | CurrencyConversionRate | Conversion rate for the currency
Public Property | CurrencyDescription | Currency description
Public Property | CurrencyISOCode | International Standards Organization code for the Country's currency
Public Property | CurrencySymbol | Currency Symbol

Reference

CreateCountrySetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateCountry(CreateCountrySetup) Method


CreateCountrySetup Constructor | fcSDK Documentation

CreateCountrySetup Constructor

Name of the Country being created

Telephone country code for the Country

Initializes a new instance of the CreateCountrySetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _country_ As String, _
   ByVal _countryCode_ As Integer _
)

[ConstructorIndexAttribute()]
public CreateCountrySetup(
   string _country_,
   int _countryCode_
)

Parameters

country

Name of the Country being created

countryCode

Telephone country code for the Country

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCountrySetup Class
CreateCountrySetup Members


Country Property (CreateCountrySetup) | fcSDK Documentation

Country Property (CreateCountrySetup)

Name of the Country being created

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Country As String

[PropertyBitValueAttribute()]
public string Country {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCountrySetup Class
CreateCountrySetup Members


CountryCode Property | fcSDK Documentation

CountryCode Property

Telephone country code for the Country

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CountryCode As Integer

[PropertyBitValueAttribute()]
public int CountryCode {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCountrySetup Class
CreateCountrySetup Members


Currency Property (CreateCountrySetup) | fcSDK Documentation

Currency Property (CreateCountrySetup)

Name of the Currency used by the Country

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Currency As String

[PropertyBitValueAttribute()]
public string Currency {get; set;}

Remarks

If the Currency name is not found a new currency one is created based on the Currency properties of this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCountrySetup Class
CreateCountrySetup Members


CurrencyConversionRate Property | fcSDK Documentation

CurrencyConversionRate Property

Conversion rate for the currency

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CurrencyConversionRate As Double

[PropertyBitValueAttribute()]
public double CurrencyConversionRate {get; set;}

Remarks

Only used if a new Currency is created by entering a country Currency name that is not already present.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCountrySetup Class
CreateCountrySetup Members


CurrencyDescription Property | fcSDK Documentation

CurrencyDescription Property

Currency description

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CurrencyDescription As String

[PropertyBitValueAttribute()]
public string CurrencyDescription {get; set;}

Remarks

Only used if a new Currency is created by entering a Currency name that is not already present.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCountrySetup Class
CreateCountrySetup Members


CurrencyISOCode Property | fcSDK Documentation

CurrencyISOCode Property

International Standards Organization code for the Country's currency

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CurrencyISOCode As String

[PropertyBitValueAttribute()]
public string CurrencyISOCode {get; set;}

Remarks

Only used if a new Currency is created by entering a Currency name that is not already present.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCountrySetup Class
CreateCountrySetup Members


CurrencySymbol Property | fcSDK Documentation

CurrencySymbol Property

Currency Symbol

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CurrencySymbol As String

[PropertyBitValueAttribute()]
public string CurrencySymbol {get; set;}

Remarks

Only used if a new Currency is created by entering a Currency name that is not already present.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCountrySetup Class
CreateCountrySetup Members


CreateDialogueSetup Class | fcSDK Documentation

CreateDialogueSetup Class

Initializes a new instance of the CreateDialogueSetup class.

Syntax

'Declaration

Public Class CreateDialogueSetup

public class CreateDialogueSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.CreateDialogueSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateDialogueSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace


CreateDialogueSetup Class Members | fcSDK Documentation

CreateDialogueSetup Class Members

The following tables list the members exposed by CreateDialogueSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateDialogueSetup Constructor | Initializes a new instance of the CreateDialogueSetup class.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | Created | The date and time that the dialogue was created.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Priority | The Priority of the dialogue.
Public Property | Status | The initial status of the dialogue.
Public Property | Title | The title of the dialogue.
Public Property | UserName | The Login Name of user creating the dialogue.

Reference

CreateDialogueSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace


CreateDialogueSetup Constructor | fcSDK Documentation

CreateDialogueSetup Constructor

Initializes a new instance of the CreateDialogueSetup class.

Syntax

'Declaration

Public Function New()

public CreateDialogueSetup()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateDialogueSetup Class
CreateDialogueSetup Members


AdditionalFields Property (CreateDialogueSetup) | fcSDK Documentation

AdditionalFields Property (CreateDialogueSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

Public ReadOnly Property AdditionalFields As SimplifiedAdditionalFields

public SimplifiedAdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateDialogueSetup Class
CreateDialogueSetup Members


Created Property (CreateDialogueSetup) | fcSDK Documentation

Created Property (CreateDialogueSetup)

The date and time that the dialogue was created.

Syntax

'Declaration

Public Property Created As Date

public DateTime Created {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateDialogueSetup Class
CreateDialogueSetup Members


GenerateTimeBombs Property (CreateDialogueSetup) | fcSDK Documentation

GenerateTimeBombs Property (CreateDialogueSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

Public Property GenerateTimeBombs As Boolean

public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateDialogueSetup Class
CreateDialogueSetup Members


Priority Property (CreateDialogueSetup) | fcSDK Documentation

Priority Property (CreateDialogueSetup)

The Priority of the dialogue.

Syntax

'Declaration

Public Property Priority As String

public string Priority {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateDialogueSetup Class
CreateDialogueSetup Members


Status Property (CreateDialogueSetup) | fcSDK Documentation

Status Property (CreateDialogueSetup)

The initial status of the dialogue.

Syntax

'Declaration

Public Property Status As String

public string Status {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateDialogueSetup Class
CreateDialogueSetup Members


Title Property (CreateDialogueSetup) | fcSDK Documentation

Title Property (CreateDialogueSetup)

The title of the dialogue.

Syntax

'Declaration

Public Property Title As String

public string Title {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateDialogueSetup Class
CreateDialogueSetup Members


UserName Property (CreateDialogueSetup) | fcSDK Documentation

UserName Property (CreateDialogueSetup)

The Login Name of user creating the dialogue.

Syntax

'Declaration

Public Property UserName As String

public string UserName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateDialogueSetup Class
CreateDialogueSetup Members


CreateEmployeeResult Class | fcSDK Documentation

CreateEmployeeResult Class

Result from the CreateEmployee API.

Syntax

'Declaration

Public Class CreateEmployeeResult
   Inherits FChoice.Toolkits.Clarify.ToolkitResult

public class CreateEmployeeResult : FChoice.Toolkits.Clarify.ToolkitResult

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.ToolkitResult
FChoice.Toolkits.Clarify.Interfaces.CreateEmployeeResult

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateEmployeeResult Members
FChoice.Toolkits.Clarify.Interfaces Namespace


CreateEmployeeResult Class Members | fcSDK Documentation

CreateEmployeeResult Class Members

The following tables list the members exposed by CreateEmployeeResult.

Public Constructors

 | Name | Description
Public Constructor | CreateEmployeeResult Constructor |

Public Properties

 | Name | Description
Public Property | EmployeeObjid | Objid of the Employee record created.
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | UserObjid | Objid of the User record created.

Reference

CreateEmployeeResult Class
FChoice.Toolkits.Clarify.Interfaces Namespace


CreateEmployeeResult Constructor | fcSDK Documentation

CreateEmployeeResult Constructor

Syntax

'Declaration

Public Function New()

public CreateEmployeeResult()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEmployeeResult Class
CreateEmployeeResult Members


EmployeeObjid Property | fcSDK Documentation

EmployeeObjid Property

Objid of the Employee record created.

Syntax

'Declaration

Public Property EmployeeObjid As Integer

public int EmployeeObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEmployeeResult Class
CreateEmployeeResult Members


UserObjid Property | fcSDK Documentation

UserObjid Property

Objid of the User record created.

Syntax

'Declaration

Public Property UserObjid As Integer

public int UserObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEmployeeResult Class
CreateEmployeeResult Members


CreateEmployeeSetup Class | fcSDK Documentation

CreateEmployeeSetup Class

Used by the CreateEmployee method as setup data for invocation.

Syntax

'Declaration

Public Class CreateEmployeeSetup

public class CreateEmployeeSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.CreateEmployeeSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateEmployeeSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateEmployee(CreateEmployeeSetup) Method


CreateEmployeeSetup Class Members | fcSDK Documentation

CreateEmployeeSetup Class Members

The following tables list the members exposed by CreateEmployeeSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateEmployeeSetup Constructor | Initializes a new instance of the CreateEmployeeSetup class.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation. | | Public Property | AfterBusinessHoursHigh | Preference for high priority notifications after business hours | | Public Property | AfterBusinessHoursLow | Preference for low priority notifications after business hours | | Public Property | AfterBusinessHoursMed | Preference for medium priority notifications after business hours | | Public Property | AllowProxy | Allow proxy use? | | Public Property | DefaultTablespace | Default Oracle Tablespace for the user | | Public Property | DefaultWipBinTitle | Title of the employee's default WipBin | | Public Property | Email | Employee's email address | | Public Property | EmployeeIdentifier | Employee Identifier | | Public Property | FirstName | Employee first name | | Public Property | IsActive | Is the Employee currently active? | | Public Property | IsFieldEngineer | Is Employee a field engineer? | | Public Property | IsSupervisor | Is Employee a supervisor?

| | Public Property | LaborRate | Employee's labor rate | | Public Property | LastName | Employee last name | | Public Property | LoginName | Employee login name | | Public Property | NormalBusinessHoursHigh | Preference for high priority notifications during normal business hours | | Public Property | NormalBusinessHoursLow | Preference for low priority notifications during normal business hours | | Public Property | NormalBusinessHoursMed | Preference for medium priority notifications during normal business hours | | Public Property | OfflinePrivilegeClass | Offline privilege class | | Public Property | OnlinePrivilegeClass | Online privilege class | | Public Property | Pager | Employee pager number | | Public Property | Password | Employee password | | Public Property | Phone | Employee phone number | | Public Property | ResourceConfig | The resource config that the Employee should be placed in | | Public Property | SiteIDNum | Identifier of the Site where the Employee is located. | | Public Property | StartDate | Employee start date | | Public Property | Supervisor | Employee's supervisor | | Public Property | TempTablespace | Temporary Oracle Tablespace for the user | | Public Property | UseDatabaseLogins | | | Public Property | WorkGroup | Element from the 'Workgroup' user defined list. If not set, the default list value is used. | | Public Property | WorkGroupStartDate | Date that the Employee started in the Workgroup |

Reference

CreateEmployeeSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateEmployee(CreateEmployeeSetup) Method


CreateEmployeeSetup Constructor | fcSDK Documentation

CreateEmployeeSetup Constructor

Employee first name

Employee last name

Employee login name

Employee password

Identifier of the Site where the Employee is located.

Employee's email address

Online privilege class

Initializes a new instance of the CreateEmployeeSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _firstName_ As String, _
   ByVal _lastName_ As String, _
   ByVal _loginName_ As String, _
   ByVal _password_ As String, _
   ByVal _siteIDNum_ As String, _
   ByVal _email_ As String, _
   ByVal _onlinePrivilegeClass_ As String _
)

[ConstructorIndexAttribute()]
public CreateEmployeeSetup(
   string _firstName_,
   string _lastName_,
   string _loginName_,
   string _password_,
   string _siteIDNum_,
   string _email_,
   string _onlinePrivilegeClass_
)

Parameters

firstName

Employee first name

lastName

Employee last name

loginName

Employee login name

password

Employee password

siteIDNum

Identifier of the Site where the Employee is located.

email

Employee's email address

onlinePrivilegeClass

Online privilege class

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEmployeeSetup Class
CreateEmployeeSetup Members


AdditionalFields Property (CreateEmployeeSetup) | fcSDK Documentation

AdditionalFields Property (CreateEmployeeSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEmployeeSetup Class
CreateEmployeeSetup Members


AfterBusinessHoursHigh Property | fcSDK Documentation

AfterBusinessHoursHigh Property

Preference for high priority notifications after business hours

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AfterBusinessHoursHigh As String

[PropertyBitValueAttribute()]
public string AfterBusinessHoursHigh {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEmployeeSetup Class
CreateEmployeeSetup Members


AfterBusinessHoursLow Property | fcSDK Documentation

AfterBusinessHoursLow Property

Preference for low priority notifications after business hours

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AfterBusinessHoursLow As String

[PropertyBitValueAttribute()]
public string AfterBusinessHoursLow {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEmployeeSetup Class
CreateEmployeeSetup Members


AfterBusinessHoursMed Property | fcSDK Documentation

AfterBusinessHoursMed Property

Preference for medium priority notifications after business hours

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AfterBusinessHoursMed As String

[PropertyBitValueAttribute()]
public string AfterBusinessHoursMed {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEmployeeSetup Class
CreateEmployeeSetup Members


AllowProxy Property | fcSDK Documentation

AllowProxy Property

Allow proxy use?

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AllowProxy As Boolean

[PropertyBitValueAttribute()]
public bool AllowProxy {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEmployeeSetup Class
CreateEmployeeSetup Members


DefaultTablespace Property | fcSDK Documentation

DefaultTablespace Property

Default Oracle Tablespace for the user

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property DefaultTablespace As String

[PropertyBitValueAttribute()]
public string DefaultTablespace {get; set;}

Remarks

This property only affects Oracle based Clarify installations. If left blank the default tablespace will be set to users

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEmployeeSetup Class
CreateEmployeeSetup Members


DefaultWipBinTitle Property | fcSDK Documentation

DefaultWipBinTitle Property

Title of the employee's default WipBin

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property DefaultWipBinTitle As String

[PropertyBitValueAttribute()]
public string DefaultWipBinTitle {get; set;}

Remarks

If not set, the DefaultWipBinTitle will be set to default

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEmployeeSetup Class
CreateEmployeeSetup Members


Email Property (CreateEmployeeSetup) | fcSDK Documentation

Email Property (CreateEmployeeSetup)

Employee's email address

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Email As String

[PropertyBitValueAttribute()]
public string Email {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEmployeeSetup Class
CreateEmployeeSetup Members


EmployeeIdentifier Property | fcSDK Documentation

EmployeeIdentifier Property

Employee Identifier

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property EmployeeIdentifier As String

[PropertyBitValueAttribute()]
public string EmployeeIdentifier {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEmployeeSetup Class
CreateEmployeeSetup Members


FirstName Property (CreateEmployeeSetup) | fcSDK Documentation

FirstName Property (CreateEmployeeSetup)

Employee first name

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FirstName As String

[PropertyBitValueAttribute()]
public string FirstName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEmployeeSetup Class
CreateEmployeeSetup Members


IsActive Property (CreateEmployeeSetup) | fcSDK Documentation

IsActive Property (CreateEmployeeSetup)

Is the Employee currently active?

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsActive As Boolean

[PropertyBitValueAttribute()]
public bool IsActive {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEmployeeSetup Class
CreateEmployeeSetup Members


IsFieldEngineer Property | fcSDK Documentation

IsFieldEngineer Property

Is Employee a field engineer?

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsFieldEngineer As Boolean

[PropertyBitValueAttribute()]
public bool IsFieldEngineer {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEmployeeSetup Class
CreateEmployeeSetup Members


IsSupervisor Property (CreateEmployeeSetup) | fcSDK Documentation

IsSupervisor Property (CreateEmployeeSetup)

Is Employee a supervisor?

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsSupervisor As Boolean

[PropertyBitValueAttribute()]
public bool IsSupervisor {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEmployeeSetup Class
CreateEmployeeSetup Members


LaborRate Property (CreateEmployeeSetup) | fcSDK Documentation

LaborRate Property (CreateEmployeeSetup)

Employee's labor rate

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LaborRate As Double

[PropertyBitValueAttribute()]
public double LaborRate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEmployeeSetup Class
CreateEmployeeSetup Members


LastName Property (CreateEmployeeSetup) | fcSDK Documentation

LastName Property (CreateEmployeeSetup)

Employee last name

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LastName As String

[PropertyBitValueAttribute()]
public string LastName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEmployeeSetup Class
CreateEmployeeSetup Members


LoginName Property | fcSDK Documentation

LoginName Property

Employee login name

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LoginName As String

[PropertyBitValueAttribute()]
public string LoginName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEmployeeSetup Class
CreateEmployeeSetup Members


NormalBusinessHoursHigh Property | fcSDK Documentation

NormalBusinessHoursHigh Property

Preference for high priority notifications during normal business hours

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NormalBusinessHoursHigh As String

[PropertyBitValueAttribute()]
public string NormalBusinessHoursHigh {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEmployeeSetup Class
CreateEmployeeSetup Members


NormalBusinessHoursLow Property | fcSDK Documentation

NormalBusinessHoursLow Property

Preference for low priority notifications during normal business hours

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NormalBusinessHoursLow As String

[PropertyBitValueAttribute()]
public string NormalBusinessHoursLow {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEmployeeSetup Class
CreateEmployeeSetup Members


NormalBusinessHoursMed Property | fcSDK Documentation

NormalBusinessHoursMed Property

Preference for medium priority notifications during normal business hours

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NormalBusinessHoursMed As String

[PropertyBitValueAttribute()]
public string NormalBusinessHoursMed {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEmployeeSetup Class
CreateEmployeeSetup Members


OfflinePrivilegeClass Property | fcSDK Documentation

OfflinePrivilegeClass Property

Offline privilege class

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property OfflinePrivilegeClass As String

[PropertyBitValueAttribute()]
public string OfflinePrivilegeClass {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEmployeeSetup Class
CreateEmployeeSetup Members


OnlinePrivilegeClass Property | fcSDK Documentation

OnlinePrivilegeClass Property

Online privilege class

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property OnlinePrivilegeClass As String

[PropertyBitValueAttribute()]
public string OnlinePrivilegeClass {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEmployeeSetup Class
CreateEmployeeSetup Members


Pager Property | fcSDK Documentation

Pager Property

Employee pager number

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Pager As String

[PropertyBitValueAttribute()]
public string Pager {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEmployeeSetup Class
CreateEmployeeSetup Members


Password Property | fcSDK Documentation

Password Property

Employee password

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Password As String

[PropertyBitValueAttribute()]
public string Password {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEmployeeSetup Class
CreateEmployeeSetup Members


Phone Property (CreateEmployeeSetup) | fcSDK Documentation

Phone Property (CreateEmployeeSetup)

Employee phone number

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Phone As String

[PropertyBitValueAttribute()]
public string Phone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEmployeeSetup Class
CreateEmployeeSetup Members


ResourceConfig Property | fcSDK Documentation

ResourceConfig Property

The resource config that the Employee should be placed in

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ResourceConfig As String

[PropertyBitValueAttribute()]
public string ResourceConfig {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEmployeeSetup Class
CreateEmployeeSetup Members


SiteIDNum Property (CreateEmployeeSetup) | fcSDK Documentation

SiteIDNum Property (CreateEmployeeSetup)

Identifier of the Site where the Employee is located.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteIDNum As String

[PropertyBitValueAttribute()]
public string SiteIDNum {get; set;}

Remarks

Must be a valid Site Identifier

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEmployeeSetup Class
CreateEmployeeSetup Members


StartDate Property (CreateEmployeeSetup) | fcSDK Documentation

StartDate Property (CreateEmployeeSetup)

Employee start date

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property StartDate As Date

[PropertyBitValueAttribute()]
public DateTime StartDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEmployeeSetup Class
CreateEmployeeSetup Members


Supervisor Property (CreateEmployeeSetup) | fcSDK Documentation

Supervisor Property (CreateEmployeeSetup)

Employee's supervisor

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Supervisor As String

[PropertyBitValueAttribute()]
public string Supervisor {get; set;}

Remarks

Enter the LoginName of an existing employee that is designated as a supervisor.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEmployeeSetup Class
CreateEmployeeSetup Members


TempTablespace Property | fcSDK Documentation

TempTablespace Property

Temporary Oracle Tablespace for the user

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property TempTablespace As String

[PropertyBitValueAttribute()]
public string TempTablespace {get; set;}

Remarks

This property only affects Oracle based Clarify installations. If left blank the temporary tablespace will be set to temp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEmployeeSetup Class
CreateEmployeeSetup Members


UseDatabaseLogins Property (CreateEmployeeSetup) | fcSDK Documentation

UseDatabaseLogins Property (CreateEmployeeSetup)

Syntax

'Declaration

Public Property UseDatabaseLogins As Boolean

public bool UseDatabaseLogins {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEmployeeSetup Class
CreateEmployeeSetup Members


WorkGroup Property | fcSDK Documentation

WorkGroup Property

Element from the 'Workgroup' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WorkGroup As String

[PropertyBitValueAttribute()]
public string WorkGroup {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEmployeeSetup Class
CreateEmployeeSetup Members


WorkGroupStartDate Property | fcSDK Documentation

WorkGroupStartDate Property

Date that the Employee started in the Workgroup

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WorkGroupStartDate As Date

[PropertyBitValueAttribute()]
public DateTime WorkGroupStartDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEmployeeSetup Class
CreateEmployeeSetup Members


CreateInteractionSetup Class | fcSDK Documentation

CreateInteractionSetup Class

Used by the CreateInteraction method as setup data for invocation.

Syntax

'Declaration

Public Class CreateInteractionSetup

public class CreateInteractionSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.CreateInteractionSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateInteractionSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateInteraction(CreateInteractionSetup) Method


CreateInteractionSetup Class Members | fcSDK Documentation

CreateInteractionSetup Class Members

The following tables list the members exposed by CreateInteractionSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateInteractionSetup Constructor | Initializes a new instance of the CreateInteractionSetup class.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation. | | Public Property | ContactFirstName | Contact's first name. | | Public Property | ContactLastName | Contact's last name. | | Public Property | ContactPhone | Contact's phone number. | | Public Property | Direction | Element from the 'Interaction Direction' user defined list. If not set, the default list value is used. | | Public Property | Duration | Duration of the Interaction

| | Public Property | EnteredDuration | Entered Interaction duration | | Public Property | FeeBased | Is the Interaction fee based? | | Public Property | GenerateTimeBombs | Specifies if timebombs should be created. | | Public Property | InteractionType | Element from the 'Interaction Type' user defined list. If not set, the default list value is used. | | Public Property | IsDoneInOne | Is the Interaction done-in-one? | | Public Property | LeadSource | Name of the person that provided the lead | | Public Property | Notes | Interaction Notes | | Public Property | Origin | Element from the 'Interaction Origin' user defined list. If not set, the default list value is used. | | Public Property | PayOption | Element from the 'Interaction Pay Option' user defined list. If not set, the default list value is used. | | Public Property | ProductName | Element from the 'Interaction Product' user defined list. If not set, the default list value is used. | | Public Property | Reason1 | Element from the 'Interaction Reason_1' user defined list. If not set, the default list value is used. | | Public Property | Reason2 | Element from the 'Interaction Reason_2' user defined list. If not set, the default list value is used. | | Public Property | Result | Element from the 'Interaction Result Code' user defined list. If not set, the default list value is used. | | Public Property | StartDate | DateTime Interaction began | | Public Property | Title | Title of the Interaction | | Public Property | UserName | User performing the Interaction | | Public Property | WaitDuration | Wait time for the Interaction | | Public Property | ZipCode | Contact zipcode |

Reference

CreateInteractionSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateInteraction(CreateInteractionSetup) Method


CreateInteractionSetup Constructor | fcSDK Documentation

CreateInteractionSetup Constructor

Contact's first name.

Contact's last name.

Contact's phone number.

Duration of the Interaction

Initializes a new instance of the CreateInteractionSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _contactFirstName_ As String, _
   ByVal _contactLastName_ As String, _
   ByVal _contactPhone_ As String, _
   ByVal _duration_ As TimeSpan _
)

[ConstructorIndexAttribute()]
public CreateInteractionSetup(
   string _contactFirstName_,
   string _contactLastName_,
   string _contactPhone_,
   TimeSpan _duration_
)

Parameters

contactFirstName

Contact's first name.

contactLastName

Contact's last name.

contactPhone

Contact's phone number.

duration

Duration of the Interaction

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateInteractionSetup Class
CreateInteractionSetup Members


AdditionalFields Property (CreateInteractionSetup) | fcSDK Documentation

AdditionalFields Property (CreateInteractionSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateInteractionSetup Class
CreateInteractionSetup Members


ContactFirstName Property (CreateInteractionSetup) | fcSDK Documentation

ContactFirstName Property (CreateInteractionSetup)

Contact's first name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactFirstName As String

[PropertyBitValueAttribute()]
public string ContactFirstName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateInteractionSetup Class
CreateInteractionSetup Members


ContactLastName Property (CreateInteractionSetup) | fcSDK Documentation

ContactLastName Property (CreateInteractionSetup)

Contact's last name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactLastName As String

[PropertyBitValueAttribute()]
public string ContactLastName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateInteractionSetup Class
CreateInteractionSetup Members


ContactPhone Property (CreateInteractionSetup) | fcSDK Documentation

ContactPhone Property (CreateInteractionSetup)

Contact's phone number.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactPhone As String

[PropertyBitValueAttribute()]
public string ContactPhone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateInteractionSetup Class
CreateInteractionSetup Members


Direction Property (CreateInteractionSetup) | fcSDK Documentation

Direction Property (CreateInteractionSetup)

Element from the 'Interaction Direction' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Direction As String

[PropertyBitValueAttribute()]
public string Direction {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateInteractionSetup Class
CreateInteractionSetup Members


Duration Property (CreateInteractionSetup) | fcSDK Documentation

Duration Property (CreateInteractionSetup)

Duration of the Interaction

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Duration As TimeSpan

[PropertyBitValueAttribute()]
public TimeSpan Duration {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateInteractionSetup Class
CreateInteractionSetup Members


EnteredDuration Property | fcSDK Documentation

EnteredDuration Property

Entered Interaction duration

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property EnteredDuration As TimeSpan

[PropertyBitValueAttribute()]
public TimeSpan EnteredDuration {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateInteractionSetup Class
CreateInteractionSetup Members


FeeBased Property | fcSDK Documentation

FeeBased Property

Is the Interaction fee based?

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FeeBased As Boolean

[PropertyBitValueAttribute()]
public bool FeeBased {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateInteractionSetup Class
CreateInteractionSetup Members


GenerateTimeBombs Property (CreateInteractionSetup) | fcSDK Documentation

GenerateTimeBombs Property (CreateInteractionSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateInteractionSetup Class
CreateInteractionSetup Members


InteractionType Property | fcSDK Documentation

InteractionType Property

Element from the 'Interaction Type' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InteractionType As String

[PropertyBitValueAttribute()]
public string InteractionType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateInteractionSetup Class
CreateInteractionSetup Members


IsDoneInOne Property | fcSDK Documentation

IsDoneInOne Property

Is the Interaction done-in-one?

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsDoneInOne As Boolean

[PropertyBitValueAttribute()]
public bool IsDoneInOne {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateInteractionSetup Class
CreateInteractionSetup Members


LeadSource Property (CreateInteractionSetup) | fcSDK Documentation

LeadSource Property (CreateInteractionSetup)

Name of the person that provided the lead

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LeadSource As String

[PropertyBitValueAttribute()]
public string LeadSource {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateInteractionSetup Class
CreateInteractionSetup Members


Notes Property (CreateInteractionSetup) | fcSDK Documentation

Notes Property (CreateInteractionSetup)

Interaction Notes

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateInteractionSetup Class
CreateInteractionSetup Members


Origin Property | fcSDK Documentation

Origin Property

Element from the 'Interaction Origin' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Origin As String

[PropertyBitValueAttribute()]
public string Origin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateInteractionSetup Class
CreateInteractionSetup Members


PayOption Property | fcSDK Documentation

PayOption Property

Element from the 'Interaction Pay Option' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PayOption As String

[PropertyBitValueAttribute()]
public string PayOption {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateInteractionSetup Class
CreateInteractionSetup Members


ProductName Property | fcSDK Documentation

ProductName Property

Element from the 'Interaction Product' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ProductName As String

[PropertyBitValueAttribute()]
public string ProductName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateInteractionSetup Class
CreateInteractionSetup Members


Reason1 Property | fcSDK Documentation

Reason1 Property

Element from the 'Interaction Reason_1' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Reason1 As String

[PropertyBitValueAttribute()]
public string Reason1 {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateInteractionSetup Class
CreateInteractionSetup Members


Reason2 Property | fcSDK Documentation

Reason2 Property

Element from the 'Interaction Reason_2' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Reason2 As String

[PropertyBitValueAttribute()]
public string Reason2 {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateInteractionSetup Class
CreateInteractionSetup Members


Result Property | fcSDK Documentation

Result Property

Element from the 'Interaction Result Code' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Result As String

[PropertyBitValueAttribute()]
public string Result {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateInteractionSetup Class
CreateInteractionSetup Members


StartDate Property (CreateInteractionSetup) | fcSDK Documentation

StartDate Property (CreateInteractionSetup)

DateTime Interaction began

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property StartDate As Date

[PropertyBitValueAttribute()]
public DateTime StartDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateInteractionSetup Class
CreateInteractionSetup Members


Title Property (CreateInteractionSetup) | fcSDK Documentation

Title Property (CreateInteractionSetup)

Title of the Interaction

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Title As String

[PropertyBitValueAttribute()]
public string Title {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateInteractionSetup Class
CreateInteractionSetup Members


UserName Property (CreateInteractionSetup) | fcSDK Documentation

UserName Property (CreateInteractionSetup)

User performing the Interaction

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateInteractionSetup Class
CreateInteractionSetup Members


WaitDuration Property | fcSDK Documentation

WaitDuration Property

Wait time for the Interaction

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WaitDuration As TimeSpan

[PropertyBitValueAttribute()]
public TimeSpan WaitDuration {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateInteractionSetup Class
CreateInteractionSetup Members


ZipCode Property (CreateInteractionSetup) | fcSDK Documentation

ZipCode Property (CreateInteractionSetup)

Contact zipcode

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ZipCode As String

[PropertyBitValueAttribute()]
public string ZipCode {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateInteractionSetup Class
CreateInteractionSetup Members


CreatePartRevisionSetup Class | fcSDK Documentation

CreatePartRevisionSetup Class

Used by the CreatePartRevision method as setup data for invocation.

Syntax

'Declaration

Public Class CreatePartRevisionSetup

public class CreatePartRevisionSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.CreatePartRevisionSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreatePartRevisionSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
CreatePartRevision(CreatePartRevisionSetup) Method


CreatePartRevisionSetup Class Members | fcSDK Documentation

CreatePartRevisionSetup Class Members

The following tables list the members exposed by CreatePartRevisionSetup.

Public Constructors

 | Name | Description
Public Constructor | CreatePartRevisionSetup Constructor | Initializes a new instance of the CreatePartRevisionSetup class.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | PartDomain | Domain of the part | | Public Property | PartNumber | Part number of the part | | Public Property | PartRevision | Revision to create | | Public Property | ReplaceDate | DateTime this part replaced the previous one. | | Public Property | ReplacePartDomain | Previous domain this PartRevision replaces.

| | Public Property | ReplacePartNumber |

Previous part number this PartRevision replaces.

| | Public Property | ReplacePartRevision |

Previous revision this PartRevision replaces.

| | Public Property | Status | The status of the Part Revision. |

Reference

CreatePartRevisionSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
CreatePartRevision(CreatePartRevisionSetup) Method


CreatePartRevisionSetup Constructor | fcSDK Documentation

CreatePartRevisionSetup Constructor

Part number of the part

Domain of the part

Revision to create

Initializes a new instance of the CreatePartRevisionSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partNumber_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _partRevision_ As String _
)

[ConstructorIndexAttribute()]
public CreatePartRevisionSetup(
   string _partNumber_,
   string _partDomain_,
   string _partRevision_
)

Parameters

partNumber

Part number of the part

partDomain

Domain of the part

partRevision

Revision to create

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRevisionSetup Class
CreatePartRevisionSetup Members


PartDomain Property (CreatePartRevisionSetup) | fcSDK Documentation

PartDomain Property (CreatePartRevisionSetup)

Domain of the part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartDomain As String

[PropertyBitValueAttribute()]
public string PartDomain {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRevisionSetup Class
CreatePartRevisionSetup Members


PartNumber Property (CreatePartRevisionSetup) | fcSDK Documentation

PartNumber Property (CreatePartRevisionSetup)

Part number of the part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartNumber As String

[PropertyBitValueAttribute()]
public string PartNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRevisionSetup Class
CreatePartRevisionSetup Members


PartRevision Property (CreatePartRevisionSetup) | fcSDK Documentation

PartRevision Property (CreatePartRevisionSetup)

Revision to create

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRevision As String

[PropertyBitValueAttribute()]
public string PartRevision {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRevisionSetup Class
CreatePartRevisionSetup Members


ReplaceDate Property (CreatePartRevisionSetup) | fcSDK Documentation

ReplaceDate Property (CreatePartRevisionSetup)

DateTime this part replaced the previous one.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ReplaceDate As Date

[PropertyBitValueAttribute()]
public DateTime ReplaceDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRevisionSetup Class
CreatePartRevisionSetup Members


ReplacePartDomain Property (CreatePartRevisionSetup) | fcSDK Documentation

ReplacePartDomain Property (CreatePartRevisionSetup)

Previous domain this PartRevision replaces.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ReplacePartDomain As String

[PropertyBitValueAttribute()]
public string ReplacePartDomain {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRevisionSetup Class
CreatePartRevisionSetup Members


ReplacePartNumber Property (CreatePartRevisionSetup) | fcSDK Documentation

ReplacePartNumber Property (CreatePartRevisionSetup)

Previous part number this PartRevision replaces.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ReplacePartNumber As String

[PropertyBitValueAttribute()]
public string ReplacePartNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRevisionSetup Class
CreatePartRevisionSetup Members


ReplacePartRevision Property (CreatePartRevisionSetup) | fcSDK Documentation

ReplacePartRevision Property (CreatePartRevisionSetup)

Previous revision this PartRevision replaces.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ReplacePartRevision As String

[PropertyBitValueAttribute()]
public string ReplacePartRevision {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRevisionSetup Class
CreatePartRevisionSetup Members


Status Property (CreatePartRevisionSetup) | fcSDK Documentation

Status Property (CreatePartRevisionSetup)

The status of the Part Revision.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Status As PartRevisionStatus

[PropertyBitValueAttribute()]
public PartRevisionStatus Status {get; set;}

Remarks

If not set, the default value of PartRevisionStatus.Active is used.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRevisionSetup Class
CreatePartRevisionSetup Members


CreatePartSetup Class | fcSDK Documentation

CreatePartSetup Class

Used by the CreatePart method as setup data for invocation.

Syntax

'Declaration

Public Class CreatePartSetup

public class CreatePartSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.CreatePartSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreatePartSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
CreatePart(CreatePartSetup) Method


CreatePartSetup Class Members | fcSDK Documentation

CreatePartSetup Class Members

The following tables list the members exposed by CreatePartSetup.

Public Constructors

 | Name | Description
Public Constructor | CreatePartSetup Constructor | Initializes a new instance of the CreatePartSetup class.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | Description | Description of the part
Public Property | Dimension | Dimensions of the part
Public Property | Family | Level 1 Element from the 'Family' user defined list. If not set, the default list value is used.
Public Property | Line | Level 2 Element from the 'Family' user defined list. If not set, the default list value is used.
Public Property | ModelNumber | Model number of the part
Public Property | Notes | Notes about the part
Public Property | PartClass | Part class for the part to create.
Public Property | PartDomain | Domain for the part to create.
Public Property | PartNumber | Part Number for the part to create.
Public Property | PartType | Element from the 'Part Type' user defined list. If not set, the default list value is used.
Public Property | RepairType | Type of repair. One of "Repairable" or "Expendable"
Public Property | UnitMeasure | Unit of measure for the part
Public Property | WarrantyDays | Number of warranty days for the part
Public Property | WarrantyStartOnShipment | Does the warranty start on shipment?
Public Property | Weight | Unit weight of the part

Reference

CreatePartSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
CreatePart(CreatePartSetup) Method


CreatePartSetup Constructor | fcSDK Documentation

CreatePartSetup Constructor

Part Number for the part to create.

Domain for the part to create.

Number of warranty days for the part

Type of repair. One of "Repairable" or "Expendable"

Initializes a new instance of the CreatePartSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partNumber_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _warrantyDays_ As Integer, _
   ByVal _repairType_ As PartRepairType _
)

[ConstructorIndexAttribute()]
public CreatePartSetup(
   string _partNumber_,
   string _partDomain_,
   int _warrantyDays_,
   PartRepairType _repairType_
)

Parameters

partNumber

Part Number for the part to create.

partDomain

Domain for the part to create.

warrantyDays

Number of warranty days for the part

repairType

Type of repair. One of "Repairable" or "Expendable"

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartSetup Class
CreatePartSetup Members


AdditionalFields Property (CreatePartSetup) | fcSDK Documentation

AdditionalFields Property (CreatePartSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartSetup Class
CreatePartSetup Members


Description Property (CreatePartSetup) | fcSDK Documentation

Description Property (CreatePartSetup)

Description of the part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Description As String

[PropertyBitValueAttribute()]
public string Description {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartSetup Class
CreatePartSetup Members


Dimension Property (CreatePartSetup) | fcSDK Documentation

Dimension Property (CreatePartSetup)

Dimensions of the part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Dimension As String

[PropertyBitValueAttribute()]
public string Dimension {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartSetup Class
CreatePartSetup Members


Family Property (CreatePartSetup) | fcSDK Documentation

Family Property (CreatePartSetup)

Level 1 Element from the 'Family' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Family As String

[PropertyBitValueAttribute()]
public string Family {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartSetup Class
CreatePartSetup Members


Line Property (CreatePartSetup) | fcSDK Documentation

Line Property (CreatePartSetup)

Level 2 Element from the 'Family' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Line As String

[PropertyBitValueAttribute()]
public string Line {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartSetup Class
CreatePartSetup Members


ModelNumber Property (CreatePartSetup) | fcSDK Documentation

ModelNumber Property (CreatePartSetup)

Model number of the part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ModelNumber As String

[PropertyBitValueAttribute()]
public string ModelNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartSetup Class
CreatePartSetup Members


Notes Property (CreatePartSetup) | fcSDK Documentation

Notes Property (CreatePartSetup)

Notes about the part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartSetup Class
CreatePartSetup Members


PartClass Property (CreatePartSetup) | fcSDK Documentation

PartClass Property (CreatePartSetup)

Part class for the part to create.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartClass As String

[PropertyBitValueAttribute()]
public string PartClass {get; set;}

Remarks

Only used by DE engine.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartSetup Class
CreatePartSetup Members


PartDomain Property (CreatePartSetup) | fcSDK Documentation

PartDomain Property (CreatePartSetup)

Domain for the part to create.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartDomain As String

[PropertyBitValueAttribute()]
public string PartDomain {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartSetup Class
CreatePartSetup Members


PartNumber Property (CreatePartSetup) | fcSDK Documentation

PartNumber Property (CreatePartSetup)

Part Number for the part to create.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartNumber As String

[PropertyBitValueAttribute()]
public string PartNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartSetup Class
CreatePartSetup Members


PartType Property (CreatePartSetup) | fcSDK Documentation

PartType Property (CreatePartSetup)

Element from the 'Part Type' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartType As String

[PropertyBitValueAttribute()]
public string PartType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartSetup Class
CreatePartSetup Members


RepairType Property (CreatePartSetup) | fcSDK Documentation

RepairType Property (CreatePartSetup)

Type of repair. One of "Repairable" or "Expendable"

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property RepairType As PartRepairType

[PropertyBitValueAttribute()]
public PartRepairType RepairType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartSetup Class
CreatePartSetup Members


UnitMeasure Property (CreatePartSetup) | fcSDK Documentation

UnitMeasure Property (CreatePartSetup)

Unit of measure for the part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UnitMeasure As String

[PropertyBitValueAttribute()]
public string UnitMeasure {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartSetup Class
CreatePartSetup Members


WarrantyDays Property (CreatePartSetup) | fcSDK Documentation

WarrantyDays Property (CreatePartSetup)

Number of warranty days for the part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WarrantyDays As Integer

[PropertyBitValueAttribute()]
public int WarrantyDays {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartSetup Class
CreatePartSetup Members


WarrantyStartOnShipment Property (CreatePartSetup) | fcSDK Documentation

WarrantyStartOnShipment Property (CreatePartSetup)

Does the warranty start on shipment?

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WarrantyStartOnShipment As Boolean

[PropertyBitValueAttribute()]
public bool WarrantyStartOnShipment {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartSetup Class
CreatePartSetup Members


Weight Property (CreatePartSetup) | fcSDK Documentation

Weight Property (CreatePartSetup)

Unit weight of the part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Weight As String

[PropertyBitValueAttribute()]
public string Weight {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartSetup Class
CreatePartSetup Members


CreatePriceInstanceSetup Class | fcSDK Documentation

CreatePriceInstanceSetup Class

Used by the CreatePriceInstance method as setup data for invocation.

Syntax

'Declaration

Public Class CreatePriceInstanceSetup

public class CreatePriceInstanceSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.CreatePriceInstanceSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreatePriceInstanceSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
CreatePriceInstance(CreatePriceInstanceSetup) Method


CreatePriceInstanceSetup Class Members | fcSDK Documentation

CreatePriceInstanceSetup Class Members

The following tables list the members exposed by CreatePriceInstanceSetup.

Public Constructors

 | Name | Description
Public Constructor | CreatePriceInstanceSetup Constructor | Initializes a new instance of the CreatePriceInstanceSetup class.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | EndDate | End date of the price instance, If not set, the end date of the price program is used. | | Public Property | PartDomain | Domain of the part | | Public Property | PartNumber | Part number to price

| | Public Property | PartRevision |

Revision to price

| | Public Property | Price | Price of the part | | Public Property | PricedQuantity | How many units in this price instance. | | Public Property | PriceProgram | Domain of the part | | Public Property | PriceType | The type of price being created. | | Public Property | StartDate | Start date of the price instance, If not set, the start date of the price program is used. |

Reference

CreatePriceInstanceSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
CreatePriceInstance(CreatePriceInstanceSetup) Method


CreatePriceInstanceSetup Constructor | fcSDK Documentation

CreatePriceInstanceSetup Constructor

Part number to price

Domain of the part

Revision to price

Domain of the part

The type of price being created.

How many units in this price instance.

Price of the part

Initializes a new instance of the CreatePriceInstanceSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partNumber_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _priceProgram_ As String, _
   ByVal _priceType_ As PriceInstanceType, _
   ByVal _pricedQuantity_ As Integer, _
   ByVal _price_ As Decimal _
)

[ConstructorIndexAttribute()]
public CreatePriceInstanceSetup(
   string _partNumber_,
   string _partDomain_,
   string _partRevision_,
   string _priceProgram_,
   PriceInstanceType _priceType_,
   int _pricedQuantity_,
   decimal _price_
)

Parameters

partNumber

Part number to price

patDomain

Domain of the part

partRevision

Revision to price

priceProgram

Domain of the part

priceType

The type of price being created.

pricedQuantity

How many units in this price instance.

price

Price of the part

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePriceInstanceSetup Class
CreatePriceInstanceSetup Members


EndDate Property (CreatePriceInstanceSetup) | fcSDK Documentation

EndDate Property (CreatePriceInstanceSetup)

End date of the price instance, If not set, the end date of the price program is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property EndDate As Date

[PropertyBitValueAttribute()]
public DateTime EndDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePriceInstanceSetup Class
CreatePriceInstanceSetup Members


PartDomain Property (CreatePriceInstanceSetup) | fcSDK Documentation

PartDomain Property (CreatePriceInstanceSetup)

Domain of the part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartDomain As String

[PropertyBitValueAttribute()]
public string PartDomain {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePriceInstanceSetup Class
CreatePriceInstanceSetup Members


PartNumber Property (CreatePriceInstanceSetup) | fcSDK Documentation

PartNumber Property (CreatePriceInstanceSetup)

Part number to price

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartNumber As String

[PropertyBitValueAttribute()]
public string PartNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePriceInstanceSetup Class
CreatePriceInstanceSetup Members


PartRevision Property (CreatePriceInstanceSetup) | fcSDK Documentation

PartRevision Property (CreatePriceInstanceSetup)

Revision to price

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRevision As String

[PropertyBitValueAttribute()]
public string PartRevision {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePriceInstanceSetup Class
CreatePriceInstanceSetup Members


Price Property (CreatePriceInstanceSetup) | fcSDK Documentation

Price Property (CreatePriceInstanceSetup)

Price of the part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Price As Decimal

[PropertyBitValueAttribute()]
public decimal Price {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePriceInstanceSetup Class
CreatePriceInstanceSetup Members


PricedQuantity Property (CreatePriceInstanceSetup) | fcSDK Documentation

PricedQuantity Property (CreatePriceInstanceSetup)

How many units in this price instance.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PricedQuantity As Integer

[PropertyBitValueAttribute()]
public int PricedQuantity {get; set;}

Remarks

Usually this value is 1

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePriceInstanceSetup Class
CreatePriceInstanceSetup Members


PriceProgram Property (CreatePriceInstanceSetup) | fcSDK Documentation

PriceProgram Property (CreatePriceInstanceSetup)

Domain of the part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PriceProgram As String

[PropertyBitValueAttribute()]
public string PriceProgram {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePriceInstanceSetup Class
CreatePriceInstanceSetup Members


PriceType Property (CreatePriceInstanceSetup) | fcSDK Documentation

PriceType Property (CreatePriceInstanceSetup)

The type of price being created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PriceType As PriceInstanceType

[PropertyBitValueAttribute()]
public PriceInstanceType PriceType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePriceInstanceSetup Class
CreatePriceInstanceSetup Members


StartDate Property (CreatePriceInstanceSetup) | fcSDK Documentation

StartDate Property (CreatePriceInstanceSetup)

Start date of the price instance, If not set, the start date of the price program is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property StartDate As Date

[PropertyBitValueAttribute()]
public DateTime StartDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePriceInstanceSetup Class
CreatePriceInstanceSetup Members


CreateProductBinSetup Class | fcSDK Documentation

CreateProductBinSetup Class

Used by the CreateProductBin method as setup data for invocation.

Syntax

'Declaration

Public Class CreateProductBinSetup

public class CreateProductBinSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.CreateProductBinSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateProductBinSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateProductBin(CreateProductBinSetup) Method


CreateProductBinSetup Class Members | fcSDK Documentation

CreateProductBinSetup Class Members

The following tables list the members exposed by CreateProductBinSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateProductBinSetup Constructor | Initializes a new instance of the CreateProductBinSetup class.

Public Properties

 | Name | Description
Public Property | BinName | Name of the bin to create
Public Property | CreateDate | Date the bin was created. If not set, the current time is used.
Public Property | Description | Bin description
Public Property | ParentBinObjid | Set this value if you wish the new Bin to be a child of this Parent Bin.
Public Property | PrimarySupportEmployeeObjid | Objid of the primary support Employee.
Public Property | SecondarySupportEmployeeObjid | Objid of the secondary support Employee.
Public Property | SiteIDNum | Identifier of the site where the bin is created
Public Property | UserName | User creating the bin. If not set, the default is the session user.

Reference

CreateProductBinSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateProductBin(CreateProductBinSetup) Method


CreateProductBinSetup Constructor | fcSDK Documentation

CreateProductBinSetup Constructor

Name of the bin to create

Identifier of the site where the bin is created

Initializes a new instance of the CreateProductBinSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _binName_ As String, _
   ByVal _siteIDNum_ As String _
)

[ConstructorIndexAttribute()]
public CreateProductBinSetup(
   string _binName_,
   string _siteIDNum_
)

Parameters

binName

Name of the bin to create

siteIDNum

Identifier of the site where the bin is created

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateProductBinSetup Class
CreateProductBinSetup Members


BinName Property (CreateProductBinSetup) | fcSDK Documentation

BinName Property (CreateProductBinSetup)

Name of the bin to create

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property BinName As String

[PropertyBitValueAttribute()]
public string BinName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateProductBinSetup Class
CreateProductBinSetup Members


CreateDate Property (CreateProductBinSetup) | fcSDK Documentation

CreateDate Property (CreateProductBinSetup)

Date the bin was created. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateProductBinSetup Class
CreateProductBinSetup Members


Description Property (CreateProductBinSetup) | fcSDK Documentation

Description Property (CreateProductBinSetup)

Bin description

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Description As String

[PropertyBitValueAttribute()]
public string Description {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateProductBinSetup Class
CreateProductBinSetup Members


ParentBinObjid Property (CreateProductBinSetup) | fcSDK Documentation

ParentBinObjid Property (CreateProductBinSetup)

Set this value if you wish the new Bin to be a child of this Parent Bin.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ParentBinObjid As Integer

[PropertyBitValueAttribute()]
public int ParentBinObjid {get; set;}

Remarks

The SiteIDNum of the parent bin must match the SiteIDNum of this bin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateProductBinSetup Class
CreateProductBinSetup Members


PrimarySupportEmployeeObjid Property (CreateProductBinSetup) | fcSDK Documentation

PrimarySupportEmployeeObjid Property (CreateProductBinSetup)

Objid of the primary support Employee.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PrimarySupportEmployeeObjid As Integer

[PropertyBitValueAttribute()]
public int PrimarySupportEmployeeObjid {get; set;}

Remarks

Note: this is an Employee not a User.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateProductBinSetup Class
CreateProductBinSetup Members


SecondarySupportEmployeeObjid Property (CreateProductBinSetup) | fcSDK Documentation

SecondarySupportEmployeeObjid Property (CreateProductBinSetup)

Objid of the secondary support Employee.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SecondarySupportEmployeeObjid As Integer

[PropertyBitValueAttribute()]
public int SecondarySupportEmployeeObjid {get; set;}

Remarks

Note: this is an Employee not a User.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateProductBinSetup Class
CreateProductBinSetup Members


SiteIDNum Property (CreateProductBinSetup) | fcSDK Documentation

SiteIDNum Property (CreateProductBinSetup)

Identifier of the site where the bin is created

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteIDNum As String

[PropertyBitValueAttribute()]
public string SiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateProductBinSetup Class
CreateProductBinSetup Members


UserName Property (CreateProductBinSetup) | fcSDK Documentation

UserName Property (CreateProductBinSetup)

User creating the bin. If not set, the default is the session user.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateProductBinSetup Class
CreateProductBinSetup Members


CreateQueueSetup Class | fcSDK Documentation

CreateQueueSetup Class

Used by the CreateQueue method as setup data for invocation.

Syntax

'Declaration

Public Class CreateQueueSetup

public class CreateQueueSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.CreateQueueSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateQueueSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateQueue(CreateQueueSetup) Method


CreateQueueSetup Class Members | fcSDK Documentation

CreateQueueSetup Class Members

The following tables list the members exposed by CreateQueueSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateQueueSetup Constructor | Initializes a new instance of the CreateQueueSetup class.

Public Properties

 | Name | Description
Public Property | AllowActionItem | Should Queue allow Action Items
Public Property | AllowCase | Should Queue allow Cases
Public Property | AllowContract | Should Queue allow Contracts
Public Property | AllowCR | Should Queue allow CRs
Public Property | AllowDemandDetail | Should Queue allow Demand Details
Public Property | AllowDialogue | Should Queue allow Dialogs
Public Property | AllowJob | Should Queue allow Jobs
Public Property | AllowOpportunity | Should Queue allow Opportunities
Public Property | AllowSolution | Should Queue allow Solutions
Public Property | AllowSubcase | Should Queue allow Subcases
Public Property | Description | Queue description
Public Property | IsPersonal | Is this a personal Queue?
Public Property | Supervisor | Username of the supervisor of the Queue
Public Property | Title | Title of the Queue

Reference

CreateQueueSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateQueue(CreateQueueSetup) Method


CreateQueueSetup Constructor | fcSDK Documentation

CreateQueueSetup Constructor

Title of the Queue

Should Queue allow CRs

Should Queue allow Cases

Should Queue allow Contracts

Should Queue allow Dialogs

Should Queue allow Demand Details

Should Queue allow Jobs

Should Queue allow Opportunities

Should Queue allow Solutions

Should Queue allow Subcases

Should Queue allow Action Items

Initializes a new instance of the CreateQueueSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _title_ As String, _
   ByVal _allowCR_ As Boolean, _
   ByVal _allowCase_ As Boolean, _
   ByVal _allowContract_ As Boolean, _
   ByVal _allowDialogue_ As Boolean, _
   ByVal _allowDemandDetail_ As Boolean, _
   ByVal _allowJob_ As Boolean, _
   ByVal _allowOpportunity_ As Boolean, _
   ByVal _allowSolution_ As Boolean, _
   ByVal _allowSubcase_ As Boolean, _
   ByVal _allowActionItem_ As Boolean _
)

[ConstructorIndexAttribute()]
public CreateQueueSetup(
   string _title_,
   bool _allowCR_,
   bool _allowCase_,
   bool _allowContract_,
   bool _allowDialogue_,
   bool _allowDemandDetail_,
   bool _allowJob_,
   bool _allowOpportunity_,
   bool _allowSolution_,
   bool _allowSubcase_,
   bool _allowActionItem_
)

Parameters

title

Title of the Queue

allowCR

Should Queue allow CRs

allowCase

Should Queue allow Cases

allowContract

Should Queue allow Contracts

allowDialogue

Should Queue allow Dialogs

allowDemandDetail

Should Queue allow Demand Details

allowJob

Should Queue allow Jobs

allowOpportunity

Should Queue allow Opportunities

allowSolution

Should Queue allow Solutions

allowSubcase

Should Queue allow Subcases

allowActionItem

Should Queue allow Action Items

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQueueSetup Class
CreateQueueSetup Members


AllowActionItem Property (CreateQueueSetup) | fcSDK Documentation

AllowActionItem Property (CreateQueueSetup)

Should Queue allow Action Items

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AllowActionItem As Boolean

[PropertyBitValueAttribute()]
public bool AllowActionItem {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQueueSetup Class
CreateQueueSetup Members


AllowCase Property (CreateQueueSetup) | fcSDK Documentation

AllowCase Property (CreateQueueSetup)

Should Queue allow Cases

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AllowCase As Boolean

[PropertyBitValueAttribute()]
public bool AllowCase {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQueueSetup Class
CreateQueueSetup Members


AllowContract Property (CreateQueueSetup) | fcSDK Documentation

AllowContract Property (CreateQueueSetup)

Should Queue allow Contracts

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AllowContract As Boolean

[PropertyBitValueAttribute()]
public bool AllowContract {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQueueSetup Class
CreateQueueSetup Members


AllowCR Property (CreateQueueSetup) | fcSDK Documentation

AllowCR Property (CreateQueueSetup)

Should Queue allow CRs

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AllowCR As Boolean

[PropertyBitValueAttribute()]
public bool AllowCR {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQueueSetup Class
CreateQueueSetup Members


AllowDemandDetail Property (CreateQueueSetup) | fcSDK Documentation

AllowDemandDetail Property (CreateQueueSetup)

Should Queue allow Demand Details

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AllowDemandDetail As Boolean

[PropertyBitValueAttribute()]
public bool AllowDemandDetail {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQueueSetup Class
CreateQueueSetup Members


AllowDialogue Property (CreateQueueSetup) | fcSDK Documentation

AllowDialogue Property (CreateQueueSetup)

Should Queue allow Dialogs

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AllowDialogue As Boolean

[PropertyBitValueAttribute()]
public bool AllowDialogue {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQueueSetup Class
CreateQueueSetup Members


AllowJob Property (CreateQueueSetup) | fcSDK Documentation

AllowJob Property (CreateQueueSetup)

Should Queue allow Jobs

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AllowJob As Boolean

[PropertyBitValueAttribute()]
public bool AllowJob {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQueueSetup Class
CreateQueueSetup Members


AllowOpportunity Property (CreateQueueSetup) | fcSDK Documentation

AllowOpportunity Property (CreateQueueSetup)

Should Queue allow Opportunities

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AllowOpportunity As Boolean

[PropertyBitValueAttribute()]
public bool AllowOpportunity {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQueueSetup Class
CreateQueueSetup Members


AllowSolution Property (CreateQueueSetup) | fcSDK Documentation

AllowSolution Property (CreateQueueSetup)

Should Queue allow Solutions

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AllowSolution As Boolean

[PropertyBitValueAttribute()]
public bool AllowSolution {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQueueSetup Class
CreateQueueSetup Members


AllowSubcase Property (CreateQueueSetup) | fcSDK Documentation

AllowSubcase Property (CreateQueueSetup)

Should Queue allow Subcases

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AllowSubcase As Boolean

[PropertyBitValueAttribute()]
public bool AllowSubcase {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQueueSetup Class
CreateQueueSetup Members


Description Property (CreateQueueSetup) | fcSDK Documentation

Description Property (CreateQueueSetup)

Queue description

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Description As String

[PropertyBitValueAttribute()]
public string Description {get; set;}

Remarks

If this property has not been set no change will occur. If the property is set, even to an empty string, that value reflected in the update.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQueueSetup Class
CreateQueueSetup Members


IsPersonal Property (CreateQueueSetup) | fcSDK Documentation

IsPersonal Property (CreateQueueSetup)

Is this a personal Queue?

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsPersonal As Boolean

[PropertyBitValueAttribute()]
public bool IsPersonal {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQueueSetup Class
CreateQueueSetup Members


Supervisor Property (CreateQueueSetup) | fcSDK Documentation

Supervisor Property (CreateQueueSetup)

Username of the supervisor of the Queue

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Supervisor As String

[PropertyBitValueAttribute()]
public string Supervisor {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQueueSetup Class
CreateQueueSetup Members


Title Property (CreateQueueSetup) | fcSDK Documentation

Title Property (CreateQueueSetup)

Title of the Queue

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Title As String

[PropertyBitValueAttribute()]
public string Title {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQueueSetup Class
CreateQueueSetup Members


CreateSiteSetup Class | fcSDK Documentation

CreateSiteSetup Class

Used by the CreateSite method as setup data for invocation.

Syntax

'Declaration

Public Class CreateSiteSetup

public class CreateSiteSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.CreateSiteSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateSiteSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateSite(CreateSiteSetup) Method


CreateSiteSetup Class Members | fcSDK Documentation

CreateSiteSetup Class Members

The following tables list the members exposed by CreateSiteSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateSiteSetup Constructor | Initializes a new instance of the CreateSiteSetup class.

Public Properties

 | Name | Description
Public Property | AccountIDNum | Identifier of the Account this site belongs to. If not set, the default Account is used.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | BillingAddressObjid | Billing Address of the site. If not set, the primary address is used.
Public Property | District | District of the Site
Public Property | IndustryType | Element from the 'Industry Type' user defined list. If not set, the default list value is used.
Public Property | ParentSiteIDNum | Identifier for the parent Site of the Site being created.
Public Property | PrimaryAddressObjid | Primary Address of the site
Public Property | PrimarySupportEmployeeObjid | Objid of the primary support Employee.
Public Property | PrimaryUse | Element from the 'Primary Use' user defined list. If not set, the default list value is used.
Public Property | Region | Region for the Site
Public Property | SecondarySupportEmployeeObjid | Objid of the secondary support Employee.
Public Property | ShippingAddressObjid | Shipping Address of the site. If not set, the primary address is used.
Public Property | SiteIDNum | Identifier for the site being created. If not set, a unique identifier will be created automatically.
Public Property | SiteName | Name of the Site
Public Property | SiteType | Type of the site
Public Property | Status | Site status
Public Property | SupportOfficeSiteIDNum | Identifier of the site where the support office is located

Reference

CreateSiteSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateSite(CreateSiteSetup) Method


CreateSiteSetup Constructor | fcSDK Documentation

CreateSiteSetup Constructor

Type of the site

Site status

Primary Address of the site

Initializes a new instance of the CreateSiteSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _siteType_ As SiteType, _
   ByVal _status_ As SiteStatus, _
   ByVal _primaryAddressObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public CreateSiteSetup(
   SiteType _siteType_,
   SiteStatus _status_,
   int _primaryAddressObjid_
)

Parameters

siteType

Type of the site

status

Site status

primaryAddressObjid

Primary Address of the site

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSiteSetup Class
CreateSiteSetup Members


AccountIDNum Property (CreateSiteSetup) | fcSDK Documentation

AccountIDNum Property (CreateSiteSetup)

Identifier of the Account this site belongs to. If not set, the default Account is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AccountIDNum As String

[PropertyBitValueAttribute()]
public string AccountIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSiteSetup Class
CreateSiteSetup Members


AdditionalFields Property (CreateSiteSetup) | fcSDK Documentation

AdditionalFields Property (CreateSiteSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSiteSetup Class
CreateSiteSetup Members


BillingAddressObjid Property (CreateSiteSetup) | fcSDK Documentation

BillingAddressObjid Property (CreateSiteSetup)

Billing Address of the site. If not set, the primary address is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property BillingAddressObjid As Integer

[PropertyBitValueAttribute()]
public int BillingAddressObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSiteSetup Class
CreateSiteSetup Members


District Property (CreateSiteSetup) | fcSDK Documentation

District Property (CreateSiteSetup)

District of the Site

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property District As String

[PropertyBitValueAttribute()]
public string District {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSiteSetup Class
CreateSiteSetup Members


IndustryType Property (CreateSiteSetup) | fcSDK Documentation

IndustryType Property (CreateSiteSetup)

Element from the 'Industry Type' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IndustryType As String

[PropertyBitValueAttribute()]
public string IndustryType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSiteSetup Class
CreateSiteSetup Members


ParentSiteIDNum Property (CreateSiteSetup) | fcSDK Documentation

ParentSiteIDNum Property (CreateSiteSetup)

Identifier for the parent Site of the Site being created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ParentSiteIDNum As String

[PropertyBitValueAttribute()]
public string ParentSiteIDNum {get; set;}

Remarks

If this property is set to an empty string the relation to the parent Site will be removed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSiteSetup Class
CreateSiteSetup Members


PrimaryAddressObjid Property (CreateSiteSetup) | fcSDK Documentation

PrimaryAddressObjid Property (CreateSiteSetup)

Primary Address of the site

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PrimaryAddressObjid As Integer

[PropertyBitValueAttribute()]
public int PrimaryAddressObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSiteSetup Class
CreateSiteSetup Members


PrimarySupportEmployeeObjid Property (CreateSiteSetup) | fcSDK Documentation

PrimarySupportEmployeeObjid Property (CreateSiteSetup)

Objid of the primary support Employee.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PrimarySupportEmployeeObjid As Integer

[PropertyBitValueAttribute()]
public int PrimarySupportEmployeeObjid {get; set;}

Remarks

If set to -2 the Employee is unrelated

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSiteSetup Class
CreateSiteSetup Members


PrimaryUse Property (CreateSiteSetup) | fcSDK Documentation

PrimaryUse Property (CreateSiteSetup)

Element from the 'Primary Use' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PrimaryUse As String

[PropertyBitValueAttribute()]
public string PrimaryUse {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSiteSetup Class
CreateSiteSetup Members


Region Property (CreateSiteSetup) | fcSDK Documentation

Region Property (CreateSiteSetup)

Region for the Site

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Region As String

[PropertyBitValueAttribute()]
public string Region {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSiteSetup Class
CreateSiteSetup Members


SecondarySupportEmployeeObjid Property (CreateSiteSetup) | fcSDK Documentation

SecondarySupportEmployeeObjid Property (CreateSiteSetup)

Objid of the secondary support Employee.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SecondarySupportEmployeeObjid As Integer

[PropertyBitValueAttribute()]
public int SecondarySupportEmployeeObjid {get; set;}

Remarks

If set to -2 the Employee is unrelated

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSiteSetup Class
CreateSiteSetup Members


ShippingAddressObjid Property (CreateSiteSetup) | fcSDK Documentation

ShippingAddressObjid Property (CreateSiteSetup)

Shipping Address of the site. If not set, the primary address is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ShippingAddressObjid As Integer

[PropertyBitValueAttribute()]
public int ShippingAddressObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSiteSetup Class
CreateSiteSetup Members


SiteIDNum Property (CreateSiteSetup) | fcSDK Documentation

SiteIDNum Property (CreateSiteSetup)

Identifier for the site being created. If not set, a unique identifier will be created automatically.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteIDNum As String

[PropertyBitValueAttribute()]
public string SiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSiteSetup Class
CreateSiteSetup Members


SiteName Property (CreateSiteSetup) | fcSDK Documentation

SiteName Property (CreateSiteSetup)

Name of the Site

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteName As String

[PropertyBitValueAttribute()]
public string SiteName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSiteSetup Class
CreateSiteSetup Members


SiteType Property (CreateSiteSetup) | fcSDK Documentation

SiteType Property (CreateSiteSetup)

Type of the site

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteType As SiteType

[PropertyBitValueAttribute()]
public SiteType SiteType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSiteSetup Class
CreateSiteSetup Members


Status Property (CreateSiteSetup) | fcSDK Documentation

Status Property (CreateSiteSetup)

Site status

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Status As SiteStatus

[PropertyBitValueAttribute()]
public SiteStatus Status {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSiteSetup Class
CreateSiteSetup Members


SupportOfficeSiteIDNum Property (CreateSiteSetup) | fcSDK Documentation

SupportOfficeSiteIDNum Property (CreateSiteSetup)

Identifier of the site where the support office is located

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SupportOfficeSiteIDNum As String

[PropertyBitValueAttribute()]
public string SupportOfficeSiteIDNum {get; set;}

Remarks

If this property is set to an empty string the relation to the support office Site will be removed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSiteSetup Class
CreateSiteSetup Members


CreateSolutionResult Class | fcSDK Documentation

CreateSolutionResult Class

Result from the CreateSolution API.

Syntax

'Declaration

Public Class CreateSolutionResult
   Inherits FChoice.Toolkits.Clarify.ToolkitResult

public class CreateSolutionResult : FChoice.Toolkits.Clarify.ToolkitResult

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.ToolkitResult
FChoice.Toolkits.Clarify.Interfaces.CreateSolutionResult

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateSolutionResult Members
FChoice.Toolkits.Clarify.Interfaces Namespace


CreateSolutionResult Class Members | fcSDK Documentation

CreateSolutionResult Class Members

The following tables list the members exposed by CreateSolutionResult.

Public Constructors

 | Name | Description
Public Constructor | CreateSolutionResult Constructor |

Public Properties

 | Name | Description
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | WorkaroundObjid | Objid of the Workaround that is created along with the Solution

Reference

CreateSolutionResult Class
FChoice.Toolkits.Clarify.Interfaces Namespace


CreateSolutionResult Constructor | fcSDK Documentation

CreateSolutionResult Constructor

Syntax

'Declaration

Public Function New()

public CreateSolutionResult()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSolutionResult Class
CreateSolutionResult Members


WorkaroundObjid Property (CreateSolutionResult) | fcSDK Documentation

WorkaroundObjid Property (CreateSolutionResult)

Objid of the Workaround that is created along with the Solution

Syntax

'Declaration

Public Property WorkaroundObjid As Integer

public int WorkaroundObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSolutionResult Class
CreateSolutionResult Members


CreateSolutionSetup Class | fcSDK Documentation

CreateSolutionSetup Class

Used by the CreateSolution method as setup data for invocation.

Syntax

'Declaration

Public Class CreateSolutionSetup

public class CreateSolutionSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.CreateSolutionSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateSolutionSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateSolution(CreateSolutionSetup) Method


CreateSolutionSetup Class Members | fcSDK Documentation

CreateSolutionSetup Class Members

The following tables list the members exposed by CreateSolutionSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateSolutionSetup Constructor | Initializes a new instance of the CreateSolutionSetup class.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CreateDate | DateTime the Solution was created. If not set, the current time is used.
Public Property | Description | The problem description of the Solution
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | IsPublic | Is the Solution public?
Public Property | Queue | Name of the Queue into which the Solution will be dispatched. If not set, the Solution is not dispatched.
Public Property | ResolutionCode | Element from the 'Resolution Code' application list. If not set, the default list value is used.
Public Property | Title | Title of the Solution
Public Property | UserName | User creating the Solution. If not set, the default is the session user.
Public Property | Workaround | Text of the first Workaround for the Solution.

Reference

CreateSolutionSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateSolution(CreateSolutionSetup) Method


CreateSolutionSetup Constructor | fcSDK Documentation

CreateSolutionSetup Constructor

Initializes a new instance of the CreateSolutionSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New()

[ConstructorIndexAttribute()]
public CreateSolutionSetup()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSolutionSetup Class
CreateSolutionSetup Members


AdditionalFields Property (CreateSolutionSetup) | fcSDK Documentation

AdditionalFields Property (CreateSolutionSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSolutionSetup Class
CreateSolutionSetup Members


CreateDate Property (CreateSolutionSetup) | fcSDK Documentation

CreateDate Property (CreateSolutionSetup)

DateTime the Solution was created. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSolutionSetup Class
CreateSolutionSetup Members


Description Property (CreateSolutionSetup) | fcSDK Documentation

Description Property (CreateSolutionSetup)

The problem description of the Solution

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Description As String

[PropertyBitValueAttribute()]
public string Description {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSolutionSetup Class
CreateSolutionSetup Members


GenerateTimeBombs Property (CreateSolutionSetup) | fcSDK Documentation

GenerateTimeBombs Property (CreateSolutionSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSolutionSetup Class
CreateSolutionSetup Members


IsPublic Property (CreateSolutionSetup) | fcSDK Documentation

IsPublic Property (CreateSolutionSetup)

Is the Solution public?

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsPublic As Boolean

[PropertyBitValueAttribute()]
public bool IsPublic {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSolutionSetup Class
CreateSolutionSetup Members


Queue Property (CreateSolutionSetup) | fcSDK Documentation

Queue Property (CreateSolutionSetup)

Name of the Queue into which the Solution will be dispatched. If not set, the Solution is not dispatched.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Queue As String

[PropertyBitValueAttribute()]
public string Queue {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSolutionSetup Class
CreateSolutionSetup Members


ResolutionCode Property (CreateSolutionSetup) | fcSDK Documentation

ResolutionCode Property (CreateSolutionSetup)

Element from the 'Resolution Code' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ResolutionCode As String

[PropertyBitValueAttribute()]
public string ResolutionCode {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSolutionSetup Class
CreateSolutionSetup Members


Title Property (CreateSolutionSetup) | fcSDK Documentation

Title Property (CreateSolutionSetup)

Title of the Solution

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Title As String

[PropertyBitValueAttribute()]
public string Title {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSolutionSetup Class
CreateSolutionSetup Members


UserName Property (CreateSolutionSetup) | fcSDK Documentation

UserName Property (CreateSolutionSetup)

User creating the Solution. If not set, the default is the session user.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSolutionSetup Class
CreateSolutionSetup Members


Workaround Property (CreateSolutionSetup) | fcSDK Documentation

Workaround Property (CreateSolutionSetup)

Text of the first Workaround for the Solution.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Workaround As String

[PropertyBitValueAttribute()]
public string Workaround {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSolutionSetup Class
CreateSolutionSetup Members


CreateStateSetup Class | fcSDK Documentation

CreateStateSetup Class

Used by the CreateState method as setup data for invocation.

Syntax

'Declaration

Public Class CreateStateSetup

public class CreateStateSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.CreateStateSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateStateSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateState(CreateStateSetup) Method


CreateStateSetup Class Members | fcSDK Documentation

CreateStateSetup Class Members

The following tables list the members exposed by CreateStateSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateStateSetup Constructor | Initializes a new instance of the CreateStateSetup class.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | Country | Name of the Country the State will belong to.

| | Public Property | FullName | Full name of the State | | Public Property | IsDefault | Is this the default State for the country? | | Public Property | State | State name |

Reference

CreateStateSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateState(CreateStateSetup) Method


CreateStateSetup Constructor | fcSDK Documentation

CreateStateSetup Constructor

State name

Full name of the State

Name of the Country the State will belong to.

Initializes a new instance of the CreateStateSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _state_ As String, _
   ByVal _fullName_ As String, _
   ByVal _country_ As String _
)

[ConstructorIndexAttribute()]
public CreateStateSetup(
   string _state_,
   string _fullName_,
   string _country_
)

Parameters

state

State name

fullName

Full name of the State

country

Name of the Country the State will belong to.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateStateSetup Class
CreateStateSetup Members


Country Property (CreateStateSetup) | fcSDK Documentation

Country Property (CreateStateSetup)

Name of the Country the State will belong to.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Country As String

[PropertyBitValueAttribute()]
public string Country {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateStateSetup Class
CreateStateSetup Members


FullName Property (CreateStateSetup) | fcSDK Documentation

FullName Property (CreateStateSetup)

Full name of the State

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FullName As String

[PropertyBitValueAttribute()]
public string FullName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateStateSetup Class
CreateStateSetup Members


IsDefault Property (CreateStateSetup) | fcSDK Documentation

IsDefault Property (CreateStateSetup)

Is this the default State for the country?

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsDefault As Boolean

[PropertyBitValueAttribute()]
public bool IsDefault {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateStateSetup Class
CreateStateSetup Members


State Property (CreateStateSetup) | fcSDK Documentation

State Property (CreateStateSetup)

State name

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property State As String

[PropertyBitValueAttribute()]
public string State {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateStateSetup Class
CreateStateSetup Members


CreateTimeZoneSetup Class | fcSDK Documentation

CreateTimeZoneSetup Class

Used by the CreateTimeZone method as setup data for invocation.

Syntax

'Declaration

Public Class CreateTimeZoneSetup

public class CreateTimeZoneSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.CreateTimeZoneSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateTimeZoneSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateTimeZone(CreateTimeZoneSetup) Method


CreateTimeZoneSetup Class Members | fcSDK Documentation

CreateTimeZoneSetup Class Members

The following tables list the members exposed by CreateTimeZoneSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateTimeZoneSetup Constructor | Initializes a new instance of the CreateTimeZoneSetup class.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | Country | Name of the Country the Timezone will belong to.

| | Public Property | FullName | Fullname of the Timezone | | Public Property | GMTDifference | Seconds between the Timezone being created and Greenwich Mean Time (GMT) | | Public Property | TimeZone | Timezone name |

Reference

CreateTimeZoneSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateTimeZone(CreateTimeZoneSetup) Method


CreateTimeZoneSetup Constructor | fcSDK Documentation

CreateTimeZoneSetup Constructor

Timezone name

Fullname of the Timezone

Name of the Country the Timezone will belong to.

Initializes a new instance of the CreateTimeZoneSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _timeZone_ As String, _
   ByVal _fullName_ As String, _
   ByVal _country_ As String _
)

[ConstructorIndexAttribute()]
public CreateTimeZoneSetup(
   string _timeZone_,
   string _fullName_,
   string _country_
)

Parameters

timeZone

Timezone name

fullName

Fullname of the Timezone

country

Name of the Country the Timezone will belong to.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateTimeZoneSetup Class
CreateTimeZoneSetup Members


Country Property (CreateTimeZoneSetup) | fcSDK Documentation

Country Property (CreateTimeZoneSetup)

Name of the Country the Timezone will belong to.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Country As String

[PropertyBitValueAttribute()]
public string Country {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateTimeZoneSetup Class
CreateTimeZoneSetup Members


FullName Property (CreateTimeZoneSetup) | fcSDK Documentation

FullName Property (CreateTimeZoneSetup)

Fullname of the Timezone

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FullName As String

[PropertyBitValueAttribute()]
public string FullName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateTimeZoneSetup Class
CreateTimeZoneSetup Members


GMTDifference Property | fcSDK Documentation

GMTDifference Property

Seconds between the Timezone being created and Greenwich Mean Time (GMT)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GMTDifference As Integer

[PropertyBitValueAttribute()]
public int GMTDifference {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateTimeZoneSetup Class
CreateTimeZoneSetup Members


TimeZone Property (CreateTimeZoneSetup) | fcSDK Documentation

TimeZone Property (CreateTimeZoneSetup)

Timezone name

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property TimeZone As String

[PropertyBitValueAttribute()]
public string TimeZone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateTimeZoneSetup Class
CreateTimeZoneSetup Members


CreateWipBinSetup Class | fcSDK Documentation

CreateWipBinSetup Class

Used by the CreateWipBin method as setup data for invocation.

Syntax

'Declaration

Public Class CreateWipBinSetup

public class CreateWipBinSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.CreateWipBinSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateWipBinSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateWipBin(CreateWipBinSetup) Method


CreateWipBinSetup Class Members | fcSDK Documentation

CreateWipBinSetup Class Members

The following tables list the members exposed by CreateWipBinSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateWipBinSetup Constructor | Initializes a new instance of the CreateWipBinSetup class.

Public Properties

 | Name | Description
Public Property | Description | WipBin description
Public Property | IsDefaultBin | Is the WipBin the user's default?
Public Property | Title | Title of the WipBin
Public Property | UserName | User the WipBin is being created for.

Reference

CreateWipBinSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateWipBin(CreateWipBinSetup) Method


CreateWipBinSetup Constructor | fcSDK Documentation

CreateWipBinSetup Constructor

Title of the WipBin

Initializes a new instance of the CreateWipBinSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _title_ As String _
)

[ConstructorIndexAttribute()]
public CreateWipBinSetup(
   string _title_
)

Parameters

title

Title of the WipBin

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateWipBinSetup Class
CreateWipBinSetup Members


Description Property (CreateWipBinSetup) | fcSDK Documentation

Description Property (CreateWipBinSetup)

WipBin description

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Description As String

[PropertyBitValueAttribute()]
public string Description {get; set;}

Remarks

If this property has not been set no change will occur. If the property is set, even to an empty string, that value reflected in the update.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateWipBinSetup Class
CreateWipBinSetup Members


IsDefaultBin Property (CreateWipBinSetup) | fcSDK Documentation

IsDefaultBin Property (CreateWipBinSetup)

Is the WipBin the user's default?

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsDefaultBin As Boolean

[PropertyBitValueAttribute()]
public bool IsDefaultBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateWipBinSetup Class
CreateWipBinSetup Members


Title Property (CreateWipBinSetup) | fcSDK Documentation

Title Property (CreateWipBinSetup)

Title of the WipBin

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Title As String

[PropertyBitValueAttribute()]
public string Title {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateWipBinSetup Class
CreateWipBinSetup Members


UserName Property (CreateWipBinSetup) | fcSDK Documentation

UserName Property (CreateWipBinSetup)

User the WipBin is being created for.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateWipBinSetup Class
CreateWipBinSetup Members


DeinstallSitePartSetup Class | fcSDK Documentation

DeinstallSitePartSetup Class

Used by the DeinstallSitePart method as setup data for invocation.

Syntax

'Declaration

Public Class DeinstallSitePartSetup

public class DeinstallSitePartSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.DeinstallSitePartSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

DeinstallSitePartSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
DeinstallSitePart(DeinstallSitePartSetup) Method


DeinstallSitePartSetup Class Members | fcSDK Documentation

DeinstallSitePartSetup Class Members

The following tables list the members exposed by DeinstallSitePartSetup.

Public Constructors

 | Name | Description
Public Constructor | DeinstallSitePartSetup Constructor | Initializes a new instance of the DeinstallSitePartSetup class.

Public Properties

 | Name | Description
Public Property | DeinstallDate | DateTime the Site Part was de-instaled
Public Property | SitePartObjid | ObjId of the Site Part to de-install
Public Property | UseRemove | Is this a remove (true) or de-Install (false) activity?
Public Property | UserName | User that performed the de-install.

Reference

DeinstallSitePartSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
DeinstallSitePart(DeinstallSitePartSetup) Method


DeinstallSitePartSetup Constructor | fcSDK Documentation

DeinstallSitePartSetup Constructor

ObjId of the Site Part to de-install

Initializes a new instance of the DeinstallSitePartSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _sitePartObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public DeinstallSitePartSetup(
   int _sitePartObjid_
)

Parameters

sitePartObjid

ObjId of the Site Part to de-install

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeinstallSitePartSetup Class
DeinstallSitePartSetup Members


DeinstallDate Property (DeinstallSitePartSetup) | fcSDK Documentation

DeinstallDate Property (DeinstallSitePartSetup)

DateTime the Site Part was de-instaled

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property DeinstallDate As Date

[PropertyBitValueAttribute()]
public DateTime DeinstallDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeinstallSitePartSetup Class
DeinstallSitePartSetup Members


SitePartObjid Property (DeinstallSitePartSetup) | fcSDK Documentation

SitePartObjid Property (DeinstallSitePartSetup)

ObjId of the Site Part to de-install

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SitePartObjid As Integer

[PropertyBitValueAttribute()]
public int SitePartObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeinstallSitePartSetup Class
DeinstallSitePartSetup Members


UseRemove Property (DeinstallSitePartSetup) | fcSDK Documentation

UseRemove Property (DeinstallSitePartSetup)

Is this a remove (true) or de-Install (false) activity?

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UseRemove As Boolean

[PropertyBitValueAttribute()]
public bool UseRemove {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeinstallSitePartSetup Class
DeinstallSitePartSetup Members


UserName Property (DeinstallSitePartSetup) | fcSDK Documentation

UserName Property (DeinstallSitePartSetup)

User that performed the de-install.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeinstallSitePartSetup Class
DeinstallSitePartSetup Members


DeleteProductBinSetup Class | fcSDK Documentation

DeleteProductBinSetup Class

Used by the DeleteProductBin method as setup data for invocation.

Syntax

'Declaration

Public Class DeleteProductBinSetup

public class DeleteProductBinSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.DeleteProductBinSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

DeleteProductBinSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
DeleteProductBin(DeleteProductBinSetup) Method


DeleteProductBinSetup Class Members | fcSDK Documentation

DeleteProductBinSetup Class Members

The following tables list the members exposed by DeleteProductBinSetup.

Public Constructors

 | Name | Description
Public Constructor | DeleteProductBinSetup Constructor | Initializes a new instance of the DeleteProductBinSetup class.

Public Properties

 | Name | Description
Public Property | BinObjid | Objid of the Bin to delete
Public Property | DeleteDate | DateTime the Bin was deleted. If not set, the current time is used.
Public Property | UserName | User who deleted the Bin. If not set, the session user is used.

Reference

DeleteProductBinSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
DeleteProductBin(DeleteProductBinSetup) Method


DeleteProductBinSetup Constructor | fcSDK Documentation

DeleteProductBinSetup Constructor

Objid of the Bin to delete

Initializes a new instance of the DeleteProductBinSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _binObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public DeleteProductBinSetup(
   int _binObjid_
)

Parameters

binObjid

Objid of the Bin to delete

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteProductBinSetup Class
DeleteProductBinSetup Members


BinObjid Property (DeleteProductBinSetup) | fcSDK Documentation

BinObjid Property (DeleteProductBinSetup)

Objid of the Bin to delete

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property BinObjid As Integer

[PropertyBitValueAttribute()]
public int BinObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteProductBinSetup Class
DeleteProductBinSetup Members


DeleteDate Property | fcSDK Documentation

DeleteDate Property

DateTime the Bin was deleted. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property DeleteDate As Date

[PropertyBitValueAttribute()]
public DateTime DeleteDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteProductBinSetup Class
DeleteProductBinSetup Members


UserName Property (DeleteProductBinSetup) | fcSDK Documentation

UserName Property (DeleteProductBinSetup)

User who deleted the Bin. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteProductBinSetup Class
DeleteProductBinSetup Members


DispatchSolutionSetup Class | fcSDK Documentation

DispatchSolutionSetup Class

Used by the DispatchSolution method as setup data for invocation.

Syntax

'Declaration

Public Class DispatchSolutionSetup

public class DispatchSolutionSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.DispatchSolutionSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

DispatchSolutionSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
DispatchSolution(DispatchSolutionSetup) Method


DispatchSolutionSetup Class Members | fcSDK Documentation

DispatchSolutionSetup Class Members

The following tables list the members exposed by DispatchSolutionSetup.

Public Constructors

 | Name | Description
Public Constructor | DispatchSolutionSetup Constructor | Initializes a new instance of the DispatchSolutionSetup class.

Public Properties

 | Name | Description
Public Property | DispatchDate | DateTime the Solution was dispatched. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Queue | The queue into which the Solution is to be dispatched.
Public Property | SolutionIDNum | Solution Identifier.
Public Property | UserName | The user who has dispatched the Solution. If not set, the Toolkit session user is used.

Reference

DispatchSolutionSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
DispatchSolution(DispatchSolutionSetup) Method


DispatchSolutionSetup Constructor | fcSDK Documentation

DispatchSolutionSetup Constructor

Solution Identifier.

The queue into which the Solution is to be dispatched.

Initializes a new instance of the DispatchSolutionSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _solutionIDNum_ As String, _
   ByVal _queue_ As String _
)

[ConstructorIndexAttribute()]
public DispatchSolutionSetup(
   string _solutionIDNum_,
   string _queue_
)

Parameters

solutionIDNum

Solution Identifier.

queue

The queue into which the Solution is to be dispatched.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchSolutionSetup Class
DispatchSolutionSetup Members


DispatchDate Property (DispatchSolutionSetup) | fcSDK Documentation

DispatchDate Property (DispatchSolutionSetup)

DateTime the Solution was dispatched. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property DispatchDate As Date

[PropertyBitValueAttribute()]
public DateTime DispatchDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchSolutionSetup Class
DispatchSolutionSetup Members


GenerateTimeBombs Property (DispatchSolutionSetup) | fcSDK Documentation

GenerateTimeBombs Property (DispatchSolutionSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchSolutionSetup Class
DispatchSolutionSetup Members


Queue Property (DispatchSolutionSetup) | fcSDK Documentation

Queue Property (DispatchSolutionSetup)

The queue into which the Solution is to be dispatched.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Queue As String

[PropertyBitValueAttribute()]
public string Queue {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchSolutionSetup Class
DispatchSolutionSetup Members


SolutionIDNum Property (DispatchSolutionSetup) | fcSDK Documentation

SolutionIDNum Property (DispatchSolutionSetup)

Solution Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SolutionIDNum As String

[PropertyBitValueAttribute()]
public string SolutionIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchSolutionSetup Class
DispatchSolutionSetup Members


UserName Property (DispatchSolutionSetup) | fcSDK Documentation

UserName Property (DispatchSolutionSetup)

The user who has dispatched the Solution. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchSolutionSetup Class
DispatchSolutionSetup Members


ForwardSolutionSetup Class | fcSDK Documentation

ForwardSolutionSetup Class

Used by the ForwardSolution method as setup data for invocation.

Syntax

'Declaration

Public Class ForwardSolutionSetup

public class ForwardSolutionSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.ForwardSolutionSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ForwardSolutionSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
ForwardSolution(ForwardSolutionSetup) Method


ForwardSolutionSetup Class Members | fcSDK Documentation

ForwardSolutionSetup Class Members

The following tables list the members exposed by ForwardSolutionSetup.

Public Constructors

 | Name | Description
Public Constructor | ForwardSolutionSetup Constructor | Initializes a new instance of the ForwardSolutionSetup class.

Public Properties

 | Name | Description
Public Property | ForwardDate | DateTime the Solution was forwarded. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewQueue | The new queue into which the Solution is to be forwarded.
Public Property | Notes | The reason the Solution was rejected from the queue into which it was dispatched.
Public Property | SolutionIDNum | Solution Identifier.
Public Property | UserName | The user who has forwarded the Solution. If not set, the Toolkit session user is used.

Reference

ForwardSolutionSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
ForwardSolution(ForwardSolutionSetup) Method


ForwardSolutionSetup Constructor | fcSDK Documentation

ForwardSolutionSetup Constructor

Solution Identifier.

The new queue into which the Solution is to be forwarded.

Initializes a new instance of the ForwardSolutionSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _solutionIDNum_ As String, _
   ByVal _newQueue_ As String _
)

[ConstructorIndexAttribute()]
public ForwardSolutionSetup(
   string _solutionIDNum_,
   string _newQueue_
)

Parameters

solutionIDNum

Solution Identifier.

newQueue

The new queue into which the Solution is to be forwarded.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardSolutionSetup Class
ForwardSolutionSetup Members


ForwardDate Property (ForwardSolutionSetup) | fcSDK Documentation

ForwardDate Property (ForwardSolutionSetup)

DateTime the Solution was forwarded. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ForwardDate As Date

[PropertyBitValueAttribute()]
public DateTime ForwardDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardSolutionSetup Class
ForwardSolutionSetup Members


GenerateTimeBombs Property (ForwardSolutionSetup) | fcSDK Documentation

GenerateTimeBombs Property (ForwardSolutionSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardSolutionSetup Class
ForwardSolutionSetup Members


NewQueue Property (ForwardSolutionSetup) | fcSDK Documentation

NewQueue Property (ForwardSolutionSetup)

The new queue into which the Solution is to be forwarded.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewQueue As String

[PropertyBitValueAttribute()]
public string NewQueue {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardSolutionSetup Class
ForwardSolutionSetup Members


Notes Property (ForwardSolutionSetup) | fcSDK Documentation

Notes Property (ForwardSolutionSetup)

The reason the Solution was rejected from the queue into which it was dispatched.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardSolutionSetup Class
ForwardSolutionSetup Members


SolutionIDNum Property (ForwardSolutionSetup) | fcSDK Documentation

SolutionIDNum Property (ForwardSolutionSetup)

Solution Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SolutionIDNum As String

[PropertyBitValueAttribute()]
public string SolutionIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardSolutionSetup Class
ForwardSolutionSetup Members


UserName Property (ForwardSolutionSetup) | fcSDK Documentation

UserName Property (ForwardSolutionSetup)

The user who has forwarded the Solution. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardSolutionSetup Class
ForwardSolutionSetup Members


InstallSitePartToBinSetup Class | fcSDK Documentation

InstallSitePartToBinSetup Class

Used by the InstallSitePartToBin method as setup data for invocation.

Syntax

'Declaration

Public Class InstallSitePartToBinSetup

public class InstallSitePartToBinSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.InstallSitePartToBinSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

InstallSitePartToBinSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
InstallSitePartToBin(InstallSitePartToBinSetup) Method


InstallSitePartToBinSetup Class Members | fcSDK Documentation

InstallSitePartToBinSetup Class Members

The following tables list the members exposed by InstallSitePartToBinSetup.

Public Constructors

 | Name | Description
Public Constructor | InstallSitePartToBinSetup Constructor | Overloaded.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AddActivityLog | Should an activity log be created? | | Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation. | | Public Property | Comments | Comment for the Site Part installation | | Public Property | InstallDate | DateTime the Site Part was installed. If not set, the current time is used. | | Public Property | InstanceName | The instance name for the Site Part. | | Public Property | InvoiceNumber | Invoice number | | Public Property | ParentBinObjid | Objid of the parent Bin this Part will be installed under | | Public Property | PartDomain | Domain of the part to install | | Public Property | PartNumber | Part Number of the part to install | | Public Property | PartRevision | Part Revision of the part to install | | Public Property | PartStatus | Element from the 'Part_Status' user defined list. If not set, the default list value is used. | | Public Property | Quantity | The number of units to install | | Public Property | SerialNumber | Serial number of the part installed | | Public Property | ShipDate | DateTime the part was shipped. If not set, the | | Public Property | SiteIDNum | Identifier of the Site where the part will be installed.

| | Public Property | UserName | User who performed the install. If not set, the session user is used. |

Reference

InstallSitePartToBinSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
InstallSitePartToBin(InstallSitePartToBinSetup) Method


InstallSitePartToBinSetup Constructor | fcSDK Documentation

InstallSitePartToBinSetup Constructor

Initializes a new instance of the InstallSitePartToBinSetup class.

Overload List

Overload | Description
InstallSitePartToBinSetup Constructor(String,Int32,String,String,String,Int32) | Initializes a new instance of the InstallSitePartToBinSetup class. This overload takes a set of required parameters for the API.
InstallSitePartToBinSetup Constructor(String,String,String,String,String) | Initializes a new instance of the InstallSitePartToBinSetup class. This overload takes a set of required parameters for the API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToBinSetup Class
InstallSitePartToBinSetup Members


InstallSitePartToBinSetup Constructor(String,Int32,String,String,String,Int32) | fcSDK Documentation

InstallSitePartToBinSetup Constructor(String,Int32,String,String,String,Int32)

Identifier of the Site where the part will be installed.

Objid of the parent Bin this Part will be installed under

Part Number of the part to install

Part Revision of the part to install

Domain of the part to install

The number of units to install

Initializes a new instance of the InstallSitePartToBinSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _siteIDNum_ As String, _
   ByVal _parentBinObjid_ As Integer, _
   ByVal _partNumber_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _quantity_ As Integer _
)

[ConstructorIndexAttribute()]
public InstallSitePartToBinSetup(
   string _siteIDNum_,
   int _parentBinObjid_,
   string _partNumber_,
   string _partRevision_,
   string _partDomain_,
   int _quantity_
)

Parameters

siteIDNum

Identifier of the Site where the part will be installed.

parentBinObjid

Objid of the parent Bin this Part will be installed under

partNumber

Part Number of the part to install

partRevision

Part Revision of the part to install

partDomain

Domain of the part to install

quantity

The number of units to install

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToBinSetup Class
InstallSitePartToBinSetup Members
Overload List


InstallSitePartToBinSetup Constructor(String,String,String,String,String) | fcSDK Documentation

InstallSitePartToBinSetup Constructor(String,String,String,String,String)

Identifier of the Site where the part will be installed.

Part Number of the part to install

Part Revision of the part to install

Domain of the part to install

Serial number of the part installed

Initializes a new instance of the InstallSitePartToBinSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _siteIDNum_ As String, _
   ByVal _partNumber_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _serialNumber_ As String _
)

[ConstructorIndexAttribute()]
public InstallSitePartToBinSetup(
   string _siteIDNum_,
   string _partNumber_,
   string _partRevision_,
   string _partDomain_,
   string _serialNumber_
)

Parameters

siteIDNum

Identifier of the Site where the part will be installed.

partNumber

Part Number of the part to install

partRevision

Part Revision of the part to install

partDomain

Domain of the part to install

serialNumber

Serial number of the part installed

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToBinSetup Class
InstallSitePartToBinSetup Members
Overload List


AddActivityLog Property (InstallSitePartToBinSetup) | fcSDK Documentation

AddActivityLog Property (InstallSitePartToBinSetup)

Should an activity log be created?

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AddActivityLog As Boolean

[PropertyBitValueAttribute()]
public bool AddActivityLog {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToBinSetup Class
InstallSitePartToBinSetup Members


AdditionalFields Property (InstallSitePartToBinSetup) | fcSDK Documentation

AdditionalFields Property (InstallSitePartToBinSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToBinSetup Class
InstallSitePartToBinSetup Members


Comments Property (InstallSitePartToBinSetup) | fcSDK Documentation

Comments Property (InstallSitePartToBinSetup)

Comment for the Site Part installation

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Comments As String

[PropertyBitValueAttribute()]
public string Comments {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToBinSetup Class
InstallSitePartToBinSetup Members


InstallDate Property (InstallSitePartToBinSetup) | fcSDK Documentation

InstallDate Property (InstallSitePartToBinSetup)

DateTime the Site Part was installed. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallDate As Date

[PropertyBitValueAttribute()]
public DateTime InstallDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToBinSetup Class
InstallSitePartToBinSetup Members


InstanceName Property (InstallSitePartToBinSetup) | fcSDK Documentation

InstanceName Property (InstallSitePartToBinSetup)

The instance name for the Site Part.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstanceName As String

[PropertyBitValueAttribute()]
public string InstanceName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToBinSetup Class
InstallSitePartToBinSetup Members


InvoiceNumber Property (InstallSitePartToBinSetup) | fcSDK Documentation

InvoiceNumber Property (InstallSitePartToBinSetup)

Invoice number

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InvoiceNumber As String

[PropertyBitValueAttribute()]
public string InvoiceNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToBinSetup Class
InstallSitePartToBinSetup Members


ParentBinObjid Property (InstallSitePartToBinSetup) | fcSDK Documentation

ParentBinObjid Property (InstallSitePartToBinSetup)

Objid of the parent Bin this Part will be installed under

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ParentBinObjid As Integer

[PropertyBitValueAttribute()]
public int ParentBinObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToBinSetup Class
InstallSitePartToBinSetup Members


PartDomain Property (InstallSitePartToBinSetup) | fcSDK Documentation

PartDomain Property (InstallSitePartToBinSetup)

Domain of the part to install

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartDomain As String

[PropertyBitValueAttribute()]
public string PartDomain {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToBinSetup Class
InstallSitePartToBinSetup Members


PartNumber Property (InstallSitePartToBinSetup) | fcSDK Documentation

PartNumber Property (InstallSitePartToBinSetup)

Part Number of the part to install

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartNumber As String

[PropertyBitValueAttribute()]
public string PartNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToBinSetup Class
InstallSitePartToBinSetup Members


PartRevision Property (InstallSitePartToBinSetup) | fcSDK Documentation

PartRevision Property (InstallSitePartToBinSetup)

Part Revision of the part to install

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRevision As String

[PropertyBitValueAttribute()]
public string PartRevision {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToBinSetup Class
InstallSitePartToBinSetup Members


PartStatus Property (InstallSitePartToBinSetup) | fcSDK Documentation

PartStatus Property (InstallSitePartToBinSetup)

Element from the 'Part_Status' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartStatus As String

[PropertyBitValueAttribute()]
public string PartStatus {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToBinSetup Class
InstallSitePartToBinSetup Members


Quantity Property (InstallSitePartToBinSetup) | fcSDK Documentation

Quantity Property (InstallSitePartToBinSetup)

The number of units to install

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Quantity As Integer

[PropertyBitValueAttribute()]
public int Quantity {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToBinSetup Class
InstallSitePartToBinSetup Members


SerialNumber Property (InstallSitePartToBinSetup) | fcSDK Documentation

SerialNumber Property (InstallSitePartToBinSetup)

Serial number of the part installed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SerialNumber As String

[PropertyBitValueAttribute()]
public string SerialNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToBinSetup Class
InstallSitePartToBinSetup Members


ShipDate Property (InstallSitePartToBinSetup) | fcSDK Documentation

ShipDate Property (InstallSitePartToBinSetup)

DateTime the part was shipped. If not set, the

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ShipDate As Date

[PropertyBitValueAttribute()]
public DateTime ShipDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToBinSetup Class
InstallSitePartToBinSetup Members


SiteIDNum Property (InstallSitePartToBinSetup) | fcSDK Documentation

SiteIDNum Property (InstallSitePartToBinSetup)

Identifier of the Site where the part will be installed.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteIDNum As String

[PropertyBitValueAttribute()]
public string SiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToBinSetup Class
InstallSitePartToBinSetup Members


UserName Property (InstallSitePartToBinSetup) | fcSDK Documentation

UserName Property (InstallSitePartToBinSetup)

User who performed the install. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToBinSetup Class
InstallSitePartToBinSetup Members


InstallSitePartToPartSetup Class | fcSDK Documentation

InstallSitePartToPartSetup Class

Used by the InstallSitePartToPart method as setup data for invocation.

Syntax

'Declaration

Public Class InstallSitePartToPartSetup

public class InstallSitePartToPartSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.InstallSitePartToPartSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

InstallSitePartToPartSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
InstallSitePartToPart(InstallSitePartToPartSetup) Method


InstallSitePartToPartSetup Class Members | fcSDK Documentation

InstallSitePartToPartSetup Class Members

The following tables list the members exposed by InstallSitePartToPartSetup.

Public Constructors

 | Name | Description
Public Constructor | InstallSitePartToPartSetup Constructor | Overloaded.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AddActivityLog | Should an activity log be created? | | Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation. | | Public Property | Comments | Comment for the Site Part installation | | Public Property | InstallDate | DateTime the Site Part was installed. If not set, the current time is used. | | Public Property | InstanceName | The instance name for the Site Part. | | Public Property | InvoiceNumber | Invoice number | | Public Property | ParentSitePartObjid | Objid of the parent Site Part this Part will be installed under. | | Public Property | PartDomain | Domain of the part to install | | Public Property | PartNumber | Part Number of the part to install | | Public Property | PartRevision | Part Revision of the part to install | | Public Property | PartStatus | Element from the 'Part_Status' user defined list. If not set, the default list value is used. | | Public Property | Quantity | The number of units to install | | Public Property | SerialNumber | Serial number of the part installed | | Public Property | ShipDate | DateTime the part was shipped. If not set, the | | Public Property | SiteIDNum | Identifier of the Site where the part will be installed.

| | Public Property | UserName | User who performed the install. If not set, the session user is used. |

Reference

InstallSitePartToPartSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
InstallSitePartToPart(InstallSitePartToPartSetup) Method


InstallSitePartToPartSetup Constructor | fcSDK Documentation

InstallSitePartToPartSetup Constructor

Initializes a new instance of the InstallSitePartToPartSetup class.

Overload List

Overload | Description
InstallSitePartToPartSetup Constructor(String,Int32,String,String,String,Int32) | Initializes a new instance of the InstallSitePartToPartSetup class. This overload takes a set of required parameters for the API.
InstallSitePartToPartSetup Constructor(String,String,String,String,String) | Initializes a new instance of the InstallSitePartToPartSetup class. This overload takes a set of required parameters for the API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToPartSetup Class
InstallSitePartToPartSetup Members


InstallSitePartToPartSetup Constructor(String,Int32,String,String,String,Int32) | fcSDK Documentation

InstallSitePartToPartSetup Constructor(String,Int32,String,String,String,Int32)

Identifier of the Site where the part will be installed.

Objid of the parent Site Part this Part will be installed under.

Part Number of the part to install

Part Revision of the part to install

Domain of the part to install

The number of units to install

Initializes a new instance of the InstallSitePartToPartSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _siteIDNum_ As String, _
   ByVal _parentSitePartObjid_ As Integer, _
   ByVal _partNumber_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _quantity_ As Integer _
)

[ConstructorIndexAttribute()]
public InstallSitePartToPartSetup(
   string _siteIDNum_,
   int _parentSitePartObjid_,
   string _partNumber_,
   string _partRevision_,
   string _partDomain_,
   int _quantity_
)

Parameters

siteIDNum

Identifier of the Site where the part will be installed.

parentSitePartObjid

Objid of the parent Site Part this Part will be installed under.

partNumber

Part Number of the part to install

partRevision

Part Revision of the part to install

partDomain

Domain of the part to install

quantity

The number of units to install

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToPartSetup Class
InstallSitePartToPartSetup Members
Overload List


InstallSitePartToPartSetup Constructor(String,String,String,String,String) | fcSDK Documentation

InstallSitePartToPartSetup Constructor(String,String,String,String,String)

Identifier of the Site where the part will be installed.

Part Number of the part to install

Part Revision of the part to install

Domain of the part to install

Serial number of the part installed

Initializes a new instance of the InstallSitePartToPartSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _siteIDNum_ As String, _
   ByVal _partNumber_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _serialNumber_ As String _
)

[ConstructorIndexAttribute()]
public InstallSitePartToPartSetup(
   string _siteIDNum_,
   string _partNumber_,
   string _partRevision_,
   string _partDomain_,
   string _serialNumber_
)

Parameters

siteIDNum

Identifier of the Site where the part will be installed.

partNumber

Part Number of the part to install

partRevision

Part Revision of the part to install

partDomain

Domain of the part to install

serialNumber

Serial number of the part installed

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToPartSetup Class
InstallSitePartToPartSetup Members
Overload List


AddActivityLog Property (InstallSitePartToPartSetup) | fcSDK Documentation

AddActivityLog Property (InstallSitePartToPartSetup)

Should an activity log be created?

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AddActivityLog As Boolean

[PropertyBitValueAttribute()]
public bool AddActivityLog {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToPartSetup Class
InstallSitePartToPartSetup Members


AdditionalFields Property (InstallSitePartToPartSetup) | fcSDK Documentation

AdditionalFields Property (InstallSitePartToPartSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToPartSetup Class
InstallSitePartToPartSetup Members


Comments Property (InstallSitePartToPartSetup) | fcSDK Documentation

Comments Property (InstallSitePartToPartSetup)

Comment for the Site Part installation

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Comments As String

[PropertyBitValueAttribute()]
public string Comments {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToPartSetup Class
InstallSitePartToPartSetup Members


InstallDate Property (InstallSitePartToPartSetup) | fcSDK Documentation

InstallDate Property (InstallSitePartToPartSetup)

DateTime the Site Part was installed. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallDate As Date

[PropertyBitValueAttribute()]
public DateTime InstallDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToPartSetup Class
InstallSitePartToPartSetup Members


InstanceName Property (InstallSitePartToPartSetup) | fcSDK Documentation

InstanceName Property (InstallSitePartToPartSetup)

The instance name for the Site Part.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstanceName As String

[PropertyBitValueAttribute()]
public string InstanceName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToPartSetup Class
InstallSitePartToPartSetup Members


InvoiceNumber Property (InstallSitePartToPartSetup) | fcSDK Documentation

InvoiceNumber Property (InstallSitePartToPartSetup)

Invoice number

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InvoiceNumber As String

[PropertyBitValueAttribute()]
public string InvoiceNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToPartSetup Class
InstallSitePartToPartSetup Members


ParentSitePartObjid Property (InstallSitePartToPartSetup) | fcSDK Documentation

ParentSitePartObjid Property (InstallSitePartToPartSetup)

Objid of the parent Site Part this Part will be installed under.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ParentSitePartObjid As Integer

[PropertyBitValueAttribute()]
public int ParentSitePartObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToPartSetup Class
InstallSitePartToPartSetup Members


PartDomain Property (InstallSitePartToPartSetup) | fcSDK Documentation

PartDomain Property (InstallSitePartToPartSetup)

Domain of the part to install

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartDomain As String

[PropertyBitValueAttribute()]
public string PartDomain {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToPartSetup Class
InstallSitePartToPartSetup Members


PartNumber Property (InstallSitePartToPartSetup) | fcSDK Documentation

PartNumber Property (InstallSitePartToPartSetup)

Part Number of the part to install

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartNumber As String

[PropertyBitValueAttribute()]
public string PartNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToPartSetup Class
InstallSitePartToPartSetup Members


PartRevision Property (InstallSitePartToPartSetup) | fcSDK Documentation

PartRevision Property (InstallSitePartToPartSetup)

Part Revision of the part to install

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRevision As String

[PropertyBitValueAttribute()]
public string PartRevision {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToPartSetup Class
InstallSitePartToPartSetup Members


PartStatus Property (InstallSitePartToPartSetup) | fcSDK Documentation

PartStatus Property (InstallSitePartToPartSetup)

Element from the 'Part_Status' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartStatus As String

[PropertyBitValueAttribute()]
public string PartStatus {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToPartSetup Class
InstallSitePartToPartSetup Members


Quantity Property (InstallSitePartToPartSetup) | fcSDK Documentation

Quantity Property (InstallSitePartToPartSetup)

The number of units to install

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Quantity As Integer

[PropertyBitValueAttribute()]
public int Quantity {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToPartSetup Class
InstallSitePartToPartSetup Members


SerialNumber Property (InstallSitePartToPartSetup) | fcSDK Documentation

SerialNumber Property (InstallSitePartToPartSetup)

Serial number of the part installed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SerialNumber As String

[PropertyBitValueAttribute()]
public string SerialNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToPartSetup Class
InstallSitePartToPartSetup Members


ShipDate Property (InstallSitePartToPartSetup) | fcSDK Documentation

ShipDate Property (InstallSitePartToPartSetup)

DateTime the part was shipped. If not set, the

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ShipDate As Date

[PropertyBitValueAttribute()]
public DateTime ShipDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToPartSetup Class
InstallSitePartToPartSetup Members


SiteIDNum Property (InstallSitePartToPartSetup) | fcSDK Documentation

SiteIDNum Property (InstallSitePartToPartSetup)

Identifier of the Site where the part will be installed.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteIDNum As String

[PropertyBitValueAttribute()]
public string SiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToPartSetup Class
InstallSitePartToPartSetup Members


UserName Property (InstallSitePartToPartSetup) | fcSDK Documentation

UserName Property (InstallSitePartToPartSetup)

User who performed the install. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToPartSetup Class
InstallSitePartToPartSetup Members


InstallSitePartToSiteSetup Class | fcSDK Documentation

InstallSitePartToSiteSetup Class

Used by the InstallSitePartToSite method as setup data for invocation.

Syntax

'Declaration

Public Class InstallSitePartToSiteSetup

public class InstallSitePartToSiteSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.InstallSitePartToSiteSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

InstallSitePartToSiteSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
InstallSitePartToSite(InstallSitePartToSiteSetup) Method


InstallSitePartToSiteSetup Class Members | fcSDK Documentation

InstallSitePartToSiteSetup Class Members

The following tables list the members exposed by InstallSitePartToSiteSetup.

Public Constructors

 | Name | Description
Public Constructor | InstallSitePartToSiteSetup Constructor | Overloaded.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AddActivityLog | Should an activity log be created? | | Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation. | | Public Property | Comments | Comment for the Site Part installation | | Public Property | InstallDate | DateTime the Site Part was installed. If not set, the current time is used. | | Public Property | InstanceName | The instance name for the Site Part. | | Public Property | InvoiceNumber | Invoice number | | Public Property | PartDomain | Domain of the part to install | | Public Property | PartNumber | Part Number of the part to install | | Public Property | PartRevision | Part Revision of the part to install | | Public Property | PartStatus | Element from the 'Part_Status' user defined list. If not set, the default list value is used. | | Public Property | Quantity | The number of units to install | | Public Property | SerialNumber | Serial number of the part installed | | Public Property | ShipDate | DateTime the part was shipped. If not set, the current time is used. | | Public Property | SiteIDNum | Identifier of the Site where the part will be installed.

| | Public Property | UserName | User who performed the install. If not set, the session user is used. |

Reference

InstallSitePartToSiteSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
InstallSitePartToSite(InstallSitePartToSiteSetup) Method


InstallSitePartToSiteSetup Constructor | fcSDK Documentation

InstallSitePartToSiteSetup Constructor

Initializes a new instance of the InstallSitePartToSiteSetup class.

Overload List

Overload | Description
InstallSitePartToSiteSetup Constructor(String,String,String,String,Int32) | Initializes a new instance of the InstallSitePartToSiteSetup class. This overload takes a set of required parameters for the API.
InstallSitePartToSiteSetup Constructor(String,String,String,String,String) | Initializes a new instance of the InstallSitePartToSiteSetup class. This overload takes a set of required parameters for the API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToSiteSetup Class
InstallSitePartToSiteSetup Members


InstallSitePartToSiteSetup Constructor(String,String,String,String,Int32) | fcSDK Documentation

InstallSitePartToSiteSetup Constructor(String,String,String,String,Int32)

Identifier of the Site where the part will be installed.

Part Number of the part to install

Part Revision of the part to install

Domain of the part to install

The number of units to install

Initializes a new instance of the InstallSitePartToSiteSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _siteIDNum_ As String, _
   ByVal _partNumber_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _quantity_ As Integer _
)

[ConstructorIndexAttribute()]
public InstallSitePartToSiteSetup(
   string _siteIDNum_,
   string _partNumber_,
   string _partRevision_,
   string _partDomain_,
   int _quantity_
)

Parameters

siteIDNum

Identifier of the Site where the part will be installed.

partNumber

Part Number of the part to install

partRevision

Part Revision of the part to install

partDomain

Domain of the part to install

quantity

The number of units to install

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToSiteSetup Class
InstallSitePartToSiteSetup Members
Overload List


InstallSitePartToSiteSetup Constructor(String,String,String,String,String) | fcSDK Documentation

InstallSitePartToSiteSetup Constructor(String,String,String,String,String)

Identifier of the Site where the part will be installed.

Part Number of the part to install

Part Revision of the part to install

Domain of the part to install

Serial number of the part installed

Initializes a new instance of the InstallSitePartToSiteSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _siteIDNum_ As String, _
   ByVal _partNumber_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _serialNumber_ As String _
)

[ConstructorIndexAttribute()]
public InstallSitePartToSiteSetup(
   string _siteIDNum_,
   string _partNumber_,
   string _partRevision_,
   string _partDomain_,
   string _serialNumber_
)

Parameters

siteIDNum

Identifier of the Site where the part will be installed.

partNumber

Part Number of the part to install

partRevision

Part Revision of the part to install

partDomain

Domain of the part to install

serialNumber

Serial number of the part installed

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToSiteSetup Class
InstallSitePartToSiteSetup Members
Overload List


AddActivityLog Property (InstallSitePartToSiteSetup) | fcSDK Documentation

AddActivityLog Property (InstallSitePartToSiteSetup)

Should an activity log be created?

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AddActivityLog As Boolean

[PropertyBitValueAttribute()]
public bool AddActivityLog {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToSiteSetup Class
InstallSitePartToSiteSetup Members


AdditionalFields Property (InstallSitePartToSiteSetup) | fcSDK Documentation

AdditionalFields Property (InstallSitePartToSiteSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToSiteSetup Class
InstallSitePartToSiteSetup Members


Comments Property (InstallSitePartToSiteSetup) | fcSDK Documentation

Comments Property (InstallSitePartToSiteSetup)

Comment for the Site Part installation

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Comments As String

[PropertyBitValueAttribute()]
public string Comments {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToSiteSetup Class
InstallSitePartToSiteSetup Members


InstallDate Property (InstallSitePartToSiteSetup) | fcSDK Documentation

InstallDate Property (InstallSitePartToSiteSetup)

DateTime the Site Part was installed. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallDate As Date

[PropertyBitValueAttribute()]
public DateTime InstallDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToSiteSetup Class
InstallSitePartToSiteSetup Members


InstanceName Property (InstallSitePartToSiteSetup) | fcSDK Documentation

InstanceName Property (InstallSitePartToSiteSetup)

The instance name for the Site Part.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstanceName As String

[PropertyBitValueAttribute()]
public string InstanceName {get; set;}

Remarks

If not set, the instance name is automatically created for you.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToSiteSetup Class
InstallSitePartToSiteSetup Members


InvoiceNumber Property (InstallSitePartToSiteSetup) | fcSDK Documentation

InvoiceNumber Property (InstallSitePartToSiteSetup)

Invoice number

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InvoiceNumber As String

[PropertyBitValueAttribute()]
public string InvoiceNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToSiteSetup Class
InstallSitePartToSiteSetup Members


PartDomain Property (InstallSitePartToSiteSetup) | fcSDK Documentation

PartDomain Property (InstallSitePartToSiteSetup)

Domain of the part to install

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartDomain As String

[PropertyBitValueAttribute()]
public string PartDomain {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToSiteSetup Class
InstallSitePartToSiteSetup Members


PartNumber Property (InstallSitePartToSiteSetup) | fcSDK Documentation

PartNumber Property (InstallSitePartToSiteSetup)

Part Number of the part to install

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartNumber As String

[PropertyBitValueAttribute()]
public string PartNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToSiteSetup Class
InstallSitePartToSiteSetup Members


PartRevision Property (InstallSitePartToSiteSetup) | fcSDK Documentation

PartRevision Property (InstallSitePartToSiteSetup)

Part Revision of the part to install

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRevision As String

[PropertyBitValueAttribute()]
public string PartRevision {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToSiteSetup Class
InstallSitePartToSiteSetup Members


PartStatus Property (InstallSitePartToSiteSetup) | fcSDK Documentation

PartStatus Property (InstallSitePartToSiteSetup)

Element from the 'Part_Status' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartStatus As String

[PropertyBitValueAttribute()]
public string PartStatus {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToSiteSetup Class
InstallSitePartToSiteSetup Members


Quantity Property (InstallSitePartToSiteSetup) | fcSDK Documentation

Quantity Property (InstallSitePartToSiteSetup)

The number of units to install

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Quantity As Integer

[PropertyBitValueAttribute()]
public int Quantity {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToSiteSetup Class
InstallSitePartToSiteSetup Members


SerialNumber Property (InstallSitePartToSiteSetup) | fcSDK Documentation

SerialNumber Property (InstallSitePartToSiteSetup)

Serial number of the part installed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SerialNumber As String

[PropertyBitValueAttribute()]
public string SerialNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToSiteSetup Class
InstallSitePartToSiteSetup Members


ShipDate Property (InstallSitePartToSiteSetup) | fcSDK Documentation

ShipDate Property (InstallSitePartToSiteSetup)

DateTime the part was shipped. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ShipDate As Date

[PropertyBitValueAttribute()]
public DateTime ShipDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToSiteSetup Class
InstallSitePartToSiteSetup Members


SiteIDNum Property (InstallSitePartToSiteSetup) | fcSDK Documentation

SiteIDNum Property (InstallSitePartToSiteSetup)

Identifier of the Site where the part will be installed.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteIDNum As String

[PropertyBitValueAttribute()]
public string SiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToSiteSetup Class
InstallSitePartToSiteSetup Members


UserName Property (InstallSitePartToSiteSetup) | fcSDK Documentation

UserName Property (InstallSitePartToSiteSetup)

User who performed the install. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InstallSitePartToSiteSetup Class
InstallSitePartToSiteSetup Members


InterfacesToolkit Class | fcSDK Documentation

InterfacesToolkit Class

Provides APIs to allow you to modify common Clarify objects such as Contacts, Sites, Addresses, Solutions, Contracts, Parts, and more. Methods on this object allow you to create, modify, dispatch, accept, reject, assign, yank, and move, among many others operations.

Syntax

'Declaration

Public Class InterfacesToolkit
   Inherits InterfacesToolkitBase

public class InterfacesToolkit : InterfacesToolkitBase

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.ToolkitBase
FChoice.Toolkits.Clarify.Interfaces.InterfacesToolkitBase
FChoice.Toolkits.Clarify.Interfaces.InterfacesToolkit

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

InterfacesToolkit Members
FChoice.Toolkits.Clarify.Interfaces Namespace


InterfacesToolkit Class Members | fcSDK Documentation

InterfacesToolkit Class Members

The following tables list the members exposed by InterfacesToolkit.

Public Constructors

 | Name | Description
Public Constructor | InterfacesToolkit Constructor | Overloaded.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | CreateCommunicationActivityCode | Activity code used for act_entry logs generated when creating a communication.
static (Shared in Visual Basic) | CreateDialogueActivityCode | Activity code used for act_entry logs generated when creating a dialogue.
static (Shared in Visual Basic) | DeliveryConfirmedActivityCode |
static (Shared in Visual Basic) | DeliveryFailedActivityCode |
static (Shared in Visual Basic) | DeliveryPendingActivityCode |

Public Properties

 | Name | Description
Public Property | AllowDuplicateContact | Should the CreateContact or UpdateContact methods allow the creation or update of a Contact with the same first name, last name, telephone number as another Contact in the system. (Inherited from FChoice.Toolkits.Clarify.Interfaces.InterfacesToolkitBase)
Public Property | ImpersonatorUsername | (Inherited from FChoice.Toolkits.Clarify.Interfaces.InterfacesToolkitBase)
Public Property | UseDatabaseLogins | (Inherited from FChoice.Toolkits.Clarify.Interfaces.InterfacesToolkitBase)

Public Methods

 | Name | Description
Public Method | AcceptSolution | Overloaded. Accept the specified Solution from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.
Public Method | AddContactToContract | Overloaded. Adds a Contact to an existing Contract. This overload takes a set of required parameters for the API.
Public Method | AddEmployeeToAccount | Overloaded. Add an Employee as a team member to an Account with a specified role. This overload takes a set of required parameters for the API.
Public Method | AddSitePartToContract | Overloaded. Adds a Site Part to an existing contract.
Public Method | AddSiteToAccount | Overloaded. Adds a Site to an existing Account specifying the Site's role in the account. This overload takes a set of required parameters for the API.
Public Method | AddSiteToContract | Overloaded. Adds a site to an existing Contract. This overload takes a set of required parameters for the API.
Public Method | AddUserToQueue | Overloaded. Add a User to a Queue. This overload takes a set of required parameters for the API.
Public Method | AddWorkaround | Overloaded. Add a new Workaround to an existing Solution. This overload takes a set of required parameters for the API.
Public Method | AssignSolution | Overloaded. Assign the Solution to a new user. This overload takes a set of required parameters for the API.
Public Method | CreateAccount | Overloaded. Create Account (business org) This overload takes a set of required parameters for the API.
Public Method | CreateAddress | Overloaded. Creates a new Address. This overload takes a set of required parameters for the API.
Public Method | CreateBOM | Overloaded. Creates a Bill Of Materials (BOM) for a Part Revision. This overload takes a set of required parameters for the API.
Public Method | CreateChannel | Overloaded.
Public Method | CreateCommunication | Overloaded. Creates a new Communication.
Public Method | CreateContact | Overloaded. Creates a Contact. This overload takes a setup object.
Public Method | CreateContract | Overloaded. Creates a Contract. This overload takes a set of required parameters for the API.
Public Method | CreateCountry | Overloaded. Creates a Country. This overload takes a set of required parameters for the API.
Public Method | CreateDialogue | Overloaded. Creates a new Dialogue.
Public Method | CreateEmployee | Overloaded. Create an Employee in Clarify This overload takes a set of required parameters for the API.
Public Method | CreateInteraction | Overloaded. Creates an Interaction in Clarify. This overload takes a set of required parameters for the API.
Public Method | CreatePart | Overloaded. Create a Part. This overload takes a set of required parameters for the API.
Public Method | CreatePartRevision | Overloaded. Create a Part Revision (mod_level) This overload takes a set of required parameters for the API.
Public Method | CreatePriceInstance | Overloaded. Creates a Price Instance. This overload takes a set of required parameters for the API.
Public Method | CreateProductBin | Overloaded. Create a Product Bin This overload takes a set of required parameters for the API.
Public Method | CreateQueue | Overloaded. Create a Queue. This overload takes a set of required parameters for the API.
Public Method | CreateSite | Overloaded. Create a Site. This overload takes a set of required parameters for the API.
Public Method | CreateSolution | Overloaded. Create a Solution. This overload takes a set of required parameters for the API.
Public Method | CreateState | Overloaded. Create a State (Provence) and relate it to an existing Country. This overload takes a set of required parameters for the API.
Public Method | CreateTimeZone | Overloaded. Creates a Time Zone and relates it to an existing Country. This overload takes a set of required parameters for the API.
Public Method | CreateWipBin | Overloaded. Create a WipBin. This overload takes a set of required parameters for the API.
Public Method | DeinstallSitePart | Overloaded. DeInstall a Site Part. This overload takes a set of required parameters for the API.
Public Method | DeleteProductBin | Overloaded. Delete a Product Bin. This overload takes a set of required parameters for the API.
Public Method | DispatchSolution | Overloaded. Dispatch the Solution to the specified queue. This overload takes a set of required parameters for the API.
Public Method | ForwardSolution | Overloaded. Reject-forward the Solution from one queue to another. This overload takes a set of required parameters for the API.
Public Method | InstallSitePartToBin | Overloaded. Install a Site Part under a Product Bin. This overload takes a set of required parameters for the API.
Public Method | InstallSitePartToPart | Overloaded. Install a Site Part under another Site Part. This overload takes a set of required parameters for the API.
Public Method | InstallSitePartToSite | Overloaded. Install a Site Part under a Site. This overload takes a set of required parameters for the API.
Public Method | LinkCaseToWorkaround | Overloaded. Link a Case to a Workaround. This overload takes a set of required parameters for the API.
Public Method | LinkCRToSolution | Overloaded. Link a CR to a Solution. This overload takes a set of required parameters for the API.
Public Method | MoveSitePartToBin | Overloaded. Move the SitePartToBin from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
Public Method | MoveSitePartToPart | Overloaded. Move the SitePartToPart from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
Public Method | MoveSitePartToSite | Overloaded. Move the SitePartToSite from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
Public Method | MoveSolution | Overloaded. Move the Solution from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
Public Method | ReinstallSitePartToBin | Overloaded. Re-Install a Site Part under a Product Bin. This overload takes a set of required parameters for the API.
Public Method | ReinstallSitePartToPart | Overloaded. Re-Install a Site Part under another Site Part. This overload takes a set of required parameters for the API.
Public Method | ReinstallSitePartToSite | Overloaded. Re-Install a Site Part under a Site. This overload takes a set of required parameters for the API.
Public Method | RejectSolution | Overloaded. Reject the Solution from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.
Public Method | RemoveContactFromContract | Overloaded.
Public Method | RemoveEmployeeFromAccount | Overloaded. Remove an Employee from an Account. This overload takes a set of required parameters for the API.
Public Method | RemoveSiteFromAccount | Overloaded. Remove a Site from an Account. This overload takes a set of required parameters for the API.
Public Method | RemoveSiteFromContract | Overloaded.
Public Method | RemoveSitePartFromContract | Overloaded.
Public Method | ReopenDialogue | Overloaded.
Public Method | UnlinkCaseFromWorkaround | Overloaded. Unlink Case from Workaround. This overload takes a set of required parameters for the API.
Public Method | UnlinkCRFromSolution | Overloaded. Unlink CR from Solution. This overload takes a set of required parameters for the API.
Public Method | UpdateAccount | Overloaded. Update an Account. This overload takes a setup object.
Public Method | UpdateAddress | Overloaded. Update an Address. This overload takes a setup object.
Public Method | UpdateCommunication | Overloaded. Update a Communication.
Public Method | UpdateContact | Overloaded. Update a Contact. This overload takes a set of required parameters for the API.
Public Method | UpdateContactByObjid | Overloaded.
Public Method | UpdateContract | Overloaded. Update a Contract. This overload takes a setup object.
Public Method | UpdateDialogue | Overloaded. Update a Dialogue.
Public Method | UpdatePart | Overloaded. Update a Part. This overload takes a set of required parameters for the API.
Public Method | UpdatePartRevision | Overloaded. Update a Part Revision (mod_level) This overload takes a set of required parameters for the API.
Public Method | UpdatePriceInstance | Overloaded. Update Price Instance. This overload takes a set of required parameters for the API.
Public Method | UpdateProductBin | Overloaded. Update a Product Bin. This overload takes a setup object.
Public Method | UpdateQueue | Overloaded. Update a Queue. This overload takes a setup object.
Public Method | UpdateSite | Overloaded. Update a Site. This overload takes a setup object.
Public Method | UpdateSiteByObjid | Overloaded. Update Site identified by Objid. This overload takes a setup object.
Public Method | UpdateSitePart | Overloaded. Update a Site Part This overload takes a set of required parameters for the API.
Public Method | UpdateWipBin | Overloaded. Update a WipBin. This overload takes a setup object.
Public Method | YankSolution | Overloaded. Yank the Solution from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.

Reference

InterfacesToolkit Class
FChoice.Toolkits.Clarify.Interfaces Namespace


InterfacesToolkit Constructor | fcSDK Documentation

InterfacesToolkit Constructor

Initializes a new instance of the InterfacesToolkit class.

Overload List

Overload | Description
InterfacesToolkit Constructor(ClarifySession) | Initializes a new instance of the InterfacesToolkit class using a ClarifySession object.
InterfacesToolkit Constructor(IFCApplication,IFCSession) | Initializes a new instance of the InterfacesToolkit class using a Compatibility application and session.

Remarks

Creating a toolkit requires that you have the application initialized and session object created.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members


InterfacesToolkit Constructor(ClarifySession) | fcSDK Documentation

InterfacesToolkit Constructor(ClarifySession)

The session under which the toolkit APIs will be executed.

Initializes a new instance of the InterfacesToolkit class using a ClarifySession object.

Syntax

'Declaration

Public Function New( _
   ByVal _session_ As ClarifySession _
)

public InterfacesToolkit(
   ClarifySession _session_
)

Parameters

session

The session under which the toolkit APIs will be executed.

Remarks

If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


InterfacesToolkit Constructor(IFCApplication,IFCSession) | fcSDK Documentation

InterfacesToolkit Constructor(IFCApplication,IFCSession)

The compatibility application under which the toolkit APIs will be executed.

The compatibility session under which the toolkit APIs will be executed.

Initializes a new instance of the InterfacesToolkit class using a Compatibility application and session.

Syntax

'Declaration

Public Function New( _
   ByVal _application_ As IFCApplication, _
   ByVal _session_ As IFCSession _
)

public InterfacesToolkit(
   IFCApplication _application_,
   IFCSession _session_
)

Parameters

application

The compatibility application under which the toolkit APIs will be executed.

session

The compatibility session under which the toolkit APIs will be executed.

Remarks

If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


AcceptSolution Method | fcSDK Documentation

AcceptSolution Method

Accept the specified Solution from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.

Accept the specified Solution from the queue in which it is currently dispatched.

Overload List

Overload | Description
AcceptSolution(String) | Accept the specified Solution from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.
AcceptSolution(AcceptSolutionSetup) | Accept the specified Solution from the queue in which it is currently dispatched. This overload takes a setup object.
AcceptSolution(AcceptSolutionSetup,IDbTransaction) | Accept the specified Solution from the queue in which it is currently dispatched. This overload takes a setup object and a database transaction.

Remarks

The Solution must be currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
AcceptSolutionSetup Class


AcceptSolution(String) Method | fcSDK Documentation

AcceptSolution(String) Method

Solution Identifier.

Accept the specified Solution from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function AcceptSolution( _
   ByVal _solutionIDNum_ As String _
) As ToolkitResult

public ToolkitResult AcceptSolution(
   string _solutionIDNum_
)

Parameters

solutionIDNum

Solution Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Solution must be currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


AcceptSolution(AcceptSolutionSetup) Method | fcSDK Documentation

AcceptSolution(AcceptSolutionSetup) Method

Setup object for API invocation.

Accept the specified Solution from the queue in which it is currently dispatched. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function AcceptSolution( _
   ByVal _setupParam_ AcceptSolutionSetup _
) As ToolkitResult

public ToolkitResult AcceptSolution(
   AcceptSolutionSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Solution must be currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
AcceptSolutionSetup Class


AcceptSolution(AcceptSolutionSetup,IDbTransaction) Method | fcSDK Documentation

AcceptSolution(AcceptSolutionSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Accept the specified Solution from the queue in which it is currently dispatched. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function AcceptSolution( _
   ByVal _setupParam_ As AcceptSolutionSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult AcceptSolution(
   AcceptSolutionSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Solution must be currently dispatched to a queue.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


AddContactToContract Method | fcSDK Documentation

AddContactToContract Method

Adds a Contact to an existing Contract. This overload takes a set of required parameters for the API.

Adds a Contact to an existing Contract.

Overload List

Overload | Description
AddContactToContract(String,String,String,String,String) | Adds a Contact to an existing Contract. This overload takes a set of required parameters for the API.
AddContactToContract(AddContactToContractSetup) | Adds a Contact to an existing Contract. This overload takes a setup object.
AddContactToContract(AddContactToContractSetup,IDbTransaction) | Adds a Contact to an existing Contract. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
AddContactToContractSetup Class


AddContactToContract(String,String,String,String,String) Method | fcSDK Documentation

AddContactToContract(String,String,String,String,String) Method

Identifies to which Contract the Contact will be added.

Contact's first name.

Contact's last name.

Contact's phone number.

Identifies the Site where the added Contact is located.

Adds a Contact to an existing Contract. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function AddContactToContract( _
   ByVal _contractIDNum_ As String, _
   ByVal _contactFirstName_ As String, _
   ByVal _contactLastName_ As String, _
   ByVal _contactPhone_ As String, _
   ByVal _siteIDNum_ As String _
) As ToolkitResult

public ToolkitResult AddContactToContract(
   string _contractIDNum_,
   string _contactFirstName_,
   string _contactLastName_,
   string _contactPhone_,
   string _siteIDNum_
)

Parameters

contractIDNum

Identifies to which Contract the Contact will be added.

contactFirstName

Contact's first name.

contactLastName

Contact's last name.

contactPhone

Contact's phone number.

siteIDNum

Identifies the Site where the added Contact is located.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - Objid of the Contract the Contact was added to.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


AddContactToContract(AddContactToContractSetup) Method | fcSDK Documentation

AddContactToContract(AddContactToContractSetup) Method

Setup object for API invocation.

Adds a Contact to an existing Contract. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function AddContactToContract( _
   ByVal _setupParam_ AddContactToContractSetup _
) As ToolkitResult

public ToolkitResult AddContactToContract(
   AddContactToContractSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - Objid of the Contract the Contact was added to.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
AddContactToContractSetup Class


AddContactToContract(AddContactToContractSetup,IDbTransaction) Method | fcSDK Documentation

AddContactToContract(AddContactToContractSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Adds a Contact to an existing Contract. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function AddContactToContract( _
   ByVal _setupParam_ As AddContactToContractSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult AddContactToContract(
   AddContactToContractSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


AddEmployeeToAccount Method | fcSDK Documentation

AddEmployeeToAccount Method

Add an Employee as a team member to an Account with a specified role. This overload takes a set of required parameters for the API.

Add an Employee as a team member to an Account with a specified role.

Overload List

Overload | Description
AddEmployeeToAccount(String,String) | Add an Employee as a team member to an Account with a specified role. This overload takes a set of required parameters for the API.
AddEmployeeToAccount(AddEmployeeToAccountSetup) | Add an Employee as a team member to an Account with a specified role. This overload takes a setup object.
AddEmployeeToAccount(AddEmployeeToAccountSetup,IDbTransaction) | Add an Employee as a team member to an Account with a specified role. This overload takes a setup object and a database transaction.

Remarks

If no RoleName is specified then the default role name is used.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
AddEmployeeToAccountSetup Class


AddEmployeeToAccount(String,String) Method | fcSDK Documentation

AddEmployeeToAccount(String,String) Method

Username of the Account team member .

Identifier of the Account the Employee is being added to .

Add an Employee as a team member to an Account with a specified role. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function AddEmployeeToAccount( _
   ByVal _userName_ As String, _
   ByVal _accountIDNum_ As String _
) As ToolkitResult

public ToolkitResult AddEmployeeToAccount(
   string _userName_,
   string _accountIDNum_
)

Parameters

userName

Username of the Account team member .

accountIDNum

Identifier of the Account the Employee is being added to .

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - Objid of the Employee Role that is created to link the Employee to the Account.

Remarks

If no RoleName is specified then the default role name is used.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


AddEmployeeToAccount(AddEmployeeToAccountSetup) Method | fcSDK Documentation

AddEmployeeToAccount(AddEmployeeToAccountSetup) Method

Setup object for API invocation.

Add an Employee as a team member to an Account with a specified role. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function AddEmployeeToAccount( _
   ByVal _setupParam_ AddEmployeeToAccountSetup _
) As ToolkitResult

public ToolkitResult AddEmployeeToAccount(
   AddEmployeeToAccountSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - Objid of the Employee Role that is created to link the Employee to the Account.

Remarks

If no RoleName is specified then the default role name is used.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
AddEmployeeToAccountSetup Class


AddEmployeeToAccount(AddEmployeeToAccountSetup,IDbTransaction) Method | fcSDK Documentation

AddEmployeeToAccount(AddEmployeeToAccountSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Add an Employee as a team member to an Account with a specified role. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function AddEmployeeToAccount( _
   ByVal _setupParam_ As AddEmployeeToAccountSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult AddEmployeeToAccount(
   AddEmployeeToAccountSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

If no RoleName is specified then the default role name is used.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


AddSitePartToContract Method | fcSDK Documentation

AddSitePartToContract Method

Adds a Site Part to an existing contract.

Adds a Site Part to a Contract.

Overload List

Overload | Description
AddSitePartToContract(String,String,Int32) | Adds a Site Part to a Contract. This overload takes a set of required parameters for the API.
AddSitePartToContract(AddSitePartToContractSetup) | Adds a Site Part to a Contract. This overload takes a setup object.
AddSitePartToContract(AddSitePartToContractSetup,IDbTransaction) | Adds a Site Part to a Contract. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
AddSitePartToContractSetup Class


AddSitePartToContract(String,String,Int32) Method | fcSDK Documentation

AddSitePartToContract(String,String,Int32) Method

Contract Identifier.

Identifier of site where the site part is located.

Objid of the SitePart to be added.

Adds a Site Part to a Contract. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function AddSitePartToContract( _
   ByVal _contractIDNum_ As String, _
   ByVal _siteIDNum_ As String, _
   ByVal _sitePartObjid_ As Integer _
) As ToolkitResult

public ToolkitResult AddSitePartToContract(
   string _contractIDNum_,
   string _siteIDNum_,
   int _sitePartObjid_
)

Parameters

contractIDNum

Contract Identifier.

siteIDNum

Identifier of site where the site part is located.

sitePartObjid

Objid of the SitePart to be added.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


AddSitePartToContract(AddSitePartToContractSetup) Method | fcSDK Documentation

AddSitePartToContract(AddSitePartToContractSetup) Method

Setup object for API invocation.

Adds a Site Part to a Contract. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function AddSitePartToContract( _
   ByVal _setupParam_ AddSitePartToContractSetup _
) As ToolkitResult

public ToolkitResult AddSitePartToContract(
   AddSitePartToContractSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
AddSitePartToContractSetup Class


AddSitePartToContract(AddSitePartToContractSetup,IDbTransaction) Method | fcSDK Documentation

AddSitePartToContract(AddSitePartToContractSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Adds a Site Part to a Contract. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function AddSitePartToContract( _
   ByVal _setupParam_ As AddSitePartToContractSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult AddSitePartToContract(
   AddSitePartToContractSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


AddSiteToAccount Method | fcSDK Documentation

AddSiteToAccount Method

Adds a Site to an existing Account specifying the Site's role in the account. This overload takes a set of required parameters for the API.

Adds a Site to an existing Account specifying the Site's role in the account.

Overload List

Overload | Description
AddSiteToAccount(String,String,String) | Adds a Site to an existing Account specifying the Site's role in the account. This overload takes a set of required parameters for the API.
AddSiteToAccount(AddSiteToAccountSetup) | Adds a Site to an existing Account specifying the Site's role in the account. This overload takes a setup object.
AddSiteToAccount(AddSiteToAccountSetup,IDbTransaction) | Adds a Site to an existing Account specifying the Site's role in the account. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
AddSiteToAccountSetup Class


AddSiteToAccount(String,String,String) Method | fcSDK Documentation

AddSiteToAccount(String,String,String) Method

Site Identifier of site to be added.

The identifier of the Account to which the site will be added.

Name of the Site Role the Site will play for the Account.

Adds a Site to an existing Account specifying the Site's role in the account. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function AddSiteToAccount( _
   ByVal _siteIDNum_ As String, _
   ByVal _accountIDNum_ As String, _
   ByVal _roleName_ As String _
) As ToolkitResult

public ToolkitResult AddSiteToAccount(
   string _siteIDNum_,
   string _accountIDNum_,
   string _roleName_
)

Parameters

siteIDNum

Site Identifier of site to be added.

accountIDNum

The identifier of the Account to which the site will be added.

roleName

Name of the Site Role the Site will play for the Account.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - Objid of the Site Role that is created to link the Site to the Account.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


AddSiteToAccount(AddSiteToAccountSetup) Method | fcSDK Documentation

AddSiteToAccount(AddSiteToAccountSetup) Method

Setup object for API invocation.

Adds a Site to an existing Account specifying the Site's role in the account. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function AddSiteToAccount( _
   ByVal _setupParam_ AddSiteToAccountSetup _
) As ToolkitResult

public ToolkitResult AddSiteToAccount(
   AddSiteToAccountSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - Objid of the Site Role that is created to link the Site to the Account.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
AddSiteToAccountSetup Class


AddSiteToAccount(AddSiteToAccountSetup,IDbTransaction) Method | fcSDK Documentation

AddSiteToAccount(AddSiteToAccountSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Adds a Site to an existing Account specifying the Site's role in the account. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function AddSiteToAccount( _
   ByVal _setupParam_ As AddSiteToAccountSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult AddSiteToAccount(
   AddSiteToAccountSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


AddSiteToContract Method | fcSDK Documentation

AddSiteToContract Method

Adds a site to an existing Contract. This overload takes a set of required parameters for the API.

Adds a site to an existing Contract.

Overload List

Overload | Description
AddSiteToContract(String,String) | Adds a site to an existing Contract. This overload takes a set of required parameters for the API.
AddSiteToContract(AddSiteToContractSetup) | Adds a site to an existing Contract. This overload takes a setup object.
AddSiteToContract(AddSiteToContractSetup,IDbTransaction) | Adds a site to an existing Contract. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
AddSiteToContractSetup Class


AddSiteToContract(String,String) Method | fcSDK Documentation

AddSiteToContract(String,String) Method

Identifier of the Contract to which the Site will be added.

Identifier of the Site to add to the Contract.

Adds a site to an existing Contract. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function AddSiteToContract( _
   ByVal _contractIDNum_ As String, _
   ByVal _siteIDNum_ As String _
) As ToolkitResult

public ToolkitResult AddSiteToContract(
   string _contractIDNum_,
   string _siteIDNum_
)

Parameters

contractIDNum

Identifier of the Contract to which the Site will be added.

siteIDNum

Identifier of the Site to add to the Contract.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


AddSiteToContract(AddSiteToContractSetup) Method | fcSDK Documentation

AddSiteToContract(AddSiteToContractSetup) Method

Setup object for API invocation.

Adds a site to an existing Contract. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function AddSiteToContract( _
   ByVal _setupParam_ AddSiteToContractSetup _
) As ToolkitResult

public ToolkitResult AddSiteToContract(
   AddSiteToContractSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
AddSiteToContractSetup Class


AddSiteToContract(AddSiteToContractSetup,IDbTransaction) Method | fcSDK Documentation

AddSiteToContract(AddSiteToContractSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Adds a site to an existing Contract. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function AddSiteToContract( _
   ByVal _setupParam_ As AddSiteToContractSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult AddSiteToContract(
   AddSiteToContractSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


AddUserToQueue Method | fcSDK Documentation

AddUserToQueue Method

Add a User to a Queue. This overload takes a set of required parameters for the API.

Add a User to a Queue.

Overload List

Overload | Description
AddUserToQueue(String,String) | Add a User to a Queue. This overload takes a set of required parameters for the API.
AddUserToQueue(AddUserToQueueSetup) | Add a User to a Queue. This overload takes a setup object.
AddUserToQueue(AddUserToQueueSetup,IDbTransaction) | Add a User to a Queue. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
AddUserToQueueSetup Class


AddUserToQueue(String,String) Method | fcSDK Documentation

AddUserToQueue(String,String) Method

Name of the Queue to which the User will be added.

Username of the user being added to the Queue.

Add a User to a Queue. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function AddUserToQueue( _
   ByVal _queue_ As String, _
   ByVal _userName_ As String _
) As ToolkitResult

public ToolkitResult AddUserToQueue(
   string _queue_,
   string _userName_
)

Parameters

queue

Name of the Queue to which the User will be added.

userName

Username of the user being added to the Queue.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - Objid of the Queue the user was added to.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


AddUserToQueue(AddUserToQueueSetup) Method | fcSDK Documentation

AddUserToQueue(AddUserToQueueSetup) Method

Setup object for API invocation.

Add a User to a Queue. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function AddUserToQueue( _
   ByVal _setupParam_ AddUserToQueueSetup _
) As ToolkitResult

public ToolkitResult AddUserToQueue(
   AddUserToQueueSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - Objid of the Queue the user was added to.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
AddUserToQueueSetup Class


AddUserToQueue(AddUserToQueueSetup,IDbTransaction) Method | fcSDK Documentation

AddUserToQueue(AddUserToQueueSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Add a User to a Queue. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function AddUserToQueue( _
   ByVal _setupParam_ As AddUserToQueueSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult AddUserToQueue(
   AddUserToQueueSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


AddWorkaround Method | fcSDK Documentation

AddWorkaround Method

Add a new Workaround to an existing Solution. This overload takes a set of required parameters for the API.

Add a new Workaround to an existing Solution.

Overload List

Overload | Description
AddWorkaround(String,String) | Add a new Workaround to an existing Solution. This overload takes a set of required parameters for the API.
AddWorkaround(Int32,String) | Add a new Workaround to an existing Solution. This overload takes a set of required parameters for the API.
AddWorkaround(AddWorkaroundSetup) | Add a new Workaround to an existing Solution. This overload takes a setup object.
AddWorkaround(AddWorkaroundSetup,IDbTransaction) | Add a new Workaround to an existing Solution. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
AddWorkaroundSetup Class


AddWorkaround(String,String) Method | fcSDK Documentation

AddWorkaround(String,String) Method

Identifier of the Solution to receive the Workaround.

Text of the Workaround.

Add a new Workaround to an existing Solution. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function AddWorkaround( _
   ByVal _solutionIDNum_ As String, _
   ByVal _workaround_ As String _
) As ToolkitResult

public ToolkitResult AddWorkaround(
   string _solutionIDNum_,
   string _workaround_
)

Parameters

solutionIDNum

Identifier of the Solution to receive the Workaround.

workaround

Text of the Workaround.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Workaround.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


AddWorkaround(Int32,String) Method | fcSDK Documentation

AddWorkaround(Int32,String) Method

Objid of the Solution to receive the Workaround.

Text of the Workaround.

Add a new Workaround to an existing Solution. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function AddWorkaround( _
   ByVal _solutionObjid_ As Integer, _
   ByVal _workaround_ As String _
) As ToolkitResult

public ToolkitResult AddWorkaround(
   int _solutionObjid_,
   string _workaround_
)

Parameters

solutionObjid

Objid of the Solution to receive the Workaround.

workaround

Text of the Workaround.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Workaround.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


AddWorkaround(AddWorkaroundSetup) Method | fcSDK Documentation

AddWorkaround(AddWorkaroundSetup) Method

Setup object for API invocation.

Add a new Workaround to an existing Solution. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function AddWorkaround( _
   ByVal _setupParam_ AddWorkaroundSetup _
) As ToolkitResult

public ToolkitResult AddWorkaround(
   AddWorkaroundSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Workaround.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
AddWorkaroundSetup Class


AddWorkaround(AddWorkaroundSetup,IDbTransaction) Method | fcSDK Documentation

AddWorkaround(AddWorkaroundSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Add a new Workaround to an existing Solution. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function AddWorkaround( _
   ByVal _setupParam_ As AddWorkaroundSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult AddWorkaround(
   AddWorkaroundSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


AssignSolution Method | fcSDK Documentation

AssignSolution Method

Assign the Solution to a new user. This overload takes a set of required parameters for the API.

Assign the Solution to a new user.

Overload List

Overload | Description
AssignSolution(String) | Assign the Solution to a new user. This overload takes a set of required parameters for the API.
AssignSolution(AssignSolutionSetup) | Assign the Solution to a new user. This overload takes a setup object.
AssignSolution(AssignSolutionSetup,IDbTransaction) | Assign the Solution to a new user. This overload takes a setup object and a database transaction.

Remarks

The Solution must be in the Open condition, and the user assigning the Solution does not have to be the owner of the Solution. In base Clarify, the assigner of a Solution must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the Solution in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
AssignSolutionSetup Class


AssignSolution(String) Method | fcSDK Documentation

AssignSolution(String) Method

Solution Identifier.

Assign the Solution to a new user. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function AssignSolution( _
   ByVal _solutionIDNum_ As String _
) As ToolkitResult

public ToolkitResult AssignSolution(
   string _solutionIDNum_
)

Parameters

solutionIDNum

Solution Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Solution must be in the Open condition, and the user assigning the Solution does not have to be the owner of the Solution. In base Clarify, the assigner of a Solution must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the Solution in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


AssignSolution(AssignSolutionSetup) Method | fcSDK Documentation

AssignSolution(AssignSolutionSetup) Method

Setup object for API invocation.

Assign the Solution to a new user. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function AssignSolution( _
   ByVal _setupParam_ AssignSolutionSetup _
) As ToolkitResult

public ToolkitResult AssignSolution(
   AssignSolutionSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Solution must be in the Open condition, and the user assigning the Solution does not have to be the owner of the Solution. In base Clarify, the assigner of a Solution must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the Solution in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
AssignSolutionSetup Class


AssignSolution(AssignSolutionSetup,IDbTransaction) Method | fcSDK Documentation

AssignSolution(AssignSolutionSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Assign the Solution to a new user. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function AssignSolution( _
   ByVal _setupParam_ As AssignSolutionSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult AssignSolution(
   AssignSolutionSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Solution must be in the Open condition, and the user assigning the Solution does not have to be the owner of the Solution. In base Clarify, the assigner of a Solution must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the Solution in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreateAccount Method | fcSDK Documentation

CreateAccount Method

Create Account (business org) This overload takes a set of required parameters for the API.

Create Account (business org)

Overload List

Overload | Description
CreateAccount() | Create Account (business org) This overload takes a set of required parameters for the API.
CreateAccount(CreateAccountSetup) | Create Account (business org) This overload takes a setup object.
CreateAccount(CreateAccountSetup,IDbTransaction) | Create Account (business org) This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
CreateAccountSetup Class


CreateAccount() Method | fcSDK Documentation

CreateAccount() Method

Create Account (business org) This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreateAccount() As ToolkitResult

public ToolkitResult CreateAccount()

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Account.
  • IDNum - The IDNum of the Account.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreateAccount(CreateAccountSetup) Method | fcSDK Documentation

CreateAccount(CreateAccountSetup) Method

Setup object for API invocation.

Create Account (business org) This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreateAccount( _
   ByVal _setupParam_ CreateAccountSetup _
) As ToolkitResult

public ToolkitResult CreateAccount(
   CreateAccountSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Account.
  • IDNum - The IDNum of the Account.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
CreateAccountSetup Class


CreateAccount(CreateAccountSetup,IDbTransaction) Method | fcSDK Documentation

CreateAccount(CreateAccountSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Create Account (business org) This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreateAccount( _
   ByVal _setupParam_ As CreateAccountSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreateAccount(
   CreateAccountSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreateAddress Method | fcSDK Documentation

CreateAddress Method

Creates a new Address. This overload takes a set of required parameters for the API.

Creates a new Address.

Overload List

Overload | Description
CreateAddress(String,String,String,String,String,String) | Creates a new Address. This overload takes a set of required parameters for the API.
CreateAddress(CreateAddressSetup) | Creates a new Address. This overload takes a setup object.
CreateAddress(CreateAddressSetup,IDbTransaction) | Creates a new Address. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
CreateAddressSetup Class


CreateAddress(String,String,String,String,String,String) Method | fcSDK Documentation

CreateAddress(String,String,String,String,String,String) Method

Address Line 1.

Address City.

Address State.

Address Zipcode.

Address Country

Address Timezone.

Creates a new Address. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreateAddress( _
   ByVal _address1_ As String, _
   ByVal _city_ As String, _
   ByVal _state_ As String, _
   ByVal _zipCode_ As String, _
   ByVal _country_ As String, _
   ByVal _timeZone_ As String _
) As ToolkitResult

public ToolkitResult CreateAddress(
   string _address1_,
   string _city_,
   string _state_,
   string _zipCode_,
   string _country_,
   string _timeZone_
)

Parameters

address1

Address Line 1.

city

Address City.

state

Address State.

zipCode

Address Zipcode.

country

Address Country

timeZone

Address Timezone.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Address.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreateAddress(CreateAddressSetup) Method | fcSDK Documentation

CreateAddress(CreateAddressSetup) Method

Setup object for API invocation.

Creates a new Address. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreateAddress( _
   ByVal _setupParam_ CreateAddressSetup _
) As ToolkitResult

public ToolkitResult CreateAddress(
   CreateAddressSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Address.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
CreateAddressSetup Class


CreateAddress(CreateAddressSetup,IDbTransaction) Method | fcSDK Documentation

CreateAddress(CreateAddressSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Creates a new Address. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreateAddress( _
   ByVal _setupParam_ As CreateAddressSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreateAddress(
   CreateAddressSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreateBOM Method | fcSDK Documentation

CreateBOM Method

Creates a Bill Of Materials (BOM) for a Part Revision. This overload takes a set of required parameters for the API.

Creates a Bill Of Materials (BOM) for a Part Revision.

Overload List

Overload | Description
CreateBOM(String,String,String,String,String,String,Int32) | Creates a Bill Of Materials (BOM) for a Part Revision. This overload takes a set of required parameters for the API.
CreateBOM(CreateBOMSetup) | Creates a Bill Of Materials (BOM) for a Part Revision. This overload takes a setup object.
CreateBOM(CreateBOMSetup,IDbTransaction) | Creates a Bill Of Materials (BOM) for a Part Revision. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
CreateBOMSetup Class


CreateBOM(String,String,String,String,String,String,Int32) Method | fcSDK Documentation

CreateBOM(String,String,String,String,String,String,Int32) Method

Parent Part Number

Parent Part Domain

Parent Part Revision

Child Part Number

Domain of the child part

Child Part Revision

How many of the Child Part Revisions are in the Parent Part Revision.

Creates a Bill Of Materials (BOM) for a Part Revision. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreateBOM( _
   ByVal _parentPartNumber_ As String, _
   ByVal _parentPartDomain_ As String, _
   ByVal _parentPartRevision_ As String, _
   ByVal _childPartNumber_ As String, _
   ByVal _childPartDomain_ As String, _
   ByVal _childPartRevision_ As String, _
   ByVal _quantity_ As Integer _
) As ToolkitResult

public ToolkitResult CreateBOM(
   string _parentPartNumber_,
   string _parentPartDomain_,
   string _parentPartRevision_,
   string _childPartNumber_,
   string _childPartDomain_,
   string _childPartRevision_,
   int _quantity_
)

Parameters

parentPartNumber

Parent Part Number

parentPartDomain

Parent Part Domain

parentPartRevision

Parent Part Revision

childPartNumber

Child Part Number

childPartDomain

Domain of the child part

childPartRevision

Child Part Revision

quantity

How many of the Child Part Revisions are in the Parent Part Revision.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the BOM.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreateBOM(CreateBOMSetup) Method | fcSDK Documentation

CreateBOM(CreateBOMSetup) Method

Setup object for API invocation.

Creates a Bill Of Materials (BOM) for a Part Revision. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreateBOM( _
   ByVal _setupParam_ CreateBOMSetup _
) As ToolkitResult

public ToolkitResult CreateBOM(
   CreateBOMSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the BOM.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
CreateBOMSetup Class


CreateBOM(CreateBOMSetup,IDbTransaction) Method | fcSDK Documentation

CreateBOM(CreateBOMSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Creates a Bill Of Materials (BOM) for a Part Revision. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreateBOM( _
   ByVal _setupParam_ As CreateBOMSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreateBOM(
   CreateBOMSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreateChannel Method | fcSDK Documentation

CreateChannel Method

Overload List

Overload | Description
CreateChannel(CreateChannelSetup) |
CreateChannel(CreateChannelSetup,IDbTransaction) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members


CreateChannel(CreateChannelSetup) Method | fcSDK Documentation

CreateChannel(CreateChannelSetup) Method

Syntax

'Declaration

Public Overloads Function CreateChannel( _
   ByVal _setup_ CreateChannelSetup _
) As ToolkitResult

public ToolkitResult CreateChannel(
   CreateChannelSetup _setup_
)

Parameters

setup

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreateChannel(CreateChannelSetup,IDbTransaction) Method | fcSDK Documentation

CreateChannel(CreateChannelSetup,IDbTransaction) Method

Syntax

'Declaration

Public Overloads Function CreateChannel( _
   ByVal _setup_ As CreateChannelSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreateChannel(
   CreateChannelSetup _setup_,
   IDbTransaction _transaction_
)

Parameters

setup

transaction

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreateCommunication Method | fcSDK Documentation

CreateCommunication Method

Creates a new Communication.

Creates a new Communication.

Overload List

Overload | Description
CreateCommunication(CreateCommunicationSetup) | Creates a new Communication.
CreateCommunication(CreateCommunicationSetup,IDbTransaction) | Creates a new Communication.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members


CreateCommunication(CreateCommunicationSetup) Method | fcSDK Documentation

CreateCommunication(CreateCommunicationSetup) Method

Setup object for API invocation.

Creates a new Communication.

Syntax

'Declaration

Public Overloads Function CreateCommunication( _
   ByVal _setup_ CreateCommunicationSetup _
) As ToolkitResult

public ToolkitResult CreateCommunication(
   CreateCommunicationSetup _setup_
)

Parameters

setup

Setup object for API invocation.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreateCommunication(CreateCommunicationSetup,IDbTransaction) Method | fcSDK Documentation

CreateCommunication(CreateCommunicationSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Creates a new Communication.

Syntax

'Declaration

Public Overloads Function CreateCommunication( _
   ByVal _setup_ As CreateCommunicationSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreateCommunication(
   CreateCommunicationSetup _setup_,
   IDbTransaction _transaction_
)

Parameters

setup

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreateContact Method | fcSDK Documentation

CreateContact Method

Creates a Contact. This overload takes a setup object.

Creates a Contact.

Overload List

Overload | Description
CreateContact(CreateContactSetup) | Creates a Contact. This overload takes a setup object.
CreateContact(CreateContactSetup,IDbTransaction) | Creates a Contact. This overload takes a setup object and a database transaction.
CreateContact(String,String,String,String) | Creates a Contact. This overload takes a set of required parameters for the API.

Remarks

A default contact role for the Site is automatically created if no role name is defined.

If you need to create duplicate contacts (same first name, last name, phone), you may use the AllowDuplicateContact property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
CreateContactSetup Class


CreateContact(CreateContactSetup) Method | fcSDK Documentation

CreateContact(CreateContactSetup) Method

Setup object for API invocation.

Creates a Contact. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreateContact( _
   ByVal _setupParam_ CreateContactSetup _
) As ToolkitResult

public ToolkitResult CreateContact(
   CreateContactSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Contact.

Remarks

A default contact role for the Site is automatically created if no role name is defined.

If you need to create duplicate contacts (same first name, last name, phone), you may use the AllowDuplicateContact property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
CreateContactSetup Class


CreateContact(CreateContactSetup,IDbTransaction) Method | fcSDK Documentation

CreateContact(CreateContactSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Creates a Contact. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreateContact( _
   ByVal _setupParam_ As CreateContactSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreateContact(
   CreateContactSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

A default contact role for the Site is automatically created if no role name is defined.

If you need to create duplicate contacts (same first name, last name, phone), you may use the AllowDuplicateContact property.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreateContact(String,String,String,String) Method | fcSDK Documentation

CreateContact(String,String,String,String) Method

Contact first name

Contact last name

Phone number for the contact

Identifier of the site for the contact role to create.

Creates a Contact. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreateContact( _
   ByVal _firstName_ As String, _
   ByVal _lastName_ As String, _
   ByVal _phone_ As String, _
   ByVal _siteIDNum_ As String _
) As ToolkitResult

public ToolkitResult CreateContact(
   string _firstName_,
   string _lastName_,
   string _phone_,
   string _siteIDNum_
)

Parameters

firstName

Contact first name

lastName

Contact last name

phone

Phone number for the contact

siteIDNum

Identifier of the site for the contact role to create.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Contact.

Remarks

A default contact role for the Site is automatically created if no role name is defined.

If you need to create duplicate contacts (same first name, last name, phone), you may use the AllowDuplicateContact property.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreateContract Method (InterfacesToolkit) | fcSDK Documentation

CreateContract Method (InterfacesToolkit)

Creates a Contract. This overload takes a set of required parameters for the API.

Creates a Contract.

Overload List

Overload | Description
CreateContract() | Creates a Contract. This overload takes a set of required parameters for the API.
CreateContract(CreateContractSetup) | Creates a Contract. This overload takes a setup object.
CreateContract(CreateContractSetup,IDbTransaction) | Creates a Contract. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
CreateContractSetup Class


CreateContract() Method | fcSDK Documentation

CreateContract() Method

Creates a Contract. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreateContract() As ToolkitResult

public ToolkitResult CreateContract()

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Contract.
  • IDNum - The IDNum of the Contract.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreateContract(CreateContractSetup) Method | fcSDK Documentation

CreateContract(CreateContractSetup) Method

Setup object for API invocation.

Creates a Contract. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreateContract( _
   ByVal _setupParam_ CreateContractSetup _
) As ToolkitResult

public ToolkitResult CreateContract(
   CreateContractSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • IDNum - The IDNum of the Contract.
  • Objid - The Objid of the Contract.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
CreateContractSetup Class


CreateContract(CreateContractSetup,IDbTransaction) Method | fcSDK Documentation

CreateContract(CreateContractSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Creates a Contract. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreateContract( _
   ByVal _setupParam_ As CreateContractSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreateContract(
   CreateContractSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreateCountry Method | fcSDK Documentation

CreateCountry Method

Creates a Country. This overload takes a set of required parameters for the API.

Creates a Country.

Overload List

Overload | Description
CreateCountry(String,Int32) | Creates a Country. This overload takes a set of required parameters for the API.
CreateCountry(CreateCountrySetup) | Creates a Country. This overload takes a setup object.
CreateCountry(CreateCountrySetup,IDbTransaction) | Creates a Country. This overload takes a setup object and a database transaction.

Remarks

If no Currency value is specified a country will be created without a relation to a Currency. If the Currency speficied does not exist. A Currency will be created using the Currency properties.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
CreateCountrySetup Class


CreateCountry(String,Int32) Method | fcSDK Documentation

CreateCountry(String,Int32) Method

Name of the Country being created

Telephone country code for the Country

Creates a Country. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreateCountry( _
   ByVal _country_ As String, _
   ByVal _countryCode_ As Integer _
) As ToolkitResult

public ToolkitResult CreateCountry(
   string _country_,
   int _countryCode_
)

Parameters

country

Name of the Country being created

countryCode

Telephone country code for the Country

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Country.

Remarks

If no Currency value is specified a country will be created without a relation to a Currency. If the Currency speficied does not exist. A Currency will be created using the Currency properties.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreateCountry(CreateCountrySetup) Method | fcSDK Documentation

CreateCountry(CreateCountrySetup) Method

Setup object for API invocation.

Creates a Country. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreateCountry( _
   ByVal _setupParam_ CreateCountrySetup _
) As ToolkitResult

public ToolkitResult CreateCountry(
   CreateCountrySetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Country.

Remarks

If no Currency value is specified a country will be created without a relation to a Currency. If the Currency speficied does not exist. A Currency will be created using the Currency properties.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
CreateCountrySetup Class


CreateCountry(CreateCountrySetup,IDbTransaction) Method | fcSDK Documentation

CreateCountry(CreateCountrySetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Creates a Country. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreateCountry( _
   ByVal _setupParam_ As CreateCountrySetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreateCountry(
   CreateCountrySetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

If no Currency value is specified a country will be created without a relation to a Currency. If the Currency speficied does not exist. A Currency will be created using the Currency properties.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreateDialogue Method | fcSDK Documentation

CreateDialogue Method

Creates a new Dialogue.

Creates a new Dialogue.

Overload List

Overload | Description
CreateDialogue() | Creates a new Dialogue.
CreateDialogue(CreateDialogueSetup) | Creates a new Dialogue.
CreateDialogue(CreateDialogueSetup,IDbTransaction) | Creates a new Dialogue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members


CreateDialogue() Method | fcSDK Documentation

CreateDialogue() Method

Creates a new Dialogue.

Syntax

'Declaration

Public Overloads Function CreateDialogue() As ToolkitResult

public ToolkitResult CreateDialogue()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreateDialogue(CreateDialogueSetup) Method | fcSDK Documentation

CreateDialogue(CreateDialogueSetup) Method

Setup object for API invocation.

Creates a new Dialogue.

Syntax

'Declaration

Public Overloads Function CreateDialogue( _
   ByVal _createDialogueSetup_ CreateDialogueSetup _
) As ToolkitResult

public ToolkitResult CreateDialogue(
   CreateDialogueSetup _createDialogueSetup_
)

Parameters

createDialogueSetup

Setup object for API invocation.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreateDialogue(CreateDialogueSetup,IDbTransaction) Method | fcSDK Documentation

CreateDialogue(CreateDialogueSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Creates a new Dialogue.

Syntax

'Declaration

Public Overloads Function CreateDialogue( _
   ByVal _setup_ As CreateDialogueSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreateDialogue(
   CreateDialogueSetup _setup_,
   IDbTransaction _transaction_
)

Parameters

setup

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreateEmployee Method | fcSDK Documentation

CreateEmployee Method

Create an Employee in Clarify This overload takes a set of required parameters for the API.

Create an Employee in Clarify

Overload List

Overload | Description
CreateEmployee(String,String,String,String,String,String,String) | Create an Employee in Clarify This overload takes a set of required parameters for the API.
CreateEmployee(CreateEmployeeSetup) | Create an Employee in Clarify This overload takes a setup object.
CreateEmployee(CreateEmployeeSetup,IDbTransaction) | Create an Employee in Clarify This overload takes a setup object and a database transaction.

Remarks

Also creates a user login for the database system tables as required by Clarify.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
CreateEmployeeSetup Class


CreateEmployee(String,String,String,String,String,String,String) Method | fcSDK Documentation

CreateEmployee(String,String,String,String,String,String,String) Method

Employee first name

Employee last name

Employee login name

Employee password

Identifier of the Site where the Employee is located.

Employee's email address

Online privilege class

Create an Employee in Clarify This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreateEmployee( _
   ByVal _firstName_ As String, _
   ByVal _lastName_ As String, _
   ByVal _loginName_ As String, _
   ByVal _password_ As String, _
   ByVal _siteIDNum_ As String, _
   ByVal _email_ As String, _
   ByVal _onlinePrivilegeClass_ As String _
) As CreateEmployeeResult

public CreateEmployeeResult CreateEmployee(
   string _firstName_,
   string _lastName_,
   string _loginName_,
   string _password_,
   string _siteIDNum_,
   string _email_,
   string _onlinePrivilegeClass_
)

Parameters

firstName

Employee first name

lastName

Employee last name

loginName

Employee login name

password

Employee password

siteIDNum

Identifier of the Site where the Employee is located.

email

Employee's email address

onlinePrivilegeClass

Online privilege class

Return Value

The following values are populated in the CreateEmployeeResult object returned by the API method:

  • UserObjid - Objid of the User record created.
  • EmployeeObjid - Objid of the Employee record created.

Remarks

Also creates a user login for the database system tables as required by Clarify.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreateEmployee(CreateEmployeeSetup) Method | fcSDK Documentation

CreateEmployee(CreateEmployeeSetup) Method

Setup object for API invocation.

Create an Employee in Clarify This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreateEmployee( _
   ByVal _setupParam_ As CreateEmployeeSetup _
) As CreateEmployeeResult

public CreateEmployeeResult CreateEmployee(
   CreateEmployeeSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the CreateEmployeeResult object returned by the API method:

  • EmployeeObjid - Objid of the Employee record created.
  • UserObjid - Objid of the User record created.

Remarks

Also creates a user login for the database system tables as required by Clarify.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
CreateEmployeeSetup Class


CreateEmployee(CreateEmployeeSetup,IDbTransaction) Method | fcSDK Documentation

CreateEmployee(CreateEmployeeSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Create an Employee in Clarify This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreateEmployee( _
   ByVal _setupParam_ As CreateEmployeeSetup, _
   ByVal _transaction_ As IDbTransaction _
) As CreateEmployeeResult

public CreateEmployeeResult CreateEmployee(
   CreateEmployeeSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A CreateEmployeeResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

Also creates a user login for the database system tables as required by Clarify.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreateInteraction Method | fcSDK Documentation

CreateInteraction Method

Creates an Interaction in Clarify. This overload takes a set of required parameters for the API.

Creates an Interaction in Clarify.

Overload List

Overload | Description
CreateInteraction(String,String,String,TimeSpan) | Creates an Interaction in Clarify. This overload takes a set of required parameters for the API.
CreateInteraction(CreateInteractionSetup) | Creates an Interaction in Clarify. This overload takes a setup object.
CreateInteraction(CreateInteractionSetup,IDbTransaction) | Creates an Interaction in Clarify. This overload takes a setup object and a database transaction.

Remarks

An interaction stores information on communications with Contacts.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
CreateInteractionSetup Class


CreateInteraction(String,String,String,TimeSpan) Method | fcSDK Documentation

CreateInteraction(String,String,String,TimeSpan) Method

Contact's first name.

Contact's last name.

Contact's phone number.

Duration of the Interaction

Creates an Interaction in Clarify. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreateInteraction( _
   ByVal _contactFirstName_ As String, _
   ByVal _contactLastName_ As String, _
   ByVal _contactPhone_ As String, _
   ByVal _duration_ As TimeSpan _
) As ToolkitResult

public ToolkitResult CreateInteraction(
   string _contactFirstName_,
   string _contactLastName_,
   string _contactPhone_,
   TimeSpan _duration_
)

Parameters

contactFirstName

Contact's first name.

contactLastName

Contact's last name.

contactPhone

Contact's phone number.

duration

Duration of the Interaction

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Interaction.
  • IDNum - The IDNum of the Interaction.

Remarks

An interaction stores information on communications with Contacts.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreateInteraction(CreateInteractionSetup) Method | fcSDK Documentation

CreateInteraction(CreateInteractionSetup) Method

Setup object for API invocation.

Creates an Interaction in Clarify. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreateInteraction( _
   ByVal _setupParam_ CreateInteractionSetup _
) As ToolkitResult

public ToolkitResult CreateInteraction(
   CreateInteractionSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • IDNum - The IDNum of the Interaction.
  • Objid - The Objid of the Interaction.

Remarks

An interaction stores information on communications with Contacts.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
CreateInteractionSetup Class


CreateInteraction(CreateInteractionSetup,IDbTransaction) Method | fcSDK Documentation

CreateInteraction(CreateInteractionSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Creates an Interaction in Clarify. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreateInteraction( _
   ByVal _setupParam_ As CreateInteractionSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreateInteraction(
   CreateInteractionSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

An interaction stores information on communications with Contacts.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreatePart Method | fcSDK Documentation

CreatePart Method

Create a Part. This overload takes a set of required parameters for the API.

Create a Part.

Overload List

Overload | Description
CreatePart(String,String,Int32,PartRepairType) | Create a Part. This overload takes a set of required parameters for the API.
CreatePart(CreatePartSetup) | Create a Part. This overload takes a setup object.
CreatePart(CreatePartSetup,IDbTransaction) | Create a Part. This overload takes a setup object and a database transaction.

Remarks

Just calling this API will NOT cause the part to be visible in Clarify. There must be at least one Part Revision present to view a Part.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
CreatePartSetup Class


CreatePart(String,String,Int32,PartRepairType) Method | fcSDK Documentation

CreatePart(String,String,Int32,PartRepairType) Method

Part Number for the part to create.

Domain for the part to create.

Number of warranty days for the part

Type of repair. One of "Repairable" or "Expendable"

Create a Part. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreatePart( _
   ByVal _partNumber_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _warrantyDays_ As Integer, _
   ByVal _repairType_ As PartRepairType _
) As ToolkitResult

public ToolkitResult CreatePart(
   string _partNumber_,
   string _partDomain_,
   int _warrantyDays_,
   PartRepairType _repairType_
)

Parameters

partNumber

Part Number for the part to create.

partDomain

Domain for the part to create.

warrantyDays

Number of warranty days for the part

repairType

Type of repair. One of "Repairable" or "Expendable"

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Part.

Remarks

Just calling this API will NOT cause the part to be visible in Clarify. There must be at least one Part Revision present to view a Part.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreatePart(CreatePartSetup) Method | fcSDK Documentation

CreatePart(CreatePartSetup) Method

Setup object for API invocation.

Create a Part. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreatePart( _
   ByVal _setupParam_ CreatePartSetup _
) As ToolkitResult

public ToolkitResult CreatePart(
   CreatePartSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Part.

Remarks

Just calling this API will NOT cause the part to be visible in Clarify. There must be at least one Part Revision present to view a Part.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
CreatePartSetup Class


CreatePart(CreatePartSetup,IDbTransaction) Method | fcSDK Documentation

CreatePart(CreatePartSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Create a Part. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreatePart( _
   ByVal _setupParam_ As CreatePartSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreatePart(
   CreatePartSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

Just calling this API will NOT cause the part to be visible in Clarify. There must be at least one Part Revision present to view a Part.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreatePartRevision Method | fcSDK Documentation

CreatePartRevision Method

Create a Part Revision (mod_level) This overload takes a set of required parameters for the API.

Create a Part Revision (mod_level)

Overload List

Overload | Description
CreatePartRevision(String,String,String) | Create a Part Revision (mod_level) This overload takes a set of required parameters for the API.
CreatePartRevision(CreatePartRevisionSetup) | Create a Part Revision (mod_level) This overload takes a setup object.
CreatePartRevision(CreatePartRevisionSetup,IDbTransaction) | Create a Part Revision (mod_level) This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
CreatePartRevisionSetup Class


CreatePartRevision(String,String,String) Method | fcSDK Documentation

CreatePartRevision(String,String,String) Method

Part number of the part

Domain of the part

Revision to create

Create a Part Revision (mod_level) This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreatePartRevision( _
   ByVal _partNumber_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _partRevision_ As String _
) As ToolkitResult

public ToolkitResult CreatePartRevision(
   string _partNumber_,
   string _partDomain_,
   string _partRevision_
)

Parameters

partNumber

Part number of the part

partDomain

Domain of the part

partRevision

Revision to create

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the PartRevision.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreatePartRevision(CreatePartRevisionSetup) Method | fcSDK Documentation

CreatePartRevision(CreatePartRevisionSetup) Method

Setup object for API invocation.

Create a Part Revision (mod_level) This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreatePartRevision( _
   ByVal _setupParam_ CreatePartRevisionSetup _
) As ToolkitResult

public ToolkitResult CreatePartRevision(
   CreatePartRevisionSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the PartRevision.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
CreatePartRevisionSetup Class


CreatePartRevision(CreatePartRevisionSetup,IDbTransaction) Method | fcSDK Documentation

CreatePartRevision(CreatePartRevisionSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Create a Part Revision (mod_level) This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreatePartRevision( _
   ByVal _setupParam_ As CreatePartRevisionSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreatePartRevision(
   CreatePartRevisionSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreatePriceInstance Method (InterfacesToolkit) | fcSDK Documentation

CreatePriceInstance Method (InterfacesToolkit)

Creates a Price Instance. This overload takes a set of required parameters for the API.

Creates a Price Instance.

Overload List

Overload | Description
CreatePriceInstance(String,String,String,String,PriceInstanceType,Int32,Decimal) | Creates a Price Instance. This overload takes a set of required parameters for the API.
CreatePriceInstance(CreatePriceInstanceSetup) | Creates a Price Instance. This overload takes a setup object.
CreatePriceInstance(CreatePriceInstanceSetup,IDbTransaction) | Creates a Price Instance. This overload takes a setup object and a database transaction.

Remarks

You many not have two prices (in the same schedule for the same part and quantity) overlap or have the price's StartDate or EndDate extend outside the span of the price program.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
CreatePriceInstanceSetup Class


CreatePriceInstance(String,String,String,String,PriceInstanceType,Int32,Decimal) Method | fcSDK Documentation

CreatePriceInstance(String,String,String,String,PriceInstanceType,Int32,Decimal) Method

Part number to price

Domain of the part

Revision to price

Domain of the part

The type of price being created.

How many units in this price instance.

Price of the part

Creates a Price Instance. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreatePriceInstance( _
   ByVal _partNumber_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _priceProgram_ As String, _
   ByVal _priceType_ As PriceInstanceType, _
   ByVal _pricedQuantity_ As Integer, _
   ByVal _price_ As Decimal _
) As ToolkitResult

public ToolkitResult CreatePriceInstance(
   string _partNumber_,
   string _partDomain_,
   string _partRevision_,
   string _priceProgram_,
   PriceInstanceType _priceType_,
   int _pricedQuantity_,
   decimal _price_
)

Parameters

partNumber

Part number to price

partDomain

Domain of the part

partRevision

Revision to price

priceProgram

Domain of the part

priceType

The type of price being created.

pricedQuantity

How many units in this price instance.

price

Price of the part

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the PriceInstance.

Remarks

You many not have two prices (in the same schedule for the same part and quantity) overlap or have the price's StartDate or EndDate extend outside the span of the price program.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreatePriceInstance(CreatePriceInstanceSetup) Method | fcSDK Documentation

CreatePriceInstance(CreatePriceInstanceSetup) Method

Setup object for API invocation.

Creates a Price Instance. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreatePriceInstance( _
   ByVal _setupParam_ CreatePriceInstanceSetup _
) As ToolkitResult

public ToolkitResult CreatePriceInstance(
   CreatePriceInstanceSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the PriceInstance.

Remarks

You many not have two prices (in the same schedule for the same part and quantity) overlap or have the price's StartDate or EndDate extend outside the span of the price program.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
CreatePriceInstanceSetup Class


CreatePriceInstance(CreatePriceInstanceSetup,IDbTransaction) Method | fcSDK Documentation

CreatePriceInstance(CreatePriceInstanceSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Creates a Price Instance. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreatePriceInstance( _
   ByVal _setupParam_ As CreatePriceInstanceSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreatePriceInstance(
   CreatePriceInstanceSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

You many not have two prices (in the same schedule for the same part and quantity) overlap or have the price's StartDate or EndDate extend outside the span of the price program.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreateProductBin Method | fcSDK Documentation

CreateProductBin Method

Create a Product Bin This overload takes a set of required parameters for the API.

Create a Product Bin

Overload List

Overload | Description
CreateProductBin(String,String) | Create a Product Bin This overload takes a set of required parameters for the API.
CreateProductBin(CreateProductBinSetup) | Create a Product Bin This overload takes a setup object.
CreateProductBin(CreateProductBinSetup,IDbTransaction) | Create a Product Bin This overload takes a setup object and a database transaction.

Remarks

A unique BinName must be provided.

If the Bin being created exists under another Bin you need to set the Parent BinObjd

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
CreateProductBinSetup Class


CreateProductBin(String,String) Method | fcSDK Documentation

CreateProductBin(String,String) Method

Name of the bin to create

Identifier of the site where the bin is created

Create a Product Bin This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreateProductBin( _
   ByVal _binName_ As String, _
   ByVal _siteIDNum_ As String _
) As ToolkitResult

public ToolkitResult CreateProductBin(
   string _binName_,
   string _siteIDNum_
)

Parameters

binName

Name of the bin to create

siteIDNum

Identifier of the site where the bin is created

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the ProductBin.

Remarks

A unique BinName must be provided.

If the Bin being created exists under another Bin you need to set the Parent BinObjd

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreateProductBin(CreateProductBinSetup) Method | fcSDK Documentation

CreateProductBin(CreateProductBinSetup) Method

Setup object for API invocation.

Create a Product Bin This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreateProductBin( _
   ByVal _setupParam_ CreateProductBinSetup _
) As ToolkitResult

public ToolkitResult CreateProductBin(
   CreateProductBinSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the ProductBin.

Remarks

A unique BinName must be provided.

If the Bin being created exists under another Bin you need to set the Parent BinObjd

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
CreateProductBinSetup Class


CreateProductBin(CreateProductBinSetup,IDbTransaction) Method | fcSDK Documentation

CreateProductBin(CreateProductBinSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Create a Product Bin This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreateProductBin( _
   ByVal _setupParam_ As CreateProductBinSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreateProductBin(
   CreateProductBinSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

A unique BinName must be provided.

If the Bin being created exists under another Bin you need to set the Parent BinObjd

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreateQueue Method | fcSDK Documentation

CreateQueue Method

Create a Queue. This overload takes a set of required parameters for the API.

Create a Queue.

Overload List

Overload | Description
CreateQueue(String,Boolean,Boolean,Boolean,Boolean,Boolean,Boolean,Boolean,Boolean,Boolean,Boolean) | Create a Queue. This overload takes a set of required parameters for the API.
CreateQueue(CreateQueueSetup) | Create a Queue. This overload takes a setup object.
CreateQueue(CreateQueueSetup,IDbTransaction) | Create a Queue. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
CreateQueueSetup Class


CreateQueue(String,Boolean,Boolean,Boolean,Boolean,Boolean,Boolean,Boolean,Boolean,Boolean,Boolean) Method | fcSDK Documentation

CreateQueue(String,Boolean,Boolean,Boolean,Boolean,Boolean,Boolean,Boolean,Boolean,Boolean,Boolean) Method

Title of the Queue

Should Queue allow CRs

Should Queue allow Cases

Should Queue allow Contracts

Should Queue allow Dialogs

Should Queue allow Demand Details

Should Queue allow Jobs

Should Queue allow Opportunities

Should Queue allow Solutions

Should Queue allow Subcases

Should Queue allow Action Items

Create a Queue. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreateQueue( _
   ByVal _title_ As String, _
   ByVal _allowCR_ As Boolean, _
   ByVal _allowCase_ As Boolean, _
   ByVal _allowContract_ As Boolean, _
   ByVal _allowDialogue_ As Boolean, _
   ByVal _allowDemandDetail_ As Boolean, _
   ByVal _allowJob_ As Boolean, _
   ByVal _allowOpportunity_ As Boolean, _
   ByVal _allowSolution_ As Boolean, _
   ByVal _allowSubcase_ As Boolean, _
   ByVal _allowActionItem_ As Boolean _
) As ToolkitResult

public ToolkitResult CreateQueue(
   string _title_,
   bool _allowCR_,
   bool _allowCase_,
   bool _allowContract_,
   bool _allowDialogue_,
   bool _allowDemandDetail_,
   bool _allowJob_,
   bool _allowOpportunity_,
   bool _allowSolution_,
   bool _allowSubcase_,
   bool _allowActionItem_
)

Parameters

title

Title of the Queue

allowCR

Should Queue allow CRs

allowCase

Should Queue allow Cases

allowContract

Should Queue allow Contracts

allowDialogue

Should Queue allow Dialogs

allowDemandDetail

Should Queue allow Demand Details

allowJob

Should Queue allow Jobs

allowOpportunity

Should Queue allow Opportunities

allowSolution

Should Queue allow Solutions

allowSubcase

Should Queue allow Subcases

allowActionItem

Should Queue allow Action Items

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreateQueue(CreateQueueSetup) Method | fcSDK Documentation

CreateQueue(CreateQueueSetup) Method

Setup object for API invocation.

Create a Queue. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreateQueue( _
   ByVal _setupParam_ CreateQueueSetup _
) As ToolkitResult

public ToolkitResult CreateQueue(
   CreateQueueSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
CreateQueueSetup Class


CreateQueue(CreateQueueSetup,IDbTransaction) Method | fcSDK Documentation

CreateQueue(CreateQueueSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Create a Queue. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreateQueue( _
   ByVal _setupParam_ As CreateQueueSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreateQueue(
   CreateQueueSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreateSite Method | fcSDK Documentation

CreateSite Method

Create a Site. This overload takes a set of required parameters for the API.

Create a Site.

Overload List

Overload | Description
CreateSite(SiteType,SiteStatus,Int32) | Create a Site. This overload takes a set of required parameters for the API.
CreateSite(CreateSiteSetup) | Create a Site. This overload takes a setup object.
CreateSite(CreateSiteSetup,IDbTransaction) | Create a Site. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
CreateSiteSetup Class


CreateSite(SiteType,SiteStatus,Int32) Method | fcSDK Documentation

CreateSite(SiteType,SiteStatus,Int32) Method

Type of the site

Site status

Primary Address of the site

Create a Site. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreateSite( _
   ByVal _siteType_ As SiteType, _
   ByVal _status_ As SiteStatus, _
   ByVal _primaryAddressObjid_ As Integer _
) As ToolkitResult

public ToolkitResult CreateSite(
   SiteType _siteType_,
   SiteStatus _status_,
   int _primaryAddressObjid_
)

Parameters

siteType

Type of the site

status

Site status

primaryAddressObjid

Primary Address of the site

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • IDNum - The IDNum of the Site.
  • Objid - The Objid of the Site.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreateSite(CreateSiteSetup) Method | fcSDK Documentation

CreateSite(CreateSiteSetup) Method

Setup object for API invocation.

Create a Site. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreateSite( _
   ByVal _setupParam_ CreateSiteSetup _
) As ToolkitResult

public ToolkitResult CreateSite(
   CreateSiteSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • IDNum - The IDNum of the Site.
  • Objid - The Objid of the Site.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
CreateSiteSetup Class


CreateSite(CreateSiteSetup,IDbTransaction) Method | fcSDK Documentation

CreateSite(CreateSiteSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Create a Site. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreateSite( _
   ByVal _setupParam_ As CreateSiteSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreateSite(
   CreateSiteSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreateSolution Method | fcSDK Documentation

CreateSolution Method

Create a Solution. This overload takes a set of required parameters for the API.

Create a Solution.

Overload List

Overload | Description
CreateSolution() | Create a Solution. This overload takes a set of required parameters for the API.
CreateSolution(CreateSolutionSetup) | Create a Solution. This overload takes a setup object.
CreateSolution(CreateSolutionSetup,IDbTransaction) | Create a Solution. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
CreateSolutionSetup Class


CreateSolution() Method | fcSDK Documentation

CreateSolution() Method

Create a Solution. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreateSolution() As CreateSolutionResult

public CreateSolutionResult CreateSolution()

Return Value

The following values are populated in the CreateSolutionResult object returned by the API method:

  • Objid - The Objid of the Solution.
  • WorkaroundObjid - Objid of the Workaround that is created along with the Solution
  • IDNum - The IDNum of the Solution.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreateSolution(CreateSolutionSetup) Method | fcSDK Documentation

CreateSolution(CreateSolutionSetup) Method

Setup object for API invocation.

Create a Solution. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreateSolution( _
   ByVal _setupParam_ As CreateSolutionSetup _
) As CreateSolutionResult

public CreateSolutionResult CreateSolution(
   CreateSolutionSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the CreateSolutionResult object returned by the API method:

  • WorkaroundObjid - Objid of the Workaround that is created along with the Solution
  • Objid - The Objid of the Solution.
  • IDNum - The IDNum of the Solution.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
CreateSolutionSetup Class


CreateSolution(CreateSolutionSetup,IDbTransaction) Method | fcSDK Documentation

CreateSolution(CreateSolutionSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Create a Solution. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreateSolution( _
   ByVal _setupParam_ As CreateSolutionSetup, _
   ByVal _transaction_ As IDbTransaction _
) As CreateSolutionResult

public CreateSolutionResult CreateSolution(
   CreateSolutionSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A CreateSolutionResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreateState Method | fcSDK Documentation

CreateState Method

Create a State (Provence) and relate it to an existing Country. This overload takes a set of required parameters for the API.

Create a State (Provence) and relate it to an existing Country.

Overload List

Overload | Description
CreateState(String,String,String) | Create a State (Provence) and relate it to an existing Country. This overload takes a set of required parameters for the API.
CreateState(CreateStateSetup) | Create a State (Provence) and relate it to an existing Country. This overload takes a setup object.
CreateState(CreateStateSetup,IDbTransaction) | Create a State (Provence) and relate it to an existing Country. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
CreateStateSetup Class


CreateState(String,String,String) Method | fcSDK Documentation

CreateState(String,String,String) Method

State name

Full name of the State

Name of the Country the State will belong to.

Create a State (Provence) and relate it to an existing Country. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreateState( _
   ByVal _state_ As String, _
   ByVal _fullName_ As String, _
   ByVal _country_ As String _
) As ToolkitResult

public ToolkitResult CreateState(
   string _state_,
   string _fullName_,
   string _country_
)

Parameters

state

State name

fullName

Full name of the State

country

Name of the Country the State will belong to.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the State.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreateState(CreateStateSetup) Method | fcSDK Documentation

CreateState(CreateStateSetup) Method

Setup object for API invocation.

Create a State (Provence) and relate it to an existing Country. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreateState( _
   ByVal _setupParam_ CreateStateSetup _
) As ToolkitResult

public ToolkitResult CreateState(
   CreateStateSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the State.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
CreateStateSetup Class


CreateState(CreateStateSetup,IDbTransaction) Method | fcSDK Documentation

CreateState(CreateStateSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Create a State (Provence) and relate it to an existing Country. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreateState( _
   ByVal _setupParam_ As CreateStateSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreateState(
   CreateStateSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreateTimeZone Method | fcSDK Documentation

CreateTimeZone Method

Creates a Time Zone and relates it to an existing Country. This overload takes a set of required parameters for the API.

Creates a Time Zone and relates it to an existing Country.

Overload List

Overload | Description
CreateTimeZone(String,String,String) | Creates a Time Zone and relates it to an existing Country. This overload takes a set of required parameters for the API.
CreateTimeZone(CreateTimeZoneSetup) | Creates a Time Zone and relates it to an existing Country. This overload takes a setup object.
CreateTimeZone(CreateTimeZoneSetup,IDbTransaction) | Creates a Time Zone and relates it to an existing Country. This overload takes a setup object and a database transaction.

Remarks

If the Time Zone already exists it will be related to the Country.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
CreateTimeZoneSetup Class


CreateTimeZone(String,String,String) Method | fcSDK Documentation

CreateTimeZone(String,String,String) Method

Timezone name

Fullname of the Timezone

Name of the Country the Timezone will belong to.

Creates a Time Zone and relates it to an existing Country. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreateTimeZone( _
   ByVal _timeZone_ As String, _
   ByVal _fullName_ As String, _
   ByVal _country_ As String _
) As ToolkitResult

public ToolkitResult CreateTimeZone(
   string _timeZone_,
   string _fullName_,
   string _country_
)

Parameters

timeZone

Timezone name

fullName

Fullname of the Timezone

country

Name of the Country the Timezone will belong to.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the TimeZone.

Remarks

If the Time Zone already exists it will be related to the Country.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreateTimeZone(CreateTimeZoneSetup) Method | fcSDK Documentation

CreateTimeZone(CreateTimeZoneSetup) Method

Setup object for API invocation.

Creates a Time Zone and relates it to an existing Country. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreateTimeZone( _
   ByVal _setupParam_ CreateTimeZoneSetup _
) As ToolkitResult

public ToolkitResult CreateTimeZone(
   CreateTimeZoneSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the TimeZone.

Remarks

If the Time Zone already exists it will be related to the Country.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
CreateTimeZoneSetup Class


CreateTimeZone(CreateTimeZoneSetup,IDbTransaction) Method | fcSDK Documentation

CreateTimeZone(CreateTimeZoneSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Creates a Time Zone and relates it to an existing Country. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreateTimeZone( _
   ByVal _setupParam_ As CreateTimeZoneSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreateTimeZone(
   CreateTimeZoneSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

If the Time Zone already exists it will be related to the Country.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreateWipBin Method | fcSDK Documentation

CreateWipBin Method

Create a WipBin. This overload takes a set of required parameters for the API.

Create a WipBin.

Overload List

Overload | Description
CreateWipBin(String) | Create a WipBin. This overload takes a set of required parameters for the API.
CreateWipBin(CreateWipBinSetup) | Create a WipBin. This overload takes a setup object.
CreateWipBin(CreateWipBinSetup,IDbTransaction) | Create a WipBin. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
CreateWipBinSetup Class


CreateWipBin(String) Method | fcSDK Documentation

CreateWipBin(String) Method

Title of the WipBin

Create a WipBin. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreateWipBin( _
   ByVal _title_ As String _
) As ToolkitResult

public ToolkitResult CreateWipBin(
   string _title_
)

Parameters

title

Title of the WipBin

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreateWipBin(CreateWipBinSetup) Method | fcSDK Documentation

CreateWipBin(CreateWipBinSetup) Method

Setup object for API invocation.

Create a WipBin. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreateWipBin( _
   ByVal _setupParam_ CreateWipBinSetup _
) As ToolkitResult

public ToolkitResult CreateWipBin(
   CreateWipBinSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
CreateWipBinSetup Class


CreateWipBin(CreateWipBinSetup,IDbTransaction) Method | fcSDK Documentation

CreateWipBin(CreateWipBinSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Create a WipBin. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreateWipBin( _
   ByVal _setupParam_ As CreateWipBinSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreateWipBin(
   CreateWipBinSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


DeinstallSitePart Method (InterfacesToolkit) | fcSDK Documentation

DeinstallSitePart Method (InterfacesToolkit)

DeInstall a Site Part. This overload takes a set of required parameters for the API.

DeInstall a Site Part.

Overload List

Overload | Description
DeinstallSitePart(Int32) | DeInstall a Site Part. This overload takes a set of required parameters for the API.
DeinstallSitePart(DeinstallSitePartSetup) | DeInstall a Site Part. This overload takes a setup object.
DeinstallSitePart(DeinstallSitePartSetup,IDbTransaction) | DeInstall a Site Part. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
DeinstallSitePartSetup Class


DeinstallSitePart(Int32) Method | fcSDK Documentation

DeinstallSitePart(Int32) Method

ObjId of the Site Part to de-install

DeInstall a Site Part. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function DeinstallSitePart( _
   ByVal _sitePartObjid_ As Integer _
) As ToolkitResult

public ToolkitResult DeinstallSitePart(
   int _sitePartObjid_
)

Parameters

sitePartObjid

ObjId of the Site Part to de-install

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


DeinstallSitePart(DeinstallSitePartSetup) Method | fcSDK Documentation

DeinstallSitePart(DeinstallSitePartSetup) Method

Setup object for API invocation.

DeInstall a Site Part. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function DeinstallSitePart( _
   ByVal _setupParam_ DeinstallSitePartSetup _
) As ToolkitResult

public ToolkitResult DeinstallSitePart(
   DeinstallSitePartSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
DeinstallSitePartSetup Class


DeinstallSitePart(DeinstallSitePartSetup,IDbTransaction) Method | fcSDK Documentation

DeinstallSitePart(DeinstallSitePartSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

DeInstall a Site Part. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function DeinstallSitePart( _
   ByVal _setupParam_ As DeinstallSitePartSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult DeinstallSitePart(
   DeinstallSitePartSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


DeleteProductBin Method | fcSDK Documentation

DeleteProductBin Method

Delete a Product Bin. This overload takes a set of required parameters for the API.

Delete a Product Bin.

Overload List

Overload | Description
DeleteProductBin(Int32) | Delete a Product Bin. This overload takes a set of required parameters for the API.
DeleteProductBin(DeleteProductBinSetup) | Delete a Product Bin. This overload takes a setup object.
DeleteProductBin(DeleteProductBinSetup,IDbTransaction) | Delete a Product Bin. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
DeleteProductBinSetup Class


DeleteProductBin(Int32) Method | fcSDK Documentation

DeleteProductBin(Int32) Method

Objid of the Bin to delete

Delete a Product Bin. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function DeleteProductBin( _
   ByVal _binObjid_ As Integer _
) As ToolkitResult

public ToolkitResult DeleteProductBin(
   int _binObjid_
)

Parameters

binObjid

Objid of the Bin to delete

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


DeleteProductBin(DeleteProductBinSetup) Method | fcSDK Documentation

DeleteProductBin(DeleteProductBinSetup) Method

Setup object for API invocation.

Delete a Product Bin. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function DeleteProductBin( _
   ByVal _setupParam_ DeleteProductBinSetup _
) As ToolkitResult

public ToolkitResult DeleteProductBin(
   DeleteProductBinSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
DeleteProductBinSetup Class


DeleteProductBin(DeleteProductBinSetup,IDbTransaction) Method | fcSDK Documentation

DeleteProductBin(DeleteProductBinSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Delete a Product Bin. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function DeleteProductBin( _
   ByVal _setupParam_ As DeleteProductBinSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult DeleteProductBin(
   DeleteProductBinSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


DispatchSolution Method | fcSDK Documentation

DispatchSolution Method

Dispatch the Solution to the specified queue. This overload takes a set of required parameters for the API.

Dispatch the Solution to the specified queue.

Overload List

Overload | Description
DispatchSolution(String,String) | Dispatch the Solution to the specified queue. This overload takes a set of required parameters for the API.
DispatchSolution(DispatchSolutionSetup) | Dispatch the Solution to the specified queue. This overload takes a setup object.
DispatchSolution(DispatchSolutionSetup,IDbTransaction) | Dispatch the Solution to the specified queue. This overload takes a setup object and a database transaction.

Remarks

The Solution must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
DispatchSolutionSetup Class


DispatchSolution(String,String) Method | fcSDK Documentation

DispatchSolution(String,String) Method

Solution Identifier.

The queue into which the Solution is to be dispatched.

Dispatch the Solution to the specified queue. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function DispatchSolution( _
   ByVal _solutionIDNum_ As String, _
   ByVal _queue_ As String _
) As ToolkitResult

public ToolkitResult DispatchSolution(
   string _solutionIDNum_,
   string _queue_
)

Parameters

solutionIDNum

Solution Identifier.

queue

The queue into which the Solution is to be dispatched.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Solution must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


DispatchSolution(DispatchSolutionSetup) Method | fcSDK Documentation

DispatchSolution(DispatchSolutionSetup) Method

Setup object for API invocation.

Dispatch the Solution to the specified queue. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function DispatchSolution( _
   ByVal _setupParam_ DispatchSolutionSetup _
) As ToolkitResult

public ToolkitResult DispatchSolution(
   DispatchSolutionSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Solution must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
DispatchSolutionSetup Class


DispatchSolution(DispatchSolutionSetup,IDbTransaction) Method | fcSDK Documentation

DispatchSolution(DispatchSolutionSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Dispatch the Solution to the specified queue. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function DispatchSolution( _
   ByVal _setupParam_ As DispatchSolutionSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult DispatchSolution(
   DispatchSolutionSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Solution must be in open condition, and not currently dispatched to a queue.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


ForwardSolution Method | fcSDK Documentation

ForwardSolution Method

Reject-forward the Solution from one queue to another. This overload takes a set of required parameters for the API.

Reject-forward the Solution from one queue to another.

Overload List

Overload | Description
ForwardSolution(String,String) | Reject-forward the Solution from one queue to another. This overload takes a set of required parameters for the API.
ForwardSolution(ForwardSolutionSetup) | Reject-forward the Solution from one queue to another. This overload takes a setup object.
ForwardSolution(ForwardSolutionSetup,IDbTransaction) | Reject-forward the Solution from one queue to another. This overload takes a setup object and a database transaction.

Remarks

The Solution must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
ForwardSolutionSetup Class


ForwardSolution(String,String) Method | fcSDK Documentation

ForwardSolution(String,String) Method

Solution Identifier.

The new queue into which the Solution is to be forwarded.

Reject-forward the Solution from one queue to another. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function ForwardSolution( _
   ByVal _solutionIDNum_ As String, _
   ByVal _newQueue_ As String _
) As ToolkitResult

public ToolkitResult ForwardSolution(
   string _solutionIDNum_,
   string _newQueue_
)

Parameters

solutionIDNum

Solution Identifier.

newQueue

The new queue into which the Solution is to be forwarded.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Solution must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


ForwardSolution(ForwardSolutionSetup) Method | fcSDK Documentation

ForwardSolution(ForwardSolutionSetup) Method

Setup object for API invocation.

Reject-forward the Solution from one queue to another. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function ForwardSolution( _
   ByVal _setupParam_ ForwardSolutionSetup _
) As ToolkitResult

public ToolkitResult ForwardSolution(
   ForwardSolutionSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Solution must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
ForwardSolutionSetup Class


ForwardSolution(ForwardSolutionSetup,IDbTransaction) Method | fcSDK Documentation

ForwardSolution(ForwardSolutionSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Reject-forward the Solution from one queue to another. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function ForwardSolution( _
   ByVal _setupParam_ As ForwardSolutionSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult ForwardSolution(
   ForwardSolutionSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Solution must be in open condition, and not currently dispatched to a queue.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


InstallSitePartToBin Method | fcSDK Documentation

InstallSitePartToBin Method

Install a Site Part under a Product Bin. This overload takes a set of required parameters for the API.

Install a Site Part under a Product Bin.

Overload List

Overload | Description
InstallSitePartToBin(String,Int32,String,String,String,Int32) | Install a Site Part under a Product Bin. This overload takes a set of required parameters for the API.
InstallSitePartToBin(String,String,String,String,String) | Install a Site Part under a Product Bin. This overload takes a set of required parameters for the API.
InstallSitePartToBin(InstallSitePartToBinSetup) | Install a Site Part under a Product Bin. This overload takes a setup object.
InstallSitePartToBin(InstallSitePartToBinSetup,IDbTransaction) | Install a Site Part under a Product Bin. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
InstallSitePartToBinSetup Class


InstallSitePartToBin(String,Int32,String,String,String,Int32) Method | fcSDK Documentation

InstallSitePartToBin(String,Int32,String,String,String,Int32) Method

Identifier of the Site where the part will be installed.

Objid of the parent Bin this Part will be installed under

Part Number of the part to install

Part Revision of the part to install

Domain of the part to install

The number of units to install

Install a Site Part under a Product Bin. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function InstallSitePartToBin( _
   ByVal _siteIDNum_ As String, _
   ByVal _parentBinObjid_ As Integer, _
   ByVal _partNumber_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _quantity_ As Integer _
) As ToolkitResult

public ToolkitResult InstallSitePartToBin(
   string _siteIDNum_,
   int _parentBinObjid_,
   string _partNumber_,
   string _partRevision_,
   string _partDomain_,
   int _quantity_
)

Parameters

siteIDNum

Identifier of the Site where the part will be installed.

parentBinObjid

Objid of the parent Bin this Part will be installed under

partNumber

Part Number of the part to install

partRevision

Part Revision of the part to install

partDomain

Domain of the part to install

quantity

The number of units to install

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the SitePart.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


InstallSitePartToBin(String,String,String,String,String) Method | fcSDK Documentation

InstallSitePartToBin(String,String,String,String,String) Method

Identifier of the Site where the part will be installed.

Part Number of the part to install

Part Revision of the part to install

Domain of the part to install

Serial number of the part installed

Install a Site Part under a Product Bin. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function InstallSitePartToBin( _
   ByVal _siteIDNum_ As String, _
   ByVal _partNumber_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _serialNumber_ As String _
) As ToolkitResult

public ToolkitResult InstallSitePartToBin(
   string _siteIDNum_,
   string _partNumber_,
   string _partRevision_,
   string _partDomain_,
   string _serialNumber_
)

Parameters

siteIDNum

Identifier of the Site where the part will be installed.

partNumber

Part Number of the part to install

partRevision

Part Revision of the part to install

partDomain

Domain of the part to install

serialNumber

Serial number of the part installed

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the SitePart.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


InstallSitePartToBin(InstallSitePartToBinSetup) Method | fcSDK Documentation

InstallSitePartToBin(InstallSitePartToBinSetup) Method

Setup object for API invocation.

Install a Site Part under a Product Bin. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function InstallSitePartToBin( _
   ByVal _setupParam_ InstallSitePartToBinSetup _
) As ToolkitResult

public ToolkitResult InstallSitePartToBin(
   InstallSitePartToBinSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the SitePart.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
InstallSitePartToBinSetup Class


InstallSitePartToBin(InstallSitePartToBinSetup,IDbTransaction) Method | fcSDK Documentation

InstallSitePartToBin(InstallSitePartToBinSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Install a Site Part under a Product Bin. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function InstallSitePartToBin( _
   ByVal _setupParam_ As InstallSitePartToBinSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult InstallSitePartToBin(
   InstallSitePartToBinSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


InstallSitePartToPart Method | fcSDK Documentation

InstallSitePartToPart Method

Install a Site Part under another Site Part. This overload takes a set of required parameters for the API.

Install a Site Part under another Site Part.

Overload List

Overload | Description
InstallSitePartToPart(String,Int32,String,String,String,Int32) | Install a Site Part under another Site Part. This overload takes a set of required parameters for the API.
InstallSitePartToPart(String,String,String,String,String) | Install a Site Part under another Site Part. This overload takes a set of required parameters for the API.
InstallSitePartToPart(InstallSitePartToPartSetup) | Install a Site Part under another Site Part. This overload takes a setup object.
InstallSitePartToPart(InstallSitePartToPartSetup,IDbTransaction) | Install a Site Part under another Site Part. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
InstallSitePartToPartSetup Class


InstallSitePartToPart(String,Int32,String,String,String,Int32) Method | fcSDK Documentation

InstallSitePartToPart(String,Int32,String,String,String,Int32) Method

Identifier of the Site where the part will be installed.

Objid of the parent Site Part this Part will be installed under.

Part Number of the part to install

Part Revision of the part to install

Domain of the part to install

The number of units to install

Install a Site Part under another Site Part. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function InstallSitePartToPart( _
   ByVal _siteIDNum_ As String, _
   ByVal _parentSitePartObjid_ As Integer, _
   ByVal _partNumber_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _quantity_ As Integer _
) As ToolkitResult

public ToolkitResult InstallSitePartToPart(
   string _siteIDNum_,
   int _parentSitePartObjid_,
   string _partNumber_,
   string _partRevision_,
   string _partDomain_,
   int _quantity_
)

Parameters

siteIDNum

Identifier of the Site where the part will be installed.

parentSitePartObjid

Objid of the parent Site Part this Part will be installed under.

partNumber

Part Number of the part to install

partRevision

Part Revision of the part to install

partDomain

Domain of the part to install

quantity

The number of units to install

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the SitePart.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


InstallSitePartToPart(String,String,String,String,String) Method | fcSDK Documentation

InstallSitePartToPart(String,String,String,String,String) Method

Identifier of the Site where the part will be installed.

Part Number of the part to install

Part Revision of the part to install

Domain of the part to install

Serial number of the part installed

Install a Site Part under another Site Part. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function InstallSitePartToPart( _
   ByVal _siteIDNum_ As String, _
   ByVal _partNumber_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _serialNumber_ As String _
) As ToolkitResult

public ToolkitResult InstallSitePartToPart(
   string _siteIDNum_,
   string _partNumber_,
   string _partRevision_,
   string _partDomain_,
   string _serialNumber_
)

Parameters

siteIDNum

Identifier of the Site where the part will be installed.

partNumber

Part Number of the part to install

partRevision

Part Revision of the part to install

partDomain

Domain of the part to install

serialNumber

Serial number of the part installed

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the SitePart.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


InstallSitePartToPart(InstallSitePartToPartSetup) Method | fcSDK Documentation

InstallSitePartToPart(InstallSitePartToPartSetup) Method

Setup object for API invocation.

Install a Site Part under another Site Part. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function InstallSitePartToPart( _
   ByVal _setupParam_ InstallSitePartToPartSetup _
) As ToolkitResult

public ToolkitResult InstallSitePartToPart(
   InstallSitePartToPartSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the SitePart.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
InstallSitePartToPartSetup Class


InstallSitePartToPart(InstallSitePartToPartSetup,IDbTransaction) Method | fcSDK Documentation

InstallSitePartToPart(InstallSitePartToPartSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Install a Site Part under another Site Part. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function InstallSitePartToPart( _
   ByVal _setupParam_ As InstallSitePartToPartSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult InstallSitePartToPart(
   InstallSitePartToPartSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


InstallSitePartToSite Method | fcSDK Documentation

InstallSitePartToSite Method

Install a Site Part under a Site. This overload takes a set of required parameters for the API.

Install a Site Part under a Site.

Overload List

Overload | Description
InstallSitePartToSite(String,String,String,String,Int32) | Install a Site Part under a Site. This overload takes a set of required parameters for the API.
InstallSitePartToSite(String,String,String,String,String) | Install a Site Part under a Site. This overload takes a set of required parameters for the API.
InstallSitePartToSite(InstallSitePartToSiteSetup) | Install a Site Part under a Site. This overload takes a setup object.
InstallSitePartToSite(InstallSitePartToSiteSetup,IDbTransaction) | Install a Site Part under a Site. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
InstallSitePartToSiteSetup Class


InstallSitePartToSite(String,String,String,String,Int32) Method | fcSDK Documentation

InstallSitePartToSite(String,String,String,String,Int32) Method

Identifier of the Site where the part will be installed.

Part Number of the part to install

Part Revision of the part to install

Domain of the part to install

The number of units to install

Install a Site Part under a Site. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function InstallSitePartToSite( _
   ByVal _siteIDNum_ As String, _
   ByVal _partNumber_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _quantity_ As Integer _
) As ToolkitResult

public ToolkitResult InstallSitePartToSite(
   string _siteIDNum_,
   string _partNumber_,
   string _partRevision_,
   string _partDomain_,
   int _quantity_
)

Parameters

siteIDNum

Identifier of the Site where the part will be installed.

partNumber

Part Number of the part to install

partRevision

Part Revision of the part to install

partDomain

Domain of the part to install

quantity

The number of units to install

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the SitePart.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


InstallSitePartToSite(String,String,String,String,String) Method | fcSDK Documentation

InstallSitePartToSite(String,String,String,String,String) Method

Identifier of the Site where the part will be installed.

Part Number of the part to install

Part Revision of the part to install

Domain of the part to install

Serial number of the part installed

Install a Site Part under a Site. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function InstallSitePartToSite( _
   ByVal _siteIDNum_ As String, _
   ByVal _partNumber_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _serialNumber_ As String _
) As ToolkitResult

public ToolkitResult InstallSitePartToSite(
   string _siteIDNum_,
   string _partNumber_,
   string _partRevision_,
   string _partDomain_,
   string _serialNumber_
)

Parameters

siteIDNum

Identifier of the Site where the part will be installed.

partNumber

Part Number of the part to install

partRevision

Part Revision of the part to install

partDomain

Domain of the part to install

serialNumber

Serial number of the part installed

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the SitePart.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


InstallSitePartToSite(InstallSitePartToSiteSetup) Method | fcSDK Documentation

InstallSitePartToSite(InstallSitePartToSiteSetup) Method

Setup object for API invocation.

Install a Site Part under a Site. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function InstallSitePartToSite( _
   ByVal _setupParam_ InstallSitePartToSiteSetup _
) As ToolkitResult

public ToolkitResult InstallSitePartToSite(
   InstallSitePartToSiteSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the SitePart.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
InstallSitePartToSiteSetup Class


InstallSitePartToSite(InstallSitePartToSiteSetup,IDbTransaction) Method | fcSDK Documentation

InstallSitePartToSite(InstallSitePartToSiteSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Install a Site Part under a Site. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function InstallSitePartToSite( _
   ByVal _setupParam_ As InstallSitePartToSiteSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult InstallSitePartToSite(
   InstallSitePartToSiteSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


LinkCaseToWorkaround Method | fcSDK Documentation

LinkCaseToWorkaround Method

Link a Case to a Workaround. This overload takes a set of required parameters for the API.

Link a Case to a Workaround.

Overload List

Overload | Description
LinkCaseToWorkaround(String,Int32) | Link a Case to a Workaround. This overload takes a set of required parameters for the API.
LinkCaseToWorkaround(LinkCaseToWorkaroundSetup) | Link a Case to a Workaround. This overload takes a setup object.
LinkCaseToWorkaround(LinkCaseToWorkaroundSetup,IDbTransaction) | Link a Case to a Workaround. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
LinkCaseToWorkaroundSetup Class


LinkCaseToWorkaround(String,Int32) Method | fcSDK Documentation

LinkCaseToWorkaround(String,Int32) Method

Identifier of the Case to link to a Workaround

Objid of the Workaround the Case will be linked to

Link a Case to a Workaround. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function LinkCaseToWorkaround( _
   ByVal _caseIDNum_ As String, _
   ByVal _workaroundObjid_ As Integer _
) As ToolkitResult

public ToolkitResult LinkCaseToWorkaround(
   string _caseIDNum_,
   int _workaroundObjid_
)

Parameters

caseIDNum

Identifier of the Case to link to a Workaround

workaroundObjid

Objid of the Workaround the Case will be linked to

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Case.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


LinkCaseToWorkaround(LinkCaseToWorkaroundSetup) Method | fcSDK Documentation

LinkCaseToWorkaround(LinkCaseToWorkaroundSetup) Method

Setup object for API invocation.

Link a Case to a Workaround. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function LinkCaseToWorkaround( _
   ByVal _setupParam_ LinkCaseToWorkaroundSetup _
) As ToolkitResult

public ToolkitResult LinkCaseToWorkaround(
   LinkCaseToWorkaroundSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Case.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
LinkCaseToWorkaroundSetup Class


LinkCaseToWorkaround(LinkCaseToWorkaroundSetup,IDbTransaction) Method | fcSDK Documentation

LinkCaseToWorkaround(LinkCaseToWorkaroundSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Link a Case to a Workaround. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function LinkCaseToWorkaround( _
   ByVal _setupParam_ As LinkCaseToWorkaroundSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult LinkCaseToWorkaround(
   LinkCaseToWorkaroundSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


LinkCRToSolution Method | fcSDK Documentation

LinkCRToSolution Method

Link a CR to a Solution. This overload takes a set of required parameters for the API.

Link a CR to a Solution.

Overload List

Overload | Description
LinkCRToSolution(String,String) | Link a CR to a Solution. This overload takes a set of required parameters for the API.
LinkCRToSolution(LinkCRToSolutionSetup) | Link a CR to a Solution. This overload takes a setup object.
LinkCRToSolution(LinkCRToSolutionSetup,IDbTransaction) | Link a CR to a Solution. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
LinkCRToSolutionSetup Class


LinkCRToSolution(String,String) Method | fcSDK Documentation

LinkCRToSolution(String,String) Method

Identifier of the CR to link to the Solution

Identifier of the Solution to link to the CR

Link a CR to a Solution. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function LinkCRToSolution( _
   ByVal _crIDNum_ As String, _
   ByVal _solutionIDNum_ As String _
) As ToolkitResult

public ToolkitResult LinkCRToSolution(
   string _crIDNum_,
   string _solutionIDNum_
)

Parameters

crIDNum

Identifier of the CR to link to the Solution

solutionIDNum

Identifier of the Solution to link to the CR

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the CR.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


LinkCRToSolution(LinkCRToSolutionSetup) Method | fcSDK Documentation

LinkCRToSolution(LinkCRToSolutionSetup) Method

Setup object for API invocation.

Link a CR to a Solution. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function LinkCRToSolution( _
   ByVal _setupParam_ LinkCRToSolutionSetup _
) As ToolkitResult

public ToolkitResult LinkCRToSolution(
   LinkCRToSolutionSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the CR.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
LinkCRToSolutionSetup Class


LinkCRToSolution(LinkCRToSolutionSetup,IDbTransaction) Method | fcSDK Documentation

LinkCRToSolution(LinkCRToSolutionSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Link a CR to a Solution. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function LinkCRToSolution( _
   ByVal _setupParam_ As LinkCRToSolutionSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult LinkCRToSolution(
   LinkCRToSolutionSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


MoveSitePartToBin Method (InterfacesToolkit) | fcSDK Documentation

MoveSitePartToBin Method (InterfacesToolkit)

Move the SitePartToBin from one WipBin to another WipBin. This overload takes a set of required parameters for the API.

Move the SitePartToBin from one WipBin to another WipBin.

Overload List

Overload | Description
MoveSitePartToBin(Int32,Int32) | Move the SitePartToBin from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
MoveSitePartToBin(MoveSitePartToBinSetup) | Move the SitePartToBin from one WipBin to another WipBin. This overload takes a setup object.
MoveSitePartToBin(MoveSitePartToBinSetup,IDbTransaction) | Move the SitePartToBin from one WipBin to another WipBin. This overload takes a setup object and a database transaction.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the SitePartToBin, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
MoveSitePartToBinSetup Class


MoveSitePartToBin(Int32,Int32) Method | fcSDK Documentation

MoveSitePartToBin(Int32,Int32) Method

Objid of the Site Part to be moved

Objid of the Bin to place the Site Part into

Move the SitePartToBin from one WipBin to another WipBin. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function MoveSitePartToBin( _
   ByVal _sitePartObjid_ As Integer, _
   ByVal _parentBinObjid_ As Integer _
) As ToolkitResult

public ToolkitResult MoveSitePartToBin(
   int _sitePartObjid_,
   int _parentBinObjid_
)

Parameters

sitePartObjid

Objid of the Site Part to be moved

parentBinObjid

Objid of the Bin to place the Site Part into

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the SitePartToBin, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


MoveSitePartToBin(MoveSitePartToBinSetup) Method | fcSDK Documentation

MoveSitePartToBin(MoveSitePartToBinSetup) Method

Setup object for API invocation.

Move the SitePartToBin from one WipBin to another WipBin. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function MoveSitePartToBin( _
   ByVal _setupParam_ MoveSitePartToBinSetup _
) As ToolkitResult

public ToolkitResult MoveSitePartToBin(
   MoveSitePartToBinSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the SitePartToBin, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
MoveSitePartToBinSetup Class


MoveSitePartToBin(MoveSitePartToBinSetup,IDbTransaction) Method | fcSDK Documentation

MoveSitePartToBin(MoveSitePartToBinSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Move the SitePartToBin from one WipBin to another WipBin. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function MoveSitePartToBin( _
   ByVal _setupParam_ As MoveSitePartToBinSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult MoveSitePartToBin(
   MoveSitePartToBinSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the SitePartToBin, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


MoveSitePartToPart Method (InterfacesToolkit) | fcSDK Documentation

MoveSitePartToPart Method (InterfacesToolkit)

Move the SitePartToPart from one WipBin to another WipBin. This overload takes a set of required parameters for the API.

Move the SitePartToPart from one WipBin to another WipBin.

Overload List

Overload | Description
MoveSitePartToPart(Int32,Int32) | Move the SitePartToPart from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
MoveSitePartToPart(MoveSitePartToPartSetup) | Move the SitePartToPart from one WipBin to another WipBin. This overload takes a setup object.
MoveSitePartToPart(MoveSitePartToPartSetup,IDbTransaction) | Move the SitePartToPart from one WipBin to another WipBin. This overload takes a setup object and a database transaction.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the SitePartToPart, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
MoveSitePartToPartSetup Class


MoveSitePartToPart(Int32,Int32) Method | fcSDK Documentation

MoveSitePartToPart(Int32,Int32) Method

Objid of the Site Part to be moved

Objid of the parent Site Part this Site Part will be placed into

Move the SitePartToPart from one WipBin to another WipBin. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function MoveSitePartToPart( _
   ByVal _sitePartObjid_ As Integer, _
   ByVal _parentSitePartObjid_ As Integer _
) As ToolkitResult

public ToolkitResult MoveSitePartToPart(
   int _sitePartObjid_,
   int _parentSitePartObjid_
)

Parameters

sitePartObjid

Objid of the Site Part to be moved

parentSitePartObjid

Objid of the parent Site Part this Site Part will be placed into

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the SitePartToPart, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


MoveSitePartToPart(MoveSitePartToPartSetup) Method | fcSDK Documentation

MoveSitePartToPart(MoveSitePartToPartSetup) Method

Setup object for API invocation.

Move the SitePartToPart from one WipBin to another WipBin. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function MoveSitePartToPart( _
   ByVal _setupParam_ MoveSitePartToPartSetup _
) As ToolkitResult

public ToolkitResult MoveSitePartToPart(
   MoveSitePartToPartSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the SitePartToPart, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
MoveSitePartToPartSetup Class


MoveSitePartToPart(MoveSitePartToPartSetup,IDbTransaction) Method | fcSDK Documentation

MoveSitePartToPart(MoveSitePartToPartSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Move the SitePartToPart from one WipBin to another WipBin. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function MoveSitePartToPart( _
   ByVal _setupParam_ As MoveSitePartToPartSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult MoveSitePartToPart(
   MoveSitePartToPartSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the SitePartToPart, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


MoveSitePartToSite Method (InterfacesToolkit) | fcSDK Documentation

MoveSitePartToSite Method (InterfacesToolkit)

Move the SitePartToSite from one WipBin to another WipBin. This overload takes a set of required parameters for the API.

Move the SitePartToSite from one WipBin to another WipBin.

Overload List

Overload | Description
MoveSitePartToSite(Int32,String) | Move the SitePartToSite from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
MoveSitePartToSite(MoveSitePartToSiteSetup) | Move the SitePartToSite from one WipBin to another WipBin. This overload takes a setup object.
MoveSitePartToSite(MoveSitePartToSiteSetup,IDbTransaction) | Move the SitePartToSite from one WipBin to another WipBin. This overload takes a setup object and a database transaction.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the SitePartToSite, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
MoveSitePartToSiteSetup Class


MoveSitePartToSite(Int32,String) Method | fcSDK Documentation

MoveSitePartToSite(Int32,String) Method

Objid of the Site Part to be moved

Identifier of the parent Site the Site Part is being moved under

Move the SitePartToSite from one WipBin to another WipBin. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function MoveSitePartToSite( _
   ByVal _sitePartObjid_ As Integer, _
   ByVal _parentSiteIDNum_ As String _
) As ToolkitResult

public ToolkitResult MoveSitePartToSite(
   int _sitePartObjid_,
   string _parentSiteIDNum_
)

Parameters

sitePartObjid

Objid of the Site Part to be moved

parentSiteIDNum

Identifier of the parent Site the Site Part is being moved under

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the SitePartToSite, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


MoveSitePartToSite(MoveSitePartToSiteSetup) Method | fcSDK Documentation

MoveSitePartToSite(MoveSitePartToSiteSetup) Method

Setup object for API invocation.

Move the SitePartToSite from one WipBin to another WipBin. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function MoveSitePartToSite( _
   ByVal _setupParam_ MoveSitePartToSiteSetup _
) As ToolkitResult

public ToolkitResult MoveSitePartToSite(
   MoveSitePartToSiteSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the SitePartToSite, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
MoveSitePartToSiteSetup Class


MoveSitePartToSite(MoveSitePartToSiteSetup,IDbTransaction) Method | fcSDK Documentation

MoveSitePartToSite(MoveSitePartToSiteSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Move the SitePartToSite from one WipBin to another WipBin. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function MoveSitePartToSite( _
   ByVal _setupParam_ As MoveSitePartToSiteSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult MoveSitePartToSite(
   MoveSitePartToSiteSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the SitePartToSite, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


MoveSolution Method | fcSDK Documentation

MoveSolution Method

Move the Solution from one WipBin to another WipBin. This overload takes a set of required parameters for the API.

Move the Solution from one WipBin to another WipBin.

Overload List

Overload | Description
MoveSolution(String,String) | Move the Solution from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
MoveSolution(MoveSolutionSetup) | Move the Solution from one WipBin to another WipBin. This overload takes a setup object.
MoveSolution(MoveSolutionSetup,IDbTransaction) | Move the Solution from one WipBin to another WipBin. This overload takes a setup object and a database transaction.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the Solution, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
MoveSolutionSetup Class


MoveSolution(String,String) Method | fcSDK Documentation

MoveSolution(String,String) Method

Solution Identifier.

The new WipBin into which the Solution is to be moved.

Move the Solution from one WipBin to another WipBin. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function MoveSolution( _
   ByVal _solutionIDNum_ As String, _
   ByVal _newWipBin_ As String _
) As ToolkitResult

public ToolkitResult MoveSolution(
   string _solutionIDNum_,
   string _newWipBin_
)

Parameters

solutionIDNum

Solution Identifier.

newWipBin

The new WipBin into which the Solution is to be moved.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the Solution, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


MoveSolution(MoveSolutionSetup) Method | fcSDK Documentation

MoveSolution(MoveSolutionSetup) Method

Setup object for API invocation.

Move the Solution from one WipBin to another WipBin. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function MoveSolution( _
   ByVal _setupParam_ MoveSolutionSetup _
) As ToolkitResult

public ToolkitResult MoveSolution(
   MoveSolutionSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the Solution, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
MoveSolutionSetup Class


MoveSolution(MoveSolutionSetup,IDbTransaction) Method | fcSDK Documentation

MoveSolution(MoveSolutionSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Move the Solution from one WipBin to another WipBin. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function MoveSolution( _
   ByVal _setupParam_ As MoveSolutionSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult MoveSolution(
   MoveSolutionSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the Solution, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


ReinstallSitePartToBin Method | fcSDK Documentation

ReinstallSitePartToBin Method

Re-Install a Site Part under a Product Bin. This overload takes a set of required parameters for the API.

Re-Install a Site Part under a Product Bin.

Overload List

Overload | Description
ReinstallSitePartToBin(Int32,String,Int32) | Re-Install a Site Part under a Product Bin. This overload takes a set of required parameters for the API.
ReinstallSitePartToBin(ReinstallSitePartToBinSetup) | Re-Install a Site Part under a Product Bin. This overload takes a setup object.
ReinstallSitePartToBin(ReinstallSitePartToBinSetup,IDbTransaction) | Re-Install a Site Part under a Product Bin. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
ReinstallSitePartToBinSetup Class


ReinstallSitePartToBin(Int32,String,Int32) Method | fcSDK Documentation

ReinstallSitePartToBin(Int32,String,Int32) Method

Objid of the Site Part being re-installed

Identifier of the Site where the Site Part will be re-installed

Objid of the parent Bin this Part will be re-installed under.

Re-Install a Site Part under a Product Bin. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function ReinstallSitePartToBin( _
   ByVal _sitePartObjid_ As Integer, _
   ByVal _siteIDNum_ As String, _
   ByVal _parentBinObjid_ As Integer _
) As ToolkitResult

public ToolkitResult ReinstallSitePartToBin(
   int _sitePartObjid_,
   string _siteIDNum_,
   int _parentBinObjid_
)

Parameters

sitePartObjid

Objid of the Site Part being re-installed

siteIDNum

Identifier of the Site where the Site Part will be re-installed

parentBinObjid

Objid of the parent Bin this Part will be re-installed under.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


ReinstallSitePartToBin(ReinstallSitePartToBinSetup) Method | fcSDK Documentation

ReinstallSitePartToBin(ReinstallSitePartToBinSetup) Method

Setup object for API invocation.

Re-Install a Site Part under a Product Bin. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function ReinstallSitePartToBin( _
   ByVal _setupParam_ ReinstallSitePartToBinSetup _
) As ToolkitResult

public ToolkitResult ReinstallSitePartToBin(
   ReinstallSitePartToBinSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
ReinstallSitePartToBinSetup Class


ReinstallSitePartToBin(ReinstallSitePartToBinSetup,IDbTransaction) Method | fcSDK Documentation

ReinstallSitePartToBin(ReinstallSitePartToBinSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Re-Install a Site Part under a Product Bin. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function ReinstallSitePartToBin( _
   ByVal _setupParam_ As ReinstallSitePartToBinSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult ReinstallSitePartToBin(
   ReinstallSitePartToBinSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


ReinstallSitePartToPart Method | fcSDK Documentation

ReinstallSitePartToPart Method

Re-Install a Site Part under another Site Part. This overload takes a set of required parameters for the API.

Re-Install a Site Part under another Site Part.

Overload List

Overload | Description
ReinstallSitePartToPart(Int32,String,Int32) | Re-Install a Site Part under another Site Part. This overload takes a set of required parameters for the API.
ReinstallSitePartToPart(ReinstallSitePartToPartSetup) | Re-Install a Site Part under another Site Part. This overload takes a setup object.
ReinstallSitePartToPart(ReinstallSitePartToPartSetup,IDbTransaction) | Re-Install a Site Part under another Site Part. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
ReinstallSitePartToPartSetup Class


ReinstallSitePartToPart(Int32,String,Int32) Method | fcSDK Documentation

ReinstallSitePartToPart(Int32,String,Int32) Method

Objid of the Site Part being re-installed

Identifier of the Site where the Site Part will be re-installed

Objid of the parent Site Part this Part will be re-installed under.

Re-Install a Site Part under another Site Part. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function ReinstallSitePartToPart( _
   ByVal _sitePartObjid_ As Integer, _
   ByVal _siteIDNum_ As String, _
   ByVal _parentSitePartObjid_ As Integer _
) As ToolkitResult

public ToolkitResult ReinstallSitePartToPart(
   int _sitePartObjid_,
   string _siteIDNum_,
   int _parentSitePartObjid_
)

Parameters

sitePartObjid

Objid of the Site Part being re-installed

siteIDNum

Identifier of the Site where the Site Part will be re-installed

parentSitePartObjid

Objid of the parent Site Part this Part will be re-installed under.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


ReinstallSitePartToPart(ReinstallSitePartToPartSetup) Method | fcSDK Documentation

ReinstallSitePartToPart(ReinstallSitePartToPartSetup) Method

Setup object for API invocation.

Re-Install a Site Part under another Site Part. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function ReinstallSitePartToPart( _
   ByVal _setupParam_ ReinstallSitePartToPartSetup _
) As ToolkitResult

public ToolkitResult ReinstallSitePartToPart(
   ReinstallSitePartToPartSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
ReinstallSitePartToPartSetup Class


ReinstallSitePartToPart(ReinstallSitePartToPartSetup,IDbTransaction) Method | fcSDK Documentation

ReinstallSitePartToPart(ReinstallSitePartToPartSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Re-Install a Site Part under another Site Part. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function ReinstallSitePartToPart( _
   ByVal _setupParam_ As ReinstallSitePartToPartSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult ReinstallSitePartToPart(
   ReinstallSitePartToPartSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


ReinstallSitePartToSite Method | fcSDK Documentation

ReinstallSitePartToSite Method

Re-Install a Site Part under a Site. This overload takes a set of required parameters for the API.

Re-Install a Site Part under a Site.

Overload List

Overload | Description
ReinstallSitePartToSite(Int32,String) | Re-Install a Site Part under a Site. This overload takes a set of required parameters for the API.
ReinstallSitePartToSite(ReinstallSitePartToSiteSetup) | Re-Install a Site Part under a Site. This overload takes a setup object.
ReinstallSitePartToSite(ReinstallSitePartToSiteSetup,IDbTransaction) | Re-Install a Site Part under a Site. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
ReinstallSitePartToSiteSetup Class


ReinstallSitePartToSite(Int32,String) Method | fcSDK Documentation

ReinstallSitePartToSite(Int32,String) Method

Objid of the Site Part being re-installed

Identifier of the Site where the Site Part will be re-installed

Re-Install a Site Part under a Site. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function ReinstallSitePartToSite( _
   ByVal _sitePartObjid_ As Integer, _
   ByVal _siteIDNum_ As String _
) As ToolkitResult

public ToolkitResult ReinstallSitePartToSite(
   int _sitePartObjid_,
   string _siteIDNum_
)

Parameters

sitePartObjid

Objid of the Site Part being re-installed

siteIDNum

Identifier of the Site where the Site Part will be re-installed

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


ReinstallSitePartToSite(ReinstallSitePartToSiteSetup) Method | fcSDK Documentation

ReinstallSitePartToSite(ReinstallSitePartToSiteSetup) Method

Setup object for API invocation.

Re-Install a Site Part under a Site. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function ReinstallSitePartToSite( _
   ByVal _setupParam_ ReinstallSitePartToSiteSetup _
) As ToolkitResult

public ToolkitResult ReinstallSitePartToSite(
   ReinstallSitePartToSiteSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
ReinstallSitePartToSiteSetup Class


ReinstallSitePartToSite(ReinstallSitePartToSiteSetup,IDbTransaction) Method | fcSDK Documentation

ReinstallSitePartToSite(ReinstallSitePartToSiteSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Re-Install a Site Part under a Site. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function ReinstallSitePartToSite( _
   ByVal _setupParam_ As ReinstallSitePartToSiteSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult ReinstallSitePartToSite(
   ReinstallSitePartToSiteSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


RejectSolution Method | fcSDK Documentation

RejectSolution Method

Reject the Solution from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.

Reject the Solution from the queue in which it currently resides, and return it to the owner.

Overload List

Overload | Description
RejectSolution(String) | Reject the Solution from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.
RejectSolution(RejectSolutionSetup) | Reject the Solution from the queue in which it currently resides, and return it to the owner. This overload takes a setup object.
RejectSolution(RejectSolutionSetup,IDbTransaction) | Reject the Solution from the queue in which it currently resides, and return it to the owner. This overload takes a setup object and a database transaction.

Remarks

The Solution must be in open condition, and currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
RejectSolutionSetup Class


RejectSolution(String) Method | fcSDK Documentation

RejectSolution(String) Method

Solution Identifier.

Reject the Solution from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function RejectSolution( _
   ByVal _solutionIDNum_ As String _
) As ToolkitResult

public ToolkitResult RejectSolution(
   string _solutionIDNum_
)

Parameters

solutionIDNum

Solution Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Solution must be in open condition, and currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


RejectSolution(RejectSolutionSetup) Method | fcSDK Documentation

RejectSolution(RejectSolutionSetup) Method

Setup object for API invocation.

Reject the Solution from the queue in which it currently resides, and return it to the owner. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function RejectSolution( _
   ByVal _setupParam_ RejectSolutionSetup _
) As ToolkitResult

public ToolkitResult RejectSolution(
   RejectSolutionSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Solution must be in open condition, and currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
RejectSolutionSetup Class


RejectSolution(RejectSolutionSetup,IDbTransaction) Method | fcSDK Documentation

RejectSolution(RejectSolutionSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Reject the Solution from the queue in which it currently resides, and return it to the owner. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function RejectSolution( _
   ByVal _setupParam_ As RejectSolutionSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult RejectSolution(
   RejectSolutionSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Solution must be in open condition, and currently dispatched to a queue.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


RemoveContactFromContract Method | fcSDK Documentation

RemoveContactFromContract Method

Overload List

Overload | Description
RemoveContactFromContract(String,Int32) |
RemoveContactFromContract(RemoveContactFromContractSetup) |
RemoveContactFromContract(RemoveContactFromContractSetup,IDbTransaction) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members


RemoveContactFromContract(String,Int32) Method | fcSDK Documentation

RemoveContactFromContract(String,Int32) Method

Syntax

'Declaration

Public Overloads Function RemoveContactFromContract( _
   ByVal _contractIDNum_ As String, _
   ByVal _contactObjid_ As Integer _
) As ToolkitResult

public ToolkitResult RemoveContactFromContract(
   string _contractIDNum_,
   int _contactObjid_
)

Parameters

contractIDNum

contactObjid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


RemoveContactFromContract(RemoveContactFromContractSetup) Method | fcSDK Documentation

RemoveContactFromContract(RemoveContactFromContractSetup) Method

Syntax

'Declaration

Public Overloads Function RemoveContactFromContract( _
   ByVal _setupParam_ RemoveContactFromContractSetup _
) As ToolkitResult

public ToolkitResult RemoveContactFromContract(
   RemoveContactFromContractSetup _setupParam_
)

Parameters

setupParam

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


RemoveContactFromContract(RemoveContactFromContractSetup,IDbTransaction) Method | fcSDK Documentation

RemoveContactFromContract(RemoveContactFromContractSetup,IDbTransaction) Method

Syntax

'Declaration

Public Overloads Function RemoveContactFromContract( _
   ByVal _setupParam_ As RemoveContactFromContractSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult RemoveContactFromContract(
   RemoveContactFromContractSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

transaction

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


RemoveEmployeeFromAccount Method | fcSDK Documentation

RemoveEmployeeFromAccount Method

Remove an Employee from an Account. This overload takes a set of required parameters for the API.

Remove an Employee from an Account.

Overload List

Overload | Description
RemoveEmployeeFromAccount(String,String,String) | Remove an Employee from an Account. This overload takes a set of required parameters for the API.
RemoveEmployeeFromAccount(RemoveEmployeeFromAccountSetup) | Remove an Employee from an Account. This overload takes a setup object.
RemoveEmployeeFromAccount(RemoveEmployeeFromAccountSetup,IDbTransaction) | Remove an Employee from an Account. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
RemoveEmployeeFromAccountSetup Class


RemoveEmployeeFromAccount(String,String,String) Method | fcSDK Documentation

RemoveEmployeeFromAccount(String,String,String) Method

Username of the Employee to be removed from the Account.

Identifier for the Account the Employee will be removed from.

Employee Role to be removing from the Account

Remove an Employee from an Account. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function RemoveEmployeeFromAccount( _
   ByVal _userName_ As String, _
   ByVal _accountIDNum_ As String, _
   ByVal _roleName_ As String _
) As ToolkitResult

public ToolkitResult RemoveEmployeeFromAccount(
   string _userName_,
   string _accountIDNum_,
   string _roleName_
)

Parameters

userName

Username of the Employee to be removed from the Account.

accountIDNum

Identifier for the Account the Employee will be removed from.

roleName

Employee Role to be removing from the Account

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


RemoveEmployeeFromAccount(RemoveEmployeeFromAccountSetup) Method | fcSDK Documentation

RemoveEmployeeFromAccount(RemoveEmployeeFromAccountSetup) Method

Setup object for API invocation.

Remove an Employee from an Account. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function RemoveEmployeeFromAccount( _
   ByVal _setupParam_ RemoveEmployeeFromAccountSetup _
) As ToolkitResult

public ToolkitResult RemoveEmployeeFromAccount(
   RemoveEmployeeFromAccountSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
RemoveEmployeeFromAccountSetup Class


RemoveEmployeeFromAccount(RemoveEmployeeFromAccountSetup,IDbTransaction) Method | fcSDK Documentation

RemoveEmployeeFromAccount(RemoveEmployeeFromAccountSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Remove an Employee from an Account. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function RemoveEmployeeFromAccount( _
   ByVal _setupParam_ As RemoveEmployeeFromAccountSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult RemoveEmployeeFromAccount(
   RemoveEmployeeFromAccountSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


RemoveSiteFromAccount Method | fcSDK Documentation

RemoveSiteFromAccount Method

Remove a Site from an Account. This overload takes a set of required parameters for the API.

Remove a Site from an Account.

Overload List

Overload | Description
RemoveSiteFromAccount(String,String,String) | Remove a Site from an Account. This overload takes a set of required parameters for the API.
RemoveSiteFromAccount(RemoveSiteFromAccountSetup) | Remove a Site from an Account. This overload takes a setup object.
RemoveSiteFromAccount(RemoveSiteFromAccountSetup,IDbTransaction) | Remove a Site from an Account. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
RemoveSiteFromAccountSetup Class


RemoveSiteFromAccount(String,String,String) Method | fcSDK Documentation

RemoveSiteFromAccount(String,String,String) Method

Identifier of the Site being removed from the Account

Identifier for the Account the Site will be removed from.

Name of the Site's role being removed from the Account

Remove a Site from an Account. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function RemoveSiteFromAccount( _
   ByVal _siteIDNum_ As String, _
   ByVal _accountIDNum_ As String, _
   ByVal _roleName_ As String _
) As ToolkitResult

public ToolkitResult RemoveSiteFromAccount(
   string _siteIDNum_,
   string _accountIDNum_,
   string _roleName_
)

Parameters

siteIDNum

Identifier of the Site being removed from the Account

accountIDNum

Identifier for the Account the Site will be removed from.

roleName

Name of the Site's role being removed from the Account

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


RemoveSiteFromAccount(RemoveSiteFromAccountSetup) Method | fcSDK Documentation

RemoveSiteFromAccount(RemoveSiteFromAccountSetup) Method

Setup object for API invocation.

Remove a Site from an Account. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function RemoveSiteFromAccount( _
   ByVal _setupParam_ RemoveSiteFromAccountSetup _
) As ToolkitResult

public ToolkitResult RemoveSiteFromAccount(
   RemoveSiteFromAccountSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
RemoveSiteFromAccountSetup Class


RemoveSiteFromAccount(RemoveSiteFromAccountSetup,IDbTransaction) Method | fcSDK Documentation

RemoveSiteFromAccount(RemoveSiteFromAccountSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Remove a Site from an Account. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function RemoveSiteFromAccount( _
   ByVal _setupParam_ As RemoveSiteFromAccountSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult RemoveSiteFromAccount(
   RemoveSiteFromAccountSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


RemoveSiteFromContract Method | fcSDK Documentation

RemoveSiteFromContract Method

Overload List

Overload | Description
RemoveSiteFromContract(String,String) |
RemoveSiteFromContract(RemoveSiteFromContractSetup) |
RemoveSiteFromContract(RemoveSiteFromContractSetup,IDbTransaction) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members


RemoveSiteFromContract(String,String) Method | fcSDK Documentation

RemoveSiteFromContract(String,String) Method

Syntax

'Declaration

Public Overloads Function RemoveSiteFromContract( _
   ByVal _contractIDNum_ As String, _
   ByVal _siteIDNum_ As String _
) As ToolkitResult

public ToolkitResult RemoveSiteFromContract(
   string _contractIDNum_,
   string _siteIDNum_
)

Parameters

contractIDNum

siteIDNum

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


RemoveSiteFromContract(RemoveSiteFromContractSetup) Method | fcSDK Documentation

RemoveSiteFromContract(RemoveSiteFromContractSetup) Method

Syntax

'Declaration

Public Overloads Function RemoveSiteFromContract( _
   ByVal _setupParam_ RemoveSiteFromContractSetup _
) As ToolkitResult

public ToolkitResult RemoveSiteFromContract(
   RemoveSiteFromContractSetup _setupParam_
)

Parameters

setupParam

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


RemoveSiteFromContract(RemoveSiteFromContractSetup,IDbTransaction) Method | fcSDK Documentation

RemoveSiteFromContract(RemoveSiteFromContractSetup,IDbTransaction) Method

Syntax

'Declaration

Public Overloads Function RemoveSiteFromContract( _
   ByVal _setupParam_ As RemoveSiteFromContractSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult RemoveSiteFromContract(
   RemoveSiteFromContractSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

transaction

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


RemoveSitePartFromContract Method | fcSDK Documentation

RemoveSitePartFromContract Method

Overload List

Overload | Description
RemoveSitePartFromContract(String,Int32) |
RemoveSitePartFromContract(RemoveSitePartFromContractSetup) |
RemoveSitePartFromContract(RemoveSitePartFromContractSetup,IDbTransaction) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members


RemoveSitePartFromContract(String,Int32) Method | fcSDK Documentation

RemoveSitePartFromContract(String,Int32) Method

Syntax

'Declaration

Public Overloads Function RemoveSitePartFromContract( _
   ByVal _contractIDNum_ As String, _
   ByVal _sitePartObjid_ As Integer _
) As ToolkitResult

public ToolkitResult RemoveSitePartFromContract(
   string _contractIDNum_,
   int _sitePartObjid_
)

Parameters

contractIDNum

sitePartObjid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


RemoveSitePartFromContract(RemoveSitePartFromContractSetup) Method | fcSDK Documentation

RemoveSitePartFromContract(RemoveSitePartFromContractSetup) Method

Syntax

'Declaration

Public Overloads Function RemoveSitePartFromContract( _
   ByVal _setupParam_ RemoveSitePartFromContractSetup _
) As ToolkitResult

public ToolkitResult RemoveSitePartFromContract(
   RemoveSitePartFromContractSetup _setupParam_
)

Parameters

setupParam

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


RemoveSitePartFromContract(RemoveSitePartFromContractSetup,IDbTransaction) Method | fcSDK Documentation

RemoveSitePartFromContract(RemoveSitePartFromContractSetup,IDbTransaction) Method

Syntax

'Declaration

Public Overloads Function RemoveSitePartFromContract( _
   ByVal _setupParam_ As RemoveSitePartFromContractSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult RemoveSitePartFromContract(
   RemoveSitePartFromContractSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

transaction

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


ReopenDialogue Method | fcSDK Documentation

ReopenDialogue Method

Overload List

Overload | Description
ReopenDialogue(String) |
ReopenDialogue(ReopenDialogueSetup) |
ReopenDialogue(ReopenDialogueSetup,IDbTransaction) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members


ReopenDialogue(String) Method | fcSDK Documentation

ReopenDialogue(String) Method

Syntax

'Declaration

Public Overloads Function ReopenDialogue( _
   ByVal _idNumber_ As String _
) As ToolkitResult

public ToolkitResult ReopenDialogue(
   string _idNumber_
)

Parameters

idNumber

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


ReopenDialogue(ReopenDialogueSetup) Method | fcSDK Documentation

ReopenDialogue(ReopenDialogueSetup) Method

Syntax

'Declaration

Public Overloads Function ReopenDialogue( _
   ByVal _reopenDialogueSetup_ ReopenDialogueSetup _
) As ToolkitResult

public ToolkitResult ReopenDialogue(
   ReopenDialogueSetup _reopenDialogueSetup_
)

Parameters

reopenDialogueSetup

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


ReopenDialogue(ReopenDialogueSetup,IDbTransaction) Method | fcSDK Documentation

ReopenDialogue(ReopenDialogueSetup,IDbTransaction) Method

Syntax

'Declaration

Public Overloads Function ReopenDialogue( _
   ByVal _setup_ As ReopenDialogueSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult ReopenDialogue(
   ReopenDialogueSetup _setup_,
   IDbTransaction _transaction_
)

Parameters

setup

transaction

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


UnlinkCaseFromWorkaround Method | fcSDK Documentation

UnlinkCaseFromWorkaround Method

Unlink Case from Workaround. This overload takes a set of required parameters for the API.

Unlink Case from Workaround.

Overload List

Overload | Description
UnlinkCaseFromWorkaround(String) | Unlink Case from Workaround. This overload takes a set of required parameters for the API.
UnlinkCaseFromWorkaround(UnlinkCaseFromWorkaroundSetup) | Unlink Case from Workaround. This overload takes a setup object.
UnlinkCaseFromWorkaround(UnlinkCaseFromWorkaroundSetup,IDbTransaction) | Unlink Case from Workaround. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
UnlinkCaseFromWorkaroundSetup Class


UnlinkCaseFromWorkaround(String) Method | fcSDK Documentation

UnlinkCaseFromWorkaround(String) Method

Identifier of the Case to unlink from the Workaround

Unlink Case from Workaround. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function UnlinkCaseFromWorkaround( _
   ByVal _caseIDNum_ As String _
) As ToolkitResult

public ToolkitResult UnlinkCaseFromWorkaround(
   string _caseIDNum_
)

Parameters

caseIDNum

Identifier of the Case to unlink from the Workaround

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Workaround.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


UnlinkCaseFromWorkaround(UnlinkCaseFromWorkaroundSetup) Method | fcSDK Documentation

UnlinkCaseFromWorkaround(UnlinkCaseFromWorkaroundSetup) Method

Setup object for API invocation.

Unlink Case from Workaround. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function UnlinkCaseFromWorkaround( _
   ByVal _setupParam_ UnlinkCaseFromWorkaroundSetup _
) As ToolkitResult

public ToolkitResult UnlinkCaseFromWorkaround(
   UnlinkCaseFromWorkaroundSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Workaround.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
UnlinkCaseFromWorkaroundSetup Class


UnlinkCaseFromWorkaround(UnlinkCaseFromWorkaroundSetup,IDbTransaction) Method | fcSDK Documentation

UnlinkCaseFromWorkaround(UnlinkCaseFromWorkaroundSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Unlink Case from Workaround. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UnlinkCaseFromWorkaround( _
   ByVal _setupParam_ As UnlinkCaseFromWorkaroundSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UnlinkCaseFromWorkaround(
   UnlinkCaseFromWorkaroundSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


UnlinkCRFromSolution Method | fcSDK Documentation

UnlinkCRFromSolution Method

Unlink CR from Solution. This overload takes a set of required parameters for the API.

Unlink CR from Solution.

Overload List

Overload | Description
UnlinkCRFromSolution(String,String) | Unlink CR from Solution. This overload takes a set of required parameters for the API.
UnlinkCRFromSolution(UnlinkCRFromSolutionSetup) | Unlink CR from Solution. This overload takes a setup object.
UnlinkCRFromSolution(UnlinkCRFromSolutionSetup,IDbTransaction) | Unlink CR from Solution. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
UnlinkCRFromSolutionSetup Class


UnlinkCRFromSolution(String,String) Method | fcSDK Documentation

UnlinkCRFromSolution(String,String) Method

Identifier of the CR to unlink from the Solution

Identifier of the Solution to unlink from the CR

Unlink CR from Solution. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function UnlinkCRFromSolution( _
   ByVal _crIDNum_ As String, _
   ByVal _solutionIDNum_ As String _
) As ToolkitResult

public ToolkitResult UnlinkCRFromSolution(
   string _crIDNum_,
   string _solutionIDNum_
)

Parameters

crIDNum

Identifier of the CR to unlink from the Solution

solutionIDNum

Identifier of the Solution to unlink from the CR

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the CR.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


UnlinkCRFromSolution(UnlinkCRFromSolutionSetup) Method | fcSDK Documentation

UnlinkCRFromSolution(UnlinkCRFromSolutionSetup) Method

Setup object for API invocation.

Unlink CR from Solution. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function UnlinkCRFromSolution( _
   ByVal _setupParam_ UnlinkCRFromSolutionSetup _
) As ToolkitResult

public ToolkitResult UnlinkCRFromSolution(
   UnlinkCRFromSolutionSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the CR.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
UnlinkCRFromSolutionSetup Class


UnlinkCRFromSolution(UnlinkCRFromSolutionSetup,IDbTransaction) Method | fcSDK Documentation

UnlinkCRFromSolution(UnlinkCRFromSolutionSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Unlink CR from Solution. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UnlinkCRFromSolution( _
   ByVal _setupParam_ As UnlinkCRFromSolutionSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UnlinkCRFromSolution(
   UnlinkCRFromSolutionSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


UpdateAccount Method | fcSDK Documentation

UpdateAccount Method

Update an Account. This overload takes a setup object.

Update an Account.

Overload List

Overload | Description
UpdateAccount(UpdateAccountSetup) | Update an Account. This overload takes a setup object.
UpdateAccount(UpdateAccountSetup,IDbTransaction) | Update an Account. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
UpdateAccountSetup Class


UpdateAccount(UpdateAccountSetup) Method | fcSDK Documentation

UpdateAccount(UpdateAccountSetup) Method

Setup object for API invocation.

Update an Account. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function UpdateAccount( _
   ByVal _setupParam_ UpdateAccountSetup _
) As ToolkitResult

public ToolkitResult UpdateAccount(
   UpdateAccountSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • IDNum - The IDNum of the Account.
  • Objid - The Objid of the Account.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
UpdateAccountSetup Class


UpdateAccount(UpdateAccountSetup,IDbTransaction) Method | fcSDK Documentation

UpdateAccount(UpdateAccountSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Update an Account. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdateAccount( _
   ByVal _setupParam_ As UpdateAccountSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdateAccount(
   UpdateAccountSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


UpdateAddress Method | fcSDK Documentation

UpdateAddress Method

Update an Address. This overload takes a setup object.

Update an Address.

Overload List

Overload | Description
UpdateAddress(UpdateAddressSetup) | Update an Address. This overload takes a setup object.
UpdateAddress(UpdateAddressSetup,IDbTransaction) | Update an Address. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
UpdateAddressSetup Class


UpdateAddress(UpdateAddressSetup) Method | fcSDK Documentation

UpdateAddress(UpdateAddressSetup) Method

Setup object for API invocation.

Update an Address. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function UpdateAddress( _
   ByVal _setupParam_ UpdateAddressSetup _
) As ToolkitResult

public ToolkitResult UpdateAddress(
   UpdateAddressSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
UpdateAddressSetup Class


UpdateAddress(UpdateAddressSetup,IDbTransaction) Method | fcSDK Documentation

UpdateAddress(UpdateAddressSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Update an Address. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdateAddress( _
   ByVal _setupParam_ As UpdateAddressSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdateAddress(
   UpdateAddressSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


UpdateCommunication Method | fcSDK Documentation

UpdateCommunication Method

Update a Communication.

Update a Communication.

Overload List

Overload | Description
UpdateCommunication(UpdateCommunicationSetup) | Update a Communication.
UpdateCommunication(UpdateCommunicationSetup,IDbTransaction) | Update a Communication.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members


UpdateCommunication(UpdateCommunicationSetup) Method | fcSDK Documentation

UpdateCommunication(UpdateCommunicationSetup) Method

Setup object for API invocation.

Update a Communication.

Syntax

'Declaration

Public Overloads Function UpdateCommunication( _
   ByVal _updateCommunicationSetup_ UpdateCommunicationSetup _
) As ToolkitResult

public ToolkitResult UpdateCommunication(
   UpdateCommunicationSetup _updateCommunicationSetup_
)

Parameters

updateCommunicationSetup

Setup object for API invocation.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


UpdateCommunication(UpdateCommunicationSetup,IDbTransaction) Method | fcSDK Documentation

UpdateCommunication(UpdateCommunicationSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Update a Communication.

Syntax

'Declaration

Public Overloads Function UpdateCommunication( _
   ByVal _setup_ As UpdateCommunicationSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdateCommunication(
   UpdateCommunicationSetup _setup_,
   IDbTransaction _transaction_
)

Parameters

setup

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


UpdateContact Method | fcSDK Documentation

UpdateContact Method

Update a Contact. This overload takes a set of required parameters for the API.

Update a Contact.

Overload List

Overload | Description
UpdateContact(String,String,String,String,String) | Update a Contact. This overload takes a set of required parameters for the API.
UpdateContact(UpdateContactSetup) | Update a Contact. This overload takes a setup object.
UpdateContact(UpdateContactSetup,IDbTransaction) | Update a Contact. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
UpdateContactSetup Class


UpdateContact(String,String,String,String,String) Method | fcSDK Documentation

UpdateContact(String,String,String,String,String) Method

Contact's first name

Contact's last name

Contact's telephone number

Identifier of the contact's current site.

Current role for the Contact at their site. Element from the 'Contact Role' application list. If not set, the default list value is used.

Update a Contact. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function UpdateContact( _
   ByVal _firstName_ As String, _
   ByVal _lastName_ As String, _
   ByVal _phone_ As String, _
   ByVal _siteIDNum_ As String, _
   ByVal _roleName_ As String _
) As ToolkitResult

public ToolkitResult UpdateContact(
   string _firstName_,
   string _lastName_,
   string _phone_,
   string _siteIDNum_,
   string _roleName_
)

Parameters

firstName

Contact's first name

lastName

Contact's last name

phone

Contact's telephone number

siteIDNum

Identifier of the contact's current site.

roleName

Current role for the Contact at their site. Element from the 'Contact Role' application list. If not set, the default list value is used.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Contact.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


UpdateContact(UpdateContactSetup) Method | fcSDK Documentation

UpdateContact(UpdateContactSetup) Method

Setup object for API invocation.

Update a Contact. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function UpdateContact( _
   ByVal _setupParam_ UpdateContactSetup _
) As ToolkitResult

public ToolkitResult UpdateContact(
   UpdateContactSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Contact.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
UpdateContactSetup Class


UpdateContact(UpdateContactSetup,IDbTransaction) Method | fcSDK Documentation

UpdateContact(UpdateContactSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Update a Contact. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdateContact( _
   ByVal _setupParam_ As UpdateContactSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdateContact(
   UpdateContactSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


UpdateContactByObjid Method | fcSDK Documentation

UpdateContactByObjid Method

Overload List

Overload | Description
UpdateContactByObjid(UpdateContactByObjidSetup) |
UpdateContactByObjid(UpdateContactByObjidSetup,IDbTransaction) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members


UpdateContactByObjid(UpdateContactByObjidSetup) Method | fcSDK Documentation

UpdateContactByObjid(UpdateContactByObjidSetup) Method

Syntax

'Declaration

Public Overloads Function UpdateContactByObjid( _
   ByVal _setupParam_ UpdateContactByObjidSetup _
) As ToolkitResult

public ToolkitResult UpdateContactByObjid(
   UpdateContactByObjidSetup _setupParam_
)

Parameters

setupParam

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


UpdateContactByObjid(UpdateContactByObjidSetup,IDbTransaction) Method | fcSDK Documentation

UpdateContactByObjid(UpdateContactByObjidSetup,IDbTransaction) Method

Syntax

'Declaration

Public Overloads Function UpdateContactByObjid( _
   ByVal _setupParam_ As UpdateContactByObjidSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdateContactByObjid(
   UpdateContactByObjidSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

transaction

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


UpdateContract Method | fcSDK Documentation

UpdateContract Method

Update a Contract. This overload takes a setup object.

Update a Contract.

Overload List

Overload | Description
UpdateContract(UpdateContractSetup) | Update a Contract. This overload takes a setup object.
UpdateContract(UpdateContractSetup,IDbTransaction) | Update a Contract. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
UpdateContractSetup Class


UpdateContract(UpdateContractSetup) Method | fcSDK Documentation

UpdateContract(UpdateContractSetup) Method

Setup object for API invocation.

Update a Contract. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function UpdateContract( _
   ByVal _setupParam_ UpdateContractSetup _
) As ToolkitResult

public ToolkitResult UpdateContract(
   UpdateContractSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Contract.
  • IDNum - The IDNum of the Contract.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
UpdateContractSetup Class


UpdateContract(UpdateContractSetup,IDbTransaction) Method | fcSDK Documentation

UpdateContract(UpdateContractSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Update a Contract. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdateContract( _
   ByVal _setupParam_ As UpdateContractSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdateContract(
   UpdateContractSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


UpdateDialogue Method | fcSDK Documentation

UpdateDialogue Method

Update a Dialogue.

Update a Dialogue.

Overload List

Overload | Description
UpdateDialogue(String,String,String) | Update a Dialogue.
UpdateDialogue(UpdateDialogueSetup) | Update a Dialogue.
UpdateDialogue(UpdateDialogueSetup,IDbTransaction) | Update a Dialogue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members


UpdateDialogue(String,String,String) Method | fcSDK Documentation

UpdateDialogue(String,String,String) Method

The ID Number of the dialogue.

The title of the dialogue.

The Priority of the dialogue.

Update a Dialogue.

Syntax

'Declaration

Public Overloads Function UpdateDialogue( _
   ByVal _idNumber_ As String, _
   ByVal _newTitle_ As String, _
   ByVal _newPriority_ As String _
) As ToolkitResult

public ToolkitResult UpdateDialogue(
   string _idNumber_,
   string _newTitle_,
   string _newPriority_
)

Parameters

idNumber

The ID Number of the dialogue.

newTitle

The title of the dialogue.

newPriority

The Priority of the dialogue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


UpdateDialogue(UpdateDialogueSetup) Method | fcSDK Documentation

UpdateDialogue(UpdateDialogueSetup) Method

Setup object for API invocation.

Update a Dialogue.

Syntax

'Declaration

Public Overloads Function UpdateDialogue( _
   ByVal _updateDialogueSetup_ UpdateDialogueSetup _
) As ToolkitResult

public ToolkitResult UpdateDialogue(
   UpdateDialogueSetup _updateDialogueSetup_
)

Parameters

updateDialogueSetup

Setup object for API invocation.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


UpdateDialogue(UpdateDialogueSetup,IDbTransaction) Method | fcSDK Documentation

UpdateDialogue(UpdateDialogueSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Update a Dialogue.

Syntax

'Declaration

Public Overloads Function UpdateDialogue( _
   ByVal _setup_ As UpdateDialogueSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdateDialogue(
   UpdateDialogueSetup _setup_,
   IDbTransaction _transaction_
)

Parameters

setup

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


UpdatePart Method | fcSDK Documentation

UpdatePart Method

Update a Part. This overload takes a set of required parameters for the API.

Update a Part.

Overload List

Overload | Description
UpdatePart(String,String,Int32) | Update a Part. This overload takes a set of required parameters for the API.
UpdatePart(UpdatePartSetup) | Update a Part. This overload takes a setup object.
UpdatePart(UpdatePartSetup,IDbTransaction) | Update a Part. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
UpdatePartSetup Class


UpdatePart(String,String,Int32) Method | fcSDK Documentation

UpdatePart(String,String,Int32) Method

Part number for the part to update

Domain for the part to update.

Number of warranty days for the part

Update a Part. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function UpdatePart( _
   ByVal _partNumber_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _warrantyDays_ As Integer _
) As ToolkitResult

public ToolkitResult UpdatePart(
   string _partNumber_,
   string _partDomain_,
   int _warrantyDays_
)

Parameters

partNumber

Part number for the part to update

partDomain

Domain for the part to update.

warrantyDays

Number of warranty days for the part

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Part.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


UpdatePart(UpdatePartSetup) Method | fcSDK Documentation

UpdatePart(UpdatePartSetup) Method

Setup object for API invocation.

Update a Part. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function UpdatePart( _
   ByVal _setupParam_ UpdatePartSetup _
) As ToolkitResult

public ToolkitResult UpdatePart(
   UpdatePartSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Part.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
UpdatePartSetup Class


UpdatePart(UpdatePartSetup,IDbTransaction) Method | fcSDK Documentation

UpdatePart(UpdatePartSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Update a Part. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdatePart( _
   ByVal _setupParam_ As UpdatePartSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdatePart(
   UpdatePartSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


UpdatePartRevision Method | fcSDK Documentation

UpdatePartRevision Method

Update a Part Revision (mod_level) This overload takes a set of required parameters for the API.

Update a Part Revision (mod_level)

Overload List

Overload | Description
UpdatePartRevision(String,String,String) | Update a Part Revision (mod_level) This overload takes a set of required parameters for the API.
UpdatePartRevision(UpdatePartRevisionSetup) | Update a Part Revision (mod_level) This overload takes a setup object.
UpdatePartRevision(UpdatePartRevisionSetup,IDbTransaction) | Update a Part Revision (mod_level) This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
UpdatePartRevisionSetup Class


UpdatePartRevision(String,String,String) Method | fcSDK Documentation

UpdatePartRevision(String,String,String) Method

Part number of the part

Domain of the part

Revision to create

Update a Part Revision (mod_level) This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function UpdatePartRevision( _
   ByVal _partNumber_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _partRevision_ As String _
) As ToolkitResult

public ToolkitResult UpdatePartRevision(
   string _partNumber_,
   string _partDomain_,
   string _partRevision_
)

Parameters

partNumber

Part number of the part

partDomain

Domain of the part

partRevision

Revision to create

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the PartRevision.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


UpdatePartRevision(UpdatePartRevisionSetup) Method | fcSDK Documentation

UpdatePartRevision(UpdatePartRevisionSetup) Method

Setup object for API invocation.

Update a Part Revision (mod_level) This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function UpdatePartRevision( _
   ByVal _setupParam_ UpdatePartRevisionSetup _
) As ToolkitResult

public ToolkitResult UpdatePartRevision(
   UpdatePartRevisionSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the PartRevision.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
UpdatePartRevisionSetup Class


UpdatePartRevision(UpdatePartRevisionSetup,IDbTransaction) Method | fcSDK Documentation

UpdatePartRevision(UpdatePartRevisionSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Update a Part Revision (mod_level) This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdatePartRevision( _
   ByVal _setupParam_ As UpdatePartRevisionSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdatePartRevision(
   UpdatePartRevisionSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


UpdatePriceInstance Method | fcSDK Documentation

UpdatePriceInstance Method

Update Price Instance. This overload takes a set of required parameters for the API.

Update Price Instance.

Overload List

Overload | Description
UpdatePriceInstance(String,String,String,String,Int32,Decimal,DateTime) | Update Price Instance. This overload takes a set of required parameters for the API.
UpdatePriceInstance(UpdatePriceInstanceSetup) | Update Price Instance. This overload takes a setup object.
UpdatePriceInstance(UpdatePriceInstanceSetup,IDbTransaction) | Update Price Instance. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
UpdatePriceInstanceSetup Class


UpdatePriceInstance(String,String,String,String,Int32,Decimal,DateTime) Method | fcSDK Documentation

UpdatePriceInstance(String,String,String,String,Int32,Decimal,DateTime) Method

Part number to price

Domain of the part

Revision to price

Name of the price program

How many units in this price instance.

Price of the part

Date when the Price was updated, any Date between the start and end date is valid.

Update Price Instance. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function UpdatePriceInstance( _
   ByVal _partNumber_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _priceProgram_ As String, _
   ByVal _pricedQuantity_ As Integer, _
   ByVal _price_ As Decimal, _
   ByVal _updateDate_ As Date _
) As ToolkitResult

public ToolkitResult UpdatePriceInstance(
   string _partNumber_,
   string _partDomain_,
   string _partRevision_,
   string _priceProgram_,
   int _pricedQuantity_,
   decimal _price_,
   DateTime _updateDate_
)

Parameters

partNumber

Part number to price

partDomain

Domain of the part

partRevision

Revision to price

priceProgram

Name of the price program

pricedQuantity

How many units in this price instance.

price

Price of the part

updateDate

Date when the Price was updated, any Date between the start and end date is valid.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the PriceInstance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


UpdatePriceInstance(UpdatePriceInstanceSetup) Method | fcSDK Documentation

UpdatePriceInstance(UpdatePriceInstanceSetup) Method

Setup object for API invocation.

Update Price Instance. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function UpdatePriceInstance( _
   ByVal _setupParam_ UpdatePriceInstanceSetup _
) As ToolkitResult

public ToolkitResult UpdatePriceInstance(
   UpdatePriceInstanceSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the PriceInstance.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
UpdatePriceInstanceSetup Class


UpdatePriceInstance(UpdatePriceInstanceSetup,IDbTransaction) Method | fcSDK Documentation

UpdatePriceInstance(UpdatePriceInstanceSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Update Price Instance. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdatePriceInstance( _
   ByVal _setupParam_ As UpdatePriceInstanceSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdatePriceInstance(
   UpdatePriceInstanceSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


UpdateProductBin Method | fcSDK Documentation

UpdateProductBin Method

Update a Product Bin. This overload takes a setup object.

Update a Product Bin.

Overload List

Overload | Description
UpdateProductBin(UpdateProductBinSetup) | Update a Product Bin. This overload takes a setup object.
UpdateProductBin(UpdateProductBinSetup,IDbTransaction) | Update a Product Bin. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
UpdateProductBinSetup Class


UpdateProductBin(UpdateProductBinSetup) Method | fcSDK Documentation

UpdateProductBin(UpdateProductBinSetup) Method

Setup object for API invocation.

Update a Product Bin. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function UpdateProductBin( _
   ByVal _setupParam_ UpdateProductBinSetup _
) As ToolkitResult

public ToolkitResult UpdateProductBin(
   UpdateProductBinSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
UpdateProductBinSetup Class


UpdateProductBin(UpdateProductBinSetup,IDbTransaction) Method | fcSDK Documentation

UpdateProductBin(UpdateProductBinSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Update a Product Bin. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdateProductBin( _
   ByVal _setupParam_ As UpdateProductBinSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdateProductBin(
   UpdateProductBinSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


UpdateQueue Method | fcSDK Documentation

UpdateQueue Method

Update a Queue. This overload takes a setup object.

Update a Queue.

Overload List

Overload | Description
UpdateQueue(UpdateQueueSetup) | Update a Queue. This overload takes a setup object.
UpdateQueue(UpdateQueueSetup,IDbTransaction) | Update a Queue. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
UpdateQueueSetup Class


UpdateQueue(UpdateQueueSetup) Method | fcSDK Documentation

UpdateQueue(UpdateQueueSetup) Method

Setup object for API invocation.

Update a Queue. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function UpdateQueue( _
   ByVal _setupParam_ UpdateQueueSetup _
) As ToolkitResult

public ToolkitResult UpdateQueue(
   UpdateQueueSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
UpdateQueueSetup Class


UpdateQueue(UpdateQueueSetup,IDbTransaction) Method | fcSDK Documentation

UpdateQueue(UpdateQueueSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Update a Queue. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdateQueue( _
   ByVal _setupParam_ As UpdateQueueSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdateQueue(
   UpdateQueueSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


UpdateSite Method | fcSDK Documentation

UpdateSite Method

Update a Site. This overload takes a setup object.

Update a Site.

Overload List

Overload | Description
UpdateSite(UpdateSiteSetup) | Update a Site. This overload takes a setup object.
UpdateSite(UpdateSiteSetup,IDbTransaction) | Update a Site. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
UpdateSiteSetup Class


UpdateSite(UpdateSiteSetup) Method | fcSDK Documentation

UpdateSite(UpdateSiteSetup) Method

Setup object for API invocation.

Update a Site. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function UpdateSite( _
   ByVal _setupParam_ UpdateSiteSetup _
) As ToolkitResult

public ToolkitResult UpdateSite(
   UpdateSiteSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • IDNum - The IDNum of the Site.
  • Objid - The Objid of the Site.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
UpdateSiteSetup Class


UpdateSite(UpdateSiteSetup,IDbTransaction) Method | fcSDK Documentation

UpdateSite(UpdateSiteSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Update a Site. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdateSite( _
   ByVal _setupParam_ As UpdateSiteSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdateSite(
   UpdateSiteSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


UpdateSiteByObjid Method | fcSDK Documentation

UpdateSiteByObjid Method

Update Site identified by Objid. This overload takes a setup object.

Update Site identified by Objid.

Overload List

Overload | Description
UpdateSiteByObjid(UpdateSiteByObjidSetup) | Update Site identified by Objid. This overload takes a setup object.
UpdateSiteByObjid(UpdateSiteByObjidSetup,IDbTransaction) | Update Site identified by Objid. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
UpdateSiteByObjidSetup Class


UpdateSiteByObjid(UpdateSiteByObjidSetup) Method | fcSDK Documentation

UpdateSiteByObjid(UpdateSiteByObjidSetup) Method

Setup object for API invocation.

Update Site identified by Objid. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function UpdateSiteByObjid( _
   ByVal _setupParam_ UpdateSiteByObjidSetup _
) As ToolkitResult

public ToolkitResult UpdateSiteByObjid(
   UpdateSiteByObjidSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Site.
  • IDNum - The IDNum of the Site.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
UpdateSiteByObjidSetup Class


UpdateSiteByObjid(UpdateSiteByObjidSetup,IDbTransaction) Method | fcSDK Documentation

UpdateSiteByObjid(UpdateSiteByObjidSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Update Site identified by Objid. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdateSiteByObjid( _
   ByVal _setupParam_ As UpdateSiteByObjidSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdateSiteByObjid(
   UpdateSiteByObjidSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


UpdateSitePart Method (InterfacesToolkit) | fcSDK Documentation

UpdateSitePart Method (InterfacesToolkit)

Update a Site Part

Overload List

Overload | Description
UpdateSitePart(Int32,Int32) | Update a Site Part This overload takes a set of required parameters for the API.
UpdateSitePart(Int32,String) | Update a Site Part This overload takes a set of required parameters for the API.
UpdateSitePart(UpdateSitePartSetup) | Update a Site Part This overload takes a setup object.
UpdateSitePart(UpdateSitePartSetup,IDbTransaction) | Update a Site Part This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class InterfacesToolkit Members UpdateSitePartSetup Class


UpdateSitePart(Int32,Int32) Method | fcSDK Documentation

UpdateSitePart(Int32,Int32) Method

Objid of the Site Part to be updated

The number of units installed

Update a Site Part This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function UpdateSitePart( _
   ByVal _sitePartObjid_ As Integer, _
   ByVal _quantity_ As Integer _
) As ToolkitResult

public ToolkitResult UpdateSitePart(
   int _sitePartObjid_,
   int _quantity_
)

Parameters

sitePartObjid

Objid of the Site Part to be updated

quantity

The number of units installed

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the SitePart.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


UpdateSitePart(Int32,String) Method | fcSDK Documentation

UpdateSitePart(Int32,String) Method

Objid of the Site Part to be updated

Serial number of the Site Part

Update a Site Part This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function UpdateSitePart( _
   ByVal _sitePartObjid_ As Integer, _
   ByVal _serialNumber_ As String _
) As ToolkitResult

public ToolkitResult UpdateSitePart(
   int _sitePartObjid_,
   string _serialNumber_
)

Parameters

sitePartObjid

Objid of the Site Part to be updated

serialNumber

Serial number of the Site Part

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the SitePart.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


UpdateSitePart(UpdateSitePartSetup) Method | fcSDK Documentation

UpdateSitePart(UpdateSitePartSetup) Method

Setup object for API invocation.

Update a Site Part This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function UpdateSitePart( _
   ByVal _setupParam_ UpdateSitePartSetup _
) As ToolkitResult

public ToolkitResult UpdateSitePart(
   UpdateSitePartSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the SitePart.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
UpdateSitePartSetup Class


UpdateSitePart(UpdateSitePartSetup,IDbTransaction) Method | fcSDK Documentation

UpdateSitePart(UpdateSitePartSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Update a Site Part This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdateSitePart( _
   ByVal _setupParam_ As UpdateSitePartSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdateSitePart(
   UpdateSitePartSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


UpdateWipBin Method | fcSDK Documentation

UpdateWipBin Method

Update a WipBin. This overload takes a setup object.

Update a WipBin.

Overload List

Overload | Description
UpdateWipBin(UpdateWipBinSetup) | Update a WipBin. This overload takes a setup object.
UpdateWipBin(UpdateWipBinSetup,IDbTransaction) | Update a WipBin. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
UpdateWipBinSetup Class


UpdateWipBin(UpdateWipBinSetup) Method | fcSDK Documentation

UpdateWipBin(UpdateWipBinSetup) Method

Setup object for API invocation.

Update a WipBin. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function UpdateWipBin( _
   ByVal _setupParam_ UpdateWipBinSetup _
) As ToolkitResult

public ToolkitResult UpdateWipBin(
   UpdateWipBinSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
UpdateWipBinSetup Class


UpdateWipBin(UpdateWipBinSetup,IDbTransaction) Method | fcSDK Documentation

UpdateWipBin(UpdateWipBinSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Update a WipBin. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdateWipBin( _
   ByVal _setupParam_ As UpdateWipBinSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdateWipBin(
   UpdateWipBinSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


YankSolution Method | fcSDK Documentation

YankSolution Method

Yank the Solution from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.

Yank the Solution from its current location to a new owner's WipBin.

Overload List

Overload | Description
YankSolution(String) | Yank the Solution from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.
YankSolution(YankSolutionSetup) | Yank the Solution from its current location to a new owner's WipBin. This overload takes a setup object.
YankSolution(YankSolutionSetup,IDbTransaction) | Yank the Solution from its current location to a new owner's WipBin. This overload takes a setup object and a database transaction.

Remarks

The WipBin to place the Solution in may also be specified. This is augmented function from base Clarify, where the Solution is always placed in the default WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
YankSolutionSetup Class


YankSolution(String) Method | fcSDK Documentation

YankSolution(String) Method

Solution Identifier.

Yank the Solution from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function YankSolution( _
   ByVal _solutionIDNum_ As String _
) As ToolkitResult

public ToolkitResult YankSolution(
   string _solutionIDNum_
)

Parameters

solutionIDNum

Solution Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The WipBin to place the Solution in may also be specified. This is augmented function from base Clarify, where the Solution is always placed in the default WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


YankSolution(YankSolutionSetup) Method | fcSDK Documentation

YankSolution(YankSolutionSetup) Method

Setup object for API invocation.

Yank the Solution from its current location to a new owner's WipBin. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function YankSolution( _
   ByVal _setupParam_ YankSolutionSetup _
) As ToolkitResult

public ToolkitResult YankSolution(
   YankSolutionSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The WipBin to place the Solution in may also be specified. This is augmented function from base Clarify, where the Solution is always placed in the default WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List
YankSolutionSetup Class


YankSolution(YankSolutionSetup,IDbTransaction) Method | fcSDK Documentation

YankSolution(YankSolutionSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Yank the Solution from its current location to a new owner's WipBin. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function YankSolution( _
   ByVal _setupParam_ As YankSolutionSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult YankSolution(
   YankSolutionSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The WipBin to place the Solution in may also be specified. This is augmented function from base Clarify, where the Solution is always placed in the default WipBin.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members
Overload List


CreateCommunicationActivityCode Field | fcSDK Documentation

CreateCommunicationActivityCode Field

Activity code used for act_entry logs generated when creating a communication.

Syntax

'Declaration

Public Shared ReadOnly CreateCommunicationActivityCode As Integer

public static readonly int CreateCommunicationActivityCode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members


CreateDialogueActivityCode Field | fcSDK Documentation

CreateDialogueActivityCode Field

Activity code used for act_entry logs generated when creating a dialogue.

Syntax

'Declaration

Public Shared ReadOnly CreateDialogueActivityCode As Integer

public static readonly int CreateDialogueActivityCode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members


DeliveryConfirmedActivityCode Field | fcSDK Documentation

DeliveryConfirmedActivityCode Field

Syntax

'Declaration

Public Shared ReadOnly DeliveryConfirmedActivityCode As Integer

public static readonly int DeliveryConfirmedActivityCode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members


DeliveryFailedActivityCode Field | fcSDK Documentation

DeliveryFailedActivityCode Field

Syntax

'Declaration

Public Shared ReadOnly DeliveryFailedActivityCode As Integer

public static readonly int DeliveryFailedActivityCode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members


DeliveryPendingActivityCode Field | fcSDK Documentation

DeliveryPendingActivityCode Field

Syntax

'Declaration

Public Shared ReadOnly DeliveryPendingActivityCode As Integer

public static readonly int DeliveryPendingActivityCode

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkit Class
InterfacesToolkit Members


InterfacesToolkitBase Class | fcSDK Documentation

InterfacesToolkitBase Class

Please see InterfacesToolkit. This class is used internally and not meant to be created by end users.

Syntax

'Declaration

Public MustInherit Class InterfacesToolkitBase
   Inherits FChoice.Toolkits.Clarify.ToolkitBase

public abstract class InterfacesToolkitBase : FChoice.Toolkits.Clarify.ToolkitBase

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.ToolkitBase
FChoice.Toolkits.Clarify.Interfaces.InterfacesToolkitBase
FChoice.Toolkits.Clarify.Interfaces.InterfacesToolkit

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

InterfacesToolkitBase Members
FChoice.Toolkits.Clarify.Interfaces Namespace


InterfacesToolkitBase Class Members | fcSDK Documentation

InterfacesToolkitBase Class Members

The following tables list the members exposed by InterfacesToolkitBase.

Public Properties

 | Name | Description
Public Property | AllowDuplicateContact | Should the CreateContact or UpdateContact methods allow the creation or update of a Contact with the same first name, last name, telephone number as another Contact in the system.
Public Property | ImpersonatorUsername |
Public Property | UseDatabaseLogins |

Reference

InterfacesToolkitBase Class
FChoice.Toolkits.Clarify.Interfaces Namespace


AllowDuplicateContact Property | fcSDK Documentation

AllowDuplicateContact Property

Should the CreateContact or UpdateContact methods allow the creation or update of a Contact with the same first name, last name, telephone number as another Contact in the system.

Syntax

'Declaration

Public Property AllowDuplicateContact As Boolean

public bool AllowDuplicateContact {get; set;}

Property Value

A Void instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API. A Boolean instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

Default value is false.

Please note this only works if the unique index (defined by default in Clarify) to be non-unique.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkitBase Class
InterfacesToolkitBase Members


ImpersonatorUsername Property (InterfacesToolkitBase) | fcSDK Documentation

ImpersonatorUsername Property (InterfacesToolkitBase)

Syntax

'Declaration

Public Property ImpersonatorUsername As String

public string ImpersonatorUsername {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkitBase Class
InterfacesToolkitBase Members


UseDatabaseLogins Property (InterfacesToolkitBase) | fcSDK Documentation

UseDatabaseLogins Property (InterfacesToolkitBase)

Syntax

'Declaration

Public Property UseDatabaseLogins As Boolean

public bool UseDatabaseLogins {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InterfacesToolkitBase Class
InterfacesToolkitBase Members


LinkCaseToWorkaroundSetup Class | fcSDK Documentation

LinkCaseToWorkaroundSetup Class

Used by the LinkCaseToWorkaround method as setup data for invocation.

Syntax

'Declaration

Public Class LinkCaseToWorkaroundSetup

public class LinkCaseToWorkaroundSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.LinkCaseToWorkaroundSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LinkCaseToWorkaroundSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
LinkCaseToWorkaround(LinkCaseToWorkaroundSetup) Method


LinkCaseToWorkaroundSetup Class Members | fcSDK Documentation

LinkCaseToWorkaroundSetup Class Members

The following tables list the members exposed by LinkCaseToWorkaroundSetup.

Public Constructors

 | Name | Description
Public Constructor | LinkCaseToWorkaroundSetup Constructor | Initializes a new instance of the LinkCaseToWorkaroundSetup class.

Public Properties

 | Name | Description
Public Property | CaseIDNum | Identifier of the Case to link to a Workaround
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | LinkDate | DateTime the link was made. If not set, the current time is used.
Public Property | UserName | User that linked the Case to the Workaround. If not set, the session user is used.
Public Property | WorkaroundObjid | Objid of the Workaround the Case will be linked to

Reference

LinkCaseToWorkaroundSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
LinkCaseToWorkaround(LinkCaseToWorkaroundSetup) Method


LinkCaseToWorkaroundSetup Constructor | fcSDK Documentation

LinkCaseToWorkaroundSetup Constructor

Identifier of the Case to link to a Workaround

Objid of the Workaround the Case will be linked to

Initializes a new instance of the LinkCaseToWorkaroundSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _caseIDNum_ As String, _
   ByVal _workaroundObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public LinkCaseToWorkaroundSetup(
   string _caseIDNum_,
   int _workaroundObjid_
)

Parameters

caseIDNum

Identifier of the Case to link to a Workaround

workaroundObjid

Objid of the Workaround the Case will be linked to

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LinkCaseToWorkaroundSetup Class
LinkCaseToWorkaroundSetup Members


CaseIDNum Property (LinkCaseToWorkaroundSetup) | fcSDK Documentation

CaseIDNum Property (LinkCaseToWorkaroundSetup)

Identifier of the Case to link to a Workaround

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LinkCaseToWorkaroundSetup Class
LinkCaseToWorkaroundSetup Members


GenerateTimeBombs Property (LinkCaseToWorkaroundSetup) | fcSDK Documentation

GenerateTimeBombs Property (LinkCaseToWorkaroundSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LinkCaseToWorkaroundSetup Class
LinkCaseToWorkaroundSetup Members


LinkDate Property (LinkCaseToWorkaroundSetup) | fcSDK Documentation

LinkDate Property (LinkCaseToWorkaroundSetup)

DateTime the link was made. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LinkDate As Date

[PropertyBitValueAttribute()]
public DateTime LinkDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LinkCaseToWorkaroundSetup Class
LinkCaseToWorkaroundSetup Members


UserName Property (LinkCaseToWorkaroundSetup) | fcSDK Documentation

UserName Property (LinkCaseToWorkaroundSetup)

User that linked the Case to the Workaround. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LinkCaseToWorkaroundSetup Class
LinkCaseToWorkaroundSetup Members


WorkaroundObjid Property (LinkCaseToWorkaroundSetup) | fcSDK Documentation

WorkaroundObjid Property (LinkCaseToWorkaroundSetup)

Objid of the Workaround the Case will be linked to

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WorkaroundObjid As Integer

[PropertyBitValueAttribute()]
public int WorkaroundObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LinkCaseToWorkaroundSetup Class
LinkCaseToWorkaroundSetup Members


LinkCRToSolutionSetup Class | fcSDK Documentation

LinkCRToSolutionSetup Class

Used by the LinkCRToSolution method as setup data for invocation.

Syntax

'Declaration

Public Class LinkCRToSolutionSetup

public class LinkCRToSolutionSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.LinkCRToSolutionSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LinkCRToSolutionSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
LinkCRToSolution(LinkCRToSolutionSetup) Method


LinkCRToSolutionSetup Class Members | fcSDK Documentation

LinkCRToSolutionSetup Class Members

The following tables list the members exposed by LinkCRToSolutionSetup.

Public Constructors

 | Name | Description
Public Constructor | LinkCRToSolutionSetup Constructor | Initializes a new instance of the LinkCRToSolutionSetup class.

Public Properties

 | Name | Description
Public Property | CRIDNum | Identifier of the CR to link to the Solution
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | LinkDate | DateTime the link was made. If not set, the current time is used.
Public Property | SolutionIDNum | Identifier of the Solution to link to the CR
Public Property | UserName | User that linked the CR to the Solution. If not set, the session user is used.

Reference

LinkCRToSolutionSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
LinkCRToSolution(LinkCRToSolutionSetup) Method


LinkCRToSolutionSetup Constructor | fcSDK Documentation

LinkCRToSolutionSetup Constructor

Identifier of the CR to link to the Solution

Identifier of the Solution to link to the CR

Initializes a new instance of the LinkCRToSolutionSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _crIDNum_ As String, _
   ByVal _solutionIDNum_ As String _
)

[ConstructorIndexAttribute()]
public LinkCRToSolutionSetup(
   string _crIDNum_,
   string _solutionIDNum_
)

Parameters

crIDNum

Identifier of the CR to link to the Solution

solutionIDNum

Identifier of the Solution to link to the CR

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LinkCRToSolutionSetup Class
LinkCRToSolutionSetup Members


CRIDNum Property (LinkCRToSolutionSetup) | fcSDK Documentation

CRIDNum Property (LinkCRToSolutionSetup)

Identifier of the CR to link to the Solution

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CRIDNum As String

[PropertyBitValueAttribute()]
public string CRIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LinkCRToSolutionSetup Class
LinkCRToSolutionSetup Members


GenerateTimeBombs Property (LinkCRToSolutionSetup) | fcSDK Documentation

GenerateTimeBombs Property (LinkCRToSolutionSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LinkCRToSolutionSetup Class
LinkCRToSolutionSetup Members


LinkDate Property (LinkCRToSolutionSetup) | fcSDK Documentation

LinkDate Property (LinkCRToSolutionSetup)

DateTime the link was made. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LinkDate As Date

[PropertyBitValueAttribute()]
public DateTime LinkDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LinkCRToSolutionSetup Class
LinkCRToSolutionSetup Members


SolutionIDNum Property (LinkCRToSolutionSetup) | fcSDK Documentation

SolutionIDNum Property (LinkCRToSolutionSetup)

Identifier of the Solution to link to the CR

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SolutionIDNum As String

[PropertyBitValueAttribute()]
public string SolutionIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LinkCRToSolutionSetup Class
LinkCRToSolutionSetup Members


UserName Property (LinkCRToSolutionSetup) | fcSDK Documentation

UserName Property (LinkCRToSolutionSetup)

User that linked the CR to the Solution. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LinkCRToSolutionSetup Class
LinkCRToSolutionSetup Members


MoveSitePartToBinSetup Class | fcSDK Documentation

MoveSitePartToBinSetup Class

Used by the MoveSitePartToBin method as setup data for invocation.

Syntax

'Declaration

Public Class MoveSitePartToBinSetup

public class MoveSitePartToBinSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.MoveSitePartToBinSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

MoveSitePartToBinSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
MoveSitePartToBin(MoveSitePartToBinSetup) Method


MoveSitePartToBinSetup Class Members | fcSDK Documentation

MoveSitePartToBinSetup Class Members

The following tables list the members exposed by MoveSitePartToBinSetup.

Public Constructors

 | Name | Description
Public Constructor | MoveSitePartToBinSetup Constructor | Initializes a new instance of the MoveSitePartToBinSetup class.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AddActivityLog | Should an activity log be created for the move? | | Public Property | InstallAndMove | If AddActivityLog is true. Should the activity be listed as an Install/Move (true) or just a Move (false)

| | Public Property | MoveDate | DateTime the SitePartToBin was moved. If not set, the current time is used. | | Public Property | ParentBinObjid | Objid of the Bin to place the Site Part into | | Public Property | SitePartObjid |

Objid of the Site Part to be moved

| | Public Property | UserName | The user who has moved the SitePartToBin. If not set, the Toolkit session user is used. |

Reference

MoveSitePartToBinSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
MoveSitePartToBin(MoveSitePartToBinSetup) Method


MoveSitePartToBinSetup Constructor | fcSDK Documentation

MoveSitePartToBinSetup Constructor

Objid of the Site Part to be moved

Objid of the Bin to place the Site Part into

Initializes a new instance of the MoveSitePartToBinSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _sitePartObjid_ As Integer, _
   ByVal _parentBinObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public MoveSitePartToBinSetup(
   int _sitePartObjid_,
   int _parentBinObjid_
)

Parameters

sitePartObjid

Objid of the Site Part to be moved

parentBinObjid

Objid of the Bin to place the Site Part into

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSitePartToBinSetup Class
MoveSitePartToBinSetup Members


AddActivityLog Property (MoveSitePartToBinSetup) | fcSDK Documentation

AddActivityLog Property (MoveSitePartToBinSetup)

Should an activity log be created for the move?

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AddActivityLog As Boolean

[PropertyBitValueAttribute()]
public bool AddActivityLog {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSitePartToBinSetup Class
MoveSitePartToBinSetup Members


InstallAndMove Property (MoveSitePartToBinSetup) | fcSDK Documentation

InstallAndMove Property (MoveSitePartToBinSetup)

If AddActivityLog is true. Should the activity be listed as an Install/Move (true) or just a Move (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallAndMove As Boolean

[PropertyBitValueAttribute()]
public bool InstallAndMove {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSitePartToBinSetup Class
MoveSitePartToBinSetup Members


ParentBinObjid Property (MoveSitePartToBinSetup) | fcSDK Documentation

ParentBinObjid Property (MoveSitePartToBinSetup)

Objid of the Bin to place the Site Part into

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ParentBinObjid As Integer

[PropertyBitValueAttribute()]
public int ParentBinObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSitePartToBinSetup Class
MoveSitePartToBinSetup Members


SitePartObjid Property (MoveSitePartToBinSetup) | fcSDK Documentation

SitePartObjid Property (MoveSitePartToBinSetup)

Objid of the Site Part to be moved

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SitePartObjid As Integer

[PropertyBitValueAttribute()]
public int SitePartObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSitePartToBinSetup Class
MoveSitePartToBinSetup Members


MoveSitePartToPartSetup Class | fcSDK Documentation

MoveSitePartToPartSetup Class

Used by the MoveSitePartToPart method as setup data for invocation.

Syntax

'Declaration

Public Class MoveSitePartToPartSetup

public class MoveSitePartToPartSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.MoveSitePartToPartSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

MoveSitePartToPartSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
MoveSitePartToPart(MoveSitePartToPartSetup) Method


MoveSitePartToPartSetup Class Members | fcSDK Documentation

MoveSitePartToPartSetup Class Members

The following tables list the members exposed by MoveSitePartToPartSetup.

Public Constructors

 | Name | Description
Public Constructor | MoveSitePartToPartSetup Constructor | Initializes a new instance of the MoveSitePartToPartSetup class.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AddActivityLog | Should an activity log be created for the move? | | Public Property | InstallAndMove | If AddActivityLog is true. Should the activity be listed as an Install/Move (true) or just a Move (false)

| | Public Property | MoveDate | DateTime the SitePartToPart was moved. If not set, the current time is used. | | Public Property | ParentSitePartObjid | Objid of the parent Site Part this Site Part will be placed into | | Public Property | SitePartObjid |

Objid of the Site Part to be moved

| | Public Property | UserName | The user who has moved the SitePartToPart. If not set, the Toolkit session user is used. |

Reference

MoveSitePartToPartSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
MoveSitePartToPart(MoveSitePartToPartSetup) Method


MoveSitePartToPartSetup Constructor | fcSDK Documentation

MoveSitePartToPartSetup Constructor

Objid of the Site Part to be moved

Objid of the parent Site Part this Site Part will be placed into

Initializes a new instance of the MoveSitePartToPartSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _sitePartObjid_ As Integer, _
   ByVal _parentSitePartObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public MoveSitePartToPartSetup(
   int _sitePartObjid_,
   int _parentSitePartObjid_
)

Parameters

sitePartObjid

Objid of the Site Part to be moved

parentSitePartObjid

Objid of the parent Site Part this Site Part will be placed into

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSitePartToPartSetup Class
MoveSitePartToPartSetup Members


AddActivityLog Property (MoveSitePartToPartSetup) | fcSDK Documentation

AddActivityLog Property (MoveSitePartToPartSetup)

Should an activity log be created for the move?

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AddActivityLog As Boolean

[PropertyBitValueAttribute()]
public bool AddActivityLog {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSitePartToPartSetup Class
MoveSitePartToPartSetup Members


InstallAndMove Property (MoveSitePartToPartSetup) | fcSDK Documentation

InstallAndMove Property (MoveSitePartToPartSetup)

If AddActivityLog is true. Should the activity be listed as an Install/Move (true) or just a Move (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallAndMove As Boolean

[PropertyBitValueAttribute()]
public bool InstallAndMove {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSitePartToPartSetup Class
MoveSitePartToPartSetup Members


ParentSitePartObjid Property (MoveSitePartToPartSetup) | fcSDK Documentation

ParentSitePartObjid Property (MoveSitePartToPartSetup)

Objid of the parent Site Part this Site Part will be placed into

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ParentSitePartObjid As Integer

[PropertyBitValueAttribute()]
public int ParentSitePartObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSitePartToPartSetup Class
MoveSitePartToPartSetup Members


SitePartObjid Property (MoveSitePartToPartSetup) | fcSDK Documentation

SitePartObjid Property (MoveSitePartToPartSetup)

Objid of the Site Part to be moved

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SitePartObjid As Integer

[PropertyBitValueAttribute()]
public int SitePartObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSitePartToPartSetup Class
MoveSitePartToPartSetup Members


MoveSitePartToSiteSetup Class | fcSDK Documentation

MoveSitePartToSiteSetup Class

Used by the MoveSitePartToSite method as setup data for invocation.

Syntax

'Declaration

Public Class MoveSitePartToSiteSetup

public class MoveSitePartToSiteSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.MoveSitePartToSiteSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

MoveSitePartToSiteSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
MoveSitePartToSite(MoveSitePartToSiteSetup) Method


MoveSitePartToSiteSetup Class Members | fcSDK Documentation

MoveSitePartToSiteSetup Class Members

The following tables list the members exposed by MoveSitePartToSiteSetup.

Public Constructors

 | Name | Description
Public Constructor | MoveSitePartToSiteSetup Constructor | Initializes a new instance of the MoveSitePartToSiteSetup class.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AddActivityLog | Should an activity log be created for the move? | | Public Property | InstallAndMove | If AddActivityLog is true. Should the activity be listed as an Install/Move (true) or just a Move (false)

| | Public Property | MoveDate | DateTime the SitePartToSite was moved. If not set, the current time is used. | | Public Property | ParentSiteIDNum |

Identifier of the parent Site the Site Part is being moved under

| | Public Property | SitePartObjid |

Objid of the Site Part to be moved

| | Public Property | UserName | The user who has moved the SitePartToSite. If not set, the Toolkit session user is used. |

Reference

MoveSitePartToSiteSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
MoveSitePartToSite(MoveSitePartToSiteSetup) Method


MoveSitePartToSiteSetup Constructor | fcSDK Documentation

MoveSitePartToSiteSetup Constructor

Objid of the Site Part to be moved

Identifier of the parent Site the Site Part is being moved under

Initializes a new instance of the MoveSitePartToSiteSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _sitePartObjid_ As Integer, _
   ByVal _parentSiteIDNum_ As String _
)

[ConstructorIndexAttribute()]
public MoveSitePartToSiteSetup(
   int _sitePartObjid_,
   string _parentSiteIDNum_
)

Parameters

sitePartObjid

Objid of the Site Part to be moved

parentSiteIDNum

Identifier of the parent Site the Site Part is being moved under

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSitePartToSiteSetup Class
MoveSitePartToSiteSetup Members


AddActivityLog Property (MoveSitePartToSiteSetup) | fcSDK Documentation

AddActivityLog Property (MoveSitePartToSiteSetup)

Should an activity log be created for the move?

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AddActivityLog As Boolean

[PropertyBitValueAttribute()]
public bool AddActivityLog {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSitePartToSiteSetup Class
MoveSitePartToSiteSetup Members


InstallAndMove Property (MoveSitePartToSiteSetup) | fcSDK Documentation

InstallAndMove Property (MoveSitePartToSiteSetup)

If AddActivityLog is true. Should the activity be listed as an Install/Move (true) or just a Move (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallAndMove As Boolean

[PropertyBitValueAttribute()]
public bool InstallAndMove {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSitePartToSiteSetup Class
MoveSitePartToSiteSetup Members


ParentSiteIDNum Property (MoveSitePartToSiteSetup) | fcSDK Documentation

ParentSiteIDNum Property (MoveSitePartToSiteSetup)

Identifier of the parent Site the Site Part is being moved under

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ParentSiteIDNum As String

[PropertyBitValueAttribute()]
public string ParentSiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSitePartToSiteSetup Class
MoveSitePartToSiteSetup Members


SitePartObjid Property (MoveSitePartToSiteSetup) | fcSDK Documentation

SitePartObjid Property (MoveSitePartToSiteSetup)

Objid of the Site Part to be moved

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SitePartObjid As Integer

[PropertyBitValueAttribute()]
public int SitePartObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSitePartToSiteSetup Class
MoveSitePartToSiteSetup Members


MoveSolutionSetup Class | fcSDK Documentation

MoveSolutionSetup Class

Used by the MoveSolution method as setup data for invocation.

Syntax

'Declaration

Public Class MoveSolutionSetup

public class MoveSolutionSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.MoveSolutionSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

MoveSolutionSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
MoveSolution(MoveSolutionSetup) Method


MoveSolutionSetup Class Members | fcSDK Documentation

MoveSolutionSetup Class Members

The following tables list the members exposed by MoveSolutionSetup.

Public Constructors

 | Name | Description
Public Constructor | MoveSolutionSetup Constructor | Initializes a new instance of the MoveSolutionSetup class.

Public Properties

 | Name | Description
Public Property | NewWipBin | The new WipBin into which the Solution is to be moved.
Public Property | SolutionIDNum | Solution Identifier.

Reference

MoveSolutionSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
MoveSolution(MoveSolutionSetup) Method


MoveSolutionSetup Constructor | fcSDK Documentation

MoveSolutionSetup Constructor

Solution Identifier.

The new WipBin into which the Solution is to be moved.

Initializes a new instance of the MoveSolutionSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _solutionIDNum_ As String, _
   ByVal _newWipBin_ As String _
)

[ConstructorIndexAttribute()]
public MoveSolutionSetup(
   string _solutionIDNum_,
   string _newWipBin_
)

Parameters

solutionIDNum

Solution Identifier.

newWipBin

The new WipBin into which the Solution is to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSolutionSetup Class
MoveSolutionSetup Members


NewWipBin Property (MoveSolutionSetup) | fcSDK Documentation

NewWipBin Property (MoveSolutionSetup)

The new WipBin into which the Solution is to be moved.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewWipBin As String

[PropertyBitValueAttribute()]
public string NewWipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSolutionSetup Class
MoveSolutionSetup Members


SolutionIDNum Property (MoveSolutionSetup) | fcSDK Documentation

SolutionIDNum Property (MoveSolutionSetup)

Solution Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SolutionIDNum As String

[PropertyBitValueAttribute()]
public string SolutionIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSolutionSetup Class
MoveSolutionSetup Members


ReinstallSitePartToBinSetup Class | fcSDK Documentation

ReinstallSitePartToBinSetup Class

Used by the ReinstallSitePartToBin method as setup data for invocation.

Syntax

'Declaration

Public Class ReinstallSitePartToBinSetup

public class ReinstallSitePartToBinSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.ReinstallSitePartToBinSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ReinstallSitePartToBinSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
ReinstallSitePartToBin(ReinstallSitePartToBinSetup) Method


ReinstallSitePartToBinSetup Class Members | fcSDK Documentation

ReinstallSitePartToBinSetup Class Members

The following tables list the members exposed by ReinstallSitePartToBinSetup.

Public Constructors

 | Name | Description
Public Constructor | ReinstallSitePartToBinSetup Constructor | Initializes a new instance of the ReinstallSitePartToBinSetup class.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AddActivityLog | Should an activity log be created for the re-installation? | | Public Property | ParentBinObjid | Objid of the parent Bin this Part will be re-installed under. | | Public Property | ReinstallDate | DateTime the Site Part was re-installed. If not set, the current time is used. | | Public Property | SiteIDNum | Identifier of the Site where the Site Part will be re-installed | | Public Property | SitePartObjid | Objid of the Site Part being re-installed | | Public Property | UseInstall | If AddActivityLog is true. Should the activity be listed as an Install (true) or just a Re-Installed (false)

| | Public Property | UserName | User that re-installed the Site Part. If not set, the session user is used. |

Reference

ReinstallSitePartToBinSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
ReinstallSitePartToBin(ReinstallSitePartToBinSetup) Method


ReinstallSitePartToBinSetup Constructor | fcSDK Documentation

ReinstallSitePartToBinSetup Constructor

Objid of the Site Part being re-installed

Identifier of the Site where the Site Part will be re-installed

Objid of the parent Bin this Part will be re-installed under.

Initializes a new instance of the ReinstallSitePartToBinSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _sitePartObjid_ As Integer, _
   ByVal _siteIDNum_ As String, _
   ByVal _parentBinObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public ReinstallSitePartToBinSetup(
   int _sitePartObjid_,
   string _siteIDNum_,
   int _parentBinObjid_
)

Parameters

sitePartObjid

Objid of the Site Part being re-installed

siteIDNum

Identifier of the Site where the Site Part will be re-installed

parentBinObjid

Objid of the parent Bin this Part will be re-installed under.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReinstallSitePartToBinSetup Class
ReinstallSitePartToBinSetup Members


AddActivityLog Property (ReinstallSitePartToBinSetup) | fcSDK Documentation

AddActivityLog Property (ReinstallSitePartToBinSetup)

Should an activity log be created for the re-installation?

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AddActivityLog As Boolean

[PropertyBitValueAttribute()]
public bool AddActivityLog {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReinstallSitePartToBinSetup Class
ReinstallSitePartToBinSetup Members


ParentBinObjid Property (ReinstallSitePartToBinSetup) | fcSDK Documentation

ParentBinObjid Property (ReinstallSitePartToBinSetup)

Objid of the parent Bin this Part will be re-installed under.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ParentBinObjid As Integer

[PropertyBitValueAttribute()]
public int ParentBinObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReinstallSitePartToBinSetup Class
ReinstallSitePartToBinSetup Members


ReinstallDate Property (ReinstallSitePartToBinSetup) | fcSDK Documentation

ReinstallDate Property (ReinstallSitePartToBinSetup)

DateTime the Site Part was re-installed. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ReinstallDate As Date

[PropertyBitValueAttribute()]
public DateTime ReinstallDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReinstallSitePartToBinSetup Class
ReinstallSitePartToBinSetup Members


SiteIDNum Property (ReinstallSitePartToBinSetup) | fcSDK Documentation

SiteIDNum Property (ReinstallSitePartToBinSetup)

Identifier of the Site where the Site Part will be re-installed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteIDNum As String

[PropertyBitValueAttribute()]
public string SiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReinstallSitePartToBinSetup Class
ReinstallSitePartToBinSetup Members


SitePartObjid Property (ReinstallSitePartToBinSetup) | fcSDK Documentation

SitePartObjid Property (ReinstallSitePartToBinSetup)

Objid of the Site Part being re-installed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SitePartObjid As Integer

[PropertyBitValueAttribute()]
public int SitePartObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReinstallSitePartToBinSetup Class
ReinstallSitePartToBinSetup Members


UseInstall Property (ReinstallSitePartToBinSetup) | fcSDK Documentation

UseInstall Property (ReinstallSitePartToBinSetup)

If AddActivityLog is true. Should the activity be listed as an Install (true) or just a Re-Installed (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UseInstall As Boolean

[PropertyBitValueAttribute()]
public bool UseInstall {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReinstallSitePartToBinSetup Class
ReinstallSitePartToBinSetup Members


UserName Property (ReinstallSitePartToBinSetup) | fcSDK Documentation

UserName Property (ReinstallSitePartToBinSetup)

User that re-installed the Site Part. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReinstallSitePartToBinSetup Class
ReinstallSitePartToBinSetup Members


ReinstallSitePartToPartSetup Class | fcSDK Documentation

ReinstallSitePartToPartSetup Class

Used by the ReinstallSitePartToPart method as setup data for invocation.

Syntax

'Declaration

Public Class ReinstallSitePartToPartSetup

public class ReinstallSitePartToPartSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.ReinstallSitePartToPartSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ReinstallSitePartToPartSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
ReinstallSitePartToPart(ReinstallSitePartToPartSetup) Method


ReinstallSitePartToPartSetup Class Members | fcSDK Documentation

ReinstallSitePartToPartSetup Class Members

The following tables list the members exposed by ReinstallSitePartToPartSetup.

Public Constructors

 | Name | Description
Public Constructor | ReinstallSitePartToPartSetup Constructor | Initializes a new instance of the ReinstallSitePartToPartSetup class.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AddActivityLog | Should an activity log be created for the re-installation? | | Public Property | ParentSitePartObjid | Objid of the parent Site Part this Part will be re-installed under. | | Public Property | ReinstallDate | DateTime the Site Part was re-installed. If not set, the current time is used. | | Public Property | SiteIDNum | Identifier of the Site where the Site Part will be re-installed | | Public Property | SitePartObjid | Objid of the Site Part being re-installed | | Public Property | UseInstall | If AddActivityLog is true. Should the activity be listed as an Install (true) or just a Re-Installed (false)

| | Public Property | UserName | User that re-installed the Site Part. If not set, the session user is used. |

Reference

ReinstallSitePartToPartSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
ReinstallSitePartToPart(ReinstallSitePartToPartSetup) Method


ReinstallSitePartToPartSetup Constructor | fcSDK Documentation

ReinstallSitePartToPartSetup Constructor

Objid of the Site Part being re-installed

Identifier of the Site where the Site Part will be re-installed

Objid of the parent Site Part this Part will be re-installed under.

Initializes a new instance of the ReinstallSitePartToPartSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _sitePartObjid_ As Integer, _
   ByVal _siteIDNum_ As String, _
   ByVal _parentSitePartObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public ReinstallSitePartToPartSetup(
   int _sitePartObjid_,
   string _siteIDNum_,
   int _parentSitePartObjid_
)

Parameters

sitePartObjid

Objid of the Site Part being re-installed

siteIDNum

Identifier of the Site where the Site Part will be re-installed

parentSitePartObjid

Objid of the parent Site Part this Part will be re-installed under.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReinstallSitePartToPartSetup Class
ReinstallSitePartToPartSetup Members


AddActivityLog Property (ReinstallSitePartToPartSetup) | fcSDK Documentation

AddActivityLog Property (ReinstallSitePartToPartSetup)

Should an activity log be created for the re-installation?

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AddActivityLog As Boolean

[PropertyBitValueAttribute()]
public bool AddActivityLog {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReinstallSitePartToPartSetup Class
ReinstallSitePartToPartSetup Members


ParentSitePartObjid Property (ReinstallSitePartToPartSetup) | fcSDK Documentation

ParentSitePartObjid Property (ReinstallSitePartToPartSetup)

Objid of the parent Site Part this Part will be re-installed under.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ParentSitePartObjid As Integer

[PropertyBitValueAttribute()]
public int ParentSitePartObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReinstallSitePartToPartSetup Class
ReinstallSitePartToPartSetup Members


ReinstallDate Property (ReinstallSitePartToPartSetup) | fcSDK Documentation

ReinstallDate Property (ReinstallSitePartToPartSetup)

DateTime the Site Part was re-installed. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ReinstallDate As Date

[PropertyBitValueAttribute()]
public DateTime ReinstallDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReinstallSitePartToPartSetup Class
ReinstallSitePartToPartSetup Members


SiteIDNum Property (ReinstallSitePartToPartSetup) | fcSDK Documentation

SiteIDNum Property (ReinstallSitePartToPartSetup)

Identifier of the Site where the Site Part will be re-installed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteIDNum As String

[PropertyBitValueAttribute()]
public string SiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReinstallSitePartToPartSetup Class
ReinstallSitePartToPartSetup Members


SitePartObjid Property (ReinstallSitePartToPartSetup) | fcSDK Documentation

SitePartObjid Property (ReinstallSitePartToPartSetup)

Objid of the Site Part being re-installed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SitePartObjid As Integer

[PropertyBitValueAttribute()]
public int SitePartObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReinstallSitePartToPartSetup Class
ReinstallSitePartToPartSetup Members


UseInstall Property (ReinstallSitePartToPartSetup) | fcSDK Documentation

UseInstall Property (ReinstallSitePartToPartSetup)

If AddActivityLog is true. Should the activity be listed as an Install (true) or just a Re-Installed (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UseInstall As Boolean

[PropertyBitValueAttribute()]
public bool UseInstall {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReinstallSitePartToPartSetup Class
ReinstallSitePartToPartSetup Members


UserName Property (ReinstallSitePartToPartSetup) | fcSDK Documentation

UserName Property (ReinstallSitePartToPartSetup)

User that re-installed the Site Part. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReinstallSitePartToPartSetup Class
ReinstallSitePartToPartSetup Members


ReinstallSitePartToSiteSetup Class | fcSDK Documentation

ReinstallSitePartToSiteSetup Class

Used by the ReinstallSitePartToSite method as setup data for invocation.

Syntax

'Declaration

Public Class ReinstallSitePartToSiteSetup

public class ReinstallSitePartToSiteSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.ReinstallSitePartToSiteSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ReinstallSitePartToSiteSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
ReinstallSitePartToSite(ReinstallSitePartToSiteSetup) Method


ReinstallSitePartToSiteSetup Class Members | fcSDK Documentation

ReinstallSitePartToSiteSetup Class Members

The following tables list the members exposed by ReinstallSitePartToSiteSetup.

Public Constructors

 | Name | Description
Public Constructor | ReinstallSitePartToSiteSetup Constructor | Initializes a new instance of the ReinstallSitePartToSiteSetup class.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AddActivityLog | Should an activity log be created for the re-installation? | | Public Property | ReinstallDate | DateTime the Site Part was re-installed. If not set, the current time is used. | | Public Property | SiteIDNum | Identifier of the Site where the Site Part will be re-installed | | Public Property | SitePartObjid | Objid of the Site Part being re-installed | | Public Property | UseInstall | If AddActivityLog is true. Should the activity be listed as an Install (true) or just a Re-Installed (false)

| | Public Property | UserName | User that re-installed the Site Part. If not set, the session user is used. |

Reference

ReinstallSitePartToSiteSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
ReinstallSitePartToSite(ReinstallSitePartToSiteSetup) Method


ReinstallSitePartToSiteSetup Constructor | fcSDK Documentation

ReinstallSitePartToSiteSetup Constructor

Objid of the Site Part being re-installed

Identifier of the Site where the Site Part will be re-installed

Initializes a new instance of the ReinstallSitePartToSiteSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _sitePartObjid_ As Integer, _
   ByVal _siteIDNum_ As String _
)

[ConstructorIndexAttribute()]
public ReinstallSitePartToSiteSetup(
   int _sitePartObjid_,
   string _siteIDNum_
)

Parameters

sitePartObjid

Objid of the Site Part being re-installed

siteIDNum

Identifier of the Site where the Site Part will be re-installed

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReinstallSitePartToSiteSetup Class
ReinstallSitePartToSiteSetup Members


AddActivityLog Property (ReinstallSitePartToSiteSetup) | fcSDK Documentation

AddActivityLog Property (ReinstallSitePartToSiteSetup)

Should an activity log be created for the re-installation?

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AddActivityLog As Boolean

[PropertyBitValueAttribute()]
public bool AddActivityLog {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReinstallSitePartToSiteSetup Class
ReinstallSitePartToSiteSetup Members


ReinstallDate Property (ReinstallSitePartToSiteSetup) | fcSDK Documentation

ReinstallDate Property (ReinstallSitePartToSiteSetup)

DateTime the Site Part was re-installed. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ReinstallDate As Date

[PropertyBitValueAttribute()]
public DateTime ReinstallDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReinstallSitePartToSiteSetup Class
ReinstallSitePartToSiteSetup Members


SiteIDNum Property (ReinstallSitePartToSiteSetup) | fcSDK Documentation

SiteIDNum Property (ReinstallSitePartToSiteSetup)

Identifier of the Site where the Site Part will be re-installed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteIDNum As String

[PropertyBitValueAttribute()]
public string SiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReinstallSitePartToSiteSetup Class
ReinstallSitePartToSiteSetup Members


SitePartObjid Property (ReinstallSitePartToSiteSetup) | fcSDK Documentation

SitePartObjid Property (ReinstallSitePartToSiteSetup)

Objid of the Site Part being re-installed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SitePartObjid As Integer

[PropertyBitValueAttribute()]
public int SitePartObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReinstallSitePartToSiteSetup Class
ReinstallSitePartToSiteSetup Members


UseInstall Property (ReinstallSitePartToSiteSetup) | fcSDK Documentation

UseInstall Property (ReinstallSitePartToSiteSetup)

If AddActivityLog is true. Should the activity be listed as an Install (true) or just a Re-Installed (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UseInstall As Boolean

[PropertyBitValueAttribute()]
public bool UseInstall {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReinstallSitePartToSiteSetup Class
ReinstallSitePartToSiteSetup Members


UserName Property (ReinstallSitePartToSiteSetup) | fcSDK Documentation

UserName Property (ReinstallSitePartToSiteSetup)

User that re-installed the Site Part. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReinstallSitePartToSiteSetup Class
ReinstallSitePartToSiteSetup Members


RejectSolutionSetup Class | fcSDK Documentation

RejectSolutionSetup Class

Used by the RejectSolution method as setup data for invocation.

Syntax

'Declaration

Public Class RejectSolutionSetup

public class RejectSolutionSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.RejectSolutionSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

RejectSolutionSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
RejectSolution(RejectSolutionSetup) Method


RejectSolutionSetup Class Members | fcSDK Documentation

RejectSolutionSetup Class Members

The following tables list the members exposed by RejectSolutionSetup.

Public Constructors

 | Name | Description
Public Constructor | RejectSolutionSetup Constructor | Initializes a new instance of the RejectSolutionSetup class.

Public Properties

 | Name | Description
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Notes | The reason the Solution was rejected from the queue into which it was dispatched.
Public Property | RejectDate | DateTime the Solution was rejected. If not set, the current time is used.
Public Property | SolutionIDNum | Solution Identifier.
Public Property | UserName | The user who has rejected the Solution. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Solution. If not set, the UserName's default is used.

Reference

RejectSolutionSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
RejectSolution(RejectSolutionSetup) Method


RejectSolutionSetup Constructor | fcSDK Documentation

RejectSolutionSetup Constructor

Solution Identifier.

Initializes a new instance of the RejectSolutionSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _solutionIDNum_ As String _
)

[ConstructorIndexAttribute()]
public RejectSolutionSetup(
   string _solutionIDNum_
)

Parameters

solutionIDNum

Solution Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectSolutionSetup Class
RejectSolutionSetup Members


GenerateTimeBombs Property (RejectSolutionSetup) | fcSDK Documentation

GenerateTimeBombs Property (RejectSolutionSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectSolutionSetup Class
RejectSolutionSetup Members


Notes Property (RejectSolutionSetup) | fcSDK Documentation

Notes Property (RejectSolutionSetup)

The reason the Solution was rejected from the queue into which it was dispatched.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectSolutionSetup Class
RejectSolutionSetup Members


RejectDate Property (RejectSolutionSetup) | fcSDK Documentation

RejectDate Property (RejectSolutionSetup)

DateTime the Solution was rejected. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property RejectDate As Date

[PropertyBitValueAttribute()]
public DateTime RejectDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectSolutionSetup Class
RejectSolutionSetup Members


SolutionIDNum Property (RejectSolutionSetup) | fcSDK Documentation

SolutionIDNum Property (RejectSolutionSetup)

Solution Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SolutionIDNum As String

[PropertyBitValueAttribute()]
public string SolutionIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectSolutionSetup Class
RejectSolutionSetup Members


UserName Property (RejectSolutionSetup) | fcSDK Documentation

UserName Property (RejectSolutionSetup)

The user who has rejected the Solution. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectSolutionSetup Class
RejectSolutionSetup Members


WipBin Property (RejectSolutionSetup) | fcSDK Documentation

WipBin Property (RejectSolutionSetup)

User's WipBin in which to place the Solution. If not set, the UserName's default is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectSolutionSetup Class
RejectSolutionSetup Members


RemoveContactFromContractSetup Class | fcSDK Documentation

RemoveContactFromContractSetup Class

Syntax

'Declaration

Public Class RemoveContactFromContractSetup

public class RemoveContactFromContractSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.RemoveContactFromContractSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

RemoveContactFromContractSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace


RemoveContactFromContractSetup Class Members | fcSDK Documentation

RemoveContactFromContractSetup Class Members

The following tables list the members exposed by RemoveContactFromContractSetup.

Public Constructors

 | Name | Description
Public Constructor | RemoveContactFromContractSetup Constructor |

Public Properties

 | Name | Description
Public Property | ContactObjid |
Public Property | ContractIDNum |

Reference

RemoveContactFromContractSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace


RemoveContactFromContractSetup Constructor | fcSDK Documentation

RemoveContactFromContractSetup Constructor

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _contractIDNum_ As String, _
   ByVal _contactObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public RemoveContactFromContractSetup(
   string _contractIDNum_,
   int _contactObjid_
)

Parameters

contractIDNum

contactObjid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RemoveContactFromContractSetup Class
RemoveContactFromContractSetup Members


ContactObjid Property (RemoveContactFromContractSetup) | fcSDK Documentation

ContactObjid Property (RemoveContactFromContractSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactObjid As Integer

[PropertyBitValueAttribute()]
public int ContactObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RemoveContactFromContractSetup Class
RemoveContactFromContractSetup Members


ContractIDNum Property (RemoveContactFromContractSetup) | fcSDK Documentation

ContractIDNum Property (RemoveContactFromContractSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContractIDNum As String

[PropertyBitValueAttribute()]
public string ContractIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RemoveContactFromContractSetup Class
RemoveContactFromContractSetup Members


RemoveEmployeeFromAccountSetup Class | fcSDK Documentation

RemoveEmployeeFromAccountSetup Class

Used by the RemoveEmployeeFromAccount method as setup data for invocation.

Syntax

'Declaration

Public Class RemoveEmployeeFromAccountSetup

public class RemoveEmployeeFromAccountSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.RemoveEmployeeFromAccountSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

RemoveEmployeeFromAccountSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
RemoveEmployeeFromAccount(RemoveEmployeeFromAccountSetup) Method


RemoveEmployeeFromAccountSetup Class Members | fcSDK Documentation

RemoveEmployeeFromAccountSetup Class Members

The following tables list the members exposed by RemoveEmployeeFromAccountSetup.

Public Constructors

 | Name | Description
Public Constructor | RemoveEmployeeFromAccountSetup Constructor | Initializes a new instance of the RemoveEmployeeFromAccountSetup class.

Public Properties

 | Name | Description
Public Property | AccountIDNum | Identifier for the Account the Employee will be removed from.
Public Property | RoleName | Employee Role to be removing from the Account
Public Property | UserName | Username of the Employee to be removed from the Account.

Reference

RemoveEmployeeFromAccountSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
RemoveEmployeeFromAccount(RemoveEmployeeFromAccountSetup) Method


RemoveEmployeeFromAccountSetup Constructor | fcSDK Documentation

RemoveEmployeeFromAccountSetup Constructor

Username of the Employee to be removed from the Account.

Identifier for the Account the Employee will be removed from.

Employee Role to be removing from the Account

Initializes a new instance of the RemoveEmployeeFromAccountSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _userName_ As String, _
   ByVal _accountIDNum_ As String, _
   ByVal _roleName_ As String _
)

[ConstructorIndexAttribute()]
public RemoveEmployeeFromAccountSetup(
   string _userName_,
   string _accountIDNum_,
   string _roleName_
)

Parameters

userName

Username of the Employee to be removed from the Account.

accountIDNum

Identifier for the Account the Employee will be removed from.

roleName

Employee Role to be removing from the Account

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RemoveEmployeeFromAccountSetup Class
RemoveEmployeeFromAccountSetup Members


AccountIDNum Property (RemoveEmployeeFromAccountSetup) | fcSDK Documentation

AccountIDNum Property (RemoveEmployeeFromAccountSetup)

Identifier for the Account the Employee will be removed from.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AccountIDNum As String

[PropertyBitValueAttribute()]
public string AccountIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RemoveEmployeeFromAccountSetup Class
RemoveEmployeeFromAccountSetup Members


RoleName Property (RemoveEmployeeFromAccountSetup) | fcSDK Documentation

RoleName Property (RemoveEmployeeFromAccountSetup)

Employee Role to be removing from the Account

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property RoleName As String

[PropertyBitValueAttribute()]
public string RoleName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RemoveEmployeeFromAccountSetup Class
RemoveEmployeeFromAccountSetup Members


UserName Property (RemoveEmployeeFromAccountSetup) | fcSDK Documentation

UserName Property (RemoveEmployeeFromAccountSetup)

Username of the Employee to be removed from the Account.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RemoveEmployeeFromAccountSetup Class
RemoveEmployeeFromAccountSetup Members


RemoveSiteFromAccountSetup Class | fcSDK Documentation

RemoveSiteFromAccountSetup Class

Used by the RemoveSiteFromAccount method as setup data for invocation.

Syntax

'Declaration

Public Class RemoveSiteFromAccountSetup

public class RemoveSiteFromAccountSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.RemoveSiteFromAccountSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

RemoveSiteFromAccountSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
RemoveSiteFromAccount(RemoveSiteFromAccountSetup) Method


RemoveSiteFromAccountSetup Class Members | fcSDK Documentation

RemoveSiteFromAccountSetup Class Members

The following tables list the members exposed by RemoveSiteFromAccountSetup.

Public Constructors

 | Name | Description
Public Constructor | RemoveSiteFromAccountSetup Constructor | Initializes a new instance of the RemoveSiteFromAccountSetup class.

Public Properties

 | Name | Description
Public Property | AccountIDNum | Identifier for the Account the Site will be removed from.
Public Property | RoleName | Name of the Site's role being removed from the Account
Public Property | SiteIDNum | Identifier of the Site being removed from the Account

Reference

RemoveSiteFromAccountSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
RemoveSiteFromAccount(RemoveSiteFromAccountSetup) Method


RemoveSiteFromAccountSetup Constructor | fcSDK Documentation

RemoveSiteFromAccountSetup Constructor

Identifier of the Site being removed from the Account

Identifier for the Account the Site will be removed from.

Name of the Site's role being removed from the Account

Initializes a new instance of the RemoveSiteFromAccountSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _siteIDNum_ As String, _
   ByVal _accountIDNum_ As String, _
   ByVal _roleName_ As String _
)

[ConstructorIndexAttribute()]
public RemoveSiteFromAccountSetup(
   string _siteIDNum_,
   string _accountIDNum_,
   string _roleName_
)

Parameters

siteIDNum

Identifier of the Site being removed from the Account

accountIDNum

Identifier for the Account the Site will be removed from.

roleName

Name of the Site's role being removed from the Account

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RemoveSiteFromAccountSetup Class
RemoveSiteFromAccountSetup Members


AccountIDNum Property (RemoveSiteFromAccountSetup) | fcSDK Documentation

AccountIDNum Property (RemoveSiteFromAccountSetup)

Identifier for the Account the Site will be removed from.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AccountIDNum As String

[PropertyBitValueAttribute()]
public string AccountIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RemoveSiteFromAccountSetup Class
RemoveSiteFromAccountSetup Members


RoleName Property (RemoveSiteFromAccountSetup) | fcSDK Documentation

RoleName Property (RemoveSiteFromAccountSetup)

Name of the Site's role being removed from the Account

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property RoleName As String

[PropertyBitValueAttribute()]
public string RoleName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RemoveSiteFromAccountSetup Class
RemoveSiteFromAccountSetup Members


SiteIDNum Property (RemoveSiteFromAccountSetup) | fcSDK Documentation

SiteIDNum Property (RemoveSiteFromAccountSetup)

Identifier of the Site being removed from the Account

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteIDNum As String

[PropertyBitValueAttribute()]
public string SiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RemoveSiteFromAccountSetup Class
RemoveSiteFromAccountSetup Members


RemoveSiteFromContractSetup Class | fcSDK Documentation

RemoveSiteFromContractSetup Class

Syntax

'Declaration

Public Class RemoveSiteFromContractSetup

public class RemoveSiteFromContractSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.RemoveSiteFromContractSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

RemoveSiteFromContractSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace


RemoveSiteFromContractSetup Class Members | fcSDK Documentation

RemoveSiteFromContractSetup Class Members

The following tables list the members exposed by RemoveSiteFromContractSetup.

Public Constructors

 | Name | Description
Public Constructor | RemoveSiteFromContractSetup Constructor |

Public Properties

 | Name | Description
Public Property | ContractIDNum |
Public Property | SiteIDNum |

Reference

RemoveSiteFromContractSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace


RemoveSiteFromContractSetup Constructor | fcSDK Documentation

RemoveSiteFromContractSetup Constructor

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _contractIDNum_ As String, _
   ByVal _siteIDNum_ As String _
)

[ConstructorIndexAttribute()]
public RemoveSiteFromContractSetup(
   string _contractIDNum_,
   string _siteIDNum_
)

Parameters

contractIDNum

siteIDNum

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RemoveSiteFromContractSetup Class
RemoveSiteFromContractSetup Members


ContractIDNum Property (RemoveSiteFromContractSetup) | fcSDK Documentation

ContractIDNum Property (RemoveSiteFromContractSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContractIDNum As String

[PropertyBitValueAttribute()]
public string ContractIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RemoveSiteFromContractSetup Class
RemoveSiteFromContractSetup Members


SiteIDNum Property (RemoveSiteFromContractSetup) | fcSDK Documentation

SiteIDNum Property (RemoveSiteFromContractSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteIDNum As String

[PropertyBitValueAttribute()]
public string SiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RemoveSiteFromContractSetup Class
RemoveSiteFromContractSetup Members


RemoveSitePartFromContractSetup Class | fcSDK Documentation

RemoveSitePartFromContractSetup Class

Syntax

'Declaration

Public Class RemoveSitePartFromContractSetup

public class RemoveSitePartFromContractSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.RemoveSitePartFromContractSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

RemoveSitePartFromContractSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace


RemoveSitePartFromContractSetup Class Members | fcSDK Documentation

RemoveSitePartFromContractSetup Class Members

The following tables list the members exposed by RemoveSitePartFromContractSetup.

Public Constructors

 | Name | Description
Public Constructor | RemoveSitePartFromContractSetup Constructor |

Public Properties

 | Name | Description
Public Property | ContractIDNum |
Public Property | SitePartObjid |

Reference

RemoveSitePartFromContractSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace


RemoveSitePartFromContractSetup Constructor | fcSDK Documentation

RemoveSitePartFromContractSetup Constructor

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _contractIDNum_ As String, _
   ByVal _sitePartObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public RemoveSitePartFromContractSetup(
   string _contractIDNum_,
   int _sitePartObjid_
)

Parameters

contractIDNum

sitePartObjid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RemoveSitePartFromContractSetup Class
RemoveSitePartFromContractSetup Members


ContractIDNum Property (RemoveSitePartFromContractSetup) | fcSDK Documentation

ContractIDNum Property (RemoveSitePartFromContractSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContractIDNum As String

[PropertyBitValueAttribute()]
public string ContractIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RemoveSitePartFromContractSetup Class
RemoveSitePartFromContractSetup Members


SitePartObjid Property (RemoveSitePartFromContractSetup) | fcSDK Documentation

SitePartObjid Property (RemoveSitePartFromContractSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SitePartObjid As Integer

[PropertyBitValueAttribute()]
public int SitePartObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RemoveSitePartFromContractSetup Class
RemoveSitePartFromContractSetup Members


ReopenDialogueSetup Class | fcSDK Documentation

ReopenDialogueSetup Class

Syntax

'Declaration

Public Class ReopenDialogueSetup

public class ReopenDialogueSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.ReopenDialogueSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ReopenDialogueSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace


ReopenDialogueSetup Class Members | fcSDK Documentation

ReopenDialogueSetup Class Members

The following tables list the members exposed by ReopenDialogueSetup.

Public Constructors

 | Name | Description
Public Constructor | ReopenDialogueSetup Constructor |

Public Properties

 | Name | Description
Public Property | AdditionalFields |
Public Property | GenerateTimeBombs |
Public Property | IDNumber |
Public Property | Reopened |
Public Property | Status |
Public Property | UserName |

Reference

ReopenDialogueSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace


ReopenDialogueSetup Constructor | fcSDK Documentation

ReopenDialogueSetup Constructor

Syntax

'Declaration

Public Function New( _
   ByVal _idNumber_ As String _
)

public ReopenDialogueSetup(
   string _idNumber_
)

Parameters

idNumber

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenDialogueSetup Class
ReopenDialogueSetup Members


AdditionalFields Property (ReopenDialogueSetup) | fcSDK Documentation

AdditionalFields Property (ReopenDialogueSetup)

Syntax

'Declaration

Public ReadOnly Property AdditionalFields As SimplifiedAdditionalFields

public SimplifiedAdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenDialogueSetup Class
ReopenDialogueSetup Members


GenerateTimeBombs Property (ReopenDialogueSetup) | fcSDK Documentation

GenerateTimeBombs Property (ReopenDialogueSetup)

Syntax

'Declaration

Public Property GenerateTimeBombs As Boolean

public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenDialogueSetup Class
ReopenDialogueSetup Members


IDNumber Property (ReopenDialogueSetup) | fcSDK Documentation

IDNumber Property (ReopenDialogueSetup)

Syntax

'Declaration

Public Property IDNumber As String

public string IDNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenDialogueSetup Class
ReopenDialogueSetup Members


Reopened Property | fcSDK Documentation

Reopened Property

Syntax

'Declaration

Public Property Reopened As Date

public DateTime Reopened {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenDialogueSetup Class
ReopenDialogueSetup Members


Status Property (ReopenDialogueSetup) | fcSDK Documentation

Status Property (ReopenDialogueSetup)

Syntax

'Declaration

Public Property Status As String

public string Status {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenDialogueSetup Class
ReopenDialogueSetup Members


UserName Property (ReopenDialogueSetup) | fcSDK Documentation

UserName Property (ReopenDialogueSetup)

Syntax

'Declaration

Public Property UserName As String

public string UserName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenDialogueSetup Class
ReopenDialogueSetup Members


UnlinkCaseFromWorkaroundSetup Class | fcSDK Documentation

UnlinkCaseFromWorkaroundSetup Class

Used by the UnlinkCaseFromWorkaround method as setup data for invocation.

Syntax

'Declaration

Public Class UnlinkCaseFromWorkaroundSetup

public class UnlinkCaseFromWorkaroundSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.UnlinkCaseFromWorkaroundSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UnlinkCaseFromWorkaroundSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
UnlinkCaseFromWorkaround(UnlinkCaseFromWorkaroundSetup) Method


UnlinkCaseFromWorkaroundSetup Class Members | fcSDK Documentation

UnlinkCaseFromWorkaroundSetup Class Members

The following tables list the members exposed by UnlinkCaseFromWorkaroundSetup.

Public Constructors

 | Name | Description
Public Constructor | UnlinkCaseFromWorkaroundSetup Constructor | Initializes a new instance of the UnlinkCaseFromWorkaroundSetup class.

Public Properties

 | Name | Description
Public Property | CaseIDNum | Identifier of the Case to unlink from the Workaround
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | UnlinkDate | DateTime the unlinking was done. If not set, the current time is used.
Public Property | UserName | User that unlinked the Case from the Workaround. If not set, the session user is used.

Reference

UnlinkCaseFromWorkaroundSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
UnlinkCaseFromWorkaround(UnlinkCaseFromWorkaroundSetup) Method


UnlinkCaseFromWorkaroundSetup Constructor | fcSDK Documentation

UnlinkCaseFromWorkaroundSetup Constructor

Identifier of the Case to unlink from the Workaround

Initializes a new instance of the UnlinkCaseFromWorkaroundSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _caseIDNum_ As String _
)

[ConstructorIndexAttribute()]
public UnlinkCaseFromWorkaroundSetup(
   string _caseIDNum_
)

Parameters

caseIDNum

Identifier of the Case to unlink from the Workaround

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UnlinkCaseFromWorkaroundSetup Class
UnlinkCaseFromWorkaroundSetup Members


CaseIDNum Property (UnlinkCaseFromWorkaroundSetup) | fcSDK Documentation

CaseIDNum Property (UnlinkCaseFromWorkaroundSetup)

Identifier of the Case to unlink from the Workaround

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UnlinkCaseFromWorkaroundSetup Class
UnlinkCaseFromWorkaroundSetup Members


GenerateTimeBombs Property (UnlinkCaseFromWorkaroundSetup) | fcSDK Documentation

GenerateTimeBombs Property (UnlinkCaseFromWorkaroundSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UnlinkCaseFromWorkaroundSetup Class
UnlinkCaseFromWorkaroundSetup Members


UnlinkDate Property (UnlinkCaseFromWorkaroundSetup) | fcSDK Documentation

UnlinkDate Property (UnlinkCaseFromWorkaroundSetup)

DateTime the unlinking was done. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UnlinkDate As Date

[PropertyBitValueAttribute()]
public DateTime UnlinkDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UnlinkCaseFromWorkaroundSetup Class
UnlinkCaseFromWorkaroundSetup Members


UserName Property (UnlinkCaseFromWorkaroundSetup) | fcSDK Documentation

UserName Property (UnlinkCaseFromWorkaroundSetup)

User that unlinked the Case from the Workaround. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UnlinkCaseFromWorkaroundSetup Class
UnlinkCaseFromWorkaroundSetup Members


UnlinkCRFromSolutionSetup Class | fcSDK Documentation

UnlinkCRFromSolutionSetup Class

Used by the UnlinkCRFromSolution method as setup data for invocation.

Syntax

'Declaration

Public Class UnlinkCRFromSolutionSetup

public class UnlinkCRFromSolutionSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.UnlinkCRFromSolutionSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UnlinkCRFromSolutionSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
UnlinkCRFromSolution(UnlinkCRFromSolutionSetup) Method


UnlinkCRFromSolutionSetup Class Members | fcSDK Documentation

UnlinkCRFromSolutionSetup Class Members

The following tables list the members exposed by UnlinkCRFromSolutionSetup.

Public Constructors

 | Name | Description
Public Constructor | UnlinkCRFromSolutionSetup Constructor | Initializes a new instance of the UnlinkCRFromSolutionSetup class.

Public Properties

 | Name | Description
Public Property | CRIDNum | Identifier of the CR to unlink from the Solution
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | SolutionIDNum | Identifier of the Solution to unlink from the CR
Public Property | UnlinkDate | DateTime the unlinking was done. If not set, the current time is used.
Public Property | UserName | User that unlinked the CR from the Solution. If not set, the session user is used.

Reference

UnlinkCRFromSolutionSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
UnlinkCRFromSolution(UnlinkCRFromSolutionSetup) Method


UnlinkCRFromSolutionSetup Constructor | fcSDK Documentation

UnlinkCRFromSolutionSetup Constructor

Identifier of the CR to unlink from the Solution

Identifier of the Solution to unlink from the CR

Initializes a new instance of the UnlinkCRFromSolutionSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _crIDNum_ As String, _
   ByVal _solutionIDNum_ As String _
)

[ConstructorIndexAttribute()]
public UnlinkCRFromSolutionSetup(
   string _crIDNum_,
   string _solutionIDNum_
)

Parameters

crIDNum

Identifier of the CR to unlink from the Solution

solutionIDNum

Identifier of the Solution to unlink from the CR

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UnlinkCRFromSolutionSetup Class
UnlinkCRFromSolutionSetup Members


CRIDNum Property (UnlinkCRFromSolutionSetup) | fcSDK Documentation

CRIDNum Property (UnlinkCRFromSolutionSetup)

Identifier of the CR to unlink from the Solution

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CRIDNum As String

[PropertyBitValueAttribute()]
public string CRIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UnlinkCRFromSolutionSetup Class
UnlinkCRFromSolutionSetup Members


GenerateTimeBombs Property (UnlinkCRFromSolutionSetup) | fcSDK Documentation

GenerateTimeBombs Property (UnlinkCRFromSolutionSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UnlinkCRFromSolutionSetup Class
UnlinkCRFromSolutionSetup Members


SolutionIDNum Property (UnlinkCRFromSolutionSetup) | fcSDK Documentation

SolutionIDNum Property (UnlinkCRFromSolutionSetup)

Identifier of the Solution to unlink from the CR

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SolutionIDNum As String

[PropertyBitValueAttribute()]
public string SolutionIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UnlinkCRFromSolutionSetup Class
UnlinkCRFromSolutionSetup Members


UnlinkDate Property (UnlinkCRFromSolutionSetup) | fcSDK Documentation

UnlinkDate Property (UnlinkCRFromSolutionSetup)

DateTime the unlinking was done. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UnlinkDate As Date

[PropertyBitValueAttribute()]
public DateTime UnlinkDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UnlinkCRFromSolutionSetup Class
UnlinkCRFromSolutionSetup Members


UserName Property (UnlinkCRFromSolutionSetup) | fcSDK Documentation

UserName Property (UnlinkCRFromSolutionSetup)

User that unlinked the CR from the Solution. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UnlinkCRFromSolutionSetup Class
UnlinkCRFromSolutionSetup Members


UpdateAccountSetup Class | fcSDK Documentation

UpdateAccountSetup Class

Used by the UpdateAccount method as setup data for invocation.

Syntax

'Declaration

Public Class UpdateAccountSetup

public class UpdateAccountSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.UpdateAccountSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdateAccountSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdateAccount(UpdateAccountSetup) Method


UpdateAccountSetup Class Members | fcSDK Documentation

UpdateAccountSetup Class Members

The following tables list the members exposed by UpdateAccountSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdateAccountSetup Constructor | Initializes a new instance of the UpdateAccountSetup class.

Public Properties

 | Name | Description
Public Property | AccountIDNum | Identifier of the Account being updated
Public Property | AccountName | Name of the Account
Public Property | AccountType | Element from the 'Company Type' user defined list. If not set, the default list value is used.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CreateDate | DateTime the Account was created. If not set, the current time is used.
Public Property | Description | Account description
Public Property | Fax | FAX number for the account
Public Property | FiscalYear | Fiscal year the account was started.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Ownership | Element from the 'Company Ownership' user defined list. If not set, the default list value is used.
Public Property | Phone | Main phone number for the Account
Public Property | Revenue | Element from the 'Company Revenue' user defined list. If not set, the default list value is used.
Public Property | Size | Element from the 'Company Size' user defined list. If not set, the default list value is used.
Public Property | Stock | Stock symbol
Public Property | Territory | Territory of the Account.
Public Property | UserName | User creating the Account
Public Property | WebSite | URL of the Account's web site.

Reference

UpdateAccountSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdateAccount(UpdateAccountSetup) Method


UpdateAccountSetup Constructor | fcSDK Documentation

UpdateAccountSetup Constructor

Identifier of the Account being updated

Initializes a new instance of the UpdateAccountSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _accountIDNum_ As String _
)

[ConstructorIndexAttribute()]
public UpdateAccountSetup(
   string _accountIDNum_
)

Parameters

accountIDNum

Identifier of the Account being updated

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAccountSetup Class
UpdateAccountSetup Members


AccountIDNum Property (UpdateAccountSetup) | fcSDK Documentation

AccountIDNum Property (UpdateAccountSetup)

Identifier of the Account being updated

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AccountIDNum As String

[PropertyBitValueAttribute()]
public string AccountIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAccountSetup Class
UpdateAccountSetup Members


AccountName Property (UpdateAccountSetup) | fcSDK Documentation

AccountName Property (UpdateAccountSetup)

Name of the Account

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AccountName As String

[PropertyBitValueAttribute()]
public string AccountName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAccountSetup Class
UpdateAccountSetup Members


AccountType Property (UpdateAccountSetup) | fcSDK Documentation

AccountType Property (UpdateAccountSetup)

Element from the 'Company Type' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AccountType As String

[PropertyBitValueAttribute()]
public string AccountType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAccountSetup Class
UpdateAccountSetup Members


AdditionalFields Property (UpdateAccountSetup) | fcSDK Documentation

AdditionalFields Property (UpdateAccountSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAccountSetup Class
UpdateAccountSetup Members


CreateDate Property (UpdateAccountSetup) | fcSDK Documentation

CreateDate Property (UpdateAccountSetup)

DateTime the Account was created. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAccountSetup Class
UpdateAccountSetup Members


Description Property (UpdateAccountSetup) | fcSDK Documentation

Description Property (UpdateAccountSetup)

Account description

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Description As String

[PropertyBitValueAttribute()]
public string Description {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAccountSetup Class
UpdateAccountSetup Members


Fax Property (UpdateAccountSetup) | fcSDK Documentation

Fax Property (UpdateAccountSetup)

FAX number for the account

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Fax As String

[PropertyBitValueAttribute()]
public string Fax {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAccountSetup Class
UpdateAccountSetup Members


FiscalYear Property (UpdateAccountSetup) | fcSDK Documentation

FiscalYear Property (UpdateAccountSetup)

Fiscal year the account was started.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FiscalYear As String

[PropertyBitValueAttribute()]
public string FiscalYear {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAccountSetup Class
UpdateAccountSetup Members


GenerateTimeBombs Property (UpdateAccountSetup) | fcSDK Documentation

GenerateTimeBombs Property (UpdateAccountSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAccountSetup Class
UpdateAccountSetup Members


Ownership Property (UpdateAccountSetup) | fcSDK Documentation

Ownership Property (UpdateAccountSetup)

Element from the 'Company Ownership' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Ownership As String

[PropertyBitValueAttribute()]
public string Ownership {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAccountSetup Class
UpdateAccountSetup Members


Phone Property (UpdateAccountSetup) | fcSDK Documentation

Phone Property (UpdateAccountSetup)

Main phone number for the Account

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Phone As String

[PropertyBitValueAttribute()]
public string Phone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAccountSetup Class
UpdateAccountSetup Members


Revenue Property (UpdateAccountSetup) | fcSDK Documentation

Revenue Property (UpdateAccountSetup)

Element from the 'Company Revenue' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Revenue As String

[PropertyBitValueAttribute()]
public string Revenue {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAccountSetup Class
UpdateAccountSetup Members


Size Property (UpdateAccountSetup) | fcSDK Documentation

Size Property (UpdateAccountSetup)

Element from the 'Company Size' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Size As String

[PropertyBitValueAttribute()]
public string Size {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAccountSetup Class
UpdateAccountSetup Members


Stock Property (UpdateAccountSetup) | fcSDK Documentation

Stock Property (UpdateAccountSetup)

Stock symbol

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Stock As String

[PropertyBitValueAttribute()]
public string Stock {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAccountSetup Class
UpdateAccountSetup Members


Territory Property (UpdateAccountSetup) | fcSDK Documentation

Territory Property (UpdateAccountSetup)

Territory of the Account.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Territory As String

[PropertyBitValueAttribute()]
public string Territory {get; set;}

Remarks

Must be a valid Territory name from table 'territory'.

If the property is set to an empty string the relation to the current Territory will be removed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAccountSetup Class
UpdateAccountSetup Members


UserName Property (UpdateAccountSetup) | fcSDK Documentation

UserName Property (UpdateAccountSetup)

User creating the Account

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAccountSetup Class
UpdateAccountSetup Members


WebSite Property (UpdateAccountSetup) | fcSDK Documentation

WebSite Property (UpdateAccountSetup)

URL of the Account's web site.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WebSite As String

[PropertyBitValueAttribute()]
public string WebSite {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAccountSetup Class
UpdateAccountSetup Members


UpdateAddressSetup Class | fcSDK Documentation

UpdateAddressSetup Class

Used by the UpdateAddress method as setup data for invocation.

Syntax

'Declaration

Public Class UpdateAddressSetup

public class UpdateAddressSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.UpdateAddressSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdateAddressSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdateAddress(UpdateAddressSetup) Method


UpdateAddressSetup Class Members | fcSDK Documentation

UpdateAddressSetup Class Members

The following tables list the members exposed by UpdateAddressSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdateAddressSetup Constructor | Initializes a new instance of the UpdateAddressSetup class.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | Address1 | Address Line 1
Public Property | Address2 | Address Line 2
Public Property | AddressObjid | Objid of the Address to be updated
Public Property | City | Address City
Public Property | Country | Address Country
Public Property | IsShortState | Is the State property abbreviated or is it the full name of the State
Public Property | State | Address State
Public Property | TimeZone | Address Timezone
Public Property | ZipCode | Address Zipcode

Reference

UpdateAddressSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdateAddress(UpdateAddressSetup) Method


UpdateAddressSetup Constructor | fcSDK Documentation

UpdateAddressSetup Constructor

Objid of the Address to be updated

Initializes a new instance of the UpdateAddressSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _addressObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public UpdateAddressSetup(
   int _addressObjid_
)

Parameters

addressObjid

Objid of the Address to be updated

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAddressSetup Class
UpdateAddressSetup Members


AdditionalFields Property (UpdateAddressSetup) | fcSDK Documentation

AdditionalFields Property (UpdateAddressSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAddressSetup Class
UpdateAddressSetup Members


Address1 Property (UpdateAddressSetup) | fcSDK Documentation

Address1 Property (UpdateAddressSetup)

Address Line 1

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Address1 As String

[PropertyBitValueAttribute()]
public string Address1 {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAddressSetup Class
UpdateAddressSetup Members


Address2 Property (UpdateAddressSetup) | fcSDK Documentation

Address2 Property (UpdateAddressSetup)

Address Line 2

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Address2 As String

[PropertyBitValueAttribute()]
public string Address2 {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAddressSetup Class
UpdateAddressSetup Members


AddressObjid Property (UpdateAddressSetup) | fcSDK Documentation

AddressObjid Property (UpdateAddressSetup)

Objid of the Address to be updated

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AddressObjid As Integer

[PropertyBitValueAttribute()]
public int AddressObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAddressSetup Class
UpdateAddressSetup Members


City Property (UpdateAddressSetup) | fcSDK Documentation

City Property (UpdateAddressSetup)

Address City

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property City As String

[PropertyBitValueAttribute()]
public string City {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAddressSetup Class
UpdateAddressSetup Members


Country Property (UpdateAddressSetup) | fcSDK Documentation

Country Property (UpdateAddressSetup)

Address Country

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Country As String

[PropertyBitValueAttribute()]
public string Country {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAddressSetup Class
UpdateAddressSetup Members


IsShortState Property (UpdateAddressSetup) | fcSDK Documentation

IsShortState Property (UpdateAddressSetup)

Is the State property abbreviated or is it the full name of the State

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsShortState As Boolean

[PropertyBitValueAttribute()]
public bool IsShortState {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAddressSetup Class
UpdateAddressSetup Members


State Property (UpdateAddressSetup) | fcSDK Documentation

State Property (UpdateAddressSetup)

Address State

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property State As String

[PropertyBitValueAttribute()]
public string State {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAddressSetup Class
UpdateAddressSetup Members


TimeZone Property (UpdateAddressSetup) | fcSDK Documentation

TimeZone Property (UpdateAddressSetup)

Address Timezone

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property TimeZone As String

[PropertyBitValueAttribute()]
public string TimeZone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAddressSetup Class
UpdateAddressSetup Members


ZipCode Property (UpdateAddressSetup) | fcSDK Documentation

ZipCode Property (UpdateAddressSetup)

Address Zipcode

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ZipCode As String

[PropertyBitValueAttribute()]
public string ZipCode {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateAddressSetup Class
UpdateAddressSetup Members


UpdateCommunicationSetup Class | fcSDK Documentation

UpdateCommunicationSetup Class

Used by the UpdateCommunication method as setup data for invocation.

Syntax

'Declaration

Public Class UpdateCommunicationSetup

public class UpdateCommunicationSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.UpdateCommunicationSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdateCommunicationSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace


UpdateCommunicationSetup Class Members | fcSDK Documentation

UpdateCommunicationSetup Class Members

The following tables list the members exposed by UpdateCommunicationSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdateCommunicationSetup Constructor | Initializes a new instance of the UpdateCommunicationSetup class.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | AutoExec | Indicator for user or automatic execution (CommunicationAutoExec).
Public Property | BCCRecipients | Array of addresses for BCC Recipients.
Public Property | CCRecipients | Array of addresses for CC Recipients.
Public Property | ChannelObjid |
Public Property | CommunicationObjid | The unique identifier for the communication to update.
Public Property | DeliveryStatus | The delivery status of the communication (CommunicationDeliveryStatus).
Public Property | Direction | The direction of the message (CommunicationDirection).
Public Property | GenerateTimeBombs |
Public Property | Message | The body text of the communication.
Public Property | MessageId | The ID of the message for the communication.
Public Property | MessageSent | The date and time that the communication was sent.
Public Property | Priority | The Priority of the communication.
Public Property | Recipients | Array of Recipient addresses (usually email addresses).
Public Property | ReplyTo | ReplyTo address (usually email address)
Public Property | Sender | Sender's address (usually email address)
Public Property | Title | The title or subject line of the communication.
Public Property | Updated | The date and time that the communication was updated.
Public Property | UserName |

Reference

UpdateCommunicationSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace


UpdateCommunicationSetup Constructor | fcSDK Documentation

UpdateCommunicationSetup Constructor

The unique identifier for the communication to update.

Initializes a new instance of the UpdateCommunicationSetup class.

Syntax

'Declaration

Public Function New( _
   ByVal _communicationObjid_ As Integer _
)

public UpdateCommunicationSetup(
   int _communicationObjid_
)

Parameters

communicationObjid

The unique identifier for the communication to update.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCommunicationSetup Class
UpdateCommunicationSetup Members


AdditionalFields Property (UpdateCommunicationSetup) | fcSDK Documentation

AdditionalFields Property (UpdateCommunicationSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

Public ReadOnly Property AdditionalFields As SimplifiedAdditionalFields

public SimplifiedAdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCommunicationSetup Class
UpdateCommunicationSetup Members


AutoExec Property (UpdateCommunicationSetup) | fcSDK Documentation

AutoExec Property (UpdateCommunicationSetup)

Indicator for user or automatic execution (CommunicationAutoExec).

Syntax

'Declaration

Public Property AutoExec As Nullable(Of CommunicationAutoExec)

public Nullable<CommunicationAutoExec> AutoExec {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCommunicationSetup Class
UpdateCommunicationSetup Members


BCCRecipients Property (UpdateCommunicationSetup) | fcSDK Documentation

BCCRecipients Property (UpdateCommunicationSetup)

Array of addresses for BCC Recipients.

Syntax

'Declaration

Public Property BCCRecipients As String()

public string[] BCCRecipients {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCommunicationSetup Class
UpdateCommunicationSetup Members


CCRecipients Property (UpdateCommunicationSetup) | fcSDK Documentation

CCRecipients Property (UpdateCommunicationSetup)

Array of addresses for CC Recipients.

Syntax

'Declaration

Public Property CCRecipients As String()

public string[] CCRecipients {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCommunicationSetup Class
UpdateCommunicationSetup Members


ChannelObjid Property (UpdateCommunicationSetup) | fcSDK Documentation

ChannelObjid Property (UpdateCommunicationSetup)

Syntax

'Declaration

Public Property ChannelObjid As Nullable(Of Integer)

public Nullable<int> ChannelObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCommunicationSetup Class
UpdateCommunicationSetup Members


CommunicationObjid Property | fcSDK Documentation

CommunicationObjid Property

The unique identifier for the communication to update.

Syntax

'Declaration

Public Property CommunicationObjid As Integer

public int CommunicationObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCommunicationSetup Class
UpdateCommunicationSetup Members


DeliveryStatus Property (UpdateCommunicationSetup) | fcSDK Documentation

DeliveryStatus Property (UpdateCommunicationSetup)

The delivery status of the communication (CommunicationDeliveryStatus).

Syntax

'Declaration

Public Property DeliveryStatus As Nullable(Of CommunicationDeliveryStatus)

public Nullable<CommunicationDeliveryStatus> DeliveryStatus {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCommunicationSetup Class
UpdateCommunicationSetup Members


Direction Property (UpdateCommunicationSetup) | fcSDK Documentation

Direction Property (UpdateCommunicationSetup)

The direction of the message (CommunicationDirection).

Syntax

'Declaration

Public Property Direction As Nullable(Of CommunicationDirection)

public Nullable<CommunicationDirection> Direction {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCommunicationSetup Class
UpdateCommunicationSetup Members


GenerateTimeBombs Property (UpdateCommunicationSetup) | fcSDK Documentation

GenerateTimeBombs Property (UpdateCommunicationSetup)

Syntax

'Declaration

Public Property GenerateTimeBombs As Boolean

public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCommunicationSetup Class
UpdateCommunicationSetup Members


Message Property (UpdateCommunicationSetup) | fcSDK Documentation

Message Property (UpdateCommunicationSetup)

The body text of the communication.

Syntax

'Declaration

Public Property Message As String

public string Message {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCommunicationSetup Class
UpdateCommunicationSetup Members


MessageId Property (UpdateCommunicationSetup) | fcSDK Documentation

MessageId Property (UpdateCommunicationSetup)

The ID of the message for the communication.

Syntax

'Declaration

Public Property MessageId As String

public string MessageId {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCommunicationSetup Class
UpdateCommunicationSetup Members


MessageSent Property (UpdateCommunicationSetup) | fcSDK Documentation

MessageSent Property (UpdateCommunicationSetup)

The date and time that the communication was sent.

Syntax

'Declaration

Public Property MessageSent As Date

public DateTime MessageSent {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCommunicationSetup Class
UpdateCommunicationSetup Members


Priority Property (UpdateCommunicationSetup) | fcSDK Documentation

Priority Property (UpdateCommunicationSetup)

The Priority of the communication.

Syntax

'Declaration

Public Property Priority As Nullable(Of CommunicationPriority)

public Nullable<CommunicationPriority> Priority {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCommunicationSetup Class
UpdateCommunicationSetup Members


Recipients Property (UpdateCommunicationSetup) | fcSDK Documentation

Recipients Property (UpdateCommunicationSetup)

Array of Recipient addresses (usually email addresses).

Syntax

'Declaration

Public Property Recipients As String()

public string[] Recipients {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCommunicationSetup Class
UpdateCommunicationSetup Members


ReplyTo Property (UpdateCommunicationSetup) | fcSDK Documentation

ReplyTo Property (UpdateCommunicationSetup)

ReplyTo address (usually email address)

Syntax

'Declaration

Public Property ReplyTo As String

public string ReplyTo {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCommunicationSetup Class
UpdateCommunicationSetup Members


Sender Property (UpdateCommunicationSetup) | fcSDK Documentation

Sender Property (UpdateCommunicationSetup)

Sender's address (usually email address)

Syntax

'Declaration

Public Property Sender As String

public string Sender {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCommunicationSetup Class
UpdateCommunicationSetup Members


Title Property (UpdateCommunicationSetup) | fcSDK Documentation

Title Property (UpdateCommunicationSetup)

The title or subject line of the communication.

Syntax

'Declaration

Public Property Title As String

public string Title {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCommunicationSetup Class
UpdateCommunicationSetup Members


Updated Property (UpdateCommunicationSetup) | fcSDK Documentation

Updated Property (UpdateCommunicationSetup)

The date and time that the communication was updated.

Syntax

'Declaration

Public Property Updated As Date

public DateTime Updated {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCommunicationSetup Class
UpdateCommunicationSetup Members


UserName Property (UpdateCommunicationSetup) | fcSDK Documentation

UserName Property (UpdateCommunicationSetup)

Syntax

'Declaration

Public Property UserName As String

public string UserName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCommunicationSetup Class
UpdateCommunicationSetup Members


UpdateContactByObjidSetup Class | fcSDK Documentation

UpdateContactByObjidSetup Class

Syntax

'Declaration

Public Class UpdateContactByObjidSetup

public class UpdateContactByObjidSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.UpdateContactByObjidSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdateContactByObjidSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace


UpdateContactByObjidSetup Class Members | fcSDK Documentation

UpdateContactByObjidSetup Class Members

The following tables list the members exposed by UpdateContactByObjidSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdateContactByObjidSetup Constructor |

Public Properties

 | Name | Description
Public Property | AdditionalFields |
Public Property | ContactObjid |
Public Property | Email |
Public Property | Fax |
Public Property | FirstName |
Public Property | Hours |
Public Property | LastName |
Public Property | MailStop |
Public Property | NewFirstName |
Public Property | NewLastName |
Public Property | NewPhone |
Public Property | NewPrimaryRole |
Public Property | NewPrimarySiteIDNum |
Public Property | Phone |
Public Property | RoleName |
Public Property | Salutation |
Public Property | SiteIDNum |
Public Property | Title |

Reference

UpdateContactByObjidSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace


UpdateContactByObjidSetup Constructor | fcSDK Documentation

UpdateContactByObjidSetup Constructor

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _contactObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public UpdateContactByObjidSetup(
   int _contactObjid_
)

Parameters

contactObjid

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContactByObjidSetup Class
UpdateContactByObjidSetup Members


AdditionalFields Property (UpdateContactByObjidSetup) | fcSDK Documentation

AdditionalFields Property (UpdateContactByObjidSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContactByObjidSetup Class
UpdateContactByObjidSetup Members


ContactObjid Property (UpdateContactByObjidSetup) | fcSDK Documentation

ContactObjid Property (UpdateContactByObjidSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactObjid As Integer

[PropertyBitValueAttribute()]
public int ContactObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContactByObjidSetup Class
UpdateContactByObjidSetup Members


Email Property (UpdateContactByObjidSetup) | fcSDK Documentation

Email Property (UpdateContactByObjidSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Email As String

[PropertyBitValueAttribute()]
public string Email {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContactByObjidSetup Class
UpdateContactByObjidSetup Members


Fax Property (UpdateContactByObjidSetup) | fcSDK Documentation

Fax Property (UpdateContactByObjidSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Fax As String

[PropertyBitValueAttribute()]
public string Fax {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContactByObjidSetup Class
UpdateContactByObjidSetup Members


FirstName Property (UpdateContactByObjidSetup) | fcSDK Documentation

FirstName Property (UpdateContactByObjidSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FirstName As String

[PropertyBitValueAttribute()]
public string FirstName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContactByObjidSetup Class
UpdateContactByObjidSetup Members


Hours Property (UpdateContactByObjidSetup) | fcSDK Documentation

Hours Property (UpdateContactByObjidSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Hours As String

[PropertyBitValueAttribute()]
public string Hours {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContactByObjidSetup Class
UpdateContactByObjidSetup Members


LastName Property (UpdateContactByObjidSetup) | fcSDK Documentation

LastName Property (UpdateContactByObjidSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LastName As String

[PropertyBitValueAttribute()]
public string LastName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContactByObjidSetup Class
UpdateContactByObjidSetup Members


MailStop Property (UpdateContactByObjidSetup) | fcSDK Documentation

MailStop Property (UpdateContactByObjidSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property MailStop As String

[PropertyBitValueAttribute()]
public string MailStop {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContactByObjidSetup Class
UpdateContactByObjidSetup Members


NewFirstName Property (UpdateContactByObjidSetup) | fcSDK Documentation

NewFirstName Property (UpdateContactByObjidSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewFirstName As String

[PropertyBitValueAttribute()]
public string NewFirstName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContactByObjidSetup Class
UpdateContactByObjidSetup Members


NewLastName Property (UpdateContactByObjidSetup) | fcSDK Documentation

NewLastName Property (UpdateContactByObjidSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewLastName As String

[PropertyBitValueAttribute()]
public string NewLastName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContactByObjidSetup Class
UpdateContactByObjidSetup Members


NewPhone Property (UpdateContactByObjidSetup) | fcSDK Documentation

NewPhone Property (UpdateContactByObjidSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewPhone As String

[PropertyBitValueAttribute()]
public string NewPhone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContactByObjidSetup Class
UpdateContactByObjidSetup Members


NewPrimaryRole Property (UpdateContactByObjidSetup) | fcSDK Documentation

NewPrimaryRole Property (UpdateContactByObjidSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewPrimaryRole As String

[PropertyBitValueAttribute()]
public string NewPrimaryRole {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContactByObjidSetup Class
UpdateContactByObjidSetup Members


NewPrimarySiteIDNum Property (UpdateContactByObjidSetup) | fcSDK Documentation

NewPrimarySiteIDNum Property (UpdateContactByObjidSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewPrimarySiteIDNum As String

[PropertyBitValueAttribute()]
public string NewPrimarySiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContactByObjidSetup Class
UpdateContactByObjidSetup Members


Phone Property (UpdateContactByObjidSetup) | fcSDK Documentation

Phone Property (UpdateContactByObjidSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Phone As String

[PropertyBitValueAttribute()]
public string Phone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContactByObjidSetup Class
UpdateContactByObjidSetup Members


RoleName Property (UpdateContactByObjidSetup) | fcSDK Documentation

RoleName Property (UpdateContactByObjidSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property RoleName As String

[PropertyBitValueAttribute()]
public string RoleName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContactByObjidSetup Class
UpdateContactByObjidSetup Members


Salutation Property (UpdateContactByObjidSetup) | fcSDK Documentation

Salutation Property (UpdateContactByObjidSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Salutation As String

[PropertyBitValueAttribute()]
public string Salutation {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContactByObjidSetup Class
UpdateContactByObjidSetup Members


SiteIDNum Property (UpdateContactByObjidSetup) | fcSDK Documentation

SiteIDNum Property (UpdateContactByObjidSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteIDNum As String

[PropertyBitValueAttribute()]
public string SiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContactByObjidSetup Class
UpdateContactByObjidSetup Members


Title Property (UpdateContactByObjidSetup) | fcSDK Documentation

Title Property (UpdateContactByObjidSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Title As String

[PropertyBitValueAttribute()]
public string Title {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContactByObjidSetup Class
UpdateContactByObjidSetup Members


UpdateContactSetup Class | fcSDK Documentation

UpdateContactSetup Class

Used by the UpdateContact method as setup data for invocation.

Syntax

'Declaration

Public Class UpdateContactSetup

public class UpdateContactSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.UpdateContactSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdateContactSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdateContact(UpdateContactSetup) Method


UpdateContactSetup Class Members | fcSDK Documentation

UpdateContactSetup Class Members

The following tables list the members exposed by UpdateContactSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdateContactSetup Constructor | Initializes a new instance of the UpdateContactSetup class.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation. | | Public Property | Email | Contact email address | | Public Property | Fax | Contact fax number | | Public Property | FirstName | Contact's first name | | Public Property | Hours | Job hours for the contact | | Public Property | LastName | Contact's last name | | Public Property | MailStop | Mail stop for Contact | | Public Property | NewFirstName | Contact's new first name. | | Public Property | NewLastName | Contact's new last name. | | Public Property | NewPhone | Contact's new telephone number. | | Public Property | NewPrimaryRole | New contact role. Element from the 'Contact Role' application list. If not set the default list value is used. | | Public Property | NewPrimarySiteIDNum | Identifier of the new site for the contact role.

| | Public Property | Phone | Contact's telephone number | | Public Property | RoleName | Current role for the Contact at their site. Element from the 'Contact Role' application list. If not set, the default list value is used. | | Public Property | Salutation | Salutation for the Contact | | Public Property | SiteIDNum |

Identifier of the contact's current site.

| | Public Property | Title | Job title for the Contact | | Public Property | UserName | |

Reference

UpdateContactSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdateContact(UpdateContactSetup) Method


UpdateContactSetup Constructor | fcSDK Documentation

UpdateContactSetup Constructor

Contact's first name

Contact's last name

Contact's telephone number

Identifier of the contact's current site.

Current role for the Contact at their site. Element from the 'Contact Role' application list. If not set, the default list value is used.

Initializes a new instance of the UpdateContactSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _firstName_ As String, _
   ByVal _lastName_ As String, _
   ByVal _phone_ As String, _
   ByVal _siteIDNum_ As String, _
   ByVal _roleName_ As String _
)

[ConstructorIndexAttribute()]
public UpdateContactSetup(
   string _firstName_,
   string _lastName_,
   string _phone_,
   string _siteIDNum_,
   string _roleName_
)

Parameters

firstName

Contact's first name

lastName

Contact's last name

phone

Contact's telephone number

siteIDNum

Identifier of the contact's current site.

roleName

Current role for the Contact at their site. Element from the 'Contact Role' application list. If not set, the default list value is used.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContactSetup Class
UpdateContactSetup Members


AdditionalFields Property (UpdateContactSetup) | fcSDK Documentation

AdditionalFields Property (UpdateContactSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContactSetup Class
UpdateContactSetup Members


Email Property (UpdateContactSetup) | fcSDK Documentation

Email Property (UpdateContactSetup)

Contact email address

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Email As String

[PropertyBitValueAttribute()]
public string Email {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContactSetup Class
UpdateContactSetup Members


Fax Property (UpdateContactSetup) | fcSDK Documentation

Fax Property (UpdateContactSetup)

Contact fax number

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Fax As String

[PropertyBitValueAttribute()]
public string Fax {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContactSetup Class
UpdateContactSetup Members


FirstName Property (UpdateContactSetup) | fcSDK Documentation

FirstName Property (UpdateContactSetup)

Contact's first name

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FirstName As String

[PropertyBitValueAttribute()]
public string FirstName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContactSetup Class
UpdateContactSetup Members


Hours Property (UpdateContactSetup) | fcSDK Documentation

Hours Property (UpdateContactSetup)

Job hours for the contact

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Hours As String

[PropertyBitValueAttribute()]
public string Hours {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContactSetup Class
UpdateContactSetup Members


LastName Property (UpdateContactSetup) | fcSDK Documentation

LastName Property (UpdateContactSetup)

Contact's last name

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LastName As String

[PropertyBitValueAttribute()]
public string LastName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContactSetup Class
UpdateContactSetup Members


MailStop Property (UpdateContactSetup) | fcSDK Documentation

MailStop Property (UpdateContactSetup)

Mail stop for Contact

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property MailStop As String

[PropertyBitValueAttribute()]
public string MailStop {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContactSetup Class
UpdateContactSetup Members


NewFirstName Property (UpdateContactSetup) | fcSDK Documentation

NewFirstName Property (UpdateContactSetup)

Contact's new first name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewFirstName As String

[PropertyBitValueAttribute()]
public string NewFirstName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContactSetup Class
UpdateContactSetup Members


NewLastName Property (UpdateContactSetup) | fcSDK Documentation

NewLastName Property (UpdateContactSetup)

Contact's new last name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewLastName As String

[PropertyBitValueAttribute()]
public string NewLastName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContactSetup Class
UpdateContactSetup Members


NewPhone Property (UpdateContactSetup) | fcSDK Documentation

NewPhone Property (UpdateContactSetup)

Contact's new telephone number.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewPhone As String

[PropertyBitValueAttribute()]
public string NewPhone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContactSetup Class
UpdateContactSetup Members


NewPrimaryRole Property (UpdateContactSetup) | fcSDK Documentation

NewPrimaryRole Property (UpdateContactSetup)

New contact role. Element from the 'Contact Role' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewPrimaryRole As String

[PropertyBitValueAttribute()]
public string NewPrimaryRole {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContactSetup Class
UpdateContactSetup Members


NewPrimarySiteIDNum Property (UpdateContactSetup) | fcSDK Documentation

NewPrimarySiteIDNum Property (UpdateContactSetup)

Identifier of the new site for the contact role.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewPrimarySiteIDNum As String

[PropertyBitValueAttribute()]
public string NewPrimarySiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContactSetup Class
UpdateContactSetup Members


Phone Property (UpdateContactSetup) | fcSDK Documentation

Phone Property (UpdateContactSetup)

Contact's telephone number

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Phone As String

[PropertyBitValueAttribute()]
public string Phone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContactSetup Class
UpdateContactSetup Members


RoleName Property (UpdateContactSetup) | fcSDK Documentation

RoleName Property (UpdateContactSetup)

Current role for the Contact at their site. Element from the 'Contact Role' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property RoleName As String

[PropertyBitValueAttribute()]
public string RoleName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContactSetup Class
UpdateContactSetup Members


Salutation Property (UpdateContactSetup) | fcSDK Documentation

Salutation Property (UpdateContactSetup)

Salutation for the Contact

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Salutation As String

[PropertyBitValueAttribute()]
public string Salutation {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContactSetup Class
UpdateContactSetup Members


SiteIDNum Property (UpdateContactSetup) | fcSDK Documentation

SiteIDNum Property (UpdateContactSetup)

Identifier of the contact's current site.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteIDNum As String

[PropertyBitValueAttribute()]
public string SiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContactSetup Class
UpdateContactSetup Members


Title Property (UpdateContactSetup) | fcSDK Documentation

Title Property (UpdateContactSetup)

Job title for the Contact

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Title As String

[PropertyBitValueAttribute()]
public string Title {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContactSetup Class
UpdateContactSetup Members


UserName Property (UpdateContactSetup) | fcSDK Documentation

UserName Property (UpdateContactSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContactSetup Class
UpdateContactSetup Members


UpdateContractSetup Class | fcSDK Documentation

UpdateContractSetup Class

Used by the UpdateContract method as setup data for invocation.

Syntax

'Declaration

Public Class UpdateContractSetup

public class UpdateContractSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.UpdateContractSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdateContractSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdateContract(UpdateContractSetup) Method


UpdateContractSetup Class Members | fcSDK Documentation

UpdateContractSetup Class Members

The following tables list the members exposed by UpdateContractSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdateContractSetup Constructor | Initializes a new instance of the UpdateContractSetup class.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation. | | Public Property | BusinessHoursForPM | Specific hours when preventive maintainence is allowed | | Public Property | ContractIDNum | Identifier of the Contract to update | | Public Property | ContractType | Element from the 'Contract Type' user defined list. If not set, the default list value is used. | | Public Property | ExpireDate | Contract expiration date

| | Public Property | Notes | Notes concerning the contract | | Public Property | OnsiteResponseDuration |

The maximum amount of time allowed by the Contract for a field engineer to arrive onsite

| | Public Property | PayOptions | Method of payment for the Contract | | Public Property | PhoneResponseDuration | The maximum amount of time allowed by the Contract for a customer service representative to contact the customer by telephone | | Public Property | PONumber | Purchase Order number | | Public Property | StartDate | Contract starting date | | Public Property | Status | Element from the 'Contract Status' user defined list. If not set, the default list value is used. | | Public Property | UnitsAvailable | Number of units currently available for use | | Public Property | UnitsPurchased | Number of units purchased | | Public Property | UnitsUsed | Number of units used | | Public Property | UnitType | The type of units the object is delivered in | | Public Property | UseSpecialConsiderations | Does Contract have special considerations? |

Reference

UpdateContractSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdateContract(UpdateContractSetup) Method


UpdateContractSetup Constructor | fcSDK Documentation

UpdateContractSetup Constructor

Identifier of the Contract to update

Initializes a new instance of the UpdateContractSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _contractIDNum_ As String _
)

[ConstructorIndexAttribute()]
public UpdateContractSetup(
   string _contractIDNum_
)

Parameters

contractIDNum

Identifier of the Contract to update

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContractSetup Class
UpdateContractSetup Members


AdditionalFields Property (UpdateContractSetup) | fcSDK Documentation

AdditionalFields Property (UpdateContractSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContractSetup Class
UpdateContractSetup Members


BusinessHoursForPM Property (UpdateContractSetup) | fcSDK Documentation

BusinessHoursForPM Property (UpdateContractSetup)

Specific hours when preventive maintainence is allowed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property BusinessHoursForPM As String

[PropertyBitValueAttribute()]
public string BusinessHoursForPM {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContractSetup Class
UpdateContractSetup Members


ContractIDNum Property (UpdateContractSetup) | fcSDK Documentation

ContractIDNum Property (UpdateContractSetup)

Identifier of the Contract to update

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContractIDNum As String

[PropertyBitValueAttribute()]
public string ContractIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContractSetup Class
UpdateContractSetup Members


ContractType Property (UpdateContractSetup) | fcSDK Documentation

ContractType Property (UpdateContractSetup)

Element from the 'Contract Type' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContractType As String

[PropertyBitValueAttribute()]
public string ContractType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContractSetup Class
UpdateContractSetup Members


ExpireDate Property (UpdateContractSetup) | fcSDK Documentation

ExpireDate Property (UpdateContractSetup)

Contract expiration date

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ExpireDate As Date

[PropertyBitValueAttribute()]
public DateTime ExpireDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContractSetup Class
UpdateContractSetup Members


Notes Property (UpdateContractSetup) | fcSDK Documentation

Notes Property (UpdateContractSetup)

Notes concerning the contract

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContractSetup Class
UpdateContractSetup Members


OnsiteResponseDuration Property (UpdateContractSetup) | fcSDK Documentation

OnsiteResponseDuration Property (UpdateContractSetup)

The maximum amount of time allowed by the Contract for a field engineer to arrive onsite

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property OnsiteResponseDuration As TimeSpan

[PropertyBitValueAttribute()]
public TimeSpan OnsiteResponseDuration {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContractSetup Class
UpdateContractSetup Members


PayOptions Property (UpdateContractSetup) | fcSDK Documentation

PayOptions Property (UpdateContractSetup)

Method of payment for the Contract

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PayOptions As String

[PropertyBitValueAttribute()]
public string PayOptions {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContractSetup Class
UpdateContractSetup Members


PhoneResponseDuration Property (UpdateContractSetup) | fcSDK Documentation

PhoneResponseDuration Property (UpdateContractSetup)

The maximum amount of time allowed by the Contract for a customer service representative to contact the customer by telephone

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PhoneResponseDuration As TimeSpan

[PropertyBitValueAttribute()]
public TimeSpan PhoneResponseDuration {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContractSetup Class
UpdateContractSetup Members


PONumber Property (UpdateContractSetup) | fcSDK Documentation

PONumber Property (UpdateContractSetup)

Purchase Order number

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PONumber As String

[PropertyBitValueAttribute()]
public string PONumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContractSetup Class
UpdateContractSetup Members


StartDate Property (UpdateContractSetup) | fcSDK Documentation

StartDate Property (UpdateContractSetup)

Contract starting date

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property StartDate As Date

[PropertyBitValueAttribute()]
public DateTime StartDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContractSetup Class
UpdateContractSetup Members


Status Property (UpdateContractSetup) | fcSDK Documentation

Status Property (UpdateContractSetup)

Element from the 'Contract Status' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Status As String

[PropertyBitValueAttribute()]
public string Status {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContractSetup Class
UpdateContractSetup Members


UnitsAvailable Property (UpdateContractSetup) | fcSDK Documentation

UnitsAvailable Property (UpdateContractSetup)

Number of units currently available for use

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UnitsAvailable As Double

[PropertyBitValueAttribute()]
public double UnitsAvailable {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContractSetup Class
UpdateContractSetup Members


UnitsPurchased Property (UpdateContractSetup) | fcSDK Documentation

UnitsPurchased Property (UpdateContractSetup)

Number of units purchased

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UnitsPurchased As Double

[PropertyBitValueAttribute()]
public double UnitsPurchased {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContractSetup Class
UpdateContractSetup Members


UnitsUsed Property (UpdateContractSetup) | fcSDK Documentation

UnitsUsed Property (UpdateContractSetup)

Number of units used

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UnitsUsed As Double

[PropertyBitValueAttribute()]
public double UnitsUsed {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContractSetup Class
UpdateContractSetup Members


UnitType Property (UpdateContractSetup) | fcSDK Documentation

UnitType Property (UpdateContractSetup)

The type of units the object is delivered in

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UnitType As String

[PropertyBitValueAttribute()]
public string UnitType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContractSetup Class
UpdateContractSetup Members


UseSpecialConsiderations Property (UpdateContractSetup) | fcSDK Documentation

UseSpecialConsiderations Property (UpdateContractSetup)

Does Contract have special considerations?

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UseSpecialConsiderations As Boolean

[PropertyBitValueAttribute()]
public bool UseSpecialConsiderations {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateContractSetup Class
UpdateContractSetup Members


UpdateDialogueSetup Class | fcSDK Documentation

UpdateDialogueSetup Class

Used by the UpdateDialogue method as setup data for invocation.

Syntax

'Declaration

Public Class UpdateDialogueSetup

public class UpdateDialogueSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.UpdateDialogueSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdateDialogueSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace


UpdateDialogueSetup Class Members | fcSDK Documentation

UpdateDialogueSetup Class Members

The following tables list the members exposed by UpdateDialogueSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdateDialogueSetup Constructor | Initializes a new instance of the UpdateDialogueSetup class.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | IDNumber | The ID NUmber of the dialogue.
Public Property | Priority | The Priority of the dialogue.
Public Property | Title | The title of the dialogue.
Public Property | Updated | The date and time that the communication was updated.
Public Property | UserName |

Reference

UpdateDialogueSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace


UpdateDialogueSetup Constructor | fcSDK Documentation

UpdateDialogueSetup Constructor

The ID Number of the dialogue.

Initializes a new instance of the UpdateDialogueSetup class.

Syntax

'Declaration

Public Function New( _
   ByVal _idNumber_ As String _
)

public UpdateDialogueSetup(
   string _idNumber_
)

Parameters

idNumber

The ID Number of the dialogue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateDialogueSetup Class
UpdateDialogueSetup Members


AdditionalFields Property (UpdateDialogueSetup) | fcSDK Documentation

AdditionalFields Property (UpdateDialogueSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

Public ReadOnly Property AdditionalFields As SimplifiedAdditionalFields

public SimplifiedAdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateDialogueSetup Class
UpdateDialogueSetup Members


GenerateTimeBombs Property (UpdateDialogueSetup) | fcSDK Documentation

GenerateTimeBombs Property (UpdateDialogueSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

Public Property GenerateTimeBombs As Boolean

public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateDialogueSetup Class
UpdateDialogueSetup Members


IDNumber Property (UpdateDialogueSetup) | fcSDK Documentation

IDNumber Property (UpdateDialogueSetup)

The ID NUmber of the dialogue.

Syntax

'Declaration

Public Property IDNumber As String

public string IDNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateDialogueSetup Class
UpdateDialogueSetup Members


Priority Property (UpdateDialogueSetup) | fcSDK Documentation

Priority Property (UpdateDialogueSetup)

The Priority of the dialogue.

Syntax

'Declaration

Public Property Priority As String

public string Priority {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateDialogueSetup Class
UpdateDialogueSetup Members


Title Property (UpdateDialogueSetup) | fcSDK Documentation

Title Property (UpdateDialogueSetup)

The title of the dialogue.

Syntax

'Declaration

Public Property Title As String

public string Title {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateDialogueSetup Class
UpdateDialogueSetup Members


Updated Property (UpdateDialogueSetup) | fcSDK Documentation

Updated Property (UpdateDialogueSetup)

The date and time that the communication was updated.

Syntax

'Declaration

Public Property Updated As Date

public DateTime Updated {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateDialogueSetup Class
UpdateDialogueSetup Members


UserName Property (UpdateDialogueSetup) | fcSDK Documentation

UserName Property (UpdateDialogueSetup)

Syntax

'Declaration

Public Property UserName As String

public string UserName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateDialogueSetup Class
UpdateDialogueSetup Members


UpdatePartRevisionSetup Class | fcSDK Documentation

UpdatePartRevisionSetup Class

Used by the UpdatePartRevision method as setup data for invocation.

Syntax

'Declaration

Public Class UpdatePartRevisionSetup

public class UpdatePartRevisionSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.UpdatePartRevisionSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdatePartRevisionSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdatePartRevision(UpdatePartRevisionSetup) Method


UpdatePartRevisionSetup Class Members | fcSDK Documentation

UpdatePartRevisionSetup Class Members

The following tables list the members exposed by UpdatePartRevisionSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdatePartRevisionSetup Constructor | Initializes a new instance of the UpdatePartRevisionSetup class.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | NewPartRevision | This will be the new revision for this PartRevision. | | Public Property | PartDomain | Domain of the part | | Public Property | PartNumber | Part number of the part | | Public Property | PartRevision | Revision to create | | Public Property | ReplaceDate | DateTime this part replaced the previous one. | | Public Property | ReplacePartDomain | Previous domain this PartRevision replaces.

| | Public Property | ReplacePartNumber |

Previous part number this PartRevision replaces.

| | Public Property | ReplacePartRevision |

Previous revision this PartRevision replaces.

| | Public Property | Status | The status of the revision. |

Reference

UpdatePartRevisionSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdatePartRevision(UpdatePartRevisionSetup) Method


UpdatePartRevisionSetup Constructor | fcSDK Documentation

UpdatePartRevisionSetup Constructor

Part number of the part

Domain of the part

Revision to create

Initializes a new instance of the UpdatePartRevisionSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partNumber_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _partRevision_ As String _
)

[ConstructorIndexAttribute()]
public UpdatePartRevisionSetup(
   string _partNumber_,
   string _partDomain_,
   string _partRevision_
)

Parameters

partNumber

Part number of the part

partDomain

Domain of the part

partRevision

Revision to create

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRevisionSetup Class
UpdatePartRevisionSetup Members


NewPartRevision Property | fcSDK Documentation

NewPartRevision Property

This will be the new revision for this PartRevision.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewPartRevision As String

[PropertyBitValueAttribute()]
public string NewPartRevision {get; set;}

Remarks

If this property has not been set no change will occur. If the property is set, even to an empty string, that value reflected in the update.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRevisionSetup Class
UpdatePartRevisionSetup Members


PartDomain Property (UpdatePartRevisionSetup) | fcSDK Documentation

PartDomain Property (UpdatePartRevisionSetup)

Domain of the part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartDomain As String

[PropertyBitValueAttribute()]
public string PartDomain {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRevisionSetup Class
UpdatePartRevisionSetup Members


PartNumber Property (UpdatePartRevisionSetup) | fcSDK Documentation

PartNumber Property (UpdatePartRevisionSetup)

Part number of the part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartNumber As String

[PropertyBitValueAttribute()]
public string PartNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRevisionSetup Class
UpdatePartRevisionSetup Members


PartRevision Property (UpdatePartRevisionSetup) | fcSDK Documentation

PartRevision Property (UpdatePartRevisionSetup)

Revision to create

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRevision As String

[PropertyBitValueAttribute()]
public string PartRevision {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRevisionSetup Class
UpdatePartRevisionSetup Members


ReplaceDate Property (UpdatePartRevisionSetup) | fcSDK Documentation

ReplaceDate Property (UpdatePartRevisionSetup)

DateTime this part replaced the previous one.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ReplaceDate As Date

[PropertyBitValueAttribute()]
public DateTime ReplaceDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRevisionSetup Class
UpdatePartRevisionSetup Members


ReplacePartDomain Property (UpdatePartRevisionSetup) | fcSDK Documentation

ReplacePartDomain Property (UpdatePartRevisionSetup)

Previous domain this PartRevision replaces.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ReplacePartDomain As String

[PropertyBitValueAttribute()]
public string ReplacePartDomain {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRevisionSetup Class
UpdatePartRevisionSetup Members


ReplacePartNumber Property (UpdatePartRevisionSetup) | fcSDK Documentation

ReplacePartNumber Property (UpdatePartRevisionSetup)

Previous part number this PartRevision replaces.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ReplacePartNumber As String

[PropertyBitValueAttribute()]
public string ReplacePartNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRevisionSetup Class
UpdatePartRevisionSetup Members


ReplacePartRevision Property (UpdatePartRevisionSetup) | fcSDK Documentation

ReplacePartRevision Property (UpdatePartRevisionSetup)

Previous revision this PartRevision replaces.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ReplacePartRevision As String

[PropertyBitValueAttribute()]
public string ReplacePartRevision {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRevisionSetup Class
UpdatePartRevisionSetup Members


Status Property (UpdatePartRevisionSetup) | fcSDK Documentation

Status Property (UpdatePartRevisionSetup)

The status of the revision.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Status As PartRevisionStatus

[PropertyBitValueAttribute()]
public PartRevisionStatus Status {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRevisionSetup Class
UpdatePartRevisionSetup Members


UpdatePartSetup Class | fcSDK Documentation

UpdatePartSetup Class

Used by the UpdatePart method as setup data for invocation.

Syntax

'Declaration

Public Class UpdatePartSetup

public class UpdatePartSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.UpdatePartSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdatePartSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdatePart(UpdatePartSetup) Method


UpdatePartSetup Class Members | fcSDK Documentation

UpdatePartSetup Class Members

The following tables list the members exposed by UpdatePartSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdatePartSetup Constructor | Initializes a new instance of the UpdatePartSetup class.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation. | | Public Property | Description | Description of the part | | Public Property | Dimension | Dimensions of the part | | Public Property | Family | Level 1 Element from the 'Family' user defined list. If not set, the default list value is used. | | Public Property | Line | Level 2 Element from the 'Family' user defined list. If not set, the default list value is used. | | Public Property | ModelNumber | Model number of the part | | Public Property | Notes | Notes about the part | | Public Property | PartClass | Part class for the part to update. | | Public Property | PartDomain | Domain for the part to update. | | Public Property | PartNumber | Part number for the part to update

| | Public Property | PartType | Element from the 'Part Type' user defined list. If not set, the default list value is used. | | Public Property | RepairType | Type of repair. One of "Repairable" or "Expendable" | | Public Property | UnitMeasure | Unit of measure for the part | | Public Property | WarrantyDays | Number of warranty days for the part | | Public Property | WarrantyStartOnShipment | Does the warranty start on shipment? | | Public Property | Weight | Unit weight of the part |

Reference

UpdatePartSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdatePart(UpdatePartSetup) Method


UpdatePartSetup Constructor | fcSDK Documentation

UpdatePartSetup Constructor

Part number for the part to update

Domain for the part to update.

Number of warranty days for the part

Initializes a new instance of the UpdatePartSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partNumber_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _warrantyDays_ As Integer _
)

[ConstructorIndexAttribute()]
public UpdatePartSetup(
   string _partNumber_,
   string _partDomain_,
   int _warrantyDays_
)

Parameters

partNumber

Part number for the part to update

partDomain

Domain for the part to update.

warrantyDays

Number of warranty days for the part

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartSetup Class
UpdatePartSetup Members


AdditionalFields Property (UpdatePartSetup) | fcSDK Documentation

AdditionalFields Property (UpdatePartSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartSetup Class
UpdatePartSetup Members


Description Property (UpdatePartSetup) | fcSDK Documentation

Description Property (UpdatePartSetup)

Description of the part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Description As String

[PropertyBitValueAttribute()]
public string Description {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartSetup Class
UpdatePartSetup Members


Dimension Property (UpdatePartSetup) | fcSDK Documentation

Dimension Property (UpdatePartSetup)

Dimensions of the part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Dimension As String

[PropertyBitValueAttribute()]
public string Dimension {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartSetup Class
UpdatePartSetup Members


Family Property (UpdatePartSetup) | fcSDK Documentation

Family Property (UpdatePartSetup)

Level 1 Element from the 'Family' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Family As String

[PropertyBitValueAttribute()]
public string Family {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartSetup Class
UpdatePartSetup Members


Line Property (UpdatePartSetup) | fcSDK Documentation

Line Property (UpdatePartSetup)

Level 2 Element from the 'Family' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Line As String

[PropertyBitValueAttribute()]
public string Line {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartSetup Class
UpdatePartSetup Members


ModelNumber Property (UpdatePartSetup) | fcSDK Documentation

ModelNumber Property (UpdatePartSetup)

Model number of the part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ModelNumber As String

[PropertyBitValueAttribute()]
public string ModelNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartSetup Class
UpdatePartSetup Members


Notes Property (UpdatePartSetup) | fcSDK Documentation

Notes Property (UpdatePartSetup)

Notes about the part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartSetup Class
UpdatePartSetup Members


PartClass Property (UpdatePartSetup) | fcSDK Documentation

PartClass Property (UpdatePartSetup)

Part class for the part to update.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartClass As String

[PropertyBitValueAttribute()]
public string PartClass {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartSetup Class
UpdatePartSetup Members


PartDomain Property (UpdatePartSetup) | fcSDK Documentation

PartDomain Property (UpdatePartSetup)

Domain for the part to update.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartDomain As String

[PropertyBitValueAttribute()]
public string PartDomain {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartSetup Class
UpdatePartSetup Members


PartNumber Property (UpdatePartSetup) | fcSDK Documentation

PartNumber Property (UpdatePartSetup)

Part number for the part to update

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartNumber As String

[PropertyBitValueAttribute()]
public string PartNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartSetup Class
UpdatePartSetup Members


PartType Property (UpdatePartSetup) | fcSDK Documentation

PartType Property (UpdatePartSetup)

Element from the 'Part Type' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartType As String

[PropertyBitValueAttribute()]
public string PartType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartSetup Class
UpdatePartSetup Members


RepairType Property (UpdatePartSetup) | fcSDK Documentation

RepairType Property (UpdatePartSetup)

Type of repair. One of "Repairable" or "Expendable"

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property RepairType As PartRepairType

[PropertyBitValueAttribute()]
public PartRepairType RepairType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartSetup Class
UpdatePartSetup Members


UnitMeasure Property (UpdatePartSetup) | fcSDK Documentation

UnitMeasure Property (UpdatePartSetup)

Unit of measure for the part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UnitMeasure As String

[PropertyBitValueAttribute()]
public string UnitMeasure {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartSetup Class
UpdatePartSetup Members


WarrantyDays Property (UpdatePartSetup) | fcSDK Documentation

WarrantyDays Property (UpdatePartSetup)

Number of warranty days for the part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WarrantyDays As Integer

[PropertyBitValueAttribute()]
public int WarrantyDays {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartSetup Class
UpdatePartSetup Members


WarrantyStartOnShipment Property (UpdatePartSetup) | fcSDK Documentation

WarrantyStartOnShipment Property (UpdatePartSetup)

Does the warranty start on shipment?

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WarrantyStartOnShipment As Boolean

[PropertyBitValueAttribute()]
public bool WarrantyStartOnShipment {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartSetup Class
UpdatePartSetup Members


Weight Property (UpdatePartSetup) | fcSDK Documentation

Weight Property (UpdatePartSetup)

Unit weight of the part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Weight As String

[PropertyBitValueAttribute()]
public string Weight {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartSetup Class
UpdatePartSetup Members


UpdatePriceInstanceSetup Class | fcSDK Documentation

UpdatePriceInstanceSetup Class

Used by the UpdatePriceInstance method as setup data for invocation.

Syntax

'Declaration

Public Class UpdatePriceInstanceSetup

public class UpdatePriceInstanceSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.UpdatePriceInstanceSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdatePriceInstanceSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdatePriceInstance(UpdatePriceInstanceSetup) Method


UpdatePriceInstanceSetup Class Members | fcSDK Documentation

UpdatePriceInstanceSetup Class Members

The following tables list the members exposed by UpdatePriceInstanceSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdatePriceInstanceSetup Constructor | Initializes a new instance of the UpdatePriceInstanceSetup class.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | PartDomain | Domain of the part | | Public Property | PartNumber | Part number to price

| | Public Property | PartRevision |

Revision to price

| | Public Property | Price | Price of the part | | Public Property | PricedQuantity | How many units in this price instance. | | Public Property | PriceProgram | Name of the price program | | Public Property | UpdateDate | Date when the Price was updated, any Date between the start and end date is valid. |

Reference

UpdatePriceInstanceSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdatePriceInstance(UpdatePriceInstanceSetup) Method


UpdatePriceInstanceSetup Constructor | fcSDK Documentation

UpdatePriceInstanceSetup Constructor

Part number to price

Domain of the part

Revision to price

Name of the price program

How many units in this price instance.

Price of the part

Date when the Price was updated, any Date between the start and end date is valid.

Initializes a new instance of the UpdatePriceInstanceSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partNumber_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _priceProgram_ As String, _
   ByVal _pricedQuantity_ As Integer, _
   ByVal _price_ As Decimal, _
   ByVal _updateDate_ As Date _
)

[ConstructorIndexAttribute()]
public UpdatePriceInstanceSetup(
   string _partNumber_,
   string _partDomain_,
   string _partRevision_,
   string _priceProgram_,
   int _pricedQuantity_,
   decimal _price_,
   DateTime _updateDate_
)

Parameters

partNumber

Part number to price

partDomain

Domain of the part

partRevision

Revision to price

priceProgram

Name of the price program

pricedQuantity

How many units in this price instance.

price

Price of the part

updateDate

Date when the Price was updated, any Date between the start and end date is valid.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePriceInstanceSetup Class
UpdatePriceInstanceSetup Members


PartDomain Property (UpdatePriceInstanceSetup) | fcSDK Documentation

PartDomain Property (UpdatePriceInstanceSetup)

Domain of the part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartDomain As String

[PropertyBitValueAttribute()]
public string PartDomain {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePriceInstanceSetup Class
UpdatePriceInstanceSetup Members


PartNumber Property (UpdatePriceInstanceSetup) | fcSDK Documentation

PartNumber Property (UpdatePriceInstanceSetup)

Part number to price

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartNumber As String

[PropertyBitValueAttribute()]
public string PartNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePriceInstanceSetup Class
UpdatePriceInstanceSetup Members


PartRevision Property (UpdatePriceInstanceSetup) | fcSDK Documentation

PartRevision Property (UpdatePriceInstanceSetup)

Revision to price

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRevision As String

[PropertyBitValueAttribute()]
public string PartRevision {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePriceInstanceSetup Class
UpdatePriceInstanceSetup Members


Price Property (UpdatePriceInstanceSetup) | fcSDK Documentation

Price Property (UpdatePriceInstanceSetup)

Price of the part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Price As Decimal

[PropertyBitValueAttribute()]
public decimal Price {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePriceInstanceSetup Class
UpdatePriceInstanceSetup Members


PricedQuantity Property (UpdatePriceInstanceSetup) | fcSDK Documentation

PricedQuantity Property (UpdatePriceInstanceSetup)

How many units in this price instance.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PricedQuantity As Integer

[PropertyBitValueAttribute()]
public int PricedQuantity {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePriceInstanceSetup Class
UpdatePriceInstanceSetup Members


PriceProgram Property (UpdatePriceInstanceSetup) | fcSDK Documentation

PriceProgram Property (UpdatePriceInstanceSetup)

Name of the price program

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PriceProgram As String

[PropertyBitValueAttribute()]
public string PriceProgram {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePriceInstanceSetup Class
UpdatePriceInstanceSetup Members


UpdateDate Property (UpdatePriceInstanceSetup) | fcSDK Documentation

UpdateDate Property (UpdatePriceInstanceSetup)

Date when the Price was updated, any Date between the start and end date is valid.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UpdateDate As Date

[PropertyBitValueAttribute()]
public DateTime UpdateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePriceInstanceSetup Class
UpdatePriceInstanceSetup Members


UpdateProductBinSetup Class | fcSDK Documentation

UpdateProductBinSetup Class

Used by the UpdateProductBin method as setup data for invocation.

Syntax

'Declaration

Public Class UpdateProductBinSetup

public class UpdateProductBinSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.UpdateProductBinSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdateProductBinSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdateProductBin(UpdateProductBinSetup) Method


UpdateProductBinSetup Class Members | fcSDK Documentation

UpdateProductBinSetup Class Members

The following tables list the members exposed by UpdateProductBinSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdateProductBinSetup Constructor | Initializes a new instance of the UpdateProductBinSetup class.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | BinName | Name of the bin to create | | Public Property | BinObjid | Objid of the Bin to be updated

| | Public Property | Description | Bin description | | Public Property | PrimarySupportEmployeeObjid | Objid of the primary support Employee. | | Public Property | SecondarySupportEmployeeObjid | Objid of the secondary support Employee. | | Public Property | UpdateDate | Date when the Bin was updated | | Public Property | UserName | User creating the bin. If not set, the default is the session user. |

Reference

UpdateProductBinSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdateProductBin(UpdateProductBinSetup) Method


UpdateProductBinSetup Constructor | fcSDK Documentation

UpdateProductBinSetup Constructor

Objid of the Bin to be updated

Initializes a new instance of the UpdateProductBinSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _binObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public UpdateProductBinSetup(
   int _binObjid_
)

Parameters

binObjid

Objid of the Bin to be updated

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateProductBinSetup Class
UpdateProductBinSetup Members


BinName Property (UpdateProductBinSetup) | fcSDK Documentation

BinName Property (UpdateProductBinSetup)

Name of the bin to create

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property BinName As String

[PropertyBitValueAttribute()]
public string BinName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateProductBinSetup Class
UpdateProductBinSetup Members


BinObjid Property (UpdateProductBinSetup) | fcSDK Documentation

BinObjid Property (UpdateProductBinSetup)

Objid of the Bin to be updated

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property BinObjid As Integer

[PropertyBitValueAttribute()]
public int BinObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateProductBinSetup Class
UpdateProductBinSetup Members


Description Property (UpdateProductBinSetup) | fcSDK Documentation

Description Property (UpdateProductBinSetup)

Bin description

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Description As String

[PropertyBitValueAttribute()]
public string Description {get; set;}

Remarks

If this property has not been set no change will occur. If the property is set, even to an empty string, that value reflected in the update.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateProductBinSetup Class
UpdateProductBinSetup Members


PrimarySupportEmployeeObjid Property (UpdateProductBinSetup) | fcSDK Documentation

PrimarySupportEmployeeObjid Property (UpdateProductBinSetup)

Objid of the primary support Employee.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PrimarySupportEmployeeObjid As Integer

[PropertyBitValueAttribute()]
public int PrimarySupportEmployeeObjid {get; set;}

Remarks

Note: this is an Employee not a User.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateProductBinSetup Class
UpdateProductBinSetup Members


SecondarySupportEmployeeObjid Property (UpdateProductBinSetup) | fcSDK Documentation

SecondarySupportEmployeeObjid Property (UpdateProductBinSetup)

Objid of the secondary support Employee.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SecondarySupportEmployeeObjid As Integer

[PropertyBitValueAttribute()]
public int SecondarySupportEmployeeObjid {get; set;}

Remarks

Note: this is an Employee not a User.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateProductBinSetup Class
UpdateProductBinSetup Members


UpdateDate Property (UpdateProductBinSetup) | fcSDK Documentation

UpdateDate Property (UpdateProductBinSetup)

Date when the Bin was updated

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UpdateDate As Date

[PropertyBitValueAttribute()]
public DateTime UpdateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateProductBinSetup Class
UpdateProductBinSetup Members


UserName Property (UpdateProductBinSetup) | fcSDK Documentation

UserName Property (UpdateProductBinSetup)

User creating the bin. If not set, the default is the session user.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateProductBinSetup Class
UpdateProductBinSetup Members


UpdateQueueSetup Class | fcSDK Documentation

UpdateQueueSetup Class

Used by the UpdateQueue method as setup data for invocation.

Syntax

'Declaration

Public Class UpdateQueueSetup

public class UpdateQueueSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.UpdateQueueSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdateQueueSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdateQueue(UpdateQueueSetup) Method


UpdateQueueSetup Class Members | fcSDK Documentation

UpdateQueueSetup Class Members

The following tables list the members exposed by UpdateQueueSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdateQueueSetup Constructor | Initializes a new instance of the UpdateQueueSetup class.

Public Properties

 | Name | Description
Public Property | AllowActionItem | Should Queue allow Action Items
Public Property | AllowCase | Should Queue allow Cases
Public Property | AllowContract | Should Queue allow Contracts
Public Property | AllowCR | Should Queue allow CRs
Public Property | AllowDemandDetail | Should Queue allow Demand Details
Public Property | AllowDialogue | Should Queue allow Dialogs
Public Property | AllowJob | Should Queue allow Jobs
Public Property | AllowOpportunity | Should Queue allow Opportunities
Public Property | AllowSolution | Should Queue allow Solutions
Public Property | AllowSubcase | Should Queue allow Subcases
Public Property | Description | Queue description
Public Property | IsPersonal | Is this a personal Queue?
Public Property | NewTitle | New title of the Queue
Public Property | Supervisor | Username of the supervisor of the Queue
Public Property | Title | Title of the Queue

Reference

UpdateQueueSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdateQueue(UpdateQueueSetup) Method


UpdateQueueSetup Constructor | fcSDK Documentation

UpdateQueueSetup Constructor

Title of the Queue

Initializes a new instance of the UpdateQueueSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _title_ As String _
)

[ConstructorIndexAttribute()]
public UpdateQueueSetup(
   string _title_
)

Parameters

title

Title of the Queue

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateQueueSetup Class
UpdateQueueSetup Members


AllowActionItem Property (UpdateQueueSetup) | fcSDK Documentation

AllowActionItem Property (UpdateQueueSetup)

Should Queue allow Action Items

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AllowActionItem As Boolean

[PropertyBitValueAttribute()]
public bool AllowActionItem {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateQueueSetup Class
UpdateQueueSetup Members


AllowCase Property (UpdateQueueSetup) | fcSDK Documentation

AllowCase Property (UpdateQueueSetup)

Should Queue allow Cases

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AllowCase As Boolean

[PropertyBitValueAttribute()]
public bool AllowCase {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateQueueSetup Class
UpdateQueueSetup Members


AllowContract Property (UpdateQueueSetup) | fcSDK Documentation

AllowContract Property (UpdateQueueSetup)

Should Queue allow Contracts

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AllowContract As Boolean

[PropertyBitValueAttribute()]
public bool AllowContract {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateQueueSetup Class
UpdateQueueSetup Members


AllowCR Property (UpdateQueueSetup) | fcSDK Documentation

AllowCR Property (UpdateQueueSetup)

Should Queue allow CRs

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AllowCR As Boolean

[PropertyBitValueAttribute()]
public bool AllowCR {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateQueueSetup Class
UpdateQueueSetup Members


AllowDemandDetail Property (UpdateQueueSetup) | fcSDK Documentation

AllowDemandDetail Property (UpdateQueueSetup)

Should Queue allow Demand Details

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AllowDemandDetail As Boolean

[PropertyBitValueAttribute()]
public bool AllowDemandDetail {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateQueueSetup Class
UpdateQueueSetup Members


AllowDialogue Property (UpdateQueueSetup) | fcSDK Documentation

AllowDialogue Property (UpdateQueueSetup)

Should Queue allow Dialogs

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AllowDialogue As Boolean

[PropertyBitValueAttribute()]
public bool AllowDialogue {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateQueueSetup Class
UpdateQueueSetup Members


AllowJob Property (UpdateQueueSetup) | fcSDK Documentation

AllowJob Property (UpdateQueueSetup)

Should Queue allow Jobs

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AllowJob As Boolean

[PropertyBitValueAttribute()]
public bool AllowJob {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateQueueSetup Class
UpdateQueueSetup Members


AllowOpportunity Property (UpdateQueueSetup) | fcSDK Documentation

AllowOpportunity Property (UpdateQueueSetup)

Should Queue allow Opportunities

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AllowOpportunity As Boolean

[PropertyBitValueAttribute()]
public bool AllowOpportunity {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateQueueSetup Class
UpdateQueueSetup Members


AllowSolution Property (UpdateQueueSetup) | fcSDK Documentation

AllowSolution Property (UpdateQueueSetup)

Should Queue allow Solutions

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AllowSolution As Boolean

[PropertyBitValueAttribute()]
public bool AllowSolution {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateQueueSetup Class
UpdateQueueSetup Members


AllowSubcase Property (UpdateQueueSetup) | fcSDK Documentation

AllowSubcase Property (UpdateQueueSetup)

Should Queue allow Subcases

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AllowSubcase As Boolean

[PropertyBitValueAttribute()]
public bool AllowSubcase {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateQueueSetup Class
UpdateQueueSetup Members


Description Property (UpdateQueueSetup) | fcSDK Documentation

Description Property (UpdateQueueSetup)

Queue description

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Description As String

[PropertyBitValueAttribute()]
public string Description {get; set;}

Remarks

If this property has not been set no change will occur. If the property is set, even to an empty string, that value reflected in the update.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateQueueSetup Class
UpdateQueueSetup Members


IsPersonal Property (UpdateQueueSetup) | fcSDK Documentation

IsPersonal Property (UpdateQueueSetup)

Is this a personal Queue?

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsPersonal As Boolean

[PropertyBitValueAttribute()]
public bool IsPersonal {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateQueueSetup Class
UpdateQueueSetup Members


NewTitle Property (UpdateQueueSetup) | fcSDK Documentation

NewTitle Property (UpdateQueueSetup)

New title of the Queue

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewTitle As String

[PropertyBitValueAttribute()]
public string NewTitle {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateQueueSetup Class
UpdateQueueSetup Members


Supervisor Property (UpdateQueueSetup) | fcSDK Documentation

Supervisor Property (UpdateQueueSetup)

Username of the supervisor of the Queue

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Supervisor As String

[PropertyBitValueAttribute()]
public string Supervisor {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateQueueSetup Class
UpdateQueueSetup Members


Title Property (UpdateQueueSetup) | fcSDK Documentation

Title Property (UpdateQueueSetup)

Title of the Queue

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Title As String

[PropertyBitValueAttribute()]
public string Title {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateQueueSetup Class
UpdateQueueSetup Members


UpdateSiteByObjidSetup Class | fcSDK Documentation

UpdateSiteByObjidSetup Class

Used by the UpdateSiteByObjid method as setup data for invocation.

Syntax

'Declaration

Public Class UpdateSiteByObjidSetup

public class UpdateSiteByObjidSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.UpdateSiteByObjidSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdateSiteByObjidSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdateSiteByObjid(UpdateSiteByObjidSetup) Method


UpdateSiteByObjidSetup Class Members | fcSDK Documentation

UpdateSiteByObjidSetup Class Members

The following tables list the members exposed by UpdateSiteByObjidSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdateSiteByObjidSetup Constructor | Initializes a new instance of the UpdateSiteByObjidSetup class.

Public Properties

 | Name | Description
Public Property | AccountIDNum | Identifier of the Account this site belongs to. If not set, the default Account is used.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | BillingAddressObjid | Billing Address of the site. If not set, the primary address is used.
Public Property | District | District of the Site
Public Property | IndustryType | Element from the 'Industry Type' user defined list. If not set, the default list value is used.
Public Property | ParentSiteIDNum | Identifier for the parent Site of the Site being created.
Public Property | PrimaryAddressObjid | Primary Address of the site.
Public Property | PrimarySupportEmployeeObjid | Objid of the primary support Employee.
Public Property | PrimaryUse | Element from the 'Primary Use' user defined list. If not set, the default list value is used.
Public Property | Region | Region for the Site
Public Property | SecondarySupportEmployeeObjid | Objid of the secondary support Employee.
Public Property | ShippingAddressObjid | Shipping Address of the site. If not set, the primary address is used.
Public Property | SiteName | Name of the Site
Public Property | SiteObjid | Objid of the Site being updated
Public Property | SiteType | Type of the site
Public Property | Status | Site status
Public Property | SupportOfficeSiteIDNum | Identifier of the site where the support office is located

Reference

UpdateSiteByObjidSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdateSiteByObjid(UpdateSiteByObjidSetup) Method


UpdateSiteByObjidSetup Constructor | fcSDK Documentation

UpdateSiteByObjidSetup Constructor

Objid of the Site being updated

Initializes a new instance of the UpdateSiteByObjidSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _siteObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public UpdateSiteByObjidSetup(
   int _siteObjid_
)

Parameters

siteObjid

Objid of the Site being updated

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSiteByObjidSetup Class
UpdateSiteByObjidSetup Members


AccountIDNum Property (UpdateSiteByObjidSetup) | fcSDK Documentation

AccountIDNum Property (UpdateSiteByObjidSetup)

Identifier of the Account this site belongs to. If not set, the default Account is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AccountIDNum As String

[PropertyBitValueAttribute()]
public string AccountIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSiteByObjidSetup Class
UpdateSiteByObjidSetup Members


AdditionalFields Property (UpdateSiteByObjidSetup) | fcSDK Documentation

AdditionalFields Property (UpdateSiteByObjidSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSiteByObjidSetup Class
UpdateSiteByObjidSetup Members


BillingAddressObjid Property (UpdateSiteByObjidSetup) | fcSDK Documentation

BillingAddressObjid Property (UpdateSiteByObjidSetup)

Billing Address of the site. If not set, the primary address is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property BillingAddressObjid As Integer

[PropertyBitValueAttribute()]
public int BillingAddressObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSiteByObjidSetup Class
UpdateSiteByObjidSetup Members


District Property (UpdateSiteByObjidSetup) | fcSDK Documentation

District Property (UpdateSiteByObjidSetup)

District of the Site

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property District As String

[PropertyBitValueAttribute()]
public string District {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSiteByObjidSetup Class
UpdateSiteByObjidSetup Members


IndustryType Property (UpdateSiteByObjidSetup) | fcSDK Documentation

IndustryType Property (UpdateSiteByObjidSetup)

Element from the 'Industry Type' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IndustryType As String

[PropertyBitValueAttribute()]
public string IndustryType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSiteByObjidSetup Class
UpdateSiteByObjidSetup Members


ParentSiteIDNum Property (UpdateSiteByObjidSetup) | fcSDK Documentation

ParentSiteIDNum Property (UpdateSiteByObjidSetup)

Identifier for the parent Site of the Site being created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ParentSiteIDNum As String

[PropertyBitValueAttribute()]
public string ParentSiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSiteByObjidSetup Class
UpdateSiteByObjidSetup Members


PrimaryAddressObjid Property (UpdateSiteByObjidSetup) | fcSDK Documentation

PrimaryAddressObjid Property (UpdateSiteByObjidSetup)

Primary Address of the site.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PrimaryAddressObjid As Integer

[PropertyBitValueAttribute()]
public int PrimaryAddressObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSiteByObjidSetup Class
UpdateSiteByObjidSetup Members


PrimarySupportEmployeeObjid Property (UpdateSiteByObjidSetup) | fcSDK Documentation

PrimarySupportEmployeeObjid Property (UpdateSiteByObjidSetup)

Objid of the primary support Employee.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PrimarySupportEmployeeObjid As Integer

[PropertyBitValueAttribute()]
public int PrimarySupportEmployeeObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSiteByObjidSetup Class
UpdateSiteByObjidSetup Members


PrimaryUse Property (UpdateSiteByObjidSetup) | fcSDK Documentation

PrimaryUse Property (UpdateSiteByObjidSetup)

Element from the 'Primary Use' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PrimaryUse As String

[PropertyBitValueAttribute()]
public string PrimaryUse {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSiteByObjidSetup Class
UpdateSiteByObjidSetup Members


Region Property (UpdateSiteByObjidSetup) | fcSDK Documentation

Region Property (UpdateSiteByObjidSetup)

Region for the Site

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Region As String

[PropertyBitValueAttribute()]
public string Region {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSiteByObjidSetup Class
UpdateSiteByObjidSetup Members


SecondarySupportEmployeeObjid Property (UpdateSiteByObjidSetup) | fcSDK Documentation

SecondarySupportEmployeeObjid Property (UpdateSiteByObjidSetup)

Objid of the secondary support Employee.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SecondarySupportEmployeeObjid As Integer

[PropertyBitValueAttribute()]
public int SecondarySupportEmployeeObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSiteByObjidSetup Class
UpdateSiteByObjidSetup Members


ShippingAddressObjid Property (UpdateSiteByObjidSetup) | fcSDK Documentation

ShippingAddressObjid Property (UpdateSiteByObjidSetup)

Shipping Address of the site. If not set, the primary address is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ShippingAddressObjid As Integer

[PropertyBitValueAttribute()]
public int ShippingAddressObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSiteByObjidSetup Class
UpdateSiteByObjidSetup Members


SiteName Property (UpdateSiteByObjidSetup) | fcSDK Documentation

SiteName Property (UpdateSiteByObjidSetup)

Name of the Site

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteName As String

[PropertyBitValueAttribute()]
public string SiteName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSiteByObjidSetup Class
UpdateSiteByObjidSetup Members


SiteObjid Property (UpdateSiteByObjidSetup) | fcSDK Documentation

SiteObjid Property (UpdateSiteByObjidSetup)

Objid of the Site being updated

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteObjid As Integer

[PropertyBitValueAttribute()]
public int SiteObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSiteByObjidSetup Class
UpdateSiteByObjidSetup Members


SiteType Property (UpdateSiteByObjidSetup) | fcSDK Documentation

SiteType Property (UpdateSiteByObjidSetup)

Type of the site

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteType As SiteType

[PropertyBitValueAttribute()]
public SiteType SiteType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSiteByObjidSetup Class
UpdateSiteByObjidSetup Members


Status Property (UpdateSiteByObjidSetup) | fcSDK Documentation

Status Property (UpdateSiteByObjidSetup)

Site status

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Status As SiteStatus

[PropertyBitValueAttribute()]
public SiteStatus Status {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSiteByObjidSetup Class
UpdateSiteByObjidSetup Members


SupportOfficeSiteIDNum Property (UpdateSiteByObjidSetup) | fcSDK Documentation

SupportOfficeSiteIDNum Property (UpdateSiteByObjidSetup)

Identifier of the site where the support office is located

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SupportOfficeSiteIDNum As String

[PropertyBitValueAttribute()]
public string SupportOfficeSiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSiteByObjidSetup Class
UpdateSiteByObjidSetup Members


UpdateSitePartSetup Class | fcSDK Documentation

UpdateSitePartSetup Class

Used by the UpdateSitePart method as setup data for invocation.

Syntax

'Declaration

Public Class UpdateSitePartSetup

public class UpdateSitePartSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.UpdateSitePartSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdateSitePartSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdateSitePart(UpdateSitePartSetup) Method


UpdateSitePartSetup Class Members | fcSDK Documentation

UpdateSitePartSetup Class Members

The following tables list the members exposed by UpdateSitePartSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdateSitePartSetup Constructor | Overloaded.

Public Properties

 | Name | Description
Public Property | AddActivityLog | Should an activity log be created?
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | Comments | Comments for the Site Part
Public Property | InstallDate | DateTime the Site Part was installed.
Public Property | InstanceName | The instance name for the Site Part.
Public Property | InvoiceNumber | Invoice number
Public Property | PartRevision | Part Revision of the part installed
Public Property | PartStatus | Element from the 'Part_Status' user defined list. If not set, the default list value is used.
Public Property | Quantity | The number of units installed
Public Property | SerialNumber | Serial number of the Site Part
Public Property | ServiceEndDate | DateTime the service ends.
Public Property | ShipDate | DateTime the part was shipped.
Public Property | SitePartObjid | Objid of the Site Part to be updated
Public Property | UserName | User who performed the update. If not set, the session user is used.
Public Property | WarrantyDate | DateTime the warranty expires.

Reference

UpdateSitePartSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdateSitePart(UpdateSitePartSetup) Method


UpdateSitePartSetup Constructor | fcSDK Documentation

UpdateSitePartSetup Constructor

Initializes a new instance of the UpdateSitePartSetup class.

Overload List

Overload | Description
UpdateSitePartSetup Constructor(Int32,Int32) | Initializes a new instance of the UpdateSitePartSetup class. This overload takes a set of required parameters for the API.
UpdateSitePartSetup Constructor(Int32,String) | Initializes a new instance of the UpdateSitePartSetup class. This overload takes a set of required parameters for the API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSitePartSetup Class
UpdateSitePartSetup Members


UpdateSitePartSetup Constructor(Int32,Int32) | fcSDK Documentation

UpdateSitePartSetup Constructor(Int32,Int32)

Objid of the Site Part to be updated

The number of units installed

Initializes a new instance of the UpdateSitePartSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _sitePartObjid_ As Integer, _
   ByVal _quantity_ As Integer _
)

[ConstructorIndexAttribute()]
public UpdateSitePartSetup(
   int _sitePartObjid_,
   int _quantity_
)

Parameters

sitePartObjid

Objid of the Site Part to be updated

quantity

The number of units installed

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSitePartSetup Class
UpdateSitePartSetup Members
Overload List


UpdateSitePartSetup Constructor(Int32,String) | fcSDK Documentation

UpdateSitePartSetup Constructor(Int32,String)

Objid of the Site Part to be updated

Serial number of the Site Part

Initializes a new instance of the UpdateSitePartSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _sitePartObjid_ As Integer, _
   ByVal _serialNumber_ As String _
)

[ConstructorIndexAttribute()]
public UpdateSitePartSetup(
   int _sitePartObjid_,
   string _serialNumber_
)

Parameters

sitePartObjid

Objid of the Site Part to be updated

serialNumber

Serial number of the Site Part

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSitePartSetup Class
UpdateSitePartSetup Members
Overload List


AddActivityLog Property (UpdateSitePartSetup) | fcSDK Documentation

AddActivityLog Property (UpdateSitePartSetup)

Should an activity log be created?

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AddActivityLog As Boolean

[PropertyBitValueAttribute()]
public bool AddActivityLog {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSitePartSetup Class
UpdateSitePartSetup Members


InstallDate Property (UpdateSitePartSetup) | fcSDK Documentation

InstallDate Property (UpdateSitePartSetup)

DateTime the Site Part was installed.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstallDate As Date

[PropertyBitValueAttribute()]
public DateTime InstallDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSitePartSetup Class
UpdateSitePartSetup Members


InstanceName Property (UpdateSitePartSetup) | fcSDK Documentation

InstanceName Property (UpdateSitePartSetup)

The instance name for the Site Part.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InstanceName As String

[PropertyBitValueAttribute()]
public string InstanceName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSitePartSetup Class
UpdateSitePartSetup Members


InvoiceNumber Property (UpdateSitePartSetup) | fcSDK Documentation

InvoiceNumber Property (UpdateSitePartSetup)

Invoice number

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InvoiceNumber As String

[PropertyBitValueAttribute()]
public string InvoiceNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSitePartSetup Class
UpdateSitePartSetup Members


PartRevision Property (UpdateSitePartSetup) | fcSDK Documentation

PartRevision Property (UpdateSitePartSetup)

Part Revision of the part installed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRevision As String

[PropertyBitValueAttribute()]
public string PartRevision {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSitePartSetup Class
UpdateSitePartSetup Members


PartStatus Property (UpdateSitePartSetup) | fcSDK Documentation

PartStatus Property (UpdateSitePartSetup)

Element from the 'Part_Status' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartStatus As String

[PropertyBitValueAttribute()]
public string PartStatus {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSitePartSetup Class
UpdateSitePartSetup Members


Quantity Property (UpdateSitePartSetup) | fcSDK Documentation

Quantity Property (UpdateSitePartSetup)

The number of units installed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Quantity As Integer

[PropertyBitValueAttribute()]
public int Quantity {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSitePartSetup Class
UpdateSitePartSetup Members


SerialNumber Property (UpdateSitePartSetup) | fcSDK Documentation

SerialNumber Property (UpdateSitePartSetup)

Serial number of the Site Part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SerialNumber As String

[PropertyBitValueAttribute()]
public string SerialNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSitePartSetup Class
UpdateSitePartSetup Members


ServiceEndDate Property (UpdateSitePartSetup) | fcSDK Documentation

ServiceEndDate Property (UpdateSitePartSetup)

DateTime the service ends.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ServiceEndDate As Date

[PropertyBitValueAttribute()]
public DateTime ServiceEndDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSitePartSetup Class
UpdateSitePartSetup Members


ShipDate Property (UpdateSitePartSetup) | fcSDK Documentation

ShipDate Property (UpdateSitePartSetup)

DateTime the part was shipped.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ShipDate As Date

[PropertyBitValueAttribute()]
public DateTime ShipDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSitePartSetup Class
UpdateSitePartSetup Members


SitePartObjid Property (UpdateSitePartSetup) | fcSDK Documentation

SitePartObjid Property (UpdateSitePartSetup)

Objid of the Site Part to be updated

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SitePartObjid As Integer

[PropertyBitValueAttribute()]
public int SitePartObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSitePartSetup Class
UpdateSitePartSetup Members


UserName Property (UpdateSitePartSetup) | fcSDK Documentation

UserName Property (UpdateSitePartSetup)

User who performed the update. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSitePartSetup Class
UpdateSitePartSetup Members


WarrantyDate Property (UpdateSitePartSetup) | fcSDK Documentation

WarrantyDate Property (UpdateSitePartSetup)

DateTime the warranty expires.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WarrantyDate As Date

[PropertyBitValueAttribute()]
public DateTime WarrantyDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSitePartSetup Class
UpdateSitePartSetup Members


UpdateSiteSetup Class | fcSDK Documentation

UpdateSiteSetup Class

Used by the UpdateSite method as setup data for invocation.

Syntax

'Declaration

Public Class UpdateSiteSetup

public class UpdateSiteSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.UpdateSiteSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdateSiteSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdateSite(UpdateSiteSetup) Method


UpdateSiteSetup Class Members | fcSDK Documentation

UpdateSiteSetup Class Members

The following tables list the members exposed by UpdateSiteSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdateSiteSetup Constructor | Initializes a new instance of the UpdateSiteSetup class.

Public Properties

 | Name | Description
Public Property | AccountIDNum | Identifier of the Account this site belongs to. If not set, the default Account is used.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | BillingAddressObjid | Billing Address of the site. If not set, the primary address is used.
Public Property | District | District of the Site
Public Property | IndustryType | Element from the 'Industry Type' user defined list. If not set, the default list value is used.
Public Property | ParentSiteIDNum | Identifier for the parent Site of the Site being created.
Public Property | PrimaryAddressObjid | Primary Address of the site.
Public Property | PrimarySupportEmployeeObjid | Objid of the primary support Employee.
Public Property | PrimaryUse | Element from the 'Primary Use' user defined list. If not set, the default list value is used.
Public Property | Region | Region for the Site
Public Property | SecondarySupportEmployeeObjid | Objid of the secondary support Employee.
Public Property | ShippingAddressObjid | Shipping Address of the site. If not set, the primary address is used.
Public Property | SiteIDNum | Identifier for the site being updated.
Public Property | SiteName | Name of the Site
Public Property | SiteType | Type of the site
Public Property | Status | Site status
Public Property | SupportOfficeSiteIDNum | Identifier of the site where the support office is located

Reference

UpdateSiteSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdateSite(UpdateSiteSetup) Method


UpdateSiteSetup Constructor | fcSDK Documentation

UpdateSiteSetup Constructor

Identifier for the site being updated.

Initializes a new instance of the UpdateSiteSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _siteIDNum_ As String _
)

[ConstructorIndexAttribute()]
public UpdateSiteSetup(
   string _siteIDNum_
)

Parameters

siteIDNum

Identifier for the site being updated.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSiteSetup Class
UpdateSiteSetup Members


AccountIDNum Property (UpdateSiteSetup) | fcSDK Documentation

AccountIDNum Property (UpdateSiteSetup)

Identifier of the Account this site belongs to. If not set, the default Account is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AccountIDNum As String

[PropertyBitValueAttribute()]
public string AccountIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSiteSetup Class
UpdateSiteSetup Members


AdditionalFields Property (UpdateSiteSetup) | fcSDK Documentation

AdditionalFields Property (UpdateSiteSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSiteSetup Class
UpdateSiteSetup Members


BillingAddressObjid Property (UpdateSiteSetup) | fcSDK Documentation

BillingAddressObjid Property (UpdateSiteSetup)

Billing Address of the site. If not set, the primary address is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property BillingAddressObjid As Integer

[PropertyBitValueAttribute()]
public int BillingAddressObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSiteSetup Class
UpdateSiteSetup Members


District Property (UpdateSiteSetup) | fcSDK Documentation

District Property (UpdateSiteSetup)

District of the Site

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property District As String

[PropertyBitValueAttribute()]
public string District {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSiteSetup Class
UpdateSiteSetup Members


IndustryType Property (UpdateSiteSetup) | fcSDK Documentation

IndustryType Property (UpdateSiteSetup)

Element from the 'Industry Type' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IndustryType As String

[PropertyBitValueAttribute()]
public string IndustryType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSiteSetup Class
UpdateSiteSetup Members


ParentSiteIDNum Property (UpdateSiteSetup) | fcSDK Documentation

ParentSiteIDNum Property (UpdateSiteSetup)

Identifier for the parent Site of the Site being created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ParentSiteIDNum As String

[PropertyBitValueAttribute()]
public string ParentSiteIDNum {get; set;}

Remarks

If this property is set to an empty string the relation to the parent Site will be removed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSiteSetup Class
UpdateSiteSetup Members


PrimaryAddressObjid Property (UpdateSiteSetup) | fcSDK Documentation

PrimaryAddressObjid Property (UpdateSiteSetup)

Primary Address of the site.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PrimaryAddressObjid As Integer

[PropertyBitValueAttribute()]
public int PrimaryAddressObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSiteSetup Class
UpdateSiteSetup Members


PrimarySupportEmployeeObjid Property (UpdateSiteSetup) | fcSDK Documentation

PrimarySupportEmployeeObjid Property (UpdateSiteSetup)

Objid of the primary support Employee.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PrimarySupportEmployeeObjid As Integer

[PropertyBitValueAttribute()]
public int PrimarySupportEmployeeObjid {get; set;}

Remarks

If set to -2 the Employee is unrelated

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSiteSetup Class
UpdateSiteSetup Members


PrimaryUse Property (UpdateSiteSetup) | fcSDK Documentation

PrimaryUse Property (UpdateSiteSetup)

Element from the 'Primary Use' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PrimaryUse As String

[PropertyBitValueAttribute()]
public string PrimaryUse {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSiteSetup Class
UpdateSiteSetup Members


Region Property (UpdateSiteSetup) | fcSDK Documentation

Region Property (UpdateSiteSetup)

Region for the Site

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Region As String

[PropertyBitValueAttribute()]
public string Region {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSiteSetup Class
UpdateSiteSetup Members


SecondarySupportEmployeeObjid Property (UpdateSiteSetup) | fcSDK Documentation

SecondarySupportEmployeeObjid Property (UpdateSiteSetup)

Objid of the secondary support Employee.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SecondarySupportEmployeeObjid As Integer

[PropertyBitValueAttribute()]
public int SecondarySupportEmployeeObjid {get; set;}

Remarks

If set to -2 the Employee is unrelated

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSiteSetup Class
UpdateSiteSetup Members


ShippingAddressObjid Property (UpdateSiteSetup) | fcSDK Documentation

ShippingAddressObjid Property (UpdateSiteSetup)

Shipping Address of the site. If not set, the primary address is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ShippingAddressObjid As Integer

[PropertyBitValueAttribute()]
public int ShippingAddressObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSiteSetup Class
UpdateSiteSetup Members


SiteIDNum Property (UpdateSiteSetup) | fcSDK Documentation

SiteIDNum Property (UpdateSiteSetup)

Identifier for the site being updated.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteIDNum As String

[PropertyBitValueAttribute()]
public string SiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSiteSetup Class
UpdateSiteSetup Members


SiteName Property (UpdateSiteSetup) | fcSDK Documentation

SiteName Property (UpdateSiteSetup)

Name of the Site

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteName As String

[PropertyBitValueAttribute()]
public string SiteName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSiteSetup Class
UpdateSiteSetup Members


SiteType Property (UpdateSiteSetup) | fcSDK Documentation

SiteType Property (UpdateSiteSetup)

Type of the site

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteType As SiteType

[PropertyBitValueAttribute()]
public SiteType SiteType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSiteSetup Class
UpdateSiteSetup Members


Status Property (UpdateSiteSetup) | fcSDK Documentation

Status Property (UpdateSiteSetup)

Site status

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Status As SiteStatus

[PropertyBitValueAttribute()]
public SiteStatus Status {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSiteSetup Class
UpdateSiteSetup Members


SupportOfficeSiteIDNum Property (UpdateSiteSetup) | fcSDK Documentation

SupportOfficeSiteIDNum Property (UpdateSiteSetup)

Identifier of the site where the support office is located

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SupportOfficeSiteIDNum As String

[PropertyBitValueAttribute()]
public string SupportOfficeSiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSiteSetup Class
UpdateSiteSetup Members


UpdateWipBinSetup Class | fcSDK Documentation

UpdateWipBinSetup Class

Used by the UpdateWipBin method as setup data for invocation.

Syntax

'Declaration

Public Class UpdateWipBinSetup

public class UpdateWipBinSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.UpdateWipBinSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdateWipBinSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdateWipBin(UpdateWipBinSetup) Method


UpdateWipBinSetup Class Members | fcSDK Documentation

UpdateWipBinSetup Class Members

The following tables list the members exposed by UpdateWipBinSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdateWipBinSetup Constructor | Initializes a new instance of the UpdateWipBinSetup class.

Public Properties

 | Name | Description
Public Property | Description | WipBin description
Public Property | IsDefaultBin | Is the WipBin the user's default?
Public Property | NewTitle | New title for the WipBin
Public Property | Title | Title of the WipBin being updated
Public Property | UserName | User the WipBin belongs to

Reference

UpdateWipBinSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdateWipBin(UpdateWipBinSetup) Method


UpdateWipBinSetup Constructor | fcSDK Documentation

UpdateWipBinSetup Constructor

Title of the WipBin being updated

Initializes a new instance of the UpdateWipBinSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _title_ As String _
)

[ConstructorIndexAttribute()]
public UpdateWipBinSetup(
   string _title_
)

Parameters

title

Title of the WipBin being updated

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateWipBinSetup Class
UpdateWipBinSetup Members


Description Property (UpdateWipBinSetup) | fcSDK Documentation

Description Property (UpdateWipBinSetup)

WipBin description

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Description As String

[PropertyBitValueAttribute()]
public string Description {get; set;}

Remarks

If this property has not been set no change will occur. If the property is set, even to an empty string, that value reflected in the update.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateWipBinSetup Class
UpdateWipBinSetup Members


IsDefaultBin Property (UpdateWipBinSetup) | fcSDK Documentation

IsDefaultBin Property (UpdateWipBinSetup)

Is the WipBin the user's default?

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsDefaultBin As Boolean

[PropertyBitValueAttribute()]
public bool IsDefaultBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateWipBinSetup Class
UpdateWipBinSetup Members


NewTitle Property (UpdateWipBinSetup) | fcSDK Documentation

NewTitle Property (UpdateWipBinSetup)

New title for the WipBin

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewTitle As String

[PropertyBitValueAttribute()]
public string NewTitle {get; set;}

Remarks

Because the WipBin is retrieved by UserName and Title you must use this property to change the WipBin's title.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateWipBinSetup Class
UpdateWipBinSetup Members


Title Property (UpdateWipBinSetup) | fcSDK Documentation

Title Property (UpdateWipBinSetup)

Title of the WipBin being updated

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Title As String

[PropertyBitValueAttribute()]
public string Title {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateWipBinSetup Class
UpdateWipBinSetup Members


UserName Property (UpdateWipBinSetup) | fcSDK Documentation

UserName Property (UpdateWipBinSetup)

User the WipBin belongs to

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateWipBinSetup Class
UpdateWipBinSetup Members


YankSolutionSetup Class | fcSDK Documentation

YankSolutionSetup Class

Used by the YankSolution method as setup data for invocation.

Syntax

'Declaration

Public Class YankSolutionSetup

public class YankSolutionSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.YankSolutionSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Interfaces

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

YankSolutionSetup Members
FChoice.Toolkits.Clarify.Interfaces Namespace
YankSolution(YankSolutionSetup) Method


YankSolutionSetup Class Members | fcSDK Documentation

YankSolutionSetup Class Members

The following tables list the members exposed by YankSolutionSetup.

Public Constructors

 | Name | Description
Public Constructor | YankSolutionSetup Constructor | Initializes a new instance of the YankSolutionSetup class.

Public Properties

 | Name | Description
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | SolutionIDNum | Solution Identifier.
Public Property | UserName | The user who has yanked the Solution. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Solution. If not set, the UserName's default is used.
Public Property | YankDate | DateTime the Solution was yanked. If not set, the current time is used.

Reference

YankSolutionSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
YankSolution(YankSolutionSetup) Method


YankSolutionSetup Constructor | fcSDK Documentation

YankSolutionSetup Constructor

Solution Identifier.

Initializes a new instance of the YankSolutionSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _solutionIDNum_ As String _
)

[ConstructorIndexAttribute()]
public YankSolutionSetup(
   string _solutionIDNum_
)

Parameters

solutionIDNum

Solution Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankSolutionSetup Class
YankSolutionSetup Members


GenerateTimeBombs Property (YankSolutionSetup) | fcSDK Documentation

GenerateTimeBombs Property (YankSolutionSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankSolutionSetup Class
YankSolutionSetup Members


SolutionIDNum Property (YankSolutionSetup) | fcSDK Documentation

SolutionIDNum Property (YankSolutionSetup)

Solution Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SolutionIDNum As String

[PropertyBitValueAttribute()]
public string SolutionIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankSolutionSetup Class
YankSolutionSetup Members


UserName Property (YankSolutionSetup) | fcSDK Documentation

UserName Property (YankSolutionSetup)

The user who has yanked the Solution. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankSolutionSetup Class
YankSolutionSetup Members


WipBin Property (YankSolutionSetup) | fcSDK Documentation

WipBin Property (YankSolutionSetup)

User's WipBin in which to place the Solution. If not set, the UserName's default is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankSolutionSetup Class
YankSolutionSetup Members


YankDate Property (YankSolutionSetup) | fcSDK Documentation

YankDate Property (YankSolutionSetup)

DateTime the Solution was yanked. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property YankDate As Date

[PropertyBitValueAttribute()]
public DateTime YankDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankSolutionSetup Class
YankSolutionSetup Members


FChoice.Toolkits.Clarify.Logistics Namespace | fcSDK Documentation

FChoice.Toolkits.Clarify.Logistics Namespace

Provides APIs for ClearLogistics Spares Manager and Order Operations. Methods on the LogisticsToolkit allow you to fully manipulate part requests with operations such as create, modify, close, perform work flow (dispatch, assign, etc), change status, and note logging. In addition, there are also methods for all warehouse operations such as pick, unpick, fulfill, ship, receive, transfer, and more.

Classes

 | Class | Description
Class | AcceptPartRequestSetup | Used by the AcceptPartRequest method as setup data for invocation.
Class | AddAlternatePartSetup | Used by the AddAlternatePart method as setup data for invocation.
Class | AddGLAccountSetup | Used by the AddGLAccount method as setup data for invocation.
Class | AddInventoryBinSetup | Used by the AddInventoryBin method as setup data for invocation.
Class | AddInventoryLocationSetup | Used by the AddInventoryLocation method as setup data for invocation.
Class | AddLocationServicingSiteSetup | Used by the AddLocationServicingSite method as setup data for invocation.
Class | AssignPartRequestSetup | Used by the AssignPartRequest method as setup data for invocation.
Class | BackorderPartRequestSetup | Used by the BackorderPartRequest method as setup data for invocation.
Class | ChangePartRequestStatusSetup | Used by the ChangePartRequestStatus method as setup data for invocation.
Class | ClosePartRequestSetup | Used by the ClosePartRequest method as setup data for invocation.
Class | CreateContainerSetup |
Class | CreatePartRequestDetailResult | Result from the CreatePartRequestDetail API.
Class | CreatePartRequestDetailSetup | Used by the CreatePartRequestDetail method as setup data for invocation.
Class | CreatePartRequestHeaderCaseSetup | Used by the CreatePartRequestHeaderCase method as setup data for invocation.
Class | CreatePartRequestHeaderSetup | Used by the CreatePartRequestHeader method as setup data for invocation.
Class | CreatePartRequestHeaderSubcaseSetup | Used by the CreatePartRequestHeaderSubcase method as setup data for invocation.
Class | CreateSubContainerSetup |
Class | DeleteAlternatePartSetup | Used by the DeleteAlternatePart method as setup data for invocation.
Class | DeleteLocationServicingSiteSetup | Used by the DeleteLocationServicingSite method as setup data for invocation.
Class | DispatchPartRequestSetup | Used by the DispatchPartRequest method as setup data for invocation.
Class | ForwardPartRequestSetup | Used by the ForwardPartRequest method as setup data for invocation.
Class | FulfillPartRequestSetup | Used by the FulfillPartRequest method as setup data for invocation.
Class | GetAlternatePartsResult | Result from the GetAlternateParts API.
Class | GetAlternatePartsSetup | Used by the GetAlternateParts method as setup data for invocation.
Class | GetLocationsServicingSiteResult | Result from the GetLocationsServicingSite API.
Class | GetLocationsServicingSiteSetup | Used by the GetLocationsServicingSite method as setup data for invocation.
Class | LogisticsToolkit | Provides APIs for ClearLogistics Spares Manager and Order Operations. Methods on the LogisticsToolkit allow you to fully manipulate part requests with operations such as create, modify, close, perform work flow (dispatch, assign, etc), change status, and note logging. In addition, there are also methods for all warehouse operations such as pick, unpick, fulfill, ship, receive, transfer, and more.
Class | LogisticsToolkitBase | This class is intended for internal use by the LogisticsToolkit.
Class | MovePartRequestSetup | Used by the MovePartRequest method as setup data for invocation.
Class | OpenContainerSetup |
Class | PartTransferResult | Result from the PartTransfer API.
Class | PartTransferSetup | Used by the PartTransfer method as setup data for invocation.
Class | PickResult | Result from the Pick API.
Class | PickSetup | Used by the Pick method as setup data for invocation.
Class | ReceivePartRequestSetup | Used by the ReceivePartRequest method as setup data for invocation.
Class | RejectPartRequestSetup | Used by the RejectPartRequest method as setup data for invocation.
Class | ReopenPartRequestSetup | Used by the ReopenPartRequest method as setup data for invocation.
Class | SealContainerSetup |
Class | SetLogisticsTransitionSetup | Used by the SetLogisticsTransition method as setup data for invocation.
Class | SetPartStockingLevelSetup | Used by the SetPartStockingLevel method as setup data for invocation.
Class | ShipSetup | Used by the Ship method as setup data for invocation.
Class | UnpickSetup | Used by the Unpick method as setup data for invocation.
Class | UpdateGLAccountSetup | Used by the UpdateGLAccount method as setup data for invocation.
Class | UpdateInventoryBinSetup | Used by the UpdateInventoryBin method as setup data for invocation.
Class | UpdateInventoryLocationSetup | Used by the UpdateInventoryLocation method as setup data for invocation.
Class | UpdateLocationServicingSiteSetup | Used by the UpdateLocationServicingSite method as setup data for invocation.
Class | UpdatePartRequestDetailSetup | Used by the UpdatePartRequestDetail method as setup data for invocation.
Class | UpdatePartRequestHeaderSetup | Used by the UpdatePartRequestHeader method as setup data for invocation.
Class | UpdatePartStockingLevelSetup | Used by the UpdatePartStockingLevel method as setup data for invocation.
Class | YankPartRequestSetup | Used by the YankPartRequest method as setup data for invocation.

Reference

FChoice.Toolkits.Clarify Assembly


AcceptPartRequestSetup Class | fcSDK Documentation

AcceptPartRequestSetup Class

Used by the AcceptPartRequest method as setup data for invocation.

Syntax

'Declaration

Public Class AcceptPartRequestSetup

public class AcceptPartRequestSetup

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.AcceptPartRequestSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

AcceptPartRequestSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitAcceptPartRequest(AcceptPartRequestSetup)


AcceptPartRequestSetup Class Members | fcSDK Documentation

AcceptPartRequestSetup Class Members

The following tables list the members exposed by AcceptPartRequestSetup.

Public Constructors

 | Name | Description
Public Constructor | AcceptPartRequestSetup Constructor | Initializes a new instance of the AcceptPartRequestSetup class.

Public Properties

 | Name | Description
Public Property | AcceptDate | DateTime the PartRequest was accepted. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | PartRequestDetailIDNum | Part Request Detail Identifier
Public Property | UserName | The user who has accepted the PartRequest. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the PartRequest. If not set, the UserName's default is used.

Reference

AcceptPartRequestSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitAcceptPartRequest(AcceptPartRequestSetup)


AcceptPartRequestSetup Constructor | fcSDK Documentation

AcceptPartRequestSetup Constructor

Part Request Detail Identifier

Initializes a new instance of the AcceptPartRequestSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String _
)

[ConstructorIndexAttribute()]
public AcceptPartRequestSetup(
   string _partRequestDetailIDNum_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptPartRequestSetup Class
AcceptPartRequestSetup Members


AcceptDate Property (AcceptPartRequestSetup) | fcSDK Documentation

AcceptDate Property (AcceptPartRequestSetup)

DateTime the PartRequest was accepted. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AcceptDate As Date

[PropertyBitValueAttribute()]
public DateTime AcceptDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptPartRequestSetup Class
AcceptPartRequestSetup Members


GenerateTimeBombs Property (AcceptPartRequestSetup) | fcSDK Documentation

GenerateTimeBombs Property (AcceptPartRequestSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptPartRequestSetup Class
AcceptPartRequestSetup Members


PartRequestDetailIDNum Property (AcceptPartRequestSetup) | fcSDK Documentation

PartRequestDetailIDNum Property (AcceptPartRequestSetup)

Part Request Detail Identifier

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRequestDetailIDNum As String

[PropertyBitValueAttribute()]
public string PartRequestDetailIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptPartRequestSetup Class
AcceptPartRequestSetup Members


UserName Property (AcceptPartRequestSetup) | fcSDK Documentation

UserName Property (AcceptPartRequestSetup)

The user who has accepted the PartRequest. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptPartRequestSetup Class
AcceptPartRequestSetup Members


WipBin Property (AcceptPartRequestSetup) | fcSDK Documentation

WipBin Property (AcceptPartRequestSetup)

User's WipBin in which to place the PartRequest. If not set, the UserName's default is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptPartRequestSetup Class
AcceptPartRequestSetup Members


AddAlternatePartSetup Class | fcSDK Documentation

AddAlternatePartSetup Class

Used by the AddAlternatePart method as setup data for invocation.

Syntax

'Declaration

Public Class AddAlternatePartSetup

public class AddAlternatePartSetup

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.AddAlternatePartSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

AddAlternatePartSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitAddAlternatePart(AddAlternatePartSetup)


AddAlternatePartSetup Class Members | fcSDK Documentation

AddAlternatePartSetup Class Members

The following tables list the members exposed by AddAlternatePartSetup.

Public Constructors

 | Name | Description
Public Constructor | AddAlternatePartSetup Constructor | Initializes a new instance of the AddAlternatePartSetup class.

Public Properties

 | Name | Description
Public Property | AlternatePartDomain | The Alternate Part domain
Public Property | AlternatePartNumber | The Alternate Part number
Public Property | AlternatePartRevision | The Alternate Part revision
Public Property | IsReciprocal | Specifies whether (true) or not (false) the first part/rev should be made an alternate of the second part
Public Property | PartDomain | The Part domain
Public Property | PartNumber | The Part number
Public Property | PartRevision | The Part revision

Reference

AddAlternatePartSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitAddAlternatePart(AddAlternatePartSetup)


AddAlternatePartSetup Constructor | fcSDK Documentation

AddAlternatePartSetup Constructor

The Part number

The Part revision

The Part domain

The Alternate Part number

The Alternate Part revision

The Alternate Part domain

Initializes a new instance of the AddAlternatePartSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partNumber_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _alternatePartNumber_ As String, _
   ByVal _alternatePartRevision_ As String, _
   ByVal _alternatePartDomain_ As String _
)

[ConstructorIndexAttribute()]
public AddAlternatePartSetup(
   string _partNumber_,
   string _partRevision_,
   string _partDomain_,
   string _alternatePartNumber_,
   string _alternatePartRevision_,
   string _alternatePartDomain_
)

Parameters

partNumber

The Part number

partRevision

The Part revision

partDomain

The Part domain

alternatePartNumber

The Alternate Part number

alternatePartRevision

The Alternate Part revision

alternatePartDomain

The Alternate Part domain

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddAlternatePartSetup Class
AddAlternatePartSetup Members


AlternatePartDomain Property (AddAlternatePartSetup) | fcSDK Documentation

AlternatePartDomain Property (AddAlternatePartSetup)

The Alternate Part domain

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AlternatePartDomain As String

[PropertyBitValueAttribute()]
public string AlternatePartDomain {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddAlternatePartSetup Class
AddAlternatePartSetup Members


AlternatePartNumber Property (AddAlternatePartSetup) | fcSDK Documentation

AlternatePartNumber Property (AddAlternatePartSetup)

The Alternate Part number

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AlternatePartNumber As String

[PropertyBitValueAttribute()]
public string AlternatePartNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddAlternatePartSetup Class
AddAlternatePartSetup Members


AlternatePartRevision Property (AddAlternatePartSetup) | fcSDK Documentation

AlternatePartRevision Property (AddAlternatePartSetup)

The Alternate Part revision

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AlternatePartRevision As String

[PropertyBitValueAttribute()]
public string AlternatePartRevision {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddAlternatePartSetup Class
AddAlternatePartSetup Members


IsReciprocal Property | fcSDK Documentation

IsReciprocal Property

Specifies whether (true) or not (false) the first part/rev should be made an alternate of the second part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsReciprocal As Boolean

[PropertyBitValueAttribute()]
public bool IsReciprocal {get; set;}

Property Value

Whether (true) or not (false) the first part/rev should be made an alternate of the second part

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddAlternatePartSetup Class
AddAlternatePartSetup Members


PartDomain Property (AddAlternatePartSetup) | fcSDK Documentation

PartDomain Property (AddAlternatePartSetup)

The Part domain

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartDomain As String

[PropertyBitValueAttribute()]
public string PartDomain {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddAlternatePartSetup Class
AddAlternatePartSetup Members


PartNumber Property (AddAlternatePartSetup) | fcSDK Documentation

PartNumber Property (AddAlternatePartSetup)

The Part number

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartNumber As String

[PropertyBitValueAttribute()]
public string PartNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddAlternatePartSetup Class
AddAlternatePartSetup Members


PartRevision Property (AddAlternatePartSetup) | fcSDK Documentation

PartRevision Property (AddAlternatePartSetup)

The Part revision

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRevision As String

[PropertyBitValueAttribute()]
public string PartRevision {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddAlternatePartSetup Class
AddAlternatePartSetup Members


AddGLAccountSetup Class | fcSDK Documentation

AddGLAccountSetup Class

Used by the AddGLAccount method as setup data for invocation.

Syntax

'Declaration

Public Class AddGLAccountSetup

public class AddGLAccountSetup

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.AddGLAccountSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

AddGLAccountSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitAddGLAccount(AddGLAccountSetup)


AddGLAccountSetup Class Members | fcSDK Documentation

AddGLAccountSetup Class Members

The following tables list the members exposed by AddGLAccountSetup.

Public Constructors

 | Name | Description
Public Constructor | AddGLAccountSetup Constructor | Initializes a new instance of the AddGLAccountSetup class.

Public Properties

 | Name | Description
Public Property | AccountName | Name of the General Ledger account
Public Property | AccountNumber | The number for the General Ledger account
Public Property | AccountType | Element from the 'Location Type' user list. If not set the default list value is used.
Public Property | Description | Description of the account
Public Property | IsActive | Specifies whether this account is active (true) or inactive (false)
Public Property | IsCompany | Specifies whether this account is company owned (true) or customer owned (false)
Public Property | IsExpenseGLAccount | Specifies whether this is an expense account (true) or a GL account (false)
Public Property | SiteIDNum | The identifier of the Site with which the account is to be associated

Reference

AddGLAccountSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitAddGLAccount(AddGLAccountSetup)


AddGLAccountSetup Constructor | fcSDK Documentation

AddGLAccountSetup Constructor

Name of the General Ledger account

The identifier of the Site with which the account is to be associated

Initializes a new instance of the AddGLAccountSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _accountName_ As String, _
   ByVal _siteIDNum_ As String _
)

[ConstructorIndexAttribute()]
public AddGLAccountSetup(
   string _accountName_,
   string _siteIDNum_
)

Parameters

accountName

Name of the General Ledger account

siteIDNum

The identifier of the Site with which the account is to be associated

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddGLAccountSetup Class
AddGLAccountSetup Members


AccountName Property (AddGLAccountSetup) | fcSDK Documentation

AccountName Property (AddGLAccountSetup)

Name of the General Ledger account

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AccountName As String

[PropertyBitValueAttribute()]
public string AccountName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddGLAccountSetup Class
AddGLAccountSetup Members


AccountNumber Property (AddGLAccountSetup) | fcSDK Documentation

AccountNumber Property (AddGLAccountSetup)

The number for the General Ledger account

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AccountNumber As String

[PropertyBitValueAttribute()]
public string AccountNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddGLAccountSetup Class
AddGLAccountSetup Members


AccountType Property (AddGLAccountSetup) | fcSDK Documentation

AccountType Property (AddGLAccountSetup)

Element from the 'Location Type' user list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AccountType As String

[PropertyBitValueAttribute()]
public string AccountType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddGLAccountSetup Class
AddGLAccountSetup Members


Description Property (AddGLAccountSetup) | fcSDK Documentation

Description Property (AddGLAccountSetup)

Description of the account

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Description As String

[PropertyBitValueAttribute()]
public string Description {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddGLAccountSetup Class
AddGLAccountSetup Members


IsActive Property (AddGLAccountSetup) | fcSDK Documentation

IsActive Property (AddGLAccountSetup)

Specifies whether this account is active (true) or inactive (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsActive As Boolean

[PropertyBitValueAttribute()]
public bool IsActive {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddGLAccountSetup Class
AddGLAccountSetup Members


IsCompany Property (AddGLAccountSetup) | fcSDK Documentation

IsCompany Property (AddGLAccountSetup)

Specifies whether this account is company owned (true) or customer owned (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsCompany As Boolean

[PropertyBitValueAttribute()]
public bool IsCompany {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddGLAccountSetup Class
AddGLAccountSetup Members


IsExpenseGLAccount Property (AddGLAccountSetup) | fcSDK Documentation

IsExpenseGLAccount Property (AddGLAccountSetup)

Specifies whether this is an expense account (true) or a GL account (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsExpenseGLAccount As Boolean

[PropertyBitValueAttribute()]
public bool IsExpenseGLAccount {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddGLAccountSetup Class
AddGLAccountSetup Members


SiteIDNum Property (AddGLAccountSetup) | fcSDK Documentation

SiteIDNum Property (AddGLAccountSetup)

The identifier of the Site with which the account is to be associated

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteIDNum As String

[PropertyBitValueAttribute()]
public string SiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddGLAccountSetup Class
AddGLAccountSetup Members


AddInventoryBinSetup Class | fcSDK Documentation

AddInventoryBinSetup Class

Used by the AddInventoryBin method as setup data for invocation.

Syntax

'Declaration

Public Class AddInventoryBinSetup

public class AddInventoryBinSetup

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.AddInventoryBinSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

AddInventoryBinSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitAddInventoryBin(AddInventoryBinSetup)


AddInventoryBinSetup Class Members | fcSDK Documentation

AddInventoryBinSetup Class Members

The following tables list the members exposed by AddInventoryBinSetup.

Public Constructors

 | Name | Description
Public Constructor | AddInventoryBinSetup Constructor | Initializes a new instance of the AddInventoryBinSetup class.

Public Properties

 | Name | Description
Public Property | IsActive | Specifies whether this inventory bin is active (true) or inactive (false)
Public Property | Location | A reference to a Location object which specifies the name of the bin to create and the name of the location in which to create it

Reference

AddInventoryBinSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitAddInventoryBin(AddInventoryBinSetup)


AddInventoryBinSetup Constructor | fcSDK Documentation

AddInventoryBinSetup Constructor

A reference to a Location object which specifies the name of the bin to create and the name of the location in which to create it

Initializes a new instance of the AddInventoryBinSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _location_ As Location _
)

[ConstructorIndexAttribute()]
public AddInventoryBinSetup(
   Location _location_
)

Parameters

location

A reference to a Location object which specifies the name of the bin to create and the name of the location in which to create it

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddInventoryBinSetup Class
AddInventoryBinSetup Members


IsActive Property (AddInventoryBinSetup) | fcSDK Documentation

IsActive Property (AddInventoryBinSetup)

Specifies whether this inventory bin is active (true) or inactive (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsActive As Boolean

[PropertyBitValueAttribute()]
public bool IsActive {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddInventoryBinSetup Class
AddInventoryBinSetup Members


Location Property (AddInventoryBinSetup) | fcSDK Documentation

Location Property (AddInventoryBinSetup)

A reference to a Location object which specifies the name of the bin to create and the name of the location in which to create it

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Location As Location

[PropertyBitValueAttribute()]
public Location Location {get; set;}

Remarks

When creating an instance of a Location object for this API, both the location name and the bin name must be specified in the Location object's constructor.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddInventoryBinSetup Class
AddInventoryBinSetup Members


AddInventoryLocationSetup Class | fcSDK Documentation

AddInventoryLocationSetup Class

Used by the AddInventoryLocation method as setup data for invocation.

Syntax

'Declaration

Public Class AddInventoryLocationSetup

public class AddInventoryLocationSetup

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.AddInventoryLocationSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

AddInventoryLocationSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitAddInventoryLocation(AddInventoryLocationSetup)


AddInventoryLocationSetup Class Members | fcSDK Documentation

AddInventoryLocationSetup Class Members

The following tables list the members exposed by AddInventoryLocationSetup.

Public Constructors

 | Name | Description
Public Constructor | AddInventoryLocationSetup Constructor | Initializes a new instance of the AddInventoryLocationSetup class.

Public Properties

 | Name | Description
Public Property | AccountType | Element from the 'Location Type' user list. If not set the default list value is used.
Public Property | CapitalGLAccount | The name of the Capital GL account with which this inventory location is to be associated
Public Property | Description | Description of the inventory location
Public Property | IsActive | Specifies whether this inventory location is active (true) or inactive (false)
Public Property | IsCompany | Specifies whether this account is company owned (true) or customer owned (false)
Public Property | LocationName | Name of the inventory location to add
Public Property | PartAuthorizationLevel | The part authorization level for this inventory location
Public Property | ReportsToLocation | Name of the inventory location to which this new inventory location reports
Public Property | SiteIDNum | The identifier of the Site with which the inventory location is to be associated

Reference

AddInventoryLocationSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitAddInventoryLocation(AddInventoryLocationSetup)


AddInventoryLocationSetup Constructor | fcSDK Documentation

AddInventoryLocationSetup Constructor

Name of the inventory location to add

The name of the Capital GL account with which this inventory location is to be associated

The identifier of the Site with which the inventory location is to be associated

The part authorization level for this inventory location

Initializes a new instance of the AddInventoryLocationSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _locationName_ As String, _
   ByVal _capitalGLAccount_ As String, _
   ByVal _siteIDNum_ As String, _
   ByVal _partAuthorizationLevel_ As PartAuthorizationLevel _
)

[ConstructorIndexAttribute()]
public AddInventoryLocationSetup(
   string _locationName_,
   string _capitalGLAccount_,
   string _siteIDNum_,
   PartAuthorizationLevel _partAuthorizationLevel_
)

Parameters

locationName

Name of the inventory location to add

capitalGLAccount

The name of the Capital GL account with which this inventory location is to be associated

siteIDNum

The identifier of the Site with which the inventory location is to be associated

partAuthorizationLevel

The part authorization level for this inventory location

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddInventoryLocationSetup Class
AddInventoryLocationSetup Members


AccountType Property (AddInventoryLocationSetup) | fcSDK Documentation

AccountType Property (AddInventoryLocationSetup)

Element from the 'Location Type' user list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AccountType As String

[PropertyBitValueAttribute()]
public string AccountType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddInventoryLocationSetup Class
AddInventoryLocationSetup Members


CapitalGLAccount Property (AddInventoryLocationSetup) | fcSDK Documentation

CapitalGLAccount Property (AddInventoryLocationSetup)

The name of the Capital GL account with which this inventory location is to be associated

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CapitalGLAccount As String

[PropertyBitValueAttribute()]
public string CapitalGLAccount {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddInventoryLocationSetup Class
AddInventoryLocationSetup Members


Description Property (AddInventoryLocationSetup) | fcSDK Documentation

Description Property (AddInventoryLocationSetup)

Description of the inventory location

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Description As String

[PropertyBitValueAttribute()]
public string Description {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddInventoryLocationSetup Class
AddInventoryLocationSetup Members


IsActive Property (AddInventoryLocationSetup) | fcSDK Documentation

IsActive Property (AddInventoryLocationSetup)

Specifies whether this inventory location is active (true) or inactive (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsActive As Boolean

[PropertyBitValueAttribute()]
public bool IsActive {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddInventoryLocationSetup Class
AddInventoryLocationSetup Members


IsCompany Property (AddInventoryLocationSetup) | fcSDK Documentation

IsCompany Property (AddInventoryLocationSetup)

Specifies whether this account is company owned (true) or customer owned (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsCompany As Boolean

[PropertyBitValueAttribute()]
public bool IsCompany {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddInventoryLocationSetup Class
AddInventoryLocationSetup Members


LocationName Property (AddInventoryLocationSetup) | fcSDK Documentation

LocationName Property (AddInventoryLocationSetup)

Name of the inventory location to add

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LocationName As String

[PropertyBitValueAttribute()]
public string LocationName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddInventoryLocationSetup Class
AddInventoryLocationSetup Members


PartAuthorizationLevel Property (AddInventoryLocationSetup) | fcSDK Documentation

PartAuthorizationLevel Property (AddInventoryLocationSetup)

The part authorization level for this inventory location

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartAuthorizationLevel As PartAuthorizationLevel

[PropertyBitValueAttribute()]
public PartAuthorizationLevel PartAuthorizationLevel {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddInventoryLocationSetup Class
AddInventoryLocationSetup Members


ReportsToLocation Property (AddInventoryLocationSetup) | fcSDK Documentation

ReportsToLocation Property (AddInventoryLocationSetup)

Name of the inventory location to which this new inventory location reports

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ReportsToLocation As String

[PropertyBitValueAttribute()]
public string ReportsToLocation {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddInventoryLocationSetup Class
AddInventoryLocationSetup Members


SiteIDNum Property (AddInventoryLocationSetup) | fcSDK Documentation

SiteIDNum Property (AddInventoryLocationSetup)

The identifier of the Site with which the inventory location is to be associated

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteIDNum As String

[PropertyBitValueAttribute()]
public string SiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddInventoryLocationSetup Class
AddInventoryLocationSetup Members


AddLocationServicingSiteSetup Class | fcSDK Documentation

AddLocationServicingSiteSetup Class

Used by the AddLocationServicingSite method as setup data for invocation.

Syntax

'Declaration

Public Class AddLocationServicingSiteSetup

public class AddLocationServicingSiteSetup

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.AddLocationServicingSiteSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

AddLocationServicingSiteSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitAddLocationServicingSite(AddLocationServicingSiteSetup)


AddLocationServicingSiteSetup Class Members | fcSDK Documentation

AddLocationServicingSiteSetup Class Members

The following tables list the members exposed by AddLocationServicingSiteSetup.

Public Constructors

 | Name | Description
Public Constructor | AddLocationServicingSiteSetup Constructor | Initializes a new instance of the AddLocationServicingSiteSetup class.

Public Properties

 | Name | Description
Public Property | IsActive | Specifies whether this inventory location is active (true) or inactive (false)
Public Property | LocationName | The name of the location that will be servicing the Site
Public Property | LocationRank | The rank of this inventory location at the associated site
Public Property | SiteIDNum | The identifier of the Site that the inventory location is servicing

Reference

AddLocationServicingSiteSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitAddLocationServicingSite(AddLocationServicingSiteSetup)


AddLocationServicingSiteSetup Constructor | fcSDK Documentation

AddLocationServicingSiteSetup Constructor

The identifier of the Site that the inventory location is servicing

The name of the location that will be servicing the Site

The rank of this inventory location at the associated site

Initializes a new instance of the AddLocationServicingSiteSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _siteIDNum_ As String, _
   ByVal _locationName_ As String, _
   ByVal _locationRank_ As Short _
)

[ConstructorIndexAttribute()]
public AddLocationServicingSiteSetup(
   string _siteIDNum_,
   string _locationName_,
   short _locationRank_
)

Parameters

siteIDNum

The identifier of the Site that the inventory location is servicing

locationName

The name of the location that will be servicing the Site

locationRank

The rank of this inventory location at the associated site

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddLocationServicingSiteSetup Class
AddLocationServicingSiteSetup Members


IsActive Property (AddLocationServicingSiteSetup) | fcSDK Documentation

IsActive Property (AddLocationServicingSiteSetup)

Specifies whether this inventory location is active (true) or inactive (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsActive As Boolean

[PropertyBitValueAttribute()]
public bool IsActive {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddLocationServicingSiteSetup Class
AddLocationServicingSiteSetup Members


LocationName Property (AddLocationServicingSiteSetup) | fcSDK Documentation

LocationName Property (AddLocationServicingSiteSetup)

The name of the location that will be servicing the Site

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LocationName As String

[PropertyBitValueAttribute()]
public string LocationName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddLocationServicingSiteSetup Class
AddLocationServicingSiteSetup Members


LocationRank Property (AddLocationServicingSiteSetup) | fcSDK Documentation

LocationRank Property (AddLocationServicingSiteSetup)

The rank of this inventory location at the associated site

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LocationRank As Short

[PropertyBitValueAttribute()]
public short LocationRank {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddLocationServicingSiteSetup Class
AddLocationServicingSiteSetup Members


SiteIDNum Property (AddLocationServicingSiteSetup) | fcSDK Documentation

SiteIDNum Property (AddLocationServicingSiteSetup)

The identifier of the Site that the inventory location is servicing

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteIDNum As String

[PropertyBitValueAttribute()]
public string SiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddLocationServicingSiteSetup Class
AddLocationServicingSiteSetup Members


AssignPartRequestSetup Class | fcSDK Documentation

AssignPartRequestSetup Class

Used by the AssignPartRequest method as setup data for invocation.

Syntax

'Declaration

Public Class AssignPartRequestSetup

public class AssignPartRequestSetup

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.AssignPartRequestSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

AssignPartRequestSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitAssignPartRequest(AssignPartRequestSetup)


AssignPartRequestSetup Class Members | fcSDK Documentation

AssignPartRequestSetup Class Members

The following tables list the members exposed by AssignPartRequestSetup.

Public Constructors

 | Name | Description
Public Constructor | AssignPartRequestSetup Constructor | Initializes a new instance of the AssignPartRequestSetup class.

Public Properties

 | Name | Description
Public Property | AssignDate | DateTime the PartRequest was assigned. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewUser | The new user to which the PartRequest is to be assigned.
Public Property | PartRequestDetailIDNum | Part Request Detail Identifier
Public Property | UserName | The user who has assigned the PartRequest. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the PartRequest. If not set, the UserName's default is used.

Reference

AssignPartRequestSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitAssignPartRequest(AssignPartRequestSetup)


AssignPartRequestSetup Constructor | fcSDK Documentation

AssignPartRequestSetup Constructor

Part Request Detail Identifier

Initializes a new instance of the AssignPartRequestSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String _
)

[ConstructorIndexAttribute()]
public AssignPartRequestSetup(
   string _partRequestDetailIDNum_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignPartRequestSetup Class
AssignPartRequestSetup Members


AssignDate Property (AssignPartRequestSetup) | fcSDK Documentation

AssignDate Property (AssignPartRequestSetup)

DateTime the PartRequest was assigned. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AssignDate As Date

[PropertyBitValueAttribute()]
public DateTime AssignDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignPartRequestSetup Class
AssignPartRequestSetup Members


GenerateTimeBombs Property (AssignPartRequestSetup) | fcSDK Documentation

GenerateTimeBombs Property (AssignPartRequestSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignPartRequestSetup Class
AssignPartRequestSetup Members


NewUser Property (AssignPartRequestSetup) | fcSDK Documentation

NewUser Property (AssignPartRequestSetup)

The new user to which the PartRequest is to be assigned.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewUser As String

[PropertyBitValueAttribute()]
public string NewUser {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignPartRequestSetup Class
AssignPartRequestSetup Members


PartRequestDetailIDNum Property (AssignPartRequestSetup) | fcSDK Documentation

PartRequestDetailIDNum Property (AssignPartRequestSetup)

Part Request Detail Identifier

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRequestDetailIDNum As String

[PropertyBitValueAttribute()]
public string PartRequestDetailIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignPartRequestSetup Class
AssignPartRequestSetup Members


UserName Property (AssignPartRequestSetup) | fcSDK Documentation

UserName Property (AssignPartRequestSetup)

The user who has assigned the PartRequest. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignPartRequestSetup Class
AssignPartRequestSetup Members


WipBin Property (AssignPartRequestSetup) | fcSDK Documentation

WipBin Property (AssignPartRequestSetup)

User's WipBin in which to place the PartRequest. If not set, the UserName's default is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignPartRequestSetup Class
AssignPartRequestSetup Members


BackorderPartRequestSetup Class | fcSDK Documentation

BackorderPartRequestSetup Class

Used by the BackorderPartRequest method as setup data for invocation.

Syntax

'Declaration

Public Class BackorderPartRequestSetup

public class BackorderPartRequestSetup

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.BackorderPartRequestSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

BackorderPartRequestSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitBackorderPartRequest(BackorderPartRequestSetup)


BackorderPartRequestSetup Class Members | fcSDK Documentation

BackorderPartRequestSetup Class Members

The following tables list the members exposed by BackorderPartRequestSetup.

Public Constructors

 | Name | Description
Public Constructor | BackorderPartRequestSetup Constructor | Overloaded.

Public Properties

 | Name | Description
Public Property | ExpectedDate | The DateTime the Part Request backordered parts are expected to arrive. If not set, the current time is used.
Public Property | FromGood | Specifies whether the backordered inventory is from good stock (true) or bad stock (false)
Public Property | FromLocation | The inventory location containing the parts used to backorder this Part Request
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewStatus | The new status for the Part Request for the backordered condition. If not set, the default status is used.
Public Property | PartRequestDetailIDNum | Part Request Detail Identifier
Public Property | Quantity | The number of parts being backordered for this Part Request
Public Property | SerialNumber | The serial number of the part used to backorder this Part Request
Public Property | ToGood | Specifies whether the backordered inventory is going to good stock (true) or bad stock (false)
Public Property | ToLocation | The destination inventory location for the parts used to backorder this Part Request
Public Property | UserName | The user who is backordering the Part Request. If not set, the session user is used.
Public Property | UseTransitions | Specifies whether or not logistics transitions will be checked and the condition/status of the part request detail will be changed during the backorder operation

Reference

BackorderPartRequestSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitBackorderPartRequest(BackorderPartRequestSetup)


BackorderPartRequestSetup Constructor | fcSDK Documentation

BackorderPartRequestSetup Constructor

Initializes a new instance of the BackorderPartRequestSetup class.

Overload List

Overload | Description
BackorderPartRequestSetup Constructor(String,DateTime,Int32) | Initializes a new instance of the BackorderPartRequestSetup class. This overload takes a set of required parameters for the API.
BackorderPartRequestSetup Constructor(String,DateTime,String) | Initializes a new instance of the BackorderPartRequestSetup class. This overload takes a set of required parameters for the API.
BackorderPartRequestSetup Constructor(String,DateTime,Boolean,Int32) | Initializes a new instance of the BackorderPartRequestSetup class. This overload takes a set of required parameters for the API.
BackorderPartRequestSetup Constructor(String,DateTime,Boolean,String) | Initializes a new instance of the BackorderPartRequestSetup class. This overload takes a set of required parameters for the API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

BackorderPartRequestSetup Class
BackorderPartRequestSetup Members


BackorderPartRequestSetup Constructor(String,DateTime,Int32) | fcSDK Documentation

BackorderPartRequestSetup Constructor(String,DateTime,Int32)

Part Request Detail Identifier

The DateTime the Part Request backordered parts are expected to arrive. If not set, the current time is used.

The number of parts being backordered for this Part Request

Initializes a new instance of the BackorderPartRequestSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _expectedDate_ As Date, _
   ByVal _quantity_ As Integer _
)

[ConstructorIndexAttribute()]
public BackorderPartRequestSetup(
   string _partRequestDetailIDNum_,
   DateTime _expectedDate_,
   int _quantity_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

expectedDate

The DateTime the Part Request backordered parts are expected to arrive. If not set, the current time is used.

quantity

The number of parts being backordered for this Part Request

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

BackorderPartRequestSetup Class
BackorderPartRequestSetup Members
Overload List


BackorderPartRequestSetup Constructor(String,DateTime,String) | fcSDK Documentation

BackorderPartRequestSetup Constructor(String,DateTime,String)

Part Request Detail Identifier

The DateTime the Part Request backordered parts are expected to arrive. If not set, the current time is used.

The serial number of the part used to backorder this Part Request

Initializes a new instance of the BackorderPartRequestSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _expectedDate_ As Date, _
   ByVal _serialNumber_ As String _
)

[ConstructorIndexAttribute()]
public BackorderPartRequestSetup(
   string _partRequestDetailIDNum_,
   DateTime _expectedDate_,
   string _serialNumber_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

expectedDate

The DateTime the Part Request backordered parts are expected to arrive. If not set, the current time is used.

serialNumber

The serial number of the part used to backorder this Part Request

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

BackorderPartRequestSetup Class
BackorderPartRequestSetup Members
Overload List


BackorderPartRequestSetup Constructor(String,DateTime,Boolean,Int32) | fcSDK Documentation

BackorderPartRequestSetup Constructor(String,DateTime,Boolean,Int32)

Part Request Detail Identifier

The DateTime the Part Request backordered parts are expected to arrive. If not set, the current time is used.

Specifies whether or not logistics transitions will be checked and the condition/status of the part request detail will be changed during the backorder operation

The number of parts being backordered for this Part Request

Initializes a new instance of the BackorderPartRequestSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _expectedDate_ As Date, _
   ByVal _useTransitions_ As Boolean, _
   ByVal _quantity_ As Integer _
)

[ConstructorIndexAttribute()]
public BackorderPartRequestSetup(
   string _partRequestDetailIDNum_,
   DateTime _expectedDate_,
   bool _useTransitions_,
   int _quantity_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

expectedDate

The DateTime the Part Request backordered parts are expected to arrive. If not set, the current time is used.

useTransitions

Specifies whether or not logistics transitions will be checked and the condition/status of the part request detail will be changed during the backorder operation

quantity

The number of parts being backordered for this Part Request

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

BackorderPartRequestSetup Class
BackorderPartRequestSetup Members
Overload List


BackorderPartRequestSetup Constructor(String,DateTime,Boolean,String) | fcSDK Documentation

BackorderPartRequestSetup Constructor(String,DateTime,Boolean,String)

Part Request Detail Identifier

The DateTime the Part Request backordered parts are expected to arrive. If not set, the current time is used.

Specifies whether or not logistics transitions will be checked and the condition/status of the part request detail will be changed during the backorder operation

The serial number of the part used to backorder this Part Request

Initializes a new instance of the BackorderPartRequestSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _expectedDate_ As Date, _
   ByVal _useTransitions_ As Boolean, _
   ByVal _serialNumber_ As String _
)

[ConstructorIndexAttribute()]
public BackorderPartRequestSetup(
   string _partRequestDetailIDNum_,
   DateTime _expectedDate_,
   bool _useTransitions_,
   string _serialNumber_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

expectedDate

The DateTime the Part Request backordered parts are expected to arrive. If not set, the current time is used.

useTransitions

Specifies whether or not logistics transitions will be checked and the condition/status of the part request detail will be changed during the backorder operation

serialNumber

The serial number of the part used to backorder this Part Request

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

BackorderPartRequestSetup Class
BackorderPartRequestSetup Members
Overload List


ExpectedDate Property | fcSDK Documentation

ExpectedDate Property

The DateTime the Part Request backordered parts are expected to arrive. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ExpectedDate As Date

[PropertyBitValueAttribute()]
public DateTime ExpectedDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

BackorderPartRequestSetup Class
BackorderPartRequestSetup Members


FromGood Property (BackorderPartRequestSetup) | fcSDK Documentation

FromGood Property (BackorderPartRequestSetup)

Specifies whether the backordered inventory is from good stock (true) or bad stock (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FromGood As Boolean

[PropertyBitValueAttribute()]
public bool FromGood {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

BackorderPartRequestSetup Class
BackorderPartRequestSetup Members


FromLocation Property (BackorderPartRequestSetup) | fcSDK Documentation

FromLocation Property (BackorderPartRequestSetup)

The inventory location containing the parts used to backorder this Part Request

Syntax

```csharp

'Declaration

<PropertyBitValueAttribute()>
Public Property FromLocation As Location

[PropertyBitValueAttribute()]
public Location FromLocation {get; set;}

Remarks

To use a primary bin suggestion/recommendation that has been previously configured, use the special constructor for the Location object and set the isPrimaryBinSuggestion parameter to true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

BackorderPartRequestSetup Class
BackorderPartRequestSetup Members


GenerateTimeBombs Property (BackorderPartRequestSetup) | fcSDK Documentation

GenerateTimeBombs Property (BackorderPartRequestSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

BackorderPartRequestSetup Class
BackorderPartRequestSetup Members


NewStatus Property (BackorderPartRequestSetup) | fcSDK Documentation

NewStatus Property (BackorderPartRequestSetup)

The new status for the Part Request for the backordered condition. If not set, the default status is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewStatus As String

[PropertyBitValueAttribute()]
public string NewStatus {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

BackorderPartRequestSetup Class
BackorderPartRequestSetup Members


PartRequestDetailIDNum Property (BackorderPartRequestSetup) | fcSDK Documentation

PartRequestDetailIDNum Property (BackorderPartRequestSetup)

Part Request Detail Identifier

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRequestDetailIDNum As String

[PropertyBitValueAttribute()]
public string PartRequestDetailIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

BackorderPartRequestSetup Class
BackorderPartRequestSetup Members


Quantity Property (BackorderPartRequestSetup) | fcSDK Documentation

Quantity Property (BackorderPartRequestSetup)

The number of parts being backordered for this Part Request

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Quantity As Integer

[PropertyBitValueAttribute()]
public int Quantity {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

BackorderPartRequestSetup Class
BackorderPartRequestSetup Members


SerialNumber Property (BackorderPartRequestSetup) | fcSDK Documentation

SerialNumber Property (BackorderPartRequestSetup)

The serial number of the part used to backorder this Part Request

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SerialNumber As String

[PropertyBitValueAttribute()]
public string SerialNumber {get; set;}

Remarks

If no serial number is specified and serialized parts are being used, the serial number from the Part Request will be used.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

BackorderPartRequestSetup Class
BackorderPartRequestSetup Members


ToGood Property (BackorderPartRequestSetup) | fcSDK Documentation

ToGood Property (BackorderPartRequestSetup)

Specifies whether the backordered inventory is going to good stock (true) or bad stock (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ToGood As Boolean

[PropertyBitValueAttribute()]
public bool ToGood {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

BackorderPartRequestSetup Class
BackorderPartRequestSetup Members


ToLocation Property (BackorderPartRequestSetup) | fcSDK Documentation

ToLocation Property (BackorderPartRequestSetup)

The destination inventory location for the parts used to backorder this Part Request

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ToLocation As Location

[PropertyBitValueAttribute()]
public Location ToLocation {get; set;}

Remarks

To use a primary bin suggestion/recommendation that has been previously configured, use the special constructor for the Location object and set the isPrimaryBinSuggestion parameter to true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

BackorderPartRequestSetup Class
BackorderPartRequestSetup Members


UserName Property (BackorderPartRequestSetup) | fcSDK Documentation

UserName Property (BackorderPartRequestSetup)

The user who is backordering the Part Request. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

BackorderPartRequestSetup Class
BackorderPartRequestSetup Members


UseTransitions Property (BackorderPartRequestSetup) | fcSDK Documentation

UseTransitions Property (BackorderPartRequestSetup)

Specifies whether or not logistics transitions will be checked and the condition/status of the part request detail will be changed during the backorder operation

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UseTransitions As Boolean

[PropertyBitValueAttribute()]
public bool UseTransitions {get; set;}

Remarks

Setting this value to false allows for multiple calls to the API to be performed without extra complex transitions being added to the system. By default, the value is true.

NOTE: The last call to FulfillPartRequest in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

BackorderPartRequestSetup Class
BackorderPartRequestSetup Members


ChangePartRequestStatusSetup Class | fcSDK Documentation

ChangePartRequestStatusSetup Class

Used by the ChangePartRequestStatus method as setup data for invocation.

Syntax

'Declaration

Public Class ChangePartRequestStatusSetup

public class ChangePartRequestStatusSetup

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.ChangePartRequestStatusSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ChangePartRequestStatusSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitChangePartRequestStatus(ChangePartRequestStatusSetup)


ChangePartRequestStatusSetup Class Members | fcSDK Documentation

ChangePartRequestStatusSetup Class Members

The following tables list the members exposed by ChangePartRequestStatusSetup.

Public Constructors

 | Name | Description
Public Constructor | ChangePartRequestStatusSetup Constructor | Initializes a new instance of the ChangePartRequestStatusSetup class.

Public Properties

 | Name | Description
Public Property | ChangeDate | The DateTime the Part Request status was changed. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewStatus | The new status for the Part Request for the current condition. If not set, the default status is used.
Public Property | Notes | Notes about the status change for the Part Request
Public Property | PartRequestDetailIDNum | Part Request Detail Identifier
Public Property | UserName | The user who is changing the status of the Part Request. If not set, the session user is used.

Reference

ChangePartRequestStatusSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitChangePartRequestStatus(ChangePartRequestStatusSetup)


ChangePartRequestStatusSetup Constructor | fcSDK Documentation

ChangePartRequestStatusSetup Constructor

Part Request Detail Identifier

Initializes a new instance of the ChangePartRequestStatusSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String _
)

[ConstructorIndexAttribute()]
public ChangePartRequestStatusSetup(
   string _partRequestDetailIDNum_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangePartRequestStatusSetup Class
ChangePartRequestStatusSetup Members


ChangeDate Property (ChangePartRequestStatusSetup) | fcSDK Documentation

ChangeDate Property (ChangePartRequestStatusSetup)

The DateTime the Part Request status was changed. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ChangeDate As Date

[PropertyBitValueAttribute()]
public DateTime ChangeDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangePartRequestStatusSetup Class
ChangePartRequestStatusSetup Members


GenerateTimeBombs Property (ChangePartRequestStatusSetup) | fcSDK Documentation

GenerateTimeBombs Property (ChangePartRequestStatusSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangePartRequestStatusSetup Class
ChangePartRequestStatusSetup Members


NewStatus Property (ChangePartRequestStatusSetup) | fcSDK Documentation

NewStatus Property (ChangePartRequestStatusSetup)

The new status for the Part Request for the current condition. If not set, the default status is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewStatus As String

[PropertyBitValueAttribute()]
public string NewStatus {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangePartRequestStatusSetup Class
ChangePartRequestStatusSetup Members


Notes Property (ChangePartRequestStatusSetup) | fcSDK Documentation

Notes Property (ChangePartRequestStatusSetup)

Notes about the status change for the Part Request

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangePartRequestStatusSetup Class
ChangePartRequestStatusSetup Members


PartRequestDetailIDNum Property (ChangePartRequestStatusSetup) | fcSDK Documentation

PartRequestDetailIDNum Property (ChangePartRequestStatusSetup)

Part Request Detail Identifier

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRequestDetailIDNum As String

[PropertyBitValueAttribute()]
public string PartRequestDetailIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangePartRequestStatusSetup Class
ChangePartRequestStatusSetup Members


UserName Property (ChangePartRequestStatusSetup) | fcSDK Documentation

UserName Property (ChangePartRequestStatusSetup)

The user who is changing the status of the Part Request. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangePartRequestStatusSetup Class
ChangePartRequestStatusSetup Members


ClosePartRequestSetup Class | fcSDK Documentation

ClosePartRequestSetup Class

Used by the ClosePartRequest method as setup data for invocation.

Syntax

'Declaration

Public Class ClosePartRequestSetup

public class ClosePartRequestSetup

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.ClosePartRequestSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ClosePartRequestSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitClosePartRequest(ClosePartRequestSetup)


ClosePartRequestSetup Class Members | fcSDK Documentation

ClosePartRequestSetup Class Members

The following tables list the members exposed by ClosePartRequestSetup.

Public Constructors

 | Name | Description
Public Constructor | ClosePartRequestSetup Constructor | Initializes a new instance of the ClosePartRequestSetup class.

Public Properties

 | Name | Description
Public Property | CloseDate | The DateTime the Part Request was closed. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewStatus | The new status for the Part Request from the Closed condition. If not set, the default status is used.
Public Property | PartRequestDetailIDNum | Part Request Detail Identifier
Public Property | UserName | The user who is closing the Part Request. If not set, the session user is used.

Reference

ClosePartRequestSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitClosePartRequest(ClosePartRequestSetup)


ClosePartRequestSetup Constructor | fcSDK Documentation

ClosePartRequestSetup Constructor

Part Request Detail Identifier

Initializes a new instance of the ClosePartRequestSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String _
)

[ConstructorIndexAttribute()]
public ClosePartRequestSetup(
   string _partRequestDetailIDNum_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClosePartRequestSetup Class
ClosePartRequestSetup Members


CloseDate Property (ClosePartRequestSetup) | fcSDK Documentation

CloseDate Property (ClosePartRequestSetup)

The DateTime the Part Request was closed. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CloseDate As Date

[PropertyBitValueAttribute()]
public DateTime CloseDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClosePartRequestSetup Class
ClosePartRequestSetup Members


GenerateTimeBombs Property (ClosePartRequestSetup) | fcSDK Documentation

GenerateTimeBombs Property (ClosePartRequestSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClosePartRequestSetup Class
ClosePartRequestSetup Members


NewStatus Property (ClosePartRequestSetup) | fcSDK Documentation

NewStatus Property (ClosePartRequestSetup)

The new status for the Part Request from the Closed condition. If not set, the default status is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewStatus As String

[PropertyBitValueAttribute()]
public string NewStatus {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClosePartRequestSetup Class
ClosePartRequestSetup Members


PartRequestDetailIDNum Property (ClosePartRequestSetup) | fcSDK Documentation

PartRequestDetailIDNum Property (ClosePartRequestSetup)

Part Request Detail Identifier

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRequestDetailIDNum As String

[PropertyBitValueAttribute()]
public string PartRequestDetailIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClosePartRequestSetup Class
ClosePartRequestSetup Members


UserName Property (ClosePartRequestSetup) | fcSDK Documentation

UserName Property (ClosePartRequestSetup)

The user who is closing the Part Request. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClosePartRequestSetup Class
ClosePartRequestSetup Members


CreateContainerSetup Class | fcSDK Documentation

CreateContainerSetup Class

Syntax

'Declaration

Public Class CreateContainerSetup

public class CreateContainerSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Logistics.CreateContainerSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateContainerSetup Members
FChoice.Toolkits.Clarify.Logistics Namespace


CreateContainerSetup Class Members | fcSDK Documentation

CreateContainerSetup Class Members

The following tables list the members exposed by CreateContainerSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateContainerSetup Constructor |

Public Properties

 | Name | Description
Public Property | BinName |
Public Property | ContainerName |
Public Property | LocationName |

Reference

CreateContainerSetup Class
FChoice.Toolkits.Clarify.Logistics Namespace


CreateContainerSetup Constructor | fcSDK Documentation

CreateContainerSetup Constructor

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _containerName_ As String, _
   ByVal _locationName_ As String _
)

[ConstructorIndexAttribute()]
public CreateContainerSetup(
   string _containerName_,
   string _locationName_
)

Parameters

containerName

locationName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContainerSetup Class
CreateContainerSetup Members


BinName Property (CreateContainerSetup) | fcSDK Documentation

BinName Property (CreateContainerSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property BinName As String

[PropertyBitValueAttribute()]
public string BinName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContainerSetup Class
CreateContainerSetup Members


ContainerName Property (CreateContainerSetup) | fcSDK Documentation

ContainerName Property (CreateContainerSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContainerName As String

[PropertyBitValueAttribute()]
public string ContainerName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContainerSetup Class
CreateContainerSetup Members


LocationName Property (CreateContainerSetup) | fcSDK Documentation

LocationName Property (CreateContainerSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LocationName As String

[PropertyBitValueAttribute()]
public string LocationName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateContainerSetup Class
CreateContainerSetup Members


CreatePartRequestDetailResult Class | fcSDK Documentation

CreatePartRequestDetailResult Class

Result from the CreatePartRequestDetail API.

Syntax

'Declaration

Public Class CreatePartRequestDetailResult
   Inherits FChoice.Toolkits.Clarify.ToolkitResult

public class CreatePartRequestDetailResult : FChoice.Toolkits.Clarify.ToolkitResult

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.ToolkitResult
FChoice.Toolkits.Clarify.Logistics.CreatePartRequestDetailResult

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreatePartRequestDetailResult Members
FChoice.Toolkits.Clarify.Logistics Namespace


CreatePartRequestDetailResult Class Members | fcSDK Documentation

CreatePartRequestDetailResult Class Members

The following tables list the members exposed by CreatePartRequestDetailResult.

Public Constructors

 | Name | Description
Public Constructor | CreatePartRequestDetailResult Constructor |

Public Properties

 | Name | Description
Public Property | DetailNumber | Detail Number.
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)

Reference

CreatePartRequestDetailResult Class
FChoice.Toolkits.Clarify.Logistics Namespace


CreatePartRequestDetailResult Constructor | fcSDK Documentation

CreatePartRequestDetailResult Constructor

Syntax

'Declaration

Public Function New()

public CreatePartRequestDetailResult()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestDetailResult Class
CreatePartRequestDetailResult Members


DetailNumber Property | fcSDK Documentation

DetailNumber Property

Detail Number.

Syntax

'Declaration

Public Property DetailNumber As String

public string DetailNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestDetailResult Class
CreatePartRequestDetailResult Members


CreatePartRequestDetailSetup Class | fcSDK Documentation

CreatePartRequestDetailSetup Class

Used by the CreatePartRequestDetail method as setup data for invocation.

Syntax

'Declaration

Public Class CreatePartRequestDetailSetup

public class CreatePartRequestDetailSetup

Remarks

NOTE: The ContractItemObjid property should not be set (left as default) unless you need this functionality AND have installed the First Choice ClearCallCenter for ClearLogistics product and schema changes. If you do not have this product and wish to use this functionality, please contact First Choice Software.

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.CreatePartRequestDetailSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreatePartRequestDetailSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitCreatePartRequestDetail(CreatePartRequestDetailSetup)


CreatePartRequestDetailSetup Class Members | fcSDK Documentation

CreatePartRequestDetailSetup Class Members

The following tables list the members exposed by CreatePartRequestDetailSetup.

Public Constructors

 | Name | Description
Public Constructor | CreatePartRequestDetailSetup Constructor | Overloaded.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CarrierName | Element from the 'Carrier' application list. If not set the default list value is used.
Public Property | ContractItemObjid | Objid of contract line item with which to link this Part Request -- see remarks for special usage
Public Property | CreateDate | The DateTime the Part Request was created. If not set, the current time is used.
Public Property | DetailType | Element from the 'RMA Type' application list. If not set the default list value is used.
Public Property | DueDate | The DateTime the Part Request is due. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | HasWarranty | Specifies whether this Part Request Detail is under warranty (true) or not (false)
Public Property | Notes | Notes about the Part Request Detail creation
Public Property | PartDomain | The Part Request domain
Public Property | PartNumber | The Part Request number
Public Property | PartRequestHeaderIDNum | Parent Part Request Header Identifier
Public Property | PartRevision | The Part Request revision
Public Property | Priority | Element from the 'Request Priority' application list. If not set the default list value is used.
Public Property | Quantity | The number of parts requested
Public Property | Queue | The name of the Queue to dispatch this Part Request to when created. If blank, the Part Request is not dispatched automatically.
Public Property | SerialNumber | The serial number of the Site Part specified for this Part Request
Public Property | ShippingMethod | Element from the 'Ship Via' application list. If not set the default list value is used.
Public Property | SitePartObjid | The Objid of the Site Part to which this Part Request will be linked.
Public Property | Status | The new status for the Part Request for the Open condition. If not set, the default status is used.
Public Property | UserName | The user creating the Part Request Detail. If not set, the session user is used.

Reference

CreatePartRequestDetailSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitCreatePartRequestDetail(CreatePartRequestDetailSetup)


CreatePartRequestDetailSetup Constructor | fcSDK Documentation

CreatePartRequestDetailSetup Constructor

Initializes a new instance of the CreatePartRequestDetailSetup class.

Overload List

Overload | Description
CreatePartRequestDetailSetup Constructor(String,String,String,String,Int32) | Initializes a new instance of the CreatePartRequestDetailSetup class. This overload takes a set of required parameters for the API.
CreatePartRequestDetailSetup Constructor(String,Int32,Int32) | Initializes a new instance of the CreatePartRequestDetailSetup class. This overload takes a set of required parameters for the API.
CreatePartRequestDetailSetup Constructor(String,String,String,String,String) | Initializes a new instance of the CreatePartRequestDetailSetup class. This overload takes a set of required parameters for the API.
CreatePartRequestDetailSetup Constructor(String,String,Int32) | Initializes a new instance of the CreatePartRequestDetailSetup class. This overload takes a set of required parameters for the API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestDetailSetup Class
CreatePartRequestDetailSetup Members


CreatePartRequestDetailSetup Constructor(String,String,String,String,Int32) | fcSDK Documentation

CreatePartRequestDetailSetup Constructor(String,String,String,String,Int32)

Parent Part Request Header Identifier

The Part Request number

The Part Request domain

The Part Request revision

The number of parts requested

Initializes a new instance of the CreatePartRequestDetailSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestHeaderIDNum_ As String, _
   ByVal _partNumber_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _quantity_ As Integer _
)

[ConstructorIndexAttribute()]
public CreatePartRequestDetailSetup(
   string _partRequestHeaderIDNum_,
   string _partNumber_,
   string _partDomain_,
   string _partRevision_,
   int _quantity_
)

Parameters

partRequestHeaderIDNum

Parent Part Request Header Identifier

partNumber

The Part Request number

partDomain

The Part Request domain

partRevision

The Part Request revision

quantity

The number of parts requested

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestDetailSetup Class
CreatePartRequestDetailSetup Members
Overload List


CreatePartRequestDetailSetup Constructor(String,Int32,Int32) | fcSDK Documentation

CreatePartRequestDetailSetup Constructor(String,Int32,Int32)

Parent Part Request Header Identifier

The number of parts requested

The Objid of the Site Part to which this Part Request will be linked.

Initializes a new instance of the CreatePartRequestDetailSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestHeaderIDNum_ As String, _
   ByVal _quantity_ As Integer, _
   ByVal _sitePartObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public CreatePartRequestDetailSetup(
   string _partRequestHeaderIDNum_,
   int _quantity_,
   int _sitePartObjid_
)

Parameters

partRequestHeaderIDNum

Parent Part Request Header Identifier

quantity

The number of parts requested

sitePartObjid

The Objid of the Site Part to which this Part Request will be linked.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestDetailSetup Class
CreatePartRequestDetailSetup Members
Overload List


CreatePartRequestDetailSetup Constructor(String,String,String,String,String) | fcSDK Documentation

CreatePartRequestDetailSetup Constructor(String,String,String,String,String)

Parent Part Request Header Identifier

The Part Request number

The Part Request domain

The Part Request revision

The serial number of the Site Part specified for this Part Request

Initializes a new instance of the CreatePartRequestDetailSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestHeaderIDNum_ As String, _
   ByVal _partNumber_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _serialNumber_ As String _
)

[ConstructorIndexAttribute()]
public CreatePartRequestDetailSetup(
   string _partRequestHeaderIDNum_,
   string _partNumber_,
   string _partDomain_,
   string _partRevision_,
   string _serialNumber_
)

Parameters

partRequestHeaderIDNum

Parent Part Request Header Identifier

partNumber

The Part Request number

partDomain

The Part Request domain

partRevision

The Part Request revision

serialNumber

The serial number of the Site Part specified for this Part Request

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestDetailSetup Class
CreatePartRequestDetailSetup Members
Overload List


CreatePartRequestDetailSetup Constructor(String,String,Int32) | fcSDK Documentation

CreatePartRequestDetailSetup Constructor(String,String,Int32)

Parent Part Request Header Identifier

The serial number of the Site Part specified for this Part Request

The Objid of the Site Part to which this Part Request will be linked.

Initializes a new instance of the CreatePartRequestDetailSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestHeaderIDNum_ As String, _
   ByVal _serialNumber_ As String, _
   ByVal _sitePartObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public CreatePartRequestDetailSetup(
   string _partRequestHeaderIDNum_,
   string _serialNumber_,
   int _sitePartObjid_
)

Parameters

partRequestHeaderIDNum

Parent Part Request Header Identifier

serialNumber

The serial number of the Site Part specified for this Part Request

sitePartObjid

The Objid of the Site Part to which this Part Request will be linked.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestDetailSetup Class
CreatePartRequestDetailSetup Members
Overload List


AdditionalFields Property (CreatePartRequestDetailSetup) | fcSDK Documentation

AdditionalFields Property (CreatePartRequestDetailSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestDetailSetup Class
CreatePartRequestDetailSetup Members


CarrierName Property (CreatePartRequestDetailSetup) | fcSDK Documentation

CarrierName Property (CreatePartRequestDetailSetup)

Element from the 'Carrier' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CarrierName As String

[PropertyBitValueAttribute()]
public string CarrierName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestDetailSetup Class
CreatePartRequestDetailSetup Members


ContractItemObjid Property | fcSDK Documentation

ContractItemObjid Property

Objid of contract line item with which to link this Part Request -- see remarks for special usage

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContractItemObjid As Integer

[PropertyBitValueAttribute()]
public int ContractItemObjid {get; set;}

Remarks

NOTE: This property should not be set (left as default) unless you need this functionality AND have installed the First Choice ClearCallCenter for ClearLogistics product and schema changes. If you do not have this product and wish to use this functionality, please contact First Choice Software.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestDetailSetup Class
CreatePartRequestDetailSetup Members


CreateDate Property (CreatePartRequestDetailSetup) | fcSDK Documentation

CreateDate Property (CreatePartRequestDetailSetup)

The DateTime the Part Request was created. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestDetailSetup Class
CreatePartRequestDetailSetup Members


DetailType Property (CreatePartRequestDetailSetup) | fcSDK Documentation

DetailType Property (CreatePartRequestDetailSetup)

Element from the 'RMA Type' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property DetailType As String

[PropertyBitValueAttribute()]
public string DetailType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestDetailSetup Class
CreatePartRequestDetailSetup Members


DueDate Property (CreatePartRequestDetailSetup) | fcSDK Documentation

DueDate Property (CreatePartRequestDetailSetup)

The DateTime the Part Request is due. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property DueDate As Date

[PropertyBitValueAttribute()]
public DateTime DueDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestDetailSetup Class
CreatePartRequestDetailSetup Members


GenerateTimeBombs Property (CreatePartRequestDetailSetup) | fcSDK Documentation

GenerateTimeBombs Property (CreatePartRequestDetailSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestDetailSetup Class
CreatePartRequestDetailSetup Members


HasWarranty Property (CreatePartRequestDetailSetup) | fcSDK Documentation

HasWarranty Property (CreatePartRequestDetailSetup)

Specifies whether this Part Request Detail is under warranty (true) or not (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property HasWarranty As Boolean

[PropertyBitValueAttribute()]
public bool HasWarranty {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestDetailSetup Class
CreatePartRequestDetailSetup Members


Notes Property (CreatePartRequestDetailSetup) | fcSDK Documentation

Notes Property (CreatePartRequestDetailSetup)

Notes about the Part Request Detail creation

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestDetailSetup Class
CreatePartRequestDetailSetup Members


PartDomain Property (CreatePartRequestDetailSetup) | fcSDK Documentation

PartDomain Property (CreatePartRequestDetailSetup)

The Part Request domain

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartDomain As String

[PropertyBitValueAttribute()]
public string PartDomain {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestDetailSetup Class
CreatePartRequestDetailSetup Members


PartNumber Property (CreatePartRequestDetailSetup) | fcSDK Documentation

PartNumber Property (CreatePartRequestDetailSetup)

The Part Request number

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartNumber As String

[PropertyBitValueAttribute()]
public string PartNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestDetailSetup Class
CreatePartRequestDetailSetup Members


PartRequestHeaderIDNum Property (CreatePartRequestDetailSetup) | fcSDK Documentation

PartRequestHeaderIDNum Property (CreatePartRequestDetailSetup)

Parent Part Request Header Identifier

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRequestHeaderIDNum As String

[PropertyBitValueAttribute()]
public string PartRequestHeaderIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestDetailSetup Class
CreatePartRequestDetailSetup Members


PartRevision Property (CreatePartRequestDetailSetup) | fcSDK Documentation

PartRevision Property (CreatePartRequestDetailSetup)

The Part Request revision

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRevision As String

[PropertyBitValueAttribute()]
public string PartRevision {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestDetailSetup Class
CreatePartRequestDetailSetup Members


Priority Property (CreatePartRequestDetailSetup) | fcSDK Documentation

Priority Property (CreatePartRequestDetailSetup)

Element from the 'Request Priority' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Priority As String

[PropertyBitValueAttribute()]
public string Priority {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestDetailSetup Class
CreatePartRequestDetailSetup Members


Quantity Property (CreatePartRequestDetailSetup) | fcSDK Documentation

Quantity Property (CreatePartRequestDetailSetup)

The number of parts requested

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Quantity As Integer

[PropertyBitValueAttribute()]
public int Quantity {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestDetailSetup Class
CreatePartRequestDetailSetup Members


Queue Property (CreatePartRequestDetailSetup) | fcSDK Documentation

Queue Property (CreatePartRequestDetailSetup)

The name of the Queue to dispatch this Part Request to when created. If blank, the Part Request is not dispatched automatically.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Queue As String

[PropertyBitValueAttribute()]
public string Queue {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestDetailSetup Class
CreatePartRequestDetailSetup Members


SerialNumber Property (CreatePartRequestDetailSetup) | fcSDK Documentation

SerialNumber Property (CreatePartRequestDetailSetup)

The serial number of the Site Part specified for this Part Request

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SerialNumber As String

[PropertyBitValueAttribute()]
public string SerialNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestDetailSetup Class
CreatePartRequestDetailSetup Members


ShippingMethod Property (CreatePartRequestDetailSetup) | fcSDK Documentation

ShippingMethod Property (CreatePartRequestDetailSetup)

Element from the 'Ship Via' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ShippingMethod As String

[PropertyBitValueAttribute()]
public string ShippingMethod {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestDetailSetup Class
CreatePartRequestDetailSetup Members


SitePartObjid Property (CreatePartRequestDetailSetup) | fcSDK Documentation

SitePartObjid Property (CreatePartRequestDetailSetup)

The Objid of the Site Part to which this Part Request will be linked.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SitePartObjid As Integer

[PropertyBitValueAttribute()]
public int SitePartObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestDetailSetup Class
CreatePartRequestDetailSetup Members


Status Property (CreatePartRequestDetailSetup) | fcSDK Documentation

Status Property (CreatePartRequestDetailSetup)

The new status for the Part Request for the Open condition. If not set, the default status is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Status As String

[PropertyBitValueAttribute()]
public string Status {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestDetailSetup Class
CreatePartRequestDetailSetup Members


UserName Property (CreatePartRequestDetailSetup) | fcSDK Documentation

UserName Property (CreatePartRequestDetailSetup)

The user creating the Part Request Detail. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestDetailSetup Class
CreatePartRequestDetailSetup Members


CreatePartRequestHeaderCaseSetup Class | fcSDK Documentation

CreatePartRequestHeaderCaseSetup Class

Used by the CreatePartRequestHeaderCase method as setup data for invocation.

Syntax

'Declaration

Public Class CreatePartRequestHeaderCaseSetup

public class CreatePartRequestHeaderCaseSetup

Remarks

NOTE: The ContractObjid property should not be set (left as default) unless you need this functionality AND have installed the First Choice ClearCallCenter for ClearLogistics product and schema changes. If you do not have this product and wish to use this functionality, please contact First Choice Software.

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.CreatePartRequestHeaderCaseSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreatePartRequestHeaderCaseSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitCreatePartRequestHeaderCase(CreatePartRequestHeaderCaseSetup)


CreatePartRequestHeaderCaseSetup Class Members | fcSDK Documentation

CreatePartRequestHeaderCaseSetup Class Members

The following tables list the members exposed by CreatePartRequestHeaderCaseSetup.

Public Constructors

 | Name | Description
Public Constructor | CreatePartRequestHeaderCaseSetup Constructor | Initializes a new instance of the CreatePartRequestHeaderCaseSetup class.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | BillSiteIDNum | Identifier of the Site where the Part Request should be billed
Public Property | CaseIDNum | The identifier of the Case with which this Part Request is associated
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | ContractObjid | Objid of contract with which to link this Part Request -- see remarks for special usage
Public Property | CreateDate | The DateTime the Part Request was created. If not set, the current time is used.
Public Property | Notes | Notes about the Part Request Header creation
Public Property | PaymentMethod | Element from the 'Payment Method' application list. If not set the default list value is used.
Public Property | PaymentTerms | Element from the 'Payment Terms' application list. If not set the default list value is used.
Public Property | Priority | Element from the 'Request Priority' application list. If not set the default list value is used.
Public Property | ShipToSiteIDNum | Identifier of the Site where this Part Request is being shipped
Public Property | UserName | The user who is creating the Part Request. If not set, the session user is used.

Reference

CreatePartRequestHeaderCaseSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitCreatePartRequestHeaderCase(CreatePartRequestHeaderCaseSetup)


CreatePartRequestHeaderCaseSetup Constructor | fcSDK Documentation

CreatePartRequestHeaderCaseSetup Constructor

Contact's first name.

Contact's last name.

Contact's phone number.

Identifier of the Site where this Part Request is being shipped

The identifier of the Case with which this Part Request is associated

Initializes a new instance of the CreatePartRequestHeaderCaseSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _contactFirstName_ As String, _
   ByVal _contactLastName_ As String, _
   ByVal _contactPhone_ As String, _
   ByVal _shipToSiteIDNum_ As String, _
   ByVal _caseIDNum_ As String _
)

[ConstructorIndexAttribute()]
public CreatePartRequestHeaderCaseSetup(
   string _contactFirstName_,
   string _contactLastName_,
   string _contactPhone_,
   string _shipToSiteIDNum_,
   string _caseIDNum_
)

Parameters

contactFirstName

Contact's first name.

contactLastName

Contact's last name.

contactPhone

Contact's phone number.

shipToSiteIDNum

Identifier of the Site where this Part Request is being shipped

caseIDNum

The identifier of the Case with which this Part Request is associated

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderCaseSetup Class
CreatePartRequestHeaderCaseSetup Members


AdditionalFields Property (CreatePartRequestHeaderCaseSetup) | fcSDK Documentation

AdditionalFields Property (CreatePartRequestHeaderCaseSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderCaseSetup Class
CreatePartRequestHeaderCaseSetup Members


BillSiteIDNum Property (CreatePartRequestHeaderCaseSetup) | fcSDK Documentation

BillSiteIDNum Property (CreatePartRequestHeaderCaseSetup)

Identifier of the Site where the Part Request should be billed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property BillSiteIDNum As String

[PropertyBitValueAttribute()]
public string BillSiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderCaseSetup Class
CreatePartRequestHeaderCaseSetup Members


CaseIDNum Property (CreatePartRequestHeaderCaseSetup) | fcSDK Documentation

CaseIDNum Property (CreatePartRequestHeaderCaseSetup)

The identifier of the Case with which this Part Request is associated

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderCaseSetup Class
CreatePartRequestHeaderCaseSetup Members


ContactFirstName Property (CreatePartRequestHeaderCaseSetup) | fcSDK Documentation

ContactFirstName Property (CreatePartRequestHeaderCaseSetup)

Contact's first name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactFirstName As String

[PropertyBitValueAttribute()]
public string ContactFirstName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderCaseSetup Class
CreatePartRequestHeaderCaseSetup Members


ContactLastName Property (CreatePartRequestHeaderCaseSetup) | fcSDK Documentation

ContactLastName Property (CreatePartRequestHeaderCaseSetup)

Contact's last name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactLastName As String

[PropertyBitValueAttribute()]
public string ContactLastName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderCaseSetup Class
CreatePartRequestHeaderCaseSetup Members


ContactPhone Property (CreatePartRequestHeaderCaseSetup) | fcSDK Documentation

ContactPhone Property (CreatePartRequestHeaderCaseSetup)

Contact's phone number.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactPhone As String

[PropertyBitValueAttribute()]
public string ContactPhone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderCaseSetup Class
CreatePartRequestHeaderCaseSetup Members


ContractObjid Property (CreatePartRequestHeaderCaseSetup) | fcSDK Documentation

ContractObjid Property (CreatePartRequestHeaderCaseSetup)

Objid of contract with which to link this Part Request -- see remarks for special usage

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContractObjid As Integer

[PropertyBitValueAttribute()]
public int ContractObjid {get; set;}

Remarks

NOTE: This property should not be set (left as default) unless you need this functionality AND have installed the First Choice ClearCallCenter for ClearLogistics product and schema changes. If you do not have this product and wish to use this functionality, please contact First Choice Software.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderCaseSetup Class
CreatePartRequestHeaderCaseSetup Members


CreateDate Property (CreatePartRequestHeaderCaseSetup) | fcSDK Documentation

CreateDate Property (CreatePartRequestHeaderCaseSetup)

The DateTime the Part Request was created. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderCaseSetup Class
CreatePartRequestHeaderCaseSetup Members


Notes Property (CreatePartRequestHeaderCaseSetup) | fcSDK Documentation

Notes Property (CreatePartRequestHeaderCaseSetup)

Notes about the Part Request Header creation

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderCaseSetup Class
CreatePartRequestHeaderCaseSetup Members


PaymentMethod Property (CreatePartRequestHeaderCaseSetup) | fcSDK Documentation

PaymentMethod Property (CreatePartRequestHeaderCaseSetup)

Element from the 'Payment Method' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PaymentMethod As String

[PropertyBitValueAttribute()]
public string PaymentMethod {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderCaseSetup Class
CreatePartRequestHeaderCaseSetup Members


PaymentTerms Property (CreatePartRequestHeaderCaseSetup) | fcSDK Documentation

PaymentTerms Property (CreatePartRequestHeaderCaseSetup)

Element from the 'Payment Terms' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PaymentTerms As String

[PropertyBitValueAttribute()]
public string PaymentTerms {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderCaseSetup Class
CreatePartRequestHeaderCaseSetup Members


Priority Property (CreatePartRequestHeaderCaseSetup) | fcSDK Documentation

Priority Property (CreatePartRequestHeaderCaseSetup)

Element from the 'Request Priority' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Priority As String

[PropertyBitValueAttribute()]
public string Priority {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderCaseSetup Class
CreatePartRequestHeaderCaseSetup Members


ShipToSiteIDNum Property (CreatePartRequestHeaderCaseSetup) | fcSDK Documentation

ShipToSiteIDNum Property (CreatePartRequestHeaderCaseSetup)

Identifier of the Site where this Part Request is being shipped

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ShipToSiteIDNum As String

[PropertyBitValueAttribute()]
public string ShipToSiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderCaseSetup Class
CreatePartRequestHeaderCaseSetup Members


UserName Property (CreatePartRequestHeaderCaseSetup) | fcSDK Documentation

UserName Property (CreatePartRequestHeaderCaseSetup)

The user who is creating the Part Request. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderCaseSetup Class
CreatePartRequestHeaderCaseSetup Members


CreatePartRequestHeaderSetup Class | fcSDK Documentation

CreatePartRequestHeaderSetup Class

Used by the CreatePartRequestHeader method as setup data for invocation.

Syntax

'Declaration

Public Class CreatePartRequestHeaderSetup

public class CreatePartRequestHeaderSetup

Remarks

NOTE: The ContractObjId property should not be set (left as default) unless you need this functionality AND have installed the First Choice ClearCallCenter for ClearLogistics product and schema changes. If you do not have this product and wish to use this functionality, please contact First Choice Software.

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.CreatePartRequestHeaderSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreatePartRequestHeaderSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitCreatePartRequestHeader(CreatePartRequestHeaderSetup)


CreatePartRequestHeaderSetup Class Members | fcSDK Documentation

CreatePartRequestHeaderSetup Class Members

The following tables list the members exposed by CreatePartRequestHeaderSetup.

Public Constructors

 | Name | Description
Public Constructor | CreatePartRequestHeaderSetup Constructor | Initializes a new instance of the CreatePartRequestHeaderSetup class.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | BillSiteIDNum | Identifier of the Site where this Part Request should be billed
Public Property | CaseIDNum | Identifier of the Case with which this Part Request is associated
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | ContractObjid | Objid of contract with which to link this Part Request -- see remarks for special usage
Public Property | CreateDate | The DateTime the Part Request was created. If not set, the current time is used.
Public Property | Notes | Notes about the Part Request Header creation
Public Property | PaymentMethod | Element from the 'Payment Method' application list. If not set the default list value is used.
Public Property | PaymentTerms | Element from the 'Payment Terms' application list. If not set the default list value is used.
Public Property | Priority | Element from the 'Request Priority' application list. If not set the default list value is used.
Public Property | ShipToSiteIDNum | Identifier of the Site where this Part Request should be shipped
Public Property | UserName | The user who creates the Part Request. If not set, the session user is used.

Reference

CreatePartRequestHeaderSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitCreatePartRequestHeader(CreatePartRequestHeaderSetup)


CreatePartRequestHeaderSetup Constructor | fcSDK Documentation

CreatePartRequestHeaderSetup Constructor

Contact's first name.

Contact's last name.

Contact's phone number.

Identifier of the Site where this Part Request should be shipped

Initializes a new instance of the CreatePartRequestHeaderSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _contactFirstName_ As String, _
   ByVal _contactLastName_ As String, _
   ByVal _contactPhone_ As String, _
   ByVal _shipToSiteIDNum_ As String _
)

[ConstructorIndexAttribute()]
public CreatePartRequestHeaderSetup(
   string _contactFirstName_,
   string _contactLastName_,
   string _contactPhone_,
   string _shipToSiteIDNum_
)

Parameters

contactFirstName

Contact's first name.

contactLastName

Contact's last name.

contactPhone

Contact's phone number.

shipToSiteIDNum

Identifier of the Site where this Part Request should be shipped

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderSetup Class
CreatePartRequestHeaderSetup Members


AdditionalFields Property (CreatePartRequestHeaderSetup) | fcSDK Documentation

AdditionalFields Property (CreatePartRequestHeaderSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderSetup Class
CreatePartRequestHeaderSetup Members


BillSiteIDNum Property (CreatePartRequestHeaderSetup) | fcSDK Documentation

BillSiteIDNum Property (CreatePartRequestHeaderSetup)

Identifier of the Site where this Part Request should be billed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property BillSiteIDNum As String

[PropertyBitValueAttribute()]
public string BillSiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderSetup Class
CreatePartRequestHeaderSetup Members


CaseIDNum Property (CreatePartRequestHeaderSetup) | fcSDK Documentation

CaseIDNum Property (CreatePartRequestHeaderSetup)

Identifier of the Case with which this Part Request is associated

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderSetup Class
CreatePartRequestHeaderSetup Members


ContactFirstName Property (CreatePartRequestHeaderSetup) | fcSDK Documentation

ContactFirstName Property (CreatePartRequestHeaderSetup)

Contact's first name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactFirstName As String

[PropertyBitValueAttribute()]
public string ContactFirstName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderSetup Class
CreatePartRequestHeaderSetup Members


ContactLastName Property (CreatePartRequestHeaderSetup) | fcSDK Documentation

ContactLastName Property (CreatePartRequestHeaderSetup)

Contact's last name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactLastName As String

[PropertyBitValueAttribute()]
public string ContactLastName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderSetup Class
CreatePartRequestHeaderSetup Members


ContactPhone Property (CreatePartRequestHeaderSetup) | fcSDK Documentation

ContactPhone Property (CreatePartRequestHeaderSetup)

Contact's phone number.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactPhone As String

[PropertyBitValueAttribute()]
public string ContactPhone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderSetup Class
CreatePartRequestHeaderSetup Members


ContractObjid Property (CreatePartRequestHeaderSetup) | fcSDK Documentation

ContractObjid Property (CreatePartRequestHeaderSetup)

Objid of contract with which to link this Part Request -- see remarks for special usage

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContractObjid As Integer

[PropertyBitValueAttribute()]
public int ContractObjid {get; set;}

Remarks

NOTE: This property should not be set (left as default) unless you need this functionality AND have installed the First Choice ClearCallCenter for ClearLogistics product and schema changes. If you do not have this product and wish to use this functionality, please contact First Choice Software.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderSetup Class
CreatePartRequestHeaderSetup Members


CreateDate Property (CreatePartRequestHeaderSetup) | fcSDK Documentation

CreateDate Property (CreatePartRequestHeaderSetup)

The DateTime the Part Request was created. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderSetup Class
CreatePartRequestHeaderSetup Members


Notes Property (CreatePartRequestHeaderSetup) | fcSDK Documentation

Notes Property (CreatePartRequestHeaderSetup)

Notes about the Part Request Header creation

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderSetup Class
CreatePartRequestHeaderSetup Members


PaymentMethod Property (CreatePartRequestHeaderSetup) | fcSDK Documentation

PaymentMethod Property (CreatePartRequestHeaderSetup)

Element from the 'Payment Method' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PaymentMethod As String

[PropertyBitValueAttribute()]
public string PaymentMethod {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderSetup Class
CreatePartRequestHeaderSetup Members


PaymentTerms Property (CreatePartRequestHeaderSetup) | fcSDK Documentation

PaymentTerms Property (CreatePartRequestHeaderSetup)

Element from the 'Payment Terms' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PaymentTerms As String

[PropertyBitValueAttribute()]
public string PaymentTerms {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderSetup Class
CreatePartRequestHeaderSetup Members


Priority Property (CreatePartRequestHeaderSetup) | fcSDK Documentation

Priority Property (CreatePartRequestHeaderSetup)

Element from the 'Request Priority' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Priority As String

[PropertyBitValueAttribute()]
public string Priority {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderSetup Class
CreatePartRequestHeaderSetup Members


ShipToSiteIDNum Property (CreatePartRequestHeaderSetup) | fcSDK Documentation

ShipToSiteIDNum Property (CreatePartRequestHeaderSetup)

Identifier of the Site where this Part Request should be shipped

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ShipToSiteIDNum As String

[PropertyBitValueAttribute()]
public string ShipToSiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderSetup Class
CreatePartRequestHeaderSetup Members


UserName Property (CreatePartRequestHeaderSetup) | fcSDK Documentation

UserName Property (CreatePartRequestHeaderSetup)

The user who creates the Part Request. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderSetup Class
CreatePartRequestHeaderSetup Members


CreatePartRequestHeaderSubcaseSetup Class | fcSDK Documentation

CreatePartRequestHeaderSubcaseSetup Class

Used by the CreatePartRequestHeaderSubcase method as setup data for invocation.

Syntax

'Declaration

Public Class CreatePartRequestHeaderSubcaseSetup

public class CreatePartRequestHeaderSubcaseSetup

Remarks

NOTE: The ContractObjid property should not be set (left as default) unless you need this functionality AND have installed the First Choice ClearCallCenter for ClearLogistics product and schema changes. If you do not have this product and wish to use this functionality, please contact First Choice Software.

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.CreatePartRequestHeaderSubcaseSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreatePartRequestHeaderSubcaseSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitCreatePartRequestHeaderSubcase(CreatePartRequestHeaderSubcaseSetup)


CreatePartRequestHeaderSubcaseSetup Class Members | fcSDK Documentation

CreatePartRequestHeaderSubcaseSetup Class Members

The following tables list the members exposed by CreatePartRequestHeaderSubcaseSetup.

Public Constructors

 | Name | Description
Public Constructor | CreatePartRequestHeaderSubcaseSetup Constructor | Initializes a new instance of the CreatePartRequestHeaderSubcaseSetup class.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | BillSiteIDNum | Identifier of the Site where this Part Request should be billed
Public Property | CaseIDNum | Identifier of the Subcase with which this Part Request is associated
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | ContractObjid | Objid of contract with which to link this Part Request -- see remarks for special usage
Public Property | CreateDate | The DateTime the Part Request was created. If not set, the current time is used.
Public Property | Notes | Notes about the Part Request Header creation
Public Property | PaymentMethod | Element from the 'Payment Method' application list. If not set the default list value is used.
Public Property | PaymentTerms | Element from the 'Payment Terms' application list. If not set the default list value is used.
Public Property | Priority | Element from the 'Request Priority' application list. If not set the default list value is used.
Public Property | ShipToSiteIDNum | Identifier of the site where this Part Request should be shipped
Public Property | UserName | The user who creates the Part Request. If not set, the session user is used.

Reference

CreatePartRequestHeaderSubcaseSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitCreatePartRequestHeaderSubcase(CreatePartRequestHeaderSubcaseSetup)


CreatePartRequestHeaderSubcaseSetup Constructor | fcSDK Documentation

CreatePartRequestHeaderSubcaseSetup Constructor

Contact's first name.

Contact's last name.

Contact's phone number.

Identifier of the site where this Part Request should be shipped

Identifier of the Subcase with which this Part Request is associated

Initializes a new instance of the CreatePartRequestHeaderSubcaseSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _contactFirstName_ As String, _
   ByVal _contactLastName_ As String, _
   ByVal _contactPhone_ As String, _
   ByVal _shipToSiteIDNum_ As String, _
   ByVal _caseIDNum_ As String _
)

[ConstructorIndexAttribute()]
public CreatePartRequestHeaderSubcaseSetup(
   string _contactFirstName_,
   string _contactLastName_,
   string _contactPhone_,
   string _shipToSiteIDNum_,
   string _caseIDNum_
)

Parameters

contactFirstName

Contact's first name.

contactLastName

Contact's last name.

contactPhone

Contact's phone number.

shipToSiteIDNum

Identifier of the site where this Part Request should be shipped

caseIDNum

Identifier of the Subcase with which this Part Request is associated

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderSubcaseSetup Class
CreatePartRequestHeaderSubcaseSetup Members


AdditionalFields Property (CreatePartRequestHeaderSubcaseSetup) | fcSDK Documentation

AdditionalFields Property (CreatePartRequestHeaderSubcaseSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderSubcaseSetup Class
CreatePartRequestHeaderSubcaseSetup Members


BillSiteIDNum Property (CreatePartRequestHeaderSubcaseSetup) | fcSDK Documentation

BillSiteIDNum Property (CreatePartRequestHeaderSubcaseSetup)

Identifier of the Site where this Part Request should be billed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property BillSiteIDNum As String

[PropertyBitValueAttribute()]
public string BillSiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderSubcaseSetup Class
CreatePartRequestHeaderSubcaseSetup Members


CaseIDNum Property (CreatePartRequestHeaderSubcaseSetup) | fcSDK Documentation

CaseIDNum Property (CreatePartRequestHeaderSubcaseSetup)

Identifier of the Subcase with which this Part Request is associated

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderSubcaseSetup Class
CreatePartRequestHeaderSubcaseSetup Members


ContactFirstName Property (CreatePartRequestHeaderSubcaseSetup) | fcSDK Documentation

ContactFirstName Property (CreatePartRequestHeaderSubcaseSetup)

Contact's first name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactFirstName As String

[PropertyBitValueAttribute()]
public string ContactFirstName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderSubcaseSetup Class
CreatePartRequestHeaderSubcaseSetup Members


ContactLastName Property (CreatePartRequestHeaderSubcaseSetup) | fcSDK Documentation

ContactLastName Property (CreatePartRequestHeaderSubcaseSetup)

Contact's last name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactLastName As String

[PropertyBitValueAttribute()]
public string ContactLastName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderSubcaseSetup Class
CreatePartRequestHeaderSubcaseSetup Members


ContactPhone Property (CreatePartRequestHeaderSubcaseSetup) | fcSDK Documentation

ContactPhone Property (CreatePartRequestHeaderSubcaseSetup)

Contact's phone number.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactPhone As String

[PropertyBitValueAttribute()]
public string ContactPhone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderSubcaseSetup Class
CreatePartRequestHeaderSubcaseSetup Members


ContractObjid Property (CreatePartRequestHeaderSubcaseSetup) | fcSDK Documentation

ContractObjid Property (CreatePartRequestHeaderSubcaseSetup)

Objid of contract with which to link this Part Request -- see remarks for special usage

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContractObjid As Integer

[PropertyBitValueAttribute()]
public int ContractObjid {get; set;}

Remarks

NOTE: This property should not be set (left as default) unless you need this functionality AND have installed the First Choice ClearCallCenter for ClearLogistics product and schema changes. If you do not have this product and wish to use this functionality, please contact First Choice Software.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderSubcaseSetup Class
CreatePartRequestHeaderSubcaseSetup Members


CreateDate Property (CreatePartRequestHeaderSubcaseSetup) | fcSDK Documentation

CreateDate Property (CreatePartRequestHeaderSubcaseSetup)

The DateTime the Part Request was created. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderSubcaseSetup Class
CreatePartRequestHeaderSubcaseSetup Members


Notes Property (CreatePartRequestHeaderSubcaseSetup) | fcSDK Documentation

Notes Property (CreatePartRequestHeaderSubcaseSetup)

Notes about the Part Request Header creation

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderSubcaseSetup Class
CreatePartRequestHeaderSubcaseSetup Members


PaymentMethod Property (CreatePartRequestHeaderSubcaseSetup) | fcSDK Documentation

PaymentMethod Property (CreatePartRequestHeaderSubcaseSetup)

Element from the 'Payment Method' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PaymentMethod As String

[PropertyBitValueAttribute()]
public string PaymentMethod {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderSubcaseSetup Class
CreatePartRequestHeaderSubcaseSetup Members


PaymentTerms Property (CreatePartRequestHeaderSubcaseSetup) | fcSDK Documentation

PaymentTerms Property (CreatePartRequestHeaderSubcaseSetup)

Element from the 'Payment Terms' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PaymentTerms As String

[PropertyBitValueAttribute()]
public string PaymentTerms {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderSubcaseSetup Class
CreatePartRequestHeaderSubcaseSetup Members


Priority Property (CreatePartRequestHeaderSubcaseSetup) | fcSDK Documentation

Priority Property (CreatePartRequestHeaderSubcaseSetup)

Element from the 'Request Priority' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Priority As String

[PropertyBitValueAttribute()]
public string Priority {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderSubcaseSetup Class
CreatePartRequestHeaderSubcaseSetup Members


ShipToSiteIDNum Property (CreatePartRequestHeaderSubcaseSetup) | fcSDK Documentation

ShipToSiteIDNum Property (CreatePartRequestHeaderSubcaseSetup)

Identifier of the site where this Part Request should be shipped

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ShipToSiteIDNum As String

[PropertyBitValueAttribute()]
public string ShipToSiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderSubcaseSetup Class
CreatePartRequestHeaderSubcaseSetup Members


UserName Property (CreatePartRequestHeaderSubcaseSetup) | fcSDK Documentation

UserName Property (CreatePartRequestHeaderSubcaseSetup)

The user who creates the Part Request. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestHeaderSubcaseSetup Class
CreatePartRequestHeaderSubcaseSetup Members


CreateSubContainerSetup Class | fcSDK Documentation

CreateSubContainerSetup Class

Syntax

'Declaration

Public Class CreateSubContainerSetup

public class CreateSubContainerSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Logistics.CreateSubContainerSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateSubContainerSetup Members
FChoice.Toolkits.Clarify.Logistics Namespace


CreateSubContainerSetup Class Members | fcSDK Documentation

CreateSubContainerSetup Class Members

The following tables list the members exposed by CreateSubContainerSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateSubContainerSetup Constructor |

Public Properties

 | Name | Description
Public Property | ContainerName |
Public Property | ParentContainerName |

Reference

CreateSubContainerSetup Class
FChoice.Toolkits.Clarify.Logistics Namespace


CreateSubContainerSetup Constructor | fcSDK Documentation

CreateSubContainerSetup Constructor

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _containerName_ As String, _
   ByVal _parentContainerName_ As String _
)

[ConstructorIndexAttribute()]
public CreateSubContainerSetup(
   string _containerName_,
   string _parentContainerName_
)

Parameters

containerName

parentContainerName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSubContainerSetup Class
CreateSubContainerSetup Members


ContainerName Property (CreateSubContainerSetup) | fcSDK Documentation

ContainerName Property (CreateSubContainerSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContainerName As String

[PropertyBitValueAttribute()]
public string ContainerName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSubContainerSetup Class
CreateSubContainerSetup Members


ParentContainerName Property | fcSDK Documentation

ParentContainerName Property

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ParentContainerName As String

[PropertyBitValueAttribute()]
public string ParentContainerName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSubContainerSetup Class
CreateSubContainerSetup Members


DeleteAlternatePartSetup Class | fcSDK Documentation

DeleteAlternatePartSetup Class

Used by the DeleteAlternatePart method as setup data for invocation.

Syntax

'Declaration

Public Class DeleteAlternatePartSetup

public class DeleteAlternatePartSetup

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.DeleteAlternatePartSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

DeleteAlternatePartSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitDeleteAlternatePart(DeleteAlternatePartSetup)


DeleteAlternatePartSetup Class Members | fcSDK Documentation

DeleteAlternatePartSetup Class Members

The following tables list the members exposed by DeleteAlternatePartSetup.

Public Constructors

 | Name | Description
Public Constructor | DeleteAlternatePartSetup Constructor | Initializes a new instance of the DeleteAlternatePartSetup class.

Public Properties

 | Name | Description
Public Property | AlternatePartDomain | The Alternate Part domain
Public Property | AlternatePartNumber | The Alternate Part number
Public Property | AlternatePartRevision | The Alternate Part revision
Public Property | PartDomain | The Part domain
Public Property | PartNumber | The Part number
Public Property | PartRevision | The Part revision

Reference

DeleteAlternatePartSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitDeleteAlternatePart(DeleteAlternatePartSetup)


DeleteAlternatePartSetup Constructor | fcSDK Documentation

DeleteAlternatePartSetup Constructor

The Part number

The Part revision

The Part domain

The Alternate Part number

The Alternate Part revision

The Alternate Part domain

Initializes a new instance of the DeleteAlternatePartSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partNumber_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _alternatePartNumber_ As String, _
   ByVal _alternatePartRevision_ As String, _
   ByVal _alternatePartDomain_ As String _
)

[ConstructorIndexAttribute()]
public DeleteAlternatePartSetup(
   string _partNumber_,
   string _partRevision_,
   string _partDomain_,
   string _alternatePartNumber_,
   string _alternatePartRevision_,
   string _alternatePartDomain_
)

Parameters

partNumber

The Part number

partRevision

The Part revision

partDomain

The Part domain

alternatePartNumber

The Alternate Part number

alternatePartRevision

The Alternate Part revision

alternatePartDomain

The Alternate Part domain

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteAlternatePartSetup Class
DeleteAlternatePartSetup Members


AlternatePartDomain Property (DeleteAlternatePartSetup) | fcSDK Documentation

AlternatePartDomain Property (DeleteAlternatePartSetup)

The Alternate Part domain

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AlternatePartDomain As String

[PropertyBitValueAttribute()]
public string AlternatePartDomain {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteAlternatePartSetup Class
DeleteAlternatePartSetup Members


AlternatePartNumber Property (DeleteAlternatePartSetup) | fcSDK Documentation

AlternatePartNumber Property (DeleteAlternatePartSetup)

The Alternate Part number

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AlternatePartNumber As String

[PropertyBitValueAttribute()]
public string AlternatePartNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteAlternatePartSetup Class
DeleteAlternatePartSetup Members


AlternatePartRevision Property (DeleteAlternatePartSetup) | fcSDK Documentation

AlternatePartRevision Property (DeleteAlternatePartSetup)

The Alternate Part revision

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AlternatePartRevision As String

[PropertyBitValueAttribute()]
public string AlternatePartRevision {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteAlternatePartSetup Class
DeleteAlternatePartSetup Members


PartDomain Property (DeleteAlternatePartSetup) | fcSDK Documentation

PartDomain Property (DeleteAlternatePartSetup)

The Part domain

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartDomain As String

[PropertyBitValueAttribute()]
public string PartDomain {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteAlternatePartSetup Class
DeleteAlternatePartSetup Members


PartNumber Property (DeleteAlternatePartSetup) | fcSDK Documentation

PartNumber Property (DeleteAlternatePartSetup)

The Part number

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartNumber As String

[PropertyBitValueAttribute()]
public string PartNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteAlternatePartSetup Class
DeleteAlternatePartSetup Members


PartRevision Property (DeleteAlternatePartSetup) | fcSDK Documentation

PartRevision Property (DeleteAlternatePartSetup)

The Part revision

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRevision As String

[PropertyBitValueAttribute()]
public string PartRevision {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteAlternatePartSetup Class
DeleteAlternatePartSetup Members


DeleteLocationServicingSiteSetup Class | fcSDK Documentation

DeleteLocationServicingSiteSetup Class

Used by the DeleteLocationServicingSite method as setup data for invocation.

Syntax

'Declaration

Public Class DeleteLocationServicingSiteSetup

public class DeleteLocationServicingSiteSetup

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.DeleteLocationServicingSiteSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

DeleteLocationServicingSiteSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitDeleteLocationServicingSite(DeleteLocationServicingSiteSetup)


DeleteLocationServicingSiteSetup Class Members | fcSDK Documentation

DeleteLocationServicingSiteSetup Class Members

The following tables list the members exposed by DeleteLocationServicingSiteSetup.

Public Constructors

 | Name | Description
Public Constructor | DeleteLocationServicingSiteSetup Constructor | Initializes a new instance of the DeleteLocationServicingSiteSetup class.

Public Properties

 | Name | Description
Public Property | LocationName | The inventory location being removed
Public Property | SiteIDNum | Identifier of the Site that the inventory location was servicing

Reference

DeleteLocationServicingSiteSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitDeleteLocationServicingSite(DeleteLocationServicingSiteSetup)


DeleteLocationServicingSiteSetup Constructor | fcSDK Documentation

DeleteLocationServicingSiteSetup Constructor

Identifier of the Site that the inventory location was servicing

The inventory location being removed

Initializes a new instance of the DeleteLocationServicingSiteSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _siteIDNum_ As String, _
   ByVal _locationName_ As String _
)

[ConstructorIndexAttribute()]
public DeleteLocationServicingSiteSetup(
   string _siteIDNum_,
   string _locationName_
)

Parameters

siteIDNum

Identifier of the Site that the inventory location was servicing

locationName

The inventory location being removed

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteLocationServicingSiteSetup Class
DeleteLocationServicingSiteSetup Members


LocationName Property (DeleteLocationServicingSiteSetup) | fcSDK Documentation

LocationName Property (DeleteLocationServicingSiteSetup)

The inventory location being removed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LocationName As String

[PropertyBitValueAttribute()]
public string LocationName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteLocationServicingSiteSetup Class
DeleteLocationServicingSiteSetup Members


SiteIDNum Property (DeleteLocationServicingSiteSetup) | fcSDK Documentation

SiteIDNum Property (DeleteLocationServicingSiteSetup)

Identifier of the Site that the inventory location was servicing

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteIDNum As String

[PropertyBitValueAttribute()]
public string SiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DeleteLocationServicingSiteSetup Class
DeleteLocationServicingSiteSetup Members


DispatchPartRequestSetup Class | fcSDK Documentation

DispatchPartRequestSetup Class

Used by the DispatchPartRequest method as setup data for invocation.

Syntax

'Declaration

Public Class DispatchPartRequestSetup

public class DispatchPartRequestSetup

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.DispatchPartRequestSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

DispatchPartRequestSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitDispatchPartRequest(DispatchPartRequestSetup)


DispatchPartRequestSetup Class Members | fcSDK Documentation

DispatchPartRequestSetup Class Members

The following tables list the members exposed by DispatchPartRequestSetup.

Public Constructors

 | Name | Description
Public Constructor | DispatchPartRequestSetup Constructor | Initializes a new instance of the DispatchPartRequestSetup class.

Public Properties

 | Name | Description
Public Property | DispatchDate | DateTime the PartRequest was dispatched. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | PartRequestDetailIDNum | Part Request Detail Identifier
Public Property | Queue | The queue into which the PartRequest is to be dispatched.
Public Property | UserName | The user who has dispatched the PartRequest. If not set, the Toolkit session user is used.

Reference

DispatchPartRequestSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitDispatchPartRequest(DispatchPartRequestSetup)


DispatchPartRequestSetup Constructor | fcSDK Documentation

DispatchPartRequestSetup Constructor

Part Request Detail Identifier

The queue into which the PartRequest is to be dispatched.

Initializes a new instance of the DispatchPartRequestSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _queue_ As String _
)

[ConstructorIndexAttribute()]
public DispatchPartRequestSetup(
   string _partRequestDetailIDNum_,
   string _queue_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

queue

The queue into which the PartRequest is to be dispatched.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchPartRequestSetup Class
DispatchPartRequestSetup Members


DispatchDate Property (DispatchPartRequestSetup) | fcSDK Documentation

DispatchDate Property (DispatchPartRequestSetup)

DateTime the PartRequest was dispatched. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property DispatchDate As Date

[PropertyBitValueAttribute()]
public DateTime DispatchDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchPartRequestSetup Class
DispatchPartRequestSetup Members


GenerateTimeBombs Property (DispatchPartRequestSetup) | fcSDK Documentation

GenerateTimeBombs Property (DispatchPartRequestSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchPartRequestSetup Class
DispatchPartRequestSetup Members


PartRequestDetailIDNum Property (DispatchPartRequestSetup) | fcSDK Documentation

PartRequestDetailIDNum Property (DispatchPartRequestSetup)

Part Request Detail Identifier

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRequestDetailIDNum As String

[PropertyBitValueAttribute()]
public string PartRequestDetailIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchPartRequestSetup Class
DispatchPartRequestSetup Members


Queue Property (DispatchPartRequestSetup) | fcSDK Documentation

Queue Property (DispatchPartRequestSetup)

The queue into which the PartRequest is to be dispatched.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Queue As String

[PropertyBitValueAttribute()]
public string Queue {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchPartRequestSetup Class
DispatchPartRequestSetup Members


UserName Property (DispatchPartRequestSetup) | fcSDK Documentation

UserName Property (DispatchPartRequestSetup)

The user who has dispatched the PartRequest. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchPartRequestSetup Class
DispatchPartRequestSetup Members


ForwardPartRequestSetup Class | fcSDK Documentation

ForwardPartRequestSetup Class

Used by the ForwardPartRequest method as setup data for invocation.

Syntax

'Declaration

Public Class ForwardPartRequestSetup

public class ForwardPartRequestSetup

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.ForwardPartRequestSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ForwardPartRequestSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitForwardPartRequest(ForwardPartRequestSetup)


ForwardPartRequestSetup Class Members | fcSDK Documentation

ForwardPartRequestSetup Class Members

The following tables list the members exposed by ForwardPartRequestSetup.

Public Constructors

 | Name | Description
Public Constructor | ForwardPartRequestSetup Constructor | Initializes a new instance of the ForwardPartRequestSetup class.

Public Properties

 | Name | Description
Public Property | ForwardDate | DateTime the PartRequest was forwarded. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewQueue | The new queue into which the PartRequest is to be forwarded.
Public Property | Notes | The reason the PartRequest was rejected from the queue into which it was dispatched.
Public Property | PartRequestDetailIDNum | Part Request Detail Identifier
Public Property | UserName | The user who has forwarded the PartRequest. If not set, the Toolkit session user is used.

Reference

ForwardPartRequestSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitForwardPartRequest(ForwardPartRequestSetup)


ForwardPartRequestSetup Constructor | fcSDK Documentation

ForwardPartRequestSetup Constructor

Part Request Detail Identifier

The new queue into which the PartRequest is to be forwarded.

Initializes a new instance of the ForwardPartRequestSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _newQueue_ As String _
)

[ConstructorIndexAttribute()]
public ForwardPartRequestSetup(
   string _partRequestDetailIDNum_,
   string _newQueue_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

newQueue

The new queue into which the PartRequest is to be forwarded.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardPartRequestSetup Class
ForwardPartRequestSetup Members


ForwardDate Property (ForwardPartRequestSetup) | fcSDK Documentation

ForwardDate Property (ForwardPartRequestSetup)

DateTime the PartRequest was forwarded. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ForwardDate As Date

[PropertyBitValueAttribute()]
public DateTime ForwardDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardPartRequestSetup Class
ForwardPartRequestSetup Members


GenerateTimeBombs Property (ForwardPartRequestSetup) | fcSDK Documentation

GenerateTimeBombs Property (ForwardPartRequestSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardPartRequestSetup Class
ForwardPartRequestSetup Members


NewQueue Property (ForwardPartRequestSetup) | fcSDK Documentation

NewQueue Property (ForwardPartRequestSetup)

The new queue into which the PartRequest is to be forwarded.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewQueue As String

[PropertyBitValueAttribute()]
public string NewQueue {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardPartRequestSetup Class
ForwardPartRequestSetup Members


Notes Property (ForwardPartRequestSetup) | fcSDK Documentation

Notes Property (ForwardPartRequestSetup)

The reason the PartRequest was rejected from the queue into which it was dispatched.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardPartRequestSetup Class
ForwardPartRequestSetup Members


PartRequestDetailIDNum Property (ForwardPartRequestSetup) | fcSDK Documentation

PartRequestDetailIDNum Property (ForwardPartRequestSetup)

Part Request Detail Identifier

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRequestDetailIDNum As String

[PropertyBitValueAttribute()]
public string PartRequestDetailIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardPartRequestSetup Class
ForwardPartRequestSetup Members


UserName Property (ForwardPartRequestSetup) | fcSDK Documentation

UserName Property (ForwardPartRequestSetup)

The user who has forwarded the PartRequest. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardPartRequestSetup Class
ForwardPartRequestSetup Members


FulfillPartRequestSetup Class | fcSDK Documentation

FulfillPartRequestSetup Class

Used by the FulfillPartRequest method as setup data for invocation.

Syntax

'Declaration

Public Class FulfillPartRequestSetup

public class FulfillPartRequestSetup

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.FulfillPartRequestSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

FulfillPartRequestSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitFulfillPartRequest(FulfillPartRequestSetup)


FulfillPartRequestSetup Class Members | fcSDK Documentation

FulfillPartRequestSetup Class Members

The following tables list the members exposed by FulfillPartRequestSetup.

Public Constructors

 | Name | Description
Public Constructor | FulfillPartRequestSetup Constructor | Overloaded.

Public Properties

 | Name | Description
Public Property | FromGood | Specifies whether the fulfilled inventory is from good stock (true) or bad stock (false)
Public Property | FromLocation | The inventory location and bin containing the parts used to fulfill this Part Request
Public Property | FulfillDate | The DateTime the Part Request is fulfilled. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewStatus | The new status for the Part Request for the Fulfilled condition. If not set, the default status is used.
Public Property | PartRequestDetailIDNum | Part Request Detail Identifier
Public Property | Quantity | The number of parts being fulfilled for this Part Request
Public Property | SerialNumber | The serial number of the part used to fulfill this Part Request
Public Property | ToGood | Specifies whether the fulfilled inventory is going to good stock (true) or bad stock (false)
Public Property | ToLocation | The destination inventory location and bin for the parts used to fulfill this Part Request
Public Property | UserName | The user who is fulfilling the Part Request. If not set, the session user is used.
Public Property | UseTransitions | Specifies whether or not logistics transitions will be checked and the condition/status of the part request detail will be changed during the fulfill operation

Reference

FulfillPartRequestSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitFulfillPartRequest(FulfillPartRequestSetup)


FulfillPartRequestSetup Constructor | fcSDK Documentation

FulfillPartRequestSetup Constructor

Initializes a new instance of the FulfillPartRequestSetup class.

Overload List

Overload | Description
FulfillPartRequestSetup Constructor(String,Int32) | Initializes a new instance of the FulfillPartRequestSetup class. This overload takes a set of required parameters for the API.
FulfillPartRequestSetup Constructor(String,String) | Initializes a new instance of the FulfillPartRequestSetup class. This overload takes a set of required parameters for the API.
FulfillPartRequestSetup Constructor(String,Boolean,Int32) | Initializes a new instance of the FulfillPartRequestSetup class. This overload takes a set of required parameters for the API.
FulfillPartRequestSetup Constructor(String,Boolean,String) | Initializes a new instance of the FulfillPartRequestSetup class. This overload takes a set of required parameters for the API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FulfillPartRequestSetup Class
FulfillPartRequestSetup Members


FulfillPartRequestSetup Constructor(String,Int32) | fcSDK Documentation

FulfillPartRequestSetup Constructor(String,Int32)

```csharp
Part Request Detail Identifier

The number of parts being fulfilled for this Part Request

Initializes a new instance of the FulfillPartRequestSetup class. This overload takes a set of required parameters for the API.

#### Syntax

```vbnet
'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _quantity_ As Integer _
)

[ConstructorIndexAttribute()]
public FulfillPartRequestSetup(
   string _partRequestDetailIDNum_,
   int _quantity_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

quantity

The number of parts being fulfilled for this Part Request

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FulfillPartRequestSetup Class
FulfillPartRequestSetup Members
Overload List


FulfillPartRequestSetup Constructor(String,String) | fcSDK Documentation

FulfillPartRequestSetup Constructor(String,String)

Part Request Detail Identifier

The serial number of the part used to fulfill this Part Request

Initializes a new instance of the FulfillPartRequestSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _serialNumber_ As String _
)

[ConstructorIndexAttribute()]
public FulfillPartRequestSetup(
   string _partRequestDetailIDNum_,
   string _serialNumber_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

serialNumber

The serial number of the part used to fulfill this Part Request

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FulfillPartRequestSetup Class
FulfillPartRequestSetup Members
Overload List


FulfillPartRequestSetup Constructor(String,Boolean,Int32) | fcSDK Documentation

FulfillPartRequestSetup Constructor(String,Boolean,Int32)

```csharp
Part Request Detail Identifier

Specifies whether or not logistics transitions will be checked and the condition/status of the part request detail will be changed during the fulfill operation

The number of parts being fulfilled for this Part Request

Initializes a new instance of the FulfillPartRequestSetup class. This overload takes a set of required parameters for the API.

#### Syntax

```vbnet
'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _useTransitions_ As Boolean, _
   ByVal _quantity_ As Integer _
)

[ConstructorIndexAttribute()]
public FulfillPartRequestSetup(
   string _partRequestDetailIDNum_,
   bool _useTransitions_,
   int _quantity_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

useTransitions

Specifies whether or not logistics transitions will be checked and the condition/status of the part request detail will be changed during the fulfill operation

quantity

The number of parts being fulfilled for this Part Request

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FulfillPartRequestSetup Class
FulfillPartRequestSetup Members
Overload List


FulfillPartRequestSetup Constructor(String,Boolean,String) | fcSDK Documentation

FulfillPartRequestSetup Constructor(String,Boolean,String)

Part Request Detail Identifier

Specifies whether or not logistics transitions will be checked and the condition/status of the part request detail will be changed during the fulfill operation

The serial number of the part used to fulfill this Part Request

Initializes a new instance of the FulfillPartRequestSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _useTransitions_ As Boolean, _
   ByVal _serialNumber_ As String _
)

[ConstructorIndexAttribute()]
public FulfillPartRequestSetup(
   string _partRequestDetailIDNum_,
   bool _useTransitions_,
   string _serialNumber_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

useTransitions

Specifies whether or not logistics transitions will be checked and the condition/status of the part request detail will be changed during the fulfill operation

serialNumber

The serial number of the part used to fulfill this Part Request

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FulfillPartRequestSetup Class
FulfillPartRequestSetup Members
Overload List


FromGood Property (FulfillPartRequestSetup) | fcSDK Documentation

FromGood Property (FulfillPartRequestSetup)

Specifies whether the fulfilled inventory is from good stock (true) or bad stock (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FromGood As Boolean

[PropertyBitValueAttribute()]
public bool FromGood {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FulfillPartRequestSetup Class
FulfillPartRequestSetup Members


FromLocation Property (FulfillPartRequestSetup) | fcSDK Documentation

FromLocation Property (FulfillPartRequestSetup)

The inventory location and bin containing the parts used to fulfill this Part Request

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FromLocation As Location

[PropertyBitValueAttribute()]
public Location FromLocation {get; set;}

Remarks

To use a primary bin suggestion/recommendation that has been previously configured, use the special constructor for the Location object and set the isPrimaryBinSuggestion parameter to true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FulfillPartRequestSetup Class
FulfillPartRequestSetup Members


FulfillDate Property (FulfillPartRequestSetup) | fcSDK Documentation

FulfillDate Property (FulfillPartRequestSetup)

The DateTime the Part Request is fulfilled. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FulfillDate As Date

[PropertyBitValueAttribute()]
public DateTime FulfillDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FulfillPartRequestSetup Class
FulfillPartRequestSetup Members


GenerateTimeBombs Property (FulfillPartRequestSetup) | fcSDK Documentation

GenerateTimeBombs Property (FulfillPartRequestSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FulfillPartRequestSetup Class
FulfillPartRequestSetup Members


NewStatus Property (FulfillPartRequestSetup) | fcSDK Documentation

NewStatus Property (FulfillPartRequestSetup)

The new status for the Part Request for the Fulfilled condition. If not set, the default status is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewStatus As String

[PropertyBitValueAttribute()]
public string NewStatus {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FulfillPartRequestSetup Class
FulfillPartRequestSetup Members


PartRequestDetailIDNum Property (FulfillPartRequestSetup) | fcSDK Documentation

PartRequestDetailIDNum Property (FulfillPartRequestSetup)

Part Request Detail Identifier

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRequestDetailIDNum As String

[PropertyBitValueAttribute()]
public string PartRequestDetailIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FulfillPartRequestSetup Class
FulfillPartRequestSetup Members


Quantity Property (FulfillPartRequestSetup) | fcSDK Documentation

Quantity Property (FulfillPartRequestSetup)

The number of parts being fulfilled for this Part Request

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Quantity As Integer

[PropertyBitValueAttribute()]
public int Quantity {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FulfillPartRequestSetup Class
FulfillPartRequestSetup Members


SerialNumber Property (FulfillPartRequestSetup) | fcSDK Documentation

SerialNumber Property (FulfillPartRequestSetup)

The serial number of the part used to fulfill this Part Request

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SerialNumber As String

[PropertyBitValueAttribute()]
public string SerialNumber {get; set;}

Remarks

If no serial number is specified and serialized parts are being used, the serial number from the Part Request will be used.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FulfillPartRequestSetup Class
FulfillPartRequestSetup Members


ToGood Property (FulfillPartRequestSetup) | fcSDK Documentation

ToGood Property (FulfillPartRequestSetup)

Specifies whether the fulfilled inventory is going to good stock (true) or bad stock (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ToGood As Boolean

[PropertyBitValueAttribute()]
public bool ToGood {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FulfillPartRequestSetup Class
FulfillPartRequestSetup Members


ToLocation Property (FulfillPartRequestSetup) | fcSDK Documentation

ToLocation Property (FulfillPartRequestSetup)

The destination inventory location and bin for the parts used to fulfill this Part Request

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ToLocation As Location

[PropertyBitValueAttribute()]
public Location ToLocation {get; set;}

Remarks

To use a primary bin suggestion/recommendation that has been previously configured, use the special constructor for the Location object and set the isPrimaryBinSuggestion parameter to true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FulfillPartRequestSetup Class
FulfillPartRequestSetup Members


UserName Property (FulfillPartRequestSetup) | fcSDK Documentation

UserName Property (FulfillPartRequestSetup)

The user who is fulfilling the Part Request. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FulfillPartRequestSetup Class
FulfillPartRequestSetup Members


UseTransitions Property (FulfillPartRequestSetup) | fcSDK Documentation

UseTransitions Property (FulfillPartRequestSetup)

Specifies whether or not logistics transitions will be checked and the condition/status of the part request detail will be changed during the fulfill operation

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UseTransitions As Boolean

[PropertyBitValueAttribute()]
public bool UseTransitions {get; set;}

Remarks

Setting this value to false allows for multiple calls to the API to be performed without extra complex transitions being added to the system. By default, the value is true.

NOTE: The last call to FulfillPartRequest in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FulfillPartRequestSetup Class
FulfillPartRequestSetup Members


GetAlternatePartsResult Class | fcSDK Documentation

GetAlternatePartsResult Class

Result from the GetAlternateParts API.

Syntax

'Declaration

Public Class GetAlternatePartsResult
   Inherits FChoice.Toolkits.Clarify.ToolkitResult

public class GetAlternatePartsResult : FChoice.Toolkits.Clarify.ToolkitResult

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.ToolkitResult
FChoice.Toolkits.Clarify.Logistics.GetAlternatePartsResult

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

GetAlternatePartsResult Members
FChoice.Toolkits.Clarify.Logistics Namespace


GetAlternatePartsResult Class Members | fcSDK Documentation

GetAlternatePartsResult Class Members

The following tables list the members exposed by GetAlternatePartsResult.

Public Constructors

 | Name | Description
Public Constructor | GetAlternatePartsResult Constructor |

Public Properties

 | Name | Description
Public Property | AlternatePartList | An array of Alternate Part objid's.
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)

Reference

GetAlternatePartsResult Class
FChoice.Toolkits.Clarify.Logistics Namespace


GetAlternatePartsResult Constructor | fcSDK Documentation

GetAlternatePartsResult Constructor

Syntax

'Declaration

Public Function New()

public GetAlternatePartsResult()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GetAlternatePartsResult Class
GetAlternatePartsResult Members


AlternatePartList Property | fcSDK Documentation

AlternatePartList Property

An array of Alternate Part objid's.

Syntax

'Declaration

Public Property AlternatePartList As Integer()

public int[] AlternatePartList {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GetAlternatePartsResult Class
GetAlternatePartsResult Members


GetAlternatePartsSetup Class | fcSDK Documentation

GetAlternatePartsSetup Class

Used by the GetAlternateParts method as setup data for invocation.

Syntax

'Declaration

Public Class GetAlternatePartsSetup

public class GetAlternatePartsSetup

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.GetAlternatePartsSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

GetAlternatePartsSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitGetAlternateParts(GetAlternatePartsSetup)


GetAlternatePartsSetup Class Members | fcSDK Documentation

GetAlternatePartsSetup Class Members

The following tables list the members exposed by GetAlternatePartsSetup.

Public Constructors

 | Name | Description
Public Constructor | GetAlternatePartsSetup Constructor | Initializes a new instance of the GetAlternatePartsSetup class.

Public Properties

 | Name | Description
Public Property | PartDomain | The Part domain
Public Property | PartNumber | The Part number
Public Property | PartRevision | The Part revision

Reference

GetAlternatePartsSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitGetAlternateParts(GetAlternatePartsSetup)


GetAlternatePartsSetup Constructor | fcSDK Documentation

GetAlternatePartsSetup Constructor

The Part number

The Part domain

The Part revision

Initializes a new instance of the GetAlternatePartsSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partNumber_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _partRevision_ As String _
)

[ConstructorIndexAttribute()]
public GetAlternatePartsSetup(
   string _partNumber_,
   string _partDomain_,
   string _partRevision_
)

Parameters

partNumber

The Part number

partDomain

The Part domain

partRevision

The Part revision

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GetAlternatePartsSetup Class
GetAlternatePartsSetup Members


PartDomain Property (GetAlternatePartsSetup) | fcSDK Documentation

PartDomain Property (GetAlternatePartsSetup)

The Part domain

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartDomain As String

[PropertyBitValueAttribute()]
public string PartDomain {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GetAlternatePartsSetup Class
GetAlternatePartsSetup Members


PartNumber Property (GetAlternatePartsSetup) | fcSDK Documentation

PartNumber Property (GetAlternatePartsSetup)

The Part number

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartNumber As String

[PropertyBitValueAttribute()]
public string PartNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GetAlternatePartsSetup Class
GetAlternatePartsSetup Members


PartRevision Property (GetAlternatePartsSetup) | fcSDK Documentation

PartRevision Property (GetAlternatePartsSetup)

The Part revision

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRevision As String

[PropertyBitValueAttribute()]
public string PartRevision {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GetAlternatePartsSetup Class
GetAlternatePartsSetup Members


GetLocationsServicingSiteResult Class | fcSDK Documentation

GetLocationsServicingSiteResult Class

Result from the GetLocationsServicingSite API.

Syntax

'Declaration

Public Class GetLocationsServicingSiteResult
   Inherits FChoice.Toolkits.Clarify.ToolkitResult

public class GetLocationsServicingSiteResult : FChoice.Toolkits.Clarify.ToolkitResult

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.ToolkitResult
FChoice.Toolkits.Clarify.Logistics.GetLocationsServicingSiteResult

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

GetLocationsServicingSiteResult Members
FChoice.Toolkits.Clarify.Logistics Namespace


GetLocationsServicingSiteResult Class Members | fcSDK Documentation

GetLocationsServicingSiteResult Class Members

The following tables list the members exposed by GetLocationsServicingSiteResult.

Public Constructors

 | Name | Description
Public Constructor | GetLocationsServicingSiteResult Constructor |

Public Properties

 | Name | Description
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | InventoryLocationObjidList | An array of Inventory Location objid's.
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)

Reference

GetLocationsServicingSiteResult Class
FChoice.Toolkits.Clarify.Logistics Namespace


GetLocationsServicingSiteResult Constructor | fcSDK Documentation

GetLocationsServicingSiteResult Constructor

Syntax

'Declaration

Public Function New()

public GetLocationsServicingSiteResult()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GetLocationsServicingSiteResult Class
GetLocationsServicingSiteResult Members


InventoryLocationObjidList Property | fcSDK Documentation

InventoryLocationObjidList Property

An array of Inventory Location objid's.

Syntax

'Declaration

Public Property InventoryLocationObjidList As Integer()

public int[] InventoryLocationObjidList {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GetLocationsServicingSiteResult Class
GetLocationsServicingSiteResult Members


GetLocationsServicingSiteSetup Class | fcSDK Documentation

GetLocationsServicingSiteSetup Class

Used by the GetLocationsServicingSite method as setup data for invocation.

Syntax

'Declaration

Public Class GetLocationsServicingSiteSetup

public class GetLocationsServicingSiteSetup

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.GetLocationsServicingSiteSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

GetLocationsServicingSiteSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitGetLocationsServicingSite(GetLocationsServicingSiteSetup)


GetLocationsServicingSiteSetup Class Members | fcSDK Documentation

GetLocationsServicingSiteSetup Class Members

The following tables list the members exposed by GetLocationsServicingSiteSetup.

Public Constructors

 | Name | Description
Public Constructor | GetLocationsServicingSiteSetup Constructor | Initializes a new instance of the GetLocationsServicingSiteSetup class.

Public Properties

 | Name | Description
Public Property | SiteIDNum | Identifier of the Site that the inventory locations are servicing

Reference

GetLocationsServicingSiteSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitGetLocationsServicingSite(GetLocationsServicingSiteSetup)


GetLocationsServicingSiteSetup Constructor | fcSDK Documentation

GetLocationsServicingSiteSetup Constructor

Identifier of the Site that the inventory locations are servicing

Initializes a new instance of the GetLocationsServicingSiteSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _siteIDNum_ As String _
)

[ConstructorIndexAttribute()]
public GetLocationsServicingSiteSetup(
   string _siteIDNum_
)

Parameters

siteIDNum

Identifier of the Site that the inventory locations are servicing

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GetLocationsServicingSiteSetup Class
GetLocationsServicingSiteSetup Members


SiteIDNum Property (GetLocationsServicingSiteSetup) | fcSDK Documentation

SiteIDNum Property (GetLocationsServicingSiteSetup)

Identifier of the Site that the inventory locations are servicing

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteIDNum As String

[PropertyBitValueAttribute()]
public string SiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GetLocationsServicingSiteSetup Class
GetLocationsServicingSiteSetup Members


LogisticsToolkit Class | fcSDK Documentation

LogisticsToolkit Class

Provides APIs for ClearLogistics Spares Manager and Order Operations. Methods on the LogisticsToolkit allow you to fully manipulate part requests with operations such as create, modify, close, perform work flow (dispatch, assign, etc), change status, and note logging. In addition, there are also methods for all warehouse operations such as pick, unpick, fulfill, ship, receive, transfer, and more.

Syntax

'Declaration

Public Class LogisticsToolkit
   Inherits LogisticsToolkitBase

public class LogisticsToolkit : LogisticsToolkitBase

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.ToolkitBase
FChoice.Toolkits.Clarify.Logistics.LogisticsToolkitBase
FChoice.Toolkits.Clarify.Logistics.LogisticsToolkit

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LogisticsToolkit Members
FChoice.Toolkits.Clarify.Logistics Namespace


LogisticsToolkit Class Members | fcSDK Documentation

LogisticsToolkit Class Members

The following tables list the members exposed by LogisticsToolkit.

Public Constructors

 | Name | Description
Public Constructor | LogisticsToolkit Constructor | Overloaded.

Public Properties

 | Name | Description
Public Property | ImpersonatorUsername | (Inherited from FChoice.Toolkits.Clarify.Logistics.LogisticsToolkitBase)

Public Methods

| | Name | Description | | --- | --- | --- | | Public Method | AcceptPartRequest | Overloaded. Accept the specified PartRequest from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API. | | Public Method | AddAlternatePart | Overloaded. Causes the second part/revision listed to become an alternate part of the first one listed. This overload takes a set of required parameters for the API. | | Public Method | AddGLAccount | Overloaded. Used to add expense and capital GL accounts to Clarify. This overload takes a set of required parameters for the API. | | Public Method | AddInventoryBin | Overloaded. Used to add inventory bins to existing locations. This overload takes a set of required parameters for the API. | | Public Method | AddInventoryLocation | Overloaded. Used to add inventory locations to the system.

This overload takes a set of required parameters for the API. | | Public Method | AddLocationServicingSite | Overloaded. Used to relate sites to the inventory locations that service them. This overload takes a set of required parameters for the API. | | Public Method | AssignPartRequest | Overloaded. Assign the PartRequest to a new user. This overload takes a set of required parameters for the API. | | Public Method | BackorderPartRequest | Overloaded. Allows for the backordering of inventory parts for a part request. This overload takes a set of required parameters for the API. | | Public Method | ChangePartRequestStatus | Overloaded. Causes the specified part request to have a status change from one status to another status – always in the same condition. This overload takes a set of required parameters for the API. | | Public Method | ClosePartRequest | Overloaded. Causes the specified part request to be closed. This overload takes a set of required parameters for the API. | | Public Method | CreateContainer | Overloaded. | | Public Method | CreatePartRequestDetail | Overloaded.

Used to create a new part request detail.

This overload takes a set of required parameters for the API. | | Public Method | CreatePartRequestHeader | Overloaded.

Used to create a new part request header.

This overload takes a set of required parameters for the API. | | Public Method | CreatePartRequestHeaderCase | Overloaded.

Used to create a new part request header against a case.

This overload takes a set of required parameters for the API. | | Public Method | CreatePartRequestHeaderSubcase | Overloaded.

Used to create a new part request header against a subcase.

This overload takes a set of required parameters for the API. | | Public Method | CreateSubContainer | Overloaded. | | Public Method | DeleteAlternatePart | Overloaded. Causes the second part/revision listed to be removed as an alternate part for the first. This overload takes a set of required parameters for the API. | | Public Method | DeleteLocationServicingSite | Overloaded. Used to remove the relationship between a site and a location servicing it. This overload takes a set of required parameters for the API. | | Public Method | DispatchPartRequest | Overloaded. Dispatch the PartRequest to the specified queue. This overload takes a set of required parameters for the API. | | Public Method | ForwardPartRequest | Overloaded. Reject-forward the PartRequest from one queue to another. This overload takes a set of required parameters for the API. | | Public Method | FulfillPartRequest | Overloaded. Allows for the fulfilling of inventory parts for a part request. This overload takes a set of required parameters for the API. | | Public Method | GetAlternateParts | Overloaded. Builds a list of the alternate parts (table_partnum_view) for the specified part and revision, and returns an array of part Objids This overload takes a set of required parameters for the API. | | Public Method | GetLocationsServicingSite | Overloaded. Returns a list of the locations (in the proper order) servicing this site. This overload takes a set of required parameters for the API. | | Public Method | MovePartRequest | Overloaded. Move the PartRequest from one WipBin to another WipBin. This overload takes a set of required parameters for the API. | | Public Method | OpenContainer | Overloaded. | | Public Method | PartTransfer | Overloaded.

Allows parts to be transferred independent of a part request to fix order errors, correct inventory variances, move parts from one inventory location (or account) to another (without having to relate that movement to a part request), and scrap parts out of inventory.

This overload takes a set of required parameters for the API. | | Public Method | Pick | Overloaded.

Allows for multiple pick actions to occur against a part request.

This overload takes a set of required parameters for the API. | | Public Method | ReceivePartRequest | Overloaded.

Causes the specified part request to have units received against it.

This overload takes a set of required parameters for the API. | | Public Method | RejectPartRequest | Overloaded. Reject the PartRequest from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API. | | Public Method | ReopenPartRequest | Overloaded.

Causes the specified part request to be reopened.

This overload takes a set of required parameters for the API. | | Public Method | SealContainer | Overloaded. | | Public Method | SetLogisticsTransition | Overloaded. Allows you to create or modify Logistics Transitions in the database. This overload takes a set of required parameters for the API. | | Public Method | SetPartStockingLevel | Overloaded. Creates a part restocking authorization level. This overload takes a set of required parameters for the API. | | Public Method | Ship | Overloaded.

Causes the specified part request to be shipped.

This overload takes a set of required parameters for the API. | | Public Method | Unpick | Overloaded.

Allows for the unpicking (unreserving) of inventory parts for a part request.

This overload takes a set of required parameters for the API. | | Public Method | UpdateGLAccount | Overloaded. Used to modify existing GL accounts. This overload takes a set of required parameters for the API. | | Public Method | UpdateInventoryBin | Overloaded. Used to modify the name or the active flag of an existing bin. This overload takes a set of required parameters for the API. | | Public Method | UpdateInventoryLocation | Overloaded.

Used to modify inventory locations in the system.

This overload takes a setup object. | | Public Method | UpdateLocationServicingSite | Overloaded. Used to change the order of the locations servicing a site. This overload takes a set of required parameters for the API. | | Public Method | UpdatePartRequestDetail | Overloaded.

Allow for the updating of part request details.

This overload takes a setup object. | | Public Method | UpdatePartRequestHeader | Overloaded.

Allow for the updating of part request headers.

This overload takes a setup object. | | Public Method | UpdatePartStockingLevel | Overloaded. Updates an existing part restocking authorization level. This overload takes a set of required parameters for the API. | | Public Method | YankPartRequest | Overloaded. Yank the PartRequest from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API. |

Reference

LogisticsToolkit Class
FChoice.Toolkits.Clarify.Logistics Namespace


LogisticsToolkit Constructor | fcSDK Documentation

LogisticsToolkit Constructor

Initializes a new instance of the LogisticsToolkit class.

Overload List

Overload | Description
LogisticsToolkit Constructor(ClarifySession) | Initializes a new instance of the LogisticsToolkit class using a ClarifySession object.
LogisticsToolkit Constructor(IFCApplication,IFCSession) | Initializes a new instance of the LogisticsToolkit class using a Compatibility application and session.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members


LogisticsToolkit Constructor(ClarifySession) | fcSDK Documentation

LogisticsToolkit Constructor(ClarifySession)

The session under which the toolkit APIs will be executed.

Initializes a new instance of the LogisticsToolkit class using a ClarifySession object.

Syntax

'Declaration

Public Function New( _
   ByVal _session_ As ClarifySession _
)

public LogisticsToolkit(
   ClarifySession _session_
)

Parameters

session

The session under which the toolkit APIs will be executed.

Remarks

If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


LogisticsToolkit Constructor(IFCApplication,IFCSession) | fcSDK Documentation

LogisticsToolkit Constructor(IFCApplication,IFCSession)

The compatibility application under which the toolkit APIs will be executed.

The compatibility session under which the toolkit APIs will be executed.

Initializes a new instance of the LogisticsToolkit class using a Compatibility application and session.

Syntax

'Declaration

Public Function New( _
   ByVal _application_ As IFCApplication, _
   ByVal _session_ As IFCSession _
)

public LogisticsToolkit(
   IFCApplication _application_,
   IFCSession _session_
)

Parameters

application

The compatibility application under which the toolkit APIs will be executed.

session

The compatibility session under which the toolkit APIs will be executed.

Remarks

If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


AcceptPartRequest Method | fcSDK Documentation

AcceptPartRequest Method

Accept the specified PartRequest from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.

Accept the specified PartRequest from the queue in which it is currently dispatched.

Overload List

Overload | Description
AcceptPartRequest(String) | Accept the specified PartRequest from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.
AcceptPartRequest(AcceptPartRequestSetup) | Accept the specified PartRequest from the queue in which it is currently dispatched. This overload takes a setup object.
AcceptPartRequest(AcceptPartRequestSetup,IDbTransaction) | Accept the specified PartRequest from the queue in which it is currently dispatched. This overload takes a setup object and a database transaction.

Remarks

The PartRequest must be currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.AcceptPartRequestSetup


AcceptPartRequest(String) Method | fcSDK Documentation

AcceptPartRequest(String) Method

Part Request Detail Identifier

Accept the specified PartRequest from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function AcceptPartRequest( _
   ByVal _partRequestDetailIDNum_ As String _
) As ToolkitResult

public ToolkitResult AcceptPartRequest(
   string _partRequestDetailIDNum_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The PartRequest must be currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


AcceptPartRequest(AcceptPartRequestSetup) Method | fcSDK Documentation

AcceptPartRequest(AcceptPartRequestSetup) Method

Setup object for API invocation.

Accept the specified PartRequest from the queue in which it is currently dispatched. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function AcceptPartRequest( _
   ByVal _setupParam_ AcceptPartRequestSetup _
) As ToolkitResult

public ToolkitResult AcceptPartRequest(
   AcceptPartRequestSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The PartRequest must be currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.AcceptPartRequestSetup


AcceptPartRequest(AcceptPartRequestSetup,IDbTransaction) Method | fcSDK Documentation

AcceptPartRequest(AcceptPartRequestSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Accept the specified PartRequest from the queue in which it is currently dispatched. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function AcceptPartRequest( _
   ByVal _setupParam_ As AcceptPartRequestSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult AcceptPartRequest(
   AcceptPartRequestSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The PartRequest must be currently dispatched to a queue.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


AddAlternatePart Method | fcSDK Documentation

AddAlternatePart Method

Causes the second part/revision listed to become an alternate part of the first one listed. This overload takes a set of required parameters for the API.

Causes the second part/revision listed to become an alternate part of the first one listed.

Overload List

Overload | Description
AddAlternatePart(String,String,String,String,String,String) | Causes the second part/revision listed to become an alternate part of the first one listed. This overload takes a set of required parameters for the API.
AddAlternatePart(AddAlternatePartSetup) | Causes the second part/revision listed to become an alternate part of the first one listed. This overload takes a setup object.
AddAlternatePart(AddAlternatePartSetup,IDbTransaction) | Causes the second part/revision listed to become an alternate part of the first one listed. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.AddAlternatePartSetup


AddAlternatePart(String,String,String,String,String,String) Method | fcSDK Documentation

AddAlternatePart(String,String,String,String,String,String) Method

The Part number

The Part revision

The Part domain

The Alternate Part number

The Alternate Part revision

The Alternate Part domain

Causes the second part/revision listed to become an alternate part of the first one listed. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function AddAlternatePart( _
   ByVal _partNumber_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _alternatePartNumber_ As String, _
   ByVal _alternatePartRevision_ As String, _
   ByVal _alternatePartDomain_ As String _
) As ToolkitResult

public ToolkitResult AddAlternatePart(
   string _partNumber_,
   string _partRevision_,
   string _partDomain_,
   string _alternatePartNumber_,
   string _alternatePartRevision_,
   string _alternatePartDomain_
)

Parameters

partNumber

The Part number

partRevision

The Part revision

partDomain

The Part domain

alternatePartNumber

The Alternate Part number

alternatePartRevision

The Alternate Part revision

alternatePartDomain

The Alternate Part domain

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


AddAlternatePart(AddAlternatePartSetup) Method | fcSDK Documentation

AddAlternatePart(AddAlternatePartSetup) Method

Setup object for API invocation.

Causes the second part/revision listed to become an alternate part of the first one listed. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function AddAlternatePart( _
   ByVal _setupParam_ AddAlternatePartSetup _
) As ToolkitResult

public ToolkitResult AddAlternatePart(
   AddAlternatePartSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.AddAlternatePartSetup


AddAlternatePart(AddAlternatePartSetup,IDbTransaction) Method | fcSDK Documentation

AddAlternatePart(AddAlternatePartSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Causes the second part/revision listed to become an alternate part of the first one listed. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function AddAlternatePart( _
   ByVal _setupParam_ As AddAlternatePartSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult AddAlternatePart(
   AddAlternatePartSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List


AddGLAccount Method | fcSDK Documentation

AddGLAccount Method

Used to add expense and capital GL accounts to Clarify. This overload takes a set of required parameters for the API.

Used to add expense and capital GL accounts to Clarify.

Overload List

Overload | Description
AddGLAccount(String,String) | Used to add expense and capital GL accounts to Clarify. This overload takes a set of required parameters for the API.
AddGLAccount(AddGLAccountSetup) | Used to add expense and capital GL accounts to Clarify. This overload takes a setup object.
AddGLAccount(AddGLAccountSetup,IDbTransaction) | Used to add expense and capital GL accounts to Clarify. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.AddGLAccountSetup


AddGLAccount(String,String) Method | fcSDK Documentation

AddGLAccount(String,String) Method

Name of the General Ledger account

The identifier of the Site with which the account is to be associated

Used to add expense and capital GL accounts to Clarify. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function AddGLAccount( _
   ByVal _accountName_ As String, _
   ByVal _siteIDNum_ As String _
) As ToolkitResult

public ToolkitResult AddGLAccount(
   string _accountName_,
   string _siteIDNum_
)

Parameters

accountName

Name of the General Ledger account

siteIDNum

The identifier of the Site with which the account is to be associated

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - Objid of the Inventory Location record.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


AddGLAccount(AddGLAccountSetup) Method | fcSDK Documentation

AddGLAccount(AddGLAccountSetup) Method

Setup object for API invocation.

Used to add expense and capital GL accounts to Clarify. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function AddGLAccount( _
   ByVal _setupParam_ AddGLAccountSetup _
) As ToolkitResult

public ToolkitResult AddGLAccount(
   AddGLAccountSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - Objid of the Inventory Location record.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.AddGLAccountSetup


AddGLAccount(AddGLAccountSetup,IDbTransaction) Method | fcSDK Documentation

AddGLAccount(AddGLAccountSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to add expense and capital GL accounts to Clarify. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function AddGLAccount( _
   ByVal _setupParam_ As AddGLAccountSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult AddGLAccount(
   AddGLAccountSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


AddInventoryBin Method | fcSDK Documentation

AddInventoryBin Method

Used to add inventory bins to existing locations. This overload takes a set of required parameters for the API.

Used to add inventory bins to existing locations.

Overload List

Overload | Description
AddInventoryBin(Location) | Used to add inventory bins to existing locations. This overload takes a set of required parameters for the API.
AddInventoryBin(AddInventoryBinSetup) | Used to add inventory bins to existing locations. This overload takes a setup object.
AddInventoryBin(AddInventoryBinSetup,IDbTransaction) | Used to add inventory bins to existing locations. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.AddInventoryBinSetup


AddInventoryBin(Location) Method | fcSDK Documentation

AddInventoryBin(Location) Method

A reference to a Location object which specifies the name of the bin to create and the name of the location in which to create it

Used to add inventory bins to existing locations. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function AddInventoryBin( _
   ByVal _location_ As Location _
) As ToolkitResult

public ToolkitResult AddInventoryBin(
   Location _location_
)

Parameters

location

A reference to a Location object which specifies the name of the bin to create and the name of the location in which to create it

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - Objid of the Inventory Bin record.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


AddInventoryBin(AddInventoryBinSetup) Method | fcSDK Documentation

AddInventoryBin(AddInventoryBinSetup) Method

Setup object for API invocation.

Used to add inventory bins to existing locations. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function AddInventoryBin( _
   ByVal _setupParam_ AddInventoryBinSetup _
) As ToolkitResult

public ToolkitResult AddInventoryBin(
   AddInventoryBinSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - Objid of the Inventory Bin record.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.AddInventoryBinSetup


AddInventoryBin(AddInventoryBinSetup,IDbTransaction) Method | fcSDK Documentation

AddInventoryBin(AddInventoryBinSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to add inventory bins to existing locations. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function AddInventoryBin( _
   ByVal _setupParam_ As AddInventoryBinSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult AddInventoryBin(
   AddInventoryBinSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List


AddInventoryLocation Method | fcSDK Documentation

AddInventoryLocation Method

Used to add inventory locations to the system.

This overload takes a set of required parameters for the API.

Used to add inventory locations to the system.

Overload List

Overload | Description
AddInventoryLocation(String,String,String,PartAuthorizationLevel) | Used to add inventory locations to the system. This overload takes a set of required parameters for the API.
AddInventoryLocation(AddInventoryLocationSetup) | Used to add inventory locations to the system. This overload takes a setup object.
AddInventoryLocation(AddInventoryLocationSetup,IDbTransaction) | Used to add inventory locations to the system. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.AddInventoryLocationSetup


AddInventoryLocation(String,String,String,PartAuthorizationLevel) Method | fcSDK Documentation

AddInventoryLocation(String,String,String,PartAuthorizationLevel) Method

Name of the inventory location to add

The name of the Capital GL account with which this inventory location is to be associated

The identifier of the Site with which the inventory location is to be associated

The part authorization level for this inventory location

Used to add inventory locations to the system.

This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function AddInventoryLocation( _
   ByVal _locationName_ As String, _
   ByVal _capitalGLAccount_ As String, _
   ByVal _siteIDNum_ As String, _
   ByVal _partAuthorizationLevel_ As PartAuthorizationLevel _
) As ToolkitResult

public ToolkitResult AddInventoryLocation(
   string _locationName_,
   string _capitalGLAccount_,
   string _siteIDNum_,
   PartAuthorizationLevel _partAuthorizationLevel_
)

Parameters

locationName

Name of the inventory location to add

capitalGLAccount

The name of the Capital GL account with which this inventory location is to be associated

siteIDNum

The identifier of the Site with which the inventory location is to be associated

partAuthorizationLevel

The part authorization level for this inventory location

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - Objid of the Inventory Location record.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


AddInventoryLocation(AddInventoryLocationSetup) Method | fcSDK Documentation

AddInventoryLocation(AddInventoryLocationSetup) Method

Setup object for API invocation.

Used to add inventory locations to the system.

This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function AddInventoryLocation( _
   ByVal _setupParam_ AddInventoryLocationSetup _
) As ToolkitResult

public ToolkitResult AddInventoryLocation(
   AddInventoryLocationSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - Objid of the Inventory Location record.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.AddInventoryLocationSetup


AddInventoryLocation(AddInventoryLocationSetup,IDbTransaction) Method | fcSDK Documentation

AddInventoryLocation(AddInventoryLocationSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to add inventory locations to the system.

This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function AddInventoryLocation( _
   ByVal _setupParam_ As AddInventoryLocationSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult AddInventoryLocation(
   AddInventoryLocationSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


AddLocationServicingSite Method | fcSDK Documentation

AddLocationServicingSite Method

Used to relate sites to the inventory locations that service them. This overload takes a set of required parameters for the API.

Used to relate sites to the inventory locations that service them.

Overload List

Overload | Description
AddLocationServicingSite(String,String,Int16) | Used to relate sites to the inventory locations that service them. This overload takes a set of required parameters for the API.
AddLocationServicingSite(AddLocationServicingSiteSetup) | Used to relate sites to the inventory locations that service them. This overload takes a setup object.
AddLocationServicingSite(AddLocationServicingSiteSetup,IDbTransaction) | Used to relate sites to the inventory locations that service them. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.AddLocationServicingSiteSetup


AddLocationServicingSite(String,String,Int16) Method | fcSDK Documentation

AddLocationServicingSite(String,String,Int16) Method

The identifier of the Site that the inventory location is servicing

The name of the location that will be servicing the Site

The rank of this inventory location at the associated site

Used to relate sites to the inventory locations that service them. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function AddLocationServicingSite( _
   ByVal _siteIDNum_ As String, _
   ByVal _locationName_ As String, _
   ByVal _locationRank_ As Short _
) As ToolkitResult

public ToolkitResult AddLocationServicingSite(
   string _siteIDNum_,
   string _locationName_,
   short _locationRank_
)

Parameters

siteIDNum

The identifier of the Site that the inventory location is servicing

locationName

The name of the location that will be servicing the Site

locationRank

The rank of this inventory location at the associated site

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - Objid of the Inventory Role record.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


AddLocationServicingSite(AddLocationServicingSiteSetup) Method | fcSDK Documentation

AddLocationServicingSite(AddLocationServicingSiteSetup) Method

Setup object for API invocation.

Used to relate sites to the inventory locations that service them. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function AddLocationServicingSite( _
   ByVal _setupParam_ AddLocationServicingSiteSetup _
) As ToolkitResult

public ToolkitResult AddLocationServicingSite(
   AddLocationServicingSiteSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - Objid of the Inventory Role record.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.AddLocationServicingSiteSetup


AddLocationServicingSite(AddLocationServicingSiteSetup,IDbTransaction) Method | fcSDK Documentation

AddLocationServicingSite(AddLocationServicingSiteSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to relate sites to the inventory locations that service them. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function AddLocationServicingSite( _
   ByVal _setupParam_ As AddLocationServicingSiteSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult AddLocationServicingSite(
   AddLocationServicingSiteSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


AssignPartRequest Method | fcSDK Documentation

AssignPartRequest Method

Assign the PartRequest to a new user. This overload takes a set of required parameters for the API.

Assign the PartRequest to a new user.

Overload List

Overload | Description
AssignPartRequest(String) | Assign the PartRequest to a new user. This overload takes a set of required parameters for the API.
AssignPartRequest(AssignPartRequestSetup) | Assign the PartRequest to a new user. This overload takes a setup object.
AssignPartRequest(AssignPartRequestSetup,IDbTransaction) | Assign the PartRequest to a new user. This overload takes a setup object and a database transaction.

Remarks

The PartRequest must be in the Open condition, and the user assigning the PartRequest does not have to be the owner of the PartRequest. In base Clarify, the assigner of a PartRequest must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the PartRequest in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.AssignPartRequestSetup


AssignPartRequest(String) Method | fcSDK Documentation

AssignPartRequest(String) Method

Part Request Detail Identifier

Assign the PartRequest to a new user. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function AssignPartRequest( _
   ByVal _partRequestDetailIDNum_ As String _
) As ToolkitResult

public ToolkitResult AssignPartRequest(
   string _partRequestDetailIDNum_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The PartRequest must be in the Open condition, and the user assigning the PartRequest does not have to be the owner of the PartRequest. In base Clarify, the assigner of a PartRequest must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the PartRequest in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


AssignPartRequest(AssignPartRequestSetup) Method | fcSDK Documentation

AssignPartRequest(AssignPartRequestSetup) Method

Setup object for API invocation.

Assign the PartRequest to a new user. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function AssignPartRequest( _
   ByVal _setupParam_ AssignPartRequestSetup _
) As ToolkitResult

public ToolkitResult AssignPartRequest(
   AssignPartRequestSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The PartRequest must be in the Open condition, and the user assigning the PartRequest does not have to be the owner of the PartRequest. In base Clarify, the assigner of a PartRequest must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the PartRequest in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.AssignPartRequestSetup


AssignPartRequest(AssignPartRequestSetup,IDbTransaction) Method | fcSDK Documentation

AssignPartRequest(AssignPartRequestSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Assign the PartRequest to a new user. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function AssignPartRequest( _
   ByVal _setupParam_ As AssignPartRequestSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult AssignPartRequest(
   AssignPartRequestSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The PartRequest must be in the Open condition, and the user assigning the PartRequest does not have to be the owner of the PartRequest. In base Clarify, the assigner of a PartRequest must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the PartRequest in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


BackorderPartRequest Method | fcSDK Documentation

BackorderPartRequest Method

Allows for the backordering of inventory parts for a part request. This overload takes a set of required parameters for the API.

Allows for the backordering of inventory parts for a part request.

Overload List

Overload | Description
BackorderPartRequest(String,DateTime,Boolean,Int32) | Allows for the backordering of inventory parts for a part request. This overload takes a set of required parameters for the API.
BackorderPartRequest(String,DateTime,Boolean,String) | Allows for the backordering of inventory parts for a part request. This overload takes a set of required parameters for the API.
BackorderPartRequest(BackorderPartRequestSetup) | Allows for the backordering of inventory parts for a part request. This overload takes a setup object.
BackorderPartRequest(BackorderPartRequestSetup,IDbTransaction) | Allows for the backordering of inventory parts for a part request. This overload takes a setup object and a database transaction.
BackorderPartRequest(String,DateTime,Int32) | Allows for the backordering of inventory parts for a part request. This overload takes a set of required parameters for the API.
BackorderPartRequest(String,DateTime,String) | Allows for the backordering of inventory parts for a part request. This overload takes a set of required parameters for the API.

Remarks

As in base Clarify, if a partial backorder is performed, the part request is broken up into two new part requests. The first is for the backorder (and the quantities are changed). The new part request will be created to hold the rest of the units that did not get backordered.

This API will validate that the part request can be transitioned (for the specified user) to the proper new condition.

This API will work with either quantity or serialized parts, based on the part number/site_part of the part request. If a serial number is specified, it will be used. Otherwise, the serial number will be taken from the part request.

To use primary bin suggestions/recommendations, please see the remarks on the ToLocation and/or FromLocation properties on the BackorderPartRequestSetup object.

To allow for multiple calls to this API to be performed without extra complex transitions being added to the system, set the UseTransitions property of the BackorderPartRequestSetup object, or the useTransitions parameter of the respective overloads to false. Note that the last call to BackorderPartRequest in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

NOTE: This API requires two other APIs (PartTransfer and CreatePartRequestDetail) to work correctly.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.BackorderPartRequestSetup


BackorderPartRequest(String,DateTime,Boolean,Int32) Method | fcSDK Documentation

BackorderPartRequest(String,DateTime,Boolean,Int32) Method

Part Request Detail Identifier

The DateTime the Part Request backordered parts are expected to arrive. If not set, the current time is used.

Specifies whether or not logistics transitions will be checked and the condition/status of the part request detail will be changed during the backorder operation

The number of parts being backordered for this Part Request

Allows for the backordering of inventory parts for a part request. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function BackorderPartRequest( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _expectedDate_ As Date, _
   ByVal _useTransitions_ As Boolean, _
   ByVal _quantity_ As Integer _
) As ToolkitResult

public ToolkitResult BackorderPartRequest(
   string _partRequestDetailIDNum_,
   DateTime _expectedDate_,
   bool _useTransitions_,
   int _quantity_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

expectedDate

The DateTime the Part Request backordered parts are expected to arrive. If not set, the current time is used.

useTransitions

Specifies whether or not logistics transitions will be checked and the condition/status of the part request detail will be changed during the backorder operation

quantity

The number of parts being backordered for this Part Request

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

As in base Clarify, if a partial backorder is performed, the part request is broken up into two new part requests. The first is for the backorder (and the quantities are changed). The new part request will be created to hold the rest of the units that did not get backordered.

This API will validate that the part request can be transitioned (for the specified user) to the proper new condition.

This API will work with either quantity or serialized parts, based on the part number/site_part of the part request. If a serial number is specified, it will be used. Otherwise, the serial number will be taken from the part request.

To use primary bin suggestions/recommendations, please see the remarks on the ToLocation and/or FromLocation properties on the BackorderPartRequestSetup object.

To allow for multiple calls to this API to be performed without extra complex transitions being added to the system, set the UseTransitions property of the BackorderPartRequestSetup object, or the useTransitions parameter of the respective overloads to false. Note that the last call to BackorderPartRequest in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

NOTE: This API requires two other APIs (PartTransfer and CreatePartRequestDetail) to work correctly.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


BackorderPartRequest(String,DateTime,Boolean,String) Method | fcSDK Documentation

BackorderPartRequest(String,DateTime,Boolean,String) Method

Part Request Detail Identifier

The DateTime the Part Request backordered parts are expected to arrive. If not set, the current time is used.

Specifies whether or not logistics transitions will be checked and the condition/status of the part request detail will be changed during the backorder operation

The serial number of the part used to backorder this Part Request

Allows for the backordering of inventory parts for a part request. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function BackorderPartRequest( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _expectedDate_ As Date, _
   ByVal _useTransitions_ As Boolean, _
   ByVal _serialNumber_ As String _
) As ToolkitResult

public ToolkitResult BackorderPartRequest(
   string _partRequestDetailIDNum_,
   DateTime _expectedDate_,
   bool _useTransitions_,
   string _serialNumber_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

expectedDate

The DateTime the Part Request backordered parts are expected to arrive. If not set, the current time is used.

useTransitions

Specifies whether or not logistics transitions will be checked and the condition/status of the part request detail will be changed during the backorder operation

serialNumber

The serial number of the part used to backorder this Part Request

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

As in base Clarify, if a partial backorder is performed, the part request is broken up into two new part requests. The first is for the backorder (and the quantities are changed). The new part request will be created to hold the rest of the units that did not get backordered.

This API will validate that the part request can be transitioned (for the specified user) to the proper new condition.

This API will work with either quantity or serialized parts, based on the part number/site_part of the part request. If a serial number is specified, it will be used. Otherwise, the serial number will be taken from the part request.

To use primary bin suggestions/recommendations, please see the remarks on the ToLocation and/or FromLocation properties on the BackorderPartRequestSetup object.

To allow for multiple calls to this API to be performed without extra complex transitions being added to the system, set the UseTransitions property of the BackorderPartRequestSetup object, or the useTransitions parameter of the respective overloads to false. Note that the last call to BackorderPartRequest in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

NOTE: This API requires two other APIs (PartTransfer and CreatePartRequestDetail) to work correctly.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


BackorderPartRequest(BackorderPartRequestSetup) Method | fcSDK Documentation

BackorderPartRequest(BackorderPartRequestSetup) Method

Setup object for API invocation.

Allows for the backordering of inventory parts for a part request. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function BackorderPartRequest( _
   ByVal _setupParam_ BackorderPartRequestSetup _
) As ToolkitResult

public ToolkitResult BackorderPartRequest(
   BackorderPartRequestSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

As in base Clarify, if a partial backorder is performed, the part request is broken up into two new part requests. The first is for the backorder (and the quantities are changed). The new part request will be created to hold the rest of the units that did not get backordered.

This API will validate that the part request can be transitioned (for the specified user) to the proper new condition.

This API will work with either quantity or serialized parts, based on the part number/site_part of the part request. If a serial number is specified, it will be used. Otherwise, the serial number will be taken from the part request.

To use primary bin suggestions/recommendations, please see the remarks on the ToLocation and/or FromLocation properties on the BackorderPartRequestSetup object.

To allow for multiple calls to this API to be performed without extra complex transitions being added to the system, set the UseTransitions property of the BackorderPartRequestSetup object, or the useTransitions parameter of the respective overloads to false. Note that the last call to BackorderPartRequest in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

NOTE: This API requires two other APIs (PartTransfer and CreatePartRequestDetail) to work correctly.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.BackorderPartRequestSetup


BackorderPartRequest(BackorderPartRequestSetup,IDbTransaction) Method | fcSDK Documentation

BackorderPartRequest(BackorderPartRequestSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Allows for the backordering of inventory parts for a part request. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function BackorderPartRequest( _
   ByVal _setupParam_ As BackorderPartRequestSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult BackorderPartRequest(
   BackorderPartRequestSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

As in base Clarify, if a partial backorder is performed, the part request is broken up into two new part requests. The first is for the backorder (and the quantities are changed). The new part request will be created to hold the rest of the units that did not get backordered.

This API will validate that the part request can be transitioned (for the specified user) to the proper new condition.

This API will work with either quantity or serialized parts, based on the part number/site_part of the part request. If a serial number is specified, it will be used. Otherwise, the serial number will be taken from the part request.

To use primary bin suggestions/recommendations, please see the remarks on the ToLocation and/or FromLocation properties on the BackorderPartRequestSetup object.

To allow for multiple calls to this API to be performed without extra complex transitions being added to the system, set the UseTransitions property of the BackorderPartRequestSetup object, or the useTransitions parameter of the respective overloads to false. Note that the last call to BackorderPartRequest in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

NOTE: This API requires two other APIs (PartTransfer and CreatePartRequestDetail) to work correctly.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


BackorderPartRequest(String,DateTime,Int32) Method | fcSDK Documentation

BackorderPartRequest(String,DateTime,Int32) Method

Part Request Detail Identifier

The DateTime the Part Request backordered parts are expected to arrive. If not set, the current time is used.

The number of parts being backordered for this Part Request

Allows for the backordering of inventory parts for a part request. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function BackorderPartRequest( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _expectedDate_ As Date, _
   ByVal _quantity_ As Integer _
) As ToolkitResult

public ToolkitResult BackorderPartRequest(
   string _partRequestDetailIDNum_,
   DateTime _expectedDate_,
   int _quantity_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

expectedDate

The DateTime the Part Request backordered parts are expected to arrive. If not set, the current time is used.

quantity

The number of parts being backordered for this Part Request

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

As in base Clarify, if a partial backorder is performed, the part request is broken up into two new part requests. The first is for the backorder (and the quantities are changed). The new part request will be created to hold the rest of the units that did not get backordered.

This API will validate that the part request can be transitioned (for the specified user) to the proper new condition.

This API will work with either quantity or serialized parts, based on the part number/site_part of the part request. If a serial number is specified, it will be used. Otherwise, the serial number will be taken from the part request.

To use primary bin suggestions/recommendations, please see the remarks on the ToLocation and/or FromLocation properties on the BackorderPartRequestSetup object.

To allow for multiple calls to this API to be performed without extra complex transitions being added to the system, set the UseTransitions property of the BackorderPartRequestSetup object, or the useTransitions parameter of the respective overloads to false. Note that the last call to BackorderPartRequest in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

NOTE: This API requires two other APIs (PartTransfer and CreatePartRequestDetail) to work correctly.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


BackorderPartRequest(String,DateTime,String) Method | fcSDK Documentation

BackorderPartRequest(String,DateTime,String) Method

Part Request Detail Identifier

The DateTime the Part Request backordered parts are expected to arrive. If not set, the current time is used.

The serial number of the part used to backorder this Part Request

Allows for the backordering of inventory parts for a part request. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function BackorderPartRequest( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _expectedDate_ As Date, _
   ByVal _serialNumber_ As String _
) As ToolkitResult

public ToolkitResult BackorderPartRequest(
   string _partRequestDetailIDNum_,
   DateTime _expectedDate_,
   string _serialNumber_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

expectedDate

The DateTime the Part Request backordered parts are expected to arrive. If not set, the current time is used.

serialNumber

The serial number of the part used to backorder this Part Request

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

As in base Clarify, if a partial backorder is performed, the part request is broken up into two new part requests. The first is for the backorder (and the quantities are changed). The new part request will be created to hold the rest of the units that did not get backordered.

This API will validate that the part request can be transitioned (for the specified user) to the proper new condition.

This API will work with either quantity or serialized parts, based on the part number/site_part of the part request. If a serial number is specified, it will be used. Otherwise, the serial number will be taken from the part request.

To use primary bin suggestions/recommendations, please see the remarks on the ToLocation and/or FromLocation properties on the BackorderPartRequestSetup object.

To allow for multiple calls to this API to be performed without extra complex transitions being added to the system, set the UseTransitions property of the BackorderPartRequestSetup object, or the useTransitions parameter of the respective overloads to false. Note that the last call to BackorderPartRequest in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

NOTE: This API requires two other APIs (PartTransfer and CreatePartRequestDetail) to work correctly.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


ChangePartRequestStatus Method | fcSDK Documentation

ChangePartRequestStatus Method

Causes the specified part request to have a status change from one status to another status – always in the same condition. This overload takes a set of required parameters for the API.

Causes the specified part request to have a status change from one status to another status – always in the same condition.

Overload List

Overload | Description
ChangePartRequestStatus(String) | Causes the specified part request to have a status change from one status to another status – always in the same condition. This overload takes a set of required parameters for the API.
ChangePartRequestStatus(ChangePartRequestStatusSetup) | Causes the specified part request to have a status change from one status to another status – always in the same condition. This overload takes a setup object.
ChangePartRequestStatus(ChangePartRequestStatusSetup,IDbTransaction) | Causes the specified part request to have a status change from one status to another status – always in the same condition. This overload takes a setup object and a database transaction.

Remarks

This API only changes a Part Request's status. To change the condition of the part request, use one of the supplied APIs such as ReceivePartRequest or Pick.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.ChangePartRequestStatusSetup


ChangePartRequestStatus(String) Method | fcSDK Documentation

ChangePartRequestStatus(String) Method

Part Request Detail Identifier

Causes the specified part request to have a status change from one status to another status – always in the same condition. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function ChangePartRequestStatus( _
   ByVal _partRequestDetailIDNum_ As String _
) As ToolkitResult

public ToolkitResult ChangePartRequestStatus(
   string _partRequestDetailIDNum_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

This API only changes a Part Request's status. To change the condition of the part request, use one of the supplied APIs such as ReceivePartRequest or Pick.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


ChangePartRequestStatus(ChangePartRequestStatusSetup) Method | fcSDK Documentation

ChangePartRequestStatus(ChangePartRequestStatusSetup) Method

Setup object for API invocation.

Causes the specified part request to have a status change from one status to another status – always in the same condition. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function ChangePartRequestStatus( _
   ByVal _setupParam_ ChangePartRequestStatusSetup _
) As ToolkitResult

public ToolkitResult ChangePartRequestStatus(
   ChangePartRequestStatusSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

This API only changes a Part Request's status. To change the condition of the part request, use one of the supplied APIs such as ReceivePartRequest or Pick.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.ChangePartRequestStatusSetup


ChangePartRequestStatus(ChangePartRequestStatusSetup,IDbTransaction) Method | fcSDK Documentation

ChangePartRequestStatus(ChangePartRequestStatusSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Causes the specified part request to have a status change from one status to another status – always in the same condition. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function ChangePartRequestStatus( _
   ByVal _setupParam_ As ChangePartRequestStatusSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult ChangePartRequestStatus(
   ChangePartRequestStatusSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

This API only changes a Part Request's status. To change the condition of the part request, use one of the supplied APIs such as ReceivePartRequest or Pick.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


ClosePartRequest Method | fcSDK Documentation

ClosePartRequest Method

Causes the specified part request to be closed. This overload takes a set of required parameters for the API.

Causes the specified part request to be closed.

Overload List

Overload | Description
ClosePartRequest(String) | Causes the specified part request to be closed. This overload takes a set of required parameters for the API.
ClosePartRequest(ClosePartRequestSetup) | Causes the specified part request to be closed. This overload takes a setup object.
ClosePartRequest(ClosePartRequestSetup,IDbTransaction) | Causes the specified part request to be closed. This overload takes a setup object and a database transaction.

Remarks

This API will validate that the user has the authority to close the part request. If this is the last part request detail that was open for the part request header, the header is also closed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.ClosePartRequestSetup


ClosePartRequest(String) Method | fcSDK Documentation

ClosePartRequest(String) Method

Part Request Detail Identifier

Causes the specified part request to be closed. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function ClosePartRequest( _
   ByVal _partRequestDetailIDNum_ As String _
) As ToolkitResult

public ToolkitResult ClosePartRequest(
   string _partRequestDetailIDNum_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

This API will validate that the user has the authority to close the part request. If this is the last part request detail that was open for the part request header, the header is also closed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


ClosePartRequest(ClosePartRequestSetup) Method | fcSDK Documentation

ClosePartRequest(ClosePartRequestSetup) Method

Setup object for API invocation.

Causes the specified part request to be closed. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function ClosePartRequest( _
   ByVal _setupParam_ ClosePartRequestSetup _
) As ToolkitResult

public ToolkitResult ClosePartRequest(
   ClosePartRequestSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

This API will validate that the user has the authority to close the part request. If this is the last part request detail that was open for the part request header, the header is also closed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.ClosePartRequestSetup


ClosePartRequest(ClosePartRequestSetup,IDbTransaction) Method | fcSDK Documentation

ClosePartRequest(ClosePartRequestSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Causes the specified part request to be closed. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function ClosePartRequest( _
   ByVal _setupParam_ As ClosePartRequestSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult ClosePartRequest(
   ClosePartRequestSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

This API will validate that the user has the authority to close the part request. If this is the last part request detail that was open for the part request header, the header is also closed.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


CreateContainer Method | fcSDK Documentation

CreateContainer Method

Overload List

Overload | Description
CreateContainer(String,String) |
CreateContainer(CreateContainerSetup) |
CreateContainer(CreateContainerSetup,IDbTransaction) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members


CreateContainer(String,String) Method | fcSDK Documentation

CreateContainer(String,String) Method

Syntax

'Declaration

Public Overloads Function CreateContainer( _
   ByVal _containerName_ As String, _
   ByVal _locationName_ As String _
) As ToolkitResult

public ToolkitResult CreateContainer(
   string _containerName_,
   string _locationName_
)

Parameters

containerName

locationName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


CreateContainer(CreateContainerSetup) Method | fcSDK Documentation

CreateContainer(CreateContainerSetup) Method

Setup object for API invocation.

Syntax

'Declaration

Public Overloads Function CreateContainer( _
   ByVal _setupParam_ CreateContainerSetup _
) As ToolkitResult

public ToolkitResult CreateContainer(
   CreateContainerSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


CreateContainer(CreateContainerSetup,IDbTransaction) Method | fcSDK Documentation

CreateContainer(CreateContainerSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Syntax

'Declaration

Public Overloads Function CreateContainer( _
   ByVal _setupParam_ As CreateContainerSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreateContainer(
   CreateContainerSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


CreatePartRequestDetail Method | fcSDK Documentation

CreatePartRequestDetail Method

Used to create a new part request detail.

This overload takes a set of required parameters for the API.

Used to create a new part request detail.

Overload List

Overload | Description
CreatePartRequestDetail(String,String,String,String,Int32) | Used to create a new part request detail. This overload takes a set of required parameters for the API.
CreatePartRequestDetail(String,Int32,Int32) | Used to create a new part request detail. This overload takes a set of required parameters for the API.
CreatePartRequestDetail(String,String,String,String,String) | Used to create a new part request detail. This overload takes a set of required parameters for the API.
CreatePartRequestDetail(String,String,Int32) | Used to create a new part request detail. This overload takes a set of required parameters for the API.
CreatePartRequestDetail(CreatePartRequestDetailSetup) | Used to create a new part request detail. This overload takes a setup object.
CreatePartRequestDetail(CreatePartRequestDetailSetup,IDbTransaction) | Used to create a new part request detail. This overload takes a setup object and a database transaction.

Remarks

This API requires a part request header in addition to a part or site_part. If the site_part record is already known, it can be specified using sitePartObjid parameter or the SitePartObjid property on the CreatePartRequestDetailSetup object. Otherwise, the part_num, mod_level, and domain define the part (which can be specified either via parameters to one of this API's overloads, or via the respective properties on the CreatePartRequestDetailSetup object). If a serialized site_part was specified, the serial number should be specified instead of quantity. Otherwise, the quantity must be specified.

NOTE: If using the overload of this API that takes a CreatePartRequestDetailSetup object, the ContractItemObjid property should not be set (left as default) unless you need this functionality AND have installed the First Choice ClearCallCenter for ClearLogistics product and required schema changes. If you do not have this product and wish to use this functionality, please contact First Choice Software.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.CreatePartRequestDetailSetup


CreatePartRequestDetail(String,String,String,String,Int32) Method | fcSDK Documentation

CreatePartRequestDetail(String,String,String,String,Int32) Method

Parent Part Request Header Identifier

The Part Request number

The Part Request domain

The Part Request revision

The number of parts requested

Used to create a new part request detail.

This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreatePartRequestDetail( _
   ByVal _partRequestHeaderIDNum_ As String, _
   ByVal _partNumber_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _quantity_ As Integer _
) As CreatePartRequestDetailResult

public CreatePartRequestDetailResult CreatePartRequestDetail(
   string _partRequestHeaderIDNum_,
   string _partNumber_,
   string _partDomain_,
   string _partRevision_,
   int _quantity_
)

Parameters

partRequestHeaderIDNum

Parent Part Request Header Identifier

partNumber

The Part Request number

partDomain

The Part Request domain

partRevision

The Part Request revision

quantity

The number of parts requested

Return Value

The following values are populated in the CreatePartRequestDetailResult object returned by the API method:

  • DetailNumber - Detail Number.

Remarks

This API requires a part request header in addition to a part or site_part. If the site_part record is already known, it can be specified using sitePartObjid parameter or the SitePartObjid property on the CreatePartRequestDetailSetup object. Otherwise, the part_num, mod_level, and domain define the part (which can be specified either via parameters to one of this API's overloads, or via the respective properties on the CreatePartRequestDetailSetup object). If a serialized site_part was specified, the serial number should be specified instead of quantity. Otherwise, the quantity must be specified.

NOTE: If using the overload of this API that takes a CreatePartRequestDetailSetup object, the ContractItemObjid property should not be set (left as default) unless you need this functionality AND have installed the First Choice ClearCallCenter for ClearLogistics product and required schema changes. If you do not have this product and wish to use this functionality, please contact First Choice Software.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


CreatePartRequestDetail(String,Int32,Int32) Method | fcSDK Documentation

CreatePartRequestDetail(String,Int32,Int32) Method

Parent Part Request Header Identifier

The number of parts requested

The Objid of the Site Part to which this Part Request will be linked.

Used to create a new part request detail.

This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreatePartRequestDetail( _
   ByVal _partRequestHeaderIDNum_ As String, _
   ByVal _quantity_ As Integer, _
   ByVal _sitePartObjid_ As Integer _
) As CreatePartRequestDetailResult

public CreatePartRequestDetailResult CreatePartRequestDetail(
   string _partRequestHeaderIDNum_,
   int _quantity_,
   int _sitePartObjid_
)

Parameters

partRequestHeaderIDNum

Parent Part Request Header Identifier

quantity

The number of parts requested

sitePartObjid

The Objid of the Site Part to which this Part Request will be linked.

Return Value

The following values are populated in the CreatePartRequestDetailResult object returned by the API method:

  • DetailNumber - Detail Number.

Remarks

This API requires a part request header in addition to a part or site_part. If the site_part record is already known, it can be specified using sitePartObjid parameter or the SitePartObjid property on the CreatePartRequestDetailSetup object. Otherwise, the part_num, mod_level, and domain define the part (which can be specified either via parameters to one of this API's overloads, or via the respective properties on the CreatePartRequestDetailSetup object). If a serialized site_part was specified, the serial number should be specified instead of quantity. Otherwise, the quantity must be specified.

NOTE: If using the overload of this API that takes a CreatePartRequestDetailSetup object, the ContractItemObjid property should not be set (left as default) unless you need this functionality AND have installed the First Choice ClearCallCenter for ClearLogistics product and required schema changes. If you do not have this product and wish to use this functionality, please contact First Choice Software.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


CreatePartRequestDetail(String,String,String,String,String) Method | fcSDK Documentation

CreatePartRequestDetail(String,String,String,String,String) Method

Parent Part Request Header Identifier

The Part Request number

The Part Request domain

The Part Request revision

The serial number of the Site Part specified for this Part Request

Used to create a new part request detail.

This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreatePartRequestDetail( _
   ByVal _partRequestHeaderIDNum_ As String, _
   ByVal _partNumber_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _serialNumber_ As String _
) As CreatePartRequestDetailResult

public CreatePartRequestDetailResult CreatePartRequestDetail(
   string _partRequestHeaderIDNum_,
   string _partNumber_,
   string _partDomain_,
   string _partRevision_,
   string _serialNumber_
)

Parameters

partRequestHeaderIDNum

Parent Part Request Header Identifier

partNumber

The Part Request number

partDomain

The Part Request domain

partRevision

The Part Request revision

serialNumber

The serial number of the Site Part specified for this Part Request

Return Value

The following values are populated in the CreatePartRequestDetailResult object returned by the API method:

  • DetailNumber - Detail Number.
  • Objid - The Objid of the DemandDetail.

Remarks

This API requires a part request header in addition to a part or site_part. If the site_part record is already known, it can be specified using sitePartObjid parameter or the SitePartObjid property on the CreatePartRequestDetailSetup object. Otherwise, the part_num, mod_level, and domain define the part (which can be specified either via parameters to one of this API's overloads, or via the respective properties on the CreatePartRequestDetailSetup object). If a serialized site_part was specified, the serial number should be specified instead of quantity. Otherwise, the quantity must be specified.

NOTE: If using the overload of this API that takes a CreatePartRequestDetailSetup object, the ContractItemObjid property should not be set (left as default) unless you need this functionality AND have installed the First Choice ClearCallCenter for ClearLogistics product and required schema changes. If you do not have this product and wish to use this functionality, please contact First Choice Software.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


CreatePartRequestDetail(String,String,Int32) Method | fcSDK Documentation

CreatePartRequestDetail(String,String,Int32) Method

Parent Part Request Header Identifier

The serial number of the Site Part specified for this Part Request

The Objid of the Site Part to which this Part Request will be linked.

Used to create a new part request detail.

This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreatePartRequestDetail( _
   ByVal _partRequestHeaderIDNum_ As String, _
   ByVal _serialNumber_ As String, _
   ByVal _sitePartObjid_ As Integer _
) As CreatePartRequestDetailResult

public CreatePartRequestDetailResult CreatePartRequestDetail(
   string _partRequestHeaderIDNum_,
   string _serialNumber_,
   int _sitePartObjid_
)

Parameters

partRequestHeaderIDNum

Parent Part Request Header Identifier

serialNumber

The serial number of the Site Part specified for this Part Request

sitePartObjid

The Objid of the Site Part to which this Part Request will be linked.

Return Value

The following values are populated in the CreatePartRequestDetailResult object returned by the API method:

  • DetailNumber - Detail Number.

Remarks

This API requires a part request header in addition to a part or site_part. If the site_part record is already known, it can be specified using sitePartObjid parameter or the SitePartObjid property on the CreatePartRequestDetailSetup object. Otherwise, the part_num, mod_level, and domain define the part (which can be specified either via parameters to one of this API's overloads, or via the respective properties on the CreatePartRequestDetailSetup object). If a serialized site_part was specified, the serial number should be specified instead of quantity. Otherwise, the quantity must be specified.

NOTE: If using the overload of this API that takes a CreatePartRequestDetailSetup object, the ContractItemObjid property should not be set (left as default) unless you need this functionality AND have installed the First Choice ClearCallCenter for ClearLogistics product and required schema changes. If you do not have this product and wish to use this functionality, please contact First Choice Software.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


CreatePartRequestDetail(CreatePartRequestDetailSetup) Method | fcSDK Documentation

CreatePartRequestDetail(CreatePartRequestDetailSetup) Method

Setup object for API invocation.

Used to create a new part request detail.

This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreatePartRequestDetail( _
   ByVal _setupParam_ As CreatePartRequestDetailSetup _
) As CreatePartRequestDetailResult

public CreatePartRequestDetailResult CreatePartRequestDetail(
   CreatePartRequestDetailSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the CreatePartRequestDetailResult object returned by the API method:

  • Objid - The Objid of the DemandDetail.
  • DetailNumber - Detail Number.

Remarks

This API requires a part request header in addition to a part or site_part. If the site_part record is already known, it can be specified using sitePartObjid parameter or the SitePartObjid property on the CreatePartRequestDetailSetup object. Otherwise, the part_num, mod_level, and domain define the part (which can be specified either via parameters to one of this API's overloads, or via the respective properties on the CreatePartRequestDetailSetup object). If a serialized site_part was specified, the serial number should be specified instead of quantity. Otherwise, the quantity must be specified.

NOTE: If using the overload of this API that takes a CreatePartRequestDetailSetup object, the ContractItemObjid property should not be set (left as default) unless you need this functionality AND have installed the First Choice ClearCallCenter for ClearLogistics product and required schema changes. If you do not have this product and wish to use this functionality, please contact First Choice Software.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.CreatePartRequestDetailSetup


CreatePartRequestDetail(CreatePartRequestDetailSetup,IDbTransaction) Method | fcSDK Documentation

CreatePartRequestDetail(CreatePartRequestDetailSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to create a new part request detail.

This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreatePartRequestDetail( _
   ByVal _setupParam_ As CreatePartRequestDetailSetup, _
   ByVal _transaction_ As IDbTransaction _
) As CreatePartRequestDetailResult

public CreatePartRequestDetailResult CreatePartRequestDetail(
   CreatePartRequestDetailSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A CreatePartRequestDetailResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

This API requires a part request header in addition to a part or site_part. If the site_part record is already known, it can be specified using sitePartObjid parameter or the SitePartObjid property on the CreatePartRequestDetailSetup object. Otherwise, the part_num, mod_level, and domain define the part (which can be specified either via parameters to one of this API's overloads, or via the respective properties on the CreatePartRequestDetailSetup object). If a serialized site_part was specified, the serial number should be specified instead of quantity. Otherwise, the quantity must be specified.

NOTE: If using the overload of this API that takes a CreatePartRequestDetailSetup object, the ContractItemObjid property should not be set (left as default) unless you need this functionality AND have installed the First Choice ClearCallCenter for ClearLogistics product and required schema changes. If you do not have this product and wish to use this functionality, please contact First Choice Software.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


CreatePartRequestHeader Method | fcSDK Documentation

CreatePartRequestHeader Method

Used to create a new part request header.

This overload takes a set of required parameters for the API.

Used to create a new part request header.

Overload List

Overload | Description
CreatePartRequestHeader(String,String,String,String) | Used to create a new part request header. This overload takes a set of required parameters for the API.
CreatePartRequestHeader(CreatePartRequestHeaderSetup) | Used to create a new part request header. This overload takes a setup object.
CreatePartRequestHeader(CreatePartRequestHeaderSetup,IDbTransaction) | Used to create a new part request header. This overload takes a setup object and a database transaction.

Remarks

If using the CreatePartRequestHeaderSetup variant of this API, and if the CaseIDNum property on the CreatePartRequestHeaderSetup object is set to a value, and there is a dash ("-") in the identifier, it will be assumed that it is a subcase identifier. Otherwise, it will be treated as a case identifier.

To create a Part Request Header for a case or subcase, without respect for dashes ("-") in the case/subcase identifier, see the CreatePartRequestHeaderCase or the CreatePartRequestHeaderSubcase APIs respectively.

NOTE: If you have one or more dashes ("-") in your case identifier numbering scheme, you MUST use one of the two CreatePartRequestHeaderCase/Subcase variants. Do not use this API (CreatePartRequestHeader) as it will mistakenly identify every case identifier as a subcase.

NOTE: The ContractObjId property on the CreatePartRequestHeaderSetup object should not be set (left as default) unless you need this functionality AND have installed the First Choice ClearCallCenter for ClearLogistics product and schema changes. If you do not have this product and wish to use this functionality, please contact First Choice Software.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.CreatePartRequestHeaderSetup


CreatePartRequestHeader(String,String,String,String) Method | fcSDK Documentation

CreatePartRequestHeader(String,String,String,String) Method

Contact's first name.

Contact's last name.

Contact's phone number.

Identifier of the Site where this Part Request should be shipped

Used to create a new part request header.

This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreatePartRequestHeader( _
   ByVal _contactFirstName_ As String, _
   ByVal _contactLastName_ As String, _
   ByVal _contactPhone_ As String, _
   ByVal _shipToSiteIDNum_ As String _
) As ToolkitResult

public ToolkitResult CreatePartRequestHeader(
   string _contactFirstName_,
   string _contactLastName_,
   string _contactPhone_,
   string _shipToSiteIDNum_
)

Parameters

contactFirstName

Contact's first name.

contactLastName

Contact's last name.

contactPhone

Contact's phone number.

shipToSiteIDNum

Identifier of the Site where this Part Request should be shipped

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Header.
  • IDNum - The IDNum of the Header.

Remarks

If using the CreatePartRequestHeaderSetup variant of this API, and if the CaseIDNum property on the CreatePartRequestHeaderSetup object is set to a value, and there is a dash ("-") in the identifier, it will be assumed that it is a subcase identifier. Otherwise, it will be treated as a case identifier.

To create a Part Request Header for a case or subcase, without respect for dashes ("-") in the case/subcase identifier, see the CreatePartRequestHeaderCase or the CreatePartRequestHeaderSubcase APIs respectively.

NOTE: If you have one or more dashes ("-") in your case identifier numbering scheme, you MUST use one of the two CreatePartRequestHeaderCase/Subcase variants. Do not use this API (CreatePartRequestHeader) as it will mistakenly identify every case identifier as a subcase.

NOTE: The ContractObjId property on the CreatePartRequestHeaderSetup object should not be set (left as default) unless you need this functionality AND have installed the First Choice ClearCallCenter for ClearLogistics product and schema changes. If you do not have this product and wish to use this functionality, please contact First Choice Software.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


CreatePartRequestHeader(CreatePartRequestHeaderSetup) Method | fcSDK Documentation

CreatePartRequestHeader(CreatePartRequestHeaderSetup) Method

Setup object for API invocation.

Used to create a new part request header.

This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreatePartRequestHeader( _
   ByVal _setupParam_ CreatePartRequestHeaderSetup _
) As ToolkitResult

public ToolkitResult CreatePartRequestHeader(
   CreatePartRequestHeaderSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Header.
  • IDNum - The IDNum of the Header.

Remarks

If using the CreatePartRequestHeaderSetup variant of this API, and if the CaseIDNum property on the CreatePartRequestHeaderSetup object is set to a value, and there is a dash ("-") in the identifier, it will be assumed that it is a subcase identifier. Otherwise, it will be treated as a case identifier.

To create a Part Request Header for a case or subcase, without respect for dashes ("-") in the case/subcase identifier, see the CreatePartRequestHeaderCase or the CreatePartRequestHeaderSubcase APIs respectively.

NOTE: If you have one or more dashes ("-") in your case identifier numbering scheme, you MUST use one of the two CreatePartRequestHeaderCase/Subcase variants. Do not use this API (CreatePartRequestHeader) as it will mistakenly identify every case identifier as a subcase.

NOTE: The ContractObjId property on the CreatePartRequestHeaderSetup object should not be set (left as default) unless you need this functionality AND have installed the First Choice ClearCallCenter for ClearLogistics product and schema changes. If you do not have this product and wish to use this functionality, please contact First Choice Software.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.CreatePartRequestHeaderSetup


CreatePartRequestHeader(CreatePartRequestHeaderSetup,IDbTransaction) Method | fcSDK Documentation

CreatePartRequestHeader(CreatePartRequestHeaderSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to create a new part request header.

This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreatePartRequestHeader( _
   ByVal _setupParam_ As CreatePartRequestHeaderSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreatePartRequestHeader(
   CreatePartRequestHeaderSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

If using the CreatePartRequestHeaderSetup variant of this API, and if the CaseIDNum property on the CreatePartRequestHeaderSetup object is set to a value, and there is a dash ("-") in the identifier, it will be assumed that it is a subcase identifier. Otherwise, it will be treated as a case identifier.

To create a Part Request Header for a case or subcase, without respect for dashes ("-") in the case/subcase identifier, see the CreatePartRequestHeaderCase or the CreatePartRequestHeaderSubcase APIs respectively.

NOTE: If you have one or more dashes ("-") in your case identifier numbering scheme, you MUST use one of the two CreatePartRequestHeaderCase/Subcase variants. Do not use this API (CreatePartRequestHeader) as it will mistakenly identify every case identifier as a subcase.

NOTE: The ContractObjId property on the CreatePartRequestHeaderSetup object should not be set (left as default) unless you need this functionality AND have installed the First Choice ClearCallCenter for ClearLogistics product and schema changes. If you do not have this product and wish to use this functionality, please contact First Choice Software.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


CreatePartRequestHeaderCase Method | fcSDK Documentation

CreatePartRequestHeaderCase Method

Used to create a new part request header against a case.

This overload takes a set of required parameters for the API.

Used to create a new part request header against a case.

Overload List

| Overload | Description | | --- | --- | | CreatePartRequestHeaderCase(String,String,String,String,String) | Used to create a new part request header against a case.

This overload takes a set of required parameters for the API. | | CreatePartRequestHeaderCase(CreatePartRequestHeaderCaseSetup) |

Used to create a new part request header against a case.

This overload takes a setup object. | | CreatePartRequestHeaderCase(CreatePartRequestHeaderCaseSetup,IDbTransaction) |

Used to create a new part request header against a case.

This overload takes a setup object and a database transaction. |

Remarks

NOTE: The ContractObjId property on the CreatePartRequestHeaderCaseSetup object should not be set (left as default) unless you need this functionality AND have installed the First Choice ClearCallCenter for ClearLogistics product and schema changes. If you do not have this product and wish to use this functionality, please contact First Choice Software.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.CreatePartRequestHeaderCaseSetup


CreatePartRequestHeaderCase(String,String,String,String,String) Method | fcSDK Documentation

CreatePartRequestHeaderCase(String,String,String,String,String) Method

Contact's first name.

Contact's last name.

Contact's phone number.

Identifier of the Site where this Part Request is being shipped

The identifier of the Case with which this Part Request is associated

Used to create a new part request header against a case.

This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreatePartRequestHeaderCase( _
   ByVal _contactFirstName_ As String, _
   ByVal _contactLastName_ As String, _
   ByVal _contactPhone_ As String, _
   ByVal _shipToSiteIDNum_ As String, _
   ByVal _caseIDNum_ As String _
) As ToolkitResult

public ToolkitResult CreatePartRequestHeaderCase(
   string _contactFirstName_,
   string _contactLastName_,
   string _contactPhone_,
   string _shipToSiteIDNum_,
   string _caseIDNum_
)

Parameters

contactFirstName

Contact's first name.

contactLastName

Contact's last name.

contactPhone

Contact's phone number.

shipToSiteIDNum

Identifier of the Site where this Part Request is being shipped

caseIDNum

The identifier of the Case with which this Part Request is associated

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Header.
  • IDNum - The IDNum of the Header.

Remarks

NOTE: The ContractObjId property on the CreatePartRequestHeaderCaseSetup object should not be set (left as default) unless you need this functionality AND have installed the First Choice ClearCallCenter for ClearLogistics product and schema changes. If you do not have this product and wish to use this functionality, please contact First Choice Software.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


CreatePartRequestHeaderCase(CreatePartRequestHeaderCaseSetup) Method | fcSDK Documentation

CreatePartRequestHeaderCase(CreatePartRequestHeaderCaseSetup) Method

Setup object for API invocation.

Used to create a new part request header against a case.

This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreatePartRequestHeaderCase( _
   ByVal _setupParam_ CreatePartRequestHeaderCaseSetup _
) As ToolkitResult

public ToolkitResult CreatePartRequestHeaderCase(
   CreatePartRequestHeaderCaseSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Header.
  • IDNum - The IDNum of the Header.

Remarks

NOTE: The ContractObjId property on the CreatePartRequestHeaderCaseSetup object should not be set (left as default) unless you need this functionality AND have installed the First Choice ClearCallCenter for ClearLogistics product and schema changes. If you do not have this product and wish to use this functionality, please contact First Choice Software.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.CreatePartRequestHeaderCaseSetup


CreatePartRequestHeaderCase(CreatePartRequestHeaderCaseSetup,IDbTransaction) Method | fcSDK Documentation

CreatePartRequestHeaderCase(CreatePartRequestHeaderCaseSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to create a new part request header against a case.

This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreatePartRequestHeaderCase( _
   ByVal _setupParam_ As CreatePartRequestHeaderCaseSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreatePartRequestHeaderCase(
   CreatePartRequestHeaderCaseSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

NOTE: The ContractObjId property on the CreatePartRequestHeaderCaseSetup object should not be set (left as default) unless you need this functionality AND have installed the First Choice ClearCallCenter for ClearLogistics product and schema changes. If you do not have this product and wish to use this functionality, please contact First Choice Software.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


CreatePartRequestHeaderSubcase Method | fcSDK Documentation

CreatePartRequestHeaderSubcase Method

Used to create a new part request header against a subcase.

This overload takes a set of required parameters for the API.

Used to create a new part request header against a subcase.

Overload List

| Overload | Description | | --- | --- | | CreatePartRequestHeaderSubcase(String,String,String,String,String) | Used to create a new part request header against a subcase.

This overload takes a set of required parameters for the API. | | CreatePartRequestHeaderSubcase(CreatePartRequestHeaderSubcaseSetup) |

Used to create a new part request header against a subcase.

This overload takes a setup object. | | CreatePartRequestHeaderSubcase(CreatePartRequestHeaderSubcaseSetup,IDbTransaction) |

Used to create a new part request header against a subcase.

This overload takes a setup object and a database transaction. |

Remarks

Use this API to explicitly create part request headers for subcases (as opposed to cases or subcases). This is useful if the case ID numbering scheme contains dashes ('-').

NOTE: The ContractObjId property on the CreatePartRequestHeaderCaseSetup object should not be set (left as default) unless you need this functionality AND have installed the First Choice ClearCallCenter for ClearLogistics product and schema changes. If you do not have this product and wish to use this functionality, please contact First Choice Software.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.CreatePartRequestHeaderSubcaseSetup


CreatePartRequestHeaderSubcase(String,String,String,String,String) Method | fcSDK Documentation

CreatePartRequestHeaderSubcase(String,String,String,String,String) Method

Contact's first name.

Contact's last name.

Contact's phone number.

Identifier of the site where this Part Request should be shipped

Identifier of the Subcase with which this Part Request is associated

Used to create a new part request header against a subcase.

This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreatePartRequestHeaderSubcase( _
   ByVal _contactFirstName_ As String, _
   ByVal _contactLastName_ As String, _
   ByVal _contactPhone_ As String, _
   ByVal _shipToSiteIDNum_ As String, _
   ByVal _caseIDNum_ As String _
) As ToolkitResult

public ToolkitResult CreatePartRequestHeaderSubcase(
   string _contactFirstName_,
   string _contactLastName_,
   string _contactPhone_,
   string _shipToSiteIDNum_,
   string _caseIDNum_
)

Parameters

contactFirstName

Contact's first name.

contactLastName

Contact's last name.

contactPhone

Contact's phone number.

shipToSiteIDNum

Identifier of the site where this Part Request should be shipped

caseIDNum

Identifier of the Subcase with which this Part Request is associated

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Header.
  • IDNum - The IDNum of the Header.

Remarks

Use this API to explicitly create part request headers for subcases (as opposed to cases or subcases). This is useful if the case ID numbering scheme contains dashes ('-').

NOTE: The ContractObjId property on the CreatePartRequestHeaderCaseSetup object should not be set (left as default) unless you need this functionality AND have installed the First Choice ClearCallCenter for ClearLogistics product and schema changes. If you do not have this product and wish to use this functionality, please contact First Choice Software.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


CreatePartRequestHeaderSubcase(CreatePartRequestHeaderSubcaseSetup) Method | fcSDK Documentation

CreatePartRequestHeaderSubcase(CreatePartRequestHeaderSubcaseSetup) Method

Setup object for API invocation.

Used to create a new part request header against a subcase.

This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreatePartRequestHeaderSubcase( _
   ByVal _setupParam_ CreatePartRequestHeaderSubcaseSetup _
) As ToolkitResult

public ToolkitResult CreatePartRequestHeaderSubcase(
   CreatePartRequestHeaderSubcaseSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Header.
  • IDNum - The IDNum of the Header.

Remarks

Use this API to explicitly create part request headers for subcases (as opposed to cases or subcases). This is useful if the case ID numbering scheme contains dashes ('-').

NOTE: The ContractObjId property on the CreatePartRequestHeaderCaseSetup object should not be set (left as default) unless you need this functionality AND have installed the First Choice ClearCallCenter for ClearLogistics product and schema changes. If you do not have this product and wish to use this functionality, please contact First Choice Software.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.CreatePartRequestHeaderSubcaseSetup


CreatePartRequestHeaderSubcase(CreatePartRequestHeaderSubcaseSetup,IDbTransaction) Method | fcSDK Documentation

CreatePartRequestHeaderSubcase(CreatePartRequestHeaderSubcaseSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to create a new part request header against a subcase.

This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreatePartRequestHeaderSubcase( _
   ByVal _setupParam_ As CreatePartRequestHeaderSubcaseSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreatePartRequestHeaderSubcase(
   CreatePartRequestHeaderSubcaseSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

Use this API to explicitly create part request headers for subcases (as opposed to cases or subcases). This is useful if the case ID numbering scheme contains dashes ('-').

NOTE: The ContractObjId property on the CreatePartRequestHeaderCaseSetup object should not be set (left as default) unless you need this functionality AND have installed the First Choice ClearCallCenter for ClearLogistics product and schema changes. If you do not have this product and wish to use this functionality, please contact First Choice Software.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


CreateSubContainer Method | fcSDK Documentation

CreateSubContainer Method

Overload List

Overload | Description
CreateSubContainer(String,String) |
CreateSubContainer(CreateSubContainerSetup) |
CreateSubContainer(CreateSubContainerSetup,IDbTransaction) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members


CreateSubContainer(String,String) Method | fcSDK Documentation

CreateSubContainer(String,String) Method

Syntax

'Declaration

Public Overloads Function CreateSubContainer( _
   ByVal _containerName_ As String, _
   ByVal _parentContainerName_ As String _
) As ToolkitResult

public ToolkitResult CreateSubContainer(
   string _containerName_,
   string _parentContainerName_
)

Parameters

containerName

parentContainerName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


CreateSubContainer(CreateSubContainerSetup) Method | fcSDK Documentation

CreateSubContainer(CreateSubContainerSetup) Method

Setup object for API invocation.

Syntax

'Declaration

Public Overloads Function CreateSubContainer( _
   ByVal _setupParam_ CreateSubContainerSetup _
) As ToolkitResult

public ToolkitResult CreateSubContainer(
   CreateSubContainerSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


CreateSubContainer(CreateSubContainerSetup,IDbTransaction) Method | fcSDK Documentation

CreateSubContainer(CreateSubContainerSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Syntax

'Declaration

Public Overloads Function CreateSubContainer( _
   ByVal _setupParam_ As CreateSubContainerSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreateSubContainer(
   CreateSubContainerSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


DeleteAlternatePart Method | fcSDK Documentation

DeleteAlternatePart Method

Causes the second part/revision listed to be removed as an alternate part for the first. This overload takes a set of required parameters for the API.

Causes the second part/revision listed to be removed as an alternate part for the first.

Overload List

Overload | Description
DeleteAlternatePart(String,String,String,String,String,String) | Causes the second part/revision listed to be removed as an alternate part for the first. This overload takes a set of required parameters for the API.
DeleteAlternatePart(DeleteAlternatePartSetup) | Causes the second part/revision listed to be removed as an alternate part for the first. This overload takes a setup object.
DeleteAlternatePart(DeleteAlternatePartSetup,IDbTransaction) | Causes the second part/revision listed to be removed as an alternate part for the first. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.DeleteAlternatePartSetup


DeleteAlternatePart(String,String,String,String,String,String) Method | fcSDK Documentation

DeleteAlternatePart(String,String,String,String,String,String) Method

The Part number

The Part revision

The Part domain

The Alternate Part number

The Alternate Part revision

The Alternate Part domain

Causes the second part/revision listed to be removed as an alternate part for the first. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function DeleteAlternatePart( _
   ByVal _partNumber_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _alternatePartNumber_ As String, _
   ByVal _alternatePartRevision_ As String, _
   ByVal _alternatePartDomain_ As String _
) As ToolkitResult

public ToolkitResult DeleteAlternatePart(
   string _partNumber_,
   string _partRevision_,
   string _partDomain_,
   string _alternatePartNumber_,
   string _alternatePartRevision_,
   string _alternatePartDomain_
)

Parameters

partNumber

The Part number

partRevision

The Part revision

partDomain

The Part domain

alternatePartNumber

The Alternate Part number

alternatePartRevision

The Alternate Part revision

alternatePartDomain

The Alternate Part domain

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


DeleteAlternatePart(DeleteAlternatePartSetup) Method | fcSDK Documentation

DeleteAlternatePart(DeleteAlternatePartSetup) Method

Setup object for API invocation.

Causes the second part/revision listed to be removed as an alternate part for the first. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function DeleteAlternatePart( _
   ByVal _setupParam_ DeleteAlternatePartSetup _
) As ToolkitResult

public ToolkitResult DeleteAlternatePart(
   DeleteAlternatePartSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.DeleteAlternatePartSetup


DeleteAlternatePart(DeleteAlternatePartSetup,IDbTransaction) Method | fcSDK Documentation

DeleteAlternatePart(DeleteAlternatePartSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Causes the second part/revision listed to be removed as an alternate part for the first. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function DeleteAlternatePart( _
   ByVal _setupParam_ As DeleteAlternatePartSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult DeleteAlternatePart(
   DeleteAlternatePartSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


DeleteLocationServicingSite Method | fcSDK Documentation

DeleteLocationServicingSite Method

Used to remove the relationship between a site and a location servicing it. This overload takes a set of required parameters for the API.

Used to remove the relationship between a site and a location servicing it.

Overload List

Overload | Description
DeleteLocationServicingSite(String,String) | Used to remove the relationship between a site and a location servicing it. This overload takes a set of required parameters for the API.
DeleteLocationServicingSite(DeleteLocationServicingSiteSetup) | Used to remove the relationship between a site and a location servicing it. This overload takes a setup object.
DeleteLocationServicingSite(DeleteLocationServicingSiteSetup,IDbTransaction) | Used to remove the relationship between a site and a location servicing it. This overload takes a setup object and a database transaction.

Remarks

As a result of a call to this API, all of the other locations that service this site will have their ranks changed as necessary.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.DeleteLocationServicingSiteSetup


DeleteLocationServicingSite(String,String) Method | fcSDK Documentation

DeleteLocationServicingSite(String,String) Method

Identifier of the Site that the inventory location was servicing

The inventory location being removed

Used to remove the relationship between a site and a location servicing it. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function DeleteLocationServicingSite( _
   ByVal _siteIDNum_ As String, _
   ByVal _locationName_ As String _
) As ToolkitResult

public ToolkitResult DeleteLocationServicingSite(
   string _siteIDNum_,
   string _locationName_
)

Parameters

siteIDNum

Identifier of the Site that the inventory location was servicing

locationName

The inventory location being removed

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - Objid of the Inventory Role record.

Remarks

As a result of a call to this API, all of the other locations that service this site will have their ranks changed as necessary.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


DeleteLocationServicingSite(DeleteLocationServicingSiteSetup) Method | fcSDK Documentation

DeleteLocationServicingSite(DeleteLocationServicingSiteSetup) Method

Setup object for API invocation.

Used to remove the relationship between a site and a location servicing it. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function DeleteLocationServicingSite( _
   ByVal _setupParam_ DeleteLocationServicingSiteSetup _
) As ToolkitResult

public ToolkitResult DeleteLocationServicingSite(
   DeleteLocationServicingSiteSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - Objid of the Inventory Role record.

Remarks

As a result of a call to this API, all of the other locations that service this site will have their ranks changed as necessary.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.DeleteLocationServicingSiteSetup


DeleteLocationServicingSite(DeleteLocationServicingSiteSetup,IDbTransaction) Method | fcSDK Documentation

DeleteLocationServicingSite(DeleteLocationServicingSiteSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to remove the relationship between a site and a location servicing it. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function DeleteLocationServicingSite( _
   ByVal _setupParam_ As DeleteLocationServicingSiteSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult DeleteLocationServicingSite(
   DeleteLocationServicingSiteSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

As a result of a call to this API, all of the other locations that service this site will have their ranks changed as necessary.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


DispatchPartRequest Method | fcSDK Documentation

DispatchPartRequest Method

Dispatch the PartRequest to the specified queue. This overload takes a set of required parameters for the API.

Dispatch the PartRequest to the specified queue.

Overload List

Overload | Description
DispatchPartRequest(String,String) | Dispatch the PartRequest to the specified queue. This overload takes a set of required parameters for the API.
DispatchPartRequest(DispatchPartRequestSetup) | Dispatch the PartRequest to the specified queue. This overload takes a setup object.
DispatchPartRequest(DispatchPartRequestSetup,IDbTransaction) | Dispatch the PartRequest to the specified queue. This overload takes a setup object and a database transaction.

Remarks

The PartRequest must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.DispatchPartRequestSetup


DispatchPartRequest(String,String) Method | fcSDK Documentation

DispatchPartRequest(String,String) Method

Part Request Detail Identifier

The queue into which the PartRequest is to be dispatched.

Dispatch the PartRequest to the specified queue. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function DispatchPartRequest( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _queue_ As String _
) As ToolkitResult

public ToolkitResult DispatchPartRequest(
   string _partRequestDetailIDNum_,
   string _queue_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

queue

The queue into which the PartRequest is to be dispatched.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The PartRequest must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


DispatchPartRequest(DispatchPartRequestSetup) Method | fcSDK Documentation

DispatchPartRequest(DispatchPartRequestSetup) Method

Setup object for API invocation.

Dispatch the PartRequest to the specified queue. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function DispatchPartRequest( _
   ByVal _setupParam_ DispatchPartRequestSetup _
) As ToolkitResult

public ToolkitResult DispatchPartRequest(
   DispatchPartRequestSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The PartRequest must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.DispatchPartRequestSetup


DispatchPartRequest(DispatchPartRequestSetup,IDbTransaction) Method | fcSDK Documentation

DispatchPartRequest(DispatchPartRequestSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Dispatch the PartRequest to the specified queue. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function DispatchPartRequest( _
   ByVal _setupParam_ As DispatchPartRequestSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult DispatchPartRequest(
   DispatchPartRequestSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The PartRequest must be in open condition, and not currently dispatched to a queue.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


ForwardPartRequest Method | fcSDK Documentation

ForwardPartRequest Method

Reject-forward the PartRequest from one queue to another. This overload takes a set of required parameters for the API.

Reject-forward the PartRequest from one queue to another.

Overload List

Overload | Description
ForwardPartRequest(String,String) | Reject-forward the PartRequest from one queue to another. This overload takes a set of required parameters for the API.
ForwardPartRequest(ForwardPartRequestSetup) | Reject-forward the PartRequest from one queue to another. This overload takes a setup object.
ForwardPartRequest(ForwardPartRequestSetup,IDbTransaction) | Reject-forward the PartRequest from one queue to another. This overload takes a setup object and a database transaction.

Remarks

The PartRequest must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.ForwardPartRequestSetup


ForwardPartRequest(String,String) Method | fcSDK Documentation

ForwardPartRequest(String,String) Method

Part Request Detail Identifier

The new queue into which the PartRequest is to be forwarded.

Reject-forward the PartRequest from one queue to another. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function ForwardPartRequest( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _newQueue_ As String _
) As ToolkitResult

public ToolkitResult ForwardPartRequest(
   string _partRequestDetailIDNum_,
   string _newQueue_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

newQueue

The new queue into which the PartRequest is to be forwarded.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The PartRequest must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


ForwardPartRequest(ForwardPartRequestSetup) Method | fcSDK Documentation

ForwardPartRequest(ForwardPartRequestSetup) Method

Setup object for API invocation.

Reject-forward the PartRequest from one queue to another. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function ForwardPartRequest( _
   ByVal _setupParam_ ForwardPartRequestSetup _
) As ToolkitResult

public ToolkitResult ForwardPartRequest(
   ForwardPartRequestSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The PartRequest must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.ForwardPartRequestSetup


ForwardPartRequest(ForwardPartRequestSetup,IDbTransaction) Method | fcSDK Documentation

ForwardPartRequest(ForwardPartRequestSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Reject-forward the PartRequest from one queue to another. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function ForwardPartRequest( _
   ByVal _setupParam_ As ForwardPartRequestSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult ForwardPartRequest(
   ForwardPartRequestSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The PartRequest must be in open condition, and not currently dispatched to a queue.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


FulfillPartRequest Method | fcSDK Documentation

FulfillPartRequest Method

Allows for the fulfilling of inventory parts for a part request. This overload takes a set of required parameters for the API.

Allows for the fulfilling of inventory parts for a part request.

Overload List

Overload | Description
FulfillPartRequest(String,Int32) | Allows for the fulfilling of inventory parts for a part request. This overload takes a set of required parameters for the API.
FulfillPartRequest(String,String) | Allows for the fulfilling of inventory parts for a part request. This overload takes a set of required parameters for the API.
FulfillPartRequest(String,Boolean,Int32) | Allows for the fulfilling of inventory parts for a part request. This overload takes a set of required parameters for the API.
FulfillPartRequest(String,Boolean,String) | Allows for the fulfilling of inventory parts for a part request. This overload takes a set of required parameters for the API.
FulfillPartRequest(FulfillPartRequestSetup) | Allows for the fulfilling of inventory parts for a part request. This overload takes a setup object.
FulfillPartRequest(FulfillPartRequestSetup,IDbTransaction) | Allows for the fulfilling of inventory parts for a part request. This overload takes a setup object and a database transaction.

Remarks

As in base Clarify, if a partial fulfill is performed, the part request is broken up into two new part requests. The first is for the fulfill (and the quantities are changed). The new part request will be created to hold the rest of the units that did not get fulfilled.

If useTransitions is true (the default), this API will validate that the part request can be transitioned (for the specified user) to the proper new condition.

If useTransitions is false, then the logistics transitions will NOT be checked. In addition, when useTransitions is false a partial fulfill will not create new part requests for the rest of the units that did not get fulfilled.

This API will work with either quantity or serialized parts, based on the part number/site_part of the part request. If a serial number is specified, it will be used. Otherwise, the serial number will be taken from the part request.

To use primary bin suggestions/recommendations, please see the remarks on the ToLocation and/or FromLocation properties on the FulfillPartRequestSetup object.

To allow for multiple calls to this API to be performed without extra complex transitions being added to the system, set the UseTransitions property of the FulfillPartRequestSetup object, or the useTransitions parameter of the respective overloads to false. Note that the last call to FulfillPartRequest in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly. As an example, if you wish to fulfill 10 serialized parts on one part request, you can call FulfillPartRequest method 9 times with UseTransitions set to false, then finally call the FulfillPartRequest method once with UseTransitions set to true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.FulfillPartRequestSetup


FulfillPartRequest(String,Int32) Method | fcSDK Documentation

FulfillPartRequest(String,Int32) Method

Part Request Detail Identifier

The number of parts being fulfilled for this Part Request

Allows for the fulfilling of inventory parts for a part request. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function FulfillPartRequest( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _quantity_ As Integer _
) As ToolkitResult

public ToolkitResult FulfillPartRequest(
   string _partRequestDetailIDNum_,
   int _quantity_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

quantity

The number of parts being fulfilled for this Part Request

Return Value

If a partial fulfill occurs then a new PartRequestDetail is created for the remaining items waiting to be fullfilled. When this occurs the ToolkitResult will be populated with the objid and id number of the PartRequestDetail that was just created.

Remarks

As in base Clarify, if a partial fulfill is performed, the part request is broken up into two new part requests. The first is for the fulfill (and the quantities are changed). The new part request will be created to hold the rest of the units that did not get fulfilled.

If useTransitions is true (the default), this API will validate that the part request can be transitioned (for the specified user) to the proper new condition.

This API will work with either quantity or serialized parts, based on the part number/site_part of the part request. If a serial number is specified, it will be used. Otherwise, the serial number will be taken from the part request.

To use primary bin suggestions/recommendations, please see the remarks on the ToLocation and/or FromLocation properties on the FulfillPartRequestSetup object.

To allow for multiple calls to this API to be performed without extra complex transitions being added to the system, set the UseTransitions property of the FulfillPartRequestSetup object, or the useTransitions parameter of the respective overloads to false. Note that the last call to FulfillPartRequest in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


FulfillPartRequest(String,String) Method | fcSDK Documentation

FulfillPartRequest(String,String) Method

Part Request Detail Identifier

The serial number of the part used to fulfill this Part Request

Allows for the fulfilling of inventory parts for a part request. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function FulfillPartRequest( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _serialNumber_ As String _
) As ToolkitResult

public ToolkitResult FulfillPartRequest(
   string _partRequestDetailIDNum_,
   string _serialNumber_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

serialNumber

The serial number of the part used to fulfill this Part Request

Return Value

If a partial fulfill occurs then a new PartRequestDetail is created for the remaining items waiting to be fullfilled. When this occurs the ToolkitResult will be populated with the objid and id number of the PartRequestDetail that was just created.

Remarks

As in base Clarify, if a partial fulfill is performed, the part request is broken up into two new part requests. The first is for the fulfill (and the quantities are changed). The new part request will be created to hold the rest of the units that did not get fulfilled.

If useTransitions is true (the default), this API will validate that the part request can be transitioned (for the specified user) to the proper new condition.

This API will work with either quantity or serialized parts, based on the part number/site_part of the part request. If a serial number is specified, it will be used. Otherwise, the serial number will be taken from the part request.

To use primary bin suggestions/recommendations, please see the remarks on the ToLocation and/or FromLocation properties on the FulfillPartRequestSetup object.

To allow for multiple calls to this API to be performed without extra complex transitions being added to the system, set the UseTransitions property of the FulfillPartRequestSetup object, or the useTransitions parameter of the respective overloads to false. Note that the last call to FulfillPartRequest in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


FulfillPartRequest(String,Boolean,Int32) Method | fcSDK Documentation

FulfillPartRequest(String,Boolean,Int32) Method

Part Request Detail Identifier

Specifies whether or not logistics transitions will be checked and the condition/status of the part request detail will be changed during the fulfill operation

The number of parts being fulfilled for this Part Request

Allows for the fulfilling of inventory parts for a part request. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function FulfillPartRequest( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _useTransitions_ As Boolean, _
   ByVal _quantity_ As Integer _
) As ToolkitResult

public ToolkitResult FulfillPartRequest(
   string _partRequestDetailIDNum_,
   bool _useTransitions_,
   int _quantity_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

useTransitions

Specifies whether or not logistics transitions will be checked and the condition/status of the part request detail will be changed during the fulfill operation

quantity

The number of parts being fulfilled for this Part Request

Return Value

If a partial fulfill occurs then a new PartRequestDetail is created for the remaining items waiting to be fullfilled. When this occurs the ToolkitResult will be populated with the objid and id number of the PartRequestDetail that was just created.

Remarks

As in base Clarify, if a partial fulfill is performed, the part request is broken up into two new part requests. The first is for the fulfill (and the quantities are changed). The new part request will be created to hold the rest of the units that did not get fulfilled.

If useTransitions is true (the default), this API will validate that the part request can be transitioned (for the specified user) to the proper new condition.

This API will work with either quantity or serialized parts, based on the part number/site_part of the part request. If a serial number is specified, it will be used. Otherwise, the serial number will be taken from the part request.

To use primary bin suggestions/recommendations, please see the remarks on the ToLocation and/or FromLocation properties on the FulfillPartRequestSetup object.

To allow for multiple calls to this API to be performed without extra complex transitions being added to the system, set the UseTransitions property of the FulfillPartRequestSetup object, or the useTransitions parameter of the respective overloads to false. Note that the last call to FulfillPartRequest in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


FulfillPartRequest(String,Boolean,String) Method | fcSDK Documentation

FulfillPartRequest(String,Boolean,String) Method

Part Request Detail Identifier

Specifies whether or not logistics transitions will be checked and the condition/status of the part request detail will be changed during the fulfill operation

The serial number of the part used to fulfill this Part Request

Allows for the fulfilling of inventory parts for a part request. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function FulfillPartRequest( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _useTransitions_ As Boolean, _
   ByVal _serialNumber_ As String _
) As ToolkitResult

public ToolkitResult FulfillPartRequest(
   string _partRequestDetailIDNum_,
   bool _useTransitions_,
   string _serialNumber_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

useTransitions

Specifies whether or not logistics transitions will be checked and the condition/status of the part request detail will be changed during the fulfill operation

serialNumber

The serial number of the part used to fulfill this Part Request

Return Value

If a partial fulfill occurs then a new PartRequestDetail is created for the remaining items waiting to be fullfilled. When this occurs the ToolkitResult will be populated with the objid and id number of the PartRequestDetail that was just created.

Remarks

As in base Clarify, if a partial fulfill is performed, the part request is broken up into two new part requests. The first is for the fulfill (and the quantities are changed). The new part request will be created to hold the rest of the units that did not get fulfilled.

If useTransitions is true (the default), this API will validate that the part request can be transitioned (for the specified user) to the proper new condition.

This API will work with either quantity or serialized parts, based on the part number/site_part of the part request. If a serial number is specified, it will be used. Otherwise, the serial number will be taken from the part request.

To use primary bin suggestions/recommendations, please see the remarks on the ToLocation and/or FromLocation properties on the FulfillPartRequestSetup object.

To allow for multiple calls to this API to be performed without extra complex transitions being added to the system, set the UseTransitions property of the FulfillPartRequestSetup object, or the useTransitions parameter of the respective overloads to false. Note that the last call to FulfillPartRequest in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


FulfillPartRequest(FulfillPartRequestSetup) Method | fcSDK Documentation

FulfillPartRequest(FulfillPartRequestSetup) Method

Setup object for API invocation.

Allows for the fulfilling of inventory parts for a part request. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function FulfillPartRequest( _
   ByVal _setupParam_ FulfillPartRequestSetup _
) As ToolkitResult

public ToolkitResult FulfillPartRequest(
   FulfillPartRequestSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

If a partial fulfill occurs then a new PartRequestDetail is created for the remaining items waiting to be fullfilled. When this occurs the ToolkitResult will be populated with the objid and id number of the PartRequestDetail that was just created.

Remarks

As in base Clarify, if a partial fulfill is performed, the part request is broken up into two new part requests. The first is for the fulfill (and the quantities are changed). The new part request will be created to hold the rest of the units that did not get fulfilled.

If useTransitions is true (the default), this API will validate that the part request can be transitioned (for the specified user) to the proper new condition.

This API will work with either quantity or serialized parts, based on the part number/site_part of the part request. If a serial number is specified, it will be used. Otherwise, the serial number will be taken from the part request.

To use primary bin suggestions/recommendations, please see the remarks on the ToLocation and/or FromLocation properties on the FulfillPartRequestSetup object.

To allow for multiple calls to this API to be performed without extra complex transitions being added to the system, set the UseTransitions property of the FulfillPartRequestSetup object, or the useTransitions parameter of the respective overloads to false. Note that the last call to FulfillPartRequest in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.FulfillPartRequestSetup


FulfillPartRequest(FulfillPartRequestSetup,IDbTransaction) Method | fcSDK Documentation

FulfillPartRequest(FulfillPartRequestSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Allows for the fulfilling of inventory parts for a part request. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function FulfillPartRequest( _
   ByVal _setupParam_ As FulfillPartRequestSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult FulfillPartRequest(
   FulfillPartRequestSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

If a partial fulfill occurs then a new PartRequestDetail is created for the remaining items waiting to be fullfilled. When this occurs the ToolkitResult will be populated with the objid and id number of the PartRequestDetail that was just created.

Remarks

As in base Clarify, if a partial fulfill is performed, the part request is broken up into two new part requests. The first is for the fulfill (and the quantities are changed). The new part request will be created to hold the rest of the units that did not get fulfilled.

If useTransitions is true (the default), this API will validate that the part request can be transitioned (for the specified user) to the proper new condition.

This API will work with either quantity or serialized parts, based on the part number/site_part of the part request. If a serial number is specified, it will be used. Otherwise, the serial number will be taken from the part request.

To use primary bin suggestions/recommendations, please see the remarks on the ToLocation and/or FromLocation properties on the FulfillPartRequestSetup object.

To allow for multiple calls to this API to be performed without extra complex transitions being added to the system, set the UseTransitions property of the FulfillPartRequestSetup object, or the useTransitions parameter of the respective overloads to false. Note that the last call to FulfillPartRequest in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


GetAlternateParts Method | fcSDK Documentation

GetAlternateParts Method

Builds a list of the alternate parts (table_partnum_view) for the specified part and revision, and returns an array of part Objids This overload takes a set of required parameters for the API.

Builds a list of the alternate parts (table_partnum_view) for the specified part and revision, and returns an array of part Objids

Overload List

Overload | Description
GetAlternateParts(String,String,String) | Builds a list of the alternate parts (table_partnum_view) for the specified part and revision, and returns an array of part Objids This overload takes a set of required parameters for the API.
GetAlternateParts(GetAlternatePartsSetup) | Builds a list of the alternate parts (table_partnum_view) for the specified part and revision, and returns an array of part Objids This overload takes a setup object.
GetAlternateParts(GetAlternatePartsSetup,IDbTransaction) | Builds a list of the alternate parts (table_partnum_view) for the specified part and revision, and returns an array of part Objids This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.GetAlternatePartsSetup


GetAlternateParts(String,String,String) Method | fcSDK Documentation

GetAlternateParts(String,String,String) Method

The Part number

The Part domain

The Part revision

Builds a list of the alternate parts (table_partnum_view) for the specified part and revision, and returns an array of part Objids This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function GetAlternateParts( _
   ByVal _partNumber_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _partRevision_ As String _
) As GetAlternatePartsResult

public GetAlternatePartsResult GetAlternateParts(
   string _partNumber_,
   string _partDomain_,
   string _partRevision_
)

Parameters

partNumber

The Part number

partDomain

The Part domain

partRevision

The Part revision

Return Value

The following values are populated in the GetAlternatePartsResult object returned by the API method:

  • AlternatePartList - An array of Alternate Part objid's.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


GetAlternateParts(GetAlternatePartsSetup) Method | fcSDK Documentation

GetAlternateParts(GetAlternatePartsSetup) Method

Setup object for API invocation.

Builds a list of the alternate parts (table_partnum_view) for the specified part and revision, and returns an array of part Objids This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function GetAlternateParts( _
   ByVal _setupParam_ As GetAlternatePartsSetup _
) As GetAlternatePartsResult

public GetAlternatePartsResult GetAlternateParts(
   GetAlternatePartsSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the GetAlternatePartsResult object returned by the API method:

  • AlternatePartList - An array of Alternate Part objid's.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.GetAlternatePartsSetup


GetAlternateParts(GetAlternatePartsSetup,IDbTransaction) Method | fcSDK Documentation

GetAlternateParts(GetAlternatePartsSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Builds a list of the alternate parts (table_partnum_view) for the specified part and revision, and returns an array of part Objids This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function GetAlternateParts( _
   ByVal _setupParam_ As GetAlternatePartsSetup, _
   ByVal _transaction_ As IDbTransaction _
) As GetAlternatePartsResult

public GetAlternatePartsResult GetAlternateParts(
   GetAlternatePartsSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A GetAlternatePartsResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


GetLocationsServicingSite Method | fcSDK Documentation

GetLocationsServicingSite Method

Returns a list of the locations (in the proper order) servicing this site. This overload takes a set of required parameters for the API.

Returns a list of the locations (in the proper order) servicing this site.

Overload List

Overload | Description
GetLocationsServicingSite(String) | Returns a list of the locations (in the proper order) servicing this site. This overload takes a set of required parameters for the API.
GetLocationsServicingSite(GetLocationsServicingSiteSetup) | Returns a list of the locations (in the proper order) servicing this site. This overload takes a setup object.
GetLocationsServicingSite(GetLocationsServicingSiteSetup,IDbTransaction) | Returns a list of the locations (in the proper order) servicing this site. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.GetLocationsServicingSiteSetup


GetLocationsServicingSite(String) Method | fcSDK Documentation

GetLocationsServicingSite(String) Method

Identifier of the Site that the inventory locations are servicing

Returns a list of the locations (in the proper order) servicing this site. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function GetLocationsServicingSite( _
   ByVal _siteIDNum_ As String _
) As GetLocationsServicingSiteResult

public GetLocationsServicingSiteResult GetLocationsServicingSite(
   string _siteIDNum_
)

Parameters

siteIDNum

Identifier of the Site that the inventory locations are servicing

Return Value

The following values are populated in the GetLocationsServicingSiteResult object returned by the API method:

  • InventoryLocationObjidList - An array of Inventory Location objid's.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


GetLocationsServicingSite(GetLocationsServicingSiteSetup) Method | fcSDK Documentation

GetLocationsServicingSite(GetLocationsServicingSiteSetup) Method

Setup object for API invocation.

Returns a list of the locations (in the proper order) servicing this site. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function GetLocationsServicingSite( _
   ByVal _setupParam_ As GetLocationsServicingSiteSetup _
) As GetLocationsServicingSiteResult

public GetLocationsServicingSiteResult GetLocationsServicingSite(
   GetLocationsServicingSiteSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the GetLocationsServicingSiteResult object returned by the API method:

  • InventoryLocationObjidList - An array of Inventory Location objid's.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.GetLocationsServicingSiteSetup


GetLocationsServicingSite(GetLocationsServicingSiteSetup,IDbTransaction) Method | fcSDK Documentation

GetLocationsServicingSite(GetLocationsServicingSiteSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Returns a list of the locations (in the proper order) servicing this site. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function GetLocationsServicingSite( _
   ByVal _setupParam_ As GetLocationsServicingSiteSetup, _
   ByVal _transaction_ As IDbTransaction _
) As GetLocationsServicingSiteResult

public GetLocationsServicingSiteResult GetLocationsServicingSite(
   GetLocationsServicingSiteSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A GetLocationsServicingSiteResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


MovePartRequest Method | fcSDK Documentation

MovePartRequest Method

Move the PartRequest from one WipBin to another WipBin. This overload takes a set of required parameters for the API.

Move the PartRequest from one WipBin to another WipBin.

Overload List

Overload | Description
MovePartRequest(String,String) | Move the PartRequest from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
MovePartRequest(MovePartRequestSetup) | Move the PartRequest from one WipBin to another WipBin. This overload takes a setup object.
MovePartRequest(MovePartRequestSetup,IDbTransaction) | Move the PartRequest from one WipBin to another WipBin. This overload takes a setup object and a database transaction.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the PartRequest, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.MovePartRequestSetup


MovePartRequest(String,String) Method | fcSDK Documentation

MovePartRequest(String,String) Method

Part Request Detail Identifier

The new WipBin into which the PartRequest is to be moved.

Move the PartRequest from one WipBin to another WipBin. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function MovePartRequest( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _newWipBin_ As String _
) As ToolkitResult

public ToolkitResult MovePartRequest(
   string _partRequestDetailIDNum_,
   string _newWipBin_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

newWipBin

The new WipBin into which the PartRequest is to be moved.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the PartRequest, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


MovePartRequest(MovePartRequestSetup) Method | fcSDK Documentation

MovePartRequest(MovePartRequestSetup) Method

Setup object for API invocation.

Move the PartRequest from one WipBin to another WipBin. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function MovePartRequest( _
   ByVal _setupParam_ MovePartRequestSetup _
) As ToolkitResult

public ToolkitResult MovePartRequest(
   MovePartRequestSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the PartRequest, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.MovePartRequestSetup


MovePartRequest(MovePartRequestSetup,IDbTransaction) Method | fcSDK Documentation

MovePartRequest(MovePartRequestSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Move the PartRequest from one WipBin to another WipBin. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function MovePartRequest( _
   ByVal _setupParam_ As MovePartRequestSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult MovePartRequest(
   MovePartRequestSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the PartRequest, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


OpenContainer Method | fcSDK Documentation

OpenContainer Method

Overload List

Overload | Description
OpenContainer(String) |
OpenContainer(OpenContainerSetup) |
OpenContainer(OpenContainerSetup,IDbTransaction) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members


OpenContainer(String) Method | fcSDK Documentation

OpenContainer(String) Method

Syntax

'Declaration

Public Overloads Function OpenContainer( _
   ByVal _containerName_ As String _
) As ToolkitResult

public ToolkitResult OpenContainer(
   string _containerName_
)

Parameters

containerName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


OpenContainer(OpenContainerSetup) Method | fcSDK Documentation

OpenContainer(OpenContainerSetup) Method

Setup object for API invocation.

Syntax

'Declaration

Public Overloads Function OpenContainer( _
   ByVal _setupParam_ OpenContainerSetup _
) As ToolkitResult

public ToolkitResult OpenContainer(
   OpenContainerSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


OpenContainer(OpenContainerSetup,IDbTransaction) Method | fcSDK Documentation

OpenContainer(OpenContainerSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Syntax

'Declaration

Public Overloads Function OpenContainer( _
   ByVal _setupParam_ As OpenContainerSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult OpenContainer(
   OpenContainerSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


PartTransfer Method (LogisticsToolkit) | fcSDK Documentation

PartTransfer Method (LogisticsToolkit)

Allows parts to be transferred independent of a part request to fix order errors, correct inventory variances, move parts from one inventory location (or account) to another (without having to relate that movement to a part request), and scrap parts out of inventory.

This overload takes a set of required parameters for the API.

Allows parts to be transferred independent of a part request to fix order errors, correct inventory variances, move parts from one inventory location (or account) to another (without having to relate that movement to a part request), and scrap parts out of inventory.

Overload List

Overload | Description
PartTransfer(String,String,String,Int32,Location,Location) | Allows parts to be transferred independent of a part request to fix order errors, correct inventory variances, move parts from one inventory location (or account) to another (without having to relate that movement to a part request), and scrap parts out of inventory. This overload takes a set of required parameters for the API.
PartTransfer(String,String,String,String,Location,Location) | Allows parts to be transferred independent of a part request to fix order errors, correct inventory variances, move parts from one inventory location (or account) to another (without having to relate that movement to a part request), and scrap parts out of inventory. This overload takes a set of required parameters for the API.
PartTransfer(PartTransferSetup) | Allows parts to be transferred independent of a part request to fix order errors, correct inventory variances, move parts from one inventory location (or account) to another (without having to relate that movement to a part request), and scrap parts out of inventory. This overload takes a setup object.
PartTransfer(PartTransferSetup,IDbTransaction) | Allows parts to be transferred independent of a part request to fix order errors, correct inventory variances, move parts from one inventory location (or account) to another (without having to relate that movement to a part request), and scrap parts out of inventory. This overload takes a setup object and a database transaction.

Remarks

As in Clarify, the transfer can be from good or bad stock and can be to good or bad stock.

This API checks part authorization levels for auto-replenishment, and will automatically work with that engine.

To use primary bin suggestions/recommendations, please see the remarks on the ToLocation and/or FromLocation properties on the PartTransferSetup object.

This API supports transferring parts by quantity or a specific serial number.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.PartTransferSetup


PartTransfer(String,String,String,Int32,Location,Location) Method | fcSDK Documentation

PartTransfer(String,String,String,Int32,Location,Location) Method

Part number for the Part Request

Part revision for the Part Request

Part domain for the Part Request

The number of parts being transferred

Inventory location (or expense GL) and bin from which to transfer the part

Inventory location and bin (or GL account) into which the part is being transferred

Allows parts to be transferred independent of a part request to fix order errors, correct inventory variances, move parts from one inventory location (or account) to another (without having to relate that movement to a part request), and scrap parts out of inventory.

This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function PartTransfer( _
   ByVal _partNumber_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _quantity_ As Integer, _
   ByVal _fromlocation_ As Location, _
   ByVal _tolocation_ As Location _
) As PartTransferResult

public PartTransferResult PartTransfer(
   string _partNumber_,
   string _partRevision_,
   string _partDomain_,
   int _quantity_,
   Location _fromlocation_,
   Location _tolocation_
)

Parameters

partNumber

Part number for the Part Request

partRevision

Part revision for the Part Request

partDomain

Part domain for the Part Request

quantity

The number of parts being transferred

fromlocation

Inventory location (or expense GL) and bin from which to transfer the part

tolocation

Inventory location and bin (or GL account) into which the part is being transferred

Return Value

The following values are populated in the PartTransferResult object returned by the API method:

  • TransactionIDNum - Part Transfer Transaction Identifier.
  • StandardCost - Part Transfer Standard Cost.
  • Objid - Objid of the Part Transfer record.

Remarks

As in Clarify, the transfer can be from good or bad stock and can be to good or bad stock.

This API checks part authorization levels for auto-replenishment, and will automatically work with that engine.

To use primary bin suggestions/recommendations, please see the remarks on the ToLocation and/or FromLocation properties on the PartTransferSetup object.

This API supports transferring parts by quantity or a specific serial number.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


PartTransfer(String,String,String,String,Location,Location) Method | fcSDK Documentation

PartTransfer(String,String,String,String,Location,Location) Method

Part number for the Part Request

Part revision for the Part Request

Part domain for the Part Request

The serial number of the part being transferred

Inventory location (or expense GL) and bin from which to transfer the part

Inventory location and bin (or GL account) into which the part is being transferred

Allows parts to be transferred independent of a part request to fix order errors, correct inventory variances, move parts from one inventory location (or account) to another (without having to relate that movement to a part request), and scrap parts out of inventory.

This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function PartTransfer( _
   ByVal _partNumber_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _serialNumber_ As String, _
   ByVal _fromlocation_ As Location, _
   ByVal _tolocation_ As Location _
) As PartTransferResult

public PartTransferResult PartTransfer(
   string _partNumber_,
   string _partRevision_,
   string _partDomain_,
   string _serialNumber_,
   Location _fromlocation_,
   Location _tolocation_
)

Parameters

partNumber

Part number for the Part Request

partRevision

Part revision for the Part Request

partDomain

Part domain for the Part Request

serialNumber

The serial number of the part being transferred

fromlocation

Inventory location (or expense GL) and bin from which to transfer the part

tolocation

Inventory location and bin (or GL account) into which the part is being transferred

Return Value

The following values are populated in the PartTransferResult object returned by the API method:

  • Objid - Objid of the Part Transfer record.
  • StandardCost - Part Transfer Standard Cost.
  • TransactionIDNum - Part Transfer Transaction Identifier.

Remarks

As in Clarify, the transfer can be from good or bad stock and can be to good or bad stock.

This API checks part authorization levels for auto-replenishment, and will automatically work with that engine.

To use primary bin suggestions/recommendations, please see the remarks on the ToLocation and/or FromLocation properties on the PartTransferSetup object.

This API supports transferring parts by quantity or a specific serial number.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


PartTransfer(PartTransferSetup) Method | fcSDK Documentation

PartTransfer(PartTransferSetup) Method

Setup object for API invocation.

Allows parts to be transferred independent of a part request to fix order errors, correct inventory variances, move parts from one inventory location (or account) to another (without having to relate that movement to a part request), and scrap parts out of inventory.

This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function PartTransfer( _
   ByVal _setupParam_ As PartTransferSetup _
) As PartTransferResult

public PartTransferResult PartTransfer(
   PartTransferSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the PartTransferResult object returned by the API method:

  • StandardCost - Part Transfer Standard Cost.
  • Objid - Objid of the Part Transfer record.
  • TransactionIDNum - Part Transfer Transaction Identifier.

Remarks

As in Clarify, the transfer can be from good or bad stock and can be to good or bad stock.

This API checks part authorization levels for auto-replenishment, and will automatically work with that engine.

To use primary bin suggestions/recommendations, please see the remarks on the ToLocation and/or FromLocation properties on the PartTransferSetup object.

This API supports transferring parts by quantity or a specific serial number.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.PartTransferSetup


PartTransfer(PartTransferSetup,IDbTransaction) Method | fcSDK Documentation

PartTransfer(PartTransferSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Allows parts to be transferred independent of a part request to fix order errors, correct inventory variances, move parts from one inventory location (or account) to another (without having to relate that movement to a part request), and scrap parts out of inventory.

This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function PartTransfer( _
   ByVal _setupParam_ As PartTransferSetup, _
   ByVal _transaction_ As IDbTransaction _
) As PartTransferResult

public PartTransferResult PartTransfer(
   PartTransferSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A PartTransferResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

As in Clarify, the transfer can be from good or bad stock and can be to good or bad stock.

This API checks part authorization levels for auto-replenishment, and will automatically work with that engine.

To use primary bin suggestions/recommendations, please see the remarks on the ToLocation and/or FromLocation properties on the PartTransferSetup object.

This API supports transferring parts by quantity or a specific serial number.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


Pick Method | fcSDK Documentation

Pick Method

Allows for multiple pick actions to occur against a part request.

This overload takes a set of required parameters for the API.

Allows for multiple pick actions to occur against a part request.

Overload List

Overload | Description
Pick(String) | Allows for multiple pick actions to occur against a part request. This overload takes a set of required parameters for the API.
Pick(String,String[]) | Allows for multiple pick actions to occur against a part request. This overload takes a set of required parameters for the API.
Pick(String,Boolean) | Allows for multiple pick actions to occur against a part request. This overload takes a set of required parameters for the API.
Pick(String,Boolean,String[]) | Allows for multiple pick actions to occur against a part request. This overload takes a set of required parameters for the API.
Pick(PickSetup) | Allows for multiple pick actions to occur against a part request. This overload takes a setup object.
Pick(PickSetup,IDbTransaction) | Allows for multiple pick actions to occur against a part request. This overload takes a setup object and a database transaction.

Remarks

This API will perform a soft pick (reserve) on all quantity or serialized parts, based on the part number/site_part of the specified part request, in all of the specified locations until all of the necessary inventory has been reserved, or there are no more locations from which to pick. This API will also validate that the part request can be transitioned for the specified user (or current user if no user is specified).

Locations can be specified either by the location name itself or by a location name/bin name combination. Please see the Locations property on the PickSetup object and the LocationCollection object for details on how to specify locations. If no locations are specified, the location_servicing_locations for the Part Request's Site will be used. That is, inventory will be checked for warehouses that are best suited for the shipping Site of the Part Request.

If the part request was created using a serialized site part and you wish to perform a "hard pick" of one or more inventory parts, you must use one of the serial numbers variants of this API and specify one or more serial numbers or use the keyword "inventory" as the only serial number. Specifying only "inventory" will force the API to ignore the serial numbers stored in the part request and allow the pick to occur from inventory parts.

To allow for multiple calls to this API to be performed without extra complex transitions being added to the system, set the UseTransitions property of the PickSetup object, or the useTransitions parameter of the respective overloads to false. Note that the last call to Pick in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

NOTE: This API must be called in conjunction with the PartTransfer API to work correctly.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.PickSetup


Pick(String) Method | fcSDK Documentation

Pick(String) Method

Part Request Detail Identifier

Allows for multiple pick actions to occur against a part request.

This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function Pick( _
   ByVal _partRequestDetailIDNum_ As String _
) As PickResult

public PickResult Pick(
   string _partRequestDetailIDNum_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

Return Value

The following values are populated in the PickResult object returned by the API method:

  • TotalPicked - The total number of parts picked.

Remarks

This API will perform a soft pick (reserve) on all quantity or serialized parts, based on the part number/site_part of the specified part request, in all of the specified locations until all of the necessary inventory has been reserved, or there are no more locations from which to pick. This API will also validate that the part request can be transitioned for the specified user (or current user if no user is specified).

Locations can be specified either by the location name itself or by a location name/bin name combination. Please see the Locations property on the PickSetup object and the LocationCollection object for details on how to specify locations. If no locations are specified, the location_servicing_locations for the Part Request's Site will be used. That is, inventory will be checked for warehouses that are best suited for the shipping Site of the Part Request.

If the part request was created using a serialized site part and you wish to perform a "hard pick" of one or more inventory parts, you must use one of the serial numbers variants of this API and specify one or more serial numbers or use the keyword "inventory" as the only serial number. Specifying only "inventory" will force the API to ignore the serial numbers stored in the part request and allow the pick to occur from inventory parts.

To allow for multiple calls to this API to be performed without extra complex transitions being added to the system, set the UseTransitions property of the PickSetup object, or the useTransitions parameter of the respective overloads to false. Note that the last call to Pick in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

NOTE: This API must be called in conjunction with the PartTransfer API to work correctly.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


Pick(String,String[]) Method | fcSDK Documentation

Pick(String,String[]) Method

Part Request Detail Identifier

The serial number(s) of the part(s) to pick (hard pick)

Allows for multiple pick actions to occur against a part request.

This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function Pick( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal ParamArray _serialNumbers_() As String _
) As PickResult

public PickResult Pick(
   string _partRequestDetailIDNum_,
   params string[] _serialNumbers_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

serialNumbers

The serial number(s) of the part(s) to pick (hard pick)

Return Value

The following values are populated in the PickResult object returned by the API method:

  • TotalPicked - The total number of parts picked.

Remarks

This API will perform a soft pick (reserve) on all quantity or serialized parts, based on the part number/site_part of the specified part request, in all of the specified locations until all of the necessary inventory has been reserved, or there are no more locations from which to pick. This API will also validate that the part request can be transitioned for the specified user (or current user if no user is specified).

Locations can be specified either by the location name itself or by a location name/bin name combination. Please see the Locations property on the PickSetup object and the LocationCollection object for details on how to specify locations. If no locations are specified, the location_servicing_locations for the Part Request's Site will be used. That is, inventory will be checked for warehouses that are best suited for the shipping Site of the Part Request.

If the part request was created using a serialized site part and you wish to perform a "hard pick" of one or more inventory parts, you must use one of the serial numbers variants of this API and specify one or more serial numbers or use the keyword "inventory" as the only serial number. Specifying only "inventory" will force the API to ignore the serial numbers stored in the part request and allow the pick to occur from inventory parts.

To allow for multiple calls to this API to be performed without extra complex transitions being added to the system, set the UseTransitions property of the PickSetup object, or the useTransitions parameter of the respective overloads to false. Note that the last call to Pick in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

NOTE: This API must be called in conjunction with the PartTransfer API to work correctly.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


Pick(String,Boolean) Method | fcSDK Documentation

Pick(String,Boolean) Method

Part Request Detail Identifier

Specifies whether or not to check logistics transitions and change the condition/status of the Part Request Detail during the Pick operation

Allows for multiple pick actions to occur against a part request.

This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function Pick( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _useTransitions_ As Boolean _
) As PickResult

public PickResult Pick(
   string _partRequestDetailIDNum_,
   bool _useTransitions_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

useTransitions

Specifies whether or not to check logistics transitions and change the condition/status of the Part Request Detail during the Pick operation

Return Value

The following values are populated in the PickResult object returned by the API method:

  • TotalPicked - The total number of parts picked.

Remarks

This API will perform a soft pick (reserve) on all quantity or serialized parts, based on the part number/site_part of the specified part request, in all of the specified locations until all of the necessary inventory has been reserved, or there are no more locations from which to pick. This API will also validate that the part request can be transitioned for the specified user (or current user if no user is specified).

Locations can be specified either by the location name itself or by a location name/bin name combination. Please see the Locations property on the PickSetup object and the LocationCollection object for details on how to specify locations. If no locations are specified, the location_servicing_locations for the Part Request's Site will be used. That is, inventory will be checked for warehouses that are best suited for the shipping Site of the Part Request.

If the part request was created using a serialized site part and you wish to perform a "hard pick" of one or more inventory parts, you must use one of the serial numbers variants of this API and specify one or more serial numbers or use the keyword "inventory" as the only serial number. Specifying only "inventory" will force the API to ignore the serial numbers stored in the part request and allow the pick to occur from inventory parts.

To allow for multiple calls to this API to be performed without extra complex transitions being added to the system, set the UseTransitions property of the PickSetup object, or the useTransitions parameter of the respective overloads to false. Note that the last call to Pick in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

NOTE: This API must be called in conjunction with the PartTransfer API to work correctly.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


Pick(String,Boolean,String[]) Method | fcSDK Documentation

Pick(String,Boolean,String[]) Method

Part Request Detail Identifier

Specifies whether or not to check logistics transitions and change the condition/status of the Part Request Detail during the Pick operation

The serial number(s) of the part(s) to pick (hard pick)

Allows for multiple pick actions to occur against a part request.

This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function Pick( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _useTransitions_ As Boolean, _
   ByVal ParamArray _serialNumbers_() As String _
) As PickResult

public PickResult Pick(
   string _partRequestDetailIDNum_,
   bool _useTransitions_,
   params string[] _serialNumbers_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

useTransitions

Specifies whether or not to check logistics transitions and change the condition/status of the Part Request Detail during the Pick operation

serialNumbers

The serial number(s) of the part(s) to pick (hard pick)

Return Value

The following values are populated in the PickResult object returned by the API method:

  • TotalPicked - The total number of parts picked.

Remarks

This API will perform a soft pick (reserve) on all quantity or serialized parts, based on the part number/site_part of the specified part request, in all of the specified locations until all of the necessary inventory has been reserved, or there are no more locations from which to pick. This API will also validate that the part request can be transitioned for the specified user (or current user if no user is specified).

Locations can be specified either by the location name itself or by a location name/bin name combination. Please see the Locations property on the PickSetup object and the LocationCollection object for details on how to specify locations. If no locations are specified, the location_servicing_locations for the Part Request's Site will be used. That is, inventory will be checked for warehouses that are best suited for the shipping Site of the Part Request.

If the part request was created using a serialized site part and you wish to perform a "hard pick" of one or more inventory parts, you must use one of the serial numbers variants of this API and specify one or more serial numbers or use the keyword "inventory" as the only serial number. Specifying only "inventory" will force the API to ignore the serial numbers stored in the part request and allow the pick to occur from inventory parts.

To allow for multiple calls to this API to be performed without extra complex transitions being added to the system, set the UseTransitions property of the PickSetup object, or the useTransitions parameter of the respective overloads to false. Note that the last call to Pick in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

NOTE: This API must be called in conjunction with the PartTransfer API to work correctly.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


Pick(PickSetup) Method | fcSDK Documentation

Pick(PickSetup) Method

Setup object for API invocation.

Allows for multiple pick actions to occur against a part request.

This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function Pick( _
   ByVal _setupParam_ As PickSetup _
) As PickResult

public PickResult Pick(
   PickSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the PickResult object returned by the API method:

  • TotalPicked - The total number of parts picked.

Remarks

This API will perform a soft pick (reserve) on all quantity or serialized parts, based on the part number/site_part of the specified part request, in all of the specified locations until all of the necessary inventory has been reserved, or there are no more locations from which to pick. This API will also validate that the part request can be transitioned for the specified user (or current user if no user is specified).

Locations can be specified either by the location name itself or by a location name/bin name combination. Please see the Locations property on the PickSetup object and the LocationCollection object for details on how to specify locations. If no locations are specified, the location_servicing_locations for the Part Request's Site will be used. That is, inventory will be checked for warehouses that are best suited for the shipping Site of the Part Request.

If the part request was created using a serialized site part and you wish to perform a "hard pick" of one or more inventory parts, you must use one of the serial numbers variants of this API and specify one or more serial numbers or use the keyword "inventory" as the only serial number. Specifying only "inventory" will force the API to ignore the serial numbers stored in the part request and allow the pick to occur from inventory parts.

To allow for multiple calls to this API to be performed without extra complex transitions being added to the system, set the UseTransitions property of the PickSetup object, or the useTransitions parameter of the respective overloads to false. Note that the last call to Pick in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

NOTE: This API must be called in conjunction with the PartTransfer API to work correctly.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List [FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.PickSetup](](FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.PickSetup.md)


Pick(PickSetup,IDbTransaction) Method | fcSDK Documentation

Pick(PickSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Allows for multiple pick actions to occur against a part request.

This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function Pick( _
   ByVal _setupParam_ As PickSetup, _
   ByVal _transaction_ As IDbTransaction _
) As PickResult

public PickResult Pick(
   PickSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A PickResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

This API will perform a soft pick (reserve) on all quantity or serialized parts, based on the part number/site_part of the specified part request, in all of the specified locations until all of the necessary inventory has been reserved, or there are no more locations from which to pick. This API will also validate that the part request can be transitioned for the specified user (or current user if no user is specified).

Locations can be specified either by the location name itself or by a location name/bin name combination. Please see the Locations property on the PickSetup object and the LocationCollection object for details on how to specify locations. If no locations are specified, the location_servicing_locations for the Part Request's Site will be used. That is, inventory will be checked for warehouses that are best suited for the shipping Site of the Part Request.

If the part request was created using a serialized site part and you wish to perform a "hard pick" of one or more inventory parts, you must use one of the serial numbers variants of this API and specify one or more serial numbers or use the keyword "inventory" as the only serial number. Specifying only "inventory" will force the API to ignore the serial numbers stored in the part request and allow the pick to occur from inventory parts.

To allow for multiple calls to this API to be performed without extra complex transitions being added to the system, set the UseTransitions property of the PickSetup object, or the useTransitions parameter of the respective overloads to false. Note that the last call to Pick in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

NOTE: This API must be called in conjunction with the PartTransfer API to work correctly.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


ReceivePartRequest Method | fcSDK Documentation

ReceivePartRequest Method

Causes the specified part request to have units received against it.

This overload takes a set of required parameters for the API.

Causes the specified part request to have units received against it.

Overload List

Overload | Description
ReceivePartRequest(String,Int32,Location) | Causes the specified part request to have units received against it. This overload takes a set of required parameters for the API.
ReceivePartRequest(String,String,Location) | Causes the specified part request to have units received against it. This overload takes a set of required parameters for the API.
ReceivePartRequest(String,Int32,Location,Boolean) | Causes the specified part request to have units received against it. This overload takes a set of required parameters for the API.
ReceivePartRequest(String,String,Location,Boolean) | Causes the specified part request to have units received against it. This overload takes a set of required parameters for the API.
ReceivePartRequest(ReceivePartRequestSetup) | Causes the specified part request to have units received against it. This overload takes a setup object.
ReceivePartRequest(ReceivePartRequestSetup,IDbTransaction) | Causes the specified part request to have units received against it. This overload takes a setup object and a database transaction.

Remarks

This API creates the part transaction (including standard costs), part instance records, receive parts records, activity logs and, optionally, generates a time bomb (for business rule notification). This API ensures that the transition from the current condition to the Received condition (for the specified user) is allowed is useTransitions is true (the default), that an inventory location's bin does not have a negative level of any part (except for expense GLs), and part authorization levels for auto-replenishment (and will automatically work with that engine).

This API supports a partial receive similar to the functionality in Clarify (as of Clarify 7.0). If only part of the Part Request is received, this API will create a new part request to handle the rest (unreceived) units of the part request.

To use a primary bin suggestion/recommendation that has been previously configured, use the special constructor for the Location object and set the isPrimaryBinSuggestion parameter to true.

To allow for multiple calls to this API to be performed without extra complex transitions being added to the system, set the UseTransitions property of the ReceivePartRequestSetup object, or the useTransitions parameter of the respective overloads to false. Note that the last call to ReceivePartRequest in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

NOTE: This API must be called in conjunction with the PartTransfer API to work correctly.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.ReceivePartRequestSetup


ReceivePartRequest(String,Int32,Location) Method | fcSDK Documentation

ReceivePartRequest(String,Int32,Location) Method

Part Request Detail Identifier

The number of parts being received for this Part Request

Inventory location (or expense GL) into which the stock will be received

Causes the specified part request to have units received against it.

This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function ReceivePartRequest( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _quantity_ As Integer, _
   ByVal _toLocation_ As Location _
) As ToolkitResult

public ToolkitResult ReceivePartRequest(
   string _partRequestDetailIDNum_,
   int _quantity_,
   Location _toLocation_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

quantity

The number of parts being received for this Part Request

toLocation

Inventory location (or expense GL) into which the stock will be received

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

This API creates the part transaction (including standard costs), part instance records, receive parts records, activity logs and, optionally, generates a time bomb (for business rule notification). This API ensures that the transition from the current condition to the Received condition (for the specified user) is allowed is useTransitions is true (the default), that an inventory location's bin does not have a negative level of any part (except for expense GLs), and part authorization levels for auto-replenishment (and will automatically work with that engine).

This API supports a partial receive similar to the functionality in Clarify (as of Clarify 7.0). If only part of the Part Request is received, this API will create a new part request to handle the rest (unreceived) units of the part request.

To use a primary bin suggestion/recommendation that has been previously configured, use the special constructor for the Location object and set the isPrimaryBinSuggestion parameter to true.

To allow for multiple calls to this API to be performed without extra complex transitions being added to the system, set the UseTransitions property of the ReceivePartRequestSetup object, or the useTransitions parameter of the respective overloads to false. Note that the last call to ReceivePartRequest in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

NOTE: This API must be called in conjunction with the PartTransfer API to work correctly.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


ReceivePartRequest(String,String,Location) Method | fcSDK Documentation

ReceivePartRequest(String,String,Location) Method

Part Request Detail Identifier

The serial number of the part being Received for this Part Request

Inventory location (or expense GL) into which the stock will be received

Causes the specified part request to have units received against it.

This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function ReceivePartRequest( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _serialNumber_ As String, _
   ByVal _toLocation_ As Location _
) As ToolkitResult

public ToolkitResult ReceivePartRequest(
   string _partRequestDetailIDNum_,
   string _serialNumber_,
   Location _toLocation_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

serialNumber

The serial number of the part being Received for this Part Request

toLocation

Inventory location (or expense GL) into which the stock will be received

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

This API creates the part transaction (including standard costs), part instance records, receive parts records, activity logs and, optionally, generates a time bomb (for business rule notification). This API ensures that the transition from the current condition to the Received condition (for the specified user) is allowed is useTransitions is true (the default), that an inventory location's bin does not have a negative level of any part (except for expense GLs), and part authorization levels for auto-replenishment (and will automatically work with that engine).

This API supports a partial receive similar to the functionality in Clarify (as of Clarify 7.0). If only part of the Part Request is received, this API will create a new part request to handle the rest (unreceived) units of the part request.

To use a primary bin suggestion/recommendation that has been previously configured, use the special constructor for the Location object and set the isPrimaryBinSuggestion parameter to true.

To allow for multiple calls to this API to be performed without extra complex transitions being added to the system, set the UseTransitions property of the ReceivePartRequestSetup object, or the useTransitions parameter of the respective overloads to false. Note that the last call to ReceivePartRequest in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

NOTE: This API must be called in conjunction with the PartTransfer API to work correctly.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


ReceivePartRequest(String,Int32,Location,Boolean) Method | fcSDK Documentation

ReceivePartRequest(String,Int32,Location,Boolean) Method

Part Request Detail Identifier

The number of parts being received for this Part Request

Inventory location (or expense GL) into which the stock will be received

Specifies whether or not to change the Part Request condition

Causes the specified part request to have units received against it.

This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function ReceivePartRequest( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _quantity_ As Integer, _
   ByVal _toLocation_ As Location, _
   ByVal _useTransitions_ As Boolean _
) As ToolkitResult

public ToolkitResult ReceivePartRequest(
   string _partRequestDetailIDNum_,
   int _quantity_,
   Location _toLocation_,
   bool _useTransitions_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

quantity

The number of parts being received for this Part Request

toLocation

Inventory location (or expense GL) into which the stock will be received

useTransitions

Specifies whether or not to change the Part Request condition

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

This API creates the part transaction (including standard costs), part instance records, receive parts records, activity logs and, optionally, generates a time bomb (for business rule notification). This API ensures that the transition from the current condition to the Received condition (for the specified user) is allowed is useTransitions is true (the default), that an inventory location's bin does not have a negative level of any part (except for expense GLs), and part authorization levels for auto-replenishment (and will automatically work with that engine).

This API supports a partial receive similar to the functionality in Clarify (as of Clarify 7.0). If only part of the Part Request is received, this API will create a new part request to handle the rest (unreceived) units of the part request.

To use a primary bin suggestion/recommendation that has been previously configured, use the special constructor for the Location object and set the isPrimaryBinSuggestion parameter to true.

To allow for multiple calls to this API to be performed without extra complex transitions being added to the system, set the UseTransitions property of the ReceivePartRequestSetup object, or the useTransitions parameter of the respective overloads to false. Note that the last call to ReceivePartRequest in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

NOTE: This API must be called in conjunction with the PartTransfer API to work correctly.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


ReceivePartRequest(String,String,Location,Boolean) Method | fcSDK Documentation

ReceivePartRequest(String,String,Location,Boolean) Method

Part Request Detail Identifier

The serial number of the part being Received for this Part Request

Inventory location (or expense GL) into which the stock will be received

Specifies whether or not to change the Part Request condition

Causes the specified part request to have units received against it.

This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function ReceivePartRequest( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _serialNumber_ As String, _
   ByVal _toLocation_ As Location, _
   ByVal _useTransitions_ As Boolean _
) As ToolkitResult

public ToolkitResult ReceivePartRequest(
   string _partRequestDetailIDNum_,
   string _serialNumber_,
   Location _toLocation_,
   bool _useTransitions_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

serialNumber

The serial number of the part being Received for this Part Request

toLocation

Inventory location (or expense GL) into which the stock will be received

useTransitions

Specifies whether or not to change the Part Request condition

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

This API creates the part transaction (including standard costs), part instance records, receive parts records, activity logs and, optionally, generates a time bomb (for business rule notification). This API ensures that the transition from the current condition to the Received condition (for the specified user) is allowed is useTransitions is true (the default), that an inventory location's bin does not have a negative level of any part (except for expense GLs), and part authorization levels for auto-replenishment (and will automatically work with that engine).

This API supports a partial receive similar to the functionality in Clarify (as of Clarify 7.0). If only part of the Part Request is received, this API will create a new part request to handle the rest (unreceived) units of the part request.

To use a primary bin suggestion/recommendation that has been previously configured, use the special constructor for the Location object and set the isPrimaryBinSuggestion parameter to true.

To allow for multiple calls to this API to be performed without extra complex transitions being added to the system, set the UseTransitions property of the ReceivePartRequestSetup object, or the useTransitions parameter of the respective overloads to false. Note that the last call to ReceivePartRequest in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

NOTE: This API must be called in conjunction with the PartTransfer API to work correctly.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


ReceivePartRequest(ReceivePartRequestSetup) Method | fcSDK Documentation

ReceivePartRequest(ReceivePartRequestSetup) Method

Setup object for API invocation.

Causes the specified part request to have units received against it.

This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function ReceivePartRequest( _
   ByVal _setupParam_ ReceivePartRequestSetup _
) As ToolkitResult

public ToolkitResult ReceivePartRequest(
   ReceivePartRequestSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

This API creates the part transaction (including standard costs), part instance records, receive parts records, activity logs and, optionally, generates a time bomb (for business rule notification). This API ensures that the transition from the current condition to the Received condition (for the specified user) is allowed is useTransitions is true (the default), that an inventory location's bin does not have a negative level of any part (except for expense GLs), and part authorization levels for auto-replenishment (and will automatically work with that engine).

This API supports a partial receive similar to the functionality in Clarify (as of Clarify 7.0). If only part of the Part Request is received, this API will create a new part request to handle the rest (unreceived) units of the part request.

To use a primary bin suggestion/recommendation that has been previously configured, use the special constructor for the Location object and set the isPrimaryBinSuggestion parameter to true.

To allow for multiple calls to this API to be performed without extra complex transitions being added to the system, set the UseTransitions property of the ReceivePartRequestSetup object, or the useTransitions parameter of the respective overloads to false. Note that the last call to ReceivePartRequest in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

NOTE: This API must be called in conjunction with the PartTransfer API to work correctly.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.ReceivePartRequestSetup


ReceivePartRequest(ReceivePartRequestSetup,IDbTransaction) Method | fcSDK Documentation

ReceivePartRequest(ReceivePartRequestSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Causes the specified part request to have units received against it.

This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function ReceivePartRequest( _
   ByVal _setupParam_ As ReceivePartRequestSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult ReceivePartRequest(
   ReceivePartRequestSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

This API creates the part transaction (including standard costs), part instance records, receive parts records, activity logs and, optionally, generates a time bomb (for business rule notification). This API ensures that the transition from the current condition to the Received condition (for the specified user) is allowed is useTransitions is true (the default), that an inventory location's bin does not have a negative level of any part (except for expense GLs), and part authorization levels for auto-replenishment (and will automatically work with that engine).

This API supports a partial receive similar to the functionality in Clarify (as of Clarify 7.0). If only part of the Part Request is received, this API will create a new part request to handle the rest (unreceived) units of the part request.

To use a primary bin suggestion/recommendation that has been previously configured, use the special constructor for the Location object and set the isPrimaryBinSuggestion parameter to true.

To allow for multiple calls to this API to be performed without extra complex transitions being added to the system, set the UseTransitions property of the ReceivePartRequestSetup object, or the useTransitions parameter of the respective overloads to false. Note that the last call to ReceivePartRequest in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

NOTE: This API must be called in conjunction with the PartTransfer API to work correctly.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


RejectPartRequest Method | fcSDK Documentation

RejectPartRequest Method

Reject the PartRequest from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.

Reject the PartRequest from the queue in which it currently resides, and return it to the owner.

Overload List

Overload | Description
RejectPartRequest(String) | Reject the PartRequest from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.
RejectPartRequest(RejectPartRequestSetup) | Reject the PartRequest from the queue in which it currently resides, and return it to the owner. This overload takes a setup object.
RejectPartRequest(RejectPartRequestSetup,IDbTransaction) | Reject the PartRequest from the queue in which it currently resides, and return it to the owner. This overload takes a setup object and a database transaction.

Remarks

The PartRequest must be in open condition, and currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.RejectPartRequestSetup


RejectPartRequest(String) Method | fcSDK Documentation

RejectPartRequest(String) Method

Part Request Detail Identifier

Reject the PartRequest from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function RejectPartRequest( _
   ByVal _partRequestDetailIDNum_ As String _
) As ToolkitResult

public ToolkitResult RejectPartRequest(
   string _partRequestDetailIDNum_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The PartRequest must be in open condition, and currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


RejectPartRequest(RejectPartRequestSetup) Method | fcSDK Documentation

RejectPartRequest(RejectPartRequestSetup) Method

Setup object for API invocation.

Reject the PartRequest from the queue in which it currently resides, and return it to the owner. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function RejectPartRequest( _
   ByVal _setupParam_ RejectPartRequestSetup _
) As ToolkitResult

public ToolkitResult RejectPartRequest(
   RejectPartRequestSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The PartRequest must be in open condition, and currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.RejectPartRequestSetup


RejectPartRequest(RejectPartRequestSetup,IDbTransaction) Method | fcSDK Documentation

RejectPartRequest(RejectPartRequestSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Reject the PartRequest from the queue in which it currently resides, and return it to the owner. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function RejectPartRequest( _
   ByVal _setupParam_ As RejectPartRequestSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult RejectPartRequest(
   RejectPartRequestSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The PartRequest must be in open condition, and currently dispatched to a queue.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


ReopenPartRequest Method | fcSDK Documentation

ReopenPartRequest Method

Causes the specified part request to be reopened.

This overload takes a set of required parameters for the API.

Causes the specified part request to be reopened.

Overload List

Overload | Description
ReopenPartRequest(String) | Causes the specified part request to be reopened. This overload takes a set of required parameters for the API.
ReopenPartRequest(ReopenPartRequestSetup) | Causes the specified part request to be reopened. This overload takes a setup object.
ReopenPartRequest(ReopenPartRequestSetup,IDbTransaction) | Causes the specified part request to be reopened. This overload takes a setup object and a database transaction.

Remarks

The Part Request must currently be closed. The WIPBIN in which to place the part request can be specified, which is an augmentation to base Clarify. If no WIPBIN is specified, the default is used.

This API will validate that the user has authority to make the status transition.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.ReopenPartRequestSetup


ReopenPartRequest(String) Method | fcSDK Documentation

ReopenPartRequest(String) Method

Part Request Detail Identifier

Causes the specified part request to be reopened.

This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function ReopenPartRequest( _
   ByVal _partRequestDetailIDNum_ As String _
) As ToolkitResult

public ToolkitResult ReopenPartRequest(
   string _partRequestDetailIDNum_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Part Request must currently be closed. The WIPBIN in which to place the part request can be specified, which is an augmentation to base Clarify. If no WIPBIN is specified, the default is used.

This API will validate that the user has authority to make the status transition.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


ReopenPartRequest(ReopenPartRequestSetup) Method | fcSDK Documentation

ReopenPartRequest(ReopenPartRequestSetup) Method

Setup object for API invocation.

Causes the specified part request to be reopened.

This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function ReopenPartRequest( _
   ByVal _setupParam_ ReopenPartRequestSetup _
) As ToolkitResult

public ToolkitResult ReopenPartRequest(
   ReopenPartRequestSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Part Request must currently be closed. The WIPBIN in which to place the part request can be specified, which is an augmentation to base Clarify. If no WIPBIN is specified, the default is used.

This API will validate that the user has authority to make the status transition.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.ReopenPartRequestSetup


ReopenPartRequest(ReopenPartRequestSetup,IDbTransaction) Method | fcSDK Documentation

ReopenPartRequest(ReopenPartRequestSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Causes the specified part request to be reopened.

This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function ReopenPartRequest( _
   ByVal _setupParam_ As ReopenPartRequestSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult ReopenPartRequest(
   ReopenPartRequestSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Part Request must currently be closed. The WIPBIN in which to place the part request can be specified, which is an augmentation to base Clarify. If no WIPBIN is specified, the default is used.

This API will validate that the user has authority to make the status transition.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


SealContainer Method | fcSDK Documentation

SealContainer Method

Overload List

Overload | Description
SealContainer(String) |
SealContainer(SealContainerSetup) |
SealContainer(SealContainerSetup,IDbTransaction) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members


SealContainer(String) Method | fcSDK Documentation

SealContainer(String) Method

Syntax

'Declaration

Public Overloads Function SealContainer( _
   ByVal _containerName_ As String _
) As ToolkitResult

public ToolkitResult SealContainer(
   string _containerName_
)

Parameters

containerName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


SealContainer(SealContainerSetup) Method | fcSDK Documentation

SealContainer(SealContainerSetup) Method

Setup object for API invocation.

Syntax

'Declaration

Public Overloads Function SealContainer( _
   ByVal _setupParam_ SealContainerSetup _
) As ToolkitResult

public ToolkitResult SealContainer(
   SealContainerSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


SealContainer(SealContainerSetup,IDbTransaction) Method | fcSDK Documentation

SealContainer(SealContainerSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Syntax

'Declaration

Public Overloads Function SealContainer( _
   ByVal _setupParam_ As SealContainerSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult SealContainer(
   SealContainerSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


SetLogisticsTransition Method | fcSDK Documentation

SetLogisticsTransition Method

Allows you to create or modify Logistics Transitions in the database. This overload takes a set of required parameters for the API.

Allows you to create or modify Logistics Transitions in the database.

Overload List

Overload | Description
SetLogisticsTransition(PartRequestType,PartRequestCondition,PartRequestCondition,String[]) | Allows you to create or modify Logistics Transitions in the database. This overload takes a set of required parameters for the API.
SetLogisticsTransition(SetLogisticsTransitionSetup) | Allows you to create or modify Logistics Transitions in the database. This overload takes a setup object.
SetLogisticsTransition(SetLogisticsTransitionSetup,IDbTransaction) | Allows you to create or modify Logistics Transitions in the database. This overload takes a setup object and a database transaction.

Remarks

If a transition does not yet exist for the conditions and request type, a new transition is created. Otherwise, the existing transition is modified.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.SetLogisticsTransitionSetup


SetLogisticsTransition(PartRequestType,PartRequestCondition,PartRequestCondition,String[]) Method | fcSDK Documentation

SetLogisticsTransition(PartRequestType,PartRequestCondition,PartRequestCondition,String[]) Method

Type of Part Request that this transition applies to

Starting condition of the Part Request for this transition

Ending condition of the Part Request for this transition

An array of Strings which are the names of the privilege classes allowed to perform this transition

Allows you to create or modify Logistics Transitions in the database. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function SetLogisticsTransition( _
   ByVal _partRequestType_ As PartRequestType, _
   ByVal _startCondition_ As PartRequestCondition, _
   ByVal _endCondition_ As PartRequestCondition, _
   ByVal ParamArray _privilegeClasses_() As String _
) As ToolkitResult

public ToolkitResult SetLogisticsTransition(
   PartRequestType _partRequestType_,
   PartRequestCondition _startCondition_,
   PartRequestCondition _endCondition_,
   params string[] _privilegeClasses_
)

Parameters

partRequestType

Type of Part Request that this transition applies to

startCondition

Starting condition of the Part Request for this transition

endCondition

Ending condition of the Part Request for this transition

privilegeClasses

An array of Strings which are the names of the privilege classes allowed to perform this transition

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

If a transition does not yet exist for the conditions and request type, a new transition is created. Otherwise, the existing transition is modified.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


SetLogisticsTransition(SetLogisticsTransitionSetup) Method | fcSDK Documentation

SetLogisticsTransition(SetLogisticsTransitionSetup) Method

Setup object for API invocation.

Allows you to create or modify Logistics Transitions in the database. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function SetLogisticsTransition( _
   ByVal _setupParam_ SetLogisticsTransitionSetup _
) As ToolkitResult

public ToolkitResult SetLogisticsTransition(
   SetLogisticsTransitionSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

If a transition does not yet exist for the conditions and request type, a new transition is created. Otherwise, the existing transition is modified.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.SetLogisticsTransitionSetup


SetLogisticsTransition(SetLogisticsTransitionSetup,IDbTransaction) Method | fcSDK Documentation

SetLogisticsTransition(SetLogisticsTransitionSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Allows you to create or modify Logistics Transitions in the database. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function SetLogisticsTransition( _
   ByVal _setupParam_ As SetLogisticsTransitionSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult SetLogisticsTransition(
   SetLogisticsTransitionSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

If a transition does not yet exist for the conditions and request type, a new transition is created. Otherwise, the existing transition is modified.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


SetPartStockingLevel Method | fcSDK Documentation

SetPartStockingLevel Method

Creates a part restocking authorization level. This overload takes a set of required parameters for the API.

Creates a part restocking authorization level.

Overload List

Overload | Description
SetPartStockingLevel(Location,String,String,String,String,Int16,Int16,Int16,Int16) | Creates a part restocking authorization level. This overload takes a set of required parameters for the API.
SetPartStockingLevel(SetPartStockingLevelSetup) | Creates a part restocking authorization level. This overload takes a setup object.
SetPartStockingLevel(SetPartStockingLevelSetup,IDbTransaction) | Creates a part restocking authorization level. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.SetPartStockingLevelSetup


SetPartStockingLevel(Location,String,String,String,String,Int16,Int16,Int16,Int16) Method | fcSDK Documentation

SetPartStockingLevel(Location,String,String,String,String,Int16,Int16,Int16,Int16) Method

The names of the restocking location/bin

The queue to which the reorder part request will be dispatched

Part number for the Part

Part revision of the Part

Part domain of the Part

Minimum quantity of parts allowed in this inventory location

Maximum quantity of parts allowed in this inventory location

The quantity of parts that will trigger a reorder Part Request to be created for this inventory location

Quantity of parts to be reordered for this inventory location when reorder level is reached

Creates a part restocking authorization level. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function SetPartStockingLevel( _
   ByVal _location_ As Location, _
   ByVal _queue_ As String, _
   ByVal _partNumber_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _partMinimum_ As Short, _
   ByVal _partMaximum_ As Short, _
   ByVal _partReorderLevel_ As Short, _
   ByVal _partReorderQuantity_ As Short _
) As ToolkitResult

public ToolkitResult SetPartStockingLevel(
   Location _location_,
   string _queue_,
   string _partNumber_,
   string _partRevision_,
   string _partDomain_,
   short _partMinimum_,
   short _partMaximum_,
   short _partReorderLevel_,
   short _partReorderQuantity_
)

Parameters

location

The names of the restocking location/bin

queue

The queue to which the reorder part request will be dispatched

partNumber

Part number for the Part

partRevision

Part revision of the Part

partDomain

Part domain of the Part

partMinimum

Minimum quantity of parts allowed in this inventory location

partMaximum

Maximum quantity of parts allowed in this inventory location

partReorderLevel

The quantity of parts that will trigger a reorder Part Request to be created for this inventory location

partReorderQuantity

Quantity of parts to be reordered for this inventory location when reorder level is reached

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - Objid of the Part Authorization record.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


SetPartStockingLevel(SetPartStockingLevelSetup) Method | fcSDK Documentation

SetPartStockingLevel(SetPartStockingLevelSetup) Method

Setup object for API invocation.

Creates a part restocking authorization level. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function SetPartStockingLevel( _
   ByVal _setupParam_ SetPartStockingLevelSetup _
) As ToolkitResult

public ToolkitResult SetPartStockingLevel(
   SetPartStockingLevelSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - Objid of the Part Authorization record.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.SetPartStockingLevelSetup


SetPartStockingLevel(SetPartStockingLevelSetup,IDbTransaction) Method | fcSDK Documentation

SetPartStockingLevel(SetPartStockingLevelSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Creates a part restocking authorization level. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function SetPartStockingLevel( _
   ByVal _setupParam_ As SetPartStockingLevelSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult SetPartStockingLevel(
   SetPartStockingLevelSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


Ship Method | fcSDK Documentation

Ship Method

Causes the specified part request to be shipped.

This overload takes a set of required parameters for the API.

Causes the specified part request to be shipped.

Overload List

Overload | Description
Ship(String) | Causes the specified part request to be shipped. This overload takes a set of required parameters for the API.
Ship(ShipSetup) | Causes the specified part request to be shipped. This overload takes a setup object.
Ship(ShipSetup,IDbTransaction) | Causes the specified part request to be shipped. This overload takes a setup object and a database transaction.

Remarks

By default, all the shipping information parameters will default to the Part Request Header's shipping site and contact information.

If no status is provided, the default status will be used (for condition 'Shipped').

If no carrier name is provided, the dummy site will be used (objid of -2).

NOTE: This API will validate that the user has authority to make the status transition.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.ShipSetup


Ship(String) Method | fcSDK Documentation

Ship(String) Method

Part Request Detail Identifier

Causes the specified part request to be shipped.

This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function Ship( _
   ByVal _partRequestDetailIDNum_ As String _
) As ToolkitResult

public ToolkitResult Ship(
   string _partRequestDetailIDNum_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - Objid of the ship_parts record.

Remarks

By default, all the shipping information parameters will default to the Part Request Header's shipping site and contact information.

If no status is provided, the default status will be used (for condition 'Shipped').

If no carrier name is provided, the dummy site will be used (objid of -2).

NOTE: This API will validate that the user has authority to make the status transition.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


Ship(ShipSetup) Method | fcSDK Documentation

Ship(ShipSetup) Method

Setup object for API invocation.

Causes the specified part request to be shipped.

This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function Ship( _
   ByVal _setupParam_ ShipSetup _
) As ToolkitResult

public ToolkitResult Ship(
   ShipSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - Objid of the ship_parts record.

Remarks

By default, all the shipping information parameters will default to the Part Request Header's shipping site and contact information.

If no status is provided, the default status will be used (for condition 'Shipped').

If no carrier name is provided, the dummy site will be used (objid of -2).

NOTE: This API will validate that the user has authority to make the status transition.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.ShipSetup


Ship(ShipSetup,IDbTransaction) Method | fcSDK Documentation

Ship(ShipSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Causes the specified part request to be shipped.

This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function Ship( _
   ByVal _setupParam_ As ShipSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult Ship(
   ShipSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - Objid of the ship_parts record.

Remarks

By default, all the shipping information parameters will default to the Part Request Header's shipping site and contact information.

If no status is provided, the default status will be used (for condition 'Shipped').

If no carrier name is provided, the dummy site will be used (objid of -2).

NOTE: This API will validate that the user has authority to make the status transition.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


Unpick Method | fcSDK Documentation

Unpick Method

Allows for the unpicking (unreserving) of inventory parts for a part request.

This overload takes a set of required parameters for the API.

Allows for the unpicking (unreserving) of inventory parts for a part request.

Overload List

| Overload | Description | | --- | --- | | Unpick(String,Location) | Allows for the unpicking (unreserving) of inventory parts for a part request.

This overload takes a set of required parameters for the API. | | Unpick(String,Location,String[]) |

Allows for the unpicking (unreserving) of inventory parts for a part request.

This overload takes a set of required parameters for the API. | | Unpick(String,Location,Boolean) |

Allows for the unpicking (unreserving) of inventory parts for a part request.

This overload takes a set of required parameters for the API. | | Unpick(String,Location,Boolean,String[]) |

Allows for the unpicking (unreserving) of inventory parts for a part request.

This overload takes a set of required parameters for the API. | | Unpick(UnpickSetup) |

Allows for the unpicking (unreserving) of inventory parts for a part request.

This overload takes a setup object. | | Unpick(UnpickSetup,IDbTransaction) |

Allows for the unpicking (unreserving) of inventory parts for a part request.

This overload takes a setup object and a database transaction. |

Remarks

This API will search in the specified location and bin (for good or bad inventory), and will unreserve it for the part request only if it was previously reserved.

WARNING: As in base Clarify, if you (for example) pick parts in multiple bins, and then try to unpick from one bin, it will try to unpick as many units as possible (quantity-tracked only). It may unpick more units in a bin than it originally picked in that bin. This is because Clarify only remembers that a part request picked against a bin (and how many units total are picked in that bin). It does not remember how many units were picked for a particular part request. Note that this is not an issue with serialized parts.

To allow for multiple calls to this API to be performed without extra complex transitions being added to the system, set the UseTransitions property of the UnpickSetup object, or the useTransitions parameter of the respective overloads to false. Note that the last call to Unpick in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

If the part request was created using a serialized site part, then in order to unpick an inventory part you must use one of the serial numbers variants of this API and specify new serial numbers or use the keyword "inventory" as the only serial number. Specifying "inventory" as the only serial number will force this API to ignore the serial number stored in the part request and allow the unpick to occur from inventory parts.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.UnpickSetup


Unpick(String,Location) Method | fcSDK Documentation

Unpick(String,Location) Method

Part Request Detail Identifier

The inventory location to unpick the part from for this Part Request

Allows for the unpicking (unreserving) of inventory parts for a part request.

This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function Unpick( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _location_ As Location _
) As ToolkitResult

public ToolkitResult Unpick(
   string _partRequestDetailIDNum_,
   Location _location_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

location

The inventory location to unpick the part from for this Part Request

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

This API will search in the specified location and bin (for good or bad inventory), and will unreserve it for the part request only if it was previously reserved.

WARNING: As in base Clarify, if you (for example) pick parts in multiple bins, and then try to unpick from one bin, it will try to unpick as many units as possible (quantity-tracked only). It may unpick more units in a bin than it originally picked in that bin. This is because Clarify only remembers that a part request picked against a bin (and how many units total are picked in that bin). It does not remember how many units were picked for a particular part request. Note that this is not an issue with serialized parts.

To allow for multiple calls to this API to be performed without extra complex transitions being added to the system, set the UseTransitions property of the UnpickSetup object, or the useTransitions parameter of the respective overloads to false. Note that the last call to Unpick in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

If the part request was created using a serialized site part, then in order to unpick an inventory part you must use one of the serial numbers variants of this API and specify new serial numbers or use the keyword "inventory" as the only serial number. Specifying "inventory" as the only serial number will force this API to ignore the serial number stored in the part request and allow the unpick to occur from inventory parts.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


Unpick(String,Location,String[]) Method | fcSDK Documentation

Unpick(String,Location,String[]) Method

Part Request Detail Identifier

The inventory location to unpick the part from for this Part Request

The serial number(s) of the part(s) to unpick (hard unpick)

Allows for the unpicking (unreserving) of inventory parts for a part request.

This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function Unpick( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _location_ As Location, _
   ByVal ParamArray _serialNumbers_() As String _
) As ToolkitResult

public ToolkitResult Unpick(
   string _partRequestDetailIDNum_,
   Location _location_,
   params string[] _serialNumbers_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

location

The inventory location to unpick the part from for this Part Request

serialNumbers

The serial number(s) of the part(s) to unpick (hard unpick)

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

This API will search in the specified location and bin (for good or bad inventory), and will unreserve it for the part request only if it was previously reserved.

WARNING: As in base Clarify, if you (for example) pick parts in multiple bins, and then try to unpick from one bin, it will try to unpick as many units as possible (quantity-tracked only). It may unpick more units in a bin than it originally picked in that bin. This is because Clarify only remembers that a part request picked against a bin (and how many units total are picked in that bin). It does not remember how many units were picked for a particular part request. Note that this is not an issue with serialized parts.

To allow for multiple calls to this API to be performed without extra complex transitions being added to the system, set the UseTransitions property of the UnpickSetup object, or the useTransitions parameter of the respective overloads to false. Note that the last call to Unpick in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

If the part request was created using a serialized site part, then in order to unpick an inventory part you must use one of the serial numbers variants of this API and specify new serial numbers or use the keyword "inventory" as the only serial number. Specifying "inventory" as the only serial number will force this API to ignore the serial number stored in the part request and allow the unpick to occur from inventory parts.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


Unpick(String,Location,Boolean) Method | fcSDK Documentation

Unpick(String,Location,Boolean) Method

Part Request Detail Identifier

The inventory location to unpick the part from for this Part Request

Specifies whether or not to check logistics transitions and change the condition/status of the Part Request Detail during the Unpick operation

Allows for the unpicking (unreserving) of inventory parts for a part request.

This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function Unpick( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _location_ As Location, _
   ByVal _useTransitions_ As Boolean _
) As ToolkitResult

public ToolkitResult Unpick(
   string _partRequestDetailIDNum_,
   Location _location_,
   bool _useTransitions_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

location

The inventory location to unpick the part from for this Part Request

useTransitions

Specifies whether or not to check logistics transitions and change the condition/status of the Part Request Detail during the Unpick operation

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

This API will search in the specified location and bin (for good or bad inventory), and will unreserve it for the part request only if it was previously reserved.

WARNING: As in base Clarify, if you (for example) pick parts in multiple bins, and then try to unpick from one bin, it will try to unpick as many units as possible (quantity-tracked only). It may unpick more units in a bin than it originally picked in that bin. This is because Clarify only remembers that a part request picked against a bin (and how many units total are picked in that bin). It does not remember how many units were picked for a particular part request. Note that this is not an issue with serialized parts.

To allow for multiple calls to this API to be performed without extra complex transitions being added to the system, set the UseTransitions property of the UnpickSetup object, or the useTransitions parameter of the respective overloads to false. Note that the last call to Unpick in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

If the part request was created using a serialized site part, then in order to unpick an inventory part you must use one of the serial numbers variants of this API and specify new serial numbers or use the keyword "inventory" as the only serial number. Specifying "inventory" as the only serial number will force this API to ignore the serial number stored in the part request and allow the unpick to occur from inventory parts.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


Unpick(String,Location,Boolean,String[]) Method | fcSDK Documentation

Unpick(String,Location,Boolean,String[]) Method

Part Request Detail Identifier

The inventory location to unpick the part from for this Part Request

Specifies whether or not to check logistics transitions and change the condition/status of the Part Request Detail during the Unpick operation

The serial number(s) of the part(s) to unpick (hard unpick)

Allows for the unpicking (unreserving) of inventory parts for a part request.

This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function Unpick( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _location_ As Location, _
   ByVal _useTransitions_ As Boolean, _
   ByVal ParamArray _serialNumbers_() As String _
) As ToolkitResult

public ToolkitResult Unpick(
   string _partRequestDetailIDNum_,
   Location _location_,
   bool _useTransitions_,
   params string[] _serialNumbers_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

location

The inventory location to unpick the part from for this Part Request

useTransitions

Specifies whether or not to check logistics transitions and change the condition/status of the Part Request Detail during the Unpick operation

serialNumbers

The serial number(s) of the part(s) to unpick (hard unpick)

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

This API will search in the specified location and bin (for good or bad inventory), and will unreserve it for the part request only if it was previously reserved.

WARNING: As in base Clarify, if you (for example) pick parts in multiple bins, and then try to unpick from one bin, it will try to unpick as many units as possible (quantity-tracked only). It may unpick more units in a bin than it originally picked in that bin. This is because Clarify only remembers that a part request picked against a bin (and how many units total are picked in that bin). It does not remember how many units were picked for a particular part request. Note that this is not an issue with serialized parts.

To allow for multiple calls to this API to be performed without extra complex transitions being added to the system, set the UseTransitions property of the UnpickSetup object, or the useTransitions parameter of the respective overloads to false. Note that the last call to Unpick in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

If the part request was created using a serialized site part, then in order to unpick an inventory part you must use one of the serial numbers variants of this API and specify new serial numbers or use the keyword "inventory" as the only serial number. Specifying "inventory" as the only serial number will force this API to ignore the serial number stored in the part request and allow the unpick to occur from inventory parts.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


Unpick(UnpickSetup) Method | fcSDK Documentation

Unpick(UnpickSetup) Method

Setup object for API invocation.

Allows for the unpicking (unreserving) of inventory parts for a part request.

This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function Unpick( _
   ByVal _setupParam_ UnpickSetup _
) As ToolkitResult

public ToolkitResult Unpick(
   UnpickSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

This API will search in the specified location and bin (for good or bad inventory), and will unreserve it for the part request only if it was previously reserved.

WARNING: As in base Clarify, if you (for example) pick parts in multiple bins, and then try to unpick from one bin, it will try to unpick as many units as possible (quantity-tracked only). It may unpick more units in a bin than it originally picked in that bin. This is because Clarify only remembers that a part request picked against a bin (and how many units total are picked in that bin). It does not remember how many units were picked for a particular part request. Note that this is not an issue with serialized parts.

To allow for multiple calls to this API to be performed without extra complex transitions being added to the system, set the UseTransitions property of the UnpickSetup object, or the useTransitions parameter of the respective overloads to false. Note that the last call to Unpick in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

If the part request was created using a serialized site part, then in order to unpick an inventory part you must use one of the serial numbers variants of this API and specify new serial numbers or use the keyword "inventory" as the only serial number. Specifying "inventory" as the only serial number will force this API to ignore the serial number stored in the part request and allow the unpick to occur from inventory parts.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.UnpickSetup


Unpick(UnpickSetup,IDbTransaction) Method | fcSDK Documentation

Unpick(UnpickSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Allows for the unpicking (unreserving) of inventory parts for a part request.

This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function Unpick( _
   ByVal _setupParam_ As UnpickSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult Unpick(
   UnpickSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

This API will search in the specified location and bin (for good or bad inventory), and will unreserve it for the part request only if it was previously reserved.

WARNING: As in base Clarify, if you (for example) pick parts in multiple bins, and then try to unpick from one bin, it will try to unpick as many units as possible (quantity-tracked only). It may unpick more units in a bin than it originally picked in that bin. This is because Clarify only remembers that a part request picked against a bin (and how many units total are picked in that bin). It does not remember how many units were picked for a particular part request. Note that this is not an issue with serialized parts.

To allow for multiple calls to this API to be performed without extra complex transitions being added to the system, set the UseTransitions property of the UnpickSetup object, or the useTransitions parameter of the respective overloads to false. Note that the last call to Unpick in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

If the part request was created using a serialized site part, then in order to unpick an inventory part you must use one of the serial numbers variants of this API and specify new serial numbers or use the keyword "inventory" as the only serial number. Specifying "inventory" as the only serial number will force this API to ignore the serial number stored in the part request and allow the unpick to occur from inventory parts.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


UpdateGLAccount Method | fcSDK Documentation

UpdateGLAccount Method

Used to modify existing GL accounts. This overload takes a set of required parameters for the API.

Used to modify existing GL accounts.

Overload List

Overload | Description
UpdateGLAccount(String,String) | Used to modify existing GL accounts. This overload takes a set of required parameters for the API.
UpdateGLAccount(UpdateGLAccountSetup) | Used to modify existing GL accounts. This overload takes a setup object.
UpdateGLAccount(UpdateGLAccountSetup,IDbTransaction) | Used to modify existing GL accounts. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.UpdateGLAccountSetup


UpdateGLAccount(String,String) Method | fcSDK Documentation

UpdateGLAccount(String,String) Method

Current name of the account

Identifier of the Site with which the account is associated

Used to modify existing GL accounts. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function UpdateGLAccount( _
   ByVal _currentName_ As String, _
   ByVal _siteIDNum_ As String _
) As ToolkitResult

public ToolkitResult UpdateGLAccount(
   string _currentName_,
   string _siteIDNum_
)

Parameters

currentName

Current name of the account

siteIDNum

Identifier of the Site with which the account is associated

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - Objid of the Inventory Location record.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


UpdateGLAccount(UpdateGLAccountSetup) Method | fcSDK Documentation

UpdateGLAccount(UpdateGLAccountSetup) Method

Setup object for API invocation.

Used to modify existing GL accounts. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function UpdateGLAccount( _
   ByVal _setupParam_ UpdateGLAccountSetup _
) As ToolkitResult

public ToolkitResult UpdateGLAccount(
   UpdateGLAccountSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - Objid of the Inventory Location record.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.UpdateGLAccountSetup


UpdateGLAccount(UpdateGLAccountSetup,IDbTransaction) Method | fcSDK Documentation

UpdateGLAccount(UpdateGLAccountSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to modify existing GL accounts. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdateGLAccount( _
   ByVal _setupParam_ As UpdateGLAccountSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdateGLAccount(
   UpdateGLAccountSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


UpdateInventoryBin Method | fcSDK Documentation

UpdateInventoryBin Method

Used to modify the name or the active flag of an existing bin. This overload takes a set of required parameters for the API.

Used to modify the name or the active flag of an existing bin.

Overload List

Overload | Description
UpdateInventoryBin(Location,String) | Used to modify the name or the active flag of an existing bin. This overload takes a set of required parameters for the API.
UpdateInventoryBin(UpdateInventoryBinSetup) | Used to modify the name or the active flag of an existing bin. This overload takes a setup object.
UpdateInventoryBin(UpdateInventoryBinSetup,IDbTransaction) | Used to modify the name or the active flag of an existing bin. This overload takes a setup object and a database transaction.

Remarks

NOTE: This API cannot move a bin to another location, only rename it at the existing location.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.UpdateInventoryBinSetup


UpdateInventoryBin(Location,String) Method | fcSDK Documentation

UpdateInventoryBin(Location,String) Method

The inventory location and bin to update

New name of the inventory bin

Used to modify the name or the active flag of an existing bin. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function UpdateInventoryBin( _
   ByVal _currentLocation_ As Location, _
   ByVal _newBinName_ As String _
) As ToolkitResult

public ToolkitResult UpdateInventoryBin(
   Location _currentLocation_,
   string _newBinName_
)

Parameters

currentLocation

The inventory location and bin to update

newBinName

New name of the inventory bin

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - Objid of the Inventory Bin record.

Remarks

NOTE: This API cannot move a bin to another location, only rename it at the existing location.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


UpdateInventoryBin(UpdateInventoryBinSetup) Method | fcSDK Documentation

UpdateInventoryBin(UpdateInventoryBinSetup) Method

Setup object for API invocation.

Used to modify the name or the active flag of an existing bin. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function UpdateInventoryBin( _
   ByVal _setupParam_ UpdateInventoryBinSetup _
) As ToolkitResult

public ToolkitResult UpdateInventoryBin(
   UpdateInventoryBinSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - Objid of the Inventory Bin record.

Remarks

NOTE: This API cannot move a bin to another location, only rename it at the existing location.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.UpdateInventoryBinSetup


UpdateInventoryBin(UpdateInventoryBinSetup,IDbTransaction) Method | fcSDK Documentation

UpdateInventoryBin(UpdateInventoryBinSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to modify the name or the active flag of an existing bin. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdateInventoryBin( _
   ByVal _setupParam_ As UpdateInventoryBinSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdateInventoryBin(
   UpdateInventoryBinSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

NOTE: This API cannot move a bin to another location, only rename it at the existing location.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


UpdateInventoryLocation Method | fcSDK Documentation

UpdateInventoryLocation Method

Used to modify inventory locations in the system.

This overload takes a setup object.

Used to modify inventory locations in the system.

Overload List

Overload | Description
UpdateInventoryLocation(UpdateInventoryLocationSetup) | Used to modify inventory locations in the system. This overload takes a setup object.
UpdateInventoryLocation(UpdateInventoryLocationSetup,IDbTransaction) |

Used to modify inventory locations in the system.

This overload takes a setup object and a database transaction. |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.UpdateInventoryLocationSetup


UpdateInventoryLocation(UpdateInventoryLocationSetup) Method | fcSDK Documentation

UpdateInventoryLocation(UpdateInventoryLocationSetup) Method

Setup object for API invocation.

Used to modify inventory locations in the system.

This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function UpdateInventoryLocation( _
   ByVal _setupParam_ UpdateInventoryLocationSetup _
) As ToolkitResult

public ToolkitResult UpdateInventoryLocation(
   UpdateInventoryLocationSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - Objid of the Inventory Location record.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.UpdateInventoryLocationSetup


UpdateInventoryLocation(UpdateInventoryLocationSetup,IDbTransaction) Method | fcSDK Documentation

UpdateInventoryLocation(UpdateInventoryLocationSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to modify inventory locations in the system.

This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdateInventoryLocation( _
   ByVal _setupParam_ As UpdateInventoryLocationSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdateInventoryLocation(
   UpdateInventoryLocationSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


UpdateLocationServicingSite Method | fcSDK Documentation

UpdateLocationServicingSite Method

Used to change the order of the locations servicing a site. This overload takes a set of required parameters for the API.

Used to change the order of the locations servicing a site.

Overload List

Overload | Description
UpdateLocationServicingSite(String,String,Int16) | Used to change the order of the locations servicing a site. This overload takes a set of required parameters for the API.
UpdateLocationServicingSite(UpdateLocationServicingSiteSetup) | Used to change the order of the locations servicing a site. This overload takes a setup object.
UpdateLocationServicingSite(UpdateLocationServicingSiteSetup,IDbTransaction) | Used to change the order of the locations servicing a site. This overload takes a setup object and a database transaction.

Remarks

This API will give a new rank to the. All other ranks are changed as necessary.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.UpdateLocationServicingSiteSetup


UpdateLocationServicingSite(String,String,Int16) Method | fcSDK Documentation

UpdateLocationServicingSite(String,String,Int16) Method

Identifier of the Site that the inventory location is servicing

Name of the inventory location

The rank of this inventory location at the associated site

Used to change the order of the locations servicing a site. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function UpdateLocationServicingSite( _
   ByVal _siteIDNum_ As String, _
   ByVal _locationName_ As String, _
   ByVal _locationRank_ As Short _
) As ToolkitResult

public ToolkitResult UpdateLocationServicingSite(
   string _siteIDNum_,
   string _locationName_,
   short _locationRank_
)

Parameters

siteIDNum

Identifier of the Site that the inventory location is servicing

locationName

Name of the inventory location

locationRank

The rank of this inventory location at the associated site

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - Objid of the Inventory Role record.

Remarks

This API will give a new rank to the. All other ranks are changed as necessary.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


UpdateLocationServicingSite(UpdateLocationServicingSiteSetup) Method | fcSDK Documentation

UpdateLocationServicingSite(UpdateLocationServicingSiteSetup) Method

Setup object for API invocation.

Used to change the order of the locations servicing a site. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function UpdateLocationServicingSite( _
   ByVal _setupParam_ UpdateLocationServicingSiteSetup _
) As ToolkitResult

public ToolkitResult UpdateLocationServicingSite(
   UpdateLocationServicingSiteSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - Objid of the Inventory Role record.

Remarks

This API will give a new rank to the. All other ranks are changed as necessary.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.UpdateLocationServicingSiteSetup


UpdateLocationServicingSite(UpdateLocationServicingSiteSetup,IDbTransaction) Method | fcSDK Documentation

UpdateLocationServicingSite(UpdateLocationServicingSiteSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to change the order of the locations servicing a site. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdateLocationServicingSite( _
   ByVal _setupParam_ As UpdateLocationServicingSiteSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdateLocationServicingSite(
   UpdateLocationServicingSiteSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

This API will give a new rank to the. All other ranks are changed as necessary.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


UpdatePartRequestDetail Method | fcSDK Documentation

UpdatePartRequestDetail Method

Allow for the updating of part request details.

This overload takes a setup object.

Allow for the updating of part request details.

Overload List

Overload | Description
UpdatePartRequestDetail(UpdatePartRequestDetailSetup) | Allow for the updating of part request details. This overload takes a setup object.
UpdatePartRequestDetail(UpdatePartRequestDetailSetup,IDbTransaction) | Allow for the updating of part request details. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.UpdatePartRequestDetailSetup


UpdatePartRequestDetail(UpdatePartRequestDetailSetup) Method | fcSDK Documentation

UpdatePartRequestDetail(UpdatePartRequestDetailSetup) Method

Setup object for API invocation.

Allow for the updating of part request details.

This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function UpdatePartRequestDetail( _
   ByVal _setupParam_ UpdatePartRequestDetailSetup _
) As ToolkitResult

public ToolkitResult UpdatePartRequestDetail(
   UpdatePartRequestDetailSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the DemandDetail.
  • IDNum - The IDNum of the DemandDetail.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.UpdatePartRequestDetailSetup


UpdatePartRequestDetail(UpdatePartRequestDetailSetup,IDbTransaction) Method | fcSDK Documentation

UpdatePartRequestDetail(UpdatePartRequestDetailSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Allow for the updating of part request details.

This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdatePartRequestDetail( _
   ByVal _setupParam_ As UpdatePartRequestDetailSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdatePartRequestDetail(
   UpdatePartRequestDetailSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


UpdatePartRequestHeader Method | fcSDK Documentation

UpdatePartRequestHeader Method

Allow for the updating of part request headers.

This overload takes a setup object.

Allow for the updating of part request headers.

Overload List

Overload | Description
UpdatePartRequestHeader(UpdatePartRequestHeaderSetup) | Allow for the updating of part request headers. This overload takes a setup object.
UpdatePartRequestHeader(UpdatePartRequestHeaderSetup,IDbTransaction) | Allow for the updating of part request headers. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.UpdatePartRequestHeaderSetup


UpdatePartRequestHeader(UpdatePartRequestHeaderSetup) Method | fcSDK Documentation

UpdatePartRequestHeader(UpdatePartRequestHeaderSetup) Method

Setup object for API invocation.

Allow for the updating of part request headers.

This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function UpdatePartRequestHeader( _
   ByVal _setupParam_ UpdatePartRequestHeaderSetup _
) As ToolkitResult

public ToolkitResult UpdatePartRequestHeader(
   UpdatePartRequestHeaderSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.UpdatePartRequestHeaderSetup


UpdatePartRequestHeader(UpdatePartRequestHeaderSetup,IDbTransaction) Method | fcSDK Documentation

UpdatePartRequestHeader(UpdatePartRequestHeaderSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Allow for the updating of part request headers.

This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdatePartRequestHeader( _
   ByVal _setupParam_ As UpdatePartRequestHeaderSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdatePartRequestHeader(
   UpdatePartRequestHeaderSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


UpdatePartStockingLevel Method | fcSDK Documentation

UpdatePartStockingLevel Method

Updates an existing part restocking authorization level. This overload takes a set of required parameters for the API.

Updates an existing part restocking authorization level.

Overload List

Overload | Description
UpdatePartStockingLevel(Location,String,String,String,String) | Updates an existing part restocking authorization level. This overload takes a set of required parameters for the API.
UpdatePartStockingLevel(UpdatePartStockingLevelSetup) | Updates an existing part restocking authorization level. This overload takes a setup object.
UpdatePartStockingLevel(UpdatePartStockingLevelSetup,IDbTransaction) | Updates an existing part restocking authorization level. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.UpdatePartStockingLevelSetup


UpdatePartStockingLevel(Location,String,String,String,String) Method | fcSDK Documentation

UpdatePartStockingLevel(Location,String,String,String,String) Method

The location and bin used for restocking

The queue to which the reorder part request will be dispatched

Part number for the Part

Part revision for the Part

Part domain for the Part

Updates an existing part restocking authorization level. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function UpdatePartStockingLevel( _
   ByVal _currentLocation_ As Location, _
   ByVal _queue_ As String, _
   ByVal _partNumber_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _partDomain_ As String _
) As ToolkitResult

public ToolkitResult UpdatePartStockingLevel(
   Location _currentLocation_,
   string _queue_,
   string _partNumber_,
   string _partRevision_,
   string _partDomain_
)

Parameters

currentLocation

The location and bin used for restocking

queue

The queue to which the reorder part request will be dispatched

partNumber

Part number for the Part

partRevision

Part revision for the Part

partDomain

Part domain for the Part

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - Objid of the Part Authorization record.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


UpdatePartStockingLevel(UpdatePartStockingLevelSetup) Method | fcSDK Documentation

UpdatePartStockingLevel(UpdatePartStockingLevelSetup) Method

Setup object for API invocation.

Updates an existing part restocking authorization level. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function UpdatePartStockingLevel( _
   ByVal _setupParam_ UpdatePartStockingLevelSetup _
) As ToolkitResult

public ToolkitResult UpdatePartStockingLevel(
   UpdatePartStockingLevelSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - Objid of the Part Authorization record.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.UpdatePartStockingLevelSetup


UpdatePartStockingLevel(UpdatePartStockingLevelSetup,IDbTransaction) Method | fcSDK Documentation

UpdatePartStockingLevel(UpdatePartStockingLevelSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Updates an existing part restocking authorization level. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdatePartStockingLevel( _
   ByVal _setupParam_ As UpdatePartStockingLevelSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdatePartStockingLevel(
   UpdatePartStockingLevelSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


YankPartRequest Method | fcSDK Documentation

YankPartRequest Method

Yank the PartRequest from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.

Yank the PartRequest from its current location to a new owner's WipBin.

Overload List

Overload | Description
YankPartRequest(String) | Yank the PartRequest from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.
YankPartRequest(YankPartRequestSetup) | Yank the PartRequest from its current location to a new owner's WipBin. This overload takes a setup object.
YankPartRequest(YankPartRequestSetup,IDbTransaction) | Yank the PartRequest from its current location to a new owner's WipBin. This overload takes a setup object and a database transaction.

Remarks

The WipBin to place the PartRequest in may also be specified. This is augmented function from base Clarify, where the PartRequest is always placed in the default WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.YankPartRequestSetup


YankPartRequest(String) Method | fcSDK Documentation

YankPartRequest(String) Method

Part Request Detail Identifier

Yank the PartRequest from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function YankPartRequest( _
   ByVal _partRequestDetailIDNum_ As String _
) As ToolkitResult

public ToolkitResult YankPartRequest(
   string _partRequestDetailIDNum_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The WipBin to place the PartRequest in may also be specified. This is augmented function from base Clarify, where the PartRequest is always placed in the default WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


YankPartRequest(YankPartRequestSetup) Method | fcSDK Documentation

YankPartRequest(YankPartRequestSetup) Method

Setup object for API invocation.

Yank the PartRequest from its current location to a new owner's WipBin. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function YankPartRequest( _
   ByVal _setupParam_ YankPartRequestSetup _
) As ToolkitResult

public ToolkitResult YankPartRequest(
   YankPartRequestSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The WipBin to place the PartRequest in may also be specified. This is augmented function from base Clarify, where the PartRequest is always placed in the default WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class LogisticsToolkit Members Overload List FChoice.Toolkits.Clarify~FChoice.Toolkits.Clarify.Logistics.YankPartRequestSetup


YankPartRequest(YankPartRequestSetup,IDbTransaction) Method | fcSDK Documentation

YankPartRequest(YankPartRequestSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Yank the PartRequest from its current location to a new owner's WipBin. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function YankPartRequest( _
   ByVal _setupParam_ As YankPartRequestSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult YankPartRequest(
   YankPartRequestSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The WipBin to place the PartRequest in may also be specified. This is augmented function from base Clarify, where the PartRequest is always placed in the default WipBin.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkit Class
LogisticsToolkit Members
Overload List


LogisticsToolkitBase Class | fcSDK Documentation

LogisticsToolkitBase Class

This class is intended for internal use by the LogisticsToolkit.

Syntax

'Declaration

Public MustInherit Class LogisticsToolkitBase
   Inherits FChoice.Toolkits.Clarify.ToolkitBase

public abstract class LogisticsToolkitBase : FChoice.Toolkits.Clarify.ToolkitBase

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.ToolkitBase
FChoice.Toolkits.Clarify.Logistics.LogisticsToolkitBase
FChoice.Toolkits.Clarify.Logistics.LogisticsToolkit

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LogisticsToolkitBase Members
FChoice.Toolkits.Clarify.Logistics Namespace


LogisticsToolkitBase Class Members | fcSDK Documentation

LogisticsToolkitBase Class Members

The following tables list the members exposed by LogisticsToolkitBase.

Public Properties

 | Name | Description
Public Property | ImpersonatorUsername |

Reference

LogisticsToolkitBase Class
FChoice.Toolkits.Clarify.Logistics Namespace


ImpersonatorUsername Property (LogisticsToolkitBase) | fcSDK Documentation

ImpersonatorUsername Property (LogisticsToolkitBase)

Syntax

'Declaration

Public Property ImpersonatorUsername As String

public string ImpersonatorUsername {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogisticsToolkitBase Class
LogisticsToolkitBase Members


MovePartRequestSetup Class | fcSDK Documentation

MovePartRequestSetup Class

Used by the MovePartRequest method as setup data for invocation.

Syntax

'Declaration

Public Class MovePartRequestSetup

public class MovePartRequestSetup

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.MovePartRequestSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

MovePartRequestSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitMovePartRequest(MovePartRequestSetup)


MovePartRequestSetup Class Members | fcSDK Documentation

MovePartRequestSetup Class Members

The following tables list the members exposed by MovePartRequestSetup.

Public Constructors

 | Name | Description
Public Constructor | MovePartRequestSetup Constructor | Initializes a new instance of the MovePartRequestSetup class.

Public Properties

 | Name | Description
Public Property | NewWipBin | The new WipBin into which the PartRequest is to be moved.
Public Property | PartRequestDetailIDNum | Part Request Detail Identifier

Reference

MovePartRequestSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitMovePartRequest(MovePartRequestSetup)


MovePartRequestSetup Constructor | fcSDK Documentation

MovePartRequestSetup Constructor

Part Request Detail Identifier

The new WipBin into which the PartRequest is to be moved.

Initializes a new instance of the MovePartRequestSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _newWipBin_ As String _
)

[ConstructorIndexAttribute()]
public MovePartRequestSetup(
   string _partRequestDetailIDNum_,
   string _newWipBin_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

newWipBin

The new WipBin into which the PartRequest is to be moved.

Remarks

The specified part request detail must be open and the specified WipBin name must be valid for the current owner.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MovePartRequestSetup Class
MovePartRequestSetup Members


NewWipBin Property (MovePartRequestSetup) | fcSDK Documentation

NewWipBin Property (MovePartRequestSetup)

The new WipBin into which the PartRequest is to be moved.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewWipBin As String

[PropertyBitValueAttribute()]
public string NewWipBin {get; set;}

Remarks

The specified WipBin name must be valid for the current owner.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MovePartRequestSetup Class
MovePartRequestSetup Members


PartRequestDetailIDNum Property (MovePartRequestSetup) | fcSDK Documentation

PartRequestDetailIDNum Property (MovePartRequestSetup)

Part Request Detail Identifier

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRequestDetailIDNum As String

[PropertyBitValueAttribute()]
public string PartRequestDetailIDNum {get; set;}

Remarks

The specified part request detail must be open.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MovePartRequestSetup Class
MovePartRequestSetup Members


OpenContainerSetup Class | fcSDK Documentation

OpenContainerSetup Class

Syntax

'Declaration

Public Class OpenContainerSetup

public class OpenContainerSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Logistics.OpenContainerSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

OpenContainerSetup Members
FChoice.Toolkits.Clarify.Logistics Namespace


OpenContainerSetup Class Members | fcSDK Documentation

OpenContainerSetup Class Members

The following tables list the members exposed by OpenContainerSetup.

Public Constructors

 | Name | Description
Public Constructor | OpenContainerSetup Constructor |

Public Properties

 | Name | Description
Public Property | ContainerName |

Reference

OpenContainerSetup Class
FChoice.Toolkits.Clarify.Logistics Namespace


OpenContainerSetup Constructor | fcSDK Documentation

OpenContainerSetup Constructor

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _containerName_ As String _
)

[ConstructorIndexAttribute()]
public OpenContainerSetup(
   string _containerName_
)

Parameters

containerName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OpenContainerSetup Class
OpenContainerSetup Members


ContainerName Property (OpenContainerSetup) | fcSDK Documentation

ContainerName Property (OpenContainerSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContainerName As String

[PropertyBitValueAttribute()]
public string ContainerName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

OpenContainerSetup Class
OpenContainerSetup Members


PartTransferResult Class | fcSDK Documentation

PartTransferResult Class

Result from the PartTransfer API.

Syntax

'Declaration

Public Class PartTransferResult
   Inherits FChoice.Toolkits.Clarify.ToolkitResult

public class PartTransferResult : FChoice.Toolkits.Clarify.ToolkitResult

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.ToolkitResult
FChoice.Toolkits.Clarify.Logistics.PartTransferResult

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

PartTransferResult Members
FChoice.Toolkits.Clarify.Logistics Namespace


PartTransferResult Class Members | fcSDK Documentation

PartTransferResult Class Members

The following tables list the members exposed by PartTransferResult.

Public Constructors

 | Name | Description
Public Constructor | PartTransferResult Constructor |

Public Properties

 | Name | Description
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | StandardCost | Part Transfer Standard Cost.
Public Property | TransactionIDNum | Part Transfer Transaction Identifier.

Reference

PartTransferResult Class
FChoice.Toolkits.Clarify.Logistics Namespace


PartTransferSetup Class | fcSDK Documentation

PartTransferSetup Class

Used by the PartTransfer method as setup data for invocation.

Syntax

'Declaration

Public Class PartTransferSetup

public class PartTransferSetup

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.PartTransferSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

PartTransferSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitPartTransfer(PartTransferSetup)


PartTransferSetup Class Members | fcSDK Documentation

PartTransferSetup Class Members

The following tables list the members exposed by PartTransferSetup.

Public Constructors

 | Name | Description
Public Constructor | PartTransferSetup Constructor | Overloaded.

Public Properties

 | Name | Description
Public Property | FromGood | Specifies whether the part is being transferred from good stock (true) or bad stock (false)
Public Property | FromLocation | Inventory location (or expense GL) and bin from which to transfer the part
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Notes | Notes about the Part Transfer
Public Property | PartDomain | Part domain for the Part Request
Public Property | PartNumber | Part number for the Part Request
Public Property | PartRevision | Part revision for the Part Request
Public Property | Quantity | The number of parts being transferred
Public Property | ReferenceIDNum | Optional reference number for this part transfer
Public Property | SerialNumber | The serial number of the part being transferred
Public Property | ToGood | Specifies whether the part is being transferred resulting in good stock (true) or bad stock (false)
Public Property | ToLocation | Inventory location and bin (or GL account) into which the part is being transferred
Public Property | TransferDate | The DateTime the Parts are transferred. If not set, the current time is used.
Public Property | UserName | The user who is transferring the Part. If not set, the session user is used.

Reference

PartTransferSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitPartTransfer(PartTransferSetup)


FromLocation Property (PartTransferSetup) | fcSDK Documentation

FromLocation Property (PartTransferSetup)

Inventory location (or expense GL) and bin from which to transfer the part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FromLocation As Location

[PropertyBitValueAttribute()]
public Location FromLocation {get; set;}

Remarks

To use a primary bin suggestion/recommendation that has been previously configured, use the special constructor for the Location object and set the isPrimaryBinSuggestion parameter to true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartTransferSetup Class
PartTransferSetup Members


ToLocation Property (PartTransferSetup) | fcSDK Documentation

ToLocation Property (PartTransferSetup)

Inventory location and bin (or GL account) into which the part is being transferred

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ToLocation As Location

[PropertyBitValueAttribute()]
public Location ToLocation {get; set;}

Remarks

To use a primary bin suggestion/recommendation that has been previously configured, use the special constructor for the Location object and set the isPrimaryBinSuggestion parameter to true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartTransferSetup Class
PartTransferSetup Members


TransferDate Property (PartTransferSetup) | fcSDK Documentation

TransferDate Property (PartTransferSetup)

The DateTime the Parts are transferred. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property TransferDate As Date

[PropertyBitValueAttribute()]
public DateTime TransferDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartTransferSetup Class
PartTransferSetup Members


PickResult Class | fcSDK Documentation

PickResult Class

Result from the Pick API.

Syntax

'Declaration

Public Class PickResult
   Inherits FChoice.Toolkits.Clarify.ToolkitResult

public class PickResult : FChoice.Toolkits.Clarify.ToolkitResult

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.ToolkitResult
FChoice.Toolkits.Clarify.Logistics.PickResult

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

PickResult Members
FChoice.Toolkits.Clarify.Logistics Namespace


PickResult Class Members | fcSDK Documentation

PickResult Class Members

The following tables list the members exposed by PickResult.

Public Constructors

 | Name | Description
Public Constructor | PickResult Constructor |

Public Properties

 | Name | Description
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | TotalPicked | The total number of parts picked.

Reference

PickResult Class
FChoice.Toolkits.Clarify.Logistics Namespace


PickResult Constructor | fcSDK Documentation

PickResult Constructor

Syntax

'Declaration

Public Function New()

public PickResult()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PickResult Class
PickResult Members


TotalPicked Property | fcSDK Documentation

TotalPicked Property

The total number of parts picked.

Syntax

'Declaration

Public Property TotalPicked As Integer

public int TotalPicked {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PickResult Class
PickResult Members


PickSetup Class | fcSDK Documentation

PickSetup Class

Used by the Pick method as setup data for invocation.

Syntax

'Declaration

Public Class PickSetup

public class PickSetup

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.PickSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

PickSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitPick(PickSetup)


PickSetup Class Members | fcSDK Documentation

PickSetup Class Members

The following tables list the members exposed by PickSetup.

Public Constructors

 | Name | Description
Public Constructor | PickSetup Constructor | Overloaded.

Public Properties

 | Name | Description
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Locations | Specifies the inventory locations which will be searched in order to find the parts to pick for this Part Request.
Public Property | NewStatus | The new status for the Part Request for the Picked condition. If not set, the default status is used.
Public Property | PartRequestDetailIDNum | Part Request Detail Identifier
Public Property | PickDate | The DateTime the Part Request is picked. If not set, the current time is used.
Public Property | SerialNumbers | The serial number(s) of the part(s) to pick (hard pick)
Public Property | UseGood | Specifies wheterh the picked inventory is from good stock (true) or bad stock (false)
Public Property | UserName | The user who is picking the Part Request. If not set, the session user is used.
Public Property | UseTransitions | Specifies whether or not to check logistics transitions and change the condition/status of the Part Request Detail during the Pick operation

Reference

PickSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitPick(PickSetup)


PickSetup Constructor | fcSDK Documentation

PickSetup Constructor

Initializes a new instance of the PickSetup class.

Overload List

Overload | Description
PickSetup Constructor(String) | Initializes a new instance of the PickSetup class. This overload takes a set of required parameters for the API.
PickSetup Constructor(String,String[]) | Initializes a new instance of the PickSetup class. This overload takes a set of required parameters for the API.
PickSetup Constructor(String,Boolean) | Initializes a new instance of the PickSetup class. This overload takes a set of required parameters for the API.
PickSetup Constructor(String,Boolean,String[]) | Initializes a new instance of the PickSetup class. This overload takes a set of required parameters for the API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PickSetup Class
PickSetup Members


PickSetup Constructor(String) | fcSDK Documentation

PickSetup Constructor(String)

Part Request Detail Identifier

Initializes a new instance of the PickSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String _
)

[ConstructorIndexAttribute()]
public PickSetup(
   string _partRequestDetailIDNum_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PickSetup Class
PickSetup Members
Overload List


PickSetup Constructor(String,String[]) | fcSDK Documentation

PickSetup Constructor(String,String[])

Part Request Detail Identifier

The serial number(s) of the part(s) to pick (hard pick)

Initializes a new instance of the PickSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal ParamArray _serialNumbers_() As String _
)

[ConstructorIndexAttribute()]
public PickSetup(
   string _partRequestDetailIDNum_,
   params string[] _serialNumbers_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

serialNumbers

The serial number(s) of the part(s) to pick (hard pick)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PickSetup Class
PickSetup Members
Overload List


PickSetup Constructor(String,Boolean) | fcSDK Documentation

PickSetup Constructor(String,Boolean)

Part Request Detail Identifier

Specifies whether or not to check logistics transitions and change the condition/status of the Part Request Detail during the Pick operation

Initializes a new instance of the PickSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _useTransitions_ As Boolean _
)

[ConstructorIndexAttribute()]
public PickSetup(
   string _partRequestDetailIDNum_,
   bool _useTransitions_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

useTransitions

Specifies whether or not to check logistics transitions and change the condition/status of the Part Request Detail during the Pick operation

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PickSetup Class
PickSetup Members
Overload List


PickSetup Constructor(String,Boolean,String[]) | fcSDK Documentation

PickSetup Constructor(String,Boolean,String[])

Part Request Detail Identifier

Specifies whether or not to check logistics transitions and change the condition/status of the Part Request Detail during the Pick operation

The serial number(s) of the part(s) to pick (hard pick)

Initializes a new instance of the PickSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _useTransitions_ As Boolean, _
   ByVal ParamArray _serialNumbers_() As String _
)

[ConstructorIndexAttribute()]
public PickSetup(
   string _partRequestDetailIDNum_,
   bool _useTransitions_,
   params string[] _serialNumbers_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

useTransitions

Specifies whether or not to check logistics transitions and change the condition/status of the Part Request Detail during the Pick operation

serialNumbers

The serial number(s) of the part(s) to pick (hard pick)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PickSetup Class
PickSetup Members
Overload List


GenerateTimeBombs Property (PickSetup) | fcSDK Documentation

GenerateTimeBombs Property (PickSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PickSetup Class
PickSetup Members


Locations Property | fcSDK Documentation

Locations Property

Specifies the inventory locations which will be searched in order to find the parts to pick for this Part Request.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property Locations As LocationCollection

[PropertyBitValueAttribute()]
public LocationCollection Locations {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PickSetup Class
PickSetup Members


NewStatus Property (PickSetup) | fcSDK Documentation

NewStatus Property (PickSetup)

The new status for the Part Request for the Picked condition. If not set, the default status is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewStatus As String

[PropertyBitValueAttribute()]
public string NewStatus {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PickSetup Class
PickSetup Members


PartRequestDetailIDNum Property (PickSetup) | fcSDK Documentation

PartRequestDetailIDNum Property (PickSetup)

Part Request Detail Identifier

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRequestDetailIDNum As String

[PropertyBitValueAttribute()]
public string PartRequestDetailIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PickSetup Class
PickSetup Members


PickDate Property | fcSDK Documentation

PickDate Property

The DateTime the Part Request is picked. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PickDate As Date

[PropertyBitValueAttribute()]
public DateTime PickDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PickSetup Class
PickSetup Members


SerialNumbers Property (PickSetup) | fcSDK Documentation

SerialNumbers Property (PickSetup)

The serial number(s) of the part(s) to pick (hard pick)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SerialNumbers As String()

[PropertyBitValueAttribute()]
public string[] SerialNumbers {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PickSetup Class
PickSetup Members


UseGood Property (PickSetup) | fcSDK Documentation

UseGood Property (PickSetup)

Specifies wheterh the picked inventory is from good stock (true) or bad stock (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UseGood As Boolean

[PropertyBitValueAttribute()]
public bool UseGood {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PickSetup Class
PickSetup Members


UserName Property (PickSetup) | fcSDK Documentation

UserName Property (PickSetup)

The user who is picking the Part Request. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PickSetup Class
PickSetup Members


UseTransitions Property (PickSetup) | fcSDK Documentation

UseTransitions Property (PickSetup)

Specifies whether or not to check logistics transitions and change the condition/status of the Part Request Detail during the Pick operation

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UseTransitions As Boolean

[PropertyBitValueAttribute()]
public bool UseTransitions {get; set;}

Remarks

Setting this value to false allows for multiple calls to the API to be performed without extra complex transitions being added to the system. By default, the value is true.

NOTE: The last call to Pick in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PickSetup Class
PickSetup Members


ReceivePartRequestSetup Class | fcSDK Documentation

ReceivePartRequestSetup Class

Used by the ReceivePartRequest method as setup data for invocation.

Syntax

'Declaration

Public Class ReceivePartRequestSetup

public class ReceivePartRequestSetup

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.ReceivePartRequestSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ReceivePartRequestSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitReceivePartRequest(ReceivePartRequestSetup)


ReceivePartRequestSetup Class Members | fcSDK Documentation

ReceivePartRequestSetup Class Members

The following tables list the members exposed by ReceivePartRequestSetup.

Public Constructors

 | Name | Description
Public Constructor | ReceivePartRequestSetup Constructor | Overloaded.

Public Properties

 | Name | Description
Public Property | AutoClose | Specifies whether the Part Request should be closed if all of the inventory for this Part Request is received (or an overage). If it is already closed, and no other details exist for the header, this parameter specifies whether the Part Request Header should be closed as well.
Public Property | CarrierName | Element from the 'Carrier' application list. If not set the default list value is used.
Public Property | FromGood | Specifies whether the received inventory from is good stock (true) or bad stock (false)
Public Property | FromLocation | Inventory location (or expense GL) from which to receive.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NotProperlyPacked | Specifies whether the received inventory is (true) or is not (false) properly packed
Public Property | PartRequestDetailIDNum | Part Request Detail Identifier
Public Property | PossibleDamage | Specifies whether the received inventory is possibly damaged (true) or not (false)
Public Property | Quantity | The number of parts being received for this Part Request
Public Property | ReceiveDate | The DateTime the Part Request is received. If not set, the current time is used.
Public Property | RouteToTest | Specifies whether the received stock should be routed to test (true) or not (false)
Public Property | SerialNumber | The serial number of the part being Received for this Part Request
Public Property | Status | The new status for the Part Request for the Received condition. If not set, the default status is used.
Public Property | ToGood | Specifies whether the received inventory is being received as good stock (true) or bad stock (false)
Public Property | ToLocation | Inventory location (or expense GL) into which the stock will be received
Public Property | UserName | The user who is receiving the Part Request. If not set, the Toolkit session user is used.
Public Property | UseTransitions | Specifies whether or not to change the Part Request condition
Public Property | WaybillName | Waybill information for this Part Request receipt

Reference

ReceivePartRequestSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitReceivePartRequest(ReceivePartRequestSetup)


ReceivePartRequestSetup Constructor | fcSDK Documentation

ReceivePartRequestSetup Constructor

Initializes a new instance of the ReceivePartRequestSetup class.

Overload List

Overload | Description
ReceivePartRequestSetup Constructor(String,Int32,Location) | Initializes a new instance of the ReceivePartRequestSetup class. This overload takes a set of required parameters for the API.
ReceivePartRequestSetup Constructor(String,String,Location) | Initializes a new instance of the ReceivePartRequestSetup class. This overload takes a set of required parameters for the API.
ReceivePartRequestSetup Constructor(String,Int32,Location,Boolean) | Initializes a new instance of the ReceivePartRequestSetup class. This overload takes a set of required parameters for the API.
ReceivePartRequestSetup Constructor(String,String,Location,Boolean) | Initializes a new instance of the ReceivePartRequestSetup class. This overload takes a set of required parameters for the API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReceivePartRequestSetup Class
ReceivePartRequestSetup Members


ReceivePartRequestSetup Constructor(String,Int32,Location) | fcSDK Documentation

ReceivePartRequestSetup Constructor(String,Int32,Location)

Part Request Detail Identifier

The number of parts being received for this Part Request

Inventory location (or expense GL) into which the stock will be received

Initializes a new instance of the ReceivePartRequestSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _quantity_ As Integer, _
   ByVal _toLocation_ As Location _
)

[ConstructorIndexAttribute()]
public ReceivePartRequestSetup(
   string _partRequestDetailIDNum_,
   int _quantity_,
   Location _toLocation_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

quantity

The number of parts being received for this Part Request

toLocation

Inventory location (or expense GL) into which the stock will be received

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReceivePartRequestSetup Class
ReceivePartRequestSetup Members
Overload List


ReceivePartRequestSetup Constructor(String,String,Location) | fcSDK Documentation

ReceivePartRequestSetup Constructor(String,String,Location)

Part Request Detail Identifier

The serial number of the part being Received for this Part Request

Inventory location (or expense GL) into which the stock will be received

Initializes a new instance of the ReceivePartRequestSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _serialNumber_ As String, _
   ByVal _toLocation_ As Location _
)

[ConstructorIndexAttribute()]
public ReceivePartRequestSetup(
   string _partRequestDetailIDNum_,
   string _serialNumber_,
   Location _toLocation_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

serialNumber

The serial number of the part being Received for this Part Request

toLocation

Inventory location (or expense GL) into which the stock will be received

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReceivePartRequestSetup Class
ReceivePartRequestSetup Members
Overload List


ReceivePartRequestSetup Constructor(String,Int32,Location,Boolean) | fcSDK Documentation

ReceivePartRequestSetup Constructor(String,Int32,Location,Boolean)

Part Request Detail Identifier

The number of parts being received for this Part Request

Inventory location (or expense GL) into which the stock will be received

Specifies whether or not to change the Part Request condition

Initializes a new instance of the ReceivePartRequestSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _quantity_ As Integer, _
   ByVal _toLocation_ As Location, _
   ByVal _useTransitions_ As Boolean _
)

[ConstructorIndexAttribute()]
public ReceivePartRequestSetup(
   string _partRequestDetailIDNum_,
   int _quantity_,
   Location _toLocation_,
   bool _useTransitions_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

quantity

The number of parts being received for this Part Request

toLocation

Inventory location (or expense GL) into which the stock will be received

useTransitions

Specifies whether or not to change the Part Request condition

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReceivePartRequestSetup Class
ReceivePartRequestSetup Members
Overload List


ReceivePartRequestSetup Constructor(String,String,Location,Boolean) | fcSDK Documentation

ReceivePartRequestSetup Constructor(String,String,Location,Boolean)

Part Request Detail Identifier

The serial number of the part being Received for this Part Request

Inventory location (or expense GL) into which the stock will be received

Specifies whether or not to change the Part Request condition

Initializes a new instance of the ReceivePartRequestSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _serialNumber_ As String, _
   ByVal _toLocation_ As Location, _
   ByVal _useTransitions_ As Boolean _
)

[ConstructorIndexAttribute()]
public ReceivePartRequestSetup(
   string _partRequestDetailIDNum_,
   string _serialNumber_,
   Location _toLocation_,
   bool _useTransitions_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

serialNumber

The serial number of the part being Received for this Part Request

toLocation

Inventory location (or expense GL) into which the stock will be received

useTransitions

Specifies whether or not to change the Part Request condition

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReceivePartRequestSetup Class
ReceivePartRequestSetup Members
Overload List


AutoClose Property | fcSDK Documentation

AutoClose Property

Specifies whether the Part Request should be closed if all of the inventory for this Part Request is received (or an overage). If it is already closed, and no other details exist for the header, this parameter specifies whether the Part Request Header should be closed as well.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AutoClose As Boolean

[PropertyBitValueAttribute()]
public bool AutoClose {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReceivePartRequestSetup Class
ReceivePartRequestSetup Members


CarrierName Property (ReceivePartRequestSetup) | fcSDK Documentation

CarrierName Property (ReceivePartRequestSetup)

Element from the 'Carrier' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CarrierName As String

[PropertyBitValueAttribute()]
public string CarrierName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReceivePartRequestSetup Class
ReceivePartRequestSetup Members


FromGood Property (ReceivePartRequestSetup) | fcSDK Documentation

FromGood Property (ReceivePartRequestSetup)

Specifies whether the received inventory from is good stock (true) or bad stock (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FromGood As Boolean

[PropertyBitValueAttribute()]
public bool FromGood {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReceivePartRequestSetup Class
ReceivePartRequestSetup Members


FromLocation Property (ReceivePartRequestSetup) | fcSDK Documentation

FromLocation Property (ReceivePartRequestSetup)

Inventory location (or expense GL) from which to receive.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FromLocation As Location

[PropertyBitValueAttribute()]
public Location FromLocation {get; set;}

Remarks

If this parameter is set to Location.EMPTY, the inventory will be searched for the received part. If found, that location will be used.

To use a primary bin suggestion/recommendation that has been previously configured, use the special constructor for the Location object and set the isPrimaryBinSuggestion parameter to true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReceivePartRequestSetup Class
ReceivePartRequestSetup Members


GenerateTimeBombs Property (ReceivePartRequestSetup) | fcSDK Documentation

GenerateTimeBombs Property (ReceivePartRequestSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReceivePartRequestSetup Class
ReceivePartRequestSetup Members


NotProperlyPacked Property | fcSDK Documentation

NotProperlyPacked Property

Specifies whether the received inventory is (true) or is not (false) properly packed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NotProperlyPacked As Boolean

[PropertyBitValueAttribute()]
public bool NotProperlyPacked {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReceivePartRequestSetup Class
ReceivePartRequestSetup Members


PartRequestDetailIDNum Property (ReceivePartRequestSetup) | fcSDK Documentation

PartRequestDetailIDNum Property (ReceivePartRequestSetup)

Part Request Detail Identifier

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRequestDetailIDNum As String

[PropertyBitValueAttribute()]
public string PartRequestDetailIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReceivePartRequestSetup Class
ReceivePartRequestSetup Members


PossibleDamage Property | fcSDK Documentation

PossibleDamage Property

Specifies whether the received inventory is possibly damaged (true) or not (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PossibleDamage As Boolean

[PropertyBitValueAttribute()]
public bool PossibleDamage {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReceivePartRequestSetup Class
ReceivePartRequestSetup Members


Quantity Property (ReceivePartRequestSetup) | fcSDK Documentation

Quantity Property (ReceivePartRequestSetup)

The number of parts being received for this Part Request

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Quantity As Integer

[PropertyBitValueAttribute()]
public int Quantity {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReceivePartRequestSetup Class
ReceivePartRequestSetup Members


ReceiveDate Property | fcSDK Documentation

ReceiveDate Property

The DateTime the Part Request is received. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ReceiveDate As Date

[PropertyBitValueAttribute()]
public DateTime ReceiveDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReceivePartRequestSetup Class
ReceivePartRequestSetup Members


RouteToTest Property | fcSDK Documentation

RouteToTest Property

Specifies whether the received stock should be routed to test (true) or not (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property RouteToTest As Boolean

[PropertyBitValueAttribute()]
public bool RouteToTest {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReceivePartRequestSetup Class
ReceivePartRequestSetup Members


SerialNumber Property (ReceivePartRequestSetup) | fcSDK Documentation

SerialNumber Property (ReceivePartRequestSetup)

The serial number of the part being Received for this Part Request

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SerialNumber As String

[PropertyBitValueAttribute()]
public string SerialNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReceivePartRequestSetup Class
ReceivePartRequestSetup Members


Status Property (ReceivePartRequestSetup) | fcSDK Documentation

Status Property (ReceivePartRequestSetup)

The new status for the Part Request for the Received condition. If not set, the default status is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Status As String

[PropertyBitValueAttribute()]
public string Status {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReceivePartRequestSetup Class
ReceivePartRequestSetup Members


ToGood Property (ReceivePartRequestSetup) | fcSDK Documentation

ToGood Property (ReceivePartRequestSetup)

Specifies whether the received inventory is being received as good stock (true) or bad stock (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ToGood As Boolean

[PropertyBitValueAttribute()]
public bool ToGood {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReceivePartRequestSetup Class
ReceivePartRequestSetup Members


ToLocation Property (ReceivePartRequestSetup) | fcSDK Documentation

ToLocation Property (ReceivePartRequestSetup)

Inventory location (or expense GL) into which the stock will be received

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ToLocation As Location

[PropertyBitValueAttribute()]
public Location ToLocation {get; set;}

Remarks

To use a primary bin suggestion/recommendation that has been previously configured, use the special constructor for the Location object and set the isPrimaryBinSuggestion parameter to true.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReceivePartRequestSetup Class
ReceivePartRequestSetup Members


UserName Property (ReceivePartRequestSetup) | fcSDK Documentation

UserName Property (ReceivePartRequestSetup)

The user who is receiving the Part Request. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReceivePartRequestSetup Class
ReceivePartRequestSetup Members


UseTransitions Property (ReceivePartRequestSetup) | fcSDK Documentation

UseTransitions Property (ReceivePartRequestSetup)

Specifies whether or not to change the Part Request condition

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UseTransitions As Boolean

[PropertyBitValueAttribute()]
public bool UseTransitions {get; set;}

Remarks

Setting this value to false allows for multiple calls to the API to be performed without extra complex transitions being added to the system. By default, the value is true.

NOTE: The last call to ReceivePartRequest in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReceivePartRequestSetup Class
ReceivePartRequestSetup Members


WaybillName Property (ReceivePartRequestSetup) | fcSDK Documentation

WaybillName Property (ReceivePartRequestSetup)

Waybill information for this Part Request receipt

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WaybillName As String

[PropertyBitValueAttribute()]
public string WaybillName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReceivePartRequestSetup Class
ReceivePartRequestSetup Members


RejectPartRequestSetup Class | fcSDK Documentation

RejectPartRequestSetup Class

Used by the RejectPartRequest method as setup data for invocation.

Syntax

'Declaration

Public Class RejectPartRequestSetup

public class RejectPartRequestSetup

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.RejectPartRequestSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

RejectPartRequestSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitRejectPartRequest(RejectPartRequestSetup)


RejectPartRequestSetup Class Members | fcSDK Documentation

RejectPartRequestSetup Class Members

The following tables list the members exposed by RejectPartRequestSetup.

Public Constructors

 | Name | Description
Public Constructor | RejectPartRequestSetup Constructor | Initializes a new instance of the RejectPartRequestSetup class.

Public Properties

 | Name | Description
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Notes | The reason the PartRequest was rejected from the queue into which it was dispatched.
Public Property | PartRequestDetailIDNum | Part Request Detail Identifier
Public Property | RejectDate | DateTime the PartRequest was rejected. If not set, the current time is used.
Public Property | UserName | The user who has rejected the PartRequest. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the PartRequest. If not set, the UserName's default is used.

Reference

RejectPartRequestSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitRejectPartRequest(RejectPartRequestSetup)


RejectPartRequestSetup Constructor | fcSDK Documentation

RejectPartRequestSetup Constructor

Part Request Detail Identifier

Initializes a new instance of the RejectPartRequestSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String _
)

[ConstructorIndexAttribute()]
public RejectPartRequestSetup(
   string _partRequestDetailIDNum_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectPartRequestSetup Class
RejectPartRequestSetup Members


GenerateTimeBombs Property (RejectPartRequestSetup) | fcSDK Documentation

GenerateTimeBombs Property (RejectPartRequestSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectPartRequestSetup Class
RejectPartRequestSetup Members


Notes Property (RejectPartRequestSetup) | fcSDK Documentation

Notes Property (RejectPartRequestSetup)

The reason the PartRequest was rejected from the queue into which it was dispatched.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectPartRequestSetup Class
RejectPartRequestSetup Members


PartRequestDetailIDNum Property (RejectPartRequestSetup) | fcSDK Documentation

PartRequestDetailIDNum Property (RejectPartRequestSetup)

Part Request Detail Identifier

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRequestDetailIDNum As String

[PropertyBitValueAttribute()]
public string PartRequestDetailIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectPartRequestSetup Class
RejectPartRequestSetup Members


RejectDate Property (RejectPartRequestSetup) | fcSDK Documentation

RejectDate Property (RejectPartRequestSetup)

DateTime the PartRequest was rejected. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property RejectDate As Date

[PropertyBitValueAttribute()]
public DateTime RejectDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectPartRequestSetup Class
RejectPartRequestSetup Members


UserName Property (RejectPartRequestSetup) | fcSDK Documentation

UserName Property (RejectPartRequestSetup)

The user who has rejected the PartRequest. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectPartRequestSetup Class
RejectPartRequestSetup Members


WipBin Property (RejectPartRequestSetup) | fcSDK Documentation

WipBin Property (RejectPartRequestSetup)

User's WipBin in which to place the PartRequest. If not set, the UserName's default is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectPartRequestSetup Class
RejectPartRequestSetup Members


ReopenPartRequestSetup Class | fcSDK Documentation

ReopenPartRequestSetup Class

Used by the ReopenPartRequest method as setup data for invocation.

Syntax

'Declaration

Public Class ReopenPartRequestSetup

public class ReopenPartRequestSetup

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.ReopenPartRequestSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ReopenPartRequestSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitReopenPartRequest(ReopenPartRequestSetup)


ReopenPartRequestSetup Class Members | fcSDK Documentation

ReopenPartRequestSetup Class Members

The following tables list the members exposed by ReopenPartRequestSetup.

Public Constructors

 | Name | Description
Public Constructor | ReopenPartRequestSetup Constructor | Initializes a new instance of the ReopenPartRequestSetup class.

Public Properties

 | Name | Description
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewStatus | The new status for the Part Request for the Reopened condition. If not set, the default status is used.
Public Property | PartRequestDetailIDNum | Part Request Detail Identifier
Public Property | ReopenDate | The DateTime the Part Request is reopened. If not set, the current time is used.
Public Property | UserName | The user who is reopening the Part Request. If not set, the session user is used.
Public Property | WipBin | The WipBin in which to place the Part Request when it is reopened. If not specified, the default WipBin for the session user is used.

Reference

ReopenPartRequestSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitReopenPartRequest(ReopenPartRequestSetup)


ReopenPartRequestSetup Constructor | fcSDK Documentation

ReopenPartRequestSetup Constructor

Part Request Detail Identifier

Initializes a new instance of the ReopenPartRequestSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String _
)

[ConstructorIndexAttribute()]
public ReopenPartRequestSetup(
   string _partRequestDetailIDNum_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenPartRequestSetup Class
ReopenPartRequestSetup Members


GenerateTimeBombs Property (ReopenPartRequestSetup) | fcSDK Documentation

GenerateTimeBombs Property (ReopenPartRequestSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenPartRequestSetup Class
ReopenPartRequestSetup Members


NewStatus Property (ReopenPartRequestSetup) | fcSDK Documentation

NewStatus Property (ReopenPartRequestSetup)

The new status for the Part Request for the Reopened condition. If not set, the default status is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewStatus As String

[PropertyBitValueAttribute()]
public string NewStatus {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenPartRequestSetup Class
ReopenPartRequestSetup Members


PartRequestDetailIDNum Property (ReopenPartRequestSetup) | fcSDK Documentation

PartRequestDetailIDNum Property (ReopenPartRequestSetup)

Part Request Detail Identifier

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRequestDetailIDNum As String

[PropertyBitValueAttribute()]
public string PartRequestDetailIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenPartRequestSetup Class
ReopenPartRequestSetup Members


| fcSDK Documentation


UserName Property (ReopenPartRequestSetup) | fcSDK Documentation

UserName Property (ReopenPartRequestSetup)

The user who is reopening the Part Request. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenPartRequestSetup Class
ReopenPartRequestSetup Members


WipBin Property (ReopenPartRequestSetup) | fcSDK Documentation

WipBin Property (ReopenPartRequestSetup)

The WipBin in which to place the Part Request when it is reopened. If not specified, the default WipBin for the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenPartRequestSetup Class
ReopenPartRequestSetup Members


SealContainerSetup Class | fcSDK Documentation

SealContainerSetup Class

Syntax

'Declaration

Public Class SealContainerSetup

public class SealContainerSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Logistics.SealContainerSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

SealContainerSetup Members
FChoice.Toolkits.Clarify.Logistics Namespace


SealContainerSetup Class Members | fcSDK Documentation

SealContainerSetup Class Members

The following tables list the members exposed by SealContainerSetup.

Public Constructors

 | Name | Description
Public Constructor | SealContainerSetup Constructor |

Public Properties

 | Name | Description
Public Property | ContainerName |

Reference

SealContainerSetup Class
FChoice.Toolkits.Clarify.Logistics Namespace


SealContainerSetup Constructor | fcSDK Documentation

SealContainerSetup Constructor

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _containerName_ As String _
)

[ConstructorIndexAttribute()]
public SealContainerSetup(
   string _containerName_
)

Parameters

containerName

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SealContainerSetup Class
SealContainerSetup Members


ContainerName Property (SealContainerSetup) | fcSDK Documentation

ContainerName Property (SealContainerSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContainerName As String

[PropertyBitValueAttribute()]
public string ContainerName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SealContainerSetup Class
SealContainerSetup Members


SetLogisticsTransitionSetup Class | fcSDK Documentation

SetLogisticsTransitionSetup Class

Used by the SetLogisticsTransition method as setup data for invocation.

Syntax

'Declaration

Public Class SetLogisticsTransitionSetup

public class SetLogisticsTransitionSetup

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.SetLogisticsTransitionSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

SetLogisticsTransitionSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitSetLogisticsTransition(SetLogisticsTransitionSetup)


SetLogisticsTransitionSetup Class Members | fcSDK Documentation

SetLogisticsTransitionSetup Class Members

The following tables list the members exposed by SetLogisticsTransitionSetup.

Public Constructors

 | Name | Description
Public Constructor | SetLogisticsTransitionSetup Constructor | Initializes a new instance of the SetLogisticsTransitionSetup class.

Public Properties

 | Name | Description
Public Property | EndCondition | Ending condition of the Part Request for this transition
Public Property | PartRequestType | Type of Part Request that this transition applies to
Public Property | PrivilegeClasses | An array of Strings which are the names of the privilege classes allowed to perform this transition
Public Property | StartCondition | Starting condition of the Part Request for this transition

Reference

SetLogisticsTransitionSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitSetLogisticsTransition(SetLogisticsTransitionSetup)


SetLogisticsTransitionSetup Constructor | fcSDK Documentation

SetLogisticsTransitionSetup Constructor

Type of Part Request that this transition applies to

Starting condition of the Part Request for this transition

Ending condition of the Part Request for this transition

An array of Strings which are the names of the privilege classes allowed to perform this transition

Initializes a new instance of the SetLogisticsTransitionSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestType_ As PartRequestType, _
   ByVal _startCondition_ As PartRequestCondition, _
   ByVal _endCondition_ As PartRequestCondition, _
   ByVal ParamArray _privilegeClasses_() As String _
)

[ConstructorIndexAttribute()]
public SetLogisticsTransitionSetup(
   PartRequestType _partRequestType_,
   PartRequestCondition _startCondition_,
   PartRequestCondition _endCondition_,
   params string[] _privilegeClasses_
)

Parameters

partRequestType

Type of Part Request that this transition applies to

startCondition

Starting condition of the Part Request for this transition

endCondition

Ending condition of the Part Request for this transition

privilegeClasses

An array of Strings which are the names of the privilege classes allowed to perform this transition

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SetLogisticsTransitionSetup Class
SetLogisticsTransitionSetup Members


EndCondition Property | fcSDK Documentation

EndCondition Property

Ending condition of the Part Request for this transition

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property EndCondition As PartRequestCondition

[PropertyBitValueAttribute()]
public PartRequestCondition EndCondition {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SetLogisticsTransitionSetup Class
SetLogisticsTransitionSetup Members


PartRequestType Property | fcSDK Documentation

PartRequestType Property

Type of Part Request that this transition applies to

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRequestType As PartRequestType

[PropertyBitValueAttribute()]
public PartRequestType PartRequestType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SetLogisticsTransitionSetup Class
SetLogisticsTransitionSetup Members


PrivilegeClasses Property | fcSDK Documentation

PrivilegeClasses Property

An array of Strings which are the names of the privilege classes allowed to perform this transition

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PrivilegeClasses As String()

[PropertyBitValueAttribute()]
public string[] PrivilegeClasses {get; set;}

Remarks

If this string array contains "ALLCLASSES", all privclasses can make the transition. If this string array contains "NOCLASSES", no privclasses can make this transition

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SetLogisticsTransitionSetup Class
SetLogisticsTransitionSetup Members


StartCondition Property | fcSDK Documentation

StartCondition Property

Starting condition of the Part Request for this transition

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property StartCondition As PartRequestCondition

[PropertyBitValueAttribute()]
public PartRequestCondition StartCondition {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SetLogisticsTransitionSetup Class
SetLogisticsTransitionSetup Members


SetPartStockingLevelSetup Class | fcSDK Documentation

SetPartStockingLevelSetup Class

Used by the SetPartStockingLevel method as setup data for invocation.

Syntax

'Declaration

Public Class SetPartStockingLevelSetup

public class SetPartStockingLevelSetup

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.SetPartStockingLevelSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

SetPartStockingLevelSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitSetPartStockingLevel(SetPartStockingLevelSetup)


SetPartStockingLevelSetup Class Members | fcSDK Documentation

SetPartStockingLevelSetup Class Members

The following tables list the members exposed by SetPartStockingLevelSetup.

Public Constructors

 | Name | Description
Public Constructor | SetPartStockingLevelSetup Constructor | Initializes a new instance of the SetPartStockingLevelSetup class.

Public Properties

 | Name | Description
Public Property | IsActive | Specifies whether this restocking entry is active (true) or inactive (false)
Public Property | Location | The names of the restocking location/bin
Public Property | PartDomain | Part domain of the Part
Public Property | PartMaximum | Maximum quantity of parts allowed in this inventory location
Public Property | PartMinimum | Minimum quantity of parts allowed in this inventory location
Public Property | PartNumber | Part number for the Part
Public Property | PartReorderLevel | The quantity of parts that will trigger a reorder Part Request to be created for this inventory location
Public Property | PartReorderQuantity | Quantity of parts to be reordered for this inventory location when reorder level is reached
Public Property | PartRevision | Part revision of the Part
Public Property | Queue | The queue to which the reorder part request will be dispatched

Reference

SetPartStockingLevelSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitSetPartStockingLevel(SetPartStockingLevelSetup)


SetPartStockingLevelSetup Constructor | fcSDK Documentation

SetPartStockingLevelSetup Constructor

The names of the restocking location/bin

The queue to which the reorder part request will be dispatched

Part number for the Part

Part revision of the Part

Part domain of the Part

Minimum quantity of parts allowed in this inventory location

Maximum quantity of parts allowed in this inventory location

The quantity of parts that will trigger a reorder Part Request to be created for this inventory location

Quantity of parts to be reordered for this inventory location when reorder level is reached

Initializes a new instance of the SetPartStockingLevelSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _location_ As Location, _
   ByVal _queue_ As String, _
   ByVal _partNumber_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _partMinimum_ As Short, _
   ByVal _partMaximum_ As Short, _
   ByVal _partReorderLevel_ As Short, _
   ByVal _partReorderQuantity_ As Short _
)

[ConstructorIndexAttribute()]
public SetPartStockingLevelSetup(
   Location _location_,
   string _queue_,
   string _partNumber_,
   string _partRevision_,
   string _partDomain_,
   short _partMinimum_,
   short _partMaximum_,
   short _partReorderLevel_,
   short _partReorderQuantity_
)

Parameters

location

The names of the restocking location/bin

queue

The queue to which the reorder part request will be dispatched

partNumber

Part number for the Part

partRevision

Part revision of the Part

partDomain

Part domain of the Part

partMinimum

Minimum quantity of parts allowed in this inventory location

partMaximum

Maximum quantity of parts allowed in this inventory location

partReorderLevel

The quantity of parts that will trigger a reorder Part Request to be created for this inventory location

partReorderQuantity

Quantity of parts to be reordered for this inventory location when reorder level is reached

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SetPartStockingLevelSetup Class
SetPartStockingLevelSetup Members


IsActive Property (SetPartStockingLevelSetup) | fcSDK Documentation

IsActive Property (SetPartStockingLevelSetup)

Specifies whether this restocking entry is active (true) or inactive (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsActive As Boolean

[PropertyBitValueAttribute()]
public bool IsActive {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SetPartStockingLevelSetup Class
SetPartStockingLevelSetup Members


Location Property (SetPartStockingLevelSetup) | fcSDK Documentation

Location Property (SetPartStockingLevelSetup)

The names of the restocking location/bin

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Location As Location

[PropertyBitValueAttribute()]
public Location Location {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SetPartStockingLevelSetup Class
SetPartStockingLevelSetup Members


PartDomain Property (SetPartStockingLevelSetup) | fcSDK Documentation

PartDomain Property (SetPartStockingLevelSetup)

Part domain of the Part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartDomain As String

[PropertyBitValueAttribute()]
public string PartDomain {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SetPartStockingLevelSetup Class
SetPartStockingLevelSetup Members


PartMaximum Property (SetPartStockingLevelSetup) | fcSDK Documentation

PartMaximum Property (SetPartStockingLevelSetup)

Maximum quantity of parts allowed in this inventory location

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartMaximum As Short

[PropertyBitValueAttribute()]
public short PartMaximum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SetPartStockingLevelSetup Class
SetPartStockingLevelSetup Members


PartMinimum Property (SetPartStockingLevelSetup) | fcSDK Documentation

PartMinimum Property (SetPartStockingLevelSetup)

Minimum quantity of parts allowed in this inventory location

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartMinimum As Short

[PropertyBitValueAttribute()]
public short PartMinimum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SetPartStockingLevelSetup Class
SetPartStockingLevelSetup Members


PartNumber Property (SetPartStockingLevelSetup) | fcSDK Documentation

PartNumber Property (SetPartStockingLevelSetup)

Part number for the Part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartNumber As String

[PropertyBitValueAttribute()]
public string PartNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SetPartStockingLevelSetup Class
SetPartStockingLevelSetup Members


PartReorderLevel Property (SetPartStockingLevelSetup) | fcSDK Documentation

PartReorderLevel Property (SetPartStockingLevelSetup)

The quantity of parts that will trigger a reorder Part Request to be created for this inventory location

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartReorderLevel As Short

[PropertyBitValueAttribute()]
public short PartReorderLevel {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SetPartStockingLevelSetup Class
SetPartStockingLevelSetup Members


PartReorderQuantity Property (SetPartStockingLevelSetup) | fcSDK Documentation

PartReorderQuantity Property (SetPartStockingLevelSetup)

Quantity of parts to be reordered for this inventory location when reorder level is reached

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartReorderQuantity As Short

[PropertyBitValueAttribute()]
public short PartReorderQuantity {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SetPartStockingLevelSetup Class
SetPartStockingLevelSetup Members


PartRevision Property (SetPartStockingLevelSetup) | fcSDK Documentation

PartRevision Property (SetPartStockingLevelSetup)

Part revision of the Part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRevision As String

[PropertyBitValueAttribute()]
public string PartRevision {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SetPartStockingLevelSetup Class
SetPartStockingLevelSetup Members


Queue Property (SetPartStockingLevelSetup) | fcSDK Documentation

Queue Property (SetPartStockingLevelSetup)

The queue to which the reorder part request will be dispatched

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Queue As String

[PropertyBitValueAttribute()]
public string Queue {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SetPartStockingLevelSetup Class
SetPartStockingLevelSetup Members


ShipSetup Class | fcSDK Documentation

ShipSetup Class

Used by the Ship method as setup data for invocation.

Syntax

'Declaration

Public Class ShipSetup

public class ShipSetup

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.ShipSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ShipSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitShip(ShipSetup)


ShipSetup Class Members | fcSDK Documentation

ShipSetup Class Members

The following tables list the members exposed by ShipSetup.

Public Constructors

 | Name | Description
Public Constructor | ShipSetup Constructor | Initializes a new instance of the ShipSetup class.

Public Properties

 | Name | Description
Public Property | Address1 | Address of the site where this Part Request will be shipped
Public Property | Address2 | Other address information for the site where this Part Request will be shipped
Public Property | CarrierName |
The site name of the shipment's carrier. The default will be the dummy site (objid of -2). |  |
Public Property | City | City of the site where this Part Request will be shipped
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | Country | Country of the site where this Part Request will be shipped
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | PackingList | Packing list information for the shipment
Public Property | PartRequestDetailIDNum | Part Request Detail Identifier
Public Property | PieceCount | The number of pieces being shipped for this Part Request
Public Property | ShipDate | The DateTime the Part Request is shipped. If not set, the current time is used.
Public Property | SiteName | Name of the site where this Part Request will be shipped
Public Property | State | State of the Site where this Part Request will be shipped
Public Property | Status | The new status for the Part Request for the Shipped condition. If not set, the default status is used.
Public Property | TotalWeight | Total weight of the pieces being shipped for this Part Request
Public Property | UserName | The user who is shipping the Part Request. If not set, the session user is used.
Public Property | WaybillName | Waybill information for this Part Request shipment
Public Property | ZipCode | Zipcode of the site where this Part Request will be shipped

Reference

ShipSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitShip(ShipSetup)


ShipSetup Constructor | fcSDK Documentation

ShipSetup Constructor

Part Request Detail Identifier

Initializes a new instance of the ShipSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String _
)

[ConstructorIndexAttribute()]
public ShipSetup(
   string _partRequestDetailIDNum_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ShipSetup Class
ShipSetup Members


Address1 Property (ShipSetup) | fcSDK Documentation

Address1 Property (ShipSetup)

Address of the site where this Part Request will be shipped

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Address1 As String

[PropertyBitValueAttribute()]
public string Address1 {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ShipSetup Class
ShipSetup Members


Address2 Property (ShipSetup) | fcSDK Documentation

Address2 Property (ShipSetup)

Other address information for the site where this Part Request will be shipped

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Address2 As String

[PropertyBitValueAttribute()]
public string Address2 {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ShipSetup Class
ShipSetup Members


CarrierName Property (ShipSetup) | fcSDK Documentation

CarrierName Property (ShipSetup)

The site name of the shipment's carrier. The default will be the dummy site (objid of -2).

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CarrierName As String

[PropertyBitValueAttribute()]
public string CarrierName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ShipSetup Class
ShipSetup Members


City Property (ShipSetup) | fcSDK Documentation

City Property (ShipSetup)

City of the site where this Part Request will be shipped

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property City As String

[PropertyBitValueAttribute()]
public string City {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ShipSetup Class
ShipSetup Members


ContactFirstName Property (ShipSetup) | fcSDK Documentation

ContactFirstName Property (ShipSetup)

Contact's first name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactFirstName As String

[PropertyBitValueAttribute()]
public string ContactFirstName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ShipSetup Class
ShipSetup Members


ContactLastName Property (ShipSetup) | fcSDK Documentation

ContactLastName Property (ShipSetup)

Contact's last name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactLastName As String

[PropertyBitValueAttribute()]
public string ContactLastName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ShipSetup Class
ShipSetup Members


Country Property (ShipSetup) | fcSDK Documentation

Country Property (ShipSetup)

Country of the site where this Part Request will be shipped

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Country As String

[PropertyBitValueAttribute()]
public string Country {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ShipSetup Class
ShipSetup Members


GenerateTimeBombs Property (ShipSetup) | fcSDK Documentation

GenerateTimeBombs Property (ShipSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ShipSetup Class
ShipSetup Members


PackingList Property | fcSDK Documentation

PackingList Property

Packing list information for the shipment

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PackingList As String

[PropertyBitValueAttribute()]
public string PackingList {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ShipSetup Class
ShipSetup Members


PartRequestDetailIDNum Property (ShipSetup) | fcSDK Documentation

PartRequestDetailIDNum Property (ShipSetup)

Part Request Detail Identifier

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRequestDetailIDNum As String

[PropertyBitValueAttribute()]
public string PartRequestDetailIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ShipSetup Class
ShipSetup Members


PieceCount Property | fcSDK Documentation

PieceCount Property

The number of pieces being shipped for this Part Request

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PieceCount As Integer

[PropertyBitValueAttribute()]
public int PieceCount {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ShipSetup Class
ShipSetup Members


ShipDate Property (ShipSetup) | fcSDK Documentation

ShipDate Property (ShipSetup)

The DateTime the Part Request is shipped. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ShipDate As Date

[PropertyBitValueAttribute()]
public DateTime ShipDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ShipSetup Class
ShipSetup Members


SiteName Property (ShipSetup) | fcSDK Documentation

SiteName Property (ShipSetup)

Name of the site where this Part Request will be shipped

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteName As String

[PropertyBitValueAttribute()]
public string SiteName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ShipSetup Class
ShipSetup Members


State Property (ShipSetup) | fcSDK Documentation

State Property (ShipSetup)

State of the Site where this Part Request will be shipped

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property State As String

[PropertyBitValueAttribute()]
public string State {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ShipSetup Class
ShipSetup Members


Status Property (ShipSetup) | fcSDK Documentation

Status Property (ShipSetup)

The new status for the Part Request for the Shipped condition. If not set, the default status is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Status As String

[PropertyBitValueAttribute()]
public string Status {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ShipSetup Class
ShipSetup Members


TotalWeight Property | fcSDK Documentation

TotalWeight Property

Total weight of the pieces being shipped for this Part Request

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property TotalWeight As Double

[PropertyBitValueAttribute()]
public double TotalWeight {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ShipSetup Class
ShipSetup Members


UserName Property (ShipSetup) | fcSDK Documentation

UserName Property (ShipSetup)

The user who is shipping the Part Request. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ShipSetup Class
ShipSetup Members


WaybillName Property (ShipSetup) | fcSDK Documentation

WaybillName Property (ShipSetup)

Waybill information for this Part Request shipment

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WaybillName As String

[PropertyBitValueAttribute()]
public string WaybillName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ShipSetup Class
ShipSetup Members


ZipCode Property (ShipSetup) | fcSDK Documentation

ZipCode Property (ShipSetup)

Zipcode of the site where this Part Request will be shipped

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ZipCode As String

[PropertyBitValueAttribute()]
public string ZipCode {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ShipSetup Class
ShipSetup Members


UnpickSetup Class | fcSDK Documentation

UnpickSetup Class

Used by the Unpick method as setup data for invocation.

Syntax

'Declaration

Public Class UnpickSetup

public class UnpickSetup

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.UnpickSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UnpickSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitUnpick(UnpickSetup)


UnpickSetup Class Members | fcSDK Documentation

UnpickSetup Class Members

The following tables list the members exposed by UnpickSetup.

Public Constructors

 | Name | Description
Public Constructor | UnpickSetup Constructor | Overloaded.

Public Properties

 | Name | Description
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Location | The inventory location to unpick the part from for this Part Request
Public Property | PartRequestDetailIDNum | Part Request Detail Identifier
Public Property | SerialNumbers | The serial number(s) of the part(s) to unpick (hard unpick)
Public Property | UnpickDate | The DateTime the Part Request is unpicked. If not set, the current time is used.
Public Property | UseGood | Specifies whether the unpicked inventory is from good stock (true) or bad stock (false)
Public Property | UserName | The user who is unpicking the Part Request. If not set, the session user is used.
Public Property | UseTransitions | Specifies whether or not to check logistics transitions and change the condition/status of the Part Request Detail during the Unpick operation

Reference

UnpickSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitUnpick(UnpickSetup)


UnpickSetup Constructor | fcSDK Documentation

UnpickSetup Constructor

Initializes a new instance of the UnpickSetup class.

Overload List

Overload | Description
UnpickSetup Constructor(String,Location) | Initializes a new instance of the UnpickSetup class. This overload takes a set of required parameters for the API.
UnpickSetup Constructor(String,Location,String[]) | Initializes a new instance of the UnpickSetup class. This overload takes a set of required parameters for the API.
UnpickSetup Constructor(String,Location,Boolean) | Initializes a new instance of the UnpickSetup class. This overload takes a set of required parameters for the API.
UnpickSetup Constructor(String,Location,Boolean,String[]) | Initializes a new instance of the UnpickSetup class. This overload takes a set of required parameters for the API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UnpickSetup Class
UnpickSetup Members


UnpickSetup Constructor(String,Location) | fcSDK Documentation

UnpickSetup Constructor(String,Location)

Part Request Detail Identifier

The inventory location to unpick the part from for this Part Request

Initializes a new instance of the UnpickSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _location_ As Location _
)

[ConstructorIndexAttribute()]
public UnpickSetup(
   string _partRequestDetailIDNum_,
   Location _location_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

location

The inventory location to unpick the part from for this Part Request

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UnpickSetup Class
UnpickSetup Members
Overload List


UnpickSetup Constructor(String,Location,String[]) | fcSDK Documentation

UnpickSetup Constructor(String,Location,String[])

Part Request Detail Identifier

The inventory location to unpick the part from for this Part Request

The serial number(s) of the part(s) to unpick (hard unpick)

Initializes a new instance of the UnpickSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _location_ As Location, _
   ByVal ParamArray _serialNumbers_() As String _
)

[ConstructorIndexAttribute()]
public UnpickSetup(
   string _partRequestDetailIDNum_,
   Location _location_,
   params string[] _serialNumbers_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

location

The inventory location to unpick the part from for this Part Request

serialNumbers

The serial number(s) of the part(s) to unpick (hard unpick)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UnpickSetup Class
UnpickSetup Members
Overload List


UnpickSetup Constructor(String,Location,Boolean) | fcSDK Documentation

UnpickSetup Constructor(String,Location,Boolean)

Part Request Detail Identifier

The inventory location to unpick the part from for this Part Request

Specifies whether or not to check logistics transitions and change the condition/status of the Part Request Detail during the Unpick operation

Initializes a new instance of the UnpickSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _location_ As Location, _
   ByVal _useTransitions_ As Boolean _
)

[ConstructorIndexAttribute()]
public UnpickSetup(
   string _partRequestDetailIDNum_,
   Location _location_,
   bool _useTransitions_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

location

The inventory location to unpick the part from for this Part Request

useTransitions

Specifies whether or not to check logistics transitions and change the condition/status of the Part Request Detail during the Unpick operation

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UnpickSetup Class
UnpickSetup Members
Overload List


UnpickSetup Constructor(String,Location,Boolean,String[]) | fcSDK Documentation

UnpickSetup Constructor(String,Location,Boolean,String[])

Part Request Detail Identifier

The inventory location to unpick the part from for this Part Request

Specifies whether or not to check logistics transitions and change the condition/status of the Part Request Detail during the Unpick operation

The serial number(s) of the part(s) to unpick (hard unpick)

Initializes a new instance of the UnpickSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String, _
   ByVal _location_ As Location, _
   ByVal _useTransitions_ As Boolean, _
   ByVal ParamArray _serialNumbers_() As String _
)

[ConstructorIndexAttribute()]
public UnpickSetup(
   string _partRequestDetailIDNum_,
   Location _location_,
   bool _useTransitions_,
   params string[] _serialNumbers_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

location

The inventory location to unpick the part from for this Part Request

useTransitions

Specifies whether or not to check logistics transitions and change the condition/status of the Part Request Detail during the Unpick operation

serialNumbers

The serial number(s) of the part(s) to unpick (hard unpick)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UnpickSetup Class
UnpickSetup Members
Overload List


GenerateTimeBombs Property (UnpickSetup) | fcSDK Documentation

GenerateTimeBombs Property (UnpickSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UnpickSetup Class
UnpickSetup Members


Location Property (UnpickSetup) | fcSDK Documentation

Location Property (UnpickSetup)

The inventory location to unpick the part from for this Part Request

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Location As Location

[PropertyBitValueAttribute()]
public Location Location {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UnpickSetup Class
UnpickSetup Members


PartRequestDetailIDNum Property (UnpickSetup) | fcSDK Documentation

PartRequestDetailIDNum Property (UnpickSetup)

Part Request Detail Identifier

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRequestDetailIDNum As String

[PropertyBitValueAttribute()]
public string PartRequestDetailIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UnpickSetup Class
UnpickSetup Members


SerialNumbers Property (UnpickSetup) | fcSDK Documentation

SerialNumbers Property (UnpickSetup)

The serial number(s) of the part(s) to unpick (hard unpick)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SerialNumbers As String()

[PropertyBitValueAttribute()]
public string[] SerialNumbers {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UnpickSetup Class
UnpickSetup Members


UnpickDate Property | fcSDK Documentation

UnpickDate Property

The DateTime the Part Request is unpicked. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UnpickDate As Date

[PropertyBitValueAttribute()]
public DateTime UnpickDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UnpickSetup Class
UnpickSetup Members


UseGood Property (UnpickSetup) | fcSDK Documentation

UseGood Property (UnpickSetup)

Specifies whether the unpicked inventory is from good stock (true) or bad stock (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UseGood As Boolean

[PropertyBitValueAttribute()]
public bool UseGood {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UnpickSetup Class
UnpickSetup Members


UserName Property (UnpickSetup) | fcSDK Documentation

UserName Property (UnpickSetup)

The user who is unpicking the Part Request. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UnpickSetup Class
UnpickSetup Members


UseTransitions Property (UnpickSetup) | fcSDK Documentation

UseTransitions Property (UnpickSetup)

Specifies whether or not to check logistics transitions and change the condition/status of the Part Request Detail during the Unpick operation

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UseTransitions As Boolean

[PropertyBitValueAttribute()]
public bool UseTransitions {get; set;}

Remarks

Setting this value to false allows for multiple calls to the API to be performed without extra complex transitions being added to the system. By default, the value is true.

NOTE: The last call to Unpick in the chain of calls should have this value set to true to ensure the transitions are checked and the condition/status is updated properly.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UnpickSetup Class
UnpickSetup Members


UpdateGLAccountSetup Class | fcSDK Documentation

UpdateGLAccountSetup Class

Used by the UpdateGLAccount method as setup data for invocation.

Syntax

'Declaration

Public Class UpdateGLAccountSetup

public class UpdateGLAccountSetup

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.UpdateGLAccountSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdateGLAccountSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitUpdateGLAccount(UpdateGLAccountSetup)


UpdateGLAccountSetup Class Members | fcSDK Documentation

UpdateGLAccountSetup Class Members

The following tables list the members exposed by UpdateGLAccountSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdateGLAccountSetup Constructor | Initializes a new instance of the UpdateGLAccountSetup class.

Public Properties

 | Name | Description
Public Property | AccountNumber | Optional number for the General Ledger account
Public Property | AccountType | Element from the 'Location Type' user list. If not set the default list value is used.
Public Property | CurrentName | Current name of the account
Public Property | Description | Description of the account
Public Property | IsActive | Specifies whether this account is active (true) or inactive (false)
Public Property | IsCompany | Specifies whether this account is company owned (true) or customer owned (false)
Public Property | IsExpenseGLAccount | Specifies whether this is an expense account (true) or a GL account (false)
Public Property | NewName | New name of the account
Public Property | SiteIDNum | Identifier of the Site with which the account is associated

Reference

UpdateGLAccountSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitUpdateGLAccount(UpdateGLAccountSetup)


UpdateGLAccountSetup Constructor | fcSDK Documentation

UpdateGLAccountSetup Constructor

Current name of the account

Identifier of the Site with which the account is associated

Initializes a new instance of the UpdateGLAccountSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _currentName_ As String, _
   ByVal _siteIDNum_ As String _
)

[ConstructorIndexAttribute()]
public UpdateGLAccountSetup(
   string _currentName_,
   string _siteIDNum_
)

Parameters

currentName

Current name of the account

siteIDNum

Identifier of the Site with which the account is associated

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateGLAccountSetup Class
UpdateGLAccountSetup Members


AccountNumber Property (UpdateGLAccountSetup) | fcSDK Documentation

AccountNumber Property (UpdateGLAccountSetup)

Optional number for the General Ledger account

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AccountNumber As String

[PropertyBitValueAttribute()]
public string AccountNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateGLAccountSetup Class
UpdateGLAccountSetup Members


AccountType Property (UpdateGLAccountSetup) | fcSDK Documentation

AccountType Property (UpdateGLAccountSetup)

Element from the 'Location Type' user list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AccountType As String

[PropertyBitValueAttribute()]
public string AccountType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateGLAccountSetup Class
UpdateGLAccountSetup Members


CurrentName Property (UpdateGLAccountSetup) | fcSDK Documentation

CurrentName Property (UpdateGLAccountSetup)

Current name of the account

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CurrentName As String

[PropertyBitValueAttribute()]
public string CurrentName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateGLAccountSetup Class
UpdateGLAccountSetup Members


Description Property (UpdateGLAccountSetup) | fcSDK Documentation

Description Property (UpdateGLAccountSetup)

Description of the account

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Description As String

[PropertyBitValueAttribute()]
public string Description {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateGLAccountSetup Class
UpdateGLAccountSetup Members


IsActive Property (UpdateGLAccountSetup) | fcSDK Documentation

IsActive Property (UpdateGLAccountSetup)

Specifies whether this account is active (true) or inactive (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsActive As Boolean

[PropertyBitValueAttribute()]
public bool IsActive {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateGLAccountSetup Class
UpdateGLAccountSetup Members


IsCompany Property (UpdateGLAccountSetup) | fcSDK Documentation

IsCompany Property (UpdateGLAccountSetup)

Specifies whether this account is company owned (true) or customer owned (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsCompany As Boolean

[PropertyBitValueAttribute()]
public bool IsCompany {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateGLAccountSetup Class
UpdateGLAccountSetup Members


IsExpenseGLAccount Property (UpdateGLAccountSetup) | fcSDK Documentation

IsExpenseGLAccount Property (UpdateGLAccountSetup)

Specifies whether this is an expense account (true) or a GL account (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsExpenseGLAccount As Boolean

[PropertyBitValueAttribute()]
public bool IsExpenseGLAccount {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateGLAccountSetup Class
UpdateGLAccountSetup Members


NewName Property (UpdateGLAccountSetup) | fcSDK Documentation

NewName Property (UpdateGLAccountSetup)

New name of the account

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewName As String

[PropertyBitValueAttribute()]
public string NewName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateGLAccountSetup Class
UpdateGLAccountSetup Members


SiteIDNum Property (UpdateGLAccountSetup) | fcSDK Documentation

SiteIDNum Property (UpdateGLAccountSetup)

Identifier of the Site with which the account is associated

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteIDNum As String

[PropertyBitValueAttribute()]
public string SiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateGLAccountSetup Class
UpdateGLAccountSetup Members


UpdateInventoryBinSetup Class | fcSDK Documentation

UpdateInventoryBinSetup Class

Used by the UpdateInventoryBin method as setup data for invocation.

Syntax

'Declaration

Public Class UpdateInventoryBinSetup

public class UpdateInventoryBinSetup

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.UpdateInventoryBinSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdateInventoryBinSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitUpdateInventoryBin(UpdateInventoryBinSetup)


UpdateInventoryBinSetup Class Members | fcSDK Documentation

UpdateInventoryBinSetup Class Members

The following tables list the members exposed by UpdateInventoryBinSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdateInventoryBinSetup Constructor | Initializes a new instance of the UpdateInventoryBinSetup class.

Public Properties

 | Name | Description
Public Property | CurrentLocation | The inventory location and bin to update
Public Property | IsActive | Specifies whether this inventory bin is active (true) or inactive (false)
Public Property | NewBinName | New name of the inventory bin

Reference

UpdateInventoryBinSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitUpdateInventoryBin(UpdateInventoryBinSetup)


UpdateInventoryBinSetup Constructor | fcSDK Documentation

UpdateInventoryBinSetup Constructor

The inventory location and bin to update

New name of the inventory bin

Initializes a new instance of the UpdateInventoryBinSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _currentLocation_ As Location, _
   ByVal _newBinName_ As String _
)

[ConstructorIndexAttribute()]
public UpdateInventoryBinSetup(
   Location _currentLocation_,
   string _newBinName_
)

Parameters

currentLocation

The inventory location and bin to update

newBinName

New name of the inventory bin

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateInventoryBinSetup Class
UpdateInventoryBinSetup Members


CurrentLocation Property (UpdateInventoryBinSetup) | fcSDK Documentation

CurrentLocation Property (UpdateInventoryBinSetup)

The inventory location and bin to update

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CurrentLocation As Location

[PropertyBitValueAttribute()]
public Location CurrentLocation {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateInventoryBinSetup Class
UpdateInventoryBinSetup Members


IsActive Property (UpdateInventoryBinSetup) | fcSDK Documentation

IsActive Property (UpdateInventoryBinSetup)

Specifies whether this inventory bin is active (true) or inactive (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsActive As Boolean

[PropertyBitValueAttribute()]
public bool IsActive {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateInventoryBinSetup Class
UpdateInventoryBinSetup Members


NewBinName Property | fcSDK Documentation

NewBinName Property

New name of the inventory bin

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewBinName As String

[PropertyBitValueAttribute()]
public string NewBinName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateInventoryBinSetup Class
UpdateInventoryBinSetup Members


UpdateInventoryLocationSetup Class | fcSDK Documentation

UpdateInventoryLocationSetup Class

Used by the UpdateInventoryLocation method as setup data for invocation.

Syntax

'Declaration

Public Class UpdateInventoryLocationSetup

public class UpdateInventoryLocationSetup

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.UpdateInventoryLocationSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdateInventoryLocationSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitUpdateInventoryLocation(UpdateInventoryLocationSetup)


UpdateInventoryLocationSetup Class Members | fcSDK Documentation

UpdateInventoryLocationSetup Class Members

The following tables list the members exposed by UpdateInventoryLocationSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdateInventoryLocationSetup Constructor | Initializes a new instance of the UpdateInventoryLocationSetup class.

Public Properties

 | Name | Description
Public Property | AccountType | Element from the 'Location Type' user list. If not set the default list value is used.
Public Property | CapitalGLAccount | The name of the Capital GL account with which this inventory location is associated
Public Property | CurrentName | Current name of the inventory location
Public Property | Description | Description of the inventory location
Public Property | IsActive | Specifies whether this inventory location is active (true) or inactive (false)
Public Property | IsCompany | Specifies whether this account is company owned (true) or customer owned (false)
Public Property | NewName | New name of the inventory location
Public Property | PartAuthorizationLevel | The part authorization level for this inventory location.
Public Property | ReportsToLocation | Name of the inventory location to which this new inventory location reports
Public Property | SiteIDNum | Identifier of the site with which this inventory location is associated

Reference

UpdateInventoryLocationSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitUpdateInventoryLocation(UpdateInventoryLocationSetup)


UpdateInventoryLocationSetup Constructor | fcSDK Documentation

UpdateInventoryLocationSetup Constructor

Current name of the inventory location

Initializes a new instance of the UpdateInventoryLocationSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _currentName_ As String _
)

[ConstructorIndexAttribute()]
public UpdateInventoryLocationSetup(
   string _currentName_
)

Parameters

currentName

Current name of the inventory location

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateInventoryLocationSetup Class
UpdateInventoryLocationSetup Members


AccountType Property (UpdateInventoryLocationSetup) | fcSDK Documentation

AccountType Property (UpdateInventoryLocationSetup)

Element from the 'Location Type' user list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AccountType As String

[PropertyBitValueAttribute()]
public string AccountType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateInventoryLocationSetup Class
UpdateInventoryLocationSetup Members


CapitalGLAccount Property (UpdateInventoryLocationSetup) | fcSDK Documentation

CapitalGLAccount Property (UpdateInventoryLocationSetup)

The name of the Capital GL account with which this inventory location is associated

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CapitalGLAccount As String

[PropertyBitValueAttribute()]
public string CapitalGLAccount {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateInventoryLocationSetup Class
UpdateInventoryLocationSetup Members


CurrentName Property (UpdateInventoryLocationSetup) | fcSDK Documentation

CurrentName Property (UpdateInventoryLocationSetup)

Current name of the inventory location

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CurrentName As String

[PropertyBitValueAttribute()]
public string CurrentName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateInventoryLocationSetup Class
UpdateInventoryLocationSetup Members


Description Property (UpdateInventoryLocationSetup) | fcSDK Documentation

Description Property (UpdateInventoryLocationSetup)

Description of the inventory location

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Description As String

[PropertyBitValueAttribute()]
public string Description {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateInventoryLocationSetup Class
UpdateInventoryLocationSetup Members


IsActive Property (UpdateInventoryLocationSetup) | fcSDK Documentation

IsActive Property (UpdateInventoryLocationSetup)

Specifies whether this inventory location is active (true) or inactive (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsActive As Boolean

[PropertyBitValueAttribute()]
public bool IsActive {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateInventoryLocationSetup Class
UpdateInventoryLocationSetup Members


IsCompany Property (UpdateInventoryLocationSetup) | fcSDK Documentation

IsCompany Property (UpdateInventoryLocationSetup)

Specifies whether this account is company owned (true) or customer owned (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsCompany As Boolean

[PropertyBitValueAttribute()]
public bool IsCompany {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateInventoryLocationSetup Class
UpdateInventoryLocationSetup Members


NewName Property (UpdateInventoryLocationSetup) | fcSDK Documentation

NewName Property (UpdateInventoryLocationSetup)

New name of the inventory location

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewName As String

[PropertyBitValueAttribute()]
public string NewName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateInventoryLocationSetup Class
UpdateInventoryLocationSetup Members


PartAuthorizationLevel Property (UpdateInventoryLocationSetup) | fcSDK Documentation

PartAuthorizationLevel Property (UpdateInventoryLocationSetup)

The part authorization level for this inventory location.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartAuthorizationLevel As PartAuthorizationLevel

[PropertyBitValueAttribute()]
public PartAuthorizationLevel PartAuthorizationLevel {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateInventoryLocationSetup Class
UpdateInventoryLocationSetup Members


ReportsToLocation Property (UpdateInventoryLocationSetup) | fcSDK Documentation

ReportsToLocation Property (UpdateInventoryLocationSetup)

Name of the inventory location to which this new inventory location reports

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ReportsToLocation As String

[PropertyBitValueAttribute()]
public string ReportsToLocation {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateInventoryLocationSetup Class
UpdateInventoryLocationSetup Members


SiteIDNum Property (UpdateInventoryLocationSetup) | fcSDK Documentation

SiteIDNum Property (UpdateInventoryLocationSetup)

Identifier of the site with which this inventory location is associated

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteIDNum As String

[PropertyBitValueAttribute()]
public string SiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateInventoryLocationSetup Class
UpdateInventoryLocationSetup Members


UpdateLocationServicingSiteSetup Class | fcSDK Documentation

UpdateLocationServicingSiteSetup Class

Used by the UpdateLocationServicingSite method as setup data for invocation.

Syntax

'Declaration

Public Class UpdateLocationServicingSiteSetup

public class UpdateLocationServicingSiteSetup

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.UpdateLocationServicingSiteSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdateLocationServicingSiteSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitUpdateLocationServicingSite(UpdateLocationServicingSiteSetup)


UpdateLocationServicingSiteSetup Class Members | fcSDK Documentation

UpdateLocationServicingSiteSetup Class Members

The following tables list the members exposed by UpdateLocationServicingSiteSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdateLocationServicingSiteSetup Constructor | Initializes a new instance of the UpdateLocationServicingSiteSetup class.

Public Properties

 | Name | Description
Public Property | LocationName | Name of the inventory location
Public Property | LocationRank | The rank of this inventory location at the associated site
Public Property | SiteIDNum | Identifier of the Site that the inventory location is servicing

Reference

UpdateLocationServicingSiteSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitUpdateLocationServicingSite(UpdateLocationServicingSiteSetup)


UpdateLocationServicingSiteSetup Constructor | fcSDK Documentation

UpdateLocationServicingSiteSetup Constructor

Identifier of the Site that the inventory location is servicing

Name of the inventory location

The rank of this inventory location at the associated site

Initializes a new instance of the UpdateLocationServicingSiteSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _siteIDNum_ As String, _
   ByVal _locationName_ As String, _
   ByVal _locationRank_ As Short _
)

[ConstructorIndexAttribute()]
public UpdateLocationServicingSiteSetup(
   string _siteIDNum_,
   string _locationName_,
   short _locationRank_
)

Parameters

siteIDNum

Identifier of the Site that the inventory location is servicing

locationName

Name of the inventory location

locationRank

The rank of this inventory location at the associated site

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateLocationServicingSiteSetup Class
UpdateLocationServicingSiteSetup Members


LocationName Property (UpdateLocationServicingSiteSetup) | fcSDK Documentation

LocationName Property (UpdateLocationServicingSiteSetup)

Name of the inventory location

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LocationName As String

[PropertyBitValueAttribute()]
public string LocationName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateLocationServicingSiteSetup Class
UpdateLocationServicingSiteSetup Members


LocationRank Property (UpdateLocationServicingSiteSetup) | fcSDK Documentation

LocationRank Property (UpdateLocationServicingSiteSetup)

The rank of this inventory location at the associated site

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LocationRank As Short

[PropertyBitValueAttribute()]
public short LocationRank {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateLocationServicingSiteSetup Class
UpdateLocationServicingSiteSetup Members


SiteIDNum Property (UpdateLocationServicingSiteSetup) | fcSDK Documentation

SiteIDNum Property (UpdateLocationServicingSiteSetup)

Identifier of the Site that the inventory location is servicing

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteIDNum As String

[PropertyBitValueAttribute()]
public string SiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateLocationServicingSiteSetup Class
UpdateLocationServicingSiteSetup Members


UpdatePartRequestDetailSetup Class | fcSDK Documentation

UpdatePartRequestDetailSetup Class

Used by the UpdatePartRequestDetail method as setup data for invocation.

Syntax

'Declaration

Public Class UpdatePartRequestDetailSetup

public class UpdatePartRequestDetailSetup

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.UpdatePartRequestDetailSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdatePartRequestDetailSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitUpdatePartRequestDetail(UpdatePartRequestDetailSetup)


UpdatePartRequestDetailSetup Class Members | fcSDK Documentation

UpdatePartRequestDetailSetup Class Members

The following tables list the members exposed by UpdatePartRequestDetailSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdatePartRequestDetailSetup Constructor | Initializes a new instance of the UpdatePartRequestDetailSetup class.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CarrierName | Element from the 'Carrier' application list. If not set the default list value is used.
Public Property | DetailType | Element from the 'RMA Type' application list. If not set the default list value is used.
Public Property | HasWarranty | Specifies whether this Part Request Detail is under warranty (true) or not (false)
Public Property | Notes | Notes about the Part Request Detail update
Public Property | PartDomain | Part domain for the Part
Public Property | PartNumber | Part number for the Part
Public Property | PartRequestDetailIDNum | Part Request Detail Identifier
Public Property | PartRevision | Part revision for the Part
Public Property | Priority | Element from the 'Request Priority' application list. If not set the default list value is used.
Public Property | Quantity | The number of parts for this Part Request
Public Property | SerialNumber | The serial number of the part specified for this Part Request
Public Property | ShippingMethod | Element from the 'Ship Via' application list. If not set the default list value is used.
Public Property | SitePartObjid | The Objid of the Site Part specified for this Part Request
Public Property | Status | The new status for the Part Request for the current condition. If not set, the default status is used.

Reference

UpdatePartRequestDetailSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitUpdatePartRequestDetail(UpdatePartRequestDetailSetup)


UpdatePartRequestDetailSetup Constructor | fcSDK Documentation

UpdatePartRequestDetailSetup Constructor

Part Request Detail Identifier

Initializes a new instance of the UpdatePartRequestDetailSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String _
)

[ConstructorIndexAttribute()]
public UpdatePartRequestDetailSetup(
   string _partRequestDetailIDNum_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRequestDetailSetup Class
UpdatePartRequestDetailSetup Members


AdditionalFields Property (UpdatePartRequestDetailSetup) | fcSDK Documentation

AdditionalFields Property (UpdatePartRequestDetailSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRequestDetailSetup Class
UpdatePartRequestDetailSetup Members


CarrierName Property (UpdatePartRequestDetailSetup) | fcSDK Documentation

CarrierName Property (UpdatePartRequestDetailSetup)

Element from the 'Carrier' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CarrierName As String

[PropertyBitValueAttribute()]
public string CarrierName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRequestDetailSetup Class
UpdatePartRequestDetailSetup Members


DetailType Property (UpdatePartRequestDetailSetup) | fcSDK Documentation

DetailType Property (UpdatePartRequestDetailSetup)

Element from the 'RMA Type' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property DetailType As String

[PropertyBitValueAttribute()]
public string DetailType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRequestDetailSetup Class
UpdatePartRequestDetailSetup Members


HasWarranty Property (UpdatePartRequestDetailSetup) | fcSDK Documentation

HasWarranty Property (UpdatePartRequestDetailSetup)

Specifies whether this Part Request Detail is under warranty (true) or not (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property HasWarranty As Boolean

[PropertyBitValueAttribute()]
public bool HasWarranty {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRequestDetailSetup Class
UpdatePartRequestDetailSetup Members


Notes Property (UpdatePartRequestDetailSetup) | fcSDK Documentation

Notes Property (UpdatePartRequestDetailSetup)

Notes about the Part Request Detail update

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Remarks

If this property has not been set no change will occur. If the property is set, even to an empty string, that value will be reflected in the update.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRequestDetailSetup Class
UpdatePartRequestDetailSetup Members


PartDomain Property (UpdatePartRequestDetailSetup) | fcSDK Documentation

PartDomain Property (UpdatePartRequestDetailSetup)

Part domain for the Part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartDomain As String

[PropertyBitValueAttribute()]
public string PartDomain {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRequestDetailSetup Class
UpdatePartRequestDetailSetup Members


PartNumber Property (UpdatePartRequestDetailSetup) | fcSDK Documentation

PartNumber Property (UpdatePartRequestDetailSetup)

Part number for the Part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartNumber As String

[PropertyBitValueAttribute()]
public string PartNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRequestDetailSetup Class
UpdatePartRequestDetailSetup Members


PartRequestDetailIDNum Property (UpdatePartRequestDetailSetup) | fcSDK Documentation

PartRequestDetailIDNum Property (UpdatePartRequestDetailSetup)

Part Request Detail Identifier

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRequestDetailIDNum As String

[PropertyBitValueAttribute()]
public string PartRequestDetailIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRequestDetailSetup Class
UpdatePartRequestDetailSetup Members


PartRevision Property (UpdatePartRequestDetailSetup) | fcSDK Documentation

PartRevision Property (UpdatePartRequestDetailSetup)

Part revision for the Part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRevision As String

[PropertyBitValueAttribute()]
public string PartRevision {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRequestDetailSetup Class
UpdatePartRequestDetailSetup Members


Priority Property (UpdatePartRequestDetailSetup) | fcSDK Documentation

Priority Property (UpdatePartRequestDetailSetup)

Element from the 'Request Priority' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Priority As String

[PropertyBitValueAttribute()]
public string Priority {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRequestDetailSetup Class
UpdatePartRequestDetailSetup Members


Quantity Property (UpdatePartRequestDetailSetup) | fcSDK Documentation

Quantity Property (UpdatePartRequestDetailSetup)

The number of parts for this Part Request

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Quantity As Integer

[PropertyBitValueAttribute()]
public int Quantity {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRequestDetailSetup Class
UpdatePartRequestDetailSetup Members


SerialNumber Property (UpdatePartRequestDetailSetup) | fcSDK Documentation

SerialNumber Property (UpdatePartRequestDetailSetup)

The serial number of the part specified for this Part Request

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SerialNumber As String

[PropertyBitValueAttribute()]
public string SerialNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRequestDetailSetup Class
UpdatePartRequestDetailSetup Members


ShippingMethod Property (UpdatePartRequestDetailSetup) | fcSDK Documentation

ShippingMethod Property (UpdatePartRequestDetailSetup)

Element from the 'Ship Via' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ShippingMethod As String

[PropertyBitValueAttribute()]
public string ShippingMethod {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRequestDetailSetup Class
UpdatePartRequestDetailSetup Members


SitePartObjid Property (UpdatePartRequestDetailSetup) | fcSDK Documentation

SitePartObjid Property (UpdatePartRequestDetailSetup)

The Objid of the Site Part specified for this Part Request

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SitePartObjid As Integer

[PropertyBitValueAttribute()]
public int SitePartObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRequestDetailSetup Class
UpdatePartRequestDetailSetup Members


Status Property (UpdatePartRequestDetailSetup) | fcSDK Documentation

Status Property (UpdatePartRequestDetailSetup)

The new status for the Part Request for the current condition. If not set, the default status is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Status As String

[PropertyBitValueAttribute()]
public string Status {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRequestDetailSetup Class
UpdatePartRequestDetailSetup Members


UpdatePartRequestHeaderSetup Class | fcSDK Documentation

UpdatePartRequestHeaderSetup Class

Used by the UpdatePartRequestHeader method as setup data for invocation.

Syntax

'Declaration

Public Class UpdatePartRequestHeaderSetup

public class UpdatePartRequestHeaderSetup

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.UpdatePartRequestHeaderSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdatePartRequestHeaderSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitUpdatePartRequestHeader(UpdatePartRequestHeaderSetup)


UpdatePartRequestHeaderSetup Class Members | fcSDK Documentation

UpdatePartRequestHeaderSetup Class Members

The following tables list the members exposed by UpdatePartRequestHeaderSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdatePartRequestHeaderSetup Constructor | Initializes a new instance of the UpdatePartRequestHeaderSetup class.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | BillSiteIDNum | Identifier of the Site where this Part Request should be billed
Public Property | CaseIDNum | Identifier of the Case with which this Part Request Header is associated.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | Notes | Notes about the Part Request Header update
Public Property | PartRequestHeaderIDNum | Part Request Header Identifier
Public Property | PaymentMethod | Element from the 'Payment Method' application list. If not set the default list value is used.
Public Property | PaymentTerms | Element from the 'Payment Terms' application list. If not set the default list value is used.
Public Property | Priority | Element from the 'Request Priority' application list. If not set the default list value is used.
Public Property | ShipToSiteIDNum | Identifier of the Site where this Part Request should be shipped

Reference

UpdatePartRequestHeaderSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitUpdatePartRequestHeader(UpdatePartRequestHeaderSetup)


UpdatePartRequestHeaderSetup Constructor | fcSDK Documentation

UpdatePartRequestHeaderSetup Constructor

Part Request Header Identifier

Initializes a new instance of the UpdatePartRequestHeaderSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestHeaderIDNum_ As String _
)

[ConstructorIndexAttribute()]
public UpdatePartRequestHeaderSetup(
   string _partRequestHeaderIDNum_
)

Parameters

partRequestHeaderIDNum

Part Request Header Identifier

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRequestHeaderSetup Class
UpdatePartRequestHeaderSetup Members


AdditionalFields Property (UpdatePartRequestHeaderSetup) | fcSDK Documentation

AdditionalFields Property (UpdatePartRequestHeaderSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRequestHeaderSetup Class
UpdatePartRequestHeaderSetup Members


BillSiteIDNum Property (UpdatePartRequestHeaderSetup) | fcSDK Documentation

BillSiteIDNum Property (UpdatePartRequestHeaderSetup)

Identifier of the Site where this Part Request should be billed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property BillSiteIDNum As String

[PropertyBitValueAttribute()]
public string BillSiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRequestHeaderSetup Class
UpdatePartRequestHeaderSetup Members


CaseIDNum Property (UpdatePartRequestHeaderSetup) | fcSDK Documentation

CaseIDNum Property (UpdatePartRequestHeaderSetup)

Identifier of the Case with which this Part Request Header is associated.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Remarks

If this property is not set, the existing value will remain. If set to a value other than an empty string, this value will be updated in the database. Otherwise, if this property is set to an empty string the relation from the Case or Subcase to the current Part Request Header will be removed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRequestHeaderSetup Class
UpdatePartRequestHeaderSetup Members


ContactFirstName Property (UpdatePartRequestHeaderSetup) | fcSDK Documentation

ContactFirstName Property (UpdatePartRequestHeaderSetup)

Contact's first name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactFirstName As String

[PropertyBitValueAttribute()]
public string ContactFirstName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRequestHeaderSetup Class
UpdatePartRequestHeaderSetup Members


ContactLastName Property (UpdatePartRequestHeaderSetup) | fcSDK Documentation

ContactLastName Property (UpdatePartRequestHeaderSetup)

Contact's last name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactLastName As String

[PropertyBitValueAttribute()]
public string ContactLastName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRequestHeaderSetup Class
UpdatePartRequestHeaderSetup Members


ContactPhone Property (UpdatePartRequestHeaderSetup) | fcSDK Documentation

ContactPhone Property (UpdatePartRequestHeaderSetup)

Contact's phone number.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactPhone As String

[PropertyBitValueAttribute()]
public string ContactPhone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRequestHeaderSetup Class
UpdatePartRequestHeaderSetup Members


Notes Property (UpdatePartRequestHeaderSetup) | fcSDK Documentation

Notes Property (UpdatePartRequestHeaderSetup)

Notes about the Part Request Header update

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Remarks

If this property is not set, the existing value will remain. If set to a value other than an empty string, this value will be updated in the database. Otherwise, if this property is set to an empty string the notes will be cleared in the database.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRequestHeaderSetup Class
UpdatePartRequestHeaderSetup Members


PartRequestHeaderIDNum Property (UpdatePartRequestHeaderSetup) | fcSDK Documentation

PartRequestHeaderIDNum Property (UpdatePartRequestHeaderSetup)

Part Request Header Identifier

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRequestHeaderIDNum As String

[PropertyBitValueAttribute()]
public string PartRequestHeaderIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRequestHeaderSetup Class
UpdatePartRequestHeaderSetup Members


PaymentMethod Property (UpdatePartRequestHeaderSetup) | fcSDK Documentation

PaymentMethod Property (UpdatePartRequestHeaderSetup)

Element from the 'Payment Method' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PaymentMethod As String

[PropertyBitValueAttribute()]
public string PaymentMethod {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRequestHeaderSetup Class
UpdatePartRequestHeaderSetup Members


PaymentTerms Property (UpdatePartRequestHeaderSetup) | fcSDK Documentation

PaymentTerms Property (UpdatePartRequestHeaderSetup)

Element from the 'Payment Terms' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PaymentTerms As String

[PropertyBitValueAttribute()]
public string PaymentTerms {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRequestHeaderSetup Class
UpdatePartRequestHeaderSetup Members


Priority Property (UpdatePartRequestHeaderSetup) | fcSDK Documentation

Priority Property (UpdatePartRequestHeaderSetup)

Element from the 'Request Priority' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Priority As String

[PropertyBitValueAttribute()]
public string Priority {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRequestHeaderSetup Class
UpdatePartRequestHeaderSetup Members


ShipToSiteIDNum Property (UpdatePartRequestHeaderSetup) | fcSDK Documentation

ShipToSiteIDNum Property (UpdatePartRequestHeaderSetup)

Identifier of the Site where this Part Request should be shipped

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ShipToSiteIDNum As String

[PropertyBitValueAttribute()]
public string ShipToSiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartRequestHeaderSetup Class
UpdatePartRequestHeaderSetup Members


UpdatePartStockingLevelSetup Class | fcSDK Documentation

UpdatePartStockingLevelSetup Class

Used by the UpdatePartStockingLevel method as setup data for invocation.

Syntax

'Declaration

Public Class UpdatePartStockingLevelSetup

public class UpdatePartStockingLevelSetup

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.UpdatePartStockingLevelSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdatePartStockingLevelSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitUpdatePartStockingLevel(UpdatePartStockingLevelSetup)


UpdatePartStockingLevelSetup Class Members | fcSDK Documentation

UpdatePartStockingLevelSetup Class Members

The following tables list the members exposed by UpdatePartStockingLevelSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdatePartStockingLevelSetup Constructor | Initializes a new instance of the UpdatePartStockingLevelSetup class.

Public Properties

 | Name | Description
Public Property | CurrentLocation | The location and bin used for restocking
Public Property | IsActive | Specifies whether this restocking is entry active (true) or inactive (false)
Public Property | PartDomain | Part domain for the Part
Public Property | PartMaximum | Maximum quantity of parts allowed in this inventory location
Public Property | PartMinimum | Minimum quantity of parts allowed in this inventory location
Public Property | PartNumber | Part number for the Part
Public Property | PartReorderLevel | The quantity of parts that will trigger a reorder Part Request to be created for this inventory location
Public Property | PartReorderQuantity | Quantity of parts to be reordered for this inventory location when reorder level is reached
Public Property | PartRevision | Part revision for the Part
Public Property | Queue | The queue to which the reorder part request will be dispatched
Public Property | ToBinName | The name of the bin to which the record will be moved. If not set or blank, no move occurs.
Public Property | ToQueue | The new name of the queue to which the reorder part request will be dispatched

Reference

UpdatePartStockingLevelSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitUpdatePartStockingLevel(UpdatePartStockingLevelSetup)


UpdatePartStockingLevelSetup Constructor | fcSDK Documentation

UpdatePartStockingLevelSetup Constructor

The location and bin used for restocking

The queue to which the reorder part request will be dispatched

Part number for the Part

Part revision for the Part

Part domain for the Part

Initializes a new instance of the UpdatePartStockingLevelSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _currentLocation_ As Location, _
   ByVal _queue_ As String, _
   ByVal _partNumber_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _partDomain_ As String _
)

[ConstructorIndexAttribute()]
public UpdatePartStockingLevelSetup(
   Location _currentLocation_,
   string _queue_,
   string _partNumber_,
   string _partRevision_,
   string _partDomain_
)

Parameters

currentLocation

The location and bin used for restocking

queue

The queue to which the reorder part request will be dispatched

partNumber

Part number for the Part

partRevision

Part revision for the Part

partDomain

Part domain for the Part

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartStockingLevelSetup Class
UpdatePartStockingLevelSetup Members


CurrentLocation Property (UpdatePartStockingLevelSetup) | fcSDK Documentation

CurrentLocation Property (UpdatePartStockingLevelSetup)

The location and bin used for restocking

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CurrentLocation As Location

[PropertyBitValueAttribute()]
public Location CurrentLocation {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartStockingLevelSetup Class
UpdatePartStockingLevelSetup Members


IsActive Property (UpdatePartStockingLevelSetup) | fcSDK Documentation

IsActive Property (UpdatePartStockingLevelSetup)

Specifies whether this restocking is entry active (true) or inactive (false)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsActive As Boolean

[PropertyBitValueAttribute()]
public bool IsActive {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartStockingLevelSetup Class
UpdatePartStockingLevelSetup Members


PartDomain Property (UpdatePartStockingLevelSetup) | fcSDK Documentation

PartDomain Property (UpdatePartStockingLevelSetup)

Part domain for the Part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartDomain As String

[PropertyBitValueAttribute()]
public string PartDomain {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartStockingLevelSetup Class
UpdatePartStockingLevelSetup Members


PartMaximum Property (UpdatePartStockingLevelSetup) | fcSDK Documentation

PartMaximum Property (UpdatePartStockingLevelSetup)

Maximum quantity of parts allowed in this inventory location

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartMaximum As Short

[PropertyBitValueAttribute()]
public short PartMaximum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartStockingLevelSetup Class
UpdatePartStockingLevelSetup Members


PartMinimum Property (UpdatePartStockingLevelSetup) | fcSDK Documentation

PartMinimum Property (UpdatePartStockingLevelSetup)

Minimum quantity of parts allowed in this inventory location

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartMinimum As Short

[PropertyBitValueAttribute()]
public short PartMinimum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartStockingLevelSetup Class
UpdatePartStockingLevelSetup Members


PartNumber Property (UpdatePartStockingLevelSetup) | fcSDK Documentation

PartNumber Property (UpdatePartStockingLevelSetup)

Part number for the Part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartNumber As String

[PropertyBitValueAttribute()]
public string PartNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartStockingLevelSetup Class
UpdatePartStockingLevelSetup Members


PartReorderLevel Property (UpdatePartStockingLevelSetup) | fcSDK Documentation

PartReorderLevel Property (UpdatePartStockingLevelSetup)

The quantity of parts that will trigger a reorder Part Request to be created for this inventory location

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartReorderLevel As Short

[PropertyBitValueAttribute()]
public short PartReorderLevel {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartStockingLevelSetup Class
UpdatePartStockingLevelSetup Members


PartReorderQuantity Property (UpdatePartStockingLevelSetup) | fcSDK Documentation

PartReorderQuantity Property (UpdatePartStockingLevelSetup)

Quantity of parts to be reordered for this inventory location when reorder level is reached

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartReorderQuantity As Short

[PropertyBitValueAttribute()]
public short PartReorderQuantity {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartStockingLevelSetup Class
UpdatePartStockingLevelSetup Members


PartRevision Property (UpdatePartStockingLevelSetup) | fcSDK Documentation

PartRevision Property (UpdatePartStockingLevelSetup)

Part revision for the Part

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRevision As String

[PropertyBitValueAttribute()]
public string PartRevision {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartStockingLevelSetup Class
UpdatePartStockingLevelSetup Members


Queue Property (UpdatePartStockingLevelSetup) | fcSDK Documentation

Queue Property (UpdatePartStockingLevelSetup)

The queue to which the reorder part request will be dispatched

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Queue As String

[PropertyBitValueAttribute()]
public string Queue {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartStockingLevelSetup Class
UpdatePartStockingLevelSetup Members


ToBinName Property | fcSDK Documentation

ToBinName Property

The name of the bin to which the record will be moved. If not set or blank, no move occurs.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ToBinName As String

[PropertyBitValueAttribute()]
public string ToBinName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartStockingLevelSetup Class
UpdatePartStockingLevelSetup Members


ToQueue Property | fcSDK Documentation

ToQueue Property

The new name of the queue to which the reorder part request will be dispatched

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ToQueue As String

[PropertyBitValueAttribute()]
public string ToQueue {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdatePartStockingLevelSetup Class
UpdatePartStockingLevelSetup Members


YankPartRequestSetup Class | fcSDK Documentation

YankPartRequestSetup Class

Used by the YankPartRequest method as setup data for invocation.

Syntax

'Declaration

Public Class YankPartRequestSetup

public class YankPartRequestSetup

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Logistics.YankPartRequestSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Logistics

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

YankPartRequestSetup Members FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitYankPartRequest(YankPartRequestSetup)


YankPartRequestSetup Class Members | fcSDK Documentation

YankPartRequestSetup Class Members

The following tables list the members exposed by YankPartRequestSetup.

Public Constructors

 | Name | Description
Public Constructor | YankPartRequestSetup Constructor | Initializes a new instance of the YankPartRequestSetup class.

Public Properties

 | Name | Description
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | PartRequestDetailIDNum | Part Request Detail Identifier
Public Property | UserName | The user who has yanked the PartRequest. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the PartRequest. If not set, the UserName's default is used.
Public Property | YankDate | DateTime the PartRequest was yanked. If not set, the current time is used.

Reference

YankPartRequestSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitYankPartRequest(YankPartRequestSetup)


YankPartRequestSetup Constructor | fcSDK Documentation

YankPartRequestSetup Constructor

Part Request Detail Identifier

Initializes a new instance of the YankPartRequestSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partRequestDetailIDNum_ As String _
)

[ConstructorIndexAttribute()]
public YankPartRequestSetup(
   string _partRequestDetailIDNum_
)

Parameters

partRequestDetailIDNum

Part Request Detail Identifier

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankPartRequestSetup Class
YankPartRequestSetup Members


GenerateTimeBombs Property (YankPartRequestSetup) | fcSDK Documentation

GenerateTimeBombs Property (YankPartRequestSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankPartRequestSetup Class
YankPartRequestSetup Members


PartRequestDetailIDNum Property (YankPartRequestSetup) | fcSDK Documentation

PartRequestDetailIDNum Property (YankPartRequestSetup)

Part Request Detail Identifier

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRequestDetailIDNum As String

[PropertyBitValueAttribute()]
public string PartRequestDetailIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankPartRequestSetup Class
YankPartRequestSetup Members


UserName Property (YankPartRequestSetup) | fcSDK Documentation

UserName Property (YankPartRequestSetup)

The user who has yanked the PartRequest. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankPartRequestSetup Class
YankPartRequestSetup Members


WipBin Property (YankPartRequestSetup) | fcSDK Documentation

WipBin Property (YankPartRequestSetup)

User's WipBin in which to place the PartRequest. If not set, the UserName's default is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankPartRequestSetup Class
YankPartRequestSetup Members


YankDate Property (YankPartRequestSetup) | fcSDK Documentation

YankDate Property (YankPartRequestSetup)

DateTime the PartRequest was yanked. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property YankDate As Date

[PropertyBitValueAttribute()]
public DateTime YankDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankPartRequestSetup Class
YankPartRequestSetup Members


FChoice.Toolkits.Clarify.Quality Namespace | fcSDK Documentation

FChoice.Toolkits.Clarify.Quality Namespace

Provides APIs to allow you to modify the basic ClearQuality object: the Change Request.

These APIs can be used in custom web pages, the Clarify thick-client GUI, or in interfaces.

Functions are provided to allow you to create, modify, close, dispatch, accept, reject, assign, yank, move, change status, log notes, reopen, fix, and more.

Classes

 | Class | Description
Class | AcceptCRSetup | Used by the AcceptCR method as setup data for invocation.
Class | AddModuleToCRSetup | Used by the AddModuleToCR method as setup data for invocation.
Class | AssignCRSetup | Used by the AssignCR method as setup data for invocation.
Class | ChangeCRStatusSetup | Used by the ChangeCRStatus method as setup data for invocation.
Class | CheckClearQualityTransitionSetup | Used by the CheckClearQualityTransition method as setup data for invocation.
Class | CloseCRSetup | Used by the CloseCR method as setup data for invocation.
Class | CreateCRSetup | Used by the CreateCR method as setup data for invocation.
Class | DispatchCRSetup | Used by the DispatchCR method as setup data for invocation.
Class | DuplicateCRSetup | Used by the DuplicateCR method as setup data for invocation.
Class | FixCRSetup | Used by the FixCR method as setup data for invocation.
Class | FixFailedSetup | Used by the FixFailed method as setup data for invocation.
Class | ForwardCRSetup | Used by the ForwardCR method as setup data for invocation.
Class | LogCREmailSetup | Used by the LogCREmail method as setup data for invocation.
Class | LogCRNoteSetup | Used by the LogCRNote method as setup data for invocation.
Class | MoveCRSetup | Used by the MoveCR method as setup data for invocation.
Class | QualityToolkit | Provides APIs to allow you to modify the basic ClearQuality object: the Change Request. Methods on the QualityToolkit object allow you to create, modify, close, dispatch, accept, reject, assign, yank, move, change status, log notes, reopen, fix, and more.
Class | QualityToolkit.LogCREmailInSetup |
Class | QualityToolkitBase | Please see QualityToolkit. This class is used internally and not meant to be created by end users.
Class | RejectCRSetup | Used by the RejectCR method as setup data for invocation.
Class | ReopenCRSetup | Used by the ReopenCR method as setup data for invocation.
Class | ReplicateCRSetup | Used by the ReplicateCR method as setup data for invocation.
Class | UpdateCRSetup | Used by the UpdateCR method as setup data for invocation.
Class | YankCRSetup | Used by the YankCR method as setup data for invocation.

Reference

FChoice.Toolkits.Clarify Assembly


AcceptCRSetup Class | fcSDK Documentation

AcceptCRSetup Class

Used by the AcceptCR method as setup data for invocation.

Syntax

'Declaration

Public Class AcceptCRSetup

public class AcceptCRSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Quality.AcceptCRSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Quality

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

AcceptCRSetup Members
FChoice.Toolkits.Clarify.Quality Namespace
AcceptCR(AcceptCRSetup) Method


AcceptCRSetup Class Members | fcSDK Documentation

AcceptCRSetup Class Members

The following tables list the members exposed by AcceptCRSetup.

Public Constructors

 | Name | Description
Public Constructor | AcceptCRSetup Constructor | Initializes a new instance of the AcceptCRSetup class.

Public Properties

 | Name | Description
Public Property | AcceptDate | DateTime the CR was accepted. If not set, the current time is used.
Public Property | CRIDNum | CR Identifier.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | UserName | The user who has accepted the CR. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the CR. If not set, the UserName's default is used.

Reference

AcceptCRSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
AcceptCR(AcceptCRSetup) Method


AcceptCRSetup Constructor | fcSDK Documentation

AcceptCRSetup Constructor

CR Identifier.

Initializes a new instance of the AcceptCRSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _cridnum_ As String _
)

[ConstructorIndexAttribute()]
public AcceptCRSetup(
   string _cridnum_
)

Parameters

cridnum

CR Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptCRSetup Class
AcceptCRSetup Members


AcceptDate Property (AcceptCRSetup) | fcSDK Documentation

AcceptDate Property (AcceptCRSetup)

DateTime the CR was accepted. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AcceptDate As Date

[PropertyBitValueAttribute()]
public DateTime AcceptDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptCRSetup Class
AcceptCRSetup Members


CRIDNum Property (AcceptCRSetup) | fcSDK Documentation

CRIDNum Property (AcceptCRSetup)

CR Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CRIDNum As String

[PropertyBitValueAttribute()]
public string CRIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptCRSetup Class
AcceptCRSetup Members


GenerateTimeBombs Property (AcceptCRSetup) | fcSDK Documentation

GenerateTimeBombs Property (AcceptCRSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptCRSetup Class
AcceptCRSetup Members


UserName Property (AcceptCRSetup) | fcSDK Documentation

UserName Property (AcceptCRSetup)

The user who has accepted the CR. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptCRSetup Class
AcceptCRSetup Members


WipBin Property (AcceptCRSetup) | fcSDK Documentation

WipBin Property (AcceptCRSetup)

User's WipBin in which to place the CR. If not set, the UserName's default is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptCRSetup Class
AcceptCRSetup Members


AddModuleToCRSetup Class | fcSDK Documentation

AddModuleToCRSetup Class

Used by the AddModuleToCR method as setup data for invocation.

Syntax

'Declaration

Public Class AddModuleToCRSetup

public class AddModuleToCRSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Quality.AddModuleToCRSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Quality

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

AddModuleToCRSetup Members
FChoice.Toolkits.Clarify.Quality Namespace
AddModuleToCR(AddModuleToCRSetup) Method


AddModuleToCRSetup Class Members | fcSDK Documentation

AddModuleToCRSetup Class Members

The following tables list the members exposed by AddModuleToCRSetup.

Public Constructors

 | Name | Description
Public Constructor | AddModuleToCRSetup Constructor | Initializes a new instance of the AddModuleToCRSetup class.

Public Properties

 | Name | Description
Public Property | FileName | Name of the file related to the fix.
Public Property | FileRevision | Revision information for the file related to the fix.
Public Property | FixObjid | Objid of the Fixed CR.

Reference

AddModuleToCRSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
AddModuleToCR(AddModuleToCRSetup) Method


AddModuleToCRSetup Constructor | fcSDK Documentation

AddModuleToCRSetup Constructor

Objid of the Fixed CR.

Name of the file related to the fix.

Initializes a new instance of the AddModuleToCRSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _fixObjid_ As Integer, _
   ByVal _fileName_ As String _
)

[ConstructorIndexAttribute()]
public AddModuleToCRSetup(
   int _fixObjid_,
   string _fileName_
)

Parameters

fixObjid

Objid of the Fixed CR.

fileName

Name of the file related to the fix.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddModuleToCRSetup Class
AddModuleToCRSetup Members


FileName Property | fcSDK Documentation

FileName Property

Name of the file related to the fix.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FileName As String

[PropertyBitValueAttribute()]
public string FileName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddModuleToCRSetup Class
AddModuleToCRSetup Members


FileRevision Property | fcSDK Documentation

FileRevision Property

Revision information for the file related to the fix.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FileRevision As String

[PropertyBitValueAttribute()]
public string FileRevision {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddModuleToCRSetup Class
AddModuleToCRSetup Members


FixObjid Property | fcSDK Documentation

FixObjid Property

Objid of the Fixed CR.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FixObjid As Integer

[PropertyBitValueAttribute()]
public int FixObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddModuleToCRSetup Class
AddModuleToCRSetup Members


AssignCRSetup Class | fcSDK Documentation

AssignCRSetup Class

Used by the AssignCR method as setup data for invocation.

Syntax

'Declaration

Public Class AssignCRSetup

public class AssignCRSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Quality.AssignCRSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Quality

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

AssignCRSetup Members
FChoice.Toolkits.Clarify.Quality Namespace
AssignCR(AssignCRSetup) Method


AssignCRSetup Class Members | fcSDK Documentation

AssignCRSetup Class Members

The following tables list the members exposed by AssignCRSetup.

Public Constructors

 | Name | Description
Public Constructor | AssignCRSetup Constructor | Initializes a new instance of the AssignCRSetup class.

Public Properties

 | Name | Description
Public Property | AssignDate | DateTime the CR was assigned. If not set, the current time is used.
Public Property | CRIDNum | CR Identifier.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewUser | The new user to which the CR is to be assigned.
Public Property | UserName | The user who has assigned the CR. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the CR. If not set, the UserName's default is used.

Reference

AssignCRSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
AssignCR(AssignCRSetup) Method


AssignCRSetup Constructor | fcSDK Documentation

AssignCRSetup Constructor

CR Identifier.

Initializes a new instance of the AssignCRSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _cridnum_ As String _
)

[ConstructorIndexAttribute()]
public AssignCRSetup(
   string _cridnum_
)

Parameters

cridnum

CR Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignCRSetup Class
AssignCRSetup Members


AssignDate Property (AssignCRSetup) | fcSDK Documentation

AssignDate Property (AssignCRSetup)

DateTime the CR was assigned. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AssignDate As Date

[PropertyBitValueAttribute()]
public DateTime AssignDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignCRSetup Class
AssignCRSetup Members


CRIDNum Property (AssignCRSetup) | fcSDK Documentation

CRIDNum Property (AssignCRSetup)

CR Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CRIDNum As String

[PropertyBitValueAttribute()]
public string CRIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignCRSetup Class
AssignCRSetup Members


GenerateTimeBombs Property (AssignCRSetup) | fcSDK Documentation

GenerateTimeBombs Property (AssignCRSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignCRSetup Class
AssignCRSetup Members


NewUser Property (AssignCRSetup) | fcSDK Documentation

NewUser Property (AssignCRSetup)

The new user to which the CR is to be assigned.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewUser As String

[PropertyBitValueAttribute()]
public string NewUser {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignCRSetup Class
AssignCRSetup Members


UserName Property (AssignCRSetup) | fcSDK Documentation

UserName Property (AssignCRSetup)

The user who has assigned the CR. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignCRSetup Class
AssignCRSetup Members


WipBin Property (AssignCRSetup) | fcSDK Documentation

WipBin Property (AssignCRSetup)

User's WipBin in which to place the CR. If not set, the UserName's default is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignCRSetup Class
AssignCRSetup Members


ChangeCRStatusSetup Class | fcSDK Documentation

ChangeCRStatusSetup Class

Used by the ChangeCRStatus method as setup data for invocation.

Syntax

'Declaration

Public Class ChangeCRStatusSetup

public class ChangeCRStatusSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Quality.ChangeCRStatusSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Quality

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ChangeCRStatusSetup Members
FChoice.Toolkits.Clarify.Quality Namespace
ChangeCRStatus(ChangeCRStatusSetup) Method


ChangeCRStatusSetup Class Members | fcSDK Documentation

ChangeCRStatusSetup Class Members

The following tables list the members exposed by ChangeCRStatusSetup.

Public Constructors

 | Name | Description
Public Constructor | ChangeCRStatusSetup Constructor | Initializes a new instance of the ChangeCRStatusSetup class.

Public Properties

 | Name | Description
Public Property | ChangeDate | DateTime the CR status was changed. If not set, the current date time is used.
Public Property | CRIDNum | Change Request Identifier
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewStatus | The new status for the Change Request. If not set, the default status is used.
Public Property | Notes | Notes about the status change for the Change Request.
Public Property | UserName | The user changing CR status. If not set, the session user is used.

Reference

ChangeCRStatusSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
ChangeCRStatus(ChangeCRStatusSetup) Method


ChangeCRStatusSetup Constructor | fcSDK Documentation

ChangeCRStatusSetup Constructor

Change Request Identifier

Initializes a new instance of the ChangeCRStatusSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _crIDNum_ As String _
)

[ConstructorIndexAttribute()]
public ChangeCRStatusSetup(
   string _crIDNum_
)

Parameters

crIDNum

Change Request Identifier

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeCRStatusSetup Class
ChangeCRStatusSetup Members


ChangeDate Property (ChangeCRStatusSetup) | fcSDK Documentation

ChangeDate Property (ChangeCRStatusSetup)

DateTime the CR status was changed. If not set, the current date time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ChangeDate As Date

[PropertyBitValueAttribute()]
public DateTime ChangeDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeCRStatusSetup Class
ChangeCRStatusSetup Members


CRIDNum Property (ChangeCRStatusSetup) | fcSDK Documentation

CRIDNum Property (ChangeCRStatusSetup)

Change Request Identifier

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CRIDNum As String

[PropertyBitValueAttribute()]
public string CRIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeCRStatusSetup Class
ChangeCRStatusSetup Members


GenerateTimeBombs Property (ChangeCRStatusSetup) | fcSDK Documentation

GenerateTimeBombs Property (ChangeCRStatusSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeCRStatusSetup Class
ChangeCRStatusSetup Members


NewStatus Property (ChangeCRStatusSetup) | fcSDK Documentation

NewStatus Property (ChangeCRStatusSetup)

The new status for the Change Request. If not set, the default status is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewStatus As String

[PropertyBitValueAttribute()]
public string NewStatus {get; set;}

Remarks

The condition of the new status for the CR must match the CR's current condition.

You cannot use this API to change the condition of a CR. To change the condition of the CR you need to use the proper API: FixCR, CloseCR, ReopenCR.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeCRStatusSetup Class
ChangeCRStatusSetup Members


Notes Property (ChangeCRStatusSetup) | fcSDK Documentation

Notes Property (ChangeCRStatusSetup)

Notes about the status change for the Change Request.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeCRStatusSetup Class
ChangeCRStatusSetup Members


UserName Property (ChangeCRStatusSetup) | fcSDK Documentation

UserName Property (ChangeCRStatusSetup)

The user changing CR status. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeCRStatusSetup Class
ChangeCRStatusSetup Members


CheckClearQualityTransitionSetup Class | fcSDK Documentation

CheckClearQualityTransitionSetup Class

Used by the CheckClearQualityTransition method as setup data for invocation.

Syntax

'Declaration

Public Class CheckClearQualityTransitionSetup

public class CheckClearQualityTransitionSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Quality.CheckClearQualityTransitionSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Quality

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CheckClearQualityTransitionSetup Members
FChoice.Toolkits.Clarify.Quality Namespace
CheckClearQualityTransition(CheckClearQualityTransitionSetup) Method


CheckClearQualityTransitionSetup Class Members | fcSDK Documentation

CheckClearQualityTransitionSetup Class Members

The following tables list the members exposed by CheckClearQualityTransitionSetup.

Public Constructors

 | Name | Description
Public Constructor | CheckClearQualityTransitionSetup Constructor | Initializes a new instance of the CheckClearQualityTransitionSetup class.

Public Properties

 | Name | Description
Public Property | NewCondition | The new condition for the Change Request.
Public Property | NewStatus | The new status for the Change Request.
Public Property | OldCondition | The current condition of the Change Request.
Public Property | OldStatus | The current status of the Change Request.
Public Property | UserName | The user checking the transition. If not set, the session user is used.

Reference

CheckClearQualityTransitionSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
CheckClearQualityTransition(CheckClearQualityTransitionSetup) Method


CheckClearQualityTransitionSetup Constructor | fcSDK Documentation

CheckClearQualityTransitionSetup Constructor

The current condition of the Change Request.

The current status of the Change Request.

The new condition for the Change Request.

The new status for the Change Request.

The user checking the transition. If not set, the session user is used.

Initializes a new instance of the CheckClearQualityTransitionSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _oldCondition_ As String, _
   ByVal _oldStatus_ As String, _
   ByVal _newCondition_ As String, _
   ByVal _newStatus_ As String, _
   ByVal _userName_ As String _
)

[ConstructorIndexAttribute()]
public CheckClearQualityTransitionSetup(
   string _oldCondition_,
   string _oldStatus_,
   string _newCondition_,
   string _newStatus_,
   string _userName_
)

Parameters

oldCondition

The current condition of the Change Request.

oldStatus

The current status of the Change Request.

newCondition

The new condition for the Change Request.

newStatus

The new status for the Change Request.

userName

The user checking the transition. If not set, the session user is used.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CheckClearQualityTransitionSetup Class
CheckClearQualityTransitionSetup Members


NewCondition Property (CheckClearQualityTransitionSetup) | fcSDK Documentation

NewCondition Property (CheckClearQualityTransitionSetup)

The new condition for the Change Request.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewCondition As String

[PropertyBitValueAttribute()]
public string NewCondition {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CheckClearQualityTransitionSetup Class
CheckClearQualityTransitionSetup Members


NewStatus Property (CheckClearQualityTransitionSetup) | fcSDK Documentation

NewStatus Property (CheckClearQualityTransitionSetup)

The new status for the Change Request.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewStatus As String

[PropertyBitValueAttribute()]
public string NewStatus {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CheckClearQualityTransitionSetup Class
CheckClearQualityTransitionSetup Members


OldCondition Property | fcSDK Documentation

OldCondition Property

The current condition of the Change Request.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property OldCondition As String

[PropertyBitValueAttribute()]
public string OldCondition {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CheckClearQualityTransitionSetup Class
CheckClearQualityTransitionSetup Members


OldStatus Property | fcSDK Documentation

OldStatus Property

The current status of the Change Request.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property OldStatus As String

[PropertyBitValueAttribute()]
public string OldStatus {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CheckClearQualityTransitionSetup Class
CheckClearQualityTransitionSetup Members


UserName Property (CheckClearQualityTransitionSetup) | fcSDK Documentation

UserName Property (CheckClearQualityTransitionSetup)

The user checking the transition. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CheckClearQualityTransitionSetup Class
CheckClearQualityTransitionSetup Members


CloseCRSetup Class | fcSDK Documentation

CloseCRSetup Class

Used by the CloseCR method as setup data for invocation.

Syntax

'Declaration

Public Class CloseCRSetup

public class CloseCRSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Quality.CloseCRSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Quality

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CloseCRSetup Members
FChoice.Toolkits.Clarify.Quality Namespace
CloseCR(CloseCRSetup) Method


CloseCRSetup Class Members | fcSDK Documentation

CloseCRSetup Class Members

The following tables list the members exposed by CloseCRSetup.

Public Constructors

 | Name | Description
Public Constructor | CloseCRSetup Constructor | Initializes a new instance of the CloseCRSetup class.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CloseDate | When Change Request was closed. If not set, the current date time is used.
Public Property | CRIDNum | Change Request Identifier
Public Property | FixedInRelease | Release information for the closure
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Notes | Notes about the closing of the Change Request.
Public Property | Status | The closed condition status for the Change Request. If not set, the default closed condition status is used.
Public Property | TestCase | Test case name for the Change Request closing
Public Property | UserName | The user closing the CR. If not set, the session user is used.

Reference

CloseCRSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
CloseCR(CloseCRSetup) Method


CloseCRSetup Constructor | fcSDK Documentation

CloseCRSetup Constructor

Change Request Identifier

Initializes a new instance of the CloseCRSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _crIDNum_ As String _
)

[ConstructorIndexAttribute()]
public CloseCRSetup(
   string _crIDNum_
)

Parameters

crIDNum

Change Request Identifier

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CloseCRSetup Class
CloseCRSetup Members


AdditionalFields Property (CloseCRSetup) | fcSDK Documentation

AdditionalFields Property (CloseCRSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CloseCRSetup Class
CloseCRSetup Members


CloseDate Property (CloseCRSetup) | fcSDK Documentation

CloseDate Property (CloseCRSetup)

When Change Request was closed. If not set, the current date time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CloseDate As Date

[PropertyBitValueAttribute()]
public DateTime CloseDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CloseCRSetup Class
CloseCRSetup Members


CRIDNum Property (CloseCRSetup) | fcSDK Documentation

CRIDNum Property (CloseCRSetup)

Change Request Identifier

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CRIDNum As String

[PropertyBitValueAttribute()]
public string CRIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CloseCRSetup Class
CloseCRSetup Members


FixedInRelease Property (CloseCRSetup) | fcSDK Documentation

FixedInRelease Property (CloseCRSetup)

Release information for the closure

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FixedInRelease As String

[PropertyBitValueAttribute()]
public string FixedInRelease {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CloseCRSetup Class
CloseCRSetup Members


GenerateTimeBombs Property (CloseCRSetup) | fcSDK Documentation

GenerateTimeBombs Property (CloseCRSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CloseCRSetup Class
CloseCRSetup Members


Notes Property (CloseCRSetup) | fcSDK Documentation

Notes Property (CloseCRSetup)

Notes about the closing of the Change Request.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CloseCRSetup Class
CloseCRSetup Members


Status Property (CloseCRSetup) | fcSDK Documentation

Status Property (CloseCRSetup)

The closed condition status for the Change Request. If not set, the default closed condition status is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Status As String

[PropertyBitValueAttribute()]
public string Status {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CloseCRSetup Class
CloseCRSetup Members


TestCase Property (CloseCRSetup) | fcSDK Documentation

TestCase Property (CloseCRSetup)

Test case name for the Change Request closing

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property TestCase As String

[PropertyBitValueAttribute()]
public string TestCase {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CloseCRSetup Class
CloseCRSetup Members


UserName Property (CloseCRSetup) | fcSDK Documentation

UserName Property (CloseCRSetup)

The user closing the CR. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CloseCRSetup Class
CloseCRSetup Members


CreateCRSetup Class | fcSDK Documentation

CreateCRSetup Class

Used by the CreateCR method as setup data for invocation.

Syntax

'Declaration

Public Class CreateCRSetup

public class CreateCRSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Quality.CreateCRSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Quality

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateCRSetup Members
FChoice.Toolkits.Clarify.Quality Namespace
CreateCR(CreateCRSetup) Method


CreateCRSetup Class Members | fcSDK Documentation

CreateCRSetup Class Members

The following tables list the members exposed by CreateCRSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateCRSetup Constructor | Initializes a new instance of the CreateCRSetup class.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CRClass | Element from the 'CR Class' application list. If not set the default list value is used.
Public Property | CreateDate | When Change Request was created. If not set, the current date time is used.
Public Property | CRType | Element from the 'CR Type' application list. If not set, the default list value is used.
Public Property | Description | Notes about the Change Request. If not set, no notes are logged.
Public Property | FixedIn | Element from the 'Fix Release' application list. If not set, the default list value is used.
Public Property | FoundOnCPU | Element from level 1 of the 'CR_DESC' user-defined list. If not set, the default list value is used.
Public Property | Frequency | Element from the 'CR Reproducible' application list. If not set, the default list value is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | IntroductionPhase | Element from the 'CR Domain' application list. If not set, the default list value is used.
Public Property | Memory | Element from level 3 of the 'CR_DESC' user-defined list. If not set the default list value is used.
Public Property | OperatingSystem | Element from level 2 of the 'CR_DESC' user-defined list. If not set the default list value is used.
Public Property | PartDomain | Part domain of part for the Change Request
Public Property | PartNumber | Part number of part for the Change Request
Public Property | PartRevision | Part revision of part for the Change Request
Public Property | Priority | Element from the 'CR Priority' application list. If not set, the default list value is used.
Public Property | Queue | Queue where the CR will be dispatched.
Public Property | Status | The initial open condition status for the Change Request. If not set, the default open condition status is used.
Public Property | TestClass | Element from the 'CR Class' application list. If not set, the default list value is used.
Public Property | Title | The title of the Change Request
Public Property | UserName | The user creating the CR. If not set, the session user is used.
Public Property | VerificationTest | List of verification tests for the Change Request

Reference

CreateCRSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
CreateCR(CreateCRSetup) Method


CreateCRSetup Constructor | fcSDK Documentation

CreateCRSetup Constructor

Part number of part for the Change Request

Part revision of part for the Change Request

Part domain of part for the Change Request

Initializes a new instance of the CreateCRSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _partNumber_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _partDomain_ As String _
)

[ConstructorIndexAttribute()]
public CreateCRSetup(
   string _partNumber_,
   string _partRevision_,
   string _partDomain_
)

Parameters

partNumber

Part number of part for the Change Request

partRevision

Part revision of part for the Change Request

partDomain

Part domain of part for the Change Request

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCRSetup Class
CreateCRSetup Members


AdditionalFields Property (CreateCRSetup) | fcSDK Documentation

AdditionalFields Property (CreateCRSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCRSetup Class
CreateCRSetup Members


CRClass Property (CreateCRSetup) | fcSDK Documentation

CRClass Property (CreateCRSetup)

Element from the 'CR Class' application list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CRClass As String

[PropertyBitValueAttribute()]
public string CRClass {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCRSetup Class
CreateCRSetup Members


CreateDate Property (CreateCRSetup) | fcSDK Documentation

CreateDate Property (CreateCRSetup)

When Change Request was created. If not set, the current date time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCRSetup Class
CreateCRSetup Members


CRType Property (CreateCRSetup) | fcSDK Documentation

CRType Property (CreateCRSetup)

Element from the 'CR Type' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CRType As String

[PropertyBitValueAttribute()]
public string CRType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCRSetup Class
CreateCRSetup Members


Description Property (CreateCRSetup) | fcSDK Documentation

Description Property (CreateCRSetup)

Notes about the Change Request. If not set, no notes are logged.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Description As String

[PropertyBitValueAttribute()]
public string Description {get; set;}

Remarks

If set, a time bomb will be generated.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCRSetup Class
CreateCRSetup Members


FixedIn Property (CreateCRSetup) | fcSDK Documentation

FixedIn Property (CreateCRSetup)

Element from the 'Fix Release' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FixedIn As String

[PropertyBitValueAttribute()]
public string FixedIn {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCRSetup Class
CreateCRSetup Members


FoundOnCPU Property (CreateCRSetup) | fcSDK Documentation

FoundOnCPU Property (CreateCRSetup)

Element from level 1 of the 'CR_DESC' user-defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FoundOnCPU As String

[PropertyBitValueAttribute()]
public string FoundOnCPU {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCRSetup Class
CreateCRSetup Members


Frequency Property (CreateCRSetup) | fcSDK Documentation

Frequency Property (CreateCRSetup)

Element from the 'CR Reproducible' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Frequency As String

[PropertyBitValueAttribute()]
public string Frequency {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCRSetup Class
CreateCRSetup Members


GenerateTimeBombs Property (CreateCRSetup) | fcSDK Documentation

GenerateTimeBombs Property (CreateCRSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCRSetup Class
CreateCRSetup Members


IntroductionPhase Property (CreateCRSetup) | fcSDK Documentation

IntroductionPhase Property (CreateCRSetup)

Element from the 'CR Domain' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IntroductionPhase As String

[PropertyBitValueAttribute()]
public string IntroductionPhase {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCRSetup Class
CreateCRSetup Members


Memory Property (CreateCRSetup) | fcSDK Documentation

Memory Property (CreateCRSetup)

Element from level 3 of the 'CR_DESC' user-defined list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Memory As String

[PropertyBitValueAttribute()]
public string Memory {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCRSetup Class
CreateCRSetup Members


OperatingSystem Property (CreateCRSetup) | fcSDK Documentation

OperatingSystem Property (CreateCRSetup)

Element from level 2 of the 'CR_DESC' user-defined list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property OperatingSystem As String

[PropertyBitValueAttribute()]
public string OperatingSystem {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCRSetup Class
CreateCRSetup Members


PartDomain Property (CreateCRSetup) | fcSDK Documentation

PartDomain Property (CreateCRSetup)

Part domain of part for the Change Request

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartDomain As String

[PropertyBitValueAttribute()]
public string PartDomain {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCRSetup Class
CreateCRSetup Members


PartNumber Property (CreateCRSetup) | fcSDK Documentation

PartNumber Property (CreateCRSetup)

Part number of part for the Change Request

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartNumber As String

[PropertyBitValueAttribute()]
public string PartNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCRSetup Class
CreateCRSetup Members


PartRevision Property (CreateCRSetup) | fcSDK Documentation

PartRevision Property (CreateCRSetup)

Part revision of part for the Change Request

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRevision As String

[PropertyBitValueAttribute()]
public string PartRevision {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCRSetup Class
CreateCRSetup Members


Priority Property (CreateCRSetup) | fcSDK Documentation

Priority Property (CreateCRSetup)

Element from the 'CR Priority' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Priority As String

[PropertyBitValueAttribute()]
public string Priority {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCRSetup Class
CreateCRSetup Members


Queue Property (CreateCRSetup) | fcSDK Documentation

Queue Property (CreateCRSetup)

Queue where the CR will be dispatched.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Queue As String

[PropertyBitValueAttribute()]
public string Queue {get; set;}

Remarks

If not set, the CR will be located in the user's default WipBin.

If set, a timebomb will be created for the Dispatch operation.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCRSetup Class
CreateCRSetup Members


Status Property (CreateCRSetup) | fcSDK Documentation

Status Property (CreateCRSetup)

The initial open condition status for the Change Request. If not set, the default open condition status is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Status As String

[PropertyBitValueAttribute()]
public string Status {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCRSetup Class
CreateCRSetup Members


TestClass Property (CreateCRSetup) | fcSDK Documentation

TestClass Property (CreateCRSetup)

Element from the 'CR Class' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property TestClass As String

[PropertyBitValueAttribute()]
public string TestClass {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCRSetup Class
CreateCRSetup Members


Title Property (CreateCRSetup) | fcSDK Documentation

Title Property (CreateCRSetup)

The title of the Change Request

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Title As String

[PropertyBitValueAttribute()]
public string Title {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCRSetup Class
CreateCRSetup Members


UserName Property (CreateCRSetup) | fcSDK Documentation

UserName Property (CreateCRSetup)

The user creating the CR. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCRSetup Class
CreateCRSetup Members


VerificationTest Property | fcSDK Documentation

VerificationTest Property

List of verification tests for the Change Request

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property VerificationTest As String

[PropertyBitValueAttribute()]
public string VerificationTest {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCRSetup Class
CreateCRSetup Members


DispatchCRSetup Class | fcSDK Documentation

DispatchCRSetup Class

Used by the DispatchCR method as setup data for invocation.

Syntax

'Declaration

Public Class DispatchCRSetup

public class DispatchCRSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Quality.DispatchCRSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Quality

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

DispatchCRSetup Members
FChoice.Toolkits.Clarify.Quality Namespace
DispatchCR(DispatchCRSetup) Method


DispatchCRSetup Class Members | fcSDK Documentation

DispatchCRSetup Class Members

The following tables list the members exposed by DispatchCRSetup.

Public Constructors

 | Name | Description
Public Constructor | DispatchCRSetup Constructor | Initializes a new instance of the DispatchCRSetup class.

Public Properties

 | Name | Description
Public Property | CRIDNum | CR Identifier.
Public Property | DispatchDate | DateTime the CR was dispatched. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Queue | The queue into which the CR is to be dispatched.
Public Property | UserName | The user who has dispatched the CR. If not set, the Toolkit session user is used.

Reference

DispatchCRSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
DispatchCR(DispatchCRSetup) Method


DispatchCRSetup Constructor | fcSDK Documentation

DispatchCRSetup Constructor

CR Identifier.

The queue into which the CR is to be dispatched.

Initializes a new instance of the DispatchCRSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _cridnum_ As String, _
   ByVal _queue_ As String _
)

[ConstructorIndexAttribute()]
public DispatchCRSetup(
   string _cridnum_,
   string _queue_
)

Parameters

cridnum

CR Identifier.

queue

The queue into which the CR is to be dispatched.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchCRSetup Class
DispatchCRSetup Members


CRIDNum Property (DispatchCRSetup) | fcSDK Documentation

CRIDNum Property (DispatchCRSetup)

CR Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CRIDNum As String

[PropertyBitValueAttribute()]
public string CRIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchCRSetup Class
DispatchCRSetup Members


DispatchDate Property (DispatchCRSetup) | fcSDK Documentation

DispatchDate Property (DispatchCRSetup)

DateTime the CR was dispatched. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property DispatchDate As Date

[PropertyBitValueAttribute()]
public DateTime DispatchDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchCRSetup Class
DispatchCRSetup Members


GenerateTimeBombs Property (DispatchCRSetup) | fcSDK Documentation

GenerateTimeBombs Property (DispatchCRSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchCRSetup Class
DispatchCRSetup Members


Queue Property (DispatchCRSetup) | fcSDK Documentation

Queue Property (DispatchCRSetup)

The queue into which the CR is to be dispatched.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Queue As String

[PropertyBitValueAttribute()]
public string Queue {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchCRSetup Class
DispatchCRSetup Members


UserName Property (DispatchCRSetup) | fcSDK Documentation

UserName Property (DispatchCRSetup)

The user who has dispatched the CR. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchCRSetup Class
DispatchCRSetup Members


DuplicateCRSetup Class | fcSDK Documentation

DuplicateCRSetup Class

Used by the DuplicateCR method as setup data for invocation.

Syntax

'Declaration

Public Class DuplicateCRSetup

public class DuplicateCRSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Quality.DuplicateCRSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Quality

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

DuplicateCRSetup Members
FChoice.Toolkits.Clarify.Quality Namespace
DuplicateCR(DuplicateCRSetup) Method


DuplicateCRSetup Class Members | fcSDK Documentation

DuplicateCRSetup Class Members

The following tables list the members exposed by DuplicateCRSetup.

Public Constructors

 | Name | Description
Public Constructor | DuplicateCRSetup Constructor | Initializes a new instance of the DuplicateCRSetup class.

Public Properties

 | Name | Description
Public Property | CloseDate | DateTime the CR was closed. If not set, the current date time is used.
Public Property | CRIDNum | Identifier of the CR being marked as a duplicate.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | MasterCRIDNum | Identifier of the 'master' CR this CR duplicates.
Public Property | Status | The new status for the duplicate Change Request. If not set, the default status is used.
Public Property | UserName | The user duplicating the CR. If not set, the session user is used.

Reference

DuplicateCRSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
DuplicateCR(DuplicateCRSetup) Method


DuplicateCRSetup Constructor | fcSDK Documentation

DuplicateCRSetup Constructor

Identifier of the CR being marked as a duplicate.

Identifier of the 'master' CR this CR duplicates.

Initializes a new instance of the DuplicateCRSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _crIDNum_ As String, _
   ByVal _masterCRIDNum_ As String _
)

[ConstructorIndexAttribute()]
public DuplicateCRSetup(
   string _crIDNum_,
   string _masterCRIDNum_
)

Parameters

crIDNum

Identifier of the CR being marked as a duplicate.

masterCRIDNum

Identifier of the 'master' CR this CR duplicates.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DuplicateCRSetup Class
DuplicateCRSetup Members


CloseDate Property (DuplicateCRSetup) | fcSDK Documentation

CloseDate Property (DuplicateCRSetup)

DateTime the CR was closed. If not set, the current date time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CloseDate As Date

[PropertyBitValueAttribute()]
public DateTime CloseDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DuplicateCRSetup Class
DuplicateCRSetup Members


CRIDNum Property (DuplicateCRSetup) | fcSDK Documentation

CRIDNum Property (DuplicateCRSetup)

Identifier of the CR being marked as a duplicate.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CRIDNum As String

[PropertyBitValueAttribute()]
public string CRIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DuplicateCRSetup Class
DuplicateCRSetup Members


GenerateTimeBombs Property (DuplicateCRSetup) | fcSDK Documentation

GenerateTimeBombs Property (DuplicateCRSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DuplicateCRSetup Class
DuplicateCRSetup Members


MasterCRIDNum Property | fcSDK Documentation

MasterCRIDNum Property

Identifier of the 'master' CR this CR duplicates.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property MasterCRIDNum As String

[PropertyBitValueAttribute()]
public string MasterCRIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DuplicateCRSetup Class
DuplicateCRSetup Members


Status Property (DuplicateCRSetup) | fcSDK Documentation

Status Property (DuplicateCRSetup)

The new status for the duplicate Change Request. If not set, the default status is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Status As String

[PropertyBitValueAttribute()]
public string Status {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DuplicateCRSetup Class
DuplicateCRSetup Members


UserName Property (DuplicateCRSetup) | fcSDK Documentation

UserName Property (DuplicateCRSetup)

The user duplicating the CR. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DuplicateCRSetup Class
DuplicateCRSetup Members


FixCRSetup Class | fcSDK Documentation

FixCRSetup Class

Used by the FixCR method as setup data for invocation.

Syntax

'Declaration

Public Class FixCRSetup

public class FixCRSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Quality.FixCRSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Quality

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

FixCRSetup Members
FChoice.Toolkits.Clarify.Quality Namespace
FixCR(FixCRSetup) Method


FixCRSetup Class Members | fcSDK Documentation

FixCRSetup Class Members

The following tables list the members exposed by FixCRSetup.

Public Constructors

 | Name | Description
Public Constructor | FixCRSetup Constructor | Initializes a new instance of the FixCRSetup class.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CRIDNum | Identifier of the CR being set to Fixed.
Public Property | FixDate | DateTime the CR was marked Fixed. If not set, the current date time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Notes | Notes about the CR's the Fix.
Public Property | Status | The new status for the Change Request. If not set, the default status is used.
Public Property | UserName | The user fixing the CR. If not set, the session user is used.

Reference

FixCRSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
FixCR(FixCRSetup) Method


FixCRSetup Constructor | fcSDK Documentation

FixCRSetup Constructor

Identifier of the CR being set to Fixed.

Initializes a new instance of the FixCRSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _crIDNum_ As String _
)

[ConstructorIndexAttribute()]
public FixCRSetup(
   string _crIDNum_
)

Parameters

crIDNum

Identifier of the CR being set to Fixed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FixCRSetup Class
FixCRSetup Members


AdditionalFields Property (FixCRSetup) | fcSDK Documentation

AdditionalFields Property (FixCRSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FixCRSetup Class
FixCRSetup Members


CRIDNum Property (FixCRSetup) | fcSDK Documentation

CRIDNum Property (FixCRSetup)

Identifier of the CR being set to Fixed.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CRIDNum As String

[PropertyBitValueAttribute()]
public string CRIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FixCRSetup Class
FixCRSetup Members


FixDate Property | fcSDK Documentation

FixDate Property

DateTime the CR was marked Fixed. If not set, the current date time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FixDate As Date

[PropertyBitValueAttribute()]
public DateTime FixDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FixCRSetup Class
FixCRSetup Members


GenerateTimeBombs Property (FixCRSetup) | fcSDK Documentation

GenerateTimeBombs Property (FixCRSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FixCRSetup Class
FixCRSetup Members


Notes Property (FixCRSetup) | fcSDK Documentation

Notes Property (FixCRSetup)

Notes about the CR's the Fix.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FixCRSetup Class
FixCRSetup Members


Status Property (FixCRSetup) | fcSDK Documentation

Status Property (FixCRSetup)

The new status for the Change Request. If not set, the default status is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Status As String

[PropertyBitValueAttribute()]
public string Status {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FixCRSetup Class
FixCRSetup Members


UserName Property (FixCRSetup) | fcSDK Documentation

UserName Property (FixCRSetup)

The user fixing the CR. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FixCRSetup Class
FixCRSetup Members


FixFailedSetup Class | fcSDK Documentation

FixFailedSetup Class

Used by the FixFailed method as setup data for invocation.

Syntax

'Declaration

Public Class FixFailedSetup

public class FixFailedSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Quality.FixFailedSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Quality

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

FixFailedSetup Members
FChoice.Toolkits.Clarify.Quality Namespace
FixFailed(FixFailedSetup) Method


FixFailedSetup Class Members | fcSDK Documentation

FixFailedSetup Class Members

The following tables list the members exposed by FixFailedSetup.

Public Constructors

 | Name | Description
Public Constructor | FixFailedSetup Constructor | Initializes a new instance of the FixFailedSetup class.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CRIDNum | Identifier of the CR being marked as FixFailed.
Public Property | FailedDate | DateTime the CR was maked as FixFailed. If not set, the current date time is used.
Public Property | FixedInRelease | Release information related to the Fixed CR being Failed.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Notes | Notes about the CR being markd FixFailed.
Public Property | Status | The new status for the Change Request. If not set, the default status is used.
Public Property | TestCase | Name of the test case related to the CR Fix being marked as Failed
Public Property | UserName | The user failing the CR. If not set, the session user is used.

Reference

FixFailedSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
FixFailed(FixFailedSetup) Method


FixFailedSetup Constructor | fcSDK Documentation

FixFailedSetup Constructor

Identifier of the CR being marked as FixFailed.

Initializes a new instance of the FixFailedSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _crIDNum_ As String _
)

[ConstructorIndexAttribute()]
public FixFailedSetup(
   string _crIDNum_
)

Parameters

crIDNum

Identifier of the CR being marked as FixFailed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FixFailedSetup Class
FixFailedSetup Members


AdditionalFields Property (FixFailedSetup) | fcSDK Documentation

AdditionalFields Property (FixFailedSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FixFailedSetup Class
FixFailedSetup Members


CRIDNum Property (FixFailedSetup) | fcSDK Documentation

CRIDNum Property (FixFailedSetup)

Identifier of the CR being marked as FixFailed.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CRIDNum As String

[PropertyBitValueAttribute()]
public string CRIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FixFailedSetup Class
FixFailedSetup Members


FailedDate Property | fcSDK Documentation

FailedDate Property

DateTime the CR was maked as FixFailed. If not set, the current date time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FailedDate As Date

[PropertyBitValueAttribute()]
public DateTime FailedDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FixFailedSetup Class
FixFailedSetup Members


FixedInRelease Property (FixFailedSetup) | fcSDK Documentation

FixedInRelease Property (FixFailedSetup)

Release information related to the Fixed CR being Failed.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FixedInRelease As String

[PropertyBitValueAttribute()]
public string FixedInRelease {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FixFailedSetup Class
FixFailedSetup Members


GenerateTimeBombs Property (FixFailedSetup) | fcSDK Documentation

GenerateTimeBombs Property (FixFailedSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FixFailedSetup Class
FixFailedSetup Members


Notes Property (FixFailedSetup) | fcSDK Documentation

Notes Property (FixFailedSetup)

Notes about the CR being markd FixFailed.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FixFailedSetup Class
FixFailedSetup Members


Status Property (FixFailedSetup) | fcSDK Documentation

Status Property (FixFailedSetup)

The new status for the Change Request. If not set, the default status is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Status As String

[PropertyBitValueAttribute()]
public string Status {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FixFailedSetup Class
FixFailedSetup Members


TestCase Property (FixFailedSetup) | fcSDK Documentation

TestCase Property (FixFailedSetup)

Name of the test case related to the CR Fix being marked as Failed

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property TestCase As String

[PropertyBitValueAttribute()]
public string TestCase {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FixFailedSetup Class
FixFailedSetup Members


UserName Property (FixFailedSetup) | fcSDK Documentation

UserName Property (FixFailedSetup)

The user failing the CR. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FixFailedSetup Class
FixFailedSetup Members


ForwardCRSetup Class | fcSDK Documentation

ForwardCRSetup Class

Used by the ForwardCR method as setup data for invocation.

Syntax

'Declaration

Public Class ForwardCRSetup

public class ForwardCRSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Quality.ForwardCRSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Quality

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ForwardCRSetup Members
FChoice.Toolkits.Clarify.Quality Namespace
ForwardCR(ForwardCRSetup) Method


ForwardCRSetup Class Members | fcSDK Documentation

ForwardCRSetup Class Members

The following tables list the members exposed by ForwardCRSetup.

Public Constructors

 | Name | Description
Public Constructor | ForwardCRSetup Constructor | Initializes a new instance of the ForwardCRSetup class.

Public Properties

 | Name | Description
Public Property | CRIDNum | CR Identifier.
Public Property | ForwardDate | DateTime the CR was forwarded. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewQueue | The new queue into which the CR is to be forwarded.
Public Property | Notes | The reason the CR was rejected from the queue into which it was dispatched.
Public Property | UserName | The user who has forwarded the CR. If not set, the Toolkit session user is used.

Reference

ForwardCRSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
ForwardCR(ForwardCRSetup) Method


ForwardCRSetup Constructor | fcSDK Documentation

ForwardCRSetup Constructor

CR Identifier.

The new queue into which the CR is to be forwarded.

Initializes a new instance of the ForwardCRSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _cridnum_ As String, _
   ByVal _newQueue_ As String _
)

[ConstructorIndexAttribute()]
public ForwardCRSetup(
   string _cridnum_,
   string _newQueue_
)

Parameters

cridnum

CR Identifier.

newQueue

The new queue into which the CR is to be forwarded.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardCRSetup Class
ForwardCRSetup Members


CRIDNum Property (ForwardCRSetup) | fcSDK Documentation

CRIDNum Property (ForwardCRSetup)

CR Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CRIDNum As String

[PropertyBitValueAttribute()]
public string CRIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardCRSetup Class
ForwardCRSetup Members


ForwardDate Property (ForwardCRSetup) | fcSDK Documentation

ForwardDate Property (ForwardCRSetup)

DateTime the CR was forwarded. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ForwardDate As Date

[PropertyBitValueAttribute()]
public DateTime ForwardDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardCRSetup Class
ForwardCRSetup Members


GenerateTimeBombs Property (ForwardCRSetup) | fcSDK Documentation

GenerateTimeBombs Property (ForwardCRSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardCRSetup Class
ForwardCRSetup Members


NewQueue Property (ForwardCRSetup) | fcSDK Documentation

NewQueue Property (ForwardCRSetup)

The new queue into which the CR is to be forwarded.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewQueue As String

[PropertyBitValueAttribute()]
public string NewQueue {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardCRSetup Class
ForwardCRSetup Members


Notes Property (ForwardCRSetup) | fcSDK Documentation

Notes Property (ForwardCRSetup)

The reason the CR was rejected from the queue into which it was dispatched.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardCRSetup Class
ForwardCRSetup Members


UserName Property (ForwardCRSetup) | fcSDK Documentation

UserName Property (ForwardCRSetup)

The user who has forwarded the CR. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardCRSetup Class
ForwardCRSetup Members


LogCREmailSetup Class | fcSDK Documentation

LogCREmailSetup Class

Used by the LogCREmail method as setup data for invocation.

Syntax

'Declaration

Public Class LogCREmailSetup

public class LogCREmailSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Quality.LogCREmailSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Quality

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LogCREmailSetup Members
FChoice.Toolkits.Clarify.Quality Namespace
LogCREmail(LogCREmailSetup) Method


LogCREmailSetup Class Members | fcSDK Documentation

LogCREmailSetup Class Members

The following tables list the members exposed by LogCREmailSetup.

Public Constructors

 | Name | Description
Public Constructor | LogCREmailSetup Constructor | Initializes a new instance of the LogCREmailSetup class.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CCList | Additional recipients to be included on the carbon copy (CC) of the email.
Public Property | CRIDNum | Identifier of the CR being logged.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | LogDate | DateTime the CR was logged. If not set, the current date time is used.
Public Property | Message | The text (body) of the email message included in the log.
Public Property | Recipient | The email address of the intended recipient of the email log.
Public Property | SendEmail | Should this email be sent from rulemanager?
Public Property | UserName | The user logging an email for the CR. If not set, the session user is used.

Reference

LogCREmailSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
LogCREmail(LogCREmailSetup) Method


LogCREmailSetup Constructor | fcSDK Documentation

LogCREmailSetup Constructor

Identifier of the CR being logged.

Initializes a new instance of the LogCREmailSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _crIDNum_ As String _
)

[ConstructorIndexAttribute()]
public LogCREmailSetup(
   string _crIDNum_
)

Parameters

crIDNum

Identifier of the CR being logged.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCREmailSetup Class
LogCREmailSetup Members


AdditionalFields Property (LogCREmailSetup) | fcSDK Documentation

AdditionalFields Property (LogCREmailSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCREmailSetup Class
LogCREmailSetup Members


CCList Property (LogCREmailSetup) | fcSDK Documentation

CCList Property (LogCREmailSetup)

Additional recipients to be included on the carbon copy (CC) of the email.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CCList As String

[PropertyBitValueAttribute()]
public string CCList {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCREmailSetup Class
LogCREmailSetup Members


CRIDNum Property (LogCREmailSetup) | fcSDK Documentation

CRIDNum Property (LogCREmailSetup)

Identifier of the CR being logged.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CRIDNum As String

[PropertyBitValueAttribute()]
public string CRIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCREmailSetup Class
LogCREmailSetup Members


GenerateTimeBombs Property (LogCREmailSetup) | fcSDK Documentation

GenerateTimeBombs Property (LogCREmailSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCREmailSetup Class
LogCREmailSetup Members


LogDate Property (LogCREmailSetup) | fcSDK Documentation

LogDate Property (LogCREmailSetup)

DateTime the CR was logged. If not set, the current date time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LogDate As Date

[PropertyBitValueAttribute()]
public DateTime LogDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCREmailSetup Class
LogCREmailSetup Members


Message Property (LogCREmailSetup) | fcSDK Documentation

Message Property (LogCREmailSetup)

The text (body) of the email message included in the log.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Message As String

[PropertyBitValueAttribute()]
public string Message {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCREmailSetup Class
LogCREmailSetup Members


Recipient Property (LogCREmailSetup) | fcSDK Documentation

Recipient Property (LogCREmailSetup)

The email address of the intended recipient of the email log.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Recipient As String

[PropertyBitValueAttribute()]
public string Recipient {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCREmailSetup Class
LogCREmailSetup Members


SendEmail Property (LogCREmailSetup) | fcSDK Documentation

SendEmail Property (LogCREmailSetup)

Should this email be sent from rulemanager?

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SendEmail As Boolean

[PropertyBitValueAttribute()]
public bool SendEmail {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCREmailSetup Class
LogCREmailSetup Members


UserName Property (LogCREmailSetup) | fcSDK Documentation

UserName Property (LogCREmailSetup)

The user logging an email for the CR. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCREmailSetup Class
LogCREmailSetup Members


LogCRNoteSetup Class | fcSDK Documentation

LogCRNoteSetup Class

Used by the LogCRNote method as setup data for invocation.

Syntax

'Declaration

Public Class LogCRNoteSetup

public class LogCRNoteSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Quality.LogCRNoteSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Quality

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LogCRNoteSetup Members
FChoice.Toolkits.Clarify.Quality Namespace
LogCRNote(LogCRNoteSetup) Method


LogCRNoteSetup Class Members | fcSDK Documentation

LogCRNoteSetup Class Members

The following tables list the members exposed by LogCRNoteSetup.

Public Constructors

 | Name | Description
Public Constructor | LogCRNoteSetup Constructor | Initializes a new instance of the LogCRNoteSetup class.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CRIDNum | Identifier of the CR being logged.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | InternalUseOnlyNotes | Notes concerning the CR to log that are for internal use only.
Public Property | LogDate | DateTime the CR was logged. If not set, the current date time is used.
Public Property | Notes | Notes concerning the CR to log.
Public Property | UserName | The user logging a note for the CR. If not set, the session user is used.

Reference

LogCRNoteSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
LogCRNote(LogCRNoteSetup) Method


LogCRNoteSetup Constructor | fcSDK Documentation

LogCRNoteSetup Constructor

Identifier of the CR being logged.

Initializes a new instance of the LogCRNoteSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _crIDNum_ As String _
)

[ConstructorIndexAttribute()]
public LogCRNoteSetup(
   string _crIDNum_
)

Parameters

crIDNum

Identifier of the CR being logged.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCRNoteSetup Class
LogCRNoteSetup Members


AdditionalFields Property (LogCRNoteSetup) | fcSDK Documentation

AdditionalFields Property (LogCRNoteSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCRNoteSetup Class
LogCRNoteSetup Members


CRIDNum Property (LogCRNoteSetup) | fcSDK Documentation

CRIDNum Property (LogCRNoteSetup)

Identifier of the CR being logged.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CRIDNum As String

[PropertyBitValueAttribute()]
public string CRIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCRNoteSetup Class
LogCRNoteSetup Members


GenerateTimeBombs Property (LogCRNoteSetup) | fcSDK Documentation

GenerateTimeBombs Property (LogCRNoteSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCRNoteSetup Class
LogCRNoteSetup Members


InternalUseOnlyNotes Property (LogCRNoteSetup) | fcSDK Documentation

InternalUseOnlyNotes Property (LogCRNoteSetup)

Notes concerning the CR to log that are for internal use only.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InternalUseOnlyNotes As String

[PropertyBitValueAttribute()]
public string InternalUseOnlyNotes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCRNoteSetup Class
LogCRNoteSetup Members


LogDate Property (LogCRNoteSetup) | fcSDK Documentation

LogDate Property (LogCRNoteSetup)

DateTime the CR was logged. If not set, the current date time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LogDate As Date

[PropertyBitValueAttribute()]
public DateTime LogDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCRNoteSetup Class
LogCRNoteSetup Members


Notes Property (LogCRNoteSetup) | fcSDK Documentation

Notes Property (LogCRNoteSetup)

Notes concerning the CR to log.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCRNoteSetup Class
LogCRNoteSetup Members


UserName Property (LogCRNoteSetup) | fcSDK Documentation

UserName Property (LogCRNoteSetup)

The user logging a note for the CR. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCRNoteSetup Class
LogCRNoteSetup Members


MoveCRSetup Class | fcSDK Documentation

MoveCRSetup Class

Used by the MoveCR method as setup data for invocation.

Syntax

'Declaration

Public Class MoveCRSetup

public class MoveCRSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Quality.MoveCRSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Quality

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

MoveCRSetup Members
FChoice.Toolkits.Clarify.Quality Namespace
MoveCR(MoveCRSetup) Method


MoveCRSetup Class Members | fcSDK Documentation

MoveCRSetup Class Members

The following tables list the members exposed by MoveCRSetup.

Public Constructors

 | Name | Description
Public Constructor | MoveCRSetup Constructor | Initializes a new instance of the MoveCRSetup class.

Public Properties

 | Name | Description
Public Property | CRIDNum | CR Identifier.
Public Property | NewWipBin | The new WipBin into which the CR is to be moved.

Reference

MoveCRSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
MoveCR(MoveCRSetup) Method


MoveCRSetup Constructor | fcSDK Documentation

MoveCRSetup Constructor

CR Identifier.

The new WipBin into which the CR is to be moved.

Initializes a new instance of the MoveCRSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _cridnum_ As String, _
   ByVal _newWipBin_ As String _
)

[ConstructorIndexAttribute()]
public MoveCRSetup(
   string _cridnum_,
   string _newWipBin_
)

Parameters

cridnum

CR Identifier.

newWipBin

The new WipBin into which the CR is to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveCRSetup Class
MoveCRSetup Members


CRIDNum Property (MoveCRSetup) | fcSDK Documentation

CRIDNum Property (MoveCRSetup)

CR Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CRIDNum As String

[PropertyBitValueAttribute()]
public string CRIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveCRSetup Class
MoveCRSetup Members


NewWipBin Property (MoveCRSetup) | fcSDK Documentation

NewWipBin Property (MoveCRSetup)

The new WipBin into which the CR is to be moved.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewWipBin As String

[PropertyBitValueAttribute()]
public string NewWipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveCRSetup Class
MoveCRSetup Members


QualityToolkit Class | fcSDK Documentation

QualityToolkit Class

Provides APIs to allow you to modify the basic ClearQuality object: the Change Request. Methods on the QualityToolkit object allow you to create, modify, close, dispatch, accept, reject, assign, yank, move, change status, log notes, reopen, fix, and more.

Syntax

'Declaration

Public Class QualityToolkit
   Inherits QualityToolkitBase

public class QualityToolkit : QualityToolkitBase

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.ToolkitBase
FChoice.Toolkits.Clarify.Quality.QualityToolkitBase
FChoice.Toolkits.Clarify.Quality.QualityToolkit

Requirements

Namespace: FChoice.Toolkits.Clarify.Quality

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

QualityToolkit Members
FChoice.Toolkits.Clarify.Quality Namespace


QualityToolkit Class Members | fcSDK Documentation

QualityToolkit Class Members

The following tables list the members exposed by QualityToolkit.

Public Constructors

 | Name | Description
Public Constructor | QualityToolkit Constructor | Overloaded.

Public Properties

 | Name | Description
Public Property | ApplicationClock |
Public Property | ImpersonatorUsername | (Inherited from FChoice.Toolkits.Clarify.Quality.QualityToolkitBase)

Public Methods

 | Name | Description
Public Method | AcceptCR | Overloaded. Accept the specified CR from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.
Public Method | AddModuleToCR | Overloaded. Adding a file Module to a Fixed CR. This overload takes a set of required parameters for the API.
Public Method | AppendHistoryToCR | Overloaded.
Public Method | AssignCR | Overloaded. Assign the CR to a new user. This overload takes a set of required parameters for the API.
Public Method | ChangeCRStatus | Overloaded. Change the status of a CR. This overload takes a set of required parameters for the API.
Public Method | CheckClearQualityTransition | Overloaded. Determine if a user can change status from an old condition/status to a new condition/status. This overload takes a set of required parameters for the API.
Public Method | CloseCR | Overloaded. Close a CR. This overload takes a set of required parameters for the API.
Public Method | CreateCR | Overloaded. Create a new Change Request (CR). This overload takes a set of required parameters for the API.
Public Method | DispatchCR | Overloaded. Dispatch the CR to the specified queue. This overload takes a set of required parameters for the API.
Public Method | DuplicateCR | Overloaded. Mark a CR as duplicate of another 'master' CR. This overload takes a set of required parameters for the API.
Public Method | FixCR | Overloaded. Change the condition of a CR to Fixed. This overload takes a set of required parameters for the API.
Public Method | FixFailed | Overloaded. Change the condition of a Change Request from Fixed to Open. This overload takes a set of required parameters for the API.
Public Method | ForwardCR | Overloaded. Reject-forward the CR from one queue to another. This overload takes a set of required parameters for the API.
Public Method | LogCREmail | Overloaded. Used to create a email log for a CR. This overload takes a set of required parameters for the API.
Public Method | LogCREmailIn | Overloaded.
Public Method | LogCRNote | Overloaded. Used to create a note log against a CR. This overload takes a set of required parameters for the API.
Public Method | MoveCR | Overloaded. Move the CR from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
Public Method | RejectCR | Overloaded. Reject the CR from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.
Public Method | ReopenCR | Overloaded. Reopen a CR. This overload takes a set of required parameters for the API.
Public Method | ReplicateCR | Overloaded. Replicate a CR. This overload takes a set of required parameters for the API.
Public Method | UpdateCR | Overloaded. Update an existing CR. This overload takes a setup object.
Public Method | YankCR | Overloaded. Yank the CR from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.

Reference

QualityToolkit Class
FChoice.Toolkits.Clarify.Quality Namespace


QualityToolkit Constructor | fcSDK Documentation

QualityToolkit Constructor

Initializes a new instance of the QualityToolkit class.

Overload List

Overload | Description
QualityToolkit Constructor(ClarifySession) | Initializes a new instance of the QualityToolkit class using a ClarifySession object.
QualityToolkit Constructor(IFCApplication,IFCSession) | Initializes a new instance of the QualityToolkit class using a Compatibility application and session.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members


QualityToolkit Constructor(ClarifySession) | fcSDK Documentation

QualityToolkit Constructor(ClarifySession)

The session under which the toolkit APIs will be executed.

Initializes a new instance of the QualityToolkit class using a ClarifySession object.

Syntax

'Declaration

Public Function New( _
   ByVal _session_ As ClarifySession _
)

public QualityToolkit(
   ClarifySession _session_
)

Parameters

session

The session under which the toolkit APIs will be executed.

Remarks

If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


QualityToolkit Constructor(IFCApplication,IFCSession) | fcSDK Documentation

QualityToolkit Constructor(IFCApplication,IFCSession)

The compatibility application under which the toolkit APIs will be executed.

The compatibility session under which the toolkit APIs will be executed.

Initializes a new instance of the QualityToolkit class using a Compatibility application and session.

Syntax

'Declaration

Public Function New( _
   ByVal _application_ As IFCApplication, _
   ByVal _session_ As IFCSession _
)

public QualityToolkit(
   IFCApplication _application_,
   IFCSession _session_
)

Parameters

application

The compatibility application under which the toolkit APIs will be executed.

session

The compatibility session under which the toolkit APIs will be executed.

Remarks

If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


AcceptCR Method | fcSDK Documentation

AcceptCR Method

Accept the specified CR from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.

Accept the specified CR from the queue in which it is currently dispatched.

Overload List

Overload | Description
AcceptCR(String) | Accept the specified CR from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.
AcceptCR(AcceptCRSetup) | Accept the specified CR from the queue in which it is currently dispatched. This overload takes a setup object.
AcceptCR(AcceptCRSetup,IDbTransaction) | Accept the specified CR from the queue in which it is currently dispatched. This overload takes a setup object and a database transaction.

Remarks

The CR must be currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
AcceptCRSetup Class


AcceptCR(String) Method | fcSDK Documentation

AcceptCR(String) Method

CR Identifier.

Accept the specified CR from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function AcceptCR( _
   ByVal _cridnum_ As String _
) As ToolkitResult

public ToolkitResult AcceptCR(
   string _cridnum_
)

Parameters

cridnum

CR Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The CR must be currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


AcceptCR(AcceptCRSetup) Method | fcSDK Documentation

AcceptCR(AcceptCRSetup) Method

Setup object for API invocation.

Accept the specified CR from the queue in which it is currently dispatched. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function AcceptCR( _
   ByVal _setupParam_ AcceptCRSetup _
) As ToolkitResult

public ToolkitResult AcceptCR(
   AcceptCRSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The CR must be currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List
AcceptCRSetup Class


AcceptCR(AcceptCRSetup,IDbTransaction) Method | fcSDK Documentation

AcceptCR(AcceptCRSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Accept the specified CR from the queue in which it is currently dispatched. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function AcceptCR( _
   ByVal _setupParam_ As AcceptCRSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult AcceptCR(
   AcceptCRSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The CR must be currently dispatched to a queue.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


AddModuleToCR Method | fcSDK Documentation

AddModuleToCR Method

Adding a file Module to a Fixed CR. This overload takes a set of required parameters for the API.

Adding a file Module to a Fixed CR.

Overload List

Overload | Description
AddModuleToCR(Int32,String) | Adding a file Module to a Fixed CR. This overload takes a set of required parameters for the API.
AddModuleToCR(AddModuleToCRSetup) | Adding a file Module to a Fixed CR. This overload takes a setup object.
AddModuleToCR(AddModuleToCRSetup,IDbTransaction) | Adding a file Module to a Fixed CR. This overload takes a setup object and a database transaction.

Remarks

There is no integration between this API and your change control system so no validation is possible for the Module filename or revision.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
AddModuleToCRSetup Class


AddModuleToCR(Int32,String) Method | fcSDK Documentation

AddModuleToCR(Int32,String) Method

Objid of the Fixed CR.

Name of the file related to the fix.

Adding a file Module to a Fixed CR. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function AddModuleToCR( _
   ByVal _fixObjid_ As Integer, _
   ByVal _fileName_ As String _
) As ToolkitResult

public ToolkitResult AddModuleToCR(
   int _fixObjid_,
   string _fileName_
)

Parameters

fixObjid

Objid of the Fixed CR.

fileName

Name of the file related to the fix.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

There is no integration between this API and your change control system so no validation is possible for the Module filename or revision.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


AddModuleToCR(AddModuleToCRSetup) Method | fcSDK Documentation

AddModuleToCR(AddModuleToCRSetup) Method

Setup object for API invocation.

Adding a file Module to a Fixed CR. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function AddModuleToCR( _
   ByVal _setupParam_ AddModuleToCRSetup _
) As ToolkitResult

public ToolkitResult AddModuleToCR(
   AddModuleToCRSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

There is no integration between this API and your change control system so no validation is possible for the Module filename or revision.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List
AddModuleToCRSetup Class


AddModuleToCR(AddModuleToCRSetup,IDbTransaction) Method | fcSDK Documentation

AddModuleToCR(AddModuleToCRSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Adding a file Module to a Fixed CR. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function AddModuleToCR( _
   ByVal _setupParam_ As AddModuleToCRSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult AddModuleToCR(
   AddModuleToCRSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

There is no integration between this API and your change control system so no validation is possible for the Module filename or revision.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


AppendHistoryToCR Method | fcSDK Documentation

AppendHistoryToCR Method

Overload List

Overload | Description
AppendHistoryToCR(String,String) |
AppendHistoryToCR(String,String,IDbTransaction) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members


AppendHistoryToCR(String,String) Method | fcSDK Documentation

AppendHistoryToCR(String,String) Method

Syntax

'Declaration

Public Overloads Sub AppendHistoryToCR( _
   ByVal _idNumber_ As String, _
   ByVal _stringToAppendToHistory_ As String _
)

public void AppendHistoryToCR(
   string _idNumber_,
   string _stringToAppendToHistory_
)

Parameters

idNumber

stringToAppendToHistory

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


AppendHistoryToCR(String,String,IDbTransaction) Method | fcSDK Documentation

AppendHistoryToCR(String,String,IDbTransaction) Method

Syntax

'Declaration

Public Overloads Sub AppendHistoryToCR( _
   ByVal _idNumber_ As String, _
   ByVal _stringToAppendToHistory_ As String, _
   ByVal _dbTransaction_ As IDbTransaction _
)

public void AppendHistoryToCR(
   string _idNumber_,
   string _stringToAppendToHistory_,
   IDbTransaction _dbTransaction_
)

Parameters

idNumber

stringToAppendToHistory

dbTransaction

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


AssignCR Method | fcSDK Documentation

AssignCR Method

Assign the CR to a new user. This overload takes a set of required parameters for the API.

Assign the CR to a new user.

Overload List

Overload | Description
AssignCR(String) | Assign the CR to a new user. This overload takes a set of required parameters for the API.
AssignCR(AssignCRSetup) | Assign the CR to a new user. This overload takes a setup object.
AssignCR(AssignCRSetup,IDbTransaction) | Assign the CR to a new user. This overload takes a setup object and a database transaction.

Remarks

The CR must be in the Open condition, and the user assigning the CR does not have to be the owner of the CR. In base Clarify, the assigner of a CR must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the CR in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
AssignCRSetup Class


AssignCR(String) Method | fcSDK Documentation

AssignCR(String) Method

CR Identifier.

Assign the CR to a new user. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function AssignCR( _
   ByVal _cridnum_ As String _
) As ToolkitResult

public ToolkitResult AssignCR(
   string _cridnum_
)

Parameters

cridnum

CR Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The CR must be in the Open condition, and the user assigning the CR does not have to be the owner of the CR. In base Clarify, the assigner of a CR must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the CR in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


AssignCR(AssignCRSetup) Method | fcSDK Documentation

AssignCR(AssignCRSetup) Method

Setup object for API invocation.

Assign the CR to a new user. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function AssignCR( _
   ByVal _setupParam_ AssignCRSetup _
) As ToolkitResult

public ToolkitResult AssignCR(
   AssignCRSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The CR must be in the Open condition, and the user assigning the CR does not have to be the owner of the CR. In base Clarify, the assigner of a CR must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the CR in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List
AssignCRSetup Class


AssignCR(AssignCRSetup,IDbTransaction) Method | fcSDK Documentation

AssignCR(AssignCRSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Assign the CR to a new user. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function AssignCR( _
   ByVal _setupParam_ As AssignCRSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult AssignCR(
   AssignCRSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The CR must be in the Open condition, and the user assigning the CR does not have to be the owner of the CR. In base Clarify, the assigner of a CR must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the CR in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


ChangeCRStatus Method | fcSDK Documentation

ChangeCRStatus Method

Change the status of a CR. This overload takes a set of required parameters for the API.

Change the status of a CR.

Overload List

Overload | Description
ChangeCRStatus(String) | Change the status of a CR. This overload takes a set of required parameters for the API.
ChangeCRStatus(ChangeCRStatusSetup) | Change the status of a CR. This overload takes a setup object.
ChangeCRStatus(ChangeCRStatusSetup,IDbTransaction) | Change the status of a CR. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
ChangeCRStatusSetup Class


ChangeCRStatus(String) Method | fcSDK Documentation

ChangeCRStatus(String) Method

Change Request Identifier

Change the status of a CR. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function ChangeCRStatus( _
   ByVal _crIDNum_ As String _
) As ToolkitResult

public ToolkitResult ChangeCRStatus(
   string _crIDNum_
)

Parameters

crIDNum

Change Request Identifier

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The change request may be in any condition, but the new status MUST have the same condition as the change request’s current condition. In other words, you cannot use this API to change the condition of a CR – you must use the proper API (fix, close, reopen) to do that. You may assign notes to the status change, as well as set the time of the status change, and the user who changed the status. The API can also generate a time bomb (for business rule notification).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


ChangeCRStatus(ChangeCRStatusSetup) Method | fcSDK Documentation

ChangeCRStatus(ChangeCRStatusSetup) Method

Setup object for API invocation.

Change the status of a CR. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function ChangeCRStatus( _
   ByVal _setupParam_ ChangeCRStatusSetup _
) As ToolkitResult

public ToolkitResult ChangeCRStatus(
   ChangeCRStatusSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The change request may be in any condition, but the new status MUST have the same condition as the change request’s current condition. In other words, you cannot use this API to change the condition of a CR – you must use the proper API (fix, close, reopen) to do that. You may assign notes to the status change, as well as set the time of the status change, and the user who changed the status. The API can also generate a time bomb (for business rule notification).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List
ChangeCRStatusSetup Class


ChangeCRStatus(ChangeCRStatusSetup,IDbTransaction) Method | fcSDK Documentation

ChangeCRStatus(ChangeCRStatusSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Change the status of a CR. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function ChangeCRStatus( _
   ByVal _setupParam_ As ChangeCRStatusSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult ChangeCRStatus(
   ChangeCRStatusSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


CheckClearQualityTransition Method | fcSDK Documentation

CheckClearQualityTransition Method

Determine if a user can change status from an old condition/status to a new condition/status. This overload takes a set of required parameters for the API.

Determine if a user can change status from an old condition/status to a new condition/status.

Overload List

Overload | Description
CheckClearQualityTransition(String,String,String,String,String) | Determine if a user can change status from an old condition/status to a new condition/status. This overload takes a set of required parameters for the API.
CheckClearQualityTransition(CheckClearQualityTransitionSetup) | Determine if a user can change status from an old condition/status to a new condition/status. This overload takes a setup object.
CheckClearQualityTransition(CheckClearQualityTransitionSetup,IDbTransaction) | Determine if a user can change status from an old condition/status to a new condition/status. This overload takes a setup object and a database transaction.

Remarks

Checks the transitions as set up in Clarify’s Policies & Customers.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
CheckClearQualityTransitionSetup Class


CheckClearQualityTransition(String,String,String,String,String) Method | fcSDK Documentation

CheckClearQualityTransition(String,String,String,String,String) Method

The current condition of the Change Request.

The current status of the Change Request.

The new condition for the Change Request.

The new status for the Change Request.

The user checking the transition. If not set, the session user is used.

Determine if a user can change status from an old condition/status to a new condition/status. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CheckClearQualityTransition( _
   ByVal _oldCondition_ As String, _
   ByVal _oldStatus_ As String, _
   ByVal _newCondition_ As String, _
   ByVal _newStatus_ As String, _
   ByVal _userName_ As String _
) As ToolkitResult

public ToolkitResult CheckClearQualityTransition(
   string _oldCondition_,
   string _oldStatus_,
   string _newCondition_,
   string _newStatus_,
   string _userName_
)

Parameters

oldCondition

The current condition of the Change Request.

oldStatus

The current status of the Change Request.

newCondition

The new condition for the Change Request.

newStatus

The new status for the Change Request.

userName

The user checking the transition. If not set, the session user is used.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

Checks the transitions as set up in Clarify’s Policies & Customers.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


CheckClearQualityTransition(CheckClearQualityTransitionSetup) Method | fcSDK Documentation

CheckClearQualityTransition(CheckClearQualityTransitionSetup) Method

Setup object for API invocation.

Determine if a user can change status from an old condition/status to a new condition/status. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CheckClearQualityTransition( _
   ByVal _setupParam_ CheckClearQualityTransitionSetup _
) As ToolkitResult

public ToolkitResult CheckClearQualityTransition(
   CheckClearQualityTransitionSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

Checks the transitions as set up in Clarify’s Policies & Customers.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List
CheckClearQualityTransitionSetup Class


CheckClearQualityTransition(CheckClearQualityTransitionSetup,IDbTransaction) Method | fcSDK Documentation

CheckClearQualityTransition(CheckClearQualityTransitionSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Determine if a user can change status from an old condition/status to a new condition/status. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CheckClearQualityTransition( _
   ByVal _setupParam_ As CheckClearQualityTransitionSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CheckClearQualityTransition(
   CheckClearQualityTransitionSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

Checks the transitions as set up in Clarify’s Policies & Customers.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


CloseCR Method | fcSDK Documentation

CloseCR Method

Close a CR. This overload takes a set of required parameters for the API.

Close a CR.

Overload List

Overload | Description
CloseCR(String) | Close a CR. This overload takes a set of required parameters for the API.
CloseCR(CloseCRSetup) | Close a CR. This overload takes a setup object.
CloseCR(CloseCRSetup,IDbTransaction) | Close a CR. This overload takes a setup object and a database transaction.

Remarks

The CR must be in a condition/status that allows the transition to the Closed condition.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
CloseCRSetup Class


CloseCR(String) Method | fcSDK Documentation

CloseCR(String) Method

Change Request Identifier

Close a CR. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CloseCR( _
   ByVal _crIDNum_ As String _
) As ToolkitResult

public ToolkitResult CloseCR(
   string _crIDNum_
)

Parameters

crIDNum

Change Request Identifier

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the CloseBug.

Remarks

The CR must be in a condition/status that allows the transition to the Closed condition.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


CloseCR(CloseCRSetup) Method | fcSDK Documentation

CloseCR(CloseCRSetup) Method

Setup object for API invocation.

Close a CR. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CloseCR( _
   ByVal _setupParam_ CloseCRSetup _
) As ToolkitResult

public ToolkitResult CloseCR(
   CloseCRSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the CloseBug.

Remarks

The CR must be in a condition/status that allows the transition to the Closed condition.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List
CloseCRSetup Class


CloseCR(CloseCRSetup,IDbTransaction) Method | fcSDK Documentation

CloseCR(CloseCRSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Close a CR. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CloseCR( _
   ByVal _setupParam_ As CloseCRSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CloseCR(
   CloseCRSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The CR must be in a condition/status that allows the transition to the Closed condition.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


CreateCR Method | fcSDK Documentation

CreateCR Method

Create a new Change Request (CR). This overload takes a set of required parameters for the API.

Create a new Change Request (CR).

Overload List

Overload | Description
CreateCR(String,String,String) | Create a new Change Request (CR). This overload takes a set of required parameters for the API.
CreateCR(CreateCRSetup) | Create a new Change Request (CR). This overload takes a setup object.
CreateCR(CreateCRSetup,IDbTransaction) | Create a new Change Request (CR). This overload takes a setup object and a database transaction.

Remarks

Unless a Queue is specified the CR is located in the owners default WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
CreateCRSetup Class


CreateCR(String,String,String) Method | fcSDK Documentation

CreateCR(String,String,String) Method

Part number of part for the Change Request

Part revision of part for the Change Request

Part domain of part for the Change Request

Create a new Change Request (CR). This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreateCR( _
   ByVal _partNumber_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _partDomain_ As String _
) As ToolkitResult

public ToolkitResult CreateCR(
   string _partNumber_,
   string _partRevision_,
   string _partDomain_
)

Parameters

partNumber

Part number of part for the Change Request

partRevision

Part revision of part for the Change Request

partDomain

Part domain of part for the Change Request

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • IDNum - The IDNum of the CR.

Remarks

Unless a Queue is specified the CR is located in the owners default WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


CreateCR(CreateCRSetup) Method | fcSDK Documentation

CreateCR(CreateCRSetup) Method

Setup object for API invocation.

Create a new Change Request (CR). This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreateCR( _
   ByVal _setupParam_ CreateCRSetup _
) As ToolkitResult

public ToolkitResult CreateCR(
   CreateCRSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • IDNum - The IDNum of the CR.

Remarks

Unless a Queue is specified the CR is located in the owners default WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List
CreateCRSetup Class


CreateCR(CreateCRSetup,IDbTransaction) Method | fcSDK Documentation

CreateCR(CreateCRSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Create a new Change Request (CR). This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreateCR( _
   ByVal _setupParam_ As CreateCRSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreateCR(
   CreateCRSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

Unless a Queue is specified the CR is located in the owners default WipBin.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


DispatchCR Method | fcSDK Documentation

DispatchCR Method

Dispatch the CR to the specified queue. This overload takes a set of required parameters for the API.

Dispatch the CR to the specified queue.

Overload List

Overload | Description
DispatchCR(String,String) | Dispatch the CR to the specified queue. This overload takes a set of required parameters for the API.
DispatchCR(DispatchCRSetup) | Dispatch the CR to the specified queue. This overload takes a setup object.
DispatchCR(DispatchCRSetup,IDbTransaction) | Dispatch the CR to the specified queue. This overload takes a setup object and a database transaction.

Remarks

The CR must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
DispatchCRSetup Class


DispatchCR(String,String) Method | fcSDK Documentation

DispatchCR(String,String) Method

CR Identifier.

The queue into which the CR is to be dispatched.

Dispatch the CR to the specified queue. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function DispatchCR( _
   ByVal _cridnum_ As String, _
   ByVal _queue_ As String _
) As ToolkitResult

public ToolkitResult DispatchCR(
   string _cridnum_,
   string _queue_
)

Parameters

cridnum

CR Identifier.

queue

The queue into which the CR is to be dispatched.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The CR must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


DispatchCR(DispatchCRSetup) Method | fcSDK Documentation

DispatchCR(DispatchCRSetup) Method

Setup object for API invocation.

Dispatch the CR to the specified queue. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function DispatchCR( _
   ByVal _setupParam_ DispatchCRSetup _
) As ToolkitResult

public ToolkitResult DispatchCR(
   DispatchCRSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The CR must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List
DispatchCRSetup Class


DispatchCR(DispatchCRSetup,IDbTransaction) Method | fcSDK Documentation

DispatchCR(DispatchCRSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Dispatch the CR to the specified queue. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function DispatchCR( _
   ByVal _setupParam_ As DispatchCRSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult DispatchCR(
   DispatchCRSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The CR must be in open condition, and not currently dispatched to a queue.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


DuplicateCR Method | fcSDK Documentation

DuplicateCR Method

Mark a CR as duplicate of another 'master' CR. This overload takes a set of required parameters for the API.

Mark a CR as duplicate of another 'master' CR.

Overload List

Overload | Description
DuplicateCR(String,String) | Mark a CR as duplicate of another 'master' CR. This overload takes a set of required parameters for the API.
DuplicateCR(DuplicateCRSetup) | Mark a CR as duplicate of another 'master' CR. This overload takes a setup object.
DuplicateCR(DuplicateCRSetup,IDbTransaction) | Mark a CR as duplicate of another 'master' CR. This overload takes a setup object and a database transaction.

Remarks

The condition of the CR is changed to CR Duplicate/Closed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
DuplicateCRSetup Class


DuplicateCR(String,String) Method | fcSDK Documentation

DuplicateCR(String,String) Method

Identifier of the CR being marked as a duplicate.

Identifier of the 'master' CR this CR duplicates.

Mark a CR as duplicate of another 'master' CR. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function DuplicateCR( _
   ByVal _crIDNum_ As String, _
   ByVal _masterCRIDNum_ As String _
) As ToolkitResult

public ToolkitResult DuplicateCR(
   string _crIDNum_,
   string _masterCRIDNum_
)

Parameters

crIDNum

Identifier of the CR being marked as a duplicate.

masterCRIDNum

Identifier of the 'master' CR this CR duplicates.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The condition of the CR is changed to CR Duplicate/Closed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


DuplicateCR(DuplicateCRSetup) Method | fcSDK Documentation

DuplicateCR(DuplicateCRSetup) Method

Setup object for API invocation.

Mark a CR as duplicate of another 'master' CR. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function DuplicateCR( _
   ByVal _setupParam_ DuplicateCRSetup _
) As ToolkitResult

public ToolkitResult DuplicateCR(
   DuplicateCRSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The condition of the CR is changed to CR Duplicate/Closed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List
DuplicateCRSetup Class


DuplicateCR(DuplicateCRSetup,IDbTransaction) Method | fcSDK Documentation

DuplicateCR(DuplicateCRSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Mark a CR as duplicate of another 'master' CR. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function DuplicateCR( _
   ByVal _setupParam_ As DuplicateCRSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult DuplicateCR(
   DuplicateCRSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The condition of the CR is changed to CR Duplicate/Closed.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


FixCR Method | fcSDK Documentation

FixCR Method

Change the condition of a CR to Fixed. This overload takes a set of required parameters for the API.

Change the condition of a CR to Fixed.

Overload List

Overload | Description
FixCR(String) | Change the condition of a CR to Fixed. This overload takes a set of required parameters for the API.
FixCR(FixCRSetup) | Change the condition of a CR to Fixed. This overload takes a setup object.
FixCR(FixCRSetup,IDbTransaction) | Change the condition of a CR to Fixed. This overload takes a setup object and a database transaction.

Remarks

The CR condition will become Fixed even if it was already Closed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
FixCRSetup Class


FixCR(String) Method | fcSDK Documentation

FixCR(String) Method

Identifier of the CR being set to Fixed.

Change the condition of a CR to Fixed. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function FixCR( _
   ByVal _crIDNum_ As String _
) As ToolkitResult

public ToolkitResult FixCR(
   string _crIDNum_
)

Parameters

crIDNum

Identifier of the CR being set to Fixed.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the FixBug.

Remarks

The CR condition will become Fixed even if it was already Closed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


FixCR(FixCRSetup) Method | fcSDK Documentation

FixCR(FixCRSetup) Method

Setup object for API invocation.

Change the condition of a CR to Fixed. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function FixCR( _
   ByVal _setupParam_ FixCRSetup _
) As ToolkitResult

public ToolkitResult FixCR(
   FixCRSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the FixBug.

Remarks

The CR condition will become Fixed even if it was already Closed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List
FixCRSetup Class


FixCR(FixCRSetup,IDbTransaction) Method | fcSDK Documentation

FixCR(FixCRSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Change the condition of a CR to Fixed. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function FixCR( _
   ByVal _setupParam_ As FixCRSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult FixCR(
   FixCRSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The CR condition will become Fixed even if it was already Closed.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


FixFailed Method | fcSDK Documentation

FixFailed Method

Change the condition of a Change Request from Fixed to Open. This overload takes a set of required parameters for the API.

Change the condition of a Change Request from Fixed to Open.

Overload List

Overload | Description
FixFailed(String) | Change the condition of a Change Request from Fixed to Open. This overload takes a set of required parameters for the API.
FixFailed(FixFailedSetup) | Change the condition of a Change Request from Fixed to Open. This overload takes a setup object.
FixFailed(FixFailedSetup,IDbTransaction) | Change the condition of a Change Request from Fixed to Open. This overload takes a setup object and a database transaction.

Remarks

The CR must be in a condition/status that allows the transition to the Open.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
FixFailedSetup Class


FixFailed(String) Method | fcSDK Documentation

FixFailed(String) Method

Identifier of the CR being marked as FixFailed.

Change the condition of a Change Request from Fixed to Open. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function FixFailed( _
   ByVal _crIDNum_ As String _
) As ToolkitResult

public ToolkitResult FixFailed(
   string _crIDNum_
)

Parameters

crIDNum

Identifier of the CR being marked as FixFailed.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the CloseBug.

Remarks

The CR must be in a condition/status that allows the transition to the Open.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


FixFailed(FixFailedSetup) Method | fcSDK Documentation

FixFailed(FixFailedSetup) Method

Setup object for API invocation.

Change the condition of a Change Request from Fixed to Open. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function FixFailed( _
   ByVal _setupParam_ FixFailedSetup _
) As ToolkitResult

public ToolkitResult FixFailed(
   FixFailedSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the CloseBug.

Remarks

The CR must be in a condition/status that allows the transition to the Open.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List
FixFailedSetup Class


FixFailed(FixFailedSetup,IDbTransaction) Method | fcSDK Documentation

FixFailed(FixFailedSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Change the condition of a Change Request from Fixed to Open. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function FixFailed( _
   ByVal _setupParam_ As FixFailedSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult FixFailed(
   FixFailedSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The CR must be in a condition/status that allows the transition to the Open.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


ForwardCR Method | fcSDK Documentation

ForwardCR Method

Reject-forward the CR from one queue to another. This overload takes a set of required parameters for the API.

Reject-forward the CR from one queue to another.

Overload List

Overload | Description
ForwardCR(String,String) | Reject-forward the CR from one queue to another. This overload takes a set of required parameters for the API.
ForwardCR(ForwardCRSetup) | Reject-forward the CR from one queue to another. This overload takes a setup object.
ForwardCR(ForwardCRSetup,IDbTransaction) | Reject-forward the CR from one queue to another. This overload takes a setup object and a database transaction.

Remarks

The CR must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
ForwardCRSetup Class


ForwardCR(String,String) Method | fcSDK Documentation

ForwardCR(String,String) Method

CR Identifier.

The new queue into which the CR is to be forwarded.

Reject-forward the CR from one queue to another. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function ForwardCR( _
   ByVal _cridnum_ As String, _
   ByVal _newQueue_ As String _
) As ToolkitResult

public ToolkitResult ForwardCR(
   string _cridnum_,
   string _newQueue_
)

Parameters

cridnum

CR Identifier.

newQueue

The new queue into which the CR is to be forwarded.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The CR must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


ForwardCR(ForwardCRSetup) Method | fcSDK Documentation

ForwardCR(ForwardCRSetup) Method

Setup object for API invocation.

Reject-forward the CR from one queue to another. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function ForwardCR( _
   ByVal _setupParam_ ForwardCRSetup _
) As ToolkitResult

public ToolkitResult ForwardCR(
   ForwardCRSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The CR must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List
ForwardCRSetup Class


ForwardCR(ForwardCRSetup,IDbTransaction) Method | fcSDK Documentation

ForwardCR(ForwardCRSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Reject-forward the CR from one queue to another. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function ForwardCR( _
   ByVal _setupParam_ As ForwardCRSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult ForwardCR(
   ForwardCRSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The CR must be in open condition, and not currently dispatched to a queue.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


LogCREmail Method | fcSDK Documentation

LogCREmail Method

Used to create a email log for a CR. This overload takes a set of required parameters for the API.

Used to create a email log for a CR.

Overload List

Overload | Description
LogCREmail(String) | Used to create a email log for a CR. This overload takes a set of required parameters for the API.
LogCREmail(LogCREmailSetup) | Used to create a email log for a CR. This overload takes a setup object.
LogCREmail(LogCREmailSetup,IDbTransaction) | Used to create a email log for a CR. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
LogCREmailSetup Class


LogCREmail(String) Method | fcSDK Documentation

LogCREmail(String) Method

Identifier of the CR being logged.

Used to create a email log for a CR. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function LogCREmail( _
   ByVal _crIDNum_ As String _
) As ToolkitResult

public ToolkitResult LogCREmail(
   string _crIDNum_
)

Parameters

crIDNum

Identifier of the CR being logged.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the EmailLog.

Remarks

The date the email is logged can be set, as well as the user who logs the email. Additional fields on the log_email record can also be set as well as a time bomb (for the email_log), which allows notifications to be generated based on the event. In addition, the proper time_bomb can be optionally created that will cause rulemanager to send out the email.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


LogCREmail(LogCREmailSetup) Method | fcSDK Documentation

LogCREmail(LogCREmailSetup) Method

Setup object for API invocation.

Used to create a email log for a CR. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function LogCREmail( _
   ByVal _setupParam_ LogCREmailSetup _
) As ToolkitResult

public ToolkitResult LogCREmail(
   LogCREmailSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the EmailLog.

Remarks

The date the email is logged can be set, as well as the user who logs the email. Additional fields on the log_email record can also be set as well as a time bomb (for the email_log), which allows notifications to be generated based on the event. In addition, the proper time_bomb can be optionally created that will cause rulemanager to send out the email.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List
LogCREmailSetup Class


LogCREmail(LogCREmailSetup,IDbTransaction) Method | fcSDK Documentation

LogCREmail(LogCREmailSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to create a email log for a CR. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function LogCREmail( _
   ByVal _setupParam_ As LogCREmailSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult LogCREmail(
   LogCREmailSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


LogCREmailIn Method | fcSDK Documentation

LogCREmailIn Method

Overload List

Overload | Description
LogCREmailIn(LogCREmailInSetup) |
LogCREmailIn(LogCREmailInSetup,IDbTransaction) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members


LogCREmailIn(LogCREmailInSetup) Method | fcSDK Documentation

LogCREmailIn(LogCREmailInSetup) Method

Syntax

'Declaration

Public Overloads Function LogCREmailIn( _
   ByVal _setup_ As QualityToolkit.LogCREmailInSetup _
) As ToolkitResult

public ToolkitResult LogCREmailIn(
   QualityToolkit.LogCREmailInSetup _setup_
)

Parameters

setup

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


LogCREmailIn(LogCREmailInSetup,IDbTransaction) Method | fcSDK Documentation

LogCREmailIn(LogCREmailInSetup,IDbTransaction) Method

Syntax

'Declaration

Public Overloads Function LogCREmailIn( _
   ByVal _setup_ As QualityToolkit.LogCREmailInSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult LogCREmailIn(
   QualityToolkit.LogCREmailInSetup _setup_,
   IDbTransaction _transaction_
)

Parameters

setup

transaction

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


LogCRNote Method | fcSDK Documentation

LogCRNote Method

Used to create a note log against a CR. This overload takes a set of required parameters for the API.

Used to create a note log against a CR.

Overload List

Overload | Description
LogCRNote(String) | Used to create a note log against a CR. This overload takes a set of required parameters for the API.
LogCRNote(LogCRNoteSetup) | Used to create a note log against a CR. This overload takes a setup object.
LogCRNote(LogCRNoteSetup,IDbTransaction) | Used to create a note log against a CR. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
LogCRNoteSetup Class


LogCRNote(String) Method | fcSDK Documentation

LogCRNote(String) Method

Identifier of the CR being logged.

Used to create a note log against a CR. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function LogCRNote( _
   ByVal _crIDNum_ As String _
) As ToolkitResult

public ToolkitResult LogCRNote(
   string _crIDNum_
)

Parameters

crIDNum

Identifier of the CR being logged.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the NoteLog.

Remarks

Allows for the assigning of notes and internal use only text. The date the note is logged can be set, as well as the user who logs the note. Additional fields on the log_cr_note can also be set as well as a time bomb (for the note log), which allows notifications to be generated based on the event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


LogCRNote(LogCRNoteSetup) Method | fcSDK Documentation

LogCRNote(LogCRNoteSetup) Method

Setup object for API invocation.

Used to create a note log against a CR. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function LogCRNote( _
   ByVal _setupParam_ LogCRNoteSetup _
) As ToolkitResult

public ToolkitResult LogCRNote(
   LogCRNoteSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the NoteLog.

Remarks

Allows for the assigning of notes and internal use only text. The date the note is logged can be set, as well as the user who logs the note. Additional fields on the log_cr_note can also be set as well as a time bomb (for the note log), which allows notifications to be generated based on the event.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List
LogCRNoteSetup Class


LogCRNote(LogCRNoteSetup,IDbTransaction) Method | fcSDK Documentation

LogCRNote(LogCRNoteSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to create a note log against a CR. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function LogCRNote( _
   ByVal _setupParam_ As LogCRNoteSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult LogCRNote(
   LogCRNoteSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


MoveCR Method | fcSDK Documentation

MoveCR Method

Move the CR from one WipBin to another WipBin. This overload takes a set of required parameters for the API.

Move the CR from one WipBin to another WipBin.

Overload List

Overload | Description
MoveCR(String,String) | Move the CR from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
MoveCR(MoveCRSetup) | Move the CR from one WipBin to another WipBin. This overload takes a setup object.
MoveCR(MoveCRSetup,IDbTransaction) | Move the CR from one WipBin to another WipBin. This overload takes a setup object and a database transaction.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the CR, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
MoveCRSetup Class


MoveCR(String,String) Method | fcSDK Documentation

MoveCR(String,String) Method

CR Identifier.

The new WipBin into which the CR is to be moved.

Move the CR from one WipBin to another WipBin. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function MoveCR( _
   ByVal _cridnum_ As String, _
   ByVal _newWipBin_ As String _
) As ToolkitResult

public ToolkitResult MoveCR(
   string _cridnum_,
   string _newWipBin_
)

Parameters

cridnum

CR Identifier.

newWipBin

The new WipBin into which the CR is to be moved.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the CR, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


MoveCR(MoveCRSetup) Method | fcSDK Documentation

MoveCR(MoveCRSetup) Method

Setup object for API invocation.

Move the CR from one WipBin to another WipBin. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function MoveCR( _
   ByVal _setupParam_ MoveCRSetup _
) As ToolkitResult

public ToolkitResult MoveCR(
   MoveCRSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the CR, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List
MoveCRSetup Class


MoveCR(MoveCRSetup,IDbTransaction) Method | fcSDK Documentation

MoveCR(MoveCRSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Move the CR from one WipBin to another WipBin. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function MoveCR( _
   ByVal _setupParam_ As MoveCRSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult MoveCR(
   MoveCRSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the CR, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


RejectCR Method | fcSDK Documentation

RejectCR Method

Reject the CR from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.

Reject the CR from the queue in which it currently resides, and return it to the owner.

Overload List

Overload | Description
RejectCR(String) | Reject the CR from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.
RejectCR(RejectCRSetup) | Reject the CR from the queue in which it currently resides, and return it to the owner. This overload takes a setup object.
RejectCR(RejectCRSetup,IDbTransaction) | Reject the CR from the queue in which it currently resides, and return it to the owner. This overload takes a setup object and a database transaction.

Remarks

The CR must be in open condition, and currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
RejectCRSetup Class


RejectCR(String) Method | fcSDK Documentation

RejectCR(String) Method

CR Identifier.

Reject the CR from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function RejectCR( _
   ByVal _cridnum_ As String _
) As ToolkitResult

public ToolkitResult RejectCR(
   string _cridnum_
)

Parameters

cridnum

CR Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The CR must be in open condition, and currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


RejectCR(RejectCRSetup) Method | fcSDK Documentation

RejectCR(RejectCRSetup) Method

Setup object for API invocation.

Reject the CR from the queue in which it currently resides, and return it to the owner. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function RejectCR( _
   ByVal _setupParam_ RejectCRSetup _
) As ToolkitResult

public ToolkitResult RejectCR(
   RejectCRSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The CR must be in open condition, and currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List
RejectCRSetup Class


RejectCR(RejectCRSetup,IDbTransaction) Method | fcSDK Documentation

RejectCR(RejectCRSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Reject the CR from the queue in which it currently resides, and return it to the owner. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function RejectCR( _
   ByVal _setupParam_ As RejectCRSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult RejectCR(
   RejectCRSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The CR must be in open condition, and currently dispatched to a queue.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


ReopenCR Method | fcSDK Documentation

ReopenCR Method

Reopen a CR. This overload takes a set of required parameters for the API.

Reopen a CR.

Overload List

Overload | Description
ReopenCR(String) | Reopen a CR. This overload takes a set of required parameters for the API.
ReopenCR(ReopenCRSetup) | Reopen a CR. This overload takes a setup object.
ReopenCR(ReopenCRSetup,IDbTransaction) | Reopen a CR. This overload takes a setup object and a database transaction.

Remarks

It must be in a condition other than “Open”, and cannot be dispatched.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
ReopenCRSetup Class


ReopenCR(String) Method | fcSDK Documentation

ReopenCR(String) Method

Identifier of the CR being reopened.

Reopen a CR. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function ReopenCR( _
   ByVal _crIDNum_ As String _
) As ToolkitResult

public ToolkitResult ReopenCR(
   string _crIDNum_
)

Parameters

crIDNum

Identifier of the CR being reopened.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

It must be in a condition other than “Open”, and cannot be dispatched.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


ReopenCR(ReopenCRSetup) Method | fcSDK Documentation

ReopenCR(ReopenCRSetup) Method

Setup object for API invocation.

Reopen a CR. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function ReopenCR( _
   ByVal _setupParam_ ReopenCRSetup _
) As ToolkitResult

public ToolkitResult ReopenCR(
   ReopenCRSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

It must be in a condition other than “Open”, and cannot be dispatched.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List
ReopenCRSetup Class


ReopenCR(ReopenCRSetup,IDbTransaction) Method | fcSDK Documentation

ReopenCR(ReopenCRSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Reopen a CR. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function ReopenCR( _
   ByVal _setupParam_ As ReopenCRSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult ReopenCR(
   ReopenCRSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

It must be in a condition other than “Open”, and cannot be dispatched.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


ReplicateCR Method | fcSDK Documentation

ReplicateCR Method

Replicate a CR. This overload takes a set of required parameters for the API.

Replicate a CR.

Overload List

Overload | Description
ReplicateCR(String) | Replicate a CR. This overload takes a set of required parameters for the API.
ReplicateCR(ReplicateCRSetup) | Replicate a CR. This overload takes a setup object.
ReplicateCR(ReplicateCRSetup,IDbTransaction) | Replicate a CR. This overload takes a setup object and a database transaction.

Remarks

The new CR is an exact copy of the original with the following exceptions:

  1. It has a new unique identifier for it.
  2. The CR history has next text added to show the start and end of the replicated CR history.
  3. A new activity log entry is added to show this CR is replicated. Also, an activity log entry is also added to the original CR to note that it has been replicated.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
ReplicateCRSetup Class


ReplicateCR(String) Method | fcSDK Documentation

ReplicateCR(String) Method

Identifier of the CR being replicated.

Replicate a CR. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function ReplicateCR( _
   ByVal _crIDNum_ As String _
) As ToolkitResult

public ToolkitResult ReplicateCR(
   string _crIDNum_
)

Parameters

crIDNum

Identifier of the CR being replicated.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the CR.
  • IDNum - The IDNum of the CR.

Remarks

The new CR is an exact copy of the original with the following exceptions:

  1. It has a new unique identifier for it.
  2. The CR history has next text added to show the start and end of the replicated CR history.
  3. A new activity log entry is added to show this CR is replicated. Also, an activity log entry is also added to the original CR to note that it has been replicated.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


ReplicateCR(ReplicateCRSetup) Method | fcSDK Documentation

ReplicateCR(ReplicateCRSetup) Method

Setup object for API invocation.

Replicate a CR. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function ReplicateCR( _
   ByVal _setupParam_ ReplicateCRSetup _
) As ToolkitResult

public ToolkitResult ReplicateCR(
   ReplicateCRSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • IDNum - The IDNum of the CR.
  • Objid - The Objid of the CR.

Remarks

The new CR is an exact copy of the original with the following exceptions:

  1. It has a new unique identifier for it.
  2. The CR history has next text added to show the start and end of the replicated CR history.
  3. A new activity log entry is added to show this CR is replicated. Also, an activity log entry is also added to the original CR to note that it has been replicated.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List
ReplicateCRSetup Class


ReplicateCR(ReplicateCRSetup,IDbTransaction) Method | fcSDK Documentation

ReplicateCR(ReplicateCRSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Replicate a CR. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function ReplicateCR( _
   ByVal _setupParam_ As ReplicateCRSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult ReplicateCR(
   ReplicateCRSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new CR is an exact copy of the original with the following exceptions:

  1. It has a new unique identifier for it.
  2. The CR history has next text added to show the start and end of the replicated CR history.
  3. A new activity log entry is added to show this CR is replicated. Also, an activity log entry is also added to the original CR to note that it has been replicated.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


UpdateCR Method | fcSDK Documentation

UpdateCR Method

Update an existing CR. This overload takes a setup object.

Update an existing CR.

Overload List

Overload | Description
UpdateCR(UpdateCRSetup) | Update an existing CR. This overload takes a setup object.
UpdateCR(UpdateCRSetup,IDbTransaction) | Update an existing CR. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
UpdateCRSetup Class


UpdateCR(UpdateCRSetup) Method | fcSDK Documentation

UpdateCR(UpdateCRSetup) Method

Setup object for API invocation.

Update an existing CR. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function UpdateCR( _
   ByVal _setupParam_ UpdateCRSetup _
) As ToolkitResult

public ToolkitResult UpdateCR(
   UpdateCRSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

All of the primary fields of the CR can be set. If they are left blank, then the value in the CR is not changed. The modifier and the time of modification may be specified, and you may specify additional fields for the modify_cr object. Can also generate a time bomb (for business rule notification).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List
UpdateCRSetup Class


UpdateCR(UpdateCRSetup,IDbTransaction) Method | fcSDK Documentation

UpdateCR(UpdateCRSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Update an existing CR. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdateCR( _
   ByVal _setupParam_ As UpdateCRSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdateCR(
   UpdateCRSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


YankCR Method | fcSDK Documentation

YankCR Method

Yank the CR from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.

Yank the CR from its current location to a new owner's WipBin.

Overload List

Overload | Description
YankCR(String) | Yank the CR from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.
YankCR(YankCRSetup) | Yank the CR from its current location to a new owner's WipBin. This overload takes a setup object.
YankCR(YankCRSetup,IDbTransaction) | Yank the CR from its current location to a new owner's WipBin. This overload takes a setup object and a database transaction.

Remarks

The WipBin to place the CR in may also be specified. This is augmented function from base Clarify, where the CR is always placed in the default WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
YankCRSetup Class


YankCR(String) Method | fcSDK Documentation

YankCR(String) Method

CR Identifier.

Yank the CR from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function YankCR( _
   ByVal _cridnum_ As String _
) As ToolkitResult

public ToolkitResult YankCR(
   string _cridnum_
)

Parameters

cridnum

CR Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The WipBin to place the CR in may also be specified. This is augmented function from base Clarify, where the CR is always placed in the default WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


YankCR(YankCRSetup) Method | fcSDK Documentation

YankCR(YankCRSetup) Method

Setup object for API invocation.

Yank the CR from its current location to a new owner's WipBin. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function YankCR( _
   ByVal _setupParam_ YankCRSetup _
) As ToolkitResult

public ToolkitResult YankCR(
   YankCRSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The WipBin to place the CR in may also be specified. This is augmented function from base Clarify, where the CR is always placed in the default WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List
YankCRSetup Class


YankCR(YankCRSetup,IDbTransaction) Method | fcSDK Documentation

YankCR(YankCRSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Yank the CR from its current location to a new owner's WipBin. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function YankCR( _
   ByVal _setupParam_ As YankCRSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult YankCR(
   YankCRSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The WipBin to place the CR in may also be specified. This is augmented function from base Clarify, where the CR is always placed in the default WipBin.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members
Overload List


ApplicationClock Property (QualityToolkit) | fcSDK Documentation

ApplicationClock Property (QualityToolkit)

Syntax

'Declaration

Public Property ApplicationClock As IApplicationClock

public IApplicationClock ApplicationClock {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit Class
QualityToolkit Members


QualityToolkit.LogCREmailInSetup Class | fcSDK Documentation

QualityToolkit.LogCREmailInSetup Class

Syntax

'Declaration

Public Class QualityToolkit.LogCREmailInSetup
   Inherits FChoice.Toolkits.Clarify.Support.LogEmailInSetup

public class QualityToolkit.LogCREmailInSetup : FChoice.Toolkits.Clarify.Support.LogEmailInSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.LogEmailInSetup
FChoice.Toolkits.Clarify.Quality.QualityToolkit.LogCREmailInSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Quality

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

QualityToolkit.LogCREmailInSetup Members
FChoice.Toolkits.Clarify.Quality Namespace


QualityToolkit.LogCREmailInSetup Class Members | fcSDK Documentation

QualityToolkit.LogCREmailInSetup Class Members

The following tables list the members exposed by QualityToolkit.LogCREmailInSetup.

Public Constructors

 | Name | Description
Public Constructor | QualityToolkit.LogCREmailInSetup Constructor |

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | CCList | Email addresses of persons CC'd on the email being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | GenerateTimeBombs | Specifies if timebombs should be created. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | IDNumber | Identifier of the Case against which the email in is being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | LogDate | DateTime the log was created. If not set, the current time is used (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | MailLogActionType | Element from the 'Mail Log Action Type' user defined list. If not set, the default list value is used. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | Message | Body of the email being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | Recipient | Email address of the recipients of the email being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | Sender | Email address of the sender of the email being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | Subject | (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | UserName | User who created the log. If not set, the session user is used. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)

Reference

QualityToolkit.LogCREmailInSetup Class
FChoice.Toolkits.Clarify.Quality Namespace


QualityToolkit.LogCREmailInSetup Constructor | fcSDK Documentation

QualityToolkit.LogCREmailInSetup Constructor

Syntax

'Declaration

Public Function New( _
   ByVal _crIDNum_ As String, _
   ByVal _sender_ As String, _
   ByVal _recipient_ As String, _
   ByVal _message_ As String _
)

public QualityToolkit.LogCREmailInSetup(
   string _crIDNum_,
   string _sender_,
   string _recipient_,
   string _message_
)

Parameters

crIDNum

sender

recipient

message

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkit.LogCREmailInSetup Class
QualityToolkit.LogCREmailInSetup Members


QualityToolkitBase Class | fcSDK Documentation

QualityToolkitBase Class

Please see QualityToolkit. This class is used internally and not meant to be created by end users.

Syntax

'Declaration

Public MustInherit Class QualityToolkitBase
   Inherits FChoice.Toolkits.Clarify.ToolkitBase

public abstract class QualityToolkitBase : FChoice.Toolkits.Clarify.ToolkitBase

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.ToolkitBase
FChoice.Toolkits.Clarify.Quality.QualityToolkitBase
FChoice.Toolkits.Clarify.Quality.QualityToolkit

Requirements

Namespace: FChoice.Toolkits.Clarify.Quality

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

QualityToolkitBase Members
FChoice.Toolkits.Clarify.Quality Namespace


QualityToolkitBase Class Members | fcSDK Documentation

QualityToolkitBase Class Members

The following tables list the members exposed by QualityToolkitBase.

Public Properties

 | Name | Description
Public Property | ImpersonatorUsername |

Reference

QualityToolkitBase Class
FChoice.Toolkits.Clarify.Quality Namespace


ImpersonatorUsername Property (QualityToolkitBase) | fcSDK Documentation

ImpersonatorUsername Property (QualityToolkitBase)

Syntax

'Declaration

Public Property ImpersonatorUsername As String

public string ImpersonatorUsername {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

QualityToolkitBase Class
QualityToolkitBase Members


RejectCRSetup Class | fcSDK Documentation

RejectCRSetup Class

Used by the RejectCR method as setup data for invocation.

Syntax

'Declaration

Public Class RejectCRSetup

public class RejectCRSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Quality.RejectCRSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Quality

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

RejectCRSetup Members
FChoice.Toolkits.Clarify.Quality Namespace
RejectCR(RejectCRSetup) Method


RejectCRSetup Class Members | fcSDK Documentation

RejectCRSetup Class Members

The following tables list the members exposed by RejectCRSetup.

Public Constructors

 | Name | Description
Public Constructor | RejectCRSetup Constructor | Initializes a new instance of the RejectCRSetup class.

Public Properties

 | Name | Description
Public Property | CRIDNum | CR Identifier.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Notes | The reason the CR was rejected from the queue into which it was dispatched.
Public Property | RejectDate | DateTime the CR was rejected. If not set, the current time is used.
Public Property | UserName | The user who has rejected the CR. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the CR. If not set, the UserName's default is used.

Reference

RejectCRSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
RejectCR(RejectCRSetup) Method


RejectCRSetup Constructor | fcSDK Documentation

RejectCRSetup Constructor

CR Identifier.

Initializes a new instance of the RejectCRSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _cridnum_ As String _
)

[ConstructorIndexAttribute()]
public RejectCRSetup(
   string _cridnum_
)

Parameters

cridnum

CR Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectCRSetup Class
RejectCRSetup Members


CRIDNum Property (RejectCRSetup) | fcSDK Documentation

CRIDNum Property (RejectCRSetup)

CR Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CRIDNum As String

[PropertyBitValueAttribute()]
public string CRIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectCRSetup Class
RejectCRSetup Members


GenerateTimeBombs Property (RejectCRSetup) | fcSDK Documentation

GenerateTimeBombs Property (RejectCRSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectCRSetup Class
RejectCRSetup Members


Notes Property (RejectCRSetup) | fcSDK Documentation

Notes Property (RejectCRSetup)

The reason the CR was rejected from the queue into which it was dispatched.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectCRSetup Class
RejectCRSetup Members


RejectDate Property (RejectCRSetup) | fcSDK Documentation

RejectDate Property (RejectCRSetup)

DateTime the CR was rejected. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property RejectDate As Date

[PropertyBitValueAttribute()]
public DateTime RejectDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectCRSetup Class
RejectCRSetup Members


UserName Property (RejectCRSetup) | fcSDK Documentation

UserName Property (RejectCRSetup)

The user who has rejected the CR. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectCRSetup Class
RejectCRSetup Members


WipBin Property (RejectCRSetup) | fcSDK Documentation

WipBin Property (RejectCRSetup)

User's WipBin in which to place the CR. If not set, the UserName's default is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectCRSetup Class
RejectCRSetup Members


ReopenCRSetup Class | fcSDK Documentation

ReopenCRSetup Class

Used by the ReopenCR method as setup data for invocation.

Syntax

'Declaration

Public Class ReopenCRSetup

public class ReopenCRSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Quality.ReopenCRSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Quality

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ReopenCRSetup Members
FChoice.Toolkits.Clarify.Quality Namespace
ReopenCR(ReopenCRSetup) Method


ReopenCRSetup Class Members | fcSDK Documentation

ReopenCRSetup Class Members

The following tables list the members exposed by ReopenCRSetup.

Public Constructors

 | Name | Description
Public Constructor | ReopenCRSetup Constructor | Initializes a new instance of the ReopenCRSetup class.

Public Properties

 | Name | Description
Public Property | CRIDNum | Identifier of the CR being reopened.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | ReopenDate | DateTime the CR was reopened. If not set, the current date time is used.
Public Property | Status | The new status for the Change Request. If not set, the default status is used.
Public Property | UserName | The user reopening the CR. If not set, the session user is used.
Public Property | WipBin | Wipbin of the user to place the reopened CR. If not set, the UserName's default is used.

Reference

ReopenCRSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
ReopenCR(ReopenCRSetup) Method


ReopenCRSetup Constructor | fcSDK Documentation

ReopenCRSetup Constructor

Identifier of the CR being reopened.

Initializes a new instance of the ReopenCRSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _crIDNum_ As String _
)

[ConstructorIndexAttribute()]
public ReopenCRSetup(
   string _crIDNum_
)

Parameters

crIDNum

Identifier of the CR being reopened.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenCRSetup Class
ReopenCRSetup Members


CRIDNum Property (ReopenCRSetup) | fcSDK Documentation

CRIDNum Property (ReopenCRSetup)

Identifier of the CR being reopened.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CRIDNum As String

[PropertyBitValueAttribute()]
public string CRIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenCRSetup Class
ReopenCRSetup Members


GenerateTimeBombs Property (ReopenCRSetup) | fcSDK Documentation

GenerateTimeBombs Property (ReopenCRSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenCRSetup Class
ReopenCRSetup Members


ReopenDate Property (ReopenCRSetup) | fcSDK Documentation

ReopenDate Property (ReopenCRSetup)

DateTime the CR was reopened. If not set, the current date time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ReopenDate As Date

[PropertyBitValueAttribute()]
public DateTime ReopenDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenCRSetup Class
ReopenCRSetup Members


Status Property (ReopenCRSetup) | fcSDK Documentation

Status Property (ReopenCRSetup)

The new status for the Change Request. If not set, the default status is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Status As String

[PropertyBitValueAttribute()]
public string Status {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenCRSetup Class
ReopenCRSetup Members


UserName Property (ReopenCRSetup) | fcSDK Documentation

UserName Property (ReopenCRSetup)

The user reopening the CR. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenCRSetup Class
ReopenCRSetup Members


WipBin Property (ReopenCRSetup) | fcSDK Documentation

WipBin Property (ReopenCRSetup)

Wipbin of the user to place the reopened CR. If not set, the UserName's default is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenCRSetup Class
ReopenCRSetup Members


ReplicateCRSetup Class | fcSDK Documentation

ReplicateCRSetup Class

Used by the ReplicateCR method as setup data for invocation.

Syntax

'Declaration

Public Class ReplicateCRSetup

public class ReplicateCRSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Quality.ReplicateCRSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Quality

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ReplicateCRSetup Members
FChoice.Toolkits.Clarify.Quality Namespace
ReplicateCR(ReplicateCRSetup) Method


ReplicateCRSetup Class Members | fcSDK Documentation

ReplicateCRSetup Class Members

The following tables list the members exposed by ReplicateCRSetup.

Public Constructors

 | Name | Description
Public Constructor | ReplicateCRSetup Constructor | Initializes a new instance of the ReplicateCRSetup class.

Public Properties

 | Name | Description
Public Property | CRIDNum | Identifier of the CR being replicated.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | ReplicatedDate | DateTime the CR was replicated. If not set, the current date time is used.
Public Property | UserName | The user replicating the CR. If not set, the session user is used.

Reference

ReplicateCRSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
ReplicateCR(ReplicateCRSetup) Method


ReplicateCRSetup Constructor | fcSDK Documentation

ReplicateCRSetup Constructor

Identifier of the CR being replicated.

Initializes a new instance of the ReplicateCRSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _crIDNum_ As String _
)

[ConstructorIndexAttribute()]
public ReplicateCRSetup(
   string _crIDNum_
)

Parameters

crIDNum

Identifier of the CR being replicated.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReplicateCRSetup Class
ReplicateCRSetup Members


CRIDNum Property (ReplicateCRSetup) | fcSDK Documentation

CRIDNum Property (ReplicateCRSetup)

Identifier of the CR being replicated.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CRIDNum As String

[PropertyBitValueAttribute()]
public string CRIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReplicateCRSetup Class
ReplicateCRSetup Members


GenerateTimeBombs Property (ReplicateCRSetup) | fcSDK Documentation

GenerateTimeBombs Property (ReplicateCRSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReplicateCRSetup Class
ReplicateCRSetup Members


ReplicatedDate Property | fcSDK Documentation

ReplicatedDate Property

DateTime the CR was replicated. If not set, the current date time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ReplicatedDate As Date

[PropertyBitValueAttribute()]
public DateTime ReplicatedDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReplicateCRSetup Class
ReplicateCRSetup Members


UserName Property (ReplicateCRSetup) | fcSDK Documentation

UserName Property (ReplicateCRSetup)

The user replicating the CR. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReplicateCRSetup Class
ReplicateCRSetup Members


UpdateCRSetup Class | fcSDK Documentation

UpdateCRSetup Class

Used by the UpdateCR method as setup data for invocation.

Syntax

'Declaration

Public Class UpdateCRSetup

public class UpdateCRSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Quality.UpdateCRSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Quality

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdateCRSetup Members
FChoice.Toolkits.Clarify.Quality Namespace
UpdateCR(UpdateCRSetup) Method


UpdateCRSetup Class Members | fcSDK Documentation

UpdateCRSetup Class Members

The following tables list the members exposed by UpdateCRSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdateCRSetup Constructor | Initializes a new instance of the UpdateCRSetup class.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CRClass | Element from the 'CR Class' application list. If not set, the default list value is used.
Public Property | CRIDNum | Identifier of the CR being updated.
Public Property | CRType | Element from the 'CR Type' application list. If not set, the default list value is used.
Public Property | FixedIn | Element from the 'Fix Release' application list. If not set, the default list value is used.
Public Property | FoundOnCPU | Element from level 1 of the 'CR_DESC' user-defined list. If not set, the default list value is used.
Public Property | Frequency | Element from the 'CR Reproducible' application list. If not set, the default list value is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | IntroductionPhase | Element from the 'CR Domain' application list. If not set, the default list value is used.
Public Property | Memory | Element from level 3 of the 'CR_DESC' user-defined list. If not set the default list value is used.
Public Property | OperatingSystem | Element from level 2 of the 'CR_DESC' user-defined list. If not set the default list value is used.
Public Property | PartDomain | Part Domain of a Part related to the CR.
Public Property | PartNumber | Part Number of a Part related to the CR.
Public Property | PartRevision | Part Revision of a Part related to the CR.
Public Property | Priority | Element from the 'CR Priority' application list. If not set, the default list value is used.
Public Property | TestClass | Element from the 'CR Class' application list. If not set, the default list value is used.
Public Property | Title | Title of the CR.
Public Property | UpdateDate | DateTime the CR was updated. If not set, the current date time is used.
Public Property | UserName | The user updating the CR. If not set, the session user is used.

Reference

UpdateCRSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
UpdateCR(UpdateCRSetup) Method


UpdateCRSetup Constructor | fcSDK Documentation

UpdateCRSetup Constructor

Identifier of the CR being updated.

Initializes a new instance of the UpdateCRSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _crIDNum_ As String _
)

[ConstructorIndexAttribute()]
public UpdateCRSetup(
   string _crIDNum_
)

Parameters

crIDNum

Identifier of the CR being updated.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCRSetup Class
UpdateCRSetup Members


AdditionalFields Property (UpdateCRSetup) | fcSDK Documentation

AdditionalFields Property (UpdateCRSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCRSetup Class
UpdateCRSetup Members


CRClass Property (UpdateCRSetup) | fcSDK Documentation

CRClass Property (UpdateCRSetup)

Element from the 'CR Class' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CRClass As String

[PropertyBitValueAttribute()]
public string CRClass {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCRSetup Class
UpdateCRSetup Members


CRIDNum Property (UpdateCRSetup) | fcSDK Documentation

CRIDNum Property (UpdateCRSetup)

Identifier of the CR being updated.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CRIDNum As String

[PropertyBitValueAttribute()]
public string CRIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCRSetup Class
UpdateCRSetup Members


CRType Property (UpdateCRSetup) | fcSDK Documentation

CRType Property (UpdateCRSetup)

Element from the 'CR Type' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CRType As String

[PropertyBitValueAttribute()]
public string CRType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCRSetup Class
UpdateCRSetup Members


FixedIn Property (UpdateCRSetup) | fcSDK Documentation

FixedIn Property (UpdateCRSetup)

Element from the 'Fix Release' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FixedIn As String

[PropertyBitValueAttribute()]
public string FixedIn {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCRSetup Class
UpdateCRSetup Members


FoundOnCPU Property (UpdateCRSetup) | fcSDK Documentation

FoundOnCPU Property (UpdateCRSetup)

Element from level 1 of the 'CR_DESC' user-defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FoundOnCPU As String

[PropertyBitValueAttribute()]
public string FoundOnCPU {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCRSetup Class
UpdateCRSetup Members


Frequency Property (UpdateCRSetup) | fcSDK Documentation

Frequency Property (UpdateCRSetup)

Element from the 'CR Reproducible' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Frequency As String

[PropertyBitValueAttribute()]
public string Frequency {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCRSetup Class
UpdateCRSetup Members


GenerateTimeBombs Property (UpdateCRSetup) | fcSDK Documentation

GenerateTimeBombs Property (UpdateCRSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCRSetup Class
UpdateCRSetup Members


IntroductionPhase Property (UpdateCRSetup) | fcSDK Documentation

IntroductionPhase Property (UpdateCRSetup)

Element from the 'CR Domain' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IntroductionPhase As String

[PropertyBitValueAttribute()]
public string IntroductionPhase {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCRSetup Class
UpdateCRSetup Members


Memory Property (UpdateCRSetup) | fcSDK Documentation

Memory Property (UpdateCRSetup)

Element from level 3 of the 'CR_DESC' user-defined list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Memory As String

[PropertyBitValueAttribute()]
public string Memory {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCRSetup Class
UpdateCRSetup Members


OperatingSystem Property (UpdateCRSetup) | fcSDK Documentation

OperatingSystem Property (UpdateCRSetup)

Element from level 2 of the 'CR_DESC' user-defined list. If not set the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property OperatingSystem As String

[PropertyBitValueAttribute()]
public string OperatingSystem {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCRSetup Class
UpdateCRSetup Members


PartDomain Property (UpdateCRSetup) | fcSDK Documentation

PartDomain Property (UpdateCRSetup)

Part Domain of a Part related to the CR.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartDomain As String

[PropertyBitValueAttribute()]
public string PartDomain {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCRSetup Class
UpdateCRSetup Members


PartNumber Property (UpdateCRSetup) | fcSDK Documentation

PartNumber Property (UpdateCRSetup)

Part Number of a Part related to the CR.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartNumber As String

[PropertyBitValueAttribute()]
public string PartNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCRSetup Class
UpdateCRSetup Members


PartRevision Property (UpdateCRSetup) | fcSDK Documentation

PartRevision Property (UpdateCRSetup)

Part Revision of a Part related to the CR.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRevision As String

[PropertyBitValueAttribute()]
public string PartRevision {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCRSetup Class
UpdateCRSetup Members


Priority Property (UpdateCRSetup) | fcSDK Documentation

Priority Property (UpdateCRSetup)

Element from the 'CR Priority' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Priority As String

[PropertyBitValueAttribute()]
public string Priority {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCRSetup Class
UpdateCRSetup Members


TestClass Property (UpdateCRSetup) | fcSDK Documentation

TestClass Property (UpdateCRSetup)

Element from the 'CR Class' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property TestClass As String

[PropertyBitValueAttribute()]
public string TestClass {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCRSetup Class
UpdateCRSetup Members


Title Property (UpdateCRSetup) | fcSDK Documentation

Title Property (UpdateCRSetup)

Title of the CR.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Title As String

[PropertyBitValueAttribute()]
public string Title {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCRSetup Class
UpdateCRSetup Members


UpdateDate Property (UpdateCRSetup) | fcSDK Documentation

UpdateDate Property (UpdateCRSetup)

DateTime the CR was updated. If not set, the current date time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UpdateDate As Date

[PropertyBitValueAttribute()]
public DateTime UpdateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCRSetup Class
UpdateCRSetup Members


UserName Property (UpdateCRSetup) | fcSDK Documentation

UserName Property (UpdateCRSetup)

The user updating the CR. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCRSetup Class
UpdateCRSetup Members


YankCRSetup Class | fcSDK Documentation

YankCRSetup Class

Used by the YankCR method as setup data for invocation.

Syntax

'Declaration

Public Class YankCRSetup

public class YankCRSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Quality.YankCRSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Quality

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

YankCRSetup Members
FChoice.Toolkits.Clarify.Quality Namespace
YankCR(YankCRSetup) Method


YankCRSetup Class Members | fcSDK Documentation

YankCRSetup Class Members

The following tables list the members exposed by YankCRSetup.

Public Constructors

 | Name | Description
Public Constructor | YankCRSetup Constructor | Initializes a new instance of the YankCRSetup class.

Public Properties

 | Name | Description
Public Property | CRIDNum | CR Identifier.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | UserName | The user who has yanked the CR. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the CR. If not set, the UserName's default is used.
Public Property | YankDate | DateTime the CR was yanked. If not set, the current time is used.

Reference

YankCRSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
YankCR(YankCRSetup) Method


YankCRSetup Constructor | fcSDK Documentation

YankCRSetup Constructor

CR Identifier.

Initializes a new instance of the YankCRSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _cridnum_ As String _
)

[ConstructorIndexAttribute()]
public YankCRSetup(
   string _cridnum_
)

Parameters

cridnum

CR Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankCRSetup Class
YankCRSetup Members


CRIDNum Property (YankCRSetup) | fcSDK Documentation

CRIDNum Property (YankCRSetup)

CR Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CRIDNum As String

[PropertyBitValueAttribute()]
public string CRIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankCRSetup Class
YankCRSetup Members


GenerateTimeBombs Property (YankCRSetup) | fcSDK Documentation

GenerateTimeBombs Property (YankCRSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankCRSetup Class
YankCRSetup Members


UserName Property (YankCRSetup) | fcSDK Documentation

UserName Property (YankCRSetup)

The user who has yanked the CR. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankCRSetup Class
YankCRSetup Members


WipBin Property (YankCRSetup) | fcSDK Documentation

WipBin Property (YankCRSetup)

User's WipBin in which to place the CR. If not set, the UserName's default is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankCRSetup Class
YankCRSetup Members


YankDate Property (YankCRSetup) | fcSDK Documentation

YankDate Property (YankCRSetup)

DateTime the CR was yanked. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property YankDate As Date

[PropertyBitValueAttribute()]
public DateTime YankDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankCRSetup Class
YankCRSetup Members


FChoice.Toolkits.Clarify.Sales Namespace | fcSDK Documentation

FChoice.Toolkits.Clarify.Sales Namespace

This toolkit provides functions to allow you to emulate the Clarify ClearSales module.

Functions included allow you to modify aspects of Quotes, Action Items, Opportunities, and Leads.

Classes

 | Class | Description
Class | AcceptActionItemSetup | Used by the AcceptActionItem method as setup data for invocation.
Class | AcceptOpportunitySetup | Used by the AcceptOpportunity method as setup data for invocation.
Class | AcceptQuoteSetup | Used by the AcceptQuote method as setup data for invocation.
Class | AssignActionItemSetup | Used by the AssignActionItem method as setup data for invocation.
Class | AssignLeadSetup | Used by the AssignLead method as setup data for invocation.
Class | AssignOpportunitySetup | Used by the AssignOpportunity method as setup data for invocation.
Class | AssignQuoteSetup | Used by the AssignQuote method as setup data for invocation.
Class | ChangeActionItemConditionSetup | Used by the ChangeActionItemCondition method as setup data for invocation.
Class | ChangeActionItemStatusSetup | Used by the ChangeActionItemStatus method as setup data for invocation.
Class | ChangeOpportunityStageSetup | Used by the ChangeOpportunityStage method as setup data for invocation.
Class | ChangeOpportunityStatusSetup | Used by the ChangeOpportunityStatus method as setup data for invocation.
Class | ChangeQuoteStatusSetup | Used by the ChangeQuoteStatus method as setup data for invocation.
Class | CloseOpportunitySetup | Used by the CloseOpportunity method as setup data for invocation.
Class | CreateActionItemSetup | Used by the CreateActionItem method as setup data for invocation.
Class | CreateLeadSetup | Used by the CreateLead method as setup data for invocation.
Class | CreateOpportunitySetup | Used by the CreateOpportunity method as setup data for invocation.
Class | CreateQuoteLineItemSetup | Used by the CreateQuoteLineItem method as setup data for invocation.
Class | CreateQuoteSetup | Used by the CreateQuote method as setup data for invocation.
Class | DispatchActionItemSetup | Used by the DispatchActionItem method as setup data for invocation.
Class | DispatchOpportunitySetup | Used by the DispatchOpportunity method as setup data for invocation.
Class | DispatchQuoteSetup | Used by the DispatchQuote method as setup data for invocation.
Class | ForwardActionItemSetup | Used by the ForwardActionItem method as setup data for invocation.
Class | ForwardOpportunitySetup | Used by the ForwardOpportunity method as setup data for invocation.
Class | ForwardQuoteSetup | Used by the ForwardQuote method as setup data for invocation.
Class | LogActionItemEmailInSetup |
Class | LogLeadNoteSetup | Used by the LogLeadNote method as setup data for invocation.
Class | LogLeadPhoneSetup | Used by the LogLeadPhone method as setup data for invocation.
Class | MoveActionItemSetup | Used by the MoveActionItem method as setup data for invocation.
Class | MoveOpportunitySetup | Used by the MoveOpportunity method as setup data for invocation.
Class | MoveQuoteSetup | Used by the MoveQuote method as setup data for invocation.
Class | RejectActionItemSetup | Used by the RejectActionItem method as setup data for invocation.
Class | RejectOpportunitySetup | Used by the RejectOpportunity method as setup data for invocation.
Class | RejectQuoteSetup | Used by the RejectQuote method as setup data for invocation.
Class | ReopenOpportunitySetup | Used by the ReopenOpportunity method as setup data for invocation.
Class | SalesToolkit | Provides APIs that allow you to emulate much of the functionality in the Clarify ClearSales module. The SalesToolkit object exposes methods that allow you to modify aspects of Quotes, Action Items, Opportunities, and Leads, and more.
Class | SalesToolkitBase |
Class | UpdateActionItemSetup | Used by the UpdateActionItem method as setup data for invocation.
Class | UpdateLeadSetup | Used by the UpdateLead method as setup data for invocation.
Class | UpdateOpportunitySetup | Used by the UpdateOpportunity method as setup data for invocation.
Class | YankActionItemSetup | Used by the YankActionItem method as setup data for invocation.
Class | YankOpportunitySetup | Used by the YankOpportunity method as setup data for invocation.
Class | YankQuoteSetup | Used by the YankQuote method as setup data for invocation.

Reference

FChoice.Toolkits.Clarify Assembly


AcceptActionItemSetup Class | fcSDK Documentation

AcceptActionItemSetup Class

Used by the AcceptActionItem method as setup data for invocation.

Syntax

'Declaration

Public Class AcceptActionItemSetup

public class AcceptActionItemSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.AcceptActionItemSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

AcceptActionItemSetup Members
FChoice.Toolkits.Clarify.Sales Namespace
AcceptActionItem(AcceptActionItemSetup) Method


AcceptActionItemSetup Class Members | fcSDK Documentation

AcceptActionItemSetup Class Members

The following tables list the members exposed by AcceptActionItemSetup.

Public Constructors

 | Name | Description
Public Constructor | AcceptActionItemSetup Constructor | Initializes a new instance of the AcceptActionItemSetup class.

Public Properties

 | Name | Description
Public Property | AcceptDate | DateTime the ActionItem was accepted. If not set, the current time is used.
Public Property | ActionItemIDNum | ActionItem Identifier.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | UserName | The user who has accepted the ActionItem. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the ActionItem. If not set, the UserName's default is used.

Reference

AcceptActionItemSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
AcceptActionItem(AcceptActionItemSetup) Method


AcceptActionItemSetup Constructor | fcSDK Documentation

AcceptActionItemSetup Constructor

ActionItem Identifier.

Initializes a new instance of the AcceptActionItemSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _actionItemIDNum_ As String _
)

[ConstructorIndexAttribute()]
public AcceptActionItemSetup(
   string _actionItemIDNum_
)

Parameters

actionItemIDNum

ActionItem Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptActionItemSetup Class
AcceptActionItemSetup Members


AcceptDate Property (AcceptActionItemSetup) | fcSDK Documentation

AcceptDate Property (AcceptActionItemSetup)

DateTime the ActionItem was accepted. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AcceptDate As Date

[PropertyBitValueAttribute()]
public DateTime AcceptDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptActionItemSetup Class
AcceptActionItemSetup Members


ActionItemIDNum Property (AcceptActionItemSetup) | fcSDK Documentation

ActionItemIDNum Property (AcceptActionItemSetup)

ActionItem Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ActionItemIDNum As String

[PropertyBitValueAttribute()]
public string ActionItemIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptActionItemSetup Class
AcceptActionItemSetup Members


GenerateTimeBombs Property (AcceptActionItemSetup) | fcSDK Documentation

GenerateTimeBombs Property (AcceptActionItemSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptActionItemSetup Class
AcceptActionItemSetup Members


UserName Property (AcceptActionItemSetup) | fcSDK Documentation

UserName Property (AcceptActionItemSetup)

The user who has accepted the ActionItem. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptActionItemSetup Class
AcceptActionItemSetup Members


WipBin Property (AcceptActionItemSetup) | fcSDK Documentation

WipBin Property (AcceptActionItemSetup)

User's WipBin in which to place the ActionItem. If not set, the UserName's default is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptActionItemSetup Class
AcceptActionItemSetup Members


AcceptOpportunitySetup Class | fcSDK Documentation

AcceptOpportunitySetup Class

Used by the AcceptOpportunity method as setup data for invocation.

Syntax

'Declaration

Public Class AcceptOpportunitySetup

public class AcceptOpportunitySetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.AcceptOpportunitySetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

AcceptOpportunitySetup Members
FChoice.Toolkits.Clarify.Sales Namespace
AcceptOpportunity(AcceptOpportunitySetup) Method


AcceptOpportunitySetup Class Members | fcSDK Documentation

AcceptOpportunitySetup Class Members

The following tables list the members exposed by AcceptOpportunitySetup.

Public Constructors

 | Name | Description
Public Constructor | AcceptOpportunitySetup Constructor | Initializes a new instance of the AcceptOpportunitySetup class.

Public Properties

 | Name | Description
Public Property | AcceptDate | DateTime the Opportunity was accepted. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | OpportunityIDNum | Opportunity Identifier.
Public Property | UserName | The user who has accepted the Opportunity. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Opportunity. If not set, the UserName's default is used.

Reference

AcceptOpportunitySetup Class
FChoice.Toolkits.Clarify.Sales Namespace
AcceptOpportunity(AcceptOpportunitySetup) Method


AcceptOpportunitySetup Constructor | fcSDK Documentation

AcceptOpportunitySetup Constructor

Opportunity Identifier.

Initializes a new instance of the AcceptOpportunitySetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _opportunityIDNum_ As String _
)

[ConstructorIndexAttribute()]
public AcceptOpportunitySetup(
   string _opportunityIDNum_
)

Parameters

opportunityIDNum

Opportunity Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptOpportunitySetup Class
AcceptOpportunitySetup Members


AcceptDate Property (AcceptOpportunitySetup) | fcSDK Documentation

AcceptDate Property (AcceptOpportunitySetup)

DateTime the Opportunity was accepted. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AcceptDate As Date

[PropertyBitValueAttribute()]
public DateTime AcceptDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptOpportunitySetup Class
AcceptOpportunitySetup Members


GenerateTimeBombs Property (AcceptOpportunitySetup) | fcSDK Documentation

GenerateTimeBombs Property (AcceptOpportunitySetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptOpportunitySetup Class
AcceptOpportunitySetup Members


OpportunityIDNum Property (AcceptOpportunitySetup) | fcSDK Documentation

OpportunityIDNum Property (AcceptOpportunitySetup)

Opportunity Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property OpportunityIDNum As String

[PropertyBitValueAttribute()]
public string OpportunityIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptOpportunitySetup Class
AcceptOpportunitySetup Members


UserName Property (AcceptOpportunitySetup) | fcSDK Documentation

UserName Property (AcceptOpportunitySetup)

The user who has accepted the Opportunity. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptOpportunitySetup Class
AcceptOpportunitySetup Members


WipBin Property (AcceptOpportunitySetup) | fcSDK Documentation

WipBin Property (AcceptOpportunitySetup)

User's WipBin in which to place the Opportunity. If not set, the UserName's default is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptOpportunitySetup Class
AcceptOpportunitySetup Members


AcceptQuoteSetup Class | fcSDK Documentation

AcceptQuoteSetup Class

Used by the AcceptQuote method as setup data for invocation.

Syntax

'Declaration

Public Class AcceptQuoteSetup

public class AcceptQuoteSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.AcceptQuoteSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

AcceptQuoteSetup Members
FChoice.Toolkits.Clarify.Sales Namespace
AcceptQuote(AcceptQuoteSetup) Method


AcceptQuoteSetup Class Members | fcSDK Documentation

AcceptQuoteSetup Class Members

The following tables list the members exposed by AcceptQuoteSetup.

Public Constructors

 | Name | Description
Public Constructor | AcceptQuoteSetup Constructor | Initializes a new instance of the AcceptQuoteSetup class.

Public Properties

 | Name | Description
Public Property | AcceptDate | DateTime the Quote was accepted. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | QuoteIDNum | Quote Identifier.
Public Property | UserName | The user who has accepted the Quote. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Quote. If not set, the UserName's default is used.

Reference

AcceptQuoteSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
AcceptQuote(AcceptQuoteSetup) Method


AcceptQuoteSetup Constructor | fcSDK Documentation

AcceptQuoteSetup Constructor

Quote Identifier.

Initializes a new instance of the AcceptQuoteSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _quoteIDNum_ As String _
)

[ConstructorIndexAttribute()]
public AcceptQuoteSetup(
   string _quoteIDNum_
)

Parameters

quoteIDNum

Quote Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptQuoteSetup Class
AcceptQuoteSetup Members


AcceptDate Property (AcceptQuoteSetup) | fcSDK Documentation

AcceptDate Property (AcceptQuoteSetup)

DateTime the Quote was accepted. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AcceptDate As Date

[PropertyBitValueAttribute()]
public DateTime AcceptDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptQuoteSetup Class
AcceptQuoteSetup Members


GenerateTimeBombs Property (AcceptQuoteSetup) | fcSDK Documentation

GenerateTimeBombs Property (AcceptQuoteSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptQuoteSetup Class
AcceptQuoteSetup Members


QuoteIDNum Property (AcceptQuoteSetup) | fcSDK Documentation

QuoteIDNum Property (AcceptQuoteSetup)

Quote Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property QuoteIDNum As String

[PropertyBitValueAttribute()]
public string QuoteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptQuoteSetup Class
AcceptQuoteSetup Members


UserName Property (AcceptQuoteSetup) | fcSDK Documentation

UserName Property (AcceptQuoteSetup)

The user who has accepted the Quote. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptQuoteSetup Class
AcceptQuoteSetup Members


WipBin Property (AcceptQuoteSetup) | fcSDK Documentation

WipBin Property (AcceptQuoteSetup)

User's WipBin in which to place the Quote. If not set, the UserName's default is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptQuoteSetup Class
AcceptQuoteSetup Members


AssignActionItemSetup Class | fcSDK Documentation

AssignActionItemSetup Class

Used by the AssignActionItem method as setup data for invocation.

Syntax

'Declaration

Public Class AssignActionItemSetup

public class AssignActionItemSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.AssignActionItemSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

AssignActionItemSetup Members
FChoice.Toolkits.Clarify.Sales Namespace
AssignActionItem(AssignActionItemSetup) Method


AssignActionItemSetup Class Members | fcSDK Documentation

AssignActionItemSetup Class Members

The following tables list the members exposed by AssignActionItemSetup.

Public Constructors

 | Name | Description
Public Constructor | AssignActionItemSetup Constructor | Initializes a new instance of the AssignActionItemSetup class.

Public Properties

 | Name | Description
Public Property | ActionItemIDNum | ActionItem Identifier.
Public Property | AssignDate | DateTime the ActionItem was assigned. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewUser | The new user to which the ActionItem is to be assigned.
Public Property | UserName | The user who has assigned the ActionItem. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the ActionItem. If not set, the UserName's default is used.

Reference

AssignActionItemSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
AssignActionItem(AssignActionItemSetup) Method


AssignActionItemSetup Constructor | fcSDK Documentation

AssignActionItemSetup Constructor

ActionItem Identifier.

Initializes a new instance of the AssignActionItemSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _actionItemIDNum_ As String _
)

[ConstructorIndexAttribute()]
public AssignActionItemSetup(
   string _actionItemIDNum_
)

Parameters

actionItemIDNum

ActionItem Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignActionItemSetup Class
AssignActionItemSetup Members


ActionItemIDNum Property (AssignActionItemSetup) | fcSDK Documentation

ActionItemIDNum Property (AssignActionItemSetup)

ActionItem Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ActionItemIDNum As String

[PropertyBitValueAttribute()]
public string ActionItemIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignActionItemSetup Class
AssignActionItemSetup Members


AssignDate Property (AssignActionItemSetup) | fcSDK Documentation

AssignDate Property (AssignActionItemSetup)

DateTime the ActionItem was assigned. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AssignDate As Date

[PropertyBitValueAttribute()]
public DateTime AssignDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignActionItemSetup Class
AssignActionItemSetup Members


GenerateTimeBombs Property (AssignActionItemSetup) | fcSDK Documentation

GenerateTimeBombs Property (AssignActionItemSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignActionItemSetup Class
AssignActionItemSetup Members


NewUser Property (AssignActionItemSetup) | fcSDK Documentation

NewUser Property (AssignActionItemSetup)

The new user to which the ActionItem is to be assigned.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewUser As String

[PropertyBitValueAttribute()]
public string NewUser {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignActionItemSetup Class
AssignActionItemSetup Members


UserName Property (AssignActionItemSetup) | fcSDK Documentation

UserName Property (AssignActionItemSetup)

The user who has assigned the ActionItem. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignActionItemSetup Class
AssignActionItemSetup Members


WipBin Property (AssignActionItemSetup) | fcSDK Documentation

WipBin Property (AssignActionItemSetup)

User's WipBin in which to place the ActionItem. If not set, the UserName's default is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignActionItemSetup Class
AssignActionItemSetup Members


AssignLeadSetup Class | fcSDK Documentation

AssignLeadSetup Class

Used by the AssignLead method as setup data for invocation.

Syntax

'Declaration

Public Class AssignLeadSetup

public class AssignLeadSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.AssignLeadSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

AssignLeadSetup Members
FChoice.Toolkits.Clarify.Sales Namespace
AssignLead(AssignLeadSetup) Method


AssignLeadSetup Class Members | fcSDK Documentation

AssignLeadSetup Class Members

The following tables list the members exposed by AssignLeadSetup.

Public Constructors

 | Name | Description
Public Constructor | AssignLeadSetup Constructor | Initializes a new instance of the AssignLeadSetup class.

Public Properties

 | Name | Description
Public Property | AssignDate | DateTime the Lead was assigned. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | LeadObjid | The objid of the lead being assigned.
Public Property | NewOwner | The new user which the lead is assigned to.

Reference

AssignLeadSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
AssignLead(AssignLeadSetup) Method


AssignLeadSetup Constructor | fcSDK Documentation

AssignLeadSetup Constructor

The objid of the lead being assigned.

The new user which the lead is assigned to.

Initializes a new instance of the AssignLeadSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _leadObjid_ As Integer, _
   ByVal _newOwner_ As String _
)

[ConstructorIndexAttribute()]
public AssignLeadSetup(
   int _leadObjid_,
   string _newOwner_
)

Parameters

leadObjid

The objid of the lead being assigned.

newOwner

The new user which the lead is assigned to.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignLeadSetup Class
AssignLeadSetup Members


AssignDate Property (AssignLeadSetup) | fcSDK Documentation

AssignDate Property (AssignLeadSetup)

DateTime the Lead was assigned. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AssignDate As Date

[PropertyBitValueAttribute()]
public DateTime AssignDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignLeadSetup Class
AssignLeadSetup Members


GenerateTimeBombs Property (AssignLeadSetup) | fcSDK Documentation

GenerateTimeBombs Property (AssignLeadSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignLeadSetup Class
AssignLeadSetup Members


LeadObjid Property (AssignLeadSetup) | fcSDK Documentation

LeadObjid Property (AssignLeadSetup)

The objid of the lead being assigned.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LeadObjid As Integer

[PropertyBitValueAttribute()]
public int LeadObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignLeadSetup Class
AssignLeadSetup Members


NewOwner Property | fcSDK Documentation

NewOwner Property

The new user which the lead is assigned to.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewOwner As String

[PropertyBitValueAttribute()]
public string NewOwner {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignLeadSetup Class
AssignLeadSetup Members


AssignOpportunitySetup Class | fcSDK Documentation

AssignOpportunitySetup Class

Used by the AssignOpportunity method as setup data for invocation.

Syntax

'Declaration

Public Class AssignOpportunitySetup

public class AssignOpportunitySetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.AssignOpportunitySetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

AssignOpportunitySetup Members
FChoice.Toolkits.Clarify.Sales Namespace
AssignOpportunity(AssignOpportunitySetup) Method


AssignOpportunitySetup Class Members | fcSDK Documentation

AssignOpportunitySetup Class Members

The following tables list the members exposed by AssignOpportunitySetup.

Public Constructors

 | Name | Description
Public Constructor | AssignOpportunitySetup Constructor | Initializes a new instance of the AssignOpportunitySetup class.

Public Properties

 | Name | Description
Public Property | AssignDate | DateTime the Opportunity was assigned. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewUser | The new user to which the Opportunity is to be assigned.
Public Property | OpportunityIDNum | Opportunity Identifier.
Public Property | UserName | The user who has assigned the Opportunity. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Opportunity. If not set, the UserName's default is used.

Reference

AssignOpportunitySetup Class
FChoice.Toolkits.Clarify.Sales Namespace
AssignOpportunity(AssignOpportunitySetup) Method


AssignOpportunitySetup Constructor | fcSDK Documentation

AssignOpportunitySetup Constructor

Opportunity Identifier.

Initializes a new instance of the AssignOpportunitySetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _opportunityIDNum_ As String _
)

[ConstructorIndexAttribute()]
public AssignOpportunitySetup(
   string _opportunityIDNum_
)

Parameters

opportunityIDNum

Opportunity Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignOpportunitySetup Class
AssignOpportunitySetup Members


AssignDate Property (AssignOpportunitySetup) | fcSDK Documentation

AssignDate Property (AssignOpportunitySetup)

DateTime the Opportunity was assigned. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AssignDate As Date

[PropertyBitValueAttribute()]
public DateTime AssignDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignOpportunitySetup Class
AssignOpportunitySetup Members


GenerateTimeBombs Property (AssignOpportunitySetup) | fcSDK Documentation

GenerateTimeBombs Property (AssignOpportunitySetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignOpportunitySetup Class
AssignOpportunitySetup Members


NewUser Property (AssignOpportunitySetup) | fcSDK Documentation

NewUser Property (AssignOpportunitySetup)

The new user to which the Opportunity is to be assigned.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewUser As String

[PropertyBitValueAttribute()]
public string NewUser {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignOpportunitySetup Class
AssignOpportunitySetup Members


OpportunityIDNum Property (AssignOpportunitySetup) | fcSDK Documentation

OpportunityIDNum Property (AssignOpportunitySetup)

Opportunity Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property OpportunityIDNum As String

[PropertyBitValueAttribute()]
public string OpportunityIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignOpportunitySetup Class
AssignOpportunitySetup Members


UserName Property (AssignOpportunitySetup) | fcSDK Documentation

UserName Property (AssignOpportunitySetup)

The user who has assigned the Opportunity. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignOpportunitySetup Class
AssignOpportunitySetup Members


WipBin Property (AssignOpportunitySetup) | fcSDK Documentation

WipBin Property (AssignOpportunitySetup)

User's WipBin in which to place the Opportunity. If not set, the UserName's default is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignOpportunitySetup Class
AssignOpportunitySetup Members


AssignQuoteSetup Class | fcSDK Documentation

AssignQuoteSetup Class

Used by the AssignQuote method as setup data for invocation.

Syntax

'Declaration

Public Class AssignQuoteSetup

public class AssignQuoteSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.AssignQuoteSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

AssignQuoteSetup Members
FChoice.Toolkits.Clarify.Sales Namespace
AssignQuote(AssignQuoteSetup) Method


AssignQuoteSetup Class Members | fcSDK Documentation

AssignQuoteSetup Class Members

The following tables list the members exposed by AssignQuoteSetup.

Public Constructors

 | Name | Description
Public Constructor | AssignQuoteSetup Constructor | Initializes a new instance of the AssignQuoteSetup class.

Public Properties

 | Name | Description
Public Property | AssignDate | DateTime the Quote was assigned. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewUser | The new user to which the Quote is to be assigned.
Public Property | QuoteIDNum | Quote Identifier.
Public Property | UserName | The user who has assigned the Quote. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Quote. If not set, the UserName's default is used.

Reference

AssignQuoteSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
AssignQuote(AssignQuoteSetup) Method


AssignDate Property (AssignQuoteSetup) | fcSDK Documentation

AssignDate Property (AssignQuoteSetup)

DateTime the Quote was assigned. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AssignDate As Date

[PropertyBitValueAttribute()]
public DateTime AssignDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignQuoteSetup Class
AssignQuoteSetup Members


GenerateTimeBombs Property (AssignQuoteSetup) | fcSDK Documentation

GenerateTimeBombs Property (AssignQuoteSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignQuoteSetup Class
AssignQuoteSetup Members


NewUser Property (AssignQuoteSetup) | fcSDK Documentation

NewUser Property (AssignQuoteSetup)

The new user to which the Quote is to be assigned.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewUser As String

[PropertyBitValueAttribute()]
public string NewUser {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignQuoteSetup Class
AssignQuoteSetup Members


QuoteIDNum Property (AssignQuoteSetup) | fcSDK Documentation

QuoteIDNum Property (AssignQuoteSetup)

Quote Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property QuoteIDNum As String

[PropertyBitValueAttribute()]
public string QuoteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignQuoteSetup Class
AssignQuoteSetup Members


UserName Property (AssignQuoteSetup) | fcSDK Documentation

UserName Property (AssignQuoteSetup)

The user who has assigned the Quote. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignQuoteSetup Class
AssignQuoteSetup Members


WipBin Property (AssignQuoteSetup) | fcSDK Documentation

WipBin Property (AssignQuoteSetup)

User's WipBin in which to place the Quote. If not set, the UserName's default is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignQuoteSetup Class
AssignQuoteSetup Members


ChangeActionItemConditionSetup Class | fcSDK Documentation

ChangeActionItemConditionSetup Class

Used by the ChangeActionItemCondition method as setup data for invocation.

Syntax

'Declaration

Public Class ChangeActionItemConditionSetup

public class ChangeActionItemConditionSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.ChangeActionItemConditionSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ChangeActionItemConditionSetup Members
FChoice.Toolkits.Clarify.Sales Namespace
ChangeActionItemCondition(ChangeActionItemConditionSetup) Method


ChangeActionItemConditionSetup Class Members | fcSDK Documentation

ChangeActionItemConditionSetup Class Members

The following tables list the members exposed by ChangeActionItemConditionSetup.

Public Constructors

 | Name | Description
Public Constructor | ChangeActionItemConditionSetup Constructor | Initializes a new instance of the ChangeActionItemConditionSetup class.

Public Properties

 | Name | Description
Public Property | ActionItemIDNum | Action Item Identifier.
Public Property | ChangeDate | The DateTime the Action Item condition was changed. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewCondition | The new condition for the Action Item
Public Property | NewStatus | Element from the 'Open Action Item' application list. If not set, the default list value is used.
Public Property | UserName | The user who is changing the action item condition. If not set, the Toolkit session user is used.

Reference

ChangeActionItemConditionSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
ChangeActionItemCondition(ChangeActionItemConditionSetup) Method


ChangeActionItemConditionSetup Constructor | fcSDK Documentation

ChangeActionItemConditionSetup Constructor

Action Item Identifier.

The new condition for the Action Item

Initializes a new instance of the ChangeActionItemConditionSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _actionItemIDNum_ As String, _
   ByVal _newcondition_ As String _
)

[ConstructorIndexAttribute()]
public ChangeActionItemConditionSetup(
   string _actionItemIDNum_,
   string _newcondition_
)

Parameters

actionItemIDNum

Action Item Identifier.

newcondition

The new condition for the Action Item

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeActionItemConditionSetup Class
ChangeActionItemConditionSetup Members


ActionItemIDNum Property (ChangeActionItemConditionSetup) | fcSDK Documentation

ActionItemIDNum Property (ChangeActionItemConditionSetup)

Action Item Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ActionItemIDNum As String

[PropertyBitValueAttribute()]
public string ActionItemIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeActionItemConditionSetup Class
ChangeActionItemConditionSetup Members


ChangeDate Property (ChangeActionItemConditionSetup) | fcSDK Documentation

ChangeDate Property (ChangeActionItemConditionSetup)

The DateTime the Action Item condition was changed. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ChangeDate As Date

[PropertyBitValueAttribute()]
public DateTime ChangeDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeActionItemConditionSetup Class
ChangeActionItemConditionSetup Members


GenerateTimeBombs Property (ChangeActionItemConditionSetup) | fcSDK Documentation

GenerateTimeBombs Property (ChangeActionItemConditionSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeActionItemConditionSetup Class
ChangeActionItemConditionSetup Members


NewCondition Property (ChangeActionItemConditionSetup) | fcSDK Documentation

NewCondition Property (ChangeActionItemConditionSetup)

The new condition for the Action Item

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewCondition As String

[PropertyBitValueAttribute()]
public string NewCondition {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeActionItemConditionSetup Class
ChangeActionItemConditionSetup Members


NewStatus Property (ChangeActionItemConditionSetup) | fcSDK Documentation

NewStatus Property (ChangeActionItemConditionSetup)

Element from the 'Open Action Item' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewStatus As String

[PropertyBitValueAttribute()]
public string NewStatus {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeActionItemConditionSetup Class
ChangeActionItemConditionSetup Members


UserName Property (ChangeActionItemConditionSetup) | fcSDK Documentation

UserName Property (ChangeActionItemConditionSetup)

The user who is changing the action item condition. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeActionItemConditionSetup Class
ChangeActionItemConditionSetup Members


ChangeActionItemStatusSetup Class | fcSDK Documentation

ChangeActionItemStatusSetup Class

Used by the ChangeActionItemStatus method as setup data for invocation.

Syntax

'Declaration

Public Class ChangeActionItemStatusSetup

public class ChangeActionItemStatusSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.ChangeActionItemStatusSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ChangeActionItemStatusSetup Members
FChoice.Toolkits.Clarify.Sales Namespace
ChangeActionItemStatus(ChangeActionItemStatusSetup) Method


ChangeActionItemStatusSetup Class Members | fcSDK Documentation

ChangeActionItemStatusSetup Class Members

The following tables list the members exposed by ChangeActionItemStatusSetup.

Public Constructors

 | Name | Description
Public Constructor | ChangeActionItemStatusSetup Constructor | Initializes a new instance of the ChangeActionItemStatusSetup class.

Public Properties

 | Name | Description
Public Property | ActionItemIDNum | Action Item Identifier.
Public Property | ChangeDate | The DateTime the Action Item status was changed. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewStatus | Element from the 'Open Action Item' application list. If not set, the default list value is used.
Public Property | Notes | Notes about the Action Item status change.
Public Property | UserName | The user who is changing the action item status. If not set, the Toolkit session user is used.

Reference

ChangeActionItemStatusSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
ChangeActionItemStatus(ChangeActionItemStatusSetup) Method


ChangeActionItemStatusSetup Constructor | fcSDK Documentation

ChangeActionItemStatusSetup Constructor

Action Item Identifier.

Initializes a new instance of the ChangeActionItemStatusSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _actionItemIDNum_ As String _
)

[ConstructorIndexAttribute()]
public ChangeActionItemStatusSetup(
   string _actionItemIDNum_
)

Parameters

actionItemIDNum

Action Item Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeActionItemStatusSetup Class
ChangeActionItemStatusSetup Members


ActionItemIDNum Property (ChangeActionItemStatusSetup) | fcSDK Documentation

ActionItemIDNum Property (ChangeActionItemStatusSetup)

Action Item Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ActionItemIDNum As String

[PropertyBitValueAttribute()]
public string ActionItemIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeActionItemStatusSetup Class
ChangeActionItemStatusSetup Members


ChangeDate Property (ChangeActionItemStatusSetup) | fcSDK Documentation

ChangeDate Property (ChangeActionItemStatusSetup)

The DateTime the Action Item status was changed. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ChangeDate As Date

[PropertyBitValueAttribute()]
public DateTime ChangeDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeActionItemStatusSetup Class
ChangeActionItemStatusSetup Members


GenerateTimeBombs Property (ChangeActionItemStatusSetup) | fcSDK Documentation

GenerateTimeBombs Property (ChangeActionItemStatusSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeActionItemStatusSetup Class
ChangeActionItemStatusSetup Members


NewStatus Property (ChangeActionItemStatusSetup) | fcSDK Documentation

NewStatus Property (ChangeActionItemStatusSetup)

Element from the 'Open Action Item' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewStatus As String

[PropertyBitValueAttribute()]
public string NewStatus {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeActionItemStatusSetup Class
ChangeActionItemStatusSetup Members


Notes Property (ChangeActionItemStatusSetup) | fcSDK Documentation

Notes Property (ChangeActionItemStatusSetup)

Notes about the Action Item status change.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeActionItemStatusSetup Class
ChangeActionItemStatusSetup Members


UserName Property (ChangeActionItemStatusSetup) | fcSDK Documentation

UserName Property (ChangeActionItemStatusSetup)

The user who is changing the action item status. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeActionItemStatusSetup Class
ChangeActionItemStatusSetup Members


ChangeOpportunityStageSetup Class | fcSDK Documentation

ChangeOpportunityStageSetup Class

Used by the ChangeOpportunityStage method as setup data for invocation.

Syntax

'Declaration

Public Class ChangeOpportunityStageSetup

public class ChangeOpportunityStageSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.ChangeOpportunityStageSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ChangeOpportunityStageSetup Members
FChoice.Toolkits.Clarify.Sales Namespace
ChangeOpportunityStage(ChangeOpportunityStageSetup) Method


ChangeOpportunityStageSetup Class Members | fcSDK Documentation

ChangeOpportunityStageSetup Class Members

The following tables list the members exposed by ChangeOpportunityStageSetup.

Public Constructors

 | Name | Description
Public Constructor | ChangeOpportunityStageSetup Constructor | Initializes a new instance of the ChangeOpportunityStageSetup class.

Public Properties

 | Name | Description
Public Property | ChangeDate | The DateTime the Opportunity stage was changed. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewStatus | Element from the 'Open Opportunity' application list. If not set, the default list value is used.
Public Property | Notes | Notes about the Opportunity stage change.
Public Property | OpportunityIDNum | Opportunity Identifier.
Public Property | Stage | The new sales stage for the Opportunity.
Public Property | UserName | The user who is changing the opportunity stage. If not set, the Toolkit session user is used.

Reference

ChangeOpportunityStageSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
ChangeOpportunityStage(ChangeOpportunityStageSetup) Method


ChangeOpportunityStageSetup Constructor | fcSDK Documentation

ChangeOpportunityStageSetup Constructor

Opportunity Identifier.

The new sales stage for the Opportunity.

Initializes a new instance of the ChangeOpportunityStageSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _opportunityIDNum_ As String, _
   ByVal _stage_ As OpportunityStage _
)

[ConstructorIndexAttribute()]
public ChangeOpportunityStageSetup(
   string _opportunityIDNum_,
   OpportunityStage _stage_
)

Parameters

opportunityIDNum

Opportunity Identifier.

stage

The new sales stage for the Opportunity.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeOpportunityStageSetup Class
ChangeOpportunityStageSetup Members


ChangeDate Property (ChangeOpportunityStageSetup) | fcSDK Documentation

ChangeDate Property (ChangeOpportunityStageSetup)

The DateTime the Opportunity stage was changed. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ChangeDate As Date

[PropertyBitValueAttribute()]
public DateTime ChangeDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeOpportunityStageSetup Class
ChangeOpportunityStageSetup Members


GenerateTimeBombs Property (ChangeOpportunityStageSetup) | fcSDK Documentation

GenerateTimeBombs Property (ChangeOpportunityStageSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeOpportunityStageSetup Class
ChangeOpportunityStageSetup Members


NewStatus Property (ChangeOpportunityStageSetup) | fcSDK Documentation

NewStatus Property (ChangeOpportunityStageSetup)

Element from the 'Open Opportunity' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewStatus As String

[PropertyBitValueAttribute()]
public string NewStatus {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeOpportunityStageSetup Class
ChangeOpportunityStageSetup Members


Notes Property (ChangeOpportunityStageSetup) | fcSDK Documentation

Notes Property (ChangeOpportunityStageSetup)

Notes about the Opportunity stage change.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeOpportunityStageSetup Class
ChangeOpportunityStageSetup Members


OpportunityIDNum Property (ChangeOpportunityStageSetup) | fcSDK Documentation

OpportunityIDNum Property (ChangeOpportunityStageSetup)

Opportunity Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property OpportunityIDNum As String

[PropertyBitValueAttribute()]
public string OpportunityIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeOpportunityStageSetup Class
ChangeOpportunityStageSetup Members


Stage Property | fcSDK Documentation

Stage Property

The new sales stage for the Opportunity.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Stage As OpportunityStage

[PropertyBitValueAttribute()]
public OpportunityStage Stage {get; set;}

Remarks

Must be a valid cycle stage from the database.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeOpportunityStageSetup Class
ChangeOpportunityStageSetup Members


UserName Property (ChangeOpportunityStageSetup) | fcSDK Documentation

UserName Property (ChangeOpportunityStageSetup)

The user who is changing the opportunity stage. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeOpportunityStageSetup Class
ChangeOpportunityStageSetup Members


ChangeOpportunityStatusSetup Class | fcSDK Documentation

ChangeOpportunityStatusSetup Class

Used by the ChangeOpportunityStatus method as setup data for invocation.

Syntax

'Declaration

Public Class ChangeOpportunityStatusSetup

public class ChangeOpportunityStatusSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.ChangeOpportunityStatusSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ChangeOpportunityStatusSetup Members
FChoice.Toolkits.Clarify.Sales Namespace
ChangeOpportunityStatus(ChangeOpportunityStatusSetup) Method


ChangeOpportunityStatusSetup Class Members | fcSDK Documentation

ChangeOpportunityStatusSetup Class Members

The following tables list the members exposed by ChangeOpportunityStatusSetup.

Public Constructors

 | Name | Description
Public Constructor | ChangeOpportunityStatusSetup Constructor | Initializes a new instance of the ChangeOpportunityStatusSetup class.

Public Properties

 | Name | Description
Public Property | ChangeDate | The DateTime the Opportunity status was changed. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewStatus | Element from the 'Open Opportunity' application list. If not set, the default list value is used.
Public Property | Notes | Notes about the Opportunity status change.
Public Property | OpportunityIDNum | Opportunity Identifier.
Public Property | UserName | The user who is changing the opportunity status. If not set, the Toolkit session user is used.

Reference

ChangeOpportunityStatusSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
ChangeOpportunityStatus(ChangeOpportunityStatusSetup) Method


ChangeOpportunityStatusSetup Constructor | fcSDK Documentation

ChangeOpportunityStatusSetup Constructor

Opportunity Identifier.

Initializes a new instance of the ChangeOpportunityStatusSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _opportunityIDNum_ As String _
)

[ConstructorIndexAttribute()]
public ChangeOpportunityStatusSetup(
   string _opportunityIDNum_
)

Parameters

opportunityIDNum

Opportunity Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeOpportunityStatusSetup Class
ChangeOpportunityStatusSetup Members


ChangeDate Property (ChangeOpportunityStatusSetup) | fcSDK Documentation

ChangeDate Property (ChangeOpportunityStatusSetup)

The DateTime the Opportunity status was changed. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ChangeDate As Date

[PropertyBitValueAttribute()]
public DateTime ChangeDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeOpportunityStatusSetup Class
ChangeOpportunityStatusSetup Members


GenerateTimeBombs Property (ChangeOpportunityStatusSetup) | fcSDK Documentation

GenerateTimeBombs Property (ChangeOpportunityStatusSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeOpportunityStatusSetup Class
ChangeOpportunityStatusSetup Members


NewStatus Property (ChangeOpportunityStatusSetup) | fcSDK Documentation

NewStatus Property (ChangeOpportunityStatusSetup)

Element from the 'Open Opportunity' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewStatus As String

[PropertyBitValueAttribute()]
public string NewStatus {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeOpportunityStatusSetup Class
ChangeOpportunityStatusSetup Members


Notes Property (ChangeOpportunityStatusSetup) | fcSDK Documentation

Notes Property (ChangeOpportunityStatusSetup)

Notes about the Opportunity status change.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeOpportunityStatusSetup Class
ChangeOpportunityStatusSetup Members


OpportunityIDNum Property (ChangeOpportunityStatusSetup) | fcSDK Documentation

OpportunityIDNum Property (ChangeOpportunityStatusSetup)

Opportunity Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property OpportunityIDNum As String

[PropertyBitValueAttribute()]
public string OpportunityIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeOpportunityStatusSetup Class
ChangeOpportunityStatusSetup Members


UserName Property (ChangeOpportunityStatusSetup) | fcSDK Documentation

UserName Property (ChangeOpportunityStatusSetup)

The user who is changing the opportunity status. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeOpportunityStatusSetup Class
ChangeOpportunityStatusSetup Members


ChangeQuoteStatusSetup Class | fcSDK Documentation

ChangeQuoteStatusSetup Class

Used by the ChangeQuoteStatus method as setup data for invocation.

Syntax

'Declaration

Public Class ChangeQuoteStatusSetup

public class ChangeQuoteStatusSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.ChangeQuoteStatusSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ChangeQuoteStatusSetup Members
FChoice.Toolkits.Clarify.Sales Namespace
ChangeQuoteStatus(ChangeQuoteStatusSetup) Method


ChangeQuoteStatusSetup Class Members | fcSDK Documentation

ChangeQuoteStatusSetup Class Members

The following tables list the members exposed by ChangeQuoteStatusSetup.

Public Constructors

 | Name | Description
Public Constructor | ChangeQuoteStatusSetup Constructor | Initializes a new instance of the ChangeQuoteStatusSetup class.

Public Properties

 | Name | Description
Public Property | ChangeDate | The DateTime the Quote status was changed. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewStatus | Element from the 'SFA Quote' application list. If not set, the default list value is used.
Public Property | Notes | Notes about the Quote status change.
Public Property | QuoteIDNum | Quote Identifier.
Public Property | UserName | The user who is changing the quote status. If not set, the Toolkit session user is used.

Reference

ChangeQuoteStatusSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
ChangeQuoteStatus(ChangeQuoteStatusSetup) Method


ChangeDate Property (ChangeQuoteStatusSetup) | fcSDK Documentation

ChangeDate Property (ChangeQuoteStatusSetup)

The DateTime the Quote status was changed. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ChangeDate As Date

[PropertyBitValueAttribute()]
public DateTime ChangeDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeQuoteStatusSetup Class
ChangeQuoteStatusSetup Members


GenerateTimeBombs Property (ChangeQuoteStatusSetup) | fcSDK Documentation

GenerateTimeBombs Property (ChangeQuoteStatusSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeQuoteStatusSetup Class
ChangeQuoteStatusSetup Members


NewStatus Property (ChangeQuoteStatusSetup) | fcSDK Documentation

NewStatus Property (ChangeQuoteStatusSetup)

Element from the 'SFA Quote' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewStatus As String

[PropertyBitValueAttribute()]
public string NewStatus {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeQuoteStatusSetup Class
ChangeQuoteStatusSetup Members


Notes Property (ChangeQuoteStatusSetup) | fcSDK Documentation

Notes Property (ChangeQuoteStatusSetup)

Notes about the Quote status change.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeQuoteStatusSetup Class
ChangeQuoteStatusSetup Members


QuoteIDNum Property (ChangeQuoteStatusSetup) | fcSDK Documentation

QuoteIDNum Property (ChangeQuoteStatusSetup)

Quote Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property QuoteIDNum As String

[PropertyBitValueAttribute()]
public string QuoteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeQuoteStatusSetup Class
ChangeQuoteStatusSetup Members


UserName Property (ChangeQuoteStatusSetup) | fcSDK Documentation

UserName Property (ChangeQuoteStatusSetup)

The user who is changing the quote status. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeQuoteStatusSetup Class
ChangeQuoteStatusSetup Members


CloseOpportunitySetup Class | fcSDK Documentation

CloseOpportunitySetup Class

Used by the CloseOpportunity method as setup data for invocation.

Syntax

'Declaration

Public Class CloseOpportunitySetup

public class CloseOpportunitySetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.CloseOpportunitySetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CloseOpportunitySetup Members
FChoice.Toolkits.Clarify.Sales Namespace
CloseOpportunity(CloseOpportunitySetup) Method


CloseOpportunitySetup Class Members | fcSDK Documentation

CloseOpportunitySetup Class Members

The following tables list the members exposed by CloseOpportunitySetup.

Public Constructors

 | Name | Description
Public Constructor | CloseOpportunitySetup Constructor | Initializes a new instance of the CloseOpportunitySetup class.

Public Properties

 | Name | Description
Public Property | CloseDate | The DateTime the Opportunity was closed. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | OpportunityIDNum | Opportunity Identifier.
Public Property | Status | Element from the 'Closed Opportunity' application list. If not set, the default list value is used.
Public Property | UserName | The user who is closing the opportunity. If not set, the Toolkit session user is used.

Reference

CloseOpportunitySetup Class
FChoice.Toolkits.Clarify.Sales Namespace
CloseOpportunity(CloseOpportunitySetup) Method


CloseOpportunitySetup Constructor | fcSDK Documentation

CloseOpportunitySetup Constructor

Opportunity Identifier.

Initializes a new instance of the CloseOpportunitySetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _opportunityIDNum_ As String _
)

[ConstructorIndexAttribute()]
public CloseOpportunitySetup(
   string _opportunityIDNum_
)

Parameters

opportunityIDNum

Opportunity Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CloseOpportunitySetup Class
CloseOpportunitySetup Members


CloseDate Property (CloseOpportunitySetup) | fcSDK Documentation

CloseDate Property (CloseOpportunitySetup)

The DateTime the Opportunity was closed. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CloseDate As Date

[PropertyBitValueAttribute()]
public DateTime CloseDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CloseOpportunitySetup Class
CloseOpportunitySetup Members


GenerateTimeBombs Property (CloseOpportunitySetup) | fcSDK Documentation

GenerateTimeBombs Property (CloseOpportunitySetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CloseOpportunitySetup Class
CloseOpportunitySetup Members


OpportunityIDNum Property (CloseOpportunitySetup) | fcSDK Documentation

OpportunityIDNum Property (CloseOpportunitySetup)

Opportunity Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property OpportunityIDNum As String

[PropertyBitValueAttribute()]
public string OpportunityIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CloseOpportunitySetup Class
CloseOpportunitySetup Members


Status Property (CloseOpportunitySetup) | fcSDK Documentation

Status Property (CloseOpportunitySetup)

Element from the 'Closed Opportunity' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Status As String

[PropertyBitValueAttribute()]
public string Status {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CloseOpportunitySetup Class
CloseOpportunitySetup Members


UserName Property (CloseOpportunitySetup) | fcSDK Documentation

UserName Property (CloseOpportunitySetup)

The user who is closing the opportunity. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CloseOpportunitySetup Class
CloseOpportunitySetup Members


CreateActionItemSetup Class | fcSDK Documentation

CreateActionItemSetup Class

Used by the CreateActionItem method as setup data for invocation.

Syntax

'Declaration

Public Class CreateActionItemSetup

public class CreateActionItemSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.CreateActionItemSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateActionItemSetup Members
FChoice.Toolkits.Clarify.Sales Namespace
CreateActionItem(CreateActionItemSetup) Method


CreateActionItemSetup Class Members | fcSDK Documentation

CreateActionItemSetup Class Members

The following tables list the members exposed by CreateActionItemSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateActionItemSetup Constructor | Initializes a new instance of the CreateActionItemSetup class.

Public Properties

 | Name | Description
Public Property | AccountName | Name of the account to relate to the action item.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CompleteDate | The DateTime the Action Item is to be completed. If not set, it will be set to one week after the start date.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | CreateDate | The DateTime the Action Item was created. If not set, the current time is used.
Public Property | DueDate | The DateTime the Action Item is due. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | LeadFirstName | First name of the lead for the action item.
Public Property | LeadLastName | Last name of the lead for the action item.
Public Property | Notes | Notes about the Action Item creation.
Public Property | OpportunityIDNum | Opportunity Identifier.
Public Property | Priority | Element from the 'Task Priority' application list. If not set, the default list value is used.
Public Property | StartDate | The DateTime the Action Item is to be started. If not set, the current time is used.
Public Property | Status | Element from the 'Open Action Item' application list. If not set, the default list value is used.
Public Property | TaskType | Element from the 'Task Type' application list. If not set, the default list value is used.
Public Property | Title | Title of the Action Item.
Public Property | UserName | The user who is creating the action item. If not set, the Toolkit session user is used.

Reference

CreateActionItemSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
CreateActionItem(CreateActionItemSetup) Method


CreateActionItemSetup Constructor | fcSDK Documentation

CreateActionItemSetup Constructor

Initializes a new instance of the CreateActionItemSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New()

[ConstructorIndexAttribute()]
public CreateActionItemSetup()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateActionItemSetup Class
CreateActionItemSetup Members


AccountName Property (CreateActionItemSetup) | fcSDK Documentation

AccountName Property (CreateActionItemSetup)

Name of the account to relate to the action item.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AccountName As String

[PropertyBitValueAttribute()]
public string AccountName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateActionItemSetup Class
CreateActionItemSetup Members


AdditionalFields Property (CreateActionItemSetup) | fcSDK Documentation

AdditionalFields Property (CreateActionItemSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateActionItemSetup Class
CreateActionItemSetup Members


CompleteDate Property (CreateActionItemSetup) | fcSDK Documentation

CompleteDate Property (CreateActionItemSetup)

The DateTime the Action Item is to be completed. If not set, it will be set to one week after the start date.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CompleteDate As Date

[PropertyBitValueAttribute()]
public DateTime CompleteDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateActionItemSetup Class
CreateActionItemSetup Members


ContactFirstName Property (CreateActionItemSetup) | fcSDK Documentation

ContactFirstName Property (CreateActionItemSetup)

Contact's first name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactFirstName As String

[PropertyBitValueAttribute()]
public string ContactFirstName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateActionItemSetup Class
CreateActionItemSetup Members


ContactLastName Property (CreateActionItemSetup) | fcSDK Documentation

ContactLastName Property (CreateActionItemSetup)

Contact's last name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactLastName As String

[PropertyBitValueAttribute()]
public string ContactLastName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateActionItemSetup Class
CreateActionItemSetup Members


ContactPhone Property (CreateActionItemSetup) | fcSDK Documentation

ContactPhone Property (CreateActionItemSetup)

Contact's phone number.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactPhone As String

[PropertyBitValueAttribute()]
public string ContactPhone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateActionItemSetup Class
CreateActionItemSetup Members


CreateDate Property (CreateActionItemSetup) | fcSDK Documentation

CreateDate Property (CreateActionItemSetup)

The DateTime the Action Item was created. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateActionItemSetup Class
CreateActionItemSetup Members


DueDate Property (CreateActionItemSetup) | fcSDK Documentation

DueDate Property (CreateActionItemSetup)

The DateTime the Action Item is due. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property DueDate As Date

[PropertyBitValueAttribute()]
public DateTime DueDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateActionItemSetup Class
CreateActionItemSetup Members


GenerateTimeBombs Property (CreateActionItemSetup) | fcSDK Documentation

GenerateTimeBombs Property (CreateActionItemSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateActionItemSetup Class
CreateActionItemSetup Members


LeadFirstName Property (CreateActionItemSetup) | fcSDK Documentation

LeadFirstName Property (CreateActionItemSetup)

First name of the lead for the action item.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LeadFirstName As String

[PropertyBitValueAttribute()]
public string LeadFirstName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateActionItemSetup Class
CreateActionItemSetup Members


LeadLastName Property (CreateActionItemSetup) | fcSDK Documentation

LeadLastName Property (CreateActionItemSetup)

Last name of the lead for the action item.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LeadLastName As String

[PropertyBitValueAttribute()]
public string LeadLastName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateActionItemSetup Class
CreateActionItemSetup Members


Notes Property (CreateActionItemSetup) | fcSDK Documentation

Notes Property (CreateActionItemSetup)

Notes about the Action Item creation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateActionItemSetup Class
CreateActionItemSetup Members


OpportunityIDNum Property (CreateActionItemSetup) | fcSDK Documentation

OpportunityIDNum Property (CreateActionItemSetup)

Opportunity Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property OpportunityIDNum As String

[PropertyBitValueAttribute()]
public string OpportunityIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateActionItemSetup Class
CreateActionItemSetup Members


Priority Property (CreateActionItemSetup) | fcSDK Documentation

Priority Property (CreateActionItemSetup)

Element from the 'Task Priority' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Priority As String

[PropertyBitValueAttribute()]
public string Priority {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateActionItemSetup Class
CreateActionItemSetup Members


StartDate Property (CreateActionItemSetup) | fcSDK Documentation

StartDate Property (CreateActionItemSetup)

The DateTime the Action Item is to be started. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property StartDate As Date

[PropertyBitValueAttribute()]
public DateTime StartDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateActionItemSetup Class
CreateActionItemSetup Members


Status Property (CreateActionItemSetup) | fcSDK Documentation

Status Property (CreateActionItemSetup)

Element from the 'Open Action Item' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Status As String

[PropertyBitValueAttribute()]
public string Status {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateActionItemSetup Class
CreateActionItemSetup Members


TaskType Property (CreateActionItemSetup) | fcSDK Documentation

TaskType Property (CreateActionItemSetup)

Element from the 'Task Type' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property TaskType As String

[PropertyBitValueAttribute()]
public string TaskType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateActionItemSetup Class
CreateActionItemSetup Members


Title Property (CreateActionItemSetup) | fcSDK Documentation

Title Property (CreateActionItemSetup)

Title of the Action Item.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Title As String

[PropertyBitValueAttribute()]
public string Title {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateActionItemSetup Class
CreateActionItemSetup Members


UserName Property (CreateActionItemSetup) | fcSDK Documentation

UserName Property (CreateActionItemSetup)

The user who is creating the action item. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateActionItemSetup Class
CreateActionItemSetup Members


CreateLeadSetup Class | fcSDK Documentation

CreateLeadSetup Class

Used by the CreateLead method as setup data for invocation.

Syntax

'Declaration

Public Class CreateLeadSetup

public class CreateLeadSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.CreateLeadSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateLeadSetup Members
FChoice.Toolkits.Clarify.Sales Namespace
CreateLead(CreateLeadSetup) Method


CreateLeadSetup Class Members | fcSDK Documentation

CreateLeadSetup Class Members

The following tables list the members exposed by CreateLeadSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateLeadSetup Constructor | Initializes a new instance of the CreateLeadSetup class.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | Address | Address for the lead.
Public Property | Address2 | Secondary address line for the lead.
Public Property | City | City for the lead.
Public Property | CompanyName | Company name for the lead.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | ContactRole | Element from the 'Contact Role' user list. If not set, the default list value is used.
Public Property | Country | Country for the lead.
Public Property | CreateDate | The DateTime the Lead was created. If not set, the current time is used.
Public Property | Email | Email address for the lead.
Public Property | Fax | Fax number for the lead.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | LeadObjid | The objid of the lead.
Public Property | LeadSource | Name of the lead source.
Public Property | PostalCode | Postal code for the lead.
Public Property | Rating | Element from the 'Lead Status' application list. If not set, the default list value is used.
Public Property | SiteName | The name of the site for the lead.
Public Property | SiteType | The type of the site for the lead.
Public Property | State | State for the lead.
Public Property | TimeZone | Time zone for the lead.
Public Property | Title | Title for the lead.
Public Property | UserName | The user who is creating the lead. If not set, the Toolkit session user is used.

Reference

CreateLeadSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
CreateLead(CreateLeadSetup) Method


CreateLeadSetup Constructor | fcSDK Documentation

CreateLeadSetup Constructor

State for the lead.

Country for the lead.

Time zone for the lead.

The type of the site for the lead.

Name of the lead source.

Initializes a new instance of the CreateLeadSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _state_ As String, _
   ByVal _country_ As String, _
   ByVal _timeZone_ As String, _
   ByVal _siteType_ As LeadSiteType, _
   ByVal _leadSource_ As String _
)

[ConstructorIndexAttribute()]
public CreateLeadSetup(
   string _state_,
   string _country_,
   string _timeZone_,
   LeadSiteType _siteType_,
   string _leadSource_
)

Parameters

state

State for the lead.

country

Country for the lead.

timeZone

Time zone for the lead.

siteType

The type of the site for the lead.

leadSource

Name of the lead source.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateLeadSetup Class
CreateLeadSetup Members


AdditionalFields Property (CreateLeadSetup) | fcSDK Documentation

AdditionalFields Property (CreateLeadSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateLeadSetup Class
CreateLeadSetup Members


Address Property (CreateLeadSetup) | fcSDK Documentation

Address Property (CreateLeadSetup)

Address for the lead.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Address As String

[PropertyBitValueAttribute()]
public string Address {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateLeadSetup Class
CreateLeadSetup Members


Address2 Property (CreateLeadSetup) | fcSDK Documentation

Address2 Property (CreateLeadSetup)

Secondary address line for the lead.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Address2 As String

[PropertyBitValueAttribute()]
public string Address2 {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateLeadSetup Class
CreateLeadSetup Members


City Property (CreateLeadSetup) | fcSDK Documentation

City Property (CreateLeadSetup)

City for the lead.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property City As String

[PropertyBitValueAttribute()]
public string City {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateLeadSetup Class
CreateLeadSetup Members


CompanyName Property (CreateLeadSetup) | fcSDK Documentation

CompanyName Property (CreateLeadSetup)

Company name for the lead.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CompanyName As String

[PropertyBitValueAttribute()]
public string CompanyName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateLeadSetup Class
CreateLeadSetup Members


ContactFirstName Property (CreateLeadSetup) | fcSDK Documentation

ContactFirstName Property (CreateLeadSetup)

Contact's first name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactFirstName As String

[PropertyBitValueAttribute()]
public string ContactFirstName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateLeadSetup Class
CreateLeadSetup Members


ContactLastName Property (CreateLeadSetup) | fcSDK Documentation

ContactLastName Property (CreateLeadSetup)

Contact's last name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactLastName As String

[PropertyBitValueAttribute()]
public string ContactLastName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateLeadSetup Class
CreateLeadSetup Members


ContactPhone Property (CreateLeadSetup) | fcSDK Documentation

ContactPhone Property (CreateLeadSetup)

Contact's phone number.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactPhone As String

[PropertyBitValueAttribute()]
public string ContactPhone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateLeadSetup Class
CreateLeadSetup Members


ContactRole Property (CreateLeadSetup) | fcSDK Documentation

ContactRole Property (CreateLeadSetup)

Element from the 'Contact Role' user list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactRole As String

[PropertyBitValueAttribute()]
public string ContactRole {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateLeadSetup Class
CreateLeadSetup Members


Country Property (CreateLeadSetup) | fcSDK Documentation

Country Property (CreateLeadSetup)

Country for the lead.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Country As String

[PropertyBitValueAttribute()]
public string Country {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateLeadSetup Class
CreateLeadSetup Members


CreateDate Property (CreateLeadSetup) | fcSDK Documentation

CreateDate Property (CreateLeadSetup)

The DateTime the Lead was created. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateLeadSetup Class
CreateLeadSetup Members


Email Property (CreateLeadSetup) | fcSDK Documentation

Email Property (CreateLeadSetup)

Email address for the lead.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Email As String

[PropertyBitValueAttribute()]
public string Email {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateLeadSetup Class
CreateLeadSetup Members


Fax Property (CreateLeadSetup) | fcSDK Documentation

Fax Property (CreateLeadSetup)

Fax number for the lead.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Fax As String

[PropertyBitValueAttribute()]
public string Fax {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateLeadSetup Class
CreateLeadSetup Members


GenerateTimeBombs Property (CreateLeadSetup) | fcSDK Documentation

GenerateTimeBombs Property (CreateLeadSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateLeadSetup Class
CreateLeadSetup Members


LeadObjid Property (CreateLeadSetup) | fcSDK Documentation

LeadObjid Property (CreateLeadSetup)

The objid of the lead.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LeadObjid As Integer

[PropertyBitValueAttribute()]
public int LeadObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateLeadSetup Class
CreateLeadSetup Members


LeadSource Property (CreateLeadSetup) | fcSDK Documentation

LeadSource Property (CreateLeadSetup)

Name of the lead source.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LeadSource As String

[PropertyBitValueAttribute()]
public string LeadSource {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateLeadSetup Class
CreateLeadSetup Members


PostalCode Property (CreateLeadSetup) | fcSDK Documentation

PostalCode Property (CreateLeadSetup)

Postal code for the lead.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PostalCode As String

[PropertyBitValueAttribute()]
public string PostalCode {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateLeadSetup Class
CreateLeadSetup Members


Rating Property (CreateLeadSetup) | fcSDK Documentation

Rating Property (CreateLeadSetup)

Element from the 'Lead Status' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Rating As String

[PropertyBitValueAttribute()]
public string Rating {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateLeadSetup Class
CreateLeadSetup Members


SiteName Property (CreateLeadSetup) | fcSDK Documentation

SiteName Property (CreateLeadSetup)

The name of the site for the lead.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteName As String

[PropertyBitValueAttribute()]
public string SiteName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateLeadSetup Class
CreateLeadSetup Members


SiteType Property (CreateLeadSetup) | fcSDK Documentation

SiteType Property (CreateLeadSetup)

The type of the site for the lead.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteType As LeadSiteType

[PropertyBitValueAttribute()]
public LeadSiteType SiteType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateLeadSetup Class
CreateLeadSetup Members


State Property (CreateLeadSetup) | fcSDK Documentation

State Property (CreateLeadSetup)

State for the lead.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property State As String

[PropertyBitValueAttribute()]
public string State {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateLeadSetup Class
CreateLeadSetup Members


TimeZone Property (CreateLeadSetup) | fcSDK Documentation

TimeZone Property (CreateLeadSetup)

Time zone for the lead.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property TimeZone As String

[PropertyBitValueAttribute()]
public string TimeZone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateLeadSetup Class
CreateLeadSetup Members


Title Property (CreateLeadSetup) | fcSDK Documentation

Title Property (CreateLeadSetup)

Title for the lead.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Title As String

[PropertyBitValueAttribute()]
public string Title {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateLeadSetup Class
CreateLeadSetup Members


UserName Property (CreateLeadSetup) | fcSDK Documentation

UserName Property (CreateLeadSetup)

The user who is creating the lead. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateLeadSetup Class
CreateLeadSetup Members


CreateOpportunitySetup Class | fcSDK Documentation

CreateOpportunitySetup Class

Used by the CreateOpportunity method as setup data for invocation.

Syntax

'Declaration

Public Class CreateOpportunitySetup

public class CreateOpportunitySetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.CreateOpportunitySetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateOpportunitySetup Members
FChoice.Toolkits.Clarify.Sales Namespace
CreateOpportunity(CreateOpportunitySetup) Method


CreateOpportunitySetup Class Members | fcSDK Documentation

CreateOpportunitySetup Class Members

The following tables list the members exposed by CreateOpportunitySetup.

Public Constructors

 | Name | Description
Public Constructor | CreateOpportunitySetup Constructor | Initializes a new instance of the CreateOpportunitySetup class.

Public Properties

 | Name | Description
Public Property | AccountIDNum | Account Identifier.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | Amount | Oppoertunity amount.
Public Property | CloseDate | The DateTime the Opportunity was closed. If not set, the current time is used.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | CreateDate | The DateTime the Opportunity was created. If not set, the current time is used.
Public Property | Currency | Name of the currency for the Opportunity.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | LeadSource | Lead source for the opportunity.
Public Property | OpportunityName | The name of the Opportunity.
Public Property | Probability | Probability of opportunity close.
Public Property | Process | The process for the Opportunity. If not set, the default process is used.
Public Property | SalesStage | Sales stage for the opportunity.
Public Property | Territory | Name of the territory for the Opportunity.
Public Property | UserName | The user who is creating the opportunity. If not set, the Toolkit session user is used.

Reference

CreateOpportunitySetup Class
FChoice.Toolkits.Clarify.Sales Namespace
CreateOpportunity(CreateOpportunitySetup) Method


CreateOpportunitySetup Constructor | fcSDK Documentation

CreateOpportunitySetup Constructor

The name of the Opportunity.

Sales stage for the opportunity.

Probability of opportunity close.

Initializes a new instance of the CreateOpportunitySetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _opportunityName_ As String, _
   ByVal _salesStage_ As String, _
   ByVal _probability_ As Single _
)

[ConstructorIndexAttribute()]
public CreateOpportunitySetup(
   string _opportunityName_,
   string _salesStage_,
   float _probability_
)

Parameters

opportunityName

The name of the Opportunity.

salesStage

Sales stage for the opportunity.

probability

Probability of opportunity close.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateOpportunitySetup Class
CreateOpportunitySetup Members


AccountIDNum Property (CreateOpportunitySetup) | fcSDK Documentation

AccountIDNum Property (CreateOpportunitySetup)

Account Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AccountIDNum As String

[PropertyBitValueAttribute()]
public string AccountIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateOpportunitySetup Class
CreateOpportunitySetup Members


AdditionalFields Property (CreateOpportunitySetup) | fcSDK Documentation

AdditionalFields Property (CreateOpportunitySetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateOpportunitySetup Class
CreateOpportunitySetup Members


Amount Property (CreateOpportunitySetup) | fcSDK Documentation

Amount Property (CreateOpportunitySetup)

Oppoertunity amount.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Amount As Decimal

[PropertyBitValueAttribute()]
public decimal Amount {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateOpportunitySetup Class
CreateOpportunitySetup Members


CloseDate Property (CreateOpportunitySetup) | fcSDK Documentation

CloseDate Property (CreateOpportunitySetup)

The DateTime the Opportunity was closed. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CloseDate As Date

[PropertyBitValueAttribute()]
public DateTime CloseDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateOpportunitySetup Class
CreateOpportunitySetup Members


ContactFirstName Property (CreateOpportunitySetup) | fcSDK Documentation

ContactFirstName Property (CreateOpportunitySetup)

Contact's first name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactFirstName As String

[PropertyBitValueAttribute()]
public string ContactFirstName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateOpportunitySetup Class
CreateOpportunitySetup Members


ContactLastName Property (CreateOpportunitySetup) | fcSDK Documentation

ContactLastName Property (CreateOpportunitySetup)

Contact's last name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactLastName As String

[PropertyBitValueAttribute()]
public string ContactLastName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateOpportunitySetup Class
CreateOpportunitySetup Members


ContactPhone Property (CreateOpportunitySetup) | fcSDK Documentation

ContactPhone Property (CreateOpportunitySetup)

Contact's phone number.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactPhone As String

[PropertyBitValueAttribute()]
public string ContactPhone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateOpportunitySetup Class
CreateOpportunitySetup Members


CreateDate Property (CreateOpportunitySetup) | fcSDK Documentation

CreateDate Property (CreateOpportunitySetup)

The DateTime the Opportunity was created. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateOpportunitySetup Class
CreateOpportunitySetup Members


Currency Property (CreateOpportunitySetup) | fcSDK Documentation

Currency Property (CreateOpportunitySetup)

Name of the currency for the Opportunity.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Currency As String

[PropertyBitValueAttribute()]
public string Currency {get; set;}

Remarks

Must be a valid currency from the database. If not specified, the default currency is used.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateOpportunitySetup Class
CreateOpportunitySetup Members


GenerateTimeBombs Property (CreateOpportunitySetup) | fcSDK Documentation

GenerateTimeBombs Property (CreateOpportunitySetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateOpportunitySetup Class
CreateOpportunitySetup Members


LeadSource Property (CreateOpportunitySetup) | fcSDK Documentation

LeadSource Property (CreateOpportunitySetup)

Lead source for the opportunity.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LeadSource As String

[PropertyBitValueAttribute()]
public string LeadSource {get; set;}

Remarks

Must be a valid lead source from the database. If not specified, the default lead source is used.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateOpportunitySetup Class
CreateOpportunitySetup Members


OpportunityName Property (CreateOpportunitySetup) | fcSDK Documentation

OpportunityName Property (CreateOpportunitySetup)

The name of the Opportunity.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property OpportunityName As String

[PropertyBitValueAttribute()]
public string OpportunityName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateOpportunitySetup Class
CreateOpportunitySetup Members


Probability Property (CreateOpportunitySetup) | fcSDK Documentation

Probability Property (CreateOpportunitySetup)

Probability of opportunity close.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Probability As Single

[PropertyBitValueAttribute()]
public float Probability {get; set;}

Remarks

Must be a numeric value between 0 and 1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateOpportunitySetup Class
CreateOpportunitySetup Members


Process Property (CreateOpportunitySetup) | fcSDK Documentation

Process Property (CreateOpportunitySetup)

The process for the Opportunity. If not set, the default process is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Process As String

[PropertyBitValueAttribute()]
public string Process {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateOpportunitySetup Class
CreateOpportunitySetup Members


SalesStage Property | fcSDK Documentation

SalesStage Property

Sales stage for the opportunity.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SalesStage As String

[PropertyBitValueAttribute()]
public string SalesStage {get; set;}

Remarks

Must be a valid cycle stage from the database.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateOpportunitySetup Class
CreateOpportunitySetup Members


Territory Property (CreateOpportunitySetup) | fcSDK Documentation

Territory Property (CreateOpportunitySetup)

Name of the territory for the Opportunity.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Territory As String

[PropertyBitValueAttribute()]
public string Territory {get; set;}

Remarks

Must be a valid territory from the database. If not specified, the default territory is used.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateOpportunitySetup Class
CreateOpportunitySetup Members


UserName Property (CreateOpportunitySetup) | fcSDK Documentation

UserName Property (CreateOpportunitySetup)

The user who is creating the opportunity. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateOpportunitySetup Class
CreateOpportunitySetup Members


CreateQuoteLineItemSetup Class | fcSDK Documentation

CreateQuoteLineItemSetup Class

Used by the CreateQuoteLineItem method as setup data for invocation.

Syntax

'Declaration

Public Class CreateQuoteLineItemSetup

public class CreateQuoteLineItemSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.CreateQuoteLineItemSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateQuoteLineItemSetup Members
FChoice.Toolkits.Clarify.Sales Namespace
CreateQuoteLineItem(CreateQuoteLineItemSetup) Method


CreateQuoteLineItemSetup Class Members | fcSDK Documentation

CreateQuoteLineItemSetup Class Members

The following tables list the members exposed by CreateQuoteLineItemSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateQuoteLineItemSetup Constructor | Overloaded.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | AutoInstall | Indicator to install the Line Item.
Public Property | Comments | Comments about this line item.
Public Property | ContractIDNum | Quote/Contract Identifier.
Public Property | CreateDate | The DateTime the Quote Line Item was created. If not set, the current time is used.
Public Property | EndDate | The DateTime the Quote Line Item ends. If not set, the current time is used.
Public Property | IsTaxable | Specifies if this line item taxable (true) or not (false).
Public Property | OverridePrice | This is the per-unit price for this line item. If not set, price from the price schedule is used
Public Property | ParentLineItemObjid | The objid of the parent line item.
Public Property | PartDomain | The domain of the part for this line item.
Public Property | PartNumber | The part number for this line item.
Public Property | PartRevision | The revision of the part for this line item.
Public Property | POIDNum | Purchase Order Identifier.
Public Property | PriceSchedule | The name of the Price Schedule for this line item.
Public Property | Quantity | The number of units for this line item.
Public Property | QuotedSiteIDNum | Site Identifier for auto-install process.
Public Property | SerialNumber | For a serialized part, the serial number referenced by this line item.
Public Property | ServicedAtSiteIDNum | Site Identifier for servicing the line item.
Public Property | StartDate | The DateTime the Quote Line Item starts. If not set, the current time is used.
Public Property | UnitsUsed | The number of units used for this line item.
Public Property | UserName | The user who is creating the line item. If not set, the Toolkit session user is used.

Reference

CreateQuoteLineItemSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
CreateQuoteLineItem(CreateQuoteLineItemSetup) Method


CreateQuoteLineItemSetup Constructor | fcSDK Documentation

CreateQuoteLineItemSetup Constructor

Initializes a new instance of the CreateQuoteLineItemSetup class.

Overload List

Overload | Description
CreateQuoteLineItemSetup Constructor(String,String,String,String,Int32,String,Int32) | Initializes a new instance of the CreateQuoteLineItemSetup class. This overload takes a set of required parameters for the API.
CreateQuoteLineItemSetup Constructor(String,String,String,String,String,String,Int32) | Initializes a new instance of the CreateQuoteLineItemSetup class. This overload takes a set of required parameters for the API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteLineItemSetup Class
CreateQuoteLineItemSetup Members


CreateQuoteLineItemSetup Constructor(String,String,String,String,Int32,String,Int32) | fcSDK Documentation

CreateQuoteLineItemSetup Constructor(String,String,String,String,Int32,String,Int32)

Quote/Contract Identifier.

The part number for this line item.

The domain of the part for this line item.

The revision of the part for this line item.

The number of units for this line item.

The name of the Price Schedule for this line item.

The objid of the parent line item.

Initializes a new instance of the CreateQuoteLineItemSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _contractIDNum_ As String, _
   ByVal _partNumber_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _quantity_ As Integer, _
   ByVal _priceSchedule_ As String, _
   ByVal _parentLineItemObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public CreateQuoteLineItemSetup(
   string _contractIDNum_,
   string _partNumber_,
   string _partDomain_,
   string _partRevision_,
   int _quantity_,
   string _priceSchedule_,
   int _parentLineItemObjid_
)

Parameters

contractIDNum

Quote/Contract Identifier.

partNumber

The part number for this line item.

partDomain

The domain of the part for this line item.

partRevision

The revision of the part for this line item.

quantity

The number of units for this line item.

priceSchedule

The name of the Price Schedule for this line item.

parentLineItemObjid

The objid of the parent line item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteLineItemSetup Class
CreateQuoteLineItemSetup Members
Overload List


CreateQuoteLineItemSetup Constructor(String,String,String,String,String,String,Int32) | fcSDK Documentation

CreateQuoteLineItemSetup Constructor(String,String,String,String,String,String,Int32)

Quote/Contract Identifier.

The part number for this line item.

The domain of the part for this line item.

The revision of the part for this line item.

The name of the Price Schedule for this line item.

For a serialized part, the serial number referenced by this line item.

The objid of the parent line item.

Initializes a new instance of the CreateQuoteLineItemSetup class. This overload takes a set of required parameters for the API.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _contractIDNum_ As String, _
   ByVal _partNumber_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _priceSchedule_ As String, _
   ByVal _serialNumber_ As String, _
   ByVal _parentLineItemObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public CreateQuoteLineItemSetup(
   string _contractIDNum_,
   string _partNumber_,
   string _partDomain_,
   string _partRevision_,
   string _priceSchedule_,
   string _serialNumber_,
   int _parentLineItemObjid_
)

Parameters

contractIDNum

Quote/Contract Identifier.

partNumber

The part number for this line item.

partDomain

The domain of the part for this line item.

partRevision

The revision of the part for this line item.

priceSchedule

The name of the Price Schedule for this line item.

serialNumber

For a serialized part, the serial number referenced by this line item.

parentLineItemObjid

The objid of the parent line item.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteLineItemSetup Class
CreateQuoteLineItemSetup Members
Overload List


AdditionalFields Property (CreateQuoteLineItemSetup) | fcSDK Documentation

AdditionalFields Property (CreateQuoteLineItemSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteLineItemSetup Class
CreateQuoteLineItemSetup Members


AutoInstall Property (CreateQuoteLineItemSetup) | fcSDK Documentation

AutoInstall Property (CreateQuoteLineItemSetup)

Indicator to install the Line Item.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AutoInstall As Boolean

[PropertyBitValueAttribute()]
public bool AutoInstall {get; set;}

Remarks

If AutoInstall = True, a QuotedSiteIDNum must be supplied.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteLineItemSetup Class
CreateQuoteLineItemSetup Members


Comments Property (CreateQuoteLineItemSetup) | fcSDK Documentation

Comments Property (CreateQuoteLineItemSetup)

Comments about this line item.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Comments As String

[PropertyBitValueAttribute()]
public string Comments {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteLineItemSetup Class
CreateQuoteLineItemSetup Members


ContractIDNum Property (CreateQuoteLineItemSetup) | fcSDK Documentation

ContractIDNum Property (CreateQuoteLineItemSetup)

Quote/Contract Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContractIDNum As String

[PropertyBitValueAttribute()]
public string ContractIDNum {get; set;}

[equirements

The Quote/Contract must already exist and have at least one valid schedule.

Reference

CreateQuoteLineItemSetup Class
CreateQuoteLineItemSetup Members


CreateDate Property (CreateQuoteLineItemSetup) | fcSDK Documentation

CreateDate Property (CreateQuoteLineItemSetup)

The DateTime the Quote Line Item was created. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteLineItemSetup Class
CreateQuoteLineItemSetup Members


EndDate Property (CreateQuoteLineItemSetup) | fcSDK Documentation

EndDate Property (CreateQuoteLineItemSetup)

The DateTime the Quote Line Item ends. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property EndDate As Date

[PropertyBitValueAttribute()]
public DateTime EndDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteLineItemSetup Class
CreateQuoteLineItemSetup Members


IsTaxable Property (CreateQuoteLineItemSetup) | fcSDK Documentation

IsTaxable Property (CreateQuoteLineItemSetup)

Specifies if this line item taxable (true) or not (false).

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsTaxable As Boolean

[PropertyBitValueAttribute()]
public bool IsTaxable {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteLineItemSetup Class
CreateQuoteLineItemSetup Members


OverridePrice Property (CreateQuoteLineItemSetup) | fcSDK Documentation

OverridePrice Property (CreateQuoteLineItemSetup)

This is the per-unit price for this line item. If not set, price from the price schedule is used

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property OverridePrice As Double

[PropertyBitValueAttribute()]
public double OverridePrice {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteLineItemSetup Class
CreateQuoteLineItemSetup Members


ParentLineItemObjid Property (CreateQuoteLineItemSetup) | fcSDK Documentation

ParentLineItemObjid Property (CreateQuoteLineItemSetup)

The objid of the parent line item.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ParentLineItemObjid As Integer

[PropertyBitValueAttribute()]
public int ParentLineItemObjid {get; set;}

Remarks

If this line item will be a parent line item, set this property to –1. Otherwise, set it to the objid of the parent line item in the field. It will be made a child of the parent line item. If the line item is to be a stand-alone item (the item is not a parent or child), set this value to –2.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteLineItemSetup Class
CreateQuoteLineItemSetup Members


PartDomain Property (CreateQuoteLineItemSetup) | fcSDK Documentation

PartDomain Property (CreateQuoteLineItemSetup)

The domain of the part for this line item.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartDomain As String

[PropertyBitValueAttribute()]
public string PartDomain {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteLineItemSetup Class
CreateQuoteLineItemSetup Members


PartNumber Property (CreateQuoteLineItemSetup) | fcSDK Documentation

PartNumber Property (CreateQuoteLineItemSetup)

The part number for this line item.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartNumber As String

[PropertyBitValueAttribute()]
public string PartNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteLineItemSetup Class
CreateQuoteLineItemSetup Members


PartRevision Property (CreateQuoteLineItemSetup) | fcSDK Documentation

PartRevision Property (CreateQuoteLineItemSetup)

The revision of the part for this line item.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRevision As String

[PropertyBitValueAttribute()]
public string PartRevision {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteLineItemSetup Class
CreateQuoteLineItemSetup Members


POIDNum Property (CreateQuoteLineItemSetup) | fcSDK Documentation

POIDNum Property (CreateQuoteLineItemSetup)

Purchase Order Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property POIDNum As String

[PropertyBitValueAttribute()]
public string POIDNum {get; set;}

Remarks

Must be a valid purchase order number for the specified PriceSchedule.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteLineItemSetup Class
CreateQuoteLineItemSetup Members


PriceSchedule Property (CreateQuoteLineItemSetup) | fcSDK Documentation

PriceSchedule Property (CreateQuoteLineItemSetup)

The name of the Price Schedule for this line item.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PriceSchedule As String

[PropertyBitValueAttribute()]
public string PriceSchedule {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteLineItemSetup Class
CreateQuoteLineItemSetup Members


Quantity Property (CreateQuoteLineItemSetup) | fcSDK Documentation

Quantity Property (CreateQuoteLineItemSetup)

The number of units for this line item.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Quantity As Integer

[PropertyBitValueAttribute()]
public int Quantity {get; set;}

Remarks

The units available is calcularted from this number.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteLineItemSetup Class
CreateQuoteLineItemSetup Members


QuotedSiteIDNum Property (CreateQuoteLineItemSetup) | fcSDK Documentation

QuotedSiteIDNum Property (CreateQuoteLineItemSetup)

Site Identifier for auto-install process.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property QuotedSiteIDNum As String

[PropertyBitValueAttribute()]
public string QuotedSiteIDNum {get; set;}

Remarks

If AutoInstall = True, this must be supplied.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteLineItemSetup Class
CreateQuoteLineItemSetup Members


SerialNumber Property (CreateQuoteLineItemSetup) | fcSDK Documentation

SerialNumber Property (CreateQuoteLineItemSetup)

For a serialized part, the serial number referenced by this line item.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SerialNumber As String

[PropertyBitValueAttribute()]
public string SerialNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteLineItemSetup Class
CreateQuoteLineItemSetup Members


ServicedAtSiteIDNum Property (CreateQuoteLineItemSetup) | fcSDK Documentation

ServicedAtSiteIDNum Property (CreateQuoteLineItemSetup)

Site Identifier for servicing the line item.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ServicedAtSiteIDNum As String

[PropertyBitValueAttribute()]
public string ServicedAtSiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteLineItemSetup Class
CreateQuoteLineItemSetup Members


StartDate Property (CreateQuoteLineItemSetup) | fcSDK Documentation

StartDate Property (CreateQuoteLineItemSetup)

The DateTime the Quote Line Item starts. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property StartDate As Date

[PropertyBitValueAttribute()]
public DateTime StartDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteLineItemSetup Class
CreateQuoteLineItemSetup Members


UnitsUsed Property (CreateQuoteLineItemSetup) | fcSDK Documentation

UnitsUsed Property (CreateQuoteLineItemSetup)

The number of units used for this line item.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UnitsUsed As Double

[PropertyBitValueAttribute()]
public double UnitsUsed {get; set;}

Remarks

If supplied, this is the number of units used. If = 0 (default), then all units are initially available.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteLineItemSetup Class
CreateQuoteLineItemSetup Members


UserName Property (CreateQuoteLineItemSetup) | fcSDK Documentation

UserName Property (CreateQuoteLineItemSetup)

The user who is creating the line item. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteLineItemSetup Class
CreateQuoteLineItemSetup Members


CreateQuoteSetup Class | fcSDK Documentation

CreateQuoteSetup Class

Used by the CreateQuote method as setup data for invocation.

Syntax

'Declaration

Public Class CreateQuoteSetup

public class CreateQuoteSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.CreateQuoteSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateQuoteSetup Members
FChoice.Toolkits.Clarify.Sales Namespace
CreateQuote(CreateQuoteSetup) Method


CreateQuoteSetup Class Members | fcSDK Documentation

CreateQuoteSetup Class Members

The following tables list the members exposed by CreateQuoteSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateQuoteSetup Constructor | Initializes a new instance of the CreateQuoteSetup class.

Public Properties

 | Name | Description
Public Property | AccountIDNum | Account Identifier.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | AdminUserName | Administrator login. If not set, the current user is used.
Public Property | BillToSiteIDNum | Site Identifier for the site being billed in the Quote.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | CreateDate | The DateTime the Quote was created. If not set, the current time is used.
Public Property | Currency | Name of the currency for the Quote.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | OpportunityIDNum | Opportunity Identifier.
Public Property | PriceProgram | Name of the price program for the Quote.
Public Property | Queue | The queue to dispatch the Quote to. If not set, no dispatch takes place.
Public Property | QuoteLengthInDays | The number of days the Quote is valid.
Public Property | QuoteTitle | The title of the Quote.
Public Property | ShipToSiteIDNum | Site Identifier for the site being shipped to in the Quote.
Public Property | SiteIDNum | Site Identifier.
Public Property | Status | Element from the 'SFA Quote' application list. If not set, the default list value is used.
Public Property | UserName | The user who is creating the quote. If not set, the Toolkit session user is used.

Reference

CreateQuoteSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
CreateQuote(CreateQuoteSetup) Method


CreateQuoteSetup Constructor | fcSDK Documentation

CreateQuoteSetup Constructor

The title of the Quote.

Initializes a new instance of the CreateQuoteSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _quoteTitle_ As String _
)

[ConstructorIndexAttribute()]
public CreateQuoteSetup(
   string _quoteTitle_
)

Parameters

quoteTitle

The title of the Quote.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteSetup Class
CreateQuoteSetup Members


AccountIDNum Property (CreateQuoteSetup) | fcSDK Documentation

AccountIDNum Property (CreateQuoteSetup)

Account Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AccountIDNum As String

[PropertyBitValueAttribute()]
public string AccountIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteSetup Class
CreateQuoteSetup Members


AdditionalFields Property (CreateQuoteSetup) | fcSDK Documentation

AdditionalFields Property (CreateQuoteSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Remarks

Additional fields may be set on either the contract or contr_schedule table. To set a field on table_contract, just use the field name. To set a field on the contr_schedule table, place “sched:” before the name of the field. For example, to set the “x_foo” field on the contr_schedule table, use a field name of “sched:x_foo”.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteSetup Class
CreateQuoteSetup Members


AdminUserName Property (CreateQuoteSetup) | fcSDK Documentation

AdminUserName Property (CreateQuoteSetup)

Administrator login. If not set, the current user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AdminUserName As String

[PropertyBitValueAttribute()]
public string AdminUserName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteSetup Class
CreateQuoteSetup Members


BillToSiteIDNum Property (CreateQuoteSetup) | fcSDK Documentation

BillToSiteIDNum Property (CreateQuoteSetup)

Site Identifier for the site being billed in the Quote.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property BillToSiteIDNum As String

[PropertyBitValueAttribute()]
public string BillToSiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteSetup Class
CreateQuoteSetup Members


ContactFirstName Property (CreateQuoteSetup) | fcSDK Documentation

ContactFirstName Property (CreateQuoteSetup)

Contact's first name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactFirstName As String

[PropertyBitValueAttribute()]
public string ContactFirstName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteSetup Class
CreateQuoteSetup Members


ContactLastName Property (CreateQuoteSetup) | fcSDK Documentation

ContactLastName Property (CreateQuoteSetup)

Contact's last name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactLastName As String

[PropertyBitValueAttribute()]
public string ContactLastName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteSetup Class
CreateQuoteSetup Members


ContactPhone Property (CreateQuoteSetup) | fcSDK Documentation

ContactPhone Property (CreateQuoteSetup)

Contact's phone number.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactPhone As String

[PropertyBitValueAttribute()]
public string ContactPhone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteSetup Class
CreateQuoteSetup Members


CreateDate Property (CreateQuoteSetup) | fcSDK Documentation

CreateDate Property (CreateQuoteSetup)

The DateTime the Quote was created. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteSetup Class
CreateQuoteSetup Members


Currency Property (CreateQuoteSetup) | fcSDK Documentation

Currency Property (CreateQuoteSetup)

Name of the currency for the Quote.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Currency As String

[PropertyBitValueAttribute()]
public string Currency {get; set;}

Remarks

Must be a valid currency from the database. If not specified, the default currency is used.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteSetup Class
CreateQuoteSetup Members


GenerateTimeBombs Property (CreateQuoteSetup) | fcSDK Documentation

GenerateTimeBombs Property (CreateQuoteSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteSetup Class
CreateQuoteSetup Members


OpportunityIDNum Property (CreateQuoteSetup) | fcSDK Documentation

OpportunityIDNum Property (CreateQuoteSetup)

Opportunity Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property OpportunityIDNum As String

[PropertyBitValueAttribute()]
public string OpportunityIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteSetup Class
CreateQuoteSetup Members


PriceProgram Property (CreateQuoteSetup) | fcSDK Documentation

PriceProgram Property (CreateQuoteSetup)

Name of the price program for the Quote.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PriceProgram As String

[PropertyBitValueAttribute()]
public string PriceProgram {get; set;}

Remarks

Must be a price program from the database. If not specified, "US Std Price List" is used.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteSetup Class
CreateQuoteSetup Members


Queue Property (CreateQuoteSetup) | fcSDK Documentation

Queue Property (CreateQuoteSetup)

The queue to dispatch the Quote to. If not set, no dispatch takes place.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Queue As String

[PropertyBitValueAttribute()]
public string Queue {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteSetup Class
CreateQuoteSetup Members


QuoteLengthInDays Property | fcSDK Documentation

QuoteLengthInDays Property

The number of days the Quote is valid.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property QuoteLengthInDays As Short

[PropertyBitValueAttribute()]
public short QuoteLengthInDays {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteSetup Class
CreateQuoteSetup Members


QuoteTitle Property | fcSDK Documentation

QuoteTitle Property

The title of the Quote.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property QuoteTitle As String

[PropertyBitValueAttribute()]
public string QuoteTitle {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteSetup Class
CreateQuoteSetup Members


ShipToSiteIDNum Property (CreateQuoteSetup) | fcSDK Documentation

ShipToSiteIDNum Property (CreateQuoteSetup)

Site Identifier for the site being shipped to in the Quote.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ShipToSiteIDNum As String

[PropertyBitValueAttribute()]
public string ShipToSiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteSetup Class
CreateQuoteSetup Members


SiteIDNum Property (CreateQuoteSetup) | fcSDK Documentation

SiteIDNum Property (CreateQuoteSetup)

Site Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteIDNum As String

[PropertyBitValueAttribute()]
public string SiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteSetup Class
CreateQuoteSetup Members


Status Property (CreateQuoteSetup) | fcSDK Documentation

Status Property (CreateQuoteSetup)

Element from the 'SFA Quote' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Status As String

[PropertyBitValueAttribute()]
public string Status {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteSetup Class
CreateQuoteSetup Members


UserName Property (CreateQuoteSetup) | fcSDK Documentation

UserName Property (CreateQuoteSetup)

The user who is creating the quote. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateQuoteSetup Class
CreateQuoteSetup Members


DispatchActionItemSetup Class | fcSDK Documentation

DispatchActionItemSetup Class

Used by the DispatchActionItem method as setup data for invocation.

Syntax

'Declaration

Public Class DispatchActionItemSetup

public class DispatchActionItemSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.DispatchActionItemSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

DispatchActionItemSetup Members
FChoice.Toolkits.Clarify.Sales Namespace
DispatchActionItem(DispatchActionItemSetup) Method


DispatchActionItemSetup Class Members | fcSDK Documentation

DispatchActionItemSetup Class Members

The following tables list the members exposed by DispatchActionItemSetup.

Public Constructors

 | Name | Description
Public Constructor | DispatchActionItemSetup Constructor | Initializes a new instance of the DispatchActionItemSetup class.

Public Properties

 | Name | Description
Public Property | ActionItemIDNum | ActionItem Identifier.
Public Property | DispatchDate | DateTime the ActionItem was dispatched. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Queue | The queue into which the ActionItem is to be dispatched.
Public Property | UserName | The user who has dispatched the ActionItem. If not set, the Toolkit session user is used.

Reference

DispatchActionItemSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
DispatchActionItem(DispatchActionItemSetup) Method


DispatchActionItemSetup Constructor | fcSDK Documentation

DispatchActionItemSetup Constructor

ActionItem Identifier.

The queue into which the ActionItem is to be dispatched.

Initializes a new instance of the DispatchActionItemSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _actionItemIDNum_ As String, _
   ByVal _queue_ As String _
)

[ConstructorIndexAttribute()]
public DispatchActionItemSetup(
   string _actionItemIDNum_,
   string _queue_
)

Parameters

actionItemIDNum

ActionItem Identifier.

queue

The queue into which the ActionItem is to be dispatched.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchActionItemSetup Class
DispatchActionItemSetup Members


ActionItemIDNum Property (DispatchActionItemSetup) | fcSDK Documentation

ActionItemIDNum Property (DispatchActionItemSetup)

ActionItem Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ActionItemIDNum As String

[PropertyBitValueAttribute()]
public string ActionItemIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchActionItemSetup Class
DispatchActionItemSetup Members


DispatchDate Property (DispatchActionItemSetup) | fcSDK Documentation

DispatchDate Property (DispatchActionItemSetup)

DateTime the ActionItem was dispatched. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property DispatchDate As Date

[PropertyBitValueAttribute()]
public DateTime DispatchDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchActionItemSetup Class
DispatchActionItemSetup Members


GenerateTimeBombs Property (DispatchActionItemSetup) | fcSDK Documentation

GenerateTimeBombs Property (DispatchActionItemSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchActionItemSetup Class
DispatchActionItemSetup Members


Queue Property (DispatchActionItemSetup) | fcSDK Documentation

Queue Property (DispatchActionItemSetup)

The queue into which the ActionItem is to be dispatched.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Queue As String

[PropertyBitValueAttribute()]
public string Queue {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchActionItemSetup Class
DispatchActionItemSetup Members


UserName Property (DispatchActionItemSetup) | fcSDK Documentation

UserName Property (DispatchActionItemSetup)

The user who has dispatched the ActionItem. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchActionItemSetup Class
DispatchActionItemSetup Members


DispatchOpportunitySetup Class | fcSDK Documentation

DispatchOpportunitySetup Class

Used by the DispatchOpportunity method as setup data for invocation.

Syntax

'Declaration

Public Class DispatchOpportunitySetup

public class DispatchOpportunitySetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.DispatchOpportunitySetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

DispatchOpportunitySetup Members
FChoice.Toolkits.Clarify.Sales Namespace
DispatchOpportunity(DispatchOpportunitySetup) Method


DispatchOpportunitySetup Class Members | fcSDK Documentation

DispatchOpportunitySetup Class Members

The following tables list the members exposed by DispatchOpportunitySetup.

Public Constructors

 | Name | Description
Public Constructor | DispatchOpportunitySetup Constructor | Initializes a new instance of the DispatchOpportunitySetup class.

Public Properties

 | Name | Description
Public Property | DispatchDate | DateTime the Opportunity was dispatched. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | OpportunityIDNum | Opportunity Identifier.
Public Property | Queue | The queue into which the Opportunity is to be dispatched.
Public Property | UserName | The user who has dispatched the Opportunity. If not set, the Toolkit session user is used.

Reference

DispatchOpportunitySetup Class
FChoice.Toolkits.Clarify.Sales Namespace
DispatchOpportunity(DispatchOpportunitySetup) Method


DispatchOpportunitySetup Constructor | fcSDK Documentation

DispatchOpportunitySetup Constructor

Opportunity Identifier.

The queue into which the Opportunity is to be dispatched.

Initializes a new instance of the DispatchOpportunitySetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _opportunityIDNum_ As String, _
   ByVal _queue_ As String _
)

[ConstructorIndexAttribute()]
public DispatchOpportunitySetup(
   string _opportunityIDNum_,
   string _queue_
)

Parameters

opportunityIDNum

Opportunity Identifier.

queue

The queue into which the Opportunity is to be dispatched.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchOpportunitySetup Class
DispatchOpportunitySetup Members


DispatchDate Property (DispatchOpportunitySetup) | fcSDK Documentation

DispatchDate Property (DispatchOpportunitySetup)

DateTime the Opportunity was dispatched. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property DispatchDate As Date

[PropertyBitValueAttribute()]
public DateTime DispatchDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchOpportunitySetup Class
DispatchOpportunitySetup Members


GenerateTimeBombs Property (DispatchOpportunitySetup) | fcSDK Documentation

GenerateTimeBombs Property (DispatchOpportunitySetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchOpportunitySetup Class
DispatchOpportunitySetup Members


OpportunityIDNum Property (DispatchOpportunitySetup) | fcSDK Documentation

OpportunityIDNum Property (DispatchOpportunitySetup)

Opportunity Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property OpportunityIDNum As String

[PropertyBitValueAttribute()]
public string OpportunityIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchOpportunitySetup Class
DispatchOpportunitySetup Members


Queue Property (DispatchOpportunitySetup) | fcSDK Documentation

Queue Property (DispatchOpportunitySetup)

The queue into which the Opportunity is to be dispatched.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Queue As String

[PropertyBitValueAttribute()]
public string Queue {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchOpportunitySetup Class
DispatchOpportunitySetup Members


UserName Property (DispatchOpportunitySetup) | fcSDK Documentation

UserName Property (DispatchOpportunitySetup)

The user who has dispatched the Opportunity. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchOpportunitySetup Class
DispatchOpportunitySetup Members


DispatchQuoteSetup Class | fcSDK Documentation

DispatchQuoteSetup Class

Used by the DispatchQuote method as setup data for invocation.

Syntax

'Declaration

Public Class DispatchQuoteSetup

public class DispatchQuoteSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.DispatchQuoteSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

DispatchQuoteSetup Members
FChoice.Toolkits.Clarify.Sales Namespace
DispatchQuote(DispatchQuoteSetup) Method


DispatchQuoteSetup Class Members | fcSDK Documentation

DispatchQuoteSetup Class Members

The following tables list the members exposed by DispatchQuoteSetup.

Public Constructors

 | Name | Description
Public Constructor | DispatchQuoteSetup Constructor | Initializes a new instance of the DispatchQuoteSetup class.

Public Properties

 | Name | Description
Public Property | DispatchDate | DateTime the Quote was dispatched. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Queue | The queue into which the Quote is to be dispatched.
Public Property | QuoteIDNum | Quote Identifier.
Public Property | UserName | The user who has dispatched the Quote. If not set, the Toolkit session user is used.

Reference

DispatchQuoteSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
DispatchQuote(DispatchQuoteSetup) Method


ForwardActionItemSetup Class | fcSDK Documentation

ForwardActionItemSetup Class

Used by the ForwardActionItem method as setup data for invocation.

Syntax

'Declaration

Public Class ForwardActionItemSetup

public class ForwardActionItemSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.ForwardActionItemSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ForwardActionItemSetup Members
FChoice.Toolkits.Clarify.Sales Namespace
ForwardActionItem(ForwardActionItemSetup) Method


ForwardActionItemSetup Class Members | fcSDK Documentation

ForwardActionItemSetup Class Members

The following tables list the members exposed by ForwardActionItemSetup.

Public Constructors

 | Name | Description
Public Constructor | ForwardActionItemSetup Constructor | Initializes a new instance of the ForwardActionItemSetup class.

Public Properties

 | Name | Description
Public Property | ActionItemIDNum | ActionItem Identifier.
Public Property | ForwardDate | DateTime the ActionItem was forwarded. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewQueue | The new queue into which the ActionItem is to be forwarded.
Public Property | Notes | The reason the ActionItem was rejected from the queue into which it was dispatched.
Public Property | UserName | The user who has forwarded the ActionItem. If not set, the Toolkit session user is used.

Reference

ForwardActionItemSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
ForwardActionItem(ForwardActionItemSetup) Method


ForwardActionItemSetup Constructor | fcSDK Documentation

ForwardActionItemSetup Constructor

ActionItem Identifier.

The new queue into which the ActionItem is to be forwarded.

Initializes a new instance of the ForwardActionItemSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _actionItemIDNum_ As String, _
   ByVal _newQueue_ As String _
)

[ConstructorIndexAttribute()]
public ForwardActionItemSetup(
   string _actionItemIDNum_,
   string _newQueue_
)

Parameters

actionItemIDNum

ActionItem Identifier.

newQueue

The new queue into which the ActionItem is to be forwarded.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardActionItemSetup Class
ForwardActionItemSetup Members


ActionItemIDNum Property (ForwardActionItemSetup) | fcSDK Documentation

ActionItemIDNum Property (ForwardActionItemSetup)

ActionItem Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ActionItemIDNum As String

[PropertyBitValueAttribute()]
public string ActionItemIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardActionItemSetup Class
ForwardActionItemSetup Members


ForwardDate Property (ForwardActionItemSetup) | fcSDK Documentation

ForwardDate Property (ForwardActionItemSetup)

DateTime the ActionItem was forwarded. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ForwardDate As Date

[PropertyBitValueAttribute()]
public DateTime ForwardDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardActionItemSetup Class
ForwardActionItemSetup Members


GenerateTimeBombs Property (ForwardActionItemSetup) | fcSDK Documentation

GenerateTimeBombs Property (ForwardActionItemSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardActionItemSetup Class
ForwardActionItemSetup Members


NewQueue Property (ForwardActionItemSetup) | fcSDK Documentation

NewQueue Property (ForwardActionItemSetup)

The new queue into which the ActionItem is to be forwarded.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewQueue As String

[PropertyBitValueAttribute()]
public string NewQueue {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardActionItemSetup Class
ForwardActionItemSetup Members


Notes Property (ForwardActionItemSetup) | fcSDK Documentation

Notes Property (ForwardActionItemSetup)

The reason the ActionItem was rejected from the queue into which it was dispatched.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardActionItemSetup Class
ForwardActionItemSetup Members


UserName Property (ForwardActionItemSetup) | fcSDK Documentation

UserName Property (ForwardActionItemSetup)

The user who has forwarded the ActionItem. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardActionItemSetup Class
ForwardActionItemSetup Members


ForwardOpportunitySetup Class | fcSDK Documentation

ForwardOpportunitySetup Class

Used by the ForwardOpportunity method as setup data for invocation.

Syntax

'Declaration

Public Class ForwardOpportunitySetup

public class ForwardOpportunitySetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.ForwardOpportunitySetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ForwardOpportunitySetup Members
FChoice.Toolkits.Clarify.Sales Namespace
ForwardOpportunity(ForwardOpportunitySetup) Method


ForwardOpportunitySetup Class Members | fcSDK Documentation

ForwardOpportunitySetup Class Members

The following tables list the members exposed by ForwardOpportunitySetup.

Public Constructors

 | Name | Description
Public Constructor | ForwardOpportunitySetup Constructor | Initializes a new instance of the ForwardOpportunitySetup class.

Public Properties

 | Name | Description
Public Property | ForwardDate | DateTime the Opportunity was forwarded. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewQueue | The new queue into which the Opportunity is to be forwarded.
Public Property | Notes | The reason the Opportunity was rejected from the queue into which it was dispatched.
Public Property | OpportunityIDNum | Opportunity Identifier.
Public Property | UserName | The user who has forwarded the Opportunity. If not set, the Toolkit session user is used.

Reference

ForwardOpportunitySetup Class
FChoice.Toolkits.Clarify.Sales Namespace
ForwardOpportunity(ForwardOpportunitySetup) Method


ForwardOpportunitySetup Constructor | fcSDK Documentation

ForwardOpportunitySetup Constructor

Opportunity Identifier.

The new queue into which the Opportunity is to be forwarded.

Initializes a new instance of the ForwardOpportunitySetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _opportunityIDNum_ As String, _
   ByVal _newQueue_ As String _
)

[ConstructorIndexAttribute()]
public ForwardOpportunitySetup(
   string _opportunityIDNum_,
   string _newQueue_
)

Parameters

opportunityIDNum

Opportunity Identifier.

newQueue

The new queue into which the Opportunity is to be forwarded.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardOpportunitySetup Class
ForwardOpportunitySetup Members


ForwardDate Property (ForwardOpportunitySetup) | fcSDK Documentation

ForwardDate Property (ForwardOpportunitySetup)

DateTime the Opportunity was forwarded. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ForwardDate As Date

[PropertyBitValueAttribute()]
public DateTime ForwardDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardOpportunitySetup Class
ForwardOpportunitySetup Members


GenerateTimeBombs Property (ForwardOpportunitySetup) | fcSDK Documentation

GenerateTimeBombs Property (ForwardOpportunitySetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardOpportunitySetup Class
ForwardOpportunitySetup Members


NewQueue Property (ForwardOpportunitySetup) | fcSDK Documentation

NewQueue Property (ForwardOpportunitySetup)

The new queue into which the Opportunity is to be forwarded.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewQueue As String

[PropertyBitValueAttribute()]
public string NewQueue {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardOpportunitySetup Class
ForwardOpportunitySetup Members


Notes Property (ForwardOpportunitySetup) | fcSDK Documentation

Notes Property (ForwardOpportunitySetup)

The reason the Opportunity was rejected from the queue into which it was dispatched.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardOpportunitySetup Class
ForwardOpportunitySetup Members


OpportunityIDNum Property (ForwardOpportunitySetup) | fcSDK Documentation

OpportunityIDNum Property (ForwardOpportunitySetup)

Opportunity Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property OpportunityIDNum As String

[PropertyBitValueAttribute()]
public string OpportunityIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardOpportunitySetup Class
ForwardOpportunitySetup Members


UserName Property (ForwardOpportunitySetup) | fcSDK Documentation

UserName Property (ForwardOpportunitySetup)

The user who has forwarded the Opportunity. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardOpportunitySetup Class
ForwardOpportunitySetup Members


ForwardQuoteSetup Class | fcSDK Documentation

ForwardQuoteSetup Class

Used by the ForwardQuote method as setup data for invocation.

Syntax

'Declaration

Public Class ForwardQuoteSetup

public class ForwardQuoteSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.ForwardQuoteSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ForwardQuoteSetup Members
FChoice.Toolkits.Clarify.Sales Namespace
ForwardQuote(ForwardQuoteSetup) Method


ForwardQuoteSetup Class Members | fcSDK Documentation

ForwardQuoteSetup Class Members

The following tables list the members exposed by ForwardQuoteSetup.

Public Constructors

 | Name | Description
Public Constructor | ForwardQuoteSetup Constructor | Initializes a new instance of the ForwardQuoteSetup class.

Public Properties

 | Name | Description
Public Property | ForwardDate | DateTime the Quote was forwarded. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewQueue | The new queue into which the Quote is to be forwarded.
Public Property | Notes | The reason the Quote was rejected from the queue into which it was dispatched.
Public Property | QuoteIDNum | Quote Identifier.
Public Property | UserName | The user who has forwarded the Quote. If not set, the Toolkit session user is used.

Reference

ForwardQuoteSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
ForwardQuote(ForwardQuoteSetup) Method


LogActionItemEmailInSetup Class | fcSDK Documentation

LogActionItemEmailInSetup Class

Syntax

'Declaration

Public Class LogActionItemEmailInSetup
   Inherits FChoice.Toolkits.Clarify.Support.LogEmailInSetup

public class LogActionItemEmailInSetup : FChoice.Toolkits.Clarify.Support.LogEmailInSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.LogEmailInSetup
FChoice.Toolkits.Clarify.Sales.LogActionItemEmailInSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LogActionItemEmailInSetup Members
FChoice.Toolkits.Clarify.Sales Namespace


LogActionItemEmailInSetup Class Members | fcSDK Documentation

LogActionItemEmailInSetup Class Members

The following tables list the members exposed by LogActionItemEmailInSetup.

Public Constructors

 | Name | Description
Public Constructor | LogActionItemEmailInSetup Constructor |

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | CCList | Email addresses of persons CC'd on the email being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | GenerateTimeBombs | Specifies if timebombs should be created. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | IDNumber | Identifier of the Case against which the email in is being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | LogDate | DateTime the log was created. If not set, the current time is used (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | MailLogActionType | Element from the 'Mail Log Action Type' user defined list. If not set, the default list value is used. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | Message | Body of the email being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | Recipient | Email address of the recipients of the email being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | Sender | Email address of the sender of the email being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | Subject | (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | UserName | User who created the log. If not set, the session user is used. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)

Reference

LogActionItemEmailInSetup Class
FChoice.Toolkits.Clarify.Sales Namespace


LogActionItemEmailInSetup Constructor | fcSDK Documentation

LogActionItemEmailInSetup Constructor

Syntax

'Declaration

Public Function New( _
   ByVal _taskId_ As String, _
   ByVal _sender_ As String, _
   ByVal _recipient_ As String, _
   ByVal _message_ As String _
)

public LogActionItemEmailInSetup(
   string _taskId_,
   string _sender_,
   string _recipient_,
   string _message_
)

Parameters

taskId

sender

recipient

message

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogActionItemEmailInSetup Class
LogActionItemEmailInSetup Members


LogLeadNoteSetup Class | fcSDK Documentation

LogLeadNoteSetup Class

Used by the LogLeadNote method as setup data for invocation.

Syntax

'Declaration

Public Class LogLeadNoteSetup

public class LogLeadNoteSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.LogLeadNoteSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LogLeadNoteSetup Members
FChoice.Toolkits.Clarify.Sales Namespace
LogLeadNote(LogLeadNoteSetup) Method


LogLeadNoteSetup Class Members | fcSDK Documentation

LogLeadNoteSetup Class Members

The following tables list the members exposed by LogLeadNoteSetup.

Public Constructors

 | Name | Description
Public Constructor | LogLeadNoteSetup Constructor | Initializes a new instance of the LogLeadNoteSetup class.

Public Properties

 | Name | Description
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | InternalUseOnlyNotes | Notes to be added as Internal Use Only notes on the Lead Note Log.
Public Property | LeadObjid | The objid of the lead for the note log.
Public Property | LogDate | The DateTime the Lead Note was logged. If not set, the current time is used.
Public Property | Notes | Notes about the Lead Note logging.
Public Property | UserName | The user who is logging the note. If not set, the Toolkit session user is used.

Reference

LogLeadNoteSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
LogLeadNote(LogLeadNoteSetup) Method


LogLeadNoteSetup Constructor | fcSDK Documentation

LogLeadNoteSetup Constructor

The objid of the lead for the note log.

Initializes a new instance of the LogLeadNoteSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _leadObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public LogLeadNoteSetup(
   int _leadObjid_
)

Parameters

leadObjid

The objid of the lead for the note log.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogLeadNoteSetup Class
LogLeadNoteSetup Members


GenerateTimeBombs Property (LogLeadNoteSetup) | fcSDK Documentation

GenerateTimeBombs Property (LogLeadNoteSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogLeadNoteSetup Class
LogLeadNoteSetup Members


InternalUseOnlyNotes Property (LogLeadNoteSetup) | fcSDK Documentation

InternalUseOnlyNotes Property (LogLeadNoteSetup)

Notes to be added as Internal Use Only notes on the Lead Note Log.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InternalUseOnlyNotes As String

[PropertyBitValueAttribute()]
public string InternalUseOnlyNotes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogLeadNoteSetup Class
LogLeadNoteSetup Members


LeadObjid Property (LogLeadNoteSetup) | fcSDK Documentation

LeadObjid Property (LogLeadNoteSetup)

The objid of the lead for the note log.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LeadObjid As Integer

[PropertyBitValueAttribute()]
public int LeadObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogLeadNoteSetup Class
LogLeadNoteSetup Members


LogDate Property (LogLeadNoteSetup) | fcSDK Documentation

LogDate Property (LogLeadNoteSetup)

The DateTime the Lead Note was logged. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LogDate As Date

[PropertyBitValueAttribute()]
public DateTime LogDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogLeadNoteSetup Class
LogLeadNoteSetup Members


Notes Property (LogLeadNoteSetup) | fcSDK Documentation

Notes Property (LogLeadNoteSetup)

Notes about the Lead Note logging.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogLeadNoteSetup Class
LogLeadNoteSetup Members


UserName Property (LogLeadNoteSetup) | fcSDK Documentation

UserName Property (LogLeadNoteSetup)

The user who is logging the note. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogLeadNoteSetup Class
LogLeadNoteSetup Members


LogLeadPhoneSetup Class | fcSDK Documentation

LogLeadPhoneSetup Class

Used by the LogLeadPhone method as setup data for invocation.

Syntax

'Declaration

Public Class LogLeadPhoneSetup

public class LogLeadPhoneSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.LogLeadPhoneSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LogLeadPhoneSetup Members
FChoice.Toolkits.Clarify.Sales Namespace
LogLeadPhone(LogLeadPhoneSetup) Method


LogLeadPhoneSetup Class Members | fcSDK Documentation

LogLeadPhoneSetup Class Members

The following tables list the members exposed by LogLeadPhoneSetup.

Public Constructors

 | Name | Description
Public Constructor | LogLeadPhoneSetup Constructor | Initializes a new instance of the LogLeadPhoneSetup class.

Public Properties

 | Name | Description
Public Property | ActionType | Element from the 'Phone Log Action Type' user list. If not set, the default list value is used.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | Duration | Time that the phone call lasted.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | InternalUseOnlyNotes | Notes to be added as Internal Use Only notes on the Lead Phone Log.
Public Property | LeadObjid | The objid of the lead for the phone log.
Public Property | LogDate | The DateTime the Lead Phone Note was logged. If not set, the current time is used.
Public Property | Notes | Notes about the Lead Phone Note logging.
Public Property | UserName | The user who is logging the phone call. If not set, the Toolkit session user is used.

Reference

LogLeadPhoneSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
LogLeadPhone(LogLeadPhoneSetup) Method


LogLeadPhoneSetup Constructor | fcSDK Documentation

LogLeadPhoneSetup Constructor

The objid of the lead for the phone log.

Contact's first name.

Contact's last name.

Contact's phone number.

Time that the phone call lasted.

Initializes a new instance of the LogLeadPhoneSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _leadObjid_ As Integer, _
   ByVal _contactFirstName_ As String, _
   ByVal _contactLastName_ As String, _
   ByVal _contactPhone_ As String, _
   ByVal _duration_ As TimeSpan _
)

[ConstructorIndexAttribute()]
public LogLeadPhoneSetup(
   int _leadObjid_,
   string _contactFirstName_,
   string _contactLastName_,
   string _contactPhone_,
   TimeSpan _duration_
)

Parameters

leadObjid

The objid of the lead for the phone log.

contactFirstName

Contact's first name.

contactLastName

Contact's last name.

contactPhone

Contact's phone number.

duration

Time that the phone call lasted.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogLeadPhoneSetup Class
LogLeadPhoneSetup Members


ActionType Property (LogLeadPhoneSetup) | fcSDK Documentation

ActionType Property (LogLeadPhoneSetup)

Element from the 'Phone Log Action Type' user list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ActionType As String

[PropertyBitValueAttribute()]
public string ActionType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogLeadPhoneSetup Class
LogLeadPhoneSetup Members


ContactFirstName Property (LogLeadPhoneSetup) | fcSDK Documentation

ContactFirstName Property (LogLeadPhoneSetup)

Contact's first name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactFirstName As String

[PropertyBitValueAttribute()]
public string ContactFirstName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogLeadPhoneSetup Class
LogLeadPhoneSetup Members


ContactLastName Property (LogLeadPhoneSetup) | fcSDK Documentation

ContactLastName Property (LogLeadPhoneSetup)

Contact's last name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactLastName As String

[PropertyBitValueAttribute()]
public string ContactLastName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogLeadPhoneSetup Class
LogLeadPhoneSetup Members


ContactPhone Property (LogLeadPhoneSetup) | fcSDK Documentation

ContactPhone Property (LogLeadPhoneSetup)

Contact's phone number.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactPhone As String

[PropertyBitValueAttribute()]
public string ContactPhone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogLeadPhoneSetup Class
LogLeadPhoneSetup Members


Duration Property (LogLeadPhoneSetup) | fcSDK Documentation

Duration Property (LogLeadPhoneSetup)

Time that the phone call lasted.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Duration As TimeSpan

[PropertyBitValueAttribute()]
public TimeSpan Duration {get; set;}

[equirements

Must be specified as a number greater than zero.

Reference

LogLeadPhoneSetup Class
LogLeadPhoneSetup Members


GenerateTimeBombs Property (LogLeadPhoneSetup) | fcSDK Documentation

GenerateTimeBombs Property (LogLeadPhoneSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogLeadPhoneSetup Class
LogLeadPhoneSetup Members


InternalUseOnlyNotes Property (LogLeadPhoneSetup) | fcSDK Documentation

InternalUseOnlyNotes Property (LogLeadPhoneSetup)

Notes to be added as Internal Use Only notes on the Lead Phone Log.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InternalUseOnlyNotes As String

[PropertyBitValueAttribute()]
public string InternalUseOnlyNotes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogLeadPhoneSetup Class
LogLeadPhoneSetup Members


LeadObjid Property (LogLeadPhoneSetup) | fcSDK Documentation

LeadObjid Property (LogLeadPhoneSetup)

The objid of the lead for the phone log.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LeadObjid As Integer

[PropertyBitValueAttribute()]
public int LeadObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogLeadPhoneSetup Class
LogLeadPhoneSetup Members


LogDate Property (LogLeadPhoneSetup) | fcSDK Documentation

LogDate Property (LogLeadPhoneSetup)

The DateTime the Lead Phone Note was logged. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LogDate As Date

[PropertyBitValueAttribute()]
public DateTime LogDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogLeadPhoneSetup Class
LogLeadPhoneSetup Members


Notes Property (LogLeadPhoneSetup) | fcSDK Documentation

Notes Property (LogLeadPhoneSetup)

Notes about the Lead Phone Note logging.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogLeadPhoneSetup Class
LogLeadPhoneSetup Members


UserName Property (LogLeadPhoneSetup) | fcSDK Documentation

UserName Property (LogLeadPhoneSetup)

The user who is logging the phone call. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogLeadPhoneSetup Class
LogLeadPhoneSetup Members


MoveActionItemSetup Class | fcSDK Documentation

MoveActionItemSetup Class

Used by the MoveActionItem method as setup data for invocation.

Syntax

'Declaration

Public Class MoveActionItemSetup

public class MoveActionItemSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.MoveActionItemSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

MoveActionItemSetup Members
FChoice.Toolkits.Clarify.Sales Namespace
MoveActionItem(MoveActionItemSetup) Method


MoveActionItemSetup Class Members | fcSDK Documentation

MoveActionItemSetup Class Members

The following tables list the members exposed by MoveActionItemSetup.

Public Constructors

 | Name | Description
Public Constructor | MoveActionItemSetup Constructor | Initializes a new instance of the MoveActionItemSetup class.

Public Properties

 | Name | Description
Public Property | ActionItemIDNum | ActionItem Identifier.
Public Property | NewWipBin | The new WipBin into which the ActionItem is to be moved.

Reference

MoveActionItemSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
MoveActionItem(MoveActionItemSetup) Method


MoveActionItemSetup Constructor | fcSDK Documentation

MoveActionItemSetup Constructor

ActionItem Identifier.

The new WipBin into which the ActionItem is to be moved.

Initializes a new instance of the MoveActionItemSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _actionItemIDNum_ As String, _
   ByVal _newWipBin_ As String _
)

[ConstructorIndexAttribute()]
public MoveActionItemSetup(
   string _actionItemIDNum_,
   string _newWipBin_
)

Parameters

actionItemIDNum

ActionItem Identifier.

newWipBin

The new WipBin into which the ActionItem is to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveActionItemSetup Class
MoveActionItemSetup Members


ActionItemIDNum Property (MoveActionItemSetup) | fcSDK Documentation

ActionItemIDNum Property (MoveActionItemSetup)

ActionItem Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ActionItemIDNum As String

[PropertyBitValueAttribute()]
public string ActionItemIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveActionItemSetup Class
MoveActionItemSetup Members


NewWipBin Property (MoveActionItemSetup) | fcSDK Documentation

NewWipBin Property (MoveActionItemSetup)

The new WipBin into which the ActionItem is to be moved.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewWipBin As String

[PropertyBitValueAttribute()]
public string NewWipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveActionItemSetup Class
MoveActionItemSetup Members


MoveOpportunitySetup Class | fcSDK Documentation

MoveOpportunitySetup Class

Used by the MoveOpportunity method as setup data for invocation.

Syntax

'Declaration

Public Class MoveOpportunitySetup

public class MoveOpportunitySetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.MoveOpportunitySetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

MoveOpportunitySetup Members
FChoice.Toolkits.Clarify.Sales Namespace
MoveOpportunity(MoveOpportunitySetup) Method


MoveOpportunitySetup Class Members | fcSDK Documentation

MoveOpportunitySetup Class Members

The following tables list the members exposed by MoveOpportunitySetup.

Public Constructors

 | Name | Description
Public Constructor | MoveOpportunitySetup Constructor | Initializes a new instance of the MoveOpportunitySetup class.

Public Properties

 | Name | Description
Public Property | NewWipBin | The new WipBin into which the Opportunity is to be moved.
Public Property | OpportunityIDNum | Opportunity Identifier.

Reference

MoveOpportunitySetup Class
FChoice.Toolkits.Clarify.Sales Namespace
MoveOpportunity(MoveOpportunitySetup) Method


MoveOpportunitySetup Constructor | fcSDK Documentation

MoveOpportunitySetup Constructor

Opportunity Identifier.

The new WipBin into which the Opportunity is to be moved.

Initializes a new instance of the MoveOpportunitySetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _opportunityIDNum_ As String, _
   ByVal _newWipBin_ As String _
)

[ConstructorIndexAttribute()]
public MoveOpportunitySetup(
   string _opportunityIDNum_,
   string _newWipBin_
)

Parameters

opportunityIDNum

Opportunity Identifier.

newWipBin

The new WipBin into which the Opportunity is to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveOpportunitySetup Class
MoveOpportunitySetup Members


NewWipBin Property (MoveOpportunitySetup) | fcSDK Documentation

NewWipBin Property (MoveOpportunitySetup)

The new WipBin into which the Opportunity is to be moved.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewWipBin As String

[PropertyBitValueAttribute()]
public string NewWipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveOpportunitySetup Class
MoveOpportunitySetup Members


OpportunityIDNum Property (MoveOpportunitySetup) | fcSDK Documentation

OpportunityIDNum Property (MoveOpportunitySetup)

Opportunity Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property OpportunityIDNum As String

[PropertyBitValueAttribute()]
public string OpportunityIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveOpportunitySetup Class
MoveOpportunitySetup Members


MoveQuoteSetup Class | fcSDK Documentation

MoveQuoteSetup Class

Used by the MoveQuote method as setup data for invocation.

Syntax

'Declaration

Public Class MoveQuoteSetup

public class MoveQuoteSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.MoveQuoteSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

MoveQuoteSetup Members
FChoice.Toolkits.Clarify.Sales Namespace
MoveQuote(MoveQuoteSetup) Method


MoveQuoteSetup Class Members | fcSDK Documentation

MoveQuoteSetup Class Members

The following tables list the members exposed by MoveQuoteSetup.

Public Constructors

 | Name | Description
Public Constructor | MoveQuoteSetup Constructor | Initializes a new instance of the MoveQuoteSetup class.

Public Properties

 | Name | Description
Public Property | NewWipBin | The new WipBin into which the Quote is to be moved.
Public Property | QuoteIDNum | Quote Identifier.

Reference

MoveQuoteSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
MoveQuote(MoveQuoteSetup) Method


RejectActionItemSetup Class | fcSDK Documentation

RejectActionItemSetup Class

Used by the RejectActionItem method as setup data for invocation.

Syntax

'Declaration

Public Class RejectActionItemSetup

public class RejectActionItemSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.RejectActionItemSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

RejectActionItemSetup Members
FChoice.Toolkits.Clarify.Sales Namespace
RejectActionItem(RejectActionItemSetup) Method


RejectActionItemSetup Class Members | fcSDK Documentation

RejectActionItemSetup Class Members

The following tables list the members exposed by RejectActionItemSetup.

Public Constructors

 | Name | Description
Public Constructor | RejectActionItemSetup Constructor | Initializes a new instance of the RejectActionItemSetup class.

Public Properties

 | Name | Description
Public Property | ActionItemIDNum | ActionItem Identifier.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Notes | The reason the ActionItem was rejected from the queue into which it was dispatched.
Public Property | RejectDate | DateTime the ActionItem was rejected. If not set, the current time is used.
Public Property | UserName | The user who has rejected the ActionItem. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the ActionItem. If not set, the UserName's default is used.

Reference

RejectActionItemSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
RejectActionItem(RejectActionItemSetup) Method


RejectActionItemSetup Constructor | fcSDK Documentation

RejectActionItemSetup Constructor

ActionItem Identifier.

Initializes a new instance of the RejectActionItemSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _actionItemIDNum_ As String _
)

[ConstructorIndexAttribute()]
public RejectActionItemSetup(
   string _actionItemIDNum_
)

Parameters

actionItemIDNum

ActionItem Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectActionItemSetup Class
RejectActionItemSetup Members


ActionItemIDNum Property (RejectActionItemSetup) | fcSDK Documentation

ActionItemIDNum Property (RejectActionItemSetup)

ActionItem Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ActionItemIDNum As String

[PropertyBitValueAttribute()]
public string ActionItemIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectActionItemSetup Class
RejectActionItemSetup Members


GenerateTimeBombs Property (RejectActionItemSetup) | fcSDK Documentation

GenerateTimeBombs Property (RejectActionItemSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectActionItemSetup Class
RejectActionItemSetup Members


Notes Property (RejectActionItemSetup) | fcSDK Documentation

Notes Property (RejectActionItemSetup)

The reason the ActionItem was rejected from the queue into which it was dispatched.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectActionItemSetup Class
RejectActionItemSetup Members


RejectDate Property (RejectActionItemSetup) | fcSDK Documentation

RejectDate Property (RejectActionItemSetup)

DateTime the ActionItem was rejected. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property RejectDate As Date

[PropertyBitValueAttribute()]
public DateTime RejectDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectActionItemSetup Class
RejectActionItemSetup Members


UserName Property (RejectActionItemSetup) | fcSDK Documentation

UserName Property (RejectActionItemSetup)

The user who has rejected the ActionItem. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectActionItemSetup Class
RejectActionItemSetup Members


WipBin Property (RejectActionItemSetup) | fcSDK Documentation

WipBin Property (RejectActionItemSetup)

User's WipBin in which to place the ActionItem. If not set, the UserName's default is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectActionItemSetup Class
RejectActionItemSetup Members


RejectOpportunitySetup Class | fcSDK Documentation

RejectOpportunitySetup Class

Used by the RejectOpportunity method as setup data for invocation.

Syntax

'Declaration

Public Class RejectOpportunitySetup

public class RejectOpportunitySetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.RejectOpportunitySetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

RejectOpportunitySetup Members
FChoice.Toolkits.Clarify.Sales Namespace
RejectOpportunity(RejectOpportunitySetup) Method


RejectOpportunitySetup Class Members | fcSDK Documentation

RejectOpportunitySetup Class Members

The following tables list the members exposed by RejectOpportunitySetup.

Public Constructors

 | Name | Description
Public Constructor | RejectOpportunitySetup Constructor | Initializes a new instance of the RejectOpportunitySetup class.

Public Properties

 | Name | Description
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Notes | The reason the Opportunity was rejected from the queue into which it was dispatched.
Public Property | OpportunityIDNum | Opportunity Identifier.
Public Property | RejectDate | DateTime the Opportunity was rejected. If not set, the current time is used.
Public Property | UserName | The user who has rejected the Opportunity. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Opportunity. If not set, the UserName's default is used.

Reference

RejectOpportunitySetup Class
FChoice.Toolkits.Clarify.Sales Namespace
RejectOpportunity(RejectOpportunitySetup) Method


RejectOpportunitySetup Constructor | fcSDK Documentation

RejectOpportunitySetup Constructor

Opportunity Identifier.

Initializes a new instance of the RejectOpportunitySetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _opportunityIDNum_ As String _
)

[ConstructorIndexAttribute()]
public RejectOpportunitySetup(
   string _opportunityIDNum_
)

Parameters

opportunityIDNum

Opportunity Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectOpportunitySetup Class
RejectOpportunitySetup Members


GenerateTimeBombs Property (RejectOpportunitySetup) | fcSDK Documentation

GenerateTimeBombs Property (RejectOpportunitySetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectOpportunitySetup Class
RejectOpportunitySetup Members


Notes Property (RejectOpportunitySetup) | fcSDK Documentation

Notes Property (RejectOpportunitySetup)

The reason the Opportunity was rejected from the queue into which it was dispatched.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectOpportunitySetup Class
RejectOpportunitySetup Members


OpportunityIDNum Property (RejectOpportunitySetup) | fcSDK Documentation

OpportunityIDNum Property (RejectOpportunitySetup)

Opportunity Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property OpportunityIDNum As String

[PropertyBitValueAttribute()]
public string OpportunityIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectOpportunitySetup Class
RejectOpportunitySetup Members


RejectDate Property (RejectOpportunitySetup) | fcSDK Documentation

RejectDate Property (RejectOpportunitySetup)

DateTime the Opportunity was rejected. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property RejectDate As Date

[PropertyBitValueAttribute()]
public DateTime RejectDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectOpportunitySetup Class
RejectOpportunitySetup Members


UserName Property (RejectOpportunitySetup) | fcSDK Documentation

UserName Property (RejectOpportunitySetup)

The user who has rejected the Opportunity. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectOpportunitySetup Class
RejectOpportunitySetup Members


WipBin Property (RejectOpportunitySetup) | fcSDK Documentation

WipBin Property (RejectOpportunitySetup)

User's WipBin in which to place the Opportunity. If not set, the UserName's default is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectOpportunitySetup Class
RejectOpportunitySetup Members


RejectQuoteSetup Class | fcSDK Documentation

RejectQuoteSetup Class

Used by the RejectQuote method as setup data for invocation.

Syntax

'Declaration

Public Class RejectQuoteSetup

public class RejectQuoteSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.RejectQuoteSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

RejectQuoteSetup Members
FChoice.Toolkits.Clarify.Sales Namespace
RejectQuote(RejectQuoteSetup) Method


RejectQuoteSetup Class Members | fcSDK Documentation

RejectQuoteSetup Class Members

The following tables list the members exposed by RejectQuoteSetup.

Public Constructors

 | Name | Description
Public Constructor | RejectQuoteSetup Constructor | Initializes a new instance of the RejectQuoteSetup class.

Public Properties

 | Name | Description
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Notes | The reason the Quote was rejected from the queue into which it was dispatched.
Public Property | QuoteIDNum | Quote Identifier.
Public Property | RejectDate | DateTime the Quote was rejected. If not set, the current time is used.
Public Property | UserName | The user who has rejected the Quote. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Quote. If not set, the UserName's default is used.

Reference

RejectQuoteSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
RejectQuote(RejectQuoteSetup) Method


ReopenOpportunitySetup Class | fcSDK Documentation

ReopenOpportunitySetup Class

Used by the ReopenOpportunity method as setup data for invocation.

Syntax

'Declaration

Public Class ReopenOpportunitySetup

public class ReopenOpportunitySetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.ReopenOpportunitySetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ReopenOpportunitySetup Members
FChoice.Toolkits.Clarify.Sales Namespace
ReopenOpportunity(ReopenOpportunitySetup) Method


ReopenOpportunitySetup Class Members | fcSDK Documentation

ReopenOpportunitySetup Class Members

The following tables list the members exposed by ReopenOpportunitySetup.

Public Constructors

 | Name | Description
Public Constructor | ReopenOpportunitySetup Constructor | Initializes a new instance of the ReopenOpportunitySetup class.

Public Properties

 | Name | Description
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | OpportunityIDNum | Opportunity Identifier.
Public Property | ReopenDate | The DateTime the Opportunity was reopened. If not set, the current time is used.
Public Property | Status | Element from the 'Open Action Item' application list. If not set, the default list value is used.
Public Property | UserName | The user who is reopening the opportunity. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin to place the Opportunity in. It not set the current user's default is used.

Reference

ReopenOpportunitySetup Class
FChoice.Toolkits.Clarify.Sales Namespace
ReopenOpportunity(ReopenOpportunitySetup) Method


ReopenOpportunitySetup Constructor | fcSDK Documentation

ReopenOpportunitySetup Constructor

Opportunity Identifier.

Initializes a new instance of the ReopenOpportunitySetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _opportunityIDNum_ As String _
)

[ConstructorIndexAttribute()]
public ReopenOpportunitySetup(
   string _opportunityIDNum_
)

Parameters

opportunityIDNum

Opportunity Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenOpportunitySetup Class
ReopenOpportunitySetup Members


GenerateTimeBombs Property (ReopenOpportunitySetup) | fcSDK Documentation

GenerateTimeBombs Property (ReopenOpportunitySetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenOpportunitySetup Class
ReopenOpportunitySetup Members


OpportunityIDNum Property (ReopenOpportunitySetup) | fcSDK Documentation

OpportunityIDNum Property (ReopenOpportunitySetup)

Opportunity Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property OpportunityIDNum As String

[PropertyBitValueAttribute()]
public string OpportunityIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenOpportunitySetup Class
ReopenOpportunitySetup Members


ReopenDate Property (ReopenOpportunitySetup) | fcSDK Documentation

ReopenDate Property (ReopenOpportunitySetup)

The DateTime the Opportunity was reopened. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ReopenDate As Date

[PropertyBitValueAttribute()]
public DateTime ReopenDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenOpportunitySetup Class
ReopenOpportunitySetup Members


Status Property (ReopenOpportunitySetup) | fcSDK Documentation

Status Property (ReopenOpportunitySetup)

Element from the 'Open Action Item' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Status As String

[PropertyBitValueAttribute()]
public string Status {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenOpportunitySetup Class
ReopenOpportunitySetup Members


UserName Property (ReopenOpportunitySetup) | fcSDK Documentation

UserName Property (ReopenOpportunitySetup)

The user who is reopening the opportunity. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenOpportunitySetup Class
ReopenOpportunitySetup Members


WipBin Property (ReopenOpportunitySetup) | fcSDK Documentation

WipBin Property (ReopenOpportunitySetup)

User's WipBin to place the Opportunity in. It not set the current user's default is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenOpportunitySetup Class
ReopenOpportunitySetup Members


SalesToolkit Class | fcSDK Documentation

SalesToolkit Class

Provides APIs that allow you to emulate much of the functionality in the Clarify ClearSales module. The SalesToolkit object exposes methods that allow you to modify aspects of Quotes, Action Items, Opportunities, and Leads, and more.

Syntax

'Declaration

Public Class SalesToolkit
   Inherits SalesToolkitBase

public class SalesToolkit : SalesToolkitBase

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.ToolkitBase
FChoice.Toolkits.Clarify.Sales.SalesToolkitBase
FChoice.Toolkits.Clarify.Sales.SalesToolkit

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

SalesToolkit Members
FChoice.Toolkits.Clarify.Sales Namespace


SalesToolkit Class Members | fcSDK Documentation

SalesToolkit Class Members

The following tables list the members exposed by SalesToolkit.

Public Constructors

 | Name | Description
Public Constructor | SalesToolkit Constructor | Overloaded.

Public Properties

 | Name | Description
Public Property | ApplicationClock |
Public Property | ImpersonatorUsername | (Inherited from FChoice.Toolkits.Clarify.Sales.SalesToolkitBase)

Public Methods

 | Name | Description
Public Method | AcceptActionItem | Overloaded. Accept the specified ActionItem from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.
Public Method | AcceptOpportunity | Overloaded. Accept the specified Opportunity from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.
Public Method | AcceptQuote | Overloaded. Accept the specified Quote from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.
Public Method | AssignActionItem | Overloaded. Assign the ActionItem to a new user. This overload takes a set of required parameters for the API.
Public Method | AssignLead | Overloaded. Assign the Lead to a new user. This overload takes a set of required parameters for the API.
Public Method | AssignOpportunity | Overloaded. Assign the Opportunity to a new user. This overload takes a set of required parameters for the API.
Public Method | AssignQuote | Overloaded. Assign the Quote to a new user. This overload takes a set of required parameters for the API.
Public Method | ChangeActionItemCondition | Overloaded. Used to change the condition and (optionally) a status for the specified Action Item. This overload takes a set of required parameters for the API.
Public Method | ChangeActionItemStatus | Overloaded. Cause the specified Action Item to have its status changed. This overload takes a set of required parameters for the API.
Public Method | ChangeOpportunityStage | Overloaded. (Inherited from FChoice.Toolkits.Clarify.Sales.SalesToolkitBase)
Public Method | ChangeOpportunityStatus | Overloaded. Cause the specified Opportunity to have its status changed. This overload takes a set of required parameters for the API.
Public Method | ChangeQuoteStatus | Overloaded. Cause the specified Quote to have its status changed. This overload takes a set of required parameters for the API.
Public Method | CloseOpportunity | Overloaded. Closes the Opportunity. This overload takes a set of required parameters for the API.
Public Method | CreateActionItem | Overloaded. Creates a new Action Item. This overload takes a set of required parameters for the API.
Public Method | CreateLead | Overloaded. Used to create a new Lead. This overload takes a set of required parameters for the API.
Public Method | CreateOpportunity | Overloaded. Used to create a new Opportunity. This overload takes a set of required parameters for the API.
Public Method | CreateQuote | Overloaded. Used to create a new Quote. This overload takes a set of required parameters for the API.
Public Method | CreateQuoteLineItem | Overloaded. Used to create a Quote/Contract line item. This overload takes a set of required parameters for the API.
Public Method | DispatchActionItem | Overloaded. Dispatch the ActionItem to the specified queue. This overload takes a set of required parameters for the API.
Public Method | DispatchOpportunity | Overloaded. Dispatch the Opportunity to the specified queue. This overload takes a set of required parameters for the API.
Public Method | DispatchQuote | Overloaded. Dispatch the Quote to the specified queue. This overload takes a set of required parameters for the API.
Public Method | ForwardActionItem | Overloaded. Reject-forward the ActionItem from one queue to another. This overload takes a set of required parameters for the API.
Public Method | ForwardOpportunity | Overloaded. Reject-forward the Opportunity from one queue to another. This overload takes a set of required parameters for the API.
Public Method | ForwardQuote | Overloaded. Reject-forward the Quote from one queue to another. This overload takes a set of required parameters for the API.
Public Method | LogActionItemEmailIn | Overloaded.
Public Method | LogLeadNote | Overloaded. Log a note for a Lead. This overload takes a set of required parameters for the API.
Public Method | LogLeadPhone | Overloaded. Log a phone call for a Lead. This overload takes a set of required parameters for the API.
Public Method | MoveActionItem | Overloaded. Move the ActionItem from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
Public Method | MoveOpportunity | Overloaded. Move the Opportunity from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
Public Method | MoveQuote | Overloaded. Move the Quote from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
Public Method | RejectActionItem | Overloaded. Reject the ActionItem from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.
Public Method | RejectOpportunity | Overloaded. Reject the Opportunity from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.
Public Method | RejectQuote | Overloaded. Reject the Quote from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.
Public Method | ReopenOpportunity | Overloaded. Causes the specified Opportunity to be reopened. This overload takes a set of required parameters for the API.
Public Method | UpdateActionItem | Overloaded. Update an existing Action Item. This overload takes a setup object.
Public Method | UpdateLead | Overloaded. Used to update a Lead. This overload takes a setup object.
Public Method | UpdateOpportunity | Overloaded. Update an Opportunity. This overload takes a setup object.
Public Method | YankActionItem | Overloaded. Yank the ActionItem from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.
Public Method | YankOpportunity | Overloaded. Yank the Opportunity from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.
Public Method | YankQuote | Overloaded. Yank the Quote from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.

Reference

SalesToolkit Class
FChoice.Toolkits.Clarify.Sales Namespace


SalesToolkit Constructor | fcSDK Documentation

SalesToolkit Constructor

Initializes a new instance of the SalesToolkit class.

Overload List

Overload | Description
SalesToolkit Constructor(ClarifySession) | Initializes a new instance of the SalesToolkit class using a ClarifySession object.
SalesToolkit Constructor(IFCApplication,IFCSession) | Initializes a new instance of the SalesToolkit class using a Compatibility application and session.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members


SalesToolkit Constructor(ClarifySession) | fcSDK Documentation

SalesToolkit Constructor(ClarifySession)

The session under which the toolkit APIs will be executed.

Initializes a new instance of the SalesToolkit class using a ClarifySession object.

Syntax

'Declaration

Public Function New( _
   ByVal _session_ As ClarifySession _
)

public SalesToolkit(
   ClarifySession _session_
)

Parameters

session

The session under which the toolkit APIs will be executed.

Remarks

If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


SalesToolkit Constructor(IFCApplication,IFCSession) | fcSDK Documentation

SalesToolkit Constructor(IFCApplication,IFCSession)

The compatibility application under which the toolkit APIs will be executed.

The compatibility session under which the toolkit APIs will be executed.

Initializes a new instance of the SalesToolkit class using a Compatibility application and session.

Syntax

'Declaration

Public Function New( _
   ByVal _application_ As IFCApplication, _
   ByVal _session_ As IFCSession _
)

public SalesToolkit(
   IFCApplication _application_,
   IFCSession _session_
)

Parameters

application

The compatibility application under which the toolkit APIs will be executed.

session

The compatibility session under which the toolkit APIs will be executed.

Remarks

If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


AcceptActionItem Method | fcSDK Documentation

AcceptActionItem Method

Accept the specified ActionItem from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.

Accept the specified ActionItem from the queue in which it is currently dispatched.

Overload List

Overload | Description
AcceptActionItem(String) | Accept the specified ActionItem from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.
AcceptActionItem(AcceptActionItemSetup) | Accept the specified ActionItem from the queue in which it is currently dispatched. This overload takes a setup object.
AcceptActionItem(AcceptActionItemSetup,IDbTransaction) | Accept the specified ActionItem from the queue in which it is currently dispatched. This overload takes a setup object and a database transaction.

Remarks

The ActionItem must be currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
AcceptActionItemSetup Class


AcceptActionItem(String) Method | fcSDK Documentation

AcceptActionItem(String) Method

ActionItem Identifier.

Accept the specified ActionItem from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function AcceptActionItem( _
   ByVal _actionItemIDNum_ As String _
) As ToolkitResult

public ToolkitResult AcceptActionItem(
   string _actionItemIDNum_
)

Parameters

actionItemIDNum

ActionItem Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The ActionItem must be currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


AcceptActionItem(AcceptActionItemSetup) Method | fcSDK Documentation

AcceptActionItem(AcceptActionItemSetup) Method

Setup object for API invocation.

Accept the specified ActionItem from the queue in which it is currently dispatched. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function AcceptActionItem( _
   ByVal _setupParam_ AcceptActionItemSetup _
) As ToolkitResult

public ToolkitResult AcceptActionItem(
   AcceptActionItemSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The ActionItem must be currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List
AcceptActionItemSetup Class


AcceptActionItem(AcceptActionItemSetup,IDbTransaction) Method | fcSDK Documentation

AcceptActionItem(AcceptActionItemSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Accept the specified ActionItem from the queue in which it is currently dispatched. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function AcceptActionItem( _
   ByVal _setupParam_ As AcceptActionItemSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult AcceptActionItem(
   AcceptActionItemSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The ActionItem must be currently dispatched to a queue.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


AcceptOpportunity Method | fcSDK Documentation

AcceptOpportunity Method

Accept the specified Opportunity from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.

Accept the specified Opportunity from the queue in which it is currently dispatched.

Overload List

Overload | Description
AcceptOpportunity(String) | Accept the specified Opportunity from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.
AcceptOpportunity(AcceptOpportunitySetup) | Accept the specified Opportunity from the queue in which it is currently dispatched. This overload takes a setup object.
AcceptOpportunity(AcceptOpportunitySetup,IDbTransaction) | Accept the specified Opportunity from the queue in which it is currently dispatched. This overload takes a setup object and a database transaction.

Remarks

The Opportunity must be currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
AcceptOpportunitySetup Class


AcceptOpportunity(String) Method | fcSDK Documentation

AcceptOpportunity(String) Method

Opportunity Identifier.

Accept the specified Opportunity from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function AcceptOpportunity( _
   ByVal _opportunityIDNum_ As String _
) As ToolkitResult

public ToolkitResult AcceptOpportunity(
   string _opportunityIDNum_
)

Parameters

opportunityIDNum

Opportunity Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Opportunity must be currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


AcceptOpportunity(AcceptOpportunitySetup) Method | fcSDK Documentation

AcceptOpportunity(AcceptOpportunitySetup) Method

Setup object for API invocation.

Accept the specified Opportunity from the queue in which it is currently dispatched. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function AcceptOpportunity( _
   ByVal _setupParam_ AcceptOpportunitySetup _
) As ToolkitResult

public ToolkitResult AcceptOpportunity(
   AcceptOpportunitySetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Opportunity must be currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List
AcceptOpportunitySetup Class


AcceptOpportunity(AcceptOpportunitySetup,IDbTransaction) Method | fcSDK Documentation

AcceptOpportunity(AcceptOpportunitySetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Accept the specified Opportunity from the queue in which it is currently dispatched. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function AcceptOpportunity( _
   ByVal _setupParam_ As AcceptOpportunitySetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult AcceptOpportunity(
   AcceptOpportunitySetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Opportunity must be currently dispatched to a queue.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


AcceptQuote Method (SalesToolkit) | fcSDK Documentation

AcceptQuote Method (SalesToolkit)

Accept the specified Quote from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.

Accept the specified Quote from the queue in which it is currently dispatched.

Overload List

Overload | Description
AcceptQuote(String) | Accept the specified Quote from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.
AcceptQuote(AcceptQuoteSetup) | Accept the specified Quote from the queue in which it is currently dispatched. This overload takes a setup object.
AcceptQuote(AcceptQuoteSetup,IDbTransaction) | Accept the specified Quote from the queue in which it is currently dispatched. This overload takes a setup object and a database transaction.

Remarks

The Quote must be currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
AcceptQuoteSetup Class


AcceptQuote(String) Method | fcSDK Documentation

AcceptQuote(String) Method

Quote Identifier.

Accept the specified Quote from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function AcceptQuote( _
   ByVal _quoteIDNum_ As String _
) As ToolkitResult

public ToolkitResult AcceptQuote(
   string _quoteIDNum_
)

Parameters

quoteIDNum

Quote Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Quote must be currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


AcceptQuote(AcceptQuoteSetup) Method | fcSDK Documentation

AcceptQuote(AcceptQuoteSetup) Method

Setup object for API invocation.

Accept the specified Quote from the queue in which it is currently dispatched. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function AcceptQuote( _
   ByVal _setupParam_ AcceptQuoteSetup _
) As ToolkitResult

public ToolkitResult AcceptQuote(
   AcceptQuoteSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Quote must be currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List
AcceptQuoteSetup Class


AcceptQuote(AcceptQuoteSetup,IDbTransaction) Method | fcSDK Documentation

AcceptQuote(AcceptQuoteSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Accept the specified Quote from the queue in which it is currently dispatched. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function AcceptQuote( _
   ByVal _setupParam_ As AcceptQuoteSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult AcceptQuote(
   AcceptQuoteSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Quote must be currently dispatched to a queue.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


AssignActionItem Method | fcSDK Documentation

AssignActionItem Method

Assign the ActionItem to a new user. This overload takes a set of required parameters for the API.

Assign the ActionItem to a new user.

Overload List

Overload | Description
AssignActionItem(String) | Assign the ActionItem to a new user. This overload takes a set of required parameters for the API.
AssignActionItem(AssignActionItemSetup) | Assign the ActionItem to a new user. This overload takes a setup object.
AssignActionItem(AssignActionItemSetup,IDbTransaction) | Assign the ActionItem to a new user. This overload takes a setup object and a database transaction.

Remarks

The ActionItem must be in the Open condition, and the user assigning the ActionItem does not have to be the owner of the ActionItem. In base Clarify, the assigner of a ActionItem must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the ActionItem in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
AssignActionItemSetup Class


AssignActionItem(String) Method | fcSDK Documentation

AssignActionItem(String) Method

ActionItem Identifier.

Assign the ActionItem to a new user. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function AssignActionItem( _
   ByVal _actionItemIDNum_ As String _
) As ToolkitResult

public ToolkitResult AssignActionItem(
   string _actionItemIDNum_
)

Parameters

actionItemIDNum

ActionItem Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The ActionItem must be in the Open condition, and the user assigning the ActionItem does not have to be the owner of the ActionItem. In base Clarify, the assigner of a ActionItem must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the ActionItem in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


AssignActionItem(AssignActionItemSetup) Method | fcSDK Documentation

AssignActionItem(AssignActionItemSetup) Method

Setup object for API invocation.

Assign the ActionItem to a new user. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function AssignActionItem( _
   ByVal _setupParam_ AssignActionItemSetup _
) As ToolkitResult

public ToolkitResult AssignActionItem(
   AssignActionItemSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The ActionItem must be in the Open condition, and the user assigning the ActionItem does not have to be the owner of the ActionItem. In base Clarify, the assigner of a ActionItem must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the ActionItem in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List
AssignActionItemSetup Class


AssignActionItem(AssignActionItemSetup,IDbTransaction) Method | fcSDK Documentation

AssignActionItem(AssignActionItemSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Assign the ActionItem to a new user. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function AssignActionItem( _
   ByVal _setupParam_ As AssignActionItemSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult AssignActionItem(
   AssignActionItemSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The ActionItem must be in the Open condition, and the user assigning the ActionItem does not have to be the owner of the ActionItem. In base Clarify, the assigner of a ActionItem must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the ActionItem in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


AssignLead Method | fcSDK Documentation

AssignLead Method

Assign the Lead to a new user. This overload takes a set of required parameters for the API.

Assign the Lead to a new user.

Overload List

Overload | Description
AssignLead(Int32,String) | Assign the Lead to a new user. This overload takes a set of required parameters for the API.
AssignLead(AssignLeadSetup) | Assign the Lead to a new user. This overload takes a setup object.
AssignLead(AssignLeadSetup,IDbTransaction) | Assign the Lead to a new user. This overload takes a setup object and a database transaction.

Remarks

The Lead must be in the Open condition, and the user assigning the Lead does not have to be the owner of the Lead. In base Clarify, the assigner of a Lead must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the Lead in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
AssignLeadSetup Class


AssignLead(Int32,String) Method | fcSDK Documentation

AssignLead(Int32,String) Method

The objid of the lead being assigned.

The new user which the lead is assigned to.

Assign the Lead to a new user. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function AssignLead( _
   ByVal _leadObjid_ As Integer, _
   ByVal _newOwner_ As String _
) As ToolkitResult

public ToolkitResult AssignLead(
   int _leadObjid_,
   string _newOwner_
)

Parameters

leadObjid

The objid of the lead being assigned.

newOwner

The new user which the lead is assigned to.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Lead must be in the Open condition, and the user assigning the Lead does not have to be the owner of the Lead. In base Clarify, the assigner of a Lead must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the Lead in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


AssignLead(AssignLeadSetup) Method | fcSDK Documentation

AssignLead(AssignLeadSetup) Method

Setup object for API invocation.

Assign the Lead to a new user. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function AssignLead( _
   ByVal _setupParam_ AssignLeadSetup _
) As ToolkitResult

public ToolkitResult AssignLead(
   AssignLeadSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Lead must be in the Open condition, and the user assigning the Lead does not have to be the owner of the Lead. In base Clarify, the assigner of a Lead must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the Lead in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List
AssignLeadSetup Class


AssignLead(AssignLeadSetup,IDbTransaction) Method | fcSDK Documentation

AssignLead(AssignLeadSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Assign the Lead to a new user. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function AssignLead( _
   ByVal _setupParam_ As AssignLeadSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult AssignLead(
   AssignLeadSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Lead must be in the Open condition, and the user assigning the Lead does not have to be the owner of the Lead. In base Clarify, the assigner of a Lead must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the Lead in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


AssignOpportunity Method | fcSDK Documentation

AssignOpportunity Method

Assign the Opportunity to a new user. This overload takes a set of required parameters for the API.

Assign the Opportunity to a new user.

Overload List

Overload | Description
AssignOpportunity(String) | Assign the Opportunity to a new user. This overload takes a set of required parameters for the API.
AssignOpportunity(AssignOpportunitySetup) | Assign the Opportunity to a new user. This overload takes a setup object.
AssignOpportunity(AssignOpportunitySetup,IDbTransaction) | Assign the Opportunity to a new user. This overload takes a setup object and a database transaction.

Remarks

The Opportunity must be in the Open condition, and the user assigning the Opportunity does not have to be the owner of the Opportunity. In base Clarify, the assigner of a Opportunity must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the Opportunity in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
AssignOpportunitySetup Class


AssignOpportunity(String) Method | fcSDK Documentation

AssignOpportunity(String) Method

Opportunity Identifier.

Assign the Opportunity to a new user. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function AssignOpportunity( _
   ByVal _opportunityIDNum_ As String _
) As ToolkitResult

public ToolkitResult AssignOpportunity(
   string _opportunityIDNum_
)

Parameters

opportunityIDNum

Opportunity Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Opportunity must be in the Open condition, and the user assigning the Opportunity does not have to be the owner of the Opportunity. In base Clarify, the assigner of a Opportunity must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the Opportunity in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


AssignOpportunity(AssignOpportunitySetup) Method | fcSDK Documentation

AssignOpportunity(AssignOpportunitySetup) Method

Setup object for API invocation.

Assign the Opportunity to a new user. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function AssignOpportunity( _
   ByVal _setupParam_ AssignOpportunitySetup _
) As ToolkitResult

public ToolkitResult AssignOpportunity(
   AssignOpportunitySetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Opportunity must be in the Open condition, and the user assigning the Opportunity does not have to be the owner of the Opportunity. In base Clarify, the assigner of a Opportunity must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the Opportunity in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List
AssignOpportunitySetup Class


AssignOpportunity(AssignOpportunitySetup,IDbTransaction) Method | fcSDK Documentation

AssignOpportunity(AssignOpportunitySetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Assign the Opportunity to a new user. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function AssignOpportunity( _
   ByVal _setupParam_ As AssignOpportunitySetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult AssignOpportunity(
   AssignOpportunitySetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Opportunity must be in the Open condition, and the user assigning the Opportunity does not have to be the owner of the Opportunity. In base Clarify, the assigner of a Opportunity must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the Opportunity in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


AssignQuote Method (SalesToolkit) | fcSDK Documentation

AssignQuote Method (SalesToolkit)

Assign the Quote to a new user. This overload takes a set of required parameters for the API.

Assign the Quote to a new user.

Overload List

Overload | Description
AssignQuote(String) | Assign the Quote to a new user. This overload takes a set of required parameters for the API.
AssignQuote(AssignQuoteSetup) | Assign the Quote to a new user. This overload takes a setup object.
AssignQuote(AssignQuoteSetup,IDbTransaction) | Assign the Quote to a new user. This overload takes a setup object and a database transaction.

Remarks

The Quote must be in the Open condition, and the user assigning the Quote does not have to be the owner of the Quote. In base Clarify, the assigner of a Quote must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the Quote in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
AssignQuoteSetup Class


AssignQuote(String) Method | fcSDK Documentation

AssignQuote(String) Method

Quote Identifier.

Assign the Quote to a new user. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function AssignQuote( _
   ByVal _quoteIDNum_ As String _
) As ToolkitResult

public ToolkitResult AssignQuote(
   string _quoteIDNum_
)

Parameters

quoteIDNum

Quote Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Quote must be in the Open condition, and the user assigning the Quote does not have to be the owner of the Quote. In base Clarify, the assigner of a Quote must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the Quote in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


AssignQuote(AssignQuoteSetup) Method | fcSDK Documentation

AssignQuote(AssignQuoteSetup) Method

Setup object for API invocation.

Assign the Quote to a new user. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function AssignQuote( _
   ByVal _setupParam_ AssignQuoteSetup _
) As ToolkitResult

public ToolkitResult AssignQuote(
   AssignQuoteSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Quote must be in the Open condition, and the user assigning the Quote does not have to be the owner of the Quote. In base Clarify, the assigner of a Quote must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the Quote in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List
AssignQuoteSetup Class


AssignQuote(AssignQuoteSetup,IDbTransaction) Method | fcSDK Documentation

AssignQuote(AssignQuoteSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Assign the Quote to a new user. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function AssignQuote( _
   ByVal _setupParam_ As AssignQuoteSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult AssignQuote(
   AssignQuoteSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Quote must be in the Open condition, and the user assigning the Quote does not have to be the owner of the Quote. In base Clarify, the assigner of a Quote must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the Quote in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


ChangeActionItemCondition Method | fcSDK Documentation

ChangeActionItemCondition Method

Used to change the condition and (optionally) a status for the specified Action Item. This overload takes a set of required parameters for the API.

Used to change the condition and (optionally) a status for the specified Action Item.

Overload List

Overload | Description
ChangeActionItemCondition(String,String) | Used to change the condition and (optionally) a status for the specified Action Item. This overload takes a set of required parameters for the API.
ChangeActionItemCondition(ChangeActionItemConditionSetup) | Used to change the condition and (optionally) a status for the specified Action Item. This overload takes a setup object.
ChangeActionItemCondition(ChangeActionItemConditionSetup,IDbTransaction) | Used to change the condition and (optionally) a status for the specified Action Item. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
ChangeActionItemConditionSetup Class


ChangeActionItemCondition(String,String) Method | fcSDK Documentation

ChangeActionItemCondition(String,String) Method

Action Item Identifier.

The new condition for the Action Item

Used to change the condition and (optionally) a status for the specified Action Item. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function ChangeActionItemCondition( _
   ByVal _actionItemIDNum_ As String, _
   ByVal _newcondition_ As String _
) As ToolkitResult

public ToolkitResult ChangeActionItemCondition(
   string _actionItemIDNum_,
   string _newcondition_
)

Parameters

actionItemIDNum

Action Item Identifier.

newcondition

The new condition for the Action Item

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • IDNum - The IDNum of the ActionItem.
  • Objid - The Objid of the ActionItem.

Remarks

The Action Item ID and the condition is required, but no other data is. The API can also generate a time bomb (for business rule notification).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


ChangeActionItemCondition(ChangeActionItemConditionSetup) Method | fcSDK Documentation

ChangeActionItemCondition(ChangeActionItemConditionSetup) Method

Setup object for API invocation.

Used to change the condition and (optionally) a status for the specified Action Item. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function ChangeActionItemCondition( _
   ByVal _setupParam_ ChangeActionItemConditionSetup _
) As ToolkitResult

public ToolkitResult ChangeActionItemCondition(
   ChangeActionItemConditionSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the ActionItem.
  • IDNum - The IDNum of the ActionItem.

Remarks

The Action Item ID and the condition is required, but no other data is. The API can also generate a time bomb (for business rule notification).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List
ChangeActionItemConditionSetup Class


ChangeActionItemCondition(ChangeActionItemConditionSetup,IDbTransaction) Method | fcSDK Documentation

ChangeActionItemCondition(ChangeActionItemConditionSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to change the condition and (optionally) a status for the specified Action Item. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function ChangeActionItemCondition( _
   ByVal _setupParam_ As ChangeActionItemConditionSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult ChangeActionItemCondition(
   ChangeActionItemConditionSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


ChangeActionItemStatus Method | fcSDK Documentation

ChangeActionItemStatus Method

Cause the specified Action Item to have its status changed. This overload takes a set of required parameters for the API.

Cause the specified Action Item to have its status changed.

Overload List

Overload | Description
ChangeActionItemStatus(String) | Cause the specified Action Item to have its status changed. This overload takes a set of required parameters for the API.
ChangeActionItemStatus(ChangeActionItemStatusSetup) | Cause the specified Action Item to have its status changed. This overload takes a setup object.
ChangeActionItemStatus(ChangeActionItemStatusSetup,IDbTransaction) | Cause the specified Action Item to have its status changed. This overload takes a setup object and a database transaction.

Remarks

The object may be in any valid condition, but the status selected MUST be valid for the current condition.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
ChangeActionItemStatusSetup Class


ChangeActionItemStatus(String) Method | fcSDK Documentation

ChangeActionItemStatus(String) Method

Action Item Identifier.

Cause the specified Action Item to have its status changed. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function ChangeActionItemStatus( _
   ByVal _actionItemIDNum_ As String _
) As ToolkitResult

public ToolkitResult ChangeActionItemStatus(
   string _actionItemIDNum_
)

Parameters

actionItemIDNum

Action Item Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The object may be in any valid condition, but the status selected MUST be valid for the current condition.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


ChangeActionItemStatus(ChangeActionItemStatusSetup) Method | fcSDK Documentation

ChangeActionItemStatus(ChangeActionItemStatusSetup) Method

Setup object for API invocation.

Cause the specified Action Item to have its status changed. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function ChangeActionItemStatus( _
   ByVal _setupParam_ ChangeActionItemStatusSetup _
) As ToolkitResult

public ToolkitResult ChangeActionItemStatus(
   ChangeActionItemStatusSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The object may be in any valid condition, but the status selected MUST be valid for the current condition.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List
ChangeActionItemStatusSetup Class


ChangeActionItemStatus(ChangeActionItemStatusSetup,IDbTransaction) Method | fcSDK Documentation

ChangeActionItemStatus(ChangeActionItemStatusSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Cause the specified Action Item to have its status changed. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function ChangeActionItemStatus( _
   ByVal _setupParam_ As ChangeActionItemStatusSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult ChangeActionItemStatus(
   ChangeActionItemStatusSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The object may be in any valid condition, but the status selected MUST be valid for the current condition.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


ChangeOpportunityStatus Method | fcSDK Documentation

ChangeOpportunityStatus Method

Cause the specified Opportunity to have its status changed. This overload takes a set of required parameters for the API.

Cause the specified Opportunity to have its status changed.

Overload List

Overload | Description
ChangeOpportunityStatus(String) | Cause the specified Opportunity to have its status changed. This overload takes a set of required parameters for the API.
ChangeOpportunityStatus(ChangeOpportunityStatusSetup) | Cause the specified Opportunity to have its status changed. This overload takes a setup object.
ChangeOpportunityStatus(ChangeOpportunityStatusSetup,IDbTransaction) | Cause the specified Opportunity to have its status changed. This overload takes a setup object and a database transaction.

Remarks

The object may be in any valid condition, but the status selected MUST be valid for the current condition. The API can also generate a time bomb (for business rule notification).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
ChangeOpportunityStatusSetup Class


ChangeOpportunityStatus(String) Method | fcSDK Documentation

ChangeOpportunityStatus(String) Method

Opportunity Identifier.

Cause the specified Opportunity to have its status changed. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function ChangeOpportunityStatus( _
   ByVal _opportunityIDNum_ As String _
) As ToolkitResult

public ToolkitResult ChangeOpportunityStatus(
   string _opportunityIDNum_
)

Parameters

opportunityIDNum

Opportunity Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The object may be in any valid condition, but the status selected MUST be valid for the current condition. The API can also generate a time bomb (for business rule notification).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


ChangeOpportunityStatus(ChangeOpportunityStatusSetup) Method | fcSDK Documentation

ChangeOpportunityStatus(ChangeOpportunityStatusSetup) Method

Setup object for API invocation.

Cause the specified Opportunity to have its status changed. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function ChangeOpportunityStatus( _
   ByVal _setupParam_ ChangeOpportunityStatusSetup _
) As ToolkitResult

public ToolkitResult ChangeOpportunityStatus(
   ChangeOpportunityStatusSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The object may be in any valid condition, but the status selected MUST be valid for the current condition. The API can also generate a time bomb (for business rule notification).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List
ChangeOpportunityStatusSetup Class


ChangeOpportunityStatus(ChangeOpportunityStatusSetup,IDbTransaction) Method | fcSDK Documentation

ChangeOpportunityStatus(ChangeOpportunityStatusSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Cause the specified Opportunity to have its status changed. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function ChangeOpportunityStatus( _
   ByVal _setupParam_ As ChangeOpportunityStatusSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult ChangeOpportunityStatus(
   ChangeOpportunityStatusSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The object may be in any valid condition, but the status selected MUST be valid for the current condition. The API can also generate a time bomb (for business rule notification).

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


ChangeQuoteStatus Method (SalesToolkit) | fcSDK Documentation

ChangeQuoteStatus Method (SalesToolkit)

Cause the specified Quote to have its status changed. This overload takes a set of required parameters for the API.

Cause the specified Quote to have its status changed.

Overload List

Overload | Description
ChangeQuoteStatus(String) | Cause the specified Quote to have its status changed. This overload takes a set of required parameters for the API.
ChangeQuoteStatus(ChangeQuoteStatusSetup) | Cause the specified Quote to have its status changed. This overload takes a setup object.
ChangeQuoteStatus(ChangeQuoteStatusSetup,IDbTransaction) | Cause the specified Quote to have its status changed. This overload takes a setup object and a database transaction.

Remarks

The object may be in any valid condition, but the status selected MUST be valid for the current condition.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
ChangeQuoteStatusSetup Class


ChangeQuoteStatus(String) Method | fcSDK Documentation

ChangeQuoteStatus(String) Method

Quote Identifier.

Cause the specified Quote to have its status changed. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function ChangeQuoteStatus( _
   ByVal _quoteIDNum_ As String _
) As ToolkitResult

public ToolkitResult ChangeQuoteStatus(
   string _quoteIDNum_
)

Parameters

quoteIDNum

Quote Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The object may be in any valid condition, but the status selected MUST be valid for the current condition.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


ChangeQuoteStatus(ChangeQuoteStatusSetup) Method | fcSDK Documentation

ChangeQuoteStatus(ChangeQuoteStatusSetup) Method

Setup object for API invocation.

Cause the specified Quote to have its status changed. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function ChangeQuoteStatus( _
   ByVal _setupParam_ ChangeQuoteStatusSetup _
) As ToolkitResult

public ToolkitResult ChangeQuoteStatus(
   ChangeQuoteStatusSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The object may be in any valid condition, but the status selected MUST be valid for the current condition.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List
ChangeQuoteStatusSetup Class


ChangeQuoteStatus(ChangeQuoteStatusSetup,IDbTransaction) Method | fcSDK Documentation

ChangeQuoteStatus(ChangeQuoteStatusSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Cause the specified Quote to have its status changed. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function ChangeQuoteStatus( _
   ByVal _setupParam_ As ChangeQuoteStatusSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult ChangeQuoteStatus(
   ChangeQuoteStatusSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The object may be in any valid condition, but the status selected MUST be valid for the current condition.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


CloseOpportunity Method | fcSDK Documentation

CloseOpportunity Method

Closes the Opportunity. This overload takes a set of required parameters for the API.

Closes the Opportunity.

Overload List

Overload | Description
CloseOpportunity(String) | Closes the Opportunity. This overload takes a set of required parameters for the API.
CloseOpportunity(CloseOpportunitySetup) | Closes the Opportunity. This overload takes a setup object.
CloseOpportunity(CloseOpportunitySetup,IDbTransaction) | Closes the Opportunity. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
CloseOpportunitySetup Class


CloseOpportunity(String) Method | fcSDK Documentation

CloseOpportunity(String) Method

Opportunity Identifier.

Closes the Opportunity. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CloseOpportunity( _
   ByVal _opportunityIDNum_ As String _
) As ToolkitResult

public ToolkitResult CloseOpportunity(
   string _opportunityIDNum_
)

Parameters

opportunityIDNum

Opportunity Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The status may be specified (in closed opportunity condition) for the opportunity, as well as the user name of the closer, and the date/time of the close. The API can also generate a time bomb (for business rule notification).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


CloseOpportunity(CloseOpportunitySetup) Method | fcSDK Documentation

CloseOpportunity(CloseOpportunitySetup) Method

Setup object for API invocation.

Closes the Opportunity. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CloseOpportunity( _
   ByVal _setupParam_ CloseOpportunitySetup _
) As ToolkitResult

public ToolkitResult CloseOpportunity(
   CloseOpportunitySetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The status may be specified (in closed opportunity condition) for the opportunity, as well as the user name of the closer, and the date/time of the close. The API can also generate a time bomb (for business rule notification).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List
CloseOpportunitySetup Class


CloseOpportunity(CloseOpportunitySetup,IDbTransaction) Method | fcSDK Documentation

CloseOpportunity(CloseOpportunitySetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Closes the Opportunity. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CloseOpportunity( _
   ByVal _setupParam_ As CloseOpportunitySetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CloseOpportunity(
   CloseOpportunitySetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


CreateActionItem Method | fcSDK Documentation

CreateActionItem Method

Creates a new Action Item. This overload takes a set of required parameters for the API.

Creates a new Action Item.

Overload List

Overload | Description
CreateActionItem() | Creates a new Action Item. This overload takes a set of required parameters for the API.
CreateActionItem(CreateActionItemSetup) | Creates a new Action Item. This overload takes a setup object.
CreateActionItem(CreateActionItemSetup,IDbTransaction) | Creates a new Action Item. This overload takes a setup object and a database transaction.

Remarks

If the new Action Item is related a contact, all three of the contact fields must be supplied. Likewise, if associated to a lead, both lead fields must be supplied.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
CreateActionItemSetup Class


CreateActionItem() Method | fcSDK Documentation

CreateActionItem() Method

Creates a new Action Item. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreateActionItem() As ToolkitResult

public ToolkitResult CreateActionItem()

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the ActionItem.
  • IDNum - The IDNum of the ActionItem.

Remarks

If the new Action Item is related a contact, all three of the contact fields must be supplied. Likewise, if associated to a lead, both lead fields must be supplied.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


CreateActionItem(CreateActionItemSetup) Method | fcSDK Documentation

CreateActionItem(CreateActionItemSetup) Method

Setup object for API invocation.

Creates a new Action Item. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreateActionItem( _
   ByVal _setupParam_ CreateActionItemSetup _
) As ToolkitResult

public ToolkitResult CreateActionItem(
   CreateActionItemSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the ActionItem.
  • IDNum - The IDNum of the ActionItem.

Remarks

If the new Action Item is related a contact, all three of the contact fields must be supplied. Likewise, if associated to a lead, both lead fields must be supplied.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List
CreateActionItemSetup Class


CreateActionItem(CreateActionItemSetup,IDbTransaction) Method | fcSDK Documentation

CreateActionItem(CreateActionItemSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Creates a new Action Item. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreateActionItem( _
   ByVal _setupParam_ As CreateActionItemSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreateActionItem(
   CreateActionItemSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

If the new Action Item is related a contact, all three of the contact fields must be supplied. Likewise, if associated to a lead, both lead fields must be supplied.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


CreateLead Method | fcSDK Documentation

CreateLead Method

Used to create a new Lead. This overload takes a set of required parameters for the API.

Used to create a new Lead.

Overload List

Overload | Description
CreateLead(String,String,String,LeadSiteType,String) | Used to create a new Lead. This overload takes a set of required parameters for the API.
CreateLead(CreateLeadSetup) | Used to create a new Lead. This overload takes a setup object.
CreateLead(CreateLeadSetup,IDbTransaction) | Used to create a new Lead. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
CreateLeadSetup Class


CreateLead(String,String,String,LeadSiteType,String) Method | fcSDK Documentation

CreateLead(String,String,String,LeadSiteType,String) Method

State for the lead.

Country for the lead.

Time zone for the lead.

The type of the site for the lead.

Name of the lead source.

Used to create a new Lead. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreateLead( _
   ByVal _state_ As String, _
   ByVal _country_ As String, _
   ByVal _timeZone_ As String, _
   ByVal _siteType_ As LeadSiteType, _
   ByVal _leadSource_ As String _
) As ToolkitResult

public ToolkitResult CreateLead(
   string _state_,
   string _country_,
   string _timeZone_,
   LeadSiteType _siteType_,
   string _leadSource_
)

Parameters

state

State for the lead.

country

Country for the lead.

timeZone

Time zone for the lead.

siteType

The type of the site for the lead.

leadSource

Name of the lead source.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Lead.

Remarks

For almost all of the data, it can be specified, or not.

The user who created the lead, and the date/time of the create can be specified. The API can also generate a time bomb (for business rules). Finally, additional fields may be set.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


CreateLead(CreateLeadSetup) Method | fcSDK Documentation

CreateLead(CreateLeadSetup) Method

Setup object for API invocation.

Used to create a new Lead. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreateLead( _
   ByVal _setupParam_ CreateLeadSetup _
) As ToolkitResult

public ToolkitResult CreateLead(
   CreateLeadSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Lead.

Remarks

For almost all of the data, it can be specified, or not.

The user who created the lead, and the date/time of the create can be specified. The API can also generate a time bomb (for business rules). Finally, additional fields may be set.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List
CreateLeadSetup Class


CreateLead(CreateLeadSetup,IDbTransaction) Method | fcSDK Documentation

CreateLead(CreateLeadSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to create a new Lead. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreateLead( _
   ByVal _setupParam_ As CreateLeadSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreateLead(
   CreateLeadSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


CreateOpportunity Method | fcSDK Documentation

CreateOpportunity Method

Used to create a new Opportunity. This overload takes a set of required parameters for the API.

Used to create a new Opportunity.

Overload List

Overload | Description
CreateOpportunity(String,String,Single) | Used to create a new Opportunity. This overload takes a set of required parameters for the API.
CreateOpportunity(CreateOpportunitySetup) | Used to create a new Opportunity. This overload takes a setup object.
CreateOpportunity(CreateOpportunitySetup,IDbTransaction) | Used to create a new Opportunity. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
CreateOpportunitySetup Class


CreateOpportunity(String,String,Single) Method | fcSDK Documentation

CreateOpportunity(String,String,Single) Method

The name of the Opportunity.

Sales stage for the opportunity.

Probability of opportunity close.

Used to create a new Opportunity. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreateOpportunity( _
   ByVal _opportunityName_ As String, _
   ByVal _salesStage_ As String, _
   ByVal _probability_ As Single _
) As ToolkitResult

public ToolkitResult CreateOpportunity(
   string _opportunityName_,
   string _salesStage_,
   float _probability_
)

Parameters

opportunityName

The name of the Opportunity.

salesStage

Sales stage for the opportunity.

probability

Probability of opportunity close.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The opportunity name must be specified. All other data is optional. The account, contact, territory, stage, source, currency, and process may be specified. Also, an amount and a probability may be specified. The API can generate a time bomb for business rules, or not.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


CreateOpportunity(CreateOpportunitySetup) Method | fcSDK Documentation

CreateOpportunity(CreateOpportunitySetup) Method

Setup object for API invocation.

Used to create a new Opportunity. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreateOpportunity( _
   ByVal _setupParam_ CreateOpportunitySetup _
) As ToolkitResult

public ToolkitResult CreateOpportunity(
   CreateOpportunitySetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The opportunity name must be specified. All other data is optional. The account, contact, territory, stage, source, currency, and process may be specified. Also, an amount and a probability may be specified. The API can generate a time bomb for business rules, or not.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List
CreateOpportunitySetup Class


CreateOpportunity(CreateOpportunitySetup,IDbTransaction) Method | fcSDK Documentation

CreateOpportunity(CreateOpportunitySetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to create a new Opportunity. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreateOpportunity( _
   ByVal _setupParam_ As CreateOpportunitySetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreateOpportunity(
   CreateOpportunitySetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


CreateQuote Method | fcSDK Documentation

CreateQuote Method

Used to create a new Quote. This overload takes a set of required parameters for the API.

Used to create a new Quote.

Overload List

Overload | Description
CreateQuote(String) | Used to create a new Quote. This overload takes a set of required parameters for the API.
CreateQuote(CreateQuoteSetup) | Used to create a new Quote. This overload takes a setup object.
CreateQuote(CreateQuoteSetup,IDbTransaction) | Used to create a new Quote. This overload takes a setup object and a database transaction.

Remarks

This API requires that a valid opportunity exists. This differs a little from the Clarify GUI, which creates the opportunity as part of the create quote. That can be done with the APIs, but there is extra flexibility provided.

As part of creating the contract record for the quote, these APIs also create the default contract schedule and relates the schedule to the contract.

Additional fields may be set on either the contract or contr_schedule table. To set a field on table_contract, just use the field name. To set a field on the contr_schedule table, place “sched:” before the name of the field. For example, to set the “x_foo” field on the contr_schedule table, use a field name of “sched:x_foo”.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
CreateQuoteSetup Class


CreateQuote(String) Method | fcSDK Documentation

CreateQuote(String) Method

The title of the Quote.

Used to create a new Quote. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreateQuote( _
   ByVal _quoteTitle_ As String _
) As ToolkitResult

public ToolkitResult CreateQuote(
   string _quoteTitle_
)

Parameters

quoteTitle

The title of the Quote.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

This API requires that a valid opportunity exists. This differs a little from the Clarify GUI, which creates the opportunity as part of the create quote. That can be done with the APIs, but there is extra flexibility provided.

As part of creating the contract record for the quote, these APIs also create the default contract schedule and relates the schedule to the contract.

Additional fields may be set on either the contract or contr_schedule table. To set a field on table_contract, just use the field name. To set a field on the contr_schedule table, place “sched:” before the name of the field. For example, to set the “x_foo” field on the contr_schedule table, use a field name of “sched:x_foo”.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


CreateQuote(CreateQuoteSetup) Method | fcSDK Documentation

CreateQuote(CreateQuoteSetup) Method

Setup object for API invocation.

Used to create a new Quote. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreateQuote( _
   ByVal _setupParam_ CreateQuoteSetup _
) As ToolkitResult

public ToolkitResult CreateQuote(
   CreateQuoteSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

This API requires that a valid opportunity exists. This differs a little from the Clarify GUI, which creates the opportunity as part of the create quote. That can be done with the APIs, but there is extra flexibility provided.

As part of creating the contract record for the quote, these APIs also create the default contract schedule and relates the schedule to the contract.

Additional fields may be set on either the contract or contr_schedule table. To set a field on table_contract, just use the field name. To set a field on the contr_schedule table, place “sched:” before the name of the field. For example, to set the “x_foo” field on the contr_schedule table, use a field name of “sched:x_foo”.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List
CreateQuoteSetup Class


CreateQuote(CreateQuoteSetup,IDbTransaction) Method | fcSDK Documentation

CreateQuote(CreateQuoteSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to create a new Quote. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreateQuote( _
   ByVal _setupParam_ As CreateQuoteSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreateQuote(
   CreateQuoteSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

This API requires that a valid opportunity exists. This differs a little from the Clarify GUI, which creates the opportunity as part of the create quote. That can be done with the APIs, but there is extra flexibility provided.

As part of creating the contract record for the quote, these APIs also create the default contract schedule and relates the schedule to the contract.

Additional fields may be set on either the contract or contr_schedule table. To set a field on table_contract, just use the field name. To set a field on the contr_schedule table, place “sched:” before the name of the field. For example, to set the “x_foo” field on the contr_schedule table, use a field name of “sched:x_foo”.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


CreateQuoteLineItem Method | fcSDK Documentation

CreateQuoteLineItem Method

Used to create a Quote/Contract line item. This overload takes a set of required parameters for the API.

Used to create a Quote/Contract line item.

Overload List

Overload | Description
CreateQuoteLineItem(String,String,String,String,Int32,String,Int32) | Used to create a Quote/Contract line item. This overload takes a set of required parameters for the API.
CreateQuoteLineItem(String,String,String,String,String,String,Int32) | Used to create a Quote/Contract line item. This overload takes a set of required parameters for the API.
CreateQuoteLineItem(CreateQuoteLineItemSetup) | Used to create a Quote/Contract line item. This overload takes a setup object.
CreateQuoteLineItem(CreateQuoteLineItemSetup,IDbTransaction) | Used to create a Quote/Contract line item. This overload takes a setup object and a database transaction.

Remarks

Requires that a valid quote already exist, and that it have at least one valid schedule. In addition, the supplied part/revision must have a price defined for it in the schedule, or you must provide an override.

The API will create a line item, add it to the proper contract/quote, and adjust all of the totals. In addition, the schedule adjustments (if any) for the schedule of the line item will be recalculated, given the new schedule totals.

The API does not do a few other items in the base GUI function. By and large, they are expected to be supplied with other API calls. For example, line item adjustments are not part of this API. If they are required, the line should be created, and then the adjustment should be applied. Parent/child line items are not provided for in the default API. Also, proration (ClearContracts) is currently hard-coded.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
CreateQuoteLineItemSetup Class


CreateQuoteLineItem(String,String,String,String,Int32,String,Int32) Method | fcSDK Documentation

CreateQuoteLineItem(String,String,String,String,Int32,String,Int32) Method

Quote/Contract Identifier.

The part number for this line item.

The domain of the part for this line item.

The revision of the part for this line item.

The number of units for this line item.

The name of the Price Schedule for this line item.

The objid of the parent line item.

Used to create a Quote/Contract line item. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreateQuoteLineItem( _
   ByVal _contractIDNum_ As String, _
   ByVal _partNumber_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _quantity_ As Integer, _
   ByVal _priceSchedule_ As String, _
   ByVal _parentLineItemObjid_ As Integer _
) As ToolkitResult

public ToolkitResult CreateQuoteLineItem(
   string _contractIDNum_,
   string _partNumber_,
   string _partDomain_,
   string _partRevision_,
   int _quantity_,
   string _priceSchedule_,
   int _parentLineItemObjid_
)

Parameters

contractIDNum

Quote/Contract Identifier.

partNumber

The part number for this line item.

partDomain

The domain of the part for this line item.

partRevision

The revision of the part for this line item.

quantity

The number of units for this line item.

priceSchedule

The name of the Price Schedule for this line item.

parentLineItemObjid

The objid of the parent line item.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the ContractItem.

Remarks

Requires that a valid quote already exist, and that it have at least one valid schedule. In addition, the supplied part/revision must have a price defined for it in the schedule, or you must provide an override.

The API will create a line item, add it to the proper contract/quote, and adjust all of the totals. In addition, the schedule adjustments (if any) for the schedule of the line item will be recalculated, given the new schedule totals.

The API does not do a few other items in the base GUI function. By and large, they are expected to be supplied with other API calls. For example, line item adjustments are not part of this API. If they are required, the line should be created, and then the adjustment should be applied. Parent/child line items are not provided for in the default API. Also, proration (ClearContracts) is currently hard-coded.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


CreateQuoteLineItem(String,String,String,String,String,String,Int32) Method | fcSDK Documentation

CreateQuoteLineItem(String,String,String,String,String,String,Int32) Method

Quote/Contract Identifier.

The part number for this line item.

The domain of the part for this line item.

The revision of the part for this line item.

The name of the Price Schedule for this line item.

For a serialized part, the serial number referenced by this line item.

The objid of the parent line item.

Used to create a Quote/Contract line item. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreateQuoteLineItem( _
   ByVal _contractIDNum_ As String, _
   ByVal _partNumber_ As String, _
   ByVal _partDomain_ As String, _
   ByVal _partRevision_ As String, _
   ByVal _priceSchedule_ As String, _
   ByVal _serialNumber_ As String, _
   ByVal _parentLineItemObjid_ As Integer _
) As ToolkitResult

public ToolkitResult CreateQuoteLineItem(
   string _contractIDNum_,
   string _partNumber_,
   string _partDomain_,
   string _partRevision_,
   string _priceSchedule_,
   string _serialNumber_,
   int _parentLineItemObjid_
)

Parameters

contractIDNum

Quote/Contract Identifier.

partNumber

The part number for this line item.

partDomain

The domain of the part for this line item.

partRevision

The revision of the part for this line item.

priceSchedule

The name of the Price Schedule for this line item.

serialNumber

For a serialized part, the serial number referenced by this line item.

parentLineItemObjid

The objid of the parent line item.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the ContractItem.

Remarks

Requires that a valid quote already exist, and that it have at least one valid schedule. In addition, the supplied part/revision must have a price defined for it in the schedule, or you must provide an override.

The API will create a line item, add it to the proper contract/quote, and adjust all of the totals. In addition, the schedule adjustments (if any) for the schedule of the line item will be recalculated, given the new schedule totals.

The API does not do a few other items in the base GUI function. By and large, they are expected to be supplied with other API calls. For example, line item adjustments are not part of this API. If they are required, the line should be created, and then the adjustment should be applied. Parent/child line items are not provided for in the default API. Also, proration (ClearContracts) is currently hard-coded.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


CreateQuoteLineItem(CreateQuoteLineItemSetup) Method | fcSDK Documentation

CreateQuoteLineItem(CreateQuoteLineItemSetup) Method

Setup object for API invocation.

Used to create a Quote/Contract line item. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreateQuoteLineItem( _
   ByVal _setupParam_ CreateQuoteLineItemSetup _
) As ToolkitResult

public ToolkitResult CreateQuoteLineItem(
   CreateQuoteLineItemSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the ContractItem.

Remarks

Requires that a valid quote already exist, and that it have at least one valid schedule. In addition, the supplied part/revision must have a price defined for it in the schedule, or you must provide an override.

The API will create a line item, add it to the proper contract/quote, and adjust all of the totals. In addition, the schedule adjustments (if any) for the schedule of the line item will be recalculated, given the new schedule totals.

The API does not do a few other items in the base GUI function. By and large, they are expected to be supplied with other API calls. For example, line item adjustments are not part of this API. If they are required, the line should be created, and then the adjustment should be applied. Parent/child line items are not provided for in the default API. Also, proration (ClearContracts) is currently hard-coded.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List
CreateQuoteLineItemSetup Class


CreateQuoteLineItem(CreateQuoteLineItemSetup,IDbTransaction) Method | fcSDK Documentation

CreateQuoteLineItem(CreateQuoteLineItemSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to create a Quote/Contract line item. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreateQuoteLineItem( _
   ByVal _setupParam_ As CreateQuoteLineItemSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreateQuoteLineItem(
   CreateQuoteLineItemSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

Requires that a valid quote already exist, and that it have at least one valid schedule. In addition, the supplied part/revision must have a price defined for it in the schedule, or you must provide an override.

The API will create a line item, add it to the proper contract/quote, and adjust all of the totals. In addition, the schedule adjustments (if any) for the schedule of the line item will be recalculated, given the new schedule totals.

The API does not do a few other items in the base GUI function. By and large, they are expected to be supplied with other API calls. For example, line item adjustments are not part of this API. If they are required, the line should be created, and then the adjustment should be applied. Parent/child line items are not provided for in the default API. Also, proration (ClearContracts) is currently hard-coded.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


DispatchActionItem Method | fcSDK Documentation

DispatchActionItem Method

Dispatch the ActionItem to the specified queue. This overload takes a set of required parameters for the API.

Dispatch the ActionItem to the specified queue.

Overload List

Overload | Description
DispatchActionItem(String,String) | Dispatch the ActionItem to the specified queue. This overload takes a set of required parameters for the API.
DispatchActionItem(DispatchActionItemSetup) | Dispatch the ActionItem to the specified queue. This overload takes a setup object.
DispatchActionItem(DispatchActionItemSetup,IDbTransaction) | Dispatch the ActionItem to the specified queue. This overload takes a setup object and a database transaction.

Remarks

The ActionItem must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
DispatchActionItemSetup Class


DispatchActionItem(String,String) Method | fcSDK Documentation

DispatchActionItem(String,String) Method

ActionItem Identifier.

The queue into which the ActionItem is to be dispatched.

Dispatch the ActionItem to the specified queue. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function DispatchActionItem( _
   ByVal _actionItemIDNum_ As String, _
   ByVal _queue_ As String _
) As ToolkitResult

public ToolkitResult DispatchActionItem(
   string _actionItemIDNum_,
   string _queue_
)

Parameters

actionItemIDNum

ActionItem Identifier.

queue

The queue into which the ActionItem is to be dispatched.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The ActionItem must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


DispatchActionItem(DispatchActionItemSetup) Method | fcSDK Documentation

DispatchActionItem(DispatchActionItemSetup) Method

Setup object for API invocation.

Dispatch the ActionItem to the specified queue. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function DispatchActionItem( _
   ByVal _setupParam_ DispatchActionItemSetup _
) As ToolkitResult

public ToolkitResult DispatchActionItem(
   DispatchActionItemSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The ActionItem must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List
DispatchActionItemSetup Class


DispatchActionItem(DispatchActionItemSetup,IDbTransaction) Method | fcSDK Documentation

DispatchActionItem(DispatchActionItemSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Dispatch the ActionItem to the specified queue. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function DispatchActionItem( _
   ByVal _setupParam_ As DispatchActionItemSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult DispatchActionItem(
   DispatchActionItemSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The ActionItem must be in open condition, and not currently dispatched to a queue.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


DispatchOpportunity Method | fcSDK Documentation

DispatchOpportunity Method

Dispatch the Opportunity to the specified queue. This overload takes a set of required parameters for the API.

Dispatch the Opportunity to the specified queue.

Overload List

Overload | Description
DispatchOpportunity(String,String) | Dispatch the Opportunity to the specified queue. This overload takes a set of required parameters for the API.
DispatchOpportunity(DispatchOpportunitySetup) | Dispatch the Opportunity to the specified queue. This overload takes a setup object.
DispatchOpportunity(DispatchOpportunitySetup,IDbTransaction) | Dispatch the Opportunity to the specified queue. This overload takes a setup object and a database transaction.

Remarks

The Opportunity must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
DispatchOpportunitySetup Class


DispatchOpportunity(String,String) Method | fcSDK Documentation

DispatchOpportunity(String,String) Method

Opportunity Identifier.

The queue into which the Opportunity is to be dispatched.

Dispatch the Opportunity to the specified queue. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function DispatchOpportunity( _
   ByVal _opportunityIDNum_ As String, _
   ByVal _queue_ As String _
) As ToolkitResult

public ToolkitResult DispatchOpportunity(
   string _opportunityIDNum_,
   string _queue_
)

Parameters

opportunityIDNum

Opportunity Identifier.

queue

The queue into which the Opportunity is to be dispatched.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Opportunity must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


DispatchOpportunity(DispatchOpportunitySetup) Method | fcSDK Documentation

DispatchOpportunity(DispatchOpportunitySetup) Method

Setup object for API invocation.

Dispatch the Opportunity to the specified queue. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function DispatchOpportunity( _
   ByVal _setupParam_ DispatchOpportunitySetup _
) As ToolkitResult

public ToolkitResult DispatchOpportunity(
   DispatchOpportunitySetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Opportunity must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List
DispatchOpportunitySetup Class


DispatchOpportunity(DispatchOpportunitySetup,IDbTransaction) Method | fcSDK Documentation

DispatchOpportunity(DispatchOpportunitySetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Dispatch the Opportunity to the specified queue. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function DispatchOpportunity( _
   ByVal _setupParam_ As DispatchOpportunitySetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult DispatchOpportunity(
   DispatchOpportunitySetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Opportunity must be in open condition, and not currently dispatched to a queue.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


DispatchQuote Method (SalesToolkit) | fcSDK Documentation

DispatchQuote Method (SalesToolkit)

Dispatch the Quote to the specified queue. This overload takes a set of required parameters for the API.

Dispatch the Quote to the specified queue.

Overload List

Overload | Description
DispatchQuote(String,String) | Dispatch the Quote to the specified queue. This overload takes a set of required parameters for the API.
DispatchQuote(DispatchQuoteSetup) | Dispatch the Quote to the specified queue. This overload takes a setup object.
DispatchQuote(DispatchQuoteSetup,IDbTransaction) | Dispatch the Quote to the specified queue. This overload takes a setup object and a database transaction.

Remarks

The Quote must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
DispatchQuoteSetup Class


DispatchQuote(String,String) Method | fcSDK Documentation

DispatchQuote(String,String) Method

Quote Identifier.

The queue into which the Quote is to be dispatched.

Dispatch the Quote to the specified queue. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function DispatchQuote( _
   ByVal _quoteIDNum_ As String, _
   ByVal _queue_ As String _
) As ToolkitResult

public ToolkitResult DispatchQuote(
   string _quoteIDNum_,
   string _queue_
)

Parameters

quoteIDNum

Quote Identifier.

queue

The queue into which the Quote is to be dispatched.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Quote must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


DispatchQuote(DispatchQuoteSetup) Method | fcSDK Documentation

DispatchQuote(DispatchQuoteSetup) Method

Setup object for API invocation.

Dispatch the Quote to the specified queue. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function DispatchQuote( _
   ByVal _setupParam_ DispatchQuoteSetup _
) As ToolkitResult

public ToolkitResult DispatchQuote(
   DispatchQuoteSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Quote must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List
DispatchQuoteSetup Class


DispatchQuote(DispatchQuoteSetup,IDbTransaction) Method | fcSDK Documentation

DispatchQuote(DispatchQuoteSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Dispatch the Quote to the specified queue. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function DispatchQuote( _
   ByVal _setupParam_ As DispatchQuoteSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult DispatchQuote(
   DispatchQuoteSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Quote must be in open condition, and not currently dispatched to a queue.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


ForwardActionItem Method | fcSDK Documentation

ForwardActionItem Method

Reject-forward the ActionItem from one queue to another. This overload takes a set of required parameters for the API.

Reject-forward the ActionItem from one queue to another.

Overload List

Overload | Description
ForwardActionItem(String,String) | Reject-forward the ActionItem from one queue to another. This overload takes a set of required parameters for the API.
ForwardActionItem(ForwardActionItemSetup) | Reject-forward the ActionItem from one queue to another. This overload takes a setup object.
ForwardActionItem(ForwardActionItemSetup,IDbTransaction) | Reject-forward the ActionItem from one queue to another. This overload takes a setup object and a database transaction.

Remarks

The ActionItem must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
ForwardActionItemSetup Class


ForwardActionItem(String,String) Method | fcSDK Documentation

ForwardActionItem(String,String) Method

ActionItem Identifier.

The new queue into which the ActionItem is to be forwarded.

Reject-forward the ActionItem from one queue to another. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function ForwardActionItem( _
   ByVal _actionItemIDNum_ As String, _
   ByVal _newQueue_ As String _
) As ToolkitResult

public ToolkitResult ForwardActionItem(
   string _actionItemIDNum_,
   string _newQueue_
)

Parameters

actionItemIDNum

ActionItem Identifier.

newQueue

The new queue into which the ActionItem is to be forwarded.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The ActionItem must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


ForwardActionItem(ForwardActionItemSetup) Method | fcSDK Documentation

ForwardActionItem(ForwardActionItemSetup) Method

Setup object for API invocation.

Reject-forward the ActionItem from one queue to another. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function ForwardActionItem( _
   ByVal _setupParam_ ForwardActionItemSetup _
) As ToolkitResult

public ToolkitResult ForwardActionItem(
   ForwardActionItemSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The ActionItem must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List
ForwardActionItemSetup Class


ForwardActionItem(ForwardActionItemSetup,IDbTransaction) Method | fcSDK Documentation

ForwardActionItem(ForwardActionItemSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Reject-forward the ActionItem from one queue to another. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function ForwardActionItem( _
   ByVal _setupParam_ As ForwardActionItemSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult ForwardActionItem(
   ForwardActionItemSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The ActionItem must be in open condition, and not currently dispatched to a queue.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


ForwardOpportunity Method | fcSDK Documentation

ForwardOpportunity Method

Reject-forward the Opportunity from one queue to another. This overload takes a set of required parameters for the API.

Reject-forward the Opportunity from one queue to another.

Overload List

Overload | Description
ForwardOpportunity(String,String) | Reject-forward the Opportunity from one queue to another. This overload takes a set of required parameters for the API.
ForwardOpportunity(ForwardOpportunitySetup) | Reject-forward the Opportunity from one queue to another. This overload takes a setup object.
ForwardOpportunity(ForwardOpportunitySetup,IDbTransaction) | Reject-forward the Opportunity from one queue to another. This overload takes a setup object and a database transaction.

Remarks

The Opportunity must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
ForwardOpportunitySetup Class


ForwardOpportunity(String,String) Method | fcSDK Documentation

ForwardOpportunity(String,String) Method

Opportunity Identifier.

The new queue into which the Opportunity is to be forwarded.

Reject-forward the Opportunity from one queue to another. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function ForwardOpportunity( _
   ByVal _opportunityIDNum_ As String, _
   ByVal _newQueue_ As String _
) As ToolkitResult

public ToolkitResult ForwardOpportunity(
   string _opportunityIDNum_,
   string _newQueue_
)

Parameters

opportunityIDNum

Opportunity Identifier.

newQueue

The new queue into which the Opportunity is to be forwarded.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Opportunity must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


ForwardOpportunity(ForwardOpportunitySetup) Method | fcSDK Documentation

ForwardOpportunity(ForwardOpportunitySetup) Method

Setup object for API invocation.

Reject-forward the Opportunity from one queue to another. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function ForwardOpportunity( _
   ByVal _setupParam_ ForwardOpportunitySetup _
) As ToolkitResult

public ToolkitResult ForwardOpportunity(
   ForwardOpportunitySetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Opportunity must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List
ForwardOpportunitySetup Class


ForwardOpportunity(ForwardOpportunitySetup,IDbTransaction) Method | fcSDK Documentation

ForwardOpportunity(ForwardOpportunitySetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Reject-forward the Opportunity from one queue to another. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function ForwardOpportunity( _
   ByVal _setupParam_ As ForwardOpportunitySetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult ForwardOpportunity(
   ForwardOpportunitySetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Opportunity must be in open condition, and not currently dispatched to a queue.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


ForwardQuote Method (SalesToolkit) | fcSDK Documentation

ForwardQuote Method (SalesToolkit)

Reject-forward the Quote from one queue to another. This overload takes a set of required parameters for the API.

Reject-forward the Quote from one queue to another.

Overload List

Overload | Description
ForwardQuote(String,String) | Reject-forward the Quote from one queue to another. This overload takes a set of required parameters for the API.
ForwardQuote(ForwardQuoteSetup) | Reject-forward the Quote from one queue to another. This overload takes a setup object.
ForwardQuote(ForwardQuoteSetup,IDbTransaction) | Reject-forward the Quote from one queue to another. This overload takes a setup object and a database transaction.

Remarks

The Quote must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
ForwardQuoteSetup Class


ForwardQuote(String,String) Method | fcSDK Documentation

ForwardQuote(String,String) Method

Quote Identifier.

The new queue into which the Quote is to be forwarded.

Reject-forward the Quote from one queue to another. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function ForwardQuote( _
   ByVal _quoteIDNum_ As String, _
   ByVal _newQueue_ As String _
) As ToolkitResult

public ToolkitResult ForwardQuote(
   string _quoteIDNum_,
   string _newQueue_
)

Parameters

quoteIDNum

Quote Identifier.

newQueue

The new queue into which the Quote is to be forwarded.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Quote must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


ForwardQuote(ForwardQuoteSetup) Method | fcSDK Documentation

ForwardQuote(ForwardQuoteSetup) Method

Setup object for API invocation.

Reject-forward the Quote from one queue to another. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function ForwardQuote( _
   ByVal _setupParam_ ForwardQuoteSetup _
) As ToolkitResult

public ToolkitResult ForwardQuote(
   ForwardQuoteSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Quote must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List
ForwardQuoteSetup Class


ForwardQuote(ForwardQuoteSetup,IDbTransaction) Method | fcSDK Documentation

ForwardQuote(ForwardQuoteSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Reject-forward the Quote from one queue to another. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function ForwardQuote( _
   ByVal _setupParam_ As ForwardQuoteSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult ForwardQuote(
   ForwardQuoteSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Quote must be in open condition, and not currently dispatched to a queue.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


LogActionItemEmailIn Method | fcSDK Documentation

LogActionItemEmailIn Method

Overload List

Overload | Description
LogActionItemEmailIn(LogActionItemEmailInSetup) |
LogActionItemEmailIn(LogActionItemEmailInSetup,IDbTransaction) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members


LogActionItemEmailIn(LogActionItemEmailInSetup) Method | fcSDK Documentation

LogActionItemEmailIn(LogActionItemEmailInSetup) Method

Syntax

'Declaration

Public Overloads Function LogActionItemEmailIn( _
   ByVal _setup_ LogActionItemEmailInSetup _
) As ToolkitResult

public ToolkitResult LogActionItemEmailIn(
   LogActionItemEmailInSetup _setup_
)

Parameters

setup

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


LogActionItemEmailIn(LogActionItemEmailInSetup,IDbTransaction) Method | fcSDK Documentation

LogActionItemEmailIn(LogActionItemEmailInSetup,IDbTransaction) Method

Syntax

'Declaration

Public Overloads Function LogActionItemEmailIn( _
   ByVal _setup_ As LogActionItemEmailInSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult LogActionItemEmailIn(
   LogActionItemEmailInSetup _setup_,
   IDbTransaction _transaction_
)

Parameters

setup

transaction

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


LogLeadNote Method | fcSDK Documentation

LogLeadNote Method

Log a note for a Lead. This overload takes a set of required parameters for the API.

Log a note for a Lead.

Overload List

Overload | Description
LogLeadNote(Int32) | Log a note for a Lead. This overload takes a set of required parameters for the API.
LogLeadNote(LogLeadNoteSetup) | Log a note for a Lead. This overload takes a setup object.
LogLeadNote(LogLeadNoteSetup,IDbTransaction) | Log a note for a Lead. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
LogLeadNoteSetup Class


LogLeadNote(Int32) Method | fcSDK Documentation

LogLeadNote(Int32) Method

The objid of the lead for the note log.

Log a note for a Lead. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function LogLeadNote( _
   ByVal _leadObjid_ As Integer _
) As ToolkitResult

public ToolkitResult LogLeadNote(
   int _leadObjid_
)

Parameters

leadObjid

The objid of the lead for the note log.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the NoteLog.

Remarks

The objid of the lead must be specified (since no other information on the lead is unique), and the description (note text). A internal use only text field can be supplied. The user who logged the note, and when can be indicated.

The API can generate a time bomb (for business rule notification).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


LogLeadNote(LogLeadNoteSetup) Method | fcSDK Documentation

LogLeadNote(LogLeadNoteSetup) Method

Setup object for API invocation.

Log a note for a Lead. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function LogLeadNote( _
   ByVal _setupParam_ LogLeadNoteSetup _
) As ToolkitResult

public ToolkitResult LogLeadNote(
   LogLeadNoteSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the NoteLog.

Remarks

The objid of the lead must be specified (since no other information on the lead is unique), and the description (note text). A internal use only text field can be supplied. The user who logged the note, and when can be indicated.

The API can generate a time bomb (for business rule notification).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List
LogLeadNoteSetup Class


LogLeadNote(LogLeadNoteSetup,IDbTransaction) Method | fcSDK Documentation

LogLeadNote(LogLeadNoteSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Log a note for a Lead. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function LogLeadNote( _
   ByVal _setupParam_ As LogLeadNoteSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult LogLeadNote(
   LogLeadNoteSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


LogLeadPhone Method | fcSDK Documentation

LogLeadPhone Method

Log a phone call for a Lead. This overload takes a set of required parameters for the API.

Log a phone call for a Lead.

Overload List

Overload | Description
LogLeadPhone(Int32,String,String,String,TimeSpan) | Log a phone call for a Lead. This overload takes a set of required parameters for the API.
LogLeadPhone(LogLeadPhoneSetup) | Log a phone call for a Lead. This overload takes a setup object.
LogLeadPhone(LogLeadPhoneSetup,IDbTransaction) | Log a phone call for a Lead. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
LogLeadPhoneSetup Class


LogLeadPhone(Int32,String,String,String,TimeSpan) Method | fcSDK Documentation

LogLeadPhone(Int32,String,String,String,TimeSpan) Method

The objid of the lead for the phone log.

Contact's first name.

Contact's last name.

Contact's phone number.

Time that the phone call lasted.

Log a phone call for a Lead. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function LogLeadPhone( _
   ByVal _leadObjid_ As Integer, _
   ByVal _contactFirstName_ As String, _
   ByVal _contactLastName_ As String, _
   ByVal _contactPhone_ As String, _
   ByVal _duration_ As TimeSpan _
) As ToolkitResult

public ToolkitResult LogLeadPhone(
   int _leadObjid_,
   string _contactFirstName_,
   string _contactLastName_,
   string _contactPhone_,
   TimeSpan _duration_
)

Parameters

leadObjid

The objid of the lead for the phone log.

contactFirstName

Contact's first name.

contactLastName

Contact's last name.

contactPhone

Contact's phone number.

duration

Time that the phone call lasted.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the PhoneLog.

Remarks

The objid of the lead must be specified (since no other information on the lead is unique), and the description (phone text). A contact for the log must be specified. If the lead is also the contact (and not a real contact), then leave the first, last, and phone fields blank, and this will use the lead as the contact. The length of the phone call (in seconds) must be supplied.

There are a variety of optional items that can be set, including the action type of the call, when the call started, and who logged the call.

The API can also generate a time bomb (for business rule notification).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


LogLeadPhone(LogLeadPhoneSetup) Method | fcSDK Documentation

LogLeadPhone(LogLeadPhoneSetup) Method

Setup object for API invocation.

Log a phone call for a Lead. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function LogLeadPhone( _
   ByVal _setupParam_ LogLeadPhoneSetup _
) As ToolkitResult

public ToolkitResult LogLeadPhone(
   LogLeadPhoneSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the PhoneLog.

Remarks

The objid of the lead must be specified (since no other information on the lead is unique), and the description (phone text). A contact for the log must be specified. If the lead is also the contact (and not a real contact), then leave the first, last, and phone fields blank, and this will use the lead as the contact. The length of the phone call (in seconds) must be supplied.

There are a variety of optional items that can be set, including the action type of the call, when the call started, and who logged the call.

The API can also generate a time bomb (for business rule notification).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List
LogLeadPhoneSetup Class


LogLeadPhone(LogLeadPhoneSetup,IDbTransaction) Method | fcSDK Documentation

LogLeadPhone(LogLeadPhoneSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Log a phone call for a Lead. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function LogLeadPhone( _
   ByVal _setupParam_ As LogLeadPhoneSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult LogLeadPhone(
   LogLeadPhoneSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


MoveActionItem Method | fcSDK Documentation

MoveActionItem Method

Move the ActionItem from one WipBin to another WipBin. This overload takes a set of required parameters for the API.

Move the ActionItem from one WipBin to another WipBin.

Overload List

Overload | Description
MoveActionItem(String,String) | Move the ActionItem from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
MoveActionItem(MoveActionItemSetup) | Move the ActionItem from one WipBin to another WipBin. This overload takes a setup object.
MoveActionItem(MoveActionItemSetup,IDbTransaction) | Move the ActionItem from one WipBin to another WipBin. This overload takes a setup object and a database transaction.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the ActionItem, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
MoveActionItemSetup Class


MoveActionItem(String,String) Method | fcSDK Documentation

MoveActionItem(String,String) Method

ActionItem Identifier.

The new WipBin into which the ActionItem is to be moved.

Move the ActionItem from one WipBin to another WipBin. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function MoveActionItem( _
   ByVal _actionItemIDNum_ As String, _
   ByVal _newWipBin_ As String _
) As ToolkitResult

public ToolkitResult MoveActionItem(
   string _actionItemIDNum_,
   string _newWipBin_
)

Parameters

actionItemIDNum

ActionItem Identifier.

newWipBin

The new WipBin into which the ActionItem is to be moved.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the ActionItem, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


MoveActionItem(MoveActionItemSetup) Method | fcSDK Documentation

MoveActionItem(MoveActionItemSetup) Method

Setup object for API invocation.

Move the ActionItem from one WipBin to another WipBin. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function MoveActionItem( _
   ByVal _setupParam_ MoveActionItemSetup _
) As ToolkitResult

public ToolkitResult MoveActionItem(
   MoveActionItemSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the ActionItem, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List
MoveActionItemSetup Class


MoveActionItem(MoveActionItemSetup,IDbTransaction) Method | fcSDK Documentation

MoveActionItem(MoveActionItemSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Move the ActionItem from one WipBin to another WipBin. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function MoveActionItem( _
   ByVal _setupParam_ As MoveActionItemSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult MoveActionItem(
   MoveActionItemSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the ActionItem, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


MoveOpportunity Method | fcSDK Documentation

MoveOpportunity Method

Move the Opportunity from one WipBin to another WipBin. This overload takes a set of required parameters for the API.

Move the Opportunity from one WipBin to another WipBin.

Overload List

Overload | Description
MoveOpportunity(String,String) | Move the Opportunity from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
MoveOpportunity(MoveOpportunitySetup) | Move the Opportunity from one WipBin to another WipBin. This overload takes a setup object.
MoveOpportunity(MoveOpportunitySetup,IDbTransaction) | Move the Opportunity from one WipBin to another WipBin. This overload takes a setup object and a database transaction.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the Opportunity, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
MoveOpportunitySetup Class


MoveOpportunity(String,String) Method | fcSDK Documentation

MoveOpportunity(String,String) Method

Opportunity Identifier.

The new WipBin into which the Opportunity is to be moved.

Move the Opportunity from one WipBin to another WipBin. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function MoveOpportunity( _
   ByVal _opportunityIDNum_ As String, _
   ByVal _newWipBin_ As String _
) As ToolkitResult

public ToolkitResult MoveOpportunity(
   string _opportunityIDNum_,
   string _newWipBin_
)

Parameters

opportunityIDNum

Opportunity Identifier.

newWipBin

The new WipBin into which the Opportunity is to be moved.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the Opportunity, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


MoveOpportunity(MoveOpportunitySetup) Method | fcSDK Documentation

MoveOpportunity(MoveOpportunitySetup) Method

Setup object for API invocation.

Move the Opportunity from one WipBin to another WipBin. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function MoveOpportunity( _
   ByVal _setupParam_ MoveOpportunitySetup _
) As ToolkitResult

public ToolkitResult MoveOpportunity(
   MoveOpportunitySetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the Opportunity, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List
MoveOpportunitySetup Class


MoveOpportunity(MoveOpportunitySetup,IDbTransaction) Method | fcSDK Documentation

MoveOpportunity(MoveOpportunitySetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Move the Opportunity from one WipBin to another WipBin. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function MoveOpportunity( _
   ByVal _setupParam_ As MoveOpportunitySetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult MoveOpportunity(
   MoveOpportunitySetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the Opportunity, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


MoveQuote Method (SalesToolkit) | fcSDK Documentation

MoveQuote Method (SalesToolkit)

Move the Quote from one WipBin to another WipBin. This overload takes a set of required parameters for the API.

Move the Quote from one WipBin to another WipBin.

Overload List

Overload | Description
MoveQuote(String,String) | Move the Quote from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
MoveQuote(MoveQuoteSetup) | Move the Quote from one WipBin to another WipBin. This overload takes a setup object.
MoveQuote(MoveQuoteSetup,IDbTransaction) | Move the Quote from one WipBin to another WipBin. This overload takes a setup object and a database transaction.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the Quote, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
MoveQuoteSetup Class


MoveQuote(String,String) Method | fcSDK Documentation

MoveQuote(String,String) Method

Quote Identifier.

The new WipBin into which the Quote is to be moved.

Move the Quote from one WipBin to another WipBin. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function MoveQuote( _
   ByVal _quoteIDNum_ As String, _
   ByVal _newWipBin_ As String _
) As ToolkitResult

public ToolkitResult MoveQuote(
   string _quoteIDNum_,
   string _newWipBin_
)

Parameters

quoteIDNum

Quote Identifier.

newWipBin

The new WipBin into which the Quote is to be moved.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the Quote, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


MoveQuote(MoveQuoteSetup) Method | fcSDK Documentation

MoveQuote(MoveQuoteSetup) Method

Setup object for API invocation.

Move the Quote from one WipBin to another WipBin. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function MoveQuote( _
   ByVal _setupParam_ MoveQuoteSetup _
) As ToolkitResult

public ToolkitResult MoveQuote(
   MoveQuoteSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the Quote, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List
MoveQuoteSetup Class


MoveQuote(MoveQuoteSetup,IDbTransaction) Method | fcSDK Documentation

MoveQuote(MoveQuoteSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Move the Quote from one WipBin to another WipBin. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function MoveQuote( _
   ByVal _setupParam_ As MoveQuoteSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult MoveQuote(
   MoveQuoteSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the Quote, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


RejectActionItem Method | fcSDK Documentation

RejectActionItem Method

Reject the ActionItem from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.

Reject the ActionItem from the queue in which it currently resides, and return it to the owner.

Overload List

Overload | Description
RejectActionItem(String) | Reject the ActionItem from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.
RejectActionItem(RejectActionItemSetup) | Reject the ActionItem from the queue in which it currently resides, and return it to the owner. This overload takes a setup object.
RejectActionItem(RejectActionItemSetup,IDbTransaction) | Reject the ActionItem from the queue in which it currently resides, and return it to the owner. This overload takes a setup object and a database transaction.

Remarks

The ActionItem must be in open condition, and currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
RejectActionItemSetup Class


RejectActionItem(String) Method | fcSDK Documentation

RejectActionItem(String) Method

ActionItem Identifier.

Reject the ActionItem from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function RejectActionItem( _
   ByVal _actionItemIDNum_ As String _
) As ToolkitResult

public ToolkitResult RejectActionItem(
   string _actionItemIDNum_
)

Parameters

actionItemIDNum

ActionItem Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The ActionItem must be in open condition, and currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


RejectActionItem(RejectActionItemSetup) Method | fcSDK Documentation

RejectActionItem(RejectActionItemSetup) Method

Setup object for API invocation.

Reject the ActionItem from the queue in which it currently resides, and return it to the owner. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function RejectActionItem( _
   ByVal _setupParam_ RejectActionItemSetup _
) As ToolkitResult

public ToolkitResult RejectActionItem(
   RejectActionItemSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The ActionItem must be in open condition, and currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List
RejectActionItemSetup Class


RejectActionItem(RejectActionItemSetup,IDbTransaction) Method | fcSDK Documentation

RejectActionItem(RejectActionItemSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Reject the ActionItem from the queue in which it currently resides, and return it to the owner. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function RejectActionItem( _
   ByVal _setupParam_ As RejectActionItemSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult RejectActionItem(
   RejectActionItemSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The ActionItem must be in open condition, and currently dispatched to a queue.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


RejectOpportunity Method | fcSDK Documentation

RejectOpportunity Method

Reject the Opportunity from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.

Reject the Opportunity from the queue in which it currently resides, and return it to the owner.

Overload List

Overload | Description
RejectOpportunity(String) | Reject the Opportunity from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.
RejectOpportunity(RejectOpportunitySetup) | Reject the Opportunity from the queue in which it currently resides, and return it to the owner. This overload takes a setup object.
RejectOpportunity(RejectOpportunitySetup,IDbTransaction) | Reject the Opportunity from the queue in which it currently resides, and return it to the owner. This overload takes a setup object and a database transaction.

Remarks

The Opportunity must be in open condition, and currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
RejectOpportunitySetup Class


RejectOpportunity(String) Method | fcSDK Documentation

RejectOpportunity(String) Method

Opportunity Identifier.

Reject the Opportunity from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function RejectOpportunity( _
   ByVal _opportunityIDNum_ As String _
) As ToolkitResult

public ToolkitResult RejectOpportunity(
   string _opportunityIDNum_
)

Parameters

opportunityIDNum

Opportunity Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Opportunity must be in open condition, and currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


RejectOpportunity(RejectOpportunitySetup) Method | fcSDK Documentation

RejectOpportunity(RejectOpportunitySetup) Method

Setup object for API invocation.

Reject the Opportunity from the queue in which it currently resides, and return it to the owner. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function RejectOpportunity( _
   ByVal _setupParam_ RejectOpportunitySetup _
) As ToolkitResult

public ToolkitResult RejectOpportunity(
   RejectOpportunitySetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Opportunity must be in open condition, and currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List
RejectOpportunitySetup Class


RejectOpportunity(RejectOpportunitySetup,IDbTransaction) Method | fcSDK Documentation

RejectOpportunity(RejectOpportunitySetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Reject the Opportunity from the queue in which it currently resides, and return it to the owner. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function RejectOpportunity( _
   ByVal _setupParam_ As RejectOpportunitySetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult RejectOpportunity(
   RejectOpportunitySetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Opportunity must be in open condition, and currently dispatched to a queue.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


RejectQuote Method (SalesToolkit) | fcSDK Documentation

RejectQuote Method (SalesToolkit)

Reject the Quote from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.

Reject the Quote from the queue in which it currently resides, and return it to the owner.

Overload List

Overload | Description
RejectQuote(String) | Reject the Quote from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.
RejectQuote(RejectQuoteSetup) | Reject the Quote from the queue in which it currently resides, and return it to the owner. This overload takes a setup object.
RejectQuote(RejectQuoteSetup,IDbTransaction) | Reject the Quote from the queue in which it currently resides, and return it to the owner. This overload takes a setup object and a database transaction.

Remarks

The Quote must be in open condition, and currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
RejectQuoteSetup Class


RejectQuote(String) Method | fcSDK Documentation

RejectQuote(String) Method

Quote Identifier.

Reject the Quote from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function RejectQuote( _
   ByVal _quoteIDNum_ As String _
) As ToolkitResult

public ToolkitResult RejectQuote(
   string _quoteIDNum_
)

Parameters

quoteIDNum

Quote Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Quote must be in open condition, and currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


RejectQuote(RejectQuoteSetup) Method | fcSDK Documentation

RejectQuote(RejectQuoteSetup) Method

Setup object for API invocation.

Reject the Quote from the queue in which it currently resides, and return it to the owner. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function RejectQuote( _
   ByVal _setupParam_ RejectQuoteSetup _
) As ToolkitResult

public ToolkitResult RejectQuote(
   RejectQuoteSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Quote must be in open condition, and currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List
RejectQuoteSetup Class


RejectQuote(RejectQuoteSetup,IDbTransaction) Method | fcSDK Documentation

RejectQuote(RejectQuoteSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Reject the Quote from the queue in which it currently resides, and return it to the owner. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function RejectQuote( _
   ByVal _setupParam_ As RejectQuoteSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult RejectQuote(
   RejectQuoteSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Quote must be in open condition, and currently dispatched to a queue.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


ReopenOpportunity Method | fcSDK Documentation

ReopenOpportunity Method

Causes the specified Opportunity to be reopened. This overload takes a set of required parameters for the API.

Causes the specified Opportunity to be reopened.

Overload List

Overload | Description
ReopenOpportunity(String) | Causes the specified Opportunity to be reopened. This overload takes a set of required parameters for the API.
ReopenOpportunity(ReopenOpportunitySetup) | Causes the specified Opportunity to be reopened. This overload takes a setup object.
ReopenOpportunity(ReopenOpportunitySetup,IDbTransaction) | Causes the specified Opportunity to be reopened. This overload takes a setup object and a database transaction.

Remarks

The status may be specified (in Open Lead condition) for the Opportunity, as well as the user name of the opener, and the date/time of the reopen. The WIPBIN to place the opportunity in may be specified. The API can also generate a time bomb (for business rule notification).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
ReopenOpportunitySetup Class


ReopenOpportunity(String) Method | fcSDK Documentation

ReopenOpportunity(String) Method

Opportunity Identifier.

Causes the specified Opportunity to be reopened. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function ReopenOpportunity( _
   ByVal _opportunityIDNum_ As String _
) As ToolkitResult

public ToolkitResult ReopenOpportunity(
   string _opportunityIDNum_
)

Parameters

opportunityIDNum

Opportunity Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The status may be specified (in Open Lead condition) for the Opportunity, as well as the user name of the opener, and the date/time of the reopen. The WIPBIN to place the opportunity in may be specified. The API can also generate a time bomb (for business rule notification).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


ReopenOpportunity(ReopenOpportunitySetup) Method | fcSDK Documentation

ReopenOpportunity(ReopenOpportunitySetup) Method

Setup object for API invocation.

Causes the specified Opportunity to be reopened. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function ReopenOpportunity( _
   ByVal _setupParam_ ReopenOpportunitySetup _
) As ToolkitResult

public ToolkitResult ReopenOpportunity(
   ReopenOpportunitySetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The status may be specified (in Open Lead condition) for the Opportunity, as well as the user name of the opener, and the date/time of the reopen. The WIPBIN to place the opportunity in may be specified. The API can also generate a time bomb (for business rule notification).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List
ReopenOpportunitySetup Class


ReopenOpportunity(ReopenOpportunitySetup,IDbTransaction) Method | fcSDK Documentation

ReopenOpportunity(ReopenOpportunitySetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Causes the specified Opportunity to be reopened. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function ReopenOpportunity( _
   ByVal _setupParam_ As ReopenOpportunitySetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult ReopenOpportunity(
   ReopenOpportunitySetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The status may be specified (in Open Lead condition) for the Opportunity, as well as the user name of the opener, and the date/time of the reopen. The WIPBIN to place the opportunity in may be specified. The API can also generate a time bomb (for business rule notification).

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


UpdateActionItem Method | fcSDK Documentation

UpdateActionItem Method

Update an existing Action Item. This overload takes a setup object.

Update an existing Action Item.

Overload List

Overload | Description
UpdateActionItem(UpdateActionItemSetup) | Update an existing Action Item. This overload takes a setup object.
UpdateActionItem(UpdateActionItemSetup,IDbTransaction) | Update an existing Action Item. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
UpdateActionItemSetup Class


UpdateActionItem(UpdateActionItemSetup) Method | fcSDK Documentation

UpdateActionItem(UpdateActionItemSetup) Method

Setup object for API invocation.

Update an existing Action Item. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function UpdateActionItem( _
   ByVal _setupParam_ UpdateActionItemSetup _
) As ToolkitResult

public ToolkitResult UpdateActionItem(
   UpdateActionItemSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • IDNum - The IDNum of the ActionItem.
  • Objid - The Objid of the ActionItem.

Remarks

Virtually all of the data is optional – only the Action Item ID is required. For most of the input fields, blank values if will result in no change to the existing Action Item. To clear a data item (for example, the contact), set the data field to “CLEAR”. It is possible to modify the title, notes, contact, account, lead, opportunity, task type, priority, status (within the same condition), start date, and the completion date.

To relate a contact to the action item, supply all three of the contact fields. Likewise, to associate a Lead to the Action Item supply both lead fields.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List
UpdateActionItemSetup Class


UpdateActionItem(UpdateActionItemSetup,IDbTransaction) Method | fcSDK Documentation

UpdateActionItem(UpdateActionItemSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Update an existing Action Item. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdateActionItem( _
   ByVal _setupParam_ As UpdateActionItemSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdateActionItem(
   UpdateActionItemSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


UpdateLead Method | fcSDK Documentation

UpdateLead Method

Used to update a Lead. This overload takes a setup object.

Used to update a Lead.

Overload List

Overload | Description
UpdateLead(UpdateLeadSetup) | Used to update a Lead. This overload takes a setup object.
UpdateLead(UpdateLeadSetup,IDbTransaction) | Used to update a Lead. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
UpdateLeadSetup Class


UpdateLead(UpdateLeadSetup) Method | fcSDK Documentation

UpdateLead(UpdateLeadSetup) Method

Setup object for API invocation.

Used to update a Lead. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function UpdateLead( _
   ByVal _setupParam_ UpdateLeadSetup _
) As ToolkitResult

public ToolkitResult UpdateLead(
   UpdateLeadSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Lead.

Remarks

The objid of the Lead is required.

For updates, if data is specified it it will be set. If left blank (“”), the current value is retained. If the string “CLEAR” is used for a value, the value is cleared. A few items (such as lead source and contact role) cannot be cleared.

The user who updated the lead, and the date/time of the update can be specified. The API can also generate a time bomb (for business rules).

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List
UpdateLeadSetup Class


UpdateLead(UpdateLeadSetup,IDbTransaction) Method | fcSDK Documentation

UpdateLead(UpdateLeadSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Used to update a Lead. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdateLead( _
   ByVal _setupParam_ As UpdateLeadSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdateLead(
   UpdateLeadSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


UpdateOpportunity Method | fcSDK Documentation

UpdateOpportunity Method

Update an Opportunity. This overload takes a setup object.

Update an Opportunity.

Overload List

Overload | Description
UpdateOpportunity(UpdateOpportunitySetup) | Update an Opportunity. This overload takes a setup object.
UpdateOpportunity(UpdateOpportunitySetup,IDbTransaction) | Update an Opportunity. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
UpdateOpportunitySetup Class


UpdateOpportunity(UpdateOpportunitySetup) Method | fcSDK Documentation

UpdateOpportunity(UpdateOpportunitySetup) Method

Setup object for API invocation.

Update an Opportunity. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function UpdateOpportunity( _
   ByVal _setupParam_ UpdateOpportunitySetup _
) As ToolkitResult

public ToolkitResult UpdateOpportunity(
   UpdateOpportunitySetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The id of the opportunity must be specified. All other data is optional. The account, contact, territory, stage, source, currency, and process may be specified. Also, an amount and a probability may be specified. The API can generate a time bomb for business rules, or not.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List
UpdateOpportunitySetup Class


UpdateOpportunity(UpdateOpportunitySetup,IDbTransaction) Method | fcSDK Documentation

UpdateOpportunity(UpdateOpportunitySetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Update an Opportunity. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdateOpportunity( _
   ByVal _setupParam_ As UpdateOpportunitySetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdateOpportunity(
   UpdateOpportunitySetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


YankActionItem Method | fcSDK Documentation

YankActionItem Method

Yank the ActionItem from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.

Yank the ActionItem from its current location to a new owner's WipBin.

Overload List

Overload | Description
YankActionItem(String) | Yank the ActionItem from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.
YankActionItem(YankActionItemSetup) | Yank the ActionItem from its current location to a new owner's WipBin. This overload takes a setup object.
YankActionItem(YankActionItemSetup,IDbTransaction) | Yank the ActionItem from its current location to a new owner's WipBin. This overload takes a setup object and a database transaction.

Remarks

The WipBin to place the ActionItem in may also be specified. This is augmented function from base Clarify, where the ActionItem is always placed in the default WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
YankActionItemSetup Class


YankActionItem(String) Method | fcSDK Documentation

YankActionItem(String) Method

ActionItem Identifier.

Yank the ActionItem from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function YankActionItem( _
   ByVal _actionItemIDNum_ As String _
) As ToolkitResult

public ToolkitResult YankActionItem(
   string _actionItemIDNum_
)

Parameters

actionItemIDNum

ActionItem Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The WipBin to place the ActionItem in may also be specified. This is augmented function from base Clarify, where the ActionItem is always placed in the default WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


YankActionItem(YankActionItemSetup) Method | fcSDK Documentation

YankActionItem(YankActionItemSetup) Method

Setup object for API invocation.

Yank the ActionItem from its current location to a new owner's WipBin. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function YankActionItem( _
   ByVal _setupParam_ YankActionItemSetup _
) As ToolkitResult

public ToolkitResult YankActionItem(
   YankActionItemSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The WipBin to place the ActionItem in may also be specified. This is augmented function from base Clarify, where the ActionItem is always placed in the default WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List
YankActionItemSetup Class


YankActionItem(YankActionItemSetup,IDbTransaction) Method | fcSDK Documentation

YankActionItem(YankActionItemSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Yank the ActionItem from its current location to a new owner's WipBin. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function YankActionItem( _
   ByVal _setupParam_ As YankActionItemSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult YankActionItem(
   YankActionItemSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The WipBin to place the ActionItem in may also be specified. This is augmented function from base Clarify, where the ActionItem is always placed in the default WipBin.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


YankOpportunity Method | fcSDK Documentation

YankOpportunity Method

Yank the Opportunity from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.

Yank the Opportunity from its current location to a new owner's WipBin.

Overload List

Overload | Description
YankOpportunity(String) | Yank the Opportunity from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.
YankOpportunity(YankOpportunitySetup) | Yank the Opportunity from its current location to a new owner's WipBin. This overload takes a setup object.
YankOpportunity(YankOpportunitySetup,IDbTransaction) | Yank the Opportunity from its current location to a new owner's WipBin. This overload takes a setup object and a database transaction.

Remarks

The WipBin to place the Opportunity in may also be specified. This is augmented function from base Clarify, where the Opportunity is always placed in the default WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
YankOpportunitySetup Class


YankOpportunity(String) Method | fcSDK Documentation

YankOpportunity(String) Method

Opportunity Identifier.

Yank the Opportunity from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function YankOpportunity( _
   ByVal _opportunityIDNum_ As String _
) As ToolkitResult

public ToolkitResult YankOpportunity(
   string _opportunityIDNum_
)

Parameters

opportunityIDNum

Opportunity Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The WipBin to place the Opportunity in may also be specified. This is augmented function from base Clarify, where the Opportunity is always placed in the default WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


YankOpportunity(YankOpportunitySetup) Method | fcSDK Documentation

YankOpportunity(YankOpportunitySetup) Method

Setup object for API invocation.

Yank the Opportunity from its current location to a new owner's WipBin. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function YankOpportunity( _
   ByVal _setupParam_ YankOpportunitySetup _
) As ToolkitResult

public ToolkitResult YankOpportunity(
   YankOpportunitySetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The WipBin to place the Opportunity in may also be specified. This is augmented function from base Clarify, where the Opportunity is always placed in the default WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List
YankOpportunitySetup Class


YankOpportunity(YankOpportunitySetup,IDbTransaction) Method | fcSDK Documentation

YankOpportunity(YankOpportunitySetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Yank the Opportunity from its current location to a new owner's WipBin. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function YankOpportunity( _
   ByVal _setupParam_ As YankOpportunitySetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult YankOpportunity(
   YankOpportunitySetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The WipBin to place the Opportunity in may also be specified. This is augmented function from base Clarify, where the Opportunity is always placed in the default WipBin.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


YankQuote Method (SalesToolkit) | fcSDK Documentation

YankQuote Method (SalesToolkit)

Yank the Quote from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.

Yank the Quote from its current location to a new owner's WipBin.

Overload List

Overload | Description
YankQuote(String) | Yank the Quote from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.
YankQuote(YankQuoteSetup) | Yank the Quote from its current location to a new owner's WipBin. This overload takes a setup object.
YankQuote(YankQuoteSetup,IDbTransaction) | Yank the Quote from its current location to a new owner's WipBin. This overload takes a setup object and a database transaction.

Remarks

The WipBin to place the Quote in may also be specified. This is augmented function from base Clarify, where the Quote is always placed in the default WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
YankQuoteSetup Class


YankQuote(String) Method | fcSDK Documentation

YankQuote(String) Method

Quote Identifier.

Yank the Quote from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function YankQuote( _
   ByVal _quoteIDNum_ As String _
) As ToolkitResult

public ToolkitResult YankQuote(
   string _quoteIDNum_
)

Parameters

quoteIDNum

Quote Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The WipBin to place the Quote in may also be specified. This is augmented function from base Clarify, where the Quote is always placed in the default WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


YankQuote(YankQuoteSetup) Method | fcSDK Documentation

YankQuote(YankQuoteSetup) Method

Setup object for API invocation.

Yank the Quote from its current location to a new owner's WipBin. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function YankQuote( _
   ByVal _setupParam_ YankQuoteSetup _
) As ToolkitResult

public ToolkitResult YankQuote(
   YankQuoteSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The WipBin to place the Quote in may also be specified. This is augmented function from base Clarify, where the Quote is always placed in the default WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List
YankQuoteSetup Class


YankQuote(YankQuoteSetup,IDbTransaction) Method | fcSDK Documentation

YankQuote(YankQuoteSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Yank the Quote from its current location to a new owner's WipBin. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function YankQuote( _
   ByVal _setupParam_ As YankQuoteSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult YankQuote(
   YankQuoteSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The WipBin to place the Quote in may also be specified. This is augmented function from base Clarify, where the Quote is always placed in the default WipBin.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members
Overload List


ApplicationClock Property (SalesToolkit) | fcSDK Documentation

ApplicationClock Property (SalesToolkit)

Syntax

'Declaration

Public Property ApplicationClock As IApplicationClock

public IApplicationClock ApplicationClock {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkit Class
SalesToolkit Members


SalesToolkitBase Class | fcSDK Documentation

SalesToolkitBase Class

Syntax

'Declaration

Public MustInherit Class SalesToolkitBase
   Inherits FChoice.Toolkits.Clarify.ToolkitBase

public abstract class SalesToolkitBase : FChoice.Toolkits.Clarify.ToolkitBase

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.ToolkitBase
FChoice.Toolkits.Clarify.Sales.SalesToolkitBase
FChoice.Toolkits.Clarify.Sales.SalesToolkit

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

SalesToolkitBase Members
FChoice.Toolkits.Clarify.Sales Namespace


SalesToolkitBase Class Members | fcSDK Documentation

SalesToolkitBase Class Members

The following tables list the members exposed by SalesToolkitBase.

Public Properties

 | Name | Description
Public Property | ImpersonatorUsername |

Public Methods

 | Name | Description
Public Method | ChangeOpportunityStage | Overloaded.

Reference

SalesToolkitBase Class
FChoice.Toolkits.Clarify.Sales Namespace


ChangeOpportunityStage Method | fcSDK Documentation

ChangeOpportunityStage Method

Overload List

Overload | Description
ChangeOpportunityStage(String,OpportunityStage) |
ChangeOpportunityStage(ChangeOpportunityStageSetup) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkitBase Class
SalesToolkitBase Members
ChangeOpportunityStageSetup Class


ChangeOpportunityStage(String,OpportunityStage) Method | fcSDK Documentation

ChangeOpportunityStage(String,OpportunityStage) Method

Opportunity Identifier.

The new sales stage for the Opportunity.

Syntax

'Declaration

Public Overloads Function ChangeOpportunityStage( _
   ByVal _opportunityIDNum_ As String, _
   ByVal _stage_ As OpportunityStage _
) As ToolkitResult

public ToolkitResult ChangeOpportunityStage(
   string _opportunityIDNum_,
   OpportunityStage _stage_
)

Parameters

opportunityIDNum

Opportunity Identifier.

stage

The new sales stage for the Opportunity.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkitBase Class
SalesToolkitBase Members
Overload List


ChangeOpportunityStage(ChangeOpportunityStageSetup) Method | fcSDK Documentation

ChangeOpportunityStage(ChangeOpportunityStageSetup) Method

Setup object for API invocation.

Syntax

'Declaration

Public Overloads Function ChangeOpportunityStage( _
   ByVal _setupParam_ ChangeOpportunityStageSetup _
) As ToolkitResult

public ToolkitResult ChangeOpportunityStage(
   ChangeOpportunityStageSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkitBase Class
SalesToolkitBase Members
Overload List
ChangeOpportunityStageSetup Class


ImpersonatorUsername Property (SalesToolkitBase) | fcSDK Documentation

ImpersonatorUsername Property (SalesToolkitBase)

Syntax

'Declaration

Public Property ImpersonatorUsername As String

public string ImpersonatorUsername {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SalesToolkitBase Class
SalesToolkitBase Members


UpdateActionItemSetup Class | fcSDK Documentation

UpdateActionItemSetup Class

Used by the UpdateActionItem method as setup data for invocation.

Syntax

'Declaration

Public Class UpdateActionItemSetup

public class UpdateActionItemSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.UpdateActionItemSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdateActionItemSetup Members
FChoice.Toolkits.Clarify.Sales Namespace
UpdateActionItem(UpdateActionItemSetup) Method


UpdateActionItemSetup Class Members | fcSDK Documentation

UpdateActionItemSetup Class Members

The following tables list the members exposed by UpdateActionItemSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdateActionItemSetup Constructor | Initializes a new instance of the UpdateActionItemSetup class.

Public Properties

 | Name | Description
Public Property | AccountName | Name of the account to relate to the action item.
Public Property | ActionItemIDNum | ActionItem Identifier.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CompleteDate | The DateTime the Action Item was completed. If not set, the current time is used.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | DueDate | The DateTime the Action Item was due. If not set, the current time is used.
Public Property | LeadFirstName | First name of the lead for the action item.
Public Property | LeadLastName | Last name of the lead for the action item.
Public Property | Notes | Action Item notes.
Public Property | OpportunityIDNum | Oppertunity Identifier.
Public Property | Priority | Element from the 'Task Priority' application list. If not set, the default list value is used.
Public Property | StartDate | The DateTime the Action Item was started. If not set, the current time is used.
Public Property | Status | Element from the 'Open Action Item' application list. If not set, the default list value is used.
Public Property | TaskType | Element from the 'Task Type' application list. If not set, the default list value is used.
Public Property | Title | Action Item title.
Public Property | UpdateDate | The DateTime the Action Item was updated. If not set, the current time is used.

Reference

UpdateActionItemSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
UpdateActionItem(UpdateActionItemSetup) Method


UpdateActionItemSetup Constructor | fcSDK Documentation

UpdateActionItemSetup Constructor

ActionItem Identifier.

Initializes a new instance of the UpdateActionItemSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _actionItemIDNum_ As String _
)

[ConstructorIndexAttribute()]
public UpdateActionItemSetup(
   string _actionItemIDNum_
)

Parameters

actionItemIDNum

ActionItem Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateActionItemSetup Class
UpdateActionItemSetup Members


AccountName Property (UpdateActionItemSetup) | fcSDK Documentation

AccountName Property (UpdateActionItemSetup)

Name of the account to relate to the action item.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AccountName As String

[PropertyBitValueAttribute()]
public string AccountName {get; set;}

Remarks

If the property is set to an empty string the relation to the current Account will be removed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateActionItemSetup Class
UpdateActionItemSetup Members


ActionItemIDNum Property (UpdateActionItemSetup) | fcSDK Documentation

ActionItemIDNum Property (UpdateActionItemSetup)

ActionItem Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ActionItemIDNum As String

[PropertyBitValueAttribute()]
public string ActionItemIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateActionItemSetup Class
UpdateActionItemSetup Members


AdditionalFields Property (UpdateActionItemSetup) | fcSDK Documentation

AdditionalFields Property (UpdateActionItemSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateActionItemSetup Class
UpdateActionItemSetup Members


CompleteDate Property (UpdateActionItemSetup) | fcSDK Documentation

CompleteDate Property (UpdateActionItemSetup)

The DateTime the Action Item was completed. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CompleteDate As Date

[PropertyBitValueAttribute()]
public DateTime CompleteDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateActionItemSetup Class
UpdateActionItemSetup Members


ContactFirstName Property (UpdateActionItemSetup) | fcSDK Documentation

ContactFirstName Property (UpdateActionItemSetup)

Contact's first name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactFirstName As String

[PropertyBitValueAttribute()]
public string ContactFirstName {get; set;}

Remarks

If this property is set to an empty string the relation to the current Contact will be removed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateActionItemSetup Class
UpdateActionItemSetup Members


ContactLastName Property (UpdateActionItemSetup) | fcSDK Documentation

ContactLastName Property (UpdateActionItemSetup)

Contact's last name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactLastName As String

[PropertyBitValueAttribute()]
public string ContactLastName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateActionItemSetup Class
UpdateActionItemSetup Members


ContactPhone Property (UpdateActionItemSetup) | fcSDK Documentation

ContactPhone Property (UpdateActionItemSetup)

Contact's phone number.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactPhone As String

[PropertyBitValueAttribute()]
public string ContactPhone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateActionItemSetup Class
UpdateActionItemSetup Members


DueDate Property (UpdateActionItemSetup) | fcSDK Documentation

DueDate Property (UpdateActionItemSetup)

The DateTime the Action Item was due. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property DueDate As Date

[PropertyBitValueAttribute()]
public DateTime DueDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateActionItemSetup Class
UpdateActionItemSetup Members


LeadFirstName Property (UpdateActionItemSetup) | fcSDK Documentation

LeadFirstName Property (UpdateActionItemSetup)

First name of the lead for the action item.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LeadFirstName As String

[PropertyBitValueAttribute()]
public string LeadFirstName {get; set;}

Remarks

If this property is set to an empty string the relation to the current Contact will be removed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateActionItemSetup Class
UpdateActionItemSetup Members


LeadLastName Property (UpdateActionItemSetup) | fcSDK Documentation

LeadLastName Property (UpdateActionItemSetup)

Last name of the lead for the action item.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LeadLastName As String

[PropertyBitValueAttribute()]
public string LeadLastName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateActionItemSetup Class
UpdateActionItemSetup Members


Notes Property (UpdateActionItemSetup) | fcSDK Documentation

Notes Property (UpdateActionItemSetup)

Action Item notes.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Remarks

If this property has not been set no change will occur. If the property is set, even to an empty string, that value reflected in the update.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateActionItemSetup Class
UpdateActionItemSetup Members


OpportunityIDNum Property (UpdateActionItemSetup) | fcSDK Documentation

OpportunityIDNum Property (UpdateActionItemSetup)

Oppertunity Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property OpportunityIDNum As String

[PropertyBitValueAttribute()]
public string OpportunityIDNum {get; set;}

Remarks

If this property is set to an empty string the relation to the current Opportunity will be removed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateActionItemSetup Class
UpdateActionItemSetup Members


Priority Property (UpdateActionItemSetup) | fcSDK Documentation

Priority Property (UpdateActionItemSetup)

Element from the 'Task Priority' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Priority As String

[PropertyBitValueAttribute()]
public string Priority {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateActionItemSetup Class
UpdateActionItemSetup Members


StartDate Property (UpdateActionItemSetup) | fcSDK Documentation

StartDate Property (UpdateActionItemSetup)

The DateTime the Action Item was started. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property StartDate As Date

[PropertyBitValueAttribute()]
public DateTime StartDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateActionItemSetup Class
UpdateActionItemSetup Members


Status Property (UpdateActionItemSetup) | fcSDK Documentation

Status Property (UpdateActionItemSetup)

Element from the 'Open Action Item' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Status As String

[PropertyBitValueAttribute()]
public string Status {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateActionItemSetup Class
UpdateActionItemSetup Members


TaskType Property (UpdateActionItemSetup) | fcSDK Documentation

TaskType Property (UpdateActionItemSetup)

Element from the 'Task Type' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property TaskType As String

[PropertyBitValueAttribute()]
public string TaskType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateActionItemSetup Class
UpdateActionItemSetup Members


Title Property (UpdateActionItemSetup) | fcSDK Documentation

Title Property (UpdateActionItemSetup)

Action Item title.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Title As String

[PropertyBitValueAttribute()]
public string Title {get; set;}

Remarks

If this property has not been set no change will occur. If the property is set, even to an empty string, that value reflected in the update.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateActionItemSetup Class
UpdateActionItemSetup Members


UpdateDate Property (UpdateActionItemSetup) | fcSDK Documentation

UpdateDate Property (UpdateActionItemSetup)

The DateTime the Action Item was updated. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UpdateDate As Date

[PropertyBitValueAttribute()]
public DateTime UpdateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateActionItemSetup Class
UpdateActionItemSetup Members


UpdateLeadSetup Class | fcSDK Documentation

UpdateLeadSetup Class

Used by the UpdateLead method as setup data for invocation.

Syntax

'Declaration

Public Class UpdateLeadSetup

public class UpdateLeadSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.UpdateLeadSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdateLeadSetup Members
FChoice.Toolkits.Clarify.Sales Namespace
UpdateLead(UpdateLeadSetup) Method


UpdateLeadSetup Class Members | fcSDK Documentation

UpdateLeadSetup Class Members

The following tables list the members exposed by UpdateLeadSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdateLeadSetup Constructor | Initializes a new instance of the UpdateLeadSetup class.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | Address | Address for the lead.
Public Property | Address2 | Secondary address line for the lead.
Public Property | City | City for the lead.
Public Property | CompanyName | Company name for the lead.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | ContactRole | Element from the 'Contact Role' user list. If not set, the default list value is used.
Public Property | Country | Country for the lead.
Public Property | CreateDate | The DateTime the Lead was created. If not set, the current time is used.
Public Property | Email | Email address for the lead.
Public Property | Fax | Fax number for the lead.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | LeadObjid | The objid of the lead being updated.
Public Property | LeadSource | Name of the lead source for this lead.
Public Property | PostalCode | Postal code for the lead.
Public Property | Rating | Element from the 'Lead Status' application list. If not set, the default list value is used.
Public Property | SiteName | The name of the site for the lead.
Public Property | SiteType | The type of the site for the lead.
Public Property | State | State for the lead.
Public Property | TimeZone | Time Zone for the lead.
Public Property | Title | Title for the lead.
Public Property | UserName | The user who is updating the lead. If not set, the Toolkit session user is used.

Reference

UpdateLeadSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
UpdateLead(UpdateLeadSetup) Method


UpdateLeadSetup Constructor | fcSDK Documentation

UpdateLeadSetup Constructor

The objid of the lead being updated.

Initializes a new instance of the UpdateLeadSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _leadObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public UpdateLeadSetup(
   int _leadObjid_
)

Parameters

leadObjid

The objid of the lead being updated.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateLeadSetup Class
UpdateLeadSetup Members


AdditionalFields Property (UpdateLeadSetup) | fcSDK Documentation

AdditionalFields Property (UpdateLeadSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateLeadSetup Class
UpdateLeadSetup Members


Address Property (UpdateLeadSetup) | fcSDK Documentation

Address Property (UpdateLeadSetup)

Address for the lead.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Address As String

[PropertyBitValueAttribute()]
public string Address {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateLeadSetup Class
UpdateLeadSetup Members


Address2 Property (UpdateLeadSetup) | fcSDK Documentation

Address2 Property (UpdateLeadSetup)

Secondary address line for the lead.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Address2 As String

[PropertyBitValueAttribute()]
public string Address2 {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateLeadSetup Class
UpdateLeadSetup Members


City Property (UpdateLeadSetup) | fcSDK Documentation

City Property (UpdateLeadSetup)

City for the lead.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property City As String

[PropertyBitValueAttribute()]
public string City {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateLeadSetup Class
UpdateLeadSetup Members


CompanyName Property (UpdateLeadSetup) | fcSDK Documentation

CompanyName Property (UpdateLeadSetup)

Company name for the lead.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CompanyName As String

[PropertyBitValueAttribute()]
public string CompanyName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateLeadSetup Class
UpdateLeadSetup Members


ContactFirstName Property (UpdateLeadSetup) | fcSDK Documentation

ContactFirstName Property (UpdateLeadSetup)

Contact's first name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactFirstName As String

[PropertyBitValueAttribute()]
public string ContactFirstName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateLeadSetup Class
UpdateLeadSetup Members


ContactLastName Property (UpdateLeadSetup) | fcSDK Documentation

ContactLastName Property (UpdateLeadSetup)

Contact's last name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactLastName As String

[PropertyBitValueAttribute()]
public string ContactLastName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateLeadSetup Class
UpdateLeadSetup Members


ContactPhone Property (UpdateLeadSetup) | fcSDK Documentation

ContactPhone Property (UpdateLeadSetup)

Contact's phone number.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactPhone As String

[PropertyBitValueAttribute()]
public string ContactPhone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateLeadSetup Class
UpdateLeadSetup Members


ContactRole Property (UpdateLeadSetup) | fcSDK Documentation

ContactRole Property (UpdateLeadSetup)

Element from the 'Contact Role' user list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactRole As String

[PropertyBitValueAttribute()]
public string ContactRole {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateLeadSetup Class
UpdateLeadSetup Members


Country Property (UpdateLeadSetup) | fcSDK Documentation

Country Property (UpdateLeadSetup)

Country for the lead.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Country As String

[PropertyBitValueAttribute()]
public string Country {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateLeadSetup Class
UpdateLeadSetup Members


CreateDate Property (UpdateLeadSetup) | fcSDK Documentation

CreateDate Property (UpdateLeadSetup)

The DateTime the Lead was created. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateLeadSetup Class
UpdateLeadSetup Members


Email Property (UpdateLeadSetup) | fcSDK Documentation

Email Property (UpdateLeadSetup)

Email address for the lead.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Email As String

[PropertyBitValueAttribute()]
public string Email {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateLeadSetup Class
UpdateLeadSetup Members


Fax Property (UpdateLeadSetup) | fcSDK Documentation

Fax Property (UpdateLeadSetup)

Fax number for the lead.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Fax As String

[PropertyBitValueAttribute()]
public string Fax {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateLeadSetup Class
UpdateLeadSetup Members


GenerateTimeBombs Property (UpdateLeadSetup) | fcSDK Documentation

GenerateTimeBombs Property (UpdateLeadSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateLeadSetup Class
UpdateLeadSetup Members


LeadObjid Property (UpdateLeadSetup) | fcSDK Documentation

LeadObjid Property (UpdateLeadSetup)

The objid of the lead being updated.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LeadObjid As Integer

[PropertyBitValueAttribute()]
public int LeadObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateLeadSetup Class
UpdateLeadSetup Members


LeadSource Property (UpdateLeadSetup) | fcSDK Documentation

LeadSource Property (UpdateLeadSetup)

Name of the lead source for this lead.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LeadSource As String

[PropertyBitValueAttribute()]
public string LeadSource {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateLeadSetup Class
UpdateLeadSetup Members


PostalCode Property (UpdateLeadSetup) | fcSDK Documentation

PostalCode Property (UpdateLeadSetup)

Postal code for the lead.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PostalCode As String

[PropertyBitValueAttribute()]
public string PostalCode {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateLeadSetup Class
UpdateLeadSetup Members


Rating Property (UpdateLeadSetup) | fcSDK Documentation

Rating Property (UpdateLeadSetup)

Element from the 'Lead Status' application list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Rating As String

[PropertyBitValueAttribute()]
public string Rating {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateLeadSetup Class
UpdateLeadSetup Members


SiteName Property (UpdateLeadSetup) | fcSDK Documentation

SiteName Property (UpdateLeadSetup)

The name of the site for the lead.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteName As String

[PropertyBitValueAttribute()]
public string SiteName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateLeadSetup Class
UpdateLeadSetup Members


SiteType Property (UpdateLeadSetup) | fcSDK Documentation

SiteType Property (UpdateLeadSetup)

The type of the site for the lead.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteType As LeadSiteType

[PropertyBitValueAttribute()]
public LeadSiteType SiteType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateLeadSetup Class
UpdateLeadSetup Members


State Property (UpdateLeadSetup) | fcSDK Documentation

State Property (UpdateLeadSetup)

State for the lead.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property State As String

[PropertyBitValueAttribute()]
public string State {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateLeadSetup Class
UpdateLeadSetup Members


TimeZone Property (UpdateLeadSetup) | fcSDK Documentation

TimeZone Property (UpdateLeadSetup)

Time Zone for the lead.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property TimeZone As String

[PropertyBitValueAttribute()]
public string TimeZone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateLeadSetup Class
UpdateLeadSetup Members


Title Property (UpdateLeadSetup) | fcSDK Documentation

Title Property (UpdateLeadSetup)

Title for the lead.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Title As String

[PropertyBitValueAttribute()]
public string Title {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateLeadSetup Class
UpdateLeadSetup Members


UserName Property (UpdateLeadSetup) | fcSDK Documentation

UserName Property (UpdateLeadSetup)

The user who is updating the lead. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateLeadSetup Class
UpdateLeadSetup Members


UpdateOpportunitySetup Class | fcSDK Documentation

UpdateOpportunitySetup Class

Used by the UpdateOpportunity method as setup data for invocation.

Syntax

'Declaration

Public Class UpdateOpportunitySetup

public class UpdateOpportunitySetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.UpdateOpportunitySetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdateOpportunitySetup Members
FChoice.Toolkits.Clarify.Sales Namespace
UpdateOpportunity(UpdateOpportunitySetup) Method


UpdateOpportunitySetup Class Members | fcSDK Documentation

UpdateOpportunitySetup Class Members

The following tables list the members exposed by UpdateOpportunitySetup.

Public Constructors

 | Name | Description
Public Constructor | UpdateOpportunitySetup Constructor | Initializes a new instance of the UpdateOpportunitySetup class.

Public Properties

 | Name | Description
Public Property | AccountIDNum | Account Identifier.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | Amount | The amount for the Opportunity.
Public Property | CloseDate | The DateTime the Opportunity was closed. If not set, the current time is used.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | Currency | Name of the currency for the Opportunity.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | LeadSource | Lead source for the opportunity.
Public Property | OpportunityIDNum | Opportunity Identifier.
Public Property | OpportunityName | The name of the Opportunity.
Public Property | Probability | The probability for the Opportunity.
Public Property | Process | The process for the Opportunity.
Public Property | Territory | Name of the territory for the Opportunity.
Public Property | UpdateDate | The DateTime the Opportunity was updated. If not set, the current time is used.
Public Property | UserName | The user who is updating the opportunity. If not set, the Toolkit session user is used.

Reference

UpdateOpportunitySetup Class
FChoice.Toolkits.Clarify.Sales Namespace
UpdateOpportunity(UpdateOpportunitySetup) Method


UpdateOpportunitySetup Constructor | fcSDK Documentation

UpdateOpportunitySetup Constructor

Opportunity Identifier.

Initializes a new instance of the UpdateOpportunitySetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _opportunityIDNum_ As String _
)

[ConstructorIndexAttribute()]
public UpdateOpportunitySetup(
   string _opportunityIDNum_
)

Parameters

opportunityIDNum

Opportunity Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateOpportunitySetup Class
UpdateOpportunitySetup Members


AccountIDNum Property (UpdateOpportunitySetup) | fcSDK Documentation

AccountIDNum Property (UpdateOpportunitySetup)

Account Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AccountIDNum As String

[PropertyBitValueAttribute()]
public string AccountIDNum {get; set;}

Remarks

If this property is set to an empty string the relation to the current Account will be removed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateOpportunitySetup Class
UpdateOpportunitySetup Members


AdditionalFields Property (UpdateOpportunitySetup) | fcSDK Documentation

AdditionalFields Property (UpdateOpportunitySetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateOpportunitySetup Class
UpdateOpportunitySetup Members


Amount Property (UpdateOpportunitySetup) | fcSDK Documentation

Amount Property (UpdateOpportunitySetup)

The amount for the Opportunity.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Amount As Decimal

[PropertyBitValueAttribute()]
public decimal Amount {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateOpportunitySetup Class
UpdateOpportunitySetup Members


CloseDate Property (UpdateOpportunitySetup) | fcSDK Documentation

CloseDate Property (UpdateOpportunitySetup)

The DateTime the Opportunity was closed. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CloseDate As Date

[PropertyBitValueAttribute()]
public DateTime CloseDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateOpportunitySetup Class
UpdateOpportunitySetup Members


ContactFirstName Property (UpdateOpportunitySetup) | fcSDK Documentation

ContactFirstName Property (UpdateOpportunitySetup)

Contact's first name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactFirstName As String

[PropertyBitValueAttribute()]
public string ContactFirstName {get; set;}

Remarks

If this property is set to an empty string the relation to the current Contact will be removed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateOpportunitySetup Class
UpdateOpportunitySetup Members


ContactLastName Property (UpdateOpportunitySetup) | fcSDK Documentation

ContactLastName Property (UpdateOpportunitySetup)

Contact's last name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactLastName As String

[PropertyBitValueAttribute()]
public string ContactLastName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateOpportunitySetup Class
UpdateOpportunitySetup Members


ContactPhone Property (UpdateOpportunitySetup) | fcSDK Documentation

ContactPhone Property (UpdateOpportunitySetup)

Contact's phone number.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactPhone As String

[PropertyBitValueAttribute()]
public string ContactPhone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateOpportunitySetup Class
UpdateOpportunitySetup Members


Currency Property (UpdateOpportunitySetup) | fcSDK Documentation

Currency Property (UpdateOpportunitySetup)

Name of the currency for the Opportunity.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Currency As String

[PropertyBitValueAttribute()]
public string Currency {get; set;}

Remarks

Must be a valid currency from the database. If not specified, the default currency is used.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateOpportunitySetup Class
UpdateOpportunitySetup Members


GenerateTimeBombs Property (UpdateOpportunitySetup) | fcSDK Documentation

GenerateTimeBombs Property (UpdateOpportunitySetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateOpportunitySetup Class
UpdateOpportunitySetup Members


LeadSource Property (UpdateOpportunitySetup) | fcSDK Documentation

LeadSource Property (UpdateOpportunitySetup)

Lead source for the opportunity.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LeadSource As String

[PropertyBitValueAttribute()]
public string LeadSource {get; set;}

Remarks

Must be a valid lead source from the database. If not specified, the default lead source is used.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateOpportunitySetup Class
UpdateOpportunitySetup Members


OpportunityIDNum Property (UpdateOpportunitySetup) | fcSDK Documentation

OpportunityIDNum Property (UpdateOpportunitySetup)

Opportunity Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property OpportunityIDNum As String

[PropertyBitValueAttribute()]
public string OpportunityIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateOpportunitySetup Class
UpdateOpportunitySetup Members


OpportunityName Property (UpdateOpportunitySetup) | fcSDK Documentation

OpportunityName Property (UpdateOpportunitySetup)

The name of the Opportunity.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property OpportunityName As String

[PropertyBitValueAttribute()]
public string OpportunityName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateOpportunitySetup Class
UpdateOpportunitySetup Members


Probability Property (UpdateOpportunitySetup) | fcSDK Documentation

Probability Property (UpdateOpportunitySetup)

The probability for the Opportunity.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Probability As Single

[PropertyBitValueAttribute()]
public float Probability {get; set;}

Remarks

Must be a numeric value between 0 and 1.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateOpportunitySetup Class
UpdateOpportunitySetup Members


Process Property (UpdateOpportunitySetup) | fcSDK Documentation

Process Property (UpdateOpportunitySetup)

The process for the Opportunity.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Process As String

[PropertyBitValueAttribute()]
public string Process {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateOpportunitySetup Class
UpdateOpportunitySetup Members


Territory Property (UpdateOpportunitySetup) | fcSDK Documentation

Territory Property (UpdateOpportunitySetup)

Name of the territory for the Opportunity.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Territory As String

[PropertyBitValueAttribute()]
public string Territory {get; set;}

Remarks

Must be a valid territory from the database. If not specified, the default territory is used.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateOpportunitySetup Class
UpdateOpportunitySetup Members


UpdateDate Property (UpdateOpportunitySetup) | fcSDK Documentation

UpdateDate Property (UpdateOpportunitySetup)

The DateTime the Opportunity was updated. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UpdateDate As Date

[PropertyBitValueAttribute()]
public DateTime UpdateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateOpportunitySetup Class
UpdateOpportunitySetup Members


UserName Property (UpdateOpportunitySetup) | fcSDK Documentation

UserName Property (UpdateOpportunitySetup)

The user who is updating the opportunity. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateOpportunitySetup Class
UpdateOpportunitySetup Members


YankActionItemSetup Class | fcSDK Documentation

YankActionItemSetup Class

Used by the YankActionItem method as setup data for invocation.

Syntax

'Declaration

Public Class YankActionItemSetup

public class YankActionItemSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.YankActionItemSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

YankActionItemSetup Members
FChoice.Toolkits.Clarify.Sales Namespace
YankActionItem(YankActionItemSetup) Method


YankActionItemSetup Class Members | fcSDK Documentation

YankActionItemSetup Class Members

The following tables list the members exposed by YankActionItemSetup.

Public Constructors

 | Name | Description
Public Constructor | YankActionItemSetup Constructor | Initializes a new instance of the YankActionItemSetup class.

Public Properties

 | Name | Description
Public Property | ActionItemIDNum | ActionItem Identifier.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | UserName | The user who has yanked the ActionItem. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the ActionItem. If not set, the UserName's default is used.
Public Property | YankDate | DateTime the ActionItem was yanked. If not set, the current time is used.

Reference

YankActionItemSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
YankActionItem(YankActionItemSetup) Method


YankActionItemSetup Constructor | fcSDK Documentation

YankActionItemSetup Constructor

ActionItem Identifier.

Initializes a new instance of the YankActionItemSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _actionItemIDNum_ As String _
)

[ConstructorIndexAttribute()]
public YankActionItemSetup(
   string _actionItemIDNum_
)

Parameters

actionItemIDNum

ActionItem Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankActionItemSetup Class
YankActionItemSetup Members


ActionItemIDNum Property (YankActionItemSetup) | fcSDK Documentation

ActionItemIDNum Property (YankActionItemSetup)

ActionItem Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ActionItemIDNum As String

[PropertyBitValueAttribute()]
public string ActionItemIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankActionItemSetup Class
YankActionItemSetup Members


GenerateTimeBombs Property (YankActionItemSetup) | fcSDK Documentation

GenerateTimeBombs Property (YankActionItemSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankActionItemSetup Class
YankActionItemSetup Members


UserName Property (YankActionItemSetup) | fcSDK Documentation

UserName Property (YankActionItemSetup)

The user who has yanked the ActionItem. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankActionItemSetup Class
YankActionItemSetup Members


WipBin Property (YankActionItemSetup) | fcSDK Documentation

WipBin Property (YankActionItemSetup)

User's WipBin in which to place the ActionItem. If not set, the UserName's default is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankActionItemSetup Class
YankActionItemSetup Members


YankOpportunitySetup Class | fcSDK Documentation

YankOpportunitySetup Class

Used by the YankOpportunity method as setup data for invocation.

Syntax

'Declaration

Public Class YankOpportunitySetup

public class YankOpportunitySetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.YankOpportunitySetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

YankOpportunitySetup Members
FChoice.Toolkits.Clarify.Sales Namespace
YankOpportunity(YankOpportunitySetup) Method


YankOpportunitySetup Class Members | fcSDK Documentation

YankOpportunitySetup Class Members

The following tables list the members exposed by YankOpportunitySetup.

Public Constructors

 | Name | Description
Public Constructor | YankOpportunitySetup Constructor | Initializes a new instance of the YankOpportunitySetup class.

Public Properties

 | Name | Description
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | OpportunityIDNum | Opportunity Identifier.
Public Property | UserName | The user who has yanked the Opportunity. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Opportunity. If not set, the UserName's default is used.
Public Property | YankDate | DateTime the Opportunity was yanked. If not set, the current time is used.

Reference

YankOpportunitySetup Class
FChoice.Toolkits.Clarify.Sales Namespace
YankOpportunity(YankOpportunitySetup) Method


YankOpportunitySetup Constructor | fcSDK Documentation

YankOpportunitySetup Constructor

Opportunity Identifier.

Initializes a new instance of the YankOpportunitySetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _opportunityIDNum_ As String _
)

[ConstructorIndexAttribute()]
public YankOpportunitySetup(
   string _opportunityIDNum_
)

Parameters

opportunityIDNum

Opportunity Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankOpportunitySetup Class
YankOpportunitySetup Members


GenerateTimeBombs Property (YankOpportunitySetup) | fcSDK Documentation

GenerateTimeBombs Property (YankOpportunitySetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankOpportunitySetup Class
YankOpportunitySetup Members


OpportunityIDNum Property (YankOpportunitySetup) | fcSDK Documentation

OpportunityIDNum Property (YankOpportunitySetup)

Opportunity Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property OpportunityIDNum As String

[PropertyBitValueAttribute()]
public string OpportunityIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankOpportunitySetup Class
YankOpportunitySetup Members


UserName Property (YankOpportunitySetup) | fcSDK Documentation

UserName Property (YankOpportunitySetup)

The user who has yanked the Opportunity. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankOpportunitySetup Class
YankOpportunitySetup Members


WipBin Property (YankOpportunitySetup) | fcSDK Documentation

WipBin Property (YankOpportunitySetup)

User's WipBin in which to place the Opportunity. If not set, the UserName's default is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankOpportunitySetup Class
YankOpportunitySetup Members


YankDate Property (YankOpportunitySetup) | fcSDK Documentation

YankDate Property (YankOpportunitySetup)

DateTime the Opportunity was yanked. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property YankDate As Date

[PropertyBitValueAttribute()]
public DateTime YankDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankOpportunitySetup Class
YankOpportunitySetup Members


YankQuoteSetup Class | fcSDK Documentation

YankQuoteSetup Class

Used by the YankQuote method as setup data for invocation.

Syntax

'Declaration

Public Class YankQuoteSetup

public class YankQuoteSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.YankQuoteSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Sales

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

YankQuoteSetup Members
FChoice.Toolkits.Clarify.Sales Namespace
YankQuote(YankQuoteSetup) Method


YankQuoteSetup Class Members | fcSDK Documentation

YankQuoteSetup Class Members

The following tables list the members exposed by YankQuoteSetup.

Public Constructors

 | Name | Description
Public Constructor | YankQuoteSetup Constructor | Initializes a new instance of the YankQuoteSetup class.

Public Properties

 | Name | Description
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | QuoteIDNum | Quote Identifier.
Public Property | UserName | The user who has yanked the Quote. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Quote. If not set, the UserName's default is used.
Public Property | YankDate | DateTime the Quote was yanked. If not set, the current time is used.

Reference

YankQuoteSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
YankQuote(YankQuoteSetup) Method


FChoice.Toolkits.Clarify.Support Namespace | fcSDK Documentation

FChoice.Toolkits.Clarify.Support Namespace

Provides APIs to allow you to modify basic ClearSupport objects such as Case and Subcase.

These APIs can be used in custom web pages, the Clarify thick-client GUI, or in interfaces.

Functions are provided to allow you to create, modify, close, dispatch, accept, reject, assign, yank, move, change status, log notes, reopen, and more.

Classes

 | Class | Description
Class | AcceptCaseSetup | Used by the AcceptCase method as setup data for invocation.
Class | AcceptSubcaseSetup | Used by the AcceptSubcase method as setup data for invocation.
Class | AssignCaseSetup | Used by the AssignCase method as setup data for invocation.
Class | AssignSubcaseSetup | Used by the AssignSubcase method as setup data for invocation.
Class | CaseTimeAndExpenses | Holds summary totals from the PrecloseCase API.
Class | ChangeCaseContactSetup | Used by the ChangeCaseContact method as setup data for invocation.
Class | ChangeCaseSiteSetup | Used by the ChangeCaseSite method as setup data for invocation.
Class | ChangeCaseStatusSetup | Used by the ChangeCaseStatus method as setup data for invocation.
Class | ChangeSubcaseStatusSetup | Used by the ChangeSubcaseStatus method as setup data for invocation.
Class | ClarifyApplicationClock |
Class | CloseCaseSetup | Used by the CloseCase method as setup data for invocation.
Class | CloseSubcaseSetup | Used by the CloseSubcase method as setup data for invocation.
Class | CompatibilityApplicationClock |
Class | CreateCaseObjidSetup | Used by the CreateCaseObjid method as setup data for invocation.
Class | CreateCaseSetup | Used by the CreateCase method as setup data for invocation.
Class | CreateSubcaseSetup | Used by the CreateSubcase method as setup data for invocation.
Class | DispatchCaseSetup | Used by the DispatchCase method as setup data for invocation.
Class | DispatchSubcaseSetup | Used by the DispatchSubcase method as setup data for invocation.
Class | ForwardCaseSetup | Used by the ForwardCase method as setup data for invocation.
Class | ForwardSubcaseSetup | Used by the ForwardSubcase method as setup data for invocation.
Class | FulfillCommitmentSetup | Used by the FulfillCommitment method as setup data for invocation.
Class | GetCaseTimeAndExpensesResult | Result from the GetCaseTimeAndExpenses API.
Class | GetCaseTimeAndExpensesSetup | Used by the GetCaseTimeAndExpenses method as setup data for invocation.
Class | GetSubcaseTimeAndExpensesResult | Result from the GetSubcaseTimeAndExpenses API.
Class | GetSubcaseTimeAndExpensesSetup | Used by the GetSubcaseTimeAndExpenses method as setup data for invocation.
Class | InitialResponseSetup | Used by the InitialResponse method as setup data for invocation.
Class | LogCaseCommitmentSetup | Used by the LogCaseCommitment method as setup data for invocation.
Class | LogCaseEmailInSetup | Used by the LogCaseEmailIn method as setup data for invocation.
Class | LogCaseEmailResult | Result from the LogCaseEmail API.
Class | LogCaseEmailSetup | Used by the LogCaseEmail method as setup data for invocation.
Class | LogCaseInternalNoteSetup |
Class | LogCaseInternalPhoneSetup |
Class | LogCaseNoteResult | Result from the LogCaseNote API.
Class | LogCaseNoteSetup | Used by the LogCaseNote method as setup data for invocation.
Class | LogCasePhoneResult | Result from the LogCasePhone API.
Class | LogCasePhoneSetup | Used by the LogCasePhone method as setup data for invocation.
Class | LogCaseResearchResult | Result from the LogCaseResearch API.
Class | LogCaseResearchSetup | Used by the LogCaseResearch method as setup data for invocation.
Class | LogEmailInSetup | Setup that is common to both LogCaseEmailInSetup and LogSubcaseEmailInSetup. This setup should not be used on its own.
Class | LogSubcaseCommitmentSetup | Used by the LogSubcaseCommitment method as setup data for invocation.
Class | LogSubCaseEmailInSetup | Used by the LogSubCaseEmailIn method as setup data for invocation.
Class | LogSubcaseEmailResult | Result from the LogSubcaseEmail API.
Class | LogSubcaseEmailSetup | Used by the LogSubcaseEmail method as setup data for invocation.
Class | LogSubcaseInternalNoteSetup |
Class | LogSubcaseInternalPhoneSetup |
Class | LogSubcaseNoteResult | Result from the LogSubcaseNote API.
Class | LogSubcaseNoteSetup | Used by the LogSubcaseNote method as setup data for invocation.
Class | LogSubcasePhoneResult | Result from the LogSubcasePhone API.
Class | LogSubcasePhoneSetup | Used by the LogSubcasePhone method as setup data for invocation.
Class | LogSubcaseResearchResult | Result from the LogSubcaseResearch API.
Class | LogSubcaseResearchSetup | Used by the LogSubcaseResearch method as setup data for invocation.
Class | MoveCaseSetup | Used by the MoveCase method as setup data for invocation.
Class | MoveSubcaseSetup | Used by the MoveSubcase method as setup data for invocation.
Class | RejectCaseSetup | Used by the RejectCase method as setup data for invocation.
Class | RejectSubcaseSetup | Used by the RejectSubcase method as setup data for invocation.
Class | RelateCaseToParentCaseSetup | Used by the RelateCaseToParentCase method as setup data for invocation.
Class | ReopenCaseSetup | Used by the ReopenCase method as setup data for invocation.
Class | ReopenSubcaseSetup | Used by the ReopenSubcase method as setup data for invocation.
Class | SubcaseTimeAndExpenses | Holds summary totals from the PrecloseSubcase API.
Class | SupportToolkit | Provides APIs to allow you to modify basic ClearSupport objects such as Case and Subcase. Methods on the SupportToolkit object allow you to create, modify, close, dispatch, accept, reject, assign, yank, move, change status, log notes, reopen, and more.
Class | SupportToolkitBase | Please see SupportToolkit. This class is used internally and not meant to be created by end users.
Class | UnrelateCaseFromParentCaseSetup | Used by the UnrelateCaseFromParentCase method as setup data for invocation.
Class | UpdateCaseCommitmentSetup | Used by the UpdateCaseCommitment method as setup data for invocation.
Class | UpdateCaseSetup | Used by the UpdateCase method as setup data for invocation.
Class | UpdateSubcaseCommitmentSetup | Used by the UpdateSubcaseCommitment method as setup data for invocation.
Class | UpdateSubcaseSetup | Used by the UpdateSubcase method as setup data for invocation.
Class | YankCaseSetup | Used by the YankCase method as setup data for invocation.
Class | YankSubcaseSetup | Used by the YankSubcase method as setup data for invocation.

Interfaces

 | Interface | Description
Interface | IApplicationClock |

Reference

FChoice.Toolkits.Clarify Assembly


AcceptCaseSetup Class | fcSDK Documentation

AcceptCaseSetup Class

Used by the AcceptCase method as setup data for invocation.

Syntax

'Declaration

Public Class AcceptCaseSetup

public class AcceptCaseSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.AcceptCaseSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

AcceptCaseSetup Members
FChoice.Toolkits.Clarify.Support Namespace
AcceptCase(AcceptCaseSetup) Method


AcceptCaseSetup Class Members | fcSDK Documentation

AcceptCaseSetup Class Members

The following tables list the members exposed by AcceptCaseSetup.

Public Constructors

 | Name | Description
Public Constructor | AcceptCaseSetup Constructor | Initializes a new instance of the AcceptCaseSetup class.

Public Properties

 | Name | Description
Public Property | AcceptDate | DateTime the Case was accepted. If not set, the current time is used.
Public Property | CaseIDNum | Case Identifier.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | UserName | The user who has accepted the Case. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Case. If not set, the UserName's default is used.

Reference

AcceptCaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
AcceptCase(AcceptCaseSetup) Method


AcceptCaseSetup Constructor | fcSDK Documentation

AcceptCaseSetup Constructor

Case Identifier.

Initializes a new instance of the AcceptCaseSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _caseIDNum_ As String _
)

[ConstructorIndexAttribute()]
public AcceptCaseSetup(
   string _caseIDNum_
)

Parameters

caseIDNum

Case Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptCaseSetup Class
AcceptCaseSetup Members


AcceptDate Property (AcceptCaseSetup) | fcSDK Documentation

AcceptDate Property (AcceptCaseSetup)

DateTime the Case was accepted. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AcceptDate As Date

[PropertyBitValueAttribute()]
public DateTime AcceptDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptCaseSetup Class
AcceptCaseSetup Members


CaseIDNum Property (AcceptCaseSetup) | fcSDK Documentation

CaseIDNum Property (AcceptCaseSetup)

Case Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptCaseSetup Class
AcceptCaseSetup Members


GenerateTimeBombs Property (AcceptCaseSetup) | fcSDK Documentation

GenerateTimeBombs Property (AcceptCaseSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptCaseSetup Class
AcceptCaseSetup Members


UserName Property (AcceptCaseSetup) | fcSDK Documentation

UserName Property (AcceptCaseSetup)

The user who has accepted the Case. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptCaseSetup Class
AcceptCaseSetup Members


WipBin Property (AcceptCaseSetup) | fcSDK Documentation

WipBin Property (AcceptCaseSetup)

User's WipBin in which to place the Case. If not set, the UserName's default is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptCaseSetup Class
AcceptCaseSetup Members


AcceptSubcaseSetup Class | fcSDK Documentation

AcceptSubcaseSetup Class

Used by the AcceptSubcase method as setup data for invocation.

Syntax

'Declaration

Public Class AcceptSubcaseSetup

public class AcceptSubcaseSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.AcceptSubcaseSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

AcceptSubcaseSetup Members
FChoice.Toolkits.Clarify.Support Namespace
AcceptSubcase(AcceptSubcaseSetup) Method


AcceptSubcaseSetup Class Members | fcSDK Documentation

AcceptSubcaseSetup Class Members

The following tables list the members exposed by AcceptSubcaseSetup.

Public Constructors

 | Name | Description
Public Constructor | AcceptSubcaseSetup Constructor | Initializes a new instance of the AcceptSubcaseSetup class.

Public Properties

 | Name | Description
Public Property | AcceptDate | DateTime the Subcase was accepted. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | SubcaseIDNum | Subcase Identifier.
Public Property | UserName | The user who has accepted the Subcase. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Subcase. If not set, the UserName's default is used.

Reference

AcceptSubcaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
AcceptSubcase(AcceptSubcaseSetup) Method


AcceptSubcaseSetup Constructor | fcSDK Documentation

AcceptSubcaseSetup Constructor

Subcase Identifier.

Initializes a new instance of the AcceptSubcaseSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _subcaseIDNum_ As String _
)

[ConstructorIndexAttribute()]
public AcceptSubcaseSetup(
   string _subcaseIDNum_
)

Parameters

subcaseIDNum

Subcase Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptSubcaseSetup Class
AcceptSubcaseSetup Members


AcceptDate Property (AcceptSubcaseSetup) | fcSDK Documentation

AcceptDate Property (AcceptSubcaseSetup)

DateTime the Subcase was accepted. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AcceptDate As Date

[PropertyBitValueAttribute()]
public DateTime AcceptDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptSubcaseSetup Class
AcceptSubcaseSetup Members


GenerateTimeBombs Property (AcceptSubcaseSetup) | fcSDK Documentation

GenerateTimeBombs Property (AcceptSubcaseSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptSubcaseSetup Class
AcceptSubcaseSetup Members


SubcaseIDNum Property (AcceptSubcaseSetup) | fcSDK Documentation

SubcaseIDNum Property (AcceptSubcaseSetup)

Subcase Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SubcaseIDNum As String

[PropertyBitValueAttribute()]
public string SubcaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptSubcaseSetup Class
AcceptSubcaseSetup Members


UserName Property (AcceptSubcaseSetup) | fcSDK Documentation

UserName Property (AcceptSubcaseSetup)

The user who has accepted the Subcase. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptSubcaseSetup Class
AcceptSubcaseSetup Members


WipBin Property (AcceptSubcaseSetup) | fcSDK Documentation

WipBin Property (AcceptSubcaseSetup)

User's WipBin in which to place the Subcase. If not set, the UserName's default is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AcceptSubcaseSetup Class
AcceptSubcaseSetup Members


AssignCaseSetup Class | fcSDK Documentation

AssignCaseSetup Class

Used by the AssignCase method as setup data for invocation.

Syntax

'Declaration

Public Class AssignCaseSetup

public class AssignCaseSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.AssignCaseSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

AssignCaseSetup Members
FChoice.Toolkits.Clarify.Support Namespace
AssignCase(AssignCaseSetup) Method


AssignCaseSetup Class Members | fcSDK Documentation

AssignCaseSetup Class Members

The following tables list the members exposed by AssignCaseSetup.

Public Constructors

 | Name | Description
Public Constructor | AssignCaseSetup Constructor | Initializes a new instance of the AssignCaseSetup class.

Public Properties

 | Name | Description
Public Property | AssignDate | DateTime the Case was assigned. If not set, the current time is used.
Public Property | CaseIDNum | Case Identifier.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewUser | The new user to which the Case is to be assigned.
Public Property | UserName | The user who has assigned the Case. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Case. If not set, the UserName's default is used.

Reference

AssignCaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
AssignCase(AssignCaseSetup) Method


AssignCaseSetup Constructor | fcSDK Documentation

AssignCaseSetup Constructor

Case Identifier.

Initializes a new instance of the AssignCaseSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _caseIDNum_ As String _
)

[ConstructorIndexAttribute()]
public AssignCaseSetup(
   string _caseIDNum_
)

Parameters

caseIDNum

Case Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignCaseSetup Class
AssignCaseSetup Members


AssignDate Property (AssignCaseSetup) | fcSDK Documentation

AssignDate Property (AssignCaseSetup)

DateTime the Case was assigned. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AssignDate As Date

[PropertyBitValueAttribute()]
public DateTime AssignDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignCaseSetup Class
AssignCaseSetup Members


CaseIDNum Property (AssignCaseSetup) | fcSDK Documentation

CaseIDNum Property (AssignCaseSetup)

Case Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignCaseSetup Class
AssignCaseSetup Members


GenerateTimeBombs Property (AssignCaseSetup) | fcSDK Documentation

GenerateTimeBombs Property (AssignCaseSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignCaseSetup Class
AssignCaseSetup Members


NewUser Property (AssignCaseSetup) | fcSDK Documentation

NewUser Property (AssignCaseSetup)

The new user to which the Case is to be assigned.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewUser As String

[PropertyBitValueAttribute()]
public string NewUser {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignCaseSetup Class
AssignCaseSetup Members


UserName Property (AssignCaseSetup) | fcSDK Documentation

UserName Property (AssignCaseSetup)

The user who has assigned the Case. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignCaseSetup Class
AssignCaseSetup Members


WipBin Property (AssignCaseSetup) | fcSDK Documentation

WipBin Property (AssignCaseSetup)

User's WipBin in which to place the Case. If not set, the UserName's default is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignCaseSetup Class
AssignCaseSetup Members


AssignSubcaseSetup Class | fcSDK Documentation

AssignSubcaseSetup Class

Used by the AssignSubcase method as setup data for invocation.

Syntax

'Declaration

Public Class AssignSubcaseSetup

public class AssignSubcaseSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.AssignSubcaseSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

AssignSubcaseSetup Members
FChoice.Toolkits.Clarify.Support Namespace
AssignSubcase(AssignSubcaseSetup) Method


AssignSubcaseSetup Class Members | fcSDK Documentation

AssignSubcaseSetup Class Members

The following tables list the members exposed by AssignSubcaseSetup.

Public Constructors

 | Name | Description
Public Constructor | AssignSubcaseSetup Constructor | Initializes a new instance of the AssignSubcaseSetup class.

Public Properties

 | Name | Description
Public Property | AssignDate | DateTime the Subcase was assigned. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewUser | The new user to which the Subcase is to be assigned.
Public Property | SubcaseIDNum | Subcase Identifier.
Public Property | UserName | The user who has assigned the Subcase. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Subcase. If not set, the UserName's default is used.

Reference

AssignSubcaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
AssignSubcase(AssignSubcaseSetup) Method


AssignSubcaseSetup Constructor | fcSDK Documentation

AssignSubcaseSetup Constructor

Subcase Identifier.

Initializes a new instance of the AssignSubcaseSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _subcaseIDNum_ As String _
)

[ConstructorIndexAttribute()]
public AssignSubcaseSetup(
   string _subcaseIDNum_
)

Parameters

subcaseIDNum

Subcase Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignSubcaseSetup Class
AssignSubcaseSetup Members


AssignDate Property (AssignSubcaseSetup) | fcSDK Documentation

AssignDate Property (AssignSubcaseSetup)

DateTime the Subcase was assigned. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AssignDate As Date

[PropertyBitValueAttribute()]
public DateTime AssignDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignSubcaseSetup Class
AssignSubcaseSetup Members


GenerateTimeBombs Property (AssignSubcaseSetup) | fcSDK Documentation

GenerateTimeBombs Property (AssignSubcaseSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignSubcaseSetup Class
AssignSubcaseSetup Members


NewUser Property (AssignSubcaseSetup) | fcSDK Documentation

NewUser Property (AssignSubcaseSetup)

The new user to which the Subcase is to be assigned.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewUser As String

[PropertyBitValueAttribute()]
public string NewUser {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignSubcaseSetup Class
AssignSubcaseSetup Members


SubcaseIDNum Property (AssignSubcaseSetup) | fcSDK Documentation

SubcaseIDNum Property (AssignSubcaseSetup)

Subcase Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SubcaseIDNum As String

[PropertyBitValueAttribute()]
public string SubcaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignSubcaseSetup Class
AssignSubcaseSetup Members


UserName Property (AssignSubcaseSetup) | fcSDK Documentation

UserName Property (AssignSubcaseSetup)

The user who has assigned the Subcase. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AssignSubcaseSetup Class
AssignSubcaseSetup Members


CaseTimeAndExpenses Class | fcSDK Documentation

CaseTimeAndExpenses Class

Holds summary totals from the PrecloseCase API.

Syntax

'Declaration

Public Class CaseTimeAndExpenses

public class CaseTimeAndExpenses

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.CaseTimeAndExpenses

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CaseTimeAndExpenses Members
FChoice.Toolkits.Clarify.Support Namespace


CaseTimeAndExpenses Class Members | fcSDK Documentation

CaseTimeAndExpenses Class Members

The following tables list the members exposed by CaseTimeAndExpenses.

Public Constructors

 | Name | Description
Public Constructor | CaseTimeAndExpenses Constructor |

Public Fields

 | Name | Description
static (Shared in Visual Basic) | EMPTY | Retrieves an instance of a CaseTimeAndExpenses object that can be used to specify "none specified" when setting the CloseSums on the CloseCaseSetup object

Public Properties

 | Name | Description
Public Property | CaseActualPhoneTime | Actual phone time for the Case
Public Property | CaseActualResearchTime | Actual research time for the Case
Public Property | CaseBillableExpenses | Captured billable expenses (Case time logs only)
Public Property | CaseBillableTime | Captured billable time (Case time logs only)
Public Property | CaseNonBillableExpenses | Captured non-billable expenses (Case time logs only)
Public Property | CaseNonBillableTime | Captured non-billable time (Case time logs only)
Public Property | CasePhoneTime | Captured phone time (Case phone logs only)
Public Property | CaseResearchTime | Captured research time (Case research logs only)
Public Property | TotalActualPhoneTime | Actual phone time (closed subcase only)
Public Property | TotalActualResearchTime | Actual research time (closed subcase only)
Public Property | TotalBillableExpenses | Total billable expenses (closed Subcase and Case expense logs)
Public Property | TotalBillableTime | Total billable time (closed Subcase and Case time logs)
Public Property | TotalNonBillableExpenses | Total billable expenses (closed Subcase and Case expense logs)
Public Property | TotalNonBillableTime | Total non-billable time (closed Subcase and Case time logs)
Public Property | TotalPhoneTime | Total phone time (closed Subcase and phone log for the Case)
Public Property | TotalResearchTime | Total research time (closed Subcase and research logs for the Case)

Reference

CaseTimeAndExpenses Class
FChoice.Toolkits.Clarify.Support Namespace


CaseTimeAndExpenses Constructor | fcSDK Documentation

CaseTimeAndExpenses Constructor

Syntax

'Declaration

Public Function New()

public CaseTimeAndExpenses()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CaseTimeAndExpenses Class
CaseTimeAndExpenses Members


CaseActualPhoneTime Property | fcSDK Documentation

CaseActualPhoneTime Property

Actual phone time for the Case

Syntax

'Declaration

Public Property CaseActualPhoneTime As TimeSpan

public TimeSpan CaseActualPhoneTime {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CaseTimeAndExpenses Class
CaseTimeAndExpenses Members


CaseActualResearchTime Property | fcSDK Documentation

CaseActualResearchTime Property

Actual research time for the Case

Syntax

'Declaration

Public Property CaseActualResearchTime As TimeSpan

public TimeSpan CaseActualResearchTime {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CaseTimeAndExpenses Class
CaseTimeAndExpenses Members


CaseBillableExpenses Property | fcSDK Documentation

CaseBillableExpenses Property

Captured billable expenses (Case time logs only)

Syntax

'Declaration

Public Property CaseBillableExpenses As Decimal

public decimal CaseBillableExpenses {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CaseTimeAndExpenses Class
CaseTimeAndExpenses Members


CaseBillableTime Property | fcSDK Documentation

CaseBillableTime Property

Captured billable time (Case time logs only)

Syntax

'Declaration

Public Property CaseBillableTime As TimeSpan

public TimeSpan CaseBillableTime {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CaseTimeAndExpenses Class
CaseTimeAndExpenses Members


CaseNonBillableExpenses Property | fcSDK Documentation

CaseNonBillableExpenses Property

Captured non-billable expenses (Case time logs only)

Syntax

'Declaration

Public Property CaseNonBillableExpenses As Decimal

public decimal CaseNonBillableExpenses {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CaseTimeAndExpenses Class
CaseTimeAndExpenses Members


CaseNonBillableTime Property | fcSDK Documentation

CaseNonBillableTime Property

Captured non-billable time (Case time logs only)

Syntax

'Declaration

Public Property CaseNonBillableTime As TimeSpan

public TimeSpan CaseNonBillableTime {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CaseTimeAndExpenses Class
CaseTimeAndExpenses Members


CasePhoneTime Property | fcSDK Documentation

CasePhoneTime Property

Captured phone time (Case phone logs only)

Syntax

'Declaration

Public Property CasePhoneTime As TimeSpan

public TimeSpan CasePhoneTime {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CaseTimeAndExpenses Class
CaseTimeAndExpenses Members


CaseResearchTime Property | fcSDK Documentation

CaseResearchTime Property

Captured research time (Case research logs only)

Syntax

'Declaration

Public Property CaseResearchTime As TimeSpan

public TimeSpan CaseResearchTime {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CaseTimeAndExpenses Class
CaseTimeAndExpenses Members


TotalActualPhoneTime Property | fcSDK Documentation

TotalActualPhoneTime Property

Actual phone time (closed subcase only)

Syntax

'Declaration

Public Property TotalActualPhoneTime As TimeSpan

public TimeSpan TotalActualPhoneTime {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CaseTimeAndExpenses Class
CaseTimeAndExpenses Members


TotalActualResearchTime Property | fcSDK Documentation

TotalActualResearchTime Property

Actual research time (closed subcase only)

Syntax

'Declaration

Public Property TotalActualResearchTime As TimeSpan

public TimeSpan TotalActualResearchTime {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CaseTimeAndExpenses Class
CaseTimeAndExpenses Members


TotalBillableExpenses Property (CaseTimeAndExpenses) | fcSDK Documentation

TotalBillableExpenses Property (CaseTimeAndExpenses)

Total billable expenses (closed Subcase and Case expense logs)

Syntax

'Declaration

Public Property TotalBillableExpenses As Decimal

public decimal TotalBillableExpenses {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CaseTimeAndExpenses Class
CaseTimeAndExpenses Members


TotalBillableTime Property (CaseTimeAndExpenses) | fcSDK Documentation

TotalBillableTime Property (CaseTimeAndExpenses)

Total billable time (closed Subcase and Case time logs)

Syntax

'Declaration

Public Property TotalBillableTime As TimeSpan

public TimeSpan TotalBillableTime {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CaseTimeAndExpenses Class
CaseTimeAndExpenses Members


TotalNonBillableExpenses Property (CaseTimeAndExpenses) | fcSDK Documentation

TotalNonBillableExpenses Property (CaseTimeAndExpenses)

Total billable expenses (closed Subcase and Case expense logs)

Syntax

'Declaration

Public Property TotalNonBillableExpenses As Decimal

public decimal TotalNonBillableExpenses {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CaseTimeAndExpenses Class
CaseTimeAndExpenses Members


TotalNonBillableTime Property (CaseTimeAndExpenses) | fcSDK Documentation

TotalNonBillableTime Property (CaseTimeAndExpenses)

Total non-billable time (closed Subcase and Case time logs)

Syntax

'Declaration

Public Property TotalNonBillableTime As TimeSpan

public TimeSpan TotalNonBillableTime {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CaseTimeAndExpenses Class
CaseTimeAndExpenses Members


TotalPhoneTime Property | fcSDK Documentation

TotalPhoneTime Property

Total phone time (closed Subcase and phone log for the Case)

Syntax

'Declaration

Public Property TotalPhoneTime As TimeSpan

public TimeSpan TotalPhoneTime {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CaseTimeAndExpenses Class
CaseTimeAndExpenses Members


TotalResearchTime Property | fcSDK Documentation

TotalResearchTime Property

Total research time (closed Subcase and research logs for the Case)

Syntax

'Declaration

Public Property TotalResearchTime As TimeSpan

public TimeSpan TotalResearchTime {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CaseTimeAndExpenses Class
CaseTimeAndExpenses Members


EMPTY Field (CaseTimeAndExpenses) | fcSDK Documentation

EMPTY Field (CaseTimeAndExpenses)

Retrieves an instance of a CaseTimeAndExpenses object that can be used to specify "none specified" when setting the CloseSums on the CloseCaseSetup object

Syntax

'Declaration

Public Shared ReadOnly EMPTY As CaseTimeAndExpenses

public static readonly CaseTimeAndExpenses EMPTY

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CaseTimeAndExpenses Class
CaseTimeAndExpenses Members


ChangeCaseContactSetup Class | fcSDK Documentation

ChangeCaseContactSetup Class

Used by the ChangeCaseContact method as setup data for invocation.

Syntax

'Declaration

Public Class ChangeCaseContactSetup

public class ChangeCaseContactSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.ChangeCaseContactSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ChangeCaseContactSetup Members
FChoice.Toolkits.Clarify.Support Namespace
ChangeCaseContact(ChangeCaseContactSetup) Method


ChangeCaseContactSetup Class Members | fcSDK Documentation

ChangeCaseContactSetup Class Members

The following tables list the members exposed by ChangeCaseContactSetup.

Public Constructors

 | Name | Description
Public Constructor | ChangeCaseContactSetup Constructor | Initializes a new instance of the ChangeCaseContactSetup class.

Public Properties

 | Name | Description
Public Property | CaseIDNum | Case Identifier.
Public Property | ChangeDate | DateTime the change was made. If not set, the current time is used.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | OnlyOpen | The OnlyOpen property, which defaults to true, is checked before updating the case contact.
Public Property | SiteIDNum |
Public Property | UserName | The User who changed the Case. If not set, the session user is used.

Reference

ChangeCaseContactSetup Class
FChoice.Toolkits.Clarify.Support Namespace
ChangeCaseContact(ChangeCaseContactSetup) Method


ChangeCaseContactSetup Constructor | fcSDK Documentation

ChangeCaseContactSetup Constructor

Case Identifier.

Contact's first name.

Contact's last name.

Contact's phone number.

Initializes a new instance of the ChangeCaseContactSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _caseIDNum_ As String, _
   ByVal _contactFirstName_ As String, _
   ByVal _contactLastName_ As String, _
   ByVal _contactPhone_ As String _
)

[ConstructorIndexAttribute()]
public ChangeCaseContactSetup(
   string _caseIDNum_,
   string _contactFirstName_,
   string _contactLastName_,
   string _contactPhone_
)

Parameters

caseIDNum

Case Identifier.

contactFirstName

Contact's first name.

contactLastName

Contact's last name.

contactPhone

Contact's phone number.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeCaseContactSetup Class
ChangeCaseContactSetup Members


CaseIDNum Property (ChangeCaseContactSetup) | fcSDK Documentation

CaseIDNum Property (ChangeCaseContactSetup)

Case Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeCaseContactSetup Class
ChangeCaseContactSetup Members


ChangeDate Property (ChangeCaseContactSetup) | fcSDK Documentation

ChangeDate Property (ChangeCaseContactSetup)

DateTime the change was made. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ChangeDate As Date

[PropertyBitValueAttribute()]
public DateTime ChangeDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeCaseContactSetup Class
ChangeCaseContactSetup Members


ContactFirstName Property (ChangeCaseContactSetup) | fcSDK Documentation

ContactFirstName Property (ChangeCaseContactSetup)

Contact's first name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactFirstName As String

[PropertyBitValueAttribute()]
public string ContactFirstName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeCaseContactSetup Class
ChangeCaseContactSetup Members


ContactLastName Property (ChangeCaseContactSetup) | fcSDK Documentation

ContactLastName Property (ChangeCaseContactSetup)

Contact's last name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactLastName As String

[PropertyBitValueAttribute()]
public string ContactLastName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeCaseContactSetup Class
ChangeCaseContactSetup Members


ContactPhone Property (ChangeCaseContactSetup) | fcSDK Documentation

ContactPhone Property (ChangeCaseContactSetup)

Contact's phone number.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactPhone As String

[PropertyBitValueAttribute()]
public string ContactPhone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeCaseContactSetup Class
ChangeCaseContactSetup Members


GenerateTimeBombs Property (ChangeCaseContactSetup) | fcSDK Documentation

GenerateTimeBombs Property (ChangeCaseContactSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeCaseContactSetup Class
ChangeCaseContactSetup Members


OnlyOpen Property (ChangeCaseContactSetup) | fcSDK Documentation

OnlyOpen Property (ChangeCaseContactSetup)

The OnlyOpen property, which defaults to true, is checked before updating the case contact.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property OnlyOpen As Boolean

[PropertyBitValueAttribute()]
public bool OnlyOpen {get; set;}

Remarks

If the property is set to true, only Open cases will have their contact changed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeCaseContactSetup Class
ChangeCaseContactSetup Members


SiteIDNum Property (ChangeCaseContactSetup) | fcSDK Documentation

SiteIDNum Property (ChangeCaseContactSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteIDNum As String

[PropertyBitValueAttribute()]
public string SiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeCaseContactSetup Class
ChangeCaseContactSetup Members


UserName Property (ChangeCaseContactSetup) | fcSDK Documentation

UserName Property (ChangeCaseContactSetup)

The User who changed the Case. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeCaseContactSetup Class
ChangeCaseContactSetup Members


ChangeCaseSiteSetup Class | fcSDK Documentation

ChangeCaseSiteSetup Class

Used by the ChangeCaseSite method as setup data for invocation.

Syntax

'Declaration

Public Class ChangeCaseSiteSetup

public class ChangeCaseSiteSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.ChangeCaseSiteSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ChangeCaseSiteSetup Members
FChoice.Toolkits.Clarify.Support Namespace
ChangeCaseSite(ChangeCaseSiteSetup) Method


ChangeCaseSiteSetup Class Members | fcSDK Documentation

ChangeCaseSiteSetup Class Members

The following tables list the members exposed by ChangeCaseSiteSetup.

Public Constructors

 | Name | Description
Public Constructor | ChangeCaseSiteSetup Constructor | Initializes a new instance of the ChangeCaseSiteSetup class.

Public Properties

 | Name | Description
Public Property | CaseIDNum | Case Identifier.
Public Property | ChangeDate | DateTime the change was made. If not set, the current time is used.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | OnlyOpen | The OnlyOpen property, which defaults to true, is checked before updating the case site.
Public Property | SiteIDNum | Site Identifier.
Public Property | UserName | The User who changed the Case. If not set, the session user is used.

Reference

ChangeCaseSiteSetup Class
FChoice.Toolkits.Clarify.Support Namespace
ChangeCaseSite(ChangeCaseSiteSetup) Method


ChangeCaseSiteSetup Constructor | fcSDK Documentation

ChangeCaseSiteSetup Constructor

Case Identifier.

Site Identifier.

Initializes a new instance of the ChangeCaseSiteSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _caseIDNum_ As String, _
   ByVal _siteIDNum_ As String _
)

[ConstructorIndexAttribute()]
public ChangeCaseSiteSetup(
   string _caseIDNum_,
   string _siteIDNum_
)

Parameters

caseIDNum

Case Identifier.

siteIDNum

Site Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeCaseSiteSetup Class
ChangeCaseSiteSetup Members


CaseIDNum Property (ChangeCaseSiteSetup) | fcSDK Documentation

CaseIDNum Property (ChangeCaseSiteSetup)

Case Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeCaseSiteSetup Class
ChangeCaseSiteSetup Members


ChangeDate Property (ChangeCaseSiteSetup) | fcSDK Documentation

ChangeDate Property (ChangeCaseSiteSetup)

DateTime the change was made. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ChangeDate As Date

[PropertyBitValueAttribute()]
public DateTime ChangeDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeCaseSiteSetup Class
ChangeCaseSiteSetup Members


ContactFirstName Property (ChangeCaseSiteSetup) | fcSDK Documentation

ContactFirstName Property (ChangeCaseSiteSetup)

Contact's first name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactFirstName As String

[PropertyBitValueAttribute()]
public string ContactFirstName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeCaseSiteSetup Class
ChangeCaseSiteSetup Members


ContactLastName Property (ChangeCaseSiteSetup) | fcSDK Documentation

ContactLastName Property (ChangeCaseSiteSetup)

Contact's last name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactLastName As String

[PropertyBitValueAttribute()]
public string ContactLastName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeCaseSiteSetup Class
ChangeCaseSiteSetup Members


ContactPhone Property (ChangeCaseSiteSetup) | fcSDK Documentation

ContactPhone Property (ChangeCaseSiteSetup)

Contact's phone number.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactPhone As String

[PropertyBitValueAttribute()]
public string ContactPhone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeCaseSiteSetup Class
ChangeCaseSiteSetup Members


GenerateTimeBombs Property (ChangeCaseSiteSetup) | fcSDK Documentation

GenerateTimeBombs Property (ChangeCaseSiteSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeCaseSiteSetup Class
ChangeCaseSiteSetup Members


OnlyOpen Property (ChangeCaseSiteSetup) | fcSDK Documentation

OnlyOpen Property (ChangeCaseSiteSetup)

The OnlyOpen property, which defaults to true, is checked before updating the case site.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property OnlyOpen As Boolean

[PropertyBitValueAttribute()]
public bool OnlyOpen {get; set;}

Remarks

If the property is set to true, only Open cases will have their site changed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeCaseSiteSetup Class
ChangeCaseSiteSetup Members


SiteIDNum Property (ChangeCaseSiteSetup) | fcSDK Documentation

SiteIDNum Property (ChangeCaseSiteSetup)

Site Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteIDNum As String

[PropertyBitValueAttribute()]
public string SiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeCaseSiteSetup Class
ChangeCaseSiteSetup Members


UserName Property (ChangeCaseSiteSetup) | fcSDK Documentation

UserName Property (ChangeCaseSiteSetup)

The User who changed the Case. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeCaseSiteSetup Class
ChangeCaseSiteSetup Members


ChangeCaseStatusSetup Class | fcSDK Documentation

ChangeCaseStatusSetup Class

Used by the ChangeCaseStatus method as setup data for invocation.

Syntax

'Declaration

Public Class ChangeCaseStatusSetup

public class ChangeCaseStatusSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.ChangeCaseStatusSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ChangeCaseStatusSetup Members
FChoice.Toolkits.Clarify.Support Namespace
ChangeCaseStatus(ChangeCaseStatusSetup) Method


ChangeCaseStatusSetup Class Members | fcSDK Documentation

ChangeCaseStatusSetup Class Members

The following tables list the members exposed by ChangeCaseStatusSetup.

Public Constructors

 | Name | Description
Public Constructor | ChangeCaseStatusSetup Constructor | Initializes a new instance of the ChangeCaseStatusSetup class.

Public Properties

 | Name | Description
Public Property | CaseIDNum | Case Identifier.
Public Property | ChangeDate | DateTime the change was made. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewStatus | The new status for the Case.
Public Property | Notes | Notes for the status change.
Public Property | UserName | The User who changed the Case. If not set, the session user is used.

Reference

ChangeCaseStatusSetup Class
FChoice.Toolkits.Clarify.Support Namespace
ChangeCaseStatus(ChangeCaseStatusSetup) Method


ChangeCaseStatusSetup Constructor | fcSDK Documentation

ChangeCaseStatusSetup Constructor

Case Identifier.

Initializes a new instance of the ChangeCaseStatusSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _caseIDNum_ As String _
)

[ConstructorIndexAttribute()]
public ChangeCaseStatusSetup(
   string _caseIDNum_
)

Parameters

caseIDNum

Case Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeCaseStatusSetup Class
ChangeCaseStatusSetup Members


CaseIDNum Property (ChangeCaseStatusSetup) | fcSDK Documentation

CaseIDNum Property (ChangeCaseStatusSetup)

Case Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeCaseStatusSetup Class
ChangeCaseStatusSetup Members


ChangeDate Property (ChangeCaseStatusSetup) | fcSDK Documentation

ChangeDate Property (ChangeCaseStatusSetup)

DateTime the change was made. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ChangeDate As Date

[PropertyBitValueAttribute()]
public DateTime ChangeDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeCaseStatusSetup Class
ChangeCaseStatusSetup Members


GenerateTimeBombs Property (ChangeCaseStatusSetup) | fcSDK Documentation

GenerateTimeBombs Property (ChangeCaseStatusSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeCaseStatusSetup Class
ChangeCaseStatusSetup Members


NewStatus Property (ChangeCaseStatusSetup) | fcSDK Documentation

NewStatus Property (ChangeCaseStatusSetup)

The new status for the Case.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewStatus As String

[PropertyBitValueAttribute()]
public string NewStatus {get; set;}

Remarks

The new status must be valid for the current condition of the Case.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeCaseStatusSetup Class
ChangeCaseStatusSetup Members


Notes Property (ChangeCaseStatusSetup) | fcSDK Documentation

Notes Property (ChangeCaseStatusSetup)

Notes for the status change.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeCaseStatusSetup Class
ChangeCaseStatusSetup Members


UserName Property (ChangeCaseStatusSetup) | fcSDK Documentation

UserName Property (ChangeCaseStatusSetup)

The User who changed the Case. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeCaseStatusSetup Class
ChangeCaseStatusSetup Members


ChangeSubcaseStatusSetup Class | fcSDK Documentation

ChangeSubcaseStatusSetup Class

Used by the ChangeSubcaseStatus method as setup data for invocation.

Syntax

'Declaration

Public Class ChangeSubcaseStatusSetup

public class ChangeSubcaseStatusSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.ChangeSubcaseStatusSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ChangeSubcaseStatusSetup Members
FChoice.Toolkits.Clarify.Support Namespace
ChangeSubcaseStatus(ChangeSubcaseStatusSetup) Method


ChangeSubcaseStatusSetup Class Members | fcSDK Documentation

ChangeSubcaseStatusSetup Class Members

The following tables list the members exposed by ChangeSubcaseStatusSetup.

Public Constructors

 | Name | Description
Public Constructor | ChangeSubcaseStatusSetup Constructor | Initializes a new instance of the ChangeSubcaseStatusSetup class.

Public Properties

 | Name | Description
Public Property | ChangeDate | DateTime the change was made. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewStatus | The new status for the Case.
Public Property | Notes | Notes for the status change.
Public Property | SubcaseIDNum | Subcase Identifier.
Public Property | UserName | The User who changed the Subcase. If not set, the session user is used.

Reference

ChangeSubcaseStatusSetup Class
FChoice.Toolkits.Clarify.Support Namespace
ChangeSubcaseStatus(ChangeSubcaseStatusSetup) Method


ChangeSubcaseStatusSetup Constructor | fcSDK Documentation

ChangeSubcaseStatusSetup Constructor

Subcase Identifier.

Initializes a new instance of the ChangeSubcaseStatusSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _subcaseIDNum_ As String _
)

[ConstructorIndexAttribute()]
public ChangeSubcaseStatusSetup(
   string _subcaseIDNum_
)

Parameters

subcaseIDNum

Subcase Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeSubcaseStatusSetup Class
ChangeSubcaseStatusSetup Members


ChangeDate Property (ChangeSubcaseStatusSetup) | fcSDK Documentation

ChangeDate Property (ChangeSubcaseStatusSetup)

DateTime the change was made. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ChangeDate As Date

[PropertyBitValueAttribute()]
public DateTime ChangeDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeSubcaseStatusSetup Class
ChangeSubcaseStatusSetup Members


GenerateTimeBombs Property (ChangeSubcaseStatusSetup) | fcSDK Documentation

GenerateTimeBombs Property (ChangeSubcaseStatusSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeSubcaseStatusSetup Class
ChangeSubcaseStatusSetup Members


NewStatus Property (ChangeSubcaseStatusSetup) | fcSDK Documentation

NewStatus Property (ChangeSubcaseStatusSetup)

The new status for the Case.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewStatus As String

[PropertyBitValueAttribute()]
public string NewStatus {get; set;}

Remarks

The new status must be valid for the current condition of the Subcase.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeSubcaseStatusSetup Class
ChangeSubcaseStatusSetup Members


Notes Property (ChangeSubcaseStatusSetup) | fcSDK Documentation

Notes Property (ChangeSubcaseStatusSetup)

Notes for the status change.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeSubcaseStatusSetup Class
ChangeSubcaseStatusSetup Members


SubcaseIDNum Property (ChangeSubcaseStatusSetup) | fcSDK Documentation

SubcaseIDNum Property (ChangeSubcaseStatusSetup)

Subcase Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SubcaseIDNum As String

[PropertyBitValueAttribute()]
public string SubcaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeSubcaseStatusSetup Class
ChangeSubcaseStatusSetup Members


UserName Property (ChangeSubcaseStatusSetup) | fcSDK Documentation

UserName Property (ChangeSubcaseStatusSetup)

The User who changed the Subcase. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ChangeSubcaseStatusSetup Class
ChangeSubcaseStatusSetup Members


ClarifyApplicationClock Class | fcSDK Documentation

ClarifyApplicationClock Class

Syntax

'Declaration

Public Class ClarifyApplicationClock
   Implements IApplicationClock

public class ClarifyApplicationClock : IApplicationClock

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.ClarifyApplicationClock

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ClarifyApplicationClock Members
FChoice.Toolkits.Clarify.Support Namespace


ClarifyApplicationClock Class Members | fcSDK Documentation

ClarifyApplicationClock Class Members

The following tables list the members exposed by ClarifyApplicationClock.

Public Constructors

 | Name | Description
Public Constructor | ClarifyApplicationClock Constructor |

Public Properties

 | Name | Description
Public Property | Now |

Reference

ClarifyApplicationClock Class
FChoice.Toolkits.Clarify.Support Namespace


ClarifyApplicationClock Constructor | fcSDK Documentation

ClarifyApplicationClock Constructor

Syntax

'Declaration

Public Function New( _
   ByVal _clarifySession_ As ClarifySession _
)

public ClarifyApplicationClock(
   ClarifySession _clarifySession_
)

Parameters

clarifySession

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyApplicationClock Class
ClarifyApplicationClock Members


Now Property (ClarifyApplicationClock) | fcSDK Documentation

Now Property (ClarifyApplicationClock)

Syntax

'Declaration

Public ReadOnly Property Now As Date

public DateTime Now {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyApplicationClock Class
ClarifyApplicationClock Members


CloseCaseSetup Class | fcSDK Documentation

CloseCaseSetup Class

Used by the CloseCase method as setup data for invocation.

Syntax

'Declaration

Public Class CloseCaseSetup

public class CloseCaseSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.CloseCaseSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CloseCaseSetup Members
FChoice.Toolkits.Clarify.Support Namespace
CloseCase(CloseCaseSetup) Method


CloseCaseSetup Class Members | fcSDK Documentation

CloseCaseSetup Class Members

The following tables list the members exposed by CloseCaseSetup.

Public Constructors

 | Name | Description
Public Constructor | CloseCaseSetup Constructor | Initializes a new instance of the CloseCaseSetup class.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation. | | Public Property | CaseIDNum | Identifier of the Case being closed. | | Public Property | CaseTimeAndExpenses | Object containing sums information for the case closing. | | Public Property | CloseDate | DateTime the Case was closed. If not set, the current time is used. | | Public Property | GenerateTimeBombs | Specifies if timebombs should be created. | | Public Property | Resolution | Element from the 'Resolution Code' application defined list. If not set, the default list value is used.

| | Public Property | Status | Element from the 'Closed' application defined list. If not set, the default list value is used. | | Public Property | Summary | Summary information about the closure. | | Public Property | UnitsUsed | The number of units to charge against the contract for the Case. If the Case has no contract, this field must be 0. | | Public Property | UserName | The User who closed the Case. If not set, the session user is used. |

Reference

CloseCaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
CloseCase(CloseCaseSetup) Method


CloseCaseSetup Constructor | fcSDK Documentation

CloseCaseSetup Constructor

Identifier of the Case being closed.

Initializes a new instance of the CloseCaseSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _caseIDNum_ As String _
)

[ConstructorIndexAttribute()]
public CloseCaseSetup(
   string _caseIDNum_
)

Parameters

caseIDNum

Identifier of the Case being closed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CloseCaseSetup Class
CloseCaseSetup Members


AdditionalFields Property (CloseCaseSetup) | fcSDK Documentation

AdditionalFields Property (CloseCaseSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CloseCaseSetup Class
CloseCaseSetup Members


CaseIDNum Property (CloseCaseSetup) | fcSDK Documentation

CaseIDNum Property (CloseCaseSetup)

Identifier of the Case being closed.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CloseCaseSetup Class
CloseCaseSetup Members


CaseTimeAndExpenses Property (CloseCaseSetup) | fcSDK Documentation

CaseTimeAndExpenses Property (CloseCaseSetup)

Object containing sums information for the case closing.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseTimeAndExpenses As CaseTimeAndExpenses

[PropertyBitValueAttribute()]
public CaseTimeAndExpenses CaseTimeAndExpenses {get; set;}

Remarks

If set, this property overrides the calculation of the Case summation.

PrecloseCase returns a CaseSums object useful for using with this property. If using the CaseSums result from PrecloseCase, any log entries between calling PrecloseCase and CloseCase will not be included in the summation.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CloseCaseSetup Class
CloseCaseSetup Members


CloseDate Property (CloseCaseSetup) | fcSDK Documentation

CloseDate Property (CloseCaseSetup)

DateTime the Case was closed. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CloseDate As Date

[PropertyBitValueAttribute()]
public DateTime CloseDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CloseCaseSetup Class
CloseCaseSetup Members


GenerateTimeBombs Property (CloseCaseSetup) | fcSDK Documentation

GenerateTimeBombs Property (CloseCaseSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CloseCaseSetup Class
CloseCaseSetup Members


Resolution Property (CloseCaseSetup) | fcSDK Documentation

Resolution Property (CloseCaseSetup)

Element from the 'Resolution Code' application defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Resolution As String

[PropertyBitValueAttribute()]
public string Resolution {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CloseCaseSetup Class
CloseCaseSetup Members


Status Property (CloseCaseSetup) | fcSDK Documentation

Status Property (CloseCaseSetup)

Element from the 'Closed' application defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Status As String

[PropertyBitValueAttribute()]
public string Status {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CloseCaseSetup Class
CloseCaseSetup Members


Summary Property (CloseCaseSetup) | fcSDK Documentation

Summary Property (CloseCaseSetup)

Summary information about the closure.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Summary As String

[PropertyBitValueAttribute()]
public string Summary {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CloseCaseSetup Class
CloseCaseSetup Members


UnitsUsed Property (CloseCaseSetup) | fcSDK Documentation

UnitsUsed Property (CloseCaseSetup)

The number of units to charge against the contract for the Case. If the Case has no contract, this field must be 0.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UnitsUsed As Double

[PropertyBitValueAttribute()]
public double UnitsUsed {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CloseCaseSetup Class
CloseCaseSetup Members


UserName Property (CloseCaseSetup) | fcSDK Documentation

UserName Property (CloseCaseSetup)

The User who closed the Case. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CloseCaseSetup Class
CloseCaseSetup Members


CloseSubcaseSetup Class | fcSDK Documentation

CloseSubcaseSetup Class

Used by the CloseSubcase method as setup data for invocation.

Syntax

'Declaration

Public Class CloseSubcaseSetup

public class CloseSubcaseSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.CloseSubcaseSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CloseSubcaseSetup Members
FChoice.Toolkits.Clarify.Support Namespace
CloseSubcase(CloseSubcaseSetup) Method


CloseSubcaseSetup Class Members | fcSDK Documentation

CloseSubcaseSetup Class Members

The following tables list the members exposed by CloseSubcaseSetup.

Public Constructors

 | Name | Description
Public Constructor | CloseSubcaseSetup Constructor | Initializes a new instance of the CloseSubcaseSetup class.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation. | | Public Property | CloseDate | DateTime the Subcase was closed. If not set, the current time is used. | | Public Property | GenerateTimeBombs | Specifies if timebombs should be created. | | Public Property | Resolution | Element from the 'Resolution Code' application defined list. If not set, the default list value is used.

| | Public Property | Status | Element from the 'Closed' application defined list. If not set, the default list value is used. | | Public Property | SubcaseIDNum | Subcase Identifier. | | Public Property | Summary | Information about the closure. | | Public Property | UserName | The User who closed the Subcase. If not set, the session user is used. |

Reference

CloseSubcaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
CloseSubcase(CloseSubcaseSetup) Method


CloseSubcaseSetup Constructor | fcSDK Documentation

CloseSubcaseSetup Constructor

Subcase Identifier.

Initializes a new instance of the CloseSubcaseSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _subcaseIDNum_ As String _
)

[ConstructorIndexAttribute()]
public CloseSubcaseSetup(
   string _subcaseIDNum_
)

Parameters

subcaseIDNum

Subcase Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CloseSubcaseSetup Class
CloseSubcaseSetup Members


AdditionalFields Property (CloseSubcaseSetup) | fcSDK Documentation

AdditionalFields Property (CloseSubcaseSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CloseSubcaseSetup Class
CloseSubcaseSetup Members


CloseDate Property (CloseSubcaseSetup) | fcSDK Documentation

CloseDate Property (CloseSubcaseSetup)

DateTime the Subcase was closed. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CloseDate As Date

[PropertyBitValueAttribute()]
public DateTime CloseDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CloseSubcaseSetup Class
CloseSubcaseSetup Members


GenerateTimeBombs Property (CloseSubcaseSetup) | fcSDK Documentation

GenerateTimeBombs Property (CloseSubcaseSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CloseSubcaseSetup Class
CloseSubcaseSetup Members


Resolution Property (CloseSubcaseSetup) | fcSDK Documentation

Resolution Property (CloseSubcaseSetup)

Element from the 'Resolution Code' application defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Resolution As String

[PropertyBitValueAttribute()]
public string Resolution {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CloseSubcaseSetup Class
CloseSubcaseSetup Members


Status Property (CloseSubcaseSetup) | fcSDK Documentation

Status Property (CloseSubcaseSetup)

Element from the 'Closed' application defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Status As String

[PropertyBitValueAttribute()]
public string Status {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CloseSubcaseSetup Class
CloseSubcaseSetup Members


SubcaseIDNum Property (CloseSubcaseSetup) | fcSDK Documentation

SubcaseIDNum Property (CloseSubcaseSetup)

Subcase Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SubcaseIDNum As String

[PropertyBitValueAttribute()]
public string SubcaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CloseSubcaseSetup Class
CloseSubcaseSetup Members


Summary Property (CloseSubcaseSetup) | fcSDK Documentation

Summary Property (CloseSubcaseSetup)

Information about the closure.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Summary As String

[PropertyBitValueAttribute()]
public string Summary {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CloseSubcaseSetup Class
CloseSubcaseSetup Members


UserName Property (CloseSubcaseSetup) | fcSDK Documentation

UserName Property (CloseSubcaseSetup)

The User who closed the Subcase. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CloseSubcaseSetup Class
CloseSubcaseSetup Members


CompatibilityApplicationClock Class | fcSDK Documentation

CompatibilityApplicationClock Class

Syntax

'Declaration

Public Class CompatibilityApplicationClock
   Implements IApplicationClock

public class CompatibilityApplicationClock : IApplicationClock

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.CompatibilityApplicationClock

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CompatibilityApplicationClock Members
FChoice.Toolkits.Clarify.Support Namespace


CompatibilityApplicationClock Class Members | fcSDK Documentation

CompatibilityApplicationClock Class Members

The following tables list the members exposed by CompatibilityApplicationClock.

Public Constructors

 | Name | Description
Public Constructor | CompatibilityApplicationClock Constructor |

Public Properties

 | Name | Description
Public Property | Now |

Reference

CompatibilityApplicationClock Class
FChoice.Toolkits.Clarify.Support Namespace


CompatibilityApplicationClock Constructor | fcSDK Documentation

CompatibilityApplicationClock Constructor

Syntax

'Declaration

Public Function New( _
   ByVal _session_ As IFCSession _
)

public CompatibilityApplicationClock(
   IFCSession _session_
)

Parameters

session

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CompatibilityApplicationClock Class
CompatibilityApplicationClock Members


Now Property (CompatibilityApplicationClock) | fcSDK Documentation

Now Property (CompatibilityApplicationClock)

Syntax

'Declaration

Public ReadOnly Property Now As Date

public DateTime Now {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CompatibilityApplicationClock Class
CompatibilityApplicationClock Members


CreateCaseObjidSetup Class | fcSDK Documentation

CreateCaseObjidSetup Class

Used by the CreateCaseObjid method as setup data for invocation.

Syntax

'Declaration

Public Class CreateCaseObjidSetup

public class CreateCaseObjidSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.CreateCaseObjidSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateCaseObjidSetup Members
FChoice.Toolkits.Clarify.Support Namespace
CreateCaseObjid(CreateCaseObjidSetup) Method


CreateCaseObjidSetup Class Members | fcSDK Documentation

CreateCaseObjidSetup Class Members

The following tables list the members exposed by CreateCaseObjidSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateCaseObjidSetup Constructor | Initializes a new instance of the CreateCaseObjidSetup class.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | AddressObjid | Address Objid.
Public Property | CaseType | Element from the 'Case Type' application defined list. If not set, the default list value is used.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactObjid | Contact Objid that represents the contact for the Case.
Public Property | ContactPhone | Contact's phone number.
Public Property | ContractObjid | Contract Objid for the Case. If not set, there is no contract.
Public Property | CreateDate | DateTime the Case was created. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | PartRevisionObjid | Revision Objid of the Case part or SitePart.
Public Property | PhoneEndDate | If there is a phone log, this is the DateTime that the call ended. If not set, the Case creation time is used.
Public Property | PhoneLogNotes | Phone notes for the Case.
Public Property | Priority | Element from the 'Response Priority Code' application defined list. If not set, the default list value is used.
Public Property | Queue | Name of the queue to dispatch the Case to. If not set, the Case is not initially dispatched.
Public Property | Serverity | Element from the 'Problem Severity Level' application defined list. If not set, the default list value is used.
Public Property | SiteObjid | Site Objid to which Site reported the Case.
Public Property | SitePartObjid | Objid of SitePart for the Case.
Public Property | Status | Initial status. Element from the 'Open' application defined list. If not set, the default list value is used.
Public Property | Title | Title for the Case.
Public Property | UserName | The User who created the Case. If not set, the session user is used.

Reference

CreateCaseObjidSetup Class
FChoice.Toolkits.Clarify.Support Namespace
CreateCaseObjid(CreateCaseObjidSetup) Method


CreateCaseObjidSetup Constructor | fcSDK Documentation

CreateCaseObjidSetup Constructor

Initializes a new instance of the CreateCaseObjidSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New()

[ConstructorIndexAttribute()]
public CreateCaseObjidSetup()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseObjidSetup Class
CreateCaseObjidSetup Members


AdditionalFields Property (CreateCaseObjidSetup) | fcSDK Documentation

AdditionalFields Property (CreateCaseObjidSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseObjidSetup Class
CreateCaseObjidSetup Members


AddressObjid Property (CreateCaseObjidSetup) | fcSDK Documentation

AddressObjid Property (CreateCaseObjidSetup)

Address Objid.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property AddressObjid As Integer

[PropertyBitValueAttribute()]
public int AddressObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseObjidSetup Class
CreateCaseObjidSetup Members


CaseType Property (CreateCaseObjidSetup) | fcSDK Documentation

CaseType Property (CreateCaseObjidSetup)

Element from the 'Case Type' application defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseType As String

[PropertyBitValueAttribute()]
public string CaseType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseObjidSetup Class
CreateCaseObjidSetup Members


ContactFirstName Property (CreateCaseObjidSetup) | fcSDK Documentation

ContactFirstName Property (CreateCaseObjidSetup)

Contact's first name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactFirstName As String

[PropertyBitValueAttribute()]
public string ContactFirstName {get; set;}

Property Value

This must be set if the ContractObjid is not known.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseObjidSetup Class
CreateCaseObjidSetup Members


ContactLastName Property (CreateCaseObjidSetup) | fcSDK Documentation

ContactLastName Property (CreateCaseObjidSetup)

Contact's last name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactLastName As String

[PropertyBitValueAttribute()]
public string ContactLastName {get; set;}

Property Value

This must be set if the ContractObjid is not known.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseObjidSetup Class
CreateCaseObjidSetup Members


ContactObjid Property (CreateCaseObjidSetup) | fcSDK Documentation

ContactObjid Property (CreateCaseObjidSetup)

Contact Objid that represents the contact for the Case.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactObjid As Integer

[PropertyBitValueAttribute()]
public int ContactObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseObjidSetup Class
CreateCaseObjidSetup Members


ContactPhone Property (CreateCaseObjidSetup) | fcSDK Documentation

ContactPhone Property (CreateCaseObjidSetup)

Contact's phone number.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactPhone As String

[PropertyBitValueAttribute()]
public string ContactPhone {get; set;}

Property Value

This must be set if the ContractObjid is not known.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseObjidSetup Class
CreateCaseObjidSetup Members


ContractObjid Property (CreateCaseObjidSetup) | fcSDK Documentation

ContractObjid Property (CreateCaseObjidSetup)

Contract Objid for the Case. If not set, there is no contract.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContractObjid As Integer

[PropertyBitValueAttribute()]
public int ContractObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseObjidSetup Class
CreateCaseObjidSetup Members


CreateDate Property (CreateCaseObjidSetup) | fcSDK Documentation

CreateDate Property (CreateCaseObjidSetup)

DateTime the Case was created. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseObjidSetup Class
CreateCaseObjidSetup Members


GenerateTimeBombs Property (CreateCaseObjidSetup) | fcSDK Documentation

GenerateTimeBombs Property (CreateCaseObjidSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseObjidSetup Class
CreateCaseObjidSetup Members


PartRevisionObjid Property (CreateCaseObjidSetup) | fcSDK Documentation

PartRevisionObjid Property (CreateCaseObjidSetup)

Revision Objid of the Case part or SitePart.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRevisionObjid As Integer

[PropertyBitValueAttribute()]
public int PartRevisionObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseObjidSetup Class
CreateCaseObjidSetup Members


PhoneEndDate Property (CreateCaseObjidSetup) | fcSDK Documentation

PhoneEndDate Property (CreateCaseObjidSetup)

If there is a phone log, this is the DateTime that the call ended. If not set, the Case creation time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PhoneEndDate As Date

[PropertyBitValueAttribute()]
public DateTime PhoneEndDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseObjidSetup Class
CreateCaseObjidSetup Members


PhoneLogNotes Property (CreateCaseObjidSetup) | fcSDK Documentation

PhoneLogNotes Property (CreateCaseObjidSetup)

Phone notes for the Case.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PhoneLogNotes As String

[PropertyBitValueAttribute()]
public string PhoneLogNotes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseObjidSetup Class
CreateCaseObjidSetup Members


Priority Property (CreateCaseObjidSetup) | fcSDK Documentation

Priority Property (CreateCaseObjidSetup)

Element from the 'Response Priority Code' application defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Priority As String

[PropertyBitValueAttribute()]
public string Priority {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseObjidSetup Class
CreateCaseObjidSetup Members


Queue Property (CreateCaseObjidSetup) | fcSDK Documentation

Queue Property (CreateCaseObjidSetup)

Name of the queue to dispatch the Case to. If not set, the Case is not initially dispatched.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Queue As String

[PropertyBitValueAttribute()]
public string Queue {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseObjidSetup Class
CreateCaseObjidSetup Members


Serverity Property | fcSDK Documentation

Serverity Property

Element from the 'Problem Severity Level' application defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Serverity As String

[PropertyBitValueAttribute()]
public string Serverity {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseObjidSetup Class
CreateCaseObjidSetup Members


SiteObjid Property (CreateCaseObjidSetup) | fcSDK Documentation

SiteObjid Property (CreateCaseObjidSetup)

Site Objid to which Site reported the Case.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteObjid As Integer

[PropertyBitValueAttribute()]
public int SiteObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseObjidSetup Class
CreateCaseObjidSetup Members


SitePartObjid Property (CreateCaseObjidSetup) | fcSDK Documentation

SitePartObjid Property (CreateCaseObjidSetup)

Objid of SitePart for the Case.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SitePartObjid As Integer

[PropertyBitValueAttribute()]
public int SitePartObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseObjidSetup Class
CreateCaseObjidSetup Members


Status Property (CreateCaseObjidSetup) | fcSDK Documentation

Status Property (CreateCaseObjidSetup)

Initial status. Element from the 'Open' application defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Status As String

[PropertyBitValueAttribute()]
public string Status {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseObjidSetup Class
CreateCaseObjidSetup Members


Title Property (CreateCaseObjidSetup) | fcSDK Documentation

Title Property (CreateCaseObjidSetup)

Title for the Case.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Title As String

[PropertyBitValueAttribute()]
public string Title {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseObjidSetup Class
CreateCaseObjidSetup Members


UserName Property (CreateCaseObjidSetup) | fcSDK Documentation

UserName Property (CreateCaseObjidSetup)

The User who created the Case. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseObjidSetup Class
CreateCaseObjidSetup Members


CreateCaseSetup Class | fcSDK Documentation

CreateCaseSetup Class

Used by the CreateCase method as setup data for invocation.

Syntax

'Declaration

Public Class CreateCaseSetup

public class CreateCaseSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.CreateCaseSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateCaseSetup Members
FChoice.Toolkits.Clarify.Support Namespace
CreateCase(CreateCaseSetup) Method


CreateCaseSetup Class Members | fcSDK Documentation

CreateCaseSetup Class Members

The following tables list the members exposed by CreateCaseSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateCaseSetup Constructor | Initializes a new instance of the CreateCaseSetup class.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CaseType | Element from the 'Case Type' application defined list. If not set, the default list value is used.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | ContractIDNum | Contract Identifier for the Case. If not set, no Contract is related to the Case.
Public Property | CreateDate | DateTime the Case was created. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | PartDomain | Part Domain of the Case part or SitePart.
Public Property | PartNumber | Part Number of the Case part or SitePart.
Public Property | PartRevision | Revision of the Case part or SitePart.
Public Property | PhoneEndDate | If there is a phone log, this is the DateTime that the call ended. If not set, the Case creation time is used.
Public Property | PhoneLogNotes | Phone notes for the Case.
Public Property | Priority | Element from the 'Response Priority Code' application defined list. If not set, the default list value is used.
Public Property | Queue | Name of the queue to dispatch the Case to. If not set, the Case is not initially dispatched.
Public Property | SerialNumber | Serial number of the SitePart for the Case (if there is one).
Public Property | Severity | Element from the 'Problem Severity Level' application defined list. If not set, the default list value is used.
Public Property | SiteIDNum | Site Identifier to which Site reported the Case.
Public Property | SitePartObjid | Objid of SitePart for the Case.
Public Property | Status | Initial status. Element from the 'Open' application defined list. If not set, the default list value is used.
Public Property | Title | Title for the Case.
Public Property | UserName | The User who created the Case. If not set, the session user is used.

Reference

CreateCaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
CreateCase(CreateCaseSetup) Method


CreateCaseSetup Constructor | fcSDK Documentation

CreateCaseSetup Constructor

Site Identifier to which Site reported the Case.

Contact's first name.

Contact's last name.

Contact's phone number.

Initializes a new instance of the CreateCaseSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _siteIDNum_ As String, _
   ByVal _contactFirstName_ As String, _
   ByVal _contactLastName_ As String, _
   ByVal _contactPhone_ As String _
)

[ConstructorIndexAttribute()]
public CreateCaseSetup(
   string _siteIDNum_,
   string _contactFirstName_,
   string _contactLastName_,
   string _contactPhone_
)

Parameters

siteIDNum

Site Identifier to which Site reported the Case.

contactFirstName

Contact's first name.

contactLastName

Contact's last name.

contactPhone

Contact's phone number.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseSetup Class
CreateCaseSetup Members


AdditionalFields Property (CreateCaseSetup) | fcSDK Documentation

AdditionalFields Property (CreateCaseSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseSetup Class
CreateCaseSetup Members


CaseType Property (CreateCaseSetup) | fcSDK Documentation

CaseType Property (CreateCaseSetup)

Element from the 'Case Type' application defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseType As String

[PropertyBitValueAttribute()]
public string CaseType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseSetup Class
CreateCaseSetup Members


ContactFirstName Property (CreateCaseSetup) | fcSDK Documentation

ContactFirstName Property (CreateCaseSetup)

Contact's first name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactFirstName As String

[PropertyBitValueAttribute()]
public string ContactFirstName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseSetup Class
CreateCaseSetup Members


ContactLastName Property (CreateCaseSetup) | fcSDK Documentation

ContactLastName Property (CreateCaseSetup)

Contact's last name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactLastName As String

[PropertyBitValueAttribute()]
public string ContactLastName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseSetup Class
CreateCaseSetup Members


ContactPhone Property (CreateCaseSetup) | fcSDK Documentation

ContactPhone Property (CreateCaseSetup)

Contact's phone number.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactPhone As String

[PropertyBitValueAttribute()]
public string ContactPhone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseSetup Class
CreateCaseSetup Members


ContractIDNum Property (CreateCaseSetup) | fcSDK Documentation

ContractIDNum Property (CreateCaseSetup)

Contract Identifier for the Case. If not set, no Contract is related to the Case.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContractIDNum As String

[PropertyBitValueAttribute()]
public string ContractIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseSetup Class
CreateCaseSetup Members


CreateDate Property (CreateCaseSetup) | fcSDK Documentation

CreateDate Property (CreateCaseSetup)

DateTime the Case was created. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseSetup Class
CreateCaseSetup Members


GenerateTimeBombs Property (CreateCaseSetup) | fcSDK Documentation

GenerateTimeBombs Property (CreateCaseSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseSetup Class
CreateCaseSetup Members


PartDomain Property (CreateCaseSetup) | fcSDK Documentation

PartDomain Property (CreateCaseSetup)

Part Domain of the Case part or SitePart.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartDomain As String

[PropertyBitValueAttribute()]
public string PartDomain {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseSetup Class
CreateCaseSetup Members


PartNumber Property (CreateCaseSetup) | fcSDK Documentation

PartNumber Property (CreateCaseSetup)

Part Number of the Case part or SitePart.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartNumber As String

[PropertyBitValueAttribute()]
public string PartNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseSetup Class
CreateCaseSetup Members


PartRevision Property (CreateCaseSetup) | fcSDK Documentation

PartRevision Property (CreateCaseSetup)

Revision of the Case part or SitePart.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRevision As String

[PropertyBitValueAttribute()]
public string PartRevision {get; set;}

Remarks

If the revision is NULL (Oracle only), still use the empty string ("") to query.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseSetup Class
CreateCaseSetup Members


PhoneEndDate Property (CreateCaseSetup) | fcSDK Documentation

PhoneEndDate Property (CreateCaseSetup)

If there is a phone log, this is the DateTime that the call ended. If not set, the Case creation time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PhoneEndDate As Date

[PropertyBitValueAttribute()]
public DateTime PhoneEndDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseSetup Class
CreateCaseSetup Members


PhoneLogNotes Property (CreateCaseSetup) | fcSDK Documentation

PhoneLogNotes Property (CreateCaseSetup)

Phone notes for the Case.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PhoneLogNotes As String

[PropertyBitValueAttribute()]
public string PhoneLogNotes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseSetup Class
CreateCaseSetup Members


Priority Property (CreateCaseSetup) | fcSDK Documentation

Priority Property (CreateCaseSetup)

Element from the 'Response Priority Code' application defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Priority As String

[PropertyBitValueAttribute()]
public string Priority {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseSetup Class
CreateCaseSetup Members


Queue Property (CreateCaseSetup) | fcSDK Documentation

Queue Property (CreateCaseSetup)

Name of the queue to dispatch the Case to. If not set, the Case is not initially dispatched.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Queue As String

[PropertyBitValueAttribute()]
public string Queue {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseSetup Class
CreateCaseSetup Members


SerialNumber Property (CreateCaseSetup) | fcSDK Documentation

SerialNumber Property (CreateCaseSetup)

Serial number of the SitePart for the Case (if there is one).

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SerialNumber As String

[PropertyBitValueAttribute()]
public string SerialNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseSetup Class
CreateCaseSetup Members


Severity Property (CreateCaseSetup) | fcSDK Documentation

Severity Property (CreateCaseSetup)

Element from the 'Problem Severity Level' application defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Severity As String

[PropertyBitValueAttribute()]
public string Severity {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseSetup Class
CreateCaseSetup Members


SiteIDNum Property (CreateCaseSetup) | fcSDK Documentation

SiteIDNum Property (CreateCaseSetup)

Site Identifier to which Site reported the Case.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SiteIDNum As String

[PropertyBitValueAttribute()]
public string SiteIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseSetup Class
CreateCaseSetup Members


SitePartObjid Property (CreateCaseSetup) | fcSDK Documentation

SitePartObjid Property (CreateCaseSetup)

Objid of SitePart for the Case.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SitePartObjid As Integer

[PropertyBitValueAttribute()]
public int SitePartObjid {get; set;}

Remarks

If set, PartNumber, PartDomain, and PartRevision properties are ignored.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseSetup Class
CreateCaseSetup Members


Status Property (CreateCaseSetup) | fcSDK Documentation

Status Property (CreateCaseSetup)

Initial status. Element from the 'Open' application defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Status As String

[PropertyBitValueAttribute()]
public string Status {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseSetup Class
CreateCaseSetup Members


Title Property (CreateCaseSetup) | fcSDK Documentation

Title Property (CreateCaseSetup)

Title for the Case.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Title As String

[PropertyBitValueAttribute()]
public string Title {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseSetup Class
CreateCaseSetup Members


UserName Property (CreateCaseSetup) | fcSDK Documentation

UserName Property (CreateCaseSetup)

The User who created the Case. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateCaseSetup Class
CreateCaseSetup Members


CreateSubcaseSetup Class | fcSDK Documentation

CreateSubcaseSetup Class

Used by the CreateSubcase method as setup data for invocation.

Syntax

'Declaration

Public Class CreateSubcaseSetup

public class CreateSubcaseSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.CreateSubcaseSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

CreateSubcaseSetup Members
FChoice.Toolkits.Clarify.Support Namespace
CreateSubcase(CreateSubcaseSetup) Method


CreateSubcaseSetup Class Members | fcSDK Documentation

CreateSubcaseSetup Class Members

The following tables list the members exposed by CreateSubcaseSetup.

Public Constructors

 | Name | Description
Public Constructor | CreateSubcaseSetup Constructor | Initializes a new instance of the CreateSubcaseSetup class.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CaseIDNum | Case Identifier of the parent Case.
Public Property | CreateDate | DateTime the Subcase was created. If not set, the current time is used.
Public Property | DueDate | DateTime for when the commitment for Subcase is due. If not set, the Subcase creation time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | IsGeneral | Specifies if this is a general Subcase (True), or administrative (False).
Public Property | Notes | Subcase notes.
Public Property | Priority | Element from the 'Response Priority Code' application defined list. If not set, the default list value is used.
Public Property | PriorWarning | The length of time prior to the due date that a warning should be issued.
Public Property | Queue | Name of the queue to dispatch the Subcase to. If not set, the Subcase is not initially dispatched.
Public Property | Severity | Element from the 'Problem Severity Level' application defined list. If not set, the default list value is used.
Public Property | Status | Initial status. Element from the 'Open' application defined list. If not set, the default list value is used.
Public Property | Title | Title for the Case.
Public Property | UserName | The User who created the Subcase. If not set, the session user is used.

Reference

CreateSubcaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
CreateSubcase(CreateSubcaseSetup) Method


CreateSubcaseSetup Constructor | fcSDK Documentation

CreateSubcaseSetup Constructor

Case Identifier of the parent Case.

Initializes a new instance of the CreateSubcaseSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _caseIDNum_ As String _
)

[ConstructorIndexAttribute()]
public CreateSubcaseSetup(
   string _caseIDNum_
)

Parameters

caseIDNum

Case Identifier of the parent Case.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSubcaseSetup Class
CreateSubcaseSetup Members


AdditionalFields Property (CreateSubcaseSetup) | fcSDK Documentation

AdditionalFields Property (CreateSubcaseSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSubcaseSetup Class
CreateSubcaseSetup Members


CaseIDNum Property (CreateSubcaseSetup) | fcSDK Documentation

CaseIDNum Property (CreateSubcaseSetup)

Case Identifier of the parent Case.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSubcaseSetup Class
CreateSubcaseSetup Members


CreateDate Property (CreateSubcaseSetup) | fcSDK Documentation

CreateDate Property (CreateSubcaseSetup)

DateTime the Subcase was created. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CreateDate As Date

[PropertyBitValueAttribute()]
public DateTime CreateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSubcaseSetup Class
CreateSubcaseSetup Members


DueDate Property (CreateSubcaseSetup) | fcSDK Documentation

DueDate Property (CreateSubcaseSetup)

DateTime for when the commitment for Subcase is due. If not set, the Subcase creation time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property DueDate As Date

[PropertyBitValueAttribute()]
public DateTime DueDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSubcaseSetup Class
CreateSubcaseSetup Members


GenerateTimeBombs Property (CreateSubcaseSetup) | fcSDK Documentation

GenerateTimeBombs Property (CreateSubcaseSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSubcaseSetup Class
CreateSubcaseSetup Members


IsGeneral Property | fcSDK Documentation

IsGeneral Property

Specifies if this is a general Subcase (True), or administrative (False).

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsGeneral As Boolean

[PropertyBitValueAttribute()]
public bool IsGeneral {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSubcaseSetup Class
CreateSubcaseSetup Members


Notes Property (CreateSubcaseSetup) | fcSDK Documentation

Notes Property (CreateSubcaseSetup)

Subcase notes.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSubcaseSetup Class
CreateSubcaseSetup Members


Priority Property (CreateSubcaseSetup) | fcSDK Documentation

Priority Property (CreateSubcaseSetup)

Element from the 'Response Priority Code' application defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Priority As String

[PropertyBitValueAttribute()]
public string Priority {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSubcaseSetup Class
CreateSubcaseSetup Members


PriorWarning Property (CreateSubcaseSetup) | fcSDK Documentation

PriorWarning Property (CreateSubcaseSetup)

The length of time prior to the due date that a warning should be issued.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PriorWarning As TimeSpan

[PropertyBitValueAttribute()]
public TimeSpan PriorWarning {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSubcaseSetup Class
CreateSubcaseSetup Members


Queue Property (CreateSubcaseSetup) | fcSDK Documentation

Queue Property (CreateSubcaseSetup)

Name of the queue to dispatch the Subcase to. If not set, the Subcase is not initially dispatched.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Queue As String

[PropertyBitValueAttribute()]
public string Queue {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSubcaseSetup Class
CreateSubcaseSetup Members


Severity Property (CreateSubcaseSetup) | fcSDK Documentation

Severity Property (CreateSubcaseSetup)

Element from the 'Problem Severity Level' application defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Severity As String

[PropertyBitValueAttribute()]
public string Severity {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSubcaseSetup Class
CreateSubcaseSetup Members


Status Property (CreateSubcaseSetup) | fcSDK Documentation

Status Property (CreateSubcaseSetup)

Initial status. Element from the 'Open' application defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Status As String

[PropertyBitValueAttribute()]
public string Status {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSubcaseSetup Class
CreateSubcaseSetup Members


Title Property (CreateSubcaseSetup) | fcSDK Documentation

Title Property (CreateSubcaseSetup)

Title for the Case.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Title As String

[PropertyBitValueAttribute()]
public string Title {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSubcaseSetup Class
CreateSubcaseSetup Members


UserName Property (CreateSubcaseSetup) | fcSDK Documentation

UserName Property (CreateSubcaseSetup)

The User who created the Subcase. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSubcaseSetup Class
CreateSubcaseSetup Members


DispatchCaseSetup Class | fcSDK Documentation

DispatchCaseSetup Class

Used by the DispatchCase method as setup data for invocation.

Syntax

'Declaration

Public Class DispatchCaseSetup

public class DispatchCaseSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.DispatchCaseSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

DispatchCaseSetup Members
FChoice.Toolkits.Clarify.Support Namespace
DispatchCase(DispatchCaseSetup) Method


DispatchCaseSetup Class Members | fcSDK Documentation

DispatchCaseSetup Class Members

The following tables list the members exposed by DispatchCaseSetup.

Public Constructors

 | Name | Description
Public Constructor | DispatchCaseSetup Constructor | Initializes a new instance of the DispatchCaseSetup class.

Public Properties

 | Name | Description
Public Property | CaseIDNum | Case Identifier.
Public Property | DispatchDate | DateTime the Case was dispatched. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Queue | The queue into which the Case is to be dispatched.
Public Property | UserName | The user who has dispatched the Case. If not set, the Toolkit session user is used.

Reference

DispatchCaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
DispatchCase(DispatchCaseSetup) Method


DispatchCaseSetup Constructor | fcSDK Documentation

DispatchCaseSetup Constructor

Case Identifier.

The queue into which the Case is to be dispatched.

Initializes a new instance of the DispatchCaseSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _caseIDNum_ As String, _
   ByVal _queue_ As String _
)

[ConstructorIndexAttribute()]
public DispatchCaseSetup(
   string _caseIDNum_,
   string _queue_
)

Parameters

caseIDNum

Case Identifier.

queue

The queue into which the Case is to be dispatched.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchCaseSetup Class
DispatchCaseSetup Members


CaseIDNum Property (DispatchCaseSetup) | fcSDK Documentation

CaseIDNum Property (DispatchCaseSetup)

Case Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchCaseSetup Class
DispatchCaseSetup Members


DispatchDate Property (DispatchCaseSetup) | fcSDK Documentation

DispatchDate Property (DispatchCaseSetup)

DateTime the Case was dispatched. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property DispatchDate As Date

[PropertyBitValueAttribute()]
public DateTime DispatchDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchCaseSetup Class
DispatchCaseSetup Members


GenerateTimeBombs Property (DispatchCaseSetup) | fcSDK Documentation

GenerateTimeBombs Property (DispatchCaseSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchCaseSetup Class
DispatchCaseSetup Members


Queue Property (DispatchCaseSetup) | fcSDK Documentation

Queue Property (DispatchCaseSetup)

The queue into which the Case is to be dispatched.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Queue As String

[PropertyBitValueAttribute()]
public string Queue {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchCaseSetup Class
DispatchCaseSetup Members


UserName Property (DispatchCaseSetup) | fcSDK Documentation

UserName Property (DispatchCaseSetup)

The user who has dispatched the Case. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchCaseSetup Class
DispatchCaseSetup Members


DispatchSubcaseSetup Class | fcSDK Documentation

DispatchSubcaseSetup Class

Used by the DispatchSubcase method as setup data for invocation.

Syntax

'Declaration

Public Class DispatchSubcaseSetup

public class DispatchSubcaseSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.DispatchSubcaseSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

DispatchSubcaseSetup Members
FChoice.Toolkits.Clarify.Support Namespace
DispatchSubcase(DispatchSubcaseSetup) Method


DispatchSubcaseSetup Class Members | fcSDK Documentation

DispatchSubcaseSetup Class Members

The following tables list the members exposed by DispatchSubcaseSetup.

Public Constructors

 | Name | Description
Public Constructor | DispatchSubcaseSetup Constructor | Initializes a new instance of the DispatchSubcaseSetup class.

Public Properties

 | Name | Description
Public Property | DispatchDate | DateTime the Subcase was dispatched. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Queue | The queue into which the Subcase is to be dispatched.
Public Property | SubcaseIDNum | Subcase Identifier.
Public Property | UserName | The user who has dispatched the Subcase. If not set, the Toolkit session user is used.

Reference

DispatchSubcaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
DispatchSubcase(DispatchSubcaseSetup) Method


DispatchSubcaseSetup Constructor | fcSDK Documentation

DispatchSubcaseSetup Constructor

Subcase Identifier.

The queue into which the Subcase is to be dispatched.

Initializes a new instance of the DispatchSubcaseSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _subcaseIDNum_ As String, _
   ByVal _queue_ As String _
)

[ConstructorIndexAttribute()]
public DispatchSubcaseSetup(
   string _subcaseIDNum_,
   string _queue_
)

Parameters

subcaseIDNum

Subcase Identifier.

queue

The queue into which the Subcase is to be dispatched.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchSubcaseSetup Class
DispatchSubcaseSetup Members


DispatchDate Property (DispatchSubcaseSetup) | fcSDK Documentation

DispatchDate Property (DispatchSubcaseSetup)

DateTime the Subcase was dispatched. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property DispatchDate As Date

[PropertyBitValueAttribute()]
public DateTime DispatchDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchSubcaseSetup Class
DispatchSubcaseSetup Members


GenerateTimeBombs Property (DispatchSubcaseSetup) | fcSDK Documentation

GenerateTimeBombs Property (DispatchSubcaseSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchSubcaseSetup Class
DispatchSubcaseSetup Members


Queue Property (DispatchSubcaseSetup) | fcSDK Documentation

Queue Property (DispatchSubcaseSetup)

The queue into which the Subcase is to be dispatched.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Queue As String

[PropertyBitValueAttribute()]
public string Queue {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchSubcaseSetup Class
DispatchSubcaseSetup Members


SubcaseIDNum Property (DispatchSubcaseSetup) | fcSDK Documentation

SubcaseIDNum Property (DispatchSubcaseSetup)

Subcase Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SubcaseIDNum As String

[PropertyBitValueAttribute()]
public string SubcaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchSubcaseSetup Class
DispatchSubcaseSetup Members


UserName Property (DispatchSubcaseSetup) | fcSDK Documentation

UserName Property (DispatchSubcaseSetup)

The user who has dispatched the Subcase. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DispatchSubcaseSetup Class
DispatchSubcaseSetup Members


ForwardCaseSetup Class | fcSDK Documentation

ForwardCaseSetup Class

Used by the ForwardCase method as setup data for invocation.

Syntax

'Declaration

Public Class ForwardCaseSetup

public class ForwardCaseSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.ForwardCaseSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ForwardCaseSetup Members
FChoice.Toolkits.Clarify.Support Namespace
ForwardCase(ForwardCaseSetup) Method


ForwardCaseSetup Class Members | fcSDK Documentation

ForwardCaseSetup Class Members

The following tables list the members exposed by ForwardCaseSetup.

Public Constructors

 | Name | Description
Public Constructor | ForwardCaseSetup Constructor | Initializes a new instance of the ForwardCaseSetup class.

Public Properties

 | Name | Description
Public Property | CaseIDNum | Case Identifier.
Public Property | ForwardDate | DateTime the Case was forwarded. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewQueue | The new queue into which the Case is to be forwarded.
Public Property | Notes | The reason the Case was rejected from the queue into which it was dispatched.
Public Property | UserName | The user who has forwarded the Case. If not set, the Toolkit session user is used.

Reference

ForwardCaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
ForwardCase(ForwardCaseSetup) Method


ForwardCaseSetup Constructor | fcSDK Documentation

ForwardCaseSetup Constructor

Case Identifier.

The new queue into which the Case is to be forwarded.

Initializes a new instance of the ForwardCaseSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _caseIDNum_ As String, _
   ByVal _newQueue_ As String _
)

[ConstructorIndexAttribute()]
public ForwardCaseSetup(
   string _caseIDNum_,
   string _newQueue_
)

Parameters

caseIDNum

Case Identifier.

newQueue

The new queue into which the Case is to be forwarded.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardCaseSetup Class
ForwardCaseSetup Members


CaseIDNum Property (ForwardCaseSetup) | fcSDK Documentation

CaseIDNum Property (ForwardCaseSetup)

Case Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardCaseSetup Class
ForwardCaseSetup Members


ForwardDate Property (ForwardCaseSetup) | fcSDK Documentation

ForwardDate Property (ForwardCaseSetup)

DateTime the Case was forwarded. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ForwardDate As Date

[PropertyBitValueAttribute()]
public DateTime ForwardDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardCaseSetup Class
ForwardCaseSetup Members


GenerateTimeBombs Property (ForwardCaseSetup) | fcSDK Documentation

GenerateTimeBombs Property (ForwardCaseSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardCaseSetup Class
ForwardCaseSetup Members


NewQueue Property (ForwardCaseSetup) | fcSDK Documentation

NewQueue Property (ForwardCaseSetup)

The new queue into which the Case is to be forwarded.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewQueue As String

[PropertyBitValueAttribute()]
public string NewQueue {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardCaseSetup Class
ForwardCaseSetup Members


Notes Property (ForwardCaseSetup) | fcSDK Documentation

Notes Property (ForwardCaseSetup)

The reason the Case was rejected from the queue into which it was dispatched.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardCaseSetup Class
ForwardCaseSetup Members


UserName Property (ForwardCaseSetup) | fcSDK Documentation

UserName Property (ForwardCaseSetup)

The user who has forwarded the Case. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardCaseSetup Class
ForwardCaseSetup Members


ForwardSubcaseSetup Class | fcSDK Documentation

ForwardSubcaseSetup Class

Used by the ForwardSubcase method as setup data for invocation.

Syntax

'Declaration

Public Class ForwardSubcaseSetup

public class ForwardSubcaseSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.ForwardSubcaseSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ForwardSubcaseSetup Members
FChoice.Toolkits.Clarify.Support Namespace
ForwardSubcase(ForwardSubcaseSetup) Method


ForwardSubcaseSetup Class Members | fcSDK Documentation

ForwardSubcaseSetup Class Members

The following tables list the members exposed by ForwardSubcaseSetup.

Public Constructors

 | Name | Description
Public Constructor | ForwardSubcaseSetup Constructor | Initializes a new instance of the ForwardSubcaseSetup class.

Public Properties

 | Name | Description
Public Property | ForwardDate | DateTime the Subcase was forwarded. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewQueue | The new queue into which the Subcase is to be forwarded.
Public Property | Notes | The reason the Subcase was rejected from the queue into which it was dispatched.
Public Property | SubcaseIDNum | Subcase Identifier.
Public Property | UserName | The user who has forwarded the Subcase. If not set, the Toolkit session user is used.

Reference

ForwardSubcaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
ForwardSubcase(ForwardSubcaseSetup) Method


ForwardSubcaseSetup Constructor | fcSDK Documentation

ForwardSubcaseSetup Constructor

Subcase Identifier.

The new queue into which the Subcase is to be forwarded.

Initializes a new instance of the ForwardSubcaseSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _subcaseIDNum_ As String, _
   ByVal _newQueue_ As String _
)

[ConstructorIndexAttribute()]
public ForwardSubcaseSetup(
   string _subcaseIDNum_,
   string _newQueue_
)

Parameters

subcaseIDNum

Subcase Identifier.

newQueue

The new queue into which the Subcase is to be forwarded.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardSubcaseSetup Class
ForwardSubcaseSetup Members


ForwardDate Property (ForwardSubcaseSetup) | fcSDK Documentation

ForwardDate Property (ForwardSubcaseSetup)

DateTime the Subcase was forwarded. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ForwardDate As Date

[PropertyBitValueAttribute()]
public DateTime ForwardDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardSubcaseSetup Class
ForwardSubcaseSetup Members


GenerateTimeBombs Property (ForwardSubcaseSetup) | fcSDK Documentation

GenerateTimeBombs Property (ForwardSubcaseSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardSubcaseSetup Class
ForwardSubcaseSetup Members


NewQueue Property (ForwardSubcaseSetup) | fcSDK Documentation

NewQueue Property (ForwardSubcaseSetup)

The new queue into which the Subcase is to be forwarded.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewQueue As String

[PropertyBitValueAttribute()]
public string NewQueue {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardSubcaseSetup Class
ForwardSubcaseSetup Members


Notes Property (ForwardSubcaseSetup) | fcSDK Documentation

Notes Property (ForwardSubcaseSetup)

The reason the Subcase was rejected from the queue into which it was dispatched.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardSubcaseSetup Class
ForwardSubcaseSetup Members


SubcaseIDNum Property (ForwardSubcaseSetup) | fcSDK Documentation

SubcaseIDNum Property (ForwardSubcaseSetup)

Subcase Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SubcaseIDNum As String

[PropertyBitValueAttribute()]
public string SubcaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardSubcaseSetup Class
ForwardSubcaseSetup Members


UserName Property (ForwardSubcaseSetup) | fcSDK Documentation

UserName Property (ForwardSubcaseSetup)

The user who has forwarded the Subcase. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ForwardSubcaseSetup Class
ForwardSubcaseSetup Members


FulfillCommitmentSetup Class | fcSDK Documentation

FulfillCommitmentSetup Class

Used by the FulfillCommitment method as setup data for invocation.

Syntax

'Declaration

Public Class FulfillCommitmentSetup

public class FulfillCommitmentSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.FulfillCommitmentSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

FulfillCommitmentSetup Members
FChoice.Toolkits.Clarify.Support Namespace
FulfillCommitment(FulfillCommitmentSetup) Method


FulfillCommitmentSetup Class Members | fcSDK Documentation

FulfillCommitmentSetup Class Members

The following tables list the members exposed by FulfillCommitmentSetup.

Public Constructors

 | Name | Description
Public Constructor | FulfillCommitmentSetup Constructor | Initializes a new instance of the FulfillCommitmentSetup class.

Public Properties

 | Name | Description
Public Property | FulfillDate | DateTime the Commitment was fulfilled. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | LogObjid | Log Objid of the log to be fulfilled.
Public Property | UserName | The User who fulfilled the Commitment. If not set, the session user is used.

Reference

FulfillCommitmentSetup Class
FChoice.Toolkits.Clarify.Support Namespace
FulfillCommitment(FulfillCommitmentSetup) Method


FulfillCommitmentSetup Constructor | fcSDK Documentation

FulfillCommitmentSetup Constructor

Log Objid of the log to be fulfilled.

Initializes a new instance of the FulfillCommitmentSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _logObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public FulfillCommitmentSetup(
   int _logObjid_
)

Parameters

logObjid

Log Objid of the log to be fulfilled.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FulfillCommitmentSetup Class
FulfillCommitmentSetup Members


FulfillDate Property (FulfillCommitmentSetup) | fcSDK Documentation

FulfillDate Property (FulfillCommitmentSetup)

DateTime the Commitment was fulfilled. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property FulfillDate As Date

[PropertyBitValueAttribute()]
public DateTime FulfillDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FulfillCommitmentSetup Class
FulfillCommitmentSetup Members


GenerateTimeBombs Property (FulfillCommitmentSetup) | fcSDK Documentation

GenerateTimeBombs Property (FulfillCommitmentSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FulfillCommitmentSetup Class
FulfillCommitmentSetup Members


LogObjid Property | fcSDK Documentation

LogObjid Property

Log Objid of the log to be fulfilled.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LogObjid As Integer

[PropertyBitValueAttribute()]
public int LogObjid {get; set;}

Remarks

The commitment objid supplied must be for an open, unfulfilled commitment.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FulfillCommitmentSetup Class
FulfillCommitmentSetup Members


UserName Property (FulfillCommitmentSetup) | fcSDK Documentation

UserName Property (FulfillCommitmentSetup)

The User who fulfilled the Commitment. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FulfillCommitmentSetup Class
FulfillCommitmentSetup Members


GetCaseTimeAndExpensesResult Class | fcSDK Documentation

GetCaseTimeAndExpensesResult Class

Result from the GetCaseTimeAndExpenses API.

Syntax

'Declaration

Public Class GetCaseTimeAndExpensesResult
   Inherits FChoice.Toolkits.Clarify.ToolkitResult

public class GetCaseTimeAndExpensesResult : FChoice.Toolkits.Clarify.ToolkitResult

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.ToolkitResult
FChoice.Toolkits.Clarify.Support.GetCaseTimeAndExpensesResult

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

GetCaseTimeAndExpensesResult Members
FChoice.Toolkits.Clarify.Support Namespace


GetCaseTimeAndExpensesResult Class Members | fcSDK Documentation

GetCaseTimeAndExpensesResult Class Members

The following tables list the members exposed by GetCaseTimeAndExpensesResult.

Public Constructors

 | Name | Description
Public Constructor | GetCaseTimeAndExpensesResult Constructor |

Public Properties

 | Name | Description
Public Property | CaseTimeAndExpenses | Contains the sums and totals of time and expenses calculated before closing a Case.
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)

Reference

GetCaseTimeAndExpensesResult Class
FChoice.Toolkits.Clarify.Support Namespace


GetCaseTimeAndExpensesResult Constructor | fcSDK Documentation

GetCaseTimeAndExpensesResult Constructor

Syntax

'Declaration

Public Function New()

public GetCaseTimeAndExpensesResult()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GetCaseTimeAndExpensesResult Class
GetCaseTimeAndExpensesResult Members


CaseTimeAndExpenses Property (GetCaseTimeAndExpensesResult) | fcSDK Documentation

CaseTimeAndExpenses Property (GetCaseTimeAndExpensesResult)

Contains the sums and totals of time and expenses calculated before closing a Case.

Syntax

'Declaration

Public Property CaseTimeAndExpenses As CaseTimeAndExpenses

public CaseTimeAndExpenses CaseTimeAndExpenses {get; set;}

Remarks

This object can be used when calling CloseCase to set the CloseSums

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GetCaseTimeAndExpensesResult Class
GetCaseTimeAndExpensesResult Members


GetCaseTimeAndExpensesSetup Class | fcSDK Documentation

GetCaseTimeAndExpensesSetup Class

Used by the GetCaseTimeAndExpenses method as setup data for invocation.

Syntax

'Declaration

Public Class GetCaseTimeAndExpensesSetup

public class GetCaseTimeAndExpensesSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.GetCaseTimeAndExpensesSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

GetCaseTimeAndExpensesSetup Members
FChoice.Toolkits.Clarify.Support Namespace
GetCaseTimeAndExpenses(GetCaseTimeAndExpensesSetup) Method


GetCaseTimeAndExpensesSetup Class Members | fcSDK Documentation

GetCaseTimeAndExpensesSetup Class Members

The following tables list the members exposed by GetCaseTimeAndExpensesSetup.

Public Constructors

 | Name | Description
Public Constructor | GetCaseTimeAndExpensesSetup Constructor | Initializes a new instance of the GetCaseTimeAndExpensesSetup class.

Public Properties

 | Name | Description
Public Property | CaseIDNum | Case Identifier.

Reference

GetCaseTimeAndExpensesSetup Class
FChoice.Toolkits.Clarify.Support Namespace
GetCaseTimeAndExpenses(GetCaseTimeAndExpensesSetup) Method


GetCaseTimeAndExpensesSetup Constructor | fcSDK Documentation

GetCaseTimeAndExpensesSetup Constructor

Case Identifier.

Initializes a new instance of the GetCaseTimeAndExpensesSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _caseIDNum_ As String _
)

[ConstructorIndexAttribute()]
public GetCaseTimeAndExpensesSetup(
   string _caseIDNum_
)

Parameters

caseIDNum

Case Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GetCaseTimeAndExpensesSetup Class
GetCaseTimeAndExpensesSetup Members


CaseIDNum Property (GetCaseTimeAndExpensesSetup) | fcSDK Documentation

CaseIDNum Property (GetCaseTimeAndExpensesSetup)

Case Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GetCaseTimeAndExpensesSetup Class
GetCaseTimeAndExpensesSetup Members


GetSubcaseTimeAndExpensesResult Class | fcSDK Documentation

GetSubcaseTimeAndExpensesResult Class

Result from the GetSubcaseTimeAndExpenses API.

Syntax

'Declaration

Public Class GetSubcaseTimeAndExpensesResult
   Inherits FChoice.Toolkits.Clarify.ToolkitResult

public class GetSubcaseTimeAndExpensesResult : FChoice.Toolkits.Clarify.ToolkitResult

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.ToolkitResult
FChoice.Toolkits.Clarify.Support.GetSubcaseTimeAndExpensesResult

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

GetSubcaseTimeAndExpensesResult Members
FChoice.Toolkits.Clarify.Support Namespace


GetSubcaseTimeAndExpensesResult Class Members | fcSDK Documentation

GetSubcaseTimeAndExpensesResult Class Members

The following tables list the members exposed by GetSubcaseTimeAndExpensesResult.

Public Constructors

 | Name | Description
Public Constructor | GetSubcaseTimeAndExpensesResult Constructor |

Public Properties

 | Name | Description
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | SubcaseTimeAndExpenses | Contains the sums and totals calculated before closing a Case.

Reference

GetSubcaseTimeAndExpensesResult Class
FChoice.Toolkits.Clarify.Support Namespace


GetSubcaseTimeAndExpensesResult Constructor | fcSDK Documentation

GetSubcaseTimeAndExpensesResult Constructor

Syntax

'Declaration

Public Function New()

public GetSubcaseTimeAndExpensesResult()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GetSubcaseTimeAndExpensesResult Class
GetSubcaseTimeAndExpensesResult Members


SubcaseTimeAndExpenses Property | fcSDK Documentation

SubcaseTimeAndExpenses Property

Contains the sums and totals calculated before closing a Case.

Syntax

'Declaration

Public Property SubcaseTimeAndExpenses As SubcaseTimeAndExpenses

public SubcaseTimeAndExpenses SubcaseTimeAndExpenses {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GetSubcaseTimeAndExpensesResult Class
GetSubcaseTimeAndExpensesResult Members


GetSubcaseTimeAndExpensesSetup Class | fcSDK Documentation

GetSubcaseTimeAndExpensesSetup Class

Used by the GetSubcaseTimeAndExpenses method as setup data for invocation.

Syntax

'Declaration

Public Class GetSubcaseTimeAndExpensesSetup

public class GetSubcaseTimeAndExpensesSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.GetSubcaseTimeAndExpensesSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

GetSubcaseTimeAndExpensesSetup Members
FChoice.Toolkits.Clarify.Support Namespace
GetSubcaseTimeAndExpenses(GetSubcaseTimeAndExpensesSetup) Method


GetSubcaseTimeAndExpensesSetup Class Members | fcSDK Documentation

GetSubcaseTimeAndExpensesSetup Class Members

The following tables list the members exposed by GetSubcaseTimeAndExpensesSetup.

Public Constructors

 | Name | Description
Public Constructor | GetSubcaseTimeAndExpensesSetup Constructor | Initializes a new instance of the GetSubcaseTimeAndExpensesSetup class.

Public Properties

 | Name | Description
Public Property | SubcaseIDNum | Subcase Identifier.

Reference

GetSubcaseTimeAndExpensesSetup Class
FChoice.Toolkits.Clarify.Support Namespace
GetSubcaseTimeAndExpenses(GetSubcaseTimeAndExpensesSetup) Method


GetSubcaseTimeAndExpensesSetup Constructor | fcSDK Documentation

GetSubcaseTimeAndExpensesSetup Constructor

Subcase Identifier.

Initializes a new instance of the GetSubcaseTimeAndExpensesSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _subcaseIDNum_ As String _
)

[ConstructorIndexAttribute()]
public GetSubcaseTimeAndExpensesSetup(
   string _subcaseIDNum_
)

Parameters

subcaseIDNum

Subcase Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GetSubcaseTimeAndExpensesSetup Class
GetSubcaseTimeAndExpensesSetup Members


SubcaseIDNum Property (GetSubcaseTimeAndExpensesSetup) | fcSDK Documentation

SubcaseIDNum Property (GetSubcaseTimeAndExpensesSetup)

Subcase Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SubcaseIDNum As String

[PropertyBitValueAttribute()]
public string SubcaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GetSubcaseTimeAndExpensesSetup Class
GetSubcaseTimeAndExpensesSetup Members


InitialResponseSetup Class | fcSDK Documentation

InitialResponseSetup Class

Used by the InitialResponse method as setup data for invocation.

Syntax

'Declaration

Public Class InitialResponseSetup

public class InitialResponseSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.InitialResponseSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

InitialResponseSetup Members
FChoice.Toolkits.Clarify.Support Namespace
InitialResponse(InitialResponseSetup) Method


InitialResponseSetup Class Members | fcSDK Documentation

InitialResponseSetup Class Members

The following tables list the members exposed by InitialResponseSetup.

Public Constructors

 | Name | Description
Public Constructor | InitialResponseSetup Constructor | Initializes a new instance of the InitialResponseSetup class.

Public Properties

 | Name | Description
Public Property | CaseIDNum | Case Identifier.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | IsVIAPhone | Was the Response made via phone.
Public Property | ResponseDate | DateTime the response was made. If not set, the current time is used.
Public Property | UserName | The User who made the response. If not set, the session user is used.

Reference

InitialResponseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
InitialResponse(InitialResponseSetup) Method


InitialResponseSetup Constructor | fcSDK Documentation

InitialResponseSetup Constructor

Case Identifier.

Initializes a new instance of the InitialResponseSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _caseIDNum_ As String _
)

[ConstructorIndexAttribute()]
public InitialResponseSetup(
   string _caseIDNum_
)

Parameters

caseIDNum

Case Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InitialResponseSetup Class
InitialResponseSetup Members


CaseIDNum Property (InitialResponseSetup) | fcSDK Documentation

CaseIDNum Property (InitialResponseSetup)

Case Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InitialResponseSetup Class
InitialResponseSetup Members


GenerateTimeBombs Property (InitialResponseSetup) | fcSDK Documentation

GenerateTimeBombs Property (InitialResponseSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InitialResponseSetup Class
InitialResponseSetup Members


IsVIAPhone Property | fcSDK Documentation

IsVIAPhone Property

Was the Response made via phone.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsVIAPhone As Boolean

[PropertyBitValueAttribute()]
public bool IsVIAPhone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InitialResponseSetup Class
InitialResponseSetup Members


ResponseDate Property | fcSDK Documentation

ResponseDate Property

DateTime the response was made. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ResponseDate As Date

[PropertyBitValueAttribute()]
public DateTime ResponseDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InitialResponseSetup Class
InitialResponseSetup Members


UserName Property (InitialResponseSetup) | fcSDK Documentation

UserName Property (InitialResponseSetup)

The User who made the response. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

InitialResponseSetup Class
InitialResponseSetup Members


LogCaseCommitmentSetup Class | fcSDK Documentation

LogCaseCommitmentSetup Class

Used by the LogCaseCommitment method as setup data for invocation.

Syntax

'Declaration

Public Class LogCaseCommitmentSetup

public class LogCaseCommitmentSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.LogCaseCommitmentSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LogCaseCommitmentSetup Members
FChoice.Toolkits.Clarify.Support Namespace
LogCaseCommitment(LogCaseCommitmentSetup) Method


LogCaseCommitmentSetup Class Members | fcSDK Documentation

LogCaseCommitmentSetup Class Members

The following tables list the members exposed by LogCaseCommitmentSetup.

Public Constructors

 | Name | Description
Public Constructor | LogCaseCommitmentSetup Constructor | Initializes a new instance of the LogCaseCommitmentSetup class.

Public Properties

 | Name | Description
Public Property | ActionType | Element from the 'Commitment Log Action Type' user defined list. If not set, the default list value is used.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CaseIDNum | Identifier of the Case against which the Committment is being logged.
Public Property | CommitmentDate | DateTime of when the commitment is due. If not set, the LogDate is used.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | GenerateCommitmentEmail | Should the Commitment generate email notifications for the commitment time and prior warning time.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | IsMadeToCustomer | Was the Commitment made to a customer.
Public Property | LogDate | DateTime the log was created. If not set, the current time is used.
Public Property | Notes | Additional notes for the log.
Public Property | PriorWarning | How long before the Commitment expires will the owner will be warned. If not set, no prior warning is given.
Public Property | Title | Title of the commitment.
Public Property | UserName | The User who created the log. If not set, the session user is used.

Reference

LogCaseCommitmentSetup Class
FChoice.Toolkits.Clarify.Support Namespace
LogCaseCommitment(LogCaseCommitmentSetup) Method


LogCaseCommitmentSetup Constructor | fcSDK Documentation

LogCaseCommitmentSetup Constructor

Identifier of the Case against which the Committment is being logged.

Title of the commitment.

How long before the Commitment expires will the owner will be warned. If not set, no prior warning is given.

Contact's first name.

Contact's last name.

Contact's phone number.

Initializes a new instance of the LogCaseCommitmentSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _caseIDNum_ As String, _
   ByVal _title_ As String, _
   ByVal _priorWarning_ As TimeSpan, _
   ByVal _contactFirstName_ As String, _
   ByVal _contactLastName_ As String, _
   ByVal _contactPhone_ As String _
)

[ConstructorIndexAttribute()]
public LogCaseCommitmentSetup(
   string _caseIDNum_,
   string _title_,
   TimeSpan _priorWarning_,
   string _contactFirstName_,
   string _contactLastName_,
   string _contactPhone_
)

Parameters

caseIDNum

Identifier of the Case against which the Committment is being logged.

title

Title of the commitment.

priorWarning

How long before the Commitment expires will the owner will be warned. If not set, no prior warning is given.

contactFirstName

Contact's first name.

contactLastName

Contact's last name.

contactPhone

Contact's phone number.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseCommitmentSetup Class
LogCaseCommitmentSetup Members


ActionType Property (LogCaseCommitmentSetup) | fcSDK Documentation

ActionType Property (LogCaseCommitmentSetup)

Element from the 'Commitment Log Action Type' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ActionType As String

[PropertyBitValueAttribute()]
public string ActionType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseCommitmentSetup Class
LogCaseCommitmentSetup Members


AdditionalFields Property (LogCaseCommitmentSetup) | fcSDK Documentation

AdditionalFields Property (LogCaseCommitmentSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseCommitmentSetup Class
LogCaseCommitmentSetup Members


CaseIDNum Property (LogCaseCommitmentSetup) | fcSDK Documentation

CaseIDNum Property (LogCaseCommitmentSetup)

Identifier of the Case against which the Committment is being logged.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseCommitmentSetup Class
LogCaseCommitmentSetup Members


CommitmentDate Property (LogCaseCommitmentSetup) | fcSDK Documentation

CommitmentDate Property (LogCaseCommitmentSetup)

DateTime of when the commitment is due. If not set, the LogDate is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentDate As Date

[PropertyBitValueAttribute()]
public DateTime CommitmentDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseCommitmentSetup Class
LogCaseCommitmentSetup Members


ContactFirstName Property (LogCaseCommitmentSetup) | fcSDK Documentation

ContactFirstName Property (LogCaseCommitmentSetup)

Contact's first name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactFirstName As String

[PropertyBitValueAttribute()]
public string ContactFirstName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseCommitmentSetup Class
LogCaseCommitmentSetup Members


ContactLastName Property (LogCaseCommitmentSetup) | fcSDK Documentation

ContactLastName Property (LogCaseCommitmentSetup)

Contact's last name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactLastName As String

[PropertyBitValueAttribute()]
public string ContactLastName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseCommitmentSetup Class
LogCaseCommitmentSetup Members


ContactPhone Property (LogCaseCommitmentSetup) | fcSDK Documentation

ContactPhone Property (LogCaseCommitmentSetup)

Contact's phone number.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactPhone As String

[PropertyBitValueAttribute()]
public string ContactPhone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseCommitmentSetup Class
LogCaseCommitmentSetup Members


GenerateCommitmentEmail Property (LogCaseCommitmentSetup) | fcSDK Documentation

GenerateCommitmentEmail Property (LogCaseCommitmentSetup)

Should the Commitment generate email notifications for the commitment time and prior warning time.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateCommitmentEmail As Boolean

[PropertyBitValueAttribute()]
public bool GenerateCommitmentEmail {get; set;}

Remarks

Base Clarify sends two emails each time a Commitment is logged. The first notifies the owner when the Commitment expires, and the second notifies the owner when the prior warning (if any) expires.

To control what is sent in the Commitment email please see your Clarify documentation concerning the 'com_tmplte' record.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseCommitmentSetup Class
LogCaseCommitmentSetup Members


GenerateTimeBombs Property (LogCaseCommitmentSetup) | fcSDK Documentation

GenerateTimeBombs Property (LogCaseCommitmentSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseCommitmentSetup Class
LogCaseCommitmentSetup Members


IsMadeToCustomer Property (LogCaseCommitmentSetup) | fcSDK Documentation

IsMadeToCustomer Property (LogCaseCommitmentSetup)

Was the Commitment made to a customer.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsMadeToCustomer As Boolean

[PropertyBitValueAttribute()]
public bool IsMadeToCustomer {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseCommitmentSetup Class
LogCaseCommitmentSetup Members


LogDate Property (LogCaseCommitmentSetup) | fcSDK Documentation

LogDate Property (LogCaseCommitmentSetup)

DateTime the log was created. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LogDate As Date

[PropertyBitValueAttribute()]
public DateTime LogDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseCommitmentSetup Class
LogCaseCommitmentSetup Members


Notes Property (LogCaseCommitmentSetup) | fcSDK Documentation

Notes Property (LogCaseCommitmentSetup)

Additional notes for the log.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseCommitmentSetup Class
LogCaseCommitmentSetup Members


PriorWarning Property (LogCaseCommitmentSetup) | fcSDK Documentation

PriorWarning Property (LogCaseCommitmentSetup)

How long before the Commitment expires will the owner will be warned. If not set, no prior warning is given.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PriorWarning As TimeSpan

[PropertyBitValueAttribute()]
public TimeSpan PriorWarning {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseCommitmentSetup Class
LogCaseCommitmentSetup Members


Title Property (LogCaseCommitmentSetup) | fcSDK Documentation

Title Property (LogCaseCommitmentSetup)

Title of the commitment.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Title As String

[PropertyBitValueAttribute()]
public string Title {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseCommitmentSetup Class
LogCaseCommitmentSetup Members


UserName Property (LogCaseCommitmentSetup) | fcSDK Documentation

UserName Property (LogCaseCommitmentSetup)

The User who created the log. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseCommitmentSetup Class
LogCaseCommitmentSetup Members


LogCaseEmailInSetup Class | fcSDK Documentation

LogCaseEmailInSetup Class

Used by the LogCaseEmailIn method as setup data for invocation.

Syntax

'Declaration

Public Class LogCaseEmailInSetup
   Inherits LogEmailInSetup

public class LogCaseEmailInSetup : LogEmailInSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.LogEmailInSetup
FChoice.Toolkits.Clarify.Support.LogCaseEmailInSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LogCaseEmailInSetup Members
FChoice.Toolkits.Clarify.Support Namespace


LogCaseEmailInSetup Class Members | fcSDK Documentation

LogCaseEmailInSetup Class Members

The following tables list the members exposed by LogCaseEmailInSetup.

Public Constructors

 | Name | Description
Public Constructor | LogCaseEmailInSetup Constructor |

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | CCList | Email addresses of persons CC'd on the email being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | GenerateTimeBombs | Specifies if timebombs should be created. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | IDNumber | Identifier of the Case against which the email in is being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | LogDate | DateTime the log was created. If not set, the current time is used. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | MailLogActionType | Element from the 'Mail Log Action Type' user defined list. If not set, the default list value is used. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | Message | Body of the email being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | Recipient | Email address of the recipients of the email being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | Sender | Email address of the sender of the email being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | Subject | (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | UserName | User who created the log. If not set, the session user is used. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)

Reference

LogCaseEmailInSetup Class
FChoice.Toolkits.Clarify.Support Namespace


LogCaseEmailInSetup Constructor | fcSDK Documentation

LogCaseEmailInSetup Constructor

Identifier of the Case against which the email in is being logged.

Email address of the sender of the email being logged.

Email address(s) of the recipients of the email being logged.

Body of the email being logged.

Syntax

'Declaration

Public Function New( _
   ByVal _caseIDNum_ As String, _
   ByVal _sender_ As String, _
   ByVal _recipient_ As String, _
   ByVal _message_ As String _
)

public LogCaseEmailInSetup(
   string _caseIDNum_,
   string _sender_,
   string _recipient_,
   string _message_
)

Parameters

caseIDNum

Identifier of the Case against which the email in is being logged.

sender

Email address of the sender of the email being logged.

recipient

Email address(s) of the recipients of the email being logged.

message

Body of the email being logged.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseEmailInSetup Class
LogCaseEmailInSetup Members


LogCaseEmailResult Class | fcSDK Documentation

LogCaseEmailResult Class

Result from the LogCaseEmail API.

Syntax

'Declaration

Public Class LogCaseEmailResult
   Inherits FChoice.Toolkits.Clarify.ToolkitResult

public class LogCaseEmailResult : FChoice.Toolkits.Clarify.ToolkitResult

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.ToolkitResult
FChoice.Toolkits.Clarify.Support.LogCaseEmailResult

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LogCaseEmailResult Members
FChoice.Toolkits.Clarify.Support Namespace


LogCaseEmailResult Class Members | fcSDK Documentation

LogCaseEmailResult Class Members

The following tables list the members exposed by LogCaseEmailResult.

Public Constructors

 | Name | Description
Public Constructor | LogCaseEmailResult Constructor |

Public Properties

 | Name | Description
Public Property | CommitmentObjid | The Objid of the Commitment.
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | StatusChangeObjid | The Objid of the StatusChange.

Reference

LogCaseEmailResult Class
FChoice.Toolkits.Clarify.Support Namespace


LogCaseEmailResult Constructor | fcSDK Documentation

LogCaseEmailResult Constructor

Syntax

'Declaration

Public Function New()

public LogCaseEmailResult()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseEmailResult Class
LogCaseEmailResult Members


CommitmentObjid Property (LogCaseEmailResult) | fcSDK Documentation

CommitmentObjid Property (LogCaseEmailResult)

The Objid of the Commitment.

Syntax

'Declaration

Public Property CommitmentObjid As Integer

public int CommitmentObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseEmailResult Class
LogCaseEmailResult Members


StatusChangeObjid Property (LogCaseEmailResult) | fcSDK Documentation

StatusChangeObjid Property (LogCaseEmailResult)

The Objid of the StatusChange.

Syntax

'Declaration

Public Property StatusChangeObjid As Integer

public int StatusChangeObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseEmailResult Class
LogCaseEmailResult Members


LogCaseEmailSetup Class | fcSDK Documentation

LogCaseEmailSetup Class

Used by the LogCaseEmail method as setup data for invocation.

Syntax

'Declaration

Public Class LogCaseEmailSetup

public class LogCaseEmailSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.LogCaseEmailSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LogCaseEmailSetup Members
FChoice.Toolkits.Clarify.Support Namespace
LogCaseEmail(LogCaseEmailSetup) Method


LogCaseEmailSetup Class Members | fcSDK Documentation

LogCaseEmailSetup Class Members

The following tables list the members exposed by LogCaseEmailSetup.

Public Constructors

 | Name | Description
Public Constructor | LogCaseEmailSetup Constructor | Initializes a new instance of the LogCaseEmailSetup class.

Public Properties

 | Name | Description
Public Property | ActionType | Element from the 'Mail Log Action Type' user defined list. If not set, the default list value is used.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CaseIDNum | Identifier of the Case against which the email is being logged.
Public Property | CCList | List of cc recipients for the email.
Public Property | CommitmentActionType | Element from the 'Commitment Log Action Type' user defined list. If not set, the default list value is used.
Public Property | CommitmentContactObjid | Commitment Objid for the contact of the commitment. If not set, the contact for the Case is used.
Public Property | CommitmentDueDate | The DateTime of when the commitment is due. If not set, the LogDate is used.
Public Property | CommitmentNotes | Notes for the commitment if one is being generated.
Public Property | CommitmentPriorWarning | The length of time preceding the commitment expiration in which the owner will be warned. If not set, no prior warning is given.
Public Property | CommitmentTitle | Title of the commitment.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | IsCommitmentToCustomer | Was the Commitment made to a customer.
Public Property | LogDate | DateTime the log was created. If not set, the current time is used.
Public Property | Message | Email message.
Public Property | NewStatus | New status for the Case.
Public Property | Recipient | List of email addresses the email is sent to.
Public Property | SendEmail | Specifies if a timebomb be added to Clarify that will cause Rule Manager (if running) to send the email.
Public Property | UserName | User who created the log. If not set, the session user is used.

Reference

LogCaseEmailSetup Class
FChoice.Toolkits.Clarify.Support Namespace
LogCaseEmail(LogCaseEmailSetup) Method


LogCaseEmailSetup Constructor | fcSDK Documentation

LogCaseEmailSetup Constructor

Identifier of the Case against which the email is being logged.

Initializes a new instance of the LogCaseEmailSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _caseIDNum_ As String _
)

[ConstructorIndexAttribute()]
public LogCaseEmailSetup(
   string _caseIDNum_
)

Parameters

caseIDNum

Identifier of the Case against which the email is being logged.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseEmailSetup Class
LogCaseEmailSetup Members


ActionType Property (LogCaseEmailSetup) | fcSDK Documentation

ActionType Property (LogCaseEmailSetup)

Element from the 'Mail Log Action Type' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ActionType As String

[PropertyBitValueAttribute()]
public string ActionType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseEmailSetup Class
LogCaseEmailSetup Members


AdditionalFields Property (LogCaseEmailSetup) | fcSDK Documentation

AdditionalFields Property (LogCaseEmailSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseEmailSetup Class
LogCaseEmailSetup Members


CaseIDNum Property (LogCaseEmailSetup) | fcSDK Documentation

CaseIDNum Property (LogCaseEmailSetup)

Identifier of the Case against which the email is being logged.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseEmailSetup Class
LogCaseEmailSetup Members


CCList Property (LogCaseEmailSetup) | fcSDK Documentation

CCList Property (LogCaseEmailSetup)

List of cc recipients for the email.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CCList As String

[PropertyBitValueAttribute()]
public string CCList {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseEmailSetup Class
LogCaseEmailSetup Members


CommitmentActionType Property (LogCaseEmailSetup) | fcSDK Documentation

CommitmentActionType Property (LogCaseEmailSetup)

Element from the 'Commitment Log Action Type' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentActionType As String

[PropertyBitValueAttribute()]
public string CommitmentActionType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseEmailSetup Class
LogCaseEmailSetup Members


CommitmentContactObjid Property (LogCaseEmailSetup) | fcSDK Documentation

CommitmentContactObjid Property (LogCaseEmailSetup)

Commitment Objid for the contact of the commitment. If not set, the contact for the Case is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentContactObjid As Integer

[PropertyBitValueAttribute()]
public int CommitmentContactObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseEmailSetup Class
LogCaseEmailSetup Members


CommitmentDueDate Property (LogCaseEmailSetup) | fcSDK Documentation

CommitmentDueDate Property (LogCaseEmailSetup)

The DateTime of when the commitment is due. If not set, the LogDate is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentDueDate As Date

[PropertyBitValueAttribute()]
public DateTime CommitmentDueDate {get; set;}

Remarks

Required if setting a Commitment.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseEmailSetup Class
LogCaseEmailSetup Members


CommitmentNotes Property (LogCaseEmailSetup) | fcSDK Documentation

CommitmentNotes Property (LogCaseEmailSetup)

Notes for the commitment if one is being generated.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentNotes As String

[PropertyBitValueAttribute()]
public string CommitmentNotes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseEmailSetup Class
LogCaseEmailSetup Members


CommitmentPriorWarning Property (LogCaseEmailSetup) | fcSDK Documentation

CommitmentPriorWarning Property (LogCaseEmailSetup)

The length of time preceding the commitment expiration in which the owner will be warned. If not set, no prior warning is given.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentPriorWarning As TimeSpan

[PropertyBitValueAttribute()]
public TimeSpan CommitmentPriorWarning {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseEmailSetup Class
LogCaseEmailSetup Members


CommitmentTitle Property (LogCaseEmailSetup) | fcSDK Documentation

CommitmentTitle Property (LogCaseEmailSetup)

Title of the commitment.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentTitle As String

[PropertyBitValueAttribute()]
public string CommitmentTitle {get; set;}

Remarks

Required if setting a Commitment.

The Commitment title usually comes from and element in the user-defined list 'COMMITMENT', but this is not required.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseEmailSetup Class
LogCaseEmailSetup Members


GenerateTimeBombs Property (LogCaseEmailSetup) | fcSDK Documentation

GenerateTimeBombs Property (LogCaseEmailSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseEmailSetup Class
LogCaseEmailSetup Members


IsCommitmentToCustomer Property (LogCaseEmailSetup) | fcSDK Documentation

IsCommitmentToCustomer Property (LogCaseEmailSetup)

Was the Commitment made to a customer.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsCommitmentToCustomer As Boolean

[PropertyBitValueAttribute()]
public bool IsCommitmentToCustomer {get; set;}

Remarks

Required if setting a Commitment.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseEmailSetup Class
LogCaseEmailSetup Members


LogDate Property (LogCaseEmailSetup) | fcSDK Documentation

LogDate Property (LogCaseEmailSetup)

DateTime the log was created. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LogDate As Date

[PropertyBitValueAttribute()]
public DateTime LogDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseEmailSetup Class
LogCaseEmailSetup Members


Message Property (LogCaseEmailSetup) | fcSDK Documentation

Message Property (LogCaseEmailSetup)

Email message.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Message As String

[PropertyBitValueAttribute()]
public string Message {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseEmailSetup Class
LogCaseEmailSetup Members


NewStatus Property (LogCaseEmailSetup) | fcSDK Documentation

NewStatus Property (LogCaseEmailSetup)

New status for the Case.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewStatus As String

[PropertyBitValueAttribute()]
public string NewStatus {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseEmailSetup Class
LogCaseEmailSetup Members


Recipient Property (LogCaseEmailSetup) | fcSDK Documentation

Recipient Property (LogCaseEmailSetup)

List of email addresses the email is sent to.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Recipient As String

[PropertyBitValueAttribute()]
public string Recipient {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseEmailSetup Class
LogCaseEmailSetup Members


SendEmail Property (LogCaseEmailSetup) | fcSDK Documentation

SendEmail Property (LogCaseEmailSetup)

Specifies if a timebomb be added to Clarify that will cause Rule Manager (if running) to send the email.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SendEmail As Boolean

[PropertyBitValueAttribute()]
public bool SendEmail {get; set;}

Remarks

If set to True, the API will add a row to Clarify that will cause the rule manager (which must be running) to send the email. This is just like logging it via the Log Email GUI in Clarify. The downside of this is that rulemanager sends the email from the server, which means that the recipient(s) cannot hit "reply", and have the email come back to you.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseEmailSetup Class
LogCaseEmailSetup Members


UserName Property (LogCaseEmailSetup) | fcSDK Documentation

UserName Property (LogCaseEmailSetup)

User who created the log. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseEmailSetup Class
LogCaseEmailSetup Members


LogCaseInternalNoteSetup Class | fcSDK Documentation

LogCaseInternalNoteSetup Class

Syntax

'Declaration

Public Class LogCaseInternalNoteSetup

public class LogCaseInternalNoteSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.LogCaseInternalNoteSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LogCaseInternalNoteSetup Members
FChoice.Toolkits.Clarify.Support Namespace


LogCaseInternalNoteSetup Class Members | fcSDK Documentation

LogCaseInternalNoteSetup Class Members

The following tables list the members exposed by LogCaseInternalNoteSetup.

Public Constructors

 | Name | Description
Public Constructor | LogCaseInternalNoteSetup Constructor |

Public Properties

 | Name | Description
Public Property | ActionType |
Public Property | AdditionalFields |
Public Property | CaseIDNum |
Public Property | CommitmentDueDate |
Public Property | CommitmentNotes |
Public Property | CommitmentPriorWarning |
Public Property | CommitmentTitle |
Public Property | GenerateTimeBombs |
Public Property | IsCommitmentToCustomer |
Public Property | LogDate |
Public Property | NewStatus |
Public Property | Notes |
Public Property | UserName |

Reference

LogCaseInternalNoteSetup Class
FChoice.Toolkits.Clarify.Support Namespace


LogCaseInternalNoteSetup Constructor | fcSDK Documentation

LogCaseInternalNoteSetup Constructor

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _caseIDNum_ As String _
)

[ConstructorIndexAttribute()]
public LogCaseInternalNoteSetup(
   string _caseIDNum_
)

Parameters

caseIDNum

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseInternalNoteSetup Class
LogCaseInternalNoteSetup Members


ActionType Property (LogCaseInternalNoteSetup) | fcSDK Documentation

ActionType Property (LogCaseInternalNoteSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ActionType As String

[PropertyBitValueAttribute()]
public string ActionType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseInternalNoteSetup Class
LogCaseInternalNoteSetup Members


AdditionalFields Property (LogCaseInternalNoteSetup) | fcSDK Documentation

AdditionalFields Property (LogCaseInternalNoteSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseInternalNoteSetup Class
LogCaseInternalNoteSetup Members


CaseIDNum Property (LogCaseInternalNoteSetup) | fcSDK Documentation

CaseIDNum Property (LogCaseInternalNoteSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseInternalNoteSetup Class
LogCaseInternalNoteSetup Members


CommitmentDueDate Property (LogCaseInternalNoteSetup) | fcSDK Documentation

CommitmentDueDate Property (LogCaseInternalNoteSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentDueDate As Date

[PropertyBitValueAttribute()]
public DateTime CommitmentDueDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseInternalNoteSetup Class
LogCaseInternalNoteSetup Members


CommitmentNotes Property (LogCaseInternalNoteSetup) | fcSDK Documentation

CommitmentNotes Property (LogCaseInternalNoteSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentNotes As String

[PropertyBitValueAttribute()]
public string CommitmentNotes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseInternalNoteSetup Class
LogCaseInternalNoteSetup Members


CommitmentPriorWarning Property (LogCaseInternalNoteSetup) | fcSDK Documentation

CommitmentPriorWarning Property (LogCaseInternalNoteSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentPriorWarning As TimeSpan

[PropertyBitValueAttribute()]
public TimeSpan CommitmentPriorWarning {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseInternalNoteSetup Class
LogCaseInternalNoteSetup Members


CommitmentTitle Property (LogCaseInternalNoteSetup) | fcSDK Documentation

CommitmentTitle Property (LogCaseInternalNoteSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentTitle As String

[PropertyBitValueAttribute()]
public string CommitmentTitle {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseInternalNoteSetup Class
LogCaseInternalNoteSetup Members


GenerateTimeBombs Property (LogCaseInternalNoteSetup) | fcSDK Documentation

GenerateTimeBombs Property (LogCaseInternalNoteSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseInternalNoteSetup Class
LogCaseInternalNoteSetup Members


IsCommitmentToCustomer Property (LogCaseInternalNoteSetup) | fcSDK Documentation

IsCommitmentToCustomer Property (LogCaseInternalNoteSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsCommitmentToCustomer As Boolean

[PropertyBitValueAttribute()]
public bool IsCommitmentToCustomer {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseInternalNoteSetup Class
LogCaseInternalNoteSetup Members


LogDate Property (LogCaseInternalNoteSetup) | fcSDK Documentation

LogDate Property (LogCaseInternalNoteSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LogDate As Date

[PropertyBitValueAttribute()]
public DateTime LogDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseInternalNoteSetup Class
LogCaseInternalNoteSetup Members


NewStatus Property (LogCaseInternalNoteSetup) | fcSDK Documentation

NewStatus Property (LogCaseInternalNoteSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewStatus As String

[PropertyBitValueAttribute()]
public string NewStatus {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseInternalNoteSetup Class
LogCaseInternalNoteSetup Members


Notes Property (LogCaseInternalNoteSetup) | fcSDK Documentation

Notes Property (LogCaseInternalNoteSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseInternalNoteSetup Class
LogCaseInternalNoteSetup Members


UserName Property (LogCaseInternalNoteSetup) | fcSDK Documentation

UserName Property (LogCaseInternalNoteSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseInternalNoteSetup Class
LogCaseInternalNoteSetup Members


LogCaseInternalPhoneSetup Class | fcSDK Documentation

LogCaseInternalPhoneSetup Class

Syntax

'Declaration

Public Class LogCaseInternalPhoneSetup

public class LogCaseInternalPhoneSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.LogCaseInternalPhoneSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LogCaseInternalPhoneSetup Members
FChoice.Toolkits.Clarify.Support Namespace


LogCaseInternalPhoneSetup Class Members | fcSDK Documentation

LogCaseInternalPhoneSetup Class Members

The following tables list the members exposed by LogCaseInternalPhoneSetup.

Public Constructors

 | Name | Description
Public Constructor | LogCaseInternalPhoneSetup Constructor |

Public Properties

 | Name | Description
Public Property | ActionType |
Public Property | AdditionalFields |
Public Property | CaseIDNum |
Public Property | CommitmentDueDate |
Public Property | CommitmentNotes |
Public Property | CommitmentPriorWarning |
Public Property | CommitmentTitle |
Public Property | ContactFirstName |
Public Property | ContactLastName |
Public Property | ContactPhone |
Public Property | GenerateTimeBombs |
Public Property | IsCommitmentToCustomer |
Public Property | LogDate |
Public Property | LogEndDate |
Public Property | NewStatus |
Public Property | Notes |
Public Property | UserName |

Reference

LogCaseInternalPhoneSetup Class
FChoice.Toolkits.Clarify.Support Namespace


LogCaseInternalPhoneSetup Constructor | fcSDK Documentation

LogCaseInternalPhoneSetup Constructor

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _caseIDNum_ As String, _
   ByVal _contactFirstName_ As String, _
   ByVal _contactLastName_ As String, _
   ByVal _contactPhone_ As String _
)

[ConstructorIndexAttribute()]
public LogCaseInternalPhoneSetup(
   string _caseIDNum_,
   string _contactFirstName_,
   string _contactLastName_,
   string _contactPhone_
)

Parameters

caseIDNum

contactFirstName

contactLastName

contactPhone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseInternalPhoneSetup Class
LogCaseInternalPhoneSetup Members


ActionType Property (LogCaseInternalPhoneSetup) | fcSDK Documentation

ActionType Property (LogCaseInternalPhoneSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ActionType As String

[PropertyBitValueAttribute()]
public string ActionType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseInternalPhoneSetup Class
LogCaseInternalPhoneSetup Members


AdditionalFields Property (LogCaseInternalPhoneSetup) | fcSDK Documentation

AdditionalFields Property (LogCaseInternalPhoneSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseInternalPhoneSetup Class
LogCaseInternalPhoneSetup Members


CaseIDNum Property (LogCaseInternalPhoneSetup) | fcSDK Documentation

CaseIDNum Property (LogCaseInternalPhoneSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseInternalPhoneSetup Class
LogCaseInternalPhoneSetup Members


CommitmentDueDate Property (LogCaseInternalPhoneSetup) | fcSDK Documentation

CommitmentDueDate Property (LogCaseInternalPhoneSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentDueDate As Date

[PropertyBitValueAttribute()]
public DateTime CommitmentDueDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseInternalPhoneSetup Class
LogCaseInternalPhoneSetup Members


CommitmentNotes Property (LogCaseInternalPhoneSetup) | fcSDK Documentation

CommitmentNotes Property (LogCaseInternalPhoneSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentNotes As String

[PropertyBitValueAttribute()]
public string CommitmentNotes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseInternalPhoneSetup Class
LogCaseInternalPhoneSetup Members


CommitmentPriorWarning Property (LogCaseInternalPhoneSetup) | fcSDK Documentation

CommitmentPriorWarning Property (LogCaseInternalPhoneSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentPriorWarning As TimeSpan

[PropertyBitValueAttribute()]
public TimeSpan CommitmentPriorWarning {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseInternalPhoneSetup Class
LogCaseInternalPhoneSetup Members


CommitmentTitle Property (LogCaseInternalPhoneSetup) | fcSDK Documentation

CommitmentTitle Property (LogCaseInternalPhoneSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentTitle As String

[PropertyBitValueAttribute()]
public string CommitmentTitle {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseInternalPhoneSetup Class
LogCaseInternalPhoneSetup Members


ContactFirstName Property (LogCaseInternalPhoneSetup) | fcSDK Documentation

ContactFirstName Property (LogCaseInternalPhoneSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactFirstName As String

[PropertyBitValueAttribute()]
public string ContactFirstName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseInternalPhoneSetup Class
LogCaseInternalPhoneSetup Members


ContactLastName Property (LogCaseInternalPhoneSetup) | fcSDK Documentation

ContactLastName Property (LogCaseInternalPhoneSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactLastName As String

[PropertyBitValueAttribute()]
public string ContactLastName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseInternalPhoneSetup Class
LogCaseInternalPhoneSetup Members


ContactPhone Property (LogCaseInternalPhoneSetup) | fcSDK Documentation

ContactPhone Property (LogCaseInternalPhoneSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactPhone As String

[PropertyBitValueAttribute()]
public string ContactPhone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseInternalPhoneSetup Class
LogCaseInternalPhoneSetup Members


GenerateTimeBombs Property (LogCaseInternalPhoneSetup) | fcSDK Documentation

GenerateTimeBombs Property (LogCaseInternalPhoneSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseInternalPhoneSetup Class
LogCaseInternalPhoneSetup Members


IsCommitmentToCustomer Property (LogCaseInternalPhoneSetup) | fcSDK Documentation

IsCommitmentToCustomer Property (LogCaseInternalPhoneSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsCommitmentToCustomer As Boolean

[PropertyBitValueAttribute()]
public bool IsCommitmentToCustomer {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseInternalPhoneSetup Class
LogCaseInternalPhoneSetup Members


LogDate Property (LogCaseInternalPhoneSetup) | fcSDK Documentation

LogDate Property (LogCaseInternalPhoneSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LogDate As Date

[PropertyBitValueAttribute()]
public DateTime LogDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseInternalPhoneSetup Class
LogCaseInternalPhoneSetup Members


LogEndDate Property (LogCaseInternalPhoneSetup) | fcSDK Documentation

LogEndDate Property (LogCaseInternalPhoneSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LogEndDate As Date

[PropertyBitValueAttribute()]
public DateTime LogEndDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseInternalPhoneSetup Class
LogCaseInternalPhoneSetup Members


NewStatus Property (LogCaseInternalPhoneSetup) | fcSDK Documentation

NewStatus Property (LogCaseInternalPhoneSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewStatus As String

[PropertyBitValueAttribute()]
public string NewStatus {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseInternalPhoneSetup Class
LogCaseInternalPhoneSetup Members


Notes Property (LogCaseInternalPhoneSetup) | fcSDK Documentation

Notes Property (LogCaseInternalPhoneSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseInternalPhoneSetup Class
LogCaseInternalPhoneSetup Members


UserName Property (LogCaseInternalPhoneSetup) | fcSDK Documentation

UserName Property (LogCaseInternalPhoneSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseInternalPhoneSetup Class
LogCaseInternalPhoneSetup Members


LogCaseNoteResult Class | fcSDK Documentation

LogCaseNoteResult Class

Result from the LogCaseNote API.

Syntax

'Declaration

Public Class LogCaseNoteResult
   Inherits FChoice.Toolkits.Clarify.ToolkitResult

public class LogCaseNoteResult : FChoice.Toolkits.Clarify.ToolkitResult

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.ToolkitResult
FChoice.Toolkits.Clarify.Support.LogCaseNoteResult

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LogCaseNoteResult Members
FChoice.Toolkits.Clarify.Support Namespace


LogCaseNoteResult Class Members | fcSDK Documentation

LogCaseNoteResult Class Members

The following tables list the members exposed by LogCaseNoteResult.

Public Constructors

 | Name | Description
Public Constructor | LogCaseNoteResult Constructor |

Public Properties

 | Name | Description
Public Property | CommitmentObjid | The Objid of the Commitment.
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | StatusChangeObjid | The Objid of the StatusChange.

Reference

LogCaseNoteResult Class
FChoice.Toolkits.Clarify.Support Namespace


LogCaseNoteResult Constructor | fcSDK Documentation

LogCaseNoteResult Constructor

Syntax

'Declaration

Public Function New()

public LogCaseNoteResult()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseNoteResult Class
LogCaseNoteResult Members


CommitmentObjid Property (LogCaseNoteResult) | fcSDK Documentation

CommitmentObjid Property (LogCaseNoteResult)

The Objid of the Commitment.

Syntax

'Declaration

Public Property CommitmentObjid As Integer

public int CommitmentObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseNoteResult Class
LogCaseNoteResult Members


StatusChangeObjid Property (LogCaseNoteResult) | fcSDK Documentation

StatusChangeObjid Property (LogCaseNoteResult)

The Objid of the StatusChange.

Syntax

'Declaration

Public Property StatusChangeObjid As Integer

public int StatusChangeObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseNoteResult Class
LogCaseNoteResult Members


LogCaseNoteSetup Class | fcSDK Documentation

LogCaseNoteSetup Class

Used by the LogCaseNote method as setup data for invocation.

Syntax

'Declaration

Public Class LogCaseNoteSetup

public class LogCaseNoteSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.LogCaseNoteSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LogCaseNoteSetup Members
FChoice.Toolkits.Clarify.Support Namespace
LogCaseNote(LogCaseNoteSetup) Method


LogCaseNoteSetup Class Members | fcSDK Documentation

LogCaseNoteSetup Class Members

The following tables list the members exposed by LogCaseNoteSetup.

Public Constructors

 | Name | Description
Public Constructor | LogCaseNoteSetup Constructor | Initializes a new instance of the LogCaseNoteSetup class.

Public Properties

 | Name | Description
Public Property | ActionType | Element from the 'Note Log Action Type' user defined list. If not set, the default list value is used.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CaseIDNum | Identifier of the Case against which the note is being logged.
Public Property | CommitmentDueDate | DateTime when the commitment is due. If not set, the LogDate is used.
Public Property | CommitmentNotes | Notes for the commitment if one is being generated.
Public Property | CommitmentPriorWarning | How long before the Commitment expires will the owner will be warned. If not set, no prior warning is given.
Public Property | CommitmentTitle | Title of the commitment.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | InternalUseOnlyNotes | Notes for internal use only.
Public Property | IsCommitmentToCustomer | Was the Commitment made to a customer.
Public Property | LogDate | DateTime the log was created. If not set, the current time is used.
Public Property | NewStatus | New status for the Case.
Public Property | Notes | Notes to be logged to the Case.
Public Property | UserName | User who created the log. If not set, the session user is used.

Reference

LogCaseNoteSetup Class
FChoice.Toolkits.Clarify.Support Namespace
LogCaseNote(LogCaseNoteSetup) Method


LogCaseNoteSetup Constructor | fcSDK Documentation

LogCaseNoteSetup Constructor

Identifier of the Case against which the note is being logged.

Initializes a new instance of the LogCaseNoteSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _caseIDNum_ As String _
)

[ConstructorIndexAttribute()]
public LogCaseNoteSetup(
   string _caseIDNum_
)

Parameters

caseIDNum

Identifier of the Case against which the note is being logged.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseNoteSetup Class
LogCaseNoteSetup Members


ActionType Property (LogCaseNoteSetup) | fcSDK Documentation

ActionType Property (LogCaseNoteSetup)

Element from the 'Note Log Action Type' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ActionType As String

[PropertyBitValueAttribute()]
public string ActionType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseNoteSetup Class
LogCaseNoteSetup Members


AdditionalFields Property (LogCaseNoteSetup) | fcSDK Documentation

AdditionalFields Property (LogCaseNoteSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseNoteSetup Class
LogCaseNoteSetup Members


CaseIDNum Property (LogCaseNoteSetup) | fcSDK Documentation

CaseIDNum Property (LogCaseNoteSetup)

Identifier of the Case against which the note is being logged.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseNoteSetup Class
LogCaseNoteSetup Members


CommitmentDueDate Property (LogCaseNoteSetup) | fcSDK Documentation

CommitmentDueDate Property (LogCaseNoteSetup)

DateTime when the commitment is due. If not set, the LogDate is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentDueDate As Date

[PropertyBitValueAttribute()]
public DateTime CommitmentDueDate {get; set;}

Remarks

Required if setting a Commitment.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseNoteSetup Class
LogCaseNoteSetup Members


CommitmentNotes Property (LogCaseNoteSetup) | fcSDK Documentation

CommitmentNotes Property (LogCaseNoteSetup)

Notes for the commitment if one is being generated.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentNotes As String

[PropertyBitValueAttribute()]
public string CommitmentNotes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseNoteSetup Class
LogCaseNoteSetup Members


CommitmentPriorWarning Property (LogCaseNoteSetup) | fcSDK Documentation

CommitmentPriorWarning Property (LogCaseNoteSetup)

How long before the Commitment expires will the owner will be warned. If not set, no prior warning is given.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentPriorWarning As TimeSpan

[PropertyBitValueAttribute()]
public TimeSpan CommitmentPriorWarning {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseNoteSetup Class
LogCaseNoteSetup Members


CommitmentTitle Property (LogCaseNoteSetup) | fcSDK Documentation

CommitmentTitle Property (LogCaseNoteSetup)

Title of the commitment.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentTitle As String

[PropertyBitValueAttribute()]
public string CommitmentTitle {get; set;}

Remarks

Required if setting a Commitment.

The Commitment title usually comes from and element in the user-defined list 'COMMITMENT', but this is not required.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseNoteSetup Class
LogCaseNoteSetup Members


GenerateTimeBombs Property (LogCaseNoteSetup) | fcSDK Documentation

GenerateTimeBombs Property (LogCaseNoteSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseNoteSetup Class
LogCaseNoteSetup Members


InternalUseOnlyNotes Property (LogCaseNoteSetup) | fcSDK Documentation

InternalUseOnlyNotes Property (LogCaseNoteSetup)

Notes for internal use only.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InternalUseOnlyNotes As String

[PropertyBitValueAttribute()]
public string InternalUseOnlyNotes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseNoteSetup Class
LogCaseNoteSetup Members


IsCommitmentToCustomer Property (LogCaseNoteSetup) | fcSDK Documentation

IsCommitmentToCustomer Property (LogCaseNoteSetup)

Was the Commitment made to a customer.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsCommitmentToCustomer As Boolean

[PropertyBitValueAttribute()]
public bool IsCommitmentToCustomer {get; set;}

Remarks

Required if setting a Commitment.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseNoteSetup Class
LogCaseNoteSetup Members


LogDate Property (LogCaseNoteSetup) | fcSDK Documentation

LogDate Property (LogCaseNoteSetup)

DateTime the log was created. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LogDate As Date

[PropertyBitValueAttribute()]
public DateTime LogDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseNoteSetup Class
LogCaseNoteSetup Members


NewStatus Property (LogCaseNoteSetup) | fcSDK Documentation

NewStatus Property (LogCaseNoteSetup)

New status for the Case.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewStatus As String

[PropertyBitValueAttribute()]
public string NewStatus {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseNoteSetup Class
LogCaseNoteSetup Members


Notes Property (LogCaseNoteSetup) | fcSDK Documentation

Notes Property (LogCaseNoteSetup)

Notes to be logged to the Case.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseNoteSetup Class
LogCaseNoteSetup Members


UserName Property (LogCaseNoteSetup) | fcSDK Documentation

UserName Property (LogCaseNoteSetup)

User who created the log. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseNoteSetup Class
LogCaseNoteSetup Members


LogCasePhoneResult Class | fcSDK Documentation

LogCasePhoneResult Class

Result from the LogCasePhone API.

Syntax

'Declaration

Public Class LogCasePhoneResult
   Inherits FChoice.Toolkits.Clarify.ToolkitResult

public class LogCasePhoneResult : FChoice.Toolkits.Clarify.ToolkitResult

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.ToolkitResult
FChoice.Toolkits.Clarify.Support.LogCasePhoneResult

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LogCasePhoneResult Members
FChoice.Toolkits.Clarify.Support Namespace


LogCasePhoneResult Class Members | fcSDK Documentation

LogCasePhoneResult Class Members

The following tables list the members exposed by LogCasePhoneResult.

Public Constructors

 | Name | Description
Public Constructor | LogCasePhoneResult Constructor |

Public Properties

 | Name | Description
Public Property | CommitmentObjid | The Objid of the Commitment.
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | StatusChangeObjid | The Objid of the StatusChange.

Reference

LogCasePhoneResult Class
FChoice.Toolkits.Clarify.Support Namespace


LogCasePhoneResult Constructor | fcSDK Documentation

LogCasePhoneResult Constructor

Syntax

'Declaration

Public Function New()

public LogCasePhoneResult()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCasePhoneResult Class
LogCasePhoneResult Members


CommitmentObjid Property (LogCasePhoneResult) | fcSDK Documentation

CommitmentObjid Property (LogCasePhoneResult)

The Objid of the Commitment.

Syntax

'Declaration

Public Property CommitmentObjid As Integer

public int CommitmentObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCasePhoneResult Class
LogCasePhoneResult Members


StatusChangeObjid Property (LogCasePhoneResult) | fcSDK Documentation

StatusChangeObjid Property (LogCasePhoneResult)

The Objid of the StatusChange.

Syntax

'Declaration

Public Property StatusChangeObjid As Integer

public int StatusChangeObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCasePhoneResult Class
LogCasePhoneResult Members


LogCasePhoneSetup Class | fcSDK Documentation

LogCasePhoneSetup Class

Used by the LogCasePhone method as setup data for invocation.

Syntax

'Declaration

Public Class LogCasePhoneSetup

public class LogCasePhoneSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.LogCasePhoneSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LogCasePhoneSetup Members
FChoice.Toolkits.Clarify.Support Namespace
LogCasePhone(LogCasePhoneSetup) Method


LogCasePhoneSetup Class Members | fcSDK Documentation

LogCasePhoneSetup Class Members

The following tables list the members exposed by LogCasePhoneSetup.

Public Constructors

 | Name | Description
Public Constructor | LogCasePhoneSetup Constructor | Initializes a new instance of the LogCasePhoneSetup class.

Public Properties

 | Name | Description
Public Property | ActionType | Element from the 'Phone Log Action Type' user defined list. If not set, the default list value is used.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CaseIDNum | Identifier of the Case against which the phone note is being logged.
Public Property | CommitmentDueDate | The DateTime of when the commitment is due. If not set, the LogDate is used.
Public Property | CommitmentNotes | Notes for the commitment if one is being generated.
Public Property | CommitmentPriorWarning | The length of time preceding the commitment expiration in which the owner will be warned. If not set, no prior warning is given.
Public Property | CommitmentTitle | Title of the commitment.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | InternalUseOnlyNotes | Notes for internal use only.
Public Property | IsCommitmentToCustomer | Specifies if the commitment is to the customer (True) or by the customer (False).
Public Property | LogDate | DateTime the log was created. If not set, the current time is used.
Public Property | LogEndDate | DateTime of the end of the phone call. If not set, the LogDate is used.
Public Property | NewStatus | New status for the Case.
Public Property | Notes | Notes to be logged to the Case.
Public Property | UserName | User who created the log. If not set, the session user is used.

Reference

LogCasePhoneSetup Class
FChoice.Toolkits.Clarify.Support Namespace
LogCasePhone(LogCasePhoneSetup) Method


LogCasePhoneSetup Constructor | fcSDK Documentation

LogCasePhoneSetup Constructor

Identifier of the Case against which the phone note is being logged.

Contact's first name.

Contact's last name.

Contact's phone number.

Initializes a new instance of the LogCasePhoneSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _caseIDNum_ As String, _
   ByVal _contactFirstName_ As String, _
   ByVal _contactLastName_ As String, _
   ByVal _contactPhone_ As String _
)

[ConstructorIndexAttribute()]
public LogCasePhoneSetup(
   string _caseIDNum_,
   string _contactFirstName_,
   string _contactLastName_,
   string _contactPhone_
)

Parameters

caseIDNum

Identifier of the Case against which the phone note is being logged.

contactFirstName

Contact's first name.

contactLastName

Contact's last name.

contactPhone

Contact's phone number.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCasePhoneSetup Class
LogCasePhoneSetup Members


ActionType Property (LogCasePhoneSetup) | fcSDK Documentation

ActionType Property (LogCasePhoneSetup)

Element from the 'Phone Log Action Type' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ActionType As String

[PropertyBitValueAttribute()]
public string ActionType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCasePhoneSetup Class
LogCasePhoneSetup Members


AdditionalFields Property (LogCasePhoneSetup) | fcSDK Documentation

AdditionalFields Property (LogCasePhoneSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCasePhoneSetup Class
LogCasePhoneSetup Members


CaseIDNum Property (LogCasePhoneSetup) | fcSDK Documentation

CaseIDNum Property (LogCasePhoneSetup)

Identifier of the Case against which the phone note is being logged.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCasePhoneSetup Class
LogCasePhoneSetup Members


CommitmentDueDate Property (LogCasePhoneSetup) | fcSDK Documentation

CommitmentDueDate Property (LogCasePhoneSetup)

The DateTime of when the commitment is due. If not set, the LogDate is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentDueDate As Date

[PropertyBitValueAttribute()]
public DateTime CommitmentDueDate {get; set;}

Remarks

Required if setting a Commitment.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCasePhoneSetup Class
LogCasePhoneSetup Members


CommitmentNotes Property (LogCasePhoneSetup) | fcSDK Documentation

CommitmentNotes Property (LogCasePhoneSetup)

Notes for the commitment if one is being generated.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentNotes As String

[PropertyBitValueAttribute()]
public string CommitmentNotes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCasePhoneSetup Class
LogCasePhoneSetup Members


CommitmentPriorWarning Property (LogCasePhoneSetup) | fcSDK Documentation

CommitmentPriorWarning Property (LogCasePhoneSetup)

The length of time preceding the commitment expiration in which the owner will be warned. If not set, no prior warning is given.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentPriorWarning As TimeSpan

[PropertyBitValueAttribute()]
public TimeSpan CommitmentPriorWarning {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCasePhoneSetup Class
LogCasePhoneSetup Members


CommitmentTitle Property (LogCasePhoneSetup) | fcSDK Documentation

CommitmentTitle Property (LogCasePhoneSetup)

Title of the commitment.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentTitle As String

[PropertyBitValueAttribute()]
public string CommitmentTitle {get; set;}

Remarks

Required if setting a Commitment.

The Commitment title usually comes from and element in the user-defined list 'COMMITMENT', but this is not required.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCasePhoneSetup Class
LogCasePhoneSetup Members


ContactFirstName Property (LogCasePhoneSetup) | fcSDK Documentation

ContactFirstName Property (LogCasePhoneSetup)

Contact's first name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactFirstName As String

[PropertyBitValueAttribute()]
public string ContactFirstName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCasePhoneSetup Class
LogCasePhoneSetup Members


ContactLastName Property (LogCasePhoneSetup) | fcSDK Documentation

ContactLastName Property (LogCasePhoneSetup)

Contact's last name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactLastName As String

[PropertyBitValueAttribute()]
public string ContactLastName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCasePhoneSetup Class
LogCasePhoneSetup Members


ContactPhone Property (LogCasePhoneSetup) | fcSDK Documentation

ContactPhone Property (LogCasePhoneSetup)

Contact's phone number.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactPhone As String

[PropertyBitValueAttribute()]
public string ContactPhone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCasePhoneSetup Class
LogCasePhoneSetup Members


GenerateTimeBombs Property (LogCasePhoneSetup) | fcSDK Documentation

GenerateTimeBombs Property (LogCasePhoneSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCasePhoneSetup Class
LogCasePhoneSetup Members


InternalUseOnlyNotes Property (LogCasePhoneSetup) | fcSDK Documentation

InternalUseOnlyNotes Property (LogCasePhoneSetup)

Notes for internal use only.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InternalUseOnlyNotes As String

[PropertyBitValueAttribute()]
public string InternalUseOnlyNotes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCasePhoneSetup Class
LogCasePhoneSetup Members


IsCommitmentToCustomer Property (LogCasePhoneSetup) | fcSDK Documentation

IsCommitmentToCustomer Property (LogCasePhoneSetup)

Specifies if the commitment is to the customer (True) or by the customer (False).

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsCommitmentToCustomer As Boolean

[PropertyBitValueAttribute()]
public bool IsCommitmentToCustomer {get; set;}

Remarks

Required if setting a Commitment.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCasePhoneSetup Class
LogCasePhoneSetup Members


LogDate Property (LogCasePhoneSetup) | fcSDK Documentation

LogDate Property (LogCasePhoneSetup)

DateTime the log was created. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LogDate As Date

[PropertyBitValueAttribute()]
public DateTime LogDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCasePhoneSetup Class
LogCasePhoneSetup Members


LogEndDate Property (LogCasePhoneSetup) | fcSDK Documentation

LogEndDate Property (LogCasePhoneSetup)

DateTime of the end of the phone call. If not set, the LogDate is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LogEndDate As Date

[PropertyBitValueAttribute()]
public DateTime LogEndDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCasePhoneSetup Class
LogCasePhoneSetup Members


NewStatus Property (LogCasePhoneSetup) | fcSDK Documentation

NewStatus Property (LogCasePhoneSetup)

New status for the Case.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewStatus As String

[PropertyBitValueAttribute()]
public string NewStatus {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCasePhoneSetup Class
LogCasePhoneSetup Members


Notes Property (LogCasePhoneSetup) | fcSDK Documentation

Notes Property (LogCasePhoneSetup)

Notes to be logged to the Case.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCasePhoneSetup Class
LogCasePhoneSetup Members


UserName Property (LogCasePhoneSetup) | fcSDK Documentation

UserName Property (LogCasePhoneSetup)

User who created the log. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCasePhoneSetup Class
LogCasePhoneSetup Members


LogCaseResearchResult Class | fcSDK Documentation

LogCaseResearchResult Class

Result from the LogCaseResearch API.

Syntax

'Declaration

Public Class LogCaseResearchResult
   Inherits FChoice.Toolkits.Clarify.ToolkitResult

public class LogCaseResearchResult : FChoice.Toolkits.Clarify.ToolkitResult

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.ToolkitResult
FChoice.Toolkits.Clarify.Support.LogCaseResearchResult

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LogCaseResearchResult Members
FChoice.Toolkits.Clarify.Support Namespace


LogCaseResearchResult Class Members | fcSDK Documentation

LogCaseResearchResult Class Members

The following tables list the members exposed by LogCaseResearchResult.

Public Constructors

 | Name | Description
Public Constructor | LogCaseResearchResult Constructor |

Public Properties

 | Name | Description
Public Property | CommitmentObjid | The Objid of the Commitment.
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | StatusChangeObjid | The Objid of the StatusChange.

Reference

LogCaseResearchResult Class
FChoice.Toolkits.Clarify.Support Namespace


LogCaseResearchResult Constructor | fcSDK Documentation

LogCaseResearchResult Constructor

Syntax

'Declaration

Public Function New()

public LogCaseResearchResult()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseResearchResult Class
LogCaseResearchResult Members


CommitmentObjid Property (LogCaseResearchResult) | fcSDK Documentation

CommitmentObjid Property (LogCaseResearchResult)

The Objid of the Commitment.

Syntax

'Declaration

Public Property CommitmentObjid As Integer

public int CommitmentObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseResearchResult Class
LogCaseResearchResult Members


StatusChangeObjid Property (LogCaseResearchResult) | fcSDK Documentation

StatusChangeObjid Property (LogCaseResearchResult)

The Objid of the StatusChange.

Syntax

'Declaration

Public Property StatusChangeObjid As Integer

public int StatusChangeObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseResearchResult Class
LogCaseResearchResult Members


LogCaseResearchSetup Class | fcSDK Documentation

LogCaseResearchSetup Class

Used by the LogCaseResearch method as setup data for invocation.

Syntax

'Declaration

Public Class LogCaseResearchSetup

public class LogCaseResearchSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.LogCaseResearchSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LogCaseResearchSetup Members
FChoice.Toolkits.Clarify.Support Namespace
LogCaseResearch(LogCaseResearchSetup) Method


LogCaseResearchSetup Class Members | fcSDK Documentation

LogCaseResearchSetup Class Members

The following tables list the members exposed by LogCaseResearchSetup.

Public Constructors

 | Name | Description
Public Constructor | LogCaseResearchSetup Constructor | Initializes a new instance of the LogCaseResearchSetup class.

Public Properties

 | Name | Description
Public Property | ActionType | Element from the 'Research Log Action Type' user defined list. If not set, the default list value is used.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CaseIDNum | Identifier of the Case against which the research note is being logged.
Public Property | CommitmentDueDate | The DateTime of when the commitment is due. If not set, the LogDate is used.
Public Property | CommitmentNotes | Notes for the commitment if one is being generated.
Public Property | CommitmentPriorWarning | The length of time preceding the commitment expiration in which the owner will be warned. If not set, no prior warning is given.
Public Property | CommitmentTitle | Title of the commitment.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | InternalUseOnlyNotes | Notes for internal use only.
Public Property | IsCommitmentToCustomer | Specifies if the commitment is to the customer (True) or by the customer (False).
Public Property | LogDate | DateTime the log was created. If not set, the current time is used.
Public Property | NewStatus | New status for the Case.
Public Property | Notes | Notes to be logged to the Case.
Public Property | ResearchDuration | The length of time for research.
Public Property | UserName | User who created the log. If not set, the session user is used.

Reference

LogCaseResearchSetup Class
FChoice.Toolkits.Clarify.Support Namespace
LogCaseResearch(LogCaseResearchSetup) Method


LogCaseResearchSetup Constructor | fcSDK Documentation

LogCaseResearchSetup Constructor

Identifier of the Case against which the research note is being logged.

The length of time for research.

Initializes a new instance of the LogCaseResearchSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _caseIDNum_ As String, _
   ByVal _researchDuration_ As TimeSpan _
)

[ConstructorIndexAttribute()]
public LogCaseResearchSetup(
   string _caseIDNum_,
   TimeSpan _researchDuration_
)

Parameters

caseIDNum

Identifier of the Case against which the research note is being logged.

researchDuration

The length of time for research.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseResearchSetup Class
LogCaseResearchSetup Members


ActionType Property (LogCaseResearchSetup) | fcSDK Documentation

ActionType Property (LogCaseResearchSetup)

Element from the 'Research Log Action Type' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ActionType As String

[PropertyBitValueAttribute()]
public string ActionType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseResearchSetup Class
LogCaseResearchSetup Members


AdditionalFields Property (LogCaseResearchSetup) | fcSDK Documentation

AdditionalFields Property (LogCaseResearchSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseResearchSetup Class
LogCaseResearchSetup Members


CaseIDNum Property (LogCaseResearchSetup) | fcSDK Documentation

CaseIDNum Property (LogCaseResearchSetup)

Identifier of the Case against which the research note is being logged.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseResearchSetup Class
LogCaseResearchSetup Members


CommitmentDueDate Property (LogCaseResearchSetup) | fcSDK Documentation

CommitmentDueDate Property (LogCaseResearchSetup)

The DateTime of when the commitment is due. If not set, the LogDate is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentDueDate As Date

[PropertyBitValueAttribute()]
public DateTime CommitmentDueDate {get; set;}

Remarks

Required if setting a Commitment.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseResearchSetup Class
LogCaseResearchSetup Members


CommitmentNotes Property (LogCaseResearchSetup) | fcSDK Documentation

CommitmentNotes Property (LogCaseResearchSetup)

Notes for the commitment if one is being generated.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentNotes As String

[PropertyBitValueAttribute()]
public string CommitmentNotes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseResearchSetup Class
LogCaseResearchSetup Members


CommitmentPriorWarning Property (LogCaseResearchSetup) | fcSDK Documentation

CommitmentPriorWarning Property (LogCaseResearchSetup)

The length of time preceding the commitment expiration in which the owner will be warned. If not set, no prior warning is given.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentPriorWarning As TimeSpan

[PropertyBitValueAttribute()]
public TimeSpan CommitmentPriorWarning {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseResearchSetup Class
LogCaseResearchSetup Members


CommitmentTitle Property (LogCaseResearchSetup) | fcSDK Documentation

CommitmentTitle Property (LogCaseResearchSetup)

Title of the commitment.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentTitle As String

[PropertyBitValueAttribute()]
public string CommitmentTitle {get; set;}

Remarks

Required if setting a Commitment.

The Commitment title usually comes from and element in the user-defined list 'COMMITMENT', but this is not required.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseResearchSetup Class
LogCaseResearchSetup Members


GenerateTimeBombs Property (LogCaseResearchSetup) | fcSDK Documentation

GenerateTimeBombs Property (LogCaseResearchSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseResearchSetup Class
LogCaseResearchSetup Members


InternalUseOnlyNotes Property (LogCaseResearchSetup) | fcSDK Documentation

InternalUseOnlyNotes Property (LogCaseResearchSetup)

Notes for internal use only.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InternalUseOnlyNotes As String

[PropertyBitValueAttribute()]
public string InternalUseOnlyNotes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseResearchSetup Class
LogCaseResearchSetup Members


IsCommitmentToCustomer Property (LogCaseResearchSetup) | fcSDK Documentation

IsCommitmentToCustomer Property (LogCaseResearchSetup)

Specifies if the commitment is to the customer (True) or by the customer (False).

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsCommitmentToCustomer As Boolean

[PropertyBitValueAttribute()]
public bool IsCommitmentToCustomer {get; set;}

Remarks

Required if setting a Commitment.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseResearchSetup Class
LogCaseResearchSetup Members


LogDate Property (LogCaseResearchSetup) | fcSDK Documentation

LogDate Property (LogCaseResearchSetup)

DateTime the log was created. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LogDate As Date

[PropertyBitValueAttribute()]
public DateTime LogDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseResearchSetup Class
LogCaseResearchSetup Members


NewStatus Property (LogCaseResearchSetup) | fcSDK Documentation

NewStatus Property (LogCaseResearchSetup)

New status for the Case.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewStatus As String

[PropertyBitValueAttribute()]
public string NewStatus {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseResearchSetup Class
LogCaseResearchSetup Members


Notes Property (LogCaseResearchSetup) | fcSDK Documentation

Notes Property (LogCaseResearchSetup)

Notes to be logged to the Case.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseResearchSetup Class
LogCaseResearchSetup Members


ResearchDuration Property (LogCaseResearchSetup) | fcSDK Documentation

ResearchDuration Property (LogCaseResearchSetup)

The length of time for research.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ResearchDuration As TimeSpan

[PropertyBitValueAttribute()]
public TimeSpan ResearchDuration {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseResearchSetup Class
LogCaseResearchSetup Members


UserName Property (LogCaseResearchSetup) | fcSDK Documentation

UserName Property (LogCaseResearchSetup)

User who created the log. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseResearchSetup Class
LogCaseResearchSetup Members


LogEmailInSetup Class | fcSDK Documentation

LogEmailInSetup Class

Setup that is common to both LogCaseEmailInSetup and LogSubcaseEmailInSetup.

This setup should not be used on its own.

Syntax

'Declaration

Public MustInherit Class LogEmailInSetup

public abstract class LogEmailInSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.LogEmailInSetup
FChoice.Toolkits.Clarify.Quality.QualityToolkit.LogCREmailInSetup
FChoice.Toolkits.Clarify.Sales.LogActionItemEmailInSetup
FChoice.Toolkits.Clarify.Support.LogCaseEmailInSetup
FChoice.Toolkits.Clarify.Support.LogSubCaseEmailInSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LogEmailInSetup Members
FChoice.Toolkits.Clarify.Support Namespace


LogEmailInSetup Class Members | fcSDK Documentation

LogEmailInSetup Class Members

The following tables list the members exposed by LogEmailInSetup.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CCList | Email addresses of persons CC'd on the email being logged.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | IDNumber | Identifier of the Case against which the email in is being logged.
Public Property | LogDate | DateTime the log was created. If not set, the current time is used
Public Property | MailLogActionType | Element from the 'Mail Log Action Type' user defined list. If not set, the default list value is used.
Public Property | Message | Body of the email being logged.
Public Property | Recipient | Email address of the recipients of the email being logged.
Public Property | Sender | Email address of the sender of the email being logged.
Public Property | Subject |
Public Property | UserName | User who created the log. If not set, the session user is used.

Reference

LogEmailInSetup Class
FChoice.Toolkits.Clarify.Support Namespace


AdditionalFields Property (LogEmailInSetup) | fcSDK Documentation

AdditionalFields Property (LogEmailInSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

Public ReadOnly Property AdditionalFields As SimplifiedAdditionalFields

public SimplifiedAdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogEmailInSetup Class
LogEmailInSetup Members


CCList Property (LogEmailInSetup) | fcSDK Documentation

CCList Property (LogEmailInSetup)

Email addresses of persons CC'd on the email being logged.

Syntax

'Declaration

Public Property CCList As String

public string CCList {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogEmailInSetup Class
LogEmailInSetup Members


GenerateTimeBombs Property (LogEmailInSetup) | fcSDK Documentation

GenerateTimeBombs Property (LogEmailInSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

Public Property GenerateTimeBombs As Boolean

public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogEmailInSetup Class
LogEmailInSetup Members


IDNumber Property (LogEmailInSetup) | fcSDK Documentation

IDNumber Property (LogEmailInSetup)

Identifier of the Case against which the email in is being logged.

Syntax

'Declaration

Public Property IDNumber As String

public string IDNumber {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogEmailInSetup Class
LogEmailInSetup Members


LogDate Property (LogEmailInSetup) | fcSDK Documentation

LogDate Property (LogEmailInSetup)

DateTime the log was created. If not set, the current time is used

Syntax

'Declaration

Public Property LogDate As Nullable(Of Date)

public Nullable<DateTime> LogDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogEmailInSetup Class
LogEmailInSetup Members


MailLogActionType Property | fcSDK Documentation

MailLogActionType Property

Element from the 'Mail Log Action Type' user defined list. If not set, the default list value is used.

Syntax

'Declaration

Public Property MailLogActionType As String

public string MailLogActionType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogEmailInSetup Class
LogEmailInSetup Members


Message Property (LogEmailInSetup) | fcSDK Documentation

Message Property (LogEmailInSetup)

Body of the email being logged.

Syntax

'Declaration

Public Property Message As String

public string Message {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogEmailInSetup Class
LogEmailInSetup Members


Recipient Property (LogEmailInSetup) | fcSDK Documentation

Recipient Property (LogEmailInSetup)

Email address of the recipients of the email being logged.

Syntax

'Declaration

Public Property Recipient As String

public string Recipient {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogEmailInSetup Class
LogEmailInSetup Members


Sender Property (LogEmailInSetup) | fcSDK Documentation

Sender Property (LogEmailInSetup)

Email address of the sender of the email being logged.

Syntax

'Declaration

Public Property Sender As String

public string Sender {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogEmailInSetup Class
LogEmailInSetup Members


Subject Property | fcSDK Documentation

Subject Property

Syntax

'Declaration

Public Property Subject As String

public string Subject {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogEmailInSetup Class
LogEmailInSetup Members


UserName Property (LogEmailInSetup) | fcSDK Documentation

UserName Property (LogEmailInSetup)

User who created the log. If not set, the session user is used.

Syntax

'Declaration

Public Property UserName As String

public string UserName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogEmailInSetup Class
LogEmailInSetup Members


LogSubcaseCommitmentSetup Class | fcSDK Documentation

LogSubcaseCommitmentSetup Class

Used by the LogSubcaseCommitment method as setup data for invocation.

Syntax

'Declaration

Public Class LogSubcaseCommitmentSetup

public class LogSubcaseCommitmentSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.LogSubcaseCommitmentSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LogSubcaseCommitmentSetup Members
FChoice.Toolkits.Clarify.Support Namespace
LogSubcaseCommitment(LogSubcaseCommitmentSetup) Method


LogSubcaseCommitmentSetup Class Members | fcSDK Documentation

LogSubcaseCommitmentSetup Class Members

The following tables list the members exposed by LogSubcaseCommitmentSetup.

Public Constructors

 | Name | Description
Public Constructor | LogSubcaseCommitmentSetup Constructor | Initializes a new instance of the LogSubcaseCommitmentSetup class.

Public Properties

 | Name | Description
Public Property | ActionType | Element from the 'Commitment Log Action Type' user defined list. If not set, the default list value is used.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CommitmentDate | DateTime when the commitment is due. If not set, the LogDate is used.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | GenerateCommitmentEmail | Specifies if the API should add the email notifications for the commitment time and prior warning time.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | IsMadeToCustomer | Specifies if the commitment is to the customer (True) or by the customer (False).
Public Property | LogDate | DateTime the log was created. If not set, the current time is used.
Public Property | Notes | Additional notes for the log.
Public Property | PriorWarning | The length of time preceding the commitment expiration in which the owner will be warned. If not set, no prior warning is given.
Public Property | SubcaseIDNum | Identifier of the Subcase against which the commitment is being logged.
Public Property | Title | Title of the commitment.
Public Property | UserName | User who created the log. If not set, the session user is used.

Reference

LogSubcaseCommitmentSetup Class
FChoice.Toolkits.Clarify.Support Namespace
LogSubcaseCommitment(LogSubcaseCommitmentSetup) Method


LogSubcaseCommitmentSetup Constructor | fcSDK Documentation

LogSubcaseCommitmentSetup Constructor

Identifier of the Subcase against which the commitment is being logged.

Title of the commitment.

The length of time preceding the commitment expiration in which the owner will be warned. If not set, no prior warning is given.

Contact's first name.

Contact's last name.

Contact's phone number.

Initializes a new instance of the LogSubcaseCommitmentSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _subcaseIDNum_ As String, _
   ByVal _title_ As String, _
   ByVal _priorWarning_ As TimeSpan, _
   ByVal _contactFirstName_ As String, _
   ByVal _contactLastName_ As String, _
   ByVal _contactPhone_ As String _
)

[ConstructorIndexAttribute()]
public LogSubcaseCommitmentSetup(
   string _subcaseIDNum_,
   string _title_,
   TimeSpan _priorWarning_,
   string _contactFirstName_,
   string _contactLastName_,
   string _contactPhone_
)

Parameters

subcaseIDNum

Identifier of the Subcase against which the commitment is being logged.

title

Title of the commitment.

priorWarning

The length of time preceding the commitment expiration in which the owner will be warned. If not set, no prior warning is given.

contactFirstName

Contact's first name.

contactLastName

Contact's last name.

contactPhone

Contact's phone number.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseCommitmentSetup Class
LogSubcaseCommitmentSetup Members


ActionType Property (LogSubcaseCommitmentSetup) | fcSDK Documentation

ActionType Property (LogSubcaseCommitmentSetup)

Element from the 'Commitment Log Action Type' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ActionType As String

[PropertyBitValueAttribute()]
public string ActionType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseCommitmentSetup Class
LogSubcaseCommitmentSetup Members


AdditionalFields Property (LogSubcaseCommitmentSetup) | fcSDK Documentation

AdditionalFields Property (LogSubcaseCommitmentSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseCommitmentSetup Class
LogSubcaseCommitmentSetup Members


CommitmentDate Property (LogSubcaseCommitmentSetup) | fcSDK Documentation

CommitmentDate Property (LogSubcaseCommitmentSetup)

DateTime when the commitment is due. If not set, the LogDate is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentDate As Date

[PropertyBitValueAttribute()]
public DateTime CommitmentDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseCommitmentSetup Class
LogSubcaseCommitmentSetup Members


ContactFirstName Property (LogSubcaseCommitmentSetup) | fcSDK Documentation

ContactFirstName Property (LogSubcaseCommitmentSetup)

Contact's first name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactFirstName As String

[PropertyBitValueAttribute()]
public string ContactFirstName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseCommitmentSetup Class
LogSubcaseCommitmentSetup Members


ContactLastName Property (LogSubcaseCommitmentSetup) | fcSDK Documentation

ContactLastName Property (LogSubcaseCommitmentSetup)

Contact's last name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactLastName As String

[PropertyBitValueAttribute()]
public string ContactLastName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseCommitmentSetup Class
LogSubcaseCommitmentSetup Members


ContactPhone Property (LogSubcaseCommitmentSetup) | fcSDK Documentation

ContactPhone Property (LogSubcaseCommitmentSetup)

Contact's phone number.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactPhone As String

[PropertyBitValueAttribute()]
public string ContactPhone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseCommitmentSetup Class
LogSubcaseCommitmentSetup Members


GenerateCommitmentEmail Property (LogSubcaseCommitmentSetup) | fcSDK Documentation

GenerateCommitmentEmail Property (LogSubcaseCommitmentSetup)

Specifies if the API should add the email notifications for the commitment time and prior warning time.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateCommitmentEmail As Boolean

[PropertyBitValueAttribute()]
public bool GenerateCommitmentEmail {get; set;}

Remarks

Base Clarify sends two emails each time a Commitment is logged. The first notifies the owner when the Commitment expires, and the second notifies the owner when the prior warning (if any) expires.

To control what is sent in the Commitment email please see your Clarify documentation concerning the 'com_tmplte' record.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseCommitmentSetup Class
LogSubcaseCommitmentSetup Members


GenerateTimeBombs Property (LogSubcaseCommitmentSetup) | fcSDK Documentation

GenerateTimeBombs Property (LogSubcaseCommitmentSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseCommitmentSetup Class
LogSubcaseCommitmentSetup Members


IsMadeToCustomer Property (LogSubcaseCommitmentSetup) | fcSDK Documentation

IsMadeToCustomer Property (LogSubcaseCommitmentSetup)

Specifies if the commitment is to the customer (True) or by the customer (False).

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsMadeToCustomer As Boolean

[PropertyBitValueAttribute()]
public bool IsMadeToCustomer {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseCommitmentSetup Class
LogSubcaseCommitmentSetup Members


LogDate Property (LogSubcaseCommitmentSetup) | fcSDK Documentation

LogDate Property (LogSubcaseCommitmentSetup)

DateTime the log was created. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LogDate As Date

[PropertyBitValueAttribute()]
public DateTime LogDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseCommitmentSetup Class
LogSubcaseCommitmentSetup Members


Notes Property (LogSubcaseCommitmentSetup) | fcSDK Documentation

Notes Property (LogSubcaseCommitmentSetup)

Additional notes for the log.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseCommitmentSetup Class
LogSubcaseCommitmentSetup Members


PriorWarning Property (LogSubcaseCommitmentSetup) | fcSDK Documentation

PriorWarning Property (LogSubcaseCommitmentSetup)

The length of time preceding the commitment expiration in which the owner will be warned. If not set, no prior warning is given.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PriorWarning As TimeSpan

[PropertyBitValueAttribute()]
public TimeSpan PriorWarning {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseCommitmentSetup Class
LogSubcaseCommitmentSetup Members


SubcaseIDNum Property (LogSubcaseCommitmentSetup) | fcSDK Documentation

SubcaseIDNum Property (LogSubcaseCommitmentSetup)

Identifier of the Subcase against which the commitment is being logged.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SubcaseIDNum As String

[PropertyBitValueAttribute()]
public string SubcaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseCommitmentSetup Class
LogSubcaseCommitmentSetup Members


Title Property (LogSubcaseCommitmentSetup) | fcSDK Documentation

Title Property (LogSubcaseCommitmentSetup)

Title of the commitment.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Title As String

[PropertyBitValueAttribute()]
public string Title {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseCommitmentSetup Class
LogSubcaseCommitmentSetup Members


UserName Property (LogSubcaseCommitmentSetup) | fcSDK Documentation

UserName Property (LogSubcaseCommitmentSetup)

User who created the log. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseCommitmentSetup Class
LogSubcaseCommitmentSetup Members


LogSubCaseEmailInSetup Class | fcSDK Documentation

LogSubCaseEmailInSetup Class

Used by the LogSubCaseEmailIn method as setup data for invocation.

Syntax

'Declaration

Public Class LogSubCaseEmailInSetup
   Inherits LogEmailInSetup

public class LogSubCaseEmailInSetup : LogEmailInSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.LogEmailInSetup
FChoice.Toolkits.Clarify.Support.LogSubCaseEmailInSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LogSubCaseEmailInSetup Members
FChoice.Toolkits.Clarify.Support Namespace


LogSubCaseEmailInSetup Class Members | fcSDK Documentation

LogSubCaseEmailInSetup Class Members

The following tables list the members exposed by LogSubCaseEmailInSetup.

Public Constructors

 | Name | Description
Public Constructor | LogSubCaseEmailInSetup Constructor |

Public Properties

 | Name | Description
Public Property | AdditionalFields | Element from the 'Mail Log Action Type' user defined list. If not set, the default list value is used. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | CCList | Email addresses of persons CC'd on the email being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | GenerateTimeBombs | Specifies if timebombs should be created. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | IDNumber | Identifier of the Case against which the email in is being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | LogDate | DateTime the log was created. If not set, the current time is used (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | MailLogActionType | Element from the 'Mail Log Action Type' user defined list. If not set, the default list value is used. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | Message | Body of the email being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | Recipient | Recipient of the email being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | Sender | Sender of the email being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | Subject | (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | UserName | User who created the log. If not set, the session user is used. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)

Reference

LogSubCaseEmailInSetup Class
FChoice.Toolkits.Clarify.Support Namespace


LogSubCaseEmailInSetup Constructor | fcSDK Documentation

LogSubCaseEmailInSetup Constructor

Identifier of the Subcase against which the email in is being logged.

Email address of the sender of the email being logged.

Email address(s) of the recipients of the email being logged.

Body of the email being logged.

Syntax

'Declaration

Public Function New( _
   ByVal _subcaseIDNum_ As String, _
   ByVal _sender_ As String, _
   ByVal _recipient_ As String, _
   ByVal _message_ As String _
)

public LogSubCaseEmailInSetup(
   string _subcaseIDNum_,
   string _sender_,
   string _recipient_,
   string _message_
)

Parameters

subcaseIDNum

Identifier of the Subcase against which the email in is being logged.

sender

Email address of the sender of the email being logged.

recipient

Email address(s) of the recipients of the email being logged.

message

Body of the email being logged.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubCaseEmailInSetup Class
LogSubCaseEmailInSetup Members


LogSubcaseEmailResult Class | fcSDK Documentation

LogSubcaseEmailResult Class

Result from the LogSubcaseEmail API.

Syntax

'Declaration

Public Class LogSubcaseEmailResult
   Inherits FChoice.Toolkits.Clarify.ToolkitResult

public class LogSubcaseEmailResult : FChoice.Toolkits.Clarify.ToolkitResult

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.ToolkitResult
FChoice.Toolkits.Clarify.Support.LogSubcaseEmailResult

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LogSubcaseEmailResult Members
FChoice.Toolkits.Clarify.Support Namespace


LogSubcaseEmailResult Class Members | fcSDK Documentation

LogSubcaseEmailResult Class Members

The following tables list the members exposed by LogSubcaseEmailResult.

Public Constructors

 | Name | Description
Public Constructor | LogSubcaseEmailResult Constructor |

Public Properties

 | Name | Description
Public Property | CommitmentObjid | The Objid of the Commitment.
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | StatusChangeObjid | The Objid of the StatusChange.

Reference

LogSubcaseEmailResult Class
FChoice.Toolkits.Clarify.Support Namespace


LogSubcaseEmailResult Constructor | fcSDK Documentation

LogSubcaseEmailResult Constructor

Syntax

'Declaration

Public Function New()

public LogSubcaseEmailResult()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseEmailResult Class
LogSubcaseEmailResult Members


CommitmentObjid Property (LogSubcaseEmailResult) | fcSDK Documentation

CommitmentObjid Property (LogSubcaseEmailResult)

The Objid of the Commitment.

Syntax

'Declaration

Public Property CommitmentObjid As Integer

public int CommitmentObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseEmailResult Class
LogSubcaseEmailResult Members


StatusChangeObjid Property (LogSubcaseEmailResult) | fcSDK Documentation

StatusChangeObjid Property (LogSubcaseEmailResult)

The Objid of the StatusChange.

Syntax

'Declaration

Public Property StatusChangeObjid As Integer

public int StatusChangeObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseEmailResult Class
LogSubcaseEmailResult Members


LogSubcaseEmailSetup Class | fcSDK Documentation

LogSubcaseEmailSetup Class

Used by the LogSubcaseEmail method as setup data for invocation.

Syntax

'Declaration

Public Class LogSubcaseEmailSetup

public class LogSubcaseEmailSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.LogSubcaseEmailSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LogSubcaseEmailSetup Members
FChoice.Toolkits.Clarify.Support Namespace
LogSubcaseEmail(LogSubcaseEmailSetup) Method


LogSubcaseEmailSetup Class Members | fcSDK Documentation

LogSubcaseEmailSetup Class Members

The following tables list the members exposed by LogSubcaseEmailSetup.

Public Constructors

 | Name | Description
Public Constructor | LogSubcaseEmailSetup Constructor | Initializes a new instance of the LogSubcaseEmailSetup class.

Public Properties

 | Name | Description
Public Property | ActionType | Element from the 'Mail Log Action Type' user defined list. If not set, the default list value is used.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CCList | List of cc recipients for the email.
Public Property | CommitmentActionType | Element from the 'Commitment Log Action Type' user defined list. If not set, the default list value is used.
Public Property | CommitmentContactObjid | Commitment Objid for the contact of the commitment. If not set, the contact for the Case is used.
Public Property | CommitmentDueDate | The DateTime of when the commitment is due. If not set, the LogDate is used.
Public Property | CommitmentNotes | Notes for the commitment if one is being generated.
Public Property | CommitmentPriorWarning | The length of time preceding the commitment expiration in which the owner will be warned. If not set, no prior warning is given.
Public Property | CommitmentTitle | Title of the commitment.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | IsCommitmentToCustomer | Specifies if the commitment is to the customer (True) or by the customer (False).
Public Property | LogDate | DateTime the log was created. If not set, the current time is used.
Public Property | Message | Email message.
Public Property | NewStatus | New status for the Subcase.
Public Property | Recipient | List of email addresses the email is sent to.
Public Property | SendEmail | Specifies if a timebomb be added to Clarify that will cause Rule Manager (if running) to send the email.
Public Property | SubcaseIDNum | Identifier of the Subcase against which the email is being logged.
Public Property | UserName | User who created the log. If not set, the session user is used.

Reference

LogSubcaseEmailSetup Class
FChoice.Toolkits.Clarify.Support Namespace
LogSubcaseEmail(LogSubcaseEmailSetup) Method


LogSubcaseEmailSetup Constructor | fcSDK Documentation

LogSubcaseEmailSetup Constructor

Identifier of the Subcase against which the email is being logged.

Initializes a new instance of the LogSubcaseEmailSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _subcaseIDNum_ As String _
)

[ConstructorIndexAttribute()]
public LogSubcaseEmailSetup(
   string _subcaseIDNum_
)

Parameters

subcaseIDNum

Identifier of the Subcase against which the email is being logged.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseEmailSetup Class
LogSubcaseEmailSetup Members


ActionType Property (LogSubcaseEmailSetup) | fcSDK Documentation

ActionType Property (LogSubcaseEmailSetup)

Element from the 'Mail Log Action Type' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ActionType As String

[PropertyBitValueAttribute()]
public string ActionType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseEmailSetup Class
LogSubcaseEmailSetup Members


AdditionalFields Property (LogSubcaseEmailSetup) | fcSDK Documentation

AdditionalFields Property (LogSubcaseEmailSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseEmailSetup Class
LogSubcaseEmailSetup Members


CCList Property (LogSubcaseEmailSetup) | fcSDK Documentation

CCList Property (LogSubcaseEmailSetup)

List of cc recipients for the email.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CCList As String

[PropertyBitValueAttribute()]
public string CCList {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseEmailSetup Class
LogSubcaseEmailSetup Members


CommitmentActionType Property (LogSubcaseEmailSetup) | fcSDK Documentation

CommitmentActionType Property (LogSubcaseEmailSetup)

Element from the 'Commitment Log Action Type' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentActionType As String

[PropertyBitValueAttribute()]
public string CommitmentActionType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseEmailSetup Class
LogSubcaseEmailSetup Members


CommitmentContactObjid Property (LogSubcaseEmailSetup) | fcSDK Documentation

CommitmentContactObjid Property (LogSubcaseEmailSetup)

Commitment Objid for the contact of the commitment. If not set, the contact for the Case is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentContactObjid As Integer

[PropertyBitValueAttribute()]
public int CommitmentContactObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseEmailSetup Class
LogSubcaseEmailSetup Members


CommitmentDueDate Property (LogSubcaseEmailSetup) | fcSDK Documentation

CommitmentDueDate Property (LogSubcaseEmailSetup)

The DateTime of when the commitment is due. If not set, the LogDate is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentDueDate As Date

[PropertyBitValueAttribute()]
public DateTime CommitmentDueDate {get; set;}

Remarks

Required if setting a Commitment.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseEmailSetup Class
LogSubcaseEmailSetup Members


CommitmentNotes Property (LogSubcaseEmailSetup) | fcSDK Documentation

CommitmentNotes Property (LogSubcaseEmailSetup)

Notes for the commitment if one is being generated.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentNotes As String

[PropertyBitValueAttribute()]
public string CommitmentNotes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseEmailSetup Class
LogSubcaseEmailSetup Members


CommitmentPriorWarning Property (LogSubcaseEmailSetup) | fcSDK Documentation

CommitmentPriorWarning Property (LogSubcaseEmailSetup)

The length of time preceding the commitment expiration in which the owner will be warned. If not set, no prior warning is given.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentPriorWarning As TimeSpan

[PropertyBitValueAttribute()]
public TimeSpan CommitmentPriorWarning {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseEmailSetup Class
LogSubcaseEmailSetup Members


CommitmentTitle Property (LogSubcaseEmailSetup) | fcSDK Documentation

CommitmentTitle Property (LogSubcaseEmailSetup)

Title of the commitment.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentTitle As String

[PropertyBitValueAttribute()]
public string CommitmentTitle {get; set;}

Remarks

Required if setting a Commitment.

The Commitment title usually comes from and element in the user-defined list 'COMMITMENT', but this is not required.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseEmailSetup Class
LogSubcaseEmailSetup Members


GenerateTimeBombs Property (LogSubcaseEmailSetup) | fcSDK Documentation

GenerateTimeBombs Property (LogSubcaseEmailSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseEmailSetup Class
LogSubcaseEmailSetup Members


IsCommitmentToCustomer Property (LogSubcaseEmailSetup) | fcSDK Documentation

IsCommitmentToCustomer Property (LogSubcaseEmailSetup)

Specifies if the commitment is to the customer (True) or by the customer (False).

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsCommitmentToCustomer As Boolean

[PropertyBitValueAttribute()]
public bool IsCommitmentToCustomer {get; set;}

Remarks

Required if setting a Commitment.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseEmailSetup Class
LogSubcaseEmailSetup Members


LogDate Property (LogSubcaseEmailSetup) | fcSDK Documentation

LogDate Property (LogSubcaseEmailSetup)

DateTime the log was created. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LogDate As Date

[PropertyBitValueAttribute()]
public DateTime LogDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseEmailSetup Class
LogSubcaseEmailSetup Members


Message Property (LogSubcaseEmailSetup) | fcSDK Documentation

Message Property (LogSubcaseEmailSetup)

Email message.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Message As String

[PropertyBitValueAttribute()]
public string Message {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseEmailSetup Class
LogSubcaseEmailSetup Members


NewStatus Property (LogSubcaseEmailSetup) | fcSDK Documentation

NewStatus Property (LogSubcaseEmailSetup)

New status for the Subcase.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewStatus As String

[PropertyBitValueAttribute()]
public string NewStatus {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseEmailSetup Class
LogSubcaseEmailSetup Members


Recipient Property (LogSubcaseEmailSetup) | fcSDK Documentation

Recipient Property (LogSubcaseEmailSetup)

List of email addresses the email is sent to.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Recipient As String

[PropertyBitValueAttribute()]
public string Recipient {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseEmailSetup Class
LogSubcaseEmailSetup Members


SendEmail Property (LogSubcaseEmailSetup) | fcSDK Documentation

SendEmail Property (LogSubcaseEmailSetup)

Specifies if a timebomb be added to Clarify that will cause Rule Manager (if running) to send the email.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SendEmail As Boolean

[PropertyBitValueAttribute()]
public bool SendEmail {get; set;}

Remarks

If you set the send_email argument to True, the API will add a row to Clarify that will cause the rule manager (which must be running) to send the email. This is just like logging it via the Log Email GUI in Clarify. The downside of this is that rulemanager sends the email from the server, which means that the recipient(s) cannot hit "reply", and have the email come back to you.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseEmailSetup Class
LogSubcaseEmailSetup Members


SubcaseIDNum Property (LogSubcaseEmailSetup) | fcSDK Documentation

SubcaseIDNum Property (LogSubcaseEmailSetup)

Identifier of the Subcase against which the email is being logged.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SubcaseIDNum As String

[PropertyBitValueAttribute()]
public string SubcaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseEmailSetup Class
LogSubcaseEmailSetup Members


UserName Property (LogSubcaseEmailSetup) | fcSDK Documentation

UserName Property (LogSubcaseEmailSetup)

User who created the log. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseEmailSetup Class
LogSubcaseEmailSetup Members


LogSubcaseInternalNoteSetup Class | fcSDK Documentation

LogSubcaseInternalNoteSetup Class

Syntax

'Declaration

Public Class LogSubcaseInternalNoteSetup

public class LogSubcaseInternalNoteSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.LogSubcaseInternalNoteSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LogSubcaseInternalNoteSetup Members
FChoice.Toolkits.Clarify.Support Namespace


LogSubcaseInternalNoteSetup Class Members | fcSDK Documentation

LogSubcaseInternalNoteSetup Class Members

The following tables list the members exposed by LogSubcaseInternalNoteSetup.

Public Constructors

 | Name | Description
Public Constructor | LogSubcaseInternalNoteSetup Constructor |

Public Properties

 | Name | Description
Public Property | ActionType |
Public Property | AdditionalFields |
Public Property | CommitmentDueDate |
Public Property | CommitmentNotes |
Public Property | CommitmentPriorWarning |
Public Property | CommitmentTitle |
Public Property | GenerateTimeBombs |
Public Property | IsCommitmentToCustomer |
Public Property | LogDate |
Public Property | NewStatus |
Public Property | Notes |
Public Property | SubcaseIDNum |
Public Property | UserName |

Reference

LogSubcaseInternalNoteSetup Class
FChoice.Toolkits.Clarify.Support Namespace


LogSubcaseInternalNoteSetup Constructor | fcSDK Documentation

LogSubcaseInternalNoteSetup Constructor

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _subcaseIDNum_ As String _
)

[ConstructorIndexAttribute()]
public LogSubcaseInternalNoteSetup(
   string _subcaseIDNum_
)

Parameters

subcaseIDNum

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseInternalNoteSetup Class
LogSubcaseInternalNoteSetup Members


ActionType Property (LogSubcaseInternalNoteSetup) | fcSDK Documentation

ActionType Property (LogSubcaseInternalNoteSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ActionType As String

[PropertyBitValueAttribute()]
public string ActionType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseInternalNoteSetup Class
LogSubcaseInternalNoteSetup Members


AdditionalFields Property (LogSubcaseInternalNoteSetup) | fcSDK Documentation

AdditionalFields Property (LogSubcaseInternalNoteSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseInternalNoteSetup Class
LogSubcaseInternalNoteSetup Members


CommitmentDueDate Property (LogSubcaseInternalNoteSetup) | fcSDK Documentation

CommitmentDueDate Property (LogSubcaseInternalNoteSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentDueDate As Date

[PropertyBitValueAttribute()]
public DateTime CommitmentDueDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseInternalNoteSetup Class
LogSubcaseInternalNoteSetup Members


CommitmentNotes Property (LogSubcaseInternalNoteSetup) | fcSDK Documentation

CommitmentNotes Property (LogSubcaseInternalNoteSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentNotes As String

[PropertyBitValueAttribute()]
public string CommitmentNotes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseInternalNoteSetup Class
LogSubcaseInternalNoteSetup Members


CommitmentPriorWarning Property (LogSubcaseInternalNoteSetup) | fcSDK Documentation

CommitmentPriorWarning Property (LogSubcaseInternalNoteSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentPriorWarning As TimeSpan

[PropertyBitValueAttribute()]
public TimeSpan CommitmentPriorWarning {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseInternalNoteSetup Class
LogSubcaseInternalNoteSetup Members


CommitmentTitle Property (LogSubcaseInternalNoteSetup) | fcSDK Documentation

CommitmentTitle Property (LogSubcaseInternalNoteSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentTitle As String

[PropertyBitValueAttribute()]
public string CommitmentTitle {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseInternalNoteSetup Class
LogSubcaseInternalNoteSetup Members


GenerateTimeBombs Property (LogSubcaseInternalNoteSetup) | fcSDK Documentation

GenerateTimeBombs Property (LogSubcaseInternalNoteSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseInternalNoteSetup Class
LogSubcaseInternalNoteSetup Members


IsCommitmentToCustomer Property (LogSubcaseInternalNoteSetup) | fcSDK Documentation

IsCommitmentToCustomer Property (LogSubcaseInternalNoteSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsCommitmentToCustomer As Boolean

[PropertyBitValueAttribute()]
public bool IsCommitmentToCustomer {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseInternalNoteSetup Class
LogSubcaseInternalNoteSetup Members


LogDate Property (LogSubcaseInternalNoteSetup) | fcSDK Documentation

LogDate Property (LogSubcaseInternalNoteSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LogDate As Date

[PropertyBitValueAttribute()]
public DateTime LogDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseInternalNoteSetup Class
LogSubcaseInternalNoteSetup Members


NewStatus Property (LogSubcaseInternalNoteSetup) | fcSDK Documentation

NewStatus Property (LogSubcaseInternalNoteSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewStatus As String

[PropertyBitValueAttribute()]
public string NewStatus {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseInternalNoteSetup Class
LogSubcaseInternalNoteSetup Members


Notes Property (LogSubcaseInternalNoteSetup) | fcSDK Documentation

Notes Property (LogSubcaseInternalNoteSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseInternalNoteSetup Class
LogSubcaseInternalNoteSetup Members


SubcaseIDNum Property (LogSubcaseInternalNoteSetup) | fcSDK Documentation

SubcaseIDNum Property (LogSubcaseInternalNoteSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SubcaseIDNum As String

[PropertyBitValueAttribute()]
public string SubcaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseInternalNoteSetup Class
LogSubcaseInternalNoteSetup Members


UserName Property (LogSubcaseInternalNoteSetup) | fcSDK Documentation

UserName Property (LogSubcaseInternalNoteSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseInternalNoteSetup Class
LogSubcaseInternalNoteSetup Members


LogSubcaseInternalPhoneSetup Class | fcSDK Documentation

LogSubcaseInternalPhoneSetup Class

Syntax

'Declaration

Public Class LogSubcaseInternalPhoneSetup

public class LogSubcaseInternalPhoneSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.LogSubcaseInternalPhoneSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LogSubcaseInternalPhoneSetup Members
FChoice.Toolkits.Clarify.Support Namespace


LogSubcaseInternalPhoneSetup Class Members | fcSDK Documentation

LogSubcaseInternalPhoneSetup Class Members

The following tables list the members exposed by LogSubcaseInternalPhoneSetup.

Public Constructors

 | Name | Description
Public Constructor | LogSubcaseInternalPhoneSetup Constructor |

Public Properties

 | Name | Description
Public Property | ActionType |
Public Property | AdditionalFields |
Public Property | CommitmentDueDate |
Public Property | CommitmentNotes |
Public Property | CommitmentPriorWarning |
Public Property | CommitmentTitle |
Public Property | ContactFirstName |
Public Property | ContactLastName |
Public Property | ContactPhone |
Public Property | GenerateTimeBombs |
Public Property | IsCommitmentToCustomer |
Public Property | LogDate |
Public Property | LogEndDate |
Public Property | NewStatus |
Public Property | Notes |
Public Property | SubcaseIDNum |
Public Property | UserName |

Reference

LogSubcaseInternalPhoneSetup Class
FChoice.Toolkits.Clarify.Support Namespace


LogSubcaseInternalPhoneSetup Constructor | fcSDK Documentation

LogSubcaseInternalPhoneSetup Constructor

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _subcaseIDNum_ As String, _
   ByVal _contactFirstName_ As String, _
   ByVal _contactLastName_ As String, _
   ByVal _contactPhone_ As String _
)

[ConstructorIndexAttribute()]
public LogSubcaseInternalPhoneSetup(
   string _subcaseIDNum_,
   string _contactFirstName_,
   string _contactLastName_,
   string _contactPhone_
)

Parameters

subcaseIDNum

contactFirstName

contactLastName

contactPhone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseInternalPhoneSetup Class
LogSubcaseInternalPhoneSetup Members


ActionType Property (LogSubcaseInternalPhoneSetup) | fcSDK Documentation

ActionType Property (LogSubcaseInternalPhoneSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ActionType As String

[PropertyBitValueAttribute()]
public string ActionType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseInternalPhoneSetup Class
LogSubcaseInternalPhoneSetup Members


AdditionalFields Property (LogSubcaseInternalPhoneSetup) | fcSDK Documentation

AdditionalFields Property (LogSubcaseInternalPhoneSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseInternalPhoneSetup Class
LogSubcaseInternalPhoneSetup Members


CommitmentDueDate Property (LogSubcaseInternalPhoneSetup) | fcSDK Documentation

CommitmentDueDate Property (LogSubcaseInternalPhoneSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentDueDate As Date

[PropertyBitValueAttribute()]
public DateTime CommitmentDueDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseInternalPhoneSetup Class
LogSubcaseInternalPhoneSetup Members


CommitmentNotes Property (LogSubcaseInternalPhoneSetup) | fcSDK Documentation

CommitmentNotes Property (LogSubcaseInternalPhoneSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentNotes As String

[PropertyBitValueAttribute()]
public string CommitmentNotes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseInternalPhoneSetup Class
LogSubcaseInternalPhoneSetup Members


CommitmentPriorWarning Property (LogSubcaseInternalPhoneSetup) | fcSDK Documentation

CommitmentPriorWarning Property (LogSubcaseInternalPhoneSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentPriorWarning As TimeSpan

[PropertyBitValueAttribute()]
public TimeSpan CommitmentPriorWarning {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseInternalPhoneSetup Class
LogSubcaseInternalPhoneSetup Members


CommitmentTitle Property (LogSubcaseInternalPhoneSetup) | fcSDK Documentation

CommitmentTitle Property (LogSubcaseInternalPhoneSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentTitle As String

[PropertyBitValueAttribute()]
public string CommitmentTitle {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseInternalPhoneSetup Class
LogSubcaseInternalPhoneSetup Members


ContactFirstName Property (LogSubcaseInternalPhoneSetup) | fcSDK Documentation

ContactFirstName Property (LogSubcaseInternalPhoneSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactFirstName As String

[PropertyBitValueAttribute()]
public string ContactFirstName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseInternalPhoneSetup Class
LogSubcaseInternalPhoneSetup Members


ContactLastName Property (LogSubcaseInternalPhoneSetup) | fcSDK Documentation

ContactLastName Property (LogSubcaseInternalPhoneSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactLastName As String

[PropertyBitValueAttribute()]
public string ContactLastName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseInternalPhoneSetup Class
LogSubcaseInternalPhoneSetup Members


ContactPhone Property (LogSubcaseInternalPhoneSetup) | fcSDK Documentation

ContactPhone Property (LogSubcaseInternalPhoneSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactPhone As String

[PropertyBitValueAttribute()]
public string ContactPhone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseInternalPhoneSetup Class
LogSubcaseInternalPhoneSetup Members


GenerateTimeBombs Property (LogSubcaseInternalPhoneSetup) | fcSDK Documentation

GenerateTimeBombs Property (LogSubcaseInternalPhoneSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseInternalPhoneSetup Class
LogSubcaseInternalPhoneSetup Members


IsCommitmentToCustomer Property (LogSubcaseInternalPhoneSetup) | fcSDK Documentation

IsCommitmentToCustomer Property (LogSubcaseInternalPhoneSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsCommitmentToCustomer As Boolean

[PropertyBitValueAttribute()]
public bool IsCommitmentToCustomer {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseInternalPhoneSetup Class
LogSubcaseInternalPhoneSetup Members


LogDate Property (LogSubcaseInternalPhoneSetup) | fcSDK Documentation

LogDate Property (LogSubcaseInternalPhoneSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LogDate As Date

[PropertyBitValueAttribute()]
public DateTime LogDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseInternalPhoneSetup Class
LogSubcaseInternalPhoneSetup Members


LogEndDate Property (LogSubcaseInternalPhoneSetup) | fcSDK Documentation

LogEndDate Property (LogSubcaseInternalPhoneSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LogEndDate As Date

[PropertyBitValueAttribute()]
public DateTime LogEndDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseInternalPhoneSetup Class
LogSubcaseInternalPhoneSetup Members


NewStatus Property (LogSubcaseInternalPhoneSetup) | fcSDK Documentation

NewStatus Property (LogSubcaseInternalPhoneSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewStatus As String

[PropertyBitValueAttribute()]
public string NewStatus {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseInternalPhoneSetup Class
LogSubcaseInternalPhoneSetup Members


Notes Property (LogSubcaseInternalPhoneSetup) | fcSDK Documentation

Notes Property (LogSubcaseInternalPhoneSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseInternalPhoneSetup Class
LogSubcaseInternalPhoneSetup Members


SubcaseIDNum Property (LogSubcaseInternalPhoneSetup) | fcSDK Documentation

SubcaseIDNum Property (LogSubcaseInternalPhoneSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SubcaseIDNum As String

[PropertyBitValueAttribute()]
public string SubcaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseInternalPhoneSetup Class
LogSubcaseInternalPhoneSetup Members


UserName Property (LogSubcaseInternalPhoneSetup) | fcSDK Documentation

UserName Property (LogSubcaseInternalPhoneSetup)

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseInternalPhoneSetup Class
LogSubcaseInternalPhoneSetup Members


LogSubcaseNoteResult Class | fcSDK Documentation

LogSubcaseNoteResult Class

Result from the LogSubcaseNote API.

Syntax

'Declaration

Public Class LogSubcaseNoteResult
   Inherits FChoice.Toolkits.Clarify.ToolkitResult

public class LogSubcaseNoteResult : FChoice.Toolkits.Clarify.ToolkitResult

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.ToolkitResult
FChoice.Toolkits.Clarify.Support.LogSubcaseNoteResult

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LogSubcaseNoteResult Members
FChoice.Toolkits.Clarify.Support Namespace


LogSubcaseNoteResult Class Members | fcSDK Documentation

LogSubcaseNoteResult Class Members

The following tables list the members exposed by LogSubcaseNoteResult.

Public Constructors

 | Name | Description
Public Constructor | LogSubcaseNoteResult Constructor |

Public Properties

 | Name | Description
Public Property | CommitmentObjid | The Objid of the Commitment.
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | StatusChangeObjid | The Objid of the StatusChange.

Reference

LogSubcaseNoteResult Class
FChoice.Toolkits.Clarify.Support Namespace


LogSubcaseNoteResult Constructor | fcSDK Documentation

LogSubcaseNoteResult Constructor

Syntax

'Declaration

Public Function New()

public LogSubcaseNoteResult()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseNoteResult Class
LogSubcaseNoteResult Members


CommitmentObjid Property (LogSubcaseNoteResult) | fcSDK Documentation

CommitmentObjid Property (LogSubcaseNoteResult)

The Objid of the Commitment.

Syntax

'Declaration

Public Property CommitmentObjid As Integer

public int CommitmentObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseNoteResult Class
LogSubcaseNoteResult Members


StatusChangeObjid Property (LogSubcaseNoteResult) | fcSDK Documentation

StatusChangeObjid Property (LogSubcaseNoteResult)

The Objid of the StatusChange.

Syntax

'Declaration

Public Property StatusChangeObjid As Integer

public int StatusChangeObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseNoteResult Class
LogSubcaseNoteResult Members


LogSubcaseNoteSetup Class | fcSDK Documentation

LogSubcaseNoteSetup Class

Used by the LogSubcaseNote method as setup data for invocation.

Syntax

'Declaration

Public Class LogSubcaseNoteSetup

public class LogSubcaseNoteSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.LogSubcaseNoteSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LogSubcaseNoteSetup Members
FChoice.Toolkits.Clarify.Support Namespace
LogSubcaseNote(LogSubcaseNoteSetup) Method


LogSubcaseNoteSetup Class Members | fcSDK Documentation

LogSubcaseNoteSetup Class Members

The following tables list the members exposed by LogSubcaseNoteSetup.

Public Constructors

 | Name | Description
Public Constructor | LogSubcaseNoteSetup Constructor | Initializes a new instance of the LogSubcaseNoteSetup class.

Public Properties

 | Name | Description
Public Property | ActionType | Element from the 'Note Log Action Type' user defined list. If not set, the default list value is used.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CommitmentDueDate | The DateTime of when the commitment is due. If not set, the LogDate is used.
Public Property | CommitmentNotes | Notes for the commitment if one is being generated.
Public Property | CommitmentPriorWarning | The length of time preceding the commitment expiration in which the owner will be warned. If not set, no prior warning is given.
Public Property | CommitmentTitle | Title of the commitment.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | InternalUseOnlyNotes | Notes for internal use only.
Public Property | IsCommitmentToCustomer | Specifies if the commitment is to the customer (True) or by the customer (False).
Public Property | LogDate | DateTime the log was created. If not set, the current time is used.
Public Property | NewStatus | New status for the Subcase.
Public Property | Notes | Notes to be logged to the Subcase.
Public Property | SubcaseIDNum | Identifier of the Subcase against which the note is being logged.
Public Property | UserName | User who created the log. If not set, the session user is used.

Reference

LogSubcaseNoteSetup Class
FChoice.Toolkits.Clarify.Support Namespace
LogSubcaseNote(LogSubcaseNoteSetup) Method


LogSubcaseNoteSetup Constructor | fcSDK Documentation

LogSubcaseNoteSetup Constructor

Identifier of the Subcase against which the note is being logged.

Initializes a new instance of the LogSubcaseNoteSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _subcaseIDNum_ As String _
)

[ConstructorIndexAttribute()]
public LogSubcaseNoteSetup(
   string _subcaseIDNum_
)

Parameters

subcaseIDNum

Identifier of the Subcase against which the note is being logged.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseNoteSetup Class
LogSubcaseNoteSetup Members


ActionType Property (LogSubcaseNoteSetup) | fcSDK Documentation

ActionType Property (LogSubcaseNoteSetup)

Element from the 'Note Log Action Type' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ActionType As String

[PropertyBitValueAttribute()]
public string ActionType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseNoteSetup Class
LogSubcaseNoteSetup Members


AdditionalFields Property (LogSubcaseNoteSetup) | fcSDK Documentation

AdditionalFields Property (LogSubcaseNoteSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseNoteSetup Class
LogSubcaseNoteSetup Members


CommitmentDueDate Property (LogSubcaseNoteSetup) | fcSDK Documentation

CommitmentDueDate Property (LogSubcaseNoteSetup)

The DateTime of when the commitment is due. If not set, the LogDate is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentDueDate As Date

[PropertyBitValueAttribute()]
public DateTime CommitmentDueDate {get; set;}

Remarks

Required if setting a Commitment.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseNoteSetup Class
LogSubcaseNoteSetup Members


CommitmentNotes Property (LogSubcaseNoteSetup) | fcSDK Documentation

CommitmentNotes Property (LogSubcaseNoteSetup)

Notes for the commitment if one is being generated.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentNotes As String

[PropertyBitValueAttribute()]
public string CommitmentNotes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseNoteSetup Class
LogSubcaseNoteSetup Members


CommitmentPriorWarning Property (LogSubcaseNoteSetup) | fcSDK Documentation

CommitmentPriorWarning Property (LogSubcaseNoteSetup)

The length of time preceding the commitment expiration in which the owner will be warned. If not set, no prior warning is given.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentPriorWarning As TimeSpan

[PropertyBitValueAttribute()]
public TimeSpan CommitmentPriorWarning {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseNoteSetup Class
LogSubcaseNoteSetup Members


CommitmentTitle Property (LogSubcaseNoteSetup) | fcSDK Documentation

CommitmentTitle Property (LogSubcaseNoteSetup)

Title of the commitment.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentTitle As String

[PropertyBitValueAttribute()]
public string CommitmentTitle {get; set;}

Remarks

Required if setting a Commitment.

The Commitment title usually comes from and element in the user-defined list 'COMMITMENT', but this is not required.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseNoteSetup Class
LogSubcaseNoteSetup Members


GenerateTimeBombs Property (LogSubcaseNoteSetup) | fcSDK Documentation

GenerateTimeBombs Property (LogSubcaseNoteSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseNoteSetup Class
LogSubcaseNoteSetup Members


InternalUseOnlyNotes Property (LogSubcaseNoteSetup) | fcSDK Documentation

InternalUseOnlyNotes Property (LogSubcaseNoteSetup)

Notes for internal use only.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InternalUseOnlyNotes As String

[PropertyBitValueAttribute()]
public string InternalUseOnlyNotes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseNoteSetup Class
LogSubcaseNoteSetup Members


IsCommitmentToCustomer Property (LogSubcaseNoteSetup) | fcSDK Documentation

IsCommitmentToCustomer Property (LogSubcaseNoteSetup)

Specifies if the commitment is to the customer (True) or by the customer (False).

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsCommitmentToCustomer As Boolean

[PropertyBitValueAttribute()]
public bool IsCommitmentToCustomer {get; set;}

Remarks

Required if setting a Commitment.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseNoteSetup Class
LogSubcaseNoteSetup Members


LogDate Property (LogSubcaseNoteSetup) | fcSDK Documentation

LogDate Property (LogSubcaseNoteSetup)

DateTime the log was created. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LogDate As Date

[PropertyBitValueAttribute()]
public DateTime LogDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseNoteSetup Class
LogSubcaseNoteSetup Members


NewStatus Property (LogSubcaseNoteSetup) | fcSDK Documentation

NewStatus Property (LogSubcaseNoteSetup)

New status for the Subcase.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewStatus As String

[PropertyBitValueAttribute()]
public string NewStatus {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseNoteSetup Class
LogSubcaseNoteSetup Members


Notes Property (LogSubcaseNoteSetup) | fcSDK Documentation

Notes Property (LogSubcaseNoteSetup)

Notes to be logged to the Subcase.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseNoteSetup Class
LogSubcaseNoteSetup Members


SubcaseIDNum Property (LogSubcaseNoteSetup) | fcSDK Documentation

SubcaseIDNum Property (LogSubcaseNoteSetup)

Identifier of the Subcase against which the note is being logged.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SubcaseIDNum As String

[PropertyBitValueAttribute()]
public string SubcaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseNoteSetup Class
LogSubcaseNoteSetup Members


UserName Property (LogSubcaseNoteSetup) | fcSDK Documentation

UserName Property (LogSubcaseNoteSetup)

User who created the log. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseNoteSetup Class
LogSubcaseNoteSetup Members


LogSubcasePhoneResult Class | fcSDK Documentation

LogSubcasePhoneResult Class

Result from the LogSubcasePhone API.

Syntax

'Declaration

Public Class LogSubcasePhoneResult
   Inherits FChoice.Toolkits.Clarify.ToolkitResult

public class LogSubcasePhoneResult : FChoice.Toolkits.Clarify.ToolkitResult

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.ToolkitResult
FChoice.Toolkits.Clarify.Support.LogSubcasePhoneResult

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LogSubcasePhoneResult Members
FChoice.Toolkits.Clarify.Support Namespace


LogSubcasePhoneResult Class Members | fcSDK Documentation

LogSubcasePhoneResult Class Members

The following tables list the members exposed by LogSubcasePhoneResult.

Public Constructors

 | Name | Description
Public Constructor | LogSubcasePhoneResult Constructor |

Public Properties

 | Name | Description
Public Property | CommitmentObjid | The Objid of the Commitment.
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | StatusChangeObjid | The Objid of the StatusChange.

Reference

LogSubcasePhoneResult Class
FChoice.Toolkits.Clarify.Support Namespace


LogSubcasePhoneResult Constructor | fcSDK Documentation

LogSubcasePhoneResult Constructor

Syntax

'Declaration

Public Function New()

public LogSubcasePhoneResult()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcasePhoneResult Class
LogSubcasePhoneResult Members


CommitmentObjid Property (LogSubcasePhoneResult) | fcSDK Documentation

CommitmentObjid Property (LogSubcasePhoneResult)

The Objid of the Commitment.

Syntax

'Declaration

Public Property CommitmentObjid As Integer

public int CommitmentObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcasePhoneResult Class
LogSubcasePhoneResult Members


StatusChangeObjid Property (LogSubcasePhoneResult) | fcSDK Documentation

StatusChangeObjid Property (LogSubcasePhoneResult)

The Objid of the StatusChange.

Syntax

'Declaration

Public Property StatusChangeObjid As Integer

public int StatusChangeObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcasePhoneResult Class
LogSubcasePhoneResult Members


LogSubcasePhoneSetup Class | fcSDK Documentation

LogSubcasePhoneSetup Class

Used by the LogSubcasePhone method as setup data for invocation.

Syntax

'Declaration

Public Class LogSubcasePhoneSetup

public class LogSubcasePhoneSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.LogSubcasePhoneSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LogSubcasePhoneSetup Members
FChoice.Toolkits.Clarify.Support Namespace
LogSubcasePhone(LogSubcasePhoneSetup) Method


LogSubcasePhoneSetup Class Members | fcSDK Documentation

LogSubcasePhoneSetup Class Members

The following tables list the members exposed by LogSubcasePhoneSetup.

Public Constructors

 | Name | Description
Public Constructor | LogSubcasePhoneSetup Constructor | Initializes a new instance of the LogSubcasePhoneSetup class.

Public Properties

 | Name | Description
Public Property | ActionType | Element from the 'Phone Log Action Type' user defined list. If not set, the default list value is used.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CommitmentDueDate | The DateTime of when the commitment is due. If not set, the LogDate is used.
Public Property | CommitmentNotes | Notes for the commitment if one is being generated.
Public Property | CommitmentPriorWarning | The length of time preceding the commitment expiration in which the owner will be warned. If not set, no prior warning is given.
Public Property | CommitmentTitle | Title of the commitment.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | InternalUseOnlyNotes | Notes for internal use only.
Public Property | IsCommitmentToCustomer | Specifies if the commitment is to the customer (True) or by the customer (False).
Public Property | LogDate | DateTime the log was created. If not set, the current time is used.
Public Property | LogEndDate | The DateTime of the end of the phone call. If not set, the LogDate is used.
Public Property | NewStatus | New status for the Subcase.
Public Property | Notes | Notes to be logged to the Case.
Public Property | SubcaseIDNum | Identifier of the Subcase against which the phone note is being logged.
Public Property | UserName | User who created the log. If not set, the session user is used.

Reference

LogSubcasePhoneSetup Class
FChoice.Toolkits.Clarify.Support Namespace
LogSubcasePhone(LogSubcasePhoneSetup) Method


LogSubcasePhoneSetup Constructor | fcSDK Documentation

LogSubcasePhoneSetup Constructor

Identifier of the Subcase against which the phone note is being logged.

Contact's first name.

Contact's last name.

Contact's phone number.

Initializes a new instance of the LogSubcasePhoneSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _subcaseIDNum_ As String, _
   ByVal _contactFirstName_ As String, _
   ByVal _contactLastName_ As String, _
   ByVal _contactPhone_ As String _
)

[ConstructorIndexAttribute()]
public LogSubcasePhoneSetup(
   string _subcaseIDNum_,
   string _contactFirstName_,
   string _contactLastName_,
   string _contactPhone_
)

Parameters

subcaseIDNum

Identifier of the Subcase against which the phone note is being logged.

contactFirstName

Contact's first name.

contactLastName

Contact's last name.

contactPhone

Contact's phone number.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcasePhoneSetup Class
LogSubcasePhoneSetup Members


ActionType Property (LogSubcasePhoneSetup) | fcSDK Documentation

ActionType Property (LogSubcasePhoneSetup)

Element from the 'Phone Log Action Type' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ActionType As String

[PropertyBitValueAttribute()]
public string ActionType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcasePhoneSetup Class
LogSubcasePhoneSetup Members


AdditionalFields Property (LogSubcasePhoneSetup) | fcSDK Documentation

AdditionalFields Property (LogSubcasePhoneSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcasePhoneSetup Class
LogSubcasePhoneSetup Members


CommitmentDueDate Property (LogSubcasePhoneSetup) | fcSDK Documentation

CommitmentDueDate Property (LogSubcasePhoneSetup)

The DateTime of when the commitment is due. If not set, the LogDate is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentDueDate As Date

[PropertyBitValueAttribute()]
public DateTime CommitmentDueDate {get; set;}

Remarks

Required if setting a Commitment.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcasePhoneSetup Class
LogSubcasePhoneSetup Members


CommitmentNotes Property (LogSubcasePhoneSetup) | fcSDK Documentation

CommitmentNotes Property (LogSubcasePhoneSetup)

Notes for the commitment if one is being generated.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentNotes As String

[PropertyBitValueAttribute()]
public string CommitmentNotes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcasePhoneSetup Class
LogSubcasePhoneSetup Members


CommitmentPriorWarning Property (LogSubcasePhoneSetup) | fcSDK Documentation

CommitmentPriorWarning Property (LogSubcasePhoneSetup)

The length of time preceding the commitment expiration in which the owner will be warned. If not set, no prior warning is given.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentPriorWarning As TimeSpan

[PropertyBitValueAttribute()]
public TimeSpan CommitmentPriorWarning {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcasePhoneSetup Class
LogSubcasePhoneSetup Members


ContactFirstName Property (LogSubcasePhoneSetup) | fcSDK Documentation

ContactFirstName Property (LogSubcasePhoneSetup)

Contact's first name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactFirstName As String

[PropertyBitValueAttribute()]
public string ContactFirstName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcasePhoneSetup Class
LogSubcasePhoneSetup Members


ContactLastName Property (LogSubcasePhoneSetup) | fcSDK Documentation

ContactLastName Property (LogSubcasePhoneSetup)

Contact's last name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactLastName As String

[PropertyBitValueAttribute()]
public string ContactLastName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcasePhoneSetup Class
LogSubcasePhoneSetup Members


ContactPhone Property (LogSubcasePhoneSetup) | fcSDK Documentation

ContactPhone Property (LogSubcasePhoneSetup)

Contact's phone number.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactPhone As String

[PropertyBitValueAttribute()]
public string ContactPhone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcasePhoneSetup Class
LogSubcasePhoneSetup Members


GenerateTimeBombs Property (LogSubcasePhoneSetup) | fcSDK Documentation

GenerateTimeBombs Property (LogSubcasePhoneSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcasePhoneSetup Class
LogSubcasePhoneSetup Members


InternalUseOnlyNotes Property (LogSubcasePhoneSetup) | fcSDK Documentation

InternalUseOnlyNotes Property (LogSubcasePhoneSetup)

Notes for internal use only.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InternalUseOnlyNotes As String

[PropertyBitValueAttribute()]
public string InternalUseOnlyNotes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcasePhoneSetup Class
LogSubcasePhoneSetup Members


IsCommitmentToCustomer Property (LogSubcasePhoneSetup) | fcSDK Documentation

IsCommitmentToCustomer Property (LogSubcasePhoneSetup)

Specifies if the commitment is to the customer (True) or by the customer (False).

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsCommitmentToCustomer As Boolean

[PropertyBitValueAttribute()]
public bool IsCommitmentToCustomer {get; set;}

Remarks

Required if setting a Commitment.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcasePhoneSetup Class
LogSubcasePhoneSetup Members


LogDate Property (LogSubcasePhoneSetup) | fcSDK Documentation

LogDate Property (LogSubcasePhoneSetup)

DateTime the log was created. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LogDate As Date

[PropertyBitValueAttribute()]
public DateTime LogDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcasePhoneSetup Class
LogSubcasePhoneSetup Members


LogEndDate Property (LogSubcasePhoneSetup) | fcSDK Documentation

LogEndDate Property (LogSubcasePhoneSetup)

The DateTime of the end of the phone call. If not set, the LogDate is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LogEndDate As Date

[PropertyBitValueAttribute()]
public DateTime LogEndDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcasePhoneSetup Class
LogSubcasePhoneSetup Members


NewStatus Property (LogSubcasePhoneSetup) | fcSDK Documentation

NewStatus Property (LogSubcasePhoneSetup)

New status for the Subcase.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewStatus As String

[PropertyBitValueAttribute()]
public string NewStatus {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcasePhoneSetup Class
LogSubcasePhoneSetup Members


Notes Property (LogSubcasePhoneSetup) | fcSDK Documentation

Notes Property (LogSubcasePhoneSetup)

Notes to be logged to the Case.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcasePhoneSetup Class
LogSubcasePhoneSetup Members


SubcaseIDNum Property (LogSubcasePhoneSetup) | fcSDK Documentation

SubcaseIDNum Property (LogSubcasePhoneSetup)

Identifier of the Subcase against which the phone note is being logged.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SubcaseIDNum As String

[PropertyBitValueAttribute()]
public string SubcaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcasePhoneSetup Class
LogSubcasePhoneSetup Members


UserName Property (LogSubcasePhoneSetup) | fcSDK Documentation

UserName Property (LogSubcasePhoneSetup)

User who created the log. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcasePhoneSetup Class
LogSubcasePhoneSetup Members


LogSubcaseResearchResult Class | fcSDK Documentation

LogSubcaseResearchResult Class

Result from the LogSubcaseResearch API.

Syntax

'Declaration

Public Class LogSubcaseResearchResult
   Inherits FChoice.Toolkits.Clarify.ToolkitResult

public class LogSubcaseResearchResult : FChoice.Toolkits.Clarify.ToolkitResult

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.ToolkitResult
FChoice.Toolkits.Clarify.Support.LogSubcaseResearchResult

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LogSubcaseResearchResult Members
FChoice.Toolkits.Clarify.Support Namespace


LogSubcaseResearchResult Class Members | fcSDK Documentation

LogSubcaseResearchResult Class Members

The following tables list the members exposed by LogSubcaseResearchResult.

Public Constructors

 | Name | Description
Public Constructor | LogSubcaseResearchResult Constructor |

Public Properties

 | Name | Description
Public Property | CommitmentObjid | The Objid of the Commitment.
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | StatusChangeObjid | The Objid of the StatusChange.

Reference

LogSubcaseResearchResult Class
FChoice.Toolkits.Clarify.Support Namespace


LogSubcaseResearchResult Constructor | fcSDK Documentation

LogSubcaseResearchResult Constructor

Syntax

'Declaration

Public Function New()

public LogSubcaseResearchResult()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseResearchResult Class
LogSubcaseResearchResult Members


CommitmentObjid Property (LogSubcaseResearchResult) | fcSDK Documentation

CommitmentObjid Property (LogSubcaseResearchResult)

The Objid of the Commitment.

Syntax

'Declaration

Public Property CommitmentObjid As Integer

public int CommitmentObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseResearchResult Class
LogSubcaseResearchResult Members


StatusChangeObjid Property (LogSubcaseResearchResult) | fcSDK Documentation

StatusChangeObjid Property (LogSubcaseResearchResult)

The Objid of the StatusChange.

Syntax

'Declaration

Public Property StatusChangeObjid As Integer

public int StatusChangeObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseResearchResult Class
LogSubcaseResearchResult Members


LogSubcaseResearchSetup Class | fcSDK Documentation

LogSubcaseResearchSetup Class

Used by the LogSubcaseResearch method as setup data for invocation.

Syntax

'Declaration

Public Class LogSubcaseResearchSetup

public class LogSubcaseResearchSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.LogSubcaseResearchSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

LogSubcaseResearchSetup Members
FChoice.Toolkits.Clarify.Support Namespace
LogSubcaseResearch(LogSubcaseResearchSetup) Method


LogSubcaseResearchSetup Class Members | fcSDK Documentation

LogSubcaseResearchSetup Class Members

The following tables list the members exposed by LogSubcaseResearchSetup.

Public Constructors

 | Name | Description
Public Constructor | LogSubcaseResearchSetup Constructor | Initializes a new instance of the LogSubcaseResearchSetup class.

Public Properties

 | Name | Description
Public Property | ActionType | Element from the 'Research Log Action Type' user defined list. If not set, the default list value is used.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CommitmentDueDate | The DateTime of when the commitment is due. If not set, the LogDate is used.
Public Property | CommitmentNotes | Notes for the commitment if one is being generated.
Public Property | CommitmentPriorWarning | The length of time preceding the commitment expiration in which the owner will be warned. If not set, no prior warning is given.
Public Property | CommitmentTitle | Title of the commitment.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | InternalUseOnlyNotes | Notes for internal use only.
Public Property | IsCommitmentToCustomer | Specifies if the commitment is to the customer (True) or by the customer (False).
Public Property | LogDate | DateTime the log was created. If not set, the current time is used.
Public Property | NewStatus | New status for the Subcase.
Public Property | Notes | Notes to be logged to the Subcase.
Public Property | ResearchDuration | The length of time for research.
Public Property | SubcaseIDNum | Identifier of the Subcase against which the research note is being logged.
Public Property | UserName | User who created the log. If not set, the session user is used.

Reference

LogSubcaseResearchSetup Class
FChoice.Toolkits.Clarify.Support Namespace
LogSubcaseResearch(LogSubcaseResearchSetup) Method


LogSubcaseResearchSetup Constructor | fcSDK Documentation

LogSubcaseResearchSetup Constructor

Identifier of the Subcase against which the research note is being logged.

The length of time for research.

Initializes a new instance of the LogSubcaseResearchSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _subcaseIDNum_ As String, _
   ByVal _researchDuration_ As TimeSpan _
)

[ConstructorIndexAttribute()]
public LogSubcaseResearchSetup(
   string _subcaseIDNum_,
   TimeSpan _researchDuration_
)

Parameters

subcaseIDNum

Identifier of the Subcase against which the research note is being logged.

researchDuration

The length of time for research.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseResearchSetup Class
LogSubcaseResearchSetup Members


ActionType Property (LogSubcaseResearchSetup) | fcSDK Documentation

ActionType Property (LogSubcaseResearchSetup)

Element from the 'Research Log Action Type' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ActionType As String

[PropertyBitValueAttribute()]
public string ActionType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseResearchSetup Class
LogSubcaseResearchSetup Members


AdditionalFields Property (LogSubcaseResearchSetup) | fcSDK Documentation

AdditionalFields Property (LogSubcaseResearchSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseResearchSetup Class
LogSubcaseResearchSetup Members


CommitmentDueDate Property (LogSubcaseResearchSetup) | fcSDK Documentation

CommitmentDueDate Property (LogSubcaseResearchSetup)

The DateTime of when the commitment is due. If not set, the LogDate is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentDueDate As Date

[PropertyBitValueAttribute()]
public DateTime CommitmentDueDate {get; set;}

Remarks

Required if setting a Commitment.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseResearchSetup Class
LogSubcaseResearchSetup Members


CommitmentNotes Property (LogSubcaseResearchSetup) | fcSDK Documentation

CommitmentNotes Property (LogSubcaseResearchSetup)

Notes for the commitment if one is being generated.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentNotes As String

[PropertyBitValueAttribute()]
public string CommitmentNotes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseResearchSetup Class
LogSubcaseResearchSetup Members


CommitmentPriorWarning Property (LogSubcaseResearchSetup) | fcSDK Documentation

CommitmentPriorWarning Property (LogSubcaseResearchSetup)

The length of time preceding the commitment expiration in which the owner will be warned. If not set, no prior warning is given.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentPriorWarning As TimeSpan

[PropertyBitValueAttribute()]
public TimeSpan CommitmentPriorWarning {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseResearchSetup Class
LogSubcaseResearchSetup Members


CommitmentTitle Property (LogSubcaseResearchSetup) | fcSDK Documentation

CommitmentTitle Property (LogSubcaseResearchSetup)

Title of the commitment.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentTitle As String

[PropertyBitValueAttribute()]
public string CommitmentTitle {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseResearchSetup Class
LogSubcaseResearchSetup Members


GenerateTimeBombs Property (LogSubcaseResearchSetup) | fcSDK Documentation

GenerateTimeBombs Property (LogSubcaseResearchSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseResearchSetup Class
LogSubcaseResearchSetup Members


InternalUseOnlyNotes Property (LogSubcaseResearchSetup) | fcSDK Documentation

InternalUseOnlyNotes Property (LogSubcaseResearchSetup)

Notes for internal use only.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property InternalUseOnlyNotes As String

[PropertyBitValueAttribute()]
public string InternalUseOnlyNotes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseResearchSetup Class
LogSubcaseResearchSetup Members


IsCommitmentToCustomer Property (LogSubcaseResearchSetup) | fcSDK Documentation

IsCommitmentToCustomer Property (LogSubcaseResearchSetup)

Specifies if the commitment is to the customer (True) or by the customer (False).

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsCommitmentToCustomer As Boolean

[PropertyBitValueAttribute()]
public bool IsCommitmentToCustomer {get; set;}

Remarks

Required if setting a Commitment.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseResearchSetup Class
LogSubcaseResearchSetup Members


LogDate Property (LogSubcaseResearchSetup) | fcSDK Documentation

LogDate Property (LogSubcaseResearchSetup)

DateTime the log was created. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property LogDate As Date

[PropertyBitValueAttribute()]
public DateTime LogDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseResearchSetup Class
LogSubcaseResearchSetup Members


NewStatus Property (LogSubcaseResearchSetup) | fcSDK Documentation

NewStatus Property (LogSubcaseResearchSetup)

New status for the Subcase.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewStatus As String

[PropertyBitValueAttribute()]
public string NewStatus {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseResearchSetup Class
LogSubcaseResearchSetup Members


Notes Property (LogSubcaseResearchSetup) | fcSDK Documentation

Notes Property (LogSubcaseResearchSetup)

Notes to be logged to the Subcase.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseResearchSetup Class
LogSubcaseResearchSetup Members


ResearchDuration Property (LogSubcaseResearchSetup) | fcSDK Documentation

ResearchDuration Property (LogSubcaseResearchSetup)

The length of time for research.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ResearchDuration As TimeSpan

[PropertyBitValueAttribute()]
public TimeSpan ResearchDuration {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseResearchSetup Class
LogSubcaseResearchSetup Members


SubcaseIDNum Property (LogSubcaseResearchSetup) | fcSDK Documentation

SubcaseIDNum Property (LogSubcaseResearchSetup)

Identifier of the Subcase against which the research note is being logged.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SubcaseIDNum As String

[PropertyBitValueAttribute()]
public string SubcaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseResearchSetup Class
LogSubcaseResearchSetup Members


UserName Property (LogSubcaseResearchSetup) | fcSDK Documentation

UserName Property (LogSubcaseResearchSetup)

User who created the log. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseResearchSetup Class
LogSubcaseResearchSetup Members


MoveCaseSetup Class | fcSDK Documentation

MoveCaseSetup Class

Used by the MoveCase method as setup data for invocation.

Syntax

'Declaration

Public Class MoveCaseSetup

public class MoveCaseSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.MoveCaseSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

MoveCaseSetup Members
FChoice.Toolkits.Clarify.Support Namespace
MoveCase(MoveCaseSetup) Method


MoveCaseSetup Class Members | fcSDK Documentation

MoveCaseSetup Class Members

The following tables list the members exposed by MoveCaseSetup.

Public Constructors

 | Name | Description
Public Constructor | MoveCaseSetup Constructor | Initializes a new instance of the MoveCaseSetup class.

Public Properties

 | Name | Description
Public Property | CaseIDNum | Case Identifier.
Public Property | NewWipBin | The new WipBin into which the Case is to be moved.

Reference

MoveCaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
MoveCase(MoveCaseSetup) Method


MoveCaseSetup Constructor | fcSDK Documentation

MoveCaseSetup Constructor

Case Identifier.

The new WipBin into which the Case is to be moved.

Initializes a new instance of the MoveCaseSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _caseIDNum_ As String, _
   ByVal _newWipBin_ As String _
)

[ConstructorIndexAttribute()]
public MoveCaseSetup(
   string _caseIDNum_,
   string _newWipBin_
)

Parameters

caseIDNum

Case Identifier.

newWipBin

The new WipBin into which the Case is to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveCaseSetup Class
MoveCaseSetup Members


CaseIDNum Property (MoveCaseSetup) | fcSDK Documentation

CaseIDNum Property (MoveCaseSetup)

Case Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveCaseSetup Class
MoveCaseSetup Members


NewWipBin Property (MoveCaseSetup) | fcSDK Documentation

NewWipBin Property (MoveCaseSetup)

The new WipBin into which the Case is to be moved.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewWipBin As String

[PropertyBitValueAttribute()]
public string NewWipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveCaseSetup Class
MoveCaseSetup Members


MoveSubcaseSetup Class | fcSDK Documentation

MoveSubcaseSetup Class

Used by the MoveSubcase method as setup data for invocation.

Syntax

'Declaration

Public Class MoveSubcaseSetup

public class MoveSubcaseSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.MoveSubcaseSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

MoveSubcaseSetup Members
FChoice.Toolkits.Clarify.Support Namespace
MoveSubcase(MoveSubcaseSetup) Method


MoveSubcaseSetup Class Members | fcSDK Documentation

MoveSubcaseSetup Class Members

The following tables list the members exposed by MoveSubcaseSetup.

Public Constructors

 | Name | Description
Public Constructor | MoveSubcaseSetup Constructor | Initializes a new instance of the MoveSubcaseSetup class.

Public Properties

 | Name | Description
Public Property | NewWipBin | The new WipBin into which the Subcase is to be moved.
Public Property | SubcaseIDNum | Subcase Identifier.

Reference

MoveSubcaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
MoveSubcase(MoveSubcaseSetup) Method


MoveSubcaseSetup Constructor | fcSDK Documentation

MoveSubcaseSetup Constructor

Subcase Identifier.

The new WipBin into which the Subcase is to be moved.

Initializes a new instance of the MoveSubcaseSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _subcaseIDNum_ As String, _
   ByVal _newWipBin_ As String _
)

[ConstructorIndexAttribute()]
public MoveSubcaseSetup(
   string _subcaseIDNum_,
   string _newWipBin_
)

Parameters

subcaseIDNum

Subcase Identifier.

newWipBin

The new WipBin into which the Subcase is to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSubcaseSetup Class
MoveSubcaseSetup Members


NewWipBin Property (MoveSubcaseSetup) | fcSDK Documentation

NewWipBin Property (MoveSubcaseSetup)

The new WipBin into which the Subcase is to be moved.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property NewWipBin As String

[PropertyBitValueAttribute()]
public string NewWipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSubcaseSetup Class
MoveSubcaseSetup Members


SubcaseIDNum Property (MoveSubcaseSetup) | fcSDK Documentation

SubcaseIDNum Property (MoveSubcaseSetup)

Subcase Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SubcaseIDNum As String

[PropertyBitValueAttribute()]
public string SubcaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

MoveSubcaseSetup Class
MoveSubcaseSetup Members


RejectCaseSetup Class | fcSDK Documentation

RejectCaseSetup Class

Used by the RejectCase method as setup data for invocation.

Syntax

'Declaration

Public Class RejectCaseSetup

public class RejectCaseSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.RejectCaseSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

RejectCaseSetup Members
FChoice.Toolkits.Clarify.Support Namespace
RejectCase(RejectCaseSetup) Method


RejectCaseSetup Class Members | fcSDK Documentation

RejectCaseSetup Class Members

The following tables list the members exposed by RejectCaseSetup.

Public Constructors

 | Name | Description
Public Constructor | RejectCaseSetup Constructor | Initializes a new instance of the RejectCaseSetup class.

Public Properties

 | Name | Description
Public Property | CaseIDNum | Case Identifier.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Notes | The reason the Case was rejected from the queue into which it was dispatched.
Public Property | RejectDate | DateTime the Case was rejected. If not set, the current time is used.
Public Property | UserName | The user who has rejected the Case. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Case. If not set, the UserName's default is used.

Reference

RejectCaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
RejectCase(RejectCaseSetup) Method


RejectCaseSetup Constructor | fcSDK Documentation

RejectCaseSetup Constructor

Case Identifier.

Initializes a new instance of the RejectCaseSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _caseIDNum_ As String _
)

[ConstructorIndexAttribute()]
public RejectCaseSetup(
   string _caseIDNum_
)

Parameters

caseIDNum

Case Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectCaseSetup Class
RejectCaseSetup Members


CaseIDNum Property (RejectCaseSetup) | fcSDK Documentation

CaseIDNum Property (RejectCaseSetup)

Case Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectCaseSetup Class
RejectCaseSetup Members


GenerateTimeBombs Property (RejectCaseSetup) | fcSDK Documentation

GenerateTimeBombs Property (RejectCaseSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectCaseSetup Class
RejectCaseSetup Members


Notes Property (RejectCaseSetup) | fcSDK Documentation

Notes Property (RejectCaseSetup)

The reason the Case was rejected from the queue into which it was dispatched.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectCaseSetup Class
RejectCaseSetup Members


RejectDate Property (RejectCaseSetup) | fcSDK Documentation

RejectDate Property (RejectCaseSetup)

DateTime the Case was rejected. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property RejectDate As Date

[PropertyBitValueAttribute()]
public DateTime RejectDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectCaseSetup Class
RejectCaseSetup Members


UserName Property (RejectCaseSetup) | fcSDK Documentation

UserName Property (RejectCaseSetup)

The user who has rejected the Case. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectCaseSetup Class
RejectCaseSetup Members


WipBin Property (RejectCaseSetup) | fcSDK Documentation

WipBin Property (RejectCaseSetup)

User's WipBin in which to place the Case. If not set, the UserName's default is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectCaseSetup Class
RejectCaseSetup Members


RejectSubcaseSetup Class | fcSDK Documentation

RejectSubcaseSetup Class

Used by the RejectSubcase method as setup data for invocation.

Syntax

'Declaration

Public Class RejectSubcaseSetup

public class RejectSubcaseSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.RejectSubcaseSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

RejectSubcaseSetup Members
FChoice.Toolkits.Clarify.Support Namespace
RejectSubcase(RejectSubcaseSetup) Method


RejectSubcaseSetup Class Members | fcSDK Documentation

RejectSubcaseSetup Class Members

The following tables list the members exposed by RejectSubcaseSetup.

Public Constructors

 | Name | Description
Public Constructor | RejectSubcaseSetup Constructor | Initializes a new instance of the RejectSubcaseSetup class.

Public Properties

 | Name | Description
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Notes | The reason the Subcase was rejected from the queue into which it was dispatched.
Public Property | RejectDate | DateTime the Subcase was rejected. If not set, the current time is used.
Public Property | SubcaseIDNum | Subcase Identifier.
Public Property | UserName | The user who has rejected the Subcase. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Subcase. If not set, the UserName's default is used.

Reference

RejectSubcaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
RejectSubcase(RejectSubcaseSetup) Method


RejectSubcaseSetup Constructor | fcSDK Documentation

RejectSubcaseSetup Constructor

Subcase Identifier.

Initializes a new instance of the RejectSubcaseSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _subcaseIDNum_ As String _
)

[ConstructorIndexAttribute()]
public RejectSubcaseSetup(
   string _subcaseIDNum_
)

Parameters

subcaseIDNum

Subcase Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectSubcaseSetup Class
RejectSubcaseSetup Members


GenerateTimeBombs Property (RejectSubcaseSetup) | fcSDK Documentation

GenerateTimeBombs Property (RejectSubcaseSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectSubcaseSetup Class
RejectSubcaseSetup Members


Notes Property (RejectSubcaseSetup) | fcSDK Documentation

Notes Property (RejectSubcaseSetup)

The reason the Subcase was rejected from the queue into which it was dispatched.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectSubcaseSetup Class
RejectSubcaseSetup Members


RejectDate Property (RejectSubcaseSetup) | fcSDK Documentation

RejectDate Property (RejectSubcaseSetup)

DateTime the Subcase was rejected. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property RejectDate As Date

[PropertyBitValueAttribute()]
public DateTime RejectDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectSubcaseSetup Class
RejectSubcaseSetup Members


SubcaseIDNum Property (RejectSubcaseSetup) | fcSDK Documentation

SubcaseIDNum Property (RejectSubcaseSetup)

Subcase Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SubcaseIDNum As String

[PropertyBitValueAttribute()]
public string SubcaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectSubcaseSetup Class
RejectSubcaseSetup Members


UserName Property (RejectSubcaseSetup) | fcSDK Documentation

UserName Property (RejectSubcaseSetup)

The user who has rejected the Subcase. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectSubcaseSetup Class
RejectSubcaseSetup Members


WipBin Property (RejectSubcaseSetup) | fcSDK Documentation

WipBin Property (RejectSubcaseSetup)

User's WipBin in which to place the Subcase. If not set, the UserName's default is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RejectSubcaseSetup Class
RejectSubcaseSetup Members


RelateCaseToParentCaseSetup Class | fcSDK Documentation

RelateCaseToParentCaseSetup Class

Used by the RelateCaseToParentCase method as setup data for invocation.

Syntax

'Declaration

Public Class RelateCaseToParentCaseSetup

public class RelateCaseToParentCaseSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.RelateCaseToParentCaseSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

RelateCaseToParentCaseSetup Members
FChoice.Toolkits.Clarify.Support Namespace
RelateCaseToParentCase(RelateCaseToParentCaseSetup) Method


RelateCaseToParentCaseSetup Class Members | fcSDK Documentation

RelateCaseToParentCaseSetup Class Members

The following tables list the members exposed by RelateCaseToParentCaseSetup.

Public Constructors

 | Name | Description
Public Constructor | RelateCaseToParentCaseSetup Constructor | Initializes a new instance of the RelateCaseToParentCaseSetup class.

Public Properties

 | Name | Description
Public Property | CaseIDNum | Identifier of the child Case in the relation.
Public Property | ParentCaseIDNum | Identifier of a oarent Case in the relation.

Reference

RelateCaseToParentCaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
RelateCaseToParentCase(RelateCaseToParentCaseSetup) Method


RelateCaseToParentCaseSetup Constructor | fcSDK Documentation

RelateCaseToParentCaseSetup Constructor

Identifier of the child Case in the relation.

Identifier of a oarent Case in the relation.

Initializes a new instance of the RelateCaseToParentCaseSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _caseIDNum_ As String, _
   ByVal _parentCaseIDNum_ As String _
)

[ConstructorIndexAttribute()]
public RelateCaseToParentCaseSetup(
   string _caseIDNum_,
   string _parentCaseIDNum_
)

Parameters

caseIDNum

Identifier of the child Case in the relation.

parentCaseIDNum

Identifier of a oarent Case in the relation.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RelateCaseToParentCaseSetup Class
RelateCaseToParentCaseSetup Members


CaseIDNum Property (RelateCaseToParentCaseSetup) | fcSDK Documentation

CaseIDNum Property (RelateCaseToParentCaseSetup)

Identifier of the child Case in the relation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RelateCaseToParentCaseSetup Class
RelateCaseToParentCaseSetup Members


ParentCaseIDNum Property | fcSDK Documentation

ParentCaseIDNum Property

Identifier of a oarent Case in the relation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ParentCaseIDNum As String

[PropertyBitValueAttribute()]
public string ParentCaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

RelateCaseToParentCaseSetup Class
RelateCaseToParentCaseSetup Members


ReopenCaseSetup Class | fcSDK Documentation

ReopenCaseSetup Class

Used by the ReopenCase method as setup data for invocation.

Syntax

'Declaration

Public Class ReopenCaseSetup

public class ReopenCaseSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.ReopenCaseSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ReopenCaseSetup Members
FChoice.Toolkits.Clarify.Support Namespace
ReopenCase(ReopenCaseSetup) Method


ReopenCaseSetup Class Members | fcSDK Documentation

ReopenCaseSetup Class Members

The following tables list the members exposed by ReopenCaseSetup.

Public Constructors

 | Name | Description
Public Constructor | ReopenCaseSetup Constructor | Initializes a new instance of the ReopenCaseSetup class.

Public Properties

 | Name | Description
Public Property | CaseIDNum | Identifier of the Case being reopened.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | ReopenDate | DateTime the Case was reopened. If not set, the current time is used.
Public Property | Status | New status for the Case. If not set, the default status for 'Open' condition is used.
Public Property | UserName | User who reopened the Case. If not set, the session user is used.
Public Property | WipBin | WipBin to place the Case in. If not set, the users default WibBin is used.

Reference

ReopenCaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
ReopenCase(ReopenCaseSetup) Method


ReopenCaseSetup Constructor | fcSDK Documentation

ReopenCaseSetup Constructor

Identifier of the Case being reopened.

Initializes a new instance of the ReopenCaseSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _caseIDNum_ As String _
)

[ConstructorIndexAttribute()]
public ReopenCaseSetup(
   string _caseIDNum_
)

Parameters

caseIDNum

Identifier of the Case being reopened.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenCaseSetup Class
ReopenCaseSetup Members


CaseIDNum Property (ReopenCaseSetup) | fcSDK Documentation

CaseIDNum Property (ReopenCaseSetup)

Identifier of the Case being reopened.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenCaseSetup Class
ReopenCaseSetup Members


GenerateTimeBombs Property (ReopenCaseSetup) | fcSDK Documentation

GenerateTimeBombs Property (ReopenCaseSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenCaseSetup Class
ReopenCaseSetup Members


ReopenDate Property (ReopenCaseSetup) | fcSDK Documentation

ReopenDate Property (ReopenCaseSetup)

DateTime the Case was reopened. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ReopenDate As Date

[PropertyBitValueAttribute()]
public DateTime ReopenDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenCaseSetup Class
ReopenCaseSetup Members


Status Property (ReopenCaseSetup) | fcSDK Documentation

Status Property (ReopenCaseSetup)

New status for the Case. If not set, the default status for 'Open' condition is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Status As String

[PropertyBitValueAttribute()]
public string Status {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenCaseSetup Class
ReopenCaseSetup Members


UserName Property (ReopenCaseSetup) | fcSDK Documentation

UserName Property (ReopenCaseSetup)

User who reopened the Case. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenCaseSetup Class
ReopenCaseSetup Members


WipBin Property (ReopenCaseSetup) | fcSDK Documentation

WipBin Property (ReopenCaseSetup)

WipBin to place the Case in. If not set, the users default WibBin is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenCaseSetup Class
ReopenCaseSetup Members


ReopenSubcaseSetup Class | fcSDK Documentation

ReopenSubcaseSetup Class

Used by the ReopenSubcase method as setup data for invocation.

Syntax

'Declaration

Public Class ReopenSubcaseSetup

public class ReopenSubcaseSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.ReopenSubcaseSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

ReopenSubcaseSetup Members
FChoice.Toolkits.Clarify.Support Namespace
ReopenSubcase(ReopenSubcaseSetup) Method


ReopenSubcaseSetup Class Members | fcSDK Documentation

ReopenSubcaseSetup Class Members

The following tables list the members exposed by ReopenSubcaseSetup.

Public Constructors

 | Name | Description
Public Constructor | ReopenSubcaseSetup Constructor | Initializes a new instance of the ReopenSubcaseSetup class.

Public Properties

 | Name | Description
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | ReopenDate | DateTime the Subcase was Reopen. If not set, the current time is used.
Public Property | Status | New status for the Subcase. If not set, the default status for Open Condition is used.
Public Property | SubcaseIDNum | Identifier of the Subcase being reopened.
Public Property | UserName | The User who rejected the Subcase. If not set, the session user is used.
Public Property | WipBin | WipBin to place the Subcase in. If not set, the users default WibBin is used.

Reference

ReopenSubcaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
ReopenSubcase(ReopenSubcaseSetup) Method


ReopenSubcaseSetup Constructor | fcSDK Documentation

ReopenSubcaseSetup Constructor

Identifier of the Subcase being reopened.

Initializes a new instance of the ReopenSubcaseSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _subcaseIDNum_ As String _
)

[ConstructorIndexAttribute()]
public ReopenSubcaseSetup(
   string _subcaseIDNum_
)

Parameters

subcaseIDNum

Identifier of the Subcase being reopened.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenSubcaseSetup Class
ReopenSubcaseSetup Members


GenerateTimeBombs Property (ReopenSubcaseSetup) | fcSDK Documentation

GenerateTimeBombs Property (ReopenSubcaseSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenSubcaseSetup Class
ReopenSubcaseSetup Members


ReopenDate Property (ReopenSubcaseSetup) | fcSDK Documentation

ReopenDate Property (ReopenSubcaseSetup)

DateTime the Subcase was Reopen. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ReopenDate As Date

[PropertyBitValueAttribute()]
public DateTime ReopenDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenSubcaseSetup Class
ReopenSubcaseSetup Members


Status Property (ReopenSubcaseSetup) | fcSDK Documentation

Status Property (ReopenSubcaseSetup)

New status for the Subcase. If not set, the default status for Open Condition is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Status As String

[PropertyBitValueAttribute()]
public string Status {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenSubcaseSetup Class
ReopenSubcaseSetup Members


SubcaseIDNum Property (ReopenSubcaseSetup) | fcSDK Documentation

SubcaseIDNum Property (ReopenSubcaseSetup)

Identifier of the Subcase being reopened.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SubcaseIDNum As String

[PropertyBitValueAttribute()]
public string SubcaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenSubcaseSetup Class
ReopenSubcaseSetup Members


UserName Property (ReopenSubcaseSetup) | fcSDK Documentation

UserName Property (ReopenSubcaseSetup)

The User who rejected the Subcase. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenSubcaseSetup Class
ReopenSubcaseSetup Members


WipBin Property (ReopenSubcaseSetup) | fcSDK Documentation

WipBin Property (ReopenSubcaseSetup)

WipBin to place the Subcase in. If not set, the users default WibBin is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ReopenSubcaseSetup Class
ReopenSubcaseSetup Members


SubcaseTimeAndExpenses Class | fcSDK Documentation

SubcaseTimeAndExpenses Class

Holds summary totals from the PrecloseSubcase API.

Syntax

'Declaration

Public Class SubcaseTimeAndExpenses

public class SubcaseTimeAndExpenses

Inheritance Hierarchy

System.Object FChoice.Toolkits.Clarify.Support.SubcaseTimeAndExpenses

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

SubcaseTimeAndExpenses Members FChoice.Toolkits.Clarify.Support Namespace FChoice.Toolkits.Clarify.Support.SubcaseTimeAndExpenses

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

SubcaseTimeAndExpenses Members FChoice.Toolkits.Clarify.Support Namespace


SubcaseTimeAndExpenses Class Members | fcSDK Documentation

SubcaseTimeAndExpenses Class Members

The following tables list the members exposed by SubcaseTimeAndExpenses.

Public Constructors

 | Name | Description
Public Constructor | SubcaseTimeAndExpenses Constructor |

Public Properties

 | Name | Description
Public Property | CapturedPhoneTime | Captured phone time.
Public Property | CapturedResearchTime | Captured research time.
Public Property | TotalBillableExpenses | Captured billable expenses.
Public Property | TotalBillableTime | Captured billable time.
Public Property | TotalNonBillableExpenses | Captured non-billable expenses.
Public Property | TotalNonBillableTime | Captured non-billable time.

Reference

SubcaseTimeAndExpenses Class
FChoice.Toolkits.Clarify.Support Namespace


SubcaseTimeAndExpenses Constructor | fcSDK Documentation

SubcaseTimeAndExpenses Constructor

Syntax

'Declaration

Public Function New()

public SubcaseTimeAndExpenses()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SubcaseTimeAndExpenses Class
SubcaseTimeAndExpenses Members


CapturedPhoneTime Property | fcSDK Documentation

CapturedPhoneTime Property

Captured phone time.

Syntax

'Declaration

Public Property CapturedPhoneTime As TimeSpan

public TimeSpan CapturedPhoneTime {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SubcaseTimeAndExpenses Class
SubcaseTimeAndExpenses Members


CapturedResearchTime Property | fcSDK Documentation

CapturedResearchTime Property

Captured research time.

Syntax

'Declaration

Public Property CapturedResearchTime As TimeSpan

public TimeSpan CapturedResearchTime {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SubcaseTimeAndExpenses Class
SubcaseTimeAndExpenses Members


TotalBillableExpenses Property (SubcaseTimeAndExpenses) | fcSDK Documentation

TotalBillableExpenses Property (SubcaseTimeAndExpenses)

Captured billable expenses.

Syntax

'Declaration

Public Property TotalBillableExpenses As Decimal

public decimal TotalBillableExpenses {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SubcaseTimeAndExpenses Class
SubcaseTimeAndExpenses Members


TotalBillableTime Property (SubcaseTimeAndExpenses) | fcSDK Documentation

TotalBillableTime Property (SubcaseTimeAndExpenses)

Captured billable time.

Syntax

'Declaration

Public Property TotalBillableTime As TimeSpan

public TimeSpan TotalBillableTime {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SubcaseTimeAndExpenses Class
SubcaseTimeAndExpenses Members


TotalNonBillableExpenses Property (SubcaseTimeAndExpenses) | fcSDK Documentation

TotalNonBillableExpenses Property (SubcaseTimeAndExpenses)

Captured non-billable expenses.

Syntax

'Declaration

Public Property TotalNonBillableExpenses As Decimal

public decimal TotalNonBillableExpenses {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SubcaseTimeAndExpenses Class
SubcaseTimeAndExpenses Members


TotalNonBillableTime Property (SubcaseTimeAndExpenses) | fcSDK Documentation

TotalNonBillableTime Property (SubcaseTimeAndExpenses)

Captured non-billable time.

Syntax

'Declaration

Public Property TotalNonBillableTime As TimeSpan

public TimeSpan TotalNonBillableTime {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SubcaseTimeAndExpenses Class
SubcaseTimeAndExpenses Members


SupportToolkit Class | fcSDK Documentation

SupportToolkit Class

Provides APIs to allow you to modify basic ClearSupport objects such as Case and Subcase.

Methods on the SupportToolkit object allow you to create, modify, close, dispatch, accept, reject, assign, yank, move, change status, log notes, reopen, and more.

Syntax

'Declaration

Public Class SupportToolkit
   Inherits SupportToolkitBase

public class SupportToolkit : SupportToolkitBase

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.ToolkitBase
FChoice.Toolkits.Clarify.Support.SupportToolkitBase
FChoice.Toolkits.Clarify.Support.SupportToolkit

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

SupportToolkit Members
FChoice.Toolkits.Clarify.Support Namespace


SupportToolkit Class Members | fcSDK Documentation

SupportToolkit Class Members

The following tables list the members exposed by SupportToolkit.

Public Constructors

 | Name | Description
Public Constructor | SupportToolkit Constructor | Overloaded.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | IsInternalLogIndicator |

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | ApplicationClock | Exposed only for testability of certain APIs.

| | Public Property | ImpersonatorUsername | (Inherited from FChoice.Toolkits.Clarify.Support.SupportToolkitBase) | | Public Property | UseDenormalizedCaseTypeLevels | (Inherited from FChoice.Toolkits.Clarify.Support.SupportToolkitBase) |

Public Methods

 | Name | Description
Public Method | AcceptCase | Overloaded. Accept the specified Case from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.
Public Method | AcceptSubcase | Overloaded. Accept the specified Subcase from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.
Public Method | AppendHistoryToCase | Overloaded. Append
Public Method | AppendHistoryToSubCase | Overloaded. Append text to a Subcase and Case's history.
Public Method | AssignCase | Overloaded. Assign the Case to a new user. This overload takes a set of required parameters for the API.
Public Method | AssignSubcase | Overloaded. Assign the Subcase to a new user. This overload takes a set of required parameters for the API.
Public Method | ChangeCaseContact | Overloaded. Changes the contact for a Case. This overload takes a set of required parameters for the API.
Public Method | ChangeCaseSite | Overloaded. Changes the Site of a Case. This overload takes a set of required parameters for the API.
Public Method | ChangeCaseStatus | Overloaded. Changes the status of a Case. This overload takes a set of required parameters for the API.
Public Method | ChangeSubcaseStatus | Overloaded. Changes the status of a Subcase. This overload takes a set of required parameters for the API.
Public Method | CloseCase | Overloaded. Closes the specified Case that is currently open. This overload takes a set of required parameters for the API.
Public Method | CloseSubcase | Overloaded. Closes the specified Subcase. This overload takes a set of required parameters for the API.
Public Method | CreateCase | Overloaded. Creates a new Case. This overload takes a set of required parameters for the API.
Public Method | CreateCaseObjid | Overloaded. Creates a new Case by using know Objids of dependencies to keep from making additional database round trips to look up the Objids. This overload takes a set of required parameters for the API.
Public Method | CreateSubcase | Overloaded. Creates a new Subcase. This overload takes a set of required parameters for the API.
Public Method | DispatchCase | Overloaded. Dispatch the Case to the specified queue. This overload takes a set of required parameters for the API.
Public Method | DispatchSubcase | Overloaded. Dispatch the Subcase to the specified queue. This overload takes a set of required parameters for the API.
Public Method | ForwardCase | Overloaded. Reject-forward the Case from one queue to another. This overload takes a set of required parameters for the API.
Public Method | ForwardSubcase | Overloaded. Reject-forward the Subcase from one queue to another. This overload takes a set of required parameters for the API.
Public Method | FulfillCommitment | Overloaded. Fulfills a previously unfulfilled commitment. This overload takes a set of required parameters for the API.
Public Method | GetCaseTimeAndExpenses | Overloaded. Captures all the summed times (such as phone log time, billable and non-billable expense, etc) for a Case about to be closed. This overload takes a set of required parameters for the API.
Public Method | GetSubcaseTimeAndExpenses | Overloaded. Captures all the summed times (such as phone log time, billable and non-billable expense, etc) for a Subcase about to be closed. This overload takes a set of required parameters for the API.
Public Method | InitialResponse | Overloaded. Marks the initial response to a Case. This overload takes a set of required parameters for the API.
Public Method | LogCaseCommitment | Overloaded. Creates a commitment against a Case. This overload takes a set of required parameters for the API.
Public Method | LogCaseEmail | Overloaded. Creates an email log against a Case. This overload takes a set of required parameters for the API.
Public Method | LogCaseEmailIn | Overloaded. Creates an email in log against a Case.
Public Method | LogCaseInternalNote | Overloaded.
Public Method | LogCaseInternalPhone | Overloaded.
Public Method | LogCaseNote | Overloaded. Creates a note log against a Case. This overload takes a set of required parameters for the API.
Public Method | LogCasePhone | Overloaded. Creates a phone log against a Case. This overload takes a set of required parameters for the API.
Public Method | LogCaseResearch | Overloaded. Creates a research log against a Case. This overload takes a set of required parameters for the API.
Public Method | LogSubcaseCommitment | Overloaded. Creates a commitment against a Subcase. This overload takes a set of required parameters for the API.
Public Method | LogSubcaseEmail | Overloaded. Creates an email log against a Subcase. This overload takes a set of required parameters for the API.
Public Method | LogSubCaseEmailIn | Overloaded. Creates an email in log against a Subcase.
Public Method | LogSubcaseInternalNote | Overloaded.
Public Method | LogSubcaseInternalPhone | Overloaded.
Public Method | LogSubcaseNote | Overloaded. Creates a note log against a Subcase. This overload takes a set of required parameters for the API.
Public Method | LogSubcasePhone | Overloaded. Creates a phone log against a Subcase. This overload takes a set of required parameters for the API.
Public Method | LogSubcaseResearch | Overloaded. Creates a research log against a Subcase. This overload takes a set of required parameters for the API.
Public Method | MoveCase | Overloaded. Move the Case from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
Public Method | MoveSubcase | Overloaded. Move the Subcase from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
Public Method | RejectCase | Overloaded. Reject the Case from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.
Public Method | RejectSubcase | Overloaded. Reject the Subcase from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.
Public Method | RelateCaseToParentCase | Overloaded. Relates a Case to a specified parent Case. This overload takes a set of required parameters for the API.
Public Method | ReopenCase | Overloaded. Reopens the specified Case. This overload takes a set of required parameters for the API.
Public Method | ReopenSubcase | Overloaded. Reopens the specified Subcase. This overload takes a set of required parameters for the API.
Public Method | UnrelateCaseFromParentCase | Overloaded. Unrelates the specified Case from the current parent Case. This overload takes a set of required parameters for the API.
Public Method | UpdateCase | Overloaded. Updates an existing Case. This overload takes a setup object.
Public Method | UpdateCaseCommitment | Overloaded. Updates a commitment against a Case. This overload takes a set of required parameters for the API.
Public Method | UpdateSubcase | Overloaded. Updates an existing Subcase. This overload takes a setup object.
Public Method | UpdateSubcaseCommitment | Overloaded. Updates a commitment against a Subcase. This overload takes a set of required parameters for the API.
Public Method | YankCase | Overloaded. Yank the Case from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.
Public Method | YankSubcase | Overloaded. Yank the Subcase from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.

Reference

SupportToolkit Class
FChoice.Toolkits.Clarify.Support Namespace


SupportToolkit Constructor | fcSDK Documentation

SupportToolkit Constructor

Initializes a new instance of the SupportToolkit class.

Overload List

Overload | Description
SupportToolkit Constructor(ClarifySession) | Initializes a new instance of the SupportToolkit class using a ClarifySession object.
SupportToolkit Constructor(IFCApplication,IFCSession) | Initializes a new instance of the SupportToolkit class using a Compatibility application and session.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members


SupportToolkit Constructor(ClarifySession) | fcSDK Documentation

SupportToolkit Constructor(ClarifySession)

The session under which the toolkit APIs will be executed.

Initializes a new instance of the SupportToolkit class using a ClarifySession object.

Syntax

'Declaration

Public Function New( _
   ByVal _session_ As ClarifySession _
)

public SupportToolkit(ClarifySession _session)

Parameters

session

The session under which the toolkit APIs will be executed.

Remarks

If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


SupportToolkit Constructor(IFCApplication,IFCSession) | fcSDK Documentation

SupportToolkit Constructor(IFCApplication,IFCSession)

The compatibility application under which the toolkit APIs will be executed.

The compatibility session under which the toolkit APIs will be executed.

Initializes a new instance of the SupportToolkit class using a Compatibility application and session.

Syntax

'Declaration

Public Function New( _
   ByVal _application_ As IFCApplication, _
   ByVal _session_ As IFCSession _
)

public SupportToolkit(
   IFCApplication _application_,
   IFCSession _session_
)

Parameters

application

The compatibility application under which the toolkit APIs will be executed.

session

The compatibility session under which the toolkit APIs will be executed.

Remarks

If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


AcceptCase Method | fcSDK Documentation

AcceptCase Method

Accept the specified Case from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.

Accept the specified Case from the queue in which it is currently dispatched.

Overload List

Overload | Description
AcceptCase(String) | Accept the specified Case from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.
AcceptCase(AcceptCaseSetup) | Accept the specified Case from the queue in which it is currently dispatched. This overload takes a setup object.
AcceptCase(AcceptCaseSetup,IDbTransaction) | Accept the specified Case from the queue in which it is currently dispatched. This overload takes a setup object and a database transaction.

Remarks

The Case must be currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
AcceptCaseSetup Class


AcceptCase(String) Method | fcSDK Documentation

AcceptCase(String) Method

Case Identifier.

Accept the specified Case from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function AcceptCase( _
   ByVal _caseIDNum_ As String _
) As ToolkitResult

public ToolkitResult AcceptCase(
   string _caseIDNum_
)

Parameters

caseIDNum

Case Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Case must be currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


AcceptCase(AcceptCaseSetup) Method | fcSDK Documentation

AcceptCase(AcceptCaseSetup) Method

Setup object for API invocation.

Accept the specified Case from the queue in which it is currently dispatched. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function AcceptCase( _
   ByVal _setupParam_ AcceptCaseSetup _
) As ToolkitResult

public ToolkitResult AcceptCase(
   AcceptCaseSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Case must be currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
AcceptCaseSetup Class


AcceptCase(AcceptCaseSetup,IDbTransaction) Method | fcSDK Documentation

AcceptCase(AcceptCaseSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Accept the specified Case from the queue in which it is currently dispatched. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function AcceptCase( _
   ByVal _setupParam_ As AcceptCaseSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult AcceptCase(
   AcceptCaseSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Case must be currently dispatched to a queue.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


AcceptSubcase Method | fcSDK Documentation

AcceptSubcase Method

Accept the specified Subcase from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.

Accept the specified Subcase from the queue in which it is currently dispatched.

Overload List

Overload | Description
AcceptSubcase(String) | Accept the specified Subcase from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.
AcceptSubcase(AcceptSubcaseSetup) | Accept the specified Subcase from the queue in which it is currently dispatched. This overload takes a setup object.
AcceptSubcase(AcceptSubcaseSetup,IDbTransaction) | Accept the specified Subcase from the queue in which it is currently dispatched. This overload takes a setup object and a database transaction.

Remarks

The Subcase must be currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
AcceptSubcaseSetup Class


AcceptSubcase(String) Method | fcSDK Documentation

AcceptSubcase(String) Method

Subcase Identifier.

Accept the specified Subcase from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function AcceptSubcase( _
   ByVal _subcaseIDNum_ As String _
) As ToolkitResult

public ToolkitResult AcceptSubcase(
   string _subcaseIDNum_
)

Parameters

subcaseIDNum

Subcase Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Subcase must be currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


AcceptSubcase(AcceptSubcaseSetup) Method | fcSDK Documentation

AcceptSubcase(AcceptSubcaseSetup) Method

Setup object for API invocation.

Accept the specified Subcase from the queue in which it is currently dispatched. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function AcceptSubcase( _
   ByVal _setupParam_ AcceptSubcaseSetup _
) As ToolkitResult

public ToolkitResult AcceptSubcase(
   AcceptSubcaseSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Subcase must be currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
AcceptSubcaseSetup Class


AcceptSubcase(AcceptSubcaseSetup,IDbTransaction) Method | fcSDK Documentation

AcceptSubcase(AcceptSubcaseSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Accept the specified Subcase from the queue in which it is currently dispatched. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function AcceptSubcase( _
   ByVal _setupParam_ As AcceptSubcaseSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult AcceptSubcase(
   AcceptSubcaseSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Subcase must be currently dispatched to a queue.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


AppendHistoryToCase Method | fcSDK Documentation

AppendHistoryToCase Method

Append

Append text to a Case's history.

Overload List

Overload | Description
AppendHistoryToCase(String,String) | Append text to a Case's history.
AppendHistoryToCase(String,String,IDbTransaction) | Append text to a Case's history.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members


AppendHistoryToCase(String,String) Method | fcSDK Documentation

AppendHistoryToCase(String,String) Method

Identifier of the Case which the history is being appended.

Text to append to the case history.

Append text to a Case's history.

Syntax

'Declaration

Public Overloads Sub AppendHistoryToCase( _
   ByVal _caseIdNumber_ As String, _
   ByVal _stringToAppendToHistory_ As String _
)

public void AppendHistoryToCase(
   string _caseIdNumber_,
   string _stringToAppendToHistory_
)

Parameters

caseIdNumber

Identifier of the Case which the history is being appended.

stringToAppendToHistory

Text to append to the case history.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


AppendHistoryToCase(String,String,IDbTransaction) Method | fcSDK Documentation

AppendHistoryToCase(String,String,IDbTransaction) Method

Identifier of the Case which the history is being appended.

Text to append to the case history.

Database transaction under which the API will be invoked.

Append text to a Case's history.

Syntax

'Declaration

Public Overloads Sub AppendHistoryToCase( _
   ByVal _caseIdNumber_ As String, _
   ByVal _stringToAppendToHistory_ As String, _
   ByVal _dbTransaction_ As IDbTransaction _
)

public void AppendHistoryToCase(
   string _caseIdNumber_,
   string _stringToAppendToHistory_,
   IDbTransaction _dbTransaction_
)

Parameters

caseIdNumber

Identifier of the Case which the history is being appended.

stringToAppendToHistory

Text to append to the case history.

dbTransaction

Database transaction under which the API will be invoked.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


AppendHistoryToSubCase Method | fcSDK Documentation

AppendHistoryToSubCase Method

Append text to a Subcase and Case's history.

Append text to a Subcase and Case's history.

Overload List

Overload | Description
AppendHistoryToSubCase(String,String,IDbTransaction) | Append text to a Subcase and Case's history.
AppendHistoryToSubCase(String,String) | Append text to a Subcase and Case's history.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members


AppendHistoryToSubCase(String,String,IDbTransaction) Method | fcSDK Documentation

AppendHistoryToSubCase(String,String,IDbTransaction) Method

Identifier of the Subcase which the history is being appended.

Text to append to the case and subcase history.

Database transaction under which the API will be invoked.

Append text to a Subcase and Case's history.

Syntax

'Declaration

Public Overloads Sub AppendHistoryToSubCase( _
   ByVal _subCaseIdNumber_ As String, _
   ByVal _stringToAppendToHistory_ As String, _
   ByVal _dbTransaction_ As IDbTransaction _
)

public void AppendHistoryToSubCase(
   string _subCaseIdNumber_,
   string _stringToAppendToHistory_,
   IDbTransaction _dbTransaction_
)

Parameters

subCaseIdNumber

Identifier of the Subcase which the history is being appended.

stringToAppendToHistory

Text to append to the case and subcase history.

dbTransaction

Database transaction under which the API will be invoked.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


AppendHistoryToSubCase(String,String) Method | fcSDK Documentation

AppendHistoryToSubCase(String,String) Method

Identifier of the Subcase which the history is being appended.

Text to append to the case and subcase history.

Append text to a Subcase and Case's history.

Syntax

'Declaration

Public Overloads Sub AppendHistoryToSubCase( _
   ByVal _subCaseIdNumber_ As String, _
   ByVal _stringToAppendToHistory_ As String _
)

public void AppendHistoryToSubCase(
   string _subCaseIdNumber_,
   string _stringToAppendToHistory_
)

Parameters

subCaseIdNumber

Identifier of the Subcase which the history is being appended.

stringToAppendToHistory

Text to append to the case and subcase history.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


AssignCase Method | fcSDK Documentation

AssignCase Method

Assign the Case to a new user. This overload takes a set of required parameters for the API.

Assign the Case to a new user.

Overload List

Overload | Description
AssignCase(String) | Assign the Case to a new user. This overload takes a set of required parameters for the API.
AssignCase(AssignCaseSetup) | Assign the Case to a new user. This overload takes a setup object.
AssignCase(AssignCaseSetup,IDbTransaction) | Assign the Case to a new user. This overload takes a setup object and a database transaction.

Remarks

The Case must be in the Open condition, and the user assigning the Case does not have to be the owner of the Case. In base Clarify, the assigner of a Case must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the Case in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
AssignCaseSetup Class


AssignCase(String) Method | fcSDK Documentation

AssignCase(String) Method

Case Identifier.

Assign the Case to a new user. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function AssignCase( _
   ByVal _caseIDNum_ As String _
) As ToolkitResult

public ToolkitResult AssignCase(
   string _caseIDNum_
)

Parameters

caseIDNum

Case Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Case must be in the Open condition, and the user assigning the Case does not have to be the owner of the Case. In base Clarify, the assigner of a Case must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the Case in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


AssignCase(AssignCaseSetup) Method | fcSDK Documentation

AssignCase(AssignCaseSetup) Method

Setup object for API invocation.

Assign the Case to a new user. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function AssignCase( _
   ByVal _setupParam_ AssignCaseSetup _
) As ToolkitResult

public ToolkitResult AssignCase(
   AssignCaseSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Case must be in the Open condition, and the user assigning the Case does not have to be the owner of the Case. In base Clarify, the assigner of a Case must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the Case in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
AssignCaseSetup Class


AssignCase(AssignCaseSetup,IDbTransaction) Method | fcSDK Documentation

AssignCase(AssignCaseSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Assign the Case to a new user. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function AssignCase( _
   ByVal _setupParam_ As AssignCaseSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult AssignCase(
   AssignCaseSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Case must be in the Open condition, and the user assigning the Case does not have to be the owner of the Case. In base Clarify, the assigner of a Case must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the Case in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


AssignSubcase Method | fcSDK Documentation

AssignSubcase Method

Assign the Subcase to a new user. This overload takes a set of required parameters for the API.

Assign the Subcase to a new user.

Overload List

Overload | Description
AssignSubcase(String) | Assign the Subcase to a new user. This overload takes a set of required parameters for the API.
AssignSubcase(AssignSubcaseSetup) | Assign the Subcase to a new user. This overload takes a setup object.
AssignSubcase(AssignSubcaseSetup,IDbTransaction) | Assign the Subcase to a new user. This overload takes a setup object and a database transaction.

Remarks

The Subcase must be in the Open condition, and the user assigning the Subcase does not have to be the owner of the Subcase. In base Clarify, the assigner of a Subcase must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the Subcase in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
AssignSubcaseSetup Class


AssignSubcase(String) Method | fcSDK Documentation

AssignSubcase(String) Method

Subcase Identifier.

Assign the Subcase to a new user. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function AssignSubcase( _
   ByVal _subcaseIDNum_ As String _
) As ToolkitResult

public ToolkitResult AssignSubcase(
   string _subcaseIDNum_
)

Parameters

subcaseIDNum

Subcase Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Subcase must be in the Open condition, and the user assigning the Subcase does not have to be the owner of the Subcase. In base Clarify, the assigner of a Subcase must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the Subcase in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


AssignSubcase(AssignSubcaseSetup) Method | fcSDK Documentation

AssignSubcase(AssignSubcaseSetup) Method

Setup object for API invocation.

Assign the Subcase to a new user. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function AssignSubcase( _
   ByVal _setupParam_ AssignSubcaseSetup _
) As ToolkitResult

public ToolkitResult AssignSubcase(
   AssignSubcaseSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Subcase must be in the Open condition, and the user assigning the Subcase does not have to be the owner of the Subcase. In base Clarify, the assigner of a Subcase must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the Subcase in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
AssignSubcaseSetup Class


AssignSubcase(AssignSubcaseSetup,IDbTransaction) Method | fcSDK Documentation

AssignSubcase(AssignSubcaseSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Assign the Subcase to a new user. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function AssignSubcase( _
   ByVal _setupParam_ As AssignSubcaseSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult AssignSubcase(
   AssignSubcaseSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Subcase must be in the Open condition, and the user assigning the Subcase does not have to be the owner of the Subcase. In base Clarify, the assigner of a Subcase must be the owner. If either user name is not specified, the “current” user is used. The date/time of the assignment, and the WipBin to place the Subcase in can also be specified. Allowing a WipBin other than the default one is also an augmentation from base Clarify.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


ChangeCaseContact Method | fcSDK Documentation

ChangeCaseContact Method

Changes the contact for a Case. This overload takes a set of required parameters for the API.

Changes the contact for a Case.

Overload List

Overload | Description
ChangeCaseContact(String,String,String,String) | Changes the contact for a Case. This overload takes a set of required parameters for the API.
ChangeCaseContact(ChangeCaseContactSetup) | Changes the contact for a Case. This overload takes a setup object.
ChangeCaseContact(ChangeCaseContactSetup,IDbTransaction) | Changes the contact for a Case. This overload takes a setup object and a database transaction.

Remarks

The Case phone and alternate phone are also changed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
ChangeCaseContactSetup Class


ChangeCaseContact(String,String,String,String) Method | fcSDK Documentation

ChangeCaseContact(String,String,String,String) Method

Case Identifier.

Contact's first name.

Contact's last name.

Contact's phone number.

Changes the contact for a Case. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function ChangeCaseContact( _
   ByVal _caseIDNum_ As String, _
   ByVal _contactFirstName_ As String, _
   ByVal _contactLastName_ As String, _
   ByVal _contactPhone_ As String _
) As ToolkitResult

public ToolkitResult ChangeCaseContact(
   string _caseIDNum_,
   string _contactFirstName_,
   string _contactLastName_,
   string _contactPhone_
)

Parameters

caseIDNum

Case Identifier.

contactFirstName

Contact's first name.

contactLastName

Contact's last name.

contactPhone

Contact's phone number.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Case phone and alternate phone are also changed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


ChangeCaseContact(ChangeCaseContactSetup) Method | fcSDK Documentation

ChangeCaseContact(ChangeCaseContactSetup) Method

Setup object for API invocation.

Changes the contact for a Case. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function ChangeCaseContact( _
   ByVal _setupParam_ ChangeCaseContactSetup _
) As ToolkitResult

public ToolkitResult ChangeCaseContact(
   ChangeCaseContactSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Case phone and alternate phone are also changed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
ChangeCaseContactSetup Class


ChangeCaseContact(ChangeCaseContactSetup,IDbTransaction) Method | fcSDK Documentation

ChangeCaseContact(ChangeCaseContactSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Changes the contact for a Case. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function ChangeCaseContact( _
   ByVal _setupParam_ As ChangeCaseContactSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult ChangeCaseContact(
   ChangeCaseContactSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Case phone and alternate phone are also changed.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


ChangeCaseSite Method | fcSDK Documentation

ChangeCaseSite Method

Changes the Site of a Case. This overload takes a set of required parameters for the API.

Changes the Site of a Case.

Overload List

Overload | Description
ChangeCaseSite(String,String) | Changes the Site of a Case. This overload takes a set of required parameters for the API.
ChangeCaseSite(ChangeCaseSiteSetup) | Changes the Site of a Case. This overload takes a setup object.
ChangeCaseSite(ChangeCaseSiteSetup,IDbTransaction) | Changes the Site of a Case. This overload takes a setup object and a database transaction.

Remarks

Any related Site Parts and Contracts for the Case are unrelated.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
ChangeCaseSiteSetup Class


ChangeCaseSite(String,String) Method | fcSDK Documentation

ChangeCaseSite(String,String) Method

Case Identifier.

Site Identifier.

Changes the Site of a Case. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function ChangeCaseSite( _
   ByVal _caseIDNum_ As String, _
   ByVal _siteIDNum_ As String _
) As ToolkitResult

public ToolkitResult ChangeCaseSite(
   string _caseIDNum_,
   string _siteIDNum_
)

Parameters

caseIDNum

Case Identifier.

siteIDNum

Site Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

Any related Site Parts and Contracts for the Case are unrelated.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


ChangeCaseSite(ChangeCaseSiteSetup) Method | fcSDK Documentation

ChangeCaseSite(ChangeCaseSiteSetup) Method

Setup object for API invocation.

Changes the Site of a Case. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function ChangeCaseSite( _
   ByVal _setupParam_ ChangeCaseSiteSetup _
) As ToolkitResult

public ToolkitResult ChangeCaseSite(
   ChangeCaseSiteSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

Any related Site Parts and Contracts for the Case are unrelated.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
ChangeCaseSiteSetup Class


ChangeCaseSite(ChangeCaseSiteSetup,IDbTransaction) Method | fcSDK Documentation

ChangeCaseSite(ChangeCaseSiteSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Changes the Site of a Case. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function ChangeCaseSite( _
   ByVal _setupParam_ As ChangeCaseSiteSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult ChangeCaseSite(
   ChangeCaseSiteSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

Any related Site Parts and Contracts for the Case are unrelated.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


ChangeCaseStatus Method | fcSDK Documentation

ChangeCaseStatus Method

Changes the status of a Case. This overload takes a set of required parameters for the API.

Changes the status of a Case.

Overload List

Overload | Description
ChangeCaseStatus(String) | Changes the status of a Case. This overload takes a set of required parameters for the API.
ChangeCaseStatus(ChangeCaseStatusSetup) | Changes the status of a Case. This overload takes a setup object.
ChangeCaseStatus(ChangeCaseStatusSetup,IDbTransaction) | Changes the status of a Case. This overload takes a setup object and a database transaction.

Remarks

The Case may be opened or closed, but the status selected must be valid for the current condition. In other words, you cannot assign a Closed condition status to a Case that is currently Open.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
ChangeCaseStatusSetup Class


ChangeCaseStatus(String) Method | fcSDK Documentation

ChangeCaseStatus(String) Method

Case Identifier.

Changes the status of a Case. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function ChangeCaseStatus( _
   ByVal _caseIDNum_ As String _
) As ToolkitResult

public ToolkitResult ChangeCaseStatus(
   string _caseIDNum_
)

Parameters

caseIDNum

Case Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Case may be opened or closed, but the status selected must be valid for the current condition. In other words, you cannot assign a Closed condition status to a Case that is currently Open.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


ChangeCaseStatus(ChangeCaseStatusSetup) Method | fcSDK Documentation

ChangeCaseStatus(ChangeCaseStatusSetup) Method

Setup object for API invocation.

Changes the status of a Case. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function ChangeCaseStatus( _
   ByVal _setupParam_ ChangeCaseStatusSetup _
) As ToolkitResult

public ToolkitResult ChangeCaseStatus(
   ChangeCaseStatusSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Case may be opened or closed, but the status selected must be valid for the current condition. In other words, you cannot assign a Closed condition status to a Case that is currently Open.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
ChangeCaseStatusSetup Class


ChangeCaseStatus(ChangeCaseStatusSetup,IDbTransaction) Method | fcSDK Documentation

ChangeCaseStatus(ChangeCaseStatusSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Changes the status of a Case. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function ChangeCaseStatus( _
   ByVal _setupParam_ As ChangeCaseStatusSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult ChangeCaseStatus(
   ChangeCaseStatusSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Case may be opened or closed, but the status selected must be valid for the current condition. In other words, you cannot assign a Closed condition status to a Case that is currently Open.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


ChangeSubcaseStatus Method | fcSDK Documentation

ChangeSubcaseStatus Method

Changes the status of a Subcase. This overload takes a set of required parameters for the API.

Changes the status of a Subcase.

Overload List

Overload | Description
ChangeSubcaseStatus(String) | Changes the status of a Subcase. This overload takes a set of required parameters for the API.
ChangeSubcaseStatus(ChangeSubcaseStatusSetup) | Changes the status of a Subcase. This overload takes a setup object.
ChangeSubcaseStatus(ChangeSubcaseStatusSetup,IDbTransaction) | Changes the status of a Subcase. This overload takes a setup object and a database transaction.

Remarks

The Subcase may be opened or closed, but the status selected must be valid for the current condition. In other words, you cannot assign a Closed condition status to a Subcase that is currently Open.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
ChangeSubcaseStatusSetup Class


ChangeSubcaseStatus(String) Method | fcSDK Documentation

ChangeSubcaseStatus(String) Method

Subcase Identifier.

Changes the status of a Subcase. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function ChangeSubcaseStatus( _
   ByVal _subcaseIDNum_ As String _
) As ToolkitResult

public ToolkitResult ChangeSubcaseStatus(
   string _subcaseIDNum_
)

Parameters

subcaseIDNum

Subcase Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Subcase may be opened or closed, but the status selected must be valid for the current condition. In other words, you cannot assign a Closed condition status to a Subcase that is currently Open.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


ChangeSubcaseStatus(ChangeSubcaseStatusSetup) Method | fcSDK Documentation

ChangeSubcaseStatus(ChangeSubcaseStatusSetup) Method

Setup object for API invocation.

Changes the status of a Subcase. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function ChangeSubcaseStatus( _
   ByVal _setupParam_ ChangeSubcaseStatusSetup _
) As ToolkitResult

public ToolkitResult ChangeSubcaseStatus(
   ChangeSubcaseStatusSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Subcase may be opened or closed, but the status selected must be valid for the current condition. In other words, you cannot assign a Closed condition status to a Subcase that is currently Open.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
ChangeSubcaseStatusSetup Class


ChangeSubcaseStatus(ChangeSubcaseStatusSetup,IDbTransaction) Method | fcSDK Documentation

ChangeSubcaseStatus(ChangeSubcaseStatusSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Changes the status of a Subcase. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function ChangeSubcaseStatus( _
   ByVal _setupParam_ As ChangeSubcaseStatusSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult ChangeSubcaseStatus(
   ChangeSubcaseStatusSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Subcase may be opened or closed, but the status selected must be valid for the current condition. In other words, you cannot assign a Closed condition status to a Subcase that is currently Open.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


CloseCase Method | fcSDK Documentation

CloseCase Method

Closes the specified Case that is currently open. This overload takes a set of required parameters for the API.

Closes the specified Case that is currently open.

Overload List

Overload | Description
CloseCase(String) | Closes the specified Case that is currently open. This overload takes a set of required parameters for the API.
CloseCase(CloseCaseSetup) | Closes the specified Case that is currently open. This overload takes a setup object.
CloseCase(CloseCaseSetup,IDbTransaction) | Closes the specified Case that is currently open. This overload takes a setup object and a database transaction.

Remarks

If the CloseSums property is not set, the API will automatically calculate the log summation for the Case.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
CloseCaseSetup Class


CloseCase(String) Method | fcSDK Documentation

CloseCase(String) Method

Identifier of the Case being closed.

Closes the specified Case that is currently open. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CloseCase( _
   ByVal _caseIDNum_ As String _
) As ToolkitResult

public ToolkitResult CloseCase(
   string _caseIDNum_
)

Parameters

caseIDNum

Identifier of the Case being closed.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The newly created CloseCase object.

Remarks

If the CloseSums property is not set, the API will automatically calculate the log summation for the Case.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


CloseCase(CloseCaseSetup) Method | fcSDK Documentation

CloseCase(CloseCaseSetup) Method

Setup object for API invocation.

Closes the specified Case that is currently open. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CloseCase( _
   ByVal _setupParam_ CloseCaseSetup _
) As ToolkitResult

public ToolkitResult CloseCase(
   CloseCaseSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The newly created CloseCase object.

Remarks

If the CloseSums property is not set, the API will automatically calculate the log summation for the Case.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
CloseCaseSetup Class


CloseCase(CloseCaseSetup,IDbTransaction) Method | fcSDK Documentation

CloseCase(CloseCaseSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Closes the specified Case that is currently open. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CloseCase( _
   ByVal _setupParam_ As CloseCaseSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CloseCase(
   CloseCaseSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

If the CloseSums property is not set, the API will automatically calculate the log summation for the Case.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


CloseSubcase Method | fcSDK Documentation

CloseSubcase Method

Closes the specified Subcase. This overload takes a set of required parameters for the API.

Closes the specified Subcase.

Overload List

Overload | Description
CloseSubcase(String) | Closes the specified Subcase. This overload takes a set of required parameters for the API.
CloseSubcase(CloseSubcaseSetup) | Closes the specified Subcase. This overload takes a setup object.
CloseSubcase(CloseSubcaseSetup,IDbTransaction) | Closes the specified Subcase. This overload takes a setup object and a database transaction.

Remarks

The Subcase must be in open condition.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
CloseSubcaseSetup Class


CloseSubcase(String) Method | fcSDK Documentation

CloseSubcase(String) Method

Subcase Identifier.

Closes the specified Subcase. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CloseSubcase( _
   ByVal _subcaseIDNum_ As String _
) As ToolkitResult

public ToolkitResult CloseSubcase(
   string _subcaseIDNum_
)

Parameters

subcaseIDNum

Subcase Identifier.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The newly created CloseCase object.

Remarks

The Subcase must be in open condition.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


CloseSubcase(CloseSubcaseSetup) Method | fcSDK Documentation

CloseSubcase(CloseSubcaseSetup) Method

Setup object for API invocation.

Closes the specified Subcase. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CloseSubcase( _
   ByVal _setupParam_ CloseSubcaseSetup _
) As ToolkitResult

public ToolkitResult CloseSubcase(
   CloseSubcaseSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The newly created CloseCase object.

Remarks

The Subcase must be in open condition.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
CloseSubcaseSetup Class


CloseSubcase(CloseSubcaseSetup,IDbTransaction) Method | fcSDK Documentation

CloseSubcase(CloseSubcaseSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Closes the specified Subcase. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CloseSubcase( _
   ByVal _setupParam_ As CloseSubcaseSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CloseSubcase(
   CloseSubcaseSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Subcase must be in open condition.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


CreateCase Method | fcSDK Documentation

CreateCase Method

Creates a new Case. This overload takes a set of required parameters for the API.

Creates a new Case.

Overload List

Overload | Description
CreateCase(String,String,String,String) | Creates a new Case. This overload takes a set of required parameters for the API.
CreateCase(CreateCaseSetup) | Creates a new Case. This overload takes a setup object.
CreateCase(CreateCaseSetup,IDbTransaction) | Creates a new Case. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
CreateCaseSetup Class


CreateCase(String,String,String,String) Method | fcSDK Documentation

CreateCase(String,String,String,String) Method

Site Identifier to which Site reported the Case.

Contact's first name.

Contact's last name.

Contact's phone number.

Creates a new Case. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreateCase( _
   ByVal _siteIDNum_ As String, _
   ByVal _contactFirstName_ As String, _
   ByVal _contactLastName_ As String, _
   ByVal _contactPhone_ As String _
) As ToolkitResult

public ToolkitResult CreateCase(
   string _siteIDNum_,
   string _contactFirstName_,
   string _contactLastName_,
   string _contactPhone_
)

Parameters

siteIDNum

Site Identifier to which Site reported the Case.

contactFirstName

Contact's first name.

contactLastName

Contact's last name.

contactPhone

Contact's phone number.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • IDNum - The IDNum of the Case.
  • Objid - The Objid of the Case.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


CreateCase(CreateCaseSetup) Method | fcSDK Documentation

CreateCase(CreateCaseSetup) Method

Setup object for API invocation.

Creates a new Case. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreateCase( _
   ByVal _setupParam_ CreateCaseSetup _
) As ToolkitResult

public ToolkitResult CreateCase(
   CreateCaseSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • IDNum - The IDNum of the Case.
  • Objid - The Objid of the Case.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
CreateCaseSetup Class


CreateCase(CreateCaseSetup,IDbTransaction) Method | fcSDK Documentation

CreateCase(CreateCaseSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Creates a new Case. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreateCase( _
   ByVal _setupParam_ As CreateCaseSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreateCase(
   CreateCaseSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


CreateCaseObjid Method | fcSDK Documentation

CreateCaseObjid Method

Creates a new Case by using know Objids of dependencies to keep from making additional database round trips to look up the Objids. This overload takes a set of required parameters for the API.

Creates a new Case by using know Objids of dependencies to keep from making additional database round trips to look up the Objids.

Overload List

Overload | Description
CreateCaseObjid() | Creates a new Case by using know Objids of dependencies to keep from making additional database round trips to look up the Objids. This overload takes a set of required parameters for the API.
CreateCaseObjid(CreateCaseObjidSetup) | Creates a new Case by using know Objids of dependencies to keep from making additional database round trips to look up the Objids. This overload takes a setup object.
CreateCaseObjid(CreateCaseObjidSetup,IDbTransaction) | Creates a new Case by using know Objids of dependencies to keep from making additional database round trips to look up the Objids. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
CreateCaseObjidSetup Class


CreateCaseObjid() Method | fcSDK Documentation

CreateCaseObjid() Method

Creates a new Case by using know Objids of dependencies to keep from making additional database round trips to look up the Objids. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreateCaseObjid() As ToolkitResult

public ToolkitResult CreateCaseObjid()

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • IDNum - The IDNum of the Case.
  • Objid - The Objid of the Case.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


CreateCaseObjid(CreateCaseObjidSetup) Method | fcSDK Documentation

CreateCaseObjid(CreateCaseObjidSetup) Method

Setup object for API invocation.

Creates a new Case by using know Objids of dependencies to keep from making additional database round trips to look up the Objids. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreateCaseObjid( _
   ByVal _setupParam_ CreateCaseObjidSetup _
) As ToolkitResult

public ToolkitResult CreateCaseObjid(
   CreateCaseObjidSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • IDNum - The IDNum of the Case.
  • Objid - The Objid of the Case.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
CreateCaseObjidSetup Class


CreateCaseObjid(CreateCaseObjidSetup,IDbTransaction) Method | fcSDK Documentation

CreateCaseObjid(CreateCaseObjidSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Creates a new Case by using know Objids of dependencies to keep from making additional database round trips to look up the Objids. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreateCaseObjid( _
   ByVal _setupParam_ As CreateCaseObjidSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreateCaseObjid(
   CreateCaseObjidSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


CreateSubcase Method | fcSDK Documentation

CreateSubcase Method

Creates a new Subcase. This overload takes a set of required parameters for the API.

Creates a new Subcase.

Overload List

Overload | Description
CreateSubcase(String) | Creates a new Subcase. This overload takes a set of required parameters for the API.
CreateSubcase(CreateSubcaseSetup) | Creates a new Subcase. This overload takes a setup object.
CreateSubcase(CreateSubcaseSetup,IDbTransaction) | Creates a new Subcase. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
CreateSubcaseSetup Class


CreateSubcase(String) Method | fcSDK Documentation

CreateSubcase(String) Method

Case Identifier of the parent Case.

Creates a new Subcase. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function CreateSubcase( _
   ByVal _caseIDNum_ As String _
) As ToolkitResult

public ToolkitResult CreateSubcase(
   string _caseIDNum_
)

Parameters

caseIDNum

Case Identifier of the parent Case.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • IDNum - The IDNum of the Subcase.
  • Objid - The Objid of the Subcase.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


CreateSubcase(CreateSubcaseSetup) Method | fcSDK Documentation

CreateSubcase(CreateSubcaseSetup) Method

Setup object for API invocation.

Creates a new Subcase. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function CreateSubcase( _
   ByVal _setupParam_ CreateSubcaseSetup _
) As ToolkitResult

public ToolkitResult CreateSubcase(
   CreateSubcaseSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • IDNum - The IDNum of the Subcase.
  • Objid - The Objid of the Subcase.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
CreateSubcaseSetup Class


CreateSubcase(CreateSubcaseSetup,IDbTransaction) Method | fcSDK Documentation

CreateSubcase(CreateSubcaseSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Creates a new Subcase. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function CreateSubcase( _
   ByVal _setupParam_ As CreateSubcaseSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult CreateSubcase(
   CreateSubcaseSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


DispatchCase Method | fcSDK Documentation

DispatchCase Method

Dispatch the Case to the specified queue. This overload takes a set of required parameters for the API.

Dispatch the Case to the specified queue.

Overload List

Overload | Description
DispatchCase(String,String) | Dispatch the Case to the specified queue. This overload takes a set of required parameters for the API.
DispatchCase(DispatchCaseSetup) | Dispatch the Case to the specified queue. This overload takes a setup object.
DispatchCase(DispatchCaseSetup,IDbTransaction) | Dispatch the Case to the specified queue. This overload takes a setup object and a database transaction.

Remarks

The Case must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
DispatchCaseSetup Class


DispatchCase(String,String) Method | fcSDK Documentation

DispatchCase(String,String) Method

Case Identifier.

The queue into which the Case is to be dispatched.

Dispatch the Case to the specified queue. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function DispatchCase( _
   ByVal _caseIDNum_ As String, _
   ByVal _queue_ As String _
) As ToolkitResult

public ToolkitResult DispatchCase(
   string _caseIDNum_,
   string _queue_
)

Parameters

caseIDNum

Case Identifier.

queue

The queue into which the Case is to be dispatched.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Case must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


DispatchCase(DispatchCaseSetup) Method | fcSDK Documentation

DispatchCase(DispatchCaseSetup) Method

Setup object for API invocation.

Dispatch the Case to the specified queue. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function DispatchCase( _
   ByVal _setupParam_ DispatchCaseSetup _
) As ToolkitResult

public ToolkitResult DispatchCase(
   DispatchCaseSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Case must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
DispatchCaseSetup Class


DispatchCase(DispatchCaseSetup,IDbTransaction) Method | fcSDK Documentation

DispatchCase(DispatchCaseSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Dispatch the Case to the specified queue. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function DispatchCase( _
   ByVal _setupParam_ As DispatchCaseSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult DispatchCase(
   DispatchCaseSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Case must be in open condition, and not currently dispatched to a queue.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


DispatchSubcase Method | fcSDK Documentation

DispatchSubcase Method

Dispatch the Subcase to the specified queue. This overload takes a set of required parameters for the API.

Dispatch the Subcase to the specified queue.

Overload List

Overload | Description
DispatchSubcase(String,String) | Dispatch the Subcase to the specified queue. This overload takes a set of required parameters for the API.
DispatchSubcase(DispatchSubcaseSetup) | Dispatch the Subcase to the specified queue. This overload takes a setup object.
DispatchSubcase(DispatchSubcaseSetup,IDbTransaction) | Dispatch the Subcase to the specified queue. This overload takes a setup object and a database transaction.

Remarks

The Subcase must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
DispatchSubcaseSetup Class


DispatchSubcase(String,String) Method | fcSDK Documentation

DispatchSubcase(String,String) Method

Subcase Identifier.

The queue into which the Subcase is to be dispatched.

Dispatch the Subcase to the specified queue. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function DispatchSubcase( _
   ByVal _subcaseIDNum_ As String, _
   ByVal _queue_ As String _
) As ToolkitResult

public ToolkitResult DispatchSubcase(
   string _subcaseIDNum_,
   string _queue_
)

Parameters

subcaseIDNum

Subcase Identifier.

queue

The queue into which the Subcase is to be dispatched.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Subcase must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


DispatchSubcase(DispatchSubcaseSetup) Method | fcSDK Documentation

DispatchSubcase(DispatchSubcaseSetup) Method

Setup object for API invocation.

Dispatch the Subcase to the specified queue. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function DispatchSubcase( _
   ByVal _setupParam_ DispatchSubcaseSetup _
) As ToolkitResult

public ToolkitResult DispatchSubcase(
   DispatchSubcaseSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Subcase must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
DispatchSubcaseSetup Class


DispatchSubcase(DispatchSubcaseSetup,IDbTransaction) Method | fcSDK Documentation

DispatchSubcase(DispatchSubcaseSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Dispatch the Subcase to the specified queue. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function DispatchSubcase( _
   ByVal _setupParam_ As DispatchSubcaseSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult DispatchSubcase(
   DispatchSubcaseSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Subcase must be in open condition, and not currently dispatched to a queue.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


ForwardCase Method | fcSDK Documentation

ForwardCase Method

Reject-forward the Case from one queue to another. This overload takes a set of required parameters for the API.

Reject-forward the Case from one queue to another.

Overload List

Overload | Description
ForwardCase(String,String) | Reject-forward the Case from one queue to another. This overload takes a set of required parameters for the API.
ForwardCase(ForwardCaseSetup) | Reject-forward the Case from one queue to another. This overload takes a setup object.
ForwardCase(ForwardCaseSetup,IDbTransaction) | Reject-forward the Case from one queue to another. This overload takes a setup object and a database transaction.

Remarks

The Case must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
ForwardCaseSetup Class


ForwardCase(String,String) Method | fcSDK Documentation

ForwardCase(String,String) Method

Case Identifier.

The new queue into which the Case is to be forwarded.

Reject-forward the Case from one queue to another. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function ForwardCase( _
   ByVal _caseIDNum_ As String, _
   ByVal _newQueue_ As String _
) As ToolkitResult

public ToolkitResult ForwardCase(
   string _caseIDNum_,
   string _newQueue_
)

Parameters

caseIDNum

Case Identifier.

newQueue

The new queue into which the Case is to be forwarded.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Case must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


ForwardCase(ForwardCaseSetup) Method | fcSDK Documentation

ForwardCase(ForwardCaseSetup) Method

Setup object for API invocation.

Reject-forward the Case from one queue to another. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function ForwardCase( _
   ByVal _setupParam_ ForwardCaseSetup _
) As ToolkitResult

public ToolkitResult ForwardCase(
   ForwardCaseSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Case must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
ForwardCaseSetup Class


ForwardCase(ForwardCaseSetup,IDbTransaction) Method | fcSDK Documentation

ForwardCase(ForwardCaseSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Reject-forward the Case from one queue to another. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function ForwardCase( _
   ByVal _setupParam_ As ForwardCaseSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult ForwardCase(
   ForwardCaseSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Case must be in open condition, and not currently dispatched to a queue.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


ForwardSubcase Method | fcSDK Documentation

ForwardSubcase Method

Reject-forward the Subcase from one queue to another. This overload takes a set of required parameters for the API.

Reject-forward the Subcase from one queue to another.

Overload List

Overload | Description
ForwardSubcase(String,String) | Reject-forward the Subcase from one queue to another. This overload takes a set of required parameters for the API.
ForwardSubcase(ForwardSubcaseSetup) | Reject-forward the Subcase from one queue to another. This overload takes a setup object.
ForwardSubcase(ForwardSubcaseSetup,IDbTransaction) | Reject-forward the Subcase from one queue to another. This overload takes a setup object and a database transaction.

Remarks

The Subcase must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
ForwardSubcaseSetup Class


ForwardSubcase(String,String) Method | fcSDK Documentation

ForwardSubcase(String,String) Method

Subcase Identifier.

The new queue into which the Subcase is to be forwarded.

Reject-forward the Subcase from one queue to another. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function ForwardSubcase( _
   ByVal _subcaseIDNum_ As String, _
   ByVal _newQueue_ As String _
) As ToolkitResult

public ToolkitResult ForwardSubcase(
   string _subcaseIDNum_,
   string _newQueue_
)

Parameters

subcaseIDNum

Subcase Identifier.

newQueue

The new queue into which the Subcase is to be forwarded.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Subcase must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


ForwardSubcase(ForwardSubcaseSetup) Method | fcSDK Documentation

ForwardSubcase(ForwardSubcaseSetup) Method

Setup object for API invocation.

Reject-forward the Subcase from one queue to another. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function ForwardSubcase( _
   ByVal _setupParam_ ForwardSubcaseSetup _
) As ToolkitResult

public ToolkitResult ForwardSubcase(
   ForwardSubcaseSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Subcase must be in open condition, and not currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
ForwardSubcaseSetup Class


ForwardSubcase(ForwardSubcaseSetup,IDbTransaction) Method | fcSDK Documentation

ForwardSubcase(ForwardSubcaseSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Reject-forward the Subcase from one queue to another. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function ForwardSubcase( _
   ByVal _setupParam_ As ForwardSubcaseSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult ForwardSubcase(
   ForwardSubcaseSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Subcase must be in open condition, and not currently dispatched to a queue.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


FulfillCommitment Method | fcSDK Documentation

FulfillCommitment Method

Fulfills a previously unfulfilled commitment. This overload takes a set of required parameters for the API.

Fulfills a previously unfulfilled commitment.

Overload List

Overload | Description
FulfillCommitment(Int32) | Fulfills a previously unfulfilled commitment. This overload takes a set of required parameters for the API.
FulfillCommitment(FulfillCommitmentSetup) | Fulfills a previously unfulfilled commitment. This overload takes a setup object.
FulfillCommitment(FulfillCommitmentSetup,IDbTransaction) | Fulfills a previously unfulfilled commitment. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
FulfillCommitmentSetup Class


FulfillCommitment(Int32) Method | fcSDK Documentation

FulfillCommitment(Int32) Method

Log Objid of the log to be fulfilled.

Fulfills a previously unfulfilled commitment. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function FulfillCommitment( _
   ByVal _logObjid_ As Integer _
) As ToolkitResult

public ToolkitResult FulfillCommitment(
   int _logObjid_
)

Parameters

logObjid

Log Objid of the log to be fulfilled.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


FulfillCommitment(FulfillCommitmentSetup) Method | fcSDK Documentation

FulfillCommitment(FulfillCommitmentSetup) Method

Setup object for API invocation.

Fulfills a previously unfulfilled commitment. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function FulfillCommitment( _
   ByVal _setupParam_ FulfillCommitmentSetup _
) As ToolkitResult

public ToolkitResult FulfillCommitment(
   FulfillCommitmentSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
FulfillCommitmentSetup Class


FulfillCommitment(FulfillCommitmentSetup,IDbTransaction) Method | fcSDK Documentation

FulfillCommitment(FulfillCommitmentSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Fulfills a previously unfulfilled commitment. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function FulfillCommitment( _
   ByVal _setupParam_ As FulfillCommitmentSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult FulfillCommitment(
   FulfillCommitmentSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


GetCaseTimeAndExpenses Method | fcSDK Documentation

GetCaseTimeAndExpenses Method

Captures all the summed times (such as phone log time, billable and non-billable expense, etc) for a Case about to be closed. This overload takes a set of required parameters for the API.

Captures all the summed times (such as phone log time, billable and non-billable expense, etc) for a Case about to be closed.

Overload List

Overload | Description
GetCaseTimeAndExpenses(String) | Captures all the summed times (such as phone log time, billable and non-billable expense, etc) for a Case about to be closed. This overload takes a set of required parameters for the API.
GetCaseTimeAndExpenses(GetCaseTimeAndExpensesSetup) | Captures all the summed times (such as phone log time, billable and non-billable expense, etc) for a Case about to be closed. This overload takes a setup object.
GetCaseTimeAndExpenses(GetCaseTimeAndExpensesSetup,IDbTransaction) | Captures all the summed times (such as phone log time, billable and non-billable expense, etc) for a Case about to be closed. This overload takes a setup object and a database transaction.

Remarks

There are a number of bugs with the default Clarify close Case summation on the form. There are not sufficient fields defined in the close_case record for the graphical fields they show. Hence, the data doesn't always make sense. For example, the total phone time captured should be the total of the phone time captured for the Case and for all general subcases. But the GUI form points that field to the total for the phone logs captured for the Case (not showing the Subcase). Hence, this API defines the data as captured from the real data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
GetCaseTimeAndExpensesSetup Class


GetCaseTimeAndExpenses(String) Method | fcSDK Documentation

GetCaseTimeAndExpenses(String) Method

Case Identifier.

Captures all the summed times (such as phone log time, billable and non-billable expense, etc) for a Case about to be closed. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function GetCaseTimeAndExpenses( _
   ByVal _caseIDNum_ As String _
) As GetCaseTimeAndExpensesResult

public GetCaseTimeAndExpensesResult GetCaseTimeAndExpenses(
   string _caseIDNum_
)

Parameters

caseIDNum

Case Identifier.

Return Value

The following values are populated in the GetCaseTimeAndExpensesResult object returned by the API method:

  • CaseTimeAndExpenses - Contains the sums and totals of time and expenses calculated before closing a Case.

Remarks

There are a number of bugs with the default Clarify close Case summation on the form. There are not sufficient fields defined in the close_case record for the graphical fields they show. Hence, the data doesn't always make sense. For example, the total phone time captured should be the total of the phone time captured for the Case and for all general subcases. But the GUI form points that field to the total for the phone logs captured for the Case (not showing the Subcase). Hence, this API defines the data as captured from the real data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


GetCaseTimeAndExpenses(GetCaseTimeAndExpensesSetup) Method | fcSDK Documentation

GetCaseTimeAndExpenses(GetCaseTimeAndExpensesSetup) Method

Setup object for API invocation.

Captures all the summed times (such as phone log time, billable and non-billable expense, etc) for a Case about to be closed. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function GetCaseTimeAndExpenses( _
   ByVal _setupParam_ As GetCaseTimeAndExpensesSetup _
) As GetCaseTimeAndExpensesResult

public GetCaseTimeAndExpensesResult GetCaseTimeAndExpenses(
   GetCaseTimeAndExpensesSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the GetCaseTimeAndExpensesResult object returned by the API method:

  • CaseTimeAndExpenses - Contains the sums and totals of time and expenses calculated before closing a Case.

Remarks

There are a number of bugs with the default Clarify close Case summation on the form. There are not sufficient fields defined in the close_case record for the graphical fields they show. Hence, the data doesn't always make sense. For example, the total phone time captured should be the total of the phone time captured for the Case and for all general subcases. But the GUI form points that field to the total for the phone logs captured for the Case (not showing the Subcase). Hence, this API defines the data as captured from the real data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
GetCaseTimeAndExpensesSetup Class


GetCaseTimeAndExpenses(GetCaseTimeAndExpensesSetup,IDbTransaction) Method | fcSDK Documentation

GetCaseTimeAndExpenses(GetCaseTimeAndExpensesSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Captures all the summed times (such as phone log time, billable and non-billable expense, etc) for a Case about to be closed. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function GetCaseTimeAndExpenses( _
   ByVal _setupParam_ As GetCaseTimeAndExpensesSetup, _
   ByVal _transaction_ As IDbTransaction _
) As GetCaseTimeAndExpensesResult

public GetCaseTimeAndExpensesResult GetCaseTimeAndExpenses(
   GetCaseTimeAndExpensesSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A GetCaseTimeAndExpensesResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

There are a number of bugs with the default Clarify close Case summation on the form. There are not sufficient fields defined in the close_case record for the graphical fields they show. Hence, the data doesn't always make sense. For example, the total phone time captured should be the total of the phone time captured for the Case and for all general subcases. But the GUI form points that field to the total for the phone logs captured for the Case (not showing the Subcase). Hence, this API defines the data as captured from the real data.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


GetSubcaseTimeAndExpenses Method | fcSDK Documentation

GetSubcaseTimeAndExpenses Method

Captures all the summed times (such as phone log time, billable and non-billable expense, etc) for a Subcase about to be closed. This overload takes a set of required parameters for the API.

Captures all the summed times (such as phone log time, billable and non-billable expense, etc) for a Subcase about to be closed.

Overload List

Overload | Description
GetSubcaseTimeAndExpenses(String) | Captures all the summed times (such as phone log time, billable and non-billable expense, etc) for a Subcase about to be closed. This overload takes a set of required parameters for the API.
GetSubcaseTimeAndExpenses(GetSubcaseTimeAndExpensesSetup) | Captures all the summed times (such as phone log time, billable and non-billable expense, etc) for a Subcase about to be closed. This overload takes a setup object.
GetSubcaseTimeAndExpenses(GetSubcaseTimeAndExpensesSetup,IDbTransaction) | Captures all the summed times (such as phone log time, billable and non-billable expense, etc) for a Subcase about to be closed. This overload takes a setup object and a database transaction.

Remarks

There are a number of bugs with the default Clarify close Case summation on the form. There are not sufficient fields defined in the close_case record for the graphical fields they show. Hence, the data doesn't always make sense. For example, the total phone time captured should be the total of the phone time captured for the Case and for all general subcases. But the GUI form points that field to the total for the phone logs captured for the Case (not showing the Subcase). Hence, this API defines the data as captured from the real data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
GetSubcaseTimeAndExpensesSetup Class


GetSubcaseTimeAndExpenses(String) Method | fcSDK Documentation

GetSubcaseTimeAndExpenses(String) Method

Subcase Identifier.

Captures all the summed times (such as phone log time, billable and non-billable expense, etc) for a Subcase about to be closed. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function GetSubcaseTimeAndExpenses( _
   ByVal _subcaseIDNum_ As String _
) As GetSubcaseTimeAndExpensesResult

public GetSubcaseTimeAndExpensesResult GetSubcaseTimeAndExpenses(
   string _subcaseIDNum_
)

Parameters

subcaseIDNum

Subcase Identifier.

Return Value

The following values are populated in the GetSubcaseTimeAndExpensesResult object returned by the API method:

  • SubcaseTimeAndExpenses - Contains the sums and totals calculated before closing a Case.

Remarks

There are a number of bugs with the default Clarify close Case summation on the form. There are not sufficient fields defined in the close_case record for the graphical fields they show. Hence, the data doesn't always make sense. For example, the total phone time captured should be the total of the phone time captured for the Case and for all general subcases. But the GUI form points that field to the total for the phone logs captured for the Case (not showing the Subcase). Hence, this API defines the data as captured from the real data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


GetSubcaseTimeAndExpenses(GetSubcaseTimeAndExpensesSetup) Method | fcSDK Documentation

GetSubcaseTimeAndExpenses(GetSubcaseTimeAndExpensesSetup) Method

Setup object for API invocation.

Captures all the summed times (such as phone log time, billable and non-billable expense, etc) for a Subcase about to be closed. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function GetSubcaseTimeAndExpenses( _
   ByVal _setupParam_ As GetSubcaseTimeAndExpensesSetup _
) As GetSubcaseTimeAndExpensesResult

public GetSubcaseTimeAndExpensesResult GetSubcaseTimeAndExpenses(
   GetSubcaseTimeAndExpensesSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the GetSubcaseTimeAndExpensesResult object returned by the API method:

  • SubcaseTimeAndExpenses - Contains the sums and totals calculated before closing a Case.

Remarks

There are a number of bugs with the default Clarify close Case summation on the form. There are not sufficient fields defined in the close_case record for the graphical fields they show. Hence, the data doesn't always make sense. For example, the total phone time captured should be the total of the phone time captured for the Case and for all general subcases. But the GUI form points that field to the total for the phone logs captured for the Case (not showing the Subcase). Hence, this API defines the data as captured from the real data.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
GetSubcaseTimeAndExpensesSetup Class


GetSubcaseTimeAndExpenses(GetSubcaseTimeAndExpensesSetup,IDbTransaction) Method | fcSDK Documentation

GetSubcaseTimeAndExpenses(GetSubcaseTimeAndExpensesSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Captures all the summed times (such as phone log time, billable and non-billable expense, etc) for a Subcase about to be closed. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function GetSubcaseTimeAndExpenses( _
   ByVal _setupParam_ As GetSubcaseTimeAndExpensesSetup, _
   ByVal _transaction_ As IDbTransaction _
) As GetSubcaseTimeAndExpensesResult

public GetSubcaseTimeAndExpensesResult GetSubcaseTimeAndExpenses(
   GetSubcaseTimeAndExpensesSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A GetSubcaseTimeAndExpensesResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

There are a number of bugs with the default Clarify close Case summation on the form. There are not sufficient fields defined in the close_case record for the graphical fields they show. Hence, the data doesn't always make sense. For example, the total phone time captured should be the total of the phone time captured for the Case and for all general subcases. But the GUI form points that field to the total for the phone logs captured for the Case (not showing the Subcase). Hence, this API defines the data as captured from the real data.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


InitialResponse Method | fcSDK Documentation

InitialResponse Method

Marks the initial response to a Case. This overload takes a set of required parameters for the API.

Marks the initial response to a Case.

Overload List

Overload | Description
InitialResponse(String) | Marks the initial response to a Case. This overload takes a set of required parameters for the API.
InitialResponse(InitialResponseSetup) | Marks the initial response to a Case. This overload takes a setup object.
InitialResponse(InitialResponseSetup,IDbTransaction) | Marks the initial response to a Case. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
InitialResponseSetup Class


InitialResponse(String) Method | fcSDK Documentation

InitialResponse(String) Method

Case Identifier.

Marks the initial response to a Case. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function InitialResponse( _
   ByVal _caseIDNum_ As String _
) As ToolkitResult

public ToolkitResult InitialResponse(
   string _caseIDNum_
)

Parameters

caseIDNum

Case Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


InitialResponse(InitialResponseSetup) Method | fcSDK Documentation

InitialResponse(InitialResponseSetup) Method

Setup object for API invocation.

Marks the initial response to a Case. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function InitialResponse( _
   ByVal _setupParam_ InitialResponseSetup _
) As ToolkitResult

public ToolkitResult InitialResponse(
   InitialResponseSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
InitialResponseSetup Class


InitialResponse(InitialResponseSetup,IDbTransaction) Method | fcSDK Documentation

InitialResponse(InitialResponseSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Marks the initial response to a Case. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function InitialResponse( _
   ByVal _setupParam_ As InitialResponseSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult InitialResponse(
   InitialResponseSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


LogCaseCommitment Method | fcSDK Documentation

LogCaseCommitment Method

Creates a commitment against a Case. This overload takes a set of required parameters for the API.

Creates a commitment against a Case.

Overload List

Overload | Description
LogCaseCommitment(String,String,TimeSpan,String,String,String) | Creates a commitment against a Case. This overload takes a set of required parameters for the API.
LogCaseCommitment(LogCaseCommitmentSetup) | Creates a commitment against a Case. This overload takes a setup object.
LogCaseCommitment(LogCaseCommitmentSetup,IDbTransaction) | Creates a commitment against a Case. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
LogCaseCommitmentSetup Class


LogCaseCommitment(String,String,TimeSpan,String,String,String) Method | fcSDK Documentation

LogCaseCommitment(String,String,TimeSpan,String,String,String) Method

Identifier of the Case against which the Committment is being logged.

Title of the commitment.

How long before the Commitment expires will the owner will be warned. If not set, no prior warning is given.

Contact's first name.

Contact's last name.

Contact's phone number.

Creates a commitment against a Case. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function LogCaseCommitment( _
   ByVal _caseIDNum_ As String, _
   ByVal _title_ As String, _
   ByVal _priorWarning_ As TimeSpan, _
   ByVal _contactFirstName_ As String, _
   ByVal _contactLastName_ As String, _
   ByVal _contactPhone_ As String _
) As ToolkitResult

public ToolkitResult LogCaseCommitment(
   string _caseIDNum_,
   string _title_,
   TimeSpan _priorWarning_,
   string _contactFirstName_,
   string _contactLastName_,
   string _contactPhone_
)

Parameters

caseIDNum

Identifier of the Case against which the Committment is being logged.

title

Title of the commitment.

priorWarning

How long before the Commitment expires will the owner will be warned. If not set, no prior warning is given.

contactFirstName

Contact's first name.

contactLastName

Contact's last name.

contactPhone

Contact's phone number.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Log.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


LogCaseCommitment(LogCaseCommitmentSetup) Method | fcSDK Documentation

LogCaseCommitment(LogCaseCommitmentSetup) Method

Setup object for API invocation.

Creates a commitment against a Case. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function LogCaseCommitment( _
   ByVal _setupParam_ LogCaseCommitmentSetup _
) As ToolkitResult

public ToolkitResult LogCaseCommitment(
   LogCaseCommitmentSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Log.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
LogCaseCommitmentSetup Class


LogCaseCommitment(LogCaseCommitmentSetup,IDbTransaction) Method | fcSDK Documentation

LogCaseCommitment(LogCaseCommitmentSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Creates a commitment against a Case. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function LogCaseCommitment( _
   ByVal _setupParam_ As LogCaseCommitmentSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult LogCaseCommitment(
   LogCaseCommitmentSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


LogCaseEmail Method | fcSDK Documentation

LogCaseEmail Method

Creates an email log against a Case. This overload takes a set of required parameters for the API.

Creates an email log against a Case.

Overload List

Overload | Description
LogCaseEmail(String) | Creates an email log against a Case. This overload takes a set of required parameters for the API.
LogCaseEmail(LogCaseEmailSetup) | Creates an email log against a Case. This overload takes a setup object.
LogCaseEmail(LogCaseEmailSetup,IDbTransaction) | Creates an email log against a Case. This overload takes a setup object and a database transaction.

Remarks

It is possible to create a Commitment with this log. To do so set the CommitmentDueDate and CommitmentTitle and IsCommitmentToCustomer properties. If a com_tmplte record with a title of "send_email_about_case" is found, it will be used to generate the email. If this template is not found, the email will be based on the "send_email_about_obj" template.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
LogCaseEmailSetup Class


LogCaseEmail(String) Method | fcSDK Documentation

LogCaseEmail(String) Method

Identifier of the Case against which the email is being logged.

Creates an email log against a Case. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function LogCaseEmail( _
   ByVal _caseIDNum_ As String _
) As LogCaseEmailResult

public LogCaseEmailResult LogCaseEmail(
   string _caseIDNum_
)

Parameters

caseIDNum

Identifier of the Case against which the email is being logged.

Return Value

The following values are populated in the LogCaseEmailResult object returned by the API method:

  • StatusChangeObjid - The Objid of the StatusChange.
  • Objid - The Objid of the Log.
  • CommitmentObjid - The Objid of the Commitment.

Remarks

It is possible to create a Commitment with this log. To do so set the CommitmentDueDate and CommitmentTitle and IsCommitmentToCustomer properties

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


LogCaseEmail(LogCaseEmailSetup) Method | fcSDK Documentation

LogCaseEmail(LogCaseEmailSetup) Method

Setup object for API invocation.

Creates an email log against a Case. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function LogCaseEmail( _
   ByVal _setupParam_ As LogCaseEmailSetup _
) As LogCaseEmailResult

public LogCaseEmailResult LogCaseEmail(
   LogCaseEmailSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the LogCaseEmailResult object returned by the API method:

  • CommitmentObjid - The Objid of the Commitment.
  • Objid - The Objid of the Log.
  • StatusChangeObjid - The Objid of the StatusChange.

Remarks

It is possible to create a Commitment with this log. To do so set the CommitmentDueDate and CommitmentTitle and IsCommitmentToCustomer properties

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
LogCaseEmailSetup Class


LogCaseEmail(LogCaseEmailSetup,IDbTransaction) Method | fcSDK Documentation

LogCaseEmail(LogCaseEmailSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Creates an email log against a Case. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function LogCaseEmail( _
   ByVal _setupParam_ As LogCaseEmailSetup, _
   ByVal _transaction_ As IDbTransaction _
) As LogCaseEmailResult

public LogCaseEmailResult LogCaseEmail(
   LogCaseEmailSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A LogCaseEmailResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

It is possible to create a Commitment with this log. To do so set the CommitmentDueDate and CommitmentTitle and IsCommitmentToCustomer properties

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


LogCaseEmailIn Method | fcSDK Documentation

LogCaseEmailIn Method

Creates an email in log against a Case.

Creates an email in log against a Case.

Overload List

Overload | Description
LogCaseEmailIn(LogCaseEmailInSetup) | Creates an email in log against a Case.
LogCaseEmailIn(LogCaseEmailInSetup,IDbTransaction) | Creates an email in log against a Case.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members


LogCaseEmailIn(LogCaseEmailInSetup) Method | fcSDK Documentation

LogCaseEmailIn(LogCaseEmailInSetup) Method

Setup object for API invocation.

Creates an email in log against a Case.

Syntax

'Declaration

Public Overloads Function LogCaseEmailIn( _
   ByVal _setup_ LogCaseEmailInSetup _
) As ToolkitResult

public ToolkitResult LogCaseEmailIn(
   LogCaseEmailInSetup _setup_
)

Parameters

setup

Setup object for API invocation.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


LogCaseEmailIn(LogCaseEmailInSetup,IDbTransaction) Method | fcSDK Documentation

LogCaseEmailIn(LogCaseEmailInSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Creates an email in log against a Case.

Syntax

'Declaration

Public Overloads Function LogCaseEmailIn( _
   ByVal _setup_ As LogCaseEmailInSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult LogCaseEmailIn(
   LogCaseEmailInSetup _setup_,
   IDbTransaction _transaction_
)

Parameters

setup

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


LogCaseInternalNote Method | fcSDK Documentation

LogCaseInternalNote Method

Overload List

Overload | Description
LogCaseInternalNote(String) |
LogCaseInternalNote(LogCaseInternalNoteSetup) |
LogCaseInternalNote(LogCaseInternalNoteSetup,IDbTransaction) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members


LogCaseInternalNote(String) Method | fcSDK Documentation

LogCaseInternalNote(String) Method

Syntax

'Declaration

Public Overloads Function LogCaseInternalNote( _
   ByVal _caseIDNum_ As String _
) As LogCaseNoteResult

public LogCaseNoteResult LogCaseInternalNote(
   string _caseIDNum_
)

Parameters

caseIDNum

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


LogCaseInternalNote(LogCaseInternalNoteSetup) Method | fcSDK Documentation

LogCaseInternalNote(LogCaseInternalNoteSetup) Method

Syntax

'Declaration

Public Overloads Function LogCaseInternalNote( _
   ByVal _setupParam_ As LogCaseInternalNoteSetup _
) As LogCaseNoteResult

public LogCaseNoteResult LogCaseInternalNote(
   LogCaseInternalNoteSetup _setupParam_
)

Parameters

setupParam

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


LogCaseInternalNote(LogCaseInternalNoteSetup,IDbTransaction) Method | fcSDK Documentation

LogCaseInternalNote(LogCaseInternalNoteSetup,IDbTransaction) Method

Syntax

'Declaration

Public Overloads Function LogCaseInternalNote( _
   ByVal _setupParam_ As LogCaseInternalNoteSetup, _
   ByVal _transaction_ As IDbTransaction _
) As LogCaseNoteResult

public LogCaseNoteResult LogCaseInternalNote(
   LogCaseInternalNoteSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

transaction

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


LogCaseInternalPhone Method | fcSDK Documentation

LogCaseInternalPhone Method

Overload List

Overload | Description
LogCaseInternalPhone(String,String,String,String) |
LogCaseInternalPhone(LogCaseInternalPhoneSetup) |
LogCaseInternalPhone(LogCaseInternalPhoneSetup,IDbTransaction) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members


LogCaseInternalPhone(String,String,String,String) Method | fcSDK Documentation

LogCaseInternalPhone(String,String,String,String) Method

Syntax

'Declaration

Public Overloads Function LogCaseInternalPhone( _
   ByVal _caseIDNum_ As String, _
   ByVal _contactFirstName_ As String, _
   ByVal _contactLastName_ As String, _
   ByVal _contactPhone_ As String _
) As LogCasePhoneResult

public LogCasePhoneResult LogCaseInternalPhone(
   string _caseIDNum_,
   string _contactFirstName_,
   string _contactLastName_,
   string _contactPhone_
)

Parameters

caseIDNum

contactFirstName

contactLastName

contactPhone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


LogCaseInternalPhone(LogCaseInternalPhoneSetup) Method | fcSDK Documentation

LogCaseInternalPhone(LogCaseInternalPhoneSetup) Method

Syntax

'Declaration

Public Overloads Function LogCaseInternalPhone( _
   ByVal _setupParam_ As LogCaseInternalPhoneSetup _
) As LogCasePhoneResult

public LogCasePhoneResult LogCaseInternalPhone(
   LogCaseInternalPhoneSetup _setupParam_
)

Parameters

setupParam

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


LogCaseInternalPhone(LogCaseInternalPhoneSetup,IDbTransaction) Method | fcSDK Documentation

LogCaseInternalPhone(LogCaseInternalPhoneSetup,IDbTransaction) Method

Syntax

'Declaration

Public Overloads Function LogCaseInternalPhone( _
   ByVal _setupParam_ As LogCaseInternalPhoneSetup, _
   ByVal _transaction_ As IDbTransaction _
) As LogCasePhoneResult

public LogCasePhoneResult LogCaseInternalPhone(
   LogCaseInternalPhoneSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

transaction

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


LogCaseNote Method | fcSDK Documentation

LogCaseNote Method

Creates a note log against a Case. This overload takes a set of required parameters for the API.

Creates a note log against a Case.

Overload List

Overload | Description
LogCaseNote(String) | Creates a note log against a Case. This overload takes a set of required parameters for the API.
LogCaseNote(LogCaseNoteSetup) | Creates a note log against a Case. This overload takes a setup object.
LogCaseNote(LogCaseNoteSetup,IDbTransaction) | Creates a note log against a Case. This overload takes a setup object and a database transaction.

Remarks

It is possible to create a Commitment with this log. To do so set the CommitmentDueDate and CommitmentTitle and IsCommitmentToCustomer properties.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
LogCaseNoteSetup Class


LogCaseNote(String) Method | fcSDK Documentation

LogCaseNote(String) Method

Identifier of the Case against which the note is being logged.

Creates a note log against a Case. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function LogCaseNote( _
   ByVal _caseIDNum_ As String _
) As LogCaseNoteResult

public LogCaseNoteResult LogCaseNote(
   string _caseIDNum_
)

Parameters

caseIDNum

Identifier of the Case against which the note is being logged.

Return Value

The following values are populated in the LogCaseNoteResult object returned by the API method:

  • Objid - The Objid of the Log.
  • StatusChangeObjid - The Objid of the StatusChange.
  • CommitmentObjid - The Objid of the Commitment.

Remarks

It is possible to create a Commitment with this log. To do so set the CommitmentDueDate and CommitmentTitle and IsCommitmentToCustomer properties.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


LogCaseNote(LogCaseNoteSetup) Method | fcSDK Documentation

LogCaseNote(LogCaseNoteSetup) Method

Setup object for API invocation.

Creates a note log against a Case. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function LogCaseNote( _
   ByVal _setupParam_ As LogCaseNoteSetup _
) As LogCaseNoteResult

public LogCaseNoteResult LogCaseNote(
   LogCaseNoteSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the LogCaseNoteResult object returned by the API method:

  • Objid - The Objid of the Log.
  • CommitmentObjid - The Objid of the Commitment.
  • StatusChangeObjid - The Objid of the StatusChange.

Remarks

It is possible to create a Commitment with this log. To do so set the CommitmentDueDate and CommitmentTitle and IsCommitmentToCustomer properties.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
LogCaseNoteSetup Class


LogCaseNote(LogCaseNoteSetup,IDbTransaction) Method | fcSDK Documentation

LogCaseNote(LogCaseNoteSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Creates a note log against a Case. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function LogCaseNote( _
   ByVal _setupParam_ As LogCaseNoteSetup, _
   ByVal _transaction_ As IDbTransaction _
) As LogCaseNoteResult

public LogCaseNoteResult LogCaseNote(
   LogCaseNoteSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A LogCaseNoteResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

It is possible to create a Commitment with this log. To do so set the CommitmentDueDate and CommitmentTitle and IsCommitmentToCustomer properties.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


LogCasePhone Method | fcSDK Documentation

LogCasePhone Method

Creates a phone log against a Case. This overload takes a set of required parameters for the API.

Creates a phone log against a Case.

Overload List

Overload | Description
LogCasePhone(String,String,String,String) | Creates a phone log against a Case. This overload takes a set of required parameters for the API.
LogCasePhone(LogCasePhoneSetup) | Creates a phone log against a Case. This overload takes a setup object.
LogCasePhone(LogCasePhoneSetup,IDbTransaction) | Creates a phone log against a Case. This overload takes a setup object and a database transaction.

Remarks

It is possible to create a Commitment with this log. To do so set the CommitmentDueDate and CommitmentTitle and IsCommitmentToCustomer properties.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
LogCasePhoneSetup Class


LogCasePhone(String,String,String,String) Method | fcSDK Documentation

LogCasePhone(String,String,String,String) Method

Identifier of the Case against which the phone note is being logged.

Contact's first name.

Contact's last name.

Contact's phone number.

Creates a phone log against a Case. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function LogCasePhone( _
   ByVal _caseIDNum_ As String, _
   ByVal _contactFirstName_ As String, _
   ByVal _contactLastName_ As String, _
   ByVal _contactPhone_ As String _
) As LogCasePhoneResult

public LogCasePhoneResult LogCasePhone(
   string _caseIDNum_,
   string _contactFirstName_,
   string _contactLastName_,
   string _contactPhone_
)

Parameters

caseIDNum

Identifier of the Case against which the phone note is being logged.

contactFirstName

Contact's first name.

contactLastName

Contact's last name.

contactPhone

Contact's phone number.

Return Value

The following values are populated in the LogCasePhoneResult object returned by the API method:

  • CommitmentObjid - The Objid of the Commitment.
  • Objid - The Objid of the Log.
  • StatusChangeObjid - The Objid of the StatusChange.

Remarks

It is possible to create a Commitment with this log. To do so set the CommitmentDueDate and CommitmentTitle and IsCommitmentToCustomer properties.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


LogCasePhone(LogCasePhoneSetup) Method | fcSDK Documentation

LogCasePhone(LogCasePhoneSetup) Method

Setup object for API invocation.

Creates a phone log against a Case. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function LogCasePhone( _
   ByVal _setupParam_ As LogCasePhoneSetup _
) As LogCasePhoneResult

public LogCasePhoneResult LogCasePhone(
   LogCasePhoneSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the LogCasePhoneResult object returned by the API method:

  • CommitmentObjid - The Objid of the Commitment.
  • StatusChangeObjid - The Objid of the StatusChange.
  • Objid - The Objid of the Log.

Remarks

It is possible to create a Commitment with this log. To do so set the CommitmentDueDate and CommitmentTitle and IsCommitmentToCustomer properties.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
LogCasePhoneSetup Class


LogCasePhone(LogCasePhoneSetup,IDbTransaction) Method | fcSDK Documentation

LogCasePhone(LogCasePhoneSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Creates a phone log against a Case. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function LogCasePhone( _
   ByVal _setupParam_ As LogCasePhoneSetup, _
   ByVal _transaction_ As IDbTransaction _
) As LogCasePhoneResult

public LogCasePhoneResult LogCasePhone(
   LogCasePhoneSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A LogCasePhoneResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

It is possible to create a Commitment with this log. To do so set the CommitmentDueDate and CommitmentTitle and IsCommitmentToCustomer properties.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


LogCaseResearch Method | fcSDK Documentation

LogCaseResearch Method

Creates a research log against a Case. This overload takes a set of required parameters for the API.

Creates a research log against a Case.

Overload List

Overload | Description
LogCaseResearch(String,TimeSpan) | Creates a research log against a Case. This overload takes a set of required parameters for the API.
LogCaseResearch(LogCaseResearchSetup) | Creates a research log against a Case. This overload takes a setup object.
LogCaseResearch(LogCaseResearchSetup,IDbTransaction) | Creates a research log against a Case. This overload takes a setup object and a database transaction.

Remarks

It is possible to create a Commitment with this log. To do so set the CommitmentDueDate and CommitmentTitle and IsCommitmentToCustomer properties

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
LogCaseResearchSetup Class


LogCaseResearch(String,TimeSpan) Method | fcSDK Documentation

LogCaseResearch(String,TimeSpan) Method

Identifier of the Case against which the research note is being logged.

The length of time for research.

Creates a research log against a Case. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function LogCaseResearch( _
   ByVal _caseIDNum_ As String, _
   ByVal _researchDuration_ As TimeSpan _
) As LogCaseResearchResult

public LogCaseResearchResult LogCaseResearch(
   string _caseIDNum_,
   TimeSpan _researchDuration_
)

Parameters

caseIDNum

Identifier of the Case against which the research note is being logged.

researchDuration

The length of time for research.

Return Value

The following values are populated in the LogCaseResearchResult object returned by the API method:

  • Objid - The Objid of the Log.
  • CommitmentObjid - The Objid of the Commitment.
  • StatusChangeObjid - The Objid of the StatusChange.

Remarks

It is possible to create a Commitment with this log. To do so set the CommitmentDueDate and CommitmentTitle and IsCommitmentToCustomer properties

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


LogCaseResearch(LogCaseResearchSetup) Method | fcSDK Documentation

LogCaseResearch(LogCaseResearchSetup) Method

Setup object for API invocation.

Creates a research log against a Case. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function LogCaseResearch( _
   ByVal _setupParam_ As LogCaseResearchSetup _
) As LogCaseResearchResult

public LogCaseResearchResult LogCaseResearch(
   LogCaseResearchSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the LogCaseResearchResult object returned by the API method:

  • Objid - The Objid of the Log.
  • StatusChangeObjid - The Objid of the StatusChange.
  • CommitmentObjid - The Objid of the Commitment.

Remarks

It is possible to create a Commitment with this log. To do so set the CommitmentDueDate and CommitmentTitle and IsCommitmentToCustomer properties

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
LogCaseResearchSetup Class


LogCaseResearch(LogCaseResearchSetup,IDbTransaction) Method | fcSDK Documentation

LogCaseResearch(LogCaseResearchSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Creates a research log against a Case. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function LogCaseResearch( _
   ByVal _setupParam_ As LogCaseResearchSetup, _
   ByVal _transaction_ As IDbTransaction _
) As LogCaseResearchResult

public LogCaseResearchResult LogCaseResearch(
   LogCaseResearchSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A LogCaseResearchResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

It is possible to create a Commitment with this log. To do so set the CommitmentDueDate and CommitmentTitle and IsCommitmentToCustomer properties

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


LogSubcaseCommitment Method | fcSDK Documentation

LogSubcaseCommitment Method

Creates a commitment against a Subcase. This overload takes a set of required parameters for the API.

Creates a commitment against a Subcase.

Overload List

Overload | Description
LogSubcaseCommitment(String,String,TimeSpan,String,String,String) | Creates a commitment against a Subcase. This overload takes a set of required parameters for the API.
LogSubcaseCommitment(LogSubcaseCommitmentSetup) | Creates a commitment against a Subcase. This overload takes a setup object.
LogSubcaseCommitment(LogSubcaseCommitmentSetup,IDbTransaction) | Creates a commitment against a Subcase. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
LogSubcaseCommitmentSetup Class


LogSubcaseCommitment(String,String,TimeSpan,String,String,String) Method | fcSDK Documentation

LogSubcaseCommitment(String,String,TimeSpan,String,String,String) Method

Identifier of the Subcase against which the commitment is being logged.

Title of the commitment.

The length of time preceding the commitment expiration in which the owner will be warned. If not set, no prior warning is given.

Contact's first name.

Contact's last name.

Contact's phone number.

Creates a commitment against a Subcase. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function LogSubcaseCommitment( _
   ByVal _subcaseIDNum_ As String, _
   ByVal _title_ As String, _
   ByVal _priorWarning_ As TimeSpan, _
   ByVal _contactFirstName_ As String, _
   ByVal _contactLastName_ As String, _
   ByVal _contactPhone_ As String _
) As ToolkitResult

public ToolkitResult LogSubcaseCommitment(
   string _subcaseIDNum_,
   string _title_,
   TimeSpan _priorWarning_,
   string _contactFirstName_,
   string _contactLastName_,
   string _contactPhone_
)

Parameters

subcaseIDNum

Identifier of the Subcase against which the commitment is being logged.

title

Title of the commitment.

priorWarning

The length of time preceding the commitment expiration in which the owner will be warned. If not set, no prior warning is given.

contactFirstName

Contact's first name.

contactLastName

Contact's last name.

contactPhone

Contact's phone number.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Log.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


LogSubcaseCommitment(LogSubcaseCommitmentSetup) Method | fcSDK Documentation

LogSubcaseCommitment(LogSubcaseCommitmentSetup) Method

Setup object for API invocation.

Creates a commitment against a Subcase. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function LogSubcaseCommitment( _
   ByVal _setupParam_ LogSubcaseCommitmentSetup _
) As ToolkitResult

public ToolkitResult LogSubcaseCommitment(
   LogSubcaseCommitmentSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the ToolkitResult object returned by the API method:

  • Objid - The Objid of the Log.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
LogSubcaseCommitmentSetup Class


LogSubcaseCommitment(LogSubcaseCommitmentSetup,IDbTransaction) Method | fcSDK Documentation

LogSubcaseCommitment(LogSubcaseCommitmentSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Creates a commitment against a Subcase. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function LogSubcaseCommitment( _
   ByVal _setupParam_ As LogSubcaseCommitmentSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult LogSubcaseCommitment(
   LogSubcaseCommitmentSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


LogSubcaseEmail Method | fcSDK Documentation

LogSubcaseEmail Method

Creates an email log against a Subcase. This overload takes a set of required parameters for the API.

Creates an email log against a Subcase.

Overload List

Overload | Description
LogSubcaseEmail(String) | Creates an email log against a Subcase. This overload takes a set of required parameters for the API.
LogSubcaseEmail(LogSubcaseEmailSetup) | Creates an email log against a Subcase. This overload takes a setup object.
LogSubcaseEmail(LogSubcaseEmailSetup,IDbTransaction) | Creates an email log against a Subcase. This overload takes a setup object and a database transaction.

Remarks

It is possible to create a Commitment with this log. To do so set the CommitmentDueDate and CommitmentTitle and IsCommitmentToCustomer properties. If a com_tmplte record with a title of "send_email_about_subcase" is found, it will be used to generate the email. If this template is not found, the email will be based on the "send_email_about_obj" template.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
LogSubcaseEmailSetup Class


LogSubcaseEmail(String) Method | fcSDK Documentation

LogSubcaseEmail(String) Method

Identifier of the Subcase against which the email is being logged.

Creates an email log against a Subcase. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function LogSubcaseEmail( _
   ByVal _subcaseIDNum_ As String _
) As LogSubcaseEmailResult

public LogSubcaseEmailResult LogSubcaseEmail(
   string _subcaseIDNum_
)

Parameters

subcaseIDNum

Identifier of the Subcase against which the email is being logged.

Return Value

The following values are populated in the LogSubcaseEmailResult object returned by the API method:

  • CommitmentObjid - The Objid of the Commitment.
  • StatusChangeObjid - The Objid of the StatusChange.
  • Objid - The Objid of the Log.

Remarks

It is possible to create a Commitment with this log. To do so set the CommitmentDueDate and CommitmentTitle and IsCommitmentToCustomer properties

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


LogSubcaseEmail(LogSubcaseEmailSetup) Method | fcSDK Documentation

LogSubcaseEmail(LogSubcaseEmailSetup) Method

Setup object for API invocation.

Creates an email log against a Subcase. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function LogSubcaseEmail( _
   ByVal _setupParam_ As LogSubcaseEmailSetup _
) As LogSubcaseEmailResult

public LogSubcaseEmailResult LogSubcaseEmail(
   LogSubcaseEmailSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the LogSubcaseEmailResult object returned by the API method:

  • CommitmentObjid - The Objid of the Commitment.
  • Objid - The Objid of the Log.
  • StatusChangeObjid - The Objid of the StatusChange.

Remarks

It is possible to create a Commitment with this log. To do so set the CommitmentDueDate and CommitmentTitle and IsCommitmentToCustomer properties

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
LogSubcaseEmailSetup Class


LogSubcaseEmail(LogSubcaseEmailSetup,IDbTransaction) Method | fcSDK Documentation

LogSubcaseEmail(LogSubcaseEmailSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Creates an email log against a Subcase. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function LogSubcaseEmail( _
   ByVal _setupParam_ As LogSubcaseEmailSetup, _
   ByVal _transaction_ As IDbTransaction _
) As LogSubcaseEmailResult

public LogSubcaseEmailResult LogSubcaseEmail(
   LogSubcaseEmailSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A LogSubcaseEmailResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

It is possible to create a Commitment with this log. To do so set the CommitmentDueDate and CommitmentTitle and IsCommitmentToCustomer properties

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


LogSubCaseEmailIn Method | fcSDK Documentation

LogSubCaseEmailIn Method

Creates an email in log against a Subcase.

Creates an email in log against a Subcase.

Overload List

Overload | Description
LogSubCaseEmailIn(LogSubCaseEmailInSetup) | Creates an email in log against a Subcase.
LogSubCaseEmailIn(LogSubCaseEmailInSetup,IDbTransaction) | Creates an email in log against a Subcase.

Exceptions

Exception | Description
[New Item] |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members


LogSubCaseEmailIn(LogSubCaseEmailInSetup) Method | fcSDK Documentation

LogSubCaseEmailIn(LogSubCaseEmailInSetup) Method

Setup object for API invocation.

Creates an email in log against a Subcase.

Syntax

'Declaration

Public Overloads Function LogSubCaseEmailIn( _
   ByVal _setup_ LogSubCaseEmailInSetup _
) As ToolkitResult

public ToolkitResult LogSubCaseEmailIn(
   LogSubCaseEmailInSetup _setup_
)

Parameters

setup

Setup object for API invocation.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


LogSubCaseEmailIn(LogSubCaseEmailInSetup,IDbTransaction) Method | fcSDK Documentation

LogSubCaseEmailIn(LogSubCaseEmailInSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Creates an email in log against a Subcase.

Syntax

'Declaration

Public Overloads Function LogSubCaseEmailIn( _
   ByVal _setup_ As LogSubCaseEmailInSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult LogSubCaseEmailIn(
   LogSubCaseEmailInSetup _setup_,
   IDbTransaction _transaction_
)

Parameters

setup

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


LogSubcaseInternalNote Method | fcSDK Documentation

LogSubcaseInternalNote Method

Overload List

Overload | Description
LogSubcaseInternalNote(String) |
LogSubcaseInternalNote(LogSubcaseInternalNoteSetup) |
LogSubcaseInternalNote(LogSubcaseInternalNoteSetup,IDbTransaction) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members


LogSubcaseInternalNote(String) Method | fcSDK Documentation

LogSubcaseInternalNote(String) Method

Syntax

'Declaration

Public Overloads Function LogSubcaseInternalNote( _
   ByVal _subcaseIDNum_ As String _
) As LogSubcaseNoteResult

public LogSubcaseNoteResult LogSubcaseInternalNote(
   string _subcaseIDNum_
)

Parameters

subcaseIDNum

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


LogSubcaseInternalNote(LogSubcaseInternalNoteSetup) Method | fcSDK Documentation

LogSubcaseInternalNote(LogSubcaseInternalNoteSetup) Method

Syntax

'Declaration

Public Overloads Function LogSubcaseInternalNote( _
   ByVal _setupParam_ As LogSubcaseInternalNoteSetup _
) As LogSubcaseNoteResult

public LogSubcaseNoteResult LogSubcaseInternalNote(
   LogSubcaseInternalNoteSetup _setupParam_
)

Parameters

setupParam

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


LogSubcaseInternalNote(LogSubcaseInternalNoteSetup,IDbTransaction) Method | fcSDK Documentation

LogSubcaseInternalNote(LogSubcaseInternalNoteSetup,IDbTransaction) Method

Syntax

'Declaration

Public Overloads Function LogSubcaseInternalNote( _
   ByVal _setupParam_ As LogSubcaseInternalNoteSetup, _
   ByVal _transaction_ As IDbTransaction _
) As LogSubcaseNoteResult

public LogSubcaseNoteResult LogSubcaseInternalNote(
   LogSubcaseInternalNoteSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

transaction

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


LogSubcaseInternalPhone Method | fcSDK Documentation

LogSubcaseInternalPhone Method

Overload List

Overload | Description
LogSubcaseInternalPhone(String,String,String,String) |
LogSubcaseInternalPhone(LogSubcaseInternalPhoneSetup) |
LogSubcaseInternalPhone(LogSubcaseInternalPhoneSetup,IDbTransaction) |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members


LogSubcaseInternalPhone(String,String,String,String) Method | fcSDK Documentation

LogSubcaseInternalPhone(String,String,String,String) Method

Syntax

'Declaration

Public Overloads Function LogSubcaseInternalPhone( _
   ByVal _subcaseIDNum_ As String, _
   ByVal _contactFirstName_ As String, _
   ByVal _contactLastName_ As String, _
   ByVal _contactPhone_ As String _
) As LogSubcasePhoneResult

public LogSubcasePhoneResult LogSubcaseInternalPhone(
   string _subcaseIDNum_,
   string _contactFirstName_,
   string _contactLastName_,
   string _contactPhone_
)

Parameters

subcaseIDNum

contactFirstName

contactLastName

contactPhone

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


LogSubcaseInternalPhone(LogSubcaseInternalPhoneSetup) Method | fcSDK Documentation

LogSubcaseInternalPhone(LogSubcaseInternalPhoneSetup) Method

Syntax

'Declaration

Public Overloads Function LogSubcaseInternalPhone( _
   ByVal _setupParam_ As LogSubcaseInternalPhoneSetup _
) As LogSubcasePhoneResult

public LogSubcasePhoneResult LogSubcaseInternalPhone(
   LogSubcaseInternalPhoneSetup _setupParam_
)

Parameters

setupParam

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


LogSubcaseInternalPhone(LogSubcaseInternalPhoneSetup,IDbTransaction) Method | fcSDK Documentation

LogSubcaseInternalPhone(LogSubcaseInternalPhoneSetup,IDbTransaction) Method

Syntax

'Declaration

Public Overloads Function LogSubcaseInternalPhone( _
   ByVal _setupParam_ As LogSubcaseInternalPhoneSetup, _
   ByVal _transaction_ As IDbTransaction _
) As LogSubcasePhoneResult

public LogSubcasePhoneResult LogSubcaseInternalPhone(
   LogSubcaseInternalPhoneSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

transaction

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


LogSubcaseNote Method | fcSDK Documentation

LogSubcaseNote Method

Creates a note log against a Subcase. This overload takes a set of required parameters for the API.

Creates a note log against a Subcase.

Overload List

Overload | Description
LogSubcaseNote(String) | Creates a note log against a Subcase. This overload takes a set of required parameters for the API.
LogSubcaseNote(LogSubcaseNoteSetup) | Creates a note log against a Subcase. This overload takes a setup object.
LogSubcaseNote(LogSubcaseNoteSetup,IDbTransaction) | Creates a note log against a Subcase. This overload takes a setup object and a database transaction.

Remarks

It is possible to create a Commitment with this log. To do so set the CommitmentDueDate and CommitmentTitle and IsCommitmentToCustomer properties

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
LogSubcaseNoteSetup Class


LogSubcaseNote(String) Method | fcSDK Documentation

LogSubcaseNote(String) Method

Identifier of the Subcase against which the note is being logged.

Creates a note log against a Subcase. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function LogSubcaseNote( _
   ByVal _subcaseIDNum_ As String _
) As LogSubcaseNoteResult

public LogSubcaseNoteResult LogSubcaseNote(
   string _subcaseIDNum_
)

Parameters

subcaseIDNum

Identifier of the Subcase against which the note is being logged.

Return Value

The following values are populated in the LogSubcaseNoteResult object returned by the API method:

  • StatusChangeObjid - The Objid of the StatusChange.
  • CommitmentObjid - The Objid of the Commitment.
  • Objid - The Objid of the Log.

Remarks

It is possible to create a Commitment with this log. To do so set the CommitmentDueDate and CommitmentTitle and IsCommitmentToCustomer properties

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


LogSubcaseNote(LogSubcaseNoteSetup) Method | fcSDK Documentation

LogSubcaseNote(LogSubcaseNoteSetup) Method

Setup object for API invocation.

Creates a note log against a Subcase. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function LogSubcaseNote( _
   ByVal _setupParam_ As LogSubcaseNoteSetup _
) As LogSubcaseNoteResult

public LogSubcaseNoteResult LogSubcaseNote(
   LogSubcaseNoteSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the LogSubcaseNoteResult object returned by the API method:

  • Objid - The Objid of the Log.
  • CommitmentObjid - The Objid of the Commitment.
  • StatusChangeObjid - The Objid of the StatusChange.

Remarks

It is possible to create a Commitment with this log. To do so set the CommitmentDueDate and CommitmentTitle and IsCommitmentToCustomer properties

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
LogSubcaseNoteSetup Class


LogSubcaseNote(LogSubcaseNoteSetup,IDbTransaction) Method | fcSDK Documentation

LogSubcaseNote(LogSubcaseNoteSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Creates a note log against a Subcase. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function LogSubcaseNote( _
   ByVal _setupParam_ As LogSubcaseNoteSetup, _
   ByVal _transaction_ As IDbTransaction _
) As LogSubcaseNoteResult

public LogSubcaseNoteResult LogSubcaseNote(
   LogSubcaseNoteSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A LogSubcaseNoteResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

It is possible to create a Commitment with this log. To do so set the CommitmentDueDate and CommitmentTitle and IsCommitmentToCustomer properties

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


LogSubcasePhone Method | fcSDK Documentation

LogSubcasePhone Method

Creates a phone log against a Subcase. This overload takes a set of required parameters for the API.

Creates a phone log against a Subcase.

Overload List

Overload | Description
LogSubcasePhone(String,String,String,String) | Creates a phone log against a Subcase. This overload takes a set of required parameters for the API.
LogSubcasePhone(LogSubcasePhoneSetup) | Creates a phone log against a Subcase. This overload takes a setup object.
LogSubcasePhone(LogSubcasePhoneSetup,IDbTransaction) | Creates a phone log against a Subcase. This overload takes a setup object and a database transaction.

Remarks

It is possible to create a Commitment with this log. To do so set the CommitmentDueDate and CommitmentTitle and IsCommitmentToCustomer properties

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
LogSubcasePhoneSetup Class


LogSubcasePhone(String,String,String,String) Method | fcSDK Documentation

LogSubcasePhone(String,String,String,String) Method

Identifier of the Subcase against which the phone note is being logged.

Contact's first name.

Contact's last name.

Contact's phone number.

Creates a phone log against a Subcase. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function LogSubcasePhone( _
   ByVal _subcaseIDNum_ As String, _
   ByVal _contactFirstName_ As String, _
   ByVal _contactLastName_ As String, _
   ByVal _contactPhone_ As String _
) As LogSubcasePhoneResult

public LogSubcasePhoneResult LogSubcasePhone(
   string _subcaseIDNum_,
   string _contactFirstName_,
   string _contactLastName_,
   string _contactPhone_
)

Parameters

subcaseIDNum

Identifier of the Subcase against which the phone note is being logged.

contactFirstName

Contact's first name.

contactLastName

Contact's last name.

contactPhone

Contact's phone number.

Return Value

The following values are populated in the LogSubcasePhoneResult object returned by the API method:

  • Objid - The Objid of the Log.
  • CommitmentObjid - The Objid of the Commitment.
  • StatusChangeObjid - The Objid of the StatusChange.

Remarks

It is possible to create a Commitment with this log. To do so set the CommitmentDueDate and CommitmentTitle and IsCommitmentToCustomer properties

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


LogSubcasePhone(LogSubcasePhoneSetup) Method | fcSDK Documentation

LogSubcasePhone(LogSubcasePhoneSetup) Method

Setup object for API invocation.

Creates a phone log against a Subcase. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function LogSubcasePhone( _
   ByVal _setupParam_ As LogSubcasePhoneSetup _
) As LogSubcasePhoneResult

public LogSubcasePhoneResult LogSubcasePhone(
   LogSubcasePhoneSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the LogSubcasePhoneResult object returned by the API method:

  • Objid - The Objid of the Log.
  • StatusChangeObjid - The Objid of the StatusChange.
  • CommitmentObjid - The Objid of the Commitment.

Remarks

It is possible to create a Commitment with this log. To do so set the CommitmentDueDate and CommitmentTitle and IsCommitmentToCustomer properties

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
LogSubcasePhoneSetup Class


LogSubcasePhone(LogSubcasePhoneSetup,IDbTransaction) Method | fcSDK Documentation

LogSubcasePhone(LogSubcasePhoneSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Creates a phone log against a Subcase. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function LogSubcasePhone( _
   ByVal _setupParam_ As LogSubcasePhoneSetup, _
   ByVal _transaction_ As IDbTransaction _
) As LogSubcasePhoneResult

public LogSubcasePhoneResult LogSubcasePhone(
   LogSubcasePhoneSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A LogSubcasePhoneResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

It is possible to create a Commitment with this log. To do so set the CommitmentDueDate and CommitmentTitle and IsCommitmentToCustomer properties

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


LogSubcaseResearch Method | fcSDK Documentation

LogSubcaseResearch Method

Creates a research log against a Subcase. This overload takes a set of required parameters for the API.

Creates a research log against a Subcase.

Overload List

Overload | Description
LogSubcaseResearch(String,TimeSpan) | Creates a research log against a Subcase. This overload takes a set of required parameters for the API.
LogSubcaseResearch(LogSubcaseResearchSetup) | Creates a research log against a Subcase. This overload takes a setup object.
LogSubcaseResearch(LogSubcaseResearchSetup,IDbTransaction) | Creates a research log against a Subcase. This overload takes a setup object and a database transaction.

Remarks

It is possible to create a Commitment with this log. To do so set the CommitmentDueDate and CommitmentTitle and IsCommitmentToCustomer properties

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
LogSubcaseResearchSetup Class


LogSubcaseResearch(String,TimeSpan) Method | fcSDK Documentation

LogSubcaseResearch(String,TimeSpan) Method

Identifier of the Subcase against which the research note is being logged.

The length of time for research.

Creates a research log against a Subcase. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function LogSubcaseResearch( _
   ByVal _subcaseIDNum_ As String, _
   ByVal _researchDuration_ As TimeSpan _
) As LogSubcaseResearchResult

public LogSubcaseResearchResult LogSubcaseResearch(
   string _subcaseIDNum_,
   TimeSpan _researchDuration_
)

Parameters

subcaseIDNum

Identifier of the Subcase against which the research note is being logged.

researchDuration

The length of time for research.

Return Value

The following values are populated in the LogSubcaseResearchResult object returned by the API method:

  • CommitmentObjid - The Objid of the Commitment.
  • StatusChangeObjid - The Objid of the StatusChange.
  • Objid - The Objid of the Log.

Remarks

It is possible to create a Commitment with this log. To do so set the CommitmentDueDate and CommitmentTitle and IsCommitmentToCustomer properties

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


LogSubcaseResearch(LogSubcaseResearchSetup) Method | fcSDK Documentation

LogSubcaseResearch(LogSubcaseResearchSetup) Method

Setup object for API invocation.

Creates a research log against a Subcase. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function LogSubcaseResearch( _
   ByVal _setupParam_ As LogSubcaseResearchSetup _
) As LogSubcaseResearchResult

public LogSubcaseResearchResult LogSubcaseResearch(
   LogSubcaseResearchSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

The following values are populated in the LogSubcaseResearchResult object returned by the API method:

  • StatusChangeObjid - The Objid of the StatusChange.
  • CommitmentObjid - The Objid of the Commitment.
  • Objid - The Objid of the Log.

Remarks

It is possible to create a Commitment with this log. To do so set the CommitmentDueDate and CommitmentTitle and IsCommitmentToCustomer properties

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
LogSubcaseResearchSetup Class


LogSubcaseResearch(LogSubcaseResearchSetup,IDbTransaction) Method | fcSDK Documentation

LogSubcaseResearch(LogSubcaseResearchSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Creates a research log against a Subcase. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function LogSubcaseResearch( _
   ByVal _setupParam_ As LogSubcaseResearchSetup, _
   ByVal _transaction_ As IDbTransaction _
) As LogSubcaseResearchResult

public LogSubcaseResearchResult LogSubcaseResearch(
   LogSubcaseResearchSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A LogSubcaseResearchResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

It is possible to create a Commitment with this log. To do so set the CommitmentDueDate and CommitmentTitle and IsCommitmentToCustomer properties

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


MoveCase Method | fcSDK Documentation

MoveCase Method

Move the Case from one WipBin to another WipBin. This overload takes a set of required parameters for the API.

Move the Case from one WipBin to another WipBin.

Overload List

Overload | Description
MoveCase(String,String) | Move the Case from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
MoveCase(MoveCaseSetup) | Move the Case from one WipBin to another WipBin. This overload takes a setup object.
MoveCase(MoveCaseSetup,IDbTransaction) | Move the Case from one WipBin to another WipBin. This overload takes a setup object and a database transaction.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the Case, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
MoveCaseSetup Class


MoveCase(String,String) Method | fcSDK Documentation

MoveCase(String,String) Method

Case Identifier.

The new WipBin into which the Case is to be moved.

Move the Case from one WipBin to another WipBin. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function MoveCase( _
   ByVal _caseIDNum_ As String, _
   ByVal _newWipBin_ As String _
) As ToolkitResult

public ToolkitResult MoveCase(
   string _caseIDNum_,
   string _newWipBin_
)

Parameters

caseIDNum

Case Identifier.

newWipBin

The new WipBin into which the Case is to be moved.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the Case, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


MoveCase(MoveCaseSetup) Method | fcSDK Documentation

MoveCase(MoveCaseSetup) Method

Setup object for API invocation.

Move the Case from one WipBin to another WipBin. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function MoveCase( _
   ByVal _setupParam_ MoveCaseSetup _
) As ToolkitResult

public ToolkitResult MoveCase(
   MoveCaseSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the Case, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
MoveCaseSetup Class


MoveCase(MoveCaseSetup,IDbTransaction) Method | fcSDK Documentation

MoveCase(MoveCaseSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Move the Case from one WipBin to another WipBin. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function MoveCase( _
   ByVal _setupParam_ As MoveCaseSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult MoveCase(
   MoveCaseSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the Case, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


MoveSubcase Method | fcSDK Documentation

MoveSubcase Method

Move the Subcase from one WipBin to another WipBin. This overload takes a set of required parameters for the API.

Move the Subcase from one WipBin to another WipBin.

Overload List

Overload | Description
MoveSubcase(String,String) | Move the Subcase from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
MoveSubcase(MoveSubcaseSetup) | Move the Subcase from one WipBin to another WipBin. This overload takes a setup object.
MoveSubcase(MoveSubcaseSetup,IDbTransaction) | Move the Subcase from one WipBin to another WipBin. This overload takes a setup object and a database transaction.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the Subcase, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
MoveSubcaseSetup Class


MoveSubcase(String,String) Method | fcSDK Documentation

MoveSubcase(String,String) Method

Subcase Identifier.

The new WipBin into which the Subcase is to be moved.

Move the Subcase from one WipBin to another WipBin. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function MoveSubcase( _
   ByVal _subcaseIDNum_ As String, _
   ByVal _newWipBin_ As String _
) As ToolkitResult

public ToolkitResult MoveSubcase(
   string _subcaseIDNum_,
   string _newWipBin_
)

Parameters

subcaseIDNum

Subcase Identifier.

newWipBin

The new WipBin into which the Subcase is to be moved.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the Subcase, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


MoveSubcase(MoveSubcaseSetup) Method | fcSDK Documentation

MoveSubcase(MoveSubcaseSetup) Method

Setup object for API invocation.

Move the Subcase from one WipBin to another WipBin. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function MoveSubcase( _
   ByVal _setupParam_ MoveSubcaseSetup _
) As ToolkitResult

public ToolkitResult MoveSubcase(
   MoveSubcaseSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the Subcase, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
MoveSubcaseSetup Class


MoveSubcase(MoveSubcaseSetup,IDbTransaction) Method | fcSDK Documentation

MoveSubcase(MoveSubcaseSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Move the Subcase from one WipBin to another WipBin. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function MoveSubcase( _
   ByVal _setupParam_ As MoveSubcaseSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult MoveSubcase(
   MoveSubcaseSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The new WipBin must belong to the same user as the first WipBin. The move operation does not change the ownership of the Subcase, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WipBin to another, even if the object is currently dispatched. Since WipBins are internal to a user, there really is no reason that you shouldn’t be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


RejectCase Method | fcSDK Documentation

RejectCase Method

Reject the Case from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.

Reject the Case from the queue in which it currently resides, and return it to the owner.

Overload List

Overload | Description
RejectCase(String) | Reject the Case from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.
RejectCase(RejectCaseSetup) | Reject the Case from the queue in which it currently resides, and return it to the owner. This overload takes a setup object.
RejectCase(RejectCaseSetup,IDbTransaction) | Reject the Case from the queue in which it currently resides, and return it to the owner. This overload takes a setup object and a database transaction.

Remarks

The Case must be in open condition, and currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
RejectCaseSetup Class


RejectCase(String) Method | fcSDK Documentation

RejectCase(String) Method

Case Identifier.

Reject the Case from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function RejectCase( _
   ByVal _caseIDNum_ As String _
) As ToolkitResult

public ToolkitResult RejectCase(
   string _caseIDNum_
)

Parameters

caseIDNum

Case Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Case must be in open condition, and currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


RejectCase(RejectCaseSetup) Method | fcSDK Documentation

RejectCase(RejectCaseSetup) Method

Setup object for API invocation.

Reject the Case from the queue in which it currently resides, and return it to the owner. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function RejectCase( _
   ByVal _setupParam_ RejectCaseSetup _
) As ToolkitResult

public ToolkitResult RejectCase(
   RejectCaseSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Case must be in open condition, and currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
RejectCaseSetup Class


RejectCase(RejectCaseSetup,IDbTransaction) Method | fcSDK Documentation

RejectCase(RejectCaseSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Reject the Case from the queue in which it currently resides, and return it to the owner. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function RejectCase( _
   ByVal _setupParam_ As RejectCaseSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult RejectCase(
   RejectCaseSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Case must be in open condition, and currently dispatched to a queue.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


RejectSubcase Method | fcSDK Documentation

RejectSubcase Method

Reject the Subcase from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.

Reject the Subcase from the queue in which it currently resides, and return it to the owner.

Overload List

Overload | Description
RejectSubcase(String) | Reject the Subcase from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.
RejectSubcase(RejectSubcaseSetup) | Reject the Subcase from the queue in which it currently resides, and return it to the owner. This overload takes a setup object.
RejectSubcase(RejectSubcaseSetup,IDbTransaction) | Reject the Subcase from the queue in which it currently resides, and return it to the owner. This overload takes a setup object and a database transaction.

Remarks

The Subcase must be in open condition, and currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
RejectSubcaseSetup Class


RejectSubcase(String) Method | fcSDK Documentation

RejectSubcase(String) Method

Subcase Identifier.

Reject the Subcase from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function RejectSubcase( _
   ByVal _subcaseIDNum_ As String _
) As ToolkitResult

public ToolkitResult RejectSubcase(
   string _subcaseIDNum_
)

Parameters

subcaseIDNum

Subcase Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Subcase must be in open condition, and currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


RejectSubcase(RejectSubcaseSetup) Method | fcSDK Documentation

RejectSubcase(RejectSubcaseSetup) Method

Setup object for API invocation.

Reject the Subcase from the queue in which it currently resides, and return it to the owner. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function RejectSubcase( _
   ByVal _setupParam_ RejectSubcaseSetup _
) As ToolkitResult

public ToolkitResult RejectSubcase(
   RejectSubcaseSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Subcase must be in open condition, and currently dispatched to a queue.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
RejectSubcaseSetup Class


RejectSubcase(RejectSubcaseSetup,IDbTransaction) Method | fcSDK Documentation

RejectSubcase(RejectSubcaseSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Reject the Subcase from the queue in which it currently resides, and return it to the owner. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function RejectSubcase( _
   ByVal _setupParam_ As RejectSubcaseSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult RejectSubcase(
   RejectSubcaseSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The Subcase must be in open condition, and currently dispatched to a queue.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


RelateCaseToParentCase Method | fcSDK Documentation

RelateCaseToParentCase Method

Relates a Case to a specified parent Case. This overload takes a set of required parameters for the API.

Relates a Case to a specified parent Case.

Overload List

Overload | Description
RelateCaseToParentCase(String,String) | Relates a Case to a specified parent Case. This overload takes a set of required parameters for the API.
RelateCaseToParentCase(RelateCaseToParentCaseSetup) | Relates a Case to a specified parent Case. This overload takes a setup object.
RelateCaseToParentCase(RelateCaseToParentCaseSetup,IDbTransaction) | Relates a Case to a specified parent Case. This overload takes a setup object and a database transaction.

Remarks

The parent Case cannot be a descendent of the child Case.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
RelateCaseToParentCaseSetup Class


RelateCaseToParentCase(String,String) Method | fcSDK Documentation

RelateCaseToParentCase(String,String) Method

Identifier of the child Case in the relation.

Identifier of a oarent Case in the relation.

Relates a Case to a specified parent Case. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function RelateCaseToParentCase( _
   ByVal _caseIDNum_ As String, _
   ByVal _parentCaseIDNum_ As String _
) As ToolkitResult

public ToolkitResult RelateCaseToParentCase(
   string _caseIDNum_,
   string _parentCaseIDNum_
)

Parameters

caseIDNum

Identifier of the child Case in the relation.

parentCaseIDNum

Identifier of a oarent Case in the relation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The parent Case cannot be a descendent of the child Case.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


RelateCaseToParentCase(RelateCaseToParentCaseSetup) Method | fcSDK Documentation

RelateCaseToParentCase(RelateCaseToParentCaseSetup) Method

Setup object for API invocation.

Relates a Case to a specified parent Case. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function RelateCaseToParentCase( _
   ByVal _setupParam_ RelateCaseToParentCaseSetup _
) As ToolkitResult

public ToolkitResult RelateCaseToParentCase(
   RelateCaseToParentCaseSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The parent Case cannot be a descendent of the child Case.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
RelateCaseToParentCaseSetup Class


RelateCaseToParentCase(RelateCaseToParentCaseSetup,IDbTransaction) Method | fcSDK Documentation

RelateCaseToParentCase(RelateCaseToParentCaseSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Relates a Case to a specified parent Case. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function RelateCaseToParentCase( _
   ByVal _setupParam_ As RelateCaseToParentCaseSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult RelateCaseToParentCase(
   RelateCaseToParentCaseSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The parent Case cannot be a descendent of the child Case.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


ReopenCase Method | fcSDK Documentation

ReopenCase Method

Reopens the specified Case. This overload takes a set of required parameters for the API.

Reopens the specified Case.

Overload List

Overload | Description
ReopenCase(String) | Reopens the specified Case. This overload takes a set of required parameters for the API.
ReopenCase(ReopenCaseSetup) | Reopens the specified Case. This overload takes a setup object.
ReopenCase(ReopenCaseSetup,IDbTransaction) | Reopens the specified Case. This overload takes a setup object and a database transaction.

Remarks

The User that reopens the Case becomes the new owner.

If the WipBin is not specified the Case is placed in the user's default WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
ReopenCaseSetup Class


ReopenCase(String) Method | fcSDK Documentation

ReopenCase(String) Method

Identifier of the Case being reopened.

Reopens the specified Case. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function ReopenCase( _
   ByVal _caseIDNum_ As String _
) As ToolkitResult

public ToolkitResult ReopenCase(
   string _caseIDNum_
)

Parameters

caseIDNum

Identifier of the Case being reopened.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The User that reopens the Case becomes the new owner.

If the WipBin is not specified the Case is placed in the user's default WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


ReopenCase(ReopenCaseSetup) Method | fcSDK Documentation

ReopenCase(ReopenCaseSetup) Method

Setup object for API invocation.

Reopens the specified Case. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function ReopenCase( _
   ByVal _setupParam_ ReopenCaseSetup _
) As ToolkitResult

public ToolkitResult ReopenCase(
   ReopenCaseSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The User that reopens the Case becomes the new owner.

If the WipBin is not specified the Case is placed in the user's default WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
ReopenCaseSetup Class


ReopenCase(ReopenCaseSetup,IDbTransaction) Method | fcSDK Documentation

ReopenCase(ReopenCaseSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Reopens the specified Case. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function ReopenCase( _
   ByVal _setupParam_ As ReopenCaseSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult ReopenCase(
   ReopenCaseSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The User that reopens the Case becomes the new owner.

If the WipBin is not specified the Case is placed in the user's default WipBin.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


ReopenSubcase Method | fcSDK Documentation

ReopenSubcase Method

Reopens the specified Subcase. This overload takes a set of required parameters for the API.

Reopens the specified Subcase.

Overload List

Overload | Description
ReopenSubcase(String) | Reopens the specified Subcase. This overload takes a set of required parameters for the API.
ReopenSubcase(ReopenSubcaseSetup) | Reopens the specified Subcase. This overload takes a setup object.
ReopenSubcase(ReopenSubcaseSetup,IDbTransaction) | Reopens the specified Subcase. This overload takes a setup object and a database transaction.

Remarks

The User that reopens the Subcase becomes the new owner.

If the WipBin is not specified the Subcase is placed in the user's default WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
ReopenSubcaseSetup Class


ReopenSubcase(String) Method | fcSDK Documentation

ReopenSubcase(String) Method

Identifier of the Subcase being reopened.

Reopens the specified Subcase. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function ReopenSubcase( _
   ByVal _subcaseIDNum_ As String _
) As ToolkitResult

public ToolkitResult ReopenSubcase(
   string _subcaseIDNum_
)

Parameters

subcaseIDNum

Identifier of the Subcase being reopened.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The User that reopens the Subcase becomes the new owner.

If the WipBin is not specified the Subcase is placed in the user's default WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


ReopenSubcase(ReopenSubcaseSetup) Method | fcSDK Documentation

ReopenSubcase(ReopenSubcaseSetup) Method

Setup object for API invocation.

Reopens the specified Subcase. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function ReopenSubcase( _
   ByVal _setupParam_ ReopenSubcaseSetup _
) As ToolkitResult

public ToolkitResult ReopenSubcase(
   ReopenSubcaseSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The User that reopens the Subcase becomes the new owner.

If the WipBin is not specified the Subcase is placed in the user's default WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
ReopenSubcaseSetup Class


ReopenSubcase(ReopenSubcaseSetup,IDbTransaction) Method | fcSDK Documentation

ReopenSubcase(ReopenSubcaseSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Reopens the specified Subcase. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function ReopenSubcase( _
   ByVal _setupParam_ As ReopenSubcaseSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult ReopenSubcase(
   ReopenSubcaseSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The User that reopens the Subcase becomes the new owner.

If the WipBin is not specified the Subcase is placed in the user's default WipBin.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


UnrelateCaseFromParentCase Method | fcSDK Documentation

UnrelateCaseFromParentCase Method

Unrelates the specified Case from the current parent Case. This overload takes a set of required parameters for the API.

Unrelates the specified Case from the current parent Case.

Overload List

Overload | Description
UnrelateCaseFromParentCase(String) | Unrelates the specified Case from the current parent Case. This overload takes a set of required parameters for the API.
UnrelateCaseFromParentCase(UnrelateCaseFromParentCaseSetup) | Unrelates the specified Case from the current parent Case. This overload takes a setup object.
UnrelateCaseFromParentCase(UnrelateCaseFromParentCaseSetup,IDbTransaction) | Unrelates the specified Case from the current parent Case. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
UnrelateCaseFromParentCaseSetup Class


UnrelateCaseFromParentCase(String) Method | fcSDK Documentation

UnrelateCaseFromParentCase(String) Method

Identifier of the Case being unrelated from its parent Case.

Unrelates the specified Case from the current parent Case. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function UnrelateCaseFromParentCase( _
   ByVal _caseIDNum_ As String _
) As ToolkitResult

public ToolkitResult UnrelateCaseFromParentCase(
   string _caseIDNum_
)

Parameters

caseIDNum

Identifier of the Case being unrelated from its parent Case.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


UnrelateCaseFromParentCase(UnrelateCaseFromParentCaseSetup) Method | fcSDK Documentation

UnrelateCaseFromParentCase(UnrelateCaseFromParentCaseSetup) Method

Setup object for API invocation.

Unrelates the specified Case from the current parent Case. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function UnrelateCaseFromParentCase( _
   ByVal _setupParam_ UnrelateCaseFromParentCaseSetup _
) As ToolkitResult

public ToolkitResult UnrelateCaseFromParentCase(
   UnrelateCaseFromParentCaseSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
UnrelateCaseFromParentCaseSetup Class


UnrelateCaseFromParentCase(UnrelateCaseFromParentCaseSetup,IDbTransaction) Method | fcSDK Documentation

UnrelateCaseFromParentCase(UnrelateCaseFromParentCaseSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Unrelates the specified Case from the current parent Case. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UnrelateCaseFromParentCase( _
   ByVal _setupParam_ As UnrelateCaseFromParentCaseSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UnrelateCaseFromParentCase(
   UnrelateCaseFromParentCaseSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


UpdateCase Method | fcSDK Documentation

UpdateCase Method

Updates an existing Case. This overload takes a setup object.

Updates an existing Case.

Overload List

Overload | Description
UpdateCase(UpdateCaseSetup) | Updates an existing Case. This overload takes a setup object.
UpdateCase(UpdateCaseSetup,IDbTransaction) | Updates an existing Case. This overload takes a setup object and a database transaction.

Remarks

If the User is not the current owner of the Case and this flag is true then the Update will not happen.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
UpdateCaseSetup Class


UpdateCase(UpdateCaseSetup) Method | fcSDK Documentation

UpdateCase(UpdateCaseSetup) Method

Setup object for API invocation.

Updates an existing Case. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function UpdateCase( _
   ByVal _setupParam_ UpdateCaseSetup _
) As ToolkitResult

public ToolkitResult UpdateCase(
   UpdateCaseSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

If the User is not the current owner of the Case and this flag is true then the Update will not happen.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
UpdateCaseSetup Class


UpdateCase(UpdateCaseSetup,IDbTransaction) Method | fcSDK Documentation

UpdateCase(UpdateCaseSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Updates an existing Case. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdateCase( _
   ByVal _setupParam_ As UpdateCaseSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdateCase(
   UpdateCaseSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

If the User is not the current owner of the Case and this flag is true then the Update will not happen.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


UpdateCaseCommitment Method | fcSDK Documentation

UpdateCaseCommitment Method

Updates a commitment against a Case. This overload takes a set of required parameters for the API.

Updates a commitment against a Case.

Overload List

Overload | Description
UpdateCaseCommitment(String,DateTime,Int32) | Updates a commitment against a Case. This overload takes a set of required parameters for the API.
UpdateCaseCommitment(UpdateCaseCommitmentSetup) | Updates a commitment against a Case. This overload takes a setup object.
UpdateCaseCommitment(UpdateCaseCommitmentSetup,IDbTransaction) | Updates a commitment against a Case. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
UpdateCaseCommitmentSetup Class


UpdateCaseCommitment(String,DateTime,Int32) Method | fcSDK Documentation

UpdateCaseCommitment(String,DateTime,Int32) Method

Identifier of the Case.

DateTime of when the commitment is due.

Objid of the commitment to update.

Updates a commitment against a Case. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function UpdateCaseCommitment( _
   ByVal _caseIDNum_ As String, _
   ByVal _commitmentDate_ As Date, _
   ByVal _commitmentObjid_ As Integer _
) As ToolkitResult

public ToolkitResult UpdateCaseCommitment(
   string _caseIDNum_,
   DateTime _commitmentDate_,
   int _commitmentObjid_
)

Parameters

caseIDNum

Identifier of the Case.

commitmentDate

DateTime of when the commitment is due.

commitmentObjid

Objid of the commitment to update.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


UpdateCaseCommitment(UpdateCaseCommitmentSetup) Method | fcSDK Documentation

UpdateCaseCommitment(UpdateCaseCommitmentSetup) Method

Setup object for API invocation.

Updates a commitment against a Case. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function UpdateCaseCommitment( _
   ByVal _setupParam_ UpdateCaseCommitmentSetup _
) As ToolkitResult

public ToolkitResult UpdateCaseCommitment(
   UpdateCaseCommitmentSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
UpdateCaseCommitmentSetup Class


UpdateCaseCommitment(UpdateCaseCommitmentSetup,IDbTransaction) Method | fcSDK Documentation

UpdateCaseCommitment(UpdateCaseCommitmentSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Updates a commitment against a Case. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdateCaseCommitment( _
   ByVal _setupParam_ As UpdateCaseCommitmentSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdateCaseCommitment(
   UpdateCaseCommitmentSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


UpdateSubcase Method | fcSDK Documentation

UpdateSubcase Method

Updates an existing Subcase. This overload takes a setup object.

Updates an existing Subcase.

Overload List

Overload | Description
UpdateSubcase(UpdateSubcaseSetup) | Updates an existing Subcase. This overload takes a setup object.
UpdateSubcase(UpdateSubcaseSetup,IDbTransaction) | Updates an existing Subcase. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
UpdateSubcaseSetup Class


UpdateSubcase(UpdateSubcaseSetup) Method | fcSDK Documentation

UpdateSubcase(UpdateSubcaseSetup) Method

Setup object for API invocation.

Updates an existing Subcase. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function UpdateSubcase( _
   ByVal _setupParam_ UpdateSubcaseSetup _
) As ToolkitResult

public ToolkitResult UpdateSubcase(
   UpdateSubcaseSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
UpdateSubcaseSetup Class


UpdateSubcase(UpdateSubcaseSetup,IDbTransaction) Method | fcSDK Documentation

UpdateSubcase(UpdateSubcaseSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Updates an existing Subcase. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdateSubcase( _
   ByVal _setupParam_ As UpdateSubcaseSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdateSubcase(
   UpdateSubcaseSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


UpdateSubcaseCommitment Method | fcSDK Documentation

UpdateSubcaseCommitment Method

Updates a commitment against a Subcase. This overload takes a set of required parameters for the API.

Updates a commitment against a Subcase.

Overload List

Overload | Description
UpdateSubcaseCommitment(String,DateTime,Int32) | Updates a commitment against a Subcase. This overload takes a set of required parameters for the API.
UpdateSubcaseCommitment(UpdateSubcaseCommitmentSetup) | Updates a commitment against a Subcase. This overload takes a setup object.
UpdateSubcaseCommitment(UpdateSubcaseCommitmentSetup,IDbTransaction) | Updates a commitment against a Subcase. This overload takes a setup object and a database transaction.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
UpdateSubcaseCommitmentSetup Class


UpdateSubcaseCommitment(String,DateTime,Int32) Method | fcSDK Documentation

UpdateSubcaseCommitment(String,DateTime,Int32) Method

Subcase Identifier.

DateTime of when the commitment is due.

Objid of the commitment to update.

Updates a commitment against a Subcase. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function UpdateSubcaseCommitment( _
   ByVal _subcaseIDNum_ As String, _
   ByVal _commitmentDate_ As Date, _
   ByVal _commitmentObjid_ As Integer _
) As ToolkitResult

public ToolkitResult UpdateSubcaseCommitment(
   string _subcaseIDNum_,
   DateTime _commitmentDate_,
   int _commitmentObjid_
)

Parameters

subcaseIDNum

Subcase Identifier.

commitmentDate

DateTime of when the commitment is due.

commitmentObjid

Objid of the commitment to update.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


UpdateSubcaseCommitment(UpdateSubcaseCommitmentSetup) Method | fcSDK Documentation

UpdateSubcaseCommitment(UpdateSubcaseCommitmentSetup) Method

Setup object for API invocation.

Updates a commitment against a Subcase. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function UpdateSubcaseCommitment( _
   ByVal _setupParam_ UpdateSubcaseCommitmentSetup _
) As ToolkitResult

public ToolkitResult UpdateSubcaseCommitment(
   UpdateSubcaseCommitmentSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
UpdateSubcaseCommitmentSetup Class


UpdateSubcaseCommitment(UpdateSubcaseCommitmentSetup,IDbTransaction) Method | fcSDK Documentation

UpdateSubcaseCommitment(UpdateSubcaseCommitmentSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Updates a commitment against a Subcase. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function UpdateSubcaseCommitment( _
   ByVal _setupParam_ As UpdateSubcaseCommitmentSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult UpdateSubcaseCommitment(
   UpdateSubcaseCommitmentSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


YankCase Method | fcSDK Documentation

YankCase Method

Yank the Case from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.

Yank the Case from its current location to a new owner's WipBin.

Overload List

Overload | Description
YankCase(String) | Yank the Case from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.
YankCase(YankCaseSetup) | Yank the Case from its current location to a new owner's WipBin. This overload takes a setup object.
YankCase(YankCaseSetup,IDbTransaction) | Yank the Case from its current location to a new owner's WipBin. This overload takes a setup object and a database transaction.

Remarks

The WipBin to place the Case in may also be specified. This is augmented function from base Clarify, where the Case is always placed in the default WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
YankCaseSetup Class


YankCase(String) Method | fcSDK Documentation

YankCase(String) Method

Case Identifier.

Yank the Case from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function YankCase( _
   ByVal _caseIDNum_ As String _
) As ToolkitResult

public ToolkitResult YankCase(
   string _caseIDNum_
)

Parameters

caseIDNum

Case Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The WipBin to place the Case in may also be specified. This is augmented function from base Clarify, where the Case is always placed in the default WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


YankCase(YankCaseSetup) Method | fcSDK Documentation

YankCase(YankCaseSetup) Method

Setup object for API invocation.

Yank the Case from its current location to a new owner's WipBin. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function YankCase( _
   ByVal _setupParam_ YankCaseSetup _
) As ToolkitResult

public ToolkitResult YankCase(
   YankCaseSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The WipBin to place the Case in may also be specified. This is augmented function from base Clarify, where the Case is always placed in the default WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
YankCaseSetup Class


YankCase(YankCaseSetup,IDbTransaction) Method | fcSDK Documentation

YankCase(YankCaseSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Yank the Case from its current location to a new owner's WipBin. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function YankCase( _
   ByVal _setupParam_ As YankCaseSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult YankCase(
   YankCaseSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The WipBin to place the Case in may also be specified. This is augmented function from base Clarify, where the Case is always placed in the default WipBin.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


YankSubcase Method | fcSDK Documentation

YankSubcase Method

Yank the Subcase from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.

Yank the Subcase from its current location to a new owner's WipBin.

Overload List

Overload | Description
YankSubcase(String) | Yank the Subcase from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.
YankSubcase(YankSubcaseSetup) | Yank the Subcase from its current location to a new owner's WipBin. This overload takes a setup object.
YankSubcase(YankSubcaseSetup,IDbTransaction) | Yank the Subcase from its current location to a new owner's WipBin. This overload takes a setup object and a database transaction.

Remarks

The WipBin to place the Subcase in may also be specified. This is augmented function from base Clarify, where the Subcase is always placed in the default WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
YankSubcaseSetup Class


YankSubcase(String) Method | fcSDK Documentation

YankSubcase(String) Method

Subcase Identifier.

Yank the Subcase from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.

Syntax

'Declaration

Public Overloads Function YankSubcase( _
   ByVal _subcaseIDNum_ As String _
) As ToolkitResult

public ToolkitResult YankSubcase(
   string _subcaseIDNum_
)

Parameters

subcaseIDNum

Subcase Identifier.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The WipBin to place the Subcase in may also be specified. This is augmented function from base Clarify, where the Subcase is always placed in the default WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


YankSubcase(YankSubcaseSetup) Method | fcSDK Documentation

YankSubcase(YankSubcaseSetup) Method

Setup object for API invocation.

Yank the Subcase from its current location to a new owner's WipBin. This overload takes a setup object.

Syntax

'Declaration

Public Overloads Function YankSubcase( _
   ByVal _setupParam_ As YankSubcaseSetup _
) As ToolkitResult

public ToolkitResult YankSubcase(
   YankSubcaseSetup _setupParam_
)

Parameters

setupParam

Setup object for API invocation.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The WipBin to place the Subcase in may also be specified. This is augmented function from base Clarify, where the Subcase is always placed in the default WipBin.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List
YankSubcaseSetup Class


YankSubcase(YankSubcaseSetup,IDbTransaction) Method | fcSDK Documentation

YankSubcase(YankSubcaseSetup,IDbTransaction) Method

Setup object for API invocation.

Database transaction under which the API will be invoked.

Yank the Subcase from its current location to a new owner's WipBin. This overload takes a setup object and a database transaction.

Syntax

'Declaration

Public Overloads Function YankSubcase( _
   ByVal _setupParam_ As YankSubcaseSetup, _
   ByVal _transaction_ As IDbTransaction _
) As ToolkitResult

public ToolkitResult YankSubcase(
   YankSubcaseSetup _setupParam_,
   IDbTransaction _transaction_
)

Parameters

setupParam

Setup object for API invocation.

transaction

Database transaction under which the API will be invoked.

Return Value

A ToolkitResult instance with no properties set. The properties (Objid, IDNum, etc.) are not relevant to this API.

Remarks

The WipBin to place the Subcase in may also be specified. This is augmented function from base Clarify, where the Subcase is always placed in the default WipBin.

Example

Developer Walkthrough - Transaction Support

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members
Overload List


ApplicationClock Property (SupportToolkit) | fcSDK Documentation

ApplicationClock Property (SupportToolkit)

Exposed only for testability of certain APIs.

Syntax

'Declaration

Public Property ApplicationClock As IApplicationClock

public IApplicationClock ApplicationClock {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members


IsInternalLogIndicator Field | fcSDK Documentation

IsInternalLogIndicator Field

Syntax

'Declaration

Public Shared IsInternalLogIndicator As String

public static string IsInternalLogIndicator

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkit Class
SupportToolkit Members


SupportToolkitBase Class | fcSDK Documentation

SupportToolkitBase Class

Please see SupportToolkit. This class is used internally and not meant to be created by end users.

Syntax

'Declaration

Public MustInherit Class SupportToolkitBase
   Inherits FChoice.Toolkits.Clarify.ToolkitBase

public abstract class SupportToolkitBase : FChoice.Toolkits.Clarify.ToolkitBase

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.ToolkitBase
FChoice.Toolkits.Clarify.Support.SupportToolkitBase
FChoice.Toolkits.Clarify.Support.SupportToolkit

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

SupportToolkitBase Members
FChoice.Toolkits.Clarify.Support Namespace


SupportToolkitBase Class Members | fcSDK Documentation

SupportToolkitBase Class Members

The following tables list the members exposed by SupportToolkitBase.

Public Properties

 | Name | Description
Public Property | ImpersonatorUsername |
Public Property | UseDenormalizedCaseTypeLevels |

Reference

SupportToolkitBase Class
FChoice.Toolkits.Clarify.Support Namespace


ImpersonatorUsername Property (SupportToolkitBase) | fcSDK Documentation

ImpersonatorUsername Property (SupportToolkitBase)

Syntax

'Declaration

Public Property ImpersonatorUsername As String

public string ImpersonatorUsername {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkitBase Class
SupportToolkitBase Members


UseDenormalizedCaseTypeLevels Property | fcSDK Documentation

UseDenormalizedCaseTypeLevels Property

Syntax

'Declaration

Public Property UseDenormalizedCaseTypeLevels As Boolean

public bool UseDenormalizedCaseTypeLevels {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SupportToolkitBase Class
SupportToolkitBase Members


UnrelateCaseFromParentCaseSetup Class | fcSDK Documentation

UnrelateCaseFromParentCaseSetup Class

Used by the UnrelateCaseFromParentCase method as setup data for invocation.

Syntax

'Declaration

Public Class UnrelateCaseFromParentCaseSetup

public class UnrelateCaseFromParentCaseSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.UnrelateCaseFromParentCaseSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UnrelateCaseFromParentCaseSetup Members
FChoice.Toolkits.Clarify.Support Namespace
UnrelateCaseFromParentCase(UnrelateCaseFromParentCaseSetup) Method


UnrelateCaseFromParentCaseSetup Class Members | fcSDK Documentation

UnrelateCaseFromParentCaseSetup Class Members

The following tables list the members exposed by UnrelateCaseFromParentCaseSetup.

Public Constructors

 | Name | Description
Public Constructor | UnrelateCaseFromParentCaseSetup Constructor | Initializes a new instance of the UnrelateCaseFromParentCaseSetup class.

Public Properties

 | Name | Description
Public Property | CaseIDNum | Identifier of the Case being unrelated from its parent Case.

Reference

UnrelateCaseFromParentCaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
UnrelateCaseFromParentCase(UnrelateCaseFromParentCaseSetup) Method


UnrelateCaseFromParentCaseSetup Constructor | fcSDK Documentation

UnrelateCaseFromParentCaseSetup Constructor

Identifier of the Case being unrelated from its parent Case.

Initializes a new instance of the UnrelateCaseFromParentCaseSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _caseIDNum_ As String _
)

[ConstructorIndexAttribute()]
public UnrelateCaseFromParentCaseSetup(
   string _caseIDNum_
)

Parameters

caseIDNum

Identifier of the Case being unrelated from its parent Case.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UnrelateCaseFromParentCaseSetup Class
UnrelateCaseFromParentCaseSetup Members


CaseIDNum Property (UnrelateCaseFromParentCaseSetup) | fcSDK Documentation

CaseIDNum Property (UnrelateCaseFromParentCaseSetup)

Identifier of the Case being unrelated from its parent Case.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UnrelateCaseFromParentCaseSetup Class
UnrelateCaseFromParentCaseSetup Members


UpdateCaseCommitmentSetup Class | fcSDK Documentation

UpdateCaseCommitmentSetup Class

Used by the UpdateCaseCommitment method as setup data for invocation.

Syntax

'Declaration

Public Class UpdateCaseCommitmentSetup

public class UpdateCaseCommitmentSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.UpdateCaseCommitmentSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdateCaseCommitmentSetup Members
FChoice.Toolkits.Clarify.Support Namespace
UpdateCaseCommitment(UpdateCaseCommitmentSetup) Method


UpdateCaseCommitmentSetup Class Members | fcSDK Documentation

UpdateCaseCommitmentSetup Class Members

The following tables list the members exposed by UpdateCaseCommitmentSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdateCaseCommitmentSetup Constructor | Initializes a new instance of the UpdateCaseCommitmentSetup class.

Public Properties

 | Name | Description
Public Property | ActionType | Element from the 'Commitment Log Action Type' user defined list. If not set, the default list value is used.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CaseIDNum | Identifier of the Case.
Public Property | CommitmentDate | DateTime of when the commitment is due.
Public Property | CommitmentObjid | Objid of the commitment to update.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | IsMadeToCustomer | Was the Commitment made to a customer.
Public Property | Notes | Additional notes for the commitment.
Public Property | PriorWarning | How long before the Commitment expires will the owner will be warned.
Public Property | Title | Title of the commitment.
Public Property | UpdateDate | DateTime the Commitment was updated. If not set, the current time is used.
Public Property | UserName | User who updating the Commitment. If not set, the session user is used.

Reference

UpdateCaseCommitmentSetup Class
FChoice.Toolkits.Clarify.Support Namespace
UpdateCaseCommitment(UpdateCaseCommitmentSetup) Method


UpdateCaseCommitmentSetup Constructor | fcSDK Documentation

UpdateCaseCommitmentSetup Constructor

Identifier of the Case.

DateTime of when the commitment is due.

Objid of the commitment to update.

Initializes a new instance of the UpdateCaseCommitmentSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _caseIDNum_ As String, _
   ByVal _commitmentDate_ As Date, _
   ByVal _commitmentObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public UpdateCaseCommitmentSetup(
   string _caseIDNum_,
   DateTime _commitmentDate_,
   int _commitmentObjid_
)

Parameters

caseIDNum

Identifier of the Case.

commitmentDate

DateTime of when the commitment is due.

commitmentObjid

Objid of the commitment to update.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCaseCommitmentSetup Class
UpdateCaseCommitmentSetup Members


ActionType Property (UpdateCaseCommitmentSetup) | fcSDK Documentation

ActionType Property (UpdateCaseCommitmentSetup)

Element from the 'Commitment Log Action Type' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ActionType As String

[PropertyBitValueAttribute()]
public string ActionType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCaseCommitmentSetup Class
UpdateCaseCommitmentSetup Members


AdditionalFields Property (UpdateCaseCommitmentSetup) | fcSDK Documentation

AdditionalFields Property (UpdateCaseCommitmentSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCaseCommitmentSetup Class
UpdateCaseCommitmentSetup Members


CaseIDNum Property (UpdateCaseCommitmentSetup) | fcSDK Documentation

CaseIDNum Property (UpdateCaseCommitmentSetup)

Identifier of the Case.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCaseCommitmentSetup Class
UpdateCaseCommitmentSetup Members


CommitmentDate Property (UpdateCaseCommitmentSetup) | fcSDK Documentation

CommitmentDate Property (UpdateCaseCommitmentSetup)

DateTime of when the commitment is due.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentDate As Date

[PropertyBitValueAttribute()]
public DateTime CommitmentDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCaseCommitmentSetup Class
UpdateCaseCommitmentSetup Members


CommitmentObjid Property (UpdateCaseCommitmentSetup) | fcSDK Documentation

CommitmentObjid Property (UpdateCaseCommitmentSetup)

Objid of the commitment to update.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentObjid As Integer

[PropertyBitValueAttribute()]
public int CommitmentObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCaseCommitmentSetup Class
UpdateCaseCommitmentSetup Members


ContactFirstName Property (UpdateCaseCommitmentSetup) | fcSDK Documentation

ContactFirstName Property (UpdateCaseCommitmentSetup)

Contact's first name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactFirstName As String

[PropertyBitValueAttribute()]
public string ContactFirstName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCaseCommitmentSetup Class
UpdateCaseCommitmentSetup Members


ContactLastName Property (UpdateCaseCommitmentSetup) | fcSDK Documentation

ContactLastName Property (UpdateCaseCommitmentSetup)

Contact's last name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactLastName As String

[PropertyBitValueAttribute()]
public string ContactLastName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCaseCommitmentSetup Class
UpdateCaseCommitmentSetup Members


ContactPhone Property (UpdateCaseCommitmentSetup) | fcSDK Documentation

ContactPhone Property (UpdateCaseCommitmentSetup)

Contact's phone number.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactPhone As String

[PropertyBitValueAttribute()]
public string ContactPhone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCaseCommitmentSetup Class
UpdateCaseCommitmentSetup Members


GenerateTimeBombs Property (UpdateCaseCommitmentSetup) | fcSDK Documentation

GenerateTimeBombs Property (UpdateCaseCommitmentSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCaseCommitmentSetup Class
UpdateCaseCommitmentSetup Members


IsMadeToCustomer Property (UpdateCaseCommitmentSetup) | fcSDK Documentation

IsMadeToCustomer Property (UpdateCaseCommitmentSetup)

Was the Commitment made to a customer.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsMadeToCustomer As Boolean

[PropertyBitValueAttribute()]
public bool IsMadeToCustomer {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCaseCommitmentSetup Class
UpdateCaseCommitmentSetup Members


Notes Property (UpdateCaseCommitmentSetup) | fcSDK Documentation

Notes Property (UpdateCaseCommitmentSetup)

Additional notes for the commitment.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCaseCommitmentSetup Class
UpdateCaseCommitmentSetup Members


PriorWarning Property (UpdateCaseCommitmentSetup) | fcSDK Documentation

PriorWarning Property (UpdateCaseCommitmentSetup)

How long before the Commitment expires will the owner will be warned.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PriorWarning As TimeSpan

[PropertyBitValueAttribute()]
public TimeSpan PriorWarning {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCaseCommitmentSetup Class
UpdateCaseCommitmentSetup Members


Title Property (UpdateCaseCommitmentSetup) | fcSDK Documentation

Title Property (UpdateCaseCommitmentSetup)

Title of the commitment.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Title As String

[PropertyBitValueAttribute()]
public string Title {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCaseCommitmentSetup Class
UpdateCaseCommitmentSetup Members


UpdateDate Property (UpdateCaseCommitmentSetup) | fcSDK Documentation

UpdateDate Property (UpdateCaseCommitmentSetup)

DateTime the Commitment was updated. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UpdateDate As Date

[PropertyBitValueAttribute()]
public DateTime UpdateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCaseCommitmentSetup Class
UpdateCaseCommitmentSetup Members


UserName Property (UpdateCaseCommitmentSetup) | fcSDK Documentation

UserName Property (UpdateCaseCommitmentSetup)

User who updating the Commitment. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCaseCommitmentSetup Class
UpdateCaseCommitmentSetup Members


UpdateCaseSetup Class | fcSDK Documentation

UpdateCaseSetup Class

Used by the UpdateCase method as setup data for invocation.

Syntax

'Declaration

Public Class UpdateCaseSetup

public class UpdateCaseSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.UpdateCaseSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdateCaseSetup Members
FChoice.Toolkits.Clarify.Support Namespace
UpdateCase(UpdateCaseSetup) Method


UpdateCaseSetup Class Members | fcSDK Documentation

UpdateCaseSetup Class Members

The following tables list the members exposed by UpdateCaseSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdateCaseSetup Constructor | Initializes a new instance of the UpdateCaseSetup class.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CaseIDNum | Identifier of the Case being updated.
Public Property | CaseType | Element from the 'Case Type' application defined list. If not set, no change is made.
Public Property | ClearContractRelation | If true the Contract will be unrelated from the Case.
Public Property | ClearPartRevisionRelation | If true the Part Revision will be unrelated from the Case.
Public Property | ClearSitePartRelation | If true the Site Part will be unrelated from the Case.
Public Property | ContractObjid | Objid of the Contract for the Case. If not set, no change is made.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | OnlyOpen | The OnlyOpen property, which defaults to true, is checked before updating the case.
Public Property | OnlyOwner | Specifies if only the owner should be allow to modify the Case.
Public Property | PartRevisionObjid | Objid of the Part Revision for the Case. If not set, no change is made.
Public Property | Priority | Element from the 'Response Priority Code' application defined list. If not set, the default list value is used.
Public Property | Severity | Element from the 'Problem Severity Level' application defined list. If not set, the default list value is used.
Public Property | SitePartObjid | Objid of the Part Revision for the Case. If not set, no change is made.
Public Property | Title | Title for the Case.
Public Property | UpdateDate | DateTime the Case was updated. If not set, the current time is used.
Public Property | UserName | User who updating the Case. If not set, the session user is used.

Reference

UpdateCaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
UpdateCase(UpdateCaseSetup) Method


UpdateCaseSetup Constructor | fcSDK Documentation

UpdateCaseSetup Constructor

Identifier of the Case being updated.

Initializes a new instance of the UpdateCaseSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _caseIDNum_ As String _
)

[ConstructorIndexAttribute()]
public UpdateCaseSetup(
   string _caseIDNum_
)

Parameters

caseIDNum

Identifier of the Case being updated.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCaseSetup Class
UpdateCaseSetup Members


AdditionalFields Property (UpdateCaseSetup) | fcSDK Documentation

AdditionalFields Property (UpdateCaseSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCaseSetup Class
UpdateCaseSetup Members


CaseIDNum Property (UpdateCaseSetup) | fcSDK Documentation

CaseIDNum Property (UpdateCaseSetup)

Identifier of the Case being updated.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCaseSetup Class
UpdateCaseSetup Members


CaseType Property (UpdateCaseSetup) | fcSDK Documentation

CaseType Property (UpdateCaseSetup)

Element from the 'Case Type' application defined list. If not set, no change is made.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseType As String

[PropertyBitValueAttribute()]
public string CaseType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCaseSetup Class
UpdateCaseSetup Members


ClearContractRelation Property | fcSDK Documentation

ClearContractRelation Property

If true the Contract will be unrelated from the Case.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ClearContractRelation As Boolean

[PropertyBitValueAttribute()]
public bool ClearContractRelation {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCaseSetup Class
UpdateCaseSetup Members


ClearPartRevisionRelation Property | fcSDK Documentation

ClearPartRevisionRelation Property

If true the Part Revision will be unrelated from the Case.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ClearPartRevisionRelation As Boolean

[PropertyBitValueAttribute()]
public bool ClearPartRevisionRelation {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCaseSetup Class
UpdateCaseSetup Members


ClearSitePartRelation Property | fcSDK Documentation

ClearSitePartRelation Property

If true the Site Part will be unrelated from the Case.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ClearSitePartRelation As Boolean

[PropertyBitValueAttribute()]
public bool ClearSitePartRelation {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCaseSetup Class
UpdateCaseSetup Members


ContractObjid Property (UpdateCaseSetup) | fcSDK Documentation

ContractObjid Property (UpdateCaseSetup)

Objid of the Contract for the Case. If not set, no change is made.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContractObjid As Integer

[PropertyBitValueAttribute()]
public int ContractObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCaseSetup Class
UpdateCaseSetup Members


GenerateTimeBombs Property (UpdateCaseSetup) | fcSDK Documentation

GenerateTimeBombs Property (UpdateCaseSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCaseSetup Class
UpdateCaseSetup Members


OnlyOpen Property (UpdateCaseSetup) | fcSDK Documentation

OnlyOpen Property (UpdateCaseSetup)

The OnlyOpen property, which defaults to true, is checked before updating the case.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property OnlyOpen As Boolean

[PropertyBitValueAttribute()]
public bool OnlyOpen {get; set;}

Remarks

If the property is set to true, only Open cases will be updated.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCaseSetup Class
UpdateCaseSetup Members


OnlyOwner Property (UpdateCaseSetup) | fcSDK Documentation

OnlyOwner Property (UpdateCaseSetup)

Specifies if only the owner should be allow to modify the Case.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property OnlyOwner As Boolean

[PropertyBitValueAttribute()]
public bool OnlyOwner {get; set;}

Remarks

If the User is not the current owner of the Case and this flag is true then the Update will not happen.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCaseSetup Class
UpdateCaseSetup Members


PartRevisionObjid Property (UpdateCaseSetup) | fcSDK Documentation

PartRevisionObjid Property (UpdateCaseSetup)

Objid of the Part Revision for the Case. If not set, no change is made.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PartRevisionObjid As Integer

[PropertyBitValueAttribute()]
public int PartRevisionObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCaseSetup Class
UpdateCaseSetup Members


Priority Property (UpdateCaseSetup) | fcSDK Documentation

Priority Property (UpdateCaseSetup)

Element from the 'Response Priority Code' application defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Priority As String

[PropertyBitValueAttribute()]
public string Priority {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCaseSetup Class
UpdateCaseSetup Members


Severity Property (UpdateCaseSetup) | fcSDK Documentation

Severity Property (UpdateCaseSetup)

Element from the 'Problem Severity Level' application defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Severity As String

[PropertyBitValueAttribute()]
public string Severity {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCaseSetup Class
UpdateCaseSetup Members


SitePartObjid Property (UpdateCaseSetup) | fcSDK Documentation

SitePartObjid Property (UpdateCaseSetup)

Objid of the Part Revision for the Case. If not set, no change is made.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SitePartObjid As Integer

[PropertyBitValueAttribute()]
public int SitePartObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCaseSetup Class
UpdateCaseSetup Members


Title Property (UpdateCaseSetup) | fcSDK Documentation

Title Property (UpdateCaseSetup)

Title for the Case.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Title As String

[PropertyBitValueAttribute()]
public string Title {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCaseSetup Class
UpdateCaseSetup Members


UpdateDate Property (UpdateCaseSetup) | fcSDK Documentation

UpdateDate Property (UpdateCaseSetup)

DateTime the Case was updated. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UpdateDate As Date

[PropertyBitValueAttribute()]
public DateTime UpdateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCaseSetup Class
UpdateCaseSetup Members


UserName Property (UpdateCaseSetup) | fcSDK Documentation

UserName Property (UpdateCaseSetup)

User who updating the Case. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateCaseSetup Class
UpdateCaseSetup Members


UpdateSubcaseCommitmentSetup Class | fcSDK Documentation

UpdateSubcaseCommitmentSetup Class

Used by the UpdateSubcaseCommitment method as setup data for invocation.

Syntax

'Declaration

Public Class UpdateSubcaseCommitmentSetup

public class UpdateSubcaseCommitmentSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.UpdateSubcaseCommitmentSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdateSubcaseCommitmentSetup Members
FChoice.Toolkits.Clarify.Support Namespace
UpdateSubcaseCommitment(UpdateSubcaseCommitmentSetup) Method


UpdateSubcaseCommitmentSetup Class Members | fcSDK Documentation

UpdateSubcaseCommitmentSetup Class Members

The following tables list the members exposed by UpdateSubcaseCommitmentSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdateSubcaseCommitmentSetup Constructor | Initializes a new instance of the UpdateSubcaseCommitmentSetup class.

Public Properties

 | Name | Description
Public Property | ActionType | Element from the 'Commitment Log Action Type' user defined list. If not set, the default list value is used.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CommitmentDate | DateTime of when the commitment is due.
Public Property | CommitmentObjid | Objid of the commitment to update.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | IsMadeToCustomer | Was the Commitment made to a customer.
Public Property | Notes | Additional notes for the commitment.
Public Property | PriorWarning | How long before the Commitment expires will the owner will be warned.
Public Property | SubcaseIDNum | Subcase Identifier.
Public Property | Title | Title of the commitment.
Public Property | UpdateDate | DateTime the Commitment was updated. If not set, the current time is used.
Public Property | UserName | User who updated the Commitment. If not set, the session user is used.

Reference

UpdateSubcaseCommitmentSetup Class
FChoice.Toolkits.Clarify.Support Namespace
UpdateSubcaseCommitment(UpdateSubcaseCommitmentSetup) Method


UpdateSubcaseCommitmentSetup Constructor | fcSDK Documentation

UpdateSubcaseCommitmentSetup Constructor

Subcase Identifier.

DateTime of when the commitment is due.

Objid of the commitment to update.

Initializes a new instance of the UpdateSubcaseCommitmentSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _subcaseIDNum_ As String, _
   ByVal _commitmentDate_ As Date, _
   ByVal _commitmentObjid_ As Integer _
)

[ConstructorIndexAttribute()]
public UpdateSubcaseCommitmentSetup(
   string _subcaseIDNum_,
   DateTime _commitmentDate_,
   int _commitmentObjid_
)

Parameters

subcaseIDNum

Subcase Identifier.

commitmentDate

DateTime of when the commitment is due.

commitmentObjid

Objid of the commitment to update.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSubcaseCommitmentSetup Class
UpdateSubcaseCommitmentSetup Members


ActionType Property (UpdateSubcaseCommitmentSetup) | fcSDK Documentation

ActionType Property (UpdateSubcaseCommitmentSetup)

Element from the 'Commitment Log Action Type' user defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ActionType As String

[PropertyBitValueAttribute()]
public string ActionType {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSubcaseCommitmentSetup Class
UpdateSubcaseCommitmentSetup Members


AdditionalFields Property (UpdateSubcaseCommitmentSetup) | fcSDK Documentation

AdditionalFields Property (UpdateSubcaseCommitmentSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSubcaseCommitmentSetup Class
UpdateSubcaseCommitmentSetup Members


CommitmentDate Property (UpdateSubcaseCommitmentSetup) | fcSDK Documentation

CommitmentDate Property (UpdateSubcaseCommitmentSetup)

DateTime of when the commitment is due.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentDate As Date

[PropertyBitValueAttribute()]
public DateTime CommitmentDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSubcaseCommitmentSetup Class
UpdateSubcaseCommitmentSetup Members


CommitmentObjid Property (UpdateSubcaseCommitmentSetup) | fcSDK Documentation

CommitmentObjid Property (UpdateSubcaseCommitmentSetup)

Objid of the commitment to update.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CommitmentObjid As Integer

[PropertyBitValueAttribute()]
public int CommitmentObjid {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSubcaseCommitmentSetup Class
UpdateSubcaseCommitmentSetup Members


ContactFirstName Property (UpdateSubcaseCommitmentSetup) | fcSDK Documentation

ContactFirstName Property (UpdateSubcaseCommitmentSetup)

Contact's first name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactFirstName As String

[PropertyBitValueAttribute()]
public string ContactFirstName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSubcaseCommitmentSetup Class
UpdateSubcaseCommitmentSetup Members


ContactLastName Property (UpdateSubcaseCommitmentSetup) | fcSDK Documentation

ContactLastName Property (UpdateSubcaseCommitmentSetup)

Contact's last name.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactLastName As String

[PropertyBitValueAttribute()]
public string ContactLastName {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSubcaseCommitmentSetup Class
UpdateSubcaseCommitmentSetup Members


ContactPhone Property (UpdateSubcaseCommitmentSetup) | fcSDK Documentation

ContactPhone Property (UpdateSubcaseCommitmentSetup)

Contact's phone number.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property ContactPhone As String

[PropertyBitValueAttribute()]
public string ContactPhone {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSubcaseCommitmentSetup Class
UpdateSubcaseCommitmentSetup Members


GenerateTimeBombs Property (UpdateSubcaseCommitmentSetup) | fcSDK Documentation

GenerateTimeBombs Property (UpdateSubcaseCommitmentSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSubcaseCommitmentSetup Class
UpdateSubcaseCommitmentSetup Members


IsMadeToCustomer Property (UpdateSubcaseCommitmentSetup) | fcSDK Documentation

IsMadeToCustomer Property (UpdateSubcaseCommitmentSetup)

Was the Commitment made to a customer.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property IsMadeToCustomer As Boolean

[PropertyBitValueAttribute()]
public bool IsMadeToCustomer {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSubcaseCommitmentSetup Class
UpdateSubcaseCommitmentSetup Members


Notes Property (UpdateSubcaseCommitmentSetup) | fcSDK Documentation

Notes Property (UpdateSubcaseCommitmentSetup)

Additional notes for the commitment.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Notes As String

[PropertyBitValueAttribute()]
public string Notes {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSubcaseCommitmentSetup Class
UpdateSubcaseCommitmentSetup Members


PriorWarning Property (UpdateSubcaseCommitmentSetup) | fcSDK Documentation

PriorWarning Property (UpdateSubcaseCommitmentSetup)

How long before the Commitment expires will the owner will be warned.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property PriorWarning As TimeSpan

[PropertyBitValueAttribute]
public TimeSpan PriorWarning {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSubcaseCommitmentSetup Class
UpdateSubcaseCommitmentSetup Members


SubcaseIDNum Property (UpdateSubcaseCommitmentSetup) | fcSDK Documentation

SubcaseIDNum Property (UpdateSubcaseCommitmentSetup)

Subcase Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SubcaseIDNum As String

[PropertyBitValueAttribute()]
public string SubcaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSubcaseCommitmentSetup Class
UpdateSubcaseCommitmentSetup Members


Title Property (UpdateSubcaseCommitmentSetup) | fcSDK Documentation

Title Property (UpdateSubcaseCommitmentSetup)

Title of the commitment.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Title As String

[PropertyBitValueAttribute()]
public string Title {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSubcaseCommitmentSetup Class
UpdateSubcaseCommitmentSetup Members


UpdateDate Property (UpdateSubcaseCommitmentSetup) | fcSDK Documentation

UpdateDate Property (UpdateSubcaseCommitmentSetup)

DateTime the Commitment was updated. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UpdateDate As Date

[PropertyBitValueAttribute()]
public DateTime UpdateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSubcaseCommitmentSetup Class
UpdateSubcaseCommitmentSetup Members


UserName Property (UpdateSubcaseCommitmentSetup) | fcSDK Documentation

UserName Property (UpdateSubcaseCommitmentSetup)

User who updated the Commitment. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSubcaseCommitmentSetup Class
UpdateSubcaseCommitmentSetup Members


UpdateSubcaseSetup Class | fcSDK Documentation

UpdateSubcaseSetup Class

Used by the UpdateSubcase method as setup data for invocation.

Syntax

'Declaration

Public Class UpdateSubcaseSetup

public class UpdateSubcaseSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.UpdateSubcaseSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

UpdateSubcaseSetup Members
FChoice.Toolkits.Clarify.Support Namespace
UpdateSubcase(UpdateSubcaseSetup) Method


UpdateSubcaseSetup Class Members | fcSDK Documentation

UpdateSubcaseSetup Class Members

The following tables list the members exposed by UpdateSubcaseSetup.

Public Constructors

 | Name | Description
Public Constructor | UpdateSubcaseSetup Constructor | Initializes a new instance of the UpdateSubcaseSetup class.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | OnlyOpen | The OnlyOpen property, which defaults to true, is checked before updating the subcase.
Public Property | OnlyOwner | Specifies if only the owner should be allow to modify the Subcase.
Public Property | Priority | Element from the 'Response Priority Code' application defined list. If not set, the default list value is used.
Public Property | Severity | Element from the 'Problem Severity Level' application defined list. If not set, the default list value is used.
Public Property | SubcaseIDNum | Subcase Identifier.
Public Property | UpdateDate | DateTime the Subcase was updated. If not set, the current time is used.
Public Property | UserName | User who updated the Subcase. If not set, the session user is used.

Reference

UpdateSubcaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
UpdateSubcase(UpdateSubcaseSetup) Method


UpdateSubcaseSetup Constructor | fcSDK Documentation

UpdateSubcaseSetup Constructor

Subcase Identifier

Initializes a new instance of the UpdateSubcaseSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _subcaseIDNum_ As String _
)

[ConstructorIndexAttribute()]
public UpdateSubcaseSetup(
   string _subcaseIDNum_
)

Parameters

subcaseIDNum

Subcase Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSubcaseSetup Class
UpdateSubcaseSetup Members


AdditionalFields Property (UpdateSubcaseSetup) | fcSDK Documentation

AdditionalFields Property (UpdateSubcaseSetup)

Allows the specification of additional fields to be updated as part of API invocation.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public ReadOnly Property AdditionalFields As AdditionalFields

[PropertyBitValueAttribute()]
public AdditionalFields AdditionalFields {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSubcaseSetup Class
UpdateSubcaseSetup Members


GenerateTimeBombs Property (UpdateSubcaseSetup) | fcSDK Documentation

GenerateTimeBombs Property (UpdateSubcaseSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSubcaseSetup Class
UpdateSubcaseSetup Members


OnlyOpen Property (UpdateSubcaseSetup) | fcSDK Documentation

OnlyOpen Property (UpdateSubcaseSetup)

The OnlyOpen property, which defaults to true, is checked before updating the subcase.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property OnlyOpen As Boolean

[PropertyBitValueAttribute()]
public bool OnlyOpen {get; set;}

Remarks

If the property is set to true, only Open subcases will be updated.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSubcaseSetup Class
UpdateSubcaseSetup Members


OnlyOwner Property (UpdateSubcaseSetup) | fcSDK Documentation

OnlyOwner Property (UpdateSubcaseSetup)

Specifies if only the owner should be allow to modify the Subcase.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property OnlyOwner As Boolean

[PropertyBitValueAttribute()]
public bool OnlyOwner {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSubcaseSetup Class
UpdateSubcaseSetup Members


Priority Property (UpdateSubcaseSetup) | fcSDK Documentation

Priority Property (UpdateSubcaseSetup)

Element from the 'Response Priority Code' application defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Priority As String

[PropertyBitValueAttribute()]
public string Priority {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSubcaseSetup Class
UpdateSubcaseSetup Members


Severity Property (UpdateSubcaseSetup) | fcSDK Documentation

Severity Property (UpdateSubcaseSetup)

Element from the 'Problem Severity Level' application defined list. If not set, the default list value is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property Severity As String

[PropertyBitValueAttribute()]
public string Severity {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSubcaseSetup Class
UpdateSubcaseSetup Members


SubcaseIDNum Property (UpdateSubcaseSetup) | fcSDK Documentation

SubcaseIDNum Property (UpdateSubcaseSetup)

Subcase Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SubcaseIDNum As String

[PropertyBitValueAttribute()]
public string SubcaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSubcaseSetup Class
UpdateSubcaseSetup Members


UpdateDate Property (UpdateSubcaseSetup) | fcSDK Documentation

UpdateDate Property (UpdateSubcaseSetup)

DateTime the Subcase was updated. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UpdateDate As Date

[PropertyBitValueAttribute()]
public DateTime UpdateDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSubcaseSetup Class
UpdateSubcaseSetup Members


UserName Property (UpdateSubcaseSetup) | fcSDK Documentation

UserName Property (UpdateSubcaseSetup)

User who updated the Subcase. If not set, the session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

UpdateSubcaseSetup Class
UpdateSubcaseSetup Members


YankCaseSetup Class | fcSDK Documentation

YankCaseSetup Class

Used by the YankCase method as setup data for invocation.

Syntax

'Declaration

Public Class YankCaseSetup

public class YankCaseSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.YankCaseSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

YankCaseSetup Members
FChoice.Toolkits.Clarify.Support Namespace
YankCase(YankCaseSetup) Method


YankCaseSetup Class Members | fcSDK Documentation

YankCaseSetup Class Members

The following tables list the members exposed by YankCaseSetup.

Public Constructors

 | Name | Description
Public Constructor | YankCaseSetup Constructor | Initializes a new instance of the YankCaseSetup class.

Public Properties

 | Name | Description
Public Property | CaseIDNum | Case Identifier.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | UserName | The user who has yanked the Case. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Case. If not set, the UserName's default is used.
Public Property | YankDate | DateTime the Case was yanked. If not set, the current time is used.

Reference

YankCaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
YankCase(YankCaseSetup) Method


YankCaseSetup Constructor | fcSDK Documentation

YankCaseSetup Constructor

Case Identifier

Initializes a new instance of the YankCaseSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _caseIDNum_ As String _
)

[ConstructorIndexAttribute()]
public YankCaseSetup(
   string _caseIDNum_
)

Parameters

caseIDNum

Case Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankCaseSetup Class
YankCaseSetup Members


CaseIDNum Property (YankCaseSetup) | fcSDK Documentation

CaseIDNum Property (YankCaseSetup)

Case Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property CaseIDNum As String

[PropertyBitValueAttribute()]
public string CaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankCaseSetup Class
YankCaseSetup Members


GenerateTimeBombs Property (YankCaseSetup) | fcSDK Documentation

GenerateTimeBombs Property (YankCaseSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

csharp

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankCaseSetup Class
YankCaseSetup Members


UserName Property (YankCaseSetup) | fcSDK Documentation

UserName Property (YankCaseSetup)

The user who has yanked the Case. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankCaseSetup Class
YankCaseSetup Members


WipBin Property (YankCaseSetup) | fcSDK Documentation

WipBin Property (YankCaseSetup)

User's WipBin in which to place the Case. If not set, the UserName's default is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankCaseSetup Class
YankCaseSetup Members


YankDate Property (YankCaseSetup) | fcSDK Documentation

YankDate Property (YankCaseSetup)

DateTime the Case was yanked. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property YankDate As Date

[PropertyBitValueAttribute()]
public DateTime YankDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankCaseSetup Class
YankCaseSetup Members


YankSubcaseSetup Class | fcSDK Documentation

YankSubcaseSetup Class

Used by the YankSubcase method as setup data for invocation.

Syntax

'Declaration

Public Class YankSubcaseSetup

public class YankSubcaseSetup

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.YankSubcaseSetup

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

YankSubcaseSetup Members
FChoice.Toolkits.Clarify.Support Namespace
YankSubcase(YankSubcaseSetup) Method


YankSubcaseSetup Class Members | fcSDK Documentation

YankSubcaseSetup Class Members

The following tables list the members exposed by YankSubcaseSetup.

Public Constructors

 | Name | Description
Public Constructor | YankSubcaseSetup Constructor | Initializes a new instance of the YankSubcaseSetup class.

Public Properties

 | Name | Description
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | SubcaseIDNum | Subcase Identifier.
Public Property | UserName | The user who has yanked the Subcase. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Subcase. If not set, the UserName's default is used.
Public Property | YankDate | DateTime the Subcase was yanked. If not set, the current time is used.

Reference

YankSubcaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
YankSubcase(YankSubcaseSetup) Method


YankSubcaseSetup Constructor | fcSDK Documentation

YankSubcaseSetup Constructor

Subcase Identifier

Initializes a new instance of the YankSubcaseSetup class.

Syntax

'Declaration

<ConstructorIndexAttribute()>
Public Function New( _
   ByVal _subcaseIDNum_ As String _
)

[ConstructorIndexAttribute()]
public YankSubcaseSetup(
   string _subcaseIDNum_
)

Parameters

subcaseIDNum

Subcase Identifier.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankSubcaseSetup Class
YankSubcaseSetup Members


GenerateTimeBombs Property (YankSubcaseSetup) | fcSDK Documentation

GenerateTimeBombs Property (YankSubcaseSetup)

Specifies if timebombs should be created.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property GenerateTimeBombs As Boolean

[PropertyBitValueAttribute()]
public bool GenerateTimeBombs {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankSubcaseSetup Class
YankSubcaseSetup Members


SubcaseIDNum Property (YankSubcaseSetup) | fcSDK Documentation

SubcaseIDNum Property (YankSubcaseSetup)

Subcase Identifier.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property SubcaseIDNum As String

[PropertyBitValueAttribute()]
public string SubcaseIDNum {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankSubcaseSetup Class
YankSubcaseSetup Members


UserName Property (YankSubcaseSetup) | fcSDK Documentation

UserName Property (YankSubcaseSetup)

The user who has yanked the Subcase. If not set, the Toolkit session user is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property UserName As String

[PropertyBitValueAttribute()]
public string UserName {get; set;}

Remarks

When this property is not specified. This API method will attempt to use the toolkit session's UserName. If the toolkit session was created as a Contact session this property is required otherwise errors will result.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankSubcaseSetup Class
YankSubcaseSetup Members


WipBin Property (YankSubcaseSetup) | fcSDK Documentation

WipBin Property (YankSubcaseSetup)

User's WipBin in which to place the Subcase. If not set, the UserName's default is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property WipBin As String

[PropertyBitValueAttribute()]
public string WipBin {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankSubcaseSetup Class
YankSubcaseSetup Members


YankDate Property (YankSubcaseSetup) | fcSDK Documentation

YankDate Property (YankSubcaseSetup)

DateTime the Subcase was yanked. If not set, the current time is used.

Syntax

'Declaration

<PropertyBitValueAttribute()>
Public Property YankDate As Date

[PropertyBitValueAttribute()]
public DateTime YankDate {get; set;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

YankSubcaseSetup Class
YankSubcaseSetup Members


IApplicationClock Interface | fcSDK Documentation

IApplicationClock Interface

Syntax

'Declaration

Public Interface IApplicationClock

public interface IApplicationClock

Requirements

Namespace: FChoice.Toolkits.Clarify.Support

Platforms: Windows 2000, Windows XP, Windows Server family

Assembly: FChoice.Toolkits.Clarify (in C:\dovetail\dovetail-sdk\build\Release\FChoice.Toolkits.Clarify.dll)

Reference

IApplicationClock Members
FChoice.Toolkits.Clarify.Support Namespace


IApplicationClock Interface Members | fcSDK Documentation

IApplicationClock Interface Members

The following tables list the members exposed by IApplicationClock.

Public Properties

 | Name | Description
Property | Now |

Reference

IApplicationClock Interface
FChoice.Toolkits.Clarify.Support Namespace


Now Property (IApplicationClock) | fcSDK Documentation

Now Property (IApplicationClock)

Syntax

'Declaration
ReadOnly Property Now As Date

DateTime Now {get;}

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

IApplicationClock Interface
IApplicationClock Members


FCFL FCApplication Object | fcSDK Documentation

FCFL FCApplication Object

Overview

The FCApplication object represents an application that will connect to a Clarify database. When you create an FCApplication object, the necessary DLLs to support the First Choice Foundation Library are loaded into memory.

The FCApplication object is used to manage cached information from the database, including meta-data and schema data.

You can use the FCApplication object to:

  • Initialize the FCApplication and connect to a Clarify database
  • Create new FCSession objects
  • Access cached data, such as lists, strings, states, countries, etc.

To create a new FCApplication object, use the CreateObject method of the language being scripted in. The following are examples of how to create an FCApplication in both JavaScript and Visual Basic:

JavaScript:

var FCApp = Server.CreateObject("FCFL.fcapplication");

Visual Basic:

Dim FCApp

Set FCApp = CreateObject("FCFL.fcapplication")


CreateSession | fcSDK Documentation

CreateSession

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function CreateSession(Optional ByVal SessionID As String) As FCSession

Description

This method creates a new FCSession object, or returns a reference to an existing FCSession object.

If this method is called without any input parameters, a new FCSession object will be created and returned.

If this method is called with a SessionID, the FCApplication will attempt to return a reference to an existing FCSession object with the given SessionID. If a FCSession with this SessionID does not exist, an error is thrown.

Parameters

Parameter Name | Required? | Description
SessionID | No | An optional parameter for re-establishing an existing FCSession object.

Returns

A new FCSession object, or a reference to an existing FCSession Object

Error Codes

Value | Meaning
10020 | Invalid SessionID

Examples

The following example attempts to retrieve a SessionID from the ASP Session, and, if found, re-establish the existing FCSession.

JavaScript:

var  FCSession;
var strSessionId = "";

strSessionId = Session.Contents("FCSessionId");

if ( typeof(strSessionId) != "string" )
   { strSessionId = ""; }

if ( strSessionId == "" )
   { Response.Redirect("Logon3.asp"); }

try
  {
  FCSession = Application.Contents("FCApp").CreateSession(strSessionId)
  }
catch ( e )
  {
  //Could not re-establish session. Re-direct to logon page
  Response.Redirect("Logon3.asp")
  }

The following example simply creates a new FCApplication object and a new FCSession object.

Visual Basic:

Dim fc_app As New FCApplication
Dim fc_session As FCSession

fc_app.WorkingDirectory = "C:\\inetpub\\wwwroot\\testing"
fc_app.Initialize()

Set fc_session = fc_app.CreateSession
fc_session.Login UserName, Password


FindString | fcSDK Documentation

FindString

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function FindString(ByVal StringID As Variant) As String

Description

This method retrieves a string from the string_db table, using either the name or the ID of the string.

These correspond to the fields ID and name in the string_db table.

The string_db table is cached in the FCApplication object, so this method does not cause a database round-trip.

Parameters

Parameter Name | Required? | Description
StringID | Yes | A string ID number or name.

Returns

The retrieved string if one is found, else an empty string.

Error Codes

Value | Meaning
10005 | Invalid Input Type - Must be String or Integer.
10006 | Input String must not be empty.
10007 | Input Integer must not be < 0.

Examples

The following example shows both ways of using the FindString method to display an error message.

JavaScript:

<%
var ErrorMessageByID = FCApp.FindString(2343);
var ErrorMessageByName = FCApp.FindString("ERR_DBS_NO_DEFAULT_WIPBIN");
%>

Error By ID: <%=ErrorMessageByID%>
<BR>
Error By Name: <%=ErrorMessageByName%>


GetCountryList | fcSDK Documentation

GetCountryList

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function GetCountryList() As ADODB.Recordset

Description

This method returns a recordset containing the country records

The country table is cached in the FCApplication object, so this method does not cause a database round-trip.

When finished with the returned recordset, you should close the recordset using the .Close method and then set your variable to Nothing or Null. This will release the resources needed for this object.

Returns

An ADO recordset containing the country records.

Example

The following example builds a drop-down list of countries. The default country is selected.

JavaScript:

<SELECT NAME="Country">
<%
var defCountry = FCApp.GetDefaultCountry();
var CountryList = FCApp.GetCountryList();
while (! CountryList.EOF) { %>
  <option
  <% if (CountryList("name") == defCountry) { %>
  selected = true <% } %> >
  <%=CountryList("name")%>
  <% CountryList.MoveNext; %>
  </option>
<% } %>
</SELECT>

<%
CountryList.Close();
CountryList = null;
%>


GetCountryObjid | fcSDK Documentation

GetCountryObjid

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function GetCountryObjid(ByVal Country As String) As Long

Description

This method returns an objid for a given country. If the country is not found, this method returns a value of zero. The country table is cached in the FCApplication object, so this method does not cause a database round-trip.

Parameters

Parameter Name | Required? | Description
Country | Yes | Name of country to get the objid for.

Returns

The objid of country. Zero, if the country is not found.

Example

The following example retrieves the objid for a country.

JavaScript:

var CountryName = Request.Form("country").Item;

var CountryObjid = FCApp.GetCountryObjid(CountryName);


GetDefaultCountry | fcSDK Documentation

GetDefaultCountry

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function GetDefaultCountry() As String

Description

This method returns the name of the default country. The default country is defined by the is_default flag on the country table. The country table is cached in the FCApplication object, so this method does not cause a database round-trip.

Returns

A string containing the name of the default country. If a country has not been set as the default, an empty string will be returned.

Example

The following example builds a drop-down list of countries. The default country is selected.

JavaScript:

<SELECT NAME="Country">
<%
var defCountry = FCApp.GetDefaultCountry();
var CountryList = FCApp.GetCountryList();
while (! CountryList.EOF) { %>
  <option
  <% if (CountryList("name") == defCountry) { %>
  selected = true <% } %> >
  <%=CountryList("name")%>
  <% CountryList.MoveNext; %>
  </option>
<% } %>
</SELECT>


GetDefaultCountryObjid | fcSDK Documentation

GetDefaultCountryObjid

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function GetDefaultCountryObjid() As Long

Description

This method returns the objid of the default country. The default country is defined by the is_default flag in the country table. The country table is cached in the FCApplication object, so this method does not cause a database round-trip.

Returns

A long integer containing the objid of the default country. If a country has not been set as the default, zero will be returned.

Example

The following example retrieves the objid of the default country.

JavaScript:

//If the customer didn't give us a country, use the default
if (CountryObjid == 0)
{
    CountryObjid = FCApp.GetDefaultCountryObjid();
}


GetDefaultState | fcSDK Documentation

GetDefaultState

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function GetDefaultState(ByVal Country As String) As String

Description

This method returns a string containing the default state_prov name for a given country. If there is not a default state (indicated by the is_default field), then the name of the first state is returned.

The state_prov and country tables are cached in the FCApplication object, so this method does not cause a database round-trip.

Parameters

Parameter Name | Required? | Description
Country | Yes | Name of country to get the default state for.

Returns

A string containing the default state_prov name for a given country.

Error Codes

Value | Meaning
10011 | Country must not be empty.
10012 | Invalid Country

Examples

The following example builds a drop-down list of states for the default. The default state is selected.

JavaScript:

<SELECT NAME="States">
<%
var defCountry = FCApp.GetDefaultCountry();
var StateList = FCApp.GetStates(defCountry);
var defState = FCApp.GetDefaultState(defCountry);
while (! StateList.EOF) { %>
  <option
  <% if (StateList("name") == defState) { %>
  selected = true <% } %> >
  <%=StateList("name")%>
  <% StateList.MoveNext; %>
  </option>
<% } %>
</SELECT>


GetDefaultStateObjid | fcSDK Documentation

GetDefaultStateObjid

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function GetDefaultStateObjid(ByVal Country As String) As Long

Description

This method returns a long integer containing the objid of the default state_prov for a given country. If there is not a default state (indicated by the is_default field), then the objid of the first state is returned.

The state_prov and country tables are cached in the FCApplication object, so this method does not cause a database round-trip.

Parameters

Parameter Name | Required? | Description
Country | Yes | Name of country to get the default state for.

Returns

A long integer containing the objid of the default state_prov for a given country.

Error Codes

Value | Meaning
10011 | Country must not be empty.
10012 | Invalid Country

Examples

The following example retrieves the objid of the default state for a given country.

JavaScript:

//If the customer didn't give us a state, use the default
if(StateObjid == 0)
{
    var defCountry = FCApp.GetDefaultCountry();
    StateObjid = FCApp.GetDefaultStateObjid(defCountry);
}


GetDefaultTimeZone | fcSDK Documentation

GetDefaultTimeZone

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function GetDefaultTimeZone() As String

Description

This method returns the full_name of the default time zone. The default time zone is defined by the is_default flag on the time_zone table. The time_zone table is cached in the FCApplication object, so this method does not cause a database round-trip.

Returns

A string containing the full_name of the default time_zone. If a time_zone has not been set as the default, an empty string will be returned.

Example

The following example builds a drop-down list of time zones. The default time zone is selected.

JavaScript:

<SELECT NAME="TZ">
<%
var defTZ = FCApp.GetDefaultTimeZone();
var TZList = FCApp.GetTimeZoneList();
while (! TZList.EOF) { %>
  <option
  <% if (TZList("full_name") == defTZ) { %>
  selected = true <% } %> >
  <%=TZList("full_name")%>
  <% TZList.MoveNext; %>
  </option>
<% } %>
</SELECT>


GetDefaultTimeZoneObjid | fcSDK Documentation

GetDefaultTimeZoneObjid

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function GetDefaultTimeZoneObjid() As Long

Description

This method returns the objid of the default time zone. The default time zone is defined by the is_default flag in the time_zone table. The time_zone table is cached in the FCApplication object, so this method does not cause a database round-trip.

Returns

A long integer containing the objid of the default time_zone. If a time_zone has not been set as the default, zero will be returned.

Example

The following example retrieves the objid of the default time_zone.

JavaScript:

//If the customer didn't give us a time zone, use the default

if (TimeZoneObjid == 0)
{
    TimeZoneObjid = FCApp.GetDefaultTimeZoneObjid();
}


GetFullStateObjid | fcSDK Documentation

GetFullStateObjid

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function GetFullStateObjid(ByVal Country As String, ByVal State As String) As Long

Description

This method returns an objid for a given state in a given country. If the state or country is not found, this method returns a value of zero. The state and country tables are cached in the FCApplication object, so this method does not cause a database round-trip.

Note: The state name supplied should be the "long" name (such as "Texas").

Parameters

Parameter Name | Required? | Description
Country | Yes | Name of country.
State | Yes | Name of state to get the objid for.

Returns

The objid of the state. Zero, if the state or country is not found.

Error Codes

Value | Meaning
10011 | Country must not be empty.
10013 | State must not be empty.

Examples

The following example checks is a given state from a posted form is valid for the posted country.

JavaScript:

var country = Request.Form("country").Item;
var state = Request.Form("state").Item;
var StateObjid = FCApp.GetFullStateObjid(country,state);

if(StateObjid > 0)
{
  Response.Write(state + " is a valid state in " + country);
}
else
{
  Response.Write(state + " is NOT a valid state in " + country);
}


GetGbstDefault or GetGbstLocalizedDefault | fcSDK Documentation

GetGbstDefault or GetGbstLocalizedDefault

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function GetGbstDefault(ByVal ListName As String) As String

Public Function GetLocalizedGbstDefault(ByVal ListName As String) As String

Description

GetGbstDefault - This method returns the default string value for a given Application Popup list.

GetLocalizedGbstDefault - This method returns the default string value for a given Application Popup list for the FCSession's current culture.

The gbst_elm table is cached in the FCApplication object, so this method does not cause a database round-trip.

Parameters

Parameter Name | Required? | Description
ListName | Yes | An Application popup list name.

Returns

The default value for this list, if one is defined. Else, the first value in the list.

Error Codes

Value | Meaning
10008 | ListName must not be empty.
10009 | Invalid ListName.

Examples

The following example displays the default Case Type.

JavaScript:

<%
var defCaseType = FCApp.GetGbstDefault("Case Type");
%>

Default Case Type= <%=defCaseType%>


GetGbstElmByID or GetLocalizedGbstElmByID | fcSDK Documentation

GetGbstElmByID or GetLocalizedGbstElmByID

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function GetGbstElmByID(ByVal ListName As String, _
                               ByVal ElmObjid As Long) As String

Description

This method returns the string value for a given element in a given Application Popup list, given the objid. If the element is not found in the list, this method returns a value of empty string (""). The gbst_elm table is cached in the FCApplication object, so this method does not cause a database round-trip.

Parameters

Parameter Name | Required? | Description
ListName | Yes | Name of the list
ElmObjid | Yes | The objid of the list item

Returns

The string value of the element.

Example

The following example retrieves the string for the priority of an already-found case.

JavaScript:

var ElmObjid = CaseObj("respprty2gbst_elm");

Response.Write("Priority is: " + FCApp.GetGbstElmByID("Response Priority Code", ElmObjid));


GetGbstElmObjid | fcSDK Documentation

GetGbstElmObjid

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function GetGbstElmObjid(ByVal ListName As String, ByVal Element As String) As Long

Description

This method returns an objid for a given element in a given Application Popup list. If the element is not found in the list, this method returns a value of zero.

The gbst_elm table is cached in the FCApplication object, so this method does not cause a database round-trip.

Parameters

Parameter Name | Required? | Description
ListName | Yes | An Application popup list name.
Element | Yes | The element to be checked for its existence in the list.

Returns

The objid of the Element in the ListName list. Zero, if the Element is not found in the ListName list.

Error Codes

Value | Meaning
10008 | ListName must not be empty.
10009 | Invalid ListName.
10010 | Element must not be empty.

Examples

The following example retrieves the objid for a Case Priority from a posted form value.

JavaScript:

var ListName = "Response Priority Code";
var ListValue = Request.Form("priority").Item;
var ElmObjid = FCApp.GetGbstElmObjid(ListName,ListValue);

If (ElmObjid > 0) {
  Response.Write("The GbstElm Objid for " + ListValue +
                 " in the list " + ListName +
                 " = " \+ ElmObjid); }
else
  { Response.Write(ListValue + " is NOT a valid " + ListName); }


GetGbstElmRankObjid | fcSDK Documentation

GetGbstElmRankObjid

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function GetGbstElmRankObjid(ByVal ListName As String, _
                                    ByVal Rank As Long) As Long

Description

This method returns an objid for an element having a given rank in a given Application Popup list. If the element is not found in the list, this method returns a value of zero.

The gbst_elm table is cached in the FCApplication object, so this method does not cause a database round-trip.

Parameters

Parameter Name | Required? | Description
ListName | Yes | Application List Name
Rank | Yes | Rank of Element

Returns

The objid of the element with the given Rank in the ListName list. Zero, if the Rank is not found in the ListName list.

Error Codes

Value | Meaning
10008 | ListName must not be empty.
10009 | Invalid ListName.

Examples

The following example relates an activity entry record to the proper gbst_elm record using the activity code (rank) of the activity.

Visual Basic:

act_code = 4700

act_rec.RelateByID FCApp.GetGbstElmRankObjid("Activity Name", act_code), "entry_name2gbst_elm"


GetGbstList | fcSDK Documentation

GetGbstList

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function GetGbstList(ByVal ListName As String) As ADODB.Recordset

Description

This method returns a recordset containing the gbst_elm records for a given gbst_lst.

An error is thrown if an empty or invalid is given.

The gbst_elm table is cached in the FCApplication object, so this method does not cause a database round-trip.

When finished with the returned recordset, you should close the recordset using the .Close method and then set your variable to Nothing or Null. This will release the resources needed for this object.

Parameters

Parameter Name | Required? | Description
ListName | Yes | An Application popup list name.

Returns

An ADO recordset containing the gbst_elm records for the ListName list.

Error Codes

Value | Meaning
10008 | ListName must not be empty.
10009 | Invalid ListName.

Examples

The following builds a drop-down list of case types.

JavaScript:

<SELECT NAME="CaseType">
<%
var CaseTypeList = FCApp.GetGbstList("Case Type");
while (! CaseTypeList.EOF) { %>
  <option
  <% if (CaseTypeList("state") == 2) { %>
         selected = true <% } %> >
  <%=CaseTypeList("title")%>
  <% CaseTypeList.MoveNext; %>
  </option>
<% } %>
</SELECT>

<%
CaseTypeList.Close();
CaseTypeList = null;
%>


GetHgbstElmDefaultObjid | fcSDK Documentation

GetHgbstElmDefaultObjid

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function GetHgbstElmDefaultObjid(ByVal ListName As String,
        Optional ByVal Element1 As String = "", Optional ByVal Element2 As String = "", Optional ByVal Element3 As String = "", Optional ByVal Element4 As String = "") As Long

Description

This method returns the hgbst_elm.objid value for the default element in a given level of a user-defined list. You may use up to a 5-level list. If an default element has not been defined, then the first element is returned. The hgbst tables are cached in the FCApplication object, so this method does not cause a database round-trip.

Parameters

Parameter Name | Required? | Description
ListName | Yes | The user-defined list name.
Element1 | No | The parent element for TheElement, if TheElement is in a 2 level list. Else, the parent element for Element2.
Element2 | No | The parent element for TheElement, if TheElement is in a 3 level list. Else, the parent element for Element3.
Element3 | No | The parent element for TheElement, if TheElement is in a 4 level list. Else, the parent element for Element4.
Element4 | No | The parent element for TheElement, if TheElement is in a 5 level list.

Returns

The hgbst_elm.objid value for the default element in a given level of a user-defined list. If the list for this level is empty, -1 is returned.

Error Codes

Value | Meaning
10008 | ListName must not be empty.
10009 | Invalid ListName.

Examples

The following example displays the default element objid for different elements in different levels of the FAMILY user-defined list.

JavaScript:

The default element objid for 'Family:Software':
<%=FCApp.GetHgbstElmDefaultObjid("Family","Software")%>
<BR>
The default element objid for 'Operating Systems' in 'Family:Bad Level':<BR>
Note that this will cause an error to be thrown.<BR>

<%
try{
    FCApp.GetHgbstElmDefaultObjid("Family", "Bad Level")
}
catch (e) {
    Response.Write(e.description);
}
%>


GetHgbstElmDefault | fcSDK Documentation

GetHgbstElmDefault

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function GetHgbstElmDefault(ByVal ListName As String,
        Optional ByVal Element1 As String = "", Optional ByVal Element2 As String = "", Optional ByVal Element3 As String = "", Optional ByVal Element4 As String = "") As String

Description

This method returns the hgbst_elm.title for the default element in a given level of a user-defined list. You may use up to a 5-level list. If an default element has not been defined, then the first element is returned. The hgbst tables are cached in the FCApplication object, so this method does not cause a database round-trip.

Parameters

Parameter Name | Required? | Description
ListName | Yes | The user-defined list name.
Element1 | No | The parent element for TheElement, if TheElement is in a 2 level list. Else, the parent element for Element2.
Element2 | No | The parent element for TheElement, if TheElement is in a 3 level list. Else, the parent element for Element3.
Element3 | No | The parent element for TheElement, if TheElement is in a 4 level list. Else, the parent element for Element4.
Element4 | No | The parent element for TheElement, if TheElement is in a 5 level list.

Returns

The hgbst_elm.title string for the default element in a given level of a user-defined list. If the list for this level is empty, "" (empty string) is returned.

Error Codes

Value | Meaning
10008 | ListName must not be empty.
10009 | Invalid ListName.

Examples

The following example displays the Family:Software user-defined list, and sets the default value to be selected.

JavaScript:

FAMILY:SOFTWARE:
<SELECT NAME="FAMILY2">
<%
var def = FCApp.GetHgbstElmDefault("FAMILY","Software");
var TheList = FCApp.GetHgbstList("FAMILY","Software");
while (! TheList.EOF) { %>
  <option
  <% if (TheList("title") == def) { %>
  selected = true <% } %> >
  <%=TheList("title")%>
  <% TheList.MoveNext; %>
  </option>
<% } %>
</SELECT>

<%
TheList.Close();
%>}


GetHgbstElmObjid | fcSDK Documentation

GetHgbstElmObjid

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function GetHgbstElmObjid(ByVal TheElement As String,
    ByVal ListName As String, Optional ByVal Element1 As String = "", Optional ByVal Element2 As String = "", Optional ByVal Element3 As String = "", Optional ByVal Element4 As String = "") As Long

Description

This method returns the hgbst_elm.objid value for a given element in a given level of a user-defined list. You may use up to a 5-level list. The hgbst tables are cached in the FCApplication object, so this method does not cause a database round-trip.

Parameters

Parameter Name | Required? | Description
TheElement | Yes | The element to get the objid for.
ListName | Yes | The user-defined list name.
Element1 | No | The parent element for TheElement, if TheElement is in a 2 level list. Else, the parent element for Element2.
Element2 | No | The parent element for TheElement, if TheElement is in a 3 level list. Else, the parent element for Element3.
Element3 | No | The parent element for TheElement, if TheElement is in a 4 level list. Else, the parent element for Element4.
Element4 | No | The parent element for TheElement, if TheElement is in a 5 level list.

Returns

The hgbst_elm.objid value for a given element in a given level of a user-defined list.

Error Codes

Value | Meaning
10008 | ListName must not be empty.
10009 | Invalid ListName.
10015 | Invalid Element for List.

Examples

The following example displays an objid for different elements in different levels of the FAMILY user-defined list.

JavaScript:

The objid for 'Operating Systems' in 'Family:Software':
<%=FCApp.GetHgbstElmObjid("Operating Systems", "Family","Software")%>
<BR>
The objid for 'Operating Systems' in 'Family:Bad Level':<BR>
Note that this will cause an error to be thrown.<BR>

<%
try {
  FCApp.GetHgbstElmObjid("Operating Systems", "Family", "Bad Level") }
catch (e) {
  Response.Write(e.description); }
%>

The following example retrieves the objids the first, 2nd, and 3rd levels of the CR_DESC user-defined list.

The first level item is "PC", and the 2nd level item is "Windows 3.1", and the 3rd level item is "16m".

Visual Basic:

Dim ElmObjid1 As Long
Dim ElmObjid2 As Long
Dim ElmObjid3 As Long

ElmObjid1 = fc_app.GetHgbstElmObjid("PC", "CR_DESC")
ElmObjid2 = fc_app.GetHgbstElmObjid("Windows 3.1", "CR_DESC", "PC")
ElmObjid3 = fc_app.GetHgbstElmObjid("16m", "CR_DESC", "PC", "Windows 3.1")


GetHgbstList | fcSDK Documentation

GetHgbstList

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function GetHgbstList  (ByVal ListName As String,
        Optional ByVal Element1 As String = "", Optional ByVal Element2 As String = "", Optional ByVal Element3 As String = "", Optional ByVal Element4 As String = "") As ADODB.Recordset

Description

This method returns an ADO recordset containing the records for a given level of a user-defined list. You may use up to a 5-level list. The hgbst tables are cached in the FCApplication object, so this method does not cause a database round-trip.

When finished with the returned recordset, you should close the recordset using the .Close method and then set your variable to Nothing or Null. This will release the resources needed for this object.

Parameters

Parameter Name | Required? | Description
ListName | Yes | The user-defined list name.
Element1 | No | The parent element for TheElement, if TheElement is in a 2 level list. Else, the parent element for Element2.
Element2 | No | The parent element for TheElement, if TheElement is in a 3 level list. Else, the parent element for Element3.
Element3 | No | The parent element for TheElement, if TheElement is in a 4 level list. Else, the parent element for Element4.
Element4 | No | The parent element for TheElement, if TheElement is in a 5 level list.

Returns

An ADO recordset containing the records for a given level of a user-defined list.

Error Codes

Value | Meaning
10008 | ListName must not be empty.
10009 | Invalid ListName.

Examples

The following example displays the Family:Software user-defined list, and sets the default value to be selected.

JavaScript:

FAMILY:SOFTWARE:

<SELECT NAME="FAMILY2">

<%
var def = FCApp.GetHgbstElmDefault("FAMILY","Software");
var TheList = FCApp.GetHgbstList("FAMILY","Software");
while (! TheList.EOF) { %>
  <option
  <% if (TheList("title") == def) { %>
  selected = true <% } %> >
  <%=TheList("title")%>
  <% TheList.MoveNext; %>
  </option>
<% } %>
</SELECT>

<%
TheList.Close();
%>}


GetMachineTimeZone | fcSDK Documentation

GetMachineTimeZone

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Property Get GetMachineTimeZone() As String

Description

This method returns a string indicating the time zone of the machine running the First Choice Foundation Library. This method uses a Win32 API call to retrieve the time zone. This may not exactly coordinate with a time zone in the Clarify database time_zone table.

Returns

A string indicating the time zone of the machine running the First Choice Generic Business Objects.

Example

The following sets the server time zone to be the machine time zone.

JavaScript:

The server time zone is <%=FCApp.ServerTimeZone%>.<BR>

The machine time zone is <%=FCApp.GetMachineTimeZone%>.<BR>

<% FCApp.SetServerTimeZoneToMachineTimeZone(); %>

The server time zone is now <%=FCApp.ServerTimeZone%>.<BR>


GetRelationData | fcSDK Documentation

GetRelationData

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function GetRelationData(ByVal rel_name As String, _
                ByVal tbl_name As String) As ADODB.Recordset

Description

This method returns the meta-data for the specified relation from the Clarify ADP table (adp_sch_rel_info). It returns a recordset (of one record) with the data for this relation. For more information about the Clarify ADP tables, please see the Clarify documentation, or contact First Choice Software.

Note: This method is only for advanced users who need to directly manipulate relation data in Clarify. Most applications will never need to use this method.

Parameters

Parameter Name | Required? | Description
rel_name | Yes | The name of the relation
tbl_name | Yes | The name of the table (without the "table_" prefix)

Returns

The record from adp_sch_rel_info with data about the specified relation.

Error Codes

Value | Meaning
10001 | The specified relation is not found for the specified table, or the table name is not valid

Examples

The following example returns data about the case_reporter2site relation in the case table:

Visual Basic:

Dim rel_data As New ADODB.Recordset

Set rel_data = fc_app.GetRelationData("case_reporter2site", "case")

MsgBox rel_data("inv_rel_name")


GetServerTimeZoneOffset | fcSDK Documentation

GetServerTimeZoneOffset

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function GetServerTimeZoneOffset() As Long

Description

This method returns the number of seconds the server time zone is offset from GMT. The time_zone table is cached in the FCApplication object, so this method does not cause a database round-trip.

Returns

The offset of the server time zone from GMT, in seconds.

Example

The following example displays the offset for the server time zone.

JavaScript:

The server time zone is <%=FCApp.ServerTimeZone%>.

The server time zone offset, in seconds =

<%=FCApp.GetServerTimeZoneOffset %>


GetShortTimeZoneObjid | fcSDK Documentation

GetShortTimeZoneObjid

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function GetShortTimeZoneObjid(ByVal TimeZone As String) As Long

Description

This method returns an objid for a given time zone. If the time zone is not found, this method returns a value of zero. The time_zone table is cached in the FCApplication object, so this method does not cause a database round-trip.

Note: The time zone used should be the short time zone ("CST") instead of the long one ("Central Time Zone").

Parameters

Parameter Name | Required? | Description
TimeZone | Yes | Name of time zone to get the objid for.

Returns

The objid of the time zone. Zero, if the time zone is not found.

Example

The following example retrieves the objid for a time zone.

**JavaScript:**

var TimeZone = Request.Form("TZ").Item;

var TimeZoneObjid = FCApp.GetShortTimeZoneObjid(TimeZone);


GetStateObjid | fcSDK Documentation

GetStateObjid

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function GetStateObjid(ByVal Country As String, ByVal State As String) As Long

Description

This method returns an objid for a given state in a given country. If the state or country is not found, this method returns a value of zero. The state and country tables are cached in the FCApplication object, so this method does not cause a database round-trip.

Note: The state name supplied should be the "short" name (such as "TX").

Parameters

Parameter Name | Required? | Description
Country | Yes | Name of country.
State | Yes | Name of state to get the objid for.

Returns

The objid of the state. Zero, if the state or country is not found.

Error Codes

Value | Meaning
10011 | Country must not be empty.
10013 | State must not be empty.

Examples

The following example checks is a given state from a posted form is valid for the posted country.

JavaScript:

var country = Request.Form("country").Item;
var state = Request.Form("state").Item;
var StateObjid = FCApp.GetStateObjid(country,state;
If (StateObjid > 0)
{
  Response.Write(state + " is a valid state in " + country);
}
else
{
  Response.Write(state + " is NOT a valid state in " + country);
}


GetStates | fcSDK Documentation

GetStates

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function GetStates(ByVal Country As String) As ADODB.Recordset

Description

This method returns a recordset containing the state_prov records for a given country.

The state_prov and country tables are cached in the FCApplication object, so this method does not cause a database round-trip.

When finished with the returned recordset, you should close the recordset using the .Close method and then set your variable to Nothing or Null. This will release the resources needed for this object.

Parameters

Parameter Name | Required? | Description
Country | Yes | Name of country to get the states for.

Returns

An ADO recordset containing the state_prov records.

Error Codes

Value | Meaning
10011 | Country must not be empty.
10012 | Invalid Country

Examples

The following example builds a drop-down list of states for the default. The default state is selected.

JavaScript:

<SELECT NAME="States">
<%
var defCountry = FCApp.GetDefaultCountry();
var StateList = FCApp.GetStates(defCountry);
var defState = FCApp.GetDefaultState(defCountry);
while (! StateList.EOF) { %>
  <option
  <% if (StateList("name") == defState) { %>
  selected = true <% } %> >
  <%=StateList("name")%>
  <% StateList.MoveNext; %>
  </option>
<% } %>
</SELECT>

<%
StateList.Close();
StateList = null;
%>


GetTableID | fcSDK Documentation

GetTableID

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function GetTableID(ByVal TableName As String) As Long

Description

This method returns the table number (or ID) for a given table name (or view name). It reads this information from the Clarify ADP tables from the FCFL cache, so no database roundtrips are needed.

This method is for advanced users only, and will seldom be called for most applications.

Note: The name of the table provided should not include the "table_" prefix.

Parameters

Parameter Name | Required? | Description
TableName | Yes | Name of table or view in the Clarify database.

Returns

The table number for the supplied table name. If no table name is found, -1 is returned.

Example

The following example prints out the table number for a Clarify table and a Clarify view.

JavaScript:

Response.Write("Table number for contact = " +
            FCApp.GetTableID("contact"));
Response.Write("View number for site_view = " +
            FCApp.GetTableID("site_view"));


GetTableName | fcSDK Documentation

GetTableName

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function GetTableName(ByVal TableNum As Long) As String

Description

This method returns the table name for a given table number (or view number). It reads this information from the Clarify ADP tables from the FCFL cache, so no database roundtrips are needed.

This method is for advanced users only, and will seldom be called for most applications.

Note: The name of the table returned will not include the "table_" prefix.

Parameters

Parameter Name | Required? | Description
TableNum | Yes | Number of table or view in the Clarify database.

Returns

The table name for the supplied table number. If the supplied number is not valid "" is returned.

Example

The following example prints out the table names for a Clarify table and a Clarify view.

JavaScript:

Response.Write("Table name for table 52 = " +
            FCApp.GetTableName(52));
Response.Write("View name for view 88 = " +
            FCApp.GetTableName(88));


GetTimeZoneList | fcSDK Documentation

GetTimeZoneList

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function GetTimeZoneList() As ADODB.Recordset

Description

This method returns a recordset containing the time_zone records

The time_zone table is cached in the FCApplication object, so this method does not cause a database round-trip.

When finished with the returned recordset, you should close the recordset using the .Close method and then set your variable to Nothing or Null. This will release the resources needed for this object.

Returns

An ADO recordset containing the time_zone records.

Example

The following example builds a drop-down list of time zones. The default time zone is selected.

JavaScript:

<SELECT NAME="TZ">
<%
var defTZ = FCApp.GetDefaultTimeZone();
var TZList = FCApp.GetTimeZoneList();

while (! TZList.EOF) { %>
  <option
  <% if (TZList("full_name") == defTZ) { %>
  selected = true <% } %> >
  <%=TZList("full_name")%>
  <% TZList.MoveNext; %>
  </option>
<% } %>
</SELECT>

<%
TZList.Close();
TZList = null;
%>


GetTimeZoneObjid | fcSDK Documentation

GetTimeZoneObjid

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function GetTimeZoneObjid(ByVal TimeZone As String) As Long

Description

This method returns an objid for a given time zone. If the time zone is not found, this method returns a value of zero. The time_zone table is cached in the FCApplication object, so this method does not cause a database round-trip.

Note: The time zone used should be the short time zone ("Central Time Zone") instead of the long one ("CST")

Parameters

Parameter Name | Required? | Description
TimeZone | Yes | Name of time zone to get the objid for.

Returns

The objid of the time zone. Zero, if the time zone is not found.

Example

The following example retrieves the objid for a time zone.

JavaScript:

var TimeZone = Request.Form("TZ").Item;
var TimeZoneObjid = FCApp.GetTimeZoneObjid(TimeZone);


GetTimeZoneOffset | fcSDK Documentation

GetTimeZoneOffset

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function GetTimeZoneOffset(ByVal TimeZone As String) As Long

Description

This method returns the number of seconds the given time zone is offset from GMT. If the time zone is not found, this method returns a value of zero. The time_zone table is cached in the FCApplication object, so this method does not cause a database round-trip.

Parameters

Parameter Name | Required? | Description
TimeZone | Yes | Name of time zone to get the offset for.

Returns

The offset of the time zone from GMT, in seconds. Zero, if the time zone is not found.

Example

The following example retrieves the offset for a time zone.

JavaScript:

<%
var TZ = "Eastern Standard Time";
var TZOffset = FCApp.GetTimeZoneOffset(TZ);
%>

<%=TZ%> is <%=TZOffset%> seconds ahead of GMT.


GetTimeZonesInCountry | fcSDK Documentation

GetTimeZonesInCountry

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function GetTimeZonesInCountry(ByVal Country As String)
  As ADODB.Recordset

Description

This method returns a recordset containing the list time_zone records for the given country.

When finished with the returned recordset, you should close the recordset using the .Close method and then set your variable to Nothing or Null. This will release the resources needed for this object.

Parameters

Parameter Name | Required? | Description
Country | Yes | Country Name

Returns

A recordset containing the list time_zone records for the given country.

Example

The following example populates a drop-down list of time zones for a particular country.

Visual Basic:

Sub FillTZ(TheCountry)
  ' Clear the existing list
  ddl_timezone.Clear

  'Get the List of TimeZones
  'Fill into the drop-down list
  'Save the First Time Zone for this country
  'Close the recordset

  Dim TZList As ADODB.Recordset
  Set TZList = FCApp.GetTimeZonesInCountry(TheCountry)

  FirstTZ = ""
  If Not TZList.EOF Then
    FirstTZ = TZList("full_name")
  End If

  While Not TZList.EOF
    ddl_timezone.AddItem TZList("full_name")
    TZList.MoveNext
  Wend

  TZList.Close
  TZList = Nothing

   'Get the Default Time Zone
   'If the default TimeZone is in this country
   'Then set this one to be selected
   'Else, set the first time zone to be selected

  defTZ = FCApp.GetDefaultTimeZone

  If FCApp.IsTimeZoneInCountry(TheCountry, defTZ, True) Then
    ddl_timezone.Text = defTZ
  Else If FirstTZ <> "" Then
    ddl_timezone.Text = FirstTZ
  End If
End Sub


Initialize | fcSDK Documentation

Initialize

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Sub Initialize()

Description

This method initializes the FCApplication, including:

  • Reading the fc.env file
  • Logging into the database
  • Opening Log Files
  • Caching schema data
  • Caching meta-data

Example

The following example displays the schema revision of the database.

JavaScript:

var FCApp = new ActiveXObject("FCFL.fcapplication");
FCApp.WorkingDirectory = "C:\\\inetpub\\\wwwroot\\\production";
FCApp.Initialize();


InitializeFull | fcSDK Documentation

InitializeFull

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Sub InitializeFull( LoginName As String, password As String, _
                DBServer As String, DBName As String, _
                Optional DBType As String, _
                Optional LogFile As String, _
                Optional SqlLogFile As String, _
                Optional SQLLogging As Boolean, _
                Optional fcAppLogging As Boolean, _
                Optional fcSessionLogging As Boolean, _
                Optional fcGenericLogging As Boolean, _
                Optional fcBulkLogging As Boolean, _
                Optional fcSqlExecLogging As Boolean, _
                Optional NoCacheFile As Boolean)

Description

This method is similar to the Initialize method, in that it initializes the FCApplication. However, rather than reading data from an fc.env file, the necessary login parameters are passed into this method.

This method initializes the FCApplication, including:

  • Logging into the database
  • Opening Log Files
  • Caching schema data
  • Caching meta-data
  • Writing cached meta-datafor additional information on the parameters, refer to the fc.env section of the FCFL user guide.

Parameters

Parameter Name | Required? | Description
LoginName | Yes | Country Name
Password | Yes | Password
DBServer | Yes | Database Server Name
DBName | Yes | Database Name
DBType | No | Database Type. Default value is MSSQL.
LogFile | No | Log File Name
SqlLogFile | No | SQL Log File Name
fcAppLogging | No | Log FCApplication Methods/Properties?
fcSessionLogging | No | Log FCSession Methods/Properties?
fcGenericLogging | No | Log FCGeneric Methods/Properties?
fcBulkLogging | No | Log FCBulk Methods/Properties?
fcSqlExecLogging | No | Log FCSqlExec Methods/Properties?
NoCacheFile | No | If true, don't write XML cache files to disk

Example

The following example initializes the FCApplication object..

JavaScript:

var FCApp = new ActiveXObject("FCFL.fcapplication");

FCApp.InitializeFull("sa","MyPassword","MyServer","MyDatabase", "MSSQL");


is_it_a_field | fcSDK Documentation

is_it_a_field

Object and Type

Object : FCApp

Type : Method

Prototype

Public Function is_it_a_field(tbl_name As String, _
                              field_name As String) As Boolean

Description

This method returns whether a given field name is defined as a field on the specified table. This method also works for fields defined in views.

Parameters

Parameter Name | Required? | Description
tbl_name | Yes | Name of the table or view
field_name | Yes | Name of the field.

Returns

A boolean (true/false) that tells if the field is a valid field in the table.

Example

The example shows if "id_number" is a valid field in the case table.

Visual Basic:

Debug.Print "Is the field 'id_number' in the case table? " & _
      CStr(FCApp.is_it_a_field("case", "id_number"))


is_it_a_table | fcSDK Documentation

is_it_a_table

Object and Type

Object : FCApp

Type : Method

Prototype

Public Function is_it_a_table(tbl_name As String) As Boolean

Description

This method returns whether a given table name is defined in the database as a valid table. This method does not work on views, only on tables.

Parameters

Parameter Name | Required? | Description
tbl_name | Yes | Name of the table

Returns

A boolean (true/false) that tells if the table name is valid.

Example

The example shows if "site_part" is a valid table in the database.

Visual Basic:

Debug.Print "Is 'site_part' a valid table name? " & _
            CStr(FCApp.is_it_a_table("site_part"))


is_it_change_field | fcSDK Documentation

is_it_change_field

Object and Type

Object : FCApp

Type : Method

Prototype

Public Function is_it_change_field(tbl_name As String, _
                      field_name As String) As Boolean

Description

This method returns whether a given field is defined (in the specified table) as a change field.

Parameters

Parameter Name | Required? | Description
tbl_name | Yes | Name of the table
field_name | Yes | Name of the field

Returns

A boolean (true/false) that tells if the field is a valid change field in the specified table.

Example

The example shows if "title" is a valid change field for the case table.

Visual Basic:

Debug.Print "Is 'title' a valid change field in the 'case' table? " & _
            CStr(FCApp.is_it_change_field("case", "title"))


is_it_date_field | fcSDK Documentation

is_it_date_field

Object and Type

Object : FCApp

Type : Method

Prototype

Public Function is_it_date_field(tbl_name As String, _
                                 field_name As String) As Boolean

Description

This method returns whether a given field is defined (in the specified table) as a date/time field.

Parameters

Parameter Name | Required? | Description
tbl_name | Yes | Name of the table
field_name | Yes | Name of the field

Returns

A boolean (true/false) that tells if the field is a valid date/time field in the specified table.

Example

The example shows if "creation_time" is a valid date/time field for the case table.

Visual Basic:

Debug.Print "Is 'creation_time' a valid date field in the 'case' " & _
   "table? " & CStr(FCApp.is_it_date_field("case", "creation_time"))


is_it_int_field | fcSDK Documentation

is_it_int_field

Object and Type

Object : FCApp

Type : Method

Prototype

Public Function is_it_a_field(tbl_name As String, _
                              field_name As String) As Boolean

Description

This method returns whether a given field is defined (in the specified table) as an integer field.

Parameters

Parameter Name | Required? | Description
tbl_name | Yes | Name of the table
field_name | Yes | Name of the field

Returns

A boolean (true/false) that tells if the field is a valid integer field in the specified table.

Example

The example shows if "objid" is a valid integer field for the case table.

Visual Basic:

Debug.Print "Is 'objid' a valid integer field in the 'case' table? " _
          & CStr(FCApp.is_it_int_field("case", "objid"))


is_it_searchable | fcSDK Documentation

is_it_searchable

Object and Type

Object : FCApp

Type : Method

Prototype

Public Function is_it_searchable(tbl_name As String, _
                                 field_name As String) As Boolean

Description

This method returns whether a given field is defined (in the specified table) as a searchable field. This is defined only for Oracle databases. SQL Server and Sybase databases do not define searchable (s_) columns. This method will always return "false" for those database types.

Parameters

Parameter Name | Required? | Description
tbl_name | Yes | Name of the table
field_name | Yes | Name of the field

Returns

A boolean (true/false) that tells if the field is a valid searchable field in the specified table. Oracle only. Other databases always return "false."

Example

The example shows if "title" is a valid searchable (string) field for the case table.

Visual Basic:

Debug.Print "Is 'title' a valid searchable field in the 'case' table? " & CStr(FCApp.is_it_searchable("case", "title"))


is_it_string_fld | fcSDK Documentation

is_it_string_fld

Object and Type

Object : FCApp

Type : Method

Prototype

Public Function is_it_string_fld(tbl_name As String, _
                                 field_name As String) As Boolean

Description

This method returns whether a given field is defined (in the specified table) as a string field.

Parameters

Parameter Name | Required? | Description
tbl_name | Yes | Name of the table
field_name | Yes | Name of the field

Returns

A boolean (true/false) that tells if the field is a valid string field in the specified table.

Example

The example shows if "title" is a valid string field for the case table.

Visual Basic:

Debug.Print "Is 'title' a valid string field in the 'case' table? " & _
            CStr(FCApp.is_it_string_fld("case", "title"))


is_it_unicode | fcSDK Documentation

is_it_unicode

Object and Type

Object : FCApp

Type : Method

Prototype

Public Function is_it_unicode(tbl_name As String, _
                              field_name As String) As Boolean

Description

This method returns whether a given field is defined (in the specified table) as a unicode string field.

Parameters

Parameter Name | Required? | Description
tbl_name | Yes | Name of the table
field_name | Yes | Name of the field

Returns

A boolean (true/false) that tells if the field is a valid unicode string field in the specified table.

Example

The example shows if "title" is a valid unicode string field for the case table.

Visual Basic:

Debug.Print "Is 'title' a valid unicode string field in the 'case'" & _
            " table? " & CStr(FCApp.is_it_unicode("case", "title"))


is_rel_exclusive | fcSDK Documentation

is_rel_exclusive

Object and Type

Object : FCApp

Type : Method

Prototype

Public Function is_rel_exclusive(tbl_num As Long, rel_name As String, _
                                 tbl_fld As String, _
                                 objid_fld As String) As Boolean

Description

This method determines if the specified relation is an exclusive relation (or not) for the specified table. If it is, the final two arguments are filled in with the names of the table and objid fields that are used to perform the exclusive relation functionality.

Parameters

Parameter Name | Required? | Description
tbl_num | Yes | Number of the table (e.g. case=0)
rel_name | Yes | Name of the relation
tbl_fld | Yes | Contains the name of the field used to store the table number for the related table
objid_fld | Yes | Contains the name of the field used to store the objid for the relation

Returns

A boolean (true/false) that tells if the relation is an exclusive relation. If it is, the final two arguments contain the names of the fields (in the tbl_name table) that contain the table number and the objid data.

Example

The example shows if "case2r_rqst" is a valid exclusive relation for the case table.

Visual Basic:

  Dim tbl_fld   As String
  Dim objid_fld As String
  Dim ret_bool  As Boolean

  ret_bool = FCApp.is_rel_exclusive(0, "case2r_rqst", _
                                     tbl_fld, objid_fld)

  If ret_bool Then
     Debug.Print "It is exclusive. The table field is '" & tbl_fld & _
       "' and the objid field is '" & objid_fld & "'" | Else | Debug.Print "Is it not an exclusive relation."
  End If


is_rel_mandatory | fcSDK Documentation

is_rel_mandatory

Object and Type

Object : FCApp

Type : Method

Prototype

Public Function is_rel_mandatory(tbl_num As Long, _
                rel_name As String) As Boolean

Description

This method determines if the specified relation is a mandatory relation.

Parameters

Parameter Name | Required? | Description
tbl_num | Yes | Number of the table (e.g. case=0)
rel_name | Yes | Name of the relation

Returns

A boolean (true/false) that tells if the relation is a mandatory relation.

Example

The example shows if "case_reporter2contact" is a valid mandatory relation for the case table.

Visual Basic:

Debug.Print "Is 'case_reporter2contact' mandatory? " & _
         CStr(FCApp.is_rel_mandatory(0, "case_reporter2contact"))


IsCountry | fcSDK Documentation

IsCountry

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function IsCountry(ByVal Country As String) As Boolean

Description

This method returns a boolean indicating if the given country is a valid country name in the database. The country table is cached in the FCApplication object, so this method does not cause a database round-trip.

Parameters

Parameter Name | Required? | Description
Country | Yes | Name of country to be validated.

Returns

A boolean value indicating if the given country is found in the database or not.

Example

The following example checks is a given value from a posted form is a valid country.

JavaScript:

var country = Request.Form("country").Item;
If (FCApp.IsCountry(country))
 { Response.Write(country + " is a valid country."); }
else
 { Response.Write(country + " is NOT a valid country."); }


IsFullState | fcSDK Documentation

IsFullState

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function IsFullState(ByVal Country As String, ByVal State As String) As Boolean

Description

This method returns a boolean indicating if the given state is valid for the given country. The state and country tables are cached in the FCApplication object, so this method does not cause a database round-trip.

Note: The state name used should be the full name ("Texas"), not the short name ("TX")

Parameters

Parameter Name | Required? | Description
Country | Yes | Name of country.
State | Yes | Name of state to be validated.

Returns

A boolean indicating if the given state is valid for the given country.

Error Codes

Value | Meaning
10011 | Country must not be empty.
10013 | State must not be empty.

Examples

The following example checks is a given state from a posted form is valid for the posted country.

JavaScript:

var country = Request.Form("country").Item;
var state = Request.Form("state").Item;

If (FCApp.IsFullState(country,state)
{
  Response.Write(state + " is a valid state in " + country);
}
else
{
  Response.Write(state + " is NOT a valid state in " + country);
}


IsInGbstLst | fcSDK Documentation

IsInGbstLst

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function IsInGbstLst(ByVal ListName As String, ByVal Element As String) As Boolean

Description

This method returns a boolean value indicating if a given string is a valid element in a given Application Popup list.

The gbst_elm table is cached in the FCApplication object, so this method does not cause a database round-trip.

Parameters

Parameter Name | Required? | Description
ListName | Yes | An Application popup list name.
Element | Yes | The element to be checked for its existence in the list.

Returns

True if the Element does exist in the ListName list. Else, False.

Error Codes

Value | Meaning
10008 | ListName must not be empty.
10009 | Invalid ListName.
10010 | Element must not be empty.

Examples

The following example checks is a given value from a posted form is a valid Case Priority.

JavaScript:

var ListName = "Response Priority Code";
var ListValue = Request.Form("priority").Item;

If (FCApp.IsInGbstLst(ListName,ListValue))
 { Response.Write(ListValue + " is a valid " + ListName); }
else
 { Response.Write(ListValue + " is NOT a valid " + ListName); }


IsInHgbstLst | fcSDK Documentation

IsInHgbstLst

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function IsInHgbstList (ByVal TheElement As String,
        ByVal ListName As String, Optional ByVal Element1 As String = "", Optional ByVal Element2 As String = "", Optional ByVal Element3 As String = "", Optional ByVal Element4 As String = "") As Boolean

Description

This method returns a boolean value indicating if a given string is a valid element in a given user-defined list. You may validate an element up to a 5-level list. The hgbst tables are cached in the FCApplication object, so this method does not cause a database round-trip.

Parameters

Parameter Name | Required? | Description
TheElement | Yes | The element to be checked for its existence in the list.
ListName | Yes | The user-defined list name.
Element1 | No | The parent element for TheElement, if TheElement is in a 2 level list. Else, the parent element for Element2.
Element2 | No | The parent element for TheElement, if TheElement is in a 3 level list. Else, the parent element for Element3.
Element3 | No | The parent element for TheElement, if TheElement is in a 4 level list. Else, the parent element for Element4.
Element4 | No | The parent element for TheElement, if TheElement is in a 5 level list.

Returns

True if the Element does exist in the ListName list. Else, False.

Error Codes

Value | Meaning
10008 | ListName must not be empty.
10009 | Invalid ListName.
10015 | Invalid Element for List.

Examples

The following example verifies different elements in different levels of the FAMILY user-defined list.

The code in this example is written in JavaScript for inclusion in ASP pages.

JavaScript:

is 'Operating Systems' a valid element in 'Family' ? <BR>

<%=FCApp.IsInHgbstList("Operating Systems", "Family")%> <BR> is 'Operating Systems' a valid element in 'Family:Software' ? <BR>

<%=FCApp.IsInHgbstList("Operating Systems", "Family", "Software")%><BR> is 'Windows' a valid element in 'Family:Software:Operating Systems' ?

<BR>

<%=FCApp.IsInHgbstList("Windows", "Family", "Software",
                       "Operating Systems")%> is 'Operating Systems' a valid element in 'Family:Bad Level' ? <BR>
Note that this will cause an error to be thrown.<BR>

<%
try {
  FCApp.IsInHgbstList("Operating Systems", "Family", "Bad Level") }
catch (e) {
  Response.Write(e.description);
}
%>


IsOnDST | fcSDK Documentation

IsOnDST

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function IsOnDST(ByVal TheTimeZone As String, ByVal TheDate As Date) As Boolean

Description

This method returns a boolean indicating if the given date in the given time zone is on DST (Daylight Savings Time). This is done by examining the daylight_hr data from the database. The time_zone and daylight_hr tables are cached in the FCApplication object, so this method does not cause a database round-trip.

Parameters

Parameter Name | Required? | Description
TheTimeZone | Yes | Name of time zone.
TheDate | Yes | Date to be checked.

Returns

A boolean value indicating if the given time in the given time zone is on DST.

Example

The following example checks if the current database time is on DST.

JavaScript:

Are we currently on DST?

<%=FCApp.IsOnDST(FCApp.ServerTimeZone,FCSession.GetCurrentDate()) %>


IsState | fcSDK Documentation

IsState

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function IsState(ByVal Country As String, ByVal State As String) As Boolean

Description

This method returns a boolean indicating if the given state is valid for the given country. The state and country tables are cached in the FCApplication object, so this method does not cause a database round-trip.

Parameters

Parameter Name | Required? | Description
Country | Yes | Name of country.
State | Yes | Name of state to be validated.

Returns

A boolean indicating if the given state is valid for the given country.

Error Codes

Value | Meaning
10011 | Country must not be empty.
10013 | State must not be empty.

Examples

The following example checks is a given state from a posted form is valid for the posted country.

JavaScript:

var country = Request.Form("country").Item;

var state = Request.Form("state").Item;

If (FCApp.IsState(country,state)
{
  Response.Write(state + " is a valid state in " + country);
}
else
{
  Response.Write(state + " is NOT a valid state in " + country);
}


IsTimeZone | fcSDK Documentation

IsTimeZone

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function IsTimeZone(ByVal TimeZone As String) As Boolean

Description

This method returns a boolean indicating if the given time zone is a valid time zone in the database. The time_zone table is cached in the FCApplication object, so this method does not cause a database round-trip.

Parameters

Parameter Name | Required? | Description
TimeZone | Yes | Name of time zone to be validated.

Returns

A boolean value indicating if the given time zone is found in the database or not.

Example

The following example checks is a given value from a posted form is a valid time zone.

JavaScript:

var time_zone = Request.Form("timezone").Item; If (FCApp.IsTimeZone(time_zone))
 { Response.Write(time_zone + " is a valid time_zone."); }
else
 { Response.Write(time_zone + " is NOT a valid time_zone."); }


IsTimeZoneInCountry | fcSDK Documentation

IsTimeZoneInCountry

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function IsTimeZoneInCountry(ByVal Country As String,
                                    ByVal TimeZone As String,
                                    ByVal IsFullName As Boolean) As Boolean

Description

This method returns a boolean indicating if the given time zone is valid for the given country. The time zone and country tables are cached in the FCApplication object, so this method does not cause a database round-trip.

Parameters

Parameter Name | Required? | Description
Country | Yes | Country Name
TimeZone | Yes | TimeZone name or TimeZone Full Name
IsFullName | Yes | Boolean indicating if the TimeZone is the name or the Full name.

Returns

A boolean value indicating if the given time zone is valid for the given country.

Example

The following example checks if a given time zone is valid for the given country using the (short) name of the time zone.

JavaScript:

var country = "USA"
var time_zone = "PST" If (FCApp.IsTimeZoneInCountry(country,time_zone,false)) {
  Response.Write(time_zone + " is valid for " + country); }
else {
  Response.Write (time_zone + " is NOT valid for " + country); }

The following example checks if a given time zone is valid for the given country using the full_name of the time zone.

JavaScript:

var country = "United Kingdom"

var time_zone = "Greenwich Mean Time" If (FCApp.IsTimeZoneInCountry(country,time_zone,true)) {
  Response.Write (time_zone + " is valid for " + country); }
else {
  Response.Write (time_zone + " is NOT valid for " + country); }


Log(FCApplication) | fcSDK Documentation

Log(FCApplication)

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Sub Log(TheMessageType As String, TheMessage As String)

Description

This method allows you to log a message to the FCFL log file. FCApplication logging must be turned on for this message to actually be logged to the file.

Parameters

Parameter Name | Required? | Description
TheMessageType | Yes | The type of message, used to identify your message within the log file.
TheMessage | Yes | The message to be logged.

Example

The following example logs a message to the log file.

Visual Basic:

fc_app.Log "My Company", "This is a test message"

JavaScript:

fc_app.Log("My Company", "This is a test message");

Here is an example of what the entry will look like in the log file:

10/27/2003 11:59:12 AM : My Company

This is a test message


LogEx(FCApplication) | fcSDK Documentation

LogEx(FCApplication)

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Sub LogEx(logLevel as String, logMessage As String)

Description

Alternate logging method that allows setting the log level. This method is similar to Logger.Log except that the log level is a string representation of the LogLevel enumeration (e.g "DEBUG", "INFO", "ERROR").

Parameters

Parameter Name | Required? | Description
logLevel | Yes | A string representation of the LogLevel enumeration (e.g "DEBUG", "INFO", "ERROR").
logMessage | Yes | The message to be logged.

Example

The following example logs a DEBUG message to the log file.

Visual Basic:

fc_app.LogEx "DEBUG", "This is a test debug message"

JavaScript:

fc_app.LogEx("DEBUG", "This is a test debug message");

Here is an example of what the entry will look like in the log file:

2004-11-15 14:21:31,469 \[DEBUG\] This is a test debug message.

Note, the log output can be easily modified by changing your Logging Configuration


RankIsInGbstList | fcSDK Documentation

RankIsInGbstList

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Function RankIsInGbstLst(ByVal ListName As String, ByVal Rank As Long) As Boolean

Description

This method returns a boolean indicating if an element having a given rank exists in a given Application Popup list. The gbst_elm table is cached in the FCApplication object, so this method does not cause a database round-trip.

Parameters

Parameter Name | Required? | Description
ListName | Yes | Application List Name
Rank | Yes | Rank of Element

Returns

A boolean indicating if an element having a given rank exists in a given Application Popup list.

Error Codes

Value | Meaning
10008 | ListName must not be empty.
10009 | Invalid ListName.

Examples

The following example verifies that the given activity code is valid.

Visual Basic:

act_code = 4700

If Not FCApp.RankIsInGbstLst("Activity Name", act_code) Then
  'Cleanup, Error, & Exit
   CloseGenerics 10, obj_rec, old_stat_rec, user_rec, emp_rec, _
        parent_rec, stat_lst_rec, cond_rec, tb_rec, _
        act_rec, stat_rec

   Err.Raise -5, ObjectName, _
        "Cannot find the activity string with rank = " & act_code
   Exit Function
End If


SetServerTimeZoneToMachineTimeZone | fcSDK Documentation

SetServerTimeZoneToMachineTimeZone

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Sub SetServerTimeZoneToMachineTimeZone()

Description

This property allows the server time zone to be set to the time zone of where the First Choice Generic Business Object is currently running. Typically, this will be a web server. The machine time zone is retrieved using standard Win32 API calls.

Example

The following example shows how to read and set the server time zone to be the machine time zone.

JavaScript:

The server time zone is currently <%=FCApp.ServerTimeZone%>.<BR>
<%
    var NewTZ = "Eastern Standard Time";
    FCApp.ServerTimeZone = NewTZ
%>

The server time zone is now <%=FCApp.ServerTimeZone%>.<BR>
The machine time zone is <%=FCApp.GetMachineTimeZone%>.<BR>

<% FCApp.SetServerTimeZoneToMachineTimeZone(); %>

The server time zone is now <%=FCApp.ServerTimeZone%>.


UpdateCache | fcSDK Documentation

UpdateCache

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Sub UpdateCache()

Description

This method updates the meta-data cache files, as well as the in-memory cache data. By having this method available, you can update your cache data on-the-fly, without having to restart your application, or re-instantiate your FCApplication object.

Example

The following example updates the meta-data cache information for an FCApplication object that is part of a web application.

JavaScript:

var FCApp = Application.Contents("FCApp");

FCApp.UpdateCache();


UpdateSchemaCache | fcSDK Documentation

UpdateSchemaCache

Object and Type

Object : FCApplication

Type : Method

Prototype

Public Sub UpdateSchemaCache()

Description

This method updates the schema cache files, as well as the in-memory schema data. By having this method available, you can update your schema data on-the-fly, without having to restart your application, or re-instantiate your FCApplication object.

Example

The following example updates the schema information for an FCApplication object that is part of a web application.

JavaScript:

var  FCApp;

FCApp = Application.Contents("FCApp");

FCApp.UpdateSchemaCache();


db_name | fcSDK Documentation

db_name

Object and Type

Object : FCApplication

Type : Property

Prototype

Public db_name As String

Description

Contains the name of the database as stored in adp_db_header.db_name.

Example

The following example displays the name of the database.

JavaScript:

<%
    var db_name;
    db_name = FCApp.db_name;
%>

Database Name = <%=db_name%>


db_type | fcSDK Documentation

db_type

Object and Type

Object : FCApplication

Type : Property

Prototype

Public db_type As String

Description

Contains the type of the database. It will be either "MSSQL" or "Oracle".

Example

The following example displays the type of database.

JavaScript:

<%
    var db_type;
    db_type = FCApp.db_type;
%>

Database Type = <%=db_type%>


IsDBTraveler | fcSDK Documentation

IsDBTraveler

Object and Type

Object : FCApp

Type : Property

Prototype

Public IsDBTraveler As Boolean

Description

This property tells whether the current database is Traveler-enabled, or not.

Values

Value | Description
FALSE | The database is a normal Clarify database.
TRUE | The database is Traveler-enabled.

Example

The example shows using the property.

Visual Basic:

Debug.Print "Is the database Traveler Enabled? " & _
      CStr(FCApp.IsDBTraveler)


Midnight | fcSDK Documentation

Midnight

Object and Type

Object : FCApplication

Type : Property

Prototype

Public Property Get Midnight() As String

Public Property Let Midnight(ByVal in_str As String)

Description

This property is specific to Oracle version 7.x databases. It should not be used for Oracle 8 or Oracle 9 databases.

It is part of a workaround for a bug in the OLEDB driver for Oracle.

The midnight property should be set to a valid time string for your database. For most customers, this will be "12:00:00 AM".

The value may also be set in the fc.env file. Refer to the fc.env section of the FCFL User Guide for more information.

Example

The following example sets the midnight time.

JavaScript:

FCApplication.Midnight='12:00:00 AM';


schema_rev | fcSDK Documentation

schema_rev

Object and Type

Object : FCApplication

Type : Property

Prototype

Public schema_rev As Integer

Description

Contains the schema revision of the database as stored in adp_db_header.schema_rev.

Example

The following example displays the schema revision of the database.

JavaScript:

<%
var schema_rev;
schema_rev = FCApp.schema_rev;
%>

Schema Revision = <%=schema_rev%>


ServerTimeZone | fcSDK Documentation

ServerTimeZone

Object and Type

Object : FCApplication

Type : Property

Prototype

Public Property Get ServerTimeZone() As String

public Property Let ServerTimeZone(ByVal NewTimeZone As String)

Description

This property allows the server time zone to be set or read. When the FCApplication is initialized, this property is initially set to the default time zone in the database.

Parameters

Parameter Name | Required? | Description
NewTimeZone | Yes | When setting the server time zone, the time zone full_name that it should be set to.

Returns

The full_name of the server time zone.

Example

The following example shows how to read and set the server time zone property.

JavaScript:

The server time zone is currently <%=FCApp.ServerTimeZone%>.<BR>
<%
    var NewTZ = "Eastern Standard Time";
    FCApp.ServerTimeZone = NewTZ
%>

The server time zone is now <%=FCApp.ServerTimeZone%>.


WorkingDirectory | fcSDK Documentation

WorkingDirectory

Object and Type

Object : FCApplication

Type : Property

Prototype

Public WorkingDirectory As String

Description

This is the working directory of the FCApplication object. This is the directory where the FCApplication will look for the fc.env file. This is also the directory under which cache files and log files will be created. Using this property will allow you to have multiple FCApplication objects accessing different databases, all from the same machine.

Example

The following example shows how to set this property.

JavaScript:

var FCApp;

FCApp = new ActiveXObject("FCFL.fcapplication");
FCApp.WorkingDirectory = "C:\\\inetpub\\\wwwroot\\\production";

Visual Basic:

Dim fc_app As New FCApplication

fc_app.WorkingDirectory = "C:\\inetpub\\wwwroot\\testing"


FCFL FCBulk Object | fcSDK Documentation

FCFL FCBulk Object

Overview

The FCBulk object is used to group generic objects together. Every generic object is always in one bulk or another. You may easily change which bulk a given generic object is in by changing the BulkName property of the generic object.

Using bulks is optional, but very useful. You may use the action methods (Query, Update, and UpdateAll) on a generic object. But, if you want all of the queries or updates for multiple generics to be performed in one unit of work (for referential integrity), you should use a bulk.

When you call on the action methods (such as UpdateAll) for a bulk object, all of the updates for all of the generics in that bulk will be completed in one transaction. All of the items in the bulk will be committed, or all will be rolled back. This is a simple, yet crucial concept for database programming.

There is a default bulk object, whose name is the empty string (""). When you create a new generic object, it is automatically placed in this bulk. You may then change the bulk for that generic.

You do not need to ever worry about creating bulks. FCFL does that for you. When you assign a generic to a bulk, FCFL will create the bulk for you, if needed.

Of the various properties and methods exposed by the FCBulk object, the only ones you will commonly use are the Query, Update, and UpdateAll methods.


NewEnum(FCBulk) | fcSDK Documentation

NewEnum(FCBulk)

Object and Type

Object : FCBulk

Type : Method

Description

Within the FCSession object, there is a method available for enumerating the available FCBulk objects.

Within the FCBulk object, there is a method available for enumerating the available FCGeneric objects.

Using these enumerators gives you access to all of the available FCBulk and FCGeneric objects.

Example

The following example demonstrates looping through and showing details about each FCBulk and each FCGeneric object.

JavaScript:

Response.Write('Open FCBulks and FCGenerics:');

for(var objEnum = new Enumerator(FCSession);
   !objEnum.atEnd(); objEnum.moveNext()) {
       bulk = objEnum.item();
       Response.Write('<br>FCBulk Name="' + bulk.name + '"');
       for(var objEnum2 = new Enumerator(bulk);
          !objEnum2.atEnd(); objEnum2.moveNext()) {
              gen = objEnum2.item();
              Response.Write('<br>&bull;DB Object Type=' +
                             gen.dbobjectname);
       }
}

Visual Basic:

For Each Bulk In fc_session
  Debug.Print "Bulk Name = " + Bulk.Name
  For Each Generic In Bulk
    Debug.Print "Generic DB Object Type = " + Generic.DbObjectName
  Next Generic
Next Bulk


Query(FCBulk) | fcSDK Documentation

Query(FCBulk)

Object and Type

Object : FCBulk

Type : Method

Prototype

Public Sub Query()

Description

This method causes each generic in the bulk to query the database (based on the DBObjectName, the Filter, the SortFields, and the DataFields you have set for this object) to retrieve records. The query retrieves 0 or more rows for each, and places them in the recordset for each generic object.

If you are using child objects (traversing from one generic object to another), only the "top-level" generics will be queried by the bulk. The children objects will also be queried, but as part of the parent query.

If you wish to query just one generic object, use the Query method on the generic object directly.

Note: If you perform a query on the generic object, the recordset for the records is then "Open." You may NOT perform another query on the same generic objects unless you close the recordset first. To do that, call on the following code (assume the name of the generic object is boCase):

boCase.Records.Close();

Note: For ADO-savvy users, the recordset for the generic object is disconnected from the database as a final part of the query.

Error Codes

There are no error codes for this method. However, it does call on FCGeneric.Query, which can generate errors. Please see that method's documentation for more information.

Example

The following example queries several objects, placed in a single bulk object.

JavaScript:

  // Get some cases, sites, and parts via a bulk
  var boCase = FCSession.CreateGeneric();
  boCase.SimpleQuery("case");
  boCase.AppendFilter("title", "contains", "a");

  var boSite = FCSession.CreateGeneric();
  boSite.SimpleQuery("site");
  boSite.AppendFilter("name", "like", "P%");

  var boPart = FCSession.CreateGeneric();
  boPart.SimpleQuery("part_num");

  boCase.Bulk.Query();

Visual Basic:

  Dim boCase As FCGeneric
  Dim boSite As FCGeneric
  Dim boPart As FCGeneric

  Set boCase = fc_session.CreateGeneric
  boCase.SimpleQuery ("case")
  boCase.AppendFilter "title", "contains", "a"

  Set boSite = fc_session.CreateGeneric
  boSite.SimpleQuery ("site")
  boSite.AppendFilter "name", "like", "P%"

  Set boPart = fc_session.CreateGeneric
  boPart.SimpleQuery ("part_num")

  boCase.Bulk.Query


RemoveAllGenerics | fcSDK Documentation

RemoveAllGenerics

Object and Type

Object : FCBulk

Type : Method

Prototype

Public Sub RemoveAllGenerics()

Description

This method removes (and closes) all generics in a Bulk object. This is useful if you don't remember which generics are in the Bulk object. If the Bulk is not the empty bulk, this method will also close and reclaim the memory for the bulk.

Example

This example removes all items from a Bulk.

Visual Basic:

boCase.Bulk.RemoveAllGenerics


Update(FCBulk) | fcSDK Documentation

Update(FCBulk)

Object and Type

Object : FCBulk

Type : Method

Prototype

Public Sub Update()

Description

This crucial method will update the CURRENT record in each generic object in the bulk.. The method will add it, update it, or delete each of the records as appropriate. It will also make whatever relations are needed so that the objects will be correct.

If no changes have been made to the current record in each generic object, this method will do nothing for that record.

If you wish to update all of the (modified) records in the generic object, you should call on the UpdateAll method.

Error Codes

Value | Meaning
13001 | You may not update a view
13002 | This operation is not valid for a generic that is marked distinct. At least one generic in this bulk is marked as distinct.

Examples

The following example updates one case, one site, and one contact record.

JavaScript:

  // Update first case, contact, and site record from a query
  var boCase = FCSession.CreateGeneric();
  boCase.SimpleQuery("case");

  var boSite = FCSession.CreateGeneric();
  boSite.SimpleQuery("site");

  var boContact = FCSession.CreateGeneric();
  boContact.SimpleQuery("contact");
  boCase.Bulk.Query();

  boCase("dev") = 1
  boContact("dev") = 2
  boSite("dev") = 3

  boCase.Bulk.Update();

Visual Basic:

  Dim boCase As FCGeneric
  Dim boContact As FCGeneric
  Dim boSite As FCGeneric

  Set boCase = fc_session.CreateGeneric
  boCase.SimpleQuery "case"

  Set boContact = fc_session.CreateGeneric
  boContact.SimpleQuery "contact"

  Set boSite = fc_session.CreateGeneric
  boSite.SimpleQuery "site"

  boCase.Bulk.Query

  boCase("dev") = 4
  boContact("dev") = 5
  boSite("dev") = 6

  boCase.Bulk.Update


UpdateAll(FCBulk) | fcSDK Documentation

UpdateAll(FCBulk)

Object and Type

Object : FCBulk

Type : Method

Prototype

Public Sub UpdateAll()

Description

This crucial method will update ALL of the records in each generic object in the bulk. The method will add, update, or delete any records in each generic as appropriate. It will also make whatever relations are needed so that the objects will be correct.

If no changes have been made to any of the records in any of the generic objects, this method will do nothing to those records.

If you wish to update just one record in each of the generic objects, you should call on the Update method.

Error Codes

Value | Meaning
13001 | You may not update a view
13002 | This operation is not valid for a generic that is marked distinct. At least one generic in this bulk is marked as distinct.

Examples

The following example updates all of the modified records in several generics that are in the bulk.

JavaScript:

  // Find all sites and all cases
  var boSite = FCSession.CreateGeneric();
  boSite.SimpleQuery("site");

  var boCase = FCSession.CreateGeneric();
  boCase.SimpleQuery("case");

  boSite.Bulk.Query();

  // Now update a field for each site, and each case
  while (boCase.EOF != true)
  {
    boCase("alt_address") = "An address";
    boCase.MoveNext();
  }

  while (boSite.EOF != true)
  {
    boSite("external_id") = "An external ID";
    boSite.MoveNext();
  }

  // Update all modified records in the bulk
  boSite.Bulk.UpdateAll();

Visual Basic:

  Dim boSite As FCGeneric
  Dim boCase As FCGeneric

  Set boSite = fc_session.CreateGeneric
  boSite.SimpleQuery "site"

  Set boCase = fc_session.CreateGeneric
  boCase.SimpleQuery "case"

  boSite.Bulk.Query

  While boCase.EOF = False
    boCase("alt_address") = "An address"
    boCase.MoveNext
  Wend

  While boSite.EOF = False
    boSite("external_id") = "An external ID"
    boSite.MoveNext
  Wend

  boSite.Bulk.UpdateAll


BulkID | fcSDK Documentation

BulkID

Object and Type

Object : FCBulk

Type : Property (Read-only)

Prototype

Public BulkID As Integer

Description

This is an internal property that uniquely identifies the Bulk within the FCFL system. In most cases there is NO REASON for you to ever use this property. If you wish to read it (to maintain a unique key for your Bulks), it can be read.

However, changing the value stored in this property could cause errors with other parts of FCFL.

Example

The following example creates two new generic objects, assigns them to bulks, and prints the BulkIDs for each.

JavaScript:

  // Create the first object
  var boObj1 = FCSession.CreateGeneric();
  boObj1.SimpleQuery("part_num");
  boObj1.BulkName = "my_bulk1";

  // Create the other object. Put it in the same bulk as the first
  var boObj2 = FCSession.CreateGeneric();
  boObj2.SimpleQuery("part_num");
  boObj2.BulkName = "my_bulk2";

  // Show that the bulks are now the same
  Response.Write ("Bulk 1 ID is: " + boObj1.Bulk.BulkID);
  Response.Write ("Bulk 2 ID is: " + boObj2.Bulk.BulkID);

Visual Basic:

  Dim boObj1 As FCGeneric
  Dim boObj2 As FCGeneric

  Set boObj1 = fc_session.CreateGeneric
  boObj1.SimpleQuery "part_num"
  boObj1.BulkName = "my_bulk1"

  Set boObj2 = fc_session.CreateGeneric
  boObj2.SimpleQuery "part_num"
  boObj2.BulkName = "my_bulk2"

  MsgBox "Bulk 1 ID is: " & boObj1.Bulk.BulkID
  MsgBox "Bulk 2 ID is: " & boObj2.Bulk.BulkID


Name | fcSDK Documentation

Name

Object and Type

Object : FCBulk

Type : Property

Prototype

Public Name As String

Description

This is the name of the FCBulk object. It is set when the bulk is created, and should not be set by the programmer, except in rare circumstances.

It is more commonly accessed as a read-only property.

Example

The following example creates two new generic objects, assigns them to bulks, and prints the bulk's name for each.

JavaScript:

  // Create the first object
  var boObj1 = FCSession.CreateGeneric();
  boObj1.SimpleQuery("part_num");
  boObj1.BulkName = "my_bulk";

  // Create the other object. Put it in the same bulk as the first
  var boObj2 = FCSession.CreateGeneric();
  boObj2.SimpleQuery("part_num");
  boObj2.BulkName = "my_bulk";

  // Show that the bulks are now the same
  Response.Write ("Bulk 1 name is: " + boObj1.Bulk.Name);
  Response.Write ("Bulk 2 name is: " + boObj2.Bulk.Name);

Visual Basic:

  Dim boObj1 As FCGeneric
  Dim boObj2 As FCGeneric

  Set boObj1 = fc_session.CreateGeneric
  boObj1.SimpleQuery "part_num"
  boObj1.BulkName = "my_bulk"

  Set boObj2 = fc_session.CreateGeneric
  boObj2.SimpleQuery "part_num"
  boObj2.BulkName = "my_bulk"

  MsgBox "Bulk 1 name is: " & boObj1.Bulk.Name
  MsgBox "Bulk 2 name is: " & boObj2.Bulk.Name


NoSorting | fcSDK Documentation

NoSorting

Object and Type

Object : FCBulk

Type : Property (Read-only)

Prototype

Public NoSorting As Boolean

Description

This property controls how a Bulk object orders and stores the generics it contains. Under normal circumstances (when this property is set to False, which it is by default), the generics in a Bulk are ordered as follows:

  1. All condition generics are stored first

  2. Other generics are ordered after the condition generics, ordered by the table or view number of the generic,

  3. If more than one generic is in a Bulk from the same table or view, the generics are ordered in the order they were added to the bulk.

The reason for this ordering is to maintain compatibility with Clarify, and minimize database deadlock issues.

Some users may wish to circumvent this ordering, however. Setting this property for a Bulk causes the generics to be saved in the bulk in the same order they are added to the bulk. This may be desired in some instances, but should be used only when you need that specific result.

In general, most users should never change the default value of this property!!!

It is important to understand that changing this property does not cause a re-order of generics already in the Bulk. It is only good for future generics added to the Bulk. Thus it is crucial that this property be set after the first generic is added to the Bulk.

Example

The following example adds many generic objects to a Bulk, but does not order them using the standard ordering algorithm. Rather, the objects are saved in the Bulk in the order they are inserted in the Bulk.

Visual Basic:

Dim boSite As FCGeneric
Dim boCRole As FCGeneric
Dim boContact As FCGeneric
Dim boCond As FCGeneric
Dim boCase As FCGeneric

' Create a site generic object
' Put it in a bulk
' Order the bulk in insertion order (no sorting)

Set boSite = fc_session.CreateGeneric("site")
boSite.BulkName = "my_bulk"
boSite.Bulk.NoSorting = true

' Create a contact role generic object

Set boCRole = fc_session.CreateGeneric("contact_role")
boCRole.BulkName = "my_bulk"

' Create a contact generic object
Set boContact = fc_session.CreateGeneric("contact")
boContact.BulkName = "my_bulk"

' Create a condition generic object
Set boCond = fc_session.CreateGeneric("condition")
boCond.BulkName = "my_bulk"

' Create a case generic object
Set boCase = fc_session.CreateGeneric("case")
boCase.BulkName = "my_bulk"


FCFL FCGeneric Object | fcSDK Documentation

FCFL FCGeneric Object

Overview

This is the core business object in the FCFL product. Each instance of an FCGeneric generic object represents records from either one table or one view in the database. The generic object allows you to query the database for rows from the table or view, to add, update, or delete rows (tables only).

Creating a generic object is easy. You must declare a variable to hold the generic. Then you create it using the CreateGeneric method of the session object. You MUST use this method, or the generic object will not be properly initialized.

The following are examples of how to create a generic in both JavaScript and Visual Basic:

JavaScript:

var boContact = FCSession.CreateGeneric();

Visual Basic:

Dim case_obj As FCGeneric

Set case_obj = fc_session.CreateGeneric()

Generic objects have a familiar interface, similar to many business object structures (include Microsoft ADO, on which it is based). See the Programming Guide for more details on using generic objects.

Since each generic object only represents one table or view, you must use multiple generics when creating a complex object. For example, to insert (create) a new case, you must add a case record and a condition record. Optionally, you may choose to add up to three act_entry records, up to three time_bomb records, and a phone_notes record. Each of these tables would require a generic object to hold the records for that table. It can be complex, but isn't too hard once you're used to it.

Note: All of this complex functionality is already provided for you in the First Choice Software Business Object API Toolkits. Contact First Choice Software for more details.


AddForUpdate | fcSDK Documentation

AddForUpdate

Object and Type

Object : FCGeneric

Type : Method

Prototype

Public Sub AddForUpdate(TheObjid As Long)

Description

This method is used when you know the objid of a database record, and wish to update it, but do not wish to take the time to query it from the database. Calling this method will add a new record (for updating) to the recordset, and will set the objid field to the specified parameter.

You can then change any fields, or set any relations, just like any other record. Unlike the AddNew method, this method will not attempt to insert a record into the database.

Note: This method does not validate the objid you provide. If it is illegal, you will receive a runtime error when you attempt to update the record.

Parameters

Parameter Name | Required? | Description
theObjid | Yes | This is the objid of the record to update

Error Codes

Value | Meaning
12031 | This operation is not valid for a generic that is marked distinct

Examples

The following example creates a new record in the recordset for the case table for update. It then updates the alt_city field.

JavaScript:

  // Allocate the case
  var boCase = FCSession.CreateGeneric();
  boCase.SimpleQuery("case");

  // Add a row for update, modify it, and commit
  boCase.AddForUpdate("268435457");
  boCase ("alt_city") = "My town";
  boCase.Update();

Visual Basic:

  Dim boCase As FCGeneric
  Set boCase = fc_session.CreateGeneric

  boCase.SimpleQuery "case"
  boCase.AddForUpdate 268435457
  boCase("alt_city") = "Your city"
  boCase.Update


AddNew | fcSDK Documentation

AddNew

Object and Type

Object : FCGeneric

Type : Method

Prototype

Public Sub AddNew()

Description

This method allows you to add a new record to a generic object. The object can later be added to the database with either the Update or UpdateAll methods.

When you call AddNew, a new record is allocated at the end of the list of records in this generic object. The new record is set to the current record, and all fields are initialized to their default values (NULL for all relations).

You can then set individual fields via the Fields collection and relate the record to other records using one of the relate methods. FCFL takes care of generating the objid for you - that is not a field you need to set.

If you do not supply an objid, FCFL will generate a proper objid for the newly-created record. This is how the method is used most of the time. In rare cases, however, a programmer may need to use a specific objid for the newly-created record. If you specify an objid for the record (after the AddNew but before the Update/UpdateAll), FCFL will not generate a new objid for the record, but will use the one you supply. You must be very careful that the supplied objid is unique.

Note: If you have previously queried the database for this generic object, and did not query for all fields, the AddNew method will fail with an error. This is because it attempts to initialize all data fields to their proper defaults, and you previously specified that only certain fields should be in this generic object. You can use the RequeryForInserts method to rectify this, or simply create a new Generic object for the insert.

Error Codes

Value | Meaning
12009 | Could not add record because not all fields were selected in a previous query
12031 | This operation is not valid for a generic that is marked distinct

Examples

The following example creates a new record for the contact_role table. It also relates it to two objects, and adds the record into the database.

JavaScript:

  // Get one specific contact
  var boContact = FCSession.CreateGeneric();
  boContact.SimpleQuery("contact");
  boContact.AppendFilter("objid", "=", "268435457");

  // Get one specific site
  // Query both tables via the bulk

  var boSite = FCSession.CreateGeneric();
  boSite.SimpleQuery("site");
  boSite.AppendFilter("objid", "=", "268435457");

  boContact.Bulk.Query();

  // Now create a new contact role
  // Set it as a secondary role, and relate it to contact and site
  // Then commit the change!!

  var boCRole = FCSession.CreateGeneric();
  boCRole.SimpleQuery("contact_role");
  boCRole.AddNew();

  boCRole("primary_site") = 2;
  boCRole("role_name") = "Default";
  boCRole.RelateRecords(boContact, "contact_role2contact");
  boCRole.RelateRecords(boSite, "contact_role2site");

  boCRole.Update();

In this example, the objid is generated by the programmer, not FCFL.

Visual Basic:

  Dim boSite As FCGeneric
  Dim boContact As FCGeneric
  Dim boCRole As FCGeneric

  Set boContact = fc_session.CreateGeneric
  boContact.SimpleQuery "contact"
  boContact.AppendFilter "objid", "=", 268435457

  Set boSite = fc_session.CreateGeneric
  boSite.SimpleQuery "site"
  boSite.AppendFilter "objid", "=", 268435457
  boContact.Bulk.Query

  Set boCRole = fc_session.CreateGeneric
  boCRole.SimpleQuery "contact_role"
  boCRole.AddNew

  boCRole = fc_session.GetObjid("contact_role")
  boCRole("primary_site") = 2
  boCRole("role_name") = "Default"
  boCRole.RelateRecords boContact, "contact_role2contact"
  boCRole.RelateRecords boSite, "contact_role2site"
  boCRole.Update


AppendFilter | fcSDK Documentation

AppendFilter

Object and Type

Object : FCGeneric

Type : Method

Prototype

Public Sub AppendFilter(ByVal field_name As String, _
                        ByVal operation As String, _
                        ByVal value As Variant)

Description

This method adds another where clause for the generic object to query the database. This clause will be "anded" to other clauses in the object. The field name must be a valid field (or MTO/OTOP relation) in the table. The operation is one of the specified, approved relations, and the value should be a valid value for the database of the field.

You MUST set the DBObjectName (either by setting it, using SimpleQuery, ParentRelation/ParentBO, or TraverseFromParent) before you can call on this method. It requires that the generic object be set to a table or view first.

If you use the ISNULL or ISNOTNULL operator, the value parameter is ignored. Also, depending on your programming language, you can test for NULL with the "=" or "<>" operators.

The method also performs some intelligent operations on the value. If the value has imbedded quotes, they are properly handled so that SQL can read them. For "IS IN" or "IS NOT IN" operators, you can place quotes around the items (for strings) as quotes or double quotes. The routine also handles having no quotes around the (string) items - it will place them for you. You also can have imbedded commas in the strings. For numerics, you should use no quotes.

The date/time filters are handy, but require a bit of care. Some of them (today, yesterday, tomorrow) do not have a value associated with them. Use the empty string ("") for the value field. The on operator specifies a specific date. In other words, the query is finding out if the date/time was on the date specified.

Within days and within hours allow you to specify that the date/time was within the specified (integer) number of days or hours. Finally, between and not between allow you to find dates/times either between or not between two dates/times. Those dates/times must be separated by either a comma or a space.

You may also use the "Now" date/time (-999) in any of the date operators, including between.

There is some special processing that is performed on date/time filters. If you suply a date but do not supply a time, FCFL attempts to put in the proper time for you. For example, if you have the "less than" filter (or before), and do not supply a time, AppendFilter will automatically fill in the time of midnight, so as to make sure that the filter is correct. Likewise for "after" (or >), the method will add the time of "11:59:59 PM" to the date if you provide only a date.

Similarly, the >= and <= filters add the proper dates. The "between" and "not between" will also add times to both the first and second dates if you do not supply times. The first date will have 11:59:59 PM added to it, and the second date will have midnight added to it. The reason for this is that "between" and "not between" are exclusionary. Saying "between 1/2/2004, 1/4/2004" should only return values on 1/3/2004 - not on either of the boundary dates.

Finally, there is an optional property on the FCApplication method called midnight. This is an optional string that is really only needed to address some of the limitations in Oracle 7. If you specify this property (in the fc.env file, or programmatically), the string you supply for midnight is appended to any dates that do not have times supplied after them. This only occurs when time zone conversion changes the time to exactly midnight. The base FCFL routines, in this case, strip off the time from the date/time. This is not a problem for SQL Server, or later versions of Oracle. Hence the optional property. If you have questions about the property, you can always set it to a valid value - it will do no harm.

Note that none of the above special processing takes place if you provide a time in the value of the filter.

Note: The Within days and Within hours filters are restricted to a value of 1-999. If you wish a bigger value you must use the Filter property of the generic object.

Note: If you have very complex logic (such as with "Or" conditions), you can use the Filter property instead, as this method simply builds up the value in the Filter property for you.

Parameters

Parameter Name | Required? | Description
field_name | Yes | Valid field name for the database object. If you wish, you may also specify a valid MTO or OTOP relation name
operation | Yes | A string with a valid operation value. One of:
  1. ends with
  2. starts with
  3. contains
  4. not starts with
  5. not ends with
  6. not contains
  7. like
  8. not like
  9. equals (or =)
  10. <> (or !=)
  11. less than (or <)
  12. greater than (or >)
  13. less or equal (or <=)
  14. greater or equal (or >=)
  15. before (date only)
  16. after (date only)
  17. sounds like
  18. is in (or in)
  19. is not in (or not in)
  20. isnull (nullable fields only)
  21. isnotnull (nullable fields only)
  22. today (use empty string for value)
  23. tomorrow (use empty string for value)
  24. yesterday (use empty string for value)
  25. on (use a date with NO time for the value)
  26. withindays (value is an integer)
  27. withinhours (value is an integer)
  28. olderthandays (value is an integer)
  29. olderthanhours (value is an integer)
  30. between (two dates, comma or space separated)
  31. not between (two dates, comma or space separated) | | value | Yes | The value for comparison. |

Error Codes

Value | Meaning
12001 | Bad operation specified
12002 | Too many filters specified. Please use the Filter property instead
12022 | The filter you have selected is not valid for the data type of this field
12023 | The specified field is not valid for the query object
12025 | The value for this AppendFilter is out of range. Valid values are 1-999
12027 | The data supplied for a date filter is not a valid date
12028 | A date and time was supplied for the "On" filter. This filter only allows a date to be supplied
12033 | The specified value is not numeric

Examples

The following example uses AppendFilter to filter both a string and integer field from the case table.

JavaScript:

  // Get some cases
  var boCase = FCSession.CreateGeneric();
  boCase.SimpleQuery("case");
  boCase.AppendFilter("objid", "<", 268435459);
  boCase.AppendFilter("title", "not contains", "fred");
  boCase.Query();

  // Now print them out
  while (boCase.EOF != true)
  {
    Response.Write ("Case ID: " + boCase("id_number"));
    boCase.MoveNext();
  }

Finds cases created in the last 6 hours.

Visual Basic:

  Dim boCase As FCGeneric

  Set boCase = fc_session.CreateGeneric
  boCase.SimpleQuery "case"
  boCase.AppendFilter "creation_time", "withinhours", 6
  boCase.Query

  While boCase.EOF = False
    MsgBox "Case ID: " & boCase("id_number")
    boCase.MoveNext
  Wend

The next example finds all cases created yesterday.

Visual Basic:

  Dim boCase As FCGeneric

  Set boCase = fc_session.CreateGeneric
  boCase.SimpleQuery "case"
  boCase.AppendFilter "creation_time", "yesterday", ""
  boCase.Query

  While boCase.EOF = False
    MsgBox "Case ID: " & boCase("id_number")
    boCase.MoveNext
  Wend

The next example finds all cases created between January 1, 2000 and now.

Visual Basic:

  Dim boCase As FCGeneric

  Set boCase = fc_session.CreateGeneric
  boCase.SimpleQuery "case"
  boCase.AppendFilter "creation_time", "between", "1/1/2000, -999"
  boCase.Query

  While boCase.EOF = False
    MsgBox "Case ID: " & boCase("id_number")
    boCase.MoveNext
  Wend


AppendSort | fcSDK Documentation

AppendSort

Object and Type

Object : FCGeneric

Type : Method

Prototype

Public Sub AppendSort(ByVal field_name As String, _
                      ByVal ascending As String)

Description

This method adds another sort clause for the generic object to query the database. This clause will be added to the end of any previous sorts specified with AppendSort. The field name must be a valid field (or MTO/OTOP relation) in the table. The ascending parameter is either ascending or descending.

You MUST set the DBObjectName (either by setting it, using SimpleQuery, ParentRelation/ParentBO, or TraverseFromParent) before you can call on this method. It requies that the generic object be set to a table or view first.

Note: You may also just set the SortFields property directly, if you would prefer. But that property requires that you know the correct SQL syntax for the sort.

Parameters

Parameter Name | Required? | Description
field_name | Yes | Valid field name for the database object. If you wish, you may also specify a valid MTO or OTOP relation name
ascending | Yes | A string that is one of: 1. ascending (or asc or a) 2. descending (or desc or d)

Error Codes

Value | Meaning
12003 | Bad ascending value specified
12004 | Too many sorts specified. Please use the SortFields property instead
12023 | The specified field is not valid for the query object

Examples

The following example uses AppendSort to sort a query of the site table by both status and site name.

JavaScript:

  // Order a query of sites by status and then site name
  var boSite = FCSession.CreateGeneric();
  boSite.SimpleQuery("site");
  boSite.AppendSort("status", "asc");
  boSite.AppendSort("name", "asc");
  boSite.Query();

  // Now print them out
  while (boSite.EOF != true)
  {
     Response.Write ("Site: " + boSite("name"));
     boSite.MoveNext();
  }

Visual Basic:

  Set boSite = fc_session.CreateGeneric
  boSite.SimpleQuery "site"
  boSite.AppendSort "status", "asc"
  boSite.AppendSort "name", "asc"
  boSite.Query

  While boSite.EOF = False
    MsgBox "Site: " & boSite("name")
    boSite.MoveNext
  Wend


ClearRoot | fcSDK Documentation

ClearRoot

Object and Type

Object : FCGeneric

Type : Method

Prototype

Public Sub ClearRoot()

Description

This method will clear the information set up (using the TraverseFromRoot method) for a generic object for a root traversal. It does not clear the DBObjectName, so the object is still set up to query the table set up in the root traversal. The generic object will now perform a SimpleQuery type query.

Note: No other properties (sort order, filters, data fields) are cleared by this method.

It is not recommended that you use this method after you have queried the generic object, as unexpected results with Move and Count may occur.

Example

The following example clears the root object information for a generic object after it was set up in error.

JavaScript:

  // Create the queue object
  var boQueue = FCSession.CreateGeneric();
  // Traverse from the current user's objid
  boQueue.TraverseFromRoot(FCSession.Item("user.id"), "user",
                           "user_assigned2queue");

  // Oops. It was a mistake - clear the root traversal
  boQueue.ClearRoot();

Visual Basic:

  Dim boQueue As FCGeneric

  Set boQueue = fc_session.CreateGeneric
  boQueue.TraverseFromRoot fc_session.item("user.id"), _
                           "user", "user_assigned2queue"
  boQueue.ClearRoot


CloseGeneric | fcSDK Documentation

CloseGeneric

Object and Type

Object : FCGeneric

Type : Method

Prototype

Public Sub CloseGeneric()

Description

When you are finished with a generic object, and do not need it any more, you should call on this method to close it out so you can reclaim the memory. It cleans up various internal data structures for you to accomplish this.

After you have called this method, you should also set the generic to Nothing (or Null, depending on the language) to complete the freeing of memory.

Example

The following example demonstrates how a generic object should be cleaned up.

JavaScript:

  // Create and query an object
  var boSite = FCSession.CreateGeneric();
  boSite.SimpleQuery("site");
  boSite.Query();

  // Now close it up properly
  boSite.CloseGeneric();
  boSite = null;

Visual Basic:

  Set boSite = fc_session.CreateGeneric
  boSite.SimpleQuery "site"
  boSite.Query
  boSite.CloseGeneric

  Set boSite = Nothing


Copy | fcSDK Documentation

Copy

Object and Type

Object : FCGeneric

Type : Method

Prototype

Public Function Copy(Optional use_generic As FCGeneric) As FCGeneric

Description

This method is exactly the same as the Duplicate method. It is included for completeness. Please see the Duplicate method for more information.


Count_(FCGeneric)_ | fcSDK Documentation

Count_(FCGeneric)_

Object and Type

Object : FCGeneric

Type : Method

Prototype

Public Function Count() As Long

Description

This method returns back the number of rows currently in a generic object. For example, if you query a database table, and the query returned 14 rows, you would expect Count to return 14. If you then called on AddNew to add a row, it would return 15.

There is one small complexity to Count, however. If this generic object is a child object (that is, it was traversed from (in a query) from a parent object), the Count method will return how many rows in this generic object are related to the current row in the parent object. Thus, as you move through the parent object, the number of rows that Count returns will change.

To see how many total rows are in this generic object, even if it is a child object, use the TotalCount method.

Returns

The total number of rows in this generic. Or, for a child object, the number of records related to the current record in the parent object.

Example

The following example queries the case table and the notes_log table. Then, for each case, it reports how many notes are related.

JavaScript:

// Query case and notes_log
  var boCase = FCSession.CreateGeneric();
  boCase.SimpleQuery("case");

  var boNotes = FCSession.CreateGeneric();
  boNotes.TraverseFromParent(boCase, "case_notes2notes_log");
  boCase.Query();

  // Loop through all cases
  // For each, print the case ID

  while (boCase.EOF != true)
  {
    Response.Write ("Case: " + boCase("id_number"));
    // Now print out how many notes exist for that case only
    Response.Write ("  Number of Notes: " + boNotes.Count());
    // Now get the next case
    boCase.MoveNext();
  }

Visual Basic:

  Dim boCase As FCGeneric
  Dim boNotes As FCGeneric

  Set boCase = fc_session.CreateGeneric
  boCase.SimpleQuery "case"

  Set boNotes = fc_session.CreateGeneric
  boNotes.TraverseFromParent boCase, "case_notes2notes_log"
  boCase.Query

  While boCase.EOF = False
    MsgBox "Case: " & boCase("id_number") & " " & "Num of notes: " & _
           Trim$(Str$(boNotes.Count))
    boCase.MoveNext
  Wend


Delete | fcSDK Documentation

Delete

Object and Type

Object : FCGeneric

Type : Method

Prototype

Public Sub Delete()

Description

This method deletes the current record in a generic object. You may not call on Delete when BOF or EOF is True, and you may not attempt to Delete a new (and as-of-yet uncommitted) record.

The deletion of a row is not immediate. You must call on UpdateAll (either on the generic object or the bulk) to cause the delete to occur. You may not use the Update method to commit the delete, as the Delete method moves the current pointer, and it is not possible to point back to it.

All relations that point to the deleted row in other tables are also set to NULL (and the MTM rows that point to it are deleted). Thus, after a Delete is committed, nothing in the database will point to the objid of the deleted row.

After an object is marked for deletion, it cannot be seen in a traversal of the generic object (with the Move methods). Also, it will not be shown as a record with the Count and TotalCount methods.

Further, when you perform a Delete, the current record is moved to the next available record in the data set. You do not have to perform a MoveNext to get to the next record. If this is the last record of the recordset, Delete will move the record to the previous active record in the recordset. If the record to be deleted is the only one in the recordset, BOF will be made True.

Error Codes

Value | Meaning
12013 | You may not delete a record marked to be added to the generic object
12031 | This operation is not valid for a generic that is marked distinct

Examples

The following example deletes all records in a custom table called "my_table".

JavaScript:

  // Set up a query of all rows in test table
  var boMyTable = FCSession.CreateGeneric();
  boMyTable.DBObjectName = "my_table";
  boMyTable.Query();

  // While there are more rows to delete, delete them all
  // Remember, you don't need to do a MoveNext here
  while (boMyTable.EOF != true)
  {
    boMyTable.Delete();
  }

  boMyTable.UpdateAll();

Visual Basic:

  Dim boMyTable As FCGeneric
  Set boMyTable = fc_session.CreateGeneric
  boMyTable.DbObjectName = "my_table"
  boMyTable.Query

  While boMyTable.EOF = False
    boMyTable.Delete
  Wend

  boMyTable.UpdateAll


DeleteAll | fcSDK Documentation

DeleteAll

Object and Type

Object : FCGeneric

Type : Method

Prototype

Public Sub DeleteAll()

Description

This method deletes all of the records in a generic object. The DeleteAll method performs a MoveFirst, so it does not matter where in the records collection you are currently positioned. The method calls on the Delete method to delete each row, so you should read that method's documentation to understand how it operates.

The deletion of a row is not immediate. You must call on UpdateAll (either on the generic object or the bulk) to cause the delete to occur. You may not use the Update method to commit the delete, as the Delete method moves the current pointer, and it is not possible to point back to it.

All relations that point to the deleted row in other tables are also set to NULL (and the MTM rows that point to it are deleted). Thus, after a DeleteAll is committed, nothing in the database will point to the objid of the deleted row(s).

After an object is marked for deletion, it cannot be seen in a traversal of the generic object (with the Move methods). Also, it will not be shown as a record with the Count and TotalCount methods.

Further, when you perform a DeleteAll, the current record is set to EOF.

Error Codes

Value | Meaning
12031 | This operation is not valid for a generic that is marked distinct

Examples

The following example deletes all records in a custom table called "my_table".

JavaScript:

  // Set up a query of all rows in test table
  var boMyTable = FCSession.CreateGeneric();
  boMyTable.DBObjectName = "my_table";
  boMyTable.Query();
  boMyTable.DeleteAll();
  boMyTable.UpdateAll();

Visual Basic:

  Dim boMyTable As FCGeneric
  Set boMyTable = fc_session.CreateGeneric
  boMyTable.DbObjectName = "my_table"
  boMyTable.Query
  boMyTable.DeleteAll
  boMyTable.UpdateAll


Duplicate | fcSDK Documentation

Duplicate

Object and Type

Object : FCGeneric

Type : Method

Prototype

Public Function Duplicate(Optional use_generic As FCGeneric) As FCGeneric

Description

This method allows you to make a copy of one row of a generic object (the current row), and to copy it to another generic object. It will copy the contents of every field in the object, EXCEPT the objid. The objid is not included because you will want the new row to have an objid that is unique to that row. All MTO and OTOP relations are also copied, as they are long integer data fields in the record.

Note: If you have set the DataFields property for the base object to only point to a subset of the fields in the object, only those fields will be copied to the new duplicate.

The one argument for this method is optional. If you do not include it, the Duplicate method will create a new generic (copying all properties of the original, including the DBObjectName, DataFields, ParentBO, and Parent Relation) and will duplicate the record in the new generic.

If you include a generic object as an argument to this method, the duplicate will be added to the specified generic. If you provide this argument, please make sure that the two generics are set for the same database object.

Note: You may NOT add a duplicate to the same business object. In other words, if you want to duplicate a row from the case_obj BO, you may not supply case_obj as the argument for Duplicate.

Error Codes

Value | Meaning
12031 | This operation is not valid for a generic that is marked distinct

Parameters

Parameter Name | Required? | Description
use_generic | No | Generic to which to add the copy. If not supplied, a new generic object will be created, used, and returned.

Returns

The generic object that contains the duplicate row. The duplicate row will be set as the current data row.

Error Codes

Value | Meaning
12017 | The generic object to duplicate has no rows in it, or the current row is set to BOF or EOF

Examples

This examples duplicates two rows from the time_bomb table and places them in the same (new) generic object.

Visual Basic:

Dim tb1 As FCGeneric
Dim tb2 As FCGeneric

' Build the first generic object and query for some time_bombs

Set tb1 = fc_session.CreateGeneric
tb1.SimpleQuery "time_bomb"
tb1.Query

' Now copy the first one
' Move to the next row
' Copy the next one in the same generic

Set tb2 = tb1.Duplicate

tb1.MoveNext
Set tb2 = tb1.Duplicate(tb2)


GetField | fcSDK Documentation

GetField

Object and Type

Object : FCGeneric

Type : Method

Prototype

Public Function GetField(ByVal field_name As String) As Variant

Description

This method returns the value in a column of the current record in a generic object. It is exactly the same as using the Fields property. It is provided for similarity with ClearBasic.

Returns

The value in the field is returned.

Example

The following example queries for a specific site. It then displays fields using the GetFields method.

JavaScript:

  // Find one site
  var boSite = FCSession.CreateGeneric();
  boSite.SimpleQuery("site");
  boSite.AppendFilter("objid", "=", 268435457);
  boSite.Query();

  // Print out some data with GetField
  Response.Write ("Site ID  : " + boSite.GetField("site_id"));
  Response.Write ("Site Name: " + boSite.GetField("name"));

Visual Basic:

  Dim boSite As FCGeneric

  Set boSite = fc_session.CreateGeneric
  boSite.SimpleQuery "site"
  boSite.AppendFilter "objid", "=", 268435457
  boSite.Query

  MsgBox "Site ID  : " & boSite.GetField("site_id")
  MsgBox "Site Name: " & boSite.GetField("name")


MoveFirst | fcSDK Documentation

MoveFirst

Object and Type

Object : FCGeneric

Type : Method

Prototype

Public Sub MoveFirst()

Description

This method sets the current record for the generic object to the first object in the recordset. The order of the records is determined by the database query used to build the generic object's recordset, or the order in which AddNew method calls were made.

If there are no records in the generic object, the BOF flag will be set to True.

If this is a child object, it is important to realize that the record that this method will find is dependent on the current row in the parent object. This will find the first record in this generic that is related to the current parent record.

Example

The following example queries for sites in the database. It then uses MoveFirst and MoveNext to iterate through the records.

JavaScript:

  // Get sites so we can loop through them
  var boSite = FCSession.CreateGeneric();
  boSite.SimpleQuery("site");
  boSite.Query();

  // This is not needed, as the query does a MoveFirst
  boSite.MoveFirst();

  // Now print them out
  while (boSite.EOF != true)
  {
    Response.Write ("Site: " + boSite("name"));
    boSite.MoveNext();
  }

Visual Basic:

  Dim boSite As FCGeneric

  Set boSite = fc_session.CreateGeneric
  boSite.SimpleQuery "site"
  boSite.Query

  boSite.MoveFirst
  While boSite.EOF = False
    MsgBox "Site is: " & boSite("name")
    boSite.MoveNext
  Wend


MoveLast | fcSDK Documentation

MoveLast

Object and Type

Object : FCGeneric

Type : Method

Prototype

Public Sub MoveLast()

Description

This method sets the current record for the generic object to the last object in the recordset. The order of the records is determined by the database query used to build the generic object's recordset, or the order in which AddNew method calls were made.

If there are no records in the generic object, the BOF flag will be set to True.

If this is a child object, it is important to realize that the record that this method will find is dependent on the current row in the parent object. This will find the last record in this generic that is related to the current parent record.

Example

The following example queries for sites in the database. It then uses MoveLast and MovePrevious to iterate through the records.

JavaScript:

  // Get sites so we can loop through them
  var boSite = FCSession.CreateGeneric();
  boSite.SimpleQuery("site");
  boSite.Query();

  // Go to last record
  boSite.MoveLast();

  // Now print them out, backwards
  while (boSite.BOF != true)
  {
    Response.Write ("Site: " + boSite("name"));
    boSite.MovePrevious();
  }

Visual Basic:

  Dim boSite As FCGeneric

  Set boSite = fc_session.CreateGeneric
  boSite.SimpleQuery "site"
  boSite.Query

  boSite.MoveLast
  While boSite.BOF = False
    MsgBox "Site is: " & boSite("name")
    boSite.MovePrevious
  Wend


MoveNext | fcSDK Documentation

MoveNext

Object and Type

Object : FCGeneric

Type : Method

Prototype

Public Sub MoveNext()

Description

This method sets the current record for the generic object to the next object in the recordset. The order of the records is determined by the database query used to build the generic object's recordset, or the order in which AddNew method calls were made.

If there are no more records in the generic object, the EOF flag will be set to True.

If this is a child object, it is important to realize that the record that this method will find is dependent on the current row in the parent object. This will find the next record in this generic that is related to the current parent record.

Example

The following example queries for sites in the database. It then uses MoveFirst and MoveNext to iterate through the records.

JavaScript:

  // Get sites so we can loop through them
  var boSite = FCSession.CreateGeneric();
  boSite.SimpleQuery("site");
  boSite.Query();

  // This is not needed, as the query does a MoveFirst
  boSite.MoveFirst();

  // Now print them out
  while (boSite.EOF != true)
  {
    Response.Write ("Site: " + boSite("name"));
    boSite.MoveNext();
  }

Visual Basic:

  Dim boSite As FCGeneric

  Set boSite = fc_session.CreateGeneric
  boSite.SimpleQuery "site"
  boSite.Query
  boSite.MoveFirst

  While boSite.EOF = False
    MsgBox "Site is: " & boSite("name")
    boSite.MoveNext
  Wend


MovePrevious | fcSDK Documentation

MovePrevious

Object and Type

Object : FCGeneric

Type : Method

Prototype

Public Sub MovePrevious()

Description

This method sets the current record for the generic object to the previous object in the recordset. The order of the records is determined by the database query used to build the generic object's recordset, or the order in which AddNew method calls were made.

If there are no previous records in the generic object, the BOF flag will be set to True.

If this is a child object, it is important to realize that the record that this method will find is dependent on the current row in the parent object. This will find the previous record in this generic that is related to the current parent record.

Example

The following example queries for sites in the database. It then uses MoveLast and MovePrevious to iterate through the records.

JavaScript:

  // Get sites so we can loop through them
  var boSite = FCSession.CreateGeneric();
  boSite.SimpleQuery("site");
  boSite.Query();

  // Go to last record
  boSite.MoveLast();

  // Now print them out, backwards
  while (boSite.BOF != true)
  {
    Response.Write ("Site: " + boSite("name"));
    boSite.MovePrevious();
  }

Visual Basic:

  Dim boSite As FCGeneric

  Set boSite = fc_session.CreateGeneric

  boSite.SimpleQuery "site"
  boSite.Query

  boSite.MoveLast
  While boSite.BOF = False
    MsgBox "Site is: " & boSite("name")
    boSite.MovePrevious
  Wend


MoveRelative | fcSDK Documentation

MoveRelative

Object and Type

Object : FCGeneric

Type : Method

Prototype

Public Sub MoveRelative(ByVal NumToMove As Integer)

Description

This method sets the current record for the generic object either forward or backward by the number of records specified by the argument. The order of the records is determined by the database query used to build the generic object's recordset, or the order in which AddNew method calls were made. If the relative move moves earlier than the first record, the BOF flag will be set to True. If the move causes the current record to move past the final record, the EOF flag will be set to True. If this is a child object, it is important to realize that the record that this method will find is dependent on the current row in the parent object. This will find the proper record in this generic that is related to the current parent record.

Parameters

Parameter Name | Required? | Description
NumToMove | Yes | An integer of how many records to move. Positive integers move forward in the recordset. Negative values move backwards.

Example

The following example queries for sites in the database. It then uses MoveRelative to change to a variety of records.

JavaScript:

  // Get sites so we can loop through them
  var boSite = FCSession.CreateGeneric();
  boSite.SimpleQuery("site");
  boSite.Query();

  // Go to 3rd record
  boSite.MoveRelative(2);
  Response.Write ("Site: " + boSite("name"));

  // Go forward 3 more
  boSite.MoveRelative(3);
  Response.Write ("Site: " + boSite("name"));

  // Go  back 4
  boSite.MoveRelative(-4);
  Response.Write ("Site: " + boSite("name"));

  // Forward 1 more - Same as MoveNext
  boSite.MoveRelative(1);
  Response.Write ("Site: " + boSite("name"));

Visual Basic:

  Dim boSite As FCGeneric

  Set boSite = fc_session.CreateGeneric
  boSite.SimpleQuery "site"
  boSite.Query

  boSite.MoveRelative (2)
  MsgBox "Site: " & boSite("name")

  boSite.MoveRelative (3)
  MsgBox "Site: " & boSite("name")

  boSite.MoveRelative (-4)
  MsgBox "Site: " & boSite("name")

  boSite.MoveRelative (1)
  MsgBox "Site: " & boSite("name")


MoveFirstAbsolute | fcSDK Documentation

MoveFirstAbsolute

Object and Type

Object : FCGeneric

Type : Method

Prototype

Public Sub MoveFirstAbsolute()

Description

This method sets the current record for the generic object to the first object in the recordset. However, unlike the MoveFirst method, this method places the current record pointer to the first record with NO regard to the parent recordset's current record pointer. In other words, this method places you at the first record in the recordset for ALL records in the generic object. This method is similar to the base ClearBasic method GetRecordList, which gets all records for a specific query.

If this object is not a child generic, this method is equivalent to the MoveFirst method.

If there are no records in the generic object, the BOF flag will be set to True.

Note: This method still performs a MoveFirst on any generic objects that are children of this object.

Example

The following example queries for all of the sites in the database. It then traverses to the contact roles for those sites, and on to the contacts for the contact roles. It uses MoveFirstAbsolute and MoveNextAbsolute to traverse through all of the contact roles (and contacts) with no regard to the site generic object.

Visual Basic:

Dim boSite As FCGeneric
Dim boCRole As FCGeneric
Dim boContact As FCGeneric

Set boSite = fc_session.CreateGeneric("site")

Set boCRole = fc_session.CreateGeneric
boCRole.TraverseFromParent boSite, "site2contact_role"
boCRole.AppendSort "contact_role2contact", "asc"

Set boContact = fc_session.CreateGeneric
boContact.TraverseFromParent boCRole, "contact_role2contact"
boSite.Query

boCRole.MoveFirstAbsolute
While boCRole.EOF = False
  Debug.Print "Role: " & boCRole("role_name")
  Debug.Print "  Count of contacts: " & Trim$(str$(boContact.Count))
  boCRole.MoveNextAbsolute
Wend


MoveLastAbsolute | fcSDK Documentation

MoveLastAbsolute

Object and Type

Object : FCGeneric

Type : Method

Prototype

Public Sub MoveLastAbsolute()

Description

This method sets the current record for the generic object to the last object in the recordset. However, unlike the MoveLast method, this method places the current record pointer to the last record with NO regard to the parent recordset's current record pointer. In other words, this method places you at the last record in the recordset for ALL records in the generic object. This method is similar to the base ClearBasic method GetRecordList, which gets all records for a specific query.

If this object is not a child generic, this method is equivalent to the MoveLast method.

If there are no records in the generic object, the BOF flag will be set to True.

Note: This method still performs a MoveFirst on any generic objects that are children of this object.

Example

The following example queries for all of the sites in the database. It then traverses to the contact roles for those sites, and on to the contacts for the contact roles. It uses MoveLastAbsolute and MovePreviousAbsolute to traverse through all of the contact roles (and contacts) with no regard to the site generic object.

Visual Basic:

Dim boSite As FCGeneric
Dim boCRole As FCGeneric
Dim boContact As FCGeneric

Set boSite = fc_session.CreateGeneric("site")
Set boCRole = fc_session.CreateGeneric
boCRole.TraverseFromParent boSite, "site2contact_role"
boCRole.AppendSort "contact_role2contact", "asc"

Set boContact = fc_session.CreateGeneric
boContact.TraverseFromParent boCRole, "contact_role2contact"
boSite.Query

boCRole.MoveLastAbsolute
While boCRole.BOF = False
  Debug.Print "Role: " & boCRole("role_name")
  Debug.Print "  Count of contacts: " & Trim$(str$(boContact.Count))
  boCRole.MovePreviousAbsolute
Wend


MoveNextAbsolute | fcSDK Documentation

MoveNextAbsolute

Object and Type

Object : FCGeneric

Type : Method

Prototype

Public Sub MoveNextAbsolute()

Description

This method sets the current record for the generic object to the next object in the recordset. However, unlike the MoveNext method, this method places the current record pointer to the next record with NO regard to the parent recordset's current record pointer. In other words, this method places you at the next record in the recordset for ALL records in the generic object. This method is similar to the base ClearBasic method GetRecordList, which gets all records for a specific query.

If this object is not a child generic, this method is equivalent to the MoveNext method.

Note: This method still performs a MoveFirst on any generic objects that are children of this object.

Example

The following example queries for all of the sites in the database. It then traverses to the contact roles for those sites, and on to the contacts for the contact roles. It uses MoveFirstAbsolute and MoveNextAbsolute to traverse through all of the contact roles (and contacts) with no regard to the site generic object.

Visual Basic:

Dim boSite As FCGeneric
Dim boCRole As FCGeneric
Dim boContact As FCGeneric

Set boSite = fc_session.CreateGeneric("site")
Set boCRole = fc_session.CreateGeneric
boCRole.TraverseFromParent boSite, "site2contact_role"
boCRole.AppendSort "contact_role2contact", "asc"

Set boContact = fc_session.CreateGeneric
boContact.TraverseFromParent boCRole, "contact_role2contact"
boSite.Query

boCRole.MoveFirstAbsolute
While boCRole.EOF = False
  Debug.Print "Role: " & boCRole("role_name")
  Debug.Print "  Count of contacts: " & Trim$(str$(boContact.Count))
  boCRole.MoveNextAbsolute
Wend


MovePreviousAbsolute | fcSDK Documentation

MovePreviousAbsolute

Object and Type

Object : FCGeneric

Type : Method

Prototype

Public Sub MovePreviousAbsolute()

Description

This method sets the current record for the generic object to the previous object in the recordset. However, unlike the MovePrevious method, this method places the current record pointer to the previous record with NO regard to the parent recordset's current record pointer. In other words, this method places you at the previous record in the recordset for ALL records in the generic object. This method is similar to the base ClearBasic method GetRecordList, which gets all records for a specific query.

If this object is not a child generic, this method is equivalent to the MovePrevious method.

Note: This method still performs a MoveFirst on any generic objects that are children of this object.

Example

The following example queries for all of the sites in the database. It then traverses to the contact roles for those sites, and on to the contacts for the contact roles. It uses MoveLastAbsolute and MovePreviousAbsolute to traverse through all of the contact roles (and contacts) with no regard to the site generic object.

Visual Basic:

Dim boSite As FCGeneric
Dim boCRole As FCGeneric
Dim boContact As FCGeneric

Set boSite = fc_session.CreateGeneric("site")
Set boCRole = fc_session.CreateGeneric
boCRole.TraverseFromParent boSite, "site2contact_role"
boCRole.AppendSort "contact_role2contact", "asc"

Set boContact = fc_session.CreateGeneric
boContact.TraverseFromParent boCRole, "contact_role2contact"
boSite.Query

boCRole.MoveLastAbsolute
While boCRole.BOF = False
  Debug.Print "Role: " & boCRole("role_name")
  Debug.Print "  Count of contacts: " & Trim$(str$(boContact.Count))
  boCRole.MovePreviousAbsolute
Wend


Query(FCGeneric) | fcSDK Documentation

Query(FCGeneric)

Object and Type

Object : FCGeneric

Type : Method

Prototype

Public Sub Query()

Description

This method causes the generic object to query the database (based on the DBObjectName, the Filter, the SortFields, and the DataFields you have set for this object) to retrieve records. The query retrieves 0 or more rows, and places them in the recordset for the generic object.

If you are using child objects (traversing from one generic object to another), you only have to query the parent object. FCFL will then query all of the child objects for you automatically. For example, if you wish to query the case object for one specific case, but also wish to get all related activity logs and the related contact, you would set up the case, activity_log, and contact generic objects (see example below), and would only have to query the case generic object.

If you have more than one object that you wish to query at the same time that are NOT related, put them in the same bulk, and use the FCBulk.Query method.

Note: If you perform a query on the generic object, the recordset for the records is then "Open." You may NOT perform another query on the same generic objects unless you close the recordset first. To do that, call on the following code (assume the name of the generic object is boCase):

boCase.Records.Close();

Note: For ADO-savvy users, the recordset for the generic object is disconnected from the database as a final part of the query.

Error Codes

Value | Meaning
12005 | The SQL query () is not valid
12006 | The object to query does not have a DBObjectName specified
12007 | You attempted to query a child object using a relation that was not queried for in the parent generic object
12016 | One of the data restriction clauses for this object is not valid
12018 | The generic object to be queried is open, and may not be queried. Please close the object before you attempt the query
12021 | Your query returned () rows. Maximum allowed for this query is ().
12032 | You must specify data fields for distinct queries. This query is for a distinct query, but has not defined data fields.

Examples

The following example queries a specific case, all related activity logs, and the related contact.

JavaScript:

  // Get all cases, activity logs, and contact.
  var boCase = FCSession.CreateGeneric();
  boCase.SimpleQuery("case");

  var boAct = FCSession.CreateGeneric();
  boAct.TraverseFromParent(boCase, "case_act2act_entry");
  var boContact = FCSession.CreateGeneric();
  boContact.TraverseFromParent(boCase, "case_reporter2contact");

  // Now query the data
  boCase.Query();

  // Display return data. First the case, then all activity logs
  //  then the one contact for the case

  while (boCase.EOF != true)
  {
    Response.Write ("Case ID: " + boCase("id_number"));
    while (boAct.EOF != true)
    {
      Response.Write("  Activity: " + boAct("objid"));
      boAct.MoveNext();
    }

    while (boContact.EOF != true)
    {
      Response.Write("  Contact: " + boContact("first_name") + " " +
                                   boContact("last_name"));
      boContact.MoveNext();
    }

    boCase.MoveNext();
  }

Visual Basic:

  Dim boCase As FCGeneric
  Dim boAct  As FCGeneric
  Dim boCont As FCGeneric

  Set boCase = fc_session.CreateGeneric
  boCase.SimpleQuery "case"

  Set boAct = fc_session.CreateGeneric
  boAct.TraverseFromParent boCase, "case_act2act_entry"

  Set boCont = fc_session.CreateGeneric
  boCont.TraverseFromParent boCase, "case_reporter2contact"

  boCase.Query

  While boCase.EOF = False
    MsgBox "Case: " & boCase("id_number")
    While boAct.EOF = False
      MsgBox "Activity: " & Trim$(Str$(boAct("objid")))
      boAct.MoveNext
    Wend

    While boCont.EOF = False
      MsgBox "Contact: " & boCont("first_name") & " " & _
                           boCont("last_name")
      boCont.MoveNext
    Wend

    boCase.MoveNext
  Wend


RelateByID | fcSDK Documentation

RelateByID

Object and Type

Object : FCGeneric

Type : Method

Prototype

Public Sub RelateByID(ByVal the_objid As Long, ByVal the_rel As String)

Description

This method relates the current row of the generic object to the specified objid for the relation specified. The proper relation data will be set, no matter which table (this table, the related table, or an MTM table) the actual physical relation is stored on. This method also supports exclusive relations.

You must update the object via the Update or UpdateAll method for the relation to take place.

Parameters

Parameter Name | Required? | Description
the_objid | Yes | The objid of the object to relate to
the_rel | Yes | The relation to use to relate the two records

Error Codes

Value | Meaning
12015 | The current object must be positioned on a valid record to call on this method.
12031 | This operation is not valid for a generic that is marked distinct

Examples

The following example relates a case to a specific site (268435457).

JavaScript:

  // Get all cases
  var boCase = FCSession.CreateGeneric();
  boCase.SimpleQuery("case");
  boCase.Query();

  boCase.RelateByID(268435457, "case_reporter2site");
  boCase.Update();

Visual Basic:

  Dim boCase As FCGeneric

  Set boCase = fc_session.CreateGeneric
  boCase.SimpleQuery "case"
  boCase.Query

  boCase.RelateByID 268435457, "case_reporter2site"
  boCase.Update


RelateIntFldByID | fcSDK Documentation

RelateIntFldByID

Object and Type

Object : FCGeneric

Type : Method

Prototype

Public Sub RelateIntFldByID(ByVal the_objid As Long, _
                            ByVal the_field As String)

Description

There are a number of fields (not relations!) that hold objids of other tables in them. For example, in the site_part table, the site_objid field contains the objid of the related Site object.

This method stores the specified objid for the current row of the generic object in the specified field.

It is basically the same as setting the relation via the Fields collection. This method is provided for compatibility. It can be used with any long integer field.

You must update the object via the Update or UpdateAll method for the relation to take place.

Parameters

Parameter Name | Required? | Description
the_objid | Yes | The objid of the object to relate to
the_field | Yes | The field to store the objid

Error Codes

Value | Meaning
12014 | The specified field is not a long integer field
12031 | This operation is not valid for a generic that is marked distinct

Examples

The following example sets the site_objid field of a site_part to a specific value: 268435457.

JavaScript:

  // Get some site_parts
  var boSitePart = FCSession.CreateGeneric();
  boSitePart.SimpleQuery("site_part");
  boSitePart.Query();

  // Relate the site_objid field to a specific objid
  boSitePart.RelateIntFldByID(268435457, "site_objid");
  boSitePart.Update();

Visual Basic:

  Dim boSitePart As FCGeneric
  Set boSitePart = fc_session.CreateGeneric
  boSitePart.SimpleQuery "site_part"
  boSitePart.Query

  boSitePart.RelateIntFldByID 268435457, "site_objid"
  boSitePart.Update


RelateIntFldToRecord | fcSDK Documentation

RelateIntFldToRecord

Object and Type

Object : FCGeneric

Type : Method

Prototype

Public Sub RelateIntFldToRecord(ByVal o_obj As FCGeneric, _
                                ByVal the_field As String)

Description

There are a number of fields (not relations!) that hold objids of other tables in them. For example, in the site_part table, the site_objid field contains the objid of the related Site object.

This method stores the objid of the generic object specified in the field in named in the 2nd argument. This is performed for the current row in the generic object. This method can be called for any long integer field.

You must update the object via the Update or UpdateAll method for the relation to take place.

Parameters

Parameter Name | Required? | Description
o_obj | Yes | The object to which to relate
the_field | Yes | The field to use to store the objid of the other object

Error Codes

Value | Meaning
12014 | The specified field is not a long integer field
12031 | This operation is not valid for a generic that is marked distinct

Examples

The following example sets the site_objid field of a site_part to the objid of a queried-for site.

JavaScript:

  // Get some site_parts
  var boSitePart = FCSession.CreateGeneric();
  boSitePart.SimpleQuery("site_part");

  var boSite = FCSession.CreateGeneric();
  boSite.SimpleQuery("site");
  boSite.AppendFilter("objid", "=", "268435457");
  boSitePart.Bulk.Query();

  // Relate the site_objid field to the objid of the first site record
  boSitePart.RelateIntFldToRecord(boSite, "site_objid");
  boSitePart.Update();

Visual Basic:

  Dim boSitePart As FCGeneric
  Dim boSite As FCGeneric

  Set boSitePart = fc_session.CreateGeneric
  boSitePart.SimpleQuery "site_part"

  Set boSite = fc_session.CreateGeneric
  boSite.SimpleQuery "site_part"
  boSite.AppendFilter "objid", "=", 268435457
  boSitePart.Bulk.Query

  boSitePart.RelateIntFldToRecord boSite, "site_objid"
  boSitePart.Update


RelateRecords | fcSDK Documentation

RelateRecords

Object and Type

Object : FCGeneric

Type : Method

Prototype

Public Sub RelateRecords(o_obj As FCGeneric, the_rel As String)

Description

This method is used to relate two records together via a specified realation. The relation specified must be valid for the generic object that the method is called on (not the generic object that is the first argument). You may relate the objects from either side.for example, suppose you wish to relate a case generic object and a site generic object. You could make either (or both, but that doesn't help you!) calls below:

boCase.RelateRecords(boSite, "case_reporter2site")

boSite.RelateRecords(boCase, "cust_loc2case")

You must update one or the other objects via the Update or UpdateAll method for the relation to take place.

Parameters

Parameter Name | Required? | Description
o_obj | Yes | The object to which to relate
the_field | Yes | The relation to use to relate the objects

Error Codes

Value | Meaning
12010 | The specified relation does not relate these two objects
12011 | The two objects must be in the same bulk
12031 | This operation is not valid for a generic that is marked distinct

Examples

The following example relates a new case generic object to a new site and contact generic objects.

JavaScript:

  // Find the site and contact

  var boSite = FCSession.CreateGeneric();
  boSite.SimpleQuery("site");
  boSite.AppendFilter("objid", "=", "268435457");

  var boContact = FCSession.CreateGeneric();
  boContact.SimpleQuery("contact");
  boContact.AppendFilter("objid", "=", "268435457");
  boContact.Bulk.Query();

  // Create a new case
  var boCase = FCSession.CreateGeneric();
  boCase.SimpleQuery("case");
  boCase.AddNew();

  // Now relate it and commit it
  boCase.RelateRecords(boSite, "case_reporter2site");
  boCase.RelateRecords(boContact, "case_reporter2contact");
  boCase.Update();

Visual Basic:

  Dim boCase As FCGeneric
  Dim boSite As FCGeneric
  Dim boContact As FCGeneric

  Set boContact = fc_session.CreateGeneric

  boContact.SimpleQuery "contact"
  boContact.AppendFilter "objid", "=", 268435457

  Set boSite = fc_session.CreateGeneric

  boSite.SimpleQuery "site"
  boSite.AppendFilter "objid", "=", 268435457
  boSite.Bulk.Query

  Set boCase = fc_session.CreateGeneric

  boCase.SimpleQuery "case"
  boCase.AddNew
  boCase.RelateRecords boSite, "case_reporter2site"
  boCase.RelateRecords boContact, "case_reporter2contact"
  boCase.Update


RequeryForInserts | fcSDK Documentation

RequeryForInserts

Object and Type

Object : FCGeneric

Type : Method

Prototype

Public Sub RequeryForInserts()

Description

This is an old method, and has been obsoleted. It is still provided for backwards compatibility, but does no work. Do not call on this method.


SimpleQuery | fcSDK Documentation

SimpleQuery

Object and Type

Object : FCGeneric

Type : Method

Prototype

Public Sub SimpleQuery(ByVal obj_name As String)

Description

This method sets the DBObjectName property for a generic object. It is exactly the same as that property, and is included for similarity with ClearBasic.

Call on this method for all generics, except those that will be child objects.

Parameters

Parameter Name | Required? | Description
obj_name | Yes | The name of the table or view, not including the "table_"

Example

The following example queries the case table.

JavaScript:

  // Query the case table
  var boCase = FCSession.CreateGeneric();
  boCase.SimpleQuery("case");
  boCase.Query();

Visual Basic:

  Dim boCase As FCGeneric
  Set boCase = fc_session.CreateGeneric
  boCase.SimpleQuery "case"
  boCase.Query


TotalCount | fcSDK Documentation

TotalCount

Object and Type

Object : FCGeneric

Type : Method

Prototype

Public Function TotalCount() As Long

Description

This method returns back the number of rows currently in a generic object. For example, if you query a database table, and the query returned 14 rows, you would expect TotalCount to return 14. If you then called on AddNew to add a row, it would return 15.

This method returns back the total number of records in the generic object, even if it is a child object. To return the number of records in the generic object related to the current row of the parent generic object, use the Count method.

Returns

The total number of rows in this generic.

Example

The following example queries the case table and the notes_log table. Then, for each case, it reports how many notes are related, and shows how many total rows are in each generic.

JavaScript:

  // Query case and notes_log
  var boCase = FCSession.CreateGeneric();
  boCase.SimpleQuery("case");

  var boNotes = FCSession.CreateGeneric();
  boNotes.TraverseFromParent(boCase, "case_notes2notes_log");
  boCase.Query();

  Response.Write ("Total Num of Cases: " + boCase.TotalCount());
  Response.Write ("Total Num of Notes: " + boNotes.TotalCount());

  // Loop through all cases
  // For each, print the case ID

  while (boCase.EOF != true)
  {
    Response.Write ("Case: " + boCase("id_number"));
    // Now print out how many notes exist for that case only
    Response.Write ("  Number of Notes: " + boNotes.Count());
    // Now get the next case
    boCase.MoveNext();
  }

Visual Basic:

  Dim boCase As FCGeneric
  Dim boNotes As FCGeneric

  Set boCase = fc_session.CreateGeneric
  boCase.SimpleQuery "case"

  Set boNotes = fc_session.CreateGeneric
  boNotes.TraverseFromParent boCase, "case_notes2notes_log"

  boCase.Query

  MsgBox "Total Num of Cases: " & Trim$(Str$(boCase.TotalCount))
  MsgBox "Total Num of Notes: " & Trim$(Str$(boNotes.TotalCount))

  While boCase.EOF = False
    MsgBox "Case: " & boCase("id_number") & " " & "Num of notes: " & _
           Trim$(Str$(boNotes.Count))
    boCase.MoveNext
  Wend


TraverseFromParent | fcSDK Documentation

TraverseFromParent

Object and Type

Object : FCGeneric

Type : Method

Prototype

Public Sub TraverseFromParent(ByVal the_parent As FCGeneric, _
                              ByVal trav_rel As String)

Description

This method sets up the parent/child relationship between two generic objects. It is exactly the same as setting the ParentRelation and ParentBO properties, but is easier.

This method should be called for the child generic object, and should specify the parent object, and the relation ON THE PARENT used to traverse between the two objects. Note that this is the opposite of the ParentRelation property which is the relation from the child to the parent.for example, to query a case, and the related contact record, you would create both generic objects and then specify:

boContact.TraverseFromParent(boCase, "case_reporter2contact");

In other words, the method specifies the parent generic object, and the relation you use on that parent to get to this (child) generic object.

You should not call on TraverseFromParent more than once in a row (or use the ParentRelation and ParentBO properties) without first calling the Untraverse method first. If you do, an error results.

Note: This method will set the DBObjectName for this generic object. Thus it is not necessary to set it for the child object.

Note: When you set the parent relation with ParentBO, the child object's BulkName is set to the parent's BulkName.

Parameters

Parameter Name | Required? | Description
the_parent | Yes | The parent generic object
trav_rel | Yes | The relation ON THE PARENT used to traverse between the two generic objects

Error Codes

Value | Meaning
12024 | Two TraverseFromParent calls were made on this generic without first calling on the UnTraverse method.

Examples

The following example queries case objects, and a related contact and site objects.

JavaScript:

  // Get all cases
  var boCase = FCSession.CreateGeneric();
  boCase.SimpleQuery("case");

  // Now get the related contacts
  var boContact = FCSession.CreateGeneric();
  boContact.TraverseFromParent(boCase, "case_reporter2contact");

  // Now get the related sites
  var boSite = FCSession.CreateGeneric();
  boSite.TraverseFromParent(boCase, "case_reporter2site");

  // Query the data, and display it
  boCase.Query();

  while (boCase.EOF != true)
  {
    Response.Write ("Case: " + boCase("id_number") + "  Site/Contact: " +
                  boSite("name") + " - " + boContact("first_name") +
                  " " \+ boContact("last_name"));
    boCase.MoveNext();
  }

Visual Basic:

  Dim boCase As FCGeneric
  Dim boSite As FCGeneric
  Dim boContact As FCGeneric

  Set boCase = fc_session.CreateGeneric
  boCase.SimpleQuery "case"

  Set boContact = fc_session.CreateGeneric
  boContact.TraverseFromParent boCase, "case_reporter2contact"

  Set boSite = fc_session.CreateGeneric
  boSite.TraverseFromParent boCase, "case_reporter2site"

  boCase.Query

  While boCase.EOF = False
    MsgBox "Case: " & boCase("id_number") & "  Site/Contact: " & _
           boSite("name") & " - " & boContact("first_name") & " " & _
           boContact("last_name")
    boCase.MoveNext
  Wend


TraverseFromRoot | fcSDK Documentation

TraverseFromRoot

Object and Type

Object : FCGeneric

Type : Method

Prototype

Public Sub TraverseFromRoot(ByVal RootObjid As Long, _
            ByVal TblName As String, ByVal RootRel As String)

Description

This method sets a query for a generic object, given a root object table name, the objid for a row in that table, and the relation to follow from that row to this generic object. This method saves querying the root object (as a parent object) when there is no need. This method is only useful when you already have an objid of a root row. For example, the current user's objid is cached in the FCApplication object. There is no reason to expend time to query the user table just to get that row (for a child query). Instead, the TraverseFromRoot is very useful.

Note: There is no parent/child relationship set up (as there is with TraverseFromParent), as there is no parent generic object.

Note: This method will set the DBObjectName for this generic object. Thus it is not necessary to set it for this object.

Note: This method does not automatically set the BulkName. You must still set this manually.

Parameters

Parameter Name | Required? | Description
RootObjid | Yes | The objid of the root row in the root object
TblName | Yes | The name (not including the "table_" of the root table
RootRel | Yes | The relation to follow from the root row to this generic object

Example

The following example retrieves all of the queues that the current user is assigned to.

JavaScript:

  // Create the queue object

  // Traverse from the current user's objid
  var boQueue = FCSession.CreateGeneric();
  boQueue.TraverseFromRoot(FCSession.Item("user.id"), "user",
                           "user_assigned2queue");

  // Query the data, and display it
  boQueue.Query();

  while (boQueue.EOF != true)
  {
    Response.Write ("Queue title: " + boQueue("title"));
    boQueue.MoveNext();
  }

Visual Basic:

  Dim boQueue As FCGeneric

  Set boQueue = fc_session.CreateGeneric
  boQueue.TraverseFromRoot fc_session.item("user.id"), _
                           "user", "user_assigned2queue"
  boQueue.Query

  While boQueue.EOF = False
    MsgBox boQueue("title")
    boQueue.MoveNext
  Wend


UnRelateAll | fcSDK Documentation

UnRelateAll

Object and Type

Object : FCGeneric

Type : Method

Prototype

Public Sub UnRelateAll(ByVal the_rel As String)

Description

This method is exactly the same as the UnRelateRecordFromAll that is documented below. It is included for compliancy with eBusiness Framework. For more details about the API, please see below.


UnRelateRecordFromAll | fcSDK Documentation

UnRelateRecordFromAll

Object and Type

Object : FCGeneric

Type : Method

Prototype

Public Sub UnRelateRecordFromAll(ByVal the_rel As String)

Description

This method will unrelate the current record in a generic object from all other objects that it is related to via the specified relation. For example, if a case is related to 100 research logs, and you would like to unrelate it from all of them (in one method call), simply call this method with the proper case relation.

The method works for any and all cardinalities (OTM, MTO, OTO, MTM), and the related objects do NOT need to be in a generic object.

Note: The unrelate does not take place until the Update or UpdateAll method is called to update the current record in the generic object.

Parameters

Parameter Name | Required? | Description
the_rel | Yes | The relation to use to find the objects to unrelate

Error Codes

Value | Meaning
12031 | This operation is not valid for a generic that is marked distinct

Examples

The following example unrelates the specified case from all part_used records.

JavaScript:

  // Query cases

  var boCase = FCSession.CreateGeneric();
  boCase.SimpleQuery("case");
  boCase.Query();

  // Now unrelate it from all part used records
  boCase.UnRelateRecordFromAll("case2part_used");

  boCase.Update();

Visual Basic:

  Dim boCase As FCGeneric

  Set boCase = fc_session.CreateGeneric
  boCase.SimpleQuery "case"
  boCase.Query

  boCase.UnRelateRecordFromAll "case2part_used"

  boCase.Update


| fcSDK Documentation

UnRelateRecords

Object and Type

Object : FCGeneric

Type : Method

Prototype

Public Sub UnRelateRecords(ByVal o_obj As FCGeneric, _
                           ByVal the_rel As String)

Description

This method will unrelate the current record in a generic object from the current record in the other specified object via the relation specified.

The relation specified must be valid for the generic object that the method is called on (not the generic object that is the first argument). You may unrelate the objects from either side.for example, suppose you wish to unrelate a case generic object and a site_part generic object. You could make the unrelate call from either object.

You must update one or the other objects via the Update or UpdateAll method for the relation to be cleared.

Parameters

Parameter Name | Required? | Description
o_obj | Yes | The other object to unrelate from
the_rel | Yes | The relation to use to find the objects to unrelate

Error Codes

Value | Meaning
12010 | The specified relation does not relate these two objects
12011 | The two objects must be in the same bulk
12031 | This operation is not valid for a generic that is marked distinct

Examples

The following example unrelates the specified case from the specified revision (mod_level).

JavaScript:

  // Find the case and revision (mod_level)

  var boCase = FCSession.CreateGeneric();
  boCase.SimpleQuery("case");
  boCase.AppendFilter("objid", "=", "268435457");

  var boML = FCSession.CreateGeneric();
  boML.SimpleQuery("mod_level");
  boML.AppendFilter("objid", "=", "268435457");

  boCase.Bulk.Query();

  // Now unrelate them and commit the change
  boCase.UnRelateRecords(boML, "case_prt2part_info");

  boCase.Update();

Visual Basic:

  Dim boCase As FCGeneric
  Dim boML As FCGeneric

  Set boCase = fc_session.CreateGeneric
  boCase.SimpleQuery "case"
  boCase.AppendFilter "objid", "=", 268435457

  Set boML = fc_session.CreateGeneric
  boML.SimpleQuery "mod_level"
  boML.AppendFilter "objid", "=", 268435457

  boCase.Bulk.Query

  boCase.UnRelateRecords boML, "case_prt2part_info"

  boCase.Update


UnTraverse | fcSDK Documentation

UnTraverse

Object and Type

Object : FCGeneric

Type : Method

Prototype

Public Sub Untraverse()

Description

This method will clear the ParentRelation, ParentBO and root object properties for a generic object that was marked as a child or as a root query. It also works if you originally called on the TraverseFromParent or TraverseFromRoot methods.

It is not recommended that you use this method after you have queried the generic object, as unexpected results with Move and Count may occur.

Example

The following example clears a child object relation after it was made in error.

JavaScript:

  // Set a case/contact relationship, and then unrelate it

  var boCase = FCSession.CreateGeneric();
  boCase.SimpleQuery("case");

  var boContact = FCSession.CreateGeneric();
  boContact.TraverseFromParent(boCase, "case_reporter2contact");

  // Remember that you now have to set the DBObjectName for the boContact

  boContact.UnTraverse();

Visual Basic:

  Dim boCase As FCGeneric
  Dim boContact As FCGeneric

  Set boCase = fc_session.CreateGeneric
  boCase.SimpleQuery "case"

  Set boContact = fc_session.CreateGeneric
  boContact.TraverseFromParent boCase, "case_reporter2contact"

  boContact.Untraverse


Update(FCGeneric) | fcSDK Documentation

Update(FCGeneric)

Object and Type

Object : FCGeneric

Type : Method

Prototype

Public Sub Update()

Description

This crucial method will update the CURRENT record in the generic object (and only that record). The method will add it, update it, or delete it as appropriate. It will also make whatever relations are needed so that the object will be correct.

If no changes have been made to the current record in the generic object, this method will do nothing.

If you wish to update all of the (modified) records in the generic object, you should call on the UpdateAll method. If you wish to modify records in multiple generic objects in one unit of work (for referential integrity), use the FCBulk object's Update or UpdateAll method.

Error Codes

Value | Meaning
12008 | You may not update a view
12009 | Could not add record because not all fields were selected in a previous query
12031 | This operation is not valid for a generic that is marked distinct

Examples

The following example locates a site record and updates a field in it.

JavaScript:

  // Locate a specific site, and update a field in it
  var boSite = FCSession.CreateGeneric();
  boSite.SimpleQuery("site");
  boSite.AppendFilter("objid", "=", "268435457");
  boSite.Query();

  boSite("external_id") = "An ID";
  boSite.Update();

Visual Basic:

  Dim boSite As FCGeneric

  Set boSite = fc_session.CreateGeneric
  boSite.SimpleQuery "site"
  boSite.AppendFilter "objid", "=", 268435457
  boSite.Query

  boSite("external_id") = "External"
  boSite.Update


UpdateAll(FCGeneric) | fcSDK Documentation

UpdateAll(FCGeneric)

Object and Type

Object : FCGeneric

Type : Method

Prototype

Public Sub UpdateAll()

Description

This crucial method will update ALL of the records in the generic object. The method will add, update, or delete any records as appropriate. It will also make whatever relations are needed so that the object will be correct.

If no changes have been made to any of the records in the generic object, this method will do nothing to those records.

If you wish to update just one record in the generic object, you should call on the Update method. If you wish to modify records in multiple generic objects in one unit of work (for referential integrity), use the FCBulk object's Update or UpdateAll method.

Error Codes

Value | Meaning
12008 | You may not update a view
12009 | Could not add record because not all fields were selected in a previous query
12031 | This operation is not valid for a generic that is marked distinct

Examples

The following example sets the external_id field for all of the sites that it locates.

JavaScript:

  // Find all sites
  var boSite = FCSession.CreateGeneric();
  boSite.SimpleQuery("site");
  boSite.Query();

  // Update a field for all of the sites
  // Update all modified records in this generic

  while (boSite.EOF != true)
  {
    boSite("external_id") = "An external ID";
    boSite.MoveNext();
  }

  boSite.UpdateAll();

Visual Basic:

  Dim boSite As FCGeneric

  Set boSite = fc_session.CreateGeneric
  boSite.SimpleQuery "site"
  boSite.Query

  While boSite.EOF = False
    boSite("external_id") = "An external ID!"
    boSite.MoveNext
  Wend

  boSite.UpdateAll


BOF | fcSDK Documentation

BOF

Object and Type

Object : FCGeneric

Type : Property (Read-only)

Prototype

Public BOF As Boolean

Description

This property is used to determine if the current record for a generic object is set before the start of the dataset. For example, if you use a MoveFirst call to move to the first record of an object, and then call on MovePrevious, the BOF property would be set to True. If you then called on MoveFirst, the BOF property would be set to False.

Example

The following example demonstrates a common loop where each record in an object is processed until there are no more. The traversal in this case is made from the last record of the object to the first. It uses BOF for the termination condition.

JavaScript:

  // Get sites so we can loop through them
  var boSite = FCSession.CreateGeneric();
  boSite.SimpleQuery("site");
  boSite.Query();

  // Now print them out in reverse order
  boSite.MoveLast();
  while (boSite.BOF != true)
  {
    Response.Write ("Site: " + boSite("name"));
    boSite.MoveNext();
  }

Visual Basic:

  Set boSite = fc_session.CreateGeneric
  boSite.SimpleQuery "site"
  boSite.Query

  boSite.MoveLast
  While boSite.BOF = False
    MsgBox "Site: " & boSite("name")
    boSite.MovePrevious
  Wend


Bulk | fcSDK Documentation

Bulk

Object and Type

Object : FCGeneric

Type : Property

Prototype

Public Bulk As FCBulk

Description

This property allows you to specify the bulk object for this generic. Or you can get the bulk object associated with this generic.

In almost all cases, you will not need to use this method. Bulks are automatically created by FCFL, and you do not need to worry about them.

Rather than using this property, you will usually just use the BulkName property to set the name of the bulk associated with this generic. If that bulk name does not exist, FCFL will build it for you.

When generic objects are created, they are associated with a special bulk, whose name is the empty string ("").

Example

The following example creates two generic objects. One is assigned to a bulk via the BulkName property. The other is moved into the same bulk with the Bulk property.

JavaScript:

  // Create the first object
  var boObj1 = FCSession.CreateGeneric();
  boObj1.SimpleQuery("part_num");
  boObj1.BulkName = "my_bulk";

  // Create the other object. Put it in the same bulk as the first
  var boObj2 = FCSession.CreateGeneric();
  boObj2.SimpleQuery("part_num");
  boObj2.Bulk = boObj1.Bulk;

  // Show that the bulks are now the same
  Response.Write ("Bulk 1 name is: " + boObj1.Bulk.Name);
  Response.Write ("Bulk 2 name is: " + boObj2.Bulk.Name);

Visual Basic:

  Dim boObj1 As FCGeneric
  Dim boObj2 As FCGeneric

  Set boObj1 = fc_session.CreateGeneric
  boObj1.SimpleQuery "part_num"
  boObj1.BulkName = "my_bulk"

  Set boObj2 = fc_session.CreateGeneric
  boObj2.SimpleQuery "part_num"
  boObj2.Bulk = boObj1.Bulk

  MsgBox "Bulk 1 name is: " & boObj1.Bulk.Name
  MsgBox "Bulk 2 name is: " & boObj2.Bulk.Name


BulkName | fcSDK Documentation

BulkName

Object and Type

Object : FCGeneric

Type : Property

Prototype

Public BulkName As String

Description

This property allows you to specify the bulk object for this generic. It also allows you to see the name of the bulk associated with this generic.

When you set the bulk name for a generic, FCFL will associate the generic to the proper bulk object for you. If the FCBulk object does not yet exist, it will create it for you automatically.

When generic objects are created, they are associated with a special bulk, whose name is the empty string ("").

Example

The following example creates two generic objects. They are both placed into the same bulk so that they can be queried and written together in a single unit of work.

JavaScript:

  // Create the first object
  var boObj1 = FCSession.CreateGeneric();
  boObj1.SimpleQuery("part_num");
  boObj1.BulkName = "my_bulk";

  // Create the other object. Put it in the same bulk as the first
  var boObj2 = FCSession.CreateGeneric();
  boObj2.SimpleQuery("part_num");
  boObj2.BulkName = "my_bulk";

  // Show that the bulks are now the same
  Response.Write ("Bulk 1 name is: " + boObj1.Bulk.Name);
  Response.Write ("Bulk 2 name is: " + boObj2.Bulk.Name);

Visual Basic:

  Dim boObj1 As FCGeneric
  Dim boObj2 As FCGeneric

  Set boObj1 = fc_session.CreateGeneric
  boObj1.SimpleQuery "part_num"
  boObj1.BulkName = "my_bulk"

  Set boObj2 = fc_session.CreateGeneric
  boObj2.SimpleQuery "part_num"
  boObj2.BulkName = "my_bulk"

  MsgBox "Bulk 1 name is: " & boObj1.Bulk.Name
  MsgBox "Bulk 2 name is: " & boObj2.Bulk.Name


DataFields | fcSDK Documentation

DataFields

Object and Type

Object : FCGeneric

Type : Property

Prototype

Public DataFields As String

Description

This property contains the column(s) that will be queried for this generic object when you query the database.

If you leave it blank, FCFL will assume that you want all fields/relations for the table, and will put "" into the property. You may also put "" into the property yourself if you want.

In general, you can query for all columns. But if your query returns a lot of rows, it may be useful to specify only those you need, to improve performance.

If you know that you only need certain columns, you may list them, separated by commas, in this property. If you plan to traverse to children objects (via an MTO or OTOP on this table), you should include that relation as one of the columns to retrieve. You may also use the IncludeRelations property to simplify the process.

The objid column is always retrieved - you do not need to specify it.

If you intend to create new rows in the generic object (with AddNew) and add them to the database, you should return all columns, as otherwise the insert will fail. You can also use the RequeryForInserts method if you only query for some columns.

Example

The following example sets up a database query, only returning the needed rows for display, and for traversing to the child object.

JavaScript:

  // Query case and notes_log
  var boCase = FCSession.CreateGeneric();
  boCase.DataFields = "id_number, title, case_reporter2contact";
  boCase.SimpleQuery("case");

  var boContact = FCSession.CreateGeneric();
  boContact.TraverseFromParent(boCase, "case_reporter2contact");
  boCase.Query();

  // Loop through all cases
  // For each, print the case ID and contact name

  while (boCase.EOF != true)
  {
    Response.Write ("Case: " + boCase("id_number") + " Contact: " +
            boContact("first_name") + " " + boContact("last_name"));
    // Now get the next case
    boCase.MoveNext();
  }

Visual Basic:

  Dim boCase As FCGeneric
  Dim boContact As FCGeneric

  Set boCase = fc_session.CreateGeneric
  boCase.SimpleQuery "case"
  boCase.DataFields = "id_number, title, case_reporter2contact"

  Set boContact = fc_session.CreateGeneric
  boContact.TraverseFromParent boCase, "case_reporter2contact"
  boCase.Query

  While boCase.EOF = False
    MsgBox "Case: " & boCase("id_number") & " Contact: " & boContact("first_name") & _
           " " & boContact("last_name")

    boCase.MoveNext
  Wend


DBObjectName | fcSDK Documentation

DBObjectName

Object and Type

Object : FCGeneric

Type : Property

Prototype

Public DBObjectName As String

Description

This property contains the table or view name of this generic object. The name should NOT include the "table_". For example, for table_case, the DBObjectName should be set to "case".

This property can be set directly on the object, or you can use the provided SimpleQuery method.

When you have a generic object that is a child object (that is, is traversed from a parent BO), you MUST NOT set this property. Rather, this property will be set for you when you call on the TraverseFromParent method, or you set the ParentRelation and ParentBO properties. However, once one of those properties/methods is called, you may still use this property to read the value of the table/view name.

Error Codes

Value | Meaning
12035 | The specified table or view name is not defined

Examples

The following example queries the contact table using the DBObjectName property.

JavaScript:

  // Set up a query of all contacts
  var boContact = FCSession.CreateGeneric();
  boContact.DBObjectName = "contact";
  boContact.Query();

Visual Basic:

  Dim boContact As FCGeneric
  Set boContact = fc_session.CreateGeneric
  boContact.DbObjectName = "contact"
  boContact.Query


DBObjectNum | fcSDK Documentation

DBObjectNum

Object and Type

Object : FCGeneric

Type : Property (Read-only)

Prototype

Public DBObjectNum As Long

Description

This property reports the object number of the table or view for this object. The value in it is not set until you either call on SimpleQuery, or set the DBObjectName property. The number corresponds to the object number in the Data Dictionary.

Example

The following example creates a new object and reports on the DBObjectNum.

JavaScript:

  // Set up a query of all contacts
  var boContact = FCSession.CreateGeneric();
  boContact.DBObjectName = "contact";
  boContact.Query();

Visual Basic:

  Dim boContact As FCGeneric
  Set boContact = fc_session.CreateGeneric
  boContact.DbObjectName = "contact"
  boContact.Query


Distinct(FCGeneric) | fcSDK Documentation

Distinct(FCGeneric)

Object and Type

Object : FCGeneric

Type : Property

Prototype

Public Distinct  As Boolean

Description

This property tells the generic object that it should perform a "distinct" query. That is, it should perform a "select distinct" for the data fields supplied.

It is required, for this property, that you supply the data fields that the object is to query. If you do not provide data fields, the Query method will throw an error. Distinct generic objects do NOT add the objid column to the output data fields.

You may use AppendFilters and AppendSorts to modify the query that FCFL will perform for the distinct generic.

Distinct generic objects, after they are queried, are read-only. If you attempt to write data to the generic, an error will be thrown. The following methods and properties are not allowed for distinct generics:

  • AddForUpdate
  • AddNew
  • Delete
  • DeleteAll
  • Duplicate
  • Fields Let
  • RelateById
  • RelateIntFldByID
  • RelateIntFldToRecord
  • RelateRecords
  • UnRelateAll
  • UnRelateRecordFromAll
  • UnRelateRecords
  • Update (Bulk)
  • Update (Generic)
  • UpdateAll (Bulk)
  • · UpdateAll (Generic)

Example

The following example demonstrates setting the Distinct property for a new object.

JavaScript:

  // Set this generic to be a distinct one
  var boCase = FCSession.CreateGeneric("case");
  boCase.DataFields = "title, id_number";
  boCase.Distinct = true;

Visual Basic:

  Dim boCase As FCGeneric
  Set boCase = fc_session.CreateGeneric
  boCase.SimpleQuery "case"
  boCase.DataFields = "title, id_number"
  boCase.Distinct = True


ErrorOnQueryTooBig | fcSDK Documentation

ErrorOnQueryTooBig

Object and Type

Object : FCGeneric

Type : Property

Prototype

Public ErrorOnQueryTooBig As Boolean

Description

If you query the database, and a Generic object has a RowLimit associated with it, and the query returns more rows than the Generic allows, this property controls the behavior of FCFL. If the property is set to True (the default), then FCFL will throw an error.

In some cases, however, the Generic's query will be part of a bulk, and you want the other queries to complete. In this situation you should set the property to False. This will cause FCFL to not throw an error. The RowsReturned property will be filled in with the number of rows that the query wants to return.

Note: If the query that exceeds a RowLimit has children queries, those children queries will not be queried against the database.

Example

The following example queries the case table with a RowLimit. If too many rows are returned, the number of rows that should have been returned is printed out because the ErrorOnQueryTooBig property is set to False.

Visual Basic:

  Set case_rec = fc_session.CreateGeneric
  case_rec.SimpleQuery "case"
  case_rec.rowLimit = 100
  case_rec.ErrorOnQueryTooBig = False
  case_rec.Query

  If case_rec.RowsReturned <> -1 Then
     MsgBox "The query returned too many rows. It returned " & _
      Trim$(Str$(case_rec.RowsReturned)) & " rows."
  End If


EOF | fcSDK Documentation

EOF

Object and Type

Object : FCGeneric

Type : Property (Read-only)

Prototype

Public EOF As Boolean

Description

This property is used to determine if the current record for a generic object is past the end of the dataset. For example, if you use a MoveLast call to move to the last record of an object, and then call on MoveNext, the EOF property would be set to True. If you then called on MoveFirst, the EOF property would be set to False.

Example

The following example demonstrates a common loop where each record in an object is processed until there are no more. It uses EOF for the termination condition.

JavaScript:

  // Get sites so we can loop through them
  var boSite = FCSession.CreateGeneric();
  boSite.SimpleQuery("site");
  boSite.Query();

  // Now print them out
  while (boSite.EOF != true)
  {
    Response.Write ("Site: " + boSite("name"));
    boSite.MoveNext();
  }

Visual Basic:

  Set boSite = fc_session.CreateGeneric
  boSite.SimpleQuery "site"
  boSite.Query

  While boSite.EOF = False
    MsgBox "Site: " & boSite("name")
    boSite.MoveNext
  Wend


Fields | fcSDK Documentation

Fields

Object and Type

Object : FCGeneric

Type : Property

Prototype

Public Fields As Collection

Description

This property is used to read or write specific fields in the current record of a generic object. The name of the field specified must be one that is valid for the generic object. You must also use the correct data type for the field when using it.

Note: If you query a table or view, and do not include a field (or MTO/OTOP relation) in the DataFields, you will receive an error if you attempt to read or set that field for any row in the generic object.

Error Codes

Value | Meaning
12023 | The field specified is not valid for this generic object
12030 | The user attempted to access a field in a generic object that contains no rows
12031 | This operation is not valid for a generic that is marked distinct
12034 | The value specified is out of range for the field's datatype

Examples

The following example demonstrates writing out some key fields from the site table after it is queried in the database. Then, some of the fields are modified so that they can be updated in the database.

JavaScript:

  // Set up a query of all rows in site table
  var boSite = FCSession.CreateGeneric();
  boSite.DBObjectName = "site";
  boSite.Query();

  // For the first row, print out some key fields and set one
  // Then update the site

  Response.Write ("Site ID  : " + boSite.Fields("site_id"));
  Response.Write ("Site Name: " + boSite("name"));

  boSite("external_id") = "My external ID";
  boSite.Update();

Visual Basic:

  Dim boSite As FCGeneric

  Set boSite = fc_session.CreateGeneric
  boSite.SimpleQuery "site"
  boSite.Query

  MsgBox "Site ID  : " & boSite.Fields("site_id")
  MsgBox "Site Name: " & boSite("name")

  boSite("external_id") = "Another external ID"
  boSite.Update


Filter | fcSDK Documentation

Filter

Object and Type

Object : FCGeneric

Type : Property

Prototype

Public Filter As String

Description

This property is used for the "where" clause when this generic object queries the database. You must use SQL syntax to specify the "where" clause.

In most cases, you should not use this property, but rather use the higher-level AppendFilter property provided. The AppendFilter property, each time you call on it, will add another clause to the "where" clause, and will join them together with "And".

The one time to use this property is if you have very complex filtering, particularly if you want to use the "Or" construct.

Example

The following example shows how to query for sites in Texas or Arizona from the site_view view.

JavaScript:

  // Set up a query of sites in Texas or Arizona
  var boSiteView = FCSession.CreateGeneric();
  boSiteView.DBObjectName = "site_view";
  boSiteView.Filter = "state = 'TX' or state = 'AZ'";
  boSiteView.Query();

  // Print them out
  while (boSiteView.EOF != true)
  {
    Response.Write ("Site ID: " + boSiteView("site_id"));
    boSiteView.MoveNext();
  }

Visual Basic:

  Dim boSiteView As FCGeneric

  Set boSiteView = fc_session.CreateGeneric
  boSiteView.SimpleQuery "site_view"
  boSiteView.Filter = "state = 'TX' or state = 'AZ'"
  boSiteView.Query

  While boSiteView.EOF = False
    MsgBox "Site: " & boSiteView("site_id")
    boSiteView.MoveNext
  Wend


GenericID | fcSDK Documentation

GenericID

Object and Type

Object : FCGeneric

Type : Property (Read-only)

Prototype

Public GenericID As String

Description

This is an internal property that uniquely identifies the BO within the FCFL system. In most cases there is NO REASON for you to ever use this property. If you wish to read it (to maintain a unique key for your BOs), it can be read.

However, changing the value stored in this property could cause errors with other parts of FCFL.

Example

The following example creates two new generic objects, and prints out their GenericID values.

JavaScript:

  // Create an object
  var boCase = FCSession.CreateGeneric();
  boCase.SimpleQuery("case");

  // Print out the Generic ID
  Response.Write ("Case Generic ID: " + boCase.GenericID);

Visual Basic:

  Set boCase = fc_session.CreateGeneric
  boCase.SimpleQuery "case"

  MsgBox "Case Generic ID: " & boCase.GenericID


ID | fcSDK Documentation

ID

Object and Type

Object : FCGeneric

Type : Property

Prototype

Public ID As Long

Description

This read-only property returns the objid field of the current row of the generic object. If there are no rows in the generic, or the current record is BOF or EOF, the property returns a value of 0.

This propety can also be performed by returning the objid field from the Fields property of the generic.

Example

The following example demonstrates printing out the objid fields for all rows in a query.

JavaScript:

  // Find all sites
  var boSite = FCSession.CreateGeneric();
  boSite.SimpleQuery("site");
  boSite.Query();

  // Print out their objids with ID
  while (boSite.EOF != true)
  {
    Response.Write ("Site objid: " + boSite.ID);
    boSite.MoveNext();
  }

Visual Basic:

  Dim boSite As FCGeneric

  Set boSite = fc_session.CreateGeneric
  boSite.SimpleQuery "site"
  boSite.Query

  While boSite.EOF = False
    MsgBox "Objid is: " & Trim$(Str$(boSite.Id))
    boSite.MoveNext
  Wend


IncludeRelations_(FCGeneric)_ | fcSDK Documentation

IncludeRelations_(FCGeneric)_

Object and Type

Object : FCGeneric

Type : Property

Prototype

Public IncludeRelations As Boolean

Description

This property tells the generic object if it should include all MTO and OTOP relations for this object in the DataFields property when it queries the generic from the database.

If this property is set to False, then you must specifically list each and every relation that you wish to query using the DataFields property. If it is set to True, all of those relations are automatically selected, and are available for you to use.

When you create a new generic (with the FCSession.CreateGeneric method), the value of FCSession.IncludeRelations is automatically filled in to this property. Thus, if you wish to have IncludeRelations set to the same value for all generic BOs, you can set the value you wish in the FCSession object, and ignore this property on each generic object.

This property is included in FCFL for performance purposes. If you do not need the relations being queried from a specific generic object, this allows you to not include those relations, which can improve performance.

This property is important because if you wish to traverse from this generic to another (using the relation), you must include the relation in the query. Thus you must either list it specifically in the DataFields property, or you must turn on IncludeRelations.

Example

The following example demonstrates setting the IncludeRelations property for a new object.

JavaScript:

  // Include all relations in a query for site_part
  var boSitePart = FCSession.CreateGeneric();
  boSitePart.SimpleQuery("site_part");
  boSitePart.IncludeRelations = true;
  boSitePart.Query();

Visual Basic:

  Dim boSitePart As FCGeneric

  Set boSitePart = fc_session.CreateGeneric
  boSitePart.SimpleQuery "site_part"
  boSitePart.IncludeRelations = True
  boSitePart.Query


MaxRecords | fcSDK Documentation

MaxRecords

Object and Type

Object : FCGeneric

Type : Property

Prototype

Public Property Get MaxRecords() As Long

Public Property Let MaxRecords(ByVal new_max As Long)

Description

Indicates the maximum number of records to return from a query. Default is zero (no limit). This property simply sets the ADO MaxRecords property on the underlying ADO recordset. One issue to be aware of is that when you complete the query (and if it returns the maximum number of rows allowed), you do not know if there were additional rows that SQL wanted to return, or if you received them all.

Related Topics

RowLimit Property

Example

The following example limits the number of records returned.

Visual Basic:

Dim case_rec As FCGeneric

Set case_rec = fc_session.CreateGeneric("case")

case_rec.MaxRecords = 300


NoRes(FCGeneric) | fcSDK Documentation

NoRes(FCGeneric)

Object and Type

Object : FCGeneric

Type : Property

Prototype

Public NoRes As Boolean

Description

This property tells the generic object if it should ignore data restriction for queries (and insertions of new rows). If this property is set to False (which is the default), then data restriction is properly applied to this generic object. If the property is set to True, then FCFL does not apply any data restrictions to the object.

This property must be set prior to the Query method being called (for queries), and the Update or UpdateAll methods being called (for inserts).

Note: This property is quite powerful, and can create significant problems if misused. It should only be used by experienced programmers.

Example

The following example demonstrates setting the NoRes property for a new object. First a query is performed with normal data restriction. Then the same query is performed without data restriction.

JavaScript:

  // Query for all sites for the restriction group
  var boSite = FCSession.CreateGeneric('site');
  boSite.Query();

  // Query for all sites
  var boSite2 = FCSession.CreateGeneric('site');
  boSite2.NoRes = True;
  boSite2.Query();

Visual Basic:

  Dim boSite  As FCGeneric
  Dim boSite2 As FCGeneric

  Set boSite = fc_session.CreateGeneric
  boSite.SimpleQuery "site"
  boSite.Query

  Set boSite2 = fc_session.CreateGeneric
  boSite2.SimpleQuery "site"
  boSite2.NoRes = true
  boSite2.Query


NowStr | fcSDK Documentation

NowStr

Object and Type

Object : FCGeneric

Type : Property

Prototype

Const NowStr = -999

Description

This is a constant that you may choose to add to your programs. In truth, you can actually use the integer (-999) defined above, but it is better to define the constant.

This constant can be used in your programs if you wish to assign the current date and time to a date/time field. If you do, when the code executes it will place the current date/time in the specified field.

Example

Visual Basic:

  Const NowStr = -999
  Dim boCase As FCGeneric

  Set boCase = fc_session.CreateGeneric
  boCase.SimpleQuery "case"
  boCase.Query

  boCase("modify_stmp") = NowStr
  boCase.Update


ParentBO | fcSDK Documentation

ParentBO

Object and Type

Object : FCGeneric

Type : Property

Prototype

Public ParentBO As FCGeneric

Description

This property contains the parent generic object for this generic object. This property is used when querying multiple tables, and traversing from one to another. The object placed in this property is the parent generic. For each row in that parent generic, using the relation in the ParentRelation property, the related rows in this object are found. For example, if we query the case table, and wish also to see the related activity logs for those cases, we would create a generic object for the activity log table, and place the case generic in the ParentBO property of the activity log generic.

Note: When you set the parent relation with ParentBO, the child object's BulkName is set to the parent's BulkName.

Example

The following example demonstrates querying the case table, and then traversing to retrieve the related contact and related site.

JavaScript:

  // Get all cases
  var boCase = FCSession.CreateGeneric();
  boCase.SimpleQuery("case");

  // Now get the related contacts
  var boContact = FCSession.CreateGeneric();
  boContact.ParentBO = boCase;
  boContact.ParentRelation = "case_reporter2contact";

  // Now get the related sites
  var boSite = FCSession.CreateGeneric();
  boSite.ParentBO = boCase;
  boSite.ParentRelation = "case_reporter2site";

  // Query the data, and display it
  boCase.Query();

  while (boCase.EOF != true)
  {
    Response.Write ("Case: " + boCase("id_number") + "  Site/Contact: " +
                  boSite("name") + " - " + boContact("first_name") +
                  " " \+ boContact("last_name"));
    boCase.MoveNext();
  }

Visual Basic:

  Dim boCase As FCGeneric
  Dim boSite As FCGeneric
  Dim boContact As FCGeneric

  Set boCase = fc_session.CreateGeneric
  boCase.SimpleQuery "case"

  Set boContact = fc_session.CreateGeneric
  boContact.ParentBO = boCase
  boContact.ParentRelation = "case_reporter2contact"

  Set boSite = fc_session.CreateGeneric
  boSite.ParentBO = boCase
  boSite.ParentRelation = "case_reporter2site"
  boCase.Query

  While boCase.EOF = False
    MsgBox "Case: " & boCase("id_number") & "  Site/Contact: " & _
           boSite("name") & " - " & boContact("first_name") & " " & _
           boContact("last_name")
    boCase.MoveNext
  Wend


ParentRelation | fcSDK Documentation

ParentRelation

Object and Type

Object : FCGeneric

Type : Property

Prototype

Public ParentRelation As String

Description

This property contains the name of the relation that points FROM a parent object to this child generic. It is not the name of the relation that points from this child generic. This property is used when querying multiple tables, and traversing from one to another. For example, if we query the case table, and wish also to see the related activity logs for those cases, we would create a generic object for the activity log table, and place the case_act2act_entry relation name in the ParentRelation property.

When this property is used, you must always also set the ParentBO property for the child object.

This property should only be set for objects that are "children" objects in a query (being visited based on the value of a parent row in the parent business object. When you simply query a table (such as the case table above), or query a view, this property should not be set.

Also, it is recommended to use the advanced TraverseFromParent method instead of using this property.

Note: This property is not defined for generic objects on views, only on data tables.

Example

The following example demonstrates querying the case table, and then traversing to retrieve the related contact and related site.

JavaScript:

  // Get all cases
  var boCase = FCSession.CreateGeneric();
  boCase.SimpleQuery("case");

  // Now get the related contacts
  var boContact = FCSession.CreateGeneric();
  boContact.ParentBO = boCase;
  boContact.ParentRelation = "case_reporter2contact";

  // Now get the related sites
  var boSite = FCSession.CreateGeneric();
  boSite.ParentBO = boCase;
  boSite.ParentRelation = "case_reporter2site";

  // Query the data, and display it
  boCase.Query();

  while (boCase.EOF != true)
  {
    Response.Write ("Case: " + boCase("id_number") + "  Site/Contact: " +
                  boSite("name") + " - " + boContact("first_name") +
                  " " \+ boContact("last_name"));
    boCase.MoveNext();
  }

Visual Basic:

  Dim boCase As FCGeneric
  Dim boSite As FCGeneric
  Dim boContact As FCGeneric

  Set boCase = fc_session.CreateGeneric
  boCase.SimpleQuery "case"

  Set boContact = fc_session.CreateGeneric
  boContact.ParentBO = boCase
  boContact.ParentRelation = "case_reporter2contact"

  Set boSite = fc_session.CreateGeneric
  boSite.ParentBO = boCase
  boSite.ParentRelation = "case_reporter2site"

  boCase.Query

  While boCase.EOF = False
    MsgBox "Case: " & boCase("id_number") & "  Site/Contact: " & _
           boSite("name") & " - " & boContact("first_name") & " " & _
           boContact("last_name")
    boCase.MoveNext
  Wend


Position | fcSDK Documentation

Position

Object and Type

Object : FCGeneric

Type : Property

Prototype

Public Position As Long

Description

This property contains the absolute record number of the current record in the generic object. This property can be used to get the record number that is currently active, and can be used to set the current record in the generic object.

If you are not on an active record (if you have moved before the first record, or after the last one), the Position property will be set to a value less than zero.

It is not recommended to use this property to set the current record. Rather, use the MoveFirst, MoveLast, MovePrevious, MoveNext, and MoveRelative methods.

Example

The following example demonstrates querying the case table, and printing out the value of the position as we move through the data in the returned recordset.

JavaScript:

  // Get all cases
  var boCase = FCSession.CreateGeneric();
  boCase.SimpleQuery("case");

  // Query the data, and display the position
  boCase.Query();

  while (boCase.EOF != true)
  {
    Response.Write (boCase.Position);
    boCase.MoveNext();
  }

Visual Basic:

  Dim boCase As FCGeneric

  Set boCase = fc_session.CreateGeneric
  boCase.SimpleQuery "case"
  boCase.Query

  While boCase.EOF = False
    MsgBox "Position: " & Trim$(Str$(boCase.Position))
    boCase.MoveNext
  Wend


QueryEmptyToNull(FCGeneric) | fcSDK Documentation

QueryEmptyToNull(FCGeneric)

Object and Type

Object : FCGeneric

Type : Property

Prototype

Public QueryEmptyToNull As Boolean

Description

This property operates on queries for generics, and alters the behavior of the query for nullable string fields. Quite often people will write queries such as the following:

var boSite = FCSession.CreateGeneric('site');

boSite.AppendFilter("site_id", "=", "");

The problem is that it is unclear if this should include only the one site that has a site_id of the empty string (""), or if should also include any sites where the site_id is NULL.

If this property is set to True, then any query (for the "=" or "is in" operators) will include both the empty string and Nulls. If it is turned off, only the empty string will be queried. No other operators (such as Starts With) take advantage of this property - it doesn't make sense for those operators.

When you create a new generic (with the FCSession.CreateGeneric method), the value of FCSession.QueryEmptyToNull is automatically filled in to this property. Thus, if you wish to have QueryEmptyToNull set to the same value for all generic BOs, you can set the value you wish in the FCSession object, and ignore this property on each generic object.

NOTE: For strings that can't be Null, this method does not do anything.

Example

The following example demonstrates setting the QueryEmptyToNull property for a new object.

JavaScript:

  // Include all relations in a query for site_part
  var boSite = FCSession.CreateGeneric('site');
  boSite.QueryEmptyToNull = true;  // Not needed - it's the default!
  boSite.Query();

Visual Basic:

  Dim boSite As FCGeneric
  Set boSite = fc_session.CreateGeneric("site")
  boSite.QueryEmptyToNull = True
  boSite.Query


QuerySQL | fcSDK Documentation

QuerySQL

Object and Type

Object : FCGeneric

Type : Property

Prototype

Public QuerySQL As String

Description

This property simply contains the SQL statement that FCFL used to query the generic. When FCFL queries a generic object, the SQL string used for the query is placed into this string property. The primary purpose of this property is for debugging as new code is written.

No similar operation is currently available for insert, delete, and update operations.

Example

The following example demonstrates setting the QuerySQL property for a query object.

JavaScript:

  // Include all relations in a query for site_part
  var boSite = FCSession.CreateGeneric('site');
  boSite.Query();

  alert(boSite.QuerySQL);

Visual Basic:

  Dim boSite As FCGeneric
  Set boSite = fc_session.CreateGeneric("site")
  boSite.Query

  msgbox boSite.QuerySQL


Records(FCGeneric) | fcSDK Documentation

Records(FCGeneric)

Object and Type

Object : FCGeneric

Type : Property

Prototype

Public Records As ADODB.RecordSet

Description

This property contains the data records for the generic object. The records are stored in an ADODB.Recordset object.

The records for a generic query are created in one of two ways:

    1. A Query is performed on the generic object, thus retrieving data from the database.
    2. The AddNew (or AddForUpdate) method is called, adding a record at the end of the Records object.

In almost all cases, you do not need to ever worry about creating a Records object for a generic object. When you create the generic object, the Records object is created for you automatically.

Data is usually read and written from the Records object using high-level methods provided for the generic object. Some of these methods are: Fields (which allows you to set/get fields), RelateRecords (and similar relate methods), and UnRelate (which allows you to unrelate records from one another).

While it is recommended that you use the methods/properties listed in the previous paragraph, you can write or read the data in the Records property directly, as seen in the example below.

Note: For more information about ADODB Recordsets, please visit the Microsoft website at: http://www.microsoft.com/.

Example

The following example demonstrates querying the case table, and setting the alt_address field for each object returned, using the Records property.

JavaScript:

  // Query for all cases
  var boCase = FCSession.CreateGeneric();
  boCase.SimpleQuery("case");
  boCase.Query();

  while (boCase.EOF != true)
  {
    boCase.Records("alt_address") = "An alt address";
    boCase.MoveNext();
  }

  boCase.UpdateAll();

Visual Basic:

  Dim boCase As FCGeneric
  Set boCase = fc_session.CreateGeneric
  boCase.SimpleQuery ("case")
  boCase.Query

  While boCase.EOF = False
    boCase.records("alt_address") = "Another alt address"
    boCase.MoveNext
  Wend

  boCase.UpdateAll


RowLimit(FCGeneric) | fcSDK Documentation

RowLimit(FCGeneric)

Object and Type

Object : FCGeneric

Type : Property

Prototype

Public RowLimit As Integer

Description

This property allows you to set the maximum number of rows that the generic can return, when it is queried. If this property is set to 0, no limit will be applied.

If a query would return more rows the RowLimit property would allow, the query returns NO rows, and the number of rows that would have been returned is filled into the RowsReturned property.

Note: This property is affected by the ErrorOnQueryTooBig property. Please see that property for more information.

Example

The following example demonstrates setting and using the RowLimit property. The example allows you to query no more than 300 cases.

JavaScript:

// Set the session row limit, and create a generic that will share
// the limit
<%
var boCase = FCSession.CreateGeneric();
boCase.SimpleQuery("case");
boCase.RowLimit = 300;
boCase.Query();
%>


RowsReturned | fcSDK Documentation

RowsReturned

Object and Type

Object : FCGeneric

Type : Property

Prototype

Public RowsReturned As Long

Description

If you query the database, and a Generic object has a RowLimit associated with it, and the query returns more rows than the Generic allows, the number of rows that the query wanted to return is stored in this property.

If a query does not exceed the limit (or if there is no limit), this property will be set to -1. In this case, the number of rows returned can be found with the Count property of the generic.

Note: If a Generic's RowLimit is exceeded, the Generic contains zero objects (the query is not performed).

Note: The query will throw an error (or won't) based on the ErrorOnQueryTooBig property.

Example

The following example queries the case table with a RowLimit. If too many rows are returned, the number of rows that should have been returned is printed out.

Visual Basic:

  Set case_rec = fc_session.CreateGeneric
  case_rec.SimpleQuery "case"
  case_rec.rowLimit = 100

  On Error GoTo too_many

  case_rec.Query

  On Error GoTo 0

  ' Rest of code here

  Exit Sub

too_many:
  Err = 0
  MsgBox Err.Description

  Resume Next


SetNullStringsToEmpty(FCGeneric) | fcSDK Documentation

SetNullStringsToEmpty(FCGeneric)

Object and Type

Object : FCGeneric

Type : Property

Prototype

Public SetNullStringsToEmpty  As Boolean

Description

This property tells the generic object if it should set a string variable (that contains NULL) to the empty string ("") when it is read (touched). In other words, in a web environment, you might wish to look at/access a value from a record in an FCGeneric object. In these web environments, you don't want (usually) to have to deal with NULL values - they're messy.

By setting the value of this property to True, FCFL will automatically change the value of the field to the empty string for you, which is much easier to use in a web environment.

But, even though the value in the field has "changed" (from NULL to the empty string), FCFL is smart enough not to write that data change back to the database.

If this property is set to False, then FCFL will not alter the value of the field, and it will stay as NULL.

When you create a new generic (with the FCSession.CreateGeneric method), the value of FCSession. SetNullStringsToEmpty is automatically filled in to this property. Thus, if you wish to have SetNullStringsToEmpty set to the same value for all generic BOs, you can set the value you wish in the FCSession object, and ignore this property on each generic object.\

The only "problem" with this property is that when it is set to True, you cannot set the value of a string field to the empty string - FCFL will ignore it. This is not a common operation, but if you wish to accomplish it, just change the FCGeneric's property back to False.

Note: This only applies to Oracle databases and string fields. All other fields are unaffected by this property.

Example

The following example demonstrates setting the SetNullStringsToEmpty property for a new object.

JavaScript:

  // Set NULL fields to empty strings for an object
  var boSitePart = FCSession.CreateGeneric();
  boSitePart.SimpleQuery("site_part");
  boSitePart.SetNullStringsToEmpty = true;

Visual Basic:

  Dim boSitePart As FCGeneric
  Set boSitePart = fc_session.CreateGeneric
  boSitePart.SimpleQuery "site_part"
  boSitePart.SetNullStringsToEmpty = True


SortOrder | fcSDK Documentation

SortOrder

Object and Type

Object : FCGeneric

Type : Property

Prototype

Public SortOrder As String

Description

This property contains the sort order for a query for this generic object. It is a string that is appended to the end of the SQL select statement if the BO is queried against the database.

Note: It is recommended that you use the higher-level AppendSort method to add sort orders to a query.

Example

The following example sets the sort order for a site query to sort by the status (active, inactive, obsolete), and then by site name. Both sorts are in ascending order.

JavaScript:

  // Query the site table with sorting
  var boSite = FCSession.CreateGeneric();
  boSite.SimpleQuery("site");
  boSite.SortOrder = "status asc, name asc"
  boSite.Query();

  while (boSite.EOF != true)
  {
    Response.Write(boSite("name"));
    boSite.MoveNext();
  }

Visual Basic:

  Dim boSite As FCGeneric

  Set boSite = fc_session.CreateGeneric
  boSite.SimpleQuery "site"
  boSite.SortOrder = "status asc, name asc"
  boSite.Query

  While boSite.EOF = False
    MsgBox boSite("name")
    boSite.MoveNext
  Wend


FCFL FCList Object | fcSDK Documentation

FCFL FCList Object

Overview

The FCList object represents a list that can contain items of any data type. It emulates the behaviors (and has the same methods and properties) as the base ClearBasic List object.

This object is completely optional. There is no need to use this object to successfully use FCFL. But if you (like the programmers at First Choice Software) find this object useful, it has been exposed for your use.

To create a new FCList object, use the New keyword as you would any object. The following are examples of how to create an FCList in both JavaScript and Visual Basic:

JavaScript:

var aList;

aList = Server.CreateObject("FCFL.fclist");

Visual Basic:

Dim aList As New FCList


Clear | fcSDK Documentation

Clear

Object and Type

Object : FCList

Type : Method

Prototype

Public Sub Clear()

Description

This method clears out the data in a list and resets the list to a pristine condition. The list's property ItemType is reset and all data in the list is lost.

Example

This example shows the creation of a list with integer data, clear and reused with string data.

JavaScript:

var aList;
aList = new ActiveXObject("FCFL.fclist");
aList.AppendItem(2, 3, 4, 5);
aList.Clear();

aList.AppendItem("This", "is", "some", "data");

Visual Basic:

Dim list As New FCList

list.AppendItem 2, 3, 4, 5

' list now has the numbers 2, 3, 4 and 5
list.Clear

' list now has no data
list.AppendItem "This", "is", "some", "data"

' list now has the strings "This", "is", "some", and "data"


Concat | fcSDK Documentation

Concat

Object and Type

Object : FCList

Type : Method

Prototype

Public Sub Concat(ByRef param1 As Variant, _
                       Optional ByRef param2 As Variant, _
                       Optional ByRef param3 As Variant, _
                       Optional ByRef param4 As Variant, _
                       Optional ByRef param5 As Variant)

Description

This method takes 1 to 5 arguments and does in order concatenation on them. Items can be strings, numbers or other lists. The in order concatenation is placed into the list the method is called on. If the list already has data, that data is cleared out first.

This method concatenates the items that are in the same position it in the argument lists and places the result in the same position at in the resulting list. For example, if the lists list1, list2 and list3 are passed in, the first item in list1 concatenated with the first item in list1 is concatenated with the first item in list2 and list3. This forms the first item in the result list. The second item in list1 concatenated with the second item in list2 and list3, forming the second item in the result, and so on. For example :

list1 = "A", "B'", "C"
list2 = "xx", "yy", "zz"
list3 = 1, 2, 3

The resulting list is "Axx1", "Byy2", "Czz3"

The resulting list always has the number of items as the largest list passed. If a list passed in is shorter than the other lists passed in, once all its items are used, no further concatenation is done from that list. For example, if list2 in the above example only had two items, the third item in the resulting list will have no piece concatenated from list2. Finally, if a number or a string is sent in as one of the parameters, it is used in all the resulting list items. For example, if the string "test_" and the list (1,2,3) was passed into the method, the resulting list would be ("test_1", "test_2", "test_3"). A more complicated example showing all these rules is :

string1 = "test_"
list1= "A", "B", "C"
string2 = "_"
list2 = 1, 2, 3, 4
list3 = "x", "y", "z", "Q"

The resulting list is "test_A_1x", "test_B_2y", "test_C_3z", "test__4Q"

Notice how all items in the resulting contain the strings "test_" and "_" and that the final item in the resulting list contains no item from list1 (which has only 3 items). This completely implements the ClearBasic version of this method.

Parameters

Parameter Name | Required? | Description
param1 | Yes | First item or list to concatenate.
param2 | No | Second item or list to concatenate.
param3 | No | Third item or list to concatenate.
param4 | No | Fourth item or list to concatenate.
param5 | No | Fifth item or list to concatenate.

Example

This code illustrates the example given in the description section.

Visual Basic:

Dim list1 As New FCList
Dim list2 As New FCList
Dim list3 As New FCList
Dim list4 As New FCList

list1.AppendItem "A", "B", "C"
list2.AppendItem 1, 2, 3, 4
list3.AppendItem "x", "y", "z", "Q"
list4.Concat "test_", list1, "_", list2, list3

' list four now contains "test_A_1x", "test_B_2y", "test_C_3z", "test__4Q"


Contains | fcSDK Documentation

Contains

Object and Type

Object : FCList

Type : Method

Prototype

Public Function Contains(ByRef item As Variant) As Boolean

Description

This method tells whether item is a member of the list.

Parameters

Parameter Name | Required? | Description
item | Yes | Item to check for in the list.

Returns

Value | Meaning
True | List contains item.
False | List does not contain item.

Example

This example tests list4 for the element "test_A_1x".

Visual Basic:

Dim list4 As New FCList

If list4.Contains("test_A_1x") Then
  MsgBox "List includes 'test_A_1x'"
Else
  MsgBox "List does not include 'test_A_1x'"
End If


CopyList | fcSDK Documentation

CopyList

Object and Type

Object : FCList

Type : Method

Prototype

Public Function CopyList() As FCList

Description

This method makes a copy of the current list, and returns a pointer to the copy.

Returns

The copy of the list.

Example

This example creates a list, and makes a copy of it.

Visual Basic:

Dim mainList As New FCList
Dim theCopy  As FCList

mainList.AppendItem 2, 3, 4, 5

Set theCopy = mainList.CopyList


Down | fcSDK Documentation

Down

Object and Type

Object : FCList

Type : Method

Prototype

Public Sub Down(ByRef index_list As FCList)

Description

This method swaps downward items in the list. It takes as it argument an integer list of indexes of the items to move. Indexes are zero based, so the first item in the list to be processed is zero and the last item in the list is list.Count - 1. If items in index_list are neighbors in the list, they are moved as a group. The bottom item in the list (item zero) can never be moved. The movement is logical, in that the movement is done in the sorted order of the index list.

Parameters

Parameter Name | Required? | Description
index_list | Yes | A list containing the indexes of the items in the processed list to move. Indexes are zero based.

Returns

The list with the appropriate items in the index list moved down.

Error Codes

Value | Meaning
9 | Index in index_list is out of range for the list.
18 | Items in the index list must be integer.
19 | The index list contains duplicate indexes.

Example

This examples sets up list1 in order and list2 as a list of indexes of items to move down in list1. It then uses list2 to move down items in list1.

Visual Basic:

Dim list1 As New FCList
Dim list2 As New FCList

list1.AppendItem 1, 2, 3, 4, 5, 6, 7, 8, 9
list2.AppendItem 2, 3, 5, 8
list1.Down list2

' List 1 now contains 1, 3, 4, 2, 6, 5, 7, 9, 8


FindFirstIndex | fcSDK Documentation

FindFirstIndex

Object and Type

Object : FCList

Type : Method

Prototype

Public Function FindFirstIndex(ByRef item As Variant) As Integer

Description

This method returns the index of the first item in the list that is equal to item. Lists are zero based. This means the index to the first item is 0, the second is 1, etc. If the item is not found -1 is returned.

Parameters

Parameter Name | Required? | Description
item | Yes | Item to locate in the list.

Returns

Value | Meaning
-1 | Item not found in list.
>= 0 | Index of the item in the list. Indexes in list are zero based.

Examples

This example shows setting up a list and checking where the item '4' is located.

Visual Basic:

Dim list As New FCList
Dim where As Integer

list.AppendItem 1, 2, 3, 4, 5, 6, 4, 8, 9

where = list.FindFirstIndex(4)

If where >= 0 Then
  MsgBox "Item is located at index " + CStr(where) ' should be at 3
Else
  MsgBox "Item is not in list"
End If


GetItemByIndex | fcSDK Documentation

GetItemByIndex

Object and Type

Object : FCList

Type : Method

Prototype

Public Sub GetItemByIndex(ByVal index As Integer, ByRef value As Variant)

Description

This method returns the item in the list at the location specified. Lists are zero based. This means the index to the first item is 0, the second is 1, etc. This is similar to the ItemByIndex function, except the value is passed back as a parameter.

Parameters

Parameter Name | Required? | Description
index | Yes | Index of item in the list to return. List is zero based.
value | Yes | The item located at the index location.

Error Codes

Value | Meaning
7 | Index out of range for the list.
8 | List is empty.

Examples

This example shows setting up a list and getting the fourth item.

Visual Basic:

Dim list As New FCList
Dim value As Integer

list.AppendItem 1, 2, 3, 4, 5, 6, 7, 8, 9
list.GetItemByIndex 4, value

If value = 5 Then
  MsgBox "Item value is as expected"
Else
  MsgBox "Item is not correct"
End If


ItemByIndex | fcSDK Documentation

ItemByIndex

Object and Type

Object : FCList

Type : Method

Prototype

Public Function ItemByIndex(ByVal index As Integer) as Variant

Description

This method returns the item in the list at the location specified. Lists are zero based. This means the index to the first item is 0, the second is 1, etc. This is similar to the GetItemByIndex subroutine, except the value is passed back as the function value.

Parameters

Parameter Name | Required? | Description
index | Yes | Item in the list to return. List is zero based.

Returns

Item located at that index location.

Error Codes

Value | Meaning
7 | Index out of range for the list.
8 | List is empty.

Examples

This example shows setting up a list and getting the fourth item.

Visual Basic:

Dim list As New FCList

list.AppendItem 1, 2, 3, 4, 5, 6, 7, 8, 9 If list.ItemByIndex(4) = 5 Then
  MsgBox "Item value is as expected"
Else
  MsgBox "Item is not correct"
End If


ListByIndex | fcSDK Documentation

ListByIndex

Object and Type

Object : FCList

Type : Method

Prototype

Public Function ListByIndex(ByRef index As Variant) As FCList

Description

This method creates a new list from the parent list. This new list contains the items in the parameter index. Index can be an integer or a list of integers. If index is an integer, the item number of parent list is the only member of the new list. If index is a list, it is a list of integers to form the new list from. The list is zero based. This means the index to the first item is 0, the second is 1, etc.

Parameters

Parameter Name | Required? | Description
index | Yes | If index is an integer number, the item to include in new list. If index is a list, it is a list of items to form new list from. The list is zero based.

Returns

Returns a list containing the indicated items.

Error Codes

Value | Meaning
9 | Index out of range for the list.
12 | Index list must be of type integer or long.
13 | Index must be variable of type list, integer or long.

Examples

This example shows the creation of list2 from list1 first by an integer and then by a list (list3).

Visual Basic:

Dim list1 As New fc_List
Dim list2 As New fc_List
Dim list3 As New fc_List

list1.AppendItem "a", "b", "c", "d", "e", "f", "g", "h", "i"

Set list2 = list1.ListByIndex(3)

' list2 contains "d"

list3.AppendItem 3, 5, 7, 0

Set list2 = list1.ListByIndex(list3)

' list2 contains "d", "f", "h", "a"


RemoveByIndex | fcSDK Documentation

RemoveByIndex

Object and Type

Object : FCList

Type : Method

Prototype

Public Sub RemoveByIndex(ByRef index As Variant)

Description

This method removes items from a list. This resulting list has the proper elements removed. Index can be an integer or a list of integers. If index is an integer, only that item is removed. If index is a list, the list is a list of integers specifying which items to remove. Items are removed as indexed from before the first remove. Lists are zero based. This means the index to the first item is 0, the second is 1, etc. The removal is logical; Items are removed at the index they located at when the method is called.

Parameters

Parameter Name | Required? | Description
index | Yes | If index is an integer number, the item to remove from the list. If index is a list, it is a list of items to remove from list. the list is zero based.

Error Codes

Value | Meaning
9 | Index out of range for list.
14 | List of items to remove must be of type integer or long.
15 | List of items to remove contains duplicate data.
20 | Index to remove must be integer or long.

Examples

This example shows items being removed from list1, first by single index, and then by a list.

Visual Basic:

Dim list1 As New FCList
Dim list2 As New FCList

list1.AppendItem "a", "b", "c", "d", "e", "f", "g", "h", "i"
list1.RemoveByIndex 2

' list1 now contains "a", "b", "d", "e", "f", "g", "h", "i"

list2.AppendItem 3, 5, 0
list1.RemoveByIndex list2

' list1 now contains "b", "d", "f", "h", "i"


ReplaceByIndex | fcSDK Documentation

ReplaceByIndex

Object and Type

Object : FCList

Type : Method

Prototype

Public Sub ReplaceByIndex(ByRef index As Variant, ByRef item As Variant)

Description

This method replaces items in a list with the specified item. Index can be an integer or a list of integers. If index is an integer, only that item is replaced. If index is a list, the list is a list of integers specifying which items to replaced. Lists are zero based. This means the index to the first item is 0, the second is 1, etc.

Parameters

Parameter Name | Required? | Description
index | Yes | Integer or list of items to replace.
item | Yes | Item to substitute into the list.

Error Codes

Value | Meaning
4 | Cannot add an element of this type to a list. List contains data of a different type.
6 | Item of a type not supported.
9 | Index out of range for list.
10 | List for replace must be of type integer or long.
11 | Index for replace must be of type integer or long.

Examples

This example shows items being replaced in list1, first by single index, and then by a list.

Visual Basic:

Dim list1 As New FCList
Dim list2 As New FCList

list1.AppendItem "a", "b", "c", "d", "e", "f", "g", "h", "i"
list1.ReplaceByIndex 2, "x"

' list1 now contains "a", "b", "x", "d", "e", "f", "g", "h", "i"

list2.AppendItem 3, 5, 0
list1.ReplaceByIndex list2, "y"

' list1 now contains "y", "b", "x", "y", "e", "y", "g", "h", "i"


Sort | fcSDK Documentation

Sort

Object and Type

Object : FCList

Type : Method

Prototype

Public Sub Sort()

Description

This method sorts the list. After the list is sorted the Sorted property is set to true. Sort order is defined by the defined sort order on the machine this method is executed.

Example

This example shows the sorting of a simple list of characters.

Visual Basic:

Dim list1 As New FCList

list1.AppendItem "c", "f", "i", "a", "d", "g", "b", "e", "h"
list1.Sort

' list1 contains "a", "b", "c", "d", "e", "f", "g", "h", "i"


Up | fcSDK Documentation

Up

Object and Type

Object : FCList

Type : Method

Prototype

Public Sub Up(ByRef list As fc_List)

Description

This method swaps upward items in the list. It takes as it argument an integer list of indexes of the items to move. Indexes are zero based, so the first item in the list to be processed is 0 and the last item in the list is list.Count - 1. If items in index_list are neighbors in the list, they are moved as a group. The top item in the list can never be moved by this method. The movement is logical, in that the movement is done in the sorted order of the index list.

Parameters

Parameter Name | Required? | Description
list | Yes | List containing the indexes of the items in the processed list to move. Indexes are zero based.

Returns

The list with the appropriate items in the index list moved up.

Error Codes

Value | Meaning
9 | Index in index_list is out of range for the list.
16 | The index list contains duplicate indexes.
17 | Items in the index list must be integer.

Examples

This examples sets up list1 in order and list2 as a list of indexes of items to move up in list1. It then uses list2 to move up items in list1.

Visual Basic:

Dim list1 As New FCList
Dim list2 As New FCList

list1.AppendItem 1, 2, 3, 4, 5, 6, 7, 8, 9
list2.AppendItem 2, 3, 5
list1.Up list2

' List 1 now contains 1, 2, 4, 5, 3, 7, 6, 8, 9


AllowDuplicates | fcSDK Documentation

AllowDuplicates

Object and Type

Object : FCList

Type : Property

Prototype

Public AllowDuplicates    As Boolean

Description

This property tells whether to allow an item to be placed in a list if an item of that value already exists in the list. If this values is set to 'FALSE' such an insertion is not allowed. This property only prohibits the insertion. If the list has duplicate entries, you may still set this property with no effect on the current list. All lists are created with AllowDuplicates set to 'TRUE'.

Values

Value | Description
FALSE | Do not allow items to be inserted into the list if it already exists in the list.
TRUE | Allow items to be inserted into the list if it already exists in the list.

Example

The example shows the adding of duplicate data to a list with the AllowDuplicates property turned on and off. Notice in the last example that the duplicate data is still in list with AllowDuplicates set to FALSE.

Visual Basic:

  Dim list As New FCList

  list.AppendItem 2, 3, 4, 5
  ' list now has the numbers 2, 3, 4 and 5

  list.AllowDuplicates = FALSE
  list.AppendItem 2
  ' list still has the numbers 2, 3, 4 and 5 - duplicate 2 not added

  list.AllowDuplicates = TRUE
  list.AppendItem 2
  ' list has the numbers 2, 3, 4, 5 and 2

  list.AllowDuplicates = FALSE
  list.AppendItem 1
  ' list still has the numbers 2, 3, 4, 5, 2 and 1
  ' notice that the duplicate 2 is still in the list


AppendItem | fcSDK Documentation

AppendItem

Object and Type

Object : FCList

Type : Property

Prototype

Public Sub AppendItem(ByRef item1 As Variant, _
                      Optional ByRef item2 As Variant, _
                      Optional ByRef item3 As Variant, _
                      Optional ByRef item4 As Variant, _
                      Optional ByRef item5 As Variant, _
                      Optional ByRef item6 As Variant, _
                      Optional ByRef item7 As Variant, _
                      Optional ByRef item8 As Variant, _
                      Optional ByRef item9 As Variant)

Description

Append from one to nine items onto the list. Items are appended in order on the end of the list. Items must be all of the same type and they must match the types of items currently in the list.

Parameters

Parameter Name | Required? | Description
item1 | Yes | First item to append to the list.
item2 - item9 | No | Second through ninth item to append to the list.

Error codes

Value | Meaning
4 | Can not add item to list. List is of different type than item.
6 | Item to be added to the list is of a type not supported.

Examples

The example shows the simple creation of a list with AppendItem.

JavaScript:

var aList;
aList = new ActiveXObject("FCFL.fclist");
aList.AppendItem(2, 3, 4, 5);
aList.AppendItem(6, 2, 4, 12);

Visual Basic:

Dim list As New FCList

list.AppendItem 2, 3, 4, 5
' list now has the numbers 2, 3, 4 and 5

list.AppendItem 6, 2, 4, 12
' list now has the numbers 2, 3, 4, 5, 6, 2, 4, and  12


Count_(FCList)_ | fcSDK Documentation

Count_(FCList)_

Object and Type

Object : FCList

Type : Property

Prototype

Public Count    As Integer

Description

This property tells you how many items are stored in the list. This is a read only property. On new, cleared and empty lists, this property is 0.

Example

This example shows the creation of a list and the verification of the number of items in it.

Visual Basic:

Dim list As New FCList

list.AppendItem "x", "y", "z", "Q"

If list.Count = 4 Then
  MsgBox "List contains the right number of items"
Else
  MsgBox "List does not contain the right number of items"
End If


ItemType | fcSDK Documentation

ItemType

Object and Type

Object : FCList

Type : Property

Prototype

Public ItemType As String

Description

This property describes the type of data that can be stored in a list. When a list is created or cleared, this property has no value. At this point, it can be set to one of the allowed values. If not set, the value is set to the type of the type of the first data added to the list. All future data added to the list must be of this type. Once set, this property can only be reset by clearing the list.

Values

Value | Description
integer | List contains short (2 byte) integer data.
long | List contains long (4-byte) integer point data.
single | List contains small (4-byte) floating-point data.
string | List contains string data.
userdefinedtype | List contains data of a user defined data structure.
variant | List contains general untyped data.

Error Codes

Value | Meaning
0 | Cannot set property - invalid type.
1 | Cannot set property - already set.

Example

This is an example of implicitly setting the ItemType and checking its value.

Visual Basic:

Dim list As New FCList

list.AppendItem "data"

MsgBox "list.ItemType = '" & list.ItemType & "'"

' type = string

This is an example of setting the ItemType on a list, and then getting the error thrown adding wrong type data to the list.

Visual Basic:

Dim list As New FCList

On Error GoTo catch_it

list.ItemType = "integer"
list.AppendItem "data"

Exit Sub

catch_it:
MsgBox "Caught error '" & Err.Description & " (" & CStr(Err.Number) & ")'"


Sorted | fcSDK Documentation

Sorted

Object and Type

Object : FCList

Type : Property

Prototype

List.ItemType = Value

Value = List.ItemType

Description

This property tells if the list is in a sorted state. A sorted state occurs only when the Sort method is called. Not being in a sorted state does not mean the list is not sorted. It only means that it was not sorted by the Sort method.

Values

Value | Description
True | List is in a sorted state.
False | List is not in a sorted state.

Error Codes

Value | Meaning
3 | The 'Sorted' property of 'List' cannot be set at runtime.

Examples

This example shows the testing of the Sorted property before and after a Sort call.

Visual Basic:

Dim list As New FCList

MsgBox "list.Sorted = '" & list.Sorted & "'"

' sorted = False
list.AppendItem "c", "f", "i", "a", "d", "g", "b", "e", "h"
list.Sort

MsgBox "list.Sorted = '" & list.Sorted & "'" ' sorted = True


FCFL FCSession Object | fcSDK Documentation

FCFL FCSession Object

Overview

The FCSession represents a single user or contact connection to the database. In traditional applications, such as Visual Basic, there would be a single FCApplication object and a single FCSession object. In a web-based application, there would be a single FCApplication object, and multiple FCSession objects. Each browser connection to the web server would have its own FCSession object.

The FCSession object is used to manage individual information for each login.

You can use the FCSession object to:

  • Login and Logout
  • Create new FCGeneric, FCBulk, and FCSQLExec objects
  • Access information specific to the user or contact
  • Convert timestamps between different time zones

To create a new FCSession object, use the CreateSession method of the FCApplication object. The following are examples of how to create an FCSession object in both JavaScript and Visual Basic:

JavaScript:

var FCApp = Server.CreateObject("FCFL.fcapplication");

FCApp.Initialize();

var FCSession = FCApp.CreateSession();

Visual Basic:

Dim FCApp as FCApplication

Dim FCSession as FCSession

Set FCApp = CreateObject("FCFL.fcapplication")

FCApp.Initialize

Set FCSession = FCApp.CreateSession


AddAttachment | fcSDK Documentation

AddAttachment

Object and Type

Object : FCSession

Type : Method

Prototype

Public Function AddAttachment(ByVal attach_name As String, _
                              ByVal file_path As String, _
                              ByVal obj_type As String, _
                              ByVal obj_id As String, _
                              Optional ByVal obj_objid As Long = 0, _
                              Optional ByVal attach_type As Long = 0) As Integer

Description

This method is used to add an attachment to an object. The only objects allowed are those supported by Clarify. For a list of those objects, please see the Clarify documentation.

For an attachment to be added, you must supply the attachment name, the file path and name, the object type (table name), and either the ID number for the object (if it has one, and you know it), or the objid of the object. Only one of obj_id or obj_objid should be supplied.

The supported table names are:

  • bug
  • bus_org
  • campaign
  • case
  • communication
  • contact
  • contract
  • demand_hdr
  • diag_hint
  • eco_hdr
  • eco_dtl
  • email_log
  • interact
  • lead
  • lit_req
  • lit_ship_req
  • mod_level
  • opportunity
  • site
  • site_part
  • subcase
  • template
  • workaround

This method does NOT copy the file to a file system, or even validate the existence of the file. You must take care of the file details on your own. This API only adds the proper records for an attachment to Clarify.

Parameters

Parameter Name | Required? | Description
attach_name | Yes | The name of the attachment
file_path | Yes | The file path and name of the attachment
obj_type | Yes | The name of the database table to add the attachment to
obj_id | No | The ID number for the object to which to add the attachment. If it is not known, or the object doesn't have an ID number, this field is left blank
obj_objid | No | The objid of the object to which to add the attachment. This argument is only supplied if you wish to specify the object by objid. If you use the ID number, this argument does not have to be supplied
attach_type | No | Attachment Type - either 0 or 1 0 = Standard Attachments 1 = Attachments Anywhere Style Attachments

Error Codes

Value | Meaning
0 | No errors
1 | No attachment name specified
2 | No File/Path specified
3 | Invalid/unsupported object type supplied
4 | An ID number was supplied, but this object type does not have an ID number field
5 | Specified object was not found
6 | This object already has an attachment with the specified attachment name

Examples

The following example adds an attachment to case '42'.

Visual Basic:

  Dim ret_int As Integer

  ret_int = fc_session.AddAttachment("An attach", "c:\\tmp\\foo.doc", "case", "42")

The following example adds an attachment to a site_part with objid 268437142.

Visual Basic:

  Dim ret_int As Integer

  ret_int = fc_session.AddAttachment("SP attach", "c:\\docs\\sp.ppt", "site_part", "", 268437142)


CloseAllGenerics | fcSDK Documentation

CloseAllGenerics

Object and Type

Object : FCSession

Type : Method

Prototype

Public Sub CloseAllGenerics()

Description

This method closes and frees all resources and references for any and all of the generics associated with the current session. It does not matter what bulks the generics are located in, nor does it matter if the generics are open or closed.

This method also closes and frees up the memory associated with any (non-empty) bulk objects associated with the generics that are closed.

This method is called by FCSession.CloseSession. If you are calling the close session method, you do not need to call this method.

up to 10 FCGeneric objects.

Example

The following example closes all generic objects associated with an FCSession object

JavaScript:

FCSession.CloseAllGenerics();

Visual Basic:

FCSession.CloseAllGenerics


CloseGenerics | fcSDK Documentation

CloseGenerics

Object and Type

Object : FCSession

Type : Method

Prototype

Public Sub CloseGenerics(ByVal NumGenerics As Integer, _
                         ByRef Generic1 As FCGeneric, _
                         Optional ByRef Generic2 As FCGeneric, _
                         Optional ByRef Generic3 As FCGeneric, _
                         Optional ByRef Generic4 As FCGeneric, _
                         Optional ByRef Generic5 As FCGeneric, _
                         Optional ByRef Generic6 As FCGeneric, _
                         Optional ByRef Generic7 As FCGeneric, _
                         Optional ByRef Generic8 As FCGeneric, _
                         Optional ByRef Generic9 As FCGeneric, _
                         Optional ByRef Generic10 As FCGeneric)

Description

This method closes and frees all resources and references for up to 10 FCGeneric objects.

This method will check to see if the object has been created. If it hasn't, it ignores it. This allows you to use a standard cleanup procedure to close all of your Fcgeneric objects, even if they haven't yet been created using the CreateGeneric method.

Note: This method should be used in Visual Basic:

#### Parameters

| Parameter Name | Required? | Description |
|:--- |:--- |:--- |
| NumGenerics | Yes | The number of FCFeneric objects to be closed |
| Generic1 | Yes | The name of the FCGeneric Object to be closed |
| Generic2 | No | The name of the FCGeneric Object to be closed |
| Generic3 | No | The name of the FCGeneric Object to be closed |
| Generic4 | No | The name of the FCGeneric Object to be closed |
| Generic5 | No | The name of the FCGeneric Object to be closed |
| Generic6 | No | The name of the FCGeneric Object to be closed |
| Generic7 | No | The name of the FCGeneric Object to be closed |
| Generic8 | No | The name of the FCGeneric Object to be closed |
| Generic9 | No | The name of the FCGeneric Object to be closed |
| Generic10 | No | The name of the FCGeneric Object to be closed |

**Example**

The following example closes 3 FCGeneric Objects

**JavaScript:**

FCSession.CloseGenerics(3,boCase,boContact,boSite);

The following example closes 10 FCGeneric Objects before exiting a function.

**Visual Basic:**

If Not FCApp.RankIsInGbstLst("Activity Name", stat_code) Then 'Cleanup, Error, & Exit CloseGenerics 10, obj_rec, old_stat_rec, user_rec, emp_rec, _ parent_rec, stat_lst_rec, cond_rec, tb_rec, _ act_rec, stat_rec Err.Raise -5, ObjectName, _ "Cannot find the activity string with rank = " & stat_code Exit Function End If


Change__Password | fcSDK Documentation

Change__Password

Object and Type

Object : FCSession

Type : Method

Prototype

Public Sub ChangePassword(ByVal password As String)

Description

This method changes the password for the session user, which may either be a contact or a user. You may not use this method to change the password for the "sa" user.

Parameters

Parameter Name | Required? | Description
password | Yes | The new password

Error Codes

Value | Meaning
11005 | Not logged in to an active session
11017 | System administrators cannot change their password using this method.

Examples

The following example changes the current user's password.

JavaScript:

FCSession.ChangePassword("new_password");


ChangeResGroup | fcSDK Documentation

ChangeResGroup

Object and Type

Object : FCSession

Type : Method

Prototype

Public Sub ChangeResGroup(new_group As String, _
                          Optional SaveToDB As Boolean)

Description

This method changes the restriction group for the session user. The first argument must be a valid restriction group that the user belongs to. You may choose to have the restrictions only apply to the local session, or to change the active restriction group for the user in the database (which will apply to future sessions) with the 2nd argument.

Parameters

Parameter Name | Required? | Description
new_group | Yes | The name of the new restriction group
SaveToDB | No | Should the change be saved to the database? If left out, the value used is "False"

Error Codes

Value | Meaning
11009 | This database is not Data Restriction enabled
11010 | The supplied restriction group does not exist, or is not valid for the current user
11014 | You may not set restrictions for contacts

Examples

The following example changes the user's restriction group, and writes the change to the database.

JavaScript:

FCSession.ChangeResGroup("AOL", true);


CloseSession | fcSDK Documentation

CloseSession

Object and Type

Object : FCSession

Type : Method

Prototype

Public Sub CloseSession()

Description

This method frees all resources and references to the FCSession object.

Example

The following example logs out and frees the FCSession resources.

JavaScript:

FCSession.Logout();
FCSession.CloseSession();
FCSession = null;


CommitTransaction | fcSDK Documentation

CommitTransaction

Object and Type

Object : FCSession

Type : Method

Prototype

Public Function CommitTransaction()

Description

After calling StartTransaction() this method is called when all database operations for this trasaction are complete.

Example

Please see Developer Walkthrough - Transaction support


ConvertDate | fcSDK Documentation

ConvertDate

Object and Type

Object : FCSession

Type : Method

Prototype

Public Function ConvertDate(ByVal TheDate As Date, ByVal FromTimeZone As String, ByVal ToTimeZone As String) As Date

Description

This property converts a date/time value from one time zone to another. It uses the time_zone table date to determine offsets from GMT, and it uses the daylight_hr table to determine if the timestamp is on daylight savings time (DST) in either time zone.

Parameters

Parameter Name | Required? | Description
TheDate | Yes | The timestamp (date and time) to be converted
FromZone | Yes | The name of the time zone that the date will be converted from.
TomeZone | Yes | The name of the time zone that the date will be converted
to |  |

Returns

A date/time value converted between time zones.

Error Codes

Value | Meaning
11007 | Invalid time_zone.
11008 | Invalid Date/Time.

Examples

The following example converts a timestamp from one time zone to another.

JavaScript:

<%
  var TZ1 = "Central Standard Time"
  var TZ2 = "Eastern Standard Time"
  var CurrDate = FCSession.GetCurrentDate();
  var NewDate = FCSession.ConvertDate(CurrDate, TZ1, TZ2);
%>

If it is <%=CurrDate%> in <%=TZ1%>, then
it is <%=NewDate%> in <%=TZ2%>.


ConvertFromLocalToServerTZ | fcSDK Documentation

ConvertFromLocalToServerTZ

Object and Type

Object : FCSession

Type : Method

Prototype

Public Function ConvertFromLocalToServerTZ(ByVal TheDate As Date) As Date

Description

This property converts a date/time value from the local time zone to the server time zone. The local time zone is the time zone of the FCSession (FCSession.LocalTimeZone), and the server time zone is the server time zone of the FCApplication (FCApplication.ServerTimeZone). It uses the time_zone table date to determine offsets from GMT, and it uses the daylight_hr table to determine if the timestamp is on daylight savings time (DST) in either time zone.

Parameters

Parameter Name | Required? | Description
TheDate | Yes | The timestamp (date and time) to be converted

Returns

A date/time value converted from the local time zone to the server time zone.

Error Codes

Value | Meaning
11008 | Invalid Date/Time.

Examples

The following example converts a timestamp from the local time zone to the server time zone.

JavaScript:

<%
    var CurrDate = FCSession.GetCurrentDate();
    var NewDate = FCSession.ConvertFromLocalToServerTZ(CurrDate);
%>

The Server Time Zone is <%=FCApp.ServerTimeZone%>.<BR>
The Local Time Zone = <%=FCSession.LocalTimeZone%>.<BR>
If it is <%=CurrDate%> in <%=FCSession.LocalTimeZone%>, then
it is <%=NewDate%> in <%=FCApp.ServerTimeZone%>.


ConvertFromServerToLocalTZ | fcSDK Documentation

ConvertFromServerToLocalTZ

Object and Type

Object : FCSession

Type : Method

Prototype

Public Function ConvertFromServerToLocalTZ(ByVal TheDate As Date) As Date

Description

This property converts a date/time value from the server time zone to the local time zone. The local time zone is the time zone of the FCSession (FCSession.LocalTimeZone), and the server time zone is the server time zone of the FCApplication (FCApplication.ServerTimeZone). It uses the time_zone table date to determine offsets from GMT, and it uses the daylight_hr table to determine if the timestamp is on daylight savings time (DST) in either time zone.

Parameters

Parameter Name | Required? | Description
TheDate | Yes | The timestamp (date and time) to be converted

Returns

A date/time value converted from the local time zone to the server time zone.

Error Codes

Value | Meaning
11008 | Invalid Date/Time.

Examples

The following example converts a timestamp from the server time zone to the local time zone.

JavaScript:

<%
    var CurrDate = FCSession.GetCurrentDate();
    var NewDate = FCSession.ConvertFromServerToLocalTZ(CurrDate);
%>

The Server Time Zone is <%=FCApp.ServerTimeZone%>.<BR>
The Local Time Zone = <%=FCSession.LocalTimeZone%>.<BR>
If it is <%=CurrDate%> in <%=FCApp.ServerTimeZone%>, then
it is <%=NewDate%> in <%=FCSession.LocalTimeZone%>.


CreateBulk | fcSDK Documentation

CreateBulk

Object and Type

Object : FCSession

Type : Method

Prototype

Public Function CreateBulk(bulk_name As String) As FCBulk

Returns

A new FCBulk object, or a reference to the existing bulk with the given name.

Description

This method creates a new FCBulk object. It is passed the name of a bulk object, and creates and initializes the bulk. In common applications you will never need to execute this method, as it is called automatically when you set the name of the bulk on a generic object.

Parameters

Parameter Name | Required? | Description
BulkName | Yes | Name of the bulk to create


CreateGeneric | fcSDK Documentation

CreateGeneric

Object and Type

Object : FCSession

Type : Method

Prototype

Public Function CreateGeneric() As FCGeneric

Description

This method creates and initializes a new FCGeneric object. It is THE ONLY way that generic objects should be created. Do not do the following: Dim boCase As New FCGeneric ' BAD!!!!!!

The above code would create a new generic object, but would not properly initialize it. Instead, simply Dim the variable as FCGeneric (no NEW keyword), and create it with this method.

Returns

A new FCGeneric object, properly initialized.

Example

The following example creates two new generic objects. One is on the case table, and one is on the site table.

JavaScript:

// Create the case object, and site object.
  var boCase = FCSession.CreateGeneric();
  boCase.SimpleQuery("case");

  var boSite = FCSession.CreateGeneric();
  boSite.SimpleQuery("site");

The following example simply creates a new FCApplication object and a new FCSession object.

Visual Basic:

  Dim boCase As FCGeneric
  Dim boSite As FCGeneric

  Set boCase = fc_session.CreateGeneric
  boCase.SimpleQuery "case"

  Set boSite = fc_session.CreateGeneric
  boSite.SimpleQuery "site"


CreateSqlExec | fcSDK Documentation

CreateSqlExec

Object and Type

Object : FCSession

Type : Method

Prototype

Public Function CreateSqlExec() As FCSqlExec

Description

This method creates and initializes a new FCSqlExec object. The default object that is created uses the existing database connection (that you referenced in your fc.env file). If you wish to query an external database, you must use the OpenConnection method.

Returns

A new FCSqlExec object, properly initialized.

Example

The following example demonstrates opening an external connection, executing SQL against it, and closing the connection.

JavaScript:

  // Create an external DB connection
  // Log in

  var SqlDB = FCSession.CreateSQLExec();
  SqlDB.OpenConnection("sql", "sa", "sa", "gaffer", "cl10");

  // Query for a simple table (with one column)
  // Iterate through it and print out the data

  SqlDB.ExecuteReturnRows("select * from foo");

  while (SqlDB.Records.EOF != true)
  {
    Response.Write ("Value: " + SqlDB.Records("out_col"));
    SqlDB.Records.MoveNext();
  }

  // Now add a row, and close the connection
  SqlDB.Execute("insert into foo values (55)");
  SqlDB.CloseConnection();

Visual Basic:

  Dim sql_db As FCSqlExec
  Set sql_db = fc_session.CreateSqlExec
  sql_db.OpenConnection "sql", "sa", "sa", "gaffer", "cl10"
  sql_db.ExecuteReturnRows "select * from foo"
  sql_db.records.MoveFirst

  While sql_db.records.EOF = False
    MsgBox sql_db.records("out_col")
    sql_db.records.MoveNext
  Wend

  sql_db.Execute "insert into foo values (44)"
  sql_db.CloseConnection


GetColor | fcSDK Documentation

GetColor

Object and Type

Object : FCSession

Type : Method

Prototype

Public Function GetColor(purpose As String) As String

Description

This method returns the color that a user should use for a specific purpose. These colors are loaded into FCFL via the LoadColors method.

The color returned will be one of three values:

If the user has specified (via the provided GUI) a personal choice for the color for the purpose, that color will be returned,

If the user has not specified a personal choice for the color, the default color for that purpose will be returned,

If no default has been specified for that purpose, "White" will be returned

Parameters

Parameter Name | Required? | Description
purpose | Yes | The purpose that this color is used for

Returns

One of the three string values listed above.

Example

This example shows the loading of colors for the current user. It then prints out the user's color for a specific purpose.

Visual Basic:

fc_session.LoadColors fc_session.item("user.login_name")

MsgBox fc_session.GetColor("Interaction History - Case")


GetConfigItem | fcSDK Documentation

GetConfigItem

Object and Type

Object : FCSession

Type : Method

Prototype

Public Function GetConfigItem(ByVal ConfigItem As String,
                              ByVal FieldName As String,
                              Optional ByVal LoginName As String = "")
                              As Variant

Description

This method returns a configuration item from the database. You must specify the name of the configuration item, along with the particular field you wish to retrieve. The field name should be a valid field in the config_itm table. In addition, you can optionally specify the login name of user, thus allowing retrieval of user-defined configuration items. You can also retrieve system wide configuration data using the Item method.

Parameters

Parameter Name | Required? | Description
ConfigItem | Yes | The name of the configuration item
FieldName | Yes | A valid field name in the config_itm table
LoginName | No | An optional parameter that is a valid login_name in the user table.

Returns

The value of the field for the configuration item. If the configuration item is not found, or not found for the defined user, then an empty string is returned. |

Error Codes

Value | Meaning
11005 | Not logged in to an active session

Examples

The following example retrieves a system-wide and a user configuration item.

JavaScript:

i_value for the config_itm "password specification" =

<%=FCSession.GetConfigItem("password specification","i_value")%> <BR>

'Win Help File' config_itm for user 'sa' =

 <%=FCSession.GetConfigItem("Win Help File","str_value","sa")%> <BR>


GetCurrentDate | fcSDK Documentation

GetCurrentDate

Object and Type

Object : FCSession

Type : Method

Prototype

Public Function GetCurrentDate() As Date

Description

This method returns the current local time zone date and time.

Returns

This method returns the current date and time in the local time zone.

Example

The following example displays the current local time.

JavaScript:

Response.Write("<BR>current session time = " + FCSession.GetCurrentDate());


GetCurrentServerDate | fcSDK Documentation

GetCurrentServerDate

Object and Type

Object : FCSession

Type : Method

Prototype

Public Function GetCurrentDate() As Date

Description

This method returns the current server time zone-based date and time.

Returns

This method returns the current server time zone-based date and time.

Example

The following example displays the current server time.

JavaScript:

Response.Write("<BR>current server time = " + FCSession.GetCurrentServerDate());


GetItem | fcSDK Documentation

GetItem

Object and Type

Object : FCSession

Type : Method

Prototype

Public Function GetItem(path_str As String, _
                     start_item As Integer, _
                     stop_item As Integer, _
                     separator As String) As String

Description

Returns all the items between first and last within the specified formatted text list. This provides the same functionality as the ClearBasic Item$ function.

Parameters

Parameter Name | Required? | Description
path_str | Yes | String containing the text from which a range of items is returned.
start_item | Yes | Integer containing the index of the first item to be returned. If first is greater than the number of items in text$, then a zero-length string is returned.
stop_item | Yes | Integer containing the index of the last item to be returned. All of the items between first and last are returned. If last is greater than the number of items in text$, then all items from first to the end of text are returned.
seperator | Yes | String containing different item delimiters.

Example

The following example creates 2 delimited lists, and then extracts a range from each.

JavaScript:

var ilist = "1,2,3,4,5,6,7,8,9,10,11,12,13,14,15";
var slist = "1/2/3/4/5/6/7/8/9/10/11/12/13/14/15";
var list1 = FCSession.GetItem(ilist,5,12,",");
var list2 = FCSession.GetItem(slist,2,9,"/");
var ilist4 = FCSession.GetItem(ilist,4,4,",");

The results of this would be:

list1  = 5,6,7,8,9,10,11,12

list2 = 2/3/4/5/6/7/8/9

ilist4 = 4


GetNextNumScheme | fcSDK Documentation

GetNextNumScheme

Object and Type

Object : FCSession

Type : Method

Prototype

Public Function GetNextNumScheme(ByVal NumSchemeName As String) As String

Description

This method is returns the next ID in the specified numbering scheme.

Parameters

Parameter Name | Required? | Description
NumSchemeName | Yes | The name of the numbering scheme

Returns

A string that is the the next ID in the specified numbering scheme.

Error Codes

Value | Meaning
11016 | Numbering Scheme Name must not be empty
11015 | Invalid Numbering Scheme

Examples

The following example sets the next ID number for a new case.

JavaScript:

var boCase = FCSession.CreateGeneric();
boCase.DBObjectName = "case";
boCase.AddNew();

boCase("id_number") = FCSession.GetNextNumScheme("Case ID");


GetNextSubcaseID | fcSDK Documentation

GetNextSubcaseID

Object and Type

Object : FCSession

Type : Method

Prototype

Public Function GetNextNumSubcaseID(ByVal CaseID As String, ByVal
                                    CaseCondID As Long) As String

Description

This method is returns the next available ID number for a subcase for the given case.

Parameters

Parameter Name | Required? | Description
CaseID | Yes | The ID Number of the case
CaseCondID | Yes | The objid of the condition record for the case

Returns

A string that is the the next available ID number for a subcase of the case.

Example

The following example gets the next ID number for a subcase of a previously-found case.

VisualBasic:

Dim boCase As FCGeneric
Dim sub_id As String

Set boCase = fc_session.CreateGeneric
boCase.SimpleQuery "case"
boCase.AppendFilter "id_number", "=", "44"
boCase.Query

sub_id = fc_session.GetNextSubcaseID(boCase("id_number"),
boCase("case_state2condition"))


GetUserVersion | fcSDK Documentation

GetUserVersion

Object and Type

Object : FCSession

Type : Method

Prototype

Public Function GetUserVersion(formName As String) As String

Description

This method returns the user version in the current user's resource configuration for the web form name passed in to the method. The resource configuration data is loaded into FCFL via the LoadUserVersions method. If the resource configuration contains a custom version of the supplied form name, the user version is returned, with slashes on either side of the version. For example, "/1.0/". If no custom version of the web form is present in the resource configuration, a slash "/" is returned. If user versions have not been loaded (with the LoadUserVersions method), a slash is also returned.

Parameters

Parameter Name | Required? | Description
formName | Yes | The web form name to locate in the current resource configuration to determine if there is a custom version used

Returns

One of the two strings detailed above.

Example

This example shows the loading of user versions for the current user. It then prints out the resource configuration's custom version (if any) for the "SITE" web form.

Visual Basic:

fc_session.LoadUserVerions
MsgBox fc_session.GetUserVersion("SITE")


IsUnicode | fcSDK Documentation

IsUnicode

Object and Type

Object : FCSession

Type : Method

Prototype

Public Function IsUnicode(in_str As String) As Boolean

Description

This method determines if a supplied string is a unicode (wide varchar) string. If it is (it contains at least one Unicode character), the function returns True. Otherwise it returns False.

Parameters

Parameter Name | Required? | Description
in_str | Yes | The string to test

Returns

A boolean value indicating if the input string contains any Unicode characters.

Example

The following example checks if a given time zone is valid for the given country using the (short) name of the time zone.

JavaScript:

var isUnicode = FCSession.IsUnicode(strString);
          // Only write the data to the string field if
          //  it is not Unicode If (!isUnicode)
{
   boString("string") = strString;
}


ItemCount | fcSDK Documentation

ItemCount

Object and Type

Object : FCSession

Type : Method

Prototype

Public Function ItemCount(path_str As String, separator As String) As Integer

Description

Returns an Integer containing the number of items in the specified delimited text. This provides the same functionality as the ClearBasic ItemCount function.

Parameters

Parameter Name | Required? | Description
path_str | Yes | String containing the text from which a range of items is returned.
seperator | Yes | String containing different item delimiters.

Example

The following example creates 2 delimited lists, and then counts the items in each.

JavaScript:

var ilist = "1,2,3,4,5,6,7,8,9,10,11,12,13,14,15";
var slist = "1/2/3/4/5/6/7/8/9/10/11/12/13/14/15/16";
var ilistCount = FCSession.ItemCount(ilist,",");
var slistCount = FCSession.ItemCount(slist,"/");

The results of this would be:

ilistCount = 15

slistCount = 16


LoadColors | fcSDK Documentation

LoadColors

Object and Type

Object : FCSession

Type : Method

Prototype

Public Sub LoadColors(user_name As String)

Description

This method reads the colors, for the specified user, from the database, and stores them in a memory cache for fast access. Colors are read from the cache with the GetColor method.

When you call this method, one color is found for each color purpose defined. If the user has specified a color that they wish to use, that color is loaded. If the user has not specified a color, the default (defined by the administrator) is used instead. If no colors are defined, the color (white, since these are background colors usually) is loaded.

This method is optional. You do not have to call on it in your FCFL programs. If you are writing a program (such as a command-line processor), you will not use colors and you do not need to call on this method. In this case, no colors are loaded, and any calls to the GetColor method will return "White". If you ever change (manually) a color in the database (in table_fc_color), you should call on this method again to recache the data. The provided GUI forms (in fcAdmin and fcClient) do this for you automatically.

Note: The fcClient program calls on this method for you so that colors are available in the thin client. You do not need to add it to your forms in the thin client.

Parameters

Parameter Name | Required? | Description
user_name | Yes | The name of the user for whom colors should be loaded into this session.

Example

This example shows the loading of colors for the current user. It then prints out the user's color for a specific purpose.

Visual Basic:

fc_session.LoadColors fc_session.item("user.login_name")

MsgBox fc_session.GetColor("Interaction History - Case")


LoadUserVersions | fcSDK Documentation

LoadUserVersions

Object and Type

Object : FCSession

Type : Method

Prototype

Public Sub LoadUserVersions(Optional user_name As String)

Description

This method reads the user version and resource configuration from the database, and stores them in a memory cache for fast access. User versions are read from the cache with the GetUserVersion and BuildUserVersionProc methods.

When you call this method, the database is searched for the user's current resource configuration. The routine then determines, for each web form type, if the user's resource configuration has a custom version of that web form in the resource config, or if the baseline version of the form should be used.

This method is optional. You do not have to call on it in your FCFL programs. If you are writing a program (such as a command-line processor), you will not use user versions of web forms, and you do not need to call on this method. In this case, no user versions are loaded, and any calls to the GetUserVersion method will return "".

You should use the supplied GUI in fcAdmin to modify web forms, web user versions, and resource configurations.

Note: The fcClient program calls on this method for you so that user versions are available in the thin client. You do not need to add it to your forms in the thin client.

Parameters

Parameter Name | Required? | Description
user_name | No | The name of the user for whom user version/resource configuration should be loaded into this session.

Example

This example shows the loading of user versions for the current user. It then prints out the user version of the "CASE" form.

Visual Basic:

fc_session.LoadUserVersions

MsgBox fc_session.GetUserVersion("CASE")


Log(FCSession) | fcSDK Documentation

Log(FCSession)

Object and Type

Object : FCSession

Type : Method

Prototype

Public Sub Log(TheMessageType As String, TheMessage As String)

Description

This method allows you to log a message to the FCFL log file. In addition to the message, the SessionId will also be logged. FCSession logging must be turned on for this message to actually be logged to the file.

Parameters

Parameter Name | Required? | Description
TheMessageType | Yes | The type of message, used to identify your message within the log file.
TheMessage | Yes | The message to be logged.

Example

The following example logs a message to the log file.

Visual Basic:

fc_session.Log "My Company", "This is a test message"

JavaScript:

fc_session.Log("My Company", "This is a test message");

Here is an example of what the entry will look like in the log file:

10/27/2003 11:59:12 AM : My Company

This is a test message

SessionID = fcclient_2


LogEx(FCSession) | fcSDK Documentation

LogEx(FCSession)

Object and Type

Object : FCSession

Type : Method

Prototype

Public Sub LogEx(logLevel as String, logMessage As String)

Description

Alternate logging method that allows setting the log level. This method is similar to Logger.Log except that the log level is a string representation of the LogLevel enumeration (e.g "DEBUG", "INFO", "ERROR").

Parameters

Parameter Name | Required? | Description
logLevel | Yes | A string representation of the LogLevel enumeration (e.g "DEBUG", "INFO", "ERROR").
logMessage | Yes | The message to be logged.

Example

The following example logs a DEBUG message to the log file.

Visual Basic:

fc_app.LogEx "DEBUG", "This is a test debug message"

JavaScript:

fc_app.LogEx("DEBUG", "This is a test debug message");

Here is an example of what the entry will look like in the log file:

2004-11-15 14:21:31,469 \[DEBUG\] This is a test debug message.

Note, the log output can be easily modified by changing your Logging Configuration


Login | fcSDK Documentation

Login

Object and Type

Object : FCSession

Type : Method

Prototype

Public Sub Login(LoginName As String, password As String, TheLoginType As String)

Description

This method validates the login name and password for either a contact or a user/employee.for contacts, the login_name is validated against the login_name field on the web_user table, and the password is validated against the passwordf field in the web_user table. The web_user record is related to the contact record via the relation web_user2contact. This is the same validation that is done in Clarify web-based products, such as ClearExpress WebSupport and eSupport.for users/employees, the login_name and password are validated against the database - similar to the Clarify Classic Client. If the login attempt is successful, the following happens:

  • The Item collection data is setup
  • If using Data Restriction, the data restrictions for the user are setup
  • If using Oracle, the NLS_DATE_FORMAT for the session is set to 'MM/DD/YYYY HH:MI:SS AM'

Note: You can use the PasswordRequired property on the FCSession to bypass password validation. Please see that method's documentation for more information.

Parameters

Parameter Name | Required? | Description
LoginName | Yes | The login name
Password | Yes | The password
LoginType | Yes | The login type - either "user" or "contact"

Error Codes

Value | Meaning
11003 | Already Logged In.
11013 | You must supply a login name.
11011 | Invalid login type.
11012 | Could not login.

Examples

The following example attempts to login as a contact using data from a posted web page.

JavaScript:

var FCApp;
var FCSession;
var strUserName = Request.Form("username").Item;
var strPassword = Request.Form("password").Item;

//Create a session using the Global FCApp
 FCApp = Application.Contents("FCApp");
 FCSession = FCApp.CreateSession();

//Set Locale on The IIS Session
  SetLCID();

//Login as a contact
  var LogonOK = true; | try | {
    FCSession.Login(strUserName,strPassword,"contact")
  }
  catch(e)
  {
    Response.Write("<BR><B>Logon Error:</B><BR>");
    Response.Write("<B>" + e.description + "</B><BR>");
    var LogonOK = false;
  }


LoginFromFCApp | fcSDK Documentation

LoginFromFCApp

Object and Type

Object : FCSession

Type : Method

Prototype

Public Sub LoginFromFCApp())

Description

This method allows you to login to a FCSession as a user using the same login_name and password that you used when logging into the FCApplication object. The login_name and password will be the same one you defined in either your fc.env file, or in the InitializeFull method. The LoginType for this type of login is always "user". The same processing happens as the normal Login method, except that you do not need to supply any parameters.

Please refer to the documentation for the Login method for more details.

Error Codes

Value | Meaning
11003 | Already Logged In.

Examples

The following example attempts to login as a user using the same user as the FCApplication.

Visual Basic:

Dim fc_session As FCSession

Set fc_session = fc_app.CreateSession

fc_session.LoginFromFCApp

MsgBox (fc_session.item("user.login_name"))


Logout | fcSDK Documentation

Logout

Object and Type

Object : FCSession

Type : Method

Prototype

Public Sub Logout()

Description

This method logs out the currently logged-in FCSession. The Item collection is also cleared out. After calling the Logout method, you should also call the CloseSession method. This will ensure that all system resources from this FCSession are freed.

Example

The following example logs out the current FCSession.

JavaScript:

FCSession.Logout();
FCSession.CloseSession();
FCSession = null;


NewEnum(FCSession) | fcSDK Documentation

NewEnum(FCSession)

Object and Type

Object : FCSession

Type : Method

Description

Within the FCSession object, there is a method available for enumerating the available FCBulk objects.

Within the FCBulk object, there is a method available for enumerating the available FCGeneric objects.

Using these enumerators gives you access to all of the available FCBulk and FCGeneric objects.

Example

The following example demonstrates looping through and showing details about each FCBulk and each FCGeneric object.

JavaScript:

Response.Write('Open FCBulks and FCGenerics:');
for(var objEnum = new Enumerator(FCSession);
   !objEnum.atEnd(); objEnum.moveNext()) {
       bulk = objEnum.item();
       Response.Write('<br>FCBulk Name="' + bulk.name + '"');
       for(var objEnum2 = new Enumerator(bulk);
          !objEnum2.atEnd(); objEnum2.moveNext()) {
              gen = objEnum2.item();
              Response.Write('<br>&bull;DB Object Type=' +
                             gen.dbobjectname);
       }
}

Visual Basic:

For Each Bulk In fc_session
  Debug.Print "Bulk Name = " + Bulk.Name
  For Each Generic In Bulk
    Debug.Print "Generic DB Object Type = " + Generic.DbObjectName
  Next Generic
Next Bulk


RefreshContext | fcSDK Documentation

RefreshContext

Object and Type

Object : FCSession

Type : Method

Prototype

Public Sub RefreshContext()

Description

This method refreshes the Item data collection for the FCSession. If any of the contact or user data is updated, the RefreshContext method should be called in order to update the data in the Item collection.

Example

The following example updates the contact information and refreshes the context.

JavaScript:

Contact Phone Number Before = <%=FCSession.Item("contact.phone")%><BR>

<%
var boContact = FCSession.CreateGeneric();
boContact.DBObjectName = "contact";
boContact.AppendFilter("objid", "=", "268435457");
boContact.Query();

boContact("objid") = FCSession.Item("contact.id");
boContact("phone") = "512-418-2905";
boContact.Update();

FCSession.RefreshContext();
%>

Contact Phone Number After = <%=FCSession.Item("contact.phone")%><BR>


RemoveAllGenericsInABulk | fcSDK Documentation

RemoveAllGenericsInABulk

Object and Type

Object : FCSession

Type : Method

Prototype

Public Sub RemoveAllGenericsInABulk(BulkName As String)

Parameters

Parameter Name | Required? | Description
BulkName | Yes | Name of the bulk to clear out

Description

This method removes (and closes) all generics in a Bulk object that you identify by name. This is useful if you don't remember which generics are in the Bulk object. If the Bulk is not the empty bulk, this method will also close and reclaim the memory for the bulk.

Example

This example removes all items from a Bulk.

Visual Basic:

fc_session.RemoveAllGenericsInABulk "MyBulk"


RollbackTransaction | fcSDK Documentation

RollbackTransaction

Object and Type

Object : FCSession

Type : Method

Prototype

Public Function RollbackTransaction()

Description

If StartTransaction() has previously been called. This method needs to be called if for some reason the transaction cannot be committed.

A rollback is necessary when an exception occurs during the lifetime of the transaction or some condition such that it is desired to return the database back to its pre-transaction state.

Care should be made when using database transactions to make sure all possible paths of code protect for thrown exceptions to avoid leaving an uncompleted transactions hanging around.

Example

Please see Developer Walkthrough - Transaction support


SetPassword | fcSDK Documentation

SetPassword

Object and Type

Object : FCSession

Type : Method

Prototype

Public Sub SetPassword(ByVal LoginName As String, ByVal Password As String, ByVal LoginType As String)

Description

This method changes the password for a given user or contact. You may not use this method to change the password for the "sa" user. When setting the password for a contact, the password is changed in the web_user table. When setting the password for a user, the password is changed at the database level, so the current session user must have the correct database permissions to execute these commands (sp_password on SQL Server, alter user on Oracle). If the user does not have these permissions, an error will be thrown.

Parameters

Parameter Name | Required? | Description
LoginName | Yes | The user or web_user login_name
Password | Yes | The new password
LoginType | Yes | The login type - either "user" or "contact"

Error Codes

Value | Meaning
11005 | Not logged in to an active session
11011 | Invalid LoginType
11017 | System administrators cannot change their password using this method.
11019 | Could not find user/contact with given login name.

Examples

The following example changes password for a user.

JavaScript:

//Get the Posted Data
var strLoginName    = Request.QueryString('login_name').Item;
var strPassword     = Request.QueryString('password').Item;

//Update the User Password
FCSession.SetPassword(strLoginName,strPassword,"user");


StartTransaction | fcSDK Documentation

StartTransaction

Object and Type

Object : FCSession

Type : Method

Prototype

Public Function StartTransaction(Optional ByVal IsolationLevel As String)

Description

Call this method when it is desired to have FCGeneric updates and queries be under the context of a transaction. When all database operations for the transaction are complete, call CommitTransaction. Care should be taken using exception handling to invoke RollbackTransaction in the case of an error.

Valid IsolationLevel parameter strings match the .Net Framework Isolation Level Enumeration

Parameters

Parameter Name | Required? | Description
isolationLevel | No | An optional parameter for controlling the Isolation Level of the transation.

Example

Please see Developer Walkthrough - Transaction support


Distinct(FCSession) | fcSDK Documentation

Distinct(FCSession)

Object and Type

Object : FCSession

Type : Property

Prototype

Public Distinct  As Boolean

Description

This property tells the session if all generic objects in that session should set the Distinct property for ) by default. Whatever value is set in this property (which is False initially) is passed to each generic when that generic is created.

The generic object can override the value passed in from the session by setting the Distinct property on the generic object after it is created.

For more details on what the Distinct property does, please see the Distinct documentation for the FCGeneric object above.

Example

The following example demonstrates setting the Distinct property for a new object.

JavaScript:

  // Set all generics to distinct
  Distinct  = true;

Visual Basic:

  Distinct  = True


IncludeRelations(FCSession) | fcSDK Documentation

IncludeRelations(FCSession)

Object and Type

Object : FCSession

Type : Property

Prototype

Public IncludeRelations As Boolean

Description

This property tells the session if all generic objects in that session should include relations by default. Whatever value is set in this property (which is False initially) is passed to each generic when that generic is created.

The generic object can override the value passed in from the session by setting the IncludeRelations property on the generic object after it is created.

For more details on what the IncludeRelations property does, please see the IncludeRelations documentation for the FCGeneric object above.

Example

The following example demonstrates setting the IncludeRelations property for a new object.

JavaScript:

  // Include all relations for the session
  IncludeRelations = true;

Visual Basic:

  IncludeRelations = True


Item | fcSDK Documentation

Item

Object and Type

Object : FCSession

Type : Property

Prototype

Public Property Get Item(TheItem As String) As Variant

Description

The Item property allows access to a collection of data stored in the FCSession object.

Parameters

Parameter Name | Required? | Description
TheItem | Yes | The item to be retrieved.

Returns

The set of data available in the collection is dependent on the LoginType used in the Login method.

The following items are always available:

Item | Type | Comments
session.login_type | String | The LoginType used in the Login method
session.login_name | String | The LoginName used in the Login method
config_itm.<name>.value_type | Integer | The Internal flag setting. Use depends on individual config_itm
config_itm.<name>.i_value | Integer | A quantity which sets behavior of the application
config_itm.<name>.f_value | Float | A quantity which sets behavior of the application
config_itm.<name>.str_value | String | A quantity which sets behavior of the application

The following items are available when the LoginType = "user"

Item | Type | Comments
employee.id | Long | Objid of employee
employee.first_name | String | First name of Employee
employee.last_name | String | Last Name of Employee
employee.phone | String | Phone Number of Employee
employee.site.id | Long | Objid of Employee's site
employee.site.site_id | String | Site ID of Employee's site
employee.site.name | String | Name of Employee's site
employee.site.type | String | Type of Employee's site
employee.address.address | String | Address of Employee's site
employee.address.city | String | City of Employee's site
employee.address.state | String | State of Employee's site
employee.address.zipcode | String | Zipcode of Employee's site
employee.country.name | String | Country of Employee's site
user.login_name | String | Login Name of User
user.locale | Integer | Locale of User
user.agentid | String | Agent ID of User
user.status | Integer | Status of User
wipbin.title | String | Title of User's Default Wipbin
user.id | Long | Objid of User
wipbin.id | Long | Objid of User's Default Wipbin
privclass.id | Long | Objid of user's privilege class
privclass.name | String | Name of user's privilege class

The following items are available when the LoginType = "contact"

Item | Type | Comments
contact.id | Long | Objid of Contact
contact.first_name | String | First Name of Contact
contact.last_name | String | Last Name of Contact
contact.email | String | Email of Contact
contact.phone | String | Phone of Contact
contact.fax | String | Fax of Contact
contact.site.id | Long | Objid of Contact's Primary Site
contact.site.site_id | String | Site ID of Contact's Primary Site
contact.site.name | String | Name of Contact's Primary Site
contact.site.type | String | Type of Contact's Primary Site
contact.title | String | Title of the contact
contact.address.address | String | Address of Contact's Primary Site
contact.address.address2 | String | Address2 of Contact's Primary Site
contact.address.city | String | City of Contact's Primary Site
contact.address.state | String | State of Contact's Primary Site
contact.address.zipcode | String | Zipcode of Contact's Primary Site
contact.country.name | String | Country Name of Contact's Primary Site

Error Codes

Value | Meaning
11001 | Field given is not a valid field for config_itm.
11002 | Item not found.

Examples

The following examples displays the name of either the user or the contact depending on the login type.

JavaScript:

<% if (FCSession.Item("session.login_type") == "contact") { %>
   Name = <%=FCSession.Item("contact.first_name")%>
          <%=FCSession.Item("contact.last_name")%> <BR>
<% } else { %>
   Name = <%=FCSession.Item("employee.first_name")%>
           <%=FCSession.Item("employee.last_name")%> <BR>
<% } %>

The following example displays the integer value for a configuration item.

JavaScript:

i_value for the config_itm "password specification" =

<%=FCSession.Item("config_itm.password specification.i_value")%> <BR>


LocalTimeZone | fcSDK Documentation

LocalTimeZone

Object and Type

Object : FCSession

Type : Property

Prototype

Public Property Get LocalTimeZone() As String

Public Property Let LocalTimeZone(ByVal NewTimeZone As String)

Description

This property retrieves or sets the local time zone. The local time zone represents the time zone of the FCSession. By default, the local time zone is the same as the FCApplication.ServerTimeZone property.

Parameters

Parameter Name | Required? | Description
NewTimeZone | Yes | The name of time zone.

Returns

A string containing the local time zone of the FCSession.

Error Codes

Value | Meaning
11007 | Invalid time_zone.

Examples

The following example displays and sets the local time zone.

JavaScript:

The Server Time Zone is <%=FCApp.ServerTimeZone%>.<BR>
The Local Time Zone = <%=FCSession.LocalTimeZone%>.<BR>

<%
var TZ = "Eastern Standard Time";
FCSession.LocalTimeZone = TZ;
%>

The Local Time Zone is now = <%=FCSession.LocalTimeZone%>.<BR>


LocalTimeZoneOffset | fcSDK Documentation

LocalTimeZoneOffset

Object and Type

Object : FCSession

Type : Property

Prototype

Public Property Get LocalTimeZoneOffset() As Long

Description

This read-only property returns the number of seconds the local time zone is offset from GMT.

Returns

A string containing the local time zone offset of the FCSession.

Example

The following example displays and sets the local time zone and offset.

JavaScript:

The Server Time Zone is <%=FCApp.ServerTimeZone%>.<BR>
The Local Time Zone = <%=FCSession.LocalTimeZone%>.<BR>
The Local Time Zone Offset = <%=FCSession.LocalTimeZoneOffset%> seconds.<BR>

<%
var TZ = "Eastern Standard Time";
FCSession.LocalTimeZone = TZ;
%>

The Local Time Zone is now = <%=FCSession.LocalTimeZone%>.<BR>
The Local Time Zone Offset is now = <%=FCSession.LocalTimeZoneOffset%> seconds.<BR>


LoginTime | fcSDK Documentation

LoginTime

Object and Type

Object : FCSession

Type : Property

Prototype

Public Property Get LoginTime() As Date

Description

This property returns the date/time of when this FCSession logged in.

Example

The following example shows when the current user logged in.

JavaScript:

Response.Write("FCSession Login Time = " + FCSession.LoginTime);

FCSession = null;


NoRes(FCSession) | fcSDK Documentation

NoRes(FCSession)

Object and Type

Object : FCSession

Type : Property

Prototype

Public NoRes As Boolean

Description

This property tells the session if all generic objects in that session should ignore data restriction, or not. Whatever value is set in this property (which is False initially) is passed to each generic when that generic is created.

The generic object can override the value passed in from the session by setting the NoRes property on the generic object after it is created.

For more details on what the NoRes property does, please see the NoRes documentation for the FCGeneric object above.

Example

The following example demonstrates setting the NoRes property for a new object.

JavaScript:

  // Include all relations for the session

  NoRes = true;

Visual Basic:

  NoRes = True


PasswordRequired | fcSDK Documentation

PasswordRequired

Object and Type

Object : FCSession

Type : Property

Prototype

Public PasswordRequired As Boolean

Description

This property allows you to disable password valdation when logging in using the Login method. By default, this property is set to True, meaning that a valid password must be supplied to the Login method. If this property is set to False, then the login name is validated, but the password is not.

This property is useful when developing applications that use their own validation mechanisms, such as an LDAP server or web server.

Example

The following example demonstrates setting and using the PasswordRequired property. The example allows you to login without supplying a valid password.

JavaScript:

  var FCApp;
  var FCSession;
  var strUserName = Request.Form("username").Item;

  //Create a session using the Global FCApp
  FCApp = Application.Contents("FCApp");
  FCSession = FCApp.CreateSession();
  FCSession.PasswordRequired = false;

  //Login as a contact

  try
  {
    FCSession.Login(strUserName,"","contact")
  }
  catch(e)
  {
    Response.Write("<BR><B>Logon Error:</B><BR>");
    Response.Write("<B>" + e.description + "</B><BR>");
  }


QueryEmptyToNull(FCSession) | fcSDK Documentation

QueryEmptyToNull(FCSession)

Object and Type

Object : FCSession

Type : Property

Prototype

Public QueryEmptyToNull As Boolean

Description

This property tells the session if all generic objects in that session should set the QueryEmptyToNull by default. Whatever value is set in this property (which is True initially) is passed to each generic when that generic is created.

The generic object can override the value passed in from the session by setting the QueryEmptyToNull property on the generic object after it is created.

For more details on what the QueryEmptyToNull property does, please see the QueryEmptyToNull documentation for the FCGeneric object above.

Example

The following example demonstrates setting the QueryEmptyToNull property for a new object.

JavaScript:

  // Include all relations for the session
  FCSession.QueryEmptyToNull = true;

Visual Basic:

  Fc_session.QueryEmptyToNull = True


RowLimit(FCSession) | fcSDK Documentation

RowLimit(FCSession)

Object and Type

Object : FCSession

Type : Property

Prototype

Public RowLimit As Integer

Description

This property allows you to set the RowLimit property for all Generic objects subsequently created from this session. Each new Generic will inherit the property from the session.

Note: Setting this property does not affect the RowLimit for any existing Generic objects - only those created after the property is set.

Example

The following example sets the RowLimit for all Generics created from this session. One of the Generics has a different RowLimit set.

JavaScript:

// Set the session row limit, and create a generic that will share
// the limit, and one that won't.

<%
FCSession.RowLimit = 300;
var boCase = FCSession.CreateGeneric();
boCase.SimpleQuery("case");
boCase.RowLimit = 100;
var boSite = FCSession.CreateGeneric();
boSite.SimpleQuery("site");
boCase.Bulk.Query();
%>


SessionID | fcSDK Documentation

SessionID

Object and Type

Object : FCSession

Type : Property

Prototype

Public Property Get SessionID() As String

Description

Returns the unique identifier associated with the FCSession. For ASP applications, this SessionID can be saved as a variable in an ASP Session object. Then, for each new page request, this value can be used with the CreateSession method on the FCApplication in order to retrieve a reference to an existing FCSession object.

Example

The following example stores the SessionID into an ASP Session object.

JavaScript:

if (LogonOK){
    // Save the FCSession Id in an ASP Session variable so that
    // it can be reestablished in the PageInitInc.asp of each
    // subsequent request.
    Session.Contents("FCSessionId") = FCSession.SessionId

The following example retrieves the SessionID from an ASP Session object, and uses the CreateSession method to reestablish it.

Visual Basic:

strSessionId = Session.Contents("FCSessionId")

if ( typeof(strSessionId) != "string" ) strSessionId = ""
if ( strSessionId == "" )
  { Response.Redirect("Logon3.asp") }

try
{
FCSession = Application.Contents("FCApp").CreateSession(strSessionId)
} catch ( e )
{
//Could not re-establish session. Re-direct to logon page
  Response.Redirect("Logon3.asp")
}


SetNullStringsToEmpty(FCSession) | fcSDK Documentation

SetNullStringsToEmpty(FCSession)

Object and Type

Object : FCSession

Type : Property

Prototype

Public SetNullStringsToEmpty  As Boolean

Description

This property tells the session if all generic objects in that session should set NULL fields to empty strings (when read) by default. Whatever value is set in this property (which is False initially) is passed to each generic when that generic is created.

The generic object can override the value passed in from the session by setting the SetNullStringsToEmpty property on the generic object after it is created.

For more details on what the SetNullStringsToEmpty property does, please see the SetNullStringsToEmpty documentation for the FCGeneric object above.

Example

The following example demonstrates setting the SetNullStringsToEmpty property for a new object.

JavaScript:

  // Set all NULL Strings to empty strings
  SetNullStringsToEmpty  = true;

Visual Basic:

  SetNullStringsToEmpty  = True


ThrowErrors | fcSDK Documentation

ThrowErrors

Object and Type

Object : FCSession

Type : Property

Prototype

Public ThrowErrors As Boolean

Description

First Choice FCFL-based High Level APIs either return errors through the return value of the COM method or throw the error (in the object programming methodology). The property ThrowErrors switches from one method to the other. Setting ThrowErrors to FALSE means First Choice methods return errors through the return code. Setting ThrowErrors to TRUE causes the methods to throw the error. By default the value of ThrowErrors is TRUE.

Example

The following example eveluates the return code from a High Level API call (Move Change Request)

Visual Basic:

FCSession.ThrowErrors = FALSE

ret_int = cq.move_cr(cbbo, "2", "Urgent")

If ret_int <> 0 Then
  Response.Write("Move CR Failed. Error Code = " + ret_int)
End If

The following example catches an error thrown from a High Level API call (Move Change Request)

JavaScript:

FCSession.ThrowErrors = TRUE

try {
  ret_int = cq.move_cr(cbbo, "2", "Urgent");
} catch{e) {
  Response.Write (e.description);
}


TruncateStringFields | fcSDK Documentation

TruncateStringFields

Object and Type

Object : FCSession

Type : Property

Prototype

Public TruncateStringFields As Boolean

Description

This property allows you to automatically truncate strings, as you assign them, for all Generics in this session. If it is set to True, FCFL will make sure that any string that you set will be truncated at the maximum length of the string field, as determined from the database. This does mean that you can lose data, as you assume that the full string will go into the database.

If the property is set to False (the default), then FCFL will attempt to write the entire string to the database. This usually will result in an error being thrown, which you can trap.

The best solution, of course, is to limit the length of your strings in your thick client application, or in your web pages.

Example

The following example attempts to write data to a field defined to a maximum length of 10. An error would be thrown.

JavaScript:

FCSession.TruncateStringFields = true;

boCase("x_short_field") = 'abcdefghijklmnopqrstuvwxyz';

The following example does the same thing, but truncates the field at the maximum length (10).

JavaScript:

FCSession.TruncateStringFields = false;

boCase("x_short_field") = 'abcdefghijklmnopqrstuvwxyz';


UpdateTime | fcSDK Documentation

UpdateTime

Object and Type

Object : FCSession

Type : Property

Prototype

Public Property Get UpdateTime() As Date

Description

This property returns the date/time of when this FCSession was last "updated". Actually, it is the date/time when the FCSession last performed a database roundtrip.

Example

The following example shows when the current user 's FCSession was last updated

JavaScript:

Response.Write("FCSession Update Time = " + FCSession.UpdateTime);


FCFL FCSQLExec Object | fcSDK Documentation

FCFL FCSQLExec Object

Overview

The FCSQLExec object is used when you wish to query an external (non-Clarify) database table using standard SQL. The FCGeneric object cannot do this, as it assumes certain things such as objid existence.

The FCSQLExec object can also be used to query tables in the Clarify database instance. This is useful in the common circumstance where you add a new (non-Clarify) table into the Clarify database instance. Since it uses straight SQL, there's no reason that the FCSQLExec object cannot be used to read/write Clarify tables directly, but that is not recommended.

Because this object only uses SQL, it is incumbent on the programmer to make sure that they get it right. Unlike the FCGeneric object, none of the details are taken care of for you. You must generate unique Ids (such as objids) yourself, you must take care of relations, etc.

If you plan on accessing a table other than the Clarify table to which you have logged in, you must use the OpenConnection (and later the CloseConnection) method.

If, however, you wish for an FCSQLExec object to simply access the database to which you are already logged in, you can do this by creating a new FCSQLExec object, and just executing SQL against it. You do not need to execute an OpenConnection method.

Creating a SQLExec object is easy. You must declare an variable to hold the SQLExec. Then you create it using the CreateSQLExec method of the session object. You MUST use this method, or the object will not be properly initialized.

The following are examples of how to create a SQLExec in both JavaScript and Visual Basic:

JavaScript:

var sqlTest = FCSession.CreateSQLExec();

Visual Basic:

Dim sql_obj As FCSQLExec

Set sql_obj = fc_session.CreateSQLExec()


Add Sql Parameter | fcSDK Documentation

Add Sql Parameter

Object and Type

Object : FCSQLExec

Type : Method

Prototype

Public Sub AddSqlParameter(ByVal value As Object)

Description

When executing SQL statements having user input it is best to use parameterized queries to avoid the potential for SQL injection attacks.

This method is used before calling Execute or ExecuteReturnRows to add sql query parameter values to the SQL query which is about to be executed. The SQL being executed needs to have parameter placeholders. Parameter placeholders are numbers starting with zero surrounded by curly braces. For example,

var sql = "Select count(*) from table_case where title = {0} or title = {1}"

SqlDB. AddSqlParameter(user_input1);

SqlDB.AddSqlParameter(user_input2);

SqlDB.Execute(sql);

Note: The type of the value being added as a SQL parameter needs to match the database field to which it is being applied. For example, you will receive an error if you apply a number parameter value to a string field.

Parameters

Parameter Name | Required? | Description
value | Yes | The sql query parameter value.


Execute | fcSDK Documentation

Execute

Object and Type

Object : FCSQLExec

Type : Method

Prototype

Public Sub Execute(ByVal SqlStr As String)

Description

This method is used to execute a SQL statement against the external database. This method is only used for SQL that DOES NOT return any database row. If you wish to execute SQL that does return rows, use the ExecuteReturnRows method.

When invoking dynamically created SQL based on user input it is best to use parameterized queries to avoid SQL injection attacks. SQLExec can run Parameterized queries by placing parameter placeholders in the SQL and calling AddSqlParameter with the parameter value before invoking the query. For example,

var sql = "UPDATE table_case SET title = {0} WHERE objid = 1";
SqlDB.AddSqlParameter(userInputCaseTitle);
SqlDB.Execute(sql);

The SQL provided must be valid SQL for the database system you connect to.

Parameters

Parameter Name | Required? | Description
SqlStr | Yes | The SQL statement to execute

Example

The following example demonstrates opening an external connection, executing SQL against it, and closing the connection.

JavaScript:

  // Create an external DB connection
  // Log in

  var SqlDB = FCSession.CreateSQLExec();
  SqlDB.OpenConnection("sql", "sa", "sa", "gaffer", "cl10");

  // Query for a simple table (with one column)
  // Iterate through it and print out the data
  SqlDB.ExecuteReturnRows("select * from foo");

  while (SqlDB.Records.EOF != true)
  {
    Response.Write ("Value: " + SqlDB.Records("out_col"));
    SqlDB.Records.MoveNext();
  }

  // Now add a row, and close the connection
  SqlDB.Execute("insert into foo values (55)");
  SqlDB.CloseConnection();

Visual Basic:

  Dim sql_db As FCSqlExec
  Set sql_db = fc_session.CreateSqlExec
  sql_db.OpenConnection "sql", "sa", "sa", "gaffer", "cl10"
  sql_db.ExecuteReturnRows "select * from foo"
  sql_db.records.MoveFirst

  While sql_db.records.EOF = False
    MsgBox sql_db.records("out_col")
    sql_db.records.MoveNext
  Wend

  sql_db.Execute "insert into foo values (44)"
  sql_db.CloseConnection


ExecuteReturnRows | fcSDK Documentation

ExecuteReturnRows

Object and Type

Object : FCSQLExec

Type : Method

Prototype

Public Sub ExecuteReturnRows(ByVal SqlStr As String)

Description

This method is used to execute a SQL statement against the external database. This method is only used for SQL that DOES return database rows. The data returned is returned in the Records property (ADODB.Recordset object). If you wish to execute SQL that does not return rows, use the Execute method. If you wish to reuse the SQLExec object (to query the database again), you must close the Record (recordset) object. For example,

SqlObj.Records.Close();

When invoking dynamically created SQL based on user input it is best to use parameterized queries to avoid SQL injection attacks. SQLExec can run Parameterized queries by placing parameter placeholders in the SQL and calling AddSqlParameter with the parameter value before invoking the query. For example,

var sql = "SELECT * FROM table_case WHERE title = {0}";
SqlDB.AddSqlParameter(userInputCaseTitle);
SqlDB.Execute(sql);

The SQL provided must be valid SQL for the database system you connect to.

Note: For more information about ADODB Recordsets, please visit the Microsoft website at: http://www.microsoft.com/.

Parameters

Parameter Name | Required? | Description
SqlStr | Yes | The SQL statement to execute

Example

The following example demonstrates opening an external connection, executing SQL against it, and closing the connection.

JavaScript:

  // Create an external DB connection
  // Log in

  var SqlDB = FCSession.CreateSQLExec();
  SqlDB.OpenConnection("sql", "sa", "sa", "gaffer", "cl10");

  // Query for a simple table (with one column)
  // Iterate through it and print out the data
  SqlDB.ExecuteReturnRows("select * from foo");

  while (SqlDB.Records.EOF != true)
  {
    Response.Write ("Value: " + SqlDB.Records("out_col"));
    SqlDB.Records.MoveNext();
  }

  // Now add a row, and close the connection
  SqlDB.Execute("insert into foo values (55)");
  SqlDB.CloseConnection();

Visual Basic:

  Dim sql_db As FCSqlExec
  Set sql_db = fc_session.CreateSqlExec
  sql_db.OpenConnection "sql", "sa", "sa", "gaffer", "cl10"
  sql_db.ExecuteReturnRows "select * from foo"
  sql_db.records.MoveFirst

  While sql_db.records.EOF = False
    MsgBox sql_db.records("out_col")
    sql_db.records.MoveNext | Wend | sql_db.Execute "insert into foo values (44)"
  sql_db.CloseConnection


OpenConnection | fcSDK Documentation

OpenConnection

Object and Type

Object : FCSQLExec

Type : Method

Prototype

Public Sub OpenConnection(ByVal TheDB As String, _
                          ByVal UserName As String, _
                          ByVal Password As String, _
                          ByVal DBServer As String, _
                          ByVal DBName As String)

Description

This method is used to open a connection to an external database. If this FCSQLExec object is using the default connection to the Clarify database, you do not need to call this method.

Parameters

Parameter Name | Required? | Description
TheDB | Yes | Database system to connect to. One of "SQL" or "ORACLE"
UserName | Yes | User name for login
Password | Yes | Password for the user
DBServer | Yes | Server on which the database is located
DBName | Yes | Database name

Error Codes

Value | Meaning
14001 | You may not connect with this SQLExec object to more than one database
14002 | Could not connect with the supplied parameters

Examples

The following example demonstrates opening an external connection, executing SQL against it, and closing the connection.

JavaScript:

  // Create an external DB connection
  // Log in
  var SqlDB = FCSession.CreateSQLExec();

  SqlDB.OpenConnection("sql", "sa", "sa", "gaffer", "cl10");

  // Query for a simple table (with one column)
  // Iterate through it and print out the data

  SqlDB.ExecuteReturnRows("select * from foo");

  while (SqlDB.Records.EOF != true)
  {
    Response.Write ("Value: " + SqlDB.Records("out_col"));
    SqlDB.Records.MoveNext();
  }

  // Now add a row, and close the connection
  SqlDB.Execute("insert into foo values (55)");
  SqlDB.CloseConnection();

Visual Basic:

 Dim sql_db As FCSqlExec

 Set sql_db = fc_session.CreateSqlExec

 sql_db.OpenConnection "sql", "sa", "sa", "gaffer", "cl10"
 sql_db.ExecuteReturnRows "select * from foo"
 sql_db.records.MoveFirst

  While sql_db.records.EOF = False
    MsgBox sql_db.records("out_col")
    sql_db.records.MoveNext
  Wend

  sql_db.Execute "insert into foo values (44)"
  sql_db.CloseConnection


CloseConnection | fcSDK Documentation

CloseConnection

Object and Type

Object : FCSQLExec

Type : Method

Prototype

Public Sub CloseConnection()

Description

This method is used to close an external database connection. If this FCSQLExec object is using the default connection to the Clarify database, you do not need to call this method. In fact, an error will occur in that case.

Error Codes

Value | Meaning
14003 | There is no open external connection to close

Examples

The following example demonstrates opening an external connection, executing SQL against it, and closing the connection.

JavaScript:

  // Create an external DB connection
  // Log in

  var SqlDB = FCSession.CreateSQLExec();
  SqlDB.OpenConnection("sql", "sa", "sa", "gaffer", "cl10");

  // Query for a simple table (with one column)
  // Iterate through it and print out the data

  SqlDB.ExecuteReturnRows("select * from foo");

  while (SqlDB.Records.EOF != true)
  {
    Response.Write ("Value: " + SqlDB.Records("out_col"));
    SqlDB.Records.MoveNext();
  }

  // Now add a row, and close the connection
  SqlDB.Execute("insert into foo values (55)");
  SqlDB.CloseConnection();

Visual Basic:

  Dim sql_db As FCSqlExec
  Set sql_db = fc_session.CreateSqlExec
  sql_db.OpenConnection "sql", "sa", "sa", "gaffer", "cl10"
  sql_db.ExecuteReturnRows "select * from foo"
  sql_db.records.MoveFirst

  While sql_db.records.EOF = False
    MsgBox sql_db.records("out_col")
    sql_db.records.MoveNext
  Wend

  sql_db.Execute "insert into foo values (44)"
  sql_db.CloseConnection


Records(FCSQLExec) | fcSDK Documentation

Records(FCSQLExec)

Object and Type

Object : FCSQLExec

Type : Property

Prototype

Public Records As ADODB.RecordSet

Description

This property contains the data records for the SQLExec object. The records are stored in an ADODB.Recordset object.

The records are created by using the ExecuteReturnRecords method.

In almost all cases, you do not need to ever worry about creating a Records object for a SQLExec object. When you create the object, the Records object is created for you automatically.

Data is read and written from the Records object using standard ADO methods. No additional methods are provided.

Note: For more information about ADODB Recordsets, please visit the Microsoft website at: http://www.microsoft.com/.

Example

The following example demonstrates querying the case table, and setting the alt_address field for each object returned, using the Records property, but not with the generic object, but a SQLExec object.

JavaScript:

  // Create an external DB connection

  // Log in
  var SqlDB = FCSession.CreateSQLExec();

  SqlDB.OpenConnection("sql", "sa", "sa", "gaffer", "cl10");

  // Query for a simple table (with one column)
  // Iterate through it and print out the data

  SqlDB.ExecuteReturnRows("select * from table_case");
  while (SqlDB.Records.EOF != true)
  {
    SqlDB.Execute("update table_case set alt_address = 'Alt1' where"
                  " objid = " + SqlDB.Records("objid"));
    SqlDB.Records.MoveNext();
  }

  SqlDB.CloseConnection();

Visual Basic:

 Dim SqlDB As New FCSqlExec

 Set SqlDB = fc_session.CreateSqlExec

 SqlDB.OpenConnection "sql", "sa", "sa", "gaffer", "cl10"
 SqlDB.ExecuteReturnRows "select * from table_case"

  While SqlDB.records.EOF = False
    SqlDB.Execute "update table_case set alt_address = 'Alt2' " & _
                  "where objid = " & _
                  Trim$(Str$(SqlDB.records("objid")))
    SqlDB.records.MoveNext
  Wend

  SqlDB.CloseConnection


FCFL API Toolkit for ClearContracts | fcSDK Documentation

FCFL API Toolkit for ClearContracts

Overview

Many customers have wanted the ability to customize the Clarify environment easily by adding base Clarify functions (such as contract and quote creation, closure, modification, or support programs) into web applications.

The First Choice Software FCFL API Toolkit for ClearContracts solves these problems, as well as many others. The toolkit is a set of COM functions that you may add to your web pages, interfaces, or customizations.

All of the APIs perform the same base functions as the Clarify GUI - all database records are properly written, activity logs are generated to track the API call, and time bombs are added to the system so that business rules can be fired based on the API function call.

While all of the APIs mimic the Clarify base function, many of them provide augmented functionality that Clarify customers have requested. For example, the base Clarify create contract functionality always requires that you dispatch the contract in a separate operation. With the create contract APIs in the toolkit, you have the choice of placing the contract in any specific Queue when creating the contract.

The APIs are simple to use. One simple API call is provided for each function, and very few data values must be supplied. The APIs are flexible in that they provide a large number of optional arguments that allow you to customize the API calls as needed.

It should be also noted that a few of the contract operations (such as convert) are already provided by Clarify in ClearBasic form in the server's rulemgr (or rulemanager on UNIX) directory. This toolkit does not duplicate that functionality.


accept_quote | fcSDK Documentation

accept_quote

Public Function accept_quote(ByVal quote_id As String, _
                             ByVal accept_date As String, _
                             ByVal wipbin_name As String, _
                             ByVal user_name As String, _
                             ByVal gen_time_bombs As Boolean) As Integer

Description

This API cause the specified quote to be accepted from a dispatched queue. The quote must be currently dispatched to a queue. The date/time of the accept, the WIPBin to place the quote in, and the user performing the accept can be specified. The API can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
quote_id | Yes | The quote to accept
accept_date | No | When was the quote accepted. If this parameter is left blank, the quote is accepted at the current time
wipbin_name | No | The WIPBin to place the quote in (for the user who accepted the quote) If left blank, the quote is placed in the user's default WIPBin
user_name | No | The user who accepted the quote. If left blank, the current user performs the accept.
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified contract
-2 | Quote is not currently dispatched
-3 | Specified user is not a member of the queue
-4 | The specified WIPBIN is not valid for the user
-5 | Could not find gbst_elm string for ACCEPT with rank = 100

Examples

Accept quote number 'Q2' right now for the current user, place in the default WIPBin, and generate a time bomb.

JavaScript:

var ret_int = fccc.accept_case("Q2", "", "", "", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fccc.accept_case("Q2", "", "", "", True)

Accept quote number 'Q2' at 10PM on November 23rd of 2001 by user 'marty', and place it in marty's WIPBin named 'Urgent'. Don't generate a time bomb.

JavaScript:

var ret_int = fccc.accept_case("Q2", "11/23/2001 22:00:00", "Urgent", "marty", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fccc.accept_case("Q2", "11/23/2001 22:00:00", "Urgent", "marty", True)


add_po_to_sched | fcSDK Documentation

add_po_to_sched

Public Function add_po_to_sched(ByVal contract_id As String, _
                                ByVal sched_id As String, _
                                ByVal po_num As String, _
                                ByVal pay_option As String, _
                                ByVal pay_terms As String, _
                                ByVal po_amt As String, _
                                ByVal po_date As String, _
                                ByVal expire_date As String, _
                                ByVal po_status As String) As Integer

Description

This API is used to add purchase orders to schedules of contracts. A valid schedule for a contract must be specified. Also, the PO number cannot be defined already for the schedule. A variety of other payment items can be specified, as well as the PO date, and the expiration date.

Parameters

Parameter Name | Required? | Description
contract_id | Yes | ID number of the contract/quote
sched_id | Yes | ID of the schedule for the specified contract
po_num | Yes | The purchase order number for the schedule
pay_option | No | Payment option. If blank, the default value of the PAY_METHOD list is used
pay_terms | No | Payment terms. If blank, the default value of the CONTRACT_PAY_TERMS list is used
po_amt | Yes | Purchase order amount. Must be numeric
po_date | No | Purchase order date. If blank, current date/time is used
expire_date | No | Purchase order expiration date. If blank, current date/time is used.
po_status | No | Purchase order status. If blank, the default status from "PO
Status" for Closed Contract condition will be used. |  |

Returns

Value | Meaning
0 | No errors
-1 | Purchase order amount is not numeric
-2 | Contract specified could not be found
-3 | The specified schedule for the contract could not be found
-4 | The specified purchase order number is already defined for this schedule
-5 | The specified payment method is not found
-6 | The specified payment terms cannot be found
-7 | The specified payment status is not found
ret_id_num | Output - Returns the header id of the newly created purchase order
ret_objid | Output - Returns the objid of the newly purchase order

Examples

Add purchase order '123' to contract '22' and schedule 'Default Schedule'. The amount is $155.55, and set the terms, method, and status. Set dates as well.

JavaScript:

   var ret_int = fc_cc.add_po_to_sched("22", "Default Schedule", "123", _
                                   "Check",  "Net 10", "155.55", _
                                   "01/01/2001", "11/01/2002", "Issued")

Visual Basic:

   Dim ret_int As Integer
   Dim po_num     As String
   Dim po_objid   As Long

   ret_int = fc_cc.add_po_to_sched("22", "Default Schedule", "123", _
                                   "Check",  "Net 10", "155.55", _
                                   "01/01/2001", "11/01/2002", "Issued")

   If ret_int = 0 Then
     po_num = fc_cc.ret_id_num
     po_objid = fc_cc.ret_objid
   End If


assign_quote | fcSDK Documentation

assign_quote

Public Function assign_quote(ByVal quote_id As String, _
                             ByVal new_user As String, _
                             ByVal wipbin_name As String, _
                             ByVal assign_date As String,
                             ByVal user_name As String, _
                             ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified quote to be assigned to a new user. The quote must be in open condition, and the user assigning the quote does not have to be the owner of the quote. In base Clarify, the assigner of a quote must be the owner. If either user name is not specified, the "current" user is used. The date/time of the assignment, and the WIPBin to place the quote in can also be specified. Allowing a WIPBin other than the default one is also an augmentation from base Clarify. The API can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
quote_id | Yes | The quote to assign
new_user | No | The user who the quote is assigned to. If left blank, the quote is assigned to the current user
wipbin_name | No | The WIPBin to place the quote in (for the user who is assigned the quote) If left blank, the quote is placed in the user's default WIPBin
assign_date | No | When was the quote assigned. If this parameter is left blank, the quote is assigned at the current time
user_name | No | The user who assigned the quote. If left blank, the current user performs the assign.
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified quote
-2 | The specified quote is not currently open
-3 | Specified user (to assign to) is not found
-4 | The specified WIPBIN is not valid for the user
-5 | Specified user (who performed the assign) is not found
-6 | Could not find gbst_elm string for ASSIGN with rank = 10500

Examples

Assign quote number '154' to user 'marty'. The assign is performed by the current user, is placed in the default WIPBin and is assigned at the current time. Generate a time bomb.

JavaScript:

var ret_int = fc_cc.assign_quote("154", "marty", "", "", "", True)

Visual Basic:

Dim ret_int As Integer

ret_int = fc_cc.assign_quote("154", "marty", "", "", "", True)

Assign quote number 'Q2' at 10PM on November 23rd of 2001 to marty, and place the quote in marty's WIPBin named 'Urgent'. Assign should be logged as performed by sam. Don't generate a time bomb

JavaScript:

var ret_int = fc_cc.assign_quote("Q2", "marty", "Urgent", _
                            "11/23/2001 22:00:00", "sam", False)

Visual Basic:

Dim ret_int As Integer

ret_int = fc_cc.assign_quote("Q2", "marty", "Urgent", _
                            "11/23/2001 22:00:00", "sam", False)


change_quote_status | fcSDK Documentation

change_quote_status

Public Function change_quote_status(ByVal quote_id As String, _
                                    ByVal new_status As String, _
                                    ByVal change_date As String, _
                                    ByVal note_str As String, _
                                    ByVal user_name As String, _
                                    ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified quote to have its status changed. The quote may be in any valid condition, but the status selected MUST be valid for the current condition. In other words, you cannot assign an Active Contract condition status to a quote that is currently in Quote condition. You may assign notes to the status change, as well as set the time of the status change, and the user who changed the status. The API can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
quote_id | Yes | The quote to change status for
new_status | No | The new status for the quote
change_date | No | When was the quote status changed. If this parameter is left blank, the quote is status changed at the current time
note_str | No | Notes for the status change
user_name | No | The user who changed the status. If left blank, the current user performs the change status.
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified quote
-2 | Cannot find the new status (or status is not defined for the current quote's condition)
-3 | Cannot find the specified user
-4 | Cannot find the CHANGE STATUS activity string with rank = 13900

Examples

Change status for quote number '154' to the default status. The change status is performed by the current user and is changed at the current time. Add no notes, and generate a time bomb.

JavaScript:

var ret_int = fc_cc.change_quote_status("154", "", "", "", "", True)

Visual Basic:

Dim ret_int As Integer

ret_int = fc_cc.change_quote_status("154", "", "", "", "", True)

Change status for quote number 'Q2' at 10PM on November 23rd of 2001 to 'Solved'. Change status has notes of 'Some notes', and should be logged as performed by user 'sam'. Don't generate a time bomb.

JavaScript:

var ret_int = fc_cc.change_quote_status("154", "", "", "", "", True)

Visual Basic:

Dim ret_int As Integer

ret ret_int = fc_cc.change_quote_status("154", "", "", "", "", True)


create_contract | fcSDK Documentation

create_contract

create_contract_list

CreateContract

CreateContractList

Public Function create_contract(ByVal contract_id As String, _
                ByVal title_str As String, ByVal create_date As String, _
                ByVal acct_id As String, ByVal acct_name As String, _
                ByVal first_name As String, ByVal last_name As String, _
                ByVal phone_num As String, ByVal type_str As String, _
                ByVal term_str As String, ByVal curr_str As String, _
                ByVal new_status As String, ByVal admin_name As String, _
                ByVal bill_to_site_id As String, ByVal ship_to_site_id As String, _
                ByVal eff_date As String, ByVal exp_date As String, _
                ByVal start_date As String, ByVal end_date As String, _
                ByVal user_name As String, ByVal queue_name As String, _
                ByVal warranty As Boolean, ByVal evergreen As Boolean, _
                ByVal renew_prior As Long, ByVal gen_time_bombs As Boolean, _
                ByVal int_fld1 As String, ByVal int_val1 As Long, _
                ByVal int_fld2 As String, ByVal int_val2 As Long, _
                ByVal str_fld1 As String, ByVal str_val1 As String, _
                ByVal str_fld2 As String, ByVal str_val2 As String, _
                ByVal date_fld1 As String, ByVal date_val1 As String) As Integer

Public Function create_contract_list(ByVal contract_id As String, _
                ByVal title_str As String, ByVal create_date As String, _
                ByVal acct_id As String, ByVal acct_name As String, _
                ByVal first_name As String, ByVal last_name As String, _
                ByVal phone_num As String, ByVal type_str As String, _
                ByVal term_str As String, ByVal curr_str As String, _
                ByVal new_status As String, ByVal admin_name As String, _
                ByVal bill_to_site_id As String, ByVal ship_to_site_id As String, _
                ByVal eff_date As String, ByVal exp_date As String, _
                ByVal start_date As String, ByVal end_date As String, _
                ByVal user_name As String, ByVal queue_name As String, _
                ByVal warranty As Boolean, ByVal evergreen As Boolean, _
                ByVal renew_prior As Long, ByVal gen_time_bombs As Boolean, _
                Optional fld_list As Variant, Optional type_list As Variant, _
                Optional val_list As Variant) As Integer

Description

These APIs are used to create new contracts. Each contract requires a unique, valid title. Everything else is optional. You may specify either an account or contact for a contract (or neither), you may specify a contract ID or let the API auto-generate the contract ID for you. You may specify the user who created the contract as well as the contract's administrator, and you may specify additional fields. You may have a creation time bomb generated (for notifications). The objid of the contract created is returned. You may also specify a bill-to and ship-to site. These sites will be related to the default schedule. If empty, no site is related. If you do not wish to associate an account or contact against the contract, leave the account and contact parameters empty. You may also initially dispatch the contract. If you specify a queue name, the contract will be dispatched to that queue.

Note: CreateContract and CreateContractList are the same methods as create_contract and create_contract_list respectively. They are alternate entry points to preserve backwards compatibility to Clear Basic API Toolkit for Clear Contracts naming.

Parameters

Parameter Name | Required? | Description
contract_id | No | Input/Output to either set or return the the newly created contract ID
title_str | Yes | The title for the new contract, must be unique
create_date | No | Date the contract was created. Will default to current time.
acct_id | No | Account ID for related account.
acct_name | No | Name of the account to which the contract is related to .
first_name | No | First name of contact associated with the case
last_name | No | Last name of contact associated with the case
phone_num | No | Phone number of contact associated with the case
type_str | No | Type of contract. Will use default list value if not supplied
term_str | No | Terms of contract. Will use default list value if not supplied
curr_str | No | Currency for contract. Will use default if value not supplied
New_status | No | Status of the contract. Will use default if value not supplied
admin_name | No | Administrator of the contract. Will use current user if not supplied
bill_to_site_id | No | Site ID of site to use for bill-to site of the schedule. If empty, no site is used
ship_to_site_id | No | Site ID of site to use for ship-to site of the schedule. If empty, no site is used
eff_date | No | Effective date for the contract. Will use current date if not supplied
exp_date | No | Expiration date for the contract. Will use current date if not supplied
start_date | No | Date service begins. Will use current date if not supplied
end_date | No | Date service ends. Will use current date if not supplied
user_name | No | Owner of the contract. Will use current user if not supplied
queue_name | No | Queue to dispatch newly created contract to
warranty | No | Warranty flag for contract
evergreen | No | Evergreen flag for contract
renew_prior | No | Days to renew prior to expiry date
gen_time_bombs | No | Flag to create time bombs. Default is FALSE
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | Found zero or many accounts. Your criteria must return one and only one account.
-2 | Found zero or many contacts. Your criteria must return one and only one account.
-3 | Could not find user specified
-4 | Could not find WipBin specified
-5 | Could not find Currency specified
-6 | Could not find user record for administrator specified
-7 | Could not find status specified
-8 | Could not find appropriate activity element for the create event
-9 | Could not find specified queue
-10 | Could not find contract type specified
-11 | Could not find contract terms specified
-12 | User did not specify required field for title
-13 | Stored procedure for numbering scheme not found
-14 | Service end date before Service start date
-15 | Contract expiry date before effective date
-16 | Contract is not unique
-17 | Specified bill-to site does not exist
-18 | Specified ship-to site does not exist
-19 | Could not find default price program of US Std Price List
ret_id_num | Output - Returns the id of the newly created contract
ret_objid | Output - Returns the objid of the newly created contract

Examples

Create a new contract with title 'White House'. Specify the account of 'Major Movers', and contact of 'George Bush'. Also, generate a time bomb. All other information is defaulted. Contract ID and objid are returned.

Field version:

JavaScript:

var ret_int = cl_cc.create_contract_list( "", "White House", _
                "", "", "White House", "George", "Bush", _
                "", "", "", "", "", "", "", "", "", _
                "", "", "", "", "", "", "", "", "TRUE", _
                "", 0, "", "", "", "")

Visual Basic:

Dim ret_int As Integer
Dim objid        As Long
Dim contract_id  As String

ret_int = cl_cc.create_contract_list( "", "White House", _
                "", "", "White House", "George", "Bush", _
                "", "", "", "", "", "", "", "", "", _
                "", "", "", "", "", "", "", "", "TRUE", _
                "", 0, "", "", "", "")

If ret_int = 0 Then
  contract_id = fc_cc.ret_id_num
  objid = fc_cc.ret_objid
End If

List version:

JavaScript:

var fld_list  = Server.CreateObject("FCFLCompat.FCList");
var type_list = Server.CreateObject("FCFLCompat.FCList");
var val_list  = Server.CreateObject("FCFLCompat.FCList");

var ret_int;

fld_list.AppendItem("x_close_int1");
type_list.AppendItem("Long");
val_list.AppendItem("1");

fld_list.AppendItem("x_close_int2");
type_list.AppendItem("Long");
val_list.AppendItem("456");

fld_list.AppendItem("x_summary2");
type_list.AppendItem("String");
val_list.AppendItem("More text");

fld_list.AppendItem("x_other_date");
type_list.AppendItem("Date");
val_list.AppendItem("1/1/99");

var ret_int = cl_cc.create_contract_list(contract_id, "White House", _
                "", "", "White House", "George", "Bush", "", _
                "", "", "", "", "", "", "", "", "", "", _
                "", "", "", "", "", "", "TRUE", _
                fld_list, type_list, val_list)

Visual Basic:

Dim ret_int As Integer
Dim objid               As Long
Dim contract_id         As String
Dim fld_list            As New FCFLCOMPAT.FCLIST
Dim type_list           As New FCFLCOMPAT.FCLIST
Dim val_list            As New FCFLCOMPAT.FCLIST

fld_list.ItemType = "String"
type_list.ItemType = "String"
val_list.ItemType = "String"

ret_int = cl_cc.create_contract_list(contract_id, "White House", _
                "", "", "White House", "George", "Bush", "", _
                "", "", "", "", "", "", "", "", "", "", _
                "", "", "", "", "", "", "TRUE", _
                fld_list, type_list, val_list) If ret_int = 0 Then

  contract_id = fc_cc.ret_id_num
  objid = fc_cc.ret_objid

End If


create_price_inst | fcSDK Documentation

create_price_inst

create_price_inst_list

CreatePriceInst

CreatePriceInstList

Public Function create_price_inst(ByVal part_num As String, _
                ByVal mod_level As String, ByVal domain As String, _
                ByVal support_prog As String, ByVal price_prog As String, _
                ByVal price_type As Integer, ByVal priced_qty As Long, _
                ByVal price As Double, ByVal eff_date As String, _
                ByVal exp_date As String, ByVal int_fld1 As String, _
                ByVal int_val1 As Long, ByVal int_fld2 As String, _
                ByVal int_val2 As Long, ByVal str_fld1 As String, _
                ByVal str_val1 As String, ByVal str_fld2 As String, _
                ByVal str_val2 As String, ByVal date_fld1 As String, _
                ByVal date_val1 As String) As Integer

Public Function create_price_inst_list(ByVal part_num As String, _
             ByVal mod_level As String, ByVal domain As String, _
             ByVal support_prog As String, ByVal price_prog As String, _
             ByVal price_type As Long, ByVal price_qty As Long, _
             ByVal price As Double, ByVal eff_date As String, _
             ByVal exp_date As String, Optional fld_list As Variant, _
             Optional type_list As Variant, Optional val_list As Variant) As Integer

Description

These APIs are used to create new price instances for support programs. They require a valid support program, price schedule, price type and price quantity. Everything else is optional. You may specify the part for product based support programs, or leave it blank when creating price instances for either site or independent support programs. If you do specify a part, you must include its domain and revision (mod level).

When pricing quantities, if you leave the price quantity empty, it will default to a zero price quantity.

NOTE: CreatePriceInst and CreatePriceInst are the same methods as create_price_inst and _create_price_inst list respectively. They are alternate entry points to preserve backwards compatibility to Clear Basic API Toolkit for Clear Contracts naming.

Parameters

Parameter Name | Required? | Description
part_num | No | The part number of the part being priced
mod_level | No | The mod level of the part being priced
domain | No | The domain of the part being priced
support_prog | Yes | The support program for which this price instance is being created
price_prog | Yes | The price schedule for this price instance
price_type | Yes | The price type for the price instance 0=fixed 1=percent of product 2=percent of option list (not supported at this time)
priced_qty | Yes | The number of units being priced
price | No | The total price for the units of this price instance
eff_date | No | The start date of this price instance
exp_date | No | The expiration date of this price instance
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list
Value | Meaning
0 | No Errors
-1 | Support program not found
-2 | Price schedule not found
-3 | Mod level not found
-4 | Price type not found
-5 | Mod level not found for support program
-6 | Priced quantity required, not supplied
-7 | Effective date comes before expiration date
-8 | Price instance expiration date comes after the price schedule expiration date
-9 | The dates supplied would cause an overlap in price instances
-10 | Priced quantity already exists
-11 | The category for the support program does not exist
-12 | Cannot price since reference part number cannot be found
-13 | Price type is not yet supported
ret_objid | Output Returns the objid of the newly created price instance

Examples

Create a new price instance for product 'Kudzu' software under the 'Kudzu Phone Support' support program. Associate this price instance with the 'US Std Price List'. Use a fixed price type with 50 units costing 100 dollars.

Field version:

JavaScript:

var ret_int = fc_cc.create_price_inst( "Kudzu", "2000", "Software Part", _
                                "Kudzu Phone Support", "US Std Price List", _
                                0, 50, 100, "","", "", 0, "", 0, "", _
                                "", "", "", "", "")

Visual Basic:

Dim ret_int As Integer
Dim objid   As Long

ret_int = fc_cc.create_price_inst( "Kudzu", "2000", "Software Part", _
                              "Kudzu Phone Support", "US Std Price List", _
                              0, 50, 100, "","", "", 0, "", 0, "", _
                              "", "", "", "", "")

**List version:**

**JavaScript:**

var fld_list  = Server.CreateObject("FCFLCompat.FCList");
var type_list = Server.CreateObject("FCFLCompat.FCList");
var val_list  = Server.CreateObject("FCFLCompat.FCList");
var ret_int;

fld_list.AppendItem("x_close_int1");
type_list.AppendItem("Long");
val_list.AppendItem("1");

fld_list.AppendItem("x_close_int2");
type_list.AppendItem("Long");
val_list.AppendItem("456");

fld_list.AppendItem("x_summary2");
type_list.AppendItem("String");
val_list.AppendItem("More text");

fld_list.AppendItem("x_other_date");
type_list.AppendItem("Date");
val_list.AppendItem("1/1/99");

ret_int = fc_cc.create_price_inst_list("Kudzu", "2000", "Software Part", _ "Kudzu Phone Support", "US Std Price List", 0, _ 50, 100, "", "", fld_list, type_list, val_list)

**Visual Basic:**

Dim ret_int As Integer
Dim objid           As Long
Dim fld_list         As New FCFLCOMPAT.FCLIST
Dim type_list        As New FCFLCOMPAT.FCLIST
Dim val_list         As New FCFLCOMPAT.FCLIST

fld_list.ItemType = "String"
type_list.ItemType = "String"
val_list.ItemType = "String"

ret_int = fc_cc.create_price_inst_list("Kudzu", "2000", "Software Part", _ "Kudzu Phone Support", "US Std Price List", 0, _ 50, 100, "", "", fld_list, type_list, val_list)


create_update_schedule | fcSDK Documentation

create_update_schedule

create_update_schedule_list

Public Function create_update_schedule(ByVal contract_id As String, _
                ByVal is_create As Boolean, ByVal sched_id As String, _
                ByVal bill_site As String, ByVal bill_attn As String, _
                ByVal ship_site As String, ByVal price_prog As String, _
                ByVal bill_freq As String, ByVal bill_option As String, _
                ByVal period_start_dt As String, ByVal first_bill_dt As String, _
                ByVal chg_start_dt As String, ByVal chg_end_dt As String, _
                ByVal int_fld1 As String, ByVal int_val1 As Long, _
                ByVal int_fld2 As String, ByVal int_val2 As Long, _
                ByVal str_fld1 As String, ByVal str_val1 As String, _
                ByVal str_fld2 As String, ByVal str_val2 As String, _
                ByVal date_fld1 As String, ByVal date_val1 As String) As Integer

Public Function create_update_schedule_list(ByVal contract_id As String, _
                ByVal is_create As Boolean, ByVal sched_id As String, _
                ByVal bill_site As String, ByVal bill_attn As String, _
                ByVal ship_site As String, ByVal price_prog As String, _
                ByVal bill_freq As String, ByVal bill_option As String, _
                ByVal period_start_dt As String, ByVal first_bill_dt As String, _
                ByVal chg_start_dt As String, ByVal chg_end_dt As String, _
                Optional fld_list As Variant, Optional type_list As Variant, _
                Optional val_list As Variant) As Integer

Description

These APIs are used to create or update a contract schedule. The contract ID must be specified, and the ID of the schedule is also specified. If this is an update, the Boolean is set to False, otherwise it is set to True. You may specify the bill-to or ship-to site, the price program, and the code list values. In addition, you may specify a variety of dates.

Parameters

Parameter Name | Required? | Description
contract_id | Yes | ID number of the contract
is_create | Yes | Is this a new schedule (True) or an update (False)
sched_id | Yes | The ID of the schedule to create, or of the one to update
bill_site | No | The ID number of the site to associate as the bill-to site. If this is set to the empty string ("") or "IGNORE", no change is made in the site
bill_attn | No | Attention person at bill-to site. If this field is set to "CLEAR", the field is set to the empty string
ship_site | No | The ID number of the site to associate as the ship-to site. If this is set to the empty string ("") or "IGNORE", no change is made in the site
price_prog | No | The price program for the schedule. If this field is left blank (for creates), the default program is used. If it is left blank (updates), the program is not changed
bill_freq | No | The billing frequency. If blank (creates), the default is used. If blank (updates), no change is made
bill_option | No | The billing option. If blank (creates), the default is used. If blank (updates), no change is made
period_start_dt | No | The start date of the billing period. If blank (creates), the current date/time is used. If blank (updates), the date is not changed
first_bill_dt | No | The first billing date. If blank (creates), the current date/time is used. If blank (updates), the date is not changed
chg_start_dt | No | The start date of the charging. If blank (creates), the current date/time is used. If blank (updates), the date is not changed
chg_end_dt | No | The end date of the charging. If blank (creates), the current date/time is used. If blank (updates), the date is not changed
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | Could not find the specified contract
-2 | Could not find the specified bill-to site
-3 | Could not find the specified ship-to site
-4 | The specified price program is not found
-5 | The specified billing option is not valid
-6 | The specified billing frequency is not valid
-7 | The end charge date is earlier than the start charge date
-8 | The specified schedule name already exists for the contract. Cannot create
-9 | The specified schedule does not exist. Cannot update
ret_objid | Output - Returns the objid of the newly created schedule

Examples

Create a new schedule for contract '42'. Give sites and attention person. Supply a price program, and other options. Specify a value for an extra field named 'x_other_string'.

JavaScript:

var ret_int = fc_cc.create_update_schedule( "42", True, "New Schedule",
        "Site 42", "Attn: Joe Francis", "Site 44", "March Prices",
        "Monthly", "In Advance", "", "", "", "",
        "", 0, "", 0, "x_other_string", "Value here!", "", "", "", "")

Visual Basic:

Dim ret_int As Integer

ret_int = fc_cc.create_update_schedule( "42", True, "New Schedule", _
        "Site 42", "Attn: Joe Francis", "Site 44", "March Prices", _
        "Monthly", "In Advance", "", "", "", "", _
        "", 0, "", 0, "x_other_string", "Value here!", "", "", "", "")

Update the same contract. Clear the attention field, and change the billing frequency.

JavaScript:

var ret_int = fc_cc.create_update_schedule("42", False, "New Schedule", _
                    "", "CLEAR", "IGNORE", "", "Quarterly", "", "", "", "", _
                    "", "", 0, "", 0, "", "", "", "", "", "")

Visual Basic:

Dim ret_int As Integer

ret_int = fc_cc.create_update_schedule("42", False, "New Schedule", _
                    "", "CLEAR", "IGNORE", "", "Quarterly", "", "", "", "", _
                    "", "", 0, "", 0, "", "", "", "", "", "")


cr_contr_itm | fcSDK Documentation

cr_contr_itm

cr_contr_itm_list

Public Function cr_contr_itm(ByVal contract_id As String, _
                ByVal user_name As String, ByVal create_date As String, _
                ByVal start_date As String, ByVal end_date As String, _
                ByVal part_num As String, ByVal domain As String, _
                ByVal rev As String, ByVal quantity As Long, _
                ByVal price_schedule As String, ByVal oride_price As String, _
                ByVal units_used As Double, ByVal serial_num As String, _
                ByVal is_taxable As Boolean, ByVal install_it As Boolean, _
                ByVal comments As String, ByVal quoted_site As String, _
                ByVal serviced_at_site As String, ByVal parent_objid As Long, _
                ByVal po_num As String, ByVal int_fld1 As String, _
                ByVal int_val1 As Long, ByVal int_fld2 As String, _
                ByVal int_val2 As Long, ByVal str_fld1 As String, _
                ByVal str_val1 As String, ByVal str_fld2 As String, _
                ByVal str_val2 As String, ByVal date_fld1 As String, _
                ByVal date_val1 As String, ByVal item_objid As Long) As Integer

Public Function cr_contr_itm_list(ByVal contract_id As String, _
                ByVal user_name As String, ByVal create_date As String, _
                ByVal start_date As String, ByVal end_date As String, _
                ByVal part_num As String, ByVal domain As String, _
                ByVal rev As String, ByVal quantity As Long, _
                ByVal price_schedule As String, ByVal oride_price As String, _
                ByVal units_used As Double, ByVal serial_num As String, _
                ByVal is_taxable As Boolean, ByVal install_it As Boolean, _
                ByVal comments As String, ByVal quoted_site As String, _
                ByVal serviced_at_site As String, ByVal parent_objid As Long, _
                ByVal po_num As String, ByVal item_objid As Long, _
                Optional fld_list As Variant, Optional type_list As Variant, _
                Optional val_list As Variant) As Integer

Description

These APIs are used to create quote/contract line items. They require that a valid quote already exist, and that it have at least one valid schedule. In addition, the supplied part/revision must have a price defined for it in the schedule, or you must provide an override.

The API will create a line item, add it to the proper contract/quote, and adjust all of the totals. In addition, the schedule adjustments (if any) for the schedule of the line item will be recalculated, given the new schedule totals.

You must specify a contract id and a price schedule, and a quantity of items in the line. You must also specify the part/revision/domain of the part to quote. All other arguments can be left blank. You may specify the user who created the line item, as well as the create date. You may also specify a start/end date for the line item.

You may specify an override price (per unit price). If this is blank, then the price from the price schedule is used. You may specify how many units are used in the line. The units available is calcularted from this number.

A purchase order number may be specified. If it is, it must be a valid purchase order for the contract schedule specified for this line item. If it is serialized part (quantity 1), the serial number may be specified. You may also specify the taxable state, and if the part is to be auto-installed. If it is, you must supply the site that it will be installed at. You may also specify the serviced at site, as well as additional fields.

If you wish to make this a parent line item, put -1 in the parent_objid argument. Else, put the objid of the parent line item in the field. It will be made a child of the parent line item.

The API does not do a few other items in the base GUI function. By and large, they are expected to be supplied with other API calls. For example, line item adjustments are not part of this API. If they are required, the line should be created, and then the adjustment should be applied. Parent/child line items are not provided for in the default API. Also, proration (ClearContracts) is currently hard-coded.

Parameters

Parameter Name | Required? | Description
contract_id | Yes | The quote/contract for the line item
user_name | No | The user who created the line item. If left blank, the current user performs the create.
create_date | No | Line item creation date. If left blank, current date/time is used
start_date | No | Start date/time of the line item. If blank, create_date is used
end_date | No | End date/time of the line item. If blank, create_date + 1 year is used
part_num | Yes | Part number of part to quote
domain | Yes | Domain of part to quote
rev | Yes | Revision of part to quote
quantity | Yes | Number of units in line
price_schedule | Yes | Name of the schedule from the quote to put the line on
oride_price | No | If supplied, this is the per-unit price. If blank, price is taken from the price schedule
units_used | No | If supplied, this is the number of units used. If = 0 (default), then all units are initially available
serial_num | No | For serialized parts, the serial number to quote
is_taxable | Yes | Is the line taxable?
install_it | Yes | Should the part be marked for auto-install?
comments | No | Comments about the line item
quoted_site | No | Site ID of the site for auto-install. If auto-install = True, this must be supplied
serviced_at_site | No | The site ID of the site servicing the line
parent_objid | Yes | The objid of the parent line item. If set to -1 then this is a parent line item
po_num | No | Purchase order number for this line item. Must be a valid purchase order number for the schedule specified above
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | Quantity supplied is < 1
-2 | End date is earlier than start date
-3 | The specified quote/contract was not found
-4 | Could not find the specified user
-5 | The revision is not found for the specified part/domain
-6 | The specified schedule is not found for the contract/quote
-7 | The specified quoted_at site was not found
-8 | The specified serviced_at site was not found
-9 | The specified part/revision is not found on the price schedule
-10 | Serial number supplied with a quantity > 1
-13 | The specified part is quantity tracked, and a serial number was supplied
-14 | The line was marked with auto-install, and no site was supplied
-15 | The override price given was not numeric
-16 | Cannot locate the specified site_part
-17 | The specified parent line item does not exist
-18 | The specified parent line item is not actually a parent. It is a child line item
-19 | The specified product is priced as a percentage of parent, but no parent was given
-20 | The specified product is priced as a percentage of child - not supported for this API
-21 | The specified purchase order is not found for the contract schedule.
-22 | The mod_level is not found for the parent contract item.
ret_objid | Output - Returns the objid of the newly created contract item

Examples

Create a new line item for quote '2'. A total of 3 Notebooks are quoted for the default schedule. Add a comment, and relate to purchase order '222'.

Field version:

JavaScript:

   var ret_int = fc_cc.cr_contr_itm( "2", "", "", "", "", "Notebook", _
                            "Quantity", "",3, "Default Schedule", "", _
                             0, "", True, False, "A Comment", "", "", _
                             -1, "222", "", 0, "", 0, "", "", "", "", _
                             "", "")

Visual Basic:

   Dim ret_int As Integer
   Dim item_objid As Long

   ret_int = fc_cc.cr_contr_itm( "2", "", "", "", "", "Notebook", _
                            "Quantity", "",3, "Default Schedule", "", _
                             0, "", True, False, "A Comment", "", "", _
                             -1, "222", "", 0, "", 0, "", "", "", "", _
                             "", "")

   If ret_int = 0 Then
     item_objid = fc_cc.ret_objid
   End If

List version:

JavaScript:

var fld_list  = Server.CreateObject("FCFLCompat.FCList");

var type_list = Server.CreateObject("FCFLCompat.FCList");
var val_list  = Server.CreateObject("FCFLCompat.FCList");
var ret_int;

fld_list.AppendItem("x_close_int1");
type_list.AppendItem("Long");
val_list.AppendItem("1");

fld_list.AppendItem("x_close_int2");
type_list.AppendItem("Long");
val_list.AppendItem("456");

fld_list.AppendItem("x_summary2");
type_list.AppendItem("String");
val_list.AppendItem("More text");

fld_list.AppendItem("x_other_date");
type_list.AppendItem("Date");
val_list.AppendItem("1/1/99");

ret_int = fc_cc.cr_contr_itm("2", "", "", "", "", "Notebook", _
                             "Quantity", "", 3, "Default Schedule", "", _
                             0, "", True, False, "A Comment", "", -1, _
                             "222", fld_list, type_list, val_list)

Visual Basic:

 Dim ret_int As Integer
 Dim item_objid      As Long
 Dim fld_list         As New FCFLCOMPAT.FCLIST
 Dim type_list        As New FCFLCOMPAT.FCLIST
 Dim val_list         As New FCFLCOMPAT.FCLIST

 fld_list.ItemType = "String"
 type_list.ItemType = "String"
 val_list.ItemType = "String"

 ret_int = fc_cc.cr_contr_itm("2", "", "", "", "", "Notebook", _
                              "Quantity", "", 3, "Default Schedule", "", _
                              0, "", True, False, "A Comment", "", -1, _
                              "222", fld_list, type_list, val_list)

 If ret_int = 0 Then
   item_objid = fc_cc.ret_objid
 End If

Do the same as above, but have "sa" log it on November 1, 2001. Set a start and end date. Override the price schedule to 1.01 per unit, and use one of the units. Do not have it taxable, but auto-install at site 23. Set site 24 as the serviced at site. Set some other fields, and make this a child line item.

Field version:

Visual Basic:

   Dim ret_int As Integer
   Dim item_objid As Long

   ret_int = fc_cc.cr_contr_itm( "2", "sa", "11/1/2001", "12/1/2001", _
                            "12/31/2001", "Notebook", "Quantity", "", 3, _
                            "Default Schedule", "1.01", 1, "",  False, _
                             True, "A Comment", "23", "24", 268435458, _
                            "", "x_int1", 434, "", 0, "x_a_string", _
                            "string value!!!", "x_another_string", _
                            "other value!!!", "x_date1", "2/2/2001")

   If ret_int = 0 Then
     item_objid = fc_cc.ret_objid
   End If

**List version:**

**Visual Basic:**

Dim ret_int As Integer
Dim log_objid    As Long
Dim fld_list    As New FCFLCOMPAT.FCLIST
Dim type_list   As New FCFLCOMPAT.FCLIST
Dim val_list    As New FCFLCOMPAT.FCLIST

fld_list.AppendItem "x_int1" type_list.AppendItem "Long" val_list.AppendItem Trim(Str$(434))

fld_list.AppendItem "x_a_string" type_list.AppendItem "String" val_list.AppendItem "string value!!!"

fld_list.AppendItem "x_another_string" type_list.AppendItem "String" val_list.AppendItem "other value!!!"

fld_list.AppendItem "x_date1" type_list.AppendItem "Date" val_list.AppendItem "2/2/2001"

ret_int = fc_cc.cr_contr_itm( "2", "sa", "11/1/2001", _ "12/1/2001", "12/31/2001", "Notebook", _ "Quantity", "", 3, "Default Schedule", _ "1.01", 1, "", False, True, "A Comment", _ "23", "24", 268435458, "", _ fld_list, type_list, val_list) If ret_int = 0 Then item_objid = fc_cc.ret_objid End If


delete_sp | fcSDK Documentation

delete_sp

Public Function delete_sp(ByVal sp_objid As Long) As Integer

Description

This API is used to delete a site_part in Clarify, and then unrelate the site_part from all other related records. Several Contracts customers have needed this function, so it was added.

Parameters

Parameter Name | Required? | Description
sp_objid | Yes | Objid of the site_part

Returns

Value | Meaning
0 | No errors
-1 | Could not find the specified site_part

Examples

Delete a site_part with an objid of 268435457.

Visual Basic:

Dim ret_int As Integer

ret_int = fc_cc.delete_sp(268435457)


dispatch_quote | fcSDK Documentation

dispatch_quote

Public Function dispatch_quote(ByVal quote_id As String, _
              ByVal queue_name As String, ByVal disp_date As String, _
              ByVal user_name As String, ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified quote to be dispatched to the specified queue. The quote must be in open condition, and not currently dispatched to a queue. The API allows for the setting of the dispatch date, and the user who dispatched the quote. The API can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
quote_id | Yes | The quote to dispatch
queue_name | Yes | The queue to dispatch to
disp_date | No | When was the quote dispatched. If this parameter is left blank, the quote is dispatched at the current time
user_name | No | The user who dispatched the quote. If left blank, the current user performs the dispatch.
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified quote
-2 | The quote is already dispatched
-3 | The quote is closed and may not be dispatched
-4 | The specified user cannot be found
-5 | The specified new queue name cannot be found
-6 | The DISPATCH activity string is not found with rank = 900
-7 | The specified queue does not allow dispatches of the quote

Examples

Dispatch quote number '154' to queue 'Hardware'. The dispatch is performed by the current user and is dispatched at the current time. Generate a time bomb.

JavaScript:

var ret_int = fc_cc.dispatch_quote("154", "Hardware", "", "", True)

Visual Basic:

Dim ret_int As Integer

ret_int = fc_cc.dispatch_quote("154", "Hardware", "", "", True)

Dispatch quote number 'Q2' at 10PM on November 23rd of 2001 to 'Software'. Dispatch should be logged as performed by user 'sam'. Don't generate a time bomb.

JavaScript:

var ret_int = fc_cc.dispatch_quote("Q2", "Software", "11/23/2001 22:00:00", _
                              "sam", False)

Visual Basic:

Dim ret_int As Integer

ret_int = fc_cc.dispatch_quote("Q2", "Software", "11/23/2001 22:00:00", _
                              "sam", False)


forward_quote | fcSDK Documentation

forward_quote

Public Function forward_quote(ByVal quote_id As String, _
                         ByVal new_queue As String, ByVal forward_date As String, _
                         ByVal note_str As String, ByVal user_name As String, _
                         ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified quote to be reject-forwarded from one queue to another. The object must be in open condition, and currently dispatched to a queue. The API allows for the setting of the forward date, some notes about the forward, and the user who forwarded the object. The API can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
quote_id | Yes | The object to reject-forward
new_queue | Yes | The queue to forward to
forward_date | No | When was the quote forwarded. If this parameter is left blank, the quote is forwarded at the current time
note_str | No | Optional notes about the reject-forward
user_name | No | The user who forwarded the quote. If left blank, the current user performs the forward.
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified quote
-2 | Quote is not currently dispatched
-3 | The new queue name specified is not found
-4 | Reject-forward attempted to same queue as currently dispatched to
-5 | The specified user is not found
-6 | The FORWARD activity string is not found with rank = 1100

Examples

Reject-forward quote number '154' to queue 'Hardware'. The reject-forward has no notes, is performed by the current user and is forwarded at the current time. Generate a time bomb.

JavaScript:

var ret_int = fc_cc.forward_quote("154", "Hardware", "", "", "", True)

Visual Basic:

Dim ret_int As Integer

ret_int = fc_cc.forward_quote("154", "Hardware", "", "", "", True)

Reject-forward quote number 'Q2' at 10PM on November 23rd of 2001 to 'Software'. Forward should be logged as performed by user 'sam', with notes of 'Some notes'. Don't generate a time bomb.

JavaScript:

Var ret_int = fc_cc.forward_quote("Q2", "Software", "11/23/2001 22:00:00", _
                             "Some notes", "sam", False)

Visual Basic:

Dim ret_int As Integer

ret_int = fc_cc.forward_quote("Q2", "Software", "11/23/2001 22:00:00", _
                             "Some notes", "sam", False)


Initialize | fcSDK Documentation

Initialize

Public Sub Initialize(ByRef TheFCApplication As Variant,
                      ByRef TheFCSession As Variant)

Description

This API is called when the FC.CC object is first created. It sets various private parameters of the object and makes it ready to be used for ClearContracts calls

Parameters

Parameter Name | Required? | Description
TheFCApplication | Yes | The FC Application object
TheFCSession | Yes | The FC Session object

Returns

No return values

Examples

JavaScript:

//  Open the FCFLCompat and FCCC objects
FCApp = new ActiveXObject("FCFLCompat.fcapplication");

FCApp.WorkingDirectory =  "C:\\\users\\\first\\\product\\\fcfl\\\error";

FCApp.Initialize();
FCSession = FCApp.CreateSession();
FCSession.Login("sa","sa", "user");
fccc = new ActiveXObject("FCCompatToolkit.CC");
fccc.Initialize(FCApp, FCSession);

Visual Basic:

Dim fc_app     As.FCApplication
Dim fc_session As FCSession
Dim fccc_obj   As FCCompatToolkit.CC

' Open the FCFLCompat and FCCC objects
Set fc_app = New FCApplication
fc_app.Initialize
Set fc_session = fc_app.CreateSession
fc_session.Login "sa", "sa", "user"
Set fccc_obj = New FCCompatToolkit.CC
fccc_obj.Initialize fc_app, fc_session


log_contract_note | fcSDK Documentation

log_contract_note

log_contract_note_list

Public Function log_contract_note(contract_id As String, _
                                 action_type As String, note_str As String, _
                                 int_use As String, log_date As String, _
                                 user_name As String, _
                                 gen_time_bombs As Boolean, _
                                 int_fld1 As String, int_val1 As Long, _
                                 int_fld2 As String, int_val2 As Long, _
                                 str_fld1 As String, str_val1 As String, _
                                 str_fld2 As String, str_val2 As String, _
                                 date_fld1 As String, date_val1 As String _
                                 ) As Integer

Public Function log_contract_note_list(contract_id As String, _
                                      action_type As String, _
                                      note_str As String, _
                                      int_use As String, _
                                      log_date As String, _
                                      user_name As String, _
                                      gen_time_bombs As Boolean, _
                                      Optional fld_list As Variant, _
                                      Optional type_list As Variant, _
                                      Optional val_list As Variant) As Integer

Description

This API causes a note log to be create and added to the specified contract. It does it in the name of the user given and allows the setting of user. It allows the setting of optional fields on the notes_log record with the optional list parameters.

Parameters

Parameter Name | Required? | Description
contract_id | Yes | The contract to add the note to
action_type | No | The note log action type taken from the "Note Log Action Type" list. If the field is not specified, the default from the list is used.
note_str | Yes | The note to attach to the contract
int_use | Yes | Whether note is internal only (=1) or general viewing (=0)
log_date | No | Date/time of the note (default is the current time)
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | Specified contract not found
-2 | Specified user not found
-3 | Cannot find the activity string with rank = 1700 ("Notes")
-4 | Cannot find the specified log action type
-5 | Cannot find employee record for the user
ret_objid | objid of the created notes log record

Examples

Move quote number '154' to the default WIPBin for the current owner.

JavaScript:

Var ret_int = log_contract_note("Ace contract","","They want to add stuff",
                      1,"","",true,"",0,"",0,"","","","","","")

Visual Basic:

Dim ret_int As Integer

ret_int = log_contract_note("Ace contract","","They want to add stuff",
                      1,"","",true,"",0,"",0,"","","","","","")


move_quote | fcSDK Documentation

move_quote

Public Function move_quote(ByVal quote_id As String, _
                           ByVal new_wipbin As String) As Integer

Description

This API causes the specified quote to be moved from one WIPBin to another WIPBin. The new WIPBin must belong to the same user as the first WIPBin. The move operation does not change the ownership of the quote, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable quote from one WIPBin to another, even if the quote is currently dispatched. Since WIPBins are internal to a user, there really is no reason that you shouldn't be able to move the interal (to a user) location of the quote. This is an enhancement to base Clarify function, which requires that the quote not be dispatched to be moved.

Parameters

Parameter Name | Required? | Description
quote_id | Yes | The quote to move
new_wipbin | Yes | The WIPBin to move the quote to. If left blank, the quote is moved to the user's default WIPBin

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified quote
-2 | Quote is already closed
-3 | New WIPBIN doesn't exist, or isn't for the owner
-4 | New WIPBIN is same as old - no move needed

Examples

Move quote number '154' to the default WIPBin for the current owner.

JavaScript:

var ret_int = fc_cc.move_quote("154", "")

Visual Basic:

Dim ret_int As Integer

ret_int = fc_cc.move_quote("154", "")

Move quote number 'Q2' to WIPBin 'Urgent'.

JavaScript:

var ret_int = fc_cc.move_quote("Q2", "Urgent")

Visual Basic:

Dim ret_int As Integer

ret_int = fc_cc.move_quote("Q2", "Urgent")


reject_contract | fcSDK Documentation

reject_contract

Public Function reject_contract(ByVal contract_id As String, _
                           ByVal status_str As String, ByVal notes_str As String, _
                           ByVal user_name As String, ByVal reject_date As String, _
                           ByVal gen_time_bombs As Boolean) As Integer

Description

This API is used to reject quotes (close them) in ClearContracts. The API accepts the contract ID, the new status (in Closed Contract condition), and optional notes. The user performing the reject, and the date/time of the reject can also be specified. The API can also either generate time bombs (for business rule notification) or not, based on the last argument.

Parameters

Parameter Name | Required? | Description
contract_id | Yes | ID number of the contract/quote to reject
status_str | No | New status of the closed contract. If blank, the default statusfor Closed Contract condition will be used.
Notes_str | No | Optional notes to add for the reject
user_name | No | The user performing the reject. If blank, the current user is used
reject_date | No | When is the reject taking place? If blank, the current date/time is used
gen_time_bomb | Yes | Should a time_bomb be added for the action?

Returns

Value | Meaning
0 | No errors
-1 | Contract specified could not be found
-2 | The contract is not in the right condition (Quote) to be rejected
-3 | The contract is currently dispatched - cannot be rejected
-4 | Cannot find the specified user
-5 | The specified status is not valid for the Closed Contract condition
-6 | Cannot find the activity record for "Quote Reject" with rank = 13800
-7 | Employee record not found for specified user

Examples

Joe rejected contract '42' on January 1st with some notes, and put it in status 'Customer bankrupt." Generate a time bomb.

JavaScript:

Var ret_int = fc_cc.reject_contract("42", "Customer bankrupt", "Some notes", _
                                  "Joe", "1/1/99 8:00:00", True)

Visual Basic:

Dim ret_int    As Integer
ret_int = fc_cc.reject_contract("42", "Customer bankrupt", "Some notes", _
                                  "Joe", "1/1/99 8:00:00", True)

The current user rejects contract '33' at the current date and time. Use the default status, and nothing else is added, and don't add a time bomb.

JavaScript:

var ret_int = fc_cc.reject_contract("33", "", "", "", "", False)

Visual Basic:

Dim ret_int    As Integer

ret_int = fc_cc.reject_contract("33", "", "", "", "", False)


reject_quote | fcSDK Documentation

reject_quote

Public Function reject_quote(ByVal quote_id As String, _
                    ByVal reject_date As String, ByVal wipbin_name As String, _
                    ByVal note_str As String, ByVal user_name As String, _
                    ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified quote to be rejected from the queue it is in, and returned back to the owner. The quote must be in open condition and currently dispatched to a queue. The API allows setting of the reject date, some notes about the reject, and the user who rejected the quote. The API also allows you to set the WIPBin that the quote is placed back in. This is additional functionality that base Clarify does not provide. The API can also generate a time bomb (for business rule notification). Note: This is not the same as the "reject_contract" API, which causes the selected contract to be rejected as a valid contract.

Parameters

Parameter Name | Required? | Description
quote_id | Yes | The quote to reject-forward
reject_date | No | When was the quote rejected. If this parameter is left blank, the quote is rejected at the current time
wipbin_name | No | The WIPBin to place the quote in. If left blank, the default WIPBin is used
note_str | No | Optional notes about the reject
user_name | No | The user who rejected the quote. If left blank, the current user performs the reject.
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified quote
-2 | The quote is not currently dispatched
-3 | Cannot find the specified user
-4 | The quote is currently closed - cannot dispatch
-5 | Cannot find the new specified WIPBIN, or it is not a WIPBIN for the specified user
-6 | Cannot find REJECT activity string with rank = 2600

Examples

Reject quote number '154' to the default WIPBin. The reject has no notes, is performed by the current user and is rejected at the current time. Generate a time bomb.

JavaScript:

var ret_int = fc_cc.reject_quote("154", "", "", "", "", True)

Visual Basic:

Dim ret_int As Integer

ret_int = fc_cc.reject_quote("154", "", "", "", "", True)

Reject quote number 'Q2' at 10PM on November 23rd of 2001 to WIPBin 'East'. Reject should be logged as performed by user 'sam', with notes of 'Some notes'. Don't generate a time bomb.

JavaScript:

var ret_int = fc_cc.reject_quote("Q2", "11/23/2001 22:00:00", "East", _
                                "Some notes", "Sam", False)

Visual Basic:

Dim ret_int As Integer

ret_int = fc_cc.reject_quote("Q2", "11/23/2001 22:00:00", "East", _
                                "Some notes", "Sam", False)


relate_contr_itm_to_sp | fcSDK Documentation

relate_contr_itm_to_sp

Public Function relate_contr_itm_to_sp(ByVal contr_objid As Long, _
                ByVal part_num As String, ByVal domain As String, _
                ByVal rev As String, ByVal serial_num As String) As Integer

Description

This API is used to relate (or unrelate) a site_part from a contract line item. The line item's objid is specified, along with the details for locating the site_part. To unrelate the contract item from a site_part, use the phrase "UNRELATE" in the serial_num field.

Parameters

Parameter Name | Required? | Description
contr_objid | Yes | Objid of the contract line item
part_num | No | Part number of site_part to relate
domain | No | Domain of site_part to relate
rev | No | Part revision of site_part to relate
serial_num | Yes | Serial number of site_part to relate. To unrelate, use UNRELATE

Returns

Value | Meaning
0 | No errors
-1 | Could not find the specified contract line item
-2 | No Site Parts Related to Specified Contract Item
-3 | Could not find the specified site_part

Examples

Relate a contract line item with 'MS Word version 6.0', serial number 'ABC'.

Field version:

JavaScript:

Var ret_int = fc_cc.relate_contr_itm_to_sp(268435457, "MS Word", "Product", _
                                        "6.0", "ABC")

Visual Basic:

Dim ret_int As Integer

ret_int = fc_cc.relate_contr_itm_to_sp(268435457, "MS Word", "Product", "6.0", "ABC")

Unrelate that same contract line item.

JavaScript:

var ret_int = fc_cc.relate_contr_itm_to_sp(268435457, "", "", "", "UNRELATE")

Visual Basic:

Dim ret_int As Integer

ret_int = fc_cc.relate_contr_itm_to_sp(268435457, "", "", "", "UNRELATE")


reopen_contract | fcSDK Documentation

reopen_contract

Public Function reopen_contract(ByVal contract_id As String, _
                ByVal wipbin_name As String, ByVal status_str As String, _
                ByVal reopen_date As String, ByVal user_name As String, _
                ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified contract to be reopened. This is augmented functionality from base Clarify, as a contract cannot be re-opened via the Clarify GUI. The date/time of the reopen, the person performing the reopen, the WIPBIN to place the contract in, and the new status of the contract can be specified. The person who reopens the contract becomes the new owner. The WIPBin to place the contract in may also be specified. If it is not, the contract is placed in the user's default WIPBIN. If the status is not specified, the case is placed in the default status for the Active Contract condition. The API can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
contract_id | Yes | The contract to reopen
wipbin_name | No | The WIPBin to place the contract in. If left blank, the default WIPBin for the user is used
status_str | No | The new status for the contract. If no status is specified, the default status for Active Contract Condition is used
reopen_date | No | When was the contract reopened. If this parameter is left blank, the reopen occurs at the current time
user_name | No | The user who reopened the contract. If left blank, the current user performs the reopen.
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified contract
-2 | The contract is not closed
-3 | Cannot find the specified user
-4 | Cannot find the specified WIPBIN
-5 | Cannot find the REOPEN activity string with rank = 2400
-6 | Cannot find the specified status
-7 | Employee record not found for specified user

Examples

Reopen contract number 'C154' by the current user at the current date/time. Place in the default WIPBin with the default status, and generate a time bomb.

JavaScript:

var ret_int = fc_cc.reopen_contract("C154", "", "", "", "", True)

Visual Basic:

Dim ret_int As Integer

ret_int = fc_cc.reopen_contract("C154", "", "", "", "", True)

Reopen contract number '2' at 10PM on November 23rd of 2001 by user 'sam'. Place in sam's WIPBin 'Urgent', with status 'User Error'. Don't generate a time bomb.

JavaScript:

var ret_int = fc_cc.reopen_contract("2", "Urgent", "User Error", _
                               "11/23/2001 22:00:00", "sam", False)

Visual Basic:

Dim ret_int As Integer

ret_int = fc_cc.reopen_contract("2", "Urgent", "User Error", _
                               "11/23/2001 22:00:00", "sam", False)


yank_quote | fcSDK Documentation

yank_quote

Public Function yank_quote(ByVal quote_id As String, _
        ByVal wipbin_name As String, ByVal yank_date As String, _
        ByVal user_name As String, ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified quote to be yanked from the current location to a new owner's WIPBin. The date/time of the yank, and the person yanking the quote are specified. The person who yanks the quote becomes the new owner. The WIPBin to place the quote in may also be specified. This is augmented function from base Clarify, where the quote is always placed in the default WIPBin. The API can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
quote_id | Yes | The quote to yank
wipbin_name | No | The WIPBin to place the quote in. If left blank, the default WIPBin for the user is used
yank_date | No | When was the quote yanked. If this parameter is left blank, the yank occurs at the current time
user_name | No | The user who yanked the quote. If left blank, the current user performs the yank.
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified quote
-2 | The quote is already closed
-3 | Cannot find the specified user
-4 | Cannot find the specified WIPBIN
-5 | Cannot find the YANK activity string with rank = 4100

Examples

Yank quote number '154' by the current user at the current date/time. Place in the default WIPBin, generate a time bomb.

JavaScript:

var ret_int = fc_cc.yank_quote("154", "", "", "", True)

Visual Basic:

Dim ret_int As Integer

ret_int = fc_cc.yank_quote("154", "", "", "", True)

Yank quote number 'Q2' at 10PM on November 23rd of 2001 by user 'sam'. Place in sam's WIPBin 'Urgent'. Don't generate a time bomb.

JavaScript:

var ret_int = fc_cc.yank_quote("Q2", "Urgent", "11/23/2001 22:00:00", "sam", False)

Visual Basic:

Dim ret_int As Integer

ret_int = fc_cc.yank_quote("Q2", "Urgent", "11/23/2001 22:00:00", "sam", False)


ret_id_num | fcSDK Documentation

ret_id_num

Prototype

Public ret_id_num As String

Description

Contains the ID number (not the objid) of the specific object created after a call to certain API function. Not all functions will populate this value.

Please see the documentation of the particular API function for information on whether or not it sets the value of this property after it completes.


ret_objid | fcSDK Documentation

ret_objid

Prototype

Public ret_objid As Long

Description

Contains the objid of the object recently created or updated as the result of the recent API function call. Not all functions set this property value.

Please see the documentation of the particular API function for information on whether or not it sets the value of this property after it completes.


ret_num | fcSDK Documentation

ret_num

Prototype

Public ret_num As Integer

Description

Contains a number relevant to the recently-invoked API function. Not all functions will populate this value.

Please see the documentation of the particular API function for information on whether or not it sets the value of this property after it completes and, if it does, what format it is in and what it represents.


ret_string | fcSDK Documentation

ret_string

Prototype

Public ret_string As String

Description

Contains a specifically-formatted string related to the recent function call. Not all functions set this property value.

Please see the documentation of the particular API function for information on whether or not it sets the value of this property after it completes and, if it does, what the format of string value of this property will be.


FCFL API Toolkit for ClearLogistics | fcSDK Documentation

FCFL API Toolkit for ClearLogistics

Overview

Many customers have wanted the ability to customize the Clarify environment easily by adding base Clarify functions (such as part request creation, closure, modification, or note logging) into web applications.

The First Choice Software FCFL API Toolkit for Clear Logistics solves these problems, as well as many others. The toolkit is a set of FCFL functions that you may call from your applications.

All of the APIs perform the same base functions as the Clarify GUI - all database records are properly written, activity logs are generated to track the API call, and time bombs are added to the system so that business rules can be fired based on the API function call.

While all of the APIs mimic the Clarify base function, many of them provide augmented functionality that Clarify customers have requested. For example, the base Clarify yank function always places the object in the user's default WIPBin. With the yank APIs in the toolkit, you have the choice of placing the object in any specific WIPBin for the user, or in the default WIPBin.

The APIs are simple to use. One simple API call is provided for each function, and very few data values must be supplied. The APIs are flexible in that they provide a large number of optional arguments that allow you to customize the API calls as needed.


accept_pr | fcSDK Documentation

accept_pr

Public Function accept_pr(ByVal pr_id As String, _
      ByVal accept_date As String, ByVal wipbin_name As String, _
      ByVal user_name As String, ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified part request to be accepted from a dispatched queue. The part request must be currently dispatched to a queue. The date/time of the accept, the WIPBin to place the case in, and the user performing the accept can be specified. The API can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
pr_id | Yes | The part request to accept
accept_date | No | When was the part request accepted. If this parameter is left blank, the PR is accepted at the current time
wipbin_name | No | The WIPBin to place the part request in (for the user who accepted PR) If left blank, the part request is placed in the user's default WIPBin
user_name | No | The user who accepted the PR. If left blank, the current user performs the accept
gen_time_bombs | Yes | Should a time_bomb be generated

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified part request
-2 | Part request is not currently in a queue
-3 | Specified user is not a member of the queue
-4 | The specified WIPBIN is not valid for the user
-5 | Could not find gbst_elm string for ACCEPT with rank 100

Examples

Accept PR number '1-14' right now for the current user, place in the default WIPBin, and generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.accept_pr("1-14", "", "", "", True)

JavaScript:

var ret_int = fccl.accept_pr("1-14", "", "", "", true);

Accept part request number '2-1' at 10PM on November 23rd of 2001 by marty, and place the part request in marty's WIPBin named 'Urgent'. Don't generate a time bomb

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.accept_pr("2-1", "11/23/2001 22:00:00", "Urgent", "marty", False)

JavaScript:

ret_int = fccl.accept_pr("2-1", "11/23/2001 22:00:00", "Urgent", "marty", false)


add_alt_part | fcSDK Documentation

add_alt_part

Public Function add_alt_part(ByVal part_num As String, ByVal rev As String, _
                                 ByVal domain As String, ByVal alt_part As String, _
                         ByVal alt_rev As String, ByVal alt_domain As String, _
                                      ByVal is_reciprocal As Boolean) As Integer

Description

This API causes the second part/revision listed to become an alternate part of the first one listed. If the is_reciprocal flag is set to True, then the first part/rev will also be added as an alternate of the second part/rev.

Parameters

Parameter Name | Required? | Description
part_num | Yes | The primary part number
rev | Yes | The primary part revision
domain | Yes | The domain of the primary part
alt_part | Yes | The part number of the alternate part
alt_rev | Yes | The revision of the alternate part
alt_domain | Yes | The domain of the alternate part
is_reciprocal | Yes | Should the first part/rev be made an alternate of the second part as well? (True), or not (False)

Returns

Value | Meaning
0 | No errors
-1 | Primary part number is missing
-2 | Primary domain is missing
-3 | Alternate part number is missing
-4 | Alternate domain is missing
-5 | Primary part/revision cannot be found
-6 | Alternate part/revision cannot be found
-7 | The second part is already an alternate for the first

Examples

Make WordPerfect 7.0 an alternate part for MS Word 7.0, but not the other way around.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.add_alt_part("MS Word", "7.0", "Product", "WordPerfect", _
                            "7.0", "Product", False)

JavaScript:

var ret_int = fccl.add_alt_part("MS Word", "7.0", "Product", "WordPerfect",
                            "7.0", "Product", false);

Do the same, but make the assignment reciprocal.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.add_alt_part("MS Word", "7.0", "Product", "WordPerfect", _
                            "7.0", "Product", True)

JavaScript:

var ret_int = fccl.add_alt_part("MS Word", "7.0", "Product", "WordPerfect",
                            "7.0", "Product", true);


add_gl_account | fcSDK Documentation

add_gl_account

Public Function add_gl_account(ByVal acct_name As String, _
           ByVal account_type As String, ByVal desc_str As String, _
           ByVal account_no As String, ByVal is_exp As Boolean, _
           ByVal is_active As Boolean, ByVal is_company As Boolean, _
           ByVal site_id As String) As Integer

Description

This API is used to add expense and capital GL accounts to Clarify. The account name, description and account number are specified. Using the boolean flags the account can be made into capital or expense, active or inactive, company or customer owned. The site for the account must be specified, and the account type can be set from the code list.

Parameters

Parameter Name | Required? | Description
acct_name | Yes | Name of the GL account
account_type | No | Type of account from the code list. If blank, the default value is used
desc_str | No | The description of the account
account_no | No | Optional account number
is_exp | Yes | Is this an expense account (True), or capital (False)
is_active | Yes | Is the account active (True) or inactive (False)
is_company | Yes | Is it company owned (True) or customer owned (False)
site_id | Yes | The site for the account

Returns

Value | Meaning
0 | No errors
-1 | Missing site id parameter
-2 | Missing acct_name parameter
-4 | The supplied site was not found
-6 | The account name already exists in the database
-7 | Location (expense/capital) type value not found
-8 | Account type value not valid for the type of account (expense/capital)
-9 | The 'From' account name already exists in the database

Examples

Add an expense GL account with no account type, a description, an account number. It is active and company owned, and for site 1.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.add_gl_account("myaccount", "", "A description", "1234", _
                              True, True, True, "1")

JavaScript:

var ret_int = fccl.add_gl_account("myaccount", "", "A description", "1234",
                              true, true, true, "1");

Add a capital GL account with no account type, a description, an account number. It is inactive and customer owned, and for site 1.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.add_gl_account("myaccount1", "", "A description", "1234", _
                              False, False, False, "1")

JavaScript:

var ret_int = fccl.add_gl_account("myaccount1", "", "A description", "1234",
                              false, false, false, "1");


add_inv_bin | fcSDK Documentation

add_inv_bin

Public Function add_inv_bin(ByVal bin_name As String, _
        ByVal loc_name As String, ByVal is_active As Boolean)

Description

This API is used to add inventory bins to existing locations. The bin name can be set, as well as if it is an active bin or not.

Parameters

Parameter Name | Required? | Description
bin_name | Yes | The name of the new inventory bin
loc_name | Yes | Name of the inventory location where the bin is located
is_active | Yes | Is the bin active (True) or inactive (False)

Returns

Value | Meaning
0 | No errors
-1 | Missing bin name parameter
-3 | Missing location name parameter
-4 | The specified location is not found
-5 | The bin name already exists at that location
ret_objid | Output - Returns the objid of the newly created inventory bin

Examples

Add a bin at the "Austin" site named "Bin 42". It is active

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.add_inv_bin("Bin 42", "Austin", True)

JavaScript:

var ret_int = fccl.add_inv_bin("Bin 42", "Austin", true);

Add an inactive bin named "Bin ABZ" in San Jose.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.add_inv_bin("Bin ABZ", "San Jose", False)

JavaScript:

var ret_int = fccl.add_inv_bin("Bin ABZ", "San Jose", false);


add_inv_location | fcSDK Documentation

add_inv_location

Public Function add_inv_location(ByVal loc_name As String, _
           ByVal account_type As String, ByVal desc_str As String, _
           ByVal reports_to_loc As String, ByVal cap_gl_acct As String, _
           ByVal is_active As Boolean, ByVal is_company As Boolean, _
           ByVal site_id As String, ByVal trans_auth_str As String) As Integer

Description

This API is used to add inventory locations to the system. The location name, capital GL account, and site must be specified. The active and company flags are set to determine the disposition of the account. Optionally, a description and reports to location (which is the location name of another inventory location) can be specified. The account type (for inventory locations) can be specified from the code list.

The trans authority determines part authorization levels, and has three possible values: none, all, auth parts only.

Parameters

Parameter Name | Required? | Description
loc_name | Yes | Name of the inventory location
account_type | No | Code list value. If blank, default value is used
desc_str | No | Description of the inventory location
reports_to_loc | No | The location name of the parent inventory location (if any)
cap_gl_acct | Yes | The name of the capital account for this location
is_active | Yes | Is the location active (True) or inactive (False)
is_company | Yes | Is the location company owned (True) or customer (False)
site_id | Yes | The location of the inventory location
trans_auth_str | Yes | One of the following values: none, all, auth parts only

Returns

Value | Meaning
0 | No errors
-1 | Missing site id parameter
-3 | Missing loc_name parameter
-4 | The supplied site was not found
-6 | The location name already exists in the database
-7 | Location type is not valid from the code list
-8 | Missing capital gl account name
-9 | The specified reports to location is not found in the database
-10 | Invalid trans_auth string
-11 | Capital GL account does not exist
ret_objid | Output - Returns the objid of the newly created inventory location

Examples

Add a new location named Buda. Assign a capital GL account to it, put it as site "1", and make it active and company owned. Allow only authorized parts.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.add_inv_location("Buda", "", "Rocket parts", "", _
                  "CAPGL", True, True, "1", "auth parts only")

JavaScript:

var ret_int = fccl.add_inv_location("Buda", "", "Rocket parts", "",
                  "CAPGL", true, true, "1", "auth parts only");

Add another location that is customer owned, inactive, and reports to Austin. Do not allow parts auths.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.add_inv_location("Houston", "", "Rocket parts", "Austin", _
                  "CAPGL", False, False, "1", "none")

JavaScript:

var ret_int = fccl.add_inv_location("Houston", "", "Rocket parts", "Austin",
                  "CAPGL", false, false, "1", "none");


add_lss | fcSDK Documentation

add_lss

Public Function add_lss(ByVal site_id As String, _
                        ByVal loc_name As String, ByVal is_active As Boolean, _
                        ByVal loc_rank As Integer) As Integer

Description

This API is used to relate sites to the inventory locations that service them. The site and location must be specified, and the rank (from 1 upwards) of the order in which the locations service the site. The active flag denotes if the servicing is currently active.

Parameters

Parameter Name | Required? | Description
site_id | Yes | Name of the site to be serviced
loc_name | Yes | Name of the servicing location
is_active | Yes | Is the servicing active?
loc_rank | Yes | Which servicing location is this. Ranks start at 1 and increase

Returns

Value | Meaning
0 | No errors
-1 | Site parameter value missing
-2 | Location parameter value missing
-3 | Invalid edit_type (not 0, 1, or 2). Internal error - should never be seen
-4 | Servicing record already exists
-6 | The specified site was not found
-7 | The specified location not found
-8 | New rank is greater than total number of items already in the list
ret_objid | Output - Returns the objid of the [newly created] service location

Examples

Austin should service site 1 first.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.add_lss("1", "Austin", True, 1)

JavaScript:

var ret_int = fccl.add_lss("1", "Austin", true, 1);

Houston should service site 1 next.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.add_lss("1", "Houston", True, 2)

JavaScript:

var ret_int = fccl.add_lss("1", "Houston", true, 2);


assign_pr | fcSDK Documentation

assign_pr

Public Function assign_pr(ByVal pr_id As String, _
                          ByVal new_user As String, ByVal wipbin_name As String, _
                          ByVal assign_date As String, ByVal user_name As String, _
                          ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified part request to be assigned to a new user. The part request must not be in closed condition, and the user assigning the part request does not have to be the owner. In base Clarify, the assigner of a part request must be the owner. If either user name is not specified, the "current" user is used. The date/time of the assignment, and the WIPBin to place the part request in can also be specified. Allowing a WIPBin other than the default one is also an augmentation from base Clarify. The API can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
pr_id | Yes | The part request to assign
new_user | No | The user who the part request is assigned to. If left blank, it is assigned to the current user
wipbin_name | No | The WIPBin to place the part request in (for the user who is assigned the part request). If left blank, it is placed in the user's default WIPBin
assign_date | No | When was the part request assigned. If this parameter is left blank, it is assigned at the current time
user_name | No | The user who assigned the part request. If left blank, the current user performs the assign
gen_time_bombs | Yes | Should a time_bomb be generated

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified part request
-2 | The specified part request is currently closed
-3 | Specified user (to assign to) is not found
-4 | The specified WIPBIN is not valid for the user
-5 | Specified user (who performed the assign) is not found
-6 | Could not find gbst_elm string for ASSIGN with rank 10500

Examples

Assign part request number '154-1' to user 'marty'. The assign is performed by the current user, is placed in the default WIPBin and is assigned at the current time. Generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.assign_pr("154-1", "marty", "", "", "", True)

JavaScript:

var ret_int = fccl.assign_pr("154-1", "marty", "", "", "", true);

Assign part request number '2-4' at 10PM on November 23rd of 2001 to marty, and place the part request in marty's WIPBin named 'Urgent'. Assign should be logged as performed by sam. Don't generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.assign_pr("2-4", "marty", "Urgent", "11/23/01 22:00:00", _
                        "sam", False)

JavaScript:

var ret_int = fccl.assign_pr("2-4", "marty", "Urgent", "11/23/01 22:00:00",
                        "sam", false);


change_pr_status | fcSDK Documentation

change_pr_status

Public Function change_pr_status(ByVal pr_id As String, _
                                 ByVal new_status As String, ByVal change_date As String, _
                                 ByVal note_str As String, ByVal user_name As String, _
                                 ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified part request to have a status change from one status to another status - always in the same condition. To change the condition of the part request, use one of the supplied APIs such as receive or pick. You may specify a new status (or blank for the default status), some notes for the change, the user who performed the status change, and when the status change occurred. Also, the API allows for time bombs (for business rules) to be created.

Parameters

Parameter Name | Required? | Description
pr_id | Yes | The part request to reject
new_status | No | The new status. If blank, the default status for the condition is used
change_date | No | When did the status change occur. If left blank, current time is used
note_str | No | Notes about the status change
user_name | No | Who performed the status change? If left blank, current user is used
gen_time_bombs | Yes | Should a time bomb record be created for business rule notification?

Returns

Value | Meaning |
0 | No errors |
-1 | Cannot find the specified part request |
-2 | Cannot find the new status (or status is not defined for the current | object's condition)
-3 | Cannot find the specified user |
-4 | Cannot find the CHG STATUS activity string with rank = 300 |
-5 | The employee record for the specified user cannot be found |

Examples

Joe changed the status of part request '1-14' to "Warehouse" on July 1 at noon. Generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.change_pr_status("1-14", "Warehouse", "7/1/2001 12:00:00", _
                               "Some notes", "joe", True)

JavaScript:

var ret_int = fccl.change_pr_status("1-14", "Warehouse", "7/1/2001 12:00:00",
                               "Some notes", "joe", true);

Change the status of part request number '2-1' to the default status. Do not generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.change_pr_status("2-1", "", "", "", "", False)

JavaScript:

var ret_int = fccl.change_pr_status("2-1", "", "", "", "", false);


close_pr | fcSDK Documentation

close_pr

Public Function close_pr(ByVal pr_id As String, _
                         ByVal new_status As String, ByVal close_date As String, _
                         ByVal user_name As String, ByVal gen_time_bombs As Boolean) _
                         As Integer

Description

This API causes the specified part request to be closed. This is a transition to condition closed, and the API will validate that the user has the authority to close the part request. The API also allows the user who performed the close and the date/time of the close to be set. In addition, the status of the part request (in closed condition) can be specified. The API can also generate a time bomb (for business rule notification). If this is the last part request detail that was open for the part request header, the header is also closed.

Parameters

Parameter Name | Required? | Description
pr_id | Yes | The part request to close
new_status | No | The (closed condition) status of the part request. If blank, the default close condition status is used
close_date | No | When was the part request closed. If this parameter is left blank, it is closed at the current time
user_name | No | The user who closed the part request. If left blank, the current user performs the close
gen_time_bombs | Yes | Should a time_bomb be generated

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified part request
-2 | The part request is already closed
-3 | Cannot find the specified user
-4 | Cannot find the CLOSE activity string with rank = 11500
-5 | The transition to CLOSED condition does not exist
-6 | The user is not authorized to make the transition to CLOSED condition
-7 | The new status is not found for CLOSED condition
-8 | The part request is currently dispatched to a queue
-9 | The employee record for the specified user cannot be found

Examples

Close part request '154-1'. Jack closed it on February 10th, and it should be put in status "Really closed". Generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.close_pr("154-1", "Really closed", "2/10/2001 14:50:00", _
    "jack", True)

JavaScript:

var ret_int = fccl.close_pr("154-1", "Really closed", "2/10/2001 14:50:00",
    "jack", true);

Current user closes part request '2-33'. Don't generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.close_pr("2-33", "", "", "", False)

JavaScript:

var ret_int = fccl.close_pr("2-33", "", "", "", false);


create_container | fcSDK Documentation

create_container

Public Function create_container(ByVal cont_name As String, _
                                 ByVal the_loc As String, ByVal bin_name As String, _
                                 ByVal parent_cont As String) As Integer

Description

This API creates a new container object. It will be installed at the specified location, either in the bin provided, or under the container specified.

Parameters

Parameter Name | Required? | Description
cont_name | Yes | Name of the container to create
the_loc | No | Location to create at (if under a bin)
bin_name | No | Bin to create the container in
parent_cont | No | Parent container name

Returns

Value | Meaning
0 | No errors
-1 | Cannot specify both a bin name and container name
-2 | Container name is already used
-3 | Cannot find the specified parent container
-4 | Parent container is currently sealed
-5 | Cannot find the specified inventory location
-6 | Cannot find the specified bin
ret_objid | Output - Returns the objid of the newly created container

Examples

Create a new container, Joe at Austin, Bin 1.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.create_container("Joe", "Austin", "Bin 1", "")

JavaScript:

var ret_int = fccl.create_container("Joe", "Austin", "Bin 1", "");

Create a new container, Joe under container Fred.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.create_container("Joe", "", "", "Fred")

JavaScript:

var ret_int = fccl.create_container("Joe", "", "", "Fred");


delete_alt_part | fcSDK Documentation

delete_alt_part

Public Function delete_alt_part(ByVal part_num As String, _
                                ByVal rev As String, ByVal domain As String, _
                                ByVal alt_part As String, ByVal alt_rev As String, _
                                ByVal alt_domain As String) As Integer

Description

This API causes the second part/revision listed to be removed as an alternate part for the first.

Parameters

Parameter Name | Required? | Description
part_num | Yes | The primary part number
rev | Yes | The primary part revision
domain | Yes | The domain of the primary part
alt_part | Yes | The part number of the alternate part
alt_rev | Yes | The revision of the alternate part
alt_domain | Yes | The domain of the alternate part

Returns

Value | Meaning
0 | No errors
-1 | Primary part number is missing
-2 | Primary domain is missing
-3 | Alternate part number is missing
-4 | Alternate domain is missing
-5 | Primary part/revision cannot be found
-6 | Alternate part/revision cannot be found
-7 | The second part is not an alternate part for the first

Example

Remove WordPerfect 7.0 as an alternate part for MS Word 7.0.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.delete_alt_part("MS Word", "7.0", "Product", "WordPerfect", _
                              "7.0", "Product")

JavaScript:

var ret_int = fccl.delete_alt_part("MS Word", "7.0", "Product", "WordPerfect",
                              "7.0", "Product");


delete_lss | fcSDK Documentation

delete_lss

Public Function delete_lss(ByVal site_id As String, _
                           ByVal loc_name As String) As Integer

Description

This API is used to remove the relationship between a site and a location servicing it. All of the other locations that service this site will have their ranks changed as necessary.

Parameters

Parameter Name | Required? | Description
site_id | Yes | Name of the site to be serviced
loc_name | Yes | Name of the servicing location

Returns

Value | Meaning
0 | No errors
-1 | Site parameter value missing
-2 | Location parameter value missing
-3 | Invalid edit_type (not 0, 1, or 2). Internal error - should never be seen
-4 | Servicing record does not exist
-5 | No change is needed for this rank
-6 | The specified site was not found
-7 | The specified location not found

Examples

Austin should not service site 1 any more.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.delete_lss("1", "Austin")

JavaScript:

var ret_int = fccl.delete_lss("1", "Austin");

Houston shouldn't service site 1 either.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.delete_lss("1", "Houston")

JavaScript:

var ret_int = fccl.delete_lss("1", "Houston");


dispatch_pr | fcSDK Documentation

dispatch_pr

Public Function dispatch_pr(ByVal pr_id As String, _
                            ByVal queue_name As String, ByVal disp_date As String, _
                            ByVal user_name As String, ByVal gen_time_bombs As Boolean) _
                            As Integer

Description

This API causes the specified part request to be dispatched to the specified queue. The part request must be in open condition, and not currently dispatched to a queue. The API allows for the setting of the dispatch date, and the user who dispatched the part request. The API can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
pr_id | Yes | The part request to dispatch
queue_name | Yes | The queue to dispatch to
disp_date | No | When was the part request dispatched. If this parameter is left blank, the PR is dispatched at the current time
user_name | No | The user who dispatched the part request. If left blank, the current user performs the dispatch.
gen_time_bombs | Yes | Should a time_bomb be generated

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified part request
-2 | The part request is already dispatched
-3 | The part request is closed and may not be dispatched
-4 | The specified user cannot be found
-5 | The specified new queue name cannot be found
-6 | The DISPATCH activity string is not found with rank = 900
-7 | The specified queue does not allow dispatches of part requests

Examples

Dispatch part request number '1-14' to queue 'Hardware'. The dispatch is performed by the current user and is dispatched at the current time. Generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.dispatch_pr("1-14", "Hardware", "", "", True)

JavaScript:

var ret_int = fccl.dispatch_pr("1-14", "Hardware", "", "", true);

Dispatch part request number '2-1' at 10PM on November 23rd of 2001 to 'Software'. Dispatch should be logged as performed by Nancy. Don't generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.dispatch_pr("2-1", "Software", "11/23/01 22:00:00", _
                       "nancy", False)

JavaScript:

var ret_int = fccl.dispatch_pr("2-1", "Software", "11/23/01 22:00:00",
                       "nancy", false);


forward_pr | fcSDK Documentation

forward_pr

Public Function forward_pr(ByVal pr_id As String, _
                           ByVal new_queue As String, ByVal forward_date As String, _
                           ByVal note_str As String, ByVal user_name As String, _
                           ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified part request to be rejected from the current queue, and forwarded to another queue. The part request must be dispatched to a queue, and the specified new queue must be valid. The API allows for the setting of the forward date, and the user who forwarded the part request. The API can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
pr_id | Yes | The part request to dispatch
queue_name | Yes | The queue to forward to
forward_date | No | When was the part request forwarded. If this parameter is left blank, the PR is forwarded at the current time
note_str | No | Optional notes about the forward
user_name | No | The user who forwarded the part request. If left blank, the current user performs the forward.
gen_time_bombs | Yes | Should a time_bomb be generated

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified part request
-2 | Part request is not currently dispatched
-3 | The new queue name specified is not found
-4 | Reject-forward attempted to same queue as currently dispatched to
-5 | The specified user is not found
-6 | The FORWARD activity string is not found with rank = 1100

Examples

Forward part request number '1-14' to queue 'Hardware'. The forward is performed by the current user and is dispatched at the current time. Generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.forward_pr("1-14", "Hardware", "", "", "", True)

JavaScript:

var ret_int = fccl.forward_pr("1-14", "Hardware", "", "", "", true);

Forward part request number '2-1' at 10PM on November 23rd of 2001 to 'Software'. Forward should be logged as performed by Nancy. Add some notes. Don't generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.dispatch_pr("2-1", "Software", "11/23/01 22:00:00", _
                          "Notes about forward", "nancy", False)

JavaScript:

var ret_int = fccl.dispatch_pr("2-1", "Software", "11/23/01 22:00:00",
                          "Notes about forward", "nancy", false);


fulfill | fcSDK Documentation

fulfill

fulfill_no_trans

Public Function fulfill(ByVal dtl_num As String, _
                        ByVal is_fulfill As Boolean, ByVal quantity_num As Integer, _
                        ByVal from_loc As String, ByVal from_bin As String, _
                        ByVal from_cont As String, ByVal from_good As Boolean, _
                        ByVal to_loc As String, ByVal to_bin As String, _
                        ByVal to_cont As String, ByVal to_good As Boolean, _
                        ByVal serial_num As String, ByVal new_status As String, _
                        ByVal expected_date As String, ByVal user_name As String, _
                        ByVal fulfill_date As String, ByVal gen_time_bombs As Boolean) _
                        As Integer

Public Function fulfill_no_trans(ByVal dtl_num As String, _
                        ByVal is_fulfill As Boolean, ByVal quantity_num As Integer, _
                        ByVal from_loc As String, ByVal from_bin As String, _
                        ByVal from_cont As String, ByVal from_good As Boolean, _
                        ByVal to_loc As String, ByVal to_bin As String, _
                        ByVal to_cont As String, ByVal to_good As Boolean, _
                        ByVal serial_num As String, ByVal new_status As String, _
                        ByVal expected_date As String, ByVal user_name As String, _
                        ByVal fulfill_date As String, ByVal gen_time_bombs As Boolean) _
                        As Integer

Description

This API allows for the fulfilling of inventory parts for a part request. The API allow for either the fulfilling of the parts, or the backordering of the parts, whichever is appropriate. The quantity to be fulfilled, as well as the user and date/time of the fulfill can be supplied. A status can be supplied (for the proper condition, Fulfilled or Backordered). If the operation is a fulfill, the from and to locations (and bins) are specified. These can be locations or expense GL accounts as necessary. All of the proper validations against inventory will be performed. Just as in normal Clarify, if a partial fulfill is performed, the part request is broken up into two new part requests. The first is for the fulfill (and the quantities are changed). The new part request will be created to hold the rest of the units that did not get fulfilled.

The API support containers. If you are transferring into or out of a container, put the container name in the bin name field, and the container number in the cont_num field. If you are not using containers, leave the container number fields blank.

The API supports a primary bin recommendataion. If you have set up a primary bin recommendation, you can set the bin name to: PRIM_BIN_REC, and the API will fill in the proper bin. If a partial fulfilled is performed, then a new part request will be created for the unfulfilled items. The objid of the newly created part request detail will be in the ret_objid property. The id number of the newly created part request detail will be in the ret_id_num property.

The "no_trans" version of the API performs exactly the same work as the other version of the API. The only difference is that this version of the API does not check the logistics transitions, and does not change the condition/status of the part request detail. This allows for multiple calls to the API to be performed. In addition, when calling the no_trans version, a partial fulfill will not create new part requests for the rest of the units that did not get fulfilled. As an example, if you wish to fulfill 10 serialized parts on one part request, you can call fulfill_no_trans 9 times, then finally call the fulfill API once. If the operation is backordering, the expected date of arrival should be supplied.

The fulfill API will work with either quantity or serialized parts, based on the part number/site_part of the part request. The serial number will be taken from the part request, unless the optional serial number is specified. Then that serial number will be used.

The fulfill API will also validate that the part request can be transitioned (for the specified user) to the proper new condition.

Parameters

Parameter Name | Required? | Description
dtl_num | Yes | The part request to fulfill against
is_fulfill | Yes | If this = True, it is a fulfill operation. If = False, it is a backorder
quantity_num | Yes | How many units to fulfill/backorder
from_loc | No | The inventory location to fulfill from
from_bin | No | The inventory bin to fulfill from. If from a container, put the container name in this field. If you want the primary bin suggestion, put PRIM_BIN_REC in this field
from_cont | No | If transferring from a container, put the container number in this field
from_good | No | Is the inventory fulfilled from good (= True) or bad ( = False)
to_loc | No | The inventory location to fulfill to
to_bin | No | The inventory bin to fulfill to. If to a container, put the container name in this field. If you want the primary bin suggestion, put PRIM_BIN_REC in this field
to_cont | No | If transferring to a container, put the container number in this field
to_good | No | Is the inventory fulfilled to good (= True) or bad ( = False)
serial_num | No | Optional serial number. If specified, it will be used. Otherwise, the serial number is taken from the part request. If you want to specify multiple serialized parts to fulfill at one time, separate the serial numbers with a pipe character
new_status | No | The new status of the part request. If blank, default status of the new condition (Fulfilled or Backordered) will be used
expected_date | No | For backorders, when is the inventory expected?
user_name | No | The user who fulfilled the part request. If left blank, the current user performs the fulfill.
fulfill_date | No | When was the part request fulfilled. If this parameter is left blank, the PR is fulfilled at the current time
gen_time_bombs | Yes | Should a time_bomb be generated

Returns

Value | Meaning
0 | No errors
-1 | Quantity is < 1
-2 | Cannot find the specified user
-3 | Cannot find the specified part request
-4 | There are no units that need to be fulfilled for the part request
-5 | No transition exists between current condition and condition Fulfilled/Backordered
-6 | User's privclass does not allow to transition between
part request's condition and condition Fulfilled/Backordered |
-7 | Cannot find the activity string for FULFILL REQUEST/BACKORDER with rank = 12600/12900
-8 | Cannot find the default state for condition Unpicked
-9 | Attempt to fulfill too many units
-10 | Cannot locate the "from" location
-11 | Cannot locate the "from" bin
-12 | Cannot locate the "to" location
-13 | Cannot locate the "to" bin
-14 | The part request is currently dispatched to a queue
-15 | A serial number was specified, but it is for a part instance that is a different part or revision than the part for the part request
-16 | The "from" container is sealed
-17 | The "to" container is sealed
-18 | Cannot find the primary bin recommendation for the from bin
-19 | Cannot find the primary bin recommendation for the to bin
-20 | No serial number provided for a serialized part
-21 | Serialized fulfill, but not enough serial numbers provided to fulfill the quantity supplied
-22 | A serial number was specified, but the part is quantity tracked
-23 | The employee record for the specified user cannot be found

Create Part Request Error Codes:

| Value | Meaning | |:--- |:--- | | -101 | No request header ID was supplied. | | -102 | The specified request header ID was not found. | | -103 | The specified request header is already closed. | | -104 | The specified user was not found. | | -105 | The specified mod_level record was not found. | | -106 | The specified site_part record was not found. | | -107 | The specified queue was not found. | | -108 | The specified detail type was not found. | | -109 | The specified priority was not found. | | -110 | The specified "ship via" value was not found. | | -111 | The specified carrier was not found. | | -112 | The default status for RQST_OPEN was not found. | | -113 | Cannot find activity code for "Create". | | -114 | Cannot find activity code for "Dispatch". | | -115 | The specified creation date is invalid. | | -116 | The specified due date is invalid. | Part Transfer Error Codes:

Value | Meaning
-220 | Serial number is found in inventory, but not at the specified "from" bin
-221 | The serialized part cannot be found at the specified from location and the from location is not a GL account that allows a part to be created.

Note: Any other error codes between -200 and -299 are from part transfer. Add 200 to the error code, and check the error code in the part transfer section of this document.

Examples

Fulfill 3 units of inventory for part request number '1-14' from Austin's Container 44 (name of Fred) to Expense GL "EXPGL. All inventory is good. Go to status "Fulfilled OK!". The fulfill is performed by Dan on January 1, 2001. Generate time bombs.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.fulfill("1-14", True, 3, "Austin", "Fred", "44", True, _
    "EXPGL", "", "", True, "", "Fulfilled OK!", "", "dan", "1/1/2001", True)

JavaScript:

var ret_int = fccl.fulfill("1-14", true, 3, "Austin", "Fred", "44", true,
    "EXPGL", "", "", true, "", "Fulfilled OK!", "", "dan", "1/1/2001", true);

Do the same fulfill, but fulfill to the default bin location in San Jose.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.fulfill("1-14", True, 3, "Austin", "Fred", "44", True, _
                       "San Jose", "PRIM_BIN_LOC", "", True, "", _
                       "Fulfilled OK!", "", "dan", "1/1/2001", True)

JavaScript:

var ret_int = fccl.fulfill("1-14", true, 3, "Austin", "Fred", "44", true,
   "San Jose", "PRIM_BIN_LOC", "", true, "",
   "Fulfilled OK!", "", "dan", "1/1/2001", true);

Backorder 4 units for part request '2-1'. It is expected on November 15th. Don't generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.fulfill("2-1", False, 4, "", "", "", True, "", "", _
                       "", True, "", "", "11/15/2001", "", "", False)

JavaScript:

var ret_int = fccl.fulfill("2-1", false, 4, "", "", "", true, "", "",
                       "", true, "", "", "11/15/2001", "", "", false);


get_alt_parts | fcSDK Documentation

get_alt_parts

Public Function get_alt_parts(ByVal part_num As String, _
                              ByVal domain_name As String, _
                              ByVal mod_level As String) As Integer

Description

This API builds a list of the alternate parts (table_partnum_view) for the specified part and revision, and sets the fccl property ret_string with the pipe-delimited list of parts.

Parameters

Parameter Name | Required? | Description
part_num | Yes | The part number
domain_name | Yes | The domain of the part
mod_level | Yes | The revision of the part

Returns

Value | Meaning
0 | No errors
+1 | No alternate parts exist
-1 | No part number supplied
-2 | No domain supplied
-3 | Cannot locate the supplied part number
-4 | Cannot locate the supplied revision
ret_string | Output - Returns a pipe delimited list of alternate parts found

Examples

Get the alternate parts for MS Word 7.0:

Visual Basic:

Dim ret_int As Integer
Dim part_list As String

ret_int = fccl.get_alt_parts("MS Word", "Product", "7.0")

If ret_int = 0 Then
  part_list = fccl.ret_string
End If

JavaScript:

var ret_int = fccl.get_alt_parts("MS Word", "Product", "7.0");
If (ret_int == 0) { var part_list = fccl.ret_string; }


get_loc_serv_site | fcSDK Documentation

get_loc_serv_site

Public Function get_loc_serv_site(ByVal site_id As String) As Integer

Description

This API returns a list of the locations (in the proper order) servicing this site.

Parameters

Parameter Name | Required? | Description
site_id | Yes | The site's ID

Returns

Value | Meaning
0 | No errors
+1 | There are no locations specified to service this site
-1 | No site ID supplied
-2 | Supplied site does not exist
ret_string | Output - Returns a pipe delimited list of the locations (in the proper order) servicing this site

Examples

Get the locations servicing the site "42".

Visual Basic:

Dim ret_int As Integer
Dim loc_list As String

ret_int = fccl.get_loc_serv_site("42", loc_list) If ret_int = 0 Then
  loc_list = fccl.ret_string
End If

JavaScript:

var ret_int = fccl.get_loc_serv_site("42", loc_list);
If (ret_int == 0) { var loc_site = fccl.ret_string; }


make_pr_detail | fcSDK Documentation

make_pr_detail

make_pr_detail_list

Public Function make_pr_detail(ByVal hdr_num As String, _
                             ByVal queue_name As String, ByVal part_num As String, _
                             ByVal domain_name As String, ByVal mod_level As String, _
                             ByVal serial_no As String, ByVal quantity_num As Integer, _
                             ByVal sp_rec_objid As Long, ByVal sp_rec_recordtype As String, _
                             ByVal dtl_type As String, ByVal priority_str As String, _
                             ByVal ship_via As String, ByVal carrier_name As String, _
                             ByVal user_name As String, ByVal warranty As Integer, _
                             ByVal note_str As String, ByVal status_str As String, _
                                           ByVal create_date As String, ByVal due_date As String, _
                             ByVal gen_time_bombs As Boolean, _
                             ByVal contr_itm_objid As Long, _
                             ByVal int_fld1 As String, ByVal int_val1 As Long, _
                             ByVal int_fld2 As String, ByVal int_val2 As Long, _
                             ByVal str_fld1 As String, ByVal str_val1 As String, _
                             ByVal str_fld2 As String, ByVal str_val2 As String, _
                             ByVal date_fld1 As String, ByVal date_val1 As String) As Integer

Public Function make_pr_detail_list(ByVal hdr_num As String, _
                             ByVal queue_name As String, ByVal part_num As String, _
                             ByVal domain_name As String, ByVal mod_level As String, _
                             ByVal serial_no As String, ByVal quantity_num As Integer, _
                             ByVal sp_rec_objid As Long, ByVal sp_rec_recordtype As String, _
                             ByVal dtl_type As String, ByVal priority_str As String, _
                             ByVal ship_via As String, ByVal carrier_name As String, _
                             ByVal user_name As String, ByVal warranty As Integer, _
                                           ByVal note_str As String, _
                             ByVal status_str As String, ByVal create_date As String, _
                             ByVal due_date As String, ByVal gen_time_bombs As Boolean, _
                             ByVal contr_itm_objid As Long, Optional fld_list As Variant, _
                             Optional type_list As Variant, Optional val_list As Variant) _
                             As Integer

Description

These APIs are used to create new part request details. The part request header must be specified. So must a part or site_part. There are two mechanisms for achieving this. If the site_part record is already known, it can be passed in the sp_rec variable. If not, the part_num, mod_level, and domain define the part. If it is a site_part (serialized), the serial_num may also be specified. But a part/revision or a site_part MUST be specified.

The quantity of units on the detail must also be specified, as must the detail_type. A number of other optional parameters (user-defined, notes-) may be specified. The user and creation time may be specified, as well as a queue to dispatch to. If a queue is specified, the part request will be dispatched (along with activity log and time_bombs). If not, it will be left in the user's WIPBIN.

An initial status (for condition "RQST OPEN") may be specified. If not, the default status will be used.

You may specify a number of values such as the billing site (defaults to the main site), the payment type and method, and the user who created the part request. You may specify the the creation date You may specify the user who created the part request header, and you may specify additional fields. You may have a creation time bomb generated (for notifications). If a site part is being specified for which to create the Part Request for, then the site part objid id must be passed in the sp_rec_objid parameter, and the keyword "site_part" must be passed in the sp_rec_recordtype parameter.

Parameters

Parameter Name | Required? | Description |
hdr_num | Yes | Part request header number |
queue_name | No | Optional queue to dispatch to |
part_num | No* | Part number for the part (required if Site | Part not specified)
mod_level | No* | Revision for the part (required if Site | Part not specified)
domain_name | No* | Domain for the part (required if Site Part not | specified)
serial_no | No | Serial number if a serialized site_part |
quantity_num | Yes | How many units recorded |
sp_rec_objid | No* | Objid of site_part record for the detail. | Use 0 if no site_part.
(required if Part Information not specified) |  |  |
sp_rec_recordtype | No* | Record Type associated to sp_rec objid field (required if Part Information not specified) |
dtl_type | No | Part request type. If not specified, default is used |
priority_str | No | Priority of the detail. If not specified, default is used |
ship_via | No | How will it be shipped? If not specified, default is used |
carrier_name | No | Carrier to ship by. If not specified, default is used |
user_name | No | The user who created the PR detail. If left blank, the current user performs the create. |
warranty | No | Indicator for part warranty information |
note_str | No | Optional notes for the part request header |
status_str | No | Initial PR detail status. If blank, default status of "RQST OPEN" used |
create_date | No | When was the create performed? If blank, current date/time used |
due_date | No | When is detail due? If not specified, create_date is used |
gen_time_bombs | Yes | Should a time_bomb be generated |
contr_itm_objid | No | Objid of contract line item to link to. Can only be used if new relations are added to the Clarify schema. Otherwise, set to 0 |
err_element | Yes | Return string if error occurs |
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write |
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name |

Returns

Value | Meaning
0 | No errors
-1 | No request header ID was supplied.
-2 | The specified request header ID was not found.
-3 | The specified request header is already closed.
-4 | The specified user was not found.
-5 | The specified mod_level record was not found.
-6 | The specified site_part record was not found.
-7 | The specified queue was not found.
-8 | The specified detail type was not found.
-9 | The specified priority was not found.
-10 | The specified "ship via" value was not found.
-11 | The specified carrier was not found.
-12 | The default status for RQST_OPEN was not found.
-13 | Cannot find activity code for "Create Part Request" with rank of 9900
-14 | Cannot find activity code for "Dispatch" with rank of 900
-15 | The specified creation date is invalid.
-16 | The specified due date is invalid.
-17 | Unable to retrieve next detail sequence number for PR Header
-18 | The employee record for the specified user cannot be found
-19 | Specified user default wipbin not found
-20 | Could not find the specified "Repair Status"
-21 | Could not find the specified "Retair Type"
-22 | Could not find the specified "Failure Code"
-23 | The specified part number domain was not found.
ret_id_num | Output - Returns the detail number of the newly created part request detail
ret_objid | Output - Returns the objid of the newly created part request detail

Examples

Create a new part request detail for PR header '1'. Make it 1 unit of "Attachments Anywhere, version 2.12"., with serial number 'A456'. Make it a "Return For Credit" type. Generate a time bomb. All other information is defaulted.

Field version:

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.make_pr_detail("1", "", "Attachments Anywhere", _
                           "2.12", "First Choice", "A456", 1, 0, "", _
                              "Return For Credit", "", "", _
                              "", "", 0, "", "", "", _
                              "", True, 0, "", 0, "", 0, "", "", _
                              "", "", "", "")

JavaScript:

var ret_int = fccl.make_pr_detail("1", "", "Attachments Anywhere",
                           "2.12", "First Choice", "A456", 1, 0, "",
                              "Return For Credit", "", "",
                              "", "", 0, "", "", "",
                              "", True, 0, "", 0, "", 0, "", "",
                              "", "", "", "");

List version:

Visual Basic:

Dim ret_int As Integer
Dim fld_list    As New FCFLCompat.FCList
Dim type_list   As New FCFLCompat.FCList
Dim val_list    As New FCFLCompat.FCList

fld_list.ItemType = "String"
type_list.ItemType = "String"
val_list.ItemType = "String"

ret_int = fccl.make_pr_detail_list("1", "", "Attachments Anywhere", _
                                   "2.12", "First Choice", "A456", 1, 0, "", _
                                   "Return For Credit", "", "", "", "", 0,"", _
                                   "", "", "", True, 0, fld_list, _
                                   type_list, val_list)

JavaScript:

var fld_list  = Server.CreateObject("FCFLCompat.FCList");
var type_list = Server.CreateObject("FCFLCompat.FCList");
var val_list  = Server.CreateObject("FCFLCompat.FCList");

var ret_int = fccl.make_pr_detail_list("1", "", "Attachments Anywhere",
                                   "2.12", "First Choice", "A456", 1, 0, "",
                                   "Return For Credit", "", "", "","", 0, "",
                                   "", "", "", True, 0, fld_list,
                                   type_list, val_list);

Create a new part request detail for PR header '42'. Make it 22 units of a quantity part. Make it a "Return For Credit" type, dispatch it to a queue (Low), and set some other useful values. Generate a time bomb. All other information is defaulted.

Field version:

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.make_pr_detail("42", "Low", "Zipcode Reverse Directory", _
                            "1.00", "First Choice", "", 22, 0, "", _
                            "Return For Credit", "Priority 1", "Overnight", _
                            "Fedex", "sa", 0, "Notes", "Open", "1/1/2001", _
                            "2/1/2001 15:00:00", True, 0, "int_fld1", 30, _
                            "", 0, "str_fld1", "Hello!!", _
                            "", "", "", "")

JavaScript:

var ret_int = fccl.make_pr_detail("42", "Low", "Zipcode Reverse Directory",
                            "1.00", "First Choice", "", 22, 0, "",
                               "Return For Credit", "Priority 1", "Overnight",
                                "Fedex", "sa", 0, "Notes", "Open", "1/1/2001",
                                "2/1/2001 15:00:00", True, 0, "int_fld1", 30,
                                "", 0, "str_fld1", "Hello!!",
                                "", "", "", "");

List version:

Visual Basic:

Dim ret_int As Integer
Dim fld_list    As New List
Dim type_list   As New List
Dim val_list    As New List

' Assume lists are filled in already

ret_int = fccl.make_pr_detail_list("42", "Low", "Zipcode Reverse Dir", _
                              "1.00", "First Choice", "", 22, 0, "", _
                              "Return For Credit", "Priority 1", "Overnight", _
                              "Fedex", "sa", 0, "Notes", "Open", "1/1/2001", _
                              "2/1/2001 15:00:00", True, 0, fld_list, _
                              type_list, val_list)

JavaScript:

var fld_list  = Server.CreateObject("FCFLCompat.FCList");
var type_list = Server.CreateObject("FCFLCompat.FCList");
var val_list  = Server.CreateObject("FCFLCompat.FCList");

var ret_int = fccl.make_pr_detail_list("42", "Low", "Zipcode Reverse Dir",
                              "1.00", "First Choice", "", 22, 0, "",
                              "Return For Credit", "Priority 1", "Overnight",
                              "Fedex", "sa", 0, "Notes", "Open", "1/1/2001",
                              "2/1/2001 15:00:00", True, 0, fld_list,
                              type_list, val_list);

Create a new part request detail for PR header '52'. Make it based on a non-serialized site part. Dispatch it to a queue (Low), and set some other useful values. Generate a time bomb. All other information is defaulted. The variable for the site part is hard-coded here for simplicity.

Field version:

Visual Basic:

Dim ret_int As Integer
Dim sp_objid  As Long

sp_objid = 268435123

ret_int = fccl.make_pr_detail("42", "Low", "Zipcode Reverse Directory", _
                     "1.00", "First Choice", "", 22, sp_objid, "site_part", _
                     "Return For Credit", "Priority 1", "Overnight", _
                     "Fedex", "sa", 0, "Notes", "Open", "1/1/2001", _
                     "2/1/2001 15:00:00", True, 0, "int_fld1", 30, _
                     "", 0, "str_fld1", "Hello!!", "", "", "", "")

JavaScript:

var sp_objid = 268435123;

var ret_int = fccl.make_pr_detail("42", "Low", "Zipcode Reverse Directory",
                        "1.00", "First Choice", "", 22, sp_objid, "site_part",
                        "Return For Credit", "Priority 1", "Overnight",
                        "Fedex", "sa", 0, "Notes", "Open", "1/1/2001",
                        "2/1/2001 15:00:00", True, 0, "int_fld1", 30,
                        "", 0, "str_fld1", "Hello!!",
                        "", "", "", "");

List version:

Visual Basic:

Dim ret_int As Integer
Dim fld_list    As New List
Dim type_list   As New List
Dim val_list    As New List
Dim sp_objid  As Long

sp_objid = 268435123

' Assume lists are filled in already
ret_int = fccl.make_pr_detail_list("42", "Low", "Zipcode Reverse Dir", _
                      "1.00", "First Choice", "", 22, sp_objid, "site_part", _
                      "Return For Credit", "Priority 1", "Overnight", _
                      "Fedex", "sa", 0, "Notes", "Open", "1/1/2001", _
                      "2/1/2001 15:00:00", True, 0, fld_list, _
                      type_list, val_list)

JavaScript:

var fld_list  = Server.CreateObject("FCFLCompat.FCList");
var type_list = Server.CreateObject("FCFLCompat.FCList");
var val_list  = Server.CreateObject("FCFLCompat.FCList");
var sp_objid = 268435123;

var ret_int = fccl.make_pr_detail_list("42", "Low", "Zipcode Reverse Dir",
                        "1.00", "First Choice", "", 22, sp_objid, "site_part",
                        "Return For Credit", "Priority 1", "Overnight",
                        "Fedex", "sa", 0, "Notes", "Open", "1/1/2001",
                        "2/1/2001 15:00:00", True, 0, fld_list,
                        type_list, val_list);


make_pr_header | fcSDK Documentation

make_pr_header

make_pr_header_list

make_pr_header_case_list

make_pr_header_subcase_list

Public Function make_pr_header(ByVal first_name As String, _
                               ByVal last_name As String, ByVal phone_num As String, _
                               ByVal ship_site_id As String, ByVal bill_site_id As String, _
                               ByVal case_id As String, ByVal pay_method As String, _
                               ByVal pay_terms As String, ByVal priority_str As String, _
                               ByVal user_name As String, ByVal note_str As String, _
                               ByVal create_date As String, ByVal contract_objid As Long, _
                               ByVal int_fld1 As String, ByVal int_val1 As Long, _
                               ByVal int_fld2 As String, ByVal int_val2 As Long, _
                               ByVal str_fld1 As String, ByVal str_val1 As String, _
                               ByVal str_fld2 As String, ByVal str_val2 As String, _
                               ByVal date_fld1 As String, ByVal date_val1 As String) _
                               As Integer

Public Function make_pr_header_list(ByVal first_name As String, _
                               ByVal last_name As String, ByVal phone_num As String, _
                               ByVal ship_site_id As String, ByVal bill_site_id As String, _
                               ByVal case_id As String, ByVal pay_method As String, _
                               ByVal pay_terms As String, ByVal priority_str As String, _
                               ByVal user_name As String, ByVal note_str As String, _
                               ByVal create_date As String, ByVal contract_objid As Long, _
                               Optional fld_list As Variant, Optional type_list As Variant, _
                               Optional val_list As Variant) As Integer

Public Function make_pr_header_case_list(ByVal first_name As String, _
                               ByVal last_name As String, ByVal phone_num As String, _
                               ByVal ship_site_id As String, ByVal bill_site_id As String, _
                               ByVal case_id As String, ByVal pay_method As String, _
                               ByVal pay_terms As String, ByVal priority_str As String, _
                               ByVal user_name As String, ByVal note_str As String, _
                               ByVal create_date As String, ByVal contract_objid As Long, _
                               Optional fld_list As Variant, Optional type_list As Variant, _
                               Optional val_list As Variant) As Integer

Public Function make_pr_header_subcase_list(ByVal first_name As String, _
                               ByVal last_name As String, ByVal phone_num As String, _
                               ByVal ship_site_id As String, ByVal bill_site_id As String, _
                               ByVal case_id As String, ByVal pay_method As String, _
                               ByVal pay_terms As String, ByVal priority_str As String, _
                               ByVal user_name As String, ByVal note_str As String, _
                               ByVal create_date As String, ByVal contract_objid As Long, _
                               Optional fld_list As Variant, Optional type_list As Variant, _
                               Optional val_list As Variant) As Integer

Description

These APIs are used to create new part request headers. The contact and site information must be specified. Everyhing else (related case, user-defined lists, notes, queue, creation date) is optional.

The make_pr_header_case_list API is used when creating a part request header for a case.

The make_pr_header_case_list API is used when creating a part request header for a subcase.

Similar functionality is available in the make_pr_header and make_pr_header_list APIs. These two APIs will try to detemine if the case_id parameter is that of a case or a subcase. If there is a dash ("-") in the case_id, then it will assume that it is a subcase id number. Else, it will assume that it is a case id number. The make_pr_header_case_list and make_pr_header_subcase_list APIs are useful when trying to create a part request for a case and your case id numbering scheme contains dashes.

Unless you are linking the part request header to a contract, and HAVE ADDED the new relations required (see the First Choice Software Call Center Integration Module), you should always specify 0 for the contract_objid field.

The function returns the header number created (and an error string for error conditions).

You may specify a number of values such as the billing site (defaults to the main site), the payment type and method, and the user who created the part request. You may specify the the creation date You may specify the user who created the part request header, and you may specify additional fields. You may have a creation time bomb generated (for notifications).

Parameters

Parameter Name | Required? | Description
first_name | Yes | Contact's first name
last_name | Yes | Contact's last name
phone_num | Yes | Contact's phone
ship_site_id | Yes | Where to send the part request
bill_site_id | No | Where to bill for the part request. If blank, API uses the ship_site_id
case_id | No | If the PR header is related to a case, it may be specified
pay_method | No | Payment method for the PR header. If left blank, default value is used
pay_terms | No | Payment terms for the PR header. If left blank, default value is used
priority_str | No | Priority for the PR header. If left blank, default value is used
user_name | No | The user who created the PR header. If left blank, the current user performs the create.
note_str | No | Optional notes for the part request header
create_date | No | When was the create performed? If blank, current date/time used
contract_objid | No | Objid of contract to link to. Can only be used if new relations are added to the Clarify schema. Otherwise, set to 0
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name

Returns

Value | Meaning
0 | No errors
-1 | No shipping site ID was supplied.
-2 | The specified contact was not found.
-3 | The specified shipping site ID was not found.
-4 | The specified billing site ID was not found.
-5 | The specified user was not found.
-6 | The specified case ID was not found.
-7 | The specified payment method was not found.
-8 | The specified payment terms were not found.
-9 | The specified priority was not found.
-10 | The specified create date is not valid.
-11 | The specified shipping site does not have a related country record.
-12 | The specified shipping site does not have a related state record.
-13 | Could not find the address for specified site
-14 | The first name, last name, and phone number cannot all be blank for the contact
ret_id_num | Output - Returns the header id of the newly created part request

Examples

Create a new part request header. Specify the site of 'First Choice', and contact of Jack Lacy. Also, generate a time bomb. All other information is defaulted.

Field version:

Visual Basic:

Dim ret_int As Integer
Dim hdr_num   As String

ret_int = fccl.make_pr_header("Jack", "Lacy", "512-418-2905", _
                              "First Choice", "", "", "", "", "", "", _
                              "", "", 0, "", 0, "", 0, "", "", "", "", "", "") 	If ret_int = 0 Then
    hdr_num = fccl.ret_id_num
 End If

JavaScript:

var ret_int = fccl.make_pr_header("Jack", "Lacy", "512-418-2905",
  "First Choice", "", "", "", "", "", "",
  "", "", 0, "", 0, "", 0, "", "", "", "", "", "");

If (ret_int == 0) { var hdr_num =fccl_ret_id_num; }

List version:

Visual Basic:

Dim ret_int As Integer
Dim hdr_num     As String
Dim fld_list    As New List
Dim type_list   As New List
Dim val_list    As New List

fld_list.ItemType = "String"
type_list.ItemType = "String"
val_list.ItemType = "String"

ret_int = fccl.make_pr_header_list("Jack", "Lacy", "512-418-2905", _
                                   "First Choice", "", "", "", "", "", "", _
                                   "", "", 0, fld_list, type_list, val_list) If ret_int = 0 Then
  hdr_num = fccl.ret_id_num
End If

JavaScript:

var fld_list  = Server.CreateObject("FCFLCompat.FCList");
var type_list = Server.CreateObject("FCFLCompat.FCList");
var val_list  = Server.CreateObject("FCFLCompat.FCList");

var ret_int = fccl.make_pr_header_list("Jack", "Lacy", "512-418-2905",
  "First Choice", "", "", "", "", "", "",
  "", "", 0, fld_list, type_list, val_list);

If (ret_int == 0) { var hdr_num =fccl_ret_id_num; }

Create a new part request header. Specify the site of 'First Choice', and contact of Jack Lacy. Also, do not generate a time bomb. Specify reasonable values for case ID, and other choices. Add some additional fields.

Field version:

Visual Basic:

Dim ret_int As Integer
Dim hdr_num   As String
Dim err       As String

ret_int = fccl.make_pr_header("Jack", "Lacy", "512-418-2905", "First Choice", _
                   "site2", "Case42", "Check", "Net 10", "Priority 1", "sa", _
                   "notes", "11/11/01", 0, "x_int1", 20, "", 0, "x_str1", _
                   "Value 1", "", "", "", "")

If ret_int = 0 Then
  hdr_num = fccl.ret_id_num
End If

JavaScript:

var ret_int = fccl.make_pr_header("Jack", "Lacy", "512-418-2905",
    "First Choice", "site2", "Case42", "Check", "Net 10", "Priority 1", "sa",
    "notes", "11/11/01", 0, "x_int1", 20, "", 0, "x_str1",
    "Value 1", "", "", "", "");

If (ret_int == 0) { var hdr_num = fccl.ret_id_num; }

List version:

Visual Basic:

Dim ret_int As Integer
Dim hdr_num     As String
Dim fld_list    As New List
Dim type_list   As New List
Dim val_list    As New List

' Assume lists are filled in already

ret_int = fccl.make_pr_header_list("Jack", "Lacy", "512-418-2905", _
                              "First Choice", "site2", "Case42", "Check", _
                              "Net 10", "Priority 1", "sa", "notes", _
                              "11/11/2001", 0, fld_list, type_list, val_list)

If ret_int = 0 Then
  hdr_num = fccl.ret_id_num
End If

JavaScript:

var fld_list  = Server.CreateObject("FCFLCompat.FCList");
var type_list = Server.CreateObject("FCFLCompat.FCList");
var val_list  = Server.CreateObject("FCFLCompat.FCList");

var ret_int = fccl.make_pr_header_list("Jack", "Lacy", "512-418-2905",
   "First Choice", "site2", "Case42", "Check",
   "Net 10", "Priority 1", "sa", "notes",
   "11/11/2001", 0, fld_list, type_list, val_list);

If (ret_int == 0) { var hdr_num = fccl.ret_id_num; }


modify_gl_account | fcSDK Documentation

modify_gl_account

Public Function modify_gl_account(ByVal old_name As String, _
                                  ByVal new_name As String, ByVal account_type As String, _
                                  ByVal desc_str As String, ByVal account_no As String, _
                                  ByVal is_exp As Boolean, ByVal is_active As Boolean, _
                                  ByVal is_company As Boolean, ByVal site_id As String) _
                                  As Integer

Description

This API is used to modify existing GL accounts. Any of the attributes of the account can be changed. See the add_gl_account API desciption for more information. To leave any of the information unchanged, simply do not specify a value for it. For example, if you do not wish to change the name of the account, leave new_name blank.

Parameters

Parameter Name | Required? | Description
old_name | Yes | The current ame of the GL account
new_name | No | The new name (if changed) of the GL account
account_type | No | Type of account from the code list. If blank, the default value is used
desc_str | No | The description of the account
account_no | No | Optional account number
is_exp | Yes | Is this an expense account (True), or capital (False)
is_active | Yes | Is the account active (True) or inactive (False)
is_company | Yes | Is it company owned (True) or customer owned (False)
site_id | Yes | The site for the account

Returns

Value | Meaning
0 | No errors
-1 | Missing site id parameter
-2 | Missing old_name parameter
-3 | Missing new_name parameter
-4 | The supplied site was not found
-6 | The account name already exists in the database
-7 | Location (expense/capital) type value not found
-8 | Account type value not valid for the type of account (expense/capital)

Example

Modify "myaccount" to change the name to "youraccount". Make it a customer owned, inactive, capital GL for site 2.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.modify_gl_account("myaccount", "youraccount", "description", _
                                "12345", False, False, False, "2")

JavaScript:

var ret_int = fccl.modify_gl_account("myaccount", "youraccount", "description",
                                "12345", false, false, false, "2");


modify_inv_bin | fcSDK Documentation

modify_inv_bin

Public Function modify_inv_bin(ByVal old_name As String, _
                               ByVal new_name As String, ByVal loc_name As String, _
                               ByVal is_active As Boolean)

Description

This API is used to modify the name or the active flag of an existing bin. You may not move the bin to another location with this API, only rename it at the existing location.

Parameters

Parameter Name | Required? | Description
old_name | Yes | Previous name for the bin
new_name | Yes | New name for the bin. If the bin isn't changing names, this argument can be left blank
loc_name | Yes | Name of the inventory location where the bin is located
is_active | Yes | Is the bin active (True) or inactive (False)

Returns

Value | Meaning
0 | No errors
-1 | Missing old name parameter
-2 | Missing new name parameter
-3 | Missing location name parameter
-4 | The specified location is not found
-5 | The bin name already exists at that location

Examples

Rename "Bin 42" to "Bin 42a" in Austin.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.modify_inv_bin("Bin 42", "Bin42a", "Austin", True)

JavaScript:

var ret_int = fccl.modify_inv_bin("Bin 42", "Bin42a", "Austin", True);

Make bin "Bin ABZ" in San Jose inactive.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.modify_inv_bin("Bin ABZ", "", "San Jose", False)

JavaScript:

var ret_int = fccl.modify_inv_bin("Bin ABZ", "", "San Jose", False);


modify_inv_location | fcSDK Documentation

modify_inv_location

Public Function modify_inv_location(ByVal old_name As String, _
                                 ByVal new_name As String, ByVal account_type As String, _
                                 ByVal desc_str As String, ByVal reports_to_loc As String, _
                                 ByVal cap_gl_acct As String, ByVal is_active As Boolean, _
                                 ByVal is_company As Boolean, ByVal site_id As String, _
                                 ByVal trans_auth_str As String) As Integer

Description

This API is used to modify inventory locations in the system. The old name must be specified (to look up the record). If a name change is needed, then the new name can be specified. Otherwise it can be left blank. The other data can be modified as needed.

The trans authority determines part authorization levels, and has three possible values: none, all, auth parts only.

Parameters

Parameter Name | Required? | Description
old_name | Yes | Name of the inventory location
new_name | No | New name of the location (if it is changing)
account_type | No | Code list value to set
desc_str | No | Description of the inventory location
reports_to_loc | No | The location name of the parent inventory location (if any)
cap_gl_acct | No | The name of the capital account for this location
is_active | Yes | Is the location active (True) or inactive (False)
is_company | Yes | Is the location company owned (True) or customer (False)
site_id | No | The location of the inventory location
trans_auth_str | No | One of the following: none, all, auth parts only. If blank, no change is made

Returns

Value | Meaning
0 | No errors
-1 | Missing site id parameter
-2 | Missing old_name parameter
-3 | Missing loc_name parameter
-4 | The supplied site was not found
-5 | The location name (old name) does not exist in the database
-7 | Location type is not valid from the code list
-8 | Missing capital gl account name
-9 | The specified reports to location is not found in the database
-10 | Invalid trans_auth string
-11 | Capital GL account does not exist

Examples

Change the name of a location from "Austin" to "Round Rock".

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.modify_inv_location("Austin", "Round Rock", "", "", "", _
                     "", True, True, "", "")

JavaScript:

var ret_int = fccl.modify_inv_location("Austin", "Round Rock", "", "", "",
                     "", true, true, "", "");

Change most of the information for a location.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.modify_inv_location("Austin", "Round Rock", "", "New desc", _
                            "Dallas", "NewCapGL", True, True, "2", "none")

JavaScript:

var ret_int = fccl.modify_inv_location("Austin", "Round Rock", "", "New desc",
                            "Dallas", "NewCapGL", true, true, "2", "none");


modify_lss | fcSDK Documentation

modify_lss

Public Function modify_lss(ByVal site_id As String, _
               ByVal loc_name As String, ByVal loc_rank As Integer) As Integer

Description

This API is used to change the order of the locations servicing a site. The new rank is given to the item, and all other ranks are changed as necessary.

Parameters

Parameter Name | Required? | Description
site_id | Yes | Name of the site to be serviced
loc_name | Yes | Name of the servicing location
loc_rank | Yes | Which servicing location is this. Ranks start at 1 and increase

Returns

Value | Meaning
0 | No errors
-1 | Site parameter value missing
-2 | Location parameter value missing
-3 | Invalid edit_type (not 0, 1, or 2). Internal error - should never be seen
-4 | Servicing record does not exist
-5 | No change is needed for this rank
-6 | The specified site was not found
-7 | The specified location not found
-8 | New rank is greater than total number of items already in the list

Examples

Austin should service site 1 third.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.modify_lss("1", "Austin", 3)

JavaScript:

var ret_int = fccl.modify_lss("1", "Austin", 3);

Houston should service site 1 next.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.modify_lss("1", "Houston", 4)

JavaScript:

var ret_int = fccl.modify_lss("1", "Houston", 4);


mod_part_stocking_lev | fcSDK Documentation

mod_part_stocking_lev

Public Function mod_part_stocking_lev(ByVal bin_name As String, _
                           ByVal to_bin As String, ByVal location_name As String, _
                           ByVal queue_name As String, ByVal to_queue As String, _
                           ByVal part_number As String, ByVal mod_level As String, _
                           ByVal domain_name As String, ByVal part_minimum As Integer, _
                           ByVal part_maximum As Integer, ByVal part_rol As Integer, _
                           ByVal part_roq As Integer, ByVal is_active As Boolean) As Integer

Description

This API modifies an existing part restocking authorization level. The location, bin, part number/revision/domain must be specified, as well as the various levels and the reorder queue. The to_bin field is move the record to another bin, and the to_queue field can be used to change the name of the queue.

Parameters

Parameter Name | Required? | Description
bin_name | Yes | The bin for the restocking
to_bin | No | The name of the bin to move the record to. If blank, no move occurs
location_name | Yes | The location for the bin
queue_name | Yes | The queue that the reorder part request will be dispatched to
to_queue | No | The new name of the dispatch queue. If blank, no change is made
part_number | Yes | The part to restock
mod_level | Yes | The revision to restock
domain_name | Yes | The domain for the part
part_minimum | Yes | Minimum quantity for bin. If no change is desired, set to -1
part_maximum | Yes | Maximum quantity for bin. If no change is desired, set to -1
part_rol | Yes | The level at which a reorder is triggered. If no change is desired, set to -1
part_roq | Yes | If a reorder happens, how many get reordered. If no change is desired, set to -1
is_active | Yes | Is this restocking entry active?

Returns

Value | Meaning
0 | No errors
-1 | Missing queue parameter
-2 | Missing location parameter
-3 | Missing part number
-4 | Part reorder level < minimum
-5 | Part reorder level > maximum
-6 | Part reorder level < 0
-7 | Part reorder qty < 0
-8 | Part minimum < 0
-9 | Part maximum < 0
-10 | Location does not exist
-11 | Bin does not exist for given location
-12 | Queue does not exist
-13 | Mod level does not exist
-14 | The specified "to_queue" does not exist
-15 | The specified "to_bin" does not exist for given location
-16 | The specified part stocking record does not exist

Examples

Move the restock record from bin 2 to bin 3. Change the queue from high to low, and don't change the minimum or maximum.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.mod_part_stocking_lev("Bin 2", "Bin 3", "Austin", "High", _
                       "Low", "CD Rom", "", "Quantity", -1, -1, _
                       15, 2, True)

JavaScript:

var ret_int = fccl.mod_part_stocking_lev("Bin 2", "Bin 3", "Austin", "High",
                       "Low", "CD Rom", "", "Quantity", -1, -1,
                       15, 2, True);


move_pr | fcSDK Documentation

move_pr

Public Function move_pr(ByVal pr_id As String, _
                        ByVal new_wipbin_name As String) As Integer

Description

This API causes the specified part request to be moved from one WIPBin to another (for the current owner). The part request must be open, and the WIPBin name must be valid for the current owner.

Note: This API allows you to move a queueable object from one WIPBin to another, even if the object is currently dispatched. Since WIPBins are internal to a user, there really is no reason that you shouldn't be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Parameters

Parameter Name | Required? | Description
pr_id | Yes | The part request to move
new_wipbin_name | Yes | Name of the WIPBin to move to

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified part request
-2 | Part request is already closed
-3 | New WIPBIN doesn't exist, or isn't for the owner
-4 | New WIPBIN is same as old - no move needed

Examples

Move part request number '1-14' to WIPBin 'Hardware'.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.move_pr("1-14", "Hardware")

JavaScript:

var ret_int = fccl.move_pr("1-14", "Hardware");


open_container | fcSDK Documentation

open_container

Public Function open_container(ByVal cont_name As String) As Integer

Description

This API opens an existing (sealed) container.

Parameters

Parameter Name | Required? | Description
cont_name | Yes | The container to open

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the container
-2 | The container is already open
-3 | The parent container is currently sealed

Examples

Open container Fred.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl. open_container("Fred")

JavaScript:

var ret_int = fccl. open_container("Fred");


part_transfer | fcSDK Documentation

part_transfer

Public Function part_transfer(ByVal part_num As String, _
                 ByVal mod_level As String, ByVal domain_name As String, _
                 ByVal quantity_num As Long, ByVal serial_num As String, _
                 ByVal from_loc As String, ByVal from_bin As String, _
                 ByVal from_cont As String, ByVal from_good As Boolean, _
                 ByVal to_loc As String, ByVal to_bin As String, _
                 ByVal to_cont As String, ByVal to_good As Boolean, _
                 ByVal user_name As String, ByVal trans_date As String, _
                 ByVal ref_id As String, ByVal note_str As String, _
                 ByVal gen_time_bombs As Boolean, ByVal fifo_flag As Integer, _
                 ByVal update_cost As String, ByVal update_source As String, _
                 trans_id As String, ByVal std_cost As String) As Integer

Description

This API emulates the Clarify part transfer mechanism. The part/revision/domain are specified (the part to be transferred). Also specified are the from location/bin and the to location/bin. The quantity and serial number of the parts to be transferred are specified, as are some additional information (reference ID, transfer date, and notes).

As in Clarify, the transfer can be from good or bad stock and can be to good or bad stock. Also, time bombs (for escalation/notification) can be specified, or not.

The API supports containers. If you are transferring into or out of a container, put the container name in the bin name field, and the container number in the cont_num field. If you are not using containers, leave the container number fields blank.

The API supports a primary bin recommendation. If you have set up a primary bin recommendation, you can set the bin name to: PRIM_BIN_REC, and the API will fill in the proper bin.

The FIFO flag has three possible values:

0 - No FIFO costing used

1 - FIFO costing is used

2 - Use the cost specified in the update_cost field

The update cost field is the cost per unit of the transfer, and is used in two cases: 1) if the preceding field is set to 2, this is the cost of the transfer. 2) If the flag is set = 1, then this is the cost of the transfer, and FIFO records will be created. This is only valid for transfers from Expense GL accounts.

The update source is also used only when the flag = 1 and it is a transfer in from an expense GL. In this case, the update source is the source placed in the FIFO costing record.

Note: If you are transferring (in from an expense GL) using FIFO costs, and don't wish to create a new FIFO record (but rather wish to increment the most recent FIFO record), just leave the update_cost field blank ("").

The final two arguments are output arguments that return the transaction ID of the part transfer, and the standard cost (total) for the transfer.

The API also checks part authorization levels for auto-replenishment, and will automatically work with the Clarify auto-replenishment engine.

Adding to an existing part transfer:

The part transfer API now has the ability to increase the number of units in a previously transacted part transfer. For example, suppose that a part transfer of 5 units has been made. The transaction ID is '42'. But you realize after the fact that the transfer really was for 8 units. You can create a new part transfer, or, using this feature, you can "fix" the previous part transfer.

To do this, specify (in the trans_id argument) the transaction ID of the previous part transfer. In the quantity field, specify how many units to add to the transfer. The fifo_flag, update_cost, update_source, and gen_time_bomb parameters are also used for the additional units. All other arguments are ignored. The from/to locations and bins, as well as the part number/mod_level are determined from the existing part transfer.

Note: This new feature only works with transfers of quantity-tracked parts.

Parameters

Parameter Name | Required? | Description
part_num | Yes | The part number transferred
mod_level | Yes | Revision of the part
domain | Yes | The domain of the part
quantity | Yes | How many to transfer
serial_num | No | The serial number (if serial tracked) to transfer
from_loc | Yes | The inventory location (or GL account) to transfer from
from_bin | No | The inventory bin to transfer from. If from a container, put the container name in this field. If you want the primary bin suggestion, put
PRIM_BIN_REC in this field |  |
from_cont | No | If transferring from a container, put the container number in this field
from_good | Yes | Is the transfer from "good" stock?
to_loc | Yes | The inventory location (or GL account) to transfer to
to_bin | No | The inventory bin to transfer to. If to a container, put the container name in this field. If you want the primary bin suggestion, put PRIM_BIN_REC in this field
to_cont | No | If transferring to a container, put the container number in this field
to_good | Yes | Is the transfer to "good" stock?
user_name | No | Who performed the transfer? If blank, current user is used
trans_date | No | When was transfer performed? If blank, current time is used
ref_id | No | Optional reference ID of transfer
notes | No | Optional notes about the transfer
gen_time_bombs | Yes | Should time bombs be generated?
fifo_flag | Yes | Should we use FIFO costing? 0 = No, 1 = Yes, 2 = Use the
cost in the next field |  |
update_cost | No | If the fifo_flag = 2, this is the per-unit cost for the transfer.
Not commonly used. If the fifo_flag = 1, it is the FIFO cost of the transfer (only valid for transfer in from expense GL) |  |
update_source | No | If the fifo_flag = 1, and this is a transfer in from an expense GL with an update cost specified, this is the source of the FIFO parts
trans_id | Yes | Output argument with the transaction ID of the part transfer
std_cost | Yes | Output argument with the standard cost of the part transfer

Returns

Value | Meaning
0 | No errors
-1 | TO location/bin and FROM location/bin cannot be the same
-2 | Specified quantity is less than 1
-3 | Can't transfer serialized part with quantity > 1
-4 | Specified Part Number was not found
-5 | Serial Number was not specified for serialized Part Number
-6 | Mod Level for specified Part Number was not found
-7 | FROM Location for specified Part Number was not found
-8 | FROM Bin for specified Part Number was not found
-9 | TO Location for Specified Part Number was not found
-10 | TO Bin for Specified Part Number was not found
-11 | Specified User not found in database
-12 | FROM Bin for Part Number is sealed
-13 | TO Bin for Part Number is sealed
-14 | FROM Loc/Bin for Part Number was not found
-15 | TO Loc/Bin for Part Number was not found
-20 | Serial number is found in inventory, but not at the "from" location/bin
-21 | The serialized part cannot be found at the specified from location and the from location is not a GL account that allows a part to be created.
-22 | Cannot find the activity string for "Transfer" with rank = 12300
-23 | Supplied update cost is not numeric
-26 | Invalid part transfer. Attempting to transfer a good part that was marked bad, or vice versa
-27 | The Part Instance was not found in the FROM location/bin
-28 | There is not enough quantity of the Part Instance in the FROM location/bin
-40 | Invalid value for fifo_flag specified
-41 | Cannot add units to an existing part transfer, because the part transfer is for a serialized part
-42 | Specified Part Transfer for augmentation was not found
ret_string | The transaction record ID number
ret_num | The standard cost of the transaction

Examples

Transfer 20 units of Accounting 101 from an expense GL account to the primary bin in Austin. All stock is good. Use FIFO costing.

Visual Basic:

Dim ret_int As Integer
Dim trans_id  As String
Dim std_cost  As String

ret_int = fcfo.part_transfer("Accounting", "101", "QuantityDomain", _
                20, "", "EXPGL", "", "", True, "Austin", _
                "PRIM_BIN_REC", "", True, "", "", "", _
                "", True, 1, "", "", trans_id, std_cost)

If ret_int = 0 Then
  trans_id = fcfo.ret_string
  std_cost = fcfo.ret_num
End If

JavaScript:

var ret_int = fcfo.part_transfer("Accounting", "101", "QuantityDomain",
                    20, "", "EXPGL", "", "", true, "Austin",
                    "PRIM_BIN_REC", "", true, "", "", "",
                    "", true, 1, "", "", trans_id, std_cost);

if (ret_int == 0){ var trans_id = fcfo.ret_objid; }

Transfer MS Word 7.0, serial number 555666 from Austin Bin 2 to San Jose Bin "Receiving". The inventory was good, but is now marked as bad (for Quality Control). Fred did the transfer on July 30, 1998, at 5:13 AM. Add notes and a ref ID, and don't generate a time bomb. Don't use FIFO costing.

Visual Basic:

Dim ret_int As Integer
Dim trans_id  As String
Dim std_cost  As String

ret_int = fcfo.part_transfer("MS Word", "7.0", "Product", 1, _
              "555666", "Austin", "Bin 1", "", True, _
              "San Jose", "Receiving", "", False, _
              "fred", "7/30/98 5:13:00", "Ref ID3", _
              "Some notes", False, 0, "", "", trans_id, std_cost)

  If ret_int = 0 Then
    trans_id = fcfo.ret_string
    std_cost = fcfo.ret_num
  End If

JavaScript:

var ret_int = fcfo.part_transfer("MS Word", "7.0", "Product", 1,
                  "555666", "Austin", "Bin 1", "", true,
                  "San Jose", "Receiving", "", false,
                  "fred", "7/30/98 5:13:00", "Ref ID3",
                  "Some notes", false, 0, "", "",
                  trans_id, std_cost);

if (ret_int == 0){ var trans_id = fcfo.ret_objid; }

Transfer 15 units of the Notebook part from expense GL 'EXPGL' to Austin Container 44 (name of Fred). The inventory was good, but is now marked as bad (for Quality Control). Fred did the transfer on July 30, 1998 at 5:13 AM. Add notes and a ref ID, and don't generate a time bomb. Use FIFO costing, and specify the cost and source.

Visual Basic:

Dim ret_int As Integer
Dim trans_id  As String
Dim std_cost  As String

ret_int = fcfo.part_transfer("Notebook", "", "Product", 15, "", _
                  "EXPGL", "", "", True, "Austin", _
                  "Fred", "44", False, "fred", _
                  "7/30/98 5:13:00", "Ref ID3", _
                  "Some notes", False, 1, ".34", "MySource", _
                              trans_id, std_cost)

   If ret_int = 0 Then
     trans_id = fcfo.ret_string
     std_cost = fcfo.ret_num
   End If

JavaScript:

var ret_int = fcfo.part_transfer("Notebook", "", "Product", 15, "",
                     "EXPGL", "", "", true, "Austin",
                     "Fred", "44", false, "fred",
                     "7/30/98 5:13:00", "Ref ID3",
                     "Some notes", false, 1, ".34", "MySource",
                                 trans_id, std_cost);

 if (ret_int == 0){ var trans_id = fcfo.ret_objid; }

Add 4 units to part transfer '42'. Generate a time bomb, and use FIFO costing.

Visual Basic:

Dim ret_int As Integer
Dim trans_id  As String
Dim std_cost  As String

trans_id = "42"

ret_int = fcfo.part_transfer("", "", "", 4, "","", "", _
                  "", True, "", "", "", True, "", _
                  "", "", "", True, 1, "", "", _
                              trans_id, std_cost)

  If ret_int = 0 Then
    std_cost = fcfo.ret_num
  End If

JavaScript:

trans_id = "42"

var ret_int = fcfo.part_transfer("", "", "", 4, "","", "",
                     "", true, "", "", "", true, "",
                     "", "", "", true, 1, "", "",
                                 trans_id, std_cost);

 if (ret_int == 0){ var trans_id = fcfo.ret_objid; }


pick | fcSDK Documentation

pick

pick_sn

pick_no_trans

pick_sn_no_trans

Public Function pick(ByVal dtl_num As String, _
                     ByVal locs_str As String, ByVal use_good As Boolean, _
                     ByVal user_name As String, ByVal pick_date As String, _
                     ByVal gen_time_bombs As Boolean) As Integer

Public Function pick_sn(ByVal dtl_num As String, _
                        ByVal locs_str As String, ByVal use_good As Boolean, _
                        ByVal user_name As String, ByVal pick_date As String, _
                        ByVal serial_no As String, ByVal gen_time_bombs As Boolean) As Integer

Public Function pick_no_trans(ByVal dtl_num As String, _
                     ByVal locs_str As String, ByVal use_good As Boolean, _
                     ByVal user_name As String, ByVal pick_date As String, _
                     ByVal gen_time_bombs As Boolean) As Integer

Public Function pick_sn_no_trans (ByVal dtl_num As String, _
                        ByVal locs_str As String, ByVal use_good As Boolean, _
                        ByVal user_name As String, ByVal pick_date As String, _
                        ByVal serial_no As String, ByVal gen_time_bombs As Boolean) As Integer

Description

This API allows for multiple pick actions to occur against a part request. Various inventory parts are picked (reserved) for the part request. The pick can be by a specified user at a specified time, and can be picked from good or bad stock. Time bombs (for notification/escalation) can also be specified.

The "no_trans" versions of the APIs perform exactly the same work as the other versions of the APIs. The only difference is that these versions of the APIs do not check the logistics transitions, and do not change the condition/status of the part request detail. This allows for multiple calls to the API to be performed without extra complex transitions being added to the system.

The pick API will pick either quantity or serialized parts, based on the part number/site_part of the part request.

The pick API will also validate that the part request can be transitioned (for the specified user).

The API can also perform a soft pick. That is a pick (reserve) of a unit in a bin or container, without worrying about the serial number to reserve. The API just pick one general unit. To do this, pick against a part request that does not have a serial number specified (for a serialized part).

The API can also perform a pick of a specific unit indicated by a serial number. To do this, specify the serial number using the pick_sn API. This will pass the serial number along to the pick API, and the specific part will be reserved. If the part request was created using a serialized site part, then in order to pick an inventory part you must use the pick_sn API and specify a new specific serial number or use the keyword "inventory" as the serial number. This will force the API to ignore the serial number stored in the part request and allow the pick to occur from inventory parts.

The locs_str argument can have one of two values in it. If it is blank, the location_servicing_locations for the part request's site will be used. That is, inventory will be checked for the warehouses that are best suited for the shipping site of the part request. If the locs_str argument is not blank, it must be in the following format:

location<:bin><:cont#>|location<:bin>|-|location<:bin>

Where inventory locations to search are specified with a pipe character between each. They will be searched in the order listed. If only one bin at that location should be searched, it can be added to the location (with a colon between them). So, for example, to search all of Austin, and then Bin 4 in San Jose, use the following string:

Austin|San Jose:Bin 4 If you want to pick from a container, put the container name in the bin name, and the container number in the cont# field. If you are not picking from a container, don't even specify the container argument.

The pick API will continue to attempt to pick until they have reserved all of the inventory necessary, or run out of locations to pick from.

Note: This API requires one other API (part_transfer) to work correctly.

Parameters

Parameter Name | Required? | Description
dtl_num | Yes | The part request to receive against
locs_str | No | The list of locations to search. If blank, location_servicing_locations are used. See above for a description of the format of this argument
use_good | Yes | Is the picked inventory from good stock?
user_name | No | The user who picked the part request. If left blank, the current user performs the pick.
pick_date | No | When was the part request picked. If this parameter is left blank, the PR is picked at the current time
tot_num_picked | Yes | Returns the number of items picked
gen_time_bombs | Yes | Should a time_bomb be generated

Returns

Value | Meaning
0 | No errors
+1 | Picked some units, but could not pick all of them (ran out of locations to search)
-1 | Cannot find the specified user
-2 | Cannot find the specified part request
-3 | There are no more units that need to be picked for the part request
-4 | No transition exists between current condition and condition Picked
-5 | User's privclass does not allow to transition between part request's condition and condition Picked
-6 | Cannot find the activity string for PICK with rank = 12700
-7 | Cannot find the default state for condition Picked
-8 | Part request is currently dispatched to a queue
-9 | The employee record for the specified user cannot be found

Part Transfer Error Codes:

Value | Meaning
-120 | Serial number is found in inventory, but not at the specified "from" bin
-121 | The serialized part cannot be found at the specified from location and the from location is not a GL account that allows a part to be created.
ret_num | Output - Total number of parts picked for this part request

Examples

Pick inventory for part request number '1-14'. Use the location_servicing_locations to search. The pick is performed by Dan on January 1, 2001, and is from bad inventory. Generate time bombs.

Visual Basic:

Dim ret_int As Integer
Dim tot_num As Integer

ret_int = fccl.pick("1-14", "", False, "Dan", "1/1/2001", True)
tot_num = fccl.ret_num

JavaScript:

var ret_int = fccl.pick("1-14", "", False, "Dan", "1/1/2001", true);

Pick against part request number '2-1'. Pick from locations Austin/Bin 1, Austin/Bin 2, and Container 44 (name is Fred) from Austin. Use the default user and time, and use good stock. Don't generate a time bomb.

Visual Basic:

Dim ret_int As Integer
Dim tot_num As Integer

ret_int = fccl.pick("2-1", "Austin:Bin 1|Austin:Bin 2|Austin:Fred:44", _
                    True, "", "", True)
tot_num = fccl.ret_num

JavaScript:

var ret_int = fccl.pick("2-1", "Austin:Bin 1|Austin:Bin 2|Austin:Fred:44",
                        true, "", "", true);


receive_pr | fcSDK Documentation

receive_pr

receive_pr_no_trans

Public Function receive_pr(pr_num As String, _
                           ByVal from_loc As String, ByVal from_bin As String, _
                           ByVal from_cont As String, ByVal from_good As Boolean, _
                           ByVal to_loc As String, ByVal to_bin As String, _
                           ByVal to_cont As String, ByVal to_good As Boolean, _
                           ByVal quantity_num As Long, ByVal serial_num As String, _
                           ByVal status_str As String, ByVal carrier_name As String, _
                           ByVal waybill_name As String, ByVal poss_damage As Boolean, _
                           ByVal not_prop_pack As Boolean, ByVal route_to_test As Boolean, _
                           ByVal user_name As String, ByVal receive_date As String, _
                           ByVal auto_close As Boolean, ByVal gen_time_bombs As Boolean) _
                           As Integer

Public Function receive_pr_no_trans(pr_num As String, _
                           ByVal from_loc As String, ByVal from_bin As String, _
                           ByVal from_cont As String, ByVal from_good As Boolean, _
                           ByVal to_loc As String, ByVal to_bin As String, _
                           ByVal to_cont As String, ByVal to_good As Boolean, _
                           ByVal quantity_num As Long, ByVal serial_num As String, _
                           ByVal status_str As String, ByVal carrier_name As String, _
                           ByVal waybill_name As String, ByVal poss_damage As Boolean, _
                           ByVal not_prop_pack As Boolean, ByVal route_to_test As Boolean, _
                           ByVal user_name As String, ByVal receive_date As String, _
                           ByVal auto_close As Boolean, ByVal gen_time_bombs As Boolean) _
                           As Integer

Description

This API causes the specified part request to have units received against it. The API supports both quantity and serial number receives. It validates the transition from the current condition to the Received condition (for the specified user). The API creates the part transaction (including standard costs), part instance records, receive parts records, and activity logs. The API can also generate a time bomb (for business rule notification).

The "no_trans" version of the API performs exactly the same work as the other version of the API. The only difference is that this version of the API does not check the logistics transitions, and does not change the condition/status of the part request detail. This allows for multiple calls to the API to be performed without extra complex transitions being added to the system.

The API supports containers. If you are transferring into or out of a container, put the container name in the bin name field, and the container number in the cont_num field. If you are not using containers, leave the container number fields blank.

The API supports a primary bin recommendataion. If you have set up a primary bin recommendation, you can set the bin name to: PRIM_BIN_REC, and the API will fill in the proper bin.

The API supports (as of Clarify 7.0) a partial receive similar to Clarify's. If you receive only part of a part request, the API will create a new part request to handle the rest (unreceived) units of the part request. The objid of the newly created part request detail will be in the ret_objid property. The id number of the newly created part request detail will be in the ret_id_num property.

Good and bad inventory levels are supported, as is all other base features of receive parts. The API will not allow for an inventory location's bin to have a negative level of any part (although, of course, expense GLs may). The API also checks part authorization levels for auto-replenishment, and will automatically work with that engine.

Note: This API requires one other API (part_transfer) to work correctly.

Parameters

Parameter Name | Required? | Description
pr_num | Yes | The part request to receive against
from_loc | No | Inventory location (or expense GL) to receive from. If this field (and the from_bin) is left empty (""), the API will search for the received part in inventory. If it finds it, it will use that location as the from location.
from_bin | No | The inventory bin to receive from. If from a container, put the container name in this field. If you want the primary bin suggestion, put PRIM_BIN_REC in this field.
from_cont | No | If receiving from a container, put the container number in this field
from_good | Yes | Is the received inventory from good stock?
to_loc | Yes | Inventory location (or expense GL) to receive to
to_bin | No | The inventory bin to receive to. If to a container, put the container name in this field. If you want the primary bin suggestion, put PRIM_BIN_REC in this field
to_cont | No | If receiving to a container, put the container number in this field
to_good | Yes | Is the received inventory put in good stock?
Quantity_num | Yes | How many units to receive (must = 1 for serialized parts)
serial_num | Yes | Serial number to receive (must be blank for quantity parts)
status_str | No | New status of part request. Must be a valid status for Received condition. If no status supplied, default status is used
carrier_name | No | Site name of the carrier. Left blank if not supplied
waybill_name | No | Waybill of receipt
poss_damage | Yes | Is the receipt possibly damaged?
not_prop_pack | Yes | Is the receipt not properly packed?
route_to_test | Yes | Should the receipt be routed to test?
user_name | No | The user who received the part request. If left blank, the current user performs the receive.
receive_date | No | When was the part request received. If this parameter is left blank, the PR is received at the current time
auto_close | Yes | If all of the inventory for this part request is received (or an overrage), should the part request be closed as well? And if it is closed, and no other details exist for the header, should the header be closed as well?
gen_time_bombs | Yes | Should a time_bomb be generated

Returns

Value | Meaning
0 | No errors
+1 | No errors, but received overage
-1 | From bin and to bin may not be the same bin
-2 | Cannot receive 0 (or fewer) units
-3 | Cannot receive > 1 unit for serialized parts
-4 | Specified user is not found
-5 | Cannot find specified part request (demand_dtl)
-6 | Cannot find the specified from location/bin
-7 | Cannot find the specified to location/bin
-8 | Carrier site cannot be found
-9 | Cannot find the specified status
-10 | Cannot find the part number for the part request
-11 | Serial number specified for quantity tracked part
-12 | No serial number specified for serial tracked part
-13 | No transition exists between current condition and condition Received
-14 | User's privclass does not allow to transition between part request's condition and condition Received
-15 | Cannot find the activity string for RECEIVE with rank = 12200
-16 | The transition (to CLOSED) for auto-close is not found or allowed
-17 | The part request is currently dispatched to a queue
-18 | Cannot find the activity string for CREATE PART REQUEST with rank = 9900
-19 | Attempted to receive inventory from a sealed container
-20 | Attempted to receive inventory into a sealed container
-21 | Could not locate "From" primary bin recommendation
-22 | Could not locate "To" primary bin recommendation
-23 | Part request is closed. You may not receive against it.
-24 | The employee record for the specified user cannot be found
-25 | Can't locate Part with serial number
-26 | Unable to retrieve next detail sequence number for PR Header
-27 | Part Request Header is not related to a Site

Part Transfer Error Codes:

Value | Meaning
-120 | Serial number is found in inventory, but not at the specified "from" bin
-121 | The serialized part cannot be found at the specified from location and the from location is not a GL account that allows a part to be created.

Note: Any other error codes between -100 and -199 are from part transfer. Add 100 to the error code, and check the error code in the part transfer section of this document.

Examples

Receive against part request number '1-14'. Receive from expense GL 'EXPGL' and to the primary bin at the Austin location. All inventory is good. Receive 12 units. Auto-close. Generate time bombs.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.receive_pr("1-14", "EXPGL", "", "", True, "Austin", _
                           "PRIM_BIN_REC", "", True, 12, "", "", "", "", _
                           False, False, False, "", "",True, True)

JavaScript:

var ret_int = fccl.receive_pr("1-14", "EXPGL", "", "", True, "Austin",
                           "PRIM_BIN_REC", "", True, 12, "", "", "", "",
                           false, false, false, "", "",true, true);

Receive against part request number '2-1'. Receive from location Austin/Bin 1 to container 44 (name Fred) in Austin. The inventory was good, but is received as bad. It is serialized with serial number 'A123'. Set up a carrier site, and a waybill. Sam does the reeceive at 10PM on November 23rd of 2001. Mark the shipment as possibly damaged, and to be routed to test. Change the status to 'Received QA'. Don't generate a time bomb or auto-close.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.receive_pr("2-1", "Austin", "Bin 1", "", True, "Austin", _
                         "Fred", "44", False, 1, "A123", "Received QA", _
                         "Site 1", "Waybil 34843834", True, False, True, _
                         "sam", "11/23/01 22:00:00", False, False)

JavaScript:

var ret_int = fccl.receive_pr("2-1", "Austin", "Bin 1", "", True, "Austin",
                         "Fred", "44", False, 1, "A123", "Received QA",
                         "Site 1", "Waybil 34843834", True, False, True,
                         "sam", "11/23/01 22:00:00", False, False);


reject_pr | fcSDK Documentation

reject_pr

Public Function reject_pr(ByVal pr_id As String, _
                          ByVal reject_date As String, ByVal wipbin_name As String, _
                          ByVal note_str As String, ByVal user_name As String, _
                          ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified part request to be rejected from the queue it is disptached to. The date and user performing the reject can be specified, and the call allows the part request to be placed back in any WIPBin of the owner. This is an augmentation over base Clarify where it is always rejected back to the default WIPBin. Also, the API allows for time bombs (for business rules) to be created, or not.

Parameters

Parameter Name | Required? | Description
pr_id | Yes | The part request to reject
reject_date | No | When did the reject occur. If left blank, current time is used
wipbin_name | No | The owner's WIPBin in which to place the part request. If left blank, it is rejected to the default WIPBin
note_str | No | Notes about the reject
user_name | No | Who performed the reject? If left blank, current user is used
gen_time_bombs | Yes | Should a time bomb record be created for business rule notification?

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified part request
-2 | The part request is not currently dispatched
-3 | Cannot find the specified user
-4 | The part request is currently closed - cannot dispatch
-5 | Cannot find the new specified WIPBIN, or it is not a WIPBIN for the specified user
-6 | Cannot find REJECT activity string with rank = 2600

Examples

Reject part request number '1-14' to WIPBin 'Hardware'. The reject occurs on August 1, 2001, and is performed by Marty. Generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.reject_pr("1-14", "8/1/2001", "Hardware", "notes", "marty", True)

JavaScript:

var ret_int = fccl.reject_pr("1-14", "8/1/2001", "Hardware", "notes", "marty", true);

Reject part request number '2-1' to the default WIPBin. Do the reject now and with the current user. Do not generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.reject_pr("2-1", "", "", "", "", False)

JavaScript:

var ret_int = fccl.reject_pr("2-1", "", "", "", "", false);


reopen_pr | fcSDK Documentation

reopen_pr

Public Function reopen_pr(ByVal pr_id As String, _
                          ByVal new_status As String, ByVal wipbin_name As String, _
                          ByVal reopen_date As String, ByVal user_name As String, _
                          ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified part request to be reopened. If the part request is not currently closed, the API will reject the attempt. The caller may specify the new status (in condition "RQST Reopened"), and the date of reopen, as well as the user performing the reopen. The WIPBIN in which to place the part request can be specified, which is an augmentation to base Clarify. If no WIPBIN is specified, the default one is used.

The API will validate that the user has authority to make the status transition. Also, the API allows for time bombs (for business rules) to be created, or not.

Parameters

Parameter Name | Required? | Description
pr_id | Yes | The part request to reject
new_status | No | The status (in condition RQST REOPENED) for the part request. If left blank, the default status is used
wipbin_name | No | The WIPBIN to place the part request in. If left blank, the default WIPBIN for the user is used
reopen_date | No | When did the reopen occur. If left blank, current time is used
user_name | No | Who performed the reopen? If left blank, current user is used
gen_time_bombs | Yes | Should a time bomb record be created for business rule notification?

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified part request
-2 | The part request is not closed
-3 | Cannot find the specified user
-4 | Cannot find the REOPEN PART REQUEST activity string with rank = 459752540
-5 | The transition to RQST REOPENED condition does not exist
-6 | The user is not authorized to make the transition to RQST REOPENED condition
-7 | The new status is not found for RQST REOPENED condition
-8 | Cannot find the specified WIPBIN
-9 | The employee record for the specified user cannot be found

Examples

Reopen part request number '1-14' to WIPBin 'Hardware'. The status should be "Reopen again!", and it was performed by Cindy. The reopen occurs on August 1, 2001. Generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.reopen_pr("1-14", "Reopen again!", "Hardware", "8/1/2001", _
                         "cindy", True)

JavaScript:

var ret_int = fccl.reopen_pr("1-14", "Reopen again!", "Hardware", "8/1/2001",
                         "cindy", true);

Reopen part request number '2-1' to the default WIPBin, default status. Do the reject now and with the current user. Do not generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.reopen_pr("2-1", "", "", "", "", False)

JavaScript:

var ret_int = fccl.reopen_pr("2-1", "", "", "", "",false);


seal_container | fcSDK Documentation

seal_container

Public Function seal_container(ByVal cont_name As String) As Integer

Description

This API seals an existing container.

Parameters

Parameter Name | Required? | Description
cont_name | Yes | The container to seal

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the container
-2 | The container is already sealed
-3 | One or more of the child containers is still open

Examples

Seal container Fred.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl. seal_container("Fred")

JavaScript:

var ret_int = fccl. seal_container("Fred");


set_cl_transition | fcSDK Documentation

set_cl_transition

Public Function set_cl_transition(request_type As String, start_cond As String, _
                                  end_cond As String, privclasses As String) As Long

Description

This API allows you to create or modify Logistics Transitions in the database. You must specify all of the arguments. If a transition does not yet exist for the conditions and request type, a new transition is created. Otherwise, the existing transition is modified.

Parameters

Parameter Name | Required? | Description
request_type | Yes | Part request request type
start_cond | Yes | Starting condition for the transition
end_cond | Yes | Ending condition for the transition
privclasses | Yes | Comma-separated list of privclasses that can make this transition. If you set this string to "ALLCLASSES", all privclasses can make the transition. If you set this string to "NOCLASSES", no privclasses can make this transition

Returns

Value | Meaning
0 | No Errors
-1 | Cannot find the specified request type
-2 | The specified start condition is not valid
-3 | The specified end condition is not valid
-4 | Too many transitions are already defined. Cannot add a new transition

Examples

Add a transition from RQST Open to Fulfilled for "Advance Exchange" type. The transition is for privclasses "CSR" and "System Administrator".

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.set_cl_transition("Advance Exchange", "RQST Open", _
        "Fulfilled", "CSR, System Administrator")

JavaScript:

var ret_int = fccl.set_cl_transition("Advance Exchange", "RQST Open",
        "Fulfilled", "CSR, System Administrator");

Set transitions for every privclass for the above transition

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.set_cl_transition("Advance Exchange", "RQST Open", _
    "Fulfilled", "ALLCLASSES")

JavaScript:

var ret_int = fccl.set_cl_transition("Advance Exchange", "RQST Open", "Fulfilled", "ALLCLASSES");


set_part_stocking_lev | fcSDK Documentation

set_part_stocking_lev

Public Function set_part_stocking_lev(ByVal bin_name As String, _
                           ByVal location_name As String, ByVal queue_name As String, _
                           ByVal part_number As String, ByVal mod_level As String, _
                           ByVal domain_name As String, ByVal part_minimum As Integer, _
                           ByVal part_maximum As Integer, ByVal part_rol As Integer, _
                           ByVal part_roq As Integer, ByVal is_active As Boolean) As Integer

Description

This API creates a part restocking authorization level. The location, bin, part number/revision/domain must be specified, as well as the various levels and the reorder queue.

Parameters

Parameter Name | Required? | Description
bin_name | Yes | The bin for the restocking
location_name | Yes | The location for the bin
queue_name | Yes | The queue that the reorder part request will be dispatched to
part_number | Yes | The part to restock
mod_level | Yes | The revision to restock
domain_name | Yes | The domain for the part
part_minimum | Yes | Minimum quantity for bin
part_maximum | Yes | Maximum quantity for bin
part_rol | Yes | The level at which a reorder is triggered
part_roq | Yes | If a reorder happens, how many get reordered
is_active | Yes | Is this restocking entry active?

Returns

Value | Meaning
0 | No Errors
-1 | Missing queue parameter
-2 | Missing location parameter
-3 | Missing part number
-4 | Part reorder level < minimum
-5 | Part reorder level > maximum
-6 | Part reorder level < 0
-7 | Part reorder qty < 0
-8 | Part minimum < 0
-9 | Part maximum < 0
-10 | Location does not exist
-11 | Bin does not exist for given location
-12 | Queue does not exist
-13 | Mod level does not exist
-16 | Part authorization record already exists
ret_objid | Output - Returns the objid of the [newly created] part stocking location

Examples

Set a reorder for Bin 2 in Austin for the "CD Rom" part. Set levels and dispatch queue to "High".

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.set_part_stocking_lev("Bin 2", "Austin", "High", "CD Rom", "", _
                                         "Quantity", 2, 100, 10, 20, True)

JavaScript:

var ret_int = fccl.set_part_stocking_lev("Bin 2", "Austin", "High",
        "CD Rom", "", "Quantity", 2, 100, 10, 20, True);


ship | fcSDK Documentation

ship

Public Function ship(ByVal dtl_num As String, _
                     ByVal site_name As String, ByVal address_1 As String, _
                     ByVal address_2 As String, ByVal city_name As String, _
                     ByVal state_name As String, ByVal zip_code As String, _
                     ByVal country_name As String, ByVal f_name As String, _
                     ByVal l_name As String, ByVal waybill_name As String, _
                     ByVal pack_list As String, ByVal piece_count As Long, _
                     ByVal total_weight As Double, ByVal status_str As String, _
                     ByVal ship_date As String, ByVal user_name As String, _
                     ByVal carrier_name As String, ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified part request to be shipped. All of the shipping information is defaulted from that part request header's shipping site (and contact) information. However, that information can be overridden with the fields specified for the API. You can override any of the address fields, the contact name fields, and the site name (for shipping). The API also allows for the setting of a new status (in condition Shipped), or will use the default status if none is supplied. The carrier name (which is actually the name of a site) can be specified, or it will default to the dummy site (objid of -2). If you pass in "fill_from_db" in the site_name, addr, addr2, city, state, zip, country, f_name, or l_name fields, you can force each field to be filled with the corresponding data from the database.

Other information about the shipment (number of pieces, overall weight, etc.) can be specified, as can be the shipping user and the date/time of shipment.

The API will validate that the user has authority to make the status transition. Also, the API allows for time bombs (for business rules) to be created, or not.

Parameters

Parameter Name | Required? | Description
dtl_num | Yes | The part request to ship
site_name | No | Site name to ship to
addr | No | Address line 1 to ship to
addr2 | No | Address line 2 to ship to
city | No | City to ship to
state | No | State to ship to
zip | No | Zipcode to ship to
country | No | Country to ship to
f_name | No | Contact first name for attention in shipping
l_name | No | Contact last name for attention in shipping
waybill | No | Waybill information for the shipment
pack_list | No | Packing list information for the shipment
pieces | No | Number of pieces shipped
weight | No | Overall weight shipped
status | No | New status (in condition Shipped) for the part request. If blank, default status for the condition is used
ship_date | No | When did the ship occur. If left blank, current time is used
user_name | No | Who performed the ship? If left blank, current user is used
carrier_name | No | The carrier of the shipment? If left blank, the dummy site (objid of -2) is used
gen_time_bombs | Yes | Should a time bomb record be created for business rule notification?

Returns

Value | Meaning
0 | No errors
-1 | Quantity to ship (from part request) can't be < 1 unit
-2 | Cannot find the specified user
-3 | Cannot find the specified part request
-4 | No address line 1 either specified or found in the shipping address
-5 | No city either specified or found in the shipping address
-6 | No state either specified or found in the shipping address
-7 | The transition to SHIPPED condition does not exist
-8 | The user is not authorized to make the transition to SHIPPED condition
-9 | Cannot locate activity string for SHIP with rank = 12500
-10 | Cannot find the specified status
-11 | The part request is currently dispatched to a queue
-12 | The employee record for the specified user cannot be found
-13 | Cannot find the specified carrier site

Examples

Ship part request number '1-14' using an address and a status of "All Shipped". Fill in other shipping information, and it was performed by Cindy. The shipping occurs on August 1, 2001. Generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.ship("1-14", "A site", "101 Main Street", "Suite 101", _
          "Any city", "Any State", "11111", "Country", "Joe", _
          "Customer", "Waybill 1234", "Packed all of it!", _
          4, 4.56, "All Shipped", "8/1/2001 8:11:00", "cindy", "Fed Ex", True)

JavaScript:

var ret_int = fccl.ship("1-14", "A site", "101 Main Street", "Suite 101",
         "Any city", "Any State", "11111", "Country", "Joe",
         "Customer", "Waybill 1234", "Packed all of it!",
         4, 4.56, "All Shipped", "8/1/2001 8:11:00", "cindy", "Fed Ex", True);

Ship part request number '2-1'. Use all the default information. Do not generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.ship("2-1", "", "", "", "", "", "", "", "", "", _
"Waybill 1234", "Packed all of it!", 4, 4.56, "", "", "", "", False)

JavaScript:

var ret_int = fccl.ship("2-1", "", "", "", "", "", "", "", "", "",

"Waybill 1234", "Packed all of it!", 4, 4.56, "", "", "", "", False);


unpick | fcSDK Documentation

unpick

unpick_sn

unpick_no_trans

unpick_sn_no_trans

Public Function unpick(ByVal dtl_num As String, _
                       ByVal loc_name As String, ByVal bin_name As String, _
                       ByVal cont_num As String, ByVal use_good As Boolean, _
                       ByVal user_name As String, ByVal unpick_date As String, _
                       ByVal gen_time_bombs As Boolean) As Integer

Public Function unpick_sn(ByVal dtl_num As String, ByVal loc_name As String, _
                          ByVal bin_name As String, ByVal cont_num As String, _
                          ByVal use_good As Boolean, ByVal user_name As String, _
                          ByVal unpick_date As String, ByVal serial_no As String, _
                          ByVal gen_time_bombs As Boolean) As Integer

Public Function unpick_no_trans(ByVal dtl_num As String, _
                       ByVal loc_name As String, ByVal bin_name As String, _
                       ByVal cont_num As String, ByVal use_good As Boolean, _
                       ByVal user_name As String, ByVal unpick_date As String, _
                       ByVal gen_time_bombs As Boolean) As Integer

Public Function unpick_sn_no_trans (ByVal dtl_num As String, ByVal loc_name As String, _
                          ByVal bin_name As String, ByVal cont_num As String, _
                          ByVal use_good As Boolean, ByVal user_name As String, _
                          ByVal unpick_date As String, ByVal serial_no As String, _
                          ByVal gen_time_bombs As Boolean) As Integer

Description

This API allows for the unpicking (unreserving) of inventory parts for a part request. The API will search in the specified location and bin (for good or bad inventory), and will unreserve it for the part request, but only if it was previously reserved.

The "no_trans" versions of the APIs perform exactly the same work as the other versions of the APIs. The only difference is that these versions of the APIs do not check the logistics transitions, and do not change the condition/status of the part request detail. This allows for multiple calls to the API to be performed without extra complex transitions being added to the system.

This API does have a loophole (as does base Clarify) that if you (for example) pick parts in multiple bins, and then try to unpick from one bin, it will try to unpick as many units as possible (quantity-tracked only). It may unpick more units in a bin than it originally picked in that bin. This is because Clarify only remembers that a part request picked against a bin (and how many units total are picked in that bin). It does not remember how many units were picked for a particular part request. Note that this is not an issue with serialized parts.

The API supports unpicking from a container object, as well as from a bin. If the part request was soft picked, the API will perform a soft unpick.

The API can also unpick a specific unit indicated by a serial number. To do this, specify the serial number using the unpick_sn API. This will pass the serial number along to the unpick API, and the specific part will be released. If the part request was created using a serialized site part, then in order to unpick an inventory part you must use the unpick_sn API and specify the specific serial number or use the keyword "inventory" as the serial number. This will force the API to ignore the serial number stored in the part request and allow the unpick to occur against the inventory part.

The unpick API will unpick either quantity or serialized parts, based on the part number/site_part of the part request.

The unpick API will also validate that the part request can be transitioned (for the specified user)

Parameters

Parameter Name | Required? | Description
dtl_num | Yes | The part request to receive against
loc_name | Yes | The inventory location to unpick from
bin_name | Yes | The inventory bin to unpick from. If from a container, put the container name in this field.
cont_num | No | If unpicking from a container, put the container number in this field
use_good | Yes | Is the unpicked inventory from good stock?
user_name | No | The user who unpicked the part request. If left blank, the current user performs the unpick.
unpick_date | No | When was the part request unpicked. If this parameter is left blank, the PR is unpicked at the current time
gen_time_bombs | Yes | Should a time_bomb be generated

Returns

Value | Meaning
0 | No errors
+1 | We unpicked some, but not all units picked for this part request
-1 | Cannot find the specified user
-2 | Cannot find the specified part request
-3 | There are no units that need to be unpicked for the part request
-4 | No transition exists between current condition and condition Unpicked
-5 | User's privclass does not allow to transition between part request's condition and condition Unpicked
-6 | Cannot find the activity string for UNPICK with rank = 12800
-7 | Cannot find the default state for condition Unpicked
-8 | For serialized parts, the part is not at the specified location/bin
-9 | This part request has not picked against the location/bin
-10 | There is no quantity of parts to unpick at the location/bin
-11 | The part request is currently dispatched to a queue
-12 | The employee record for the specified user cannot be found

Part Transfer Error Codes:

| -120 | Serial number is found in inventory, but not at the specified "from" bin | | -121 | The serialized part cannot be found at the specified from location and the from location is not a GL account that allows a part to be created. |

Examples

Unpick inventory for part request number '1-14' from Austin's Bin 12. The unpick is performed by Dan on January 1, 2001, and is from bad inventory. Generate time bombs.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.unpick("1-14", "Austin", "Bin 12", "", False, "dan", _
     "1/1/2001", True)

JavaScript:

var ret_int = fccl.unpick("1-14", "Austin", "Bin 12", "", false, "dan",
         "1/1/2001", true);

Unpick against part request number '2-1'. Unpick from location Austin/Container 44 (name of Fred). Use the default user and time, and use good stock. Don't generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.unpick("2-1", "Austin", "Fred", "44", True, "", "", True)

JavaScript:

var ret_int = fccl.unpick("2-1", "Austin", "Fred", "44", true, "", "", true);


update_pr_detail | fcSDK Documentation

update_pr_detail

update_pr_detail_list

Public Function update_pr_detail(ByVal dtl_num As String, _
                        ByVal part_num As String, ByVal domain_name As String, _
                        ByVal mod_level As String, ByVal serial_no As String, _
                        ByVal quantity_num As Long, ByVal sp_objid As Long, _
                        ByVal dtl_type As String, ByVal priority_str As String, _
                        ByVal ship_via As String, ByVal carrier_name As String, _
                        ByVal warranty As Integer, ByVal note_str As String, _
                        ByVal status_str as String, ByVal int_fld1 As String, _
                        ByVal int_val1 As Long, ByVal int_fld2 As String, _
                        ByVal int_val2 As Long, ByVal str_fld1 As String, _
                        ByVal str_val1 As String, ByVal str_fld2 As String, _
                        ByVal str_val2 As String, ByVal date_fld1 As String, _
                        ByVal date_val1 As String) As Integer

Public Function update_pr_detail_list(ByVal dtl_num As String, _
                        ByVal part_num As String, ByVal domain_name As String, _
                        ByVal mod_level As String, ByVal serial_no As String, _
                        ByVal quantity_num As Long, ByVal sp_objid As Long, _
                        ByVal dtl_type As String, ByVal priority_str As String, _
                        ByVal ship_via As String, ByVal carrier_name As String, _
                        ByVal warranty As Integer, ByVal note_str As String, _
                        ByVal status_str As String, Optional fld_list As Variant, _
                        Optional type_list As Variant, Optional val_list As Variant) _
                        As Integer

Description

These APIs allow for the updating of part request details. You must supply the detail number, and any other attributes you wish to update. If an attribute is left blank, the API will not update the value. If you modify the part/mod_level for the part request, or the site_part, you must supply either a valid site_part record, or you must supply the part_num, mod_leve, AND domain. You may optionally specify the serial_no field if it is a site_part (serialized).

Parameters

Parameter Name | Required? | Description
dtl_num | Yes | The part request to update
part_num | No | Part number to update the part request to. If no new part/revision for part request, leave this field blank.
mod_level | No | Revision to udpate the part request to. If no new part/revision for part request, leave this field blank.
domain_name | No | Domain for the part number. If no new part/revision for part request, leave this field blank.
serial_no | No | Serial number for the new site_part for the part request
quantity_num | Yes | New quantity for the part request. Use 0 if no change in this field
sp_objid | Yes | Objid of new site_part for the part request (if known as a record). If no new site_part record to set, use 0 for this parameter
dtl_type | No | New type of the detail. If blank, no change is made
priority_str | No | New priority of the detail. If blank, no change is made
ship_via | No | New ship_via of the detail. If blank, no change is made
carrier_name | No | New carrier of the detail. If blank, no change is made
warranty | No | Indicator for part warranty information
note_str | No | New detail notes for the part request. If blank, no change is made. If this field is set to "CLEAR", the notes will be cleared
status_str | No | Initial PR detail status. If blank, default status of "RQST OPEN" used
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name

Returns

Value | Meaning
0 | No Errors
-1 | Specified quantity must be >= 0
-2 | Cannot find the specified detail
-3 | The specified detail type is not found
-4 | The specified detail priority is not found
-5 | The specified detail ship_via is not found
-6 | The specified detail carrier is not found
-7 | The specified status was not found for RQST Open
-8 | Cannot find the specified part_num/domain/revision
-9 | Cannot find the specified serial number for the part/revision
-10 | The site_part record does not have a related part revision

Examples

Update part request '3-3'. Change the part to 'MS Word, revision 7.0' (no site_part). Change the ship_via, and one extra field.

Visual Basic:

Dim ret_int As Integer
Dim sp_objid As Long

sp_objid = 0

ret_int = fccl.update_pr_detail("3-3", "MS Word", "Product", "7.0", "", _
                   1, sp_objid, "", "", "Fedex","", 0, "","","", _
                   0, "", 0, "detail_notes", "xyzzy", "", "", "", "")

JavaScript:

var ret_int = fccl.update_pr_detail("3-3", "MS Word", "Product", "7.0", "",
                   1, sp_objid, "", "", "Fedex", "", 0, "","", "",
                   0, "", 0, "detail_notes", "xyzzy", "", "", "", "");

Update part request '3-3'. Change the part to 'MS Word, revision 7.0', serial number 123. Change the carrier and the notes, and no extra fields.

Visual Basic:

Dim ret_int As Integer
Dim sp_objid As Long

sp_objid = 0

ret_int = fccl.update_pr_detail("3-3", "MS Word", "Product", "7.0", "123", _
          1, sp_objid, "", "", "", "UPS", 0, "Some notes", _
          "", "", 0, "", 0, "", "", "", "", "", "")

JavaScript:

var ret_int = fccl.update_pr_detail("3-3", "MS Word", "Product", "7.0", "123",
       1, sp_objid, "", "", "", "UPS", 0, "Some notes",
       "", "",0, "", 0, "", "", "", "", "", "");


update_pr_header | fcSDK Documentation

update_pr_header

update_pr_header_list

Public Function update_pr_header(ByVal hdr_num As String, _
                               ByVal first_name As String, ByVal last_name As String, _
                               ByVal phone_num As String, ByVal ship_site_id As String, _
                               ByVal bill_site_id As String, ByVal case_id As String, _
                               ByVal pay_method As String, ByVal pay_terms As String, _
                               ByVal priority_str As String, ByVal note_str As String, _
                               ByVal int_fld1 As String, ByVal int_val1 As Long, _
                               ByVal int_fld2 As String, ByVal int_val2 As Long, _
                               ByVal str_fld1 As String, ByVal str_val1 As String, _
                               ByVal str_fld2 As String, ByVal str_val2 As String, _
                               ByVal date_fld1 As String, ByVal date_val1 As String) _
                               As Integer

Public Function update_pr_header_list(ByVal hdr_num As String, _
                               ByVal first_name As String, ByVal last_name As String, _
                               ByVal phone_num As String, ByVal ship_site_id As String, _
                               ByVal bill_site_id As String, ByVal case_id As String, _
                               ByVal pay_method As String, ByVal pay_terms As String, _
                               ByVal priority_str As String, ByVal note_str As String, _

                               Optional fld_list As Variant, Optional type_list As Variant, _
                               Optional val_list As Variant) As Integer

Description

These APIs allow for the updating of part request headers. You must supply the header number, and any other attributes you wish to update. If an attribute is left blank, the API will not update the value. Two of the attributes allow you to clear the previous result. To clear the related case number, or to clear the header notes, put the string "CLEAR" for the argument. If you leave an argument blank, the value in the header record is not changed. If you want to change the contact for the part request, you must supply first name, last name, and phone number for the contact.

Parameters

Parameter Name | Required? | Description
hdr_num | Yes | The part request to update
first_name | No | First name of contact for part request
last_name | No | Last name of contact for part request
phone_num | No | Phone number of contact for part request
ship_site_id | No | Site ID of shipping site for part request
bill_site_id | No | Site ID of billing site for part request
case_id | No | ID number of case related to the part request. To clear the case (have no case related to the part request), place "CLEAR" in this argument
pay_method | No | Payment method for the part request
pay_terms | No | Payment terms for the part request
priority_str | No | Priority of the part request
notes_str | No | Additional information about the part request. To clear the text, put the string "CLEAR" in this argument
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name

Returns

Value | Meaning
0 | No Errors
-1 | Cannot find the specified part request header
-2 | The specified contact could not be found
-3 | Cannot find the specified shipping site
-4 | Cannot find the specified billing site
-5 | The specified case ID is not found
-6 | The specified payment method is not found
-7 | The specified payment terms is not found
-8 | The specified priority is not found

Examples

Update part request header '1'. Change the contact to Sara Grinch, change the billing site ID to 43, the case ID to 14, the payment terms and method, and one extra field.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.update_pr_header("1", "Sara", "Grinch", "555-1212", "", _
                                "43", "14", "Cash", "Net 10", "", "", "", 0, _
                                "",0, "x_extra_field", "a_value", "", "", "", _
                                "")

JavaScript:

var ret_int = fccl.update_pr_header("1", "Sara", "Grinch", "555-1212", "",
                                "43", "14", "Cash", "Net 10", "", "", "", 0,
                                "",0, "x_extra_field", "a_value", "", "", "",
                                "");

Update part request header '33'. Change the shipping site to '55', change the priority, and clear the notes for the header.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.update_pr_header("33", "", "", "", "55", "", _
                                "", "", "", "Priority 1", "CLEAR", "", _
                                0, "", 0, "", "", "", "", "", "")

JavaScript:

var ret_int = fccl.update_pr_header("33", "", "", "", "55", "",
                                "", "", "", "Priority 1", "CLEAR", "",
                                0, "", 0, "", "", "", "", "", "");


yank_pr | fcSDK Documentation

yank_pr

Public Function yank_pr(ByVal pr_id As String, _
                        ByVal wipbin_name As String, ByVal yank_date As String, _
                        ByVal user_name As String, ByVal gen_time_bombs As Boolean) _
                        As Integer

Description

This API causes the specified part request to be yanked and placed in a specific WIPBin. The person perfoming the yank (the new owner) and the time of the yank can be specified. Also, the API allows for time bombs (for business rules) to be created, or not.

Parameters

Parameter Name | Required? | Description
pr_id | Yes | The part request to yank
wipbin_name | No | The WIPBin in which to place the part request. If left blank, it is yanked to the default WIPBin
yank_date | No | The date/time to yank the part request. If left blank, the current date/time is used
user_name | No | Who performed the yank? If left blank, current user is used
gen_time_bombs | Yes | Should a time bomb record be created for business rule notification?

Returns

Value | Meaning
0 | No Errors
-1 | Cannot find the specified part request
-2 | The part request is already closed
-3 | Cannot find the specified user
-4 | Cannot find the specified WIPBIN
-5 | Cannot find the YANK activity string with rank 4100

Examples

Yank part request number '1-14' to WIPBin 'Hardware'. The yank occurs on August 1, 2001, and is performed by Marty. Generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.yank_pr("1-14", "Hardware", "8/1/2001", "marty", True)

JavaScript:

var ret_int = fccl.yank_pr("1-14", "Hardware", "8/1/2001", "marty", true);

Yank part request number '2-1' to the default WIPBin. Do the yank now and with the current user. Do not generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fccl.yank_pr("2-1", "", "", "", False)

JavaScript:

var ret_int = fccl.yank_pr("2-1", "", "", "", false);


FCFL API Toolkit for ClearQuality | fcSDK Documentation

FCFL API Toolkit for ClearQuality

Overview

Many customers have wanted the ability to customize the Clarify environment easily by adding base Clarify functions (such as change request creation, closure, modification, or note logging) to web applications.

The First Choice Software FCFL API Toolkit for Clear Quality solves these problems, as well as many others. The toolkit is a series of COM functions that you may add to your customizations.

All of the APIs perform the same base functions as the Clarify GUI - all database records are properly written, activity logs are generated to track the API call, and time bombs are added to the system so that business rules can be fired based on the API function call.

While all of the APIs mimic the Clarify base function, many of them provide augmented functionality that Clarify customers have requested. For example, the base Clarify yank function always placed the object in the user's default WIPBin. With the yank API in the toolkit, you have the choice of placing the object in any specific WIPBin for the user, or in the default WIPBin.

The APIs are simple to use. One simple API call is provided for each function, and very few data values must be supplied. The APIs are flexible in that they provide a large number of optional arguments that allow you to customize the API calls as needed.


accept_cr | fcSDK Documentation

accept_cr

Public Function accept_cr(ByVal cr_id As String, _
                          ByVal accept_date As String, _
                          ByVal wipbin_name As String, _
                          ByVal user_name As String, _
                          ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified change request to be accepted from a dispatched queue. The change request must be currently dispatched to a queue. The date/time of the accept, the WIPBin to place the change request in, and the user performing the accept can be specified. The API can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
cr_id | Yes | The change request to accept
accept_date | No | When was the change request accepted. If this parameter is left blank, the CR is accepted at the current time
wipbin_name | No | The WIPBin to place the change request in (for the user who accepted CR) If left blank, the change request is placed in the user's default WIPBin
user_name | No | The user who accepted the CR. If left blank, the current user performs the accept
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified change request
-2 | Change request is not currently dispatched
-3 | Specified user is not found
-4 | The specified WIPBin is not valid for the user
-5 | Cannot find gbst_elm rank 100 for string ACCEPT

Examples

Accept CR number '10' right now for the current user, place in the default WIPBin, and generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fccq.accept_cr("10", "", "", "", True)

JavaScript:

var ret_int = fccq.accept_cr("10", "", "", "", true);

Accept change request number '2' at 10PM on November 23rd of 1997 by marty, and place the change request in marty's WIPBin named 'Urgent'. Don't generate a time bomb

Visual Basic:

Dim ret_int As Integer

ret_int = fccq.accept_cr("2", "11/23/97 22:00:00", "Urgent", "marty", False)

JavaScript:

var ret_int = fccq.accept_cr("2", "11/23/97 22:00:00", "Urgent", "marty", false);


add_module_to_cr | fcSDK Documentation

add_module_to_cr

Public Function add_module_to_cr(ByVal fix_objid As Long, _
                                 Byval file As String, _
                                 ByVal rev As String) As Integer

Description

This API allows for adding a module (file name and revision from a source control system) to the list of modules fixed for a given fix of a CR. The fix_objid must be the objid of a specific fix_bug record. No checking is performed to validate that the file/revision is valid in the source control system.

Parameters

Parameter Name | Required? | Description
fix_objid | Yes | The objid of the fix_bug record
file | Yes | Name of the file fixed
rev | No | Revision of file fixed

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified fix bug record
-2 | A fixed module file was not provided

Examples

Add file 'foo.c', revision 3.32 to a specific fix_bug record.

Visual Basic:

Dim ret_int As Integer

ret_int = fccq.add_module_to_cr(268435666, "foo.c", "3.32")

JavaScript:

var ret_int = fccq.add_module_to_cr(268435666, "foo.c", "3.32");


assign_cr | fcSDK Documentation

assign_cr

Public Function assign_cr(ByVal cr_id As String, _
                          ByVal new_user As String, _
                          ByVal wipbin_name As String, _
                          ByVal assign_date As String, _
                          ByVal user_name As String, _
                          ByVal gen_time_bombs As Boolean) As Integer

Description

This API cause the specified change request to be assigned to a new user. The CR must be in an Open condition, and the user assigning the change request does not have to be the owner of the change request. In base Clarify, the assigner of a change request must be the owner. If either user name is not specified, the "current" user is used. The date/time of the assignment, and the WIPBin to place the change request in can also be specified. Allowing a WIPBin other than the default one is also an augmentation from base Clarify. The API can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
cr_id | Yes | The change request Id to be assigned
new_user | No | The user who the change request is assigned to. If left blank, the CR is assigned to the current user
wipbin_name | No | The WIPBin to place the change request in (for the user who is assigned the CR). If left blank, the change request is placed in the user's default WIPBin
assign_date | No | When was the change request assigned. If this parameter is left blank, the CR is assigned at the current time
user_name | No | The user who assigned the CR. If left blank, the current user performs the assign
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified change request
-2 | The specified change request is not currently open
-3 | Specified user (to assign to) is not found
-4 | The specified WIPBin is not valid for the user
-5 | Specified user (who performed the assign) is not found
-6 | Cannot find gbst_elm rank 10500 for string ASSIGN

Examples

Assign change request number '10' to user 'marty'. The assign is performed by the current user, is placed in the default WIPBin and is assigned at the current time. Generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fccq.assign_cr("10", "marty", "", "", "", True)

JavaScript:

var ret_int = fccq.assign_cr("10", "marty", "", "", "", true);

Assign change request number '2' at 10PM on November 23rd of 1997 to marty, and place the change request in marty's WIPBin named 'Urgent'. Assign should be logged as performed by sam. Don't generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fccq.assign_cr("2", "marty", "Urgent",
   "11/23/97 22:00:00", "sam", False)

JavaScript:

var ret_int = fccq.assign_cr("2", "marty", "Urgent",
                         "11/23/97 22:00:00", "sam", false);


change_cr_state | fcSDK Documentation

change_cr_state

Public Function change_cr_state(ByVal cr_id As String, _
                ByVal new_status As String, new_condition As String, _
                ByVal change_date As String, _
                ByVal notes As String, ByVal user_name As String, _
                ByVal gen_time_bombs As Boolean, _
                ByVal wipbin As String, ByVal test_case As String, _
                ByVal int_release As String, ByVal master_cr As String, _
                ByVal int_fld1 As String, ByVal int_val1 As Long, _
                ByVal int_fld2 As String, ByVal int_val2 As Long, _
                ByVal str_fld1 As String, ByVal str_val1 As String, _
                ByVal str_fld2 As String, ByVal str_val2 As String, _
                ByVal date_fld1 As String, ByVal date_val1 As String) As Integer

Description

This API causes the specified change request to have its status and/or condition changed. This function is basically a wrapper function for multiple APIs (change_cr_status, fix_cr, close_cr, fix_failed, reopen_cr, and duplicate_cr). Depending on the current condition of the CR and the new_condition parameter, the appropriate API will be called.

Current CR Condition | new_condition | Which API is called
Any | Same as Current CR condition | change_cr_status
Any | CR Fixed | fix_cr
Any | CR Closed | close_cr
Any | CR Closed/Duplicate | duplicate_cr
CR Fixed | CR Open | fix_failed
CR Closed | CR Open | reopen_cr
CR Closed/Duplicate | CR Open | reopen_cr

Parameters

Parameter Name | Required? | Description
cr_id | Yes | The change request Id to change status for
new_status | No | The new status for the change request. If blank, the default status is used
new_condition | Yes | The new condition for the change request
change_date | No | When was the CR status changed. If this parameter is left blank, the CR is status changed at the current time
notes | No | Notes for the status change
user_name | No | The user who changed the status. If left blank, the current user performs the change status
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)
wipbin | No | The WIPBin to place the change request in. If left blank, the default WIPBin is used (for reopen_cr)
test_case | No | Test case string for closure (for close_cr and fix_failed)
int_release | No | Release information for the closure (for close_cr and fix_failed)
master_cr | No | The ID of the master (parent) CR (for duplicate_cr)
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name

Returns

All return codes are defined by which API is called, as this API is simply a wrapper.

Examples

Change status for change request number '10' to a new status and condition. The change status is performed by the current user and is changed at the current time. Generate a time bomb.

JavaScript:

var ret_int = FCCQ.change_cr_state("10",strNewStatus,strNewCondition,"",
             strReason,"",true, "",test_case,int_release,master_cr,
             "",0,"",0,"","","","","","")


change_cr_status | fcSDK Documentation

change_cr_status

Public Function change_cr_status(ByVal cr_id As String, _
                                 ByVal new_status As String, _
                                 ByVal change_date As String, _
                                 ByVal notes As String, _
                                 ByVal user_name As String, _
                                 ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified change request to have its status changed. The change request may be in any condition, but the new status MUST have the same condition as the change request's current condition. In other words, you cannot use this API to change the condition of a CR - you must use the proper API (fix, close, reopen) to do that. You may assign notes to the status change, as well as set the time of the status change, and the user who changed the status. The API can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
cr_id | Yes | The change request Id to change status for
new_status | No | The new status for the change request. If blank, the default status is used
change_date | No | When was the CR status changed. If this parameter is left blank, the CR is status changed at the current time
notes | No | Notes for the status change
user_name | No | The user who changed the status. If left blank, the current user performs the change status
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified change request
-2 | Cannot find the new status (or status is not defined for the current object's condition)
-3 | Cannot find the specified user
-4 | Cannot find gbst_elm rank 4900 for string CHG BUG STS
-5 | Status transition not defined in Policies and Customers
-6 | Status transition not allowed for specified user
-14 | Privclass not found for specified user
-15 | Old status not found for old condition
-16 | New status not found for new condition
-17 | Cannot find the specified user's employee record for relating time bomb

Examples

Change status for change request number '10' to the default status. The change status is performed by the current user and is changed at the current time. Add no notes, and generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fccq.change_cr_status("10", "", "", "", "", True)

JavaScript:

var ret_int = fccq.change_cr_status("10", "", "", "", "", true);

Change status for change request number '2' at 10PM on November 23rd of 1997 to 'Solved'. Change status has notes of 'Some notes', and should be logged as performed by mark. Don't generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fccq.change_cr_status("2", "Solved", _
                                "11/23/97 22:00:00", _
                                "Some notes", "mark", False)

JavaScript:

var ret_int = fccq.change_cr_status("2", "Solved",
       "11/23/97 22:00:00", "Some notes", "mark", false);


check_cq_trans | fcSDK Documentation

check_cq_trans

Public Function check_cq_trans(ByVal old_cond As String, _
                                         ByVal old_stat As String, _
                            ByVal new_cond As String, _
                                      ByVal new_stat As String, _
                            ByVal user_name As String) As Integer

Description

This API can be used to determine if a particular user can change status from an old condition/status to a new condition/status. The API checks the transitions as set up in Clarify's Policies & Customers.

Parameters

Parameter Name | Required? | Description
old_cond | Yes | Old condition for the CR
old_stat | Yes | Old status for the CR
new_cond | Yes | New condition for the CR
new_stat | Yes | New status for the CR
user_name | Yes | User performing the transition

Returns

Value | Meaning
0 | Transition is allowed for this user
-1 | Status transition not defined in Policies and Customers
-2 | Status transition not allowed for specified user
-10 | Privclass not found for specified user
-11 | Old status not found for old condition
-12 | New status not found for new condition

Examples

Check if Sam can transition from "In research" in "Open" condition to "Fixed" status in the "Fixed" condition.

Visual Basic:

Dim ret_int As Integer

ret_int = fccq.check_cq_trans("Open", "In research", "Fixed", "Fixed", "sam")

JavaScript:

var ret_int = fccq.check_cq_trans("Open", "In research", "Fixed", "Fixed", "sam");


close_cr | fcSDK Documentation

close_cr

close_cr_list

Public Function close_cr(ByVal cr_id As String, _
                        ByVal the_status As String, _
                        ByVal notes As String, _
                        ByVal test_case As String, _
                        ByVal int_release As String, _
                        ByVal user_name As String, _
                        ByVal close_date As String, _
                        ByVal gen_time_bombs As Boolean, _
                        ByVal int_fld1 As String, ByVal int_val1 As Long, _
                        ByVal int_fld2 As String, ByVal int_val2 As Long, _
                        ByVal str_fld1 As String, ByVal str_val1 As String, _
                        ByVal str_fld2 As String, ByVal str_val2 As String, _
                        ByVal date_fld1 As String, ByVal date_val1 As String) _
                        As Integer

Public Function close_cr_list(ByVal cr_id As String, _
                              ByVal the_status As String, _
                              ByVal notes As String, _
                              ByVal test_case As String, _
                              ByVal int_release As String, _
                              ByVal user_name As String, _
                              ByVal close_date As String, _
                              ByVal gen_time_bombs As Boolean, _
                              Optional fld_list As Variant, _
                              Optional type_list As Variant, _
                              Optional val_list As Variant) As Integer

Description

These APIs are used to close a change request. The change request must be in a condition/status that allows the transition to the closed condition. The APIs allow for the assigning of a closed status, as well as notes, the test cases used to verify the close, and the release. The APIs allow you to specify a user who performed the close, as well as the date/time of closure. The APIs allow for additional fields to be written to the close_bug object. The APIs can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
cr_id | Yes | The change request Id to be closed
the_status | No | The closed condition status for the CR. If left blank, the default status for closed condition is used
notes | No | Notes about the closure
test_case | No | Test case string for closure
int_release | No | Release information for the closure
user_name | No | The user who closed the CR. If left blank, the current user performs the close
close_date | No | The date/time of the close. If left blank, the current time is used
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules).
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors; sets objid of new close_bug object in the ret_objid (Long) global variable
-1 | Cannot find the specified change request
-2 | The specified change request is already closed
-3 | The CR is currently dispatched
-4 | The specified user is not found
-5 | Cannot find gbst_elm rank 4800 for string CHG STS:CLOSED
-6 | The specified status is not a valid status for condition 'CR Closed'
-7 | Status transition not defined in Policies and Customers
-8 | Status transition not allowed for specified user
-16 | Privclass not found for specified user
-17 | Old status not found for old condition
-18 | New status not found for new condition
-19 | Cannot find the specified user's employee record for relating time bomb
ret_objid | Output - Returns the objid of the new change request

Examples

Close change request number '10'. Close with status "Won't fix", add some notes and other information. The close was performed by patty at the current time. Generate a time bomb (for business rule notification). The second field version illustrates how to set the additional fields.

Field version 1:

Visual Basic:

Dim ret_int As Integer
Dim close_objid As Long

ret_int = fccq.close_cr("10", "Won't fix", "Some notes", _
         "Test case 43", "Release 1.2", "patty", "", _
         True, ", 0, "", 0, "", "", "", "", "", "")

 If ret_int = 0 Then
   close_objid = fccq.ret_objid
 End If

JavaScript:

var ret_int = fccq.close_cr("10", "Won't fix", "Some notes",
   "Test case 43", "Release 1.2", "patty", "",
   true, ", 0, "", 0, "", "", "", "", "", "");

if (ret_int == 0){ var close_objid = fccq.ret_objid; }

Field version 2:

Visual Basic:

Dim ret_int As Integer
Dim close_objid As Long

ret_int = fccq.close_cr("10", "Won't fix", "Some notes", _
     "Test case 43", "Release 1.2", "patty", "", True, _
     "x_close_int1", 1, "x_close_int2", 456, _
     "x_summary2", "More text", "", "", _
     "x_other_date", "1/1/99")

 If ret_int = 0 Then
   close_objid = fccq.ret_objid
 End If

JavaScript:

var ret_int = fccq.close_cr("10", "Won't fix", "Some notes",
   "Test case 43", "Release 1.2", "patty", "",true,
   "x_close_int1", 1, "x_close_int2", 456,
   "x_summary2", "More text", "", "",
   "x_other_date", "1/1/99");

 if (ret_int == 0){ var close_objid = fccq.ret_objid;

List version:

Visual Basic:

Dim close_objid As Long

Dim ret_int As Integer
Dim fld_list    As New FCFLCompat.FCList
Dim type_list   As New FCFLCompat.FCList
Dim val_list    As New FCFLCompat.FCList

fld_list.AppendItem "x_close_int1"
type_list.AppendItem "Long"

val_list.AppendItem Trim(Str$(1))

fld_list.AppendItem "x_close_int2"
type_list.AppendItem "Long"
val_list.AppendItem Trim(Str$(456))

fld_list.AppendItem "x_summary2"
type_list.AppendItem "String"
val_list.AppendItem "More text"

fld_list.AppendItem "x_other_date"
type_list.AppendItem "Date"
val_list.AppendItem "1/1/99"

ret_int = fccq.close_cr_list("10", "Won't fix", "Some notes", _
                             "Test Case 43", "Release 1.2", "patty", "", _
                             True, fld_list, type_list, val_list)

close_objid = fccq.ret_objid

JavaScript:

var fld_list  = Server.CreateObject("FCFLCompat.FCList");
var type_list = Server.CreateObject("FCFLCompat.FCList");
var val_list  = Server.CreateObject("FCFLCompat.FCList");

fld_list.AppendItem("x_close_int1");
type_list.AppendItem("Long");
val_list.AppendItem("1");

fld_list.AppendItem("x_close_int2");
type_list.AppendItem("Long");
val_list.AppendItem("456");

fld_list.AppendItem("x_summary2");
type_list.AppendItem("String");
val_list.AppendItem("More text");

fld_list.AppendItem("x_other_date");
type_list.AppendItem("Date");
val_list.AppendItem("1/1/99");

var ret_int = fccq.close_cr_list("10", "Won't fix", "Some notes",
   "Test Case 43", "Release 1.2",
   "patty", "", true, fld_list, type_list, val_list);

var close_objid = fccq.ret_objid;


create_cr | fcSDK Documentation

create_cr

create_cr_list

Public Function create_cr(ByVal part_num As String, _
                          ByVal mod_level As String, _
                          ByVal domain As String, ByVal the_title As String, _
                          ByVal status As String, ByVal note_log As String, _
                          ByVal cr_type As String, ByVal priority As String, _
                          ByVal frequency As String, _
                          ByVal found_on As String, ByVal op_sys As String, _
                          ByVal memory As String, ByVal cr_class As String, _
                          ByVal intro_phase As String, _
                          ByVal test_class As String, _
                          ByVal fixed_in As String, ByVal test As String, _
                          ByVal queue_name As String, _
                          ByVal user_name As String, ByVal cr_date As String, _
                          ByVal gen_time_bombs As Boolean, _
                          ByVal int_fld1 As String, ByVal int_val1 As Long, _
                          ByVal int_fld2 As String, ByVal int_val2 As Long, _
                          ByVal str_fld1 As String, ByVal str_val1 As String, _
                          ByVal str_fld2 As String, ByVal str_val2 As String, _
                          ByVal date_fld1 As String, ByVal date_val1 As String) _
                          As Integer

Public Function create_cr_list(ByVal part_num As String, _
       ByVal mod_level As String, _
       ByVal domain As String, _
       ByVal the_title As String, _
       ByVal status As String, _
       ByVal note_log As String, _
       ByVal cr_type As String, _
       ByVal priority As String, _
       ByVal frequency As String, _
       ByVal found_on As String, _
       ByVal op_sys As String, _
       ByVal memory As String, _
       ByVal cr_class As String, _
       ByVal intro_phase As String, _
       ByVal test_class As String, _
       ByVal fixed_in As String, _
       ByVal test As String, _
       ByVal queue_name As String, _
       ByVal user_name As String, _
       ByVal cr_date As String, _
       ByVal gen_time_bombs As Boolean, _
       Optional fld_list As Variant, _
       Optional type_list As Variant, _
       Optional val_list As Variant) As Integer

Description

These APIs are used to create new change requests. They require that the part number, domain, and revision be specified (for the part to be associated). You may specify a title for the CR, notes, the status, and a variety of other text and code list values.

If you specify a queue name, the CR will be initially dispatched to the queue. Otherwise, it will be located in the owner's WIPBin. You may also list who created the CR, and when it was created. You may specify additional fields for the CR object, and if a time bomb should be generated (for business rule notification). If you dispatch the CR, a second time bomb will be generated. If you add notes to the CR, another time bomb will be generated.

Parameters

Parameter Name | Required? | Description |  |
part_num | Yes | Part number of part for change request |  |
mod_level | Yes | Revision of part for change request |  |
domain | Yes | Domain of the part for the change request |  |
the_title | No | Title of the change request |  |
status | No | Initial status (in condition CR Open) of the change request. If blank, the default status is used | note_log | No Notes about the change request. If blank, no notes are logged
cr_type | No | A code list value from list CR TYPE. If blank, default value is used |  |
priority | No | A code list value from list CR PRIORITY. If blank, default value is used |  |
frequency | No | A code list value from list CR REPRODUCIBLE. If blank, default value is used |  |
found_on | No | Level 1 of the list CR_DESC. If blank, default value is used |  |
os | No | Level 2 of the list CR_DESC. If blank, default value is used |  |
memory | No | Level 3 of the list CR_DESC. If blank, default value is used |  |
cr_class | No | A code list value from list CR_CLASS. If blank, default value is used |  |
intro_phase | No | A code list value from list CR DOMAIN. If blank, default value is used |  |
test_class | No | A code list value from list CR CLASS. If blank, default value is used |  |
fixed_in | No | A code list value from list FIX RELEASE. If blank, default value is used |  |
test | No | Lists of tests for this CR |  |
queue_name | No | Queue to dispatch the CR to. If blank, no dispatch occurs |  |
user_name | No | The user who created the change request. If left blank, the current user is used |  |
cr_date | No | The date the CR was created. If blank, the current date/time is used |  |
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules) |  |
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write |  |
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name |  |
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list |  |
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list |  |
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list |  |

Returns

Value | Meaning
0 | No errors; sets objid and id_number of new bug object in ret_objid (Long) and ret_id_num (String) global variables
-2 | Cannot find the specified user
-3 | Cannot find the part and revision
-4 | The specified status could not be found
-5 | Cannot find gbst_elm rank 4700 for string CREATE CR
-6 | Cannot find gbst_elm rank 1700 for string NOTES
-7 | Cannot find gbst_elm rank 900 for string DISPATCH
-8 | Could not find the specified queue
-10 | Cannot find the CR Type list item
-11 | Cannot find the specified CR Priority
-12 | Cannot find the specified frequency
-13 | Cannot find the specified intro phase
-14 | Cannot find the specified test class
-15 | Cannot find the specified CR class
-16 | Cannot find the specified fixed in release
-17 | Cannot find the specified found_on value (cpu)
-18 | Cannot find the specified op_sys value (operation system)
-19 | Cannot find the specified memory value
-20 | Cannot find the specified user's employee record for relating time bomb
ret_objid | Output - Returns the objid of the change request
ret_id_num | Output - Returns the id of the change request

Examples

Create a new change request. Specify the part of MS Word, revision 1.2. Use the default values for the code list, and generate a time bomb. Add notes from the file "note.txt", and dispatch to queue "High". The second field version illustrates how to set additional fields.

Field version 1:

Visual Basic:

Dim ret_int As Integer
Dim bug_id_num  As String
Dim bug_objid   As Long

ret_int = fccq.create_cr("MS Word"", "1.2", "Product", "CR Title", _
                "", "note.txt", "", "", "", "", "", "", _
                "", "", "", "", "Some tests to run", _
                "High", "", "", True, "", 0, "", 0, "", "", "", _
                "", "", "")

 If ret_int = 0 Then
   bug_id_num = fccq.ret_id_num
   bug_objid = fccq.ret_objid
 End If

JavaScript:

var ret_int = fccq.create_cr("MS Word"", "1.2", "Product",
   "CR Title", "", "note.txt", "", "", "", "", "", "",
   "", "", "", "", "Some tests to run", "High",
   "", "", true, "", 0, "", 0, "", "", "", "", "", "");

 if (ret_int == 0) {
   var bug_id_num = fccq.ret_id_num;
   var bug_objid = fccq.ret_objid;
 }

Field version 2:

Visual Basic:

Dim ret_int As Integer
Dim bug_id_num  As String
Dim bug_objid   As Long

ret_int = fccq.create_cr("MS Word"", "1.2", "Product", "CR Title", _
          "", "note.txt", "", "", "", "", "", "", _
          "", "", "", "", "Some tests to run", "High", _
          "", "", True, "x_create_1", 1, "x_create_2", 2,
          "x_summary2", "More text", "", "", "x_other_date", "1/1/99")

 If ret_int = 0 Then
   bug_id_num = fccq.ret_id_num
   bug_objid = fccq.ret_objid
 End If

JavaScript:

var ret_int = fccq.create_cr("MS Word"", "1.2", "Product", "CR Title",
      "", "note.txt", "", "", "", "", "", "",
      "", "", "", "", "Some tests to run", "High",
      "", "", true, "x_create_1", 1, "x_create_2", 2,
      "x_summary2", "More text", "", "", "x_other_date", "1/1/99");

 if (ret_int == 0) {
   var bug_id_num = fccq.ret_id_num;
   var bug_objid = fccq.ret_objid;
 }

List version:

Visual Basic:

Dim bug_id_num  As String
Dim bug_objid   As Long

Dim ret_int As Integer
Dim fld_list    As New FCFLCompat.FCList
Dim type_list   As New FCFLCompat.FCList
Dim val_list    As New FCFLCompat.FCList

fld_list.AppendItem("dist");
type_list.AppendItem("Long");
val_list.AppendItem("456");

fld_list.AppendItem("attribute2");
type_list.AppendItem("String");
val_list.AppendItem("More text");

fld_list.AppendItem("date_found");
type_list.AppendItem("Date");
val_list.AppendItem("1/1/99");

ret_int = fccq.create_cr_list("MS Word", "1.2", "Product", _
                              "CR Title", "", "note.txt", "", _
                              "", "", "", _
                              "", "", "", "", "", "", _
                              "Some tests to run", _
                              "High", "", "", True, _
                              fld_list, type_list, val_list)

 If ret_int = 0 Then
   bug_id_num = fccq.ret_id_num
   bug_objid = fccq.ret_objid
 End If

JavaScript:

var fld_list  = Server.CreateObject("FCFLCompat.FCList");
var type_list = Server.CreateObject("FCFLCompat.FCList");
var val_list  = Server.CreateObject("FCFLCompat.FCList");

fld_list.AppendItem("dist");
type_list.AppendItem("Long");
val_list.AppendItem("456");

fld_list.AppendItem("attribute2");
type_list.AppendItem("String");
val_list.AppendItem("More text");

fld_list.AppendItem("date_found");
type_list.AppendItem("Date");
val_list.AppendItem("1/1/99");

var ret_int = fccq.create_cr_list("MS Word", "1.2", "Product",
   "CR Title", "", "note.txt", "", "", "", "",
   "", "", "", "", "", "", "Some tests to run",
   "High", "", "", true, fld_list, type_list, val_list)

 if (ret_int == 0) {
   var bug_id_num = fccq.ret_id_num;
   var bug_objid = fccq.ret_objid;
 }


dispatch_cr | fcSDK Documentation

dispatch_cr

Public Function dispatch_cr(ByVal cr_id As String, _
                            ByVal queue_name As String, _
                            ByVal disp_date As String, _
                            ByVal user_name As String, _
                            ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified change request to be dispatched to the specified queue. The change request must not be currently dispatched to a queue. The API allows for the setting of the dispatch date, and the user who dispatched the change request. The APIs can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
cr_id | Yes | The change request Id to be dispatched
queue_name | Yes | The queue to dispatch to
disp_date | No | When was the change request dispatched. If this parameter is left blank, the CR is dispatched at the current time
user_name | No | The user who dispatched the change request. If left blank, the current user performs the dispatch
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified change request
-2 | The change request is already dispatched
-3 | The change request is closed and may not be dispatched
-4 | The specified user cannot be found
-5 | The specified new queue name cannot be found
-6 | Cannot find gbst_elm rank 900 for string DISPATCH
-7 | Not allowed to dispatch a CR to the specified queue

Examples

Dispatch change request number '10' to queue 'Hardware'. The dispatch is performed by the current user and is dispatched at the current time. Generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fccq.dispatch_cr("10", "Hardware", "", "", True)

JavaScript:

var ret_int = fccq.dispatch_cr("10", "Hardware", "", "", true);

Dispatch change request number '2' at 10PM on November 23rd of 1997 to queue 'Software'. Dispatch should be logged as performed by nancy. Don't generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fccq.dispatch_cr("2", "Software", "11/23/97 22:00:00", _
                           "nancy", False)

JavaScript:

var ret_int = fccq.dispatch_cr("2", "Software", "11/23/97 22:00:00", _
                           "nancy", false);


duplicate_cr | fcSDK Documentation

duplicate_cr

Public Function duplicate_cr(ByVal cr_id As String, _
                             ByVal the_status As String, _
                             ByVal master_cr As String, _
                             ByVal user_name As String, _
                             ByVal close_date As String, _
                             ByVal gen_time_bombs As Boolean) As Integer

Description

This API closes the specified CR as a duplicate of the "master CR". The CR is placed in "CR Duplicate/Closed" condition, and in the specified status. You may specify the user performing the duplication, as well as when it occurred. A time bomb may be generated for business rule notification.

Parameters

Parameter Name | Required? | Description
cr_id | Yes | The change request to mark as a duplicate
the_status | No | The new status for the duplicate CR. If blank, the default status for the condition is used
master_cr | Yes | The ID of the master (parent) CR
user_name | No | The user who duplicated the change request. If left blank, the current user performs the marking
close_date | No | When was the duplication. If blank, the current date/time is used
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified change request
-2 | The CR is already closed
-3 | The CR is currently dispatched
-4 | Cannot find the specified user
-5 | Cannot find gbst_elm rank 7300 for string CHG STS:DUPL
-6 | Cannot find the new status
-7 | Cannot find the master CR
-8 | The master CR is already marked as a duplicate
-9 | Status transition not defined in Policies and Customers
-10 | Status transition not allowed for specified user
-18 | Privclass not found for specified user
-19 | Old status not found for old condition
-20 | New status not found for new condition
-21 | Cannot find the specified user's employee record for relating time bomb

Examples

Mark CR '2' as a duplicate of CR '4' with a new status of 'Double Entry". Gary performed the close at 8AM on March 29, 1999. Generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fccq.duplicate_cr("2", "Double Entry", "4", "gary", _
       "3/29/99 08:00:00", True)

JavaScript:

var ret_int = fccq.duplicate_cr("2", "Double Entry", "4", "gary", "3/29/99 08:00:00", true);


fix_cr | fcSDK Documentation

fix_cr

fix_cr_list

Public Function fix_cr(ByVal cr_id As String, _
                       ByVal the_status As String, _
                       ByVal notes As String, _
                       ByVal user_name As String, _
                       ByVal fix_date As String, _
                       ByVal gen_time_bombs As Boolean, _
                       ByVal int_fld1 As String, _
                       ByVal int_val1 As Long, _
                       ByVal int_fld2 As String, _
                       ByVal int_val2 As Long, _
                       ByVal str_fld1 As String, _
                       ByVal str_val1 As String, _
                       ByVal str_fld2 As String, _
                       ByVal str_val2 As String, _
                       ByVal date_fld1 As String, _
                       ByVal date_val1 As String) As Integer

Public Function fix_cr_list(ByVal cr_id As String, _
                            ByVal the_status As String, _
                            ByVal notes As String, _
                            ByVal user_name As String, _
                            ByVal fix_date As String, _
                            ByVal gen_time_bombs As Boolean, _
                            Optional fld_list As Variant, _
                            Optional type_list As Variant, _
                            Optional val_list As Variant) As Integer

Description

These APIs change the condition of a CR to "Fixed", even if it was already closed. The status specified must be defined in the fixed condition per Clarify's Policies and Customers. You may specify notes about the fix, and the user and date/time of the fix. A time bomb may be generated (for business rule notification), and additional fields (on the fix_bug record) may be specified.

Parameters

Parameter Name | Required? | Description
cr_id | Yes | The change request to fix
the_status | No | The new status for the CR. If blank, the default status for the condition is used
notes | No | Notes for the fix
user_name | No | The user who fixed the change request. If left blank, the current user performs the fix
fix_date | No | The date of the fix. If blank, the current date/time is used
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors; sets objid of new fix_bug object in ret_objid (Long) global variable
-1 | Cannot find the specified change request
-2 | The CR is currently dispatched
-3 | Cannot find the specified user
-4 | Cannot find gbst_elm rank 5100 for string CHG STS:FIXED
-5 | Cannot find the new status
-6 | Status transition not defined in Policies and Customers
-7 | Status transition not allowed for specified user
-15 | Privclass not found for specified user
-16 | Old status not found for old condition
-17 | New status not found for new condition
-18 | Cannot find the specified user's employee record for relating time bomb
ret_objid | Output - Returns the objid of the fixed cr

Examples

Fix CR '2' using the default status and some notes. Gary performed the fix at 8AM on March 29, 1999. Generate a time bomb. The second field version illustrates how to set additional fields.

Field version 1:

Visual Basic:

Dim ret_int As Integer
Dim fix_objid   As Long

ret_int = fccq.fix_cr("2", "", "Notes about fix", "gary", _
       "3/29/99 08:00:00", True, "", 0, "", 0, _
       "", "", "", "", "", "")

If ret_int = 0 Then
   fix_objid = fccq.ret_objid
End If

JavaScript

var int = fccq.fix_cr("2", "", "Notes about fix", "gary",
      "3/29/99 08:00:00", tue, "", 0, "", 0,
      "", "", "", "", "", "");

if (ret_int == 0) { var fix_objid = fccq.ret_objid; }

Field version 2:

Visual Basic:

Dim ret_int As Integer
Dim fix_objid   As Long

ret_int = fccq.fix_cr("2", "", "Notes about fix", "gary", _
       "3/29/99 08:00:00", True, "x_fix_1", 1, "x_fix_2", 2, _
       "x_summary2", "More text", "", "", "x_other_Date", "1/1/99")

If ret_int = 0 Then
   fix_objid = fccq.ret_objid
End If

JavaScript

var ret_int = fccq.fix_cr("2", "", "Notes about fix", "gary",
      "3/29/99 08:00:00", true, "x_fix_1", 1,
      "x_fix_2", 2, "x_summary2", "More text", "", "",
      "x_other_Date", "1/1/99");

if (ret_int == 0) { var fix_objid = fccq.ret_objid; }

List version:

Visual Basic:

Dim fix_objid   As Long
Dim ret_int As Integer
Dim fld_list    As New FCFLCompat.FCList
Dim type_list   As New FCFLCompat.FCList
Dim val_list    As New FCFLCompat.FCList

fld_list.AppendItem "x_fix_int1"
type_list.AppendItem "Long"
val_list.AppendItem Trim(Str$(1))

fld_list.AppendItem "x_fix_int2"
type_list.AppendItem "Long"
val_list.AppendItem Trim(Str$(456))

fld_list.AppendItem "x_summary2"
type_list.AppendItem "String"
val_list.AppendItem "More text"

fld_list.AppendItem "x_other_date"
type_list.AppendItem "Date"
val_list.AppendItem "1/1/99"

ret_int = fccq.fix_cr_list("2", "", "Notes about fix", "gary", _
          "3/29/99 08:00:00", True, fld_list, type_list, val_list)

If ret_int = 0 Then
   fix_objid = fccq.ret_objid
End If

JavaScript:

var fld_list  = Server.CreateObject("FCFLCompat.FCList");
var type_list = Server.CreateObject("FCFLCompat.FCList");
var val_list  = Server.CreateObject("FCFLCompat.FCList");

fld_list.AppendItem("x_fix_int1");
type_list.AppendItem("Long");
val_list.AppendItem("1");

fld_list.AppendItem("x_fix_int2");
type_list.AppendItem("Long");
val_list.AppendItem("456");

fld_list.AppendItem("x_summary2");
type_list.AppendItem("String");
val_list.AppendItem("More text");

fld_list.AppendItem("x_other_date");
type_list.AppendItem("Date");
val_list.AppendItem("1/1/99");

var ret_int = fccq.fix_cr_list("2", "", "Notes about fix", "gary",
      "3/29/99 08:00:00", true, fld_list, type_list, val_list)

if (ret_int == 0) { var fix_objid = fccq.ret_objid; }


fix_failed | fcSDK Documentation

fix_failed

cfix_failed_list

Public Function fix_failed(ByVal cr_id As String, _
                        ByVal the_status As String, _
                        ByVal notes As String, _
                        ByVal test_case As String, _
                        ByVal int_release As String, _
                        ByVal user_name As String, _
                        ByVal failed_date As String, _
                        ByVal gen_time_bombs As Boolean, _
                        ByVal int_fld1 As String, ByVal int_val1 As Long, _
                        ByVal int_fld2 As String, ByVal int_val2 As Long, _
                        ByVal str_fld1 As String, ByVal str_val1 As String, _
                        ByVal str_fld2 As String, ByVal str_val2 As String, _
                        ByVal date_fld1 As String, ByVal date_val1 As String) _
                        As Integer

Public Function fix_failed _list(ByVal cr_id As String, _
                              ByVal the_status As String, _
                              ByVal notes As String, _
                              ByVal test_case As String, _
                              ByVal int_release As String, _
                              ByVal user_name As String, _
                              ByVal failed_date As String, _
                              ByVal gen_time_bombs As Boolean, _
                              Optional fld_list As Variant, _
                              Optional type_list As Variant, _
                              Optional val_list As Variant) As Integer

Description

These APIs are used to change the condition of a change request from Fixed to Open. The change request must be in a condition/status that allows the transition to the open condition. The APIs allow for the assigning of an open status, as well as notes, the test cases used to verify the fix failed, and the release. The APIs allow you to specify a user who performed the operation, as well as the date/time of the operation. The APIs allow for additional fields to be written to the close_bug object. The APIs can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
cr_id | Yes | The change request Id
the_status | No | The open condition status for the CR. If left blank, the default status for open condition is used
notes | No | Notes about the failure
test_case | No | Test case string for failure
int_release | No | Release information for the failure
user_name | No | The user who performs the operation. If left blank, the current user performs the operation
close_date | No | The date/time of the operation. If left blank, the current time is used
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules).
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
1 | No errors; sets objid of new close_bug object in the ret_objid (Long) global variable
-1 | Cannot find the specified change request
-2 | The specified change request is not in a Fixed condition
-3 | The CR is currently dispatched
-4 | The specified user is not found
-5 | Cannot find gbst_elm rank 5700 for string CHG STS:FAILED
-6 | The specified status is not a valid status for condition 'CR Open'
-7 | Status transition not defined in Policies and Customers
-8 | Status transition not allowed for specified user
-16 | Privclass not found for specified user
-17 | Old status not found for old condition
-18 | New status not found for new condition
-19 | Cannot find the specified user's employee record for relating time bomb
ret_objid | Output - Returns the objid of the new close_bug record

Examples

Fix Failed for change request number '10'. Change to new status "Fix Failed", add some notes and other information. The operation was performed by patty at the current time. Generate a time bomb (for business rule notification). The second field version illustrates how to set the additional fields.

Field version 1:

Visual Basic:

Dim ret_int As Integer
Dim close_objid As Long

ret_int = fccq.fix_failed("10", "Fix Failed", "Some notes", _
         "Test case 43", "Release 1.2", "patty", "", _
         True, ", 0, "", 0, "", "", "", "", "", "")

If ret_int = 0 Then
  close_objid = fccq.ret_objid
End If

JavaScript:

var ret_int = fccq.fix_failed("10", "Fix Failed", "Some notes",
   "Test case 43", "Release 1.2", "patty", "",
   true, ", 0, "", 0, "", "", "", "", "", "");

if (ret_int == 0){ var close_objid = fccq.ret_objid; }

Field version 2:

Visual Basic:

Dim ret_int As Integer
Dim close_objid As Long

ret_int = fccq.fix_failed("10", "Fix Failed", "Some notes", _
     "Test case 43", "Release 1.2", "patty", "", True, _
     "x_close_int1", 1, "x_close_int2", 456, _
     "x_summary2", "More text", "", "", _
     "x_other_date", "1/1/99")

 If ret_int = 0 Then
   close_objid = fccq.ret_objid
 End If

JavaScript:

var ret_int = fccq.fix_failed("10", "Fix Failed", "Some notes",
   "Test case 43", "Release 1.2", "patty", "", true,
   "x_close_int1", 1, "x_close_int2", 456,
   "x_summary2", "More text", "", "",
   "x_other_date", "1/1/99");

 if (ret_int == 0){ var close_objid = fccq.ret_objid;

List version:

Visual Basic:

Dim close_objid As Long
Dim ret_int As Integer
Dim fld_list    As New FCFLCompat.FCList
Dim type_list   As New FCFLCompat.FCList
Dim val_list    As New FCFLCompat.FCList

fld_list.AppendItem "x_close_int1"
type_list.AppendItem "Long"
val_list.AppendItem Trim(Str$(1))

fld_list.AppendItem "x_close_int2"
type_list.AppendItem "Long"
val_list.AppendItem Trim(Str$(456))

fld_list.AppendItem "x_summary2"
type_list.AppendItem "String"
val_list.AppendItem "More text"

fld_list.AppendItem "x_other_date"
type_list.AppendItem "Date"
val_list.AppendItem "1/1/99"

ret_int = fccq.fix_failed_list("10", "Fix Failed", "Some notes", _
                 "Test Case 43", "Release 1.2", "patty", "", _
                 True, fld_list, type_list, val_list)

close_objid = fccq.ret_objid

JavaScript:

var fld_list  = Server.CreateObject("FCFLCompat.FCList");
var type_list = Server.CreateObject("FCFLCompat.FCList");
var val_list  = Server.CreateObject("FCFLCompat.FCList");

fld_list.AppendItem("x_close_int1");
type_list.AppendItem("Long");
val_list.AppendItem("1");

fld_list.AppendItem("x_close_int2");
type_list.AppendItem("Long");
val_list.AppendItem("456");

fld_list.AppendItem("x_summary2");
type_list.AppendItem("String");
val_list.AppendItem("More text");

fld_list.AppendItem("x_other_date");
type_list.AppendItem("Date");
val_list.AppendItem("1/1/99");

var ret_int = fccq.fix_failed_list("10", "Fix Failed", "Some notes",
   "Test Case 43", "Release 1.2", "patty", "", true, fld_list, type_list, val_list);

var close_objid = fccq.ret_objid;


forward_cr | fcSDK Documentation

forward_cr

Public Function forward_cr(ByVal cr_id As String, _
                                       ByVal new_queue As String, _
                           ByVal forward_date As String, _
                                       ByVal notes As String, _
                           ByVal user_name As String, _
                           ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified change request to be reject-forwarded from one queue to another. The change request must be currently dispatched to a queue. The API allows for the setting of the forward date, some notes about the forward, and the user who forwarded the change request. The API can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
cr_id | Yes | The change request Id to be reject-forward
new_queue | Yes | The queue to forward to
forward_date | No | When was the change request forwarded. If this parameter is left blank, the CR is forwarded at the current time
notes | No | Optional notes about the reject-forward
user_name | No | The user who forwarded the change request. If left blank, the current user performs the forward
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified change request
-2 | Change request is not currently dispatched
-3 | The new queue name specified is not found
-4 | Reject-forward attempted to same queue as currently dispatched to
-5 | The specified user is not found
-6 | Cannot find gbst_elm rank 1100 for string FORWARD
-7 | Not allowed to forward a CR to the specified queue

Examples

Reject-forward change request number '10' to queue 'Hardware'. The reject-forward has no notes, is performed by the current user and is forwarded at the current time. Generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fccq.forward_cr("10", "Hardware", "", "", "", True)

JavaScript:

var ret_int = fccq.forward_cr("10", "Hardware", "", "", "", true);

Reject-forward change request number '2' at 10PM on November 23rd of 1997 to queue 'Software'. Forward should be logged as performed by ann, with notes of 'Some notes'. Don't generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fccq.forward_cr("2", "Software", "11/23/97 22:00:00", _
                          "Some notes", "ann", False)

JavaScript:

var ret_int = fccq.forward_cr("2", "Software", "11/23/97 22:00:00",
      "Some notes", "ann", false);


Initialize | fcSDK Documentation

Initialize

Public Sub Initialize(ByRef TheFCApplication As FCApplication, _
                      ByRef TheFCSession As FCSession)

Description

The Initialize method is used to establish the relationship between the FCCQ object and the FCApplication and FCSession objects. This method must be called before calling any of the other API methods.

Parameters

Parameter Name | Required? | Description
TheFCApplication | Yes | The FCApplication Object
TheFCSession | Yes | The FCSession Object

Example

Create the necessary objects, and initialize the FCCQ object

Visual Basic:

Dim FCApp     As New FCApplication
Dim FCSession As FCSession
Dim FCCQ      As New CQ

FCApp.WorkingDirectory = "c:\\temp"
FCApp.Initialize

Set FCSession = FCApp.CreateSession
FCSession.Login "sa", "sa", "user"
FCSession.ThrowErrors = False
FCCQ.Initialize FCApp, FCSession

'Now any of the API methods on FCCQ can be called
'When finished, destroy the FCCQ object

Set FCCQ = Nothing

JavaScript:

var FCApp = Server.CreateObject("FCFLCompat.FCApplication");
var FCCQ = Server.CreateObject("FCCompatToolkit.CQ");
FCApp.WorkingDirectory = "C:\\\temp";
FCApp.Initialize();

var FCSession = FCApp.CreateSession();
FCSession.Login("sa", "sa", "user");
FCSession.ThrowErrors = false;
FCCQ.Initialize(FCApp, FCSession);

//Now any of the API methods on FCCQ can be called
//When finished, destroy the FCCQ object
FCCQ = null;


log_cr_email | fcSDK Documentation

log_cr_email

log_cr_email_list

Public Function log_cr_email(ByVal cr_id As String, _
                          ByVal log_date As String, ByVal message As String, _
                          ByVal recipient As String, ByVal cc_list As String, _
                          ByVal user_name As String, _
                                      ByVal gen_time_bombs As Boolean, _
                          ByVal send_email As Boolean, _
                          ByVal int_fld1 As String, ByVal int_val1 As Long, _
                          ByVal int_fld2 As String, ByVal int_val2 As Long, _
                          ByVal str_fld1 As String, ByVal str_val1 As String, _
                          ByVal str_fld2 As String, ByVal str_val2 As String, _
                          ByVal date_fld1 As String, _
                                      ByVal date_val1 As String) As Integer

Public Function log_cr_email_list(ByVal cr_id As String, _
                                  ByVal log_date As String, _
                                                  ByVal message As String, _
                                  ByVal recipient As String, _
                                                  ByVal cc_list As String, _
                                  ByVal user_name As String, _
                                                  ByVal gen_time_bombs As Boolean, _
                                  ByVal send_email As Boolean, _
                                  Optional fld_list As Variant, _
                                  Optional type_list As Variant, _
                                  Optional val_list As Variant) As Integer

Description

These APIs are used to create an email log (email out) against a CR. The date the email is logged can be set, as well as the user who logs the email. Additional fields on the log_email record can also be set as well as a time bomb (for the email_log), which allows notifications to be generated based on the event. In addition, the proper time_bomb can be optionally created that will cause rulemanager to send out the email.

Parameters

Parameter Name | Required? | Description
cr_id | Yes | The CR to create the log for
log_date | No | The date the log was created. If left blank, the current time is used
message | No | The text (body) of the email message
recipient | No | The email address of the intended recipient
cc_list | No | A list of additional recipients to be included on the CC list
user_name | No | The user who created the log. If left blank, the current user performs the logging
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)
send_email | Yes | Should rulemanager send this email
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors; sets objid of new email_log object in ret_objid (Long) global variable
-1 | Cannot find the specified CR
-2 | Cannot find the specified user
-3 | Cannot find gbst_elm rank 3400 for string EMAIL OUT
-4 | Cannot find the specified user's employee record for relating time bomb
-5 | Cannot find the com_tmplte with a title of "send_email_about_bug"
ret_objid | Output - Returns the objid of the email_log

Examples

Create an email_log for CR number '2'. Set the message for the log. Set the recipient to be joe@company.com, and also CC the email to mary@company.com and sally@company.com Have the email logged by marty on November 23, 1997 at 10PM. Generate a time bomb (for business rule notification), and also generate a time_bomb so that rulemanager will send out the email. The second field version illustrates how to set additional fields.

Field version 1:

Visual Basic:

Dim ret_int As Integer
Dim log_objid As Long

ret_int = fccq.log_cr_email("2", "11/23/97 22:00:00",_
    "This is an outgoing email", _
    "joe@company.com", _
    "mary@company.com,sally@company.com", _
    "marty", True, True, _
    "", 0, "", 0, "", "", "", "", "", "")

 If ret_int = 0 Then
   log_objid = fccq.ret_objid
 End If

JavaScript:

var ret_int = fccq.log_cr_email("2", "11/23/97 22:00:00",_
    "This is an outgoing email", _
    "joe@company.com", _
    "mary@company.com,sally@company.com", _
    "marty", True, True, _
    "", 0, "", 0, "", "", "", "", "", "");

 if (ret_int == 0) { var log_objid = fccq.ret_objid; }

Field version 2:

Visual Basic:

Dim ret_int As Integer
Dim log_objid As Long

ret_int = fccq.log_cr_email("2", "11/23/97 22:00:00",_
    "This is an outgoing email", _
    "joe@company.com", _
    "mary@company.com,sally@company.com", _
    "marty", True, True, _
    "x_int1", 1, "x_int2", 456, _
    "x_summary2", "More text", "", "", _
    "x_other_date", "1/1/99")

 If ret_int = 0 Then
   log_objid = fccq.ret_objid
 End If

JavaScript:

var ret_int = fccq.log_cr_email("2", "11/23/97 22:00:00",_
    "This is an outgoing email", _
    "joe@company.com", _
    "mary@company.com,sally@company.com", _
    "marty", True, True, _
    "x_int1", 1, "x_int2", 456,
    "x_summary2", "More text", "", "",
    "x_other_date", "1/1/99");

 if (ret_int == 0) { var log_objid = fccq.ret_objid; }

List version:

Visual Basic:

Dim log_objid As Long
Dim ret_int As Integer
Dim fld_list  As New FCFLCompat.FCList
Dim type_list As New FCFLCompat.FCList
Dim val_list  As New FCFLCompat.FCList

fld_list.AppendItem "x_log_int1"
type_list.AppendItem "Long"
val_list.AppendItem Trim(Str$(1))

fld_list.AppendItem "x_log_int2"
type_list.AppendItem "Long"
val_list.AppendItem Trim(Str$(456))

fld_list.AppendItem "x_summary2"
type_list.AppendItem "String"
val_list.AppendItem "More text"

fld_list.AppendItem "x_other_date"
type_list.AppendItem "Date"
val_list.AppendItem "1/1/99"

ret_int = fccq.log_cr_email_list("2", "11/23/97 22:00:00",_
    "This is an outgoing email", _
    "joe@company.com", _
    "mary@company.com,sally@company.com", _
    "marty", True, True, _
    fld_list, type_list, val_list)

 If ret_int = 0 Then
   log_objid = fccq.ret_objid
 End If

JavaScript:

var fld_list  = Server.CreateObject("FCFLCompat.FCList");
var type_list = Server.CreateObject("FCFLCompat.FCList");
var val_list  = Server.CreateObject("FCFLCompat.FCList");

fld_list.AppendItem("x_log_int1");
type_list.AppendItem("Long");
val_list.AppendItem("1");

fld_list.AppendItem("x_log_int2");
type_list.AppendItem("Long");
val_list.AppendItem("456");

fld_list.AppendItem("x_summary2");
type_list.AppendItem("String");
val_list.AppendItem("More text");

fld_list.AppendItem("x_other_date");
type_list.AppendItem("Date");
val_list.AppendItem("1/1/99");

var ret_int = fccq.log_cr_email_list("2", "11/23/97 22:00:00",_
    "This is an outgoing email", _
    "joe@company.com", _
    "mary@company.com,sally@company.com", _
    "marty", True, True, _
    fld_list, type_list, val_list);

 if (ret_int == 0) { var log_objid = fccq.ret_objid; }


log_cr_note | fcSDK Documentation

log_cr_note

log_cr_note_list

Public Function log_cr_note(ByVal cr_id As String, _
                            ByVal notes As String, _
                            ByVal int_use As String, _
                            ByVal log_date As String, _
                            ByVal user_name As String, _
                            ByVal gen_time_bombs As Boolean, _
                            ByVal int_fld1 As String, _
                            ByVal int_val1 As Long, _
                            ByVal int_fld2 As String, _
                            ByVal int_val2 As Long, _
                            ByVal str_fld1 As String, _
                            ByVal str_val1 As String, _
                            ByVal str_fld2 As String, _
                            ByVal str_val2 As String, _
                            ByVal date_fld1 As String, _
                            ByVal date_val1 As String) As Integer

Public Function log_cr_note_list(ByVal cr_id As String, _
                                 ByVal notes As String, _
                                 ByVal int_use As String, _
                                 ByVal log_date As String, _
                                 ByVal user_name As String, _
                                 ByVal gen_time_bombs As Boolean, _
                                 Optional fld_list As Variant, _
                                 Optional val_list As Variant, _
                                 Optional type_list As Variant) As Integer

Description

These APIs are used to create a note log against a CR. The APIs allow for the assigning of notes and internal use only text. The date the note is logged can be set, as well as the user who logs the note. Additional fields on the log_cr_note can also be set as well as a time bomb (for the note log), which allows notifications to be generated based on the event.

Parameters

Parameter Name | Required? | Description
cr_id | Yes | The CR to create the log for
notes | No | The note log text
int_use | No | Internal use only information
log_date | No | The date the log was created. If left blank, the current time is used
user_name | No | The user who created the log. If left blank, the current user performs the logging
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors; sets objid of new notes_log object in ret_objid (Long) global variable
-1 | Cannot find the specified CR
-2 | Cannot find the specified user
-3 | Cannot find gbst_elm rank 1700 for string NOTES
-4 | Cannot find the specified user's employee record for relating time bomb
ret_objid | Output - Returns the objid of the note

Examples

Create a note log for CR number '2'. Set the notes for the log, and indicate that it's internal use only. Have the note logged by marty on November 23, 1997 at 10PM. Don't generate a time bomb (for business rule notification). The second field version illustrates how to set additional fields.

Field version 1:

Visual Basic:

Dim ret_int As Integer
Dim log_objid As Long

ret_int = fccq.log_cr_note("2", "Some notes", "Internal text", _
      "11/23/97 22:00:00", "marty", False, _
      "", 0, "", 0, "", "", "", "", "", "")

 If ret_int = 0 Then
   log_objid = fccq.ret_objid
 End If

JavaScript:

var ret_int = fccq.log_cr_note("2", "Some notes", "Internal text",
   "11/23/97 22:00:00", "marty", false,
   "", 0, "", 0, "", "", "", "", "", "");

 if (ret_int == 0) { var log_objid = fccq.ret_objid; }

Field version 2:

Visual Basic:

Dim ret_int As Integer
Dim log_objid As Long

ret_int = fccq.log_cr_note("2", "Some notes", "Internal text", _
      "11/23/97 22:00:00", "marty", False, _
      "x_close_int1", 1, "x_close_int2", 456, _
      "x_summary2", "More text", "", "", _
      "x_other_date", "1/1/99")

 If ret_int = 0 Then
   log_objid = fccq.ret_objid
 End If

JavaScript:

var ret_int = fccq.log_cr_note("2", "Some notes", "Internal text",
   "11/23/97 22:00:00", "marty", false,
   "x_close_int1", 1, "x_close_int2", 456,
   "x_summary2", "More text", "", "",
   "x_other_date", "1/1/99");

 if (ret_int == 0) { var log_objid = fccq.ret_objid; }

List version:

Visual Basic:

Dim log_objid As Long
Dim ret_int As Integer
Dim fld_list  As New FCFLCompat.FCList
Dim type_list As New FCFLCompat.FCList
Dim val_list  As New FCFLCompat.FCList

fld_list.AppendItem "x_log_int1"
type_list.AppendItem "Long"
val_list.AppendItem Trim(Str$(1))

fld_list.AppendItem "x_log_int2"
type_list.AppendItem "Long"
val_list.AppendItem Trim(Str$(456))

fld_list.AppendItem "x_summary2"
type_list.AppendItem "String"
val_list.AppendItem "More text"

fld_list.AppendItem "x_other_date"
type_list.AppendItem "Date"
val_list.AppendItem "1/1/99"

ret_int = fccq.log_cr_note_list("2", "Some notes", _
           "Internal text", _
           "11/23/97 22:00:00", "marty", False, _
           fld_list, type_list, val_list)

 If ret_int = 0 Then
   log_objid = fccq.ret_objid
 End If

JavaScript:

var fld_list  = Server.CreateObject("FCFLCompat.FCList");
var type_list = Server.CreateObject("FCFLCompat.FCList");
var val_list  = Server.CreateObject("FCFLCompat.FCList");

fld_list.AppendItem("x_log_int1");
type_list.AppendItem("Long");
val_list.AppendItem("1");

fld_list.AppendItem("x_log_int2");
type_list.AppendItem("Long");
val_list.AppendItem("456");

fld_list.AppendItem("x_summary2");
type_list.AppendItem("String");
val_list.AppendItem("More text");

fld_list.AppendItem("x_other_date");
type_list.AppendItem("Date");
val_list.AppendItem("1/1/99");

var ret_int = fccq.log_cr_note_list("2", "Some notes",
   "Internal text",
   "11/23/97 22:00:00", "marty", False,
   fld_list, type_list, val_list);

 if (ret_int == 0) { var log_objid = fccq.ret_objid; }


modify_cr | fcSDK Documentation

modify_cr

modify_cr_list

Public Function modify_cr(ByVal cr_num As String, _
                ByVal part_num As String, _
                        ByVal mod_level As String, _
                        ByVal domain As String, _
                        ByVal the_title As String, _
                        ByVal cr_type As String, _
                        ByVal priority As Strings, _
                        ByVal frequency As String, _
                        ByVal found_on As String, _
                        ByVal op_sys As String, _
                        ByVal memory As String, _
                        ByVal cr_class As String, _
                        ByVal intro_phase As String, _
                        ByVal test_class As String, _
                        ByVal fixed_in As String, _
                        ByVal user_name As String, _
                        ByVal cr_date As String, _
                ByVal gen_time_bombs As Boolean, _
                        ByVal int_fld1 As String, _
                        ByVal int_val1 As Long, _
                        ByVal int_fld2 As String, _
                        ByVal int_val2 As Long, _
                ByVal str_fld1 As String, _
                ByVal str_val1 As String, _
                ByVal str_fld2 As String, _
                ByVal str_val2 As String, _
                ByVal date_fld1 As String, _
                ByVal date_val1 As String) As Integer

Public Function modify_cr_list(ByVal cr_num As String, _
                   ByVal part_num As String, _
                   ByVal mod_level As String, _
                   ByVal domain As String, _
                               ByVal the_title As String, _
                               ByVal cr_type As String, _
                               ByVal priority As String, _
                               ByVal frequency As String, _
                               ByVal found_on As String, _
                               ByVal op_sys As String, _
                   ByVal memory As String, _
                   ByVal cr_class As String, _
                   ByVal intro_phase As String, _
                   ByVal test_class As String, _
                   ByVal fixed_in As String, _
                   ByVal user_name As String, _
                   ByVal cr_date As String, _
                   ByVal gen_time_bombs As Boolean, _
                   Optional fld_list As Variant, _
                                Optional type_list As Variant, _
                   Optional val_list As Variant) As Integer

Description

These APIs are used to modify existing CRs. All of the primary fields of the CR can be set. If they are left blank, then the value in the CR is not changed. The modifier and the time of modification may be specified, and you may specify additional fields for the modify_cr object. You may also have a modify time bomb generated (for business rule notifications).

Parameters

Parameter Name | Required? | Description
cr_num | Yes | The CR to modify
part_num | No | Part number of part for change request
mod_level | No | Revision of part for change request
domain | No | Domain of the part for the change request
the_title | No | Title of the change request
cr_type | No | A code list value from list CR TYPE
priority | No | A code list value from list CR PRIORITY
frequency | No | A code list value from list CR REPRODUCIBLE
found_on | No | Level 1 of the list CR_DESC
os | No | Level 2 of the list CR_DESC. If no sublist is described for this item, you may specify "" for no list entry
memory | No | Level 3 of the list CR_DESC. If no sublist is described for this item, you may specify "" for no list entry
cr_class | No | A code list value from list CR_CLASS
intro_phase | No | A code list value from list CR DOMAIN
test_class | No | A code list value from list CR CLASS
fixed_in | No | A code list value from list FIX RELEASE
user_name | No | The user who modified the change request. If left blank, the current user is used
cr_date | No | The date the CR was modified. If blank, the current date/time is used
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified CR
-2 | Cannot find the specified user
-3 | Cannot find the part and revision
-4 | Cannot find gbst_elm rank 1500 for string MODIFY
-5 | Cannot find the specified CR Type
-6 | Cannot find the specified CR Priority
-7 | Cannot find the specified frequency
-8 | Cannot find the specified intro phase
-9 | Cannot find the specified test class
-10 | Cannot find the specified CR class
-11 | Cannot find the specified fixed in release
-12 | Cannot find the specified found_on value (cpu)
-13 | Cannot find the specified op_sys value (operating system)
-14 | Cannot find the specified memory value
-15 | Cannot find the specified user's employee record for relating time bomb

Examples

Modify CR '19'. Change the priority and generate a time bomb (for business rule notification). All other information is defaulted. The second field version illustrates how to set additional fields.

Field version 1:

Visual Basic:

Dim ret_int As Integer

ret_int = fccq.modify_cr("19", "", "", "", "", "", "Low", _
                         "", "", "", "", "", "", _
                         "", "", "", "", _
                         True, "", 0, "", 0, "", "", _
                         "", "", "", "")

JavaScript:

var ret_int = fccq.modify_cr("19", "", "", "", "", "", "Low",
   "", "", "", "", "", "",
   "", "", "", "",
   true, "", 0, "", 0, "", "",
   "", "", "", "");

Field version 2:

Visual Basic:

Dim ret_int As Integer

ret_int = fccq.modify_cr("19", "", "", "", "", "", "Low", _
                       "", "", "", "", "", "", _
                       "", "", "", "", _
                       True, "x_create_1", 1, "x_create_2", 2,
                       "x_summary2", "More text", "", "", _
                       "x_other_date", "1/1/99")

JavaScript:

var ret_int = fccq.modify_cr("19", "", "", "", "", "", "Low",
   "", "", "", "", "", "",
   "", "", "", "",
   true, "x_create_1", 1, "x_create_2", 2,
   "x_summary2", "More text", "", "",
   "x_other_date", "1/1/99");

List version:

Visual Basic:

Dim ret_int As Integer
Dim fld_list    As New FCFLCompat.FCList
Dim type_list   As New FCFLCompat.FCList
Dim val_list    As New FCFLCompat.FCList

fld_list.AppendItem "x_fix_int1"
type_list.AppendItem "Long"
val_list.AppendItem Trim(Str$(1))

fld_list.AppendItem "x_fix_int2"
type_list.AppendItem "Long"
val_list.AppendItem Trim(Str$(456))

fld_list.AppendItem "x_summary2"
type_list.AppendItem "String"
val_list.AppendItem "More text"

fld_list.AppendItem "x_other_date"
type_list.AppendItem "Date"
val_list.AppendItem "1/1/99"

ret_int = fccq.modify_cr_list("19", "", "", "", "", "", "Low", _
                              "", "", "", "", "", "", _
                              "", "", "", "", _
                              True, fld_list, type_list, val_list)

JavaScript:

var fld_list  = Server.CreateObject("FCFLCompat.FCList");
var type_list = Server.CreateObject("FCFLCompat.FCList");
var val_list  = Server.CreateObject("FCFLCompat.FCList");

fld_list.AppendItem("dist");
type_list.AppendItem("Long");
val_list.AppendItem("456");

fld_list.AppendItem("attribute2");
type_list.AppendItem("String");
val_list.AppendItem("More text");

fld_list.AppendItem("date_found");
type_list.AppendItem("Date");
val_list.AppendItem("1/1/99");

var ret_int = fccq.modify_cr_list("19", "", "", "", "", "", "Low",
   "", "", "", "", "", "", "", "", "", "", true, fld_list, type_list, val_list);


move_cr | fcSDK Documentation

move_cr

Public Function move_cr(ByVal cr_id As String, _
                                    ByVal new_wipbin As String) As Integer

Description

This API causes the specified change request to be moved from one WIPBin to another WIPBin. The new WIPBin must belong to the same user as the initial WIPBin. The move operation does not change the ownership of the change request, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WIPBin to another, even if the object is currently dispatched. Since WIPBins are internal to a user, there really is no reason that you shouldn't be able to move the location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Parameters

Parameter Name | Required? | Description
cr_id | Yes | The change request to move
new_wipbin | Yes | The WIPBin to move the change request to

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified change request
-2 | Change request is already closed
-3 | New WIPBin doesn't exist, or doesn't exist for the owner
-4 | New WIPBin is same as old - no move needed

Examples

Move change request number '2' to WIPBin 'Urgent'.

Visual Basic:

Dim ret_int As Integer

ret_int = fccq.move_cr("2", "Urgent")

JavaScript:

var ret_int = fccq.move_cr("2", "Urgent");


reject_cr | fcSDK Documentation

reject_cr

Public Function reject_cr(ByVal cr_id As String, _
                                    ByVal reject_date As String, _
                        ByVal wipbin As String, _
                                    ByVal notes As String, _
                        ByVal user_name As String, _
                        ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified change request to be rejected from the queue it is in, and returned back to the owner. The change request must be currently dispatched to a queue. The API allows for the setting of the reject date, some notes about the reject, and the user who rejected the change request. The API also allows you to set the WIPBin that the change request is placed back in. This is additional functionality that base Clarify does not provide. The API can also generate a time bomb (for business rule notifications).

Parameters

Parameter Name | Required? | Description
cr_id | Yes | The change request to reject-forward
reject_date | No | When was the change request rejected. If this parameter is left blank, the CR is rejected at the current time
wipbin | No | The WIPBin to place the change request in. If left blank, the default WIPBin is used
notes | No | Notes about the reject
user_name | No | The user who rejected the change request. If left blank, the current user performs the reject
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified change request
-2 | The change request is not currently dispatched
-3 | Cannot find the specified user
-4 | The change request is currently closed - cannot dispatch
-5 | Cannot find the new specified WIPBin, or it is not a WIPBin for the specified user
-6 | Cannot find gbst_elm rank 2600 for string RETURN

Examples

Reject change request number '10' to the default WIPBin. The reject has no notes, is performed by the current user and is rejected at the current time. Generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fccq.reject_cr("10", "", "", "", "", True)

JavaScript:

var ret_int = fccq.reject_cr("10", "", "", "", "", true);

Reject change request number '2' at 10PM on November 23rd of 1997 to WIPBin 'East'. Reject should be logged as performed by steven, with notes of 'Some notes'. Don't generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fccq.reject_cr("2", "11/23/97 22:00:00", "East", _
                         "Some notes", "steven", False)

JavaScript:

var ret_int = fccq.reject_cr("2", "11/23/97 22:00:00", "East",
  "Some notes", "steven", false);


reopen_cr | fcSDK Documentation

reopen_cr

Public Function reopen_cr(ByVal cr_id As String, _
                        ByVal the_status As String, _
                        ByVal wipbin As String, _
                        ByVal user_name As String, _
                        ByVal reopen_date As String, _
                        ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified CR to be reopened. It must be in a condition other than "Open", and cannot be dispatched. The date/time of the reopen, the person performing the reopen, the WIPBin to place the case in, and the new status of the case can be specified. The person who reopens the case becomes the new owner. If the WIPBin is not specified, the CR is placed in the user's default WIPBin. This is augmented function from base Clarify, where the case is always placed in the default WIPBin. The status field is also augmented function. If the status is not specified, the case is placed in the default status for the Open condition. The API can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
cr_id | Yes | The CR to reopen
status | No | The new status for the CR. If no status is specified, the default status for CR Open condition is used
wipbin | No | The WIPBin to place the CR in. If left blank, the default WIPBin for the user is used
user_name | No | The user who reopened the CR. If left blank, the current user performs the reopen
reopen_date | No | When was the CR reopened. If this parameter is left blank, the reopen occurs at the current time
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified CR
-2 | The CR is not closed
-3 | The CR is currently dispatched
-4 | Cannot find the specified user
-5 | Cannot find gbst_elm rank 8800 for string CHG STS:REOPEN
-6 | Cannot find the specified status
-7 | Cannot find the specified WIPBin
-8 | Status transition not defined in Policies and Customers
-9 | Status transition not allowed for specified user
-17 | Privclass not found for specified user
-18 | Old status not found for old condition
-19 | New status not found for new condition
-20 | Cannot find the specified user's employee record for relating time bomb

Examples

Reopen CR number '10' by the current user at the current date/time. Place in the default WIPBin with the default status, and generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fccq.reopen_cr("10", "", "", "", "", True)

JavaScript:

var ret_int = fccq.reopen_cr("10", "", "", "", "", true);

Reopen CR number '2' at 10PM on November 23rd of 1997 by jeanne. Place in jeanne's WIPBin 'Urgent', with status 'User Error'. Don't generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fccq.reopen_cr("2", "User Error", "Urgent", _
                         "jeanne", "11/23/97 22:00:00", False)

JavaScript:

var ret_int = fccq.reopen_cr("2", "User Error", "Urgent",
     "jeanne", "11/23/97 22:00:00", false);


replicate_cr | fcSDK Documentation

replicate_cr

Public Function replicate_cr (ByVal cr_id As String, _
                                            ByVal user_name As String, _
                              ByVal rep_date As String, _
                              ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified change request to be replicated (copied) to a new CR. The new CR has all of the same fields/values/relations as the original (including relations to solutions) with a few exceptions:

  1. It has a new CR ID generated for it

  2. There is extra text placed in the CR history to show the start and end of the replicated CR history

  3. A new activity log entry is added to show the replication (one is added to the original record as well)

The API can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
cr_id | Yes | The change request to replicate
user_name | No | The user who replicated the change request. If left blank, the current user performs the replication
rep_date | No | When was the change request replicated. If this parameter is left blank, the replication occurs at the current time
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors; sets objid and id_number of new bug object in ret_objid (Long) and ret_id_num (String) global variables
-1 | Cannot find the specified change request
-2 | The change request is currently closed
-3 | Cannot find the specified user
-4 | Cannot find gbst_elm rank 8400 for string REPLICATE CR
-5 | Cannot find gbst_elm rank 11800 for string REPLICATE TO
-6 | Cannot find the specified user's employee record for relating time bomb
ret_objid | Output - Returns the objid of the replicated change request
ret_id_num | Output - Returns the id of the replicated change request

Examples

Tony replicates CR '10' at 10PM on November 23rd of 1997. Generate a time bomb.

Visual Basic:

Dim replicate_objid  As Long
Dim replicate_id_num As String
Dim ret_int As Integer

ret_int = fccq.replicate_cr("10", "tony", "11/23/97 22:00:00", True)

 If ret_int = 0 Then
   replicate_objid = fccq.ret_objid
   replicate_id_num = fccq.ret_id_num
 End If

JavaScript:

var ret_int = fccq.replicate_cr("10", "tony", "11/23/97 22:00:00", true);

 if (ret_int == 0) {
   var replicate_objid = fccq.ret_objid;
   var replicate_id_num = fccq.ret_id_num;
 }


yank_cr | fcSDK Documentation

yank_cr

Public Function yank_cr(ByVal cr_id As String, _
                              ByVal wipbin As String, _
                        ByVal yank_date As String, _
                              ByVal user_name As String, _
                        ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified change request to be yanked from the current location to a new owner's WIPBin. The date/time of the yank and the person yanking the change request can be specified. The person who yanks the change request becomes the new owner. The WIPBin to place the change request in may also be specified. This is augmented function from base Clarify, where the change request is always placed in the default WIPBin. The API can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
cr_id | Yes | The change request to yank
wipbin | No | The WIPBin to place the change request in. If left blank, the default WIPBin for the user is used
yank_date | No | When was the change request yanked. If this parameter is left blank, the yank occurs at the current time
user_name | No | The user who yanked the change request. If left blank, the current user performs the yank
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified change request
-2 | The change request is currently closed
-3 | Cannot find the specified user
-4 | Cannot find the specified WIPBin
-5 | Cannot find gbst_elm rank 4100 for string YANKED

Examples

Yank change request number '10' by the current user at the current date/time. Place in the default WIPBin and generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fccq.yank_cr("10", "", "", "", True)

JavaScript:

var ret_int = fccq.yank_cr("10", "", "", "", true);

Yank change request number '2' at 10PM on November 23rd of 1997 by dave. Place in WIPBin 'Urgent', and don't generate a time bomb.

Visual Basic:

Dim ret_int As Integer
ret_int = fccq.yank_cr("2", "Urgent", "11/23/97 22:00:00", "dave", False)

JavaScript:

var ret_int = fccq.yank_cr("2", "Urgent", "11/23/97 22:00:00", "dave", false);


FCFL API Toolkit for ClearSupport | fcSDK Documentation

FCFL API Toolkit for ClearSupport

Overview

Many customers have wanted the ability to customize the Clarify environment easily by adding base Clarify functions (such as case creation, closure, modification, or note logging) to web applications.

The First Choice Software FCFL API Toolkit for Clear Support solves these problems, as well as many others. The toolkit is a series of COM functions that you may add to your customizations.

All of the APIs perform the same base functions as the Clarify GUI - all database records are properly written, activity logs are generated to track the API call, and time bombs are added to the system so that business rules can be fired based on the API function call.

While all of the APIs mimic the Clarify base function, many of them provide augmented functionality that Clarify customers have requested. For example, the base Clarify yank function always placed the object in the user's default WIPBin. With the yank API in the toolkit, you have the choice of placing the object in any specific WIPBin for the user, or in the default WIPBin.

The APIs are simple to use. One simple API call is provided for each function, and very few data values must be supplied. The APIs are flexible in that they provide a large number of optional arguments that allow you to customize the API calls as needed.


accept_case | fcSDK Documentation

accept_case

Public Function accept_case(ByVal case_id As String, _
                          ByVal accept_date As String, _
                          ByVal wipbin_name As String, _
                          ByVal user_name As String, _
                          ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified case to be accepted from a dispatched queue. The case must be currently dispatched to a queue. The date/time of the accept, the WIPBin to place the case in, and the user performing the accept can be specified. The API can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
case_id | Yes | The case to accept
accept_date | No | When was the case accepted. If this parameter is left blank, the case is accepted at the current time
wipbin_name | No | The WIPBin to place the case in (for the user who accepted case) If left blank, the case is placed in the user's default WIPBin
user_name | No | The user who accepted the case. If left blank, the current user performs the accept
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified case
-2 | Case is not currently dispatched
-3 | Specified user is not found
-4 | The specified WIPBin is not valid for the user
-5 | Cannot find gbst_elm rank 100 for string ACCEPT

Examples

Accept Case number '10' right now for the current user, place in the default WIPBin, and generate a time bomb.

JavaScript:

var ret_int = fccs.accept_case("10", "", "", "", true);

Visual Basic:

Dim ret_int As Integer
ret_int = fccs.accept_case("10", "", "", "", True)

Accept case number '2' at 10PM on November 23rd of 1997 by marty, and place the case in marty's WIPBin named 'Urgent'. Don't generate a time bomb

JavaScript:

var ret_int = fccs.accept_case("2", "11/23/97 22:00:00", "Urgent", "marty", false);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.accept_case("2", "11/23/97 22:00:00", "Urgent", "marty", False)


accept_subcase | fcSDK Documentation

accept_subcase

Public Function accept_subcase(ByVal subcase_id As String, _
                        ByVal accept_date As String, _
                        ByVal wipbin As String, _
                        ByVal user_name As String, _
                        ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified subcase to be accepted from a dispatched queue. The subcase must be currently dispatched to a queue. The date/time of the accept, the WIPBin to place the subcase in, and the user performing the accept can be specified. The API can also generate a time bomb (for business rule notification), or not.

Parameters

Parameter Name | Required? | Description
subcase_id | Yes | The subcase to accept
accept_date | No | When was the subcase accepted. If this parameter is left blank, the subcase is accepted at the current time
wipbin | No | The WIPBin to place the subcase in (for the user who accepted the subcase). If left blank, the subcase is placed in the user's default WIPBin
user_name | No | The user who accepted the subcase. If left blank, the current user performs the accept.
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified subcase
-2 | Subcase is not currently in a queue
-3 | Specified user is not a member of the queue
-4 | The specified WIPBIN is not valid for the user
-5 | Could not find gbst_elm string for ACCEPT

Examples

Accept Subcase number '10-1' right now for the current user, place in the default WIPBin, and generate a time bomb.

JavaScript:

var ret_int = fccs.accept_subcase("10-1", "", "", "", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.accept_subcase("10-1", "", "", "", True)

Accept subcase number '2-3' at 10PM on November 23rd of 1997 by marty, and place the subcase in marty's WIPBin named 'Urgent'. Don't generate a time bomb

JavaScript:

var ret_int = fccs.accept_subcase("2-3", "11/23/97 22:00:00", "Urgent",  "marty", false);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.accept_subcase("2-3", "11/23/97 22:00:00", "Urgent", "marty", False)


assign_case | fcSDK Documentation

assign_case

Public Function assign_case(ByVal case_id As String, _
                          ByVal new_user As String, _
                          ByVal wipbin_name As String, _
                          ByVal assign_date As String, _
                                  ByVal user_name As String, _
                                  ByVal gen_time_bombs As Boolean) As Integer

Description

This API cause the specified case to be assigned to a new user. The case must be in the Open condition, and the user assigning the case does not have to be the owner of the case. In base Clarify, the assigner of a case must be the owner. If either user name is not specified, the "current" user is used. The date/time of the assignment, and the WIPBin to place the case in can also be specified. Allowing a WIPBin other than the default one is also an augmentation from base Clarify. The API can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
case_id | Yes | The case ID to be assigned
new_user | No | The user who the case is assigned to. If left blank, the case is assigned to the current user
wipbin_name | No | The WIPBin to place the case in (for the user who is assigned the case). If left blank, the case is placed in the user's default WIPBin
assign_date | No | When was the case assigned. If this parameter is left blank, the case is assigned at the current time
user_name | No | The user who assigned the case If left blank, the current user performs the assign
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified case
-2 | The specified case is not currently open
-3 | Specified user (to assign to) is not found
-4 | The specified WIPBin is not valid for the user
-5 | Specified user (who performed the assign) is not found
-6 | Cannot find gbst_elm rank 10500 for string ASSIGN

Examples

Assign case number '10' to user 'marty'. The assign is performed by the current user, is placed in the default WIPBin and is assigned at the current time. Generate a time bomb.

JavaScript:

var ret_int = fccs.assign_case("10", "marty", "", "", "", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.assign_case("10", "marty", "", "", "", True)

Assign case number '2' at 10PM on November 23rd of 1997 to marty, and place the case in marty's WIPBin named 'Urgent'. Assign should be logged as performed by sam. Don't generate a time bomb.

JavaScript:

var ret_int = fccs.assign_case("2", "marty", "Urgent",
                               "11/23/97 22:00:00", "sam", false);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.assign_case("2", "marty", "Urgent", "11/23/97 22:00:00", "sam", False)


assign_subcase | fcSDK Documentation

assign_subcase

Public Function assign_subcase(ByVal subcase_id As String, _
                             ByVal new_user As String, _
                             ByVal wipbin_name As String, _
                             ByVal assign_date As String, _
                                     ByVal user_name As String, _
                                     ByVal gen_time_bombs As Boolean) As Integer

Description

This API cause the specified subcase to be assigned to a new user. The subcase must be in the Open condition, and the user assigning the subcase does not have to be the owner of the subcase. In base Clarify, the assigner of a subcase must be the owner. If either user name is not specified, the "current" user is used. The date/time of the assignment, and the WIPBin to place the subcase in can also be specified. Allowing a WIPBin other than the default one is also an augmentation from base Clarify. The API can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
subcase_id | Yes | The subcase ID to be assigned
new_user | No | The user who the subcase is assigned to. If left blank, the subcase is assigned to the current user
wipbin_name | No | The WIPBin to place the subcase in (for the user who is assigned the subcase). If left blank, the subcase is placed in the user's default WIPBin
assign_date | No | When was the subcase assigned. If this parameter is left blank, the subcase is assigned at the current time
user_name | No | The user who assigned the subcase If left blank, the current user performs the assign
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified subcase
-2 | The specified subcase is not currently open
-3 | Specified user (to assign to) is not found
-4 | The specified WIPBin is not valid for the user
-5 | Specified user (who performed the assign) is not found
-6 | Cannot find gbst_elm rank 10500 for string ASSIGN

Examples

Assign subcase number '10-1' to user 'marty'. The assign is performed by the current user, is placed in the default WIPBin and is assigned at the current time. Generate a time bomb.

JavaScript:

var ret_int = fccs.assign_subcase("10-1", "marty", "", "", "", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.assign_subcase("10-1", "marty", "", "", "", True)

Assign subcase number '2'-3 at 10PM on November 23rd of 1997 to marty, and place the subcase in marty's WIPBin named 'Urgent'. Assign should be logged as performed by sam. Don't generate a time bomb.

JavaScript:

var ret_int = fccs.assign_subcase("2-3", "marty", "Urgent",
                               "11/23/97 22:00:00", "sam", false);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.assign_subcase("2-3", "marty", "Urgent", _
                           "11/23/97 22:00:00", "sam", False)


change_case_status | fcSDK Documentation

change_case_status

Public Function change_case_status(ByVal case_id As String, _
                                   ByVal new_status As String, _
                                   ByVal change_date As String, _
                                   ByVal note_str As String, _
                                   ByVal user_name As String, _
                                   ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified case to have its status changed. The case may be opened or closed, but the status selected MUST be valid for the current condition. In other words, you cannot assign a close condition status to a case that is currently open. You may assign notes to the status change, as well as set the time of the status change, and the user who changed the status. The API can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
case_id | Yes | The case to change status for
new_status | No | The new status for the case
change_date | No | When was the case status changed. If this parameter is left blank, the case is status changed at the current time
note_str | No | Notes for the status change
user_name | No | The user who changed the status. If left blank, the current user performs the change status
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified case
-2 | Cannot find the new status (or status is not defined for the current object's condition)
-3 | Cannot find the specified user
-4 | Cannot find the CHANGE STATUS activity string

Examples

Change status for case number 'C154' to the default status. The change status is performed by the current user and is changed at the current time. Add no notes, and generate a time bomb.

JavaScript:

var ret_int = fccs.change_case_status("C154", "", "", "", "", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.change_case_status("C154", "", "", "", "", True)

Change status for case number '2' at 10PM on November 23rd of 1997 to 'Solved'. Change status has notes of 'Some notes', and should be logged as performed by dave. Don't generate a time bomb.

JavaScript:

var ret_int = fccs.change_case_status("2", "Solved", "11/23/97 22:00:00", "Some notes", "dave", false);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.change_case_status("2", "Solved", "11/23/97 22:00:00", _
                                  "Some notes", "dave", False)


change_contact | fcSDK Documentation

change_contact

Public Function change_contact(ByVal case_id As String, _
                               ByVal f_name As String, _
                               ByVal l_name As String, _
                               ByVal phone_num As String, _
                               ByVal site_id As String, _
                               ByVal change_date As String, _
                               ByVal user_name As String, _
                               ByVal gen_time_bombs As Boolean) As Integer

Description

This API allows for the changing of a contact and/or site for a case. Unlike the Clarify GUI (which changes contacts via contact roles), you may change the contact and/or site such that the contact for the case is not a contact at the site for the case. Since this is possible in the base GUI (by changing the contact's site after the contact/site are used for the case), the API allows this natively.

To use the API, you must specify the case to change, and then either a contact, or site (or both). In addition, the date/time of the change, as well as the user performing the change can be specified. Finally, the API can also genereate time bombs (for business rule notification).

The API changes the relations for the case. In addition, the case history and activity log are modified. If the contact is changed, the case phone and alternate phone are changed. If the site is changed, any related site_parts for the case are unrelated, as is any contract related to the case. All of this corresponds to actions taken by the base Clarify GUI.

Parameters

Parameter Name | Required? | Description
case_id | Yes | The case to change the contact/site for
first | No | First name of new contact
last | No | Last name of new contact
phone_num | No | Phone number of new contact
site_id | No | Site ID of new site
change_date | No | Date the contact/site was changed. If left blank, the current date/time is used
user_name | No | User making the change. If left blank, the current user is used
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified case
-2 | Cannot find the specified user
-3 | Cannot find the CHNG CONTACT activity string
-4 | Cannot find the MODIFY activity string
-5 | Cannot find the specified contact
-6 | Cannot find the specified site
-7 | Neither a new contact nor new site was specified
-8 | Case is currently closed
-9 | Could not find a status for the specified case
-10 | A new contact and/or site must be specified
-11 | No employee record exists for the specified user

Examples

Change contact for case number 'C154' to Joe Jackson. Don't change the site. The change is performed by the current user and is changed at the current time. Generate a time bomb.

JavaScript:

var ret_int = fccs.change_contact("C154", "Joe", "Jackson", "555-1212", "",
                                  "", "", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.change_contact("C154", "Joe", "Jackson", "555-1212", "", _
                              "", "", True)

Change contact and site for case number '2' at 10PM on November 23rd of 1997 to 'Mary Smith' at site '43'. Change should be logged as performed by Patty. Don't generate a time bomb.

JavaScript:

var ret_int = fccs.change_contact("2", "Mary", "Smith", "555-5555", "43",

                                  "11/23/97 22:00:00", "patty", false);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.change_contact("2", "Mary", "Smith", "555-5555", "43", _
                              "11/23/97 22:00:00", "patty", False)


change_subcase_status | fcSDK Documentation

change_subcase_status

Public Function change_subcase_status(ByVal subcase_id As String, _
                                      ByVal new_status As String, _
                                      ByVal change_date As String, _
                                      ByVal note_str As String, _
                                      ByVal user_name As String, _
                                      ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified subcase to have its status changed. The subcase may be opened or closed, but the status selected MUST be valid for the current condition. In other words, you cannot assign a close condition status to a subcase that is currently open. You may assign notes to the status change, as well as set the time of the status change, and the user who changed the status. The API can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
subcase_id | Yes | The subcase to change status for
new_status | No | The new status for the subcase
change_date | No | When was the subcase status changed. If this parameter is left blank, the subcase is status changed at the current time
note_str | No | Notes for the status change
user_name | No | The user who changed the status. If left blank, the current user performs the change status
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified subcase
-2 | Cannot find the new status (or status is not defined for the current object's condition)
-3 | Cannot find the specified user
-4 | Cannot find the CHANGE STATUS activity string

Examples

Change status for subcase number 'C154-1' to the default status. The change status is performed by the current user and is changed at the current time. Add no notes, and generate a time bomb.

JavaScript:

var ret_int = fccs.change_case_status("C154-1", "", "", "", "", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.change_subcase_status("C154-1", "", "", "", "", True)

Change status for subcase number '2-2' at 10PM on November 23rd of 1997 to 'Solved'. Change status has notes of 'Some notes', and should be logged as performed by dave. Don't generate a time bomb.

JavaScript:

var ret_int = fccs.change_subcase_status("2-2", "Solved", "11/23/97 22:00:00",
                                        "Some notes", "dave", false);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.change_subcase_status("2-2", "Solved", "11/23/97 22:00:00", _
                                     "Some notes", "dave", False)


close_case | fcSDK Documentation

close_case

close_case_list

Public Function close_case(ByVal case_id As String, _
                           ByVal the_status As String, _
                           ByVal resolution_str As String, _
                           ByVal summary_str As String, _
                           ByVal user_name As String, _
                           ByVal close_date As String, _
                           ByVal units_used As Double, _
                           ByVal close_sums As String, _
                           ByVal gen_time_bombs As Boolean, _
                           ByVal int_fld1 As String, _
                           ByVal int_val1 As Long, ByVal int_fld2 As String, _
                           ByVal int_val2 As Long, ByVal str_fld1 As String, _
                           ByVal str_val1 As String, ByVal str_fld2 As String, _
                           ByVal str_val2 As String, ByVal date_fld1 As String, _
                           ByVal date_val1 As String) As Integer

Public Function close_case_list(ByVal case_id As String, _
                                ByVal the_status As String, _
                                ByVal resolution_str As String, _
                                ByVal summary_str As String, _
                                ByVal user_name As String, _
                                ByVal close_date As String, _
                                ByVal units_used As Double, _
                                ByVal close_sums As String, _
                                ByVal gen_time_bombs As Boolean, _
                                Optional fld_list As Variant, _
                                Optional type_list As Variant, _
                                Optional val_list As Variant) As Integer

Description

These APIs are used to close a case. The case must be in open condition. The APIs allow for the assigning of a closed status, as well as resolution codes, the number of units to apply to the contract for the case, and a summary string. The APIs allow you to specify a user who performed the close, as well as the date/time of closure. The APIs allow for additional fields to be written to the close_case object, and the APIs return the objid of the newly created close_case object (in the FCCS object return variable ret_objid). The APIs can also generate a time bomb (for business rule notification).

There is an argument (close_sums) that can be used for advanced functioning of the API. In some cases (for example, web pages), you may wish to show the summation times for the case (phone log time, research time, time and expense logs), and allow the user to override some of them. This can be performed with the preclose_case API.

After those times are determined, it would be useful to close the case with them. That is the purpose of the close_sums argument. It is a pipe-delimited string ("|"), that contains exactly 12 items. Those items are detailed below. If you do not have a time for a given item, use 0 as a placeholder.

If the close_sums argument is used, the API will not spend the effort to do the log summation. That means that if a log was created between the time you call on preclose_case, and this API, it will not be added to the summation.

In almost all cases, this argument is left blank.

    1. Total phone time (closed subcase and phone log for the case)
    2. Captured phone time (case phone logs only)
    3. Total research time (closed subcase and research logs for the case)
    4. Captured research time (case research logs only)
    5. Total non-billable time (closed subcase and case time logs)
    6. Captured non-billable time (case time logs only)
    7. Total billable time (closed subcase and case time logs)
    8. Captured billable time (case time logs only)
    9. Total non-billable expenses (closed subcase and case expense logs)
    10. Captured non-billable expenses (case time logs only)
    11. Total billable expenses (closed subcase and case expense logs)
    12. Captured billable expenses (case time logs only)

Parameters

Parameter Name | Required? | Description
case_id | Yes | The case to close
the_status | No | The closed condition status for the case. If left blank, the default status for closed condition is used
resolution | No | The resolution code for the close. If left blank, the default code is used
summary | No | An optional text string with information about the closure
user_name | No | The user who closed the case. If left blank, the current user performs the close
close_date | No | The date/time of the close. If left blank, the current time is used
units_used | No | The number of units to charge against the contract for the case. If the case has no contract, this field must be 0
close_sums | No | Sums already determined for the close_case record (see above). If blank, the summation times are calculated by this API
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules).
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | No | List of additional field names to write.
type_list | No | List of additional field data types to write
val_list | No | List of additional field values to write.

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified case
-2 | The specified case is already closed
-3 | There is at least one open general subcase
-10 | The specified user is not found
-11 | The specified status is not a valid status for condition 'Closed'
-12 | Could not find gbst_elm string for CASE CLOSE
-13 | Could not find the specified resolution string
-14 | Units to charge are specified, but there is no contract for this case
-15 | No employee record was found for the specified user
-16 | A close_sums string was passed in with an invalid format

Examples

Close case number 'C154'. Use the default status and resolution code. Add no summary text, and let the close be by the default user at the current date/time. There is no contract, so there are no units to charge, and no additional fields to write. Generate a time bomb.

Field version:

JavaScript:

var ret_int = fccs.close_case("C154", "", "", "", "", "", 0, "", true, "", 0,
                              "", 0, "", "", "", "", "", "");

Visual Basic:

Dim ret_int     As Integer

ret_int = fccs.close_case("C154", "", "", "", "", "", 0, "", True, "", 0, _
                     "", 0, "", "", "", "", "", "")

List version:

JavaScript:

var ret_int = fccs.close_case_list("C154", "", "", "", "", "", 0, "", true);

Visual Basic:

Dim ret_int     As Integer

ret_int = fccs.close_case_list("C154", "", "", "", "", "", 0, "", True)

Close case number '2' at 10PM on November 23rd of 1997 by marty. Put in status 'Closed-final', with resolution 'Software Shipped', summary of 'Auto-close' with 1.4 units charged against the contract. There are several 'x_' fields to be written to the close_case object. Don't generate a time bomb

Field version:

JavaScript:

var ret_int = fccs.close_case("2", "Closed-final", "Software Shipped",
   "Auto-close", "marty", "11/23/97 22:00:00", 1.4,
   "", true, "x_close_int1", 1, "x_close_int2", 456,
   "x_summary2", "More text", "", "",
   "x_other_date", "1/1/99");

Visual Basic:

Dim ret_int     As Integer

ret_int = fccs.close_case("2", "Closed-final", "Software Shipped", _
                "Auto-close", "marty", "11/23/97 22:00:00", 1.4, _
                "", True, "x_close_int1", 1, "x_close_int2", 456, _
                "x_summary2", "More text", "", "", _
                "x_other_date", "1/1/99")

List version:

JavaScript:

var fld_list  = Server.CreateObject("FCFL.FCList");
var type_list = Server.CreateObject("FCFL.FCList");
var val_list  = Server.CreateObject("FCFL.FCList");

fld_list.AppendItem("x_close_int1");
type_list.AppendItem("Long");
val_list.AppendItem("1");

fld_list.AppendItem("x_close_int2");
type_list.AppendItem("Long");
val_list.AppendItem("456");

fld_list.AppendItem("x_summary2");
type_list.AppendItem("String");
val_list.AppendItem("More text");

fld_list.AppendItem("x_other_date");
type_list.AppendItem("Date");
val_list.AppendItem("1/1/99");

var ret_int = fccs.close_case_list("2", "Closed-final", "Software Shipped",
                "Auto-close", "marty", "11/23/97 22:00:00", 1.4,
                "", true, fld_list, type_list, val_list);

Visual Basic:

Dim ret_int As Integer
Dim fld_list    As New FCList
Dim type_list   As New FCList
Dim val_list    As New FCList
fld_list.AppendItem "x_close_int1"
type_list.AppendItem "Long"
val_list.AppendItem Trim(Str$(1))

fld_list.AppendItem "x_close_int2"
type_list.AppendItem "Long"
val_list.AppendItem Trim(Str$(456))

fld_list.AppendItem "x_summary2"
type_list.AppendItem "String"
val_list.AppendItem "More text"

fld_list.AppendItem "x_other_date"
type_list.AppendItem "Date"
val_list.AppendItem "1/1/99"

ret_int = fccs.close_case_list("2", "Closed-final", "Software Shipped", _
                "Auto-close", "marty", "11/23/97 22:00:00", 1.4, _
                "", True, fld_list, type_list, val_list)


close_subcase | fcSDK Documentation

close_subcase

close_subcase_list

Public Function close_subcase(ByVal subcase_id As String, _
                              ByVal the_status As String, _
                              ByVal resolution_str As String, _
                              ByVal summary_str As String, _
                              ByVal user_name As String, _
                              ByVal close_date As String, _
                              ByVal gen_time_bombs As Boolean, _
                              ByVal int_fld1 As String, _
                              ByVal int_val1 As Long, ByVal int_fld2 As String, _
                              ByVal int_val2 As Long, ByVal str_fld1 As String, _
                              ByVal str_val1 As String, _
                              ByVal str_fld2 As String, _
                              ByVal str_val2 As String, _
                              ByVal date_fld1 As String, _
                              ByVal date_val1 As String) As Integer

Public Function close_subcase_list(ByVal subcase_id As String, _
                                   ByVal the_status As String, _
                                   ByVal resolution_str As String, _
                                   ByVal summary_str As String, _
                                   ByVal user_name As String, _
                                   ByVal close_date As String, _
                                   ByVal units_used As Double, _
                                   ByVal gen_time_bombs As Boolean, _
                                   Optional fld_list As Variant, _
                                   Optional type_list As Variant, _
                                   Optional val_list As Variant) As Integer

Description

These APIs are used to close a subcase. The subcase must be in open condition. The APIs allow for the assigning of a closed status, as well as resolution codes, and a summary string. The APIs allow you to specify a user who performed the close, as well as the date/time of closure. The APIs allow for additional fields to be written to the close_case object via three list arguments, and the API returns the objid of the newly created close_case object(in the FCCS object return variable ret_objid). The APIs can also generate a time bomb (for business rule notification). The business rule version of this API does not return the objid of the new close_case object.

Parameters

Parameter Name | Required? | Description
subcase_id | Yes | The subcase to close
the_status | No | The closed condition status for the subcase. If left blank, the default status for closed condition is used
resolution | No | The resolution code for the close. If left blank, the default code is used
summary | No | An optional text string with information about the closure
user_name | No | The user who closed the subcase. If left blank, the current user performs the close
close_date | No | The date/time of the close. If left blank, the current time is used
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified subcase
-2 | The specified subcase is already closed
-10 | The specified user is not found
-11 | The specified status is not a valid status for condition 'Closed'
-12 | Could not find gbst_elm string for CASE CLOSE
-13 | Could not find the specified resolution string
-14 | Units to charge are specified, but there is no contract for this case
-15 | No employee record was found for the specified user

Examples

Close subcase number 'C154-1'. Use the default status and resolution code. Add no summary text, and let the close be by the default user at the current date/time. There are no additional fields to write. Generate a time bomb.

Field version:

JavaScript:

var ret_int = fccs.close_subcase("C154-1", "", "", "", "", "", true, "", 0,
                              "", 0, "", "", "", "", "", "");

Visual Basic:

Dim ret_int     As Integer

ret_int = fccs.close_subcase("C154-1", "", "", "", "", "", True, "", 0, _
                     "", 0, "", "", "", "", "", "")

List version:

JavaScript:

var ret_int = fccs.close_subcase_list("C154-1", "", "", "", "", "", true);

Visual Basic:

Dim ret_int     As Integer

ret_int = fccs.close_subcase_list("C154-1", "", "", "", "", "", True)

Close subcase number '2-1' at 10PM on November 23rd of 1997 by marty. Put in status 'Closed-final', with resolution 'Software Shipped', summary of 'Auto-close'. There are several 'x_' fields to be written to the close_case object. Don't generate a time bomb

Field version:

JavaScript:

var ret_int = fccs.close_subcase("2-1", "Closed-final", "Software Shipped",
   "Auto-close", "marty", "11/23/97 22:00:00",
   true, "x_close_int1", 1, "x_close_int2", 456,
   "x_summary2", "More text", "", "",
   "x_other_date", "1/1/99");
`

**Visual Basic:**

Dim ret_int As Integer

ret_int = fccs.close_subcase("2-1", "Closed-final", "Software Shipped", _ "Auto-close", "marty", "11/23/97 22:00:00", _ True, "x_close_int1", 1, "x_close_int2", 456, _ "x_summary2", "More text", "", "", _ "x_other_date", "1/1/99")

**List version:**

**JavaScript:**

var fld_list  = Server.CreateObject("FCFL.FCList");
var type_list = Server.CreateObject("FCFL.FCList");
var val_list  = Server.CreateObject("FCFL.FCList");

fld_list.AppendItem("x_close_int1");
type_list.AppendItem("Long");
val_list.AppendItem("1");

fld_list.AppendItem("x_close_int2");
type_list.AppendItem("Long");
val_list.AppendItem("456");

fld_list.AppendItem("x_summary2");
type_list.AppendItem("String");
val_list.AppendItem("More text");

fld_list.AppendItem("x_other_date");
type_list.AppendItem("Date");
val_list.AppendItem("1/1/99");

var ret_int = fccs.close_subcase_list("2-1", "Closed-final", "Software Shipped", "Auto-close", "marty", "11/23/97 22:00:00", true, fld_list, type_list, val_list);

**Visual Basic:**

Dim ret_int As Integer
Dim fld_list    As New FCList
Dim type_list   As New FCList
Dim val_list    As New FCList

fld_list.AppendItem "x_close_int1" type_list.AppendItem "Long" val_list.AppendItem Trim(Str$(1))

fld_list.AppendItem "x_close_int2" type_list.AppendItem "Long" val_list.AppendItem Trim(Str$(456))

fld_list.AppendItem "x_summary2" type_list.AppendItem "String" val_list.AppendItem "More text"

fld_list.AppendItem "x_other_date" type_list.AppendItem "Date" val_list.AppendItem "1/1/99"

ret_int = fccs.close_subcase_list("2-1", "Closed-final", "Software Shipped", _ "Auto-close", "marty", "11/23/97 22:00:00", _ True, fld_list, type_list, val_list)


create_case | fcSDK Documentation

create_case

create_case_list

Public Function create_case(ByVal site_id As String, _
                ByVal f_name As String, ByVal l_name As String, _
                ByVal phone_num As String, ByVal part_num As String, _
                ByVal mod_level As String, ByVal domain_name As String, _
                ByVal serial_no As String, ByVal sp_objid As Long, _
                ByVal contract_id As String, ByVal the_title As String, _
                ByVal case_type As String, ByVal priority_str As String, _
                ByVal severity_str As String, ByVal status_str As String, _
                ByVal phone_log As String, ByVal queue_name As String, _
                ByVal cr_date As String, ByVal phone_end_date As String, _
                ByVal user_name As String, ByVal gen_time_bombs As Boolean, _
                ByVal int_fld1 As String, ByVal int_val1 As Long, _
                ByVal int_fld2 As String, ByVal int_val2 As Long, _
                Byval str_fld1 As String, ByVal str_val1 As String, _
                ByVal str_fld2 As String, ByVal str_val2 As String, _
                ByVal date_fld1 As String, ByVal date_val1 As String) As Integer

Public Function create_case_list(ByVal site_id As String, _
                ByVal f_name As String, ByVal l_name As String, _
                ByVal phone_num As String, ByVal part_num As String, _
                ByVal mod_level As String, ByVal domain_name As String, _
                ByVal serial_no As String, ByVal sp_objid As Long, _
                ByVal contract_id As String, ByVal the_title As String, _
                ByVal case_type As String, ByVal priority_str As String, _
                ByVal severity_str As String, ByVal status_str As String, _
                ByVal phone_log As String, ByVal queue_name As String, _
                ByVal cr_date As String, ByVal phone_end_date As String, _
                ByVal user_name As String, ByVal gen_time_bombs As Boolean, _
                Optional fld_list As Variant, Optional type_list As Variant, _
                Optional val_list As Variant) As Integer

Description

These APIs are used to create new cases. They require that a valid site and contact be specified. Everything else is optional. You may specify either a part/mod_level or a site part for a case (or neither), you may specify a contract, a title, a case type, priority, severity, and status (base Clarify does not allow you to specify a status). You may add a phone, log (or not), and you may have the case initially dispatched to a queue. You may specify the the case creation date, and the end of the phone log (for phone call length). You may specify the user who created the case, and you may specify additional fields. You may have a creation time bomb generated (for notifications). The objid of the case created is returned. The business rule version of this API does not return the objid of the new case object.

If you do not wish to associate a part/revision or site_part against the case, leave the part_num field empty. If you wish to have a case part (and revision), you must fill in the part_num, mod_level, and domain fields. If you also specify a serial_no, the system will associate the site_part against the case. If you have site_parts that are not serialized, you can query for the site_part before calling this API, and pass in the objid of the site_part in the sp_objid field. If you do this, then the other fields (part_num, mod_level, domain, serial_no) are ignored.

If you want to have a phone log for the case, place the text in the phone_log field. Note that this is different than the ClearBasic version of this API, which required an external file. If you have a phone log the API will also generate a phone log activity log and a phone log time bomb (if time bombs are enabled).

You may also initially dispatch the case. If you specify a queue name, the case will be dispatched to that queue. In addition, an activity log entry will be added, and a time_bomb will be generated (if time bombs are enabled).

If successful, these APIs return both the objid and the id_number of the newly-created case. They are returned in the FCCS object variables ret_objid and ret_id_num.

Parameters

Parameter Name | Required? | Description
site_id | Yes | Which site reported the case
first | Yes | First name of contact calling in the case
last | Yes | Last name of contact calling in the case
phone | Yes | Phone number of contact calling in the case
part_num | No | Part number of case part or site_part
mod_level | No | Revision of case part or site_part. If the revision is NULL (Oracle only), still use the empty string ("") to query
domain | No | Domain of case part or site_part
serial_no | No | Serial number of the site_part for the case (if there is one)
sp_objid | No | Objid of site_part for the case (if externally queried)
contract | No | ID of the contract for the case. If left blank, there is no contract
the_title | No | Title for the case. It is suggested that you always have a title
case_type | No | Case type for the case. If left blank, default value is used
priority | No | Priority for the case. If left blank, default value is used
severity | No | Severity for the case. If left blank, default value is used
status | No | Initial status for the case. If left blank, default status is used
phone_log | No | Phone notes for the case
queue_name | No | Name of the queue to dispatch the case to. If left blank, the case is not initially dispatched
cr_date | No | Case creation date. If left blank, current date/time is used
phone_end_date | No | If there is a phone log, this is the date/time that the call ended. If left blank, the case creation time is used
user_name | No | The user who created the case. If left blank, the current user performs the create
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules). and prior warning time?
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified site
-2 | Cannot find the specified contact
-3 | Cannot find the specified part number
-4 | The mod_level is not valid for the specified part
-5 | The serial number specified is not valid for the part/mod_level
-6 | The specified site_part is at another site
-7 | The specified site_part is not found
-10 | The phone log end time is prior to the case creation time
-11 | The phone log text file is not found
-12 | The specified user is not found
-13 | The specified case type is not found
-14 | The specified priority is not found
-15 | The specified severity is not found
-16 | The specified status is not found
-17 | The CREATE activity string is not found
-18 | The PHONE LOG activity string is not found
-19 | The DISPATCH activity string is not found
-20 | The specified Phone Log action type string is not found
-21 | Cannot find a primary address for the specified site
-22 | The specified contract is not found
-23 | The specified queue is not found
-25 | Could not locate an employee record for the specified user

Examples

Create a new case. Specify the site of 'White House', and contact of Bill Clinton. Also, generate a time bomb. All other information is defaulted.

Field version:

JavaScript:

var ret_int = fccs.create_case("White House", "Bill", "Clinton",
          "555-555-1234", "", "", "", "", 0, "", "", "",
          "", "", "", "", "", "", "", "", true, "", 0,
          "", 0, "", "", "", "", "", "");

   if (ret_int == 0)
   {
      WScript.Echo("The ID of the created case is: " + fccs.ret_id_num);
   }

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.create_case("White House", "Bill", "Clinton", _
          "555-555-1234", "", "", "", "", 0, "", "", "", _
          "", "", "", "", "", "", "", "", True, "", 0, _
          "", 0, "", "", "", "", "", "")

   If ret_int = 0 Then
      MsgBox "The ID of the created case is: " & fccs.ret_id_num
   End If

List version:

JavaScript:

var ret_int = fccs.create_case_list("White House", "Bill", "Clinton",
          "555-555-1234", "", "", "", "", 0, "", "", "",
          "", "", "", "", "", "", "", "", true);

   if (ret_int == 0)
   {
      WScript.Echo("The ID of the created case is: " + fccs.ret_id_num);
   }

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.create_case_list("White House", "Bill", "Clinton", _
          "555-555-1234", "", "", "", "", 0, "", "", "", _
          "", "", "", "", "", "", "", "", True)

   If ret_int = 0 Then
      MsgBox "The ID of the created case is: " & fccs.ret_id_num
   End If

Create a case for Bill Clinton at the White House. The problem is for MS Word, Version 7.0 (serial number 1234). The case is on contract 'Hardware Support', and the case is given a title. It is entered by marty on November 23, 1997 at 10PM. The case_type is a Problem with High priority and Medium severity. The initial case status is Solving. Include some phone notes, the call lasted 15 minutes, and the case is dispatched to the Important queue. There are no time bombs generated, and some additional fields are also filled in.

Field version:

JavaScript:

var ret_int = fccs.create_case("White House", "Bill", "Clinton",
          "555-555-1234", "MS Word", "7.0", "Software",
          "1234", 0, "ABCD", "The title", "Problem",
          "High", "Medium", "Solving", "Some phone notes",
          "Important", "11/23/97 22:00:00", "11/23/97 22:15:00",
          "marty", true, "x_create_int1", 1,
          "x_create_int2", 456, "x_summary2", "More text",
          "", "", "", "");

   if (ret_int == 0)
   {
      WScript.Echo("The ID of the created case is: " + fccs.ret_id_num);
   }

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.create_case("White House", "Bill", "Clinton", _
          "555-555-1234", "MS Word", "7.0", "Software", _
          "1234", 0, "ABCD", "The title", "Problem", _
          "High", "Medium", "Solving", "Some phone notes", _
          "Important", "11/23/97 22:00:00", "11/23/97 22:15:00", _
          "marty", True, "x_create_int1", 1, _
          "x_create_int2", 456, "x_summary2", "More text", _
          "", "", "", "")

   If ret_int = 0 Then
      MsgBox "The ID of the created case is: " & fccs.ret_id_num
   End If

List version:

JavaScript:

var fld_list  = Server.CreateObject("FCFL.FCList");
var type_list = Server.CreateObject("FCFL.FCList");
var val_list  = Server.CreateObject("FCFL.FCList");

fld_list.AppendItem("x_create_int1");
type_list.AppendItem("Long");
val_list.AppendItem("1");

fld_list.AppendItem("x_ create_int2");
type_list.AppendItem("Long");
val_list.AppendItem("456");

fld_list.AppendItem("x_summary2");
type_list.AppendItem("String");
val_list.AppendItem("More text");

var ret_int = fccs.create_case_list("White House", "Bill", "Clinton",
          "555-555-1234", "MS Word", "7.0", "Software",
          "1234", 0, "ABCD", "The title", "Problem",
          "High", "Medium", "Solving", "Some phone notes",
          "Important", "11/23/97 22:00:00", "11/23/97 22:15:00",
          "marty", true, fld_list, type_list, val_list);

   if (ret_int == 0)
   {
      WScript.Echo("The ID of the created case is: " + fccs.ret_id_num);
   }

Visual Basic:

Dim ret_int As Integer
Dim fld_list   As New FCList
Dim type_list  As New FCList
Dim val_list   As New FCList

fld_list.AppendItem("x_create_int1")
type_list.AppendItem("Long")
val_list.AppendItem("1")

fld_list.AppendItem("x_ create_int2")
type_list.AppendItem("Long")
val_list.AppendItem("456")

fld_list.AppendItem("x_summary2")
type_list.AppendItem("String")
val_list.AppendItem("More text")

ret_int = fccs.create_case_list("White House", "Bill", "Clinton", _
          "555-555-1234", "MS Word", "7.0", "Software", _
          "1234", 0, "ABCD", "The title", "Problem", _
          "High", "Medium", "Solving", "Some phone notes", _
          "Important", "11/23/97 22:00:00", "11/23/97 22:15:00", _
          "marty", True, fld_list, type_list, val_list)

   If ret_int = 0 Then
      MsgBox "The ID of the created case is: " & fccs.ret_id_num
   End If


create_subcase | fcSDK Documentation

create_subcase

create_subcase_list

Public Function create_subcase(ByVal case_id As String, _
                ByVal the_title As String, ByVal is_general As Boolean, _
                ByVal priority_str As String, ByVal severity_str As String, _
                ByVal status_str As String, ByVal note_str As String, _
                ByVal queue_name As String, ByVal cr_date As String, _
                ByVal due_date As String, ByVal prior_warn As Long, _
                ByVal user_name As String, ByVal gen_time_bombs As Boolean, _
                ByVal int_fld1 As String, ByVal int_val1 As Long, _
                ByVal int_fld2 As String, ByVal int_val2 As Long, _
                ByVal str_fld1 As String, ByVal str_val1 As String, _
                ByVal str_fld2 As String, ByVal str_val2 As String, _
                ByVal date_fld1 As String, ByVal date_val1 As String) As Integer

Public Function create_subcase_list(ByVal case_id As String, _
                ByVal the_title As String, ByVal is_general As Boolean, _
                ByVal priority_str As String, ByVal severity_str As String, _
                ByVal status_str As String, ByVal note_str As String, _
                ByVal queue_name As String, ByVal cr_date As String, _
                ByVal due_date As String, ByVal prior_warn As Long, _
                ByVal user_name As String, ByVal gen_time_bombs As Boolean, _
                Optional fld_list As Variant, Optional type_list As Variant, _
                Optional val_list As Variant) As Integer

Description

These APIs are used to create new subcases. They require that a valid, open case be used as the parent case. You must specify if it is either general or administrative. Everything else is optional. You may specify a title, priority, severity, initial status, queue to dispatch to, due date and prior warning, user who creates the subcase, and subcase creation time. You may add additional fields to the subcase object. You may have a creation time bomb generated (for notifications).

You may also initially dispatch the subcase. If you specify a queue name, the subcase will be dispatched to that queue. In addition, an activity log entry will be added, and a time_bomb will be generated (if time bombs are enabled).

If successful, these APIs return both the objid and the id_number of the newly-created case. They are returned in the FCCS object variables ret_objid and ret_id_num.

Parameters

Parameter Name | Required? | Description
case_id | Yes | The ID of the parent case
the_title | No | Title for the subcase. It is suggested that you always have a title
is_general | Yes | Is this a general subcase (True), or administrative (False)
priority | No | Priority for the subcase. If left blank, default value is used
severity | No | Severity for the subcase. If left blank, default value is used
status | No | Initial status for the subcase. If left blank, default status is used
notes | No | Subcase notes
queue_name | No | Name of the queue to dispatch the subcase to. If left blank, the subcase is not initially dispatched
cr_date | No | Subcase creation date. If left blank, current date/time is used
due_date | No | When the commitment for subcase is due. If left blank, the subcase creation time is used
prior_warn | No | How long before the due date should a warning be issued (in seconds)
user_name | No | The user who created the subcase. If left blank, the current user performs the create
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules). and prior warning time?
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified master case ID
-2 | The prior warning (in seconds) is negative
-10 | The commitment date is prior to the case creation date
-11 | The warning date is prior to the case creation date
-12 | The specified user is not found
-14 | The specified priority is not found
-15 | The specified severity is not found
-16 | The specified status is not found
-17 | The CREATE SUBCASE activity string is not found
-18 | The CREATE ADMIN SUBCASE activity string is not found
-19 | The DISPATCH activity string is not found
-23 | The specified queue is not found
-24 | Could not build a new unique ID number. See if stored procedure is compiled in the database
-25 | Could not locate an employee record for the specified user

Examples

Create a general subcase for case number 'C154'. Set a title and use the default priority, severity, status, user_name and dates. Make no prior warning, have no notes, and set no additional fields. Generate a time bomb.

Field version:

JavaScript:

var ret_int = fccs.create_subcase("C154", "Subcase Title", true,
          "", "", "", "", "", "", "", 0, "", true,
          "", 0, "", 0, "", "", "", "", "", "");

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.create_subcase("C154", "Subcase Title", True, _
          "", "", "", "", "", "", "", 0, "", True, _
          "", 0, "", 0, "", "", "", "", "", "")

List version:

JavaScript:

var ret_int = fccs.create_subcase_list("C154", "Subcase Title", true,
          "", "", "", "", "", "", "", 0, "", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.create_subcase_list("C154", "Subcase Title", True, _
          "", "", "", "", "", "", "", 0, "", True)

Create an administrative subcase for case number '2'. Set a title, priority, severity, status, notes, creation date, due date, a prior warning of two hours, and dispatch it to 'Queue 2'. Set it so that marty created the case, and add some additional fields. Do not generate a time bomb.

Field version:

JavaScript:

var ret_int = fccs.create_subcase("2", "A title", false, "High",
          "Low", "Solving", "Some notes", "Queue 2",
          "11/23/97 16:00:00", "11/24/97 13:00:00", 7200,
          "marty", false, "x_create_int1", 1, "x_create_int2",
          456, "x_summary2", "More text", "", "",
          "x_other_date", "1/1/99");

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.create_subcase("2", "A title", False, "High", _
          "Low", "Solving", "Some notes", "Queue 2", _
          "11/23/97 16:00:00", "11/24/97 13:00:00", 7200, _
          "marty", False, "x_create_int1", 1, "x_create_int2", _
          456, "x_summary2", "More text", "", "", _
          "x_other_date", "1/1/99")

List version:

JavaScript:

var fld_list  = Server.CreateObject("FCFL.FCList");
var type_list = Server.CreateObject("FCFL.FCList");
var val_list  = Server.CreateObject("FCFL.FCList");

fld_list.AppendItem("x_create_int1");
type_list.AppendItem("Long");
val_list.AppendItem("1");

fld_list.AppendItem("x_ create_int2");
type_list.AppendItem("Long");
val_list.AppendItem("456");

fld_list.AppendItem("x_summary2");
type_list.AppendItem("String");
val_list.AppendItem("More text");

fld_list.AppendItem("x_other_date");
type_list.AppendItem("Date");
val_list.AppendItem("1/1/99");

var ret_int = fccs.create_subcase_list("2", "A title", false, "High",
          "Low", "Solving", "Some notes", "Queue 2",
          "11/23/97 16:00:00", "11/24/97 13:00:00", 7200,
          "marty", false, type_list, val_list);

Visual Basic:

Dim ret_int As Integer
Dim fld_list   As New FCList
Dim type_list  As New FCList
Dim val_list   As New FCList

fld_list.AppendItem("x_create_int1")
type_list.AppendItem("Long")
val_list.AppendItem("1")

fld_list.AppendItem("x_ create_int2")
type_list.AppendItem("Long")
val_list.AppendItem("456")

fld_list.AppendItem("x_summary2")
type_list.AppendItem("String")
val_list.AppendItem("More text")

fld_list.AppendItem("x_other_date")
type_list.AppendItem("Date")
val_list.AppendItem("1/1/99")

ret_int = fccs.create_subcase_list("2", "A title", False, "High", _
          "Low", "Solving", "Some notes", "Queue 2", _
         "11/23/97 16:00:00", "11/24/97 13:00:00", 7200, _
          "marty", False, type_list, val_list)


dispatch_case | fcSDK Documentation

dispatch_case

Public Function dispatch_case(ByVal case_id As String, _
                              ByVal queue_name As String, _
                              ByVal disp_date As String, _
                              ByVal user_name As String, _
                              ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified case to be dispatched to the specified queue. The case must be in open condition, and not currently dispatched to a queue. The API allows for the setting of the dispatch date, and the user who dispatched the case. The API can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
case_id | Yes | The case to dispatch
queue_name | Yes | The queue to dispatch to
disp_date | No | When was the case dispatched. If this parameter is left blank, the case is dispatched at the current time
user_name | No | The user who dispatched the case. If left blank, the current user performs the dispatch.
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified case
-2 | The case is already dispatched
-3 | The case is closed and may not be dispatched
-4 | The specified user cannot be found
-5 | The specified new queue name cannot be found
-6 | The DISPATCH activity string is not found
-7 | The specified queue does not allow dispatches of cases
-8 | Cannot find the employee record for the designated user

Examples

Dispatch case number 'C154' to queue 'Hardware'. The dispatch is performed by the current user and is dispatched at the current time. Generate a time bomb.

JavaScript:

var ret_int = fccs.dispatch_case("C154", "Hardware", "", "", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.dispatch_case("C154", "Hardware", "", "", True)

Dispatch case number '2' at 10PM on November 23rd of 1997 to 'Software'. Dispatch should be logged as performed by dave. Don't generate a time bomb.

JavaScript:

var ret_int = fccs.dispatch_case("2", "Software",
                                 "11/23/97 22:00:00", "dave", false);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.dispatch_case("2", "Software", "11/23/97 22:00:00", _
                             "dave", False)


dispatch_subcase | fcSDK Documentation

dispatch_subcase

Public Function dispatch_subcase(ByVal subcase_id As String, _
                                 ByVal queue_name As String, _
                                 ByVal disp_date As String, _
                                 ByVal user_name As String, _
                                 ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified subcase to be dispatched to the specified queue. The subcase must be in open condition, and not currently dispatched to a queue. The API allows for the setting of the dispatch date, and the user who dispatched the subcase. The API can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
subcase_id | Yes | The subcase to dispatch
queue_name | Yes | The queue to dispatch to
disp_date | No | When was the subcase dispatched. If this parameter is left blank, the subcase is dispatched at the current time
user_name | No | The user who dispatched the subcase. If left blank, the current user performs the dispatch.
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified subcase
-2 | The subcase is already dispatched
-3 | The subcase is closed and may not be dispatched
-4 | The specified user cannot be found
-5 | The specified new queue name cannot be found
-6 | The DISPATCH activity string is not found
-7 | The specified queue does not allow dispatches of subcases
-8 | Cannot find the employee record for the designated user

Examples

Dispatch subcase number 'C154-1' to queue 'Hardware'. The dispatch is performed by the current user and is dispatched at the current time. Generate a time bomb.

JavaScript:

var ret_int = fccs.dispatch_subcase("C154-1", "Hardware", "", "", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.dispatch_subcase("C154-1", "Hardware", "", "", True)

Dispatch subcase number '2-2' at 10PM on November 23rd of 1997 to 'Software'. Dispatch should be logged as performed by dave. Don't generate a time bomb.

JavaScript:

var ret_int = fccs.dispatch_subcase("2-2", "Software",
                                    "11/23/97 22:00:00", "dave", false);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.dispatch_subcase("2-2", "Software", "11/23/97 22:00:00", _
                                "dave", False)


forward_case | fcSDK Documentation

forward_case

Public Function forward_case(ByVal case_id As String, _
                             ByVal new_queue As String, _
                             ByVal forward_date As String, _
                             ByVal note_str As String, _
                             ByVal user_name As String, _
                             ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified case to be reject-forwarded from one queue to another. The case must be in open condition, and currently dispatched to a queue. The API allows for the setting of the forward date, some notes about the forward, and the user who forwarded the case. The APIs can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
case_id | Yes | The case to reject-forward
new_queue | Yes | The queue to forward to
forward_date | No | When was the case forwarded. If this parameter is left blank, the case is forwarded at the current time
notes | No | Optional notes about the reject-forward
user_name | No | The user who forwarded the case. If left blank, the current user performs the forward
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified case
-2 | Case is not currently dispatched
-3 | The new queue name specified is not found
-4 | Reject-forward attempted to same queue as currently dispatched to
-5 | The specified user is not found
-6 | The FORWARD activity string is not found
-7 | Can not forward Case to specified queue

Examples

Reject-forward case number 'C154' to queue 'Hardware'. The reject-forward has no notes, is performed by the current user and is forwarded at the current time. Generate a time bomb.

JavaScript:

ret_int = fccs.forward_case("C154", "Hardware", "", "", "", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.forward_case("C154", "Hardware", "", "", "", True)

Reject-forward case number '2' at 10PM on November 23rd of 1997 to 'Software'. Forward should be logged as performed by dave, with notes of 'Some notes'. Don't generate a time bomb.

JavaScript:

var ret_int = fccs.forward_case("2", "Software", "11/23/97 22:00:00",
                                "Some notes", "dave", false);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.forward_case("2", "Software", "11/23/97 22:00:00", _
                            "Some notes", "dave", False)


forward_subcase | fcSDK Documentation

forward_subcase

Public Function forward_subcase(ByVal subcase_id As String, _
                                ByVal new_queue As String, _
                                ByVal forward_date As String, _
                                ByVal note_str As String, _
                                ByVal user_name As String, _
                                ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified subcase to be reject-forwarded from one queue to another. The subcase must be in open condition, and currently dispatched to a queue. The API allows for the setting of the forward date, some notes about the forward, and the user who forwarded the subcase. The APIs can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
subcase_id | Yes | The subcase to reject-forward
new_queue | Yes | The queue to forward to
forward_date | No | When was the subcase forwarded. If this parameter is left blank, the subcase is forwarded at the current time
notes | No | Optional notes about the reject-forward
user_name | No | The user who forwarded the subcase. If left blank, the current user performs the forward
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified subcase
-2 | Subcase is not currently dispatched
-3 | The new queue name specified is not found
-4 | Reject-forward attempted to same queue as currently dispatched to
-5 | The specified user is not found
-6 | The FORWARD activity string is not found
-7 | Can not forward Case to specified queue

Examples

Reject-forward subcase number 'C154-1' to queue 'Hardware'. The reject-forward has no notes, is performed by the current user and is forwarded at the current time. Generate a time bomb.

JavaScript:

ret_int = fccs.forward_subcase("C154-1", "Hardware", "", "", "", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.forward_subcase("C154-1", "Hardware", "", "", "", True)

Reject-forward subcase number '2-2' at 10PM on November 23rd of 1997 to 'Software'. Forward should be logged as performed by dave, with notes of 'Some notes'. Don't generate a time bomb.

JavaScript:

var ret_int = fccs.forward_subcase("2-2", "Software", "11/23/97 22:00:00",
                                   "Some notes", "dave", false);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.forward_subcase("2-2", "Software", "11/23/97 22:00:00", _
                               "Some notes", "dave", False)


fulfill_commitment | fcSDK Documentation

fulfill_commitment

Public Function fulfill_commitment(ByVal log_objid As Long, _
                                   ByVal fulfill_date As String, _
                                   ByVal user_name As String, _
                                   ByVal gen_time_bombs As Boolean) As Integer

Description

This API will fulfill a previously unfulfilled commitment. The commitment objid supplied must be for an open, unfulfilled commitment. The user who fulfills the commitment, as well as the fulfill time may be specified. The API can also generate a time bomb (for business rule notification). The objid for the commitment can either be retrieved from the log_*_commitment APIs in this toolkit (which return the objid of the commitment or from a Clear Basic query.

Parameters

Parameter Name | Required? | Description
log_objid | Yes | The objid of the log to be fulfilled
fulfill_date | No | When was the commitment fulfilled. If this parameter is left blank, commitment is fulfilled at the current time
user_name | No | The user who fulfilled the commitment. If left blank, the current user performs the fulfill
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified commit log
-2 | The fulfill date is before the log creation date
-3 | The commitment is already fulfilled
-4 | The specified commitment is not for case or subcase
-5 | The specified user is not found
-6 | The FULFILL activity string is not found
-7 | Cannot find Employee record for specified user

Examples

Fulfill the commitment with the objid of 268435457. The fulfill is is performed by the current user and is fulfilled at the current time. Generate a time bomb.

JavaScript:

var ret_int = fccs.fulfill_commitment(268435457, "", "", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.fulfill_commitment(268435457, "", "", True)

Fulfill a commitment with an objid of 268435500. The fulfill is perfomed by dave at 10PM on November 23rd of 1997. Don't generate a time bomb.

JavaScript:

var ret_int = fccs.fulfill_commitment(268435500,
                   "11/23/97 22:00:00", "dave", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.fulfill_commitment(268435500, _
               "11/23/97 22:00:00", "dave", True)


initial_response | fcSDK Documentation

initial_response

Public Function initial_response(ByVal case_id As String, _
                                 ByVal resp_date As String, _
                                 ByVal user_name As String, _
                                 ByVal via_phone As Boolean, _
                                 ByVal gen_time_bombs As Boolean) As Integer

Description

This API will mark the initial response to a case. The case supplied should not already have had the intial response marked because it can only be marked once for a given case. The response can be marked as being from a phone call (True), or from an email (False). The user who performed the initial response and the time of that response can be specified. The APIs can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
case_id | Yes | The case that the initial response is for
resp_date | No | When was the initial response logged.If this parameter is left blank, the response is at the current time
user_name | No | The user who logged the initial response. If left blank, the current user performs the logging. For business rules, it defaults to the
user_name who is executing the cbbatch |  |
via_phone | Yes | Is the response via a phone call (True), or via email (False)
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified case
-2 | The initial response date is earlier than the case creation date
-3 | The case already has a marked initial response
-4 | The specified user is not found
-5 | The INITIAL RESPONSE activity string is not found
-6 | Cannot find Employee record for specified user

Examples

Mark an initial response for case 'C154' via a phone call. The logging is performed by the current user and is performed at the current time. Generate a time bomb.

JavaScript:

var ret_int = fccs.initial_response("C154", "", "", true, true);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.initial_response("C154", "", "", True, True)

Mark an initial response via an email for case '2' at 10PM on November 23rd of 1997. It is logged by dave. Don't generate a time bomb.

JavaScript:

var ret_int = fccs.initial_response("2", "11/23/97 22:00:00", "dave",
                                    false, false);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.initial_response("2", "11/23/97 22:00:00", "dave", _
                                False, False)


initialize | fcSDK Documentation

initialize

Public Sub Initialize(ByVal FCApp As FCApplication, ByVal FCSess As FCSession)

Description

This API initializes an FCCS object. It must be called after the creation of the object, and before any other APIs can be called on the FCCS object. Simply put, this API simply saves the FCApplication and FCSession pointers within the FCCS object so that they can be used as needed.

Parameters

Parameter Name | Required? | Description
FCApp | Yes | FCApplication object
FCSess | Yes | FCSession object

Examples

Create and initialize a new FCCS object.

JavaScript:

var FCApp;
var FCSession;
var fccs;

FCApp = new ActiveXObject("FCFL.fcapplication");
FCApp.WorkingDirectory =
    "C:\\\users\\\first\\\product\\\fcfl\\\error";

FCApp.Initialize();
FCSession = FCApp.CreateSession();
FCSession.Login("sa","sa", "user");

fccs = new ActiveXObject("FCCS.CS");
fccs.Initialize(FCApp, FCSession);

//  Do FCCS work here
FCCS = null;
FCSession.Logout();
FCSession.CloseSession();
FCSession = null;
FCApp = null;

Visual Basic:

Dim fc_app     As FCApplication
Dim fc_session As FCSession
Dim fccs_obj   As CS

Set fc_app = New FCApplication
fc_app.ConnectionString = "provider=sqloledb;datasource=gaffer;initial   catalog=cl10;user id=sa; password=sa;"
fc_app.Initialize

Set fc_session = fc_app.CreateSession
fc_session.Login "sa", "sa", "user"

Set fccs_obj = New CS
fccs_obj.Initialize fc_app, fc_session

' Do FCCS work here
Set fccs_obj = Nothing
fc_session.Logout

Set fc_session = Nothing
Set fc_app = Nothing


log_case_commit | fcSDK Documentation

log_case_commit

log_case_commit_list

Public Function log_case_commit(ByVal case_id As String, _
                    ByVal the_title As String, ByVal action_type As String, _
                    ByVal log_date As String, ByVal commit_date As String, _
                    ByVal prior_warn As Long, ByVal made_to As Boolean, _
                    ByVal cont_first As String, ByVal cont_last As String, _
                    ByVal cont_phone As String, ByVal note_str As String, _
                    ByVal user_name As String, ByVal gen_time_bombs As Boolean, _
                    ByVal generate_commit_email As Boolean, _
                    ByVal int_fld1 As String, _
                    ByVal int_val1 As Long, ByVal int_fld2 As String, _
                    ByVal int_val2 As Long, ByVal str_fld1 As String, _
                    ByVal str_val1 As String, ByVal str_fld2 As String, _
                    ByVal str_val2 As String, ByVal date_fld1 As String, _
                    ByVal date_val1 As String) As Integer

Public Function log_case_commit_list(ByVal case_id As String, _
                    ByVal the_title As String, ByVal action_type As String, _
                    ByVal log_date As String, ByVal commit_date As String, _
                    ByVal prior_warn As Long, ByVal made_to As Boolean, _
                    ByVal cont_first As String, ByVal cont_last As String, _
                    ByVal cont_phone As String, ByVal note_str As String, _
                    ByVal user_name As String, ByVal gen_time_bombs As Boolean, _
                    ByVal generate_commit_email As Boolean, _
                    Optional fld_list As Variant, _
                    Optional type_list As Variant,
                    Optional val_list As Variant) As Integer

Description

These APIs are used to create a commitment against a case. The APIs allow for the assigning of a title and action type. The date the commitment is logged can be set, as well as the commitment date, and prior warning. A flag can be set so that the commitment can be made to or by a contact, and the contact can be set. The user who logs the commitment can be set, and additional fields can also be set. Finally, a time bomb (for the commitment) can be generated, as can the email reminders. This last item has been added for consistency with Clarify. Base Clarify sends two email commitments each time a commitment is logged. The first notifies the owner when the commitment expires, and the second notifies the owner when the prior warning (if any) expires. These can only be email commitments, but the delivery mechanism can be modified by changing the com_tmplte record. See Clarify for more details. These APIs allow the programmer to turn off those extra notifications, if desired. The objid of the log created is returned.

The objid of the created log is returned in the FCCS object variable ret_objid.

Parameters

Parameter Name | Required? | Description
case_id | Yes | The case to close
the_title | Yes | The title of the commitment
action_type | No | The commitment log action type code value
log_date | No | The date the log was created. If left blank, the current time is used
commit_date | Yes | When the commitment is due. If left blank, set to the log date
prior_warn | Yes | How long to warn the owner before the commitment expires. This is recorded in seconds (1 hour = 3600 seconds). If set to 0, no prior warning is given
made_to | Yes | Is the commitment to the contact (True), or by the contact (False)
cont_first | Yes | First name of the contact
cont_last | Yes | Last name of the contact
cont_phone | Yes | Phone number of the contact
note_str | No | Additional text notes for the log
user_name | No | The user who created the log. If left blank, the current user performs the logging
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules).
generate_commit_email | Yes | Should the API add the email notifications for the commitment time and prior warning time?
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | No title specified
-2 | Prior warning is negative (warning after the commitment expires)
-3 | The commitment date is before the log date
-4 | Cannot find the specified case
-5 | Specified user is not found
-6 | Could not find gbst_elm string for COMMIT
-7 | Could not find the specified log action type
-8 | Could not find the specified contact
-9 | Could not find the com_tmplte for WARNING
-10 | Could not find the com_tmplte for COMMITMENT
-11 | Cannot find the employee record for the specified user

Examples

Create a log for case number 'C154'. Set a title and use the default action code, log date, and user. Make the commitment to "Bill Clinton", and make the commitment expire on the default (log) date. Make no prior warning, have no notes, and set no additional fields. Generate a time bomb, and the commitement emails.

Field version:

JavaScript:

var ret_int = fccs.log_case_commit("C154", "A title", "", "", "", 0, true,
          "Bill", "Clinton", "555-555-1234", "", "", true, true,
          "", 0, "", 0, "", "", "", "", "", "");

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.log_case_commit("C154", "A title", "", "", "", 0, True, _
          "Bill", "Clinton", "555-555-1234", "", "", True, True, _
          "", 0, "", 0, "", "", "", "", "", "")

List version:

JavaScript:

var ret_int = fccs.log_case_commit_list("C154", "A title", "", "",
          "", 0, true, "Bill", "Clinton", "555-555-1234", "",
          "", true, true);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.log_case_commit_list("C154", "A title", "", "", "", 0, True, _
          "Bill", "Clinton", "555-555-1234", "", "", True, True)

Create a log for case number '2'. Set a title, action code, log date, and user. Make the commitment by "Bill Clinton", and make the commitment expire on '1/1/99'. Make a prior warning for two hours, have some notes, and additional fields. Generate neither a time bomb, nor the commitement emails.

Field version:

JavaScript:

var ret_int = fccs.log_case_commit("2", "A title", "External Commitment",
          "11/23/97 22:00:00", "1/1/99", 7200, false,
          "Bill", "Clinton", "555-555-1234", "Some notes", "marty",
          false, false, "x_close_int1", 1, "x_close_int2", 456,
          "x_summary2", "More text", "", "",
          "x_other_date", "1/1/99")

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.log_case_commit("2", "A title", "External Commitment", _
          "11/23/97 22:00:00", "1/1/99", 7200, False, _
          "Bill", "Clinton", "555-555-1234", "Some notes", "marty", _
          False, False, "x_close_int1", 1, "x_close_int2", 456, _
          "x_summary2", "More text", "", "", _
          "x_other_date", "1/1/99")

List version:

JavaScript:

var fld_list  = Server.CreateObject("FCFL.FCList");
var type_list = Server.CreateObject("FCFL.FCList");
var val_list  = Server.CreateObject("FCFL.FCList");

fld_list.AppendItem("x_close_int1");
type_list.AppendItem("Long");
val_list.AppendItem ("1");

fld_list.AppendItem("x_close_int2");
type_list.AppendItem("Long");
val_list.AppendItem ("456");

fld_list.AppendItem("x_summary2");
type_list.AppendItem("String");
val_list.AppendItem("More text");

fld_list.AppendItem("x_other_date");
type_list.AppendItem("Date");
val_list.AppendItem("1/1/99");

var ret_int = fccs.log_case_commit_list("2", "A title",
          "External Commitment", "11/23/97 22:00:00", "1/1/99", 7200, false,
          "Bill", "Clinton", "555-555-1234", "Some notes", "marty",
          false, false, fld_list, type_list, val_list);

Visual Basic:

Dim ret_int As Integer
Dim fld_list    As New FCList
Dim type_list   As New FCList
Dim val_list    As New FCList

fld_list.AppendItem "x_close_int1"
type_list.AppendItem "Long"
val_list.AppendItem Trim(Str$(1))

fld_list.AppendItem "x_close_int2"
type_list.AppendItem "Long"
val_list.AppendItem Trim(Str$(456))

fld_list.AppendItem "x_summary2"
type_list.AppendItem "String"
val_list.AppendItem "More text"

fld_list.AppendItem "x_other_date"
type_list.AppendItem "Date"
val_list.AppendItem "1/1/99"

ret_int = fccs.log_case_commit_list("2", "A title", "External Commitment", _
          "11/23/97 22:00:00", "1/1/99", 7200, False, _
          "Bill", "Clinton", "555-555-1234", "Some notes", "marty", _
          False, False, fld_list, type_list, val_list)


log_case_email | fcSDK Documentation

log_case_email

log_case_ email_list

Public Function log_case_email(ByVal case_id As String, _
                    ByVal action_type As String, _
                    ByVal log_date As String, ByVal message As String, _
                    ByVal recipient As String, ByVal cc_list As String, _
                    ByVal user_name As String, ByVal new_stat As String, _
                    ByVal cmit_title As String, ByVal cmit_notes As String, _
                    ByVal cmit_due As String, ByVal cmit_prior As Long, _
                    ByVal cmit_to As Boolean, ByVal cmit_action_type As String, _
                    ByVal cmit_contact_objid As Long, _
                              ByVal gen_time_bombs As Boolean, _
                    ByVal send_email As Boolean, _
                    ByVal int_fld1 As String, ByVal int_val1 As Long, _
                    ByVal int_fld2 As String, ByVal int_val2 As Long, _
                    ByVal str_fld1 As String, ByVal str_val1 As String, _
                    ByVal str_fld2 As String, ByVal str_val2 As String, _
                    ByVal date_fld1 As String, _
                    ByVal date_val1 As String) As Integer

Public Function log_case_email_list(ByVal case_id As String, _
                    ByVal action_type As String, _
                    ByVal log_date As String, ByVal message As String, _
                    ByVal recipient As String, ByVal cc_list As String, _
                    ByVal user_name As String, ByVal new_stat As String, _
                    ByVal cmit_title As String, ByVal cmit_notes As String, _
                    ByVal cmit_due As String, ByVal cmit_prior As Long, _
                    ByVal cmit_to As Boolean, ByVal cmit_action_type As String, _
                    ByVal cmit_contact_objid As Long, _
                              ByVal gen_time_bombs As Boolean, _
                    ByVal send_email As Boolean, Optional fld_list As Variant, _
                    Optional type_list As Variant, _
                    Optional val_list As Variant) As Integer

Description

These APIs are used to create an email log against a case. The APIs allow for the assigning of the email message, the email recipients, a cc list, and an action type. A new case status can be set with this API. Additional fields can also be set as well as a time bomb (for the phone log), which allows notifications to be generated based on the event. You may also specify the user who created/sent the email.

You have the option, with these APIs, of sending the email yourself, or of having Clarify send it for you. If you set the send_email argument to True, the API will add a row to Clarify that will cause the rule manager (which must be running) to send the email. This is just like logging it via the Log Email GUI in Clarify. The downside of this is that rulemanager sends the email from the server, which means that the recipient(s) cannot hit "reply", and have the email come back to you.

If you want to send the email yourself, just set the argument to False. In this case, the API logs the email, but does not send it.

Optionally, you can also set a commitment with the note log. If you wish to set a commitment, you MUST set the commitment due date (cmit_due) and the commitement title (cmit_title). The commitment title usually comes from the user-defined list "COMMITMENT", but it does not have to for this API. Any string is acceptable. The other commitment fields are optional. You can add notes to the commitement , and a prior warning. Also, you must set if the commitment is to the contact or by the contact. The contact for the case is always used for the commitment contact.

The objid of the created log is returned in the FCCS object variable ret_objid.

The objid of the commitment log record is returned in the FCCS object variable ret_objid2.

The objid of the status change record is returned in the FCCS object variable ret_objid3.

Parameters

Parameter Name | Required? | Description
case_id | Yes | The case to create the log for
action_type | No | The email log action type code value. If left blank, default code is used
log_date | No | The date the log was created. If left blank, the current time is used
message | No | The email message
recipient | No | List of email addresses the email is sent to
cc_list | No | List of cc recipients for the email
user_name | No | The user who created the log. If left blank, the current user performs the logging
new_stat | No | New status for the case. If blank (""), no status change is performed
cmit_title | No | Title of the commitment. If blank, no commitment is generated
cmit_notes | No | If generating a commitment, optional notes for the commitment (max length of 255)
cmit_due | No | When is the commitment due. If blank, no commitment is generated
cmit_prior | No | How long (in seconds) before the commitment is due should a warning business rule notification be fired. If set to 0, no warning is generated
cmit_to | Yes | Is the commitment made to the customer (=True), or by the customer (=False). If no commitment is to be generated, this value is ignored
cmit_action_type | No | The commitment log action type value. If left blank, default code is used
cmit_contact_objid | No | The objid of the contact for the commitment. If set to 0, the contact for the case is used.
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules).
send_email | Yes | Should a time_bomb be added to Clarify that will cause rule manager (if running) to send the email
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified case
-2 | Cannot find the specified user
-3 | Cannot find the EMAIL LOG activity string
-4 | Cannot find the employee record for the specified user
-5 | Cannot find the COM TEMPLATE for sending email
-6 | The specified action type is not valid
-7 | The supplied status is invalid for the current condition
-8 | A commitment is to be created, but the title is blank
-9 | The prior warning is negative
-10 | The commitment due date is before the log creation date
-11 | Cannot find the COMMIT activity string
-12 | Could not find the com_tmplte for WARNING
-13 | Could not find the com_tmplte for COMMITMENT
-14 | Cannot find the specified commitment log action type
-15 | Cannot find the specified contact

Examples

Create an email to send to 'joe@fred.com' for case C154. Set the message for the log, and no other information. Do not send the email, just log it. Generate a time bomb.

Field version:

JavaScript:

   var ret_int = fccs.log_case_email("C154", "", "", "Email message",
        "joe@fred.com", "", "", "", "", "", "", 0, true, "", 0, true, false,
        "", 0, "", 0, "", "", "", "", "", "");

Visual Basic:

   Dim ret_int As Integer

   ret_int = fccs.log_case_email("C154", "", "", "Email message", _
       "joe@fred.com", "", "", "", "", "", "", 0, True, "", 0, True, False, _
       "", 0, "", 0, "", "", "", "", "", "")

List version:

JavaScript:

   var ret_int = fccs.log_case_email_list("C154", "", "", "Email message",
        "joe@fred.com", "", "", "", "", "", "", 0, true, "", 0, true, false);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.log_case_email_list("C154", "", "", "Email message", _
         "joe@fred.com", "", "", "", "", "", "", 0, True, "", 0, True, False)

Send an email for case '2' with a recieipient, and a list of "cc" recipients. Send as internal email. Send from "sam", on November 23, 1997 at 10PM. Change the status to "Working". Also, create a commitment for January 1, 1999 at 8:00AM, with a title, notes, and a prior warning of 1 hour (with the commitment being made by the contact). Generate some additional fields, but do not generate a time bomb. Send the email.

Field version:

JavaScript:

   var ret_int = fccs.log_case_email("2", "Internal Email",
           "11/23/97 22:00:00", "Email message", "joe@fred.com",
           "mary@fred.com, cathy@fred.com", "sam", "Working",
           "Commit title", "Commit notes", "1/1/1999 8:00:00",
           3600, false, "", 0, false, true,
           "x_close_int1", 1, "x_close_int2", 456,
           "x_summary2", "More text", "", "",
           "x_other_date", "1/1/99");

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.log_case_email("2", "Internal Email", _
           "11/23/97 22:00:00", "Email message", "joe@fred.com", _
           "mary@fred.com, cathy@fred.com", "sam", "Working", _
           "Commit title", "Commit notes", "1/1/1999 8:00:00", _
           3600, False, "", 0, False, True, _
           "x_close_int1", 1, "x_close_int2", 456, _
           "x_summary2", "More text", "", "", _
           "x_other_date", "1/1/99")

List version:

JavaScript:

var fld_list  = Server.CreateObject("FCFL.FCList");
var type_list = Server.CreateObject("FCFL.FCList");
var val_list  = Server.CreateObject("FCFL.FCList");

fld_list.AppendItem("x_close_int1");
type_list.AppendItem("Long");
val_list.AppendItem ("1");

fld_list.AppendItem("x_close_int2");
type_list.AppendItem("Long");
val_list.AppendItem ("456");

fld_list.AppendItem("x_summary2");
type_list.AppendItem("String");
val_list.AppendItem("More text");

fld_list.AppendItem("x_other_date");
type_list.AppendItem("Date");
val_list.AppendItem("1/1/99");

var ret_int = fccs.log_case_email("2", "Internal Email",
           "11/23/97 22:00:00", "Email message", "joe@fred.com",
           "mary@fred.com, cathy@fred.com", "sam", "Working",
           "Commit title", "Commit notes", "1/1/1999 8:00:00",
           3600, false, false, "", 0, true, fld_list, type_list, val_list);

Visual Basic:

Dim ret_int As Integer
Dim fld_list    As New List
Dim type_list   As New List
Dim val_list    As New List

fld_list.AppendItem "x_close_int1"
type_list.AppendItem "Long"
val_list.AppendItem Trim(Str$(1))

fld_list.AppendItem "x_close_int2"
type_list.AppendItem "Long"
val_list.AppendItem Trim(Str$(456))

fld_list.AppendItem "x_summary2"
type_list.AppendItem "String"
val_list.AppendItem "More text"

fld_list.AppendItem "x_other_date"
type_list.AppendItem "Date"
val_list.AppendItem "1/1/99"

ret_int = fccs.log_case_email("2", "Internal Email", _
          "11/23/97 22:00:00", "Email message", "joe@fred.com", _
          "mary@fred.com, cathy@fred.com", "sam", "Working", _
          "Commit title", "Commit notes", "1/1/1999 8:00:00", _
          3600, False, "", 0, False, True, fld_list, type_list, val_list)


log_case_note | fcSDK Documentation

log_case_note

log_case_note_list

Public Function log_case_note(ByVal case_id As String, _
                    ByVal action_type As String, ByVal note_str As String, _
                    ByVal int_use As String, ByVal log_date As String, _
                    ByVal user_name As String, ByVal new_stat As String, _
                    ByVal cmit_title As String, ByVal cmit_notes As String, _
                    ByVal cmit_due As String, ByVal cmit_prior As Long, _
                    ByVal cmit_to As Boolean, ByVal gen_time_bombs As Boolean, _
                    ByVal int_fld1 As String, ByVal int_val1 As Long, _
                    ByVal int_fld2 As String, ByVal int_val2 As Long, _
                    ByVal str_fld1 As String, ByVal str_val1 As String, _
                    ByVal str_fld2 As String, ByVal str_val2 As String, _
                    ByVal date_fld1 As String, _
                    ByVal date_val1 As String) As Integer

Public Function log_case_note_list(ByVal case_id As String, _
                    ByVal action_type As String, ByVal note_str As String, _
                    ByVal int_use As String, ByVal log_date As String, _
                    ByVal user_name As String, ByVal new_stat As String, _
                    ByVal cmit_title As String, ByVal cmit_notes As String, _
                    ByVal cmit_due As String, ByVal cmit_prior As Long, _
                    ByVal cmit_to As Boolean, ByVal gen_time_bombs As Boolean, _
                    Optional fld_list As Variant, _
                    Optional type_list As Variant, _
                    Optional val_list As Variant) As Integer

Description

These APIs are used to create a note log against a case. The APIs allow for the assigning of notes, internal use only text, and an action type. The date the note is logged can be set, as well as the user who logs the note. Also, a new status can be set for the case. Additional fields can also be set as well as a time bomb (for the note log), which allows notifications to be generated based on the event.

Optionally, you can also set a commitment with the note log. If you wish to set a commitment, you MUST set the commitment due date (cmit_due) and the commitement title (cmit_title). The commitment title usually comes from the user-defined list "COMMITMENT", but it does not have to for this API. Any string is acceptable. The other commitment fields are optional. You can add notes to the commitement , and a prior warning. Also, you must set if the commitment is to the contact or by the contact. The contact for the case is always used for the commitment contact.

The objid of the created log is returned in the FCCS object variable ret_objid.

The objid of the commitment log record is returned in the FCCS object variable ret_objid2.

The objid of the status change record is returned in the FCCS object variable ret_objid3.

Parameters

Parameter Name | Required? | Description
case_id | Yes | The case to create the log for
action_type | No | The note log action type code value. If left blank, default code is used
notes | No | The note log text
int_use | No | Internal use only information
log_date | No | The date the log was created. If left blank, the current time is used
user_name | No | The user who created the log. If left blank, the current user performs the logging
new_stat | No | New status for the case. If blank (""), no status change is performed
cmit_title | No | Title of the commitment. If blank, no commitment is generated
cmit_notes | No | If generating a commitment, optional notes for the commitment (max length of 255)
cmit_due | No | When is the commitment due. If blank, no commitment is generated
cmit_prior | No | How long (in seconds) before the commitment is due should a warning business rule notification be fired. If set to 0, no warning is generated
cmit_to | Yes | Is the commitment made to the customer (=True), or by the customer (=False). If no commitment is to be generated, this value is ignored
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified case
-2 | Cannot find the specified user
-3 | Cannot find the NOTES activity string
-4 | Cannot find the notes log action type string
-5 | Cannot find employee record for specified user
-6 | The supplied status is invalid for the current condition
-7 | A commitment is to be created, but the title is blank
-8 | The prior warning is negative
-9 | The commitment due date is before the log creation date
-10 | Cannot find the COMMIT activity string
-11 | Could not find the com_tmplte for WARNING
-12 | Could not find the com_tmplte for COMMITMENT

Examples

Create a note log for case number 'C154'. Set the notes for the log, and no other information. Generate a time bomb.

Field version:

JavaScript:

var ret_int = fccs.log_case_note("C154", "", "Some notes", "", "", "", "",
                        "", "", "", 0, true, true, "", 0, "", 0, "",
                        "", "", "", "", "");

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.log_case_note("C154", "", "Some notes", "", "", "", "", _
                        "", "", "", 0, True, True, _
                        "", 0, "", 0, "", "", "", "", "", "")

List version:

JavaScript:

var ret_int = fccs.log_case_note_list("C154", "", "Some notes", "", "", "",
                                      "", "", "", "", 0, true, true)

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.log_case_note_list("C154", "", "Some notes", "", "", "", _
                                  "", "", "", "", 0, True, True)

Create a note log for case number '2'. Set action code of 'Manager Note', some note text, and internal use only text. Have the note logged by marty on November 23, 1997 at 10PM. Change the status to "Working". Also, create a commitment for January 1, 1999 at 8:00AM, with a title, notes, and a prior warning of 1 hour (with the commitment being made by the contact). Generate some additional fields, but do not generate a time bomb.

Field version:

JavaScript:

var ret_int = fccs.log_case_note("2", "Manager Note", "Some notes",
          "Internal text", "11/23/97 22:00:00", "marty",
          "Working", "Commit title", "Commit notes", "1/1/1999 8:00:00",
          3600, false, true, "x_close_int1", 1, "x_close_int2", 456,
          "x_summary2", "More text", "", "", "x_other_date", "1/1/99");

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.log_case_note("2", "Manager Note", "Some notes", _
          "Internal text", "11/23/97 22:00:00", "marty", _
          "Working", "Commit title", "Commit notes", "1/1/1999 8:00:00", _
          3600, False, True, "x_close_int1", 1, "x_close_int2", 456, _
          "x_summary2", "More text", "", "", "x_other_date", "1/1/99")

List version:

JavaScript:

var fld_list  = Server.CreateObject("FCFL.FCList");
var type_list = Server.CreateObject("FCFL.FCList");
var val_list  = Server.CreateObject("FCFL.FCList");

fld_list.AppendItem("x_close_int1");
type_list.AppendItem("Long");
val_list.AppendItem ("1");

fld_list.AppendItem("x_close_int2");
type_list.AppendItem("Long");
val_list.AppendItem ("456");

fld_list.AppendItem("x_summary2");
type_list.AppendItem("String");
val_list.AppendItem("More text");

fld_list.AppendItem("x_other_date");
type_list.AppendItem("Date");
val_list.AppendItem("1/1/99");

var ret_int = fccs.log_case_note_list("2", "Manager Note", "Some notes",
          "Internal text", "11/23/97 22:00:00", "marty",
          "Working", "Commit title", "Commit notes", "1/1/1999 8:00:00",
          3600, false, true, fld_list, type_list, val_list);

Visual Basic:

Dim ret_int As Integer
Dim fld_list    As New List
Dim type_list   As New List
Dim val_list    As New List

fld_list.AppendItem "x_close_int1"
type_list.AppendItem "Long"
val_list.AppendItem Trim(Str$(1))

fld_list.AppendItem "x_close_int2"
type_list.AppendItem "Long"
val_list.AppendItem Trim(Str$(456))

fld_list.AppendItem "x_summary2"
type_list.AppendItem "String"
val_list.AppendItem "More text"

fld_list.AppendItem "x_other_date"
type_list.AppendItem "Date"
val_list.AppendItem "1/1/99"

ret_int = fccs.log_case_note_list("2", "Manager Note", "Some notes", _
          "Internal text", "11/23/97 22:00:00", "marty", _
          "Working", "Commit title", "Commit notes", "1/1/1999 8:00:00", _
          3600, False, True, fld_list, type_list, val_list)


log_case_phone | fcSDK Documentation

log_case_phone

log_case_phone_list

Public Function log_case_phone(ByVal case_id As String, _
                ByVal cont_first As String, ByVal cont_last As String, _
                ByVal cont_phone As String, ByVal action_type As String, _
                ByVal note_str As String, ByVal int_use As String, _
                ByVal log_date As String, ByVal log_end_date As String, _
                ByVal user_name As String, ByVal new_stat As String, _
                ByVal cmit_title As String, ByVal cmit_notes As String, _
                ByVal cmit_due As String, ByVal cmit_prior As Long, _
                ByVal cmit_to As Boolean, ByVal gen_time_bombs As Boolean, _
                ByVal int_fld1 As String, ByVal int_val1 As Long, _
                ByVal int_fld2 As String, ByVal int_val2 As Long, _
                ByVal str_fld1 As String, ByVal str_val1 As String, _
                ByVal str_fld2 As String, ByVal str_val2 As String, _
                ByVal date_fld1 As String, ByVal date_val1 As String) As Integer

Public Function log_case_phone_list(ByVal case_id As String, _
                ByVal cont_first As String, ByVal cont_last As String, _
                ByVal cont_phone As String, ByVal action_type As String, _
                ByVal note_str As String, ByVal int_use As String, _
                ByVal log_date As String, ByVal log_end_date As String, _
                ByVal user_name As String, ByVal new_stat As String, _
                ByVal cmit_title As String, ByVal cmit_notes As String, _
                ByVal cmit_due As String, ByVal cmit_prior As Long, _
                ByVal cmit_to As Boolean, ByVal gen_time_bombs As Boolean, _
                Optional fld_list As Variant, Optional type_list As Variant, _
                Optional val_list As Variant) As Integer

Description

These APIs are used to create a phone log against a case. The APIs allow for the assigning of notes and internal use only text. An action type is also specified. The action type is usually used to distinguish between incoming and outgoing calls. The contact for the phone call is also specified, as is the phone call ending time (for length of call calculations). A new case status can be set with this API. Additional fields can also be set as well as a time bomb (for the phone log), which allows notifications to be generated based on the event.

Optionally, you can also set a commitment with the note log. If you wish to set a commitment, you MUST set the commitment due date (cmit_due) and the commitement title (cmit_title). The commitment title usually comes from the user-defined list "COMMITMENT", but it does not have to for this API. Any string is acceptable. The other commitment fields are optional. You can add notes to the commitement , and a prior warning. Also, you must set if the commitment is to the contact or by the contact. The contact for the case is always used for the commitment contact.

The objid of the created log is returned in the FCCS object variable ret_objid.

The objid of the commitment log record is returned in the FCCS object variable ret_objid2.

The objid of the status change record is returned in the FCCS object variable ret_objid3.

Parameters

Parameter Name | Required? | Description
case_id | Yes | The case to create the log for
cont_first | Yes | Phone call contact first name
cont_last | Yes | Phone call contact last name
cont_phone | Yes | Phone call contact phone number
action_type | No | The phone log action type code value. If left blank, default code is used
notes | No | The phone log text
int_use | No | Internal use only information
log_date | No | The date the log was created. If left blank, the current time is used
log_end_date | No | The date/time of the end of the phone call. If left blank, the log_date is used (i.e. a zero length phone call)
user_name | No | The user who created the log. If left blank, the current user performs the logging
new_stat | No | New status for the case. If blank (""), no status change is performed
cmit_title | No | Title of the commitment. If blank, no commitment is generated
cmit_notes | No | If generating a commitment, optional notes for the commitment (max length of 255)
cmit_due | No | When is the commitment due. If blank, no commitment is generated
cmit_prior | No | How long (in seconds) before the commitment is due should a warning business rule notification be fired. If set to 0, no warning is generated
cmit_to | Yes | Is the commitment made to the customer (=True), or by the customer (=False). If no commitment is to be generated, this value is ignored
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules).
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | End of phone call is before start of call
-2 | Cannot find the specified case
-3 | Cannot find the specified contact
-4 | Cannot find the specified user
-5 | Cannot find the phone log action type string
-6 | Cannot find the PHONE LOG activity string
-7 | Cannot find employee record for specified user
-8 | The supplied status is invalid for the current condition
-9 | A commitment is to be created, but the title is blank
-10 | The prior warning is negative
-11 | The commitment due date is before the log creation date
-12 | Cannot find the COMMIT activity string
-13 | Could not find the com_tmplte for WARNING
-14 | Could not find the com_tmplte for COMMITMENT

Examples

Create a phone log for case number 'C154'. The call was made with Bill Clinton. Set the notes for the log, and no other information. Generate a time bomb.

Field version:

JavaScript:

var ret_int = fccs.log_case_phone("C154", "Bill", "Clinton", "555-555-1234",
              "", "Some notes", "", "", "", "", "", "", "", "", 0, true, true,
              "", 0, "", 0, "", "", "", "", "", "");

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.log_case_phone_list("C154", "Bill", "Clinton", _
              "555-555-1234", "", "Some notes", "", "", "", "", _
              "", "", "", "", 0, True, True, _
              "", 0, "", 0, "", "", "", "", "", "")

List version:

JavaScript:

var ret_int = fccs.log_case_phone_list("C154", "Bill", "Clinton",
              "555-555-1234", "", "Some notes", "", "", "", "",
              "", "", "", "", 0, true, true);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.log_case_phone("C154", "Bill", "Clinton", "555-555-1234", _
              "", "Some notes", "", "", "", "", "", "", "", "", 0, True, True)

Create a 3 minute phone log made by Bill Clinton for case number '2'. Set action code of 'Incoming call', some note text, and internal use only text. Have the note logged by marty on November 23, 1997 at 10PM. Change the status to "Working". Also, create a commitment for January 1, 1999 at 8:00AM, with a title, notes, and a prior warning of 1 hour (with the commitment being made by the contact). Generate some additional fields, but do not generate a time bomb.

Field version:

JavaScript:

var ret_int = fccs.log_case_phone("2", "Bill", "Clinton", "555-555-1234",
              "Incoming call", "Some notes", "Internal notes",
              "11/23/97 22:00:00", "11/23/97 22:03:00", "marty",
              "Working", "Commit title", "Commit notes", "1/1/1999 8:00:00",
              3600, false, true, "x_close_int1", 1, "x_close_int2", 456,
              "x_summary2", "More text", "", "", "x_other_date", "1/1/99");

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.log_case_phone("2", "Bill", "Clinton", "555-555-1234", _
              "Incoming call", "Some notes", "Internal notes", _
              "11/23/97 22:00:00", "11/23/97 22:03:00", "marty", _
              "Working", "Commit title", "Commit notes", "1/1/1999 8:00:00", _
              3600, False, True, "x_close_int1", 1, "x_close_int2", 456, _
              "x_summary2", "More text", "", "", "x_other_date", "1/1/99")

List version:

JavaScript:

var fld_list  = Server.CreateObject("FCFL.FCList");
var type_list = Server.CreateObject("FCFL.FCList");
var val_list  = Server.CreateObject("FCFL.FCList");

fld_list.AppendItem("x_close_int1");
type_list.AppendItem("Long");
val_list.AppendItem ("1");

fld_list.AppendItem("x_close_int2");
type_list.AppendItem("Long");
val_list.AppendItem ("456");

fld_list.AppendItem("x_summary2");
type_list.AppendItem("String");
val_list.AppendItem("More text");

fld_list.AppendItem("x_other_date");
type_list.AppendItem("Date");
val_list.AppendItem("1/1/99");

var ret_int = fccs.log_case_phone_list("2", "Bill", "Clinton", "555-555-1234",
              "Incoming call", "Some notes", "Internal notes",
              "11/23/97 22:00:00", "11/23/97 22:03:00", "marty", "Working",
              "Commit title", "Commit notes", "1/1/1999 8:00:00",
              3600, false, true, fld_list, type_list, val_list);

Visual Basic:

Dim ret_int As Integer
Dim fld_list    As New List
Dim type_list   As New List
Dim val_list    As New List

fld_list.AppendItem "x_close_int1"
type_list.AppendItem "Long"
val_list.AppendItem Trim(Str$(1))

fld_list.AppendItem "x_close_int2"
type_list.AppendItem "Long"
val_list.AppendItem Trim(Str$(456))

fld_list.AppendItem "x_summary2"
type_list.AppendItem "String"
val_list.AppendItem "More text"

fld_list.AppendItem "x_other_date"
type_list.AppendItem "Date"
val_list.AppendItem "1/1/99"

ret_int = fccs.log_case_phone_list("2", "Bill", "Clinton", "555-555-1234", _
              "Incoming call", "Some notes", "Internal notes", _
              "11/23/97 22:00:00", "11/23/97 22:03:00", "marty", _
              "Working", "Commit title", "Commit notes", "1/1/1999 8:00:00", _
              3600, False, True, fld_list, type_list, val_list)


log_case_resrch | fcSDK Documentation

log_case_resrch

log_case_ resrch_list

Public Function log_case_resrch(ByVal case_id As String, _
                    ByVal action_type As String, ByVal note_str As String, _
                    ByVal int_use As String, ByVal log_date As String, _
                    ByVal research_time As Long, ByVal user_name As String, _
                    ByVal new_stat As String, ByVal cmit_title As String, _
                    ByVal cmit_notes As String, ByVal cmit_due As String, _
                    ByVal cmit_prior As Long, ByVal cmit_to As Boolean, _
                    ByVal gen_time_bombs As Boolean, ByVal int_fld1 As String, _
                    ByVal int_val1 As Long, ByVal int_fld2 As String, _
                    ByVal int_val2 As Long, ByVal str_fld1 As String, _
                    ByVal str_val1 As String, ByVal str_fld2 As String, _
                    ByVal str_val2 As String, ByVal date_fld1 As String, _
                    ByVal date_val1 As String) As Integer

Public Function log_case_resrch_list(ByVal case_id As String, _
                   ByVal action_type As String, ByVal note_str As String, _
                   ByVal int_use As String, ByVal log_date As String, _
                   ByVal research_time As Long, ByVal user_name As String, _
                   ByVal new_stat As String, ByVal cmit_title As String, _
                   ByVal cmit_notes As String, ByVal cmit_due As String, _
                   ByVal cmit_prior As Long, ByVal cmit_to As Boolean, _
                   ByVal gen_time_bombs As Boolean, _
                   Optional fld_list As Variant, Optional type_list As Variant, _
                   Optional val_list As Variant) As Integer

Description

These APIs are used to create a research log against a case. The APIs allow for the assigning of notes, internal use only text, and an action type. The research time (in seconds) is specified. For example, a 5 minute log would be 300 seconds. A new case status can be set with this API. Additional fields can also be set as well as a time bomb (for the phone log), which allows notifications to be generated based on the event.

Optionally, you can also set a commitment with the note log. If you wish to set a commitment, you MUST set the commitment due date (cmit_due) and the commitement title (cmit_title). The commitment title usually comes from the user-defined list "COMMITMENT", but it does not have to for this API. Any string is acceptable. The other commitment fields are optional. You can add notes to the commitement , and a prior warning. Also, you must set if the commitment is to the contact or by the contact. The contact for the case is always used for the commitment contact.

The objid of the created log is returned in the FCCS object variable ret_objid.

The objid of the commitment log record is returned in the FCCS object variable ret_objid2.

The objid of the status change record is returned in the FCCS object variable ret_objid3.

Parameters

Parameter Name | Required? | Description
case_id | Yes | The case to create the log for
action_type | No | The research log action type code value. If left blank, default code is used
notes | No | The research log text
int_use | No | Internal use only information
log_date | No | The date the log was created. If left blank, the current time is used
research_time | Yes | The length of the research time in seconds
user_name | No | The user who created the log. If left blank, the current user performs the logging
new_stat | No | New status for the case. If blank (""), no status change is performed
cmit_title | No | Title of the commitment. If blank, no commitment is generated
cmit_notes | No | If generating a commitment, optional notes for the commitment (max length of 255)
cmit_due | No | When is the commitment due. If blank, no commitment is generated
cmit_prior | No | How long (in seconds) before the commitment is due should a warning business rule notification be fired. If set to 0, no warning is generated
cmit_to | Yes | Is the commitment made to the customer (=True), or by the customer (=False). If no commitment is to be generated, this value is ignored
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules).
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list
log_objid | Output | This field returns the objid of the newly created log object

Returns

Value | Meaning
0 | No errors
-1 | Research log time is negative
-2 | Cannot find the specified case
-3 | Cannot find the specified user
-4 | Cannot find the RESEARCH LOG activity string
-5 | Cannot find the research log action type string
-6 | Cannot find the employee record for the specified user
-7 | The supplied status is invalid for the current condition
-8 | A commitment is to be created, but the title is blank
-9 | The prior warning is negative
-10 | The commitment due date is before the log creation date
-11 | Cannot find the COMMIT activity string
-12 | Could not find the com_tmplte for WARNING
-13 | Could not find the com_tmplte for COMMITMENT

Examples

Create a research log of 4 minutes for case number 'C154'. Set the notes for the log, and no other information. Generate a time bomb.

Field version:

JavaScript:

var ret_int = fccs.log_case_resrch("C154", "", "Some notes", "",
              "", 240, "", "", "", "", "", 0, true, true,
              "", 0, "", 0, "", "", "", "", "", "");

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.log_case_resrch("C154", "", "Some notes", "", _
              "", 240, "", "", "", "", "", 0, True, True, _
              "", 0, "", 0, "", "", "", "", "", "")

List version:

JavaScript:

var ret_int = fccs.log_case_resrch_list("C154", "", "Some notes", "",
              "", 240, "", "", "", "", "", 0, true, true);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.log_case_resrch_list("C154", "", "Some notes", "", _
              "", 240, "", "", "", "", "", 0, True, True)

Create a 3 minute research log for case number '2'. Set action code of 'Engineering Research', some note text, and internal use only text. Have the note logged by marty on November 23, 1997 at 10PM. Change the status to "Working". Also, create a commitment for January 1, 1999 at 8:00AM, with a title, notes, and a prior warning of 1 hour (with the commitment being made by the contact). Generate some additional fields, but do not generate a time bomb.

Field version:

JavaScript:

var ret_int = fccs.log_case_resrch("2", "Engineering Research",
             "Some notes", "Internal use", "11/23/97 22:00:00", 180,
             "marty", "Working", "Commit title", "Commit notes",
             "1/1/1999 8:00:00", 3600, false, true,
             "x_close_int1", 1, "x_close_int2", 456,
             "x_summary2", "More text", "", "", "x_other_date", "1/1/99");

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.log_case_resrch("2", "Engineering Research", "Some notes", _
             "Internal use", "11/23/97 22:00:00", 180, "marty", _
             "Working", "Commit title", "Commit notes", "1/1/1999 8:00:00", _
             3600, False, True, "x_close_int1", 1, "x_close_int2", 456, _
             "x_summary2", "More text", "", "", "x_other_date", "1/1/99")

List version:

JavaScript:

var fld_list  = Server.CreateObject("FCFL.FCList");
var type_list = Server.CreateObject("FCFL.FCList");
var val_list  = Server.CreateObject("FCFL.FCList");

fld_list.AppendItem("x_close_int1");
type_list.AppendItem("Long");
val_list.AppendItem ("1");

fld_list.AppendItem("x_close_int2");
type_list.AppendItem("Long");
val_list.AppendItem ("456");

fld_list.AppendItem("x_summary2");
type_list.AppendItem("String");
val_list.AppendItem("More text");

fld_list.AppendItem("x_other_date");
type_list.AppendItem("Date");
val_list.AppendItem("1/1/99");

var ret_int = fccs.log_case_resrch_list("2", "Engineering Research",
             "Some notes", "Internal use", "11/23/97 22:00:00", 180,
             "marty", "Working", "Commit title", "Commit notes",
             "1/1/1999 8:00:00", 3600, false, true, fld_list,
             type_list, val_list);

Visual Basic:

Dim ret_int As Integer
Dim fld_list    As New List
Dim type_list   As New List
Dim val_list    As New List

fld_list.AppendItem "x_close_int1"
type_list.AppendItem "Long"
val_list.AppendItem Trim(Str$(1))

fld_list.AppendItem "x_close_int2"
type_list.AppendItem "Long"
val_list.AppendItem Trim(Str$(456))

fld_list.AppendItem "x_summary2"
type_list.AppendItem "String"
val_list.AppendItem "More text"

fld_list.AppendItem "x_other_date"
type_list.AppendItem "Date"
val_list.AppendItem "1/1/99"

ret_int = fccs.log_case_resrch_list("2", "Engineering Research", _
             "Some notes", "Internal use", "11/23/97 22:00:00", 180, _
             "marty", "Working", "Commit title", "Commit notes", _
             "1/1/1999 8:00:00", 3600, False, True, fld_list, _
             type_list, val_list)


log_subcase_commit | fcSDK Documentation

log_subcase_commit

log_subcase_commit_list

Public Function log_subcase_commit(ByVal subcase_id As String, _
                ByVal the_title As String, ByVal action_type As String, _
                ByVal log_date As String, ByVal commit_date As String, _
                ByVal prior_warn As Long, ByVal made_to As Boolean, _
                ByVal cont_first As String, ByVal cont_last As String, _
                ByVal cont_phone As String, ByVal note_str As String, _
                ByVal user_name As String, ByVal gen_time_bombs As Boolean, _
                ByVal generate_commit_email As Boolean, _
                ByVal int_fld1 As String, _
                ByVal int_val1 As Long, ByVal int_fld2 As String, _
                ByVal int_val2 As Long, ByVal str_fld1 As String, _
                ByVal str_val1 As String, ByVal str_fld2 As String, _
                ByVal str_val2 As String, ByVal date_fld1 As String, _
                ByVal date_val1 As String) As Integer

Public Function log_subcase_commit_list(ByVal subcase_id As String, _
                    ByVal the_title As String, ByVal action_type As String, _
                    ByVal log_date As String, ByVal commit_date As String, _
                    ByVal prior_warn As Long, ByVal made_to As Boolean, _
                    ByVal cont_first As String, ByVal cont_last As String, _
                    ByVal cont_phone As String, ByVal note_str As String, _
                    ByVal user_name As String, ByVal gen_time_bombs As Boolean, _
                    ByVal generate_commit_email As Boolean, _
                    Optional fld_list As Variant, _
                    Optional type_list As Variant, _
                    Optional val_list As Variant) As Integer

Description

These APIs are used to create a commitment against a subcase. The APIs allow for the assigning of a title and action type. The date the commitment is logged can be set, as well as the commitment date, and prior warning. A flag can be set so that the commitment can be made to or by a contact, and the contact can be set. The user who logs the commitment can be set, and additional fields can also be set. Finally, a time bomb (for the commitment) can be generated, as can the email reminders. This last item has been added for consistency with Clarify. Base Clarify sends two email commitments each time a commitment is logged. The first notifies the owner when the commitment expires, and the second notifies the owner when the prior warning (if any) expires. These can only be email commitments, but the delivery mechanism can be modified by changing the com_tmplte record. See Clarify for more details. These APIs allow the programmer to turn off those extra notifications, if desired. The objid of the log created is returned.

The objid of the created log is returned in the FCCS object variable ret_objid.

Parameters

Parameter Name | Required? | Description
subcase_id | Yes | The subcase to close
the_title | Yes | The title of the commitment
action_type | No | The commitment log action type code value
log_date | No | The date the log was created. If left blank, the current time is used
commit_date | Yes | When the commitment is due. If left blank, set to the log date
prior_warn | Yes | How long to warn the owner before the commitment expires. This is recorded in seconds (1 hour = 3600 seconds). If set to 0, no prior warning is given
made_to | Yes | Is the commitment to the contact (True), or by the contact (False)
cont_first | Yes | First name of the contact
cont_last | Yes | Last name of the contact
cont_phone | Yes | Phone number of the contact
note_str | No | Additional text notes for the log
user_name | No | The user who created the log. If left blank, the current user performs the logging
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules).
generate_commit_email | Yes | Should the API add the email notifications for the commitment time and prior warning time?
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | No title specified
-2 | Prior warning is negative (warning after the commitment expires)
-3 | The commitment date is before the log date
-4 | Cannot find the specified subcase
-5 | Specified user is not found
-6 | Could not find gbst_elm string for COMMIT
-7 | Could not find the specified log action type
-8 | Could not find the specified contact
-9 | Could not find the com_tmplte for WARNING
-10 | Could not find the com_tmplte for COMMITMENT
-11 | Cannot find the employee record for the specified user

Examples

Create a log for subcase number 'C154-1'. Set a title and use the default action code, log date, and user. Make the commitment to "Bill Clinton", and make the commitment expire on the default (log) date. Make no prior warning, have no notes, and set no additional fields. Generate a time bomb, and the commitement emails.

Field version:

JavaScript:

var ret_int = fccs.log_subcase_commit("C154-1", "A title", "", "", "",
          0, true, "Bill", "Clinton", "555-555-1234", "", "", true, true,
          "", 0, "", 0, "", "", "", "", "", "");

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.log_subcase_commit("C154-1", "A title", "", "", "", 0, True, _
          "Bill", "Clinton", "555-555-1234", "", "", True, True, _
          "", 0, "", 0, "", "", "", "", "", "")

List version:

JavaScript:

var ret_int = fccs.log_subcase_commit_list("C154-1", "A title", "", "",
          "", 0, true, "Bill", "Clinton", "555-555-1234", "",
          "", true, true);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.log_subcase_commit_list("C154-1", "A title", "", "", "", 0, _
          True, "Bill", "Clinton", "555-555-1234", "", "", True, True)

Create a log for subcase number '2-1'. Set a title, action code, log date, and user. Make the commitment by "Bill Clinton", and make the commitment expire on '1/1/99'. Make a prior warning for two hours, have some notes, and additional fields. Generate neither a time bomb, nor the commitement emails.

Field version:

JavaScript:

var ret_int = fccs.log_subcase_commit("2-2", "A title", "External Commitment",
          "11/23/97 22:00:00", "1/1/99", 7200, false,
          "Bill", "Clinton", "555-555-1234", "Some notes", "marty",
          false, false, "x_close_int1", 1, "x_close_int2", 456,
          "x_summary2", "More text", "", "",
          "x_other_date", "1/1/99")

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.log_subcase_commit("2-2", "A title", "External Commitment", _
          "11/23/97 22:00:00", "1/1/99", 7200, False, _
          "Bill", "Clinton", "555-555-1234", "Some notes", "marty", _
          False, False, "x_close_int1", 1, "x_close_int2", 456, _
          "x_summary2", "More text", "", "", _
          "x_other_date", "1/1/99")

List version:

JavaScript:

var fld_list  = Server.CreateObject("FCFL.FCList");
var type_list = Server.CreateObject("FCFL.FCList");
var val_list  = Server.CreateObject("FCFL.FCList");

fld_list.AppendItem("x_close_int1");
type_list.AppendItem("Long");
val_list.AppendItem ("1");

fld_list.AppendItem("x_close_int2");
type_list.AppendItem("Long");
val_list.AppendItem ("456");

fld_list.AppendItem("x_summary2");
type_list.AppendItem("String");
val_list.AppendItem("More text");

fld_list.AppendItem("x_other_date");
type_list.AppendItem("Date");
val_list.AppendItem("1/1/99");

var ret_int = fccs.log_subcase_commit_list("2-2", "A title",
          "External Commitment", "11/23/97 22:00:00", "1/1/99", 7200, false,
          "Bill", "Clinton", "555-555-1234", "Some notes", "marty",
          false, false, fld_list, type_list, val_list);

Visual Basic:

Dim ret_int As Integer
Dim fld_list    As New FCList
Dim type_list   As New FCList
Dim val_list    As New FCList

fld_list.AppendItem "x_close_int1"
type_list.AppendItem "Long"
val_list.AppendItem Trim(Str$(1))

fld_list.AppendItem "x_close_int2"
type_list.AppendItem "Long"
val_list.AppendItem Trim(Str$(456))

fld_list.AppendItem "x_summary2"
type_list.AppendItem "String"
val_list.AppendItem "More text"

fld_list.AppendItem "x_other_date"
type_list.AppendItem "Date"
val_list.AppendItem "1/1/99"

ret_int = fccs.log_subcase_commit_list("2-2", "A title", _
          "External Commitment", _
          "11/23/97 22:00:00", "1/1/99", 7200, False, _
          "Bill", "Clinton", "555-555-1234", "Some notes", "marty", _
          False, False, fld_list, type_list, val_list)


log_subcase_email | fcSDK Documentation

log_subcase_email

log_subcase_ email_list

Public Function log_subcase_email(ByVal subcase_id As String, _
                    ByVal action_type As String, _
                    ByVal log_date As String, ByVal message As String, _
                    ByVal recipient As String, ByVal cc_list As String, _
                    ByVal user_name As String, ByVal new_stat As String, _
                    ByVal cmit_title As String, ByVal cmit_notes As String, _
                    ByVal cmit_due As String, ByVal cmit_prior As Long, _
                    ByVal cmit_to As Boolean, ByVal cmit_action_type As String, _
                    ByVal cmit_contact_objid As Long, _
                              ByVal gen_time_bombs As Boolean, _
                    ByVal send_email As Boolean, _
                    ByVal int_fld1 As String, ByVal int_val1 As Long, _
                    ByVal int_fld2 As String, ByVal int_val2 As Long, _
                    ByVal str_fld1 As String, ByVal str_val1 As String, _
                    ByVal str_fld2 As String, ByVal str_val2 As String, _
                    ByVal date_fld1 As String, _
                    ByVal date_val1 As String) As Integer

Public Function log_subcase_email_list(ByVal subcase_id As String, _
                    ByVal action_type As String, _
                    ByVal log_date As String, ByVal message As String, _
                    ByVal recipient As String, ByVal cc_list As String, _
                    ByVal user_name As String, ByVal new_stat As String, _
                    ByVal cmit_title As String, ByVal cmit_notes As String, _
                    ByVal cmit_due As String, ByVal cmit_prior As Long, _
                    ByVal cmit_to As Boolean, ByVal cmit_action_type As String, _
                    ByVal cmit_contact_objid As Long, _
                    ByVal gen_time_bombs As Boolean, _
                    ByVal send_email As Boolean, Optional fld_list As Variant, _
                    Optional type_list As Variant, _
                    Optional val_list As Variant) As Integer

Description

These APIs are used to create an email log against a subcase. The APIs allow for the assigning of the email message, the email recipients, a cc list, and an action type. A new subcase status can be set with this API. Additional fields can also be set as well as a time bomb (for the phone log), which allows notifications to be generated based on the event. You may also specify the user who created/sent the email.

You have the option, with these APIs, of sending the email yourself, or of having Clarify send it for you. If you set the send_email argument to True, the API will add a row to Clarify that will cause the rule manager (which must be running) to send the email. This is just like logging it via the Log Email GUI in Clarify. The downside of this is that rulemanager sends the email from the server, which means that the recipient(s) cannot hit "reply", and have the email come back to you.

If you want to send the email yourself, just set the argument to False. In this case, the API logs the email, but does not send it.

Optionally, you can also set a commitment with the note log. If you wish to set a commitment, you MUST set the commitment due date (cmit_due) and the commitement title (cmit_title). The commitment title usually comes from the user-defined list "COMMITMENT", but it does not have to for this API. Any string is acceptable. The other commitment fields are optional. You can add notes to the commitement , and a prior warning. Also, you must set if the commitment is to the contact or by the contact. The contact for the case is always used for the commitment contact.

The objid of the created log is returned in the FCCS object variable ret_objid.

The objid of the commitment log record is returned in the FCCS object variable ret_objid2.

The objid of the status change record is returned in the FCCS object variable ret_objid3.

Parameters

Parameter Name | Required? | Description
subcase_id | Yes | The subcase to create the log for
action_type | No | The email log action type code value. If left blank, default code is used
log_date | No | The date the log was created. If left blank, the current time is used
message | No | The email message
recipient | No | List of email addresses the email is sent to
cc_list | No | List of cc recipients for the email
user_name | No | The user who created the log. If left blank, the current user performs the logging
new_stat | No | New status for the subcase. If blank (""), no status change is performed
cmit_title | No | Title of the commitment. If blank, no commitment is generated
cmit_notes | No | If generating a commitment, optional notes for the commitment (max length of 255)
cmit_due | No | When is the commitment due. If blank, no commitment is generated
cmit_prior | No | How long (in seconds) before the commitment is due should a warning business rule notification be fired. If set to 0, no warning is generated
cmit_to | Yes | Is the commitment made to the customer (=True), or by the customer (=False). If no commitment is to be generated, this value is ignored
cmit_action_type | No | The commitment log action type value. If left blank, default code is used
cmit_contact_objid | No | The objid of the contact for the commitment. If set to 0, the contact for the case is used.
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules).
send_email | Yes | Should a time_bomb be added to Clarify that will cause rule manager (if running) to send the email
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified subcase
-2 | Cannot find the specified user
-3 | Cannot find the EMAIL LOG activity string
-4 | Cannot find the employee record for the specified user
-5 | Cannot find the COM TEMPLATE for sending email
-6 | The specified action type is not valid
-7 | The supplied status is invalid for the current condition
-8 | A commitment is to be created, but the title is blank
-9 | The prior warning is negative
-10 | The commitment due date is before the log creation date
-11 | Cannot find the COMMIT activity string
-12 | Could not find the com_tmplte for WARNING
-13 | Could not find the com_tmplte for COMMITMENT
-14 | Cannot find the specified commitment log action type
-15 | Cannot find the specified contact

Examples

Create an email to send to 'joe@fred.com' for subcase C154-1. Set the message for the log, and no other information. Do not send the email, just log it. Generate a time bomb.

Field version:

JavaScript:

   var ret_int = fccs.log_subcase_email("C154-1", "", "", "Email message",
      "joe@fred.com", "", "", "", "", "", "", 0, true, "", 0,
      true, false, "", 0, "", 0, "", "", "", "", "", "");

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.log_subcase_email("C154-1", "", "", "Email message", _
              "joe@fred.com", "", "", "", "", "", "", 0, True, "", 0,
              True, False, "", 0, "", 0, "", "", "", "", "", "")

List version:

JavaScript:

var ret_int = fccs.log_subcase_email_list("C154-1", "", "", "Email message",
         "joe@fred.com", "", "", "", "", "", "", 0, true, "", 0, true, false);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.log_subcase_email_list("C154-1", "", "", "Email message", _
      "joe@fred.com", "", "", "", "", "", "", 0, True, "", 0, True, False)

Send an email for subcase '2-2' with a recieipient, and a list of "cc" recipients. Send as internal email. Send from "sam", on November 23, 1997 at 10PM. Change the status to "Working". Also, create a commitment for January 1, 1999 at 8:00AM, with a title, notes, and a prior warning of 1 hour (with the commitment being made by the contact). Generate some additional fields, but do not generate a time bomb. Send the email.

Field version:

JavaScript:

var ret_int = fccs.log_subcase_email("2-2", "Internal Email",
      "11/23/97 22:00:00", "Email message", "joe@fred.com",
      "mary@fred.com, cathy@fred.com", "sam", "Working",
      "Commit title", "Commit notes", "1/1/1999 8:00:00",
      3600, false, "", 0, false, true,
      "x_close_int1", 1, "x_close_int2", 456,
      "x_summary2", "More text", "", "", "x_other_date", "1/1/99");

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.log_subcase_email("2-2", "Internal Email", _
           "11/23/97 22:00:00", "Email message", "joe@fred.com", _
           "mary@fred.com, cathy@fred.com", "sam", "Working", _
           "Commit title", "Commit notes", "1/1/1999 8:00:00", _
           3600, False, "", 0, False, True, _
           "x_close_int1", 1, "x_close_int2", 456, _
           "x_summary2", "More text", "", "", "x_other_date", "1/1/99")

List version:

JavaScript:

var fld_list  = Server.CreateObject("FCFL.FCList");
var type_list = Server.CreateObject("FCFL.FCList");
var val_list  = Server.CreateObject("FCFL.FCList");

fld_list.AppendItem("x_close_int1");
type_list.AppendItem("Long");
val_list.AppendItem ("1");

fld_list.AppendItem("x_close_int2");
type_list.AppendItem("Long");
val_list.AppendItem ("456");

fld_list.AppendItem("x_summary2");
type_list.AppendItem("String");
val_list.AppendItem("More text");

fld_list.AppendItem("x_other_date");
type_list.AppendItem("Date");
val_list.AppendItem("1/1/99");

var ret_int = fccs.log_subcase_email("2-2", "Internal Email",
           "11/23/97 22:00:00", "Email message", "joe@fred.com",
           "mary@fred.com, cathy@fred.com", "sam", "Working",
           "Commit title", "Commit notes", "1/1/1999 8:00:00",
           3600, false, "", 0, false, true, fld_list, type_list, val_list);

Visual Basic:

Dim ret_int As Integer
Dim fld_list    As New List
Dim type_list   As New List
Dim val_list    As New List

fld_list.AppendItem "x_close_int1"
type_list.AppendItem "Long"
val_list.AppendItem Trim(Str$(1))

fld_list.AppendItem "x_close_int2"
type_list.AppendItem "Long"
val_list.AppendItem Trim(Str$(456))

fld_list.AppendItem "x_summary2"
type_list.AppendItem "String"
val_list.AppendItem "More text"

fld_list.AppendItem "x_other_date"
type_list.AppendItem "Date"
val_list.AppendItem "1/1/99"

ret_int = fccs.log_subcase_email("2-2", "Internal Email", _
          "11/23/97 22:00:00", "Email message", "joe@fred.com", _
          "mary@fred.com, cathy@fred.com", "sam", "Working", _
          "Commit title", "Commit notes", "1/1/1999 8:00:00", _
          3600, False, "", 0, False, True, fld_list, type_list, val_list)


log_subcase_note | fcSDK Documentation

log_subcase_note

log_subcase_note_list

Public Function log_subcase_note(ByVal subcase_id As String, _
                    ByVal action_type As String, ByVal note_str As String, _
                    ByVal int_use As String, ByVal log_date As String, _
                    ByVal user_name As String, ByVal new_stat As String, _
                    ByVal cmit_title As String, ByVal cmit_notes As String, _
                    ByVal cmit_due As String, ByVal cmit_prior As Long, _
                    ByVal cmit_to As Boolean, ByVal gen_time_bombs As Boolean, _
                    ByVal int_fld1 As String, ByVal int_val1 As Long, _
                    ByVal int_fld2 As String, ByVal int_val2 As Long, _
                    ByVal str_fld1 As String, ByVal str_val1 As String, _
                    ByVal str_fld2 As String, ByVal str_val2 As String, _
                    ByVal date_fld1 As String, _
                    ByVal date_val1 As String) As Integer

Public Function log_subcase_note_list(ByVal subcase_id As String, _
                    ByVal action_type As String, ByVal note_str As String, _
                    ByVal int_use As String, ByVal log_date As String, _
                    ByVal user_name As String, ByVal new_stat As String, _
                    ByVal cmit_title As String, ByVal cmit_notes As String, _
                    ByVal cmit_due As String, ByVal cmit_prior As Long, _
                    ByVal cmit_to As Boolean, ByVal gen_time_bombs As Boolean, _
                    Optional fld_list As Variant, _
                    Optional type_list As Variant, _
                    Optional val_list As Variant) As Integer

Description

These APIs are used to create a note log against a subcase. The APIs allow for the assigning of notes, internal use only text, and an action type. The date the note is logged can be set, as well as the user who logs the note. You may also specify a new status for the subcase. Additional fields can also be set as well as a time bomb (for the note log), which allows notifications to be generated based on the event.

Optionally, you can also set a commitment with the note log. If you wish to set a commitment, you MUST set the commitment due date (cmit_due) and the commitement title (cmit_title). The commitment title usually comes from the user-defined list "COMMITMENT", but it does not have to for this API. Any string is acceptable. The other commitment fields are optional. You can add notes to the commitement , and a prior warning. Also, you must set if the commitment is to the contact or by the contact. The contact for the case is always used for the commitment contact.

The objid of the created log is returned in the FCCS object variable ret_objid.

The objid of the commitment log record is returned in the FCCS object variable ret_objid2.

The objid of the status change record is returned in the FCCS object variable ret_objid3.

Parameters

Parameter Name | Required? | Description
subcase_id | Yes | The subcase to create the log for
action_type | No | The note log action type code value. If left blank, default code is used
notes | No | The note log text
int_use | No | Internal use only information
log_date | No | The date the log was created. If left blank, the current time is used
user_name | No | The user who created the log. If left blank, the current user performs the logging
new_stat | No | New status for the subcase. If blank (""), no status change is performed
cmit_title | No | Title of the commitment. If blank, no commitment is generated
cmit_notes | No | If generating a commitment, optional notes for the commitment (max length of 255)
cmit_due | No | When is the commitment due. If blank, no commitment is generated
cmit_prior | No | How long (in seconds) before the commitment is due should a warning business rule notification be fired. If set to 0, no warning is generated
cmit_to | Yes | Is the commitment made to the customer (=True), or by the customer (=False). If no commitment is to be generated, this value is ignored
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules).
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified case
-2 | Cannot find the specified user
-3 | Cannot find the NOTES activity string
-4 | Cannot find the notes log action type string
-5 | Cannot find employee record for specified user
-6 | The supplied status for the subcase is invalid for the current condition
-7 | A commitment is to be created, but the title is blank
-8 | The prior warning is negative
-9 | The commitment due date is before the log creation date
-10 | Cannot find the COMMIT activity string
-11 | Could not find the com_tmplte for WARNING
-12 | Could not find the com_tmplte for COMMITMENT

Examples

Create a note log for subcase number 'C154-1'. Set the notes for the log, and no other information. Generate a time bomb.

Field version:

JavaScript:

var ret_int = fccs.log_subcase_note("C154-1", "", "Some notes", "", "", "",
                        "", "", "", "", 0, true, true, "", 0, "", 0,
                        "", "", "", "", "", "");

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.log_subcase_note("C154-1", "", "Some notes", "", "", "", _
                        "", "", "", "", 0, True, True, "", 0, "", 0, _
                        "", "", "", "", "", "")

List version:

JavaScript:

var ret_int = fccs.log_subcase_note_list("C154-1", "", "Some notes", "",
                                 "", "", "", "", "", "", 0, true, true)

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.log_subcase_note_list("C154-1", "", "Some notes", "", "", "", _
                                     "", "", "", "", 0, True, True)

Create a note log for subcase number '2-2'. Set action code of 'Manager Note', some note text, and internal use only text. Have the note logged by marty on November 23, 1997 at 10PM. Change the status to "Working". Also, create a commitment for January 1, 1999 at 8:00AM, with a title, notes, and a prior warning of 1 hour (with the commitment being made by the contact). Generate some additional fields, but do not generate a time bomb.

Field version:

JavaScript:

var ret_int = fccs.log_subcase_note("2-2", "Manager Note", "Some notes",
          "Internal text", "11/23/97 22:00:00", "marty",
          "Working", "Commit title", "Commit notes", "1/1/1999 8:00:00",
          3600, false, true, "x_close_int1", 1, "x_close_int2", 456,
          "x_summary2", "More text", "", "", "x_other_date", "1/1/99");

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.log_subcase_note("2-2", "Manager Note", "Some notes", _
          "Internal text", "11/23/97 22:00:00", "marty", _
          "Working", "Commit title", "Commit notes", "1/1/1999 8:00:00", _
          3600, False, True, "x_close_int1", 1, "x_close_int2", 456, _
          "x_summary2", "More text", "", "", "x_other_date", "1/1/99")

List version:

JavaScript:

var fld_list  = Server.CreateObject("FCFL.FCList");
var type_list = Server.CreateObject("FCFL.FCList");
var val_list  = Server.CreateObject("FCFL.FCList");

fld_list.AppendItem("x_close_int1");
type_list.AppendItem("Long");
val_list.AppendItem ("1");

fld_list.AppendItem("x_close_int2");
type_list.AppendItem("Long");
val_list.AppendItem ("456");

fld_list.AppendItem("x_summary2");
type_list.AppendItem("String");
val_list.AppendItem("More text");

fld_list.AppendItem("x_other_date");
type_list.AppendItem("Date");
val_list.AppendItem("1/1/99");

var ret_int = fccs.log_subcase_note_list("2-2", "Manager Note", "Some notes",
          "Internal text", "11/23/97 22:00:00", "marty",
          "Working", "Commit title", "Commit notes", "1/1/1999 8:00:00",
          3600, false, true, fld_list, type_list, val_list);

Visual Basic:

Dim ret_int As Integer
Dim fld_list    As New List
Dim type_list   As New List
Dim val_list    As New List

fld_list.AppendItem "x_close_int1"
type_list.AppendItem "Long"
val_list.AppendItem Trim(Str$(1))

fld_list.AppendItem "x_close_int2"
type_list.AppendItem "Long"
val_list.AppendItem Trim(Str$(456))

fld_list.AppendItem "x_summary2"
type_list.AppendItem "String"
val_list.AppendItem "More text"

fld_list.AppendItem "x_other_date"
type_list.AppendItem "Date"
val_list.AppendItem "1/1/99"

ret_int = fccs.log_subcase_note_list("2-2", "Manager Note", "Some notes", _
          "Internal text", "11/23/97 22:00:00", "marty", _
          "Working", "Commit title", "Commit notes", "1/1/1999 8:00:00", _
          3600, False, True, fld_list, type_list, val_list)


log_subcase_phone | fcSDK Documentation

log_subcase_phone

log_subcase_phone_list

Public Function log_subcase_phone(ByVal subcase_id As String, _
                ByVal cont_first As String, ByVal cont_last As String, _
                ByVal cont_phone As String, ByVal action_type As String, _
                ByVal note_str As String, ByVal int_use As String, _
                ByVal log_date As String, ByVal log_end_date As String, _
                ByVal user_name As String, ByVal new_stat As String, _
                ByVal cmit_title As String, ByVal cmit_notes As String, _
                ByVal cmit_due As String, ByVal cmit_prior As Long, _
                ByVal cmit_to As Boolean, ByVal gen_time_bombs As Boolean, _
                ByVal int_fld1 As String, ByVal int_val1 As Long, _
                ByVal int_fld2 As String, ByVal int_val2 As Long, _
                ByVal str_fld1 As String, ByVal str_val1 As String, _
                ByVal str_fld2 As String, ByVal str_val2 As String, _
                ByVal date_fld1 As String, ByVal date_val1 As String) As Integer

Public Function log_subcase_phone_list(ByVal subcase_id As String, _
                ByVal cont_first As String, ByVal cont_last As String, _
                ByVal cont_phone As String, ByVal action_type As String, _
                ByVal note_str As String, ByVal int_use As String, _
                ByVal log_date As String, ByVal log_end_date As String, _
                ByVal user_name As String, ByVal new_stat As String, _
                ByVal cmit_title As String, ByVal cmit_notes As String, _
                ByVal cmit_due As String, ByVal cmit_prior As Long, _
                ByVal cmit_to As Boolean, ByVal gen_time_bombs As Boolean, _
                Optional fld_list As Variant, Optional type_list As Variant, _
                Optional val_list As Variant) As Integer

Description

These APIs are used to create a phone log against a subcase. The APIs allow for the assigning of notes and internal use only text. An action type is also specified. The action type is usually used to distinguish between incoming and outgoing calls. The contact for the phone call is also specified, as is the phone call ending time (for length of call calculations). A new status for the subcase can be set with this API. Additional fields can also be set as well as a time bomb (for the phone log), which allows notifications to be generated based on the event.

Optionally, you can also set a commitment with the note log. If you wish to set a commitment, you MUST set the commitment due date (cmit_due) and the commitement title (cmit_title). The commitment title usually comes from the user-defined list "COMMITMENT", but it does not have to for this API. Any string is acceptable. The other commitment fields are optional. You can add notes to the commitement , and a prior warning. Also, you must set if the commitment is to the contact or by the contact. The contact for the case is always used for the commitment contact.

The objid of the created log is returned in the FCCS object variable ret_objid.

The objid of the commitment log record is returned in the FCCS object variable ret_objid2.

The objid of the status change record is returned in the FCCS object variable ret_objid3.

Parameters

Parameter Name | Required? | Description
subcase_id | Yes | The subcase to create the log for
cont_first | Yes | Phone call contact first name
cont_last | Yes | Phone call contact last name
cont_phone | Yes | Phone call contact phone number
action_type | No | The phone log action type code value. If left blank, default code is used
notes | No | The phone log text
int_use | No | Internal use only information
log_date | No | The date the log was created. If left blank, the current time is used
log_end_date | No | The date/time of the end of the phone call. If left blank, the log_date is used (i.e. a zero length phone call)
user_name | No | The user who created the log. If left blank, the current user performs the logging
new_stat | No | New status for the subcase. If blank (""), no status change is performed
cmit_title | No | Title of the commitment. If blank, no commitment is generated
cmit_notes | No | If generating a commitment, optional notes for the commitment (max length of 255)
cmit_due | No | When is the commitment due. If blank, no commitment is generated
cmit_prior | No | How long (in seconds) before the commitment is due should a warning business rule notification be fired. If set to 0, no warning is generated
cmit_to | Yes | Is the commitment made to the customer (=True), or by the customer (=False). If no commitment is to be generated, this value is ignored
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules).
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | End of phone call is before start of call
-2 | Cannot find the specified subcase
-3 | Cannot find the specified contact
-4 | Cannot find the specified user
-5 | Cannot find the phone log action type string
-6 | Cannot find the PHONE LOG activity string
-7 | Cannot find employee record for specified user
-8 | The supplied status is invalid for the current condition
-9 | A commitment is to be created, but the title is blank
-10 | The prior warning is negative
-11 | The commitment due date is before the log creation date
-12 | Cannot find the COMMIT activity string
-13 | Could not find the com_tmplte for WARNING
-14 | Could not find the com_tmplte for COMMITMENT

Examples

Create a phone log for subcase number 'C154-1'. The call was made with Bill Clinton. Set the notes for the log, and no other information. Generate a time bomb.

Field version:

JavaScript:

var ret_int = fccs.log_subcase_phone("C154-1", "Bill", "Clinton",
              "555-555-1234","", "Some notes", "", "", "", "",
              "", "", "", "", 0, true, true,
              "", 0, "", 0, "", "", "", "", "", "");

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.log_subcase_phone_list("C154-1", "Bill", "Clinton", _
              "555-555-1234", "", "Some notes", "", "", "", "", _
              "", "", "", "", 0, True, True, _
              "", 0, "", 0, "", "", "", "", "", "")

List version:

JavaScript:

var ret_int = fccs.log_subcase_phone_list("C154-1", "Bill", "Clinton",
              "555-555-1234", "", "Some notes", "", "", "", "",
              "", "", "", "", 0, true, true);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.log_subcase_phone("C154-1", "Bill", "Clinton", _
              "555-555-1234", "", "Some notes", "", "", "", "", _
              "", "", "", "", 0, True, True)

Create a 3 minute phone log made by Bill Clinton for subcase number '2-2'. Set action code of 'Incoming call', some note text, and internal use only text. Have the note logged by marty on November 23, 1997 at 10PM. Change the status to "Working". Also, create a commitment for January 1, 1999 at 8:00AM, with a title, notes, and a prior warning of 1 hour (with the commitment being made by the contact). Generate some additional fields, but do not generate a time bomb.

Field version:

JavaScript:

var ret_int = fccs.log_subcase_phone("2-2", "Bill", "Clinton", "555-555-1234",
              "Incoming call", "Some notes", "Internal notes",
              "11/23/97 22:00:00", "11/23/97 22:03:00", "marty",
              "Working", "Commit title", "Commit notes", "1/1/1999 8:00:00",
              3600, false, true, "x_close_int1", 1, "x_close_int2", 456,
              "x_summary2", "More text", "", "", "x_other_date", "1/1/99");

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.log_subcase_phone("2-2", "Bill", "Clinton", "555-555-1234", _
              "Incoming call", "Some notes", "Internal notes", _
              "11/23/97 22:00:00", "11/23/97 22:03:00", "marty", _
              "Working", "Commit title", "Commit notes", "1/1/1999 8:00:00", _
              3600, False, True, "x_close_int1", 1, "x_close_int2", 456, _
              "x_summary2", "More text", "", "", "x_other_date", _
              "1/1/99")

List version:

JavaScript:

var fld_list  = Server.CreateObject("FCFL.FCList");
var type_list = Server.CreateObject("FCFL.FCList");
var val_list  = Server.CreateObject("FCFL.FCList");

fld_list.AppendItem("x_close_int1");
type_list.AppendItem("Long");
val_list.AppendItem ("1");

fld_list.AppendItem("x_close_int2");
type_list.AppendItem("Long");
val_list.AppendItem ("456");

fld_list.AppendItem("x_summary2");
type_list.AppendItem("String");
val_list.AppendItem("More text");

fld_list.AppendItem("x_other_date");
type_list.AppendItem("Date");
val_list.AppendItem("1/1/99");

var ret_int = fccs.log_subcase_phone_list("2-2", "Bill", "Clinton",
              "555-555-1234", "Incoming call", "Some notes", "Internal notes",
              "11/23/97 22:00:00", "11/23/97 22:03:00", "marty", "Working",
              "Commit title", "Commit notes", "1/1/1999 8:00:00",
              3600, false, true, fld_list, type_list, val_list);

Visual Basic:

Dim ret_int As Integer
Dim fld_list    As New List
Dim type_list   As New List
Dim val_list    As New List

fld_list.AppendItem "x_close_int1"
type_list.AppendItem "Long"
val_list.AppendItem Trim(Str$(1))

fld_list.AppendItem "x_close_int2"
type_list.AppendItem "Long"
val_list.AppendItem Trim(Str$(456))

fld_list.AppendItem "x_summary2"
type_list.AppendItem "String"
val_list.AppendItem "More text"

fld_list.AppendItem "x_other_date"
type_list.AppendItem "Date"
val_list.AppendItem "1/1/99"

ret_int = fccs.log_subcase_phone_list("2-2", "Bill", "Clinton", _
              "555-555-1234", "Incoming call", "Some notes", _
              "Internal notes", "11/23/97 22:00:00", _
              "11/23/97 22:03:00", "marty", "Working", "Commit title", _
              "Commit notes", "1/1/1999 8:00:00", 3600, False, True, _
              fld_list, type_list, val_list)


log_subcase_resrch | fcSDK Documentation

log_subcase_resrch

log_subcase_ resrch_list

Public Function log_subcase_resrch(ByVal subcase_id As String, _
                    ByVal action_type As String, ByVal note_str As String, _
                    ByVal int_use As String, ByVal log_date As String, _
                    ByVal research_time As Long, ByVal user_name As String, _
                    ByVal new_stat As String, ByVal cmit_title As String, _
                    ByVal cmit_notes As String, ByVal cmit_due As String, _
                    ByVal cmit_prior As Long, ByVal cmit_to As Boolean, _
                    ByVal gen_time_bombs As Boolean, ByVal int_fld1 As String, _
                    ByVal int_val1 As Long, ByVal int_fld2 As String, _
                    ByVal int_val2 As Long, ByVal str_fld1 As String, _
                    ByVal str_val1 As String, ByVal str_fld2 As String, _
                    ByVal str_val2 As String, ByVal date_fld1 As String, _
                    ByVal date_val1 As String) As Integer

Public Function log_subcase_resrch_list(ByVal subcase_id As String, _
                   ByVal action_type As String, ByVal note_str As String, _
                   ByVal int_use As String, ByVal log_date As String, _
                   ByVal research_time As Long, ByVal user_name As String, _
                   ByVal new_stat As String, ByVal cmit_title As String, _
                   ByVal cmit_notes As String, ByVal cmit_due As String, _
                   ByVal cmit_prior As Long, ByVal cmit_to As Boolean, _
                   ByVal gen_time_bombs As Boolean, _
                   Optional fld_list As Variant, Optional type_list As Variant, _
                   Optional val_list As Variant) As Integer

Description

These APIs are used to create a research log against a subcase. The APIs allow for the assigning of notes, internal use only text, and an action type. The research time (in seconds) is specified. For example, a 5 minute log would be 300 seconds. A new status can be set for the subcase with this API. Additional fields can also be set as well as a time bomb (for the phone log), which allows notifications to be generated based on the event.

Optionally, you can also set a commitment with the note log. If you wish to set a commitment, you MUST set the commitment due date (cmit_due) and the commitement title (cmit_title). The commitment title usually comes from the user-defined list "COMMITMENT", but it does not have to for this API. Any string is acceptable. The other commitment fields are optional. You can add notes to the commitement , and a prior warning. Also, you must set if the commitment is to the contact or by the contact. The contact for the case is always used for the commitment contact.

The objid of the created log is returned in the FCCS object variable ret_objid.

The objid of the commitment log record is returned in the FCCS object variable ret_objid2.

The objid of the status change record is returned in the FCCS object variable ret_objid3.

Parameters

Parameter Name | Required? | Description
subcase _id | Yes | The subcase to create the log for
action_type | No | The research log action type code value. If left blank, default code is used
notes | No | The research log text
int_use | No | Internal use only information
log_date | No | The date the log was created. If left blank, the current time is used
research_time | Yes | The length of the research time in seconds
user_name | No | The user who created the log. If left blank, the current user performs the logging
new_stat | No | New status for the subcase. If blank (""), no status change is performed
cmit_title | No | Title of the commitment. If blank, no commitment is generated
cmit_notes | No | If generating a commitment, optional notes for the commitment (max length of 255)
cmit_due | No | When is the commitment due. If blank, no commitment is generated
cmit_prior | No | How long (in seconds) before the commitment is due should a warning business rule notification be fired. If set to 0, no warning is generated
cmit_to | Yes | Is the commitment made to the customer (=True), or by the customer (=False). If no commitment is to be generated, this value is ignored
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules).
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list
log_objid | Output | This field returns the objid of the newly created log object

Returns

Value | Meaning
0 | No errors
-1 | Research log time is negative
-2 | Cannot find the specified subcase
-3 | Cannot find the specified user
-4 | Cannot find the RESEARCH LOG activity string
-5 | Cannot find the research log action type string
-6 | Cannot find the employee record for the specified user
-7 | The supplied status is invalid for the current condition
-8 | A commitment is to be created, but the title is blank
-9 | The prior warning is negative
-10 | The commitment due date is before the log creation date
-11 | Cannot find the COMMIT activity string
-12 | Could not find the com_tmplte for WARNING
-13 | Could not find the com_tmplte for COMMITMENT

Examples

Create a research log of 4 minutes for subcase number 'C154-1'. Set the notes for the log, and no other information. Generate a time bomb.

Field version:

JavaScript:

var ret_int = fccs.log_subcase_resrch("C154-1", "", "Some notes", "",
              "", 240, "", "", "", "", "", 0, true, true,
              "", 0, "", 0, "", "", "", "", "", "");

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.log_subcase_resrch("C154-1", "", "Some notes", "", _
              "", 240, "", "", "", "", "", 0, True, True, _
              "", 0, "", 0, "", "", "", "", "", "")

List version:

JavaScript:

var ret_int = fccs.log_subcase_resrch_list("C154-1", "", "Some notes", "",
              "", 240, "", "", "", "", "", 0, true, true);

Visual Basic:

   Dim ret_int As Integer

ret_int = fccs.log_subcase_resrch_list("C154-1", "", "Some notes", "", _
              "", 240, "", "", "", "", "", 0, True, True)

Create a 3 minute research log for subcase number '2-2'. Set action code of 'Engineering Research', some note text, and internal use only text. Have the note logged by marty on November 23, 1997 at 10PM. Change the status to "Working". Also, create a commitment for January 1, 1999 at 8:00AM, with a title, notes, and a prior warning of 1 hour (with the commitment being made by the contact). Generate some additional fields, but do not generate a time bomb.

Field version:

JavaScript:

var ret_int = fccs.log_subcase_resrch("2-2", "Engineering Research",
             "Some notes", "Internal use", "11/23/97 22:00:00", 180,
             "marty", "Working", "Commit title", "Commit notes",
             "1/1/1999 8:00:00", 3600, false, true, "x_close_int1",
             1, "x_close_int2", 456, "x_summary2", "More text",
             "", "", "x_other_date", "1/1/99");

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.log_subcase_resrch("2-2", "Engineering Research", _
             "Some notes", _
             "Internal use", "11/23/97 22:00:00", 180, "marty", _
             "Working", "Commit title", "Commit notes", "1/1/1999 8:00:00", _
             3600, False, True, "x_close_int1", 1, "x_close_int2", 456, _
             "x_summary2", "More text", "", "", "x_other_date", "1/1/99")

List version:

JavaScript:

var fld_list  = Server.CreateObject("FCFL.FCList");
var type_list = Server.CreateObject("FCFL.FCList");
var val_list  = Server.CreateObject("FCFL.FCList");

fld_list.AppendItem("x_close_int1");
type_list.AppendItem("Long");
val_list.AppendItem ("1");

fld_list.AppendItem("x_close_int2");
type_list.AppendItem("Long");
val_list.AppendItem ("456");

fld_list.AppendItem("x_summary2");
type_list.AppendItem("String");
val_list.AppendItem("More text");

fld_list.AppendItem("x_other_date");
type_list.AppendItem("Date");
val_list.AppendItem("1/1/99");

var ret_int = fccs.log_subcase_resrch_list("2-2", "Engineering Research",
             "Some notes", "Internal use", "11/23/97 22:00:00", 180,
             "marty", "Working", "Commit title", "Commit notes",
             "1/1/1999 8:00:00", 3600, false, true, fld_list,
             type_list, val_list);

Visual Basic:

Dim ret_int As Integer
Dim fld_list    As New List
Dim type_list   As New List
Dim val_list    As New List

fld_list.AppendItem "x_close_int1"
type_list.AppendItem "Long"
val_list.AppendItem Trim(Str$(1))

fld_list.AppendItem "x_close_int2"
type_list.AppendItem "Long"
val_list.AppendItem Trim(Str$(456))

fld_list.AppendItem "x_summary2"
type_list.AppendItem "String"
val_list.AppendItem "More text"

fld_list.AppendItem "x_other_date"
type_list.AppendItem "Date"
val_list.AppendItem "1/1/99"

ret_int = fccs.log_subcase_resrch_list("2-2", "Engineering Research", _
             "Some notes", "Internal use", "11/23/97 22:00:00", 180, _
             "marty", "Working", "Commit title", "Commit notes", _
             "1/1/1999 8:00:00", 3600, False, True, fld_list, _
             type_list, val_list)


modify_case | fcSDK Documentation

modify_case

modify_case_list

Public Function modify_case(ByVal case_id As String, _
                ByVal priority_str As String, ByVal severity_str As String, _
                ByVal case_type As String, ByVal user_name As String, _
                ByVal mod_date As String, ByVal only_owner As Boolean, _
                ByVal gen_time_bombs As Boolean, _
                ByVal the_title As String, ByVal ml_obj As Long, _
                ByVal sp_obj As Long, ByVal contr_obj As Long, _
                ByVal int_fld1 As String, ByVal int_val1 As Long, _
                ByVal int_fld2 As String, ByVal int_val2 As Long, _
                ByVal str_fld1 As String, ByVal str_val1 As String, _
                ByVal str_fld2 As String, ByVal str_val2 As String, _
                ByVal date_fld1 As String, ByVal date_val1 As String) As Integer

Public Function modify_case_list(ByVal case_id As String, _
                ByVal priority_str As String, ByVal severity_str As String, _
                ByVal case_type As String, ByVal user_name As String, _
                ByVal mod_date As String, ByVal only_owner As Boolean, _
                ByVal gen_time_bombs As Boolean, _
                ByVal the_title As String, ByVal ml_obj As Long, _
                ByVal sp_obj As Long, ByVal contr_obj As Long, _
                Optional fld_list As Variant, Optional type_list As Variant, _
                Optional val_list As Variant) As Integer

Description

These APIs are used to modify existing cases. If the priority, severity, or case type is changing, record the new value in the argument. If they are left blank, the value is not changed in the case. The modifier and the time of modification may be specified, and you may specify additional fields. You may have a creation time bomb generated (for notifications).

The argument only_owner allows you to specify that only the current owner of the case may modify it. If the user_name (or default user if no name is provided) is not the current owner, and this flag is set to True, the modify will not happen. If only_owner is set to False, any user can make the modification. This is an augmentation of the ClearBasic version of the APIs.

There are four arguments to this method that allow you to change (or clear) various parameters. The title, mod_level objid, site_part objid, and contract objid can be set (if you wish), or can be left alone (with "" for title, and 0 for the others), or can be cleared (with "CLEARFIELD" for title, and -999 for the others). This is an augmentation from the base ClearBasic APIs that do not provide this functionality. These arguments are particularly useful in web settings.

Parameters

Parameter Name | Required? | Description
case_id | Yes | The case to modify
priority_str | No | The new priority for the case. If left blank, no change is made
severity_str | No | The new severity for the case. If left blank, no change is made
case_type | No | The new case_type for the case. If left blank, no change is made
user_name | No | The user who modified the case. If left blank, the current user performs the modify
the_title | No | The case title. If empty (""), no change is made. To clear the title field, use the string "CLEARFIELD."
ml_obj | No | Objid of the mod_level (part revision) related to the case. If 0 is used, no change is made. If set to -999, the relation is cleared (set to NULL).
sp_obj | No | Objid of the site_part related to the case. If 0 is used, no change is made. If set to -999, the relation is cleared (set to NULL).
contr_obj | No | Objid of the contract related to the case. If 0 is used, no change is made. If set to -999, the relation is cleared (set to NULL).
mod_date | No | The date/time the case was modified. If left blank, current date/time is used
only_owner | Yes | Should only the owner of the case be allowed to modify it?
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified case
-2 | Case is already closed
-3 | Cannot find the specified priority
-4 | Cannot find the specified severity
-5 | Cannot find the specified case type
-6 | Cannot find the MODIFY activity string
-7 | Cannot find the specified user
-8 | Cannot find employee record for specified user
-9 | Another user (not the owner) attempted to modify the case and the only_owner flag was set to True

Examples

Modify case 'C154'. Change the priority, but nothing else. Do not write any other fields. Any user can make the change. Also, generate a time bomb. All other information is defaulted.

Field version:

JavaScript:

var ret_int = fccs.modify_case("C154", "High", "", "", "", "", 0, 0, 0,
                      "", false, true, "", 0, "", 0, "", "", "", "", "", "");

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.modify_case("C154", "High", "", "", "", "", 0, 0, 0, _
                      "", False, True, "", 0, "", 0, "", "", "", "", "", "")

List version:

JavaScript:

var ret_int = fccs.modify_case_list("C154", "High", "", "", "", "",
                   0, 0, 0, "", false, true);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.modify_case_list("C154", "High", "", "", "", "", _
                   0, 0, 0, "", False, True)

Modify case '2'. It is modified on November 23, 1997 at 10PM by marty. Make sure that marty is the owner of the case to modify it. The severity is 'Low' and the case type is set to 'Question'. The title is changed, and the contract is set, and the mod_level and site_part are cleared. There are no time bombs generated, and some additional fields are also filled in.

Field version:

JavaScript:

var ret_int = fccs.modify_case("2", "", "Low", "Question", "marty",
                      "New title", -999, -999, 268435458,
                      "11/23/97 22:00:00", true, false,
                      "x_close_int1", 1, "x_close_int2",
                      456, "x_summary2", "More text", "", "",
                      "x_other_date", "1/1/99");

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.modify_case("2", "", "Low", "Question", "marty", _
                      "New title", -999, -999, 268435458, _
                      "11/23/97 22:00:00", True, False, _
                      "x_close_int1", 1, "x_close_int2", _
                      456, "x_summary2", "More text", "", "", _
                      "x_other_date", "1/1/99")

List version:

JavaScript:

var fld_list  = Server.CreateObject("FCFL.FCList");
var type_list = Server.CreateObject("FCFL.FCList");
var val_list  = Server.CreateObject("FCFL.FCList");

fld_list.AppendItem("x_close_int1");
type_list.AppendItem("Long");
val_list.AppendItem ("1");

fld_list.AppendItem("x_close_int2");
type_list.AppendItem("Long");
val_list.AppendItem ("456");

fld_list.AppendItem("x_summary2");
type_list.AppendItem("String");
val_list.AppendItem("More text");

fld_list.AppendItem("x_other_date");
type_list.AppendItem("Date");
val_list.AppendItem("1/1/99");

var ret_int = fccs.modify_case_list("2", "", "Low", "Question", "marty",
                           "New title", -999, -999, 268435458,
                           "11/23/97 22:00:00", true, false,
                           fld_list, type_list, val_list);

Visual Basic:

Dim ret_int As Integer
Dim fld_list    As New List
Dim type_list   As New List
Dim val_list    As New List

fld_list.AppendItem "x_close_int1"
type_list.AppendItem "Long"
val_list.AppendItem Trim(Str$(1))

fld_list.AppendItem "x_close_int2"
type_list.AppendItem "Long"
val_list.AppendItem Trim(Str$(456))

fld_list.AppendItem "x_summary2"
type_list.AppendItem "String"
val_list.AppendItem "More text"

fld_list.AppendItem "x_other_date"
type_list.AppendItem "Date"
val_list.AppendItem "1/1/99"

ret_int = fccs.modify_case_list("2", "", "Low", "Question", "marty", _
                           "New title", -999, -999, 268435458, _
                           "11/23/97 22:00:00", True, False, _
                           fld_list, type_list, val_list)


modify_case_commit | fcSDK Documentation

modify_case_commit

modify_case_commit_list

modify_subcase_commit

modify_subcase_commit_list

Public Function modify_case_commit( ByVal id_num As String, _
        ByVal the_title As String, _
                ByVal action_type As String, _
                ByVal commit_date As String, _
                ByVal commit_objid As Long, _
                ByVal prior_warn As Long, _
                ByVal made_to_str As String, _
                ByVal cont_first As String,
                ByVal cont_last As String, _
                ByVal cont_phone As String,
                ByVal note_str As String, _
                ByVal mod_date As String, _
                ByVal user_name As String, _
                ByVal gen_time_bombs As Boolean, _
                ByVal int_fld1 As String, _
                ByVal int_val1 As Long, _
                ByVal int_fld2 As String, _
                ByVal int_val2 As Long, _
                ByVal str_fld1 As String, _
                ByVal str_val1 As String, _
                ByVal str_fld2 As String, _
                ByVal str_val2 As String, _
                ByVal date_fld1 As String, _
                ByVal date_val1 As String) As Integer

Public Function modify_case_commit_list(  ByVal id_num As String, _
            ByVal the_title As String, _
                ByVal action_type As String, _
                ByVal commit_date As String, _
                ByVal commit_objid As Long, _
                ByVal prior_warn As Long, _
                ByVal made_to_str As String, _
                ByVal cont_first As String,
                ByVal cont_last As String, _
                ByVal cont_phone As String,
                ByVal note_str As String, _
                ByVal mod_date As String,
                ByVal user_name As String, _
                ByVal gen_time_bombs As Boolean, _
                Optional fld_list As Variant,
                Optional type_list As Variant, _
                Optional val_list As Variant) As Integer

Public Function modify_subcase_commit(ByVal id_num As String, _
        ByVal the_title As String, _
                ByVal action_type As String, _
                ByVal commit_date As String, _
                ByVal commit_objid As Long, _
                ByVal prior_warn As Long, _
                ByVal made_to_str As String, _
                ByVal cont_first As String, _
                ByVal cont_last As String, _
                ByVal cont_phone As String, _
                ByVal note_str As String, _
                ByVal mod_date As String, _
                ByVal user_name As String, _
                ByVal gen_time_bombs As Boolean, _
                ByVal int_fld1 As String, _
                ByVal int_val1 As Long, _
                ByVal int_fld2 As String, _
                ByVal int_val2 As Long, _
                ByVal str_fld1 As String, _
                ByVal str_val1 As String, _
                ByVal str_fld2 As String, _
                ByVal str_val2 As String, _
                ByVal date_fld1 As String, _
                ByVal date_val1 As String) As Integer

Public Function modify_subcase_commit_list(ByVal id_num As String, _
        ByVal the_title As String, _
                ByVal action_type As String, _
                ByVal commit_date As String, _
                ByVal commit_objid As Long, _
                ByVal prior_warn As Long, _
                ByVal made_to_str As String, _
                ByVal cont_first As String, _
                ByVal cont_last As String, _
                ByVal cont_phone As String, _
                ByVal note_str As String, _
                ByVal mod_date As String, _
                ByVal user_name As String, _
                ByVal gen_time_bombs As Boolean, _
                Optional fld_list As Variant, _
                Optional type_list As Variant, _
                Optional val_list As Variant) As Integer

These APIs are used to modify a commitment against a case or subcase. The APIs allow for the assigning of a title and action type. The date the commitment is logged can be set, as well as the commitment date, and prior warning. A flag can be set so that the commitment can be made to or by a contact, and the contact can be set. The user who logs the commitment can be set, and additional fields can also be set. Finally, a time bomb (for the commitment) can be generated.

Parameters

Parameter Name | Required? | Description
id_num | Yes | The ID number of the case or subcase to modify a commitment for
the_title | No | The title of the commitment
action_type | No | The commitment log action type code value
commit_date | No | When the commitment is due. If left blank, set to the log date
commit_objid | Yes | The objid of the commitment to be modified
prior_warn | No | How long to warn the owner before the commitment expires. This is recorded in seconds (1 hour = 3600 seconds). If set to 0, no prior warning is given
made_to | No | Is the commitment to the contact (True), or by the contact (False)
cont_first | No | First name of the contact
cont_last | No | Last name of the contact
cont_phone | No | Phone number of the contact
note_str | No | Additional text notes for the log
mod_date | No | The date the commitment was modified. If left blank, the current date is used.
user_name | No | The user who modified the commitment. If left blank, the current user ise used.
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules).
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | No | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | No | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | No | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | No title specified
-2 | Must specify phone number of new contact
-2 | Must specify last name of new contact
-2 | Must specify first name of new contact
-3 | The commitment date is not a valid date
-4 | Prior warning is negative (warning after the commitment expires)
-5 | The commitment date is before the modification date
-6 | Could not find gbst_elm string for Modify Commitment
-7 | Could not find the specified log action type
-8 | Cannot find the specified case or subcase
-9 | Specified user is not found
-10 | Cannot find the employee record for the specified user
-11 | Specified commitment with given objid is not found
-12 | Could not find the specified contact
-13 | Could not find the com_tmplte for WARNING
-14 | Could not find the com_tmplte for COMMITMENT

Examples

Modify a commitment with objid 268435459 for case number 'C154'. Set a title and use the default action code, log date, and user. Make the commitment to "Bill Clinton", and make the commitment expire on the default (log) date. Make no prior warning, have no notes, and set no additional fields. Generate a time bomb, and the commitement emails.

JavaScript:

var ret_int = fccs.modify_case_commit("C154", "A title", "",
    "", 268435459, 0, "to","Bill", "Clinton", "555-555-1234",
    "", "", "",true,"", 0, "", 0, "", "", "", "", "", "");

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.modify_case_commit("C154", "A title", "", _
    "", 268435459, 0, "to","Bill", "Clinton", "555-555-1234", _
    "", "", "",true,"", 0, "", 0, "", "", "", "", "", "")


modify_subcase | fcSDK Documentation

modify_subcase

modify_subcase_list

Public Function modify_subcase(ByVal subcase_id As String, _
                ByVal priority_str As String, ByVal severity_str As String, _
                ByVal user_name As String, ByVal mod_date As String, _
                ByVal only_owner As Boolean, ByVal gen_time_bombs As Boolean, _
                ByVal int_fld1 As String, ByVal int_val1 As Long, _
                ByVal int_fld2 As String, ByVal int_val2 As Long, _
                ByVal str_fld1 As String, ByVal str_val1 As String, _
                ByVal str_fld2 As String, ByVal str_val2 As String, _
                ByVal date_fld1 As String, ByVal date_val1 As String) As Integer

Public Function modify_subcase_list(ByVal subcase_id As String, _
                ByVal priority_str As String, ByVal severity_str As String, _
                ByVal user_name As String, ByVal mod_date As String, _
                ByVal only_owner As Boolean, ByVal gen_time_bombs As Boolean, _
                Optional fld_list As Variant, Optional type_list As Variant, _
                Optional val_list As Variant) As Integer

Description

These APIs are used to modify existing subcases. If the priority or severity is changing, record the new value in the argument. If they are left blank, the value is not changed in the case. The modifier and the time of modification may be specified, and you may specify additional fields. You may have a creation time bomb generated (for notifications).

The argument only_owner allows you to specify that only the current owner of the subcase may modify it. If the user_name (or default user if no name is provided) is not the current owner, and this flag is set to True, the modify will not happen. If only_owner is set to False, any user can make the modification. This is an augmentation of the ClearBasic version of the APIs.

Parameters

Parameter Name | Required? | Description
subcase_id | Yes | The subcase to modify
priority | No | The new priority for the subcase. If left blank, no change is made
severity | No | The new severity for the subcase. If left blank, no change is made
user_name | No | The user who modified the subcase. If left blank, the current user performs the modify
mod_date | No | The date/time the subcase was modified. If left blank, current date/time is used
only_owner | Yes | Should only the owner of the subcase be allowed to modify it?
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified case
-2 | Case is already closed
-3 | Cannot find the specified priority
-4 | Cannot find the specified severity
-5 | Cannot find the specified case type
-6 | Cannot find the MODIFY activity string
-7 | Cannot find the specified user
-8 | Cannot find the employee record for the specified user
-9 | Another user (not the owner) attempted to modify the subcase and the only_owner flag was set to True

Examples

Modify subcase 'C154-1'. Change the priority, but nothing else. Do not write any other fields. Any user can make the change. Also, generate a time bomb. All other information is defaulted.

Field version:

JavaScript:

var ret_int = fccs.modify_subcase("C154-1", "High", "", "", "", false, true,
                      "", 0, "", 0, "", "", "", "", "", "");

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.modify_subcase("C154-1", "High", "", "", "", False, True, _
                      "", 0, "", 0, "", "", "", "", "", "")

List version:

JavaScript:

var ret_int = fccs.modify_subcase_list("C154-1", "High", "", "", "", false, true);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.modify_subcase_list("C154-1", "High", "", "", "", False, True)

Modify subcase '2-2'. It is modified on November 23, 1997 at 10PM by marty. Make sure that marty is the owner of the subcase to modify it. The severity is 'Low'. There are no time bombs generated, and some additional fields are also filled in.

Field version:

JavaScript:

var ret_int = fccs.modify_subcase("2-2", "", "Low", "marty",
                      "11/23/97 22:00:00", true, false,
                      "x_close_int1", 1, "x_close_int2",
                      456, "x_summary2", "More text", "", "",
                      "x_other_date", "1/1/99");

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.modify_subcase("2-2", "", "Low", "marty", _
                      "11/23/97 22:00:00", True, False, _
                      "x_close_int1", 1, "x_close_int2", _
                      456, "x_summary2", "More text", "", "", _
                      "x_other_date", "1/1/99")

List version:

JavaScript:

var fld_list  = Server.CreateObject("FCFL.FCList");
var type_list = Server.CreateObject("FCFL.FCList");
var val_list  = Server.CreateObject("FCFL.FCList");

fld_list.AppendItem("x_close_int1");
type_list.AppendItem("Long");
val_list.AppendItem ("1");

fld_list.AppendItem("x_close_int2");
type_list.AppendItem("Long");
val_list.AppendItem ("456");

fld_list.AppendItem("x_summary2");
type_list.AppendItem("String");
val_list.AppendItem("More text");

fld_list.AppendItem("x_other_date");
type_list.AppendItem("Date");
val_list.AppendItem("1/1/99");

var ret_int = fccs.modify_subcase_list("2-2", "", "Low", "marty",
                           "11/23/97 22:00:00", true, false,
                           fld_list, type_list, val_list);

Visual Basic:

Dim ret_int As Integer
Dim fld_list    As New List
Dim type_list   As New List
Dim val_list    As New List

fld_list.AppendItem "x_close_int1"
type_list.AppendItem "Long"
val_list.AppendItem Trim(Str$(1))

fld_list.AppendItem "x_close_int2"
type_list.AppendItem "Long"
val_list.AppendItem Trim(Str$(456))

fld_list.AppendItem "x_summary2"
type_list.AppendItem "String"
val_list.AppendItem "More text"

fld_list.AppendItem "x_other_date"
type_list.AppendItem "Date"
val_list.AppendItem "1/1/99"

ret_int = fccs.modify_subcase_list("2-2", "", "Low", "marty", _
                           "11/23/97 22:00:00", True, False, _
                           fld_list, type_list, val_list)


move_case | fcSDK Documentation

move_case

Public Function move_case(ByVal case_id As String, _
                          ByVal new_wipbin As String) As Integer

Description

This API causes the specified case to be moved from one WIPBin to another WIPBin. The new WIPBin must belong to the same user as the first WIPBin. The move operation does not change the ownership of the case, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WIPBin to another, even if the object is currently dispatched. Since WIPBins are internal to a user, there really is no reason that you shouldn't be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Parameters

Parameter Name | Required? | Description
case_id | Yes | The case to move
new_wipbin | Yes | The WIPBin to move the case to. If left blank, the case is moved to the user's default WIPBin

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified case
-2 | Case is already closed
-3 | New WIPBIN doesn't exist, or isn't for the owner
-4 | New WIPBIN is same as old - no move needed

Examples

Move case number 'C154' to the default WIPBin for the current owner.

JavaScript:

var ret_int = fccs.move_case("C154", "");

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.move_case("C154", "")

Move case number '2' to WIPBin 'Urgent'.

JavaScript:

var ret_int = fccs.move_case("2", "Urgent");

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.move_case("2", "Urgent")


move_subcase | fcSDK Documentation

move_subcase

Public Function move_subcase(ByVal subcase_id As String, _
                          ByVal new_wipbin As String) As Integer

Description

This API causes the specified subcase to be moved from one WIPBin to another WIPBin. The new WIPBin must belong to the same user as the first WIPBin. The move operation does not change the ownership of the subcase, nor is an activity log or time bomb generated for the action.

Note: This API allows you to move a queueable object from one WIPBin to another, even if the object is currently dispatched. Since WIPBins are internal to a user, there really is no reason that you shouldn't be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Parameters

Parameter Name | Required? | Description
subcase_id | Yes | The subcase to move
new_wipbin | Yes | The WIPBin to move the subcase to. If left blank, the case is moved to the user's default WIPBin

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified subcase
-2 | Subcase is already closed
-3 | New WIPBIN doesn't exist, or isn't for the owner
-4 | New WIPBIN is same as old - no move needed

Examples

Move subcase number 'C154-1' to the default WIPBin for the current owner.

JavaScript:

var ret_int = fccs.move_subcase("C154-1", "");

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.move_subcase("C154-1", "")

Move subcase number '2-2' to WIPBin 'Urgent'.

JavaScript:

var ret_int = fccs.move_subcase("2-2", "Urgent");

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.move_subcase("2-2", "Urgent")


preclose_case | fcSDK Documentation

preclose_case

Public Function preclose_case(case_id As String) As Integer

Description

This API is used if you wish to see all of the summed times (such as phone log time, billable and non-billable expense, etc) for a case about to be closed. This is particularly useful in web applications, where you wish to display the captured times for a case, so that a user can modify them (the actual times).

If you wish to just close a case (and have the times automatically summed), you do not need to call this API. In that case, just call on close_case.

The results of the API are returned in the output string ret_id_num. While the results are not an id_number, they are returned in this string. See the Results section for details of the format of the string.

Note: There are a number of bugs with the default Clarify close case summation on the form. There are not sufficient fields defined in the close_case record for the graphical fields they show. Hence, the data doesn't always make sense. For example, the "total phone time captured" should be the total of the phone time captured for the case and for all general subcases. But the GUI form points that field to the total for the phone logs captured for the case (not showing the subcase). Hence, this API defines the data as captured from the real data. How you present it is up to you.

Parameters

Parameter Name | Required? | Description
case_id | Yes | The case to sum

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified case
-2 | The specified case is already closed

The results of the API are returned in the string ret_id_num. The values are separated by a pipe ("|") character. They are:

  1. Total phone time (closed subcase and phone log for the case)

  2. Captured phone time (case phone logs only)

  3. Actual phone time (closed subcase only)

  4. Total research time (closed subcase and research logs for the case)

  5. Captured research time (case research logs only)

  6. Actual research time (closed subcase only)

  7. Total non-billable time (closed subcase and case time logs)

  8. Captured non-billable time (case time logs only)

  9. Total billable time (closed subcase and case time logs)

  10. Captured billable time (case time logs only)

  11. Total non-billable expenses (closed subcase and case expense logs)

  12. Captured non-billable expenses (case time logs only)

  13. Total billable expenses (closed subcase and case expense logs)

  14. Captured billable expenses (case time logs only)

Examples

Preclose case number 'C154'. Get the value for the captured and total phone logs, and for the captured and total billable expenses.

JavaScript:

var ret_int = fccs.preclose_case("C154");
var c_phone = fc_session.GetItem(fccs.ret_id_num, 2, 2, "|");
var t_phone = fc_session.GetItem(fccs.ret_id_num, 1, 1, "|");
var c_bill = fc_session.GetItem(fccs.ret_id_num, 14, 14, "|");
var t_bill = fc_session.GetItem(fccs.ret_id_num, 13, 13, "|");

Visual Basic:

Const PIPE      =  "|"
Dim ret_int As Integer
Dim c_phone     As Long
Dim t_phone     As Long
Dim c_bill      As Long
Dim t_bill      As Long
ret_int = fccs.preclose_case("C154")

c_phone = CLng(fc_session.GetItem(fccs.ret_id_num, 2, 2, PIPE))
t_phone = CLng(fc_session.GetItem(fccs.ret_id_num, 1, 1, PIPE))
c_bill = CLng(fc_session.GetItem(fccs.ret_id_num, 14, 14, PIPE))
t_bill = CLng(fc_session.GetItem(fccs.ret_id_num, 13, 13, PIPE))


preclose_subcase | fcSDK Documentation

preclose_subcase

Public Function preclose_subcase(case_id As String) As Integer

Description

This API is used if you wish to see all of the summed times (such as phone log time, billable and non-billable expense, etc) for a subcase about to be closed. This is particularly useful in web applications, where you wish to display the captured times for a subcase, so that a user can modify them (the actual times).

If you wish to just close a subcase (and have the times automatically summed), you do not need to call this API. In that case, just call on close_subcase.

The results of the API are returned in the output string ret_id_num. While the results are not an id_number, they are returned in this string. See the Results section for details of the format of the string.

Note: There are a number of bugs with the default Clarify close subcase summation on the form. There are not sufficient fields defined in the close_case record for the graphical fields they show. Hence, the data doesn't always make sense. For example, the "total phone time captured" should be the total of the phone time captured for the case and for all general subcases. But the GUI form points that field to the total for the phone logs captured for the case (not showing the subcase). Hence, this API defines the data as captured from the real data. How you present it is up to you.

Parameters

Parameter Name | Required? | Description
subcase_id | Yes | The subcase to sum

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified subcase
-2 | The specified subcase is already closed

The results of the API are returned in the string ret_id_num. The values are separated by a pipe ("|") character. They are:

    1. Captured phone time
    2. Captured research time
    3. Captured non-billable time
    4. Captured billable time
    5. Captured non-billable expenses
    6. Captured billable expenses

Examples

Preclose subcase number 'C154-1'. Get the value for the captured phone logs, and for the captured billable expenses.

JavaScript:

var ret_int = fccs.preclose_subcase("C154-1");
var c_phone = fc_session.GetItem(fccs.ret_id_num, 1, 1, "|");
var c_bill = fc_session.GetItem(fccs.ret_id_num, 6, 6, "|");

Visual Basic:

Const PIPE      =  "|"
Dim ret_int As Integer
Dim c_phone     As Long
Dim t_phone     As Long
Dim c_bill      As Long
Dim t_bill      As Long
ret_int = fccs.preclose_subcase("C154-1")

c_phone = CLng(fc_session.GetItem(fccs.ret_id_num, 1, 1, PIPE))
c_bill = CLng(fc_session.GetItem(fccs.ret_id_num, 6, 6, PIPE))


reject_case | fcSDK Documentation

reject_case

Public Function reject_case(ByVal case_id As String, _
                ByVal reject_date As String, ByVal wipbin_name As String, _
                ByVal note_str As String, ByVal user_name As String, _
                ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified case to be rejected from the queue it is in, and returned back to the owner. The case must be in open condition, and currently dispatched to a queue. The API allows for the setting of the reject date, some notes about the reject, and the user who rejected the case. The API also allows you to set the WIPBin that the case is placed back in. This is additional functionality that base Clarify does not provide. The APIs can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
case_id | Yes | The case to reject-forward
reject_date | No | When was the case rejected. If this parameter is left blank, the case is rejected at the current time
wipbin | No | The WIPBin to place the case in. If left blank, the default WIPBin is used
notes | No | Optional notes about the reject
user_name | No | The user who rejected the case. If left blank, the current user performs the reject
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified case
-2 | The case is not currently dispatched
-3 | Cannot find the specified user
-4 | The case is currently closed - cannot dispatch
-5 | Cannot find the new specified WIPBIN, or it is not a WIPBIN for the specified user
-6 | Cannot find REJECT activity string

Examples

Reject case number 'C154' to the default WIPBin. The reject has no notes, is performed by the current user and is rejected at the current time. Generate a time bomb.

JavaScript:

var ret_int = fccs.reject_case("C154", "", "", "", "", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.reject_case("C154", "", "", "", "", True)

Reject case number '2' at 10PM on November 23rd of 1997 to WIPBin 'East'. Reject should be logged as performed by dave, with notes of 'Some notes'. Don't generate a time bomb.

JavaScript:

var ret_int = fccs.reject_case("2", "11/23/97 22:00:00", "East", "Some notes", "dave", false);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.reject_case("2", "11/23/97 22:00:00", "East", "Some notes", "dave", False)


reject_subcase | fcSDK Documentation

reject_subcase

Public Function reject_subcase(ByVal subcase_id As String, _
                ByVal reject_date As String, ByVal wipbin_name As String, _
                ByVal note_str As String, ByVal user_name As String, _
                ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified subcase to be rejected from the queue it is in, and returned back to the owner. The subcase must be in open condition, and currently dispatched to a queue. The API allows for the setting of the reject date, some notes about the reject, and the user who rejected the subcase. The API also allows you to set the WIPBin that the subcase is placed back in. This is additional functionality that base Clarify does not provide. The APIs can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
subcase_id | Yes | The subcase to reject-forward
reject_date | No | When was the subcase rejected. If this parameter is left blank, the subcase is rejected at the current time
wipbin | No | The WIPBin to place the subcase in. If left blank, the default WIPBin is used
notes | No | Optional notes about the reject
user_name | No | The user who rejected the subcase. If left blank, the current user performs the reject
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified subcase
-2 | The subcase is not currently dispatched
-3 | Cannot find the specified user
-4 | The subcase is currently closed - cannot dispatch
-5 | Cannot find the new specified WIPBIN, or it is not a WIPBIN for the specified user
-6 | Cannot find REJECT activity string

Examples

Reject subcase number 'C154-1' to the default WIPBin. The reject has no notes, is performed by the current user and is rejected at the current time. Generate a time bomb.

JavaScript:

var ret_int = fccs.reject_subcase("C154-1", "", "", "", "", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.reject_subcase("C154-1", "", "", "", "", True)

Reject subcase number '2-2' at 10PM on November 23rd of 1997 to WIPBin 'East'. Reject should be logged as performed by dave, with notes of 'Some notes'. Don't generate a time bomb.

JavaScript:

var ret_int = fccs.reject_subcase("2-2", "11/23/97 22:00:00", "East", "Some notes", "dave", false);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.reject_subcase("2-2", "11/23/97 22:00:00", "East", "Some notes", "dave", False)


relate_case_to_parent | fcSDK Documentation

relate_case_to_parent

Public Function relate_case_to_parent(ByVal case_id As String, _
                            ByVal parent_id As String) As Integer

Description

This API allows a case to be related to a specified parent case. You must make sure that the new parent case is not the same as the case (you cannot relate a case to itself), and the new parent cannot be anywhere in the descendent tree of the new child case.

Parameters

Parameter Name | Required? | Description
case_id | Yes | The ID of the new child case
parent_id | Yes | The ID of the new parent case

Returns

Value | Meaning
0 | No errors
-1 | The case ID and parent case ID cannot be the same
-2 | Cannot find the specified case ID
-3 | The parent ID is already a descendent of the case ID
-4 | Cannot find the specified parent case ID
-5 | The new parent is already related as the parent of the case

Examples

Relate case 5 to have a new parent of case 66.

JavaScript:

var ret_int = fccs.relate_case_to_parent("5", "66");

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.relate_case_to_parent("5", "66")


reopen_case | fcSDK Documentation

reopen_case

Public Function reopen_case(ByVal case_id As String, _
                ByVal wipbin_name As String, ByVal status_str As String, _
                ByVal reopen_date As String, ByVal user_name As String, _
                ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified case to be reopened. The date/time of the reopen, the person performing the reopen, the WIPBIN to place the case in, and the new status of the case are specified. The person who reopens the case becomes the new owner. The WIPBin to place the case in may also be specified. If it is not, the case is placed in the user's default WIPBIN. This is augmented function from base Clarify, where the case is always placed in the default WIPBin. The status field is also augmented function. If the status is not specified, the case is placed in the default status for the Open condition. The API can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
case_id | Yes | The case to reopen
wipbin_name | No | The WIPBin to place the case in. If left blank, the default WIPBin for the user is used
status_str | No | The new status for the case. If no status is specified, the default status for Open Condition is used
reopen_date | No | When was the case reopened. If this parameter is left blank, the reopen occurs at the current time
user_name | No | The user who reopened the case. If left blank, the current user performs the reopen
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified case
-2 | The case is not closed
-3 | Cannot find the specified user
-4 | Cannot find the specified WIPBIN
-5 | Cannot find the REOPEN activity string
-6 | Cannot find the specified status
-7 | Cannot find the employee record for the specified user

Examples

Reopen case number 'C154' by the current user at the current date/time. Place in the default WIPBin with the default status, and generate a time bomb.

JavaScript:

var ret_int = fccs.reopen_case("C154", "", "", "", "", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.reopen_case("C154", "", "", "", "", True)

Reopen case number '2' at 10PM on November 23rd of 1997 by dave. Place in dave's WIPBin 'Urgent', with status 'User Error'. Don't generate a time bomb.

JavaScript:

var ret_int = fccs.reopen_case("2", "Urgent", "User Error", "11/23/97 22:00:00", "dave", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.reopen_case("2", "Urgent", "User Error", "11/23/97 22:00:00", "dave", True)


reopen_subcase | fcSDK Documentation

reopen_subcase

Public Function reopen_subcase(ByVal subcase_id As String, _
                ByVal wipbin_name As String, ByVal status_str As String, _
                ByVal reopen_date As String, ByVal user_name As String, _
                ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified subcase to be reopened. The date/time of the reopen, the person performing the reopen, the WIPBIN to place the subcase in, and the new status of the subcase are specified. The person who reopens the subcase becomes the new owner. The WIPBin to place the subcase in may also be specified. If it is not, the subcase is placed in the user's default WIPBIN. This is augmented function from base Clarify, where the subcase is always placed in the default WIPBin. The status field is also augmented function. If the status is not specified, the subcase is placed in the default status for the Open condition. The API can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
subcase_id | Yes | The subcase to reopen
wipbin_name | No | The WIPBin to place the subcase in. If left blank, the default WIPBin for the user is used
status_str | No | The new status for the subcase. If no status is specified, the default status for Open Condition is used
reopen_date | No | When was the subcase reopened. If this parameter is left blank, the reopen occurs at the current time
user_name | No | The user who reopened the subcase. If left blank, the current user performs the reopen
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified subcase
-2 | The subcase is not closed
-3 | Cannot find the specified user
-4 | Cannot find the specified WIPBIN
-5 | Cannot find the REOPEN activity string
-6 | Cannot find the specified status
-7 | Cannot find the employee record for the specified user

Examples

Reopen subcase number 'C154-1' by the current user at the current date/time. Place in the default WIPBin with the default status, and generate a time bomb.

JavaScript:

var ret_int = fccs.reopen_subcase("C154-1", "", "", "", "", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.reopen_subcase("C154-1", "", "", "", "", True)

Reopen subcase number '2-2' at 10PM on November 23rd of 1997 by dave. Place in dave's WIPBin 'Urgent', with status 'User Error'. Don't generate a time bomb.

JavaScript:

var ret_int = fccs.reopen_subcase("2-2", "Urgent", "User Error", "11/23/97 22:00:00", "dave", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.reopen_subcase("2-2", "Urgent", "User Error", "11/23/97 22:00:00", "dave", True)


unrelate_case_from_parent | fcSDK Documentation

unrelate_case_from_parent

Public Function unrelate_case_from_parent(ByVal case_id As String) As Integer

Description

This API allows a case to be unrelated from the current parent case. The case must be related to a parent case.

Parameters

Parameter Name | Required? | Description
case_id | Yes | The ID of the case. The parent of this case will be cleared.

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified case ID
-2 | The specified case does not have a parent case

Examples

Unrelate case 5 from its parent case.

JavaScript:

var ret_int = fccs.unrelate_case_from_parent("5");

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.unrelate_case_from_parent("5")


yank_case | fcSDK Documentation

yank_case

Public Function yank_case(ByVal case_id As String, _
                ByVal wipbin_name As String, ByVal yank_date As String, _
                ByVal user_name As String, _
                ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified case to be yanked from the current location to a new owner's WIPBin. The date/time of the yank, and the person yanking the case are specified. The person who yanks the case becomes the new owner. The WIPBin to place the case in may also be specified. This is augmented function from base Clarify, where the case is always placed in the default WIPBin. The APIs can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
case_id | Yes | The case to yank
wipbin | No | The WIPBin to place the case in. If left blank, the default WIPBin for the user is used
yank_date | No | When was the case yanked. If this parameter is left blank, the yank occurs at the current time
user_name | No | The user who yanked the case. If left blank, the current user performs the yank
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified case
-2 | The case is already closed
-3 | Cannot find the specified user
-4 | Cannot find the specified WIPBIN
-5 | Cannot find the YANK activity string

Examples

Yank case number 'C154' by the current user at the current date/time. Place in the default WIPBin, generate a time bomb.

JavaScript:

var ret_int = fccs.yank_case("C154", "", "", "", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.yank_case("C154", "", "", "", True)

Yank case number '2' at 10PM on November 23rd of 1997 by dave. Place in dave's WIPBin 'Urgent'. Don't generate a time bomb.

JavaScript:

var ret_int = fccs.yank_case("2", "Urgent", "11/23/97 22:00:00", "dave", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.yank_case("2", "Urgent", "11/23/97 22:00:00", "dave", True)


yank_subcase | fcSDK Documentation

yank_subcase

Public Function yank_subcase(ByVal subcase_id As String, _
                ByVal wipbin_name As String, ByVal yank_date As String, _
                ByVal user_name As String, _
                ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified subcase to be yanked from the current location to a new owner's WIPBin. The date/time of the yank, and the person yanking the subcase are specified. The person who yanks the subcase becomes the new owner. The WIPBin to place the subcase in may also be specified. This is augmented function from base Clarify, where the subcase is always placed in the default WIPBin. The APIs can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
subcase_id | Yes | The subcase to yank
wipbin | No | The WIPBin to place the subcase in. If left blank, the default WIPBin for the user is used
yank_date | No | When was the subcase yanked. If this parameter is left blank, the yank occurs at the current time
user_name | No | The user who yanked the subcase. If left blank, the current user performs the yank
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified subcase
-2 | The subcase is already closed
-3 | Cannot find the specified user
-4 | Cannot find the specified WIPBIN
-5 | Cannot find the YANK activity string

Examples

Yank subcase number 'C154-1' by the current user at the current date/time. Place in the default WIPBin, generate a time bomb.

JavaScript:

var ret_int = fccs.yank_subcase("C154-1", "", "", "", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.yank_subcase("C154-1", "", "", "", True)

Yank subcase number '2-2' at 10PM on November 23rd of 1997 by dave. Place in dave's WIPBin 'Urgent'. Don't generate a time bomb.

JavaScript:

var ret_int = fccs.yank_subcase("2-2", "Urgent", "11/23/97 22:00:00", "dave",  true);

Visual Basic:

Dim ret_int As Integer

ret_int = fccs.yank_subcase("2-2", "Urgent", "11/23/97 22:00:00", "dave", True)


ret_objid2 | fcSDK Documentation

ret_objid2

Prototype

Public ret_objid2 As Long

Description

Contains the objid of an object recently created or updated as the result of the recent API function call. Not all functions set this property value.

Please see the documentation of the particular API function for information on whether or not it sets the value of this property after it completes and to which of the multiple objects affected by the function call this objid belongs.


ret_objid3 | fcSDK Documentation

ret_objid3

Prototype

Public ret_objid3 As Long

Description

Contains the objid of an object recently created or updated as the result of the recent API function call. Not all functions set this property value.

Please see the documentation of the particular API function for information on whether or not it sets the value of this property after it completes and to which of the multiple objects affected by the function call this objid belongs.


FCFL API Toolkit for Depot Repair | fcSDK Documentation

FCFL API Toolkit for Depot Repair

Overview

Many customers have wanted the ability to customize the Clarify environment easily by adding base Clarify functions (such as ECO creation, or Depot Repair labor logging) to web applications.

The First Choice Software FCFL API Toolkit for Depot Repair solves these problems, as well as many others. The toolkit is a series of COM functions that you may add to your customizations.

All of the APIs perform the same base functions as the Clarify GUI - all database records are properly written, activity logs are generated to track the API call, and time bombs are added to the system so that business rules can be fired based on the API function call.

While all of the APIs mimic the Clarify base function, many of them provide augmented functionality that Clarify customers have requested. For example, the base Clarify yank function always placed the object in the user's default WIPBin. With the yank API in the toolkit, you have the choice of placing the object in any specific WIPBin for the user, or in the default WIPBin.

The APIs are simple to use. One simple API call is provided for each function, and very few data values must be supplied. The APIs are flexible in that they provide a large number of optional arguments that allow you to customize the API calls as needed.


create_eco_hdr | fcSDK Documentation

create_eco_hdr

Public Function create_eco_hdr(ByVal eco_title As String, _
             ByVal eco_type As String, _
             ByVal create_date As String, _
             ByVal eff_type As String, _
             ByVal start_date As String, _
             ByVal end_date As String, _
             ByVal status As String, _
             ByVal description As String) As Integer

Description

This API create a new ECO Header object.

Parameters

Parameter Name | Required? | Description
eco_title | No | The title of the new ECO header.
eco_type | No | The type of ECO, defined by the Clarify list of "ECO Type" values. The list default is used if no parameter is supplied.
create_date | No | The date the ECO header was created. Will default to the current date.
eff_type | No | The effect type of ECO, defined by the Clarify list of "ECO Effect Type" values. The list default is used if no parameter is supplied.
start_date | Yes | The date that this ECO header goes into effect.
end_date | Yes | The date that this ECO header becomes obsolete.
status | No | The type of ECO, defined by the Clarify list of "ECO Status" values. The list default is used if no parameter is supplied.
description | No | The text description of the ECO header.

Returns

Value | Meaning
0 | No errors
-1 | Invalid Start Date Specified
-2 | Invalid End Date Specified
-3 | Specified Start Date After Specified End Date
-4 | Cannot generate a new ECO ID number
-5 | Specified ECO Type is not in database
-6 | Specified ECO Effect Type is not in database
-7 | Specified ECO Status is not in database
ret_id_num | Output - Returns the ECO Header Code of the newly created ECO
ret_objid | Output - Returns the objid of the newly created ECO

Examples

  • Create a new ECO header titled "5001", type "Service Update", status "In Effect", starting "1/1/1999", and ending "1/31/1999".

JavaScript:

var ret_int = fcdr. create_eco_hdr("5001","Service
                    Update","","","01/01/99 00:00",
                    "01/31/99 23:59","In Effect","")

Visual Basic:

Dim ret_int As Integer

ret_int = fcdr. create_eco_hdr("5001","Service
                Update","","","01/01/99 00:00",
                "01/31/99 23:59","In Effect","")


create_eco_item | fcSDK Documentation

create_eco_item

Public Function create_eco_item(ByVal focus_type As Long, _
                         ByVal active As Long, _
                         ByVal eco_hdr_code As String, _
                         ByVal apply_mod_level As Long, _
                         ByVal result_mod_level As Long) As Integer

Description

This API is used to create new ECO items. It requires that a valid ECO Header be specified. The objid of the ECO item created is returned in the object property ret_objid (FCDR.ret_objid).

Parameters

Parameter Name | Required? | Description
focus_type | Yes | This points the ECO item to 5148 for ECO headers, or 329 for Mod levels.
active | Yes | Sate of the ECO item, 1 for active, 0 for inactive.
eco_hdr_code | Yes | ECO Code of the ECO Header this item will be attached to.
apply_mod_level | Yes | Objid of part and revision affected by the ECO.
result_mod_level | Yes | Objid of resulting part and revision following implementation of the ECO.

Returns

Value | Meaning
0 | No errors
-1 | Invalid Focus Type Specified
-2 | Invalid Value for Active Indicator
-3 | Specified ECO Header is not in database
-4 | Specified Apply-to Mod Level is not in database
-5 | Specified Results-in Mod Level is not in database
-6 | Specified Role Name and Apply-to Mod Level already in database
ret_objid | Output - Returns the objid of the newly created ECO Item

Examples

Create a new ECO item. It will relate to ECO Header "8", be active, and change part 268435464 to part 268435465.

JavaScript:

var ret_int = fcdr.create_eco_item(5148, 1, "8", 268435464, 268435465);

Visual Basic:

Dim ret_int As Integer

ret_int = fcdr.create_eco_item(5148, 1, "8", 268435464, 268435465)


create_eco_dtl | fcSDK Documentation

create_eco_dtl

Public Function create_eco_dtl(ByVal detail_type As String, _
                        ByVal required As Long, _
                        ByVal status As String, _
                        ByVal labor_type As String, _
                        ByVal elapsed_time As Long, _
                        ByVal location As String, _
                        ByVal description As String, _
                        ByVal eco_hdr_code As String, _
                        ByVal mod_level_objid As Long) As Integer

Description

This API add labor or material details to the specified ECO Header. The objid of the ECO detail created is returned in the object property ret_objid (FCDR.ret_objid).

Parameters

Parameter Name | Required? | Description
detail_type | Yes | Must be "Labor" or "Material"
Required? | Yes | Indicates if this detail is required (1), or not (0)
status | No | Indicates the effectivity of the ECO, defined by the Clarify list of "ECO Status" values. The list default is used if no parameter is supplied.
labor_type | No* | Indicates the type of labor being added, from the Clarify list of "Labor Type" values. The list default is used if no parameter is supplied.
elapsed_time | Yes* | Estimated amount of time required to perform the work in seconds.
location | No** | Indicates the location where the material belongs.
description | No | Text field for the description of the ECO detail.
eco_hdr_code | Yes | ECO Code of the ECO Header this detail will be attached to.
mod_level_objid | Yes** | Indicates the part and revision used to apply this ECO.
* These parameters only apply to Labor detail items.
** These parameters only apply to Material detail items.

Returns

Value | Meaning
0 | No errors
-1 | Invalid Detail Type Specified
-2 | Invalid Value for Detail Required Field
-3 | Invalid Value for Elapsed Time
-4 | Specified ECO Status is not in database
-5 | Specified Labor Type is not in database
-6 | Specified ECO Header is not in database
-7 | Specified Mod Level is not in database
ret_objid | Output - Returns the objid of the newly created ECO Detail

Examples

Create a labor ECO detail attached to ECO "8". The estimated time is 10 minutes (600 seconds).

JavaScript:

var ret_int = fcdr.create_eco_dtl("Labor",0,"","",600,"",
    "Apply Upgrade","8",0);

Visual Basic:

Dim ret_int As Integer

ret_int = fcdr.create_eco_dtl("Labor",0,"","",600,"","Apply Upgrade","8",0)


modify_eco_item | fcSDK Documentation

modify_eco_item

Public Function modify_eco_item(ByVal eco_mod_role_objid As Long, _
                          ByVal focus_type As Long, _
                          ByVal active As Long, _
                          ByVal eco_hdr_code As String, _
                          ByVal applies_to_mod As Long, _
                          ByVal results_in_mod As Long) As Integer

Description

This API modifies an existing labor or material detail.

Parameters

Parameter Name | Required? | Description
eco_mod_role_objid | Yes | The objid of the ECO item object to be modified.
focus_type | Yes | This points the ECO item to 5148 for ECO headers, or 329 for Mod levels. This can also be -1 to ignore any change to this item.
active | Yes | Sate of the ECO item, 1 for active, 0 for inactive. This can also be -1 to ignore any change to this item.
eco_hdr_code | No | ECO Code of the ECO Header this item will be switched to, or an empty string for no change.
applies_to_mod | No | Objid of part and revision affected by the ECO, or 0 for no change.
results_in_mod | No | Objid of resulting part and revision following implementation of the ECO, or 0 for no change.

Returns

Value | Meaning
0 | No errors
-1 | Invalid Role Name Specified
-2 | Invalid Value for Active Indicator
-3 | Specified ECO Mod Role is not in database
-4 | Specified ECO Header is not in database
-5 | Specified Applies-To Mod Level is not in database
-6 | Specified Results-In Mod Level is not in database
-7 | Specified Role Name and Apply-to Mod Level already exists in database

Examples

Modify ECO item 268435460, to result in part 268435465.

JavaScript:

var ret_int = fcdr.modify_eco_item(268435460, -1, -1, "", 0, 268435465);

Visual Basic:

Dim ret_int As Integer

ret_int = fcdr. modify_eco_item(268435460, -1, -1, "", 0, 268435465)


modify_eco_dtl | fcSDK Documentation

modify_eco_dtl

Public Function modify_eco_dtl(ByVal eco_dtl_objid As Long, _
                         ByVal detail_type As String, _
                         ByVal required As Long, _
                         ByVal status As String, _
                         ByVal labor_type As String, _
                         ByVal elapsed_time As Long, _
                         ByVal location As String, _
                         ByVal description As String, _
                         ByVal eco_hdr_code As String, _
                         ByVal mod_level_objid As Long) As Integer

Description

This API modifies an existing ECO detail object.

Parameters

Parameter Name | Required? | Description
eco_dtl_objid | Yes | The objid of the ECO item object to be modified.
detail_type | No | This is the type of detail, "Labor", "Material", or "" to ignore.
Required? | No | This indicates if the detail is required; 0 for no, 1 for yes, or -1 to ignore.
status | No | Use to change the status of the ECO Detail
labor_type | No | Use to change the labor type for a "Labor" detail.
elapsed_time | No | This will replace existing time (use -1 to ignore) if detail_type is "Labor".
location | No | Any non-zero length string will replace location for "Material" details.
description | No | Any non-zero length string will replace description.
eco_hdr_code | No | Use to reassign detail to another ECO header, or use "" to ignore.
mod_level_objid | No | The part in "Material" details can be changed, or use 0 to ignore.

Returns

Value | Meaning
0 | No errors
-1 | Invalid Detail Type Specified
-2 | Invalid Value for Detail Required Field
-3 | Specified ECO Status is not in database
-4 | Specified Labor Type is not in database
-5 | Specified ECO Detail is not in database
-6 | Specified ECO Header is not in database
-7 | Specified Mod Level is not in database

Examples

Modify a "Labor" ECO detail to change the status to expired.

JavaScript:

var ret_int = fcdr.modify_eco_dtl(268435465,"",-1,"Expired","",-1, "", "","", 0);

Visual Basic:

Dim ret_int As Integer

ret_int = fcdr. modify_eco_dtl(268435465,"",-1,"Expired","",-1, "", "","", 0)


delete_eco_item | fcSDK Documentation

delete_eco_item

Public Function delete_eco_item(ByVal eco_item_objid As Long) As Integer

Description

This API will delete an ECO item object.

Parameters

Parameter Name | Required? | Description
eco_item_objid | Yes | The objid of the ECO item object to be deleted.

Returns

Value | Meaning
0 | No errors
-1 | Specified ECO Item is not in database

Examples

Delete ECO Item 268435463.

JavaScript:

var ret_int = fcdr. delete_eco_item(268435463);

Visual Basic:

Dim ret_int As Integer

ret_int = fcdr. delete_eco_item(268435463)


delete_eco_detail | fcSDK Documentation

delete_eco_detail

Public Function delete_eco_dtl(ByVal eco_dtl_objid As Long) As Integer

Description

This API will delete an ECO detail object.

Parameters

Parameter Name | Required? | Description
eco_dtl_objid | Yes | The objid of the ECO detail object to be deleted.

Returns

Value | Meaning
0 | No errors
-1 | Specified ECO Detail is not in database

Examples

Delete ECO Detail 268435463.

JavaScript:

var ret_int = fcdr.delete_eco_dtl(268435463);

Visual Basic:

Dim ret_int As Integer

ret_int = fcdr.delete_eco_dtl(268435463)


apply_eco | fcSDK Documentation

apply_eco

Public Function apply_eco(ByVal demand_dtl_objid As Long, _
                          ByVal eco_code As String,
                                ByVal perf_by As String,
                                ByVal creation_time As String) As Integer

Description

These APIs allow an ECO to be applied against a Depot Repair.

Parameters

Parameter Name | Required? | Description
demand_dtl_objid | Yes | Object ID of specified part request.
eco_code | Yes | Header Code of ECO to apply.
perf_by | No | Indicates the technician who performed the action. Will default to the current user if not supplied.
creation_time | No | Indicates the time this action is logged. Will default to the current time if a different time is not supplied.

Returns

Value | Meaning
0 | No errors
-1 | Specified demand_dtl object not in database
-2 | Unable to find related mod_level
-3 | Specified eco_hdr object not in database
-4 | Specified activity date is outside of date ranges of eco
-5 | Related apply_to mod_level object not in database
-6 | Part to be replaced does not match eco apply_to part
-7 | Related result_in mod_level object not in database
-8 | Specified user not in database

Examples

Apply ECO 5 against Part Repair 268435470.

JavaScript:

var ret_int = fcdr.apply_eco(268435470,"5","","");

Visual Basic:

Dim ret_int As Integer

ret_int = fcdr.apply_eco(268435470,"5","","")


create_dr_labor | fcSDK Documentation

create_dr_labor

Public Function create_dr_labor(ByVal demand_dtl_objid As Long, _
                          ByVal labor_type As String, _
                          ByVal start_time As String, _
                          ByVal duration As Long, _
                          ByVal billable As Integer, _
                          ByVal bill_to As String, _
                          ByVal wrk_center As String, _
                          ByVal tl_rate As Double, _
                          ByVal perf_by As String, _
                          ByVal creation_time As String) As Integer

Description

This API allows labor performed to be logged against a depot repair part.

Parameters

Parameter Name | Required? | Description
demand_dtl_objid | Yes | Object ID of specified part request.
labor_type | No | Labor type for this Depot Repair change. Will use default if not supplied.
start_time | Yes | Time and date at which labor began.
duration | Yes | Length of time required to do the work, in seconds.
billable | No | Indicates whether labor is billable.
bill_to | No | Indicates who is billed for the labor. Will use default if not supplied.
wrk_center | No | Indicates where labor was perfromed.
tl_rate | No | This is the labor rate for the performing employee.
perf_by | No | Indicates the technician who performed the labor. Will default to the current Clarify user if not supplied.
creation_time | No | Indicates the time this action is logged. Will default to the current time if a different time is not supplied.

Returns

Value | Meaning
0 | No errors
-1 | Specified Start Time is not a valid date/time value
-2 | Specified Duration in seconds is not more than zero
-3 | Specified Labor Type is not in database
-4 | Specified Bill To Labor is not in database
-5 | Specified Work Center is not in database
-6 | Specified User is not in database
-7 | Related Part Request record is not in database
ret_objid | Output - Returns the objid of the newly created time log record

Examples

Create a billable labor segment against Part Repair 268435465. The default labor type was used, it started at 1:00 pm on September 9th, 1998, and lasted 10 minutes (600 seconds). All other defaults are used.

JavaScript:

var ret_int = fcdr.create_dr_labor(268435465, "", "09/09/1998 13:00", 600, 1,
                             "", 0, "", 0, "", "", "", "")

Visual Basic:

Dim ret_int As Integer

ret_int = fcdr.create_dr_labor(268435465, "", "09/09/1998 13:00", 600, 1, _
                             "", 0, "", 0, "", "", "", "")


create_dr_mtl | fcSDK Documentation

create_dr_mtl

Public Function create_dr_mtl(ByVal demand_dtl_objid As Long, _
                         ByVal repair_code As String, _
                         ByVal failure_code As String, _
                         ByVal mod_level As Long, _
                         ByVal billable As Integer, _
                         ByVal bill_to As String, _
                         ByVal wrk_center As String, _
                         ByVal disposition As Integer, _
                         ByVal ref_designator As String, _
                         ByVal notes As String, _
                         ByVal transaction_id As String, _
                         ByVal perf_by As String, _
                         ByVal creation_time As String) As Integer

Description

This API allows usage of material to be logged against a depot repair part.

Parameters

Parameter Name | Required? | Description
demand_dtl_objid | Yes | Object ID of specified part request.
repair_code | No | Repair type for this usage of material. Will use default if not supplied.
failure_code | No | Failure code for the part being serviced. Will use default if not supplied.
mod_level | Yes | Part and revision of the material that was put in use.
billable | No | Indicates whether material usage is billable.
bill_to | No | Indicates who is billed for the material. Will use default if not supplied.
wrk_center | No | Indicates the location where material was used.
disposition | Yes | Indicates how the material relates to the depot repair part.
ref_designator | No | Describes a reference location or designation for the part.
notes | No | Description area for the material usage activity.
transaction_id | No | Indicates the id of the GL transaction associated with this material usage.
perf_by | No | Indicates the technician who performed the labor. Will default to the current Clarify user if not supplied.
creation_time | No | Indicates the time this action is logged. Will default to the current time if a different time is not supplied.

Returns

Value | Meaning
0 | No errors
-1 | Invalid Disposition (must be 0, 1, or 2)
-2 | Cannot find the specified repair code
-3 | Cannot find the specified bill to material
-4 | Cannot find the specified work center
-5 | Specified User is not in database
-6 | Related Part Request Header record is not in database
-7 | Unable to find Standard Cost for part revision
ret_objid | Output - Returns the objid of the newly created material log record

Examples

Apply usage of Part 268435465 against Part Repair 268435466. The job was done by user "db", billable to the customer. All other defaults are used.

JavaScript:

var demand_dtl_objid = 268435466;
var repair_code = "";
var failure_code = "";
var mod_level = 268435465;
var bill_to = "Customer";
var wrk_center = "";
var disposition = "";
var ref_designator = "";
var notes = "";
var transaction_id = "";
var creation_time = "";
var perf_by = "db";
var billable = 1;

var retval = FCDR.create_dr_mtl(demand_dtl_objid, repair_code, failure_code,
mod_level, billable, bill_to, wrk_center,
disposition, ref_designator, notes, transaction_id,
perf_by, creation_time);


modify_dr_labor | fcSDK Documentation

modify_dr_labor

Public Function modify_dr_labor(ByVal time_log_objid As Long, _
                         ByVal labor_type As String, _
                         ByVal start_time As String, _
                         ByVal duration As Long, _
                         ByVal billable As Integer, _
                         ByVal bill_to As String, _
                         ByVal wrk_center As String, _
                         ByVal tl_rate As Double, _
                         ByVal perf_by As String, _
                         ByVal creation_time As String) As Integer

Description

This API allows modification of labor that is logged against a depot repair part.

Parameters

Parameter Name | Required? | Description
time_log_objid | Yes | Object ID of specified time log.
labor_type | No | Labor type for this Depot Repair change.
start_time | No | Time and date at which labor began.
duration | No | Length of time required to do the work, in seconds.
billable | No | Indicates whether labor is billable.
bill_to | No | Indicates who is billed for the labor.
wrk_center | No | Indicates where labor was perfromed.
tl_rate | No | This is the labor rate for the performing employee.
perf_by | No | Indicates the technician who performed the labor.
creation_time | No | Indicates the time this action is logged. Will default to the current time if a different time is not supplied.

Returns

Value | Meaning
0 | No errors
-1 | Specified Duration in seconds is not more than zero
-2 | Specified Labor Type is not in database
-3 | Specified Bill To Labor is not in database
-4 | Specified Work Center is not in database
-5 | Specified Time Log record is not in database
-6 | Related Onsite Log record is not in database
-7 | Related Demand Dtl record is not in database
-8 | Specified User is not in database

Examples

Change labor applied in time_log 268435465. The job was done by user "db" in the Lab, billable to the customer. No other changes are being made at this time.

JavaScript:

var time_log_objid = 268435465;
var labor_type = "";
var creation_time = "";
var perf_by = "db";
var billable = -1;
var start_time = "";
var duration = 0;
var bill_to = "Customer";
var wrk_center = "Lab";
var tl_rate = 0;

var retval = FCDR.modify_dr_labor(time_log_objid, labor_type, start_time,
    duration,billable, bill_to, wrk_center, tl_rate,
    perf_by, creation_time);


modify_dr_mtl | fcSDK Documentation

modify_dr_mtl

Public Function modify_dr_mtl(ByVal mtl_log_objid As Long, _
                         ByVal repair_code As String, _
                         ByVal failure_code As String, _
                         ByVal mod_level As Long, _
                         ByVal billable As Integer, _
                         ByVal bill_to As String, _
                         ByVal wrk_center As String, _
                         ByVal disposition As Integer, _
                         ByVal ref_designator As String, _
                         ByVal notes As String, _
                         ByVal transaction_id As String, _
                         ByVal perf_by As String, _
                         ByVal creation_time As String) As Integer

Description

Theis API allows modification of material that is logged against a depot repair part.

Parameters

Parameter Name | Required? | Description
mtl_log_objid | Yes | Object ID of specified mtl log.
repair_code | No | Repair type for this usage of material.
failure_code | No | Failure code for the part being serviced.
mod_level | No | Part and revision of the material that was put in use.
billable | No | Indicates whether material usage is billable.
bill_to | No | Indicates who is billed for the material.
wrk_center | No | Indicates the location where material was used.
disposition | Yes | Indicates how the material relates to the depot repair part.
ref_designator | No | Describes a reference location or designation for the part.
notes | No | Description area for the material usage activity.
transaction_id | No | Indicates the id of the GL transaction associated with this material usage.
perf_by | No | Indicates the technician who performed the labor.
creation_time | No | Indicates the time this action is logged. Will default to the current time if a different time is not supplied.

Returns

Value | Meaning
0 | No errors
-1 | Specified Repair Code is not in database
-2 | Specified Bill To Material is not in database
-3 | Specified Work Center is not in database
-4 | Specified Material Log record is not in database
-5 | Related Onsite Log record is not in database
-6 | Related Demand Detail record is not in database
-7 | Specified User is not in database
-8 | nable to find Standard Cost for part revision

Examples

Change material applied in mtl_log 268435465. The job was done by user "db" in the Lab, billable to the customer. No other changes are being made at this time.

JavaScript:

var material_log_objid = 268435465;
var repair_code = "";
var failure_code = "";
var mod_level = 0;
var bill_to = "Customer";
var wrk_center = "Lab";
var disposition = "";
var ref_designator = "";
var notes = "";
var transaction_id = "";
var creation_time = "";
var perf_by = "db";
var billable = 1;

var retval = FCDR.modify_dr_mtl(material_log_objid, repair_code, failure_code,
    mod_level, billable, bill_to, wrk_center,
    disposition, ref_designator, notes, transaction_id,
    perf_by, creation_time);


delete_dr_labor | fcSDK Documentation

delete_dr_labor

Public Function delete_dr_labor(ByVal time_log_objid As Long,
                                                ByVal creation_time As String) As Integer

Description

This API will delete labor applied to a depot repair part.

Parameters

Parameter Name | Required? | Description
time_log_objid | Yes | The objid of the time log object to be deleted.
creation_time | No | The time that the labor is being removed from the depot repair part.

Returns

Value | Meaning
0 | No errors
-1 | Specified Time Log record is not in database
-2 | Related Onsite Log record is not in database
-3 | Related Demand Dtl record is not in database

Examples

Delete Time Log 268435463.

JavaScript:

var retval = FCDR.delete_dr_labor(268435463, "");


delete_dr_mtl | fcSDK Documentation

delete_dr_mtl

Public Function delete_dr_mtl(ByVal mtl_log_objid As Long,
                                            ByVal creation_time As String) As Integer

Description

This API will delete material usage applied to a depot repair part.

Parameters

Parameter Name | Required? | Description
mtl_log_objid | Yes | The objid of the material log object to be deleted.
creation_time | No | The time that the material is being removed from the depot repair part.

Returns

Value | Meaning
0 | No errors
-1 | Specified Material Log record is not in database
-2 | Related Onsite Log record is not in database
-3 | Related Demand Detail record is not in database

Examples

Delete material log 268435463.

JavaScript:

var retval = FCDR.delete_dr_mtl(268435463, "");


FCFL API Toolkit for Interfaces | fcSDK Documentation

FCFL API Toolkit for Interfaces

Overview

Many customers have wanted the ability to customize the Clarify environment easily by adding base Clarify functions (such as create/modify addresses, contacts, sites) to web applications.

The First Choice Software FCFL API Toolkit for Interfaces solves these problems, as well as many others. The toolkit is a series of COM functions that you may add to your customizations.

All of the APIs perform the same base functions as the Clarify GUI - all database records are properly written, activity logs are generated to track the API call, and time bombs are added to the system so that business rules can be fired based on the API function call.

While all of the APIs mimic the Clarify base function, many of them provide augmented functionality that Clarify customers have requested. For example, the base Clarify yank function always placed the object in the user's default WIPBin. With the yank API in the toolkit, you have the choice of placing the object in any specific WIPBin for the user, or in the default WIPBin.

The APIs are simple to use. One simple API call is provided for each function, and very few data values must be supplied. The APIs are flexible in that they provide a large number of optional arguments that allow you to customize the API calls as needed.


accept_solution | fcSDK Documentation

accept_solution

Public Function accept_solution(ByVal solution_id As String, _
                                ByVal accept_date As String, _
                                ByVal wipbin As String, _
                                ByVal user_name As String, _
                                ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified solution to be accepted from a dispatched queue. The solution must be currently dispatched to a queue. The date/time of the accept, the WIPBin to place the solution in, and the user performing the accept can be specified. The API can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
solution_id | Yes | The solution to accept
accept_date | No | When was the solution accepted. If this parameter is left blank, it is accepted at the current time
wipbin | No | The WIPBin to place the solution in (for the user who accepted it) If left blank, the solution is placed in the user's default WIPBin
user_name | No | The user who accepted the solution. If left blank, the current user performs the accept
gen_time_bombs | Yes | Should a time bomb record be created for business rule notification?

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified solution
-2 | Solution is not currently in a queue
-3 | Specified user is not a member of the queue
-4 | The specified WIPBIN is not valid for the user
-5 | Could not find the activity string ACCEPT rank equal to 100

Examples

Accept solution number "14" right now for the current user, place in the default WIPBin, and generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fcinter.accept_solution("14", "", "", "", true)

JavaScript:

var ret_int = fcinter.accept_solution("14", "", "", "", true);

Accept solution number '2' at 10PM on November 23rd of 1997 by marty, and place the part request in marty's WIPBin named 'Urgent'. Don't generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fcinter.accept_solution("2", "11/23/97 22:00:00", "Urgent","marty", false)

JavaScript:

var ret_int = fcinter.accept_solution("2", "11/23/97 22:00:00", "Urgent","marty", false);


add_contact_to_contract | fcSDK Documentation

add_contact_to_contract

Public Function add_contact_to_contract(ByVal contract_id As String, _
                                        ByVal f_name As String, _
                                        ByVal l_name As String, _
                                        ByVal phone_num As String, _
                                        ByVal site_id As String) As Integer

Description

This API adds a contact to an existing contract. You must specify the contract ID and the site id.

Parameters

Parameter Name | Required? | Description
contract_id | Yes | ID of contract to add site to
f_name | Yes | First name of contact to be added
l_name | Yes | Last name of contact to be added
phone_num | Yes | Phone number of contact to be added
site_id | Yes | Site where contact to be added is located

Returns

Value | Meaning
0 | No errors
-1 | No Contract Id Specified
-2 | No Contact Information Specified
-3 | No Site Id Specified
-4 | Specified Contract Not Found
-5 | Specified site is not related to this contract
-6 | Specified Contact Not Found
ret_objid | Output - Returns the objid of the contact

Examples

Add John Smith at (512)123-4567 from site "2" to contract "AMD 1"

Visual Basic:

Dim ret_int As Integer
Dim contact_objid As Long

ret_int = fcinter.add_contact_to_contract("AMD 1", "John", "Smith", "5121234567", "2")

If ret_int = 0 Then
  contact_objid = fcinter.ret_objid
End If

JavaScript:

var ret_int = fcinter.add_contact_to_contract("AMD 1", "John", "Smith", "5121234567", "2");

if (ret_int == 0){ var contact_objid = fcinter.ret_objid; }


add_emp_to_bus_org | fcSDK Documentation

add_emp_to_bus_org

Public Function add_emp_to_bus_org(ByVal user_name As String, _
                                   ByVal acct_id As String, _
                                   ByVal role_name As String) As Integer

Description

This API adds an employee as a team member to an account (bus_org) with the specified role. You must specify the user name, account ID, and role name.

Parameters

Parameter Name | Required? | Description
user_name | Yes | User name of account team member
site_id | Yes | Account to add team member to
role_name | No | Role for team member. If left blank, default role is used

Returns

Value | Meaning
0 | No errors
+1 | The employee already exists on the account team with the specified role
-1 | Cannot find the specified user name
-2 | Cannot find the specified account id
-3 | The supplied Account Team role is not found
ret_objid | Output - Returns the objid of the employee

Examples

Add Jeanne to the account team for account "AN_CUST1" with a role of "Executive Sponsor".

Visual Basic:

Dim ret_int As Integer
Dim emp_objid  As Long

ret_int = fcinter.add_emp_to_bus_org("jeanne", "AN_CUST1", "Executive Sponsor")

If ret_int = 0 Then
  emp_objid = fcinter.ret_objid
End If

JavaScript:

var ret_int = fcinter.add_emp_to_bus_org("jeanne", "AN_CUST1", "Executive Sponsor");

if (ret_int == 0){ var emp_objid = fcinter.ret_objid; }


add_site_part_to_contract | fcSDK Documentation

add_site_part_to_contract

Public Function add_site_part_to_contract(ByVal contract_id As String, _
                                          ByVal site_id As String, _
                                          ByVal sp_objid As Long) As Integer

Description

This API adds a site_part to an existing contract. You must specify the contract ID, site id, and site_part instance name.

Parameters

Parameter Name | Required? | Description
contract_id | Yes | ID of contract to add site to
site_id | Yes | ID of site to be added
sp_objid | Yes | objid of site_part to be added

Returns

Value | Meaning
0 | No errors
-1 | No Contract Id specified
-2 | Specified Contract Not Found
-3 | Specified Site Not Found
-4 | Specified Site Part Not Found
ret_objid | Output - Returns the objid of the site part

Examples

Add "MS Word 97" to site "2" to contract "AMD 1"

Visual Basic:

Dim ret_int As Integer
Dim sp_objid   As Long

ret_int = fcinter.add_site_part_to_contract("AMD 1", "2", 268435414)

 If ret_int = 0 Then
   sp_objid = fcinter.ret_objid
 End If

JavaScript:

var ret_int = fcinter.add_site_part_to_contract("AMD 1", "2", 268435414);

 if (ret_int == 0){ var sp_objid = fcinter.ret_objid; }


add_site_to_bus_org | fcSDK Documentation

add_site_to_bus_org

Public Function add_site_to_bus_org(ByVal site_id As String, _
                                    ByVal acct_id As String, _
                                    ByVal role_name As String) As Integer

Description

This API adds a site to an existing account (bus_org). You must specify the account ID and the site id. In addition, you must specify the site's role. In addition, you must specify the role_name. This is either a valid Account Site Role value, or the string "OWNER" for a site that is the owner of the account.

Parameters

Parameter Name | Required? | Description
site_id | Yes | ID of site to be added
acct_id | Yes | ID of account to add site to
role_name | Yes | Role name of site in account

Returns

Value | Meaning
0 | No errors
+1 | The site already exists in the account with the specified role name
-1 | Specified site ID is not found
-2 | Specified account ID is not found
-3 | The supplied Account site role is not found
ret_objid | Output - Returns the objid of the site

Examples

Add site "2" to account "AN_CUST33" with a role of "OWNER".

Visual Basic:

Dim ret_int As Integer
Dim site_objid As Long

ret_int = fcinter.add_site_to_bus_org("2", "AN_CUST33", "OWNER")

 If ret_int = 0 Then
   site_objid = fcinter.ret_objid
 End If

JavaScript:

var ret_int = fcinter.add_site_to_bus_org("2", "AN_CUST33", "OWNER");

 if (ret_int == 0){ var site_objid = fcinter.ret_objid; }


add_site_to_contract | fcSDK Documentation

add_site_to_contract

Public Function add_site_to_contract(ByVal contract_id As String, _
                                     ByVal site_id As String) As Integer

Description

This API adds a site to an existing contract. You must specify the contract ID and the site id.

Parameters

Parameter Name | Required? | Description
contract_id | Yes | ID of contract to add site to
site_id | Yes | ID of site to be added

Returns

Value | Meaning
0 | No errors
-1 | No Contract Id Specified
-2 | No Site Id Specified
-3 | Specified Contract Not Found
-4 | Specified Site Not Found
ret_objid | Output - Returns the objid of the site

Examples

Add site "2" to contract "AMD 1"

Visual Basic:

Dim ret_int As Integer
Dim site_objid As Long

ret_int = fcinter.add_site_to_contract("AMD 1", "2")

 If ret_int = 0 Then
   site_objid = fcinter.ret_objid
 End If

JavaScript:

var ret_int = fcinter.add_site_to_contract("AMD 1", "2");

 if (ret_int == 0){ var site_objid = fcinter.ret_objid; }


add_user_to_queue | fcSDK Documentation

add_user_to_queue

Public Function add_user_to_queue(ByVal queue As String, _
                                  ByVal user_name As String, _
                                  ByVal supervisor As Boolean) As Integer

Description

This API allows you to add a user (or supervisor) to a queue.

Parameters

Parameter Name | Required? | Description
queue | Yes | The name of the queue
user_name | Yes | The user to add
supervisor | Yes | Is this a supervisor (True) or just a user (False)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified queue (or queue not specified)
-2 | Specified user not found
ret_objid | Output - Returns the objid of the user

Examples

Add "joe" to queue "Urgent" as a supervisor

Visual Basic:

Dim ret_int As Integer
Dim user_objid As Long

ret_int = fcinter.add_user_to_queue("Urgent", "joe", true)

 If ret_int = 0 Then
   user_objid = fcinter.ret_objid
 End If

JavaScript:

var ret_int = fcinter.add_user_to_queue("Urgent", "joe", true);

 if (ret_int == 0){ var user_objid = fcinter.ret_objid; }


add_workaround | fcSDK Documentation

add_workaround

add_workaround_list

Public Function add_workaround(ByVal soln_id As String, _
                               ByVal soln_objid As Long, _
                               ByVal workaround As String, _
                               ByVal is_public As Boolean, _
                               ByVal create_date As String, _
                               ByVal res_code As String, _
                               ByVal int_fld1 As String, _
                               ByVal int_val1 As Long, _
                               ByVal int_fld2 As String, _
                               ByVal int_val2 As Long, _
                               ByVal str_fld1 As String, _
                               ByVal str_val1 As String, _
                               ByVal str_fld2 As String, _
                               ByVal str_val2 As String, _
                               ByVal date_fld1 As String, _
                               ByVal date_val1 As String) As Integer

Public Function add_workaround_list(ByVal soln_id As String, _
                                    ByVal soln_objid As Long, _
                                    ByVal workaround As String, _
                                    ByVal is_public As Boolean, _
                                    ByVal create_date As String, _
                                    ByVal res_code As String, _
                                    Optional fld_list As Variant, _
                                    Optional type_list As Variant, _
                                    Optional val_list As Variant) As Integer

Description

These APIs add a new workaround to an existing solution. You must specify the solution ID or the solution's objid, the workaround, if it is public, the workaround creation date, and the resolution code. You may specify additional fields for the workaround, if needed.

Parameters

Parameter Name | Required? | Description
soln_id | No | ID of solution to link workaround to
soln_objid | No | Objid of solution to link workaround to
workaround | No | The text of the workaround
is_public | Yes | Is the workaround public, or not? Used by Clarify Web applications
create_date | No | When was workaround created? If blank, current date/time is used
res_code | No | Resolution code for the workaround. If left blank, default value is used from the list
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | No solution supplied
-2 | Supplied both a soln ID and the objid
-3 | Cannot find the specified solution
-4 | Cannot find the resolution code
ret_objid | Output - Returns the objid of the newly workaround

Examples

Create a new workaround for solution '44' with workaround (public, with default res code). The create was made on November 11, 1998 at 11:00 AM.

Visual Basic:

Dim ret_int As Integer
Dim workaround_objid As Long

ret_int = fcinter.add_workaround("44", 0, _
                                 "No current workaround", true, _
                                 "11/11/1998 11:00:00", "", "", 0, _
                                 "", 0, "", "", "", "", "", "")

 If ret_int = 0 Then
   workaround_objid = fcinter.ret_objid
 End If

JavaScript:

var ret_int = fcinter.add_workaround("44", 0,
                                 "No current workaround", true,
                                 "11/11/1998 11:00:00", "", "", 0,
                                 "", 0, "", "", "", "", "", "");

if (ret_int == 0){ var workaround_objid = fcinter.ret_objid; }


allow_duplicate_contact | fcSDK Documentation

allow_duplicate_contact

Property allow_duplicate_contact As Boolean

Description

This is a property on the base FCINTER class object. By default, it is set to False. If this property is set to True, the create_contact and upate_contact APIs will allow you to create or update a contact to the same first_name, last_name, and phone number as another contact in the database. Note that this only works if you change the unique index (defined by default in Clarify) to be non-unique.

Examples

Create a duplicate contact to one already in the database.

Visual Basic:

allow_duplicate_contact = True

ret_int = fc_inter.create_contact("Joe", "Blow", "1234", "1", "", "", _
      "joe@blow.com", "", "", "", "", "", 0, "", 0, "", "", "", "", "", "")


assign_solution | fcSDK Documentation

assign_solution

Public Function assign_solution(ByVal solution_id As String, _
                                ByVal new_user As String, _
                                ByVal wipbin As String, _
                                ByVal assign_date As String, _
                                ByVal user_name As String, _
                                ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified solution to be assigned to a new user. The solution must not be in closed condition, and the user assigning the solution does not have to be the owner. In base Clarify, the assigner of a solution must be the owner. If either user name is not specified, the "current" user is used. The date/time of the assignment, and the WIPBin to place the solution in can also be specified. Allowing a WIPBin other than the default one is also an augmentation from base Clarify. The API can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
solution_id | Yes | The solution to assign
new_user | No | The user who the solution is assigned to. If left blank, it is assigned to the current user
wipbin | No | The WIPBin to place the solution in (for the user who is assigned the solution). If left blank, it is placed in the user's default WIPBin
assign_date | No | When was the solution assigned. If this parameter is left blank, it is assigned at the current time
user_name | No | The user who assigned the solution. If left blank, the current user performs the assign.
gen_time_bombs | Yes | Should a time bomb record be created for business rule notification?

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified solution
-2 | The specified solution is currently closed
-3 | Specified user (to assign to) is not found
-4 | The specified WIPBIN is not valid for the user
-5 | Specified user (who performed the assign) is not found
-6 | Could not find gbst_elm string for ASSIGN with rank equal to 10500

Examples

Assign solution number '154' to user 'marty'. The assign is performed by the current user, is placed in the default WIPBin and is assigned at the current time. Generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fcinter.assign_solution("154", "marty", "", "", "", true)

JavaScript:

var ret_int = fcinter.assign_solution("154", "marty", "", "", "", true);

Assign solution number '4' at 10PM on November 23rd of 1997 to marty, and place the solution in marty's WIPBin named 'Urgent'. Assign should be logged as performed by sam. Don't generate a time bomb

Visual Basic:

Dim ret_int As Integer

ret_int = fcinter.assign_solution("4", "marty", "Urgent", _
     "11/23/97 22:00:00", "sam", false)

JavaScript:

var ret_int = fcinter.assign_solution("4", "marty", "Urgent",
     "11/23/97 22:00:00", "sam", false);


create_address | fcSDK Documentation

create_address

create_address_list

Public Function create_address(ByVal addr1 As String, _
                               ByVal addr2 As String, _
                               ByVal city As String, _
                               ByVal state As String, _
                               ByVal short_state As Boolean, _
                               ByVal zip As String, _
                               ByVal country As String, _
                               ByVal time_zone As String, _
                               ByVal int_fld1 As String, _
                               ByVal int_val1 As Long, _
                               ByVal int_fld2 As String, _
                               ByVal int_val2 As Long, _
                               ByVal str_fld1 As String, _
                               ByVal str_val1 As String, _
                               ByVal str_fld2 As String, _
                               ByVal str_val2 As String, _
                               ByVal date_fld1 As String, _
                               ByVal date_val1 As String) As Integer

Public Function create_address_list(ByVal addr1 As String, _
                                    ByVal addr2 As String, _
                                    ByVal city As String, _
                                    ByVal state As String, _
                                    ByVal short_state As Boolean, _
                                    ByVal zip As String, _
                                    ByVal country As String, _
                                    ByVal time_zone As String, _
                                    Optional fld_list As Variant, _
                                    Optional type_list As Variant, _
                                    Optional val_list As Variant) As Integer

Description

These APIs create new addresses in the database. You must specify one of the two address lines, the city, state, country, and time zone.

Parameters

Parameter Name | Required? | Description
addr1 | No | Address line 1
addr2 | No | Address line 2
city | Yes | City
state | Yes | State
short_state | Yes | Is the "state" field the "short state name" (Ex: TX), or the long state name (Ex: Texas)
zip | Yes | Zipcode
country | Yes | Country
time_zone | Yes | Time zone
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
1 | No errors
-1 | Either address or address2 must have data
-2 | City must be specified
-3 | State must be specified
-4 | Zipcode must be specified
-5 | Country must be specified
-6 | Time zone must be specified
-7 | The specified country is not found
-8 | The specified state is not found for the country
-9 | The specified time zone is not found for the country
ret_objid | Output - Returns the objid of the new address

Examples

Create an address.

Visual Basic:

Dim ret_int As Integer
Dim address_objid  As Long

ret_int = fcinter.create_address("101 Main St.", "Suite 100",_
                                 "Austin", "TX", true, "78759", "USA", _
                                 "CST", "", 0, "", 0, "", "", _
                                 "", "", "", "")

 If ret_int = 0 Then
   address_objid = fcinter.ret_objid
 End If

JavaScript:

var ret_int = fcinter.create_address("101 Main St.", "Suite 100",
                                 "Austin", "TX", true, "78759", "USA",
                                 "CST", "", 0, "", 0, "", "",
                                 "", "", "", "");

 if (ret_int == 0){ var address_objid = fcinter.ret_objid; }


create_bom | fcSDK Documentation

create_bom

Public Function create_bom(ByVal parent_part As String, _
                           ByVal parent_dom As String, _
                           ByVal parent_rev As String, _
                           ByVal child_part As String, _
                           ByVal child_dom As String, _
                           ByVal child_rev As String, _
                           ByVal quantity As Long) As Integer

Description

This API places a revision of a part in a bill of materials for another part/revision. You must specify the parent part/rev as well as the child part/rev. Finally, you must specify how many of the child parts are contained in the parent part.

Parameters

Parameter Name | Required? | Description
parent_part | Yes | Part number of the parent part
parent_dom | Yes | Domain of the parent part
parent_rev | Yes | Mod_level of the parent part
child_part | Yes | Part number of the child part
child_dom | Yes | Domain of the child part
child_rev | Yes | Mod_level of the child part
quantity | Yes | How many of the child part/rev are in the parent part/rev

Returns

Value | Meaning
0 | No errors
-1 | Quantity must be positive
-2 | Parent part and child part may not be the same part
-3 | Cannot find the parent part/rev
-4 | Cannot find the child part/rev
-5 | The parent part is already in the BOM of the child part. Cannot have circular BOMs
ret_objid | Output - Returns the objid of the new address

Examples

Add 2 batteries (rev '') in the BOM of "Computer rev 1.0".

Visual Basic:

Dim ret_int As Integer
Dim bom_objid  As Long

ret_int = fcinter.create_bom("Computer", "Product","1.0", _
                             "Battery","Quantity", "", 2)

 If ret_int = 0 Then
   bom_objid = fcinter.ret_objid
 End If

JavaScript:

var ret_int = fcinter.create_bom("Computer", "Product","1.0",
                             "Battery","Quantity", "", 2);

 if (ret_int == 0){ var bom_objid = fcinter.ret_objid; }


create_contact | fcSDK Documentation

create_contact

create_contact_list

Public Function create_contact(ByVal first As String, ByVal last As String, _
       ByVal phone As String, ByVal site_id As String, ByVal role As String, _
       ByVal fax As String, ByVal email As String, ByVal mail_stop As String, _
       ByVal the_title As String, ByVal hours As String, _
       ByVal salutation As String, _
       ByVal int_fld1 As String, ByVal int_val1 As Long, ByVal int_fld2 As String, _
       ByVal int_val2 As Long, ByVal str_fld1 As String, ByVal str_val1 As String, _
       ByVal str_fld2 As String, ByVal str_val2 As String, _
       ByVal date_fld1 As String, ByVal date_val1 As String) As Integer

Public Function create_contact_list(ByVal first As String, _
       ByVal last As String, ByVal phone As String, ByVal site_id As String, _
       ByVal role As String, ByVal fax As String, ByVal email As String, _
       ByVal mail_stop As String, ByVal the_title As String, _
       ByVal hours As String, ByVal salutation As String, _
       Optional fld_list As Variant, Optional type_list As Variant, _
       Optional val_list As Variant) As Integer

Description

These APIs create a contact in the database. The APIs also create the contact role record.

Note: If you wish to create a duplicate contact (same first, last, and phone as another contact in the database), you may use the allow_duplicate_contact property.

Parameters

Parameter Name | Required? | Description
first | Yes | First name of the contact
last | Yes | Last name of the contact
phone | Yes | Phone number of the contact
site_id | Yes | Site ID for the contact role to create
role | Yes | The contact role to create
fax | No | Fax number for contact
email | No | Email address for contact
mail_stop | No | Mail stop for contact
the_title | No | Job title for contact
hours | No | Job hours for contact
salutation | No | Salutation for contact
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | First, Last, Phone not supplied for contact
-2 | Could not find the specified site
-3 | Could not find specified contact role in list
-4 | A contact with the same first name, last name and phone already exists
-5 | Cannot find the activity string CREATE CONTACT rank equal to 14000
ret_objid | Output - Returns the objid of the new contact

Examples

Add a new contact to the database.

Visual Basic:

Dim ret_int As Integer

Dim contact_objid As Long

ret_int = fcinter.create_contact("Mary", "Smith", "555-1213", _
          "43", "End User", "555-1314", "mary@com.net", "Stop 33", _
          "Boss", "", "Ms.", "", 0, "", 0, _
          "", "", "", "", "", "")

 If ret_int = 0 Then
   contact_objid = fcinter.ret_objid
 End If

JavaScript:

var ret_int = fcinter.create_contact("Mary", "Smith", "555-1213",
              "43", "End User", "555-1314", "mary@com.net", "Stop 33",
              "Boss", "", "Ms.", "", 0, "", 0,
              "", "", "", "", "", "");

 if (ret_int == 0){ var contact_objid = fcinter.ret_objid; }


create_country | fcSDK Documentation

create_country

Public Function create_country(ByVal cname As String, _
                               ByVal c_code As Long, _
                               ByVal the_currency As String, _
                               ByVal symbol As String, _
                               ByVal desc As String, _
                               ByVal conv_rate As Double, _
                               ByVal iso_code As String) As Integer

Description

This API creates a country object in Clarify, and can also create a currency object. If you specify a country name without a currency name, the country will be created without a related currency name. If a currency name is given, and it matches an existing currency name, that currency is used for the country. If no match is found, the data provided in the API will be used for the new currency record. The country code is added to the country object, where the symbol, description, iso_code, and conversion rate are used in the new currency object.

The API checks both the country name and the ISO code. If either is found in the Database, then the API cannot create a new country.

Parameters

Parameter Name | Required? | Description
cname | Yes | Country name to add
c_code | Yes | Country code (phone calling code) for the country
the_currency | No | The currency name to use for the country. If found in the DB, that currency is used. If not found, a new currency object is created. If blank, no currency is used for this country
symbol | No | Symbol for the currency. Only used if new currency is created
desc | No | Description for the currency. Only used if new currency is created
conv_rate | No | Conversion rate for the currency. Only used if new currency is created
iso_code | No | ISO Code for the currency. Only used if new currency is created

Returns

Value | Meaning
0 | No errors
-1 | Country name is already found in the Database
-2 | Country code is already found in the Database

Examples

Add a country named 'Fooland' with a country code of 42. Add no new currency.

Visual Basic:

Dim ret_int As Integer

ret_int = fcinter.create_country("Fooland", 42, "", "", "", 0, "")

JavaScript:

var ret_int = fcinter.create_country("Fooland", 42, "", "", "", 0, "")

Add a country named 'Fooland' with a country code of 42. Add a currency for the country.

Visual Basic:

Dim ret_int As Integer

ret_int = fcinter.create_country("Fooland", 42, "FD", "F$", _
                                 "Foo Dollars", 4.3, "FDD")

JavaScript:

var ret_int = fcinter.create_country("Fooland", 42, "FD", "F$",
                                     "Foo Dollars", 4.3, "FDD")


create_employee | fcSDK Documentation

create_employee

create_employee_list

Public Function create_employee(
            ByVal first_name As String, ByVal last_name As String, _
            ByVal login_name As String, ByVal password As String, _
            ByVal site_id As String, ByVal e_mail As String, _
            ByVal phone As String, ByVal pager As String, _
            ByVal online_priv_class As String, ByVal offline_priv_class As String, _
            ByVal Id As String, ByVal is_active As Boolean, _
            ByVal allow_proxy As Boolean, ByVal start_date As String, _
            ByVal supervisor As String, ByVal work_group As String, _
            ByVal work_group_start As String, ByVal labor_rate As String, _
            ByVal is_supervisor As Boolean, ByVal is_fe As Boolean, _
            ByVal normal_biz_high As String, ByVal normal_biz_mid As String, _
            ByVal normal_biz_low As String, ByVal after_biz_high As String, _
            ByVal after_biz_mid As String, ByVal after_biz_low As String, _
            ByVal def_wipbin_title As String, ByVal rc_config As String, _
            ByVal def_tablespace As String, ByVal temp_tablespace As String, _
            ByVal int_fld1 As String, ByVal int_val1 As Long, _
            ByVal int_fld2 As String, ByVal int_val2 As Long, _
            ByVal str_fld1 As String, ByVal str_val1 As String, _
            ByVal str_fld2 As String, ByVal str_val2 As String, _
            ByVal date_fld1 As String, ByVal date_val1 As String) As Integer

Public Function create_employee_list(
            ByVal first_name As String, ByVal last_name As String, _
            ByVal login_name As String, ByVal password As String, _
            ByVal site_id As String, ByVal e_mail As String, _
            ByVal phone As String, ByVal pager As String, _
            ByVal online_priv_class As String, ByVal offline_priv_class As String, _
            ByVal Id As String, ByVal is_active As Boolean, _
            ByVal allow_proxy As Boolean, ByVal start_date As String, _
            ByVal supervisor As String, ByVal work_group As String, _
            ByVal work_group_start As String, ByVal labor_rate As String, _
            ByVal is_supervisor As Boolean, ByVal is_fe As Boolean, _
            ByVal normal_biz_high As String, ByVal normal_biz_mid As String, _
            ByVal normal_biz_low As String, ByVal after_biz_high As String, _
            ByVal after_biz_mid As String, ByVal after_biz_low As String, _
            ByVal def_wipbin_title As String, ByVal rc_config As String, _
            ByVal def_tablespace As String, ByVal temp_tablespace As String, _
            Optional fld_list As Variant, Optional type_list As Variant, _
            Optional val_list As Variant) As Integer

Description

This API creates an employee in Clarify. It actually creates an employee record, a user record, and a wipbin record. In addition, it creates a user/login in the database system tables.

Important Note for MSSQL databases only: Beginning with Version 3.4.3, SQL statements: CREATE LOGIN and CREATE USER are used instead of stored procedures: sp_adduser and sp_addlogin. This has the following implications:

  • This API no longer supports MS SQL 2000 due to the fact that CREATE LOGIN and CREATE USER statements were introduced in version 2005.
  • It is no longer required for database users to be members of 'db_owner' role at the database level to be able to create new user logins. To the contrary, it is now recommended that these users do not belong to 'db_owner' role due to security concerns.
  • However, it is required for such database users to have 'securityadmin' server role granted, and to be members of 'db_accessadmin' and 'db_securityadmin' roles at the database level.

Note: If you wish to create an employee without creating a user at the database level, set the FCINTER.UseDatabaseLogins property to False.

Parameters

Parameter Name | Required? | Description
first_name | Yes | Employee First Name
last_name | Yes | Employee Last Name
login_name | Yes | Employee Login Name
password | Yes | Employee's Password
site_id | Yes | Site ID of where employee is located. Must be a valid Site Id.
e_mail | Yes | Employee's Email Address
phone | No | Employee's Phone Number
pager | No | Employee's Pager/Beeper Number
online_priv_class | Yes | Privilege Class. Must be an existing privilege class.
offline_priv_class | No | Offline Privilege Class.
id | No | Employee's Id.
is_active | Yes | Is this employee an active employee?
allow_proxy | Yes | Allow proxy use
start_date | No | Employee Start Date
supervisor | No | Employee's supervisor. This value should be the login_name of an existing employee that is designated as a supervisor.
work_group | No | Employee's workgroup. Must be a valid workgroup, or left blank. If left blank, the default workgroup will be used.
work_group_start | No | Date that the employee started in the workgroup.
labor_rate | No | Employee's Labor Rate
is_supervisor | Yes | Is this employee a supervisor?
is_fe | Yes | Is this employee a field engineer?
normal_biz_high | No | Notification Preference - Normal Business Hours - High Priority
normal_biz_mid | No | Notification Preference - Normal Business Hours - Medium Priority
normal_biz_low | No | Notification Preference - Normal Business Hours - Low Priority
after_biz_high | No | Notification Preference - After Business Hours - High Priority
after _biz_mid | No | Notification Preference - After Business Hours - Medium Priority
after _biz_low | No | Notification Preference - After Business Hours - Low Priority
def_wipbin_title | No | Title of employee's default wipbin. If left blank, it will be "default"
rc_config | No | Resource Config employee should be placed in. If left blank, the employee will be placed in the baseline resource config.
def_tablespace | No | Oracle only - Default Tablespace for user. If left blank, the user's default tablespace will be set to "users".
temp_tablespace | No | Oracle only - Temporary Tablespace for user. If left blank, the user's temporary tablespace will be set to "temp".
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | First Name is required
-2 | Last Name is required
-3 | Login Name is required
-4 | Password is required
-5 | Site Id is required
-6 | Email Address is required
-7 | Online Privilege Class is required
-8 | The supplied workgroup was not found
-9 | Could not find the specified site
-10 | Could not find the specified privilege class
-11 | Could not find the specified offline privilege class
-12 | Could not find an offline privilege class
-13 | Could not find the specified supervisor
-14 | A user with the same login name already exists
-15 | Could not find the specified resource config
-16 | Could not find the baseline resource config
-17 | A user with the same username already exists in the system tables
-18 | Unable to create the database user/login
-19 | Oracle database only: Login Name can only contain alphanumeric characters from your database character set and the underscore (_), dollar sign ($), and pound sign (#). It also must begin with an alphabetic character.
ret_objid | Output - Returns the objid of the employee
ret_objid2 | Output - Returns the objid of the user

Examples

Add a new employee.

Visual Basic:

   first_name = "Joe"
   last_name = "User"
   login_name = "joe_user"
   password = "password"
   site_id = "INT1"
   e_mail = first_name + "@company.com"
   online_priv_class = "CSR"
   offline_priv_class = "Offline User"
   Id = "100"
   is_active = True
   allow_proxy = True
   is_supervisor = True
   is_fe = True
   labor_rate = "100.00"
   start_date = "1/1/2000"
   supervisor = "sa"
   work_group = "Quality Engineer"
   work_group_start = "12/27/2002"
   normal_biz_high = "Notifier"
   normal_biz_mid = "Notifier"
   normal_biz_low = "Notifier"
   after_biz_high = "Digital Pager"
   after_biz_mid = "Digital Pager"
   after_biz_low = "Digital Pager"
   def_wipbin_title = "my stuff"
   rc_config = "custom"
   phone = "512-418-2905"
   pager = "1-800-skytel x101"
   def_tablespace = ""
   temp_tablespace = ""

int_fld1 = ""
int_val1 = 0
int_fld2 = ""
int_val2 = 0
str_fld1 = ""
str_val1 = ""
str_fld2 = ""
str_val2 = ""
date_fld1 = ""
date_val1 = ""

ret_int = fcinter.create_employee(first_name, last_name, _
                     login_name, password, site_id, e_mail, _
                     phone, pager, online_priv_class, offline_priv_class, _
                     Id, is_active, _
                     allow_proxy, start_date, _
                     supervisor, work_group, _
                     work_group_start, labor_rate, _
                     is_supervisor, is_fe, _
                     normal_biz_high, normal_biz_mid, _
                     normal_biz_low, after_biz_high, _
                     after_biz_mid, after_biz_low, _
                     def_wipbin_title, rc_config, _
                     def_tablespace, temp_tablespace, _
                     int_fld1, int_val1, _
                     int_fld2, int_val2, _
                     str_fld1, str_val1, _
                     str_fld2, str_val2, _
                     date_fld1, date_val1)

If ret_int = 0
  EmployeeObjid = fcinter.ret_objid
  UserObjid = fcinter.ret_objid2
End If

JavaScript:

  first_name = "Joe"
  last_name = "User"
  login_name = "joe_user"
  password = "password"
  site_id = "INT1"
  e_mail = first_name + "@company.com"
  online_priv_class = "CSR"
  offline_priv_class = "Offline User"
  Id = "100"
  is_active = True
  allow_proxy = True
  is_supervisor = True
  is_fe = True
  labor_rate = "125.00"
  start_date = "1/1/2000"
  supervisor = "sa"
  work_group = "Quality Engineer"
  work_group_start = "12/27/2002"
  normal_biz_high = "Notifier"
  normal_biz_mid = "Notifier"
  normal_biz_low = "Notifier"
  after_biz_high = "Digital Pager"
  after_biz_mid = "Digital Pager"
  after_biz_low = "Digital Pager"
  def_wipbin_title = "my stuff"
  rc_config = "custom"
  phone = "512-418-2905"
  pager = "1-800-skytel x101"
  def_tablespace = ""
  temp_tablespace = ""
  int_fld1 = '';
  int_val1 = 0;
  int_fld2 = '';
  int_val2 = 0;
  str_fld1 = '';
  str_val1 = '';
  str_fld2 = '';
  str_val2 = '';
  date_fld1 = '';
  date_val1 = '';

 var ret_int = fcinter.create_employee(first_name, last_name,
   login_name, password,
   site_id, e_mail,
   phone, pager,
   online_priv_class,offline_priv_class,
   Id, is_active,
   allow_proxy, start_date,
   supervisor, work_group,
   work_group_start, labor_rate,
   is_supervisor, is_fe,
   normal_biz_high, normal_biz_mid,
   normal_biz_low, after_biz_high,
   after_biz_mid, after_biz_low,
   def_wipbin_title, rc_config,
   def_tablespace, temp_tablespace,
   int_fld1, int_val1,
   int_fld2, int_val2,
   str_fld1, str_val1,
   str_fld2, str_val2,
   date_fld1, date_val1);

   if (ret_int == 0) {
      var EmployeeObjid = fcinter.ret_objid;
      var UserObjid = fcinter.ret_objid2;
   }


create_interact | fcSDK Documentation

create_interact

create_interact_list

Public Function create_interact(ByVal the_title As String, _
                     ByVal the_notes As String, ByVal first As String, _
                     ByVal last As String, ByVal phone As String, _
                     ByVal zipcode As String, ByVal reason1 As String, _
                     ByVal reason2 As String, ByVal prod_name As String, _
                     ByVal direction As String, ByVal the_type As String, _
                     ByVal origin As String, ByVal done_in_one As Boolean, _
                     ByVal result As String, ByVal fee_based As Boolean, _
                     ByVal pay_option As String, ByVal lead_source As String, _
                     ByVal start_date As String, ByVal duration As Long, _
                     ByVal wait_time As Long, ByVal entered_time As Long, _
                     ByVal user_name As String, ByVal gen_time_bomb As Boolean, _
                     ByVal int_fld1 As String, ByVal int_val1 As Long, _
                     ByVal str_fld1 As String, ByVal str_val1 As String, _
                     ByVal str_fld2 As String, ByVal str_val2 As String, _
                     ByVal date_fld1 As String, ByVal date_val1 As String) As Integer

Public Function create_interact_list(ByVal the_title As String, _
                     ByVal the_notes As String, ByVal first As String, _
                     ByVal last As String, ByVal phone As String, _
                     ByVal zipcode As String, ByVal reason1 As String, _
                     ByVal reason2 As String, ByVal prod_name As String, _
                     ByVal direction As String, ByVal the_type As String, _
                     ByVal origin As String, ByVal done_in_one As Boolean, _
                     ByVal result As String, ByVal fee_based As Boolean, _
                     ByVal pay_option As String, ByVal lead_source As String, _
                     ByVal start_date As String, ByVal duration As Long, _
                     ByVal wait_time As Long, ByVal entered_time As Long, _
                     ByVal user_name As String, ByVal gen_time_bomb As Boolean, _
                     Optional fld_list As Variant, Optional type_list As Variant, _
                     Optional val_list As Variant) As Integer

Description

This API creates an interaction in Clarify. An interaction stores information on communications with contacts. This API saves the reason for the interaction, if the interaction is product related, how much time was spent with the contact, and so on. It actually creates an interact record and an activity log entry, and allows time bomb records to be created.

Parameters

Parameter Name | Required? | Description
the_title | No | Title of the interaction
the_notes | No | Notes for the interaction
first | Yes | Contact First Name
last | Yes | Contact Last Name
phone | Yes | Contact Phone
zipcode | No | Contact Zip Code
reason1 | No | Choice from Interaction Reason_1 User-Defined List
reason2 | No | Choice from Interaction Reason_2 User-Defined List
prod_name | No | Choice from Interaction Product User-Defined List
direction | No | Choice from Interaction Direction User-Defined List
the_type | No | Choice from Interaction Type User-Defined List
origin | No | Choice from Interaction Origin User-Defined List
done_in_one | Yes | Indicates whether interaction is done-in-one (true) or not (false)
result | No | Choice from Interaction Result Code User-Defined List
fee_based | Yes | Indicates whether interaction is fee-based (true) or not (false)
pay_option | No | Choice from Interaction Pay Option User-Defined List
lead_source | No | Name of person who provided lead
start_date | No | Interaction Start Date and Time
duration | No | Length of the Interaction
wait_time | No | Waiting time for the Interaction
entered_time | No | Entered Length of the Interaction
user_name | No | User that performed the Interaction
gen_time_bomb | Yes | Should a time bomb be added to the system for business rule firing?
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | Specified User not found
-2 | Supplied Reason1 code is invalid
-3 | Supplied Reason2 code is invalid
-4 | Supplied Product Name is invalid
-5 | Supplied Direction is invalid
-6 | Supplied Type is invalid
-7 | Supplied Origin is invalid
-8 | Supplied Result Code is invalid
-9 | Supplied Pay Option is invalid
-10 | Specified Lead source not found
-11 | Specified Contact not found
-12 | Interaction duration is negative or equal zero
-13 | Bad wait time supplied. Must be > 0
-14 | Cannot find the activity string with rank = 500
-15 | Specified User's Employee record not found
ret_objid | Output - Returns the objid of the Interaction
ret_id_num | Output - Returns the Interaction id number

Examples

Create a new Interaction

Visual Basic:

the_title = ""
the_notes = ""
first = "Joe"
last = "Contact"
phone = "512-123-4567"
zipcode = "02021"
reason1 = "Order"
reason2 = ""
prod_name = ""
direction = "Inbound"
the_type = "Call"
origin = "800#"
done_in_one = True
result = "Placed Order"
fee_based = False
pay_option = "Credit Card"
lead_source = ""
start_date = "12/27/2002 10:30"
duration = 5
wait_time = 0
entered_time = 0
user_name = "sam"
gen_time_bomb = False
int_fld1 = ""
int_val1 = 0
str_fld1 = ""
str_val1 = ""
str_fld2 = ""
str_val2 = ""
date_fld1 = ""
date_val1 = ""

ret_int = fcinter.create_interact(the_title, the_notes, first, last, _
                     phone, zipcode, reason1, reason2, _
                     prod_name, direction, the_type, origin, _
                     done_in_one, result, fee_based, pay_option, _
                     lead_source, start_date, duration, _
                     wait_time, entered_time, user_name, _
                     gen_time_bomb, _
                     int_fld1, int_val1, _
                     str_fld1, str_val1, _
                     str_fld2, str_val2, _
                     date_fld1, date_val1)

 If ret_int = 0
   InteractionObjid = fcinter.ret_objid
   InteractionId = fcinter.ret_id_num
 End If

JavaScript:

the_title = "";
the_notes = "";
first = "Joe";
last = "Contact";
phone = "512-123-4567";
zipcode = "02021";
reason1 = "Order";
reason2 = "";
prod_name = "";
direction = "Inbound";
the_type = "Call";
origin = "800#";
done_in_one = True;
result = "Placed Order";
fee_based = False;
pay_option = "Credit Card";
lead_source = "";
start_date = "12/27/2002 10:30";
duration = 5;
wait_time = 0;
entered_time = 0;
user_name = "sam";
gen_time_bomb = False;
int_fld1 = "";
int_val1 = 0;
str_fld1 = "";
str_val1 = "";
str_fld2 = "";
str_val2 = "";
date_fld1 = "";
date_val1 = "";

var ret_int = fcinter.create_interact(the_title, the_notes, first, last,
                   phone, zipcode, reason1, reason2,
                   prod_name, direction, the_type, origin,
                   done_in_one, result, fee_based, pay_option,
                   lead_source, start_date, duration,
                   wait_time, entered_time, user_name,
                   gen_time_bomb,
                   int_fld1, int_val1,
                   str_fld1, str_val1,
                   str_fld2, str_val2,
                   date_fld1, date_val1);

   if(ret_int == 0) {
      var InteractionObjid = fcinter.ret_objid;
      var InteractionId = fcinter.ret_id_num;
   }


create_price_inst | fcSDK Documentation

create_price_inst

Public Function create_price_inst(ByVal part_num As String, _
                                  ByVal domain As String, _
                                  ByVal mod_level As String, _
                                  ByVal price_prog As String, _
                                  ByVal price_type As Integer, _
                                  ByVal priced_qty As Long, _
                                  ByVal price As String, _
                                  ByVal start_date As String, _
                                  ByVal end_date As String) As Integer

Description

This API creates a price instance object in Clarify. They are currently only enabled for simple price instances (not child/parent pricing, only fixed pricing). You must specify the part/domain/revision of the part to price, and the price program (schedule). You must also specify the quantity to be priced, as well as the start and end date of the price.

Note that standard Clarify checks for dates apply for these price schedules - you may not have two prices (in the same schedule for the same part and quantity) overlap. And, you cannot have the price's dates extend before or after the dates for the price program.

This API can also be used to create price instances for standard costs. Just use the predefined standard cost price program.

The non-business rule version of the API returns the objid of the created price instance record.

Parameters

Parameter Name | Required? | Description
part_num | Yes | Part number to price
domain | Yes | Domain of the part
mod_level | Yes | Revision to price
price_prog | Yes | Name of the price program
price_type | Yes | What kind of price. 0 = Fixed price, 1 = Percent of product list, 2 = Option price. Currently, only 0, 1 supported
priced_qty | Yes | How many units in the price instance. Usually, this is = 1
price | Yes | What is the price of the part?
start_date | No | Start date of the price. If blank, start date of the program is used
end_date | No | End date of the price. If blank, end date of the program is used

Returns

Value | Meaning
0 | No errors
-1 | Part number was not found
-2 | Revision for the part was not found
-3 | Could not find the price program
-4 | The price type is not valid
-5 | The quantity supplied is < 1
-6 | The price start date is earlier than the program start date
-7 | The price end date is after the program end date
-8 | The price start date is later than the price end date
-9 | This price instance has dates that overlap another price instance for this part in this price program
-10 | The supplied price type is not yet supported
-11 | Could not open database for SQL query
ret_objid | Output - Returns the objid of the new price instance

Examples

Add a price for quantity 1 of "MS Word" to the "Spring" price list. Give dates and a price.

Visual Basic:

Dim ret_int As Integer
Dim price_inst_objid As Long

ret_int = fcinter.create_price_inst("MS Word", "Product", "","Spring", _
                                    0, 1, "45.54","3/2/2000", "6/1/2000")

 If ret_int = 0 Then
   price_inst_objid = fcinter.ret_objid
 End If

JavaScript:

var ret_int = fcinter.create_price_inst("MS Word", "Product", "","Spring",
                0, 1, "45.54","3/2/2000", "6/1/2000");

if (ret_int == 0){ var price_inst_objid = fcinter.ret_objid; }

Price a part for quantity 2 in the standard price list, using the dates of the price program.

Visual Basic:

Dim ret_int As Integer
Dim price_inst_objid As Long

ret_int = fcinter.create_price_inst("MS Word", "Product", "",_
                                    "US Std Price List", _
                                    0, 2, "99.99", "", "")

 If ret_int = 0 Then
   price_inst_objid = fcinter.ret_objid
 End If

JavaScript:

var ret_int = fcinter.create_price_inst("MS Word", "Product", "",
  "US Std Price List", 0, 2, "99.99", "", "");

 if (ret_int == 0){ var price_inst_objid = fcinter.ret_objid; }


create_product_bin | fcSDK Documentation

create_product_bin

Public Function create_product_bin(ByVal bin_name As String, _
                                   ByVal site_id As String, _
                                   ByVal bin_objid As Long, _
                                   ByVal description As String, _
                                   ByVal prim_supp As Long, _
                                   ByVal sec_supp As Long, _
                                   ByVal user_name As String, _
                                   ByVal create_date As String) As Integer

Description

This API allows you to create a product bin either at a site, or underneath another product bin. You must supply a (unique for the site) bin name, and the site at which the bin is created. If the bin is to be underneath another bin, you must supply the objid of the parent bin. If you supply no parent bin, the new bin is created at the site level. You may optionally also specify a description for the bin, as well as the objids for support employees. Finally you may specify who created the bin, and when they created it. The API returns the objid of the newly-created bin.

Parameters

Parameter Name | Required? | Description
bin_name | Yes | Name of the bin to create
site_id | Yes | ID of the site at which the bin is created
bin_objid | Yes | Objid of the bin to install the new bin under. If the new bin is to be installed at the site itself, set this argument to -1
description | No | Description of the bin
prim_supp | No | Objid of the primary support employee. Note this is an employee, not a user. If you do not wish to supply a support employee, set this argument to -1
sec_supp | No | Objid of the secondary support employee. Note this is an employee, not a user. If you do not wish to supply a support employee, set this argument to -1
user_name | No | Name of the user who created the bin. If blank, the current user is used
create_date | No | When was the bin created. If blank, the current date/time is used

Returns

Value | Meaning
0 | No errors
-1 | The specified site could not be found
-2 | A product bin with the specified bin name already exists at the specified site
-3 | The specified parent bin cannot be found
-4 | The specified parent bin was found, but is not located at the specified site
-5 | Could not locate the specified primary support employee
-6 | Could not locate the specified secondary support employee
-7 | Could not locate the "Created" activity log string
-8 | The specified user name could not be found
ret_objid | Output - Returns the objid of the new product bin

Examples

Create a bin named "Hardware" at the site who has a site ID of "42". Add a description, and set up a primary support employee. "Kent" did the create at the current date/time

Visual Basic:

Dim ret_int As Integer
Dim bin_objid  As Long

ret_int = fcinter.create_product_bin("Hardware", "42", -1, _
        "Description here", 268435457, -1, "kent", "")

 If ret_int = 0 Then
   bin_objid = fcinter.ret_objid
 End If

JavaScript:

var ret_int = fcinter.create_product_bin("Hardware", "42", -1, "Description here", 268435457, -1, "kent", "");

 if (ret_int == 0){ var bin_objid = fcinter.ret_objid; }


create_soln | fcSDK Documentation

create_soln

create_soln_list

Public Function create_soln(ByVal the_title As String, _
                            ByVal description As String, _
                            ByVal workaround As String, _
                            ByVal is_public As Boolean, _
                            ByVal res_code As String, _
                            ByVal queue_name As String, _
                            ByVal create_date As String, _
                            ByVal user_name As String, _
                            ByVal create_time_bomb As Boolean, _
                            ByVal int_fld1 As String, ByVal int_val1 As Long, _
                            ByVal int_fld2 As String, ByVal int_val2 As Long, _
                            ByVal str_fld1 As String, ByVal str_val1 As String, _
                            ByVal str_fld2 As String, ByVal str_val2 As String, _
                            ByVal date_fld1 As String, _
                            ByVal date_val1 As String) As Integer

Public Function create_soln_list(ByVal the_title As String, _
                                 ByVal description As String, _
                                 ByVal workaround As String, _
                                 ByVal is_public As Boolean, _
                                 ByVal res_code As String, _
                                 ByVal queue_name As String, _
                                 ByVal create_date As String, _
                                 ByVal user_name As String, _
                                 ByVal create_time_bomb As Boolean, _
                                 Optional fld_list As Variant, _
                                 Optional type_list As Variant, _
                                 Optional val_list As Variant) As Integer

Description

These APIs create a solution record (and one workaround). You may supply the title and description for the solution. The workaround, public indicator, and resolution code are used for the one workaround that is created. You may optionally dispatch the solution. If a queue name is specified, the solution is dispatched to that queue. Otherwise it is left in the default WIPBIN of the owner.

You may specify a creation date, and the user who created the solution. You may also set additional fields in the probdesc object. Finally, you may specify if a time bomb (for business rules) is generated, or not.

Parameters

Parameter Name | Required? | Description
the_title | No | Title of the solution
description | No | The problem description of the solution
workaround | No | The text of the 1st workaround for the solution. Highly recommended that this have text
is_public | Yes | Is the workaround public, or not? Used by Clarify Web applications
res_code | No | Resolution code for the workaround. If left blank, default value is used from the list
queue_name | No | Name of the queue to dispatch to. If blank, solution is not dispatched
create_date | No | When was solution created? If blank, current date/time is used
user_name | No | Who created the solution? If blank, current user is used
create_time_bomb | Yes | Should a time bomb be added to the system for business rule firing?
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified user
-2 | Cannot find the activity string for CREATE rank equal to 600
-3 | Cannot find the specified resolution code
-4 | Cannot find the activity string for DISPATCH rank equal to 900
-5 | Could not find the specified queue name
-6 | Cannot find the specified user's employee record for relating time bomb
ret_objid | Output - Returns the objid of the new solution record
ret_objid2 | Output - Returns the objid of the new work-around record

Examples

Create a new solution with title, description, workaround (public, with default res code). Dispatch the solution to the "High" queue. Generate time bombs, and the create was made by Joe on November 11, 1998 at 11:00 AM.

Visual Basic:

Dim ret_int As Integer
Dim soln_objid As Long
Dim work_objid As Long

ret_int = fcinter.create_soln("The Solution","There is a problem", _
                              "No current workaround", true, "", "High",_
                              "11/11/1998 11:00:00", "joe", true ,"", 0, _
                              "", 0, "", "", "", "", "", "")

 If ret_int = 0 Then
      soln_objid = fcinter.ret_objid
      work_objid = fcinter.ret_objid2
 End If

JavaScript:

var ret_int = fcinter.create_soln("The Solution","There is a problem",
                              "No current workaround", true, "", "High",
                              "11/11/1998 11:00:00", "joe", true ,"", 0,
                              "", 0, "", "", "", "", "", "");

 if (ret_int == 0){
    var soln_objid = fcinter.ret_objid;
    var work_objid = fcinter.ret_objid2;
 }


create_state | fcSDK Documentation

create_state

Public Function create_state(ByVal state As String, _
                             ByVal full_name As String, _
                             ByVal is_default As Boolean, _
                             ByVal country As String) As Integer

Description

This API creates a state/prov object in Clarify database, and relates it to an existing country. In addition, the state can be set to be the default state for the country, or not. If it is to be the default state, the previous default state is set to be a normal state.

Parameters

Parameter Name | Required? | Description
state | Yes | State name
full_name | No | Full name of the state
is_default | Yes | Is this the default state for the country?
country | Yes | The country to link the state to

Returns

Value | Meaning
0 | No errors
-1 | No state name supplied
-2 | Cannot find the specified country name
-3 | The supplied state is already defined for the country
ret_objid | Output - Returns the objid of the new state

Examples

Add a new state of "Confusion" for the USA. Do not make it the default.

Visual Basic:

Dim ret_int As Integer
Dim state_objid As Long

ret_int = fcinter.create_state("Confusion", "The state of confusion", false, "USA")

 If ret_int = 0 Then
   state_objid = fcinter.ret_objid
 End If

JavaScript:

var ret_int = fcinter.create_state("Confusion", "The state of confusion",

                                   false, "USA");

 if (ret_int == 0){ var state_objid = fcinter.ret_objid; }

Add the same state, but make it the default state for the USA.

Visual Basic:

Dim ret_int As Integer
Dim state_objid As Long

ret_int = fcinter.create_state("Confusion", _
                               "The state of confusion", true, "USA")

 If ret_int = 0 Then
   state_objid = fcinter.ret_objid
 End If

JavaScript:

var ret_int = fcinter.create_state("Confusion", "The state of confusion",
                                   true, "USA");

 if (ret_int == 0){ var state_objid = fcinter.ret_objid; }


create_time_zone | fcSDK Documentation

create_time_zone

Public Function create_time_zone(ByVal time_zone As String, _
                                 ByVal full_name As String, _
                                 ByVal country As String, _
                                 ByVal gmt_diff As Long) As Integer

Description

This API creates a time zone in the Clarify database, and relates it to a country. If the time zone is not found in the database, a new time zone record is created.

Parameters

Parameter Name | Required? | Description
time_zone | Yes | Time zone name
full_name | No | Full name of the time zone
country | Yes | The country to link the time zone to
gmt_diff | No | The number of seconds (positive or negative) that the time zone is off of GMT

Returns

Value | Meaning
0 | No errors
-1 | No time zone name supplied
-2 | Cannot find the specified country name
-3 | The supplied time zone is already defined for the country
ret_objid | Output - Returns the objid of the new time zone

Examples

Add a new time zone of 'FST' for the USA that is 14400 seconds off of GMT.

Visual Basic:

Dim ret_int As Integer
Dim tz_objid As Long

ret_int = fcinter.create_time_zone("FST", "Foo Standard Time", "USA", 14400)

 If ret_int = 0 Then
   tz_objid = fcinter.ret_objid
 End If

JavaScript:

var ret_int = fcinter.create_time_zone("FST", "Foo Standard Time",
                                       "USA", 14400);

 if (ret_int == 0){ var tz_objid = fcinter.ret_objid; }


create_update_account | fcSDK Documentation

create_update_account

create_update_account_list

Public Function create_update_account(ByVal acct_name As String, _
                                      ByVal desc As String, _
                                      ByVal territory As String, _
                                      ByVal stock As String, _
                                      ByVal fiscal_yr As String, _
                                      ByVal the_type As String, _
                                      ByVal size As String, _
                                      ByVal revenue As String, _
                                      ByVal ownership As String, _
                                      ByVal phone As String, _
                                      ByVal fax As String, _
                                      ByVal web_site As String, _
                                      ByVal user_name As String, _
                                      ByVal create_date As String, _
                                      ByVal gen_time_bombs As Boolean, _
                                      ByVal acct_id As String, _
                                      ByVal int_fld1 As String, _
                                      ByVal int_val1 As Long, -_
                                      ByVal int_fld2 As String, _
                                      ByVal int_val2 As Long, _
                                      ByVal str_fld1 As String, _
                                      ByVal str_val1 As String, _
                                      ByVal str_fld2 As String, _
                                      ByVal str_val2 As String, _
                                      ByVal date_fld1 As String, _
                                      ByVal date_val1 As String As Integer

Public Function create_update_account_list(ByVal acct_name As String, _
                                           ByVal desc As String, _
                                           ByVal territory As String, _
                                           ByVal stock As String, _
                                           ByVal fiscal_yr As String, _
                                           ByVal the_type As String, _
                                           ByVal size As String, _
                                           ByVal revenue As String, _
                                           ByVal ownership As String, _
                                           ByVal phone As String, _
                                           ByVal fax As String, _
                                           ByVal web_site As String, _
                                           ByVal user_name As String, _
                                           ByVal create_date As String, _
                                           ByVal gen_time_bombs As Boolean, _
                                           ByVal acct_id As String, _
                                           Optional fld_list As Variant, _
                                           Optional type_list As Variant, _
                                           Optional val_list As Variant) _
                                           As Integer

Description

These APIs create or update accounts (business orgs). An existing account can be updated by setting the acct_id field. When updating an existing account, setting an argument (for example, fiscal_yr) will cause the field to be updated. To leave the current value in the field, leave the argument blank (""). To clear the value in an argument, use the string "CLEAR".

To create a new account, leave the account field blank. A variety of fields in the account can be optionally set. Four of them, type, size, revenue, and ownership are values from code lists. If the code list values are blank, the default value of the list is used.

Parameters

Parameter Name | Required? | Description
acct_name | No | Account's name
desc | No | Description
territory | No | Territory of the account
stock | No | Stock symbol for the account
fiscal_yr | No | Fiscal year for the account
the_type | No | Account type list
size | No | Account size list
revenue | No | Account revenue list
ownership | No | Account's ownership list
phone | No | Phone number
fax | No | Fax number
web_site | No | URL for the account
user_name | No | User name for the account "created by" employee role. If blank, the current user performs the create
create_date | No | When the account is created. If blank, current time is used. Argument is ignored for updates
gen_time_bombs | Yes | Should a time bomb record be created for business rule notification?
acct_id | Yes | The account ID (updates only)
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | Specified User Not Found
-2 | Specified Territory Not Found
-3 | Specified Account Type Not Found
-4 | Specified Account Size Not Found
-5 | Specified Account Revenue Not Found
-6 | Specified Account Ownership Not Found
-7 | Cannot find the activity string for "Create" rank equal to 600
-8 | Cannot find the specified user's employee record for relating time bomb
-9 | Cannot find the specified account to update
ret_objid | Output - Returns the objid of the account

Examples

Create a new account with a name, description, stock symbol, and year. Put it in the default territory (The World), and set the code lists to interesting values. Set a phone and fax number, and a URL. Have it created by the default user, and set no extra fields.

Visual Basic:

Dim ret_int As Integer
Dim account_objid   As Long

ret_int = fcinter.create_update_account("New account", _
                                           "Description", "The World", _
                                           "ACCT", "YEAR", "Customer",_
                                           "10 - 99", _
                                           "$1M - 5M", "Private", _
                                           "333-333-3333", "333-333-3334", _
                                           "www.acct.com",  _
                                           "", "", true, "", "", 0, "", 0, _
                                           "", "", "", "", "", "")

 If ret_int = 0 Then
   account_objid = fcinter.ret_objid
 End If

JavaScript:

var ret_int = fcinter.create_update_account("New account",
                                           "Description", "The World",
                                           "ACCT", "YEAR", "Customer",
                                           "10 - 99", "$1M - 5M", "Private",
                                           "333-333-3333", "333-333-3334",
                                           "www.acct.com",
                                           "", "", true, "", "", 0, "", 0,
                                           "", "", "", "", "", "");

 if (ret_int == 0){ var account_objid = fcinter.ret_objid; }

Do the same with the list version:

Visual Basic:

Dim ret_int As Integer
Dim account_objid As Long
Dim fld_list      As List
Dim type_list     As List
Dim val_list      As List

ret_int = fcinter.create_update_account_list("New account", _
                                              "Description", _
                                              "The World", "ACCT", "YEAR", _
                                              "Customer", "10 - 99", _
                                              "$1M - 5M", "Private", _
                                              "333-333-3333", _
                                              "333-333-3334", "www.acct.com", _
                                              "", "", true, "", _
                                              fld_list, type_list, val_list)

 If ret_int = 0 Then
   account_objid = fcinter.ret_objid
 End If

JavaScript:

var ret_int = fcinter.create_update_account_list("New account",
                                               "Description",
                                               "The World", "ACCT", "YEAR",
                                               "Customer", "10 - 99",
                                               "$1M - 5M", "Private",
                                               "333-333-3333",
                                               "333-333-3334", "www.acct.com",
                                               "", "", true, "",
                                               fld_list, type_list, val_list);

 if (ret_int == 0){ var account_objid = fcinter.ret_objid; }

Modify account "AN_CUST44". Set a few fields. Leave most of them blank, and clear the territory.

Visual Basic:

Dim ret_int As Integer
Dim acct_id   As String

acct_id = "AN_CUST44"

ret_int = fcinter.create_update_account("", "", "CLEAR", "IBM", "", _
                                           "", "", "", "", _
                                           "", "", "", "", "", true, acct_id, _
                                           "", 0, "", 0, "", "", _
                                           "", "", "", "")

JavaScript:

var acct_id = "AN_CUST44";

var ret_int = fcinter.create_update_account("", "", "CLEAR", "IBM", "",
                           "", "", "", "", "", "", "", "", "", true, acct_id,
                           "", 0, "", 0, "", "", "", "", "", "");


create_update_contract | fcSDK Documentation

create_update_contract

create_update_contract_list

Public Function create_update_contract(ByVal contract_id As String, _
                                 ByVal contract_type As String, _
                                 ByVal status As String, _
                                 ByVal po_number As String, _
                                 ByVal pay_options As String, _
                                 ByVal phone_resp As Long, _
                                 ByVal onsite_resp As Long, _
                                 ByVal hours_for_pm As String, _
                                 ByVal start_date As String, _
                                 ByVal expire_date As String, _
                                 ByVal unit_type As String, _
                                 ByVal units_purch As Double, _
                                 ByVal units_used As Double, _
                                 ByVal units_avail As Double, _
                                 ByVal spec_consid As Long, _
                                 ByVal notes As String, _
                                 ByVal int_fld1 As String, _
                                 ByVal int_val1 As Long, _
                                 ByVal int_fld2 As String, _
                                 ByVal int_val2 As Long, _
                                 ByVal str_fld1 As String, _
                                 ByVal str_val1 As String, _
                                 ByVal str_fld2 As String, _
                                 ByVal str_val2 As String, _
                                 ByVal date_fld1 As String, _
                                 ByVal date_val1 As String) As Integer

Public Function create_update_contract_list(ByVal contract_id As String, _
                                            ByVal contract_type As String, _
                                            ByVal status As String, _
                                            ByVal po_number As String, _
                                            ByVal pay_options As String, _
                                            ByVal phone_resp As Long, _
                                            ByVal onsite_resp As Long, _
                                            ByVal hours_for_pm As String, _
                                            ByVal start_date As String, _
                                            ByVal expire_date As String, _
                                            ByVal unit_type As String, _
                                            ByVal units_purch As Double, _
                                            ByVal units_used As Double, _
                                            ByVal units_avail As Double, _
                                            ByVal spec_consid As Long, _
                                            ByVal notes As String, _
                                            Optional fld_list As Variant, _
                                            Optional type_list As Variant, _
                                            Optional val_list As Variant) _
                                            As Integer

Description

These APIs create or update a contract. An existing contract can be updated, or a new contract can be created.

Parameters

Parameter Name | Required? | Description
contract_id | No | Contract Id, an existing one, or blank one for new contract
contract_type | No | Contract Type, from list. If no value given, default is used (create), or no change is made (update)
status | No | Contract Status, from list. If no value given, default is used (create), or no change is made (update)
po_number | No | Purchase order number for the contract. If none given (update), no change is made
pay_options | No | Payment options for the contract. If none is given (create), default is used. If none is given (update), no change is made
phone_resp | No | How much time (in seconds) before we should call back. If <0 (update), no change is made
onsite_resp | No | How much time (in seconds) before we should be on site. If <0 (update), no change is made
hours_for_pm | No | The business hours for PM. If none given (update), no change is made
start_date | No | The effective date of this contract. If none given (update), no change is made
expire_date | No | The expiration date of this contract. If none given (update), no change is made
units_used | No | The number of units used. If none given (update), no change is made
units_avail | No | The number of units available. If none given (update), no change is made
spec_consid | No | Turns the flag on/off for special considerations (0 = off, 1 = on). If no change (update), then set to -1
notes | No | Notes (special consid) to be added or changed on the contract. These notes are only displayed if the spec_consid field = 1
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | Specified Contract Type Not Found
-2 | Specified Contract Status Not Found
-3 | Specified Start Date is invalid
-4 | Specified Expire Date is invalid
-5 | Expire Date is earlier than the Start Date
-6 | One of the Unit values is negative (-1 is allowed)
-7 | Units Available does not equal Units Purchased minus Units Used
-8 | Special Consideration needs to be 0 (false) or 1 (true)
ret_objid | Output - Returns the objid of the contract

Examples

Create a new software support contract. Use the default status. Assign a purchase order to it, and use 1 hour and 1 day as the response times. Set the start date and end date, and they purchased 50 phone calls. Add some special considerations to the contract.

Visual Basic:

Dim ret_int As Integer
Dim contract_objid As Long

ret_int = fcinter.create_update_contract("","Software Support", _
                                         "", "PO1234", _
                                         "", 3600, 86400, "", _
                                         "1/1/2000 8:00:00", _
                                         "12/31/2000 8:00:00", "Call",_
                                         50, 0, 50, 1, "Good contract!", _
                                         "", 0, "", _
                                         0, "", "", "", "", "", "")

 If ret_int = 0 Then
   contract_objid = fcinter.ret_objid
 End If

JavaScript:

var ret_int = fcinter.create_update_contract("","Software Support",
                                         "", "PO1234",
                                         "", 3600, 86400, "",
                                         "1/1/2000 8:00:00",
                                         "12/31/2000 8:00:00", "Call",
                                         50, 0, 50, 1, "Good contract!",
                                         "", 0, "",
                                         0, "", "", "", "", "", "");

 if (ret_int == 0){ var contract_objid = fcinter.ret_objid; }


create_update_mod_level | fcSDK Documentation

create_update_mod_level

Public Function create_update_mod_level(ByVal part_num As String, _
                                        ByVal domain As String, _
                                        ByVal mod_level As String, _
                                        ByVal replaces_part As String, _
                                        ByVal replaces_dom As String, _
                                        ByVal replaces_rev As String, _
                                        ByVal replaces_date As String, _
                                        ByVal status As String, _
                                        ByVal change_ml As Boolean, _
                                        ByVal new_ml As String) As Integer

Description

This API creates or update part mod levels (revisions). You must supply the part number and domain (to identify the part), and the mod_level. If the mod_level record already exists, it's an update. If it doesn't, it's a create. You may also (optionally) specify the part number/domain/revision that this revision replaces, and the date that it replaces the previous revision.

You may also specify the status of the revision. If you do not specify a status (for create), the status of "Active" is assumed. Also, you may use the change_ml and new_ml arguments to change the mod_level of an existing mod_level record.

Parameters

Parameter Name | Required? | Description
part_num | Yes | Part number of the part
part_dom | Yes | Domain of the part
mod_level | Yes | Revision to create
replaces_part | No | Part number of part/rev that this revision replaces
replaces_dom | No | Domain of part/rev that this revision replaces
replaces_rev | No | Revision of part/rev that this revision replaces
replaces_date | No | What date/time does this part/rev replace the previous one?
status | No | The status of the revision. For creates, if blank, the status of "Active" is used. For updates, if it is blank, no change is made to the status. Must be a valid status otherwise (Active, Inactive, Obsolete)
change_ml | Yes | For updates only (ignored for creates). Should the mod_level be updated? Should be True or False
new_ml | No | For updates only. If change_ml = True, this is the new mod_level for the revision record

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified part number
-2 | An invalid status was supplied
-3 | Cannot find the specified replaces part and revision
-4 | The new mod_level (updates only) supplied already exists for a revision of this part.
ret_objid | Output - Returns the objid of the mod level

Examples

Create revision '2.4' for product 'Zipcode Reverse Directory'. It does not replace another revision. Assume it is active.

Visual Basic:

Dim ret_int As Integer
Dim mod_level As Long

ret_int = fcinter.create_update_mod_level("Zipcode Reverse Directory", _
                        "Product", "2.4", "", "", "", "", "", false, "")

 If ret_int = 0 Then
   mod_level_objid = fcinter.ret_objid
 End If

JavaScript:

var ret_int = fcinter.create_update_mod_level("Zipcode Reverse Directory",
                      "Product", "2.4", "", "", "", "", "", false, "");

 if (ret_int == 0){ var mod_level_objid = fcinter.ret_objid; }

Modify revision '2.4' for product 'Zipcode Reverse Directory'. It replaces revision '2.3' of the same package on January 23rd 1998. Leave everything else alone.

Visual Basic:

Dim ret_int As Integer

ret_int = fcinter.create_update_mod_level("Zipcode Reverse Directory", _
                  "Product", "2.4", "Zipcode Reverse Directory", _
                  "Product", "2.3", "1/23/98 8:00:00", "", false, "")

JavaScript:

var ret_int = fcinter.create_update_mod_level("Zipcode Reverse Directory",
                      "Product", "2.4", "Zipcode Reverse Directory",
                      "Product", "2.3", "1/23/98 8:00:00", "", false, "");


create_update_part | fcSDK Documentation

create_update_part

create_update_part_list

Public Function create_update_part(ByVal part_num As String, _
                                   ByVal domain As String, _
                                   ByVal notes As String, ByVal desc As String, _
                                   ByVal model_num As String, _
                                   ByVal warr_days As Long, _
                                   ByVal start_on_ship As Boolean, _
                                   ByVal unit_measure As String, _
                                   ByVal family As String, _
                                   ByVal the_line As String, _
                                   ByVal repair_type As String, _
                                   ByVal part_type As String, _
                                   ByVal weight As String, _
                                   ByVal dimension As String, _
                                   ByVal class As String, _
                                   ByVal int_fld1 As String, _
                                   ByVal int_val1 As Long, _
                                   ByVal int_fld2 As String, _
                                   ByVal int_val2 As Long, _
                                   ByVal str_fld1 As String, _
                                   ByVal str_val1 As String, _
                                   ByVal str_fld2 As String, _
                                   ByVal str_val2 As String, _
                                   ByVal date_fld1 As String, _
                                   ByVal date_val1 As String) As Integer

Public Function create_update_part_list(ByVal part_num As String, _
                                        ByVal domain As String, _
                                        ByVal notes As String, _
                                        ByVal desc As String, _
                                        ByVal model_num As String, _
                                        ByVal warr_days As Long, _
                                        ByVal start_on_ship As Boolean, _
                                        ByVal unit_measure As String, _
                                        ByVal family As String, _
                                        ByVal the_line As String, _
                                        ByVal repair_type As String, _
                                        ByVal part_type As String, _
                                        ByVal weight As String, _
                                        ByVal dimension As String, _
                                        ByVal class As String, _
                                        Optional fld_list As Variant, _
                                        Optional type_list As Variant,
                                        Optional val_list As Variant), _
                                        As Integer

Description

These APIs either create or update a part number in the database. The part number and domain must be specified. Also, the start on ship (or install) flag and warr_days must be specified. All of the other arguments are optional. For inserts, if the values are not specified (for code lists such as family and line), the default list values are used. For updates, leaving an argument blank causes the old value to be retained. If you wish (on an update) to blank a field's value, use the alternate fields (str_fld1 etc.) to assign them.

Note: Just calling on this API will NOT cause the part to be visible in Clarify. To see the part number, there must be at least one part revision. Use the create_update_mod_level to add a part revision.

Parameters

Parameter Name | Required? | Description
part_num | Yes | Part number to insert/update
domain | Yes | The domain for the part to insert/update
notes | No | Notes about the part
desc | No | Description of the part
model_num | No | Model number of the part
warr_days | Yes | Number of warranty days for the part
start_on_ship | Yes | Should the warranty start on shipment (=0), or on install (=1)
unit_measure | No | What is the unit of measure for the part?
family | No | Level 1 of the FAMILY/LINE code list. If blank (on insert), the default value is used. If blank (on update) no change is made
the_line | No | Level 2 of the FAMILY/LINE code list. If blank (on insert), the default value is used. If blank (on update) no change is made
repair_type | No | String for type. One of: "Repairable" or "Expendable". If blank (on update), no change is made
part_type | No | Level 1 of the PART TYPE code list. If blank (on insert), the default value is used. If blank (on update), no change is made
weight | No | Unit weight of the part
dimension | No | Dimensions of the part
class | No | Part class for the part. Only used by DE engine. If blank (on insert), default part class is used. If blank (on update), no change is made
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | Warranty days is negative (for inserts only)
-2 | Invalid repair type
-3 | Could not find the specified part domain
-4 | Invalid part type specified
-5 | Invalid family/line specified
-6 | Invalid part class specified
ret_objid | Output - Returns the objid of the part

Examples

Add a new part 'Attachments Anywhere' in domain 'Product' to the system. Set the family and line to 'Software', 'Workflow Series', and some other values, including 30 warranty days that start from shipment.

Visual Basic:

Dim ret_int As Integer
Dim part_objid As Long

ret_int = fcinter.create_update_part("Attachments Anywhere", _
                  "Product", "Some notes", "A good product description",_
                  "Model 42", 30, true, "Each", "Software", _
                  "Workflow Series", "Expendable", "Software", "2.3", _
                  "2x2x3", "", "", 0, "", 0, "", "", "", "","","")

If ret_int = 0 Then
  part_objid = fcinter.ret_objid
End If

JavaScript:

var ret_int = fcinter.create_update_part("Attachments Anywhere",
          "Product", "Some notes", "A good product description", "Model 42",
          30, true, "Each", "Software", "Workflow Series",
          "Expendable", "Software", "2.3", "2x2x3", "", "", 0,
          "", 0, "", "", "", "","","");

if (ret_int == 0){ var part_objid = fcinter.ret_objid; }


create_update_queue | fcSDK Documentation

create_update_queue

Public Function create_update_queue(ByVal title As String, _
                                    ByVal personal As Boolean, _
                                    ByVal description As String, _
                                    ByVal allow_bug As Integer, _
                                    ByVal allow_case As Integer, _
                                    ByVal allow_contract As Integer, _
                                    ByVal allow_dialogue As Integer, _
                                    ByVal allow_dmnd_dtl As Integer, _
                                    ByVal allow_job As Integer, _
                                    ByVal allow_opp As Integer, _
                                    ByVal allow_probdesc As Integer, _
                                    ByVal allow_subcase As Integer, _
                                    ByVal allow_task As Integer, _
                                    ByVal supervisor As String, _
                                    ByVal new_title As String) As Integer

Description

This API either creates or updates a queue in the database. If the supplied queue title is not found in the database, the API will create a new queue. If the title is found in the database, an update will occur. The user can mark if it is a personal or shared queue, a description, and can decide which objects can be dispatched to the queue. Finally, the user who is the supervisor must be specified.

For updates, a new title can be specified. An updated description can be provided, and you can decide to turn on or off the allow fields. You can also change the queue supervisor.

Parameters

Parameter Name | Required? | Description
title | Yes | Title of the queue. For creates, it is a unique name. For updates, it is the name of the queue to update
personal | Yes | Is this a personal queue (True), or shared (False)
description | No | The description of the queue. For updates, if you leave it blank (""), no change will be made. If you want to clear the description (for updates), use the string "CLEAR".
allow_bug | Yes | Should the queue allow dispatches of each of these objects. Values are "1"
allow_case allow_contract allow_dialogue allow_demand_dtl allow_job allow_opp allow_probdesc allow_subcase allow_task | (Yes), or "0" (No). For updates, if you set this to "-1", the previous value is retained. |
supervisor | No | Supervisor of the queue. If blank, the current user is used
new_title | No | For updates only. If you wish to change the name of the queue, it is supplied in this argument

Returns

Value | Meaning
0 | No errors
-1 | The supplied queue name is not found
-2 | Cannot find the user name supplied
-3 | The new title is already used for another queue
ret_objid | Output - Returns the objid of the queue

Examples

Create a new shared queue "Urgent" with all objects allowed. Assume the current user is the supervisor.

Visual Basic:

Dim ret_int As Integer
Dim queue_objid As Long

ret_int = fcinter.create_update_queue("Urgent", false, "A new queue", _
                                      1, 1, 1, 1, 1, 1, 1, 1, 1, 1, "", "")

If ret_int = 0 Then
  queue_objid = fcinter.ret_objid
End If

JavaScript:

var ret_int = fcinter.create_update_queue("Urgent", false, "A new queue",
                                      1, 1, 1, 1, 1, 1, 1, 1, 1, 1, "", "");

 if (ret_int == 0){ var queue_objid = fcinter.ret_objid; }

Update the previously created queue. Change the name and set it so that part requests cannot be dispatched to the queue (all other items stay the same). Clear the description. Change the name of it.

Visual Basic:

Dim ret_int As Integer

ret_int = fcinter.create_update_queue("Urgent", false, "CLEAR", _
          -1, -1, -1, -1, 0, -1, -1, -1, -1, -1, "", "Really Urgent")

JavaScript:

var ret_int = fcinter.create_update_queue("Urgent", false, "CLEAR",
              -1, -1, -1, -1, 0, -1, -1, -1, -1, -1, "", "Really Urgent");


create_update_site | fcSDK Documentation

create_update_site

create_update_site_list

Public Function create_update_site(ByVal site_objid As Long, _
                                   ByVal site_id As String, _
                                   ByVal site_name As String, _
                                   ByVal site_type As String, _
                                   ByVal bus_org As String, _
                                   ByVal status As String, _
                                   ByVal region As String, _
                                   ByVal district As String, _
                                   ByVal industry_type As String, _
                                   ByVal appl_type As String, _
                                   ByVal prim_addr As Long, _
                                   ByVal ship_addr As Long, _
                                   ByVal bill_addr As Long, _
                                   ByVal parent_site As String, _
                                   ByVal supp_office As String, _
                                   ByVal prim_emp As Long, _
                                   ByVal sec_emp As Long, _
                                   ByVal int_fld1 As String, _
                                   ByVal int_val1 As Long, _
                                   ByVal int_fld2 As String, _
                                   ByVal int_val2 As Long, _
                                   ByVal str_fld1 As String, _
                                   ByVal str_val1 As String, _
                                   ByVal str_fld2 As String, _
                                   ByVal str_val2 As String, _
                                   ByVal date_fld1 As String, _
                                   ByVal date_val1 As String) As Integer

Public Function create_update_site_list(ByVal site_objid As Long, _
                                        ByVal site_id As String, _
                                        ByVal site_name As String, _
                                        ByVal site_type As String, _
                                        ByVal bus_org As String, _
                                        ByVal status As String, _
                                        ByVal region As String, _
                                        ByVal district As String, _
                                        ByVal industry_type As String, _
                                        ByVal appl_type As String, _
                                        ByVal prim_addr As Long, _
                                        ByVal ship_addr As Long, _
                                        ByVal bill_addr As Long, _
                                        ByVal parent_site As String, _
                                        ByVal supp_office As String, _
                                        ByVal prim_emp As Long, _
                                        ByVal sec_emp As Long, _
                                        Optional fld_list As Variant, _
                                        Optional type_list As Variant,__
                                        Optional val_list As Variant) As Integer

Description

These APIs either create or update a site in the database. If the site_id is set to 0, it is considered an insert. Otherwise, it is an update. If you are performing an update, you may specify either the site_objid or the site_id (whichever is more convenient), or both. If you do not want to use the site_id, set it to the string "NOTSUPPLIED". In this case, the site_objid is is used to find the site to update. If the site_id is set to any other string value, it will be used.

For inserts, some of the data must be supplied: site_type, status, and a primary address (objid). For updates, any blank data is not changed. For string variables, this is a blank string "". For integer variables (such as the addresses and employees), use -1 to not change the data.

In addition (for updates), the APIs allow you to blank some of the data. Setting the parent_site or support office fields to "REMOVE" will cause the site to be unrelated from the other site. Setting the site name to "REMOVE" will do the same. Setting the integer fields to "-2" will cause them to be unrelated.

The primary address is required for inserts. If the shipping and billing addresses are not supplied, they are defaulted to the same value as the primary address. For updates, you must specify the address to change to. If the value is set to -1 then no change is made.

Parameters

Parameter Name | Required? | Description
site_objid | Yes | For inserts, this is set to zero. For updates, set it to the site objid. If (for updates) the site_id is set to "NOTSUPPLIED", this field must be specified. If the site_id is specified for updates, this field is ignored.
site_id | No | For inserts, if this variable is blank, a new site_id is generated. For inserts, if this field is supplied, it will be used for the new site. For updates, supply the site_id to update. For updates, if this field is set to "NOTSUPPLIED", the site_objid is used to identify the site.
site_name | No | The name of the site. For updates, if you set it to "REMOVE", the site name will be cleared
site_type | No | Required for inserts. Must be one of: "CUST, INTR, RSEL, INDV". For updates, only changed if the value is supplied
bus_org | No | What account is this site in? If blank, the default site is used
status | No | Required for inserts. One of "ACTIVE, INACTIVE, OBSOLETE". For updates, only changed if the value is supplied
region | No | Region for the site. For updates, if blank, no change is made, and if set to "REMOVE", the field is cleared.
district | No | District of the site. For updates, if blank, no change is made, and if set to "REMOVE", the field is cleared.
industry_type | No | Value from the INDUSTRY_TYPE code list. For inserts, if this is blank, the default value of the list is used. For updates, if blank, no change is made
appl_type | No | Value from the PRIMARY_USE code list. For inserts, if this is blank, the default value of the list is used. For updates, if blank, no change is made
prim_addr | No | Objid of the primary address for the site. For inserts, this must be supplied. For updates, if set to -1, no change is made
ship_addr | No | Shipping address of the site. If set to -1 (for inserts), the primary address is used. If set to -1 for updates, no change is made
bill_addr | No | Billing address of the site. If set to -1 (for inserts), the primary address is used. If set to -1 for updates, no change is made
parent_site | No | Optional site_id of parent site. If left blank, no change is made (updates), and relation is not set (inserts). If you wish to clear the relation (updates), set the value to "REMOVE"
supp_office | No | Optional site_id of support office. If left blank, no change is made (updates), and relation is not set (inserts). If you wish to clear the relation (updates), set the value to "REMOVE"
prim_emp | No | Optional objid of primary support employee. If set to -1, no change is made (updates), or the relation is not set (inserts). If set to -2, the relation is unrelated
sec_emp | No | Optional objid of secondary support employee. If set to -1, no change is made. (updates), or the relation is not set (inserts). If set to -2, the relation is unrelated
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | Site type is not valid or is not supplied (inserts)
-2 | Status is not valid or is not supplied (inserts)
-3 | The supplied industry type is not found
-4 | The supplied application type is not found
-5 | Could not locate specified parent site
-6 | Could not locate specified support office site
-7 | Could not locate specified primary employee
-8 | Could not locate specified secondary employee
-9 | Shipping address specified is not valid
-10 | Billing address specified is not valid
-11 | Primary address is not valid or is not supplied (inserts)
-12 | Site with objid = ### cannot be found
-13 | The parent site cannot be the same as this site
-14 | The support office site cannot be the same as this site
-15 | The supplied Site Id is already used for a different site
-16 | The supplied account is not found
-17 | Cannot find the 'Changed Primary' activity string with rank = 8100
-18 | Cannot find the 'Changed Bill To' activity string with rank = 8200
-19 | Cannot find the 'Changed Ship To' activity string with rank = 8300
ret_objid | Output - Returns the objid of the site

Examples

Add a new site. Set it with a site name, make it a customer site, and active. Set region/district to North/Northeast. Use the default industry type, and application type. Set the primary address and the billing address. Set a parent site, and a primary employee.

Visual Basic:

Dim ret_int As Integer
Dim site_objid As Long

ret_int = fcinter.create_update_site(0, "", "My Site", "CUST", _
                                     "", "Active", _
                                     "North", "Northeast", _
                                     "", "", 268435457, -1, 268435459, _
                                     "42", "", 268435666, -1, _
                                     "", 0, "",_
                                     0, "", "", "", "", "", "")

 If ret_int = 0 Then
   site_objid = fcinter.ret_objid
 End If

JavaScript:

var ret_int = fcinter.create_update_site(0, "", "My Site",
   "CUST", "", "Active",
   "North", "Northeast",
   "", "", 268435457, -1, 268435459,
   "42", "", 268435666, -1, "", 0, "",
   0, "", "", "", "", "", "");

 if (ret_int == 0){ var site_objid = fcinter.ret_objid; }

Add a new site with site_id of 'INTER123'. Set it with a site name, make it a customer site, and active. Set region/district to North/Northeast. Use the default industry type, and application type. Set the primary address and the billing address. Set a parent site, and a primary employee.

Visual Basic:

Dim ret_int As Integer
Dim site_id    As String

site_id = "INTER123"

ret_int = fcinter.create_update_site(0, site_id, _
                                     "My Site", "CUST", _
                                     "", "Active", _
                                     "North", "Northeast", "", _
                                     "", 268435457, _
                                     -1, 268435459, _
                                     "42", "", 268435666, -1, _
                                     "", 0, "", 0, _
                                     "", "", "", "", "", "")

JavaScript:

var site_id = "INTER123"

var ret_int = fcinter.create_update_site(0, site_id, "My Site",
  "CUST", "", "Active",
  "North", "Northeast", "",
  "", 268435457, -1, 268435459,
  "42", "", 268435666, -1,
  "", 0, "", 0,
  "", "", "", "", "", "");

Update site '42'. Set the support office to site "56", and clear out the primary support employee and parent site.

Visual Basic:

Dim ret_int As Integer
Dim site_id    As String

site_id = "42"

ret_int = fcinter.create_update_site(268435600, site_id, "", _
                                     "", "", "", _
                                     "", "", "", "", -1, -1, -1, _
                                     "REMOVE", "56", -2, -1, "", 0, _
                                     "", 0, "", "", "", "", "", "")

JavaScript:

var site_id = "42"

var ret_int = fcinter.create_update_site(268435600, site_id, "", "", "", "",
                                      "", "", "", "", -1, -1, -1,
                                     "REMOVE", "56", -2, -1, "", 0,
                                     "", 0, "", "", "", "", "", "");


create_update_wipbin | fcSDK Documentation

create_update_wipbin

Public Function create_update_wipbin(ByVal title As String, _
                                     ByVal new_title As String, _
                                     ByVal description As String, _
                                     ByVal user_name As String,_
                                     ByVal def_bin As Boolean) As Integer

Description

This API either creates or updates a WIPBIN. For a new wipbin, you must specify a title. The description is optional, as is the user name. You must specify if this WIPBIN will be the default wipbin, or not.

For updates, you must specify the title of the WIPBIN. You may change the name of the WIPBIN, or leave it as is. You may leave the description as is, clear it, or change it. As with inserts, you must specify if this WIPBIN is to be the default, or not.

Parameters

Parameter Name | Required? | Description
title | Yes | Title of the WIPBIN. For inserts, it is the name of the new WIPBIN. For updates, this is the name of the WIPBIN to update
new_title | No | For updates only, the new name of the WIPBIN. If blank, the name of the WIPBIN is left as is
description | No | For inserts, the description of the WIPBIN. For updates it can contain a new value of the description. If blank, the description is left as is. To clear the description, set it to "CLEAR"
user_name | No | User name of the user for whom the WIPBIN is created/updated. If blank, the current user is used
def_bin | Yes | Is this the default WIPBIN?

Returns

Value | Meaning
0 | No errors
-1 | No title provided
-2 | The specified user name is not found
-3 | The new title for the WIPBIN is already a WIPBIN title for the current user
ret_objid | Output - Returns the objid of the wipbin

Examples

Create a new WIPBIN with a name of "Important" and a description. Create it for "Gary", and make it the default WIPBIN.

Visual Basic:

Dim ret_int As Integer
Dim wipbin_objid As Long

ret_int = fcinter.create_update_wipbin("Important", "", "A description.", "gary", true)

If ret_int = 0 Then
  wipbin_objid = fcinter.ret_objid
End If

JavaScript:

var ret_int = fcinter.create_update_wipbin("Important", "", "A description.", "gary", true);

if (ret_int == 0){ var wipbin_objid = fcinter.ret_objid; }

Update that WIPBIN. Change the name, and clear the description. Don't make it the default WIPBIN.

Visual Basic:

Dim ret_int As Integer

ret_int = fcinter.create_update_wipbin("Important", "Important Issues", "CLEAR", "", false)

JavaScript:

var ret_int = fcinter.create_update_wipbin("Important", "Important Issues", "CLEAR", "", false);


deinstall_sp | fcSDK Documentation

deinstall_sp

Public Function deinstall_sp(ByVal sp_objid As Long, _
                                   ByVal user_name As String, _
                                   ByVal deinstall_date As String, _
                                 ByVal use_remove As Boolean) As Integer

Description

This API can be used to de-install a site part (and the sub-parts installed underneath it) from a site in Clarify. The objid of the site_part to be de-installed is specified, as well as the user performing the action, and the time of the action.

Parameters

Parameter Name | Required? | Description
sp_objid | Yes | OBJID for the site_part to be de-installed
user_name | No | Who performed the de-install. If blank, the current user is used
deinstall_date | No | When was the de-installation. If blank, the current time is used
use_remove | Yes | Should we use the "Remove" (True) or the "De-installed" (False) activity string

Returns

Value | Meaning
0 | No errors
-1 | The specified site_part is not in the database
-2 | The site_part is already de-installed
-3 | The specified user is not found
-4 | Cannot find the Removed/De-Installed activity string with rank = 9600/3800

Examples

Joe deinstalled a site_part on March 15th at noon.

Visual Basic:

Dim ret_int As Integer

ret_int = fcfo.deinstall_sp(268435444, "Joe", "3/15/98 12:00:00")

JavaScript:

var ret_int = fcfo.deinstall_sp(268435444, "Joe", "3/15/98 12:00:00");

The current user de-installs a site_part.

Visual Basic:

Dim ret_int As Integer

ret_int = fcfo.deinstall_sp(268435457, "", "")

JavaScript:

var ret_int = fcfo.deinstall_sp(268435457, "", "");


delete_product_bin | fcSDK Documentation

delete_product_bin

Public Function delete_product_bin(ByVal bin_objid As Long, _
                                   ByVal user_name As String, _
                                   ByVal delete_date As String) As Integer

Description

This API allows you to delete an existing product bin. The bin must be empty (no child bins or child site_parts), and cannot be the deinstall (special) bin. You may also specify who deleted the product bin, and when.

Parameters

Parameter Name | Required? | Description
bin_objid | Yes | Objid of the bin to delete
user_name | No | Name of the user who deleted the bin. If blank, the current user is used
delete_date | No | When was the bin deleted. If blank, the current date/time is used

Returns

Value | Meaning
0 | No errors
-1 | Could not locate the "Deleted" activity log string
-2 | The specified bin could not be located
-3 | The specified bin contains one or more child bins and cannot be deleted
-4 | The specified bin contains one or more child site parts and cannot be deleted
-5 | The specified bin is a special bin, and cannot be deleted
-6 | Could not locate the specified user name

Examples

Delete bin 268435460. Deleted by "Joe" on 1/1/2005.

Visual Basic:

Dim ret_int As Integer

ret_int = fcinter.delete_product_bin(268435460, "joe", "1/1/2005")

JavaScript:

var ret_int = fcinter.delete_product_bin(268435460, "joe", "1/1/2005");


dispatch_solution | fcSDK Documentation

dispatch_solution

Public Function dispatch_solution(ByVal solution_id As String, _
                                  ByVal queue_name As String, _
                                  ByVal disp_date As String, _
                                  ByVal user_name As String, _
                                  ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified solution to be dispatched to the specified queue. The solution must be in open condition, and not currently dispatched to a queue. The API allows for the setting of the dispatch date, and the user who dispatched the solution. The APIs can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
solution_id | Yes | The solution to dispatch
queue_name | Yes | The queue to dispatch to
disp_date | No | When was solution dispatched. If this parameter is left blank, the solution is dispatched at the current time
user_name | No | The user who dispatched the solution. If left blank, the current user performs the dispatch
gen_time_bombs | Yes | Should a time bomb record be created for business rule notification?

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified solution
-2 | The solution is already dispatched
-3 | The solution is closed and may not be dispatched
-4 | The specified user cannot be found
-5 | The specified new queue name cannot be found
-6 | Cannot find the activity string for "Dispatch" rank equal to 900
-7 | The specified queue does not allow dispatches of solutions

Examples

Dispatch solution number '14' to queue 'Hardware'. The dispatch is performed by the current user and is dispatched at the current time. Generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fcinter.dispatch_solution("14", "Hardware", "", "", true)

JavaScript:

var ret_int = fcinter.dispatch_solution("14", "Hardware", "", "", true);

Dispatch solution number '2' at 10PM on November 23rd of 1997 to 'Software'. Dispatch should be logged as performed by Nancy. Don't generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fcinter.dispatch_solution("2", "Software", _
                                    "11/23/97 22:00:00", "nancy", false)

JavaScript:

var ret_int = fcinter.dispatch_solution("2", "Software",
                                    "11/23/97 22:00:00", "nancy", false);


forward_solution | fcSDK Documentation

forward_solution

Public Function forward_solution(ByVal solution_id As String, _
                                 ByVal new_queue As String, _
                                 ByVal forward_date As String, _
                                 ByVal notes As String, _
                                 ByVal user_name As String, _
                                 ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified solution to be rejected from the current queue, and forwarded to another queue. The solution must be dispatched to a queue, and the specified new queue must be valid. The API allows for the setting of the forward date, and the user who forwarded the solution. The APIs can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
solution_id | Yes | The solution to dispatch
queue_name | Yes | The queue to forward to
forward_date | No | When was the solution forwarded. If this parameter is left blank, the solution is forwarded at the current time
notes | No | Optional notes about the forward
user_name | No | The user who forwarded the solution. If left blank, the current user performs the forward
gen_time_bombs | Yes | Should a time bomb record be created for business rule notification?

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified solution
-2 | Solution is not currently dispatched
-3 | The new queue name specified is not found
-4 | Reject-forward attempted to same queue as currently dispatched to
-5 | The specified user is not found
-6 | Cannot find the activity string for "Forward" rank equal to 1100
-7 | Can not forward Solution to specified queue

Examples

Forward solution number '14' to queue 'Hardware'. The forward is performed by the current user and is forwarded at the current time. Generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fcinter.forward_solution("14", "Hardware", "", _
                                   "", "", true)

JavaScript:

var ret_int = fcinter.forward_solution("14", "Hardware", "",
                                   "", "", true);

Forward solution number '2' at 10PM on November 23rd of 1997 to 'Software'. Forward should be logged as performed by Nancy. Add some notes. Don't generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fcinter.forward_solution("2", "Software", _
                                    "11/23/97 22:00:00", _
                                    "Notes about forward", "nancy", false)

JavaScript:

var ret_int = fcinter.forward_solution("2", "Software",
                                    "11/23/97 22:00:00",
                                    "Notes about forward", "nancy", false);


install_sp | fcSDK Documentation

install_sp

install_sp_list

Public Function install_sp(ByVal site_id As String, _
        ByVal part_num As String, ByVal mod_level As String, _
        ByVal domain As String, ByVal quantity As Long, _
        ByVal serial_num As String, ByVal parent_bin_objid As Long, _
        ByVal parent_sp_objid As Long, ByVal instance_name As String, _
        ByVal comment As String, ByVal part_status As String, _
        ByVal invoice_no As String, ByVal user_name As String, _
        ByVal install_date As String, ByVal ship_date As String, _
        ByVal add_activity As Boolean) As Integer

Public Function install_sp_list(ByVal site_id As String, _
        ByVal part_num As String, ByVal mod_level As String, _
        ByVal domain As String, ByVal quantity As Long, _
        ByVal serial_num As String, ByVal parent_bin_objid As Long, _
        ByVal parent_sp_objid As Long, ByVal instance_name As String, _
        ByVal comment As String, ByVal part_status As String, _
        ByVal invoice_no As String, ByVal user_name As String, _
        ByVal install_date As String, ByVal ship_date As String, _
        ByVal add_activity As Boolean, Optional fld_list As Variant, _
        Optional type_list As Variant, Optional val_list As Variant) As Integer

Description

These APIs install site_parts in Clarify. They are very sophisticated and allow virtually any type of install. You must specify a site where the site_part is to be installed, along with the part number, revision and domain for the part. The quantity must be specified. For serial number parts, the serial number is also specified. The part can be installed at the top level of the site, under another site_part or in a bin. An optional instance_name can be specified, as well as the status of the part, a comment, the invoice number, and the install/ship dates. You may determine if activity logs should be added (to the site and to the site_part), and the objid of the top site_part created will be returned.

If the part revision to be installed has a bill of materials (BOM), that BOM will also be installed at the site under the new site_part. If the sub-parts are serial tracked, the APIs will generate the proper new serial numbers for the sub-parts. If the part to be installed is serialized, and the quantity is > 1, the API will generate individual parts for you (sub-parts only).

Other data (such as the warranty end date) is automatically calculated and filled in by the API.

Parameters

Parameter Name | Required? | Description
site_id | Yes | Where to install the site_part
part_num | Yes | The part number to install
mod_level | Yes | The revision of the part
domain | Yes | The domain of the part
quantity | Yes | How many to install
serial_num | No | The serial number of the part to install
parent_bin_objid | No | The objid of the bin to install under. If no bin is to be used, set to 0
parent_sp_objid | No | The objid of the site_part to install under. If this is under a bin, or it is a top-level part, set this argument = 0
instance_name | No | The instance name for the site_part. If this is left blank, the instance_name is generated for you by the API
comment | No | Comment for the site_part
part_status | No | Value from the PART_STATUS list. If left blank, the default value is used
invoice_no | No | The invoice number
user_name | No | Who performed the install? If left blank the current user does the install
install_date | No | When was the site_part installed? If blank, current time is used
ship_date | No | When was the site_part shipped? If blank, current time is used
add_activity | Yes | Should activity log entries be generated?
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | The specified site_id is not found
-2 | Part number cannot be found from supplied part_num and domain
-3 | The specified part revision (mod_level) does not exist
-4 | The specified user cannot be found
-5 | Cannot find the 'Install' activity string with rank = 3600
-6 | The parent bin specified does not exist
-7 | The parent site_part specified does not exist
-8 | The supplied part status is not found
-9 | Both a parent bin and a parent site_part were specified. Cannot install under both
-10 | Positive quantity to install not supplied
-11 | A serial number was supplied, and a quantity > 1
-12 | The part is serialized, and a quantity > 1 was given
-13 | This part may only be installed within another part
-14 | This part may only be installed at the site or in a bin
-15 | The domain rules for this part specify no serial number, but a serial number was supplied
-16 | This part has unique serialization (from the domain) that would be violated by the install
-17 | This part is not able to be installed at a site or under another part
ret_objid | This property will contain the objid of new site_part installed

Examples

Install an MS Word 7.0 at the top-level of site "1234". Install it with serial number "xyzzy", and generate activity logs. Install with status "Installed/Good".

Visual Basic:

Dim ret_int As Integer
Dim sp_objid   As Long

ret_int = fcfo.install_sp("1234", "MS Word", "7.0", "Product", 1, _
           "xyzzy", 0, 0, "", "", "Installed/Good", "", _
           "", "", "", True)

 If ret_int = 0 Then
   sp_objid = fcfo.ret_objid
 End If

JavaScript:

var ret_int = fcfo.install_sp("1234", "MS Word", "7.0", "Product", 1,
   "xyzzy", 0, 0, "", "", "Installed/Good", "",
   "", "", "", true);

 if (ret_int == 0){ var sp_objid = fcfo.ret_objid; }

Joe installs a quantity tracked part (30 of them) in a bin at site "444". It was shipped on February 1, 1998, and installed a month later. Don't add activity logs. Set two other user-defined fields.

Visual Basic:

Dim ret_int As Integer
Dim sp_objid   As Long

ret_int = fcfo.install_sp("444", "QuantPart", "", "Quantity", 30, _
            "", 268435457, 0, "", "", "", "", "", _
            "3/1/98", "2/1/98", False, "x_long", 22, "", _
            0, "x_string", "Hello!!", "", "", "", "")

 If ret_int = 0 Then
   sp_objid = fcfo.ret_objid
 End If

JavaScript:

var ret_int = fcfo.install_sp("444", "QuantPart", "", "Quantity", 30,
   "", 268435457, 0, "", "", "", "", "",
   "3/1/98", "2/1/98", false, "x_long", 22, "",
   0, "x_string", "Hello!!", "", "", "", "");

 if (ret_int == 0){ var sp_objid = fcfo.ret_objid; }


link_case_to_workaround | fcSDK Documentation

link_case_to_workaround

Public Function link_case_to_workaround(ByVal case_id As String, _
                                        ByVal work_objid As Long, _
                                        ByVal link_date As String, _
                                        ByVal user_name As String, _
                                        ByVal create_time_bomb As Boolean) _
                                        As Integer

Description

This API allows a case to be linked to a specific workaround. The case cannot already be linked to a workaround. The link date, and user can be specified. Also, a time bomb can be generated for business rules.

Parameters

Parameter Name | Required? | Description
case_id | Yes | Case to link
work_objid | Yes | Objid of workaround to link to the case
link_date | No | When was the link performed? If blank, current date/time is used
user_name | No | Who performed the link? If blank, current user is used
create_time_bomb | Yes | Should a time bomb be added to the system for business rule firing?

Returns

Value | Meaning
0 | No errors
-1 | Cannot find specified case
-2 | Case is already linked
-3 | Cannot find specified workaround
-4 | Cannot find the specified user
-5 | Cannot find the activity string for "Link" rank equal to 1400
-6 | Cannot find the specified user's employee record for relating time bomb

Examples

Link case '55' to workaround 268435676 at the current date/time by the current user. Generate time bombs.

Visual Basic:

Dim ret_int As Integer

ret_int = fcinter.link_case_to_workaround("55", 268435676, "", "", true)

JavaScript:

var ret_int = fcinter.link_case_to_workaround("55", 268435676, "", "", true);


link_cr_to_soln | fcSDK Documentation

link_cr_to_soln

Public Function link_cr_to_soln(ByVal cr_id As String, _
                                ByVal soln_id As String, _
                                ByVal link_date As String, _
                                ByVal user_name As String, _
                                ByVal create_time_bomb As Boolean) As Integer

Description

This API allows a change request to be linked to a solution. The link date, and user can be specified. Also, a time bomb can be generated for business rules.

Parameters

Parameter Name | Required? | Description
cr_id | Yes | CR to link
soln_id | Yes | ID number of solution to link
link_date | No | When was the link performed? If blank, current date/time is used
user_name | No | Who performed the link? If blank, current user is used
create_time_bomb | Yes | Should a time bomb be added to the system for business rule firing?

Returns

Value | Meaning
0 | No errors
-1 | Cannot find specified CR
-2 | CR is already linked to the specified solution
-3 | Cannot find specified solution
-4 | Cannot find the specified user
-5 | Cannot find the activity string for LINK CR rank equal to 6700
-6 | Cannot find the activity string LINK SOLUTION rank equal to 6500
-7 | Cannot find the specified user's employee record for relating time bomb

Examples

Link CR '14' to solution '66' at the current date/time by the current user. Generate time bombs.

Visual Basic:

Dim ret_int As Integer

ret_int = fcinter.link_cr_to_soln("14", '66', "", "", true)

JavaScript:

var ret_int = fcinter.link_cr_to_soln("14", '66', "", "", true);


modify_product_bin | fcSDK Documentation

modify_product_bin

Public Function modify_product_bin(ByVal bin_objid As Long, _
                                   ByVal bin_name As String, _
                                   ByVal description As String, _
                                   ByVal prim_supp As Long, _
                                   ByVal sec_supp As Long, _
                                   ByVal user_name As String, _
                                   ByVal mod_date As String) As Integer

Description

This API allows you to modify an existing product bin. You may change the bin name and the description. You may also set or clear out the primary and backup support employee. Finally you may specify who modified the product bin, and when.

Parameters

Parameter Name | Required? | Description
bin_objid | Yes | Objid of the bin to modify
bin_name | No | New name of the bin. If no change is to be made, set the bin_name to ""
description | No | New description of the bin. If no change is to be made, use "". If you wish to clear out the description, set this argument to "CLEAR"
prim_supp | No | Objid of the primary support employee. If you do not wish to change this value, use 0. If you wish to clear out the primary support employee, set this argument to -1.
sec_supp | No | Objid of the secondary support employee. If you do not wish to change this value, use 0. If you wish to clear out the primary support employee, set this argument to -1.
user_name | No | Name of the user who modified the bin. If blank, the current user is used
modify_date | No | When was the bin modified. If blank, the current date/time is used

Returns

Value | Meaning
0 | No errors
-1 | Could not locate the "Modified" activity log string
-2 | The specified bin could not be located
-3 | The specified bin is a special bin (ex: deinstall bin). This API cannot delete such a bin
-4 | The specified bin name to change to is already used at the bin's site
-5 | Cannot find the specified user name
-6 | Could not locate the specified primary support employee
-7 | Could not locate the specified secondary support employee

Examples

Modify bin 268435460. Change the name to "Software" and clear out the description. Leave the primary support employee the same, but clear out the secondary support employee. The current user modifies the bin at the current time.

Visual Basic:

Dim ret_int As Integer

ret_int = fcinter.modify_product_bin(268435460, "Software", "CLEAR", _
             0, -1, "", "")

JavaScript:

var ret_int = fcinter.modify_product_bin(268435460, "Software", "CLEAR",
             0, -1, "", "");


modify_sp | fcSDK Documentation

modify_sp

modify_sp_list

Public Function modify_sp(ByVal sp_objid As Long, _
                          ByVal instance_name As String, _
                          ByVal serial_num As String, _
                          ByVal invoice_no As String, _
                          ByVal ship_date As String, _
                          ByVal install_date As String, _
                          ByVal warranty_date As String, _
                          ByVal quantity As Long, _
                          ByVal part_status As String, _
                          ByVal comments As String, _
                          ByVal service_end_dt As String, _
                          ByVal user_name As String, _
                          ByVal mod_level As String, _
                          ByVal add_activity As Boolean, _
                          ByVal int_fld1 As String, _
                          ByVal int_val1 As Long, _
                          ByVal int_fld2 As String, _
                          ByVal int_val2 As Long, _
                          ByVal str_fld1 As String, _
                          ByVal str_val1 As String, _
                          ByVal str_fld2 As String, _
                          ByVal str_val2 As String, _
                          ByVal date_fld1 As String, _
                          ByVal date_val1 As String) As Integer

Public Function modify_sp_list(ByVal sp_objid As Long, _
                               ByVal instance_name As String, _
                               ByVal serial_num As String, _
                               ByVal invoice_no As String, _
                               ByVal ship_date As String, _
                               ByVal install_date As String, _
                               ByVal warranty_date As String, _
                               ByVal quantity As Long, _
                               ByVal part_status As String, _
                               ByVal comments As String, _
                               ByVal service_end_dt As String, _
                               ByVal user_name As String, _
                               ByVal mod_level As String, _
                               ByVal add_activity As Boolean, _
                               Optional fld_list As Variant, _
                               Optional type_list As Variant, _
                               Optional val_list As Variant) As Integer

Description

These APIs allow you to modify an existing site part in the Clarify database. You must pass in a valid site part objid. You can then specify other data to modify the existing site_part record with. You also have the option of adding an activity log for this operation, or not. Finally, you may specify additional fields on the activity log, if desired.

Parameters

Parameter Name | Required? | Description
site_part_objid | Yes | The OBJID of the site_part to modify
instance_name | No | Instance name of the site_part. If blank, no change is made. If set to "#default", the instance name is set to the part number and mod_level of the site_part
serial_num | No | Serial number for the site_part. If blank, no change is made.
invoice_no | No | Invoice number for the site_part. If blank, no change is made.
ship_date | No | Ship date of the site_part. If blank, no change is made.
install_date | No | Install date of the site_part. If blank, no change is made.
warranty_date | No | Warranty date of the site_part. If blank, no change is made.
quantity | No | Quantity of the site_part.
part_status | No | Part status of the site_part. If blank, no change is made.
comments | No | Comments for the site_part. If blank, no change is made.
service_end_dt | No | Service end date for site_part. If blank, no change is made.
user_name | No | Who modified the site_part. If blank, current user is used.
mod_level | No | Revision for the site_part. Used for instance name if default instance name is set.
add_activity | Yes | Do we add an activity log for the site_part, or not.
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | Site part objid of 0 supplied
-2 | Invalid PART_STATUS supplied
-3 | Could not find specified site_part
-4 | Could not locate the mod_level for the site_part
-5 | Could not locate the part for the site_part
-6 | Site for the site_part could not be found
-7 | The specified user is not found in the database
-8 | Cannot locate activity string for "CHANGED DETAILS"
-9 | Quantity specified is < 1
-10 | A serial number and a quantity > 1 were both specified
-11 | Serialized site_part with quantity > 1
-12 | The site_part is not serialized, but a serial number was provided
-13 | The serial number provided is already in use
-17 | New mod_level is not found for the part for the site_part

Examples

Update an existing site part (268435460). Set the instance_name only. Generate an activity log.

Visual Basic:

Dim ret_int As Integer

ret_int = fcfo.modify_sp(268435460, "New instance name", "", "", "", "", "", _
            1, "", "", "", "", "", True, "", 0, "", 0, "", "", "", "", "", "")

JavaScript:

Var ret_int = fcfo.modify_sp(268435460, "New instance name", "", "", "", "",
     "",1, "", "", "", "", "", true, "", 0, "", 0, "", "", "", "", "", "");

Update an existing site part (268435461). Modify the serial number and ship date. Do not add an activity log

Visual Basic:

Dim ret_int As Integer

ret_int = fcfo.modify_sp(268435461, "", "ABCD", "", "1/1/2005", "", "", _
            1, "", "", "", "", "", False, "", 0, "", 0, "", "", "", "", "", "")

JavaScript:

Var ret_int = fcfo.modify_sp(268435461, "", "ABCD", "", "1/1/2005", "", "",
            1, "", "", "", "", "", false, "", 0, "", 0, "", "", "", "", "", "");


move_solution | fcSDK Documentation

move_solution

Public Function move_solution(ByVal solution_id As String, _
                              ByVal new_wipbin As String) As Integer

Description

This API causes the specified solution to be moved from one WIPBin to another (for the current owner). The solution must be open, and the WIPBin name must be valid for the current owner.

Note: This API allows you to move a solution object from one WIPBin to another, even if the object is currently dispatched. Since WIPBins are internal to a user, there really is no reason that you shouldn't be able to move the internal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

Parameters

Parameter Name | Required? | Description
solution_id | Yes | The solution to move
new_wipbin | Yes | Name of the WIPBin to move to

Returns

Value | Meaning
0 | No Errors
-1 | Cannot find the specified solution
-2 | Solution is already closed
-3 | New WIPBIN doesn't exist, or isn't for the owner
-4 | New WIPBIN is same as old - no move needed

Examples

Move solution number '14' to WIPBin 'Hardware'.

Visual Basic:

Dim ret_int As Integer

ret_int = fcinter.move_solution("14", "Hardware")

JavaScript:

var ret_int = fcinter.move_solution("14", "Hardware");


move_sp | fcSDK Documentation

move_sp

Public Function move_sp(ByVal sp_objid As Long,
                  ByVal move_date As String, ByVal parent_sp_objid As Long, _
                  ByVal site_id As String, ByVal parent_bin_objid As Long, _
                  ByVal add_activity As Boolean, ByVal user_name As String, _
                  ByVal install_and_move As Boolean) As Integer

Description

This API moves an existing site_part from one location to another within the Clarify site configuration. The site part to be moved must be current (not de-installed). The site_part can be moved to one (and only one!) of three places:

To the top-level at a site. Specify the site_id only.

Underneath another part. Specify the parent site_part objid only.

In a product bin. Specify the bin objid only.

Only one of the three locations may be specified. In addition, the API allows for the generation of the three standard activity log entries, and the user performing the move may be specified.

When a site_part is moved, all sub-site_parts underneath it are also moved.

Parameters

Parameter Name | Required? | Description
sp_objid | Yes | The OBJID of the site_part to be moved
move_date | No | The date that the site_part is being moved
parent_sp_objid | No | The OBJID of the site_part under which you wish to move the site_part. Only specified if the site_part is to be moved under another site_part
site_id | No | The site ID of the site to which you will move the site_part. Only specified for moves to the top-level of a site
parent_bin_objid | No | The bin objid to move the site_part to. Only specified if the site_part is to be placed in a bin
add_activity | Yes | Should activity log records be created, or not?
user_name | No | The user who moved the site_part. If left blank, the current user performs the move
install_and_move | Yes | Should the activity be listed as "Install (Move)" (True), or just "Move" (False)?

Returns

Value | Meaning
0 | No errors
-1 | Both a parent_site_part objid and a parent_bin_objid specified
-2 | Both a parent_site_part objid and a site_id specified
-3 | Both a site_id and parent_bin_objid specified
-4 | Cannot find specified user in database
-5 | Site part specified is not found in the database
-6 | Parent site_part specified is not found in the database
-7 | Install site specified is not found in the database
-8 | Parent bin specified is not found in the database
-9 | Cannot find the 'Move'/'Install(Move)' activity string with rank = 3700/11900
-10 | Site_part to be moved is currently de-installed
-11 | Cannot move the part (which is denoted only to be installed under another part) to the top-level of the site or under a bin
-12 | Cannot move the part (which is denoted only to be installed at the site or under a bin) under another part
-13 | No site part OBJID was specified

Examples

Move site_part 268435457 to the top level of site "4". Generate activity logs. Sam performs the move.

Visual Basic:

Dim ret_int As Integer

ret_int = fcfo.move_sp(268435457, 0, "4", 0, True, "sam", False)

JavaScript:

var ret_int = fcfo.move_sp(268435457, 0, "4", 0, true, "sam", false);

Move the same part under site_part 268435555. Don't generate activities, and use the default user.

Visual Basic:

Dim ret_int As Integer

ret_int = fcfo.move_sp(268435457, 268435555, "", 0, False, "", False)

JavaScript:

var ret_int = fcfo.move_sp(268435457, 268435555, "", 0, false, "", false);


reinstall_sp | fcSDK Documentation

reinstall_sp

Public Function reinstall_sp(ByVal sp_objid As Long, _
                  ByVal site_id As String, ByVal parent_bin_objid As Long, _
                  ByVal parent_sp_objid As Long, ByVal user_name As String, _
                  ByVal reinst_date As String, ByVal add_activity As Boolean, _
                  ByVal use_install As Boolean) As Integer

Description

This API can be used to re-install a site part (and the sub-parts installed underneath it) that have been deinstalled from a site in Clarify. The objid of the site_part to be re-installed is specified, as well as the site_id of the site to install it at. If the site_part is to be reinstalled in a bin, the bin's objid is specified. If it is to be installed under another part, the parent part's objid is specified. If the site_part is to be installed at the top-level of the site, neither objid is specified.

In addition, the user performing the action, and the time of the action can be specified, as well as if activity logs should be generated, or not. Finally, a flag allows the activities to be either "Re-install" or just "Install"

Parameters

Parameter Name | Required? | Description
sp_objid | Yes | OBJID for the site_part to be re-installed
site_id | Yes | The site to reinstall the site_part at. Note that this does not have to be the same as the site where it was de-installed
parent_bin_objid | No | The objid of the bin to install the site_part in (if one is used)
parent_sp_objid | No | The objid of the site_part to re-install the site_part under. If the site_part is not to be installed under another site_part, use a value of 0
user_name | No | Who performed the re-install? If blank, the current user is used
reinst_date | No | When was the re-installation? If blank, the current time is used
add_activity | Yes | Should activity log entries be generated?
use_install | Yes | Should the activity string be "Install" (True), or "Re-installed" (False). This flag should almost always = False

Returns

Value | Meaning
0 | No errors
-1 | The specified site_part is not in the database
-2 | The site_part is not de-installed
-3 | The specified site is not found
-4 | The specified user is not found
-5 | Cannot find the 'Install'/'Re-Install' activity string with rank = 3600/5900
-6 | Cannot find the specified parent bin
-7 | Cannot find the specified parent site_part
-8 | Cannot re-install to both a bin and a parent site_part
-9 | Cannot install sub_parts at the top level of a site (or in a bin)
-10 | Cannot install top-level only parts under a parent site_part
-11 | Cannot find the current deinstall_rip bin
-12 | Cannot find the old (deinstalled) site if different
-13 | A site objid must be specified

Examples

Joe reinstalled a site_part to the top level of site "2" on March 15, 1998, at noon. Add activities, and consider it a re-install action.

Visual Basic:

Dim ret_int As Integer

ret_int = fcfo.reinstall_sp(268435444, "2", 0, 0, "Joe", _
 "3/1/98 12:00:00", True, False)

JavaScript:

var ret_int = fcfo.reinstall_sp(268435444, "2", 0, 0, "Joe",
 "3/1/98 12:00:00", true, false);

The current user re-installs a site_part to site "S1" under a bin. Do not generate activity log entries.

Visual Basic:

Dim ret_int As Integer

ret_int = fcfo.reinstall_sp(268435457, "S1", 268435466, 0, "", "", _
                             False, False)

JavaScript:

var ret_int = fcfo.reinstall_sp(268435457, "S1", 268435466, 0, "", "",
                                false, false);


reject_solution | fcSDK Documentation

reject_solution

Public Function reject_solution(ByVal solution_id As String, _
                                ByVal reject_date As String, _
                                ByVal wipbin As String, _
                                ByVal notes As String, _
                                ByVal user_name As String, _
                                ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified solution to be rejected from the queue. The date and user performing the reject can be specified, and the API allows the solution to be placed back in any WIPBin of the owner. This is an augmentation over base Clarify where it is always rejected back to the default WIPBin. Also, the API allows for time bombs (for business rules) to be created, or not.

Parameters

Parameter Name | Required? | Description
solution_id | Yes | The solution to reject
reject_date | No | When did the reject occur. If left blank, current time is used
wipbin | No | The owner's WIPBin in which to place the solution. If left blank, it is rejected to the default WIPBin
notes | No | Notes about the reject
user_name | No | Who performed the reject? If left blank, current user is used
gen_time_bombs | Yes | Should a time bomb record be created for business rule notification?

Returns

Value | Meaning
0 | No Errors
-1 | Cannot find the specified solution
-2 | The solution is not currently dispatched
-3 | Cannot find the specified user
-4 | The solution is currently closed - cannot dispatch
-5 | Cannot find the new specified WIPBIN, or it is not a WIPBIN for the specified user
-6 | Cannot find activity string REJECT with rank equal to 2600

Examples

Reject solution number '14' to WIPBin 'Hardware'. The reject occurs on August 1, 1998, and is performed by Marty. Generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fcinter.reject_solution("14", "8/1/98", "Hardware", _
                                  "Some notes", "marty", true)

JavaScript:

var ret_int = fcinter.reject_solution("14", "8/1/98", "Hardware",
                                  "Some notes", "marty", true);

Reject solution number '2' to the default WIPBin. Do the reject now and with the current user. Do not generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fcinter.reject_solution("2", "", "", "", "", false)

JavaScript:

var ret_int = fcinter.reject_solution("2", "", "", "", "", false);


remove_emp_from_bus_org | fcSDK Documentation

remove_emp_from_bus_org

Public Function remove_emp_from_bus_org(ByVal user_name As String, _
                                        ByVal acct_id As String, _
                                        ByVal role_name As String) As Integer

Description

This API allows an employee (team member) to be removed from an account. The user name and account ID must be specified, as well as the role the user currently plays. The user may be included in the account with many roles, and only the specified role will be removed.

Parameters

Parameter Name | Required? | Description
user_name | Yes | The user name to remove from the account as a team member
acct_id | Yes | ID of the account
role_name | Yes | Role of the user to be removed from the account

Returns

Value | Meaning
0 | No errors
-1 | Cannot find specified user
-2 | The specified user is not on the account team with the specified role

Examples

Remove user 'Michelle' from account 'AN_CUST2' with role 'Manager'

Visual Basic:

Dim ret_int As Integer

ret_int = fcinter.remove_emp_from_bus_org("michelle", "AN_CUST2", "Manager")

JavaScript:

var ret_int = fcinter.remove_emp_from_bus_org("michelle", "AN_CUST2", "Manager");


remove_site_from_bus_org | fcSDK Documentation

remove_site_from_bus_org

Public Function remove_site_from_bus_org(ByVal site_id As String, _
                                         ByVal acct_id As String, _
                                         ByVal role_name As String) As Integer

Description

This API allows a site to be removed from an account. The site and account IDs must be specified, as well as the role the site currently plays. The site may be included in the account with many roles, and only the specified role will be removed.

Parameters

Parameter Name | Required? | Description
site_id | Yes | The site to remove from the account
acct_id | Yes | ID of the account
role_name | Yes | Role of the site to be removed from the account

Returns

Value | Meaning
0 | No errors
-1 | Cannot find specified site
-2 | Cannot find the role for the specified site
-3 | Cannot find the role for the specified site and account

Examples

Remove site '3' from account 'AN_CUST2' with role 'Development'.

Visual Basic:

Dim ret_int As Integer

ret_int = fcinter.remove_site_from_bus_org("3", "AN_CUST2", "Development")

JavaScript:

var ret_int = fcinter.remove_site_from_bus_org("3", "AN_CUST2", "Development");


unlink_case_from_workaround | fcSDK Documentation

unlink_case_from_workaround

Public Function unlink_case_from_workaround(ByVal case_id As String, _
                                  ByVal unlink_date As String, _
                                  ByVal user_name As String, _
                                  ByVal create_time_bomb As Boolean) As Integer

Description

This API allows a case to be unlinked from the workaround it is currently linked to. The case must already be linked to a workaround. The unlink date, and user can be specified. Also, a time bomb can be generated for business rules.

Parameters

Parameter Name | Required? | Description
case_id | Yes | Case id to unlink from
unlink_date | No | When was the unlink performed? If blank, current date/time is used
user_name | No | Who performed the unlink? If blank, current user is used
create_time_bomb | Yes | Should a time bomb be added to the system for business rule firing?

Returns

Value | Meaning
0 | No errors
-1 | Cannot find specified case
-2 | Case is not linked
-3 | Cannot find the specified user
-4 | Cannot find the activity string for "Un-Link" rank equal to 4000
-5 | Cannot find the specified user's employee record for relating time bomb

Examples

Unlink case '55' from the workaround at the current date/time by the current user. Generate time bombs.

Visual Basic:

Dim ret_int As Integer

ret_int = fcinter.unlink_case_from_workaround("55", "", "", true)

JavaScript:

var ret_int = fcinter.unlink_case_from_workaround("55", "", "", true);


unlink_cr_from_soln | fcSDK Documentation

unlink_cr_from_soln

Public Function unlink_cr_from_soln(ByVal cr_id As String, _
                                    ByVal soln_id As String, _
                                    ByVal unlink_date As String, _
                                    ByVal user_name As String, _
                                    ByVal create_time_bomb As Boolean) As Integer

Description

This API allows a CR to be unlinked from a solution it is currently linked to. The CR must already be linked to the solution. The unlink date, and user can be specified. Also, a time bomb can be generated for business rules.

Parameters

Parameter Name | Required? | Description
cr_id | Yes | CR to unlink
soln_id | Yes | Solution ID to unlink
unlink_date | No | When was the unlink performed? If blank, current date/time is used
user_name | No | Who performed the unlink? If blank, current user is used
create_time_bomb | Yes | Should a time bomb be added to the system for business rule firing?

Returns

Value | Meaning
0 | No errors
-1 | Cannot find specified CR
-2 | CR is not linked to the solution
-3 | Cannot find the specified user
-4 | Cannot find the activity string for "Unlink CR" rank equal to 6800
-5 | Cannot find the activity string for "Unlink Solution" rank equal to 6600
-6 | Cannot find the specified user's employee record for relating time bomb

Examples

Unlink CR '55' from the solution '66' at the current date/time by the current user. Generate time bombs.

Visual Basic:

Dim ret_int As Integer

ret_int = fcinter.unlink_cr_from_soln("55", "66", "", "", true)

JavaScript:

var ret_int = fcinter.unlink_cr_from_soln("55", "66", "", "", true);


update_address | fcSDK Documentation

update_address

update_address_list

Public Function update_address(ByVal addr_objid As Long, _
                               ByVal addr1 As String, _
                               ByVal addr2 As String, _
                               ByVal city As String, _
                               ByVal state As String, _
                               ByVal short_state As Boolean, _
                               ByVal zip As String, _
                               ByVal country As String, _
                               ByVal time_zone As String, _
                               ByVal int_fld1 As String, _
                               ByVal int_val1 As Long, _
                               ByVal int_fld2 As String, _
                               ByVal int_val2 As Long, _
                               ByVal str_fld1 As String, _
                               ByVal str_val1 As String, _
                               ByVal str_fld2 As String, _
                               ByVal str_val2 As String, _
                               ByVal date_fld1 As String, _
                               ByVal date_val1 As String) As Integer

Public Function update_address_list(ByVal addr_objid As Long, _
                                    ByVal addr1 As String, _
                                    ByVal addr2 As String, _
                                    ByVal city As String, _
                                    ByVal state As String, _
                                    ByVal short_state As Boolean, _
                                    ByVal zip As String, _
                                    ByVal country As String, _
                                    ByVal time_zone As String, _
                                    Optional fld_list As Variant, _
                                    Optional type_list As Variant, _
                                    Optional val_list As Variant) As Integer

Description

These APIs update addresses in the database. You must supply the objid of the address to update, and the fields to modify. If you don't wish to modify a specific field, you should leave it blank ("").

If you wish to change address line 1 or line 2 to be blank, you may use the additional fields (str_fld1, str_fld2) to set it.

Parameters

Parameter Name | Required? | Description
addr_objid | Yes | Objid of address to update
addr1 | No | Address line 1
addr2 | No | Address line 2
city | No | City
state | No | State
short_state | Yes | Is the "state" field the "short state name" (Ex: TX), or the long state name (Ex: Texas)
zip | No | Zipcode
country | No | Country
time_zone | No | Time zone
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified address
-2 | Cannot find the specified country
-3 | Cannot find the specified state
-4 | Cannot find the specified time zone

Examples

Update an address. Only update the address line 1 and the state.

Visual Basic:

Dim ret_int As Integer

ret_int = fcinter.update_address(268435012, "101 Main St.", "", _
              "", "LA", true, "", _
              "USA", "", "", 0, "", 0, _
              "", "", "", "", "", "")

JavaScript:

var ret_int = fcinter.update_address(268435012, "101 Main St.", "",
              "", "LA", true, "",
              "USA", "", "", 0, "", 0,
               "", "", "", "", "", "");


update_contact | fcSDK Documentation

update_contact

update_contact_list

update_contact_objid_list

Public Function update_contact(ByVal first As String, ByVal last As String, _
       ByVal phone As String, ByVal site_id As String, ByVal role As String, _
       ByVal fax As String, ByVal email As String, ByVal mail_stop As String, _
       ByVal the_title As String, ByVal hours As String, _
       ByVal salutation As String, ByVal new_first As String, _
       ByVal new_last As String, ByVal new_phone As String, _
       ByVal new_prim_site_id As String, ByVal new_prim_role As String, _
       ByVal int_fld1 As String, ByVal int_val1 As Long, ByVal int_fld2 As String, _
       ByVal int_val2 As Long, ByVal str_fld1 As String, ByVal str_val1 As String, _
       ByVal str_fld2 As String, ByVal str_val2 As String, _
       ByVal date_fld1 As String, ByVal date_val1 As String) As Integer

Public Function update_contact_list(ByVal first As String, _
       ByVal last As String, ByVal phone As String, ByVal site_id As String, _
       ByVal role As String, ByVal fax As String, ByVal email As String, _
       ByVal mail_stop As String, ByVal the_title As String, _
       ByVal hours As String, ByVal salutation As String, _
       ByVal new_first As String, ByVal new_last As String, _
       ByVal new_phone As String, ByVal new_prim_site_id As String, _
       ByVal new_prim_role As String, Optional fld_list As Variant, _
       Optional type_list As Variant, Optional val_list As Variant) As Integer

Public Function update_contact_objid_list(ByVal contact_objid As Integer, _
       ByVal site_id As String, ByVal role As String, ByVal fax As String, _
       ByVal email As String, ByVal mail_stop As String, ByVal the_title As String, _
       ByVal hours As String, ByVal salutation As String, _
       ByVal new_first As String, ByVal new_last As String, _
       ByVal new_phone As String, ByVal new_prim_site_id As String, _
       ByVal new_prim_role As String, Optional fld_list As Variant, _
       Optional type_list As Variant, Optional val_list As Variant) As Integer

Description

These APIs update a contact in the database. The update_contact and update_contact_list APIs use the first name, last name, and phone are used to look up the contact in the database. The update_contact_objid_list looks up the contact by objid. The other fields for the contact can be set. If they are left blank, then they are not set but are left at their current values.

Three fields are supplied that allow you to change the name or phone number of the contact.

The APIs also create contact roles (if needed). The API can therefore be used to add additional contact roles for a contact. Simply specify the contact name/phone (or objid), the site for the contact and the role. If the role doesn't exist, then it will be created. If the role already exists, a positive return code (+1) will be returned.

The new_prim_site and new_prim_role fields allow the primary contact role to be changed or modified for a contact. If neither field has a value supplied, the contact information is changed as described above. If only the new site is supplied, the current primary role will be updated to be shown at the new site. If only the new role is supplied, the current primary role will be changed, and will remain at the current site. If both are supplied, the current primary role will be updated to reflect both the new site and role.

Note: If you wish to create a duplicate contact (same first, last, and phone as another contact in the database), you may use the allow_duplicate_contact property.

Parameters

Parameter Name | Required? | Description
contact_objid | Yes* | Objid of the contact
first | Yes* | First name of the contact
last | Yes* | Last name of the contact
phone | Yes* | Phone number of the contact
site_id | Yes | Site ID for the contact role to create
role | Yes | The contact role to create
fax | No | Fax number for contact
email | No | Email address for contact
mail_stop | No | Mail stop for contact
the_title | No | Job title for contact
hours | No | Job hours for contact
salutation | No | Salutation for contact
new_first | No | New first name for contact (updates)
new_last | No | New last name for contact (updates)
new_phone | No | New phone number for contact (updates)
new_prim_site_id | No | New primary site ID
new_prim_role | No | New primary role name
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

* - contact_objid is required for update_contact_objid_list. first, last, phone are required for update_contact and update_contact_list.

Returns

Value | Meaning
0 | No errors
1 | Contact role already exists
-1 | First, Last, Phone not supplied for contact
-2 | Could not find the specified site
-3 | Could not find specified contact role in list
-4 | A contact with the same first name, last name and phone already exists
-5 | Cannot find the activity string CREATE CONTACT rank equal to 14000
-6 | Cannot find the activity string MODIFY rank equal to 1500
-7 | The specified role for the contact is already an alternate role for the specified site
-8 | The specified role for the contact is already the primary role for the specified site
-9 | The specified new site for the new primary role does not exist
-10 | Could not find specified new primary contact role in list
-11 | The specified role for the contact is already an alternate role for the specified site
ret_objid | Output - Returns the objid of the contact

Examples

Update Mary Smith. Change her name to "Mary Jones", and her phone number.

Visual Basic:

Dim ret_int As Integer

ret_int = fcinter.update_contact("Mary", "Smith", "555-1213", _
          "43", "End User", "", "", "", "", "","", "Jones", _
          "555-2222", "", "", "", 0, "", 0, "", "", "", "", _
          "", "")

JavaScript:

var ret_int = fcinter.update_contact("Mary", "Smith",
              "555-1213", "43", "End User", "", "", "", "", "",
              "", "Jones", "555-2222", "", "", "", 0, "", 0, "",
              "", "", "", "", "");

Update Mary Jones. Change her primary contact role to be 'Supervisor' at the current location.

Visual Basic:

Dim ret_int As Integer

ret_int = fcinter.update_contact("Mary", "Jones", "555-2222", _
              "43", "End User", "", "", "", "", "","", "", _
              "","", "Supervisor", "", 0, "", 0, "", "", "", "", _
              "", "")

JavaScript:

var ret_int = fcinter.update_contact("Mary", "Jones",
              "555-2222", "43", "End User", "", "", "", "", "",
              "", "", "","", "Supervisor", "", 0, "", 0, "",
              "", "", "", "", "");


update_price_inst | fcSDK Documentation

update_price_inst

Public Function update_price_inst(ByVal part_num As String, _
                ByVal domain As String, _
                ByVal mod_level As String, _
                ByVal price_prog As String, _
                ByVal priced_qty As Long, _
                ByVal price As String, _
                ByVal the_date As String) As Integer
```

#### Description

This API updates a price for an existing price instance. You must supply the part, revision, price program and quantity. Also, you must supply a date (any date) that occurs in the price instance. If that price instance is found, the price for it will be updated.

#### Parameters

| Parameter Name | Required? | Description |
|:--- |:--- |:--- |
| part_num | Yes | Part number to update price |
| domain | Yes | Domain of the part |
| mod_level | Yes | Revision to update price |
| price_prog | Yes | Name of the price program for the price |
| priced_qty | Yes | How many units in the price instance to be updated. Usually, this is = 1 |
| price | Yes | What is the new price of the part? |
| the_date | Yes | Date in the price range. Any date in the price instance range can be used |

#### Returns

| Value | Meaning |
|:--- |:--- |
| 0 | No errors |
| -1 | Part number was not found |
| -2 | Revision for the part was not found |
| -3 | Could not find the price program |
| -4 | The price instance cannot be found |
| -5 | The quantity supplied is < 1 |
| -6 | The price instance is found, but not for the supplied quantity |

#### Examples

Update the price for MS Word in the "Spring" price list for March 31 to $5.55.

**Visual Basic:**

Dim ret_int As Integer

ret_int = fcinter.update_price_inst("MS Word", "Product", "", "Spring", _ 1, "5.55", "3/31/2000")

**JavaScript:**

var ret_int = fcinter.update_price_inst("MS Word", "Product", "", "Spring", 1, "5.55", "3/31/2000");


yank_solution | fcSDK Documentation

yank_solution

Public Function yank_solution(ByVal solution_id As String, _
                              ByVal wipbin As String, _
                              ByVal yank_date As String, _
                              ByVal user_name As String, _
                              ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified solution to be yanked and placed in a specific WIPBin. The person perfoming the yank (the new owner) and the time of the yank can be specified. Also, the API allows for time bombs (for business rules) to be created, or not.

Parameters

Parameter Name | Required? | Description
solution_id | Yes | The solution to yank
wipbin | No | The WIPBin in which to place the solution. If left blank, it is yanked to the default WIPBin
yank_date | No | The date/time to yank the solution. If left blank, the current date/time is used
user_name | No | Who performed the yank? If left blank, current user is used
gen_time_bombs | Yes | Should a time bomb record be created for business rule notification?

Returns

Value | Meaning
0 | No Errors
-1 | Cannot find the specified solution
-2 | The solution is already closed
-3 | Cannot find the specified user
-4 | Cannot find the specified WIPBIN
-5 | Cannot find the activity string for "Yank" rank equal to 4100

Examples

Yank solution number '14' to WIPBin 'Hardware'. The yank occurs on August 1, 1998, and is performed by Marty. Generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fcinter.yank_solution("14", "Hardware", "8/1/98", "marty", true)

JavaScript:

var ret_int = fcinter.yank_solution("14", "Hardware", "8/1/98", "marty", true);

Yank solution number '2' to the default WIPBin. Do the yank now and with the current user. Do not generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fcinter.yank_solution("2", "", "", "", false)

JavaScript:

var ret_int = fcinter.yank_solution("2", "", "", "", false);


FCFL API Toolkit for ClearSales | fcSDK Documentation

FCFL API Toolkit for ClearSales

Overview

Many customers have wanted the ability to customize the Clarify environment easily by adding base Clarify functions (such as action item creation, closure, and modification) to web applications.

The First Choice Software FCFL API Toolkit for Clear Sales solves these problems, as well as many others. The toolkit is a series of COM functions that you may add to your customizations.

All of the APIs perform the same base functions as the Clarify GUI - all database records are properly written, activity logs are generated to track the API call, and time bombs are added to the system so that business rules can be fired based on the API function call.

While all of the APIs mimic the Clarify base function, many of them provide augmented functionality that Clarify customers have requested. For example, the base Clarify yank function always placed the object in the user's default WIPBin. With the yank API in the toolkit, you have the choice of placing the object in any specific WIPBin for the user, or in the default WIPBin.

The APIs are simple to use. One simple API call is provided for each function, and very few data values must be supplied. The APIs are flexible in that they provide a large number of optional arguments that allow you to customize the API calls as needed.


accept_action_item | fcSDK Documentation

accept_action_item

accept_opportunity

accept_quote

Public Function accept_action_item(ByVal the_id As String, _
                                   ByVal accept_date As String, _
                                   ByVal wipbin As String, _
                                   ByVal user_name As String, _
                                   ByVal gen_time_bombs As Boolean) As Integer

Public Function accept_opportunity(ByVal the_id As String, _
                                   ByVal accept_date As String, _
                                   ByVal wipbin As String, _
                                   ByVal user_name As String, _
                                   ByVal gen_time_bombs As Boolean) As Integer

Public Function accept_quote(ByVal the_id As String, _
                             ByVal accept_date As String, _
                             ByVal wipbin As String, _
                             ByVal user_name As String, _
                             ByVal gen_time_bombs As Boolean) As Integer

Description

These APIs cause the specified action item, opportunity, or quote to be accepted from a dispatched queue. The object must be currently dispatched to a queue. The date/time of the accept, the WIPBin to place the object in, and the user performing the accept can be specified. The API can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
the_id | Yes | The action item, opportunity, or quote to accept
accept_date | No | When was the object accepted. If this parameter is left blank, the object is accepted at the current time
wipbin | No | The WIPBin to place the object in (for the user who did the accept) If left blank, the object is placed in the user's default WIPBin
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified action item, opportunity, or quote
-2 | Action Item, opportunity, or quote is not currently dispatched
-3 | Specified user is not found
-4 | The specified WIPBin is not valid for the user
-5 | Cannot find gbst_elm rank 100 for string ACCEPT

Examples

Accept Action Item number '10' right now for the current user, place in the default WIPBin, and generate a time bomb.

JavaScript:

var ret_int = fcsfa.accept_action_item("10", "", "", "", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fcsfa.accept_action_item("10", "", "", "", True)

Accept quote number '2' at 10PM on November 23rd of 1997 by marty, and place it in marty's WIPBin named 'Urgent'. Don't generate a time bomb

JavaScript:

var ret_int = fcsfa.accept_quote("2", "11/23/97 22:00:00", "Urgent", "marty", false);

Visual Basic:

Dim ret_int As Integer

ret_int = fcsfa.accept_quote("2", "11/23/97 22:00:00", "Urgent", "marty", False)


assign_action_item | fcSDK Documentation

assign_action_item

assign_opportunity

assign_quote

Public Function assign_action_item(ByVal the_id As String, _
                                 ByVal new_user As String, _
                                 ByVal wipbin_name As String, _
                                 ByVal assign_date As String, _
                                 ByVal user_name As String, _
                                 ByVal gen_time_bombs As Boolean) As Integer

Public Function assign_opportunity(ByVal the_id As String, _
                                 ByVal new_user As String, _
                                 ByVal wipbin_name As String, _
                                 ByVal assign_date As String, _
                                 ByVal user_name As String, _
                                 ByVal gen_time_bombs As Boolean) As Integer

Public Function assign_quote(ByVal the_id As String, _
                             ByVal new_user As String, _
                             ByVal wipbin_name As String, _
                             ByVal assign_date As String, _
                             ByVal user_name As String, _
                             ByVal gen_time_bombs As Boolean) As Integer

Description

These APIs cause the specified action item, opportunity, or quote to be assigned to a new user. The object must be in open condition, and the user assigning the object does not have to be the owner of the object. In base Clarify, the assigner of a object must be the owner. If either user name is not specified, the "current" user is used. The date/time of the assignment, and the WIPBin to place the object in can also be specified. Allowing a WIPBin other than the default one is also an augmentation from base Clarify. The API can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
the_id | Yes | The action item, opportunity, or quote ID to be assigned
new_user | No | The user who the object is assigned to. If left blank, the object is assigned to the current user
wipbin_name | No | The WIPBin to place the object in (for the user who is assigned the case). If left blank, the object is placed in the user's default WIPBin
assign_date | No | When was the object assigned. If this parameter is left blank, the case is assigned at the current time
user_name | No | The user who assigned the object If left blank, the current user performs the assign
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified action item, opportunity, or quote
-2 | The specified object is not currently open
-3 | Specified user (to assign to) is not found
-4 | The specified WIPBin is not valid for the user
-5 | Specified user (who performed the assign) is not found
-6 | Cannot find gbst_elm rank 10500 for string ASSIGN

Examples

Assign action item number '10' to user 'marty'. The assign is performed by the current user, is placed in the default WIPBin and is assigned at the current time. Generate a time bomb.

JavaScript:

var ret_int = fcsfa.assign_action_item("10", "marty", "", "", "", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fcsfa.assign_action item("10", "marty", "", "", "", True)

Assign opportunity number '2' at 10PM on November 23rd of 1997 to marty, and place it in marty's WIPBin named 'Urgent'. Assign should be logged as performed by sam. Don't generate a time bomb.

JavaScript:

var ret_int = fcsfa.assign_quote("2", "marty", "Urgent", "11/23/97 22:00:00", "sam", false);

Visual Basic:

Dim ret_int As Integer

ret_int = fcsfa.assign_quote("2", "marty", "Urgent", "11/23/97 22:00:00", "sam", False)


assign_lead | fcSDK Documentation

assign_lead

Public Function assign_lead(ByVal lead_objid As Long, _
                            ByVal new_owner As String, _
                            ByVal assign_date As String, _
                            ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified lead to be assigned to a new user. The objid of the lead must be specified (since there are no other unique keys for leads), and the new user name to assign to must also be supplied. Optionally, the assign date/time may be specified.

Note: Unlike objects such as cases, quotes, and part requests, leads are not queueable objects in Clarify. By "assigning" the lead, you simply cause it to be seen by the new owner when they view leads in ClearSales. They will not show up in a WIPBin or queue.

Parameters

Parameter Name | Required? | Description
lead_objid | Yes | Objid (unique identifier) of the lead
new_owner | Yes | Login name of new owner of the lead
assign_date | No | When did the assign take place? If blank, the current date/time is used
gen_time_bombs | Yes | Should a time bomb be created? Values are "True" or "False".

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified lead
-2 | The specified user cannot be found
-3 | The LEAD activity string is not found

Examples

Assign action item number '10' to user 'marty'. The assign is performed by the current user, is placed in the default WIPBin and is assigned at the current time. Generate a time bomb.

JavaScript:

var ret_int = fcsfa.assign_action_item("10", "marty", "", "", "", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fcsfa.assign_action item("10", "marty", "", "", "", True)

Assign lead 268435457 to user "gary" at the current date/time.

JavaScript:

var ret_int = fcsfa.assign_lead(268435457, "gary", "", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fcsfa.assign_lead(268435457, "gary", "", True)

Assign lead 268435457 to user "cheryl" on 1/1/01 at 8AM.. Do not generate time bombs.

JavaScript:

var ret_int = fcsfa.assign_lead(268435457, "cheryl", "1/1/01 08:00:00", false);

Visual Basic:

Dim ret_int As Integer

ret_int = fcsfa.assign_lead(268435457, "cheryl", "1/1/01 08:00:00", False)


change_action_item_status | fcSDK Documentation

change_action_item_status

change_opportunity_status

change_quote_status

Public Function change_action_item_status(ByVal the_id As String, _
                                   ByVal new_status As String, _
                                   ByVal change_date As String, _
                                   ByVal notes As String, _
                                   ByVal local_user_name As String, _
                                   ByVal gen_time_bombs As Boolean) As Integer

Public Function change_opportunity_status(ByVal the_id As String, _
                                   ByVal new_status As String, _
                                   ByVal change_date As String, _
                                   ByVal notes As String, _
                                   ByVal local_user_name As String, _
                                   ByVal gen_time_bombs As Boolean) As Integer

Public Function change_quote_status(ByVal the_id As String, _
                                    ByVal new_status As String, _
                                    ByVal change_date As String, _
                                    ByVal notes As String, _
                                    ByVal local_user_name As String, _
                                    ByVal gen_time_bombs As Boolean) As Integer

Description

These APIs cause the specified action item, opportunity, or quote to have its status changed. The object may be in any valid condition, but the status selected MUST be valid for the current condition. In other words, you cannot assign a Won condition status (for an opportunity) to an opportunity that is currently in Lost condition. You may assign notes to the status change, as well as set the time of the status change, and the user who changed the status. The APIs can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
the_id | Yes | The ID of the object to change status for
new_status | No | The new status for the object
change_date | No | When was the object status changed. If this parameter is left blank, the object is status changed at the current time
notes | No | Notes for the status change
local_user_name | No | The user who changed the status. If left blank, the current user performs the change status. For business rules, it defaults to the user_name who is executing the cbbatch
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified object
-2 | Cannot find the new status (or status is not defined for the current object's condition)
-3 | Cannot find the specified user
-5 | Cannot find the CHANGE STATUS activity string

Examples

Change status for opportunity number '154' to the default status. The change status is performed by the current user and is changed at the current time. Add no notes, and generate a time bomb.

JavaScript:

var ret_int = fcsfa.change_opportunity_status("154", "", "", "", "", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fcsfa.change_opportunity_status("154", "", "", "", "", True)

Change status for quote number '2' at 10PM on November 23rd of 1997 to 'Solved'. Change status has notes of 'Some notes', and should be logged as performed by dave. Don't generate a time bomb.

JavaScript:

var ret_int = fcsfa.change_quote_status("2", "Solved", "11/23/97 22:00:00",
                                        "Some notes", "dave", false);

Visual Basic:

Dim ret_int As Integer

ret_int = fcsfa.change_quote_status("2", "Solved", "11/23/97 22:00:00", _
                                    "Some notes", "dave", False)


change_task_cond | fcSDK Documentation

change_task_cond

Public Function change_task_cond(ByVal task_id As String, _
                                 ByVal new_cond As String, _
                                 ByVal new_status As String, _
                                 ByVal user_name As String, _
                                 ByVal change_date As String, _
                                 ByVal gen_time_bombs As Boolean) As Integer

Description

This API can be used to change the condition and (optionally) a status for an action item. You must supply the action item ID and the condition, but no other data is required. The APIs can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
task_id | Yes | The ID of the action item to change
new_cond | Yes | The new condition for the action item
new_status | No | New status for the action item
user_name | No | The user who changed the condition/status. If left blank, the current user performs the change status.
change_date | No | When was the condition/status changed. If this parameter is left blank, the change occurs at the current time
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Invalid condition specified
-2 | Cannot find the specified action item
-3 | The action item is currently closed
-4 | The action item is currently dispatched
-5 | Cannot locate the specified user
-6 | The status provided is not valid for the specified condition
-7 | Cannot find the employee record for the specified user
-8 | Cannot find the activity string for "Change Condition"

Examples

Change condition and status for action item '44' to Not Started/Working. Generate a time bomb.

JavaScript:

var ret_int = fcsfa.change_task_cond("44", "Not Started", "Working", "",
                                     "", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fcsfa.change_task_cond("44", "Not Started", "Working", "", "", True)

Change to the default status for action item "55" on 1/1/2005. The change was performed by "Fred". Do not generate a time bomb.

JavaScript:

var ret_int = fcsfa.change_task_cond("55", "Not Started", "", "fred",
                                     "1/1/2005", false);

Visual Basic:

Dim ret_int As Integer

ret_int = fcsfa.change_task_cond("55", "Not Started", "", "fred",
                                     "1/1/2005", False)


close_opp | fcSDK Documentation

close_opp

Function close_opp(ByVal opp_id As String, _ ByVal the_status As String, _ ByVal close_date As String, _ ByValu user_name As String, _ ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified opportunity to be closed. You may specify the status (in closed opportunity condition) for the opportunity, as well as the user name of the closer, and the date/time of the close. The APIs can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
opp_id | Yes | The ID of the opportunity to close
the_status | No | The new status for the opportunity. If blank, the default status for Closed Opportunity condition is used
close_date | No | When was the opportunity closed? If this parameter is left blank, the opportunity is closed at the current time
user_name | No | The user who closed the opportunity. If left blank, the current user performs the close
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified status for the closed opportunity condition
-2 | Cannot find the CLOSE OPP activity string
-3 | Cannot find the specified opportunity
-4 | The opportunity is already closed
-5 | The opportunity cannot be closed since it is already dispatched
-6 | The specified user is not found
-7 | The employee for the specified user cannot be found

Examples

Close opportunity "32" at the current time with the current user. Put in closed status "close now". Generate a time bomb.

JavaScript:

ret_int = fcsfa_obj.close_opp("32", "close now", "", "", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fcsfa_obj.close_opp("32", "close now", "", "", True)


cr_contr_itm | fcSDK Documentation

cr_contr_itm

cr_contr_itm_list

Public Function cr_contr_itm(ByVal contract_id As String, _
                             ByVal user_name As String, _
                             ByVal create_date As String, _
                             ByVal start_date As String, _
                             ByVal end_date As String, _
                             ByVal part_num As String, _
                             ByVal domain As String, _
                             ByVal rev As String, _
                             ByVal quantity As Long, _
                             ByVal price_schedule As String, _
                             ByVal oride_price As String, _
                             ByVal units_used As Double, _
                             ByVal serial_num As String, _
                             ByVal is_taxable As Boolean, _
                             ByVal install_it As Boolean, _
                             ByVal comments As String, _
                             ByVal quoted_site As String, _
                             ByVal serviced_at_site As String, _
                             ByVal parent_objid As Long, _
                             ByVal po_num As String, _
                             Optional fld_list As Variant, _
                             Optional type_list As Variant, _
                             Optional val_list As Variant) As Integer

Public Function cr_contr_itm_list(ByVal contract_id As String, _
                             ByVal user_name As String, _
                             ByVal create_date As String, _
                             ByVal start_date As String, _
                             ByVal end_date As String, _
                             ByVal part_num As String, _
                             ByVal domain As String, _
                             ByVal rev As String, _
                             ByVal quantity As Long, _
                             ByVal price_schedule As String, _
                             ByVal oride_price As String, _
                             ByVal units_used As Double, _
                             ByVal serial_num As String, _
                             ByVal is_taxable As Boolean, _
                             ByVal install_it As Boolean, _
                             ByVal comments As String, _
                             ByVal quoted_site As String, _
                             ByVal serviced_at_site As String, _
                             ByVal parent_objid As Long, _
                             ByVal po_num As String, _
                             ByVal int_fld1 As String, _
                             ByVal int_val1 As Long, _
                             ByVal int_fld2 As String, _
                             ByVal int_val2 As Long, _
                             ByVal str_fld1 As String, _
                             ByVal str_val1 As String, _
                             ByVal str_fld2 As String, _
                             ByVal str_val2 As String, _
                             ByVal date_fld1 As String, _
                             ByVal date_val1 As String) As Integer

Description

These APIs are used to create quote/contract line items. They require that a valid quote already exist, and that it have at least one valid schedule. In addition, the supplied part/revision must have a price defined for it in the schedule, or you must provide an override.

The API will create a line item, add it to the proper contract/quote, and adjust all of the totals. In addition, the schedule adjustments (if any) for the schedule of the line item will be recalculated, given the new schedule totals.

You must specify a contract id and a price schedule, and a quantity of items in the line. You must also specify the part/revision/domain of the part to quote. All other arguments can be left blank. You may specify the user who created the line item, as well as the create date. You may also specify a start/end date for the line item.

You may specify an override price (per unit price). If this is blank, then the price from the price schedule is used. You may specify how many units are used in the line. The units available is calcularted from this number.

A purchase order number may be specified. If it is, it must be a valid purchase order for the contract schedule specified for this line item.

If it is serialized part (quantity 1), the serial number may be specified. You may also specify the taxable state, and if the part is to be auto-installed. If it is, you must supply the site that it will be installed at. You may also specify the serviced at site, as well as additional fields.

If you wish to make this a parent line item, put -1 in the parent_objid argument. Else, put the objid of the parent line item in the field. It will be made a child of the parent line item. If the line item is to be a stand-alone item (the item is not a parent or child), put a -2 in the parent_objid argument.

The API does not do a few other items in the base GUI function. By and large, they are expected to be supplied with other API calls. For example, line item adjustments are not part of this API. If they are required, the line should be created, and then the adjustment should be applied. Parent/child line items are not provided for in the default API. Also, proration (ClearContracts) is currently hard-coded.

The objid of the newly-created contract line item will be returned in fcsfa.ret_objid.

Parameters

Parameter Name | Required? | Description
contract_id | Yes | The quote/contract for the line item
user_name | No | The user who created the line item. If left blank, the current user performs the create. For business rules, it defaults to the user_name who is executing the cbbatch
create_date | No | Line item creation date. If left blank, current date/time is used
start_date | No | Start date/time of the line item. If blank, create_date is used
end_date | No | End date/time of the line item. If blank, create_date + 1 year is used
part_num | Yes | Part number of part to quote
domain | Yes | Domain of part to quote
rev | Yes | Revision of part to quote
quantity | Yes | Number of units in line
price_schedule | Yes | Name of the schedule from the quote to put the line on
oride_price | No | If supplied, this is the per-unit price. If blank, price is taken from the price schedule
units_used | No | If supplied, this is the number of units used. If = 0 (default), then all units are initially available
serial_num | No | For serialized parts, the serial number to quote
is_taxable | Yes | Is the line taxable?
install_it | Yes | Should the part be marked for auto-install?
comments | No | Comments about the line item
quoted_site | No | Site ID of the site for auto-install. If auto-install = True, this must be supplied
serviced_at_site | No | The site ID of the site servicing the line
parent_objid | Yes | The objid of the parent line item. If set to -1 then this is a parent line item. If set to -2 then this is a stand-alone item.
po_num | No | Purchase order number for this line item. Must be a valid purchase order number for the schedule specified above
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | Quantity supplied is < 1
-2 | End date is earlier than start date
-3 | The specified quote/contract was not found
-4 | Could not find the specified user
-5 | The revision is not found for the specified part/domain
-6 | The specified schedule is not found for the contract/quote
-7 | The specified quoted_at site was not found
-8 | The specified serviced_at site was not found
-9 | The specified part/revision is not found on the price schedule
-10 | Serial number supplied with a quantity > 1
-13 | The specified part is quantity tracked, and a serial number was supplied
-14 | The line was marked with auto-install, and no site was supplied
-15 | The override price given was not numeric
-16 | Cannot locate the specified site_part
-17 | The specified parent line item does not exist
-18 | The specified parent line item is not actually a parent. It is a child line item
-19 | The specified product is priced as a percentage of parent, but no parent was given
-20 | The specified product is priced as a percentage of child - not supported for this API
-21 | The specified purchase order is not found for the contract schedule.
-22 | The mod_level is not found for the parent contract item.

Examples

Create a new line item for quote "2". A total of 3 Notebooks are quoted for the default schedule. Add a comment, and relate to purchase order '222'.

Field version:

JavaScript:

var ret_int = fcsfa.cr_contr_itm("2", "", "", "", "", "Notebook", "Quantity",
                   "", 3, "Default Schedule", "", 0, "", true, false,
                   "A Comment", "", "", -1, "222", "x_int1", 44, "", 0, "",
                   "", "", "", "", "");

Visual Basic:

Dim ret_int As Integer

ret_int = fcsfa.cr_contr_itm("2", "", "", "", "", "Notebook", "Quantity", _
                   "", 3, "Default Schedule", "", 0, "", True, False, _
                   "A Comment", "", "", -1, "222", "x_int1", 44, "", 0, "", _
                   "", "", "", "", "")

List version:

JavaScript:

var fld_list  = Server.CreateObject("FCFLCOMPAT.FCLIST");
var type_list = Server.CreateObject("FCFLCOMPAT.FCLIST");
var val_list  = Server.CreateObject("FCFLCOMPAT.FCLIST");

fld_list.AppendItem("x_int1");
type_list.AppendItem("Long");
val_list.AppendItem("44");

var ret_int = fcsfa.cr_contr_itm("2", "", "", "", "", "Notebook", "Quantity",
          "", 3, "Default Schedule", "", 0, "", true, false,
          "A Comment", "", "", -1, "222", fld_list,
          type_list, val_list);

Visual Basic:

Dim ret_int As Integer
Dim fld_list   As New FCList
Dim type_list  As New FCList
Dim val_list   As New FCList

fld_list.AppendItem("x_int1")
type_list.AppendItem("Long")
val_list.AppendItem("44")

ret_int = fcsfa.cr_contr_itm("2", "", "", "", "", "Notebook", "Quantity", _
          "", 3, "Default Schedule", "", 0, "", True, False, _
          "A Comment", "", "", -1, "222", fld_list, _
          type_list, val_list)


create_action_item | fcSDK Documentation

create_action_item

create_action_item_list

Public Function create_action_item(ByVal title As String, _
                                   ByVal notes As String, _
                                   ByVal first_name As String, _
                                   ByVal last_name As String, _
                                   ByVal phone As String, _
                                   ByVal acct_name As String, _
                                   ByVal lead_first As String, _
                                   ByVal lead_last As String, _
                                   ByVal opp_id As String, _
                                   ByVal the_type As String, _
                                   ByVal priority As String, _
                                   ByVal start_date As String, _
                                   ByVal due_date As String, _
                                   ByVal complete_date As String, _
                                   ByVal status As String, _
                                   ByVal create_date As String, _
                                   ByVal user_name As String, _
                                   ByVal gen_time_bombs As Boolean, _
                                   ByVal int_fld1 As String, _
                                   ByVal int_val1 As Long, _
                                   ByVal int_fld2 As String, _
                                   ByVal int_val2 As Long, _
                                   ByVal str_fld1 As String, _
                                   ByVal str_val1 As String, _
                                   ByVal str_fld2 As String, _
                                   ByVal str_val2 As String, _
                                   ByVal date_fld1 As String, _
                                   ByVal date_val1 As String) As Integer

Public Function create_action_item_list(ByVal title As String, _
                                        ByVal notes As String, _
                                        ByVal first_name As String, _
                                        ByVal last_name As String, _
                                        ByVal phone As String, _
                                        ByVal acct_name As String, _
                                        ByVal lead_first As String, _
                                        ByVal lead_last As String, _
                                        ByVal opp_id As String, _
                                        ByVal the_type As String, _
                                        ByVal priority As String, _
                                        ByVal start_date As String, _
                                        ByVal due_date As String, _
                                        ByVal complete_date As String, _
                                        ByVal status As String, _
                                        ByVal create_date As String, _
                                        ByVal user_name As String, _
                                        ByVal gen_time_bombs As Boolean, _
                                        Optional fld_list As Variant, _
                                        Optional type_list As Variant, _
                                        Optional val_list As Variant) As Integer

Description

These APIs are used to create new action items. Most of the data you can specify is optional for the action item, including the contact, lead, account, and opportunity. You may specify the creation date, the start date, and the completion date. If you do not specify a completion date, it will be set to one week after the start date. You may specify the user who created the action item, and you may specify additional fields. You may have a creation time bomb generated (for notifications). The ID of the new action item is returned.

If you want to relate a contact to the action item you must supply all three of the contact fields. Likewise, if you wish to associate a lead to the action item you must supply both lead fields.

The task_id of the newly-created action item will be returned in fcsfa.ret_id_num. The objid of the action item will be returned in fcsfa.ret_objid.

Parameters

Parameter Name | Required? | Description
title | No | The title of the action item
notes | No | Notes about the action item
first_name | No | First name of the related contact
last_name | No | Last name of the related contact
phone | No | Phone number of the related contact
acct_name | No | Name of the account to relate to the action item
lead_first | No | First name of the related lead
lead_last | No | Last name of the related lead
opp_id | No | Opportunity related to the action item
the_type | No | Type of the action item (code list value). If empty, default value is used
priority | No | Priority for the action item. If empty, default value is used
start_date | No | Start date for the action item. If empty, current date/time is used
due_date | No | Required completion date of the task. If empty, one week after the start
complete_date | No | End date for the action item. If empty, default value is used
status | No | Status for the action item. If empty, default status is used
create_date | No | When was the action item created? If empty, current date/time is used
user_name | No | Who created the action item? If empty, current user is used
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules). and prior warning time?
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | The completion date is earlier than the start date
-2 | The supplied contact could not be found
-3 | The specified user could not be found
-4 | Cannot find the specified account
-5 | Cannot find the specified lead
-6 | Cannot find the specified opportunity
-7 | The specified status cannot be found
-8 | The specified type cannot be found
-9 | The specified priority cannot be found
-10 | The CREATE ACTION ITEM activity code could not be found
-11 | The employee record for the specified user could not be found

Examples

Create a new action item. Give a title and notes for the action item. The contact is 'Bill Gates'. The account is 'Microsoft.' A status, type, and priority are given. Create the action item on Janurary 1st, set to start on January 2nd, and to expire at the end of the month. Generate time bombs, and set a user-defined field.

Field version:

JavaScript:

var ret_int = fcsfa.create_action_item("The Title", "Some notes", "Bill",
       "Gates", "206-555-1212", "Microsoft", "", "", "",
       "Fax", "High", "1/2/00", "1/30/00", "Not Started",
       "1/1/00", "", true, "", 0, "", 0, "x_str1",
       "A value", "", "", "", "")

Visual Basic:

Dim ret_int As Integer

ret_int = fcsfa.create_action_item("The Title", "Some notes", "Bill", _
   "Gates", "206-555-1212", "Microsoft", "", "", "", _
   "Fax", "High", "1/2/00", "1/30/00", "Not Started", _
   "1/1/00", "", True, "", 0, "", 0, "x_str1", _
   "A value", "", "", "", "")

List version:

JavaScript:

var fld_list  = Server.CreateObject("FCFLCOMPAT.FCLIST");
var type_list = Server.CreateObject("FCFLCOMPAT.FCLIST");
var val_list  = Server.CreateObject("FCFLCOMPAT.FCLIST");

fld_list.AppendItem("x_create_int1");
type_list.AppendItem("Long");
val_list.AppendItem("1");

fld_list.AppendItem("x_ create_int2");
type_list.AppendItem("Long");
val_list.AppendItem("456");

fld_list.AppendItem("x_summary2");
type_list.AppendItem("String");
val_list.AppendItem("More text");

var ret_int = fcsfa.create_action_item("The Title", "Some notes", "Bill",
       "Gates", "206-555-1212", "Microsoft", "", "", "",
       "Fax", "High", "1/2/00", "1/30/00", "Not Started",
       "1/1/00", "", true, fld_list, type_list, val_list);

Visual Basic:

Dim ret_int As Integer
Dim fld_list   As New FCList
Dim type_list  As New FCList
Dim val_list   As New FCList

fld_list.AppendItem("x_create_int1")
type_list.AppendItem("Long")
val_list.AppendItem("1")

fld_list.AppendItem("x_ create_int2")
type_list.AppendItem("Long")
val_list.AppendItem("456")

fld_list.AppendItem("x_summary2")
type_list.AppendItem("String")
val_list.AppendItem("More text")

ret_int = fcsfa.create_action_item("The Title", "Some notes", "Bill", _
   "Gates", "206-555-1212", "Microsoft", "", "", "", _
   "Fax", "High", "1/2/00", "1/30/00", "Not Started", _
   "1/1/00", "", True, fld_list, type_list, val_list)


create_opp | fcSDK Documentation

create_opp

create_opp_list

Public Function create_opp(ByVal opp_name As String, _
                           ByVal acct_id As String, _
                           ByVal con_first As String, _
                           ByVal con_last As String, _
                           ByVal con_phone As String, _
                           ByVal terr_name As String, _
                           ByVal amt As Currency, _
                           ByVal close_date As String, _
                           ByVal sales_stage As String, _
                           ByVal lead_source As String, _
                           ByVal the_currency As String, _
                           ByVal prob As String, _
                           ByVal process As String, _
                           ByVal user_name As String, _
                           ByVal create_date As String, _
                           ByVal gen_time_bombs As Boolean, _
                           ByVal int_fld1 As String, _
                           ByVal int_val1 As Long, _
                           ByVal int_fld2 As String, _
                           ByVal int_val2 As Long, _
                           ByVal str_fld1 As String, _
                           ByVal str_val1 As    String, _
                           ByVal str_fld2 As String, _
                           ByVal str_val2 As String, _
                           ByVal date_fld1 As String, _
                           ByVal date_val1 As String) As Integer

Public Function create_opp_list(ByVal opp_name As String, _
                                ByVal acct_id As String, _
                                ByVal con_first As String, _
                                ByVal con_last As String, _
                                ByVal con_phone As String, _
                                ByVal terr_name As String, _
                                ByVal amt As Currency, _
                                ByVal close_date As String, _
                                ByVal sales_stage As String, _
                                ByVal lead_source As String, _
                                ByVal the_currency As String, _
                                ByVal prob As String, _
                                ByVal process As String, _
                                ByVal user_name As String, _
                                ByVal create_date As String, _
                                ByVal gen_time_bombs As Boolean, _
                                Optional fld_list As Variant, _
                                Optional type_list As Variant, _
                                Optional val_list As Variant) As Integer

Description

These APIs are used to create opportunities. The opportunity name must be specified. All other data is optional. The account, contact, territory, stage, source, currency, and process may be specified. You may generate time bombs for business rules, or not. Also, an amount and a probability may be specified.

The ID of the newly-created opportunity will be returned in fcsfa.ret_id_num. The objid of the opportunity will be returned in fcsfa.ret_objid.

Parameters

Parameter Name | Required? | Description
opp_name | Yes | Name of the opportunity
acct_id | No | ID of the related account
con_first, con_last, con_phone | No | Name and phone number of related contact. If a contact is to be specified, all three must be given
terr_name | No | Name of the territory. If blank, the default territory is used
amt | No | Amount of the opportunity. Must be numeric
close_date | No | Close date of the opportunity. If blank, the current date/time are used
sales_stage | Yes | Sales stage for the opportunity.
lead_source | No | Lead source for the opportunity. If blank, default source is used
the_currency | No | Currency for the opportunity. If blank, default currency is used.
prob | No | Probability of opportunity close. Must be numeric, and between 0 and 1
process | No | Process for the opportunity. If blank, default process is used
user_name | No | Creator of the opportunity. If blank, the current user is used
create_date | No | When was the opportunity created? If blank, current date/time is used
gen_time_bombs | Yes | Should time_bombs be built for business rule evaluation
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | No opportunity name was supplied
-2 | The supplied account ID could not be found
-3 | The specified contact could not be found
-4 | The specified territory could not be found
-5 | The specified lead source could not be found
-6 | The sales stage supplied is not valid
-7 | The currency specified is not valid
-8 | The specified process/life cycle could not be located
-9 | The probability supplied is not numeric or is not between 0 and 1
-10 | Cannot find the specified user
-11 | The specified cycle stage is not valid
-12 | Cannot find the Create opportunity activity string
-13 | Cannot find the Won activity string
-14 | Cannot find the Lost activity string

Examples

Create a new opportunity. Specify an account, a contact, a territory, an amount (123.33), a close date, the stage, the source, the currency, a probability of .5, a process of 'default'. Use the current user name and time. Generate time bombs. Also, specify a new string field.

Field version:

JavaScript:

var ret_int = fcsfa.create_opp("My opp", "AN_CUST1", "a", "b", "c",
                      "The World", "123.33", "1/1/00", "Lost", "Default",
                      "US Dollar", ".5", "default", "", "", true, "", 0, "", 0,
                        "x_objective", "foobar", "", "", "", "");

Visual Basic:

Dim ret_int As Integer
Dim opp_id     As String

ret_int = fcsfa.create_opp("My opp", "AN_CUST1", "a", "b", "c", "The World", _
                        "123.33", "1/1/00", "Lost", "Default", "US Dollar", _
                        ".5", "default", "", "", True, "", 0, "", 0, _
                        "x_objective", "foobar", "", "", "", "")

List version:

JavaScript:

var fld_list  = Server.CreateObject("FCFLCOMPAT.FCLIST");
var type_list = Server.CreateObject("FCFLCOMPAT.FCLIST");
var val_list  = Server.CreateObject("FCFLCOMPAT.FCLIST");

fld_list.AppendItem("x_objective");
type_list.AppendItem("String");
val_list.AppendItem("foobar");

var ret_int = fcsfa.create_opp("My opp", "AN_CUST1", "a", "b", "c",
                        "The World", "123.33", "1/1/00", "Lost", "Default",
                        "US Dollar", ".5", "default", "", "", true, fld_list
                        type_list, val_list);

Visual Basic:

Dim ret_int As Integer
Dim fld_list   As New FCList
Dim type_list  As New FCList
Dim val_list   As New FCList

fld_list.AppendItem("x_objective")
type_list.AppendItem("String")
val_list.AppendItem("foobar")

ret_int = fcsfa.create_opp("My opp", "AN_CUST1", "a", "b", "c", "The World", _
            "123.33", "1/1/00", "Lost", "Default", "US Dollar", _
            ".5", "default", "", "", True, fld_list, _
            type_list, val_list)


create_quote | fcSDK Documentation

create_quote

create_quote_list

Public Function create_quote_list(ByVal quote_title As String, _
                                  ByVal account_id As String, _
                                  ByVal site_id As String, _
                                  ByVal opp_id As String, _
                                  ByVal first As String, _
                                  ByVal last As String, _
                                  ByVal phone As String, _
                                  ByVal status As String, _
                                  ByVal bill_to_site As String, _
                                  ByVal ship_to_site As String, _
                                  ByVal the_curr As String, _
                                  ByVal price_prog As String, _
                                  ByVal queue As String, _
                                  ByVal admin_user As String, _
                                  ByVal create_date As String, _
                                  ByVal user_name As String, _
                                  ByVal quote_len As Integer, _
                                  ByVal gen_time_bombs As Boolean, _
                                  ByVal int_fld1 As String, _
                                  ByVal int_val1 As Long, _
                                  ByVal int_fld2 As String, _
                                  ByVal int_val2 As Long, _
                                  ByVal str_fld1 As String, _
                                  ByVal str_val1 As    String, _
                                  ByVal str_fld2 As String, _
                                  ByVal str_val2 As String,
                                  ByVal date_fld1 As String, _
                                  ByVal date_val1 As String) As Integer

Public Function create_quote_list(ByVal quote_title As String, _
                                  ByVal account_id As String, _
                                  ByVal site_id As String, _
                                  ByVal opp_id As String, _
                                  ByVal first As String, _
                                  ByVal last As String, _
                                  ByVal phone As String, _
                                  ByVal status As String, _
                                  ByVal bill_to_site As String, _
                                  ByVal ship_to_site As String, _
                                  ByVal the_curr As String, _
                                  ByVal price_prog As String, _
                                  ByVal queue As String, _
                                  ByVal admin_user As String, _
                                  ByVal create_date As String, _
                                  ByVal user_name As String, _
                                  ByVal quote_len As Integer, _
                                  ByVal gen_time_bombs As Boolean, _
                                  Optional fld_list As Variant, _
                                  Optional type_list As Variant, _
                                  Optional val_list As Variant) As Integer

Description

These APIs are used to create quotes. They require that a valid title be supplied. Most of the other data (including account, site, contact) is optional. These APIs require that a valid opportunity also exist (you can create it in the GUI, or use the FCS API). This differs a little from the Clarify GUI, which creates the opportunity as part of the create quote. You can still do that with the APIs, but there is extra flexibility provided.

You may also specify a queue to dispatch the quote to. If you do, the quote will be created, and then dispatched. If not, the quote will be created, and left in the user's default WIPBIN. The APIs allow for extra fields to be set on the contract table, and you have the option of creating time bombs (for business rules), or not.

As part of creating the contract record for the quote, these APIs also create the default contract schedule and relates the schedule to the contract.

You may set additional fields on either the contract or contr_schedule table. To set a field on table_contract, just use the field name. To set a field on the contr_schedule table, place "sched:" before the name of the field. For example, to set the "x_foo" field on the contr_schedule table, you would use a field name of "sched:x_foo".

The ID of the newly-created quote will be returned in fcsfa.ret_id_num. The objid of the quote will be returned in fcsfa.ret_objid. The objid of the newly-created contr_schedule will be returned in fcsfa.ret_objid2.

Parameters

Parameter Name | Required? | Description |  |
quote_title | Yes | The title of the quote |  |
account_id | No | ID of the related account for "sell-to" |  |
site_id | No | ID number of the related site |  |
opp_id | No | ID of the related opportunity first,last, phone | No | First name, last name and phone of the related contact. If you are specifying a contact, all are required
status | No | Status for the Quote (from SFA Quote condition). If no status is supplied, the default status is used |  |
bill_to_site | No | Bill-to site for the default schedule |  |
ship_to_site | No | Ship-to site for the default schedule |  |
the_curr | No | Currency to use for quote. If blank, the system default currency is used |  |
price_prog | No | Price program for the quote. If blank, use "US Std Price List" program |  |
queue | No | Queue to dispatch the quote to. If blank, no dispatch takes place |  |
admin_user | No | Login name of the administrator. If blank, current user is used |  |
create_date | No | When was the quote created? If blank, current date/time is used |  |
user_name | No | Creator of the quote. If blank, the current user is used |  |
quote_len | Yes | How long is quote good for (in days). If set to 0, the default (30) is used |  |
gen_time_bombs | Yes | Should time_bombs be built for business rule evaluation |  |
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write |  |
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name |  |
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list |  |
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list |  |
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list |  |

Returns

Value | Meaning
0 | No errors
-1 | No title was supplied
-2 | Could not locate the supplied account
-3 | The specified site could not be found
-4 | The specified contact could not be found
-5 | The bill-to site could not be found
-6 | The ship-to site could not be found
-7 | The currency specified is not valid
-8 | The specified queue could not be located
-9 | The queue specified does not allow quotes to be dispatched to it
-10 | Cannot find the specified administrator
-11 | Cannot find the specified user
-12 | The status provided is not valid for the Quote's condition
-13 | The specified opportunity was not found
-14 | The default price program (US Standard Prices) could not be found
-15 | Cannot find the Create ClearContracts Quote Activity string
-16 | Cannot find the Create SFA Quote Activity string
-17 | Cannot find the Dispatch Activity string

Examples

Create a new quote good for 60 days. Relate it to account "AN_CUST1", site "1", and opportunity "4". Relate it to a contact, and set the status to "Need Approval". Relate the bill-to and ship-to sites to "4" and "6". Use the default currency and do not dispatch to a queue. Set the administrator to "Fred", and the user to "Marty". Set an extra string field on the contract, and one on the contr_schedule.

Field version:

JavaScript:

var ret_int = fcsfa.create_quote("Title", "AN_CUST1", "1", "4",
                     "Test", "Customer", "222-2222", "Need Approval", "4",
                     "6", "", "", "fred", "", "marty", 60, true,
                     "", 0, "", 0, "x_fld", "The value", "sched:x_sched_field",
                     "Field on contract schedule", "", "");

Visual Basic:

Dim ret_int As Integer

ret_int = fcsfa.create_quote("Title", "AN_CUST1", "1", "4", _
                   "Test", "Customer", "222-2222", "Need Approval", "4", _
                   "6", "", "", "fred", "", "marty", 60, True, _
                   "", 0, "", 0, "x_fld", "The value", "sched:x_sched_field",
                   "Field on contract schedule", "", "")

List version:

JavaScript:

var fld_list  = Server.CreateObject("FCFLCOMPAT.FCLIST");
var type_list = Server.CreateObject("FCFLCOMPAT.FCLIST");
var val_list  = Server.CreateObject("FCFLCOMPAT.FCLIST");

fld_list.AppendItem("x_fld");
type_list.AppendItem("String");
val_list.AppendItem("The value");

fld_list.AppendItem("sched:x_sched_field");
type_list.AppendItem("String");
val_list.AppendItem("Field on contract schedule");

var ret_int = fcsfa.create_quote("Title", "AN_CUST1", "1", "4",
                       "Test", "Customer", "222-2222", "Need Approval", "4",
                       "6", "", "", "fred", "", "marty", 60, true,
                        type_list, val_list);

Visual Basic:

Dim ret_int As Integer
Dim fld_list   As New FCList
Dim type_list  As New FCList
Dim val_list   As New FCList

fld_list.AppendItem("x_objective")
type_list.AppendItem("String")
val_list.AppendItem("foobar")

fld_list.AppendItem("sched:x_sched_field")
type_list.AppendItem("String")
val_list.AppendItem("Field on contract schedule")

ret_int = fcsfa.create_quote("Title", "AN_CUST1", "1", "4", _
                   "Test", "Customer", "222-2222", "Need Approval", "4", _
                   "6", "", "", "fred", "", "marty", 60, True, _
                   type_list, val_list)


create_update_lead | fcSDK Documentation

create_update_lead

create_update_lead_list

Public Function create_update_lead(ByVal lead_objid As Long, _
                                   ByVal first_name As String, _
                                   ByVal last_name As String, _
                                   ByVal phone As String, _
                                   ByVal fax As String, _
                                   ByVal address As String, _
                                   ByVal address_2 As String, _
                                   ByVal city As String, _
                                   ByVal state As String, _
                                   ByVal postal_code As String, _
                                   ByVal country As String, _
                                   ByVal time_zone As String, _
                                   ByVal e_mail As String, _
                                   ByVal the_title As String, _
                                   ByVal company_name As String, _
                                   ByVal site_name As String, _
                                   ByVal site_type As String, _
                                   ByVal rating As String, _
                                   ByVal contact_role As String, _
                                   ByVal lead_source As String, _
                                   ByVal user_name As String, _
                                   ByVal create_date As String, _
                                   ByVal gen_time_bombs As Boolean, _
                                   ByVal int_fld1 As String, _
                                   ByVal int_val1 As Long, _
                                   ByVal int_fld2 As String, _
                                   ByVal int_val2 As Long, _
                                   ByVal str_fld1 As String, _
                                   ByVal str_val1 As String, _
                                   ByVal str_fld2 As String, _
                                   ByVal str_val2 As String, _
                                   ByVal date_fld1 As String, _
                                   ByVal date_val1 As String) As Integer

Public Function create_update_lead_list(ByVal lead_objid As Long, _
                       ByVal first_name As String, _
                       ByVal last_name As String, _
                       ByVal phone As String, _
                       ByVal fax As String, _
                       ByVal address As String, _
                       ByVal address_2 As String, _
                       ByVal city As String, _
                       ByVal state As String, _
                       ByVal postal_code As String, _
                       ByVal country As String, _
                       ByVal time_zone As String, _
                       ByVal e_mail As String, _
                       ByVal the_title As String, _
                       ByVal company_name As String, _
                       ByVal site_name As String, _
                       ByVal site_type As String, _
                       ByVal rating As String, _
                       ByVal contact_role As String, _
                       ByVal lead_source As String, _
                       ByVal user_name As String, _
                       ByVal create_date As String, _
                       ByVal gen_time_bombs As Boolean, _
                       Optional fld_list As Variant, _
                       Optional type_list As Variant, _
                       Optional val_list As Variant) As Integer

Description

These APIs are used to create or update leads in Clarify. You specify if it is a create or update with the objid of the lead. If it is = -1, it's a create. Otherwise it's an update. The objid of the lead (for creates) is returned in that same argument.

For almost all of the data, you can specify it, or not (for creates). For updates, if you specify it it will be set. If you leave it blank (""), the current value is retained. If you use the string "CLEAR", the value is cleared. A few items (such as lead source and contact role) cannot be cleared.

You may specify the user who created/updated the lead, and the date/time of the create/update). You can also specify if time bombs (for business rules) will be generated, or not. Finally, you may set extra fields.

The objid of the newly-created lead will be returned in fcsfa.ret_objid.

Parameters

Parameter Name | Required? | Description
lead_objid | Yes | A variable set to -1 for creates, and to the objid of the lead to update for updates
first_name | No | First name of the lead
last_name | No | Last name of the lead
phone | No | Phone of the lead
fax | No | Fax number of the lead
address | No | Address line 1 of the lead
address_2 | No | Address line 2 of the lead
city | No | City of the lead's address
state | No | State of the lead's address
postal_code | No | The postal/zip code for the address
country | No | Country of the lead's address
time_zone | No | Time zone of the lead's address
e_mail | No | Email address of the lead
the_title | No | Title of the lead
company_name | No | Company name/account for lead
site_name | No | Name of the site for the lead
site_type | No | Type of the site. Must be "Business" or "Individual". If an update, it can be set to "" (do not update)
rating | No | Rating of the lead. Must be a value from the code list. If blank (creates), the default code list value is used
contact_role | No | Contact role for the lead. Must be a value from the code list. If blank (creates), the default contact role is used
lead_source | No | Lead source for the contact role. If blank (creates), the default lead source is used
user_name | No | Who created/updated the lead? If empty, current user is used
create_date | No | When was the lead created/updated? If empty, current date/time is used
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules).
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | The specified user could not be found
-2 | Cannot find the specified country
-3 | Cannot find the specified state for the country
-4 | Cannot find the specified time_zone for the country
-5 | Site type is not Business or Individual
-6 | The specified contact_role is not found
-7 | The rating specified is not found in the list
-8 | The specified lead source is not found
-9 | The activity code string could not be found
-10 | The specified lead could not be found to update

Examples

Create a new lead. Set most of the fields. Joe created it on January 1, 1999. Generate time bombs, and set a user-defined field.

Field version:

JavaScript:

var ret_int = fcsfa.create_update_lead(lead_objid, "First", "Last", "Phone",
          "Fax", "110 Main St", "Suite 701", "Sharon",
          "MA", "02067", "USA", "EST", "email", "Title",
          "Company", "Sitename", "Business", "Warm", "Default",
          "Default Lead Source", "joe", "1/1/99", true,
          "x_col_val", 44, "", 0, "", "", "", "", "", "");

Visual Basic:

Dim ret_int As Integer
Dim lead_objid As Long

lead_objid = -1

ret_int = fcsfa.create_update_lead(lead_objid, "First", "Last", "Phone", _
          "Fax", "110 Main St", "Suite 701", "Sharon", _
          "MA", "02067", "USA", "EST", "email", "Title", _
          "Company", "Sitename", "Business", "Warm", "Default", _
          "Default Lead Source", "joe", "1/1/99", True, _
          "x_col_val", 44, "", 0, "", "", "", "", "", "")

List version:

JavaScript:

var fld_list  = Server.CreateObject("FCFLCOMPAT.FCLIST");

var type_list = Server.CreateObject("FCFLCOMPAT.FCLIST");

var val_list  = Server.CreateObject("FCFLCOMPAT.FCLIST");

fld_list.AppendItem("x_col_val");

type_list.AppendItem("Long");

val_list.AppendItem("44");

var ret_int = fcsfa.create_quote("Title", "AN_CUST1", "1", "4",
                       "Test", "Customer", "222-2222", "Need Approval", "4",
                       "6", "", "", "fred", "", "marty", 60, true,
                        type_list, val_list);

Visual Basic:

Dim ret_int As Integer
Dim lead_objid As Long
Dim fld_list   As New FCList
Dim type_list  As New FCList
Dim val_list   As New FCList |

fld_list.AppendItem("x_col_val")
type_list.AppendItem("Long")
val_list.AppendItem("44")

lead_objid = -1

ret_int = fcsfa.create_update_lead(lead_objid, "First", "Last", "Phone", _
          "Fax", "110 Main St", "Suite 701", "Sharon", _
          "MA", "02067", "USA", "EST", "email", "Title", _
          "Company", "Sitename", "Business", "Warm", "Default", _
          "Default Lead Source", "joe", "1/1/99", True, _
          fld_list, type_list, val_list)


dispatch_action_item | fcSDK Documentation

dispatch_action_item

dispatch_opportunity

dispatch_quote

Public Function dispatch_action_item(ByVal the_id As String, _
                                  ByVal queue_name As String, _
                                  ByVal disp_date As String, _
                                  ByVal user_name As String, _
                                  ByVal gen_time_bombs As Boolean) As Integer

Public Function dispatch_opportunity(ByVal the_id As String, _
                                  ByVal queue_name As String, _
                                  ByVal disp_date As String, _
                                  ByVal user_name As String, _
                                  ByVal gen_time_bombs As Boolean) As Integer

Public Function dispatch_quote(ByVal the_id As String, _
                               ByVal queue_name As String, _
                               ByVal disp_date As String, _
                               ByVal user_name As String, _
                               ByVal gen_time_bombs As Boolean) As Integer

Description

These APIs cause the specified object (action_item, opportunity, quote) to be dispatched to the specified queue. The object must be in open condition, and not currently dispatched to a queue. The API allows for the setting of the dispatch date, and the user who dispatched the object. The API can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
the_id | Yes | The object (action_item, opportunity, quote) to dispatch
queue_name | Yes | The queue to dispatch to
disp_date | No | When was the object dispatched. If this parameter is left blank, the case is dispatched at the current time
user_name | No | The user who dispatched the object. If left blank, the current user performs the dispatch.
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified object
-2 | The object is already dispatched
-3 | The object is closed and may not be dispatched
-4 | The specified user cannot be found
-5 | The specified new queue name cannot be found
-6 | The DISPATCH activity string is not found
-7 | The specified queue does not allow dispatches of this specific object type
-8 | Cannot find the employee record for the designated user

Examples

Dispatch action item number '154' to queue 'Hardware'. The dispatch is performed by the current user and is dispatched at the current time. Generate a time bomb.

JavaScript:

var ret_int = fcsfa.dispatch_action_item("154", "Hardware", "", "", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fcsfa.dispatch_action_item("154", "Hardware", "", "", True)

Dispatch quote number '2' at 10PM on November 23rd of 1997 to 'Software'. Dispatch should be logged as performed by dave. Don't generate a time bomb.

JavaScript:

var ret_int = fcsfa.dispatch_quote("2", "Software",
                                   "11/23/97 22:00:00", "dave", false);

Visual Basic:

Dim ret_int As Integer

ret_int = fcsfa.dispatch_quote("2", "Software", "11/23/97 22:00:00", _
                               "dave", False)


forward_action_item | fcSDK Documentation

forward_action_item

forward_opportunity

forward_quote

Public Function forward_action_item(ByVal the_id As String, _
                                    ByVal new_queue As String, _
                                    ByVal forward_date As String, _
                                    ByVal notes As String, _
                                    ByVal user_name As String, _
                                    ByVal gen_time_bombs As Boolean) As Integer

Public Function forward_opportunity(ByVal the_id As String, _
                                    ByVal new_queue As String, _
                                    ByVal forward_date As String, _
                                    ByVal notes As String, _
                                    ByVal user_name As String, _
                                    ByVal gen_time_bombs As Boolean) As Integer

Public Function forward_quote(ByVal the_id As String, _
                              ByVal new_queue As String, _
                              ByVal forward_date As String, _
                              ByVal notes As String, _
                              ByVal user_name As String, _
                              ByVal gen_time_bombs As Boolean) As Integer

Description

These APIs cause the specified action item, opportunity, or quote to be reject-forwarded from one queue to another. The object must be in open condition, and currently dispatched to a queue. The API allows for the setting of the forward date, some notes about the forward, and the user who forwarded the object. The APIs can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
The_id | Yes | The object to reject-forward
new_queue | Yes | The queue to forward to
forward_date | No | When was the object forwarded. If this parameter is left blank, the object is forwarded at the current time
notes | No | Optional notes about the reject-forward
user_name | No | The user who forwarded the object. If left blank, the current user performs the forward. For business rules, it defaults to the user_name who is executing the cbbatch
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified object
-2 | Object is not currently dispatched
-3 | The new queue name specified is not found
-4 | Reject-forward attempted to same queue as currently dispatched to
-5 | The specified user is not found
-6 | The FORWARD activity string is not found

Examples

Reject-forward action item number '154' to queue 'Hardware'. The reject-forward has no notes, is performed by the current user and is forwarded at the current time. Generate a time bomb.

JavaScript:

var ret_int = fcsfa.forward_action_item("154", "Hardware", "", "", "", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fcsfa.forward_action_item("154", "Hardware", "", "", "", True)

Reject-forward quote number 'Q2' at 10PM on November 23rd of 1997 to 'Software'. Forward should be logged as performed by dave, with notes of 'Some notes'. Don't generate a time bomb.

JavaScript:

var ret_int = fcsfa.forward_quote("Q2", "Software", "11/23/97 22:00:00",
                              "Some notes", "dave", false);

Visual Basic:

Dim ret_int As Integer

ret_int = fcsfa.forward_quote("Q2", "Software", "11/23/97 22:00:00", _
                              "Some notes", "dave", False)


lead_opp | fcSDK Documentation

lead_opp

Public Function lead_opp(opp_id As String, _
                         new_status As String, _
                         the_note As String, _
                         user_name As String, _
                         change_date As String, _
                         gen_time_bombs As Boolean) As Integer

Description

This API allows you to mark an opportunity as a "Lead." It changes both the cycle stage and the opportunity. It also allows you to specify an optional note about the change, who performed the change, as well as when they performed the change. All of these can be left blank - see below for more details.

There are three significant differences between this API, and the base Clarify function.

This API allows you to specify a new status for the opportunity. In base Clarify, you must always use the default status for the opportunity. If you leave the string blank for these APIs, the default will be used.

Since the API allows for the changing of status, the activity log entries now reflect the new status as well as the cycle change/condition change.

The activity logs for the base function contain the date of the action in the additional information. Since that is also shown in the date/time field, it is pointless, and was removed. Also, Clarify places return characters in the additional information field. This makes it impossible to read from the activity log form. Those have been removed for the API.

The API can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
opp_id | Yes | The opportunity to mark as a lead
new_status | No | New status of the opportunity. If blank, default status is used.
the_note | No | Optional note about the change
user_name | No | The user who performed the change. If left blank, the current user performs the change. For business rules, it defaults to the user_name who is executing the cbbatch
change_date | No | When was the opportunity changed. If this parameter is left blank, the object is changed at the current date/time
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | An invalid condition was supplied (internal error - should not ever occur)
-2 | The opportunity specified cannot be found
-3 | The opportunity is already closed
-4 | The opportunity is currently dispatched
-5 | Cannot find the specified user
-6 | The specified status cannot be found for the new condition
-7 | Cannot find the cycle stage for this condition
-8 | Cannot find the activity code for the status change event

Examples

Mark opportunity '44' as a lead. Add some notes, and the change occurs now and is performed by the current user. Assume that we'll use the default status. Generate a time bomb.

JavaScript:

var ret_int = fcsfa.lead_opp("44", "", "Some notes!!", "", "", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fcsfa.lead_opp("44", "", "Some notes!!", "", "", True)

Opportunity '42' is changed to a lead at 10PM on November 23rd of 1997. Change should be logged as performed by dave, with notes of 'Some notes'. Set the status to "Another status." Don't generate a time bomb.

JavaScript:

var ret_int = fcsfa.lead_opp("42", "Another status", "Some notes!!",
                             "dave", "11/23/97 22:00:00", false);

Visual Basic:

Dim ret_int As Integer

ret_int = fcsfa.lead_opp("42", "Another status", "Some notes!!", _
                         "dave", "11/23/97 22:00:00", False)


log_lead_note | fcSDK Documentation

log_lead_note

Public Function log_lead_note(ByVal lead_objid As Long, _
                              ByVal the_text As String, _
                              ByVal iuo As String, _
                              ByVal log_date As String, _
                              ByVal user_name As String, _
                              ByVal gen_time_bombs As Boolean) As Integer

Description

This API allows you to log a note for a lead. You must specify the objid of the lead (since no other information on the lead is unique), and the description (note text). You may also specify the internal use only text field. You may specify who logged the note, and when

The APIs can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
lead_objid | Yes | The unique object ID of the lead
the_text | No | Note text
iuo | No | Internal use only text for the note
log_date | No | When was the note logged? If blank, current date/time used
user_name | No | Who logged the note? If blank, current user is used
gen_time_bombs | Yes | Should a time bomb be created? Values are "True" or "False".

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified lead
-2 | The specified user is not found
-3 | The NOTES activity string is not found

Examples

Sam logged a note on December 12, 2000 (at 11AM) for a lead. The text is "Hello there", with some internal use only text as well. Generate time bombs.

JavaScript:

var ret_int = fcsfa.log_lead_note(268435458, "Hello there",
                    "This customer is a pain", "12/12/2000 11:00:00",
                    "sam", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fcsfa.log_lead_note(268435458, "Hello there", _
                    "This customer is a pain", "12/12/2000 11:00:00", _
                    "sam", True)

Log notes for the same lead. Only log text, and do it now for the current user. Don't generate a time bomb.

JavaScript:

var ret_int = fcsfa.log_lead_note(268435458, "More text", "", "", "", false);

Visual Basic:

Dim ret_int As Integer

ret_int = fcsfa.log_lead_note(268435458, "More text", "", "", "", False)


log_lead_phone | fcSDK Documentation

log_lead_phone

Public Function log_lead_phone(ByVal lead_objid As Long, _
                               ByVal the_text As String, _
                               ByVal iuo As String, _
                               ByVal first As String, _
                               ByVal last As String, _
                               ByVal phone As String, _
                               ByVal action As String, _
                               ByVal log_date As String, _
                               ByVal duration As Long, _
                               ByVal user_name As String, _
                               ByVal gen_time_bombs As Boolean) As Integer

Description

This API allows you to log a phone for a lead. You must specify the objid of the lead (since no other information on the lead is unique), and the description (phone text). You must also specify a contact for the log. If you want to use the lead as the contact (and not a real contact), then leave the first, last, and phone fields blank, and this will use the lead. You must specify the length of the phone call (in seconds).

There are a variety of optional items that you may set, including the action type of the call, when the call started, and who logged the call.

The API can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
lead_objid | Yes | The unique object ID of the lead
the_text | No | Note text
iuo | No | Internal Use Only optional text for the phone log
first | Yes | First name of the related contact. If you wish to use the lead as the contact, leave this field blank
last | Yes | Last name of the related contact. If you wish to use the lead as the contact, leave this field blank
phone | Yes | Phone number of the related contact. If you wish to use the lead as the contact, leave this field blank
action | No | Phone Log Action Type. If blank, the default value of the code list is used
log_date | No | When was the call logged? If blank, current date/time used
duration | Yes | How long did the call last, in seconds
user_name | No | Who logged the note? If blank, current user is used
gen_time_bombs | Yes | Should a time bomb be created? Values are "True" or "False".

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified lead
-2 | The specified user is not found
-3 | The PHONE LOG activity string is not found
-4 | Cannot find the specified contact
-5 | Cannot locate the specified phone log action type
-6 | The duration is < 0

Examples

Sam logged a call on December 12, 2000 (at 11AM) for a lead. The text is "Hello there", and the call lasted 3 minutes and 15 seconds. Do not specify an action type. Use the lead as the contact. Generate time bombs.

JavaScript:

var ret_int = fcsfa.log_lead_phone(268435458, "Hello there", "", "", "", "",
                                   "", "12/12/2000 11:00:00",
                                   195, "sam", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fcsfa.log_lead_phone(268435458, "Hello there", "", "", "", "", _
                               "", "12/12/2000 11:00:00", 195, "sam", True)

Log another call for the same lead. Specify a contact and an action type, and log it at the current time and from the current user. The call lasted 30 seconds, and don't generate a time bomb.

JavaScript:

var ret_int = fcsfa.log_lead_phone(268435458, "More notes", "", "Jane", "Doe",
                             "555-1212", "Outgoing call", "", 30, "", false);

Visual Basic:

Dim ret_int As Integer

ret_int = fcsfa.log_lead_phone(268435458, "More notes", "", "Jane", "Doe", _
                               "555-1212", "Outgoing call", _
                               "", 30, "", False)


lose_opp | fcSDK Documentation

lose_opp

Public Function lose_opp(opp_id As String, _
                         new_status As String, _
                         the_note As String, _
                         user_name As String, _
                         change_date As String, _
                         gen_time_bombs As Boolean) As Integer

Description

This API allows you to mark an opportunity as "Lost." It changes both the cycle stage and the opportunity. It also allows you to specify an optional note about the change, who performed the change, as well as when they performed the change. All of these can be left blank - see below for more details.

There are three significant differences between this API, and the base Clarify function.

This API allows you to specify a new status for the opportunity. In base Clarify, you must always use the default status for the opportunity. If you leave the string blank for these APIs, the default will be used.

Since the API allows for the changing of status, the activity log entries now reflect the new status as well as the cycle change/condition change.

The activity logs for the base function contain the date of the action in the additional information. Since that is also shown in the date/time field, it is pointless, and was removed. Also, Clarify places return characters in the additional information field. This makes it impossible to read from the activity log form. Those have been removed for the API.

The API can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
opp_id | Yes | The opportunity to mark as a loss
new_status | No | New status of the opportunity. If blank, default status is used.
the_note | No | Optional note about the change
user_name | No | The user who performed the change. If left blank, the current user performs the change. For business rules, it defaults to the user_name who is executing the cbbatch
change_date | No | When was the opportunity changed. If this parameter is left blank, the object is changed at the current date/time
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | An invalid condition was supplied (internal error - should not ever occur)
-2 | The opportunity specified cannot be found
-3 | The opportunity is already closed
-4 | The opportunity is currently dispatched
-5 | Cannot find the specified user
-6 | The specified status cannot be found for the new condition
-7 | Cannot find the cycle stage for this condition
-8 | Cannot find the activity code for the status change event

Examples

Mark opportunity '44' as lost. Add some notes, and the change occurs now and is performed by the current user. Assume that we'll use the default status. Generate a time bomb.

JavaScript:

var ret_int = fcsfa.lose_opp("44", "", "Some notes!!", "", "", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fcsfa.lose_opp("44", "", "Some notes!!", "", "", True)

Opportunity '42' is changed to a loss at 10PM on November 23rd of 1997. Change should be logged as performed by dave, with notes of 'Some notes'. Set the status to "Another status." Don't generate a time bomb.

JavaScript:

var ret_int = fcsfa.lose_opp("42", "Another status", "Some notes!!",
                             "dave", "11/23/97 22:00:00", false);

Visual Basic:

Dim ret_int As Integer

ret_int = fcsfa.lose_opp("42", "Another status", "Some notes!!", _
                         "dave", "11/23/97 22:00:00", False)


modify_opp | fcSDK Documentation

modify_opp

modify_opp_list

Public Function modify_opp(ByVal opp_id As String, _
                           ByVal opp_name As String, _
                           ByVal acct_id As String, _
                           ByVal con_first As String, _
                           ByVal con_last As String, _
                           ByVal con_phone As String, _
                           ByVal terr_name As String, _
                           ByVal amt As Currency, _
                           ByVal close_date As String, _
                           ByVal lead_source As String, _
                           ByVal the_currency As String, _
                           ByVal prob As String, _
                           ByVal process As String, _
                           ByVal mod_date As String, _
                           ByVal user_name As String, _
                           ByVal gen_time_bombs As Boolean, _
                           ByVal int_fld1 As String, _
                           ByVal int_val1 As Long, _
                           ByVal int_fld2 As String, _
                           ByVal int_val2 As Long, _
                           ByVal str_fld1 As String, _
                           ByVal str_val1 As String, _
                           ByVal str_fld2 As String, _
                           ByVal str_val2 As String, _
                           ByVal date_fld1 As String, _
                           ByVal date_val1 As String) As Integer

Public Function modify_opp_list( ByVal opp_id As String, _
                           ByVal opp_name As String, _
                           ByVal acct_id As String, _
                           ByVal con_first As String, _
                           ByVal con_last As String, _
                           ByVal con_phone As String, _
                           ByVal terr_name As String, _
                           ByVal amt As Currency, _
                           ByVal close_date As String, _
                           ByVal lead_source As String, _
                           ByVal the_currency As String, _
                           ByVal prob As String, _
                           ByVal process As String, _
                           ByVal mod_date As String, _
                           ByVal user_name As String, _
                           ByVal gen_time_bombs As Boolean, _
                           Optional fld_list As Variant, _
                           Optional type_list As Variant, _
                           Optional val_list As Variant) As Integer

Description

These APIs are used to modify opportunities. The opportunity ID must be specified. All other data is optional. The opportunity name, account, contact, territory, stage, source, currency, and process may be specified. You may generate time bombs for business rules, or not. Also, an amount and a probability may be specified.

Most of the data items can be left with their current values. To not change an item, simply leave the data blank (for strings), or less than 0 (for numerics). If you wish to clear out the value in an option item, use the keyword "CLEAR".

Parameters

Parameter Name | Required? | Description
opp_id | Yes | The ID of the opportunity to modify
opp_name | No | Name of the opportunity. If blank, no change is made
acct_id | No | ID of the related account. If blank, no change is made. To clear the account, use "CLEAR"
con_first, con_last, con_phone | No | Name and phone number of related contact. If a contact is to be specified, all three must be given. If all three are blank, no change is made. To clear out the specified contact, put "CLEAR" in con_first, and leave the other two blank
terr_name | No | Name of the territory. If blank, no change is made
amt | No | Amount of the opportunity. Must be numeric. If < 0, no change is made
close_date | No | Close date of the opportunity. If blank, no change is made
lead_source | No | Lead source for the opportunity. If blank, no change is made
the_currency | No | Currency for the opportunity. If blank, no change is made
prob | No | Probability of opportunity close. Must be numeric, and between 0 and 1. If blank, (""), no change is made
process | No | Process for the opportunity. If blank, no change is made
user_name | No | Owner of the opportunity. If blank, the current owner is not changed
mod_date | No | When was the opportunity modified? If blank, current date/time is used
gen_time_bombs | Yes | Should time_bombs be built for business rule evaluation
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | The specified opportunity was not found
-2 | The supplied account ID could not be found
-3 | The specified contact could not be found
-4 | The specified territory could not be found
-5 | The specified lead source could not be found
-6 | The currency specified is not valid
-7 | The specified process/life cycle could not be located
-8 | The specified user cannot be found
-9 | The supplied close date is not a valid date
-10 | The probability supplied is not numeric or is not between 0 and 1
-11 | Cannot find the Modify Opp activity string

Examples

Modify opportunity 33. Specify an account, clear the contact, and leave all other data alone. Generate time bombs. Also, specify a new string field.

Field version:

**JavaScript:**

ret_int = fcsfa_obj.modify_opp("33", "", "AN_CUST2", "CLEAR", "", "", "",

-1, "", "", "", "", "", "", "", true, "", 0, "", 0,

"x_str_fld", "Data value", "", "", "", "");

**Visual Basic:**

Dim ret_int As Integer

Dim opp_id As String

ret_int = fcsfa_obj.modify_opp("33", "", "AN_CUST2", "CLEAR", "", "", "", _ -1, "", "", "", "", "", "", "", True, "", 0, "", 0, _ "x_str_fld", "Data value", "", "", "", "")

List version:

JavaScript:

var fld_list  = Server.CreateObject("FCFLCOMPAT.FCLIST");

var type_list = Server.CreateObject("FCFLCOMPAT.FCLIST");

var val_list  = Server.CreateObject("FCFLCOMPAT.FCLIST");

fld_list.AppendItem("x_str_fld");

type_list.AppendItem("String");

val_list.AppendItem("Data value");

   ret_int = fcsfa_obj.modify_opp("33", "", "AN_CUST2", "CLEAR", "", "", "",

              -1, "", "", "", "", "", "", "", true, fld_list,

              type_list, val_list);

Visual Basic:

   Dim ret_int As Integer

Dim fld_list   As New FCList

Dim type_list  As New FCList

Dim val_list   As New FCList

fld_list.AppendItem("x_str_fld")

type_list.AppendItem("String")

val_list.AppendItem("Data value")

   ret_int = fcsfa_obj.modify_opp("33", "", "AN_CUST2", "CLEAR", "", "", "", _
              -1, "", "", "", "", "", "", "", True, fld_list, _
              type_list, val_list)

move_action_item
------------------

move_opportunity
----------------

move_quote
----------

Public Function move_action_item(ByVal the_id As String, _ ByVal new_wipbin As String) As Integer

Public Function move_opportunity(ByVal the_id As String, _ ByVal new_wipbin As String) As Integer

Public Function move_quote(ByVal the_id As String, _ ByVal new_wipbin As String) As Integer

#### Description

These APIs cause the specified action item, opportunity, or quote to be moved from one WIPBin to another WIPBin. The new WIPBin must belong to the same user as the first WIPBin. The move operation does not change the ownership of the object, nor is an activity log or time bomb generated for the action.

**Note:** These APIs allow you to move a queueable object from one WIPBin to another, even if the object is currently dispatched. Since WIPBins are internal to a user, there really is no reason that you shouldn't be able to move the interal (to a user) location of the object. This is an enhancement to base Clarify function, which requires that the object not be dispatched to be moved.

#### Parameters

| Parameter Name | Required? | Description |
|:--- |:--- |:--- |
| the_id | Yes | The object to move |
| new_wipbin | Yes | The WIPBin to move the object to. If left blank, the object is moved to the |

#### Returns

| Value | Meaning |
|:--- |:--- |
| 0 | No errors |
| -1 | Cannot find the specified object |
| -2 | Object is already closed |
| -3 | New WIPBIN doesn't exist, or isn't for the owner |
| -4 | New WIPBIN is same as old - no move needed |

#### Examples

Move action item number '154' to the default WIPBin for the current owner.

**JavaScript:**

var ret_int = fcsfa.move_action_item("154", "");

**Visual Basic:**

Dim ret_int As Integer

ret_int = fcsfa.move_action_item("154", "")

Move quote number 'Q2' to WIPBin 'Urgent'.

**JavaScript:**

var ret_int = ret_int = fcsfa.move_quote("Q2", "Urgent");

**Visual Basic:**

Dim ret_int As Integer

ret_int = fcsfa.move_quote("Q2", "Urgent")


opp_opp | fcSDK Documentation

opp_opp

Public Function opp_opp(opp_id As String, _
                        new_status As String, _
                        the_note As String, _
                        user_name As String, _
                        change_date As String, _
                        gen_time_bombs As Boolean) As Integer

Description

This API allows you to mark an opportunity as an "Opportunity." It changes both the cycle stage and the opportunity. It also allows you to specify an optional note about the change, who performed the change, as well as when they performed the change. All of these can be left blank - see below for more details.

There are three significant differences between this API, and the base Clarify function.

This API allows you to specify a new status for the opportunity. In base Clarify, you must always use the default status for the opportunity. If you leave the string blank for these APIs, the default will be used.

Since the API allows for the changing of status, the activity log entries now reflect the new status as well as the cycle change/condition change.

The activity logs for the base function contain the date of the action in the additional information. Since that is also shown in the date/time field, it is pointless, and was removed. Also, Clarify places return characters in the additional information field. This makes it impossible to read from the activity log form. Those have been removed for the API.

The API can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
opp_id | Yes | The opportunity to mark as an opportunity
new_status | No | New status of the opportunity. If blank, default status is used.
the_note | No | Optional note about the change
user_name | No | The user who performed the change. If left blank, the current user performs the change. For business rules, it defaults to the user_name who is executing the cbbatch
change_date | No | When was the opportunity changed. If this parameter is left blank, the object is changed at the current date/time
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | An invalid condition was supplied (internal error - should not ever occur)
-2 | The opportunity specified cannot be found
-3 | The opportunity is already closed
-4 | The opportunity is currently dispatched
-5 | Cannot find the specified user
-6 | The specified status cannot be found for the new condition
-7 | Cannot find the cycle stage for this condition
-8 | Cannot find the activity code for the status change event

Examples

Mark opportunity '44' as an opportunity. Add some notes, and the change occurs now and is performed by the current user. Assume that we'll use the default status. Generate a time bomb.

JavaScript:

var ret_int = fcsfa.opp_opp("44", "", "Some notes!!", "", "", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fcsfa.opp_opp("44", "", "Some notes!!", "", "", True)

Opportunity '42' is changed to an opportunity at 10PM on November 23rd of 1997. Change should be logged as performed by dave, with notes of 'Some notes'. Set the status to "Another status." Don't generate a time bomb.

JavaScript:

var ret_int = fcsfa.opp_opp("42", "Another status", "Some notes!!",
                             "dave", "11/23/97 22:00:00", false);

Visual Basic:

Dim ret_int As Integer

ret_int = fcsfa.opp_opp("42", "Another status", "Some notes!!", _
                         "dave", "11/23/97 22:00:00", False)


reject_action_item | fcSDK Documentation

reject_action_item

reject_opportunity

reject_quote

Public Function reject_action_item(ByVal the_id As String, _
                                   ByVal reject_date As String, _
                                   ByVal wipbin As String, _
                                   ByVal notes As String, _
                                   ByVal user_name As String, _
                                   ByVal gen_time_bombs As Boolean) As Integer

Public Function reject_opportunity(ByVal the_id As String, _
                                   ByVal reject_date As String, _
                                   ByVal wipbin As String, _
                                   ByVal notes As String, _
                                   ByVal user_name As String, _
                                   ByVal gen_time_bombs As Boolean) As Integer

Public Function reject_quote(ByVal the_id As String, _
                             ByVal reject_date As String, _
                             ByVal wipbin As String, _
                             ByVal notes As String, _
                             ByVal user_name As String, _
                             ByVal gen_time_bombs As Boolean) As Integer

Description

These APIs cause the specified action item, opportunity, or quote to be rejected from the queue it is in, and returned back to the owner. The object must be in open condition, and currently dispatched to a queue. The API allows for the setting of the reject date, some notes about the reject, and the user who rejected the object. The APIs also allow you to set the WIPBin that the object is placed back in. This is additional functionality that base Clarify does not provide. The APIs can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
the_id | Yes | The object to reject-forward
reject_date | No | When was the object rejected. If this parameter is left blank, the object is rejected at the current time
wipbin | No | The WIPBin to place the object in. If left blank, the default WIPBin is used
notes | No | Optional notes about the reject
user_name | No | The user who rejected the object. If left blank, the current user performs the reject. For business rules, it defaults to the user_name who is executing the cbbatch
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified object
-2 | The object is not currently dispatched
-3 | Cannot find the specified user
-4 | The object is currently closed - cannot dispatch
-5 | Cannot find the new specified WIPBIN, or it is not a WIPBIN for the specified user
-6 | Cannot find REJECT activity string

Examples

Reject action item number '154' to the default WIPBin. The reject has no notes, is performed by the current user and is rejected at the current time. Generate a time bomb.

JavaScript:

var ret_int = fcsfa.reject_action_item("154", "", "", "", "", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fcsfa.reject_action_item("154", "", "", "", "", True)

Reject quote number 'Q2' at 10PM on November 23rd of 1997 to WIPBin 'East'. Reject should be logged as performed by dave, with notes of 'Some notes'. Don't generate a time bomb.

JavaScript:

var ret_int = fcsfa.reject_quote("Q2", "11/23/97 22:00:00", "East",
                                 "Some notes", "dave", false);

Visual Basic:

Dim ret_int As Integer

ret_int = fcsfa.reject_quote("Q2", "11/23/97 22:00:00", "East", _
                      "Some notes", "dave", False)


reopen_opp | fcSDK Documentation

reopen_opp

Public Function reopen_opp(ByVal opp_id As String, _
                    ByVal the_status As String, _
                    ByVal wipbin As String, _
                    ByVal reopen_date As String, _
                    ByVal user_name As String, _
                    ByVal gen_time_bombs As Boolean) As Integer

Description

This API causes the specified opportunity to be reopened. You may specify the status (in open lead condition) for the opportunity, as well as the user name of the opener, and the date/time of the reopen. You may also specify the WIPBIN to place the opportunity in. The APIs can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
opp_id | Yes | The ID of the opportunity to close
the_status | No | The new status for the opportunity. If blank, the default status for Open Lead condition is used
wipbin | No | The WIPBIN in which to place the opportunity. If blank, the default WIPBIN for the user is used
reopen_date | No | When was the opportunity reopened? If this parameter is left blank, the opportunity is reopened at the current time
user_name | No | The user who reopened the opportunity. If left blank, the current user performs the reopen
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified status for the open lead condition
-2 | Cannot find the CHANGE OPP STATUS activity string
-3 | Cannot find the specified opportunity
-4 | The opportunity is not closed
-5 | The specified user is not found
-6 | The employee for the specified user cannot be found
-7 | Cannot find the specified WIPBIN

Examples

Reopen opportunity "32" at the current time with the current user. Put in status "Active now". Put in WIPBIN "Important". Generate a time bomb.

JavaScript:

ret_int = fcsfa_obj.reopen_opp("32", "Active now", "Important", "", "", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fcsfa_obj.reopen_opp("32", "Active now", "Important", "", "", True)


update_action_item | fcSDK Documentation

update_action_item

update_action_item_list

Public Function update_action_item(ByVal task_id As String, _
                                   ByVal title As String, _
                                   ByVal notes As String, _
                                   ByVal first_name As String, _
                                   ByVal last_name As String, _
                                   ByVal phone As String, _
                                   ByVal acct_name As String, _
                                   ByVal lead_first As String, _
                                   ByVal lead_last As String, _
                                   ByVal opp_id As String, _
                                   ByVal the_type As String, _
                                   ByVal priority As String, _
                                   ByVal start_date As String, _
                                   ByVal complete_date As String, _
                                   ByVal status As String, _
                                   ByVal update_date As String, _
                                   ByVal int_fld1 As String, _
                                   ByVal int_val1 As Long, _
                                   ByVal int_fld2 As String, _
                                   ByVal int_val2 As Long, _
                                   ByVal str_fld1 As String, _
                                   ByVal str_val1 As String, _
                                   ByVal str_fld2 As String, _
                                   ByVal str_val2 As String, _
                                   ByVal date_fld1 As String, _
                                   ByVal date_val1 As String) As Integer

Public Function update_action_item_list(ByVal task_id As String, _
                                        ByVal title As String, _
                                        ByVal notes As String, _
                                        ByVal first_name As String, _
                                        ByVal last_name As String, _
                                        ByVal phone As String, _
                                        ByVal acct_name As String, _
                                        ByVal lead_first As String, _
                                        ByVal lead_last As String, _
                                        ByVal opp_id As String, _
                                        ByVal the_type As String, _
                                        ByVal priority As String, _
                                        ByVal start_date As String, _
                                        ByVal complete_date As String, _
                                        ByVal status As String, _
                                        ByVal update_date As String, _
                                        Optional fld_list As Variant, _
                                        Optional type_list As Variant, _
                                        Optional val_list As Variant) As Integer

Description

These APIs are used to update existing action items. Virtually all of the data is optional - only the action item ID is required. For most of the input fields if you leave them blank no change will be made to the existing action item. To clear a data item (for example, the contact), set the data field to "CLEAR". You may modify the the title, notes, contact, account, lead, opportunity, task type, priority, status (within the same condition), start date, and the completion date.

If you want to relate a contact to the action item you must supply all three of the contact fields. Likewise, if you wish to associate a lead to the action item you must supply both lead fields.

Parameters

Parameter Name | Required? | Description
task_id | Yes | ID number of the action item to modify
title | No | The title of the action item. If blank, no change is made. To clear, specify "CLEAR"
notes | No | Notes about the action item. If blank, no change is made. To clear, specify "CLEAR"
first_name | No | First name of the related contact If first name and last name are blank, no change is made. To clear, specify "CLEAR"
last_name | No | Last name of the related contact. If first name and last name are blank, no change is made. To clear the contact, specify "CLEAR" in the first name
phone | No | Phone number of the related contact
acct_name | No | Name of the account to relate to the action item. If blank, no change is made. To clear, specify "CLEAR"
lead_first | No | First name of the related lead. If first and last name are blank, no change is made. If set to "CLEAR", the lead is cleared out
lead_last | No | Last name of the related lead. If first and last name are blank, no change is made
opp_id | No | Opportunity related to the action item. If blank, no change is made. To clear, specify "CLEAR"
the_type | No | Type of the action item (code list value). If empty, no change is made
priority | No | Priority for the action item. If empty, no change is made
start_date | No | Start date for the action item. If empty, action item's start date is used
complete_date | No | End date for the action item. If empty, action item's due date is used
status | No | Status for the action item. If empty, no change is made
update_date | No | When was the action item modified? If empty, current date/time is used
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified action item
-2 | The supplied contact could not be found
-3 | Cannot find the specified account
-4 | Cannot find the specified lead
-5 | Cannot find the specified opportunity
-6 | The specified status cannot be found for the action item's current condition
-7 | The completion date is earlier than the start date
-8 | The supplied start date is not a valid date
-9 | The supplied completion date is not a valid date
-10 | The specified type cannot be found
-11 | The specified priority cannot be found

Examples

Update action item '9'. Specify a new title and notes. Specify a new contact and lead, but clear out the opportunity, and account. Also specify a new task type and priority. Leave the start/due times alone, but specify a new status. Set a user-defined field

Field version:

JavaScript:

var ret_int = fcsfa.update_action_item("9", "New Title", "New notes", "John",
                   "Doe", "555-1212", "CLEAR", "Lead", "Guy", "CLEAR",
                   "Fax", "Low", "", "", "NewStat", "", "x_int1", 44, "", 0,
                   "", "", "", "", "", "");

Visual Basic:

Dim ret_int As Integer

ret_int = fcsfa.update_action_item("9", "New Title", "New notes", "John",_
                   "Doe", "555-1212", "CLEAR", "Lead", "Guy", "CLEAR", _
                   "Fax", "Low", "", "", "NewStat", "", "x_int1", 44, "", 0, _
                   "", "", "", "", "", "")

List version:

JavaScript:

var fld_list  = Server.CreateObject("FCFLCOMPAT.FCLIST");
var type_list = Server.CreateObject("FCFLCOMPAT.FCLIST");
var val_list  = Server.CreateObject("FCFLCOMPAT.FCLIST");

fld_list.AppendItem("x_int1");
type_list.AppendItem("Long");
val_list.AppendItem("44");

var ret_int = fcsfa.update_action_item("9", "New Title", "New notes", "John",
       "Doe", "555-1212", "CLEAR", "Lead", "Guy", "CLEAR",
       "Fax", "Low", "", "", "NewStat", "", fld_list,
       type_list, val_list);

Visual Basic:

Dim ret_int As Integer
Dim fld_list   As New FCList
Dim type_list  As New FCList
Dim val_list   As New FCList

fld_list.AppendItem("x_int1")
type_list.AppendItem("Long")
val_list.AppendItem("44")

ret_int = fcsfa.update_action_item("9", "New Title", "New notes", "John",_
                   "Doe", "555-1212", "CLEAR", "Lead", "Guy", "CLEAR", _
                   "Fax", "Low", "", "", "NewStat", "", fld_list, _
                   type_list, val_list)


win_opp | fcSDK Documentation

win_opp

Public Function win_opp(opp_id As String, _
                        new_status As String, _
                        the_note As String, _
                        user_name As String, _
                        change_date As String, _
                        gen_time_bombs As Boolean) As Integer

Description

This API allows you to mark an opportunity as "Won." It changes both the cycle stage and the opportunity. It also allows you to specify an optional note about the change, who performed the change, as well as when they performed the change. All of these can be left blank - see below for more details.

There are three significant differences between this API, and the base Clarify function.

This API allows you to specify a new status for the opportunity. In base Clarify, you must always use the default status for the opportunity. If you leave the string blank for these APIs, the default will be used.

Since the API allows for the changing of status, the activity log entries now reflect the new status as well as the cycle change/condition change.

The activity logs for the base function contain the date of the action in the additional information. Since that is also shown in the date/time field, it is pointless, and was removed. Also, Clarify places return characters in the additional information field. This makes it impossible to read from the activity log form. Those have been removed for the API.

The API can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
opp_id | Yes | The opportunity to mark as won
new_status | No | New status of the opportunity. If blank, default status is used.
the_note | No | Optional note about the change
user_name | No | The user who performed the change. If left blank, the current user performs the change. For business rules, it defaults to the user_name who is executing the cbbatch
change_date | No | When was the opportunity changed. If this parameter is left blank, the object is changed at the current date/time
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | An invalid condition was supplied (internal error - should not ever occur)
-2 | The opportunity specified cannot be found
-3 | The opportunity is already closed
-4 | The opportunity is currently dispatched
-5 | Cannot find the specified user
-6 | The specified status cannot be found for the new condition
-7 | Cannot find the cycle stage for this condition
-8 | Cannot find the activity code for the status change event

Examples

Mark opportunity '44' as won. Add some notes, and the change occurs now and is performed by the current user. Assume that we'll use the default status. Generate a time bomb.

JavaScript:

var ret_int = fcsfa.win_opp("44", "", "Some notes!!", "", "", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fcsfa.win_opp("44", "", "Some notes!!", "", "", True)

Opportunity '42' is changed to won at 10PM on November 23rd of 1997. Change should be logged as performed by dave, with notes of 'Some notes'. Set the status to "Another status." Don't generate a time bomb.

JavaScript:

var ret_int = fcsfa.win_opp("42", "Another status", "Some notes!!",

                            "dave", "11/23/97 22:00:00", false);

Visual Basic:

Dim ret_int As Integer

ret_int = fcsfa.win_opp("42", "Another status", "Some notes!!", _
                         "dave", "11/23/97 22:00:00", False)


yank_action_item | fcSDK Documentation

yank_action_item

yank_opportunity

yank_quote

Public Function yank_action_item(ByVal the_id As String, _
                                 ByVal wipbin As String, _
                                 ByVal yank_date As String, _
                                 ByVal user_name As String, _
                                 ByVal gen_time_bombs As Boolean) As Integer

Public Function yank_opportunity(ByVal the_id As String, _
                                 ByVal wipbin As String, _
                                 ByVal yank_date As String, _
                                 ByVal user_name As String, _
                                 ByVal gen_time_bombs As Boolean) As Integer

Public Function yank_quote(ByVal the_id As String, _
                                 ByVal wipbin As String, _
                                 ByVal yank_date As String, _
                                 ByVal user_name As String, _
                                 ByVal gen_time_bombs As Boolean) As Integer

Description

These APIs cause the specified action item, opportunity, or quote to be yanked from the current location to a new owner's WIPBin. The date/time of the yank, and the person yanking the object are specified. The person who yanks the object becomes the new owner. The WIPBin to place the object in may also be specified. This is augmented function from base Clarify, where the object is always placed in the default WIPBin. The APIs can also generate a time bomb (for business rule notification).

Parameters

Parameter Name | Required? | Description
the_id | Yes | The object to yank
wipbin | No | The WIPBin to place the object in. If left blank, the default WIPBin for the user is used
yank_date | No | When was the object yanked. If this parameter is left blank, the yank occurs at the current time
user_name | No | The user who yanked the object. If left blank, the current user performs the yank. For business rules, it defaults to the user_name who is executing the cbbatch
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules)

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified object
-2 | The object is already closed
-3 | Cannot find the specified user
-4 | Cannot find the specified WIPBIN
-5 | Cannot find the YANK activity string

Examples

Yank action item number '154' by the current user at the current date/time. Place in the default WIPBin, generate a time bomb.

JavaScript:

var ret_int = fcsfa.yank_action_item("154", "", "", "", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fcsfa.yank_action_item("154", "", "", "", True)

Yank quote number 'Q2' at 10PM on November 23rd of 1997 by dave. Place in dave's WIPBin 'Urgent'. Don't generate a time bomb.

JavaScript:

var ret_int = fcsfa.yank_quote("Q2", "Urgent", "11/23/97 22:00:00", "dave", true);

Visual Basic:

Dim ret_int As Integer

ret_int = fcsfa.yank_quote("Q2", "Urgent", "11/23/97 22:00:00", "dave", True)


API Toolkit for ClearLogistics Field Operations | fcSDK Documentation

API Toolkit for ClearLogistics Field Operations

Overview

Many customers have wanted the ability to customize the Clarify environment easily by adding base Clarify functions (such as log time and expenses, log part used transactions, etc.) into web applications.

The First Choice Software FCFL API Toolkit for Clear Logistics Field Operations solves these problems, as well as many others. The toolkit is a set of functions that you may call from your applications.

All of the APIs perform the same base functions as the Clarify GUI - all database records are properly written, activity logs are generated to track the API call, and time bombs are added to the system so that business rules can be fired based on the API function call.

While all of the APIs mimic the Clarify base function, many of them provide augmented functionality that Clarify customers have requested. For example, the base Clarify log_parts_used function always requires the user to update the site configuration and inventory as separate steps (after the part used record is created). With the API, these functions can all be executed at the same time.

The APIs are simple to use. One simple API call is provided for each function, and very few data values must be supplied. The APIs are flexible in that they provide a large number of optional arguments that allow you to customize the API calls as needed.


add_svc_inter | fcSDK Documentation

add_svc_inter

Public Function add_svc_inter(ByVal case_id As String, _
                  ByVal sp_objid As Long, ByVal description As String, _
                  ByVal start_time As String, ByVal end_time As String, _
                  ByVal duration As Long, ByVal svc_class As String, _
                  ByVal svc_type As String, ByVal user_name As String, _
                  ByVal creation_time As String) As Integer

Description

This API logs a service interruption (and creates an appointment record) in the Clarify database. The user can specify a description and a cell text (the latter is what is shown in schedule tracker). You can specify the start/end time either with both times or with one time and a duration. The duration is specified in seconds.

Each appointment must be specified for a given case or a piece of equipment (site_part), but both cannot be specified. If you specify a case, the case must have a related site_part. The appointment type and subtype are optional code list values that may be specified. The user performing the logging may be specified as can the creation time. The APIs return the objid of the appointment object created.

Parameters

Parameter Name | Required? | Description
case_id | Yes | ID number of optional case, if appointment is for a case or site part
sp_objid | No | OBJID of the site_part if appointment is for a piece of equipment
description | No | The description of the appointment
start_time | No | When does the appointment start
end_time | No | When does the appointment end
duration | No | How long (in seconds) is the appointment. Note that two of the three (start, end, duration) must be given
svc_class | No | Value from the Installed Prod Sched Class code list
svc_type | No | Value from the Employee Sched Type code list
user_name | No | The user who made the appointment. If left blank, the current user performs the create
creation_time | No | When is the appt. log created. If left blank, it will be created at the current time

Returns

Value | Meaning
0 | No errors
-1 | If start time not specified there must be both an end time and duration specified
-2 | If end time not specified there must be both a start time and duration specified
-3 | Start time specified is after end time specified
-4 | If start time, end time, and duration are specified, duration specified must match
-5 | There must be either a case id or site part objid specified
-6 | Cannot find site_part for specified case
-7 | Cannot find specified case
-8 | The specified Installed Prod Sched Class not found in database
-9 | The specified Installed Prod Sched Type not found in database
-10 | Cannot find user in database
-11 | Cannot find employee record for user in database
-12 | Cannot find the 'Add Appt' activity string with rank = 6200
-13 | Site Part specified by objid was not found
-14 | There is an overlap between new interruption and existing interruption
-15 | There must be either a case id or site part objid specified, but not both
ret_objid | OBJID of the newly created appointment record.
ret_objid2 | OBJID of the newly created appointment record's schedule record.

Examples

Create a service interruption for case C102 for "sa" for the September 12, 1999, for 10 minutes. Relate to a case, and use default code list values.

Visual Basic:

Dim ret_int As Integer
Dim ap_objid   As Long

ret_int = fcfo.add_svc_inter("C102", 0, "test by case", _
   "9/12/99 11:00:00", "9/12/99 11:10:00", 600, _
   "", "", "sa", "7/23/99 2:57:59")

 If ret_int = 0 Then
   ap_objid = fcfo.ret_objid
 End If

JavaScript:

var ret_int = fcfo.add_svc_inter("C102", 0, "test by case",
   "9/12/99 11:00:00", "9/12/99 11:10:00", 600,
   "", "", "sa", "7/23/99 2:57:59");

 if (ret_int == 0){ var ap_objid = fcfo.ret_objid; }

Create an appointment for site_part 268435458 for the 12th of September 1999 (use start and end time) for 1 hour. Relate to a site_part, use default code list values.

Visual Basic:

Dim ret_int As Integer
Dim ap_objid   As Long

ret_int = fcfo.add_svc_inter("", 268435458, "test by site part", _
   "9/12/99 11:00:00", "9/12/99 12:00:00", _
   0, "", "", "", "7/23/99 2:57:59")

 If ret_int = 0 Then
   ap_objid = fcfo.ret_objid
 End If

JavaScript:

var ret_int = fcfo.add_svc_inter("", 268435458, "test by site part",
   "9/12/99 11:00:00", "9/12/99 12:00:00",
   0, "", "", "", "7/23/99 2:57:59");

 if (ret_int == 0){ var ap_objid = fcfo.ret_objid; }


create_expense_log | fcSDK Documentation

create_expense_log

Public Function create_expense_log(ByVal onsite_objid As Long, _
                  ByVal id_num As String, ByVal creation_time As String, _
                  ByVal notes As String, ByVal perf_by As String, _
                  ByVal user_name As String, ByVal expense_type As String, _
                  ByVal quantity As Double, ByVal the_rate As Double, _
                  ByVal billable As Long, ByVal bill_to As String, _
                  ByVal resolution As String) As Integer

Description

This API allows creation of an expense log that is related to an onsite log. The OBJID of the onsite log or a case/subcase id must be supplied (but not both), and the other parameters are all optional. If you do not specify a billing rate, the employee's labor_rate field will be used.

Parameters

Parameter Name | Required? | Description
onsite_objid | Yes | The OBJID of the onsite log this expense log is related to
id_num | No | The Id number for the Case if no onsite log is specified
creation_time | No | The time this expense log is created. If left blank, it will be the current time
notes | No | The note text for this expense log
perf_by | No | The user that is performing the actions associated to the onsite log
user_name | No | The user who is creating the onsite log. If left blank, the current user performs the create
expense_type | No | Value for the type of expense, from the EXPENSE_TYPE list in Policies and Customers. If left blank, the default value is used
quantity | No | The number of units that are being applied to the onsite log
the_rate | No | Billing rate (per unit). If no rate specified, the employee's labor_rate is used
billable | No | Indicates if this expense is billable
bill_to | No | Indicates who this expense log will be billed to, from the BILL_TO_EXPENSE list in Policies and Customers
resolution | No | Value from the Resolution Code list

Returns

Value | Meaning
0 | No errors
-1 | Could not find specified EXPENSE_TYPE
-2 | Could not find specified BILL_TO_EXPENSE
-3 | Cannot find user in database
-4 | Cannot find employee record for user in database
-5 | Cannot find performing user in database
-6 | Could not find specified RESOLUTION
-7 | Cannot find employee record for performing user in database
-8 | Cannot find the 'T & E log' activity string with rank = 1800
-9 | Cannot find case or subcase related to this expense log
-10 | Cannot find specified onsite_log record
-11 | Either Case Id or an onsite log objid must be specified
ret_objid | The objid of the new expense log object is returned by this parameter.
ret_objid2 | The objid of the new onsite object is returned by this parameter.

Examples

Create a new expense log related to onsite log 268435499. The creation time is 10:30 am on September 11, 1998. A sample note is passed, and the resolution will be "Completed". The user will default, and the performing user will be set to "db". This default expense type is billable to the "Customer". Once created, the new objid will be placed in the el_objid variable.

Visual Basic:

Dim ret_int As Integer
Dim el_objid As Long

ret_int = fcfo.create_expense_log(268435499, "", "09/11/98 10:30:00", _
       "expense log note", "db", "", "", 1, _
       4.5, 1, "Customer", "Completed")

   If ret_int = 0 Then
     el_objid = fcfo.ret_objid
   End If

JavaScript:

var ret_int = fcfo.create_expense_log(268435499, "", "09/11/98 10:30:00",
        "expense log note", "db", "", "", 1,
        4.5, 1, "Customer", "Completed");

if (ret_int == 0){ var el_objid = fcfo.ret_objid; }

Create a new expense log related to onsite log 268435463. The quantity is 1.5 units (at 3.33 each), non-billable. All other parameters will default.

Visual Basic:

Dim ret_int As Integer
Dim el_objid As Long

ret_int = fcfo.create_expense_log(268435463, "", "", "", "", "", _
                                   "", 1.5, 3.33, 0, "", "")

   If ret_int = 0 Then
     el_objid = fcfo.ret_objid
   End If

JavaScript:

var ret_int = fcfo.create_expense_log(268435463, "", "", "", "", "",
                                   "", 1.5, 3.33, 0, "", "");

if (ret_int == 0){ var el_objid = fcfo.ret_objid; }


create_onsite_log | fcSDK Documentation

create_onsite_log

Public Function create_onsite_log(ByVal object_type As String, _
                  ByVal object_id As String, ByVal creation_time As String, _
                  ByVal last_modified As String, ByVal notes As String, _
                  ByVal resolution As String, ByVal user_name As String, _
                  ByVal perf_by As String) As Integer

Description

This API allows creation of an onsite log that is related to a case or subcase. The object type and id of the focus object (the case or subcase) must be supplied, and the other parameters are all optional.

Parameters

Parameter Name | Required? | Description
object_type | Yes | The type of focus object that this onsite log is tied to. (CASE or SUBCASE)
object_id | Yes | The id number of the focus object
creation_time | No | The time this onsite log is created. If left blank, it will be set to the current time
last_modified | No | The last time a change was made to this onsite log
notes | No | The note text for this onsite log
resolution | No | Value from the Resolution Code list
user_name | No | The user who is creating the onsite log. If left blank, the current user performs the create
perf_by | No | The user that is performing the actions associated to the onsite log

Returns

Value | Meaning
0 | No errors
-1 | Object type must be 'case' or 'subcase'
-2 | Cannot find performing user in database
-3 | Cannot find RESOLUTION code in database
-4 | Cannot find employee record for user in database
-5 | Cannot find subcase in database
-6 | Cannot find the 'T & E log' activity string with rank = 1800
-7 | Cannot find specified case in database
ret_objid | The objid of the new onsite log object is returned by this parameter.

Examples

Create a new onsite log related to Case "3". The creation time is 4:00 pm on September 10, 1998. A sample note is shown, and the resolution will be the list default. The user and performing user will both default to the current Clarify user. Once created, the new objid will be placed in the ol_objid variable.

Visual Basic:

Dim ret_int As Integer
Dim ol_objid As Long

ret_int = fcfo.create_onsite_log("CASE", "3", _
"09/10/98 16:00:00", "", _
"New Onsite Log note", "", "", "")

 If ret_int = 0 Then
   ol_objid = fcfo.ret_objid
 End If

JavaScript:

var ret_int = fcfo.create_onsite_log("CASE", "3",
  "09/10/98 16:00:00", "",
  "New Onsite Log note", "", "", "");

if (ret_int == 0){ var ol_objid = fcfo.ret_objid; }

Create a new onsite log related to subcase "4-1". All other parameters will default.

Visual Basic:

Dim ret_int As Integer
Dim ol_objid As Long

ret_int = fcfo.create_onsite_log("SUBCASE", "4-1", "", "", _
                                  "", "", "", "")

   If ret_int = 0 Then
     ol_objid = fcfo.ret_objid
   End If

JavaScript:

var ret_int = fcfo.create_onsite_log("SUBCASE", "4-1", "", "",
                                     "", "", "", "");

if (ret_int == 0){ var ol_objid = fcfo.ret_objid; }


create_time_log | fcSDK Documentation

create_time_log

Public Function create_time_log(ByVal onsite_objid As Long, _
        ByVal id_num As String, ByVal creation_time As String, _
          ByVal notes As String, ByVal perf_by As String, _
        ByVal user_name As String, ByVal time_type As String, _
          ByVal start_time As String, ByVal duration As Long, _
        ByVal billable As Long, ByVal bill_to As String, _
          ByVal wrk_center As String, _
        ByVal resolution As String) As Integer

Description

This API allows creation of a time log that is related to an onsite log. The OBJID of the onsite log or a case/subcase id must be supplied (but not both), and the other parameters are all optional.

Parameters

Parameter Name | Required? | Description
onsite_objid | Yes | The OBJID of the onsite log this time log is related to
id_num | No | The Id number for the Case or Subcase if no onsite log is specified
creation_time | No | The time this time log is created. If left blank, it will be the current time
notes | No | The note text for this time log
perf_by | No | The user who is performing the actions associated to the onsite log
user_name | No | The user who is creating the onsite log. If left blank, the current user performs the create
time_type | No | Value from the TIME_TYPE list
start_time | Yes | When the process started
duration | Yes | How much time was spent, in number of seconds
billable | No | Indicates if this time is billable (1=Billable, Other Value = Not Billable)
bill_to | No | Indicates who this expense log will be billed to, from the BILL_TO_TIME list in Policies and Customers
wrk_center | No | Value from the WORK_CENTER list where the time was spent
resolution | No | Value from the RESOLUTION_CODE list

Returns

Value | Meaning
0 | No errors
-1 | Could not find specified TIME_TYPE value
-2 | Could not find specified BILL_TO_TIME value
-3 | Cannot find user in database
-4 | Cannot find employee record for user in database
-5 | Cannot find employee record for performing user in database
-6 | Cannot find specified case/subcase
-7 | Could not find specified WORK_CENTER
-8 | Could not find specified RESOLUTION_CODE
-9 | Cannot find the 'T & E log' activity string with rank = 1800
-10 | Either Case ID or Onsite Log Objid must be specified
-11 | Cannot find user record for performing user in database
-12 | The supplied onsite log objid is not found
ret_objid | The objid of the new time log object is returned by this parameter.
ret_objid2 | The objid of the new onsite object is returned by this parameter.

Examples

Create a new time log related to onsite log 268435522. The creation time is 10:55 am on September 11, 1998. A sample note is passed, and the resolution will be "Completed". The user will default, and the performing user will be set to "db". This default time type is billable to the customer. The process started in the default work center at 10:00 am and lasted for 10 minutes. Once created, the new objid will be passed back in the tl_objid field.

Visual Basic:

Dim ret_int As Integer
Dim tl_objid As Long

ret_int = fcfo.create_expense_log(268435522, "", "09/11/98 10:55:00", _
        "time log note", "db", "", "", _
        "09/11/98 10:00:00", 600, 1, "Customer", _
        "", "Completed")

   If ret_int = 0 Then
     tl_objid = fcfo.ret_objid
   End If

JavaScript:

var ret_int = fcfo.create_expense_log(268435522, "", "09/11/98 10:55:00",

                                   "time log note", "db", "", "",

        "09/11/98 10:00:00", 600, 1, "Customer",

        "", "Completed");

if (ret_int == 0){ var tl_objid = fcfo.ret_objid; }

Create a new time log related to onsite log 268435463. The time spent was 2 minutes, starting at noon on 9/10/1998, and was non-billable. All other parameters will default.

Visual Basic:

Dim ret_int As Integer
Dim tl_objid As Long

ret_int = fcfo.create_expense_log(268435463, "", "", "", "", "",_
                                   "", "09/09/1998 12:00", 120, 0, "", _
                                   "", "")

   If ret_int = 0 Then
     tl_objid = fcfo.ret_objid
   End If

JavaScript:

var ret_int = fcfo.create_expense_log(268435463, "", "", "", "", "",
                                   "", "09/09/1998 12:00", 120, 0, "",
                                   "", "");

if (ret_int == 0){ var tl_objid = fcfo.ret_objid; }


delete_appt | fcSDK Documentation

delete_appt

Public Function delete_appt(ByVal appt_objid As Long, _
                            ByVal user_name As String, _
                            ByVal creation_time As String) As Integer

Description

This API deletes an existing appointment. The objid of the appointment being deleted must be specified. You may specify the user performing the delete, and the time that the delete occurred.

Parameters

Parameter Name | Required? | Description
appt_objid | Yes | The OBJID of the appointment to delete
user_name | No | The user who deleted the appt. If left blank, the current user performs the delete
creation_time | No | When is the log deleted. If left blank, it will be deleted at the current time

Returns

Value | Meaning
0 | No errors
-1 | Specified appt not found in appointment table
-2 | Specified appt's schedule not found in database
-3 | Specified user name not found
-4 | Cannot find the 'Delete Appt' activity string with rank = 6400

Examples

Delete an appointment.

Visual Basic:

Dim ret_int As Integer

ret_int = fcfo.delete_appt(268435666, "", "")

JavaScript:

var ret_int = fcfo.delete_appt(268435666, "", "");

Joe deleted an appointment on February 1, 1998 at noon.

Visual Basic:

Dim ret_int As Integer

ret_int = fcfo.delete_appt(268436555, "Joe", "2/1/98 12:00:00")

JavaScript:

var ret_int = fcfo.delete_appt(268436555, "Joe", "2/1/98 12:00:00");


delete_expense_log | fcSDK Documentation

delete_expense_log

Public Function delete_expense_log(ByVal expense_log_objid As Long, _
                                   ByVal last_modified As String, _
                                   ByVal user_name As String) As Integer

Description

This API deletes an existing expense log. The expense log OBJID must be supplied, and the user performing the delete and the time that the delete occurred can optionally be specified.

Parameters

Parameter Name | Required? | Description
expense_log_objid | Yes | The OBJID of the expense log to delete
last_modified | No | When is the log deleted? If left blank, it will be deleted at the current time
user_name | No | The user who deleted the log. If left blank, the current user performs the delete

Returns

Value | Meaning
0 | No errors
-1 | Could not find specified expense log
-2 | Could not find onsite log for specified expense log
-3 | Could not find case for specified expense log
-4 | Could not find user in the database
-5 | Cannot find the 'T & E log edit' activity string with rank = 8700

Examples

Delete an expense log.

Visual Basic:

Dim ret_int As Integer

ret_int = fcfo.delete_expense_log(268435666, "", "")

JavaScript:

var ret_int = fcfo.delete_expense_log(268435666, "", "");

Joe deleted an expense log on February 1.

Visual Basic:

Dim ret_int As Integer

ret_int = fcfo.delete_expense_log(268436555, "2/1/98 12:00:00", "Joe")

JavaScript:

var ret_int = fcfo.delete_expense_log(268436555, "2/1/98 12:00:00", "Joe");


delete_onsite_log | fcSDK Documentation

delete_onsite_log

Public Function delete_onsite_log(ByVal onsite_log_objid As Long, _
                  ByVal note_date As String, _
                  ByVal user_name As String) As Integer

Description

This API deletes an existing onsite log. The onsite log OBJID must be supplied, and the user performing the delete and the time that the delete occurred can optionally be specified.

Parameters

Parameter Name | Required? | Description
onsite_log_objid | Yes | The OBJID of the onsite log to delete
note_date | No | When is the log deleted? If left blank, it will be deleted at the current time
user_name | No | The user who deleted the log. If left blank, the current user performs the delete

Returns

Value | Meaning
0 | No errors
-1 | Cannot find specified onsite record
-2 | Cannot find user for onsite record
-3 | Cannot find case for onsite record
-4 | Cannot find the 'T & E log delete' activity string with rank = 10600

Examples

Delete an onsite log.

Visual Basic:

Dim ret_int As Integer

ret_int = fcfo.delete_onsite_log(268435666, "", "")

JavaScript:

var ret_int = fcfo.delete_onsite_log(268435666, "", "");

Joe deleted an onsite log on February 1, 1998 at noon.

Visual Basic:

Dim ret_int As Integer

ret_int = fcfo.delete_onsite_log(268436555, "2/1/98 12:00:00", "Joe")

JavaScript:

var ret_int = fcfo.delete_onsite_log(268436555, "2/1/98 12:00:00", "Joe");


delete_svc_inter | fcSDK Documentation

delete_svc_inter

Public Function delete_svc_inter(ByVal appt_objid As Long, _
                                 ByVal user_name As String, _
                                 ByVal creation_time As String) As Integer

Description

This API deletes an existing service interruption (appointment). The objid of the appointment being deleted must be specified. You may specify the user performing the delete, and the time that the delete occurred.

Parameters

Parameter Name | Required? | Description
appt_objid | Yes | The OBJID of the appointment to delete
user_name | No | The user who deleted the appt. If left blank, the current user performs the delete
creation_time | No | When is the Appt. deleted? If left blank, it will be deleted at the current time

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified appointment
-2 | Cannot find user in database
-3 | Cannot find employee record for user in database
-4 | Cannot find the 'Delete Appt' activity string with rank = 6400

Examples

Delete an appointment.

Visual Basic:

Dim ret_int As Integer

ret_int = fcfo.delete_svc_inter(268435666, "", "")

JavaScript:

var ret_int = fcfo.delete_svc_inter(268435666, "", "");

Joe deleted an appointment on February 1, 1999 at noon.

Visual Basic:

Dim ret_int As Integer

ret_int = fcfo.delete_svc_inter(268436555, "Joe", "2/1/99 12:00:00")

JavaScript:

var ret_int = fcfo.delete_svc_inter(268436555, "Joe", "2/1/99 12:00:00");


delete_time_log | fcSDK Documentation

delete_time_log

Public Function delete_time_log(ByVal time_log_objid As Long, _
                  ByVal last_modified As String, _
                  ByVal user_name As String) As Integer

Description

This API deletes an existing time log. The time log OBJID must be supplied, and the user performing the delete and the time that the delete occurred can optionally be specified.

Parameters

Parameter Name | Required? | Description
time_log_objid | Yes | The OBJID of the time log to delete
last_modified | No | When is the log deleted? If left blank, it will be deleted at the current time
user_name | No | The user who deleted the log. If left blank, the current user performs the delete

Returns

Value | Meaning
0 | No errors
-1 | Could not find specified time log
-2 | Could not find onsite log for time log
-3 | Could not find case for time log
-4 | Could not find user in the database
-5 | Cannot find the 'T & E log edit' activity string with rank = 8700

Examples

Delete time log.

Visual Basic:

Dim ret_int As Integer

ret_int = fcfo.delete_time_log(268435666, "", "")

JavaScript:

var ret_int = fcfo.delete_time_log(268435666, "", "");

Joe deleted a time log on February 1, 1998 at noon.

Visual Basic:

Dim ret_int As Integer

ret_int = fcfo.delete_time_log(268436555, "2/1/98 12:00:00", "Joe")

JavaScript:

var ret_int = fcfo.delete_time_log(268436555, "2/1/98 12:00:00", "Joe");


dispatch_fe | fcSDK Documentation

dispatch_fe

Public Function dispatch_fe(ByVal case_id As String, _
      ByVal user_name As String, ByVal dispatch_time As String, _
      ByVal work_order As String, ByVal appointment_time As String, _
      ByVal duration As Long, ByVal description As String, _
      ByVal cont_fname As String, ByVal cont_lname As String, _
      ByVal address1 As String, ByVal address2 As String, _
      ByVal city As String, ByVal state As String, _
      ByVal zipcode As String, ByVal main_phone As String, _
      ByVal alt_phone As String, ByVal site_id As Long, _
      ByVal pay_method As String, ByVal ref_number As String, _
      ByVal notes As String, ByVal requested_eta As String, _
      ByVal appt_confirm As Long, ByVal cell_text As String, _
      ByVal proxy As String, ByVal removed As Long, _
      ByVal gen_time_bomb As Boolean) As Integer

Description

This API creates a dispatch field engineer (work order) record. The caller may specify the appointment time and duration, text about the work order and other fields such as the payment method. The contact and site for the dispatch will be derived from the case/subcase. If this is not correct, the address for the site for the dispatch can be specified in the site_id field. If that is mostly correct, but some fields need to be overridden, they can in the extra phone and address fields supplied. Finally, a time bomb for the dispatch FE action can be generated, or not.

Parameters

Parameter Name | Required? | Description
case_id | Yes | The case (or subcase) that the dispatch FE is for
user_name | No | The user who dispatched the FE request. If left blank, the current user performs the dispatch
dispatch_time | No | When is the dispatch logged. If left blank, it will be logged at the current time
work_order | No | The ID of the work order. If left blank, "." is used for the work order
appointment_time | No | When to add an appointment for the work order. If left blank, the current time is used
duration | No | The length (in seconds) of the appointment. If left blank, the duration is calculated from the start and end times
description | No | Description of the dispatch FE. If left blank, the description is set to the title of the case or subcase
cont_fname | No | Contact first name to override case/subcase contact
cont_lname | No | Contact last name to override case/subcase contact
address1 | No | Address line 1 (if override desired)
address2 | No | Address line 2 (if override desired)
city | No | Address city (if override desired)
state | No | Address state (if override desired)
zipcode | No | Address zipcode (if override desired)
main_phone | No | Contact's phone (if override desired)
alt_phone | No | Alternate phone (if override desired)
site_id | No | Site for dispatch if case/subcase site is not OK
pay_method | No | Payment method used. If left blank, default is used
ref_number | No | Reference number for work order
notes | No | Notes about the work order
requested_eta | No | When should the engineer arrive (date/time). If left blank, the current time is used as the time for arrival
appt_confirm | No | Is the appointment confirmed? Default is 0 (not)
cell_text | No | Cell text for the appointment in schedule tracker
proxy | No | Optional proxy field. Defaults to "" on the activity record if not specified
removed | No | Optional remove field. Defaults to 0 on the activity record if not specified
gen_time_bomb | Yes | Should a time_bomb be created?

Returns

Value | Meaning
0 | No errors
-1 | Could not find Specified case/subcase in database
-2 | Could not find the contact for specified case/subcase
-3 | Cannot find the 'Field Dispatch' activity string with rank = 700
-4 | Specified user name is not valid
-5 | Specified PAY_METHOD not found in database
-6 | The requested ETA is not a valid date
-7 | Cannot find employee record for specified user
ret_objid | The objid of the new dispatch_fe object is returned by this parameter.

Examples

Dispatch an Engineer for case 3. "sa" logged the request, and we built up the work order number. Override all contact/site information, and generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fcfo.dispatch_fe("3", "sa", "", "work order" & _
                DatePart("m", Date), "", 0, "", _
                "Sam", "Tyson", "112 Jupiter Hollow", _
                "Shack #69", "Jupiter", "MN", "88775", _
                "512-418-2905", "",0,  "", "", "", "", _
                0, "", "", 0, True)

JavaScript:

var ret_int = fcfo.dispatch_fe("3", "sa", "", "work order" &
   DatePart("m", Date), "", 0, "",
   "Sam", "Tyson", "112 Jupiter Hollow",
   "Shack #69", "Jupiter", "MN", "88775",
   "512-418-2905", "",0,  "", "", "", "",
   0, "", "", 0, true);

Dispatch an engineer for subcase 42-2. Don't fill in any extra information. Don't generate a time bomb.

Visual Basic:

Dim ret_int As Integer

ret_int = fcfo.dispatch_fe("42-2", "", "", "", "", 0, "", _
                "", "", "", "", "", "", "", "", "", _
                0,  "", "", "", "", 0, "", "", 0, False)

JavaScript:

var ret_int = fcfo.dispatch_fe("42-2", "", "", "", "", 0, "",
   "", "", "", "", "", "", "", "", "",
   0,  "", "", "", "", 0, "", "", 0, false);


log_parts_used | fcSDK Documentation

log_parts_used

Public Function log_parts_used(ByVal dtl_num As String, _
                  ByVal case_id As String, ByVal pu_type As String, _
                  ByVal parent_sp As Long, ByVal install_at_site As Boolean, _
                  ByVal remove_sp As Long, ByVal to_loc As String, _
                  ByVal to_bin As String, ByVal to_cont As String, _
                  ByVal to_good As Boolean, ByVal fail_code As String, _
                  ByVal inst_part As String, ByVal inst_rev As String, _
                  ByVal inst_domain As String, ByVal inst_serial As String, _
                  ByVal inst_qty As Long, ByVal inst_price As String, _
                  ByVal from_loc As String, ByVal from_bin As String, _
                  ByVal from_cont As String, ByVal from_good As Boolean, _
                  ByVal engineer_name As String, ByVal user_name As String, _
                  ByVal allow_move As Boolean, ByVal log_date As String, _
                  ByVal log_objid As Long) As Integer

Description

This API allows you to record a log parts used transaction in Clarify. All of the functionality (and there is quite a lot of it!) from the Log Parts Used form is emulated in the API. Each log parts used must be related to either a case or a part request detail. If it is related to both, the part request detail must be linked to the case. The engineer performing the log parts used, as well as the user who is recording the log can be specified, as well as the date/time of the action. The objid of the log parts used record is returned.

Both serialized and quantity-tracked parts can be logged, and the API performs all of the correct operations, based on the serial number/quantity fields.

Each of the five types of log parts used (Exchange, Upgrade, Install, Remove, Consume) are supported. Only the fields needed for the specific PU type being executed are validated. For the various types, four different actions are supported:

  1. Install a site_part. If the type requires a site_part to be installed, the part_number, revision (mod_level), and domain must be specified. Also, the quantity and/or serial number should be supplied. Optionally, the installed part's price can be specified, and the "install_at_site" should be specified to determine if it is installed at the top-level of the site, or under another site_part. In the latter case, the objid of the parent site_part must be specified.

  2. Remove a site_part. The objid of the part to be removed must be specified, and the failure code (dropdown list) value may be specified.

  3. Place removed part in inventory. Optionally, a removed part may be placed back in inventory. If the "to" fields for location, bin, and good/bad are specified, the part will be put back in inventory. It can also be transferred to an Expense GL account.

  4. Install a part from inventory. Optionally, the part to be installed can be pulled from inventory (or an Expense GL account) by specifying the "to" fields.

If a part is to be installed (serialized parts only), and already exists in the system as a site_part, it will be moved (not installed). This assumes that the "allow_move" flag is set to True. If not, an error code is produced.

When the log parts used action occurs, the API will change the condition of the part request (if one is listed in the arguments) to either the condition of: Part Used or Update Inv. If there are no inventory movements, the former condition will be used. If either the install or remove part are moved to/from inventory, the condition will be set to Update Inv. In both cases, the API will set the status of the part request to the default status for the condition, and will validate the ClearLogistics transitions to make sure that the user who is logging the action can perform the state transition.

Note: You may set the log_objid argument to the value of -99. If you do, then no config mgr actions will be performed. No installs of parts, de-installs of parts, or moves of parts will be performed. If this option is selected, then only the inventory movements will be recorded (along with the activity log and condition change). THIS OPTION IS NOT RECOMMENDED, as it leaves inventory in a confusing state. If you have a site_part to remove, you may still supply the objid in the argument "remove_sp." If there are no installed site_parts, you may supply a part number, revision, domain, quantity, and serial number to remove (again, only as an inventory operation) by putting the data in the "inst_price" field in the following format (pipe delimited):

Part_num|rev|domain|quantity|serial_num

All five fields must be defined. If one is blank, just put two pipes next to each other with no data. For example, suppose a part of "MS Word" is being removed, with no revision, a domain of "Product", quantity 1 and serial number of "ABC", the price_inst argument would be: "MS Word||Product|1|abc".

Four error codes (-32, -33, -37, -38) are supplied for this option.

Parameters

Parameter Name | Required? | Description |
dtl_num | No | The ID number of the related part request detail (if one is related) |
case_id | No | The ID number of the related case (if one is related) |
pu_type | Yes | The type of the log parts used. One of: Exchange, Consume, Install, Remove, Upgrade |
parent_sp | No | If a part is being installed, and it should be installed underneath a site_part, this field contains the objid of the parent site_part |
install_at_site | Yes | For installing parts, should the part be installed at the top-level of the site? |
remove_sp | No | For removing parts, this is the objid of the site_part to remove |
to_loc | No | For removing parts, this is the inventory location (or expense GL) to transfer the part to (if it is being transferred to inventory) |
to_bin | No | The bin to transfer the removed site_part to |
to_cont | No | The id_number of the container. If not using a container, this argument should be blank. If you are using a container, the to_bin argument should be the container name. |
to_good | Yes | Should the removed site_part be placed as good or bad stock in inventory |
fail_code | No | For removing parts, what is the failure code (dropdown list). If left blank, the default code is used |
inst_part | No | For installing parts, the part_number to install. If a part request is specified, the default part is taken from the part request |
inst_rev | No | For installing parts, the revision (mod_level) to install. If a part request is specified, the default part revision is taken from the part request |
inst_domain | No | For installing parts, the domain of the part to install. If a part request is specified, the default part domain is taken from the part request |
inst_serial | No | If the part to be installed is serialized, this is the serial number |
inst_qty | No | For installing parts, the quantity of parts to install |
inst_price | No | For installing parts, the price (per part) to use. If left blank, the default US List price is used. For inventory-only transactions, this field may contain the part number, revision, domain, quantity, and serial number of the part (all separated by ' | ' characters) to remove to inventory. See above for more details
from_loc | No | If the installed part is pulled from inventory, this is the inventory location (or expense GL) |
from_bin | No | The bin that the installed part is pulled from |
from_cont | No | The id_number of the container. If not using a container, this argument should be blank. If you are using a container, the to_bin argument should be the container name |
from_good | No | Was the installed part pulled from good or bad stock? |
engineer_name | No | The login_name of the engineer who performed the parts used action. If left blank, the current user is used |
user_name | No | The name of the user who logged the action. If left blank, the current user is used. |
allow_move | Yes | If a serialized part is to be installed, and it already exists as an active site _part, should we allow the move to occur? |
log_date | No | When was the action? If left blank, the current time is used |
log_objid | No | If you wish to perform only the inventory movements for this log_pu, then set this argument to -99 as input |

Returns

Value | Meaning
0 | No errors
-1 | The Part Usage Type specified is invalid
-2 | Cannot install at top_level and specify a parent part
-3 | Cannot install under a parent and not specify parent part
-4 | Cannot find specified user in database
-5 | The engineer name supplied is not found in the database
-6 | The specified part request detail is not found
-7 | The specified case is not found in the database
-8 | The parent site_part specified is not found in the database
-9 | The specified parent site_part is not at the case's (or part request's) site
-10 | The removed site_part is not at the site for the case (or part request)
-11 | The specified "to_bin" cannot be found
-12 | Specified Failure Code is not a valid code
-13 | A Case ID or Part Request Detail must be specified
-14 | The part request detail is not related to a case
-15 | The Specified Case and part request ID are not related to each other
-16 | Cannot install part because part_number/revision/domain specified is not found
-17 | Quantity specified must be greater than 0
-18 | The specified "from_bin" cannot be found
-19 | Cannot find the "Part Used Variance" expense GL account
-20 | If serial number tracked, the specified serial number is not found at the "from_bin" - it's at another location
-21 | Quantity must be 1 if serial number specified
-22 | Specified price is not numeric
-23 | Cannot find the "Part Used" activity string with rank = 11300
-24 | Cannot find specified condition
-25 | The specified transition (to "Part Used" or "Update Inv") is not defined
-26 | The specified user is not authorized to make the transition to the new part request condition
-27 | Removing a site_part, but no site_part is specified, and the part request (if using one) is not on a site_part
-28 | Upgrade transaction specified, but the part number or serial number for the install and remove parts do not agree
-29 | Trying to install a site_part, but it already exists, and the allow_move flag is set to False
-30 | The "to" container is sealed
-31 | The "from" container is sealed
-32 | Inventory only was selected (log_objid = -99), but no inventory locations were specified
-33 | For inventory-only removes, the number of variables in the inst_price is not 5
-34 | Cannot find privilege class for specified user
-35 | Cannot find old status for part request condition
-36 | Cannot find new status for part request condition
-37 | For inventory-only removes, the part number supplied to remove is not found
-38 | For inventory-only removes, the revision of the part to remove is not found
-39 | There is no quantity in the "from_bin" to transfer and install the part(s)
-40 | There is not enough GOOD quantity in the "from_bin" to transfer and install the part(s)
-41 | There is not enough BAD quantity in the "from_bin" to transfer and install the part(s)
-42 | Cannot find employee record for specified user in database
-100 -> -199 | Any errors between -100 and -199 are from the call to install site_part. See the documentation for install_sp in this manual. For example, -101 from this API is the same as -1 from the other
-200 -> -299 | Any errors between -200 and -299 are from deinstall site_part. See the documentation for deinstall_sp in this manual. For example, -201 from this API is the same as -1 from the other
-300 -> -399 | Any errors between -300 and -399 are from the call to part_transfer. See the documentation for part_transfer in this manual. For example, -301 from this API is the same as -1 from the other. These codes are for the transfer "to" transaction (remove site_part)
-400 -> -499 | Any errors between -400 and -499 are from the call to part_transfer. See the documentation for part_transfer in this manual. For example, -401 from this API is the same as -1 from the other. These codes are for the transfer "from" transaction (install site_part)
-500 -> -599 | Any errors between -500 and -599 are from move_sp. See the documentation for move_sp in this manual. For example, -501 from this API is the same as -1 from the other
-600 -> -699 | Any errors between -600 and -699 are from the call to reinstall_sp. See the documentation for reinstall_sp in this manual
ret_objid | The objid of the new part_used object is returned by this parameter.

Examples

Fred performed an exchange of parts. He removed a site_part (related to part request '14-1'), and installed MS Word version 7.0, with a serial number of '1234' (under a site_part). The removed part will be put in the "Restock" bin (as bad inventory), and the installed part was pulled from "San Jose/Bin 4". The action is logged by "sa" on February 20,1998. It is also against case '23'.

Visual Basic:

Dim ret_int As Integer
Dim log_objid  As Long

ret_int = fcfo.log_parts_used("14-1", "23", "Exchange", 268435566, _
    False, 0, "Austin", "Restock", "", False, _
    "Failure code3", "MS Word", "7.0", _
    "Product", "1234", 1, "", "San Jose", _
    "Bin 4", "", True, "Fred", "sa", True, _
    "2/20/98 9:25:00")

 If ret_int = 0 Then
   log_objid = fcfo.ret_objid
 End If

JavaScript:

var ret_int = fcfo.log_parts_used("14-1", "23", "Exchange", 268435566,
   false, 0, "Austin", "Restock", "", false,
   "Failure code3", "MS Word", "7.0",
   "Product", "1234", 1, "", "San Jose",
   "Bin 4", "", true, "Fred", "sa", true,
   "2/20/98 9:25:00");

if (ret_int == 0){ var log_objid = fcfo.ret_objid; }

Install 5 of a site_part at the top level of a site. Do not do any inventory transfers.

Visual Basic:

Dim ret_int As Integer
Dim log_objid  As Long

ret_int = fcfo.log_parts_used("2-2", "", "Install", 0, True, 0, _
   "", "", "", True, "", "", "", "", _
   "", 5, "", "", "", "", True, _
   "", "",False, "")

 If ret_int = 0 Then
   log_objid = fcfo.ret_objid
 End If

JavaScript:

var ret_int = fcfo.log_parts_used("2-2", "", "Install", 0, true, 0,
   "", "", "", true, "", "", "", "",
   "", 5, "", "", "", "", true,
   "", "",false, "");

 if (ret_int == 0){ var log_objid = fcfo.ret_objid; }


make_appt | fcSDK Documentation

make_appt

Public Function make_appt(ByVal description As String, _
      ByVal start_time As String, ByVal end_time As String, _
      ByVal duration As Long, ByVal cell_text As String, _
      ByVal emp_first As String, ByVal emp_last As String, _
      ByVal site_part_objid As Long, ByVal appt_type As String, _
      ByVal appt_sub_type As String, ByVal case_id As String, _
      ByVal user_name As String, ByVal creation_time As String) As Integer

Description

This API creates an appointment record in the Clarify database. The user can specify a description and a cell text (the latter is what is shown in schedule tracker). You can specify the start/end time either with both times or with one time and a duration. The duration is specified in seconds.

Each appointment must be specified for a given employee or a piece of equipment (site_part). Both cannot be specified. The appointment type and subtype are optional code list values that may be specified, and the case ID may also be optionally specified. The user performing the logging may be specified as can the creation time. The API returns the objid of the appointment object created.

Parameters

Parameter Name | Required? | Description
description | No | The description of the appointment
start_time | Yes | When does the appointment start
end_time | No | When does the appointment end
duration | No | How long (in seconds) is the appointment. Note that two of the three (start, end, duration) must be given
cell_text | No | The text to display in the schedule tracker cell
emp_first | No | First name of employee if appointment is for the employee
emp_last | No | Last name of the employee if appointment is for the employee
site_part_objid | No | OBJID of the site_part if appointment is for a piece of equipment
appt_type | No | Value from the Employee Sched Class code list
appt_sub_type | No | Value from the Employee Sched Type code list
case_id | No | ID number of optional case, if appointment is for a case
user_name | No | The user who made the appointment. If left blank, the current user performs the create
creation_time | No | When is the log created. If left blank, it will be created at the current time

Returns

Value | Meaning
0 | No errors
-1 | End date and duration required if start time not specified
-2 | Start date and duration required if end time not specified
-3 | Start time cannot be greater than specified end time
-4 | Duration does not match start/end times
-5 | No employee or site_part specified
-6 | Both employee and site_part specified
-7 | Specified case not found in database
-8 | The appt_type gbst elm not found in database
-9 | The appt_sub_type gbst elm not found in database
-10 | Specified user name not found in database
-11 | Cannot find the 'Add Appt' activity string with rank = 6200
-12 | Specified employee not found in database
-13 | Specified site_part not found in database
ret_objid | The objid of the new appointment object is returned by this parameter.

Examples

Create an appointment for employee "sa" for the 11th of October, 1998 for 10 minutes. Relate to a case, and set up type and subtype values.

Visual Basic:

Dim ret_int As Integer
Dim ap_objid   As Long

ret_int = fcfo.make_appt("test description", "10/11/98 11:00:00", _
           "", 600, "Cell text", "sa", "sa", 0, _
           "Field Service", "Warranty Upgrade", "1", _
           "sa", "")

 If ret_int = 0 Then
   ap_objid = fcfo.ret_objid
 End If

JavaScript:

var ret_int = fcfo.make_appt("test description", "10/11/98 11:00:00",
       "", 600, "Cell text", "sa", "sa", 0,
    "Field Service", "Warranty Upgrade", "1", "sa", "");

 if (ret_int == 0){ var ap_objid = fcfo.ret_objid; }

Create an appointment for site_part 268435458 for the 11th of Octember, 1998 (use start and end time) for 1 hour. Relate to a case, use default code list values. Don't relate to a case, and have it logged by "Joe" at an earlier date/time.

Visual Basic:

Dim ret_int As Integer
Dim ap_objid   As Long

ret_int = fcfo.make_appt("test description", "10/11/98 11:00:00", _
   "9/11/98 12:00:00", 0, "Cell text", "", "", _
   268435458, "", "", "", "Joe", "10/1/98 8:00:00")

 If ret_int = 0 Then
   ap_objid = fcfo.ret_objid
 End If

JavaScript:

var ret_int = fcfo.make_appt("test description", "10/11/98 11:00:00",
     "9/11/98 12:00:00", 0, "Cell text", "", "",
       268435458, "", "", "", "Joe", "10/1/98 8:00:00");

 if (ret_int == 0){ var ap_objid = fcfo.ret_objid; }


modify_appt | fcSDK Documentation

modify_appt

Public Function modify_appt(ByVal appt_objid As Long, _
                  ByVal start_time As String, ByVal end_time As String, _
                  ByVal duration As Long, ByVal description As String, _
                  ByVal cell_text As String, ByVal appt_class As String, _
                  ByVal appt_type As String, ByVal user_name As String, _
                  ByVal creation_time As String) As Integer

Description

This API modifies an existing appointment record in the Clarify database. You must pass in a valid appointment Objid (which is returned by the make_appt API). The user can specify a description and a cell text (the latter is what is shown in schedule tracker). You can specify the start/end time either with both times or with one time and a duration, but at least 2 of the 3 parameters must be specified. The duration is specified in seconds.

The appointment type and subtype are optional code list values that may be specified. The user performing the logging may be specified as can the creation time. If you do not specify a value for one of the arguments, the value in the existing record is not updated.

Parameters

Parameter Name | Required? | Description
appt_objid | Yes | The OBJID of the appointment to modify
start_time | No | When does the appointment start
end_time | No | When does the appointment end
duration | No | How long (in seconds) is the appointment. Note that two of the three (start, end, duration) must be given
description | No | The description of the appointment
cell_text | No | The text to display in the schedule tracker cell
appt_type | No | Value from the Employee Sched Class code list
appt_sub_type | No | Value from the Employee Sched Type code list
user_name | No | The user who modified the appointment. If left blank, the current user performs the modify
creation_time | No | When is the log modified? If left blank, it will be modified at the current time

Returns

Value | Meaning
0 | No errors
-1 | Specified start time is not a valid date
-2 | Specified end time is not a valid date
-3 | Start time cannot be greater than specified end time
-4 | Duration is not the same as difference of start and end times
-5 | Cannot find specified appointment record
-6 | Cannot find schedule for specified appointment
-7 | Cannot find specified user in database
-8 | Cannot find the 'Replace Appt' activity string with rank = 6300
-9 | Cannot find specified Appt Class
-10 | Cannot find specified Appt Type

Examples

Update an existing appointment. Set all the data that you can set. Change the start time and end time for the appointment.

Visual Basic:

Dim ret_int As Integer

ret_int = fcfo.modify_appt(268435457, "12/1/98 16:00:00", "", 1800, _
                            "A new description", "New cell text", _
                            "Appt type", "Appt subtype", "Fred", "9/9/98")

JavaScript:

var ret_int = fcfo.modify_appt(268435457, "12/1/98 16:00:00", "", 1800,
                         "A new description", "New cell text",
                         "Appt type", "Appt subtype", "Fred", "9/9/98");

Simply change the start time for an appointment. Leave it at 1 hour in length.

Visual Basic:

Dim ret_int As Integer

ret_int = fcfo.modify_appt(268435466, "12/1/98 16:00:00", "", 3600, _
                            "", "", "", "", "", "")

JavaScript:

var ret_int = fcfo.modify_appt(268435466, "12/1/98 16:00:00", "", 3600,_
                            "", "", "", "", "", "");


modify_expense_log | fcSDK Documentation

modify_expense_log

Public Function modify_expense_log(ByVal expense_log_objid As Long, _
                                   ByVal creation_time As String, _
                                   ByVal perf_by As String, _
                                   ByVal notes As String, _
                                   ByVal user_name As String, _
                                   ByVal expense_type As String, _
                                   ByVal quantity As Double, _
                                   ByVal the_rate As Double, _
                                   ByVal billable As Long, _
                                   ByVal bill_to As String, _
                                   ByVal resolution As String) As Integer

Description

This API modifies an existing expense log record in the Clarify database. You must pass in a valid expense log objid (which is returned by the create_expsense_log API). You can specify the a variety of data items for the expense, including who performed the expense, notes, and a quantity and rate for the expense. If you do not specify a value for one of the arguments, the value in the existing record is not updated.

Parameters

Parameter Name | Required? | Description
expense_log_objid | Yes | The OBJID of the expense log to modify
creation_time | No | When is the log modified? If left blank, it will be modified at the current time. Used for time_bomb creation.
perf_by | No | The user who modified the time log. If left blank, the current user performs the modify
notes | No | The updated notes for the onsite log
user_name | No | The user who is recording the modification of the expense log. If left blank, the current user records the modify
expense_type | No | Value from the EXPENSE_TYPE code list
quantity | Yes | Quantity for the expense log
the_rate | Yes | Rate for the expense log
billable | No | Indicates if this expense is billable
bill_to | No | Indicates who this expense log will be billed to, from the BILL_TO_EXPENSE list in Policies and Customers
resolution | No | Value from the RESOLUTION_CODE list

Returns

Value | Meaning
0 | No errors
-1 | Could not find specified EXPENSE_TYPE
-2 | Could not find specified BILL_TO_TIME
-3 | Cannot find specified user in database
-4 | Cannot find employee record for specified user in database
-5 | Cannot find performing user in database
-6 | Could not find case or subcase for expense log record
-7 | Could not find specified WORK_CENTER
-8 | Could not find specified RESOLUTION_CODE
-9 | Could not find the specified expense log record
-10 | Cannot find employee record for performing user in database
-11 | Cannot find the 'T & E Log' activity string with rank = 8700

Examples

Update an existing expense log (268435600). Log is created at the current time, is performed by "joe", and is logged by "fred". Add some notes, and set the quantity to 6 and the rate to 3.45. Use the default expense type. Make it not billable, and don't set the bill_to string. Use the default resolution code.

Visual Basic:

Dim ret_int As Integer

ret_int = fcfo.modify_expense_log(268435600, "joe", "Some notes here",
    "fred", "", 6, 3.45, 0, "", "")

JavaScript:

var ret_int = fcfo.modify_expense_log(268435600, "joe", "Some notes here",
    "fred", "", 6, 3.45, 0, "", "");


modify_svc_inter | fcSDK Documentation

modify_svc_inter

Public Function modify_svc_inter(ByVal appt_objid As Long, _
          ByVal desc As String, ByVal start_time As String, _
          ByVal end_time As String, ByVal duration As Long, _
          ByVal svc_class As String, ByVal svc_type As String, _
          ByVal user_name As String, ByVal creation_time As String) As Integer

Description

This API modifies an existing service interruption (appointment) record in the Clarify database. You must pass in a valid appointment objid (which is returned by the add_svc_inter APIs). The user can specify a description and can append to a description by using "+" as the first character of the text to add to the original. You can specify the start/end time either with both times or with one time and a duration but at least 2 of the 3 parameters must be specified. To use the original appointment time, don't specify the start_time or end_time. The duration is specified in seconds. You can specify a "-1" in the svc_class, svc_type, and this will leave the original data in the appointment record.

The appointment type and subtype are optional code list values that may be specified. The user performing the logging may be specified as can the creation time. If you do not specify a value for one of the arguments, the value in the existing record is not updated.

Parameters

Parameter Name | Required? | Description
appt_objid | Yes | The OBJID of the appointment to modify
description | No | The description of the appointment
start_time | No | When does the appointment start. If you want to leave the original time, use = ""
end_time | No | When does the appointment end. If you want to leave the original time, use = ""
duration | No | How long (in seconds) is the appointment
svc_class | No | Value from the Installed Prod Sched Class code list (Use "" to keep current value)
svc_type | No | Value from the Installed Prod Sched Type code list (Use "" to keep current value)
user_name | No | The user who modified the appointment. If left blank, the current user performs the modify
creation_time | No | When is the log modified? If left blank, it will be modified at the current time

Returns

Value | Meaning
0 | No errors
-1 | If start time not specified there must be both an end time and duration specified
-2 | Specified end time is not valid
-3 | Start time specified is after end time specified
-4 | If start time, end time, and duration are specified, duration specified must match
-5 | Cannot find the specified appointment
-6 | Cannot find the schedule for the specified appointment
-7 | Specified appt has no appt_type defined
-8 | Specified appt has no sub_type defined
-9 | Cannot find specified Appt Class
-10 | Cannot find specified Appt Type
-11 | Cannot find specified user in database
-12 | Cannot find employee record for specified user in database
-13 | Cannot find the 'Replace Appt' activity string with rank = 6300

Examples

Update an existing appointment. Set all the data that you can set. Change the start time and set the end time to the original end time from the appointment by using "-1".

Visual Basic:

Dim ret_int As Integer

ret_int = fcfo.modify_svc_inter(268435465, "A new description", _
     "12/1/98 16:00:00", "-1", 600, _
     "Appt type", "Appt subtype",  "sa", "9/9/98")

JavaScript:

var ret_int = fcfo.modify_svc_inter(268435465, "A new description",
         "12/1/98 16:00:00", "-1", 600,
         "Appt type", "Appt subtype",  "sa", "9/9/98");

Simply append to the description for an appointment.

Visual Basic:

Dim ret_int As Integer

ret_int = fcfo.modify_svc_inter(268435465, "+for api", "", "", 0, _
                                "", "", "", "")

JavaScript:

var ret_int = fcfo.modify_svc_inter(268435465, "+for api", "", "", 0,
                                    "", "", "", "");


modify_time_log | fcSDK Documentation

modify_time_log

Public Function modify_time_log(ByVal time_log_objid As Long, _
                  ByVal creation_time As String, ByVal perf_by As String, _
                  ByVal notes As String, ByVal user_name As String, _
                  ByVal time_type As String, ByVal start_time As String, _
                  ByVal duration As Long, ByVal billable As Long, _
                  ByVal bill_to As String, ByVal wrk_center As String, _
                  ByVal resolution As String) As Integer

Description

This API modifies an existing time log record in the Clarify database. You must pass in a valid time log objid (which is returned by the create_time_log API). You can specify the start time and a duration. The duration is specified in seconds.

The time type is an optional code list value that may be specified. The user performing the logging may be specified as can the creation time. If you do not specify a value for one of the arguments, the value in the existing record is not updated.

Parameters

Parameter Name | Required? | Description
time_log_objid | Yes | The OBJID of the time log to modify
creation_time | No | When is the log modified? If left blank, it will be modified at the current time
perf_by | No | The user who modified the time log. If left blank, the current user performs the modify
notes | No | The updated notes for the onsite log
user_name | No | The user who is recording the modification of the time log. If left blank, the current user records the modify
time_type | No | Value from the TIME_TYPE code list
start_time | No | When does the time log start? If you want to leave the original time, leave this field empty
duration | No | How long (in seconds) is the appointment?
billable | No | Indicates if this time is billable
bill_to | No | Indicates who this time log will be billed to, from the BILL_TO_TIME list in Policies and Customers
wrk_center | No | Value from the WORK_CENTER list where the time was spent
resolution | No | Value from the RESOLUTION_CODE list

Returns

Value | Meaning
0 | No errors
-1 | Could not find specified TIME_TYPE
-2 | Could not find specified BILL_TO_TIME
-3 | Cannot find specified user in database
-4 | Cannot find employee record for specified user in database
-5 | Cannot find performing user in database
-6 | Could not find case or subcase for time log record
-7 | Could not find specified WORK_CENTER
-8 | Could not find specified RESOLUTION_CODE
-9 | Could not find the specified time log record
-10 | Cannot find employee record for performing user in database
-11 | Cannot find the 'T & E Log' activity string with rank = 8700

Examples

Update an existing appointment. Set all the data that you can set. Change the start time and set the end time with the original end time from the appointment by using "-1".

Visual Basic:

Dim ret_int As Integer

ret_int = fcfo.modify_svc_inter(268435465, "A new description",
      "12/1/98 16:00:00", "-1", 600, _
      "Appt type", "Appt subtype", "sa", "9/9/98")

JavaScript:

var ret_int = fcfo.modify_svc_inter(268435465, "A new description",
      "12/1/98 16:00:00", "-1", 600,
      "Appt type", "Appt subtype", "sa", "9/9/98");

Simply append to the description for an appointment.

Visual Basic:

Dim ret_int As Integer

ret_int = fcfo.modify_svc_inter(268435465, "+for api", "", "", 0, _
                                 "-1", "-1", "", "")

JavaScript:

var ret_int = fcfo.modify_svc_inter(268435465, "+for api", "", "", 0,
                                 "-1", "-1", "", "");


Namespace FChoice.Common | fcSDK Documentation

Namespace FChoice.Common

Classes

CommonException

ConfigValues

DataProtector

FCArgumentException

FCConfiguration

FCExceptionBase

FCInvalidConfigurationException

FCLicenseException

InvalidLoggingConfigException

Logger

LogManager

PerfManager

StringUtil

Interfaces

IErrorMessageProvider

Enums

DataProtectionStore

FCLicenseException.LoadFailReasons

LogLevel

Back to top © 2022 Dovetail Software, Inc. - All rights reserved.
Clarify, Amdocs, and related products and names are copyright and trademark of Amdocs, Inc.
.NET, Visual Studio.NET, C#, Visual Basic and related products are trademark of Microsoft corporation.


Class CommonException | fcSDK Documentation

Class CommonException

Inheritance
System.Object
System.Exception
System.ApplicationException
FCExceptionBase
CommonException
FCArgumentException
Implements
System.Runtime.InteropServices._Exception
System.Runtime.Serialization.ISerializable
Inherited Members
FCExceptionBase.SetMessageProvider(IErrorMessageProvider)
FCExceptionBase.GetResourceData()
FCExceptionBase.GetErrorMessageFormat(Object, String)
FCExceptionBase.FormatMessage(String, String, Object[])
FCExceptionBase.LoadErrorResourceSet(String)
FCExceptionBase.GetObjectData(SerializationInfo, StreamingContext)
FCExceptionBase.MessageProvider
FCExceptionBase.ErrorCode
FCExceptionBase.ErrorMessageID
FCExceptionBase.Message
System.Exception.GetBaseException()
System.Exception.ToString()
System.Exception.GetType()
System.Exception.Data
System.Exception.InnerException
System.Exception.TargetSite
System.Exception.StackTrace
System.Exception.HelpLink
System.Exception.Source
System.Exception.HResult
System.Exception.SerializeObjectState
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.MemberwiseClone()
Namespace: FChoice.Common
Assembly: FChoice.Common.dll
Syntax
public class CommonException : FCExceptionBase, _Exception, ISerializable

Constructors

CommonException(Exception, Int32, String, Object[])

Declaration
protected CommonException(Exception innerEx, int errorId, string messageId, params object[] args)
Parameters
Type | Name | Description
System.Exception | innerEx |
System.Int32 | errorId |
System.String | messageId |
System.Object[] | args |

CommonException(Int32, String, Object[])

Declaration
protected CommonException(int errorId, string messageId, params object[] args)
Parameters
Type | Name | Description
System.Int32 | errorId |
System.String | messageId |
System.Object[] | args |

CommonException(SerializationInfo, StreamingContext)

Declaration
protected CommonException(SerializationInfo info, StreamingContext context)
Parameters
Type | Name | Description
System.Runtime.Serialization.SerializationInfo | info |
System.Runtime.Serialization.StreamingContext | context |

Methods

Assert(Int32, Boolean, String)

Declaration
public static void Assert(int errorId, bool assertionResult, string reason)
Parameters
Type | Name | Description
System.Int32 | errorId |
System.Boolean | assertionResult |
System.String | reason |

Implements

System.Runtime.InteropServices._Exception
System.Runtime.Serialization.ISerializable


Class ConfigValues | fcSDK Documentation

Class ConfigValues

Inheritance
System.Object
ConfigValues
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Common
Assembly: FChoice.Common.dll
Syntax
public static class ConfigValues

Fields

CACHE_FILE_PATH

Declaration
public static readonly string CACHE_FILE_PATH
Field Value
Type | Description
System.String |

CONNECT_STRING

Declaration
public static readonly string CONNECT_STRING
Field Value
Type | Description
System.String |

DB_TYPE

Declaration
public static readonly string DB_TYPE
Field Value
Type | Description
System.String |

DBPROVIDER_CONFIGFILE

Declaration
public static readonly string DBPROVIDER_CONFIGFILE
Field Value
Type | Description
System.String |

ENABLE_BATCH

Declaration
public static readonly string ENABLE_BATCH
Field Value
Type | Description
System.String |

LOG_CONFIG_FILE_PATH

Declaration
public static readonly string LOG_CONFIG_FILE_PATH
Field Value
Type | Description
System.String |

NO_CACHE_FILE

Declaration
public static readonly string NO_CACHE_FILE
Field Value
Type | Description
System.String |

PERF_ENABLED

Declaration
public static readonly string PERF_ENABLED
Field Value
Type | Description
System.String |

PERF_INSTANCE_NAME

Declaration
public static readonly string PERF_INSTANCE_NAME
Field Value
Type | Description
System.String |

SQL_BIG_QUERY_COUNT_THRESHOLD

Declaration
public static readonly string SQL_BIG_QUERY_COUNT_THRESHOLD
Field Value
Type | Description
System.String |

SQL_BIG_QUERY_TIME_THRESHOLD

Declaration
public static readonly string SQL_BIG_QUERY_TIME_THRESHOLD
Field Value
Type | Description
System.String |

SQL_COMMAND_TIMEOUT

Declaration
public static readonly string SQL_COMMAND_TIMEOUT
Field Value
Type | Description
System.String |

STATEMANAGER_CONFIGFILE

Declaration
public static readonly string STATEMANAGER_CONFIGFILE
Field Value
Type | Description
System.String |

Methods

GetConditionalString(Boolean, String, String, NameValueCollection)

Declaration
public static string GetConditionalString(bool isRequired, string defaultVal, string keyName, NameValueCollection settingsCol)
Parameters
Type | Name | Description
System.Boolean | isRequired |
System.String | defaultVal |
System.String | keyName |
System.Collections.Specialized.NameValueCollection | settingsCol |
Returns
Type | Description
System.String |

GetConditionalString(Boolean, String, String, String)

Declaration
public static string GetConditionalString(bool isRequired, string defaultVal, string val, string keyName)
Parameters
Type | Name | Description
System.Boolean | isRequired |
System.String | defaultVal |
System.String | val |
System.String | keyName |
Returns
Type | Description
System.String |

GetOptBool(Boolean, String)

Declaration
public static bool GetOptBool(bool defaultVal, string val)
Parameters
Type | Name | Description
System.Boolean | defaultVal |
System.String | val |
Returns
Type | Description
System.Boolean |

GetOptBool(Boolean, String, NameValueCollection)

Declaration
public static bool GetOptBool(bool defaultVal, string keyName, NameValueCollection settingsCol)
Parameters
Type | Name | Description
System.Boolean | defaultVal |
System.String | keyName |
System.Collections.Specialized.NameValueCollection | settingsCol |
Returns
Type | Description
System.Boolean |

GetOptInt32(Int32, String, NameValueCollection)

Declaration
public static int GetOptInt32(int defaultVal, string keyName, NameValueCollection settingsCol)
Parameters
Type | Name | Description
System.Int32 | defaultVal |
System.String | keyName |
System.Collections.Specialized.NameValueCollection | settingsCol |
Returns
Type | Description
System.Int32 |

GetOptInt32(Int32, String, String)

Declaration
public static int GetOptInt32(int defaultVal, string val, string keyName)
Parameters
Type | Name | Description
System.Int32 | defaultVal |
System.String | val |
System.String | keyName |
Returns
Type | Description
System.Int32 |

GetOptString(String, String)

Declaration
public static string GetOptString(string defaultVal, string val)
Parameters
Type | Name | Description
System.String | defaultVal |
System.String | val |
Returns
Type | Description
System.String |

GetOptString(String, String, NameValueCollection)

Declaration
public static string GetOptString(string defaultVal, string keyName, NameValueCollection settingsCol)
Parameters
Type | Name | Description
System.String | defaultVal |
System.String | keyName |
System.Collections.Specialized.NameValueCollection | settingsCol |
Returns
Type | Description
System.String |

GetReqString(String, NameValueCollection)

Declaration
public static string GetReqString(string keyName, NameValueCollection settingsCol)
Parameters
Type | Name | Description
System.String | keyName |
System.Collections.Specialized.NameValueCollection | settingsCol |
Returns
Type | Description
System.String |

GetReqString(String, String)

Declaration
public static string GetReqString(string val, string keyName)
Parameters
Type | Name | Description
System.String | val |
System.String | keyName |
Returns
Type | Description
System.String |

VerifyPositive(Object, String)

Declaration
public static void VerifyPositive(object value, string keyName)
Parameters
Type | Name | Description
System.Object | value |
System.String | keyName |


Namespace FChoice.Common.Data | fcSDK Documentation

Namespace FChoice.Common.Data

Classes

DataAccessSectionHandler

DataParameterCollection

DataSetSurrogate

DbProvider

DbProviderFactory

FCTypes

ODPOracleProvider

OleDbDataProviderBase

OracleProvider

OracleProviderBase

SqlHelper

TypeMapper

UpdateQueryBatch

Interfaces

IDbExtension

Back to top © 2022 Dovetail Software, Inc. - All rights reserved.
Clarify, Amdocs, and related products and names are copyright and trademark of Amdocs, Inc.
.NET, Visual Studio.NET, C#, Visual Basic and related products are trademark of Microsoft corporation.


Class DataAccessSectionHandler | fcSDK Documentation

Class DataAccessSectionHandler

Inheritance
System.Object
DataAccessSectionHandler
Implements
System.Configuration.IConfigurationSectionHandler
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Common.Data
Assembly: FChoice.Common.dll
Syntax
public class DataAccessSectionHandler : IConfigurationSectionHandler

Constructors

DataAccessSectionHandler()

Declaration
public DataAccessSectionHandler()

Methods

Create(Object, Object, XmlNode)

Declaration
public object Create(object parent, object configContext, XmlNode section)
Parameters
Type | Name | Description
System.Object | parent |
System.Object | configContext |
System.Xml.XmlNode | section |
Returns
Type | Description
System.Object |

Implements

System.Configuration.IConfigurationSectionHandler


Class DataParameterCollection | fcSDK Documentation

Class DataParameterCollection

Inheritance
System.Object
DataParameterCollection
Implements
System.Collections.IList
System.Collections.ICollection
System.Collections.IEnumerable
System.ICloneable
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Common.Data
Assembly: FChoice.Common.dll
Syntax
public class DataParameterCollection : IList, ICollection, IEnumerable, ICloneable

Constructors

DataParameterCollection()

Declaration
public DataParameterCollection()

DataParameterCollection(DbProvider)

Declaration
public DataParameterCollection(DbProvider accessProvider)
Parameters
Type | Name | Description
DbProvider | accessProvider |

DataParameterCollection(IDbDataParameter[])

Declaration
public DataParameterCollection(IDbDataParameter[] parameters)
Parameters
Type | Name | Description
System.Data.IDbDataParameter[] | parameters |

DataParameterCollection(Int32)

Declaration
public DataParameterCollection(int capacity)
Parameters
Type | Name | Description
System.Int32 | capacity |

Properties

Count

Declaration
public int Count { get; }
Property Value
Type | Description
System.Int32 |

IsFixedSize

Declaration
public bool IsFixedSize { get; }
Property Value
Type | Description
System.Boolean |

IsReadOnly

Declaration
public bool IsReadOnly { get; }
Property Value
Type | Description
System.Boolean |

IsSynchronized

Declaration
public bool IsSynchronized { get; }
Property Value
Type | Description
System.Boolean |

Item[Int32]

Declaration
public IDbDataParameter this[int index] { get; set; }
Parameters
Type | Name | Description
System.Int32 | index |
Property Value
Type | Description
System.Data.IDbDataParameter |

Item[String]

Declaration
public IDbDataParameter this[string name] { get; }
Parameters
Type | Name | Description
System.String | name |
Property Value
Type | Description
System.Data.IDbDataParameter |

Parameters

Declaration
public ICollection Parameters { get; }
Property Value
Type | Description
System.Collections.ICollection |

SyncRoot

Declaration
public object SyncRoot { get; }
Property Value
Type | Description
System.Object |

Methods

Add(String, IDbDataParameter)

Declaration
public int Add(string name, IDbDataParameter param)
Parameters
Type | Name | Description
System.String | name |
System.Data.IDbDataParameter | param |
Returns
Type | Description
System.Int32 |

Add(String, Object)

Declaration
public int Add(string name, object value)
Parameters
Type | Name | Description
System.String | name |
System.Object | value |
Returns
Type | Description
System.Int32 |

Add(String, Object, IDbDataParameter)

Declaration
public int Add(string name, object value, IDbDataParameter parameterTemplate)
Parameters
Type | Name | Description
System.String | name |
System.Object | value |
System.Data.IDbDataParameter | parameterTemplate |
Returns
Type | Description
System.Int32 |

Add(String, Object, ParameterDirection)

Declaration
public int Add(string name, object value, ParameterDirection direction)
Parameters
Type | Name | Description
System.String | name |
System.Object | value |
System.Data.ParameterDirection | direction |
Returns
Type | Description
System.Int32 |

Clear()

Declaration
public void Clear()

Clone()

Declaration
public DataParameterCollection Clone()
Returns
Type | Description
DataParameterCollection |

Contains(Object)

Declaration
public bool Contains(object value)
Parameters
Type | Name | Description
System.Object | value |
Returns
Type | Description
System.Boolean |

CopyTo(DataParameterCollection)

Declaration
public void CopyTo(DataParameterCollection otherCol)
Parameters
Type | Name | Description
DataParameterCollection | otherCol |

CopyTo(Array, Int32)

Declaration
public void CopyTo(Array array, int index)
Parameters
Type | Name | Description
System.Array | array |
System.Int32 | index |

DeepClone()

Declaration
public DataParameterCollection DeepClone()
Returns
Type | Description
DataParameterCollection |

GetEnumerator()

Declaration
public IEnumerator GetEnumerator()
Returns
Type | Description
System.Collections.IEnumerator |

IndexOf(Object)

Declaration
public int IndexOf(object value)
Parameters
Type | Name | Description
System.Object | value |
Returns
Type | Description
System.Int32 |

Insert(Int32, Object)

Declaration
public void Insert(int index, object value)
Parameters
Type | Name | Description
System.Int32 | index |
System.Object | value |

Remove(IDbDataParameter)

Declaration
public void Remove(IDbDataParameter param)
Parameters
Type | Name | Description
System.Data.IDbDataParameter | param |

Remove(Object)

Declaration
public void Remove(object value)
Parameters
Type | Name | Description
System.Object | value |

Remove(String)

Declaration
public void Remove(string name)
Parameters
Type | Name | Description
System.String | name |

RemoveAt(Int32)

Declaration
public void RemoveAt(int index)
Parameters
Type | Name | Description
System.Int32 | index |

Explicit Interface Implementations

IList.Add(Object)

Declaration
int IList.Add(object value)
Parameters
Type | Name | Description
System.Object | value |
Returns
Type | Description
System.Int32 |

IList.get_Item(Int32)

Declaration
object IList.get_Item(int index)
Parameters
Type | Name | Description
System.Int32 | index |
Returns
Type | Description
System.Object |

IList.Item[Int32]

Declaration
object IList.this[] { get; set; }
Parameters
Type | Name | Description
System.Int32 | index |
Returns
Type | Description
System.Object |

IList.set_Item(Int32, Object)

Declaration
void IList.set_Item(int index, object value)
Parameters
Type | Name | Description
System.Int32 | index |
System.Object | value |

ICloneable.Clone()

Declaration
object ICloneable.Clone()
Returns
Type | Description
System.Object |

Implements

System.Collections.IList
System.Collections.ICollection
System.Collections.IEnumerable
System.ICloneable


Class DataSetSurrogate | fcSDK Documentation

Class DataSetSurrogate

Inheritance
System.Object
DataSetSurrogate
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Common.Data
Assembly: FChoice.Common.dll
Syntax
public class DataSetSurrogate

Methods

ReadBinary(Stream)

Declaration
public static DataSet ReadBinary(Stream str)
Parameters
Type | Name | Description
System.IO.Stream | str |
Returns
Type | Description
System.Data.DataSet |

WriteBinary(DataSet, Stream)

Declaration
public static void WriteBinary(DataSet ds, Stream str)
Parameters
Type | Name | Description
System.Data.DataSet | ds |
System.IO.Stream | str |


Class DbProvider | fcSDK Documentation

Class DbProvider

Inheritance
System.Object
DbProvider
OleDbDataProviderBase
OracleProviderBase
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Common.Data
Assembly: FChoice.Common.dll
Syntax
public abstract class DbProvider

Constructors

DbProvider()

Declaration
protected DbProvider()

Properties

CanBatchQueries

Declaration
public virtual bool CanBatchQueries { get; }
Property Value
Type | Description
System.Boolean |

ConnectionString

Declaration
public virtual string ConnectionString { get; set; }
Property Value
Type | Description
System.String |

MaxInListItems

Declaration
public abstract int MaxInListItems { get; }
Property Value
Type | Description
System.Int32 |

ProviderCanBatchQueries

Declaration
protected abstract bool ProviderCanBatchQueries { get; }
Property Value
Type | Description
System.Boolean |

ProviderName

Declaration
public abstract string ProviderName { get; }
Property Value
Type | Description
System.String |

RequiresDbNameParameter

Declaration
public abstract bool RequiresDbNameParameter { get; }
Property Value
Type | Description
System.Boolean |

TypeMapper

Declaration
public abstract TypeMapper TypeMapper { get; }
Property Value
Type | Description
TypeMapper |

Methods

ConstructConnectionString(NameValueCollection)

Declaration
public static string ConstructConnectionString(NameValueCollection keyValues)
Parameters
Type | Name | Description
System.Collections.Specialized.NameValueCollection | keyValues |
Returns
Type | Description
System.String |

CreateCommand(IDbConnection)

Declaration
public virtual IDbCommand CreateCommand(IDbConnection dbConnection)
Parameters
Type | Name | Description
System.Data.IDbConnection | dbConnection |
Returns
Type | Description
System.Data.IDbCommand |

CreateConnectionString(String, String, String, String, String)

Declaration
public abstract string CreateConnectionString(string dbServer, string dbName, string dbUser, string dbPass, string extraParams)
Parameters
Type | Name | Description
System.String | dbServer |
System.String | dbName |
System.String | dbUser |
System.String | dbPass |
System.String | extraParams |
Returns
Type | Description
System.String |

CreateParameter(String, Object)

Declaration
public abstract IDbDataParameter CreateParameter(string name, object value)
Parameters
Type | Name | Description
System.String | name |
System.Object | value |
Returns
Type | Description
System.Data.IDbDataParameter |

FormatDateLiteral(DateTime)

Declaration
public abstract string FormatDateLiteral(DateTime value)
Parameters
Type | Name | Description
System.DateTime | value |
Returns
Type | Description
System.String |

GetAdapter()

Declaration
public abstract DbDataAdapter GetAdapter()
Returns
Type | Description
System.Data.Common.DbDataAdapter |

GetAdapter(IDbConnection)

Declaration
public abstract DbDataAdapter GetAdapter(IDbConnection conn)
Parameters
Type | Name | Description
System.Data.IDbConnection | conn |
Returns
Type | Description
System.Data.Common.DbDataAdapter |

GetAdapter(IDbConnection, String)

Declaration
public abstract DbDataAdapter GetAdapter(IDbConnection conn, string sqlStmt)
Parameters
Type | Name | Description
System.Data.IDbConnection | conn |
System.String | sqlStmt |
Returns
Type | Description
System.Data.Common.DbDataAdapter |

GetAsStatement(String)

Declaration
public abstract string GetAsStatement(string name)
Parameters
Type | Name | Description
System.String | name |
Returns
Type | Description
System.String |

GetBitwiseAndStatement(Object, Object)

Declaration
public abstract string GetBitwiseAndStatement(object operand1, object operand2)
Parameters
Type | Name | Description
System.Object | operand1 |
System.Object | operand2 |
Returns
Type | Description
System.String |

GetConnection()

Declaration
public abstract IDbConnection GetConnection()
Returns
Type | Description
System.Data.IDbConnection |

GetConnection(String)

Declaration
public abstract IDbConnection GetConnection(string conStr)
Parameters
Type | Name | Description
System.String | conStr |
Returns
Type | Description
System.Data.IDbConnection |

GetDateStatement()

Declaration
public abstract string GetDateStatement()
Returns
Type | Description
System.String |

GetDBDate()

Declaration
public abstract DateTime GetDBDate()
Returns
Type | Description
System.DateTime |

GetDbVersion()

Declaration
public Version GetDbVersion()
Returns
Type | Description
System.Version |

GetDbVersion(Boolean)

Declaration
public Version GetDbVersion(bool force)
Parameters
Type | Name | Description
System.Boolean | force |
Returns
Type | Description
System.Version |

GetParameterNamePrefix()

Declaration
public abstract string GetParameterNamePrefix()
Returns
Type | Description
System.String |

GetVersionFromString(String)

Declaration
protected Version GetVersionFromString(string versionStr)
Parameters
Type | Name | Description
System.String | versionStr |
Returns
Type | Description
System.Version |

Initialize()

Declaration
protected abstract void Initialize()

Load(XmlNodeList)

Declaration
protected abstract void Load(XmlNodeList configArguments)
Parameters
Type | Name | Description
System.Xml.XmlNodeList | configArguments |

ParseConnectionString(String)

Declaration
public static NameValueCollection ParseConnectionString(string connectStr)
Parameters
Type | Name | Description
System.String | connectStr |
Returns
Type | Description
System.Collections.Specialized.NameValueCollection |

PerformGetDbVersion()

Declaration
protected abstract Version PerformGetDbVersion()
Returns
Type | Description
System.Version |

PrepareParameter(IDbDataParameter, CommandType)

Declaration
public virtual void PrepareParameter(IDbDataParameter param, CommandType cmdType)
Parameters
Type | Name | Description
System.Data.IDbDataParameter | param |
System.Data.CommandType | cmdType |

PrepareSQLStatement(String, CommandType, DataParameterCollection)

Declaration
public abstract string PrepareSQLStatement(string sqlStmt, CommandType cmdType, DataParameterCollection commandParams)
Parameters
Type | Name | Description
System.String | sqlStmt |
System.Data.CommandType | cmdType |
DataParameterCollection | commandParams |
Returns
Type | Description
System.String |

RemoveParameterNamePrefix(String)

Declaration
public abstract string RemoveParameterNamePrefix(string name)
Parameters
Type | Name | Description
System.String | name |
Returns
Type | Description
System.String |

SetDatabaseParameterTypeForClobText(IDbDataParameter, Boolean)

Declaration
public virtual void SetDatabaseParameterTypeForClobText(IDbDataParameter dbParameter, bool isParameterUnicode)
Parameters
Type | Name | Description
System.Data.IDbDataParameter | dbParameter |
System.Boolean | isParameterUnicode |

TestConnection()

Declaration
public bool TestConnection()
Returns
Type | Description
System.Boolean |

TestConnection(out Exception)

Declaration
public bool TestConnection(out Exception outEx)
Parameters
Type | Name | Description
System.Exception | outEx |
Returns
Type | Description
System.Boolean |

ValidateConnectionParams(String, String, String, String)

Declaration
public abstract bool ValidateConnectionParams(string dbServer, string dbName, string dbUser, string dbPass)
Parameters
Type | Name | Description
System.String | dbServer |
System.String | dbName |
System.String | dbUser |
System.String | dbPass |
Returns
Type | Description
System.Boolean |


Class DbProviderFactory | fcSDK Documentation

Class DbProviderFactory

Inheritance
System.Object
DbProviderFactory
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Common.Data
Assembly: FChoice.Common.dll
Syntax
public sealed class DbProviderFactory

Fields

CONFIGURATION_SECTION_NAME

Declaration
public const string CONFIGURATION_SECTION_NAME = "dataAccess"
Field Value
Type | Description
System.String |

MSSQL_PROVIDER_NAME

Declaration
public const string MSSQL_PROVIDER_NAME = "MSSQL"
Field Value
Type | Description
System.String |

ODPNET_PROVIDER_NAME

Declaration
public const string ODPNET_PROVIDER_NAME = "ODPNET"
Field Value
Type | Description
System.String |

ORACLE_PROVIDER_NAME

Declaration
public const string ORACLE_PROVIDER_NAME = "ORACLE"
Field Value
Type | Description
System.String |

Properties

Provider

Declaration
public static DbProvider Provider { get; set; }
Property Value
Type | Description
DbProvider |

ProviderNames

Declaration
public static string[] ProviderNames { get; }
Property Value
Type | Description
System.String[] |

Methods

ConfigureProviders()

Declaration
public static void ConfigureProviders()

ConfigureProviders(String)

Declaration
public static void ConfigureProviders(string configFilePath)
Parameters
Type | Name | Description
System.String | configFilePath |

ConfigureProviders(XmlElement)

Declaration
public static void ConfigureProviders(XmlElement parentElm)
Parameters
Type | Name | Description
System.Xml.XmlElement | parentElm |

CreateProvider()

Declaration
public static DbProvider CreateProvider()
Returns
Type | Description
DbProvider |

CreateProvider(String)

Declaration
public static DbProvider CreateProvider(string providerAlias)
Parameters
Type | Name | Description
System.String | providerAlias |
Returns
Type | Description
DbProvider |

IsOracle()

Declaration
public static bool IsOracle()
Returns
Type | Description
System.Boolean |

IsValidProvider(String)

Declaration
public bool IsValidProvider(string providerName)
Parameters
Type | Name | Description
System.String | providerName |
Returns
Type | Description
System.Boolean |


Class FCTypes | fcSDK Documentation

Class FCTypes

Inheritance
System.Object
FCTypes
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Common.Data
Assembly: FChoice.Common.dll
Syntax
public sealed class FCTypes

Fields

Date

Declaration
public const string Date = "date"
Field Value
Type | Description
System.String |

DateNumber

Declaration
public const int DateNumber = 7
Field Value
Type | Description
System.Int32 |

Decimal

Declaration
public const string Decimal = "decimal"
Field Value
Type | Description
System.String |

DecimalNumber

Declaration
public const int DecimalNumber = 8
Field Value
Type | Description
System.Int32 |

Float

Declaration
public const string Float = "float"
Field Value
Type | Description
System.String |

FloatNumber

Declaration
public const int FloatNumber = 9
Field Value
Type | Description
System.Int32 |

Guid

Declaration
public const string Guid = "guid"
Field Value
Type | Description
System.String |

GuidNumber

Declaration
public const int GuidNumber = 10
Field Value
Type | Description
System.Int32 |

LongInt

Declaration
public const string LongInt = "longint"
Field Value
Type | Description
System.String |

LongIntNumber

Declaration
public const int LongIntNumber = 5
Field Value
Type | Description
System.Int32 |

NText

Declaration
public const string NText = "ntext"
Field Value
Type | Description
System.String |

NTextNumber

Declaration
public const int NTextNumber = 4
Field Value
Type | Description
System.Int32 |

NVarchar

Declaration
public const string NVarchar = "nvarchar"
Field Value
Type | Description
System.String |

NVarcharNumber

Declaration
public const int NVarcharNumber = 2
Field Value
Type | Description
System.Int32 |

Text

Declaration
public const string Text = "text"
Field Value
Type | Description
System.String |

TextNumber

Declaration
public const int TextNumber = 3
Field Value
Type | Description
System.Int32 |

TinyInt

Declaration
public const string TinyInt = "tinyint"
Field Value
Type | Description
System.String |

TinyIntNumber

Declaration
public const int TinyIntNumber = 6
Field Value
Type | Description
System.Int32 |

Varchar

Declaration
public const string Varchar = "varchar"
Field Value
Type | Description
System.String |

VarcharNumber

Declaration
public const int VarcharNumber = 1
Field Value
Type | Description
System.Int32 |


Interface IDbExtension | fcSDK Documentation

Interface IDbExtension

Namespace: FChoice.Common.Data
Assembly: FChoice.Common.dll
Syntax
public interface IDbExtension

Methods

Initialize(DbProvider, XmlNode)

Declaration
void Initialize(DbProvider provider, XmlNode extensionConfig)
Parameters
Type | Name | Description
DbProvider | provider |
System.Xml.XmlNode | extensionConfig |


Class ODPOracleProvider | fcSDK Documentation

Class ODPOracleProvider

Inheritance
System.Object
DbProvider
OracleProviderBase
ODPOracleProvider
Inherited Members
OracleProviderBase.CONN_STR_FORMAT
OracleProviderBase.ORACLE_DATE_FORMAT
OracleProviderBase.ORACLE_OUTPUT_DATE_FORMAT
OracleProviderBase.PrepareParameter(IDbDataParameter, CommandType)
OracleProviderBase.GetBadConTypeException(String, String)
OracleProviderBase.Initialize()
OracleProviderBase.Load(XmlNodeList)
OracleProviderBase.GetBitwiseAndStatement(Object, Object)
OracleProviderBase.GetParameterNamePrefix()
OracleProviderBase.RemoveParameterNamePrefix(String)
OracleProviderBase.CreateConnectionString(String, String, String, String, String)
OracleProviderBase.ValidateConnectionParams(String, String, String, String)
OracleProviderBase.PrepareSQLStatement(String, CommandType, DataParameterCollection)
OracleProviderBase.GetDateStatement()
OracleProviderBase.GetAsStatement(String)
OracleProviderBase.GetDBDate()
OracleProviderBase.FormatDateLiteral(DateTime)
OracleProviderBase.PerformGetDbVersion()
OracleProviderBase.GetNlsFormat(OracleProviderBase)
OracleProviderBase.AreLargeTextFieldsClobs()
OracleProviderBase.RequiresDbNameParameter
OracleProviderBase.ProviderCanBatchQueries
OracleProviderBase.MaxInListItems
OracleProviderBase.TypeMapper
OracleProviderBase.ProviderName
DbProvider.TestConnection()
DbProvider.TestConnection(Exception)
DbProvider.GetDbVersion()
DbProvider.GetDbVersion(Boolean)
DbProvider.GetVersionFromString(String)
DbProvider.ParseConnectionString(String)
DbProvider.ConstructConnectionString(NameValueCollection)
DbProvider.CanBatchQueries
DbProvider.ConnectionString
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Common.Data
Assembly: FChoice.Common.dll
Syntax
public class ODPOracleProvider : OracleProviderBase

Constructors

ODPOracleProvider()

Declaration
public ODPOracleProvider()

Methods

CreateCommand(IDbConnection)

Declaration
public override IDbCommand CreateCommand(IDbConnection dbConnection)
Parameters
Type | Name | Description
System.Data.IDbConnection | dbConnection |
Returns
Type | Description
System.Data.IDbCommand |
Overrides
DbProvider.CreateCommand(IDbConnection)

CreateParameter(String, Object)

Declaration
public override IDbDataParameter CreateParameter(string name, object value)
Parameters
Type | Name | Description
System.String | name |
System.Object | value |
Returns
Type | Description
System.Data.IDbDataParameter |
Overrides
OracleProviderBase.CreateParameter(String, Object)

GetAdapter()

Declaration
public override DbDataAdapter GetAdapter()
Returns
Type | Description
System.Data.Common.DbDataAdapter |
Overrides
OracleProviderBase.GetAdapter()

GetAdapter(IDbConnection)

Declaration
public override DbDataAdapter GetAdapter(IDbConnection conn)
Parameters
Type | Name | Description
System.Data.IDbConnection | conn |
Returns
Type | Description
System.Data.Common.DbDataAdapter |
Overrides
OracleProviderBase.GetAdapter(IDbConnection)

GetAdapter(IDbConnection, String)

Declaration
public override DbDataAdapter GetAdapter(IDbConnection conn, string sqlStmt)
Parameters
Type | Name | Description
System.Data.IDbConnection | conn |
System.String | sqlStmt |
Returns
Type | Description
System.Data.Common.DbDataAdapter |
Overrides
OracleProviderBase.GetAdapter(IDbConnection, String)

GetConnection()

Declaration
public override IDbConnection GetConnection()
Returns
Type | Description
System.Data.IDbConnection |
Overrides
OracleProviderBase.GetConnection()

GetConnection(String)

Declaration
public override IDbConnection GetConnection(string newConStr)
Parameters
Type | Name | Description
System.String | newConStr |
Returns
Type | Description
System.Data.IDbConnection |
Overrides
OracleProviderBase.GetConnection(String)

SetDatabaseParameterTypeForClobText(IDbDataParameter, Boolean)

Declaration
public override void SetDatabaseParameterTypeForClobText(IDbDataParameter dbParameter, bool isParameterUnicode)
Parameters
Type | Name | Description
System.Data.IDbDataParameter | dbParameter |
System.Boolean | isParameterUnicode |
Overrides
DbProvider.SetDatabaseParameterTypeForClobText(IDbDataParameter, Boolean)


Class OleDbDataProviderBase | fcSDK Documentation

Class OleDbDataProviderBase

Inheritance
System.Object
DbProvider
OleDbDataProviderBase
Inherited Members
DbProvider.Load(XmlNodeList)
DbProvider.Initialize()
DbProvider.GetDateStatement()
DbProvider.GetAsStatement(String)
DbProvider.GetDBDate()
DbProvider.FormatDateLiteral(DateTime)
DbProvider.PerformGetDbVersion()
DbProvider.SetDatabaseParameterTypeForClobText(IDbDataParameter, Boolean)
DbProvider.CreateCommand(IDbConnection)
DbProvider.PrepareParameter(IDbDataParameter, CommandType)
DbProvider.TestConnection()
DbProvider.TestConnection(Exception)
DbProvider.GetDbVersion()
DbProvider.GetDbVersion(Boolean)
DbProvider.GetVersionFromString(String)
DbProvider.ParseConnectionString(String)
DbProvider.ConstructConnectionString(NameValueCollection)
DbProvider.ProviderCanBatchQueries
DbProvider.TypeMapper
DbProvider.ProviderName
DbProvider.MaxInListItems
DbProvider.RequiresDbNameParameter
DbProvider.CanBatchQueries
DbProvider.ConnectionString
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Common.Data
Assembly: FChoice.Common.dll
Syntax
public abstract class OleDbDataProviderBase : DbProvider

Constructors

OleDbDataProviderBase()

Declaration
protected OleDbDataProviderBase()

Properties

OleDbProviderName

Declaration
protected string OleDbProviderName { get; set; }
Property Value
Type | Description
System.String |

Methods

CreateConnectionString(String, String, String, String, String)

Declaration
public override string CreateConnectionString(string dbServer, string dbName, string dbUser, string dbPass, string extraParams)
Parameters
Type | Name | Description
System.String | dbServer |
System.String | dbName |
System.String | dbUser |
System.String | dbPass |
System.String | extraParams |
Returns
Type | Description
System.String |
Overrides
DbProvider.CreateConnectionString(String, String, String, String, String)

CreateParameter(String, Object)

Declaration
public override IDbDataParameter CreateParameter(string name, object value)
Parameters
Type | Name | Description
System.String | name |
System.Object | value |
Returns
Type | Description
System.Data.IDbDataParameter |
Overrides
DbProvider.CreateParameter(String, Object)

GetAdapter()

Declaration
public override DbDataAdapter GetAdapter()
Returns
Type | Description
System.Data.Common.DbDataAdapter |
Overrides
DbProvider.GetAdapter()

GetAdapter(IDbConnection)

Declaration
public override DbDataAdapter GetAdapter(IDbConnection conn)
Parameters
Type | Name | Description
System.Data.IDbConnection | conn |
Returns
Type | Description
System.Data.Common.DbDataAdapter |
Overrides
DbProvider.GetAdapter(IDbConnection)

GetAdapter(IDbConnection, String)

Declaration
public override DbDataAdapter GetAdapter(IDbConnection conn, string sqlStmt)
Parameters
Type | Name | Description
System.Data.IDbConnection | conn |
System.String | sqlStmt |
Returns
Type | Description
System.Data.Common.DbDataAdapter |
Overrides
DbProvider.GetAdapter(IDbConnection, String)

GetBitwiseAndStatement(Object, Object)

Declaration
public override string GetBitwiseAndStatement(object operand1, object operand2)
Parameters
Type | Name | Description
System.Object | operand1 |
System.Object | operand2 |
Returns
Type | Description
System.String |
Overrides
DbProvider.GetBitwiseAndStatement(Object, Object)

GetConnection()

Declaration
public override IDbConnection GetConnection()
Returns
Type | Description
System.Data.IDbConnection |
Overrides
DbProvider.GetConnection()

GetConnection(String)

Declaration
public override IDbConnection GetConnection(string newConStr)
Parameters
Type | Name | Description
System.String | newConStr |
Returns
Type | Description
System.Data.IDbConnection |
Overrides
DbProvider.GetConnection(String)

GetParameterNamePrefix()

Declaration
public override string GetParameterNamePrefix()
Returns
Type | Description
System.String |
Overrides
DbProvider.GetParameterNamePrefix()

PrepareSQLStatement(String, CommandType, DataParameterCollection)

Declaration
public override string PrepareSQLStatement(string sqlStmt, CommandType cmdType, DataParameterCollection commandParams)
Parameters
Type | Name | Description
System.String | sqlStmt |
System.Data.CommandType | cmdType |
DataParameterCollection | commandParams |
Returns
Type | Description
System.String |
Overrides
DbProvider.PrepareSQLStatement(String, CommandType, DataParameterCollection)

RemoveParameterNamePrefix(String)

Declaration
public override string RemoveParameterNamePrefix(string name)
Parameters
Type | Name | Description
System.String | name |
Returns
Type | Description
System.String |
Overrides
DbProvider.RemoveParameterNamePrefix(String)

ValidateConnectionParams(String, String, String, String)

Declaration
public override bool ValidateConnectionParams(string dbServer, string dbName, string dbUser, string dbPass)
Parameters
Type | Name | Description
System.String | dbServer |
System.String | dbName |
System.String | dbUser |
System.String | dbPass |
Returns
Type | Description
System.Boolean |
Overrides
DbProvider.ValidateConnectionParams(String, String, String, String)


Class OracleProvider | fcSDK Documentation

Class OracleProvider

Inheritance
System.Object
DbProvider
OracleProviderBase
OracleProvider
Inherited Members
OracleProviderBase.CONN_STR_FORMAT
OracleProviderBase.ORACLE_DATE_FORMAT
OracleProviderBase.ORACLE_OUTPUT_DATE_FORMAT
OracleProviderBase.PrepareParameter(IDbDataParameter, CommandType)
OracleProviderBase.GetBadConTypeException(String, String)
OracleProviderBase.Initialize()
OracleProviderBase.Load(XmlNodeList)
OracleProviderBase.GetBitwiseAndStatement(Object, Object)
OracleProviderBase.GetParameterNamePrefix()
OracleProviderBase.RemoveParameterNamePrefix(String)
OracleProviderBase.CreateParameter(String, Object)
OracleProviderBase.GetConnection()
OracleProviderBase.GetConnection(String)
OracleProviderBase.GetAdapter()
OracleProviderBase.GetAdapter(IDbConnection)
OracleProviderBase.GetAdapter(IDbConnection, String)
OracleProviderBase.CreateConnectionString(String, String, String, String, String)
OracleProviderBase.ValidateConnectionParams(String, String, String, String)
OracleProviderBase.PrepareSQLStatement(String, CommandType, DataParameterCollection)
OracleProviderBase.GetDateStatement()
OracleProviderBase.GetAsStatement(String)
OracleProviderBase.GetDBDate()
OracleProviderBase.FormatDateLiteral(DateTime)
OracleProviderBase.PerformGetDbVersion()
OracleProviderBase.GetNlsFormat(OracleProviderBase)
OracleProviderBase.AreLargeTextFieldsClobs()
OracleProviderBase.RequiresDbNameParameter
OracleProviderBase.ProviderCanBatchQueries
OracleProviderBase.MaxInListItems
OracleProviderBase.TypeMapper
OracleProviderBase.ProviderName
DbProvider.CreateCommand(IDbConnection)
DbProvider.TestConnection()
DbProvider.TestConnection(Exception)
DbProvider.GetDbVersion()
DbProvider.GetDbVersion(Boolean)
DbProvider.GetVersionFromString(String)
DbProvider.ParseConnectionString(String)
DbProvider.ConstructConnectionString(NameValueCollection)
DbProvider.CanBatchQueries
DbProvider.ConnectionString
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Common.Data
Assembly: FChoice.Common.dll
Syntax
public class OracleProvider : OracleProviderBase

Constructors

OracleProvider()

Declaration
public OracleProvider()

Methods

SetDatabaseParameterTypeForClobText(IDbDataParameter, Boolean)

Declaration
public override void SetDatabaseParameterTypeForClobText(IDbDataParameter dbParameter, bool isParameterUnicode)
Parameters
Type | Name | Description
System.Data.IDbDataParameter | dbParameter |
System.Boolean | isParameterUnicode |
Overrides
DbProvider.SetDatabaseParameterTypeForClobText(IDbDataParameter, Boolean)


Class OracleProviderBase | fcSDK Documentation

Class OracleProviderBase

Inheritance
System.Object
DbProvider
OracleProviderBase
ODPOracleProvider
OracleProvider
ODPOracleProvider
Inherited Members
DbProvider.SetDatabaseParameterTypeForClobText(IDbDataParameter, Boolean)
DbProvider.CreateCommand(IDbConnection)
DbProvider.TestConnection()
DbProvider.TestConnection(Exception)
DbProvider.GetDbVersion()
DbProvider.GetDbVersion(Boolean)
DbProvider.GetVersionFromString(String)
DbProvider.ParseConnectionString(String)
DbProvider.ConstructConnectionString(NameValueCollection)
DbProvider.CanBatchQueries
DbProvider.ConnectionString
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Common.Data
Assembly: FChoice.Common.dll
Syntax
public abstract class OracleProviderBase : DbProvider

Constructors

OracleProviderBase()

Declaration
protected OracleProviderBase()

Fields

CONN_STR_FORMAT

Declaration
protected const string CONN_STR_FORMAT = "Data Source={0};User Id={1};Password={2};{3}"
Field Value
Type | Description
System.String |

ORACLE_DATE_FORMAT

Declaration
protected const string ORACLE_DATE_FORMAT = "yyyy-MM-dd HH:mm:ss"
Field Value
Type | Description
System.String |

ORACLE_OUTPUT_DATE_FORMAT

Declaration
protected const string ORACLE_OUTPUT_DATE_FORMAT = "TO_DATE('{0}', 'yyyy-mm-dd hh24:mi:ss')"
Field Value
Type | Description
System.String |

Properties

MaxInListItems

Declaration
public override int MaxInListItems { get; }
Property Value
Type | Description
System.Int32 |
Overrides
DbProvider.MaxInListItems

ProviderCanBatchQueries

Declaration
protected override bool ProviderCanBatchQueries { get; }
Property Value
Type | Description
System.Boolean |
Overrides
DbProvider.ProviderCanBatchQueries

ProviderName

Declaration
public override string ProviderName { get; }
Property Value
Type | Description
System.String |
Overrides
DbProvider.ProviderName

RequiresDbNameParameter

Declaration
public override bool RequiresDbNameParameter { get; }
Property Value
Type | Description
System.Boolean |
Overrides
DbProvider.RequiresDbNameParameter

TypeMapper

Declaration
public override TypeMapper TypeMapper { get; }
Property Value
Type | Description
TypeMapper |
Overrides
DbProvider.TypeMapper

Methods

AreLargeTextFieldsClobs()

Declaration
public virtual bool AreLargeTextFieldsClobs()
Returns
Type | Description
System.Boolean |

CreateConnectionString(String, String, String, String, String)

Declaration
public override string CreateConnectionString(string dbServer, string dbName, string dbUser, string dbPass, string extraParams)
Parameters
Type | Name | Description
System.String | dbServer |
System.String | dbName |
System.String | dbUser |
System.String | dbPass |
System.String | extraParams |
Returns
Type | Description
System.String |
Overrides
DbProvider.CreateConnectionString(String, String, String, String, String)

CreateParameter(String, Object)

Declaration
public override IDbDataParameter CreateParameter(string name, object value)
Parameters
Type | Name | Description
System.String | name |
System.Object | value |
Returns
Type | Description
System.Data.IDbDataParameter |
Overrides
DbProvider.CreateParameter(String, Object)

FormatDateLiteral(DateTime)

Declaration
public override string FormatDateLiteral(DateTime value)
Parameters
Type | Name | Description
System.DateTime | value |
Returns
Type | Description
System.String |
Overrides
DbProvider.FormatDateLiteral(DateTime)

GetAdapter()

Declaration
public override DbDataAdapter GetAdapter()
Returns
Type | Description
System.Data.Common.DbDataAdapter |
Overrides
DbProvider.GetAdapter()

GetAdapter(IDbConnection)

Declaration
public override DbDataAdapter GetAdapter(IDbConnection conn)
Parameters
Type | Name | Description
System.Data.IDbConnection | conn |
Returns
Type | Description
System.Data.Common.DbDataAdapter |
Overrides
DbProvider.GetAdapter(IDbConnection)

GetAdapter(IDbConnection, String)

Declaration
public override DbDataAdapter GetAdapter(IDbConnection conn, string sqlStmt)
Parameters
Type | Name | Description
System.Data.IDbConnection | conn |
System.String | sqlStmt |
Returns
Type | Description
System.Data.Common.DbDataAdapter |
Overrides
DbProvider.GetAdapter(IDbConnection, String)

GetAsStatement(String)

Declaration
public override string GetAsStatement(string name)
Parameters
Type | Name | Description
System.String | name |
Returns
Type | Description
System.String |
Overrides
DbProvider.GetAsStatement(String)

GetBadConTypeException(String, String)

Declaration
protected static Exception GetBadConTypeException(string actualType, string expectedType)
Parameters
Type | Name | Description
System.String | actualType |
System.String | expectedType |
Returns
Type | Description
System.Exception |

GetBitwiseAndStatement(Object, Object)

Declaration
public override string GetBitwiseAndStatement(object operand1, object operand2)
Parameters
Type | Name | Description
System.Object | operand1 |
System.Object | operand2 |
Returns
Type | Description
System.String |
Overrides
DbProvider.GetBitwiseAndStatement(Object, Object)

GetConnection()

Declaration
public override IDbConnection GetConnection()
Returns
Type | Description
System.Data.IDbConnection |
Overrides
DbProvider.GetConnection()

GetConnection(String)

Declaration
public override IDbConnection GetConnection(string newConStr)
Parameters
Type | Name | Description
System.String | newConStr |
Returns
Type | Description
System.Data.IDbConnection |
Overrides
DbProvider.GetConnection(String)

GetDateStatement()

Declaration
public override string GetDateStatement()
Returns
Type | Description
System.String |
Overrides
DbProvider.GetDateStatement()

GetDBDate()

Declaration
public override DateTime GetDBDate()
Returns
Type | Description
System.DateTime |
Overrides
DbProvider.GetDBDate()

GetNlsFormat(OracleProviderBase)

Declaration
public static string GetNlsFormat(OracleProviderBase provider)
Parameters
Type | Name | Description
OracleProviderBase | provider |
Returns
Type | Description
System.String |

GetParameterNamePrefix()

Declaration
public override string GetParameterNamePrefix()
Returns
Type | Description
System.String |
Overrides
DbProvider.GetParameterNamePrefix()

Initialize()

Declaration
protected override void Initialize()
Overrides
DbProvider.Initialize()

Load(XmlNodeList)

Declaration
protected override void Load(XmlNodeList configArguments)
Parameters
Type | Name | Description
System.Xml.XmlNodeList | configArguments |
Overrides
DbProvider.Load(XmlNodeList)

PerformGetDbVersion()

Declaration
protected override Version PerformGetDbVersion()
Returns
Type | Description
System.Version |
Overrides
DbProvider.PerformGetDbVersion()

PrepareParameter(IDbDataParameter, CommandType)

Declaration
public override void PrepareParameter(IDbDataParameter param, CommandType cmdType)
Parameters
Type | Name | Description
System.Data.IDbDataParameter | param |
System.Data.CommandType | cmdType |
Overrides
DbProvider.PrepareParameter(IDbDataParameter, CommandType)

PrepareSQLStatement(String, CommandType, DataParameterCollection)

Declaration
public override string PrepareSQLStatement(string sqlStmt, CommandType cmdType, DataParameterCollection commandParams)
Parameters
Type | Name | Description
System.String | sqlStmt |
System.Data.CommandType | cmdType |
DataParameterCollection | commandParams |
Returns
Type | Description
System.String |
Overrides
DbProvider.PrepareSQLStatement(String, CommandType, DataParameterCollection)

RemoveParameterNamePrefix(String)

Declaration
public override string RemoveParameterNamePrefix(string name)
Parameters
Type | Name | Description
System.String | name |
Returns
Type | Description
System.String |
Overrides
DbProvider.RemoveParameterNamePrefix(String)

ValidateConnectionParams(String, String, String, String)

Declaration
public override bool ValidateConnectionParams(string dbServer, string dbName, string dbUser, string dbPass)
Parameters
Type | Name | Description
System.String | dbServer |
System.String | dbName |
System.String | dbUser |
System.String | dbPass |
Returns
Type | Description
System.Boolean |
Overrides
DbProvider.ValidateConnectionParams(String, String, String, String)


Class SqlHelper | fcSDK Documentation

Class SqlHelper

Inheritance
System.Object
SqlHelper
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Common.Data
Assembly: FChoice.Common.dll
Syntax
public class SqlHelper

Constructors

SqlHelper()

Declaration
public SqlHelper()

SqlHelper(DbProvider)

Declaration
public SqlHelper(DbProvider dataProvider)
Parameters
Type | Name | Description
DbProvider | dataProvider |

SqlHelper(DbProvider, CommandType, String)

Declaration
public SqlHelper(DbProvider dataProvider, CommandType inCmdType, string cmdTxt)
Parameters
Type | Name | Description
DbProvider | dataProvider |
System.Data.CommandType | inCmdType |
System.String | cmdTxt |

SqlHelper(DbProvider, String)

Declaration
public SqlHelper(DbProvider dataProvider, string cmdTxt)
Parameters
Type | Name | Description
DbProvider | dataProvider |
System.String | cmdTxt |

SqlHelper(CommandType, String)

Declaration
public SqlHelper(CommandType inCmdType, string cmdTxt)
Parameters
Type | Name | Description
System.Data.CommandType | inCmdType |
System.String | cmdTxt |

SqlHelper(String)

Declaration
public SqlHelper(string cmdTxt)
Parameters
Type | Name | Description
System.String | cmdTxt |

Fields

IN_LIST_TOKEN

Declaration
public const string IN_LIST_TOKEN = "{INLIST}"
Field Value
Type | Description
System.String |

Properties

CommandText

Declaration
public string CommandText { get; set; }
Property Value
Type | Description
System.String |

CommandType

Declaration
public CommandType CommandType { get; set; }
Property Value
Type | Description
System.Data.CommandType |

Connection

Declaration
public IDbConnection Connection { get; set; }
Property Value
Type | Description
System.Data.IDbConnection |

DataProvider

Declaration
public DbProvider DataProvider { get; set; }
Property Value
Type | Description
DbProvider |

Log

Declaration
public static Logger Log { get; }
Property Value
Type | Description
Logger |

Parameters

Declaration
public DataParameterCollection Parameters { get; }
Property Value
Type | Description
DataParameterCollection |

Transaction

Declaration
public IDbTransaction Transaction { get; set; }
Property Value
Type | Description
System.Data.IDbTransaction |

Methods

ExecuteDataSet()

Declaration
public DataSet ExecuteDataSet()
Returns
Type | Description
System.Data.DataSet |

ExecuteDataSet(CommandType, String)

Declaration
public static DataSet ExecuteDataSet(CommandType commandType, string commandText)
Parameters
Type | Name | Description
System.Data.CommandType | commandType |
System.String | commandText |
Returns
Type | Description
System.Data.DataSet |

ExecuteDataSet(CommandType, String, DataParameterCollection)

Declaration
public static DataSet ExecuteDataSet(CommandType commandType, string commandText, DataParameterCollection commandParams)
Parameters
Type | Name | Description
System.Data.CommandType | commandType |
System.String | commandText |
DataParameterCollection | commandParams |
Returns
Type | Description
System.Data.DataSet |

ExecuteDataSet(IDbConnection, CommandType, String)

Declaration
public static DataSet ExecuteDataSet(IDbConnection connection, CommandType commandType, string commandText)
Parameters
Type | Name | Description
System.Data.IDbConnection | connection |
System.Data.CommandType | commandType |
System.String | commandText |
Returns
Type | Description
System.Data.DataSet |

ExecuteDataSet(IDbConnection, CommandType, String, DataParameterCollection)

Declaration
public static DataSet ExecuteDataSet(IDbConnection connection, CommandType commandType, string commandText, DataParameterCollection commandParams)
Parameters
Type | Name | Description
System.Data.IDbConnection | connection |
System.Data.CommandType | commandType |
System.String | commandText |
DataParameterCollection | commandParams |
Returns
Type | Description
System.Data.DataSet |

ExecuteDataSet(IDbTransaction, CommandType, String)

Declaration
public static DataSet ExecuteDataSet(IDbTransaction transaction, CommandType commandType, string commandText)
Parameters
Type | Name | Description
System.Data.IDbTransaction | transaction |
System.Data.CommandType | commandType |
System.String | commandText |
Returns
Type | Description
System.Data.DataSet |

ExecuteDataSet(IDbTransaction, CommandType, String, DataParameterCollection)

Declaration
public static DataSet ExecuteDataSet(IDbTransaction transaction, CommandType commandType, string commandText, DataParameterCollection commandParams)
Parameters
Type | Name | Description
System.Data.IDbTransaction | transaction |
System.Data.CommandType | commandType |
System.String | commandText |
DataParameterCollection | commandParams |
Returns
Type | Description
System.Data.DataSet |

ExecuteDataSet(String)

Declaration
public static DataSet ExecuteDataSet(string commandText)
Parameters
Type | Name | Description
System.String | commandText |
Returns
Type | Description
System.Data.DataSet |

ExecuteDataSetInList(Object[], String)

Declaration
public DataSet ExecuteDataSetInList(object[] inList, string columnName)
Parameters
Type | Name | Description
System.Object[] | inList |
System.String | columnName |
Returns
Type | Description
System.Data.DataSet |

ExecuteNonQuery()

Declaration
public int ExecuteNonQuery()
Returns
Type | Description
System.Int32 |

ExecuteNonQuery(CommandType, String)

Declaration
public static int ExecuteNonQuery(CommandType commandType, string commandText)
Parameters
Type | Name | Description
System.Data.CommandType | commandType |
System.String | commandText |
Returns
Type | Description
System.Int32 |

ExecuteNonQuery(CommandType, String, DataParameterCollection)

Declaration
public static int ExecuteNonQuery(CommandType commandType, string commandText, DataParameterCollection commandParams)
Parameters
Type | Name | Description
System.Data.CommandType | commandType |
System.String | commandText |
DataParameterCollection | commandParams |
Returns
Type | Description
System.Int32 |

ExecuteNonQuery(IDbConnection, CommandType, String)

Declaration
public static int ExecuteNonQuery(IDbConnection connection, CommandType commandType, string commandText)
Parameters
Type | Name | Description
System.Data.IDbConnection | connection |
System.Data.CommandType | commandType |
System.String | commandText |
Returns
Type | Description
System.Int32 |

ExecuteNonQuery(IDbConnection, CommandType, String, DataParameterCollection)

Declaration
public static int ExecuteNonQuery(IDbConnection connection, CommandType commandType, string commandText, DataParameterCollection commandParams)
Parameters
Type | Name | Description
System.Data.IDbConnection | connection |
System.Data.CommandType | commandType |
System.String | commandText |
DataParameterCollection | commandParams |
Returns
Type | Description
System.Int32 |

ExecuteNonQuery(IDbTransaction, CommandType, String)

Declaration
public static int ExecuteNonQuery(IDbTransaction transaction, CommandType commandType, string commandText)
Parameters
Type | Name | Description
System.Data.IDbTransaction | transaction |
System.Data.CommandType | commandType |
System.String | commandText |
Returns
Type | Description
System.Int32 |

ExecuteNonQuery(IDbTransaction, CommandType, String, DataParameterCollection)

Declaration
public static int ExecuteNonQuery(IDbTransaction transaction, CommandType commandType, string commandText, DataParameterCollection commandParams)
Parameters
Type | Name | Description
System.Data.IDbTransaction | transaction |
System.Data.CommandType | commandType |
System.String | commandText |
DataParameterCollection | commandParams |
Returns
Type | Description
System.Int32 |

ExecuteNonQuery(String)

Declaration
public static int ExecuteNonQuery(string commandText)
Parameters
Type | Name | Description
System.String | commandText |
Returns
Type | Description
System.Int32 |

ExecuteNonQueryInList(Object[], String)

Declaration
public int ExecuteNonQueryInList(object[] inList, string columnName)
Parameters
Type | Name | Description
System.Object[] | inList |
System.String | columnName |
Returns
Type | Description
System.Int32 |

ExecuteReader()

Declaration
public IDataReader ExecuteReader()
Returns
Type | Description
System.Data.IDataReader |

ExecuteReader(CommandType, String)

Declaration
public static IDataReader ExecuteReader(CommandType commandType, string commandText)
Parameters
Type | Name | Description
System.Data.CommandType | commandType |
System.String | commandText |
Returns
Type | Description
System.Data.IDataReader |

ExecuteReader(CommandType, String, DataParameterCollection)

Declaration
public static IDataReader ExecuteReader(CommandType commandType, string commandText, DataParameterCollection commandParams)
Parameters
Type | Name | Description
System.Data.CommandType | commandType |
System.String | commandText |
DataParameterCollection | commandParams |
Returns
Type | Description
System.Data.IDataReader |

ExecuteReader(IDbConnection, CommandType, String)

Declaration
public static IDataReader ExecuteReader(IDbConnection connection, CommandType commandType, string commandText)
Parameters
Type | Name | Description
System.Data.IDbConnection | connection |
System.Data.CommandType | commandType |
System.String | commandText |
Returns
Type | Description
System.Data.IDataReader |

ExecuteReader(IDbConnection, CommandType, String, DataParameterCollection)

Declaration
public static IDataReader ExecuteReader(IDbConnection connection, CommandType commandType, string commandText, DataParameterCollection commandParams)
Parameters
Type | Name | Description
System.Data.IDbConnection | connection |
System.Data.CommandType | commandType |
System.String | commandText |
DataParameterCollection | commandParams |
Returns
Type | Description
System.Data.IDataReader |

ExecuteReader(IDbTransaction, CommandType, String)

Declaration
public static IDataReader ExecuteReader(IDbTransaction transaction, CommandType commandType, string commandText)
Parameters
Type | Name | Description
System.Data.IDbTransaction | transaction |
System.Data.CommandType | commandType |
System.String | commandText |
Returns
Type | Description
System.Data.IDataReader |

ExecuteReader(IDbTransaction, CommandType, String, DataParameterCollection)

Declaration
public static IDataReader ExecuteReader(IDbTransaction transaction, CommandType commandType, string commandText, DataParameterCollection commandParams)
Parameters
Type | Name | Description
System.Data.IDbTransaction | transaction |
System.Data.CommandType | commandType |
System.String | commandText |
DataParameterCollection | commandParams |
Returns
Type | Description
System.Data.IDataReader |

ExecuteReader(String)

Declaration
public static IDataReader ExecuteReader(string commandText)
Parameters
Type | Name | Description
System.String | commandText |
Returns
Type | Description
System.Data.IDataReader |

ExecuteReaderInList(Object[], String)

Declaration
public IDataReader ExecuteReaderInList(object[] inList, string columnName)
Parameters
Type | Name | Description
System.Object[] | inList |
System.String | columnName |
Returns
Type | Description
System.Data.IDataReader |

ExecuteScalar()

Declaration
public object ExecuteScalar()
Returns
Type | Description
System.Object |

ExecuteScalar(CommandType, String)

Declaration
public static object ExecuteScalar(CommandType commandType, string commandText)
Parameters
Type | Name | Description
System.Data.CommandType | commandType |
System.String | commandText |
Returns
Type | Description
System.Object |

ExecuteScalar(CommandType, String, DataParameterCollection)

Declaration
public static object ExecuteScalar(CommandType commandType, string commandText, DataParameterCollection commandParams)
Parameters
Type | Name | Description
System.Data.CommandType | commandType |
System.String | commandText |
DataParameterCollection | commandParams |
Returns
Type | Description
System.Object |

ExecuteScalar(IDbConnection, CommandType, String)

Declaration
public static object ExecuteScalar(IDbConnection connection, CommandType commandType, string commandText)
Parameters
Type | Name | Description
System.Data.IDbConnection | connection |
System.Data.CommandType | commandType |
System.String | commandText |
Returns
Type | Description
System.Object |

ExecuteScalar(IDbConnection, CommandType, String, DataParameterCollection)

Declaration
public static object ExecuteScalar(IDbConnection connection, CommandType commandType, string commandText, DataParameterCollection commandParams)
Parameters
Type | Name | Description
System.Data.IDbConnection | connection |
System.Data.CommandType | commandType |
System.String | commandText |
DataParameterCollection | commandParams |
Returns
Type | Description
System.Object |

ExecuteScalar(IDbTransaction, CommandType, String)

Declaration
public static object ExecuteScalar(IDbTransaction transaction, CommandType commandType, string commandText)
Parameters
Type | Name | Description
System.Data.IDbTransaction | transaction |
System.Data.CommandType | commandType |
System.String | commandText |
Returns
Type | Description
System.Object |

ExecuteScalar(IDbTransaction, CommandType, String, DataParameterCollection)

Declaration
public static object ExecuteScalar(IDbTransaction transaction, CommandType commandType, string commandText, DataParameterCollection commandParams)
Parameters
Type | Name | Description
System.Data.IDbTransaction | transaction |
System.Data.CommandType | commandType |
System.String | commandText |
DataParameterCollection | commandParams |
Returns
Type | Description
System.Object |

ExecuteScalar(String)

Declaration
public static object ExecuteScalar(string commandText)
Parameters
Type | Name | Description
System.String | commandText |
Returns
Type | Description
System.Object |

ExecuteScalarInList(Object[], String)

Declaration
public object ExecuteScalarInList(object[] inList, string columnName)
Parameters
Type | Name | Description
System.Object[] | inList |
System.String | columnName |
Returns
Type | Description
System.Object |

FillDataSet(DbDataAdapter, DataSet, String[], IDbTransaction, CommandType, String, DataParameterCollection, Boolean)

Declaration
public static void FillDataSet(DbDataAdapter adapter, DataSet ds, string[] tableNames, IDbTransaction transaction, CommandType cmdType, string cmdText, DataParameterCollection dataParams, bool fillSchema)
Parameters
Type | Name | Description
System.Data.Common.DbDataAdapter | adapter |
System.Data.DataSet | ds |
System.String[] | tableNames |
System.Data.IDbTransaction | transaction |
System.Data.CommandType | cmdType |
System.String | cmdText |
DataParameterCollection | dataParams |
System.Boolean | fillSchema |

FillDataSet(DataSet, Boolean, String[])

Declaration
public void FillDataSet(DataSet ds, bool fillSchema, params string[] tableNames)
Parameters
Type | Name | Description
System.Data.DataSet | ds |
System.Boolean | fillSchema |
System.String[] | tableNames |

FillDataSet(DataSet, String, String[])

Declaration
public static void FillDataSet(DataSet ds, string sqlStmt, string[] tableNames)
Parameters
Type | Name | Description
System.Data.DataSet | ds |
System.String | sqlStmt |
System.String[] | tableNames |

FillDataSet(DataSet, String, String[], Boolean)

Declaration
public static void FillDataSet(DataSet ds, string sqlStmt, string[] tableNames, bool fillSchema)
Parameters
Type | Name | Description
System.Data.DataSet | ds |
System.String | sqlStmt |
System.String[] | tableNames |
System.Boolean | fillSchema |

FillDataSet(DataSet, String[])

Declaration
public void FillDataSet(DataSet ds, params string[] tableNames)
Parameters
Type | Name | Description
System.Data.DataSet | ds |
System.String[] | tableNames |

FillDataSet(DataSet, String[], CommandType, String, DataParameterCollection, Boolean)

Declaration
public static void FillDataSet(DataSet ds, string[] tableNames, CommandType cmdType, string cmdText, DataParameterCollection dataParams, bool fillSchema)
Parameters
Type | Name | Description
System.Data.DataSet | ds |
System.String[] | tableNames |
System.Data.CommandType | cmdType |
System.String | cmdText |
DataParameterCollection | dataParams |
System.Boolean | fillSchema |

FillDataSet(DataSet, String[], CommandType, String, Boolean)

Declaration
public static void FillDataSet(DataSet ds, string[] tableNames, CommandType cmdType, string cmdText, bool fillSchema)
Parameters
Type | Name | Description
System.Data.DataSet | ds |
System.String[] | tableNames |
System.Data.CommandType | cmdType |
System.String | cmdText |
System.Boolean | fillSchema |

FillDataSet(DataSet, String[], IDbConnection, CommandType, String, DataParameterCollection, Boolean)

Declaration
public static void FillDataSet(DataSet ds, string[] tableNames, IDbConnection conn, CommandType cmdType, string cmdText, DataParameterCollection dataParams, bool fillSchema)
Parameters
Type | Name | Description
System.Data.DataSet | ds |
System.String[] | tableNames |
System.Data.IDbConnection | conn |
System.Data.CommandType | cmdType |
System.String | cmdText |
DataParameterCollection | dataParams |
System.Boolean | fillSchema |

FillDataSet(DataSet, String[], IDbConnection, CommandType, String, Boolean)

Declaration
public static void FillDataSet(DataSet ds, string[] tableNames, IDbConnection conn, CommandType cmdType, string cmdText, bool fillSchema)
Parameters
Type | Name | Description
System.Data.DataSet | ds |
System.String[] | tableNames |
System.Data.IDbConnection | conn |
System.Data.CommandType | cmdType |
System.String | cmdText |
System.Boolean | fillSchema |

FillDataSet(DataSet, String[], IDbTransaction, CommandType, String, DataParameterCollection, Boolean)

Declaration
public static void FillDataSet(DataSet ds, string[] tableNames, IDbTransaction transaction, CommandType cmdType, string cmdText, DataParameterCollection dataParams, bool fillSchema)
Parameters
Type | Name | Description
System.Data.DataSet | ds |
System.String[] | tableNames |
System.Data.IDbTransaction | transaction |
System.Data.CommandType | cmdType |
System.String | cmdText |
DataParameterCollection | dataParams |
System.Boolean | fillSchema |

FillDataSet(DataSet, String[], IDbTransaction, CommandType, String, Boolean)

Declaration
public static void FillDataSet(DataSet ds, string[] tableNames, IDbTransaction trans, CommandType cmdType, string cmdText, bool fillSchema)
Parameters
Type | Name | Description
System.Data.DataSet | ds |
System.String[] | tableNames |
System.Data.IDbTransaction | trans |
System.Data.CommandType | cmdType |
System.String | cmdText |
System.Boolean | fillSchema |

FillDataSetInList(DataSet, Object[], String)

Declaration
public void FillDataSetInList(DataSet ds, object[] inList, string columnName)
Parameters
Type | Name | Description
System.Data.DataSet | ds |
System.Object[] | inList |
System.String | columnName |

FillDataSetInList(DataSet, Object[], String, String, Boolean)

Declaration
public void FillDataSetInList(DataSet ds, object[] inList, string columnName, string tableName, bool fillSchema)
Parameters
Type | Name | Description
System.Data.DataSet | ds |
System.Object[] | inList |
System.String | columnName |
System.String | tableName |
System.Boolean | fillSchema |

FillDataSetRaw(DataSet, Boolean, String[])

Declaration
public static void FillDataSetRaw(DataSet ds, bool fillSchema, params string[] tableNames)
Parameters
Type | Name | Description
System.Data.DataSet | ds |
System.Boolean | fillSchema |
System.String[] | tableNames |

FillDataSetRaw(DataSet, String[])

Declaration
public static void FillDataSetRaw(DataSet ds, params string[] tableNames)
Parameters
Type | Name | Description
System.Data.DataSet | ds |
System.String[] | tableNames |

GetTableAsDataSet(String)

Declaration
public static DataSet GetTableAsDataSet(string tableName)
Parameters
Type | Name | Description
System.String | tableName |
Returns
Type | Description
System.Data.DataSet |

GetTableAsDataSet(String, String)

Declaration
public static DataSet GetTableAsDataSet(string tableName, string orderBy)
Parameters
Type | Name | Description
System.String | tableName |
System.String | orderBy |
Returns
Type | Description
System.Data.DataSet |

PrepareInListStatement(Int32, DataParameterCollection, Object[], String, String)

Declaration
public string PrepareInListStatement(int paramBaseNum, DataParameterCollection dataParams, object[] inList, string columnName, string text)
Parameters
Type | Name | Description
System.Int32 | paramBaseNum |
DataParameterCollection | dataParams |
System.Object[] | inList |
System.String | columnName |
System.String | text |
Returns
Type | Description
System.String |

PrepareInListStatement(Int32, DataParameterCollection, Object[], String, String, IDbDataParameter)

Declaration
public string PrepareInListStatement(int paramBaseNum, DataParameterCollection dataParams, object[] inList, string columnName, string text, IDbDataParameter parameterTemplate)
Parameters
Type | Name | Description
System.Int32 | paramBaseNum |
DataParameterCollection | dataParams |
System.Object[] | inList |
System.String | columnName |
System.String | text |
System.Data.IDbDataParameter | parameterTemplate |
Returns
Type | Description
System.String |

PrepareInListStatement(Int32[], String, String)

Declaration
public string PrepareInListStatement(int[] inList, string columnName, string text)
Parameters
Type | Name | Description
System.Int32[] | inList |
System.String | columnName |
System.String | text |
Returns
Type | Description
System.String |

PrepareInListStatement(Object[], String, String)

Declaration
public string PrepareInListStatement(object[] inList, string columnName, string text)
Parameters
Type | Name | Description
System.Object[] | inList |
System.String | columnName |
System.String | text |
Returns
Type | Description
System.String |

PrepareIntegerListStatement(Int32[], String, String)

Declaration
public string PrepareIntegerListStatement(int[] intList, string columnName, string text)
Parameters
Type | Name | Description
System.Int32[] | intList |
System.String | columnName |
System.String | text |
Returns
Type | Description
System.String |


Class TypeMapper | fcSDK Documentation

Class TypeMapper

Inheritance
System.Object
TypeMapper
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Common.Data
Assembly: FChoice.Common.dll
Syntax
public abstract class TypeMapper

Constructors

TypeMapper()

Declaration
protected TypeMapper()

Methods

MapDbNameToDbNumber(String)

Declaration
public abstract int MapDbNameToDbNumber(string dbName)
Parameters
Type | Name | Description
System.String | dbName |
Returns
Type | Description
System.Int32 |

MapDbNameToFCName(String)

Declaration
public abstract string MapDbNameToFCName(string dbName)
Parameters
Type | Name | Description
System.String | dbName |
Returns
Type | Description
System.String |

MapDbNameToFCNumber(String)

Declaration
public abstract int MapDbNameToFCNumber(string dbName)
Parameters
Type | Name | Description
System.String | dbName |
Returns
Type | Description
System.Int32 |

MapDbNumberToDbName(Int32)

Declaration
public abstract string MapDbNumberToDbName(int dbNumber)
Parameters
Type | Name | Description
System.Int32 | dbNumber |
Returns
Type | Description
System.String |

MapDbNumberToFCName(Int32)

Declaration
public abstract string MapDbNumberToFCName(int dbNumber)
Parameters
Type | Name | Description
System.Int32 | dbNumber |
Returns
Type | Description
System.String |

MapDbNumberToFCNumber(Int32)

Declaration
public abstract int MapDbNumberToFCNumber(int dbNumber)
Parameters
Type | Name | Description
System.Int32 | dbNumber |
Returns
Type | Description
System.Int32 |

MapFCNameToDbName(String)

Declaration
public abstract string MapFCNameToDbName(string fcName)
Parameters
Type | Name | Description
System.String | fcName |
Returns
Type | Description
System.String |

MapFCNameToDbNumber(String)

Declaration
public abstract int MapFCNameToDbNumber(string fcName)
Parameters
Type | Name | Description
System.String | fcName |
Returns
Type | Description
System.Int32 |

MapFCNameToFCNumber(String)

Declaration
public static int MapFCNameToFCNumber(string fcName)
Parameters
Type | Name | Description
System.String | fcName |
Returns
Type | Description
System.Int32 |

MapFCNumberToDbName(Int32)

Declaration
public abstract string MapFCNumberToDbName(int fcNumber)
Parameters
Type | Name | Description
System.Int32 | fcNumber |
Returns
Type | Description
System.String |

MapFCNumberToDbNumber(Int32)

Declaration
public abstract int MapFCNumberToDbNumber(int fcNumber)
Parameters
Type | Name | Description
System.Int32 | fcNumber |
Returns
Type | Description
System.Int32 |

MapFCNumberToFCName(Int32)

Declaration
public static string MapFCNumberToFCName(int fcNumber)
Parameters
Type | Name | Description
System.Int32 | fcNumber |
Returns
Type | Description
System.String |

MapTypeToDbType(Type)

Declaration
public virtual Type MapTypeToDbType(Type type)
Parameters
Type | Name | Description
System.Type | type |
Returns
Type | Description
System.Type |


Class UpdateQueryBatch | fcSDK Documentation

Class UpdateQueryBatch

Inheritance
System.Object
UpdateQueryBatch
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Common.Data
Assembly: FChoice.Common.dll
Syntax
public class UpdateQueryBatch

Constructors

UpdateQueryBatch(IDbTransaction)

Declaration
public UpdateQueryBatch(IDbTransaction trans)
Parameters
Type | Name | Description
System.Data.IDbTransaction | trans |

UpdateQueryBatch(IDbTransaction, DbProvider)

Declaration
public UpdateQueryBatch(IDbTransaction trans, DbProvider prov)
Parameters
Type | Name | Description
System.Data.IDbTransaction | trans |
DbProvider | prov |

Properties

CommandText

Declaration
public StringBuilder CommandText { get; }
Property Value
Type | Description
System.Text.StringBuilder |

Parameters

Declaration
public DataParameterCollection Parameters { get; }
Property Value
Type | Description
DataParameterCollection |

Provider

Declaration
public DbProvider Provider { get; }
Property Value
Type | Description
DbProvider |

SqlHelper

Declaration
public SqlHelper SqlHelper { get; }
Property Value
Type | Description
SqlHelper |

Transaction

Declaration
public IDbTransaction Transaction { get; }
Property Value
Type | Description
System.Data.IDbTransaction |

Methods

AddStatement(String, DataParameterCollection)

Declaration
public void AddStatement(string sqlStmt, DataParameterCollection cmdParams)
Parameters
Type | Name | Description
System.String | sqlStmt |
DataParameterCollection | cmdParams |

Execute()

Declaration
public int Execute()
Returns
Type | Description
System.Int32 |

GetUniqueParamName(String)

Declaration
public string GetUniqueParamName(string baseName)
Parameters
Type | Name | Description
System.String | baseName |
Returns
Type | Description
System.String |


Enum DataProtectionStore | fcSDK Documentation

Enum DataProtectionStore

Namespace: FChoice.Common
Assembly: FChoice.Common.dll
Syntax
public enum DataProtectionStore

Fields

Name | Description
UseMachineStore |
UseUserStore |


Class DataProtector | fcSDK Documentation

Class DataProtector

Inheritance
System.Object
DataProtector
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Common
Assembly: FChoice.Common.dll
Syntax
public sealed class DataProtector

Methods

Decrypt(DataProtectionStore, Byte[])

Declaration
public static byte[] Decrypt(DataProtectionStore keyStore, byte[] cipherBytes)
Parameters
Type | Name | Description
DataProtectionStore | keyStore |
System.Byte[] | cipherBytes |
Returns
Type | Description
System.Byte[] |

Decrypt(DataProtectionStore, Byte[], Byte[])

Declaration
public static byte[] Decrypt(DataProtectionStore keyStore, byte[] cipherBytes, byte[] entropy)
Parameters
Type | Name | Description
DataProtectionStore | keyStore |
System.Byte[] | cipherBytes |
System.Byte[] | entropy |
Returns
Type | Description
System.Byte[] |

DecryptString(DataProtectionStore, String)

Declaration
public static string DecryptString(DataProtectionStore keyStore, string encryptedText)
Parameters
Type | Name | Description
DataProtectionStore | keyStore |
System.String | encryptedText |
Returns
Type | Description
System.String |

DecryptString(DataProtectionStore, String, String)

Declaration
public static string DecryptString(DataProtectionStore keyStore, string encryptedText, string entropy)
Parameters
Type | Name | Description
DataProtectionStore | keyStore |
System.String | encryptedText |
System.String | entropy |
Returns
Type | Description
System.String |

Encrypt(DataProtectionStore, Byte[])

Declaration
public static byte[] Encrypt(DataProtectionStore keyStore, byte[] plainBytes)
Parameters
Type | Name | Description
DataProtectionStore | keyStore |
System.Byte[] | plainBytes |
Returns
Type | Description
System.Byte[] |

Encrypt(DataProtectionStore, Byte[], Byte[])

Declaration
public static byte[] Encrypt(DataProtectionStore keyStore, byte[] plainBytes, byte[] entropy)
Parameters
Type | Name | Description
DataProtectionStore | keyStore |
System.Byte[] | plainBytes |
System.Byte[] | entropy |
Returns
Type | Description
System.Byte[] |

EncryptString(DataProtectionStore, String)

Declaration
public static string EncryptString(DataProtectionStore keyStore, string plainText)
Parameters
Type | Name | Description
DataProtectionStore | keyStore |
System.String | plainText |
Returns
Type | Description
System.String |

EncryptString(DataProtectionStore, String, String)

Declaration
public static string EncryptString(DataProtectionStore keyStore, string plainText, string entropy)
Parameters
Type | Name | Description
DataProtectionStore | keyStore |
System.String | plainText |
System.String | entropy |
Returns
Type | Description
System.String |


Class FCArgumentException | fcSDK Documentation

Class FCArgumentException

Inheritance
System.Object
System.Exception
System.ApplicationException
FCExceptionBase
CommonException
FCArgumentException
Implements
System.Runtime.InteropServices._Exception
System.Runtime.Serialization.ISerializable
Inherited Members
CommonException.Assert(Int32, Boolean, String)
FCExceptionBase.SetMessageProvider(IErrorMessageProvider)
FCExceptionBase.GetResourceData()
FCExceptionBase.GetErrorMessageFormat(Object, String)
FCExceptionBase.FormatMessage(String, String, Object[])
FCExceptionBase.LoadErrorResourceSet(String)
FCExceptionBase.GetObjectData(SerializationInfo, StreamingContext)
FCExceptionBase.MessageProvider
FCExceptionBase.ErrorCode
FCExceptionBase.ErrorMessageID
FCExceptionBase.Message
System.Exception.GetBaseException()
System.Exception.ToString()
System.Exception.GetType()
System.Exception.Data
System.Exception.InnerException
System.Exception.TargetSite
System.Exception.StackTrace
System.Exception.HelpLink
System.Exception.Source
System.Exception.HResult
System.Exception.SerializeObjectState
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.MemberwiseClone()
Namespace: FChoice.Common
Assembly: FChoice.Common.dll
Syntax
public class FCArgumentException : CommonException, _Exception, ISerializable

Constructors

FCArgumentException(Int32, String)

Declaration
protected FCArgumentException(int errorId, string messageId)
Parameters
Type | Name | Description
System.Int32 | errorId |
System.String | messageId |

FCArgumentException(Int32, String, Object[])

Declaration
protected FCArgumentException(int errorId, string messageId, params object[] args)
Parameters
Type | Name | Description
System.Int32 | errorId |
System.String | messageId |
System.Object[] | args |

FCArgumentException(SerializationInfo, StreamingContext)

Declaration
protected FCArgumentException(SerializationInfo info, StreamingContext context)
Parameters
Type | Name | Description
System.Runtime.Serialization.SerializationInfo | info |
System.Runtime.Serialization.StreamingContext | context |

Methods

CheckIndexBounds(Int32, String, Int32, Int32)

Declaration
public static void CheckIndexBounds(int errorId, string paramName, int index, int maxBound)
Parameters
Type | Name | Description
System.Int32 | errorId |
System.String | paramName |
System.Int32 | index |
System.Int32 | maxBound |

CheckIsEmpty(Int32, String, String)

Declaration
public static void CheckIsEmpty(int errorId, string paramName, string val)
Parameters
Type | Name | Description
System.Int32 | errorId |
System.String | paramName |
System.String | val |

CheckIsNull(Int32, String, Object)

Declaration
public static void CheckIsNull(int errorId, string paramName, object val)
Parameters
Type | Name | Description
System.Int32 | errorId |
System.String | paramName |
System.Object | val |

Implements

System.Runtime.InteropServices._Exception
System.Runtime.Serialization.ISerializable


Class FCConfiguration | fcSDK Documentation

Class FCConfiguration

Inheritance
System.Object
FCConfiguration
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Common
Assembly: FChoice.Common.dll
Syntax
public sealed class FCConfiguration

Properties

Current

Declaration
public static NameValueCollection Current { get; set; }
Property Value
Type | Description
System.Collections.Specialized.NameValueCollection |

DataProtectionEntropy

Declaration
public static string DataProtectionEntropy { get; set; }
Property Value
Type | Description
System.String |

Methods

LoadEnvironmentSettings()

Declaration
public static NameValueCollection LoadEnvironmentSettings()
Returns
Type | Description
System.Collections.Specialized.NameValueCollection |

LoadEnvironmentSettings(NameValueCollection)

Declaration
public static NameValueCollection LoadEnvironmentSettings(NameValueCollection initialValues)
Parameters
Type | Name | Description
System.Collections.Specialized.NameValueCollection | initialValues |
Returns
Type | Description
System.Collections.Specialized.NameValueCollection |

LoadEnvironmentSettings(NameValueCollection, Boolean, Boolean)

Declaration
public static NameValueCollection LoadEnvironmentSettings(NameValueCollection initialValues, bool checkRequired, bool forceLoad)
Parameters
Type | Name | Description
System.Collections.Specialized.NameValueCollection | initialValues |
System.Boolean | checkRequired |
System.Boolean | forceLoad |
Returns
Type | Description
System.Collections.Specialized.NameValueCollection |

ParseFcEnvFile(String)

Declaration
public static NameValueCollection ParseFcEnvFile(string filePath)
Parameters
Type | Name | Description
System.String | filePath |
Returns
Type | Description
System.Collections.Specialized.NameValueCollection |


Class FCExceptionBase | fcSDK Documentation

Class FCExceptionBase

Inheritance
System.Object
System.Exception
System.ApplicationException
FCExceptionBase
CommonException
FCInvalidConfigurationException
FCLicenseException
InvalidLoggingConfigException
StateManagerException
ClarifyException
CompatibilityException
CompatibilityToolkitException
WorkflowException
FoundationException
Implements
System.Runtime.InteropServices._Exception
System.Runtime.Serialization.ISerializable
Inherited Members
System.Exception.GetBaseException()
System.Exception.ToString()
System.Exception.GetType()
System.Exception.Data
System.Exception.InnerException
System.Exception.TargetSite
System.Exception.StackTrace
System.Exception.HelpLink
System.Exception.Source
System.Exception.HResult
System.Exception.SerializeObjectState
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.MemberwiseClone()
Namespace: FChoice.Common
Assembly: FChoice.Common.dll
Syntax
public abstract class FCExceptionBase : ApplicationException, _Exception, ISerializable

Constructors

FCExceptionBase(Boolean, Exception, Int32, String, Object[])

Declaration
protected FCExceptionBase(bool logException, Exception innerEx, int errorId, string messageId, params object[] args)
Parameters
Type | Name | Description
System.Boolean | logException |
System.Exception | innerEx |
System.Int32 | errorId |
System.String | messageId |
System.Object[] | args |

FCExceptionBase(Exception, Int32, String, Object[])

Declaration
protected FCExceptionBase(Exception innerEx, int errorId, string messageId, params object[] args)
Parameters
Type | Name | Description
System.Exception | innerEx |
System.Int32 | errorId |
System.String | messageId |
System.Object[] | args |

FCExceptionBase(Int32, String, Object[])

Declaration
protected FCExceptionBase(int errorId, string messageId, params object[] args)
Parameters
Type | Name | Description
System.Int32 | errorId |
System.String | messageId |
System.Object[] | args |

FCExceptionBase(SerializationInfo, StreamingContext)

Declaration
protected FCExceptionBase(SerializationInfo info, StreamingContext context)
Parameters
Type | Name | Description
System.Runtime.Serialization.SerializationInfo | info |
System.Runtime.Serialization.StreamingContext | context |

Properties

ErrorCode

Declaration
public int ErrorCode { get; }
Property Value
Type | Description
System.Int32 |

ErrorMessageID

Declaration
public string ErrorMessageID { get; }
Property Value
Type | Description
System.String |

Message

Declaration
public override string Message { get; }
Property Value
Type | Description
System.String |
Overrides
System.Exception.Message

MessageProvider

Declaration
public static IErrorMessageProvider MessageProvider { get; }
Property Value
Type | Description
IErrorMessageProvider |

Methods

FormatMessage(String, String, Object[])

Declaration
protected virtual string FormatMessage(string messageId, string messageFmt, params object[] args)
Parameters
Type | Name | Description
System.String | messageId |
System.String | messageFmt |
System.Object[] | args |
Returns
Type | Description
System.String |

GetErrorMessageFormat(Object, String)

Declaration
protected virtual string GetErrorMessageFormat(object resData, string messageId)
Parameters
Type | Name | Description
System.Object | resData |
System.String | messageId |
Returns
Type | Description
System.String |

GetObjectData(SerializationInfo, StreamingContext)

Declaration
public override void GetObjectData(SerializationInfo info, StreamingContext context)
Parameters
Type | Name | Description
System.Runtime.Serialization.SerializationInfo | info |
System.Runtime.Serialization.StreamingContext | context |
Overrides
System.Exception.GetObjectData(System.Runtime.Serialization.SerializationInfo, System.Runtime.Serialization.StreamingContext)

GetResourceData()

Declaration
protected virtual object GetResourceData()
Returns
Type | Description
System.Object |

LoadErrorResourceSet(String)

Declaration
protected ResourceSet LoadErrorResourceSet(string resourceFileName)
Parameters
Type | Name | Description
System.String | resourceFileName |
Returns
Type | Description
System.Resources.ResourceSet |

SetMessageProvider(IErrorMessageProvider)

Declaration
public static void SetMessageProvider(IErrorMessageProvider provider)
Parameters
Type | Name | Description
IErrorMessageProvider | provider |

Implements

System.Runtime.InteropServices._Exception
System.Runtime.Serialization.ISerializable


Class FCInvalidConfigurationException | fcSDK Documentation

Class FCInvalidConfigurationException

Inheritance
System.Object
System.Exception
System.ApplicationException
FCExceptionBase
FCInvalidConfigurationException
Implements
System.Runtime.InteropServices._Exception
System.Runtime.Serialization.ISerializable
Inherited Members
FCExceptionBase.SetMessageProvider(IErrorMessageProvider)
FCExceptionBase.GetResourceData()
FCExceptionBase.GetErrorMessageFormat(Object, String)
FCExceptionBase.FormatMessage(String, String, Object[])
FCExceptionBase.LoadErrorResourceSet(String)
FCExceptionBase.GetObjectData(SerializationInfo, StreamingContext)
FCExceptionBase.MessageProvider
FCExceptionBase.ErrorCode
FCExceptionBase.ErrorMessageID
FCExceptionBase.Message
System.Exception.GetBaseException()
System.Exception.ToString()
System.Exception.GetType()
System.Exception.Data
System.Exception.InnerException
System.Exception.TargetSite
System.Exception.StackTrace
System.Exception.HelpLink
System.Exception.Source
System.Exception.HResult
System.Exception.SerializeObjectState
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.MemberwiseClone()
Namespace: FChoice.Common
Assembly: FChoice.Common.dll
Syntax
public class FCInvalidConfigurationException : FCExceptionBase, _Exception, ISerializable

Constructors

FCInvalidConfigurationException(Exception, Int32, String, Object[])

Declaration
protected FCInvalidConfigurationException(Exception innerEx, int errorId, string messageId, params object[] args)
Parameters
Type | Name | Description
System.Exception | innerEx |
System.Int32 | errorId |
System.String | messageId |
System.Object[] | args |

FCInvalidConfigurationException(Int32, String, Object[])

Declaration
protected FCInvalidConfigurationException(int errorId, string messageId, params object[] args)
Parameters
Type | Name | Description
System.Int32 | errorId |
System.String | messageId |
System.Object[] | args |

FCInvalidConfigurationException(SerializationInfo, StreamingContext)

Declaration
protected FCInvalidConfigurationException(SerializationInfo info, StreamingContext context)
Parameters
Type | Name | Description
System.Runtime.Serialization.SerializationInfo | info |
System.Runtime.Serialization.StreamingContext | context |

Implements

System.Runtime.InteropServices._Exception
System.Runtime.Serialization.ISerializable


Class FCLicenseException | fcSDK Documentation

Class FCLicenseException

Inheritance
System.Object
System.Exception
System.ApplicationException
FCExceptionBase
FCLicenseException
Implements
System.Runtime.InteropServices._Exception
System.Runtime.Serialization.ISerializable
Inherited Members
FCExceptionBase.SetMessageProvider(IErrorMessageProvider)
FCExceptionBase.GetResourceData()
FCExceptionBase.GetErrorMessageFormat(Object, String)
FCExceptionBase.FormatMessage(String, String, Object[])
FCExceptionBase.LoadErrorResourceSet(String)
FCExceptionBase.GetObjectData(SerializationInfo, StreamingContext)
FCExceptionBase.MessageProvider
FCExceptionBase.ErrorCode
FCExceptionBase.ErrorMessageID
FCExceptionBase.Message
System.Exception.GetBaseException()
System.Exception.ToString()
System.Exception.GetType()
System.Exception.Data
System.Exception.InnerException
System.Exception.TargetSite
System.Exception.StackTrace
System.Exception.HelpLink
System.Exception.Source
System.Exception.HResult
System.Exception.SerializeObjectState
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.MemberwiseClone()
Namespace: FChoice.Common
Assembly: FChoice.Common.dll
Syntax
public class FCLicenseException : FCExceptionBase, _Exception, ISerializable

Constructors

FCLicenseException(Boolean, Int32, String, Object[])

Declaration
public FCLicenseException(bool loggingEnabled, int errorId, string messageId, params object[] args)
Parameters
Type | Name | Description
System.Boolean | loggingEnabled |
System.Int32 | errorId |
System.String | messageId |
System.Object[] | args |

FCLicenseException(Exception, Int32, String, Object[])

Declaration
public FCLicenseException(Exception innerEx, int errorId, string messageId, params object[] args)
Parameters
Type | Name | Description
System.Exception | innerEx |
System.Int32 | errorId |
System.String | messageId |
System.Object[] | args |

FCLicenseException(Int32, String, Object[])

Declaration
public FCLicenseException(int errorId, string messageId, params object[] args)
Parameters
Type | Name | Description
System.Int32 | errorId |
System.String | messageId |
System.Object[] | args |

FCLicenseException(SerializationInfo, StreamingContext)

Declaration
protected FCLicenseException(SerializationInfo info, StreamingContext context)
Parameters
Type | Name | Description
System.Runtime.Serialization.SerializationInfo | info |
System.Runtime.Serialization.StreamingContext | context |

Methods

GetLicenseLoadError(Exception, Int32, FCLicenseException.LoadFailReasons)

Declaration
public static FCLicenseException GetLicenseLoadError(Exception ex, int errorId, FCLicenseException.LoadFailReasons reason)
Parameters
Type | Name | Description
System.Exception | ex |
System.Int32 | errorId |
FCLicenseException.LoadFailReasons | reason |
Returns
Type | Description
FCLicenseException |

GetProductLicenseError(Int32, Int32)

Declaration
public static FCLicenseException GetProductLicenseError(int errorId, int productId)
Parameters
Type | Name | Description
System.Int32 | errorId |
System.Int32 | productId |
Returns
Type | Description
FCLicenseException |

Implements

System.Runtime.InteropServices._Exception
System.Runtime.Serialization.ISerializable


Enum FCLicenseException.LoadFailReasons | fcSDK Documentation

Enum FCLicenseException.LoadFailReasons

Namespace: FChoice.Common
Assembly: FChoice.Common.dll
Syntax
public enum LoadFailReasons

Fields

Name | Description
GeneralError |
InvalidGraceLimit |
InvalidLicenseDate |
InvalidUserLimit |
MissingSiteId |
MissingTables |


Interface IErrorMessageProvider | fcSDK Documentation

Interface IErrorMessageProvider

Namespace: FChoice.Common
Assembly: FChoice.Common.dll
Syntax
public interface IErrorMessageProvider

Methods

GetMessageFormat(String)

Declaration
string GetMessageFormat(string messageId)
Parameters
Type | Name | Description
System.String | messageId |
Returns
Type | Description
System.String |


Class InvalidLoggingConfigException | fcSDK Documentation

Class InvalidLoggingConfigException

Inheritance
System.Object
System.Exception
System.ApplicationException
FCExceptionBase
InvalidLoggingConfigException
Implements
System.Runtime.InteropServices._Exception
System.Runtime.Serialization.ISerializable
Inherited Members
FCExceptionBase.SetMessageProvider(IErrorMessageProvider)
FCExceptionBase.GetResourceData()
FCExceptionBase.GetErrorMessageFormat(Object, String)
FCExceptionBase.FormatMessage(String, String, Object[])
FCExceptionBase.LoadErrorResourceSet(String)
FCExceptionBase.GetObjectData(SerializationInfo, StreamingContext)
FCExceptionBase.MessageProvider
FCExceptionBase.ErrorCode
FCExceptionBase.ErrorMessageID
FCExceptionBase.Message
System.Exception.GetBaseException()
System.Exception.ToString()
System.Exception.GetType()
System.Exception.Data
System.Exception.InnerException
System.Exception.TargetSite
System.Exception.StackTrace
System.Exception.HelpLink
System.Exception.Source
System.Exception.HResult
System.Exception.SerializeObjectState
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.MemberwiseClone()
Namespace: FChoice.Common
Assembly: FChoice.Common.dll
Syntax
public class InvalidLoggingConfigException : FCExceptionBase, _Exception, ISerializable

Constructors

InvalidLoggingConfigException(Exception, Int32, String, Object[])

Declaration
protected InvalidLoggingConfigException(Exception innerEx, int errorId, string messageId, params object[] args)
Parameters
Type | Name | Description
System.Exception | innerEx |
System.Int32 | errorId |
System.String | messageId |
System.Object[] | args |

InvalidLoggingConfigException(Int32, String, Object[])

Declaration
protected InvalidLoggingConfigException(int errorId, string messageId, params object[] args)
Parameters
Type | Name | Description
System.Int32 | errorId |
System.String | messageId |
System.Object[] | args |

InvalidLoggingConfigException(SerializationInfo, StreamingContext)

Declaration
protected InvalidLoggingConfigException(SerializationInfo info, StreamingContext context)
Parameters
Type | Name | Description
System.Runtime.Serialization.SerializationInfo | info |
System.Runtime.Serialization.StreamingContext | context |

Implements

System.Runtime.InteropServices._Exception
System.Runtime.Serialization.ISerializable


Namespace FChoice.Common.Licensing | fcSDK Documentation

Namespace FChoice.Common.Licensing

Classes

LicenseCollection

LicenseInfo

LicenseManager

XmlClarifyLicenseTool

XmlLicenseTool

Interfaces

ILicenseInfo

ILicenseTool

Enums

GracePeriodTimeSpan

LicenseUserRestrictionType

Back to top © 2022 Dovetail Software, Inc. - All rights reserved.
Clarify, Amdocs, and related products and names are copyright and trademark of Amdocs, Inc.
.NET, Visual Studio.NET, C#, Visual Basic and related products are trademark of Microsoft corporation.


Enum GracePeriodTimeSpan | fcSDK Documentation

Enum GracePeriodTimeSpan

Namespace: FChoice.Common.Licensing
Assembly: FChoice.Common.dll
Syntax
public enum GracePeriodTimeSpan : byte

Fields

Name | Description
Day |
Month |
Week |


Interface ILicenseInfo | fcSDK Documentation

Interface ILicenseInfo

Namespace: FChoice.Common.Licensing
Assembly: FChoice.Common.dll
Syntax
public interface ILicenseInfo

Properties

ExpirationDate

Declaration
DateTime ExpirationDate { get; }
Property Value
Type | Description
System.DateTime |

GraceEventLimit

Declaration
int GraceEventLimit { get; }
Property Value
Type | Description
System.Int32 |

GraceEventsRemaining

Declaration
int GraceEventsRemaining { get; }
Property Value
Type | Description
System.Int32 |

GraceLicensesRemaining

Declaration
int GraceLicensesRemaining { get; }
Property Value
Type | Description
System.Int32 |

GraceLoginLimit

Declaration
int GraceLoginLimit { get; }
Property Value
Type | Description
System.Int32 |

GraceTimeSpan

Declaration
GracePeriodTimeSpan GraceTimeSpan { get; }
Property Value
Type | Description
GracePeriodTimeSpan |

ProductId

Declaration
int ProductId { get; }
Property Value
Type | Description
System.Int32 |

UserLicenseLimit

Declaration
int UserLicenseLimit { get; }
Property Value
Type | Description
System.Int32 |

UserLicensesRemaining

Declaration
int UserLicensesRemaining { get; }
Property Value
Type | Description
System.Int32 |

UserRestriction

Declaration
LicenseUserRestrictionType UserRestriction { get; }
Property Value
Type | Description
LicenseUserRestrictionType |


Interface ILicenseTool | fcSDK Documentation

Interface ILicenseTool

Namespace: FChoice.Common.Licensing
Assembly: FChoice.Common.dll
Syntax
public interface ILicenseTool

Methods

GraceEventInfo(String)

Declaration
DateTime[] GraceEventInfo(string licenseKey)
Parameters
Type | Name | Description
System.String | licenseKey |
Returns
Type | Description
System.DateTime[] |

LogGraceEvent(String)

Declaration
void LogGraceEvent(string licenseKey)
Parameters
Type | Name | Description
System.String | licenseKey |

RetrieveLicenses()

Declaration
LicenseCollection RetrieveLicenses()
Returns
Type | Description
LicenseCollection |

ValidateLockdownData(String)

Declaration
bool ValidateLockdownData(string lockdownData)
Parameters
Type | Name | Description
System.String | lockdownData |
Returns
Type | Description
System.Boolean |


Class LicenseCollection | fcSDK Documentation

Class LicenseCollection

Inheritance
System.Object
System.Collections.CollectionBase
LicenseCollection
Implements
System.Collections.IList
System.Collections.ICollection
System.Collections.IEnumerable
Inherited Members
System.Collections.CollectionBase.Clear()
System.Collections.CollectionBase.RemoveAt(System.Int32)
System.Collections.CollectionBase.System.Collections.ICollection.CopyTo(System.Array, System.Int32)
System.Collections.CollectionBase.System.Collections.IList.get_Item(System.Int32)
System.Collections.CollectionBase.System.Collections.IList.set_Item(System.Int32, System.Object)
System.Collections.CollectionBase.System.Collections.IList.Contains(System.Object)
System.Collections.CollectionBase.System.Collections.IList.Add(System.Object)
System.Collections.CollectionBase.System.Collections.IList.Remove(System.Object)
System.Collections.CollectionBase.System.Collections.IList.IndexOf(System.Object)
System.Collections.CollectionBase.System.Collections.IList.Insert(System.Int32, System.Object)
System.Collections.CollectionBase.GetEnumerator()
System.Collections.CollectionBase.OnSet(System.Int32, System.Object, System.Object)
System.Collections.CollectionBase.OnInsert(System.Int32, System.Object)
System.Collections.CollectionBase.OnClear()
System.Collections.CollectionBase.OnRemove(System.Int32, System.Object)
System.Collections.CollectionBase.OnValidate(System.Object)
System.Collections.CollectionBase.OnSetComplete(System.Int32, System.Object, System.Object)
System.Collections.CollectionBase.OnInsertComplete(System.Int32, System.Object)
System.Collections.CollectionBase.OnClearComplete()
System.Collections.CollectionBase.OnRemoveComplete(System.Int32, System.Object)
System.Collections.CollectionBase.InnerList
System.Collections.CollectionBase.List
System.Collections.CollectionBase.Capacity
System.Collections.CollectionBase.Count
System.Collections.CollectionBase.System.Collections.IList.IsReadOnly
System.Collections.CollectionBase.System.Collections.IList.IsFixedSize
System.Collections.CollectionBase.System.Collections.ICollection.IsSynchronized
System.Collections.CollectionBase.System.Collections.ICollection.SyncRoot
System.Collections.CollectionBase.System.Collections.IList.Item[System.Int32]
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Common.Licensing
Assembly: FChoice.Common.dll
Syntax
public sealed class LicenseCollection : CollectionBase, IList, ICollection, IEnumerable

Constructors

LicenseCollection()

Declaration
public LicenseCollection()

LicenseCollection(IDataReader)

Declaration
public LicenseCollection(IDataReader licenseReader)
Parameters
Type | Name | Description
System.Data.IDataReader | licenseReader |

LicenseCollection(XmlDocument)

Declaration
public LicenseCollection(XmlDocument xmlDocument)
Parameters
Type | Name | Description
System.Xml.XmlDocument | xmlDocument |

Implements

System.Collections.IList
System.Collections.ICollection
System.Collections.IEnumerable


Class LicenseInfo | fcSDK Documentation

Class LicenseInfo

Inheritance
System.Object
LicenseInfo
Implements
ILicenseInfo
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Common.Licensing
Assembly: FChoice.Common.dll
Syntax
public class LicenseInfo : ILicenseInfo

Properties

ExpirationDate

Declaration
public DateTime ExpirationDate { get; }
Property Value
Type | Description
System.DateTime |

GraceEventLimit

Declaration
public int GraceEventLimit { get; }
Property Value
Type | Description
System.Int32 |

GraceEventsRemaining

Declaration
public int GraceEventsRemaining { get; }
Property Value
Type | Description
System.Int32 |

GraceLicensesRemaining

Declaration
public int GraceLicensesRemaining { get; }
Property Value
Type | Description
System.Int32 |

GraceLoginLimit

Declaration
public int GraceLoginLimit { get; }
Property Value
Type | Description
System.Int32 |

GraceTimeSpan

Declaration
public GracePeriodTimeSpan GraceTimeSpan { get; }
Property Value
Type | Description
GracePeriodTimeSpan |

ProductId

Declaration
public int ProductId { get; }
Property Value
Type | Description
System.Int32 |

UserLicenseLimit

Declaration
public int UserLicenseLimit { get; }
Property Value
Type | Description
System.Int32 |

UserLicensesRemaining

Declaration
public int UserLicensesRemaining { get; }
Property Value
Type | Description
System.Int32 |

UserRestriction

Declaration
public LicenseUserRestrictionType UserRestriction { get; }
Property Value
Type | Description
LicenseUserRestrictionType |

Implements

ILicenseInfo


Class LicenseManager | fcSDK Documentation

Class LicenseManager

Inheritance
System.Object
LicenseManager
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Common.Licensing
Assembly: FChoice.Common.dll
Syntax
public sealed class LicenseManager

Properties

Instance

Declaration
public static LicenseManager Instance { get; }
Property Value
Type | Description
LicenseManager |

IsInitialized

Declaration
public static bool IsInitialized { get; }
Property Value
Type | Description
System.Boolean |

Methods

GetAllLicenseInformation()

Declaration
public ILicenseInfo[] GetAllLicenseInformation()
Returns
Type | Description
ILicenseInfo[] |

GetAllLicenseInformationXml()

Declaration
public string GetAllLicenseInformationXml()
Returns
Type | Description
System.String |

GetLicenseInformation(Int32)

Declaration
public ILicenseInfo GetLicenseInformation(int productId)
Parameters
Type | Name | Description
System.Int32 | productId |
Returns
Type | Description
ILicenseInfo |

Initialize()

Declaration
public static void Initialize()

Initialize(ILicenseTool)

Declaration
public static void Initialize(ILicenseTool licenseTool)
Parameters
Type | Name | Description
ILicenseTool | licenseTool |

RefreshLicensing()

Declaration
public void RefreshLicensing()

ReleaseLicenses(Object)

Declaration
public void ReleaseLicenses(object context)
Parameters
Type | Name | Description
System.Object | context |

ReserveLicense(Object, Int32)

Declaration
public void ReserveLicense(object context, int productId)
Parameters
Type | Name | Description
System.Object | context |
System.Int32 | productId |

ReserveLicense(Object, Int32[])

Declaration
public void ReserveLicense(object context, int[] productIds)
Parameters
Type | Name | Description
System.Object | context |
System.Int32[] | productIds |

VerifyLicense(Int32)

Declaration
public bool VerifyLicense(int productId)
Parameters
Type | Name | Description
System.Int32 | productId |
Returns
Type | Description
System.Boolean |


Enum LicenseUserRestrictionType | fcSDK Documentation

Enum LicenseUserRestrictionType

Namespace: FChoice.Common.Licensing
Assembly: FChoice.Common.dll
Syntax
public enum LicenseUserRestrictionType : byte

Fields

Name | Description
ConcurrentUsers |
None |


Class XmlClarifyLicenseTool | fcSDK Documentation

Class XmlClarifyLicenseTool

Inheritance
System.Object
XmlClarifyLicenseTool
Implements
ILicenseTool
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Common.Licensing
Assembly: FChoice.Common.dll
Syntax
public class XmlClarifyLicenseTool : ILicenseTool

Constructors

XmlClarifyLicenseTool(String, DbProvider)

Declaration
public XmlClarifyLicenseTool(string xmlFilePath, DbProvider dbProvider)
Parameters
Type | Name | Description
System.String | xmlFilePath |
DbProvider | dbProvider |

Properties

XmlFilePath

Declaration
public string XmlFilePath { get; }
Property Value
Type | Description
System.String |

Methods

GraceEventInfo(String)

Declaration
public DateTime[] GraceEventInfo(string licenseKey)
Parameters
Type | Name | Description
System.String | licenseKey |
Returns
Type | Description
System.DateTime[] |

LogGraceEvent(String)

Declaration
public void LogGraceEvent(string licenseKey)
Parameters
Type | Name | Description
System.String | licenseKey |

RetrieveLicenses()

Declaration
public LicenseCollection RetrieveLicenses()
Returns
Type | Description
LicenseCollection |

ValidateLockdownData(String)

Declaration
public bool ValidateLockdownData(string lockdownData)
Parameters
Type | Name | Description
System.String | lockdownData |
Returns
Type | Description
System.Boolean |

Implements

ILicenseTool


Class XmlLicenseTool | fcSDK Documentation

Class XmlLicenseTool

Inheritance
System.Object
XmlLicenseTool
Implements
ILicenseTool
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Common.Licensing
Assembly: FChoice.Common.dll
Syntax
public class XmlLicenseTool : ILicenseTool

Constructors

XmlLicenseTool(String)

Declaration
public XmlLicenseTool(string xmlFilePath)
Parameters
Type | Name | Description
System.String | xmlFilePath |

Properties

XmlFilePath

Declaration
public string XmlFilePath { get; }
Property Value
Type | Description
System.String |

Methods

GraceEventInfo(String)

Declaration
public DateTime[] GraceEventInfo(string licenseKey)
Parameters
Type | Name | Description
System.String | licenseKey |
Returns
Type | Description
System.DateTime[] |

LogGraceEvent(String)

Declaration
public void LogGraceEvent(string licenseKey)
Parameters
Type | Name | Description
System.String | licenseKey |

RetrieveLicenses()

Declaration
public LicenseCollection RetrieveLicenses()
Returns
Type | Description
LicenseCollection |

ValidateLockdownData(String)

Declaration
public bool ValidateLockdownData(string lockdownData)
Parameters
Type | Name | Description
System.String | lockdownData |
Returns
Type | Description
System.Boolean |

Implements

ILicenseTool


Class Logger | fcSDK Documentation

Class Logger

Inheritance
System.Object
Logger
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Common
Assembly: FChoice.Common.dll
Syntax
public class Logger

Properties

IsDebugEnabled

Declaration
public bool IsDebugEnabled { get; }
Property Value
Type | Description
System.Boolean |

IsErrorEnabled

Declaration
public bool IsErrorEnabled { get; }
Property Value
Type | Description
System.Boolean |

IsFatalEnabled

Declaration
public bool IsFatalEnabled { get; }
Property Value
Type | Description
System.Boolean |

IsInfoEnabled

Declaration
public bool IsInfoEnabled { get; }
Property Value
Type | Description
System.Boolean |

IsWarnEnabled

Declaration
public bool IsWarnEnabled { get; }
Property Value
Type | Description
System.Boolean |

Methods

Log(LogLevel, Exception, String, Object[])

Declaration
public void Log(LogLevel level, Exception ex, string format, params object[] args)
Parameters
Type | Name | Description
LogLevel | level |
System.Exception | ex |
System.String | format |
System.Object[] | args |

Log(LogLevel, String, Object[])

Declaration
public void Log(LogLevel level, string format, params object[] args)
Parameters
Type | Name | Description
LogLevel | level |
System.String | format |
System.Object[] | args |

LogDebug(Exception, String, Object[])

Declaration
public void LogDebug(Exception ex, string format, params object[] args)
Parameters
Type | Name | Description
System.Exception | ex |
System.String | format |
System.Object[] | args |

LogDebug(String, Object[])

Declaration
public void LogDebug(string format, params object[] args)
Parameters
Type | Name | Description
System.String | format |
System.Object[] | args |

LogError(Exception, String, Object[])

Declaration
public void LogError(Exception ex, string format, params object[] args)
Parameters
Type | Name | Description
System.Exception | ex |
System.String | format |
System.Object[] | args |

LogError(String, Object[])

Declaration
public void LogError(string format, params object[] args)
Parameters
Type | Name | Description
System.String | format |
System.Object[] | args |

LogInfo(Exception, String, Object[])

Declaration
public void LogInfo(Exception ex, string format, params object[] args)
Parameters
Type | Name | Description
System.Exception | ex |
System.String | format |
System.Object[] | args |

LogInfo(String, Object[])

Declaration
public void LogInfo(string format, params object[] args)
Parameters
Type | Name | Description
System.String | format |
System.Object[] | args |

LogWarn(Exception, String, Object[])

Declaration
public void LogWarn(Exception ex, string format, params object[] args)
Parameters
Type | Name | Description
System.Exception | ex |
System.String | format |
System.Object[] | args |

LogWarn(String, Object[])

Declaration
public void LogWarn(string format, params object[] args)
Parameters
Type | Name | Description
System.String | format |
System.Object[] | args |


Enum LogLevel | fcSDK Documentation

Enum LogLevel

Namespace: FChoice.Common
Assembly: FChoice.Common.dll
Syntax
public enum LogLevel

Fields

Name | Description
DEBUG |
ERROR |
FATAL |
INFO |
UNDEFINED |
WARN |


Class LogManager | fcSDK Documentation

Class LogManager

Inheritance
System.Object
LogManager
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Common
Assembly: FChoice.Common.dll
Syntax
public sealed class LogManager

Constructors

LogManager()

Declaration
public LogManager()

Fields

SyncRoot

Declaration
public static readonly object SyncRoot
Field Value
Type | Description
System.Object |

Properties

Instance

Declaration
public static LogManager Instance { get; }
Property Value
Type | Description
LogManager |

IsInitialized

Declaration
public static bool IsInitialized { get; }
Property Value
Type | Description
System.Boolean |

LogConfigFilePath

Declaration
public static string LogConfigFilePath { get; set; }
Property Value
Type | Description
System.String |

Methods

AddAppenderToLogger(String, String)

Declaration
public static void AddAppenderToLogger(string appenderName, string loggerName)
Parameters
Type | Name | Description
System.String | appenderName |
System.String | loggerName |

AddAppenderToLogger(String, Type)

Declaration
public static void AddAppenderToLogger(string appenderName, Type typeBeingLogged)
Parameters
Type | Name | Description
System.String | appenderName |
System.Type | typeBeingLogged |

AddAppenderToRoot(String)

Declaration
public static void AddAppenderToRoot(string appenderName)
Parameters
Type | Name | Description
System.String | appenderName |

AddLogFileAppender(String, String)

Declaration
public static void AddLogFileAppender(string appenderName, string fileName)
Parameters
Type | Name | Description
System.String | appenderName |
System.String | fileName |

FindFile(String)

Declaration
public static string FindFile(string suggestedFilePath)
Parameters
Type | Name | Description
System.String | suggestedFilePath |
Returns
Type | Description
System.String |

GetLogger(String)

Declaration
public static Logger GetLogger(string loggerName)
Parameters
Type | Name | Description
System.String | loggerName |
Returns
Type | Description
Logger |

GetLogger(Type)

Declaration
public static Logger GetLogger(Type loggerType)
Parameters
Type | Name | Description
System.Type | loggerType |
Returns
Type | Description
Logger |

Initialize()

Declaration
public static void Initialize()

Reconfigure()

Declaration
public static void Reconfigure()

ResetConfiguration()

Declaration
public static void ResetConfiguration()

SetLoggerLevel(String, LogLevel)

Declaration
public static void SetLoggerLevel(string loggerName, LogLevel level)
Parameters
Type | Name | Description
System.String | loggerName |
LogLevel | level |

SetLoggerLevel(Type, LogLevel)

Declaration
public static void SetLoggerLevel(Type loggerType, LogLevel level)
Parameters
Type | Name | Description
System.Type | loggerType |
LogLevel | level |

SetRootLoggerLevel(LogLevel)

Declaration
public static void SetRootLoggerLevel(LogLevel level)
Parameters
Type | Name | Description
LogLevel | level |

SetThreadContextValue(String, String)

Declaration
public static void SetThreadContextValue(string key, string value)
Parameters
Type | Name | Description
System.String | key |
System.String | value |


Class PerfManager | fcSDK Documentation

Class PerfManager

Inheritance
System.Object
PerfManager
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Common
Assembly: FChoice.Common.dll
Syntax
public sealed class PerfManager

Properties

Instance

Declaration
public static PerfManager Instance { get; }
Property Value
Type | Description
PerfManager |

InstanceName

Declaration
public string InstanceName { get; }
Property Value
Type | Description
System.String |

IsEnabled

Declaration
public static bool IsEnabled { get; }
Property Value
Type | Description
System.Boolean |

IsInitialized

Declaration
public static bool IsInitialized { get; }
Property Value
Type | Description
System.Boolean |

Methods

DeInitialize()

Declaration
public static void DeInitialize()

Finalize()

Declaration
protected void Finalize()

GetCounter(String)

Declaration
public PerformanceCounter GetCounter(string counterName)
Parameters
Type | Name | Description
System.String | counterName |
Returns
Type | Description
System.Diagnostics.PerformanceCounter |

GetPerfDurationSecs(Int64)

Declaration
public static decimal GetPerfDurationSecs(long startTicks)
Parameters
Type | Name | Description
System.Int64 | startTicks |
Returns
Type | Description
System.Decimal |

GetPerfTimer()

Declaration
public static long GetPerfTimer()
Returns
Type | Description
System.Int64 |

Initialize()

Declaration
public static void Initialize()


Namespace FChoice.Common.State | fcSDK Documentation

Namespace FChoice.Common.State

Classes

MemoryStateManager

MsSqlStateManager

OracleStateManager

RemoteStateManager

RemoteStateManager.RemoteStateErrors

StateManager

StateManagerException

StateManagerSectionHandler

Interfaces

IStateManager

Back to top © 2022 Dovetail Software, Inc. - All rights reserved.
Clarify, Amdocs, and related products and names are copyright and trademark of Amdocs, Inc.
.NET, Visual Studio.NET, C#, Visual Basic and related products are trademark of Microsoft corporation.


Interface IStateManager | fcSDK Documentation

Interface IStateManager

Namespace: FChoice.Common.State
Assembly: FChoice.Common.dll
Syntax
public interface IStateManager

Properties

ApplicationName

Declaration
string ApplicationName { get; set; }
Property Value
Type | Description
System.String |

IsStateSerialized

Declaration
bool IsStateSerialized { get; }
Property Value
Type | Description
System.Boolean |

StateTimeout

Declaration
TimeSpan StateTimeout { get; set; }
Property Value
Type | Description
System.TimeSpan |

Methods

GetApplicationStates()

Declaration
object[] GetApplicationStates()
Returns
Type | Description
System.Object[] |

GetApplicationStates(Type)

Declaration
object[] GetApplicationStates(Type stateType)
Parameters
Type | Name | Description
System.Type | stateType |
Returns
Type | Description
System.Object[] |

InitializeManager(String, TimeSpan, XmlNode)

Declaration
void InitializeManager(string applicationName, TimeSpan timeoutLength, XmlNode configNode)
Parameters
Type | Name | Description
System.String | applicationName |
System.TimeSpan | timeoutLength |
System.Xml.XmlNode | configNode |

InitializeState(Guid)

Declaration
void InitializeState(Guid id)
Parameters
Type | Name | Description
System.Guid | id |

IsStateExpired(Guid)

Declaration
bool IsStateExpired(Guid id)
Parameters
Type | Name | Description
System.Guid | id |
Returns
Type | Description
System.Boolean |

LoadState(Guid)

Declaration
byte[] LoadState(Guid id)
Parameters
Type | Name | Description
System.Guid | id |
Returns
Type | Description
System.Byte[] |

LoadState(Guid, Type)

Declaration
object LoadState(Guid id, Type stateType)
Parameters
Type | Name | Description
System.Guid | id |
System.Type | stateType |
Returns
Type | Description
System.Object |

RemoveExpiredStates()

Declaration
Guid[] RemoveExpiredStates()
Returns
Type | Description
System.Guid[] |

RemoveState(Guid)

Declaration
void RemoveState(Guid id)
Parameters
Type | Name | Description
System.Guid | id |

ResetTimeout(Guid)

Declaration
void ResetTimeout(Guid id)
Parameters
Type | Name | Description
System.Guid | id |

SaveState(Guid, Byte[])

Declaration
void SaveState(Guid id, byte[] state)
Parameters
Type | Name | Description
System.Guid | id |
System.Byte[] | state |

SaveState(Guid, Object)

Declaration
void SaveState(Guid id, object state)
Parameters
Type | Name | Description
System.Guid | id |
System.Object | state |


Class MemoryStateManager | fcSDK Documentation

Class MemoryStateManager

Inheritance
System.Object
MemoryStateManager
Implements
IStateManager
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Common.State
Assembly: FChoice.Common.dll
Syntax
public class MemoryStateManager : IStateManager

Constructors

MemoryStateManager()

Declaration
public MemoryStateManager()

Properties

ApplicationName

Declaration
public string ApplicationName { get; set; }
Property Value
Type | Description
System.String |

IsStateSerialized

Declaration
public bool IsStateSerialized { get; }
Property Value
Type | Description
System.Boolean |

StateTimeout

Declaration
public TimeSpan StateTimeout { get; set; }
Property Value
Type | Description
System.TimeSpan |

Methods

GetApplicationStates()

Declaration
public object[] GetApplicationStates()
Returns
Type | Description
System.Object[] |

GetApplicationStates(Type)

Declaration
public object[] GetApplicationStates(Type stateType)
Parameters
Type | Name | Description
System.Type | stateType |
Returns
Type | Description
System.Object[] |

InitializeManager(String, TimeSpan, XmlNode)

Declaration
public void InitializeManager(string applicationName, TimeSpan timeoutLength, XmlNode configNode)
Parameters
Type | Name | Description
System.String | applicationName |
System.TimeSpan | timeoutLength |
System.Xml.XmlNode | configNode |

InitializeState(Guid)

Declaration
public void InitializeState(Guid id)
Parameters
Type | Name | Description
System.Guid | id |

IsStateExpired(Guid)

Declaration
public bool IsStateExpired(Guid id)
Parameters
Type | Name | Description
System.Guid | id |
Returns
Type | Description
System.Boolean |

LoadState(Guid, Type)

Declaration
public object LoadState(Guid id, Type stateType)
Parameters
Type | Name | Description
System.Guid | id |
System.Type | stateType |
Returns
Type | Description
System.Object |

RemoveExpiredStates()

Declaration
public Guid[] RemoveExpiredStates()
Returns
Type | Description
System.Guid[] |

RemoveState(Guid)

Declaration
public void RemoveState(Guid id)
Parameters
Type | Name | Description
System.Guid | id |

ResetTimeout(Guid)

Declaration
public void ResetTimeout(Guid id)
Parameters
Type | Name | Description
System.Guid | id |

SaveState(Guid, Byte[])

Declaration
public void SaveState(Guid id, byte[] state)
Parameters
Type | Name | Description
System.Guid | id |
System.Byte[] | state |

SaveState(Guid, Object)

Declaration
public void SaveState(Guid id, object state)
Parameters
Type | Name | Description
System.Guid | id |
System.Object | state |

Explicit Interface Implementations

IStateManager.LoadState(Guid)

Declaration
byte[] IStateManager.LoadState(Guid id)
Parameters
Type | Name | Description
System.Guid | id |
Returns
Type | Description
System.Byte[] |

Implements

IStateManager


Class MsSqlStateManager | fcSDK Documentation

Class MsSqlStateManager

Inheritance
System.Object
RemoteStateManager
MsSqlStateManager
Implements
IStateManager
Inherited Members
RemoteStateManager.log
RemoteStateManager.provider
RemoteStateManager.connectionString
RemoteStateManager.timeoutMinutes
RemoteStateManager.applicationName
RemoteStateManager.configNode
RemoteStateManager.providerAlias
RemoteStateManager.appParameterTemplate
RemoteStateManager.GetApplicationStates()
RemoteStateManager.GetApplicationStates(Type)
RemoteStateManager.InitializeManager(String, TimeSpan, XmlNode)
RemoteStateManager.LoadState(Guid, Type)
RemoteStateManager.SaveState(Guid, Object)
RemoteStateManager.ValidateIsSerialzable(Type)
RemoteStateManager.ValidateSetup(XmlNode)
RemoteStateManager.ConnectionString
RemoteStateManager.Provider
RemoteStateManager.StateTimeout
RemoteStateManager.ApplicationName
RemoteStateManager.IsStateSerialized
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Common.State
Assembly: FChoice.Common.dll
Syntax
public class MsSqlStateManager : RemoteStateManager, IStateManager

Constructors

MsSqlStateManager()

Declaration
public MsSqlStateManager()

Methods

GetCurrentStates()

Declaration
public override object[] GetCurrentStates()
Returns
Type | Description
System.Object[] |
Overrides
RemoteStateManager.GetCurrentStates()

InitializeState(Guid)

Declaration
public override void InitializeState(Guid id)
Parameters
Type | Name | Description
System.Guid | id |
Overrides
RemoteStateManager.InitializeState(Guid)

IsStateExpired(Guid)

Declaration
public override bool IsStateExpired(Guid id)
Parameters
Type | Name | Description
System.Guid | id |
Returns
Type | Description
System.Boolean |
Overrides
RemoteStateManager.IsStateExpired(Guid)

LoadState(Guid)

Declaration
public override byte[] LoadState(Guid id)
Parameters
Type | Name | Description
System.Guid | id |
Returns
Type | Description
System.Byte[] |
Overrides
RemoteStateManager.LoadState(Guid)

RemoveExpiredStates()

Declaration
public override Guid[] RemoveExpiredStates()
Returns
Type | Description
System.Guid[] |
Overrides
RemoteStateManager.RemoveExpiredStates()

RemoveState(Guid)

Declaration
public override void RemoveState(Guid id)
Parameters
Type | Name | Description
System.Guid | id |
Overrides
RemoteStateManager.RemoveState(Guid)

ResetTimeout(Guid)

Declaration
public override void ResetTimeout(Guid id)
Parameters
Type | Name | Description
System.Guid | id |
Overrides
RemoteStateManager.ResetTimeout(Guid)

SaveState(Guid, Byte[])

Declaration
public override void SaveState(Guid id, byte[] state)
Parameters
Type | Name | Description
System.Guid | id |
System.Byte[] | state |
Overrides
RemoteStateManager.SaveState(Guid, Byte[])

Implements

IStateManager


Class OracleStateManager | fcSDK Documentation

Class OracleStateManager

Inheritance
System.Object
RemoteStateManager
OracleStateManager
Implements
IStateManager
Inherited Members
RemoteStateManager.log
RemoteStateManager.provider
RemoteStateManager.connectionString
RemoteStateManager.timeoutMinutes
RemoteStateManager.applicationName
RemoteStateManager.configNode
RemoteStateManager.providerAlias
RemoteStateManager.appParameterTemplate
RemoteStateManager.GetApplicationStates()
RemoteStateManager.GetApplicationStates(Type)
RemoteStateManager.InitializeManager(String, TimeSpan, XmlNode)
RemoteStateManager.LoadState(Guid, Type)
RemoteStateManager.SaveState(Guid, Object)
RemoteStateManager.ValidateIsSerialzable(Type)
RemoteStateManager.ValidateSetup(XmlNode)
RemoteStateManager.ConnectionString
RemoteStateManager.Provider
RemoteStateManager.StateTimeout
RemoteStateManager.ApplicationName
RemoteStateManager.IsStateSerialized
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Common.State
Assembly: FChoice.Common.dll
Syntax
[Obsolete("Remote state management support has been marked obsolete.")]
public class OracleStateManager : RemoteStateManager, IStateManager

Constructors

OracleStateManager()

Declaration
public OracleStateManager()

Methods

GetCurrentStates()

Declaration
public override object[] GetCurrentStates()
Returns
Type | Description
System.Object[] |
Overrides
RemoteStateManager.GetCurrentStates()

InitializeState(Guid)

Declaration
public override void InitializeState(Guid id)
Parameters
Type | Name | Description
System.Guid | id |
Overrides
RemoteStateManager.InitializeState(Guid)

IsStateExpired(Guid)

Declaration
public override bool IsStateExpired(Guid id)
Parameters
Type | Name | Description
System.Guid | id |
Returns
Type | Description
System.Boolean |
Overrides
RemoteStateManager.IsStateExpired(Guid)

LoadState(Guid)

Declaration
public override byte[] LoadState(Guid id)
Parameters
Type | Name | Description
System.Guid | id |
Returns
Type | Description
System.Byte[] |
Overrides
RemoteStateManager.LoadState(Guid)

RemoveExpiredStates()

Declaration
public override Guid[] RemoveExpiredStates()
Returns
Type | Description
System.Guid[] |
Overrides
RemoteStateManager.RemoveExpiredStates()

RemoveState(Guid)

Declaration
public override void RemoveState(Guid id)
Parameters
Type | Name | Description
System.Guid | id |
Overrides
RemoteStateManager.RemoveState(Guid)

ResetTimeout(Guid)

Declaration
public override void ResetTimeout(Guid id)
Parameters
Type | Name | Description
System.Guid | id |
Overrides
RemoteStateManager.ResetTimeout(Guid)

SaveState(Guid, Byte[])

Declaration
public override void SaveState(Guid id, byte[] state)
Parameters
Type | Name | Description
System.Guid | id |
System.Byte[] | state |
Overrides
RemoteStateManager.SaveState(Guid, Byte[])

Implements

IStateManager


Class RemoteStateManager | fcSDK Documentation

Class RemoteStateManager

Inheritance
System.Object
RemoteStateManager
MsSqlStateManager
OracleStateManager
Implements
IStateManager
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Common.State
Assembly: FChoice.Common.dll
Syntax
public abstract class RemoteStateManager : IStateManager

Constructors

RemoteStateManager()

Declaration
protected RemoteStateManager()

Fields

applicationName

Declaration
protected string applicationName
Field Value
Type | Description
System.String |

appParameterTemplate

Declaration
protected IDbDataParameter appParameterTemplate
Field Value
Type | Description
System.Data.IDbDataParameter |

configNode

Declaration
protected XmlNode configNode
Field Value
Type | Description
System.Xml.XmlNode |

connectionString

Declaration
protected string connectionString
Field Value
Type | Description
System.String |

log

Declaration
protected Logger log
Field Value
Type | Description
Logger |

provider

Declaration
protected DbProvider provider
Field Value
Type | Description
DbProvider |

providerAlias

Declaration
protected string providerAlias
Field Value
Type | Description
System.String |

timeoutMinutes

Declaration
protected int timeoutMinutes
Field Value
Type | Description
System.Int32 |

Properties

ApplicationName

Declaration
public string ApplicationName { get; set; }
Property Value
Type | Description
System.String |

ConnectionString

Declaration
public string ConnectionString { get; }
Property Value
Type | Description
System.String |

IsStateSerialized

Declaration
public bool IsStateSerialized { get; }
Property Value
Type | Description
System.Boolean |

Provider

Declaration
public DbProvider Provider { get; }
Property Value
Type | Description
DbProvider |

StateTimeout

Declaration
public TimeSpan StateTimeout { get; set; }
Property Value
Type | Description
System.TimeSpan |

Methods

GetApplicationStates()

Declaration
public object[] GetApplicationStates()
Returns
Type | Description
System.Object[] |

GetApplicationStates(Type)

Declaration
public object[] GetApplicationStates(Type stateType)
Parameters
Type | Name | Description
System.Type | stateType |
Returns
Type | Description
System.Object[] |

GetCurrentStates()

Declaration
public abstract object[] GetCurrentStates()
Returns
Type | Description
System.Object[] |

InitializeManager(String, TimeSpan, XmlNode)

Declaration
public void InitializeManager(string applicationName, TimeSpan timeoutLength, XmlNode configNode)
Parameters
Type | Name | Description
System.String | applicationName |
System.TimeSpan | timeoutLength |
System.Xml.XmlNode | configNode |

InitializeState(Guid)

Declaration
public abstract void InitializeState(Guid id)
Parameters
Type | Name | Description
System.Guid | id |

IsStateExpired(Guid)

Declaration
public abstract bool IsStateExpired(Guid id)
Parameters
Type | Name | Description
System.Guid | id |
Returns
Type | Description
System.Boolean |

LoadState(Guid)

Declaration
public abstract byte[] LoadState(Guid id)
Parameters
Type | Name | Description
System.Guid | id |
Returns
Type | Description
System.Byte[] |

LoadState(Guid, Type)

Declaration
public object LoadState(Guid id, Type stateType)
Parameters
Type | Name | Description
System.Guid | id |
System.Type | stateType |
Returns
Type | Description
System.Object |

RemoveExpiredStates()

Declaration
public abstract Guid[] RemoveExpiredStates()
Returns
Type | Description
System.Guid[] |

RemoveState(Guid)

Declaration
public abstract void RemoveState(Guid id)
Parameters
Type | Name | Description
System.Guid | id |

ResetTimeout(Guid)

Declaration
public abstract void ResetTimeout(Guid id)
Parameters
Type | Name | Description
System.Guid | id |

SaveState(Guid, Byte[])

Declaration
public abstract void SaveState(Guid id, byte[] state)
Parameters
Type | Name | Description
System.Guid | id |
System.Byte[] | state |

SaveState(Guid, Object)

Declaration
public void SaveState(Guid id, object state)
Parameters
Type | Name | Description
System.Guid | id |
System.Object | state |

ValidateIsSerialzable(Type)

Declaration
protected void ValidateIsSerialzable(Type type)
Parameters
Type | Name | Description
System.Type | type |

ValidateSetup(XmlNode)

Declaration
protected virtual void ValidateSetup(XmlNode config)
Parameters
Type | Name | Description
System.Xml.XmlNode | config |

Implements

IStateManager


Class RemoteStateManager.RemoteStateErrors | fcSDK Documentation

Class RemoteStateManager.RemoteStateErrors

Inheritance
System.Object
RemoteStateManager.RemoteStateErrors
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Common.State
Assembly: FChoice.Common.dll
Syntax
protected class RemoteStateErrors

Fields

RS_DATABASE_SETUP

Declaration
public const string RS_DATABASE_SETUP = "COMMON_RS_DATABASE_SETUP"
Field Value
Type | Description
System.String |

RS_INIT_ERROR

Declaration
public const string RS_INIT_ERROR = "COMMON_RS_INIT_ERROR"
Field Value
Type | Description
System.String |

RS_LOAD_ERROR

Declaration
public const string RS_LOAD_ERROR = "COMMON_RS_LOAD_ERROR"
Field Value
Type | Description
System.String |

RS_MISSING_CONFIG

Declaration
public const string RS_MISSING_CONFIG = "COMMON_RS_MISSING_CONFIG"
Field Value
Type | Description
System.String |

RS_NOT_SERIALIZABLE

Declaration
public const string RS_NOT_SERIALIZABLE = "COMMON_RS_NOT_SERIALIZABLE"
Field Value
Type | Description
System.String |

RS_REMOVE_ERROR

Declaration
public const string RS_REMOVE_ERROR = "COMMON_RS_REMOVE_ERROR"
Field Value
Type | Description
System.String |

RS_REMOVE_EXPIRED_ERROR

Declaration
public const string RS_REMOVE_EXPIRED_ERROR = "COMMON_RS_REMOVE_EXPIRED_ERROR"
Field Value
Type | Description
System.String |

RS_RESETTIMEOUT_ERROR

Declaration
public const string RS_RESETTIMEOUT_ERROR = "COMMON_RS_RESETTIMEOUT_ERROR"
Field Value
Type | Description
System.String |

RS_SAVE_ERROR

Declaration
public const string RS_SAVE_ERROR = "COMMON_RS_SAVE_ERROR"
Field Value
Type | Description
System.String |

RS_UNABLE_TO_CONNECT

Declaration
public const string RS_UNABLE_TO_CONNECT = "COMMON_RS_UNABLE_TO_CONNECT"
Field Value
Type | Description
System.String |


Class StateManager | fcSDK Documentation

Class StateManager

Inheritance
System.Object
StateManager
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Common.State
Assembly: FChoice.Common.dll
Syntax
public sealed class StateManager

Fields

CONFIGURATION_SECTION_NAME

Declaration
public const string CONFIGURATION_SECTION_NAME = "stateManager"
Field Value
Type | Description
System.String |

DEFAULT_APPLICATION_NAME

Declaration
public const string DEFAULT_APPLICATION_NAME = "Untitled"
Field Value
Type | Description
System.String |

SyncRoot

Declaration
public static readonly object SyncRoot
Field Value
Type | Description
System.Object |

Properties

ApplicationName

Declaration
public static string ApplicationName { get; }
Property Value
Type | Description
System.String |

IsStateSerialized

Declaration
public static bool IsStateSerialized { get; }
Property Value
Type | Description
System.Boolean |

StateTimeout

Declaration
public static TimeSpan StateTimeout { get; set; }
Property Value
Type | Description
System.TimeSpan |

Methods

GetApplicationStates()

Declaration
public static object[] GetApplicationStates()
Returns
Type | Description
System.Object[] |

GetApplicationStates(Type)

Declaration
public static object[] GetApplicationStates(Type stateType)
Parameters
Type | Name | Description
System.Type | stateType |
Returns
Type | Description
System.Object[] |

Initialize()

Declaration
public static void Initialize()

InitializeState(Guid)

Declaration
public static void InitializeState(Guid id)
Parameters
Type | Name | Description
System.Guid | id |

IsStateExpired(Guid)

Declaration
public static bool IsStateExpired(Guid id)
Parameters
Type | Name | Description
System.Guid | id |
Returns
Type | Description
System.Boolean |

LoadState(Guid)

Declaration
public static byte[] LoadState(Guid id)
Parameters
Type | Name | Description
System.Guid | id |
Returns
Type | Description
System.Byte[] |

LoadState(Guid, Type)

Declaration
public static object LoadState(Guid id, Type stateType)
Parameters
Type | Name | Description
System.Guid | id |
System.Type | stateType |
Returns
Type | Description
System.Object |

RemoveExpiredStates()

Declaration
public static Guid[] RemoveExpiredStates()
Returns
Type | Description
System.Guid[] |

RemoveState(Guid)

Declaration
public static void RemoveState(Guid id)
Parameters
Type | Name | Description
System.Guid | id |

ResetTimeout(Guid)

Declaration
public static void ResetTimeout(Guid id)
Parameters
Type | Name | Description
System.Guid | id |

SaveState(Guid, Byte[])

Declaration
public static void SaveState(Guid id, byte[] state)
Parameters
Type | Name | Description
System.Guid | id |
System.Byte[] | state |

SaveState(Guid, Object)

Declaration
public static void SaveState(Guid id, object state)
Parameters
Type | Name | Description
System.Guid | id |
System.Object | state |


Class StateManagerException | fcSDK Documentation

Class StateManagerException

Inheritance
System.Object
System.Exception
System.ApplicationException
FCExceptionBase
StateManagerException
Implements
System.Runtime.InteropServices._Exception
System.Runtime.Serialization.ISerializable
Inherited Members
FCExceptionBase.SetMessageProvider(IErrorMessageProvider)
FCExceptionBase.GetResourceData()
FCExceptionBase.GetErrorMessageFormat(Object, String)
FCExceptionBase.FormatMessage(String, String, Object[])
FCExceptionBase.LoadErrorResourceSet(String)
FCExceptionBase.GetObjectData(SerializationInfo, StreamingContext)
FCExceptionBase.MessageProvider
FCExceptionBase.ErrorCode
FCExceptionBase.ErrorMessageID
FCExceptionBase.Message
System.Exception.GetBaseException()
System.Exception.ToString()
System.Exception.GetType()
System.Exception.Data
System.Exception.InnerException
System.Exception.TargetSite
System.Exception.StackTrace
System.Exception.HelpLink
System.Exception.Source
System.Exception.HResult
System.Exception.SerializeObjectState
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.MemberwiseClone()
Namespace: FChoice.Common.State
Assembly: FChoice.Common.dll
Syntax
public class StateManagerException : FCExceptionBase, _Exception, ISerializable

Constructors

StateManagerException(Exception, Int32, String, Object[])

Declaration
public StateManagerException(Exception innerEx, int errorId, string messageId, params object[] args)
Parameters
Type | Name | Description
System.Exception | innerEx |
System.Int32 | errorId |
System.String | messageId |
System.Object[] | args |

StateManagerException(Int32, String, Object[])

Declaration
public StateManagerException(int errorId, string messageId, params object[] args)
Parameters
Type | Name | Description
System.Int32 | errorId |
System.String | messageId |
System.Object[] | args |

StateManagerException(SerializationInfo, StreamingContext)

Declaration
protected StateManagerException(SerializationInfo info, StreamingContext context)
Parameters
Type | Name | Description
System.Runtime.Serialization.SerializationInfo | info |
System.Runtime.Serialization.StreamingContext | context |

Implements

System.Runtime.InteropServices._Exception
System.Runtime.Serialization.ISerializable


Class StateManagerSectionHandler | fcSDK Documentation

Class StateManagerSectionHandler

Inheritance
System.Object
StateManagerSectionHandler
Implements
System.Configuration.IConfigurationSectionHandler
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Common.State
Assembly: FChoice.Common.dll
Syntax
public class StateManagerSectionHandler : IConfigurationSectionHandler

Constructors

StateManagerSectionHandler()

Declaration
public StateManagerSectionHandler()

Methods

Create(Object, Object, XmlNode)

Declaration
public object Create(object parent, object configContext, XmlNode section)
Parameters
Type | Name | Description
System.Object | parent |
System.Object | configContext |
System.Xml.XmlNode | section |
Returns
Type | Description
System.Object |

Implements

System.Configuration.IConfigurationSectionHandler


Class StringUtil | fcSDK Documentation

Class StringUtil

Inheritance
System.Object
StringUtil
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Common
Assembly: FChoice.Common.dll
Syntax
public static class StringUtil

Methods

AreEqual(String, String)

Declaration
public static bool AreEqual(string firstVal, string secondVal)
Parameters
Type | Name | Description
System.String | firstVal |
System.String | secondVal |
Returns
Type | Description
System.Boolean |

AreEqual(String, String, Boolean)

Declaration
public static bool AreEqual(string firstVal, string secondVal, bool ignoreCase)
Parameters
Type | Name | Description
System.String | firstVal |
System.String | secondVal |
System.Boolean | ignoreCase |
Returns
Type | Description
System.Boolean |

AreEqual(String, String, Boolean, Boolean)

Declaration
public static bool AreEqual(string firstVal, string secondVal, bool ignoreCase, bool cultureNeutral)
Parameters
Type | Name | Description
System.String | firstVal |
System.String | secondVal |
System.Boolean | ignoreCase |
System.Boolean | cultureNeutral |
Returns
Type | Description
System.Boolean |

AreEqual(String, String, Boolean, CultureInfo)

Declaration
public static bool AreEqual(string firstVal, string secondVal, bool ignoreCase, CultureInfo culture)
Parameters
Type | Name | Description
System.String | firstVal |
System.String | secondVal |
System.Boolean | ignoreCase |
System.Globalization.CultureInfo | culture |
Returns
Type | Description
System.Boolean |

IsNonEmptyString(String)

Declaration
public static bool IsNonEmptyString(string val)
Parameters
Type | Name | Description
System.String | val |
Returns
Type | Description
System.Boolean |

StartsWith(String, String)

Declaration
public static bool StartsWith(string origVal, string startVal)
Parameters
Type | Name | Description
System.String | origVal |
System.String | startVal |
Returns
Type | Description
System.Boolean |

StartsWith(String, String, Boolean)

Declaration
public static bool StartsWith(string origVal, string startVal, bool ignoreCase)
Parameters
Type | Name | Description
System.String | origVal |
System.String | startVal |
System.Boolean | ignoreCase |
Returns
Type | Description
System.Boolean |

StartsWith(String, String, Boolean, Boolean)

Declaration
public static bool StartsWith(string origVal, string startVal, bool ignoreCase, bool cultureNeutral)
Parameters
Type | Name | Description
System.String | origVal |
System.String | startVal |
System.Boolean | ignoreCase |
System.Boolean | cultureNeutral |
Returns
Type | Description
System.Boolean |

StartsWith(String, String, Boolean, CultureInfo)

Declaration
public static bool StartsWith(string origVal, string startVal, bool ignoreCase, CultureInfo culture)
Parameters
Type | Name | Description
System.String | origVal |
System.String | startVal |
System.Boolean | ignoreCase |
System.Globalization.CultureInfo | culture |
Returns
Type | Description
System.Boolean |


Namespace FChoice.DataProviders.ODPNet | fcSDK Documentation

Namespace FChoice.DataProviders.ODPNet

Classes

ODPOracleProvider

Back to top © 2022 Dovetail Software, Inc. - All rights reserved.
Clarify, Amdocs, and related products and names are copyright and trademark of Amdocs, Inc.
.NET, Visual Studio.NET, C#, Visual Basic and related products are trademark of Microsoft corporation.


Class ODPOracleProvider | fcSDK Documentation

Class ODPOracleProvider

Inheritance
System.Object
DbProvider
OracleProviderBase
ODPOracleProvider
Inherited Members
OracleProviderBase.CONN_STR_FORMAT
OracleProviderBase.ORACLE_DATE_FORMAT
OracleProviderBase.ORACLE_OUTPUT_DATE_FORMAT
OracleProviderBase.PrepareParameter(IDbDataParameter, CommandType)
OracleProviderBase.GetBadConTypeException(String, String)
OracleProviderBase.Initialize()
OracleProviderBase.Load(XmlNodeList)
OracleProviderBase.GetBitwiseAndStatement(Object, Object)
OracleProviderBase.GetParameterNamePrefix()
OracleProviderBase.RemoveParameterNamePrefix(String)
OracleProviderBase.CreateConnectionString(String, String, String, String, String)
OracleProviderBase.ValidateConnectionParams(String, String, String, String)
OracleProviderBase.PrepareSQLStatement(String, CommandType, DataParameterCollection)
OracleProviderBase.GetDateStatement()
OracleProviderBase.GetAsStatement(String)
OracleProviderBase.GetDBDate()
OracleProviderBase.FormatDateLiteral(DateTime)
OracleProviderBase.PerformGetDbVersion()
OracleProviderBase.GetNlsFormat(OracleProviderBase)
OracleProviderBase.AreLargeTextFieldsClobs()
OracleProviderBase.RequiresDbNameParameter
OracleProviderBase.ProviderCanBatchQueries
OracleProviderBase.MaxInListItems
OracleProviderBase.TypeMapper
OracleProviderBase.ProviderName
DbProvider.TestConnection()
DbProvider.TestConnection(Exception)
DbProvider.GetDbVersion()
DbProvider.GetDbVersion(Boolean)
DbProvider.GetVersionFromString(String)
DbProvider.ParseConnectionString(String)
DbProvider.ConstructConnectionString(NameValueCollection)
DbProvider.CanBatchQueries
DbProvider.ConnectionString
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.DataProviders.ODPNet
Assembly: FChoice.DataProviders.ODPNet.dll
Syntax
public class ODPOracleProvider : OracleProviderBase

Constructors

ODPOracleProvider()

Declaration
public ODPOracleProvider()

Methods

CreateCommand(IDbConnection)

Declaration
public override IDbCommand CreateCommand(IDbConnection dbConnection)
Parameters
Type | Name | Description
System.Data.IDbConnection | dbConnection |
Returns
Type | Description
System.Data.IDbCommand |
Overrides
DbProvider.CreateCommand(IDbConnection)

CreateParameter(String, Object)

Declaration
public override IDbDataParameter CreateParameter(string name, object value)
Parameters
Type | Name | Description
System.String | name |
System.Object | value |
Returns
Type | Description
System.Data.IDbDataParameter |
Overrides
OracleProviderBase.CreateParameter(String, Object)

GetAdapter()

Declaration
public override DbDataAdapter GetAdapter()
Returns
Type | Description
System.Data.Common.DbDataAdapter |
Overrides
OracleProviderBase.GetAdapter()

GetAdapter(IDbConnection)

Declaration
public override DbDataAdapter GetAdapter(IDbConnection conn)
Parameters
Type | Name | Description
System.Data.IDbConnection | conn |
Returns
Type | Description
System.Data.Common.DbDataAdapter |
Overrides
OracleProviderBase.GetAdapter(IDbConnection)

GetAdapter(IDbConnection, String)

Declaration
public override DbDataAdapter GetAdapter(IDbConnection conn, string sqlStmt)
Parameters
Type | Name | Description
System.Data.IDbConnection | conn |
System.String | sqlStmt |
Returns
Type | Description
System.Data.Common.DbDataAdapter |
Overrides
OracleProviderBase.GetAdapter(IDbConnection, String)

GetConnection()

Declaration
public override IDbConnection GetConnection()
Returns
Type | Description
System.Data.IDbConnection |
Overrides
OracleProviderBase.GetConnection()

GetConnection(String)

Declaration
public override IDbConnection GetConnection(string newConStr)
Parameters
Type | Name | Description
System.String | newConStr |
Returns
Type | Description
System.Data.IDbConnection |
Overrides
OracleProviderBase.GetConnection(String)

SetDatabaseParameterTypeForClobText(IDbDataParameter, Boolean)

Declaration
public override void SetDatabaseParameterTypeForClobText(IDbDataParameter dbParameter, bool isParameterUnicode)
Parameters
Type | Name | Description
System.Data.IDbDataParameter | dbParameter |
System.Boolean | isParameterUnicode |
Overrides
DbProvider.SetDatabaseParameterTypeForClobText(IDbDataParameter, Boolean)


Namespace FChoice.Foundation | fcSDK Documentation

Namespace FChoice.Foundation

Classes

CacheBase

CacheManager

CacheSectionHandler

CustomCache

DataFieldNameCollection

DictionaryExtensions

ExcludedColumns

FCApplication

FCGeneric

FCGeneric.FCFilterType

FCGeneric.FCGenericSort

FCInvalidLoginException

FCSession

FCSessionData

FCSessionSummary

FoundationException

GenericDataRow

GenericDataRowCollection

GenericDataSet

GenericDataTable

GenericException

MaximumRowsExceededEventArgs

RelationNameCollection

ValidatedNameCollection

Enums

CacheType

DateOps

NumberOps

StringOps

Delegates

CacheLoadedEventHandler

CachesUpdatedEventHandler

MaximumRowsExceededEventHandler

Back to top © 2022 Dovetail Software, Inc. - All rights reserved.
Clarify, Amdocs, and related products and names are copyright and trademark of Amdocs, Inc.
.NET, Visual Studio.NET, C#, Visual Basic and related products are trademark of Microsoft corporation.


Class CacheBase | fcSDK Documentation

Class CacheBase

Inheritance
System.Object
CacheBase
ClarifyCacheBase
CustomCache
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation
Assembly: fcSDK.dll
Syntax
public abstract class CacheBase

Constructors

CacheBase()

Declaration
protected CacheBase()

Fields

UpdateSyncRoot

Declaration
protected readonly object UpdateSyncRoot
Field Value
Type | Description
System.Object |

Properties

CacheSetName

Declaration
public abstract string CacheSetName { get; }
Property Value
Type | Description
System.String |

CacheType

Declaration
public abstract CacheType CacheType { get; }
Property Value
Type | Description
CacheType |

Methods

AllTablesExistInDataSet(DataSet, String[])

Declaration
protected bool AllTablesExistInDataSet(DataSet dataDs, params string[] tableNames)
Parameters
Type | Name | Description
System.Data.DataSet | dataDs |
System.String[] | tableNames |
Returns
Type | Description
System.Boolean |

GenerateMD5Hash(String)

Declaration
protected static string GenerateMD5Hash(string sourceValue)
Parameters
Type | Name | Description
System.String | sourceValue |
Returns
Type | Description
System.String |

GetCacheDataHash()

Declaration
protected virtual string GetCacheDataHash()
Returns
Type | Description
System.String |

GetCacheFilePath(String)

Declaration
protected string GetCacheFilePath(string cacheSetName)
Parameters
Type | Name | Description
System.String | cacheSetName |
Returns
Type | Description
System.String |

InitCacheData()

Declaration
protected abstract object InitCacheData()
Returns
Type | Description
System.Object |

IsCacheOutOfDate(DateTime)

Declaration
protected abstract bool IsCacheOutOfDate(DateTime testDate)
Parameters
Type | Name | Description
System.DateTime | testDate |
Returns
Type | Description
System.Boolean |

LoadCacheData(Object)

Declaration
protected virtual void LoadCacheData(object cacheData)
Parameters
Type | Name | Description
System.Object | cacheData |

OnAnyCacheUpdated(CacheBase)

Declaration
protected static void OnAnyCacheUpdated(CacheBase instance)
Parameters
Type | Name | Description
CacheBase | instance |

OnCacheUpdated()

Declaration
protected void OnCacheUpdated()

PersistCacheData(Object, String)

Declaration
protected virtual void PersistCacheData(object cacheData, string filePath)
Parameters
Type | Name | Description
System.Object | cacheData |
System.String | filePath |

ReadCacheData(String)

Declaration
protected virtual object ReadCacheData(string filePath)
Parameters
Type | Name | Description
System.String | filePath |
Returns
Type | Description
System.Object |

SetNameAndParameters(String, String)

Declaration
protected abstract void SetNameAndParameters(string name, string parameters)
Parameters
Type | Name | Description
System.String | name |
System.String | parameters |

UpdateCache()

Declaration
public virtual void UpdateCache()

Events

AnyCacheUpdated

Declaration
public static event EventHandler AnyCacheUpdated
Event Type
Type | Description
System.EventHandler |

CacheUpdated

Declaration
public event EventHandler CacheUpdated
Event Type
Type | Description
System.EventHandler |


Delegate CacheLoadedEventHandler | fcSDK Documentation

Delegate CacheLoadedEventHandler

Namespace: FChoice.Foundation
Assembly: fcSDK.dll
Syntax
public delegate void CacheLoadedEventHandler(string cacheName, bool isCustom);
Parameters
Type | Name | Description
System.String | cacheName |
System.Boolean | isCustom |

Constructors

CacheLoadedEventHandler(Object, IntPtr)

Declaration
public CacheLoadedEventHandler(object object, IntPtr method)
Parameters
Type | Name | Description
System.Object | object |
System.IntPtr | method |

Methods

BeginInvoke(String, Boolean, AsyncCallback, Object)

Declaration
public virtual IAsyncResult BeginInvoke(string cacheName, bool isCustom, AsyncCallback callback, object object)
Parameters
Type | Name | Description
System.String | cacheName |
System.Boolean | isCustom |
System.AsyncCallback | callback |
System.Object | object |
Returns
Type | Description
System.IAsyncResult |

EndInvoke(IAsyncResult)

Declaration
public virtual void EndInvoke(IAsyncResult result)
Parameters
Type | Name | Description
System.IAsyncResult | result |

Invoke(String, Boolean)

Declaration
public virtual void Invoke(string cacheName, bool isCustom)
Parameters
Type | Name | Description
System.String | cacheName |
System.Boolean | isCustom |


Class CacheManager | fcSDK Documentation

Class CacheManager

Inheritance
System.Object
CacheManager
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation
Assembly: fcSDK.dll
Syntax
public class CacheManager

Fields

FC_CACHE_PATH_SUFFIX

Declaration
public const string FC_CACHE_PATH_SUFFIX = "fc_cache"
Field Value
Type | Description
System.String |

Properties

CacheFilePath

Declaration
public static string CacheFilePath { get; }
Property Value
Type | Description
System.String |

ConnectionStringHashValue

Declaration
public static string ConnectionStringHashValue { get; }
Property Value
Type | Description
System.String |

IsInitialized

Declaration
public static bool IsInitialized { get; }
Property Value
Type | Description
System.Boolean |

SchemaCache

Declaration
public static ISchemaCache SchemaCache { get; }
Property Value
Type | Description
ISchemaCache |

Methods

AddCache(CacheBase)

Declaration
public static void AddCache(CacheBase cache)
Parameters
Type | Name | Description
CacheBase | cache |

GetCache(String)

Declaration
public static CacheBase GetCache(string name)
Parameters
Type | Name | Description
System.String | name |
Returns
Type | Description
CacheBase |

UpdateCaches(CacheType)

Declaration
public static void UpdateCaches(CacheType cacheType)
Parameters
Type | Name | Description
CacheType | cacheType |

Events

CacheLoaded

Declaration
public static event CacheLoadedEventHandler CacheLoaded
Event Type
Type | Description
CacheLoadedEventHandler |

CachesUpdated

Declaration
public static event CachesUpdatedEventHandler CachesUpdated
Event Type
Type | Description
CachesUpdatedEventHandler |


Class CacheSectionHandler | fcSDK Documentation

Class CacheSectionHandler

Inheritance
System.Object
CacheSectionHandler
Implements
System.Configuration.IConfigurationSectionHandler
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation
Assembly: fcSDK.dll
Syntax
public class CacheSectionHandler : IConfigurationSectionHandler

Constructors

CacheSectionHandler()

Declaration
public CacheSectionHandler()

Implements

System.Configuration.IConfigurationSectionHandler


Delegate CachesUpdatedEventHandler | fcSDK Documentation

Delegate CachesUpdatedEventHandler

Namespace: FChoice.Foundation
Assembly: fcSDK.dll
Syntax
public delegate void CachesUpdatedEventHandler(string[] cacheNames, CacheType cacheType);
Parameters
Type | Name | Description
System.String[] | cacheNames |
CacheType | cacheType |

Constructors

CachesUpdatedEventHandler(Object, IntPtr)

Declaration
public CachesUpdatedEventHandler(object object, IntPtr method)
Parameters
Type | Name | Description
System.Object | object |
System.IntPtr | method |

Methods

BeginInvoke(String[], CacheType, AsyncCallback, Object)

Declaration
public virtual IAsyncResult BeginInvoke(string[] cacheNames, CacheType cacheType, AsyncCallback callback, object object)
Parameters
Type | Name | Description
System.String[] | cacheNames |
CacheType | cacheType |
System.AsyncCallback | callback |
System.Object | object |
Returns
Type | Description
System.IAsyncResult |

EndInvoke(IAsyncResult)

Declaration
public virtual void EndInvoke(IAsyncResult result)
Parameters
Type | Name | Description
System.IAsyncResult | result |

Invoke(String[], CacheType)

Declaration
public virtual void Invoke(string[] cacheNames, CacheType cacheType)
Parameters
Type | Name | Description
System.String[] | cacheNames |
CacheType | cacheType |


Enum CacheType | fcSDK Documentation

Enum CacheType

Namespace: FChoice.Foundation
Assembly: fcSDK.dll
Syntax
[Flags]
public enum CacheType

Fields

Name | Description
All |
Data |
Schema |


Namespace FChoice.Foundation.Clarify | fcSDK Documentation

Namespace FChoice.Foundation.Clarify

Classes

ClarifyApplication

ClarifyAuthenticationResult

ClarifyAuthenticationService

ClarifyCacheBase

ClarifyDataRow

ClarifyDataSet

ClarifyDataSet.TableNumOrderComparer

ClarifyDataTable

ClarifyException

ClarifyGeneric

ClarifyGenericException

ClarifyRowCollection

ClarifySession

ClarifySessionData

ConfigItemCache

ConfigurationHelper

DatabaseParameterFactory

ListCache

LocaleCache

SchemaCache

SchemaCacheHelper

StringCache

WorkflowObjectInfo

Interfaces

IClarifyApplication

IListCache

ILocaleCache

IStringCache

Enums

ClarifyLoginType

InitStatusChangeType

SchemaLoadStatusType

Delegates

InitializeStatusChangeEventHandler

SchemaLoadStatusEventHandler

Back to top © 2022 Dovetail Software, Inc. - All rights reserved.
Clarify, Amdocs, and related products and names are copyright and trademark of Amdocs, Inc.
.NET, Visual Studio.NET, C#, Visual Basic and related products are trademark of Microsoft corporation.


Namespace FChoice.Foundation.Clarify.Attributes | fcSDK Documentation

Namespace FChoice.Foundation.Clarify.Attributes

Classes

AltNameAttribute

AltTypeAttribute

CheckIsNullAttribute

FacadePropertyAttribute

FacadeVoidAttribute

OutputPropertyAttribute

ParameterDefaultValueAttribute

ParameterReadOnlyAttribute

ParameterRequiredAttribute

ParameterVoidAttribute

SplitMethodAttribute

ToolkitVisibleAttribute

Back to top © 2022 Dovetail Software, Inc. - All rights reserved.
Clarify, Amdocs, and related products and names are copyright and trademark of Amdocs, Inc.
.NET, Visual Studio.NET, C#, Visual Basic and related products are trademark of Microsoft corporation.


Class AltNameAttribute | fcSDK Documentation

Class AltNameAttribute

Inheritance
System.Object
System.Attribute
AltNameAttribute
Implements
System.Runtime.InteropServices._Attribute
Inherited Members
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Boolean)
System.Attribute.IsDefined(System.Reflection.MemberInfo, System.Type)
System.Attribute.IsDefined(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.MemberInfo, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Boolean)
System.Attribute.IsDefined(System.Reflection.ParameterInfo, System.Type)
System.Attribute.IsDefined(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.ParameterInfo, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.Module)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.IsDefined(System.Reflection.Module, System.Type)
System.Attribute.IsDefined(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.Module, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Boolean)
System.Attribute.IsDefined(System.Reflection.Assembly, System.Type)
System.Attribute.IsDefined(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.Assembly, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.Equals(System.Object)
System.Attribute.GetHashCode()
System.Attribute.Match(System.Object)
System.Attribute.IsDefaultAttribute()
System.Attribute.System.Runtime.InteropServices._Attribute.GetTypeInfoCount(System.UInt32)
System.Attribute.System.Runtime.InteropServices._Attribute.GetTypeInfo(System.UInt32, System.UInt32, System.IntPtr)
System.Attribute.System.Runtime.InteropServices._Attribute.GetIDsOfNames(System.Guid, System.IntPtr, System.UInt32, System.UInt32, System.IntPtr)
System.Attribute.System.Runtime.InteropServices._Attribute.Invoke(System.UInt32, System.Guid, System.UInt32, System.Int16, System.IntPtr, System.IntPtr, System.IntPtr, System.IntPtr)
System.Attribute.TypeId
System.Object.ToString()
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Attributes
Assembly: fcSDK.dll
Syntax
[AttributeUsage(AttributeTargets.Class | AttributeTargets.Method | AttributeTargets.Parameter)]
public class AltNameAttribute : Attribute, _Attribute

Constructors

AltNameAttribute(String)

Declaration
public AltNameAttribute(string name)
Parameters
Type | Name | Description
System.String | name |

Fields

AltName

Declaration
public readonly string AltName
Field Value
Type | Description
System.String |

Implements

System.Runtime.InteropServices._Attribute


Class AltTypeAttribute | fcSDK Documentation

Class AltTypeAttribute

Inheritance
System.Object
System.Attribute
AltTypeAttribute
Implements
System.Runtime.InteropServices._Attribute
Inherited Members
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Boolean)
System.Attribute.IsDefined(System.Reflection.MemberInfo, System.Type)
System.Attribute.IsDefined(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.MemberInfo, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Boolean)
System.Attribute.IsDefined(System.Reflection.ParameterInfo, System.Type)
System.Attribute.IsDefined(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.ParameterInfo, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.Module)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.IsDefined(System.Reflection.Module, System.Type)
System.Attribute.IsDefined(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.Module, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Boolean)
System.Attribute.IsDefined(System.Reflection.Assembly, System.Type)
System.Attribute.IsDefined(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.Assembly, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.Equals(System.Object)
System.Attribute.GetHashCode()
System.Attribute.Match(System.Object)
System.Attribute.IsDefaultAttribute()
System.Attribute.System.Runtime.InteropServices._Attribute.GetTypeInfoCount(System.UInt32)
System.Attribute.System.Runtime.InteropServices._Attribute.GetTypeInfo(System.UInt32, System.UInt32, System.IntPtr)
System.Attribute.System.Runtime.InteropServices._Attribute.GetIDsOfNames(System.Guid, System.IntPtr, System.UInt32, System.UInt32, System.IntPtr)
System.Attribute.System.Runtime.InteropServices._Attribute.Invoke(System.UInt32, System.Guid, System.UInt32, System.Int16, System.IntPtr, System.IntPtr, System.IntPtr, System.IntPtr)
System.Attribute.TypeId
System.Object.ToString()
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Attributes
Assembly: fcSDK.dll
Syntax
[AttributeUsage(AttributeTargets.Parameter)]
public class AltTypeAttribute : Attribute, _Attribute

Constructors

AltTypeAttribute(String)

Declaration
public AltTypeAttribute(string type)
Parameters
Type | Name | Description
System.String | type |

AltTypeAttribute(String, String)

Declaration
public AltTypeAttribute(string type, string conversionExpression)
Parameters
Type | Name | Description
System.String | type |
System.String | conversionExpression |

AltTypeAttribute(String, String, String)

Declaration
public AltTypeAttribute(string type, string conversionExpression, string method)
Parameters
Type | Name | Description
System.String | type |
System.String | conversionExpression |
System.String | method |

Fields

AltType

Declaration
public readonly string AltType
Field Value
Type | Description
System.String |

ConversionExpression

Declaration
public readonly string ConversionExpression
Field Value
Type | Description
System.String |

Properties

Method

Declaration
public string Method { get; }
Property Value
Type | Description
System.String |

Implements

System.Runtime.InteropServices._Attribute


Class CheckIsNullAttribute | fcSDK Documentation

Class CheckIsNullAttribute

Inheritance
System.Object
System.Attribute
CheckIsNullAttribute
Implements
System.Runtime.InteropServices._Attribute
Inherited Members
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Boolean)
System.Attribute.IsDefined(System.Reflection.MemberInfo, System.Type)
System.Attribute.IsDefined(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.MemberInfo, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Boolean)
System.Attribute.IsDefined(System.Reflection.ParameterInfo, System.Type)
System.Attribute.IsDefined(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.ParameterInfo, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.Module)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.IsDefined(System.Reflection.Module, System.Type)
System.Attribute.IsDefined(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.Module, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Boolean)
System.Attribute.IsDefined(System.Reflection.Assembly, System.Type)
System.Attribute.IsDefined(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.Assembly, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.Equals(System.Object)
System.Attribute.GetHashCode()
System.Attribute.Match(System.Object)
System.Attribute.IsDefaultAttribute()
System.Attribute.System.Runtime.InteropServices._Attribute.GetTypeInfoCount(System.UInt32)
System.Attribute.System.Runtime.InteropServices._Attribute.GetTypeInfo(System.UInt32, System.UInt32, System.IntPtr)
System.Attribute.System.Runtime.InteropServices._Attribute.GetIDsOfNames(System.Guid, System.IntPtr, System.UInt32, System.UInt32, System.IntPtr)
System.Attribute.System.Runtime.InteropServices._Attribute.Invoke(System.UInt32, System.Guid, System.UInt32, System.Int16, System.IntPtr, System.IntPtr, System.IntPtr, System.IntPtr)
System.Attribute.TypeId
System.Object.ToString()
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Attributes
Assembly: fcSDK.dll
Syntax
[AttributeUsage(AttributeTargets.Parameter)]
public class CheckIsNullAttribute : Attribute, _Attribute

Constructors

CheckIsNullAttribute(Int32)

Declaration
public CheckIsNullAttribute(int errorNumber)
Parameters
Type | Name | Description
System.Int32 | errorNumber |

Fields

ErrorNumber

Declaration
public readonly int ErrorNumber
Field Value
Type | Description
System.Int32 |

Implements

System.Runtime.InteropServices._Attribute


Class FacadePropertyAttribute | fcSDK Documentation

Class FacadePropertyAttribute

Inheritance
System.Object
System.Attribute
FacadePropertyAttribute
Implements
System.Runtime.InteropServices._Attribute
Inherited Members
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Boolean)
System.Attribute.IsDefined(System.Reflection.MemberInfo, System.Type)
System.Attribute.IsDefined(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.MemberInfo, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Boolean)
System.Attribute.IsDefined(System.Reflection.ParameterInfo, System.Type)
System.Attribute.IsDefined(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.ParameterInfo, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.Module)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.IsDefined(System.Reflection.Module, System.Type)
System.Attribute.IsDefined(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.Module, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Boolean)
System.Attribute.IsDefined(System.Reflection.Assembly, System.Type)
System.Attribute.IsDefined(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.Assembly, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.Equals(System.Object)
System.Attribute.GetHashCode()
System.Attribute.Match(System.Object)
System.Attribute.IsDefaultAttribute()
System.Attribute.System.Runtime.InteropServices._Attribute.GetTypeInfoCount(System.UInt32)
System.Attribute.System.Runtime.InteropServices._Attribute.GetTypeInfo(System.UInt32, System.UInt32, System.IntPtr)
System.Attribute.System.Runtime.InteropServices._Attribute.GetIDsOfNames(System.Guid, System.IntPtr, System.UInt32, System.UInt32, System.IntPtr)
System.Attribute.System.Runtime.InteropServices._Attribute.Invoke(System.UInt32, System.Guid, System.UInt32, System.Int16, System.IntPtr, System.IntPtr, System.IntPtr, System.IntPtr)
System.Attribute.TypeId
System.Object.ToString()
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Attributes
Assembly: fcSDK.dll
Syntax
[AttributeUsage(AttributeTargets.Method, AllowMultiple = true)]
public class FacadePropertyAttribute : Attribute, _Attribute

Constructors

FacadePropertyAttribute(String, String, String, String)

Declaration
public FacadePropertyAttribute(string propertyName, string propertyType, string defaultValue, string setupExpression)
Parameters
Type | Name | Description
System.String | propertyName |
System.String | propertyType |
System.String | defaultValue |
System.String | setupExpression |

FacadePropertyAttribute(String, String, String, String, Boolean)

Declaration
public FacadePropertyAttribute(string propertyName, string propertyType, string defaultValue, string setupExpression, bool required)
Parameters
Type | Name | Description
System.String | propertyName |
System.String | propertyType |
System.String | defaultValue |
System.String | setupExpression |
System.Boolean | required |

FacadePropertyAttribute(String, String, String, String, Boolean, Boolean)

Declaration
public FacadePropertyAttribute(string propertyName, string propertyType, string defaultValue, string setupExpression, bool required, bool isParamArray)
Parameters
Type | Name | Description
System.String | propertyName |
System.String | propertyType |
System.String | defaultValue |
System.String | setupExpression |
System.Boolean | required |
System.Boolean | isParamArray |

FacadePropertyAttribute(String, String, String, String, Boolean, Boolean, String)

Declaration
public FacadePropertyAttribute(string propertyName, string propertyType, string defaultValue, string setupExpression, bool required, bool isParamArray, string methodName)
Parameters
Type | Name | Description
System.String | propertyName |
System.String | propertyType |
System.String | defaultValue |
System.String | setupExpression |
System.Boolean | required |
System.Boolean | isParamArray |
System.String | methodName |

FacadePropertyAttribute(String, String, String, String, Boolean, Boolean, String, String)

Declaration
public FacadePropertyAttribute(string propertyName, string propertyType, string defaultValue, string setupExpression, bool required, bool isParamArray, string methodName, string indexes)
Parameters
Type | Name | Description
System.String | propertyName |
System.String | propertyType |
System.String | defaultValue |
System.String | setupExpression |
System.Boolean | required |
System.Boolean | isParamArray |
System.String | methodName |
System.String | indexes |

FacadePropertyAttribute(String, String, String, String, Boolean, Boolean, String, String, Int32)

Declaration
public FacadePropertyAttribute(string propertyName, string propertyType, string defaultValue, string setupExpression, bool required, bool isParamArray, string methodName, string indexes, int checkIsNullErrorNumber)
Parameters
Type | Name | Description
System.String | propertyName |
System.String | propertyType |
System.String | defaultValue |
System.String | setupExpression |
System.Boolean | required |
System.Boolean | isParamArray |
System.String | methodName |
System.String | indexes |
System.Int32 | checkIsNullErrorNumber |

FacadePropertyAttribute(String, String, String, String, Boolean, Boolean, String, String, Int32, Boolean)

Declaration
public FacadePropertyAttribute(string propertyName, string propertyType, string defaultValue, string setupExpression, bool required, bool isParamArray, string methodName, string indexes, int checkIsNullErrorNumber, bool readOnly)
Parameters
Type | Name | Description
System.String | propertyName |
System.String | propertyType |
System.String | defaultValue |
System.String | setupExpression |
System.Boolean | required |
System.Boolean | isParamArray |
System.String | methodName |
System.String | indexes |
System.Int32 | checkIsNullErrorNumber |
System.Boolean | readOnly |

Properties

CheckIsNullErrorNumber

Declaration
public int CheckIsNullErrorNumber { get; }
Property Value
Type | Description
System.Int32 |

DefaultValue

Declaration
public string DefaultValue { get; }
Property Value
Type | Description
System.String |

IsParamArray

Declaration
public bool IsParamArray { get; }
Property Value
Type | Description
System.Boolean |

MethodName

Declaration
public string MethodName { get; }
Property Value
Type | Description
System.String |

PropertyName

Declaration
public string PropertyName { get; }
Property Value
Type | Description
System.String |

PropertyType

Declaration
public string PropertyType { get; }
Property Value
Type | Description
System.String |

ReadOnly

Declaration
public bool ReadOnly { get; }
Property Value
Type | Description
System.Boolean |

Required

Declaration
public bool Required { get; }
Property Value
Type | Description
System.Boolean |

SetupExpression

Declaration
public string SetupExpression { get; }
Property Value
Type | Description
System.String |

Methods

GetParameterIndex(Int32)

Declaration
public int GetParameterIndex(int constructorIndex)
Parameters
Type | Name | Description
System.Int32 | constructorIndex |
Returns
Type | Description
System.Int32 |

HasConstructorIndex(Int32)

Declaration
public bool HasConstructorIndex(int constructorIndex)
Parameters
Type | Name | Description
System.Int32 | constructorIndex |
Returns
Type | Description
System.Boolean |

HasConstructorParameterPair(Int32, Int32)

Declaration
public bool HasConstructorParameterPair(int constructorIndex, int parameterIndex)
Parameters
Type | Name | Description
System.Int32 | constructorIndex |
System.Int32 | parameterIndex |
Returns
Type | Description
System.Boolean |

Implements

System.Runtime.InteropServices._Attribute


Class FacadeVoidAttribute | fcSDK Documentation

Class FacadeVoidAttribute

Inheritance
System.Object
System.Attribute
FacadeVoidAttribute
Implements
System.Runtime.InteropServices._Attribute
Inherited Members
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Boolean)
System.Attribute.IsDefined(System.Reflection.MemberInfo, System.Type)
System.Attribute.IsDefined(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.MemberInfo, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Boolean)
System.Attribute.IsDefined(System.Reflection.ParameterInfo, System.Type)
System.Attribute.IsDefined(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.ParameterInfo, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.Module)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.IsDefined(System.Reflection.Module, System.Type)
System.Attribute.IsDefined(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.Module, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Boolean)
System.Attribute.IsDefined(System.Reflection.Assembly, System.Type)
System.Attribute.IsDefined(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.Assembly, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.Equals(System.Object)
System.Attribute.GetHashCode()
System.Attribute.Match(System.Object)
System.Attribute.IsDefaultAttribute()
System.Attribute.System.Runtime.InteropServices._Attribute.GetTypeInfoCount(System.UInt32)
System.Attribute.System.Runtime.InteropServices._Attribute.GetTypeInfo(System.UInt32, System.UInt32, System.IntPtr)
System.Attribute.System.Runtime.InteropServices._Attribute.GetIDsOfNames(System.Guid, System.IntPtr, System.UInt32, System.UInt32, System.IntPtr)
System.Attribute.System.Runtime.InteropServices._Attribute.Invoke(System.UInt32, System.Guid, System.UInt32, System.Int16, System.IntPtr, System.IntPtr, System.IntPtr, System.IntPtr)
System.Attribute.TypeId
System.Object.ToString()
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Attributes
Assembly: fcSDK.dll
Syntax
[AttributeUsage(AttributeTargets.Method)]
public class FacadeVoidAttribute : Attribute, _Attribute

Constructors

FacadeVoidAttribute()

Declaration
public FacadeVoidAttribute()

FacadeVoidAttribute(Boolean)

Declaration
public FacadeVoidAttribute(bool isVoid)
Parameters
Type | Name | Description
System.Boolean | isVoid |

Fields

IsVoid

Declaration
public readonly bool IsVoid
Field Value
Type | Description
System.Boolean |

Implements

System.Runtime.InteropServices._Attribute


Class OutputPropertyAttribute | fcSDK Documentation

Class OutputPropertyAttribute

Inheritance
System.Object
System.Attribute
OutputPropertyAttribute
Implements
System.Runtime.InteropServices._Attribute
Inherited Members
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Boolean)
System.Attribute.IsDefined(System.Reflection.MemberInfo, System.Type)
System.Attribute.IsDefined(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.MemberInfo, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Boolean)
System.Attribute.IsDefined(System.Reflection.ParameterInfo, System.Type)
System.Attribute.IsDefined(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.ParameterInfo, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.Module)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.IsDefined(System.Reflection.Module, System.Type)
System.Attribute.IsDefined(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.Module, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Boolean)
System.Attribute.IsDefined(System.Reflection.Assembly, System.Type)
System.Attribute.IsDefined(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.Assembly, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.Equals(System.Object)
System.Attribute.GetHashCode()
System.Attribute.Match(System.Object)
System.Attribute.IsDefaultAttribute()
System.Attribute.System.Runtime.InteropServices._Attribute.GetTypeInfoCount(System.UInt32)
System.Attribute.System.Runtime.InteropServices._Attribute.GetTypeInfo(System.UInt32, System.UInt32, System.IntPtr)
System.Attribute.System.Runtime.InteropServices._Attribute.GetIDsOfNames(System.Guid, System.IntPtr, System.UInt32, System.UInt32, System.IntPtr)
System.Attribute.System.Runtime.InteropServices._Attribute.Invoke(System.UInt32, System.Guid, System.UInt32, System.Int16, System.IntPtr, System.IntPtr, System.IntPtr, System.IntPtr)
System.Attribute.TypeId
System.Object.ToString()
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Attributes
Assembly: fcSDK.dll
Syntax
[AttributeUsage(AttributeTargets.Method, AllowMultiple = true)]
public class OutputPropertyAttribute : Attribute, _Attribute

Constructors

OutputPropertyAttribute(String)

Declaration
public OutputPropertyAttribute(string propertyName)
Parameters
Type | Name | Description
System.String | propertyName |

OutputPropertyAttribute(String, String)

Declaration
public OutputPropertyAttribute(string propertyName, string docSummary)
Parameters
Type | Name | Description
System.String | propertyName |
System.String | docSummary |

OutputPropertyAttribute(String, String, String, String, String)

Declaration
public OutputPropertyAttribute(string propertyName, string facadePropertyName, string facadeType, string facadeDefaultValue, string docSummary)
Parameters
Type | Name | Description
System.String | propertyName |
System.String | facadePropertyName |
System.String | facadeType |
System.String | facadeDefaultValue |
System.String | docSummary |

OutputPropertyAttribute(String, String, String, String, String, String)

Declaration
public OutputPropertyAttribute(string propertyName, string facadePropertyName, string facadeType, string facadeDefaultValue, string docSummary, string typeConversionExpression)
Parameters
Type | Name | Description
System.String | propertyName |
System.String | facadePropertyName |
System.String | facadeType |
System.String | facadeDefaultValue |
System.String | docSummary |
System.String | typeConversionExpression |

OutputPropertyAttribute(String, String, String, String, String, String, String)

Declaration
public OutputPropertyAttribute(string propertyName, string facadePropertyName, string facadeType, string facadeDefaultValue, string docSummary, string typeConversionExpression, string methodName)
Parameters
Type | Name | Description
System.String | propertyName |
System.String | facadePropertyName |
System.String | facadeType |
System.String | facadeDefaultValue |
System.String | docSummary |
System.String | typeConversionExpression |
System.String | methodName |

Properties

DocSummary

Declaration
public string DocSummary { get; }
Property Value
Type | Description
System.String |

FacadeDefaultValue

Declaration
public string FacadeDefaultValue { get; }
Property Value
Type | Description
System.String |

FacadePropertyName

Declaration
public string FacadePropertyName { get; }
Property Value
Type | Description
System.String |

FacadeType

Declaration
public string FacadeType { get; }
Property Value
Type | Description
System.String |

MethodName

Declaration
public string MethodName { get; }
Property Value
Type | Description
System.String |

PropertyName

Declaration
public string PropertyName { get; }
Property Value
Type | Description
System.String |

TypeConversionExpression

Declaration
public string TypeConversionExpression { get; }
Property Value
Type | Description
System.String |

Implements

System.Runtime.InteropServices._Attribute


Class ParameterDefaultValueAttribute | fcSDK Documentation

Class ParameterDefaultValueAttribute

Inheritance
System.Object
System.Attribute
ParameterDefaultValueAttribute
Implements
System.Runtime.InteropServices._Attribute
Inherited Members
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Boolean)
System.Attribute.IsDefined(System.Reflection.MemberInfo, System.Type)
System.Attribute.IsDefined(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.MemberInfo, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Boolean)
System.Attribute.IsDefined(System.Reflection.ParameterInfo, System.Type)
System.Attribute.IsDefined(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.ParameterInfo, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.Module)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.IsDefined(System.Reflection.Module, System.Type)
System.Attribute.IsDefined(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.Module, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Boolean)
System.Attribute.IsDefined(System.Reflection.Assembly, System.Type)
System.Attribute.IsDefined(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.Assembly, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.Equals(System.Object)
System.Attribute.GetHashCode()
System.Attribute.Match(System.Object)
System.Attribute.IsDefaultAttribute()
System.Attribute.System.Runtime.InteropServices._Attribute.GetTypeInfoCount(System.UInt32)
System.Attribute.System.Runtime.InteropServices._Attribute.GetTypeInfo(System.UInt32, System.UInt32, System.IntPtr)
System.Attribute.System.Runtime.InteropServices._Attribute.GetIDsOfNames(System.Guid, System.IntPtr, System.UInt32, System.UInt32, System.IntPtr)
System.Attribute.System.Runtime.InteropServices._Attribute.Invoke(System.UInt32, System.Guid, System.UInt32, System.Int16, System.IntPtr, System.IntPtr, System.IntPtr, System.IntPtr)
System.Attribute.TypeId
System.Object.ToString()
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Attributes
Assembly: fcSDK.dll
Syntax
[AttributeUsage(AttributeTargets.Parameter, AllowMultiple = true)]
public class ParameterDefaultValueAttribute : Attribute, _Attribute

Constructors

ParameterDefaultValueAttribute(String)

Declaration
public ParameterDefaultValueAttribute(string defaultValue)
Parameters
Type | Name | Description
System.String | defaultValue |

ParameterDefaultValueAttribute(String, String)

Declaration
public ParameterDefaultValueAttribute(string defaultValue, string method)
Parameters
Type | Name | Description
System.String | defaultValue |
System.String | method |

Fields

method

Declaration
public readonly string method
Field Value
Type | Description
System.String |

parameterDefaultValue

Declaration
public readonly string parameterDefaultValue
Field Value
Type | Description
System.String |

Properties

Method

Declaration
public string Method { get; }
Property Value
Type | Description
System.String |

ParameterDefaultValue

Declaration
public string ParameterDefaultValue { get; }
Property Value
Type | Description
System.String |

Implements

System.Runtime.InteropServices._Attribute


Class ParameterReadOnlyAttribute | fcSDK Documentation

Class ParameterReadOnlyAttribute

Inheritance
System.Object
System.Attribute
ParameterReadOnlyAttribute
Implements
System.Runtime.InteropServices._Attribute
Inherited Members
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Boolean)
System.Attribute.IsDefined(System.Reflection.MemberInfo, System.Type)
System.Attribute.IsDefined(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.MemberInfo, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Boolean)
System.Attribute.IsDefined(System.Reflection.ParameterInfo, System.Type)
System.Attribute.IsDefined(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.ParameterInfo, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.Module)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.IsDefined(System.Reflection.Module, System.Type)
System.Attribute.IsDefined(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.Module, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Boolean)
System.Attribute.IsDefined(System.Reflection.Assembly, System.Type)
System.Attribute.IsDefined(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.Assembly, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.Equals(System.Object)
System.Attribute.GetHashCode()
System.Attribute.Match(System.Object)
System.Attribute.IsDefaultAttribute()
System.Attribute.System.Runtime.InteropServices._Attribute.GetTypeInfoCount(System.UInt32)
System.Attribute.System.Runtime.InteropServices._Attribute.GetTypeInfo(System.UInt32, System.UInt32, System.IntPtr)
System.Attribute.System.Runtime.InteropServices._Attribute.GetIDsOfNames(System.Guid, System.IntPtr, System.UInt32, System.UInt32, System.IntPtr)
System.Attribute.System.Runtime.InteropServices._Attribute.Invoke(System.UInt32, System.Guid, System.UInt32, System.Int16, System.IntPtr, System.IntPtr, System.IntPtr, System.IntPtr)
System.Attribute.TypeId
System.Object.ToString()
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Attributes
Assembly: fcSDK.dll
Syntax
[AttributeUsage(AttributeTargets.Parameter)]
public class ParameterReadOnlyAttribute : Attribute, _Attribute

Constructors

ParameterReadOnlyAttribute()

Declaration
public ParameterReadOnlyAttribute()

Implements

System.Runtime.InteropServices._Attribute


Class ParameterRequiredAttribute | fcSDK Documentation

Class ParameterRequiredAttribute

Inheritance
System.Object
System.Attribute
ParameterRequiredAttribute
Implements
System.Runtime.InteropServices._Attribute
Inherited Members
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Boolean)
System.Attribute.IsDefined(System.Reflection.MemberInfo, System.Type)
System.Attribute.IsDefined(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.MemberInfo, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Boolean)
System.Attribute.IsDefined(System.Reflection.ParameterInfo, System.Type)
System.Attribute.IsDefined(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.ParameterInfo, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.Module)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.IsDefined(System.Reflection.Module, System.Type)
System.Attribute.IsDefined(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.Module, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Boolean)
System.Attribute.IsDefined(System.Reflection.Assembly, System.Type)
System.Attribute.IsDefined(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.Assembly, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.Equals(System.Object)
System.Attribute.GetHashCode()
System.Attribute.Match(System.Object)
System.Attribute.IsDefaultAttribute()
System.Attribute.System.Runtime.InteropServices._Attribute.GetTypeInfoCount(System.UInt32)
System.Attribute.System.Runtime.InteropServices._Attribute.GetTypeInfo(System.UInt32, System.UInt32, System.IntPtr)
System.Attribute.System.Runtime.InteropServices._Attribute.GetIDsOfNames(System.Guid, System.IntPtr, System.UInt32, System.UInt32, System.IntPtr)
System.Attribute.System.Runtime.InteropServices._Attribute.Invoke(System.UInt32, System.Guid, System.UInt32, System.Int16, System.IntPtr, System.IntPtr, System.IntPtr, System.IntPtr)
System.Attribute.TypeId
System.Object.ToString()
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Attributes
Assembly: fcSDK.dll
Syntax
[AttributeUsage(AttributeTargets.Parameter, AllowMultiple = true)]
public class ParameterRequiredAttribute : Attribute, _Attribute

Constructors

ParameterRequiredAttribute()

Declaration
public ParameterRequiredAttribute()

ParameterRequiredAttribute(Boolean)

Declaration
public ParameterRequiredAttribute(bool isRequired)
Parameters
Type | Name | Description
System.Boolean | isRequired |

ParameterRequiredAttribute(Boolean, String)

Declaration
public ParameterRequiredAttribute(bool isReq, string method)
Parameters
Type | Name | Description
System.Boolean | isReq |
System.String | method |

ParameterRequiredAttribute(Boolean, String, Int32)

Declaration
public ParameterRequiredAttribute(bool isReq, string method, int constructorIndex)
Parameters
Type | Name | Description
System.Boolean | isReq |
System.String | method |
System.Int32 | constructorIndex |

ParameterRequiredAttribute(Boolean, String, Int32, Int32)

Declaration
public ParameterRequiredAttribute(bool isReq, string method, int constructorIndex, int positionIndex)
Parameters
Type | Name | Description
System.Boolean | isReq |
System.String | method |
System.Int32 | constructorIndex |
System.Int32 | positionIndex |

ParameterRequiredAttribute(Boolean, String, Int32, Int32, Boolean)

Declaration
public ParameterRequiredAttribute(bool isReq, string method, int constructorIndex, int positionIndex, bool isParamArray)
Parameters
Type | Name | Description
System.Boolean | isReq |
System.String | method |
System.Int32 | constructorIndex |
System.Int32 | positionIndex |
System.Boolean | isParamArray |

ParameterRequiredAttribute(String)

Declaration
public ParameterRequiredAttribute(string method)
Parameters
Type | Name | Description
System.String | method |

ParameterRequiredAttribute(String, Int32)

Declaration
public ParameterRequiredAttribute(string method, int constructorIndex)
Parameters
Type | Name | Description
System.String | method |
System.Int32 | constructorIndex |

ParameterRequiredAttribute(String, Int32, Int32)

Declaration
public ParameterRequiredAttribute(string method, int constructorIndex, int positionIndex)
Parameters
Type | Name | Description
System.String | method |
System.Int32 | constructorIndex |
System.Int32 | positionIndex |

ParameterRequiredAttribute(String, Int32, Int32, Boolean)

Declaration
public ParameterRequiredAttribute(string method, int constructorIndex, int positionIndex, bool isParamArray)
Parameters
Type | Name | Description
System.String | method |
System.Int32 | constructorIndex |
System.Int32 | positionIndex |
System.Boolean | isParamArray |

Fields

constructorIndex

Declaration
public readonly int constructorIndex
Field Value
Type | Description
System.Int32 |

isParamArray

Declaration
public readonly bool isParamArray
Field Value
Type | Description
System.Boolean |

positionIndex

Declaration
public readonly int positionIndex
Field Value
Type | Description
System.Int32 |

Properties

ConstructorIndex

Declaration
public int ConstructorIndex { get; }
Property Value
Type | Description
System.Int32 |

IsParamArray

Declaration
public bool IsParamArray { get; }
Property Value
Type | Description
System.Boolean |

IsRequired

Declaration
public bool IsRequired { get; }
Property Value
Type | Description
System.Boolean |

Method

Declaration
public string Method { get; }
Property Value
Type | Description
System.String |

PositionIndex

Declaration
public int PositionIndex { get; }
Property Value
Type | Description
System.Int32 |

Implements

System.Runtime.InteropServices._Attribute


Class ParameterVoidAttribute | fcSDK Documentation

Class ParameterVoidAttribute

Inheritance
System.Object
System.Attribute
ParameterVoidAttribute
Implements
System.Runtime.InteropServices._Attribute
Inherited Members
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Boolean)
System.Attribute.IsDefined(System.Reflection.MemberInfo, System.Type)
System.Attribute.IsDefined(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.MemberInfo, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Boolean)
System.Attribute.IsDefined(System.Reflection.ParameterInfo, System.Type)
System.Attribute.IsDefined(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.ParameterInfo, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.Module)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.IsDefined(System.Reflection.Module, System.Type)
System.Attribute.IsDefined(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.Module, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Boolean)
System.Attribute.IsDefined(System.Reflection.Assembly, System.Type)
System.Attribute.IsDefined(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.Assembly, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.Equals(System.Object)
System.Attribute.GetHashCode()
System.Attribute.Match(System.Object)
System.Attribute.IsDefaultAttribute()
System.Attribute.System.Runtime.InteropServices._Attribute.GetTypeInfoCount(System.UInt32)
System.Attribute.System.Runtime.InteropServices._Attribute.GetTypeInfo(System.UInt32, System.UInt32, System.IntPtr)
System.Attribute.System.Runtime.InteropServices._Attribute.GetIDsOfNames(System.Guid, System.IntPtr, System.UInt32, System.UInt32, System.IntPtr)
System.Attribute.System.Runtime.InteropServices._Attribute.Invoke(System.UInt32, System.Guid, System.UInt32, System.Int16, System.IntPtr, System.IntPtr, System.IntPtr, System.IntPtr)
System.Attribute.TypeId
System.Object.ToString()
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Attributes
Assembly: fcSDK.dll
Syntax
[AttributeUsage(AttributeTargets.Parameter, AllowMultiple = true)]
public class ParameterVoidAttribute : Attribute, _Attribute

Constructors

ParameterVoidAttribute()

Declaration
public ParameterVoidAttribute()

ParameterVoidAttribute(Boolean)

Declaration
public ParameterVoidAttribute(bool isVoid)
Parameters
Type | Name | Description
System.Boolean | isVoid |

ParameterVoidAttribute(Boolean, String)

Declaration
public ParameterVoidAttribute(bool isVoid, string method)
Parameters
Type | Name | Description
System.Boolean | isVoid |
System.String | method |

ParameterVoidAttribute(String)

Declaration
public ParameterVoidAttribute(string method)
Parameters
Type | Name | Description
System.String | method |

Fields

isVoid

Declaration
public readonly bool isVoid
Field Value
Type | Description
System.Boolean |

method

Declaration
public readonly string method
Field Value
Type | Description
System.String |

Properties

IsVoid

Declaration
public bool IsVoid { get; }
Property Value
Type | Description
System.Boolean |

Method

Declaration
public string Method { get; }
Property Value
Type | Description
System.String |

Implements

System.Runtime.InteropServices._Attribute


Class SplitMethodAttribute | fcSDK Documentation

Class SplitMethodAttribute

Inheritance
System.Object
System.Attribute
SplitMethodAttribute
Implements
System.Runtime.InteropServices._Attribute
Inherited Members
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Boolean)
System.Attribute.IsDefined(System.Reflection.MemberInfo, System.Type)
System.Attribute.IsDefined(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.MemberInfo, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Boolean)
System.Attribute.IsDefined(System.Reflection.ParameterInfo, System.Type)
System.Attribute.IsDefined(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.ParameterInfo, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.Module)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.IsDefined(System.Reflection.Module, System.Type)
System.Attribute.IsDefined(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.Module, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Boolean)
System.Attribute.IsDefined(System.Reflection.Assembly, System.Type)
System.Attribute.IsDefined(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.Assembly, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.Equals(System.Object)
System.Attribute.GetHashCode()
System.Attribute.Match(System.Object)
System.Attribute.IsDefaultAttribute()
System.Attribute.System.Runtime.InteropServices._Attribute.GetTypeInfoCount(System.UInt32)
System.Attribute.System.Runtime.InteropServices._Attribute.GetTypeInfo(System.UInt32, System.UInt32, System.IntPtr)
System.Attribute.System.Runtime.InteropServices._Attribute.GetIDsOfNames(System.Guid, System.IntPtr, System.UInt32, System.UInt32, System.IntPtr)
System.Attribute.System.Runtime.InteropServices._Attribute.Invoke(System.UInt32, System.Guid, System.UInt32, System.Int16, System.IntPtr, System.IntPtr, System.IntPtr, System.IntPtr)
System.Attribute.TypeId
System.Object.ToString()
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Attributes
Assembly: fcSDK.dll
Syntax
[AttributeUsage(AttributeTargets.Method, AllowMultiple = true)]
public class SplitMethodAttribute : Attribute, _Attribute

Constructors

SplitMethodAttribute(String)

Declaration
public SplitMethodAttribute(string methodName)
Parameters
Type | Name | Description
System.String | methodName |

SplitMethodAttribute(String, Int32)

Declaration
public SplitMethodAttribute(string methodName, int numOfConstructors)
Parameters
Type | Name | Description
System.String | methodName |
System.Int32 | numOfConstructors |

Properties

MethodName

Declaration
public string MethodName { get; }
Property Value
Type | Description
System.String |

NumOfConstructors

Declaration
public int NumOfConstructors { get; }
Property Value
Type | Description
System.Int32 |

Implements

System.Runtime.InteropServices._Attribute


Class ToolkitVisibleAttribute | fcSDK Documentation

Class ToolkitVisibleAttribute

Inheritance
System.Object
System.Attribute
ToolkitVisibleAttribute
Implements
System.Runtime.InteropServices._Attribute
Inherited Members
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Boolean)
System.Attribute.IsDefined(System.Reflection.MemberInfo, System.Type)
System.Attribute.IsDefined(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.MemberInfo, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Boolean)
System.Attribute.IsDefined(System.Reflection.ParameterInfo, System.Type)
System.Attribute.IsDefined(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.ParameterInfo, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.Module)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.IsDefined(System.Reflection.Module, System.Type)
System.Attribute.IsDefined(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.Module, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Boolean)
System.Attribute.IsDefined(System.Reflection.Assembly, System.Type)
System.Attribute.IsDefined(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.Assembly, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.Equals(System.Object)
System.Attribute.GetHashCode()
System.Attribute.Match(System.Object)
System.Attribute.IsDefaultAttribute()
System.Attribute.System.Runtime.InteropServices._Attribute.GetTypeInfoCount(System.UInt32)
System.Attribute.System.Runtime.InteropServices._Attribute.GetTypeInfo(System.UInt32, System.UInt32, System.IntPtr)
System.Attribute.System.Runtime.InteropServices._Attribute.GetIDsOfNames(System.Guid, System.IntPtr, System.UInt32, System.UInt32, System.IntPtr)
System.Attribute.System.Runtime.InteropServices._Attribute.Invoke(System.UInt32, System.Guid, System.UInt32, System.Int16, System.IntPtr, System.IntPtr, System.IntPtr, System.IntPtr)
System.Attribute.TypeId
System.Object.ToString()
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Attributes
Assembly: fcSDK.dll
Syntax
[AttributeUsage(AttributeTargets.Class | AttributeTargets.Struct | AttributeTargets.Method)]
public class ToolkitVisibleAttribute : Attribute, _Attribute

Constructors

ToolkitVisibleAttribute(Boolean)

Declaration
public ToolkitVisibleAttribute(bool isVisible)
Parameters
Type | Name | Description
System.Boolean | isVisible |

Fields

IsVisible

Declaration
public readonly bool IsVisible
Field Value
Type | Description
System.Boolean |

Implements

System.Runtime.InteropServices._Attribute


Namespace FChoice.Foundation.Clarify.AutoDest | fcSDK Documentation

Namespace FChoice.Foundation.Clarify.AutoDest

Classes

AutoDestRule

Back to top © 2022 Dovetail Software, Inc. - All rights reserved.
Clarify, Amdocs, and related products and names are copyright and trademark of Amdocs, Inc.
.NET, Visual Studio.NET, C#, Visual Basic and related products are trademark of Microsoft corporation.


Class AutoDestRule | fcSDK Documentation

Class AutoDestRule

Inheritance
System.Object
AutoDestRule
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.AutoDest
Assembly: fcSDK.dll
Syntax
public class AutoDestRule

Properties

IsAutoDispatch

Declaration
public bool IsAutoDispatch { get; }
Property Value
Type | Description
System.Boolean |

Operation

Declaration
public string Operation { get; set; }
Property Value
Type | Description
System.String |

RootTable

Declaration
public SchemaTable RootTable { get; set; }
Property Value
Type | Description
SchemaTable |

RuleText

Declaration
public string RuleText { get; set; }
Property Value
Type | Description
System.String |

SuccessfulRuleClause

Declaration
public string SuccessfulRuleClause { get; }
Property Value
Type | Description
System.String |

Methods

EvaluateRule(String)

Declaration
public string[] EvaluateRule(string rootIdentifier)
Parameters
Type | Name | Description
System.String | rootIdentifier |
Returns
Type | Description
System.String[] |

EvaluateRule(String, IDbTransaction)

Declaration
public string[] EvaluateRule(string rootIdentifier, IDbTransaction transaction)
Parameters
Type | Name | Description
System.String | rootIdentifier |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
System.String[] |

RetrieveRule(String, String)

Declaration
public static AutoDestRule RetrieveRule(string ruleTitle, string ruleOperation)
Parameters
Type | Name | Description
System.String | ruleTitle |
System.String | ruleOperation |
Returns
Type | Description
AutoDestRule |

RunRule(String, String, String)

Declaration
public static string[] RunRule(string ruleTitle, string ruleText, string rootObjectId)
Parameters
Type | Name | Description
System.String | ruleTitle |
System.String | ruleText |
System.String | rootObjectId |
Returns
Type | Description
System.String[] |

RunRule(String, String, String, out Boolean)

Declaration
public static string[] RunRule(string ruleTitle, string ruleText, string rootObjectId, out bool isAutoDispatch)
Parameters
Type | Name | Description
System.String | ruleTitle |
System.String | ruleText |
System.String | rootObjectId |
System.Boolean | isAutoDispatch |
Returns
Type | Description
System.String[] |

RunRule(String, String, String, out Boolean, IDbTransaction)

Declaration
public static string[] RunRule(string ruleTitle, string ruleText, string rootObjectId, out bool isAutoDispatch, IDbTransaction transaction)
Parameters
Type | Name | Description
System.String | ruleTitle |
System.String | ruleText |
System.String | rootObjectId |
System.Boolean | isAutoDispatch |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
System.String[] |

RunRule(String, String, String, IDbTransaction)

Declaration
public static string[] RunRule(string ruleTitle, string ruleText, string rootObjectId, IDbTransaction transaction)
Parameters
Type | Name | Description
System.String | ruleTitle |
System.String | ruleText |
System.String | rootObjectId |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
System.String[] |


Class ClarifyApplication | fcSDK Documentation

Class ClarifyApplication

Inheritance
System.Object
FCApplication
ClarifyApplication
Implements
IClarifyApplication
Inherited Members
FCApplication.SyncRoot
FCApplication.FCAppInitialize(CacheBase[], ISchemaCache)
FCApplication.RemoveSession(FCSession)
FCApplication.AddSessionData(FCSessionData)
FCApplication.SaveSessionData(FCSessionData)
FCApplication.GetSessionData(Guid)
FCApplication.FCAppParseConnectionString(String, String)
FCApplication.FCAppParseConnectionString(String, String, String, String, String)
FCApplication.SetInitializeComplete(Boolean)
FCApplication.CurrentSessions()
FCApplication.LogError(String, Object[])
FCApplication.LogError(Exception, String, Object[])
FCApplication.LogWarn(String, Object[])
FCApplication.LogWarn(Exception, String, Object[])
FCApplication.LogInfo(String, Object[])
FCApplication.LogInfo(Exception, String, Object[])
FCApplication.LogDebug(String, Object[])
FCApplication.LogDebug(Exception, String, Object[])
FCApplication.Log(LogLevel, String, Object[])
FCApplication.Log(LogLevel, Exception, String, Object[])
FCApplication.Deinitialize()
FCApplication.IsInitialized
FCApplication.Username
FCApplication.DatabaseVersion
FCApplication.FCAppInstance
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify
Assembly: fcSDK.dll
Syntax
public class ClarifyApplication : FCApplication, IClarifyApplication

Constructors

ClarifyApplication()

Declaration
protected ClarifyApplication()

Properties

ClarifyVersion

Declaration
public string ClarifyVersion { get; }
Property Value
Type | Description
System.String |

ConfigItemCache

Declaration
public ConfigItemCache ConfigItemCache { get; }
Property Value
Type | Description
ConfigItemCache |

ConfigItems

Declaration
public ClarifyConfigItemCollection ConfigItems { get; }
Property Value
Type | Description
ClarifyConfigItemCollection |

Configuration

Declaration
public NameValueCollection Configuration { get; }
Property Value
Type | Description
System.Collections.Specialized.NameValueCollection |

ConvertTimeZone

Declaration
public bool ConvertTimeZone { get; set; }
Property Value
Type | Description
System.Boolean |

DataRestrictionsEnabled

Declaration
public bool DataRestrictionsEnabled { get; }
Property Value
Type | Description
System.Boolean |

DBUserName

Declaration
public string DBUserName { get; }
Property Value
Type | Description
System.String |

FCAppDataRestrictionsEnabled

Declaration
protected override bool FCAppDataRestrictionsEnabled { get; }
Property Value
Type | Description
System.Boolean |
Overrides
FCApplication.FCAppDataRestrictionsEnabled

FCAppServerTimeZone

Declaration
protected override ITimeZone FCAppServerTimeZone { get; }
Property Value
Type | Description
ITimeZone |
Overrides
FCApplication.FCAppServerTimeZone

Instance

Declaration
public static ClarifyApplication Instance { get; }
Property Value
Type | Description
ClarifyApplication |

IsDbUnicode

Declaration
[Obsolete("Use the SchemaCache IsDatabaseUnicode property")]
public bool IsDbUnicode { get; }
Property Value
Type | Description
System.Boolean |

IsTravelerEnabled

Declaration
public bool IsTravelerEnabled { get; }
Property Value
Type | Description
System.Boolean |

ListCache

Declaration
public IListCache ListCache { get; }
Property Value
Type | Description
IListCache |

LocaleCache

Declaration
public ILocaleCache LocaleCache { get; }
Property Value
Type | Description
ILocaleCache |

SchemaCache

Declaration
public SchemaCache SchemaCache { get; }
Property Value
Type | Description
SchemaCache |

ServerTimeZone

Declaration
public ITimeZone ServerTimeZone { get; set; }
Property Value
Type | Description
ITimeZone |

StringCache

Declaration
public IStringCache StringCache { get; }
Property Value
Type | Description
IStringCache |

TimeZoneConversions

Declaration
public ExcludedColumns TimeZoneConversions { get; }
Property Value
Type | Description
ExcludedColumns |

TruncateStringFields

Declaration
public bool TruncateStringFields { get; set; }
Property Value
Type | Description
System.Boolean |

Methods

BeginInitialize(AsyncCallback, Object)

Declaration
public static IAsyncResult BeginInitialize(AsyncCallback callback, object state)
Parameters
Type | Name | Description
System.AsyncCallback | callback |
System.Object | state |
Returns
Type | Description
System.IAsyncResult |

CreateSession()

Declaration
public ClarifySession CreateSession()
Returns
Type | Description
ClarifySession |

CreateSession(String, ClarifyLoginType)

Declaration
public virtual ClarifySession CreateSession(string userName, ClarifyLoginType loginType)
Parameters
Type | Name | Description
System.String | userName |
ClarifyLoginType | loginType |
Returns
Type | Description
ClarifySession |

CreateSession(String, String, ClarifyLoginType)

Declaration
public virtual ClarifySession CreateSession(string userName, string password, ClarifyLoginType loginType)
Parameters
Type | Name | Description
System.String | userName |
System.String | password |
ClarifyLoginType | loginType |
Returns
Type | Description
ClarifySession |

CreateSessionData()

Declaration
protected virtual ClarifySessionData CreateSessionData()
Returns
Type | Description
ClarifySessionData |

EncryptClarifyPassword(String)

Declaration
public string EncryptClarifyPassword(string password)
Parameters
Type | Name | Description
System.String | password |
Returns
Type | Description
System.String |

EncryptDBPassword(String)

Declaration
public string EncryptDBPassword(string password)
Parameters
Type | Name | Description
System.String | password |
Returns
Type | Description
System.String |

EndInitialize(IAsyncResult)

Declaration
public static ClarifyApplication EndInitialize(IAsyncResult result)
Parameters
Type | Name | Description
System.IAsyncResult | result |
Returns
Type | Description
ClarifyApplication |

GetMtmTableName(SchemaRelation)

Declaration
public string GetMtmTableName(SchemaRelation relation)
Parameters
Type | Name | Description
SchemaRelation | relation |
Returns
Type | Description
System.String |

GetObjID(String)

Declaration
public int GetObjID(string tableName)
Parameters
Type | Name | Description
System.String | tableName |
Returns
Type | Description
System.Int32 |

GetObjIdsFromFCStoredProcedure(Int32, Int32, Int32)

Declaration
public static int[] GetObjIdsFromFCStoredProcedure(int numberOfIdRequested, int clarifyBaseObjId, int objectTypeId)
Parameters
Type | Name | Description
System.Int32 | numberOfIdRequested |
System.Int32 | clarifyBaseObjId |
System.Int32 | objectTypeId |
Returns
Type | Description
System.Int32[] |

GetSession(Guid)

Declaration
public virtual ClarifySession GetSession(Guid sessionID)
Parameters
Type | Name | Description
System.Guid | sessionID |
Returns
Type | Description
ClarifySession |

Initialize()

Declaration
public static ClarifyApplication Initialize()
Returns
Type | Description
ClarifyApplication |

Initialize(NameValueCollection)

Declaration
public static ClarifyApplication Initialize(NameValueCollection configValues)
Parameters
Type | Name | Description
System.Collections.Specialized.NameValueCollection | configValues |
Returns
Type | Description
ClarifyApplication |

InitializeInternal(NameValueCollection, CacheBase[], ISchemaCache)

Declaration
protected void InitializeInternal(NameValueCollection configValues, CacheBase[] caches, ISchemaCache schemaMaster)
Parameters
Type | Name | Description
System.Collections.Specialized.NameValueCollection | configValues |
CacheBase[] | caches |
ISchemaCache | schemaMaster |

IsSessionValid(Guid)

Declaration
public bool IsSessionValid(Guid sessionID)
Parameters
Type | Name | Description
System.Guid | sessionID |
Returns
Type | Description
System.Boolean |

ParseConnectionString(out String, out String)

Declaration
protected NameValueCollection ParseConnectionString(out string username, out string password)
Parameters
Type | Name | Description
System.String | username |
System.String | password |
Returns
Type | Description
System.Collections.Specialized.NameValueCollection |

ParseConnectionString(out String, out String, out String, out String, out String)

Declaration
protected NameValueCollection ParseConnectionString(out string username, out string password, out string usernameKey, out string passwordKey, out string integratedSecurityKey)
Parameters
Type | Name | Description
System.String | username |
System.String | password |
System.String | usernameKey |
System.String | passwordKey |
System.String | integratedSecurityKey |
Returns
Type | Description
System.Collections.Specialized.NameValueCollection |

ValidateEncryptedPassword(String, String, Boolean)

Declaration
public static bool ValidateEncryptedPassword(string password, string passHash, bool pre9)
Parameters
Type | Name | Description
System.String | password |
System.String | passHash |
System.Boolean | pre9 |
Returns
Type | Description
System.Boolean |

Events

InitializeStatusChange

Declaration
public static event InitializeStatusChangeEventHandler InitializeStatusChange
Event Type
Type | Description
InitializeStatusChangeEventHandler |

Implements

IClarifyApplication


Class ClarifyAuthenticationResult | fcSDK Documentation

Class ClarifyAuthenticationResult

Inheritance
System.Object
ClarifyAuthenticationResult
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify
Assembly: fcSDK.dll
Syntax
public class ClarifyAuthenticationResult

Constructors

ClarifyAuthenticationResult()

Declaration
public ClarifyAuthenticationResult()

Properties

PasswordUsed

Declaration
public string PasswordUsed { get; set; }
Property Value
Type | Description
System.String |

Success

Declaration
public bool Success { get; set; }
Property Value
Type | Description
System.Boolean |


Class ClarifyAuthenticationService | fcSDK Documentation

Class ClarifyAuthenticationService

Inheritance
System.Object
ClarifyAuthenticationService
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify
Assembly: fcSDK.dll
Syntax
public class ClarifyAuthenticationService

Constructors

ClarifyAuthenticationService()

Declaration
public ClarifyAuthenticationService()

Methods

AuthenticateUser(String, String)

Declaration
public ClarifyAuthenticationResult AuthenticateUser(string username, string password)
Parameters
Type | Name | Description
System.String | username |
System.String | password |
Returns
Type | Description
ClarifyAuthenticationResult |

ReconstructConnectString(String, String)

Declaration
public static string ReconstructConnectString(string inUsername, string encPassword)
Parameters
Type | Name | Description
System.String | inUsername |
System.String | encPassword |
Returns
Type | Description
System.String |


Class ClarifyCacheBase | fcSDK Documentation

Class ClarifyCacheBase

Inheritance
System.Object
CacheBase
ClarifyCacheBase
ConfigItemCache
ListCache
LocaleCache
SchemaCache
StringCache
Inherited Members
CacheBase.UpdateSyncRoot
CacheBase.OnCacheUpdated()
CacheBase.OnAnyCacheUpdated(CacheBase)
CacheBase.SetNameAndParameters(String, String)
CacheBase.UpdateCache()
CacheBase.ReadCacheData(String)
CacheBase.PersistCacheData(Object, String)
CacheBase.GetCacheDataHash()
CacheBase.GenerateMD5Hash(String)
CacheBase.InitCacheData()
CacheBase.LoadCacheData(Object)
CacheBase.AllTablesExistInDataSet(DataSet, String[])
CacheBase.GetCacheFilePath(String)
CacheBase.CacheType
CacheBase.CacheSetName
CacheBase.AnyCacheUpdated
CacheBase.CacheUpdated
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify
Assembly: fcSDK.dll
Syntax
public abstract class ClarifyCacheBase : CacheBase

Constructors

ClarifyCacheBase()

Declaration
protected ClarifyCacheBase()

Methods

IsCacheOutOfDate(DateTime)

Declaration
protected override bool IsCacheOutOfDate(DateTime testDate)
Parameters
Type | Name | Description
System.DateTime | testDate |
Returns
Type | Description
System.Boolean |
Overrides
CacheBase.IsCacheOutOfDate(DateTime)


Class ClarifyDataRow | fcSDK Documentation

Class ClarifyDataRow

Inheritance
System.Object
GenericDataRow
ClarifyDataRow
Inherited Members
GenericDataRow.parentTable
GenericDataRow.parentGeneric
GenericDataRow.isAddForUpdate
GenericDataRow.forcedUpdateCols
GenericDataRow.IsForcedUpdateColumn(DataColumn)
GenericDataRow.Update()
GenericDataRow.Update(UpdateQueryBatch)
GenericDataRow.Update(IDbTransaction)
GenericDataRow.SetBaseColumn(DataColumn, Object)
GenericDataRow.RelateToIntField(GenericDataRow, String)
GenericDataRow.RelateByID(Object, String)
GenericDataRow.RelateRecord(GenericDataRow, String)
GenericDataRow.AreIDsEqual(Object, Object)
GenericDataRow.Unrelate(GenericDataRow, String)
GenericDataRow.UnrelateFromAll(String)
GenericDataRow.BaseParentGeneric
GenericDataRow.IsAddForUpdate
GenericDataRow.ForcedUpdateColumns
GenericDataRow.RowGuid
GenericDataRow.Item[DataColumn, DataRowVersion]
GenericDataRow.Item[Int32, DataRowVersion]
GenericDataRow.Item[String, DataRowVersion]
GenericDataRow.Item[DataColumn]
GenericDataRow.Item[Int32]
GenericDataRow.Item[String]
GenericDataRow.UniqueID
GenericDataRow.IsNew
Namespace: FChoice.Foundation.Clarify
Assembly: fcSDK.dll
Syntax
public class ClarifyDataRow : GenericDataRow

Constructors

ClarifyDataRow(DataRowBuilder)

Declaration
protected ClarifyDataRow(DataRowBuilder rb)
Parameters
Type | Name | Description
System.Data.DataRowBuilder | rb |

Properties

ParentGeneric

Declaration
public ClarifyGeneric ParentGeneric { get; }
Property Value
Type | Description
ClarifyGeneric |

Table

Declaration
public ClarifyDataTable Table { get; }
Property Value
Type | Description
ClarifyDataTable |

Methods

ProcessGetColumn(Object, DataColumn)

Declaration
protected override object ProcessGetColumn(object obj, DataColumn column)
Parameters
Type | Name | Description
System.Object | obj |
System.Data.DataColumn | column |
Returns
Type | Description
System.Object |
Overrides
GenericDataRow.ProcessGetColumn(Object, DataColumn)

ProcessSetColumn(Object, DataColumn)

Declaration
protected override void ProcessSetColumn(object obj, DataColumn column)
Parameters
Type | Name | Description
System.Object | obj |
System.Data.DataColumn | column |
Overrides
GenericDataRow.ProcessSetColumn(Object, DataColumn)

RelatedRows(ClarifyGeneric)

Declaration
public ClarifyDataRow[] RelatedRows(ClarifyGeneric otherGen)
Parameters
Type | Name | Description
ClarifyGeneric | otherGen |
Returns
Type | Description
ClarifyDataRow[] |


Class ClarifyDataSet | fcSDK Documentation

Class ClarifyDataSet

Inheritance
System.Object
GenericDataSet
ClarifyDataSet
Inherited Members
GenericDataSet.Query(FCGeneric[])
GenericDataSet.Query(IDbTransaction, FCGeneric[])
GenericDataSet.Update(FCGeneric[])
GenericDataSet.Update(IDbTransaction, FCGeneric[])
GenericDataSet.RestrictionGroup
GenericDataSet.UniqueID
GenericDataSet.DataSet
GenericDataSet.SortGenerics
GenericDataSet.FCSession
GenericDataSet.ListComparer
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify
Assembly: fcSDK.dll
Syntax
public class ClarifyDataSet : GenericDataSet

Constructors

ClarifyDataSet(ClarifySession)

Declaration
public ClarifyDataSet(ClarifySession session)
Parameters
Type | Name | Description
ClarifySession | session |

Fields

orderComparer

Declaration
protected static ClarifyDataSet.TableNumOrderComparer orderComparer
Field Value
Type | Description
ClarifyDataSet.TableNumOrderComparer |

Properties

Session

Declaration
public ClarifySession Session { get; }
Property Value
Type | Description
ClarifySession |

Methods

CreateGeneric(ClarifyGeneric, String)

Declaration
protected virtual ClarifyGeneric CreateGeneric(ClarifyGeneric parent, string parentRelation)
Parameters
Type | Name | Description
ClarifyGeneric | parent |
System.String | parentRelation |
Returns
Type | Description
ClarifyGeneric |

CreateGeneric(Int32, String, String)

Declaration
public virtual ClarifyGeneric CreateGeneric(int rootObjID, string rootObject, string relFromParent)
Parameters
Type | Name | Description
System.Int32 | rootObjID |
System.String | rootObject |
System.String | relFromParent |
Returns
Type | Description
ClarifyGeneric |

CreateGeneric(String)

Declaration
public virtual ClarifyGeneric CreateGeneric(string tableName)
Parameters
Type | Name | Description
System.String | tableName |
Returns
Type | Description
ClarifyGeneric |


Class ClarifyDataSet.TableNumOrderComparer | fcSDK Documentation

Class ClarifyDataSet.TableNumOrderComparer

Inheritance
System.Object
ClarifyDataSet.TableNumOrderComparer
Implements
System.Collections.IComparer
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify
Assembly: fcSDK.dll
Syntax
protected class TableNumOrderComparer : IComparer

Constructors

TableNumOrderComparer()

Declaration
public TableNumOrderComparer()

Methods

Compare(Object, Object)

Declaration
public int Compare(object x, object y)
Parameters
Type | Name | Description
System.Object | x |
System.Object | y |
Returns
Type | Description
System.Int32 |

Implements

System.Collections.IComparer


Class ClarifyDataTable | fcSDK Documentation

Class ClarifyDataTable

Inheritance
System.Object
GenericDataTable
ClarifyDataTable
Implements
System.Collections.IEnumerable
Inherited Members
GenericDataTable.GetEnumerator()
GenericDataTable.BaseRows
GenericDataTable.IsMtmTable
GenericDataTable.FCGeneric
GenericDataTable.Count
GenericDataTable.InnerRows
Namespace: FChoice.Foundation.Clarify
Assembly: fcSDK.dll
Syntax
public class ClarifyDataTable : GenericDataTable, IEnumerable

Constructors

ClarifyDataTable(String)

Declaration
protected ClarifyDataTable(string tableName)
Parameters
Type | Name | Description
System.String | tableName |

ClarifyDataTable(String, ClarifyGeneric)

Declaration
protected ClarifyDataTable(string tableName, ClarifyGeneric generic)
Parameters
Type | Name | Description
System.String | tableName |
ClarifyGeneric | generic |

Properties

Generic

Declaration
public ClarifyGeneric Generic { get; }
Property Value
Type | Description
ClarifyGeneric |

Item[Int32]

Declaration
public ClarifyDataRow this[int index] { get; }
Parameters
Type | Name | Description
System.Int32 | index |
Property Value
Type | Description
ClarifyDataRow |

Rows

Declaration
public ClarifyRowCollection Rows { get; }
Property Value
Type | Description
ClarifyRowCollection |

Methods

CreateInstance()

Declaration
protected override DataTable CreateInstance()
Returns
Type | Description
System.Data.DataTable |

CreateRowCollection()

Declaration
protected override GenericDataRowCollection CreateRowCollection()
Returns
Type | Description
GenericDataRowCollection |
Overrides
GenericDataTable.CreateRowCollection()

GetRowType()

Declaration
protected override Type GetRowType()
Returns
Type | Description
System.Type |

NewRowFromBuilder(DataRowBuilder)

Declaration
protected override DataRow NewRowFromBuilder(DataRowBuilder builder)
Parameters
Type | Name | Description
System.Data.DataRowBuilder | builder |
Returns
Type | Description
System.Data.DataRow |

Implements

System.Collections.IEnumerable


Class ClarifyException | fcSDK Documentation

Class ClarifyException

Inheritance
System.Object
System.Exception
System.ApplicationException
FCExceptionBase
ClarifyException
Implements
System.Runtime.InteropServices._Exception
System.Runtime.Serialization.ISerializable
Inherited Members
FCExceptionBase.SetMessageProvider(IErrorMessageProvider)
FCExceptionBase.GetResourceData()
FCExceptionBase.GetErrorMessageFormat(Object, String)
FCExceptionBase.FormatMessage(String, String, Object[])
FCExceptionBase.LoadErrorResourceSet(String)
FCExceptionBase.GetObjectData(SerializationInfo, StreamingContext)
FCExceptionBase.MessageProvider
FCExceptionBase.ErrorCode
FCExceptionBase.ErrorMessageID
FCExceptionBase.Message
System.Exception.GetBaseException()
System.Exception.ToString()
System.Exception.GetType()
System.Exception.Data
System.Exception.InnerException
System.Exception.TargetSite
System.Exception.StackTrace
System.Exception.HelpLink
System.Exception.Source
System.Exception.HResult
System.Exception.SerializeObjectState
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify
Assembly: fcSDK.dll
Syntax
public class ClarifyException : FCExceptionBase, _Exception, ISerializable

Constructors

ClarifyException(SerializationInfo, StreamingContext)

Declaration
protected ClarifyException(SerializationInfo info, StreamingContext context)
Parameters
Type | Name | Description
System.Runtime.Serialization.SerializationInfo | info |
System.Runtime.Serialization.StreamingContext | context |

Implements

System.Runtime.InteropServices._Exception
System.Runtime.Serialization.ISerializable


Class ClarifyGeneric | fcSDK Documentation

Class ClarifyGeneric

Inheritance
System.Object
FCGeneric
ClarifyGeneric
Implements
System.Collections.ICollection
System.Collections.IEnumerable
System.ComponentModel.IListSource
Inherited Members
FCGeneric.FILTER_LIKE
FCGeneric.FILTER_NOT_LIKE
FCGeneric.FILTER_SOUNDS_LIKE
FCGeneric.FILTER_EQUAL
FCGeneric.FILTER_NOT_EQUAL
FCGeneric.FILTER_LESS_THAN
FCGeneric.FILTER_GREATER_THAN
FCGeneric.FILTER_LESS_THAN_EQUAL
FCGeneric.FILTER_GREATER_THAN_EQUAL
FCGeneric.FILTER_IS_NULL
FCGeneric.FILTER_IS_NOT_NULL
FCGeneric.FILTER_IS_IN
FCGeneric.FILTER_IS_NOT_IN
FCGeneric.EXCLUSIVE_REL_TABLEIDFIELDNAME
FCGeneric.INCLUDE_MTM_PARENT_FIELDNAME
FCGeneric.NOW_DATE
FCGeneric.MIN_DATE
FCGeneric.MAX_DATE
FCGeneric.schemaTable
FCGeneric.ChangeRestrictionGroup(String)
FCGeneric.PerformAddToParentGeneric(FCGeneric, ISchemaRelation)
FCGeneric.ClearRoot()
FCGeneric.BaseTraverseFromRoot(Object, String, String)
FCGeneric.BaseTraverseFromParent(FCGeneric, String)
FCGeneric.Traverse(FCGeneric, String)
FCGeneric.UnTraverse()
FCGeneric.OnMaximumRowsExceeded(Int32, MaximumRowsExceededEventArgs)
FCGeneric.SetTableName(String)
FCGeneric.CloseGeneric()
FCGeneric.AddForUpdate(Object)
FCGeneric.ValidateAddNew()
FCGeneric.BaseDeleteById(Object)
FCGeneric.AppendSort(String, Boolean)
FCGeneric.AppendSort(String, Boolean, Boolean)
FCGeneric.AppendFilter(String, Boolean)
FCGeneric.AppendFilter(String, NumberOps, Int32)
FCGeneric.AppendFilter(String, NumberOps, Decimal)
FCGeneric.AppendFilter(String, DateOps, DateTime)
FCGeneric.AppendFilter(String, StringOps, String)
FCGeneric.AppendFilterBetween(String, Boolean, Int32, Int32)
FCGeneric.AppendFilterBetween(String, Boolean, Decimal, Decimal)
FCGeneric.AppendFilterBetween(String, Boolean, DateTime, DateTime)
FCGeneric.AppendFilterInList(String, Boolean, Int32[])
FCGeneric.AppendFilterInList(String, Boolean, Decimal[])
FCGeneric.AppendFilterInList(String, Boolean, DateTime[])
FCGeneric.AppendFilterInList(String, Boolean, String[])
FCGeneric.AppendFilterIsNull(String, Boolean)
FCGeneric.ClearFilters()
FCGeneric.ClearSorts()
FCGeneric.DeleteAll()
FCGeneric.Update(GenericDataRow)
FCGeneric.Update(GenericDataRow, IDbTransaction)
FCGeneric.Update(GenericDataRow, UpdateQueryBatch)
FCGeneric.UpdateAll()
FCGeneric.UpdateAll(UpdateQueryBatch)
FCGeneric.ProcessBindings(IDictionary<FCGeneric, IDictionary<Guid, GenericDataRow>>, UpdateQueryBatch)
FCGeneric.AssignAllObjIDs(IEnumerable<GenericDataRow>)
FCGeneric.AssignObjID(GenericDataRow)
FCGeneric.CopyTo(Array, Int32)
FCGeneric.GetEnumerator()
FCGeneric.RestrictionGroup
FCGeneric.BaseSession
FCGeneric.BaseDataSet
FCGeneric.BaseSortList
FCGeneric.BaseRootObjectID
FCGeneric.BaseIsTraverseFromRoot
FCGeneric.BaseDataTable
FCGeneric.IsOracleProvider
FCGeneric.DataSetTableName
FCGeneric.BaseRows
FCGeneric.BaseResults
FCGeneric.Bindings
FCGeneric.BaseSchemaTable
FCGeneric.BaseParentGeneric
FCGeneric.ChildGenerics
FCGeneric.BaseChildGenerics
FCGeneric.BaseParentRelation
FCGeneric.Filter
FCGeneric.DeleteRelationsToUnrelate
FCGeneric.MaximumRows
FCGeneric.Count
FCGeneric.TableName
FCGeneric.SetNullStringsToEmpty
FCGeneric.IsDistinct
FCGeneric.RawFilter
FCGeneric.DataFields
FCGeneric.DataRestrictionsEnabled
FCGeneric.IncludeRelations
FCGeneric.QueryEmptyToNull
FCGeneric.IsSynchronized
FCGeneric.SyncRoot
FCGeneric.MaximumRowsExceeded
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify
Assembly: fcSDK.dll
Syntax
public class ClarifyGeneric : FCGeneric, ICollection, IEnumerable, IListSource

Constructors

ClarifyGeneric(ClarifyDataSet)

Declaration
protected ClarifyGeneric(ClarifyDataSet parentData)
Parameters
Type | Name | Description
ClarifyDataSet | parentData |

ClarifyGeneric(ClarifyDataSet, ClarifyGeneric, String)

Declaration
protected ClarifyGeneric(ClarifyDataSet parentData, ClarifyGeneric parent, string relationName)
Parameters
Type | Name | Description
ClarifyDataSet | parentData |
ClarifyGeneric | parent |
System.String | relationName |

ClarifyGeneric(ClarifyDataSet, Int32, String, String)

Declaration
protected ClarifyGeneric(ClarifyDataSet parentData, int rootObjId, string rootObjName, string relFromParent)
Parameters
Type | Name | Description
ClarifyDataSet | parentData |
System.Int32 | rootObjId |
System.String | rootObjName |
System.String | relFromParent |

ClarifyGeneric(ClarifyDataSet, String)

Declaration
protected ClarifyGeneric(ClarifyDataSet parentData, string tableName)
Parameters
Type | Name | Description
ClarifyDataSet | parentData |
System.String | tableName |

Fields

GuidColumnName

Declaration
public static readonly string GuidColumnName
Field Value
Type | Description
System.String |

Properties

DataSet

Declaration
public ClarifyDataSet DataSet { get; }
Property Value
Type | Description
ClarifyDataSet |

DefaultObjectIdValue

Declaration
protected override object DefaultObjectIdValue { get; }
Property Value
Type | Description
System.Object |
Overrides
FCGeneric.DefaultObjectIdValue

Item[Int32]

Declaration
public ClarifyDataRow this[int index] { get; }
Parameters
Type | Name | Description
System.Int32 | index |
Property Value
Type | Description
ClarifyDataRow |

Log

Declaration
protected override Logger Log { get; }
Property Value
Type | Description
Logger |
Overrides
FCGeneric.Log

ObjectIdFieldName

Declaration
protected override string ObjectIdFieldName { get; }
Property Value
Type | Description
System.String |
Overrides
FCGeneric.ObjectIdFieldName

ParentGeneric

Declaration
public ClarifyGeneric ParentGeneric { get; }
Property Value
Type | Description
ClarifyGeneric |

ParentRelation

Declaration
public SchemaRelation ParentRelation { get; }
Property Value
Type | Description
SchemaRelation |

Results

Declaration
protected ClarifyDataTable Results { get; }
Property Value
Type | Description
ClarifyDataTable |

Rows

Declaration
public ClarifyRowCollection Rows { get; }
Property Value
Type | Description
ClarifyRowCollection |

SchemaTable

Declaration
public SchemaTableBase SchemaTable { get; }
Property Value
Type | Description
SchemaTableBase |

SearchableFieldPrefix

Declaration
public override string SearchableFieldPrefix { get; }
Property Value
Type | Description
System.String |
Overrides
FCGeneric.SearchableFieldPrefix

Session

Declaration
public ClarifySession Session { get; }
Property Value
Type | Description
ClarifySession |

Methods

AddColumn(DataTable, SchemaRelation)

Declaration
protected DataColumn AddColumn(DataTable dt, SchemaRelation rel)
Parameters
Type | Name | Description
System.Data.DataTable | dt |
SchemaRelation | rel |
Returns
Type | Description
System.Data.DataColumn |

AddColumn(DataTable, ISchemaField)

Declaration
protected DataColumn AddColumn(DataTable dt, ISchemaField field)
Parameters
Type | Name | Description
System.Data.DataTable | dt |
ISchemaField | field |
Returns
Type | Description
System.Data.DataColumn |

AddColumn(DataTable, String)

Declaration
protected DataColumn AddColumn(DataTable dt, string fieldName)
Parameters
Type | Name | Description
System.Data.DataTable | dt |
System.String | fieldName |
Returns
Type | Description
System.Data.DataColumn |

AddForUpdate(Int32)

Declaration
public ClarifyDataRow AddForUpdate(int objId)
Parameters
Type | Name | Description
System.Int32 | objId |
Returns
Type | Description
ClarifyDataRow |

AddNew()

Declaration
public ClarifyDataRow AddNew()
Returns
Type | Description
ClarifyDataRow |

AddNew(ClarifyDataRow)

Declaration
public ClarifyDataRow AddNew(ClarifyDataRow rowToDuplicate)
Parameters
Type | Name | Description
ClarifyDataRow | rowToDuplicate |
Returns
Type | Description
ClarifyDataRow |

AssignAllObjIDs(ClarifyDataRow[])

Declaration
public void AssignAllObjIDs(ClarifyDataRow[] rows)
Parameters
Type | Name | Description
ClarifyDataRow[] | rows |

BuildObjIdString(SqlHelper, String, String, Int32[])

Declaration
protected string BuildObjIdString(SqlHelper dbHelper, string fieldName, string format, int[] relatedObjIds)
Parameters
Type | Name | Description
SqlHelper | dbHelper |
System.String | fieldName |
System.String | format |
System.Int32[] | relatedObjIds |
Returns
Type | Description
System.String |

BuildSortStatement()

Declaration
protected string BuildSortStatement()
Returns
Type | Description
System.String |

BuildSortStatement(Boolean)

Declaration
protected string BuildSortStatement(bool includePrefix)
Parameters
Type | Name | Description
System.Boolean | includePrefix |
Returns
Type | Description
System.String |

CreateEmptyMtmTable(ClarifyGeneric, SchemaRelation)

Declaration
protected ClarifyDataTable CreateEmptyMtmTable(ClarifyGeneric childGeneric, SchemaRelation relation)
Parameters
Type | Name | Description
ClarifyGeneric | childGeneric |
SchemaRelation | relation |
Returns
Type | Description
ClarifyDataTable |

CreateTraversedGeneric(String)

Declaration
protected virtual ClarifyGeneric CreateTraversedGeneric(string relationName)
Parameters
Type | Name | Description
System.String | relationName |
Returns
Type | Description
ClarifyGeneric |

DeleteById(Int32)

Declaration
public void DeleteById(int objId)
Parameters
Type | Name | Description
System.Int32 | objId |

GetRelation(ClarifyGeneric, out Boolean, out Boolean)

Declaration
protected ISchemaRelation GetRelation(ClarifyGeneric otherGeneric, out bool thisIsDBParent, out bool thisIsParentGeneric)
Parameters
Type | Name | Description
ClarifyGeneric | otherGeneric |
System.Boolean | thisIsDBParent |
System.Boolean | thisIsParentGeneric |
Returns
Type | Description
ISchemaRelation |

GetRelationName(ClarifyGeneric, ClarifyGeneric, ISchemaRelation)

Declaration
protected static string GetRelationName(ClarifyGeneric parentGen, ClarifyGeneric childGen, ISchemaRelation rel)
Parameters
Type | Name | Description
ClarifyGeneric | parentGen |
ClarifyGeneric | childGen |
ISchemaRelation | rel |
Returns
Type | Description
System.String |

PerformAddNew()

Declaration
protected override GenericDataRow PerformAddNew()
Returns
Type | Description
GenericDataRow |
Overrides
FCGeneric.PerformAddNew()

PerformAssignObjID(GenericDataRow)

Declaration
protected override void PerformAssignObjID(GenericDataRow row)
Parameters
Type | Name | Description
GenericDataRow | row |
Overrides
FCGeneric.PerformAssignObjID(GenericDataRow)

PerformDeletes(IDictionary<Guid, GenericDataRow>, UpdateQueryBatch)

Declaration
protected override void PerformDeletes(IDictionary<Guid, GenericDataRow> deletedRows, UpdateQueryBatch batch)
Parameters
Type | Name | Description
System.Collections.Generic.IDictionary<System.Guid, GenericDataRow> | deletedRows |
UpdateQueryBatch | batch |
Overrides
FCGeneric.PerformDeletes(IDictionary<Guid, GenericDataRow>, UpdateQueryBatch)

PerformSetTableName(String)

Declaration
protected override void PerformSetTableName(string value)
Parameters
Type | Name | Description
System.String | value |
Overrides
FCGeneric.PerformSetTableName(String)

PerformUpdate(GenericDataRow, UpdateQueryBatch)

Declaration
protected override void PerformUpdate(GenericDataRow row, UpdateQueryBatch batch)
Parameters
Type | Name | Description
GenericDataRow | row |
UpdateQueryBatch | batch |
Overrides
FCGeneric.PerformUpdate(GenericDataRow, UpdateQueryBatch)

Query()

Declaration
public override void Query()
Overrides
FCGeneric.Query()

Query(IDbTransaction)

Declaration
public override void Query(IDbTransaction transaction)
Parameters
Type | Name | Description
System.Data.IDbTransaction | transaction |
Overrides
FCGeneric.Query(IDbTransaction)

RelateGeneric(FCGeneric, ISchemaRelation)

Declaration
protected override void RelateGeneric(FCGeneric childGeneric, ISchemaRelation relation)
Parameters
Type | Name | Description
FCGeneric | childGeneric |
ISchemaRelation | relation |
Overrides
FCGeneric.RelateGeneric(FCGeneric, ISchemaRelation)

SetupDataTable()

Declaration
protected override void SetupDataTable()
Overrides
FCGeneric.SetupDataTable()

Traverse(String)

Declaration
public ClarifyGeneric Traverse(string relationName)
Parameters
Type | Name | Description
System.String | relationName |
Returns
Type | Description
ClarifyGeneric |

TraverseFromParent(ClarifyGeneric, String)

Declaration
public void TraverseFromParent(ClarifyGeneric parentGeneric, string relationName)
Parameters
Type | Name | Description
ClarifyGeneric | parentGeneric |
System.String | relationName |

TraverseFromRoot(Int32, String, String)

Declaration
public void TraverseFromRoot(int rootObjID, string rootObject, string relationName)
Parameters
Type | Name | Description
System.Int32 | rootObjID |
System.String | rootObject |
System.String | relationName |

WasRowAdded(GenericDataRow)

Declaration
protected bool WasRowAdded(GenericDataRow row)
Parameters
Type | Name | Description
GenericDataRow | row |
Returns
Type | Description
System.Boolean |

Implements

System.Collections.ICollection
System.Collections.IEnumerable
System.ComponentModel.IListSource


Class ClarifyGenericException | fcSDK Documentation

Class ClarifyGenericException

Inheritance
System.Object
System.Exception
System.ApplicationException
FCExceptionBase
FoundationException
GenericException
ClarifyGenericException
Implements
System.Runtime.InteropServices._Exception
System.Runtime.Serialization.ISerializable
Inherited Members
FCExceptionBase.SetMessageProvider(IErrorMessageProvider)
FCExceptionBase.GetResourceData()
FCExceptionBase.GetErrorMessageFormat(Object, String)
FCExceptionBase.FormatMessage(String, String, Object[])
FCExceptionBase.LoadErrorResourceSet(String)
FCExceptionBase.GetObjectData(SerializationInfo, StreamingContext)
FCExceptionBase.MessageProvider
FCExceptionBase.ErrorCode
FCExceptionBase.ErrorMessageID
FCExceptionBase.Message
System.Exception.GetBaseException()
System.Exception.ToString()
System.Exception.GetType()
System.Exception.Data
System.Exception.InnerException
System.Exception.TargetSite
System.Exception.StackTrace
System.Exception.HelpLink
System.Exception.Source
System.Exception.HResult
System.Exception.SerializeObjectState
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify
Assembly: fcSDK.dll
Syntax
public class ClarifyGenericException : GenericException, _Exception, ISerializable

Constructors

ClarifyGenericException(Int32, String)

Declaration
protected ClarifyGenericException(int errorId, string messageId)
Parameters
Type | Name | Description
System.Int32 | errorId |
System.String | messageId |

ClarifyGenericException(Int32, String, Object[])

Declaration
protected ClarifyGenericException(int errorId, string messageId, params object[] args)
Parameters
Type | Name | Description
System.Int32 | errorId |
System.String | messageId |
System.Object[] | args |

ClarifyGenericException(SerializationInfo, StreamingContext)

Declaration
protected ClarifyGenericException(SerializationInfo info, StreamingContext context)
Parameters
Type | Name | Description
System.Runtime.Serialization.SerializationInfo | info |
System.Runtime.Serialization.StreamingContext | context |

Implements

System.Runtime.InteropServices._Exception
System.Runtime.Serialization.ISerializable


Enum ClarifyLoginType | fcSDK Documentation

Enum ClarifyLoginType

Namespace: FChoice.Foundation.Clarify
Assembly: fcSDK.dll
Syntax
public enum ClarifyLoginType

Fields

Name | Description
Contact |
User |


Class ClarifyRowCollection | fcSDK Documentation

Class ClarifyRowCollection

Inheritance
System.Object
GenericDataRowCollection
ClarifyRowCollection
Implements
System.Collections.ICollection
System.Collections.IEnumerable
Inherited Members
GenericDataRowCollection.Add(GenericDataRow)
GenericDataRowCollection.Contains(Object[])
GenericDataRowCollection.Contains(Object)
GenericDataRowCollection.Find(Object[])
GenericDataRowCollection.Find(Object)
GenericDataRowCollection.CopyTo(Array, Int32)
GenericDataRowCollection.GetEnumerator()
GenericDataRowCollection.BaseRows
GenericDataRowCollection.IsSynchronized
GenericDataRowCollection.Count
GenericDataRowCollection.SyncRoot
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify
Assembly: fcSDK.dll
Syntax
public class ClarifyRowCollection : GenericDataRowCollection, ICollection, IEnumerable

Constructors

ClarifyRowCollection(ClarifyDataTable, DataRowCollection)

Declaration
protected ClarifyRowCollection(ClarifyDataTable parentTable, DataRowCollection tableBaseRows)
Parameters
Type | Name | Description
ClarifyDataTable | parentTable |
System.Data.DataRowCollection | tableBaseRows |

Properties

Item[Int32]

Declaration
public ClarifyDataRow this[int index] { get; }
Parameters
Type | Name | Description
System.Int32 | index |
Property Value
Type | Description
ClarifyDataRow |

Table

Declaration
public ClarifyDataTable Table { get; }
Property Value
Type | Description
ClarifyDataTable |

Implements

System.Collections.ICollection
System.Collections.IEnumerable


Class ClarifySession | fcSDK Documentation

Class ClarifySession

Inheritance
System.Object
FCSession
ClarifySession
Implements
System.IDisposable
Inherited Members
FCSession.InitializeSession(FCSessionData)
FCSession.ResetSessionLoginStatus()
FCSession.LoginFromApp()
FCSession.LoginInternal(String, String, Int32, Boolean, Boolean, Boolean)
FCSession.LoadSessionDataFromApplicationCache(Guid)
FCSession._GetNextDataTableId()
FCSession.RegisterLicenseRequirements(Int32)
FCSession.CloseSession()
FCSession.CloseSession(Boolean)
FCSession.Dispose()
FCSession.SaveSession()
FCSession.GetCurrentServerDate()
FCSession.FormatElapsedTime(Int32)
FCSession.FormatElapsedTime(Double)
FCSession.FormatElapsedTime(TimeSpan)
FCSession.SetPassword(String, String, Int32)
FCSession.ChangePassword(String)
FCSession.ChangeRestrictionGroup(String, Boolean)
FCSession.ConvertDate(DateTime, String, String)
FCSession.ConvertDate(DateTime, ITimeZone, ITimeZone)
FCSession.ConvertFromLocalToServerDate(DateTime)
FCSession.ConvertFromServerToLocalDate(DateTime)
FCSession.GetCurrentDate()
FCSession.RefreshContext()
FCSession.HasPermission(String)
FCSession.GetAssignedPermissions()
FCSession.ShouldConvertToLocalDate(DateTime, DataColumn)
FCSession.SessionData
FCSession.CreationTime
FCSession.LastLoadTime
FCSession.SessionID
FCSession.UserID
FCSession.DefaultCulture
FCSession.CurrentCulture
FCSession.UserName
FCSession.RestrictionGroup
FCSession.Log
FCSession.LocalTimeZone
FCSession.DisableDataConversions
FCSession.IncludeRelations
FCSession.QueryEmptyToNull
FCSession.PasswordRequired
FCSession.DataRestrictionsEnabled
FCSession.DefaultDistinctGenerics
FCSession.MaximumRows
FCSession.TruncateStringFields
FCSession.SetNullStringsToEmpty
FCSession.ConvertTimeZone
FCSession.TimeZoneConversions
FCSession.Items
FCSession.Item[String]
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify
Assembly: fcSDK.dll
Syntax
public class ClarifySession : FCSession, IDisposable

Constructors

ClarifySession()

Declaration
protected ClarifySession()

ClarifySession(Guid)

Declaration
protected ClarifySession(Guid sessionId)
Parameters
Type | Name | Description
System.Guid | sessionId |

Properties

ConfigItems

Declaration
public ClarifyConfigItemCollection ConfigItems { get; }
Property Value
Type | Description
ClarifyConfigItemCollection |

LoginType

Declaration
public ClarifyLoginType LoginType { get; }
Property Value
Type | Description
ClarifyLoginType |

Methods

AuthenticateContact(String, String)

Declaration
public static bool AuthenticateContact(string username, string password)
Parameters
Type | Name | Description
System.String | username |
System.String | password |
Returns
Type | Description
System.Boolean |

ChangeUserConfigItem(String, Double)

Declaration
public void ChangeUserConfigItem(string configItemName, double newValue)
Parameters
Type | Name | Description
System.String | configItemName |
System.Double | newValue |

ChangeUserConfigItem(String, Int32)

Declaration
public void ChangeUserConfigItem(string configItemName, int newValue)
Parameters
Type | Name | Description
System.String | configItemName |
System.Int32 | newValue |

ChangeUserConfigItem(String, String)

Declaration
public void ChangeUserConfigItem(string configItemName, string newValue)
Parameters
Type | Name | Description
System.String | configItemName |
System.String | newValue |

FormatNumScheme(String, Int32, Boolean, Int32)

Declaration
protected string FormatNumScheme(string schemeFormat, int nextVal, bool padded, int valWidth)
Parameters
Type | Name | Description
System.String | schemeFormat |
System.Int32 | nextVal |
System.Boolean | padded |
System.Int32 | valWidth |
Returns
Type | Description
System.String |

GetNextNumScheme(String)

Declaration
public string GetNextNumScheme(string schemeName)
Parameters
Type | Name | Description
System.String | schemeName |
Returns
Type | Description
System.String |

GetNextNumScheme(String, IDbTransaction)

Declaration
public string GetNextNumScheme(string schemeName, IDbTransaction trans)
Parameters
Type | Name | Description
System.String | schemeName |
System.Data.IDbTransaction | trans |
Returns
Type | Description
System.String |

GetRestrictionGroupForUser(Object)

Declaration
protected override RestrictionGroup GetRestrictionGroupForUser(object userID)
Parameters
Type | Name | Description
System.Object | userID |
Returns
Type | Description
RestrictionGroup |
Overrides
FCSession.GetRestrictionGroupForUser(Object)

GetUserConfigItem(String, String)

Declaration
protected ClarifyConfigItem GetUserConfigItem(string loginName, string configItemName)
Parameters
Type | Name | Description
System.String | loginName |
System.String | configItemName |
Returns
Type | Description
ClarifyConfigItem |

GetUserConfigItems(String)

Declaration
protected ConfigItemCollection GetUserConfigItems(string loginName)
Parameters
Type | Name | Description
System.String | loginName |
Returns
Type | Description
ConfigItemCollection |

PerformChangePassword(String, String, Int32)

Declaration
protected override void PerformChangePassword(string username, string newPassword, int loginType)
Parameters
Type | Name | Description
System.String | username |
System.String | newPassword |
System.Int32 | loginType |
Overrides
FCSession.PerformChangePassword(String, String, Int32)

PerformChangeResGroup(String, Boolean)

Declaration
protected override RestrictionGroup PerformChangeResGroup(string newGroupName, bool saveChanges)
Parameters
Type | Name | Description
System.String | newGroupName |
System.Boolean | saveChanges |
Returns
Type | Description
RestrictionGroup |
Overrides
FCSession.PerformChangeResGroup(String, Boolean)

PerformConvertDate(DateTime, ITimeZone, ITimeZone)

Declaration
protected override DateTime PerformConvertDate(DateTime date, ITimeZone fromTZ, ITimeZone toTZ)
Parameters
Type | Name | Description
System.DateTime | date |
ITimeZone | fromTZ |
ITimeZone | toTZ |
Returns
Type | Description
System.DateTime |
Overrides
FCSession.PerformConvertDate(DateTime, ITimeZone, ITimeZone)

PerformConvertDate(DateTime, String, String)

Declaration
protected override DateTime PerformConvertDate(DateTime date, string fromTZName, string toTZName)
Parameters
Type | Name | Description
System.DateTime | date |
System.String | fromTZName |
System.String | toTZName |
Returns
Type | Description
System.DateTime |
Overrides
FCSession.PerformConvertDate(DateTime, String, String)

PerformLogin(String, Int32)

Declaration
protected override object PerformLogin(string inUsername, int inLoginType)
Parameters
Type | Name | Description
System.String | inUsername |
System.Int32 | inLoginType |
Returns
Type | Description
System.Object |
Overrides
FCSession.PerformLogin(String, Int32)

PerformLogin(String, String)

Declaration
protected override object PerformLogin(string inUsername, string password)
Parameters
Type | Name | Description
System.String | inUsername |
System.String | password |
Returns
Type | Description
System.Object |
Overrides
FCSession.PerformLogin(String, String)

PerformLogin(String, String, Int32)

Declaration
protected override object PerformLogin(string inUsername, string password, int inLoginType)
Parameters
Type | Name | Description
System.String | inUsername |
System.String | password |
System.Int32 | inLoginType |
Returns
Type | Description
System.Object |
Overrides
FCSession.PerformLogin(String, String, Int32)

PerformRefreshContext()

Declaration
protected override void PerformRefreshContext()
Overrides
FCSession.PerformRefreshContext()

PerformSetPassword(String, String, Int32)

Declaration
protected override void PerformSetPassword(string username, string newPassword, int loginType)
Parameters
Type | Name | Description
System.String | username |
System.String | newPassword |
System.Int32 | loginType |
Overrides
FCSession.PerformSetPassword(String, String, Int32)

SetContactUserPassword(String, String)

Declaration
public static void SetContactUserPassword(string username, string newPassword)
Parameters
Type | Name | Description
System.String | username |
System.String | newPassword |

SetupSessionData(FCSessionData)

Declaration
protected override void SetupSessionData(FCSessionData data)
Parameters
Type | Name | Description
FCSessionData | data |
Overrides
FCSession.SetupSessionData(FCSessionData)

UpdateLastLogin(String)

Declaration
protected override void UpdateLastLogin(string username)
Parameters
Type | Name | Description
System.String | username |
Overrides
FCSession.UpdateLastLogin(String)

Explicit Interface Implementations

IDisposable.Dispose()

Declaration
void IDisposable.Dispose()

Implements

System.IDisposable


Class ClarifySessionData | fcSDK Documentation

Class ClarifySessionData

Inheritance
System.Object
FCSessionData
ClarifySessionData
Implements
System.Runtime.Serialization.ISerializable
Inherited Members
FCSessionData.DefaultCulture
FCSessionData.isSessionDirty
FCSessionData.sessionID
FCSessionData.newSession
FCSessionData.userID
FCSessionData.username
FCSessionData.loginType
FCSessionData.sessionData
FCSessionData.localTimeZone
FCSessionData.currentCulture
FCSessionData.disableDataConversion
FCSessionData.emptyNullStrings
FCSessionData.convertTimeZone
FCSessionData.truncateStringFields
FCSessionData.includeRelations
FCSessionData.queryEmptyToNull
FCSessionData.disableRestrictions
FCSessionData.defaultDistinct
FCSessionData.curResGroup
FCSessionData.configItems
FCSessionData.restrictionsEnabled
FCSessionData.passwordRequired
FCSessionData.maximumRows
FCSessionData.creationTime
FCSessionData.lastLoadTime
FCSessionData.loginTime
FCSessionData.permissions
FCSessionData.timeZoneConversions
FCSessionData.IsDirty
FCSessionData.NewSession
FCSessionData.CreationTime
FCSessionData.LoginTime
FCSessionData.LastLoadTime
FCSessionData.MaximumRows
FCSessionData.SessionID
FCSessionData.UserID
FCSessionData.UserName
FCSessionData.LoginType
FCSessionData.SessionData
FCSessionData.LocalTimeZone
FCSessionData.CurrentCulture
FCSessionData.DisableDataConversion
FCSessionData.EmptyNullStrings
FCSessionData.ConvertTimeZone
FCSessionData.TruncateStringFields
FCSessionData.IncludeRelations
FCSessionData.QueryEmptyToNull
FCSessionData.DisableRestrictions
FCSessionData.DefaultDistinctGenerics
FCSessionData.CurResGroup
FCSessionData.ConfigItems
FCSessionData.PasswordRequired
FCSessionData.Permissions
FCSessionData.TimeZoneConversions
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify
Assembly: fcSDK.dll
Syntax
public class ClarifySessionData : FCSessionData, ISerializable

Constructors

ClarifySessionData()

Declaration
protected ClarifySessionData()

ClarifySessionData(SerializationInfo, StreamingContext)

Declaration
protected ClarifySessionData(SerializationInfo info, StreamingContext context)
Parameters
Type | Name | Description
System.Runtime.Serialization.SerializationInfo | info |
System.Runtime.Serialization.StreamingContext | context |

Properties

PrivatePassword

Declaration
public string PrivatePassword { get; set; }
Property Value
Type | Description
System.String |

Methods

CopyTo(FCSessionData)

Declaration
public override void CopyTo(FCSessionData newData)
Parameters
Type | Name | Description
FCSessionData | newData |
Overrides
FCSessionData.CopyTo(FCSessionData)

LoadConfigItems(Object[][])

Declaration
protected override ConfigItemCollection LoadConfigItems(object[][] itemData)
Parameters
Type | Name | Description
System.Object[][] | itemData |
Returns
Type | Description
ConfigItemCollection |
Overrides
FCSessionData.LoadConfigItems(Object[][])

LoadTimeZone(String)

Declaration
protected override ITimeZone LoadTimeZone(string shortTzName)
Parameters
Type | Name | Description
System.String | shortTzName |
Returns
Type | Description
ITimeZone |
Overrides
FCSessionData.LoadTimeZone(String)

SerializeObjectData(SerializationInfo, StreamingContext)

Declaration
protected override void SerializeObjectData(SerializationInfo info, StreamingContext context)
Parameters
Type | Name | Description
System.Runtime.Serialization.SerializationInfo | info |
System.Runtime.Serialization.StreamingContext | context |
Overrides
FCSessionData.SerializeObjectData(SerializationInfo, StreamingContext)

Explicit Interface Implementations

ISerializable.GetObjectData(SerializationInfo, StreamingContext)

Declaration
void ISerializable.GetObjectData(SerializationInfo info, StreamingContext context)
Parameters
Type | Name | Description
System.Runtime.Serialization.SerializationInfo | info |
System.Runtime.Serialization.StreamingContext | context |

Implements

System.Runtime.Serialization.ISerializable


Namespace FChoice.Foundation.Clarify.Compatibility | fcSDK Documentation

Namespace FChoice.Foundation.Clarify.Compatibility

Classes

AdoField

AdoFieldInformationProvider

CompatibilityException

FCApplication

FCBulk

FCGeneric

FCList

FCNotLoggedInException

FCSession

FCSqlExec

MockAdoField

MockCollection

Interfaces

IFCApplication

IFCBulk

IFCGeneric

IFCList

IFCSession

IFCSqlExec

IMockAdoField

IMockCollection

Back to top © 2022 Dovetail Software, Inc. - All rights reserved.
Clarify, Amdocs, and related products and names are copyright and trademark of Amdocs, Inc.
.NET, Visual Studio.NET, C#, Visual Basic and related products are trademark of Microsoft corporation.


Class AdoField | fcSDK Documentation

Class AdoField

Inheritance
System.Object
AdoField
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Compatibility
Assembly: FChoice.Foundation.Clarify.Compatibility.dll
Syntax
[ComVisible(false)]
public class AdoField

Constructors

AdoField(String, DataTypeEnum, Int32)

Declaration
public AdoField(string fieldName, DataTypeEnum type, int length)
Parameters
Type | Name | Description
System.String | fieldName |
ADODB.DataTypeEnum | type |
System.Int32 | length |

Properties

DataType

Declaration
public DataTypeEnum DataType { get; set; }
Property Value
Type | Description
ADODB.DataTypeEnum |

Length

Declaration
public int Length { get; set; }
Property Value
Type | Description
System.Int32 |

Name

Declaration
public string Name { get; set; }
Property Value
Type | Description
System.String |


Class AdoFieldInformationProvider | fcSDK Documentation

Class AdoFieldInformationProvider

Inheritance
System.Object
AdoFieldInformationProvider
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Compatibility
Assembly: FChoice.Foundation.Clarify.Compatibility.dll
Syntax
[ComVisible(false)]
[Guid("EFCE1EFA-CE35-3D45-9722-07CF53F13778")]
public class AdoFieldInformationProvider

Constructors

AdoFieldInformationProvider()

Declaration
public AdoFieldInformationProvider()

AdoFieldInformationProvider(Boolean)

Declaration
public AdoFieldInformationProvider(bool isUnicode)
Parameters
Type | Name | Description
System.Boolean | isUnicode |

Fields

MaximumFieldSizeForSortableAdoStringFields

Declaration
public const int MaximumFieldSizeForSortableAdoStringFields = 4679
Field Value
Type | Description
System.Int32 |

Methods

GetAdoFieldInformation(String, Type, Int32)

Declaration
public AdoField GetAdoFieldInformation(string fieldName, Type dataType, int maxLength)
Parameters
Type | Name | Description
System.String | fieldName |
System.Type | dataType |
System.Int32 | maxLength |
Returns
Type | Description
AdoField |


Class CompatibilityException | fcSDK Documentation

Class CompatibilityException

Inheritance
System.Object
System.Exception
System.ApplicationException
FCExceptionBase
CompatibilityException
FCNotLoggedInException
Implements
System.Runtime.InteropServices._Exception
System.Runtime.Serialization.ISerializable
Inherited Members
FCExceptionBase.SetMessageProvider(IErrorMessageProvider)
FCExceptionBase.GetResourceData()
FCExceptionBase.GetErrorMessageFormat(Object, String)
FCExceptionBase.FormatMessage(String, String, Object[])
FCExceptionBase.LoadErrorResourceSet(String)
FCExceptionBase.GetObjectData(SerializationInfo, StreamingContext)
FCExceptionBase.MessageProvider
FCExceptionBase.ErrorCode
FCExceptionBase.ErrorMessageID
FCExceptionBase.Message
System.Exception.GetBaseException()
System.Exception.ToString()
System.Exception.GetType()
System.Exception.Data
System.Exception.InnerException
System.Exception.TargetSite
System.Exception.StackTrace
System.Exception.HelpLink
System.Exception.Source
System.Exception.HResult
System.Exception.SerializeObjectState
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Compatibility
Assembly: FChoice.Foundation.Clarify.Compatibility.dll
Syntax
[ComVisible(false)]
[Guid("4EC21DC6-3E55-3633-B289-FCC59D5AF61C")]
public class CompatibilityException : FCExceptionBase, _Exception, ISerializable

Constructors

CompatibilityException(Exception, Int32, String, Object[])

Declaration
protected CompatibilityException(Exception innerEx, int errorId, string messageId, params object[] args)
Parameters
Type | Name | Description
System.Exception | innerEx |
System.Int32 | errorId |
System.String | messageId |
System.Object[] | args |

CompatibilityException(Int32, String, Object[])

Declaration
protected CompatibilityException(int errorId, string messageId, params object[] args)
Parameters
Type | Name | Description
System.Int32 | errorId |
System.String | messageId |
System.Object[] | args |

CompatibilityException(SerializationInfo, StreamingContext)

Declaration
protected CompatibilityException(SerializationInfo info, StreamingContext context)
Parameters
Type | Name | Description
System.Runtime.Serialization.SerializationInfo | info |
System.Runtime.Serialization.StreamingContext | context |

Implements

System.Runtime.InteropServices._Exception
System.Runtime.Serialization.ISerializable


Class FCApplication | fcSDK Documentation

Class FCApplication

Inheritance
System.Object
FCApplication
Implements
IFCApplication
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Compatibility
Assembly: FChoice.Foundation.Clarify.Compatibility.dll
Syntax
[ComVisible(true)]
[Guid("96EFBAF6-4FA0-4f71-A012-910F6CF61120")]
[ClassInterface(ClassInterfaceType.None)]
public sealed class FCApplication : IFCApplication

Constructors

FCApplication()

Declaration
public FCApplication()

Fields

LOGDIRNAME

Declaration
public const string LOGDIRNAME = "logs"
Field Value
Type | Description
System.String |

LOGFILENAME

Declaration
public const string LOGFILENAME = "fc.log"
Field Value
Type | Description
System.String |

SQLLOGFILENAME

Declaration
public const string SQLLOGFILENAME = "fc_sql.log"
Field Value
Type | Description
System.String |

Properties

base_objid

Declaration
public int base_objid { get; }
Property Value
Type | Description
System.Int32 |

clarify_ver

Declaration
public string clarify_ver { get; }
Property Value
Type | Description
System.String |

ConnectionString

Declaration
public string ConnectionString { get; }
Property Value
Type | Description
System.String |

ConvertTimeZone

Declaration
public bool ConvertTimeZone { get; set; }
Property Value
Type | Description
System.Boolean |

DataProtectorEntropy

Declaration
public string DataProtectorEntropy { set; }
Property Value
Type | Description
System.String |

db_name

Declaration
public string db_name { get; }
Property Value
Type | Description
System.String |

db_type

Declaration
public string db_type { get; }
Property Value
Type | Description
System.String |

GetMachineTimeZone

Declaration
public string GetMachineTimeZone { get; }
Property Value
Type | Description
System.String |

IsDBTraveler

Declaration
public bool IsDBTraveler { get; }
Property Value
Type | Description
System.Boolean |

IsDBUnicode

Declaration
public bool IsDBUnicode { get; }
Property Value
Type | Description
System.Boolean |

IsFcflNet

Declaration
public bool IsFcflNet { get; }
Property Value
Type | Description
System.Boolean |

LicenseExpirationDate

Declaration
public string LicenseExpirationDate { get; }
Property Value
Type | Description
System.String |

LoggingConfigFilePath

Declaration
public string LoggingConfigFilePath { get; set; }
Property Value
Type | Description
System.String |

Midnight

Declaration
public string Midnight { get; set; }
Property Value
Type | Description
System.String |

schema_rev

Declaration
public short schema_rev { get; }
Property Value
Type | Description
System.Int16 |

ServerTimeZone

Declaration
public string ServerTimeZone { get; set; }
Property Value
Type | Description
System.String |

site_id

Declaration
public short site_id { get; }
Property Value
Type | Description
System.Int16 |

TruncateStringFields

Declaration
public bool TruncateStringFields { get; set; }
Property Value
Type | Description
System.Boolean |

WorkingDirectory

Declaration
public string WorkingDirectory { get; set; }
Property Value
Type | Description
System.String |

Methods

build_mtm_name(String, String, String)

Declaration
public string build_mtm_name(string tableName, string relationName, string inverseRelationName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | relationName |
System.String | inverseRelationName |
Returns
Type | Description
System.String |

CreateSession(Object)

Declaration
public FCSession CreateSession(object sessIdValue)
Parameters
Type | Name | Description
System.Object | sessIdValue |
Returns
Type | Description
FCSession |

CurrentSessions()

Declaration
public string CurrentSessions()
Returns
Type | Description
System.String |

EncryptClarifyPassword(String, String)

Declaration
public string EncryptClarifyPassword(string password, string fc_session_id)
Parameters
Type | Name | Description
System.String | password |
System.String | fc_session_id |
Returns
Type | Description
System.String |

EncryptDBPassword(String)

Declaration
public string EncryptDBPassword(string password)
Parameters
Type | Name | Description
System.String | password |
Returns
Type | Description
System.String |

FileExists(String)

Declaration
public bool FileExists(string path)
Parameters
Type | Name | Description
System.String | path |
Returns
Type | Description
System.Boolean |

FindString(Object)

Declaration
public string FindString(object StringID)
Parameters
Type | Name | Description
System.Object | StringID |
Returns
Type | Description
System.String |

get_change_date_field(String)

Declaration
public string get_change_date_field(string tableName)
Parameters
Type | Name | Description
System.String | tableName |
Returns
Type | Description
System.String |

get_dt_fields(String)

Declaration
public string get_dt_fields(string tableName)
Parameters
Type | Name | Description
System.String | tableName |
Returns
Type | Description
System.String |

get_fields_types_lens(String, Boolean)

Declaration
public string get_fields_types_lens(string tableName, bool includeRelations)
Parameters
Type | Name | Description
System.String | tableName |
System.Boolean | includeRelations |
Returns
Type | Description
System.String |

GetADPObjects(Object)

Declaration
public Recordset GetADPObjects(object ObjectTypes)
Parameters
Type | Name | Description
System.Object | ObjectTypes |
Returns
Type | Description
ADODB.Recordset |

GetCountryList()

Declaration
public Recordset GetCountryList()
Returns
Type | Description
ADODB.Recordset |

GetCountryObjid(String)

Declaration
public int GetCountryObjid(string Country)
Parameters
Type | Name | Description
System.String | Country |
Returns
Type | Description
System.Int32 |

GetDefaultCountry()

Declaration
public string GetDefaultCountry()
Returns
Type | Description
System.String |

GetDefaultCountryObjId()

Declaration
public int GetDefaultCountryObjId()
Returns
Type | Description
System.Int32 |

GetDefaultState(String)

Declaration
public string GetDefaultState(string country)
Parameters
Type | Name | Description
System.String | country |
Returns
Type | Description
System.String |

GetDefaultStateObjid(String)

Declaration
public int GetDefaultStateObjid(string country)
Parameters
Type | Name | Description
System.String | country |
Returns
Type | Description
System.Int32 |

GetDefaultTimeZone()

Declaration
public string GetDefaultTimeZone()
Returns
Type | Description
System.String |

GetDefaultTimeZoneObjid()

Declaration
public int GetDefaultTimeZoneObjid()
Returns
Type | Description
System.Int32 |

GetFullStateObjid(String, String)

Declaration
public int GetFullStateObjid(string country, string state)
Parameters
Type | Name | Description
System.String | country |
System.String | state |
Returns
Type | Description
System.Int32 |

GetGbstDefault(String)

Declaration
public string GetGbstDefault(string listName)
Parameters
Type | Name | Description
System.String | listName |
Returns
Type | Description
System.String |

GetGbstDefaultObjid(String)

Declaration
public int GetGbstDefaultObjid(string listName)
Parameters
Type | Name | Description
System.String | listName |
Returns
Type | Description
System.Int32 |

GetGbstElmById(String, Int32)

Declaration
public string GetGbstElmById(string listName, int elmObjID)
Parameters
Type | Name | Description
System.String | listName |
System.Int32 | elmObjID |
Returns
Type | Description
System.String |

GetGbstElmObjid(String, String)

Declaration
public int GetGbstElmObjid(string listName, string element)
Parameters
Type | Name | Description
System.String | listName |
System.String | element |
Returns
Type | Description
System.Int32 |

GetGbstElmRankObjid(String, Int32)

Declaration
public int GetGbstElmRankObjid(string listName, int elementRank)
Parameters
Type | Name | Description
System.String | listName |
System.Int32 | elementRank |
Returns
Type | Description
System.Int32 |

GetGbstList(String, Object)

Declaration
public Recordset GetGbstList(string listName, object includeInactive)
Parameters
Type | Name | Description
System.String | listName |
System.Object | includeInactive |
Returns
Type | Description
ADODB.Recordset |

GetHgbstElmDefault(String, Object, Object, Object, Object)

Declaration
public string GetHgbstElmDefault(string listName, object element1, object element2, object element3, object element4)
Parameters
Type | Name | Description
System.String | listName |
System.Object | element1 |
System.Object | element2 |
System.Object | element3 |
System.Object | element4 |
Returns
Type | Description
System.String |

GetHgbstElmDefaultObjid(String, Object, Object, Object, Object)

Declaration
public int GetHgbstElmDefaultObjid(string listName, object Element1, object Element2, object Element3, object Element4)
Parameters
Type | Name | Description
System.String | listName |
System.Object | Element1 |
System.Object | Element2 |
System.Object | Element3 |
System.Object | Element4 |
Returns
Type | Description
System.Int32 |

GetHgbstElmObjId(String, String, Object, Object, Object, Object)

Declaration
public int GetHgbstElmObjId(string element, string listName, object Element1, object Element2, object Element3, object Element4)
Parameters
Type | Name | Description
System.String | element |
System.String | listName |
System.Object | Element1 |
System.Object | Element2 |
System.Object | Element3 |
System.Object | Element4 |
Returns
Type | Description
System.Int32 |

GetHgbstList(String, Object, Object, Object, Object, Object)

Declaration
public Recordset GetHgbstList(string listName, object Element1, object Element2, object Element3, object Element4, object includeInactive)
Parameters
Type | Name | Description
System.String | listName |
System.Object | Element1 |
System.Object | Element2 |
System.Object | Element3 |
System.Object | Element4 |
System.Object | includeInactive |
Returns
Type | Description
ADODB.Recordset |

GetLocalizedGbstDefault(String)

Declaration
public string GetLocalizedGbstDefault(string listName)
Parameters
Type | Name | Description
System.String | listName |
Returns
Type | Description
System.String |

GetLocalizedGbstElmById(String, Int32)

Declaration
public string GetLocalizedGbstElmById(string listName, int elmObjID)
Parameters
Type | Name | Description
System.String | listName |
System.Int32 | elmObjID |
Returns
Type | Description
System.String |

GetRelationData(String, String)

Declaration
public Recordset GetRelationData(string relationName, string tableName)
Parameters
Type | Name | Description
System.String | relationName |
System.String | tableName |
Returns
Type | Description
ADODB.Recordset |

GetResClauses(Int32, ref String)

Declaration
public bool GetResClauses(int tblNum, ref string clauses)
Parameters
Type | Name | Description
System.Int32 | tblNum |
System.String | clauses |
Returns
Type | Description
System.Boolean |

GetResClausesStr(Int32)

Declaration
public string GetResClausesStr(int tblNum)
Parameters
Type | Name | Description
System.Int32 | tblNum |
Returns
Type | Description
System.String |

GetResTbl(Int32, ref String[])

Declaration
public bool GetResTbl(int tblNum, ref string[] restructionFieldNames)
Parameters
Type | Name | Description
System.Int32 | tblNum |
System.String[] | restructionFieldNames |
Returns
Type | Description
System.Boolean |

GetServerTimeZoneOffset()

Declaration
public int GetServerTimeZoneOffset()
Returns
Type | Description
System.Int32 |

GetShortTimeZoneObjId(String)

Declaration
public int GetShortTimeZoneObjId(string timeZoneName)
Parameters
Type | Name | Description
System.String | timeZoneName |
Returns
Type | Description
System.Int32 |

GetStateObjid(String, String)

Declaration
public int GetStateObjid(string country, string state)
Parameters
Type | Name | Description
System.String | country |
System.String | state |
Returns
Type | Description
System.Int32 |

GetStates(String)

Declaration
public Recordset GetStates(string country)
Parameters
Type | Name | Description
System.String | country |
Returns
Type | Description
ADODB.Recordset |

GetTableFields(String)

Declaration
public Recordset GetTableFields(string tableName)
Parameters
Type | Name | Description
System.String | tableName |
Returns
Type | Description
ADODB.Recordset |

GetTableID(String)

Declaration
public int GetTableID(string tableName)
Parameters
Type | Name | Description
System.String | tableName |
Returns
Type | Description
System.Int32 |

GetTableName(Int32)

Declaration
public string GetTableName(int TableNum)
Parameters
Type | Name | Description
System.Int32 | TableNum |
Returns
Type | Description
System.String |

GetTableRels(String, Boolean)

Declaration
public Recordset GetTableRels(string tableName, bool allowOneToMany)
Parameters
Type | Name | Description
System.String | tableName |
System.Boolean | allowOneToMany |
Returns
Type | Description
ADODB.Recordset |

GetTablesAndViews(Object)

Declaration
public Recordset GetTablesAndViews(object TablesOnly)
Parameters
Type | Name | Description
System.Object | TablesOnly |
Returns
Type | Description
ADODB.Recordset |

GetTimeZoneList()

Declaration
public Recordset GetTimeZoneList()
Returns
Type | Description
ADODB.Recordset |

GetTimeZoneObjid(String)

Declaration
public int GetTimeZoneObjid(string timeZoneName)
Parameters
Type | Name | Description
System.String | timeZoneName |
Returns
Type | Description
System.Int32 |

GetTimeZoneOffset(String)

Declaration
public int GetTimeZoneOffset(string timeZoneName)
Parameters
Type | Name | Description
System.String | timeZoneName |
Returns
Type | Description
System.Int32 |

GetTimeZonesInCountry(String)

Declaration
public Recordset GetTimeZonesInCountry(string Country)
Parameters
Type | Name | Description
System.String | Country |
Returns
Type | Description
ADODB.Recordset |

Initialize()

Declaration
public void Initialize()

InitializeFull(String, String, String, String, Object, Object, Object, Object, Object, Object, Object, Object, Object, Object)

Declaration
public void InitializeFull(string LoginName, string password, string DBServer, string DBName, object DBType, object LogFile, object SqlLogFile, object SQLLogging, object fcAppLogging, object fcSessionLogging, object fcGenericLogging, object fcBulkLogging, object fcSqlExecLogging, object NoCacheFile)
Parameters
Type | Name | Description
System.String | LoginName |
System.String | password |
System.String | DBServer |
System.String | DBName |
System.Object | DBType |
System.Object | LogFile |
System.Object | SqlLogFile |
System.Object | SQLLogging |
System.Object | fcAppLogging |
System.Object | fcSessionLogging |
System.Object | fcGenericLogging |
System.Object | fcBulkLogging |
System.Object | fcSqlExecLogging |
System.Object | NoCacheFile |

InitializeWithParams(NameValueCollection)

Declaration
[ComVisible(false)]
public void InitializeWithParams(NameValueCollection envParams)
Parameters
Type | Name | Description
System.Collections.Specialized.NameValueCollection | envParams |

is_it_a_field(String, String)

Declaration
public bool is_it_a_field(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

is_it_a_table(String)

Declaration
public bool is_it_a_table(string tableName)
Parameters
Type | Name | Description
System.String | tableName |
Returns
Type | Description
System.Boolean |

is_it_change_field(String, String)

Declaration
public bool is_it_change_field(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

is_it_date_field(String, String)

Declaration
public bool is_it_date_field(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

is_it_int_field(String, String)

Declaration
public bool is_it_int_field(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

is_it_searchable(String, String)

Declaration
public bool is_it_searchable(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

is_it_string_fld(String, String)

Declaration
public bool is_it_string_fld(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

is_it_unicode(String, String)

Declaration
public bool is_it_unicode(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

is_rel_exclusive(Int32, String, ref String, ref String)

Declaration
public bool is_rel_exclusive(int tbl_num, string relationName, ref string tbl_fld, ref string objid_fld)
Parameters
Type | Name | Description
System.Int32 | tbl_num |
System.String | relationName |
System.String | tbl_fld |
System.String | objid_fld |
Returns
Type | Description
System.Boolean |

is_rel_mandatory(Int32, String)

Declaration
public bool is_rel_mandatory(int tableNum, string relationName)
Parameters
Type | Name | Description
System.Int32 | tableNum |
System.String | relationName |
Returns
Type | Description
System.Boolean |

IsCountry(String)

Declaration
public bool IsCountry(string Country)
Parameters
Type | Name | Description
System.String | Country |
Returns
Type | Description
System.Boolean |

IsFullState(String, String)

Declaration
public bool IsFullState(string country, string state)
Parameters
Type | Name | Description
System.String | country |
System.String | state |
Returns
Type | Description
System.Boolean |

IsInGbstLst(String, String)

Declaration
public bool IsInGbstLst(string listName, string element)
Parameters
Type | Name | Description
System.String | listName |
System.String | element |
Returns
Type | Description
System.Boolean |

IsInHgbstList(String, String, Object, Object, Object, Object)

Declaration
public bool IsInHgbstList(string element, string listName, object Element1, object Element2, object Element3, object Element4)
Parameters
Type | Name | Description
System.String | element |
System.String | listName |
System.Object | Element1 |
System.Object | Element2 |
System.Object | Element3 |
System.Object | Element4 |
Returns
Type | Description
System.Boolean |

IsOnDST(String, DateTime)

Declaration
public bool IsOnDST(string timeZoneName, DateTime date)
Parameters
Type | Name | Description
System.String | timeZoneName |
System.DateTime | date |
Returns
Type | Description
System.Boolean |

IsState(String, String)

Declaration
public bool IsState(string country, string state)
Parameters
Type | Name | Description
System.String | country |
System.String | state |
Returns
Type | Description
System.Boolean |

IsTimeZone(String)

Declaration
public bool IsTimeZone(string timeZoneName)
Parameters
Type | Name | Description
System.String | timeZoneName |
Returns
Type | Description
System.Boolean |

IsTimeZoneInCountry(String, String, Boolean)

Declaration
public bool IsTimeZoneInCountry(string country, string timeZone, bool IsFullName)
Parameters
Type | Name | Description
System.String | country |
System.String | timeZone |
System.Boolean | IsFullName |
Returns
Type | Description
System.Boolean |

Log(Object, Object)

Declaration
public void Log(object TheMessageType, object TheMessage)
Parameters
Type | Name | Description
System.Object | TheMessageType |
System.Object | TheMessage |

LogEx(String, String)

Declaration
public void LogEx(string logLevel, string logMessage)
Parameters
Type | Name | Description
System.String | logLevel |
System.String | logMessage |

RankIsInGbstLst(String, Int32)

Declaration
public bool RankIsInGbstLst(string listName, int rank)
Parameters
Type | Name | Description
System.String | listName |
System.Int32 | rank |
Returns
Type | Description
System.Boolean |

SetServerTimeZoneToMachineTimeZone()

Declaration
public void SetServerTimeZoneToMachineTimeZone()

sprintf(String, Object, Object, Object, Object, Object, Object)

Declaration
public string sprintf(string inputString, object arg1, object arg2, object arg3, object arg4, object arg5, object arg6)
Parameters
Type | Name | Description
System.String | inputString |
System.Object | arg1 |
System.Object | arg2 |
System.Object | arg3 |
System.Object | arg4 |
System.Object | arg5 |
System.Object | arg6 |
Returns
Type | Description
System.String |

UpdateCache()

Declaration
public void UpdateCache()

UpdateSchemaCache()

Declaration
public void UpdateSchemaCache()

ValidateEncryptedPassword(String, String, Int16)

Declaration
public bool ValidateEncryptedPassword(string str, string encr, short pre9)
Parameters
Type | Name | Description
System.String | str |
System.String | encr |
System.Int16 | pre9 |
Returns
Type | Description
System.Boolean |

Implements

IFCApplication


Class FCBulk | fcSDK Documentation

Class FCBulk

Inheritance
System.Object
FCBulk
Implements
IFCBulk
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Compatibility
Assembly: FChoice.Foundation.Clarify.Compatibility.dll
Syntax
[ComVisible(true)]
[Guid("DDBC0BE8-F58D-4bde-B658-6FB1E0851C4C")]
[ClassInterface(ClassInterfaceType.None)]
public sealed class FCBulk : IFCBulk

Properties

BulkID

Declaration
public short BulkID { get; set; }
Property Value
Type | Description
System.Int16 |

Name

Declaration
public string Name { get; set; }
Property Value
Type | Description
System.String |

NoSorting

Declaration
public bool NoSorting { get; set; }
Property Value
Type | Description
System.Boolean |

Methods

AddGeneric(IFCGeneric)

Declaration
public void AddGeneric(IFCGeneric generic)
Parameters
Type | Name | Description
IFCGeneric | generic |

ChangeGenericsOrdering(IFCGeneric)

Declaration
public void ChangeGenericsOrdering(IFCGeneric generic)
Parameters
Type | Name | Description
IFCGeneric | generic |

GenericCount()

Declaration
public int GenericCount()
Returns
Type | Description
System.Int32 |

NewEnum()

Declaration
public IEnumerator NewEnum()
Returns
Type | Description
System.Collections.IEnumerator |

Query()

Declaration
public void Query()

RemoveAllGenerics()

Declaration
public void RemoveAllGenerics()

RemoveGeneric(IFCGeneric)

Declaration
public void RemoveGeneric(IFCGeneric generic)
Parameters
Type | Name | Description
IFCGeneric | generic |

Update()

Declaration
public void Update()

UpdateAll()

Declaration
public void UpdateAll()

Implements

IFCBulk


Class FCGeneric | fcSDK Documentation

Class FCGeneric

Inheritance
System.Object
FCGeneric
Implements
IFCGeneric
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Compatibility
Assembly: FChoice.Foundation.Clarify.Compatibility.dll
Syntax
[ComVisible(true)]
[Guid("2888C9FF-F557-4CEA-BDDF-08DF16715D6E")]
[ClassInterface(ClassInterfaceType.None)]
public sealed class FCGeneric : IFCGeneric

Properties

BOF

Declaration
public bool BOF { get; }
Property Value
Type | Description
System.Boolean |

Bulk

Declaration
public IFCBulk Bulk { get; set; }
Property Value
Type | Description
IFCBulk |

BulkName

Declaration
public string BulkName { get; set; }
Property Value
Type | Description
System.String |

child_objects

Declaration
public IMockCollection child_objects { get; }
Property Value
Type | Description
IMockCollection |

DataFields

Declaration
public string DataFields { get; set; }
Property Value
Type | Description
System.String |

DbObjectName

Declaration
public string DbObjectName { get; set; }
Property Value
Type | Description
System.String |

DbObjectNum

Declaration
public int DbObjectNum { get; }
Property Value
Type | Description
System.Int32 |

DelRelList

Declaration
public string DelRelList { get; set; }
Property Value
Type | Description
System.String |

Distinct

Declaration
public bool Distinct { get; set; }
Property Value
Type | Description
System.Boolean |

EOF

Declaration
public bool EOF { get; }
Property Value
Type | Description
System.Boolean |

ErrorOnQueryTooBig

Declaration
public bool ErrorOnQueryTooBig { get; set; }
Property Value
Type | Description
System.Boolean |

Filter

Declaration
public string Filter { get; set; }
Property Value
Type | Description
System.String |

GenericId

Declaration
public string GenericId { get; set; }
Property Value
Type | Description
System.String |

Id

Declaration
public int Id { get; }
Property Value
Type | Description
System.Int32 |

IncludeRelations

Declaration
public bool IncludeRelations { get; set; }
Property Value
Type | Description
System.Boolean |

Item[Object]

Declaration
[ComVisible(false)]
public IMockAdoField this[object colIndex] { get; set; }
Parameters
Type | Name | Description
System.Object | colIndex |
Property Value
Type | Description
IMockAdoField |

MaxRecords

Declaration
public int MaxRecords { get; set; }
Property Value
Type | Description
System.Int32 |

NoRes

Declaration
public bool NoRes { get; set; }
Property Value
Type | Description
System.Boolean |

ParentBO

Declaration
public IFCGeneric ParentBO { get; set; }
Property Value
Type | Description
IFCGeneric |

ParentRelation

Declaration
public string ParentRelation { get; set; }
Property Value
Type | Description
System.String |

Position

Declaration
public short Position { get; set; }
Property Value
Type | Description
System.Int16 |

QueryEmptyToNull

Declaration
public bool QueryEmptyToNull { get; set; }
Property Value
Type | Description
System.Boolean |

records

Declaration
public Recordset records { get; }
Property Value
Type | Description
ADODB.Recordset |

rel_from_parent

Declaration
public string rel_from_parent { get; }
Property Value
Type | Description
System.String |

rel_to_parent

Declaration
public string rel_to_parent { get; }
Property Value
Type | Description
System.String |

rel_type

Declaration
public short rel_type { get; }
Property Value
Type | Description
System.Int16 |

rowLimit

Declaration
public int rowLimit { get; set; }
Property Value
Type | Description
System.Int32 |

rowsReturned

Declaration
public int rowsReturned { get; }
Property Value
Type | Description
System.Int32 |

SetNullStringsToEmpty

Declaration
public bool SetNullStringsToEmpty { get; set; }
Property Value
Type | Description
System.Boolean |

SortOrder

Declaration
public string SortOrder { get; set; }
Property Value
Type | Description
System.String |

Methods

AddForUpdate(Int32)

Declaration
public void AddForUpdate(int TheObjid)
Parameters
Type | Name | Description
System.Int32 | TheObjid |

AddNew()

Declaration
public void AddNew()

AppendFilter(String, String, Object)

Declaration
public void AppendFilter(string fieldName, string operation, object filterValue)
Parameters
Type | Name | Description
System.String | fieldName |
System.String | operation |
System.Object | filterValue |

AppendSort(String, String)

Declaration
public void AppendSort(string fieldName, string ascending)
Parameters
Type | Name | Description
System.String | fieldName |
System.String | ascending |

AssignAllObjids()

Declaration
public void AssignAllObjids()

AssignObjid()

Declaration
public void AssignObjid()

ClearRoot()

Declaration
public void ClearRoot()

CloseGeneric()

Declaration
public void CloseGeneric()

copy(Object)

Declaration
public IFCGeneric copy(object use_generic)
Parameters
Type | Name | Description
System.Object | use_generic |
Returns
Type | Description
IFCGeneric |

Count()

Declaration
public int Count()
Returns
Type | Description
System.Int32 |

Delete()

Declaration
public void Delete()

DeleteAll()

Declaration
public void DeleteAll()

Duplicate(Object)

Declaration
public IFCGeneric Duplicate(object use_generic)
Parameters
Type | Name | Description
System.Object | use_generic |
Returns
Type | Description
IFCGeneric |

get_Fields(Object)

Declaration
public object get_Fields(object index)
Parameters
Type | Name | Description
System.Object | index |
Returns
Type | Description
System.Object |

GetField(String)

Declaration
public object GetField(string fieldName)
Parameters
Type | Name | Description
System.String | fieldName |
Returns
Type | Description
System.Object |

GetFieldValue(Object)

Declaration
public object GetFieldValue(object index)
Parameters
Type | Name | Description
System.Object | index |
Returns
Type | Description
System.Object |

let_Fields(Object, Object)

Declaration
[ComVisible(false)]
public void let_Fields(object index, object newValue)
Parameters
Type | Name | Description
System.Object | index |
System.Object | newValue |

MoveFirst()

Declaration
public void MoveFirst()

MoveFirstAbsolute()

Declaration
public void MoveFirstAbsolute()

MoveLast()

Declaration
public void MoveLast()

MoveLastAbsolute()

Declaration
public void MoveLastAbsolute()

MoveNext()

Declaration
public void MoveNext()

MoveNextAbsolute()

Declaration
public void MoveNextAbsolute()

MovePrevious()

Declaration
public void MovePrevious()

MovePreviousAbsolute()

Declaration
public void MovePreviousAbsolute()

MoveRelative(Int16)

Declaration
public void MoveRelative(short NumToMove)
Parameters
Type | Name | Description
System.Int16 | NumToMove |

Query()

Declaration
public void Query()

RelateByID(Int32, String)

Declaration
public void RelateByID(int objId, string relationName)
Parameters
Type | Name | Description
System.Int32 | objId |
System.String | relationName |

RelateIntFldByID(Int32, String)

Declaration
public void RelateIntFldByID(int objId, string fieldName)
Parameters
Type | Name | Description
System.Int32 | objId |
System.String | fieldName |

RelateIntFldToRecord(IFCGeneric, String)

Declaration
public void RelateIntFldToRecord(IFCGeneric otherGeneric, string myIntFieldName)
Parameters
Type | Name | Description
IFCGeneric | otherGeneric |
System.String | myIntFieldName |

RelateRecords(IFCGeneric, String)

Declaration
public void RelateRecords(IFCGeneric otherGeneric, string relationName)
Parameters
Type | Name | Description
IFCGeneric | otherGeneric |
System.String | relationName |

set_Fields(Object, Object)

Declaration
public void set_Fields(object index, object newValue)
Parameters
Type | Name | Description
System.Object | index |
System.Object | newValue |

SimpleQuery(String)

Declaration
public void SimpleQuery(string dbObjectName)
Parameters
Type | Name | Description
System.String | dbObjectName |

TotalCount()

Declaration
public int TotalCount()
Returns
Type | Description
System.Int32 |

TraverseFromParent(IFCGeneric, String)

Declaration
public void TraverseFromParent(IFCGeneric parentGeneric, string traverseRelation)
Parameters
Type | Name | Description
IFCGeneric | parentGeneric |
System.String | traverseRelation |

TraverseFromRoot(Int32, String, String)

Declaration
public void TraverseFromRoot(int RootObjid, string TblName, string RootRel)
Parameters
Type | Name | Description
System.Int32 | RootObjid |
System.String | TblName |
System.String | RootRel |

UnRelateAll(String)

Declaration
public void UnRelateAll(string relationName)
Parameters
Type | Name | Description
System.String | relationName |

UnRelateRecordFromAll(String)

Declaration
public void UnRelateRecordFromAll(string relationName)
Parameters
Type | Name | Description
System.String | relationName |

UnRelateRecords(IFCGeneric, String)

Declaration
public void UnRelateRecords(IFCGeneric o_obj, string relationName)
Parameters
Type | Name | Description
IFCGeneric | o_obj |
System.String | relationName |

Untraverse()

Declaration
public void Untraverse()

Update()

Declaration
public void Update()

UpdateAll()

Declaration
public void UpdateAll()

Implements

IFCGeneric


Class FCList | fcSDK Documentation

Class FCList

Inheritance
System.Object
FCList
Implements
IFCList
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Compatibility
Assembly: FChoice.Foundation.Clarify.Compatibility.dll
Syntax
[ComVisible(true)]
[Guid("007EE1DD-6614-4833-BB7F-2AB543B42CE9")]
[ClassInterface(ClassInterfaceType.None)]
public sealed class FCList : IFCList

Constructors

FCList()

Declaration
public FCList()

Properties

AllowDuplicates

Declaration
public bool AllowDuplicates { get; set; }
Property Value
Type | Description
System.Boolean |

Count

Declaration
public short Count { get; }
Property Value
Type | Description
System.Int16 |

ItemType

Declaration
public string ItemType { get; set; }
Property Value
Type | Description
System.String |

Sorted

Declaration
public bool Sorted { get; }
Property Value
Type | Description
System.Boolean |

Methods

AppendItem(Object, Object, Object, Object, Object, Object, Object, Object, Object)

Declaration
public void AppendItem(object param1, object param2, object param3, object param4, object param5, object param6, object param7, object param8, object param9)
Parameters
Type | Name | Description
System.Object | param1 |
System.Object | param2 |
System.Object | param3 |
System.Object | param4 |
System.Object | param5 |
System.Object | param6 |
System.Object | param7 |
System.Object | param8 |
System.Object | param9 |

AppendSingleItem(Object)

Declaration
public void AppendSingleItem(object appendItem)
Parameters
Type | Name | Description
System.Object | appendItem |

Clear()

Declaration
public void Clear()

Contains(Object)

Declaration
public bool Contains(object item)
Parameters
Type | Name | Description
System.Object | item |
Returns
Type | Description
System.Boolean |

FindFirstindex(Object)

Declaration
public short FindFirstindex(object param1)
Parameters
Type | Name | Description
System.Object | param1 |
Returns
Type | Description
System.Int16 |

GetItemByIndex(Int16, ref Object)

Declaration
public void GetItemByIndex(short index, ref object item)
Parameters
Type | Name | Description
System.Int16 | index |
System.Object | item |

ItemByIndex(Int16)

Declaration
public object ItemByIndex(short index)
Parameters
Type | Name | Description
System.Int16 | index |
Returns
Type | Description
System.Object |

Sort()

Declaration
public void Sort()

Implements

IFCList


Class FCNotLoggedInException | fcSDK Documentation

Class FCNotLoggedInException

Inheritance
System.Object
System.Exception
System.ApplicationException
FCExceptionBase
CompatibilityException
FCNotLoggedInException
Implements
System.Runtime.InteropServices._Exception
System.Runtime.Serialization.ISerializable
Inherited Members
FCExceptionBase.SetMessageProvider(IErrorMessageProvider)
FCExceptionBase.GetResourceData()
FCExceptionBase.GetErrorMessageFormat(Object, String)
FCExceptionBase.FormatMessage(String, String, Object[])
FCExceptionBase.LoadErrorResourceSet(String)
FCExceptionBase.GetObjectData(SerializationInfo, StreamingContext)
FCExceptionBase.MessageProvider
FCExceptionBase.ErrorCode
FCExceptionBase.ErrorMessageID
FCExceptionBase.Message
System.Exception.GetBaseException()
System.Exception.ToString()
System.Exception.GetType()
System.Exception.Data
System.Exception.InnerException
System.Exception.TargetSite
System.Exception.StackTrace
System.Exception.HelpLink
System.Exception.Source
System.Exception.HResult
System.Exception.SerializeObjectState
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Compatibility
Assembly: FChoice.Foundation.Clarify.Compatibility.dll
Syntax
[ComVisible(false)]
public class FCNotLoggedInException : CompatibilityException, _Exception, ISerializable

Constructors

FCNotLoggedInException(Int32)

Declaration
public FCNotLoggedInException(int errorId)
Parameters
Type | Name | Description
System.Int32 | errorId |

FCNotLoggedInException(SerializationInfo, StreamingContext)

Declaration
protected FCNotLoggedInException(SerializationInfo info, StreamingContext context)
Parameters
Type | Name | Description
System.Runtime.Serialization.SerializationInfo | info |
System.Runtime.Serialization.StreamingContext | context |

Implements

System.Runtime.InteropServices._Exception
System.Runtime.Serialization.ISerializable


Class FCSession | fcSDK Documentation

Class FCSession

Inheritance
System.Object
FCSession
Implements
IFCSession
System.IDisposable
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Compatibility
Assembly: FChoice.Foundation.Clarify.Compatibility.dll
Syntax
[ComVisible(true)]
[Guid("906C1CC2-5CE2-456b-BF53-129336DAA394")]
[ClassInterface(ClassInterfaceType.None)]
public sealed class FCSession : IFCSession, IDisposable

Properties

ad_auto

Declaration
public bool ad_auto { get; set; }
Property Value
Type | Description
System.Boolean |

ad_list

Declaration
public string ad_list { get; set; }
Property Value
Type | Description
System.String |

BulkCollection

Declaration
public IMockCollection BulkCollection { get; }
Property Value
Type | Description
IMockCollection |

ConvertTimeZone

Declaration
public bool ConvertTimeZone { get; set; }
Property Value
Type | Description
System.Boolean |

cur_res

Declaration
public IMockCollection cur_res { get; set; }
Property Value
Type | Description
IMockCollection |

CurrentCulture

Declaration
public string CurrentCulture { get; set; }
Property Value
Type | Description
System.String |

CurrentNetTransaction

Declaration
[ComVisible(false)]
public IDbTransaction CurrentNetTransaction { get; set; }
Property Value
Type | Description
System.Data.IDbTransaction |

DbHelper

Declaration
[ComVisible(false)]
public SqlHelper DbHelper { get; }
Property Value
Type | Description
SqlHelper |

Distinct

Declaration
public bool Distinct { get; set; }
Property Value
Type | Description
System.Boolean |

ErrorMessage

Declaration
public string ErrorMessage { get; set; }
Property Value
Type | Description
System.String |

ErrorNumber

Declaration
public short ErrorNumber { get; set; }
Property Value
Type | Description
System.Int16 |

ErrorSource

Declaration
public string ErrorSource { get; set; }
Property Value
Type | Description
System.String |

hist_change

Declaration
public bool hist_change { get; }
Property Value
Type | Description
System.Boolean |

IncludeRelations

Declaration
public bool IncludeRelations { get; set; }
Property Value
Type | Description
System.Boolean |

IsInTransaction

Declaration
public bool IsInTransaction { get; }
Property Value
Type | Description
System.Boolean |

IsLoggedIn

Declaration
public bool IsLoggedIn { get; }
Property Value
Type | Description
System.Boolean |

Item[String]

Declaration
[ComVisible(false)]
public object this[string key] { get; set; }
Parameters
Type | Name | Description
System.String | key |
Property Value
Type | Description
System.Object |

LocalTimeZone

Declaration
public string LocalTimeZone { get; set; }
Property Value
Type | Description
System.String |

LocalTimeZoneOffset

Declaration
public int LocalTimeZoneOffset { get; }
Property Value
Type | Description
System.Int32 |

LoginTime

Declaration
public DateTime LoginTime { get; }
Property Value
Type | Description
System.DateTime |

NoRes

Declaration
public bool NoRes { get; set; }
Property Value
Type | Description
System.Boolean |

num_ad

Declaration
public short num_ad { get; set; }
Property Value
Type | Description
System.Int16 |

PasswordRequired

Declaration
public bool PasswordRequired { get; set; }
Property Value
Type | Description
System.Boolean |

QueryEmptyToNull

Declaration
public bool QueryEmptyToNull { get; set; }
Property Value
Type | Description
System.Boolean |

RESEnabled

Declaration
public bool RESEnabled { get; set; }
Property Value
Type | Description
System.Boolean |

rowLimit

Declaration
public int rowLimit { get; set; }
Property Value
Type | Description
System.Int32 |

SessionID

Declaration
public string SessionID { get; }
Property Value
Type | Description
System.String |

SetNullStringsToEmpty

Declaration
public bool SetNullStringsToEmpty { get; set; }
Property Value
Type | Description
System.Boolean |

ThrowErrors

Declaration
public bool ThrowErrors { get; set; }
Property Value
Type | Description
System.Boolean |

TruncateStringFields

Declaration
public bool TruncateStringFields { get; set; }
Property Value
Type | Description
System.Boolean |

UpdateTime

Declaration
public DateTime UpdateTime { get; }
Property Value
Type | Description
System.DateTime |

Methods

accept_object(String, ref String, ref String, ref String, Boolean, String)

Declaration
public short accept_object(string objId, ref string acceptDate, ref string wipBin, ref string localUserName, bool generateTimeBombs, string objectType)
Parameters
Type | Name | Description
System.String | objId |
System.String | acceptDate |
System.String | wipBin |
System.String | localUserName |
System.Boolean | generateTimeBombs |
System.String | objectType |
Returns
Type | Description
System.Int16 |

active_connection()

Declaration
public Connection active_connection()
Returns
Type | Description
ADODB.Connection |

AddAttachment(String, String, String, String, Object, Object)

Declaration
public short AddAttachment(string attachmentName, string filePath, string objectType, string idNumber, object objectObjId, object attachmentType)
Parameters
Type | Name | Description
System.String | attachmentName |
System.String | filePath |
System.String | objectType |
System.String | idNumber |
System.Object | objectObjId |
System.Object | attachmentType |
Returns
Type | Description
System.Int16 |

AppendFilter(Object, String, String, Object, Object)

Declaration
public void AppendFilter(object fcGeneric, string fieldName, string filterOperator, object filterValue, object isAndOr)
Parameters
Type | Name | Description
System.Object | fcGeneric |
System.String | fieldName |
System.String | filterOperator |
System.Object | filterValue |
System.Object | isAndOr |

assign_object(String, ref String, String, ref String, ref String, Boolean, String)

Declaration
public short assign_object(string objId, ref string newUser, string wipBin, ref string assignDate, ref string localUserName, bool generateTimeBombs, string objectType)
Parameters
Type | Name | Description
System.String | objId |
System.String | newUser |
System.String | wipBin |
System.String | assignDate |
System.String | localUserName |
System.Boolean | generateTimeBombs |
System.String | objectType |
Returns
Type | Description
System.Int16 |

auto_dest(String, String, String)

Declaration
public short auto_dest(string objId, string operation, string idNumber)
Parameters
Type | Name | Description
System.String | objId |
System.String | operation |
System.String | idNumber |
Returns
Type | Description
System.Int16 |

AutoDest(String, String, String)

Declaration
public short AutoDest(string the_object, string operation, string idNumber)
Parameters
Type | Name | Description
System.String | the_object |
System.String | operation |
System.String | idNumber |
Returns
Type | Description
System.Int16 |

build_hist(String, String)

Declaration
public string build_hist(string currentHistory, string appendHistory)
Parameters
Type | Name | Description
System.String | currentHistory |
System.String | appendHistory |
Returns
Type | Description
System.String |

build_lists(String, Int32, String, Int32, String, String, String, String, String, String, ref IFCList, ref IFCList, ref IFCList, ref Int16)

Declaration
public void build_lists(string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1, ref IFCList fld_list, ref IFCList type_list, ref IFCList val_list, ref short list_used)
Parameters
Type | Name | Description
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
System.Int16 | list_used |

BuildUserVersionProc()

Declaration
public string BuildUserVersionProc()
Returns
Type | Description
System.String |

change_obj_status(String, ref String, ref String, String, ref String, Boolean, String)

Declaration
public short change_obj_status(string objId, ref string newStatus, ref string changeDate, string notes, ref string localUserName, bool generateTimeBombs, string objectType)
Parameters
Type | Name | Description
System.String | objId |
System.String | newStatus |
System.String | changeDate |
System.String | notes |
System.String | localUserName |
System.Boolean | generateTimeBombs |
System.String | objectType |
Returns
Type | Description
System.Int16 |

ChangePassword(String)

Declaration
public void ChangePassword(string password)
Parameters
Type | Name | Description
System.String | password |

ChangeResGroup(String, Object)

Declaration
public void ChangeResGroup(string newGroup, object saveToDB)
Parameters
Type | Name | Description
System.String | newGroup |
System.Object | saveToDB |

check_cl_trans(String, String, String, String)

Declaration
public short check_cl_trans(string oldCondition, string newCondition, string reqType, string userName)
Parameters
Type | Name | Description
System.String | oldCondition |
System.String | newCondition |
System.String | reqType |
System.String | userName |
Returns
Type | Description
System.Int16 |

CloseAllGenerics()

Declaration
public void CloseAllGenerics()

CloseGenerics(Int16, Object, Object, Object, Object, Object, Object, Object, Object, Object, Object)

Declaration
public void CloseGenerics(short NumGenerics, object Generic1, object Generic2, object Generic3, object Generic4, object Generic5, object Generic6, object Generic7, object Generic8, object Generic9, object Generic10)
Parameters
Type | Name | Description
System.Int16 | NumGenerics |
System.Object | Generic1 |
System.Object | Generic2 |
System.Object | Generic3 |
System.Object | Generic4 |
System.Object | Generic5 |
System.Object | Generic6 |
System.Object | Generic7 |
System.Object | Generic8 |
System.Object | Generic9 |
System.Object | Generic10 |

CloseSession()

Declaration
public void CloseSession()

CommitTransaction()

Declaration
public void CommitTransaction()

ConvertDate(DateTime, String, String)

Declaration
public DateTime ConvertDate(DateTime convertDate, string fromTimeZone, string toTimeZone)
Parameters
Type | Name | Description
System.DateTime | convertDate |
System.String | fromTimeZone |
System.String | toTimeZone |
Returns
Type | Description
System.DateTime |

ConvertFromLocalToServerTZ(DateTime)

Declaration
public DateTime ConvertFromLocalToServerTZ(DateTime convertDate)
Parameters
Type | Name | Description
System.DateTime | convertDate |
Returns
Type | Description
System.DateTime |

ConvertFromServerToLocalTZ(DateTime)

Declaration
public DateTime ConvertFromServerToLocalTZ(DateTime convertDate)
Parameters
Type | Name | Description
System.DateTime | convertDate |
Returns
Type | Description
System.DateTime |

create_act_entry(IFCGeneric, String, Int32, Int32, String, IFCGeneric, String, String, Object)

Declaration
public void create_act_entry(IFCGeneric mainRecord, string actName, int userId, int actCode, string currentDateTime, IFCGeneric activityRecord, string additionalInfo, string objectType, object optLinkRecord)
Parameters
Type | Name | Description
IFCGeneric | mainRecord |
System.String | actName |
System.Int32 | userId |
System.Int32 | actCode |
System.String | currentDateTime |
IFCGeneric | activityRecord |
System.String | additionalInfo |
System.String | objectType |
System.Object | optLinkRecord |

create_act_entry(IFCGeneric, String, Int32, Int32, String, IFCGeneric, String, String, String, Object)

Declaration
public void create_act_entry(IFCGeneric mainRecord, string actName, int userId, int actCode, string currentDateTime, IFCGeneric activityRecord, string additionalInfo, string objectType, string impersonatorUserName, object optLinkRecord)
Parameters
Type | Name | Description
IFCGeneric | mainRecord |
System.String | actName |
System.Int32 | userId |
System.Int32 | actCode |
System.String | currentDateTime |
IFCGeneric | activityRecord |
System.String | additionalInfo |
System.String | objectType |
System.String | impersonatorUserName |
System.Object | optLinkRecord |

create_time_bomb(ref IFCGeneric, IFCGeneric, String, IFCGeneric, String, Int32, String, String, Object)

Declaration
public void create_time_bomb(ref IFCGeneric timeBombRecord, IFCGeneric mainRecord, string t_save, IFCGeneric activityRecord, string the_type, int emp_rec, string t_date, string focus_obj, object new_generic)
Parameters
Type | Name | Description
IFCGeneric | timeBombRecord |
IFCGeneric | mainRecord |
System.String | t_save |
IFCGeneric | activityRecord |
System.String | the_type |
System.Int32 | emp_rec |
System.String | t_date |
System.String | focus_obj |
System.Object | new_generic |

create_time_bomb(ref IFCGeneric, IFCGeneric, String, IFCGeneric, String, Int32, String, String, String, Object)

Declaration
public void create_time_bomb(ref IFCGeneric timeBombRecord, IFCGeneric mainRecord, string t_save, IFCGeneric activityRecord, string the_type, int emp_rec, string t_date, string focus_obj, string escalate_time, object new_generic)
Parameters
Type | Name | Description
IFCGeneric | timeBombRecord |
IFCGeneric | mainRecord |
System.String | t_save |
IFCGeneric | activityRecord |
System.String | the_type |
System.Int32 | emp_rec |
System.String | t_date |
System.String | focus_obj |
System.String | escalate_time |
System.Object | new_generic |

create_time_bomb(Int32, ref IFCGeneric, IFCGeneric, String, IFCGeneric, Int32, String, String, Object)

Declaration
[ComVisible(false)]
public void create_time_bomb(int timeBombFlag, ref IFCGeneric timeBombRecord, IFCGeneric mainRecord, string t_save, IFCGeneric activityRecord, int emp_rec, string t_date, string focus_obj, object new_generic)
Parameters
Type | Name | Description
System.Int32 | timeBombFlag |
IFCGeneric | timeBombRecord |
IFCGeneric | mainRecord |
System.String | t_save |
IFCGeneric | activityRecord |
System.Int32 | emp_rec |
System.String | t_date |
System.String | focus_obj |
System.Object | new_generic |

create_time_bomb(Int32, ref IFCGeneric, IFCGeneric, String, IFCGeneric, Int32, String, String, String, Object)

Declaration
[ComVisible(false)]
public void create_time_bomb(int timeBombFlag, ref IFCGeneric timeBombRecord, IFCGeneric mainRecord, string t_save, IFCGeneric activityRecord, int emp_rec, string t_date, string focus_obj, string escalate_time, object new_generic)
Parameters
Type | Name | Description
System.Int32 | timeBombFlag |
IFCGeneric | timeBombRecord |
IFCGeneric | mainRecord |
System.String | t_save |
IFCGeneric | activityRecord |
System.Int32 | emp_rec |
System.String | t_date |
System.String | focus_obj |
System.String | escalate_time |
System.Object | new_generic |

createBulk(String)

Declaration
public IFCBulk createBulk(string bulkName)
Parameters
Type | Name | Description
System.String | bulkName |
Returns
Type | Description
IFCBulk |

CreateGeneric(Object)

Declaration
public IFCGeneric CreateGeneric(object dbObjectName)
Parameters
Type | Name | Description
System.Object | dbObjectName |
Returns
Type | Description
IFCGeneric |

CreateSqlExec()

Declaration
public IFCSqlExec CreateSqlExec()
Returns
Type | Description
IFCSqlExec |

dispatch_object(String, String, ref String, ref String, Boolean, String)

Declaration
public short dispatch_object(string objId, string queueName, ref string dispatchDate, ref string localUserName, bool generateTimeBombs, string objectType)
Parameters
Type | Name | Description
System.String | objId |
System.String | queueName |
System.String | dispatchDate |
System.String | localUserName |
System.Boolean | generateTimeBombs |
System.String | objectType |
Returns
Type | Description
System.Int16 |

Dispose()

Declaration
public void Dispose()

error_handler(Int16, String, String, FCExceptionBase)

Declaration
[ComVisible(false)]
public short error_handler(short errorNum, string objId, string source, FCExceptionBase exception)
Parameters
Type | Name | Description
System.Int16 | errorNum |
System.String | objId |
System.String | source |
FCExceptionBase | exception |
Returns
Type | Description
System.Int16 |

error_handler(Int16, String, String, String)

Declaration
public short error_handler(short error_num, string objId, string source, string message)
Parameters
Type | Name | Description
System.Int16 | error_num |
System.String | objId |
System.String | source |
System.String | message |
Returns
Type | Description
System.Int16 |

error_handler(Int32, String, String, String, Exception)

Declaration
[ComVisible(false)]
public short error_handler(int error_num, string objId, string source, string message, Exception ex)
Parameters
Type | Name | Description
System.Int32 | error_num |
System.String | objId |
System.String | source |
System.String | message |
System.Exception | ex |
Returns
Type | Description
System.Int16 |

ExecuteSQL(String, ref Recordset)

Declaration
public void ExecuteSQL(string sql, ref Recordset records)
Parameters
Type | Name | Description
System.String | sql |
ADODB.Recordset | records |

ExecuteSQLNoReturn(String)

Declaration
public void ExecuteSQLNoReturn(string sql)
Parameters
Type | Name | Description
System.String | sql |

format_time(Int32)

Declaration
public string format_time(int totalTime)
Parameters
Type | Name | Description
System.Int32 | totalTime |
Returns
Type | Description
System.String |

forward_object(String, String, ref String, String, ref String, Boolean, String)

Declaration
public short forward_object(string objId, string newQueue, ref string forwardDate, string notes, ref string localUserName, bool generateTimeBombs, string objectType)
Parameters
Type | Name | Description
System.String | objId |
System.String | newQueue |
System.String | forwardDate |
System.String | notes |
System.String | localUserName |
System.Boolean | generateTimeBombs |
System.String | objectType |
Returns
Type | Description
System.Int16 |

FreeConnection()

Declaration
public void FreeConnection()

get_item(String)

Declaration
public object get_item(string key)
Parameters
Type | Name | Description
System.String | key |
Returns
Type | Description
System.Object |

get_next_sn(Int16)

Declaration
public object get_next_sn(short the_ind)
Parameters
Type | Name | Description
System.Int16 | the_ind |
Returns
Type | Description
System.Object |

GetColor(String)

Declaration
public string GetColor(string purpose)
Parameters
Type | Name | Description
System.String | purpose |
Returns
Type | Description
System.String |

GetConfigItem(String, String, Object)

Declaration
public object GetConfigItem(string configItem, string fieldName, object loginName)
Parameters
Type | Name | Description
System.String | configItem |
System.String | fieldName |
System.Object | loginName |
Returns
Type | Description
System.Object |

GetCurrentDate()

Declaration
public DateTime GetCurrentDate()
Returns
Type | Description
System.DateTime |

GetCurrentServerDate()

Declaration
public DateTime GetCurrentServerDate()
Returns
Type | Description
System.DateTime |

GetItem(String, Int16, Int16, String)

Declaration
public string GetItem(string path, short startItem, short stopItem, string separator)
Parameters
Type | Name | Description
System.String | path |
System.Int16 | startItem |
System.Int16 | stopItem |
System.String | separator |
Returns
Type | Description
System.String |

GetNextNumScheme(String)

Declaration
public string GetNextNumScheme(string numSchemaName)
Parameters
Type | Name | Description
System.String | numSchemaName |
Returns
Type | Description
System.String |

GetNextSubcaseID(String, Int32)

Declaration
public string GetNextSubcaseID(string caseId, int caseConditionId)
Parameters
Type | Name | Description
System.String | caseId |
System.Int32 | caseConditionId |
Returns
Type | Description
System.String |

GetNextSubcaseID(String, Int32, IDbTransaction)

Declaration
public string GetNextSubcaseID(string caseId, int caseConditionId, IDbTransaction transaction)
Parameters
Type | Name | Description
System.String | caseId |
System.Int32 | caseConditionId |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
System.String |

GetNumGenerics()

Declaration
public int GetNumGenerics()
Returns
Type | Description
System.Int32 |

GetObjid(String)

Declaration
public int GetObjid(string tableName)
Parameters
Type | Name | Description
System.String | tableName |
Returns
Type | Description
System.Int32 |

GetUserVersion(String)

Declaration
public string GetUserVersion(string formName)
Parameters
Type | Name | Description
System.String | formName |
Returns
Type | Description
System.String |

Init_Object(ref IFCGeneric, String, String, String)

Declaration
public IFCGeneric Init_Object(ref IFCGeneric generic, string objectType, string dataFields, string bulkName)
Parameters
Type | Name | Description
IFCGeneric | generic |
System.String | objectType |
System.String | dataFields |
System.String | bulkName |
Returns
Type | Description
IFCGeneric |

IsUnicode(String)

Declaration
public object IsUnicode(string testString)
Parameters
Type | Name | Description
System.String | testString |
Returns
Type | Description
System.Object |

ItemCount(String, String)

Declaration
public short ItemCount(string path, string separator)
Parameters
Type | Name | Description
System.String | path |
System.String | separator |
Returns
Type | Description
System.Int16 |

LoadColors(String)

Declaration
public void LoadColors(string userName)
Parameters
Type | Name | Description
System.String | userName |

LoadUserVersions(Object)

Declaration
public void LoadUserVersions(object userName)
Parameters
Type | Name | Description
System.Object | userName |

Log(String, String)

Declaration
public void Log(string messageType, string message)
Parameters
Type | Name | Description
System.String | messageType |
System.String | message |

LogEx(String, String)

Declaration
public void LogEx(string logLevel, string logMessage)
Parameters
Type | Name | Description
System.String | logLevel |
System.String | logMessage |

Login(String, String, String)

Declaration
public void Login(string username, string password, string loginType)
Parameters
Type | Name | Description
System.String | username |
System.String | password |
System.String | loginType |

LoginFromFCApp()

Declaration
public void LoginFromFCApp()

Logout()

Declaration
public void Logout()

move_object(String, String, String)

Declaration
public short move_object(string objId, string newWipBin, string objectType)
Parameters
Type | Name | Description
System.String | objId |
System.String | newWipBin |
System.String | objectType |
Returns
Type | Description
System.Int16 |

NewEnum()

Declaration
public IEnumerator NewEnum()
Returns
Type | Description
System.Collections.IEnumerator |

RefreshContext()

Declaration
public void RefreshContext()

RegisterLicenseRequirements(Int32)

Declaration
[ComVisible(false)]
public void RegisterLicenseRequirements(int productId)
Parameters
Type | Name | Description
System.Int32 | productId |

reject_object(String, ref String, String, String, ref String, Boolean, String)

Declaration
public short reject_object(string objId, ref string rejectDate, string wipBin, string notes, ref string localUserName, bool generateTimeBombs, string objectType)
Parameters
Type | Name | Description
System.String | objId |
System.String | rejectDate |
System.String | wipBin |
System.String | notes |
System.String | localUserName |
System.Boolean | generateTimeBombs |
System.String | objectType |
Returns
Type | Description
System.Int16 |

RemoveAllGenericsInABulk(String)

Declaration
public void RemoveAllGenericsInABulk(string bulkName)
Parameters
Type | Name | Description
System.String | bulkName |

RollbackTransaction()

Declaration
public void RollbackTransaction()

SaveSession()

Declaration
public void SaveSession()

set_item(String, Object)

Declaration
public void set_item(string key, object newValue)
Parameters
Type | Name | Description
System.String | key |
System.Object | newValue |

SetNullStringToEmpty(Object)

Declaration
public object SetNullStringToEmpty(object inputString)
Parameters
Type | Name | Description
System.Object | inputString |
Returns
Type | Description
System.Object |

SetPassword(String, String, String)

Declaration
public void SetPassword(string loginName, string password, string loginType)
Parameters
Type | Name | Description
System.String | loginName |
System.String | password |
System.String | loginType |

SimpleQuery(ref IFCGeneric, String, String, String)

Declaration
public void SimpleQuery(ref IFCGeneric generic, string objectType, string dataFields, string bulkName)
Parameters
Type | Name | Description
IFCGeneric | generic |
System.String | objectType |
System.String | dataFields |
System.String | bulkName |

single_quotify(String)

Declaration
public string single_quotify(string inputString)
Parameters
Type | Name | Description
System.String | inputString |
Returns
Type | Description
System.String |

sprintf(String, Object, Object, Object, Object, Object, Object)

Declaration
public string sprintf(string inputString, object arg1, object arg2, object arg3, object arg4, object arg5, object arg6)
Parameters
Type | Name | Description
System.String | inputString |
System.Object | arg1 |
System.Object | arg2 |
System.Object | arg3 |
System.Object | arg4 |
System.Object | arg5 |
System.Object | arg6 |
Returns
Type | Description
System.String |

StartTransaction(Object)

Declaration
public void StartTransaction(object isolationLevel)
Parameters
Type | Name | Description
System.Object | isolationLevel |

TraverseFromParent(ref IFCGeneric, String, String, String, IFCGeneric, String)

Declaration
public IFCGeneric TraverseFromParent(ref IFCGeneric generic, string objectType, string dataFields, string bulkName, IFCGeneric parentGeneric, string relationName)
Parameters
Type | Name | Description
IFCGeneric | generic |
System.String | objectType |
System.String | dataFields |
System.String | bulkName |
IFCGeneric | parentGeneric |
System.String | relationName |
Returns
Type | Description
IFCGeneric |

turn_off(Int32, Int32)

Declaration
public int turn_off(int bigNum, int smallNum)
Parameters
Type | Name | Description
System.Int32 | bigNum |
System.Int32 | smallNum |
Returns
Type | Description
System.Int32 |

use_list(IFCGeneric, Object, Object, Object)

Declaration
public void use_list(IFCGeneric generic, object fieldList, object typeList, object valueList)
Parameters
Type | Name | Description
IFCGeneric | generic |
System.Object | fieldList |
System.Object | typeList |
System.Object | valueList |

yank_object(String, String, ref String, ref String, Boolean, String)

Declaration
public short yank_object(string objId, string wipBin, ref string yankDate, ref string localUserName, bool generateTimeBombs, string objectType)
Parameters
Type | Name | Description
System.String | objId |
System.String | wipBin |
System.String | yankDate |
System.String | localUserName |
System.Boolean | generateTimeBombs |
System.String | objectType |
Returns
Type | Description
System.Int16 |

Implements

IFCSession
System.IDisposable


Class FCSqlExec | fcSDK Documentation

Class FCSqlExec

Inheritance
System.Object
FCSqlExec
Implements
IFCSqlExec
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Compatibility
Assembly: FChoice.Foundation.Clarify.Compatibility.dll
Syntax
[ComVisible(true)]
[Guid("DA8E45C3-FD13-4ab4-8CCD-8E3DF8635519")]
[ClassInterface(ClassInterfaceType.None)]
public sealed class FCSqlExec : IFCSqlExec

Properties

CurrentConnection

Declaration
[ComVisible(false)]
public IDbConnection CurrentConnection { get; }
Property Value
Type | Description
System.Data.IDbConnection |

Records

Declaration
public Recordset Records { get; }
Property Value
Type | Description
ADODB.Recordset |

StayConnected

Declaration
public bool StayConnected { get; set; }
Property Value
Type | Description
System.Boolean |

Methods

AddSqlParameter(Object)

Declaration
public void AddSqlParameter(object value)
Parameters
Type | Name | Description
System.Object | value |

CloseConnection()

Declaration
public void CloseConnection()

Execute(String)

Declaration
public void Execute(string SqlStr)
Parameters
Type | Name | Description
System.String | SqlStr |

ExecuteReturnRows(String)

Declaration
public void ExecuteReturnRows(string sqlStatement)
Parameters
Type | Name | Description
System.String | sqlStatement |

FreeConnection()

Declaration
public void FreeConnection()

OpenConnection(String, String, String, String, String)

Declaration
public void OpenConnection(string TheDB, string UserName, string password, string DBServer, string DBName)
Parameters
Type | Name | Description
System.String | TheDB |
System.String | UserName |
System.String | password |
System.String | DBServer |
System.String | DBName |

Implements

IFCSqlExec


Interface IFCApplication | fcSDK Documentation

Interface IFCApplication

Namespace: FChoice.Foundation.Clarify.Compatibility
Assembly: FChoice.Foundation.Clarify.Compatibility.dll
Syntax
[Guid("76778FF4-8666-4eba-A60A-DA8D9F743A64")]
[ComVisible(true)]
public interface IFCApplication

Properties

base_objid

Declaration
int base_objid { get; }
Property Value
Type | Description
System.Int32 |

clarify_ver

Declaration
string clarify_ver { get; }
Property Value
Type | Description
System.String |

ConnectionString

Declaration
string ConnectionString { get; }
Property Value
Type | Description
System.String |

ConvertTimeZone

Declaration
bool ConvertTimeZone { get; set; }
Property Value
Type | Description
System.Boolean |

DataProtectorEntropy

Declaration
string DataProtectorEntropy { set; }
Property Value
Type | Description
System.String |

db_name

Declaration
string db_name { get; }
Property Value
Type | Description
System.String |

db_type

Declaration
string db_type { get; }
Property Value
Type | Description
System.String |

GetMachineTimeZone

Declaration
string GetMachineTimeZone { get; }
Property Value
Type | Description
System.String |

IsDBTraveler

Declaration
bool IsDBTraveler { get; }
Property Value
Type | Description
System.Boolean |

IsDBUnicode

Declaration
bool IsDBUnicode { get; }
Property Value
Type | Description
System.Boolean |

IsFcflNet

Declaration
bool IsFcflNet { get; }
Property Value
Type | Description
System.Boolean |

LicenseExpirationDate

Declaration
string LicenseExpirationDate { get; }
Property Value
Type | Description
System.String |

LoggingConfigFilePath

Declaration
string LoggingConfigFilePath { get; set; }
Property Value
Type | Description
System.String |

Midnight

Declaration
string Midnight { get; set; }
Property Value
Type | Description
System.String |

schema_rev

Declaration
short schema_rev { get; }
Property Value
Type | Description
System.Int16 |

ServerTimeZone

Declaration
string ServerTimeZone { get; set; }
Property Value
Type | Description
System.String |

site_id

Declaration
short site_id { get; }
Property Value
Type | Description
System.Int16 |

TruncateStringFields

Declaration
bool TruncateStringFields { get; set; }
Property Value
Type | Description
System.Boolean |

WorkingDirectory

Declaration
string WorkingDirectory { get; set; }
Property Value
Type | Description
System.String |

Methods

build_mtm_name(String, String, String)

Declaration
string build_mtm_name(string tableName, string relationName, string inverseRelatioName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | relationName |
System.String | inverseRelatioName |
Returns
Type | Description
System.String |

CreateSession(Object)

Declaration
FCSession CreateSession(object sessionId)
Parameters
Type | Name | Description
System.Object | sessionId |
Returns
Type | Description
FCSession |

CurrentSessions()

Declaration
string CurrentSessions()
Returns
Type | Description
System.String |

EncryptClarifyPassword(String, String)

Declaration
string EncryptClarifyPassword(string password, string fc_session_id)
Parameters
Type | Name | Description
System.String | password |
System.String | fc_session_id |
Returns
Type | Description
System.String |

EncryptDBPassword(String)

Declaration
string EncryptDBPassword(string password)
Parameters
Type | Name | Description
System.String | password |
Returns
Type | Description
System.String |

FileExists(String)

Declaration
bool FileExists(string path)
Parameters
Type | Name | Description
System.String | path |
Returns
Type | Description
System.Boolean |

FindString(Object)

Declaration
string FindString(object StringID)
Parameters
Type | Name | Description
System.Object | StringID |
Returns
Type | Description
System.String |

get_change_date_field(String)

Declaration
string get_change_date_field(string tableName)
Parameters
Type | Name | Description
System.String | tableName |
Returns
Type | Description
System.String |

get_dt_fields(String)

Declaration
string get_dt_fields(string tableName)
Parameters
Type | Name | Description
System.String | tableName |
Returns
Type | Description
System.String |

get_fields_types_lens(String, Boolean)

Declaration
string get_fields_types_lens(string tableName, bool includeRelations)
Parameters
Type | Name | Description
System.String | tableName |
System.Boolean | includeRelations |
Returns
Type | Description
System.String |

GetADPObjects(Object)

Declaration
Recordset GetADPObjects(object ObjectTypes)
Parameters
Type | Name | Description
System.Object | ObjectTypes |
Returns
Type | Description
ADODB.Recordset |

GetCountryList()

Declaration
Recordset GetCountryList()
Returns
Type | Description
ADODB.Recordset |

GetCountryObjid(String)

Declaration
int GetCountryObjid(string Country)
Parameters
Type | Name | Description
System.String | Country |
Returns
Type | Description
System.Int32 |

GetDefaultCountry()

Declaration
string GetDefaultCountry()
Returns
Type | Description
System.String |

GetDefaultCountryObjId()

Declaration
int GetDefaultCountryObjId()
Returns
Type | Description
System.Int32 |

GetDefaultState(String)

Declaration
string GetDefaultState(string Country)
Parameters
Type | Name | Description
System.String | Country |
Returns
Type | Description
System.String |

GetDefaultStateObjid(String)

Declaration
int GetDefaultStateObjid(string Country)
Parameters
Type | Name | Description
System.String | Country |
Returns
Type | Description
System.Int32 |

GetDefaultTimeZone()

Declaration
string GetDefaultTimeZone()
Returns
Type | Description
System.String |

GetDefaultTimeZoneObjid()

Declaration
int GetDefaultTimeZoneObjid()
Returns
Type | Description
System.Int32 |

GetFullStateObjid(String, String)

Declaration
int GetFullStateObjid(string Country, string State)
Parameters
Type | Name | Description
System.String | Country |
System.String | State |
Returns
Type | Description
System.Int32 |

GetGbstDefault(String)

Declaration
string GetGbstDefault(string ListName)
Parameters
Type | Name | Description
System.String | ListName |
Returns
Type | Description
System.String |

GetGbstDefaultObjid(String)

Declaration
int GetGbstDefaultObjid(string ListName)
Parameters
Type | Name | Description
System.String | ListName |
Returns
Type | Description
System.Int32 |

GetGbstElmById(String, Int32)

Declaration
string GetGbstElmById(string ListName, int ElmObjid)
Parameters
Type | Name | Description
System.String | ListName |
System.Int32 | ElmObjid |
Returns
Type | Description
System.String |

GetGbstElmObjid(String, String)

Declaration
int GetGbstElmObjid(string ListName, string Element)
Parameters
Type | Name | Description
System.String | ListName |
System.String | Element |
Returns
Type | Description
System.Int32 |

GetGbstElmRankObjid(String, Int32)

Declaration
int GetGbstElmRankObjid(string ListName, int Rank)
Parameters
Type | Name | Description
System.String | ListName |
System.Int32 | Rank |
Returns
Type | Description
System.Int32 |

GetGbstList(String, Object)

Declaration
Recordset GetGbstList(string ListName, object IncludeInactive)
Parameters
Type | Name | Description
System.String | ListName |
System.Object | IncludeInactive |
Returns
Type | Description
ADODB.Recordset |

GetHgbstElmDefault(String, Object, Object, Object, Object)

Declaration
string GetHgbstElmDefault(string ListName, object Element1, object Element2, object Element3, object Element4)
Parameters
Type | Name | Description
System.String | ListName |
System.Object | Element1 |
System.Object | Element2 |
System.Object | Element3 |
System.Object | Element4 |
Returns
Type | Description
System.String |

GetHgbstElmDefaultObjid(String, Object, Object, Object, Object)

Declaration
int GetHgbstElmDefaultObjid(string ListName, object Element1, object Element2, object Element3, object Element4)
Parameters
Type | Name | Description
System.String | ListName |
System.Object | Element1 |
System.Object | Element2 |
System.Object | Element3 |
System.Object | Element4 |
Returns
Type | Description
System.Int32 |

GetHgbstElmObjId(String, String, Object, Object, Object, Object)

Declaration
int GetHgbstElmObjId(string TheElement, string ListName, object Element1, object Element2, object Element3, object Element4)
Parameters
Type | Name | Description
System.String | TheElement |
System.String | ListName |
System.Object | Element1 |
System.Object | Element2 |
System.Object | Element3 |
System.Object | Element4 |
Returns
Type | Description
System.Int32 |

GetHgbstList(String, Object, Object, Object, Object, Object)

Declaration
Recordset GetHgbstList(string ListName, object Element1, object Element2, object Element3, object Element4, object includeInactive)
Parameters
Type | Name | Description
System.String | ListName |
System.Object | Element1 |
System.Object | Element2 |
System.Object | Element3 |
System.Object | Element4 |
System.Object | includeInactive |
Returns
Type | Description
ADODB.Recordset |

GetLocalizedGbstDefault(String)

Declaration
string GetLocalizedGbstDefault(string listName)
Parameters
Type | Name | Description
System.String | listName |
Returns
Type | Description
System.String |

GetLocalizedGbstElmById(String, Int32)

Declaration
string GetLocalizedGbstElmById(string listName, int elmObjID)
Parameters
Type | Name | Description
System.String | listName |
System.Int32 | elmObjID |
Returns
Type | Description
System.String |

GetRelationData(String, String)

Declaration
Recordset GetRelationData(string relationName, string tableName)
Parameters
Type | Name | Description
System.String | relationName |
System.String | tableName |
Returns
Type | Description
ADODB.Recordset |

GetResClauses(Int32, ref String)

Declaration
bool GetResClauses(int tblNum, ref string clauses)
Parameters
Type | Name | Description
System.Int32 | tblNum |
System.String | clauses |
Returns
Type | Description
System.Boolean |

GetResClausesStr(Int32)

Declaration
string GetResClausesStr(int tblNum)
Parameters
Type | Name | Description
System.Int32 | tblNum |
Returns
Type | Description
System.String |

GetResTbl(Int32, ref String[])

Declaration
bool GetResTbl(int tblNum, ref string[] the_res)
Parameters
Type | Name | Description
System.Int32 | tblNum |
System.String[] | the_res |
Returns
Type | Description
System.Boolean |

GetServerTimeZoneOffset()

Declaration
int GetServerTimeZoneOffset()
Returns
Type | Description
System.Int32 |

GetShortTimeZoneObjId(String)

Declaration
int GetShortTimeZoneObjId(string TimeZone)
Parameters
Type | Name | Description
System.String | TimeZone |
Returns
Type | Description
System.Int32 |

GetStateObjid(String, String)

Declaration
int GetStateObjid(string Country, string State)
Parameters
Type | Name | Description
System.String | Country |
System.String | State |
Returns
Type | Description
System.Int32 |

GetStates(String)

Declaration
Recordset GetStates(string Country)
Parameters
Type | Name | Description
System.String | Country |
Returns
Type | Description
ADODB.Recordset |

GetTableFields(String)

Declaration
Recordset GetTableFields(string tableName)
Parameters
Type | Name | Description
System.String | tableName |
Returns
Type | Description
ADODB.Recordset |

GetTableID(String)

Declaration
int GetTableID(string TableName)
Parameters
Type | Name | Description
System.String | TableName |
Returns
Type | Description
System.Int32 |

GetTableName(Int32)

Declaration
string GetTableName(int TableNum)
Parameters
Type | Name | Description
System.Int32 | TableNum |
Returns
Type | Description
System.String |

GetTableRels(String, Boolean)

Declaration
Recordset GetTableRels(string tableName, bool allowOneToMany)
Parameters
Type | Name | Description
System.String | tableName |
System.Boolean | allowOneToMany |
Returns
Type | Description
ADODB.Recordset |

GetTablesAndViews(Object)

Declaration
Recordset GetTablesAndViews(object TablesOnly)
Parameters
Type | Name | Description
System.Object | TablesOnly |
Returns
Type | Description
ADODB.Recordset |

GetTimeZoneList()

Declaration
Recordset GetTimeZoneList()
Returns
Type | Description
ADODB.Recordset |

GetTimeZoneObjid(String)

Declaration
int GetTimeZoneObjid(string TimeZone)
Parameters
Type | Name | Description
System.String | TimeZone |
Returns
Type | Description
System.Int32 |

GetTimeZoneOffset(String)

Declaration
int GetTimeZoneOffset(string TimeZone)
Parameters
Type | Name | Description
System.String | TimeZone |
Returns
Type | Description
System.Int32 |

GetTimeZonesInCountry(String)

Declaration
Recordset GetTimeZonesInCountry(string Country)
Parameters
Type | Name | Description
System.String | Country |
Returns
Type | Description
ADODB.Recordset |

Initialize()

Declaration
void Initialize()

InitializeFull(String, String, String, String, Object, Object, Object, Object, Object, Object, Object, Object, Object, Object)

Declaration
void InitializeFull(string LoginName, string password, string DBServer, string DBName, object DBType, object LogFile, object SqlLogFile, object SQLLogging, object fcAppLogging, object fcSessionLogging, object fcGenericLogging, object fcBulkLogging, object fcSqlExecLogging, object NoCacheFile)
Parameters
Type | Name | Description
System.String | LoginName |
System.String | password |
System.String | DBServer |
System.String | DBName |
System.Object | DBType |
System.Object | LogFile |
System.Object | SqlLogFile |
System.Object | SQLLogging |
System.Object | fcAppLogging |
System.Object | fcSessionLogging |
System.Object | fcGenericLogging |
System.Object | fcBulkLogging |
System.Object | fcSqlExecLogging |
System.Object | NoCacheFile |

is_it_a_field(String, String)

Declaration
bool is_it_a_field(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

is_it_a_table(String)

Declaration
bool is_it_a_table(string tableName)
Parameters
Type | Name | Description
System.String | tableName |
Returns
Type | Description
System.Boolean |

is_it_change_field(String, String)

Declaration
bool is_it_change_field(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

is_it_date_field(String, String)

Declaration
bool is_it_date_field(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

is_it_int_field(String, String)

Declaration
bool is_it_int_field(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

is_it_searchable(String, String)

Declaration
bool is_it_searchable(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

is_it_string_fld(String, String)

Declaration
bool is_it_string_fld(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

is_it_unicode(String, String)

Declaration
bool is_it_unicode(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

is_rel_exclusive(Int32, String, ref String, ref String)

Declaration
bool is_rel_exclusive(int tbl_num, string relationName, ref string tbl_fld, ref string objid_fld)
Parameters
Type | Name | Description
System.Int32 | tbl_num |
System.String | relationName |
System.String | tbl_fld |
System.String | objid_fld |
Returns
Type | Description
System.Boolean |

is_rel_mandatory(Int32, String)

Declaration
bool is_rel_mandatory(int tbl_num, string relationName)
Parameters
Type | Name | Description
System.Int32 | tbl_num |
System.String | relationName |
Returns
Type | Description
System.Boolean |

IsCountry(String)

Declaration
bool IsCountry(string Country)
Parameters
Type | Name | Description
System.String | Country |
Returns
Type | Description
System.Boolean |

IsFullState(String, String)

Declaration
bool IsFullState(string Country, string State)
Parameters
Type | Name | Description
System.String | Country |
System.String | State |
Returns
Type | Description
System.Boolean |

IsInGbstLst(String, String)

Declaration
bool IsInGbstLst(string ListName, string Element)
Parameters
Type | Name | Description
System.String | ListName |
System.String | Element |
Returns
Type | Description
System.Boolean |

IsInHgbstList(String, String, Object, Object, Object, Object)

Declaration
bool IsInHgbstList(string TheElement, string ListName, object Element1, object Element2, object Element3, object Element4)
Parameters
Type | Name | Description
System.String | TheElement |
System.String | ListName |
System.Object | Element1 |
System.Object | Element2 |
System.Object | Element3 |
System.Object | Element4 |
Returns
Type | Description
System.Boolean |

IsOnDST(String, DateTime)

Declaration
bool IsOnDST(string TheTimeZone, DateTime TheDate)
Parameters
Type | Name | Description
System.String | TheTimeZone |
System.DateTime | TheDate |
Returns
Type | Description
System.Boolean |

IsState(String, String)

Declaration
bool IsState(string Country, string State)
Parameters
Type | Name | Description
System.String | Country |
System.String | State |
Returns
Type | Description
System.Boolean |

IsTimeZone(String)

Declaration
bool IsTimeZone(string TImeZone)
Parameters
Type | Name | Description
System.String | TImeZone |
Returns
Type | Description
System.Boolean |

IsTimeZoneInCountry(String, String, Boolean)

Declaration
bool IsTimeZoneInCountry(string Country, string TimeZone, bool IsFullName)
Parameters
Type | Name | Description
System.String | Country |
System.String | TimeZone |
System.Boolean | IsFullName |
Returns
Type | Description
System.Boolean |

Log(Object, Object)

Declaration
void Log(object TheMessageType, object TheMessage)
Parameters
Type | Name | Description
System.Object | TheMessageType |
System.Object | TheMessage |

LogEx(String, String)

Declaration
void LogEx(string logLevel, string logMessage)
Parameters
Type | Name | Description
System.String | logLevel |
System.String | logMessage |

RankIsInGbstLst(String, Int32)

Declaration
bool RankIsInGbstLst(string ListName, int Rank)
Parameters
Type | Name | Description
System.String | ListName |
System.Int32 | Rank |
Returns
Type | Description
System.Boolean |

SetServerTimeZoneToMachineTimeZone()

Declaration
void SetServerTimeZoneToMachineTimeZone()

sprintf(String, Object, Object, Object, Object, Object, Object)

Declaration
string sprintf(string inputString, object arg1, object arg2, object arg3, object arg4, object arg5, object arg6)
Parameters
Type | Name | Description
System.String | inputString |
System.Object | arg1 |
System.Object | arg2 |
System.Object | arg3 |
System.Object | arg4 |
System.Object | arg5 |
System.Object | arg6 |
Returns
Type | Description
System.String |

UpdateCache()

Declaration
void UpdateCache()

UpdateSchemaCache()

Declaration
void UpdateSchemaCache()

ValidateEncryptedPassword(String, String, Int16)

Declaration
bool ValidateEncryptedPassword(string str, string encr, short pre9)
Parameters
Type | Name | Description
System.String | str |
System.String | encr |
System.Int16 | pre9 |
Returns
Type | Description
System.Boolean |


Interface IFCBulk | fcSDK Documentation

Interface IFCBulk

Namespace: FChoice.Foundation.Clarify.Compatibility
Assembly: FChoice.Foundation.Clarify.Compatibility.dll
Syntax
[Guid("3D860A38-CDDA-4653-88DC-F7BB6AD46E94")]
[ComVisible(true)]
public interface IFCBulk

Properties

BulkID

Declaration
short BulkID { get; set; }
Property Value
Type | Description
System.Int16 |

Name

Declaration
string Name { get; set; }
Property Value
Type | Description
System.String |

NoSorting

Declaration
bool NoSorting { get; set; }
Property Value
Type | Description
System.Boolean |

Methods

AddGeneric(IFCGeneric)

Declaration
void AddGeneric(IFCGeneric generic)
Parameters
Type | Name | Description
IFCGeneric | generic |

ChangeGenericsOrdering(IFCGeneric)

Declaration
void ChangeGenericsOrdering(IFCGeneric generic)
Parameters
Type | Name | Description
IFCGeneric | generic |

NewEnum()

Declaration
IEnumerator NewEnum()
Returns
Type | Description
System.Collections.IEnumerator |

Query()

Declaration
void Query()

RemoveAllGenerics()

Declaration
void RemoveAllGenerics()

RemoveGeneric(IFCGeneric)

Declaration
void RemoveGeneric(IFCGeneric generic)
Parameters
Type | Name | Description
IFCGeneric | generic |

Update()

Declaration
void Update()

UpdateAll()

Declaration
void UpdateAll()


Interface IFCGeneric | fcSDK Documentation

Interface IFCGeneric

Namespace: FChoice.Foundation.Clarify.Compatibility
Assembly: FChoice.Foundation.Clarify.Compatibility.dll
Syntax
[Guid("545582EE-2D64-4869-AC88-7D1B5031A960")]
[ComVisible(true)]
public interface IFCGeneric

Properties

BOF

Declaration
bool BOF { get; }
Property Value
Type | Description
System.Boolean |

Bulk

Declaration
IFCBulk Bulk { get; set; }
Property Value
Type | Description
IFCBulk |

BulkName

Declaration
string BulkName { get; set; }
Property Value
Type | Description
System.String |

child_objects

Declaration
IMockCollection child_objects { get; }
Property Value
Type | Description
IMockCollection |

DataFields

Declaration
string DataFields { get; set; }
Property Value
Type | Description
System.String |

DbObjectName

Declaration
string DbObjectName { get; set; }
Property Value
Type | Description
System.String |

DbObjectNum

Declaration
int DbObjectNum { get; }
Property Value
Type | Description
System.Int32 |

DelRelList

Declaration
string DelRelList { get; set; }
Property Value
Type | Description
System.String |

Distinct

Declaration
bool Distinct { get; set; }
Property Value
Type | Description
System.Boolean |

EOF

Declaration
bool EOF { get; }
Property Value
Type | Description
System.Boolean |

ErrorOnQueryTooBig

Declaration
bool ErrorOnQueryTooBig { get; set; }
Property Value
Type | Description
System.Boolean |

Filter

Declaration
string Filter { get; set; }
Property Value
Type | Description
System.String |

GenericId

Declaration
string GenericId { get; set; }
Property Value
Type | Description
System.String |

Id

Declaration
int Id { get; }
Property Value
Type | Description
System.Int32 |

IncludeRelations

Declaration
bool IncludeRelations { get; set; }
Property Value
Type | Description
System.Boolean |

Item[Object]

Declaration
[ComVisible(false)]
IMockAdoField this[object index] { get; set; }
Parameters
Type | Name | Description
System.Object | index |
Property Value
Type | Description
IMockAdoField |

MaxRecords

Declaration
int MaxRecords { get; set; }
Property Value
Type | Description
System.Int32 |

NoRes

Declaration
bool NoRes { get; set; }
Property Value
Type | Description
System.Boolean |

ParentBO

Declaration
IFCGeneric ParentBO { get; set; }
Property Value
Type | Description
IFCGeneric |

ParentRelation

Declaration
string ParentRelation { get; set; }
Property Value
Type | Description
System.String |

Position

Declaration
short Position { get; set; }
Property Value
Type | Description
System.Int16 |

QueryEmptyToNull

Declaration
bool QueryEmptyToNull { get; set; }
Property Value
Type | Description
System.Boolean |

records

Declaration
Recordset records { get; }
Property Value
Type | Description
ADODB.Recordset |

rel_from_parent

Declaration
string rel_from_parent { get; }
Property Value
Type | Description
System.String |

rel_to_parent

Declaration
string rel_to_parent { get; }
Property Value
Type | Description
System.String |

rel_type

Declaration
short rel_type { get; }
Property Value
Type | Description
System.Int16 |

rowLimit

Declaration
int rowLimit { get; set; }
Property Value
Type | Description
System.Int32 |

rowsReturned

Declaration
int rowsReturned { get; }
Property Value
Type | Description
System.Int32 |

SetNullStringsToEmpty

Declaration
bool SetNullStringsToEmpty { get; set; }
Property Value
Type | Description
System.Boolean |

SortOrder

Declaration
string SortOrder { get; set; }
Property Value
Type | Description
System.String |

Methods

AddForUpdate(Int32)

Declaration
void AddForUpdate(int TheObjid)
Parameters
Type | Name | Description
System.Int32 | TheObjid |

AddNew()

Declaration
void AddNew()

AppendFilter(String, String, Object)

Declaration
void AppendFilter(string field_name, string operation, object value)
Parameters
Type | Name | Description
System.String | field_name |
System.String | operation |
System.Object | value |

AppendSort(String, String)

Declaration
void AppendSort(string field_name, string ascending)
Parameters
Type | Name | Description
System.String | field_name |
System.String | ascending |

AssignAllObjids()

Declaration
void AssignAllObjids()

AssignObjid()

Declaration
void AssignObjid()

ClearRoot()

Declaration
void ClearRoot()

CloseGeneric()

Declaration
void CloseGeneric()

copy(Object)

Declaration
IFCGeneric copy(object use_generic)
Parameters
Type | Name | Description
System.Object | use_generic |
Returns
Type | Description
IFCGeneric |

Count()

Declaration
int Count()
Returns
Type | Description
System.Int32 |

Delete()

Declaration
void Delete()

DeleteAll()

Declaration
void DeleteAll()

Duplicate(Object)

Declaration
IFCGeneric Duplicate(object use_generic)
Parameters
Type | Name | Description
System.Object | use_generic |
Returns
Type | Description
IFCGeneric |

get_Fields(Object)

Declaration
object get_Fields(object index)
Parameters
Type | Name | Description
System.Object | index |
Returns
Type | Description
System.Object |

GetField(String)

Declaration
object GetField(string fieldName)
Parameters
Type | Name | Description
System.String | fieldName |
Returns
Type | Description
System.Object |

GetFieldValue(Object)

Declaration
object GetFieldValue(object index)
Parameters
Type | Name | Description
System.Object | index |
Returns
Type | Description
System.Object |

MoveFirst()

Declaration
void MoveFirst()

MoveFirstAbsolute()

Declaration
void MoveFirstAbsolute()

MoveLast()

Declaration
void MoveLast()

MoveLastAbsolute()

Declaration
void MoveLastAbsolute()

MoveNext()

Declaration
void MoveNext()

MoveNextAbsolute()

Declaration
void MoveNextAbsolute()

MovePrevious()

Declaration
void MovePrevious()

MovePreviousAbsolute()

Declaration
void MovePreviousAbsolute()

MoveRelative(Int16)

Declaration
void MoveRelative(short NumToMove)
Parameters
Type | Name | Description
System.Int16 | NumToMove |

Query()

Declaration
void Query()

RelateByID(Int32, String)

Declaration
void RelateByID(int objId, string relationName)
Parameters
Type | Name | Description
System.Int32 | objId |
System.String | relationName |

RelateIntFldByID(Int32, String)

Declaration
void RelateIntFldByID(int objId, string the_field)
Parameters
Type | Name | Description
System.Int32 | objId |
System.String | the_field |

RelateIntFldToRecord(IFCGeneric, String)

Declaration
void RelateIntFldToRecord(IFCGeneric o_obj, string the_field)
Parameters
Type | Name | Description
IFCGeneric | o_obj |
System.String | the_field |

RelateRecords(IFCGeneric, String)

Declaration
void RelateRecords(IFCGeneric o_obj, string relationName)
Parameters
Type | Name | Description
IFCGeneric | o_obj |
System.String | relationName |

set_Fields(Object, Object)

Declaration
void set_Fields(object index, object newValue)
Parameters
Type | Name | Description
System.Object | index |
System.Object | newValue |

SimpleQuery(String)

Declaration
void SimpleQuery(string obj_name)
Parameters
Type | Name | Description
System.String | obj_name |

TotalCount()

Declaration
int TotalCount()
Returns
Type | Description
System.Int32 |

TraverseFromParent(IFCGeneric, String)

Declaration
void TraverseFromParent(IFCGeneric the_parent, string trav_rel)
Parameters
Type | Name | Description
IFCGeneric | the_parent |
System.String | trav_rel |

TraverseFromRoot(Int32, String, String)

Declaration
void TraverseFromRoot(int RootObjid, string TblName, string RootRel)
Parameters
Type | Name | Description
System.Int32 | RootObjid |
System.String | TblName |
System.String | RootRel |

UnRelateAll(String)

Declaration
void UnRelateAll(string relationName)
Parameters
Type | Name | Description
System.String | relationName |

UnRelateRecordFromAll(String)

Declaration
void UnRelateRecordFromAll(string relationName)
Parameters
Type | Name | Description
System.String | relationName |

UnRelateRecords(IFCGeneric, String)

Declaration
void UnRelateRecords(IFCGeneric o_obj, string relationName)
Parameters
Type | Name | Description
IFCGeneric | o_obj |
System.String | relationName |

Untraverse()

Declaration
void Untraverse()

Update()

Declaration
void Update()

UpdateAll()

Declaration
void UpdateAll()


Interface IFCList | fcSDK Documentation

Interface IFCList

Namespace: FChoice.Foundation.Clarify.Compatibility
Assembly: FChoice.Foundation.Clarify.Compatibility.dll
Syntax
[Guid("6AFFB191-74AD-4d5f-A2B5-2456A3F5AA9F")]
[ComVisible(true)]
public interface IFCList

Properties

AllowDuplicates

Declaration
bool AllowDuplicates { get; set; }
Property Value
Type | Description
System.Boolean |

Count

Declaration
short Count { get; }
Property Value
Type | Description
System.Int16 |

ItemType

Declaration
string ItemType { get; set; }
Property Value
Type | Description
System.String |

Sorted

Declaration
bool Sorted { get; }
Property Value
Type | Description
System.Boolean |

Methods

AppendItem(Object, Object, Object, Object, Object, Object, Object, Object, Object)

Declaration
void AppendItem(object param1, object param2, object param3, object param4, object param5, object param6, object param7, object param8, object param9)
Parameters
Type | Name | Description
System.Object | param1 |
System.Object | param2 |
System.Object | param3 |
System.Object | param4 |
System.Object | param5 |
System.Object | param6 |
System.Object | param7 |
System.Object | param8 |
System.Object | param9 |

AppendSingleItem(Object)

Declaration
void AppendSingleItem(object param1)
Parameters
Type | Name | Description
System.Object | param1 |

Clear()

Declaration
void Clear()

Contains(Object)

Declaration
bool Contains(object item)
Parameters
Type | Name | Description
System.Object | item |
Returns
Type | Description
System.Boolean |

FindFirstindex(Object)

Declaration
short FindFirstindex(object param1)
Parameters
Type | Name | Description
System.Object | param1 |
Returns
Type | Description
System.Int16 |

GetItemByIndex(Int16, ref Object)

Declaration
void GetItemByIndex(short index, ref object item)
Parameters
Type | Name | Description
System.Int16 | index |
System.Object | item |

ItemByIndex(Int16)

Declaration
object ItemByIndex(short index)
Parameters
Type | Name | Description
System.Int16 | index |
Returns
Type | Description
System.Object |

Sort()

Declaration
void Sort()


Interface IFCSession | fcSDK Documentation

Interface IFCSession

Namespace: FChoice.Foundation.Clarify.Compatibility
Assembly: FChoice.Foundation.Clarify.Compatibility.dll
Syntax
[Guid("772CB7F1-F6D6-4783-9390-979DE87386C9")]
[ComVisible(true)]
public interface IFCSession

Properties

ad_auto

Declaration
bool ad_auto { get; set; }
Property Value
Type | Description
System.Boolean |

ad_list

Declaration
string ad_list { get; set; }
Property Value
Type | Description
System.String |

BulkCollection

Declaration
IMockCollection BulkCollection { get; }
Property Value
Type | Description
IMockCollection |

ConvertTimeZone

Declaration
bool ConvertTimeZone { get; set; }
Property Value
Type | Description
System.Boolean |

cur_res

Declaration
IMockCollection cur_res { get; set; }
Property Value
Type | Description
IMockCollection |

CurrentCulture

Declaration
string CurrentCulture { get; set; }
Property Value
Type | Description
System.String |

Distinct

Declaration
bool Distinct { get; set; }
Property Value
Type | Description
System.Boolean |

ErrorMessage

Declaration
string ErrorMessage { get; set; }
Property Value
Type | Description
System.String |

ErrorNumber

Declaration
short ErrorNumber { get; set; }
Property Value
Type | Description
System.Int16 |

ErrorSource

Declaration
string ErrorSource { get; set; }
Property Value
Type | Description
System.String |

hist_change

Declaration
bool hist_change { get; }
Property Value
Type | Description
System.Boolean |

IncludeRelations

Declaration
bool IncludeRelations { get; set; }
Property Value
Type | Description
System.Boolean |

IsInTransaction

Declaration
bool IsInTransaction { get; }
Property Value
Type | Description
System.Boolean |

IsLoggedIn

Declaration
bool IsLoggedIn { get; }
Property Value
Type | Description
System.Boolean |

Item[String]

Declaration
[ComVisible(false)]
object this[string index] { get; set; }
Parameters
Type | Name | Description
System.String | index |
Property Value
Type | Description
System.Object |

LocalTimeZone

Declaration
string LocalTimeZone { get; set; }
Property Value
Type | Description
System.String |

LocalTimeZoneOffset

Declaration
int LocalTimeZoneOffset { get; }
Property Value
Type | Description
System.Int32 |

LoginTime

Declaration
DateTime LoginTime { get; }
Property Value
Type | Description
System.DateTime |

NoRes

Declaration
bool NoRes { get; set; }
Property Value
Type | Description
System.Boolean |

num_ad

Declaration
short num_ad { get; set; }
Property Value
Type | Description
System.Int16 |

PasswordRequired

Declaration
bool PasswordRequired { get; set; }
Property Value
Type | Description
System.Boolean |

QueryEmptyToNull

Declaration
bool QueryEmptyToNull { get; set; }
Property Value
Type | Description
System.Boolean |

RESEnabled

Declaration
bool RESEnabled { get; set; }
Property Value
Type | Description
System.Boolean |

rowLimit

Declaration
int rowLimit { get; set; }
Property Value
Type | Description
System.Int32 |

SessionID

Declaration
string SessionID { get; }
Property Value
Type | Description
System.String |

SetNullStringsToEmpty

Declaration
bool SetNullStringsToEmpty { get; set; }
Property Value
Type | Description
System.Boolean |

ThrowErrors

Declaration
bool ThrowErrors { get; set; }
Property Value
Type | Description
System.Boolean |

TruncateStringFields

Declaration
bool TruncateStringFields { get; set; }
Property Value
Type | Description
System.Boolean |

UpdateTime

Declaration
DateTime UpdateTime { get; }
Property Value
Type | Description
System.DateTime |

Methods

accept_object(String, ref String, ref String, ref String, Boolean, String)

Declaration
short accept_object(string objId, ref string acceptDate, ref string wipBin, ref string localUserName, bool generateTimebombs, string objectType)
Parameters
Type | Name | Description
System.String | objId |
System.String | acceptDate |
System.String | wipBin |
System.String | localUserName |
System.Boolean | generateTimebombs |
System.String | objectType |
Returns
Type | Description
System.Int16 |

active_connection()

Declaration
Connection active_connection()
Returns
Type | Description
ADODB.Connection |

AddAttachment(String, String, String, String, Object, Object)

Declaration
short AddAttachment(string attachmentName, string filePath, string objectType, string idNumber, object objectObjId, object attachmentType)
Parameters
Type | Name | Description
System.String | attachmentName |
System.String | filePath |
System.String | objectType |
System.String | idNumber |
System.Object | objectObjId |
System.Object | attachmentType |
Returns
Type | Description
System.Int16 |

AppendFilter(Object, String, String, Object, Object)

Declaration
void AppendFilter(object fcGeneric, string fieldName, string filterOperator, object filterValue, object isAndOr)
Parameters
Type | Name | Description
System.Object | fcGeneric |
System.String | fieldName |
System.String | filterOperator |
System.Object | filterValue |
System.Object | isAndOr |

assign_object(String, ref String, String, ref String, ref String, Boolean, String)

Declaration
short assign_object(string objId, ref string newUser, string wipBin, ref string assignDate, ref string localUserName, bool generateTimeBombs, string objectType)
Parameters
Type | Name | Description
System.String | objId |
System.String | newUser |
System.String | wipBin |
System.String | assignDate |
System.String | localUserName |
System.Boolean | generateTimeBombs |
System.String | objectType |
Returns
Type | Description
System.Int16 |

auto_dest(String, String, String)

Declaration
short auto_dest(string objId, string operation, string idNumber)
Parameters
Type | Name | Description
System.String | objId |
System.String | operation |
System.String | idNumber |
Returns
Type | Description
System.Int16 |

AutoDest(String, String, String)

Declaration
short AutoDest(string objId, string operation, string idNumber)
Parameters
Type | Name | Description
System.String | objId |
System.String | operation |
System.String | idNumber |
Returns
Type | Description
System.Int16 |

build_hist(String, String)

Declaration
string build_hist(string objectHistory, string appendHistory)
Parameters
Type | Name | Description
System.String | objectHistory |
System.String | appendHistory |
Returns
Type | Description
System.String |

build_lists(String, Int32, String, Int32, String, String, String, String, String, String, ref IFCList, ref IFCList, ref IFCList, ref Int16)

Declaration
void build_lists(string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1, ref IFCList fld_list, ref IFCList type_list, ref IFCList val_list, ref short list_used)
Parameters
Type | Name | Description
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
System.Int16 | list_used |

BuildUserVersionProc()

Declaration
string BuildUserVersionProc()
Returns
Type | Description
System.String |

change_obj_status(String, ref String, ref String, String, ref String, Boolean, String)

Declaration
short change_obj_status(string objId, ref string newStatus, ref string changeDate, string notes, ref string localUserName, bool generateTimeBombs, string objectType)
Parameters
Type | Name | Description
System.String | objId |
System.String | newStatus |
System.String | changeDate |
System.String | notes |
System.String | localUserName |
System.Boolean | generateTimeBombs |
System.String | objectType |
Returns
Type | Description
System.Int16 |

ChangePassword(String)

Declaration
void ChangePassword(string password)
Parameters
Type | Name | Description
System.String | password |

ChangeResGroup(String, Object)

Declaration
void ChangeResGroup(string newGroup, object saveToDB)
Parameters
Type | Name | Description
System.String | newGroup |
System.Object | saveToDB |

check_cl_trans(String, String, String, String)

Declaration
short check_cl_trans(string oldCondition, string newCondition, string reqType, string userName)
Parameters
Type | Name | Description
System.String | oldCondition |
System.String | newCondition |
System.String | reqType |
System.String | userName |
Returns
Type | Description
System.Int16 |

CloseAllGenerics()

Declaration
void CloseAllGenerics()

CloseGenerics(Int16, Object, Object, Object, Object, Object, Object, Object, Object, Object, Object)

Declaration
void CloseGenerics(short NumGenerics, object Generic1, object Generic2, object Generic3, object Generic4, object Generic5, object Generic6, object Generic7, object Generic8, object Generic9, object Generic10)
Parameters
Type | Name | Description
System.Int16 | NumGenerics |
System.Object | Generic1 |
System.Object | Generic2 |
System.Object | Generic3 |
System.Object | Generic4 |
System.Object | Generic5 |
System.Object | Generic6 |
System.Object | Generic7 |
System.Object | Generic8 |
System.Object | Generic9 |
System.Object | Generic10 |

CloseSession()

Declaration
void CloseSession()

CommitTransaction()

Declaration
void CommitTransaction()

ConvertDate(DateTime, String, String)

Declaration
DateTime ConvertDate(DateTime convertDate, string fromTimeZone, string toTimeZone)
Parameters
Type | Name | Description
System.DateTime | convertDate |
System.String | fromTimeZone |
System.String | toTimeZone |
Returns
Type | Description
System.DateTime |

ConvertFromLocalToServerTZ(DateTime)

Declaration
DateTime ConvertFromLocalToServerTZ(DateTime convertDate)
Parameters
Type | Name | Description
System.DateTime | convertDate |
Returns
Type | Description
System.DateTime |

ConvertFromServerToLocalTZ(DateTime)

Declaration
DateTime ConvertFromServerToLocalTZ(DateTime convertDate)
Parameters
Type | Name | Description
System.DateTime | convertDate |
Returns
Type | Description
System.DateTime |

create_act_entry(IFCGeneric, String, Int32, Int32, String, IFCGeneric, String, String, Object)

Declaration
void create_act_entry(IFCGeneric mainRecord, string actName, int userId, int actCode, string currentDateTime, IFCGeneric activityRecord, string additionalInfo, string objectType, object linkRecord)
Parameters
Type | Name | Description
IFCGeneric | mainRecord |
System.String | actName |
System.Int32 | userId |
System.Int32 | actCode |
System.String | currentDateTime |
IFCGeneric | activityRecord |
System.String | additionalInfo |
System.String | objectType |
System.Object | linkRecord |

create_act_entry(IFCGeneric, String, Int32, Int32, String, IFCGeneric, String, String, String, Object)

Declaration
[ComVisible(false)]
void create_act_entry(IFCGeneric mainRecord, string actName, int userId, int actCode, string currentDateTime, IFCGeneric activityRecord, string additionalInfo, string objectType, string impersonatorUserName, object linkRecord)
Parameters
Type | Name | Description
IFCGeneric | mainRecord |
System.String | actName |
System.Int32 | userId |
System.Int32 | actCode |
System.String | currentDateTime |
IFCGeneric | activityRecord |
System.String | additionalInfo |
System.String | objectType |
System.String | impersonatorUserName |
System.Object | linkRecord |

create_time_bomb(ref IFCGeneric, IFCGeneric, String, IFCGeneric, String, Int32, String, String, Object)

Declaration
void create_time_bomb(ref IFCGeneric timeBombRecord, IFCGeneric mainRecord, string t_save, IFCGeneric activityRecord, string the_type, int emp_rec, string t_date, string focus_obj, object new_generic)
Parameters
Type | Name | Description
IFCGeneric | timeBombRecord |
IFCGeneric | mainRecord |
System.String | t_save |
IFCGeneric | activityRecord |
System.String | the_type |
System.Int32 | emp_rec |
System.String | t_date |
System.String | focus_obj |
System.Object | new_generic |

create_time_bomb(Int32, ref IFCGeneric, IFCGeneric, String, IFCGeneric, Int32, String, String, Object)

Declaration
[ComVisible(false)]
void create_time_bomb(int timeBombFlag, ref IFCGeneric timeBombRecord, IFCGeneric mainRecord, string t_save, IFCGeneric activityRecord, int emp_rec, string t_date, string focus_obj, object new_generic)
Parameters
Type | Name | Description
System.Int32 | timeBombFlag |
IFCGeneric | timeBombRecord |
IFCGeneric | mainRecord |
System.String | t_save |
IFCGeneric | activityRecord |
System.Int32 | emp_rec |
System.String | t_date |
System.String | focus_obj |
System.Object | new_generic |

create_time_bomb(Int32, ref IFCGeneric, IFCGeneric, String, IFCGeneric, Int32, String, String, String, Object)

Declaration
[ComVisible(false)]
void create_time_bomb(int timeBombFlag, ref IFCGeneric timeBombRecord, IFCGeneric mainRecord, string t_save, IFCGeneric activityRecord, int emp_rec, string t_date, string focus_obj, string escalate_time, object new_generic)
Parameters
Type | Name | Description
System.Int32 | timeBombFlag |
IFCGeneric | timeBombRecord |
IFCGeneric | mainRecord |
System.String | t_save |
IFCGeneric | activityRecord |
System.Int32 | emp_rec |
System.String | t_date |
System.String | focus_obj |
System.String | escalate_time |
System.Object | new_generic |

createBulk(String)

Declaration
IFCBulk createBulk(string bulkName)
Parameters
Type | Name | Description
System.String | bulkName |
Returns
Type | Description
IFCBulk |

CreateGeneric(Object)

Declaration
IFCGeneric CreateGeneric(object dbObjectName)
Parameters
Type | Name | Description
System.Object | dbObjectName |
Returns
Type | Description
IFCGeneric |

CreateSqlExec()

Declaration
IFCSqlExec CreateSqlExec()
Returns
Type | Description
IFCSqlExec |

dispatch_object(String, String, ref String, ref String, Boolean, String)

Declaration
short dispatch_object(string objId, string queueName, ref string dispatchDate, ref string localUserName, bool generateTimeBombs, string objectType)
Parameters
Type | Name | Description
System.String | objId |
System.String | queueName |
System.String | dispatchDate |
System.String | localUserName |
System.Boolean | generateTimeBombs |
System.String | objectType |
Returns
Type | Description
System.Int16 |

error_handler(Int16, String, String, String)

Declaration
short error_handler(short errorNum, string objId, string source, string message)
Parameters
Type | Name | Description
System.Int16 | errorNum |
System.String | objId |
System.String | source |
System.String | message |
Returns
Type | Description
System.Int16 |

error_handler(Int32, String, String, String, Exception)

Declaration
[ComVisible(false)]
short error_handler(int errorNum, string objId, string source, string message, Exception ex)
Parameters
Type | Name | Description
System.Int32 | errorNum |
System.String | objId |
System.String | source |
System.String | message |
System.Exception | ex |
Returns
Type | Description
System.Int16 |

ExecuteSQL(String, ref Recordset)

Declaration
void ExecuteSQL(string sql, ref Recordset records)
Parameters
Type | Name | Description
System.String | sql |
ADODB.Recordset | records |

ExecuteSQLNoReturn(String)

Declaration
void ExecuteSQLNoReturn(string sql)
Parameters
Type | Name | Description
System.String | sql |

format_time(Int32)

Declaration
string format_time(int totalTime)
Parameters
Type | Name | Description
System.Int32 | totalTime |
Returns
Type | Description
System.String |

forward_object(String, String, ref String, String, ref String, Boolean, String)

Declaration
short forward_object(string objId, string newQueue, ref string forwardDate, string notes, ref string localuserName, bool genearateTimeBombs, string objectType)
Parameters
Type | Name | Description
System.String | objId |
System.String | newQueue |
System.String | forwardDate |
System.String | notes |
System.String | localuserName |
System.Boolean | genearateTimeBombs |
System.String | objectType |
Returns
Type | Description
System.Int16 |

FreeConnection()

Declaration
void FreeConnection()

get_item(String)

Declaration
object get_item(string key)
Parameters
Type | Name | Description
System.String | key |
Returns
Type | Description
System.Object |

get_next_sn(Int16)

Declaration
object get_next_sn(short the_ind)
Parameters
Type | Name | Description
System.Int16 | the_ind |
Returns
Type | Description
System.Object |

GetColor(String)

Declaration
string GetColor(string purpose)
Parameters
Type | Name | Description
System.String | purpose |
Returns
Type | Description
System.String |

GetConfigItem(String, String, Object)

Declaration
object GetConfigItem(string configItem, string fieldName, object loginName)
Parameters
Type | Name | Description
System.String | configItem |
System.String | fieldName |
System.Object | loginName |
Returns
Type | Description
System.Object |

GetCurrentDate()

Declaration
DateTime GetCurrentDate()
Returns
Type | Description
System.DateTime |

GetCurrentServerDate()

Declaration
DateTime GetCurrentServerDate()
Returns
Type | Description
System.DateTime |

GetItem(String, Int16, Int16, String)

Declaration
string GetItem(string path, short startItem, short stopItem, string separator)
Parameters
Type | Name | Description
System.String | path |
System.Int16 | startItem |
System.Int16 | stopItem |
System.String | separator |
Returns
Type | Description
System.String |

GetNextNumScheme(String)

Declaration
string GetNextNumScheme(string numSchemaName)
Parameters
Type | Name | Description
System.String | numSchemaName |
Returns
Type | Description
System.String |

GetNextSubcaseID(String, Int32)

Declaration
string GetNextSubcaseID(string caseId, int caseConditionId)
Parameters
Type | Name | Description
System.String | caseId |
System.Int32 | caseConditionId |
Returns
Type | Description
System.String |

GetNumGenerics()

Declaration
int GetNumGenerics()
Returns
Type | Description
System.Int32 |

GetObjid(String)

Declaration
int GetObjid(string tableName)
Parameters
Type | Name | Description
System.String | tableName |
Returns
Type | Description
System.Int32 |

GetUserVersion(String)

Declaration
string GetUserVersion(string formName)
Parameters
Type | Name | Description
System.String | formName |
Returns
Type | Description
System.String |

Init_Object(ref IFCGeneric, String, String, String)

Declaration
IFCGeneric Init_Object(ref IFCGeneric generic, string objectType, string dataFields, string bulkName)
Parameters
Type | Name | Description
IFCGeneric | generic |
System.String | objectType |
System.String | dataFields |
System.String | bulkName |
Returns
Type | Description
IFCGeneric |

IsUnicode(String)

Declaration
object IsUnicode(string inputString)
Parameters
Type | Name | Description
System.String | inputString |
Returns
Type | Description
System.Object |

ItemCount(String, String)

Declaration
short ItemCount(string path, string separator)
Parameters
Type | Name | Description
System.String | path |
System.String | separator |
Returns
Type | Description
System.Int16 |

LoadColors(String)

Declaration
void LoadColors(string userName)
Parameters
Type | Name | Description
System.String | userName |

LoadUserVersions(Object)

Declaration
void LoadUserVersions(object userName)
Parameters
Type | Name | Description
System.Object | userName |

Log(String, String)

Declaration
void Log(string messageType, string message)
Parameters
Type | Name | Description
System.String | messageType |
System.String | message |

LogEx(String, String)

Declaration
void LogEx(string logLevel, string logMessage)
Parameters
Type | Name | Description
System.String | logLevel |
System.String | logMessage |

Login(String, String, String)

Declaration
void Login(string username, string password, string loginType)
Parameters
Type | Name | Description
System.String | username |
System.String | password |
System.String | loginType |

LoginFromFCApp()

Declaration
void LoginFromFCApp()

Logout()

Declaration
void Logout()

move_object(String, String, String)

Declaration
short move_object(string objId, string newWipBin, string objectType)
Parameters
Type | Name | Description
System.String | objId |
System.String | newWipBin |
System.String | objectType |
Returns
Type | Description
System.Int16 |

NewEnum()

Declaration
IEnumerator NewEnum()
Returns
Type | Description
System.Collections.IEnumerator |

RefreshContext()

Declaration
void RefreshContext()

reject_object(String, ref String, String, String, ref String, Boolean, String)

Declaration
short reject_object(string objId, ref string rejectDate, string wipBin, string notes, ref string localuserName, bool genearateTimeBombs, string objectType)
Parameters
Type | Name | Description
System.String | objId |
System.String | rejectDate |
System.String | wipBin |
System.String | notes |
System.String | localuserName |
System.Boolean | genearateTimeBombs |
System.String | objectType |
Returns
Type | Description
System.Int16 |

RemoveAllGenericsInABulk(String)

Declaration
void RemoveAllGenericsInABulk(string bulkName)
Parameters
Type | Name | Description
System.String | bulkName |

RollbackTransaction()

Declaration
void RollbackTransaction()

SaveSession()

Declaration
void SaveSession()

set_item(String, Object)

Declaration
void set_item(string key, object newValue)
Parameters
Type | Name | Description
System.String | key |
System.Object | newValue |

SetNullStringToEmpty(Object)

Declaration
object SetNullStringToEmpty(object inputString)
Parameters
Type | Name | Description
System.Object | inputString |
Returns
Type | Description
System.Object |

SetPassword(String, String, String)

Declaration
void SetPassword(string loginName, string password, string loginType)
Parameters
Type | Name | Description
System.String | loginName |
System.String | password |
System.String | loginType |

SimpleQuery(ref IFCGeneric, String, String, String)

Declaration
void SimpleQuery(ref IFCGeneric generic, string objectType, string dataFields, string bulkName)
Parameters
Type | Name | Description
IFCGeneric | generic |
System.String | objectType |
System.String | dataFields |
System.String | bulkName |

single_quotify(String)

Declaration
string single_quotify(string inputString)
Parameters
Type | Name | Description
System.String | inputString |
Returns
Type | Description
System.String |

sprintf(String, Object, Object, Object, Object, Object, Object)

Declaration
string sprintf(string inputString, object arg1, object arg2, object arg3, object arg4, object arg5, object arg6)
Parameters
Type | Name | Description
System.String | inputString |
System.Object | arg1 |
System.Object | arg2 |
System.Object | arg3 |
System.Object | arg4 |
System.Object | arg5 |
System.Object | arg6 |
Returns
Type | Description
System.String |

StartTransaction(Object)

Declaration
void StartTransaction(object isolationLevel)
Parameters
Type | Name | Description
System.Object | isolationLevel |

TraverseFromParent(ref IFCGeneric, String, String, String, IFCGeneric, String)

Declaration
IFCGeneric TraverseFromParent(ref IFCGeneric generic, string objectType, string dataFields, string bulkName, IFCGeneric the_parent, string relation)
Parameters
Type | Name | Description
IFCGeneric | generic |
System.String | objectType |
System.String | dataFields |
System.String | bulkName |
IFCGeneric | the_parent |
System.String | relation |
Returns
Type | Description
IFCGeneric |

turn_off(Int32, Int32)

Declaration
int turn_off(int bigNum, int smallNum)
Parameters
Type | Name | Description
System.Int32 | bigNum |
System.Int32 | smallNum |
Returns
Type | Description
System.Int32 |

use_list(IFCGeneric, Object, Object, Object)

Declaration
void use_list(IFCGeneric tempRecord, object fieldList, object typeList, object valueList)
Parameters
Type | Name | Description
IFCGeneric | tempRecord |
System.Object | fieldList |
System.Object | typeList |
System.Object | valueList |

yank_object(String, String, ref String, ref String, Boolean, String)

Declaration
short yank_object(string objId, string wipBin, ref string yankDate, ref string localuserName, bool genearateTimeBombs, string objectType)
Parameters
Type | Name | Description
System.String | objId |
System.String | wipBin |
System.String | yankDate |
System.String | localuserName |
System.Boolean | genearateTimeBombs |
System.String | objectType |
Returns
Type | Description
System.Int16 |


Interface IFCSqlExec | fcSDK Documentation

Interface IFCSqlExec

Namespace: FChoice.Foundation.Clarify.Compatibility
Assembly: FChoice.Foundation.Clarify.Compatibility.dll
Syntax
[Guid("F2455264-5491-4c13-89E9-15CF44F2C75A")]
[ComVisible(true)]
public interface IFCSqlExec

Properties

Records

Declaration
Recordset Records { get; }
Property Value
Type | Description
ADODB.Recordset |

StayConnected

Declaration
bool StayConnected { get; set; }
Property Value
Type | Description
System.Boolean |

Methods

AddSqlParameter(Object)

Declaration
void AddSqlParameter(object value)
Parameters
Type | Name | Description
System.Object | value |

CloseConnection()

Declaration
void CloseConnection()

Execute(String)

Declaration
void Execute(string SqlStr)
Parameters
Type | Name | Description
System.String | SqlStr |

ExecuteReturnRows(String)

Declaration
void ExecuteReturnRows(string sqlStatement)
Parameters
Type | Name | Description
System.String | sqlStatement |

FreeConnection()

Declaration
void FreeConnection()

OpenConnection(String, String, String, String, String)

Declaration
void OpenConnection(string TheDB, string UserName, string password, string DBServer, string DBName)
Parameters
Type | Name | Description
System.String | TheDB |
System.String | UserName |
System.String | password |
System.String | DBServer |
System.String | DBName |


Interface IMockAdoField | fcSDK Documentation

Interface IMockAdoField

Namespace: FChoice.Foundation.Clarify.Compatibility
Assembly: FChoice.Foundation.Clarify.Compatibility.dll
Syntax
[Guid("F7AED485-957A-4ad6-90C8-7D475C87F9C7")]
[ComVisible(true)]
public interface IMockAdoField

Properties

DefinedSize

Declaration
int DefinedSize { get; }
Property Value
Type | Description
System.Int32 |

Name

Declaration
string Name { get; }
Property Value
Type | Description
System.String |

NetValue

Declaration
[ComVisible(false)]
object NetValue { get; set; }
Property Value
Type | Description
System.Object |

Type

Declaration
int Type { get; }
Property Value
Type | Description
System.Int32 |

Methods

get_Value()

Declaration
object get_Value()
Returns
Type | Description
System.Object |

set_Value(Object)

Declaration
void set_Value(object newValue)
Parameters
Type | Name | Description
System.Object | newValue |


Interface IMockCollection | fcSDK Documentation

Interface IMockCollection

Namespace: FChoice.Foundation.Clarify.Compatibility
Assembly: FChoice.Foundation.Clarify.Compatibility.dll
Syntax
[Guid("E56DD62E-5282-4ca0-8AE5-9B40D173B39E")]
[ComVisible(true)]
public interface IMockCollection

Methods

_NewEnum()

Declaration
IEnumerator _NewEnum()
Returns
Type | Description
System.Collections.IEnumerator |

Add(ref Object, ref Object, ref Object, ref Object)

Declaration
void Add(ref object Item, ref object Key, ref object Before, ref object After)
Parameters
Type | Name | Description
System.Object | Item |
System.Object | Key |
System.Object | Before |
System.Object | After |

Count()

Declaration
int Count()
Returns
Type | Description
System.Int32 |

Item(ref Object)

Declaration
object Item(ref object Index)
Parameters
Type | Name | Description
System.Object | Index |
Returns
Type | Description
System.Object |

Remove(ref Object)

Declaration
void Remove(ref object Index)
Parameters
Type | Name | Description
System.Object | Index |


Class MockAdoField | fcSDK Documentation

Class MockAdoField

Inheritance
System.Object
MockAdoField
Implements
IMockAdoField
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Compatibility
Assembly: FChoice.Foundation.Clarify.Compatibility.dll
Syntax
[ComVisible(true)]
[Guid("78A3320B-100C-4225-A3C1-58C2A3E73A86")]
[ClassInterface(ClassInterfaceType.None)]
public class MockAdoField : IMockAdoField

Properties

DefinedSize

Declaration
public int DefinedSize { get; }
Property Value
Type | Description
System.Int32 |

Name

Declaration
public string Name { get; }
Property Value
Type | Description
System.String |

NetValue

Declaration
[ComVisible(false)]
public object NetValue { get; set; }
Property Value
Type | Description
System.Object |

Type

Declaration
public int Type { get; }
Property Value
Type | Description
System.Int32 |

Methods

get_Value()

Declaration
public object get_Value()
Returns
Type | Description
System.Object |

set_Value(Object)

Declaration
public void set_Value(object newValue)
Parameters
Type | Name | Description
System.Object | newValue |

Implements

IMockAdoField


Class MockCollection | fcSDK Documentation

Class MockCollection

Inheritance
System.Object
MockCollection
Implements
IMockCollection
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Compatibility
Assembly: FChoice.Foundation.Clarify.Compatibility.dll
Syntax
[ComVisible(true)]
[Guid("9D9620BB-8673-4265-B6BC-A6EF0A536F60")]
[ClassInterface(ClassInterfaceType.None)]
public class MockCollection : IMockCollection

Methods

_NewEnum()

Declaration
public IEnumerator _NewEnum()
Returns
Type | Description
System.Collections.IEnumerator |

Add(ref Object, ref Object, ref Object, ref Object)

Declaration
public void Add(ref object Item, ref object Key, ref object Before, ref object After)
Parameters
Type | Name | Description
System.Object | Item |
System.Object | Key |
System.Object | Before |
System.Object | After |

Count()

Declaration
public int Count()
Returns
Type | Description
System.Int32 |

Item(ref Object)

Declaration
public object Item(ref object Index)
Parameters
Type | Name | Description
System.Object | Index |
Returns
Type | Description
System.Object |

Remove(ref Object)

Declaration
public void Remove(ref object Index)
Parameters
Type | Name | Description
System.Object | Index |

Implements

IMockCollection


Namespace FChoice.Foundation.Clarify.Compatibility.Toolkits | fcSDK Documentation

Namespace FChoice.Foundation.Clarify.Compatibility.Toolkits

Classes

CompatibilityToolkitException

FCCC

FCCCBase

FCCL

FCCLBase

FCCQ

FCCQBase

FCCS

FCCSBase

FCDR

FCDRBase

FCFO

FCFOBase

FCINTER

FCINTERBase

FCSFA

FCSFABase

SitePartDataAccess

Interfaces

IFCCC

IFCCL

IFCCQ

IFCCS

IFCDR

IFCFO

IFCINTER

IFCSFA

IToolkit

Back to top © 2022 Dovetail Software, Inc. - All rights reserved.
Clarify, Amdocs, and related products and names are copyright and trademark of Amdocs, Inc.
.NET, Visual Studio.NET, C#, Visual Basic and related products are trademark of Microsoft corporation.


Class CompatibilityToolkitException | fcSDK Documentation

Class CompatibilityToolkitException

Inheritance
System.Object
System.Exception
System.ApplicationException
FCExceptionBase
CompatibilityToolkitException
Implements
System.Runtime.InteropServices._Exception
System.Runtime.Serialization.ISerializable
Inherited Members
FCExceptionBase.SetMessageProvider(IErrorMessageProvider)
FCExceptionBase.GetResourceData()
FCExceptionBase.GetErrorMessageFormat(Object, String)
FCExceptionBase.FormatMessage(String, String, Object[])
FCExceptionBase.LoadErrorResourceSet(String)
FCExceptionBase.GetObjectData(SerializationInfo, StreamingContext)
FCExceptionBase.MessageProvider
FCExceptionBase.ErrorCode
FCExceptionBase.ErrorMessageID
FCExceptionBase.Message
System.Exception.GetBaseException()
System.Exception.ToString()
System.Exception.GetType()
System.Exception.Data
System.Exception.InnerException
System.Exception.TargetSite
System.Exception.StackTrace
System.Exception.HelpLink
System.Exception.Source
System.Exception.HResult
System.Exception.SerializeObjectState
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Compatibility.Toolkits
Assembly: FChoice.Foundation.Clarify.Compatibility.Toolkits.dll
Syntax
[ComVisible(false)]
[Guid("147BEBDF-CEF8-4517-A28A-9CEC8D7D1D7B")]
public class CompatibilityToolkitException : FCExceptionBase, _Exception, ISerializable

Constructors

CompatibilityToolkitException(Exception, Int32, String, Object[])

Declaration
protected CompatibilityToolkitException(Exception innerEx, int errorId, string messageId, params object[] args)
Parameters
Type | Name | Description
System.Exception | innerEx |
System.Int32 | errorId |
System.String | messageId |
System.Object[] | args |

CompatibilityToolkitException(Int32, String, Object[])

Declaration
protected CompatibilityToolkitException(int errorId, string messageId, params object[] args)
Parameters
Type | Name | Description
System.Int32 | errorId |
System.String | messageId |
System.Object[] | args |

CompatibilityToolkitException(SerializationInfo, StreamingContext)

Declaration
protected CompatibilityToolkitException(SerializationInfo info, StreamingContext context)
Parameters
Type | Name | Description
System.Runtime.Serialization.SerializationInfo | info |
System.Runtime.Serialization.StreamingContext | context |

Implements

System.Runtime.InteropServices._Exception
System.Runtime.Serialization.ISerializable


Class FCCC | fcSDK Documentation

Class FCCC

Inheritance
System.Object
FCCCBase
FCCC
Implements
IFCCC
IToolkit
Inherited Members
FCCCBase._Initialize(IFCApplication, IFCSession)
FCCCBase._CreateContractList(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, Boolean, Int32, Boolean, IFCList, IFCList, IFCList)
FCCCBase._create_contract_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, Boolean, Int32, Boolean, IFCList, IFCList, IFCList)
FCCCBase._CreateContract(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, Boolean, Int32, Boolean, String, Int32, String, String, String, String)
FCCCBase._create_contract(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, Boolean, Int32, Boolean, String, Int32, String, String, String, String)
FCCCBase._accept_quote(String, String, String, String, Boolean)
FCCCBase._assign_quote(String, String, String, String, String, Boolean)
FCCCBase._change_quote_status(String, String, String, String, String, Boolean)
FCCCBase._dispatch_quote(String, String, String, String, Boolean)
FCCCBase._forward_quote(String, String, String, String, String, Boolean)
FCCCBase._move_quote(String, String)
FCCCBase._reject_quote(String, String, String, String, String, Boolean)
FCCCBase._yank_quote(String, String, String, String, Boolean)
FCCCBase._create_update_schedule_list(String, Boolean, String, String, String, String, String, String, String, String, String, String, String, IFCList, IFCList, IFCList)
FCCCBase._create_update_schedule(String, Boolean, String, String, String, String, String, String, String, String, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)
FCCCBase._reject_contract(String, String, String, String, String, Boolean)
FCCCBase._log_contract_note(String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)
FCCCBase._log_contract_note_list(String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)
FCCCBase._delete_sp(Int32)
FCCCBase._reopen_contract(String, String, String, String, String, Boolean)
FCCCBase._cr_contr_itm_list(String, String, String, String, String, String, String, String, Int32, String, String, Double, String, Boolean, Boolean, String, String, String, Int32, String, IFCList, IFCList, IFCList)
FCCCBase._cr_contr_itm(String, String, String, String, String, String, String, String, Int32, String, String, Double, String, Boolean, Boolean, String, String, String, Int32, String, String, Int32, String, Int32, String, String, String, String, String, String)
FCCCBase._add_po_to_sched(String, String, String, String, String, String, String, String, String)
FCCCBase._CreatePriceInstList(String, String, String, String, String, Int32, Int32, Double, String, String, IFCList, IFCList, IFCList)
FCCCBase._create_price_inst_list(String, String, String, String, String, Int32, Int32, Double, String, String, IFCList, IFCList, IFCList)
FCCCBase._CreatePriceInst(String, String, String, String, String, Int32, Int32, Double, String, String, String, Int32, String, Int32, String, String, String, String, String, String)
FCCCBase._create_price_inst(String, String, String, String, String, Int32, Int32, Double, String, String, String, Int32, String, Int32, String, String, String, String, String, String)
FCCCBase._relate_contr_itm_to_sp(Int32, String, String, String, String)
FCCCBase._CreateLineItem(String, String, String, String, String, Boolean, Int32, String, String, String, Int32, String, Int32, String, String, String, String, String, String)
FCCCBase._CreateLineItemList(String, String, String, String, String, Boolean, Int32, String, String, IFCList, IFCList, IFCList)
FCCCBase._ret_objid
FCCCBase._ret_num
FCCCBase._ret_id_num
FCCCBase._ret_string
FCCCBase._impersonatorUserName
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Compatibility.Toolkits
Assembly: FChoice.Foundation.Clarify.Compatibility.Toolkits.dll
Syntax
[Guid("7345AC26-5DA2-4127-9464-2E3A942C14EB")]
[ComVisible(true)]
[AltName("Contracts")]
[ClassInterface(ClassInterfaceType.None)]
public sealed class FCCC : FCCCBase, IFCCC, IToolkit

Constructors

FCCC()

Declaration
public FCCC()

FCCC(IFCApplication, IFCSession)

Declaration
public FCCC(IFCApplication FCApp, IFCSession FCSess)
Parameters
Type | Name | Description
IFCApplication | FCApp |
IFCSession | FCSess |

Methods

GetProductID()

Declaration
protected override int GetProductID()
Returns
Type | Description
System.Int32 |
Overrides
FCCCBase.GetProductID()

Explicit Interface Implementations

IFCCC.accept_quote(String, String, String, String, Boolean)

Declaration
public short IFCCC.accept_quote([ParameterRequired, AltName("Quote_IDNum")] string quote_id, string accept_date, [AltName("WipBin")] string wipbin_name, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | quote_id |
System.String | accept_date |
System.String | wipbin_name |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCC.add_po_to_sched(String, String, String, String, String, String, String, String, String)

Declaration
[AltName("Add_PO_To_Schedule")]
[OutputProperty("ret_objid", "PO")]
[OutputProperty("ret_id_num", "PO")]
public short IFCCC.add_po_to_sched([ParameterRequired, AltName("Contract_ID_Num")] string contract_id, [ParameterRequired, AltName("Schedule_ID_Num")] string sched_id, [ParameterRequired, AltName("PO_IDNum")] string po_num, [AltName("Payment_Option")] string pay_option, [AltName("Payment_Terms")] string pay_terms, [ParameterRequired, AltType("System.Decimal", "{0}.ToString()"), AltName("PO_Amount")] string po_amt, [AltName("PO_Date")] string po_date, string expire_date, [AltName("PO_Status")] string po_status)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | sched_id |
System.String | po_num |
System.String | pay_option |
System.String | pay_terms |
System.String | po_amt |
System.String | po_date |
System.String | expire_date |
System.String | po_status |
Returns
Type | Description
System.Int16 |

IFCCC.assign_quote(String, String, String, String, String, Boolean)

Declaration
public short IFCCC.assign_quote([ParameterRequired, AltName("Quote_IDNum")] string quote_id, string new_user, [AltName("WipBin")] string wipbin_name, string assign_date, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | quote_id |
System.String | new_user |
System.String | wipbin_name |
System.String | assign_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCC.change_quote_status(String, String, String, String, String, Boolean)

Declaration
public short IFCCC.change_quote_status([ParameterRequired, AltName("Quote_IDNum")] string quote_id, string new_status, string change_date, [AltName("notes")] string note_str, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | quote_id |
System.String | new_status |
System.String | change_date |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCC.cr_contr_itm(String, String, String, String, String, String, String, String, Int32, String, String, Double, String, Boolean, Boolean, String, String, String, Int32, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[SplitMethod("Create_Contract_Line_Item", 2)]
[OutputProperty("ret_objid", "ContractLineItem")]
public short IFCCC.cr_contr_itm([ParameterRequired, AltName("Contract_ID_Num")] string contract_id, string user_name, string create_date, string start_date, string end_date, [ParameterRequired, AltName("Part_Number")] string part_num, [ParameterRequired, AltName("Part_Domain")] string domain, [ParameterRequired, AltName("Part_Revision")] string rev, [ParameterRequired(null, 0), ParameterDefaultValue("1")] int quantity, [ParameterRequired] string price_schedule, [AltType("System.Double", "{1} ? {0}.ToString() : string.Empty"), AltName("Override_Price")] string oride_price, double units_used, [ParameterRequired(null, 0), AltName("Serial_Number")] string serial_num, bool is_taxable, [AltName("auto_install")] bool install_it, string comments, [AltName("quoted_site_IDNum")] string quoted_site, [AltName("serviced_at_site_IDNum")] string serviced_at_site, [ParameterRequired, AltName("Parent_Line_Item_Objid")] int parent_objid, [AltName("PO_IDNum")] string po_num, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | user_name |
System.String | create_date |
System.String | start_date |
System.String | end_date |
System.String | part_num |
System.String | domain |
System.String | rev |
System.Int32 | quantity |
System.String | price_schedule |
System.String | oride_price |
System.Double | units_used |
System.String | serial_num |
System.Boolean | is_taxable |
System.Boolean | install_it |
System.String | comments |
System.String | quoted_site |
System.String | serviced_at_site |
System.Int32 | parent_objid |
System.String | po_num |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCC.cr_contr_itm_list(String, String, String, String, String, String, String, String, Int32, String, String, Double, String, Boolean, Boolean, String, String, String, Int32, String, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[SplitMethod("Create_Contract_Line_Item", 2)]
[OutputProperty("ret_objid", "ContractLineItem")]
public short IFCCC.cr_contr_itm_list([ParameterRequired, AltName("Contract_ID_Num")] string contract_id, string user_name, string create_date, string start_date, string end_date, [ParameterRequired, AltName("Part_Number")] string part_num, [ParameterRequired, AltName("Part_Domain")] string domain, [ParameterRequired, AltName("Part_Revision")] string rev, [ParameterRequired(null, 0), ParameterDefaultValue("1")] int quantity, [ParameterRequired] string price_schedule, [AltType("System.Double", "{1} ? {0}.ToString() : string.Empty"), AltName("Override_Price")] string oride_price, double units_used, [ParameterRequired(null, 1), AltName("Serial_Number")] string serial_num, bool is_taxable, [AltName("auto_install")] bool install_it, string comments, [AltName("quoted_site_IDNum")] string quoted_site, [AltName("serviced_at_site_IDNum")] string serviced_at_site, [ParameterRequired, AltName("Parent_Line_Item_Objid")] int parent_objid, [AltName("PO_IDNum")] string po_num, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | user_name |
System.String | create_date |
System.String | start_date |
System.String | end_date |
System.String | part_num |
System.String | domain |
System.String | rev |
System.Int32 | quantity |
System.String | price_schedule |
System.String | oride_price |
System.Double | units_used |
System.String | serial_num |
System.Boolean | is_taxable |
System.Boolean | install_it |
System.String | comments |
System.String | quoted_site |
System.String | serviced_at_site |
System.Int32 | parent_objid |
System.String | po_num |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCCC.create_contract(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, Boolean, Int32, Boolean, String, Int32, String, String, String, String)

Declaration
[OutputProperty("ret_objid", "Contract")]
[OutputProperty("ret_id_num", "Contract")]
public short IFCCC.create_contract([AltName("Contract_Objid")] string strContractID, [ParameterRequired, AltName("Title")] string str_r_Title, [AltName("Create_Date")] string strCreateDate, [AltName("Account_IDNum")] string strAccountID, [AltName("Account_Name")] string strAccountName, [AltName("Contact_First_Name")] string strContactFirst, [AltName("Contact_Last_Name")] string strContactLast, [AltName("Contact_Phone")] string strContactPhone, [AltName("contract_type")] string strType, [AltName("Terms")] string strTerms, [AltName("Price_Program")] string strPriceProg, [AltName("Status")] string strStatus, [AltName("Administrator_Objid")] string strAdmin, [AltName("Bill_To_Site_IDNum")] string strBillToSite, [AltName("Ship_To_Site_IDNum")] string strShipToSite, [AltName("Start_Date")] string strEffDate, [AltName("Expire_Date")] string strExpiryDate, [AltName("Default_Start_Date")] string strServStartDate, [AltName("Default_Expiration_Date")] string strServEndDate, [AltName("User_Name")] string strUser, [AltName("queue")] string strQueue, [AltName("Is_Warranty")] bool bWarranty, [AltName("Is_Evergreen")] bool bEvergreen, [AltName("Renew_Prior")] int lRenewPrior, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool bGenTimeBombs, string int_fld1, int int_val1, string str_fld1, string str_val1, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | strContractID |
System.String | str_r_Title |
System.String | strCreateDate |
System.String | strAccountID |
System.String | strAccountName |
System.String | strContactFirst |
System.String | strContactLast |
System.String | strContactPhone |
System.String | strType |
System.String | strTerms |
System.String | strPriceProg |
System.String | strStatus |
System.String | strAdmin |
System.String | strBillToSite |
System.String | strShipToSite |
System.String | strEffDate |
System.String | strExpiryDate |
System.String | strServStartDate |
System.String | strServEndDate |
System.String | strUser |
System.String | strQueue |
System.Boolean | bWarranty |
System.Boolean | bEvergreen |
System.Int32 | lRenewPrior |
System.Boolean | bGenTimeBombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCC.create_contract_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, Boolean, Int32, Boolean, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[OutputProperty("ret_objid", "Contract")]
[OutputProperty("ret_id_num", "Contract")]
public short IFCCC.create_contract_list([AltName("Contract_ID_Num")] string strContractID, [ParameterRequired, AltName("Title")] string str_r_Title, [AltName("Create_Date")] string strCreateDate, [AltName("Account_IDNum")] string strAccountID, [AltName("Account_Name")] string strAccountName, [AltName("Contact_First_Name")] string strContactFirst, [AltName("Contact_Last_Name")] string strContactLast, [AltName("Contact_Phone")] string strContactPhone, [AltName("contract_type")] string strType, [AltName("Terms")] string strTerms, [AltName("Price_Program")] string strPriceProg, [AltName("Status")] string strStatus, [AltName("Admin_User_Name")] string strAdmin, [AltName("Bill_To_Site_ID_Num")] string strBillToSite, [AltName("Ship_To_Site_ID_Num")] string strShipToSite, [AltName("Start_Date")] string strEffDate, [AltName("Expire_Date")] string strExpiryDate, [AltName("Default_Start_Date")] string strServStartDate, [AltName("Default_Expiration_Date")] string strServEndDate, [AltName("User_Name")] string strUser, [AltName("queue")] string strQueue, [AltName("Is_Warranty")] bool bWarranty, [AltName("Is_Evergreen")] bool bEvergreen, [AltName("Renew_Prior_Days")] int lRenewPrior, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool bGenTimeBombs, IFCList lstFields = null, IFCList lstDataTypes = null, IFCList lstValues = null)
Parameters
Type | Name | Description
System.String | strContractID |
System.String | str_r_Title |
System.String | strCreateDate |
System.String | strAccountID |
System.String | strAccountName |
System.String | strContactFirst |
System.String | strContactLast |
System.String | strContactPhone |
System.String | strType |
System.String | strTerms |
System.String | strPriceProg |
System.String | strStatus |
System.String | strAdmin |
System.String | strBillToSite |
System.String | strShipToSite |
System.String | strEffDate |
System.String | strExpiryDate |
System.String | strServStartDate |
System.String | strServEndDate |
System.String | strUser |
System.String | strQueue |
System.Boolean | bWarranty |
System.Boolean | bEvergreen |
System.Int32 | lRenewPrior |
System.Boolean | bGenTimeBombs |
IFCList | lstFields |
IFCList | lstDataTypes |
IFCList | lstValues |
Returns
Type | Description
System.Int16 |

IFCCC.create_price_inst(String, String, String, String, String, Int32, Int32, Double, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[OutputProperty("ret_objid", "PriceInstance")]
public short IFCCC.create_price_inst([ParameterRequired, AltName("part_number")] string strPartNum, [ParameterRequired, AltName("Part_Revision")] string strModLevel, [ParameterRequired, AltName("Part_Domain")] string strDomain, [ParameterRequired, AltName("Support_Program")] string str_r_SupportProg, [ParameterRequired, AltName("Price_Program")] string str_r_PriceProg, [ParameterRequired, AltType("FChoice.Toolkits.Clarify.PriceType", "(short)({0})"), AltName("Price_Type")] int l_r_PriceType, [ParameterRequired, AltName("Quantity")] int l_r_PricedQty, [AltName("Price")] double dPrice, [AltName("Effective_Date")] string strEffDate, [AltName("Expire_Date")] string strExpiryDate, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | strPartNum |
System.String | strModLevel |
System.String | strDomain |
System.String | str_r_SupportProg |
System.String | str_r_PriceProg |
System.Int32 | l_r_PriceType |
System.Int32 | l_r_PricedQty |
System.Double | dPrice |
System.String | strEffDate |
System.String | strExpiryDate |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCC.create_price_inst_list(String, String, String, String, String, Int32, Int32, Double, String, String, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[AltName("Create_Price_Instance")]
[OutputProperty("ret_objid", "Objid of the Price Instance record.")]
public short IFCCC.create_price_inst_list([ParameterRequired, AltName("part_number")] string strPartNum, [ParameterRequired, AltName("Part_Revision")] string strModLevel, [ParameterRequired, AltName("Part_Domain")] string strDomain, [ParameterRequired, AltName("Support_Program")] string str_r_SupportProg, [ParameterRequired, AltName("Price_Program")] string str_r_PriceProg, [ParameterRequired, AltType("FChoice.Toolkits.Clarify.PriceInstanceType", "(int)({0})"), ParameterDefaultValue("FChoice.Toolkits.Clarify.PriceInstanceType.Fixed"), AltName("Price_Type")] int l_r_PriceType, [ParameterRequired, AltName("Quantity")] int l_r_PricedQty, [AltName("Price")] double dPrice, [AltName("Effective_Date")] string strEffDate, [AltName("Expire_Date")] string strExpiryDate, IFCList lstFields = null, IFCList lstDataTypes = null, IFCList lstValues = null)
Parameters
Type | Name | Description
System.String | strPartNum |
System.String | strModLevel |
System.String | strDomain |
System.String | str_r_SupportProg |
System.String | str_r_PriceProg |
System.Int32 | l_r_PriceType |
System.Int32 | l_r_PricedQty |
System.Double | dPrice |
System.String | strEffDate |
System.String | strExpiryDate |
IFCList | lstFields |
IFCList | lstDataTypes |
IFCList | lstValues |
Returns
Type | Description
System.Int16 |

IFCCC.create_update_schedule(String, Boolean, String, String, String, String, String, String, String, String, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[FacadeVoid]
public short IFCCC.create_update_schedule(string contract_id, bool is_create, string sched_id, string bill_site, string bill_attn, string ship_site, string price_prog, string bill_freq, string bill_option, string period_start_dt, string first_bill_dt, string chg_start_dt, string chg_end_dt, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | contract_id |
System.Boolean | is_create |
System.String | sched_id |
System.String | bill_site |
System.String | bill_attn |
System.String | ship_site |
System.String | price_prog |
System.String | bill_freq |
System.String | bill_option |
System.String | period_start_dt |
System.String | first_bill_dt |
System.String | chg_start_dt |
System.String | chg_end_dt |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCC.create_update_schedule_list(String, Boolean, String, String, String, String, String, String, String, String, String, String, String, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[SplitMethod("create_schedule_list")]
[SplitMethod("update_schedule_list")]
public short IFCCC.create_update_schedule_list([ParameterRequired, AltName("Contract_ID_Num")] string contract_id, [ParameterDefaultValue("true", "create_schedule_list"), ParameterDefaultValue("false", "update_schedule_list"), ParameterVoid] bool is_create, [ParameterRequired("update_schedule_list"), AltName("Schedule_IDNum")] string sched_id, [AltName("Bill_Site_ID_Num")] string bill_site, [AltName("Billing_ATTN"), AltType("System.String", "({1} && {0} == String.Empty) ? \"CLEAR\" : {0}", "update_schedule_list")] string bill_attn, [AltName("Ship_To_Site_ID_Num")] string ship_site, [AltName("Price_Program")] string price_prog, [AltName("Billing_Frequency"), AltType("BillingFrequency", "{1} ? Utility.GetBillingFrequency({0}) : string.Empty "), ParameterDefaultValue("BillingFrequency.Annual")] string bill_freq, [AltName("Billing_Option"), AltType("BillingOption", "{1} ? Utility.GetBillingOption({0}) : string.Empty "), ParameterDefaultValue("BillingOption.InAdvance")] string bill_option, [AltName("Billing_Period_Start_Date")] string period_start_dt, [AltName("First_Billing_Date")] string first_bill_dt, [AltName("Charge_Start_Date")] string chg_start_dt, [AltName("Charge_End_Date")] string chg_end_dt, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | contract_id |
System.Boolean | is_create |
System.String | sched_id |
System.String | bill_site |
System.String | bill_attn |
System.String | ship_site |
System.String | price_prog |
System.String | bill_freq |
System.String | bill_option |
System.String | period_start_dt |
System.String | first_bill_dt |
System.String | chg_start_dt |
System.String | chg_end_dt |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCCC.CreateContract(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, Boolean, Int32, Boolean, String, Int32, String, String, String, String)

Declaration
[FacadeVoid]
public short IFCCC.CreateContract([AltName("Contract_Objid")] string strContractID, [ParameterRequired, AltName("Title")] string str_r_Title, [AltName("Create_Date")] string strCreateDate, [AltName("Account_IDNum")] string strAccountID, [AltName("Account_Name")] string strAccountName, [AltName("Contact_First_Name")] string strContactFirst, [AltName("Contact_Last_Name")] string strContactLast, [AltName("Contact_Phone")] string strContactPhone, [AltName("contract_type")] string strType, [AltName("Terms")] string strTerms, [AltName("Price_Program")] string strPriceProg, [AltName("Status")] string strStatus, [AltName("Administrator_Objid")] string strAdmin, [AltName("Bill_To_Site_IDNum")] string strBillToSite, [AltName("Ship_To_Site_IDNum")] string strShipToSite, [AltName("Start_Date")] string strEffDate, [AltName("Expire_Date")] string strExpiryDate, [AltName("Default_Start_Date")] string strServStartDate, [AltName("Default_Expiration_Date")] string strServEndDate, [AltName("User_Name")] string strUser, [AltName("queue")] string strQueue, [AltName("Is_Warranty")] bool bWarranty, [AltName("Is_Evergreen")] bool bEvergreen, [AltName("Renew_Prior")] int lRenewPrior, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool bGenTimeBombs, string int_fld1, int int_val1, string str_fld1, string str_val1, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | strContractID |
System.String | str_r_Title |
System.String | strCreateDate |
System.String | strAccountID |
System.String | strAccountName |
System.String | strContactFirst |
System.String | strContactLast |
System.String | strContactPhone |
System.String | strType |
System.String | strTerms |
System.String | strPriceProg |
System.String | strStatus |
System.String | strAdmin |
System.String | strBillToSite |
System.String | strShipToSite |
System.String | strEffDate |
System.String | strExpiryDate |
System.String | strServStartDate |
System.String | strServEndDate |
System.String | strUser |
System.String | strQueue |
System.Boolean | bWarranty |
System.Boolean | bEvergreen |
System.Int32 | lRenewPrior |
System.Boolean | bGenTimeBombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCC.CreateContractList(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, Boolean, Int32, Boolean, IFCList, IFCList, IFCList)

Declaration
[FacadeVoid]
public short IFCCC.CreateContractList([AltName("Contract_ID_Num")] string strContractID, [ParameterRequired, AltName("Title")] string str_r_Title, [AltName("Create_Date")] string strCreateDate, [AltName("Account_ID_Num")] string strAccountID, [AltName("Account_Name")] string strAccountName, [AltName("Contact_First_Name")] string strContactFirst, [AltName("Contact_Last_Name")] string strContactLast, [AltName("Contact_Phone")] string strContactPhone, [AltName("contract_type")] string strType, [AltName("Terms")] string strTerms, [AltName("Price_Program")] string strPriceProg, [AltName("Status")] string strStatus, [AltName("Admin_User_Name")] string strAdmin, [AltName("Bill_To_Site_ID_Num")] string strBillToSite, [AltName("Ship_To_Site_ID_Num")] string strShipToSite, [AltName("Start_Date")] string strEffDate, [AltName("Expire_Date")] string strExpiryDate, [AltName("Default_Start_Date")] string strServStartDate, [AltName("Default_Expiration_Date")] string strServEndDate, [AltName("User_Name")] string strUser, [AltName("queue")] string strQueue, [AltName("Is_Warranty")] bool bWarranty, [AltName("Is_Evergreen")] bool bEvergreen, [AltName("Renew_Prior")] int lRenewPrior, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool bGenTimeBombs, IFCList lstFields = null, IFCList lstDataTypes = null, IFCList lstValues = null)
Parameters
Type | Name | Description
System.String | strContractID |
System.String | str_r_Title |
System.String | strCreateDate |
System.String | strAccountID |
System.String | strAccountName |
System.String | strContactFirst |
System.String | strContactLast |
System.String | strContactPhone |
System.String | strType |
System.String | strTerms |
System.String | strPriceProg |
System.String | strStatus |
System.String | strAdmin |
System.String | strBillToSite |
System.String | strShipToSite |
System.String | strEffDate |
System.String | strExpiryDate |
System.String | strServStartDate |
System.String | strServEndDate |
System.String | strUser |
System.String | strQueue |
System.Boolean | bWarranty |
System.Boolean | bEvergreen |
System.Int32 | lRenewPrior |
System.Boolean | bGenTimeBombs |
IFCList | lstFields |
IFCList | lstDataTypes |
IFCList | lstValues |
Returns
Type | Description
System.Int16 |

IFCCC.CreateLineItem(String, String, String, String, String, Boolean, Int32, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[FacadeVoid]
[AltName("Create_Contract_Schedule_Line_Item")]
public short IFCCC.CreateLineItem([AltName("Contract_ID_Num")] string str_r_ContractID, [AltName("Schedule_ID_Num")] string str_r_ScheduleID, [AltName("Part_Number")] string str_r_PartNum, [AltName("Part_Revision")] string strModLevel, [AltName("Part_Domain")] string str_r_Domain, [AltName("Is_Generic")] bool b_IsGeneric, [AltName("Site_Part_Objid")] int lSitePartObjid, [AltName("Serial_Number")] string strSerialNum, [AltName("Site_ID_Num")] string strSiteId, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | str_r_ContractID |
System.String | str_r_ScheduleID |
System.String | str_r_PartNum |
System.String | strModLevel |
System.String | str_r_Domain |
System.Boolean | b_IsGeneric |
System.Int32 | lSitePartObjid |
System.String | strSerialNum |
System.String | strSiteId |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCC.CreateLineItemList(String, String, String, String, String, Boolean, Int32, String, String, IFCList, IFCList, IFCList)

Declaration
[FacadeVoid]
[ToolkitVisible(false)]
public short IFCCC.CreateLineItemList([AltName("Contract_ID_Num")] string str_r_ContractID, [AltName("Schedule_ID_Num")] string str_r_ScheduleID, [AltName("Part_Number")] string str_r_PartNum, [AltName("Part_Revision")] string strModLevel, [AltName("Part_Domain")] string str_r_Domain, [AltName("Is_Generic")] bool b_IsGeneric, [AltName("Site_Part_Objid")] int lSitePartObjid, [AltName("Serial_Number")] string strSerialNum, [AltName("Site_ID_Num")] string strSiteId, IFCList lstFields = null, IFCList lstDataTypes = null, IFCList lstValues = null)
Parameters
Type | Name | Description
System.String | str_r_ContractID |
System.String | str_r_ScheduleID |
System.String | str_r_PartNum |
System.String | strModLevel |
System.String | str_r_Domain |
System.Boolean | b_IsGeneric |
System.Int32 | lSitePartObjid |
System.String | strSerialNum |
System.String | strSiteId |
IFCList | lstFields |
IFCList | lstDataTypes |
IFCList | lstValues |
Returns
Type | Description
System.Int16 |

IFCCC.CreatePriceInst(String, String, String, String, String, Int32, Int32, Double, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[FacadeVoid]
public short IFCCC.CreatePriceInst([AltName("part_number")] string strPartNum, string strModLevel, string strDomain, [ParameterRequired, AltName("Support_Program")] string str_r_SupportProg, [ParameterRequired, AltName("Price_Program")] string str_r_PriceProg, [ParameterRequired, AltName("Price_Type")] int l_r_PriceType, [ParameterRequired, AltName("Quantity")] int l_r_PricedQty, [AltName("Price")] double dPrice, [AltName("Effective_Date")] string strEffDate, [AltName("Expire_Date")] string strExpiryDate, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | strPartNum |
System.String | strModLevel |
System.String | strDomain |
System.String | str_r_SupportProg |
System.String | str_r_PriceProg |
System.Int32 | l_r_PriceType |
System.Int32 | l_r_PricedQty |
System.Double | dPrice |
System.String | strEffDate |
System.String | strExpiryDate |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCC.CreatePriceInstList(String, String, String, String, String, Int32, Int32, Double, String, String, IFCList, IFCList, IFCList)

Declaration
[FacadeVoid]
public short IFCCC.CreatePriceInstList([ParameterRequired, AltName("Part_Number")] string strPartNum, [ParameterRequired, AltName("Part_Revision")] string strModLevel, [ParameterRequired, AltName("Part_Domain")] string strDomain, string str_r_SupportProg, string str_r_PriceProg, int l_r_PriceType, [ParameterRequired, AltName("Quantity")] int l_r_PricedQty, double dPrice, string strEffDate, string strExpiryDate, IFCList lstFields = null, IFCList lstDataTypes = null, IFCList lstValues = null)
Parameters
Type | Name | Description
System.String | strPartNum |
System.String | strModLevel |
System.String | strDomain |
System.String | str_r_SupportProg |
System.String | str_r_PriceProg |
System.Int32 | l_r_PriceType |
System.Int32 | l_r_PricedQty |
System.Double | dPrice |
System.String | strEffDate |
System.String | strExpiryDate |
IFCList | lstFields |
IFCList | lstDataTypes |
IFCList | lstValues |
Returns
Type | Description
System.Int16 |

IFCCC.delete_sp(Int32)

Declaration
[AltName("Delete_Site_Part")]
public short IFCCC.delete_sp([ParameterRequired, AltName("Site_Part_Objid")] int sp_objid)
Parameters
Type | Name | Description
System.Int32 | sp_objid |
Returns
Type | Description
System.Int16 |

IFCCC.dispatch_quote(String, String, String, String, Boolean)

Declaration
public short IFCCC.dispatch_quote([ParameterRequired, AltName("Quote_IDNum")] string quote_id, [ParameterRequired, AltName("queue")] string queue_name, [AltName("Dispatch_Date")] string disp_date, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | quote_id |
System.String | queue_name |
System.String | disp_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCC.forward_quote(String, String, String, String, String, Boolean)

Declaration
public short IFCCC.forward_quote([ParameterRequired, AltName("Quote_IDNum")] string quote_id, [ParameterRequired] string new_queue, string forward_date, [AltName("notes")] string note_str, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | quote_id |
System.String | new_queue |
System.String | forward_date |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCC.impersonatorUserName

Declaration
public string IFCCC.impersonatorUserName { get; set; }
Returns
Type | Description
System.String |

IFCCC.Initialize(IFCApplication, IFCSession)

Declaration
[ToolkitVisible(false)]
public void IFCCC.Initialize(IFCApplication TheFCApplication, IFCSession TheFCSession)
Parameters
Type | Name | Description
IFCApplication | TheFCApplication |
IFCSession | TheFCSession |

IFCCC.log_contract_note(String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[FacadeVoid]
public short IFCCC.log_contract_note([ParameterRequired, AltName("Contract_ID_Num")] string contract_id, string action_type, [ParameterRequired, AltName("notes")] string note_str, [ParameterRequired, AltName("Internal_Use")] string int_use, string log_date, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCC.log_contract_note_list(String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[OutputProperty("ret_objid", "NotesLog")]
public short IFCCC.log_contract_note_list([ParameterRequired, AltName("Contract_ID_Num")] string contract_id, string action_type, [ParameterRequired, AltName("notes")] string note_str, [AltName("Internal_Use_Only_Notes")] string int_use, string log_date, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCCC.move_quote(String, String)

Declaration
public short IFCCC.move_quote([ParameterRequired, AltName("Quote_IDNum")] string quote_id, [ParameterRequired, AltName("new_Wip_bin")] string new_wipbin_name)
Parameters
Type | Name | Description
System.String | quote_id |
System.String | new_wipbin_name |
Returns
Type | Description
System.Int16 |

IFCCC.reject_contract(String, String, String, String, String, Boolean)

Declaration
public short IFCCC.reject_contract([ParameterRequired, AltName("Contract_ID_Num")] string contract_id, [AltName("Status")] string the_status, [AltName("notes")] string the_notes, string user_name, string reject_date, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bomb)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | the_status |
System.String | the_notes |
System.String | user_name |
System.String | reject_date |
System.Boolean | gen_time_bomb |
Returns
Type | Description
System.Int16 |

IFCCC.reject_quote(String, String, String, String, String, Boolean)

Declaration
public short IFCCC.reject_quote([ParameterRequired, AltName("Quote_IDNum")] string quote_id, string reject_date, [AltName("WipBin")] string wipbin_name, [AltName("notes")] string note_str, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | quote_id |
System.String | reject_date |
System.String | wipbin_name |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCC.relate_contr_itm_to_sp(Int32, String, String, String, String)

Declaration
[SplitMethod("Relate_Contract_Item_To_Site_Part")]
[SplitMethod("Unrelate_Contract_Item_From_Site_Part")]
public short IFCCC.relate_contr_itm_to_sp([ParameterRequired, AltName("Contract_Objid")] int contr_objid, [ParameterRequired, AltName("Part_Number")] string part_num, [ParameterRequired, AltName("Part_Domain")] string domain, [ParameterRequired, AltName("Part_Revision")] string rev, [ParameterRequired("Relate_Contract_Item_To_Site_Part"), ParameterDefaultValue("\"UNRELATE\"", "Unrelate_Contract_Item_From_Site_Part"), ParameterVoid("Unrelate_Contract_Item_From_Site_Part"), AltName("Serial_Number")] string serial_num)
Parameters
Type | Name | Description
System.Int32 | contr_objid |
System.String | part_num |
System.String | domain |
System.String | rev |
System.String | serial_num |
Returns
Type | Description
System.Int16 |

IFCCC.reopen_contract(String, String, String, String, String, Boolean)

Declaration
public short IFCCC.reopen_contract([ParameterRequired, AltName("Contract_ID_Num")] string the_id, [AltName("wip_bin")] string wipbin, [ParameterRequired] string status, string reopen_date, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | wipbin |
System.String | status |
System.String | reopen_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCC.ret_id_num

Declaration
public string IFCCC.ret_id_num { get; }
Returns
Type | Description
System.String |

IFCCC.ret_num

Declaration
public short IFCCC.ret_num { get; }
Returns
Type | Description
System.Int16 |

IFCCC.ret_objid

Declaration
public int IFCCC.ret_objid { get; }
Returns
Type | Description
System.Int32 |

IFCCC.ret_string

Declaration
public string IFCCC.ret_string { get; }
Returns
Type | Description
System.String |

IToolkit.ReturnIDNum

Declaration
public string IToolkit.ReturnIDNum { get; }
Returns
Type | Description
System.String |

IToolkit.ReturnObjid

Declaration
public int IToolkit.ReturnObjid { get; }
Returns
Type | Description
System.Int32 |

IFCCC.yank_quote(String, String, String, String, Boolean)

Declaration
public short IFCCC.yank_quote([ParameterRequired, AltName("Quote_IDNum")] string quote_id, [AltName("WipBin")] string wipbin_name, string yank_date, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | quote_id |
System.String | wipbin_name |
System.String | yank_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

Implements

IFCCC
IToolkit


Class FCCCBase | fcSDK Documentation

Class FCCCBase

Inheritance
System.Object
FCCCBase
FCCC
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Compatibility.Toolkits
Assembly: FChoice.Foundation.Clarify.Compatibility.Toolkits.dll
Syntax
[ComVisible(false)]
public abstract class FCCCBase

Constructors

FCCCBase()

Declaration
protected FCCCBase()

FCCCBase(IFCApplication, IFCSession)

Declaration
protected FCCCBase(IFCApplication FCApp, IFCSession FCSess)
Parameters
Type | Name | Description
IFCApplication | FCApp |
IFCSession | FCSess |

Properties

_impersonatorUserName

Declaration
protected string _impersonatorUserName { get; set; }
Property Value
Type | Description
System.String |

_ret_id_num

Declaration
protected string _ret_id_num { get; set; }
Property Value
Type | Description
System.String |

_ret_num

Declaration
protected short _ret_num { get; set; }
Property Value
Type | Description
System.Int16 |

_ret_objid

Declaration
protected int _ret_objid { get; set; }
Property Value
Type | Description
System.Int32 |

_ret_string

Declaration
protected string _ret_string { get; set; }
Property Value
Type | Description
System.String |

Methods

_accept_quote(String, String, String, String, Boolean)

Declaration
protected short _accept_quote(string quote_id, string accept_date, string wipbin_name, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | quote_id |
System.String | accept_date |
System.String | wipbin_name |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_add_po_to_sched(String, String, String, String, String, String, String, String, String)

Declaration
protected short _add_po_to_sched(string contract_id, string sched_id, string po_num, string pay_option, string pay_terms, string po_amt, string po_date, string expire_date, string po_status)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | sched_id |
System.String | po_num |
System.String | pay_option |
System.String | pay_terms |
System.String | po_amt |
System.String | po_date |
System.String | expire_date |
System.String | po_status |
Returns
Type | Description
System.Int16 |

_assign_quote(String, String, String, String, String, Boolean)

Declaration
protected short _assign_quote(string quote_id, string new_user, string wipbin_name, string assign_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | quote_id |
System.String | new_user |
System.String | wipbin_name |
System.String | assign_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_change_quote_status(String, String, String, String, String, Boolean)

Declaration
protected short _change_quote_status(string quote_id, string new_status, string change_date, string note_str, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | quote_id |
System.String | new_status |
System.String | change_date |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_cr_contr_itm(String, String, String, String, String, String, String, String, Int32, String, String, Double, String, Boolean, Boolean, String, String, String, Int32, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _cr_contr_itm(string contract_id, string user_name, string create_date, string start_date, string end_date, string part_num, string domain, string rev, int quantity, string price_schedule, string oride_price, double units_used, string serial_num, bool is_taxable, bool install_it, string comments, string quoted_site, string serviced_at_site, int parent_objid, string po_num, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | user_name |
System.String | create_date |
System.String | start_date |
System.String | end_date |
System.String | part_num |
System.String | domain |
System.String | rev |
System.Int32 | quantity |
System.String | price_schedule |
System.String | oride_price |
System.Double | units_used |
System.String | serial_num |
System.Boolean | is_taxable |
System.Boolean | install_it |
System.String | comments |
System.String | quoted_site |
System.String | serviced_at_site |
System.Int32 | parent_objid |
System.String | po_num |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_cr_contr_itm_list(String, String, String, String, String, String, String, String, Int32, String, String, Double, String, Boolean, Boolean, String, String, String, Int32, String, IFCList, IFCList, IFCList)

Declaration
protected short _cr_contr_itm_list(string contract_id, string user_name, string create_date, string start_date, string end_date, string part_num, string domain, string rev, int quantity, string price_schedule, string oride_price, double units_used, string serial_num, bool is_taxable, bool install_it, string comments, string quoted_site, string serviced_at_site, int parent_objid, string po_num, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | user_name |
System.String | create_date |
System.String | start_date |
System.String | end_date |
System.String | part_num |
System.String | domain |
System.String | rev |
System.Int32 | quantity |
System.String | price_schedule |
System.String | oride_price |
System.Double | units_used |
System.String | serial_num |
System.Boolean | is_taxable |
System.Boolean | install_it |
System.String | comments |
System.String | quoted_site |
System.String | serviced_at_site |
System.Int32 | parent_objid |
System.String | po_num |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_create_contract(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, Boolean, Int32, Boolean, String, Int32, String, String, String, String)

Declaration
protected short _create_contract(string strContractID, string str_r_Title, string strCreateDate, string strAccountID, string strAccountName, string strContactFirst, string strContactLast, string strContactPhone, string strType, string strTerms, string strPriceProg, string strStatus, string strAdmin, string strBillToSite, string strShipToSite, string strEffDate, string strExpiryDate, string strServStartDate, string strServEndDate, string strUser, string strQueue, bool bWarranty, bool bEvergreen, int lRenewPrior, bool bGenTimeBombs, string int_fld1, int int_val1, string str_fld1, string str_val1, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | strContractID |
System.String | str_r_Title |
System.String | strCreateDate |
System.String | strAccountID |
System.String | strAccountName |
System.String | strContactFirst |
System.String | strContactLast |
System.String | strContactPhone |
System.String | strType |
System.String | strTerms |
System.String | strPriceProg |
System.String | strStatus |
System.String | strAdmin |
System.String | strBillToSite |
System.String | strShipToSite |
System.String | strEffDate |
System.String | strExpiryDate |
System.String | strServStartDate |
System.String | strServEndDate |
System.String | strUser |
System.String | strQueue |
System.Boolean | bWarranty |
System.Boolean | bEvergreen |
System.Int32 | lRenewPrior |
System.Boolean | bGenTimeBombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_create_contract_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, Boolean, Int32, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _create_contract_list(string strContractID, string str_r_Title, string strCreateDate, string strAccountID, string strAccountName, string strContactFirst, string strContactLast, string strContactPhone, string strType, string strTerms, string strPriceProg, string strStatus, string strAdmin, string strBillToSite, string strShipToSite, string strEffDate, string strExpiryDate, string strServStartDate, string strServEndDate, string strUser, string strQueue, bool bWarranty, bool bEvergreen, int lRenewPrior, bool bGenTimeBombs, IFCList lstFields, IFCList lstDataTypes, IFCList lstValues)
Parameters
Type | Name | Description
System.String | strContractID |
System.String | str_r_Title |
System.String | strCreateDate |
System.String | strAccountID |
System.String | strAccountName |
System.String | strContactFirst |
System.String | strContactLast |
System.String | strContactPhone |
System.String | strType |
System.String | strTerms |
System.String | strPriceProg |
System.String | strStatus |
System.String | strAdmin |
System.String | strBillToSite |
System.String | strShipToSite |
System.String | strEffDate |
System.String | strExpiryDate |
System.String | strServStartDate |
System.String | strServEndDate |
System.String | strUser |
System.String | strQueue |
System.Boolean | bWarranty |
System.Boolean | bEvergreen |
System.Int32 | lRenewPrior |
System.Boolean | bGenTimeBombs |
IFCList | lstFields |
IFCList | lstDataTypes |
IFCList | lstValues |
Returns
Type | Description
System.Int16 |

_create_price_inst(String, String, String, String, String, Int32, Int32, Double, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _create_price_inst(string strPartNum, string strModLevel, string strDomain, string str_r_SupportProg, string str_r_PriceProg, int l_r_PriceType, int l_r_PricedQty, double dPrice, string strEffDate, string strExpiryDate, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | strPartNum |
System.String | strModLevel |
System.String | strDomain |
System.String | str_r_SupportProg |
System.String | str_r_PriceProg |
System.Int32 | l_r_PriceType |
System.Int32 | l_r_PricedQty |
System.Double | dPrice |
System.String | strEffDate |
System.String | strExpiryDate |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_create_price_inst_list(String, String, String, String, String, Int32, Int32, Double, String, String, IFCList, IFCList, IFCList)

Declaration
protected short _create_price_inst_list(string strPartNum, string strModLevel, string strDomain, string str_r_SupportProg, string str_r_PriceProg, int l_r_PriceType, int l_r_PricedQty, double dPrice, string strEffDate, string strExpiryDate, IFCList lstFields, IFCList lstDataTypes, IFCList lstValues)
Parameters
Type | Name | Description
System.String | strPartNum |
System.String | strModLevel |
System.String | strDomain |
System.String | str_r_SupportProg |
System.String | str_r_PriceProg |
System.Int32 | l_r_PriceType |
System.Int32 | l_r_PricedQty |
System.Double | dPrice |
System.String | strEffDate |
System.String | strExpiryDate |
IFCList | lstFields |
IFCList | lstDataTypes |
IFCList | lstValues |
Returns
Type | Description
System.Int16 |

_create_update_schedule(String, Boolean, String, String, String, String, String, String, String, String, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _create_update_schedule(string contract_id, bool is_create, string sched_id, string bill_site, string bill_attn, string ship_site, string price_prog, string bill_freq, string bill_option, string period_start_dt, string first_bill_dt, string chg_start_dt, string chg_end_dt, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | contract_id |
System.Boolean | is_create |
System.String | sched_id |
System.String | bill_site |
System.String | bill_attn |
System.String | ship_site |
System.String | price_prog |
System.String | bill_freq |
System.String | bill_option |
System.String | period_start_dt |
System.String | first_bill_dt |
System.String | chg_start_dt |
System.String | chg_end_dt |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_create_update_schedule_list(String, Boolean, String, String, String, String, String, String, String, String, String, String, String, IFCList, IFCList, IFCList)

Declaration
protected short _create_update_schedule_list(string contract_id, bool is_create, string sched_id, string bill_site, string bill_attn, string ship_site, string price_prog, string bill_freq, string bill_option, string period_start_dt, string first_bill_dt, string chg_start_dt, string chg_end_dt, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | contract_id |
System.Boolean | is_create |
System.String | sched_id |
System.String | bill_site |
System.String | bill_attn |
System.String | ship_site |
System.String | price_prog |
System.String | bill_freq |
System.String | bill_option |
System.String | period_start_dt |
System.String | first_bill_dt |
System.String | chg_start_dt |
System.String | chg_end_dt |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_CreateContract(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, Boolean, Int32, Boolean, String, Int32, String, String, String, String)

Declaration
protected short _CreateContract(string strContractID, string str_r_Title, string strCreateDate, string strAccountID, string strAccountName, string strContactFirst, string strContactLast, string strContactPhone, string strType, string strTerms, string strPriceProg, string strStatus, string strAdmin, string strBillToSite, string strShipToSite, string strEffDate, string strExpiryDate, string strServStartDate, string strServEndDate, string strUser, string strQueue, bool bWarranty, bool bEvergreen, int lRenewPrior, bool bGenTimeBombs, string int_fld1, int int_val1, string str_fld1, string str_val1, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | strContractID |
System.String | str_r_Title |
System.String | strCreateDate |
System.String | strAccountID |
System.String | strAccountName |
System.String | strContactFirst |
System.String | strContactLast |
System.String | strContactPhone |
System.String | strType |
System.String | strTerms |
System.String | strPriceProg |
System.String | strStatus |
System.String | strAdmin |
System.String | strBillToSite |
System.String | strShipToSite |
System.String | strEffDate |
System.String | strExpiryDate |
System.String | strServStartDate |
System.String | strServEndDate |
System.String | strUser |
System.String | strQueue |
System.Boolean | bWarranty |
System.Boolean | bEvergreen |
System.Int32 | lRenewPrior |
System.Boolean | bGenTimeBombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_CreateContractList(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, Boolean, Int32, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _CreateContractList(string strContractID, string str_r_Title, string strCreateDate, string strAccountID, string strAccountName, string strContactFirst, string strContactLast, string strContactPhone, string strType, string strTerms, string strPriceProg, string strStatus, string strAdmin, string strBillToSite, string strShipToSite, string strEffDate, string strExpiryDate, string strServStartDate, string strServEndDate, string strUser, string strQueue, bool bWarranty, bool bEvergreen, int lRenewPrior, bool bGenTimeBombs, IFCList lstFields, IFCList lstDataTypes, IFCList lstValues)
Parameters
Type | Name | Description
System.String | strContractID |
System.String | str_r_Title |
System.String | strCreateDate |
System.String | strAccountID |
System.String | strAccountName |
System.String | strContactFirst |
System.String | strContactLast |
System.String | strContactPhone |
System.String | strType |
System.String | strTerms |
System.String | strPriceProg |
System.String | strStatus |
System.String | strAdmin |
System.String | strBillToSite |
System.String | strShipToSite |
System.String | strEffDate |
System.String | strExpiryDate |
System.String | strServStartDate |
System.String | strServEndDate |
System.String | strUser |
System.String | strQueue |
System.Boolean | bWarranty |
System.Boolean | bEvergreen |
System.Int32 | lRenewPrior |
System.Boolean | bGenTimeBombs |
IFCList | lstFields |
IFCList | lstDataTypes |
IFCList | lstValues |
Returns
Type | Description
System.Int16 |

_CreateLineItem(String, String, String, String, String, Boolean, Int32, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _CreateLineItem(string str_r_ContractID, string str_r_ScheduleID, string str_r_PartNum, string strModLevel, string str_r_Domain, bool b_IsGeneric, int lSitePartObjid, string strSerialNum, string strSiteId, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | str_r_ContractID |
System.String | str_r_ScheduleID |
System.String | str_r_PartNum |
System.String | strModLevel |
System.String | str_r_Domain |
System.Boolean | b_IsGeneric |
System.Int32 | lSitePartObjid |
System.String | strSerialNum |
System.String | strSiteId |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_CreateLineItemList(String, String, String, String, String, Boolean, Int32, String, String, IFCList, IFCList, IFCList)

Declaration
protected short _CreateLineItemList(string str_r_ContractID, string str_r_ScheduleID, string str_r_PartNum, string strModLevel, string str_r_Domain, bool b_IsGeneric, int lSitePartObjid, string strSerialNum, string strSiteId, IFCList lstFields, IFCList lstDataTypes, IFCList lstValues)
Parameters
Type | Name | Description
System.String | str_r_ContractID |
System.String | str_r_ScheduleID |
System.String | str_r_PartNum |
System.String | strModLevel |
System.String | str_r_Domain |
System.Boolean | b_IsGeneric |
System.Int32 | lSitePartObjid |
System.String | strSerialNum |
System.String | strSiteId |
IFCList | lstFields |
IFCList | lstDataTypes |
IFCList | lstValues |
Returns
Type | Description
System.Int16 |

_CreatePriceInst(String, String, String, String, String, Int32, Int32, Double, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _CreatePriceInst(string strPartNum, string strModLevel, string strDomain, string str_r_SupportProg, string str_r_PriceProg, int l_r_PriceType, int l_r_PricedQty, double dPrice, string strEffDate, string strExpiryDate, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | strPartNum |
System.String | strModLevel |
System.String | strDomain |
System.String | str_r_SupportProg |
System.String | str_r_PriceProg |
System.Int32 | l_r_PriceType |
System.Int32 | l_r_PricedQty |
System.Double | dPrice |
System.String | strEffDate |
System.String | strExpiryDate |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_CreatePriceInstList(String, String, String, String, String, Int32, Int32, Double, String, String, IFCList, IFCList, IFCList)

Declaration
protected short _CreatePriceInstList(string strPartNum, string strModLevel, string strDomain, string str_r_SupportProg, string str_r_PriceProg, int l_r_PriceType, int l_r_PricedQty, double dPrice, string strEffDate, string strExpiryDate, IFCList lstFields, IFCList lstDataTypes, IFCList lstValues)
Parameters
Type | Name | Description
System.String | strPartNum |
System.String | strModLevel |
System.String | strDomain |
System.String | str_r_SupportProg |
System.String | str_r_PriceProg |
System.Int32 | l_r_PriceType |
System.Int32 | l_r_PricedQty |
System.Double | dPrice |
System.String | strEffDate |
System.String | strExpiryDate |
IFCList | lstFields |
IFCList | lstDataTypes |
IFCList | lstValues |
Returns
Type | Description
System.Int16 |

_delete_sp(Int32)

Declaration
protected short _delete_sp(int sp_objid)
Parameters
Type | Name | Description
System.Int32 | sp_objid |
Returns
Type | Description
System.Int16 |

_dispatch_quote(String, String, String, String, Boolean)

Declaration
protected short _dispatch_quote(string quote_id, string queue_name, string disp_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | quote_id |
System.String | queue_name |
System.String | disp_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_forward_quote(String, String, String, String, String, Boolean)

Declaration
protected short _forward_quote(string quote_id, string new_queue, string forward_date, string note_str, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | quote_id |
System.String | new_queue |
System.String | forward_date |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_Initialize(IFCApplication, IFCSession)

Declaration
public void _Initialize(IFCApplication TheFCApplication, IFCSession TheFCSession)
Parameters
Type | Name | Description
IFCApplication | TheFCApplication |
IFCSession | TheFCSession |

_log_contract_note(String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _log_contract_note(string contract_id, string action_type, string note_str, string int_use, string log_date, string user_name, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_log_contract_note_list(String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _log_contract_note_list(string contract_id, string action_type, string note_str, string int_use, string log_date, string user_name, bool gen_time_bombs, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_move_quote(String, String)

Declaration
protected short _move_quote(string quote_id, string new_wipbin_name)
Parameters
Type | Name | Description
System.String | quote_id |
System.String | new_wipbin_name |
Returns
Type | Description
System.Int16 |

_reject_contract(String, String, String, String, String, Boolean)

Declaration
protected short _reject_contract(string contract_id, string the_status, string the_notes, string user_name, string reject_date, bool gen_time_bomb)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | the_status |
System.String | the_notes |
System.String | user_name |
System.String | reject_date |
System.Boolean | gen_time_bomb |
Returns
Type | Description
System.Int16 |

_reject_quote(String, String, String, String, String, Boolean)

Declaration
protected short _reject_quote(string quote_id, string reject_date, string wipbin_name, string note_str, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | quote_id |
System.String | reject_date |
System.String | wipbin_name |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_relate_contr_itm_to_sp(Int32, String, String, String, String)

Declaration
protected short _relate_contr_itm_to_sp(int contr_objid, string part_num, string domain, string rev, string serial_num)
Parameters
Type | Name | Description
System.Int32 | contr_objid |
System.String | part_num |
System.String | domain |
System.String | rev |
System.String | serial_num |
Returns
Type | Description
System.Int16 |

_reopen_contract(String, String, String, String, String, Boolean)

Declaration
protected short _reopen_contract(string the_id, string wipbin, string status, string reopen_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | wipbin |
System.String | status |
System.String | reopen_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_yank_quote(String, String, String, String, Boolean)

Declaration
protected short _yank_quote(string quote_id, string wipbin_name, string yank_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | quote_id |
System.String | wipbin_name |
System.String | yank_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

GetProductID()

Declaration
protected abstract int GetProductID()
Returns
Type | Description
System.Int32 |


Class FCCL | fcSDK Documentation

Class FCCL

Inheritance
System.Object
FCCLBase
FCCL
Implements
IFCCL
IToolkit
Inherited Members
FCCLBase.pick_serial_no
FCCLBase._Initialize(IFCApplication, IFCSession)
FCCLBase._accept_pr(String, String, String, String, Boolean)
FCCLBase._assign_pr(String, String, String, String, String, Boolean)
FCCLBase._change_pr_status(String, String, String, String, String, Boolean)
FCCLBase._close_pr(String, String, String, String, Boolean)
FCCLBase._dispatch_pr(String, String, String, String, Boolean)
FCCLBase._forward_pr(String, String, String, String, String, Boolean)
FCCLBase._add_alt_part(String, String, String, String, String, String, Boolean)
FCCLBase._delete_alt_part(String, String, String, String, String, String)
FCCLBase._get_alt_parts(String, String, String)
FCCLBase._get_loc_serv_site(String)
FCCLBase._move_pr(String, String)
FCCLBase._pick_sn(String, String, Boolean, String, String, String, String, Boolean)
FCCLBase._pick_sn_no_trans(String, String, Boolean, String, String, String, String, Boolean)
FCCLBase._pick(String, String, Boolean, String, String, String, Boolean)
FCCLBase._pick_no_trans(String, String, Boolean, String, String, String, Boolean)
FCCLBase._pick_internal(String, String, Boolean, String, String, String, Boolean, Boolean)
FCCLBase._reject_pr(String, String, String, String, String, Boolean)
FCCLBase._reopen_pr(String, String, String, String, String, Boolean)
FCCLBase._ship(String, String, String, String, String, String, String, String, String, String, String, String, Int32, Double, String, String, String, String, Boolean)
FCCLBase._unpick_sn(String, String, String, String, Boolean, String, String, String, Boolean)
FCCLBase._unpick_sn_no_trans(String, String, String, String, Boolean, String, String, String, Boolean)
FCCLBase._unpick(String, String, String, String, Boolean, String, String, Boolean)
FCCLBase._unpick_no_trans(String, String, String, String, Boolean, String, String, Boolean)
FCCLBase._unpick_internal(String, String, String, String, Boolean, String, String, Boolean, Boolean)
FCCLBase._yank_pr(String, String, String, String, Boolean)
FCCLBase._add_inv_bin(String, String, Boolean)
FCCLBase._modify_inv_bin(String, String, String, Boolean)
FCCLBase._add_gl_account(String, String, String, String, Boolean, Boolean, Boolean, String)
FCCLBase._modify_gl_account(String, String, String, String, String, Boolean, Boolean, Boolean, String)
FCCLBase._add_inv_location(String, String, String, String, String, Boolean, Boolean, String, String)
FCCLBase._modify_inv_location(String, String, String, String, String, String, Boolean, Boolean, String, String)
FCCLBase._add_lss(String, String, Boolean, Int16)
FCCLBase._delete_lss(String, String)
FCCLBase._modify_lss(String, String, Int16)
FCCLBase._set_part_stocking_lev(String, String, String, String, String, String, Int16, Int16, Int16, Int16, Boolean)
FCCLBase._mod_part_stocking_lev(String, String, String, String, String, String, String, String, Int16, Int16, Int16, Int16, Boolean)
FCCLBase._fulfill(String, Boolean, Int32, String, String, String, Boolean, String, String, String, Boolean, String, String, String, String, String, Boolean)
FCCLBase._fulfill_no_trans(String, Boolean, Int32, String, String, String, Boolean, String, String, String, Boolean, String, String, String, String, String, Boolean)
FCCLBase._fulfill_internal(String, Boolean, Int32, String, String, String, Boolean, String, String, String, Boolean, String, String, String, String, String, Boolean, Boolean)
FCCLBase._make_pr_detail_list(String, String, String, String, String, String, Int32, Int32, String, String, String, String, String, String, Int16, String, String, String, String, Boolean, Int32, IFCList, IFCList, IFCList)
FCCLBase._make_pr_detail(String, String, String, String, String, String, Int32, Int32, String, String, String, String, String, String, Int16, String, String, String, String, Boolean, Int32, String, Int32, String, Int32, String, String, String, String, String, String)
FCCLBase._part_transfer(String, String, String, Int32, String, String, String, String, Boolean, String, String, String, Boolean, String, String, String, String, Boolean, Int16, String, String, String, String)
FCCLBase._make_pr_header_case_list(String, String, String, String, String, String, String, String, String, String, String, String, Int32, IFCList, IFCList, IFCList)
FCCLBase._make_pr_header_subcase_list(String, String, String, String, String, String, String, String, String, String, String, String, Int32, IFCList, IFCList, IFCList)
FCCLBase._make_pr_header_list(String, String, String, String, String, String, String, String, String, String, String, String, Int32, IFCList, IFCList, IFCList)
FCCLBase._make_pr_header(String, String, String, String, String, String, String, String, String, String, String, String, Int32, String, Int32, String, Int32, String, String, String, String, String, String)
FCCLBase._update_pr_header_list(String, String, String, String, String, String, String, String, String, String, String, IFCList, IFCList, IFCList)
FCCLBase._update_pr_header(String, String, String, String, String, String, String, String, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)
FCCLBase._update_pr_detail_list(String, String, String, String, String, Int32, Int32, String, String, String, String, Int16, String, String, IFCList, IFCList, IFCList)
FCCLBase._update_pr_detail(String, String, String, String, String, Int32, Int32, String, String, String, String, Int16, String, String, String, Int32, String, Int32, String, String, String, String, String, String)
FCCLBase._create_container(String, String, String, String)
FCCLBase._seal_container(String)
FCCLBase._open_container(String)
FCCLBase._receive_pr_internal(String, String, String, String, Boolean, String, String, String, Boolean, Int32, String, String, String, String, Boolean, Boolean, Boolean, String, String, Boolean, Boolean, Boolean)
FCCLBase._set_cl_transition(String, String, String, String[])
FCCLBase._object_name
FCCLBase._ret_objid
FCCLBase._ret_num
FCCLBase._ret_id_num
FCCLBase._ret_string
FCCLBase._impersonatorUserName
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Compatibility.Toolkits
Assembly: FChoice.Foundation.Clarify.Compatibility.Toolkits.dll
Syntax
[Guid("FB9E2A48-FE03-405a-A34C-94FF5974BB53")]
[ComVisible(true)]
[AltName("Logistics")]
[ClassInterface(ClassInterfaceType.None)]
public sealed class FCCL : FCCLBase, IFCCL, IToolkit

Constructors

FCCL()

Declaration
public FCCL()

FCCL(IFCApplication, IFCSession)

Declaration
public FCCL(IFCApplication FCApp, IFCSession FCSess)
Parameters
Type | Name | Description
IFCApplication | FCApp |
IFCSession | FCSess |

Methods

fulfill_internal(String, Boolean, Int32, String, String, String, Boolean, String, String, String, Boolean, String, String, String, String, String, Boolean, Boolean)

Declaration
[SplitMethod("fulfill_part_request", 4)]
[SplitMethod("backorder_part_request", 4)]
[FacadeProperty("From_Location", "FChoice.Toolkits.Clarify.Location", "FChoice.Toolkits.Clarify.Location.EMPTY", "if({0}.IsLocationNameDirty) {2}.InternalFromLocation = {0}.LocationName; if({0}.IsBinNameDirty) {2}.InternalFromBin = {0}.BinName; if({0}.IsContainerIDNumDirty) {2}.InternalFromContainer = {0}.ContainerIDNum;", false, false, null, null, 70012)]
[FacadeProperty("To_Location", "FChoice.Toolkits.Clarify.Location", "FChoice.Toolkits.Clarify.Location.EMPTY", "if({0}.IsLocationNameDirty) {2}.InternalToLocation = {0}.LocationName; if({0}.IsBinNameDirty) {2}.InternalToBin = {0}.BinName; if({0}.IsContainerIDNumDirty) {2}.InternalToContainer = {0}.ContainerIDNum;", false, false, null, null, 70013)]
[ComVisible(false)]
public short fulfill_internal([ParameterRequired(null, 0, 0), ParameterRequired(null, 1, 0), ParameterRequired(null, 2, 0), ParameterRequired(null, 3, 0), AltName("part_request_detail_IDNum")] string dtl_num, [ParameterVoid, ParameterDefaultValue("true", "fulfill_part_request"), ParameterDefaultValue("false", "backorder_part_request")] bool is_fulfill, [ParameterRequired(null, 0, 3), ParameterRequired(null, 2, 3), AltName("quantity"), ParameterDefaultValue("1")] int quantity_num, [ParameterVoid, AltName("internal_from_location")] string from_loc, [ParameterVoid, AltName("internal_from_bin")] string from_bin, [ParameterVoid, AltName("internal_from_container")] string from_cont, [ParameterDefaultValue("true")] bool from_good, [ParameterVoid, AltName("internal_to_location")] string to_loc, [ParameterVoid, AltName("internal_to_bin")] string to_bin, [ParameterVoid, AltName("internal_to_container")] string to_cont, [ParameterDefaultValue("true")] bool to_good, [ParameterRequired(null, 1, 3, false), ParameterRequired(null, 3, 3, false), AltName("serial_number")] string serial_num, [AltName("new_Status")] string new_status, [ParameterRequired("backorder_part_request", 0, 1), ParameterRequired("backorder_part_request", 1, 1), ParameterRequired("backorder_part_request", 2, 1), ParameterRequired("backorder_part_request", 3, 1), ParameterVoid("fulfill_part_request")] string expected_date, string user_name, [ParameterVoid("backorder_part_request")] string fulfill_date, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs, [ParameterRequired(null, 2, 2), ParameterRequired(null, 3, 2), AltName("use_transitions"), ParameterDefaultValue("true")] bool do_cond_change)
Parameters
Type | Name | Description
System.String | dtl_num |
System.Boolean | is_fulfill |
System.Int32 | quantity_num |
System.String | from_loc |
System.String | from_bin |
System.String | from_cont |
System.Boolean | from_good |
System.String | to_loc |
System.String | to_bin |
System.String | to_cont |
System.Boolean | to_good |
System.String | serial_num |
System.String | new_status |
System.String | expected_date |
System.String | user_name |
System.String | fulfill_date |
System.Boolean | gen_time_bombs |
System.Boolean | do_cond_change |
Returns
Type | Description
System.Int16 |

GetProductID()

Declaration
protected override int GetProductID()
Returns
Type | Description
System.Int32 |
Overrides
FCCLBase.GetProductID()

pick_internal(String, String, Boolean, String, String, String, String[], Boolean, Boolean)

Declaration
[SplitMethod("pick", 4)]
[ComVisible(false)]
[OutputProperty("ret_num", "TotalPicked", "System.Int32", "0", "The total number of parts picked.")]
public short pick_internal([ParameterRequired(null, 0, 0), ParameterRequired(null, 1, 0), ParameterRequired(null, 2, 0), ParameterRequired(null, 3, 0), AltName("part_request_detail_IDNum")] string dtl_num, [ParameterReadOnly, AltName("locations"), AltType("FChoice.Toolkits.Clarify.LocationCollection", "({0}.IsDirty) ? {0}.ToLegacyString() : \"\""), ParameterDefaultValue("new FChoice.Toolkits.Clarify.LocationCollection()")] string locs_str, [ParameterDefaultValue("true")] bool use_good, string user_name, string pick_date, [AltName("new_Status")] string new_status, [ParameterRequired(true, null, 1, 1, true), ParameterRequired(true, null, 3, 2, true), ParameterDefaultValue("new string[0]")] string[] serial_numbers, [ParameterRequired(null, 2, 1), ParameterRequired(null, 3, 1), AltName("use_transitions"), ParameterDefaultValue("true")] bool do_cond_change, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | locs_str |
System.Boolean | use_good |
System.String | user_name |
System.String | pick_date |
System.String | new_status |
System.String[] | serial_numbers |
System.Boolean | do_cond_change |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

receive_pr_internal(String, String, String, String, Boolean, String, String, String, Boolean, Int32, String, String, String, String, Boolean, Boolean, Boolean, String, String, Boolean, Boolean, Boolean)

Declaration
[ComVisible(false)]
[SplitMethod("Receive_Part_Request", 4)]
[FacadeProperty("From_Location", "FChoice.Toolkits.Clarify.Location", "FChoice.Toolkits.Clarify.Location.EMPTY", "if({0}.IsLocationNameDirty) {2}.InternalFromLocation = {0}.LocationName; if({0}.IsBinNameDirty) {2}.InternalFromBin = {0}.BinName; if({0}.IsContainerIDNumDirty) {2}.InternalFromContainer = {0}.ContainerIDNum;", false, false, null, null, 70016)]
[FacadeProperty("To_Location", "FChoice.Toolkits.Clarify.Location", "FChoice.Toolkits.Clarify.Location.EMPTY", "if({0}.IsLocationNameDirty) {2}.InternalToLocation = {0}.LocationName; if({0}.IsBinNameDirty) {2}.InternalToBin = {0}.BinName; if({0}.IsContainerIDNumDirty) {2}.InternalToContainer = {0}.ContainerIDNum;", true, false, null, null, 70017)]
public short receive_pr_internal([ParameterRequired, AltName("part_request_detail_IDNum")] string pr_num, [ParameterVoid, AltName("internal_from_location")] string from_loc, [ParameterVoid, AltName("internal_from_bin")] string from_bin, [ParameterVoid, AltName("internal_from_container")] string from_cont, [ParameterDefaultValue("true")] bool from_good, [ParameterVoid, AltName("internal_to_location")] string to_loc, [ParameterVoid, AltName("internal_to_bin")] string to_bin, [ParameterVoid, AltName("internal_to_container")] string to_cont, [ParameterDefaultValue("true")] bool to_good, [ParameterRequired(null, 0), ParameterRequired(null, 2), AltName("quantity"), ParameterDefaultValue("1")] int quantity_num, [ParameterRequired(null, 1), ParameterRequired(null, 3), AltName("serial_number")] string serial_num, [AltName("status")] string status_str, string carrier_name, string waybill_name, [AltName("possible_damage")] bool poss_damage, [AltName("not_properly_packed")] bool not_prop_pack, bool route_to_test, string user_name, string receive_date, bool auto_close, [ParameterRequired(null, 2, 5), ParameterRequired(null, 3, 5), AltName("use_transitions"), ParameterDefaultValue("true")] bool doTransition, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | pr_num |
System.String | from_loc |
System.String | from_bin |
System.String | from_cont |
System.Boolean | from_good |
System.String | to_loc |
System.String | to_bin |
System.String | to_cont |
System.Boolean | to_good |
System.Int32 | quantity_num |
System.String | serial_num |
System.String | status_str |
System.String | carrier_name |
System.String | waybill_name |
System.Boolean | poss_damage |
System.Boolean | not_prop_pack |
System.Boolean | route_to_test |
System.String | user_name |
System.String | receive_date |
System.Boolean | auto_close |
System.Boolean | doTransition |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

set_cl_transition(String, String, String, String[])

Declaration
[ComVisible(false)]
[AltName("set_logistics_transition")]
public short set_cl_transition([ParameterRequired(true, "set_logistics_transition", 0, 0), AltName("Part_Request_Type"), AltType("FChoice.Toolkits.Clarify.PartRequestType", "Utility.GetPartRequestType({0})"), ParameterDefaultValue("FChoice.Toolkits.Clarify.PartRequestType.PleaseSpecify")] string request_type, [ParameterRequired(true, "set_logistics_transition", 0, 1), AltName("start_condition"), AltType("FChoice.Toolkits.Clarify.PartRequestCondition", "Utility.GetPartCondition({0})"), ParameterDefaultValue("FChoice.Toolkits.Clarify.PartRequestCondition.RequestOpen")] string start_cond, [ParameterRequired(true, "set_logistics_transition", 0, 2), AltName("end_condition"), AltType("FChoice.Toolkits.Clarify.PartRequestCondition", "Utility.GetPartCondition({0})"), ParameterDefaultValue("FChoice.Toolkits.Clarify.PartRequestCondition.RequestOpen")] string end_cond, [ParameterRequired(true, "set_logistics_transition", 0, 3, true), AltName("privilege_classes"), ParameterDefaultValue("null"), AltType("System.String[]", "{0}")] string[] privclasses)
Parameters
Type | Name | Description
System.String | request_type |
System.String | start_cond |
System.String | end_cond |
System.String[] | privclasses |
Returns
Type | Description
System.Int16 |

unpick_internal(String, String, String, String, Boolean, String, String, String[], Boolean, Boolean)

Declaration
[SplitMethod("unpick", 4)]
[ComVisible(false)]
[FacadeProperty("Location", "FChoice.Toolkits.Clarify.Location", "FChoice.Toolkits.Clarify.Location.EMPTY", "if({0}.IsLocationNameDirty) {2}.LocationName = {0}.LocationName; if({0}.IsBinNameDirty) {2}.BinName = {0}.BinName; if({0}.IsContainerIDNumDirty) {2}.ContainerIDNum = {0}.ContainerIDNum;", true, false, null, "0:1,1:1,2:1,3:1", 70007)]
public short unpick_internal([ParameterRequired(null, 0, 0), ParameterRequired(null, 1, 0), ParameterRequired(null, 2, 0), ParameterRequired(null, 3, 0), AltName("part_request_detail_IDNum")] string dtl_num, [ParameterVoid, AltName("location_name")] string loc_name, [ParameterVoid] string bin_name, [ParameterVoid, AltName("Container_ID_Num")] string cont_num, [ParameterDefaultValue("true")] bool use_good, string user_name, string unpick_date, [ParameterRequired(true, null, 1, 2, true), ParameterRequired(true, null, 3, 3, true), ParameterDefaultValue("new string[0]")] string[] serial_numbers, [ParameterRequired(null, 2, 2), ParameterRequired(null, 3, 2), AltName("use_transitions"), ParameterDefaultValue("true")] bool do_cond_change, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | loc_name |
System.String | bin_name |
System.String | cont_num |
System.Boolean | use_good |
System.String | user_name |
System.String | unpick_date |
System.String[] | serial_numbers |
System.Boolean | do_cond_change |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

Explicit Interface Implementations

IFCCL.accept_pr(String, String, String, String, Boolean)

Declaration
[AltName("accept_part_request")]
public short IFCCL.accept_pr([ParameterRequired, AltName("part_request_detail_IDNum")] string pr_id, string accept_date, [AltName("wip_bin")] string wipbin_name, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | pr_id |
System.String | accept_date |
System.String | wipbin_name |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCL.add_alt_part(String, String, String, String, String, String, Boolean)

Declaration
[AltName("add_alternate_part")]
public short IFCCL.add_alt_part([ParameterRequired, AltName("part_Number")] string part_num, [ParameterRequired, AltName("part_revision")] string rev, [ParameterRequired, AltName("part_domain")] string domain, [ParameterRequired, AltName("alternate_part_number")] string alt_part, [ParameterRequired, AltName("alternate_part_revision")] string alt_rev, [ParameterRequired, AltName("alternate_part_domain")] string alt_domain, bool is_reciprocal)
Parameters
Type | Name | Description
System.String | part_num |
System.String | rev |
System.String | domain |
System.String | alt_part |
System.String | alt_rev |
System.String | alt_domain |
System.Boolean | is_reciprocal |
Returns
Type | Description
System.Int16 |

IFCCL.add_gl_account(String, String, String, String, Boolean, Boolean, Boolean, String)

Declaration
[AltName("add_GL_account")]
[OutputProperty("ret_objid", "Objid of the Inventory Location record.")]
public short IFCCL.add_gl_account([ParameterRequired, AltName("account_name")] string acct_name, string account_type, [AltName("description")] string desc_str, [AltName("account_number")] string account_no, [ParameterDefaultValue("true"), AltName("is_expense_GL_account")] bool is_exp, [ParameterDefaultValue("true")] bool is_active, [ParameterDefaultValue("true")] bool is_company, [ParameterRequired, AltName("site_IDNum")] string site_id)
Parameters
Type | Name | Description
System.String | acct_name |
System.String | account_type |
System.String | desc_str |
System.String | account_no |
System.Boolean | is_exp |
System.Boolean | is_active |
System.Boolean | is_company |
System.String | site_id |
Returns
Type | Description
System.Int16 |

IFCCL.add_inv_bin(String, String, Boolean)

Declaration
[AltName("add_inventory_bin")]
[OutputProperty("ret_objid", "Objid of the Inventory Bin record.")]
[FacadeProperty("Location", "FChoice.Toolkits.Clarify.Location", "FChoice.Toolkits.Clarify.Location.EMPTY", "if({0}.IsLocationNameDirty) {2}.LocationName = {0}.LocationName; if({0}.IsBinNameDirty) {2}.BinName = {0}.BinName;", true, false, "add_inventory_bin", "0:0", 70008)]
public short IFCCL.add_inv_bin([ParameterVoid] string bin_name, [ParameterVoid, AltName("location_name")] string loc_name, [ParameterDefaultValue("true")] bool is_active)
Parameters
Type | Name | Description
System.String | bin_name |
System.String | loc_name |
System.Boolean | is_active |
Returns
Type | Description
System.Int16 |

IFCCL.add_inv_location(String, String, String, String, String, Boolean, Boolean, String, String)

Declaration
[AltName("add_inventory_location")]
[OutputProperty("ret_objid", "Objid of the Inventory Location record.")]
public short IFCCL.add_inv_location([ParameterRequired, AltName("location_name")] string loc_name, string account_type, [AltName("description")] string desc_str, [AltName("reports_to_location")] string reports_to_loc, [ParameterRequired, AltName("capital_GL_account")] string cap_gl_acct, [ParameterDefaultValue("true")] bool is_active, [ParameterDefaultValue("true")] bool is_company, [ParameterRequired, AltName("site_IDNum")] string site_id, [ParameterRequired, AltType("FChoice.Toolkits.Clarify.PartAuthorizationLevel", "Utility.GetPartAuthorizationLevel({0})"), ParameterDefaultValue("FChoice.Toolkits.Clarify.PartAuthorizationLevel.None"), AltName("part_authorization_level")] string trans_auth_str)
Parameters
Type | Name | Description
System.String | loc_name |
System.String | account_type |
System.String | desc_str |
System.String | reports_to_loc |
System.String | cap_gl_acct |
System.Boolean | is_active |
System.Boolean | is_company |
System.String | site_id |
System.String | trans_auth_str |
Returns
Type | Description
System.Int16 |

IFCCL.add_lss(String, String, Boolean, Int16)

Declaration
[AltName("add_location_servicing_site")]
[OutputProperty("ret_objid", "Objid of the Inventory Role record.")]
public short IFCCL.add_lss([ParameterRequired, AltName("site_IDNum")] string site_id, [ParameterRequired, AltName("location_name")] string loc_name, [ParameterDefaultValue("true")] bool is_active, [ParameterRequired, AltName("location_rank")] short loc_rank)
Parameters
Type | Name | Description
System.String | site_id |
System.String | loc_name |
System.Boolean | is_active |
System.Int16 | loc_rank |
Returns
Type | Description
System.Int16 |

IFCCL.assign_pr(String, String, String, String, String, Boolean)

Declaration
[AltName("assign_part_request")]
public short IFCCL.assign_pr([ParameterRequired, AltName("part_request_detail_IDNum")] string pr_id, string new_user, [AltName("wip_bin")] string wipbin_name, string assign_date, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | pr_id |
System.String | new_user |
System.String | wipbin_name |
System.String | assign_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCL.change_pr_status(String, String, String, String, String, Boolean)

Declaration
[AltName("change_part_request_status")]
public short IFCCL.change_pr_status([ParameterRequired, AltName("part_request_detail_IDNum")] string pr_id, [AltName("new_Status")] string new_status, string change_date, [AltName("notes")] string note_str, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | pr_id |
System.String | new_status |
System.String | change_date |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCL.close_pr(String, String, String, String, Boolean)

Declaration
[AltName("close_part_request")]
public short IFCCL.close_pr([ParameterRequired, AltName("part_request_detail_IDNum")] string pr_id, [AltName("new_Status")] string new_status, string close_date, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | pr_id |
System.String | new_status |
System.String | close_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCL.create_container(String, String, String, String)

Declaration
[SplitMethod("create_container")]
[SplitMethod("create_sub_container")]
[OutputProperty("ret_objid", "Container")]
[OutputProperty("ret_id_num", "Container")]
public short IFCCL.create_container([ParameterRequired, AltName("container_name")] string cont_name, [ParameterVoid("create_sub_container"), ParameterRequired(true, "create_container"), AltName("location_name")] string the_loc, [ParameterVoid("create_sub_container")] string bin_name, [ParameterVoid("create_container"), ParameterRequired(true, "create_sub_container"), AltName("parent_container_name")] string parent_cont)
Parameters
Type | Name | Description
System.String | cont_name |
System.String | the_loc |
System.String | bin_name |
System.String | parent_cont |
Returns
Type | Description
System.Int16 |

IFCCL.delete_alt_part(String, String, String, String, String, String)

Declaration
[AltName("delete_alternate_part")]
public short IFCCL.delete_alt_part([ParameterRequired, AltName("part_Number")] string part_num, [ParameterRequired, AltName("part_revision")] string rev, [ParameterRequired, AltName("part_domain")] string domain, [ParameterRequired, AltName("alternate_part_number")] string alt_part, [ParameterRequired, AltName("alternate_part_revision")] string alt_rev, [ParameterRequired, AltName("alternate_part_domain")] string alt_domain)
Parameters
Type | Name | Description
System.String | part_num |
System.String | rev |
System.String | domain |
System.String | alt_part |
System.String | alt_rev |
System.String | alt_domain |
Returns
Type | Description
System.Int16 |

IFCCL.delete_lss(String, String)

Declaration
[AltName("delete_location_servicing_site")]
[OutputProperty("ret_objid", "Objid of the Inventory Role record.")]
public short IFCCL.delete_lss([ParameterRequired, AltName("site_IDNum")] string site_id, [ParameterRequired, AltName("location_name")] string loc_name)
Parameters
Type | Name | Description
System.String | site_id |
System.String | loc_name |
Returns
Type | Description
System.Int16 |

IFCCL.dispatch_pr(String, String, String, String, Boolean)

Declaration
[AltName("dispatch_part_request")]
public short IFCCL.dispatch_pr([ParameterRequired, AltName("part_request_detail_IDNum")] string pr_id, [ParameterRequired, AltName("queue")] string queue_name, [AltName("dispatch_date")] string disp_date, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | pr_id |
System.String | queue_name |
System.String | disp_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCL.forward_pr(String, String, String, String, String, Boolean)

Declaration
[AltName("forward_part_request")]
public short IFCCL.forward_pr([ParameterRequired, AltName("part_request_detail_IDNum")] string pr_id, [ParameterRequired] string new_queue, string forward_date, [AltName("notes")] string note_str, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | pr_id |
System.String | new_queue |
System.String | forward_date |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCL.fulfill(String, Boolean, Int32, String, String, String, Boolean, String, String, String, Boolean, String, String, String, String, String, Boolean)

Declaration
[FacadeVoid]
[SplitMethod("fulfill_part_request")]
[SplitMethod("backorder_part_request")]
[FacadeProperty("From_Location", "FChoice.Toolkits.Clarify.Location", "FChoice.Toolkits.Clarify.Location.EMPTY", "if({0}.IsLocationNameDirty) {2}.InternalFromLocation = {0}.LocationName; if({0}.IsBinNameDirty) {2}.InternalFromBin = {0}.BinName;")]
[FacadeProperty("To_Location", "FChoice.Toolkits.Clarify.Location", "FChoice.Toolkits.Clarify.Location.EMPTY", "if({0}.IsLocationNameDirty) {2}.InternalToLocation = {0}.LocationName; if({0}.IsBinNameDirty) {2}.InternalToBin = {0}.BinName;")]
public short IFCCL.fulfill([ParameterRequired, AltName("part_request_detail_IDNum")] string dtl_num, [ParameterVoid, ParameterDefaultValue("false", "backorder_part_request"), ParameterDefaultValue("true", "fulfill_part_request")] bool is_fulfill, [ParameterRequired, AltName("quantity")] int quantity_num, [ParameterVoid, AltName("internal_from_location")] string from_loc, [ParameterVoid, AltName("internal_from_bin")] string from_bin, [ParameterVoid, AltName("internal_from_container")] string from_cont, [ParameterDefaultValue("true")] bool from_good, [ParameterVoid, AltName("internal_to_location")] string to_loc, [ParameterVoid, AltName("internal_to_bin")] string to_bin, [ParameterVoid, AltName("internal_to_container")] string to_cont, [ParameterDefaultValue("true")] bool to_good, [AltName("serial_number")] string serial_num, [AltName("new_Status")] string new_status, [ParameterRequired("backorder_part_request"), ParameterVoid("fulfill_part_request")] string expected_date, string user_name, [ParameterVoid("backorder_part_request")] string fulfill_date, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | dtl_num |
System.Boolean | is_fulfill |
System.Int32 | quantity_num |
System.String | from_loc |
System.String | from_bin |
System.String | from_cont |
System.Boolean | from_good |
System.String | to_loc |
System.String | to_bin |
System.String | to_cont |
System.Boolean | to_good |
System.String | serial_num |
System.String | new_status |
System.String | expected_date |
System.String | user_name |
System.String | fulfill_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCL.fulfill_no_trans(String, Boolean, Int32, String, String, String, Boolean, String, String, String, Boolean, String, String, String, String, String, Boolean)

Declaration
[FacadeVoid]
[SplitMethod("fulfill_part_request_no_transition")]
[SplitMethod("backorder_part_request_no_transition")]
[FacadeProperty("From_Location", "FChoice.Toolkits.Clarify.Location", "FChoice.Toolkits.Clarify.Location.EMPTY", "if({0}.IsLocationNameDirty) {2}.InternalFromLocation = {0}.LocationName; if({0}.IsBinNameDirty) {2}.InternalFromBin = {0}.BinName;")]
[FacadeProperty("To_Location", "FChoice.Toolkits.Clarify.Location", "FChoice.Toolkits.Clarify.Location.EMPTY", "if({0}.IsLocationNameDirty) {2}.InternalToLocation = {0}.LocationName; if({0}.IsBinNameDirty) {2}.InternalToBin = {0}.BinName;")]
public short IFCCL.fulfill_no_trans([ParameterRequired, AltName("part_request_detail_IDNum")] string dtl_num, [ParameterVoid, ParameterDefaultValue("true", "fulfill_part_request_no_transition"), ParameterDefaultValue("false", "backorder_part_request_no_transition")] bool is_fulfill, [ParameterRequired, AltName("quantity")] int quantity_num, [ParameterVoid, AltName("internal_from_location")] string from_loc, [ParameterVoid, AltName("internal_from_bin")] string from_bin, [ParameterVoid, AltName("internal_from_container")] string from_cont, [ParameterDefaultValue("true")] bool from_good, [ParameterVoid, AltName("internal_to_location")] string to_loc, [ParameterVoid, AltName("internal_to_bin")] string to_bin, [ParameterVoid, AltName("internal_to_container")] string to_cont, [ParameterDefaultValue("true")] bool to_good, [AltName("serial_number")] string serial_num, [AltName("new_Status")] string new_status, [ParameterRequired("backorder_part_request_no_transition"), ParameterVoid("fulfill_part_request_no_transition")] string expected_date, string user_name, [ParameterVoid("backorder_part_request_no_transition")] string fulfill_date, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | dtl_num |
System.Boolean | is_fulfill |
System.Int32 | quantity_num |
System.String | from_loc |
System.String | from_bin |
System.String | from_cont |
System.Boolean | from_good |
System.String | to_loc |
System.String | to_bin |
System.String | to_cont |
System.Boolean | to_good |
System.String | serial_num |
System.String | new_status |
System.String | expected_date |
System.String | user_name |
System.String | fulfill_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCL.get_alt_parts(String, String, String)

Declaration
[AltName("get_alternate_parts")]
[OutputProperty("ret_string", "AlternatePartList", "System.Int32[]", "new System.Int32[0]", "An array of Alternate Part objid's.", "Utility.ParseObjidPipeString({0})")]
public short IFCCL.get_alt_parts([ParameterRequired, AltName("part_Number")] string part_num, [ParameterRequired, AltName("part_domain")] string domain_name, [ParameterRequired, AltName("part_revision")] string mod_level)
Parameters
Type | Name | Description
System.String | part_num |
System.String | domain_name |
System.String | mod_level |
Returns
Type | Description
System.Int16 |

IFCCL.get_loc_serv_site(String)

Declaration
[AltName("get_locations_servicing_site")]
[OutputProperty("ret_string", "InventoryLocationObjidList", "System.Int32[]", "new System.Int32[0]", "An array of Inventory Location objid's.", "Utility.ParseObjidPipeString({0})")]
public short IFCCL.get_loc_serv_site([ParameterRequired, AltName("site_IDNum")] string site_id)
Parameters
Type | Name | Description
System.String | site_id |
Returns
Type | Description
System.Int16 |

IFCCL.impersonatorUserName

Declaration
public string IFCCL.impersonatorUserName { get; set; }
Returns
Type | Description
System.String |

IFCCL.Initialize(IFCApplication, IFCSession)

Declaration
[ToolkitVisible(false)]
public void IFCCL.Initialize(IFCApplication TheFCApplication, IFCSession TheFCSession)
Parameters
Type | Name | Description
IFCApplication | TheFCApplication |
IFCSession | TheFCSession |

IFCCL.make_pr_detail(String, String, String, String, String, String, Int32, Int32, String, String, String, String, String, String, Int16, String, String, String, String, Boolean, Int32, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[SplitMethod("create_part_request_detail", 2)]
[SplitMethod("create_part_request_detail_site_part", 2)]
[OutputProperty("ret_string", "DetailNumber", "System.String", "String.Empty", "Detail Number.")]
[OutputProperty("ret_objid", "DemandDetail")]
public short IFCCL.make_pr_detail([ParameterRequired, AltName("part_request_header_IDNum")] string hdr_num, [AltName("queue")] string queue_name, [ParameterRequired("create_part_request_detail", 0), ParameterRequired("create_part_request_detail", 1), AltName("part_Number")] string part_num, [ParameterRequired("create_part_request_detail", 0), ParameterRequired("create_part_request_detail", 1)] string domain_name, [ParameterRequired("create_part_request_detail", 0), ParameterRequired("create_part_request_detail", 1), AltName("part_revision")] string mod_level, [ParameterRequired(null, 0), AltName("serial_number")] string serial_no, [ParameterRequired(null, 1), AltName("quantity"), ParameterDefaultValue("1")] int quantity_num, [ParameterRequired("create_part_request_detail_site_part", 0), ParameterRequired("create_part_request_detail_site_part", 1), AltName("site_part_objid")] int sp_rec_objid, [ParameterRequired("create_part_request_detail_site_part", 0), ParameterRequired("create_part_request_detail_site_part", 1), AltName("site_part_type")] string sp_rec_recordtype, [AltName("detail_type")] string dtl_type, [AltName("priority")] string priority_str, [AltName("shipping_method")] string ship_via, string carrier_name, string user_name, [AltName("warranty_days")] short warranty, [AltName("notes")] string note_str, [AltName("status")] string status_str, string create_date, string due_date, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs, [AltName("contract_item_objid")] int contr_itm_objid, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | hdr_num |
System.String | queue_name |
System.String | part_num |
System.String | domain_name |
System.String | mod_level |
System.String | serial_no |
System.Int32 | quantity_num |
System.Int32 | sp_rec_objid |
System.String | sp_rec_recordtype |
System.String | dtl_type |
System.String | priority_str |
System.String | ship_via |
System.String | carrier_name |
System.String | user_name |
System.Int16 | warranty |
System.String | note_str |
System.String | status_str |
System.String | create_date |
System.String | due_date |
System.Boolean | gen_time_bombs |
System.Int32 | contr_itm_objid |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCL.make_pr_detail_list(String, String, String, String, String, String, Int32, Int32, String, String, String, String, String, String, Int16, String, String, String, String, Boolean, Int32, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[SplitMethod("create_part_request_detail_list", 4)]
[OutputProperty("ret_string", "DetailNumber", "System.String", "String.Empty", "Detail Number.")]
[OutputProperty("ret_objid", "DemandDetail")]
public short IFCCL.make_pr_detail_list([ParameterRequired(null, 0), ParameterRequired(null, 1), ParameterRequired(null, 2), ParameterRequired(null, 3), AltName("part_request_header_IDNum")] string hdr_num, [AltName("queue")] string queue_name, [ParameterRequired(null, 0), ParameterRequired(null, 2), AltName("part_Number")] string part_num, [ParameterRequired(null, 0), ParameterRequired(null, 2), AltName("part_domain")] string domain_name, [ParameterRequired(null, 0), ParameterRequired(null, 2), AltName("part_revision")] string mod_level, [ParameterRequired(null, 2), ParameterRequired(null, 3), AltName("serial_number")] string serial_no, [ParameterRequired(null, 0), ParameterRequired(null, 1), AltName("quantity"), ParameterDefaultValue("1")] int quantity_num, [ParameterRequired(null, 1), ParameterRequired(null, 3), AltName("site_part_objid")] int sp_rec_objid, [ParameterVoid, ParameterDefaultValue("\"site_part\"")] string sp_rec_recordtype, [AltName("detail_type")] string dtl_type, [AltName("priority")] string priority_str, [AltName("shipping_method")] string ship_via, string carrier_name, string user_name, [AltName("has_warranty"), AltType("System.Boolean", "Convert.ToInt16( {0} ? 1 : 0 )")] short warranty, [AltName("notes")] string note_str, [AltName("status")] string status_str, string create_date, string due_date, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs, [AltName("contract_item_objid")] int contr_itm_objid, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | hdr_num |
System.String | queue_name |
System.String | part_num |
System.String | domain_name |
System.String | mod_level |
System.String | serial_no |
System.Int32 | quantity_num |
System.Int32 | sp_rec_objid |
System.String | sp_rec_recordtype |
System.String | dtl_type |
System.String | priority_str |
System.String | ship_via |
System.String | carrier_name |
System.String | user_name |
System.Int16 | warranty |
System.String | note_str |
System.String | status_str |
System.String | create_date |
System.String | due_date |
System.Boolean | gen_time_bombs |
System.Int32 | contr_itm_objid |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCCL.make_pr_header(String, String, String, String, String, String, String, String, String, String, String, String, Int32, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[FacadeVoid]
[OutputProperty("ret_id_num", "Header")]
[OutputProperty("ret_objid", "Header")]
public short IFCCL.make_pr_header(string first_name, string last_name, string phone_num, string ship_site_id, string bill_site_id, string case_id, string pay_method, string pay_terms, string priority_str, string user_name, string note_str, string create_date, int contract_objid, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | first_name |
System.String | last_name |
System.String | phone_num |
System.String | ship_site_id |
System.String | bill_site_id |
System.String | case_id |
System.String | pay_method |
System.String | pay_terms |
System.String | priority_str |
System.String | user_name |
System.String | note_str |
System.String | create_date |
System.Int32 | contract_objid |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCL.make_pr_header_case_list(String, String, String, String, String, String, String, String, String, String, String, String, Int32, IFCList, IFCList, IFCList)

Declaration
[AltName("create_part_request_header_case")]
[OutputProperty("ret_id_num", "Header")]
[OutputProperty("ret_objid", "Header")]
public short IFCCL.make_pr_header_case_list([ParameterRequired, AltName("contact_First_Name")] string first_name, [ParameterRequired, AltName("contact_Last_Name")] string last_name, [ParameterRequired, AltName("contact_Phone")] string phone_num, [ParameterRequired, AltName("Ship_To_Site_ID_Num")] string ship_site_id, [AltName("bill_site_IDNum")] string bill_site_id, [ParameterRequired, AltName("Case_IDNum")] string case_id, [AltName("payment_method")] string pay_method, [AltName("payment_terms")] string pay_terms, [AltName("priority")] string priority_str, string user_name, [AltName("notes")] string note_str, string create_date, int contract_objid, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | first_name |
System.String | last_name |
System.String | phone_num |
System.String | ship_site_id |
System.String | bill_site_id |
System.String | case_id |
System.String | pay_method |
System.String | pay_terms |
System.String | priority_str |
System.String | user_name |
System.String | note_str |
System.String | create_date |
System.Int32 | contract_objid |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCCL.make_pr_header_list(String, String, String, String, String, String, String, String, String, String, String, String, Int32, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[AltName("create_part_request_header_list")]
[OutputProperty("ret_id_num", "Header")]
[OutputProperty("ret_objid", "Header")]
public short IFCCL.make_pr_header_list([ParameterRequired, AltName("contact_First_Name")] string first_name, [ParameterRequired, AltName("contact_Last_Name")] string last_name, [ParameterRequired, AltName("contact_Phone")] string phone_num, [ParameterRequired, AltName("Ship_To_Site_ID_Num")] string ship_site_id, [AltName("bill_site_IDNum")] string bill_site_id, [AltName("Case_IDNum")] string case_id, [AltName("payment_method")] string pay_method, [AltName("payment_terms")] string pay_terms, [AltName("priority")] string priority_str, string user_name, [AltName("notes")] string note_str, string create_date, int contract_objid, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | first_name |
System.String | last_name |
System.String | phone_num |
System.String | ship_site_id |
System.String | bill_site_id |
System.String | case_id |
System.String | pay_method |
System.String | pay_terms |
System.String | priority_str |
System.String | user_name |
System.String | note_str |
System.String | create_date |
System.Int32 | contract_objid |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCCL.make_pr_header_subcase_list(String, String, String, String, String, String, String, String, String, String, String, String, Int32, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[AltName("create_part_request_header_subcase")]
[OutputProperty("ret_id_num", "Header")]
[OutputProperty("ret_objid", "Header")]
public short IFCCL.make_pr_header_subcase_list([ParameterRequired, AltName("contact_First_Name")] string first_name, [ParameterRequired, AltName("contact_Last_Name")] string last_name, [ParameterRequired, AltName("contact_Phone")] string phone_num, [ParameterRequired, AltName("Ship_To_Site_ID_Num")] string ship_site_id, [AltName("bill_site_IDNum")] string bill_site_id, [ParameterRequired, AltName("Case_IDNum")] string case_id, [AltName("payment_method")] string pay_method, [AltName("payment_terms")] string pay_terms, [AltName("priority")] string priority_str, string user_name, [AltName("notes")] string note_str, string create_date, int contract_objid, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | first_name |
System.String | last_name |
System.String | phone_num |
System.String | ship_site_id |
System.String | bill_site_id |
System.String | case_id |
System.String | pay_method |
System.String | pay_terms |
System.String | priority_str |
System.String | user_name |
System.String | note_str |
System.String | create_date |
System.Int32 | contract_objid |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCCL.mod_part_stocking_lev(String, String, String, String, String, String, String, String, Int16, Int16, Int16, Int16, Boolean)

Declaration
[AltName("update_part_stocking_level")]
[OutputProperty("ret_objid", "Objid of the Part Authorization record.")]
[FacadeProperty("Current_Location", "FChoice.Toolkits.Clarify.Location", "FChoice.Toolkits.Clarify.Location.EMPTY", "if({0}.IsLocationNameDirty) {2}.LocationName = {0}.LocationName; if({0}.IsBinNameDirty) {2}.BinName = {0}.BinName;", true, false, "update_part_stocking_level", "0:0", 70011)]
public short IFCCL.mod_part_stocking_lev([ParameterVoid] string bin_name, [AltName("to_bin_name")] string to_bin, [ParameterVoid] string location_name, [ParameterRequired(true, "update_part_stocking_level", 0, 2), AltName("queue")] string queue_name, string to_queue, [ParameterRequired(true, "update_part_stocking_level", 0, 3)] string part_number, [ParameterRequired(true, "update_part_stocking_level", 0, 4), AltName("part_revision")] string mod_level, [ParameterRequired(true, "update_part_stocking_level", 0, 5), AltName("part_domain")] string domain_name, [AltType("System.Int16", "{1} ? {0} : (short)-1")] short part_minimum, [AltType("System.Int16", "{1} ? {0} : (short)-1")] short part_maximum, [AltType("System.Int16", "{1} ? {0} : (short)-1"), AltName("part_reorder_level")] short part_rol, [AltType("System.Int16", "{1} ? {0} : (short)-1"), AltName("part_reorder_quantity")] short part_roq, [ParameterDefaultValue("true")] bool is_active)
Parameters
Type | Name | Description
System.String | bin_name |
System.String | to_bin |
System.String | location_name |
System.String | queue_name |
System.String | to_queue |
System.String | part_number |
System.String | mod_level |
System.String | domain_name |
System.Int16 | part_minimum |
System.Int16 | part_maximum |
System.Int16 | part_rol |
System.Int16 | part_roq |
System.Boolean | is_active |
Returns
Type | Description
System.Int16 |

IFCCL.modify_gl_account(String, String, String, String, String, Boolean, Boolean, Boolean, String)

Declaration
[AltName("Update_GL_account")]
[OutputProperty("ret_objid", "Objid of the Inventory Location record.")]
public short IFCCL.modify_gl_account([ParameterRequired, AltName("current_name")] string old_name, string new_name, string account_type, [AltName("description")] string desc_str, [AltName("account_number")] string account_no, [ParameterDefaultValue("true"), AltName("is_expense_GL_account")] bool is_exp, [ParameterDefaultValue("true")] bool is_active, [ParameterDefaultValue("true")] bool is_company, [ParameterRequired, AltName("site_IDNum")] string site_id)
Parameters
Type | Name | Description
System.String | old_name |
System.String | new_name |
System.String | account_type |
System.String | desc_str |
System.String | account_no |
System.Boolean | is_exp |
System.Boolean | is_active |
System.Boolean | is_company |
System.String | site_id |
Returns
Type | Description
System.Int16 |

IFCCL.modify_inv_bin(String, String, String, Boolean)

Declaration
[AltName("update_inventory_bin")]
[OutputProperty("ret_objid", "Objid of the Inventory Bin record.")]
[FacadeProperty("Current_Location", "FChoice.Toolkits.Clarify.Location", "FChoice.Toolkits.Clarify.Location.EMPTY", "if({0}.IsLocationNameDirty) {2}.LocationName = {0}.LocationName; if({0}.IsBinNameDirty) {2}.OldName = {0}.BinName;", true, false, "update_inventory_bin", "0:0", 70009)]
public short IFCCL.modify_inv_bin([ParameterVoid] string old_name, [ParameterRequired(true, "update_inventory_bin", 0, 1), AltName("new_bin_name")] string new_name, [ParameterVoid, AltName("location_name")] string loc_name, [ParameterDefaultValue("true")] bool is_active)
Parameters
Type | Name | Description
System.String | old_name |
System.String | new_name |
System.String | loc_name |
System.Boolean | is_active |
Returns
Type | Description
System.Int16 |

IFCCL.modify_inv_location(String, String, String, String, String, String, Boolean, Boolean, String, String)

Declaration
[AltName("Update_inventory_location")]
[OutputProperty("ret_objid", "Objid of the Inventory Location record.")]
public short IFCCL.modify_inv_location([ParameterRequired, AltName("current_name")] string old_name, string new_name, string account_type, [AltName("description")] string desc_str, [AltName("reports_to_location")] string reports_to_loc, [AltName("capital_GL_account")] string cap_gl_acct, [ParameterDefaultValue("true")] bool is_active, [ParameterDefaultValue("true")] bool is_company, [AltName("site_IDNum")] string site_id, [AltType("FChoice.Toolkits.Clarify.PartAuthorizationLevel", "{1} ? Utility.GetPartAuthorizationLevel({0}): String.Empty"), ParameterDefaultValue("FChoice.Toolkits.Clarify.PartAuthorizationLevel.None"), AltName("part_authorization_level")] string trans_auth_str)
Parameters
Type | Name | Description
System.String | old_name |
System.String | new_name |
System.String | account_type |
System.String | desc_str |
System.String | reports_to_loc |
System.String | cap_gl_acct |
System.Boolean | is_active |
System.Boolean | is_company |
System.String | site_id |
System.String | trans_auth_str |
Returns
Type | Description
System.Int16 |

IFCCL.modify_lss(String, String, Int16)

Declaration
[AltName("update_location_servicing_site")]
[OutputProperty("ret_objid", "Objid of the Inventory Role record.")]
public short IFCCL.modify_lss([ParameterRequired, AltName("site_IDNum")] string site_id, [ParameterRequired, AltName("location_name")] string loc_name, [ParameterRequired, AltName("location_rank")] short loc_rank)
Parameters
Type | Name | Description
System.String | site_id |
System.String | loc_name |
System.Int16 | loc_rank |
Returns
Type | Description
System.Int16 |

IFCCL.move_pr(String, String)

Declaration
[AltName("move_part_request")]
public short IFCCL.move_pr([ParameterRequired, AltName("part_request_detail_IDNum")] string pr_id, [ParameterRequired, AltName("new_wip_bin")] string new_wipbin_name)
Parameters
Type | Name | Description
System.String | pr_id |
System.String | new_wipbin_name |
Returns
Type | Description
System.Int16 |

IFCCL.open_container(String)

Declaration
public short IFCCL.open_container([ParameterRequired, AltName("container_name")] string cont_name)
Parameters
Type | Name | Description
System.String | cont_name |
Returns
Type | Description
System.Int16 |

IFCCL.part_transfer(String, String, String, Int32, String, String, String, String, Boolean, String, String, String, Boolean, String, String, String, String, Boolean, Int16, String, String, String, String)

Declaration
[SplitMethod("part_transfer", 2)]
[OutputProperty("ret_objid", "Objid of the Part Transfer record.")]
[OutputProperty("ret_string", "StandardCost", "System.Decimal", "0M", "Part Transfer Standard Cost.", "(retVal == 0) ? decimal.Parse({0}) : 0M")]
[OutputProperty("ret_id_num", "TransactionIDNum", "System.String", "String.Empty", "Part Transfer Transaction Identifier.")]
[FacadeProperty("FromLocation", "FChoice.Toolkits.Clarify.Location", "FChoice.Toolkits.Clarify.Location.EMPTY", "if({0}.IsLocationNameDirty) {2}.InternalFromLocation = {0}.LocationName; if({0}.IsBinNameDirty) {2}.InternalFromBin = {0}.BinName; if({0}.IsContainerIDNumDirty) {2}.InternalFromContainer = {0}.ContainerIDNum;", true, false, "part_transfer", "0:4,1:4", 70014)]
[FacadeProperty("ToLocation", "FChoice.Toolkits.Clarify.Location", "FChoice.Toolkits.Clarify.Location.EMPTY", "if({0}.IsLocationNameDirty) {2}.InternalToLocation = {0}.LocationName; if({0}.IsBinNameDirty) {2}.InternalToBin = {0}.BinName; if({0}.IsContainerIDNumDirty) {2}.InternalToContainer = {0}.ContainerIDNum;", true, false, "part_transfer", "0:5,1:5", 70015)]
public short IFCCL.part_transfer([ParameterRequired(true, null, 0, 0), ParameterRequired(true, null, 1, 0), AltName("part_Number")] string part_num, [ParameterRequired(true, null, 0, 1), ParameterRequired(true, null, 1, 1), AltName("part_revision")] string mod_level, [ParameterRequired(true, null, 0, 2), ParameterRequired(true, null, 1, 2), AltName("part_domain")] string domain_name, [ParameterRequired(true, null, 0, 3), AltName("quantity"), ParameterDefaultValue("1")] int quantity_num, [ParameterRequired(true, null, 1, 3), AltName("serial_number")] string serial_num, [ParameterVoid, AltName("internal_from_location")] string from_loc, [ParameterVoid, AltName("internal_from_bin")] string from_bin, [ParameterVoid, AltName("internal_from_container")] string from_cont, [ParameterDefaultValue("true")] bool from_good, [ParameterVoid, AltName("internal_to_location")] string to_loc, [ParameterVoid, AltName("internal_to_bin")] string to_bin, [ParameterVoid, AltName("internal_to_container")] string to_cont, [ParameterDefaultValue("true")] bool to_good, string user_name, [AltName("transfer_date")] string trans_date, [AltName("reference_IDNum")] string ref_id, [AltName("notes")] string note_str, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs, [ParameterVoid, ParameterDefaultValue("0")] short fifo_flag, [ParameterVoid, AltType("System.Double", "{1} ? {0}.ToString() : string.Empty")] string update_cost, [ParameterVoid] string update_source, [ParameterVoid] string trans_id, [ParameterVoid] string std_cost)
Parameters
Type | Name | Description
System.String | part_num |
System.String | mod_level |
System.String | domain_name |
System.Int32 | quantity_num |
System.String | serial_num |
System.String | from_loc |
System.String | from_bin |
System.String | from_cont |
System.Boolean | from_good |
System.String | to_loc |
System.String | to_bin |
System.String | to_cont |
System.Boolean | to_good |
System.String | user_name |
System.String | trans_date |
System.String | ref_id |
System.String | note_str |
System.Boolean | gen_time_bombs |
System.Int16 | fifo_flag |
System.String | update_cost |
System.String | update_source |
System.String | trans_id |
System.String | std_cost |
Returns
Type | Description
System.Int16 |

IFCCL.pick(String, String, Boolean, String, String, String, Boolean)

Declaration
[FacadeVoid]
[OutputProperty("ret_num", "TotalPicked", "System.Int32", "0", "the total number of parts picked.")]
public short IFCCL.pick([ParameterRequired, AltName("part_request_detail_IDNum")] string dtl_num, [AltName("locations"), AltType("FChoice.Toolkits.Clarify.LocationCollection", "({0}.IsDirty) ? {0}.ToLegacyString() : \"\""), ParameterDefaultValue("new FChoice.Toolkits.Clarify.LocationCollection()")] string locs_str, [ParameterDefaultValue("true")] bool use_good, string user_name, string pick_date, [AltName("new_Status")] string new_status, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | locs_str |
System.Boolean | use_good |
System.String | user_name |
System.String | pick_date |
System.String | new_status |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCL.pick_no_trans(String, String, Boolean, String, String, String, Boolean)

Declaration
[FacadeVoid]
[AltName("pick_no_transition")]
[OutputProperty("ret_num", "TotalPicked", "System.Int32", "0", "the total number of parts picked.")]
public short IFCCL.pick_no_trans([ParameterRequired, AltName("part_request_detail_IDNum")] string dtl_num, [AltName("locations"), AltType("FChoice.Toolkits.Clarify.LocationCollection", "({0}.IsDirty) ? {0}.ToLegacyString() : \"\""), ParameterDefaultValue("new FChoice.Toolkits.Clarify.LocationCollection()")] string locs_str, [ParameterDefaultValue("true")] bool use_good, string user_name, string pick_date, [AltName("new_Status")] string new_status, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | locs_str |
System.Boolean | use_good |
System.String | user_name |
System.String | pick_date |
System.String | new_status |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCL.pick_sn(String, String, Boolean, String, String, String, String, Boolean)

Declaration
[FacadeVoid]
[AltName("pick_serial_number")]
[OutputProperty("ret_num", "TotalPicked", "System.Int32", "0", "the total number of parts picked.")]
public short IFCCL.pick_sn([ParameterRequired(true, "pick_serial_number", 0, 0), AltName("part_request_detail_IDNum")] string dtl_num, [AltName("locations"), AltType("FChoice.Toolkits.Clarify.LocationCollection", "({0}.IsDirty) ? {0}.ToLegacyString() : \"\""), ParameterDefaultValue("new FChoice.Toolkits.Clarify.LocationCollection()")] string locs_str, [ParameterDefaultValue("true")] bool use_good, string user_name, string pick_date, [AltName("new_Status")] string new_status, [ParameterDefaultValue("new string[0]"), ParameterRequired(true, "pick_serial_number", 0, 1, true), AltName("serial_numbers"), AltType("System.String[]", "System.String.Join(\",\", {0})")] string serial_no, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | locs_str |
System.Boolean | use_good |
System.String | user_name |
System.String | pick_date |
System.String | new_status |
System.String | serial_no |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCL.pick_sn_no_trans(String, String, Boolean, String, String, String, String, Boolean)

Declaration
[FacadeVoid]
[AltName("pick_serial_number_no_transition")]
[OutputProperty("ret_num", "TotalPicked", "System.Int32", "0", "the total number of parts picked.")]
public short IFCCL.pick_sn_no_trans([ParameterRequired(true, "pick_serial_number_no_transition", 0, 0), AltName("part_request_detail_IDNum")] string dtl_num, [AltName("locations"), AltType("FChoice.Toolkits.Clarify.LocationCollection", "({0}.IsDirty) ? {0}.ToLegacyString() : \"\""), ParameterDefaultValue("new FChoice.Toolkits.Clarify.LocationCollection()")] string locs_str, [ParameterDefaultValue("true")] bool use_good, string user_name, string pick_date, [AltName("new_Status")] string new_status, [ParameterDefaultValue("new string[0]"), ParameterRequired(true, "pick_serial_number_no_transition", 0, 1, true), AltName("serial_numbers"), AltType("System.String[]", "System.String.Join(\",\", {0})")] string serial_no, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | locs_str |
System.Boolean | use_good |
System.String | user_name |
System.String | pick_date |
System.String | new_status |
System.String | serial_no |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCL.receive_pr(String, String, String, String, Boolean, String, String, String, Boolean, Int32, String, String, String, String, Boolean, Boolean, Boolean, String, String, Boolean, Boolean)

Declaration
[FacadeVoid]
public short IFCCL.receive_pr(string pr_num, string from_loc, string from_bin, string from_cont, bool from_good, string to_loc, string to_bin, string to_cont, bool to_good, int quantity_num, string serial_num, string status_str, string carrier_name, string waybill_name, bool poss_damage, bool not_prop_pack, bool route_to_test, string user_name, string receive_date, bool auto_close, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | pr_num |
System.String | from_loc |
System.String | from_bin |
System.String | from_cont |
System.Boolean | from_good |
System.String | to_loc |
System.String | to_bin |
System.String | to_cont |
System.Boolean | to_good |
System.Int32 | quantity_num |
System.String | serial_num |
System.String | status_str |
System.String | carrier_name |
System.String | waybill_name |
System.Boolean | poss_damage |
System.Boolean | not_prop_pack |
System.Boolean | route_to_test |
System.String | user_name |
System.String | receive_date |
System.Boolean | auto_close |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCL.receive_pr_no_trans(String, String, String, String, Boolean, String, String, String, Boolean, Int32, String, String, String, String, Boolean, Boolean, Boolean, String, String, Boolean, Boolean)

Declaration
[FacadeVoid]
public short IFCCL.receive_pr_no_trans(string pr_num, string from_loc, string from_bin, string from_cont, bool from_good, string to_loc, string to_bin, string to_cont, bool to_good, int quantity_num, string serial_num, string status_str, string carrier_name, string waybill_name, bool poss_damage, bool not_prop_pack, bool route_to_test, string user_name, string receive_date, bool auto_close, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | pr_num |
System.String | from_loc |
System.String | from_bin |
System.String | from_cont |
System.Boolean | from_good |
System.String | to_loc |
System.String | to_bin |
System.String | to_cont |
System.Boolean | to_good |
System.Int32 | quantity_num |
System.String | serial_num |
System.String | status_str |
System.String | carrier_name |
System.String | waybill_name |
System.Boolean | poss_damage |
System.Boolean | not_prop_pack |
System.Boolean | route_to_test |
System.String | user_name |
System.String | receive_date |
System.Boolean | auto_close |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCL.reject_pr(String, String, String, String, String, Boolean)

Declaration
[AltName("reject_part_request")]
public short IFCCL.reject_pr([ParameterRequired, AltName("part_request_detail_IDNum")] string pr_id, string reject_date, [AltName("wip_bin")] string wipbin_name, [AltName("notes")] string note_str, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | pr_id |
System.String | reject_date |
System.String | wipbin_name |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCL.reopen_pr(String, String, String, String, String, Boolean)

Declaration
[AltName("reopen_part_request")]
public short IFCCL.reopen_pr([ParameterRequired, AltName("part_request_detail_IDNum")] string pr_id, [AltName("new_Status")] string new_status, [AltName("wip_bin")] string wipbin_name, string reopen_date, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | pr_id |
System.String | new_status |
System.String | wipbin_name |
System.String | reopen_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCL.ret_id_num

Declaration
public string IFCCL.ret_id_num { get; }
Returns
Type | Description
System.String |

IFCCL.ret_num

Declaration
public short IFCCL.ret_num { get; }
Returns
Type | Description
System.Int16 |

IFCCL.ret_objid

Declaration
public int IFCCL.ret_objid { get; }
Returns
Type | Description
System.Int32 |

IFCCL.ret_string

Declaration
public string IFCCL.ret_string { get; }
Returns
Type | Description
System.String |

IToolkit.ReturnIDNum

Declaration
public string IToolkit.ReturnIDNum { get; }
Returns
Type | Description
System.String |

IToolkit.ReturnObjid

Declaration
public int IToolkit.ReturnObjid { get; }
Returns
Type | Description
System.Int32 |

IFCCL.seal_container(String)

Declaration
public short IFCCL.seal_container([ParameterRequired, AltName("container_name")] string cont_name)
Parameters
Type | Name | Description
System.String | cont_name |
Returns
Type | Description
System.Int16 |

IFCCL.set_part_stocking_lev(String, String, String, String, String, String, Int16, Int16, Int16, Int16, Boolean)

Declaration
[AltName("set_part_stocking_level")]
[OutputProperty("ret_objid", "Objid of the Part Authorization record.")]
[FacadeProperty("Location", "FChoice.Toolkits.Clarify.Location", "FChoice.Toolkits.Clarify.Location.EMPTY", "if({0}.IsLocationNameDirty){2}.LocationName = {0}.LocationName; if({0}.IsBinNameDirty){2}.BinName = {0}.BinName;", true, false, "set_part_stocking_level", "0:0", 70010)]
public short IFCCL.set_part_stocking_lev([ParameterVoid] string bin_name, [ParameterVoid] string location_name, [ParameterRequired(true, "set_part_stocking_level", 0, 1), AltName("queue")] string queue_name, [ParameterRequired(true, "set_part_stocking_level", 0, 2)] string part_number, [ParameterRequired(true, "set_part_stocking_level", 0, 3), AltName("part_revision")] string mod_level, [ParameterRequired(true, "set_part_stocking_level", 0, 4), AltName("part_domain")] string domain_name, [ParameterRequired(true, "set_part_stocking_level", 0, 5)] short part_minimum, [ParameterRequired(true, "set_part_stocking_level", 0, 6)] short part_maximum, [ParameterRequired(true, "set_part_stocking_level", 0, 7), AltName("part_reorder_level")] short part_rol, [ParameterRequired(true, "set_part_stocking_level", 0, 8), AltName("part_reorder_quantity")] short part_roq, [ParameterDefaultValue("true")] bool is_active)
Parameters
Type | Name | Description
System.String | bin_name |
System.String | location_name |
System.String | queue_name |
System.String | part_number |
System.String | mod_level |
System.String | domain_name |
System.Int16 | part_minimum |
System.Int16 | part_maximum |
System.Int16 | part_rol |
System.Int16 | part_roq |
System.Boolean | is_active |
Returns
Type | Description
System.Int16 |

IFCCL.ship(String, String, String, String, String, String, String, String, String, String, String, String, Int32, Double, String, String, String, String, Boolean)

Declaration
[OutputProperty("ret_objid", "Objid of the parts shipment record.")]
public short IFCCL.ship([ParameterRequired, AltName("part_request_detail_IDNum")] string dtl_num, [AltType("System.String", "{1} ? {0} : \"fill_from_db\"")] string site_name, [AltType("System.String", "{1} ? {0} : \"fill_from_db\"")] string address_1, [AltType("System.String", "{1} ? {0} : \"fill_from_db\"")] string address_2, [AltName("city"), AltType("System.String", "{1} ? {0} : \"fill_from_db\"")] string city_name, [AltName("state"), AltType("System.String", "{1} ? {0} : \"fill_from_db\"")] string state_name, [AltType("System.String", "{1} ? {0} : \"fill_from_db\"")] string zip_code, [AltName("country"), AltType("System.String", "{1} ? {0} : \"fill_from_db\"")] string country_name, [AltName("contact_First_Name"), AltType("System.String", "{1} ? {0} : \"fill_from_db\"")] string f_name, [AltName("contact_Last_Name"), AltType("System.String", "{1} ? {0} : \"fill_from_db\"")] string l_name, string waybill_name, [AltName("packing_list")] string pack_list, int piece_count, double total_weight, [AltName("status")] string status_str, string ship_date, string user_name, string carrier_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | site_name |
System.String | address_1 |
System.String | address_2 |
System.String | city_name |
System.String | state_name |
System.String | zip_code |
System.String | country_name |
System.String | f_name |
System.String | l_name |
System.String | waybill_name |
System.String | pack_list |
System.Int32 | piece_count |
System.Double | total_weight |
System.String | status_str |
System.String | ship_date |
System.String | user_name |
System.String | carrier_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCL.unpick(String, String, String, String, Boolean, String, String, Boolean)

Declaration
[FacadeVoid]
[FacadeProperty("Location", "FChoice.Toolkits.Clarify.Location", "FChoice.Toolkits.Clarify.Location.EMPTY", "if({0}.IsLocationNameDirty) {2}.LocationName = {0}.LocationName; if({0}.IsBinNameDirty) {2}.BinName = {0}.BinName; if({0}.IsContainerIDNumDirty) {2}.ContainerIDNum = {0}.ContainerIDNum;", true, false, "unpick", "0:1")]
public short IFCCL.unpick([ParameterRequired(true, "unpick", 0, 0), AltName("part_request_detail_IDNum")] string dtl_num, [ParameterVoid, AltName("location_name")] string loc_name, [ParameterVoid] string bin_name, [AltName("Container_ID_Num")] string cont_num, [ParameterDefaultValue("true")] bool use_good, string user_name, string unpick_date, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | loc_name |
System.String | bin_name |
System.String | cont_num |
System.Boolean | use_good |
System.String | user_name |
System.String | unpick_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCL.unpick_no_trans(String, String, String, String, Boolean, String, String, Boolean)

Declaration
[FacadeVoid]
[AltName("unpick_no_transition")]
[FacadeProperty("Location", "FChoice.Toolkits.Clarify.Location", "FChoice.Toolkits.Clarify.Location.EMPTY", "if({0}.IsLocationNameDirty) {2}.LocationName = {0}.LocationName; if({0}.IsBinNameDirty) {2}.BinName = {0}.BinName; if({0}.IsContainerIDNumDirty) {2}.ContainerIDNum = {0}.ContainerIDNum;", true, false, "unpick_no_transition", "0:1")]
public short IFCCL.unpick_no_trans([ParameterRequired(true, "unpick_no_transition", 0, 0), AltName("part_request_detail_IDNum")] string dtl_num, [ParameterVoid, AltName("location_name")] string loc_name, [ParameterVoid] string bin_name, [AltName("Container_ID_Num")] string cont_num, [ParameterDefaultValue("true")] bool use_good, string user_name, string unpick_date, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | loc_name |
System.String | bin_name |
System.String | cont_num |
System.Boolean | use_good |
System.String | user_name |
System.String | unpick_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCL.unpick_sn(String, String, String, String, Boolean, String, String, String, Boolean)

Declaration
[FacadeVoid]
[AltName("unpick_serial_number")]
[FacadeProperty("Location", "FChoice.Toolkits.Clarify.Location", "FChoice.Toolkits.Clarify.Location.EMPTY", "if({0}.IsLocationNameDirty) {2}.LocationName = {0}.LocationName; if({0}.IsBinNameDirty) {2}.BinName = {0}.BinName; if({0}.IsContainerIDNumDirty) {2}.ContainerIDNum = {0}.ContainerIDNum;", true, false, "unpick_serial_number", "0:1")]
public short IFCCL.unpick_sn([ParameterRequired(true, "unpick_serial_number", 0, 0), AltName("part_request_detail_IDNum")] string dtl_num, [ParameterVoid, AltName("location_name")] string loc_name, [ParameterVoid] string bin_name, [ParameterVoid, AltName("Container_ID_Num")] string cont_num, [ParameterDefaultValue("true")] bool use_good, string user_name, string unpick_date, [ParameterDefaultValue("new string[0]"), ParameterRequired(true, "unpick_serial_number", 0, 2, true), AltName("serial_numbers"), AltType("System.String[]", "System.String.Join(\",\", {0})")] string serial_no, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | loc_name |
System.String | bin_name |
System.String | cont_num |
System.Boolean | use_good |
System.String | user_name |
System.String | unpick_date |
System.String | serial_no |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCL.unpick_sn_no_trans(String, String, String, String, Boolean, String, String, String, Boolean)

Declaration
[FacadeVoid]
[AltName("unpick_serial_number_no_transition")]
[FacadeProperty("Location", "FChoice.Toolkits.Clarify.Location", "FChoice.Toolkits.Clarify.Location.EMPTY", "if({0}.IsLocationNameDirty) {2}.LocationName = {0}.LocationName; if({0}.IsBinNameDirty) {2}.BinName = {0}.BinName; if({0}.IsContainerIDNumDirty) {2}.ContainerIDNum = {0}.ContainerIDNum;", true, false, "unpick_serial_number_no_transition", "0:1")]
public short IFCCL.unpick_sn_no_trans([ParameterRequired(true, "unpick_serial_number_no_transition", 0, 0), AltName("part_request_detail_IDNum")] string dtl_num, [ParameterVoid, AltName("location_name")] string loc_name, [ParameterVoid] string bin_name, [AltName("Container_ID_Num")] string cont_num, [ParameterDefaultValue("true")] bool use_good, string user_name, string unpick_date, [ParameterDefaultValue("new string[0]"), ParameterRequired(true, "unpick_serial_number_no_transition", 0, 2, true), AltName("serial_numbers"), AltType("System.String[]", "System.String.Join(\",\", {0})")] string serial_no, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | loc_name |
System.String | bin_name |
System.String | cont_num |
System.Boolean | use_good |
System.String | user_name |
System.String | unpick_date |
System.String | serial_no |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCL.update_pr_detail(String, String, String, String, String, Int32, Int32, String, String, String, String, Int16, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[FacadeVoid]
[OutputProperty("ret_id_num", "DemandDetail")]
[OutputProperty("ret_objid", "DemandDetail")]
public short IFCCL.update_pr_detail(string dtl_num, string part_num, string domain_name, string mod_level, string serial_no, int quantity_num, int sp_objid, string dtl_type, string priority_str, string ship_via, string carrier_name, short warranty, string note_str, string status_str, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | part_num |
System.String | domain_name |
System.String | mod_level |
System.String | serial_no |
System.Int32 | quantity_num |
System.Int32 | sp_objid |
System.String | dtl_type |
System.String | priority_str |
System.String | ship_via |
System.String | carrier_name |
System.Int16 | warranty |
System.String | note_str |
System.String | status_str |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCL.update_pr_detail_list(String, String, String, String, String, Int32, Int32, String, String, String, String, Int16, String, String, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[SplitMethod("update_part_request_detail_list")]
[OutputProperty("ret_id_num", "DemandDetail")]
[OutputProperty("ret_objid", "DemandDetail")]
public short IFCCL.update_pr_detail_list([ParameterRequired, AltName("part_request_detail_IDNum")] string dtl_num, [AltName("part_Number")] string part_num, [AltName("part_domain")] string domain_name, [AltName("part_revision")] string mod_level, [AltName("serial_number")] string serial_no, [AltName("quantity")] int quantity_num, [AltName("site_part_objid")] int sp_objid, [AltName("detail_type")] string dtl_type, [AltName("priority")] string priority_str, [AltName("shipping_method")] string ship_via, string carrier_name, [AltName("has_warranty"), AltType("System.Boolean", "Convert.ToInt16( {0} ? 1 : 0 )")] short warranty, [AltName("notes"), AltType("System.String", "({1} && {0} == String.Empty) ? \"CLEAR\" : {0}")] string note_str, [AltName("status")] string status_str, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | part_num |
System.String | domain_name |
System.String | mod_level |
System.String | serial_no |
System.Int32 | quantity_num |
System.Int32 | sp_objid |
System.String | dtl_type |
System.String | priority_str |
System.String | ship_via |
System.String | carrier_name |
System.Int16 | warranty |
System.String | note_str |
System.String | status_str |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCCL.update_pr_header(String, String, String, String, String, String, String, String, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[AltName("update_part_request_header")]
public short IFCCL.update_pr_header([ParameterRequired, AltName("part_request_header_IDNum")] string hdr_num, [AltName("contact_First_Name")] string first_name, [AltName("contact_Last_Name")] string last_name, [AltName("contact_Phone")] string phone_num, [AltName("Ship_To_Site_ID_Num")] string ship_site_id, [AltName("bill_site_IDNum")] string bill_site_id, [AltName("Case_IDNum")] string case_id, [AltName("payment_method")] string pay_method, [AltName("payment_terms")] string pay_terms, [AltName("priority")] string priority_str, [AltName("notes")] string note_str, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | hdr_num |
System.String | first_name |
System.String | last_name |
System.String | phone_num |
System.String | ship_site_id |
System.String | bill_site_id |
System.String | case_id |
System.String | pay_method |
System.String | pay_terms |
System.String | priority_str |
System.String | note_str |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCL.update_pr_header_list(String, String, String, String, String, String, String, String, String, String, String, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[AltName("update_part_request_header_list")]
public short IFCCL.update_pr_header_list([ParameterRequired, AltName("part_request_header_IDNum")] string hdr_num, [AltName("contact_First_Name")] string first_name, [AltName("contact_Last_Name")] string last_name, [AltName("contact_Phone")] string phone_num, [AltName("Ship_To_Site_ID_Num")] string ship_site_id, [AltName("bill_site_IDNum")] string bill_site_id, [AltName("Case_IDNum"), AltType("System.String", "({1} && {0} == String.Empty) ? \"CLEAR\" : {0}")] string case_id, [AltName("payment_method")] string pay_method, [AltName("payment_terms")] string pay_terms, [AltName("priority")] string priority_str, [AltName("notes"), AltType("System.String", "({1} && {0} == String.Empty) ? \"CLEAR\" : {0}")] string note_str, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | hdr_num |
System.String | first_name |
System.String | last_name |
System.String | phone_num |
System.String | ship_site_id |
System.String | bill_site_id |
System.String | case_id |
System.String | pay_method |
System.String | pay_terms |
System.String | priority_str |
System.String | note_str |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCCL.yank_pr(String, String, String, String, Boolean)

Declaration
[AltName("yank_part_request")]
public short IFCCL.yank_pr([ParameterRequired, AltName("part_request_detail_IDNum")] string pr_id, [AltName("wip_bin")] string wipbin_name, string yank_date, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | pr_id |
System.String | wipbin_name |
System.String | yank_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

Implements

IFCCL
IToolkit


Class FCCLBase | fcSDK Documentation

Class FCCLBase

Inheritance
System.Object
FCCLBase
FCCL
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Compatibility.Toolkits
Assembly: FChoice.Foundation.Clarify.Compatibility.Toolkits.dll
Syntax
[ComVisible(false)]
public abstract class FCCLBase

Constructors

FCCLBase()

Declaration
protected FCCLBase()

FCCLBase(IFCApplication, IFCSession)

Declaration
protected FCCLBase(IFCApplication FCApp, IFCSession FCSess)
Parameters
Type | Name | Description
IFCApplication | FCApp |
IFCSession | FCSess |

Fields

pick_serial_no

Declaration
protected string pick_serial_no
Field Value
Type | Description
System.String |

Properties

_impersonatorUserName

Declaration
protected string _impersonatorUserName { get; set; }
Property Value
Type | Description
System.String |

_object_name

Declaration
protected string _object_name { get; set; }
Property Value
Type | Description
System.String |

_ret_id_num

Declaration
protected string _ret_id_num { get; set; }
Property Value
Type | Description
System.String |

_ret_num

Declaration
protected short _ret_num { get; set; }
Property Value
Type | Description
System.Int16 |

_ret_objid

Declaration
protected int _ret_objid { get; set; }
Property Value
Type | Description
System.Int32 |

_ret_string

Declaration
protected string _ret_string { get; set; }
Property Value
Type | Description
System.String |

Methods

_accept_pr(String, String, String, String, Boolean)

Declaration
protected short _accept_pr(string pr_id, string accept_date, string wipbin_name, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | pr_id |
System.String | accept_date |
System.String | wipbin_name |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_add_alt_part(String, String, String, String, String, String, Boolean)

Declaration
protected short _add_alt_part(string part_num, string rev, string domain, string alt_part, string alt_rev, string alt_domain, bool is_reciprocal)
Parameters
Type | Name | Description
System.String | part_num |
System.String | rev |
System.String | domain |
System.String | alt_part |
System.String | alt_rev |
System.String | alt_domain |
System.Boolean | is_reciprocal |
Returns
Type | Description
System.Int16 |

_add_gl_account(String, String, String, String, Boolean, Boolean, Boolean, String)

Declaration
protected short _add_gl_account(string acct_name, string account_type, string desc_str, string account_no, bool is_exp, bool is_active, bool is_company, string site_id)
Parameters
Type | Name | Description
System.String | acct_name |
System.String | account_type |
System.String | desc_str |
System.String | account_no |
System.Boolean | is_exp |
System.Boolean | is_active |
System.Boolean | is_company |
System.String | site_id |
Returns
Type | Description
System.Int16 |

_add_inv_bin(String, String, Boolean)

Declaration
protected short _add_inv_bin(string bin_name, string loc_name, bool is_active)
Parameters
Type | Name | Description
System.String | bin_name |
System.String | loc_name |
System.Boolean | is_active |
Returns
Type | Description
System.Int16 |

_add_inv_location(String, String, String, String, String, Boolean, Boolean, String, String)

Declaration
protected short _add_inv_location(string loc_name, string account_type, string desc_str, string reports_to_loc, string cap_gl_acct, bool is_active, bool is_company, string site_id, string trans_auth_str)
Parameters
Type | Name | Description
System.String | loc_name |
System.String | account_type |
System.String | desc_str |
System.String | reports_to_loc |
System.String | cap_gl_acct |
System.Boolean | is_active |
System.Boolean | is_company |
System.String | site_id |
System.String | trans_auth_str |
Returns
Type | Description
System.Int16 |

_add_lss(String, String, Boolean, Int16)

Declaration
protected short _add_lss(string site_id, string loc_name, bool is_active, short loc_rank)
Parameters
Type | Name | Description
System.String | site_id |
System.String | loc_name |
System.Boolean | is_active |
System.Int16 | loc_rank |
Returns
Type | Description
System.Int16 |

_assign_pr(String, String, String, String, String, Boolean)

Declaration
protected short _assign_pr(string pr_id, string new_user, string wipbin_name, string assign_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | pr_id |
System.String | new_user |
System.String | wipbin_name |
System.String | assign_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_change_pr_status(String, String, String, String, String, Boolean)

Declaration
protected short _change_pr_status(string pr_id, string new_status, string change_date, string note_str, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | pr_id |
System.String | new_status |
System.String | change_date |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_close_pr(String, String, String, String, Boolean)

Declaration
protected short _close_pr(string pr_id, string new_status, string close_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | pr_id |
System.String | new_status |
System.String | close_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_create_container(String, String, String, String)

Declaration
protected short _create_container(string cont_name, string the_loc, string bin_name, string parent_cont)
Parameters
Type | Name | Description
System.String | cont_name |
System.String | the_loc |
System.String | bin_name |
System.String | parent_cont |
Returns
Type | Description
System.Int16 |

_delete_alt_part(String, String, String, String, String, String)

Declaration
protected short _delete_alt_part(string part_num, string rev, string domain, string alt_part, string alt_rev, string alt_domain)
Parameters
Type | Name | Description
System.String | part_num |
System.String | rev |
System.String | domain |
System.String | alt_part |
System.String | alt_rev |
System.String | alt_domain |
Returns
Type | Description
System.Int16 |

_delete_lss(String, String)

Declaration
protected short _delete_lss(string site_id, string loc_name)
Parameters
Type | Name | Description
System.String | site_id |
System.String | loc_name |
Returns
Type | Description
System.Int16 |

_dispatch_pr(String, String, String, String, Boolean)

Declaration
protected short _dispatch_pr(string pr_id, string queue_name, string disp_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | pr_id |
System.String | queue_name |
System.String | disp_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_forward_pr(String, String, String, String, String, Boolean)

Declaration
protected short _forward_pr(string pr_id, string new_queue, string forward_date, string note_str, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | pr_id |
System.String | new_queue |
System.String | forward_date |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_fulfill(String, Boolean, Int32, String, String, String, Boolean, String, String, String, Boolean, String, String, String, String, String, Boolean)

Declaration
protected short _fulfill(string dtl_num, bool is_fulfill, int quantity_num, string from_loc, string from_bin, string from_cont, bool from_good, string to_loc, string to_bin, string to_cont, bool to_good, string serial_num, string new_status, string expected_date, string user_name, string fulfill_date, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | dtl_num |
System.Boolean | is_fulfill |
System.Int32 | quantity_num |
System.String | from_loc |
System.String | from_bin |
System.String | from_cont |
System.Boolean | from_good |
System.String | to_loc |
System.String | to_bin |
System.String | to_cont |
System.Boolean | to_good |
System.String | serial_num |
System.String | new_status |
System.String | expected_date |
System.String | user_name |
System.String | fulfill_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_fulfill_internal(String, Boolean, Int32, String, String, String, Boolean, String, String, String, Boolean, String, String, String, String, String, Boolean, Boolean)

Declaration
protected short _fulfill_internal(string dtl_num, bool is_fulfill, int quantity_num, string from_loc, string from_bin, string from_cont, bool from_good, string to_loc, string to_bin, string to_cont, bool to_good, string serial_num, string new_status, string expected_date, string user_name, string fulfill_date, bool gen_time_bombs, bool do_cond_change)
Parameters
Type | Name | Description
System.String | dtl_num |
System.Boolean | is_fulfill |
System.Int32 | quantity_num |
System.String | from_loc |
System.String | from_bin |
System.String | from_cont |
System.Boolean | from_good |
System.String | to_loc |
System.String | to_bin |
System.String | to_cont |
System.Boolean | to_good |
System.String | serial_num |
System.String | new_status |
System.String | expected_date |
System.String | user_name |
System.String | fulfill_date |
System.Boolean | gen_time_bombs |
System.Boolean | do_cond_change |
Returns
Type | Description
System.Int16 |

_fulfill_no_trans(String, Boolean, Int32, String, String, String, Boolean, String, String, String, Boolean, String, String, String, String, String, Boolean)

Declaration
protected short _fulfill_no_trans(string dtl_num, bool is_fulfill, int quantity_num, string from_loc, string from_bin, string from_cont, bool from_good, string to_loc, string to_bin, string to_cont, bool to_good, string serial_num, string new_status, string expected_date, string user_name, string fulfill_date, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | dtl_num |
System.Boolean | is_fulfill |
System.Int32 | quantity_num |
System.String | from_loc |
System.String | from_bin |
System.String | from_cont |
System.Boolean | from_good |
System.String | to_loc |
System.String | to_bin |
System.String | to_cont |
System.Boolean | to_good |
System.String | serial_num |
System.String | new_status |
System.String | expected_date |
System.String | user_name |
System.String | fulfill_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_get_alt_parts(String, String, String)

Declaration
protected short _get_alt_parts(string part_num, string domain_name, string mod_level)
Parameters
Type | Name | Description
System.String | part_num |
System.String | domain_name |
System.String | mod_level |
Returns
Type | Description
System.Int16 |

_get_loc_serv_site(String)

Declaration
protected short _get_loc_serv_site(string site_id)
Parameters
Type | Name | Description
System.String | site_id |
Returns
Type | Description
System.Int16 |

_Initialize(IFCApplication, IFCSession)

Declaration
public void _Initialize(IFCApplication TheFCApplication, IFCSession TheFCSession)
Parameters
Type | Name | Description
IFCApplication | TheFCApplication |
IFCSession | TheFCSession |

_make_pr_detail(String, String, String, String, String, String, Int32, Int32, String, String, String, String, String, String, Int16, String, String, String, String, Boolean, Int32, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _make_pr_detail(string hdr_num, string queue_name, string part_num, string domain_name, string mod_level, string serial_no, int quantity_num, int sp_rec_objid, string sp_rec_recordtype, string dtl_type, string priority_str, string ship_via, string carrier_name, string user_name, short warranty, string note_str, string status_str, string create_date, string due_date, bool gen_time_bombs, int contr_itm_objid, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | hdr_num |
System.String | queue_name |
System.String | part_num |
System.String | domain_name |
System.String | mod_level |
System.String | serial_no |
System.Int32 | quantity_num |
System.Int32 | sp_rec_objid |
System.String | sp_rec_recordtype |
System.String | dtl_type |
System.String | priority_str |
System.String | ship_via |
System.String | carrier_name |
System.String | user_name |
System.Int16 | warranty |
System.String | note_str |
System.String | status_str |
System.String | create_date |
System.String | due_date |
System.Boolean | gen_time_bombs |
System.Int32 | contr_itm_objid |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_make_pr_detail_list(String, String, String, String, String, String, Int32, Int32, String, String, String, String, String, String, Int16, String, String, String, String, Boolean, Int32, IFCList, IFCList, IFCList)

Declaration
protected short _make_pr_detail_list(string hdr_num, string queue_name, string part_num, string domain_name, string mod_level, string serial_no, int quantity_num, int sp_rec_objid, string sp_rec_recordtype, string dtl_type, string priority_str, string ship_via, string carrier_name, string user_name, short warranty, string note_str, string status_str, string create_date, string due_date, bool gen_time_bombs, int contr_itm_objid, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | hdr_num |
System.String | queue_name |
System.String | part_num |
System.String | domain_name |
System.String | mod_level |
System.String | serial_no |
System.Int32 | quantity_num |
System.Int32 | sp_rec_objid |
System.String | sp_rec_recordtype |
System.String | dtl_type |
System.String | priority_str |
System.String | ship_via |
System.String | carrier_name |
System.String | user_name |
System.Int16 | warranty |
System.String | note_str |
System.String | status_str |
System.String | create_date |
System.String | due_date |
System.Boolean | gen_time_bombs |
System.Int32 | contr_itm_objid |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_make_pr_header(String, String, String, String, String, String, String, String, String, String, String, String, Int32, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _make_pr_header(string first_name, string last_name, string phone_num, string ship_site_id, string bill_site_id, string case_id, string pay_method, string pay_terms, string priority_str, string user_name, string note_str, string create_date, int contract_objid, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | first_name |
System.String | last_name |
System.String | phone_num |
System.String | ship_site_id |
System.String | bill_site_id |
System.String | case_id |
System.String | pay_method |
System.String | pay_terms |
System.String | priority_str |
System.String | user_name |
System.String | note_str |
System.String | create_date |
System.Int32 | contract_objid |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_make_pr_header_case_list(String, String, String, String, String, String, String, String, String, String, String, String, Int32, IFCList, IFCList, IFCList)

Declaration
protected short _make_pr_header_case_list(string first_name, string last_name, string phone_num, string ship_site_id, string bill_site_id, string case_id, string pay_method, string pay_terms, string priority_str, string user_name, string note_str, string create_date, int contract_objid, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | first_name |
System.String | last_name |
System.String | phone_num |
System.String | ship_site_id |
System.String | bill_site_id |
System.String | case_id |
System.String | pay_method |
System.String | pay_terms |
System.String | priority_str |
System.String | user_name |
System.String | note_str |
System.String | create_date |
System.Int32 | contract_objid |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_make_pr_header_list(String, String, String, String, String, String, String, String, String, String, String, String, Int32, IFCList, IFCList, IFCList)

Declaration
protected short _make_pr_header_list(string first_name, string last_name, string phone_num, string ship_site_id, string bill_site_id, string case_id, string pay_method, string pay_terms, string priority_str, string user_name, string note_str, string create_date, int contract_objid, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | first_name |
System.String | last_name |
System.String | phone_num |
System.String | ship_site_id |
System.String | bill_site_id |
System.String | case_id |
System.String | pay_method |
System.String | pay_terms |
System.String | priority_str |
System.String | user_name |
System.String | note_str |
System.String | create_date |
System.Int32 | contract_objid |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_make_pr_header_subcase_list(String, String, String, String, String, String, String, String, String, String, String, String, Int32, IFCList, IFCList, IFCList)

Declaration
protected short _make_pr_header_subcase_list(string first_name, string last_name, string phone_num, string ship_site_id, string bill_site_id, string case_id, string pay_method, string pay_terms, string priority_str, string user_name, string note_str, string create_date, int contract_objid, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | first_name |
System.String | last_name |
System.String | phone_num |
System.String | ship_site_id |
System.String | bill_site_id |
System.String | case_id |
System.String | pay_method |
System.String | pay_terms |
System.String | priority_str |
System.String | user_name |
System.String | note_str |
System.String | create_date |
System.Int32 | contract_objid |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_mod_part_stocking_lev(String, String, String, String, String, String, String, String, Int16, Int16, Int16, Int16, Boolean)

Declaration
protected short _mod_part_stocking_lev(string bin_name, string to_bin, string location_name, string queue_name, string to_queue, string part_number, string mod_level, string domain_name, short part_minimum, short part_maximum, short part_rol, short part_roq, bool is_active)
Parameters
Type | Name | Description
System.String | bin_name |
System.String | to_bin |
System.String | location_name |
System.String | queue_name |
System.String | to_queue |
System.String | part_number |
System.String | mod_level |
System.String | domain_name |
System.Int16 | part_minimum |
System.Int16 | part_maximum |
System.Int16 | part_rol |
System.Int16 | part_roq |
System.Boolean | is_active |
Returns
Type | Description
System.Int16 |

_modify_gl_account(String, String, String, String, String, Boolean, Boolean, Boolean, String)

Declaration
protected short _modify_gl_account(string old_name, string new_name, string account_type, string desc_str, string account_no, bool is_exp, bool is_active, bool is_company, string site_id)
Parameters
Type | Name | Description
System.String | old_name |
System.String | new_name |
System.String | account_type |
System.String | desc_str |
System.String | account_no |
System.Boolean | is_exp |
System.Boolean | is_active |
System.Boolean | is_company |
System.String | site_id |
Returns
Type | Description
System.Int16 |

_modify_inv_bin(String, String, String, Boolean)

Declaration
protected short _modify_inv_bin(string old_name, string new_name, string loc_name, bool is_active)
Parameters
Type | Name | Description
System.String | old_name |
System.String | new_name |
System.String | loc_name |
System.Boolean | is_active |
Returns
Type | Description
System.Int16 |

_modify_inv_location(String, String, String, String, String, String, Boolean, Boolean, String, String)

Declaration
protected short _modify_inv_location(string old_name, string new_name, string account_type, string desc_str, string reports_to_loc, string cap_gl_acct, bool is_active, bool is_company, string site_id, string trans_auth_str)
Parameters
Type | Name | Description
System.String | old_name |
System.String | new_name |
System.String | account_type |
System.String | desc_str |
System.String | reports_to_loc |
System.String | cap_gl_acct |
System.Boolean | is_active |
System.Boolean | is_company |
System.String | site_id |
System.String | trans_auth_str |
Returns
Type | Description
System.Int16 |

_modify_lss(String, String, Int16)

Declaration
protected short _modify_lss(string site_id, string loc_name, short loc_rank)
Parameters
Type | Name | Description
System.String | site_id |
System.String | loc_name |
System.Int16 | loc_rank |
Returns
Type | Description
System.Int16 |

_move_pr(String, String)

Declaration
protected short _move_pr(string pr_id, string new_wipbin_name)
Parameters
Type | Name | Description
System.String | pr_id |
System.String | new_wipbin_name |
Returns
Type | Description
System.Int16 |

_open_container(String)

Declaration
protected short _open_container(string cont_name)
Parameters
Type | Name | Description
System.String | cont_name |
Returns
Type | Description
System.Int16 |

_part_transfer(String, String, String, Int32, String, String, String, String, Boolean, String, String, String, Boolean, String, String, String, String, Boolean, Int16, String, String, String, String)

Declaration
protected short _part_transfer(string part_num, string mod_level, string domain_name, int quantity_num, string serial_num, string from_loc, string from_bin, string from_cont, bool from_good, string to_loc, string to_bin, string to_cont, bool to_good, string user_name, string trans_date, string ref_id, string note_str, bool gen_time_bombs, short fifo_flag, string update_cost, string update_source, string trans_id, string std_cost)
Parameters
Type | Name | Description
System.String | part_num |
System.String | mod_level |
System.String | domain_name |
System.Int32 | quantity_num |
System.String | serial_num |
System.String | from_loc |
System.String | from_bin |
System.String | from_cont |
System.Boolean | from_good |
System.String | to_loc |
System.String | to_bin |
System.String | to_cont |
System.Boolean | to_good |
System.String | user_name |
System.String | trans_date |
System.String | ref_id |
System.String | note_str |
System.Boolean | gen_time_bombs |
System.Int16 | fifo_flag |
System.String | update_cost |
System.String | update_source |
System.String | trans_id |
System.String | std_cost |
Returns
Type | Description
System.Int16 |

_pick(String, String, Boolean, String, String, String, Boolean)

Declaration
protected short _pick(string dtl_num, string locs_str, bool use_good, string user_name, string pick_date, string new_status, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | locs_str |
System.Boolean | use_good |
System.String | user_name |
System.String | pick_date |
System.String | new_status |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_pick_internal(String, String, Boolean, String, String, String, Boolean, Boolean)

Declaration
protected short _pick_internal(string dtl_num, string locs_str, bool use_good, string user_name, string pick_date, string new_status, bool do_cond_change, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | locs_str |
System.Boolean | use_good |
System.String | user_name |
System.String | pick_date |
System.String | new_status |
System.Boolean | do_cond_change |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_pick_no_trans(String, String, Boolean, String, String, String, Boolean)

Declaration
protected short _pick_no_trans(string dtl_num, string locs_str, bool use_good, string user_name, string pick_date, string new_status, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | locs_str |
System.Boolean | use_good |
System.String | user_name |
System.String | pick_date |
System.String | new_status |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_pick_sn(String, String, Boolean, String, String, String, String, Boolean)

Declaration
protected short _pick_sn(string dtl_num, string locs_str, bool use_good, string user_name, string pick_date, string new_status, string serial_no, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | locs_str |
System.Boolean | use_good |
System.String | user_name |
System.String | pick_date |
System.String | new_status |
System.String | serial_no |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_pick_sn_no_trans(String, String, Boolean, String, String, String, String, Boolean)

Declaration
protected short _pick_sn_no_trans(string dtl_num, string locs_str, bool use_good, string user_name, string pick_date, string new_status, string serial_no, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | locs_str |
System.Boolean | use_good |
System.String | user_name |
System.String | pick_date |
System.String | new_status |
System.String | serial_no |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_receive_pr_internal(ref String, String, String, String, Boolean, String, String, String, Boolean, Int32, String, String, String, String, Boolean, Boolean, Boolean, String, String, Boolean, Boolean, Boolean)

Declaration
protected short _receive_pr_internal(ref string pr_num, string from_loc, string from_bin, string from_cont, bool from_good, string to_loc, string to_bin, string to_cont, bool to_good, int quantity_num, string serial_num, string status_str, string carrier_name, string waybill_name, bool poss_damage, bool not_prop_pack, bool route_to_test, string user_name, string receive_date, bool auto_close, bool gen_time_bombs, bool do_cond_change)
Parameters
Type | Name | Description
System.String | pr_num |
System.String | from_loc |
System.String | from_bin |
System.String | from_cont |
System.Boolean | from_good |
System.String | to_loc |
System.String | to_bin |
System.String | to_cont |
System.Boolean | to_good |
System.Int32 | quantity_num |
System.String | serial_num |
System.String | status_str |
System.String | carrier_name |
System.String | waybill_name |
System.Boolean | poss_damage |
System.Boolean | not_prop_pack |
System.Boolean | route_to_test |
System.String | user_name |
System.String | receive_date |
System.Boolean | auto_close |
System.Boolean | gen_time_bombs |
System.Boolean | do_cond_change |
Returns
Type | Description
System.Int16 |

_reject_pr(String, String, String, String, String, Boolean)

Declaration
protected short _reject_pr(string pr_id, string reject_date, string wipbin_name, string note_str, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | pr_id |
System.String | reject_date |
System.String | wipbin_name |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_reopen_pr(String, String, String, String, String, Boolean)

Declaration
protected short _reopen_pr(string pr_id, string new_status, string wipbin_name, string reopen_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | pr_id |
System.String | new_status |
System.String | wipbin_name |
System.String | reopen_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_seal_container(String)

Declaration
protected short _seal_container(string cont_name)
Parameters
Type | Name | Description
System.String | cont_name |
Returns
Type | Description
System.Int16 |

_set_cl_transition(ref String, ref String, ref String, ref String[])

Declaration
protected short _set_cl_transition(ref string request_type, ref string start_cond, ref string end_cond, ref string[] privclasses)
Parameters
Type | Name | Description
System.String | request_type |
System.String | start_cond |
System.String | end_cond |
System.String[] | privclasses |
Returns
Type | Description
System.Int16 |

_set_part_stocking_lev(String, String, String, String, String, String, Int16, Int16, Int16, Int16, Boolean)

Declaration
protected short _set_part_stocking_lev(string bin_name, string location_name, string queue_name, string part_number, string mod_level, string domain_name, short part_minimum, short part_maximum, short part_rol, short part_roq, bool is_active)
Parameters
Type | Name | Description
System.String | bin_name |
System.String | location_name |
System.String | queue_name |
System.String | part_number |
System.String | mod_level |
System.String | domain_name |
System.Int16 | part_minimum |
System.Int16 | part_maximum |
System.Int16 | part_rol |
System.Int16 | part_roq |
System.Boolean | is_active |
Returns
Type | Description
System.Int16 |

_ship(String, String, String, String, String, String, String, String, String, String, String, String, Int32, Double, String, String, String, String, Boolean)

Declaration
protected short _ship(string dtl_num, string site_name, string address_1, string address_2, string city_name, string state_name, string zip_code, string country_name, string f_name, string l_name, string waybill_name, string pack_list, int piece_count, double total_weight, string status_str, string ship_date, string user_name, string carrier_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | site_name |
System.String | address_1 |
System.String | address_2 |
System.String | city_name |
System.String | state_name |
System.String | zip_code |
System.String | country_name |
System.String | f_name |
System.String | l_name |
System.String | waybill_name |
System.String | pack_list |
System.Int32 | piece_count |
System.Double | total_weight |
System.String | status_str |
System.String | ship_date |
System.String | user_name |
System.String | carrier_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_unpick(String, String, String, String, Boolean, String, String, Boolean)

Declaration
protected short _unpick(string dtl_num, string loc_name, string bin_name, string cont_num, bool use_good, string user_name, string unpick_date, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | loc_name |
System.String | bin_name |
System.String | cont_num |
System.Boolean | use_good |
System.String | user_name |
System.String | unpick_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_unpick_internal(String, String, String, String, Boolean, String, String, Boolean, Boolean)

Declaration
protected short _unpick_internal(string dtl_num, string loc_name, string bin_name, string cont_num, bool use_good, string user_name, string unpick_date, bool do_cond_change, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | loc_name |
System.String | bin_name |
System.String | cont_num |
System.Boolean | use_good |
System.String | user_name |
System.String | unpick_date |
System.Boolean | do_cond_change |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_unpick_no_trans(String, String, String, String, Boolean, String, String, Boolean)

Declaration
protected short _unpick_no_trans(string dtl_num, string loc_name, string bin_name, string cont_num, bool use_good, string user_name, string unpick_date, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | loc_name |
System.String | bin_name |
System.String | cont_num |
System.Boolean | use_good |
System.String | user_name |
System.String | unpick_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_unpick_sn(String, String, String, String, Boolean, String, String, String, Boolean)

Declaration
protected short _unpick_sn(string dtl_num, string loc_name, string bin_name, string cont_num, bool use_good, string user_name, string unpick_date, string serial_no, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | loc_name |
System.String | bin_name |
System.String | cont_num |
System.Boolean | use_good |
System.String | user_name |
System.String | unpick_date |
System.String | serial_no |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_unpick_sn_no_trans(String, String, String, String, Boolean, String, String, String, Boolean)

Declaration
protected short _unpick_sn_no_trans(string dtl_num, string loc_name, string bin_name, string cont_num, bool use_good, string user_name, string unpick_date, string serial_no, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | loc_name |
System.String | bin_name |
System.String | cont_num |
System.Boolean | use_good |
System.String | user_name |
System.String | unpick_date |
System.String | serial_no |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_update_pr_detail(String, String, String, String, String, Int32, Int32, String, String, String, String, Int16, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _update_pr_detail(string dtl_num, string part_num, string domain_name, string mod_level, string serial_no, int quantity_num, int sp_objid, string dtl_type, string priority_str, string ship_via, string carrier_name, short warranty, string note_str, string status_str, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | part_num |
System.String | domain_name |
System.String | mod_level |
System.String | serial_no |
System.Int32 | quantity_num |
System.Int32 | sp_objid |
System.String | dtl_type |
System.String | priority_str |
System.String | ship_via |
System.String | carrier_name |
System.Int16 | warranty |
System.String | note_str |
System.String | status_str |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_update_pr_detail_list(String, String, String, String, String, Int32, Int32, String, String, String, String, Int16, String, String, IFCList, IFCList, IFCList)

Declaration
protected short _update_pr_detail_list(string dtl_num, string part_num, string domain_name, string mod_level, string serial_no, int quantity_num, int sp_objid, string dtl_type, string priority_str, string ship_via, string carrier_name, short warranty, string note_str, string status_str, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | part_num |
System.String | domain_name |
System.String | mod_level |
System.String | serial_no |
System.Int32 | quantity_num |
System.Int32 | sp_objid |
System.String | dtl_type |
System.String | priority_str |
System.String | ship_via |
System.String | carrier_name |
System.Int16 | warranty |
System.String | note_str |
System.String | status_str |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_update_pr_header(String, String, String, String, String, String, String, String, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _update_pr_header(string hdr_num, string first_name, string last_name, string phone_num, string ship_site_id, string bill_site_id, string case_id, string pay_method, string pay_terms, string priority_str, string note_str, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | hdr_num |
System.String | first_name |
System.String | last_name |
System.String | phone_num |
System.String | ship_site_id |
System.String | bill_site_id |
System.String | case_id |
System.String | pay_method |
System.String | pay_terms |
System.String | priority_str |
System.String | note_str |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_update_pr_header_list(String, String, String, String, String, String, String, String, String, String, String, IFCList, IFCList, IFCList)

Declaration
protected short _update_pr_header_list(string hdr_num, string first_name, string last_name, string phone_num, string ship_site_id, string bill_site_id, string case_id, string pay_method, string pay_terms, string priority_str, string note_str, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | hdr_num |
System.String | first_name |
System.String | last_name |
System.String | phone_num |
System.String | ship_site_id |
System.String | bill_site_id |
System.String | case_id |
System.String | pay_method |
System.String | pay_terms |
System.String | priority_str |
System.String | note_str |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_yank_pr(String, String, String, String, Boolean)

Declaration
protected short _yank_pr(string pr_id, string wipbin_name, string yank_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | pr_id |
System.String | wipbin_name |
System.String | yank_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

GetProductID()

Declaration
protected abstract int GetProductID()
Returns
Type | Description
System.Int32 |


Class FCCQ | fcSDK Documentation

Class FCCQ

Inheritance
System.Object
FCCQBase
FCCQ
Implements
IFCCQ
IToolkit
Inherited Members
FCCQBase._Initialize(IFCApplication, IFCSession)
FCCQBase._dispatch_cr(String, String, String, String, Boolean)
FCCQBase._accept_cr(String, String, String, String, Boolean)
FCCQBase._reject_cr(String, String, String, String, String, Boolean)
FCCQBase._forward_cr(String, String, String, String, String, Boolean)
FCCQBase._assign_cr(String, String, String, String, String, Boolean)
FCCQBase._move_cr(String, String)
FCCQBase._yank_cr(String, String, String, String, Boolean)
FCCQBase._create_cr_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)
FCCQBase._create_cr(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)
FCCQBase._log_cr_note_list(String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)
FCCQBase._log_cr_note(String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)
FCCQBase._check_cq_trans(String, String, String, String, String)
FCCQBase._close_cr_list(String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)
FCCQBase._close_cr(String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)
FCCQBase._reopen_cr(String, String, String, String, String, Boolean)
FCCQBase._change_cr_status(String, String, String, String, String, Boolean)
FCCQBase._add_module_to_cr(Int32, String, String)
FCCQBase._duplicate_cr(String, String, String, String, String, Boolean)
FCCQBase._fix_cr(String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)
FCCQBase._fix_cr_list(String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)
FCCQBase._modify_cr(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)
FCCQBase._modify_cr_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)
FCCQBase._replicate_cr(String, String, String, Boolean)
FCCQBase._log_cr_email(String, String, String, String, String, String, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)
FCCQBase._log_cr_email_list(String, String, String, String, String, String, Boolean, Boolean, IFCList, IFCList, IFCList)
FCCQBase._fix_failed_list(String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)
FCCQBase._fix_failed(String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)
FCCQBase._change_cr_state(String, String, String, String, String, String, Boolean, String, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)
FCCQBase._ret_objid
FCCQBase._ret_id_num
FCCQBase._impersonatorUserName
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Compatibility.Toolkits
Assembly: FChoice.Foundation.Clarify.Compatibility.Toolkits.dll
Syntax
[Guid("559A7F0D-E334-4a6d-A870-98D8D16217DA")]
[ComVisible(true)]
[AltName("Quality")]
[ClassInterface(ClassInterfaceType.None)]
public sealed class FCCQ : FCCQBase, IFCCQ, IToolkit

Constructors

FCCQ()

Declaration
public FCCQ()

FCCQ(IFCApplication, IFCSession)

Declaration
public FCCQ(IFCApplication FCApp, IFCSession FCSess)
Parameters
Type | Name | Description
IFCApplication | FCApp |
IFCSession | FCSess |

Methods

GetProductID()

Declaration
protected override int GetProductID()
Returns
Type | Description
System.Int32 |
Overrides
FCCQBase.GetProductID()

Explicit Interface Implementations

IFCCQ.accept_cr(String, String, String, String, Boolean)

Declaration
[AltName("Accept_CR")]
public short IFCCQ.accept_cr([ParameterRequired, AltName("CRIDNum")] string cr_id, string accept_date, [AltName("wip_bin")] string wipbin, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | accept_date |
System.String | wipbin |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCQ.add_module_to_cr(Int32, String, String)

Declaration
[AltName("Add_Module_To_CR")]
public short IFCCQ.add_module_to_cr([ParameterRequired] int fix_objid, [ParameterRequired, AltName("File_Name")] string file, [AltName("File_Revision")] string rev)
Parameters
Type | Name | Description
System.Int32 | fix_objid |
System.String | file |
System.String | rev |
Returns
Type | Description
System.Int16 |

IFCCQ.assign_cr(String, String, String, String, String, Boolean)

Declaration
[AltName("Assign_CR")]
public short IFCCQ.assign_cr([ParameterRequired, AltName("CRIDNum")] string cr_id, string new_user, [AltName("wip_bin")] string wipbin, string assign_date, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | new_user |
System.String | wipbin |
System.String | assign_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCQ.change_cr_state(String, String, String, String, String, String, Boolean, String, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[FacadeVoid]
[AltName("Change_CR_State")]
public short IFCCQ.change_cr_state([ParameterRequired, AltName("CR_ID_Num")] string cr_id, string new_status, [ParameterRequired, AltType("FChoice.Toolkits.Clarify.CRCondition", "FChoice.Toolkits.Clarify.Utility.GetCRCondition({0})"), ParameterDefaultValue("FChoice.Toolkits.Clarify.CRCondition.Fixed")] string new_condition, string change_date, string notes, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs, [AltName("wip_bin")] string wipbin, string test_case, [AltName("Fixed_In_Release")] string int_release, [AltName("Master_CRIDNum")] string master_cr, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | new_status |
System.String | new_condition |
System.String | change_date |
System.String | notes |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.String | wipbin |
System.String | test_case |
System.String | int_release |
System.String | master_cr |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCQ.change_cr_status(String, String, String, String, String, Boolean)

Declaration
[AltName("Change_CR_Status")]
public short IFCCQ.change_cr_status([ParameterRequired, AltName("CR_ID_Num")] string cr_id, string new_status, string change_date, string notes, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | new_status |
System.String | change_date |
System.String | notes |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCQ.check_cq_trans(String, String, String, String, String)

Declaration
[AltName("Check_Clear_Quality_Transition")]
public short IFCCQ.check_cq_trans([ParameterRequired, AltName("Old_Condition")] string old_cond, [ParameterRequired, AltName("Old_Status")] string old_stat, [ParameterRequired, AltName("New_Condition")] string new_cond, [ParameterRequired, AltName("New_Status")] string new_stat, [ParameterRequired] string user_name)
Parameters
Type | Name | Description
System.String | old_cond |
System.String | old_stat |
System.String | new_cond |
System.String | new_stat |
System.String | user_name |
Returns
Type | Description
System.Int16 |

IFCCQ.close_cr(String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[FacadeVoid]
[OutputProperty("ret_objid", "CloseBug")]
public short IFCCQ.close_cr([ParameterRequired, AltName("CR_ID_Num")] string cr_id, [AltName("Status")] string the_status, string notes, string test_case, [AltName("Fixed_In_Release")] string int_release, string user_name, string close_date, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | the_status |
System.String | notes |
System.String | test_case |
System.String | int_release |
System.String | user_name |
System.String | close_date |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCQ.close_cr_list(String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[AltName("Close_CR")]
[OutputProperty("ret_objid", "CloseBug")]
public short IFCCQ.close_cr_list([ParameterRequired, AltName("CR_ID_Num")] string cr_id, [AltName("Status")] string the_status, string notes, string test_case, [AltName("Fixed_In_Release")] string int_release, string user_name, string close_date, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | the_status |
System.String | notes |
System.String | test_case |
System.String | int_release |
System.String | user_name |
System.String | close_date |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCCQ.create_cr(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[AltName("Create_CR")]
[OutputProperty("ret_id_num", "ChangeRequestIDNum", "System.String", "String.Empty", "Change Request ID Number.")]
public short IFCCQ.create_cr([ParameterRequired, AltName("Part_Number")] string part_num, [ParameterRequired, AltName("part_revision")] string mod_level, [ParameterRequired, AltName("part_domain")] string domain, [AltName("Title")] string the_title, string status, [AltName("Description")] string note_log, [AltName("CR_Type")] string cr_type, string priority, string frequency, [AltName("Found_On_CPU")] string found_on, [AltName("Operating_System")] string op_sys, string memory, string cr_class, [AltName("introduction_phase")] string intro_phase, string test_class, string fixed_in, [AltName("Verification_Test")] string test, [AltName("queue")] string queue_name, string user_name, [AltName("create_Date")] string cr_date, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | part_num |
System.String | mod_level |
System.String | domain |
System.String | the_title |
System.String | status |
System.String | note_log |
System.String | cr_type |
System.String | priority |
System.String | frequency |
System.String | found_on |
System.String | op_sys |
System.String | memory |
System.String | cr_class |
System.String | intro_phase |
System.String | test_class |
System.String | fixed_in |
System.String | test |
System.String | queue_name |
System.String | user_name |
System.String | cr_date |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCQ.create_cr_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[AltName("Create_CR")]
[OutputProperty("ret_id_num", "CR")]
public short IFCCQ.create_cr_list([ParameterRequired, AltName("Part_Number")] string part_num, [ParameterRequired, AltName("part_revision")] string mod_level, [ParameterRequired, AltName("part_domain")] string domain, [AltName("Title")] string the_title, string status, [AltName("Description")] string note_log, [AltName("CR_Type")] string cr_type, string priority, string frequency, [AltName("Found_On_CPU")] string found_on, [AltName("Operating_System")] string op_sys, string memory, [AltName("CR_Class")] string cr_class, [AltName("introduction_phase")] string intro_phase, string test_class, string fixed_in, [AltName("Verification_Test")] string test, [AltName("queue")] string queue_name, string user_name, [AltName("Create_Date")] string cr_date, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | part_num |
System.String | mod_level |
System.String | domain |
System.String | the_title |
System.String | status |
System.String | note_log |
System.String | cr_type |
System.String | priority |
System.String | frequency |
System.String | found_on |
System.String | op_sys |
System.String | memory |
System.String | cr_class |
System.String | intro_phase |
System.String | test_class |
System.String | fixed_in |
System.String | test |
System.String | queue_name |
System.String | user_name |
System.String | cr_date |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCCQ.dispatch_cr(String, String, String, String, Boolean)

Declaration
[AltName("Dispatch_CR")]
public short IFCCQ.dispatch_cr([ParameterRequired, AltName("CRIDNum")] string cr_id, [ParameterRequired, AltName("queue")] string queue_name, [AltName("Dispatch_Date")] string disp_date, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | queue_name |
System.String | disp_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCQ.duplicate_cr(String, String, String, String, String, Boolean)

Declaration
[AltName("Duplicate_CR")]
public short IFCCQ.duplicate_cr([ParameterRequired, AltName("CR_ID_Num")] string cr_id, [AltName("Status")] string the_status, [ParameterRequired, AltName("Master_CRIDNum")] string master_cr, string user_name, string close_date, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | the_status |
System.String | master_cr |
System.String | user_name |
System.String | close_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCQ.fix_cr(String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[FacadeVoid]
[OutputProperty("ret_objid", "FixBug")]
public short IFCCQ.fix_cr([ParameterRequired, AltName("CR_ID_Num")] string cr_id, [AltName("Status")] string the_status, string notes, string user_name, string fix_date, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | the_status |
System.String | notes |
System.String | user_name |
System.String | fix_date |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCQ.fix_cr_list(String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[AltName("Fix_CR")]
[OutputProperty("ret_objid", "FixBug")]
public short IFCCQ.fix_cr_list([ParameterRequired, AltName("CR_ID_Num")] string cr_id, [AltName("Status")] string the_status, string notes, string user_name, string fix_date, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | the_status |
System.String | notes |
System.String | user_name |
System.String | fix_date |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCCQ.fix_failed(String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[FacadeVoid]
[OutputProperty("ret_objid", "CloseBug")]
public short IFCCQ.fix_failed([ParameterRequired, AltName("CR_ID_Num")] string cr_id, [AltName("Status")] string the_status, string notes, string test_case, [AltName("Fixed_In_Release")] string int_release, string user_name, string failed_date, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | the_status |
System.String | notes |
System.String | test_case |
System.String | int_release |
System.String | user_name |
System.String | failed_date |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCQ.fix_failed_list(String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[AltName("Fix_Failed")]
[OutputProperty("ret_objid", "CloseBug")]
public short IFCCQ.fix_failed_list([ParameterRequired, AltName("CR_ID_Num")] string cr_id, [AltName("Status")] string the_status, string notes, string test_case, [AltName("Fixed_In_Release")] string int_release, string user_name, string failed_date, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | the_status |
System.String | notes |
System.String | test_case |
System.String | int_release |
System.String | user_name |
System.String | failed_date |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCCQ.forward_cr(String, String, String, String, String, Boolean)

Declaration
[AltName("Forward_CR")]
public short IFCCQ.forward_cr([ParameterRequired, AltName("CRIDNum")] string cr_id, [ParameterRequired] string new_queue, string forward_date, string notes, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | new_queue |
System.String | forward_date |
System.String | notes |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCQ.impersonatorUserName

Declaration
public string IFCCQ.impersonatorUserName { get; set; }
Returns
Type | Description
System.String |

IFCCQ.Initialize(IFCApplication, IFCSession)

Declaration
[ToolkitVisible(false)]
public void IFCCQ.Initialize(IFCApplication TheFCApplication, IFCSession TheFCSession)
Parameters
Type | Name | Description
IFCApplication | TheFCApplication |
IFCSession | TheFCSession |

IFCCQ.log_cr_email(String, String, String, String, String, String, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[FacadeVoid]
[OutputProperty("ret_objid", "EmailLog")]
public short IFCCQ.log_cr_email([ParameterRequired, AltName("CR_ID_Num")] string cr_id, string log_date, string message, string recipient, [AltName("CCList")] string cc_list, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs, [ParameterDefaultValue("true")] bool send_email, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | log_date |
System.String | message |
System.String | recipient |
System.String | cc_list |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.Boolean | send_email |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCQ.log_cr_email_list(String, String, String, String, String, String, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[AltName("Log_CR_Email")]
[OutputProperty("ret_objid", "EmailLog")]
public short IFCCQ.log_cr_email_list([ParameterRequired, AltName("CR_ID_Num")] string cr_id, string log_date, string message, string recipient, [AltName("CCList")] string cc_list, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs, [ParameterDefaultValue("true")] bool send_email, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | log_date |
System.String | message |
System.String | recipient |
System.String | cc_list |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.Boolean | send_email |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCCQ.log_cr_note(String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[FacadeVoid]
[OutputProperty("ret_objid", "NoteLog")]
public short IFCCQ.log_cr_note([ParameterRequired, AltName("CR_ID_Num")] string cr_id, string notes, [AltName("Internal_Use_Only_Notes")] string int_use, string log_date, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | notes |
System.String | int_use |
System.String | log_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCQ.log_cr_note_list(String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[AltName("Log_CR_Note")]
[OutputProperty("ret_objid", "NoteLog")]
public short IFCCQ.log_cr_note_list([ParameterRequired, AltName("CR_ID_Num")] string cr_id, string notes, [AltName("Internal_Use_Only_Notes")] string int_use, string log_date, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | notes |
System.String | int_use |
System.String | log_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCCQ.modify_cr(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[FacadeVoid]
public short IFCCQ.modify_cr([ParameterRequired, AltName("CR_ID_Num")] string cr_num, [AltName("part_number")] string part_num, [AltName("part_revision")] string mod_level, [AltName("part_domain")] string domain, [AltName("Title")] string the_title, [AltName("CR_Type")] string cr_type, string priority, string frequency, [AltName("Found_On_CPU")] string found_on, [AltName("Operating_System")] string op_sys, string memory, [AltName("CR_Class")] string cr_class, [AltName("introduction_phase")] string intro_phase, string test_class, string fixed_in, string user_name, [AltName("update_Date")] string cr_date, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | cr_num |
System.String | part_num |
System.String | mod_level |
System.String | domain |
System.String | the_title |
System.String | cr_type |
System.String | priority |
System.String | frequency |
System.String | found_on |
System.String | op_sys |
System.String | memory |
System.String | cr_class |
System.String | intro_phase |
System.String | test_class |
System.String | fixed_in |
System.String | user_name |
System.String | cr_date |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCQ.modify_cr_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[AltName("Update_CR")]
public short IFCCQ.modify_cr_list([ParameterRequired, AltName("CR_ID_Num")] string cr_num, [AltName("part_number")] string part_num, [AltName("part_revision")] string mod_level, [AltName("part_domain")] string domain, [AltName("Title")] string the_title, [AltName("CR_Type")] string cr_type, string priority, string frequency, [AltName("Found_On_CPU")] string found_on, [AltName("Operating_System")] string op_sys, string memory, [AltName("CR_Class")] string cr_class, [AltName("introduction_phase")] string intro_phase, string test_class, string fixed_in, string user_name, [AltName("update_Date")] string cr_date, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | cr_num |
System.String | part_num |
System.String | mod_level |
System.String | domain |
System.String | the_title |
System.String | cr_type |
System.String | priority |
System.String | frequency |
System.String | found_on |
System.String | op_sys |
System.String | memory |
System.String | cr_class |
System.String | intro_phase |
System.String | test_class |
System.String | fixed_in |
System.String | user_name |
System.String | cr_date |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCCQ.move_cr(String, String)

Declaration
[AltName("Move_CR")]
public short IFCCQ.move_cr([ParameterRequired, AltName("CRIDNum")] string cr_id, [ParameterRequired, AltName("new_wip_bin")] string new_wipbin)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | new_wipbin |
Returns
Type | Description
System.Int16 |

IFCCQ.reject_cr(String, String, String, String, String, Boolean)

Declaration
[AltName("Reject_CR")]
public short IFCCQ.reject_cr([ParameterRequired, AltName("CRIDNum")] string cr_id, string reject_date, [AltName("wip_bin")] string wipbin, string notes, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | reject_date |
System.String | wipbin |
System.String | notes |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCQ.reopen_cr(String, String, String, String, String, Boolean)

Declaration
[AltName("Reopen_CR")]
public short IFCCQ.reopen_cr([ParameterRequired, AltName("CR_ID_Num")] string cr_id, [AltName("Status")] string the_status, [AltName("wip_bin")] string wipbin, string user_name, string reopen_date, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | the_status |
System.String | wipbin |
System.String | user_name |
System.String | reopen_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCQ.replicate_cr(String, String, String, Boolean)

Declaration
[AltName("Replicate_CR")]
[OutputProperty("ret_id_num", "CR")]
[OutputProperty("ret_objid", "CR")]
public short IFCCQ.replicate_cr([ParameterRequired, AltName("CR_ID_Num")] string cr_id, string user_name, [AltName("Replicated_Date")] string rep_date, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | user_name |
System.String | rep_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCQ.ret_id_num

Declaration
public string IFCCQ.ret_id_num { get; }
Returns
Type | Description
System.String |

IFCCQ.ret_objid

Declaration
public int IFCCQ.ret_objid { get; }
Returns
Type | Description
System.Int32 |

IToolkit.ReturnIDNum

Declaration
public string IToolkit.ReturnIDNum { get; }
Returns
Type | Description
System.String |

IToolkit.ReturnObjid

Declaration
public int IToolkit.ReturnObjid { get; }
Returns
Type | Description
System.Int32 |

IFCCQ.yank_cr(String, String, String, String, Boolean)

Declaration
[AltName("Yank_CR")]
public short IFCCQ.yank_cr([ParameterRequired, AltName("CRIDNum")] string cr_id, [AltName("wip_bin")] string wipbin, string yank_date, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | wipbin |
System.String | yank_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

Implements

IFCCQ
IToolkit


Class FCCQBase | fcSDK Documentation

Class FCCQBase

Inheritance
System.Object
FCCQBase
FCCQ
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Compatibility.Toolkits
Assembly: FChoice.Foundation.Clarify.Compatibility.Toolkits.dll
Syntax
[ComVisible(false)]
public abstract class FCCQBase

Constructors

FCCQBase()

Declaration
protected FCCQBase()

FCCQBase(IFCApplication, IFCSession)

Declaration
protected FCCQBase(IFCApplication FCApp, IFCSession FCSess)
Parameters
Type | Name | Description
IFCApplication | FCApp |
IFCSession | FCSess |

Properties

_impersonatorUserName

Declaration
protected string _impersonatorUserName { get; set; }
Property Value
Type | Description
System.String |

_ret_id_num

Declaration
protected string _ret_id_num { get; }
Property Value
Type | Description
System.String |

_ret_objid

Declaration
protected int _ret_objid { get; }
Property Value
Type | Description
System.Int32 |

Methods

_accept_cr(String, String, String, String, Boolean)

Declaration
protected short _accept_cr(string cr_id, string accept_date, string wipbin, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | accept_date |
System.String | wipbin |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_add_module_to_cr(Int32, String, String)

Declaration
protected short _add_module_to_cr(int fix_objid, string file, string rev)
Parameters
Type | Name | Description
System.Int32 | fix_objid |
System.String | file |
System.String | rev |
Returns
Type | Description
System.Int16 |

_assign_cr(String, String, String, String, String, Boolean)

Declaration
protected short _assign_cr(string cr_id, string new_user, string wipbin, string assign_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | new_user |
System.String | wipbin |
System.String | assign_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_change_cr_state(String, String, String, String, String, String, Boolean, String, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _change_cr_state(string cr_id, string new_status, string new_condition, string change_date, string notes, string user_name, bool gen_time_bombs, string wipbin, string test_case, string int_release, string master_cr, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | new_status |
System.String | new_condition |
System.String | change_date |
System.String | notes |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.String | wipbin |
System.String | test_case |
System.String | int_release |
System.String | master_cr |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_change_cr_status(String, String, String, String, String, Boolean)

Declaration
protected short _change_cr_status(string cr_id, string new_status, string change_date, string notes, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | new_status |
System.String | change_date |
System.String | notes |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_check_cq_trans(String, String, String, String, String)

Declaration
protected short _check_cq_trans(string old_cond, string old_stat, string new_cond, string new_stat, string user_name)
Parameters
Type | Name | Description
System.String | old_cond |
System.String | old_stat |
System.String | new_cond |
System.String | new_stat |
System.String | user_name |
Returns
Type | Description
System.Int16 |

_close_cr(String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _close_cr(string cr_id, string the_status, string notes, string test_case, string int_release, string user_name, string close_date, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | the_status |
System.String | notes |
System.String | test_case |
System.String | int_release |
System.String | user_name |
System.String | close_date |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_close_cr_list(String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _close_cr_list(string cr_id, string the_status, string notes, string test_case, string int_release, string user_name, string close_date, bool gen_time_bombs, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | the_status |
System.String | notes |
System.String | test_case |
System.String | int_release |
System.String | user_name |
System.String | close_date |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_create_cr(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _create_cr(string part_num, string mod_level, string domain, string the_title, string status, string note_log, string cr_type, string priority, string frequency, string found_on, string op_sys, string memory, string cr_class, string intro_phase, string test_class, string fixed_in, string test, string queue_name, string user_name, string cr_date, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | part_num |
System.String | mod_level |
System.String | domain |
System.String | the_title |
System.String | status |
System.String | note_log |
System.String | cr_type |
System.String | priority |
System.String | frequency |
System.String | found_on |
System.String | op_sys |
System.String | memory |
System.String | cr_class |
System.String | intro_phase |
System.String | test_class |
System.String | fixed_in |
System.String | test |
System.String | queue_name |
System.String | user_name |
System.String | cr_date |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_create_cr_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _create_cr_list(string part_num, string mod_level, string domain, string the_title, string status, string note_log, string cr_type, string priority, string frequency, string found_on, string op_sys, string memory, string cr_class, string intro_phase, string test_class, string fixed_in, string test, string queue_name, string user_name, string cr_date, bool gen_time_bombs, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | part_num |
System.String | mod_level |
System.String | domain |
System.String | the_title |
System.String | status |
System.String | note_log |
System.String | cr_type |
System.String | priority |
System.String | frequency |
System.String | found_on |
System.String | op_sys |
System.String | memory |
System.String | cr_class |
System.String | intro_phase |
System.String | test_class |
System.String | fixed_in |
System.String | test |
System.String | queue_name |
System.String | user_name |
System.String | cr_date |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_dispatch_cr(String, String, String, String, Boolean)

Declaration
protected short _dispatch_cr(string cr_id, string queue_name, string disp_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | queue_name |
System.String | disp_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_duplicate_cr(String, String, String, String, String, Boolean)

Declaration
protected short _duplicate_cr(string cr_id, string the_status, string master_cr, string user_name, string close_date, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | the_status |
System.String | master_cr |
System.String | user_name |
System.String | close_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_fix_cr(String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _fix_cr(string cr_id, string the_status, string notes, string user_name, string fix_date, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | the_status |
System.String | notes |
System.String | user_name |
System.String | fix_date |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_fix_cr_list(String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _fix_cr_list(string cr_id, string the_status, string notes, string user_name, string fix_date, bool gen_time_bombs, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | the_status |
System.String | notes |
System.String | user_name |
System.String | fix_date |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_fix_failed(String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _fix_failed(string cr_id, string the_status, string notes, string test_case, string int_release, string user_name, string failed_date, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | the_status |
System.String | notes |
System.String | test_case |
System.String | int_release |
System.String | user_name |
System.String | failed_date |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_fix_failed_list(String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _fix_failed_list(string cr_id, string the_status, string notes, string test_case, string int_release, string user_name, string failed_date, bool gen_time_bombs, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | the_status |
System.String | notes |
System.String | test_case |
System.String | int_release |
System.String | user_name |
System.String | failed_date |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_forward_cr(String, String, String, String, String, Boolean)

Declaration
protected short _forward_cr(string cr_id, string new_queue, string forward_date, string notes, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | new_queue |
System.String | forward_date |
System.String | notes |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_Initialize(IFCApplication, IFCSession)

Declaration
public void _Initialize(IFCApplication TheFCApplication, IFCSession TheFCSession)
Parameters
Type | Name | Description
IFCApplication | TheFCApplication |
IFCSession | TheFCSession |

_log_cr_email(String, String, String, String, String, String, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _log_cr_email(string cr_id, string log_date, string message, string recipient, string cc_list, string user_name, bool gen_time_bombs, bool send_email, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | log_date |
System.String | message |
System.String | recipient |
System.String | cc_list |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.Boolean | send_email |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_log_cr_email_list(String, String, String, String, String, String, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _log_cr_email_list(string cr_id, string log_date, string message, string recipient, string cc_list, string user_name, bool gen_time_bombs, bool send_email, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | log_date |
System.String | message |
System.String | recipient |
System.String | cc_list |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.Boolean | send_email |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_log_cr_note(String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _log_cr_note(string cr_id, string notes, string int_use, string log_date, string user_name, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | notes |
System.String | int_use |
System.String | log_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_log_cr_note_list(String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _log_cr_note_list(string cr_id, string notes, string int_use, string log_date, string user_name, bool gen_time_bombs, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | notes |
System.String | int_use |
System.String | log_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_modify_cr(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _modify_cr(string cr_num, string part_num, string mod_level, string domain, string the_title, string cr_type, string priority, string frequency, string found_on, string op_sys, string memory, string cr_class, string intro_phase, string test_class, string fixed_in, string user_name, string cr_date, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | cr_num |
System.String | part_num |
System.String | mod_level |
System.String | domain |
System.String | the_title |
System.String | cr_type |
System.String | priority |
System.String | frequency |
System.String | found_on |
System.String | op_sys |
System.String | memory |
System.String | cr_class |
System.String | intro_phase |
System.String | test_class |
System.String | fixed_in |
System.String | user_name |
System.String | cr_date |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_modify_cr_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _modify_cr_list(string cr_num, string part_num, string mod_level, string domain, string the_title, string cr_type, string priority, string frequency, string found_on, string op_sys, string memory, string cr_class, string intro_phase, string test_class, string fixed_in, string user_name, string cr_date, bool gen_time_bombs, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | cr_num |
System.String | part_num |
System.String | mod_level |
System.String | domain |
System.String | the_title |
System.String | cr_type |
System.String | priority |
System.String | frequency |
System.String | found_on |
System.String | op_sys |
System.String | memory |
System.String | cr_class |
System.String | intro_phase |
System.String | test_class |
System.String | fixed_in |
System.String | user_name |
System.String | cr_date |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_move_cr(String, String)

Declaration
protected short _move_cr(string cr_id, string new_wipbin)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | new_wipbin |
Returns
Type | Description
System.Int16 |

_reject_cr(String, String, String, String, String, Boolean)

Declaration
protected short _reject_cr(string cr_id, string reject_date, string wipbin, string notes, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | reject_date |
System.String | wipbin |
System.String | notes |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_reopen_cr(String, String, String, String, String, Boolean)

Declaration
protected short _reopen_cr(string cr_id, string the_status, string wipbin, string user_name, string reopen_date, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | the_status |
System.String | wipbin |
System.String | user_name |
System.String | reopen_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_replicate_cr(String, String, String, Boolean)

Declaration
protected short _replicate_cr(string cr_id, string user_name, string rep_date, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | user_name |
System.String | rep_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_yank_cr(String, String, String, String, Boolean)

Declaration
protected short _yank_cr(string cr_id, string wipbin, string yank_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | wipbin |
System.String | yank_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

GetProductID()

Declaration
protected abstract int GetProductID()
Returns
Type | Description
System.Int32 |


Class FCCS | fcSDK Documentation

Class FCCS

Inheritance
System.Object
FCCSBase
FCCS
Implements
IFCCS
IToolkit
Inherited Members
FCCSBase._Initialize(IFCApplication, IFCSession)
FCCSBase._change_contact(String, String, String, String, String, String, String, Boolean)
FCCSBase._change_case_status(String, String, String, String, String, Boolean)
FCCSBase._change_subcase_status(String, String, String, String, String, Boolean)
FCCSBase._close_case_list(String, String, String, String, String, String, Double, String, Boolean, IFCList, IFCList, IFCList)
FCCSBase._close_case(String, String, String, String, String, String, Double, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)
FCCSBase._close_subcase_list(String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)
FCCSBase._close_subcase(String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)
FCCSBase._create_case_objid_list(String, String, String, Int32, String, String, String, String, String, String, String, String, String, String, Boolean, Int32, Int32, Int32, Int32, Int32, IFCList, IFCList, IFCList)
FCCSBase._create_case_objid(String, String, String, Int32, String, String, String, String, String, String, String, String, String, String, Boolean, Int32, Int32, Int32, Int32, Int32, String, Int32, String, Int32, String, String, String, String, String, String)
FCCSBase._create_case_list(String, String, String, String, String, String, String, String, Int32, String, String, String, String, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)
FCCSBase._create_case(String, String, String, String, String, String, String, String, Int32, String, String, String, String, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)
FCCSBase._create_subcase_list(String, String, Boolean, String, String, String, String, String, String, String, Int32, String, Boolean, IFCList, IFCList, IFCList)
FCCSBase._create_subcase(String, String, Boolean, String, String, String, String, String, String, String, Int32, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)
FCCSBase._dispatch_case(String, String, String, String, Boolean)
FCCSBase._dispatch_subcase(String, String, String, String, Boolean)
FCCSBase._forward_case(String, String, String, String, String, Boolean)
FCCSBase._forward_subcase(String, String, String, String, String, Boolean)
FCCSBase._initial_response(String, String, String, Boolean, Boolean)
FCCSBase._yank_case(String, String, String, String, Boolean)
FCCSBase._yank_subcase(String, String, String, String, Boolean)
FCCSBase._log_case_commit(String, String, String, String, String, Int32, Boolean, String, String, String, String, String, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)
FCCSBase._log_case_commit_list(String, String, String, String, String, Int32, Boolean, String, String, String, String, String, Boolean, Boolean, IFCList, IFCList, IFCList)
FCCSBase._log_subcase_commit_list(String, String, String, String, String, Int32, Boolean, String, String, String, String, String, Boolean, Boolean, IFCList, IFCList, IFCList)
FCCSBase._log_subcase_commit(String, String, String, String, String, Int32, Boolean, String, String, String, String, String, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)
FCCSBase._modify_case_commit(String, String, String, String, Int32, Int32, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)
FCCSBase._modify_case_commit_list(String, String, String, String, Int32, Int32, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)
FCCSBase._modify_subcase_commit(String, String, String, String, Int32, Int32, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)
FCCSBase._modify_subcase_commit_list(String, String, String, String, Int32, Int32, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)
FCCSBase._fulfill_commitment(Int32, String, String, Boolean)
FCCSBase._move_case(String, String)
FCCSBase._move_subcase(String, String)
FCCSBase._accept_case(String, String, String, String, Boolean)
FCCSBase._accept_subcase(String, String, String, String, Boolean)
FCCSBase._reject_case(String, String, String, String, String, Boolean)
FCCSBase._reject_subcase(String, String, String, String, String, Boolean)
FCCSBase._assign_case(String, String, String, String, String, Boolean)
FCCSBase._assign_subcase(String, String, String, String, String, Boolean)
FCCSBase._modify_case_list_setup(String, String, String, String, String, String, Boolean, Boolean, Boolean, String, Int32, Int32, Int32, IFCList, IFCList, IFCList)
FCCSBase._modify_case_list(String, String, String, String, String, String, Boolean, Boolean, String, Int32, Int32, Int32, IFCList, IFCList, IFCList)
FCCSBase._modify_case(String, String, String, String, String, String, Boolean, Boolean, String, Int32, Int32, Int32, String, Int32, String, Int32, String, String, String, String, String, String)
FCCSBase._modify_subcase_list(String, String, String, String, String, Boolean, Boolean, IFCList, IFCList, IFCList)
FCCSBase._modify_subcase_list_setup(String, String, String, String, String, Boolean, Boolean, Boolean, IFCList, IFCList, IFCList)
FCCSBase._modify_subcase(String, String, String, String, String, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)
FCCSBase._reopen_case(String, String, String, String, String, Boolean)
FCCSBase._reopen_subcase(String, String, String, String, String, Boolean)
FCCSBase._log_case_phone(String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int32, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)
FCCSBase._log_subcase_phone(String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int32, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)
FCCSBase._log_case_phone_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int32, Boolean, Boolean, IFCList, IFCList, IFCList)
FCCSBase._log_subcase_phone_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int32, Boolean, Boolean, IFCList, IFCList, IFCList)
FCCSBase._log_case_resrch(String, String, String, String, String, Int32, String, String, String, String, String, Int32, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)
FCCSBase._log_subcase_resrch(String, String, String, String, String, Int32, String, String, String, String, String, Int32, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)
FCCSBase._log_case_resrch_list(String, String, String, String, String, Int32, String, String, String, String, String, Int32, Boolean, Boolean, IFCList, IFCList, IFCList)
FCCSBase._log_subcase_resrch_list(String, String, String, String, String, Int32, String, String, String, String, String, Int32, Boolean, Boolean, IFCList, IFCList, IFCList)
FCCSBase._log_case_note(String, String, String, String, String, String, String, String, String, String, Int32, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)
FCCSBase._log_subcase_note(String, String, String, String, String, String, String, String, String, String, Int32, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)
FCCSBase._log_case_note_list(String, String, String, String, String, String, String, String, String, String, Int32, Boolean, Boolean, IFCList, IFCList, IFCList)
FCCSBase._log_subcase_note_list(String, String, String, String, String, String, String, String, String, String, Int32, Boolean, Boolean, IFCList, IFCList, IFCList)
FCCSBase._case_is_child(IFCGeneric, String)
FCCSBase._relate_case_to_parent(String, String)
FCCSBase._unrelate_case_from_parent(String)
FCCSBase._log_object_email(String, String, String, String, String, String, String, String, String, String, String, Int32, Boolean, String, Int32, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String, String)
FCCSBase._log_case_email(String, String, String, String, String, String, String, String, String, String, String, Int32, Boolean, String, Int32, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)
FCCSBase._log_case_email_list(String, String, String, String, String, String, String, String, String, String, String, Int32, Boolean, String, Int32, Boolean, Boolean, IFCList, IFCList, IFCList)
FCCSBase._log_subcase_email(String, String, String, String, String, String, String, String, String, String, String, Int32, Boolean, String, Int32, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)
FCCSBase._log_subcase_email_list(String, String, String, String, String, String, String, String, String, String, String, Int32, Boolean, String, Int32, Boolean, Boolean, IFCList, IFCList, IFCList)
FCCSBase._preclose_case(String)
FCCSBase._preclose_subcase(String)
FCCSBase._ret_objid
FCCSBase._ret_objid2
FCCSBase._ret_objid3
FCCSBase._ret_id_num
FCCSBase._UseDenormalizedCaseTypeLevels
FCCSBase._impersonatorUserName
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Compatibility.Toolkits
Assembly: FChoice.Foundation.Clarify.Compatibility.Toolkits.dll
Syntax
[Guid("3A5AC0C4-04A2-4bb6-96C9-7033979EC7FD")]
[ComVisible(true)]
[AltName("Support")]
[ClassInterface(ClassInterfaceType.None)]
public sealed class FCCS : FCCSBase, IFCCS, IToolkit

Constructors

FCCS()

Declaration
public FCCS()

FCCS(IFCApplication, IFCSession)

Declaration
public FCCS(IFCApplication FCApp, IFCSession FCSess)
Parameters
Type | Name | Description
IFCApplication | FCApp |
IFCSession | FCSess |

Methods

GetProductID()

Declaration
protected override int GetProductID()
Returns
Type | Description
System.Int32 |
Overrides
FCCSBase.GetProductID()

Explicit Interface Implementations

IFCCS.accept_case(String, String, String, String, Boolean)

Declaration
public short IFCCS.accept_case([ParameterRequired, AltName("case_IDNum")] string case_id, string accept_date, [AltName("wip_bin")] string wipbin_name, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | case_id |
System.String | accept_date |
System.String | wipbin_name |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCS.accept_subcase(String, String, String, String, Boolean)

Declaration
public short IFCCS.accept_subcase([ParameterRequired, AltName("subcase_IDNum")] string subcase_id, string accept_date, [AltName("wip_bin")] string wipbin_name, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | accept_date |
System.String | wipbin_name |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCS.assign_case(String, String, String, String, String, Boolean)

Declaration
public short IFCCS.assign_case([ParameterRequired, AltName("case_IDNum")] string case_id, string new_user, [AltName("wip_bin")] string wipbin_name, string assign_date, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | case_id |
System.String | new_user |
System.String | wipbin_name |
System.String | assign_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCS.assign_subcase(String, String, String, String, String, Boolean)

Declaration
public short IFCCS.assign_subcase([ParameterRequired, AltName("subcase_IDNum")] string subcase_id, string new_user, [AltName("wip_bin")] string wipbin_name, string assign_date, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | new_user |
System.String | wipbin_name |
System.String | assign_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCS.change_case_status(String, String, String, String, String, Boolean)

Declaration
public short IFCCS.change_case_status([ParameterRequired, AltName("Case_IDNum")] string case_id, string new_status, string change_date, [AltName("notes")] string note_str, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | case_id |
System.String | new_status |
System.String | change_date |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCS.change_contact(String, String, String, String, String, String, String, Boolean)

Declaration
[SplitMethod("change_case_contact")]
[SplitMethod("change_case_site")]
public short IFCCS.change_contact([ParameterRequired, AltName("Case_IDNum")] string case_id, [ParameterRequired("change_case_contact"), AltName("Contact_First_Name")] string f_name, [ParameterRequired("change_case_contact"), AltName("Contact_Last_Name")] string l_name, [ParameterRequired("change_case_contact"), AltName("Contact_Phone")] string phone_num, [ParameterRequired("change_case_site"), ParameterVoid("change_case_contact"), AltName("Site_IDNum")] string site_id, string change_date, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | case_id |
System.String | f_name |
System.String | l_name |
System.String | phone_num |
System.String | site_id |
System.String | change_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCS.change_subcase_status(String, String, String, String, String, Boolean)

Declaration
public short IFCCS.change_subcase_status([ParameterRequired, AltName("subcase_IDNum")] string subcase_id, string new_status, string change_date, [AltName("notes")] string note_str, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | new_status |
System.String | change_date |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCS.close_case(String, String, String, String, String, String, Double, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[FacadeVoid]
[OutputProperty("ret_objid")]
public short IFCCS.close_case(string case_id, string the_status, string resolution_str, string summary_str, string user_name, string close_date, double units_used, string close_sums, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | case_id |
System.String | the_status |
System.String | resolution_str |
System.String | summary_str |
System.String | user_name |
System.String | close_date |
System.Double | units_used |
System.String | close_sums |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCS.close_case_list(String, String, String, String, String, String, Double, String, Boolean, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[OutputProperty("ret_objid", "The newly created CloseCase object.")]
public short IFCCS.close_case_list([ParameterRequired, AltName("case_IDNum")] string case_id, [AltName("status")] string the_status, [AltName("resolution")] string resolution_str, [AltName("summary")] string summary_str, string user_name, string close_date, double units_used, [CheckIsNull(70018), AltName("case_time_and_expenses"), AltType("FChoice.Toolkits.Clarify.Support.CaseTimeAndExpenses", "{0}.ToCloseCaseSummaryString()"), ParameterDefaultValue("FChoice.Toolkits.Clarify.Support.CaseTimeAndExpenses.EMPTY")] string close_sums, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | case_id |
System.String | the_status |
System.String | resolution_str |
System.String | summary_str |
System.String | user_name |
System.String | close_date |
System.Double | units_used |
System.String | close_sums |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCCS.close_subcase(String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[FacadeVoid]
public short IFCCS.close_subcase(string subcase_id, string the_status, string resolution_str, string summary_str, string user_name, string close_date, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | the_status |
System.String | resolution_str |
System.String | summary_str |
System.String | user_name |
System.String | close_date |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCS.close_subcase_list(String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[OutputProperty("ret_objid", "The newly created CloseCase object.")]
public short IFCCS.close_subcase_list([ParameterRequired, AltName("subcase_IDNum")] string subcase_id, [AltName("status")] string the_status, [AltName("resolution")] string resolution_str, [AltName("summary")] string summary_str, string user_name, string close_date, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | the_status |
System.String | resolution_str |
System.String | summary_str |
System.String | user_name |
System.String | close_date |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCCS.create_case(String, String, String, String, String, String, String, String, Int32, String, String, String, String, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[FacadeVoid]
[OutputProperty("ret_objid")]
[OutputProperty("ret_id_num")]
public short IFCCS.create_case(string site_id, string f_name, string l_name, string phone_num, string part_num, string mod_level, string domain_name, string serial_no, int sp_objid, string contract_id, string the_title, string case_type, string priority_str, string severity_str, string status_str, string phone_log, string queue_name, string cr_date, string phone_end_date, string user_name, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | site_id |
System.String | f_name |
System.String | l_name |
System.String | phone_num |
System.String | part_num |
System.String | mod_level |
System.String | domain_name |
System.String | serial_no |
System.Int32 | sp_objid |
System.String | contract_id |
System.String | the_title |
System.String | case_type |
System.String | priority_str |
System.String | severity_str |
System.String | status_str |
System.String | phone_log |
System.String | queue_name |
System.String | cr_date |
System.String | phone_end_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCS.create_case_list(String, String, String, String, String, String, String, String, Int32, String, String, String, String, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[OutputProperty("ret_objid", "Case")]
[OutputProperty("ret_id_num", "Case")]
public short IFCCS.create_case_list([ParameterRequired, AltName("site_IDNum")] string site_id, [ParameterRequired, AltName("contact_First_Name")] string f_name, [ParameterRequired, AltName("contact_Last_Name")] string l_name, [ParameterRequired, AltName("contact_Phone")] string phone_num, [AltName("part_Number")] string part_num, [AltName("part_Revision")] string mod_level, [AltName("part_Domain")] string domain_name, [AltName("serial_Number")] string serial_no, [AltName("Site_Part_ObjID")] int sp_objid, [AltName("contract_IDNum")] string contract_id, [AltName("title")] string the_title, string case_type, [AltName("priority")] string priority_str, [AltName("severity")] string severity_str, [AltName("status")] string status_str, [AltName("Phone_Log_Notes")] string phone_log, [AltName("queue")] string queue_name, [AltName("create_date")] string cr_date, string phone_end_date, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | site_id |
System.String | f_name |
System.String | l_name |
System.String | phone_num |
System.String | part_num |
System.String | mod_level |
System.String | domain_name |
System.String | serial_no |
System.Int32 | sp_objid |
System.String | contract_id |
System.String | the_title |
System.String | case_type |
System.String | priority_str |
System.String | severity_str |
System.String | status_str |
System.String | phone_log |
System.String | queue_name |
System.String | cr_date |
System.String | phone_end_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCCS.create_case_objid(String, String, String, Int32, String, String, String, String, String, String, String, String, String, String, Boolean, Int32, Int32, Int32, Int32, Int32, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[ToolkitVisible(false)]
[FacadeVoid]
public short IFCCS.create_case_objid(string f_name, string l_name, string phone_num, int sp_objid, string the_title, string case_type, string priority_str, string severity_str, string status_str, string phone_log, string queue_name, string cr_date, string phone_end_date, string user_name, bool gen_time_bombs, int contact_objid, int site_objid, int ml_objid, int contract_objid, int addr_objid, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | f_name |
System.String | l_name |
System.String | phone_num |
System.Int32 | sp_objid |
System.String | the_title |
System.String | case_type |
System.String | priority_str |
System.String | severity_str |
System.String | status_str |
System.String | phone_log |
System.String | queue_name |
System.String | cr_date |
System.String | phone_end_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.Int32 | contact_objid |
System.Int32 | site_objid |
System.Int32 | ml_objid |
System.Int32 | contract_objid |
System.Int32 | addr_objid |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCS.create_case_objid_list(String, String, String, Int32, String, String, String, String, String, String, String, String, String, String, Boolean, Int32, Int32, Int32, Int32, Int32, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[OutputProperty("ret_objid", "Case")]
[OutputProperty("ret_id_num", "Case")]
public short IFCCS.create_case_objid_list([AltName("Contact_First_Name")] string f_name, [AltName("Contact_Last_Name")] string l_name, [AltName("Contact_Phone")] string phone_num, [AltName("site_Part_ObjID")] int sp_objid, [AltName("title")] string the_title, string case_type, [AltName("priority")] string priority_str, [AltName("serverity")] string severity_str, [AltName("status")] string status_str, [AltName("Phone_Log_Notes")] string phone_log, [AltName("queue")] string queue_name, [AltName("create_date")] string cr_date, string phone_end_date, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs, [AltName("contact_ObjID")] int contact_objid, [AltName("site_ObjID")] int site_objid, [AltName("Part_Revision_Objid")] int ml_objid, int contract_objid, [AltName("Address_ObjID")] int addr_objid, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | f_name |
System.String | l_name |
System.String | phone_num |
System.Int32 | sp_objid |
System.String | the_title |
System.String | case_type |
System.String | priority_str |
System.String | severity_str |
System.String | status_str |
System.String | phone_log |
System.String | queue_name |
System.String | cr_date |
System.String | phone_end_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.Int32 | contact_objid |
System.Int32 | site_objid |
System.Int32 | ml_objid |
System.Int32 | contract_objid |
System.Int32 | addr_objid |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCCS.create_subcase(String, String, Boolean, String, String, String, String, String, String, String, Int32, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[FacadeVoid]
[OutputProperty("ret_objid")]
[OutputProperty("ret_objid")]
[OutputProperty("ret_id_num")]
public short IFCCS.create_subcase(string case_id, string the_title, bool is_general, string priority_str, string severity_str, string status_str, string note_str, string queue_name, string cr_date, string due_date, int prior_warn, string user_name, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | case_id |
System.String | the_title |
System.Boolean | is_general |
System.String | priority_str |
System.String | severity_str |
System.String | status_str |
System.String | note_str |
System.String | queue_name |
System.String | cr_date |
System.String | due_date |
System.Int32 | prior_warn |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCS.create_subcase_list(String, String, Boolean, String, String, String, String, String, String, String, Int32, String, Boolean, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[OutputProperty("ret_objid", "Subcase")]
[OutputProperty("ret_id_num", "Subcase")]
public short IFCCS.create_subcase_list([ParameterRequired, AltName("case_IDNum")] string case_id, [AltName("title")] string the_title, [ParameterDefaultValue("true")] bool is_general, [AltName("priority")] string priority_str, [AltName("severity")] string severity_str, [AltName("status")] string status_str, [AltName("notes")] string note_str, [AltName("queue")] string queue_name, [AltName("create_date")] string cr_date, string due_date, [AltName("prior_Warning"), AltType("System.TimeSpan", "Convert.ToInt32({0}.TotalSeconds)")] int prior_warn, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | case_id |
System.String | the_title |
System.Boolean | is_general |
System.String | priority_str |
System.String | severity_str |
System.String | status_str |
System.String | note_str |
System.String | queue_name |
System.String | cr_date |
System.String | due_date |
System.Int32 | prior_warn |
System.String | user_name |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCCS.dispatch_case(String, String, String, String, Boolean)

Declaration
public short IFCCS.dispatch_case([ParameterRequired, AltName("case_IDNum")] string case_id, [ParameterRequired, AltName("queue")] string queue_name, [AltName("dispatch_date")] string disp_date, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | case_id |
System.String | queue_name |
System.String | disp_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCS.dispatch_subcase(String, String, String, String, Boolean)

Declaration
public short IFCCS.dispatch_subcase([ParameterRequired, AltName("subcase_IDNum")] string subcase_id, [ParameterRequired, AltName("queue")] string queue_name, [AltName("dispatch_date")] string disp_date, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | queue_name |
System.String | disp_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCS.forward_case(String, String, String, String, String, Boolean)

Declaration
public short IFCCS.forward_case([ParameterRequired, AltName("case_IDNum")] string case_id, [ParameterRequired] string new_queue, string forward_date, [AltName("notes")] string note_str, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | case_id |
System.String | new_queue |
System.String | forward_date |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCS.forward_subcase(String, String, String, String, String, Boolean)

Declaration
public short IFCCS.forward_subcase([ParameterRequired, AltName("subcase_IDNum")] string subcase_id, [ParameterRequired] string new_queue, string forward_date, [AltName("notes")] string note_str, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | new_queue |
System.String | forward_date |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCS.fulfill_commitment(Int32, String, String, Boolean)

Declaration
public short IFCCS.fulfill_commitment([ParameterRequired] int log_objid, string fulfill_date, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.Int32 | log_objid |
System.String | fulfill_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCS.impersonatorUserName

Declaration
public string IFCCS.impersonatorUserName { get; set; }
Returns
Type | Description
System.String |

IFCCS.initial_response(String, String, String, Boolean, Boolean)

Declaration
public short IFCCS.initial_response([ParameterRequired, AltName("case_IDNum")] string case_id, [AltName("response_date")] string resp_date, string user_name, [AltName("IsVIAPhone")] bool via_phone, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | case_id |
System.String | resp_date |
System.String | user_name |
System.Boolean | via_phone |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCS.Initialize(IFCApplication, IFCSession)

Declaration
[ToolkitVisible(false)]
public void IFCCS.Initialize(IFCApplication FCApp, IFCSession FCSess)
Parameters
Type | Name | Description
IFCApplication | FCApp |
IFCSession | FCSess |

IFCCS.log_case_commit(String, String, String, String, String, Int32, Boolean, String, String, String, String, String, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[OutputProperty("ret_objid")]
[FacadeVoid]
public short IFCCS.log_case_commit(string case_id, string the_title, string action_type, string log_date, string commit_date, int prior_warn, bool made_to, string cont_first, string cont_last, string cont_phone, string note_str, string user_name, bool gen_time_bombs, bool generate_commit_email, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | case_id |
System.String | the_title |
System.String | action_type |
System.String | log_date |
System.String | commit_date |
System.Int32 | prior_warn |
System.Boolean | made_to |
System.String | cont_first |
System.String | cont_last |
System.String | cont_phone |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.Boolean | generate_commit_email |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCS.log_case_commit_list(String, String, String, String, String, Int32, Boolean, String, String, String, String, String, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[OutputProperty("ret_objid", "Log")]
[AltName("log_case_commitment")]
public short IFCCS.log_case_commit_list([ParameterRequired, AltName("case_IDNum")] string case_id, [ParameterRequired, AltName("title")] string the_title, string action_type, string log_date, [AltName("commitment_date")] string commit_date, [ParameterRequired, AltName("prior_Warning"), AltType("System.TimeSpan", "Convert.ToInt32({0}.TotalSeconds)")] int prior_warn, [ParameterDefaultValue("true"), AltName("is_Made_To_Customer")] bool made_to, [ParameterRequired, AltName("contact_First_Name")] string cont_first, [ParameterRequired, AltName("contact_Last_Name")] string cont_last, [ParameterRequired, AltName("contact_Phone")] string cont_phone, [AltName("notes")] string note_str, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs, [AltName("generate_Commitment_Email")] bool generate_commit_email, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | case_id |
System.String | the_title |
System.String | action_type |
System.String | log_date |
System.String | commit_date |
System.Int32 | prior_warn |
System.Boolean | made_to |
System.String | cont_first |
System.String | cont_last |
System.String | cont_phone |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.Boolean | generate_commit_email |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCCS.log_case_email(String, String, String, String, String, String, String, String, String, String, String, Int32, Boolean, String, Int32, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[FacadeVoid]
[OutputProperty("ret_objid")]
[OutputProperty("ret_objid2")]
[OutputProperty("ret_objid3")]
public short IFCCS.log_case_email(string case_id, string action_type, string log_date, string message, string recipient, string cc_list, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, string cmit_action_type, int cmit_contact_objid, bool gen_time_bombs, bool send_email, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | case_id |
System.String | action_type |
System.String | log_date |
System.String | message |
System.String | recipient |
System.String | cc_list |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.String | cmit_action_type |
System.Int32 | cmit_contact_objid |
System.Boolean | gen_time_bombs |
System.Boolean | send_email |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCS.log_case_email_list(String, String, String, String, String, String, String, String, String, String, String, Int32, Boolean, String, Int32, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[OutputProperty("ret_objid", "Log")]
[OutputProperty("ret_objid2", "CommitmentObjid", "System.Int32", "0", "Commitment")]
[OutputProperty("ret_objid3", "StatusChangeObjid", "System.Int32", "0", "StatusChange")]
public short IFCCS.log_case_email_list([ParameterRequired, AltName("case_IDNum")] string case_id, string action_type, string log_date, string message, string recipient, [AltName("CC_List")] string cc_list, string user_name, [AltName("new_status")] string new_stat, [AltName("commitment_title")] string cmit_title, [AltName("commitment_notes")] string cmit_notes, [AltName("commitment_due_date")] string cmit_due, [AltName("commitment_prior_warning"), AltType("System.TimeSpan", "Convert.ToInt32({0}.TotalSeconds)")] int cmit_prior, [AltName("is_commitment_to_customer")] bool cmit_to, [AltName("commitment_action_type")] string cmit_action_type, [AltName("commitment_contact_ObjID")] int cmit_contact_objid, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs, [ParameterDefaultValue("true")] bool send_email, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | case_id |
System.String | action_type |
System.String | log_date |
System.String | message |
System.String | recipient |
System.String | cc_list |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.String | cmit_action_type |
System.Int32 | cmit_contact_objid |
System.Boolean | gen_time_bombs |
System.Boolean | send_email |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCCS.log_case_note(String, String, String, String, String, String, String, String, String, String, Int32, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[FacadeVoid]
[OutputProperty("ret_objid")]
[OutputProperty("ret_objid2")]
[OutputProperty("ret_objid3")]
public short IFCCS.log_case_note(string case_id, string action_type, string note_str, string int_use, string log_date, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | case_id |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCS.log_case_note_list(String, String, String, String, String, String, String, String, String, String, Int32, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[OutputProperty("ret_objid", "Log")]
[OutputProperty("ret_objid2", "CommitmentObjid", "System.Int32", "0", "Commitment")]
[OutputProperty("ret_objid3", "StatusChangeObjid", "System.Int32", "0", "StatusChange")]
public short IFCCS.log_case_note_list([ParameterRequired, AltName("case_IDNum")] string case_id, string action_type, [AltName("notes")] string note_str, [AltName("Internal_Use_Only_Notes")] string int_use, string log_date, string user_name, [AltName("new_Status")] string new_stat, [AltName("commitment_Title")] string cmit_title, [AltName("commitment_Notes")] string cmit_notes, [AltName("commitment_Due_date")] string cmit_due, [AltName("commitment_Prior_Warning"), AltType("System.TimeSpan", "Convert.ToInt32({0}.TotalSeconds)")] int cmit_prior, [AltName("is_commitment_to_customer")] bool cmit_to, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | case_id |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCCS.log_case_phone(String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int32, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[FacadeVoid]
[OutputProperty("ret_objid")]
[OutputProperty("ret_objid2")]
[OutputProperty("ret_objid3")]
public short IFCCS.log_case_phone(string case_id, string cont_first, string cont_last, string cont_phone, string action_type, string note_str, string int_use, string log_date, string log_end_date, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | case_id |
System.String | cont_first |
System.String | cont_last |
System.String | cont_phone |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.String | log_end_date |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCS.log_case_phone_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int32, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[OutputProperty("ret_objid", "Log")]
[OutputProperty("ret_objid2", "CommitmentObjid", "System.Int32", "0", "Commitment")]
[OutputProperty("ret_objid3", "StatusChangeObjid", "System.Int32", "0", "StatusChange")]
public short IFCCS.log_case_phone_list([ParameterRequired, AltName("case_IDNum")] string case_id, [ParameterRequired, AltName("contact_First_Name")] string cont_first, [ParameterRequired, AltName("contact_Last_Name")] string cont_last, [ParameterRequired, AltName("contact_Phone")] string cont_phone, string action_type, [AltName("notes")] string note_str, [AltName("Internal_Use_Only_Notes")] string int_use, string log_date, string log_end_date, string user_name, [AltName("new_Status")] string new_stat, [AltName("commitment_Title")] string cmit_title, [AltName("commitment_Notes")] string cmit_notes, [AltName("commitment_Due_date")] string cmit_due, [AltName("commitment_Prior_Warning"), AltType("System.TimeSpan", "Convert.ToInt32({0}.TotalSeconds)")] int cmit_prior, [AltName("is_commitment_to_customer")] bool cmit_to, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | case_id |
System.String | cont_first |
System.String | cont_last |
System.String | cont_phone |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.String | log_end_date |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCCS.log_case_resrch(String, String, String, String, String, Int32, String, String, String, String, String, Int32, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[FacadeVoid]
[OutputProperty("ret_objid")]
[OutputProperty("ret_objid2")]
[OutputProperty("ret_objid3")]
public short IFCCS.log_case_resrch(string case_id, string action_type, string note_str, string int_use, string log_date, int research_time, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | case_id |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.Int32 | research_time |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCS.log_case_resrch_list(String, String, String, String, String, Int32, String, String, String, String, String, Int32, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[OutputProperty("ret_objid", "Log")]
[OutputProperty("ret_objid2", "CommitmentObjid", "System.Int32", "0", "Commitment")]
[OutputProperty("ret_objid3", "StatusChangeObjid", "System.Int32", "0", "StatusChange")]
[AltName("log_case_research")]
public short IFCCS.log_case_resrch_list([ParameterRequired, AltName("case_IDNum")] string case_id, string action_type, [AltName("notes")] string note_str, [AltName("Internal_Use_Only_Notes")] string int_use, string log_date, [ParameterRequired, AltName("research_Duration"), AltType("System.TimeSpan", "Convert.ToInt32({0}.TotalSeconds)")] int research_time, string user_name, [AltName("new_Status")] string new_stat, [AltName("commitment_Title")] string cmit_title, [AltName("commitment_Notes")] string cmit_notes, [AltName("commitment_Due_date")] string cmit_due, [AltName("commitment_Prior_Warning"), AltType("System.TimeSpan", "Convert.ToInt32({0}.TotalSeconds)")] int cmit_prior, [AltName("is_commitment_to_customer")] bool cmit_to, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | case_id |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.Int32 | research_time |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCCS.log_subcase_commit(String, String, String, String, String, Int32, Boolean, String, String, String, String, String, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[OutputProperty("ret_objid")]
[FacadeVoid]
public short IFCCS.log_subcase_commit(string subcase_id, string the_title, string action_type, string log_date, string commit_date, int prior_warn, bool made_to, string cont_first, string cont_last, string cont_phone, string note_str, string user_name, bool gen_time_bombs, bool generate_commit_email, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | the_title |
System.String | action_type |
System.String | log_date |
System.String | commit_date |
System.Int32 | prior_warn |
System.Boolean | made_to |
System.String | cont_first |
System.String | cont_last |
System.String | cont_phone |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.Boolean | generate_commit_email |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCS.log_subcase_commit_list(String, String, String, String, String, Int32, Boolean, String, String, String, String, String, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[OutputProperty("ret_objid", "Log")]
[AltName("log_subcase_commitment")]
public short IFCCS.log_subcase_commit_list([ParameterRequired, AltName("subcase_IDNum")] string subcase_id, [ParameterRequired, AltName("title")] string the_title, string action_type, string log_date, [AltName("commitment_date")] string commit_date, [ParameterRequired, AltName("prior_Warning"), AltType("System.TimeSpan", "Convert.ToInt32({0}.TotalSeconds)")] int prior_warn, [ParameterDefaultValue("true"), AltName("is_Made_To_Customer")] bool made_to, [ParameterRequired, AltName("contact_First_Name")] string cont_first, [ParameterRequired, AltName("contact_Last_Name")] string cont_last, [ParameterRequired, AltName("contact_Phone")] string cont_phone, [AltName("notes")] string note_str, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs, [AltName("generate_Commitment_Email")] bool generate_commit_email, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | the_title |
System.String | action_type |
System.String | log_date |
System.String | commit_date |
System.Int32 | prior_warn |
System.Boolean | made_to |
System.String | cont_first |
System.String | cont_last |
System.String | cont_phone |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.Boolean | generate_commit_email |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCCS.log_subcase_email(String, String, String, String, String, String, String, String, String, String, String, Int32, Boolean, String, Int32, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[FacadeVoid]
[OutputProperty("ret_objid")]
[OutputProperty("ret_objid2")]
[OutputProperty("ret_objid3")]
public short IFCCS.log_subcase_email(string case_id, string action_type, string log_date, string message, string recipient, string cc_list, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, string cmit_action_type, int cmit_contact_objid, bool gen_time_bombs, bool send_email, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | case_id |
System.String | action_type |
System.String | log_date |
System.String | message |
System.String | recipient |
System.String | cc_list |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.String | cmit_action_type |
System.Int32 | cmit_contact_objid |
System.Boolean | gen_time_bombs |
System.Boolean | send_email |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCS.log_subcase_email_list(String, String, String, String, String, String, String, String, String, String, String, Int32, Boolean, String, Int32, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[OutputProperty("ret_objid", "Log")]
[OutputProperty("ret_objid2", "CommitmentObjid", "System.Int32", "0", "Commitment")]
[OutputProperty("ret_objid3", "StatusChangeObjid", "System.Int32", "0", "StatusChange")]
public short IFCCS.log_subcase_email_list([ParameterRequired, AltName("subcase_IDNum")] string case_id, string action_type, string log_date, string message, string recipient, [AltName("CC_List")] string cc_list, string user_name, [AltName("new_status")] string new_stat, [AltName("commitment_title")] string cmit_title, [AltName("commitment_notes")] string cmit_notes, [AltName("commitment_due_date")] string cmit_due, [AltName("commitment_prior_warning"), AltType("System.TimeSpan", "Convert.ToInt32({0}.TotalSeconds)")] int cmit_prior, [AltName("is_commitment_to_customer")] bool cmit_to, [AltName("commitment_action_type")] string cmit_action_type, [AltName("commitment_contact_ObjID")] int cmit_contact_objid, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs, [ParameterDefaultValue("true")] bool send_email, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | case_id |
System.String | action_type |
System.String | log_date |
System.String | message |
System.String | recipient |
System.String | cc_list |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.String | cmit_action_type |
System.Int32 | cmit_contact_objid |
System.Boolean | gen_time_bombs |
System.Boolean | send_email |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCCS.log_subcase_note(String, String, String, String, String, String, String, String, String, String, Int32, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[FacadeVoid]
[OutputProperty("ret_objid")]
[OutputProperty("ret_objid2")]
[OutputProperty("ret_objid3")]
public short IFCCS.log_subcase_note(string subcase_id, string action_type, string note_str, string int_use, string log_date, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCS.log_subcase_note_list(String, String, String, String, String, String, String, String, String, String, Int32, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[OutputProperty("ret_objid", "Log")]
[OutputProperty("ret_objid2", "CommitmentObjid", "System.Int32", "0", "Commitment")]
[OutputProperty("ret_objid3", "StatusChangeObjid", "System.Int32", "0", "StatusChange")]
public short IFCCS.log_subcase_note_list([ParameterRequired, AltName("subcase_IDNum")] string subcase_id, string action_type, [AltName("notes")] string note_str, [AltName("Internal_Use_Only_Notes")] string int_use, string log_date, string user_name, [AltName("new_Status")] string new_stat, [AltName("commitment_Title")] string cmit_title, [AltName("commitment_Notes")] string cmit_notes, [AltName("commitment_Due_date")] string cmit_due, [AltName("commitment_Prior_Warning"), AltType("System.TimeSpan", "Convert.ToInt32({0}.TotalSeconds)")] int cmit_prior, [AltName("is_commitment_to_customer")] bool cmit_to, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCCS.log_subcase_phone(String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int32, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[FacadeVoid]
[OutputProperty("ret_objid")]
[OutputProperty("ret_objid2")]
[OutputProperty("ret_objid3")]
public short IFCCS.log_subcase_phone(string subcase_id, string cont_first, string cont_last, string cont_phone, string action_type, string note_str, string int_use, string log_date, string log_end_date, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | cont_first |
System.String | cont_last |
System.String | cont_phone |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.String | log_end_date |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCS.log_subcase_phone_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int32, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[OutputProperty("ret_objid", "Log")]
[OutputProperty("ret_objid2", "CommitmentObjid", "System.Int32", "0", "Commitment")]
[OutputProperty("ret_objid3", "StatusChangeObjid", "System.Int32", "0", "StatusChange")]
public short IFCCS.log_subcase_phone_list([ParameterRequired, AltName("subcase_IDNum")] string subcase_id, [ParameterRequired, AltName("contact_First_Name")] string cont_first, [ParameterRequired, AltName("contact_Last_Name")] string cont_last, [ParameterRequired, AltName("contact_Phone")] string cont_phone, string action_type, [AltName("notes")] string note_str, [AltName("Internal_Use_Only_Notes")] string int_use, string log_date, string log_end_date, string user_name, [AltName("new_Status")] string new_stat, [AltName("commitment_Title")] string cmit_title, [AltName("commitment_Notes")] string cmit_notes, [AltName("commitment_Due_date")] string cmit_due, [AltName("commitment_Prior_Warning"), AltType("System.TimeSpan", "Convert.ToInt32({0}.TotalSeconds)")] int cmit_prior, [AltName("is_commitment_to_customer")] bool cmit_to, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | cont_first |
System.String | cont_last |
System.String | cont_phone |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.String | log_end_date |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCCS.log_subcase_resrch(String, String, String, String, String, Int32, String, String, String, String, String, Int32, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[FacadeVoid]
[OutputProperty("ret_objid")]
[OutputProperty("ret_objid2")]
[OutputProperty("ret_objid3")]
public short IFCCS.log_subcase_resrch(string subcase_id, string action_type, string note_str, string int_use, string log_date, int research_time, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.Int32 | research_time |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCS.log_subcase_resrch_list(String, String, String, String, String, Int32, String, String, String, String, String, Int32, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[OutputProperty("ret_objid", "Log")]
[OutputProperty("ret_objid2", "CommitmentObjid", "System.Int32", "0", "Commitment")]
[OutputProperty("ret_objid3", "StatusChangeObjid", "System.Int32", "0", "StatusChange")]
[AltName("log_subcase_research")]
public short IFCCS.log_subcase_resrch_list([ParameterRequired, AltName("subcase_IDNum")] string subcase_id, string action_type, [AltName("notes")] string note_str, [AltName("Internal_Use_Only_Notes")] string int_use, string log_date, [ParameterRequired, AltName("research_Duration"), AltType("System.TimeSpan", "Convert.ToInt32({0}.TotalSeconds)")] int research_time, string user_name, [AltName("new_Status")] string new_stat, [AltName("commitment_Title")] string cmit_title, [AltName("commitment_Notes")] string cmit_notes, [AltName("commitment_Due_date")] string cmit_due, [AltName("commitment_Prior_Warning"), AltType("System.TimeSpan", "Convert.ToInt32({0}.TotalSeconds)")] int cmit_prior, [AltName("is_commitment_to_customer")] bool cmit_to, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.Int32 | research_time |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCCS.modify_case(String, String, String, String, String, String, Boolean, Boolean, String, Int32, Int32, Int32, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[FacadeVoid]
public short IFCCS.modify_case(string case_id, string priority_str, string severity_str, string case_type, string user_name, string mod_date, bool only_owner, bool gen_time_bombs, string the_title, int ml_obj, int sp_obj, int contr_obj, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | case_id |
System.String | priority_str |
System.String | severity_str |
System.String | case_type |
System.String | user_name |
System.String | mod_date |
System.Boolean | only_owner |
System.Boolean | gen_time_bombs |
System.String | the_title |
System.Int32 | ml_obj |
System.Int32 | sp_obj |
System.Int32 | contr_obj |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCS.modify_case_commit(String, String, String, String, Int32, Int32, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[FacadeVoid]
[OutputProperty("ret_objid")]
public short IFCCS.modify_case_commit(string case_id_num, string the_title, string action_type, string commit_date, int commit_objid, int prior_warn, string made_to_str, string cont_first, string cont_last, string cont_phone, string note_str, string mod_date, string user_name, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | case_id_num |
System.String | the_title |
System.String | action_type |
System.String | commit_date |
System.Int32 | commit_objid |
System.Int32 | prior_warn |
System.String | made_to_str |
System.String | cont_first |
System.String | cont_last |
System.String | cont_phone |
System.String | note_str |
System.String | mod_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCS.modify_case_commit_list(String, String, String, String, Int32, Int32, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[AltName("Update_case_commitment")]
public short IFCCS.modify_case_commit_list([ParameterRequired, AltName("case_IDNum")] string case_id_num, [AltName("title")] string the_title, string action_type, [ParameterRequired, AltName("commitment_date")] string commit_date, [ParameterRequired, AltName("commitment_ObjID")] int commit_objid, [AltName("prior_Warning"), AltType("System.TimeSpan", "Convert.ToInt32({0}.TotalSeconds)")] int prior_warn, [AltType("System.Boolean", "{1} ? ({0} ? \"True\" : \"False\") : string.Empty"), AltName("is_Made_To_Customer")] string made_to_str, [AltName("contact_First_Name")] string cont_first, [AltName("contact_Last_Name")] string cont_last, [AltName("contact_Phone")] string cont_phone, [AltName("notes")] string note_str, [AltName("Update_date")] string mod_date, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | case_id_num |
System.String | the_title |
System.String | action_type |
System.String | commit_date |
System.Int32 | commit_objid |
System.Int32 | prior_warn |
System.String | made_to_str |
System.String | cont_first |
System.String | cont_last |
System.String | cont_phone |
System.String | note_str |
System.String | mod_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCCS.modify_case_list(String, String, String, String, String, String, Boolean, Boolean, String, Int32, Int32, Int32, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[AltName("update_case_list")]
[FacadeProperty("Clear_Part_Revision_Relation", "System.Boolean", "false", "if({0}) {2}.PartRevisionObjid = -999;")]
[FacadeProperty("Clear_Site_Part_Relation", "System.Boolean", "false", "if({0}) {2}.SitePartObjid = -999;")]
[FacadeProperty("Clear_Contract_Relation", "System.Boolean", "false", "if({0}) {2}.ContractObjid = -999;")]
public short IFCCS.modify_case_list([ParameterRequired, AltName("case_IDNum")] string case_id, [AltName("priority")] string priority_str, [AltName("severity")] string severity_str, string case_type, string user_name, [AltName("Update_date")] string mod_date, bool only_owner, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs, [AltName("title"), AltType("System.String", "({1} && {0} == String.Empty) ? \"CLEARFIELD\" : {0}")] string the_title, [AltName("Part_Revision_Objid")] int ml_obj, [AltName("site_Part_ObjID")] int sp_obj, [AltName("contract_ObjID")] int contr_obj, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | case_id |
System.String | priority_str |
System.String | severity_str |
System.String | case_type |
System.String | user_name |
System.String | mod_date |
System.Boolean | only_owner |
System.Boolean | gen_time_bombs |
System.String | the_title |
System.Int32 | ml_obj |
System.Int32 | sp_obj |
System.Int32 | contr_obj |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCCS.modify_case_list_setup(String, String, String, String, String, String, Boolean, Boolean, Boolean, String, Int32, Int32, Int32, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[AltName("update_case_list")]
[FacadeProperty("Clear_Part_Revision_Relation", "System.Boolean", "false", "if({0}) {2}.PartRevisionObjid = -999;")]
[FacadeProperty("Clear_Site_Part_Relation", "System.Boolean", "false", "if({0}) {2}.SitePartObjid = -999;")]
[FacadeProperty("Clear_Contract_Relation", "System.Boolean", "false", "if({0}) {2}.ContractObjid = -999;")]
public short IFCCS.modify_case_list_setup([ParameterRequired, AltName("case_IDNum")] string case_id, [AltName("priority")] string priority_str, [AltName("severity")] string severity_str, string case_type, string user_name, [AltName("Update_date")] string mod_date, bool only_owner, bool only_open, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs, [AltName("title"), AltType("System.String", "({1} && {0} == String.Empty) ? \"CLEARFIELD\" : {0}")] string the_title, [AltName("Part_Revision_Objid")] int ml_obj, [AltName("site_Part_ObjID")] int sp_obj, [AltName("contract_ObjID")] int contr_obj, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | case_id |
System.String | priority_str |
System.String | severity_str |
System.String | case_type |
System.String | user_name |
System.String | mod_date |
System.Boolean | only_owner |
System.Boolean | only_open |
System.Boolean | gen_time_bombs |
System.String | the_title |
System.Int32 | ml_obj |
System.Int32 | sp_obj |
System.Int32 | contr_obj |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCCS.modify_subcase(String, String, String, String, String, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[AltName("update_subcase")]
public short IFCCS.modify_subcase([ParameterRequired, AltName("subcase_IDNum")] string subcase_id, [AltName("priority")] string priority_str, [AltName("serverity")] string severity_str, string user_name, [AltName("Update_date")] string mod_date, bool only_owner, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | priority_str |
System.String | severity_str |
System.String | user_name |
System.String | mod_date |
System.Boolean | only_owner |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCS.modify_subcase_commit(String, String, String, String, Int32, Int32, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[FacadeVoid]
public short IFCCS.modify_subcase_commit(string subcase_id_num, string the_title, string action_type, string commit_date, int commit_objid, int prior_warn, string made_to_str, string cont_first, string cont_last, string cont_phone, string note_str, string mod_date, string user_name, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | subcase_id_num |
System.String | the_title |
System.String | action_type |
System.String | commit_date |
System.Int32 | commit_objid |
System.Int32 | prior_warn |
System.String | made_to_str |
System.String | cont_first |
System.String | cont_last |
System.String | cont_phone |
System.String | note_str |
System.String | mod_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCCS.modify_subcase_commit_list(String, String, String, String, Int32, Int32, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[AltName("Update_subcase_commitment")]
public short IFCCS.modify_subcase_commit_list([ParameterRequired, AltName("subcase_IDNum")] string subcase_id_num, [AltName("title")] string the_title, string action_type, [ParameterRequired, AltName("commitment_date")] string commit_date, [ParameterRequired, AltName("commitment_ObjID")] int commit_objid, [AltName("prior_Warning"), AltType("System.TimeSpan", "Convert.ToInt32({0}.TotalSeconds)")] int prior_warn, [AltType("System.Boolean", "{1} ? ({0} ? \"True\" : \"False\") : string.Empty"), AltName("is_Made_To_Customer")] string made_to_str, [AltName("contact_First_Name")] string cont_first, [AltName("contact_Last_Name")] string cont_last, [AltName("contact_Phone")] string cont_phone, [AltName("notes")] string note_str, [AltName("Update_date")] string mod_date, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | subcase_id_num |
System.String | the_title |
System.String | action_type |
System.String | commit_date |
System.Int32 | commit_objid |
System.Int32 | prior_warn |
System.String | made_to_str |
System.String | cont_first |
System.String | cont_last |
System.String | cont_phone |
System.String | note_str |
System.String | mod_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCCS.modify_subcase_list(String, String, String, String, String, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[AltName("update_subcase_list")]
public short IFCCS.modify_subcase_list([ParameterRequired, AltName("subcase_IDNum")] string subcase_id, [AltName("priority")] string priority_str, [AltName("severity")] string severity_str, string user_name, [AltName("Update_date")] string mod_date, bool only_owner, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | priority_str |
System.String | severity_str |
System.String | user_name |
System.String | mod_date |
System.Boolean | only_owner |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCCS.modify_subcase_list_setup(String, String, String, String, String, Boolean, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[AltName("update_subcase_list")]
public short IFCCS.modify_subcase_list_setup([ParameterRequired, AltName("subcase_IDNum")] string subcase_id, [AltName("priority")] string priority_str, [AltName("severity")] string severity_str, string user_name, [AltName("Update_date")] string mod_date, bool only_owner, bool only_open, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | priority_str |
System.String | severity_str |
System.String | user_name |
System.String | mod_date |
System.Boolean | only_owner |
System.Boolean | only_open |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCCS.move_case(String, String)

Declaration
public short IFCCS.move_case([ParameterRequired, AltName("case_IDNum")] string case_id, [ParameterRequired, AltName("new_wip_bin")] string new_wipbin)
Parameters
Type | Name | Description
System.String | case_id |
System.String | new_wipbin |
Returns
Type | Description
System.Int16 |

IFCCS.move_subcase(String, String)

Declaration
public short IFCCS.move_subcase([ParameterRequired, AltName("subcase_IDNum")] string subcase_id, [ParameterRequired, AltName("new_wip_bin")] string new_wipbin)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | new_wipbin |
Returns
Type | Description
System.Int16 |

IFCCS.preclose_case(String)

Declaration
[OutputProperty("ret_id_num", "CaseTimeAndExpenses", "CaseTimeAndExpenses", "null", "Contains the sums and totals of time and expenses calculated before closing a Case.", "CaseTimeAndExpenses.Parse({0})")]
[AltName("get_case_time_and_expenses")]
public short IFCCS.preclose_case([ParameterRequired, AltName("case_IDNum")] string case_id)
Parameters
Type | Name | Description
System.String | case_id |
Returns
Type | Description
System.Int16 |

IFCCS.preclose_subcase(String)

Declaration
[OutputProperty("ret_id_num", "SubcaseTimeAndExpenses", "SubcaseTimeAndExpenses", "null", "Contains the sums and totals calculated before closing a Case.", "SubcaseTimeAndExpenses.Parse({0})")]
[AltName("get_subcase_time_and_expenses")]
public short IFCCS.preclose_subcase([ParameterRequired, AltName("subcase_IDNum")] string subcase_id)
Parameters
Type | Name | Description
System.String | subcase_id |
Returns
Type | Description
System.Int16 |

IFCCS.reject_case(String, String, String, String, String, Boolean)

Declaration
public short IFCCS.reject_case([ParameterRequired, AltName("case_IDNum")] string case_id, string reject_date, [AltName("wip_bin")] string wipbin_name, [AltName("notes")] string note_str, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | case_id |
System.String | reject_date |
System.String | wipbin_name |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCS.reject_subcase(String, String, String, String, String, Boolean)

Declaration
public short IFCCS.reject_subcase([ParameterRequired, AltName("subcase_IDNum")] string subcase_id, string reject_date, [AltName("wip_bin")] string wipbin_name, [AltName("notes")] string note_str, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | reject_date |
System.String | wipbin_name |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCS.relate_case_to_parent(String, String)

Declaration
[ToolkitVisible(false)]
[AltName("relate_case_to_parent_case")]
public short IFCCS.relate_case_to_parent([ParameterRequired, AltName("case_IDNum")] string case_id, [ParameterRequired, AltName("parent_Case_IDNum")] string parent_id)
Parameters
Type | Name | Description
System.String | case_id |
System.String | parent_id |
Returns
Type | Description
System.Int16 |

IFCCS.reopen_case(String, String, String, String, String, Boolean)

Declaration
[ToolkitVisible(false)]
public short IFCCS.reopen_case([ParameterRequired, AltName("case_IDNum")] string case_id, [AltName("wip_bin")] string wipbin_name, [AltName("status")] string status_str, string reopen_date, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | case_id |
System.String | wipbin_name |
System.String | status_str |
System.String | reopen_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCS.reopen_subcase(String, String, String, String, String, Boolean)

Declaration
public short IFCCS.reopen_subcase([ParameterRequired, AltName("subcase_IDNum")] string subcase_id, [AltName("wip_bin")] string wipbin_name, [AltName("status")] string status_str, string reopen_date, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | wipbin_name |
System.String | status_str |
System.String | reopen_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCS.ret_id_num

Declaration
public string IFCCS.ret_id_num { get; }
Returns
Type | Description
System.String |

IFCCS.ret_objid

Declaration
public int IFCCS.ret_objid { get; }
Returns
Type | Description
System.Int32 |

IFCCS.ret_objid2

Declaration
public int IFCCS.ret_objid2 { get; }
Returns
Type | Description
System.Int32 |

IFCCS.ret_objid3

Declaration
public int IFCCS.ret_objid3 { get; }
Returns
Type | Description
System.Int32 |

IToolkit.ReturnIDNum

Declaration
public string IToolkit.ReturnIDNum { get; }
Returns
Type | Description
System.String |

IToolkit.ReturnObjid

Declaration
public int IToolkit.ReturnObjid { get; }
Returns
Type | Description
System.Int32 |

IFCCS.unrelate_case_from_parent(String)

Declaration
[ToolkitVisible(false)]
[AltName("unrelate_case_from_parent_case")]
public short IFCCS.unrelate_case_from_parent([ParameterRequired, AltName("case_IDNum")] string case_id)
Parameters
Type | Name | Description
System.String | case_id |
Returns
Type | Description
System.Int16 |

IFCCS.UseDenormalizedCaseTypeLevels

Declaration
public bool IFCCS.UseDenormalizedCaseTypeLevels { get; set; }
Returns
Type | Description
System.Boolean |

IFCCS.yank_case(String, String, String, String, Boolean)

Declaration
public short IFCCS.yank_case([ParameterRequired, AltName("Case_IDNum")] string case_id, [AltName("wip_bin")] string wipbin_name, string yank_date, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | case_id |
System.String | wipbin_name |
System.String | yank_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCCS.yank_subcase(String, String, String, String, Boolean)

Declaration
public short IFCCS.yank_subcase([ParameterRequired, AltName("subcase_IDNum")] string subcase_id, [AltName("wip_bin")] string wipbin_name, string yank_date, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | wipbin_name |
System.String | yank_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

Implements

IFCCS
IToolkit


Class FCCSBase | fcSDK Documentation

Class FCCSBase

Inheritance
System.Object
FCCSBase
FCCS
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Compatibility.Toolkits
Assembly: FChoice.Foundation.Clarify.Compatibility.Toolkits.dll
Syntax
[ComVisible(false)]
public abstract class FCCSBase

Constructors

FCCSBase()

Declaration
protected FCCSBase()

FCCSBase(IFCApplication, IFCSession)

Declaration
protected FCCSBase(IFCApplication FCApp, IFCSession FCSess)
Parameters
Type | Name | Description
IFCApplication | FCApp |
IFCSession | FCSess |

Properties

_impersonatorUserName

Declaration
protected string _impersonatorUserName { get; set; }
Property Value
Type | Description
System.String |

_ret_id_num

Declaration
protected string _ret_id_num { get; }
Property Value
Type | Description
System.String |

_ret_objid

Declaration
protected int _ret_objid { get; }
Property Value
Type | Description
System.Int32 |

_ret_objid2

Declaration
protected int _ret_objid2 { get; }
Property Value
Type | Description
System.Int32 |

_ret_objid3

Declaration
protected int _ret_objid3 { get; }
Property Value
Type | Description
System.Int32 |

_UseDenormalizedCaseTypeLevels

Declaration
protected bool _UseDenormalizedCaseTypeLevels { get; set; }
Property Value
Type | Description
System.Boolean |

Methods

_accept_case(String, String, String, String, Boolean)

Declaration
protected short _accept_case(string case_id, string accept_date, string wipbin_name, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | case_id |
System.String | accept_date |
System.String | wipbin_name |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_accept_subcase(String, String, String, String, Boolean)

Declaration
protected short _accept_subcase(string subcase_id, string accept_date, string wipbin_name, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | accept_date |
System.String | wipbin_name |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_assign_case(String, String, String, String, String, Boolean)

Declaration
protected short _assign_case(string case_id, string new_user, string wipbin_name, string assign_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | case_id |
System.String | new_user |
System.String | wipbin_name |
System.String | assign_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_assign_subcase(String, String, String, String, String, Boolean)

Declaration
protected short _assign_subcase(string subcase_id, string new_user, string wipbin_name, string assign_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | new_user |
System.String | wipbin_name |
System.String | assign_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_case_is_child(IFCGeneric, String)

Declaration
protected bool _case_is_child(IFCGeneric the_case, string o_case)
Parameters
Type | Name | Description
IFCGeneric | the_case |
System.String | o_case |
Returns
Type | Description
System.Boolean |

_change_case_status(String, String, String, String, String, Boolean)

Declaration
protected short _change_case_status(string case_id, string new_status, string change_date, string note_str, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | case_id |
System.String | new_status |
System.String | change_date |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_change_contact(String, String, String, String, String, String, String, Boolean)

Declaration
protected short _change_contact(string case_id, string f_name, string l_name, string phone_num, string site_id, string change_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | case_id |
System.String | f_name |
System.String | l_name |
System.String | phone_num |
System.String | site_id |
System.String | change_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_change_subcase_status(String, String, String, String, String, Boolean)

Declaration
protected short _change_subcase_status(string subcase_id, string new_status, string change_date, string note_str, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | new_status |
System.String | change_date |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_close_case(String, String, String, String, String, String, Double, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _close_case(string case_id, string the_status, string resolution_str, string summary_str, string user_name, string close_date, double units_used, string close_sums, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | case_id |
System.String | the_status |
System.String | resolution_str |
System.String | summary_str |
System.String | user_name |
System.String | close_date |
System.Double | units_used |
System.String | close_sums |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_close_case_list(String, String, String, String, String, String, Double, String, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _close_case_list(string case_id, string the_status, string resolution_str, string summary_str, string user_name, string close_date, double units_used, string close_sums, bool gen_time_bombs, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | case_id |
System.String | the_status |
System.String | resolution_str |
System.String | summary_str |
System.String | user_name |
System.String | close_date |
System.Double | units_used |
System.String | close_sums |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_close_subcase(String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _close_subcase(string subcase_id, string the_status, string resolution_str, string summary_str, string user_name, string close_date, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | the_status |
System.String | resolution_str |
System.String | summary_str |
System.String | user_name |
System.String | close_date |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_close_subcase_list(String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _close_subcase_list(string subcase_id, string the_status, string resolution_str, string summary_str, string user_name, string close_date, bool gen_time_bombs, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | the_status |
System.String | resolution_str |
System.String | summary_str |
System.String | user_name |
System.String | close_date |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_create_case(String, String, String, String, String, String, String, String, Int32, String, String, String, String, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _create_case(string site_id, string f_name, string l_name, string phone_num, string part_num, string mod_level, string domain_name, string serial_no, int sp_objid, string contract_id, string the_title, string case_type, string priority_str, string severity_str, string status_str, string phone_log, string queue_name, string cr_date, string phone_end_date, string user_name, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | site_id |
System.String | f_name |
System.String | l_name |
System.String | phone_num |
System.String | part_num |
System.String | mod_level |
System.String | domain_name |
System.String | serial_no |
System.Int32 | sp_objid |
System.String | contract_id |
System.String | the_title |
System.String | case_type |
System.String | priority_str |
System.String | severity_str |
System.String | status_str |
System.String | phone_log |
System.String | queue_name |
System.String | cr_date |
System.String | phone_end_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_create_case_list(String, String, String, String, String, String, String, String, Int32, String, String, String, String, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _create_case_list(string site_id, string f_name, string l_name, string phone_num, string part_num, string mod_level, string domain_name, string serial_no, int sp_objid, string contract_id, string the_title, string case_type, string priority_str, string severity_str, string status_str, string phone_log, string queue_name, string cr_date, string phone_end_date, string user_name, bool gen_time_bombs, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | site_id |
System.String | f_name |
System.String | l_name |
System.String | phone_num |
System.String | part_num |
System.String | mod_level |
System.String | domain_name |
System.String | serial_no |
System.Int32 | sp_objid |
System.String | contract_id |
System.String | the_title |
System.String | case_type |
System.String | priority_str |
System.String | severity_str |
System.String | status_str |
System.String | phone_log |
System.String | queue_name |
System.String | cr_date |
System.String | phone_end_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_create_case_objid(String, String, String, Int32, String, String, String, String, String, String, String, String, String, String, Boolean, Int32, Int32, Int32, Int32, Int32, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _create_case_objid(string f_name, string l_name, string phone_num, int sp_objid, string the_title, string case_type, string priority_str, string severity_str, string status_str, string phone_log, string queue_name, string cr_date, string phone_end_date, string user_name, bool gen_time_bombs, int contact_objid, int site_objid, int ml_objid, int contract_objid, int addr_objid, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | f_name |
System.String | l_name |
System.String | phone_num |
System.Int32 | sp_objid |
System.String | the_title |
System.String | case_type |
System.String | priority_str |
System.String | severity_str |
System.String | status_str |
System.String | phone_log |
System.String | queue_name |
System.String | cr_date |
System.String | phone_end_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.Int32 | contact_objid |
System.Int32 | site_objid |
System.Int32 | ml_objid |
System.Int32 | contract_objid |
System.Int32 | addr_objid |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_create_case_objid_list(String, String, String, Int32, String, String, String, String, String, String, String, String, String, String, Boolean, Int32, Int32, Int32, Int32, Int32, IFCList, IFCList, IFCList)

Declaration
protected short _create_case_objid_list(string f_name, string l_name, string phone_num, int sp_objid, string the_title, string case_type, string priority_str, string severity_str, string status_str, string phone_log, string queue_name, string cr_date, string phone_end_date, string user_name, bool gen_time_bombs, int contact_objid, int site_objid, int ml_objid, int contract_objid, int addr_objid, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | f_name |
System.String | l_name |
System.String | phone_num |
System.Int32 | sp_objid |
System.String | the_title |
System.String | case_type |
System.String | priority_str |
System.String | severity_str |
System.String | status_str |
System.String | phone_log |
System.String | queue_name |
System.String | cr_date |
System.String | phone_end_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.Int32 | contact_objid |
System.Int32 | site_objid |
System.Int32 | ml_objid |
System.Int32 | contract_objid |
System.Int32 | addr_objid |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_create_subcase(String, String, Boolean, String, String, String, String, String, String, String, Int32, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _create_subcase(string case_id, string the_title, bool is_general, string priority_str, string severity_str, string status_str, string note_str, string queue_name, string cr_date, string due_date, int prior_warn, string user_name, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | case_id |
System.String | the_title |
System.Boolean | is_general |
System.String | priority_str |
System.String | severity_str |
System.String | status_str |
System.String | note_str |
System.String | queue_name |
System.String | cr_date |
System.String | due_date |
System.Int32 | prior_warn |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_create_subcase_list(String, String, Boolean, String, String, String, String, String, String, String, Int32, String, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _create_subcase_list(string case_id, string the_title, bool is_general, string priority_str, string severity_str, string status_str, string note_str, string queue_name, string cr_date, string due_date, int prior_warn, string user_name, bool gen_time_bombs, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | case_id |
System.String | the_title |
System.Boolean | is_general |
System.String | priority_str |
System.String | severity_str |
System.String | status_str |
System.String | note_str |
System.String | queue_name |
System.String | cr_date |
System.String | due_date |
System.Int32 | prior_warn |
System.String | user_name |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_dispatch_case(String, String, String, String, Boolean)

Declaration
protected short _dispatch_case(string case_id, string queue_name, string disp_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | case_id |
System.String | queue_name |
System.String | disp_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_dispatch_subcase(String, String, String, String, Boolean)

Declaration
protected short _dispatch_subcase(string subcase_id, string queue_name, string disp_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | queue_name |
System.String | disp_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_forward_case(String, String, String, String, String, Boolean)

Declaration
protected short _forward_case(string case_id, string new_queue, string forward_date, string note_str, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | case_id |
System.String | new_queue |
System.String | forward_date |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_forward_subcase(String, String, String, String, String, Boolean)

Declaration
protected short _forward_subcase(string subcase_id, string new_queue, string forward_date, string note_str, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | new_queue |
System.String | forward_date |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_fulfill_commitment(Int32, String, String, Boolean)

Declaration
protected short _fulfill_commitment(int log_objid, string fulfill_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.Int32 | log_objid |
System.String | fulfill_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_initial_response(String, String, String, Boolean, Boolean)

Declaration
protected short _initial_response(string case_id, string resp_date, string user_name, bool via_phone, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | case_id |
System.String | resp_date |
System.String | user_name |
System.Boolean | via_phone |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_Initialize(IFCApplication, IFCSession)

Declaration
public void _Initialize(IFCApplication FCApp, IFCSession FCSess)
Parameters
Type | Name | Description
IFCApplication | FCApp |
IFCSession | FCSess |

_log_case_commit(String, String, String, String, String, Int32, Boolean, String, String, String, String, String, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _log_case_commit(string case_id, string the_title, string action_type, string log_date, string commit_date, int prior_warn, bool made_to, string cont_first, string cont_last, string cont_phone, string note_str, string user_name, bool gen_time_bombs, bool generate_commit_email, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | case_id |
System.String | the_title |
System.String | action_type |
System.String | log_date |
System.String | commit_date |
System.Int32 | prior_warn |
System.Boolean | made_to |
System.String | cont_first |
System.String | cont_last |
System.String | cont_phone |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.Boolean | generate_commit_email |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_log_case_commit_list(String, String, String, String, String, Int32, Boolean, String, String, String, String, String, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _log_case_commit_list(string case_id, string the_title, string action_type, string log_date, string commit_date, int prior_warn, bool made_to, string cont_first, string cont_last, string cont_phone, string note_str, string user_name, bool gen_time_bombs, bool generate_commit_email, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | case_id |
System.String | the_title |
System.String | action_type |
System.String | log_date |
System.String | commit_date |
System.Int32 | prior_warn |
System.Boolean | made_to |
System.String | cont_first |
System.String | cont_last |
System.String | cont_phone |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.Boolean | generate_commit_email |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_log_case_email(String, String, String, String, String, String, String, String, String, String, String, Int32, Boolean, String, Int32, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _log_case_email(string case_id, string action_type, string log_date, string message, string recipient, string cc_list, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, string cmit_action_type, int cmit_contact_objid, bool gen_time_bombs, bool send_email, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | case_id |
System.String | action_type |
System.String | log_date |
System.String | message |
System.String | recipient |
System.String | cc_list |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.String | cmit_action_type |
System.Int32 | cmit_contact_objid |
System.Boolean | gen_time_bombs |
System.Boolean | send_email |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_log_case_email_list(String, String, String, String, String, String, String, String, String, String, String, Int32, Boolean, String, Int32, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _log_case_email_list(string case_id, string action_type, string log_date, string message, string recipient, string cc_list, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, string cmit_action_type, int cmit_contact_objid, bool gen_time_bombs, bool send_email, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | case_id |
System.String | action_type |
System.String | log_date |
System.String | message |
System.String | recipient |
System.String | cc_list |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.String | cmit_action_type |
System.Int32 | cmit_contact_objid |
System.Boolean | gen_time_bombs |
System.Boolean | send_email |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_log_case_note(String, String, String, String, String, String, String, String, String, String, Int32, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _log_case_note(string case_id, string action_type, string note_str, string int_use, string log_date, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | case_id |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_log_case_note_list(String, String, String, String, String, String, String, String, String, String, Int32, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _log_case_note_list(string case_id, string action_type, string note_str, string int_use, string log_date, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, bool gen_time_bombs, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | case_id |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_log_case_phone(String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int32, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _log_case_phone(string case_id, string cont_first, string cont_last, string cont_phone, string action_type, string note_str, string int_use, string log_date, string log_end_date, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | case_id |
System.String | cont_first |
System.String | cont_last |
System.String | cont_phone |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.String | log_end_date |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_log_case_phone_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int32, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _log_case_phone_list(string case_id, string cont_first, string cont_last, string cont_phone, string action_type, string note_str, string int_use, string log_date, string log_end_date, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, bool gen_time_bombs, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | case_id |
System.String | cont_first |
System.String | cont_last |
System.String | cont_phone |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.String | log_end_date |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_log_case_resrch(String, String, String, String, String, Int32, String, String, String, String, String, Int32, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _log_case_resrch(string case_id, string action_type, string note_str, string int_use, string log_date, int research_time, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | case_id |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.Int32 | research_time |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_log_case_resrch_list(String, String, String, String, String, Int32, String, String, String, String, String, Int32, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _log_case_resrch_list(string case_id, string action_type, string note_str, string int_use, string log_date, int research_time, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, bool gen_time_bombs, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | case_id |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.Int32 | research_time |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_log_object_email(String, String, String, String, String, String, String, String, String, String, String, Int32, Boolean, String, Int32, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String, String)

Declaration
protected short _log_object_email(string case_id, string action_type, string log_date, string message, string recipient, string cc_list, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, string cmit_action_type, int cmit_contact_objid, bool gen_time_bombs, bool send_email, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1, string obj_type)
Parameters
Type | Name | Description
System.String | case_id |
System.String | action_type |
System.String | log_date |
System.String | message |
System.String | recipient |
System.String | cc_list |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.String | cmit_action_type |
System.Int32 | cmit_contact_objid |
System.Boolean | gen_time_bombs |
System.Boolean | send_email |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
System.String | obj_type |
Returns
Type | Description
System.Int16 |

_log_subcase_commit(String, String, String, String, String, Int32, Boolean, String, String, String, String, String, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _log_subcase_commit(string subcase_id, string the_title, string action_type, string log_date, string commit_date, int prior_warn, bool made_to, string cont_first, string cont_last, string cont_phone, string note_str, string user_name, bool gen_time_bombs, bool generate_commit_email, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | the_title |
System.String | action_type |
System.String | log_date |
System.String | commit_date |
System.Int32 | prior_warn |
System.Boolean | made_to |
System.String | cont_first |
System.String | cont_last |
System.String | cont_phone |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.Boolean | generate_commit_email |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_log_subcase_commit_list(String, String, String, String, String, Int32, Boolean, String, String, String, String, String, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _log_subcase_commit_list(string subcase_id, string the_title, string action_type, string log_date, string commit_date, int prior_warn, bool made_to, string cont_first, string cont_last, string cont_phone, string note_str, string user_name, bool gen_time_bombs, bool generate_commit_email, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | the_title |
System.String | action_type |
System.String | log_date |
System.String | commit_date |
System.Int32 | prior_warn |
System.Boolean | made_to |
System.String | cont_first |
System.String | cont_last |
System.String | cont_phone |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.Boolean | generate_commit_email |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_log_subcase_email(String, String, String, String, String, String, String, String, String, String, String, Int32, Boolean, String, Int32, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _log_subcase_email(string case_id, string action_type, string log_date, string message, string recipient, string cc_list, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, string cmit_action_type, int cmit_contact_objid, bool gen_time_bombs, bool send_email, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | case_id |
System.String | action_type |
System.String | log_date |
System.String | message |
System.String | recipient |
System.String | cc_list |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.String | cmit_action_type |
System.Int32 | cmit_contact_objid |
System.Boolean | gen_time_bombs |
System.Boolean | send_email |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_log_subcase_email_list(String, String, String, String, String, String, String, String, String, String, String, Int32, Boolean, String, Int32, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _log_subcase_email_list(string case_id, string action_type, string log_date, string message, string recipient, string cc_list, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, string cmit_action_type, int cmit_contact_objid, bool gen_time_bombs, bool send_email, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | case_id |
System.String | action_type |
System.String | log_date |
System.String | message |
System.String | recipient |
System.String | cc_list |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.String | cmit_action_type |
System.Int32 | cmit_contact_objid |
System.Boolean | gen_time_bombs |
System.Boolean | send_email |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_log_subcase_note(String, String, String, String, String, String, String, String, String, String, Int32, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _log_subcase_note(string subcase_id, string action_type, string note_str, string int_use, string log_date, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_log_subcase_note_list(String, String, String, String, String, String, String, String, String, String, Int32, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _log_subcase_note_list(string subcase_id, string action_type, string note_str, string int_use, string log_date, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, bool gen_time_bombs, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_log_subcase_phone(String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int32, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _log_subcase_phone(string subcase_id, string cont_first, string cont_last, string cont_phone, string action_type, string note_str, string int_use, string log_date, string log_end_date, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | cont_first |
System.String | cont_last |
System.String | cont_phone |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.String | log_end_date |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_log_subcase_phone_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int32, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _log_subcase_phone_list(string subcase_id, string cont_first, string cont_last, string cont_phone, string action_type, string note_str, string int_use, string log_date, string log_end_date, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, bool gen_time_bombs, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | cont_first |
System.String | cont_last |
System.String | cont_phone |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.String | log_end_date |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_log_subcase_resrch(String, String, String, String, String, Int32, String, String, String, String, String, Int32, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _log_subcase_resrch(string subcase_id, string action_type, string note_str, string int_use, string log_date, int research_time, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.Int32 | research_time |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_log_subcase_resrch_list(String, String, String, String, String, Int32, String, String, String, String, String, Int32, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _log_subcase_resrch_list(string subcase_id, string action_type, string note_str, string int_use, string log_date, int research_time, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, bool gen_time_bombs, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.Int32 | research_time |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_modify_case(String, String, String, String, String, String, Boolean, Boolean, String, Int32, Int32, Int32, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _modify_case(string case_id, string priority_str, string severity_str, string case_type, string user_name, string mod_date, bool only_owner, bool gen_time_bombs, string the_title, int ml_obj, int sp_obj, int contr_obj, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | case_id |
System.String | priority_str |
System.String | severity_str |
System.String | case_type |
System.String | user_name |
System.String | mod_date |
System.Boolean | only_owner |
System.Boolean | gen_time_bombs |
System.String | the_title |
System.Int32 | ml_obj |
System.Int32 | sp_obj |
System.Int32 | contr_obj |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_modify_case_commit(String, String, String, String, Int32, Int32, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _modify_case_commit(string case_id_num, string the_title, string action_type, string commit_date, int commit_objid, int prior_warn, string made_to_str, string cont_first, string cont_last, string cont_phone, string note_str, string mod_date, string user_name, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | case_id_num |
System.String | the_title |
System.String | action_type |
System.String | commit_date |
System.Int32 | commit_objid |
System.Int32 | prior_warn |
System.String | made_to_str |
System.String | cont_first |
System.String | cont_last |
System.String | cont_phone |
System.String | note_str |
System.String | mod_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_modify_case_commit_list(String, String, String, String, Int32, Int32, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _modify_case_commit_list(string case_id_num, string the_title, string action_type, string commit_date, int commit_objid, int prior_warn, string made_to_str, string cont_first, string cont_last, string cont_phone, string note_str, string mod_date, string user_name, bool gen_time_bombs, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | case_id_num |
System.String | the_title |
System.String | action_type |
System.String | commit_date |
System.Int32 | commit_objid |
System.Int32 | prior_warn |
System.String | made_to_str |
System.String | cont_first |
System.String | cont_last |
System.String | cont_phone |
System.String | note_str |
System.String | mod_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_modify_case_list(String, String, String, String, String, String, Boolean, Boolean, String, Int32, Int32, Int32, IFCList, IFCList, IFCList)

Declaration
protected short _modify_case_list(string case_id, string priority_str, string severity_str, string case_type, string user_name, string mod_date, bool only_owner, bool gen_time_bombs, string the_title, int ml_obj, int sp_obj, int contr_obj, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | case_id |
System.String | priority_str |
System.String | severity_str |
System.String | case_type |
System.String | user_name |
System.String | mod_date |
System.Boolean | only_owner |
System.Boolean | gen_time_bombs |
System.String | the_title |
System.Int32 | ml_obj |
System.Int32 | sp_obj |
System.Int32 | contr_obj |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_modify_case_list_setup(String, String, String, String, String, String, Boolean, Boolean, Boolean, String, Int32, Int32, Int32, IFCList, IFCList, IFCList)

Declaration
protected short _modify_case_list_setup(string case_id, string priority_str, string severity_str, string case_type, string user_name, string mod_date, bool only_owner, bool only_open, bool gen_time_bombs, string the_title, int ml_obj, int sp_obj, int contr_obj, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | case_id |
System.String | priority_str |
System.String | severity_str |
System.String | case_type |
System.String | user_name |
System.String | mod_date |
System.Boolean | only_owner |
System.Boolean | only_open |
System.Boolean | gen_time_bombs |
System.String | the_title |
System.Int32 | ml_obj |
System.Int32 | sp_obj |
System.Int32 | contr_obj |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_modify_subcase(String, String, String, String, String, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _modify_subcase(string subcase_id, string priority_str, string severity_str, string user_name, string mod_date, bool only_owner, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | priority_str |
System.String | severity_str |
System.String | user_name |
System.String | mod_date |
System.Boolean | only_owner |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_modify_subcase_commit(String, String, String, String, Int32, Int32, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _modify_subcase_commit(string subcase_id_num, string the_title, string action_type, string commit_date, int commit_objid, int prior_warn, string made_to_str, string cont_first, string cont_last, string cont_phone, string note_str, string mod_date, string user_name, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | subcase_id_num |
System.String | the_title |
System.String | action_type |
System.String | commit_date |
System.Int32 | commit_objid |
System.Int32 | prior_warn |
System.String | made_to_str |
System.String | cont_first |
System.String | cont_last |
System.String | cont_phone |
System.String | note_str |
System.String | mod_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_modify_subcase_commit_list(String, String, String, String, Int32, Int32, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _modify_subcase_commit_list(string subcase_id_num, string the_title, string action_type, string commit_date, int commit_objid, int prior_warn, string made_to_str, string cont_first, string cont_last, string cont_phone, string note_str, string mod_date, string user_name, bool gen_time_bombs, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | subcase_id_num |
System.String | the_title |
System.String | action_type |
System.String | commit_date |
System.Int32 | commit_objid |
System.Int32 | prior_warn |
System.String | made_to_str |
System.String | cont_first |
System.String | cont_last |
System.String | cont_phone |
System.String | note_str |
System.String | mod_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_modify_subcase_list(String, String, String, String, String, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _modify_subcase_list(string subcase_id, string priority_str, string severity_str, string user_name, string mod_date, bool only_owner, bool gen_time_bombs, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | priority_str |
System.String | severity_str |
System.String | user_name |
System.String | mod_date |
System.Boolean | only_owner |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_modify_subcase_list_setup(String, String, String, String, String, Boolean, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _modify_subcase_list_setup(string subcase_id, string priority_str, string severity_str, string user_name, string mod_date, bool only_owner, bool only_open, bool gen_time_bombs, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | priority_str |
System.String | severity_str |
System.String | user_name |
System.String | mod_date |
System.Boolean | only_owner |
System.Boolean | only_open |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_move_case(String, String)

Declaration
protected short _move_case(string case_id, string new_wipbin)
Parameters
Type | Name | Description
System.String | case_id |
System.String | new_wipbin |
Returns
Type | Description
System.Int16 |

_move_subcase(String, String)

Declaration
protected short _move_subcase(string subcase_id, string new_wipbin)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | new_wipbin |
Returns
Type | Description
System.Int16 |

_preclose_case(String)

Declaration
protected short _preclose_case(string case_id)
Parameters
Type | Name | Description
System.String | case_id |
Returns
Type | Description
System.Int16 |

_preclose_subcase(String)

Declaration
protected short _preclose_subcase(string subcase_id)
Parameters
Type | Name | Description
System.String | subcase_id |
Returns
Type | Description
System.Int16 |

_reject_case(String, String, String, String, String, Boolean)

Declaration
protected short _reject_case(string case_id, string reject_date, string wipbin_name, string note_str, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | case_id |
System.String | reject_date |
System.String | wipbin_name |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_reject_subcase(String, String, String, String, String, Boolean)

Declaration
protected short _reject_subcase(string subcase_id, string reject_date, string wipbin_name, string note_str, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | reject_date |
System.String | wipbin_name |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_relate_case_to_parent(String, String)

Declaration
protected short _relate_case_to_parent(string case_id, string parent_id)
Parameters
Type | Name | Description
System.String | case_id |
System.String | parent_id |
Returns
Type | Description
System.Int16 |

_reopen_case(String, String, String, String, String, Boolean)

Declaration
protected short _reopen_case(string case_id, string wipbin_name, string status_str, string reopen_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | case_id |
System.String | wipbin_name |
System.String | status_str |
System.String | reopen_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_reopen_subcase(String, String, String, String, String, Boolean)

Declaration
protected short _reopen_subcase(string subcase_id, string wipbin_name, string status_str, string reopen_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | wipbin_name |
System.String | status_str |
System.String | reopen_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_unrelate_case_from_parent(String)

Declaration
protected short _unrelate_case_from_parent(string case_id)
Parameters
Type | Name | Description
System.String | case_id |
Returns
Type | Description
System.Int16 |

_yank_case(String, String, String, String, Boolean)

Declaration
protected short _yank_case(string case_id, string wipbin_name, string yank_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | case_id |
System.String | wipbin_name |
System.String | yank_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_yank_subcase(String, String, String, String, Boolean)

Declaration
protected short _yank_subcase(string subcase_id, string wipbin_name, string yank_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | wipbin_name |
System.String | yank_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

GetProductID()

Declaration
protected abstract int GetProductID()
Returns
Type | Description
System.Int32 |


Class FCDR | fcSDK Documentation

Class FCDR

Inheritance
System.Object
FCDRBase
FCDR
Implements
IFCDR
IToolkit
Inherited Members
FCDRBase._Initialize(IFCApplication, IFCSession)
FCDRBase._create_eco_hdr(String, String, String, String, String, String, String, String)
FCDRBase._create_eco_item(Int32, Int32, String, Int32, Int32)
FCDRBase._modify_eco_item(Int32, Int32, Int32, String, Int32, Int32)
FCDRBase._delete_eco_item(Int32)
FCDRBase._create_eco_dtl(String, Int32, String, String, Int32, String, String, String, Int32)
FCDRBase._delete_eco_dtl(Int32)
FCDRBase._modify_eco_dtl(Int32, String, Int32, String, String, Int32, String, String, String, Int32)
FCDRBase._create_dr_labor(Int32, String, String, Int32, Int16, String, String, Double, String, String)
FCDRBase._create_dr_mtl(Int32, String, String, Int32, Int16, String, String, Int16, String, String, String, String, String)
FCDRBase._delete_dr_labor(Int32, String)
FCDRBase._delete_dr_mtl(Int32, String)
FCDRBase._modify_dr_labor(Int32, String, String, Int32, Int16, String, String, Double, String, String)
FCDRBase._modify_dr_mtl(Int32, String, String, Int32, Int16, String, String, Int16, String, String, String, String, String)
FCDRBase._apply_eco(Int32, String, String, String)
FCDRBase._object_name
FCDRBase._ret_objid
FCDRBase._user_id
FCDRBase._user_id2
FCDRBase._emp_id
FCDRBase._emp_id2
FCDRBase._wipbin_id
FCDRBase._wipbin_id2
FCDRBase._wipbin_title
FCDRBase._wipbin_title2
FCDRBase._ret_id_num
FCDRBase._impersonatorUserName
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Compatibility.Toolkits
Assembly: FChoice.Foundation.Clarify.Compatibility.Toolkits.dll
Syntax
[Guid("E3D1915E-3932-4075-B65F-74B8C71FFCB9")]
[ComVisible(true)]
[AltName("DepotRepair")]
[ClassInterface(ClassInterfaceType.None)]
public sealed class FCDR : FCDRBase, IFCDR, IToolkit

Constructors

FCDR()

Declaration
public FCDR()

FCDR(IFCApplication, IFCSession)

Declaration
public FCDR(IFCApplication FCApp, IFCSession FCSess)
Parameters
Type | Name | Description
IFCApplication | FCApp |
IFCSession | FCSess |

Methods

GetProductID()

Declaration
protected override int GetProductID()
Returns
Type | Description
System.Int32 |
Overrides
FCDRBase.GetProductID()

Explicit Interface Implementations

IFCDR.apply_eco(Int32, String, String, String)

Declaration
[AltName("Apply_Eco")]
public short IFCDR.apply_eco([ParameterRequired, AltName("demand_detail_Objid")] int demand_dtl_objid, [ParameterRequired, AltName("Eco_Header_ID_Num")] string eco_code, [AltName("User_Name")] string perf_by, [AltName("create_date")] string creation_time)
Parameters
Type | Name | Description
System.Int32 | demand_dtl_objid |
System.String | eco_code |
System.String | perf_by |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

IFCDR.create_dr_labor(Int32, String, String, Int32, Int16, String, String, Double, String, String)

Declaration
[AltName("create_depot_repair_labor")]
[OutputProperty("ret_objid", "TimeLog")]
public short IFCDR.create_dr_labor([ParameterRequired, AltName("Demand_detail_Objid")] int demand_dtl_objid, string labor_type, [ParameterRequired, AltName("start_date")] string start_time, [ParameterRequired, AltType("System.TimeSpan", "Convert.ToInt32({0}.TotalSeconds)")] int duration, [AltName("Is_Billable"), AltType("System.Boolean", "(short)({0} ? 1 : 0)")] short billable, string bill_to, [AltName("work_center")] string wrk_center, [AltName("labor_rate")] double tl_rate, [AltName("User_Name")] string perf_by, [AltName("create_date")] string creation_time)
Parameters
Type | Name | Description
System.Int32 | demand_dtl_objid |
System.String | labor_type |
System.String | start_time |
System.Int32 | duration |
System.Int16 | billable |
System.String | bill_to |
System.String | wrk_center |
System.Double | tl_rate |
System.String | perf_by |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

IFCDR.create_dr_mtl(Int32, String, String, Int32, Int16, String, String, Int16, String, String, String, String, String)

Declaration
[AltName("create_depot_repair_material")]
[OutputProperty("ret_objid", "MaterialLog")]
public short IFCDR.create_dr_mtl([ParameterRequired, AltName("Demand_detail_Objid")] int demand_dtl_objid, string repair_code, string failure_code, [ParameterRequired, AltName("Part_Revision_Objid")] int mod_level, [AltName("Is_Billable"), AltType("System.Boolean", "(short)({0} ? 1 : 0)")] short billable, string bill_to, [AltName("work_center")] string wrk_center, [ParameterRequired, AltType("RepairPartDisposition", "Convert.ToInt16((int)({0}))"), ParameterDefaultValue("RepairPartDisposition.Used")] short disposition, [AltName("reference_designator")] string ref_designator, string notes, string transaction_id, [AltName("User_Name")] string perf_by, [AltName("create_date")] string creation_time)
Parameters
Type | Name | Description
System.Int32 | demand_dtl_objid |
System.String | repair_code |
System.String | failure_code |
System.Int32 | mod_level |
System.Int16 | billable |
System.String | bill_to |
System.String | wrk_center |
System.Int16 | disposition |
System.String | ref_designator |
System.String | notes |
System.String | transaction_id |
System.String | perf_by |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

IFCDR.create_eco_dtl(String, Int32, String, String, Int32, String, String, String, Int32)

Declaration
[SplitMethod("Create_Eco_Labor_Detail")]
[SplitMethod("Create_Eco_Material_Detail")]
public short IFCDR.create_eco_dtl([ParameterVoid, ParameterDefaultValue("\"Labor\"", "Create_Eco_Labor_Detail"), ParameterDefaultValue("\"Material\"", "Create_Eco_Material_Detail")] string detail_type, [AltName("Is_Required"), ParameterRequired, AltType("System.Boolean", "{0} ? 1 : 0")] int required, string status, [ParameterVoid(true, "Create_Eco_Material_Detail")] string labor_type, [AltType("System.TimeSpan", "Convert.ToInt32({0}.TotalSeconds)"), AltName("elapsed_time"), ParameterRequired("Create_Eco_Labor_Detail"), ParameterVoid("Create_Eco_Material_Detail")] int elapsed_time, [ParameterVoid(true, "Create_Eco_Labor_Detail")] string location, string description, [ParameterRequired, AltName("Eco_header_Id_Num")] string eco_hdr_code, [ParameterRequired("Create_Eco_Material_Detail"), AltName("Part_Revision_Objid"), ParameterVoid("Update_Eco_Labor_Detail")] int mod_level_objid)
Parameters
Type | Name | Description
System.String | detail_type |
System.Int32 | required |
System.String | status |
System.String | labor_type |
System.Int32 | elapsed_time |
System.String | location |
System.String | description |
System.String | eco_hdr_code |
System.Int32 | mod_level_objid |
Returns
Type | Description
System.Int16 |

IFCDR.create_eco_hdr(String, String, String, String, String, String, String, String)

Declaration
[AltName("create_Eco_header")]
public short IFCDR.create_eco_hdr([AltName("Eco_title")] string eco_title, [AltName("Eco_type")] string eco_type, string create_date, [AltName("effect_type")] string eff_type, [ParameterRequired] string start_date, [ParameterRequired] string end_date, string status, string description)
Parameters
Type | Name | Description
System.String | eco_title |
System.String | eco_type |
System.String | create_date |
System.String | eff_type |
System.String | start_date |
System.String | end_date |
System.String | status |
System.String | description |
Returns
Type | Description
System.Int16 |

IFCDR.create_eco_item(Int32, Int32, String, Int32, Int32)

Declaration
[AltName("create_Eco_item")]
public short IFCDR.create_eco_item([ParameterRequired, AltType("FChoice.Toolkits.Clarify.EcoItemAppliesTo", "{1} ? (int)({0}) : -1"), AltName("Applies_to"), ParameterDefaultValue("FChoice.Toolkits.Clarify.EcoItemAppliesTo.EcoHeader")] int focus_type, [AltName("Is_Active"), ParameterRequired, AltType("System.Boolean", "({0} ? 1 : 0)")] int active, [ParameterRequired, AltName("Eco_header_ID_Num")] string eco_hdr_code, [ParameterRequired, AltName("Apply_Part_Revision_Objid")] int apply_mod_level, [ParameterRequired, AltName("Result_Part_Revision_Objid")] int result_mod_level)
Parameters
Type | Name | Description
System.Int32 | focus_type |
System.Int32 | active |
System.String | eco_hdr_code |
System.Int32 | apply_mod_level |
System.Int32 | result_mod_level |
Returns
Type | Description
System.Int16 |

IFCDR.delete_dr_labor(Int32, String)

Declaration
[AltName("delete_depot_repair_labor")]
public short IFCDR.delete_dr_labor([ParameterRequired] int time_log_objid, [AltName("create_date")] string creation_time)
Parameters
Type | Name | Description
System.Int32 | time_log_objid |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

IFCDR.delete_dr_mtl(Int32, String)

Declaration
[AltName("delete_depot_repair_material")]
public short IFCDR.delete_dr_mtl([ParameterRequired, AltName("material_log_Objid")] int mtl_log_objid, [AltName("create_date")] string creation_time)
Parameters
Type | Name | Description
System.Int32 | mtl_log_objid |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

IFCDR.delete_eco_dtl(Int32)

Declaration
[AltName("delete_Eco_detail")]
public short IFCDR.delete_eco_dtl([ParameterRequired, AltName("Eco_detail_Objid")] int eco_dtl_objid)
Parameters
Type | Name | Description
System.Int32 | eco_dtl_objid |
Returns
Type | Description
System.Int16 |

IFCDR.delete_eco_item(Int32)

Declaration
[AltName("delete_Eco_item")]
public short IFCDR.delete_eco_item([ParameterRequired, AltName("Eco_ItemObjid")] int eco_item_objid)
Parameters
Type | Name | Description
System.Int32 | eco_item_objid |
Returns
Type | Description
System.Int16 |

IFCDR.impersonatorUserName

Declaration
public string IFCDR.impersonatorUserName { get; set; }
Returns
Type | Description
System.String |

IFCDR.Initialize(IFCApplication, IFCSession)

Declaration
[ToolkitVisible(false)]
public void IFCDR.Initialize(IFCApplication FCApp, IFCSession FCSess)
Parameters
Type | Name | Description
IFCApplication | FCApp |
IFCSession | FCSess |

IFCDR.modify_dr_labor(Int32, String, String, Int32, Int16, String, String, Double, String, String)

Declaration
[AltName("Update_depot_repair_labor")]
[OutputProperty("ret_objid", "TimeLog")]
public short IFCDR.modify_dr_labor([ParameterRequired] int time_log_objid, string labor_type, [AltName("start_date")] string start_time, [AltType("System.TimeSpan", "Convert.ToInt32({0}.TotalSeconds)")] int duration, [AltName("Is_Billable"), AltType("System.Boolean", "(short)({1} ? ({0} ? 1 : 0) : -1)")] short billable, string bill_to, [AltName("work_center")] string wrk_center, [AltName("labor_rate")] double tl_rate, [AltName("User_Name")] string perf_by, [AltName("create_date")] string creation_time)
Parameters
Type | Name | Description
System.Int32 | time_log_objid |
System.String | labor_type |
System.String | start_time |
System.Int32 | duration |
System.Int16 | billable |
System.String | bill_to |
System.String | wrk_center |
System.Double | tl_rate |
System.String | perf_by |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

IFCDR.modify_dr_mtl(Int32, String, String, Int32, Int16, String, String, Int16, String, String, String, String, String)

Declaration
[AltName("Update_depot_repair_material")]
[OutputProperty("ret_objid", "MaterialLog")]
public short IFCDR.modify_dr_mtl([ParameterRequired, AltName("material_log_Objid")] int mtl_log_objid, string repair_code, string failure_code, [AltName("Part_Revision_Objid")] int mod_level, [AltName("Is_Billable"), AltType("System.Boolean", "(short)({1} ? ({0} ? 1 : 0) : -1)")] short billable, string bill_to, [AltName("work_center")] string wrk_center, [ParameterRequired, AltType("RepairPartDisposition", "Convert.ToInt16((int)({0}))"), ParameterDefaultValue("RepairPartDisposition.Used")] short disposition, [AltName("reference_designator")] string ref_designator, string notes, string transaction_id, [AltName("User_Name")] string perf_by, [AltName("create_date")] string creation_time)
Parameters
Type | Name | Description
System.Int32 | mtl_log_objid |
System.String | repair_code |
System.String | failure_code |
System.Int32 | mod_level |
System.Int16 | billable |
System.String | bill_to |
System.String | wrk_center |
System.Int16 | disposition |
System.String | ref_designator |
System.String | notes |
System.String | transaction_id |
System.String | perf_by |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

IFCDR.modify_eco_dtl(Int32, String, Int32, String, String, Int32, String, String, String, Int32)

Declaration
[SplitMethod("Update_Eco_Labor_Detail")]
[SplitMethod("Update_Eco_Material_Detail")]
public short IFCDR.modify_eco_dtl([ParameterRequired, AltName("Eco_detail_Objid")] int eco_dtl_objid, [ParameterVoid, ParameterDefaultValue("\"Labor\"", "Update_Eco_Labor_Detail"), ParameterDefaultValue("\"Material\"", "Update_Eco_Material_Detail")] string detail_type, [AltName("Is_Required"), AltType("System.Boolean", "({1} ? ({0} ? 1 : 0) : -1)")] int required, string status, [ParameterVoid(true, "Update_Eco_Material_Detail")] string labor_type, [AltType("System.TimeSpan", "Convert.ToInt32({0}.TotalSeconds)"), AltName("elapsed_time"), ParameterRequired("Create_Eco_Labor_Detail"), ParameterVoid("Create_Eco_Material_Detail")] int elapsed_time, [ParameterVoid(true, "Update_Eco_Labor_Detail")] string location, string description, [AltName("Eco_header_ID_Num")] string eco_hdr_code, [AltName("Part_Revision_Objid"), ParameterRequired("Update_Eco_Material_Detail"), ParameterVoid("Update_Eco_Labor_Detail")] int mod_level_objid)
Parameters
Type | Name | Description
System.Int32 | eco_dtl_objid |
System.String | detail_type |
System.Int32 | required |
System.String | status |
System.String | labor_type |
System.Int32 | elapsed_time |
System.String | location |
System.String | description |
System.String | eco_hdr_code |
System.Int32 | mod_level_objid |
Returns
Type | Description
System.Int16 |

IFCDR.modify_eco_item(Int32, Int32, Int32, String, Int32, Int32)

Declaration
[AltName("Update_Eco_item")]
public short IFCDR.modify_eco_item([ParameterRequired, AltName("Eco_ItemObjid")] int eco_mod_role_objid, [AltType("FChoice.Toolkits.Clarify.EcoItemAppliesTo", "{1} ? (int)({0}) : -1"), AltName("Applies_to"), ParameterDefaultValue("FChoice.Toolkits.Clarify.EcoItemAppliesTo.EcoHeader")] int focus_type, [AltName("Is_Active"), ParameterRequired, AltType("System.Boolean", "({1} ? ({0} ? 1 : 0) : -1)")] int active, [ParameterRequired, AltName("Eco_header_ID_Num")] string eco_hdr_code, [AltName("Apply_Part_Revision_Objid")] int applies_to_mod, [AltName("Result_Part_Revision_Objid")] int results_in_mod)
Parameters
Type | Name | Description
System.Int32 | eco_mod_role_objid |
System.Int32 | focus_type |
System.Int32 | active |
System.String | eco_hdr_code |
System.Int32 | applies_to_mod |
System.Int32 | results_in_mod |
Returns
Type | Description
System.Int16 |

IFCDR.ret_id_num

Declaration
public string IFCDR.ret_id_num { get; }
Returns
Type | Description
System.String |

IFCDR.ret_objid

Declaration
public int IFCDR.ret_objid { get; }
Returns
Type | Description
System.Int32 |

IToolkit.ReturnIDNum

Declaration
public string IToolkit.ReturnIDNum { get; }
Returns
Type | Description
System.String |

IToolkit.ReturnObjid

Declaration
public int IToolkit.ReturnObjid { get; }
Returns
Type | Description
System.Int32 |

Implements

IFCDR
IToolkit


Class FCDRBase | fcSDK Documentation

Class FCDRBase

Inheritance
System.Object
FCDRBase
FCDR
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Compatibility.Toolkits
Assembly: FChoice.Foundation.Clarify.Compatibility.Toolkits.dll
Syntax
[ComVisible(false)]
public abstract class FCDRBase

Constructors

FCDRBase()

Declaration
protected FCDRBase()

FCDRBase(IFCApplication, IFCSession)

Declaration
protected FCDRBase(IFCApplication FCApp, IFCSession FCSess)
Parameters
Type | Name | Description
IFCApplication | FCApp |
IFCSession | FCSess |

Properties

_emp_id

Declaration
protected int _emp_id { get; set; }
Property Value
Type | Description
System.Int32 |

_emp_id2

Declaration
protected int _emp_id2 { get; set; }
Property Value
Type | Description
System.Int32 |

_impersonatorUserName

Declaration
protected string _impersonatorUserName { get; set; }
Property Value
Type | Description
System.String |

_object_name

Declaration
protected string _object_name { get; set; }
Property Value
Type | Description
System.String |

_ret_id_num

Declaration
protected string _ret_id_num { get; set; }
Property Value
Type | Description
System.String |

_ret_objid

Declaration
protected int _ret_objid { get; set; }
Property Value
Type | Description
System.Int32 |

_user_id

Declaration
protected int _user_id { get; set; }
Property Value
Type | Description
System.Int32 |

_user_id2

Declaration
protected int _user_id2 { get; set; }
Property Value
Type | Description
System.Int32 |

_wipbin_id

Declaration
protected int _wipbin_id { get; set; }
Property Value
Type | Description
System.Int32 |

_wipbin_id2

Declaration
protected int _wipbin_id2 { get; set; }
Property Value
Type | Description
System.Int32 |

_wipbin_title

Declaration
protected string _wipbin_title { get; set; }
Property Value
Type | Description
System.String |

_wipbin_title2

Declaration
protected string _wipbin_title2 { get; set; }
Property Value
Type | Description
System.String |

Methods

_apply_eco(Int32, String, String, String)

Declaration
protected short _apply_eco(int demand_dtl_objid, string eco_code, string perf_by, string creation_time)
Parameters
Type | Name | Description
System.Int32 | demand_dtl_objid |
System.String | eco_code |
System.String | perf_by |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

_create_dr_labor(Int32, String, String, Int32, Int16, String, String, Double, String, String)

Declaration
protected short _create_dr_labor(int demand_dtl_objid, string labor_type, string start_time, int duration, short billable, string bill_to, string wrk_center, double tl_rate, string perf_by, string creation_time)
Parameters
Type | Name | Description
System.Int32 | demand_dtl_objid |
System.String | labor_type |
System.String | start_time |
System.Int32 | duration |
System.Int16 | billable |
System.String | bill_to |
System.String | wrk_center |
System.Double | tl_rate |
System.String | perf_by |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

_create_dr_mtl(Int32, String, String, Int32, Int16, String, String, Int16, String, String, String, String, String)

Declaration
protected short _create_dr_mtl(int demand_dtl_objid, string repair_code, string failure_code, int mod_level, short billable, string bill_to, string wrk_center, short disposition, string ref_designator, string notes, string transaction_id, string perf_by, string creation_time)
Parameters
Type | Name | Description
System.Int32 | demand_dtl_objid |
System.String | repair_code |
System.String | failure_code |
System.Int32 | mod_level |
System.Int16 | billable |
System.String | bill_to |
System.String | wrk_center |
System.Int16 | disposition |
System.String | ref_designator |
System.String | notes |
System.String | transaction_id |
System.String | perf_by |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

_create_eco_dtl(String, Int32, String, String, Int32, String, String, String, Int32)

Declaration
protected short _create_eco_dtl(string detail_type, int required, string status, string labor_type, int elapsed_time, string location, string description, string eco_hdr_code, int mod_level_objid)
Parameters
Type | Name | Description
System.String | detail_type |
System.Int32 | required |
System.String | status |
System.String | labor_type |
System.Int32 | elapsed_time |
System.String | location |
System.String | description |
System.String | eco_hdr_code |
System.Int32 | mod_level_objid |
Returns
Type | Description
System.Int16 |

_create_eco_hdr(String, String, String, String, String, String, String, String)

Declaration
protected short _create_eco_hdr(string eco_title, string eco_type, string create_date, string eff_type, string start_date, string end_date, string status, string description)
Parameters
Type | Name | Description
System.String | eco_title |
System.String | eco_type |
System.String | create_date |
System.String | eff_type |
System.String | start_date |
System.String | end_date |
System.String | status |
System.String | description |
Returns
Type | Description
System.Int16 |

_create_eco_item(Int32, Int32, String, Int32, Int32)

Declaration
protected short _create_eco_item(int focus_type, int active, string eco_hdr_code, int apply_mod_level, int result_mod_level)
Parameters
Type | Name | Description
System.Int32 | focus_type |
System.Int32 | active |
System.String | eco_hdr_code |
System.Int32 | apply_mod_level |
System.Int32 | result_mod_level |
Returns
Type | Description
System.Int16 |

_delete_dr_labor(Int32, String)

Declaration
protected short _delete_dr_labor(int time_log_objid, string creation_time)
Parameters
Type | Name | Description
System.Int32 | time_log_objid |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

_delete_dr_mtl(Int32, String)

Declaration
protected short _delete_dr_mtl(int mtl_log_objid, string creation_time)
Parameters
Type | Name | Description
System.Int32 | mtl_log_objid |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

_delete_eco_dtl(Int32)

Declaration
protected short _delete_eco_dtl(int eco_dtl_objid)
Parameters
Type | Name | Description
System.Int32 | eco_dtl_objid |
Returns
Type | Description
System.Int16 |

_delete_eco_item(Int32)

Declaration
protected short _delete_eco_item(int eco_item_objid)
Parameters
Type | Name | Description
System.Int32 | eco_item_objid |
Returns
Type | Description
System.Int16 |

_Initialize(IFCApplication, IFCSession)

Declaration
public void _Initialize(IFCApplication FCApp, IFCSession FCSess)
Parameters
Type | Name | Description
IFCApplication | FCApp |
IFCSession | FCSess |

_modify_dr_labor(Int32, String, String, Int32, Int16, String, String, Double, String, String)

Declaration
protected short _modify_dr_labor(int time_log_objid, string labor_type, string start_time, int duration, short billable, string bill_to, string wrk_center, double tl_rate, string perf_by, string creation_time)
Parameters
Type | Name | Description
System.Int32 | time_log_objid |
System.String | labor_type |
System.String | start_time |
System.Int32 | duration |
System.Int16 | billable |
System.String | bill_to |
System.String | wrk_center |
System.Double | tl_rate |
System.String | perf_by |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

_modify_dr_mtl(Int32, String, String, Int32, Int16, String, String, Int16, String, String, String, String, String)

Declaration
protected short _modify_dr_mtl(int mtl_log_objid, string repair_code, string failure_code, int mod_level, short billable, string bill_to, string wrk_center, short disposition, string ref_designator, string notes, string transaction_id, string perf_by, string creation_time)
Parameters
Type | Name | Description
System.Int32 | mtl_log_objid |
System.String | repair_code |
System.String | failure_code |
System.Int32 | mod_level |
System.Int16 | billable |
System.String | bill_to |
System.String | wrk_center |
System.Int16 | disposition |
System.String | ref_designator |
System.String | notes |
System.String | transaction_id |
System.String | perf_by |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

_modify_eco_dtl(Int32, String, Int32, String, String, Int32, String, String, String, Int32)

Declaration
protected short _modify_eco_dtl(int eco_dtl_objid, string detail_type, int required, string status, string labor_type, int elapsed_time, string location, string description, string eco_hdr_code, int mod_level_objid)
Parameters
Type | Name | Description
System.Int32 | eco_dtl_objid |
System.String | detail_type |
System.Int32 | required |
System.String | status |
System.String | labor_type |
System.Int32 | elapsed_time |
System.String | location |
System.String | description |
System.String | eco_hdr_code |
System.Int32 | mod_level_objid |
Returns
Type | Description
System.Int16 |

_modify_eco_item(Int32, Int32, Int32, String, Int32, Int32)

Declaration
protected short _modify_eco_item(int eco_mod_role_objid, int focus_type, int active, string eco_hdr_code, int applies_to_mod, int results_in_mod)
Parameters
Type | Name | Description
System.Int32 | eco_mod_role_objid |
System.Int32 | focus_type |
System.Int32 | active |
System.String | eco_hdr_code |
System.Int32 | applies_to_mod |
System.Int32 | results_in_mod |
Returns
Type | Description
System.Int16 |

GetProductID()

Declaration
protected abstract int GetProductID()
Returns
Type | Description
System.Int32 |


Class FCFO | fcSDK Documentation

Class FCFO

Inheritance
System.Object
FCFOBase
FCFO
Implements
IFCFO
IToolkit
Inherited Members
FCFOBase.ServiceCOGSVirtualInventoryLocationName
FCFOBase.PartUsedVarianceVirtualInventoryLocationName
FCFOBase._Initialize(IFCApplication, IFCSession)
FCFOBase._dispatch_fe(String, String, String, String, String, Int32, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int32, String, String, Int32, Boolean)
FCFOBase._make_appt(String, String, String, Int32, String, String, String, Int32, String, String, String, String, String)
FCFOBase._modify_appt(Int32, String, String, Int32, String, String, String, String, String, String)
FCFOBase._delete_appt(Int32, String, String)
FCFOBase._create_onsite_log(String, String, String, String, String, String, String, String)
FCFOBase._delete_onsite_log(Int32, String, String)
FCFOBase._create_time_log(Int32, String, String, String, String, String, String, String, Int32, Int32, String, String, String)
FCFOBase._modify_time_log(Int32, String, String, String, String, String, String, Int32, Int32, String, String, String)
FCFOBase._delete_time_log(Int32, String, String)
FCFOBase._create_expense_log(Int32, String, String, String, String, String, String, Double, Double, Int32, String, String)
FCFOBase._modify_expense_log(Int32, String, String, String, String, String, Double, Double, Int32, String, String)
FCFOBase._delete_expense_log(Int32, String, String)
FCFOBase._add_svc_inter(String, Int32, String, String, String, Int32, String, String, String, String)
FCFOBase._modify_svc_inter(Int32, String, String, String, Int32, String, String, String, String)
FCFOBase._delete_svc_inter(Int32, String, String)
FCFOBase._install_sp(String, String, String, String, Int32, String, Int32, Int32, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)
FCFOBase._install_sp_list(String, String, String, String, Int32, String, Int32, Int32, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)
FCFOBase._install_sp_list(String, String, String, String, Int32, String, Int32, Int32, String, String, String, String, String, String, String, Boolean)
FCFOBase._deinstall_sp(Int32, String, String, Boolean)
FCFOBase._modify_sp(Int32, String, String, String, String, String, String, Int32, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)
FCFOBase._modify_sp_list(Int32, String, String, String, String, String, String, Int32, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)
FCFOBase._modify_sp_list(Int32, String, String, String, String, String, String, Int32, String, String, String, String, String, Boolean)
FCFOBase._move_sp(Int32, String, Int32, String, Int32, Boolean, String, Boolean)
FCFOBase._reinstall_sp(Int32, String, Int32, Int32, String, String, Boolean, Boolean)
FCFOBase._part_transfer(String, String, String, Int32, String, String, String, String, Boolean, String, String, String, Boolean, String, String, String, String, Boolean, Int16, String, String, String, String)
FCFOBase._log_parts_used(String, String, String, Int32, Boolean, Int32, String, String, String, Boolean, String, String, String, String, String, Int32, String, String, String, String, Boolean, String, String, Boolean, String, Int32)
FCFOBase._object_name
FCFOBase._ret_objid
FCFOBase._ret_objid2
FCFOBase._ret_id_num
FCFOBase._ret_string
FCFOBase._impersonatorUserName
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Compatibility.Toolkits
Assembly: FChoice.Foundation.Clarify.Compatibility.Toolkits.dll
Syntax
[Guid("1D515A33-E701-4bfb-9BD2-EB12CA55790E")]
[ComVisible(true)]
[AltName("FieldOps")]
[ClassInterface(ClassInterfaceType.None)]
public sealed class FCFO : FCFOBase, IFCFO, IToolkit

Constructors

FCFO()

Declaration
public FCFO()

FCFO(IFCApplication, IFCSession)

Declaration
public FCFO(IFCApplication FCApp, IFCSession FCSess)
Parameters
Type | Name | Description
IFCApplication | FCApp |
IFCSession | FCSess |

Methods

GetProductID()

Declaration
protected override int GetProductID()
Returns
Type | Description
System.Int32 |
Overrides
FCFOBase.GetProductID()

Explicit Interface Implementations

IFCFO.add_svc_inter(String, Int32, String, String, String, Int32, String, String, String, String)

Declaration
[AltName("add_service_interruption")]
[OutputProperty("ret_objid", "Appointment")]
[OutputProperty("ret_objid2", "ScheduleObjid", "System.Int32", "0", "Schedule")]
public short IFCFO.add_svc_inter([ParameterRequired, AltName("case_IDNum")] string case_id, [AltName("site_part_ObjID")] int sp_objid, string description, [AltName("start_date")] string start_time, [AltName("end_date")] string end_time, [AltType("System.TimeSpan", "Convert.ToInt32({0}.TotalSeconds)")] int duration, [AltName("Service_class")] string svc_class, [AltName("Service_type")] string svc_type, string user_name, [AltName("create_date")] string creation_time)
Parameters
Type | Name | Description
System.String | case_id |
System.Int32 | sp_objid |
System.String | description |
System.String | start_time |
System.String | end_time |
System.Int32 | duration |
System.String | svc_class |
System.String | svc_type |
System.String | user_name |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

IFCFO.create_expense_log(Int32, String, String, String, String, String, String, Double, Double, Int32, String, String)

Declaration
[OutputProperty("ret_objid", "ExpenseLog")]
[OutputProperty("ret_objid2", "OnsiteLogObjid", "System.Int32", "0", "OnsiteLog")]
public short IFCFO.create_expense_log([AltName("Onsite_Log_Objid"), ParameterRequired] int onsite_objid, [AltName("case_IDNum")] string id_num, [AltName("create_date")] string creation_time, string notes, [AltName("performed_by_user_name")] string perf_by, string user_name, string expense_type, double quantity, [AltName("rate")] double the_rate, [AltType("System.Boolean", "{0} ? 1 : 0"), AltName("is_billable")] int billable, string bill_to, string resolution)
Parameters
Type | Name | Description
System.Int32 | onsite_objid |
System.String | id_num |
System.String | creation_time |
System.String | notes |
System.String | perf_by |
System.String | user_name |
System.String | expense_type |
System.Double | quantity |
System.Double | the_rate |
System.Int32 | billable |
System.String | bill_to |
System.String | resolution |
Returns
Type | Description
System.Int16 |

IFCFO.create_onsite_log(String, String, String, String, String, String, String, String)

Declaration
[OutputProperty("ret_objid", "Objid of the Onsite Log record.")]
public short IFCFO.create_onsite_log([ParameterRequired, ParameterDefaultValue("FChoice.Toolkits.Clarify.CaseObjectType.Case"), AltType("FChoice.Toolkits.Clarify.CaseObjectType", "FChoice.Toolkits.Clarify.Utility.GetCaseObjectType({0})")] string object_type, [ParameterRequired, AltName("object_IDNum")] string object_id, [AltName("create_date")] string creation_time, [AltName("last_modified_date")] string last_modified, string notes, string resolution, string user_name, [AltName("performed_by_user_name")] string perf_by)
Parameters
Type | Name | Description
System.String | object_type |
System.String | object_id |
System.String | creation_time |
System.String | last_modified |
System.String | notes |
System.String | resolution |
System.String | user_name |
System.String | perf_by |
Returns
Type | Description
System.Int16 |

IFCFO.create_time_log(Int32, String, String, String, String, String, String, String, Int32, Int32, String, String, String)

Declaration
[OutputProperty("ret_objid", "TimeLog")]
[OutputProperty("ret_objid2", "OnsiteLogObjid", "System.Int32", "0", "OnsiteLog")]
public short IFCFO.create_time_log([AltName("Onsite_Log_Objid"), ParameterRequired] int onsite_objid, [AltName("case_IDNum")] string id_num, [AltName("create_date")] string creation_time, string notes, [AltName("performed_by_user_name")] string perf_by, string user_name, string time_type, [ParameterRequired, AltName("start_date")] string start_time, [ParameterRequired, AltType("System.TimeSpan", "Convert.ToInt32({0}.TotalSeconds)")] int duration, [AltName("is_billable"), AltType("System.Boolean", "{0} ? 1 : 0")] int billable, string bill_to, [AltName("work_center")] string wrk_center, string resolution)
Parameters
Type | Name | Description
System.Int32 | onsite_objid |
System.String | id_num |
System.String | creation_time |
System.String | notes |
System.String | perf_by |
System.String | user_name |
System.String | time_type |
System.String | start_time |
System.Int32 | duration |
System.Int32 | billable |
System.String | bill_to |
System.String | wrk_center |
System.String | resolution |
Returns
Type | Description
System.Int16 |

IFCFO.deinstall_sp(Int32, String, String, Boolean)

Declaration
[AltName("deinstall_site_part")]
public short IFCFO.deinstall_sp([ParameterRequired, AltName("site_part_ObjID")] int sp_objid, string user_name, string deinstall_date, bool use_remove)
Parameters
Type | Name | Description
System.Int32 | sp_objid |
System.String | user_name |
System.String | deinstall_date |
System.Boolean | use_remove |
Returns
Type | Description
System.Int16 |

IFCFO.delete_appt(Int32, String, String)

Declaration
[AltName("delete_appointment")]
public short IFCFO.delete_appt([ParameterRequired, AltName("appointment_ObjID")] int appt_objid, string user_name, [AltName("create_date")] string creation_time)
Parameters
Type | Name | Description
System.Int32 | appt_objid |
System.String | user_name |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

IFCFO.delete_expense_log(Int32, String, String)

Declaration
public short IFCFO.delete_expense_log([ParameterRequired, AltName("expense_log_ObjID")] int expense_objid, [AltName("last_modified_date")] string last_modified, string user_name)
Parameters
Type | Name | Description
System.Int32 | expense_objid |
System.String | last_modified |
System.String | user_name |
Returns
Type | Description
System.Int16 |

IFCFO.delete_onsite_log(Int32, String, String)

Declaration
public short IFCFO.delete_onsite_log([AltName("Onsite_Log_Objid"), ParameterRequired] int onsite_log_objid, string note_date, string user_name)
Parameters
Type | Name | Description
System.Int32 | onsite_log_objid |
System.String | note_date |
System.String | user_name |
Returns
Type | Description
System.Int16 |

IFCFO.delete_svc_inter(Int32, String, String)

Declaration
[AltName("delete_service_interruption")]
public short IFCFO.delete_svc_inter([ParameterRequired, AltName("appointment_ObjID")] int appt_objid, string user_name, [AltName("create_date")] string creation_time)
Parameters
Type | Name | Description
System.Int32 | appt_objid |
System.String | user_name |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

IFCFO.delete_time_log(Int32, String, String)

Declaration
public short IFCFO.delete_time_log([ParameterRequired, AltName("time_log_objid")] int time_objid, [AltName("last_modified_date")] string last_modified, string user_name)
Parameters
Type | Name | Description
System.Int32 | time_objid |
System.String | last_modified |
System.String | user_name |
Returns
Type | Description
System.Int16 |

IFCFO.dispatch_fe(String, String, String, String, String, Int32, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int32, String, String, Int32, Boolean)

Declaration
[AltName("dispatch_field_engineer")]
[OutputProperty("ret_objid", "Objid of the Dispatch FE record.")]
public short IFCFO.dispatch_fe([ParameterRequired, AltName("case_IDNum")] string case_id, string user_name, [AltName("dispatch_date")] string dispatch_time, string work_order, [AltName("appointment_date")] string appointment_time, [AltType("System.TimeSpan", "Convert.ToInt32({0}.TotalSeconds)")] int duration, string description, [AltName("contact_first_Name")] string cont_fname, [AltName("contact_last_Name")] string cont_lname, string address1, string address2, string city, string state, [AltName("Zip_Code")] string zipcode, string main_phone, [AltName("Alternate_Phone")] string alt_phone, [AltName("site_IDNum")] string site_id, [AltName("payment_method")] string pay_method, [AltName("reference_number")] string ref_number, string notes, [AltName("requested_ETA_date")] string requested_eta, [AltName("appointment_confirmed")] int appt_confirm, string cell_text, string proxy, [ParameterVoid] int removed, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | case_id |
System.String | user_name |
System.String | dispatch_time |
System.String | work_order |
System.String | appointment_time |
System.Int32 | duration |
System.String | description |
System.String | cont_fname |
System.String | cont_lname |
System.String | address1 |
System.String | address2 |
System.String | city |
System.String | state |
System.String | zipcode |
System.String | main_phone |
System.String | alt_phone |
System.String | site_id |
System.String | pay_method |
System.String | ref_number |
System.String | notes |
System.String | requested_eta |
System.Int32 | appt_confirm |
System.String | cell_text |
System.String | proxy |
System.Int32 | removed |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCFO.impersonatorUserName

Declaration
public string IFCFO.impersonatorUserName { get; set; }
Returns
Type | Description
System.String |

IFCFO.Initialize(IFCApplication, IFCSession)

Declaration
[ToolkitVisible(false)]
public void IFCFO.Initialize(IFCApplication TheFCApplication, IFCSession TheFCSession)
Parameters
Type | Name | Description
IFCApplication | TheFCApplication |
IFCSession | TheFCSession |

IFCFO.install_sp(String, String, String, String, Int32, String, Int32, Int32, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[SplitMethod("install_site_part", 2)]
[OutputProperty("ret_objid", "SitePart")]
public short IFCFO.install_sp([ParameterRequired, AltName("site_IDNum")] string site_id, [ParameterRequired, AltName("Part_Number")] string part_num, [ParameterRequired, AltName("part_revision")] string mod_level, [ParameterRequired, AltName("part_domain")] string domain, [ParameterRequired(null, 0), ParameterDefaultValue("1")] int quantity, [ParameterRequired(null, 1), AltName("serial_Number")] string serial_num, int parent_bin_objid, [AltName("parent_site_part_ObjID")] int parent_sp_objid, string instance_name, string comment, string part_status, [AltName("invoice_number")] string invoice_no, string user_name, string install_date, string ship_date, [AltName("Add_Activity_Log"), ParameterDefaultValue("true")] bool add_activity, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | site_id |
System.String | part_num |
System.String | mod_level |
System.String | domain |
System.Int32 | quantity |
System.String | serial_num |
System.Int32 | parent_bin_objid |
System.Int32 | parent_sp_objid |
System.String | instance_name |
System.String | comment |
System.String | part_status |
System.String | invoice_no |
System.String | user_name |
System.String | install_date |
System.String | ship_date |
System.Boolean | add_activity |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCFO.install_sp_list(String, String, String, String, Int32, String, Int32, Int32, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[SplitMethod("install_site_part", 2)]
[OutputProperty("ret_objid", "SitePart")]
public short IFCFO.install_sp_list([ParameterRequired, AltName("site_IDNum")] string site_id, [ParameterRequired, AltName("part_number")] string part_num, [ParameterRequired, AltName("PartRevision")] string mod_level, [ParameterRequired, AltName("PartDomain")] string domain, [ParameterRequired(null, 0), ParameterDefaultValue("1")] int quantity, [ParameterRequired(null, 1), AltName("serial_Number")] string serial_num, int parent_bin_objid, [AltName("parent_site_part_ObjID")] int parent_sp_objid, string instance_name, [AltName("comments")] string comment, string part_status, [AltName("invoice_number")] string invoice_no, string user_name, string install_date, string ship_date, [AltName("Add_Activity_Log"), ParameterDefaultValue("true")] bool add_activity, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | site_id |
System.String | part_num |
System.String | mod_level |
System.String | domain |
System.Int32 | quantity |
System.String | serial_num |
System.Int32 | parent_bin_objid |
System.Int32 | parent_sp_objid |
System.String | instance_name |
System.String | comment |
System.String | part_status |
System.String | invoice_no |
System.String | user_name |
System.String | install_date |
System.String | ship_date |
System.Boolean | add_activity |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCFO.log_parts_used(String, String, String, Int32, Boolean, Int32, String, String, String, Boolean, String, String, String, String, String, Int32, String, String, String, String, Boolean, String, String, Boolean, String, Int32)

Declaration
[SplitMethod("LogPartsUsedExchange", 4)]
[SplitMethod("LogPartsUsedConsume", 4)]
[SplitMethod("LogPartsUsedInstall", 4)]
[SplitMethod("LogPartsUsedRemove", 2)]
[SplitMethod("LogPartsUsedUpgrade", 4)]
[OutputProperty("ret_objid", "PartUsed")]
public short IFCFO.log_parts_used([ParameterRequired("LogPartsUsedExchange", 0), ParameterRequired("LogPartsUsedExchange", 1), ParameterRequired("LogPartsUsedExchange", 2), ParameterRequired("LogPartsUsedExchange", 3), ParameterRequired("LogPartsUsedConsume", 0), ParameterRequired("LogPartsUsedConsume", 1), ParameterRequired("LogPartsUsedConsume", 2), ParameterRequired("LogPartsUsedConsume", 3), ParameterRequired("LogPartsUsedInstall", 0), ParameterRequired("LogPartsUsedInstall", 1), ParameterRequired("LogPartsUsedInstall", 2), ParameterRequired("LogPartsUsedInstall", 3), ParameterRequired("LogPartsUsedRemove", 0), ParameterRequired("LogPartsUsedRemove", 1), ParameterRequired("LogPartsUsedUpgrade", 0), ParameterRequired("LogPartsUsedUpgrade", 1), ParameterRequired("LogPartsUsedUpgrade", 2), ParameterRequired("LogPartsUsedUpgrade", 3), AltName("part_request_detail_IDNum")] string dtl_num, [ParameterRequired("LogPartsUsedExchange", 2), ParameterRequired("LogPartsUsedExchange", 3), ParameterRequired("LogPartsUsedConsume", 2), ParameterRequired("LogPartsUsedConsume", 3), ParameterRequired("LogPartsUsedInstall", 2), ParameterRequired("LogPartsUsedInstall", 3), ParameterRequired("LogPartsUsedRemove", 1), ParameterRequired("LogPartsUsedUpgrade", 2), ParameterRequired("LogPartsUsedUpgrade", 3), AltName("case_IDNum")] string case_id, [ParameterVoid, ParameterDefaultValue("\"Exchange\"", "LogPartsUsedExchange"), ParameterDefaultValue("\"Consume\"", "LogPartsUsedConsume"), ParameterDefaultValue("\"Install\"", "LogPartsUsedInstall"), ParameterDefaultValue("\"Remove\"", "LogPartsUsedRemove"), ParameterDefaultValue("\"Upgrade\"", "LogPartsUsedUpgrade"), AltName("Parts_used_type")] string pu_type, [AltName("parent_site_part_ObjID")] int parent_sp, [ParameterDefaultValue("true")] bool install_at_site, [ParameterVoid("LogPartsUsedConsume"), ParameterVoid("LogPartsUsedInstall"), ParameterRequired("LogPartsUsedExchange", 0), ParameterRequired("LogPartsUsedRemove", 0), ParameterRequired("LogPartsUsedUpgrade", 0), ParameterRequired("LogPartsUsedExchange", 1), ParameterRequired("LogPartsUsedRemove", 1), ParameterRequired("LogPartsUsedUpgrade", 1), ParameterRequired("LogPartsUsedExchange", 2), ParameterRequired("LogPartsUsedUpgrade", 2), ParameterRequired("LogPartsUsedExchange", 3), ParameterRequired("LogPartsUsedUpgrade", 3), AltName("remove_site_part_ObjID")] int remove_sp, [ParameterVoid("LogPartsUsedConsume"), ParameterVoid("LogPartsUsedInstall"), AltName("to_location")] string to_loc, [ParameterVoid("LogPartsUsedConsume"), ParameterVoid("LogPartsUsedInstall")] string to_bin, [ParameterVoid("LogPartsUsedConsume"), ParameterVoid("LogPartsUsedInstall"), AltName("to_container")] string to_cont, [ParameterVoid("LogPartsUsedConsume"), ParameterVoid("LogPartsUsedInstall"), ParameterDefaultValue("true")] bool to_good, [ParameterVoid("LogPartsUsedConsume"), ParameterVoid("LogPartsUsedInstall"), AltName("failure_code")] string fail_code, [ParameterVoid("LogPartsUsedRemove"), ParameterRequired("LogPartsUsedExchange", 0), ParameterRequired("LogPartsUsedConsume", 0), ParameterRequired("LogPartsUsedInstall", 0), ParameterRequired("LogPartsUsedUpgrade", 0), ParameterRequired("LogPartsUsedExchange", 1), ParameterRequired("LogPartsUsedConsume", 1), ParameterRequired("LogPartsUsedInstall", 1), ParameterRequired("LogPartsUsedUpgrade", 1), ParameterRequired("LogPartsUsedExchange", 2), ParameterRequired("LogPartsUsedConsume", 2), ParameterRequired("LogPartsUsedInstall", 2), ParameterRequired("LogPartsUsedUpgrade", 2), ParameterRequired("LogPartsUsedExchange", 3), ParameterRequired("LogPartsUsedConsume", 3), ParameterRequired("LogPartsUsedInstall", 3), ParameterRequired("LogPartsUsedUpgrade", 3), AltName("install_part_number")] string inst_part, [ParameterVoid("LogPartsUsedRemove"), ParameterRequired("LogPartsUsedExchange", 0), ParameterRequired("LogPartsUsedConsume", 0), ParameterRequired("LogPartsUsedInstall", 0), ParameterRequired("LogPartsUsedUpgrade", 0), ParameterRequired("LogPartsUsedExchange", 1), ParameterRequired("LogPartsUsedConsume", 1), ParameterRequired("LogPartsUsedInstall", 1), ParameterRequired("LogPartsUsedUpgrade", 1), ParameterRequired("LogPartsUsedExchange", 2), ParameterRequired("LogPartsUsedConsume", 2), ParameterRequired("LogPartsUsedInstall", 2), ParameterRequired("LogPartsUsedUpgrade", 2), ParameterRequired("LogPartsUsedExchange", 3), ParameterRequired("LogPartsUsedConsume", 3), ParameterRequired("LogPartsUsedInstall", 3), ParameterRequired("LogPartsUsedUpgrade", 3), AltName("install_part_revision")] string inst_rev, [ParameterVoid("LogPartsUsedRemove"), ParameterRequired("LogPartsUsedExchange", 0), ParameterRequired("LogPartsUsedConsume", 0), ParameterRequired("LogPartsUsedInstall", 0), ParameterRequired("LogPartsUsedUpgrade", 0), ParameterRequired("LogPartsUsedExchange", 1), ParameterRequired("LogPartsUsedConsume", 1), ParameterRequired("LogPartsUsedInstall", 1), ParameterRequired("LogPartsUsedUpgrade", 1), ParameterRequired("LogPartsUsedExchange", 2), ParameterRequired("LogPartsUsedConsume", 2), ParameterRequired("LogPartsUsedInstall", 2), ParameterRequired("LogPartsUsedUpgrade", 2), ParameterRequired("LogPartsUsedExchange", 3), ParameterRequired("LogPartsUsedConsume", 3), ParameterRequired("LogPartsUsedInstall", 3), ParameterRequired("LogPartsUsedUpgrade", 3), AltName("install_part_domain")] string inst_domain, [ParameterVoid("LogPartsUsedRemove"), ParameterRequired("LogPartsUsedExchange", 0), ParameterRequired("LogPartsUsedConsume", 0), ParameterRequired("LogPartsUsedInstall", 0), ParameterRequired("LogPartsUsedUpgrade", 0), ParameterRequired("LogPartsUsedExchange", 2), ParameterRequired("LogPartsUsedConsume", 2), ParameterRequired("LogPartsUsedInstall", 2), ParameterRequired("LogPartsUsedUpgrade", 2), AltName("install_serial_number")] string inst_serial, [ParameterVoid("LogPartsUsedRemove"), ParameterRequired("LogPartsUsedExchange", 1), ParameterRequired("LogPartsUsedConsume", 1), ParameterRequired("LogPartsUsedInstall", 1), ParameterRequired("LogPartsUsedUpgrade", 1), ParameterRequired("LogPartsUsedExchange", 3), ParameterRequired("LogPartsUsedConsume", 3), ParameterRequired("LogPartsUsedInstall", 3), ParameterRequired("LogPartsUsedUpgrade", 3), AltName("install_quantity")] int inst_qty, [ParameterVoid("LogPartsUsedRemove"), AltName("install_price")] string inst_price, [ParameterVoid("LogPartsUsedRemove"), AltName("from_location")] string from_loc, [ParameterVoid("LogPartsUsedRemove")] string from_bin, [ParameterVoid("LogPartsUsedRemove"), AltName("from_container")] string from_cont, [ParameterVoid("LogPartsUsedRemove"), ParameterDefaultValue("true")] bool from_good, [AltName("engineer_user_name")] string engineer_name, string user_name, bool allow_move, string log_date, [ParameterVoid] int log_objid)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | case_id |
System.String | pu_type |
System.Int32 | parent_sp |
System.Boolean | install_at_site |
System.Int32 | remove_sp |
System.String | to_loc |
System.String | to_bin |
System.String | to_cont |
System.Boolean | to_good |
System.String | fail_code |
System.String | inst_part |
System.String | inst_rev |
System.String | inst_domain |
System.String | inst_serial |
System.Int32 | inst_qty |
System.String | inst_price |
System.String | from_loc |
System.String | from_bin |
System.String | from_cont |
System.Boolean | from_good |
System.String | engineer_name |
System.String | user_name |
System.Boolean | allow_move |
System.String | log_date |
System.Int32 | log_objid |
Returns
Type | Description
System.Int16 |

IFCFO.make_appt(String, String, String, Int32, String, String, String, Int32, String, String, String, String, String)

Declaration
[SplitMethod("create_appointment", 3)]
[OutputProperty("ret_objid", "Appointment")]
[OutputProperty("ret_objid2", "ScheduleObjid", "System.Int32", "0", "Schedule")]
public short IFCFO.make_appt(string description, [ParameterRequired("create_appointment", 0), ParameterRequired("create_appointment", 1), AltName("start_date")] string start_time, [ParameterRequired("create_appointment", 0), ParameterRequired("create_appointment", 2, 2), AltName("end_date")] string end_time, [ParameterRequired("create_appointment", 1), ParameterRequired("create_appointment", 2, 1), AltType("System.TimeSpan", "Convert.ToInt32({0}.TotalSeconds)")] int duration, string cell_text, [AltName("employee_first_name")] string emp_first, [AltName("employee_last_name")] string emp_last, int site_part_objid, [AltName("appointment_class")] string appt_class, [AltName("appointment_type")] string appt_type, [AltName("case_IDNum")] string case_id, string user_name, [AltName("create_date")] string creation_time)
Parameters
Type | Name | Description
System.String | description |
System.String | start_time |
System.String | end_time |
System.Int32 | duration |
System.String | cell_text |
System.String | emp_first |
System.String | emp_last |
System.Int32 | site_part_objid |
System.String | appt_class |
System.String | appt_type |
System.String | case_id |
System.String | user_name |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

IFCFO.modify_appt(Int32, String, String, Int32, String, String, String, String, String, String)

Declaration
[AltName("Update_appointment")]
public short IFCFO.modify_appt([ParameterRequired, AltName("appointment_ObjID")] int appt_objid, [AltName("start_date")] string start_time, [AltName("end_date")] string end_time, [AltType("System.TimeSpan", "Convert.ToInt32({0}.TotalSeconds)")] int duration, string description, string cell_text, [AltName("appointment_class")] string appt_class, [AltName("appointment_type")] string appt_type, string user_name, [AltName("create_date")] string creation_time)
Parameters
Type | Name | Description
System.Int32 | appt_objid |
System.String | start_time |
System.String | end_time |
System.Int32 | duration |
System.String | description |
System.String | cell_text |
System.String | appt_class |
System.String | appt_type |
System.String | user_name |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

IFCFO.modify_expense_log(Int32, String, String, String, String, String, Double, Double, Int32, String, String)

Declaration
[AltName("update_expense_log")]
public short IFCFO.modify_expense_log([ParameterRequired] int expense_log_objid, [AltName("create_date")] string creation_time, [AltName("performed_by_user_name")] string perf_by, [ParameterVoid] string notes, string user_name, string expense_type, [ParameterRequired] double quantity, [ParameterRequired, AltName("rate")] double the_rate, [AltType("System.Boolean", "{0} ? 1 : 0"), AltName("is_billable")] int billable, string bill_to, string resolution)
Parameters
Type | Name | Description
System.Int32 | expense_log_objid |
System.String | creation_time |
System.String | perf_by |
System.String | notes |
System.String | user_name |
System.String | expense_type |
System.Double | quantity |
System.Double | the_rate |
System.Int32 | billable |
System.String | bill_to |
System.String | resolution |
Returns
Type | Description
System.Int16 |

IFCFO.modify_sp(Int32, String, String, String, String, String, String, Int32, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[AltName("Update_site_part")]
[OutputProperty("ret_objid", "SitePart")]
public short IFCFO.modify_sp([ParameterRequired, AltName("site_part_ObjID")] int sp_objid, string instance_name, [AltName("serial_number")] string serial_num, [AltName("invoice_number")] string invoice_no, string ship_date, string install_date, string warranty_date, [ParameterDefaultValue("1")] int quantity, string part_status, string comments, [AltName("service_end_date")] string service_end_dt, string user_name, [AltName("part_revision")] string mod_level, [AltName("Add_Activity_Log"), ParameterDefaultValue("true"), ParameterRequired] bool add_activity, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.Int32 | sp_objid |
System.String | instance_name |
System.String | serial_num |
System.String | invoice_no |
System.String | ship_date |
System.String | install_date |
System.String | warranty_date |
System.Int32 | quantity |
System.String | part_status |
System.String | comments |
System.String | service_end_dt |
System.String | user_name |
System.String | mod_level |
System.Boolean | add_activity |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCFO.modify_sp_list(Int32, String, String, String, String, String, String, Int32, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[AltName("Update_site_part")]
[OutputProperty("ret_objid", "SitePart")]
public short IFCFO.modify_sp_list([ParameterRequired, AltName("site_part_ObjID")] int sp_objid, string instance_name, [AltName("serial_number")] string serial_num, [AltName("invoice_number")] string invoice_no, string ship_date, string install_date, string warranty_date, [ParameterDefaultValue("1")] int quantity, string part_status, string comments, [AltName("service_end_date")] string service_end_dt, string user_name, [AltName("part_revision")] string mod_level, [AltName("Add_Activity_Log"), ParameterDefaultValue("true")] bool add_activity, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.Int32 | sp_objid |
System.String | instance_name |
System.String | serial_num |
System.String | invoice_no |
System.String | ship_date |
System.String | install_date |
System.String | warranty_date |
System.Int32 | quantity |
System.String | part_status |
System.String | comments |
System.String | service_end_dt |
System.String | user_name |
System.String | mod_level |
System.Boolean | add_activity |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCFO.modify_svc_inter(Int32, String, String, String, Int32, String, String, String, String)

Declaration
[AltName("Update_service_interruption")]
public short IFCFO.modify_svc_inter([ParameterRequired, AltName("appointment_ObjID")] int appt_objid, [AltName("description")] string desc, [AltName("start_date")] string start_time, [AltName("end_date")] string end_time, [AltType("System.TimeSpan", "Convert.ToInt32({0}.TotalSeconds)")] int duration, [AltName("service_class")] string svc_class, [AltName("service_type")] string svc_type, string user_name, [AltName("create_date")] string creation_time)
Parameters
Type | Name | Description
System.Int32 | appt_objid |
System.String | desc |
System.String | start_time |
System.String | end_time |
System.Int32 | duration |
System.String | svc_class |
System.String | svc_type |
System.String | user_name |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

IFCFO.modify_time_log(Int32, String, String, String, String, String, String, Int32, Int32, String, String, String)

Declaration
[AltName("update_time_log")]
public short IFCFO.modify_time_log([ParameterRequired] int time_log_objid, [AltName("create_date")] string creation_time, [AltName("performed_by_user_name")] string perf_by, [ParameterVoid] string notes, string user_name, string time_type, [ParameterVoid] string start_time, [AltType("System.TimeSpan", "Convert.ToInt32({0}.TotalSeconds)")] int duration, [AltType("System.Boolean", "{0} ? 1 : 0"), AltName("is_billable")] int billable, string bill_to, [AltName("work_center")] string wrk_center, string resolution)
Parameters
Type | Name | Description
System.Int32 | time_log_objid |
System.String | creation_time |
System.String | perf_by |
System.String | notes |
System.String | user_name |
System.String | time_type |
System.String | start_time |
System.Int32 | duration |
System.Int32 | billable |
System.String | bill_to |
System.String | wrk_center |
System.String | resolution |
Returns
Type | Description
System.Int16 |

IFCFO.move_sp(Int32, String, Int32, String, Int32, Boolean, String, Boolean)

Declaration
[SplitMethod("move_site_part_to_site")]
[SplitMethod("move_site_part_to_bin")]
[SplitMethod("move_site_part_to_part")]
public short IFCFO.move_sp([ParameterRequired, AltName("site_part_ObjID")] int sp_objid, string move_date, [ParameterRequired("move_site_part_to_part"), ParameterDefaultValue("-1"), ParameterVoid("move_site_part_to_site"), ParameterVoid("move_site_part_to_bin"), AltName("parent_site_part_ObjID")] int parent_sp_objid, [ParameterRequired("move_site_part_to_site"), ParameterVoid("move_site_part_to_part"), ParameterVoid("move_site_part_to_bin"), AltName("site_IDNum")] string site_id, [ParameterRequired("move_site_part_to_bin"), ParameterDefaultValue("-1"), ParameterVoid("move_site_part_to_part"), ParameterVoid("move_site_part_to_site")] int parent_bin_objid, [AltName("Add_Activity_Log"), ParameterDefaultValue("true")] bool add_activity, string user_name, [ParameterDefaultValue("true")] bool install_and_move)
Parameters
Type | Name | Description
System.Int32 | sp_objid |
System.String | move_date |
System.Int32 | parent_sp_objid |
System.String | site_id |
System.Int32 | parent_bin_objid |
System.Boolean | add_activity |
System.String | user_name |
System.Boolean | install_and_move |
Returns
Type | Description
System.Int16 |

IFCFO.part_transfer(String, String, String, Int32, String, String, String, String, Boolean, String, String, String, Boolean, String, String, String, String, Boolean, Int16, String, String, String, String)

Declaration
[SplitMethod("part_transfer", 2)]
[OutputProperty("ret_objid", "Objid of the Part Transfer record.")]
[OutputProperty("ret_string", "StandardCost", "System.Decimal", "0M", "Part Transfer Standard Cost.", "(retVal == 0) ? decimal.Parse({0}) : 0M")]
[OutputProperty("ret_id_num", "TransactionIDNum", "System.String", "String.Empty", "Part Transfer Transaction Identifier.")]
[FacadeProperty("FromLocation", "FChoice.Toolkits.Clarify.Location", "FChoice.Toolkits.Clarify.Location.EMPTY", "if({0}.IsLocationNameDirty) {2}.InternalFromLocation = {0}.LocationName; if({0}.IsBinNameDirty) {2}.InternalFromBin = {0}.BinName; if({0}.IsContainerIDNumDirty) {2}.InternalFromContainer = {0}.ContainerIDNum;", true, false, "part_transfer", "0:4,1:4", 70014)]
[FacadeProperty("ToLocation", "FChoice.Toolkits.Clarify.Location", "FChoice.Toolkits.Clarify.Location.EMPTY", "if({0}.IsLocationNameDirty) {2}.InternalToLocation = {0}.LocationName; if({0}.IsBinNameDirty) {2}.InternalToBin = {0}.BinName; if({0}.IsContainerIDNumDirty) {2}.InternalToContainer = {0}.ContainerIDNum;", true, false, "part_transfer", "0:5,1:5", 70015)]
public short IFCFO.part_transfer([ParameterRequired, AltName("part_number")] string part_num, [ParameterRequired, AltName("part_revision")] string mod_level, [ParameterRequired, AltName("part_domain")] string domain_name, [ParameterRequired(null, 0), ParameterDefaultValue("1"), AltName("quantity")] int quantity_num, [ParameterRequired(null, 1), AltName("serial_Number")] string serial_num, [ParameterVoid, AltName("internal_from_location")] string from_loc, [ParameterVoid, AltName("internal_from_bin")] string from_bin, [ParameterVoid, AltName("internal_from_container")] string from_cont, [ParameterDefaultValue("true")] bool from_good, [ParameterVoid, AltName("internal_to_location")] string to_loc, [ParameterVoid, AltName("internal_to_bin")] string to_bin, [ParameterVoid, AltName("internal_to_container")] string to_cont, [ParameterDefaultValue("true")] bool to_good, string user_name, [AltName("transfer_date")] string trans_date, [AltName("reference_IDNum")] string ref_id, [AltName("notes")] string note_str, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs, [ParameterVoid, ParameterDefaultValue("0")] short fifo_flag, [ParameterVoid, AltType("System.Double", "{1} ? {0}.ToString() : string.Empty")] string update_cost, [ParameterVoid] string update_source, [ParameterVoid, AltName("transaction_ID")] string trans_id, [ParameterVoid, AltName("standard_cost")] string std_cost)
Parameters
Type | Name | Description
System.String | part_num |
System.String | mod_level |
System.String | domain_name |
System.Int32 | quantity_num |
System.String | serial_num |
System.String | from_loc |
System.String | from_bin |
System.String | from_cont |
System.Boolean | from_good |
System.String | to_loc |
System.String | to_bin |
System.String | to_cont |
System.Boolean | to_good |
System.String | user_name |
System.String | trans_date |
System.String | ref_id |
System.String | note_str |
System.Boolean | gen_time_bombs |
System.Int16 | fifo_flag |
System.String | update_cost |
System.String | update_source |
System.String | trans_id |
System.String | std_cost |
Returns
Type | Description
System.Int16 |

IFCFO.reinstall_sp(Int32, String, Int32, Int32, String, String, Boolean, Boolean)

Declaration
[AltName("reinstall_site_part")]
public short IFCFO.reinstall_sp([ParameterRequired, AltName("site_part_ObjID")] int sp_objid, [ParameterRequired, AltName("site_IDNum")] string site_id, int parent_bin_objid, [AltName("parent_site_part_ObjID")] int parent_sp_objid, string user_name, [AltName("reinstall_date")] string reinst_date, [AltName("Add_Activity_Log"), ParameterDefaultValue("true")] bool add_activity, bool use_install)
Parameters
Type | Name | Description
System.Int32 | sp_objid |
System.String | site_id |
System.Int32 | parent_bin_objid |
System.Int32 | parent_sp_objid |
System.String | user_name |
System.String | reinst_date |
System.Boolean | add_activity |
System.Boolean | use_install |
Returns
Type | Description
System.Int16 |

IFCFO.ret_id_num

Declaration
public string IFCFO.ret_id_num { get; }
Returns
Type | Description
System.String |

IFCFO.ret_objid

Declaration
public int IFCFO.ret_objid { get; }
Returns
Type | Description
System.Int32 |

IFCFO.ret_objid2

Declaration
public int IFCFO.ret_objid2 { get; }
Returns
Type | Description
System.Int32 |

IFCFO.ret_string

Declaration
public string IFCFO.ret_string { get; }
Returns
Type | Description
System.String |

IToolkit.ReturnIDNum

Declaration
public string IToolkit.ReturnIDNum { get; }
Returns
Type | Description
System.String |

IToolkit.ReturnObjid

Declaration
public int IToolkit.ReturnObjid { get; }
Returns
Type | Description
System.Int32 |

Implements

IFCFO
IToolkit


Class FCFOBase | fcSDK Documentation

Class FCFOBase

Inheritance
System.Object
FCFOBase
FCFO
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Compatibility.Toolkits
Assembly: FChoice.Foundation.Clarify.Compatibility.Toolkits.dll
Syntax
[ComVisible(false)]
public abstract class FCFOBase

Constructors

FCFOBase()

Declaration
protected FCFOBase()

FCFOBase(IFCApplication, IFCSession)

Declaration
protected FCFOBase(IFCApplication FCApp, IFCSession FCSess)
Parameters
Type | Name | Description
IFCApplication | FCApp |
IFCSession | FCSess |

Fields

PartUsedVarianceVirtualInventoryLocationName

Declaration
public static readonly string PartUsedVarianceVirtualInventoryLocationName
Field Value
Type | Description
System.String |

ServiceCOGSVirtualInventoryLocationName

Declaration
public static readonly string ServiceCOGSVirtualInventoryLocationName
Field Value
Type | Description
System.String |

Properties

_impersonatorUserName

Declaration
protected string _impersonatorUserName { get; set; }
Property Value
Type | Description
System.String |

_object_name

Declaration
protected string _object_name { get; set; }
Property Value
Type | Description
System.String |

_ret_id_num

Declaration
protected string _ret_id_num { get; set; }
Property Value
Type | Description
System.String |

_ret_objid

Declaration
protected int _ret_objid { get; set; }
Property Value
Type | Description
System.Int32 |

_ret_objid2

Declaration
protected int _ret_objid2 { get; set; }
Property Value
Type | Description
System.Int32 |

_ret_string

Declaration
protected string _ret_string { get; set; }
Property Value
Type | Description
System.String |

Methods

_add_svc_inter(String, Int32, String, String, String, Int32, String, String, String, String)

Declaration
protected short _add_svc_inter(string case_id, int sp_objid, string description, string start_time, string end_time, int duration, string svc_class, string svc_type, string user_name, string creation_time)
Parameters
Type | Name | Description
System.String | case_id |
System.Int32 | sp_objid |
System.String | description |
System.String | start_time |
System.String | end_time |
System.Int32 | duration |
System.String | svc_class |
System.String | svc_type |
System.String | user_name |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

_create_expense_log(Int32, String, String, String, String, String, String, Double, Double, Int32, String, String)

Declaration
protected short _create_expense_log(int onsite_objid, string id_num, string creation_time, string notes, string perf_by, string user_name, string expense_type, double quantity, double the_rate, int billable, string bill_to, string resolution)
Parameters
Type | Name | Description
System.Int32 | onsite_objid |
System.String | id_num |
System.String | creation_time |
System.String | notes |
System.String | perf_by |
System.String | user_name |
System.String | expense_type |
System.Double | quantity |
System.Double | the_rate |
System.Int32 | billable |
System.String | bill_to |
System.String | resolution |
Returns
Type | Description
System.Int16 |

_create_onsite_log(String, String, String, String, String, String, String, String)

Declaration
protected short _create_onsite_log(string object_type, string object_id, string creation_time, string last_modified, string notes, string resolution, string user_name, string perf_by)
Parameters
Type | Name | Description
System.String | object_type |
System.String | object_id |
System.String | creation_time |
System.String | last_modified |
System.String | notes |
System.String | resolution |
System.String | user_name |
System.String | perf_by |
Returns
Type | Description
System.Int16 |

_create_time_log(Int32, String, String, String, String, String, String, String, Int32, Int32, String, String, String)

Declaration
protected short _create_time_log(int onsite_objid, string id_num, string creation_time, string notes, string perf_by, string user_name, string time_type, string start_time, int duration, int billable, string bill_to, string wrk_center, string resolution)
Parameters
Type | Name | Description
System.Int32 | onsite_objid |
System.String | id_num |
System.String | creation_time |
System.String | notes |
System.String | perf_by |
System.String | user_name |
System.String | time_type |
System.String | start_time |
System.Int32 | duration |
System.Int32 | billable |
System.String | bill_to |
System.String | wrk_center |
System.String | resolution |
Returns
Type | Description
System.Int16 |

_deinstall_sp(Int32, String, String, Boolean)

Declaration
protected short _deinstall_sp(int sp_objid, string user_name, string deinstall_date, bool use_remove)
Parameters
Type | Name | Description
System.Int32 | sp_objid |
System.String | user_name |
System.String | deinstall_date |
System.Boolean | use_remove |
Returns
Type | Description
System.Int16 |

_delete_appt(Int32, String, String)

Declaration
protected short _delete_appt(int appt_objid, string user_name, string creation_time)
Parameters
Type | Name | Description
System.Int32 | appt_objid |
System.String | user_name |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

_delete_expense_log(Int32, String, String)

Declaration
protected short _delete_expense_log(int expense_objid, string last_modified, string user_name)
Parameters
Type | Name | Description
System.Int32 | expense_objid |
System.String | last_modified |
System.String | user_name |
Returns
Type | Description
System.Int16 |

_delete_onsite_log(Int32, String, String)

Declaration
protected short _delete_onsite_log(int onsite_log_objid, string note_date, string user_name)
Parameters
Type | Name | Description
System.Int32 | onsite_log_objid |
System.String | note_date |
System.String | user_name |
Returns
Type | Description
System.Int16 |

_delete_svc_inter(Int32, String, String)

Declaration
protected short _delete_svc_inter(int appt_objid, string user_name, string creation_time)
Parameters
Type | Name | Description
System.Int32 | appt_objid |
System.String | user_name |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

_delete_time_log(Int32, String, String)

Declaration
protected short _delete_time_log(int time_objid, string last_modified, string user_name)
Parameters
Type | Name | Description
System.Int32 | time_objid |
System.String | last_modified |
System.String | user_name |
Returns
Type | Description
System.Int16 |

_dispatch_fe(String, String, String, String, String, Int32, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int32, String, String, Int32, Boolean)

Declaration
protected short _dispatch_fe(string case_id, string user_name, string dispatch_time, string work_order, string appointment_time, int duration, string description, string cont_fname, string cont_lname, string address1, string address2, string city, string state, string zipcode, string main_phone, string alt_phone, string site_id, string pay_method, string ref_number, string notes, string requested_eta, int appt_confirm, string cell_text, string proxy, int removed, bool gen_time_bomb)
Parameters
Type | Name | Description
System.String | case_id |
System.String | user_name |
System.String | dispatch_time |
System.String | work_order |
System.String | appointment_time |
System.Int32 | duration |
System.String | description |
System.String | cont_fname |
System.String | cont_lname |
System.String | address1 |
System.String | address2 |
System.String | city |
System.String | state |
System.String | zipcode |
System.String | main_phone |
System.String | alt_phone |
System.String | site_id |
System.String | pay_method |
System.String | ref_number |
System.String | notes |
System.String | requested_eta |
System.Int32 | appt_confirm |
System.String | cell_text |
System.String | proxy |
System.Int32 | removed |
System.Boolean | gen_time_bomb |
Returns
Type | Description
System.Int16 |

_Initialize(IFCApplication, IFCSession)

Declaration
public void _Initialize(IFCApplication TheFCApplication, IFCSession TheFCSession)
Parameters
Type | Name | Description
IFCApplication | TheFCApplication |
IFCSession | TheFCSession |

_install_sp(String, String, String, String, Int32, String, Int32, Int32, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _install_sp(string site_id, string part_num, string mod_level, string domain, int quantity, string serial_num, int parent_bin_objid, int parent_sp_objid, string instance_name, string comment, string part_status, string invoice_no, string user_name, string install_date, string ship_date, bool add_activity, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | site_id |
System.String | part_num |
System.String | mod_level |
System.String | domain |
System.Int32 | quantity |
System.String | serial_num |
System.Int32 | parent_bin_objid |
System.Int32 | parent_sp_objid |
System.String | instance_name |
System.String | comment |
System.String | part_status |
System.String | invoice_no |
System.String | user_name |
System.String | install_date |
System.String | ship_date |
System.Boolean | add_activity |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_install_sp_list(String, String, String, String, Int32, String, Int32, Int32, String, String, String, String, String, String, String, Boolean)

Declaration
protected short _install_sp_list(string site_id, string part_num, string mod_level, string domain, int quantity, string serial_num, int parent_bin_objid, int parent_sp_objid, string instance_name, string comment, string part_status, string invoice_no, string user_name, string install_date, string ship_date, bool add_activity)
Parameters
Type | Name | Description
System.String | site_id |
System.String | part_num |
System.String | mod_level |
System.String | domain |
System.Int32 | quantity |
System.String | serial_num |
System.Int32 | parent_bin_objid |
System.Int32 | parent_sp_objid |
System.String | instance_name |
System.String | comment |
System.String | part_status |
System.String | invoice_no |
System.String | user_name |
System.String | install_date |
System.String | ship_date |
System.Boolean | add_activity |
Returns
Type | Description
System.Int16 |

_install_sp_list(String, String, String, String, Int32, String, Int32, Int32, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _install_sp_list(string site_id, string part_num, string mod_level, string domain, int quantity, string serial_num, int parent_bin_objid, int parent_sp_objid, string instance_name, string comment, string part_status, string invoice_no, string user_name, string install_date, string ship_date, bool add_activity, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | site_id |
System.String | part_num |
System.String | mod_level |
System.String | domain |
System.Int32 | quantity |
System.String | serial_num |
System.Int32 | parent_bin_objid |
System.Int32 | parent_sp_objid |
System.String | instance_name |
System.String | comment |
System.String | part_status |
System.String | invoice_no |
System.String | user_name |
System.String | install_date |
System.String | ship_date |
System.Boolean | add_activity |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_log_parts_used(String, String, String, Int32, Boolean, Int32, String, String, String, Boolean, String, String, String, String, String, Int32, String, String, String, String, Boolean, String, String, Boolean, String, Int32)

Declaration
protected short _log_parts_used(string dtl_num, string case_id, string pu_type, int parent_sp, bool install_at_site, int remove_sp, string to_loc, string to_bin, string to_cont, bool to_good, string fail_code, string inst_part, string inst_rev, string inst_domain, string serialNumber, int inst_qty, string inst_price, string from_loc, string from_bin, string from_cont, bool from_good, string engineer_name, string user_name, bool allow_move, string log_date, int log_objid)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | case_id |
System.String | pu_type |
System.Int32 | parent_sp |
System.Boolean | install_at_site |
System.Int32 | remove_sp |
System.String | to_loc |
System.String | to_bin |
System.String | to_cont |
System.Boolean | to_good |
System.String | fail_code |
System.String | inst_part |
System.String | inst_rev |
System.String | inst_domain |
System.String | serialNumber |
System.Int32 | inst_qty |
System.String | inst_price |
System.String | from_loc |
System.String | from_bin |
System.String | from_cont |
System.Boolean | from_good |
System.String | engineer_name |
System.String | user_name |
System.Boolean | allow_move |
System.String | log_date |
System.Int32 | log_objid |
Returns
Type | Description
System.Int16 |

_make_appt(String, String, String, Int32, String, String, String, Int32, String, String, String, String, String)

Declaration
protected short _make_appt(string description, string start_time, string end_time, int duration, string cell_text, string emp_first, string emp_last, int site_part_objid, string appt_class, string appt_type, string case_id, string user_name, string creation_time)
Parameters
Type | Name | Description
System.String | description |
System.String | start_time |
System.String | end_time |
System.Int32 | duration |
System.String | cell_text |
System.String | emp_first |
System.String | emp_last |
System.Int32 | site_part_objid |
System.String | appt_class |
System.String | appt_type |
System.String | case_id |
System.String | user_name |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

_modify_appt(Int32, String, String, Int32, String, String, String, String, String, String)

Declaration
protected short _modify_appt(int appt_objid, string start_time, string end_time, int duration, string description, string cell_text, string appt_class, string appt_type, string user_name, string creation_time)
Parameters
Type | Name | Description
System.Int32 | appt_objid |
System.String | start_time |
System.String | end_time |
System.Int32 | duration |
System.String | description |
System.String | cell_text |
System.String | appt_class |
System.String | appt_type |
System.String | user_name |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

_modify_expense_log(Int32, String, String, String, String, String, Double, Double, Int32, String, String)

Declaration
protected short _modify_expense_log(int expense_log_objid, string creation_time, string perf_by, string notes, string user_name, string expense_type, double quantity, double the_rate, int billable, string bill_to, string resolution)
Parameters
Type | Name | Description
System.Int32 | expense_log_objid |
System.String | creation_time |
System.String | perf_by |
System.String | notes |
System.String | user_name |
System.String | expense_type |
System.Double | quantity |
System.Double | the_rate |
System.Int32 | billable |
System.String | bill_to |
System.String | resolution |
Returns
Type | Description
System.Int16 |

_modify_sp(Int32, String, String, String, String, String, String, Int32, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _modify_sp(int sp_objid, string instance_name, string serial_num, string invoice_no, string ship_date, string install_date, string warranty_date, int quantity, string part_status, string comments, string service_end_dt, string user_name, string mod_level, bool add_activity, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.Int32 | sp_objid |
System.String | instance_name |
System.String | serial_num |
System.String | invoice_no |
System.String | ship_date |
System.String | install_date |
System.String | warranty_date |
System.Int32 | quantity |
System.String | part_status |
System.String | comments |
System.String | service_end_dt |
System.String | user_name |
System.String | mod_level |
System.Boolean | add_activity |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_modify_sp_list(Int32, String, String, String, String, String, String, Int32, String, String, String, String, String, Boolean)

Declaration
protected short _modify_sp_list(int sp_objid, string instance_name, string serial_num, string invoice_no, string ship_date, string install_date, string warranty_date, int quantity, string part_status, string comments, string service_end_dt, string user_name, string mod_level, bool add_activity)
Parameters
Type | Name | Description
System.Int32 | sp_objid |
System.String | instance_name |
System.String | serial_num |
System.String | invoice_no |
System.String | ship_date |
System.String | install_date |
System.String | warranty_date |
System.Int32 | quantity |
System.String | part_status |
System.String | comments |
System.String | service_end_dt |
System.String | user_name |
System.String | mod_level |
System.Boolean | add_activity |
Returns
Type | Description
System.Int16 |

_modify_sp_list(Int32, String, String, String, String, String, String, Int32, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _modify_sp_list(int sp_objid, string instance_name, string serial_num, string invoice_no, string ship_date, string install_date, string warranty_date, int quantity, string part_status, string comments, string service_end_dt, string user_name, string mod_level, bool add_activity, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.Int32 | sp_objid |
System.String | instance_name |
System.String | serial_num |
System.String | invoice_no |
System.String | ship_date |
System.String | install_date |
System.String | warranty_date |
System.Int32 | quantity |
System.String | part_status |
System.String | comments |
System.String | service_end_dt |
System.String | user_name |
System.String | mod_level |
System.Boolean | add_activity |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_modify_svc_inter(Int32, String, String, String, Int32, String, String, String, String)

Declaration
protected short _modify_svc_inter(int appt_objid, string desc, string start_time, string end_time, int duration, string svc_class, string svc_type, string user_name, string creation_time)
Parameters
Type | Name | Description
System.Int32 | appt_objid |
System.String | desc |
System.String | start_time |
System.String | end_time |
System.Int32 | duration |
System.String | svc_class |
System.String | svc_type |
System.String | user_name |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

_modify_time_log(Int32, String, String, String, String, String, String, Int32, Int32, String, String, String)

Declaration
protected short _modify_time_log(int time_log_objid, string creation_time, string perf_by, string notes, string user_name, string time_type, string start_time, int duration, int billable, string bill_to, string wrk_center, string resolution)
Parameters
Type | Name | Description
System.Int32 | time_log_objid |
System.String | creation_time |
System.String | perf_by |
System.String | notes |
System.String | user_name |
System.String | time_type |
System.String | start_time |
System.Int32 | duration |
System.Int32 | billable |
System.String | bill_to |
System.String | wrk_center |
System.String | resolution |
Returns
Type | Description
System.Int16 |

_move_sp(Int32, String, Int32, String, Int32, Boolean, String, Boolean)

Declaration
protected short _move_sp(int sp_objid, string move_date, int parent_sp_objid, string site_id, int parent_bin_objid, bool add_activity, string user_name, bool install_and_move)
Parameters
Type | Name | Description
System.Int32 | sp_objid |
System.String | move_date |
System.Int32 | parent_sp_objid |
System.String | site_id |
System.Int32 | parent_bin_objid |
System.Boolean | add_activity |
System.String | user_name |
System.Boolean | install_and_move |
Returns
Type | Description
System.Int16 |

_part_transfer(String, String, String, Int32, String, String, String, String, Boolean, String, String, String, Boolean, String, String, String, String, Boolean, Int16, String, String, String, String)

Declaration
protected short _part_transfer(string part_num, string mod_level, string domain_name, int quantity_num, string serial_num, string from_loc, string from_bin, string from_cont, bool from_good, string to_loc, string to_bin, string to_cont, bool to_good, string user_name, string trans_date, string ref_id, string note_str, bool gen_time_bombs, short fifo_flag, string update_cost, string update_source, string trans_id, string std_cost)
Parameters
Type | Name | Description
System.String | part_num |
System.String | mod_level |
System.String | domain_name |
System.Int32 | quantity_num |
System.String | serial_num |
System.String | from_loc |
System.String | from_bin |
System.String | from_cont |
System.Boolean | from_good |
System.String | to_loc |
System.String | to_bin |
System.String | to_cont |
System.Boolean | to_good |
System.String | user_name |
System.String | trans_date |
System.String | ref_id |
System.String | note_str |
System.Boolean | gen_time_bombs |
System.Int16 | fifo_flag |
System.String | update_cost |
System.String | update_source |
System.String | trans_id |
System.String | std_cost |
Returns
Type | Description
System.Int16 |

_reinstall_sp(Int32, String, Int32, Int32, String, String, Boolean, Boolean)

Declaration
protected short _reinstall_sp(int sp_objid, string site_id, int parent_bin_objid, int parent_sp_objid, string user_name, string reinst_date, bool add_activity, bool use_install)
Parameters
Type | Name | Description
System.Int32 | sp_objid |
System.String | site_id |
System.Int32 | parent_bin_objid |
System.Int32 | parent_sp_objid |
System.String | user_name |
System.String | reinst_date |
System.Boolean | add_activity |
System.Boolean | use_install |
Returns
Type | Description
System.Int16 |

GetProductID()

Declaration
protected abstract int GetProductID()
Returns
Type | Description
System.Int32 |


Class FCINTER | fcSDK Documentation

Class FCINTER

Inheritance
System.Object
FCINTERBase
FCINTER
Implements
IFCINTER
IToolkit
Inherited Members
FCINTERBase._Initialize(IFCApplication, IFCSession)
FCINTERBase._create_address_list(String, String, String, String, Boolean, String, String, String, IFCList, IFCList, IFCList)
FCINTERBase._create_address(String, String, String, String, Boolean, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)
FCINTERBase._update_address_list(Int32, String, String, String, String, Boolean, String, String, String, IFCList, IFCList, IFCList)
FCINTERBase._update_address(Int32, String, String, String, String, Boolean, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)
FCINTERBase._create_country(String, Int32, String, String, String, Double, String)
FCINTERBase._create_state(String, String, Boolean, String)
FCINTERBase._create_time_zone(String, String, String, Int32)
FCINTERBase._create_update_site_list(Int32, String, String, String, String, String, String, String, String, String, Int32, Int32, Int32, String, String, Int32, Int32, IFCList, IFCList, IFCList)
FCINTERBase._create_update_site(Int32, String, String, String, String, String, String, String, String, String, Int32, Int32, Int32, String, String, Int32, Int32, String, Int32, String, Int32, String, String, String, String, String, String)
FCINTERBase._create_bom(String, String, String, String, String, String, Int32)
FCINTERBase._create_price_inst(String, String, String, String, Int16, Int32, String, String, String)
FCINTERBase._update_price_inst(String, String, String, String, Int32, String, String)
FCINTERBase._create_soln_list(String, String, String, Boolean, String, String, String, String, Boolean, IFCList, IFCList, IFCList)
FCINTERBase._create_soln(String, String, String, Boolean, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)
FCINTERBase._add_workaround_list(String, Int32, String, Boolean, String, String, IFCList, IFCList, IFCList)
FCINTERBase._add_workaround(String, Int32, String, Boolean, String, String, String, Int32, String, Int32, String, String, String, String, String, String)
FCINTERBase._link_case_to_workaround(String, Int32, String, String, Boolean)
FCINTERBase._unlink_case_from_workaround(String, String, String, Boolean)
FCINTERBase._link_cr_to_soln(String, String, String, String, Boolean)
FCINTERBase._unlink_cr_from_soln(String, String, String, String, Boolean)
FCINTERBase._create_update_account_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, String, IFCList, IFCList, IFCList)
FCINTERBase._create_update_account(String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, String, String, Int32, String, Int32, String, String, String, String, String, String)
FCINTERBase._add_site_to_bus_org(String, String, String)
FCINTERBase._remove_site_from_bus_org(String, String, String)
FCINTERBase._add_emp_to_bus_org(String, String, String)
FCINTERBase._remove_emp_from_bus_org(String, String, String)
FCINTERBase._update_contact_objid_list(Int32, String, String, String, String, String, String, String, String, String, String, String, String, String, String, IFCList, IFCList, IFCList)
FCINTERBase._update_contact_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, IFCList, IFCList, IFCList)
FCINTERBase._update_contact(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)
FCINTERBase._update_contact(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)
FCINTERBase._create_contact_list(String, String, String, String, String, String, String, String, String, String, String, IFCList, IFCList, IFCList)
FCINTERBase._create_contact(String, String, String, String, String, String, String, String, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)
FCINTERBase._create_update_wipbin(String, String, String, String, Boolean)
FCINTERBase._create_update_queue(String, Boolean, String, Int16, Int16, Int16, Int16, Int16, Int16, Int16, Int16, Int16, Int16, String, String)
FCINTERBase._add_user_to_queue(String, String, Boolean)
FCINTERBase._create_update_part_list(String, String, String, String, String, Int32, Boolean, String, String, String, String, String, String, String, String, IFCList, IFCList, IFCList)
FCINTERBase._create_update_part(String, String, String, String, String, Int32, Boolean, String, String, String, String, String, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)
FCINTERBase._create_update_mod_level(String, String, String, String, String, String, String, String, Boolean, String)
FCINTERBase._create_update_contract_list(String, String, String, String, String, Int32, Int32, String, String, String, String, Double, Double, Double, Int32, String, IFCList, IFCList, IFCList)
FCINTERBase._create_update_contract(String, String, String, String, String, Int32, Int32, String, String, String, String, Double, Double, Double, Int32, String, String, Int32, String, Int32, String, String, String, String, String, String)
FCINTERBase._add_site_to_contract(String, String)
FCINTERBase._remove_site_from_contract(String, String)
FCINTERBase._add_site_part_to_contract(String, String, Int32)
FCINTERBase._remove_site_part_from_contract(String, Int32)
FCINTERBase._add_contact_to_contract(String, String, String, String, String)
FCINTERBase._remove_contact_from_contract(String, Int32)
FCINTERBase._deinstall_sp(Int32, String, String, Boolean)
FCINTERBase._install_sp(String, String, String, String, Int32, String, Int32, Int32, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)
FCINTERBase._install_sp_list(String, String, String, String, Int32, String, Int32, Int32, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)
FCINTERBase._install_sp_list(String, String, String, String, Int32, String, Int32, Int32, String, String, String, String, String, String, String, Boolean)
FCINTERBase._modify_sp(Int32, String, String, String, String, String, String, Int32, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)
FCINTERBase._modify_sp_list(Int32, String, String, String, String, String, String, Int32, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)
FCINTERBase._modify_sp_list(Int32, String, String, String, String, String, String, Int32, String, String, String, String, String, Boolean)
FCINTERBase._move_sp(Int32, String, Int32, String, Int32, Boolean, String, Boolean)
FCINTERBase._reinstall_sp(Int32, String, Int32, Int32, String, String, Boolean, Boolean)
FCINTERBase._accept_solution(String, String, String, String, Boolean)
FCINTERBase._assign_solution(String, String, String, String, String, Boolean)
FCINTERBase._dispatch_solution(String, String, String, String, Boolean)
FCINTERBase._forward_solution(String, String, String, String, String, Boolean)
FCINTERBase._move_solution(String, String)
FCINTERBase._reject_solution(String, String, String, String, String, Boolean)
FCINTERBase._yank_solution(String, String, String, String, Boolean)
FCINTERBase._create_employee_list(String, String, String, String, String, String, String, String, String, String, String, Boolean, Boolean, String, String, String, String, String, Boolean, Boolean, String, String, String, String, String, String, String, String, String, String, IFCList, IFCList, IFCList)
FCINTERBase._create_employee(String, String, String, String, String, String, String, String, String, String, String, Boolean, Boolean, String, String, String, String, String, Boolean, Boolean, String, String, String, String, String, String, String, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)
FCINTERBase._create_interact_list(String, String, String, String, String, String, String, String, String, String, String, String, Boolean, String, Boolean, String, String, String, Int32, Int32, Int32, String, Boolean, IFCList, IFCList, IFCList)
FCINTERBase._create_interact(String, String, String, String, String, String, String, String, String, String, String, String, Boolean, String, Boolean, String, String, String, Int32, Int32, Int32, String, Boolean, String, Int32, String, String, String, String, String, String)
FCINTERBase._delete_product_bin(Int32, String, String)
FCINTERBase._modify_product_bin(Int32, String, String, Int32, Int32, String, String)
FCINTERBase._create_product_bin(String, String, Int32, String, Int32, Int32, String, String)
FCINTERBase._ret_id_num
FCINTERBase._ret_objid
FCINTERBase._ret_objid2
FCINTERBase._allow_duplicate_contact
FCINTERBase._useDatabaseLogins
FCINTERBase._impersonatorUserName
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Compatibility.Toolkits
Assembly: FChoice.Foundation.Clarify.Compatibility.Toolkits.dll
Syntax
[Guid("DC0E1117-672D-4d99-9B3F-0ABDA24BFF59")]
[ComVisible(true)]
[AltName("Interfaces")]
[ClassInterface(ClassInterfaceType.None)]
public sealed class FCINTER : FCINTERBase, IFCINTER, IToolkit

Constructors

FCINTER()

Declaration
public FCINTER()

FCINTER(IFCApplication, IFCSession)

Declaration
public FCINTER(IFCApplication FCApp, IFCSession FCSess)
Parameters
Type | Name | Description
IFCApplication | FCApp |
IFCSession | FCSess |

Methods

GetProductID()

Declaration
protected override int GetProductID()
Returns
Type | Description
System.Int32 |
Overrides
FCINTERBase.GetProductID()

update_contact_by_user(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[AltName("update_contact")]
[ComVisible(false)]
[OutputProperty("ret_objid", "Contact")]
public short update_contact_by_user([ParameterRequired, AltName("First_Name")] string first, [ParameterRequired, AltName("Last_Name")] string last, [ParameterRequired] string phone, [ParameterRequired, AltName("Site_IDNum")] string site_id, [ParameterRequired, AltName("role_name")] string role, string fax, string email, string mail_stop, [AltName("title")] string the_title, string hours, string salutation, [AltName("New_First_Name")] string new_first, [AltName("New_Last_Name")] string new_last, [AltName("New_Phone")] string new_phone, [AltName("New_Primary_Site_IDNum")] string new_prim_site_id, [AltName("New_Primary_Role")] string new_prim_role, string user_name, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | first |
System.String | last |
System.String | phone |
System.String | site_id |
System.String | role |
System.String | fax |
System.String | email |
System.String | mail_stop |
System.String | the_title |
System.String | hours |
System.String | salutation |
System.String | new_first |
System.String | new_last |
System.String | new_phone |
System.String | new_prim_site_id |
System.String | new_prim_role |
System.String | user_name |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

update_contact_by_user_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[AltName("update_contact_list")]
[ComVisible(false)]
[OutputProperty("ret_objid", "Contact")]
public short update_contact_by_user_list([ParameterRequired, AltName("First_Name")] string first, [ParameterRequired, AltName("Last_Name")] string last, [ParameterRequired] string phone, [ParameterRequired, AltName("Site_IDNum")] string site_id, [ParameterRequired, AltName("role_name")] string role, string fax, string email, string mail_stop, [AltName("title")] string the_title, string hours, string salutation, [AltName("New_First_Name")] string new_first, [AltName("New_Last_Name")] string new_last, [AltName("New_Phone")] string new_phone, [AltName("New_Primary_Site_IDNum")] string new_prim_site_id, [AltName("New_Primary_Role")] string new_prim_role, string user_name, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | first |
System.String | last |
System.String | phone |
System.String | site_id |
System.String | role |
System.String | fax |
System.String | email |
System.String | mail_stop |
System.String | the_title |
System.String | hours |
System.String | salutation |
System.String | new_first |
System.String | new_last |
System.String | new_phone |
System.String | new_prim_site_id |
System.String | new_prim_role |
System.String | user_name |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

Explicit Interface Implementations

IFCINTER.accept_solution(String, String, String, String, Boolean)

Declaration
public short IFCINTER.accept_solution([ParameterRequired, AltName("Solution_IDNum")] string solution_id, string accept_date, [AltName("wip_bin")] string wipbin, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | solution_id |
System.String | accept_date |
System.String | wipbin |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCINTER.add_contact_to_contract(String, String, String, String, String)

Declaration
[OutputProperty("ret_objid", "Objid of the Contract the Contact was added to.")]
public short IFCINTER.add_contact_to_contract([ParameterRequired, AltName("Contract_IDNum")] string contract_id, [ParameterRequired, AltName("Contact_First_Name")] string f_name, [ParameterRequired, AltName("Contact_Last_Name")] string l_name, [ParameterRequired, AltName("Contact_Phone")] string phone_num, [ParameterRequired, AltName("Site_IDNum")] string site_id)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | f_name |
System.String | l_name |
System.String | phone_num |
System.String | site_id |
Returns
Type | Description
System.Int16 |

IFCINTER.add_emp_to_bus_org(String, String, String)

Declaration
[OutputProperty("ret_objid", "Objid of the Employee Role that is created to link the Employee to the Account.")]
[AltName("Add_Employee_To_Account")]
public short IFCINTER.add_emp_to_bus_org([ParameterRequired] string user_name, [ParameterRequired, AltName("Account_IDNum")] string acct_id, string role_name)
Parameters
Type | Name | Description
System.String | user_name |
System.String | acct_id |
System.String | role_name |
Returns
Type | Description
System.Int16 |

IFCINTER.add_site_part_to_contract(String, String, Int32)

Declaration
public short IFCINTER.add_site_part_to_contract([ParameterRequired, AltName("Contract_IDNum")] string contract_id, [ParameterRequired, AltName("Site_IDNum")] string site_id, [ParameterRequired, AltName("Site_Part_ObjID")] int sp_objid)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | site_id |
System.Int32 | sp_objid |
Returns
Type | Description
System.Int16 |

IFCINTER.add_site_to_bus_org(String, String, String)

Declaration
[OutputProperty("ret_objid", "Objid of the Site Role that is created to link the Site to the Account.")]
[AltName("Add_Site_To_Account")]
public short IFCINTER.add_site_to_bus_org([ParameterRequired, AltName("site_IDNum")] string site_id, [ParameterRequired, AltName("Account_IDNum")] string acct_id, [ParameterRequired] string role_name)
Parameters
Type | Name | Description
System.String | site_id |
System.String | acct_id |
System.String | role_name |
Returns
Type | Description
System.Int16 |

IFCINTER.add_site_to_contract(String, String)

Declaration
public short IFCINTER.add_site_to_contract([ParameterRequired, AltName("Contract_IDNum")] string contract_id, [ParameterRequired, AltName("Site_IDNum")] string site_id)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | site_id |
Returns
Type | Description
System.Int16 |

IFCINTER.add_user_to_queue(String, String, Boolean)

Declaration
[OutputProperty("ret_objid", "Objid of the Queue the user was added to.")]
public short IFCINTER.add_user_to_queue([ParameterRequired] string queue, [ParameterRequired] string user_name, [AltName("Is_Supervisor")] bool supervisor)
Parameters
Type | Name | Description
System.String | queue |
System.String | user_name |
System.Boolean | supervisor |
Returns
Type | Description
System.Int16 |

IFCINTER.add_workaround(String, Int32, String, Boolean, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[SplitMethod("add_workaround", 2)]
[OutputProperty("ret_objid", "Workaround")]
public short IFCINTER.add_workaround([ParameterRequired("add_workaround", 0), AltName("solution_IDNum")] string soln_id, [ParameterRequired("add_workaround", 1), AltName("solution_ObjID")] int soln_objid, [ParameterRequired] string workaround, bool is_public, string create_date, [AltName("Resolution_Code")] string res_code, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | soln_id |
System.Int32 | soln_objid |
System.String | workaround |
System.Boolean | is_public |
System.String | create_date |
System.String | res_code |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCINTER.add_workaround_list(String, Int32, String, Boolean, String, String, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[SplitMethod("add_workaround_list", 2)]
[OutputProperty("ret_objid", "Workaround")]
public short IFCINTER.add_workaround_list([ParameterRequired(null, 0), AltName("solution_IDNum")] string soln_id, [ParameterRequired(null, 1), AltName("solution_ObjID")] int soln_objid, [ParameterRequired(null, 0), ParameterRequired(null, 1)] string workaround, bool is_public, string create_date, [AltName("Resolution_Code")] string res_code, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | soln_id |
System.Int32 | soln_objid |
System.String | workaround |
System.Boolean | is_public |
System.String | create_date |
System.String | res_code |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCINTER.allow_duplicate_contact

Declaration
public bool IFCINTER.allow_duplicate_contact { get; set; }
Returns
Type | Description
System.Boolean |

IFCINTER.assign_solution(String, String, String, String, String, Boolean)

Declaration
public short IFCINTER.assign_solution([ParameterRequired, AltName("Solution_IDNum")] string solution_id, string new_user, [AltName("wip_bin")] string wipbin, string assign_date, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | solution_id |
System.String | new_user |
System.String | wipbin |
System.String | assign_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCINTER.create_address(String, String, String, String, Boolean, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[FacadeVoid]
[OutputProperty("ret_objid", "Address")]
public short IFCINTER.create_address([ParameterRequired, AltName("Address1")] string addr1, [AltName("Address2")] string addr2, [ParameterRequired] string city, [ParameterRequired] string State, [ParameterDefaultValue("true"), AltName("is_short_state")] bool short_state, [AltName("Zip_Code")] string zip, [ParameterRequired] string Country, [ParameterRequired] string time_zone, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | addr1 |
System.String | addr2 |
System.String | city |
System.String | State |
System.Boolean | short_state |
System.String | zip |
System.String | Country |
System.String | time_zone |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCINTER.create_address_list(String, String, String, String, Boolean, String, String, String, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[OutputProperty("ret_objid", "Address")]
public short IFCINTER.create_address_list([ParameterRequired, AltName("Address1")] string addr1, [AltName("Address2")] string addr2, [ParameterRequired] string city, [ParameterRequired] string State, [ParameterDefaultValue("true"), AltName("is_short_state")] bool short_state, [ParameterRequired, AltName("Zip_Code")] string zip, [ParameterRequired] string Country, [ParameterRequired] string time_zone, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | addr1 |
System.String | addr2 |
System.String | city |
System.String | State |
System.Boolean | short_state |
System.String | zip |
System.String | Country |
System.String | time_zone |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCINTER.create_bom(String, String, String, String, String, String, Int32)

Declaration
[OutputProperty("ret_objid", "BOM")]
[AltName("Create_BOM")]
public short IFCINTER.create_bom([ParameterRequired, AltName("Parent_Part_Number")] string parent_part, [ParameterRequired, AltName("Parent_Part_Domain")] string parent_dom, [ParameterRequired, AltName("Parent_Part_Revision")] string parent_rev, [ParameterRequired, AltName("Child_Part_Number")] string child_part, [ParameterRequired, AltName("Child_Part_Domain")] string child_dom, [ParameterRequired, AltName("Child_Part_Revision")] string child_rev, [ParameterRequired] int quantity)
Parameters
Type | Name | Description
System.String | parent_part |
System.String | parent_dom |
System.String | parent_rev |
System.String | child_part |
System.String | child_dom |
System.String | child_rev |
System.Int32 | quantity |
Returns
Type | Description
System.Int16 |

IFCINTER.create_contact(String, String, String, String, String, String, String, String, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[OutputProperty("ret_objid", "Contact")]
[FacadeVoid]
public short IFCINTER.create_contact([ParameterRequired, AltName("First_Name")] string first, [ParameterRequired, AltName("Last_Name")] string last, [ParameterRequired] string phone, [ParameterRequired, AltName("Site_IDNum")] string site_id, [AltName("role_name")] string role, string fax, string email, string mail_stop, [AltName("title")] string the_title, string hours, string salutation, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | first |
System.String | last |
System.String | phone |
System.String | site_id |
System.String | role |
System.String | fax |
System.String | email |
System.String | mail_stop |
System.String | the_title |
System.String | hours |
System.String | salutation |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCINTER.create_contact_list(String, String, String, String, String, String, String, String, String, String, String, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[OutputProperty("ret_objid", "Contact")]
public short IFCINTER.create_contact_list([ParameterRequired, AltName("First_Name")] string first, [ParameterRequired, AltName("Last_Name")] string last, [ParameterRequired] string phone, [ParameterRequired, AltName("Site_IDNum")] string site_id, [AltName("role_name")] string role, string fax, string email, string mail_stop, [AltName("title")] string the_title, string hours, string salutation, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | first |
System.String | last |
System.String | phone |
System.String | site_id |
System.String | role |
System.String | fax |
System.String | email |
System.String | mail_stop |
System.String | the_title |
System.String | hours |
System.String | salutation |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCINTER.create_country(String, Int32, String, String, String, Double, String)

Declaration
[OutputProperty("ret_objid", "Country")]
public short IFCINTER.create_country([ParameterRequired, AltName("Country")] string cname, [ParameterRequired, AltName("Country_Code")] int c_code, [AltName("Currency")] string the_currency, [AltName("Currency_Symbol")] string symbol, [AltName("Currency_Description")] string desc, [AltName("Currency_Conversion_Rate")] double conv_rate, [AltName("Currency_ISO_code")] string iso_code)
Parameters
Type | Name | Description
System.String | cname |
System.Int32 | c_code |
System.String | the_currency |
System.String | symbol |
System.String | desc |
System.Double | conv_rate |
System.String | iso_code |
Returns
Type | Description
System.Int16 |

IFCINTER.create_employee(String, String, String, String, String, String, String, String, String, String, String, Boolean, Boolean, String, String, String, String, String, Boolean, Boolean, String, String, String, String, String, String, String, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[OutputProperty("ret_objid")]
[OutputProperty("ret_objid2")]
[FacadeVoid]
public short IFCINTER.create_employee([ParameterRequired] string first_name, [ParameterRequired] string last_name, [ParameterRequired] string login_name, [ParameterRequired] string password, [ParameterRequired, AltName("Site_IDNum")] string site_id, [ParameterRequired, AltName("Email")] string e_mail, string phone, string pager, [ParameterRequired, AltName("online_privilege_class")] string online_priv_class, [AltName("offline_privilege_class")] string offline_priv_class, [AltName("Employee_IDNum")] string Id, [ParameterDefaultValue("true")] bool is_active, bool allow_proxy, string start_date, string supervisor, string work_group, string work_group_start, string labor_rate, bool is_supervisor, bool is_fe, string normal_biz_high, string normal_biz_mid, string normal_biz_low, string after_biz_high, string after_biz_mid, string after_biz_low, string def_wipbin_title, string rc_config, string def_tablespace, string temp_tablespace, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | first_name |
System.String | last_name |
System.String | login_name |
System.String | password |
System.String | site_id |
System.String | e_mail |
System.String | phone |
System.String | pager |
System.String | online_priv_class |
System.String | offline_priv_class |
System.String | Id |
System.Boolean | is_active |
System.Boolean | allow_proxy |
System.String | start_date |
System.String | supervisor |
System.String | work_group |
System.String | work_group_start |
System.String | labor_rate |
System.Boolean | is_supervisor |
System.Boolean | is_fe |
System.String | normal_biz_high |
System.String | normal_biz_mid |
System.String | normal_biz_low |
System.String | after_biz_high |
System.String | after_biz_mid |
System.String | after_biz_low |
System.String | def_wipbin_title |
System.String | rc_config |
System.String | def_tablespace |
System.String | temp_tablespace |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCINTER.create_employee_list(String, String, String, String, String, String, String, String, String, String, String, Boolean, Boolean, String, String, String, String, String, Boolean, Boolean, String, String, String, String, String, String, String, String, String, String, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[OutputProperty("ret_objid", "EmployeeObjid", "System.Int32", "-1", "Objid of the Employee record created.")]
[OutputProperty("ret_objid2", "UserObjid", "System.Int32", "-1", "Objid of the User record created.")]
public short IFCINTER.create_employee_list([ParameterRequired] string first_name, [ParameterRequired] string last_name, [ParameterRequired] string login_name, [ParameterRequired] string password, [ParameterRequired, AltName("Site_IDNum")] string site_id, [ParameterRequired, AltName("Email")] string e_mail, string phone, string pager, [ParameterRequired, AltName("online_privilege_class")] string online_priv_class, [AltName("offline_privilege_class")] string offline_priv_class, [AltName("Employee_Identifier")] string Id, [ParameterDefaultValue("true")] bool is_active, bool allow_proxy, string start_date, string supervisor, string work_group, [AltName("Work_Group_Start_date")] string work_group_start, [AltType("System.Double", "{1} ? {0}.ToString() : string.Empty")] string labor_rate, bool is_supervisor, [AltName("Is_Field_Engineer")] bool is_fe, [AltName("Normal_Business_Hours_High")] string normal_biz_high, [AltName("Normal_Business_Hours_Med")] string normal_biz_mid, [AltName("Normal_Business_Hours_Low")] string normal_biz_low, [AltName("After_Business_Hours_High")] string after_biz_high, [AltName("After_Business_Hours_Med")] string after_biz_mid, [AltName("After_Business_Hours_Low")] string after_biz_low, [AltName("Default_Wip_bin_Title")] string def_wipbin_title, [AltName("Resource_Config")] string rc_config, [AltName("Default_Tablespace")] string def_tablespace, string temp_tablespace, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | first_name |
System.String | last_name |
System.String | login_name |
System.String | password |
System.String | site_id |
System.String | e_mail |
System.String | phone |
System.String | pager |
System.String | online_priv_class |
System.String | offline_priv_class |
System.String | Id |
System.Boolean | is_active |
System.Boolean | allow_proxy |
System.String | start_date |
System.String | supervisor |
System.String | work_group |
System.String | work_group_start |
System.String | labor_rate |
System.Boolean | is_supervisor |
System.Boolean | is_fe |
System.String | normal_biz_high |
System.String | normal_biz_mid |
System.String | normal_biz_low |
System.String | after_biz_high |
System.String | after_biz_mid |
System.String | after_biz_low |
System.String | def_wipbin_title |
System.String | rc_config |
System.String | def_tablespace |
System.String | temp_tablespace |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCINTER.create_interact(String, String, String, String, String, String, String, String, String, String, String, String, Boolean, String, Boolean, String, String, String, Int32, Int32, Int32, String, Boolean, String, Int32, String, String, String, String, String, String)

Declaration
[OutputProperty("ret_objid")]
[OutputProperty("ret_id_num")]
[FacadeVoid]
public short IFCINTER.create_interact([AltName("title")] string the_title, [AltName("notes")] string the_notes, [ParameterRequired, AltName("Contact_First_Name")] string first, [ParameterRequired, AltName("Contact_Last_Name")] string last, [ParameterRequired, AltName("Contact_Phone")] string phone, [AltName("Zip_Code")] string zipcode, string reason1, string reason2, [AltName("Product_Name")] string prod_name, string direction, [AltName("Interaction_Type")] string the_type, string origin, [AltName("Is_Done_In_One")] bool done_in_one, string result, bool fee_based, string pay_option, string lead_source, string start_date, [ParameterRequired] int duration, [AltName("wait_time_Duration")] int wait_time, [AltName("Entered_Duration")] int entered_time, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bomb, string int_fld1, int int_val1, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | the_title |
System.String | the_notes |
System.String | first |
System.String | last |
System.String | phone |
System.String | zipcode |
System.String | reason1 |
System.String | reason2 |
System.String | prod_name |
System.String | direction |
System.String | the_type |
System.String | origin |
System.Boolean | done_in_one |
System.String | result |
System.Boolean | fee_based |
System.String | pay_option |
System.String | lead_source |
System.String | start_date |
System.Int32 | duration |
System.Int32 | wait_time |
System.Int32 | entered_time |
System.String | user_name |
System.Boolean | gen_time_bomb |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCINTER.create_interact_list(String, String, String, String, String, String, String, String, String, String, String, String, Boolean, String, Boolean, String, String, String, Int32, Int32, Int32, String, Boolean, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[OutputProperty("ret_objid", "Interaction")]
[OutputProperty("ret_id_num", "Interaction")]
[AltName("create_interaction_list")]
public short IFCINTER.create_interact_list([AltName("title")] string the_title, [AltName("notes")] string the_notes, [ParameterRequired, AltName("Contact_First_Name")] string first, [ParameterRequired, AltName("Contact_Last_Name")] string last, [ParameterRequired, AltName("Contact_Phone")] string phone, [AltName("Zip_Code")] string zipcode, string reason1, string reason2, [AltName("Product_Name")] string prod_name, string direction, [AltName("Interaction_Type")] string the_type, string origin, [AltName("Is_Done_In_One")] bool done_in_one, string result, bool fee_based, string pay_option, string lead_source, string start_date, [ParameterRequired, AltType("System.TimeSpan", "Convert.ToInt32({0}.TotalSeconds)")] int duration, [AltName("Wait_Duration"), AltType("System.TimeSpan", "Convert.ToInt32({0}.TotalSeconds)")] int wait_time, [AltName("Entered_Duration"), AltType("System.TimeSpan", "Convert.ToInt32({0}.TotalSeconds)")] int entered_time, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bomb, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | the_title |
System.String | the_notes |
System.String | first |
System.String | last |
System.String | phone |
System.String | zipcode |
System.String | reason1 |
System.String | reason2 |
System.String | prod_name |
System.String | direction |
System.String | the_type |
System.String | origin |
System.Boolean | done_in_one |
System.String | result |
System.Boolean | fee_based |
System.String | pay_option |
System.String | lead_source |
System.String | start_date |
System.Int32 | duration |
System.Int32 | wait_time |
System.Int32 | entered_time |
System.String | user_name |
System.Boolean | gen_time_bomb |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCINTER.create_price_inst(String, String, String, String, Int16, Int32, String, String, String)

Declaration
[OutputProperty("ret_objid", "PriceInstance")]
[AltName("Create_Price_Instance")]
public short IFCINTER.create_price_inst([ParameterRequired, AltName("Part_Number")] string part_num, [ParameterRequired, AltName("part_domain")] string domain, [ParameterRequired, AltName("part_Revision")] string mod_level, [ParameterRequired, AltName("Price_Program")] string price_prog, [ParameterRequired, AltType("FChoice.Toolkits.Clarify.PriceInstanceType", "Convert.ToInt16( (int)({0}) )"), ParameterDefaultValue("FChoice.Toolkits.Clarify.PriceInstanceType.Fixed")] short price_type, [ParameterRequired, AltName("Priced_Quantity")] int priced_qty, [ParameterRequired, AltType("System.Decimal", "{0}.ToString()")] string price, string start_date, string end_date)
Parameters
Type | Name | Description
System.String | part_num |
System.String | domain |
System.String | mod_level |
System.String | price_prog |
System.Int16 | price_type |
System.Int32 | priced_qty |
System.String | price |
System.String | start_date |
System.String | end_date |
Returns
Type | Description
System.Int16 |

IFCINTER.create_product_bin(String, String, Int32, String, Int32, Int32, String, String)

Declaration
[OutputProperty("ret_objid", "ProductBin")]
public short IFCINTER.create_product_bin([ParameterRequired] string bin_name, [ParameterRequired, AltName("Site_IDNum")] string site_id, [AltName("Parent_Bin_Objid"), ParameterDefaultValue("-1")] int bin_objid, string description, [ParameterDefaultValue("-1"), AltName("Primary_Support_Employee_ObjID")] int prim_supp, [ParameterDefaultValue("-1"), AltName("Secondary_Support_Employee_ObjID")] int sec_supp, string user_name, string create_date)
Parameters
Type | Name | Description
System.String | bin_name |
System.String | site_id |
System.Int32 | bin_objid |
System.String | description |
System.Int32 | prim_supp |
System.Int32 | sec_supp |
System.String | user_name |
System.String | create_date |
Returns
Type | Description
System.Int16 |

IFCINTER.create_soln(String, String, String, Boolean, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[OutputProperty("ret_objid")]
[OutputProperty("ret_objid2")]
[OutputProperty("ret_id_num")]
[FacadeVoid]
public short IFCINTER.create_soln([AltName("title")] string the_title, string description, string workaround, bool is_public, [AltName("Resolution_Code")] string res_code, [AltName("queue")] string queue_name, string create_date, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool create_time_bomb, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | the_title |
System.String | description |
System.String | workaround |
System.Boolean | is_public |
System.String | res_code |
System.String | queue_name |
System.String | create_date |
System.String | user_name |
System.Boolean | create_time_bomb |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCINTER.create_soln_list(String, String, String, Boolean, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[OutputProperty("ret_objid", "Solution")]
[OutputProperty("ret_objid2", "WorkaroundObjid", "System.Int32", "-1", "Objid of the Workaround that is created along with the Solution")]
[OutputProperty("ret_id_num", "Solution")]
[AltName("Create_Solution")]
public short IFCINTER.create_soln_list([AltName("title")] string the_title, string description, string workaround, bool is_public, [AltName("Resolution_Code")] string res_code, [AltName("queue")] string queue_name, string create_date, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool create_time_bomb, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | the_title |
System.String | description |
System.String | workaround |
System.Boolean | is_public |
System.String | res_code |
System.String | queue_name |
System.String | create_date |
System.String | user_name |
System.Boolean | create_time_bomb |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCINTER.create_state(String, String, Boolean, String)

Declaration
[OutputProperty("ret_objid", "State")]
public short IFCINTER.create_state([ParameterRequired] string State, [ParameterRequired] string full_name, bool is_default, [ParameterRequired] string Country)
Parameters
Type | Name | Description
System.String | State |
System.String | full_name |
System.Boolean | is_default |
System.String | Country |
Returns
Type | Description
System.Int16 |

IFCINTER.create_time_zone(String, String, String, Int32)

Declaration
[OutputProperty("ret_objid", "TimeZone")]
public short IFCINTER.create_time_zone([ParameterRequired] string time_zone, [ParameterRequired] string full_name, [ParameterRequired] string Country, [AltName("GMT_Difference")] int gmt_diff)
Parameters
Type | Name | Description
System.String | time_zone |
System.String | full_name |
System.String | Country |
System.Int32 | gmt_diff |
Returns
Type | Description
System.Int16 |

IFCINTER.create_update_account(String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[FacadeVoid]
[OutputProperty("ret_objid", "Account")]
[OutputProperty("ret_id_num", "Account")]
public short IFCINTER.create_update_account([AltName("Account_Name")] string acct_name, [AltName("Description")] string desc, string territory, string stock, [AltName("Fiscal_Year")] string fiscal_yr, [AltName("Account_Type")] string the_type, string size, string revenue, string ownership, string phone, string fax, string web_site, string user_name, string create_date, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs, [ParameterRequired("update_account"), ParameterVoid("create_account_list"), AltName("Account_ID_Num")] string acct_id, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | acct_name |
System.String | desc |
System.String | territory |
System.String | stock |
System.String | fiscal_yr |
System.String | the_type |
System.String | size |
System.String | revenue |
System.String | ownership |
System.String | phone |
System.String | fax |
System.String | web_site |
System.String | user_name |
System.String | create_date |
System.Boolean | gen_time_bombs |
System.String | acct_id |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCINTER.create_update_account_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, String, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[SplitMethod("create_account_list")]
[SplitMethod("update_account_list")]
[OutputProperty("ret_objid", "Account")]
[OutputProperty("ret_id_num", "Account")]
public short IFCINTER.create_update_account_list([AltName("Account_Name")] string acct_name, [AltName("Description")] string desc, [AltType("System.String", "({1} && {0} == String.Empty) ? \"CLEAR\" : {0}", "update_account_list")] string territory, string stock, [AltName("Fiscal_Year")] string fiscal_yr, [AltName("Account_Type")] string the_type, string size, string revenue, string ownership, string phone, string fax, string web_site, string user_name, string create_date, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs, [ParameterRequired("update_account_list"), ParameterVoid("create_account_list"), AltName("Account_ID_Num")] string acct_id, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | acct_name |
System.String | desc |
System.String | territory |
System.String | stock |
System.String | fiscal_yr |
System.String | the_type |
System.String | size |
System.String | revenue |
System.String | ownership |
System.String | phone |
System.String | fax |
System.String | web_site |
System.String | user_name |
System.String | create_date |
System.Boolean | gen_time_bombs |
System.String | acct_id |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCINTER.create_update_contract(String, String, String, String, String, Int32, Int32, String, String, String, String, Double, Double, Double, Int32, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[FacadeVoid]
[OutputProperty("ret_objid", "Contract")]
[OutputProperty("ret_id_num", "Contract")]
public short IFCINTER.create_update_contract([ParameterRequired("update_contract"), AltName("Contract_IDNum")] string contract_id, string contract_type, string status, string po_number, string pay_options, [AltName("Phone_Response")] int phone_resp, [AltName("Onsite_Response")] int onsite_resp, [AltName("Business_Hours_For_PM")] string hours_for_pm, string start_date, string expire_date, string unit_type, [AltName("Units_Purchased")] double units_purch, double units_used, [AltName("Units_Available")] double units_avail, [AltType("System.Boolean", "{1} ? ({0} ? 1 : 0) : -1"), AltName("Use_Special_Considerations")] int spec_consid, string notes, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | contract_type |
System.String | status |
System.String | po_number |
System.String | pay_options |
System.Int32 | phone_resp |
System.Int32 | onsite_resp |
System.String | hours_for_pm |
System.String | start_date |
System.String | expire_date |
System.String | unit_type |
System.Double | units_purch |
System.Double | units_used |
System.Double | units_avail |
System.Int32 | spec_consid |
System.String | notes |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCINTER.create_update_contract_list(String, String, String, String, String, Int32, Int32, String, String, String, String, Double, Double, Double, Int32, String, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[SplitMethod("create_contract_list")]
[SplitMethod("update_contract_list")]
[OutputProperty("ret_objid", "Contract")]
[OutputProperty("ret_id_num", "Contract")]
public short IFCINTER.create_update_contract_list([ParameterRequired("update_contract_list"), ParameterVoid("create_contract_list"), AltName("Contract_IDNum")] string contract_id, string contract_type, string status, string po_number, string pay_options, [AltName("Phone_Response_duration"), AltType("System.TimeSpan", "Convert.ToInt32({0}.TotalSeconds)")] int phone_resp, [AltName("Onsite_Response_duration"), AltType("System.TimeSpan", "Convert.ToInt32({0}.TotalSeconds)")] int onsite_resp, [AltName("Business_Hours_For_PM")] string hours_for_pm, string start_date, string expire_date, string unit_type, [AltName("Units_Purchased")] double units_purch, double units_used, [AltName("Units_Available")] double units_avail, [AltType("System.Boolean", "{1} ? ({0} ? 1 : 0) : -1"), AltName("Use_Special_Considerations")] int spec_consid, string notes, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | contract_type |
System.String | status |
System.String | po_number |
System.String | pay_options |
System.Int32 | phone_resp |
System.Int32 | onsite_resp |
System.String | hours_for_pm |
System.String | start_date |
System.String | expire_date |
System.String | unit_type |
System.Double | units_purch |
System.Double | units_used |
System.Double | units_avail |
System.Int32 | spec_consid |
System.String | notes |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCINTER.create_update_mod_level(String, String, String, String, String, String, String, String, Boolean, String)

Declaration
[SplitMethod("create_part_revision")]
[SplitMethod("update_part_revision")]
[OutputProperty("ret_objid", "PartRevision")]
public short IFCINTER.create_update_mod_level([ParameterRequired, AltName("Part_Number")] string part_num, [ParameterRequired, AltName("part_domain")] string domain, [ParameterRequired, AltName("part_Revision")] string mod_level, [AltName("Replace_Part_Number")] string replaces_part, [AltName("Replace_Part_Domain")] string replaces_dom, [AltName("Replace_Part_Revision")] string replaces_rev, [AltName("Replace_Date")] string replaces_date, [ParameterDefaultValue("FChoice.Toolkits.Clarify.PartRevisionStatus.Active"), AltType("FChoice.Toolkits.Clarify.PartRevisionStatus", "{1} ? {0}.ToString() : string.Empty")] string status, [ParameterVoid, AltType("System.Boolean", "{2}.IsPartRevisionDirty", "update_part_revision")] bool change_ml, [ParameterVoid("create_part_revision"), AltName("New_Part_Revision")] string new_ml)
Parameters
Type | Name | Description
System.String | part_num |
System.String | domain |
System.String | mod_level |
System.String | replaces_part |
System.String | replaces_dom |
System.String | replaces_rev |
System.String | replaces_date |
System.String | status |
System.Boolean | change_ml |
System.String | new_ml |
Returns
Type | Description
System.Int16 |

IFCINTER.create_update_part(String, String, String, String, String, Int32, Boolean, String, String, String, String, String, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[FacadeVoid]
[OutputProperty("ret_objid", "Part")]
public short IFCINTER.create_update_part([ParameterRequired, AltName("Part_Number")] string part_num, [ParameterRequired, AltName("part_domain")] string domain, string notes, [AltName("description")] string desc, [AltName("Model_Number")] string model_num, [ParameterRequired, AltName("Warranty_Days")] int warr_days, [AltName("Warranty_Start_On_Shipment")] bool start_on_ship, string unit_measure, string family, [AltName("line")] string the_line, [ParameterRequired("create_part")] string repair_type, [AltType("FChoice.Toolkits.Clarify.PartType", "{1} ? {0}.ToString() : string.Empty"), ParameterDefaultValue("FChoice.Toolkits.Clarify.PartType.Repairable")] string part_type, string weight, string dimension, string part_class, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | part_num |
System.String | domain |
System.String | notes |
System.String | desc |
System.String | model_num |
System.Int32 | warr_days |
System.Boolean | start_on_ship |
System.String | unit_measure |
System.String | family |
System.String | the_line |
System.String | repair_type |
System.String | part_type |
System.String | weight |
System.String | dimension |
System.String | part_class |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCINTER.create_update_part_list(String, String, String, String, String, Int32, Boolean, String, String, String, String, String, String, String, String, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[SplitMethod("create_part_list")]
[SplitMethod("update_part_list")]
[OutputProperty("ret_objid", "Part")]
public short IFCINTER.create_update_part_list([ParameterRequired, AltName("Part_Number")] string part_num, [ParameterRequired, AltName("part_domain")] string domain, string notes, [AltName("description")] string desc, [AltName("Model_Number")] string model_num, [ParameterRequired, AltName("Warranty_Days")] int warr_days, [AltName("Warranty_Start_On_Shipment")] bool start_on_ship, string unit_measure, string family, [AltName("line")] string the_line, [ParameterRequired("create_part_list"), AltType("FChoice.Toolkits.Clarify.PartRepairType", "{1} ? {0}.ToString() : string.Empty"), ParameterDefaultValue("FChoice.Toolkits.Clarify.PartRepairType.Repairable")] string repair_type, string part_type, string weight, string dimension, string part_class, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | part_num |
System.String | domain |
System.String | notes |
System.String | desc |
System.String | model_num |
System.Int32 | warr_days |
System.Boolean | start_on_ship |
System.String | unit_measure |
System.String | family |
System.String | the_line |
System.String | repair_type |
System.String | part_type |
System.String | weight |
System.String | dimension |
System.String | part_class |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCINTER.create_update_queue(String, Boolean, String, Int16, Int16, Int16, Int16, Int16, Int16, Int16, Int16, Int16, Int16, String, String)

Declaration
[SplitMethod("create_queue")]
[SplitMethod("update_queue")]
[OutputProperty("ret_objid", "Queue")]
public short IFCINTER.create_update_queue([ParameterRequired] string Title, [ParameterDefaultValue("true"), AltName("Is_Personal")] bool personal, [AltType("System.String", "({1} && {0} == String.Empty) ? \"CLEAR\" : {0}", "update_queue")] string description, [AltName("Allow_CR"), ParameterRequired("create_queue"), AltType("System.Boolean", "(short)({1} ? ({0} ? 1 : 0) : -1)")] short allow_bug, [ParameterRequired("create_queue"), AltType("System.Boolean", "(short)({1} ? ({0} ? 1 : 0) : -1)")] short allow_case, [ParameterRequired("create_queue"), AltType("System.Boolean", "(short)({1} ? ({0} ? 1 : 0) : -1)")] short allow_contract, [ParameterRequired("create_queue"), AltType("System.Boolean", "(short)({1} ? ({0} ? 1 : 0) : -1)")] short allow_dialogue, [ParameterRequired("create_queue"), AltType("System.Boolean", "(short)({1} ? ({0} ? 1 : 0) : -1)"), AltName("Allow_Demand_Detail")] short allow_dmnd_dtl, [ParameterRequired("create_queue"), AltType("System.Boolean", "(short)({1} ? ({0} ? 1 : 0) : -1)")] short allow_job, [ParameterRequired("create_queue"), AltType("System.Boolean", "(short)({1} ? ({0} ? 1 : 0) : -1)"), AltName("Allow_Opportunity")] short allow_opp, [ParameterRequired("create_queue"), AltType("System.Boolean", "(short)({1} ? ({0} ? 1 : 0) : -1)"), AltName("Allow_Solution")] short allow_probdesc, [ParameterRequired("create_queue"), AltType("System.Boolean", "(short)({1} ? ({0} ? 1 : 0) : -1)")] short allow_subcase, [AltName("Allow_Action_Item"), ParameterRequired("create_queue"), AltType("System.Boolean", "(short)({1} ? ({0} ? 1 : 0) : -1)")] short allow_task, string supervisor, [ParameterVoid("create_queue")] string new_title)
Parameters
Type | Name | Description
System.String | Title |
System.Boolean | personal |
System.String | description |
System.Int16 | allow_bug |
System.Int16 | allow_case |
System.Int16 | allow_contract |
System.Int16 | allow_dialogue |
System.Int16 | allow_dmnd_dtl |
System.Int16 | allow_job |
System.Int16 | allow_opp |
System.Int16 | allow_probdesc |
System.Int16 | allow_subcase |
System.Int16 | allow_task |
System.String | supervisor |
System.String | new_title |
Returns
Type | Description
System.Int16 |

IFCINTER.create_update_site(Int32, String, String, String, String, String, String, String, String, String, Int32, Int32, Int32, String, String, Int32, Int32, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[FacadeVoid]
[OutputProperty("ret_objid", "Site")]
[OutputProperty("ret_id_num", "Site")]
public short IFCINTER.create_update_site([ParameterRequired("update_site_by_objid"), ParameterDefaultValue("-1", "create_site"), ParameterDefaultValue("-1", "update_site"), ParameterVoid("create_site"), ParameterVoid("update_site"), AltName("Site_ObjID")] int site_objid, [ParameterRequired("update_site"), ParameterDefaultValue("NOTSUPPLIED", "update_site_by_objid"), ParameterVoid("update_site_by_objid"), AltName("Site_IDNum")] string site_id, string site_name, [ParameterRequired("create_site"), AltType("FChoice.Toolkits.Clarify.SiteType", "{1} ? FChoice.Toolkits.Clarify.Utility.GetSiteType({0}) : string.Empty"), ParameterDefaultValue("FChoice.Toolkits.Clarify.SiteType.Customer")] string site_type, string bus_org, [ParameterRequired("create_site_list"), AltType("FChoice.Toolkits.Clarify.SiteStatus", "{1} ? {0}.ToString().ToUpperInvariant() : string.Empty"), ParameterDefaultValue("FChoice.Toolkits.Clarify.SiteStatus.Active")] string status, string region, string district, string industry_type, [AltName("Primary_Use")] string appl_type, [ParameterRequired("create_site"), AltName("Primary_Address_ObjID")] int prim_addr, [ParameterRequired("create_site"), AltName("Shipping_Address_ObjID")] int ship_addr, [ParameterRequired("create_site"), AltName("Billing_Address_ObjID")] int bill_addr, [AltName("parent_site_IDNum")] string parent_site, [AltName("Support_Office_IDNum")] string supp_office, [AltName("Primary_Support_Employee_ObjID")] int prim_emp, [AltName("Secondary_Support_Employee_ObjID")] int sec_emp, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.Int32 | site_objid |
System.String | site_id |
System.String | site_name |
System.String | site_type |
System.String | bus_org |
System.String | status |
System.String | region |
System.String | district |
System.String | industry_type |
System.String | appl_type |
System.Int32 | prim_addr |
System.Int32 | ship_addr |
System.Int32 | bill_addr |
System.String | parent_site |
System.String | supp_office |
System.Int32 | prim_emp |
System.Int32 | sec_emp |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCINTER.create_update_site_list(Int32, String, String, String, String, String, String, String, String, String, Int32, Int32, Int32, String, String, Int32, Int32, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[SplitMethod("create_site_list")]
[SplitMethod("update_site_list")]
[SplitMethod("update_site_by_objid_list")]
[OutputProperty("ret_objid", "Site")]
[OutputProperty("ret_id_num", "Site")]
public short IFCINTER.create_update_site_list([ParameterRequired("update_site_by_objid_list"), ParameterDefaultValue("0", "create_site_list"), ParameterDefaultValue("-1", "update_site_list"), ParameterVoid("create_site_list"), ParameterVoid("update_site_list"), AltName("Site_ObjID")] int site_objid, [ParameterRequired("update_site_list"), ParameterDefaultValue("\"NOTSUPPLIED\"", "update_site_by_objid_list"), ParameterVoid("update_site_by_objid_list"), AltName("Site_IDNum")] string site_id, string site_name, [ParameterRequired("create_site_list"), AltType("FChoice.Toolkits.Clarify.SiteType", "{1} ? FChoice.Toolkits.Clarify.Utility.GetSiteType({0}) : string.Empty"), ParameterDefaultValue("FChoice.Toolkits.Clarify.SiteType.Customer")] string site_type, [AltName("AccountIDNum")] string bus_org, [ParameterRequired("create_site_list"), AltType("FChoice.Toolkits.Clarify.SiteStatus", "{1} ? {0}.ToString().ToUpperInvariant() : string.Empty"), ParameterDefaultValue("FChoice.Toolkits.Clarify.SiteStatus.Active")] string status, string region, string district, string industry_type, [AltName("Primary_Use")] string appl_type, [ParameterRequired("create_site_list"), AltName("Primary_Address_ObjID")] int prim_addr, [AltName("Shipping_Address_ObjID"), ParameterDefaultValue("-1")] int ship_addr, [AltName("Billing_Address_ObjID"), ParameterDefaultValue("-1")] int bill_addr, [AltName("parent_site_IDNum"), AltType("System.String", "({1} && {0} == String.Empty) ? \"REMOVE\" : {0}")] string parent_site, [AltName("Support_Office_Site_IDNum"), AltType("System.String", "({1} && {0} == String.Empty) ? \"REMOVE\" : {0}")] string supp_office, [AltName("Primary_Support_Employee_ObjID")] int prim_emp, [AltName("Secondary_Support_Employee_ObjID")] int sec_emp, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.Int32 | site_objid |
System.String | site_id |
System.String | site_name |
System.String | site_type |
System.String | bus_org |
System.String | status |
System.String | region |
System.String | district |
System.String | industry_type |
System.String | appl_type |
System.Int32 | prim_addr |
System.Int32 | ship_addr |
System.Int32 | bill_addr |
System.String | parent_site |
System.String | supp_office |
System.Int32 | prim_emp |
System.Int32 | sec_emp |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCINTER.create_update_wipbin(String, String, String, String, Boolean)

Declaration
[SplitMethod("create_wip_bin")]
[SplitMethod("update_wip_bin")]
[OutputProperty("ret_objid", "WipBin")]
public short IFCINTER.create_update_wipbin([ParameterRequired] string Title, [ParameterVoid("create_wip_bin")] string new_title, [AltType("System.String", "({1} && {0} == String.Empty) ? \"CLEAR\" : {0}", "update_wip_bin")] string description, string user_name, [AltName("is_default_bin")] bool def_bin)
Parameters
Type | Name | Description
System.String | Title |
System.String | new_title |
System.String | description |
System.String | user_name |
System.Boolean | def_bin |
Returns
Type | Description
System.Int16 |

IFCINTER.deinstall_sp(Int32, String, String, Boolean)

Declaration
[AltName("Deinstall_Site_Part")]
public short IFCINTER.deinstall_sp([ParameterRequired, AltName("Site_Part_ObjID")] int sp_objid, string user_name, string deinstall_date, bool use_remove)
Parameters
Type | Name | Description
System.Int32 | sp_objid |
System.String | user_name |
System.String | deinstall_date |
System.Boolean | use_remove |
Returns
Type | Description
System.Int16 |

IFCINTER.delete_product_bin(Int32, String, String)

Declaration
public short IFCINTER.delete_product_bin([ParameterRequired] int bin_objid, string user_name, string delete_date)
Parameters
Type | Name | Description
System.Int32 | bin_objid |
System.String | user_name |
System.String | delete_date |
Returns
Type | Description
System.Int16 |

IFCINTER.dispatch_solution(String, String, String, String, Boolean)

Declaration
public short IFCINTER.dispatch_solution([ParameterRequired, AltName("Solution_IDNum")] string solution_id, [ParameterRequired, AltName("queue")] string queue_name, [AltName("Dispatch_Date")] string disp_date, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | solution_id |
System.String | queue_name |
System.String | disp_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCINTER.forward_solution(String, String, String, String, String, Boolean)

Declaration
public short IFCINTER.forward_solution([ParameterRequired, AltName("Solution_IDNum")] string solution_id, [ParameterRequired] string new_queue, string forward_date, string notes, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | solution_id |
System.String | new_queue |
System.String | forward_date |
System.String | notes |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCINTER.impersonatorUserName

Declaration
public string IFCINTER.impersonatorUserName { get; set; }
Returns
Type | Description
System.String |

IFCINTER.Initialize(IFCApplication, IFCSession)

Declaration
[ToolkitVisible(false)]
public void IFCINTER.Initialize(IFCApplication TheFCApplication, IFCSession TheFCSession)
Parameters
Type | Name | Description
IFCApplication | TheFCApplication |
IFCSession | TheFCSession |

IFCINTER.install_sp(String, String, String, String, Int32, String, Int32, Int32, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[OutputProperty("ret_objid", "SitePart")]
[FacadeVoid]
public short IFCINTER.install_sp([ParameterRequired, AltName("Site_IDNum")] string site_id, [ParameterRequired, AltName("Part_Number")] string part_num, [ParameterRequired, AltName("Part_Revision")] string mod_level, [ParameterRequired, AltName("Part_Domain")] string domain, [ParameterRequired] int quantity, [AltName("Serial_Number")] string serial_num, int parent_bin_objid, [AltName("Parent_Site_Part_ObjID")] int parent_sp_objid, string instance_name, string comment, string part_status, [AltName("Invoice_Number")] string invoice_no, string user_name, string install_date, string ship_date, [AltName("Add_Activity_Log"), ParameterDefaultValue("true")] bool add_activity, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | site_id |
System.String | part_num |
System.String | mod_level |
System.String | domain |
System.Int32 | quantity |
System.String | serial_num |
System.Int32 | parent_bin_objid |
System.Int32 | parent_sp_objid |
System.String | instance_name |
System.String | comment |
System.String | part_status |
System.String | invoice_no |
System.String | user_name |
System.String | install_date |
System.String | ship_date |
System.Boolean | add_activity |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCINTER.install_sp_list(String, String, String, String, Int32, String, Int32, Int32, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[OutputProperty("ret_objid", "SitePart")]
[SplitMethod("install_site_part_to_site", 2)]
[SplitMethod("install_site_part_to_bin", 2)]
[SplitMethod("install_site_part_to_part", 2)]
public short IFCINTER.install_sp_list([ParameterRequired(null, -1, 0), AltName("Site_IDNum")] string site_id, [ParameterRequired(null, -1, 2), AltName("Part_Number")] string part_num, [ParameterRequired(null, -1, 3), AltName("Part_Revision")] string mod_level, [ParameterRequired(null, -1, 4), AltName("Part_Domain")] string domain, [ParameterRequired(null, 0, 5), ParameterDefaultValue("1")] int quantity, [ParameterRequired(null, 1, 5), AltName("serial_number")] string serial_num, [ParameterRequired(true, "install_site_part_to_bin", 0, 1), ParameterVoid("install_site_part_to_part"), ParameterVoid("install_site_part_to_site")] int parent_bin_objid, [ParameterRequired(true, "install_site_part_to_part", 0, 1), ParameterVoid("install_site_part_to_bin"), ParameterVoid("install_site_part_to_site"), AltName("Parent_Site_Part_ObjID")] int parent_sp_objid, string instance_name, [AltName("comments")] string comment, string part_status, [AltName("Invoice_Number")] string invoice_no, string user_name, string install_date, string ship_date, [AltName("Add_Activity_Log"), ParameterDefaultValue("true")] bool add_activity, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | site_id |
System.String | part_num |
System.String | mod_level |
System.String | domain |
System.Int32 | quantity |
System.String | serial_num |
System.Int32 | parent_bin_objid |
System.Int32 | parent_sp_objid |
System.String | instance_name |
System.String | comment |
System.String | part_status |
System.String | invoice_no |
System.String | user_name |
System.String | install_date |
System.String | ship_date |
System.Boolean | add_activity |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCINTER.link_case_to_workaround(String, Int32, String, String, Boolean)

Declaration
[OutputProperty("ret_objid", "Case")]
public short IFCINTER.link_case_to_workaround([ParameterRequired, AltName("Case_IDNum")] string case_id, [ParameterRequired, AltName("Workaround_ObjID")] int work_objid, string link_date, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool create_time_bomb)
Parameters
Type | Name | Description
System.String | case_id |
System.Int32 | work_objid |
System.String | link_date |
System.String | user_name |
System.Boolean | create_time_bomb |
Returns
Type | Description
System.Int16 |

IFCINTER.link_cr_to_soln(String, String, String, String, Boolean)

Declaration
[OutputProperty("ret_objid", "CR")]
[AltName("Link_CR_To_Solution")]
public short IFCINTER.link_cr_to_soln([ParameterRequired, AltName("CR_IDNum")] string cr_id, [ParameterRequired, AltName("Solution_IDNum")] string soln_id, string link_date, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool create_time_bomb)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | soln_id |
System.String | link_date |
System.String | user_name |
System.Boolean | create_time_bomb |
Returns
Type | Description
System.Int16 |

IFCINTER.modify_product_bin(Int32, String, String, Int32, Int32, String, String)

Declaration
[AltName("update_product_bin")]
public short IFCINTER.modify_product_bin([ParameterRequired] int bin_objid, string bin_name, [AltType("System.String", "({1} && {0} == String.Empty) ? \"CLEAR\" : {0}")] string description, [AltName("Primary_Support_Employee_ObjID")] int prim_supp, [AltName("Secondary_Support_Employee_ObjID")] int sec_supp, string user_name, [AltName("Update_Date")] string mod_date)
Parameters
Type | Name | Description
System.Int32 | bin_objid |
System.String | bin_name |
System.String | description |
System.Int32 | prim_supp |
System.Int32 | sec_supp |
System.String | user_name |
System.String | mod_date |
Returns
Type | Description
System.Int16 |

IFCINTER.modify_sp(Int32, String, String, String, String, String, String, Int32, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[OutputProperty("ret_objid", "SitePart")]
[FacadeVoid]
public short IFCINTER.modify_sp([ParameterRequired, AltName("Site_Part_ObjID")] int sp_objid, string instance_name, [AltName("Serial_Number")] string serial_num, [AltName("Invoice_Number")] string invoice_no, string ship_date, string install_date, string warranty_date, [ParameterRequired] int quantity, string part_status, string comments, [AltName("service_end_date")] string service_end_dt, string user_name, [AltName("part_revision")] string mod_level, [AltName("Add_Activity_Log"), ParameterDefaultValue("true")] bool add_activity, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.Int32 | sp_objid |
System.String | instance_name |
System.String | serial_num |
System.String | invoice_no |
System.String | ship_date |
System.String | install_date |
System.String | warranty_date |
System.Int32 | quantity |
System.String | part_status |
System.String | comments |
System.String | service_end_dt |
System.String | user_name |
System.String | mod_level |
System.Boolean | add_activity |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCINTER.modify_sp_list(Int32, String, String, String, String, String, String, Int32, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[OutputProperty("ret_objid", "SitePart")]
[SplitMethod("Update_Site_Part", 2)]
public short IFCINTER.modify_sp_list([ParameterRequired, AltName("Site_Part_ObjID")] int sp_objid, string instance_name, [ParameterRequired(null, 1), AltName("Serial_Number")] string serial_num, [AltName("Invoice_Number")] string invoice_no, string ship_date, string install_date, string warranty_date, [ParameterRequired(null, 0), ParameterDefaultValue("1")] int quantity, string part_status, string comments, [AltName("service_end_date")] string service_end_dt, string user_name, [AltName("part_revision")] string mod_level, [AltName("Add_Activity_Log"), ParameterDefaultValue("true")] bool add_activity, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.Int32 | sp_objid |
System.String | instance_name |
System.String | serial_num |
System.String | invoice_no |
System.String | ship_date |
System.String | install_date |
System.String | warranty_date |
System.Int32 | quantity |
System.String | part_status |
System.String | comments |
System.String | service_end_dt |
System.String | user_name |
System.String | mod_level |
System.Boolean | add_activity |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCINTER.move_solution(String, String)

Declaration
public short IFCINTER.move_solution([ParameterRequired, AltName("Solution_IDNum")] string solution_id, [ParameterRequired, AltName("new_wip_bin")] string new_wipbin)
Parameters
Type | Name | Description
System.String | solution_id |
System.String | new_wipbin |
Returns
Type | Description
System.Int16 |

IFCINTER.move_sp(Int32, String, Int32, String, Int32, Boolean, String, Boolean)

Declaration
[SplitMethod("move_site_part_to_site")]
[SplitMethod("move_site_part_to_bin")]
[SplitMethod("move_site_part_to_part")]
public short IFCINTER.move_sp([ParameterRequired, AltName("Site_Part_ObjID")] int sp_objid, string move_date, [ParameterRequired("move_site_part_to_part"), ParameterDefaultValue("-1"), ParameterVoid("move_site_part_to_bin"), ParameterVoid("move_site_part_to_site"), AltName("Parent_Site_Part_ObjID")] int parent_sp_objid, [ParameterRequired("move_site_part_to_site"), ParameterVoid("move_site_part_to_bin"), ParameterVoid("move_site_part_to_part"), AltName("Parent_Site_IDNum")] string site_id, [ParameterRequired("move_site_part_to_bin"), ParameterDefaultValue("-1"), ParameterVoid("move_site_part_to_site"), ParameterVoid("move_site_part_to_part")] int parent_bin_objid, [AltName("Add_Activity_Log")] bool add_activity, string user_name, bool install_and_move)
Parameters
Type | Name | Description
System.Int32 | sp_objid |
System.String | move_date |
System.Int32 | parent_sp_objid |
System.String | site_id |
System.Int32 | parent_bin_objid |
System.Boolean | add_activity |
System.String | user_name |
System.Boolean | install_and_move |
Returns
Type | Description
System.Int16 |

IFCINTER.reinstall_sp(Int32, String, Int32, Int32, String, String, Boolean, Boolean)

Declaration
[AltName("Reinstall_Site_Part")]
[SplitMethod("reinstall_site_part_to_site")]
[SplitMethod("reinstall_site_part_to_bin")]
[SplitMethod("reinstall_site_part_to_part")]
public short IFCINTER.reinstall_sp([ParameterRequired, AltName("Site_Part_ObjID")] int sp_objid, [ParameterRequired, AltName("Site_IDNum")] string site_id, [ParameterRequired("reinstall_site_part_to_bin"), ParameterVoid("reinstall_site_part_to_site"), ParameterVoid("reinstall_site_part_to_part")] int parent_bin_objid, [ParameterRequired("reinstall_site_part_to_part"), ParameterVoid("reinstall_site_part_to_bin"), ParameterVoid("reinstall_site_part_to_site"), AltName("Parent_Site_Part_ObjID")] int parent_sp_objid, string user_name, [AltName("Reinstall_Date")] string reinst_date, [AltName("Add_Activity_Log")] bool add_activity, bool use_install)
Parameters
Type | Name | Description
System.Int32 | sp_objid |
System.String | site_id |
System.Int32 | parent_bin_objid |
System.Int32 | parent_sp_objid |
System.String | user_name |
System.String | reinst_date |
System.Boolean | add_activity |
System.Boolean | use_install |
Returns
Type | Description
System.Int16 |

IFCINTER.reject_solution(String, String, String, String, String, Boolean)

Declaration
public short IFCINTER.reject_solution([ParameterRequired, AltName("Solution_IDNum")] string solution_id, string reject_date, [AltName("wip_bin")] string wipbin, string notes, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | solution_id |
System.String | reject_date |
System.String | wipbin |
System.String | notes |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCINTER.remove_contact_from_contract(String, Int32)

Declaration
public short IFCINTER.remove_contact_from_contract([ParameterRequired, AltName("Contract_IDNum")] string contract_id, [ParameterRequired, AltName("Contact_ObjID")] int contact_objid)
Parameters
Type | Name | Description
System.String | contract_id |
System.Int32 | contact_objid |
Returns
Type | Description
System.Int16 |

IFCINTER.remove_emp_from_bus_org(String, String, String)

Declaration
[AltName("Remove_Employee_From_Account")]
public short IFCINTER.remove_emp_from_bus_org([ParameterRequired] string user_name, [ParameterRequired, AltName("Account_IDNum")] string acct_id, [ParameterRequired] string role_name)
Parameters
Type | Name | Description
System.String | user_name |
System.String | acct_id |
System.String | role_name |
Returns
Type | Description
System.Int16 |

IFCINTER.remove_site_from_bus_org(String, String, String)

Declaration
[AltName("Remove_Site_From_Account")]
public short IFCINTER.remove_site_from_bus_org([ParameterRequired, AltName("site_IDNum")] string site_id, [ParameterRequired, AltName("Account_IDNum")] string acct_id, [ParameterRequired] string role_name)
Parameters
Type | Name | Description
System.String | site_id |
System.String | acct_id |
System.String | role_name |
Returns
Type | Description
System.Int16 |

IFCINTER.remove_site_from_contract(String, String)

Declaration
public short IFCINTER.remove_site_from_contract([ParameterRequired, AltName("Contract_IDNum")] string contract_id, [ParameterRequired, AltName("Site_IDNum")] string site_id)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | site_id |
Returns
Type | Description
System.Int16 |

IFCINTER.remove_site_part_from_contract(String, Int32)

Declaration
public short IFCINTER.remove_site_part_from_contract([ParameterRequired, AltName("Contract_IDNum")] string contract_id, [ParameterRequired, AltName("Site_Part_ObjID")] int sp_objid)
Parameters
Type | Name | Description
System.String | contract_id |
System.Int32 | sp_objid |
Returns
Type | Description
System.Int16 |

IFCINTER.ret_id_num

Declaration
public string IFCINTER.ret_id_num { get; }
Returns
Type | Description
System.String |

IFCINTER.ret_objid

Declaration
public int IFCINTER.ret_objid { get; }
Returns
Type | Description
System.Int32 |

IFCINTER.ret_objid2

Declaration
public int IFCINTER.ret_objid2 { get; }
Returns
Type | Description
System.Int32 |

IToolkit.ReturnIDNum

Declaration
public string IToolkit.ReturnIDNum { get; }
Returns
Type | Description
System.String |

IToolkit.ReturnObjid

Declaration
public int IToolkit.ReturnObjid { get; }
Returns
Type | Description
System.Int32 |

IFCINTER.unlink_case_from_workaround(String, String, String, Boolean)

Declaration
[OutputProperty("ret_objid", "Workaround")]
public short IFCINTER.unlink_case_from_workaround([ParameterRequired, AltName("Case_IDNum")] string case_id, string unlink_date, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool create_time_bomb)
Parameters
Type | Name | Description
System.String | case_id |
System.String | unlink_date |
System.String | user_name |
System.Boolean | create_time_bomb |
Returns
Type | Description
System.Int16 |

IFCINTER.unlink_cr_from_soln(String, String, String, String, Boolean)

Declaration
[OutputProperty("ret_objid", "CR")]
[AltName("Unlink_CR_From_Solution")]
public short IFCINTER.unlink_cr_from_soln([ParameterRequired, AltName("CR_IDNum")] string cr_id, [ParameterRequired, AltName("Solution_IDNum")] string soln_id, string unlink_date, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool create_time_bomb)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | soln_id |
System.String | unlink_date |
System.String | user_name |
System.Boolean | create_time_bomb |
Returns
Type | Description
System.Int16 |

IFCINTER.update_address(Int32, String, String, String, String, Boolean, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[FacadeVoid]
public short IFCINTER.update_address([ParameterRequired, AltName("Address_ObjID")] int addr_objid, [AltName("Address1")] string addr1, [AltName("Address2")] string addr2, string city, string State, [AltName("is_short_state")] bool short_state, [AltName("Zip_Code")] string zip, string Country, string time_zone, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.Int32 | addr_objid |
System.String | addr1 |
System.String | addr2 |
System.String | city |
System.String | State |
System.Boolean | short_state |
System.String | zip |
System.String | Country |
System.String | time_zone |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCINTER.update_address_list(Int32, String, String, String, String, Boolean, String, String, String, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
public short IFCINTER.update_address_list([ParameterRequired, AltName("Address_ObjID")] int addr_objid, [AltName("Address1")] string addr1, [AltName("Address2")] string addr2, string city, string State, [ParameterDefaultValue("true"), AltName("is_short_state")] bool short_state, [AltName("Zip_Code")] string zip, string Country, string time_zone, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.Int32 | addr_objid |
System.String | addr1 |
System.String | addr2 |
System.String | city |
System.String | State |
System.Boolean | short_state |
System.String | zip |
System.String | Country |
System.String | time_zone |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCINTER.update_contact(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[FacadeVoid]
[OutputProperty("ret_objid", "Contact")]
public short IFCINTER.update_contact([ParameterRequired, AltName("First_Name")] string first, [ParameterRequired, AltName("Last_Name")] string last, [ParameterRequired] string phone, [ParameterRequired, AltName("Site_IDNum")] string site_id, [ParameterRequired, AltName("role_name")] string role, string fax, string email, string mail_stop, [AltName("title")] string the_title, string hours, string salutation, [AltName("New_First_Name")] string new_first, [AltName("New_Last_Name")] string new_last, [AltName("New_Phone")] string new_phone, [AltName("New_Primary_Site_IDNum")] string new_prim_site_id, [AltName("New_Primary_Role")] string new_prim_role, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | first |
System.String | last |
System.String | phone |
System.String | site_id |
System.String | role |
System.String | fax |
System.String | email |
System.String | mail_stop |
System.String | the_title |
System.String | hours |
System.String | salutation |
System.String | new_first |
System.String | new_last |
System.String | new_phone |
System.String | new_prim_site_id |
System.String | new_prim_role |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCINTER.update_contact_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, IFCList, IFCList, IFCList)

Declaration
[FacadeVoid]
[ToolkitVisible(false)]
public short IFCINTER.update_contact_list([ParameterRequired, AltName("First_Name")] string first, [ParameterRequired, AltName("Last_Name")] string last, [ParameterRequired] string phone, [ParameterRequired, AltName("Site_IDNum")] string site_id, [ParameterRequired, AltName("role_name")] string role, string fax, string email, string mail_stop, [AltName("title")] string the_title, string hours, string salutation, [AltName("New_First_Name")] string new_first, [AltName("New_Last_Name")] string new_last, [AltName("New_Phone")] string new_phone, [AltName("New_Primary_Site_IDNum")] string new_prim_site_id, [AltName("New_Primary_Role")] string new_prim_role, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | first |
System.String | last |
System.String | phone |
System.String | site_id |
System.String | role |
System.String | fax |
System.String | email |
System.String | mail_stop |
System.String | the_title |
System.String | hours |
System.String | salutation |
System.String | new_first |
System.String | new_last |
System.String | new_phone |
System.String | new_prim_site_id |
System.String | new_prim_role |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCINTER.update_contact_objid_list(Int32, String, String, String, String, String, String, String, String, String, String, String, String, String, IFCList, IFCList, IFCList)

Declaration
[FacadeVoid]
[ToolkitVisible(false)]
public short IFCINTER.update_contact_objid_list([ParameterRequired, AltName("Contact_Objid")] int contact_objid, [ParameterRequired, AltName("Site_IDNum")] string site_id, [ParameterRequired, AltName("role_name")] string role, string fax, string email, string mail_stop, [AltName("title")] string the_title, string hours, string salutation, [AltName("New_First_Name")] string new_first, [AltName("New_Last_Name")] string new_last, [AltName("New_Phone")] string new_phone, [AltName("New_Primary_Site_IDNum")] string new_prim_site_id, [AltName("New_Primary_Role")] string new_prim_role, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.Int32 | contact_objid |
System.String | site_id |
System.String | role |
System.String | fax |
System.String | email |
System.String | mail_stop |
System.String | the_title |
System.String | hours |
System.String | salutation |
System.String | new_first |
System.String | new_last |
System.String | new_phone |
System.String | new_prim_site_id |
System.String | new_prim_role |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCINTER.update_price_inst(String, String, String, String, Int32, String, String)

Declaration
[OutputProperty("ret_objid", "PriceInstance")]
[AltName("Update_Price_Instance")]
public short IFCINTER.update_price_inst([ParameterRequired, AltName("Part_Number")] string part_num, [ParameterRequired, AltName("part_domain")] string domain, [ParameterRequired, AltName("part_Revision")] string mod_level, [ParameterRequired, AltName("Price_Program")] string price_prog, [ParameterRequired, AltName("Priced_Quantity")] int priced_qty, [ParameterRequired, AltType("System.Decimal", "{0}.ToString()")] string price, [ParameterRequired, AltName("Update_Date")] string the_date)
Parameters
Type | Name | Description
System.String | part_num |
System.String | domain |
System.String | mod_level |
System.String | price_prog |
System.Int32 | priced_qty |
System.String | price |
System.String | the_date |
Returns
Type | Description
System.Int16 |

IFCINTER.UseDatabaseLogins

Declaration
public bool IFCINTER.UseDatabaseLogins { get; set; }
Returns
Type | Description
System.Boolean |

IFCINTER.yank_solution(String, String, String, String, Boolean)

Declaration
public short IFCINTER.yank_solution([ParameterRequired, AltName("Solution_IDNum")] string solution_id, [AltName("wip_bin")] string wipbin, string yank_date, string user_name, [ParameterDefaultValue("true"), AltName("Generate_Time_Bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | solution_id |
System.String | wipbin |
System.String | yank_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

Implements

IFCINTER
IToolkit


Class FCINTERBase | fcSDK Documentation

Class FCINTERBase

Inheritance
System.Object
FCINTERBase
FCINTER
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Compatibility.Toolkits
Assembly: FChoice.Foundation.Clarify.Compatibility.Toolkits.dll
Syntax
[ComVisible(false)]
public abstract class FCINTERBase

Constructors

FCINTERBase()

Declaration
protected FCINTERBase()

FCINTERBase(IFCApplication, IFCSession)

Declaration
protected FCINTERBase(IFCApplication FCApp, IFCSession FCSess)
Parameters
Type | Name | Description
IFCApplication | FCApp |
IFCSession | FCSess |

Properties

_allow_duplicate_contact

Declaration
protected bool _allow_duplicate_contact { get; set; }
Property Value
Type | Description
System.Boolean |

_impersonatorUserName

Declaration
protected string _impersonatorUserName { get; set; }
Property Value
Type | Description
System.String |

_ret_id_num

Declaration
protected string _ret_id_num { get; }
Property Value
Type | Description
System.String |

_ret_objid

Declaration
protected int _ret_objid { get; }
Property Value
Type | Description
System.Int32 |

_ret_objid2

Declaration
protected int _ret_objid2 { get; }
Property Value
Type | Description
System.Int32 |

_useDatabaseLogins

Declaration
protected bool _useDatabaseLogins { get; set; }
Property Value
Type | Description
System.Boolean |

Methods

_accept_solution(String, String, String, String, Boolean)

Declaration
protected short _accept_solution(string solution_id, string accept_date, string wipbin, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | solution_id |
System.String | accept_date |
System.String | wipbin |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_add_contact_to_contract(String, String, String, String, String)

Declaration
protected short _add_contact_to_contract(string contract_id, string f_name, string l_name, string phone_num, string site_id)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | f_name |
System.String | l_name |
System.String | phone_num |
System.String | site_id |
Returns
Type | Description
System.Int16 |

_add_emp_to_bus_org(String, String, String)

Declaration
protected short _add_emp_to_bus_org(string user_name, string acct_id, string role_name)
Parameters
Type | Name | Description
System.String | user_name |
System.String | acct_id |
System.String | role_name |
Returns
Type | Description
System.Int16 |

_add_site_part_to_contract(String, String, Int32)

Declaration
protected short _add_site_part_to_contract(string contract_id, string site_id, int sp_objid)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | site_id |
System.Int32 | sp_objid |
Returns
Type | Description
System.Int16 |

_add_site_to_bus_org(String, String, String)

Declaration
protected short _add_site_to_bus_org(string site_id, string acct_id, string role_name)
Parameters
Type | Name | Description
System.String | site_id |
System.String | acct_id |
System.String | role_name |
Returns
Type | Description
System.Int16 |

_add_site_to_contract(String, String)

Declaration
protected short _add_site_to_contract(string contract_id, string site_id)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | site_id |
Returns
Type | Description
System.Int16 |

_add_user_to_queue(String, String, Boolean)

Declaration
protected short _add_user_to_queue(string queue, string user_name, bool supervisor)
Parameters
Type | Name | Description
System.String | queue |
System.String | user_name |
System.Boolean | supervisor |
Returns
Type | Description
System.Int16 |

_add_workaround(String, Int32, String, Boolean, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _add_workaround(string soln_id, int soln_objid, string workaround, bool is_public, string create_date, string res_code, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | soln_id |
System.Int32 | soln_objid |
System.String | workaround |
System.Boolean | is_public |
System.String | create_date |
System.String | res_code |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_add_workaround_list(String, Int32, String, Boolean, String, String, IFCList, IFCList, IFCList)

Declaration
protected short _add_workaround_list(string soln_id, int soln_objid, string workaround, bool is_public, string create_date, string res_code, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | soln_id |
System.Int32 | soln_objid |
System.String | workaround |
System.Boolean | is_public |
System.String | create_date |
System.String | res_code |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_assign_solution(String, String, String, String, String, Boolean)

Declaration
protected short _assign_solution(string solution_id, string new_user, string wipbin, string assign_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | solution_id |
System.String | new_user |
System.String | wipbin |
System.String | assign_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_create_address(String, String, String, String, Boolean, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _create_address(string addr1, string addr2, string city, string State, bool short_state, string zip, string Country, string time_zone, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | addr1 |
System.String | addr2 |
System.String | city |
System.String | State |
System.Boolean | short_state |
System.String | zip |
System.String | Country |
System.String | time_zone |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_create_address_list(String, String, String, String, Boolean, String, String, String, IFCList, IFCList, IFCList)

Declaration
protected short _create_address_list(string addr1, string addr2, string city, string State, bool short_state, string zip, string Country, string time_zone, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | addr1 |
System.String | addr2 |
System.String | city |
System.String | State |
System.Boolean | short_state |
System.String | zip |
System.String | Country |
System.String | time_zone |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_create_bom(String, String, String, String, String, String, Int32)

Declaration
protected short _create_bom(string parent_part, string parent_dom, string parent_rev, string child_part, string child_dom, string child_rev, int quantity)
Parameters
Type | Name | Description
System.String | parent_part |
System.String | parent_dom |
System.String | parent_rev |
System.String | child_part |
System.String | child_dom |
System.String | child_rev |
System.Int32 | quantity |
Returns
Type | Description
System.Int16 |

_create_contact(String, String, String, String, String, String, String, String, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _create_contact(string first, string last, string phone, string site_id, string role, string fax, string email, string mail_stop, string the_title, string hours, string salutation, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | first |
System.String | last |
System.String | phone |
System.String | site_id |
System.String | role |
System.String | fax |
System.String | email |
System.String | mail_stop |
System.String | the_title |
System.String | hours |
System.String | salutation |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_create_contact_list(String, String, String, String, String, String, String, String, String, String, String, IFCList, IFCList, IFCList)

Declaration
protected short _create_contact_list(string first, string last, string phone, string site_id, string role, string fax, string email, string mail_stop, string the_title, string hours, string salutation, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | first |
System.String | last |
System.String | phone |
System.String | site_id |
System.String | role |
System.String | fax |
System.String | email |
System.String | mail_stop |
System.String | the_title |
System.String | hours |
System.String | salutation |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_create_country(String, Int32, String, String, String, Double, String)

Declaration
protected short _create_country(string cname, int c_code, string the_currency, string symbol, string desc, double conv_rate, string iso_code)
Parameters
Type | Name | Description
System.String | cname |
System.Int32 | c_code |
System.String | the_currency |
System.String | symbol |
System.String | desc |
System.Double | conv_rate |
System.String | iso_code |
Returns
Type | Description
System.Int16 |

_create_employee(String, String, String, String, String, String, String, String, String, String, String, Boolean, Boolean, String, String, String, String, String, Boolean, Boolean, String, String, String, String, String, String, String, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _create_employee(string first_name, string last_name, string login_name, string password, string site_id, string e_mail, string phone, string pager, string online_priv_class, string offline_priv_class, string Id, bool is_active, bool allow_proxy, string start_date, string supervisor, string work_group, string work_group_start, string labor_rate, bool is_supervisor, bool is_fe, string normal_biz_high, string normal_biz_mid, string normal_biz_low, string after_biz_high, string after_biz_mid, string after_biz_low, string def_wipbin_title, string rc_config, string def_tablespace, string temp_tablespace, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | first_name |
System.String | last_name |
System.String | login_name |
System.String | password |
System.String | site_id |
System.String | e_mail |
System.String | phone |
System.String | pager |
System.String | online_priv_class |
System.String | offline_priv_class |
System.String | Id |
System.Boolean | is_active |
System.Boolean | allow_proxy |
System.String | start_date |
System.String | supervisor |
System.String | work_group |
System.String | work_group_start |
System.String | labor_rate |
System.Boolean | is_supervisor |
System.Boolean | is_fe |
System.String | normal_biz_high |
System.String | normal_biz_mid |
System.String | normal_biz_low |
System.String | after_biz_high |
System.String | after_biz_mid |
System.String | after_biz_low |
System.String | def_wipbin_title |
System.String | rc_config |
System.String | def_tablespace |
System.String | temp_tablespace |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_create_employee_list(String, String, String, String, String, String, String, String, String, String, String, Boolean, Boolean, String, String, String, String, String, Boolean, Boolean, String, String, String, String, String, String, String, String, String, String, IFCList, IFCList, IFCList)

Declaration
protected short _create_employee_list(string first_name, string last_name, string login_name, string password, string site_id, string e_mail, string phone, string pager, string online_priv_class, string offline_priv_class, string Id, bool is_active, bool allow_proxy, string start_date, string supervisor, string work_group, string work_group_start, string labor_rate, bool is_supervisor, bool is_fe, string normal_biz_high, string normal_biz_mid, string normal_biz_low, string after_biz_high, string after_biz_mid, string after_biz_low, string def_wipbin_title, string rc_config, string def_tablespace, string temp_tablespace, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | first_name |
System.String | last_name |
System.String | login_name |
System.String | password |
System.String | site_id |
System.String | e_mail |
System.String | phone |
System.String | pager |
System.String | online_priv_class |
System.String | offline_priv_class |
System.String | Id |
System.Boolean | is_active |
System.Boolean | allow_proxy |
System.String | start_date |
System.String | supervisor |
System.String | work_group |
System.String | work_group_start |
System.String | labor_rate |
System.Boolean | is_supervisor |
System.Boolean | is_fe |
System.String | normal_biz_high |
System.String | normal_biz_mid |
System.String | normal_biz_low |
System.String | after_biz_high |
System.String | after_biz_mid |
System.String | after_biz_low |
System.String | def_wipbin_title |
System.String | rc_config |
System.String | def_tablespace |
System.String | temp_tablespace |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_create_interact(String, String, String, String, String, String, String, String, String, String, String, String, Boolean, String, Boolean, String, String, String, Int32, Int32, Int32, String, Boolean, String, Int32, String, String, String, String, String, String)

Declaration
protected short _create_interact(string the_title, string the_notes, string first, string last, string phone, string zipcode, string reason1, string reason2, string prod_name, string direction, string the_type, string origin, bool done_in_one, string result, bool fee_based, string pay_option, string lead_source, string start_date, int duration, int wait_time, int entered_time, string user_name, bool gen_time_bomb, string int_fld1, int int_val1, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | the_title |
System.String | the_notes |
System.String | first |
System.String | last |
System.String | phone |
System.String | zipcode |
System.String | reason1 |
System.String | reason2 |
System.String | prod_name |
System.String | direction |
System.String | the_type |
System.String | origin |
System.Boolean | done_in_one |
System.String | result |
System.Boolean | fee_based |
System.String | pay_option |
System.String | lead_source |
System.String | start_date |
System.Int32 | duration |
System.Int32 | wait_time |
System.Int32 | entered_time |
System.String | user_name |
System.Boolean | gen_time_bomb |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_create_interact_list(String, String, String, String, String, String, String, String, String, String, String, String, Boolean, String, Boolean, String, String, String, Int32, Int32, Int32, String, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _create_interact_list(string the_title, string the_notes, string first, string last, string phone, string zipcode, string reason1, string reason2, string prod_name, string direction, string the_type, string origin, bool done_in_one, string result, bool fee_based, string pay_option, string lead_source, string start_date, int duration, int wait_time, int entered_time, string user_name, bool gen_time_bomb, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | the_title |
System.String | the_notes |
System.String | first |
System.String | last |
System.String | phone |
System.String | zipcode |
System.String | reason1 |
System.String | reason2 |
System.String | prod_name |
System.String | direction |
System.String | the_type |
System.String | origin |
System.Boolean | done_in_one |
System.String | result |
System.Boolean | fee_based |
System.String | pay_option |
System.String | lead_source |
System.String | start_date |
System.Int32 | duration |
System.Int32 | wait_time |
System.Int32 | entered_time |
System.String | user_name |
System.Boolean | gen_time_bomb |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_create_price_inst(String, String, String, String, Int16, Int32, String, String, String)

Declaration
protected short _create_price_inst(string part_num, string domain, string mod_level, string price_prog, short price_type, int priced_qty, string price, string start_date, string end_date)
Parameters
Type | Name | Description
System.String | part_num |
System.String | domain |
System.String | mod_level |
System.String | price_prog |
System.Int16 | price_type |
System.Int32 | priced_qty |
System.String | price |
System.String | start_date |
System.String | end_date |
Returns
Type | Description
System.Int16 |

_create_product_bin(String, String, Int32, String, Int32, Int32, String, String)

Declaration
protected short _create_product_bin(string bin_name, string site_id, int bin_objid, string description, int prim_supp, int sec_supp, string user_name, string create_date)
Parameters
Type | Name | Description
System.String | bin_name |
System.String | site_id |
System.Int32 | bin_objid |
System.String | description |
System.Int32 | prim_supp |
System.Int32 | sec_supp |
System.String | user_name |
System.String | create_date |
Returns
Type | Description
System.Int16 |

_create_soln(String, String, String, Boolean, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _create_soln(string the_title, string description, string workaround, bool is_public, string res_code, string queue_name, string create_date, string user_name, bool create_time_bomb, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | the_title |
System.String | description |
System.String | workaround |
System.Boolean | is_public |
System.String | res_code |
System.String | queue_name |
System.String | create_date |
System.String | user_name |
System.Boolean | create_time_bomb |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_create_soln_list(String, String, String, Boolean, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _create_soln_list(string the_title, string description, string workaround, bool is_public, string res_code, string queue_name, string create_date, string user_name, bool create_time_bomb, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | the_title |
System.String | description |
System.String | workaround |
System.Boolean | is_public |
System.String | res_code |
System.String | queue_name |
System.String | create_date |
System.String | user_name |
System.Boolean | create_time_bomb |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_create_state(String, String, Boolean, String)

Declaration
protected short _create_state(string State, string full_name, bool is_default, string Country)
Parameters
Type | Name | Description
System.String | State |
System.String | full_name |
System.Boolean | is_default |
System.String | Country |
Returns
Type | Description
System.Int16 |

_create_time_zone(String, String, String, Int32)

Declaration
protected short _create_time_zone(string time_zone, string full_name, string Country, int gmt_diff)
Parameters
Type | Name | Description
System.String | time_zone |
System.String | full_name |
System.String | Country |
System.Int32 | gmt_diff |
Returns
Type | Description
System.Int16 |

_create_update_account(String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _create_update_account(string acct_name, string desc, string territory, string stock, string fiscal_yr, string the_type, string size, string revenue, string ownership, string phone, string fax, string web_site, string user_name, string create_date, bool gen_time_bombs, string acct_id, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | acct_name |
System.String | desc |
System.String | territory |
System.String | stock |
System.String | fiscal_yr |
System.String | the_type |
System.String | size |
System.String | revenue |
System.String | ownership |
System.String | phone |
System.String | fax |
System.String | web_site |
System.String | user_name |
System.String | create_date |
System.Boolean | gen_time_bombs |
System.String | acct_id |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_create_update_account_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, String, IFCList, IFCList, IFCList)

Declaration
protected short _create_update_account_list(string acct_name, string desc, string territory, string stock, string fiscal_yr, string the_type, string size, string revenue, string ownership, string phone, string fax, string web_site, string user_name, string create_date, bool gen_time_bombs, string acct_id, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | acct_name |
System.String | desc |
System.String | territory |
System.String | stock |
System.String | fiscal_yr |
System.String | the_type |
System.String | size |
System.String | revenue |
System.String | ownership |
System.String | phone |
System.String | fax |
System.String | web_site |
System.String | user_name |
System.String | create_date |
System.Boolean | gen_time_bombs |
System.String | acct_id |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_create_update_contract(String, String, String, String, String, Int32, Int32, String, String, String, String, Double, Double, Double, Int32, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _create_update_contract(string contract_id, string contract_type, string status, string po_number, string pay_options, int phone_resp, int onsite_resp, string hours_for_pm, string start_date, string EXPIRE_DATE, string unit_type, double units_purch, double units_used, double units_avail, int spec_consid, string notes, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | contract_type |
System.String | status |
System.String | po_number |
System.String | pay_options |
System.Int32 | phone_resp |
System.Int32 | onsite_resp |
System.String | hours_for_pm |
System.String | start_date |
System.String | EXPIRE_DATE |
System.String | unit_type |
System.Double | units_purch |
System.Double | units_used |
System.Double | units_avail |
System.Int32 | spec_consid |
System.String | notes |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_create_update_contract_list(String, String, String, String, String, Int32, Int32, String, String, String, String, Double, Double, Double, Int32, String, IFCList, IFCList, IFCList)

Declaration
protected short _create_update_contract_list(string contract_id, string contract_type, string status, string po_number, string pay_options, int phone_resp, int onsite_resp, string hours_for_pm, string start_date, string EXPIRE_DATE, string unit_type, double units_purch, double units_used, double units_avail, int spec_consid, string notes, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | contract_type |
System.String | status |
System.String | po_number |
System.String | pay_options |
System.Int32 | phone_resp |
System.Int32 | onsite_resp |
System.String | hours_for_pm |
System.String | start_date |
System.String | EXPIRE_DATE |
System.String | unit_type |
System.Double | units_purch |
System.Double | units_used |
System.Double | units_avail |
System.Int32 | spec_consid |
System.String | notes |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_create_update_mod_level(String, String, String, String, String, String, String, String, Boolean, String)

Declaration
protected short _create_update_mod_level(string part_num, string domain, string mod_level, string replaces_part, string replaces_dom, string replaces_rev, string replaces_date, string status, bool change_ml, string new_ml)
Parameters
Type | Name | Description
System.String | part_num |
System.String | domain |
System.String | mod_level |
System.String | replaces_part |
System.String | replaces_dom |
System.String | replaces_rev |
System.String | replaces_date |
System.String | status |
System.Boolean | change_ml |
System.String | new_ml |
Returns
Type | Description
System.Int16 |

_create_update_part(String, String, String, String, String, Int32, Boolean, String, String, String, String, String, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _create_update_part(string part_num, string domain, string notes, string desc, string model_num, int warr_days, bool start_on_ship, string unit_measure, string family, string the_line, string repair_type, string part_type, string weight, string dimension, string Class_Renamed, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | part_num |
System.String | domain |
System.String | notes |
System.String | desc |
System.String | model_num |
System.Int32 | warr_days |
System.Boolean | start_on_ship |
System.String | unit_measure |
System.String | family |
System.String | the_line |
System.String | repair_type |
System.String | part_type |
System.String | weight |
System.String | dimension |
System.String | Class_Renamed |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_create_update_part_list(String, String, String, String, String, Int32, Boolean, String, String, String, String, String, String, String, String, IFCList, IFCList, IFCList)

Declaration
protected short _create_update_part_list(string part_num, string domain, string notes, string desc, string model_num, int warr_days, bool start_on_ship, string unit_measure, string family, string the_line, string repair_type, string part_type, string weight, string dimension, string Class_Renamed, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | part_num |
System.String | domain |
System.String | notes |
System.String | desc |
System.String | model_num |
System.Int32 | warr_days |
System.Boolean | start_on_ship |
System.String | unit_measure |
System.String | family |
System.String | the_line |
System.String | repair_type |
System.String | part_type |
System.String | weight |
System.String | dimension |
System.String | Class_Renamed |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_create_update_queue(String, Boolean, String, Int16, Int16, Int16, Int16, Int16, Int16, Int16, Int16, Int16, Int16, String, String)

Declaration
protected short _create_update_queue(string Title, bool personal, string description, short allow_bug, short allow_case, short allow_contract, short allow_dialogue, short allow_dmnd_dtl, short allow_job, short allow_opp, short allow_probdesc, short allow_subcase, short allow_task, string supervisor, string new_title)
Parameters
Type | Name | Description
System.String | Title |
System.Boolean | personal |
System.String | description |
System.Int16 | allow_bug |
System.Int16 | allow_case |
System.Int16 | allow_contract |
System.Int16 | allow_dialogue |
System.Int16 | allow_dmnd_dtl |
System.Int16 | allow_job |
System.Int16 | allow_opp |
System.Int16 | allow_probdesc |
System.Int16 | allow_subcase |
System.Int16 | allow_task |
System.String | supervisor |
System.String | new_title |
Returns
Type | Description
System.Int16 |

_create_update_site(Int32, String, String, String, String, String, String, String, String, String, Int32, Int32, Int32, String, String, Int32, Int32, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _create_update_site(int site_objid, string site_id, string site_name, string site_type, string bus_org, string status, string region, string district, string industry_type, string appl_type, int prim_addr, int ship_addr, int bill_addr, string parent_site, string supp_office, int prim_emp, int sec_emp, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.Int32 | site_objid |
System.String | site_id |
System.String | site_name |
System.String | site_type |
System.String | bus_org |
System.String | status |
System.String | region |
System.String | district |
System.String | industry_type |
System.String | appl_type |
System.Int32 | prim_addr |
System.Int32 | ship_addr |
System.Int32 | bill_addr |
System.String | parent_site |
System.String | supp_office |
System.Int32 | prim_emp |
System.Int32 | sec_emp |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_create_update_site_list(Int32, String, String, String, String, String, String, String, String, String, Int32, Int32, Int32, String, String, Int32, Int32, IFCList, IFCList, IFCList)

Declaration
protected short _create_update_site_list(int site_objid, string site_id, string site_name, string site_type, string bus_org, string status, string region, string district, string industry_type, string appl_type, int prim_addr, int ship_addr, int bill_addr, string parent_site, string supp_office, int prim_emp, int sec_emp, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.Int32 | site_objid |
System.String | site_id |
System.String | site_name |
System.String | site_type |
System.String | bus_org |
System.String | status |
System.String | region |
System.String | district |
System.String | industry_type |
System.String | appl_type |
System.Int32 | prim_addr |
System.Int32 | ship_addr |
System.Int32 | bill_addr |
System.String | parent_site |
System.String | supp_office |
System.Int32 | prim_emp |
System.Int32 | sec_emp |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_create_update_wipbin(String, String, String, String, Boolean)

Declaration
protected short _create_update_wipbin(string Title, string new_title, string description, string user_name, bool def_bin)
Parameters
Type | Name | Description
System.String | Title |
System.String | new_title |
System.String | description |
System.String | user_name |
System.Boolean | def_bin |
Returns
Type | Description
System.Int16 |

_deinstall_sp(Int32, String, String, Boolean)

Declaration
protected short _deinstall_sp(int sp_objid, string user_name, string deinstall_date, bool use_remove)
Parameters
Type | Name | Description
System.Int32 | sp_objid |
System.String | user_name |
System.String | deinstall_date |
System.Boolean | use_remove |
Returns
Type | Description
System.Int16 |

_delete_product_bin(Int32, String, String)

Declaration
protected short _delete_product_bin(int bin_objid, string user_name, string delete_date)
Parameters
Type | Name | Description
System.Int32 | bin_objid |
System.String | user_name |
System.String | delete_date |
Returns
Type | Description
System.Int16 |

_dispatch_solution(String, String, String, String, Boolean)

Declaration
protected short _dispatch_solution(string solution_id, string queue_name, string disp_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | solution_id |
System.String | queue_name |
System.String | disp_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_forward_solution(String, String, String, String, String, Boolean)

Declaration
protected short _forward_solution(string solution_id, string new_queue, string forward_date, string notes, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | solution_id |
System.String | new_queue |
System.String | forward_date |
System.String | notes |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_Initialize(IFCApplication, IFCSession)

Declaration
public void _Initialize(IFCApplication TheFCApplication, IFCSession TheFCSession)
Parameters
Type | Name | Description
IFCApplication | TheFCApplication |
IFCSession | TheFCSession |

_install_sp(String, String, String, String, Int32, String, Int32, Int32, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _install_sp(string site_id, string part_num, string mod_level, string domain, int quantity, string serial_num, int parent_bin_objid, int parent_sp_objid, string instance_name, string comment, string part_status, string invoice_no, string user_name, string install_date, string ship_date, bool add_activity, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | site_id |
System.String | part_num |
System.String | mod_level |
System.String | domain |
System.Int32 | quantity |
System.String | serial_num |
System.Int32 | parent_bin_objid |
System.Int32 | parent_sp_objid |
System.String | instance_name |
System.String | comment |
System.String | part_status |
System.String | invoice_no |
System.String | user_name |
System.String | install_date |
System.String | ship_date |
System.Boolean | add_activity |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_install_sp_list(String, String, String, String, Int32, String, Int32, Int32, String, String, String, String, String, String, String, Boolean)

Declaration
protected short _install_sp_list(string site_id, string part_num, string mod_level, string domain, int quantity, string serial_num, int parent_bin_objid, int parent_sp_objid, string instance_name, string comment, string part_status, string invoice_no, string user_name, string install_date, string ship_date, bool add_activity)
Parameters
Type | Name | Description
System.String | site_id |
System.String | part_num |
System.String | mod_level |
System.String | domain |
System.Int32 | quantity |
System.String | serial_num |
System.Int32 | parent_bin_objid |
System.Int32 | parent_sp_objid |
System.String | instance_name |
System.String | comment |
System.String | part_status |
System.String | invoice_no |
System.String | user_name |
System.String | install_date |
System.String | ship_date |
System.Boolean | add_activity |
Returns
Type | Description
System.Int16 |

_install_sp_list(String, String, String, String, Int32, String, Int32, Int32, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _install_sp_list(string site_id, string part_num, string mod_level, string domain, int quantity, string serial_num, int parent_bin_objid, int parent_sp_objid, string instance_name, string comment, string part_status, string invoice_no, string user_name, string install_date, string ship_date, bool add_activity, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | site_id |
System.String | part_num |
System.String | mod_level |
System.String | domain |
System.Int32 | quantity |
System.String | serial_num |
System.Int32 | parent_bin_objid |
System.Int32 | parent_sp_objid |
System.String | instance_name |
System.String | comment |
System.String | part_status |
System.String | invoice_no |
System.String | user_name |
System.String | install_date |
System.String | ship_date |
System.Boolean | add_activity |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_link_case_to_workaround(String, Int32, String, String, Boolean)

Declaration
protected short _link_case_to_workaround(string case_id, int work_objid, string link_date, string user_name, bool create_time_bomb)
Parameters
Type | Name | Description
System.String | case_id |
System.Int32 | work_objid |
System.String | link_date |
System.String | user_name |
System.Boolean | create_time_bomb |
Returns
Type | Description
System.Int16 |

_link_cr_to_soln(String, String, String, String, Boolean)

Declaration
protected short _link_cr_to_soln(string cr_id, string soln_id, string link_date, string user_name, bool create_time_bomb)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | soln_id |
System.String | link_date |
System.String | user_name |
System.Boolean | create_time_bomb |
Returns
Type | Description
System.Int16 |

_modify_product_bin(Int32, String, String, Int32, Int32, String, String)

Declaration
protected short _modify_product_bin(int bin_objid, string bin_name, string description, int prim_supp, int sec_supp, string user_name, string mod_date)
Parameters
Type | Name | Description
System.Int32 | bin_objid |
System.String | bin_name |
System.String | description |
System.Int32 | prim_supp |
System.Int32 | sec_supp |
System.String | user_name |
System.String | mod_date |
Returns
Type | Description
System.Int16 |

_modify_sp(Int32, String, String, String, String, String, String, Int32, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _modify_sp(int sp_objid, string instance_name, string serial_num, string invoice_no, string ship_date, string install_date, string warranty_date, int quantity, string part_status, string comments, string service_end_dt, string user_name, string mod_level, bool add_activity, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.Int32 | sp_objid |
System.String | instance_name |
System.String | serial_num |
System.String | invoice_no |
System.String | ship_date |
System.String | install_date |
System.String | warranty_date |
System.Int32 | quantity |
System.String | part_status |
System.String | comments |
System.String | service_end_dt |
System.String | user_name |
System.String | mod_level |
System.Boolean | add_activity |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_modify_sp_list(Int32, String, String, String, String, String, String, Int32, String, String, String, String, String, Boolean)

Declaration
protected short _modify_sp_list(int sp_objid, string instance_name, string serial_num, string invoice_no, string ship_date, string install_date, string warranty_date, int quantity, string part_status, string comments, string service_end_dt, string user_name, string mod_level, bool add_activity)
Parameters
Type | Name | Description
System.Int32 | sp_objid |
System.String | instance_name |
System.String | serial_num |
System.String | invoice_no |
System.String | ship_date |
System.String | install_date |
System.String | warranty_date |
System.Int32 | quantity |
System.String | part_status |
System.String | comments |
System.String | service_end_dt |
System.String | user_name |
System.String | mod_level |
System.Boolean | add_activity |
Returns
Type | Description
System.Int16 |

_modify_sp_list(Int32, String, String, String, String, String, String, Int32, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _modify_sp_list(int sp_objid, string instance_name, string serial_num, string invoice_no, string ship_date, string install_date, string warranty_date, int quantity, string part_status, string comments, string service_end_dt, string user_name, string mod_level, bool add_activity, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.Int32 | sp_objid |
System.String | instance_name |
System.String | serial_num |
System.String | invoice_no |
System.String | ship_date |
System.String | install_date |
System.String | warranty_date |
System.Int32 | quantity |
System.String | part_status |
System.String | comments |
System.String | service_end_dt |
System.String | user_name |
System.String | mod_level |
System.Boolean | add_activity |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_move_solution(String, String)

Declaration
protected short _move_solution(string solution_id, string new_wipbin)
Parameters
Type | Name | Description
System.String | solution_id |
System.String | new_wipbin |
Returns
Type | Description
System.Int16 |

_move_sp(Int32, String, Int32, String, Int32, Boolean, String, Boolean)

Declaration
protected short _move_sp(int sp_objid, string move_date, int parent_sp_objid, string site_id, int parent_bin_objid, bool add_activity, string user_name, bool install_and_move)
Parameters
Type | Name | Description
System.Int32 | sp_objid |
System.String | move_date |
System.Int32 | parent_sp_objid |
System.String | site_id |
System.Int32 | parent_bin_objid |
System.Boolean | add_activity |
System.String | user_name |
System.Boolean | install_and_move |
Returns
Type | Description
System.Int16 |

_reinstall_sp(Int32, String, Int32, Int32, String, String, Boolean, Boolean)

Declaration
protected short _reinstall_sp(int sp_objid, string site_id, int parent_bin_objid, int parent_sp_objid, string user_name, string reinst_date, bool add_activity, bool use_install)
Parameters
Type | Name | Description
System.Int32 | sp_objid |
System.String | site_id |
System.Int32 | parent_bin_objid |
System.Int32 | parent_sp_objid |
System.String | user_name |
System.String | reinst_date |
System.Boolean | add_activity |
System.Boolean | use_install |
Returns
Type | Description
System.Int16 |

_reject_solution(String, String, String, String, String, Boolean)

Declaration
protected short _reject_solution(string solution_id, string reject_date, string wipbin, string notes, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | solution_id |
System.String | reject_date |
System.String | wipbin |
System.String | notes |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_remove_contact_from_contract(String, Int32)

Declaration
protected short _remove_contact_from_contract(string contract_id, int contact_objid)
Parameters
Type | Name | Description
System.String | contract_id |
System.Int32 | contact_objid |
Returns
Type | Description
System.Int16 |

_remove_emp_from_bus_org(String, String, String)

Declaration
protected short _remove_emp_from_bus_org(string user_name, string acct_id, string role_name)
Parameters
Type | Name | Description
System.String | user_name |
System.String | acct_id |
System.String | role_name |
Returns
Type | Description
System.Int16 |

_remove_site_from_bus_org(String, String, String)

Declaration
protected short _remove_site_from_bus_org(string site_id, string acct_id, string role_name)
Parameters
Type | Name | Description
System.String | site_id |
System.String | acct_id |
System.String | role_name |
Returns
Type | Description
System.Int16 |

_remove_site_from_contract(String, String)

Declaration
protected short _remove_site_from_contract(string contract_id, string site_id)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | site_id |
Returns
Type | Description
System.Int16 |

_remove_site_part_from_contract(String, Int32)

Declaration
protected short _remove_site_part_from_contract(string contract_id, int sp_objid)
Parameters
Type | Name | Description
System.String | contract_id |
System.Int32 | sp_objid |
Returns
Type | Description
System.Int16 |

_unlink_case_from_workaround(String, String, String, Boolean)

Declaration
protected short _unlink_case_from_workaround(string case_id, string unlink_date, string user_name, bool create_time_bomb)
Parameters
Type | Name | Description
System.String | case_id |
System.String | unlink_date |
System.String | user_name |
System.Boolean | create_time_bomb |
Returns
Type | Description
System.Int16 |

_unlink_cr_from_soln(String, String, String, String, Boolean)

Declaration
protected short _unlink_cr_from_soln(string cr_id, string soln_id, string unlink_date, string user_name, bool create_time_bomb)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | soln_id |
System.String | unlink_date |
System.String | user_name |
System.Boolean | create_time_bomb |
Returns
Type | Description
System.Int16 |

_update_address(Int32, String, String, String, String, Boolean, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _update_address(int addr_objid, string addr1, string addr2, string city, string State, bool short_state, string zip, string Country, string time_zone, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.Int32 | addr_objid |
System.String | addr1 |
System.String | addr2 |
System.String | city |
System.String | State |
System.Boolean | short_state |
System.String | zip |
System.String | Country |
System.String | time_zone |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_update_address_list(Int32, String, String, String, String, Boolean, String, String, String, IFCList, IFCList, IFCList)

Declaration
protected short _update_address_list(int addr_objid, string addr1, string addr2, string city, string State, bool short_state, string zip, string Country, string time_zone, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.Int32 | addr_objid |
System.String | addr1 |
System.String | addr2 |
System.String | city |
System.String | State |
System.Boolean | short_state |
System.String | zip |
System.String | Country |
System.String | time_zone |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_update_contact(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _update_contact(string first, string last, string phone, string site_id, string role, string fax, string email, string mail_stop, string the_title, string hours, string salutation, string new_first, string new_last, string new_phone, string new_prim_site_id, string new_prim_role, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | first |
System.String | last |
System.String | phone |
System.String | site_id |
System.String | role |
System.String | fax |
System.String | email |
System.String | mail_stop |
System.String | the_title |
System.String | hours |
System.String | salutation |
System.String | new_first |
System.String | new_last |
System.String | new_phone |
System.String | new_prim_site_id |
System.String | new_prim_role |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_update_contact(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _update_contact(string first, string last, string phone, string site_id, string role, string fax, string email, string mail_stop, string the_title, string hours, string salutation, string new_first, string new_last, string new_phone, string new_prim_site_id, string new_prim_role, string user_name, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | first |
System.String | last |
System.String | phone |
System.String | site_id |
System.String | role |
System.String | fax |
System.String | email |
System.String | mail_stop |
System.String | the_title |
System.String | hours |
System.String | salutation |
System.String | new_first |
System.String | new_last |
System.String | new_phone |
System.String | new_prim_site_id |
System.String | new_prim_role |
System.String | user_name |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_update_contact_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, IFCList, IFCList, IFCList)

Declaration
protected short _update_contact_list(string first, string last, string phone, string site_id, string role, string fax, string email, string mail_stop, string the_title, string hours, string salutation, string new_first, string new_last, string new_phone, string new_prim_site_id, string new_prim_role, string user_name, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | first |
System.String | last |
System.String | phone |
System.String | site_id |
System.String | role |
System.String | fax |
System.String | email |
System.String | mail_stop |
System.String | the_title |
System.String | hours |
System.String | salutation |
System.String | new_first |
System.String | new_last |
System.String | new_phone |
System.String | new_prim_site_id |
System.String | new_prim_role |
System.String | user_name |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_update_contact_objid_list(Int32, String, String, String, String, String, String, String, String, String, String, String, String, String, String, IFCList, IFCList, IFCList)

Declaration
protected short _update_contact_objid_list(int contact_objid, string site_id, string role, string fax, string email, string mail_stop, string the_title, string hours, string salutation, string new_first, string new_last, string new_phone, string new_prim_site_id, string new_prim_role, string user_name, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.Int32 | contact_objid |
System.String | site_id |
System.String | role |
System.String | fax |
System.String | email |
System.String | mail_stop |
System.String | the_title |
System.String | hours |
System.String | salutation |
System.String | new_first |
System.String | new_last |
System.String | new_phone |
System.String | new_prim_site_id |
System.String | new_prim_role |
System.String | user_name |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_update_price_inst(String, String, String, String, Int32, String, String)

Declaration
protected short _update_price_inst(string part_num, string domain, string mod_level, string price_prog, int priced_qty, string price, string the_date)
Parameters
Type | Name | Description
System.String | part_num |
System.String | domain |
System.String | mod_level |
System.String | price_prog |
System.Int32 | priced_qty |
System.String | price |
System.String | the_date |
Returns
Type | Description
System.Int16 |

_yank_solution(String, String, String, String, Boolean)

Declaration
protected short _yank_solution(string solution_id, string wipbin, string yank_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | solution_id |
System.String | wipbin |
System.String | yank_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

GetProductID()

Declaration
protected abstract int GetProductID()
Returns
Type | Description
System.Int32 |


Class FCSFA | fcSDK Documentation

Class FCSFA

Inheritance
System.Object
FCSFABase
FCSFA
Implements
IFCSFA
IToolkit
Inherited Members
FCSFABase._Initialize(IFCApplication, IFCSession)
FCSFABase._update_action_item_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, IFCList, IFCList, IFCList)
FCSFABase._update_action_item(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)
FCSFABase._create_action_item(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)
FCSFABase._create_action_item_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)
FCSFABase._change_task_cond(String, String, String, String, String, Boolean)
FCSFABase._reopen_opp(String, String, String, String, String, Boolean)
FCSFABase._close_opp(String, String, String, String, Boolean)
FCSFABase._modify_opp(String, String, String, String, String, String, String, Decimal, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)
FCSFABase._modify_opp_list(String, String, String, String, String, String, String, Decimal, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)
FCSFABase._create_opp(String, String, String, String, String, String, Decimal, String, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)
FCSFABase._create_opp_list(String, String, String, String, String, String, Decimal, String, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)
FCSFABase._win_opp(String, String, String, String, String, Boolean)
FCSFABase._lose_opp(String, String, String, String, String, Boolean)
FCSFABase._lead_opp(String, String, String, String, String, Boolean)
FCSFABase._opp_opp(String, String, String, String, String, Boolean)
FCSFABase._dispatch_action_item(String, String, String, String, Boolean)
FCSFABase._dispatch_opportunity(String, String, String, String, Boolean)
FCSFABase._dispatch_quote(String, String, String, String, Boolean)
FCSFABase._reject_action_item(String, String, String, String, String, Boolean)
FCSFABase._reject_opportunity(String, String, String, String, String, Boolean)
FCSFABase._reject_quote(String, String, String, String, String, Boolean)
FCSFABase._accept_action_item(String, String, String, String, Boolean)
FCSFABase._accept_opportunity(String, String, String, String, Boolean)
FCSFABase._accept_quote(String, String, String, String, Boolean)
FCSFABase._forward_action_item(String, String, String, String, String, Boolean)
FCSFABase._forward_opportunity(String, String, String, String, String, Boolean)
FCSFABase._forward_quote(String, String, String, String, String, Boolean)
FCSFABase._yank_action_item(String, String, String, String, Boolean)
FCSFABase._yank_opportunity(String, String, String, String, Boolean)
FCSFABase._yank_quote(String, String, String, String, Boolean)
FCSFABase._assign_action_item(String, String, String, String, String, Boolean)
FCSFABase._assign_opportunity(String, String, String, String, String, Boolean)
FCSFABase._assign_quote(String, String, String, String, String, Boolean)
FCSFABase._move_action_item(String, String)
FCSFABase._move_opportunity(String, String)
FCSFABase._move_quote(String, String)
FCSFABase._change_action_item_status(String, String, String, String, String, Boolean)
FCSFABase._change_opportunity_status(String, String, String, String, String, Boolean)
FCSFABase._change_quote_status(String, String, String, String, String, Boolean)
FCSFABase._create_quote(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int16, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)
FCSFABase._create_quote_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int16, Boolean, IFCList, IFCList, IFCList)
FCSFABase._cr_contr_itm(String, String, String, String, String, String, String, String, Int32, String, String, Double, String, Boolean, Boolean, String, String, String, Int32, String, String, Int32, String, Int32, String, String, String, String, String, String)
FCSFABase._cr_contr_itm_list(String, String, String, String, String, String, String, String, Int32, String, String, Double, String, Boolean, Boolean, String, String, String, Int32, String, IFCList, IFCList, IFCList)
FCSFABase._update_field(IFCGeneric, String, String)
FCSFABase._create_update_lead(Int32, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)
FCSFABase._create_update_lead_list(Int32, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)
FCSFABase._assign_lead(Int32, String, String, Boolean)
FCSFABase._log_lead_note(Int32, String, String, String, String, Boolean)
FCSFABase._log_lead_phone(Int32, String, String, String, String, String, String, String, Int32, String, Boolean)
FCSFABase._object_name
FCSFABase._ret_objid
FCSFABase._ret_objid2
FCSFABase._user_id
FCSFABase._emp_id
FCSFABase._wipbin_id
FCSFABase._wipbin_title
FCSFABase._ret_id_num
FCSFABase._impersonatorUserName
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Compatibility.Toolkits
Assembly: FChoice.Foundation.Clarify.Compatibility.Toolkits.dll
Syntax
[Guid("3EDF925A-1AC8-4116-9D51-7547AD12C47B")]
[ComVisible(true)]
[AltName("Sales")]
[ClassInterface(ClassInterfaceType.None)]
public sealed class FCSFA : FCSFABase, IFCSFA, IToolkit

Constructors

FCSFA()

Declaration
public FCSFA()

FCSFA(IFCApplication, IFCSession)

Declaration
public FCSFA(IFCApplication FCApp, IFCSession FCSess)
Parameters
Type | Name | Description
IFCApplication | FCApp |
IFCSession | FCSess |

Methods

GetProductID()

Declaration
protected override int GetProductID()
Returns
Type | Description
System.Int32 |
Overrides
FCSFABase.GetProductID()

Explicit Interface Implementations

IFCSFA.accept_action_item(String, String, String, String, Boolean)

Declaration
public short IFCSFA.accept_action_item([ParameterRequired, AltName("Action_Item_ID_Num")] string the_id, string accept_date, [AltName("wip_bin")] string wipbin, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | accept_date |
System.String | wipbin |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCSFA.accept_opportunity(String, String, String, String, Boolean)

Declaration
public short IFCSFA.accept_opportunity([ParameterRequired, AltName("Opportunity_IDNum")] string the_id, string accept_date, [AltName("wip_bin")] string wipbin, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | accept_date |
System.String | wipbin |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCSFA.accept_quote(String, String, String, String, Boolean)

Declaration
public short IFCSFA.accept_quote([ParameterRequired, AltName("Quote_IDNum")] string the_id, string accept_date, [AltName("wip_bin")] string wipbin, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | accept_date |
System.String | wipbin |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCSFA.assign_action_item(String, String, String, String, String, Boolean)

Declaration
public short IFCSFA.assign_action_item([ParameterRequired, AltName("Action_Item_ID_Num")] string the_id, string new_user, [AltName("wip_bin")] string wipbin, string assign_date, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | new_user |
System.String | wipbin |
System.String | assign_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCSFA.assign_lead(Int32, String, String, Boolean)

Declaration
public short IFCSFA.assign_lead([ParameterRequired, AltName("Lead_Objid")] int lead_objid, [ParameterRequired] string new_owner, string assign_date, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.Int32 | lead_objid |
System.String | new_owner |
System.String | assign_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCSFA.assign_opportunity(String, String, String, String, String, Boolean)

Declaration
public short IFCSFA.assign_opportunity([ParameterRequired, AltName("Opportunity_IDNum")] string the_id, string new_user, [AltName("wip_bin")] string wipbin, string assign_date, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | new_user |
System.String | wipbin |
System.String | assign_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCSFA.assign_quote(String, String, String, String, String, Boolean)

Declaration
public short IFCSFA.assign_quote([ParameterRequired, AltName("Quote_IDNum")] string the_id, string new_user, [AltName("wip_bin")] string wipbin, string assign_date, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | new_user |
System.String | wipbin |
System.String | assign_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCSFA.change_action_item_status(String, String, String, String, String, Boolean)

Declaration
public short IFCSFA.change_action_item_status([ParameterRequired, AltName("Action_Item_ID_Num")] string the_id, string new_status, string change_date, string notes, [AltName("user_name")] string local_user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | new_status |
System.String | change_date |
System.String | notes |
System.String | local_user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCSFA.change_opportunity_status(String, String, String, String, String, Boolean)

Declaration
public short IFCSFA.change_opportunity_status([ParameterRequired, AltName("Opportunity_IDNum")] string the_id, string new_status, string change_date, string notes, [AltName("user_name")] string local_user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | new_status |
System.String | change_date |
System.String | notes |
System.String | local_user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCSFA.change_quote_status(String, String, String, String, String, Boolean)

Declaration
public short IFCSFA.change_quote_status([ParameterRequired, AltName("Quote_IDNum")] string the_id, string new_status, string change_date, string notes, [AltName("user_name")] string local_user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | new_status |
System.String | change_date |
System.String | notes |
System.String | local_user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCSFA.change_task_cond(String, String, String, String, String, Boolean)

Declaration
[AltName("Change_Action_Item_Condition")]
[OutputProperty("ret_objid", "ActionItem")]
[OutputProperty("ret_id_num", "ActionItem")]
public short IFCSFA.change_task_cond([ParameterRequired, AltName("Action_Item_IDNum")] string task_id, [ParameterRequired, AltName("NewCondition")] string new_cond, string new_status, string user_name, string change_date, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | task_id |
System.String | new_cond |
System.String | new_status |
System.String | user_name |
System.String | change_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCSFA.close_opp(String, String, String, String, Boolean)

Declaration
[AltName("Close_Opportunity")]
public short IFCSFA.close_opp([ParameterRequired, AltName("Opportunity_ID_Num")] string opp_id, [AltName("Status")] string the_status, string close_date, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | opp_id |
System.String | the_status |
System.String | close_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCSFA.cr_contr_itm(String, String, String, String, String, String, String, String, Int32, String, String, Double, String, Boolean, Boolean, String, String, String, Int32, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[FacadeVoid]
[OutputProperty("ret_objid", "ContractItem")]
public short IFCSFA.cr_contr_itm(string contract_id, string user_name, string create_date, string start_date, string end_date, string part_num, string domain, string rev, int quantity, string price_schedule, string oride_price, double units_used, string serial_num, bool is_taxable, bool install_it, string comments, string quoted_site, string serviced_at_site, int parent_objid, string po_num, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | user_name |
System.String | create_date |
System.String | start_date |
System.String | end_date |
System.String | part_num |
System.String | domain |
System.String | rev |
System.Int32 | quantity |
System.String | price_schedule |
System.String | oride_price |
System.Double | units_used |
System.String | serial_num |
System.Boolean | is_taxable |
System.Boolean | install_it |
System.String | comments |
System.String | quoted_site |
System.String | serviced_at_site |
System.Int32 | parent_objid |
System.String | po_num |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCSFA.cr_contr_itm_list(String, String, String, String, String, String, String, String, Int32, String, String, Double, String, Boolean, Boolean, String, String, String, Int32, String, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[SplitMethod("Create_Quote_Line_Item", 2)]
[OutputProperty("ret_objid", "ContractItem")]
public short IFCSFA.cr_contr_itm_list([ParameterRequired, AltName("Contract_ID_Num")] string contract_id, string user_name, string create_date, string start_date, string end_date, [ParameterRequired, AltName("Part_Number")] string part_num, [ParameterRequired, AltName("Part_Domain")] string domain, [ParameterRequired, AltName("Part_Revision")] string rev, [ParameterRequired(null, 0), ParameterDefaultValue("1")] int quantity, [ParameterRequired] string price_schedule, [AltType("System.Double", "{1} ? {0}.ToString() : string.Empty"), AltName("Override_Price")] string oride_price, double units_used, [ParameterRequired(null, 1), AltName("Serial_Number")] string serial_num, bool is_taxable, [AltName("auto_install")] bool install_it, string comments, [AltName("quoted_site_IDNum")] string quoted_site, [AltName("serviced_at_site_IDNum")] string serviced_at_site, [ParameterRequired, AltName("Parent_Line_Item_Objid")] int parent_objid, [AltName("PO_IDNum")] string po_num, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | user_name |
System.String | create_date |
System.String | start_date |
System.String | end_date |
System.String | part_num |
System.String | domain |
System.String | rev |
System.Int32 | quantity |
System.String | price_schedule |
System.String | oride_price |
System.Double | units_used |
System.String | serial_num |
System.Boolean | is_taxable |
System.Boolean | install_it |
System.String | comments |
System.String | quoted_site |
System.String | serviced_at_site |
System.Int32 | parent_objid |
System.String | po_num |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCSFA.create_action_item(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[FacadeVoid]
[OutputProperty("ret_objid", "ActionItem")]
[OutputProperty("ret_id_num", "ActionItem")]
public short IFCSFA.create_action_item(string title, string notes, [AltName("Contact_First_Name")] string first_name, [AltName("Contact_Last_Name")] string last_name, [AltName("Contact_Phone")] string phone, [AltName("Account_Name")] string acct_name, [AltName("lead_first_name")] string lead_first, [AltName("lead_last_name")] string lead_last, [AltName("Opportunity_ID_Num")] string opp_id, [AltName("Task_Type")] string the_type, string priority, string start_date, string due_date, string complete_date, string status, string create_date, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | title |
System.String | notes |
System.String | first_name |
System.String | last_name |
System.String | phone |
System.String | acct_name |
System.String | lead_first |
System.String | lead_last |
System.String | opp_id |
System.String | the_type |
System.String | priority |
System.String | start_date |
System.String | due_date |
System.String | complete_date |
System.String | status |
System.String | create_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCSFA.create_action_item_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[OutputProperty("ret_objid", "ActionItem")]
[OutputProperty("ret_id_num", "ActionItem")]
public short IFCSFA.create_action_item_list(string title, string notes, [AltName("Contact_First_Name")] string first_name, [AltName("Contact_Last_Name")] string last_name, [AltName("Contact_Phone")] string phone, [AltName("Account_Name")] string acct_name, [AltName("lead_first_name")] string lead_first, [AltName("lead_last_name")] string lead_last, [AltName("Opportunity_ID_Num")] string opp_id, [AltName("Task_Type")] string the_type, string priority, string start_date, string due_date, string complete_date, string status, string create_date, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | title |
System.String | notes |
System.String | first_name |
System.String | last_name |
System.String | phone |
System.String | acct_name |
System.String | lead_first |
System.String | lead_last |
System.String | opp_id |
System.String | the_type |
System.String | priority |
System.String | start_date |
System.String | due_date |
System.String | complete_date |
System.String | status |
System.String | create_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCSFA.create_opp(String, String, String, String, String, String, Decimal, String, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[AltName("Create_Opportunity")]
[OutputProperty("ret_objid", "Opportunity")]
[OutputProperty("ret_id_num", "Opportunity")]
public short IFCSFA.create_opp([ParameterRequired, AltName("Opportunity_name")] string opp_name, [AltName("Account_IDNum")] string acct_id, [AltName("Contact_First_Name")] string con_first, [AltName("Contact_Last_Name")] string con_last, [AltName("Contact_Phone")] string con_phone, [AltName("territory")] string terr_name, [AltName("Amount")] decimal amt, string close_date, [ParameterRequired] string sales_stage, string lead_source, [AltName("Currency")] string the_currency, [AltType("System.Single", "{1} ? {0}.ToString() : string.Empty"), AltName("Probability")] string prob, string process, string user_name, string create_date, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | opp_name |
System.String | acct_id |
System.String | con_first |
System.String | con_last |
System.String | con_phone |
System.String | terr_name |
System.Decimal | amt |
System.String | close_date |
System.String | sales_stage |
System.String | lead_source |
System.String | the_currency |
System.String | prob |
System.String | process |
System.String | user_name |
System.String | create_date |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCSFA.create_opp_list(String, String, String, String, String, String, Decimal, String, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[AltName("Create_Opportunity")]
public short IFCSFA.create_opp_list([ParameterRequired, AltName("Opportunity_name")] string opp_name, [AltName("Account_IDNum")] string acct_id, [AltName("Contact_First_Name")] string con_first, [AltName("Contact_Last_Name")] string con_last, [AltName("Contact_Phone")] string con_phone, [AltName("territory")] string terr_name, [AltName("Amount")] decimal amt, string close_date, [ParameterRequired] string sales_stage, string lead_source, [AltName("Currency")] string the_currency, [ParameterRequired, AltType("System.Single", "{1} ? {0}.ToString() : string.Empty"), AltName("Probability")] string prob, string process, string user_name, string create_date, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | opp_name |
System.String | acct_id |
System.String | con_first |
System.String | con_last |
System.String | con_phone |
System.String | terr_name |
System.Decimal | amt |
System.String | close_date |
System.String | sales_stage |
System.String | lead_source |
System.String | the_currency |
System.String | prob |
System.String | process |
System.String | user_name |
System.String | create_date |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCSFA.create_quote(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int16, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[OutputProperty("ret_objid", "Quote")]
[OutputProperty("ret_id_num", "Quote")]
[OutputProperty("ret_objid2", "ScheduleObjid", "System.Int32", "0", "ContractSchedule")]
public short IFCSFA.create_quote([ParameterRequired] string quote_title, [AltName("Account_IDNum")] string account_id, [AltName("Site_IDNum")] string site_id, [AltName("Opportunity_ID_Num")] string opp_id, [AltName("Contact_First_Name")] string first, [AltName("Contact_last_Name")] string last, [AltName("Contact_Phone")] string phone, string status, [AltName("bill_to_site_IDNum")] string bill_to_site, [AltName("ship_to_site_IDNum")] string ship_to_site, [AltName("Currency")] string the_curr, [AltName("Price_Program")] string price_prog, string queue, [AltName("Admin_User_Name")] string admin_user, string create_date, string user_name, [AltName("Quote_Length_In_Days")] short quote_len, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | quote_title |
System.String | account_id |
System.String | site_id |
System.String | opp_id |
System.String | first |
System.String | last |
System.String | phone |
System.String | status |
System.String | bill_to_site |
System.String | ship_to_site |
System.String | the_curr |
System.String | price_prog |
System.String | queue |
System.String | admin_user |
System.String | create_date |
System.String | user_name |
System.Int16 | quote_len |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCSFA.create_quote_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int16, Boolean, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
public short IFCSFA.create_quote_list([ParameterRequired] string quote_title, [AltName("Account_IDNum")] string account_id, [AltName("Site_IDNum")] string site_id, [AltName("Opportunity_ID_Num")] string opp_id, [AltName("Contact_First_Name")] string first, [AltName("Contact_last_Name")] string last, [AltName("Contact_Phone")] string phone, string status, [AltName("bill_to_site_IDNum")] string bill_to_site, [AltName("ship_to_site_IDNum")] string ship_to_site, [AltName("Currency")] string the_curr, [AltName("Price_Program")] string price_prog, string queue, [AltName("Admin_User_Name")] string admin_user, string create_date, string user_name, [AltName("Quote_Length_In_Days")] short quote_len, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | quote_title |
System.String | account_id |
System.String | site_id |
System.String | opp_id |
System.String | first |
System.String | last |
System.String | phone |
System.String | status |
System.String | bill_to_site |
System.String | ship_to_site |
System.String | the_curr |
System.String | price_prog |
System.String | queue |
System.String | admin_user |
System.String | create_date |
System.String | user_name |
System.Int16 | quote_len |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCSFA.create_update_lead(Int32, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[SplitMethod("create_lead")]
[SplitMethod("update_lead")]
public short IFCSFA.create_update_lead([ParameterRequired("update_lead"), ParameterDefaultValue("-1"), AltName("Lead_Objid")] int lead_objid, [AltName("Contact_First_Name")] string first_name, [AltName("Contact_Last_Name")] string last_name, [AltName("Contact_Phone")] string phone, string fax, [AltName("address_1")] string address, string address_2, string city, [ParameterRequired("create_lead")] string state, string postal_code, [ParameterRequired("create_lead")] string country, [ParameterRequired("create_lead")] string time_zone, [AltName("Email")] string e_mail, [AltName("Title")] string the_title, string company_name, string site_name, [ParameterRequired("create_lead"), AltType("FChoice.Toolkits.Clarify.LeadSiteType", "{1} ? {0}.ToString() : string.Empty"), ParameterDefaultValue("FChoice.Toolkits.Clarify.LeadSiteType.Business")] string site_type, string rating, string contact_role, [ParameterRequired("create_lead")] string lead_source, string user_name, string create_date, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.Int32 | lead_objid |
System.String | first_name |
System.String | last_name |
System.String | phone |
System.String | fax |
System.String | address |
System.String | address_2 |
System.String | city |
System.String | state |
System.String | postal_code |
System.String | country |
System.String | time_zone |
System.String | e_mail |
System.String | the_title |
System.String | company_name |
System.String | site_name |
System.String | site_type |
System.String | rating |
System.String | contact_role |
System.String | lead_source |
System.String | user_name |
System.String | create_date |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCSFA.create_update_lead_list(Int32, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[SplitMethod("create_lead_list")]
[SplitMethod("update_lead_list")]
[OutputProperty("ret_objid", "Lead")]
public short IFCSFA.create_update_lead_list([ParameterRequired("update_lead_list"), ParameterDefaultValue("-1"), AltName("Lead_Objid")] int lead_objid, [AltName("Contact_First_Name")] string first_name, [AltName("Contact_Last_Name")] string last_name, [AltName("Contact_Phone")] string phone, string fax, string address, string address_2, string city, [ParameterRequired("create_lead_list")] string state, string postal_code, [ParameterRequired("create_lead_list")] string country, [ParameterRequired("create_lead_list")] string time_zone, [AltName("Email")] string e_mail, [AltName("Title")] string the_title, string company_name, string site_name, [ParameterRequired("create_lead_list"), AltType("FChoice.Toolkits.Clarify.LeadSiteType", "{1} ? {0}.ToString() : string.Empty"), ParameterDefaultValue("FChoice.Toolkits.Clarify.LeadSiteType.Business")] string site_type, string rating, string contact_role, [ParameterRequired("create_lead_list")] string lead_source, string user_name, string create_date, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.Int32 | lead_objid |
System.String | first_name |
System.String | last_name |
System.String | phone |
System.String | fax |
System.String | address |
System.String | address_2 |
System.String | city |
System.String | state |
System.String | postal_code |
System.String | country |
System.String | time_zone |
System.String | e_mail |
System.String | the_title |
System.String | company_name |
System.String | site_name |
System.String | site_type |
System.String | rating |
System.String | contact_role |
System.String | lead_source |
System.String | user_name |
System.String | create_date |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCSFA.dispatch_action_item(String, String, String, String, Boolean)

Declaration
public short IFCSFA.dispatch_action_item([ParameterRequired, AltName("Action_Item_ID_Num")] string the_id, [ParameterRequired, AltName("queue")] string queue_name, [AltName("Dispatch_Date")] string disp_date, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | queue_name |
System.String | disp_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCSFA.dispatch_opportunity(String, String, String, String, Boolean)

Declaration
public short IFCSFA.dispatch_opportunity([ParameterRequired, AltName("Opportunity_IDNum")] string the_id, [ParameterRequired, AltName("queue")] string queue_name, [AltName("Dispatch_Date")] string disp_date, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | queue_name |
System.String | disp_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCSFA.dispatch_quote(String, String, String, String, Boolean)

Declaration
public short IFCSFA.dispatch_quote([ParameterRequired, AltName("Quote_IDNum")] string the_id, [ParameterRequired, AltName("queue")] string queue_name, [AltName("Dispatch_Date")] string disp_date, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | queue_name |
System.String | disp_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCSFA.forward_action_item(String, String, String, String, String, Boolean)

Declaration
public short IFCSFA.forward_action_item([ParameterRequired, AltName("Action_Item_ID_Num")] string the_id, [ParameterRequired] string new_queue, string forward_date, string notes, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | new_queue |
System.String | forward_date |
System.String | notes |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCSFA.forward_opportunity(String, String, String, String, String, Boolean)

Declaration
public short IFCSFA.forward_opportunity([ParameterRequired, AltName("Opportunity_IDNum")] string the_id, [ParameterRequired] string new_queue, string forward_date, string notes, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | new_queue |
System.String | forward_date |
System.String | notes |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCSFA.forward_quote(String, String, String, String, String, Boolean)

Declaration
public short IFCSFA.forward_quote([ParameterRequired, AltName("Quote_IDNum")] string the_id, [ParameterRequired] string new_queue, string forward_date, string notes, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | new_queue |
System.String | forward_date |
System.String | notes |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCSFA.impersonatorUserName

Declaration
public string IFCSFA.impersonatorUserName { get; set; }
Returns
Type | Description
System.String |

IFCSFA.Initialize(IFCApplication, IFCSession)

Declaration
[ToolkitVisible(false)]
public void IFCSFA.Initialize(IFCApplication FCApp, IFCSession FCSess)
Parameters
Type | Name | Description
IFCApplication | FCApp |
IFCSession | FCSess |

IFCSFA.lead_opp(String, String, String, String, String, Boolean)

Declaration
[FacadeVoid]
[AltName("Lead_Opportunity")]
public short IFCSFA.lead_opp([ParameterRequired, AltName("Opportunity_ID_Num")] string opp_id, string new_status, [AltName("notes")] string the_note, string user_name, string change_date, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | opp_id |
System.String | new_status |
System.String | the_note |
System.String | user_name |
System.String | change_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCSFA.log_lead_note(Int32, String, String, String, String, Boolean)

Declaration
[OutputProperty("ret_objid", "NoteLog")]
public short IFCSFA.log_lead_note([ParameterRequired, AltName("Lead_Objid")] int lead_objid, [AltName("notes")] string the_text, [AltName("Internal_Use_Only_Notes")] string iuo, string log_date, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.Int32 | lead_objid |
System.String | the_text |
System.String | iuo |
System.String | log_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCSFA.log_lead_phone(Int32, String, String, String, String, String, String, String, Int32, String, Boolean)

Declaration
[OutputProperty("ret_objid", "PhoneLog")]
public short IFCSFA.log_lead_phone([ParameterRequired, AltName("Lead_Objid")] int lead_objid, [AltName("notes")] string the_text, [AltName("Internal_Use_Only_Notes")] string iuo, [ParameterRequired, AltName("Contact_First_Name")] string first, [ParameterRequired, AltName("Contact_Last_Name")] string last, [ParameterRequired, AltName("Contact_Phone")] string phone, [AltName("action_type")] string action, string log_date, [ParameterRequired, AltType("System.TimeSpan", "Convert.ToInt32({0}.TotalSeconds)")] int duration, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.Int32 | lead_objid |
System.String | the_text |
System.String | iuo |
System.String | first |
System.String | last |
System.String | phone |
System.String | action |
System.String | log_date |
System.Int32 | duration |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCSFA.lose_opp(String, String, String, String, String, Boolean)

Declaration
[FacadeVoid]
[AltName("Lose_Opportunity")]
public short IFCSFA.lose_opp([ParameterRequired, AltName("Opportunity_ID_Num")] string opp_id, string new_status, [AltName("notes")] string the_note, string user_name, string change_date, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | opp_id |
System.String | new_status |
System.String | the_note |
System.String | user_name |
System.String | change_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCSFA.modify_opp(String, String, String, String, String, String, String, Decimal, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[AltName("Update_Opportunity")]
public short IFCSFA.modify_opp([ParameterRequired, AltName("Opportunity_ID_Num")] string opp_id, [AltName("Opportunity_name")] string opp_name, [AltName("Account_IDNum")] string acct_id, [AltName("Contact_First_Name")] string con_first, [AltName("Contact_Last_Name")] string con_last, [AltName("Contact_Phone")] string con_phone, [AltName("territory")] string terr_name, [AltName("Amount")] decimal amt, string close_date, string lead_source, [AltName("Currency")] string the_currency, [AltType("System.Single", "{1} ? {0}.ToString() : string.Empty"), AltName("Probability")] string prob, string process, [AltName("Update_Date")] string mod_date, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | opp_id |
System.String | opp_name |
System.String | acct_id |
System.String | con_first |
System.String | con_last |
System.String | con_phone |
System.String | terr_name |
System.Decimal | amt |
System.String | close_date |
System.String | lead_source |
System.String | the_currency |
System.String | prob |
System.String | process |
System.String | mod_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCSFA.modify_opp_list(String, String, String, String, String, String, String, Decimal, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[AltName("Update_Opportunity")]
public short IFCSFA.modify_opp_list([ParameterRequired, AltName("Opportunity_ID_Num")] string opp_id, [AltName("Opportunity_name")] string opp_name, [AltName("Account_IDNum"), AltType("System.String", "({1} && {0} == String.Empty) ? \"CLEAR\" : {0}")] string acct_id, [AltName("Contact_First_Name"), AltType("System.String", "({1} && {0} == String.Empty) ? \"CLEAR\" : {0}")] string con_first, [AltName("Contact_Last_Name")] string con_last, [AltName("Contact_Phone")] string con_phone, [AltName("territory")] string terr_name, [AltName("Amount")] decimal amt, string close_date, string lead_source, [AltName("Currency")] string the_currency, [AltType("System.Single", "{1} ? {0}.ToString() : string.Empty"), AltName("Probability")] string prob, string process, [AltName("Update_date")] string mod_date, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | opp_id |
System.String | opp_name |
System.String | acct_id |
System.String | con_first |
System.String | con_last |
System.String | con_phone |
System.String | terr_name |
System.Decimal | amt |
System.String | close_date |
System.String | lead_source |
System.String | the_currency |
System.String | prob |
System.String | process |
System.String | mod_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCSFA.move_action_item(String, String)

Declaration
public short IFCSFA.move_action_item([ParameterRequired, AltName("Action_Item_ID_Num")] string the_id, [ParameterRequired, AltName("new_wip_bin")] string new_wipbin)
Parameters
Type | Name | Description
System.String | the_id |
System.String | new_wipbin |
Returns
Type | Description
System.Int16 |

IFCSFA.move_opportunity(String, String)

Declaration
public short IFCSFA.move_opportunity([ParameterRequired, AltName("Opportunity_IDNum")] string the_id, [ParameterRequired, AltName("new_wip_bin")] string new_wipbin)
Parameters
Type | Name | Description
System.String | the_id |
System.String | new_wipbin |
Returns
Type | Description
System.Int16 |

IFCSFA.move_quote(String, String)

Declaration
public short IFCSFA.move_quote([ParameterRequired, AltName("Quote_IDNum")] string the_id, [ParameterRequired, AltName("new_wip_bin")] string new_wipbin)
Parameters
Type | Name | Description
System.String | the_id |
System.String | new_wipbin |
Returns
Type | Description
System.Int16 |

IFCSFA.opp_opp(String, String, String, String, String, Boolean)

Declaration
[FacadeVoid]
[AltName("Open_Opportunity")]
public short IFCSFA.opp_opp([ParameterRequired, AltName("Opportunity_ID_Num")] string opp_id, string new_status, [AltName("notes")] string the_note, string user_name, string change_date, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | opp_id |
System.String | new_status |
System.String | the_note |
System.String | user_name |
System.String | change_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCSFA.reject_action_item(String, String, String, String, String, Boolean)

Declaration
public short IFCSFA.reject_action_item([ParameterRequired, AltName("Action_Item_ID_Num")] string the_id, string reject_date, [AltName("wip_bin")] string wipbin, string notes, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | reject_date |
System.String | wipbin |
System.String | notes |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCSFA.reject_opportunity(String, String, String, String, String, Boolean)

Declaration
public short IFCSFA.reject_opportunity([ParameterRequired, AltName("Opportunity_IDNum")] string the_id, string reject_date, [AltName("wip_bin")] string wipbin, string notes, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | reject_date |
System.String | wipbin |
System.String | notes |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCSFA.reject_quote(String, String, String, String, String, Boolean)

Declaration
public short IFCSFA.reject_quote([ParameterRequired, AltName("Quote_IDNum")] string the_id, string reject_date, [AltName("wip_bin")] string wipbin, string notes, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | reject_date |
System.String | wipbin |
System.String | notes |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCSFA.reopen_opp(String, String, String, String, String, Boolean)

Declaration
[AltName("Reopen_Opportunity")]
public short IFCSFA.reopen_opp([ParameterRequired, AltName("Opportunity_ID_Num")] string opp_id, [AltName("Status")] string the_status, [AltName("wip_bin")] string wipbin, string reopen_date, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | opp_id |
System.String | the_status |
System.String | wipbin |
System.String | reopen_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCSFA.ret_id_num

Declaration
public string IFCSFA.ret_id_num { get; }
Returns
Type | Description
System.String |

IFCSFA.ret_objid

Declaration
public int IFCSFA.ret_objid { get; }
Returns
Type | Description
System.Int32 |

IFCSFA.ret_objid2

Declaration
public int IFCSFA.ret_objid2 { get; }
Returns
Type | Description
System.Int32 |

IToolkit.ReturnIDNum

Declaration
public string IToolkit.ReturnIDNum { get; }
Returns
Type | Description
System.String |

IToolkit.ReturnObjid

Declaration
public int IToolkit.ReturnObjid { get; }
Returns
Type | Description
System.Int32 |

IFCSFA.update_action_item(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
[FacadeVoid]
[OutputProperty("ret_objid", "ActionItem")]
[OutputProperty("ret_id_num", "ActionItem")]
public short IFCSFA.update_action_item([ParameterRequired, AltName("Action_Item_IDNum")] string task_id, string title, string notes, [AltName("Contact_First_Name")] string first_name, [AltName("Contact_Last_Name")] string last_name, [AltName("Contact_Phone")] string phone, [AltName("Account_Name")] string acct_name, [AltName("lead_first_name")] string lead_first, [AltName("lead_last_name")] string lead_last, [AltName("Opportunity_ID_Num")] string opp_id, [AltName("Task_Type")] string the_type, string priority, string start_date, string due_date, string complete_date, string status, string update_date, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | task_id |
System.String | title |
System.String | notes |
System.String | first_name |
System.String | last_name |
System.String | phone |
System.String | acct_name |
System.String | lead_first |
System.String | lead_last |
System.String | opp_id |
System.String | the_type |
System.String | priority |
System.String | start_date |
System.String | due_date |
System.String | complete_date |
System.String | status |
System.String | update_date |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

IFCSFA.update_action_item_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, IFCList, IFCList, IFCList)

Declaration
[ToolkitVisible(false)]
[OutputProperty("ret_objid", "ActionItem")]
[OutputProperty("ret_id_num", "ActionItem")]
public short IFCSFA.update_action_item_list([ParameterRequired, AltName("Action_Item_IDNum")] string task_id, [AltType("System.String", "({1} && {0} == String.Empty) ? \"CLEAR\" : {0}")] string title, [AltType("System.String", "({1} && {0} == String.Empty) ? \"CLEAR\" : {0}")] string notes, [AltName("Contact_First_Name")] string first_name, [AltName("Contact_Last_Name")] string last_name, [AltName("Contact_Phone")] string phone, [AltName("Account_Name")] string acct_name, [AltName("lead_first_name")] string lead_first, [AltName("lead_last_name")] string lead_last, [AltName("Opportunity_ID_Num")] string opp_id, [AltName("Task_Type")] string the_type, string priority, string start_date, string due_date, string complete_date, string status, string update_date, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | task_id |
System.String | title |
System.String | notes |
System.String | first_name |
System.String | last_name |
System.String | phone |
System.String | acct_name |
System.String | lead_first |
System.String | lead_last |
System.String | opp_id |
System.String | the_type |
System.String | priority |
System.String | start_date |
System.String | due_date |
System.String | complete_date |
System.String | status |
System.String | update_date |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

IFCSFA.win_opp(String, String, String, String, String, Boolean)

Declaration
[FacadeVoid]
[AltName("Win_Opportunity")]
public short IFCSFA.win_opp([ParameterRequired, AltName("Opportunity_ID_Num")] string opp_id, string new_status, [AltName("notes")] string the_note, string user_name, string change_date, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | opp_id |
System.String | new_status |
System.String | the_note |
System.String | user_name |
System.String | change_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCSFA.yank_action_item(String, String, String, String, Boolean)

Declaration
public short IFCSFA.yank_action_item([ParameterRequired, AltName("Action_Item_ID_Num")] string the_id, [AltName("wip_bin")] string wipbin, string yank_date, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | wipbin |
System.String | yank_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCSFA.yank_opportunity(String, String, String, String, Boolean)

Declaration
public short IFCSFA.yank_opportunity([ParameterRequired, AltName("Opportunity_IDNum")] string the_id, [AltName("wip_bin")] string wipbin, string yank_date, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | wipbin |
System.String | yank_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

IFCSFA.yank_quote(String, String, String, String, Boolean)

Declaration
public short IFCSFA.yank_quote([ParameterRequired, AltName("Quote_IDNum")] string the_id, [AltName("wip_bin")] string wipbin, string yank_date, string user_name, [ParameterDefaultValue("true"), AltName("generate_time_bombs")] bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | wipbin |
System.String | yank_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

Implements

IFCSFA
IToolkit


Class FCSFABase | fcSDK Documentation

Class FCSFABase

Inheritance
System.Object
FCSFABase
FCSFA
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Compatibility.Toolkits
Assembly: FChoice.Foundation.Clarify.Compatibility.Toolkits.dll
Syntax
[ComVisible(false)]
public abstract class FCSFABase

Constructors

FCSFABase()

Declaration
protected FCSFABase()

FCSFABase(IFCApplication, IFCSession)

Declaration
protected FCSFABase(IFCApplication FCApp, IFCSession FCSess)
Parameters
Type | Name | Description
IFCApplication | FCApp |
IFCSession | FCSess |

Properties

_emp_id

Declaration
protected int _emp_id { get; set; }
Property Value
Type | Description
System.Int32 |

_impersonatorUserName

Declaration
protected string _impersonatorUserName { get; set; }
Property Value
Type | Description
System.String |

_object_name

Declaration
protected string _object_name { get; set; }
Property Value
Type | Description
System.String |

_ret_id_num

Declaration
protected string _ret_id_num { get; set; }
Property Value
Type | Description
System.String |

_ret_objid

Declaration
protected int _ret_objid { get; set; }
Property Value
Type | Description
System.Int32 |

_ret_objid2

Declaration
protected int _ret_objid2 { get; set; }
Property Value
Type | Description
System.Int32 |

_user_id

Declaration
protected int _user_id { get; set; }
Property Value
Type | Description
System.Int32 |

_wipbin_id

Declaration
protected int _wipbin_id { get; set; }
Property Value
Type | Description
System.Int32 |

_wipbin_title

Declaration
protected string _wipbin_title { get; set; }
Property Value
Type | Description
System.String |

Methods

_accept_action_item(String, String, String, String, Boolean)

Declaration
protected short _accept_action_item(string the_id, string accept_date, string wipbin, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | accept_date |
System.String | wipbin |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_accept_opportunity(String, String, String, String, Boolean)

Declaration
protected short _accept_opportunity(string the_id, string accept_date, string wipbin, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | accept_date |
System.String | wipbin |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_accept_quote(String, String, String, String, Boolean)

Declaration
protected short _accept_quote(string the_id, string accept_date, string wipbin, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | accept_date |
System.String | wipbin |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_assign_action_item(String, String, String, String, String, Boolean)

Declaration
protected short _assign_action_item(string the_id, string new_user, string wipbin, string assign_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | new_user |
System.String | wipbin |
System.String | assign_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_assign_lead(Int32, String, String, Boolean)

Declaration
protected short _assign_lead(int lead_objid, string new_owner, string assign_date, bool gen_time_bombs)
Parameters
Type | Name | Description
System.Int32 | lead_objid |
System.String | new_owner |
System.String | assign_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_assign_opportunity(String, String, String, String, String, Boolean)

Declaration
protected short _assign_opportunity(string the_id, string new_user, string wipbin, string assign_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | new_user |
System.String | wipbin |
System.String | assign_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_assign_quote(String, String, String, String, String, Boolean)

Declaration
protected short _assign_quote(string the_id, string new_user, string wipbin, string assign_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | new_user |
System.String | wipbin |
System.String | assign_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_change_action_item_status(String, String, String, String, String, Boolean)

Declaration
protected short _change_action_item_status(string the_id, string new_status, string change_date, string notes, string local_user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | new_status |
System.String | change_date |
System.String | notes |
System.String | local_user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_change_opportunity_status(String, String, String, String, String, Boolean)

Declaration
protected short _change_opportunity_status(string the_id, string new_status, string change_date, string notes, string local_user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | new_status |
System.String | change_date |
System.String | notes |
System.String | local_user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_change_quote_status(String, String, String, String, String, Boolean)

Declaration
protected short _change_quote_status(string the_id, string new_status, string change_date, string notes, string local_user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | new_status |
System.String | change_date |
System.String | notes |
System.String | local_user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_change_task_cond(String, String, String, String, String, Boolean)

Declaration
protected short _change_task_cond(string task_id, string new_cond, string new_status, string user_name, string change_date, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | task_id |
System.String | new_cond |
System.String | new_status |
System.String | user_name |
System.String | change_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_close_opp(String, String, String, String, Boolean)

Declaration
protected short _close_opp(string opp_id, string the_status, string close_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | opp_id |
System.String | the_status |
System.String | close_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_cr_contr_itm(String, String, String, String, String, String, String, String, Int32, String, String, Double, String, Boolean, Boolean, String, String, String, Int32, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _cr_contr_itm(string contract_id, string user_name, string create_date, string start_date, string end_date, string part_num, string domain, string rev, int quantity, string price_schedule, string oride_price, double units_used, string serial_num, bool is_taxable, bool install_it, string comments, string quoted_site, string serviced_at_site, int parent_objid, string po_num, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | user_name |
System.String | create_date |
System.String | start_date |
System.String | end_date |
System.String | part_num |
System.String | domain |
System.String | rev |
System.Int32 | quantity |
System.String | price_schedule |
System.String | oride_price |
System.Double | units_used |
System.String | serial_num |
System.Boolean | is_taxable |
System.Boolean | install_it |
System.String | comments |
System.String | quoted_site |
System.String | serviced_at_site |
System.Int32 | parent_objid |
System.String | po_num |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_cr_contr_itm_list(String, String, String, String, String, String, String, String, Int32, String, String, Double, String, Boolean, Boolean, String, String, String, Int32, String, IFCList, IFCList, IFCList)

Declaration
protected short _cr_contr_itm_list(string contract_id, string user_name, string create_date, string start_date, string end_date, string part_num, string domain, string rev, int quantity, string price_schedule, string oride_price, double units_used, string serial_num, bool is_taxable, bool install_it, string comments, string quoted_site, string serviced_at_site, int parent_objid, string po_num, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | user_name |
System.String | create_date |
System.String | start_date |
System.String | end_date |
System.String | part_num |
System.String | domain |
System.String | rev |
System.Int32 | quantity |
System.String | price_schedule |
System.String | oride_price |
System.Double | units_used |
System.String | serial_num |
System.Boolean | is_taxable |
System.Boolean | install_it |
System.String | comments |
System.String | quoted_site |
System.String | serviced_at_site |
System.Int32 | parent_objid |
System.String | po_num |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_create_action_item(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _create_action_item(string title, string notes, string first_name, string last_name, string phone, string acct_name, string lead_first, string lead_last, string opp_id, string the_type, string priority, string start_date, string due_date, string complete_date, string status, string create_date, string user_name, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | title |
System.String | notes |
System.String | first_name |
System.String | last_name |
System.String | phone |
System.String | acct_name |
System.String | lead_first |
System.String | lead_last |
System.String | opp_id |
System.String | the_type |
System.String | priority |
System.String | start_date |
System.String | due_date |
System.String | complete_date |
System.String | status |
System.String | create_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_create_action_item_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _create_action_item_list(string title, string notes, string first_name, string last_name, string phone, string acct_name, string lead_first, string lead_last, string opp_id, string the_type, string priority, string start_date, string due_date, string complete_date, string status, string create_date, string user_name, bool gen_time_bombs, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | title |
System.String | notes |
System.String | first_name |
System.String | last_name |
System.String | phone |
System.String | acct_name |
System.String | lead_first |
System.String | lead_last |
System.String | opp_id |
System.String | the_type |
System.String | priority |
System.String | start_date |
System.String | due_date |
System.String | complete_date |
System.String | status |
System.String | create_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_create_opp(String, String, String, String, String, String, Decimal, String, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _create_opp(string opp_name, string acct_id, string con_first, string con_last, string con_phone, string terr_name, decimal amt, string close_date, string sales_stage, string lead_source, string the_currency, string prob, string process, string user_name, string create_date, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | opp_name |
System.String | acct_id |
System.String | con_first |
System.String | con_last |
System.String | con_phone |
System.String | terr_name |
System.Decimal | amt |
System.String | close_date |
System.String | sales_stage |
System.String | lead_source |
System.String | the_currency |
System.String | prob |
System.String | process |
System.String | user_name |
System.String | create_date |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_create_opp_list(String, String, String, String, String, String, Decimal, String, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _create_opp_list(string opp_name, string acct_id, string con_first, string con_last, string con_phone, string terr_name, decimal amt, string close_date, string sales_stage, string lead_source, string the_currency, string prob, string process, string user_name, string create_date, bool gen_time_bombs, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | opp_name |
System.String | acct_id |
System.String | con_first |
System.String | con_last |
System.String | con_phone |
System.String | terr_name |
System.Decimal | amt |
System.String | close_date |
System.String | sales_stage |
System.String | lead_source |
System.String | the_currency |
System.String | prob |
System.String | process |
System.String | user_name |
System.String | create_date |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_create_quote(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int16, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _create_quote(string quote_title, string account_id, string site_id, string opp_id, string first, string last, string phone, string status, string bill_to_site, string ship_to_site, string the_curr, string price_prog, string queue, string admin_user, string create_date, string user_name, short quote_len, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | quote_title |
System.String | account_id |
System.String | site_id |
System.String | opp_id |
System.String | first |
System.String | last |
System.String | phone |
System.String | status |
System.String | bill_to_site |
System.String | ship_to_site |
System.String | the_curr |
System.String | price_prog |
System.String | queue |
System.String | admin_user |
System.String | create_date |
System.String | user_name |
System.Int16 | quote_len |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_create_quote_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int16, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _create_quote_list(string quote_title, string account_id, string site_id, string opp_id, string first, string last, string phone, string status, string bill_to_site, string ship_to_site, string the_curr, string price_prog, string queue, string admin_user, string create_date, string user_name, short quote_len, bool gen_time_bombs, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | quote_title |
System.String | account_id |
System.String | site_id |
System.String | opp_id |
System.String | first |
System.String | last |
System.String | phone |
System.String | status |
System.String | bill_to_site |
System.String | ship_to_site |
System.String | the_curr |
System.String | price_prog |
System.String | queue |
System.String | admin_user |
System.String | create_date |
System.String | user_name |
System.Int16 | quote_len |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_create_update_lead(Int32, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _create_update_lead(int lead_objid, string first_name, string last_name, string phone, string fax, string address, string address_2, string city, string state, string postal_code, string country, string time_zone, string e_mail, string the_title, string company_name, string site_name, string site_type, string rating, string contact_role, string lead_source, string user_name, string create_date, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.Int32 | lead_objid |
System.String | first_name |
System.String | last_name |
System.String | phone |
System.String | fax |
System.String | address |
System.String | address_2 |
System.String | city |
System.String | state |
System.String | postal_code |
System.String | country |
System.String | time_zone |
System.String | e_mail |
System.String | the_title |
System.String | company_name |
System.String | site_name |
System.String | site_type |
System.String | rating |
System.String | contact_role |
System.String | lead_source |
System.String | user_name |
System.String | create_date |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_create_update_lead_list(Int32, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _create_update_lead_list(int lead_objid, string first_name, string last_name, string phone, string fax, string address, string address_2, string city, string state, string postal_code, string country, string time_zone, string e_mail, string the_title, string company_name, string site_name, string site_type, string rating, string contact_role, string lead_source, string user_name, string create_date, bool gen_time_bombs, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.Int32 | lead_objid |
System.String | first_name |
System.String | last_name |
System.String | phone |
System.String | fax |
System.String | address |
System.String | address_2 |
System.String | city |
System.String | state |
System.String | postal_code |
System.String | country |
System.String | time_zone |
System.String | e_mail |
System.String | the_title |
System.String | company_name |
System.String | site_name |
System.String | site_type |
System.String | rating |
System.String | contact_role |
System.String | lead_source |
System.String | user_name |
System.String | create_date |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_dispatch_action_item(String, String, String, String, Boolean)

Declaration
protected short _dispatch_action_item(string the_id, string queue_name, string disp_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | queue_name |
System.String | disp_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_dispatch_opportunity(String, String, String, String, Boolean)

Declaration
protected short _dispatch_opportunity(string the_id, string queue_name, string disp_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | queue_name |
System.String | disp_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_dispatch_quote(String, String, String, String, Boolean)

Declaration
protected short _dispatch_quote(string the_id, string queue_name, string disp_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | queue_name |
System.String | disp_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_forward_action_item(String, String, String, String, String, Boolean)

Declaration
protected short _forward_action_item(string the_id, string new_queue, string forward_date, string notes, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | new_queue |
System.String | forward_date |
System.String | notes |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_forward_opportunity(String, String, String, String, String, Boolean)

Declaration
protected short _forward_opportunity(string the_id, string new_queue, string forward_date, string notes, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | new_queue |
System.String | forward_date |
System.String | notes |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_forward_quote(String, String, String, String, String, Boolean)

Declaration
protected short _forward_quote(string the_id, string new_queue, string forward_date, string notes, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | new_queue |
System.String | forward_date |
System.String | notes |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_Initialize(IFCApplication, IFCSession)

Declaration
public void _Initialize(IFCApplication FCApp, IFCSession FCSess)
Parameters
Type | Name | Description
IFCApplication | FCApp |
IFCSession | FCSess |

_lead_opp(String, String, String, String, String, Boolean)

Declaration
protected short _lead_opp(string opp_id, string new_status, string the_note, string user_name, string change_date, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | opp_id |
System.String | new_status |
System.String | the_note |
System.String | user_name |
System.String | change_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_log_lead_note(Int32, String, String, String, String, Boolean)

Declaration
protected short _log_lead_note(int lead_objid, string the_text, string iuo, string log_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.Int32 | lead_objid |
System.String | the_text |
System.String | iuo |
System.String | log_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_log_lead_phone(Int32, String, String, String, String, String, String, String, Int32, String, Boolean)

Declaration
protected short _log_lead_phone(int lead_objid, string the_text, string iuo, string first, string last, string phone, string action, string log_date, int duration, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.Int32 | lead_objid |
System.String | the_text |
System.String | iuo |
System.String | first |
System.String | last |
System.String | phone |
System.String | action |
System.String | log_date |
System.Int32 | duration |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_lose_opp(String, String, String, String, String, Boolean)

Declaration
protected short _lose_opp(string opp_id, string new_status, string the_note, string user_name, string change_date, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | opp_id |
System.String | new_status |
System.String | the_note |
System.String | user_name |
System.String | change_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_modify_opp(String, String, String, String, String, String, String, Decimal, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _modify_opp(string opp_id, string opp_name, string acct_id, string con_first, string con_last, string con_phone, string terr_name, decimal amt, string close_date, string lead_source, string the_currency, string prob, string process, string mod_date, string user_name, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | opp_id |
System.String | opp_name |
System.String | acct_id |
System.String | con_first |
System.String | con_last |
System.String | con_phone |
System.String | terr_name |
System.Decimal | amt |
System.String | close_date |
System.String | lead_source |
System.String | the_currency |
System.String | prob |
System.String | process |
System.String | mod_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_modify_opp_list(String, String, String, String, String, String, String, Decimal, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
protected short _modify_opp_list(string opp_id, string opp_name, string acct_id, string con_first, string con_last, string con_phone, string terr_name, decimal amt, string close_date, string lead_source, string the_currency, string prob, string process, string mod_date, string user_name, bool gen_time_bombs, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | opp_id |
System.String | opp_name |
System.String | acct_id |
System.String | con_first |
System.String | con_last |
System.String | con_phone |
System.String | terr_name |
System.Decimal | amt |
System.String | close_date |
System.String | lead_source |
System.String | the_currency |
System.String | prob |
System.String | process |
System.String | mod_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_move_action_item(String, String)

Declaration
protected short _move_action_item(string the_id, string new_wipbin)
Parameters
Type | Name | Description
System.String | the_id |
System.String | new_wipbin |
Returns
Type | Description
System.Int16 |

_move_opportunity(String, String)

Declaration
protected short _move_opportunity(string the_id, string new_wipbin)
Parameters
Type | Name | Description
System.String | the_id |
System.String | new_wipbin |
Returns
Type | Description
System.Int16 |

_move_quote(String, String)

Declaration
protected short _move_quote(string the_id, string new_wipbin)
Parameters
Type | Name | Description
System.String | the_id |
System.String | new_wipbin |
Returns
Type | Description
System.Int16 |

_opp_opp(String, String, String, String, String, Boolean)

Declaration
protected short _opp_opp(string opp_id, string new_status, string the_note, string user_name, string change_date, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | opp_id |
System.String | new_status |
System.String | the_note |
System.String | user_name |
System.String | change_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_reject_action_item(String, String, String, String, String, Boolean)

Declaration
protected short _reject_action_item(string the_id, string reject_date, string wipbin, string notes, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | reject_date |
System.String | wipbin |
System.String | notes |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_reject_opportunity(String, String, String, String, String, Boolean)

Declaration
protected short _reject_opportunity(string the_id, string reject_date, string wipbin, string notes, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | reject_date |
System.String | wipbin |
System.String | notes |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_reject_quote(String, String, String, String, String, Boolean)

Declaration
protected short _reject_quote(string the_id, string reject_date, string wipbin, string notes, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | reject_date |
System.String | wipbin |
System.String | notes |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_reopen_opp(String, String, String, String, String, Boolean)

Declaration
protected short _reopen_opp(string opp_id, string the_status, string wipbin, string reopen_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | opp_id |
System.String | the_status |
System.String | wipbin |
System.String | reopen_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_update_action_item(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
protected short _update_action_item(string task_id, string title, string notes, string first_name, string last_name, string phone, string acct_name, string lead_first, string lead_last, string opp_id, string the_type, string priority, string start_date, string due_date, string complete_date, string status, string update_date, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | task_id |
System.String | title |
System.String | notes |
System.String | first_name |
System.String | last_name |
System.String | phone |
System.String | acct_name |
System.String | lead_first |
System.String | lead_last |
System.String | opp_id |
System.String | the_type |
System.String | priority |
System.String | start_date |
System.String | due_date |
System.String | complete_date |
System.String | status |
System.String | update_date |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

_update_action_item_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, IFCList, IFCList, IFCList)

Declaration
protected short _update_action_item_list(string task_id, string title, string notes, string first_name, string last_name, string phone, string acct_name, string lead_first, string lead_last, string opp_id, string the_type, string priority, string start_date, string due_date, string complete_date, string status, string update_date, IFCList fld_list, IFCList type_list, IFCList val_list)
Parameters
Type | Name | Description
System.String | task_id |
System.String | title |
System.String | notes |
System.String | first_name |
System.String | last_name |
System.String | phone |
System.String | acct_name |
System.String | lead_first |
System.String | lead_last |
System.String | opp_id |
System.String | the_type |
System.String | priority |
System.String | start_date |
System.String | due_date |
System.String | complete_date |
System.String | status |
System.String | update_date |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

_update_field(IFCGeneric, String, String)

Declaration
protected void _update_field(IFCGeneric the_rec, string fld_name, string the_val)
Parameters
Type | Name | Description
IFCGeneric | the_rec |
System.String | fld_name |
System.String | the_val |

_win_opp(String, String, String, String, String, Boolean)

Declaration
protected short _win_opp(string opp_id, string new_status, string the_note, string user_name, string change_date, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | opp_id |
System.String | new_status |
System.String | the_note |
System.String | user_name |
System.String | change_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_yank_action_item(String, String, String, String, Boolean)

Declaration
protected short _yank_action_item(string the_id, string wipbin, string yank_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | wipbin |
System.String | yank_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_yank_opportunity(String, String, String, String, Boolean)

Declaration
protected short _yank_opportunity(string the_id, string wipbin, string yank_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | wipbin |
System.String | yank_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

_yank_quote(String, String, String, String, Boolean)

Declaration
protected short _yank_quote(string the_id, string wipbin, string yank_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | wipbin |
System.String | yank_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

GetProductID()

Declaration
protected abstract int GetProductID()
Returns
Type | Description
System.Int32 |


Interface IFCCC | fcSDK Documentation

Interface IFCCC

Namespace: FChoice.Foundation.Clarify.Compatibility.Toolkits
Assembly: FChoice.Foundation.Clarify.Compatibility.Toolkits.dll
Syntax
[Guid("6C0FD17C-AF19-4ef0-BD32-B9D796EC519B")]
[ComVisible(true)]
public interface IFCCC

Properties

impersonatorUserName

Declaration
string impersonatorUserName { get; set; }
Property Value
Type | Description
System.String |

ret_id_num

Declaration
string ret_id_num { get; }
Property Value
Type | Description
System.String |

ret_num

Declaration
short ret_num { get; }
Property Value
Type | Description
System.Int16 |

ret_objid

Declaration
int ret_objid { get; }
Property Value
Type | Description
System.Int32 |

ret_string

Declaration
string ret_string { get; }
Property Value
Type | Description
System.String |

Methods

accept_quote(String, String, String, String, Boolean)

Declaration
short accept_quote(string quote_id, string accept_date, string wipbin_name, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | quote_id |
System.String | accept_date |
System.String | wipbin_name |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

add_po_to_sched(String, String, String, String, String, String, String, String, String)

Declaration
short add_po_to_sched(string contract_id, string sched_id, string po_num, string pay_option, string pay_terms, string po_amt, string po_date, string expire_date, string po_status)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | sched_id |
System.String | po_num |
System.String | pay_option |
System.String | pay_terms |
System.String | po_amt |
System.String | po_date |
System.String | expire_date |
System.String | po_status |
Returns
Type | Description
System.Int16 |

assign_quote(String, String, String, String, String, Boolean)

Declaration
short assign_quote(string quote_id, string new_user, string wipbin_name, string assign_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | quote_id |
System.String | new_user |
System.String | wipbin_name |
System.String | assign_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

change_quote_status(String, String, String, String, String, Boolean)

Declaration
short change_quote_status(string quote_id, string new_status, string change_date, string note_str, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | quote_id |
System.String | new_status |
System.String | change_date |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

cr_contr_itm(String, String, String, String, String, String, String, String, Int32, String, String, Double, String, Boolean, Boolean, String, String, String, Int32, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short cr_contr_itm(string contract_id, string user_name, string create_date, string start_date, string end_date, string part_num, string domain, string rev, int quantity, string price_schedule, string oride_price, double units_used, string serial_num, bool is_taxable, bool install_it, string comments, string quoted_site, string serviced_at_site, int parent_objid, string po_num, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | user_name |
System.String | create_date |
System.String | start_date |
System.String | end_date |
System.String | part_num |
System.String | domain |
System.String | rev |
System.Int32 | quantity |
System.String | price_schedule |
System.String | oride_price |
System.Double | units_used |
System.String | serial_num |
System.Boolean | is_taxable |
System.Boolean | install_it |
System.String | comments |
System.String | quoted_site |
System.String | serviced_at_site |
System.Int32 | parent_objid |
System.String | po_num |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

cr_contr_itm_list(String, String, String, String, String, String, String, String, Int32, String, String, Double, String, Boolean, Boolean, String, String, String, Int32, String, IFCList, IFCList, IFCList)

Declaration
short cr_contr_itm_list(string contract_id, string user_name, string create_date, string start_date, string end_date, string part_num, string domain, string rev, int quantity, string price_schedule, string oride_price, double units_used, string serial_num, bool is_taxable, bool install_it, string comments, string quoted_site, string serviced_at_site, int parent_objid, string po_num, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | user_name |
System.String | create_date |
System.String | start_date |
System.String | end_date |
System.String | part_num |
System.String | domain |
System.String | rev |
System.Int32 | quantity |
System.String | price_schedule |
System.String | oride_price |
System.Double | units_used |
System.String | serial_num |
System.Boolean | is_taxable |
System.Boolean | install_it |
System.String | comments |
System.String | quoted_site |
System.String | serviced_at_site |
System.Int32 | parent_objid |
System.String | po_num |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

create_contract(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, Boolean, Int32, Boolean, String, Int32, String, String, String, String)

Declaration
short create_contract(string strContractID, string str_r_Title, string strCreateDate, string strAccountID, string strAccountName, string strContactFirst, string strContactLast, string strContactPhone, string strType, string strTerms, string strPriceProg, string strStatus, string strAdmin, string strBillToSite, string strShipToSite, string strEffDate, string strExpiryDate, string strServStartDate, string strServEndDate, string strUser, string strQueue, bool bWarranty, bool bEvergreen, int lRenewPrior, bool bGenTimeBombs, string int_fld1, int int_val1, string str_fld1, string str_val1, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | strContractID |
System.String | str_r_Title |
System.String | strCreateDate |
System.String | strAccountID |
System.String | strAccountName |
System.String | strContactFirst |
System.String | strContactLast |
System.String | strContactPhone |
System.String | strType |
System.String | strTerms |
System.String | strPriceProg |
System.String | strStatus |
System.String | strAdmin |
System.String | strBillToSite |
System.String | strShipToSite |
System.String | strEffDate |
System.String | strExpiryDate |
System.String | strServStartDate |
System.String | strServEndDate |
System.String | strUser |
System.String | strQueue |
System.Boolean | bWarranty |
System.Boolean | bEvergreen |
System.Int32 | lRenewPrior |
System.Boolean | bGenTimeBombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

create_contract_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, Boolean, Int32, Boolean, IFCList, IFCList, IFCList)

Declaration
short create_contract_list(string strContractID, string str_r_Title, string strCreateDate, string strAccountID, string strAccountName, string strContactFirst, string strContactLast, string strContactPhone, string strType, string strTerms, string strPriceProg, string strStatus, string strAdmin, string strBillToSite, string strShipToSite, string strEffDate, string strExpiryDate, string strServStartDate, string strServEndDate, string strUser, string strQueue, bool bWarranty, bool bEvergreen, int lRenewPrior, bool bGenTimeBombs, IFCList lstFields = null, IFCList lstDataTypes = null, IFCList lstValues = null)
Parameters
Type | Name | Description
System.String | strContractID |
System.String | str_r_Title |
System.String | strCreateDate |
System.String | strAccountID |
System.String | strAccountName |
System.String | strContactFirst |
System.String | strContactLast |
System.String | strContactPhone |
System.String | strType |
System.String | strTerms |
System.String | strPriceProg |
System.String | strStatus |
System.String | strAdmin |
System.String | strBillToSite |
System.String | strShipToSite |
System.String | strEffDate |
System.String | strExpiryDate |
System.String | strServStartDate |
System.String | strServEndDate |
System.String | strUser |
System.String | strQueue |
System.Boolean | bWarranty |
System.Boolean | bEvergreen |
System.Int32 | lRenewPrior |
System.Boolean | bGenTimeBombs |
IFCList | lstFields |
IFCList | lstDataTypes |
IFCList | lstValues |
Returns
Type | Description
System.Int16 |

create_price_inst(String, String, String, String, String, Int32, Int32, Double, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short create_price_inst(string strPartNum, string strModLevel, string strDomain, string str_r_SupportProg, string str_r_PriceProg, int l_r_PriceType, int l_r_PricedQty, double dPrice, string strEffDate, string strExpiryDate, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | strPartNum |
System.String | strModLevel |
System.String | strDomain |
System.String | str_r_SupportProg |
System.String | str_r_PriceProg |
System.Int32 | l_r_PriceType |
System.Int32 | l_r_PricedQty |
System.Double | dPrice |
System.String | strEffDate |
System.String | strExpiryDate |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

create_price_inst_list(String, String, String, String, String, Int32, Int32, Double, String, String, IFCList, IFCList, IFCList)

Declaration
short create_price_inst_list(string strPartNum, string strModLevel, string strDomain, string str_r_SupportProg, string str_r_PriceProg, int l_r_PriceType, int l_r_PricedQty, double dPrice, string strEffDate, string strExpiryDate, IFCList lstFields = null, IFCList lstDataTypes = null, IFCList lstValues = null)
Parameters
Type | Name | Description
System.String | strPartNum |
System.String | strModLevel |
System.String | strDomain |
System.String | str_r_SupportProg |
System.String | str_r_PriceProg |
System.Int32 | l_r_PriceType |
System.Int32 | l_r_PricedQty |
System.Double | dPrice |
System.String | strEffDate |
System.String | strExpiryDate |
IFCList | lstFields |
IFCList | lstDataTypes |
IFCList | lstValues |
Returns
Type | Description
System.Int16 |

create_update_schedule(String, Boolean, String, String, String, String, String, String, String, String, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short create_update_schedule(string contract_id, bool is_create, string sched_id, string bill_site, string bill_attn, string ship_site, string price_prog, string bill_freq, string bill_option, string period_start_dt, string first_bill_dt, string chg_start_dt, string chg_end_dt, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | contract_id |
System.Boolean | is_create |
System.String | sched_id |
System.String | bill_site |
System.String | bill_attn |
System.String | ship_site |
System.String | price_prog |
System.String | bill_freq |
System.String | bill_option |
System.String | period_start_dt |
System.String | first_bill_dt |
System.String | chg_start_dt |
System.String | chg_end_dt |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

create_update_schedule_list(String, Boolean, String, String, String, String, String, String, String, String, String, String, String, IFCList, IFCList, IFCList)

Declaration
short create_update_schedule_list(string contract_id, bool is_create, string sched_id, string bill_site, string bill_attn, string ship_site, string price_prog, string bill_freq, string bill_option, string period_start_dt, string first_bill_dt, string chg_start_dt, string chg_end_dt, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | contract_id |
System.Boolean | is_create |
System.String | sched_id |
System.String | bill_site |
System.String | bill_attn |
System.String | ship_site |
System.String | price_prog |
System.String | bill_freq |
System.String | bill_option |
System.String | period_start_dt |
System.String | first_bill_dt |
System.String | chg_start_dt |
System.String | chg_end_dt |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

CreateContract(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, Boolean, Int32, Boolean, String, Int32, String, String, String, String)

Declaration
short CreateContract(string strContractID, string str_r_Title, string strCreateDate, string strAccountID, string strAccountName, string strContactFirst, string strContactLast, string strContactPhone, string strType, string strTerms, string strPriceProg, string strStatus, string strAdmin, string strBillToSite, string strShipToSite, string strEffDate, string strExpiryDate, string strServStartDate, string strServEndDate, string strUser, string strQueue, bool bWarranty, bool bEvergreen, int lRenewPrior, bool bGenTimeBombs, string int_fld1, int int_val1, string str_fld1, string str_val1, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | strContractID |
System.String | str_r_Title |
System.String | strCreateDate |
System.String | strAccountID |
System.String | strAccountName |
System.String | strContactFirst |
System.String | strContactLast |
System.String | strContactPhone |
System.String | strType |
System.String | strTerms |
System.String | strPriceProg |
System.String | strStatus |
System.String | strAdmin |
System.String | strBillToSite |
System.String | strShipToSite |
System.String | strEffDate |
System.String | strExpiryDate |
System.String | strServStartDate |
System.String | strServEndDate |
System.String | strUser |
System.String | strQueue |
System.Boolean | bWarranty |
System.Boolean | bEvergreen |
System.Int32 | lRenewPrior |
System.Boolean | bGenTimeBombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

CreateContractList(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, Boolean, Int32, Boolean, IFCList, IFCList, IFCList)

Declaration
short CreateContractList(string strContractID, string str_r_Title, string strCreateDate, string strAccountID, string strAccountName, string strContactFirst, string strContactLast, string strContactPhone, string strType, string strTerms, string strPriceProg, string strStatus, string strAdmin, string strBillToSite, string strShipToSite, string strEffDate, string strExpiryDate, string strServStartDate, string strServEndDate, string strUser, string strQueue, bool bWarranty, bool bEvergreen, int lRenewPrior, bool bGenTimeBombs, IFCList lstFields = null, IFCList lstDataTypes = null, IFCList lstValues = null)
Parameters
Type | Name | Description
System.String | strContractID |
System.String | str_r_Title |
System.String | strCreateDate |
System.String | strAccountID |
System.String | strAccountName |
System.String | strContactFirst |
System.String | strContactLast |
System.String | strContactPhone |
System.String | strType |
System.String | strTerms |
System.String | strPriceProg |
System.String | strStatus |
System.String | strAdmin |
System.String | strBillToSite |
System.String | strShipToSite |
System.String | strEffDate |
System.String | strExpiryDate |
System.String | strServStartDate |
System.String | strServEndDate |
System.String | strUser |
System.String | strQueue |
System.Boolean | bWarranty |
System.Boolean | bEvergreen |
System.Int32 | lRenewPrior |
System.Boolean | bGenTimeBombs |
IFCList | lstFields |
IFCList | lstDataTypes |
IFCList | lstValues |
Returns
Type | Description
System.Int16 |

CreateLineItem(String, String, String, String, String, Boolean, Int32, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short CreateLineItem(string str_r_ContractID, string str_r_ScheduleID, string str_r_PartNum, string strModLevel, string str_r_Domain, bool b_IsGeneric, int lSitePartObjid, string strSerialNum, string strSiteId, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | str_r_ContractID |
System.String | str_r_ScheduleID |
System.String | str_r_PartNum |
System.String | strModLevel |
System.String | str_r_Domain |
System.Boolean | b_IsGeneric |
System.Int32 | lSitePartObjid |
System.String | strSerialNum |
System.String | strSiteId |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

CreateLineItemList(String, String, String, String, String, Boolean, Int32, String, String, IFCList, IFCList, IFCList)

Declaration
short CreateLineItemList(string str_r_ContractID, string str_r_ScheduleID, string str_r_PartNum, string strModLevel, string str_r_Domain, bool b_IsGeneric, int lSitePartObjid, string strSerialNum, string strSiteId, IFCList lstFields = null, IFCList lstDataTypes = null, IFCList lstValues = null)
Parameters
Type | Name | Description
System.String | str_r_ContractID |
System.String | str_r_ScheduleID |
System.String | str_r_PartNum |
System.String | strModLevel |
System.String | str_r_Domain |
System.Boolean | b_IsGeneric |
System.Int32 | lSitePartObjid |
System.String | strSerialNum |
System.String | strSiteId |
IFCList | lstFields |
IFCList | lstDataTypes |
IFCList | lstValues |
Returns
Type | Description
System.Int16 |

CreatePriceInst(String, String, String, String, String, Int32, Int32, Double, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short CreatePriceInst(string strPartNum, string strModLevel, string strDomain, string str_r_SupportProg, string str_r_PriceProg, int l_r_PriceType, int l_r_PricedQty, double dPrice, string strEffDate, string strExpiryDate, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | strPartNum |
System.String | strModLevel |
System.String | strDomain |
System.String | str_r_SupportProg |
System.String | str_r_PriceProg |
System.Int32 | l_r_PriceType |
System.Int32 | l_r_PricedQty |
System.Double | dPrice |
System.String | strEffDate |
System.String | strExpiryDate |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

CreatePriceInstList(String, String, String, String, String, Int32, Int32, Double, String, String, IFCList, IFCList, IFCList)

Declaration
short CreatePriceInstList(string strPartNum, string strModLevel, string strDomain, string str_r_SupportProg, string str_r_PriceProg, int l_r_PriceType, int l_r_PricedQty, double dPrice, string strEffDate, string strExpiryDate, IFCList lstFields = null, IFCList lstDataTypes = null, IFCList lstValues = null)
Parameters
Type | Name | Description
System.String | strPartNum |
System.String | strModLevel |
System.String | strDomain |
System.String | str_r_SupportProg |
System.String | str_r_PriceProg |
System.Int32 | l_r_PriceType |
System.Int32 | l_r_PricedQty |
System.Double | dPrice |
System.String | strEffDate |
System.String | strExpiryDate |
IFCList | lstFields |
IFCList | lstDataTypes |
IFCList | lstValues |
Returns
Type | Description
System.Int16 |

delete_sp(Int32)

Declaration
short delete_sp(int sp_objid)
Parameters
Type | Name | Description
System.Int32 | sp_objid |
Returns
Type | Description
System.Int16 |

dispatch_quote(String, String, String, String, Boolean)

Declaration
short dispatch_quote(string quote_id, string queue_name, string disp_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | quote_id |
System.String | queue_name |
System.String | disp_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

forward_quote(String, String, String, String, String, Boolean)

Declaration
short forward_quote(string quote_id, string new_queue, string forward_date, string note_str, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | quote_id |
System.String | new_queue |
System.String | forward_date |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

Initialize(IFCApplication, IFCSession)

Declaration
void Initialize(IFCApplication TheFCApplication, IFCSession TheFCSession)
Parameters
Type | Name | Description
IFCApplication | TheFCApplication |
IFCSession | TheFCSession |

log_contract_note(String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short log_contract_note(string contract_id, string action_type, string note_str, string int_use, string log_date, string user_name, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

log_contract_note_list(String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
short log_contract_note_list(string contract_id, string action_type, string note_str, string int_use, string log_date, string user_name, bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

move_quote(String, String)

Declaration
short move_quote(string quote_id, string new_wipbin_name)
Parameters
Type | Name | Description
System.String | quote_id |
System.String | new_wipbin_name |
Returns
Type | Description
System.Int16 |

reject_contract(String, String, String, String, String, Boolean)

Declaration
short reject_contract(string contract_id, string the_status, string the_notes, string user_name, string reject_date, bool gen_time_bomb)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | the_status |
System.String | the_notes |
System.String | user_name |
System.String | reject_date |
System.Boolean | gen_time_bomb |
Returns
Type | Description
System.Int16 |

reject_quote(String, String, String, String, String, Boolean)

Declaration
short reject_quote(string quote_id, string reject_date, string wipbin_name, string note_str, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | quote_id |
System.String | reject_date |
System.String | wipbin_name |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

relate_contr_itm_to_sp(Int32, String, String, String, String)

Declaration
short relate_contr_itm_to_sp(int contr_objid, string part_num, string domain, string rev, string serial_num)
Parameters
Type | Name | Description
System.Int32 | contr_objid |
System.String | part_num |
System.String | domain |
System.String | rev |
System.String | serial_num |
Returns
Type | Description
System.Int16 |

reopen_contract(String, String, String, String, String, Boolean)

Declaration
short reopen_contract(string the_id, string wipbin, string status, string reopen_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | wipbin |
System.String | status |
System.String | reopen_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

yank_quote(String, String, String, String, Boolean)

Declaration
short yank_quote(string quote_id, string wipbin_name, string yank_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | quote_id |
System.String | wipbin_name |
System.String | yank_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |


Interface IFCCL | fcSDK Documentation

Interface IFCCL

Namespace: FChoice.Foundation.Clarify.Compatibility.Toolkits
Assembly: FChoice.Foundation.Clarify.Compatibility.Toolkits.dll
Syntax
[Guid("ADFCFB46-442B-475b-B906-6CEDC5EF397F")]
[ComVisible(true)]
public interface IFCCL

Properties

impersonatorUserName

Declaration
string impersonatorUserName { get; set; }
Property Value
Type | Description
System.String |

ret_id_num

Declaration
string ret_id_num { get; }
Property Value
Type | Description
System.String |

ret_num

Declaration
short ret_num { get; }
Property Value
Type | Description
System.Int16 |

ret_objid

Declaration
int ret_objid { get; }
Property Value
Type | Description
System.Int32 |

ret_string

Declaration
string ret_string { get; }
Property Value
Type | Description
System.String |

Methods

accept_pr(String, String, String, String, Boolean)

Declaration
short accept_pr(string pr_id, string accept_date, string wipbin_name, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | pr_id |
System.String | accept_date |
System.String | wipbin_name |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

add_alt_part(String, String, String, String, String, String, Boolean)

Declaration
short add_alt_part(string part_num, string rev, string domain, string alt_part, string alt_rev, string alt_domain, bool is_reciprocal)
Parameters
Type | Name | Description
System.String | part_num |
System.String | rev |
System.String | domain |
System.String | alt_part |
System.String | alt_rev |
System.String | alt_domain |
System.Boolean | is_reciprocal |
Returns
Type | Description
System.Int16 |

add_gl_account(String, String, String, String, Boolean, Boolean, Boolean, String)

Declaration
short add_gl_account(string acct_name, string account_type, string desc_str, string account_no, bool is_exp, bool is_active, bool is_company, string site_id)
Parameters
Type | Name | Description
System.String | acct_name |
System.String | account_type |
System.String | desc_str |
System.String | account_no |
System.Boolean | is_exp |
System.Boolean | is_active |
System.Boolean | is_company |
System.String | site_id |
Returns
Type | Description
System.Int16 |

add_inv_bin(String, String, Boolean)

Declaration
short add_inv_bin(string bin_name, string loc_name, bool is_active)
Parameters
Type | Name | Description
System.String | bin_name |
System.String | loc_name |
System.Boolean | is_active |
Returns
Type | Description
System.Int16 |

add_inv_location(String, String, String, String, String, Boolean, Boolean, String, String)

Declaration
short add_inv_location(string loc_name, string account_type, string desc_str, string reports_to_loc, string cap_gl_acct, bool is_active, bool is_company, string site_id, string trans_auth_str)
Parameters
Type | Name | Description
System.String | loc_name |
System.String | account_type |
System.String | desc_str |
System.String | reports_to_loc |
System.String | cap_gl_acct |
System.Boolean | is_active |
System.Boolean | is_company |
System.String | site_id |
System.String | trans_auth_str |
Returns
Type | Description
System.Int16 |

add_lss(String, String, Boolean, Int16)

Declaration
short add_lss(string site_id, string loc_name, bool is_active, short loc_rank)
Parameters
Type | Name | Description
System.String | site_id |
System.String | loc_name |
System.Boolean | is_active |
System.Int16 | loc_rank |
Returns
Type | Description
System.Int16 |

assign_pr(String, String, String, String, String, Boolean)

Declaration
short assign_pr(string pr_id, string new_user, string wipbin_name, string assign_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | pr_id |
System.String | new_user |
System.String | wipbin_name |
System.String | assign_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

change_pr_status(String, String, String, String, String, Boolean)

Declaration
short change_pr_status(string pr_id, string new_status, string change_date, string note_str, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | pr_id |
System.String | new_status |
System.String | change_date |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

close_pr(String, String, String, String, Boolean)

Declaration
short close_pr(string pr_id, string new_status, string close_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | pr_id |
System.String | new_status |
System.String | close_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

create_container(String, String, String, String)

Declaration
short create_container(string cont_name, string the_loc, string bin_name, string parent_cont)
Parameters
Type | Name | Description
System.String | cont_name |
System.String | the_loc |
System.String | bin_name |
System.String | parent_cont |
Returns
Type | Description
System.Int16 |

delete_alt_part(String, String, String, String, String, String)

Declaration
short delete_alt_part(string part_num, string rev, string domain, string alt_part, string alt_rev, string alt_domain)
Parameters
Type | Name | Description
System.String | part_num |
System.String | rev |
System.String | domain |
System.String | alt_part |
System.String | alt_rev |
System.String | alt_domain |
Returns
Type | Description
System.Int16 |

delete_lss(String, String)

Declaration
short delete_lss(string site_id, string loc_name)
Parameters
Type | Name | Description
System.String | site_id |
System.String | loc_name |
Returns
Type | Description
System.Int16 |

dispatch_pr(String, String, String, String, Boolean)

Declaration
short dispatch_pr(string pr_id, string queue_name, string disp_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | pr_id |
System.String | queue_name |
System.String | disp_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

forward_pr(String, String, String, String, String, Boolean)

Declaration
short forward_pr(string pr_id, string new_queue, string forward_date, string note_str, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | pr_id |
System.String | new_queue |
System.String | forward_date |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

fulfill(String, Boolean, Int32, String, String, String, Boolean, String, String, String, Boolean, String, String, String, String, String, Boolean)

Declaration
short fulfill(string dtl_num, bool is_fulfill, int quantity_num, string from_loc, string from_bin, string from_cont, bool from_good, string to_loc, string to_bin, string to_cont, bool to_good, string serial_num, string new_status, string expected_date, string user_name, string fulfill_date, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | dtl_num |
System.Boolean | is_fulfill |
System.Int32 | quantity_num |
System.String | from_loc |
System.String | from_bin |
System.String | from_cont |
System.Boolean | from_good |
System.String | to_loc |
System.String | to_bin |
System.String | to_cont |
System.Boolean | to_good |
System.String | serial_num |
System.String | new_status |
System.String | expected_date |
System.String | user_name |
System.String | fulfill_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

fulfill_no_trans(String, Boolean, Int32, String, String, String, Boolean, String, String, String, Boolean, String, String, String, String, String, Boolean)

Declaration
short fulfill_no_trans(string dtl_num, bool is_fulfill, int quantity_num, string from_loc, string from_bin, string from_cont, bool from_good, string to_loc, string to_bin, string to_cont, bool to_good, string serial_num, string new_status, string expected_date, string user_name, string fulfill_date, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | dtl_num |
System.Boolean | is_fulfill |
System.Int32 | quantity_num |
System.String | from_loc |
System.String | from_bin |
System.String | from_cont |
System.Boolean | from_good |
System.String | to_loc |
System.String | to_bin |
System.String | to_cont |
System.Boolean | to_good |
System.String | serial_num |
System.String | new_status |
System.String | expected_date |
System.String | user_name |
System.String | fulfill_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

get_alt_parts(String, String, String)

Declaration
short get_alt_parts(string part_num, string domain_name, string mod_level)
Parameters
Type | Name | Description
System.String | part_num |
System.String | domain_name |
System.String | mod_level |
Returns
Type | Description
System.Int16 |

get_loc_serv_site(String)

Declaration
short get_loc_serv_site(string site_id)
Parameters
Type | Name | Description
System.String | site_id |
Returns
Type | Description
System.Int16 |

Initialize(IFCApplication, IFCSession)

Declaration
void Initialize(IFCApplication TheFCApplication, IFCSession TheFCSession)
Parameters
Type | Name | Description
IFCApplication | TheFCApplication |
IFCSession | TheFCSession |

make_pr_detail(String, String, String, String, String, String, Int32, Int32, String, String, String, String, String, String, Int16, String, String, String, String, Boolean, Int32, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short make_pr_detail(string hdr_num, string queue_name, string part_num, string domain_name, string mod_level, string serial_no, int quantity_num, int sp_rec_objid, string sp_rec_recordtype, string dtl_type, string priority_str, string ship_via, string carrier_name, string user_name, short warranty, string note_str, string status_str, string create_date, string due_date, bool gen_time_bombs, int contr_itm_objid, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | hdr_num |
System.String | queue_name |
System.String | part_num |
System.String | domain_name |
System.String | mod_level |
System.String | serial_no |
System.Int32 | quantity_num |
System.Int32 | sp_rec_objid |
System.String | sp_rec_recordtype |
System.String | dtl_type |
System.String | priority_str |
System.String | ship_via |
System.String | carrier_name |
System.String | user_name |
System.Int16 | warranty |
System.String | note_str |
System.String | status_str |
System.String | create_date |
System.String | due_date |
System.Boolean | gen_time_bombs |
System.Int32 | contr_itm_objid |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

make_pr_detail_list(String, String, String, String, String, String, Int32, Int32, String, String, String, String, String, String, Int16, String, String, String, String, Boolean, Int32, IFCList, IFCList, IFCList)

Declaration
short make_pr_detail_list(string hdr_num, string queue_name, string part_num, string domain_name, string mod_level, string serial_no, int quantity_num, int sp_rec_objid, string sp_rec_recordtype, string dtl_type, string priority_str, string ship_via, string carrier_name, string user_name, short warranty, string note_str, string status_str, string create_date, string due_date, bool gen_time_bombs, int contr_itm_objid, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | hdr_num |
System.String | queue_name |
System.String | part_num |
System.String | domain_name |
System.String | mod_level |
System.String | serial_no |
System.Int32 | quantity_num |
System.Int32 | sp_rec_objid |
System.String | sp_rec_recordtype |
System.String | dtl_type |
System.String | priority_str |
System.String | ship_via |
System.String | carrier_name |
System.String | user_name |
System.Int16 | warranty |
System.String | note_str |
System.String | status_str |
System.String | create_date |
System.String | due_date |
System.Boolean | gen_time_bombs |
System.Int32 | contr_itm_objid |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

make_pr_header(String, String, String, String, String, String, String, String, String, String, String, String, Int32, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short make_pr_header(string first_name, string last_name, string phone_num, string ship_site_id, string bill_site_id, string case_id, string pay_method, string pay_terms, string priority_str, string user_name, string note_str, string create_date, int contract_objid, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | first_name |
System.String | last_name |
System.String | phone_num |
System.String | ship_site_id |
System.String | bill_site_id |
System.String | case_id |
System.String | pay_method |
System.String | pay_terms |
System.String | priority_str |
System.String | user_name |
System.String | note_str |
System.String | create_date |
System.Int32 | contract_objid |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

make_pr_header_case_list(String, String, String, String, String, String, String, String, String, String, String, String, Int32, IFCList, IFCList, IFCList)

Declaration
short make_pr_header_case_list(string first_name, string last_name, string phone_num, string ship_site_id, string bill_site_id, string case_id, string pay_method, string pay_terms, string priority_str, string user_name, string note_str, string create_date, int contract_objid, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | first_name |
System.String | last_name |
System.String | phone_num |
System.String | ship_site_id |
System.String | bill_site_id |
System.String | case_id |
System.String | pay_method |
System.String | pay_terms |
System.String | priority_str |
System.String | user_name |
System.String | note_str |
System.String | create_date |
System.Int32 | contract_objid |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

make_pr_header_list(String, String, String, String, String, String, String, String, String, String, String, String, Int32, IFCList, IFCList, IFCList)

Declaration
short make_pr_header_list(string first_name, string last_name, string phone_num, string ship_site_id, string bill_site_id, string case_id, string pay_method, string pay_terms, string priority_str, string user_name, string note_str, string create_date, int contract_objid, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | first_name |
System.String | last_name |
System.String | phone_num |
System.String | ship_site_id |
System.String | bill_site_id |
System.String | case_id |
System.String | pay_method |
System.String | pay_terms |
System.String | priority_str |
System.String | user_name |
System.String | note_str |
System.String | create_date |
System.Int32 | contract_objid |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

make_pr_header_subcase_list(String, String, String, String, String, String, String, String, String, String, String, String, Int32, IFCList, IFCList, IFCList)

Declaration
short make_pr_header_subcase_list(string first_name, string last_name, string phone_num, string ship_site_id, string bill_site_id, string case_id, string pay_method, string pay_terms, string priority_str, string user_name, string note_str, string create_date, int contract_objid, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | first_name |
System.String | last_name |
System.String | phone_num |
System.String | ship_site_id |
System.String | bill_site_id |
System.String | case_id |
System.String | pay_method |
System.String | pay_terms |
System.String | priority_str |
System.String | user_name |
System.String | note_str |
System.String | create_date |
System.Int32 | contract_objid |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

mod_part_stocking_lev(String, String, String, String, String, String, String, String, Int16, Int16, Int16, Int16, Boolean)

Declaration
short mod_part_stocking_lev(string bin_name, string to_bin, string location_name, string queue_name, string to_queue, string part_number, string mod_level, string domain_name, short part_minimum, short part_maximum, short part_rol, short part_roq, bool is_active)
Parameters
Type | Name | Description
System.String | bin_name |
System.String | to_bin |
System.String | location_name |
System.String | queue_name |
System.String | to_queue |
System.String | part_number |
System.String | mod_level |
System.String | domain_name |
System.Int16 | part_minimum |
System.Int16 | part_maximum |
System.Int16 | part_rol |
System.Int16 | part_roq |
System.Boolean | is_active |
Returns
Type | Description
System.Int16 |

modify_gl_account(String, String, String, String, String, Boolean, Boolean, Boolean, String)

Declaration
short modify_gl_account(string old_name, string new_name, string account_type, string desc_str, string account_no, bool is_exp, bool is_active, bool is_company, string site_id)
Parameters
Type | Name | Description
System.String | old_name |
System.String | new_name |
System.String | account_type |
System.String | desc_str |
System.String | account_no |
System.Boolean | is_exp |
System.Boolean | is_active |
System.Boolean | is_company |
System.String | site_id |
Returns
Type | Description
System.Int16 |

modify_inv_bin(String, String, String, Boolean)

Declaration
short modify_inv_bin(string old_name, string new_name, string loc_name, bool is_active)
Parameters
Type | Name | Description
System.String | old_name |
System.String | new_name |
System.String | loc_name |
System.Boolean | is_active |
Returns
Type | Description
System.Int16 |

modify_inv_location(String, String, String, String, String, String, Boolean, Boolean, String, String)

Declaration
short modify_inv_location(string old_name, string new_name, string account_type, string desc_str, string reports_to_loc, string cap_gl_acct, bool is_active, bool is_company, string site_id, string trans_auth_str)
Parameters
Type | Name | Description
System.String | old_name |
System.String | new_name |
System.String | account_type |
System.String | desc_str |
System.String | reports_to_loc |
System.String | cap_gl_acct |
System.Boolean | is_active |
System.Boolean | is_company |
System.String | site_id |
System.String | trans_auth_str |
Returns
Type | Description
System.Int16 |

modify_lss(String, String, Int16)

Declaration
short modify_lss(string site_id, string loc_name, short loc_rank)
Parameters
Type | Name | Description
System.String | site_id |
System.String | loc_name |
System.Int16 | loc_rank |
Returns
Type | Description
System.Int16 |

move_pr(String, String)

Declaration
short move_pr(string pr_id, string new_wipbin_name)
Parameters
Type | Name | Description
System.String | pr_id |
System.String | new_wipbin_name |
Returns
Type | Description
System.Int16 |

open_container(String)

Declaration
short open_container(string cont_name)
Parameters
Type | Name | Description
System.String | cont_name |
Returns
Type | Description
System.Int16 |

part_transfer(String, String, String, Int32, String, String, String, String, Boolean, String, String, String, Boolean, String, String, String, String, Boolean, Int16, String, String, String, String)

Declaration
short part_transfer(string part_num, string mod_level, string domain_name, int quantity_num, string serial_num, string from_loc, string from_bin, string from_cont, bool from_good, string to_loc, string to_bin, string to_cont, bool to_good, string user_name, string trans_date, string ref_id, string note_str, bool gen_time_bombs, short fifo_flag, string update_cost, string update_source, string trans_id, string std_cost)
Parameters
Type | Name | Description
System.String | part_num |
System.String | mod_level |
System.String | domain_name |
System.Int32 | quantity_num |
System.String | serial_num |
System.String | from_loc |
System.String | from_bin |
System.String | from_cont |
System.Boolean | from_good |
System.String | to_loc |
System.String | to_bin |
System.String | to_cont |
System.Boolean | to_good |
System.String | user_name |
System.String | trans_date |
System.String | ref_id |
System.String | note_str |
System.Boolean | gen_time_bombs |
System.Int16 | fifo_flag |
System.String | update_cost |
System.String | update_source |
System.String | trans_id |
System.String | std_cost |
Returns
Type | Description
System.Int16 |

pick(String, String, Boolean, String, String, String, Boolean)

Declaration
short pick(string dtl_num, string locs_str, bool use_good, string user_name, string pick_date, string new_status, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | locs_str |
System.Boolean | use_good |
System.String | user_name |
System.String | pick_date |
System.String | new_status |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

pick_no_trans(String, String, Boolean, String, String, String, Boolean)

Declaration
short pick_no_trans(string dtl_num, string locs_str, bool use_good, string user_name, string pick_date, string new_status, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | locs_str |
System.Boolean | use_good |
System.String | user_name |
System.String | pick_date |
System.String | new_status |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

pick_sn(String, String, Boolean, String, String, String, String, Boolean)

Declaration
short pick_sn(string dtl_num, string locs_str, bool use_good, string user_name, string pick_date, string new_status, string serial_no, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | locs_str |
System.Boolean | use_good |
System.String | user_name |
System.String | pick_date |
System.String | new_status |
System.String | serial_no |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

pick_sn_no_trans(String, String, Boolean, String, String, String, String, Boolean)

Declaration
short pick_sn_no_trans(string dtl_num, string locs_str, bool use_good, string user_name, string pick_date, string new_status, string serial_no, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | locs_str |
System.Boolean | use_good |
System.String | user_name |
System.String | pick_date |
System.String | new_status |
System.String | serial_no |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

receive_pr(String, String, String, String, Boolean, String, String, String, Boolean, Int32, String, String, String, String, Boolean, Boolean, Boolean, String, String, Boolean, Boolean)

Declaration
short receive_pr(string pr_num, string from_loc, string from_bin, string from_cont, bool from_good, string to_loc, string to_bin, string to_cont, bool to_good, int quantity_num, string serial_num, string status_str, string carrier_name, string waybill_name, bool poss_damage, bool not_prop_pack, bool route_to_test, string user_name, string receive_date, bool auto_close, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | pr_num |
System.String | from_loc |
System.String | from_bin |
System.String | from_cont |
System.Boolean | from_good |
System.String | to_loc |
System.String | to_bin |
System.String | to_cont |
System.Boolean | to_good |
System.Int32 | quantity_num |
System.String | serial_num |
System.String | status_str |
System.String | carrier_name |
System.String | waybill_name |
System.Boolean | poss_damage |
System.Boolean | not_prop_pack |
System.Boolean | route_to_test |
System.String | user_name |
System.String | receive_date |
System.Boolean | auto_close |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

receive_pr_no_trans(String, String, String, String, Boolean, String, String, String, Boolean, Int32, String, String, String, String, Boolean, Boolean, Boolean, String, String, Boolean, Boolean)

Declaration
short receive_pr_no_trans(string pr_num, string from_loc, string from_bin, string from_cont, bool from_good, string to_loc, string to_bin, string to_cont, bool to_good, int quantity_num, string serial_num, string status_str, string carrier_name, string waybill_name, bool poss_damage, bool not_prop_pack, bool route_to_test, string user_name, string receive_date, bool auto_close, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | pr_num |
System.String | from_loc |
System.String | from_bin |
System.String | from_cont |
System.Boolean | from_good |
System.String | to_loc |
System.String | to_bin |
System.String | to_cont |
System.Boolean | to_good |
System.Int32 | quantity_num |
System.String | serial_num |
System.String | status_str |
System.String | carrier_name |
System.String | waybill_name |
System.Boolean | poss_damage |
System.Boolean | not_prop_pack |
System.Boolean | route_to_test |
System.String | user_name |
System.String | receive_date |
System.Boolean | auto_close |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

reject_pr(String, String, String, String, String, Boolean)

Declaration
short reject_pr(string pr_id, string reject_date, string wipbin_name, string note_str, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | pr_id |
System.String | reject_date |
System.String | wipbin_name |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

reopen_pr(String, String, String, String, String, Boolean)

Declaration
short reopen_pr(string pr_id, string new_status, string wipbin_name, string reopen_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | pr_id |
System.String | new_status |
System.String | wipbin_name |
System.String | reopen_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

seal_container(String)

Declaration
short seal_container(string cont_name)
Parameters
Type | Name | Description
System.String | cont_name |
Returns
Type | Description
System.Int16 |

set_part_stocking_lev(String, String, String, String, String, String, Int16, Int16, Int16, Int16, Boolean)

Declaration
short set_part_stocking_lev(string bin_name, string location_name, string queue_name, string part_number, string mod_level, string domain_name, short part_minimum, short part_maximum, short part_rol, short part_roq, bool is_active)
Parameters
Type | Name | Description
System.String | bin_name |
System.String | location_name |
System.String | queue_name |
System.String | part_number |
System.String | mod_level |
System.String | domain_name |
System.Int16 | part_minimum |
System.Int16 | part_maximum |
System.Int16 | part_rol |
System.Int16 | part_roq |
System.Boolean | is_active |
Returns
Type | Description
System.Int16 |

ship(String, String, String, String, String, String, String, String, String, String, String, String, Int32, Double, String, String, String, String, Boolean)

Declaration
short ship(string dtl_num, string site_name, string address_1, string address_2, string city_name, string state_name, string zip_code, string country_name, string f_name, string l_name, string waybill_name, string pack_list, int piece_count, double total_weight, string status_str, string ship_date, string user_name, string carrier_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | site_name |
System.String | address_1 |
System.String | address_2 |
System.String | city_name |
System.String | state_name |
System.String | zip_code |
System.String | country_name |
System.String | f_name |
System.String | l_name |
System.String | waybill_name |
System.String | pack_list |
System.Int32 | piece_count |
System.Double | total_weight |
System.String | status_str |
System.String | ship_date |
System.String | user_name |
System.String | carrier_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

unpick(String, String, String, String, Boolean, String, String, Boolean)

Declaration
short unpick(string dtl_num, string loc_name, string bin_name, string cont_num, bool use_good, string user_name, string unpick_date, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | loc_name |
System.String | bin_name |
System.String | cont_num |
System.Boolean | use_good |
System.String | user_name |
System.String | unpick_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

unpick_no_trans(String, String, String, String, Boolean, String, String, Boolean)

Declaration
short unpick_no_trans(string dtl_num, string loc_name, string bin_name, string cont_num, bool use_good, string user_name, string unpick_date, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | loc_name |
System.String | bin_name |
System.String | cont_num |
System.Boolean | use_good |
System.String | user_name |
System.String | unpick_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

unpick_sn(String, String, String, String, Boolean, String, String, String, Boolean)

Declaration
short unpick_sn(string dtl_num, string loc_name, string bin_name, string cont_num, bool use_good, string user_name, string unpick_date, string serial_no, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | loc_name |
System.String | bin_name |
System.String | cont_num |
System.Boolean | use_good |
System.String | user_name |
System.String | unpick_date |
System.String | serial_no |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

unpick_sn_no_trans(String, String, String, String, Boolean, String, String, String, Boolean)

Declaration
short unpick_sn_no_trans(string dtl_num, string loc_name, string bin_name, string cont_num, bool use_good, string user_name, string unpick_date, string serial_no, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | loc_name |
System.String | bin_name |
System.String | cont_num |
System.Boolean | use_good |
System.String | user_name |
System.String | unpick_date |
System.String | serial_no |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

update_pr_detail(String, String, String, String, String, Int32, Int32, String, String, String, String, Int16, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short update_pr_detail(string dtl_num, string part_num, string domain_name, string mod_level, string serial_no, int quantity_num, int sp_objid, string dtl_type, string priority_str, string ship_via, string carrier_name, short warranty, string note_str, string status_str, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | part_num |
System.String | domain_name |
System.String | mod_level |
System.String | serial_no |
System.Int32 | quantity_num |
System.Int32 | sp_objid |
System.String | dtl_type |
System.String | priority_str |
System.String | ship_via |
System.String | carrier_name |
System.Int16 | warranty |
System.String | note_str |
System.String | status_str |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

update_pr_detail_list(String, String, String, String, String, Int32, Int32, String, String, String, String, Int16, String, String, IFCList, IFCList, IFCList)

Declaration
short update_pr_detail_list(string dtl_num, string part_num, string domain_name, string mod_level, string serial_no, int quantity_num, int sp_objid, string dtl_type, string priority_str, string ship_via, string carrier_name, short warranty, string note_str, string status_str, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | part_num |
System.String | domain_name |
System.String | mod_level |
System.String | serial_no |
System.Int32 | quantity_num |
System.Int32 | sp_objid |
System.String | dtl_type |
System.String | priority_str |
System.String | ship_via |
System.String | carrier_name |
System.Int16 | warranty |
System.String | note_str |
System.String | status_str |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

update_pr_header(String, String, String, String, String, String, String, String, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short update_pr_header(string hdr_num, string first_name, string last_name, string phone_num, string ship_site_id, string bill_site_id, string case_id, string pay_method, string pay_terms, string priority_str, string note_str, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | hdr_num |
System.String | first_name |
System.String | last_name |
System.String | phone_num |
System.String | ship_site_id |
System.String | bill_site_id |
System.String | case_id |
System.String | pay_method |
System.String | pay_terms |
System.String | priority_str |
System.String | note_str |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

update_pr_header_list(String, String, String, String, String, String, String, String, String, String, String, IFCList, IFCList, IFCList)

Declaration
short update_pr_header_list(string hdr_num, string first_name, string last_name, string phone_num, string ship_site_id, string bill_site_id, string case_id, string pay_method, string pay_terms, string priority_str, string note_str, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | hdr_num |
System.String | first_name |
System.String | last_name |
System.String | phone_num |
System.String | ship_site_id |
System.String | bill_site_id |
System.String | case_id |
System.String | pay_method |
System.String | pay_terms |
System.String | priority_str |
System.String | note_str |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

yank_pr(String, String, String, String, Boolean)

Declaration
short yank_pr(string pr_id, string wipbin_name, string yank_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | pr_id |
System.String | wipbin_name |
System.String | yank_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |


Interface IFCCQ | fcSDK Documentation

Interface IFCCQ

Namespace: FChoice.Foundation.Clarify.Compatibility.Toolkits
Assembly: FChoice.Foundation.Clarify.Compatibility.Toolkits.dll
Syntax
[Guid("7530FF07-C99D-4882-91BC-A1B3FE1D99AD")]
[ComVisible(true)]
public interface IFCCQ

Properties

impersonatorUserName

Declaration
string impersonatorUserName { get; set; }
Property Value
Type | Description
System.String |

ret_id_num

Declaration
string ret_id_num { get; }
Property Value
Type | Description
System.String |

ret_objid

Declaration
int ret_objid { get; }
Property Value
Type | Description
System.Int32 |

Methods

accept_cr(String, String, String, String, Boolean)

Declaration
short accept_cr(string cr_id, string accept_date, string wipbin, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | accept_date |
System.String | wipbin |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

add_module_to_cr(Int32, String, String)

Declaration
short add_module_to_cr(int fix_objid, string file, string rev)
Parameters
Type | Name | Description
System.Int32 | fix_objid |
System.String | file |
System.String | rev |
Returns
Type | Description
System.Int16 |

assign_cr(String, String, String, String, String, Boolean)

Declaration
short assign_cr(string cr_id, string new_user, string wipbin, string assign_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | new_user |
System.String | wipbin |
System.String | assign_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

change_cr_state(String, String, String, String, String, String, Boolean, String, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short change_cr_state(string cr_id, string new_status, string new_condition, string change_date, string notes, string user_name, bool gen_time_bombs, string wipbin, string test_case, string int_release, string master_cr, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | new_status |
System.String | new_condition |
System.String | change_date |
System.String | notes |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.String | wipbin |
System.String | test_case |
System.String | int_release |
System.String | master_cr |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

change_cr_status(String, String, String, String, String, Boolean)

Declaration
short change_cr_status(string cr_id, string new_status, string change_date, string notes, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | new_status |
System.String | change_date |
System.String | notes |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

check_cq_trans(String, String, String, String, String)

Declaration
short check_cq_trans(string old_cond, string old_stat, string new_cond, string new_stat, string user_name)
Parameters
Type | Name | Description
System.String | old_cond |
System.String | old_stat |
System.String | new_cond |
System.String | new_stat |
System.String | user_name |
Returns
Type | Description
System.Int16 |

close_cr(String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short close_cr(string cr_id, string the_status, string notes, string test_case, string int_release, string user_name, string close_date, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | the_status |
System.String | notes |
System.String | test_case |
System.String | int_release |
System.String | user_name |
System.String | close_date |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

close_cr_list(String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
short close_cr_list(string cr_id, string the_status, string notes, string test_case, string int_release, string user_name, string close_date, bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | the_status |
System.String | notes |
System.String | test_case |
System.String | int_release |
System.String | user_name |
System.String | close_date |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

create_cr(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short create_cr(string part_num, string mod_level, string domain, string the_title, string status, string note_log, string cr_type, string priority, string frequency, string found_on, string op_sys, string memory, string cr_class, string intro_phase, string test_class, string fixed_in, string test, string queue_name, string user_name, string cr_date, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | part_num |
System.String | mod_level |
System.String | domain |
System.String | the_title |
System.String | status |
System.String | note_log |
System.String | cr_type |
System.String | priority |
System.String | frequency |
System.String | found_on |
System.String | op_sys |
System.String | memory |
System.String | cr_class |
System.String | intro_phase |
System.String | test_class |
System.String | fixed_in |
System.String | test |
System.String | queue_name |
System.String | user_name |
System.String | cr_date |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

create_cr_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
short create_cr_list(string part_num, string mod_level, string domain, string the_title, string status, string note_log, string cr_type, string priority, string frequency, string found_on, string op_sys, string memory, string cr_class, string intro_phase, string test_class, string fixed_in, string test, string queue_name, string user_name, string cr_date, bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | part_num |
System.String | mod_level |
System.String | domain |
System.String | the_title |
System.String | status |
System.String | note_log |
System.String | cr_type |
System.String | priority |
System.String | frequency |
System.String | found_on |
System.String | op_sys |
System.String | memory |
System.String | cr_class |
System.String | intro_phase |
System.String | test_class |
System.String | fixed_in |
System.String | test |
System.String | queue_name |
System.String | user_name |
System.String | cr_date |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

dispatch_cr(String, String, String, String, Boolean)

Declaration
short dispatch_cr(string cr_id, string queue_name, string disp_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | queue_name |
System.String | disp_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

duplicate_cr(String, String, String, String, String, Boolean)

Declaration
short duplicate_cr(string cr_id, string the_status, string master_cr, string user_name, string close_date, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | the_status |
System.String | master_cr |
System.String | user_name |
System.String | close_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

fix_cr(String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short fix_cr(string cr_id, string the_status, string notes, string user_name, string fix_date, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | the_status |
System.String | notes |
System.String | user_name |
System.String | fix_date |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

fix_cr_list(String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
short fix_cr_list(string cr_id, string the_status, string notes, string user_name, string fix_date, bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | the_status |
System.String | notes |
System.String | user_name |
System.String | fix_date |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

fix_failed(String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short fix_failed(string cr_id, string the_status, string notes, string test_case, string int_release, string user_name, string failed_date, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | the_status |
System.String | notes |
System.String | test_case |
System.String | int_release |
System.String | user_name |
System.String | failed_date |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

fix_failed_list(String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
short fix_failed_list(string cr_id, string the_status, string notes, string test_case, string int_release, string user_name, string failed_date, bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | the_status |
System.String | notes |
System.String | test_case |
System.String | int_release |
System.String | user_name |
System.String | failed_date |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

forward_cr(String, String, String, String, String, Boolean)

Declaration
short forward_cr(string cr_id, string new_queue, string forward_date, string notes, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | new_queue |
System.String | forward_date |
System.String | notes |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

Initialize(IFCApplication, IFCSession)

Declaration
void Initialize(IFCApplication TheFCApplication, IFCSession TheFCSession)
Parameters
Type | Name | Description
IFCApplication | TheFCApplication |
IFCSession | TheFCSession |

log_cr_email(String, String, String, String, String, String, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short log_cr_email(string cr_id, string log_date, string message, string recipient, string cc_list, string user_name, bool gen_time_bombs, bool send_email, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | log_date |
System.String | message |
System.String | recipient |
System.String | cc_list |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.Boolean | send_email |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

log_cr_email_list(String, String, String, String, String, String, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
short log_cr_email_list(string cr_id, string log_date, string message, string recipient, string cc_list, string user_name, bool gen_time_bombs, bool send_email, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | log_date |
System.String | message |
System.String | recipient |
System.String | cc_list |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.Boolean | send_email |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

log_cr_note(String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short log_cr_note(string cr_id, string notes, string int_use, string log_date, string user_name, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | notes |
System.String | int_use |
System.String | log_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

log_cr_note_list(String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
short log_cr_note_list(string cr_id, string notes, string int_use, string log_date, string user_name, bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | notes |
System.String | int_use |
System.String | log_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

modify_cr(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short modify_cr(string cr_num, string part_num, string mod_level, string domain, string the_title, string cr_type, string priority, string frequency, string found_on, string op_sys, string memory, string cr_class, string intro_phase, string test_class, string fixed_in, string user_name, string cr_date, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | cr_num |
System.String | part_num |
System.String | mod_level |
System.String | domain |
System.String | the_title |
System.String | cr_type |
System.String | priority |
System.String | frequency |
System.String | found_on |
System.String | op_sys |
System.String | memory |
System.String | cr_class |
System.String | intro_phase |
System.String | test_class |
System.String | fixed_in |
System.String | user_name |
System.String | cr_date |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

modify_cr_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
short modify_cr_list(string cr_num, string part_num, string mod_level, string domain, string the_title, string cr_type, string priority, string frequency, string found_on, string op_sys, string memory, string cr_class, string intro_phase, string test_class, string fixed_in, string user_name, string cr_date, bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | cr_num |
System.String | part_num |
System.String | mod_level |
System.String | domain |
System.String | the_title |
System.String | cr_type |
System.String | priority |
System.String | frequency |
System.String | found_on |
System.String | op_sys |
System.String | memory |
System.String | cr_class |
System.String | intro_phase |
System.String | test_class |
System.String | fixed_in |
System.String | user_name |
System.String | cr_date |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

move_cr(String, String)

Declaration
short move_cr(string cr_id, string new_wipbin)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | new_wipbin |
Returns
Type | Description
System.Int16 |

reject_cr(String, String, String, String, String, Boolean)

Declaration
short reject_cr(string cr_id, string reject_date, string wipbin, string notes, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | reject_date |
System.String | wipbin |
System.String | notes |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

reopen_cr(String, String, String, String, String, Boolean)

Declaration
short reopen_cr(string cr_id, string the_status, string wipbin, string user_name, string reopen_date, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | the_status |
System.String | wipbin |
System.String | user_name |
System.String | reopen_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

replicate_cr(String, String, String, Boolean)

Declaration
short replicate_cr(string cr_id, string user_name, string rep_date, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | user_name |
System.String | rep_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

yank_cr(String, String, String, String, Boolean)

Declaration
short yank_cr(string cr_id, string wipbin, string yank_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | wipbin |
System.String | yank_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |


Interface IFCCS | fcSDK Documentation

Interface IFCCS

Namespace: FChoice.Foundation.Clarify.Compatibility.Toolkits
Assembly: FChoice.Foundation.Clarify.Compatibility.Toolkits.dll
Syntax
[Guid("C13AAB7B-E3BE-4387-84A4-86F78D119D6A")]
[ComVisible(true)]
public interface IFCCS

Properties

impersonatorUserName

Declaration
string impersonatorUserName { get; set; }
Property Value
Type | Description
System.String |

ret_id_num

Declaration
string ret_id_num { get; }
Property Value
Type | Description
System.String |

ret_objid

Declaration
int ret_objid { get; }
Property Value
Type | Description
System.Int32 |

ret_objid2

Declaration
int ret_objid2 { get; }
Property Value
Type | Description
System.Int32 |

ret_objid3

Declaration
int ret_objid3 { get; }
Property Value
Type | Description
System.Int32 |

UseDenormalizedCaseTypeLevels

Declaration
bool UseDenormalizedCaseTypeLevels { get; set; }
Property Value
Type | Description
System.Boolean |

Methods

accept_case(String, String, String, String, Boolean)

Declaration
short accept_case(string case_id, string accept_date, string wipbin_name, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | case_id |
System.String | accept_date |
System.String | wipbin_name |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

accept_subcase(String, String, String, String, Boolean)

Declaration
short accept_subcase(string subcase_id, string accept_date, string wipbin_name, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | accept_date |
System.String | wipbin_name |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

assign_case(String, String, String, String, String, Boolean)

Declaration
short assign_case(string case_id, string new_user, string wipbin_name, string assign_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | case_id |
System.String | new_user |
System.String | wipbin_name |
System.String | assign_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

assign_subcase(String, String, String, String, String, Boolean)

Declaration
short assign_subcase(string subcase_id, string new_user, string wipbin_name, string assign_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | new_user |
System.String | wipbin_name |
System.String | assign_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

change_case_status(String, String, String, String, String, Boolean)

Declaration
short change_case_status(string case_id, string new_status, string change_date, string note_str, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | case_id |
System.String | new_status |
System.String | change_date |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

change_contact(String, String, String, String, String, String, String, Boolean)

Declaration
short change_contact(string case_id, string f_name, string l_name, string phone_num, string site_id, string change_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | case_id |
System.String | f_name |
System.String | l_name |
System.String | phone_num |
System.String | site_id |
System.String | change_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

change_subcase_status(String, String, String, String, String, Boolean)

Declaration
short change_subcase_status(string subcase_id, string new_status, string change_date, string note_str, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | new_status |
System.String | change_date |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

close_case(String, String, String, String, String, String, Double, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short close_case(string case_id, string the_status, string resolution_str, string summary_str, string user_name, string close_date, double units_used, string close_sums, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | case_id |
System.String | the_status |
System.String | resolution_str |
System.String | summary_str |
System.String | user_name |
System.String | close_date |
System.Double | units_used |
System.String | close_sums |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

close_case_list(String, String, String, String, String, String, Double, String, Boolean, IFCList, IFCList, IFCList)

Declaration
short close_case_list(string case_id, string the_status, string resolution_str, string summary_str, string user_name, string close_date, double units_used, string close_sums, bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | case_id |
System.String | the_status |
System.String | resolution_str |
System.String | summary_str |
System.String | user_name |
System.String | close_date |
System.Double | units_used |
System.String | close_sums |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

close_subcase(String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short close_subcase(string subcase_id, string the_status, string resolution_str, string summary_str, string user_name, string close_date, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | the_status |
System.String | resolution_str |
System.String | summary_str |
System.String | user_name |
System.String | close_date |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

close_subcase_list(String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
short close_subcase_list(string subcase_id, string the_status, string resolution_str, string summary_str, string user_name, string close_date, bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | the_status |
System.String | resolution_str |
System.String | summary_str |
System.String | user_name |
System.String | close_date |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

create_case(String, String, String, String, String, String, String, String, Int32, String, String, String, String, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short create_case(string site_id, string f_name, string l_name, string phone_num, string part_num, string mod_level, string domain_name, string serial_no, int sp_objid, string contract_id, string the_title, string case_type, string priority_str, string severity_str, string status_str, string phone_log, string queue_name, string cr_date, string phone_end_date, string user_name, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | site_id |
System.String | f_name |
System.String | l_name |
System.String | phone_num |
System.String | part_num |
System.String | mod_level |
System.String | domain_name |
System.String | serial_no |
System.Int32 | sp_objid |
System.String | contract_id |
System.String | the_title |
System.String | case_type |
System.String | priority_str |
System.String | severity_str |
System.String | status_str |
System.String | phone_log |
System.String | queue_name |
System.String | cr_date |
System.String | phone_end_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

create_case_list(String, String, String, String, String, String, String, String, Int32, String, String, String, String, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
short create_case_list(string site_id, string f_name, string l_name, string phone_num, string part_num, string mod_level, string domain_name, string serial_no, int sp_objid, string contract_id, string the_title, string case_type, string priority_str, string severity_str, string status_str, string phone_log, string queue_name, string cr_date, string phone_end_date, string user_name, bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | site_id |
System.String | f_name |
System.String | l_name |
System.String | phone_num |
System.String | part_num |
System.String | mod_level |
System.String | domain_name |
System.String | serial_no |
System.Int32 | sp_objid |
System.String | contract_id |
System.String | the_title |
System.String | case_type |
System.String | priority_str |
System.String | severity_str |
System.String | status_str |
System.String | phone_log |
System.String | queue_name |
System.String | cr_date |
System.String | phone_end_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

create_case_objid(String, String, String, Int32, String, String, String, String, String, String, String, String, String, String, Boolean, Int32, Int32, Int32, Int32, Int32, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short create_case_objid(string f_name, string l_name, string phone_num, int sp_objid, string the_title, string case_type, string priority_str, string severity_str, string status_str, string phone_log, string queue_name, string cr_date, string phone_end_date, string user_name, bool gen_time_bombs, int contact_objid, int site_objid, int ml_objid, int contract_objid, int addr_objid, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | f_name |
System.String | l_name |
System.String | phone_num |
System.Int32 | sp_objid |
System.String | the_title |
System.String | case_type |
System.String | priority_str |
System.String | severity_str |
System.String | status_str |
System.String | phone_log |
System.String | queue_name |
System.String | cr_date |
System.String | phone_end_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.Int32 | contact_objid |
System.Int32 | site_objid |
System.Int32 | ml_objid |
System.Int32 | contract_objid |
System.Int32 | addr_objid |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

create_case_objid_list(String, String, String, Int32, String, String, String, String, String, String, String, String, String, String, Boolean, Int32, Int32, Int32, Int32, Int32, IFCList, IFCList, IFCList)

Declaration
short create_case_objid_list(string f_name, string l_name, string phone_num, int sp_objid, string the_title, string case_type, string priority_str, string severity_str, string status_str, string phone_log, string queue_name, string cr_date, string phone_end_date, string user_name, bool gen_time_bombs, int contact_objid, int site_objid, int ml_objid, int contract_objid, int addr_objid, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | f_name |
System.String | l_name |
System.String | phone_num |
System.Int32 | sp_objid |
System.String | the_title |
System.String | case_type |
System.String | priority_str |
System.String | severity_str |
System.String | status_str |
System.String | phone_log |
System.String | queue_name |
System.String | cr_date |
System.String | phone_end_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.Int32 | contact_objid |
System.Int32 | site_objid |
System.Int32 | ml_objid |
System.Int32 | contract_objid |
System.Int32 | addr_objid |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

create_subcase(String, String, Boolean, String, String, String, String, String, String, String, Int32, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short create_subcase(string case_id, string the_title, bool is_general, string priority_str, string severity_str, string status_str, string note_str, string queue_name, string cr_date, string due_date, int prior_warn, string user_name, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | case_id |
System.String | the_title |
System.Boolean | is_general |
System.String | priority_str |
System.String | severity_str |
System.String | status_str |
System.String | note_str |
System.String | queue_name |
System.String | cr_date |
System.String | due_date |
System.Int32 | prior_warn |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

create_subcase_list(String, String, Boolean, String, String, String, String, String, String, String, Int32, String, Boolean, IFCList, IFCList, IFCList)

Declaration
short create_subcase_list(string case_id, string the_title, bool is_general, string priority_str, string severity_str, string status_str, string note_str, string queue_name, string cr_date, string due_date, int prior_warn, string user_name, bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | case_id |
System.String | the_title |
System.Boolean | is_general |
System.String | priority_str |
System.String | severity_str |
System.String | status_str |
System.String | note_str |
System.String | queue_name |
System.String | cr_date |
System.String | due_date |
System.Int32 | prior_warn |
System.String | user_name |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

dispatch_case(String, String, String, String, Boolean)

Declaration
short dispatch_case(string case_id, string queue_name, string disp_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | case_id |
System.String | queue_name |
System.String | disp_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

dispatch_subcase(String, String, String, String, Boolean)

Declaration
short dispatch_subcase(string subcase_id, string queue_name, string disp_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | queue_name |
System.String | disp_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

forward_case(String, String, String, String, String, Boolean)

Declaration
short forward_case(string case_id, string new_queue, string forward_date, string note_str, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | case_id |
System.String | new_queue |
System.String | forward_date |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

forward_subcase(String, String, String, String, String, Boolean)

Declaration
short forward_subcase(string subcase_id, string new_queue, string forward_date, string note_str, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | new_queue |
System.String | forward_date |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

fulfill_commitment(Int32, String, String, Boolean)

Declaration
short fulfill_commitment(int log_objid, string fulfill_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.Int32 | log_objid |
System.String | fulfill_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

initial_response(String, String, String, Boolean, Boolean)

Declaration
short initial_response(string case_id, string resp_date, string user_name, bool via_phone, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | case_id |
System.String | resp_date |
System.String | user_name |
System.Boolean | via_phone |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

Initialize(IFCApplication, IFCSession)

Declaration
void Initialize(IFCApplication FCApp, IFCSession FCSess)
Parameters
Type | Name | Description
IFCApplication | FCApp |
IFCSession | FCSess |

log_case_commit(String, String, String, String, String, Int32, Boolean, String, String, String, String, String, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short log_case_commit(string case_id, string the_title, string action_type, string log_date, string commit_date, int prior_warn, bool made_to, string cont_first, string cont_last, string cont_phone, string note_str, string user_name, bool gen_time_bombs, bool generate_commit_email, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | case_id |
System.String | the_title |
System.String | action_type |
System.String | log_date |
System.String | commit_date |
System.Int32 | prior_warn |
System.Boolean | made_to |
System.String | cont_first |
System.String | cont_last |
System.String | cont_phone |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.Boolean | generate_commit_email |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

log_case_commit_list(String, String, String, String, String, Int32, Boolean, String, String, String, String, String, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
short log_case_commit_list(string case_id, string the_title, string action_type, string log_date, string commit_date, int prior_warn, bool made_to, string cont_first, string cont_last, string cont_phone, string note_str, string user_name, bool gen_time_bombs, bool generate_commit_email, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | case_id |
System.String | the_title |
System.String | action_type |
System.String | log_date |
System.String | commit_date |
System.Int32 | prior_warn |
System.Boolean | made_to |
System.String | cont_first |
System.String | cont_last |
System.String | cont_phone |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.Boolean | generate_commit_email |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

log_case_email(String, String, String, String, String, String, String, String, String, String, String, Int32, Boolean, String, Int32, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short log_case_email(string case_id, string action_type, string log_date, string message, string recipient, string cc_list, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, string cmit_action_type, int cmit_contact_objid, bool gen_time_bombs, bool send_email, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | case_id |
System.String | action_type |
System.String | log_date |
System.String | message |
System.String | recipient |
System.String | cc_list |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.String | cmit_action_type |
System.Int32 | cmit_contact_objid |
System.Boolean | gen_time_bombs |
System.Boolean | send_email |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

log_case_email_list(String, String, String, String, String, String, String, String, String, String, String, Int32, Boolean, String, Int32, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
short log_case_email_list(string case_id, string action_type, string log_date, string message, string recipient, string cc_list, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, string cmit_action_type, int cmit_contact_objid, bool gen_time_bombs, bool send_email, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | case_id |
System.String | action_type |
System.String | log_date |
System.String | message |
System.String | recipient |
System.String | cc_list |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.String | cmit_action_type |
System.Int32 | cmit_contact_objid |
System.Boolean | gen_time_bombs |
System.Boolean | send_email |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

log_case_note(String, String, String, String, String, String, String, String, String, String, Int32, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short log_case_note(string case_id, string action_type, string note_str, string int_use, string log_date, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | case_id |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

log_case_note_list(String, String, String, String, String, String, String, String, String, String, Int32, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
short log_case_note_list(string case_id, string action_type, string note_str, string int_use, string log_date, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | case_id |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

log_case_phone(String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int32, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short log_case_phone(string case_id, string cont_first, string cont_last, string cont_phone, string action_type, string note_str, string int_use, string log_date, string log_end_date, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | case_id |
System.String | cont_first |
System.String | cont_last |
System.String | cont_phone |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.String | log_end_date |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

log_case_phone_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int32, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
short log_case_phone_list(string case_id, string cont_first, string cont_last, string cont_phone, string action_type, string note_str, string int_use, string log_date, string log_end_date, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | case_id |
System.String | cont_first |
System.String | cont_last |
System.String | cont_phone |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.String | log_end_date |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

log_case_resrch(String, String, String, String, String, Int32, String, String, String, String, String, Int32, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short log_case_resrch(string case_id, string action_type, string note_str, string int_use, string log_date, int research_time, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | case_id |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.Int32 | research_time |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

log_case_resrch_list(String, String, String, String, String, Int32, String, String, String, String, String, Int32, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
short log_case_resrch_list(string case_id, string action_type, string note_str, string int_use, string log_date, int research_time, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | case_id |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.Int32 | research_time |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

log_subcase_commit(String, String, String, String, String, Int32, Boolean, String, String, String, String, String, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short log_subcase_commit(string subcase_id, string the_title, string action_type, string log_date, string commit_date, int prior_warn, bool made_to, string cont_first, string cont_last, string cont_phone, string note_str, string user_name, bool gen_time_bombs, bool generate_commit_email, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | the_title |
System.String | action_type |
System.String | log_date |
System.String | commit_date |
System.Int32 | prior_warn |
System.Boolean | made_to |
System.String | cont_first |
System.String | cont_last |
System.String | cont_phone |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.Boolean | generate_commit_email |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

log_subcase_commit_list(String, String, String, String, String, Int32, Boolean, String, String, String, String, String, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
short log_subcase_commit_list(string subcase_id, string the_title, string action_type, string log_date, string commit_date, int prior_warn, bool made_to, string cont_first, string cont_last, string cont_phone, string note_str, string user_name, bool gen_time_bombs, bool generate_commit_email, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | the_title |
System.String | action_type |
System.String | log_date |
System.String | commit_date |
System.Int32 | prior_warn |
System.Boolean | made_to |
System.String | cont_first |
System.String | cont_last |
System.String | cont_phone |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.Boolean | generate_commit_email |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

log_subcase_email(String, String, String, String, String, String, String, String, String, String, String, Int32, Boolean, String, Int32, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short log_subcase_email(string case_id, string action_type, string log_date, string message, string recipient, string cc_list, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, string cmit_action_type, int cmit_contact_objid, bool gen_time_bombs, bool send_email, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | case_id |
System.String | action_type |
System.String | log_date |
System.String | message |
System.String | recipient |
System.String | cc_list |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.String | cmit_action_type |
System.Int32 | cmit_contact_objid |
System.Boolean | gen_time_bombs |
System.Boolean | send_email |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

log_subcase_email_list(String, String, String, String, String, String, String, String, String, String, String, Int32, Boolean, String, Int32, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
short log_subcase_email_list(string case_id, string action_type, string log_date, string message, string recipient, string cc_list, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, string cmit_action_type, int cmit_contact_objid, bool gen_time_bombs, bool send_email, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | case_id |
System.String | action_type |
System.String | log_date |
System.String | message |
System.String | recipient |
System.String | cc_list |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.String | cmit_action_type |
System.Int32 | cmit_contact_objid |
System.Boolean | gen_time_bombs |
System.Boolean | send_email |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

log_subcase_note(String, String, String, String, String, String, String, String, String, String, Int32, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short log_subcase_note(string subcase_id, string action_type, string note_str, string int_use, string log_date, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

log_subcase_note_list(String, String, String, String, String, String, String, String, String, String, Int32, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
short log_subcase_note_list(string subcase_id, string action_type, string note_str, string int_use, string log_date, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

log_subcase_phone(String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int32, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short log_subcase_phone(string subcase_id, string cont_first, string cont_last, string cont_phone, string action_type, string note_str, string int_use, string log_date, string log_end_date, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | cont_first |
System.String | cont_last |
System.String | cont_phone |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.String | log_end_date |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

log_subcase_phone_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int32, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
short log_subcase_phone_list(string subcase_id, string cont_first, string cont_last, string cont_phone, string action_type, string note_str, string int_use, string log_date, string log_end_date, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | cont_first |
System.String | cont_last |
System.String | cont_phone |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.String | log_end_date |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

log_subcase_resrch(String, String, String, String, String, Int32, String, String, String, String, String, Int32, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short log_subcase_resrch(string subcase_id, string action_type, string note_str, string int_use, string log_date, int research_time, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.Int32 | research_time |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

log_subcase_resrch_list(String, String, String, String, String, Int32, String, String, String, String, String, Int32, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
short log_subcase_resrch_list(string subcase_id, string action_type, string note_str, string int_use, string log_date, int research_time, string user_name, string new_stat, string cmit_title, string cmit_notes, string cmit_due, int cmit_prior, bool cmit_to, bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | action_type |
System.String | note_str |
System.String | int_use |
System.String | log_date |
System.Int32 | research_time |
System.String | user_name |
System.String | new_stat |
System.String | cmit_title |
System.String | cmit_notes |
System.String | cmit_due |
System.Int32 | cmit_prior |
System.Boolean | cmit_to |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

modify_case(String, String, String, String, String, String, Boolean, Boolean, String, Int32, Int32, Int32, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short modify_case(string case_id, string priority_str, string severity_str, string case_type, string user_name, string mod_date, bool only_owner, bool gen_time_bombs, string the_title, int ml_obj, int sp_obj, int contr_obj, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | case_id |
System.String | priority_str |
System.String | severity_str |
System.String | case_type |
System.String | user_name |
System.String | mod_date |
System.Boolean | only_owner |
System.Boolean | gen_time_bombs |
System.String | the_title |
System.Int32 | ml_obj |
System.Int32 | sp_obj |
System.Int32 | contr_obj |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

modify_case_commit(String, String, String, String, Int32, Int32, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short modify_case_commit(string case_id_num, string the_title, string action_type, string commit_date, int commit_objid, int prior_warn, string made_to_str, string cont_first, string cont_last, string cont_phone, string note_str, string mod_date, string user_name, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | case_id_num |
System.String | the_title |
System.String | action_type |
System.String | commit_date |
System.Int32 | commit_objid |
System.Int32 | prior_warn |
System.String | made_to_str |
System.String | cont_first |
System.String | cont_last |
System.String | cont_phone |
System.String | note_str |
System.String | mod_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

modify_case_commit_list(String, String, String, String, Int32, Int32, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
short modify_case_commit_list(string case_id_num, string the_title, string action_type, string commit_date, int commit_objid, int prior_warn, string made_to_str, string cont_first, string cont_last, string cont_phone, string note_str, string mod_date, string user_name, bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | case_id_num |
System.String | the_title |
System.String | action_type |
System.String | commit_date |
System.Int32 | commit_objid |
System.Int32 | prior_warn |
System.String | made_to_str |
System.String | cont_first |
System.String | cont_last |
System.String | cont_phone |
System.String | note_str |
System.String | mod_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

modify_case_list(String, String, String, String, String, String, Boolean, Boolean, String, Int32, Int32, Int32, IFCList, IFCList, IFCList)

Declaration
short modify_case_list(string case_id, string priority_str, string severity_str, string case_type, string user_name, string mod_date, bool only_owner, bool gen_time_bombs, string the_title, int ml_obj, int sp_obj, int contr_obj, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | case_id |
System.String | priority_str |
System.String | severity_str |
System.String | case_type |
System.String | user_name |
System.String | mod_date |
System.Boolean | only_owner |
System.Boolean | gen_time_bombs |
System.String | the_title |
System.Int32 | ml_obj |
System.Int32 | sp_obj |
System.Int32 | contr_obj |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

modify_case_list_setup(String, String, String, String, String, String, Boolean, Boolean, Boolean, String, Int32, Int32, Int32, IFCList, IFCList, IFCList)

Declaration
short modify_case_list_setup(string case_id, string priority_str, string severity_str, string case_type, string user_name, string mod_date, bool only_owner, bool only_open, bool gen_time_bombs, string the_title, int ml_obj, int sp_obj, int contr_obj, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | case_id |
System.String | priority_str |
System.String | severity_str |
System.String | case_type |
System.String | user_name |
System.String | mod_date |
System.Boolean | only_owner |
System.Boolean | only_open |
System.Boolean | gen_time_bombs |
System.String | the_title |
System.Int32 | ml_obj |
System.Int32 | sp_obj |
System.Int32 | contr_obj |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

modify_subcase(String, String, String, String, String, Boolean, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short modify_subcase(string subcase_id, string priority_str, string severity_str, string user_name, string mod_date, bool only_owner, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | priority_str |
System.String | severity_str |
System.String | user_name |
System.String | mod_date |
System.Boolean | only_owner |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

modify_subcase_commit(String, String, String, String, Int32, Int32, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short modify_subcase_commit(string subcase_id_num, string the_title, string action_type, string commit_date, int commit_objid, int prior_warn, string made_to_str, string cont_first, string cont_last, string cont_phone, string note_str, string mod_date, string user_name, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | subcase_id_num |
System.String | the_title |
System.String | action_type |
System.String | commit_date |
System.Int32 | commit_objid |
System.Int32 | prior_warn |
System.String | made_to_str |
System.String | cont_first |
System.String | cont_last |
System.String | cont_phone |
System.String | note_str |
System.String | mod_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

modify_subcase_commit_list(String, String, String, String, Int32, Int32, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
short modify_subcase_commit_list(string subcase_id_num, string the_title, string action_type, string commit_date, int commit_objid, int prior_warn, string made_to_str, string cont_first, string cont_last, string cont_phone, string note_str, string mod_date, string user_name, bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | subcase_id_num |
System.String | the_title |
System.String | action_type |
System.String | commit_date |
System.Int32 | commit_objid |
System.Int32 | prior_warn |
System.String | made_to_str |
System.String | cont_first |
System.String | cont_last |
System.String | cont_phone |
System.String | note_str |
System.String | mod_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

modify_subcase_list(String, String, String, String, String, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
short modify_subcase_list(string subcase_id, string priority_str, string severity_str, string user_name, string mod_date, bool only_owner, bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | priority_str |
System.String | severity_str |
System.String | user_name |
System.String | mod_date |
System.Boolean | only_owner |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

modify_subcase_list_setup(String, String, String, String, String, Boolean, Boolean, Boolean, IFCList, IFCList, IFCList)

Declaration
short modify_subcase_list_setup(string subcase_id, string priority_str, string severity_str, string user_name, string mod_date, bool only_owner, bool only_open, bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | priority_str |
System.String | severity_str |
System.String | user_name |
System.String | mod_date |
System.Boolean | only_owner |
System.Boolean | only_open |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

move_case(String, String)

Declaration
short move_case(string case_id, string new_wipbin)
Parameters
Type | Name | Description
System.String | case_id |
System.String | new_wipbin |
Returns
Type | Description
System.Int16 |

move_subcase(String, String)

Declaration
short move_subcase(string subcase_id, string new_wipbin)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | new_wipbin |
Returns
Type | Description
System.Int16 |

preclose_case(String)

Declaration
short preclose_case(string case_id)
Parameters
Type | Name | Description
System.String | case_id |
Returns
Type | Description
System.Int16 |

preclose_subcase(String)

Declaration
short preclose_subcase(string subcase_id)
Parameters
Type | Name | Description
System.String | subcase_id |
Returns
Type | Description
System.Int16 |

reject_case(String, String, String, String, String, Boolean)

Declaration
short reject_case(string case_id, string reject_date, string wipbin_name, string note_str, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | case_id |
System.String | reject_date |
System.String | wipbin_name |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

reject_subcase(String, String, String, String, String, Boolean)

Declaration
short reject_subcase(string subcase_id, string reject_date, string wipbin_name, string note_str, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | reject_date |
System.String | wipbin_name |
System.String | note_str |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

relate_case_to_parent(String, String)

Declaration
short relate_case_to_parent(string case_id, string parent_id)
Parameters
Type | Name | Description
System.String | case_id |
System.String | parent_id |
Returns
Type | Description
System.Int16 |

reopen_case(String, String, String, String, String, Boolean)

Declaration
short reopen_case(string case_id, string wipbin_name, string status_str, string reopen_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | case_id |
System.String | wipbin_name |
System.String | status_str |
System.String | reopen_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

reopen_subcase(String, String, String, String, String, Boolean)

Declaration
short reopen_subcase(string subcase_id, string wipbin_name, string status_str, string reopen_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | wipbin_name |
System.String | status_str |
System.String | reopen_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

unrelate_case_from_parent(String)

Declaration
short unrelate_case_from_parent(string case_id)
Parameters
Type | Name | Description
System.String | case_id |
Returns
Type | Description
System.Int16 |

yank_case(String, String, String, String, Boolean)

Declaration
short yank_case(string case_id, string wipbin_name, string yank_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | case_id |
System.String | wipbin_name |
System.String | yank_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

yank_subcase(String, String, String, String, Boolean)

Declaration
short yank_subcase(string subcase_id, string wipbin_name, string yank_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | subcase_id |
System.String | wipbin_name |
System.String | yank_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |


Interface IFCDR | fcSDK Documentation

Interface IFCDR

Namespace: FChoice.Foundation.Clarify.Compatibility.Toolkits
Assembly: FChoice.Foundation.Clarify.Compatibility.Toolkits.dll
Syntax
[Guid("6B68AF21-47DD-45c4-8D85-374B238584EF")]
[ComVisible(true)]
public interface IFCDR

Properties

impersonatorUserName

Declaration
string impersonatorUserName { get; set; }
Property Value
Type | Description
System.String |

ret_id_num

Declaration
string ret_id_num { get; }
Property Value
Type | Description
System.String |

ret_objid

Declaration
int ret_objid { get; }
Property Value
Type | Description
System.Int32 |

Methods

apply_eco(Int32, String, String, String)

Declaration
short apply_eco(int demand_dtl_objid, string eco_code, string perf_by, string creation_time)
Parameters
Type | Name | Description
System.Int32 | demand_dtl_objid |
System.String | eco_code |
System.String | perf_by |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

create_dr_labor(Int32, String, String, Int32, Int16, String, String, Double, String, String)

Declaration
short create_dr_labor(int demand_dtl_objid, string labor_type, string start_time, int duration, short billable, string bill_to, string wrk_center, double tl_rate, string perf_by, string creation_time)
Parameters
Type | Name | Description
System.Int32 | demand_dtl_objid |
System.String | labor_type |
System.String | start_time |
System.Int32 | duration |
System.Int16 | billable |
System.String | bill_to |
System.String | wrk_center |
System.Double | tl_rate |
System.String | perf_by |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

create_dr_mtl(Int32, String, String, Int32, Int16, String, String, Int16, String, String, String, String, String)

Declaration
short create_dr_mtl(int demand_dtl_objid, string repair_code, string failure_code, int mod_level, short billable, string bill_to, string wrk_center, short disposition, string ref_designator, string notes, string transaction_id, string perf_by, string creation_time)
Parameters
Type | Name | Description
System.Int32 | demand_dtl_objid |
System.String | repair_code |
System.String | failure_code |
System.Int32 | mod_level |
System.Int16 | billable |
System.String | bill_to |
System.String | wrk_center |
System.Int16 | disposition |
System.String | ref_designator |
System.String | notes |
System.String | transaction_id |
System.String | perf_by |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

create_eco_dtl(String, Int32, String, String, Int32, String, String, String, Int32)

Declaration
short create_eco_dtl(string detail_type, int required, string status, string labor_type, int elapsed_time, string location, string description, string eco_hdr_code, int mod_level_objid)
Parameters
Type | Name | Description
System.String | detail_type |
System.Int32 | required |
System.String | status |
System.String | labor_type |
System.Int32 | elapsed_time |
System.String | location |
System.String | description |
System.String | eco_hdr_code |
System.Int32 | mod_level_objid |
Returns
Type | Description
System.Int16 |

create_eco_hdr(String, String, String, String, String, String, String, String)

Declaration
short create_eco_hdr(string eco_title, string eco_type, string create_date, string eff_type, string start_date, string end_date, string status, string description)
Parameters
Type | Name | Description
System.String | eco_title |
System.String | eco_type |
System.String | create_date |
System.String | eff_type |
System.String | start_date |
System.String | end_date |
System.String | status |
System.String | description |
Returns
Type | Description
System.Int16 |

create_eco_item(Int32, Int32, String, Int32, Int32)

Declaration
short create_eco_item(int focus_type, int active, string eco_hdr_code, int apply_mod_level, int result_mod_level)
Parameters
Type | Name | Description
System.Int32 | focus_type |
System.Int32 | active |
System.String | eco_hdr_code |
System.Int32 | apply_mod_level |
System.Int32 | result_mod_level |
Returns
Type | Description
System.Int16 |

delete_dr_labor(Int32, String)

Declaration
short delete_dr_labor(int time_log_objid, string creation_time)
Parameters
Type | Name | Description
System.Int32 | time_log_objid |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

delete_dr_mtl(Int32, String)

Declaration
short delete_dr_mtl(int mtl_log_objid, string creation_time)
Parameters
Type | Name | Description
System.Int32 | mtl_log_objid |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

delete_eco_dtl(Int32)

Declaration
short delete_eco_dtl(int eco_dtl_objid)
Parameters
Type | Name | Description
System.Int32 | eco_dtl_objid |
Returns
Type | Description
System.Int16 |

delete_eco_item(Int32)

Declaration
short delete_eco_item(int eco_item_objid)
Parameters
Type | Name | Description
System.Int32 | eco_item_objid |
Returns
Type | Description
System.Int16 |

Initialize(IFCApplication, IFCSession)

Declaration
void Initialize(IFCApplication FCApp, IFCSession FCSess)
Parameters
Type | Name | Description
IFCApplication | FCApp |
IFCSession | FCSess |

modify_dr_labor(Int32, String, String, Int32, Int16, String, String, Double, String, String)

Declaration
short modify_dr_labor(int time_log_objid, string labor_type, string start_time, int duration, short billable, string bill_to, string wrk_center, double tl_rate, string perf_by, string creation_time)
Parameters
Type | Name | Description
System.Int32 | time_log_objid |
System.String | labor_type |
System.String | start_time |
System.Int32 | duration |
System.Int16 | billable |
System.String | bill_to |
System.String | wrk_center |
System.Double | tl_rate |
System.String | perf_by |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

modify_dr_mtl(Int32, String, String, Int32, Int16, String, String, Int16, String, String, String, String, String)

Declaration
short modify_dr_mtl(int mtl_log_objid, string repair_code, string failure_code, int mod_level, short billable, string bill_to, string wrk_center, short disposition, string ref_designator, string notes, string transaction_id, string perf_by, string creation_time)
Parameters
Type | Name | Description
System.Int32 | mtl_log_objid |
System.String | repair_code |
System.String | failure_code |
System.Int32 | mod_level |
System.Int16 | billable |
System.String | bill_to |
System.String | wrk_center |
System.Int16 | disposition |
System.String | ref_designator |
System.String | notes |
System.String | transaction_id |
System.String | perf_by |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

modify_eco_dtl(Int32, String, Int32, String, String, Int32, String, String, String, Int32)

Declaration
short modify_eco_dtl(int eco_dtl_objid, string detail_type, int required, string status, string labor_type, int elapsed_time, string location, string description, string eco_hdr_code, int mod_level_objid)
Parameters
Type | Name | Description
System.Int32 | eco_dtl_objid |
System.String | detail_type |
System.Int32 | required |
System.String | status |
System.String | labor_type |
System.Int32 | elapsed_time |
System.String | location |
System.String | description |
System.String | eco_hdr_code |
System.Int32 | mod_level_objid |
Returns
Type | Description
System.Int16 |

modify_eco_item(Int32, Int32, Int32, String, Int32, Int32)

Declaration
short modify_eco_item(int eco_mod_role_objid, int focus_type, int active, string eco_hdr_code, int applies_to_mod, int results_in_mod)
Parameters
Type | Name | Description
System.Int32 | eco_mod_role_objid |
System.Int32 | focus_type |
System.Int32 | active |
System.String | eco_hdr_code |
System.Int32 | applies_to_mod |
System.Int32 | results_in_mod |
Returns
Type | Description
System.Int16 |


Interface IFCFO | fcSDK Documentation

Interface IFCFO

Namespace: FChoice.Foundation.Clarify.Compatibility.Toolkits
Assembly: FChoice.Foundation.Clarify.Compatibility.Toolkits.dll
Syntax
[Guid("53BEA621-C158-448b-B9F9-33B3A18084E8")]
[ComVisible(true)]
public interface IFCFO

Properties

impersonatorUserName

Declaration
string impersonatorUserName { get; set; }
Property Value
Type | Description
System.String |

ret_id_num

Declaration
string ret_id_num { get; }
Property Value
Type | Description
System.String |

ret_objid

Declaration
int ret_objid { get; }
Property Value
Type | Description
System.Int32 |

ret_objid2

Declaration
int ret_objid2 { get; }
Property Value
Type | Description
System.Int32 |

ret_string

Declaration
string ret_string { get; }
Property Value
Type | Description
System.String |

Methods

add_svc_inter(String, Int32, String, String, String, Int32, String, String, String, String)

Declaration
short add_svc_inter(string case_id, int sp_objid, string description, string start_time, string end_time, int duration, string svc_class, string svc_type, string user_name, string creation_time)
Parameters
Type | Name | Description
System.String | case_id |
System.Int32 | sp_objid |
System.String | description |
System.String | start_time |
System.String | end_time |
System.Int32 | duration |
System.String | svc_class |
System.String | svc_type |
System.String | user_name |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

create_expense_log(Int32, String, String, String, String, String, String, Double, Double, Int32, String, String)

Declaration
short create_expense_log(int onsite_objid, string id_num, string creation_time, string notes, string perf_by, string user_name, string expense_type, double quantity, double the_rate, int billable, string bill_to, string resolution)
Parameters
Type | Name | Description
System.Int32 | onsite_objid |
System.String | id_num |
System.String | creation_time |
System.String | notes |
System.String | perf_by |
System.String | user_name |
System.String | expense_type |
System.Double | quantity |
System.Double | the_rate |
System.Int32 | billable |
System.String | bill_to |
System.String | resolution |
Returns
Type | Description
System.Int16 |

create_onsite_log(String, String, String, String, String, String, String, String)

Declaration
short create_onsite_log(string object_type, string object_id, string creation_time, string last_modified, string notes, string resolution, string user_name, string perf_by)
Parameters
Type | Name | Description
System.String | object_type |
System.String | object_id |
System.String | creation_time |
System.String | last_modified |
System.String | notes |
System.String | resolution |
System.String | user_name |
System.String | perf_by |
Returns
Type | Description
System.Int16 |

create_time_log(Int32, String, String, String, String, String, String, String, Int32, Int32, String, String, String)

Declaration
short create_time_log(int onsite_objid, string id_num, string creation_time, string notes, string perf_by, string user_name, string time_type, string start_time, int duration, int billable, string bill_to, string wrk_center, string resolution)
Parameters
Type | Name | Description
System.Int32 | onsite_objid |
System.String | id_num |
System.String | creation_time |
System.String | notes |
System.String | perf_by |
System.String | user_name |
System.String | time_type |
System.String | start_time |
System.Int32 | duration |
System.Int32 | billable |
System.String | bill_to |
System.String | wrk_center |
System.String | resolution |
Returns
Type | Description
System.Int16 |

deinstall_sp(Int32, String, String, Boolean)

Declaration
short deinstall_sp(int sp_objid, string user_name, string deinstall_date, bool use_remove)
Parameters
Type | Name | Description
System.Int32 | sp_objid |
System.String | user_name |
System.String | deinstall_date |
System.Boolean | use_remove |
Returns
Type | Description
System.Int16 |

delete_appt(Int32, String, String)

Declaration
short delete_appt(int appt_objid, string user_name, string creation_time)
Parameters
Type | Name | Description
System.Int32 | appt_objid |
System.String | user_name |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

delete_expense_log(Int32, String, String)

Declaration
short delete_expense_log(int expense_objid, string last_modified, string user_name)
Parameters
Type | Name | Description
System.Int32 | expense_objid |
System.String | last_modified |
System.String | user_name |
Returns
Type | Description
System.Int16 |

delete_onsite_log(Int32, String, String)

Declaration
short delete_onsite_log(int onsite_log_objid, string note_date, string user_name)
Parameters
Type | Name | Description
System.Int32 | onsite_log_objid |
System.String | note_date |
System.String | user_name |
Returns
Type | Description
System.Int16 |

delete_svc_inter(Int32, String, String)

Declaration
short delete_svc_inter(int appt_objid, string user_name, string creation_time)
Parameters
Type | Name | Description
System.Int32 | appt_objid |
System.String | user_name |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

delete_time_log(Int32, String, String)

Declaration
short delete_time_log(int time_objid, string last_modified, string user_name)
Parameters
Type | Name | Description
System.Int32 | time_objid |
System.String | last_modified |
System.String | user_name |
Returns
Type | Description
System.Int16 |

dispatch_fe(String, String, String, String, String, Int32, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int32, String, String, Int32, Boolean)

Declaration
short dispatch_fe(string case_id, string user_name, string dispatch_time, string work_order, string appointment_time, int duration, string description, string cont_fname, string cont_lname, string address1, string address2, string city, string state, string zipcode, string main_phone, string alt_phone, string site_id, string pay_method, string ref_number, string notes, string requested_eta, int appt_confirm, string cell_text, string proxy, int removed, bool gen_time_bomb)
Parameters
Type | Name | Description
System.String | case_id |
System.String | user_name |
System.String | dispatch_time |
System.String | work_order |
System.String | appointment_time |
System.Int32 | duration |
System.String | description |
System.String | cont_fname |
System.String | cont_lname |
System.String | address1 |
System.String | address2 |
System.String | city |
System.String | state |
System.String | zipcode |
System.String | main_phone |
System.String | alt_phone |
System.String | site_id |
System.String | pay_method |
System.String | ref_number |
System.String | notes |
System.String | requested_eta |
System.Int32 | appt_confirm |
System.String | cell_text |
System.String | proxy |
System.Int32 | removed |
System.Boolean | gen_time_bomb |
Returns
Type | Description
System.Int16 |

Initialize(IFCApplication, IFCSession)

Declaration
void Initialize(IFCApplication TheFCApplication, IFCSession TheFCSession)
Parameters
Type | Name | Description
IFCApplication | TheFCApplication |
IFCSession | TheFCSession |

install_sp(String, String, String, String, Int32, String, Int32, Int32, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short install_sp(string site_id, string part_num, string mod_level, string domain, int quantity, string serial_num, int parent_bin_objid, int parent_sp_objid, string instance_name, string comment, string part_status, string invoice_no, string user_name, string install_date, string ship_date, bool add_activity, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | site_id |
System.String | part_num |
System.String | mod_level |
System.String | domain |
System.Int32 | quantity |
System.String | serial_num |
System.Int32 | parent_bin_objid |
System.Int32 | parent_sp_objid |
System.String | instance_name |
System.String | comment |
System.String | part_status |
System.String | invoice_no |
System.String | user_name |
System.String | install_date |
System.String | ship_date |
System.Boolean | add_activity |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

install_sp_list(String, String, String, String, Int32, String, Int32, Int32, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
short install_sp_list(string site_id, string part_num, string mod_level, string domain, int quantity, string serial_num, int parent_bin_objid, int parent_sp_objid, string instance_name, string comment, string part_status, string invoice_no, string user_name, string install_date, string ship_date, bool add_activity, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | site_id |
System.String | part_num |
System.String | mod_level |
System.String | domain |
System.Int32 | quantity |
System.String | serial_num |
System.Int32 | parent_bin_objid |
System.Int32 | parent_sp_objid |
System.String | instance_name |
System.String | comment |
System.String | part_status |
System.String | invoice_no |
System.String | user_name |
System.String | install_date |
System.String | ship_date |
System.Boolean | add_activity |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

log_parts_used(String, String, String, Int32, Boolean, Int32, String, String, String, Boolean, String, String, String, String, String, Int32, String, String, String, String, Boolean, String, String, Boolean, String, Int32)

Declaration
short log_parts_used(string dtl_num, string case_id, string pu_type, int parent_sp, bool install_at_site, int remove_sp, string to_loc, string to_bin, string to_cont, bool to_good, string fail_code, string inst_part, string inst_rev, string inst_domain, string inst_serial, int inst_qty, string inst_price, string from_loc, string from_bin, string from_cont, bool from_good, string engineer_name, string user_name, bool allow_move, string log_date, int log_objid)
Parameters
Type | Name | Description
System.String | dtl_num |
System.String | case_id |
System.String | pu_type |
System.Int32 | parent_sp |
System.Boolean | install_at_site |
System.Int32 | remove_sp |
System.String | to_loc |
System.String | to_bin |
System.String | to_cont |
System.Boolean | to_good |
System.String | fail_code |
System.String | inst_part |
System.String | inst_rev |
System.String | inst_domain |
System.String | inst_serial |
System.Int32 | inst_qty |
System.String | inst_price |
System.String | from_loc |
System.String | from_bin |
System.String | from_cont |
System.Boolean | from_good |
System.String | engineer_name |
System.String | user_name |
System.Boolean | allow_move |
System.String | log_date |
System.Int32 | log_objid |
Returns
Type | Description
System.Int16 |

make_appt(String, String, String, Int32, String, String, String, Int32, String, String, String, String, String)

Declaration
short make_appt(string description, string start_time, string end_time, int duration, string cell_text, string emp_first, string emp_last, int site_part_objid, string appt_class, string appt_type, string case_id, string user_name, string creation_time)
Parameters
Type | Name | Description
System.String | description |
System.String | start_time |
System.String | end_time |
System.Int32 | duration |
System.String | cell_text |
System.String | emp_first |
System.String | emp_last |
System.Int32 | site_part_objid |
System.String | appt_class |
System.String | appt_type |
System.String | case_id |
System.String | user_name |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

modify_appt(Int32, String, String, Int32, String, String, String, String, String, String)

Declaration
short modify_appt(int appt_objid, string start_time, string end_time, int duration, string description, string cell_text, string appt_class, string appt_type, string user_name, string creation_time)
Parameters
Type | Name | Description
System.Int32 | appt_objid |
System.String | start_time |
System.String | end_time |
System.Int32 | duration |
System.String | description |
System.String | cell_text |
System.String | appt_class |
System.String | appt_type |
System.String | user_name |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

modify_expense_log(Int32, String, String, String, String, String, Double, Double, Int32, String, String)

Declaration
short modify_expense_log(int expense_log_objid, string creation_time, string perf_by, string notes, string user_name, string expense_type, double quantity, double the_rate, int billable, string bill_to, string resolution)
Parameters
Type | Name | Description
System.Int32 | expense_log_objid |
System.String | creation_time |
System.String | perf_by |
System.String | notes |
System.String | user_name |
System.String | expense_type |
System.Double | quantity |
System.Double | the_rate |
System.Int32 | billable |
System.String | bill_to |
System.String | resolution |
Returns
Type | Description
System.Int16 |

modify_sp(Int32, String, String, String, String, String, String, Int32, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short modify_sp(int sp_objid, string instance_name, string serial_num, string invoice_no, string ship_date, string install_date, string warranty_date, int quantity, string part_status, string comments, string service_end_dt, string user_name, string mod_level, bool add_activity, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.Int32 | sp_objid |
System.String | instance_name |
System.String | serial_num |
System.String | invoice_no |
System.String | ship_date |
System.String | install_date |
System.String | warranty_date |
System.Int32 | quantity |
System.String | part_status |
System.String | comments |
System.String | service_end_dt |
System.String | user_name |
System.String | mod_level |
System.Boolean | add_activity |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

modify_sp_list(Int32, String, String, String, String, String, String, Int32, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
short modify_sp_list(int sp_objid, string instance_name, string serial_num, string invoice_no, string ship_date, string install_date, string warranty_date, int quantity, string part_status, string comments, string service_end_dt, string user_name, string mod_level, bool add_activity, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.Int32 | sp_objid |
System.String | instance_name |
System.String | serial_num |
System.String | invoice_no |
System.String | ship_date |
System.String | install_date |
System.String | warranty_date |
System.Int32 | quantity |
System.String | part_status |
System.String | comments |
System.String | service_end_dt |
System.String | user_name |
System.String | mod_level |
System.Boolean | add_activity |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

modify_svc_inter(Int32, String, String, String, Int32, String, String, String, String)

Declaration
short modify_svc_inter(int appt_objid, string desc, string start_time, string end_time, int duration, string svc_class, string svc_type, string user_name, string creation_time)
Parameters
Type | Name | Description
System.Int32 | appt_objid |
System.String | desc |
System.String | start_time |
System.String | end_time |
System.Int32 | duration |
System.String | svc_class |
System.String | svc_type |
System.String | user_name |
System.String | creation_time |
Returns
Type | Description
System.Int16 |

modify_time_log(Int32, String, String, String, String, String, String, Int32, Int32, String, String, String)

Declaration
short modify_time_log(int time_log_objid, string creation_time, string perf_by, string notes, string user_name, string time_type, string start_time, int duration, int billable, string bill_to, string wrk_center, string resolution)
Parameters
Type | Name | Description
System.Int32 | time_log_objid |
System.String | creation_time |
System.String | perf_by |
System.String | notes |
System.String | user_name |
System.String | time_type |
System.String | start_time |
System.Int32 | duration |
System.Int32 | billable |
System.String | bill_to |
System.String | wrk_center |
System.String | resolution |
Returns
Type | Description
System.Int16 |

move_sp(Int32, String, Int32, String, Int32, Boolean, String, Boolean)

Declaration
short move_sp(int sp_objid, string move_date, int parent_sp_objid, string site_id, int parent_bin_objid, bool add_activity, string user_name, bool install_and_move)
Parameters
Type | Name | Description
System.Int32 | sp_objid |
System.String | move_date |
System.Int32 | parent_sp_objid |
System.String | site_id |
System.Int32 | parent_bin_objid |
System.Boolean | add_activity |
System.String | user_name |
System.Boolean | install_and_move |
Returns
Type | Description
System.Int16 |

part_transfer(String, String, String, Int32, String, String, String, String, Boolean, String, String, String, Boolean, String, String, String, String, Boolean, Int16, String, String, String, String)

Declaration
short part_transfer(string part_num, string mod_level, string domain_name, int quantity_num, string serial_num, string from_loc, string from_bin, string from_cont, bool from_good, string to_loc, string to_bin, string to_cont, bool to_good, string user_name, string trans_date, string ref_id, string note_str, bool gen_time_bombs, short fifo_flag, string update_cost, string update_source, string trans_id, string std_cost)
Parameters
Type | Name | Description
System.String | part_num |
System.String | mod_level |
System.String | domain_name |
System.Int32 | quantity_num |
System.String | serial_num |
System.String | from_loc |
System.String | from_bin |
System.String | from_cont |
System.Boolean | from_good |
System.String | to_loc |
System.String | to_bin |
System.String | to_cont |
System.Boolean | to_good |
System.String | user_name |
System.String | trans_date |
System.String | ref_id |
System.String | note_str |
System.Boolean | gen_time_bombs |
System.Int16 | fifo_flag |
System.String | update_cost |
System.String | update_source |
System.String | trans_id |
System.String | std_cost |
Returns
Type | Description
System.Int16 |

reinstall_sp(Int32, String, Int32, Int32, String, String, Boolean, Boolean)

Declaration
short reinstall_sp(int sp_objid, string site_id, int parent_bin_objid, int parent_sp_objid, string user_name, string reinst_date, bool add_activity, bool use_install)
Parameters
Type | Name | Description
System.Int32 | sp_objid |
System.String | site_id |
System.Int32 | parent_bin_objid |
System.Int32 | parent_sp_objid |
System.String | user_name |
System.String | reinst_date |
System.Boolean | add_activity |
System.Boolean | use_install |
Returns
Type | Description
System.Int16 |


Interface IFCINTER | fcSDK Documentation

Interface IFCINTER

Namespace: FChoice.Foundation.Clarify.Compatibility.Toolkits
Assembly: FChoice.Foundation.Clarify.Compatibility.Toolkits.dll
Syntax
[Guid("690BCCF2-8400-4724-8354-8AB700E4DC51")]
[ComVisible(true)]
public interface IFCINTER

Properties

allow_duplicate_contact

Declaration
bool allow_duplicate_contact { get; set; }
Property Value
Type | Description
System.Boolean |

impersonatorUserName

Declaration
string impersonatorUserName { get; set; }
Property Value
Type | Description
System.String |

ret_id_num

Declaration
string ret_id_num { get; }
Property Value
Type | Description
System.String |

ret_objid

Declaration
int ret_objid { get; }
Property Value
Type | Description
System.Int32 |

ret_objid2

Declaration
int ret_objid2 { get; }
Property Value
Type | Description
System.Int32 |

UseDatabaseLogins

Declaration
bool UseDatabaseLogins { get; set; }
Property Value
Type | Description
System.Boolean |

Methods

accept_solution(String, String, String, String, Boolean)

Declaration
short accept_solution(string solution_id, string accept_date, string wipbin, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | solution_id |
System.String | accept_date |
System.String | wipbin |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

add_contact_to_contract(String, String, String, String, String)

Declaration
short add_contact_to_contract(string contract_id, string f_name, string l_name, string phone_num, string site_id)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | f_name |
System.String | l_name |
System.String | phone_num |
System.String | site_id |
Returns
Type | Description
System.Int16 |

add_emp_to_bus_org(String, String, String)

Declaration
short add_emp_to_bus_org(string user_name, string acct_id, string role_name)
Parameters
Type | Name | Description
System.String | user_name |
System.String | acct_id |
System.String | role_name |
Returns
Type | Description
System.Int16 |

add_site_part_to_contract(String, String, Int32)

Declaration
short add_site_part_to_contract(string contract_id, string site_id, int sp_objid)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | site_id |
System.Int32 | sp_objid |
Returns
Type | Description
System.Int16 |

add_site_to_bus_org(String, String, String)

Declaration
short add_site_to_bus_org(string site_id, string acct_id, string role_name)
Parameters
Type | Name | Description
System.String | site_id |
System.String | acct_id |
System.String | role_name |
Returns
Type | Description
System.Int16 |

add_site_to_contract(String, String)

Declaration
short add_site_to_contract(string contract_id, string site_id)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | site_id |
Returns
Type | Description
System.Int16 |

add_user_to_queue(String, String, Boolean)

Declaration
short add_user_to_queue(string queue, string user_name, bool supervisor)
Parameters
Type | Name | Description
System.String | queue |
System.String | user_name |
System.Boolean | supervisor |
Returns
Type | Description
System.Int16 |

add_workaround(String, Int32, String, Boolean, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short add_workaround(string soln_id, int soln_objid, string workaround, bool is_public, string create_date, string res_code, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | soln_id |
System.Int32 | soln_objid |
System.String | workaround |
System.Boolean | is_public |
System.String | create_date |
System.String | res_code |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

add_workaround_list(String, Int32, String, Boolean, String, String, IFCList, IFCList, IFCList)

Declaration
short add_workaround_list(string soln_id, int soln_objid, string workaround, bool is_public, string create_date, string res_code, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | soln_id |
System.Int32 | soln_objid |
System.String | workaround |
System.Boolean | is_public |
System.String | create_date |
System.String | res_code |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

assign_solution(String, String, String, String, String, Boolean)

Declaration
short assign_solution(string solution_id, string new_user, string wipbin, string assign_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | solution_id |
System.String | new_user |
System.String | wipbin |
System.String | assign_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

create_address(String, String, String, String, Boolean, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short create_address(string addr1, string addr2, string city, string State, bool short_state, string zip, string Country, string time_zone, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | addr1 |
System.String | addr2 |
System.String | city |
System.String | State |
System.Boolean | short_state |
System.String | zip |
System.String | Country |
System.String | time_zone |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

create_address_list(String, String, String, String, Boolean, String, String, String, IFCList, IFCList, IFCList)

Declaration
short create_address_list(string addr1, string addr2, string city, string State, bool short_state, string zip, string Country, string time_zone, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | addr1 |
System.String | addr2 |
System.String | city |
System.String | State |
System.Boolean | short_state |
System.String | zip |
System.String | Country |
System.String | time_zone |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

create_bom(String, String, String, String, String, String, Int32)

Declaration
short create_bom(string parent_part, string parent_dom, string parent_rev, string child_part, string child_dom, string child_rev, int quantity)
Parameters
Type | Name | Description
System.String | parent_part |
System.String | parent_dom |
System.String | parent_rev |
System.String | child_part |
System.String | child_dom |
System.String | child_rev |
System.Int32 | quantity |
Returns
Type | Description
System.Int16 |

create_contact(String, String, String, String, String, String, String, String, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short create_contact(string first, string last, string phone, string site_id, string role, string fax, string email, string mail_stop, string the_title, string hours, string salutation, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | first |
System.String | last |
System.String | phone |
System.String | site_id |
System.String | role |
System.String | fax |
System.String | email |
System.String | mail_stop |
System.String | the_title |
System.String | hours |
System.String | salutation |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

create_contact_list(String, String, String, String, String, String, String, String, String, String, String, IFCList, IFCList, IFCList)

Declaration
short create_contact_list(string first, string last, string phone, string site_id, string role, string fax, string email, string mail_stop, string the_title, string hours, string salutation, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | first |
System.String | last |
System.String | phone |
System.String | site_id |
System.String | role |
System.String | fax |
System.String | email |
System.String | mail_stop |
System.String | the_title |
System.String | hours |
System.String | salutation |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

create_country(String, Int32, String, String, String, Double, String)

Declaration
short create_country(string cname, int c_code, string the_currency, string symbol, string desc, double conv_rate, string iso_code)
Parameters
Type | Name | Description
System.String | cname |
System.Int32 | c_code |
System.String | the_currency |
System.String | symbol |
System.String | desc |
System.Double | conv_rate |
System.String | iso_code |
Returns
Type | Description
System.Int16 |

create_employee(String, String, String, String, String, String, String, String, String, String, String, Boolean, Boolean, String, String, String, String, String, Boolean, Boolean, String, String, String, String, String, String, String, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short create_employee(string first_name, string last_name, string login_name, string password, string site_id, string e_mail, string phone, string pager, string online_priv_class, string offline_priv_class, string Id, bool is_active, bool allow_proxy, string start_date, string supervisor, string work_group, string work_group_start, string labor_rate, bool is_supervisor, bool is_fe, string normal_biz_high, string normal_biz_mid, string normal_biz_low, string after_biz_high, string after_biz_mid, string after_biz_low, string def_wipbin_title, string rc_config, string def_tablespace, string temp_tablespace, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | first_name |
System.String | last_name |
System.String | login_name |
System.String | password |
System.String | site_id |
System.String | e_mail |
System.String | phone |
System.String | pager |
System.String | online_priv_class |
System.String | offline_priv_class |
System.String | Id |
System.Boolean | is_active |
System.Boolean | allow_proxy |
System.String | start_date |
System.String | supervisor |
System.String | work_group |
System.String | work_group_start |
System.String | labor_rate |
System.Boolean | is_supervisor |
System.Boolean | is_fe |
System.String | normal_biz_high |
System.String | normal_biz_mid |
System.String | normal_biz_low |
System.String | after_biz_high |
System.String | after_biz_mid |
System.String | after_biz_low |
System.String | def_wipbin_title |
System.String | rc_config |
System.String | def_tablespace |
System.String | temp_tablespace |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

create_employee_list(String, String, String, String, String, String, String, String, String, String, String, Boolean, Boolean, String, String, String, String, String, Boolean, Boolean, String, String, String, String, String, String, String, String, String, String, IFCList, IFCList, IFCList)

Declaration
short create_employee_list(string first_name, string last_name, string login_name, string password, string site_id, string e_mail, string phone, string pager, string online_priv_class, string offline_priv_class, string Id, bool is_active, bool allow_proxy, string start_date, string supervisor, string work_group, string work_group_start, string labor_rate, bool is_supervisor, bool is_fe, string normal_biz_high, string normal_biz_mid, string normal_biz_low, string after_biz_high, string after_biz_mid, string after_biz_low, string def_wipbin_title, string rc_config, string def_tablespace, string temp_tablespace, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | first_name |
System.String | last_name |
System.String | login_name |
System.String | password |
System.String | site_id |
System.String | e_mail |
System.String | phone |
System.String | pager |
System.String | online_priv_class |
System.String | offline_priv_class |
System.String | Id |
System.Boolean | is_active |
System.Boolean | allow_proxy |
System.String | start_date |
System.String | supervisor |
System.String | work_group |
System.String | work_group_start |
System.String | labor_rate |
System.Boolean | is_supervisor |
System.Boolean | is_fe |
System.String | normal_biz_high |
System.String | normal_biz_mid |
System.String | normal_biz_low |
System.String | after_biz_high |
System.String | after_biz_mid |
System.String | after_biz_low |
System.String | def_wipbin_title |
System.String | rc_config |
System.String | def_tablespace |
System.String | temp_tablespace |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

create_interact(String, String, String, String, String, String, String, String, String, String, String, String, Boolean, String, Boolean, String, String, String, Int32, Int32, Int32, String, Boolean, String, Int32, String, String, String, String, String, String)

Declaration
short create_interact(string the_title, string the_notes, string first, string last, string phone, string zipcode, string reason1, string reason2, string prod_name, string direction, string the_type, string origin, bool done_in_one, string result, bool fee_based, string pay_option, string lead_source, string start_date, int duration, int wait_time, int entered_time, string user_name, bool gen_time_bomb, string int_fld1, int int_val1, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | the_title |
System.String | the_notes |
System.String | first |
System.String | last |
System.String | phone |
System.String | zipcode |
System.String | reason1 |
System.String | reason2 |
System.String | prod_name |
System.String | direction |
System.String | the_type |
System.String | origin |
System.Boolean | done_in_one |
System.String | result |
System.Boolean | fee_based |
System.String | pay_option |
System.String | lead_source |
System.String | start_date |
System.Int32 | duration |
System.Int32 | wait_time |
System.Int32 | entered_time |
System.String | user_name |
System.Boolean | gen_time_bomb |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

create_interact_list(String, String, String, String, String, String, String, String, String, String, String, String, Boolean, String, Boolean, String, String, String, Int32, Int32, Int32, String, Boolean, IFCList, IFCList, IFCList)

Declaration
short create_interact_list(string the_title, string the_notes, string first, string last, string phone, string zipcode, string reason1, string reason2, string prod_name, string direction, string the_type, string origin, bool done_in_one, string result, bool fee_based, string pay_option, string lead_source, string start_date, int duration, int wait_time, int entered_time, string user_name, bool gen_time_bomb, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | the_title |
System.String | the_notes |
System.String | first |
System.String | last |
System.String | phone |
System.String | zipcode |
System.String | reason1 |
System.String | reason2 |
System.String | prod_name |
System.String | direction |
System.String | the_type |
System.String | origin |
System.Boolean | done_in_one |
System.String | result |
System.Boolean | fee_based |
System.String | pay_option |
System.String | lead_source |
System.String | start_date |
System.Int32 | duration |
System.Int32 | wait_time |
System.Int32 | entered_time |
System.String | user_name |
System.Boolean | gen_time_bomb |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

create_price_inst(String, String, String, String, Int16, Int32, String, String, String)

Declaration
short create_price_inst(string part_num, string domain, string mod_level, string price_prog, short price_type, int priced_qty, string price, string start_date, string end_date)
Parameters
Type | Name | Description
System.String | part_num |
System.String | domain |
System.String | mod_level |
System.String | price_prog |
System.Int16 | price_type |
System.Int32 | priced_qty |
System.String | price |
System.String | start_date |
System.String | end_date |
Returns
Type | Description
System.Int16 |

create_product_bin(String, String, Int32, String, Int32, Int32, String, String)

Declaration
short create_product_bin(string bin_name, string site_id, int bin_objid, string description, int prim_supp, int sec_supp, string user_name, string create_date)
Parameters
Type | Name | Description
System.String | bin_name |
System.String | site_id |
System.Int32 | bin_objid |
System.String | description |
System.Int32 | prim_supp |
System.Int32 | sec_supp |
System.String | user_name |
System.String | create_date |
Returns
Type | Description
System.Int16 |

create_soln(String, String, String, Boolean, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short create_soln(string the_title, string description, string workaround, bool is_public, string res_code, string queue_name, string create_date, string user_name, bool create_time_bomb, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | the_title |
System.String | description |
System.String | workaround |
System.Boolean | is_public |
System.String | res_code |
System.String | queue_name |
System.String | create_date |
System.String | user_name |
System.Boolean | create_time_bomb |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

create_soln_list(String, String, String, Boolean, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
short create_soln_list(string the_title, string description, string workaround, bool is_public, string res_code, string queue_name, string create_date, string user_name, bool create_time_bomb, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | the_title |
System.String | description |
System.String | workaround |
System.Boolean | is_public |
System.String | res_code |
System.String | queue_name |
System.String | create_date |
System.String | user_name |
System.Boolean | create_time_bomb |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

create_state(String, String, Boolean, String)

Declaration
short create_state(string State, string full_name, bool is_default, string Country)
Parameters
Type | Name | Description
System.String | State |
System.String | full_name |
System.Boolean | is_default |
System.String | Country |
Returns
Type | Description
System.Int16 |

create_time_zone(String, String, String, Int32)

Declaration
short create_time_zone(string time_zone, string full_name, string Country, int gmt_diff)
Parameters
Type | Name | Description
System.String | time_zone |
System.String | full_name |
System.String | Country |
System.Int32 | gmt_diff |
Returns
Type | Description
System.Int16 |

create_update_account(String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short create_update_account(string acct_name, string desc, string territory, string stock, string fiscal_yr, string the_type, string size, string revenue, string ownership, string phone, string fax, string web_site, string user_name, string create_date, bool gen_time_bombs, string acct_id, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | acct_name |
System.String | desc |
System.String | territory |
System.String | stock |
System.String | fiscal_yr |
System.String | the_type |
System.String | size |
System.String | revenue |
System.String | ownership |
System.String | phone |
System.String | fax |
System.String | web_site |
System.String | user_name |
System.String | create_date |
System.Boolean | gen_time_bombs |
System.String | acct_id |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

create_update_account_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, String, IFCList, IFCList, IFCList)

Declaration
short create_update_account_list(string acct_name, string desc, string territory, string stock, string fiscal_yr, string the_type, string size, string revenue, string ownership, string phone, string fax, string web_site, string user_name, string create_date, bool gen_time_bombs, string acct_id, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | acct_name |
System.String | desc |
System.String | territory |
System.String | stock |
System.String | fiscal_yr |
System.String | the_type |
System.String | size |
System.String | revenue |
System.String | ownership |
System.String | phone |
System.String | fax |
System.String | web_site |
System.String | user_name |
System.String | create_date |
System.Boolean | gen_time_bombs |
System.String | acct_id |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

create_update_contract(String, String, String, String, String, Int32, Int32, String, String, String, String, Double, Double, Double, Int32, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short create_update_contract(string contract_id, string contract_type, string status, string po_number, string pay_options, int phone_resp, int onsite_resp, string hours_for_pm, string start_date, string EXPIRE_DATE, string unit_type, double units_purch, double units_used, double units_avail, int spec_consid, string notes, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | contract_type |
System.String | status |
System.String | po_number |
System.String | pay_options |
System.Int32 | phone_resp |
System.Int32 | onsite_resp |
System.String | hours_for_pm |
System.String | start_date |
System.String | EXPIRE_DATE |
System.String | unit_type |
System.Double | units_purch |
System.Double | units_used |
System.Double | units_avail |
System.Int32 | spec_consid |
System.String | notes |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

create_update_contract_list(String, String, String, String, String, Int32, Int32, String, String, String, String, Double, Double, Double, Int32, String, IFCList, IFCList, IFCList)

Declaration
short create_update_contract_list(string contract_id, string contract_type, string status, string po_number, string pay_options, int phone_resp, int onsite_resp, string hours_for_pm, string start_date, string EXPIRE_DATE, string unit_type, double units_purch, double units_used, double units_avail, int spec_consid, string notes, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | contract_type |
System.String | status |
System.String | po_number |
System.String | pay_options |
System.Int32 | phone_resp |
System.Int32 | onsite_resp |
System.String | hours_for_pm |
System.String | start_date |
System.String | EXPIRE_DATE |
System.String | unit_type |
System.Double | units_purch |
System.Double | units_used |
System.Double | units_avail |
System.Int32 | spec_consid |
System.String | notes |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

create_update_mod_level(String, String, String, String, String, String, String, String, Boolean, String)

Declaration
short create_update_mod_level(string part_num, string domain, string mod_level, string replaces_part, string replaces_dom, string replaces_rev, string replaces_date, string status, bool change_ml, string new_ml)
Parameters
Type | Name | Description
System.String | part_num |
System.String | domain |
System.String | mod_level |
System.String | replaces_part |
System.String | replaces_dom |
System.String | replaces_rev |
System.String | replaces_date |
System.String | status |
System.Boolean | change_ml |
System.String | new_ml |
Returns
Type | Description
System.Int16 |

create_update_part(String, String, String, String, String, Int32, Boolean, String, String, String, String, String, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short create_update_part(string part_num, string domain, string notes, string desc, string model_num, int warr_days, bool start_on_ship, string unit_measure, string family, string the_line, string repair_type, string part_type, string weight, string dimension, string Class_Renamed, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | part_num |
System.String | domain |
System.String | notes |
System.String | desc |
System.String | model_num |
System.Int32 | warr_days |
System.Boolean | start_on_ship |
System.String | unit_measure |
System.String | family |
System.String | the_line |
System.String | repair_type |
System.String | part_type |
System.String | weight |
System.String | dimension |
System.String | Class_Renamed |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

create_update_part_list(String, String, String, String, String, Int32, Boolean, String, String, String, String, String, String, String, String, IFCList, IFCList, IFCList)

Declaration
short create_update_part_list(string part_num, string domain, string notes, string desc, string model_num, int warr_days, bool start_on_ship, string unit_measure, string family, string the_line, string repair_type, string part_type, string weight, string dimension, string Class_Renamed, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | part_num |
System.String | domain |
System.String | notes |
System.String | desc |
System.String | model_num |
System.Int32 | warr_days |
System.Boolean | start_on_ship |
System.String | unit_measure |
System.String | family |
System.String | the_line |
System.String | repair_type |
System.String | part_type |
System.String | weight |
System.String | dimension |
System.String | Class_Renamed |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

create_update_queue(String, Boolean, String, Int16, Int16, Int16, Int16, Int16, Int16, Int16, Int16, Int16, Int16, String, String)

Declaration
short create_update_queue(string Title, bool personal, string description, short allow_bug, short allow_case, short allow_contract, short allow_dialogue, short allow_dmnd_dtl, short allow_job, short allow_opp, short allow_probdesc, short allow_subcase, short allow_task, string supervisor, string new_title)
Parameters
Type | Name | Description
System.String | Title |
System.Boolean | personal |
System.String | description |
System.Int16 | allow_bug |
System.Int16 | allow_case |
System.Int16 | allow_contract |
System.Int16 | allow_dialogue |
System.Int16 | allow_dmnd_dtl |
System.Int16 | allow_job |
System.Int16 | allow_opp |
System.Int16 | allow_probdesc |
System.Int16 | allow_subcase |
System.Int16 | allow_task |
System.String | supervisor |
System.String | new_title |
Returns
Type | Description
System.Int16 |

create_update_site(Int32, String, String, String, String, String, String, String, String, String, Int32, Int32, Int32, String, String, Int32, Int32, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short create_update_site(int site_objid, string site_id, string site_name, string site_type, string bus_org, string status, string region, string district, string industry_type, string appl_type, int prim_addr, int ship_addr, int bill_addr, string parent_site, string supp_office, int prim_emp, int sec_emp, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.Int32 | site_objid |
System.String | site_id |
System.String | site_name |
System.String | site_type |
System.String | bus_org |
System.String | status |
System.String | region |
System.String | district |
System.String | industry_type |
System.String | appl_type |
System.Int32 | prim_addr |
System.Int32 | ship_addr |
System.Int32 | bill_addr |
System.String | parent_site |
System.String | supp_office |
System.Int32 | prim_emp |
System.Int32 | sec_emp |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

create_update_site_list(Int32, String, String, String, String, String, String, String, String, String, Int32, Int32, Int32, String, String, Int32, Int32, IFCList, IFCList, IFCList)

Declaration
short create_update_site_list(int site_objid, string site_id, string site_name, string site_type, string bus_org, string status, string region, string district, string industry_type, string appl_type, int prim_addr, int ship_addr, int bill_addr, string parent_site, string supp_office, int prim_emp, int sec_emp, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.Int32 | site_objid |
System.String | site_id |
System.String | site_name |
System.String | site_type |
System.String | bus_org |
System.String | status |
System.String | region |
System.String | district |
System.String | industry_type |
System.String | appl_type |
System.Int32 | prim_addr |
System.Int32 | ship_addr |
System.Int32 | bill_addr |
System.String | parent_site |
System.String | supp_office |
System.Int32 | prim_emp |
System.Int32 | sec_emp |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

create_update_wipbin(String, String, String, String, Boolean)

Declaration
short create_update_wipbin(string Title, string new_title, string description, string user_name, bool def_bin)
Parameters
Type | Name | Description
System.String | Title |
System.String | new_title |
System.String | description |
System.String | user_name |
System.Boolean | def_bin |
Returns
Type | Description
System.Int16 |

deinstall_sp(Int32, String, String, Boolean)

Declaration
short deinstall_sp(int sp_objid, string user_name, string deinstall_date, bool use_remove)
Parameters
Type | Name | Description
System.Int32 | sp_objid |
System.String | user_name |
System.String | deinstall_date |
System.Boolean | use_remove |
Returns
Type | Description
System.Int16 |

delete_product_bin(Int32, String, String)

Declaration
short delete_product_bin(int bin_objid, string user_name, string delete_date)
Parameters
Type | Name | Description
System.Int32 | bin_objid |
System.String | user_name |
System.String | delete_date |
Returns
Type | Description
System.Int16 |

dispatch_solution(String, String, String, String, Boolean)

Declaration
short dispatch_solution(string solution_id, string queue_name, string disp_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | solution_id |
System.String | queue_name |
System.String | disp_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

forward_solution(String, String, String, String, String, Boolean)

Declaration
short forward_solution(string solution_id, string new_queue, string forward_date, string notes, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | solution_id |
System.String | new_queue |
System.String | forward_date |
System.String | notes |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

Initialize(IFCApplication, IFCSession)

Declaration
void Initialize(IFCApplication TheFCApplication, IFCSession TheFCSession)
Parameters
Type | Name | Description
IFCApplication | TheFCApplication |
IFCSession | TheFCSession |

install_sp(String, String, String, String, Int32, String, Int32, Int32, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short install_sp(string site_id, string part_num, string mod_level, string domain, int quantity, string serial_num, int parent_bin_objid, int parent_sp_objid, string instance_name, string comment, string part_status, string invoice_no, string user_name, string install_date, string ship_date, bool add_activity, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | site_id |
System.String | part_num |
System.String | mod_level |
System.String | domain |
System.Int32 | quantity |
System.String | serial_num |
System.Int32 | parent_bin_objid |
System.Int32 | parent_sp_objid |
System.String | instance_name |
System.String | comment |
System.String | part_status |
System.String | invoice_no |
System.String | user_name |
System.String | install_date |
System.String | ship_date |
System.Boolean | add_activity |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

install_sp_list(String, String, String, String, Int32, String, Int32, Int32, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
short install_sp_list(string site_id, string part_num, string mod_level, string domain, int quantity, string serial_num, int parent_bin_objid, int parent_sp_objid, string instance_name, string comment, string part_status, string invoice_no, string user_name, string install_date, string ship_date, bool add_activity, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | site_id |
System.String | part_num |
System.String | mod_level |
System.String | domain |
System.Int32 | quantity |
System.String | serial_num |
System.Int32 | parent_bin_objid |
System.Int32 | parent_sp_objid |
System.String | instance_name |
System.String | comment |
System.String | part_status |
System.String | invoice_no |
System.String | user_name |
System.String | install_date |
System.String | ship_date |
System.Boolean | add_activity |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

link_case_to_workaround(String, Int32, String, String, Boolean)

Declaration
short link_case_to_workaround(string case_id, int work_objid, string link_date, string user_name, bool create_time_bomb)
Parameters
Type | Name | Description
System.String | case_id |
System.Int32 | work_objid |
System.String | link_date |
System.String | user_name |
System.Boolean | create_time_bomb |
Returns
Type | Description
System.Int16 |

link_cr_to_soln(String, String, String, String, Boolean)

Declaration
short link_cr_to_soln(string cr_id, string soln_id, string link_date, string user_name, bool create_time_bomb)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | soln_id |
System.String | link_date |
System.String | user_name |
System.Boolean | create_time_bomb |
Returns
Type | Description
System.Int16 |

modify_product_bin(Int32, String, String, Int32, Int32, String, String)

Declaration
short modify_product_bin(int bin_objid, string bin_name, string description, int prim_supp, int sec_supp, string user_name, string mod_date)
Parameters
Type | Name | Description
System.Int32 | bin_objid |
System.String | bin_name |
System.String | description |
System.Int32 | prim_supp |
System.Int32 | sec_supp |
System.String | user_name |
System.String | mod_date |
Returns
Type | Description
System.Int16 |

modify_sp(Int32, String, String, String, String, String, String, Int32, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short modify_sp(int sp_objid, string instance_name, string serial_num, string invoice_no, string ship_date, string install_date, string warranty_date, int quantity, string part_status, string comments, string service_end_dt, string user_name, string mod_level, bool add_activity, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.Int32 | sp_objid |
System.String | instance_name |
System.String | serial_num |
System.String | invoice_no |
System.String | ship_date |
System.String | install_date |
System.String | warranty_date |
System.Int32 | quantity |
System.String | part_status |
System.String | comments |
System.String | service_end_dt |
System.String | user_name |
System.String | mod_level |
System.Boolean | add_activity |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

modify_sp_list(Int32, String, String, String, String, String, String, Int32, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
short modify_sp_list(int sp_objid, string instance_name, string serial_num, string invoice_no, string ship_date, string install_date, string warranty_date, int quantity, string part_status, string comments, string service_end_dt, string user_name, string mod_level, bool add_activity, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.Int32 | sp_objid |
System.String | instance_name |
System.String | serial_num |
System.String | invoice_no |
System.String | ship_date |
System.String | install_date |
System.String | warranty_date |
System.Int32 | quantity |
System.String | part_status |
System.String | comments |
System.String | service_end_dt |
System.String | user_name |
System.String | mod_level |
System.Boolean | add_activity |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

move_solution(String, String)

Declaration
short move_solution(string solution_id, string new_wipbin)
Parameters
Type | Name | Description
System.String | solution_id |
System.String | new_wipbin |
Returns
Type | Description
System.Int16 |

move_sp(Int32, String, Int32, String, Int32, Boolean, String, Boolean)

Declaration
short move_sp(int sp_objid, string move_date, int parent_sp_objid, string site_id, int parent_bin_objid, bool add_activity, string user_name, bool install_and_move)
Parameters
Type | Name | Description
System.Int32 | sp_objid |
System.String | move_date |
System.Int32 | parent_sp_objid |
System.String | site_id |
System.Int32 | parent_bin_objid |
System.Boolean | add_activity |
System.String | user_name |
System.Boolean | install_and_move |
Returns
Type | Description
System.Int16 |

reinstall_sp(Int32, String, Int32, Int32, String, String, Boolean, Boolean)

Declaration
short reinstall_sp(int sp_objid, string site_id, int parent_bin_objid, int parent_sp_objid, string user_name, string reinst_date, bool add_activity, bool use_install)
Parameters
Type | Name | Description
System.Int32 | sp_objid |
System.String | site_id |
System.Int32 | parent_bin_objid |
System.Int32 | parent_sp_objid |
System.String | user_name |
System.String | reinst_date |
System.Boolean | add_activity |
System.Boolean | use_install |
Returns
Type | Description
System.Int16 |

reject_solution(String, String, String, String, String, Boolean)

Declaration
short reject_solution(string solution_id, string reject_date, string wipbin, string notes, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | solution_id |
System.String | reject_date |
System.String | wipbin |
System.String | notes |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

remove_contact_from_contract(String, Int32)

Declaration
short remove_contact_from_contract(string contract_id, int contact_objid)
Parameters
Type | Name | Description
System.String | contract_id |
System.Int32 | contact_objid |
Returns
Type | Description
System.Int16 |

remove_emp_from_bus_org(String, String, String)

Declaration
short remove_emp_from_bus_org(string user_name, string acct_id, string role_name)
Parameters
Type | Name | Description
System.String | user_name |
System.String | acct_id |
System.String | role_name |
Returns
Type | Description
System.Int16 |

remove_site_from_bus_org(String, String, String)

Declaration
short remove_site_from_bus_org(string site_id, string acct_id, string role_name)
Parameters
Type | Name | Description
System.String | site_id |
System.String | acct_id |
System.String | role_name |
Returns
Type | Description
System.Int16 |

remove_site_from_contract(String, String)

Declaration
short remove_site_from_contract(string contract_id, string site_id)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | site_id |
Returns
Type | Description
System.Int16 |

remove_site_part_from_contract(String, Int32)

Declaration
short remove_site_part_from_contract(string contract_id, int sp_objid)
Parameters
Type | Name | Description
System.String | contract_id |
System.Int32 | sp_objid |
Returns
Type | Description
System.Int16 |

unlink_case_from_workaround(String, String, String, Boolean)

Declaration
short unlink_case_from_workaround(string case_id, string unlink_date, string user_name, bool create_time_bomb)
Parameters
Type | Name | Description
System.String | case_id |
System.String | unlink_date |
System.String | user_name |
System.Boolean | create_time_bomb |
Returns
Type | Description
System.Int16 |

unlink_cr_from_soln(String, String, String, String, Boolean)

Declaration
short unlink_cr_from_soln(string cr_id, string soln_id, string unlink_date, string user_name, bool create_time_bomb)
Parameters
Type | Name | Description
System.String | cr_id |
System.String | soln_id |
System.String | unlink_date |
System.String | user_name |
System.Boolean | create_time_bomb |
Returns
Type | Description
System.Int16 |

update_address(Int32, String, String, String, String, Boolean, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short update_address(int addr_objid, string addr1, string addr2, string city, string State, bool short_state, string zip, string Country, string time_zone, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.Int32 | addr_objid |
System.String | addr1 |
System.String | addr2 |
System.String | city |
System.String | State |
System.Boolean | short_state |
System.String | zip |
System.String | Country |
System.String | time_zone |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

update_address_list(Int32, String, String, String, String, Boolean, String, String, String, IFCList, IFCList, IFCList)

Declaration
short update_address_list(int addr_objid, string addr1, string addr2, string city, string State, bool short_state, string zip, string Country, string time_zone, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.Int32 | addr_objid |
System.String | addr1 |
System.String | addr2 |
System.String | city |
System.String | State |
System.Boolean | short_state |
System.String | zip |
System.String | Country |
System.String | time_zone |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

update_contact(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short update_contact(string first, string last, string phone, string site_id, string role, string fax, string email, string mail_stop, string the_title, string hours, string salutation, string new_first, string new_last, string new_phone, string new_prim_site_id, string new_prim_role, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | first |
System.String | last |
System.String | phone |
System.String | site_id |
System.String | role |
System.String | fax |
System.String | email |
System.String | mail_stop |
System.String | the_title |
System.String | hours |
System.String | salutation |
System.String | new_first |
System.String | new_last |
System.String | new_phone |
System.String | new_prim_site_id |
System.String | new_prim_role |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

update_contact_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, IFCList, IFCList, IFCList)

Declaration
short update_contact_list(string first, string last, string phone, string site_id, string role, string fax, string email, string mail_stop, string the_title, string hours, string salutation, string new_first, string new_last, string new_phone, string new_prim_site_id, string new_prim_role, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | first |
System.String | last |
System.String | phone |
System.String | site_id |
System.String | role |
System.String | fax |
System.String | email |
System.String | mail_stop |
System.String | the_title |
System.String | hours |
System.String | salutation |
System.String | new_first |
System.String | new_last |
System.String | new_phone |
System.String | new_prim_site_id |
System.String | new_prim_role |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

update_contact_objid_list(Int32, String, String, String, String, String, String, String, String, String, String, String, String, String, IFCList, IFCList, IFCList)

Declaration
short update_contact_objid_list(int contact_objid, string site_id, string role, string fax, string email, string mail_stop, string the_title, string hours, string salutation, string new_first, string new_last, string new_phone, string new_prim_site_id, string new_prim_role, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.Int32 | contact_objid |
System.String | site_id |
System.String | role |
System.String | fax |
System.String | email |
System.String | mail_stop |
System.String | the_title |
System.String | hours |
System.String | salutation |
System.String | new_first |
System.String | new_last |
System.String | new_phone |
System.String | new_prim_site_id |
System.String | new_prim_role |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

update_price_inst(String, String, String, String, Int32, String, String)

Declaration
short update_price_inst(string part_num, string domain, string mod_level, string price_prog, int priced_qty, string price, string the_date)
Parameters
Type | Name | Description
System.String | part_num |
System.String | domain |
System.String | mod_level |
System.String | price_prog |
System.Int32 | priced_qty |
System.String | price |
System.String | the_date |
Returns
Type | Description
System.Int16 |

yank_solution(String, String, String, String, Boolean)

Declaration
short yank_solution(string solution_id, string wipbin, string yank_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | solution_id |
System.String | wipbin |
System.String | yank_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |


Interface IFCSFA | fcSDK Documentation

Interface IFCSFA

Namespace: FChoice.Foundation.Clarify.Compatibility.Toolkits
Assembly: FChoice.Foundation.Clarify.Compatibility.Toolkits.dll
Syntax
[Guid("31BFCC5F-1E05-44fa-BBDC-CB1B96070BC8")]
[ComVisible(true)]
public interface IFCSFA

Properties

impersonatorUserName

Declaration
string impersonatorUserName { get; set; }
Property Value
Type | Description
System.String |

ret_id_num

Declaration
string ret_id_num { get; }
Property Value
Type | Description
System.String |

ret_objid

Declaration
int ret_objid { get; }
Property Value
Type | Description
System.Int32 |

ret_objid2

Declaration
int ret_objid2 { get; }
Property Value
Type | Description
System.Int32 |

Methods

accept_action_item(String, String, String, String, Boolean)

Declaration
short accept_action_item(string the_id, string accept_date, string wipbin, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | accept_date |
System.String | wipbin |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

accept_opportunity(String, String, String, String, Boolean)

Declaration
short accept_opportunity(string the_id, string accept_date, string wipbin, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | accept_date |
System.String | wipbin |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

accept_quote(String, String, String, String, Boolean)

Declaration
short accept_quote(string the_id, string accept_date, string wipbin, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | accept_date |
System.String | wipbin |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

assign_action_item(String, String, String, String, String, Boolean)

Declaration
short assign_action_item(string the_id, string new_user, string wipbin, string assign_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | new_user |
System.String | wipbin |
System.String | assign_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

assign_lead(Int32, String, String, Boolean)

Declaration
short assign_lead(int lead_objid, string new_owner, string assign_date, bool gen_time_bombs)
Parameters
Type | Name | Description
System.Int32 | lead_objid |
System.String | new_owner |
System.String | assign_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

assign_opportunity(String, String, String, String, String, Boolean)

Declaration
short assign_opportunity(string the_id, string new_user, string wipbin, string assign_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | new_user |
System.String | wipbin |
System.String | assign_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

assign_quote(String, String, String, String, String, Boolean)

Declaration
short assign_quote(string the_id, string new_user, string wipbin, string assign_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | new_user |
System.String | wipbin |
System.String | assign_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

change_action_item_status(String, String, String, String, String, Boolean)

Declaration
short change_action_item_status(string the_id, string new_status, string change_date, string notes, string local_user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | new_status |
System.String | change_date |
System.String | notes |
System.String | local_user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

change_opportunity_status(String, String, String, String, String, Boolean)

Declaration
short change_opportunity_status(string the_id, string new_status, string change_date, string notes, string local_user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | new_status |
System.String | change_date |
System.String | notes |
System.String | local_user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

change_quote_status(String, String, String, String, String, Boolean)

Declaration
short change_quote_status(string the_id, string new_status, string change_date, string notes, string local_user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | new_status |
System.String | change_date |
System.String | notes |
System.String | local_user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

change_task_cond(String, String, String, String, String, Boolean)

Declaration
short change_task_cond(string task_id, string new_cond, string new_status, string user_name, string change_date, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | task_id |
System.String | new_cond |
System.String | new_status |
System.String | user_name |
System.String | change_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

close_opp(String, String, String, String, Boolean)

Declaration
short close_opp(string opp_id, string the_status, string close_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | opp_id |
System.String | the_status |
System.String | close_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

cr_contr_itm(String, String, String, String, String, String, String, String, Int32, String, String, Double, String, Boolean, Boolean, String, String, String, Int32, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short cr_contr_itm(string contract_id, string user_name, string create_date, string start_date, string end_date, string part_num, string domain, string rev, int quantity, string price_schedule, string oride_price, double units_used, string serial_num, bool is_taxable, bool install_it, string comments, string quoted_site, string serviced_at_site, int parent_objid, string po_num, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | user_name |
System.String | create_date |
System.String | start_date |
System.String | end_date |
System.String | part_num |
System.String | domain |
System.String | rev |
System.Int32 | quantity |
System.String | price_schedule |
System.String | oride_price |
System.Double | units_used |
System.String | serial_num |
System.Boolean | is_taxable |
System.Boolean | install_it |
System.String | comments |
System.String | quoted_site |
System.String | serviced_at_site |
System.Int32 | parent_objid |
System.String | po_num |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

cr_contr_itm_list(String, String, String, String, String, String, String, String, Int32, String, String, Double, String, Boolean, Boolean, String, String, String, Int32, String, IFCList, IFCList, IFCList)

Declaration
short cr_contr_itm_list(string contract_id, string user_name, string create_date, string start_date, string end_date, string part_num, string domain, string rev, int quantity, string price_schedule, string oride_price, double units_used, string serial_num, bool is_taxable, bool install_it, string comments, string quoted_site, string serviced_at_site, int parent_objid, string po_num, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | contract_id |
System.String | user_name |
System.String | create_date |
System.String | start_date |
System.String | end_date |
System.String | part_num |
System.String | domain |
System.String | rev |
System.Int32 | quantity |
System.String | price_schedule |
System.String | oride_price |
System.Double | units_used |
System.String | serial_num |
System.Boolean | is_taxable |
System.Boolean | install_it |
System.String | comments |
System.String | quoted_site |
System.String | serviced_at_site |
System.Int32 | parent_objid |
System.String | po_num |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

create_action_item(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short create_action_item(string title, string notes, string first_name, string last_name, string phone, string acct_name, string lead_first, string lead_last, string opp_id, string the_type, string priority, string start_date, string due_date, string complete_date, string status, string create_date, string user_name, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | title |
System.String | notes |
System.String | first_name |
System.String | last_name |
System.String | phone |
System.String | acct_name |
System.String | lead_first |
System.String | lead_last |
System.String | opp_id |
System.String | the_type |
System.String | priority |
System.String | start_date |
System.String | due_date |
System.String | complete_date |
System.String | status |
System.String | create_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

create_action_item_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
short create_action_item_list(string title, string notes, string first_name, string last_name, string phone, string acct_name, string lead_first, string lead_last, string opp_id, string the_type, string priority, string start_date, string due_date, string complete_date, string status, string create_date, string user_name, bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | title |
System.String | notes |
System.String | first_name |
System.String | last_name |
System.String | phone |
System.String | acct_name |
System.String | lead_first |
System.String | lead_last |
System.String | opp_id |
System.String | the_type |
System.String | priority |
System.String | start_date |
System.String | due_date |
System.String | complete_date |
System.String | status |
System.String | create_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

create_opp(String, String, String, String, String, String, Decimal, String, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short create_opp(string opp_name, string acct_id, string con_first, string con_last, string con_phone, string terr_name, decimal amt, string close_date, string sales_stage, string lead_source, string the_currency, string prob, string process, string user_name, string create_date, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | opp_name |
System.String | acct_id |
System.String | con_first |
System.String | con_last |
System.String | con_phone |
System.String | terr_name |
System.Decimal | amt |
System.String | close_date |
System.String | sales_stage |
System.String | lead_source |
System.String | the_currency |
System.String | prob |
System.String | process |
System.String | user_name |
System.String | create_date |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

create_opp_list(String, String, String, String, String, String, Decimal, String, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
short create_opp_list(string opp_name, string acct_id, string con_first, string con_last, string con_phone, string terr_name, decimal amt, string close_date, string sales_stage, string lead_source, string the_currency, string prob, string process, string user_name, string create_date, bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | opp_name |
System.String | acct_id |
System.String | con_first |
System.String | con_last |
System.String | con_phone |
System.String | terr_name |
System.Decimal | amt |
System.String | close_date |
System.String | sales_stage |
System.String | lead_source |
System.String | the_currency |
System.String | prob |
System.String | process |
System.String | user_name |
System.String | create_date |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

create_quote(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int16, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short create_quote(string quote_title, string account_id, string site_id, string opp_id, string first, string last, string phone, string status, string bill_to_site, string ship_to_site, string the_curr, string price_prog, string queue, string admin_user, string create_date, string user_name, short quote_len, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | quote_title |
System.String | account_id |
System.String | site_id |
System.String | opp_id |
System.String | first |
System.String | last |
System.String | phone |
System.String | status |
System.String | bill_to_site |
System.String | ship_to_site |
System.String | the_curr |
System.String | price_prog |
System.String | queue |
System.String | admin_user |
System.String | create_date |
System.String | user_name |
System.Int16 | quote_len |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

create_quote_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int16, Boolean, IFCList, IFCList, IFCList)

Declaration
short create_quote_list(string quote_title, string account_id, string site_id, string opp_id, string first, string last, string phone, string status, string bill_to_site, string ship_to_site, string the_curr, string price_prog, string queue, string admin_user, string create_date, string user_name, short quote_len, bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | quote_title |
System.String | account_id |
System.String | site_id |
System.String | opp_id |
System.String | first |
System.String | last |
System.String | phone |
System.String | status |
System.String | bill_to_site |
System.String | ship_to_site |
System.String | the_curr |
System.String | price_prog |
System.String | queue |
System.String | admin_user |
System.String | create_date |
System.String | user_name |
System.Int16 | quote_len |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

create_update_lead(Int32, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short create_update_lead(int lead_objid, string first_name, string last_name, string phone, string fax, string address, string address_2, string city, string state, string postal_code, string country, string time_zone, string e_mail, string the_title, string company_name, string site_name, string site_type, string rating, string contact_role, string lead_source, string user_name, string create_date, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.Int32 | lead_objid |
System.String | first_name |
System.String | last_name |
System.String | phone |
System.String | fax |
System.String | address |
System.String | address_2 |
System.String | city |
System.String | state |
System.String | postal_code |
System.String | country |
System.String | time_zone |
System.String | e_mail |
System.String | the_title |
System.String | company_name |
System.String | site_name |
System.String | site_type |
System.String | rating |
System.String | contact_role |
System.String | lead_source |
System.String | user_name |
System.String | create_date |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

create_update_lead_list(Int32, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
short create_update_lead_list(int lead_objid, string first_name, string last_name, string phone, string fax, string address, string address_2, string city, string state, string postal_code, string country, string time_zone, string e_mail, string the_title, string company_name, string site_name, string site_type, string rating, string contact_role, string lead_source, string user_name, string create_date, bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.Int32 | lead_objid |
System.String | first_name |
System.String | last_name |
System.String | phone |
System.String | fax |
System.String | address |
System.String | address_2 |
System.String | city |
System.String | state |
System.String | postal_code |
System.String | country |
System.String | time_zone |
System.String | e_mail |
System.String | the_title |
System.String | company_name |
System.String | site_name |
System.String | site_type |
System.String | rating |
System.String | contact_role |
System.String | lead_source |
System.String | user_name |
System.String | create_date |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

dispatch_action_item(String, String, String, String, Boolean)

Declaration
short dispatch_action_item(string the_id, string queue_name, string disp_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | queue_name |
System.String | disp_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

dispatch_opportunity(String, String, String, String, Boolean)

Declaration
short dispatch_opportunity(string the_id, string queue_name, string disp_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | queue_name |
System.String | disp_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

dispatch_quote(String, String, String, String, Boolean)

Declaration
short dispatch_quote(string the_id, string queue_name, string disp_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | queue_name |
System.String | disp_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

forward_action_item(String, String, String, String, String, Boolean)

Declaration
short forward_action_item(string the_id, string new_queue, string forward_date, string notes, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | new_queue |
System.String | forward_date |
System.String | notes |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

forward_opportunity(String, String, String, String, String, Boolean)

Declaration
short forward_opportunity(string the_id, string new_queue, string forward_date, string notes, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | new_queue |
System.String | forward_date |
System.String | notes |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

forward_quote(String, String, String, String, String, Boolean)

Declaration
short forward_quote(string the_id, string new_queue, string forward_date, string notes, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | new_queue |
System.String | forward_date |
System.String | notes |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

Initialize(IFCApplication, IFCSession)

Declaration
void Initialize(IFCApplication FCApp, IFCSession FCSess)
Parameters
Type | Name | Description
IFCApplication | FCApp |
IFCSession | FCSess |

lead_opp(String, String, String, String, String, Boolean)

Declaration
short lead_opp(string opp_id, string new_status, string the_note, string user_name, string change_date, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | opp_id |
System.String | new_status |
System.String | the_note |
System.String | user_name |
System.String | change_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

log_lead_note(Int32, String, String, String, String, Boolean)

Declaration
short log_lead_note(int lead_objid, string the_text, string iuo, string log_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.Int32 | lead_objid |
System.String | the_text |
System.String | iuo |
System.String | log_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

log_lead_phone(Int32, String, String, String, String, String, String, String, Int32, String, Boolean)

Declaration
short log_lead_phone(int lead_objid, string the_text, string iuo, string first, string last, string phone, string action, string log_date, int duration, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.Int32 | lead_objid |
System.String | the_text |
System.String | iuo |
System.String | first |
System.String | last |
System.String | phone |
System.String | action |
System.String | log_date |
System.Int32 | duration |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

lose_opp(String, String, String, String, String, Boolean)

Declaration
short lose_opp(string opp_id, string new_status, string the_note, string user_name, string change_date, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | opp_id |
System.String | new_status |
System.String | the_note |
System.String | user_name |
System.String | change_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

modify_opp(String, String, String, String, String, String, String, Decimal, String, String, String, String, String, String, String, Boolean, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short modify_opp(string opp_id, string opp_name, string acct_id, string con_first, string con_last, string con_phone, string terr_name, decimal amt, string close_date, string lead_source, string the_currency, string prob, string process, string mod_date, string user_name, bool gen_time_bombs, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | opp_id |
System.String | opp_name |
System.String | acct_id |
System.String | con_first |
System.String | con_last |
System.String | con_phone |
System.String | terr_name |
System.Decimal | amt |
System.String | close_date |
System.String | lead_source |
System.String | the_currency |
System.String | prob |
System.String | process |
System.String | mod_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

modify_opp_list(String, String, String, String, String, String, String, Decimal, String, String, String, String, String, String, String, Boolean, IFCList, IFCList, IFCList)

Declaration
short modify_opp_list(string opp_id, string opp_name, string acct_id, string con_first, string con_last, string con_phone, string terr_name, decimal amt, string close_date, string lead_source, string the_currency, string prob, string process, string mod_date, string user_name, bool gen_time_bombs, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | opp_id |
System.String | opp_name |
System.String | acct_id |
System.String | con_first |
System.String | con_last |
System.String | con_phone |
System.String | terr_name |
System.Decimal | amt |
System.String | close_date |
System.String | lead_source |
System.String | the_currency |
System.String | prob |
System.String | process |
System.String | mod_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

move_action_item(String, String)

Declaration
short move_action_item(string the_id, string new_wipbin)
Parameters
Type | Name | Description
System.String | the_id |
System.String | new_wipbin |
Returns
Type | Description
System.Int16 |

move_opportunity(String, String)

Declaration
short move_opportunity(string the_id, string new_wipbin)
Parameters
Type | Name | Description
System.String | the_id |
System.String | new_wipbin |
Returns
Type | Description
System.Int16 |

move_quote(String, String)

Declaration
short move_quote(string the_id, string new_wipbin)
Parameters
Type | Name | Description
System.String | the_id |
System.String | new_wipbin |
Returns
Type | Description
System.Int16 |

opp_opp(String, String, String, String, String, Boolean)

Declaration
short opp_opp(string opp_id, string new_status, string the_note, string user_name, string change_date, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | opp_id |
System.String | new_status |
System.String | the_note |
System.String | user_name |
System.String | change_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

reject_action_item(String, String, String, String, String, Boolean)

Declaration
short reject_action_item(string the_id, string reject_date, string wipbin, string notes, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | reject_date |
System.String | wipbin |
System.String | notes |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

reject_opportunity(String, String, String, String, String, Boolean)

Declaration
short reject_opportunity(string the_id, string reject_date, string wipbin, string notes, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | reject_date |
System.String | wipbin |
System.String | notes |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

reject_quote(String, String, String, String, String, Boolean)

Declaration
short reject_quote(string the_id, string reject_date, string wipbin, string notes, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | reject_date |
System.String | wipbin |
System.String | notes |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

reopen_opp(String, String, String, String, String, Boolean)

Declaration
short reopen_opp(string opp_id, string the_status, string wipbin, string reopen_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | opp_id |
System.String | the_status |
System.String | wipbin |
System.String | reopen_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

update_action_item(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, Int32, String, Int32, String, String, String, String, String, String)

Declaration
short update_action_item(string task_id, string title, string notes, string first_name, string last_name, string phone, string acct_name, string lead_first, string lead_last, string opp_id, string the_type, string priority, string start_date, string due_date, string complete_date, string status, string update_date, string int_fld1, int int_val1, string int_fld2, int int_val2, string str_fld1, string str_val1, string str_fld2, string str_val2, string date_fld1, string date_val1)
Parameters
Type | Name | Description
System.String | task_id |
System.String | title |
System.String | notes |
System.String | first_name |
System.String | last_name |
System.String | phone |
System.String | acct_name |
System.String | lead_first |
System.String | lead_last |
System.String | opp_id |
System.String | the_type |
System.String | priority |
System.String | start_date |
System.String | due_date |
System.String | complete_date |
System.String | status |
System.String | update_date |
System.String | int_fld1 |
System.Int32 | int_val1 |
System.String | int_fld2 |
System.Int32 | int_val2 |
System.String | str_fld1 |
System.String | str_val1 |
System.String | str_fld2 |
System.String | str_val2 |
System.String | date_fld1 |
System.String | date_val1 |
Returns
Type | Description
System.Int16 |

update_action_item_list(String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, String, IFCList, IFCList, IFCList)

Declaration
short update_action_item_list(string task_id, string title, string notes, string first_name, string last_name, string phone, string acct_name, string lead_first, string lead_last, string opp_id, string the_type, string priority, string start_date, string due_date, string complete_date, string status, string update_date, IFCList fld_list = null, IFCList type_list = null, IFCList val_list = null)
Parameters
Type | Name | Description
System.String | task_id |
System.String | title |
System.String | notes |
System.String | first_name |
System.String | last_name |
System.String | phone |
System.String | acct_name |
System.String | lead_first |
System.String | lead_last |
System.String | opp_id |
System.String | the_type |
System.String | priority |
System.String | start_date |
System.String | due_date |
System.String | complete_date |
System.String | status |
System.String | update_date |
IFCList | fld_list |
IFCList | type_list |
IFCList | val_list |
Returns
Type | Description
System.Int16 |

win_opp(String, String, String, String, String, Boolean)

Declaration
short win_opp(string opp_id, string new_status, string the_note, string user_name, string change_date, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | opp_id |
System.String | new_status |
System.String | the_note |
System.String | user_name |
System.String | change_date |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

yank_action_item(String, String, String, String, Boolean)

Declaration
short yank_action_item(string the_id, string wipbin, string yank_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | wipbin |
System.String | yank_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

yank_opportunity(String, String, String, String, Boolean)

Declaration
short yank_opportunity(string the_id, string wipbin, string yank_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | wipbin |
System.String | yank_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |

yank_quote(String, String, String, String, Boolean)

Declaration
short yank_quote(string the_id, string wipbin, string yank_date, string user_name, bool gen_time_bombs)
Parameters
Type | Name | Description
System.String | the_id |
System.String | wipbin |
System.String | yank_date |
System.String | user_name |
System.Boolean | gen_time_bombs |
Returns
Type | Description
System.Int16 |


Interface IToolkit | fcSDK Documentation

Interface IToolkit

Namespace: FChoice.Foundation.Clarify.Compatibility.Toolkits
Assembly: FChoice.Foundation.Clarify.Compatibility.Toolkits.dll
Syntax
[Guid("C51486FE-C026-4fba-A358-BF86C958580D")]
[ComVisible(false)]
public interface IToolkit

Properties

ReturnIDNum

Declaration
string ReturnIDNum { get; }
Property Value
Type | Description
System.String |

ReturnObjid

Declaration
int ReturnObjid { get; }
Property Value
Type | Description
System.Int32 |


Class SitePartDataAccess | fcSDK Documentation

Class SitePartDataAccess

Inheritance
System.Object
SitePartDataAccess
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Compatibility.Toolkits
Assembly: FChoice.Foundation.Clarify.Compatibility.Toolkits.dll
Syntax
[ComVisible(false)]
[Guid("F8492FBA-90F2-38D1-BB20-5C00882C2D9F")]
public class SitePartDataAccess

Constructors

SitePartDataAccess(ClarifySession)

Declaration
public SitePartDataAccess(ClarifySession clarifySession)
Parameters
Type | Name | Description
ClarifySession | clarifySession |

Fields

ImpersonatorUserName

Declaration
public string ImpersonatorUserName
Field Value
Type | Description
System.String |

Methods

AddSitePartQuantityAndSetInstallAndShipDate(Int32, Int32, DateTime, String, String)

Declaration
public void AddSitePartQuantityAndSetInstallAndShipDate(int sitePartObjid, int quantityToAdd, DateTime installAndShipDate, string partRequstNumberIDNum, string caseIDNum)
Parameters
Type | Name | Description
System.Int32 | sitePartObjid |
System.Int32 | quantityToAdd |
System.DateTime | installAndShipDate |
System.String | partRequstNumberIDNum |
System.String | caseIDNum |

GetNonSerializedSitePartObjId(Int32, Int32)

Declaration
public int GetNonSerializedSitePartObjId(int siteObjId, int modLevelObjId)
Parameters
Type | Name | Description
System.Int32 | siteObjId |
System.Int32 | modLevelObjId |
Returns
Type | Description
System.Int32 |

GetSerializedSitePartObjId(Int32, String)

Declaration
public int GetSerializedSitePartObjId(int modLevelObjId, string serialNumber)
Parameters
Type | Name | Description
System.Int32 | modLevelObjId |
System.String | serialNumber |
Returns
Type | Description
System.Int32 |

IsNonSerializedSitePartPresent(Int32, Int32)

Declaration
public bool IsNonSerializedSitePartPresent(int siteObjId, int modLevelObjId)
Parameters
Type | Name | Description
System.Int32 | siteObjId |
System.Int32 | modLevelObjId |
Returns
Type | Description
System.Boolean |

IsSerializedSitePartPresent(Int32, String)

Declaration
public bool IsSerializedSitePartPresent(int modLevelObjId, string serialNumber)
Parameters
Type | Name | Description
System.Int32 | modLevelObjId |
System.String | serialNumber |
Returns
Type | Description
System.Boolean |


Class ConfigItemCache | fcSDK Documentation

Class ConfigItemCache

Inheritance
System.Object
CacheBase
ClarifyCacheBase
ConfigItemCache
Inherited Members
ClarifyCacheBase.IsCacheOutOfDate(DateTime)
CacheBase.UpdateSyncRoot
CacheBase.OnCacheUpdated()
CacheBase.OnAnyCacheUpdated(CacheBase)
CacheBase.UpdateCache()
CacheBase.ReadCacheData(String)
CacheBase.PersistCacheData(Object, String)
CacheBase.GetCacheDataHash()
CacheBase.GenerateMD5Hash(String)
CacheBase.AllTablesExistInDataSet(DataSet, String[])
CacheBase.GetCacheFilePath(String)
CacheBase.AnyCacheUpdated
CacheBase.CacheUpdated
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify
Assembly: fcSDK.dll
Syntax
public class ConfigItemCache : ClarifyCacheBase

Properties

CacheSetName

Declaration
public override string CacheSetName { get; }
Property Value
Type | Description
System.String |
Overrides
CacheBase.CacheSetName

CacheType

Declaration
public override CacheType CacheType { get; }
Property Value
Type | Description
CacheType |
Overrides
CacheBase.CacheType

ConfigItems

Declaration
public ClarifyConfigItemCollection ConfigItems { get; }
Property Value
Type | Description
ClarifyConfigItemCollection |

Item[String]

Declaration
public ClarifyConfigItem this[string key] { get; }
Parameters
Type | Name | Description
System.String | key |
Property Value
Type | Description
ClarifyConfigItem |

Methods

InitCacheData()

Declaration
protected override object InitCacheData()
Returns
Type | Description
System.Object |
Overrides
CacheBase.InitCacheData()

LoadCacheData(Object)

Declaration
protected override void LoadCacheData(object cacheData)
Parameters
Type | Name | Description
System.Object | cacheData |
Overrides
CacheBase.LoadCacheData(Object)

SetNameAndParameters(String, String)

Declaration
protected override void SetNameAndParameters(string name, string parameters)
Parameters
Type | Name | Description
System.String | name |
System.String | parameters |
Overrides
CacheBase.SetNameAndParameters(String, String)


Class ConfigurationHelper | fcSDK Documentation

Class ConfigurationHelper

Inheritance
System.Object
ConfigurationHelper
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify
Assembly: fcSDK.dll
Syntax
public static class ConfigurationHelper

Fields

IsClarifyClassicClientLineReturnCompatible

Declaration
public static readonly bool IsClarifyClassicClientLineReturnCompatible
Field Value
Type | Description
System.Boolean |

IsOracleAscii7bit

Declaration
public static readonly bool IsOracleAscii7bit
Field Value
Type | Description
System.Boolean |

RemoveDateTimeMilliseconds

Declaration
public static readonly bool RemoveDateTimeMilliseconds
Field Value
Type | Description
System.Boolean |


Class DatabaseParameterFactory | fcSDK Documentation

Class DatabaseParameterFactory

Inheritance
System.Object
DatabaseParameterFactory
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify
Assembly: fcSDK.dll
Syntax
public class DatabaseParameterFactory

Constructors

DatabaseParameterFactory(DbProvider)

Declaration
public DatabaseParameterFactory(DbProvider dbProvider)
Parameters
Type | Name | Description
DbProvider | dbProvider |

DatabaseParameterFactory(ISchemaCache, DbProvider)

Declaration
public DatabaseParameterFactory(ISchemaCache schemaCache, DbProvider dbProvider)
Parameters
Type | Name | Description
ISchemaCache | schemaCache |
DbProvider | dbProvider |

Fields

EnableSettingStringParameterTypeAndSize

Declaration
public const string EnableSettingStringParameterTypeAndSize = "fchoice.setstringparameterdbtypeandsize"
Field Value
Type | Description
System.String |

Methods

ConfigureStringDatabaseParameter(IDbDataParameter, ISchemaCache, DbProvider, ISchemaField)

Declaration
public static void ConfigureStringDatabaseParameter(IDbDataParameter databaseParameter, ISchemaCache schemaCache, DbProvider dbProvider, ISchemaField schemaField)
Parameters
Type | Name | Description
System.Data.IDbDataParameter | databaseParameter |
ISchemaCache | schemaCache |
DbProvider | dbProvider |
ISchemaField | schemaField |

Create(String, ISchemaField, Object)

Declaration
public IDbDataParameter Create(string paramName, ISchemaField schemaField, object paramValue)
Parameters
Type | Name | Description
System.String | paramName |
ISchemaField | schemaField |
System.Object | paramValue |
Returns
Type | Description
System.Data.IDbDataParameter |

Create(String, String, String, Object)

Declaration
public IDbDataParameter Create(string paramName, string tableName, string fieldName, object paramValue)
Parameters
Type | Name | Description
System.String | paramName |
System.String | tableName |
System.String | fieldName |
System.Object | paramValue |
Returns
Type | Description
System.Data.IDbDataParameter |

ShouldStringParameterTypeAndSizeBeSet()

Declaration
public virtual bool ShouldStringParameterTypeAndSizeBeSet()
Returns
Type | Description
System.Boolean |


Namespace FChoice.Foundation.Clarify.DataObjects | fcSDK Documentation

Namespace FChoice.Foundation.Clarify.DataObjects

Classes

ClarifyConfigItem

ClarifyConfigItemCollection

ClarifyDataObject

Country

CountryCollection

DaylightSavingsCollection

DaylightSavingsPeriod

FCString

FCTimeZone

FCTimeZoneCollection

GlobalStringElement

GlobalStringElementCollection

GlobalStringList

GlobalStringListCollection

HierarchicalStringElement

HierarchicalStringElementCollection

HierarchicalStringList

HierarchicalStringListCollection

HierarchicalStringShow

LocalizedString

StateCollection

StateProvince

Interfaces

IGlobalStringElement

IGlobalStringElementCollection

IGlobalStringList

IGlobalStringListCollection

IHierarchicalStringElement

IHierarchicalStringElementCollection

IHierarchicalStringList

IHierarchicalStringListCollection

Back to top © 2022 Dovetail Software, Inc. - All rights reserved.
Clarify, Amdocs, and related products and names are copyright and trademark of Amdocs, Inc.
.NET, Visual Studio.NET, C#, Visual Basic and related products are trademark of Microsoft corporation.


Class ClarifyConfigItem | fcSDK Documentation

Class ClarifyConfigItem

Inheritance
System.Object
DataObject
ConfigItem
ClarifyConfigItem
Implements
IDataObject
Inherited Members
ConfigItem.SetName(String)
ConfigItem.SetIntVal(Int32)
ConfigItem.SetLongVal(Int64)
ConfigItem.SetDateVal(DateTime)
ConfigItem.SetDecVal(Decimal)
ConfigItem.SetDblVal(Double)
ConfigItem.SetStrVal(String)
ConfigItem.SetDescription(String)
ConfigItem.SetValueType(Int32)
ConfigItem.SetScope(ConfigItemScope)
ConfigItem.Name
ConfigItem.ValueTypeRaw
ConfigItem.ValueType
ConfigItem.IntegerValue
ConfigItem.LongValue
ConfigItem.DoubleValue
ConfigItem.DateValue
ConfigItem.DecimalValue
ConfigItem.StringValue
ConfigItem.Scope
ConfigItem.Description
DataObject.SetUniqueID(Object)
DataObject.GetFieldValue(String)
DataObject.GetFieldValue(Int32)
DataObject.ContainsColumn(String)
DataObject.GetSafeInt32FieldValue(String)
DataObject.GetSafeInt32FieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeDoubleFieldValue(String)
DataObject.GetSafeDoubleFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeBooleanFieldValue(String)
DataObject.GetSafeBooleanFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeStringFieldValue(String)
DataObject.SetFieldValue(String, Object)
DataObject.GetSafeString(Object)
DataObject.UniqueID
DataObject.FieldValues
DataObject.ColumnMap
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataObjects
Assembly: fcSDK.dll
Syntax
public class ClarifyConfigItem : ConfigItem, IDataObject

Properties

LastModTime

Declaration
public DateTime LastModTime { get; }
Property Value
Type | Description
System.DateTime |

Implements

IDataObject


Class ClarifyConfigItemCollection | fcSDK Documentation

Class ClarifyConfigItemCollection

Inheritance
System.Object
System.Collections.Generic.List<ConfigItem>
DataObjectCollection<ConfigItem>
ConfigItemCollection
ClarifyConfigItemCollection
Implements
System.Collections.Generic.IList<ConfigItem>
System.Collections.Generic.ICollection<ConfigItem>
System.Collections.IList
System.Collections.ICollection
System.Collections.Generic.IReadOnlyList<ConfigItem>
System.Collections.Generic.IReadOnlyCollection<ConfigItem>
System.Collections.Generic.IEnumerable<ConfigItem>
System.Collections.IEnumerable
Inherited Members
ConfigItemCollection.Create(DataRow)
ConfigItemCollection.Create(Object[])
DataObjectCollection<ConfigItem>.Initialize(DataTable)
DataObjectCollection<ConfigItem>.Initialize(DataRow[])
DataObjectCollection<ConfigItem>.Initialize(Object[][])
DataObjectCollection<ConfigItem>.AddDataObject(ConfigItem)
DataObjectCollection<ConfigItem>.OnDataObjectAdded(ConfigItem)
DataObjectCollection<ConfigItem>.GetItemByIndex(Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.System.Collections.IList.get_Item(System.Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.System.Collections.IList.set_Item(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.Add(FChoice.Foundation.DataObjects.ConfigItem)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.System.Collections.IList.Add(System.Object)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.AddRange(System.Collections.Generic.IEnumerable<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.AsReadOnly()
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.BinarySearch(System.Int32, System.Int32, FChoice.Foundation.DataObjects.ConfigItem, System.Collections.Generic.IComparer<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.BinarySearch(FChoice.Foundation.DataObjects.ConfigItem)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.BinarySearch(FChoice.Foundation.DataObjects.ConfigItem, System.Collections.Generic.IComparer<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.Clear()
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.Contains(FChoice.Foundation.DataObjects.ConfigItem)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.System.Collections.IList.Contains(System.Object)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.ConvertAll<TOutput>(System.Converter<FChoice.Foundation.DataObjects.ConfigItem, TOutput>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.CopyTo(FChoice.Foundation.DataObjects.ConfigItem[])
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.System.Collections.ICollection.CopyTo(System.Array, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.CopyTo(System.Int32, FChoice.Foundation.DataObjects.ConfigItem[], System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.CopyTo(FChoice.Foundation.DataObjects.ConfigItem[], System.Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.Exists(System.Predicate<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.Find(System.Predicate<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.FindAll(System.Predicate<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.FindIndex(System.Predicate<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.FindIndex(System.Int32, System.Predicate<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.FindIndex(System.Int32, System.Int32, System.Predicate<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.FindLast(System.Predicate<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.FindLastIndex(System.Predicate<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.FindLastIndex(System.Int32, System.Predicate<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.FindLastIndex(System.Int32, System.Int32, System.Predicate<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.ForEach(System.Action<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.System.Collections.Generic.IEnumerable<FChoice.Foundation.DataObjects.ConfigItem>.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.System.Collections.IEnumerable.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.GetRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.IndexOf(FChoice.Foundation.DataObjects.ConfigItem)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.System.Collections.IList.IndexOf(System.Object)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.IndexOf(FChoice.Foundation.DataObjects.ConfigItem, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.IndexOf(FChoice.Foundation.DataObjects.ConfigItem, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.Insert(System.Int32, FChoice.Foundation.DataObjects.ConfigItem)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.System.Collections.IList.Insert(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.InsertRange(System.Int32, System.Collections.Generic.IEnumerable<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.LastIndexOf(FChoice.Foundation.DataObjects.ConfigItem)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.LastIndexOf(FChoice.Foundation.DataObjects.ConfigItem, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.LastIndexOf(FChoice.Foundation.DataObjects.ConfigItem, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.Remove(FChoice.Foundation.DataObjects.ConfigItem)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.System.Collections.IList.Remove(System.Object)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.RemoveAll(System.Predicate<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.RemoveAt(System.Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.RemoveRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.Reverse()
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.Reverse(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.Sort()
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.Sort(System.Collections.Generic.IComparer<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.Sort(System.Int32, System.Int32, System.Collections.Generic.IComparer<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.Sort(System.Comparison<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.ToArray()
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.TrimExcess()
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.TrueForAll(System.Predicate<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.Capacity
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.Count
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.System.Collections.IList.IsFixedSize
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.System.Collections.Generic.ICollection<FChoice.Foundation.DataObjects.ConfigItem>.IsReadOnly
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.System.Collections.IList.IsReadOnly
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.System.Collections.ICollection.IsSynchronized
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.System.Collections.ICollection.SyncRoot
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.Item[System.Int32]
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.System.Collections.IList.Item[System.Int32]
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataObjects
Assembly: fcSDK.dll
Syntax
public class ClarifyConfigItemCollection : ConfigItemCollection, IList<ConfigItem>, ICollection<ConfigItem>, IList, ICollection, IReadOnlyList<ConfigItem>, IReadOnlyCollection<ConfigItem>, IEnumerable<ConfigItem>, IEnumerable

Properties

Item[String]

Declaration
public ClarifyConfigItem this[string itemName] { get; }
Parameters
Type | Name | Description
System.String | itemName |
Property Value
Type | Description
ClarifyConfigItem |

Methods

CreateConfigItem(DataRow)

Declaration
protected override ConfigItem CreateConfigItem(DataRow row)
Parameters
Type | Name | Description
System.Data.DataRow | row |
Returns
Type | Description
ConfigItem |
Overrides
ConfigItemCollection.CreateConfigItem(DataRow)

CreateConfigItem(Object[])

Declaration
protected override ConfigItem CreateConfigItem(object[] fieldData)
Parameters
Type | Name | Description
System.Object[] | fieldData |
Returns
Type | Description
ConfigItem |
Overrides
ConfigItemCollection.CreateConfigItem(Object[])

Implements

System.Collections.Generic.IList<T>
System.Collections.Generic.ICollection<T>
System.Collections.IList
System.Collections.ICollection
System.Collections.Generic.IReadOnlyList<T>
System.Collections.Generic.IReadOnlyCollection<T>
System.Collections.Generic.IEnumerable<T>
System.Collections.IEnumerable


Class ClarifyDataObject | fcSDK Documentation

Class ClarifyDataObject

Inheritance
System.Object
DataObject
ClarifyDataObject
Country
DaylightSavingsPeriod
FCString
FCTimeZone
GlobalStringElement
GlobalStringList
HierarchicalStringElement
HierarchicalStringList
HierarchicalStringShow
LocalizedString
StateProvince
SchemaFieldBase
SchemaRelation
SchemaTableBase
SchemaViewFieldInfo
SchemaViewJoin
Implements
IDataObject
Inherited Members
DataObject.SetUniqueID(Object)
DataObject.GetFieldValue(String)
DataObject.GetFieldValue(Int32)
DataObject.ContainsColumn(String)
DataObject.GetSafeInt32FieldValue(String)
DataObject.GetSafeInt32FieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeDoubleFieldValue(String)
DataObject.GetSafeDoubleFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeBooleanFieldValue(String)
DataObject.GetSafeBooleanFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeStringFieldValue(String)
DataObject.SetFieldValue(String, Object)
DataObject.GetSafeString(Object)
DataObject.UniqueID
DataObject.FieldValues
DataObject.ColumnMap
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataObjects
Assembly: fcSDK.dll
Syntax
public abstract class ClarifyDataObject : DataObject, IDataObject

Constructors

ClarifyDataObject(DataRow)

Declaration
protected ClarifyDataObject(DataRow row)
Parameters
Type | Name | Description
System.Data.DataRow | row |

ClarifyDataObject(DataRow, String)

Declaration
protected ClarifyDataObject(DataRow row, string idColumnName)
Parameters
Type | Name | Description
System.Data.DataRow | row |
System.String | idColumnName |

Properties

CommentFieldName

Declaration
public static string CommentFieldName { get; }
Property Value
Type | Description
System.String |

ObjectID

Declaration
public int ObjectID { get; }
Property Value
Type | Description
System.Int32 |

Methods

GetCommentFieldValue(DataRow)

Declaration
protected string GetCommentFieldValue(DataRow row)
Parameters
Type | Name | Description
System.Data.DataRow | row |
Returns
Type | Description
System.String |

Implements

IDataObject


Class Country | fcSDK Documentation

Class Country

Inheritance
System.Object
DataObject
ClarifyDataObject
Country
Implements
IDataObject
Inherited Members
ClarifyDataObject.GetCommentFieldValue(DataRow)
ClarifyDataObject.CommentFieldName
ClarifyDataObject.ObjectID
DataObject.SetUniqueID(Object)
DataObject.GetFieldValue(String)
DataObject.GetFieldValue(Int32)
DataObject.ContainsColumn(String)
DataObject.GetSafeInt32FieldValue(String)
DataObject.GetSafeInt32FieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeDoubleFieldValue(String)
DataObject.GetSafeDoubleFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeBooleanFieldValue(String)
DataObject.GetSafeBooleanFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeStringFieldValue(String)
DataObject.SetFieldValue(String, Object)
DataObject.GetSafeString(Object)
DataObject.UniqueID
DataObject.FieldValues
DataObject.ColumnMap
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataObjects
Assembly: fcSDK.dll
Syntax
public class Country : ClarifyDataObject, IDataObject

Properties

Code

Declaration
public int Code { get; }
Property Value
Type | Description
System.Int32 |

DefaultState

Declaration
public StateProvince DefaultState { get; }
Property Value
Type | Description
StateProvince |

DefaultTimeZone

Declaration
public FCTimeZone DefaultTimeZone { get; }
Property Value
Type | Description
FCTimeZone |

IsDefault

Declaration
public bool IsDefault { get; }
Property Value
Type | Description
System.Boolean |

Name

Declaration
public string Name { get; }
Property Value
Type | Description
System.String |

States

Declaration
public StateCollection States { get; }
Property Value
Type | Description
StateCollection |

TimeZones

Declaration
public FCTimeZoneCollection TimeZones { get; }
Property Value
Type | Description
FCTimeZoneCollection |

Implements

IDataObject


Class CountryCollection | fcSDK Documentation

Class CountryCollection

Inheritance
System.Object
System.Collections.Generic.List<Country>
DataObjectCollection<Country>
CountryCollection
Implements
System.Collections.Generic.IList<Country>
System.Collections.Generic.ICollection<Country>
System.Collections.IList
System.Collections.ICollection
System.Collections.Generic.IReadOnlyList<Country>
System.Collections.Generic.IReadOnlyCollection<Country>
System.Collections.Generic.IEnumerable<Country>
System.Collections.IEnumerable
Inherited Members
DataObjectCollection<Country>.Initialize(DataTable)
DataObjectCollection<Country>.Initialize(DataRow[])
DataObjectCollection<Country>.Initialize(Object[][])
DataObjectCollection<Country>.AddDataObject(Country)
DataObjectCollection<Country>.OnDataObjectAdded(Country)
DataObjectCollection<Country>.Create(Object[])
DataObjectCollection<Country>.GetItemByIndex(Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.System.Collections.IList.get_Item(System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.System.Collections.IList.set_Item(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.Add(FChoice.Foundation.Clarify.DataObjects.Country)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.System.Collections.IList.Add(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.AddRange(System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.DataObjects.Country>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.AsReadOnly()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.BinarySearch(System.Int32, System.Int32, FChoice.Foundation.Clarify.DataObjects.Country, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.DataObjects.Country>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.BinarySearch(FChoice.Foundation.Clarify.DataObjects.Country)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.BinarySearch(FChoice.Foundation.Clarify.DataObjects.Country, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.DataObjects.Country>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.Clear()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.Contains(FChoice.Foundation.Clarify.DataObjects.Country)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.System.Collections.IList.Contains(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.ConvertAll<TOutput>(System.Converter<FChoice.Foundation.Clarify.DataObjects.Country, TOutput>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.CopyTo(FChoice.Foundation.Clarify.DataObjects.Country[])
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.System.Collections.ICollection.CopyTo(System.Array, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.CopyTo(System.Int32, FChoice.Foundation.Clarify.DataObjects.Country[], System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.CopyTo(FChoice.Foundation.Clarify.DataObjects.Country[], System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.Exists(System.Predicate<FChoice.Foundation.Clarify.DataObjects.Country>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.Find(System.Predicate<FChoice.Foundation.Clarify.DataObjects.Country>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.FindAll(System.Predicate<FChoice.Foundation.Clarify.DataObjects.Country>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.FindIndex(System.Predicate<FChoice.Foundation.Clarify.DataObjects.Country>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.FindIndex(System.Int32, System.Predicate<FChoice.Foundation.Clarify.DataObjects.Country>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.FindIndex(System.Int32, System.Int32, System.Predicate<FChoice.Foundation.Clarify.DataObjects.Country>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.FindLast(System.Predicate<FChoice.Foundation.Clarify.DataObjects.Country>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.FindLastIndex(System.Predicate<FChoice.Foundation.Clarify.DataObjects.Country>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.FindLastIndex(System.Int32, System.Predicate<FChoice.Foundation.Clarify.DataObjects.Country>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.FindLastIndex(System.Int32, System.Int32, System.Predicate<FChoice.Foundation.Clarify.DataObjects.Country>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.ForEach(System.Action<FChoice.Foundation.Clarify.DataObjects.Country>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.DataObjects.Country>.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.System.Collections.IEnumerable.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.GetRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.IndexOf(FChoice.Foundation.Clarify.DataObjects.Country)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.System.Collections.IList.IndexOf(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.IndexOf(FChoice.Foundation.Clarify.DataObjects.Country, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.IndexOf(FChoice.Foundation.Clarify.DataObjects.Country, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.Insert(System.Int32, FChoice.Foundation.Clarify.DataObjects.Country)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.System.Collections.IList.Insert(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.InsertRange(System.Int32, System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.DataObjects.Country>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.LastIndexOf(FChoice.Foundation.Clarify.DataObjects.Country)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.LastIndexOf(FChoice.Foundation.Clarify.DataObjects.Country, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.LastIndexOf(FChoice.Foundation.Clarify.DataObjects.Country, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.Remove(FChoice.Foundation.Clarify.DataObjects.Country)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.System.Collections.IList.Remove(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.RemoveAll(System.Predicate<FChoice.Foundation.Clarify.DataObjects.Country>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.RemoveAt(System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.RemoveRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.Reverse()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.Reverse(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.Sort()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.Sort(System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.DataObjects.Country>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.Sort(System.Int32, System.Int32, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.DataObjects.Country>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.Sort(System.Comparison<FChoice.Foundation.Clarify.DataObjects.Country>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.ToArray()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.TrimExcess()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.TrueForAll(System.Predicate<FChoice.Foundation.Clarify.DataObjects.Country>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.Capacity
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.Count
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.System.Collections.IList.IsFixedSize
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.DataObjects.Country>.IsReadOnly
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.System.Collections.IList.IsReadOnly
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.System.Collections.ICollection.IsSynchronized
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.System.Collections.ICollection.SyncRoot
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.Item[System.Int32]
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.Country>.System.Collections.IList.Item[System.Int32]
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataObjects
Assembly: fcSDK.dll
Syntax
public class CountryCollection : DataObjectCollection<Country>, IList<Country>, ICollection<Country>, IList, ICollection, IReadOnlyList<Country>, IReadOnlyCollection<Country>, IEnumerable<Country>, IEnumerable

Properties

DefaultCountry

Declaration
public Country DefaultCountry { get; }
Property Value
Type | Description
Country |

Item[String]

Declaration
public Country this[string countryName] { get; }
Parameters
Type | Name | Description
System.String | countryName |
Property Value
Type | Description
Country |

Methods

Create(DataRow)

Declaration
protected override Country Create(DataRow row)
Parameters
Type | Name | Description
System.Data.DataRow | row |
Returns
Type | Description
Country |
Overrides
FChoice.Foundation.DataObjects.DataObjectCollection<FChoice.Foundation.Clarify.DataObjects.Country>.Create(System.Data.DataRow)

Implements

System.Collections.Generic.IList<T>
System.Collections.Generic.ICollection<T>
System.Collections.IList
System.Collections.ICollection
System.Collections.Generic.IReadOnlyList<T>
System.Collections.Generic.IReadOnlyCollection<T>
System.Collections.Generic.IEnumerable<T>
System.Collections.IEnumerable


Class DaylightSavingsCollection | fcSDK Documentation

Class DaylightSavingsCollection

Inheritance
System.Object
System.Collections.Generic.List<DaylightSavingsPeriod>
DataObjectCollection<DaylightSavingsPeriod>
DaylightSavingsCollection
Implements
System.Collections.Generic.IList<DaylightSavingsPeriod>
System.Collections.Generic.ICollection<DaylightSavingsPeriod>
System.Collections.IList
System.Collections.ICollection
System.Collections.Generic.IReadOnlyList<DaylightSavingsPeriod>
System.Collections.Generic.IReadOnlyCollection<DaylightSavingsPeriod>
System.Collections.Generic.IEnumerable<DaylightSavingsPeriod>
System.Collections.IEnumerable
Inherited Members
DataObjectCollection<DaylightSavingsPeriod>.Initialize(DataTable)
DataObjectCollection<DaylightSavingsPeriod>.Initialize(DataRow[])
DataObjectCollection<DaylightSavingsPeriod>.Initialize(Object[][])
DataObjectCollection<DaylightSavingsPeriod>.AddDataObject(DaylightSavingsPeriod)
DataObjectCollection<DaylightSavingsPeriod>.OnDataObjectAdded(DaylightSavingsPeriod)
DataObjectCollection<DaylightSavingsPeriod>.Create(Object[])
DataObjectCollection<DaylightSavingsPeriod>.GetItemByIndex(Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.System.Collections.IList.get_Item(System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.System.Collections.IList.set_Item(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.Add(FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.System.Collections.IList.Add(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.AddRange(System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.AsReadOnly()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.BinarySearch(System.Int32, System.Int32, FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.BinarySearch(FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.BinarySearch(FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.Clear()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.Contains(FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.System.Collections.IList.Contains(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.ConvertAll<TOutput>(System.Converter<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod, TOutput>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.CopyTo(FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod[])
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.System.Collections.ICollection.CopyTo(System.Array, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.CopyTo(System.Int32, FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod[], System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.CopyTo(FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod[], System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.Exists(System.Predicate<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.Find(System.Predicate<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.FindAll(System.Predicate<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.FindIndex(System.Predicate<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.FindIndex(System.Int32, System.Predicate<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.FindIndex(System.Int32, System.Int32, System.Predicate<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.FindLast(System.Predicate<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.FindLastIndex(System.Predicate<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.FindLastIndex(System.Int32, System.Predicate<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.FindLastIndex(System.Int32, System.Int32, System.Predicate<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.ForEach(System.Action<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.System.Collections.IEnumerable.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.GetRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.IndexOf(FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.System.Collections.IList.IndexOf(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.IndexOf(FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.IndexOf(FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.Insert(System.Int32, FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.System.Collections.IList.Insert(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.InsertRange(System.Int32, System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.LastIndexOf(FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.LastIndexOf(FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.LastIndexOf(FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.Remove(FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.System.Collections.IList.Remove(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.RemoveAll(System.Predicate<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.RemoveAt(System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.RemoveRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.Reverse()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.Reverse(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.Sort()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.Sort(System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.Sort(System.Int32, System.Int32, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.Sort(System.Comparison<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.ToArray()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.TrimExcess()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.TrueForAll(System.Predicate<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.Capacity
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.Count
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.System.Collections.IList.IsFixedSize
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.IsReadOnly
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.System.Collections.IList.IsReadOnly
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.System.Collections.ICollection.IsSynchronized
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.System.Collections.ICollection.SyncRoot
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.Item[System.Int32]
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.System.Collections.IList.Item[System.Int32]
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataObjects
Assembly: fcSDK.dll
Syntax
public class DaylightSavingsCollection : DataObjectCollection<DaylightSavingsPeriod>, IList<DaylightSavingsPeriod>, ICollection<DaylightSavingsPeriod>, IList, ICollection, IReadOnlyList<DaylightSavingsPeriod>, IReadOnlyCollection<DaylightSavingsPeriod>, IEnumerable<DaylightSavingsPeriod>, IEnumerable

Methods

Create(DataRow)

Declaration
protected override DaylightSavingsPeriod Create(DataRow row)
Parameters
Type | Name | Description
System.Data.DataRow | row |
Returns
Type | Description
DaylightSavingsPeriod |
Overrides
FChoice.Foundation.DataObjects.DataObjectCollection<FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod>.Create(System.Data.DataRow)

GetPeriod(DateTime)

Declaration
public DaylightSavingsPeriod GetPeriod(DateTime date)
Parameters
Type | Name | Description
System.DateTime | date |
Returns
Type | Description
DaylightSavingsPeriod |

Implements

System.Collections.Generic.IList<T>
System.Collections.Generic.ICollection<T>
System.Collections.IList
System.Collections.ICollection
System.Collections.Generic.IReadOnlyList<T>
System.Collections.Generic.IReadOnlyCollection<T>
System.Collections.Generic.IEnumerable<T>
System.Collections.IEnumerable


Class DaylightSavingsPeriod | fcSDK Documentation

Class DaylightSavingsPeriod

Inheritance
System.Object
DataObject
ClarifyDataObject
DaylightSavingsPeriod
Implements
IDataObject
Inherited Members
ClarifyDataObject.GetCommentFieldValue(DataRow)
ClarifyDataObject.CommentFieldName
ClarifyDataObject.ObjectID
DataObject.SetUniqueID(Object)
DataObject.GetFieldValue(String)
DataObject.GetFieldValue(Int32)
DataObject.ContainsColumn(String)
DataObject.GetSafeInt32FieldValue(String)
DataObject.GetSafeInt32FieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeDoubleFieldValue(String)
DataObject.GetSafeDoubleFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeBooleanFieldValue(String)
DataObject.GetSafeBooleanFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeStringFieldValue(String)
DataObject.SetFieldValue(String, Object)
DataObject.GetSafeString(Object)
DataObject.UniqueID
DataObject.FieldValues
DataObject.ColumnMap
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataObjects
Assembly: fcSDK.dll
Syntax
public class DaylightSavingsPeriod : ClarifyDataObject, IDataObject

Properties

EndDate

Declaration
public DateTime EndDate { get; }
Property Value
Type | Description
System.DateTime |

StartDate

Declaration
public DateTime StartDate { get; }
Property Value
Type | Description
System.DateTime |

Methods

Intersects(DaylightSavingsPeriod)

Declaration
public bool Intersects(DaylightSavingsPeriod input)
Parameters
Type | Name | Description
DaylightSavingsPeriod | input |
Returns
Type | Description
System.Boolean |

IsDateInRange(DateTime)

Declaration
public bool IsDateInRange(DateTime testDate)
Parameters
Type | Name | Description
System.DateTime | testDate |
Returns
Type | Description
System.Boolean |

Implements

IDataObject


Class FCString | fcSDK Documentation

Class FCString

Inheritance
System.Object
DataObject
ClarifyDataObject
FCString
Implements
IDataObject
Inherited Members
ClarifyDataObject.GetCommentFieldValue(DataRow)
ClarifyDataObject.CommentFieldName
ClarifyDataObject.ObjectID
DataObject.SetUniqueID(Object)
DataObject.GetFieldValue(String)
DataObject.GetFieldValue(Int32)
DataObject.ContainsColumn(String)
DataObject.GetSafeInt32FieldValue(String)
DataObject.GetSafeInt32FieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeDoubleFieldValue(String)
DataObject.GetSafeDoubleFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeBooleanFieldValue(String)
DataObject.GetSafeBooleanFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeStringFieldValue(String)
DataObject.SetFieldValue(String, Object)
DataObject.GetSafeString(Object)
DataObject.UniqueID
DataObject.FieldValues
DataObject.ColumnMap
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataObjects
Assembly: fcSDK.dll
Syntax
public class FCString : ClarifyDataObject, IDataObject

Properties

Application

Declaration
public string Application { get; }
Property Value
Type | Description
System.String |

Culture

Declaration
public CultureInfo Culture { get; }
Property Value
Type | Description
System.Globalization.CultureInfo |

IDKey

Declaration
public string IDKey { get; }
Property Value
Type | Description
System.String |

LocaleName

Declaration
public string LocaleName { get; }
Property Value
Type | Description
System.String |

NameKey

Declaration
public string NameKey { get; }
Property Value
Type | Description
System.String |

StringID

Declaration
public int StringID { get; }
Property Value
Type | Description
System.Int32 |

Value

Declaration
public string Value { get; }
Property Value
Type | Description
System.String |

Methods

GetCultureForCultureName(String, String, String)

Declaration
public static CultureInfo GetCultureForCultureName(string cultureName, string requestingObjType, string itemID)
Parameters
Type | Name | Description
System.String | cultureName |
System.String | requestingObjType |
System.String | itemID |
Returns
Type | Description
System.Globalization.CultureInfo |

Implements

IDataObject


Class FCTimeZone | fcSDK Documentation

Class FCTimeZone

Inheritance
System.Object
DataObject
ClarifyDataObject
FCTimeZone
FakeTimeZone
Implements
IDataObject
ITimeZone
Inherited Members
ClarifyDataObject.GetCommentFieldValue(DataRow)
ClarifyDataObject.CommentFieldName
ClarifyDataObject.ObjectID
DataObject.SetUniqueID(Object)
DataObject.GetFieldValue(String)
DataObject.GetFieldValue(Int32)
DataObject.ContainsColumn(String)
DataObject.GetSafeInt32FieldValue(String)
DataObject.GetSafeInt32FieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeDoubleFieldValue(String)
DataObject.GetSafeDoubleFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeBooleanFieldValue(String)
DataObject.GetSafeBooleanFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeStringFieldValue(String)
DataObject.SetFieldValue(String, Object)
DataObject.GetSafeString(Object)
DataObject.UniqueID
DataObject.FieldValues
DataObject.ColumnMap
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataObjects
Assembly: fcSDK.dll
Syntax
public class FCTimeZone : ClarifyDataObject, IDataObject, ITimeZone

Properties

DaylightSavingsPeriods

Declaration
public DaylightSavingsCollection DaylightSavingsPeriods { get; protected set; }
Property Value
Type | Description
DaylightSavingsCollection |

FullName

Declaration
public string FullName { get; }
Property Value
Type | Description
System.String |

IsDefault

Declaration
public bool IsDefault { get; }
Property Value
Type | Description
System.Boolean |

Name

Declaration
public string Name { get; }
Property Value
Type | Description
System.String |

UtcOffsetSeconds

Declaration
public int UtcOffsetSeconds { get; }
Property Value
Type | Description
System.Int32 |

Methods

ConvertDate(DateTime, ITimeZone)

Declaration
public DateTime ConvertDate(DateTime date, ITimeZone toZone)
Parameters
Type | Name | Description
System.DateTime | date |
ITimeZone | toZone |
Returns
Type | Description
System.DateTime |

ConvertDate(DateTime, ITimeZone, ITimeZone)

Declaration
public static DateTime ConvertDate(DateTime date, ITimeZone fromZone, ITimeZone toZone)
Parameters
Type | Name | Description
System.DateTime | date |
ITimeZone | fromZone |
ITimeZone | toZone |
Returns
Type | Description
System.DateTime |

IsDaylightSavingsTime(DateTime)

Declaration
public bool IsDaylightSavingsTime(DateTime testDate)
Parameters
Type | Name | Description
System.DateTime | testDate |
Returns
Type | Description
System.Boolean |

Implements

IDataObject
ITimeZone


Class FCTimeZoneCollection | fcSDK Documentation

Class FCTimeZoneCollection

Inheritance
System.Object
System.Collections.Generic.List<FCTimeZone>
DataObjectCollection<FCTimeZone>
FCTimeZoneCollection
Implements
System.Collections.Generic.IList<FCTimeZone>
System.Collections.Generic.ICollection<FCTimeZone>
System.Collections.IList
System.Collections.ICollection
System.Collections.Generic.IReadOnlyList<FCTimeZone>
System.Collections.Generic.IReadOnlyCollection<FCTimeZone>
System.Collections.Generic.IEnumerable<FCTimeZone>
System.Collections.IEnumerable
Inherited Members
DataObjectCollection<FCTimeZone>.Initialize(DataTable)
DataObjectCollection<FCTimeZone>.Initialize(DataRow[])
DataObjectCollection<FCTimeZone>.Initialize(Object[][])
DataObjectCollection<FCTimeZone>.AddDataObject(FCTimeZone)
DataObjectCollection<FCTimeZone>.OnDataObjectAdded(FCTimeZone)
DataObjectCollection<FCTimeZone>.Create(Object[])
DataObjectCollection<FCTimeZone>.GetItemByIndex(Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.System.Collections.IList.get_Item(System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.System.Collections.IList.set_Item(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.Add(FChoice.Foundation.Clarify.DataObjects.FCTimeZone)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.System.Collections.IList.Add(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.AddRange(System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.AsReadOnly()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.BinarySearch(System.Int32, System.Int32, FChoice.Foundation.Clarify.DataObjects.FCTimeZone, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.BinarySearch(FChoice.Foundation.Clarify.DataObjects.FCTimeZone)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.BinarySearch(FChoice.Foundation.Clarify.DataObjects.FCTimeZone, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.Clear()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.Contains(FChoice.Foundation.Clarify.DataObjects.FCTimeZone)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.System.Collections.IList.Contains(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.ConvertAll<TOutput>(System.Converter<FChoice.Foundation.Clarify.DataObjects.FCTimeZone, TOutput>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.CopyTo(FChoice.Foundation.Clarify.DataObjects.FCTimeZone[])
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.System.Collections.ICollection.CopyTo(System.Array, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.CopyTo(System.Int32, FChoice.Foundation.Clarify.DataObjects.FCTimeZone[], System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.CopyTo(FChoice.Foundation.Clarify.DataObjects.FCTimeZone[], System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.Exists(System.Predicate<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.Find(System.Predicate<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.FindAll(System.Predicate<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.FindIndex(System.Predicate<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.FindIndex(System.Int32, System.Predicate<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.FindIndex(System.Int32, System.Int32, System.Predicate<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.FindLast(System.Predicate<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.FindLastIndex(System.Predicate<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.FindLastIndex(System.Int32, System.Predicate<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.FindLastIndex(System.Int32, System.Int32, System.Predicate<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.ForEach(System.Action<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.System.Collections.IEnumerable.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.GetRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.IndexOf(FChoice.Foundation.Clarify.DataObjects.FCTimeZone)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.System.Collections.IList.IndexOf(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.IndexOf(FChoice.Foundation.Clarify.DataObjects.FCTimeZone, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.IndexOf(FChoice.Foundation.Clarify.DataObjects.FCTimeZone, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.Insert(System.Int32, FChoice.Foundation.Clarify.DataObjects.FCTimeZone)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.System.Collections.IList.Insert(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.InsertRange(System.Int32, System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.LastIndexOf(FChoice.Foundation.Clarify.DataObjects.FCTimeZone)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.LastIndexOf(FChoice.Foundation.Clarify.DataObjects.FCTimeZone, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.LastIndexOf(FChoice.Foundation.Clarify.DataObjects.FCTimeZone, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.Remove(FChoice.Foundation.Clarify.DataObjects.FCTimeZone)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.System.Collections.IList.Remove(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.RemoveAll(System.Predicate<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.RemoveAt(System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.RemoveRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.Reverse()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.Reverse(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.Sort()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.Sort(System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.Sort(System.Int32, System.Int32, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.Sort(System.Comparison<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.ToArray()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.TrimExcess()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.TrueForAll(System.Predicate<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.Capacity
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.Count
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.System.Collections.IList.IsFixedSize
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.IsReadOnly
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.System.Collections.IList.IsReadOnly
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.System.Collections.ICollection.IsSynchronized
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.System.Collections.ICollection.SyncRoot
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.Item[System.Int32]
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.System.Collections.IList.Item[System.Int32]
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataObjects
Assembly: fcSDK.dll
Syntax
public class FCTimeZoneCollection : DataObjectCollection<FCTimeZone>, IList<FCTimeZone>, ICollection<FCTimeZone>, IList, ICollection, IReadOnlyList<FCTimeZone>, IReadOnlyCollection<FCTimeZone>, IEnumerable<FCTimeZone>, IEnumerable

Properties

DefaultTimeZone

Declaration
public FCTimeZone DefaultTimeZone { get; set; }
Property Value
Type | Description
FCTimeZone |

Item[String, Boolean]

Declaration
public FCTimeZone this[string name, bool isFullName] { get; }
Parameters
Type | Name | Description
System.String | name |
System.Boolean | isFullName |
Property Value
Type | Description
FCTimeZone |

Methods

Contains(String, Boolean)

Declaration
public bool Contains(string name, bool isFullName)
Parameters
Type | Name | Description
System.String | name |
System.Boolean | isFullName |
Returns
Type | Description
System.Boolean |

Create(DataRow)

Declaration
protected override FCTimeZone Create(DataRow row)
Parameters
Type | Name | Description
System.Data.DataRow | row |
Returns
Type | Description
FCTimeZone |
Overrides
FChoice.Foundation.DataObjects.DataObjectCollection<FChoice.Foundation.Clarify.DataObjects.FCTimeZone>.Create(System.Data.DataRow)

Implements

System.Collections.Generic.IList<T>
System.Collections.Generic.ICollection<T>
System.Collections.IList
System.Collections.ICollection
System.Collections.Generic.IReadOnlyList<T>
System.Collections.Generic.IReadOnlyCollection<T>
System.Collections.Generic.IEnumerable<T>
System.Collections.IEnumerable


Class GlobalStringElement | fcSDK Documentation

Class GlobalStringElement

Inheritance
System.Object
DataObject
ClarifyDataObject
GlobalStringElement
Implements
IGlobalStringElement
IDataObject
Inherited Members
ClarifyDataObject.GetCommentFieldValue(DataRow)
ClarifyDataObject.CommentFieldName
ClarifyDataObject.ObjectID
DataObject.SetUniqueID(Object)
DataObject.GetFieldValue(String)
DataObject.GetFieldValue(Int32)
DataObject.ContainsColumn(String)
DataObject.GetSafeInt32FieldValue(String)
DataObject.GetSafeInt32FieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeDoubleFieldValue(String)
DataObject.GetSafeDoubleFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeBooleanFieldValue(String)
DataObject.GetSafeBooleanFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeStringFieldValue(String)
DataObject.SetFieldValue(String, Object)
DataObject.GetSafeString(Object)
DataObject.UniqueID
DataObject.FieldValues
DataObject.ColumnMap
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataObjects
Assembly: fcSDK.dll
Syntax
public class GlobalStringElement : ClarifyDataObject, IGlobalStringElement, IDataObject

Properties

AdditionalInfo

Declaration
public string AdditionalInfo { get; }
Property Value
Type | Description
System.String |

Description

Declaration
public string Description { get; }
Property Value
Type | Description
System.String |

LocalizedTitle

Declaration
public string LocalizedTitle { get; }
Property Value
Type | Description
System.String |

Rank

Declaration
public int Rank { get; }
Property Value
Type | Description
System.Int32 |

State

Declaration
public int State { get; }
Property Value
Type | Description
System.Int32 |

Title

Declaration
public string Title { get; }
Property Value
Type | Description
System.String |

Methods

GetLocalizedTitle(CultureInfo)

Declaration
public string GetLocalizedTitle(CultureInfo specificCulture)
Parameters
Type | Name | Description
System.Globalization.CultureInfo | specificCulture |
Returns
Type | Description
System.String |

Implements

IGlobalStringElement
IDataObject


Class GlobalStringElementCollection | fcSDK Documentation

Class GlobalStringElementCollection

Inheritance
System.Object
System.Collections.Generic.List<IGlobalStringElement>
DataObjectCollection<IGlobalStringElement>
GlobalStringElementCollection
Implements
System.Collections.IList
System.Collections.ICollection
System.Collections.Generic.IReadOnlyList<IGlobalStringElement>
System.Collections.Generic.IReadOnlyCollection<IGlobalStringElement>
IGlobalStringElementCollection
System.Collections.Generic.IList<IGlobalStringElement>
System.Collections.Generic.ICollection<IGlobalStringElement>
System.Collections.Generic.IEnumerable<IGlobalStringElement>
System.Collections.IEnumerable
Inherited Members
DataObjectCollection<IGlobalStringElement>.Initialize(DataTable)
DataObjectCollection<IGlobalStringElement>.Initialize(DataRow[])
DataObjectCollection<IGlobalStringElement>.Initialize(Object[][])
DataObjectCollection<IGlobalStringElement>.AddDataObject(IGlobalStringElement)
DataObjectCollection<IGlobalStringElement>.OnDataObjectAdded(IGlobalStringElement)
DataObjectCollection<IGlobalStringElement>.Create(Object[])
DataObjectCollection<IGlobalStringElement>.GetItemByIndex(Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.System.Collections.IList.get_Item(System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.System.Collections.IList.set_Item(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.Add(FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.System.Collections.IList.Add(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.AddRange(System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.AsReadOnly()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.BinarySearch(System.Int32, System.Int32, FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.BinarySearch(FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.BinarySearch(FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.Clear()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.Contains(FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.System.Collections.IList.Contains(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.ConvertAll<TOutput>(System.Converter<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement, TOutput>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.CopyTo(FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement[])
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.System.Collections.ICollection.CopyTo(System.Array, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.CopyTo(System.Int32, FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement[], System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.CopyTo(FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement[], System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.Exists(System.Predicate<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.Find(System.Predicate<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.FindAll(System.Predicate<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.FindIndex(System.Predicate<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.FindIndex(System.Int32, System.Predicate<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.FindIndex(System.Int32, System.Int32, System.Predicate<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.FindLast(System.Predicate<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.FindLastIndex(System.Predicate<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.FindLastIndex(System.Int32, System.Predicate<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.FindLastIndex(System.Int32, System.Int32, System.Predicate<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.ForEach(System.Action<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.System.Collections.IEnumerable.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.GetRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.IndexOf(FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.System.Collections.IList.IndexOf(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.IndexOf(FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.IndexOf(FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.Insert(System.Int32, FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.System.Collections.IList.Insert(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.InsertRange(System.Int32, System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.LastIndexOf(FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.LastIndexOf(FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.LastIndexOf(FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.Remove(FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.System.Collections.IList.Remove(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.RemoveAll(System.Predicate<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.RemoveAt(System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.RemoveRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.Reverse()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.Reverse(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.Sort()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.Sort(System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.Sort(System.Int32, System.Int32, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.Sort(System.Comparison<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.ToArray()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.TrimExcess()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.TrueForAll(System.Predicate<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.Capacity
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.Count
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.System.Collections.IList.IsFixedSize
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.IsReadOnly
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.System.Collections.IList.IsReadOnly
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.System.Collections.ICollection.IsSynchronized
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.System.Collections.ICollection.SyncRoot
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.Item[System.Int32]
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.System.Collections.IList.Item[System.Int32]
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataObjects
Assembly: fcSDK.dll
Syntax
public class GlobalStringElementCollection : DataObjectCollection<IGlobalStringElement>, IList, ICollection, IReadOnlyList<IGlobalStringElement>, IReadOnlyCollection<IGlobalStringElement>, IGlobalStringElementCollection, IList<IGlobalStringElement>, ICollection<IGlobalStringElement>, IEnumerable<IGlobalStringElement>, IEnumerable

Properties

ActiveElements

Declaration
public IGlobalStringElementCollection ActiveElements { get; }
Property Value
Type | Description
IGlobalStringElementCollection |

DefaultElement

Declaration
public IGlobalStringElement DefaultElement { get; }
Property Value
Type | Description
IGlobalStringElement |

InactiveElements

Declaration
public IGlobalStringElementCollection InactiveElements { get; }
Property Value
Type | Description
IGlobalStringElementCollection |

Item[String]

Declaration
public IGlobalStringElement this[string title] { get; }
Parameters
Type | Name | Description
System.String | title |
Property Value
Type | Description
IGlobalStringElement |

Methods

AddElement(IGlobalStringElement, Boolean)

Declaration
public void AddElement(IGlobalStringElement element, bool addToList)
Parameters
Type | Name | Description
IGlobalStringElement | element |
System.Boolean | addToList |

Create(DataRow)

Declaration
protected override IGlobalStringElement Create(DataRow row)
Parameters
Type | Name | Description
System.Data.DataRow | row |
Returns
Type | Description
IGlobalStringElement |
Overrides
FChoice.Foundation.DataObjects.DataObjectCollection<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.Create(System.Data.DataRow)

GetElementByObjectId(Int32)

Declaration
public IGlobalStringElement GetElementByObjectId(int objectId)
Parameters
Type | Name | Description
System.Int32 | objectId |
Returns
Type | Description
IGlobalStringElement |

GetElementByRank(Int32)

Declaration
public IGlobalStringElement GetElementByRank(int rank)
Parameters
Type | Name | Description
System.Int32 | rank |
Returns
Type | Description
IGlobalStringElement |

Explicit Interface Implementations

IGlobalStringElementCollection.AddRange(IEnumerable<IGlobalStringElement>)

Declaration
void IGlobalStringElementCollection.AddRange(IEnumerable<IGlobalStringElement> collection)
Parameters
Type | Name | Description
System.Collections.Generic.IEnumerable<IGlobalStringElement> | collection |

IGlobalStringElementCollection.AsReadOnly()

Declaration
ReadOnlyCollection<IGlobalStringElement> IGlobalStringElementCollection.AsReadOnly()
Returns
Type | Description
System.Collections.ObjectModel.ReadOnlyCollection<IGlobalStringElement> |

IGlobalStringElementCollection.BinarySearch(IGlobalStringElement)

Declaration
int IGlobalStringElementCollection.BinarySearch(IGlobalStringElement item)
Parameters
Type | Name | Description
IGlobalStringElement | item |
Returns
Type | Description
System.Int32 |

IGlobalStringElementCollection.BinarySearch(IGlobalStringElement, IComparer<IGlobalStringElement>)

Declaration
int IGlobalStringElementCollection.BinarySearch(IGlobalStringElement item, IComparer<IGlobalStringElement> comparer)
Parameters
Type | Name | Description
IGlobalStringElement | item |
System.Collections.Generic.IComparer<IGlobalStringElement> | comparer |
Returns
Type | Description
System.Int32 |

IGlobalStringElementCollection.BinarySearch(Int32, Int32, IGlobalStringElement, IComparer<IGlobalStringElement>)

Declaration
int IGlobalStringElementCollection.BinarySearch(int index, int count, IGlobalStringElement item, IComparer<IGlobalStringElement> comparer)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |
IGlobalStringElement | item |
System.Collections.Generic.IComparer<IGlobalStringElement> | comparer |
Returns
Type | Description
System.Int32 |

IGlobalStringElementCollection.CopyTo(IGlobalStringElement[])

Declaration
void IGlobalStringElementCollection.CopyTo(IGlobalStringElement[] array)
Parameters
Type | Name | Description
IGlobalStringElement[] | array |

IGlobalStringElementCollection.CopyTo(Int32, IGlobalStringElement[], Int32, Int32)

Declaration
void IGlobalStringElementCollection.CopyTo(int index, IGlobalStringElement[] array, int arrayIndex, int count)
Parameters
Type | Name | Description
System.Int32 | index |
IGlobalStringElement[] | array |
System.Int32 | arrayIndex |
System.Int32 | count |

IGlobalStringElementCollection.Exists(Predicate<IGlobalStringElement>)

Declaration
bool IGlobalStringElementCollection.Exists(Predicate<IGlobalStringElement> match)
Parameters
Type | Name | Description
System.Predicate<IGlobalStringElement> | match |
Returns
Type | Description
System.Boolean |

IGlobalStringElementCollection.Find(Predicate<IGlobalStringElement>)

Declaration
IGlobalStringElement IGlobalStringElementCollection.Find(Predicate<IGlobalStringElement> match)
Parameters
Type | Name | Description
System.Predicate<IGlobalStringElement> | match |
Returns
Type | Description
IGlobalStringElement |

IGlobalStringElementCollection.FindAll(Predicate<IGlobalStringElement>)

Declaration
List<IGlobalStringElement> IGlobalStringElementCollection.FindAll(Predicate<IGlobalStringElement> match)
Parameters
Type | Name | Description
System.Predicate<IGlobalStringElement> | match |
Returns
Type | Description
System.Collections.Generic.List<IGlobalStringElement> |

IGlobalStringElementCollection.FindIndex(Int32, Int32, Predicate<IGlobalStringElement>)

Declaration
int IGlobalStringElementCollection.FindIndex(int startIndex, int count, Predicate<IGlobalStringElement> match)
Parameters
Type | Name | Description
System.Int32 | startIndex |
System.Int32 | count |
System.Predicate<IGlobalStringElement> | match |
Returns
Type | Description
System.Int32 |

IGlobalStringElementCollection.FindIndex(Int32, Predicate<IGlobalStringElement>)

Declaration
int IGlobalStringElementCollection.FindIndex(int startIndex, Predicate<IGlobalStringElement> match)
Parameters
Type | Name | Description
System.Int32 | startIndex |
System.Predicate<IGlobalStringElement> | match |
Returns
Type | Description
System.Int32 |

IGlobalStringElementCollection.FindIndex(Predicate<IGlobalStringElement>)

Declaration
int IGlobalStringElementCollection.FindIndex(Predicate<IGlobalStringElement> match)
Parameters
Type | Name | Description
System.Predicate<IGlobalStringElement> | match |
Returns
Type | Description
System.Int32 |

IGlobalStringElementCollection.FindLast(Predicate<IGlobalStringElement>)

Declaration
IGlobalStringElement IGlobalStringElementCollection.FindLast(Predicate<IGlobalStringElement> match)
Parameters
Type | Name | Description
System.Predicate<IGlobalStringElement> | match |
Returns
Type | Description
IGlobalStringElement |

IGlobalStringElementCollection.FindLastIndex(Int32, Int32, Predicate<IGlobalStringElement>)

Declaration
int IGlobalStringElementCollection.FindLastIndex(int startIndex, int count, Predicate<IGlobalStringElement> match)
Parameters
Type | Name | Description
System.Int32 | startIndex |
System.Int32 | count |
System.Predicate<IGlobalStringElement> | match |
Returns
Type | Description
System.Int32 |

IGlobalStringElementCollection.FindLastIndex(Int32, Predicate<IGlobalStringElement>)

Declaration
int IGlobalStringElementCollection.FindLastIndex(int startIndex, Predicate<IGlobalStringElement> match)
Parameters
Type | Name | Description
System.Int32 | startIndex |
System.Predicate<IGlobalStringElement> | match |
Returns
Type | Description
System.Int32 |

IGlobalStringElementCollection.FindLastIndex(Predicate<IGlobalStringElement>)

Declaration
int IGlobalStringElementCollection.FindLastIndex(Predicate<IGlobalStringElement> match)
Parameters
Type | Name | Description
System.Predicate<IGlobalStringElement> | match |
Returns
Type | Description
System.Int32 |

IGlobalStringElementCollection.ForEach(Action<IGlobalStringElement>)

Declaration
void IGlobalStringElementCollection.ForEach(Action<IGlobalStringElement> action)
Parameters
Type | Name | Description
System.Action<IGlobalStringElement> | action |

IGlobalStringElementCollection.get_Capacity()

Declaration
int IGlobalStringElementCollection.get_Capacity()
Returns
Type | Description
System.Int32 |

IGlobalStringElementCollection.GetRange(Int32, Int32)

Declaration
List<IGlobalStringElement> IGlobalStringElementCollection.GetRange(int index, int count)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |
Returns
Type | Description
System.Collections.Generic.List<IGlobalStringElement> |

IGlobalStringElementCollection.IndexOf(IGlobalStringElement, Int32)

Declaration
int IGlobalStringElementCollection.IndexOf(IGlobalStringElement item, int index)
Parameters
Type | Name | Description
IGlobalStringElement | item |
System.Int32 | index |
Returns
Type | Description
System.Int32 |

IGlobalStringElementCollection.IndexOf(IGlobalStringElement, Int32, Int32)

Declaration
int IGlobalStringElementCollection.IndexOf(IGlobalStringElement item, int index, int count)
Parameters
Type | Name | Description
IGlobalStringElement | item |
System.Int32 | index |
System.Int32 | count |
Returns
Type | Description
System.Int32 |

IGlobalStringElementCollection.InsertRange(Int32, IEnumerable<IGlobalStringElement>)

Declaration
void IGlobalStringElementCollection.InsertRange(int index, IEnumerable<IGlobalStringElement> collection)
Parameters
Type | Name | Description
System.Int32 | index |
System.Collections.Generic.IEnumerable<IGlobalStringElement> | collection |

IGlobalStringElementCollection.LastIndexOf(IGlobalStringElement)

Declaration
int IGlobalStringElementCollection.LastIndexOf(IGlobalStringElement item)
Parameters
Type | Name | Description
IGlobalStringElement | item |
Returns
Type | Description
System.Int32 |

IGlobalStringElementCollection.LastIndexOf(IGlobalStringElement, Int32)

Declaration
int IGlobalStringElementCollection.LastIndexOf(IGlobalStringElement item, int index)
Parameters
Type | Name | Description
IGlobalStringElement | item |
System.Int32 | index |
Returns
Type | Description
System.Int32 |

IGlobalStringElementCollection.LastIndexOf(IGlobalStringElement, Int32, Int32)

Declaration
int IGlobalStringElementCollection.LastIndexOf(IGlobalStringElement item, int index, int count)
Parameters
Type | Name | Description
IGlobalStringElement | item |
System.Int32 | index |
System.Int32 | count |
Returns
Type | Description
System.Int32 |

IGlobalStringElementCollection.RemoveAll(Predicate<IGlobalStringElement>)

Declaration
int IGlobalStringElementCollection.RemoveAll(Predicate<IGlobalStringElement> match)
Parameters
Type | Name | Description
System.Predicate<IGlobalStringElement> | match |
Returns
Type | Description
System.Int32 |

IGlobalStringElementCollection.RemoveRange(Int32, Int32)

Declaration
void IGlobalStringElementCollection.RemoveRange(int index, int count)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |

IGlobalStringElementCollection.Reverse()

Declaration
void IGlobalStringElementCollection.Reverse()

IGlobalStringElementCollection.Reverse(Int32, Int32)

Declaration
void IGlobalStringElementCollection.Reverse(int index, int count)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |

IGlobalStringElementCollection.set_Capacity(Int32)

Declaration
void IGlobalStringElementCollection.set_Capacity(int value)
Parameters
Type | Name | Description
System.Int32 | value |

IGlobalStringElementCollection.Sort()

Declaration
void IGlobalStringElementCollection.Sort()

IGlobalStringElementCollection.Sort(IComparer<IGlobalStringElement>)

Declaration
void IGlobalStringElementCollection.Sort(IComparer<IGlobalStringElement> comparer)
Parameters
Type | Name | Description
System.Collections.Generic.IComparer<IGlobalStringElement> | comparer |

IGlobalStringElementCollection.Sort(Comparison<IGlobalStringElement>)

Declaration
void IGlobalStringElementCollection.Sort(Comparison<IGlobalStringElement> comparison)
Parameters
Type | Name | Description
System.Comparison<IGlobalStringElement> | comparison |

IGlobalStringElementCollection.Sort(Int32, Int32, IComparer<IGlobalStringElement>)

Declaration
void IGlobalStringElementCollection.Sort(int index, int count, IComparer<IGlobalStringElement> comparer)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |
System.Collections.Generic.IComparer<IGlobalStringElement> | comparer |

IGlobalStringElementCollection.ToArray()

Declaration
IGlobalStringElement[] IGlobalStringElementCollection.ToArray()
Returns
Type | Description
IGlobalStringElement[] |

IGlobalStringElementCollection.TrimExcess()

Declaration
void IGlobalStringElementCollection.TrimExcess()

IGlobalStringElementCollection.TrueForAll(Predicate<IGlobalStringElement>)

Declaration
bool IGlobalStringElementCollection.TrueForAll(Predicate<IGlobalStringElement> match)
Parameters
Type | Name | Description
System.Predicate<IGlobalStringElement> | match |
Returns
Type | Description
System.Boolean |

Implements

System.Collections.IList
System.Collections.ICollection
System.Collections.Generic.IReadOnlyList<T>
System.Collections.Generic.IReadOnlyCollection<T>
IGlobalStringElementCollection
System.Collections.Generic.IList<T>
System.Collections.Generic.ICollection<T>
System.Collections.Generic.IEnumerable<T>
System.Collections.IEnumerable


Class GlobalStringList | fcSDK Documentation

Class GlobalStringList

Inheritance
System.Object
DataObject
ClarifyDataObject
GlobalStringList
Implements
IGlobalStringList
IDataObject
Inherited Members
ClarifyDataObject.GetCommentFieldValue(DataRow)
ClarifyDataObject.CommentFieldName
ClarifyDataObject.ObjectID
DataObject.SetUniqueID(Object)
DataObject.GetFieldValue(String)
DataObject.GetFieldValue(Int32)
DataObject.ContainsColumn(String)
DataObject.GetSafeInt32FieldValue(String)
DataObject.GetSafeInt32FieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeDoubleFieldValue(String)
DataObject.GetSafeDoubleFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeBooleanFieldValue(String)
DataObject.GetSafeBooleanFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeStringFieldValue(String)
DataObject.SetFieldValue(String, Object)
DataObject.GetSafeString(Object)
DataObject.UniqueID
DataObject.FieldValues
DataObject.ColumnMap
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataObjects
Assembly: fcSDK.dll
Syntax
public class GlobalStringList : ClarifyDataObject, IGlobalStringList, IDataObject

Properties

ActiveElements

Declaration
public IGlobalStringElementCollection ActiveElements { get; }
Property Value
Type | Description
IGlobalStringElementCollection |

AdditionalInfo

Declaration
public string AdditionalInfo { get; }
Property Value
Type | Description
System.String |

DefaultElement

Declaration
public IGlobalStringElement DefaultElement { get; }
Property Value
Type | Description
IGlobalStringElement |

Elements

Declaration
public IGlobalStringElementCollection Elements { get; }
Property Value
Type | Description
IGlobalStringElementCollection |

InactiveElements

Declaration
public IGlobalStringElementCollection InactiveElements { get; }
Property Value
Type | Description
IGlobalStringElementCollection |

ListID

Declaration
public int ListID { get; }
Property Value
Type | Description
System.Int32 |

LocaleID

Declaration
public int LocaleID { get; }
Property Value
Type | Description
System.Int32 |

Title

Declaration
public string Title { get; }
Property Value
Type | Description
System.String |

Implements

IGlobalStringList
IDataObject


Class GlobalStringListCollection | fcSDK Documentation

Class GlobalStringListCollection

Inheritance
System.Object
System.Collections.Generic.List<IGlobalStringList>
DataObjectCollection<IGlobalStringList>
GlobalStringListCollection
Implements
System.Collections.Generic.IList<IGlobalStringList>
System.Collections.IList
System.Collections.ICollection
System.Collections.Generic.IReadOnlyList<IGlobalStringList>
System.Collections.Generic.IReadOnlyCollection<IGlobalStringList>
IGlobalStringListCollection
System.Collections.Generic.ICollection<IGlobalStringList>
System.Collections.Generic.IEnumerable<IGlobalStringList>
System.Collections.IEnumerable
Inherited Members
DataObjectCollection<IGlobalStringList>.Initialize(DataTable)
DataObjectCollection<IGlobalStringList>.Initialize(DataRow[])
DataObjectCollection<IGlobalStringList>.Initialize(Object[][])
DataObjectCollection<IGlobalStringList>.AddDataObject(IGlobalStringList)
DataObjectCollection<IGlobalStringList>.OnDataObjectAdded(IGlobalStringList)
DataObjectCollection<IGlobalStringList>.Create(Object[])
DataObjectCollection<IGlobalStringList>.GetItemByIndex(Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.System.Collections.IList.get_Item(System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.System.Collections.IList.set_Item(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.Add(FChoice.Foundation.Clarify.DataObjects.IGlobalStringList)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.System.Collections.IList.Add(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.AddRange(System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.AsReadOnly()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.BinarySearch(System.Int32, System.Int32, FChoice.Foundation.Clarify.DataObjects.IGlobalStringList, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.BinarySearch(FChoice.Foundation.Clarify.DataObjects.IGlobalStringList)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.BinarySearch(FChoice.Foundation.Clarify.DataObjects.IGlobalStringList, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.Clear()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.Contains(FChoice.Foundation.Clarify.DataObjects.IGlobalStringList)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.System.Collections.IList.Contains(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.ConvertAll<TOutput>(System.Converter<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList, TOutput>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.CopyTo(FChoice.Foundation.Clarify.DataObjects.IGlobalStringList[])
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.System.Collections.ICollection.CopyTo(System.Array, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.CopyTo(System.Int32, FChoice.Foundation.Clarify.DataObjects.IGlobalStringList[], System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.CopyTo(FChoice.Foundation.Clarify.DataObjects.IGlobalStringList[], System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.Exists(System.Predicate<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.Find(System.Predicate<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.FindAll(System.Predicate<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.FindIndex(System.Predicate<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.FindIndex(System.Int32, System.Predicate<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.FindIndex(System.Int32, System.Int32, System.Predicate<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.FindLast(System.Predicate<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.FindLastIndex(System.Predicate<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.FindLastIndex(System.Int32, System.Predicate<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.FindLastIndex(System.Int32, System.Int32, System.Predicate<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.ForEach(System.Action<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.System.Collections.IEnumerable.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.GetRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.IndexOf(FChoice.Foundation.Clarify.DataObjects.IGlobalStringList)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.System.Collections.IList.IndexOf(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.IndexOf(FChoice.Foundation.Clarify.DataObjects.IGlobalStringList, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.IndexOf(FChoice.Foundation.Clarify.DataObjects.IGlobalStringList, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.Insert(System.Int32, FChoice.Foundation.Clarify.DataObjects.IGlobalStringList)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.System.Collections.IList.Insert(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.InsertRange(System.Int32, System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.LastIndexOf(FChoice.Foundation.Clarify.DataObjects.IGlobalStringList)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.LastIndexOf(FChoice.Foundation.Clarify.DataObjects.IGlobalStringList, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.LastIndexOf(FChoice.Foundation.Clarify.DataObjects.IGlobalStringList, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.Remove(FChoice.Foundation.Clarify.DataObjects.IGlobalStringList)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.System.Collections.IList.Remove(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.RemoveAll(System.Predicate<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.RemoveAt(System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.RemoveRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.Reverse()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.Reverse(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.Sort()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.Sort(System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.Sort(System.Int32, System.Int32, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.Sort(System.Comparison<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.ToArray()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.TrimExcess()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.TrueForAll(System.Predicate<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.Capacity
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.Count
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.System.Collections.IList.IsFixedSize
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.IsReadOnly
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.System.Collections.IList.IsReadOnly
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.System.Collections.ICollection.IsSynchronized
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.System.Collections.ICollection.SyncRoot
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.Item[System.Int32]
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.System.Collections.IList.Item[System.Int32]
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataObjects
Assembly: fcSDK.dll
Syntax
public class GlobalStringListCollection : DataObjectCollection<IGlobalStringList>, IList<IGlobalStringList>, IList, ICollection, IReadOnlyList<IGlobalStringList>, IReadOnlyCollection<IGlobalStringList>, IGlobalStringListCollection, ICollection<IGlobalStringList>, IEnumerable<IGlobalStringList>, IEnumerable

Properties

Item[String]

Declaration
public IGlobalStringList this[string title] { get; }
Parameters
Type | Name | Description
System.String | title |
Property Value
Type | Description
IGlobalStringList |

Methods

Create(DataRow)

Declaration
protected override IGlobalStringList Create(DataRow row)
Parameters
Type | Name | Description
System.Data.DataRow | row |
Returns
Type | Description
IGlobalStringList |
Overrides
FChoice.Foundation.DataObjects.DataObjectCollection<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.Create(System.Data.DataRow)

Explicit Interface Implementations

IGlobalStringListCollection.AddRange(IEnumerable<IGlobalStringList>)

Declaration
void IGlobalStringListCollection.AddRange(IEnumerable<IGlobalStringList> collection)
Parameters
Type | Name | Description
System.Collections.Generic.IEnumerable<IGlobalStringList> | collection |

IGlobalStringListCollection.AsReadOnly()

Declaration
ReadOnlyCollection<IGlobalStringList> IGlobalStringListCollection.AsReadOnly()
Returns
Type | Description
System.Collections.ObjectModel.ReadOnlyCollection<IGlobalStringList> |

IGlobalStringListCollection.BinarySearch(IGlobalStringList)

Declaration
int IGlobalStringListCollection.BinarySearch(IGlobalStringList item)
Parameters
Type | Name | Description
IGlobalStringList | item |
Returns
Type | Description
System.Int32 |

IGlobalStringListCollection.BinarySearch(IGlobalStringList, IComparer<IGlobalStringList>)

Declaration
int IGlobalStringListCollection.BinarySearch(IGlobalStringList item, IComparer<IGlobalStringList> comparer)
Parameters
Type | Name | Description
IGlobalStringList | item |
System.Collections.Generic.IComparer<IGlobalStringList> | comparer |
Returns
Type | Description
System.Int32 |

IGlobalStringListCollection.BinarySearch(Int32, Int32, IGlobalStringList, IComparer<IGlobalStringList>)

Declaration
int IGlobalStringListCollection.BinarySearch(int index, int count, IGlobalStringList item, IComparer<IGlobalStringList> comparer)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |
IGlobalStringList | item |
System.Collections.Generic.IComparer<IGlobalStringList> | comparer |
Returns
Type | Description
System.Int32 |

IGlobalStringListCollection.CopyTo(IGlobalStringList[])

Declaration
void IGlobalStringListCollection.CopyTo(IGlobalStringList[] array)
Parameters
Type | Name | Description
IGlobalStringList[] | array |

IGlobalStringListCollection.CopyTo(Int32, IGlobalStringList[], Int32, Int32)

Declaration
void IGlobalStringListCollection.CopyTo(int index, IGlobalStringList[] array, int arrayIndex, int count)
Parameters
Type | Name | Description
System.Int32 | index |
IGlobalStringList[] | array |
System.Int32 | arrayIndex |
System.Int32 | count |

IGlobalStringListCollection.Exists(Predicate<IGlobalStringList>)

Declaration
bool IGlobalStringListCollection.Exists(Predicate<IGlobalStringList> match)
Parameters
Type | Name | Description
System.Predicate<IGlobalStringList> | match |
Returns
Type | Description
System.Boolean |

IGlobalStringListCollection.Find(Predicate<IGlobalStringList>)

Declaration
IGlobalStringList IGlobalStringListCollection.Find(Predicate<IGlobalStringList> match)
Parameters
Type | Name | Description
System.Predicate<IGlobalStringList> | match |
Returns
Type | Description
IGlobalStringList |

IGlobalStringListCollection.FindAll(Predicate<IGlobalStringList>)

Declaration
List<IGlobalStringList> IGlobalStringListCollection.FindAll(Predicate<IGlobalStringList> match)
Parameters
Type | Name | Description
System.Predicate<IGlobalStringList> | match |
Returns
Type | Description
System.Collections.Generic.List<IGlobalStringList> |

IGlobalStringListCollection.FindIndex(Int32, Int32, Predicate<IGlobalStringList>)

Declaration
int IGlobalStringListCollection.FindIndex(int startIndex, int count, Predicate<IGlobalStringList> match)
Parameters
Type | Name | Description
System.Int32 | startIndex |
System.Int32 | count |
System.Predicate<IGlobalStringList> | match |
Returns
Type | Description
System.Int32 |

IGlobalStringListCollection.FindIndex(Int32, Predicate<IGlobalStringList>)

Declaration
int IGlobalStringListCollection.FindIndex(int startIndex, Predicate<IGlobalStringList> match)
Parameters
Type | Name | Description
System.Int32 | startIndex |
System.Predicate<IGlobalStringList> | match |
Returns
Type | Description
System.Int32 |

IGlobalStringListCollection.FindIndex(Predicate<IGlobalStringList>)

Declaration
int IGlobalStringListCollection.FindIndex(Predicate<IGlobalStringList> match)
Parameters
Type | Name | Description
System.Predicate<IGlobalStringList> | match |
Returns
Type | Description
System.Int32 |

IGlobalStringListCollection.FindLast(Predicate<IGlobalStringList>)

Declaration
IGlobalStringList IGlobalStringListCollection.FindLast(Predicate<IGlobalStringList> match)
Parameters
Type | Name | Description
System.Predicate<IGlobalStringList> | match |
Returns
Type | Description
IGlobalStringList |

IGlobalStringListCollection.FindLastIndex(Int32, Int32, Predicate<IGlobalStringList>)

Declaration
int IGlobalStringListCollection.FindLastIndex(int startIndex, int count, Predicate<IGlobalStringList> match)
Parameters
Type | Name | Description
System.Int32 | startIndex |
System.Int32 | count |
System.Predicate<IGlobalStringList> | match |
Returns
Type | Description
System.Int32 |

IGlobalStringListCollection.FindLastIndex(Int32, Predicate<IGlobalStringList>)

Declaration
int IGlobalStringListCollection.FindLastIndex(int startIndex, Predicate<IGlobalStringList> match)
Parameters
Type | Name | Description
System.Int32 | startIndex |
System.Predicate<IGlobalStringList> | match |
Returns
Type | Description
System.Int32 |

IGlobalStringListCollection.FindLastIndex(Predicate<IGlobalStringList>)

Declaration
int IGlobalStringListCollection.FindLastIndex(Predicate<IGlobalStringList> match)
Parameters
Type | Name | Description
System.Predicate<IGlobalStringList> | match |
Returns
Type | Description
System.Int32 |

IGlobalStringListCollection.ForEach(Action<IGlobalStringList>)

Declaration
void IGlobalStringListCollection.ForEach(Action<IGlobalStringList> action)
Parameters
Type | Name | Description
System.Action<IGlobalStringList> | action |

IGlobalStringListCollection.get_Capacity()

Declaration
int IGlobalStringListCollection.get_Capacity()
Returns
Type | Description
System.Int32 |

IGlobalStringListCollection.GetRange(Int32, Int32)

Declaration
List<IGlobalStringList> IGlobalStringListCollection.GetRange(int index, int count)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |
Returns
Type | Description
System.Collections.Generic.List<IGlobalStringList> |

IGlobalStringListCollection.IndexOf(IGlobalStringList, Int32)

Declaration
int IGlobalStringListCollection.IndexOf(IGlobalStringList item, int index)
Parameters
Type | Name | Description
IGlobalStringList | item |
System.Int32 | index |
Returns
Type | Description
System.Int32 |

IGlobalStringListCollection.IndexOf(IGlobalStringList, Int32, Int32)

Declaration
int IGlobalStringListCollection.IndexOf(IGlobalStringList item, int index, int count)
Parameters
Type | Name | Description
IGlobalStringList | item |
System.Int32 | index |
System.Int32 | count |
Returns
Type | Description
System.Int32 |

IGlobalStringListCollection.InsertRange(Int32, IEnumerable<IGlobalStringList>)

Declaration
void IGlobalStringListCollection.InsertRange(int index, IEnumerable<IGlobalStringList> collection)
Parameters
Type | Name | Description
System.Int32 | index |
System.Collections.Generic.IEnumerable<IGlobalStringList> | collection |

IGlobalStringListCollection.LastIndexOf(IGlobalStringList)

Declaration
int IGlobalStringListCollection.LastIndexOf(IGlobalStringList item)
Parameters
Type | Name | Description
IGlobalStringList | item |
Returns
Type | Description
System.Int32 |

IGlobalStringListCollection.LastIndexOf(IGlobalStringList, Int32)

Declaration
int IGlobalStringListCollection.LastIndexOf(IGlobalStringList item, int index)
Parameters
Type | Name | Description
IGlobalStringList | item |
System.Int32 | index |
Returns
Type | Description
System.Int32 |

IGlobalStringListCollection.LastIndexOf(IGlobalStringList, Int32, Int32)

Declaration
int IGlobalStringListCollection.LastIndexOf(IGlobalStringList item, int index, int count)
Parameters
Type | Name | Description
IGlobalStringList | item |
System.Int32 | index |
System.Int32 | count |
Returns
Type | Description
System.Int32 |

IGlobalStringListCollection.RemoveAll(Predicate<IGlobalStringList>)

Declaration
int IGlobalStringListCollection.RemoveAll(Predicate<IGlobalStringList> match)
Parameters
Type | Name | Description
System.Predicate<IGlobalStringList> | match |
Returns
Type | Description
System.Int32 |

IGlobalStringListCollection.RemoveRange(Int32, Int32)

Declaration
void IGlobalStringListCollection.RemoveRange(int index, int count)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |

IGlobalStringListCollection.Reverse()

Declaration
void IGlobalStringListCollection.Reverse()

IGlobalStringListCollection.Reverse(Int32, Int32)

Declaration
void IGlobalStringListCollection.Reverse(int index, int count)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |

IGlobalStringListCollection.set_Capacity(Int32)

Declaration
void IGlobalStringListCollection.set_Capacity(int value)
Parameters
Type | Name | Description
System.Int32 | value |

IGlobalStringListCollection.Sort()

Declaration
void IGlobalStringListCollection.Sort()

IGlobalStringListCollection.Sort(IComparer<IGlobalStringList>)

Declaration
void IGlobalStringListCollection.Sort(IComparer<IGlobalStringList> comparer)
Parameters
Type | Name | Description
System.Collections.Generic.IComparer<IGlobalStringList> | comparer |

IGlobalStringListCollection.Sort(Comparison<IGlobalStringList>)

Declaration
void IGlobalStringListCollection.Sort(Comparison<IGlobalStringList> comparison)
Parameters
Type | Name | Description
System.Comparison<IGlobalStringList> | comparison |

IGlobalStringListCollection.Sort(Int32, Int32, IComparer<IGlobalStringList>)

Declaration
void IGlobalStringListCollection.Sort(int index, int count, IComparer<IGlobalStringList> comparer)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |
System.Collections.Generic.IComparer<IGlobalStringList> | comparer |

IGlobalStringListCollection.ToArray()

Declaration
IGlobalStringList[] IGlobalStringListCollection.ToArray()
Returns
Type | Description
IGlobalStringList[] |

IGlobalStringListCollection.TrimExcess()

Declaration
void IGlobalStringListCollection.TrimExcess()

IGlobalStringListCollection.TrueForAll(Predicate<IGlobalStringList>)

Declaration
bool IGlobalStringListCollection.TrueForAll(Predicate<IGlobalStringList> match)
Parameters
Type | Name | Description
System.Predicate<IGlobalStringList> | match |
Returns
Type | Description
System.Boolean |

Implements

System.Collections.Generic.IList<T>
System.Collections.IList
System.Collections.ICollection
System.Collections.Generic.IReadOnlyList<T>
System.Collections.Generic.IReadOnlyCollection<T>
IGlobalStringListCollection
System.Collections.Generic.ICollection<T>
System.Collections.Generic.IEnumerable<T>
System.Collections.IEnumerable


Class HierarchicalStringElement | fcSDK Documentation

Class HierarchicalStringElement

Inheritance
System.Object
DataObject
ClarifyDataObject
HierarchicalStringElement
Implements
IHierarchicalStringElement
IDataObject
Inherited Members
ClarifyDataObject.GetCommentFieldValue(DataRow)
ClarifyDataObject.CommentFieldName
ClarifyDataObject.ObjectID
DataObject.SetUniqueID(Object)
DataObject.GetFieldValue(String)
DataObject.GetFieldValue(Int32)
DataObject.ContainsColumn(String)
DataObject.GetSafeInt32FieldValue(String)
DataObject.GetSafeInt32FieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeDoubleFieldValue(String)
DataObject.GetSafeDoubleFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeBooleanFieldValue(String)
DataObject.GetSafeBooleanFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeStringFieldValue(String)
DataObject.SetFieldValue(String, Object)
DataObject.GetSafeString(Object)
DataObject.UniqueID
DataObject.FieldValues
DataObject.ColumnMap
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataObjects
Assembly: fcSDK.dll
Syntax
public class HierarchicalStringElement : ClarifyDataObject, IHierarchicalStringElement, IDataObject

Fields

ACTIVE_STATE

Declaration
public const string ACTIVE_STATE = "Active"
Field Value
Type | Description
System.String |

DEFAULT_STATE

Declaration
public const string DEFAULT_STATE = "Default"
Field Value
Type | Description
System.String |

INACTIVE_STATE

Declaration
public const string INACTIVE_STATE = "Inactive"
Field Value
Type | Description
System.String |

Properties

Elements

Declaration
public IHierarchicalStringElementCollection Elements { get; }
Property Value
Type | Description
IHierarchicalStringElementCollection |

IsActive

Declaration
public bool IsActive { get; }
Property Value
Type | Description
System.Boolean |

IsDefault

Declaration
public bool IsDefault { get; }
Property Value
Type | Description
System.Boolean |

LocalizedTitle

Declaration
public string LocalizedTitle { get; }
Property Value
Type | Description
System.String |

Rank

Declaration
public int Rank { get; }
Property Value
Type | Description
System.Int32 |

State

Declaration
public string State { get; }
Property Value
Type | Description
System.String |

Title

Declaration
public string Title { get; }
Property Value
Type | Description
System.String |

Methods

GetLocalizedTitle(CultureInfo)

Declaration
public string GetLocalizedTitle(CultureInfo specificCulture)
Parameters
Type | Name | Description
System.Globalization.CultureInfo | specificCulture |
Returns
Type | Description
System.String |

Implements

IHierarchicalStringElement
IDataObject


Class HierarchicalStringElementCollection | fcSDK Documentation

Class HierarchicalStringElementCollection

Inheritance
System.Object
System.Collections.Generic.List<IHierarchicalStringElement>
DataObjectCollection<IHierarchicalStringElement>
HierarchicalStringElementCollection
Implements
System.Collections.IList
System.Collections.ICollection
System.Collections.Generic.IReadOnlyList<IHierarchicalStringElement>
System.Collections.Generic.IReadOnlyCollection<IHierarchicalStringElement>
IHierarchicalStringElementCollection
System.Collections.Generic.IList<IHierarchicalStringElement>
System.Collections.Generic.ICollection<IHierarchicalStringElement>
System.Collections.Generic.IEnumerable<IHierarchicalStringElement>
System.Collections.IEnumerable
Inherited Members
DataObjectCollection<IHierarchicalStringElement>.Initialize(DataTable)
DataObjectCollection<IHierarchicalStringElement>.Initialize(DataRow[])
DataObjectCollection<IHierarchicalStringElement>.Initialize(Object[][])
DataObjectCollection<IHierarchicalStringElement>.AddDataObject(IHierarchicalStringElement)
DataObjectCollection<IHierarchicalStringElement>.OnDataObjectAdded(IHierarchicalStringElement)
DataObjectCollection<IHierarchicalStringElement>.Create(Object[])
DataObjectCollection<IHierarchicalStringElement>.GetItemByIndex(Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.System.Collections.IList.get_Item(System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.System.Collections.IList.set_Item(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.Add(FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.System.Collections.IList.Add(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.AddRange(System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.AsReadOnly()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.BinarySearch(System.Int32, System.Int32, FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.BinarySearch(FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.BinarySearch(FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.Clear()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.Contains(FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.System.Collections.IList.Contains(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.ConvertAll<TOutput>(System.Converter<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement, TOutput>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.CopyTo(FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement[])
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.System.Collections.ICollection.CopyTo(System.Array, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.CopyTo(System.Int32, FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement[], System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.CopyTo(FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement[], System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.Exists(System.Predicate<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.Find(System.Predicate<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.FindAll(System.Predicate<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.FindIndex(System.Predicate<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.FindIndex(System.Int32, System.Predicate<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.FindIndex(System.Int32, System.Int32, System.Predicate<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.FindLast(System.Predicate<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.FindLastIndex(System.Predicate<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.FindLastIndex(System.Int32, System.Predicate<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.FindLastIndex(System.Int32, System.Int32, System.Predicate<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.ForEach(System.Action<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.System.Collections.IEnumerable.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.GetRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.IndexOf(FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.System.Collections.IList.IndexOf(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.IndexOf(FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.IndexOf(FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.Insert(System.Int32, FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.System.Collections.IList.Insert(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.InsertRange(System.Int32, System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.LastIndexOf(FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.LastIndexOf(FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.LastIndexOf(FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.Remove(FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.System.Collections.IList.Remove(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.RemoveAll(System.Predicate<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.RemoveAt(System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.RemoveRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.Reverse()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.Reverse(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.Sort()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.Sort(System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.Sort(System.Int32, System.Int32, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.Sort(System.Comparison<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.ToArray()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.TrimExcess()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.TrueForAll(System.Predicate<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.Capacity
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.Count
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.System.Collections.IList.IsFixedSize
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.IsReadOnly
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.System.Collections.IList.IsReadOnly
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.System.Collections.ICollection.IsSynchronized
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.System.Collections.ICollection.SyncRoot
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.Item[System.Int32]
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.System.Collections.IList.Item[System.Int32]
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataObjects
Assembly: fcSDK.dll
Syntax
public class HierarchicalStringElementCollection : DataObjectCollection<IHierarchicalStringElement>, IList, ICollection, IReadOnlyList<IHierarchicalStringElement>, IReadOnlyCollection<IHierarchicalStringElement>, IHierarchicalStringElementCollection, IList<IHierarchicalStringElement>, ICollection<IHierarchicalStringElement>, IEnumerable<IHierarchicalStringElement>, IEnumerable

Properties

ActiveElements

Declaration
public HierarchicalStringElementCollection ActiveElements { get; }
Property Value
Type | Description
HierarchicalStringElementCollection |

DefaultElement

Declaration
public IHierarchicalStringElement DefaultElement { get; set; }
Property Value
Type | Description
IHierarchicalStringElement |

Item[String]

Declaration
public IHierarchicalStringElement this[string title] { get; }
Parameters
Type | Name | Description
System.String | title |
Property Value
Type | Description
IHierarchicalStringElement |

Methods

Create(DataRow)

Declaration
protected override IHierarchicalStringElement Create(DataRow row)
Parameters
Type | Name | Description
System.Data.DataRow | row |
Returns
Type | Description
IHierarchicalStringElement |
Overrides
FChoice.Foundation.DataObjects.DataObjectCollection<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.Create(System.Data.DataRow)

GetByObjID(Int32)

Declaration
public IHierarchicalStringElement GetByObjID(int objectID)
Parameters
Type | Name | Description
System.Int32 | objectID |
Returns
Type | Description
IHierarchicalStringElement |

Explicit Interface Implementations

IHierarchicalStringElementCollection.AddRange(IEnumerable<IHierarchicalStringElement>)

Declaration
void IHierarchicalStringElementCollection.AddRange(IEnumerable<IHierarchicalStringElement> collection)
Parameters
Type | Name | Description
System.Collections.Generic.IEnumerable<IHierarchicalStringElement> | collection |

IHierarchicalStringElementCollection.AsReadOnly()

Declaration
ReadOnlyCollection<IHierarchicalStringElement> IHierarchicalStringElementCollection.AsReadOnly()
Returns
Type | Description
System.Collections.ObjectModel.ReadOnlyCollection<IHierarchicalStringElement> |

IHierarchicalStringElementCollection.BinarySearch(IHierarchicalStringElement)

Declaration
int IHierarchicalStringElementCollection.BinarySearch(IHierarchicalStringElement item)
Parameters
Type | Name | Description
IHierarchicalStringElement | item |
Returns
Type | Description
System.Int32 |

IHierarchicalStringElementCollection.BinarySearch(IHierarchicalStringElement, IComparer<IHierarchicalStringElement>)

Declaration
int IHierarchicalStringElementCollection.BinarySearch(IHierarchicalStringElement item, IComparer<IHierarchicalStringElement> comparer)
Parameters
Type | Name | Description
IHierarchicalStringElement | item |
System.Collections.Generic.IComparer<IHierarchicalStringElement> | comparer |
Returns
Type | Description
System.Int32 |

IHierarchicalStringElementCollection.BinarySearch(Int32, Int32, IHierarchicalStringElement, IComparer<IHierarchicalStringElement>)

Declaration
int IHierarchicalStringElementCollection.BinarySearch(int index, int count, IHierarchicalStringElement item, IComparer<IHierarchicalStringElement> comparer)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |
IHierarchicalStringElement | item |
System.Collections.Generic.IComparer<IHierarchicalStringElement> | comparer |
Returns
Type | Description
System.Int32 |

IHierarchicalStringElementCollection.CopyTo(IHierarchicalStringElement[])

Declaration
void IHierarchicalStringElementCollection.CopyTo(IHierarchicalStringElement[] array)
Parameters
Type | Name | Description
IHierarchicalStringElement[] | array |

IHierarchicalStringElementCollection.CopyTo(Int32, IHierarchicalStringElement[], Int32, Int32)

Declaration
void IHierarchicalStringElementCollection.CopyTo(int index, IHierarchicalStringElement[] array, int arrayIndex, int count)
Parameters
Type | Name | Description
System.Int32 | index |
IHierarchicalStringElement[] | array |
System.Int32 | arrayIndex |
System.Int32 | count |

IHierarchicalStringElementCollection.Exists(Predicate<IHierarchicalStringElement>)

Declaration
bool IHierarchicalStringElementCollection.Exists(Predicate<IHierarchicalStringElement> match)
Parameters
Type | Name | Description
System.Predicate<IHierarchicalStringElement> | match |
Returns
Type | Description
System.Boolean |

IHierarchicalStringElementCollection.Find(Predicate<IHierarchicalStringElement>)

Declaration
IHierarchicalStringElement IHierarchicalStringElementCollection.Find(Predicate<IHierarchicalStringElement> match)
Parameters
Type | Name | Description
System.Predicate<IHierarchicalStringElement> | match |
Returns
Type | Description
IHierarchicalStringElement |

IHierarchicalStringElementCollection.FindAll(Predicate<IHierarchicalStringElement>)

Declaration
List<IHierarchicalStringElement> IHierarchicalStringElementCollection.FindAll(Predicate<IHierarchicalStringElement> match)
Parameters
Type | Name | Description
System.Predicate<IHierarchicalStringElement> | match |
Returns
Type | Description
System.Collections.Generic.List<IHierarchicalStringElement> |

IHierarchicalStringElementCollection.FindIndex(Int32, Int32, Predicate<IHierarchicalStringElement>)

Declaration
int IHierarchicalStringElementCollection.FindIndex(int startIndex, int count, Predicate<IHierarchicalStringElement> match)
Parameters
Type | Name | Description
System.Int32 | startIndex |
System.Int32 | count |
System.Predicate<IHierarchicalStringElement> | match |
Returns
Type | Description
System.Int32 |

IHierarchicalStringElementCollection.FindIndex(Int32, Predicate<IHierarchicalStringElement>)

Declaration
int IHierarchicalStringElementCollection.FindIndex(int startIndex, Predicate<IHierarchicalStringElement> match)
Parameters
Type | Name | Description
System.Int32 | startIndex |
System.Predicate<IHierarchicalStringElement> | match |
Returns
Type | Description
System.Int32 |

IHierarchicalStringElementCollection.FindIndex(Predicate<IHierarchicalStringElement>)

Declaration
int IHierarchicalStringElementCollection.FindIndex(Predicate<IHierarchicalStringElement> match)
Parameters
Type | Name | Description
System.Predicate<IHierarchicalStringElement> | match |
Returns
Type | Description
System.Int32 |

IHierarchicalStringElementCollection.FindLast(Predicate<IHierarchicalStringElement>)

Declaration
IHierarchicalStringElement IHierarchicalStringElementCollection.FindLast(Predicate<IHierarchicalStringElement> match)
Parameters
Type | Name | Description
System.Predicate<IHierarchicalStringElement> | match |
Returns
Type | Description
IHierarchicalStringElement |

IHierarchicalStringElementCollection.FindLastIndex(Int32, Int32, Predicate<IHierarchicalStringElement>)

Declaration
int IHierarchicalStringElementCollection.FindLastIndex(int startIndex, int count, Predicate<IHierarchicalStringElement> match)
Parameters
Type | Name | Description
System.Int32 | startIndex |
System.Int32 | count |
System.Predicate<IHierarchicalStringElement> | match |
Returns
Type | Description
System.Int32 |

IHierarchicalStringElementCollection.FindLastIndex(Int32, Predicate<IHierarchicalStringElement>)

Declaration
int IHierarchicalStringElementCollection.FindLastIndex(int startIndex, Predicate<IHierarchicalStringElement> match)
Parameters
Type | Name | Description
System.Int32 | startIndex |
System.Predicate<IHierarchicalStringElement> | match |
Returns
Type | Description
System.Int32 |

IHierarchicalStringElementCollection.FindLastIndex(Predicate<IHierarchicalStringElement>)

Declaration
int IHierarchicalStringElementCollection.FindLastIndex(Predicate<IHierarchicalStringElement> match)
Parameters
Type | Name | Description
System.Predicate<IHierarchicalStringElement> | match |
Returns
Type | Description
System.Int32 |

IHierarchicalStringElementCollection.ForEach(Action<IHierarchicalStringElement>)

Declaration
void IHierarchicalStringElementCollection.ForEach(Action<IHierarchicalStringElement> action)
Parameters
Type | Name | Description
System.Action<IHierarchicalStringElement> | action |

IHierarchicalStringElementCollection.get_Capacity()

Declaration
int IHierarchicalStringElementCollection.get_Capacity()
Returns
Type | Description
System.Int32 |

IHierarchicalStringElementCollection.GetRange(Int32, Int32)

Declaration
List<IHierarchicalStringElement> IHierarchicalStringElementCollection.GetRange(int index, int count)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |
Returns
Type | Description
System.Collections.Generic.List<IHierarchicalStringElement> |

IHierarchicalStringElementCollection.IndexOf(IHierarchicalStringElement, Int32)

Declaration
int IHierarchicalStringElementCollection.IndexOf(IHierarchicalStringElement item, int index)
Parameters
Type | Name | Description
IHierarchicalStringElement | item |
System.Int32 | index |
Returns
Type | Description
System.Int32 |

IHierarchicalStringElementCollection.IndexOf(IHierarchicalStringElement, Int32, Int32)

Declaration
int IHierarchicalStringElementCollection.IndexOf(IHierarchicalStringElement item, int index, int count)
Parameters
Type | Name | Description
IHierarchicalStringElement | item |
System.Int32 | index |
System.Int32 | count |
Returns
Type | Description
System.Int32 |

IHierarchicalStringElementCollection.InsertRange(Int32, IEnumerable<IHierarchicalStringElement>)

Declaration
void IHierarchicalStringElementCollection.InsertRange(int index, IEnumerable<IHierarchicalStringElement> collection)
Parameters
Type | Name | Description
System.Int32 | index |
System.Collections.Generic.IEnumerable<IHierarchicalStringElement> | collection |

IHierarchicalStringElementCollection.LastIndexOf(IHierarchicalStringElement)

Declaration
int IHierarchicalStringElementCollection.LastIndexOf(IHierarchicalStringElement item)
Parameters
Type | Name | Description
IHierarchicalStringElement | item |
Returns
Type | Description
System.Int32 |

IHierarchicalStringElementCollection.LastIndexOf(IHierarchicalStringElement, Int32)

Declaration
int IHierarchicalStringElementCollection.LastIndexOf(IHierarchicalStringElement item, int index)
Parameters
Type | Name | Description
IHierarchicalStringElement | item |
System.Int32 | index |
Returns
Type | Description
System.Int32 |

IHierarchicalStringElementCollection.LastIndexOf(IHierarchicalStringElement, Int32, Int32)

Declaration
int IHierarchicalStringElementCollection.LastIndexOf(IHierarchicalStringElement item, int index, int count)
Parameters
Type | Name | Description
IHierarchicalStringElement | item |
System.Int32 | index |
System.Int32 | count |
Returns
Type | Description
System.Int32 |

IHierarchicalStringElementCollection.RemoveAll(Predicate<IHierarchicalStringElement>)

Declaration
int IHierarchicalStringElementCollection.RemoveAll(Predicate<IHierarchicalStringElement> match)
Parameters
Type | Name | Description
System.Predicate<IHierarchicalStringElement> | match |
Returns
Type | Description
System.Int32 |

IHierarchicalStringElementCollection.RemoveRange(Int32, Int32)

Declaration
void IHierarchicalStringElementCollection.RemoveRange(int index, int count)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |

IHierarchicalStringElementCollection.Reverse()

Declaration
void IHierarchicalStringElementCollection.Reverse()

IHierarchicalStringElementCollection.Reverse(Int32, Int32)

Declaration
void IHierarchicalStringElementCollection.Reverse(int index, int count)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |

IHierarchicalStringElementCollection.set_Capacity(Int32)

Declaration
void IHierarchicalStringElementCollection.set_Capacity(int value)
Parameters
Type | Name | Description
System.Int32 | value |

IHierarchicalStringElementCollection.Sort()

Declaration
void IHierarchicalStringElementCollection.Sort()

IHierarchicalStringElementCollection.Sort(IComparer<IHierarchicalStringElement>)

Declaration
void IHierarchicalStringElementCollection.Sort(IComparer<IHierarchicalStringElement> comparer)
Parameters
Type | Name | Description
System.Collections.Generic.IComparer<IHierarchicalStringElement> | comparer |

IHierarchicalStringElementCollection.Sort(Comparison<IHierarchicalStringElement>)

Declaration
void IHierarchicalStringElementCollection.Sort(Comparison<IHierarchicalStringElement> comparison)
Parameters
Type | Name | Description
System.Comparison<IHierarchicalStringElement> | comparison |

IHierarchicalStringElementCollection.Sort(Int32, Int32, IComparer<IHierarchicalStringElement>)

Declaration
void IHierarchicalStringElementCollection.Sort(int index, int count, IComparer<IHierarchicalStringElement> comparer)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |
System.Collections.Generic.IComparer<IHierarchicalStringElement> | comparer |

IHierarchicalStringElementCollection.ToArray()

Declaration
IHierarchicalStringElement[] IHierarchicalStringElementCollection.ToArray()
Returns
Type | Description
IHierarchicalStringElement[] |

IHierarchicalStringElementCollection.TrimExcess()

Declaration
void IHierarchicalStringElementCollection.TrimExcess()

IHierarchicalStringElementCollection.TrueForAll(Predicate<IHierarchicalStringElement>)

Declaration
bool IHierarchicalStringElementCollection.TrueForAll(Predicate<IHierarchicalStringElement> match)
Parameters
Type | Name | Description
System.Predicate<IHierarchicalStringElement> | match |
Returns
Type | Description
System.Boolean |

Implements

System.Collections.IList
System.Collections.ICollection
System.Collections.Generic.IReadOnlyList<T>
System.Collections.Generic.IReadOnlyCollection<T>
IHierarchicalStringElementCollection
System.Collections.Generic.IList<T>
System.Collections.Generic.ICollection<T>
System.Collections.Generic.IEnumerable<T>
System.Collections.IEnumerable


Class HierarchicalStringList | fcSDK Documentation

Class HierarchicalStringList

Inheritance
System.Object
DataObject
ClarifyDataObject
HierarchicalStringList
Implements
IHierarchicalStringList
IDataObject
Inherited Members
ClarifyDataObject.GetCommentFieldValue(DataRow)
ClarifyDataObject.CommentFieldName
ClarifyDataObject.ObjectID
DataObject.SetUniqueID(Object)
DataObject.GetFieldValue(String)
DataObject.GetFieldValue(Int32)
DataObject.ContainsColumn(String)
DataObject.GetSafeInt32FieldValue(String)
DataObject.GetSafeInt32FieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeDoubleFieldValue(String)
DataObject.GetSafeDoubleFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeBooleanFieldValue(String)
DataObject.GetSafeBooleanFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeStringFieldValue(String)
DataObject.SetFieldValue(String, Object)
DataObject.GetSafeString(Object)
DataObject.UniqueID
DataObject.FieldValues
DataObject.ColumnMap
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataObjects
Assembly: fcSDK.dll
Syntax
public class HierarchicalStringList : ClarifyDataObject, IHierarchicalStringList, IDataObject

Properties

ActiveElements

Declaration
public IHierarchicalStringElementCollection ActiveElements { get; }
Property Value
Type | Description
IHierarchicalStringElementCollection |

Description

Declaration
public string Description { get; }
Property Value
Type | Description
System.String |

Elements

Declaration
public IHierarchicalStringElementCollection Elements { get; }
Property Value
Type | Description
IHierarchicalStringElementCollection |

InactiveElements

Declaration
public IHierarchicalStringElementCollection InactiveElements { get; }
Property Value
Type | Description
IHierarchicalStringElementCollection |

ListID

Declaration
public int ListID { get; }
Property Value
Type | Description
System.Int32 |

Title

Declaration
public string Title { get; }
Property Value
Type | Description
System.String |

Implements

IHierarchicalStringList
IDataObject


Class HierarchicalStringListCollection | fcSDK Documentation

Class HierarchicalStringListCollection

Inheritance
System.Object
System.Collections.Generic.List<IHierarchicalStringList>
DataObjectCollection<IHierarchicalStringList>
HierarchicalStringListCollection
Implements
System.Collections.Generic.IList<IHierarchicalStringList>
System.Collections.IList
System.Collections.ICollection
System.Collections.Generic.IReadOnlyList<IHierarchicalStringList>
System.Collections.Generic.IReadOnlyCollection<IHierarchicalStringList>
IHierarchicalStringListCollection
System.Collections.Generic.ICollection<IHierarchicalStringList>
System.Collections.Generic.IEnumerable<IHierarchicalStringList>
System.Collections.IEnumerable
Inherited Members
DataObjectCollection<IHierarchicalStringList>.Initialize(DataTable)
DataObjectCollection<IHierarchicalStringList>.Initialize(DataRow[])
DataObjectCollection<IHierarchicalStringList>.Initialize(Object[][])
DataObjectCollection<IHierarchicalStringList>.AddDataObject(IHierarchicalStringList)
DataObjectCollection<IHierarchicalStringList>.OnDataObjectAdded(IHierarchicalStringList)
DataObjectCollection<IHierarchicalStringList>.Create(Object[])
DataObjectCollection<IHierarchicalStringList>.GetItemByIndex(Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.System.Collections.IList.get_Item(System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.System.Collections.IList.set_Item(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.Add(FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.System.Collections.IList.Add(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.AddRange(System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.AsReadOnly()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.BinarySearch(System.Int32, System.Int32, FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.BinarySearch(FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.BinarySearch(FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.Clear()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.Contains(FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.System.Collections.IList.Contains(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.ConvertAll<TOutput>(System.Converter<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList, TOutput>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.CopyTo(FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList[])
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.System.Collections.ICollection.CopyTo(System.Array, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.CopyTo(System.Int32, FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList[], System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.CopyTo(FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList[], System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.Exists(System.Predicate<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.Find(System.Predicate<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.FindAll(System.Predicate<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.FindIndex(System.Predicate<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.FindIndex(System.Int32, System.Predicate<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.FindIndex(System.Int32, System.Int32, System.Predicate<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.FindLast(System.Predicate<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.FindLastIndex(System.Predicate<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.FindLastIndex(System.Int32, System.Predicate<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.FindLastIndex(System.Int32, System.Int32, System.Predicate<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.ForEach(System.Action<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.System.Collections.IEnumerable.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.GetRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.IndexOf(FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.System.Collections.IList.IndexOf(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.IndexOf(FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.IndexOf(FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.Insert(System.Int32, FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.System.Collections.IList.Insert(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.InsertRange(System.Int32, System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.LastIndexOf(FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.LastIndexOf(FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.LastIndexOf(FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.Remove(FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.System.Collections.IList.Remove(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.RemoveAll(System.Predicate<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.RemoveAt(System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.RemoveRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.Reverse()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.Reverse(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.Sort()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.Sort(System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.Sort(System.Int32, System.Int32, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.Sort(System.Comparison<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.ToArray()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.TrimExcess()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.TrueForAll(System.Predicate<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.Capacity
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.Count
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.System.Collections.IList.IsFixedSize
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.IsReadOnly
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.System.Collections.IList.IsReadOnly
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.System.Collections.ICollection.IsSynchronized
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.System.Collections.ICollection.SyncRoot
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.Item[System.Int32]
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.System.Collections.IList.Item[System.Int32]
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataObjects
Assembly: fcSDK.dll
Syntax
public class HierarchicalStringListCollection : DataObjectCollection<IHierarchicalStringList>, IList<IHierarchicalStringList>, IList, ICollection, IReadOnlyList<IHierarchicalStringList>, IReadOnlyCollection<IHierarchicalStringList>, IHierarchicalStringListCollection, ICollection<IHierarchicalStringList>, IEnumerable<IHierarchicalStringList>, IEnumerable

Properties

Item[String]

Declaration
public IHierarchicalStringList this[string title] { get; }
Parameters
Type | Name | Description
System.String | title |
Property Value
Type | Description
IHierarchicalStringList |

Methods

Create(DataRow)

Declaration
protected override IHierarchicalStringList Create(DataRow row)
Parameters
Type | Name | Description
System.Data.DataRow | row |
Returns
Type | Description
IHierarchicalStringList |
Overrides
FChoice.Foundation.DataObjects.DataObjectCollection<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.Create(System.Data.DataRow)

Explicit Interface Implementations

IHierarchicalStringListCollection.AddRange(IEnumerable<IHierarchicalStringList>)

Declaration
void IHierarchicalStringListCollection.AddRange(IEnumerable<IHierarchicalStringList> collection)
Parameters
Type | Name | Description
System.Collections.Generic.IEnumerable<IHierarchicalStringList> | collection |

IHierarchicalStringListCollection.AsReadOnly()

Declaration
ReadOnlyCollection<IHierarchicalStringList> IHierarchicalStringListCollection.AsReadOnly()
Returns
Type | Description
System.Collections.ObjectModel.ReadOnlyCollection<IHierarchicalStringList> |

IHierarchicalStringListCollection.BinarySearch(IHierarchicalStringList)

Declaration
int IHierarchicalStringListCollection.BinarySearch(IHierarchicalStringList item)
Parameters
Type | Name | Description
IHierarchicalStringList | item |
Returns
Type | Description
System.Int32 |

IHierarchicalStringListCollection.BinarySearch(IHierarchicalStringList, IComparer<IHierarchicalStringList>)

Declaration
int IHierarchicalStringListCollection.BinarySearch(IHierarchicalStringList item, IComparer<IHierarchicalStringList> comparer)
Parameters
Type | Name | Description
IHierarchicalStringList | item |
System.Collections.Generic.IComparer<IHierarchicalStringList> | comparer |
Returns
Type | Description
System.Int32 |

IHierarchicalStringListCollection.BinarySearch(Int32, Int32, IHierarchicalStringList, IComparer<IHierarchicalStringList>)

Declaration
int IHierarchicalStringListCollection.BinarySearch(int index, int count, IHierarchicalStringList item, IComparer<IHierarchicalStringList> comparer)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |
IHierarchicalStringList | item |
System.Collections.Generic.IComparer<IHierarchicalStringList> | comparer |
Returns
Type | Description
System.Int32 |

IHierarchicalStringListCollection.CopyTo(IHierarchicalStringList[])

Declaration
void IHierarchicalStringListCollection.CopyTo(IHierarchicalStringList[] array)
Parameters
Type | Name | Description
IHierarchicalStringList[] | array |

IHierarchicalStringListCollection.CopyTo(Int32, IHierarchicalStringList[], Int32, Int32)

Declaration
void IHierarchicalStringListCollection.CopyTo(int index, IHierarchicalStringList[] array, int arrayIndex, int count)
Parameters
Type | Name | Description
System.Int32 | index |
IHierarchicalStringList[] | array |
System.Int32 | arrayIndex |
System.Int32 | count |

IHierarchicalStringListCollection.Exists(Predicate<IHierarchicalStringList>)

Declaration
bool IHierarchicalStringListCollection.Exists(Predicate<IHierarchicalStringList> match)
Parameters
Type | Name | Description
System.Predicate<IHierarchicalStringList> | match |
Returns
Type | Description
System.Boolean |

IHierarchicalStringListCollection.Find(Predicate<IHierarchicalStringList>)

Declaration
IHierarchicalStringList IHierarchicalStringListCollection.Find(Predicate<IHierarchicalStringList> match)
Parameters
Type | Name | Description
System.Predicate<IHierarchicalStringList> | match |
Returns
Type | Description
IHierarchicalStringList |

IHierarchicalStringListCollection.FindAll(Predicate<IHierarchicalStringList>)

Declaration
List<IHierarchicalStringList> IHierarchicalStringListCollection.FindAll(Predicate<IHierarchicalStringList> match)
Parameters
Type | Name | Description
System.Predicate<IHierarchicalStringList> | match |
Returns
Type | Description
System.Collections.Generic.List<IHierarchicalStringList> |

IHierarchicalStringListCollection.FindIndex(Int32, Int32, Predicate<IHierarchicalStringList>)

Declaration
int IHierarchicalStringListCollection.FindIndex(int startIndex, int count, Predicate<IHierarchicalStringList> match)
Parameters
Type | Name | Description
System.Int32 | startIndex |
System.Int32 | count |
System.Predicate<IHierarchicalStringList> | match |
Returns
Type | Description
System.Int32 |

IHierarchicalStringListCollection.FindIndex(Int32, Predicate<IHierarchicalStringList>)

Declaration
int IHierarchicalStringListCollection.FindIndex(int startIndex, Predicate<IHierarchicalStringList> match)
Parameters
Type | Name | Description
System.Int32 | startIndex |
System.Predicate<IHierarchicalStringList> | match |
Returns
Type | Description
System.Int32 |

IHierarchicalStringListCollection.FindIndex(Predicate<IHierarchicalStringList>)

Declaration
int IHierarchicalStringListCollection.FindIndex(Predicate<IHierarchicalStringList> match)
Parameters
Type | Name | Description
System.Predicate<IHierarchicalStringList> | match |
Returns
Type | Description
System.Int32 |

IHierarchicalStringListCollection.FindLast(Predicate<IHierarchicalStringList>)

Declaration
IHierarchicalStringList IHierarchicalStringListCollection.FindLast(Predicate<IHierarchicalStringList> match)
Parameters
Type | Name | Description
System.Predicate<IHierarchicalStringList> | match |
Returns
Type | Description
IHierarchicalStringList |

IHierarchicalStringListCollection.FindLastIndex(Int32, Int32, Predicate<IHierarchicalStringList>)

Declaration
int IHierarchicalStringListCollection.FindLastIndex(int startIndex, int count, Predicate<IHierarchicalStringList> match)
Parameters
Type | Name | Description
System.Int32 | startIndex |
System.Int32 | count |
System.Predicate<IHierarchicalStringList> | match |
Returns
Type | Description
System.Int32 |

IHierarchicalStringListCollection.FindLastIndex(Int32, Predicate<IHierarchicalStringList>)

Declaration
int IHierarchicalStringListCollection.FindLastIndex(int startIndex, Predicate<IHierarchicalStringList> match)
Parameters
Type | Name | Description
System.Int32 | startIndex |
System.Predicate<IHierarchicalStringList> | match |
Returns
Type | Description
System.Int32 |

IHierarchicalStringListCollection.FindLastIndex(Predicate<IHierarchicalStringList>)

Declaration
int IHierarchicalStringListCollection.FindLastIndex(Predicate<IHierarchicalStringList> match)
Parameters
Type | Name | Description
System.Predicate<IHierarchicalStringList> | match |
Returns
Type | Description
System.Int32 |

IHierarchicalStringListCollection.ForEach(Action<IHierarchicalStringList>)

Declaration
void IHierarchicalStringListCollection.ForEach(Action<IHierarchicalStringList> action)
Parameters
Type | Name | Description
System.Action<IHierarchicalStringList> | action |

IHierarchicalStringListCollection.get_Capacity()

Declaration
int IHierarchicalStringListCollection.get_Capacity()
Returns
Type | Description
System.Int32 |

IHierarchicalStringListCollection.GetRange(Int32, Int32)

Declaration
List<IHierarchicalStringList> IHierarchicalStringListCollection.GetRange(int index, int count)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |
Returns
Type | Description
System.Collections.Generic.List<IHierarchicalStringList> |

IHierarchicalStringListCollection.IndexOf(IHierarchicalStringList, Int32)

Declaration
int IHierarchicalStringListCollection.IndexOf(IHierarchicalStringList item, int index)
Parameters
Type | Name | Description
IHierarchicalStringList | item |
System.Int32 | index |
Returns
Type | Description
System.Int32 |

IHierarchicalStringListCollection.IndexOf(IHierarchicalStringList, Int32, Int32)

Declaration
int IHierarchicalStringListCollection.IndexOf(IHierarchicalStringList item, int index, int count)
Parameters
Type | Name | Description
IHierarchicalStringList | item |
System.Int32 | index |
System.Int32 | count |
Returns
Type | Description
System.Int32 |

IHierarchicalStringListCollection.InsertRange(Int32, IEnumerable<IHierarchicalStringList>)

Declaration
void IHierarchicalStringListCollection.InsertRange(int index, IEnumerable<IHierarchicalStringList> collection)
Parameters
Type | Name | Description
System.Int32 | index |
System.Collections.Generic.IEnumerable<IHierarchicalStringList> | collection |

IHierarchicalStringListCollection.LastIndexOf(IHierarchicalStringList)

Declaration
int IHierarchicalStringListCollection.LastIndexOf(IHierarchicalStringList item)
Parameters
Type | Name | Description
IHierarchicalStringList | item |
Returns
Type | Description
System.Int32 |

IHierarchicalStringListCollection.LastIndexOf(IHierarchicalStringList, Int32)

Declaration
int IHierarchicalStringListCollection.LastIndexOf(IHierarchicalStringList item, int index)
Parameters
Type | Name | Description
IHierarchicalStringList | item |
System.Int32 | index |
Returns
Type | Description
System.Int32 |

IHierarchicalStringListCollection.LastIndexOf(IHierarchicalStringList, Int32, Int32)

Declaration
int IHierarchicalStringListCollection.LastIndexOf(IHierarchicalStringList item, int index, int count)
Parameters
Type | Name | Description
IHierarchicalStringList | item |
System.Int32 | index |
System.Int32 | count |
Returns
Type | Description
System.Int32 |

IHierarchicalStringListCollection.RemoveAll(Predicate<IHierarchicalStringList>)

Declaration
int IHierarchicalStringListCollection.RemoveAll(Predicate<IHierarchicalStringList> match)
Parameters
Type | Name | Description
System.Predicate<IHierarchicalStringList> | match |
Returns
Type | Description
System.Int32 |

IHierarchicalStringListCollection.RemoveRange(Int32, Int32)

Declaration
void IHierarchicalStringListCollection.RemoveRange(int index, int count)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |

IHierarchicalStringListCollection.Reverse()

Declaration
void IHierarchicalStringListCollection.Reverse()

IHierarchicalStringListCollection.Reverse(Int32, Int32)

Declaration
void IHierarchicalStringListCollection.Reverse(int index, int count)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |

IHierarchicalStringListCollection.set_Capacity(Int32)

Declaration
void IHierarchicalStringListCollection.set_Capacity(int value)
Parameters
Type | Name | Description
System.Int32 | value |

IHierarchicalStringListCollection.Sort()

Declaration
void IHierarchicalStringListCollection.Sort()

IHierarchicalStringListCollection.Sort(IComparer<IHierarchicalStringList>)

Declaration
void IHierarchicalStringListCollection.Sort(IComparer<IHierarchicalStringList> comparer)
Parameters
Type | Name | Description
System.Collections.Generic.IComparer<IHierarchicalStringList> | comparer |

IHierarchicalStringListCollection.Sort(Comparison<IHierarchicalStringList>)

Declaration
void IHierarchicalStringListCollection.Sort(Comparison<IHierarchicalStringList> comparison)
Parameters
Type | Name | Description
System.Comparison<IHierarchicalStringList> | comparison |

IHierarchicalStringListCollection.Sort(Int32, Int32, IComparer<IHierarchicalStringList>)

Declaration
void IHierarchicalStringListCollection.Sort(int index, int count, IComparer<IHierarchicalStringList> comparer)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |
System.Collections.Generic.IComparer<IHierarchicalStringList> | comparer |

IHierarchicalStringListCollection.ToArray()

Declaration
IHierarchicalStringList[] IHierarchicalStringListCollection.ToArray()
Returns
Type | Description
IHierarchicalStringList[] |

IHierarchicalStringListCollection.TrimExcess()

Declaration
void IHierarchicalStringListCollection.TrimExcess()

IHierarchicalStringListCollection.TrueForAll(Predicate<IHierarchicalStringList>)

Declaration
bool IHierarchicalStringListCollection.TrueForAll(Predicate<IHierarchicalStringList> match)
Parameters
Type | Name | Description
System.Predicate<IHierarchicalStringList> | match |
Returns
Type | Description
System.Boolean |

Implements

System.Collections.Generic.IList<T>
System.Collections.IList
System.Collections.ICollection
System.Collections.Generic.IReadOnlyList<T>
System.Collections.Generic.IReadOnlyCollection<T>
IHierarchicalStringListCollection
System.Collections.Generic.ICollection<T>
System.Collections.Generic.IEnumerable<T>
System.Collections.IEnumerable


Class HierarchicalStringShow | fcSDK Documentation

Class HierarchicalStringShow

Inheritance
System.Object
DataObject
ClarifyDataObject
HierarchicalStringShow
Implements
IDataObject
Inherited Members
ClarifyDataObject.GetCommentFieldValue(DataRow)
ClarifyDataObject.CommentFieldName
ClarifyDataObject.ObjectID
DataObject.SetUniqueID(Object)
DataObject.GetFieldValue(String)
DataObject.GetFieldValue(Int32)
DataObject.ContainsColumn(String)
DataObject.GetSafeInt32FieldValue(String)
DataObject.GetSafeInt32FieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeDoubleFieldValue(String)
DataObject.GetSafeDoubleFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeBooleanFieldValue(String)
DataObject.GetSafeBooleanFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeStringFieldValue(String)
DataObject.SetFieldValue(String, Object)
DataObject.GetSafeString(Object)
DataObject.UniqueID
DataObject.FieldValues
DataObject.ColumnMap
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataObjects
Assembly: fcSDK.dll
Syntax
public class HierarchicalStringShow : ClarifyDataObject, IDataObject

Properties

DefaultElement

Declaration
public IHierarchicalStringElement DefaultElement { get; }
Property Value
Type | Description
IHierarchicalStringElement |

Elements

Declaration
public HierarchicalStringElementCollection Elements { get; }
Property Value
Type | Description
HierarchicalStringElementCollection |

LastModifiedTime

Declaration
public DateTime LastModifiedTime { get; }
Property Value
Type | Description
System.DateTime |

Title

Declaration
public string Title { get; }
Property Value
Type | Description
System.String |

Implements

IDataObject


Interface IGlobalStringElement | fcSDK Documentation

Interface IGlobalStringElement

Inherited Members
IDataObject.GetFieldValue(String)
IDataObject.GetFieldValue(Int32)
IDataObject.ContainsColumn(String)
IDataObject.GetSafeInt32FieldValue(String)
IDataObject.GetSafeDoubleFieldValue(String)
IDataObject.GetSafeBooleanFieldValue(String)
IDataObject.GetSafeStringFieldValue(String)
IDataObject.UniqueID
IDataObject.FieldValues
IDataObject.ColumnMap
Namespace: FChoice.Foundation.Clarify.DataObjects
Assembly: fcSDK.dll
Syntax
public interface IGlobalStringElement : IDataObject

Properties

AdditionalInfo

Declaration
string AdditionalInfo { get; }
Property Value
Type | Description
System.String |

Description

Declaration
string Description { get; }
Property Value
Type | Description
System.String |

LocalizedTitle

Declaration
string LocalizedTitle { get; }
Property Value
Type | Description
System.String |

ObjectID

Declaration
int ObjectID { get; }
Property Value
Type | Description
System.Int32 |

Rank

Declaration
int Rank { get; }
Property Value
Type | Description
System.Int32 |

State

Declaration
int State { get; }
Property Value
Type | Description
System.Int32 |

Title

Declaration
string Title { get; }
Property Value
Type | Description
System.String |

Methods

GetLocalizedTitle(CultureInfo)

Declaration
string GetLocalizedTitle(CultureInfo specificCulture)
Parameters
Type | Name | Description
System.Globalization.CultureInfo | specificCulture |
Returns
Type | Description
System.String |


Interface IGlobalStringElementCollection | fcSDK Documentation

Interface IGlobalStringElementCollection

Inherited Members
System.Collections.Generic.IList<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.IndexOf(FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement)
System.Collections.Generic.IList<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.Insert(System.Int32, FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement)
System.Collections.Generic.IList<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.RemoveAt(System.Int32)
System.Collections.Generic.IList<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.Item[System.Int32]
System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.Add(FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement)
System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.Clear()
System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.Contains(FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement)
System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.CopyTo(FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement[], System.Int32)
System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.Remove(FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement)
System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.Count
System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.IsReadOnly
System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.DataObjects.IGlobalStringElement>.GetEnumerator()
Namespace: FChoice.Foundation.Clarify.DataObjects
Assembly: fcSDK.dll
Syntax
public interface IGlobalStringElementCollection : IList<IGlobalStringElement>, ICollection<IGlobalStringElement>, IEnumerable<IGlobalStringElement>, IEnumerable

Properties

ActiveElements

Declaration
IGlobalStringElementCollection ActiveElements { get; }
Property Value
Type | Description
IGlobalStringElementCollection |

Capacity

Declaration
int Capacity { get; set; }
Property Value
Type | Description
System.Int32 |

DefaultElement

Declaration
IGlobalStringElement DefaultElement { get; }
Property Value
Type | Description
IGlobalStringElement |

InactiveElements

Declaration
IGlobalStringElementCollection InactiveElements { get; }
Property Value
Type | Description
IGlobalStringElementCollection |

Item[String]

Declaration
IGlobalStringElement this[string title] { get; }
Parameters
Type | Name | Description
System.String | title |
Property Value
Type | Description
IGlobalStringElement |

Methods

AddElement(IGlobalStringElement, Boolean)

Declaration
void AddElement(IGlobalStringElement element, bool addToList)
Parameters
Type | Name | Description
IGlobalStringElement | element |
System.Boolean | addToList |

AddRange(IEnumerable<IGlobalStringElement>)

Declaration
void AddRange(IEnumerable<IGlobalStringElement> collection)
Parameters
Type | Name | Description
System.Collections.Generic.IEnumerable<IGlobalStringElement> | collection |

AsReadOnly()

Declaration
ReadOnlyCollection<IGlobalStringElement> AsReadOnly()
Returns
Type | Description
System.Collections.ObjectModel.ReadOnlyCollection<IGlobalStringElement> |

BinarySearch(IGlobalStringElement)

Declaration
int BinarySearch(IGlobalStringElement item)
Parameters
Type | Name | Description
IGlobalStringElement | item |
Returns
Type | Description
System.Int32 |

BinarySearch(IGlobalStringElement, IComparer<IGlobalStringElement>)

Declaration
int BinarySearch(IGlobalStringElement item, IComparer<IGlobalStringElement> comparer)
Parameters
Type | Name | Description
IGlobalStringElement | item |
System.Collections.Generic.IComparer<IGlobalStringElement> | comparer |
Returns
Type | Description
System.Int32 |

BinarySearch(Int32, Int32, IGlobalStringElement, IComparer<IGlobalStringElement>)

Declaration
int BinarySearch(int index, int count, IGlobalStringElement item, IComparer<IGlobalStringElement> comparer)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |
IGlobalStringElement | item |
System.Collections.Generic.IComparer<IGlobalStringElement> | comparer |
Returns
Type | Description
System.Int32 |

CopyTo(IGlobalStringElement[])

Declaration
void CopyTo(IGlobalStringElement[] array)
Parameters
Type | Name | Description
IGlobalStringElement[] | array |

CopyTo(Int32, IGlobalStringElement[], Int32, Int32)

Declaration
void CopyTo(int index, IGlobalStringElement[] array, int arrayIndex, int count)
Parameters
Type | Name | Description
System.Int32 | index |
IGlobalStringElement[] | array |
System.Int32 | arrayIndex |
System.Int32 | count |

Exists(Predicate<IGlobalStringElement>)

Declaration
bool Exists(Predicate<IGlobalStringElement> match)
Parameters
Type | Name | Description
System.Predicate<IGlobalStringElement> | match |
Returns
Type | Description
System.Boolean |

Find(Predicate<IGlobalStringElement>)

Declaration
IGlobalStringElement Find(Predicate<IGlobalStringElement> match)
Parameters
Type | Name | Description
System.Predicate<IGlobalStringElement> | match |
Returns
Type | Description
IGlobalStringElement |

FindAll(Predicate<IGlobalStringElement>)

Declaration
List<IGlobalStringElement> FindAll(Predicate<IGlobalStringElement> match)
Parameters
Type | Name | Description
System.Predicate<IGlobalStringElement> | match |
Returns
Type | Description
System.Collections.Generic.List<IGlobalStringElement> |

FindIndex(Int32, Int32, Predicate<IGlobalStringElement>)

Declaration
int FindIndex(int startIndex, int count, Predicate<IGlobalStringElement> match)
Parameters
Type | Name | Description
System.Int32 | startIndex |
System.Int32 | count |
System.Predicate<IGlobalStringElement> | match |
Returns
Type | Description
System.Int32 |

FindIndex(Int32, Predicate<IGlobalStringElement>)

Declaration
int FindIndex(int startIndex, Predicate<IGlobalStringElement> match)
Parameters
Type | Name | Description
System.Int32 | startIndex |
System.Predicate<IGlobalStringElement> | match |
Returns
Type | Description
System.Int32 |

FindIndex(Predicate<IGlobalStringElement>)

Declaration
int FindIndex(Predicate<IGlobalStringElement> match)
Parameters
Type | Name | Description
System.Predicate<IGlobalStringElement> | match |
Returns
Type | Description
System.Int32 |

FindLast(Predicate<IGlobalStringElement>)

Declaration
IGlobalStringElement FindLast(Predicate<IGlobalStringElement> match)
Parameters
Type | Name | Description
System.Predicate<IGlobalStringElement> | match |
Returns
Type | Description
IGlobalStringElement |

FindLastIndex(Int32, Int32, Predicate<IGlobalStringElement>)

Declaration
int FindLastIndex(int startIndex, int count, Predicate<IGlobalStringElement> match)
Parameters
Type | Name | Description
System.Int32 | startIndex |
System.Int32 | count |
System.Predicate<IGlobalStringElement> | match |
Returns
Type | Description
System.Int32 |

FindLastIndex(Int32, Predicate<IGlobalStringElement>)

Declaration
int FindLastIndex(int startIndex, Predicate<IGlobalStringElement> match)
Parameters
Type | Name | Description
System.Int32 | startIndex |
System.Predicate<IGlobalStringElement> | match |
Returns
Type | Description
System.Int32 |

FindLastIndex(Predicate<IGlobalStringElement>)

Declaration
int FindLastIndex(Predicate<IGlobalStringElement> match)
Parameters
Type | Name | Description
System.Predicate<IGlobalStringElement> | match |
Returns
Type | Description
System.Int32 |

ForEach(Action<IGlobalStringElement>)

Declaration
void ForEach(Action<IGlobalStringElement> action)
Parameters
Type | Name | Description
System.Action<IGlobalStringElement> | action |

GetElementByObjectId(Int32)

Declaration
IGlobalStringElement GetElementByObjectId(int objectId)
Parameters
Type | Name | Description
System.Int32 | objectId |
Returns
Type | Description
IGlobalStringElement |

GetElementByRank(Int32)

Declaration
IGlobalStringElement GetElementByRank(int rank)
Parameters
Type | Name | Description
System.Int32 | rank |
Returns
Type | Description
IGlobalStringElement |

GetItemByIndex(Int32)

Declaration
IGlobalStringElement GetItemByIndex(int index)
Parameters
Type | Name | Description
System.Int32 | index |
Returns
Type | Description
IGlobalStringElement |

GetRange(Int32, Int32)

Declaration
List<IGlobalStringElement> GetRange(int index, int count)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |
Returns
Type | Description
System.Collections.Generic.List<IGlobalStringElement> |

IndexOf(IGlobalStringElement, Int32)

Declaration
int IndexOf(IGlobalStringElement item, int index)
Parameters
Type | Name | Description
IGlobalStringElement | item |
System.Int32 | index |
Returns
Type | Description
System.Int32 |

IndexOf(IGlobalStringElement, Int32, Int32)

Declaration
int IndexOf(IGlobalStringElement item, int index, int count)
Parameters
Type | Name | Description
IGlobalStringElement | item |
System.Int32 | index |
System.Int32 | count |
Returns
Type | Description
System.Int32 |

InsertRange(Int32, IEnumerable<IGlobalStringElement>)

Declaration
void InsertRange(int index, IEnumerable<IGlobalStringElement> collection)
Parameters
Type | Name | Description
System.Int32 | index |
System.Collections.Generic.IEnumerable<IGlobalStringElement> | collection |

LastIndexOf(IGlobalStringElement)

Declaration
int LastIndexOf(IGlobalStringElement item)
Parameters
Type | Name | Description
IGlobalStringElement | item |
Returns
Type | Description
System.Int32 |

LastIndexOf(IGlobalStringElement, Int32)

Declaration
int LastIndexOf(IGlobalStringElement item, int index)
Parameters
Type | Name | Description
IGlobalStringElement | item |
System.Int32 | index |
Returns
Type | Description
System.Int32 |

LastIndexOf(IGlobalStringElement, Int32, Int32)

Declaration
int LastIndexOf(IGlobalStringElement item, int index, int count)
Parameters
Type | Name | Description
IGlobalStringElement | item |
System.Int32 | index |
System.Int32 | count |
Returns
Type | Description
System.Int32 |

RemoveAll(Predicate<IGlobalStringElement>)

Declaration
int RemoveAll(Predicate<IGlobalStringElement> match)
Parameters
Type | Name | Description
System.Predicate<IGlobalStringElement> | match |
Returns
Type | Description
System.Int32 |

RemoveRange(Int32, Int32)

Declaration
void RemoveRange(int index, int count)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |

Reverse()

Declaration
void Reverse()

Reverse(Int32, Int32)

Declaration
void Reverse(int index, int count)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |

Sort()

Declaration
void Sort()

Sort(IComparer<IGlobalStringElement>)

Declaration
void Sort(IComparer<IGlobalStringElement> comparer)
Parameters
Type | Name | Description
System.Collections.Generic.IComparer<IGlobalStringElement> | comparer |

Sort(Comparison<IGlobalStringElement>)

Declaration
void Sort(Comparison<IGlobalStringElement> comparison)
Parameters
Type | Name | Description
System.Comparison<IGlobalStringElement> | comparison |

Sort(Int32, Int32, IComparer<IGlobalStringElement>)

Declaration
void Sort(int index, int count, IComparer<IGlobalStringElement> comparer)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |
System.Collections.Generic.IComparer<IGlobalStringElement> | comparer |

ToArray()

Declaration
IGlobalStringElement[] ToArray()
Returns
Type | Description
IGlobalStringElement[] |

TrimExcess()

Declaration
void TrimExcess()

TrueForAll(Predicate<IGlobalStringElement>)

Declaration
bool TrueForAll(Predicate<IGlobalStringElement> match)
Parameters
Type | Name | Description
System.Predicate<IGlobalStringElement> | match |
Returns
Type | Description
System.Boolean |


Interface IGlobalStringList | fcSDK Documentation

Interface IGlobalStringList

Inherited Members
IDataObject.GetFieldValue(String)
IDataObject.GetFieldValue(Int32)
IDataObject.ContainsColumn(String)
IDataObject.GetSafeInt32FieldValue(String)
IDataObject.GetSafeDoubleFieldValue(String)
IDataObject.GetSafeBooleanFieldValue(String)
IDataObject.GetSafeStringFieldValue(String)
IDataObject.UniqueID
IDataObject.FieldValues
IDataObject.ColumnMap
Namespace: FChoice.Foundation.Clarify.DataObjects
Assembly: fcSDK.dll
Syntax
public interface IGlobalStringList : IDataObject

Properties

ActiveElements

Declaration
IGlobalStringElementCollection ActiveElements { get; }
Property Value
Type | Description
IGlobalStringElementCollection |

AdditionalInfo

Declaration
string AdditionalInfo { get; }
Property Value
Type | Description
System.String |

DefaultElement

Declaration
IGlobalStringElement DefaultElement { get; }
Property Value
Type | Description
IGlobalStringElement |

Elements

Declaration
IGlobalStringElementCollection Elements { get; }
Property Value
Type | Description
IGlobalStringElementCollection |

InactiveElements

Declaration
IGlobalStringElementCollection InactiveElements { get; }
Property Value
Type | Description
IGlobalStringElementCollection |

ListID

Declaration
int ListID { get; }
Property Value
Type | Description
System.Int32 |

LocaleID

Declaration
int LocaleID { get; }
Property Value
Type | Description
System.Int32 |

ObjectID

Declaration
int ObjectID { get; }
Property Value
Type | Description
System.Int32 |

Title

Declaration
string Title { get; }
Property Value
Type | Description
System.String |


Interface IGlobalStringListCollection | fcSDK Documentation

Interface IGlobalStringListCollection

Inherited Members
System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.Add(FChoice.Foundation.Clarify.DataObjects.IGlobalStringList)
System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.Clear()
System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.Contains(FChoice.Foundation.Clarify.DataObjects.IGlobalStringList)
System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.CopyTo(FChoice.Foundation.Clarify.DataObjects.IGlobalStringList[], System.Int32)
System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.Remove(FChoice.Foundation.Clarify.DataObjects.IGlobalStringList)
System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.Count
System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.IsReadOnly
System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.DataObjects.IGlobalStringList>.GetEnumerator()
Namespace: FChoice.Foundation.Clarify.DataObjects
Assembly: fcSDK.dll
Syntax
public interface IGlobalStringListCollection : ICollection<IGlobalStringList>, IEnumerable<IGlobalStringList>, IEnumerable

Properties

Capacity

Declaration
int Capacity { get; set; }
Property Value
Type | Description
System.Int32 |

Item[Int32]

Declaration
IGlobalStringList this[int index] { get; set; }
Parameters
Type | Name | Description
System.Int32 | index |
Property Value
Type | Description
IGlobalStringList |

Item[String]

Declaration
IGlobalStringList this[string title] { get; }
Parameters
Type | Name | Description
System.String | title |
Property Value
Type | Description
IGlobalStringList |

Methods

AddRange(IEnumerable<IGlobalStringList>)

Declaration
void AddRange(IEnumerable<IGlobalStringList> collection)
Parameters
Type | Name | Description
System.Collections.Generic.IEnumerable<IGlobalStringList> | collection |

AsReadOnly()

Declaration
ReadOnlyCollection<IGlobalStringList> AsReadOnly()
Returns
Type | Description
System.Collections.ObjectModel.ReadOnlyCollection<IGlobalStringList> |

BinarySearch(IGlobalStringList)

Declaration
int BinarySearch(IGlobalStringList item)
Parameters
Type | Name | Description
IGlobalStringList | item |
Returns
Type | Description
System.Int32 |

BinarySearch(IGlobalStringList, IComparer<IGlobalStringList>)

Declaration
int BinarySearch(IGlobalStringList item, IComparer<IGlobalStringList> comparer)
Parameters
Type | Name | Description
IGlobalStringList | item |
System.Collections.Generic.IComparer<IGlobalStringList> | comparer |
Returns
Type | Description
System.Int32 |

BinarySearch(Int32, Int32, IGlobalStringList, IComparer<IGlobalStringList>)

Declaration
int BinarySearch(int index, int count, IGlobalStringList item, IComparer<IGlobalStringList> comparer)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |
IGlobalStringList | item |
System.Collections.Generic.IComparer<IGlobalStringList> | comparer |
Returns
Type | Description
System.Int32 |

CopyTo(IGlobalStringList[])

Declaration
void CopyTo(IGlobalStringList[] array)
Parameters
Type | Name | Description
IGlobalStringList[] | array |

CopyTo(Int32, IGlobalStringList[], Int32, Int32)

Declaration
void CopyTo(int index, IGlobalStringList[] array, int arrayIndex, int count)
Parameters
Type | Name | Description
System.Int32 | index |
IGlobalStringList[] | array |
System.Int32 | arrayIndex |
System.Int32 | count |

Exists(Predicate<IGlobalStringList>)

Declaration
bool Exists(Predicate<IGlobalStringList> match)
Parameters
Type | Name | Description
System.Predicate<IGlobalStringList> | match |
Returns
Type | Description
System.Boolean |

Find(Predicate<IGlobalStringList>)

Declaration
IGlobalStringList Find(Predicate<IGlobalStringList> match)
Parameters
Type | Name | Description
System.Predicate<IGlobalStringList> | match |
Returns
Type | Description
IGlobalStringList |

FindAll(Predicate<IGlobalStringList>)

Declaration
List<IGlobalStringList> FindAll(Predicate<IGlobalStringList> match)
Parameters
Type | Name | Description
System.Predicate<IGlobalStringList> | match |
Returns
Type | Description
System.Collections.Generic.List<IGlobalStringList> |

FindIndex(Int32, Int32, Predicate<IGlobalStringList>)

Declaration
int FindIndex(int startIndex, int count, Predicate<IGlobalStringList> match)
Parameters
Type | Name | Description
System.Int32 | startIndex |
System.Int32 | count |
System.Predicate<IGlobalStringList> | match |
Returns
Type | Description
System.Int32 |

FindIndex(Int32, Predicate<IGlobalStringList>)

Declaration
int FindIndex(int startIndex, Predicate<IGlobalStringList> match)
Parameters
Type | Name | Description
System.Int32 | startIndex |
System.Predicate<IGlobalStringList> | match |
Returns
Type | Description
System.Int32 |

FindIndex(Predicate<IGlobalStringList>)

Declaration
int FindIndex(Predicate<IGlobalStringList> match)
Parameters
Type | Name | Description
System.Predicate<IGlobalStringList> | match |
Returns
Type | Description
System.Int32 |

FindLast(Predicate<IGlobalStringList>)

Declaration
IGlobalStringList FindLast(Predicate<IGlobalStringList> match)
Parameters
Type | Name | Description
System.Predicate<IGlobalStringList> | match |
Returns
Type | Description
IGlobalStringList |

FindLastIndex(Int32, Int32, Predicate<IGlobalStringList>)

Declaration
int FindLastIndex(int startIndex, int count, Predicate<IGlobalStringList> match)
Parameters
Type | Name | Description
System.Int32 | startIndex |
System.Int32 | count |
System.Predicate<IGlobalStringList> | match |
Returns
Type | Description
System.Int32 |

FindLastIndex(Int32, Predicate<IGlobalStringList>)

Declaration
int FindLastIndex(int startIndex, Predicate<IGlobalStringList> match)
Parameters
Type | Name | Description
System.Int32 | startIndex |
System.Predicate<IGlobalStringList> | match |
Returns
Type | Description
System.Int32 |

FindLastIndex(Predicate<IGlobalStringList>)

Declaration
int FindLastIndex(Predicate<IGlobalStringList> match)
Parameters
Type | Name | Description
System.Predicate<IGlobalStringList> | match |
Returns
Type | Description
System.Int32 |

ForEach(Action<IGlobalStringList>)

Declaration
void ForEach(Action<IGlobalStringList> action)
Parameters
Type | Name | Description
System.Action<IGlobalStringList> | action |

GetItemByIndex(Int32)

Declaration
IGlobalStringList GetItemByIndex(int index)
Parameters
Type | Name | Description
System.Int32 | index |
Returns
Type | Description
IGlobalStringList |

GetRange(Int32, Int32)

Declaration
List<IGlobalStringList> GetRange(int index, int count)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |
Returns
Type | Description
System.Collections.Generic.List<IGlobalStringList> |

IndexOf(IGlobalStringList)

Declaration
int IndexOf(IGlobalStringList item)
Parameters
Type | Name | Description
IGlobalStringList | item |
Returns
Type | Description
System.Int32 |

IndexOf(IGlobalStringList, Int32)

Declaration
int IndexOf(IGlobalStringList item, int index)
Parameters
Type | Name | Description
IGlobalStringList | item |
System.Int32 | index |
Returns
Type | Description
System.Int32 |

IndexOf(IGlobalStringList, Int32, Int32)

Declaration
int IndexOf(IGlobalStringList item, int index, int count)
Parameters
Type | Name | Description
IGlobalStringList | item |
System.Int32 | index |
System.Int32 | count |
Returns
Type | Description
System.Int32 |

Insert(Int32, IGlobalStringList)

Declaration
void Insert(int index, IGlobalStringList item)
Parameters
Type | Name | Description
System.Int32 | index |
IGlobalStringList | item |

InsertRange(Int32, IEnumerable<IGlobalStringList>)

Declaration
void InsertRange(int index, IEnumerable<IGlobalStringList> collection)
Parameters
Type | Name | Description
System.Int32 | index |
System.Collections.Generic.IEnumerable<IGlobalStringList> | collection |

LastIndexOf(IGlobalStringList)

Declaration
int LastIndexOf(IGlobalStringList item)
Parameters
Type | Name | Description
IGlobalStringList | item |
Returns
Type | Description
System.Int32 |

LastIndexOf(IGlobalStringList, Int32)

Declaration
int LastIndexOf(IGlobalStringList item, int index)
Parameters
Type | Name | Description
IGlobalStringList | item |
System.Int32 | index |
Returns
Type | Description
System.Int32 |

LastIndexOf(IGlobalStringList, Int32, Int32)

Declaration
int LastIndexOf(IGlobalStringList item, int index, int count)
Parameters
Type | Name | Description
IGlobalStringList | item |
System.Int32 | index |
System.Int32 | count |
Returns
Type | Description
System.Int32 |

RemoveAll(Predicate<IGlobalStringList>)

Declaration
int RemoveAll(Predicate<IGlobalStringList> match)
Parameters
Type | Name | Description
System.Predicate<IGlobalStringList> | match |
Returns
Type | Description
System.Int32 |

RemoveAt(Int32)

Declaration
void RemoveAt(int index)
Parameters
Type | Name | Description
System.Int32 | index |

RemoveRange(Int32, Int32)

Declaration
void RemoveRange(int index, int count)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |

Reverse()

Declaration
void Reverse()

Reverse(Int32, Int32)

Declaration
void Reverse(int index, int count)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |

Sort()

Declaration
void Sort()

Sort(IComparer<IGlobalStringList>)

Declaration
void Sort(IComparer<IGlobalStringList> comparer)
Parameters
Type | Name | Description
System.Collections.Generic.IComparer<IGlobalStringList> | comparer |

Sort(Comparison<IGlobalStringList>)

Declaration
void Sort(Comparison<IGlobalStringList> comparison)
Parameters
Type | Name | Description
System.Comparison<IGlobalStringList> | comparison |

Sort(Int32, Int32, IComparer<IGlobalStringList>)

Declaration
void Sort(int index, int count, IComparer<IGlobalStringList> comparer)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |
System.Collections.Generic.IComparer<IGlobalStringList> | comparer |

ToArray()

Declaration
IGlobalStringList[] ToArray()
Returns
Type | Description
IGlobalStringList[] |

TrimExcess()

Declaration
void TrimExcess()

TrueForAll(Predicate<IGlobalStringList>)

Declaration
bool TrueForAll(Predicate<IGlobalStringList> match)
Parameters
Type | Name | Description
System.Predicate<IGlobalStringList> | match |
Returns
Type | Description
System.Boolean |


Interface IHierarchicalStringElement | fcSDK Documentation

Interface IHierarchicalStringElement

Inherited Members
IDataObject.GetFieldValue(String)
IDataObject.GetFieldValue(Int32)
IDataObject.ContainsColumn(String)
IDataObject.GetSafeInt32FieldValue(String)
IDataObject.GetSafeDoubleFieldValue(String)
IDataObject.GetSafeBooleanFieldValue(String)
IDataObject.GetSafeStringFieldValue(String)
IDataObject.UniqueID
IDataObject.FieldValues
IDataObject.ColumnMap
Namespace: FChoice.Foundation.Clarify.DataObjects
Assembly: fcSDK.dll
Syntax
public interface IHierarchicalStringElement : IDataObject

Properties

Elements

Declaration
IHierarchicalStringElementCollection Elements { get; }
Property Value
Type | Description
IHierarchicalStringElementCollection |

IsActive

Declaration
bool IsActive { get; }
Property Value
Type | Description
System.Boolean |

IsDefault

Declaration
bool IsDefault { get; }
Property Value
Type | Description
System.Boolean |

LocalizedTitle

Declaration
string LocalizedTitle { get; }
Property Value
Type | Description
System.String |

ObjectID

Declaration
int ObjectID { get; }
Property Value
Type | Description
System.Int32 |

Rank

Declaration
int Rank { get; }
Property Value
Type | Description
System.Int32 |

State

Declaration
string State { get; }
Property Value
Type | Description
System.String |

Title

Declaration
string Title { get; }
Property Value
Type | Description
System.String |

Methods

GetLocalizedTitle(CultureInfo)

Declaration
string GetLocalizedTitle(CultureInfo specificCulture)
Parameters
Type | Name | Description
System.Globalization.CultureInfo | specificCulture |
Returns
Type | Description
System.String |


Interface IHierarchicalStringElementCollection | fcSDK Documentation

Interface IHierarchicalStringElementCollection

Inherited Members
System.Collections.Generic.IList<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.IndexOf(FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement)
System.Collections.Generic.IList<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.Insert(System.Int32, FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement)
System.Collections.Generic.IList<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.RemoveAt(System.Int32)
System.Collections.Generic.IList<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.Item[System.Int32]
System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.Add(FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement)
System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.Clear()
System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.Contains(FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement)
System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.CopyTo(FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement[], System.Int32)
System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.Remove(FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement)
System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.Count
System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.IsReadOnly
System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringElement>.GetEnumerator()
Namespace: FChoice.Foundation.Clarify.DataObjects
Assembly: fcSDK.dll
Syntax
public interface IHierarchicalStringElementCollection : IList<IHierarchicalStringElement>, ICollection<IHierarchicalStringElement>, IEnumerable<IHierarchicalStringElement>, IEnumerable

Properties

ActiveElements

Declaration
HierarchicalStringElementCollection ActiveElements { get; }
Property Value
Type | Description
HierarchicalStringElementCollection |

Capacity

Declaration
int Capacity { get; set; }
Property Value
Type | Description
System.Int32 |

DefaultElement

Declaration
IHierarchicalStringElement DefaultElement { get; }
Property Value
Type | Description
IHierarchicalStringElement |

Item[String]

Declaration
IHierarchicalStringElement this[string title] { get; }
Parameters
Type | Name | Description
System.String | title |
Property Value
Type | Description
IHierarchicalStringElement |

Methods

AddRange(IEnumerable<IHierarchicalStringElement>)

Declaration
void AddRange(IEnumerable<IHierarchicalStringElement> collection)
Parameters
Type | Name | Description
System.Collections.Generic.IEnumerable<IHierarchicalStringElement> | collection |

AsReadOnly()

Declaration
ReadOnlyCollection<IHierarchicalStringElement> AsReadOnly()
Returns
Type | Description
System.Collections.ObjectModel.ReadOnlyCollection<IHierarchicalStringElement> |

BinarySearch(IHierarchicalStringElement)

Declaration
int BinarySearch(IHierarchicalStringElement item)
Parameters
Type | Name | Description
IHierarchicalStringElement | item |
Returns
Type | Description
System.Int32 |

BinarySearch(IHierarchicalStringElement, IComparer<IHierarchicalStringElement>)

Declaration
int BinarySearch(IHierarchicalStringElement item, IComparer<IHierarchicalStringElement> comparer)
Parameters
Type | Name | Description
IHierarchicalStringElement | item |
System.Collections.Generic.IComparer<IHierarchicalStringElement> | comparer |
Returns
Type | Description
System.Int32 |

BinarySearch(Int32, Int32, IHierarchicalStringElement, IComparer<IHierarchicalStringElement>)

Declaration
int BinarySearch(int index, int count, IHierarchicalStringElement item, IComparer<IHierarchicalStringElement> comparer)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |
IHierarchicalStringElement | item |
System.Collections.Generic.IComparer<IHierarchicalStringElement> | comparer |
Returns
Type | Description
System.Int32 |

CopyTo(IHierarchicalStringElement[])

Declaration
void CopyTo(IHierarchicalStringElement[] array)
Parameters
Type | Name | Description
IHierarchicalStringElement[] | array |

CopyTo(Int32, IHierarchicalStringElement[], Int32, Int32)

Declaration
void CopyTo(int index, IHierarchicalStringElement[] array, int arrayIndex, int count)
Parameters
Type | Name | Description
System.Int32 | index |
IHierarchicalStringElement[] | array |
System.Int32 | arrayIndex |
System.Int32 | count |

Exists(Predicate<IHierarchicalStringElement>)

Declaration
bool Exists(Predicate<IHierarchicalStringElement> match)
Parameters
Type | Name | Description
System.Predicate<IHierarchicalStringElement> | match |
Returns
Type | Description
System.Boolean |

Find(Predicate<IHierarchicalStringElement>)

Declaration
IHierarchicalStringElement Find(Predicate<IHierarchicalStringElement> match)
Parameters
Type | Name | Description
System.Predicate<IHierarchicalStringElement> | match |
Returns
Type | Description
IHierarchicalStringElement |

FindAll(Predicate<IHierarchicalStringElement>)

Declaration
List<IHierarchicalStringElement> FindAll(Predicate<IHierarchicalStringElement> match)
Parameters
Type | Name | Description
System.Predicate<IHierarchicalStringElement> | match |
Returns
Type | Description
System.Collections.Generic.List<IHierarchicalStringElement> |

FindIndex(Int32, Int32, Predicate<IHierarchicalStringElement>)

Declaration
int FindIndex(int startIndex, int count, Predicate<IHierarchicalStringElement> match)
Parameters
Type | Name | Description
System.Int32 | startIndex |
System.Int32 | count |
System.Predicate<IHierarchicalStringElement> | match |
Returns
Type | Description
System.Int32 |

FindIndex(Int32, Predicate<IHierarchicalStringElement>)

Declaration
int FindIndex(int startIndex, Predicate<IHierarchicalStringElement> match)
Parameters
Type | Name | Description
System.Int32 | startIndex |
System.Predicate<IHierarchicalStringElement> | match |
Returns
Type | Description
System.Int32 |

FindIndex(Predicate<IHierarchicalStringElement>)

Declaration
int FindIndex(Predicate<IHierarchicalStringElement> match)
Parameters
Type | Name | Description
System.Predicate<IHierarchicalStringElement> | match |
Returns
Type | Description
System.Int32 |

FindLast(Predicate<IHierarchicalStringElement>)

Declaration
IHierarchicalStringElement FindLast(Predicate<IHierarchicalStringElement> match)
Parameters
Type | Name | Description
System.Predicate<IHierarchicalStringElement> | match |
Returns
Type | Description
IHierarchicalStringElement |

FindLastIndex(Int32, Int32, Predicate<IHierarchicalStringElement>)

Declaration
int FindLastIndex(int startIndex, int count, Predicate<IHierarchicalStringElement> match)
Parameters
Type | Name | Description
System.Int32 | startIndex |
System.Int32 | count |
System.Predicate<IHierarchicalStringElement> | match |
Returns
Type | Description
System.Int32 |

FindLastIndex(Int32, Predicate<IHierarchicalStringElement>)

Declaration
int FindLastIndex(int startIndex, Predicate<IHierarchicalStringElement> match)
Parameters
Type | Name | Description
System.Int32 | startIndex |
System.Predicate<IHierarchicalStringElement> | match |
Returns
Type | Description
System.Int32 |

FindLastIndex(Predicate<IHierarchicalStringElement>)

Declaration
int FindLastIndex(Predicate<IHierarchicalStringElement> match)
Parameters
Type | Name | Description
System.Predicate<IHierarchicalStringElement> | match |
Returns
Type | Description
System.Int32 |

ForEach(Action<IHierarchicalStringElement>)

Declaration
void ForEach(Action<IHierarchicalStringElement> action)
Parameters
Type | Name | Description
System.Action<IHierarchicalStringElement> | action |

GetByObjID(Int32)

Declaration
IHierarchicalStringElement GetByObjID(int objectID)
Parameters
Type | Name | Description
System.Int32 | objectID |
Returns
Type | Description
IHierarchicalStringElement |

GetItemByIndex(Int32)

Declaration
IHierarchicalStringElement GetItemByIndex(int index)
Parameters
Type | Name | Description
System.Int32 | index |
Returns
Type | Description
IHierarchicalStringElement |

GetRange(Int32, Int32)

Declaration
List<IHierarchicalStringElement> GetRange(int index, int count)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |
Returns
Type | Description
System.Collections.Generic.List<IHierarchicalStringElement> |

IndexOf(IHierarchicalStringElement, Int32)

Declaration
int IndexOf(IHierarchicalStringElement item, int index)
Parameters
Type | Name | Description
IHierarchicalStringElement | item |
System.Int32 | index |
Returns
Type | Description
System.Int32 |

IndexOf(IHierarchicalStringElement, Int32, Int32)

Declaration
int IndexOf(IHierarchicalStringElement item, int index, int count)
Parameters
Type | Name | Description
IHierarchicalStringElement | item |
System.Int32 | index |
System.Int32 | count |
Returns
Type | Description
System.Int32 |

InsertRange(Int32, IEnumerable<IHierarchicalStringElement>)

Declaration
void InsertRange(int index, IEnumerable<IHierarchicalStringElement> collection)
Parameters
Type | Name | Description
System.Int32 | index |
System.Collections.Generic.IEnumerable<IHierarchicalStringElement> | collection |

LastIndexOf(IHierarchicalStringElement)

Declaration
int LastIndexOf(IHierarchicalStringElement item)
Parameters
Type | Name | Description
IHierarchicalStringElement | item |
Returns
Type | Description
System.Int32 |

LastIndexOf(IHierarchicalStringElement, Int32)

Declaration
int LastIndexOf(IHierarchicalStringElement item, int index)
Parameters
Type | Name | Description
IHierarchicalStringElement | item |
System.Int32 | index |
Returns
Type | Description
System.Int32 |

LastIndexOf(IHierarchicalStringElement, Int32, Int32)

Declaration
int LastIndexOf(IHierarchicalStringElement item, int index, int count)
Parameters
Type | Name | Description
IHierarchicalStringElement | item |
System.Int32 | index |
System.Int32 | count |
Returns
Type | Description
System.Int32 |

RemoveAll(Predicate<IHierarchicalStringElement>)

Declaration
int RemoveAll(Predicate<IHierarchicalStringElement> match)
Parameters
Type | Name | Description
System.Predicate<IHierarchicalStringElement> | match |
Returns
Type | Description
System.Int32 |

RemoveRange(Int32, Int32)

Declaration
void RemoveRange(int index, int count)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |

Reverse()

Declaration
void Reverse()

Reverse(Int32, Int32)

Declaration
void Reverse(int index, int count)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |

Sort()

Declaration
void Sort()

Sort(IComparer<IHierarchicalStringElement>)

Declaration
void Sort(IComparer<IHierarchicalStringElement> comparer)
Parameters
Type | Name | Description
System.Collections.Generic.IComparer<IHierarchicalStringElement> | comparer |

Sort(Comparison<IHierarchicalStringElement>)

Declaration
void Sort(Comparison<IHierarchicalStringElement> comparison)
Parameters
Type | Name | Description
System.Comparison<IHierarchicalStringElement> | comparison |

Sort(Int32, Int32, IComparer<IHierarchicalStringElement>)

Declaration
void Sort(int index, int count, IComparer<IHierarchicalStringElement> comparer)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |
System.Collections.Generic.IComparer<IHierarchicalStringElement> | comparer |

ToArray()

Declaration
IHierarchicalStringElement[] ToArray()
Returns
Type | Description
IHierarchicalStringElement[] |

TrimExcess()

Declaration
void TrimExcess()

TrueForAll(Predicate<IHierarchicalStringElement>)

Declaration
bool TrueForAll(Predicate<IHierarchicalStringElement> match)
Parameters
Type | Name | Description
System.Predicate<IHierarchicalStringElement> | match |
Returns
Type | Description
System.Boolean |


Interface IHierarchicalStringList | fcSDK Documentation

Interface IHierarchicalStringList

Inherited Members
IDataObject.GetFieldValue(String)
IDataObject.GetFieldValue(Int32)
IDataObject.ContainsColumn(String)
IDataObject.GetSafeInt32FieldValue(String)
IDataObject.GetSafeDoubleFieldValue(String)
IDataObject.GetSafeBooleanFieldValue(String)
IDataObject.GetSafeStringFieldValue(String)
IDataObject.UniqueID
IDataObject.FieldValues
IDataObject.ColumnMap
Namespace: FChoice.Foundation.Clarify.DataObjects
Assembly: fcSDK.dll
Syntax
public interface IHierarchicalStringList : IDataObject

Properties

ActiveElements

Declaration
IHierarchicalStringElementCollection ActiveElements { get; }
Property Value
Type | Description
IHierarchicalStringElementCollection |

Description

Declaration
string Description { get; }
Property Value
Type | Description
System.String |

Elements

Declaration
IHierarchicalStringElementCollection Elements { get; }
Property Value
Type | Description
IHierarchicalStringElementCollection |

InactiveElements

Declaration
IHierarchicalStringElementCollection InactiveElements { get; }
Property Value
Type | Description
IHierarchicalStringElementCollection |

ListID

Declaration
int ListID { get; }
Property Value
Type | Description
System.Int32 |

ObjectID

Declaration
int ObjectID { get; }
Property Value
Type | Description
System.Int32 |

Title

Declaration
string Title { get; }
Property Value
Type | Description
System.String |


Interface IHierarchicalStringListCollection | fcSDK Documentation

Interface IHierarchicalStringListCollection

Inherited Members
System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.Add(FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList)
System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.Clear()
System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.Contains(FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList)
System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.CopyTo(FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList[], System.Int32)
System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.Remove(FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList)
System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.Count
System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.IsReadOnly
System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.DataObjects.IHierarchicalStringList>.GetEnumerator()
Namespace: FChoice.Foundation.Clarify.DataObjects
Assembly: fcSDK.dll
Syntax
public interface IHierarchicalStringListCollection : ICollection<IHierarchicalStringList>, IEnumerable<IHierarchicalStringList>, IEnumerable

Properties

Capacity

Declaration
int Capacity { get; set; }
Property Value
Type | Description
System.Int32 |

Item[String]

Declaration
IHierarchicalStringList this[string title] { get; }
Parameters
Type | Name | Description
System.String | title |
Property Value
Type | Description
IHierarchicalStringList |

Methods

AddRange(IEnumerable<IHierarchicalStringList>)

Declaration
void AddRange(IEnumerable<IHierarchicalStringList> collection)
Parameters
Type | Name | Description
System.Collections.Generic.IEnumerable<IHierarchicalStringList> | collection |

AsReadOnly()

Declaration
ReadOnlyCollection<IHierarchicalStringList> AsReadOnly()
Returns
Type | Description
System.Collections.ObjectModel.ReadOnlyCollection<IHierarchicalStringList> |

BinarySearch(IHierarchicalStringList)

Declaration
int BinarySearch(IHierarchicalStringList item)
Parameters
Type | Name | Description
IHierarchicalStringList | item |
Returns
Type | Description
System.Int32 |

BinarySearch(IHierarchicalStringList, IComparer<IHierarchicalStringList>)

Declaration
int BinarySearch(IHierarchicalStringList item, IComparer<IHierarchicalStringList> comparer)
Parameters
Type | Name | Description
IHierarchicalStringList | item |
System.Collections.Generic.IComparer<IHierarchicalStringList> | comparer |
Returns
Type | Description
System.Int32 |

BinarySearch(Int32, Int32, IHierarchicalStringList, IComparer<IHierarchicalStringList>)

Declaration
int BinarySearch(int index, int count, IHierarchicalStringList item, IComparer<IHierarchicalStringList> comparer)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |
IHierarchicalStringList | item |
System.Collections.Generic.IComparer<IHierarchicalStringList> | comparer |
Returns
Type | Description
System.Int32 |

CopyTo(IHierarchicalStringList[])

Declaration
void CopyTo(IHierarchicalStringList[] array)
Parameters
Type | Name | Description
IHierarchicalStringList[] | array |

CopyTo(Int32, IHierarchicalStringList[], Int32, Int32)

Declaration
void CopyTo(int index, IHierarchicalStringList[] array, int arrayIndex, int count)
Parameters
Type | Name | Description
System.Int32 | index |
IHierarchicalStringList[] | array |
System.Int32 | arrayIndex |
System.Int32 | count |

Exists(Predicate<IHierarchicalStringList>)

Declaration
bool Exists(Predicate<IHierarchicalStringList> match)
Parameters
Type | Name | Description
System.Predicate<IHierarchicalStringList> | match |
Returns
Type | Description
System.Boolean |

Find(Predicate<IHierarchicalStringList>)

Declaration
IHierarchicalStringList Find(Predicate<IHierarchicalStringList> match)
Parameters
Type | Name | Description
System.Predicate<IHierarchicalStringList> | match |
Returns
Type | Description
IHierarchicalStringList |

FindAll(Predicate<IHierarchicalStringList>)

Declaration
List<IHierarchicalStringList> FindAll(Predicate<IHierarchicalStringList> match)
Parameters
Type | Name | Description
System.Predicate<IHierarchicalStringList> | match |
Returns
Type | Description
System.Collections.Generic.List<IHierarchicalStringList> |

FindIndex(Int32, Int32, Predicate<IHierarchicalStringList>)

Declaration
int FindIndex(int startIndex, int count, Predicate<IHierarchicalStringList> match)
Parameters
Type | Name | Description
System.Int32 | startIndex |
System.Int32 | count |
System.Predicate<IHierarchicalStringList> | match |
Returns
Type | Description
System.Int32 |

FindIndex(Int32, Predicate<IHierarchicalStringList>)

Declaration
int FindIndex(int startIndex, Predicate<IHierarchicalStringList> match)
Parameters
Type | Name | Description
System.Int32 | startIndex |
System.Predicate<IHierarchicalStringList> | match |
Returns
Type | Description
System.Int32 |

FindIndex(Predicate<IHierarchicalStringList>)

Declaration
int FindIndex(Predicate<IHierarchicalStringList> match)
Parameters
Type | Name | Description
System.Predicate<IHierarchicalStringList> | match |
Returns
Type | Description
System.Int32 |

FindLast(Predicate<IHierarchicalStringList>)

Declaration
IHierarchicalStringList FindLast(Predicate<IHierarchicalStringList> match)
Parameters
Type | Name | Description
System.Predicate<IHierarchicalStringList> | match |
Returns
Type | Description
IHierarchicalStringList |

FindLastIndex(Int32, Int32, Predicate<IHierarchicalStringList>)

Declaration
int FindLastIndex(int startIndex, int count, Predicate<IHierarchicalStringList> match)
Parameters
Type | Name | Description
System.Int32 | startIndex |
System.Int32 | count |
System.Predicate<IHierarchicalStringList> | match |
Returns
Type | Description
System.Int32 |

FindLastIndex(Int32, Predicate<IHierarchicalStringList>)

Declaration
int FindLastIndex(int startIndex, Predicate<IHierarchicalStringList> match)
Parameters
Type | Name | Description
System.Int32 | startIndex |
System.Predicate<IHierarchicalStringList> | match |
Returns
Type | Description
System.Int32 |

FindLastIndex(Predicate<IHierarchicalStringList>)

Declaration
int FindLastIndex(Predicate<IHierarchicalStringList> match)
Parameters
Type | Name | Description
System.Predicate<IHierarchicalStringList> | match |
Returns
Type | Description
System.Int32 |

ForEach(Action<IHierarchicalStringList>)

Declaration
void ForEach(Action<IHierarchicalStringList> action)
Parameters
Type | Name | Description
System.Action<IHierarchicalStringList> | action |

GetItemByIndex(Int32)

Declaration
IHierarchicalStringList GetItemByIndex(int index)
Parameters
Type | Name | Description
System.Int32 | index |
Returns
Type | Description
IHierarchicalStringList |

GetRange(Int32, Int32)

Declaration
List<IHierarchicalStringList> GetRange(int index, int count)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |
Returns
Type | Description
System.Collections.Generic.List<IHierarchicalStringList> |

IndexOf(IHierarchicalStringList, Int32)

Declaration
int IndexOf(IHierarchicalStringList item, int index)
Parameters
Type | Name | Description
IHierarchicalStringList | item |
System.Int32 | index |
Returns
Type | Description
System.Int32 |

IndexOf(IHierarchicalStringList, Int32, Int32)

Declaration
int IndexOf(IHierarchicalStringList item, int index, int count)
Parameters
Type | Name | Description
IHierarchicalStringList | item |
System.Int32 | index |
System.Int32 | count |
Returns
Type | Description
System.Int32 |

InsertRange(Int32, IEnumerable<IHierarchicalStringList>)

Declaration
void InsertRange(int index, IEnumerable<IHierarchicalStringList> collection)
Parameters
Type | Name | Description
System.Int32 | index |
System.Collections.Generic.IEnumerable<IHierarchicalStringList> | collection |

LastIndexOf(IHierarchicalStringList)

Declaration
int LastIndexOf(IHierarchicalStringList item)
Parameters
Type | Name | Description
IHierarchicalStringList | item |
Returns
Type | Description
System.Int32 |

LastIndexOf(IHierarchicalStringList, Int32)

Declaration
int LastIndexOf(IHierarchicalStringList item, int index)
Parameters
Type | Name | Description
IHierarchicalStringList | item |
System.Int32 | index |
Returns
Type | Description
System.Int32 |

LastIndexOf(IHierarchicalStringList, Int32, Int32)

Declaration
int LastIndexOf(IHierarchicalStringList item, int index, int count)
Parameters
Type | Name | Description
IHierarchicalStringList | item |
System.Int32 | index |
System.Int32 | count |
Returns
Type | Description
System.Int32 |

RemoveAll(Predicate<IHierarchicalStringList>)

Declaration
int RemoveAll(Predicate<IHierarchicalStringList> match)
Parameters
Type | Name | Description
System.Predicate<IHierarchicalStringList> | match |
Returns
Type | Description
System.Int32 |

RemoveRange(Int32, Int32)

Declaration
void RemoveRange(int index, int count)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |

Reverse()

Declaration
void Reverse()

Reverse(Int32, Int32)

Declaration
void Reverse(int index, int count)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |

Sort()

Declaration
void Sort()

Sort(IComparer<IHierarchicalStringList>)

Declaration
void Sort(IComparer<IHierarchicalStringList> comparer)
Parameters
Type | Name | Description
System.Collections.Generic.IComparer<IHierarchicalStringList> | comparer |

Sort(Comparison<IHierarchicalStringList>)

Declaration
void Sort(Comparison<IHierarchicalStringList> comparison)
Parameters
Type | Name | Description
System.Comparison<IHierarchicalStringList> | comparison |

Sort(Int32, Int32, IComparer<IHierarchicalStringList>)

Declaration
void Sort(int index, int count, IComparer<IHierarchicalStringList> comparer)
Parameters
Type | Name | Description
System.Int32 | index |
System.Int32 | count |
System.Collections.Generic.IComparer<IHierarchicalStringList> | comparer |

ToArray()

Declaration
IHierarchicalStringList[] ToArray()
Returns
Type | Description
IHierarchicalStringList[] |

TrimExcess()

Declaration
void TrimExcess()

TrueForAll(Predicate<IHierarchicalStringList>)

Declaration
bool TrueForAll(Predicate<IHierarchicalStringList> match)
Parameters
Type | Name | Description
System.Predicate<IHierarchicalStringList> | match |
Returns
Type | Description
System.Boolean |


Class LocalizedString | fcSDK Documentation

Class LocalizedString

Inheritance
System.Object
DataObject
ClarifyDataObject
LocalizedString
Implements
IDataObject
Inherited Members
ClarifyDataObject.GetCommentFieldValue(DataRow)
ClarifyDataObject.CommentFieldName
ClarifyDataObject.ObjectID
DataObject.SetUniqueID(Object)
DataObject.GetFieldValue(String)
DataObject.GetFieldValue(Int32)
DataObject.ContainsColumn(String)
DataObject.GetSafeInt32FieldValue(String)
DataObject.GetSafeInt32FieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeDoubleFieldValue(String)
DataObject.GetSafeDoubleFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeBooleanFieldValue(String)
DataObject.GetSafeBooleanFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeStringFieldValue(String)
DataObject.SetFieldValue(String, Object)
DataObject.GetSafeString(Object)
DataObject.UniqueID
DataObject.FieldValues
DataObject.ColumnMap
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataObjects
Assembly: fcSDK.dll
Syntax
public class LocalizedString : ClarifyDataObject, IDataObject

Properties

Culture

Declaration
public CultureInfo Culture { get; }
Property Value
Type | Description
System.Globalization.CultureInfo |

IDKey

Declaration
public string IDKey { get; }
Property Value
Type | Description
System.String |

LocaleID

Declaration
public int LocaleID { get; }
Property Value
Type | Description
System.Int32 |

Name

Declaration
public string Name { get; }
Property Value
Type | Description
System.String |

NameKey

Declaration
public string NameKey { get; }
Property Value
Type | Description
System.String |

StringID

Declaration
public int StringID { get; }
Property Value
Type | Description
System.Int32 |

StringType

Declaration
public int StringType { get; }
Property Value
Type | Description
System.Int32 |

TranslateIndicator

Declaration
public int TranslateIndicator { get; }
Property Value
Type | Description
System.Int32 |

Value

Declaration
public string Value { get; }
Property Value
Type | Description
System.String |

Implements

IDataObject


Class StateCollection | fcSDK Documentation

Class StateCollection

Inheritance
System.Object
System.Collections.Generic.List<StateProvince>
DataObjectCollection<StateProvince>
StateCollection
Implements
System.Collections.Generic.IList<StateProvince>
System.Collections.Generic.ICollection<StateProvince>
System.Collections.IList
System.Collections.ICollection
System.Collections.Generic.IReadOnlyList<StateProvince>
System.Collections.Generic.IReadOnlyCollection<StateProvince>
System.Collections.Generic.IEnumerable<StateProvince>
System.Collections.IEnumerable
Inherited Members
DataObjectCollection<StateProvince>.Initialize(DataTable)
DataObjectCollection<StateProvince>.Initialize(DataRow[])
DataObjectCollection<StateProvince>.Initialize(Object[][])
DataObjectCollection<StateProvince>.AddDataObject(StateProvince)
DataObjectCollection<StateProvince>.OnDataObjectAdded(StateProvince)
DataObjectCollection<StateProvince>.Create(Object[])
DataObjectCollection<StateProvince>.GetItemByIndex(Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.System.Collections.IList.get_Item(System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.System.Collections.IList.set_Item(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.Add(FChoice.Foundation.Clarify.DataObjects.StateProvince)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.System.Collections.IList.Add(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.AddRange(System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.DataObjects.StateProvince>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.AsReadOnly()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.BinarySearch(System.Int32, System.Int32, FChoice.Foundation.Clarify.DataObjects.StateProvince, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.DataObjects.StateProvince>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.BinarySearch(FChoice.Foundation.Clarify.DataObjects.StateProvince)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.BinarySearch(FChoice.Foundation.Clarify.DataObjects.StateProvince, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.DataObjects.StateProvince>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.Clear()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.Contains(FChoice.Foundation.Clarify.DataObjects.StateProvince)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.System.Collections.IList.Contains(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.ConvertAll<TOutput>(System.Converter<FChoice.Foundation.Clarify.DataObjects.StateProvince, TOutput>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.CopyTo(FChoice.Foundation.Clarify.DataObjects.StateProvince[])
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.System.Collections.ICollection.CopyTo(System.Array, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.CopyTo(System.Int32, FChoice.Foundation.Clarify.DataObjects.StateProvince[], System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.CopyTo(FChoice.Foundation.Clarify.DataObjects.StateProvince[], System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.Exists(System.Predicate<FChoice.Foundation.Clarify.DataObjects.StateProvince>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.Find(System.Predicate<FChoice.Foundation.Clarify.DataObjects.StateProvince>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.FindAll(System.Predicate<FChoice.Foundation.Clarify.DataObjects.StateProvince>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.FindIndex(System.Predicate<FChoice.Foundation.Clarify.DataObjects.StateProvince>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.FindIndex(System.Int32, System.Predicate<FChoice.Foundation.Clarify.DataObjects.StateProvince>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.FindIndex(System.Int32, System.Int32, System.Predicate<FChoice.Foundation.Clarify.DataObjects.StateProvince>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.FindLast(System.Predicate<FChoice.Foundation.Clarify.DataObjects.StateProvince>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.FindLastIndex(System.Predicate<FChoice.Foundation.Clarify.DataObjects.StateProvince>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.FindLastIndex(System.Int32, System.Predicate<FChoice.Foundation.Clarify.DataObjects.StateProvince>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.FindLastIndex(System.Int32, System.Int32, System.Predicate<FChoice.Foundation.Clarify.DataObjects.StateProvince>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.ForEach(System.Action<FChoice.Foundation.Clarify.DataObjects.StateProvince>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.DataObjects.StateProvince>.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.System.Collections.IEnumerable.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.GetRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.IndexOf(FChoice.Foundation.Clarify.DataObjects.StateProvince)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.System.Collections.IList.IndexOf(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.IndexOf(FChoice.Foundation.Clarify.DataObjects.StateProvince, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.IndexOf(FChoice.Foundation.Clarify.DataObjects.StateProvince, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.Insert(System.Int32, FChoice.Foundation.Clarify.DataObjects.StateProvince)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.System.Collections.IList.Insert(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.InsertRange(System.Int32, System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.DataObjects.StateProvince>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.LastIndexOf(FChoice.Foundation.Clarify.DataObjects.StateProvince)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.LastIndexOf(FChoice.Foundation.Clarify.DataObjects.StateProvince, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.LastIndexOf(FChoice.Foundation.Clarify.DataObjects.StateProvince, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.Remove(FChoice.Foundation.Clarify.DataObjects.StateProvince)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.System.Collections.IList.Remove(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.RemoveAll(System.Predicate<FChoice.Foundation.Clarify.DataObjects.StateProvince>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.RemoveAt(System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.RemoveRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.Reverse()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.Reverse(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.Sort()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.Sort(System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.DataObjects.StateProvince>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.Sort(System.Int32, System.Int32, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.DataObjects.StateProvince>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.Sort(System.Comparison<FChoice.Foundation.Clarify.DataObjects.StateProvince>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.ToArray()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.TrimExcess()
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.TrueForAll(System.Predicate<FChoice.Foundation.Clarify.DataObjects.StateProvince>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.Capacity
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.Count
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.System.Collections.IList.IsFixedSize
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.DataObjects.StateProvince>.IsReadOnly
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.System.Collections.IList.IsReadOnly
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.System.Collections.ICollection.IsSynchronized
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.System.Collections.ICollection.SyncRoot
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.Item[System.Int32]
System.Collections.Generic.List<FChoice.Foundation.Clarify.DataObjects.StateProvince>.System.Collections.IList.Item[System.Int32]
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataObjects
Assembly: fcSDK.dll
Syntax
public class StateCollection : DataObjectCollection<StateProvince>, IList<StateProvince>, ICollection<StateProvince>, IList, ICollection, IReadOnlyList<StateProvince>, IReadOnlyCollection<StateProvince>, IEnumerable<StateProvince>, IEnumerable

Properties

DefaultState

Declaration
public StateProvince DefaultState { get; }
Property Value
Type | Description
StateProvince |

Item[String, Boolean]

Declaration
public StateProvince this[string name, bool isFullName] { get; }
Parameters
Type | Name | Description
System.String | name |
System.Boolean | isFullName |
Property Value
Type | Description
StateProvince |

Methods

Create(DataRow)

Declaration
protected override StateProvince Create(DataRow row)
Parameters
Type | Name | Description
System.Data.DataRow | row |
Returns
Type | Description
StateProvince |
Overrides
FChoice.Foundation.DataObjects.DataObjectCollection<FChoice.Foundation.Clarify.DataObjects.StateProvince>.Create(System.Data.DataRow)

Implements

System.Collections.Generic.IList<T>
System.Collections.Generic.ICollection<T>
System.Collections.IList
System.Collections.ICollection
System.Collections.Generic.IReadOnlyList<T>
System.Collections.Generic.IReadOnlyCollection<T>
System.Collections.Generic.IEnumerable<T>
System.Collections.IEnumerable


Class StateProvince | fcSDK Documentation

Class StateProvince

Inheritance
System.Object
DataObject
ClarifyDataObject
StateProvince
Implements
IDataObject
Inherited Members
ClarifyDataObject.GetCommentFieldValue(DataRow)
ClarifyDataObject.CommentFieldName
ClarifyDataObject.ObjectID
DataObject.SetUniqueID(Object)
DataObject.GetFieldValue(String)
DataObject.GetFieldValue(Int32)
DataObject.ContainsColumn(String)
DataObject.GetSafeInt32FieldValue(String)
DataObject.GetSafeInt32FieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeDoubleFieldValue(String)
DataObject.GetSafeDoubleFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeBooleanFieldValue(String)
DataObject.GetSafeBooleanFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeStringFieldValue(String)
DataObject.SetFieldValue(String, Object)
DataObject.GetSafeString(Object)
DataObject.UniqueID
DataObject.FieldValues
DataObject.ColumnMap
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataObjects
Assembly: fcSDK.dll
Syntax
public class StateProvince : ClarifyDataObject, IDataObject

Properties

DisplayOrder

Declaration
public int DisplayOrder { get; }
Property Value
Type | Description
System.Int32 |

FullName

Declaration
public string FullName { get; }
Property Value
Type | Description
System.String |

IsDefault

Declaration
public bool IsDefault { get; }
Property Value
Type | Description
System.Boolean |

Name

Declaration
public string Name { get; }
Property Value
Type | Description
System.String |

Implements

IDataObject


Namespace FChoice.Foundation.Clarify.DataVerifier.Core | fcSDK Documentation

Namespace FChoice.Foundation.Clarify.DataVerifier.Core

Classes

CompatVerifier

CompatVerifier.FcflNetCompatDomainVerifier

ConfigItemVerifier

DaylightHourVerifier

DaylightHourVerifier.DaylightSavingsPeriod

DovetailLicensingVerifier

FcflNetVerifier

FcflNetVerifier.FcflNetDomainVerifier

FCStringLocaleVerifier

GbstVerifier

HgbstVerifier

RemoteSessionVerifier

SchemaVerifier

StateVerifier

StoredProcVerifier

StringVerifier

TimeZoneVerifier

Verifier

VerifierFactory

VerifyEndEventArgs

VerifyFailDetail

VerifyTestResult

Enums

VerifierGroupType

VerifyResultType

Delegates

VerifyEndEventHandler

VerifyStartEventHandler

Back to top © 2022 Dovetail Software, Inc. - All rights reserved.
Clarify, Amdocs, and related products and names are copyright and trademark of Amdocs, Inc.
.NET, Visual Studio.NET, C#, Visual Basic and related products are trademark of Microsoft corporation.


Class CompatVerifier | fcSDK Documentation

Class CompatVerifier

Inheritance
System.Object
Verifier
CompatVerifier
Inherited Members
Verifier.isVerifiedByDefault
Verifier.IsVerifiedByDefault
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataVerifier.Core
Assembly: FChoice.Foundation.Clarify.DataVerifier.Core.dll
Syntax
public class CompatVerifier : Verifier

Constructors

CompatVerifier()

Declaration
public CompatVerifier()

Properties

GroupType

Declaration
public override VerifierGroupType GroupType { get; }
Property Value
Type | Description
VerifierGroupType |
Overrides
Verifier.GroupType

Name

Declaration
public override string Name { get; }
Property Value
Type | Description
System.String |
Overrides
Verifier.Name

TableName

Declaration
public override string TableName { get; }
Property Value
Type | Description
System.String |
Overrides
Verifier.TableName

Methods

Verify(NameValueCollection)

Declaration
public override VerifyTestResult[] Verify(NameValueCollection appState)
Parameters
Type | Name | Description
System.Collections.Specialized.NameValueCollection | appState |
Returns
Type | Description
VerifyTestResult[] |
Overrides
Verifier.Verify(NameValueCollection)


Class CompatVerifier.FcflNetCompatDomainVerifier | fcSDK Documentation

Class CompatVerifier.FcflNetCompatDomainVerifier

Inheritance
System.Object
System.MarshalByRefObject
CompatVerifier.FcflNetCompatDomainVerifier
Inherited Members
System.MarshalByRefObject.MemberwiseClone(System.Boolean)
System.MarshalByRefObject.GetLifetimeService()
System.MarshalByRefObject.InitializeLifetimeService()
System.MarshalByRefObject.CreateObjRef(System.Type)
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataVerifier.Core
Assembly: FChoice.Foundation.Clarify.DataVerifier.Core.dll
Syntax
public class FcflNetCompatDomainVerifier : MarshalByRefObject

Constructors

FcflNetCompatDomainVerifier()

Declaration
public FcflNetCompatDomainVerifier()

Methods

TestFCApplication(NameValueCollection)

Declaration
public void TestFCApplication(NameValueCollection appState)
Parameters
Type | Name | Description
System.Collections.Specialized.NameValueCollection | appState |

TestFCGeneric()

Declaration
public void TestFCGeneric()

TestFCSession()

Declaration
public void TestFCSession()


Class ConfigItemVerifier | fcSDK Documentation

Class ConfigItemVerifier

Inheritance
System.Object
Verifier
ConfigItemVerifier
Inherited Members
Verifier.isVerifiedByDefault
Verifier.IsVerifiedByDefault
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataVerifier.Core
Assembly: FChoice.Foundation.Clarify.DataVerifier.Core.dll
Syntax
public class ConfigItemVerifier : Verifier

Constructors

ConfigItemVerifier()

Declaration
public ConfigItemVerifier()

Properties

GroupType

Declaration
public override VerifierGroupType GroupType { get; }
Property Value
Type | Description
VerifierGroupType |
Overrides
Verifier.GroupType

Name

Declaration
public override string Name { get; }
Property Value
Type | Description
System.String |
Overrides
Verifier.Name

TableName

Declaration
public override string TableName { get; }
Property Value
Type | Description
System.String |
Overrides
Verifier.TableName

Methods

Verify(NameValueCollection)

Declaration
public override VerifyTestResult[] Verify(NameValueCollection appState)
Parameters
Type | Name | Description
System.Collections.Specialized.NameValueCollection | appState |
Returns
Type | Description
VerifyTestResult[] |
Overrides
Verifier.Verify(NameValueCollection)


Class DaylightHourVerifier | fcSDK Documentation

Class DaylightHourVerifier

Inheritance
System.Object
Verifier
DaylightHourVerifier
Inherited Members
Verifier.isVerifiedByDefault
Verifier.IsVerifiedByDefault
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataVerifier.Core
Assembly: FChoice.Foundation.Clarify.DataVerifier.Core.dll
Syntax
public class DaylightHourVerifier : Verifier

Constructors

DaylightHourVerifier()

Declaration
public DaylightHourVerifier()

Properties

GroupType

Declaration
public override VerifierGroupType GroupType { get; }
Property Value
Type | Description
VerifierGroupType |
Overrides
Verifier.GroupType

Name

Declaration
public override string Name { get; }
Property Value
Type | Description
System.String |
Overrides
Verifier.Name

TableName

Declaration
public override string TableName { get; }
Property Value
Type | Description
System.String |
Overrides
Verifier.TableName

Methods

Verify(NameValueCollection)

Declaration
public override VerifyTestResult[] Verify(NameValueCollection appState)
Parameters
Type | Name | Description
System.Collections.Specialized.NameValueCollection | appState |
Returns
Type | Description
VerifyTestResult[] |
Overrides
Verifier.Verify(NameValueCollection)


Class DaylightHourVerifier.DaylightSavingsPeriod | fcSDK Documentation

Class DaylightHourVerifier.DaylightSavingsPeriod

Inheritance
System.Object
DaylightHourVerifier.DaylightSavingsPeriod
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataVerifier.Core
Assembly: FChoice.Foundation.Clarify.DataVerifier.Core.dll
Syntax
public class DaylightSavingsPeriod

Constructors

DaylightSavingsPeriod()

Declaration
public DaylightSavingsPeriod()

Properties

EndDate

Declaration
public DateTime EndDate { get; set; }
Property Value
Type | Description
System.DateTime |

Objid

Declaration
public int Objid { get; set; }
Property Value
Type | Description
System.Int32 |

StartDate

Declaration
public DateTime StartDate { get; set; }
Property Value
Type | Description
System.DateTime |

TimezoneObjid

Declaration
public int TimezoneObjid { get; set; }
Property Value
Type | Description
System.Int32 |

Methods

Intersects(DaylightHourVerifier.DaylightSavingsPeriod)

Declaration
public bool Intersects(DaylightHourVerifier.DaylightSavingsPeriod input)
Parameters
Type | Name | Description
DaylightHourVerifier.DaylightSavingsPeriod | input |
Returns
Type | Description
System.Boolean |


Class DovetailLicensingVerifier | fcSDK Documentation

Class DovetailLicensingVerifier

Inheritance
System.Object
Verifier
DovetailLicensingVerifier
Inherited Members
Verifier.isVerifiedByDefault
Verifier.IsVerifiedByDefault
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataVerifier.Core
Assembly: FChoice.Foundation.Clarify.DataVerifier.Core.dll
Syntax
public class DovetailLicensingVerifier : Verifier

Constructors

DovetailLicensingVerifier()

Declaration
public DovetailLicensingVerifier()

Properties

GroupType

Declaration
public override VerifierGroupType GroupType { get; }
Property Value
Type | Description
VerifierGroupType |
Overrides
Verifier.GroupType

Name

Declaration
public override string Name { get; }
Property Value
Type | Description
System.String |
Overrides
Verifier.Name

TableName

Declaration
public override string TableName { get; }
Property Value
Type | Description
System.String |
Overrides
Verifier.TableName

Methods

Verify(NameValueCollection)

Declaration
public override VerifyTestResult[] Verify(NameValueCollection appState)
Parameters
Type | Name | Description
System.Collections.Specialized.NameValueCollection | appState |
Returns
Type | Description
VerifyTestResult[] |
Overrides
Verifier.Verify(NameValueCollection)


Class FcflNetVerifier | fcSDK Documentation

Class FcflNetVerifier

Inheritance
System.Object
Verifier
FcflNetVerifier
Inherited Members
Verifier.isVerifiedByDefault
Verifier.IsVerifiedByDefault
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataVerifier.Core
Assembly: FChoice.Foundation.Clarify.DataVerifier.Core.dll
Syntax
public class FcflNetVerifier : Verifier

Constructors

FcflNetVerifier()

Declaration
public FcflNetVerifier()

Properties

GroupType

Declaration
public override VerifierGroupType GroupType { get; }
Property Value
Type | Description
VerifierGroupType |
Overrides
Verifier.GroupType

Name

Declaration
public override string Name { get; }
Property Value
Type | Description
System.String |
Overrides
Verifier.Name

TableName

Declaration
public override string TableName { get; }
Property Value
Type | Description
System.String |
Overrides
Verifier.TableName

Methods

Verify(NameValueCollection)

Declaration
public override VerifyTestResult[] Verify(NameValueCollection appState)
Parameters
Type | Name | Description
System.Collections.Specialized.NameValueCollection | appState |
Returns
Type | Description
VerifyTestResult[] |
Overrides
Verifier.Verify(NameValueCollection)


Class FcflNetVerifier.FcflNetDomainVerifier | fcSDK Documentation

Class FcflNetVerifier.FcflNetDomainVerifier

Inheritance
System.Object
System.MarshalByRefObject
FcflNetVerifier.FcflNetDomainVerifier
Inherited Members
System.MarshalByRefObject.MemberwiseClone(System.Boolean)
System.MarshalByRefObject.GetLifetimeService()
System.MarshalByRefObject.InitializeLifetimeService()
System.MarshalByRefObject.CreateObjRef(System.Type)
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataVerifier.Core
Assembly: FChoice.Foundation.Clarify.DataVerifier.Core.dll
Syntax
public class FcflNetDomainVerifier : MarshalByRefObject

Constructors

FcflNetDomainVerifier()

Declaration
public FcflNetDomainVerifier()

Methods

TestClarifyApplication(NameValueCollection)

Declaration
public void TestClarifyApplication(NameValueCollection envVals)
Parameters
Type | Name | Description
System.Collections.Specialized.NameValueCollection | envVals |

TestClarifyGeneric(NameValueCollection)

Declaration
public void TestClarifyGeneric(NameValueCollection config)
Parameters
Type | Name | Description
System.Collections.Specialized.NameValueCollection | config |

TestClarifySession()

Declaration
public void TestClarifySession()


Class FCStringLocaleVerifier | fcSDK Documentation

Class FCStringLocaleVerifier

Inheritance
System.Object
Verifier
FCStringLocaleVerifier
Inherited Members
Verifier.isVerifiedByDefault
Verifier.IsVerifiedByDefault
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataVerifier.Core
Assembly: FChoice.Foundation.Clarify.DataVerifier.Core.dll
Syntax
public class FCStringLocaleVerifier : Verifier

Constructors

FCStringLocaleVerifier()

Declaration
public FCStringLocaleVerifier()

Properties

GroupType

Declaration
public override VerifierGroupType GroupType { get; }
Property Value
Type | Description
VerifierGroupType |
Overrides
Verifier.GroupType

Name

Declaration
public override string Name { get; }
Property Value
Type | Description
System.String |
Overrides
Verifier.Name

TableName

Declaration
public override string TableName { get; }
Property Value
Type | Description
System.String |
Overrides
Verifier.TableName

Methods

Verify(NameValueCollection)

Declaration
public override VerifyTestResult[] Verify(NameValueCollection appState)
Parameters
Type | Name | Description
System.Collections.Specialized.NameValueCollection | appState |
Returns
Type | Description
VerifyTestResult[] |
Overrides
Verifier.Verify(NameValueCollection)


Class GbstVerifier | fcSDK Documentation

Class GbstVerifier

Inheritance
System.Object
Verifier
GbstVerifier
Inherited Members
Verifier.isVerifiedByDefault
Verifier.IsVerifiedByDefault
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataVerifier.Core
Assembly: FChoice.Foundation.Clarify.DataVerifier.Core.dll
Syntax
public class GbstVerifier : Verifier

Constructors

GbstVerifier()

Declaration
public GbstVerifier()

Properties

GroupType

Declaration
public override VerifierGroupType GroupType { get; }
Property Value
Type | Description
VerifierGroupType |
Overrides
Verifier.GroupType

Name

Declaration
public override string Name { get; }
Property Value
Type | Description
System.String |
Overrides
Verifier.Name

TableName

Declaration
public override string TableName { get; }
Property Value
Type | Description
System.String |
Overrides
Verifier.TableName

Methods

Verify(NameValueCollection)

Declaration
public override VerifyTestResult[] Verify(NameValueCollection appState)
Parameters
Type | Name | Description
System.Collections.Specialized.NameValueCollection | appState |
Returns
Type | Description
VerifyTestResult[] |
Overrides
Verifier.Verify(NameValueCollection)


Class HgbstVerifier | fcSDK Documentation

Class HgbstVerifier

Inheritance
System.Object
Verifier
HgbstVerifier
Inherited Members
Verifier.isVerifiedByDefault
Verifier.IsVerifiedByDefault
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataVerifier.Core
Assembly: FChoice.Foundation.Clarify.DataVerifier.Core.dll
Syntax
public class HgbstVerifier : Verifier

Constructors

HgbstVerifier()

Declaration
public HgbstVerifier()

Properties

GroupType

Declaration
public override VerifierGroupType GroupType { get; }
Property Value
Type | Description
VerifierGroupType |
Overrides
Verifier.GroupType

Name

Declaration
public override string Name { get; }
Property Value
Type | Description
System.String |
Overrides
Verifier.Name

TableName

Declaration
public override string TableName { get; }
Property Value
Type | Description
System.String |
Overrides
Verifier.TableName

Methods

Verify(NameValueCollection)

Declaration
public override VerifyTestResult[] Verify(NameValueCollection appState)
Parameters
Type | Name | Description
System.Collections.Specialized.NameValueCollection | appState |
Returns
Type | Description
VerifyTestResult[] |
Overrides
Verifier.Verify(NameValueCollection)


Class RemoteSessionVerifier | fcSDK Documentation

Class RemoteSessionVerifier

Inheritance
System.Object
Verifier
RemoteSessionVerifier
Inherited Members
Verifier.isVerifiedByDefault
Verifier.IsVerifiedByDefault
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataVerifier.Core
Assembly: FChoice.Foundation.Clarify.DataVerifier.Core.dll
Syntax
public class RemoteSessionVerifier : Verifier

Constructors

RemoteSessionVerifier()

Declaration
public RemoteSessionVerifier()

Properties

GroupType

Declaration
public override VerifierGroupType GroupType { get; }
Property Value
Type | Description
VerifierGroupType |
Overrides
Verifier.GroupType

Name

Declaration
public override string Name { get; }
Property Value
Type | Description
System.String |
Overrides
Verifier.Name

TableName

Declaration
public override string TableName { get; }
Property Value
Type | Description
System.String |
Overrides
Verifier.TableName

Methods

Verify(NameValueCollection)

Declaration
public override VerifyTestResult[] Verify(NameValueCollection appState)
Parameters
Type | Name | Description
System.Collections.Specialized.NameValueCollection | appState |
Returns
Type | Description
VerifyTestResult[] |
Overrides
Verifier.Verify(NameValueCollection)


Class SchemaVerifier | fcSDK Documentation

Class SchemaVerifier

Inheritance
System.Object
Verifier
SchemaVerifier
Inherited Members
Verifier.isVerifiedByDefault
Verifier.IsVerifiedByDefault
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataVerifier.Core
Assembly: FChoice.Foundation.Clarify.DataVerifier.Core.dll
Syntax
public class SchemaVerifier : Verifier

Constructors

SchemaVerifier()

Declaration
public SchemaVerifier()

Properties

GroupType

Declaration
public override VerifierGroupType GroupType { get; }
Property Value
Type | Description
VerifierGroupType |
Overrides
Verifier.GroupType

Name

Declaration
public override string Name { get; }
Property Value
Type | Description
System.String |
Overrides
Verifier.Name

TableName

Declaration
public override string TableName { get; }
Property Value
Type | Description
System.String |
Overrides
Verifier.TableName

Methods

Verify(NameValueCollection)

Declaration
public override VerifyTestResult[] Verify(NameValueCollection appState)
Parameters
Type | Name | Description
System.Collections.Specialized.NameValueCollection | appState |
Returns
Type | Description
VerifyTestResult[] |
Overrides
Verifier.Verify(NameValueCollection)


Class StateVerifier | fcSDK Documentation

Class StateVerifier

Inheritance
System.Object
Verifier
StateVerifier
Inherited Members
Verifier.isVerifiedByDefault
Verifier.IsVerifiedByDefault
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataVerifier.Core
Assembly: FChoice.Foundation.Clarify.DataVerifier.Core.dll
Syntax
public class StateVerifier : Verifier

Constructors

StateVerifier()

Declaration
public StateVerifier()

Properties

GroupType

Declaration
public override VerifierGroupType GroupType { get; }
Property Value
Type | Description
VerifierGroupType |
Overrides
Verifier.GroupType

Name

Declaration
public override string Name { get; }
Property Value
Type | Description
System.String |
Overrides
Verifier.Name

TableName

Declaration
public override string TableName { get; }
Property Value
Type | Description
System.String |
Overrides
Verifier.TableName

Methods

Verify(NameValueCollection)

Declaration
public override VerifyTestResult[] Verify(NameValueCollection appState)
Parameters
Type | Name | Description
System.Collections.Specialized.NameValueCollection | appState |
Returns
Type | Description
VerifyTestResult[] |
Overrides
Verifier.Verify(NameValueCollection)


Class StoredProcVerifier | fcSDK Documentation

Class StoredProcVerifier

Inheritance
System.Object
Verifier
StoredProcVerifier
Inherited Members
Verifier.isVerifiedByDefault
Verifier.IsVerifiedByDefault
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataVerifier.Core
Assembly: FChoice.Foundation.Clarify.DataVerifier.Core.dll
Syntax
public class StoredProcVerifier : Verifier

Constructors

StoredProcVerifier()

Declaration
public StoredProcVerifier()

Properties

GroupType

Declaration
public override VerifierGroupType GroupType { get; }
Property Value
Type | Description
VerifierGroupType |
Overrides
Verifier.GroupType

Name

Declaration
public override string Name { get; }
Property Value
Type | Description
System.String |
Overrides
Verifier.Name

TableName

Declaration
public override string TableName { get; }
Property Value
Type | Description
System.String |
Overrides
Verifier.TableName

Methods

Verify(NameValueCollection)

Declaration
public override VerifyTestResult[] Verify(NameValueCollection appState)
Parameters
Type | Name | Description
System.Collections.Specialized.NameValueCollection | appState |
Returns
Type | Description
VerifyTestResult[] |
Overrides
Verifier.Verify(NameValueCollection)


Class StringVerifier | fcSDK Documentation

Class StringVerifier

Inheritance
System.Object
Verifier
StringVerifier
Inherited Members
Verifier.isVerifiedByDefault
Verifier.IsVerifiedByDefault
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataVerifier.Core
Assembly: FChoice.Foundation.Clarify.DataVerifier.Core.dll
Syntax
public class StringVerifier : Verifier

Constructors

StringVerifier()

Declaration
public StringVerifier()

Properties

GroupType

Declaration
public override VerifierGroupType GroupType { get; }
Property Value
Type | Description
VerifierGroupType |
Overrides
Verifier.GroupType

Name

Declaration
public override string Name { get; }
Property Value
Type | Description
System.String |
Overrides
Verifier.Name

TableName

Declaration
public override string TableName { get; }
Property Value
Type | Description
System.String |
Overrides
Verifier.TableName

Methods

Verify(NameValueCollection)

Declaration
public override VerifyTestResult[] Verify(NameValueCollection appState)
Parameters
Type | Name | Description
System.Collections.Specialized.NameValueCollection | appState |
Returns
Type | Description
VerifyTestResult[] |
Overrides
Verifier.Verify(NameValueCollection)


Class TimeZoneVerifier | fcSDK Documentation

Class TimeZoneVerifier

Inheritance
System.Object
Verifier
TimeZoneVerifier
Inherited Members
Verifier.isVerifiedByDefault
Verifier.IsVerifiedByDefault
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataVerifier.Core
Assembly: FChoice.Foundation.Clarify.DataVerifier.Core.dll
Syntax
public class TimeZoneVerifier : Verifier

Constructors

TimeZoneVerifier()

Declaration
public TimeZoneVerifier()

Properties

GroupType

Declaration
public override VerifierGroupType GroupType { get; }
Property Value
Type | Description
VerifierGroupType |
Overrides
Verifier.GroupType

Name

Declaration
public override string Name { get; }
Property Value
Type | Description
System.String |
Overrides
Verifier.Name

TableName

Declaration
public override string TableName { get; }
Property Value
Type | Description
System.String |
Overrides
Verifier.TableName

Methods

Verify(NameValueCollection)

Declaration
public override VerifyTestResult[] Verify(NameValueCollection appState)
Parameters
Type | Name | Description
System.Collections.Specialized.NameValueCollection | appState |
Returns
Type | Description
VerifyTestResult[] |
Overrides
Verifier.Verify(NameValueCollection)


Class Verifier | fcSDK Documentation

Class Verifier

Inheritance
System.Object
Verifier
CompatVerifier
ConfigItemVerifier
DaylightHourVerifier
DovetailLicensingVerifier
FcflNetVerifier
FCStringLocaleVerifier
GbstVerifier
HgbstVerifier
RemoteSessionVerifier
SchemaVerifier
StateVerifier
StoredProcVerifier
StringVerifier
TimeZoneVerifier
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataVerifier.Core
Assembly: FChoice.Foundation.Clarify.DataVerifier.Core.dll
Syntax
public abstract class Verifier

Constructors

Verifier()

Declaration
protected Verifier()

Fields

isVerifiedByDefault

Declaration
protected bool isVerifiedByDefault
Field Value
Type | Description
System.Boolean |

Properties

GroupType

Declaration
public abstract VerifierGroupType GroupType { get; }
Property Value
Type | Description
VerifierGroupType |

IsVerifiedByDefault

Declaration
public bool IsVerifiedByDefault { get; }
Property Value
Type | Description
System.Boolean |

Name

Declaration
public abstract string Name { get; }
Property Value
Type | Description
System.String |

TableName

Declaration
public abstract string TableName { get; }
Property Value
Type | Description
System.String |

Methods

Verify(NameValueCollection)

Declaration
public abstract VerifyTestResult[] Verify(NameValueCollection appState)
Parameters
Type | Name | Description
System.Collections.Specialized.NameValueCollection | appState |
Returns
Type | Description
VerifyTestResult[] |


Class VerifierFactory | fcSDK Documentation

Class VerifierFactory

Inheritance
System.Object
VerifierFactory
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataVerifier.Core
Assembly: FChoice.Foundation.Clarify.DataVerifier.Core.dll
Syntax
public static class VerifierFactory

Properties

Verifiers

Declaration
public static ICollection Verifiers { get; }
Property Value
Type | Description
System.Collections.ICollection |

Methods

Initialize()

Declaration
public static void Initialize()

Verify(NameValueCollection)

Declaration
public static void Verify(NameValueCollection appState)
Parameters
Type | Name | Description
System.Collections.Specialized.NameValueCollection | appState |

Verify(NameValueCollection, Verifier[])

Declaration
public static void Verify(NameValueCollection appState, Verifier[] selectedVerifiers)
Parameters
Type | Name | Description
System.Collections.Specialized.NameValueCollection | appState |
Verifier[] | selectedVerifiers |

Events

VerifierFinish

Declaration
public static event VerifyEndEventHandler VerifierFinish
Event Type
Type | Description
VerifyEndEventHandler |

VerifierStart

Declaration
public static event VerifyStartEventHandler VerifierStart
Event Type
Type | Description
VerifyStartEventHandler |


Enum VerifierGroupType | fcSDK Documentation

Enum VerifierGroupType

Namespace: FChoice.Foundation.Clarify.DataVerifier.Core
Assembly: FChoice.Foundation.Clarify.DataVerifier.Core.dll
Syntax
public enum VerifierGroupType

Fields

Name | Description
Cache |
Dovetail |
Initialize |
Remote |
Schema |


Class VerifyEndEventArgs | fcSDK Documentation

Class VerifyEndEventArgs

Inheritance
System.Object
System.EventArgs
VerifyEndEventArgs
Inherited Members
System.EventArgs.Empty
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataVerifier.Core
Assembly: FChoice.Foundation.Clarify.DataVerifier.Core.dll
Syntax
public class VerifyEndEventArgs : EventArgs

Properties

ErrorsPresent

Declaration
public bool ErrorsPresent { get; }
Property Value
Type | Description
System.Boolean |

Results

Declaration
public VerifyTestResult[] Results { get; }
Property Value
Type | Description
VerifyTestResult[] |

WarningsPresent

Declaration
public bool WarningsPresent { get; }
Property Value
Type | Description
System.Boolean |


Delegate VerifyEndEventHandler | fcSDK Documentation

Delegate VerifyEndEventHandler

Namespace: FChoice.Foundation.Clarify.DataVerifier.Core
Assembly: FChoice.Foundation.Clarify.DataVerifier.Core.dll
Syntax
public delegate void VerifyEndEventHandler(Verifier sender, VerifyEndEventArgs args);
Parameters
Type | Name | Description
Verifier | sender |
VerifyEndEventArgs | args |

Constructors

VerifyEndEventHandler(Object, IntPtr)

Declaration
public VerifyEndEventHandler(object object, IntPtr method)
Parameters
Type | Name | Description
System.Object | object |
System.IntPtr | method |

Methods

BeginInvoke(Verifier, VerifyEndEventArgs, AsyncCallback, Object)

Declaration
public virtual IAsyncResult BeginInvoke(Verifier sender, VerifyEndEventArgs args, AsyncCallback callback, object object)
Parameters
Type | Name | Description
Verifier | sender |
VerifyEndEventArgs | args |
System.AsyncCallback | callback |
System.Object | object |
Returns
Type | Description
System.IAsyncResult |

EndInvoke(IAsyncResult)

Declaration
public virtual void EndInvoke(IAsyncResult result)
Parameters
Type | Name | Description
System.IAsyncResult | result |

Invoke(Verifier, VerifyEndEventArgs)

Declaration
public virtual void Invoke(Verifier sender, VerifyEndEventArgs args)
Parameters
Type | Name | Description
Verifier | sender |
VerifyEndEventArgs | args |


Class VerifyFailDetail | fcSDK Documentation

Class VerifyFailDetail

Inheritance
System.Object
VerifyFailDetail
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataVerifier.Core
Assembly: FChoice.Foundation.Clarify.DataVerifier.Core.dll
Syntax
public class VerifyFailDetail

Constructors

VerifyFailDetail(String, Int32, String, String, String)

Declaration
public VerifyFailDetail(string table, int rowObjID, string rowObjidFieldName, string rowDescription, string rowDescFieldName)
Parameters
Type | Name | Description
System.String | table |
System.Int32 | rowObjID |
System.String | rowObjidFieldName |
System.String | rowDescription |
System.String | rowDescFieldName |

VerifyFailDetail(String, Int32, String, String[], Object[])

Declaration
public VerifyFailDetail(string table, int rowObjID, string rowObjidFieldName, string[] rowFields, object[] rowVals)
Parameters
Type | Name | Description
System.String | table |
System.Int32 | rowObjID |
System.String | rowObjidFieldName |
System.String[] | rowFields |
System.Object[] | rowVals |

Fields

HACK_PLEASE_HIDE_ID_COLUMN

Declaration
public const string HACK_PLEASE_HIDE_ID_COLUMN = "n/a"
Field Value
Type | Description
System.String |

Properties

FieldNames

Declaration
public string[] FieldNames { get; }
Property Value
Type | Description
System.String[] |

FieldValues

Declaration
public object[] FieldValues { get; }
Property Value
Type | Description
System.Object[] |

ObjID

Declaration
public int ObjID { get; }
Property Value
Type | Description
System.Int32 |

ObjIDFieldName

Declaration
public string ObjIDFieldName { get; }
Property Value
Type | Description
System.String |

TableName

Declaration
public string TableName { get; }
Property Value
Type | Description
System.String |

Methods

GetFieldValString()

Declaration
public string GetFieldValString()
Returns
Type | Description
System.String |


Enum VerifyResultType | fcSDK Documentation

Enum VerifyResultType

Namespace: FChoice.Foundation.Clarify.DataVerifier.Core
Assembly: FChoice.Foundation.Clarify.DataVerifier.Core.dll
Syntax
public enum VerifyResultType

Fields

Name | Description
Error |
Failure |
Success |
Warning |


Delegate VerifyStartEventHandler | fcSDK Documentation

Delegate VerifyStartEventHandler

Namespace: FChoice.Foundation.Clarify.DataVerifier.Core
Assembly: FChoice.Foundation.Clarify.DataVerifier.Core.dll
Syntax
public delegate void VerifyStartEventHandler(Verifier sender, EventArgs args);
Parameters
Type | Name | Description
Verifier | sender |
System.EventArgs | args |

Constructors

VerifyStartEventHandler(Object, IntPtr)

Declaration
public VerifyStartEventHandler(object object, IntPtr method)
Parameters
Type | Name | Description
System.Object | object |
System.IntPtr | method |

Methods

BeginInvoke(Verifier, EventArgs, AsyncCallback, Object)

Declaration
public virtual IAsyncResult BeginInvoke(Verifier sender, EventArgs args, AsyncCallback callback, object object)
Parameters
Type | Name | Description
Verifier | sender |
System.EventArgs | args |
System.AsyncCallback | callback |
System.Object | object |
Returns
Type | Description
System.IAsyncResult |

EndInvoke(IAsyncResult)

Declaration
public virtual void EndInvoke(IAsyncResult result)
Parameters
Type | Name | Description
System.IAsyncResult | result |

Invoke(Verifier, EventArgs)

Declaration
public virtual void Invoke(Verifier sender, EventArgs args)
Parameters
Type | Name | Description
Verifier | sender |
System.EventArgs | args |


Class VerifyTestResult | fcSDK Documentation

Class VerifyTestResult

Inheritance
System.Object
VerifyTestResult
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.DataVerifier.Core
Assembly: FChoice.Foundation.Clarify.DataVerifier.Core.dll
Syntax
public class VerifyTestResult

Constructors

VerifyTestResult(String, String, String, String)

Declaration
public VerifyTestResult(string name, string desc, string table, string sql)
Parameters
Type | Name | Description
System.String | name |
System.String | desc |
System.String | table |
System.String | sql |

Properties

ErrorException

Declaration
public Exception ErrorException { get; }
Property Value
Type | Description
System.Exception |

Explanation

Declaration
public string Explanation { get; }
Property Value
Type | Description
System.String |

FailureDetails

Declaration
public VerifyFailDetail[] FailureDetails { get; }
Property Value
Type | Description
VerifyFailDetail[] |

ResultType

Declaration
public VerifyResultType ResultType { get; }
Property Value
Type | Description
VerifyResultType |

TableName

Declaration
public string TableName { get; }
Property Value
Type | Description
System.String |

TestDescription

Declaration
public string TestDescription { get; }
Property Value
Type | Description
System.String |

TestName

Declaration
public string TestName { get; }
Property Value
Type | Description
System.String |

TestSql

Declaration
public string TestSql { get; set; }
Property Value
Type | Description
System.String |

Methods

AddFailureDetail(VerifyFailDetail)

Declaration
public void AddFailureDetail(VerifyFailDetail detail)
Parameters
Type | Name | Description
VerifyFailDetail | detail |

Error(String, Exception)

Declaration
public void Error(string errorExplanation, Exception ex)
Parameters
Type | Name | Description
System.String | errorExplanation |
System.Exception | ex |

Fail(String)

Declaration
public void Fail(string failExplanation)
Parameters
Type | Name | Description
System.String | failExplanation |

Warning(String)

Declaration
public void Warning(string warningExplanation)
Parameters
Type | Name | Description
System.String | warningExplanation |


Interface IClarifyApplication | fcSDK Documentation

Interface IClarifyApplication

Namespace: FChoice.Foundation.Clarify
Assembly: fcSDK.dll
Syntax
public interface IClarifyApplication

Properties

ClarifyVersion

Declaration
string ClarifyVersion { get; }
Property Value
Type | Description
System.String |

ConfigItemCache

Declaration
ConfigItemCache ConfigItemCache { get; }
Property Value
Type | Description
ConfigItemCache |

ConfigItems

Declaration
ClarifyConfigItemCollection ConfigItems { get; }
Property Value
Type | Description
ClarifyConfigItemCollection |

Configuration

Declaration
NameValueCollection Configuration { get; }
Property Value
Type | Description
System.Collections.Specialized.NameValueCollection |

ConvertTimeZone

Declaration
bool ConvertTimeZone { get; set; }
Property Value
Type | Description
System.Boolean |

DatabaseVersion

Declaration
Version DatabaseVersion { get; }
Property Value
Type | Description
System.Version |

DataRestrictionsEnabled

Declaration
bool DataRestrictionsEnabled { get; }
Property Value
Type | Description
System.Boolean |

DBUserName

Declaration
string DBUserName { get; }
Property Value
Type | Description
System.String |

IsDbUnicode

Declaration
[Obsolete("Use the SchemaCache IsDatabaseUnicode property")]
bool IsDbUnicode { get; }
Property Value
Type | Description
System.Boolean |

IsTravelerEnabled

Declaration
bool IsTravelerEnabled { get; }
Property Value
Type | Description
System.Boolean |

ListCache

Declaration
IListCache ListCache { get; }
Property Value
Type | Description
IListCache |

LocaleCache

Declaration
ILocaleCache LocaleCache { get; }
Property Value
Type | Description
ILocaleCache |

SchemaCache

Declaration
SchemaCache SchemaCache { get; }
Property Value
Type | Description
SchemaCache |

ServerTimeZone

Declaration
ITimeZone ServerTimeZone { get; set; }
Property Value
Type | Description
ITimeZone |

StringCache

Declaration
IStringCache StringCache { get; }
Property Value
Type | Description
IStringCache |

TruncateStringFields

Declaration
bool TruncateStringFields { get; set; }
Property Value
Type | Description
System.Boolean |

Methods

CreateSession()

Declaration
ClarifySession CreateSession()
Returns
Type | Description
ClarifySession |

CreateSession(String, ClarifyLoginType)

Declaration
ClarifySession CreateSession(string userName, ClarifyLoginType loginType)
Parameters
Type | Name | Description
System.String | userName |
ClarifyLoginType | loginType |
Returns
Type | Description
ClarifySession |

CreateSession(String, String, ClarifyLoginType)

Declaration
ClarifySession CreateSession(string userName, string password, ClarifyLoginType loginType)
Parameters
Type | Name | Description
System.String | userName |
System.String | password |
ClarifyLoginType | loginType |
Returns
Type | Description
ClarifySession |

CurrentSessions()

Declaration
FCSessionSummary[] CurrentSessions()
Returns
Type | Description
FCSessionSummary[] |

EncryptClarifyPassword(String)

Declaration
string EncryptClarifyPassword(string password)
Parameters
Type | Name | Description
System.String | password |
Returns
Type | Description
System.String |

EncryptDBPassword(String)

Declaration
string EncryptDBPassword(string password)
Parameters
Type | Name | Description
System.String | password |
Returns
Type | Description
System.String |

GetMtmTableName(SchemaRelation)

Declaration
string GetMtmTableName(SchemaRelation relation)
Parameters
Type | Name | Description
SchemaRelation | relation |
Returns
Type | Description
System.String |

GetObjID(String)

Declaration
int GetObjID(string tableName)
Parameters
Type | Name | Description
System.String | tableName |
Returns
Type | Description
System.Int32 |

GetSession(Guid)

Declaration
ClarifySession GetSession(Guid sessionID)
Parameters
Type | Name | Description
System.Guid | sessionID |
Returns
Type | Description
ClarifySession |

IsSessionValid(Guid)

Declaration
bool IsSessionValid(Guid sessionID)
Parameters
Type | Name | Description
System.Guid | sessionID |
Returns
Type | Description
System.Boolean |


Interface IListCache | fcSDK Documentation

Interface IListCache

Namespace: FChoice.Foundation.Clarify
Assembly: fcSDK.dll
Syntax
public interface IListCache

Properties

CacheSetName

Declaration
string CacheSetName { get; }
Property Value
Type | Description
System.String |

CacheType

Declaration
CacheType CacheType { get; }
Property Value
Type | Description
CacheType |

GlobalStrings

Declaration
IGlobalStringListCollection GlobalStrings { get; }
Property Value
Type | Description
IGlobalStringListCollection |

HierarchicalStrings

Declaration
IHierarchicalStringListCollection HierarchicalStrings { get; }
Property Value
Type | Description
IHierarchicalStringListCollection |

Methods

GetGbstDefault(String)

Declaration
string GetGbstDefault(string listTitle)
Parameters
Type | Name | Description
System.String | listTitle |
Returns
Type | Description
System.String |

GetGbstDefaultObjID(String)

Declaration
int GetGbstDefaultObjID(string listTitle)
Parameters
Type | Name | Description
System.String | listTitle |
Returns
Type | Description
System.Int32 |

GetGbstElmByID(String, Int32)

Declaration
string GetGbstElmByID(string listTitle, int elmObjID)
Parameters
Type | Name | Description
System.String | listTitle |
System.Int32 | elmObjID |
Returns
Type | Description
System.String |

GetGbstElmObjID(String, String)

Declaration
int GetGbstElmObjID(string listTitle, string elementTitle)
Parameters
Type | Name | Description
System.String | listTitle |
System.String | elementTitle |
Returns
Type | Description
System.Int32 |

GetGbstElmRankObjID(String, Int32)

Declaration
int GetGbstElmRankObjID(string listTitle, int elementRank)
Parameters
Type | Name | Description
System.String | listTitle |
System.Int32 | elementRank |
Returns
Type | Description
System.Int32 |

GetGbstList(String)

Declaration
IGlobalStringList GetGbstList(string listTitle)
Parameters
Type | Name | Description
System.String | listTitle |
Returns
Type | Description
IGlobalStringList |

GetGbstListElements(String, Boolean)

Declaration
IGlobalStringElementCollection GetGbstListElements(string listTitle, bool includeInactive)
Parameters
Type | Name | Description
System.String | listTitle |
System.Boolean | includeInactive |
Returns
Type | Description
IGlobalStringElementCollection |

GetHgbstElmDefault(String, String[])

Declaration
string GetHgbstElmDefault(string listTitle, params string[] elementTitles)
Parameters
Type | Name | Description
System.String | listTitle |
System.String[] | elementTitles |
Returns
Type | Description
System.String |

GetHgbstElmDefaultElement(String, Boolean, String[])

Declaration
IHierarchicalStringElement GetHgbstElmDefaultElement(string listTitle, bool throwErrors, params string[] elementTitles)
Parameters
Type | Name | Description
System.String | listTitle |
System.Boolean | throwErrors |
System.String[] | elementTitles |
Returns
Type | Description
IHierarchicalStringElement |

GetHgbstElmDefaultElement(String, String[])

Declaration
IHierarchicalStringElement GetHgbstElmDefaultElement(string listTitle, params string[] elementTitles)
Parameters
Type | Name | Description
System.String | listTitle |
System.String[] | elementTitles |
Returns
Type | Description
IHierarchicalStringElement |

GetHgbstElmDefaultObjID(String, Boolean, String[])

Declaration
int GetHgbstElmDefaultObjID(string listTitle, bool throwErrors, params string[] elementTitles)
Parameters
Type | Name | Description
System.String | listTitle |
System.Boolean | throwErrors |
System.String[] | elementTitles |
Returns
Type | Description
System.Int32 |

GetHgbstElmDefaultObjID(String, String[])

Declaration
int GetHgbstElmDefaultObjID(string listTitle, params string[] elementTitles)
Parameters
Type | Name | Description
System.String | listTitle |
System.String[] | elementTitles |
Returns
Type | Description
System.Int32 |

GetHgbstElmObjID(String, String, Boolean, String[])

Declaration
int GetHgbstElmObjID(string listTitle, string elementTitle, bool throwErrors, params string[] elementTitles)
Parameters
Type | Name | Description
System.String | listTitle |
System.String | elementTitle |
System.Boolean | throwErrors |
System.String[] | elementTitles |
Returns
Type | Description
System.Int32 |

GetHgbstElmObjID(String, String, String[])

Declaration
int GetHgbstElmObjID(string listTitle, string elementTitle, params string[] elementTitles)
Parameters
Type | Name | Description
System.String | listTitle |
System.String | elementTitle |
System.String[] | elementTitles |
Returns
Type | Description
System.Int32 |

GetHgbstList(String, Boolean, Boolean, String[])

Declaration
IHierarchicalStringElementCollection GetHgbstList(string listTitle, bool includeInactive, bool throwErrors, params string[] elementTitles)
Parameters
Type | Name | Description
System.String | listTitle |
System.Boolean | includeInactive |
System.Boolean | throwErrors |
System.String[] | elementTitles |
Returns
Type | Description
IHierarchicalStringElementCollection |

GetHgbstList(String, Boolean, String[])

Declaration
IHierarchicalStringElementCollection GetHgbstList(string listTitle, bool includeInactive, params string[] elementTitles)
Parameters
Type | Name | Description
System.String | listTitle |
System.Boolean | includeInactive |
System.String[] | elementTitles |
Returns
Type | Description
IHierarchicalStringElementCollection |

GetHgbstList(String, String[])

Declaration
IHierarchicalStringElementCollection GetHgbstList(string listTitle, params string[] elementTitles)
Parameters
Type | Name | Description
System.String | listTitle |
System.String[] | elementTitles |
Returns
Type | Description
IHierarchicalStringElementCollection |

IsInGbstList(String, String)

Declaration
bool IsInGbstList(string listTitle, string element)
Parameters
Type | Name | Description
System.String | listTitle |
System.String | element |
Returns
Type | Description
System.Boolean |

IsInHgbstList(String, String, Boolean, String[])

Declaration
bool IsInHgbstList(string listTitle, string elementTitle, bool throwErrors, params string[] elementTitles)
Parameters
Type | Name | Description
System.String | listTitle |
System.String | elementTitle |
System.Boolean | throwErrors |
System.String[] | elementTitles |
Returns
Type | Description
System.Boolean |

IsInHgbstList(String, String, String[])

Declaration
bool IsInHgbstList(string listTitle, string elementTitle, params string[] elementTitles)
Parameters
Type | Name | Description
System.String | listTitle |
System.String | elementTitle |
System.String[] | elementTitles |
Returns
Type | Description
System.Boolean |

RankIsInGbstList(String, Int32)

Declaration
bool RankIsInGbstList(string listTitle, int rank)
Parameters
Type | Name | Description
System.String | listTitle |
System.Int32 | rank |
Returns
Type | Description
System.Boolean |

TryGetHgbstList(String, Boolean, Boolean, String[])

Declaration
IHierarchicalStringElementCollection TryGetHgbstList(string listTitle, bool throwErrors, bool includeInactive, params string[] elementTitles)
Parameters
Type | Name | Description
System.String | listTitle |
System.Boolean | throwErrors |
System.Boolean | includeInactive |
System.String[] | elementTitles |
Returns
Type | Description
IHierarchicalStringElementCollection |

TryGetHgbstList(String, Boolean, String[])

Declaration
IHierarchicalStringElementCollection TryGetHgbstList(string listTitle, bool throwErrors, params string[] elementTitles)
Parameters
Type | Name | Description
System.String | listTitle |
System.Boolean | throwErrors |
System.String[] | elementTitles |
Returns
Type | Description
IHierarchicalStringElementCollection |

UpdateCache()

Declaration
void UpdateCache()

Events

CacheUpdated

Declaration
event EventHandler CacheUpdated
Event Type
Type | Description
System.EventHandler |


Interface ILocaleCache | fcSDK Documentation

Interface ILocaleCache

Namespace: FChoice.Foundation.Clarify
Assembly: fcSDK.dll
Syntax
public interface ILocaleCache

Properties

CacheSetName

Declaration
string CacheSetName { get; }
Property Value
Type | Description
System.String |

CacheType

Declaration
CacheType CacheType { get; }
Property Value
Type | Description
CacheType |

Countries

Declaration
CountryCollection Countries { get; }
Property Value
Type | Description
CountryCollection |

DefaultTimeZone

Declaration
ITimeZone DefaultTimeZone { get; }
Property Value
Type | Description
ITimeZone |

ServerTimeZone

Declaration
ITimeZone ServerTimeZone { get; }
Property Value
Type | Description
ITimeZone |

TimeZones

Declaration
FCTimeZoneCollection TimeZones { get; }
Property Value
Type | Description
FCTimeZoneCollection |

Methods

GetCountryObjID(String)

Declaration
int GetCountryObjID(string countryName)
Parameters
Type | Name | Description
System.String | countryName |
Returns
Type | Description
System.Int32 |

GetDefaultCountry()

Declaration
Country GetDefaultCountry()
Returns
Type | Description
Country |

GetDefaultCountryObjID()

Declaration
int GetDefaultCountryObjID()
Returns
Type | Description
System.Int32 |

GetDefaultState()

Declaration
StateProvince GetDefaultState()
Returns
Type | Description
StateProvince |

GetDefaultState(String)

Declaration
StateProvince GetDefaultState(string countryName)
Parameters
Type | Name | Description
System.String | countryName |
Returns
Type | Description
StateProvince |

GetDefaultStateObjID(String)

Declaration
int GetDefaultStateObjID(string countryName)
Parameters
Type | Name | Description
System.String | countryName |
Returns
Type | Description
System.Int32 |

GetDefaultTimeZone()

Declaration
ITimeZone GetDefaultTimeZone()
Returns
Type | Description
ITimeZone |

GetDefaultTimeZoneObjID()

Declaration
int GetDefaultTimeZoneObjID()
Returns
Type | Description
System.Int32 |

GetFullStateObjID(String, String)

Declaration
int GetFullStateObjID(string countryName, string fullStateName)
Parameters
Type | Name | Description
System.String | countryName |
System.String | fullStateName |
Returns
Type | Description
System.Int32 |

GetServerTimeZoneOffset()

Declaration
int GetServerTimeZoneOffset()
Returns
Type | Description
System.Int32 |

GetShortTimeZoneObjID(String)

Declaration
int GetShortTimeZoneObjID(string shortName)
Parameters
Type | Name | Description
System.String | shortName |
Returns
Type | Description
System.Int32 |

GetStateObjID(String, String)

Declaration
int GetStateObjID(string countryName, string stateName)
Parameters
Type | Name | Description
System.String | countryName |
System.String | stateName |
Returns
Type | Description
System.Int32 |

GetStates()

Declaration
StateCollection GetStates()
Returns
Type | Description
StateCollection |

GetStates(String)

Declaration
StateCollection GetStates(string countryName)
Parameters
Type | Name | Description
System.String | countryName |
Returns
Type | Description
StateCollection |

GetTimeZoneObjID(String)

Declaration
int GetTimeZoneObjID(string fullTimeZoneName)
Parameters
Type | Name | Description
System.String | fullTimeZoneName |
Returns
Type | Description
System.Int32 |

GetTimeZoneOffset(String)

Declaration
int GetTimeZoneOffset(string fullTimeZoneName)
Parameters
Type | Name | Description
System.String | fullTimeZoneName |
Returns
Type | Description
System.Int32 |

GetTimeZonesInCountry(String)

Declaration
FCTimeZoneCollection GetTimeZonesInCountry(string countryName)
Parameters
Type | Name | Description
System.String | countryName |
Returns
Type | Description
FCTimeZoneCollection |

IsCountry(String)

Declaration
bool IsCountry(string countryName)
Parameters
Type | Name | Description
System.String | countryName |
Returns
Type | Description
System.Boolean |

IsFullState(String, String)

Declaration
bool IsFullState(string countryName, string stateName)
Parameters
Type | Name | Description
System.String | countryName |
System.String | stateName |
Returns
Type | Description
System.Boolean |

IsOnDST(String, DateTime)

Declaration
bool IsOnDST(string fullTimeZoneName, DateTime checkDate)
Parameters
Type | Name | Description
System.String | fullTimeZoneName |
System.DateTime | checkDate |
Returns
Type | Description
System.Boolean |

IsState(String, String)

Declaration
bool IsState(string countryName, string stateName)
Parameters
Type | Name | Description
System.String | countryName |
System.String | stateName |
Returns
Type | Description
System.Boolean |

IsState(String, String, Boolean)

Declaration
bool IsState(string countryName, string stateName, bool isFullStateName)
Parameters
Type | Name | Description
System.String | countryName |
System.String | stateName |
System.Boolean | isFullStateName |
Returns
Type | Description
System.Boolean |

IsTimeZone(String)

Declaration
bool IsTimeZone(string tzName)
Parameters
Type | Name | Description
System.String | tzName |
Returns
Type | Description
System.Boolean |

IsTimeZoneInCountry(String, String)

Declaration
bool IsTimeZoneInCountry(string countryName, string tzName)
Parameters
Type | Name | Description
System.String | countryName |
System.String | tzName |
Returns
Type | Description
System.Boolean |

IsTimeZoneInCountry(String, String, Boolean)

Declaration
bool IsTimeZoneInCountry(string countryName, string tzName, bool isFullTzName)
Parameters
Type | Name | Description
System.String | countryName |
System.String | tzName |
System.Boolean | isFullTzName |
Returns
Type | Description
System.Boolean |

SetServerTimeZoneToMachineTimeZone()

Declaration
void SetServerTimeZoneToMachineTimeZone()

UpdateCache()

Declaration
void UpdateCache()

Events

CacheUpdated

Declaration
event EventHandler CacheUpdated
Event Type
Type | Description
System.EventHandler |


Delegate InitializeStatusChangeEventHandler | fcSDK Documentation

Delegate InitializeStatusChangeEventHandler

Namespace: FChoice.Foundation.Clarify
Assembly: fcSDK.dll
Syntax
public delegate void InitializeStatusChangeEventHandler(InitStatusChangeType statusType);
Parameters
Type | Name | Description
InitStatusChangeType | statusType |

Constructors

InitializeStatusChangeEventHandler(Object, IntPtr)

Declaration
public InitializeStatusChangeEventHandler(object object, IntPtr method)
Parameters
Type | Name | Description
System.Object | object |
System.IntPtr | method |

Methods

BeginInvoke(InitStatusChangeType, AsyncCallback, Object)

Declaration
public virtual IAsyncResult BeginInvoke(InitStatusChangeType statusType, AsyncCallback callback, object object)
Parameters
Type | Name | Description
InitStatusChangeType | statusType |
System.AsyncCallback | callback |
System.Object | object |
Returns
Type | Description
System.IAsyncResult |

EndInvoke(IAsyncResult)

Declaration
public virtual void EndInvoke(IAsyncResult result)
Parameters
Type | Name | Description
System.IAsyncResult | result |

Invoke(InitStatusChangeType)

Declaration
public virtual void Invoke(InitStatusChangeType statusType)
Parameters
Type | Name | Description
InitStatusChangeType | statusType |


Enum InitStatusChangeType | fcSDK Documentation

Enum InitStatusChangeType

Namespace: FChoice.Foundation.Clarify
Assembly: fcSDK.dll
Syntax
public enum InitStatusChangeType

Fields

Name | Description
CacheLoaded |
Completed |
Started |


Interface IStringCache | fcSDK Documentation

Interface IStringCache

Namespace: FChoice.Foundation.Clarify
Assembly: fcSDK.dll
Syntax
public interface IStringCache

Properties

CacheSetName

Declaration
string CacheSetName { get; }
Property Value
Type | Description
System.String |

CacheType

Declaration
CacheType CacheType { get; }
Property Value
Type | Description
CacheType |

Methods

FindFCString(Int32)

Declaration
string FindFCString(int stringID)
Parameters
Type | Name | Description
System.Int32 | stringID |
Returns
Type | Description
System.String |

FindFCString(Int32, CultureInfo)

Declaration
string FindFCString(int stringID, CultureInfo culture)
Parameters
Type | Name | Description
System.Int32 | stringID |
System.Globalization.CultureInfo | culture |
Returns
Type | Description
System.String |

FindFCString(String, String)

Declaration
string FindFCString(string applicationName, string stringName)
Parameters
Type | Name | Description
System.String | applicationName |
System.String | stringName |
Returns
Type | Description
System.String |

FindFCString(String, String, CultureInfo)

Declaration
string FindFCString(string applicationName, string stringName, CultureInfo culture)
Parameters
Type | Name | Description
System.String | applicationName |
System.String | stringName |
System.Globalization.CultureInfo | culture |
Returns
Type | Description
System.String |

FindFCStringObject(Int32, CultureInfo)

Declaration
FCString FindFCStringObject(int stringID, CultureInfo culture)
Parameters
Type | Name | Description
System.Int32 | stringID |
System.Globalization.CultureInfo | culture |
Returns
Type | Description
FCString |

FindFCStringObject(String, String, CultureInfo)

Declaration
FCString FindFCStringObject(string applicationName, string stringName, CultureInfo culture)
Parameters
Type | Name | Description
System.String | applicationName |
System.String | stringName |
System.Globalization.CultureInfo | culture |
Returns
Type | Description
FCString |

FindString(Int32)

Declaration
string FindString(int stringID)
Parameters
Type | Name | Description
System.Int32 | stringID |
Returns
Type | Description
System.String |

FindString(Int32, CultureInfo)

Declaration
string FindString(int stringID, CultureInfo culture)
Parameters
Type | Name | Description
System.Int32 | stringID |
System.Globalization.CultureInfo | culture |
Returns
Type | Description
System.String |

FindString(Int32, Int32)

Declaration
string FindString(int stringID, int localeID)
Parameters
Type | Name | Description
System.Int32 | stringID |
System.Int32 | localeID |
Returns
Type | Description
System.String |

FindString(Int32, String)

Declaration
string FindString(int stringID, string culture)
Parameters
Type | Name | Description
System.Int32 | stringID |
System.String | culture |
Returns
Type | Description
System.String |

FindString(String)

Declaration
string FindString(string stringName)
Parameters
Type | Name | Description
System.String | stringName |
Returns
Type | Description
System.String |

FindString(String, CultureInfo)

Declaration
string FindString(string stringName, CultureInfo culture)
Parameters
Type | Name | Description
System.String | stringName |
System.Globalization.CultureInfo | culture |
Returns
Type | Description
System.String |

FindString(String, Int32)

Declaration
string FindString(string stringName, int localeID)
Parameters
Type | Name | Description
System.String | stringName |
System.Int32 | localeID |
Returns
Type | Description
System.String |

FindString(String, String)

Declaration
string FindString(string stringName, string culture)
Parameters
Type | Name | Description
System.String | stringName |
System.String | culture |
Returns
Type | Description
System.String |

SupportedLocales()

Declaration
IEnumerable<CultureInfo> SupportedLocales()
Returns
Type | Description
System.Collections.Generic.IEnumerable<System.Globalization.CultureInfo> |

UpdateCache()

Declaration
void UpdateCache()

Events

CacheUpdated

Declaration
event EventHandler CacheUpdated
Event Type
Type | Description
System.EventHandler |


Class ListCache | fcSDK Documentation

Class ListCache

Inheritance
System.Object
CacheBase
ClarifyCacheBase
ListCache
Implements
IListCache
Inherited Members
ClarifyCacheBase.IsCacheOutOfDate(DateTime)
CacheBase.UpdateSyncRoot
CacheBase.OnCacheUpdated()
CacheBase.OnAnyCacheUpdated(CacheBase)
CacheBase.UpdateCache()
CacheBase.ReadCacheData(String)
CacheBase.PersistCacheData(Object, String)
CacheBase.GetCacheDataHash()
CacheBase.GenerateMD5Hash(String)
CacheBase.AllTablesExistInDataSet(DataSet, String[])
CacheBase.GetCacheFilePath(String)
CacheBase.AnyCacheUpdated
CacheBase.CacheUpdated
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify
Assembly: fcSDK.dll
Syntax
public class ListCache : ClarifyCacheBase, IListCache

Properties

CacheSetName

Declaration
public override string CacheSetName { get; }
Property Value
Type | Description
System.String |
Overrides
CacheBase.CacheSetName

CacheType

Declaration
public override CacheType CacheType { get; }
Property Value
Type | Description
CacheType |
Overrides
CacheBase.CacheType

GlobalStrings

Declaration
public IGlobalStringListCollection GlobalStrings { get; }
Property Value
Type | Description
IGlobalStringListCollection |

HierarchicalStrings

Declaration
public IHierarchicalStringListCollection HierarchicalStrings { get; }
Property Value
Type | Description
IHierarchicalStringListCollection |

Methods

GetGbstDefault(String)

Declaration
public string GetGbstDefault(string listTitle)
Parameters
Type | Name | Description
System.String | listTitle |
Returns
Type | Description
System.String |

GetGbstDefaultObjID(String)

Declaration
public int GetGbstDefaultObjID(string listTitle)
Parameters
Type | Name | Description
System.String | listTitle |
Returns
Type | Description
System.Int32 |

GetGbstElmByID(String, Int32)

Declaration
public string GetGbstElmByID(string listTitle, int elmObjID)
Parameters
Type | Name | Description
System.String | listTitle |
System.Int32 | elmObjID |
Returns
Type | Description
System.String |

GetGbstElmObjID(String, String)

Declaration
public int GetGbstElmObjID(string listTitle, string elementTitle)
Parameters
Type | Name | Description
System.String | listTitle |
System.String | elementTitle |
Returns
Type | Description
System.Int32 |

GetGbstElmRankObjID(String, Int32)

Declaration
public int GetGbstElmRankObjID(string listTitle, int elementRank)
Parameters
Type | Name | Description
System.String | listTitle |
System.Int32 | elementRank |
Returns
Type | Description
System.Int32 |

GetGbstList(String)

Declaration
public IGlobalStringList GetGbstList(string listTitle)
Parameters
Type | Name | Description
System.String | listTitle |
Returns
Type | Description
IGlobalStringList |

GetGbstListElements(String, Boolean)

Declaration
public IGlobalStringElementCollection GetGbstListElements(string listTitle, bool includeInactive)
Parameters
Type | Name | Description
System.String | listTitle |
System.Boolean | includeInactive |
Returns
Type | Description
IGlobalStringElementCollection |

GetHgbstElmDefault(String, String[])

Declaration
public string GetHgbstElmDefault(string listTitle, params string[] elementTitles)
Parameters
Type | Name | Description
System.String | listTitle |
System.String[] | elementTitles |
Returns
Type | Description
System.String |

GetHgbstElmDefaultElement(String, Boolean, String[])

Declaration
public IHierarchicalStringElement GetHgbstElmDefaultElement(string listTitle, bool throwErrors, params string[] elementTitles)
Parameters
Type | Name | Description
System.String | listTitle |
System.Boolean | throwErrors |
System.String[] | elementTitles |
Returns
Type | Description
IHierarchicalStringElement |

GetHgbstElmDefaultElement(String, String[])

Declaration
public IHierarchicalStringElement GetHgbstElmDefaultElement(string listTitle, params string[] elementTitles)
Parameters
Type | Name | Description
System.String | listTitle |
System.String[] | elementTitles |
Returns
Type | Description
IHierarchicalStringElement |

GetHgbstElmDefaultObjID(String, Boolean, String[])

Declaration
public int GetHgbstElmDefaultObjID(string listTitle, bool throwErrors, params string[] elementTitles)
Parameters
Type | Name | Description
System.String | listTitle |
System.Boolean | throwErrors |
System.String[] | elementTitles |
Returns
Type | Description
System.Int32 |

GetHgbstElmDefaultObjID(String, String[])

Declaration
public int GetHgbstElmDefaultObjID(string listTitle, params string[] elementTitles)
Parameters
Type | Name | Description
System.String | listTitle |
System.String[] | elementTitles |
Returns
Type | Description
System.Int32 |

GetHgbstElmObjID(String, String, Boolean, String[])

Declaration
public int GetHgbstElmObjID(string listTitle, string elementTitle, bool throwErrors, params string[] elementTitles)
Parameters
Type | Name | Description
System.String | listTitle |
System.String | elementTitle |
System.Boolean | throwErrors |
System.String[] | elementTitles |
Returns
Type | Description
System.Int32 |

GetHgbstElmObjID(String, String, String[])

Declaration
public int GetHgbstElmObjID(string listTitle, string elementTitle, params string[] elementTitles)
Parameters
Type | Name | Description
System.String | listTitle |
System.String | elementTitle |
System.String[] | elementTitles |
Returns
Type | Description
System.Int32 |

GetHgbstList(String, Boolean, Boolean, String[])

Declaration
public IHierarchicalStringElementCollection GetHgbstList(string listTitle, bool includeInactive, bool throwErrors, params string[] elementTitles)
Parameters
Type | Name | Description
System.String | listTitle |
System.Boolean | includeInactive |
System.Boolean | throwErrors |
System.String[] | elementTitles |
Returns
Type | Description
IHierarchicalStringElementCollection |

GetHgbstList(String, Boolean, String[])

Declaration
public IHierarchicalStringElementCollection GetHgbstList(string listTitle, bool includeInactive, params string[] elementTitles)
Parameters
Type | Name | Description
System.String | listTitle |
System.Boolean | includeInactive |
System.String[] | elementTitles |
Returns
Type | Description
IHierarchicalStringElementCollection |

GetHgbstList(String, String[])

Declaration
public IHierarchicalStringElementCollection GetHgbstList(string listTitle, params string[] elementTitles)
Parameters
Type | Name | Description
System.String | listTitle |
System.String[] | elementTitles |
Returns
Type | Description
IHierarchicalStringElementCollection |

InitCacheData()

Declaration
protected override object InitCacheData()
Returns
Type | Description
System.Object |
Overrides
CacheBase.InitCacheData()

IsInGbstList(String, String)

Declaration
public bool IsInGbstList(string listTitle, string element)
Parameters
Type | Name | Description
System.String | listTitle |
System.String | element |
Returns
Type | Description
System.Boolean |

IsInHgbstList(String, String, Boolean, String[])

Declaration
public bool IsInHgbstList(string listTitle, string elementTitle, bool throwErrors, params string[] elementTitles)
Parameters
Type | Name | Description
System.String | listTitle |
System.String | elementTitle |
System.Boolean | throwErrors |
System.String[] | elementTitles |
Returns
Type | Description
System.Boolean |

IsInHgbstList(String, String, String[])

Declaration
public bool IsInHgbstList(string listTitle, string elementTitle, params string[] elementTitles)
Parameters
Type | Name | Description
System.String | listTitle |
System.String | elementTitle |
System.String[] | elementTitles |
Returns
Type | Description
System.Boolean |

LoadCacheData(Object)

Declaration
protected override void LoadCacheData(object cacheData)
Parameters
Type | Name | Description
System.Object | cacheData |
Overrides
CacheBase.LoadCacheData(Object)

RankIsInGbstList(String, Int32)

Declaration
public bool RankIsInGbstList(string listTitle, int rank)
Parameters
Type | Name | Description
System.String | listTitle |
System.Int32 | rank |
Returns
Type | Description
System.Boolean |

SetNameAndParameters(String, String)

Declaration
protected override void SetNameAndParameters(string name, string parameters)
Parameters
Type | Name | Description
System.String | name |
System.String | parameters |
Overrides
CacheBase.SetNameAndParameters(String, String)

TryGetHgbstList(String, Boolean, Boolean, String[])

Declaration
public IHierarchicalStringElementCollection TryGetHgbstList(string listTitle, bool throwErrors, bool includeInactive, params string[] elementTitles)
Parameters
Type | Name | Description
System.String | listTitle |
System.Boolean | throwErrors |
System.Boolean | includeInactive |
System.String[] | elementTitles |
Returns
Type | Description
IHierarchicalStringElementCollection |

TryGetHgbstList(String, Boolean, String[])

Declaration
public IHierarchicalStringElementCollection TryGetHgbstList(string listTitle, bool throwErrors, params string[] elementTitles)
Parameters
Type | Name | Description
System.String | listTitle |
System.Boolean | throwErrors |
System.String[] | elementTitles |
Returns
Type | Description
IHierarchicalStringElementCollection |

Implements

IListCache


Class LocaleCache | fcSDK Documentation

Class LocaleCache

Inheritance
System.Object
CacheBase
ClarifyCacheBase
LocaleCache
Implements
ILocaleCache
Inherited Members
ClarifyCacheBase.IsCacheOutOfDate(DateTime)
CacheBase.UpdateSyncRoot
CacheBase.OnCacheUpdated()
CacheBase.OnAnyCacheUpdated(CacheBase)
CacheBase.UpdateCache()
CacheBase.ReadCacheData(String)
CacheBase.PersistCacheData(Object, String)
CacheBase.GetCacheDataHash()
CacheBase.GenerateMD5Hash(String)
CacheBase.AllTablesExistInDataSet(DataSet, String[])
CacheBase.GetCacheFilePath(String)
CacheBase.AnyCacheUpdated
CacheBase.CacheUpdated
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify
Assembly: fcSDK.dll
Syntax
public class LocaleCache : ClarifyCacheBase, ILocaleCache

Properties

CacheSetName

Declaration
public override string CacheSetName { get; }
Property Value
Type | Description
System.String |
Overrides
CacheBase.CacheSetName

CacheType

Declaration
public override CacheType CacheType { get; }
Property Value
Type | Description
CacheType |
Overrides
CacheBase.CacheType

Countries

Declaration
public CountryCollection Countries { get; }
Property Value
Type | Description
CountryCollection |

DefaultTimeZone

Declaration
public ITimeZone DefaultTimeZone { get; }
Property Value
Type | Description
ITimeZone |

ServerTimeZone

Declaration
public ITimeZone ServerTimeZone { get; }
Property Value
Type | Description
ITimeZone |

TimeZones

Declaration
public FCTimeZoneCollection TimeZones { get; }
Property Value
Type | Description
FCTimeZoneCollection |

Methods

GetCountryObjID(String)

Declaration
public int GetCountryObjID(string countryName)
Parameters
Type | Name | Description
System.String | countryName |
Returns
Type | Description
System.Int32 |

GetDefaultCountry()

Declaration
public Country GetDefaultCountry()
Returns
Type | Description
Country |

GetDefaultCountryObjID()

Declaration
public int GetDefaultCountryObjID()
Returns
Type | Description
System.Int32 |

GetDefaultState()

Declaration
public StateProvince GetDefaultState()
Returns
Type | Description
StateProvince |

GetDefaultState(String)

Declaration
public StateProvince GetDefaultState(string countryName)
Parameters
Type | Name | Description
System.String | countryName |
Returns
Type | Description
StateProvince |

GetDefaultStateObjID(String)

Declaration
public int GetDefaultStateObjID(string countryName)
Parameters
Type | Name | Description
System.String | countryName |
Returns
Type | Description
System.Int32 |

GetDefaultTimeZone()

Declaration
public ITimeZone GetDefaultTimeZone()
Returns
Type | Description
ITimeZone |

GetDefaultTimeZoneObjID()

Declaration
public int GetDefaultTimeZoneObjID()
Returns
Type | Description
System.Int32 |

GetFullStateObjID(String, String)

Declaration
public int GetFullStateObjID(string countryName, string fullStateName)
Parameters
Type | Name | Description
System.String | countryName |
System.String | fullStateName |
Returns
Type | Description
System.Int32 |

GetServerTimeZoneOffset()

Declaration
public int GetServerTimeZoneOffset()
Returns
Type | Description
System.Int32 |

GetShortTimeZoneObjID(String)

Declaration
public int GetShortTimeZoneObjID(string shortName)
Parameters
Type | Name | Description
System.String | shortName |
Returns
Type | Description
System.Int32 |

GetStateObjID(String, String)

Declaration
public int GetStateObjID(string countryName, string stateName)
Parameters
Type | Name | Description
System.String | countryName |
System.String | stateName |
Returns
Type | Description
System.Int32 |

GetStates()

Declaration
public StateCollection GetStates()
Returns
Type | Description
StateCollection |

GetStates(String)

Declaration
public StateCollection GetStates(string countryName)
Parameters
Type | Name | Description
System.String | countryName |
Returns
Type | Description
StateCollection |

GetTimeZoneObjID(String)

Declaration
public int GetTimeZoneObjID(string fullTimeZoneName)
Parameters
Type | Name | Description
System.String | fullTimeZoneName |
Returns
Type | Description
System.Int32 |

GetTimeZoneOffset(String)

Declaration
public int GetTimeZoneOffset(string fullTimeZoneName)
Parameters
Type | Name | Description
System.String | fullTimeZoneName |
Returns
Type | Description
System.Int32 |

GetTimeZonesInCountry(String)

Declaration
public FCTimeZoneCollection GetTimeZonesInCountry(string countryName)
Parameters
Type | Name | Description
System.String | countryName |
Returns
Type | Description
FCTimeZoneCollection |

InitCacheData()

Declaration
protected override object InitCacheData()
Returns
Type | Description
System.Object |
Overrides
CacheBase.InitCacheData()

IsCountry(String)

Declaration
public bool IsCountry(string countryName)
Parameters
Type | Name | Description
System.String | countryName |
Returns
Type | Description
System.Boolean |

IsFullState(String, String)

Declaration
public bool IsFullState(string countryName, string stateName)
Parameters
Type | Name | Description
System.String | countryName |
System.String | stateName |
Returns
Type | Description
System.Boolean |

IsOnDST(String, DateTime)

Declaration
public bool IsOnDST(string fullTimeZoneName, DateTime checkDate)
Parameters
Type | Name | Description
System.String | fullTimeZoneName |
System.DateTime | checkDate |
Returns
Type | Description
System.Boolean |

IsState(String, String)

Declaration
public bool IsState(string countryName, string stateName)
Parameters
Type | Name | Description
System.String | countryName |
System.String | stateName |
Returns
Type | Description
System.Boolean |

IsState(String, String, Boolean)

Declaration
public bool IsState(string countryName, string stateName, bool isFullStateName)
Parameters
Type | Name | Description
System.String | countryName |
System.String | stateName |
System.Boolean | isFullStateName |
Returns
Type | Description
System.Boolean |

IsTimeZone(String)

Declaration
public bool IsTimeZone(string tzName)
Parameters
Type | Name | Description
System.String | tzName |
Returns
Type | Description
System.Boolean |

IsTimeZoneInCountry(String, String)

Declaration
public bool IsTimeZoneInCountry(string countryName, string tzName)
Parameters
Type | Name | Description
System.String | countryName |
System.String | tzName |
Returns
Type | Description
System.Boolean |

IsTimeZoneInCountry(String, String, Boolean)

Declaration
public bool IsTimeZoneInCountry(string countryName, string tzName, bool isFullTzName)
Parameters
Type | Name | Description
System.String | countryName |
System.String | tzName |
System.Boolean | isFullTzName |
Returns
Type | Description
System.Boolean |

LoadCacheData(Object)

Declaration
protected override void LoadCacheData(object cacheData)
Parameters
Type | Name | Description
System.Object | cacheData |
Overrides
CacheBase.LoadCacheData(Object)

SetNameAndParameters(String, String)

Declaration
protected override void SetNameAndParameters(string name, string parameters)
Parameters
Type | Name | Description
System.String | name |
System.String | parameters |
Overrides
CacheBase.SetNameAndParameters(String, String)

SetServerTimeZoneToMachineTimeZone()

Declaration
public void SetServerTimeZoneToMachineTimeZone()

Implements

ILocaleCache


Namespace FChoice.Foundation.Clarify.Schema | fcSDK Documentation

Namespace FChoice.Foundation.Clarify.Schema

Classes

RestrictionClause

SchemaFieldBase

SchemaFieldCollectionBase

SchemaRelation

SchemaRelationCollection

SchemaTable

SchemaTableBase

SchemaTableCollection

SchemaTableField

SchemaTableFieldCollection

SchemaView

SchemaViewCollection

SchemaViewField

SchemaViewFieldCollection

SchemaViewFieldInfo

SchemaViewFieldInfoCollection

SchemaViewJoin

SchemaViewJoinCollection

Enums

SchemaCommonType

SchemaDataType

Back to top © 2022 Dovetail Software, Inc. - All rights reserved.
Clarify, Amdocs, and related products and names are copyright and trademark of Amdocs, Inc.
.NET, Visual Studio.NET, C#, Visual Basic and related products are trademark of Microsoft corporation.


Class RestrictionClause | fcSDK Documentation

Class RestrictionClause

Inheritance
System.Object
RestrictionClause
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Schema
Assembly: fcSDK.dll
Syntax
public class RestrictionClause

Constructors

RestrictionClause(String, String, String)

Declaration
public RestrictionClause(string tableName, string fieldName, string clause)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
System.String | clause |

Properties

Clause

Declaration
public string Clause { get; }
Property Value
Type | Description
System.String |

FieldName

Declaration
public string FieldName { get; }
Property Value
Type | Description
System.String |

TableName

Declaration
public string TableName { get; }
Property Value
Type | Description
System.String |


Enum SchemaCommonType | fcSDK Documentation

Enum SchemaCommonType

Namespace: FChoice.Foundation.Clarify.Schema
Assembly: fcSDK.dll
Syntax
public enum SchemaCommonType

Fields

Name | Description
Date |
Decimal |
Double |
Float |
Integer |
String |


Enum SchemaDataType | fcSDK Documentation

Enum SchemaDataType

Namespace: FChoice.Foundation.Clarify.Schema
Assembly: fcSDK.dll
Syntax
public enum SchemaDataType

Fields

Name | Description
CharArray |
ClobOrText |
DateTime |
Decimal |
Double |
Integer |
Real |
SmallInt |
TinyInt |
VarChar |


Class SchemaFieldBase | fcSDK Documentation

Class SchemaFieldBase

Inheritance
System.Object
DataObject
ClarifyDataObject
SchemaFieldBase
SchemaTableField
SchemaViewField
Implements
IDataObject
ISchemaField
Inherited Members
ClarifyDataObject.GetCommentFieldValue(DataRow)
ClarifyDataObject.CommentFieldName
ClarifyDataObject.ObjectID
DataObject.SetUniqueID(Object)
DataObject.GetFieldValue(String)
DataObject.GetFieldValue(Int32)
DataObject.ContainsColumn(String)
DataObject.GetSafeInt32FieldValue(String)
DataObject.GetSafeInt32FieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeDoubleFieldValue(String)
DataObject.GetSafeDoubleFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeBooleanFieldValue(String)
DataObject.GetSafeBooleanFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeStringFieldValue(String)
DataObject.SetFieldValue(String, Object)
DataObject.GetSafeString(Object)
DataObject.UniqueID
DataObject.FieldValues
DataObject.ColumnMap
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Schema
Assembly: fcSDK.dll
Syntax
public abstract class SchemaFieldBase : ClarifyDataObject, IDataObject, ISchemaField

Constructors

SchemaFieldBase(DataRow, SchemaTableBase)

Declaration
protected SchemaFieldBase(DataRow row, SchemaTableBase tableBase)
Parameters
Type | Name | Description
System.Data.DataRow | row |
SchemaTableBase | tableBase |

Properties

ArraySize

Declaration
public int ArraySize { get; }
Property Value
Type | Description
System.Int32 |

CommonType

Declaration
public int CommonType { get; }
Property Value
Type | Description
System.Int32 |

DatabaseType

Declaration
public int DatabaseType { get; }
Property Value
Type | Description
System.Int32 |

DecimalPrecision

Declaration
public int DecimalPrecision { get; }
Property Value
Type | Description
System.Int32 |

DecimalScale

Declaration
public int DecimalScale { get; }
Property Value
Type | Description
System.Int32 |

Default

Declaration
public object Default { get; }
Property Value
Type | Description
System.Object |

DefaultString

Declaration
public string DefaultString { get; }
Property Value
Type | Description
System.String |

FCFlags

Declaration
public int FCFlags { get; }
Property Value
Type | Description
System.Int32 |

FieldDefault

Declaration
public object FieldDefault { get; }
Property Value
Type | Description
System.Object |

FieldDefaultString

Declaration
public string FieldDefaultString { get; }
Property Value
Type | Description
System.String |

Flags

Declaration
public int Flags { get; }
Property Value
Type | Description
System.Int32 |

GenFieldID

Declaration
public int GenFieldID { get; }
Property Value
Type | Description
System.Int32 |

IsSearchable

Declaration
public bool IsSearchable { get; }
Property Value
Type | Description
System.Boolean |

IsUnicode

Declaration
public bool IsUnicode { get; }
Property Value
Type | Description
System.Boolean |

Name

Declaration
public string Name { get; }
Property Value
Type | Description
System.String |

ObjectType

Declaration
public Type ObjectType { get; }
Property Value
Type | Description
System.Type |

Parent

Declaration
public SchemaTableBase Parent { get; }
Property Value
Type | Description
SchemaTableBase |

ParentTypeID

Declaration
public int ParentTypeID { get; }
Property Value
Type | Description
System.Int32 |

SpecificFieldID

Declaration
public int SpecificFieldID { get; }
Property Value
Type | Description
System.Int32 |

Methods

GetFieldDefault(String)

Declaration
protected object GetFieldDefault(string defVal)
Parameters
Type | Name | Description
System.String | defVal |
Returns
Type | Description
System.Object |

IsDate()

Declaration
public bool IsDate()
Returns
Type | Description
System.Boolean |

IsInteger()

Declaration
public bool IsInteger()
Returns
Type | Description
System.Boolean |

IsNumeric()

Declaration
public bool IsNumeric()
Returns
Type | Description
System.Boolean |

IsString()

Declaration
public bool IsString()
Returns
Type | Description
System.Boolean |

Explicit Interface Implementations

ISchemaField.DataType

Declaration
int ISchemaField.DataType { get; }
Returns
Type | Description
System.Int32 |

ISchemaField.Description

Declaration
string ISchemaField.Description { get; }
Returns
Type | Description
System.String |

ISchemaField.Flags

Declaration
object ISchemaField.Flags { get; }
Returns
Type | Description
System.Object |

ISchemaField.Length

Declaration
int ISchemaField.Length { get; }
Returns
Type | Description
System.Int32 |

ISchemaField.Rank

Declaration
int ISchemaField.Rank { get; }
Returns
Type | Description
System.Int32 |

Implements

IDataObject
ISchemaField


Class SchemaFieldCollectionBase | fcSDK Documentation

Class SchemaFieldCollectionBase

Inheritance
System.Object
System.Collections.Generic.List<SchemaFieldBase>
DataObjectCollection<SchemaFieldBase>
SchemaFieldCollectionBase
SchemaTableFieldCollection
SchemaViewFieldCollection
Implements
System.Collections.Generic.IList<SchemaFieldBase>
System.Collections.Generic.ICollection<SchemaFieldBase>
System.Collections.IList
System.Collections.Generic.IReadOnlyList<SchemaFieldBase>
System.Collections.Generic.IReadOnlyCollection<SchemaFieldBase>
System.Collections.Generic.IEnumerable<SchemaFieldBase>
ISchemaFieldCollection
System.Collections.ICollection
System.Collections.IEnumerable
Inherited Members
DataObjectCollection<SchemaFieldBase>.Initialize(DataTable)
DataObjectCollection<SchemaFieldBase>.Initialize(DataRow[])
DataObjectCollection<SchemaFieldBase>.Initialize(Object[][])
DataObjectCollection<SchemaFieldBase>.AddDataObject(SchemaFieldBase)
DataObjectCollection<SchemaFieldBase>.OnDataObjectAdded(SchemaFieldBase)
DataObjectCollection<SchemaFieldBase>.Create(Object[])
DataObjectCollection<SchemaFieldBase>.GetItemByIndex(Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.IList.get_Item(System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.IList.set_Item(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Add(FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.IList.Add(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.AddRange(System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.AsReadOnly()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.BinarySearch(System.Int32, System.Int32, FChoice.Foundation.Clarify.Schema.SchemaFieldBase, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.BinarySearch(FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.BinarySearch(FChoice.Foundation.Clarify.Schema.SchemaFieldBase, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Clear()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Contains(FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.IList.Contains(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.ConvertAll<TOutput>(System.Converter<FChoice.Foundation.Clarify.Schema.SchemaFieldBase, TOutput>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.CopyTo(FChoice.Foundation.Clarify.Schema.SchemaFieldBase[])
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.ICollection.CopyTo(System.Array, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.CopyTo(System.Int32, FChoice.Foundation.Clarify.Schema.SchemaFieldBase[], System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.CopyTo(FChoice.Foundation.Clarify.Schema.SchemaFieldBase[], System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Exists(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Find(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.FindAll(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.FindIndex(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.FindIndex(System.Int32, System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.FindIndex(System.Int32, System.Int32, System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.FindLast(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.FindLastIndex(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.FindLastIndex(System.Int32, System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.FindLastIndex(System.Int32, System.Int32, System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.ForEach(System.Action<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.IEnumerable.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.GetRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.IndexOf(FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.IList.IndexOf(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.IndexOf(FChoice.Foundation.Clarify.Schema.SchemaFieldBase, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.IndexOf(FChoice.Foundation.Clarify.Schema.SchemaFieldBase, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Insert(System.Int32, FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.IList.Insert(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.InsertRange(System.Int32, System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.LastIndexOf(FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.LastIndexOf(FChoice.Foundation.Clarify.Schema.SchemaFieldBase, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.LastIndexOf(FChoice.Foundation.Clarify.Schema.SchemaFieldBase, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Remove(FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.IList.Remove(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.RemoveAll(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.RemoveAt(System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.RemoveRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Reverse()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Reverse(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Sort()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Sort(System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Sort(System.Int32, System.Int32, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Sort(System.Comparison<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.ToArray()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.TrimExcess()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.TrueForAll(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Capacity
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Count
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.IList.IsFixedSize
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.IsReadOnly
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.IList.IsReadOnly
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.ICollection.IsSynchronized
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.ICollection.SyncRoot
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Item[System.Int32]
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.IList.Item[System.Int32]
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Schema
Assembly: fcSDK.dll
Syntax
public abstract class SchemaFieldCollectionBase : DataObjectCollection<SchemaFieldBase>, IList<SchemaFieldBase>, ICollection<SchemaFieldBase>, IList, IReadOnlyList<SchemaFieldBase>, IReadOnlyCollection<SchemaFieldBase>, IEnumerable<SchemaFieldBase>, ISchemaFieldCollection, ICollection, IEnumerable

Constructors

SchemaFieldCollectionBase(DataRow[], SchemaTableBase)

Declaration
protected SchemaFieldCollectionBase(DataRow[] rows, SchemaTableBase parent)
Parameters
Type | Name | Description
System.Data.DataRow[] | rows |
SchemaTableBase | parent |

Properties

Item[String]

Declaration
public SchemaFieldBase this[string name] { get; }
Parameters
Type | Name | Description
System.String | name |
Property Value
Type | Description
SchemaFieldBase |

Methods

Create(DataRow)

Declaration
protected override SchemaFieldBase Create(DataRow row)
Parameters
Type | Name | Description
System.Data.DataRow | row |
Returns
Type | Description
SchemaFieldBase |
Overrides
FChoice.Foundation.DataObjects.DataObjectCollection<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Create(System.Data.DataRow)

CreateFieldType(DataRow, Object)

Declaration
protected abstract SchemaFieldBase CreateFieldType(DataRow row, object baseObject)
Parameters
Type | Name | Description
System.Data.DataRow | row |
System.Object | baseObject |
Returns
Type | Description
SchemaFieldBase |

GetInternalFieldByID(Int32)

Declaration
protected SchemaFieldBase GetInternalFieldByID(int specFieldID)
Parameters
Type | Name | Description
System.Int32 | specFieldID |
Returns
Type | Description
SchemaFieldBase |

Explicit Interface Implementations

ISchemaFieldCollection.get_Item(Int32)

Declaration
ISchemaField ISchemaFieldCollection.get_Item(int rank)
Parameters
Type | Name | Description
System.Int32 | rank |
Returns
Type | Description
ISchemaField |

ISchemaFieldCollection.get_Item(String)

Declaration
ISchemaField ISchemaFieldCollection.get_Item(string name)
Parameters
Type | Name | Description
System.String | name |
Returns
Type | Description
ISchemaField |

ISchemaFieldCollection.Item[Int32]

Declaration
ISchemaField ISchemaFieldCollection.this[] { get; }
Parameters
Type | Name | Description
System.Int32 | rank |
Returns
Type | Description
ISchemaField |

ISchemaFieldCollection.Item[String]

Declaration
ISchemaField ISchemaFieldCollection.this[] { get; }
Parameters
Type | Name | Description
System.String | name |
Returns
Type | Description
ISchemaField |

Implements

System.Collections.Generic.IList<T>
System.Collections.Generic.ICollection<T>
System.Collections.IList
System.Collections.Generic.IReadOnlyList<T>
System.Collections.Generic.IReadOnlyCollection<T>
System.Collections.Generic.IEnumerable<T>
ISchemaFieldCollection
System.Collections.ICollection
System.Collections.IEnumerable


Class SchemaRelation | fcSDK Documentation

Class SchemaRelation

Inheritance
System.Object
DataObject
ClarifyDataObject
SchemaRelation
Implements
IDataObject
ISchemaRelation
Inherited Members
ClarifyDataObject.GetCommentFieldValue(DataRow)
ClarifyDataObject.CommentFieldName
ClarifyDataObject.ObjectID
DataObject.SetUniqueID(Object)
DataObject.GetFieldValue(String)
DataObject.GetFieldValue(Int32)
DataObject.ContainsColumn(String)
DataObject.GetSafeInt32FieldValue(String)
DataObject.GetSafeInt32FieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeDoubleFieldValue(String)
DataObject.GetSafeDoubleFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeBooleanFieldValue(String)
DataObject.GetSafeBooleanFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeStringFieldValue(String)
DataObject.SetFieldValue(String, Object)
DataObject.GetSafeString(Object)
DataObject.UniqueID
DataObject.FieldValues
DataObject.ColumnMap
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Schema
Assembly: fcSDK.dll
Syntax
public class SchemaRelation : ClarifyDataObject, IDataObject, ISchemaRelation

Fields

MANDATORY_REL_OBJID

Declaration
public const int MANDATORY_REL_OBJID = -2
Field Value
Type | Description
System.Int32 |

Properties

Cardinality

Declaration
public SchemaRelationCardinality Cardinality { get; }
Property Value
Type | Description
SchemaRelationCardinality |

ChildTable

Declaration
public SchemaTable ChildTable { get; }
Property Value
Type | Description
SchemaTable |

Comments

Declaration
public string Comments { get; }
Property Value
Type | Description
System.String |

ExclusiveSet

Declaration
public string ExclusiveSet { get; }
Property Value
Type | Description
System.String |

Flags

Declaration
public int Flags { get; }
Property Value
Type | Description
System.Int32 |

FocusFieldName

Declaration
public string FocusFieldName { get; }
Property Value
Type | Description
System.String |

GenericRelationID

Declaration
public int GenericRelationID { get; }
Property Value
Type | Description
System.Int32 |

InverseRelation

Declaration
public SchemaRelation InverseRelation { get; }
Property Value
Type | Description
SchemaRelation |

InverseRelationName

Declaration
public string InverseRelationName { get; }
Property Value
Type | Description
System.String |

IsExclusive

Declaration
public bool IsExclusive { get; }
Property Value
Type | Description
System.Boolean |

IsMandatory

Declaration
public bool IsMandatory { get; }
Property Value
Type | Description
System.Boolean |

IsMtm

Declaration
public bool IsMtm { get; }
Property Value
Type | Description
System.Boolean |

MandatoryObjectID

Declaration
public object MandatoryObjectID { get; }
Property Value
Type | Description
System.Object |

MtmTableName

Declaration
public string MtmTableName { get; }
Property Value
Type | Description
System.String |

Name

Declaration
public string Name { get; }
Property Value
Type | Description
System.String |

ParentTable

Declaration
public SchemaTable ParentTable { get; }
Property Value
Type | Description
SchemaTable |

ParentTypeID

Declaration
public int ParentTypeID { get; }
Property Value
Type | Description
System.Int32 |

RelationFlags

Declaration
public int RelationFlags { get; }
Property Value
Type | Description
System.Int32 |

RelationPhysicalName

Declaration
public string RelationPhysicalName { get; }
Property Value
Type | Description
System.String |

SourceTable

Declaration
public SchemaTable SourceTable { get; }
Property Value
Type | Description
SchemaTable |

SpecificRelationID

Declaration
public int SpecificRelationID { get; }
Property Value
Type | Description
System.Int32 |

TargetName

Declaration
public string TargetName { get; }
Property Value
Type | Description
System.String |

TargetTable

Declaration
public SchemaTable TargetTable { get; }
Property Value
Type | Description
SchemaTable |

Explicit Interface Implementations

ISchemaRelation.ChildTable

Declaration
ISchemaTable ISchemaRelation.ChildTable { get; }
Returns
Type | Description
ISchemaTable |

ISchemaRelation.Description

Declaration
string ISchemaRelation.Description { get; }
Returns
Type | Description
System.String |

ISchemaRelation.ExclusiveObjectIDField

Declaration
ISchemaField ISchemaRelation.ExclusiveObjectIDField { get; }
Returns
Type | Description
ISchemaField |

ISchemaRelation.ExclusiveTableField

Declaration
ISchemaField ISchemaRelation.ExclusiveTableField { get; }
Returns
Type | Description
ISchemaField |

ISchemaRelation.Flags

Declaration
object ISchemaRelation.Flags { get; }
Returns
Type | Description
System.Object |

ISchemaRelation.InverseRelation

Declaration
ISchemaRelation ISchemaRelation.InverseRelation { get; }
Returns
Type | Description
ISchemaRelation |

ISchemaRelation.ObjectID

Declaration
object ISchemaRelation.ObjectID { get; }
Returns
Type | Description
System.Object |

ISchemaRelation.ParentTable

Declaration
ISchemaTable ISchemaRelation.ParentTable { get; }
Returns
Type | Description
ISchemaTable |

ISchemaRelation.Rank

Declaration
int ISchemaRelation.Rank { get; }
Returns
Type | Description
System.Int32 |

ISchemaRelation.SourceTable

Declaration
ISchemaTable ISchemaRelation.SourceTable { get; }
Returns
Type | Description
ISchemaTable |

ISchemaRelation.TargetTable

Declaration
ISchemaTable ISchemaRelation.TargetTable { get; }
Returns
Type | Description
ISchemaTable |

Implements

IDataObject
ISchemaRelation


Class SchemaRelationCollection | fcSDK Documentation

Class SchemaRelationCollection

Inheritance
System.Object
System.Collections.Generic.List<SchemaRelation>
DataObjectCollection<SchemaRelation>
SchemaRelationCollection
Implements
System.Collections.Generic.IList<SchemaRelation>
System.Collections.Generic.ICollection<SchemaRelation>
System.Collections.IList
System.Collections.Generic.IReadOnlyList<SchemaRelation>
System.Collections.Generic.IReadOnlyCollection<SchemaRelation>
System.Collections.Generic.IEnumerable<SchemaRelation>
ISchemaRelationCollection
System.Collections.ICollection
System.Collections.IEnumerable
Inherited Members
DataObjectCollection<SchemaRelation>.Initialize(DataTable)
DataObjectCollection<SchemaRelation>.Initialize(DataRow[])
DataObjectCollection<SchemaRelation>.Initialize(Object[][])
DataObjectCollection<SchemaRelation>.AddDataObject(SchemaRelation)
DataObjectCollection<SchemaRelation>.OnDataObjectAdded(SchemaRelation)
DataObjectCollection<SchemaRelation>.Create(Object[])
DataObjectCollection<SchemaRelation>.GetItemByIndex(Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.System.Collections.IList.get_Item(System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.System.Collections.IList.set_Item(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.Add(FChoice.Foundation.Clarify.Schema.SchemaRelation)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.System.Collections.IList.Add(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.AddRange(System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.Schema.SchemaRelation>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.AsReadOnly()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.BinarySearch(System.Int32, System.Int32, FChoice.Foundation.Clarify.Schema.SchemaRelation, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.Schema.SchemaRelation>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.BinarySearch(FChoice.Foundation.Clarify.Schema.SchemaRelation)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.BinarySearch(FChoice.Foundation.Clarify.Schema.SchemaRelation, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.Schema.SchemaRelation>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.Clear()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.Contains(FChoice.Foundation.Clarify.Schema.SchemaRelation)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.System.Collections.IList.Contains(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.ConvertAll<TOutput>(System.Converter<FChoice.Foundation.Clarify.Schema.SchemaRelation, TOutput>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.CopyTo(FChoice.Foundation.Clarify.Schema.SchemaRelation[])
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.System.Collections.ICollection.CopyTo(System.Array, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.CopyTo(System.Int32, FChoice.Foundation.Clarify.Schema.SchemaRelation[], System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.CopyTo(FChoice.Foundation.Clarify.Schema.SchemaRelation[], System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.Exists(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaRelation>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.Find(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaRelation>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.FindAll(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaRelation>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.FindIndex(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaRelation>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.FindIndex(System.Int32, System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaRelation>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.FindIndex(System.Int32, System.Int32, System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaRelation>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.FindLast(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaRelation>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.FindLastIndex(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaRelation>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.FindLastIndex(System.Int32, System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaRelation>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.FindLastIndex(System.Int32, System.Int32, System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaRelation>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.ForEach(System.Action<FChoice.Foundation.Clarify.Schema.SchemaRelation>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.Schema.SchemaRelation>.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.System.Collections.IEnumerable.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.GetRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.IndexOf(FChoice.Foundation.Clarify.Schema.SchemaRelation)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.System.Collections.IList.IndexOf(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.IndexOf(FChoice.Foundation.Clarify.Schema.SchemaRelation, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.IndexOf(FChoice.Foundation.Clarify.Schema.SchemaRelation, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.Insert(System.Int32, FChoice.Foundation.Clarify.Schema.SchemaRelation)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.System.Collections.IList.Insert(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.InsertRange(System.Int32, System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.Schema.SchemaRelation>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.LastIndexOf(FChoice.Foundation.Clarify.Schema.SchemaRelation)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.LastIndexOf(FChoice.Foundation.Clarify.Schema.SchemaRelation, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.LastIndexOf(FChoice.Foundation.Clarify.Schema.SchemaRelation, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.Remove(FChoice.Foundation.Clarify.Schema.SchemaRelation)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.System.Collections.IList.Remove(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.RemoveAll(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaRelation>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.RemoveAt(System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.RemoveRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.Reverse()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.Reverse(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.Sort()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.Sort(System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.Schema.SchemaRelation>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.Sort(System.Int32, System.Int32, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.Schema.SchemaRelation>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.Sort(System.Comparison<FChoice.Foundation.Clarify.Schema.SchemaRelation>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.ToArray()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.TrimExcess()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.TrueForAll(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaRelation>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.Capacity
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.Count
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.System.Collections.IList.IsFixedSize
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.Schema.SchemaRelation>.IsReadOnly
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.System.Collections.IList.IsReadOnly
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.System.Collections.ICollection.IsSynchronized
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.System.Collections.ICollection.SyncRoot
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaRelation>.System.Collections.IList.Item[System.Int32]
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Schema
Assembly: fcSDK.dll
Syntax
public class SchemaRelationCollection : DataObjectCollection<SchemaRelation>, IList<SchemaRelation>, ICollection<SchemaRelation>, IList, IReadOnlyList<SchemaRelation>, IReadOnlyCollection<SchemaRelation>, IEnumerable<SchemaRelation>, ISchemaRelationCollection, ICollection, IEnumerable

Properties

Item[Int32]

Declaration
public SchemaRelation this[int specificRelID] { get; }
Parameters
Type | Name | Description
System.Int32 | specificRelID |
Property Value
Type | Description
SchemaRelation |

Item[String]

Declaration
public SchemaRelation this[string relationName] { get; }
Parameters
Type | Name | Description
System.String | relationName |
Property Value
Type | Description
SchemaRelation |

OtmOtofAndMtmRelations

Declaration
public ICollection<SchemaRelation> OtmOtofAndMtmRelations { get; }
Property Value
Type | Description
System.Collections.Generic.ICollection<SchemaRelation> |

Methods

Create(DataRow)

Declaration
protected override SchemaRelation Create(DataRow row)
Parameters
Type | Name | Description
System.Data.DataRow | row |
Returns
Type | Description
SchemaRelation |
Overrides
FChoice.Foundation.DataObjects.DataObjectCollection<FChoice.Foundation.Clarify.Schema.SchemaRelation>.Create(System.Data.DataRow)

Explicit Interface Implementations

ISchemaRelationCollection.get_Item(String)

Declaration
ISchemaRelation ISchemaRelationCollection.get_Item(string name)
Parameters
Type | Name | Description
System.String | name |
Returns
Type | Description
ISchemaRelation |

ISchemaRelationCollection.Item[String]

Declaration
ISchemaRelation ISchemaRelationCollection.this[] { get; }
Parameters
Type | Name | Description
System.String | name |
Returns
Type | Description
ISchemaRelation |

Implements

System.Collections.Generic.IList<T>
System.Collections.Generic.ICollection<T>
System.Collections.IList
System.Collections.Generic.IReadOnlyList<T>
System.Collections.Generic.IReadOnlyCollection<T>
System.Collections.Generic.IEnumerable<T>
ISchemaRelationCollection
System.Collections.ICollection
System.Collections.IEnumerable


Class SchemaTable | fcSDK Documentation

Class SchemaTable

Inheritance
System.Object
DataObject
ClarifyDataObject
SchemaTableBase
SchemaTable
Implements
IDataObject
ISchemaTable
ISchemaTableBase
Inherited Members
SchemaTableBase.isDataRestricted
SchemaTableBase.restrictedFields
SchemaTableBase.restrictionClauses
SchemaTableBase.LoadData(DataRow)
SchemaTableBase.SetFlags(Int32)
SchemaTableBase.SetName(String)
SchemaTableBase.SetComments(String)
SchemaTableBase.SetIsUnicode(Boolean)
SchemaTableBase.SetObjectGroup(String)
SchemaTableBase.LoadRestrictions(DataRow[], Type)
SchemaTableBase.LoadResSqlClauses(DataRow[])
SchemaTableBase.Flags
SchemaTableBase.Name
SchemaTableBase.Comments
SchemaTableBase.TypeID
SchemaTableBase.ObjectGroup
SchemaTableBase.IsUnicode
SchemaTableBase.IsDataRestricted
SchemaTableBase.RestrictedFields
SchemaTableBase.RestrictionClauses
SchemaTableBase.ISchemaTableBase.ObjectID
SchemaTableBase.ISchemaTableBase.Name
SchemaTableBase.ISchemaTableBase.Number
SchemaTableBase.ISchemaTableBase.Description
SchemaTableBase.ISchemaTableBase.Flags
SchemaTableBase.ISchemaTableBase.Subsystem
SchemaTableBase.ISchemaTableBase.Fields
ClarifyDataObject.GetCommentFieldValue(DataRow)
ClarifyDataObject.CommentFieldName
ClarifyDataObject.ObjectID
DataObject.SetUniqueID(Object)
DataObject.GetFieldValue(String)
DataObject.GetFieldValue(Int32)
DataObject.ContainsColumn(String)
DataObject.GetSafeInt32FieldValue(String)
DataObject.GetSafeInt32FieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeDoubleFieldValue(String)
DataObject.GetSafeDoubleFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeBooleanFieldValue(String)
DataObject.GetSafeBooleanFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeStringFieldValue(String)
DataObject.SetFieldValue(String, Object)
DataObject.GetSafeString(Object)
DataObject.UniqueID
DataObject.FieldValues
DataObject.ColumnMap
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Schema
Assembly: fcSDK.dll
Syntax
public class SchemaTable : SchemaTableBase, IDataObject, ISchemaTable, ISchemaTableBase

Properties

Fields

Declaration
public SchemaTableFieldCollection Fields { get; }
Property Value
Type | Description
SchemaTableFieldCollection |

Relationships

Declaration
public SchemaRelationCollection Relationships { get; }
Property Value
Type | Description
SchemaRelationCollection |

Views

Declaration
public SchemaViewCollection Views { get; }
Property Value
Type | Description
SchemaViewCollection |

Methods

LoadFields(DataRow)

Declaration
protected override SchemaFieldCollectionBase LoadFields(DataRow row)
Parameters
Type | Name | Description
System.Data.DataRow | row |
Returns
Type | Description
SchemaFieldCollectionBase |
Overrides
SchemaTableBase.LoadFields(DataRow)

Explicit Interface Implementations

ISchemaTable.Relationships

Declaration
ISchemaRelationCollection ISchemaTable.Relationships { get; }
Returns
Type | Description
ISchemaRelationCollection |

ISchemaTable.Views

Declaration
ISchemaViewCollection ISchemaTable.Views { get; }
Returns
Type | Description
ISchemaViewCollection |

Implements

IDataObject
ISchemaTable
ISchemaTableBase


Class SchemaTableBase | fcSDK Documentation

Class SchemaTableBase

Inheritance
System.Object
DataObject
ClarifyDataObject
SchemaTableBase
SchemaTable
SchemaView
Implements
IDataObject
ISchemaTableBase
Inherited Members
ClarifyDataObject.GetCommentFieldValue(DataRow)
ClarifyDataObject.CommentFieldName
ClarifyDataObject.ObjectID
DataObject.SetUniqueID(Object)
DataObject.GetFieldValue(String)
DataObject.GetFieldValue(Int32)
DataObject.ContainsColumn(String)
DataObject.GetSafeInt32FieldValue(String)
DataObject.GetSafeInt32FieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeDoubleFieldValue(String)
DataObject.GetSafeDoubleFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeBooleanFieldValue(String)
DataObject.GetSafeBooleanFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeStringFieldValue(String)
DataObject.SetFieldValue(String, Object)
DataObject.GetSafeString(Object)
DataObject.UniqueID
DataObject.FieldValues
DataObject.ColumnMap
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Schema
Assembly: fcSDK.dll
Syntax
public abstract class SchemaTableBase : ClarifyDataObject, IDataObject, ISchemaTableBase

Constructors

SchemaTableBase(DataRow)

Declaration
protected SchemaTableBase(DataRow row)
Parameters
Type | Name | Description
System.Data.DataRow | row |

Fields

isDataRestricted

Declaration
protected bool isDataRestricted
Field Value
Type | Description
System.Boolean |

restrictedFields

Declaration
protected SchemaFieldBase[] restrictedFields
Field Value
Type | Description
SchemaFieldBase[] |

restrictionClauses

Declaration
protected RestrictionClause[] restrictionClauses
Field Value
Type | Description
RestrictionClause[] |

Properties

Comments

Declaration
public string Comments { get; }
Property Value
Type | Description
System.String |

Fields

Declaration
public SchemaFieldCollectionBase Fields { get; }
Property Value
Type | Description
SchemaFieldCollectionBase |

Flags

Declaration
public int Flags { get; }
Property Value
Type | Description
System.Int32 |

IsDataRestricted

Declaration
public bool IsDataRestricted { get; }
Property Value
Type | Description
System.Boolean |

IsUnicode

Declaration
public bool IsUnicode { get; }
Property Value
Type | Description
System.Boolean |

Name

Declaration
public string Name { get; }
Property Value
Type | Description
System.String |

ObjectGroup

Declaration
public string ObjectGroup { get; }
Property Value
Type | Description
System.String |

RestrictedFields

Declaration
public SchemaFieldBase[] RestrictedFields { get; }
Property Value
Type | Description
SchemaFieldBase[] |

RestrictionClauses

Declaration
public RestrictionClause[] RestrictionClauses { get; }
Property Value
Type | Description
RestrictionClause[] |

TypeID

Declaration
public int TypeID { get; }
Property Value
Type | Description
System.Int32 |

Methods

LoadData(DataRow)

Declaration
protected void LoadData(DataRow row)
Parameters
Type | Name | Description
System.Data.DataRow | row |

LoadFields(DataRow)

Declaration
protected abstract SchemaFieldCollectionBase LoadFields(DataRow row)
Parameters
Type | Name | Description
System.Data.DataRow | row |
Returns
Type | Description
SchemaFieldCollectionBase |

LoadResSqlClauses(DataRow[])

Declaration
protected RestrictionClause[] LoadResSqlClauses(DataRow[] rows)
Parameters
Type | Name | Description
System.Data.DataRow[] | rows |
Returns
Type | Description
RestrictionClause[] |

LoadRestrictions(DataRow[], Type)

Declaration
protected SchemaFieldBase[] LoadRestrictions(DataRow[] rows, Type arrayBaseType)
Parameters
Type | Name | Description
System.Data.DataRow[] | rows |
System.Type | arrayBaseType |
Returns
Type | Description
SchemaFieldBase[] |

SetComments(String)

Declaration
protected void SetComments(string value)
Parameters
Type | Name | Description
System.String | value |

SetFlags(Int32)

Declaration
protected void SetFlags(int value)
Parameters
Type | Name | Description
System.Int32 | value |

SetIsUnicode(Boolean)

Declaration
protected void SetIsUnicode(bool value)
Parameters
Type | Name | Description
System.Boolean | value |

SetName(String)

Declaration
protected void SetName(string value)
Parameters
Type | Name | Description
System.String | value |

SetObjectGroup(String)

Declaration
protected void SetObjectGroup(string value)
Parameters
Type | Name | Description
System.String | value |

Explicit Interface Implementations

ISchemaTableBase.Description

Declaration
string ISchemaTableBase.Description { get; }
Returns
Type | Description
System.String |

ISchemaTableBase.Fields

Declaration
ISchemaFieldCollection ISchemaTableBase.Fields { get; }
Returns
Type | Description
ISchemaFieldCollection |

ISchemaTableBase.Flags

Declaration
object ISchemaTableBase.Flags { get; }
Returns
Type | Description
System.Object |

ISchemaTableBase.Name

Declaration
string ISchemaTableBase.Name { get; }
Returns
Type | Description
System.String |

ISchemaTableBase.Number

Declaration
object ISchemaTableBase.Number { get; }
Returns
Type | Description
System.Object |

ISchemaTableBase.ObjectID

Declaration
object ISchemaTableBase.ObjectID { get; }
Returns
Type | Description
System.Object |

ISchemaTableBase.Subsystem

Declaration
string ISchemaTableBase.Subsystem { get; }
Returns
Type | Description
System.String |

Implements

IDataObject
ISchemaTableBase


Class SchemaTableCollection | fcSDK Documentation

Class SchemaTableCollection

Inheritance
System.Object
System.Collections.Generic.List<SchemaTable>
DataObjectCollection<SchemaTable>
SchemaTableCollection
Implements
System.Collections.Generic.IList<SchemaTable>
System.Collections.Generic.ICollection<SchemaTable>
System.Collections.IList
System.Collections.Generic.IReadOnlyList<SchemaTable>
System.Collections.Generic.IReadOnlyCollection<SchemaTable>
System.Collections.Generic.IEnumerable<SchemaTable>
ISchemaTableCollection
System.Collections.ICollection
System.Collections.IEnumerable
Inherited Members
DataObjectCollection<SchemaTable>.Initialize(DataTable)
DataObjectCollection<SchemaTable>.Initialize(DataRow[])
DataObjectCollection<SchemaTable>.Initialize(Object[][])
DataObjectCollection<SchemaTable>.AddDataObject(SchemaTable)
DataObjectCollection<SchemaTable>.OnDataObjectAdded(SchemaTable)
DataObjectCollection<SchemaTable>.Create(Object[])
DataObjectCollection<SchemaTable>.GetItemByIndex(Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.System.Collections.IList.get_Item(System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.System.Collections.IList.set_Item(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.Add(FChoice.Foundation.Clarify.Schema.SchemaTable)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.System.Collections.IList.Add(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.AddRange(System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.Schema.SchemaTable>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.AsReadOnly()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.BinarySearch(System.Int32, System.Int32, FChoice.Foundation.Clarify.Schema.SchemaTable, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.Schema.SchemaTable>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.BinarySearch(FChoice.Foundation.Clarify.Schema.SchemaTable)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.BinarySearch(FChoice.Foundation.Clarify.Schema.SchemaTable, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.Schema.SchemaTable>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.Clear()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.Contains(FChoice.Foundation.Clarify.Schema.SchemaTable)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.System.Collections.IList.Contains(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.ConvertAll<TOutput>(System.Converter<FChoice.Foundation.Clarify.Schema.SchemaTable, TOutput>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.CopyTo(FChoice.Foundation.Clarify.Schema.SchemaTable[])
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.System.Collections.ICollection.CopyTo(System.Array, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.CopyTo(System.Int32, FChoice.Foundation.Clarify.Schema.SchemaTable[], System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.CopyTo(FChoice.Foundation.Clarify.Schema.SchemaTable[], System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.Exists(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaTable>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.Find(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaTable>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.FindAll(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaTable>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.FindIndex(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaTable>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.FindIndex(System.Int32, System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaTable>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.FindIndex(System.Int32, System.Int32, System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaTable>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.FindLast(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaTable>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.FindLastIndex(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaTable>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.FindLastIndex(System.Int32, System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaTable>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.FindLastIndex(System.Int32, System.Int32, System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaTable>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.ForEach(System.Action<FChoice.Foundation.Clarify.Schema.SchemaTable>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.Schema.SchemaTable>.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.System.Collections.IEnumerable.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.GetRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.IndexOf(FChoice.Foundation.Clarify.Schema.SchemaTable)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.System.Collections.IList.IndexOf(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.IndexOf(FChoice.Foundation.Clarify.Schema.SchemaTable, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.IndexOf(FChoice.Foundation.Clarify.Schema.SchemaTable, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.Insert(System.Int32, FChoice.Foundation.Clarify.Schema.SchemaTable)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.System.Collections.IList.Insert(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.InsertRange(System.Int32, System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.Schema.SchemaTable>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.LastIndexOf(FChoice.Foundation.Clarify.Schema.SchemaTable)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.LastIndexOf(FChoice.Foundation.Clarify.Schema.SchemaTable, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.LastIndexOf(FChoice.Foundation.Clarify.Schema.SchemaTable, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.Remove(FChoice.Foundation.Clarify.Schema.SchemaTable)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.System.Collections.IList.Remove(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.RemoveAll(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaTable>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.RemoveAt(System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.RemoveRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.Reverse()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.Reverse(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.Sort()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.Sort(System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.Schema.SchemaTable>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.Sort(System.Int32, System.Int32, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.Schema.SchemaTable>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.Sort(System.Comparison<FChoice.Foundation.Clarify.Schema.SchemaTable>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.ToArray()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.TrimExcess()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.TrueForAll(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaTable>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.Capacity
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.Count
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.System.Collections.IList.IsFixedSize
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.Schema.SchemaTable>.IsReadOnly
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.System.Collections.IList.IsReadOnly
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.System.Collections.ICollection.IsSynchronized
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.System.Collections.ICollection.SyncRoot
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.Item[System.Int32]
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaTable>.System.Collections.IList.Item[System.Int32]
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Schema
Assembly: fcSDK.dll
Syntax
public class SchemaTableCollection : DataObjectCollection<SchemaTable>, IList<SchemaTable>, ICollection<SchemaTable>, IList, IReadOnlyList<SchemaTable>, IReadOnlyCollection<SchemaTable>, IEnumerable<SchemaTable>, ISchemaTableCollection, ICollection, IEnumerable

Properties

Item[String]

Declaration
public SchemaTable this[string tableName] { get; }
Parameters
Type | Name | Description
System.String | tableName |
Property Value
Type | Description
SchemaTable |

Methods

Create(DataRow)

Declaration
protected override SchemaTable Create(DataRow row)
Parameters
Type | Name | Description
System.Data.DataRow | row |
Returns
Type | Description
SchemaTable |
Overrides
FChoice.Foundation.DataObjects.DataObjectCollection<FChoice.Foundation.Clarify.Schema.SchemaTable>.Create(System.Data.DataRow)

GetByNumber(Int32)

Declaration
public SchemaTable GetByNumber(int tableID)
Parameters
Type | Name | Description
System.Int32 | tableID |
Returns
Type | Description
SchemaTable |

Explicit Interface Implementations

ISchemaTableCollection.get_Item(Int32)

Declaration
ISchemaTable ISchemaTableCollection.get_Item(int index)
Parameters
Type | Name | Description
System.Int32 | index |
Returns
Type | Description
ISchemaTable |

ISchemaTableCollection.get_Item(String)

Declaration
ISchemaTable ISchemaTableCollection.get_Item(string name)
Parameters
Type | Name | Description
System.String | name |
Returns
Type | Description
ISchemaTable |

ISchemaTableCollection.GetByNumber(Object)

Declaration
ISchemaTable ISchemaTableCollection.GetByNumber(object number)
Parameters
Type | Name | Description
System.Object | number |
Returns
Type | Description
ISchemaTable |

ISchemaTableCollection.Item[Int32]

Declaration
ISchemaTable ISchemaTableCollection.this[] { get; }
Parameters
Type | Name | Description
System.Int32 | index |
Returns
Type | Description
ISchemaTable |

ISchemaTableCollection.Item[String]

Declaration
ISchemaTable ISchemaTableCollection.this[] { get; }
Parameters
Type | Name | Description
System.String | name |
Returns
Type | Description
ISchemaTable |

Implements

System.Collections.Generic.IList<T>
System.Collections.Generic.ICollection<T>
System.Collections.IList
System.Collections.Generic.IReadOnlyList<T>
System.Collections.Generic.IReadOnlyCollection<T>
System.Collections.Generic.IEnumerable<T>
ISchemaTableCollection
System.Collections.ICollection
System.Collections.IEnumerable


Class SchemaTableField | fcSDK Documentation

Class SchemaTableField

Inheritance
System.Object
DataObject
ClarifyDataObject
SchemaFieldBase
SchemaTableField
Implements
IDataObject
ISchemaField
Inherited Members
SchemaFieldBase.IsString()
SchemaFieldBase.IsNumeric()
SchemaFieldBase.IsInteger()
SchemaFieldBase.IsDate()
SchemaFieldBase.GetFieldDefault(String)
SchemaFieldBase.Parent
SchemaFieldBase.ParentTypeID
SchemaFieldBase.Name
SchemaFieldBase.CommonType
SchemaFieldBase.DatabaseType
SchemaFieldBase.ObjectType
SchemaFieldBase.ArraySize
SchemaFieldBase.DecimalPrecision
SchemaFieldBase.DecimalScale
SchemaFieldBase.Flags
SchemaFieldBase.FCFlags
SchemaFieldBase.GenFieldID
SchemaFieldBase.SpecificFieldID
SchemaFieldBase.FieldDefault
SchemaFieldBase.FieldDefaultString
SchemaFieldBase.IsUnicode
SchemaFieldBase.IsSearchable
SchemaFieldBase.ISchemaField.DataType
SchemaFieldBase.ISchemaField.Rank
SchemaFieldBase.ISchemaField.Length
SchemaFieldBase.ISchemaField.Description
SchemaFieldBase.ISchemaField.Flags
SchemaFieldBase.Default
SchemaFieldBase.DefaultString
ClarifyDataObject.GetCommentFieldValue(DataRow)
ClarifyDataObject.CommentFieldName
ClarifyDataObject.ObjectID
DataObject.SetUniqueID(Object)
DataObject.GetFieldValue(String)
DataObject.GetFieldValue(Int32)
DataObject.ContainsColumn(String)
DataObject.GetSafeInt32FieldValue(String)
DataObject.GetSafeInt32FieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeDoubleFieldValue(String)
DataObject.GetSafeDoubleFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeBooleanFieldValue(String)
DataObject.GetSafeBooleanFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeStringFieldValue(String)
DataObject.SetFieldValue(String, Object)
DataObject.GetSafeString(Object)
DataObject.UniqueID
DataObject.FieldValues
DataObject.ColumnMap
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Schema
Assembly: fcSDK.dll
Syntax
public class SchemaTableField : SchemaFieldBase, IDataObject, ISchemaField

Properties

Table

Declaration
public SchemaTable Table { get; }
Property Value
Type | Description
SchemaTable |

ViewFieldInfos

Declaration
public SchemaViewFieldInfoCollection ViewFieldInfos { get; }
Property Value
Type | Description
SchemaViewFieldInfoCollection |

Implements

IDataObject
ISchemaField


Class SchemaTableFieldCollection | fcSDK Documentation

Class SchemaTableFieldCollection

Inheritance
System.Object
System.Collections.Generic.List<SchemaFieldBase>
DataObjectCollection<SchemaFieldBase>
SchemaFieldCollectionBase
SchemaTableFieldCollection
Implements
System.Collections.Generic.IList<SchemaFieldBase>
System.Collections.Generic.ICollection<SchemaFieldBase>
System.Collections.IList
System.Collections.Generic.IReadOnlyList<SchemaFieldBase>
System.Collections.Generic.IReadOnlyCollection<SchemaFieldBase>
System.Collections.Generic.IEnumerable<SchemaFieldBase>
ISchemaFieldCollection
System.Collections.ICollection
System.Collections.IEnumerable
Inherited Members
SchemaFieldCollectionBase.Create(DataRow)
SchemaFieldCollectionBase.GetInternalFieldByID(Int32)
SchemaFieldCollectionBase.ISchemaFieldCollection.get_Item(Int32)
SchemaFieldCollectionBase.ISchemaFieldCollection.get_Item(String)
SchemaFieldCollectionBase.ISchemaFieldCollection.Item[Int32]
SchemaFieldCollectionBase.ISchemaFieldCollection.Item[String]
DataObjectCollection<SchemaFieldBase>.Initialize(DataTable)
DataObjectCollection<SchemaFieldBase>.Initialize(DataRow[])
DataObjectCollection<SchemaFieldBase>.Initialize(Object[][])
DataObjectCollection<SchemaFieldBase>.AddDataObject(SchemaFieldBase)
DataObjectCollection<SchemaFieldBase>.OnDataObjectAdded(SchemaFieldBase)
DataObjectCollection<SchemaFieldBase>.Create(Object[])
DataObjectCollection<SchemaFieldBase>.GetItemByIndex(Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.IList.get_Item(System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.IList.set_Item(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Add(FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.IList.Add(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.AddRange(System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.AsReadOnly()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.BinarySearch(System.Int32, System.Int32, FChoice.Foundation.Clarify.Schema.SchemaFieldBase, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.BinarySearch(FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.BinarySearch(FChoice.Foundation.Clarify.Schema.SchemaFieldBase, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Clear()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Contains(FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.IList.Contains(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.ConvertAll<TOutput>(System.Converter<FChoice.Foundation.Clarify.Schema.SchemaFieldBase, TOutput>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.CopyTo(FChoice.Foundation.Clarify.Schema.SchemaFieldBase[])
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.ICollection.CopyTo(System.Array, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.CopyTo(System.Int32, FChoice.Foundation.Clarify.Schema.SchemaFieldBase[], System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.CopyTo(FChoice.Foundation.Clarify.Schema.SchemaFieldBase[], System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Exists(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Find(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.FindAll(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.FindIndex(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.FindIndex(System.Int32, System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.FindIndex(System.Int32, System.Int32, System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.FindLast(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.FindLastIndex(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.FindLastIndex(System.Int32, System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.FindLastIndex(System.Int32, System.Int32, System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.ForEach(System.Action<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.IEnumerable.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.GetRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.IndexOf(FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.IList.IndexOf(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.IndexOf(FChoice.Foundation.Clarify.Schema.SchemaFieldBase, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.IndexOf(FChoice.Foundation.Clarify.Schema.SchemaFieldBase, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Insert(System.Int32, FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.IList.Insert(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.InsertRange(System.Int32, System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.LastIndexOf(FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.LastIndexOf(FChoice.Foundation.Clarify.Schema.SchemaFieldBase, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.LastIndexOf(FChoice.Foundation.Clarify.Schema.SchemaFieldBase, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Remove(FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.IList.Remove(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.RemoveAll(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.RemoveAt(System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.RemoveRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Reverse()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Reverse(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Sort()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Sort(System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Sort(System.Int32, System.Int32, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Sort(System.Comparison<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.ToArray()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.TrimExcess()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.TrueForAll(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Capacity
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Count
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.IList.IsFixedSize
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.IsReadOnly
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.IList.IsReadOnly
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.ICollection.IsSynchronized
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.ICollection.SyncRoot
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.IList.Item[System.Int32]
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Schema
Assembly: fcSDK.dll
Syntax
public class SchemaTableFieldCollection : SchemaFieldCollectionBase, IList<SchemaFieldBase>, ICollection<SchemaFieldBase>, IList, IReadOnlyList<SchemaFieldBase>, IReadOnlyCollection<SchemaFieldBase>, IEnumerable<SchemaFieldBase>, ISchemaFieldCollection, ICollection, IEnumerable

Properties

Item[Int32]

Declaration
public SchemaTableField this[int fieldID] { get; }
Parameters
Type | Name | Description
System.Int32 | fieldID |
Property Value
Type | Description
SchemaTableField |

Item[String]

Declaration
public SchemaTableField this[string fieldName] { get; }
Parameters
Type | Name | Description
System.String | fieldName |
Property Value
Type | Description
SchemaTableField |

Methods

CreateFieldType(DataRow, Object)

Declaration
protected override SchemaFieldBase CreateFieldType(DataRow row, object baseObject)
Parameters
Type | Name | Description
System.Data.DataRow | row |
System.Object | baseObject |
Returns
Type | Description
SchemaFieldBase |
Overrides
SchemaFieldCollectionBase.CreateFieldType(DataRow, Object)

Implements

System.Collections.Generic.IList<T>
System.Collections.Generic.ICollection<T>
System.Collections.IList
System.Collections.Generic.IReadOnlyList<T>
System.Collections.Generic.IReadOnlyCollection<T>
System.Collections.Generic.IEnumerable<T>
ISchemaFieldCollection
System.Collections.ICollection
System.Collections.IEnumerable


Class SchemaView | fcSDK Documentation

Class SchemaView

Inheritance
System.Object
DataObject
ClarifyDataObject
SchemaTableBase
SchemaView
Implements
IDataObject
ISchemaView
ISchemaTableBase
Inherited Members
SchemaTableBase.isDataRestricted
SchemaTableBase.restrictedFields
SchemaTableBase.restrictionClauses
SchemaTableBase.LoadData(DataRow)
SchemaTableBase.SetFlags(Int32)
SchemaTableBase.SetName(String)
SchemaTableBase.SetComments(String)
SchemaTableBase.SetIsUnicode(Boolean)
SchemaTableBase.SetObjectGroup(String)
SchemaTableBase.LoadRestrictions(DataRow[], Type)
SchemaTableBase.LoadResSqlClauses(DataRow[])
SchemaTableBase.Flags
SchemaTableBase.Name
SchemaTableBase.Comments
SchemaTableBase.TypeID
SchemaTableBase.ObjectGroup
SchemaTableBase.IsUnicode
SchemaTableBase.IsDataRestricted
SchemaTableBase.RestrictedFields
SchemaTableBase.RestrictionClauses
SchemaTableBase.ISchemaTableBase.ObjectID
SchemaTableBase.ISchemaTableBase.Name
SchemaTableBase.ISchemaTableBase.Number
SchemaTableBase.ISchemaTableBase.Description
SchemaTableBase.ISchemaTableBase.Flags
SchemaTableBase.ISchemaTableBase.Subsystem
SchemaTableBase.ISchemaTableBase.Fields
ClarifyDataObject.GetCommentFieldValue(DataRow)
ClarifyDataObject.CommentFieldName
ClarifyDataObject.ObjectID
DataObject.SetUniqueID(Object)
DataObject.GetFieldValue(String)
DataObject.GetFieldValue(Int32)
DataObject.ContainsColumn(String)
DataObject.GetSafeInt32FieldValue(String)
DataObject.GetSafeInt32FieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeDoubleFieldValue(String)
DataObject.GetSafeDoubleFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeBooleanFieldValue(String)
DataObject.GetSafeBooleanFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeStringFieldValue(String)
DataObject.SetFieldValue(String, Object)
DataObject.GetSafeString(Object)
DataObject.UniqueID
DataObject.FieldValues
DataObject.ColumnMap
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Schema
Assembly: fcSDK.dll
Syntax
public class SchemaView : SchemaTableBase, IDataObject, ISchemaView, ISchemaTableBase

Properties

Fields

Declaration
public SchemaViewFieldCollection Fields { get; }
Property Value
Type | Description
SchemaViewFieldCollection |

IsSqlView

Declaration
public bool IsSqlView { get; }
Property Value
Type | Description
System.Boolean |

Joins

Declaration
public SchemaViewJoinCollection Joins { get; }
Property Value
Type | Description
SchemaViewJoinCollection |

Methods

LoadFields(DataRow)

Declaration
protected override SchemaFieldCollectionBase LoadFields(DataRow row)
Parameters
Type | Name | Description
System.Data.DataRow | row |
Returns
Type | Description
SchemaFieldCollectionBase |
Overrides
SchemaTableBase.LoadFields(DataRow)

Explicit Interface Implementations

ISchemaView.Joins

Declaration
ISchemaViewJoinCollection ISchemaView.Joins { get; }
Returns
Type | Description
ISchemaViewJoinCollection |

Implements

IDataObject
ISchemaView
ISchemaTableBase


Class SchemaViewCollection | fcSDK Documentation

Class SchemaViewCollection

Inheritance
System.Object
System.Collections.Generic.List<SchemaView>
DataObjectCollection<SchemaView>
SchemaViewCollection
Implements
System.Collections.Generic.IList<SchemaView>
System.Collections.Generic.ICollection<SchemaView>
System.Collections.IList
System.Collections.Generic.IReadOnlyList<SchemaView>
System.Collections.Generic.IReadOnlyCollection<SchemaView>
System.Collections.Generic.IEnumerable<SchemaView>
ISchemaViewCollection
System.Collections.ICollection
System.Collections.IEnumerable
Inherited Members
DataObjectCollection<SchemaView>.Initialize(DataTable)
DataObjectCollection<SchemaView>.Initialize(DataRow[])
DataObjectCollection<SchemaView>.Initialize(Object[][])
DataObjectCollection<SchemaView>.AddDataObject(SchemaView)
DataObjectCollection<SchemaView>.OnDataObjectAdded(SchemaView)
DataObjectCollection<SchemaView>.Create(Object[])
DataObjectCollection<SchemaView>.GetItemByIndex(Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.System.Collections.IList.get_Item(System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.System.Collections.IList.set_Item(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.Add(FChoice.Foundation.Clarify.Schema.SchemaView)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.System.Collections.IList.Add(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.AddRange(System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.Schema.SchemaView>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.AsReadOnly()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.BinarySearch(System.Int32, System.Int32, FChoice.Foundation.Clarify.Schema.SchemaView, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.Schema.SchemaView>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.BinarySearch(FChoice.Foundation.Clarify.Schema.SchemaView)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.BinarySearch(FChoice.Foundation.Clarify.Schema.SchemaView, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.Schema.SchemaView>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.Clear()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.Contains(FChoice.Foundation.Clarify.Schema.SchemaView)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.System.Collections.IList.Contains(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.ConvertAll<TOutput>(System.Converter<FChoice.Foundation.Clarify.Schema.SchemaView, TOutput>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.CopyTo(FChoice.Foundation.Clarify.Schema.SchemaView[])
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.System.Collections.ICollection.CopyTo(System.Array, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.CopyTo(System.Int32, FChoice.Foundation.Clarify.Schema.SchemaView[], System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.CopyTo(FChoice.Foundation.Clarify.Schema.SchemaView[], System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.Exists(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaView>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.Find(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaView>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.FindAll(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaView>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.FindIndex(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaView>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.FindIndex(System.Int32, System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaView>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.FindIndex(System.Int32, System.Int32, System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaView>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.FindLast(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaView>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.FindLastIndex(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaView>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.FindLastIndex(System.Int32, System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaView>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.FindLastIndex(System.Int32, System.Int32, System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaView>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.ForEach(System.Action<FChoice.Foundation.Clarify.Schema.SchemaView>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.Schema.SchemaView>.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.System.Collections.IEnumerable.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.GetRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.IndexOf(FChoice.Foundation.Clarify.Schema.SchemaView)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.System.Collections.IList.IndexOf(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.IndexOf(FChoice.Foundation.Clarify.Schema.SchemaView, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.IndexOf(FChoice.Foundation.Clarify.Schema.SchemaView, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.Insert(System.Int32, FChoice.Foundation.Clarify.Schema.SchemaView)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.System.Collections.IList.Insert(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.InsertRange(System.Int32, System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.Schema.SchemaView>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.LastIndexOf(FChoice.Foundation.Clarify.Schema.SchemaView)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.LastIndexOf(FChoice.Foundation.Clarify.Schema.SchemaView, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.LastIndexOf(FChoice.Foundation.Clarify.Schema.SchemaView, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.Remove(FChoice.Foundation.Clarify.Schema.SchemaView)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.System.Collections.IList.Remove(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.RemoveAll(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaView>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.RemoveAt(System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.RemoveRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.Reverse()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.Reverse(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.Sort()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.Sort(System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.Schema.SchemaView>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.Sort(System.Int32, System.Int32, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.Schema.SchemaView>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.Sort(System.Comparison<FChoice.Foundation.Clarify.Schema.SchemaView>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.ToArray()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.TrimExcess()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.TrueForAll(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaView>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.Capacity
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.Count
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.System.Collections.IList.IsFixedSize
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.Schema.SchemaView>.IsReadOnly
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.System.Collections.IList.IsReadOnly
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.System.Collections.ICollection.IsSynchronized
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.System.Collections.ICollection.SyncRoot
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.Item[System.Int32]
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaView>.System.Collections.IList.Item[System.Int32]
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Schema
Assembly: fcSDK.dll
Syntax
public class SchemaViewCollection : DataObjectCollection<SchemaView>, IList<SchemaView>, ICollection<SchemaView>, IList, IReadOnlyList<SchemaView>, IReadOnlyCollection<SchemaView>, IEnumerable<SchemaView>, ISchemaViewCollection, ICollection, IEnumerable

Properties

Item[String]

Declaration
public SchemaView this[string viewName] { get; }
Parameters
Type | Name | Description
System.String | viewName |
Property Value
Type | Description
SchemaView |

Methods

Create(DataRow)

Declaration
protected override SchemaView Create(DataRow row)
Parameters
Type | Name | Description
System.Data.DataRow | row |
Returns
Type | Description
SchemaView |
Overrides
FChoice.Foundation.DataObjects.DataObjectCollection<FChoice.Foundation.Clarify.Schema.SchemaView>.Create(System.Data.DataRow)

GetByNumber(Int32)

Declaration
public SchemaView GetByNumber(int viewID)
Parameters
Type | Name | Description
System.Int32 | viewID |
Returns
Type | Description
SchemaView |

Explicit Interface Implementations

ISchemaViewCollection.get_Item(Int32)

Declaration
ISchemaView ISchemaViewCollection.get_Item(int index)
Parameters
Type | Name | Description
System.Int32 | index |
Returns
Type | Description
ISchemaView |

ISchemaViewCollection.get_Item(String)

Declaration
ISchemaView ISchemaViewCollection.get_Item(string name)
Parameters
Type | Name | Description
System.String | name |
Returns
Type | Description
ISchemaView |

ISchemaViewCollection.GetByNumber(Object)

Declaration
ISchemaView ISchemaViewCollection.GetByNumber(object number)
Parameters
Type | Name | Description
System.Object | number |
Returns
Type | Description
ISchemaView |

ISchemaViewCollection.Item[Int32]

Declaration
ISchemaView ISchemaViewCollection.this[] { get; }
Parameters
Type | Name | Description
System.Int32 | index |
Returns
Type | Description
ISchemaView |

ISchemaViewCollection.Item[String]

Declaration
ISchemaView ISchemaViewCollection.this[] { get; }
Parameters
Type | Name | Description
System.String | name |
Returns
Type | Description
ISchemaView |

Implements

System.Collections.Generic.IList<T>
System.Collections.Generic.ICollection<T>
System.Collections.IList
System.Collections.Generic.IReadOnlyList<T>
System.Collections.Generic.IReadOnlyCollection<T>
System.Collections.Generic.IEnumerable<T>
ISchemaViewCollection
System.Collections.ICollection
System.Collections.IEnumerable


Class SchemaViewField | fcSDK Documentation

Class SchemaViewField

Inheritance
System.Object
DataObject
ClarifyDataObject
SchemaFieldBase
SchemaViewField
Implements
IDataObject
ISchemaField
Inherited Members
SchemaFieldBase.IsString()
SchemaFieldBase.IsNumeric()
SchemaFieldBase.IsInteger()
SchemaFieldBase.IsDate()
SchemaFieldBase.GetFieldDefault(String)
SchemaFieldBase.Parent
SchemaFieldBase.ParentTypeID
SchemaFieldBase.Name
SchemaFieldBase.CommonType
SchemaFieldBase.DatabaseType
SchemaFieldBase.ObjectType
SchemaFieldBase.ArraySize
SchemaFieldBase.DecimalPrecision
SchemaFieldBase.DecimalScale
SchemaFieldBase.Flags
SchemaFieldBase.FCFlags
SchemaFieldBase.GenFieldID
SchemaFieldBase.SpecificFieldID
SchemaFieldBase.FieldDefault
SchemaFieldBase.FieldDefaultString
SchemaFieldBase.IsUnicode
SchemaFieldBase.IsSearchable
SchemaFieldBase.ISchemaField.DataType
SchemaFieldBase.ISchemaField.Rank
SchemaFieldBase.ISchemaField.Length
SchemaFieldBase.ISchemaField.Description
SchemaFieldBase.ISchemaField.Flags
SchemaFieldBase.Default
SchemaFieldBase.DefaultString
ClarifyDataObject.GetCommentFieldValue(DataRow)
ClarifyDataObject.CommentFieldName
ClarifyDataObject.ObjectID
DataObject.SetUniqueID(Object)
DataObject.GetFieldValue(String)
DataObject.GetFieldValue(Int32)
DataObject.ContainsColumn(String)
DataObject.GetSafeInt32FieldValue(String)
DataObject.GetSafeInt32FieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeDoubleFieldValue(String)
DataObject.GetSafeDoubleFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeBooleanFieldValue(String)
DataObject.GetSafeBooleanFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeStringFieldValue(String)
DataObject.SetFieldValue(String, Object)
DataObject.GetSafeString(Object)
DataObject.UniqueID
DataObject.FieldValues
DataObject.ColumnMap
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Schema
Assembly: fcSDK.dll
Syntax
public class SchemaViewField : SchemaFieldBase, IDataObject, ISchemaField

Properties

FieldInfo

Declaration
public SchemaViewFieldInfo FieldInfo { get; }
Property Value
Type | Description
SchemaViewFieldInfo |

View

Declaration
public SchemaView View { get; }
Property Value
Type | Description
SchemaView |

Implements

IDataObject
ISchemaField


Class SchemaViewFieldCollection | fcSDK Documentation

Class SchemaViewFieldCollection

Inheritance
System.Object
System.Collections.Generic.List<SchemaFieldBase>
DataObjectCollection<SchemaFieldBase>
SchemaFieldCollectionBase
SchemaViewFieldCollection
Implements
System.Collections.Generic.IList<SchemaFieldBase>
System.Collections.Generic.ICollection<SchemaFieldBase>
System.Collections.IList
System.Collections.Generic.IReadOnlyList<SchemaFieldBase>
System.Collections.Generic.IReadOnlyCollection<SchemaFieldBase>
System.Collections.Generic.IEnumerable<SchemaFieldBase>
ISchemaFieldCollection
System.Collections.ICollection
System.Collections.IEnumerable
Inherited Members
SchemaFieldCollectionBase.Create(DataRow)
SchemaFieldCollectionBase.GetInternalFieldByID(Int32)
SchemaFieldCollectionBase.ISchemaFieldCollection.get_Item(Int32)
SchemaFieldCollectionBase.ISchemaFieldCollection.get_Item(String)
SchemaFieldCollectionBase.ISchemaFieldCollection.Item[Int32]
SchemaFieldCollectionBase.ISchemaFieldCollection.Item[String]
DataObjectCollection<SchemaFieldBase>.Initialize(DataTable)
DataObjectCollection<SchemaFieldBase>.Initialize(DataRow[])
DataObjectCollection<SchemaFieldBase>.Initialize(Object[][])
DataObjectCollection<SchemaFieldBase>.AddDataObject(SchemaFieldBase)
DataObjectCollection<SchemaFieldBase>.OnDataObjectAdded(SchemaFieldBase)
DataObjectCollection<SchemaFieldBase>.Create(Object[])
DataObjectCollection<SchemaFieldBase>.GetItemByIndex(Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.IList.get_Item(System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.IList.set_Item(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Add(FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.IList.Add(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.AddRange(System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.AsReadOnly()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.BinarySearch(System.Int32, System.Int32, FChoice.Foundation.Clarify.Schema.SchemaFieldBase, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.BinarySearch(FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.BinarySearch(FChoice.Foundation.Clarify.Schema.SchemaFieldBase, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Clear()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Contains(FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.IList.Contains(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.ConvertAll<TOutput>(System.Converter<FChoice.Foundation.Clarify.Schema.SchemaFieldBase, TOutput>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.CopyTo(FChoice.Foundation.Clarify.Schema.SchemaFieldBase[])
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.ICollection.CopyTo(System.Array, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.CopyTo(System.Int32, FChoice.Foundation.Clarify.Schema.SchemaFieldBase[], System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.CopyTo(FChoice.Foundation.Clarify.Schema.SchemaFieldBase[], System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Exists(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Find(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.FindAll(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.FindIndex(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.FindIndex(System.Int32, System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.FindIndex(System.Int32, System.Int32, System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.FindLast(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.FindLastIndex(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.FindLastIndex(System.Int32, System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.FindLastIndex(System.Int32, System.Int32, System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.ForEach(System.Action<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.IEnumerable.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.GetRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.IndexOf(FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.IList.IndexOf(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.IndexOf(FChoice.Foundation.Clarify.Schema.SchemaFieldBase, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.IndexOf(FChoice.Foundation.Clarify.Schema.SchemaFieldBase, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Insert(System.Int32, FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.IList.Insert(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.InsertRange(System.Int32, System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.LastIndexOf(FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.LastIndexOf(FChoice.Foundation.Clarify.Schema.SchemaFieldBase, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.LastIndexOf(FChoice.Foundation.Clarify.Schema.SchemaFieldBase, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Remove(FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.IList.Remove(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.RemoveAll(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.RemoveAt(System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.RemoveRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Reverse()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Reverse(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Sort()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Sort(System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Sort(System.Int32, System.Int32, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Sort(System.Comparison<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.ToArray()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.TrimExcess()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.TrueForAll(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Capacity
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.Count
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.IList.IsFixedSize
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.IsReadOnly
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.IList.IsReadOnly
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.ICollection.IsSynchronized
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.ICollection.SyncRoot
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaFieldBase>.System.Collections.IList.Item[System.Int32]
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Schema
Assembly: fcSDK.dll
Syntax
public class SchemaViewFieldCollection : SchemaFieldCollectionBase, IList<SchemaFieldBase>, ICollection<SchemaFieldBase>, IList, IReadOnlyList<SchemaFieldBase>, IReadOnlyCollection<SchemaFieldBase>, IEnumerable<SchemaFieldBase>, ISchemaFieldCollection, ICollection, IEnumerable

Properties

Item[Int32]

Declaration
public SchemaViewField this[int fieldID] { get; }
Parameters
Type | Name | Description
System.Int32 | fieldID |
Property Value
Type | Description
SchemaViewField |

Item[String]

Declaration
public SchemaViewField this[string fieldName] { get; }
Parameters
Type | Name | Description
System.String | fieldName |
Property Value
Type | Description
SchemaViewField |

Methods

CreateFieldType(DataRow, Object)

Declaration
protected override SchemaFieldBase CreateFieldType(DataRow row, object baseObject)
Parameters
Type | Name | Description
System.Data.DataRow | row |
System.Object | baseObject |
Returns
Type | Description
SchemaFieldBase |
Overrides
SchemaFieldCollectionBase.CreateFieldType(DataRow, Object)

Implements

System.Collections.Generic.IList<T>
System.Collections.Generic.ICollection<T>
System.Collections.IList
System.Collections.Generic.IReadOnlyList<T>
System.Collections.Generic.IReadOnlyCollection<T>
System.Collections.Generic.IEnumerable<T>
ISchemaFieldCollection
System.Collections.ICollection
System.Collections.IEnumerable


Class SchemaViewFieldInfo | fcSDK Documentation

Class SchemaViewFieldInfo

Inheritance
System.Object
DataObject
ClarifyDataObject
SchemaViewFieldInfo
Implements
IDataObject
Inherited Members
ClarifyDataObject.GetCommentFieldValue(DataRow)
ClarifyDataObject.CommentFieldName
ClarifyDataObject.ObjectID
DataObject.SetUniqueID(Object)
DataObject.GetFieldValue(String)
DataObject.GetFieldValue(Int32)
DataObject.ContainsColumn(String)
DataObject.GetSafeInt32FieldValue(String)
DataObject.GetSafeInt32FieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeDoubleFieldValue(String)
DataObject.GetSafeDoubleFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeBooleanFieldValue(String)
DataObject.GetSafeBooleanFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeStringFieldValue(String)
DataObject.SetFieldValue(String, Object)
DataObject.GetSafeString(Object)
DataObject.UniqueID
DataObject.FieldValues
DataObject.ColumnMap
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Schema
Assembly: fcSDK.dll
Syntax
public class SchemaViewFieldInfo : ClarifyDataObject, IDataObject

Properties

Alias

Declaration
public string Alias { get; }
Property Value
Type | Description
System.String |

Comments

Declaration
public string Comments { get; }
Property Value
Type | Description
System.String |

Flags

Declaration
public int Flags { get; }
Property Value
Type | Description
System.Int32 |

TableField

Declaration
public SchemaTableField TableField { get; }
Property Value
Type | Description
SchemaTableField |

TableFieldID

Declaration
public int TableFieldID { get; }
Property Value
Type | Description
System.Int32 |

TableTypeID

Declaration
public int TableTypeID { get; }
Property Value
Type | Description
System.Int32 |

ViewField

Declaration
public SchemaViewField ViewField { get; }
Property Value
Type | Description
SchemaViewField |

ViewID

Declaration
public int ViewID { get; }
Property Value
Type | Description
System.Int32 |

Implements

IDataObject


Class SchemaViewFieldInfoCollection | fcSDK Documentation

Class SchemaViewFieldInfoCollection

Inheritance
System.Object
System.Collections.Generic.List<SchemaViewFieldInfo>
DataObjectCollection<SchemaViewFieldInfo>
SchemaViewFieldInfoCollection
Implements
System.Collections.Generic.IList<SchemaViewFieldInfo>
System.Collections.Generic.ICollection<SchemaViewFieldInfo>
System.Collections.IList
System.Collections.ICollection
System.Collections.Generic.IReadOnlyList<SchemaViewFieldInfo>
System.Collections.Generic.IReadOnlyCollection<SchemaViewFieldInfo>
System.Collections.Generic.IEnumerable<SchemaViewFieldInfo>
System.Collections.IEnumerable
Inherited Members
DataObjectCollection<SchemaViewFieldInfo>.Initialize(DataTable)
DataObjectCollection<SchemaViewFieldInfo>.Initialize(DataRow[])
DataObjectCollection<SchemaViewFieldInfo>.Initialize(Object[][])
DataObjectCollection<SchemaViewFieldInfo>.AddDataObject(SchemaViewFieldInfo)
DataObjectCollection<SchemaViewFieldInfo>.OnDataObjectAdded(SchemaViewFieldInfo)
DataObjectCollection<SchemaViewFieldInfo>.Create(Object[])
DataObjectCollection<SchemaViewFieldInfo>.GetItemByIndex(Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.System.Collections.IList.get_Item(System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.System.Collections.IList.set_Item(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.Add(FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.System.Collections.IList.Add(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.AddRange(System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.AsReadOnly()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.BinarySearch(System.Int32, System.Int32, FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.BinarySearch(FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.BinarySearch(FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.Clear()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.Contains(FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.System.Collections.IList.Contains(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.ConvertAll<TOutput>(System.Converter<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo, TOutput>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.CopyTo(FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo[])
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.System.Collections.ICollection.CopyTo(System.Array, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.CopyTo(System.Int32, FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo[], System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.CopyTo(FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo[], System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.Exists(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.Find(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.FindAll(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.FindIndex(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.FindIndex(System.Int32, System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.FindIndex(System.Int32, System.Int32, System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.FindLast(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.FindLastIndex(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.FindLastIndex(System.Int32, System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.FindLastIndex(System.Int32, System.Int32, System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.ForEach(System.Action<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.System.Collections.IEnumerable.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.GetRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.IndexOf(FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.System.Collections.IList.IndexOf(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.IndexOf(FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.IndexOf(FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.Insert(System.Int32, FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.System.Collections.IList.Insert(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.InsertRange(System.Int32, System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.LastIndexOf(FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.LastIndexOf(FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.LastIndexOf(FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.Remove(FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.System.Collections.IList.Remove(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.RemoveAll(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.RemoveAt(System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.RemoveRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.Reverse()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.Reverse(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.Sort()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.Sort(System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.Sort(System.Int32, System.Int32, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.Sort(System.Comparison<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.ToArray()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.TrimExcess()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.TrueForAll(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.Capacity
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.Count
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.System.Collections.IList.IsFixedSize
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.IsReadOnly
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.System.Collections.IList.IsReadOnly
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.System.Collections.ICollection.IsSynchronized
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.System.Collections.ICollection.SyncRoot
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.Item[System.Int32]
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.System.Collections.IList.Item[System.Int32]
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Schema
Assembly: fcSDK.dll
Syntax
public class SchemaViewFieldInfoCollection : DataObjectCollection<SchemaViewFieldInfo>, IList<SchemaViewFieldInfo>, ICollection<SchemaViewFieldInfo>, IList, ICollection, IReadOnlyList<SchemaViewFieldInfo>, IReadOnlyCollection<SchemaViewFieldInfo>, IEnumerable<SchemaViewFieldInfo>, IEnumerable

Methods

Create(DataRow)

Declaration
protected override SchemaViewFieldInfo Create(DataRow row)
Parameters
Type | Name | Description
System.Data.DataRow | row |
Returns
Type | Description
SchemaViewFieldInfo |
Overrides
FChoice.Foundation.DataObjects.DataObjectCollection<FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo>.Create(System.Data.DataRow)

CreateViewFieldInfoKey(Int32, Int32)

Declaration
public static string CreateViewFieldInfoKey(int viewID, int fieldID)
Parameters
Type | Name | Description
System.Int32 | viewID |
System.Int32 | fieldID |
Returns
Type | Description
System.String |

GetViewFieldInfoByID(Int32, Int32)

Declaration
public SchemaViewFieldInfo GetViewFieldInfoByID(int viewID, int fieldID)
Parameters
Type | Name | Description
System.Int32 | viewID |
System.Int32 | fieldID |
Returns
Type | Description
SchemaViewFieldInfo |

Implements

System.Collections.Generic.IList<T>
System.Collections.Generic.ICollection<T>
System.Collections.IList
System.Collections.ICollection
System.Collections.Generic.IReadOnlyList<T>
System.Collections.Generic.IReadOnlyCollection<T>
System.Collections.Generic.IEnumerable<T>
System.Collections.IEnumerable


Class SchemaViewJoin | fcSDK Documentation

Class SchemaViewJoin

Inheritance
System.Object
DataObject
ClarifyDataObject
SchemaViewJoin
Implements
IDataObject
ISchemaViewJoin
Inherited Members
ClarifyDataObject.GetCommentFieldValue(DataRow)
ClarifyDataObject.CommentFieldName
ClarifyDataObject.ObjectID
DataObject.SetUniqueID(Object)
DataObject.GetFieldValue(String)
DataObject.GetFieldValue(Int32)
DataObject.ContainsColumn(String)
DataObject.GetSafeInt32FieldValue(String)
DataObject.GetSafeInt32FieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeDoubleFieldValue(String)
DataObject.GetSafeDoubleFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeBooleanFieldValue(String)
DataObject.GetSafeBooleanFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeStringFieldValue(String)
DataObject.SetFieldValue(String, Object)
DataObject.GetSafeString(Object)
DataObject.UniqueID
DataObject.FieldValues
DataObject.ColumnMap
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Schema
Assembly: fcSDK.dll
Syntax
public class SchemaViewJoin : ClarifyDataObject, IDataObject, ISchemaViewJoin

Properties

BaseRelation

Declaration
public SchemaRelation BaseRelation { get; }
Property Value
Type | Description
SchemaRelation |

Comments

Declaration
public string Comments { get; }
Property Value
Type | Description
System.String |

Flags

Declaration
public int Flags { get; }
Property Value
Type | Description
System.Int32 |

JoinFlag

Declaration
public int JoinFlag { get; }
Property Value
Type | Description
System.Int32 |

PrimaryAlias

Declaration
public string PrimaryAlias { get; }
Property Value
Type | Description
System.String |

SecondaryAlias

Declaration
public string SecondaryAlias { get; }
Property Value
Type | Description
System.String |

SpecificRelationID

Declaration
public int SpecificRelationID { get; }
Property Value
Type | Description
System.Int32 |

TableID

Declaration
public int TableID { get; }
Property Value
Type | Description
System.Int32 |

Explicit Interface Implementations

ISchemaViewJoin.Description

Declaration
string ISchemaViewJoin.Description { get; }
Returns
Type | Description
System.String |

ISchemaViewJoin.Flags

Declaration
object ISchemaViewJoin.Flags { get; }
Returns
Type | Description
System.Object |

ISchemaViewJoin.IsPrimaryOuter

Declaration
bool ISchemaViewJoin.IsPrimaryOuter { get; }
Returns
Type | Description
System.Boolean |

ISchemaViewJoin.IsSecondaryOuter

Declaration
bool ISchemaViewJoin.IsSecondaryOuter { get; }
Returns
Type | Description
System.Boolean |

ISchemaViewJoin.PrimaryAlias

Declaration
string ISchemaViewJoin.PrimaryAlias { get; }
Returns
Type | Description
System.String |

ISchemaViewJoin.PrimaryTable

Declaration
ISchemaTable ISchemaViewJoin.PrimaryTable { get; }
Returns
Type | Description
ISchemaTable |

ISchemaViewJoin.SecondaryAlias

Declaration
string ISchemaViewJoin.SecondaryAlias { get; }
Returns
Type | Description
System.String |

ISchemaViewJoin.SecondaryTable

Declaration
ISchemaTable ISchemaViewJoin.SecondaryTable { get; }
Returns
Type | Description
ISchemaTable |

Implements

IDataObject
ISchemaViewJoin


Class SchemaViewJoinCollection | fcSDK Documentation

Class SchemaViewJoinCollection

Inheritance
System.Object
System.Collections.Generic.List<SchemaViewJoin>
DataObjectCollection<SchemaViewJoin>
SchemaViewJoinCollection
Implements
System.Collections.Generic.IList<SchemaViewJoin>
System.Collections.Generic.ICollection<SchemaViewJoin>
System.Collections.IList
System.Collections.Generic.IReadOnlyList<SchemaViewJoin>
System.Collections.Generic.IReadOnlyCollection<SchemaViewJoin>
System.Collections.Generic.IEnumerable<SchemaViewJoin>
ISchemaViewJoinCollection
System.Collections.ICollection
System.Collections.IEnumerable
Inherited Members
DataObjectCollection<SchemaViewJoin>.Initialize(DataTable)
DataObjectCollection<SchemaViewJoin>.Initialize(DataRow[])
DataObjectCollection<SchemaViewJoin>.Initialize(Object[][])
DataObjectCollection<SchemaViewJoin>.AddDataObject(SchemaViewJoin)
DataObjectCollection<SchemaViewJoin>.OnDataObjectAdded(SchemaViewJoin)
DataObjectCollection<SchemaViewJoin>.Create(Object[])
DataObjectCollection<SchemaViewJoin>.GetItemByIndex(Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.System.Collections.IList.get_Item(System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.System.Collections.IList.set_Item(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.Add(FChoice.Foundation.Clarify.Schema.SchemaViewJoin)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.System.Collections.IList.Add(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.AddRange(System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.AsReadOnly()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.BinarySearch(System.Int32, System.Int32, FChoice.Foundation.Clarify.Schema.SchemaViewJoin, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.BinarySearch(FChoice.Foundation.Clarify.Schema.SchemaViewJoin)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.BinarySearch(FChoice.Foundation.Clarify.Schema.SchemaViewJoin, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.Clear()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.Contains(FChoice.Foundation.Clarify.Schema.SchemaViewJoin)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.System.Collections.IList.Contains(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.ConvertAll<TOutput>(System.Converter<FChoice.Foundation.Clarify.Schema.SchemaViewJoin, TOutput>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.CopyTo(FChoice.Foundation.Clarify.Schema.SchemaViewJoin[])
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.System.Collections.ICollection.CopyTo(System.Array, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.CopyTo(System.Int32, FChoice.Foundation.Clarify.Schema.SchemaViewJoin[], System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.CopyTo(FChoice.Foundation.Clarify.Schema.SchemaViewJoin[], System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.Exists(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.Find(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.FindAll(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.FindIndex(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.FindIndex(System.Int32, System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.FindIndex(System.Int32, System.Int32, System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.FindLast(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.FindLastIndex(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.FindLastIndex(System.Int32, System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.FindLastIndex(System.Int32, System.Int32, System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.ForEach(System.Action<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.System.Collections.IEnumerable.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.GetRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.IndexOf(FChoice.Foundation.Clarify.Schema.SchemaViewJoin)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.System.Collections.IList.IndexOf(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.IndexOf(FChoice.Foundation.Clarify.Schema.SchemaViewJoin, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.IndexOf(FChoice.Foundation.Clarify.Schema.SchemaViewJoin, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.Insert(System.Int32, FChoice.Foundation.Clarify.Schema.SchemaViewJoin)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.System.Collections.IList.Insert(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.InsertRange(System.Int32, System.Collections.Generic.IEnumerable<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.LastIndexOf(FChoice.Foundation.Clarify.Schema.SchemaViewJoin)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.LastIndexOf(FChoice.Foundation.Clarify.Schema.SchemaViewJoin, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.LastIndexOf(FChoice.Foundation.Clarify.Schema.SchemaViewJoin, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.Remove(FChoice.Foundation.Clarify.Schema.SchemaViewJoin)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.System.Collections.IList.Remove(System.Object)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.RemoveAll(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.RemoveAt(System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.RemoveRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.Reverse()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.Reverse(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.Sort()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.Sort(System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.Sort(System.Int32, System.Int32, System.Collections.Generic.IComparer<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.Sort(System.Comparison<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.ToArray()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.TrimExcess()
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.TrueForAll(System.Predicate<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>)
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.Capacity
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.Count
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.System.Collections.IList.IsFixedSize
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.System.Collections.Generic.ICollection<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.IsReadOnly
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.System.Collections.IList.IsReadOnly
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.System.Collections.ICollection.IsSynchronized
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.System.Collections.ICollection.SyncRoot
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.Item[System.Int32]
System.Collections.Generic.List<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.System.Collections.IList.Item[System.Int32]
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Schema
Assembly: fcSDK.dll
Syntax
public class SchemaViewJoinCollection : DataObjectCollection<SchemaViewJoin>, IList<SchemaViewJoin>, ICollection<SchemaViewJoin>, IList, IReadOnlyList<SchemaViewJoin>, IReadOnlyCollection<SchemaViewJoin>, IEnumerable<SchemaViewJoin>, ISchemaViewJoinCollection, ICollection, IEnumerable

Methods

Create(DataRow)

Declaration
protected override SchemaViewJoin Create(DataRow row)
Parameters
Type | Name | Description
System.Data.DataRow | row |
Returns
Type | Description
SchemaViewJoin |
Overrides
FChoice.Foundation.DataObjects.DataObjectCollection<FChoice.Foundation.Clarify.Schema.SchemaViewJoin>.Create(System.Data.DataRow)

Implements

System.Collections.Generic.IList<T>
System.Collections.Generic.ICollection<T>
System.Collections.IList
System.Collections.Generic.IReadOnlyList<T>
System.Collections.Generic.IReadOnlyCollection<T>
System.Collections.Generic.IEnumerable<T>
ISchemaViewJoinCollection
System.Collections.ICollection
System.Collections.IEnumerable


Class SchemaCache | fcSDK Documentation

Class SchemaCache

Inheritance
System.Object
CacheBase
ClarifyCacheBase
SchemaCache
Implements
ISchemaCache
Inherited Members
CacheBase.UpdateSyncRoot
CacheBase.OnCacheUpdated()
CacheBase.OnAnyCacheUpdated(CacheBase)
CacheBase.ReadCacheData(String)
CacheBase.PersistCacheData(Object, String)
CacheBase.GetCacheDataHash()
CacheBase.GenerateMD5Hash(String)
CacheBase.AllTablesExistInDataSet(DataSet, String[])
CacheBase.GetCacheFilePath(String)
CacheBase.AnyCacheUpdated
CacheBase.CacheUpdated
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify
Assembly: fcSDK.dll
Syntax
public class SchemaCache : ClarifyCacheBase, ISchemaCache

Constructors

SchemaCache(Boolean)

Declaration
public SchemaCache(bool isSolo)
Parameters
Type | Name | Description
System.Boolean | isSolo |

Fields

Amdocs65

Declaration
public const int Amdocs65 = 62
Field Value
Type | Description
System.Int32 |

Amdocs75

Declaration
public const int Amdocs75 = 6600
Field Value
Type | Description
System.Int32 |

CLARIFY_10

Declaration
public const int CLARIFY_10 = 55
Field Value
Type | Description
System.Int32 |

CLARIFY_11

Declaration
public const int CLARIFY_11 = 56
Field Value
Type | Description
System.Int32 |

CLARIFY_115

Declaration
public const int CLARIFY_115 = 58
Field Value
Type | Description
System.Int32 |

CLARIFY_12

Declaration
public const int CLARIFY_12 = 59
Field Value
Type | Description
System.Int32 |

CLARIFY_125

Declaration
public const int CLARIFY_125 = 60
Field Value
Type | Description
System.Int32 |

CLARIFY_13

Declaration
public const int CLARIFY_13 = 61
Field Value
Type | Description
System.Int32 |

CLARIFY_4

Declaration
public const int CLARIFY_4 = 42
Field Value
Type | Description
System.Int32 |

CLARIFY_45

Declaration
public const int CLARIFY_45 = 43
Field Value
Type | Description
System.Int32 |

CLARIFY_5

Declaration
public const int CLARIFY_5 = 44
Field Value
Type | Description
System.Int32 |

CLARIFY_6

Declaration
public const int CLARIFY_6 = 45
Field Value
Type | Description
System.Int32 |

CLARIFY_6X

Declaration
public const int CLARIFY_6X = 46
Field Value
Type | Description
System.Int32 |

CLARIFY_7

Declaration
public const int CLARIFY_7 = 51
Field Value
Type | Description
System.Int32 |

CLARIFY_8

Declaration
public const int CLARIFY_8 = 52
Field Value
Type | Description
System.Int32 |

CLARIFY_9

Declaration
public const int CLARIFY_9 = 54
Field Value
Type | Description
System.Int32 |

CLARIFY_CFO98

Declaration
public const int CLARIFY_CFO98 = 48
Field Value
Type | Description
System.Int32 |

Properties

CacheSetName

Declaration
public override string CacheSetName { get; }
Property Value
Type | Description
System.String |
Overrides
CacheBase.CacheSetName

CacheType

Declaration
public override CacheType CacheType { get; }
Property Value
Type | Description
CacheType |
Overrides
CacheBase.CacheType

CustomSchemaDate

Declaration
public DateTime CustomSchemaDate { get; }
Property Value
Type | Description
System.DateTime |

DatabaseName

Declaration
public string DatabaseName { get; }
Property Value
Type | Description
System.String |

DataRestrictionsEnabled

Declaration
public bool DataRestrictionsEnabled { get; }
Property Value
Type | Description
System.Boolean |

Flags

Declaration
public int Flags { get; }
Property Value
Type | Description
System.Int32 |

IsDatabaseUnicode

Declaration
public bool IsDatabaseUnicode { get; }
Property Value
Type | Description
System.Boolean |

LastModifiedDate

Declaration
public DateTime LastModifiedDate { get; }
Property Value
Type | Description
System.DateTime |

RestrictionGroups

Declaration
public RestrictionGroupCollection RestrictionGroups { get; }
Property Value
Type | Description
RestrictionGroupCollection |

SchemaRevision

Declaration
public string SchemaRevision { get; }
Property Value
Type | Description
System.String |

SiteID

Declaration
public string SiteID { get; }
Property Value
Type | Description
System.String |

Tables

Declaration
public SchemaTableCollection Tables { get; }
Property Value
Type | Description
SchemaTableCollection |

VendorSchemaDate

Declaration
public DateTime VendorSchemaDate { get; }
Property Value
Type | Description
System.DateTime |

Views

Declaration
public SchemaViewCollection Views { get; }
Property Value
Type | Description
SchemaViewCollection |

Methods

GetChangeDateField(String)

Declaration
public SchemaTableField GetChangeDateField(string tableName)
Parameters
Type | Name | Description
System.String | tableName |
Returns
Type | Description
SchemaTableField |

GetDateFields(String)

Declaration
public SchemaFieldBase[] GetDateFields(string objectName)
Parameters
Type | Name | Description
System.String | objectName |
Returns
Type | Description
SchemaFieldBase[] |

GetField(String, String)

Declaration
public SchemaFieldBase GetField(string objectName, string fieldName)
Parameters
Type | Name | Description
System.String | objectName |
System.String | fieldName |
Returns
Type | Description
SchemaFieldBase |

GetRelation(String, String)

Declaration
public SchemaRelation GetRelation(string tableName, string relationName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | relationName |
Returns
Type | Description
SchemaRelation |

GetTableField(String, String)

Declaration
public SchemaTableField GetTableField(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
SchemaTableField |

GetTableID(String)

Declaration
public int GetTableID(string tableName)
Parameters
Type | Name | Description
System.String | tableName |
Returns
Type | Description
System.Int32 |

GetTableName(Int32)

Declaration
public string GetTableName(int tableID)
Parameters
Type | Name | Description
System.Int32 | tableID |
Returns
Type | Description
System.String |

GetTableOrView(String)

Declaration
public SchemaTableBase GetTableOrView(string tableName)
Parameters
Type | Name | Description
System.String | tableName |
Returns
Type | Description
SchemaTableBase |

GetTableOrViewByID(Int32)

Declaration
public SchemaTableBase GetTableOrViewByID(int typeID)
Parameters
Type | Name | Description
System.Int32 | typeID |
Returns
Type | Description
SchemaTableBase |

GetTableOrViewID(String)

Declaration
public int GetTableOrViewID(string objectName)
Parameters
Type | Name | Description
System.String | objectName |
Returns
Type | Description
System.Int32 |

GetTypeForSchemaType(SchemaFieldBase)

Declaration
public Type GetTypeForSchemaType(SchemaFieldBase field)
Parameters
Type | Name | Description
SchemaFieldBase | field |
Returns
Type | Description
System.Type |

GetTypeForSchemaType(SchemaFieldBase, DbProvider)

Declaration
public Type GetTypeForSchemaType(SchemaFieldBase field, DbProvider provider)
Parameters
Type | Name | Description
SchemaFieldBase | field |
DbProvider | provider |
Returns
Type | Description
System.Type |

GetViewField(String, String)

Declaration
public SchemaViewField GetViewField(string viewName, string fieldName)
Parameters
Type | Name | Description
System.String | viewName |
System.String | fieldName |
Returns
Type | Description
SchemaViewField |

GetViewID(String)

Declaration
public int GetViewID(string viewName)
Parameters
Type | Name | Description
System.String | viewName |
Returns
Type | Description
System.Int32 |

InitCacheData()

Declaration
protected override object InitCacheData()
Returns
Type | Description
System.Object |
Overrides
CacheBase.InitCacheData()

IsCacheOutOfDate(DateTime)

Declaration
protected override bool IsCacheOutOfDate(DateTime testDate)
Parameters
Type | Name | Description
System.DateTime | testDate |
Returns
Type | Description
System.Boolean |
Overrides
ClarifyCacheBase.IsCacheOutOfDate(DateTime)

IsChangeField(String, String)

Declaration
public bool IsChangeField(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

IsDateField(String, String)

Declaration
public bool IsDateField(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

IsFieldSearchable(String, String)

Declaration
public bool IsFieldSearchable(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

IsFieldUnicode(String, String)

Declaration
public bool IsFieldUnicode(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

IsIntegerField(String, String)

Declaration
public bool IsIntegerField(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

IsNumericField(String, String)

Declaration
public bool IsNumericField(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

IsRelationExclusive(String, String, out SchemaTableField, out SchemaTableField)

Declaration
public bool IsRelationExclusive(string tableName, string relationName, out SchemaTableField objIDField, out SchemaTableField tableField)
Parameters
Type | Name | Description
System.String | tableName |
System.String | relationName |
SchemaTableField | objIDField |
SchemaTableField | tableField |
Returns
Type | Description
System.Boolean |

IsRelationMandatory(String, String)

Declaration
public bool IsRelationMandatory(string tableName, string relationName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | relationName |
Returns
Type | Description
System.Boolean |

IsStringField(String, String)

Declaration
public bool IsStringField(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

IsStringOrDateField(String, String)

Declaration
public bool IsStringOrDateField(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

IsValidField(String, String)

Declaration
public bool IsValidField(string objectName, string fieldName)
Parameters
Type | Name | Description
System.String | objectName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

IsValidField(String, String, out Boolean)

Declaration
public bool IsValidField(string objectName, string fieldName, out bool isRelation)
Parameters
Type | Name | Description
System.String | objectName |
System.String | fieldName |
System.Boolean | isRelation |
Returns
Type | Description
System.Boolean |

IsValidRelation(String, String)

Declaration
public bool IsValidRelation(string tableName, string relName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | relName |
Returns
Type | Description
System.Boolean |

IsValidTable(String)

Declaration
public bool IsValidTable(string tableName)
Parameters
Type | Name | Description
System.String | tableName |
Returns
Type | Description
System.Boolean |

IsValidTableOrView(Int32)

Declaration
public bool IsValidTableOrView(int typeID)
Parameters
Type | Name | Description
System.Int32 | typeID |
Returns
Type | Description
System.Boolean |

IsValidTableOrView(String)

Declaration
public bool IsValidTableOrView(string objectName)
Parameters
Type | Name | Description
System.String | objectName |
Returns
Type | Description
System.Boolean |

IsValidView(String)

Declaration
public bool IsValidView(string viewName)
Parameters
Type | Name | Description
System.String | viewName |
Returns
Type | Description
System.Boolean |

LoadCacheData(Object)

Declaration
protected override void LoadCacheData(object cacheData)
Parameters
Type | Name | Description
System.Object | cacheData |
Overrides
CacheBase.LoadCacheData(Object)

SetNameAndParameters(String, String)

Declaration
protected override void SetNameAndParameters(string name, string parameters)
Parameters
Type | Name | Description
System.String | name |
System.String | parameters |
Overrides
CacheBase.SetNameAndParameters(String, String)

TryGetField(String, String)

Declaration
public SchemaFieldBase TryGetField(string objectName, string fieldName)
Parameters
Type | Name | Description
System.String | objectName |
System.String | fieldName |
Returns
Type | Description
SchemaFieldBase |

TryIsFieldSearchable(String, String)

Declaration
public bool TryIsFieldSearchable(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

TryIsStringField(String, String)

Declaration
public bool TryIsStringField(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

UpdateCache()

Declaration
public override void UpdateCache()
Overrides
CacheBase.UpdateCache()

Events

SchemaLoadStatusChanged

Declaration
public event SchemaLoadStatusEventHandler SchemaLoadStatusChanged
Event Type
Type | Description
SchemaLoadStatusEventHandler |

Explicit Interface Implementations

ISchemaCache.GetChangeDateField(String)

Declaration
ISchemaField ISchemaCache.GetChangeDateField(string tableName)
Parameters
Type | Name | Description
System.String | tableName |
Returns
Type | Description
ISchemaField |

ISchemaCache.GetDateFields(String)

Declaration
IEnumerable ISchemaCache.GetDateFields(string tableName)
Parameters
Type | Name | Description
System.String | tableName |
Returns
Type | Description
System.Collections.IEnumerable |

ISchemaCache.GetField(String, String)

Declaration
ISchemaField ISchemaCache.GetField(string objectName, string fieldName)
Parameters
Type | Name | Description
System.String | objectName |
System.String | fieldName |
Returns
Type | Description
ISchemaField |

ISchemaCache.GetRelation(String, String)

Declaration
ISchemaRelation ISchemaCache.GetRelation(string tableName, string relationName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | relationName |
Returns
Type | Description
ISchemaRelation |

ISchemaCache.GetTableName(Int32)

Declaration
string ISchemaCache.GetTableName(int tableNum)
Parameters
Type | Name | Description
System.Int32 | tableNum |
Returns
Type | Description
System.String |

ISchemaCache.GetTableNumber(String)

Declaration
int ISchemaCache.GetTableNumber(string tableName)
Parameters
Type | Name | Description
System.String | tableName |
Returns
Type | Description
System.Int32 |

ISchemaCache.IsChangeField(String, String)

Declaration
bool ISchemaCache.IsChangeField(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

ISchemaCache.IsDateField(String, String)

Declaration
bool ISchemaCache.IsDateField(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

ISchemaCache.IsFieldSearchable(String, String)

Declaration
bool ISchemaCache.IsFieldSearchable(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

ISchemaCache.IsFieldUnicode(String, String)

Declaration
bool ISchemaCache.IsFieldUnicode(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

ISchemaCache.IsIntegerField(String, String)

Declaration
bool ISchemaCache.IsIntegerField(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

ISchemaCache.IsNumericField(String, String)

Declaration
bool ISchemaCache.IsNumericField(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

ISchemaCache.IsRelationExclusive(String, String)

Declaration
bool ISchemaCache.IsRelationExclusive(string tableName, string relationName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | relationName |
Returns
Type | Description
System.Boolean |

ISchemaCache.IsStringField(String, String)

Declaration
bool ISchemaCache.IsStringField(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

ISchemaCache.IsStringOrDateField(String, String)

Declaration
bool ISchemaCache.IsStringOrDateField(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

ISchemaCache.IsValidField(String, String)

Declaration
bool ISchemaCache.IsValidField(string objectName, string fieldName)
Parameters
Type | Name | Description
System.String | objectName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

ISchemaCache.IsValidTable(String)

Declaration
bool ISchemaCache.IsValidTable(string tableName)
Parameters
Type | Name | Description
System.String | tableName |
Returns
Type | Description
System.Boolean |

ISchemaCache.IsValidTableOrView(String)

Declaration
bool ISchemaCache.IsValidTableOrView(string objectName)
Parameters
Type | Name | Description
System.String | objectName |
Returns
Type | Description
System.Boolean |

ISchemaCache.IsValidView(String)

Declaration
bool ISchemaCache.IsValidView(string viewName)
Parameters
Type | Name | Description
System.String | viewName |
Returns
Type | Description
System.Boolean |

ISchemaCache.Tables

Declaration
ISchemaTableCollection ISchemaCache.Tables { get; }
Returns
Type | Description
ISchemaTableCollection |

ISchemaCache.Views

Declaration
ISchemaViewCollection ISchemaCache.Views { get; }
Returns
Type | Description
ISchemaViewCollection |

Implements

ISchemaCache


Class SchemaCacheHelper | fcSDK Documentation

Class SchemaCacheHelper

Inheritance
System.Object
SchemaCacheHelper
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify
Assembly: fcSDK.dll
Syntax
public static class SchemaCacheHelper

Methods

DoesColumnExist(String, String)

Declaration
public static bool DoesColumnExist(string tableName, string columnName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | columnName |
Returns
Type | Description
System.Boolean |

DoesMsSqlColumnExist(String, String)

Declaration
public static bool DoesMsSqlColumnExist(string tableName, string columnName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | columnName |
Returns
Type | Description
System.Boolean |

DoesOracleColumnExist(String, String)

Declaration
public static bool DoesOracleColumnExist(string tableName, string columnName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | columnName |
Returns
Type | Description
System.Boolean |


Delegate SchemaLoadStatusEventHandler | fcSDK Documentation

Delegate SchemaLoadStatusEventHandler

Namespace: FChoice.Foundation.Clarify
Assembly: fcSDK.dll
Syntax
public delegate void SchemaLoadStatusEventHandler(object sender, SchemaLoadStatusType newStatus);
Parameters
Type | Name | Description
System.Object | sender |
SchemaLoadStatusType | newStatus |

Constructors

SchemaLoadStatusEventHandler(Object, IntPtr)

Declaration
public SchemaLoadStatusEventHandler(object object, IntPtr method)
Parameters
Type | Name | Description
System.Object | object |
System.IntPtr | method |

Methods

BeginInvoke(Object, SchemaLoadStatusType, AsyncCallback, Object)

Declaration
public virtual IAsyncResult BeginInvoke(object sender, SchemaLoadStatusType newStatus, AsyncCallback callback, object object)
Parameters
Type | Name | Description
System.Object | sender |
SchemaLoadStatusType | newStatus |
System.AsyncCallback | callback |
System.Object | object |
Returns
Type | Description
System.IAsyncResult |

EndInvoke(IAsyncResult)

Declaration
public virtual void EndInvoke(IAsyncResult result)
Parameters
Type | Name | Description
System.IAsyncResult | result |

Invoke(Object, SchemaLoadStatusType)

Declaration
public virtual void Invoke(object sender, SchemaLoadStatusType newStatus)
Parameters
Type | Name | Description
System.Object | sender |
SchemaLoadStatusType | newStatus |


Enum SchemaLoadStatusType | fcSDK Documentation

Enum SchemaLoadStatusType

Namespace: FChoice.Foundation.Clarify
Assembly: fcSDK.dll
Syntax
public enum SchemaLoadStatusType

Fields

Name | Description
Completed |
QueryExecuted |
RestrictionsLoaded |
Starting |
TablesLoaded |
ViewsLoaded |


Class StringCache | fcSDK Documentation

Class StringCache

Inheritance
System.Object
CacheBase
ClarifyCacheBase
StringCache
Implements
IStringCache
Inherited Members
ClarifyCacheBase.IsCacheOutOfDate(DateTime)
CacheBase.UpdateSyncRoot
CacheBase.OnCacheUpdated()
CacheBase.OnAnyCacheUpdated(CacheBase)
CacheBase.UpdateCache()
CacheBase.ReadCacheData(String)
CacheBase.PersistCacheData(Object, String)
CacheBase.GetCacheDataHash()
CacheBase.GenerateMD5Hash(String)
CacheBase.AllTablesExistInDataSet(DataSet, String[])
CacheBase.GetCacheFilePath(String)
CacheBase.AnyCacheUpdated
CacheBase.CacheUpdated
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify
Assembly: fcSDK.dll
Syntax
public class StringCache : ClarifyCacheBase, IStringCache

Constructors

StringCache()

Declaration
protected StringCache()

Properties

CacheSetName

Declaration
public override string CacheSetName { get; }
Property Value
Type | Description
System.String |
Overrides
CacheBase.CacheSetName

CacheType

Declaration
public override CacheType CacheType { get; }
Property Value
Type | Description
CacheType |
Overrides
CacheBase.CacheType

Methods

FindFCString(Int32)

Declaration
public string FindFCString(int stringID)
Parameters
Type | Name | Description
System.Int32 | stringID |
Returns
Type | Description
System.String |

FindFCString(Int32, CultureInfo)

Declaration
public string FindFCString(int stringID, CultureInfo culture)
Parameters
Type | Name | Description
System.Int32 | stringID |
System.Globalization.CultureInfo | culture |
Returns
Type | Description
System.String |

FindFCString(String, String)

Declaration
public string FindFCString(string applicationName, string stringName)
Parameters
Type | Name | Description
System.String | applicationName |
System.String | stringName |
Returns
Type | Description
System.String |

FindFCString(String, String, CultureInfo)

Declaration
public string FindFCString(string applicationName, string stringName, CultureInfo culture)
Parameters
Type | Name | Description
System.String | applicationName |
System.String | stringName |
System.Globalization.CultureInfo | culture |
Returns
Type | Description
System.String |

FindFCStringObject(Int32, CultureInfo)

Declaration
public FCString FindFCStringObject(int stringID, CultureInfo culture)
Parameters
Type | Name | Description
System.Int32 | stringID |
System.Globalization.CultureInfo | culture |
Returns
Type | Description
FCString |

FindFCStringObject(String, String, CultureInfo)

Declaration
public FCString FindFCStringObject(string applicationName, string stringName, CultureInfo culture)
Parameters
Type | Name | Description
System.String | applicationName |
System.String | stringName |
System.Globalization.CultureInfo | culture |
Returns
Type | Description
FCString |

FindString(Int32)

Declaration
public string FindString(int stringID)
Parameters
Type | Name | Description
System.Int32 | stringID |
Returns
Type | Description
System.String |

FindString(Int32, CultureInfo)

Declaration
public string FindString(int stringID, CultureInfo culture)
Parameters
Type | Name | Description
System.Int32 | stringID |
System.Globalization.CultureInfo | culture |
Returns
Type | Description
System.String |

FindString(Int32, Int32)

Declaration
public string FindString(int stringID, int localeID)
Parameters
Type | Name | Description
System.Int32 | stringID |
System.Int32 | localeID |
Returns
Type | Description
System.String |

FindString(Int32, String)

Declaration
public string FindString(int stringID, string culture)
Parameters
Type | Name | Description
System.Int32 | stringID |
System.String | culture |
Returns
Type | Description
System.String |

FindString(String)

Declaration
public string FindString(string stringName)
Parameters
Type | Name | Description
System.String | stringName |
Returns
Type | Description
System.String |

FindString(String, CultureInfo)

Declaration
public string FindString(string stringName, CultureInfo culture)
Parameters
Type | Name | Description
System.String | stringName |
System.Globalization.CultureInfo | culture |
Returns
Type | Description
System.String |

FindString(String, Int32)

Declaration
public string FindString(string stringName, int localeID)
Parameters
Type | Name | Description
System.String | stringName |
System.Int32 | localeID |
Returns
Type | Description
System.String |

FindString(String, String)

Declaration
public string FindString(string stringName, string culture)
Parameters
Type | Name | Description
System.String | stringName |
System.String | culture |
Returns
Type | Description
System.String |

InitCacheData()

Declaration
protected override object InitCacheData()
Returns
Type | Description
System.Object |
Overrides
CacheBase.InitCacheData()

LoadCacheData(Object)

Declaration
protected override void LoadCacheData(object cacheData)
Parameters
Type | Name | Description
System.Object | cacheData |
Overrides
CacheBase.LoadCacheData(Object)

SetNameAndParameters(String, String)

Declaration
protected override void SetNameAndParameters(string name, string parameters)
Parameters
Type | Name | Description
System.String | name |
System.String | parameters |
Overrides
CacheBase.SetNameAndParameters(String, String)

SupportedLocales()

Declaration
public IEnumerable<CultureInfo> SupportedLocales()
Returns
Type | Description
System.Collections.Generic.IEnumerable<System.Globalization.CultureInfo> |

Implements

IStringCache


Namespace FChoice.Foundation.Clarify.Workflow | fcSDK Documentation

Namespace FChoice.Foundation.Clarify.Workflow

Classes

WorkflowException

WorkFlowInfo

WorkflowManager

Enums

AttachmentFolderMode

Back to top © 2022 Dovetail Software, Inc. - All rights reserved.
Clarify, Amdocs, and related products and names are copyright and trademark of Amdocs, Inc.
.NET, Visual Studio.NET, C#, Visual Basic and related products are trademark of Microsoft corporation.


Enum AttachmentFolderMode | fcSDK Documentation

Enum AttachmentFolderMode

Namespace: FChoice.Foundation.Clarify.Workflow
Assembly: fcSDK.dll
Syntax
public enum AttachmentFolderMode

Fields

Name | Description
ModeA |
ModeB |
ModeC |


Class WorkflowException | fcSDK Documentation

Class WorkflowException

Inheritance
System.Object
System.Exception
System.ApplicationException
FCExceptionBase
WorkflowException
Implements
System.Runtime.InteropServices._Exception
System.Runtime.Serialization.ISerializable
Inherited Members
FCExceptionBase.SetMessageProvider(IErrorMessageProvider)
FCExceptionBase.GetResourceData()
FCExceptionBase.GetErrorMessageFormat(Object, String)
FCExceptionBase.FormatMessage(String, String, Object[])
FCExceptionBase.LoadErrorResourceSet(String)
FCExceptionBase.GetObjectData(SerializationInfo, StreamingContext)
FCExceptionBase.MessageProvider
FCExceptionBase.ErrorCode
FCExceptionBase.ErrorMessageID
FCExceptionBase.Message
System.Exception.GetBaseException()
System.Exception.ToString()
System.Exception.GetType()
System.Exception.Data
System.Exception.InnerException
System.Exception.TargetSite
System.Exception.StackTrace
System.Exception.HelpLink
System.Exception.Source
System.Exception.HResult
System.Exception.SerializeObjectState
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Workflow
Assembly: fcSDK.dll
Syntax
public class WorkflowException : FCExceptionBase, _Exception, ISerializable

Constructors

WorkflowException(SerializationInfo, StreamingContext)

Declaration
protected WorkflowException(SerializationInfo info, StreamingContext context)
Parameters
Type | Name | Description
System.Runtime.Serialization.SerializationInfo | info |
System.Runtime.Serialization.StreamingContext | context |

Implements

System.Runtime.InteropServices._Exception
System.Runtime.Serialization.ISerializable


Class WorkFlowInfo | fcSDK Documentation

Class WorkFlowInfo

Inheritance
System.Object
WorkFlowInfo
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Workflow
Assembly: fcSDK.dll
Syntax
public class WorkFlowInfo

Constructors

WorkFlowInfo(String)

Declaration
public WorkFlowInfo(string objectName)
Parameters
Type | Name | Description
System.String | objectName |

Properties

ActivityDate

Declaration
public DateTime ActivityDate { get; }
Property Value
Type | Description
System.DateTime |

ActivityRelation

Declaration
public string ActivityRelation { get; }
Property Value
Type | Description
System.String |

ConditionRelation

Declaration
public string ConditionRelation { get; }
Property Value
Type | Description
System.String |

DatabaseTable

Declaration
public string DatabaseTable { get; }
Property Value
Type | Description
System.String |

EmployeeID

Declaration
public int EmployeeID { get; }
Property Value
Type | Description
System.Int32 |

GenerateTimeBomb

Declaration
public bool GenerateTimeBomb { get; }
Property Value
Type | Description
System.Boolean |

HistoryFieldName

Declaration
public string HistoryFieldName { get; }
Property Value
Type | Description
System.String |

IDFieldName

Declaration
public string IDFieldName { get; }
Property Value
Type | Description
System.String |

IDNum

Declaration
public string IDNum { get; }
Property Value
Type | Description
System.String |

IsAllowedCheckFieldName

Declaration
public string IsAllowedCheckFieldName { get; }
Property Value
Type | Description
System.String |

IsApplicationUser

Declaration
public bool IsApplicationUser { get; }
Property Value
Type | Description
System.Boolean |

IsSessionUser

Declaration
public bool IsSessionUser { get; }
Property Value
Type | Description
System.Boolean |

IsWipBinDefault

Declaration
public bool IsWipBinDefault { get; }
Property Value
Type | Description
System.Boolean |

NewStatus

Declaration
public string NewStatus { get; }
Property Value
Type | Description
System.String |

NewUserID

Declaration
public int NewUserID { get; }
Property Value
Type | Description
System.Int32 |

NewUserName

Declaration
public string NewUserName { get; }
Property Value
Type | Description
System.String |

ObjectName

Declaration
public string ObjectName { get; }
Property Value
Type | Description
System.String |

OldRejectRelation

Declaration
public string OldRejectRelation { get; }
Property Value
Type | Description
System.String |

OldStatusRelation

Declaration
public string OldStatusRelation { get; }
Property Value
Type | Description
System.String |

OwnerRelation

Declaration
public string OwnerRelation { get; }
Property Value
Type | Description
System.String |

PreviousQueueRelation

Declaration
public string PreviousQueueRelation { get; }
Property Value
Type | Description
System.String |

QueueId

Declaration
public int QueueId { get; }
Property Value
Type | Description
System.Int32 |

QueueName

Declaration
public string QueueName { get; }
Property Value
Type | Description
System.String |

QueueRelation

Declaration
public string QueueRelation { get; }
Property Value
Type | Description
System.String |

RejectRelation

Declaration
public string RejectRelation { get; }
Property Value
Type | Description
System.String |

StatusCode

Declaration
public int StatusCode { get; }
Property Value
Type | Description
System.Int32 |

StatusRelation

Declaration
public string StatusRelation { get; }
Property Value
Type | Description
System.String |

UseParticipantActEntryModel

Declaration
public bool UseParticipantActEntryModel { get; }
Property Value
Type | Description
System.Boolean |

UserID

Declaration
public int UserID { get; }
Property Value
Type | Description
System.Int32 |

UserName

Declaration
public string UserName { get; }
Property Value
Type | Description
System.String |

WipBin

Declaration
public string WipBin { get; }
Property Value
Type | Description
System.String |

WipBinID

Declaration
public int WipBinID { get; }
Property Value
Type | Description
System.Int32 |

WipBinRelation

Declaration
public string WipBinRelation { get; }
Property Value
Type | Description
System.String |


Class WorkflowManager | fcSDK Documentation

Class WorkflowManager

Inheritance
System.Object
WorkflowManager
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify.Workflow
Assembly: fcSDK.dll
Syntax
public class WorkflowManager

Constructors

WorkflowManager(ClarifyDataSet)

Declaration
public WorkflowManager(ClarifyDataSet ds)
Parameters
Type | Name | Description
ClarifyDataSet | ds |

WorkflowManager(IDbTransaction, ClarifyDataSet, String)

Declaration
public WorkflowManager(IDbTransaction transaction, ClarifyDataSet ds, string userName = null)
Parameters
Type | Name | Description
System.Data.IDbTransaction | transaction |
ClarifyDataSet | ds |
System.String | userName |

Fields

EndOfHistoryMagicText

Declaration
public static readonly string EndOfHistoryMagicText
Field Value
Type | Description
System.String |

ImpersonatorUserName

Declaration
public string ImpersonatorUserName
Field Value
Type | Description
System.String |

Methods

Accept(String, String, String, DateTime, String, Boolean)

Declaration
public WorkFlowInfo Accept(string idNum, string objectName, string wipBin, DateTime acceptDate, string userName, bool generateTimeBomb)
Parameters
Type | Name | Description
System.String | idNum |
System.String | objectName |
System.String | wipBin |
System.DateTime | acceptDate |
System.String | userName |
System.Boolean | generateTimeBomb |
Returns
Type | Description
WorkFlowInfo |

Assign(String, String, String, String, DateTime, String, Boolean)

Declaration
public WorkFlowInfo Assign(string idNum, string objectName, string newUserName, string wipBin, DateTime assignDate, string currentUserName, bool generateTimeBomb)
Parameters
Type | Name | Description
System.String | idNum |
System.String | objectName |
System.String | newUserName |
System.String | wipBin |
System.DateTime | assignDate |
System.String | currentUserName |
System.Boolean | generateTimeBomb |
Returns
Type | Description
WorkFlowInfo |

BuildClarifyHistory(String, String)

Declaration
public static string BuildClarifyHistory(string currentHistory, string appendHistory)
Parameters
Type | Name | Description
System.String | currentHistory |
System.String | appendHistory |
Returns
Type | Description
System.String |

ChangeStatus(String, String, String, DateTime, String, Boolean, String)

Declaration
public WorkFlowInfo ChangeStatus(string idNum, string objectName, string newStatus, DateTime changeDate, string userName, bool generateTimeBomb, string notes)
Parameters
Type | Name | Description
System.String | idNum |
System.String | objectName |
System.String | newStatus |
System.DateTime | changeDate |
System.String | userName |
System.Boolean | generateTimeBomb |
System.String | notes |
Returns
Type | Description
WorkFlowInfo |

CreateActivityEntryRow(Int32, String, Int32, DateTime, String, ClarifyDataRow, IList<ClarifyGeneric>)

Declaration
public ClarifyDataRow CreateActivityEntryRow(int activityCode, string activityName, int userObjid, DateTime activityDate, string addnl_info, ClarifyDataRow objectRow, IList<ClarifyGeneric> clarifyGenericsToUpdate)
Parameters
Type | Name | Description
System.Int32 | activityCode |
System.String | activityName |
System.Int32 | userObjid |
System.DateTime | activityDate |
System.String | addnl_info |
ClarifyDataRow | objectRow |
System.Collections.Generic.IList<ClarifyGeneric> | clarifyGenericsToUpdate |
Returns
Type | Description
ClarifyDataRow |

CreateActivityLogEntry(Int32, Int32, DateTime, String, ClarifyDataRow, ClarifyDataRow, WorkflowObjectInfo)

Declaration
public void CreateActivityLogEntry(int activityCode, int userObjid, DateTime activityDate, string addlInfo, ClarifyDataRow objectRow, ClarifyDataRow actEntryRow, WorkflowObjectInfo objInfo = null)
Parameters
Type | Name | Description
System.Int32 | activityCode |
System.Int32 | userObjid |
System.DateTime | activityDate |
System.String | addlInfo |
ClarifyDataRow | objectRow |
ClarifyDataRow | actEntryRow |
WorkflowObjectInfo | objInfo |

CreateAttachmentRecord(Int32, String, String, String, Boolean, Boolean)

Declaration
public int CreateAttachmentRecord(int objectObjId, string attachmentName, string filePath, string objectType, bool attachmentsAnywhere, bool createActEntry)
Parameters
Type | Name | Description
System.Int32 | objectObjId |
System.String | attachmentName |
System.String | filePath |
System.String | objectType |
System.Boolean | attachmentsAnywhere |
System.Boolean | createActEntry |
Returns
Type | Description
System.Int32 |

CreateAttachmentRecord(Int32, String, String, String, Boolean, Boolean, IDictionary<String, Object>)

Declaration
public int CreateAttachmentRecord(int objectObjId, string attachmentName, string filePath, string objectType, bool attachmentsAnywhere, bool createActEntry, IDictionary<string, object> docPathFields)
Parameters
Type | Name | Description
System.Int32 | objectObjId |
System.String | attachmentName |
System.String | filePath |
System.String | objectType |
System.Boolean | attachmentsAnywhere |
System.Boolean | createActEntry |
System.Collections.Generic.IDictionary<System.String, System.Object> | docPathFields |
Returns
Type | Description
System.Int32 |

CreateAttachmentRecord(String, String, String, String, Boolean, Boolean)

Declaration
public int CreateAttachmentRecord(string idNumber, string attachmentName, string filePath, string objectType, bool attachmentsAnywhere, bool createActEntry)
Parameters
Type | Name | Description
System.String | idNumber |
System.String | attachmentName |
System.String | filePath |
System.String | objectType |
System.Boolean | attachmentsAnywhere |
System.Boolean | createActEntry |
Returns
Type | Description
System.Int32 |

CreateAttachmentRecord(String, String, String, String, Boolean, Boolean, IDictionary<String, Object>)

Declaration
public int CreateAttachmentRecord(string idNumber, string attachmentName, string filePath, string objectType, bool attachmentsAnywhere, bool createActEntry, IDictionary<string, object> docPathFields)
Parameters
Type | Name | Description
System.String | idNumber |
System.String | attachmentName |
System.String | filePath |
System.String | objectType |
System.Boolean | attachmentsAnywhere |
System.Boolean | createActEntry |
System.Collections.Generic.IDictionary<System.String, System.Object> | docPathFields |
Returns
Type | Description
System.Int32 |

CreateCasePhoneLogActivityEntry(Int32, DateTime, String, ClarifyDataRow, ClarifyDataRow, ClarifyDataRow)

Declaration
public void CreateCasePhoneLogActivityEntry(int userObjid, DateTime activityDate, string addlInfo, ClarifyDataRow objectRow, ClarifyDataRow actEntryRow, ClarifyDataRow phoneLogRow)
Parameters
Type | Name | Description
System.Int32 | userObjid |
System.DateTime | activityDate |
System.String | addlInfo |
ClarifyDataRow | objectRow |
ClarifyDataRow | actEntryRow |
ClarifyDataRow | phoneLogRow |

CreateParticipantActivityEntry(Int32, Int32, DateTime, String, ClarifyDataRow, ClarifyDataRow, IList<ClarifyGeneric>, String)

Declaration
public void CreateParticipantActivityEntry(int activityCode, int userObjid, DateTime activityDate, string additionalInfo, ClarifyDataRow objectRow, ClarifyDataRow actEntryRow, IList<ClarifyGeneric> clarifyGenericsToUpdate, string parentRelation)
Parameters
Type | Name | Description
System.Int32 | activityCode |
System.Int32 | userObjid |
System.DateTime | activityDate |
System.String | additionalInfo |
ClarifyDataRow | objectRow |
ClarifyDataRow | actEntryRow |
System.Collections.Generic.IList<ClarifyGeneric> | clarifyGenericsToUpdate |
System.String | parentRelation |

CreateTimeBomb(ClarifyDataRow, ClarifyDataRow, Int32, Int32, DateTime, String)

Declaration
public ClarifyGeneric CreateTimeBomb(ClarifyDataRow mainRecord, ClarifyDataRow activityRecord, int timeBombFlag, int employeeId, DateTime timebombDate, string focusObjectName)
Parameters
Type | Name | Description
ClarifyDataRow | mainRecord |
ClarifyDataRow | activityRecord |
System.Int32 | timeBombFlag |
System.Int32 | employeeId |
System.DateTime | timebombDate |
System.String | focusObjectName |
Returns
Type | Description
ClarifyGeneric |

CreateTimeBomb(ClarifyDataRow, ClarifyDataRow, String, Int32, DateTime, String)

Declaration
public ClarifyGeneric CreateTimeBomb(ClarifyDataRow mainRecord, ClarifyDataRow activityRecord, string action, int employeeId, DateTime timebombDate, string focusObjectName)
Parameters
Type | Name | Description
ClarifyDataRow | mainRecord |
ClarifyDataRow | activityRecord |
System.String | action |
System.Int32 | employeeId |
System.DateTime | timebombDate |
System.String | focusObjectName |
Returns
Type | Description
ClarifyGeneric |

Dispatch(String, String, String, DateTime, String, Boolean)

Declaration
public WorkFlowInfo Dispatch(string idNum, string objectName, string queueName, DateTime dispatchDate, string userName, bool generateTimeBomb)
Parameters
Type | Name | Description
System.String | idNum |
System.String | objectName |
System.String | queueName |
System.DateTime | dispatchDate |
System.String | userName |
System.Boolean | generateTimeBomb |
Returns
Type | Description
WorkFlowInfo |

Forward(String, String, String, DateTime, String, Boolean, String)

Declaration
public WorkFlowInfo Forward(string idNum, string objectName, string newQueueName, DateTime forwardDate, string userName, bool generateTimeBomb, string notes)
Parameters
Type | Name | Description
System.String | idNum |
System.String | objectName |
System.String | newQueueName |
System.DateTime | forwardDate |
System.String | userName |
System.Boolean | generateTimeBomb |
System.String | notes |
Returns
Type | Description
WorkFlowInfo |

GetAttachmentFilePath(String, String, String, AttachmentFolderMode)

Declaration
public string GetAttachmentFilePath(string idNumber, string basePath, string fileName, AttachmentFolderMode attachMode)
Parameters
Type | Name | Description
System.String | idNumber |
System.String | basePath |
System.String | fileName |
AttachmentFolderMode | attachMode |
Returns
Type | Description
System.String |

GetNextFileName(String, String)

Declaration
public string GetNextFileName(string fileName, string basePath)
Parameters
Type | Name | Description
System.String | fileName |
System.String | basePath |
Returns
Type | Description
System.String |

GetNextFileNameIgnoringExistence(String, String)

Declaration
public string GetNextFileNameIgnoringExistence(string fileName, string basePath)
Parameters
Type | Name | Description
System.String | fileName |
System.String | basePath |
Returns
Type | Description
System.String |

GetWipDetails(ClarifyGeneric, WorkFlowInfo)

Declaration
public void GetWipDetails(ClarifyGeneric wipGen, WorkFlowInfo info)
Parameters
Type | Name | Description
ClarifyGeneric | wipGen |
WorkFlowInfo | info |

IsFilenameAlreadyInUseOnTheWorkflowObject(String, String, String)

Declaration
public bool IsFilenameAlreadyInUseOnTheWorkflowObject(string fileName, string idNumber, string workflowObjectName)
Parameters
Type | Name | Description
System.String | fileName |
System.String | idNumber |
System.String | workflowObjectName |
Returns
Type | Description
System.Boolean |

MakeFullHistoryDirty(String)

Declaration
public static string MakeFullHistoryDirty(string currentHistory)
Parameters
Type | Name | Description
System.String | currentHistory |
Returns
Type | Description
System.String |

MapObjectNameToTableID(String)

Declaration
public static int MapObjectNameToTableID(string objectName)
Parameters
Type | Name | Description
System.String | objectName |
Returns
Type | Description
System.Int32 |

MapTimeBombActionToFlag(String)

Declaration
public static int MapTimeBombActionToFlag(string timeBombAction)
Parameters
Type | Name | Description
System.String | timeBombAction |
Returns
Type | Description
System.Int32 |

Move(String, String, String)

Declaration
public WorkFlowInfo Move(string idNum, string objectName, string newWipBin)
Parameters
Type | Name | Description
System.String | idNum |
System.String | objectName |
System.String | newWipBin |
Returns
Type | Description
WorkFlowInfo |

Reject(String, String, String, DateTime, String, Boolean, String)

Declaration
public WorkFlowInfo Reject(string idNum, string objectName, string newWipBin, DateTime rejectDate, string userName, bool generateTimeBomb, string notes)
Parameters
Type | Name | Description
System.String | idNum |
System.String | objectName |
System.String | newWipBin |
System.DateTime | rejectDate |
System.String | userName |
System.Boolean | generateTimeBomb |
System.String | notes |
Returns
Type | Description
WorkFlowInfo |

Yank(String, String, String, DateTime, String, Boolean)

Declaration
public WorkFlowInfo Yank(string idNum, string objectName, string wipBin, DateTime yankDate, string userName, bool generateTimeBomb)
Parameters
Type | Name | Description
System.String | idNum |
System.String | objectName |
System.String | wipBin |
System.DateTime | yankDate |
System.String | userName |
System.Boolean | generateTimeBomb |
Returns
Type | Description
WorkFlowInfo |


Class WorkflowObjectInfo | fcSDK Documentation

Class WorkflowObjectInfo

Inheritance
System.Object
WorkflowObjectInfo
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Clarify
Assembly: fcSDK.dll
Syntax
public class WorkflowObjectInfo

Constructors

WorkflowObjectInfo(String)

Declaration
public WorkflowObjectInfo(string objectName)
Parameters
Type | Name | Description
System.String | objectName |

Properties

ActivityRelation

Declaration
public string ActivityRelation { get; set; }
Property Value
Type | Description
System.String |

AttachmentRelation

Declaration
public string AttachmentRelation { get; set; }
Property Value
Type | Description
System.String |

ConditionRelation

Declaration
public string ConditionRelation { get; set; }
Property Value
Type | Description
System.String |

DatabaseTable

Declaration
public string DatabaseTable { get; set; }
Property Value
Type | Description
System.String |

HasIDFieldName

Declaration
public bool HasIDFieldName { get; }
Property Value
Type | Description
System.Boolean |

HistoryFieldName

Declaration
public string HistoryFieldName { get; set; }
Property Value
Type | Description
System.String |

IDFieldName

Declaration
public string IDFieldName { get; set; }
Property Value
Type | Description
System.String |

IsAllowedCheckFieldName

Declaration
public string IsAllowedCheckFieldName { get; set; }
Property Value
Type | Description
System.String |

IsQueueableObject

Declaration
public bool IsQueueableObject { get; set; }
Property Value
Type | Description
System.Boolean |

ObjectName

Declaration
public string ObjectName { get; set; }
Property Value
Type | Description
System.String |

OldRejectRelation

Declaration
public string OldRejectRelation { get; set; }
Property Value
Type | Description
System.String |

OldStatusRelation

Declaration
public string OldStatusRelation { get; set; }
Property Value
Type | Description
System.String |

OwnerRelation

Declaration
public string OwnerRelation { get; set; }
Property Value
Type | Description
System.String |

ParentRelation

Declaration
public string ParentRelation { get; set; }
Property Value
Type | Description
System.String |

PreviousQueueRelation

Declaration
public string PreviousQueueRelation { get; set; }
Property Value
Type | Description
System.String |

QueueRelation

Declaration
public string QueueRelation { get; set; }
Property Value
Type | Description
System.String |

RejectRelation

Declaration
public string RejectRelation { get; set; }
Property Value
Type | Description
System.String |

StatusCode

Declaration
public int StatusCode { get; set; }
Property Value
Type | Description
System.Int32 |

StatusRelation

Declaration
public string StatusRelation { get; set; }
Property Value
Type | Description
System.String |

TimeStampFieldName

Declaration
public string TimeStampFieldName { get; set; }
Property Value
Type | Description
System.String |

UseParticipantActEntryModel

Declaration
public bool UseParticipantActEntryModel { get; set; }
Property Value
Type | Description
System.Boolean |

WipBinRelation

Declaration
public string WipBinRelation { get; set; }
Property Value
Type | Description
System.String |

Methods

AddToCache(WorkflowObjectInfo)

Declaration
public static void AddToCache(WorkflowObjectInfo info)
Parameters
Type | Name | Description
WorkflowObjectInfo | info |

AddToCache(WorkflowObjectInfo, String)

Declaration
public static void AddToCache(WorkflowObjectInfo info, string objectName)
Parameters
Type | Name | Description
WorkflowObjectInfo | info |
System.String | objectName |

CreateCustomQueueableObjectInfo(String, Boolean)

Declaration
public static WorkflowObjectInfo CreateCustomQueueableObjectInfo(string objName, bool useCache)
Parameters
Type | Name | Description
System.String | objName |
System.Boolean | useCache |
Returns
Type | Description
WorkflowObjectInfo |

GetObjectInfo(String)

Declaration
public static WorkflowObjectInfo GetObjectInfo(string objectName)
Parameters
Type | Name | Description
System.String | objectName |
Returns
Type | Description
WorkflowObjectInfo |

GetQueueableObjectInfo(String)

Declaration
public static WorkflowObjectInfo GetQueueableObjectInfo(string objectName)
Parameters
Type | Name | Description
System.String | objectName |
Returns
Type | Description
WorkflowObjectInfo |

GetQueueableObjectInfo(String, Boolean)

Declaration
public static WorkflowObjectInfo GetQueueableObjectInfo(string objectName, bool createCustomIfNotFound)
Parameters
Type | Name | Description
System.String | objectName |
System.Boolean | createCustomIfNotFound |
Returns
Type | Description
WorkflowObjectInfo |

ObjectTypeExists(String)

Declaration
public static bool ObjectTypeExists(string objectName)
Parameters
Type | Name | Description
System.String | objectName |
Returns
Type | Description
System.Boolean |


Class CustomCache | fcSDK Documentation

Class CustomCache

Inheritance
System.Object
CacheBase
CustomCache
Inherited Members
CacheBase.UpdateSyncRoot
CacheBase.OnCacheUpdated()
CacheBase.OnAnyCacheUpdated(CacheBase)
CacheBase.UpdateCache()
CacheBase.GetCacheDataHash()
CacheBase.GenerateMD5Hash(String)
CacheBase.AllTablesExistInDataSet(DataSet, String[])
CacheBase.GetCacheFilePath(String)
CacheBase.AnyCacheUpdated
CacheBase.CacheUpdated
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation
Assembly: fcSDK.dll
Syntax
public class CustomCache : CacheBase

Properties

CacheSetName

Declaration
public override string CacheSetName { get; }
Property Value
Type | Description
System.String |
Overrides
CacheBase.CacheSetName

CacheType

Declaration
public override CacheType CacheType { get; }
Property Value
Type | Description
CacheType |
Overrides
CacheBase.CacheType

Data

Declaration
public DataSet Data { get; }
Property Value
Type | Description
System.Data.DataSet |

Methods

GetInstance(String)

Declaration
public static CustomCache GetInstance(string cacheSetName)
Parameters
Type | Name | Description
System.String | cacheSetName |
Returns
Type | Description
CustomCache |

InitCacheData()

Declaration
protected override object InitCacheData()
Returns
Type | Description
System.Object |
Overrides
CacheBase.InitCacheData()

IsCacheOutOfDate(DateTime)

Declaration
protected override bool IsCacheOutOfDate(DateTime testDate)
Parameters
Type | Name | Description
System.DateTime | testDate |
Returns
Type | Description
System.Boolean |
Overrides
CacheBase.IsCacheOutOfDate(DateTime)

LoadCacheData(Object)

Declaration
protected override void LoadCacheData(object ds)
Parameters
Type | Name | Description
System.Object | ds |
Overrides
CacheBase.LoadCacheData(Object)

PersistCacheData(Object, String)

Declaration
protected override void PersistCacheData(object cacheData, string filePath)
Parameters
Type | Name | Description
System.Object | cacheData |
System.String | filePath |
Overrides
CacheBase.PersistCacheData(Object, String)

ReadCacheData(String)

Declaration
protected override object ReadCacheData(string filePath)
Parameters
Type | Name | Description
System.String | filePath |
Returns
Type | Description
System.Object |
Overrides
CacheBase.ReadCacheData(String)

SetNameAndParameters(String, String)

Declaration
protected override void SetNameAndParameters(string name, string parameters)
Parameters
Type | Name | Description
System.String | name |
System.String | parameters |
Overrides
CacheBase.SetNameAndParameters(String, String)


Class DataFieldNameCollection | fcSDK Documentation

Class DataFieldNameCollection

Inheritance
System.Object
ValidatedNameCollection
DataFieldNameCollection
Implements
System.Collections.IList
System.Collections.ICollection
System.Collections.IEnumerable
Inherited Members
ValidatedNameCollection.SetList(String)
ValidatedNameCollection.Remove(String)
ValidatedNameCollection.RemoveAt(Int32)
ValidatedNameCollection.Contains(String)
ValidatedNameCollection.Clear()
ValidatedNameCollection.IndexOf(String)
ValidatedNameCollection.Add(String)
ValidatedNameCollection.CopyTo(String[], Int32)
ValidatedNameCollection.ToString()
ValidatedNameCollection.IList.get_Item(Int32)
ValidatedNameCollection.IList.set_Item(Int32, Object)
ValidatedNameCollection.IList.Insert(Int32, Object)
ValidatedNameCollection.IList.Remove(Object)
ValidatedNameCollection.IList.Contains(Object)
ValidatedNameCollection.IList.IndexOf(Object)
ValidatedNameCollection.IList.Add(Object)
ValidatedNameCollection.ICollection.CopyTo(Array, Int32)
ValidatedNameCollection.GetEnumerator()
ValidatedNameCollection.Item[Int32]
ValidatedNameCollection.InnerNames
ValidatedNameCollection.IsReadOnly
ValidatedNameCollection.IsFixedSize
ValidatedNameCollection.IList.Item[Int32]
ValidatedNameCollection.IsSynchronized
ValidatedNameCollection.Count
ValidatedNameCollection.SyncRoot
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation
Assembly: fcSDK.dll
Syntax
public class DataFieldNameCollection : ValidatedNameCollection, IList, ICollection, IEnumerable

Methods

AddRange(String[])

Declaration
public override int[] AddRange(params string[] addNames)
Parameters
Type | Name | Description
System.String[] | addNames |
Returns
Type | Description
System.Int32[] |
Overrides
ValidatedNameCollection.AddRange(String[])

Insert(Int32, String)

Declaration
public override void Insert(int index, string name)
Parameters
Type | Name | Description
System.Int32 | index |
System.String | name |
Overrides
ValidatedNameCollection.Insert(Int32, String)

ValidateName(String)

Declaration
protected override bool ValidateName(string value)
Parameters
Type | Name | Description
System.String | value |
Returns
Type | Description
System.Boolean |
Overrides
ValidatedNameCollection.ValidateName(String)

Implements

System.Collections.IList
System.Collections.ICollection
System.Collections.IEnumerable


Namespace FChoice.Foundation.DataObjects | fcSDK Documentation

Namespace FChoice.Foundation.DataObjects

Classes

ColumnInfo

ConfigItem

ConfigItemCollection

DataObject

DataObjectCollection<T>

FakeTimeZone

RestrictionGroup

RestrictionGroupCollection

Interfaces

IDataObject

ITimeZone

Enums

ConfigItemScope

ConfigItemValueType

Back to top © 2022 Dovetail Software, Inc. - All rights reserved.
Clarify, Amdocs, and related products and names are copyright and trademark of Amdocs, Inc.
.NET, Visual Studio.NET, C#, Visual Basic and related products are trademark of Microsoft corporation.


Class ColumnInfo | fcSDK Documentation

Class ColumnInfo

Inheritance
System.Object
ColumnInfo
Implements
System.IComparable
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.DataObjects
Assembly: fcSDK.dll
Syntax
public class ColumnInfo : IComparable

Constructors

ColumnInfo()

Declaration
public ColumnInfo()

ColumnInfo(DataColumn)

Declaration
public ColumnInfo(DataColumn col)
Parameters
Type | Name | Description
System.Data.DataColumn | col |

Properties

DataType

Declaration
public Type DataType { get; }
Property Value
Type | Description
System.Type |

DefaultValue

Declaration
public object DefaultValue { get; }
Property Value
Type | Description
System.Object |

MaxLength

Declaration
public int MaxLength { get; }
Property Value
Type | Description
System.Int32 |

Name

Declaration
public string Name { get; }
Property Value
Type | Description
System.String |

Ordinal

Declaration
public int Ordinal { get; }
Property Value
Type | Description
System.Int32 |

TableName

Declaration
public string TableName { get; }
Property Value
Type | Description
System.String |

Methods

CompareTo(Object)

Declaration
public int CompareTo(object obj)
Parameters
Type | Name | Description
System.Object | obj |
Returns
Type | Description
System.Int32 |

Implements

System.IComparable


Class ConfigItem | fcSDK Documentation

Class ConfigItem

Inheritance
System.Object
DataObject
ConfigItem
ClarifyConfigItem
Implements
IDataObject
Inherited Members
DataObject.SetUniqueID(Object)
DataObject.GetFieldValue(String)
DataObject.GetFieldValue(Int32)
DataObject.ContainsColumn(String)
DataObject.GetSafeInt32FieldValue(String)
DataObject.GetSafeInt32FieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeDoubleFieldValue(String)
DataObject.GetSafeDoubleFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeBooleanFieldValue(String)
DataObject.GetSafeBooleanFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeStringFieldValue(String)
DataObject.SetFieldValue(String, Object)
DataObject.GetSafeString(Object)
DataObject.UniqueID
DataObject.FieldValues
DataObject.ColumnMap
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.DataObjects
Assembly: fcSDK.dll
Syntax
public abstract class ConfigItem : DataObject, IDataObject

Constructors

ConfigItem(DataRow)

Declaration
protected ConfigItem(DataRow row)
Parameters
Type | Name | Description
System.Data.DataRow | row |

ConfigItem(Object[])

Declaration
protected ConfigItem(object[] fieldData)
Parameters
Type | Name | Description
System.Object[] | fieldData |

Properties

DateValue

Declaration
public DateTime DateValue { get; }
Property Value
Type | Description
System.DateTime |

DecimalValue

Declaration
public decimal DecimalValue { get; }
Property Value
Type | Description
System.Decimal |

Description

Declaration
public string Description { get; }
Property Value
Type | Description
System.String |

DoubleValue

Declaration
public double DoubleValue { get; }
Property Value
Type | Description
System.Double |

IntegerValue

Declaration
public int IntegerValue { get; }
Property Value
Type | Description
System.Int32 |

LongValue

Declaration
public long LongValue { get; }
Property Value
Type | Description
System.Int64 |

Name

Declaration
public string Name { get; }
Property Value
Type | Description
System.String |

Scope

Declaration
public ConfigItemScope Scope { get; }
Property Value
Type | Description
ConfigItemScope |

StringValue

Declaration
public string StringValue { get; }
Property Value
Type | Description
System.String |

ValueType

Declaration
public ConfigItemValueType ValueType { get; }
Property Value
Type | Description
ConfigItemValueType |

ValueTypeRaw

Declaration
public int ValueTypeRaw { get; }
Property Value
Type | Description
System.Int32 |

Methods

SetDateVal(DateTime)

Declaration
protected void SetDateVal(DateTime value)
Parameters
Type | Name | Description
System.DateTime | value |

SetDblVal(Double)

Declaration
protected void SetDblVal(double value)
Parameters
Type | Name | Description
System.Double | value |

SetDecVal(Decimal)

Declaration
protected void SetDecVal(decimal value)
Parameters
Type | Name | Description
System.Decimal | value |

SetDescription(String)

Declaration
protected void SetDescription(string value)
Parameters
Type | Name | Description
System.String | value |

SetIntVal(Int32)

Declaration
protected void SetIntVal(int value)
Parameters
Type | Name | Description
System.Int32 | value |

SetLongVal(Int64)

Declaration
protected void SetLongVal(long value)
Parameters
Type | Name | Description
System.Int64 | value |

SetName(String)

Declaration
protected void SetName(string value)
Parameters
Type | Name | Description
System.String | value |

SetScope(ConfigItemScope)

Declaration
protected void SetScope(ConfigItemScope value)
Parameters
Type | Name | Description
ConfigItemScope | value |

SetStrVal(String)

Declaration
protected void SetStrVal(string value)
Parameters
Type | Name | Description
System.String | value |

SetValueType(Int32)

Declaration
protected void SetValueType(int value)
Parameters
Type | Name | Description
System.Int32 | value |

Implements

IDataObject


Class ConfigItemCollection | fcSDK Documentation

Class ConfigItemCollection

Inheritance
System.Object
System.Collections.Generic.List<ConfigItem>
DataObjectCollection<ConfigItem>
ConfigItemCollection
ClarifyConfigItemCollection
Implements
System.Collections.Generic.IList<ConfigItem>
System.Collections.Generic.ICollection<ConfigItem>
System.Collections.IList
System.Collections.ICollection
System.Collections.Generic.IReadOnlyList<ConfigItem>
System.Collections.Generic.IReadOnlyCollection<ConfigItem>
System.Collections.Generic.IEnumerable<ConfigItem>
System.Collections.IEnumerable
Inherited Members
DataObjectCollection<ConfigItem>.Initialize(DataTable)
DataObjectCollection<ConfigItem>.Initialize(DataRow[])
DataObjectCollection<ConfigItem>.Initialize(Object[][])
DataObjectCollection<ConfigItem>.AddDataObject(ConfigItem)
DataObjectCollection<ConfigItem>.OnDataObjectAdded(ConfigItem)
DataObjectCollection<ConfigItem>.GetItemByIndex(Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.System.Collections.IList.get_Item(System.Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.System.Collections.IList.set_Item(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.Add(FChoice.Foundation.DataObjects.ConfigItem)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.System.Collections.IList.Add(System.Object)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.AddRange(System.Collections.Generic.IEnumerable<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.AsReadOnly()
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.BinarySearch(System.Int32, System.Int32, FChoice.Foundation.DataObjects.ConfigItem, System.Collections.Generic.IComparer<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.BinarySearch(FChoice.Foundation.DataObjects.ConfigItem)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.BinarySearch(FChoice.Foundation.DataObjects.ConfigItem, System.Collections.Generic.IComparer<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.Clear()
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.Contains(FChoice.Foundation.DataObjects.ConfigItem)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.System.Collections.IList.Contains(System.Object)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.ConvertAll<TOutput>(System.Converter<FChoice.Foundation.DataObjects.ConfigItem, TOutput>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.CopyTo(FChoice.Foundation.DataObjects.ConfigItem[])
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.System.Collections.ICollection.CopyTo(System.Array, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.CopyTo(System.Int32, FChoice.Foundation.DataObjects.ConfigItem[], System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.CopyTo(FChoice.Foundation.DataObjects.ConfigItem[], System.Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.Exists(System.Predicate<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.Find(System.Predicate<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.FindAll(System.Predicate<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.FindIndex(System.Predicate<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.FindIndex(System.Int32, System.Predicate<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.FindIndex(System.Int32, System.Int32, System.Predicate<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.FindLast(System.Predicate<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.FindLastIndex(System.Predicate<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.FindLastIndex(System.Int32, System.Predicate<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.FindLastIndex(System.Int32, System.Int32, System.Predicate<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.ForEach(System.Action<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.System.Collections.Generic.IEnumerable<FChoice.Foundation.DataObjects.ConfigItem>.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.System.Collections.IEnumerable.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.GetRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.IndexOf(FChoice.Foundation.DataObjects.ConfigItem)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.System.Collections.IList.IndexOf(System.Object)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.IndexOf(FChoice.Foundation.DataObjects.ConfigItem, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.IndexOf(FChoice.Foundation.DataObjects.ConfigItem, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.Insert(System.Int32, FChoice.Foundation.DataObjects.ConfigItem)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.System.Collections.IList.Insert(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.InsertRange(System.Int32, System.Collections.Generic.IEnumerable<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.LastIndexOf(FChoice.Foundation.DataObjects.ConfigItem)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.LastIndexOf(FChoice.Foundation.DataObjects.ConfigItem, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.LastIndexOf(FChoice.Foundation.DataObjects.ConfigItem, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.Remove(FChoice.Foundation.DataObjects.ConfigItem)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.System.Collections.IList.Remove(System.Object)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.RemoveAll(System.Predicate<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.RemoveAt(System.Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.RemoveRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.Reverse()
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.Reverse(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.Sort()
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.Sort(System.Collections.Generic.IComparer<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.Sort(System.Int32, System.Int32, System.Collections.Generic.IComparer<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.Sort(System.Comparison<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.ToArray()
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.TrimExcess()
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.TrueForAll(System.Predicate<FChoice.Foundation.DataObjects.ConfigItem>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.Capacity
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.Count
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.System.Collections.IList.IsFixedSize
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.System.Collections.Generic.ICollection<FChoice.Foundation.DataObjects.ConfigItem>.IsReadOnly
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.System.Collections.IList.IsReadOnly
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.System.Collections.ICollection.IsSynchronized
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.System.Collections.ICollection.SyncRoot
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.Item[System.Int32]
System.Collections.Generic.List<FChoice.Foundation.DataObjects.ConfigItem>.System.Collections.IList.Item[System.Int32]
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.DataObjects
Assembly: fcSDK.dll
Syntax
public abstract class ConfigItemCollection : DataObjectCollection<ConfigItem>, IList<ConfigItem>, ICollection<ConfigItem>, IList, ICollection, IReadOnlyList<ConfigItem>, IReadOnlyCollection<ConfigItem>, IEnumerable<ConfigItem>, IEnumerable

Constructors

ConfigItemCollection(DataTable)

Declaration
protected ConfigItemCollection(DataTable table)
Parameters
Type | Name | Description
System.Data.DataTable | table |

ConfigItemCollection(Object[][])

Declaration
protected ConfigItemCollection(object[][] fieldData)
Parameters
Type | Name | Description
System.Object[][] | fieldData |

Properties

Item[String]

Declaration
public ConfigItem this[string itemName] { get; }
Parameters
Type | Name | Description
System.String | itemName |
Property Value
Type | Description
ConfigItem |

Methods

Create(DataRow)

Declaration
protected override ConfigItem Create(DataRow row)
Parameters
Type | Name | Description
System.Data.DataRow | row |
Returns
Type | Description
ConfigItem |
Overrides
FChoice.Foundation.DataObjects.DataObjectCollection<FChoice.Foundation.DataObjects.ConfigItem>.Create(System.Data.DataRow)

Create(Object[])

Declaration
protected override ConfigItem Create(object[] fieldData)
Parameters
Type | Name | Description
System.Object[] | fieldData |
Returns
Type | Description
ConfigItem |
Overrides
FChoice.Foundation.DataObjects.DataObjectCollection<FChoice.Foundation.DataObjects.ConfigItem>.Create(System.Object[])

CreateConfigItem(DataRow)

Declaration
protected abstract ConfigItem CreateConfigItem(DataRow row)
Parameters
Type | Name | Description
System.Data.DataRow | row |
Returns
Type | Description
ConfigItem |

CreateConfigItem(Object[])

Declaration
protected abstract ConfigItem CreateConfigItem(object[] fieldData)
Parameters
Type | Name | Description
System.Object[] | fieldData |
Returns
Type | Description
ConfigItem |

Implements

System.Collections.Generic.IList<T>
System.Collections.Generic.ICollection<T>
System.Collections.IList
System.Collections.ICollection
System.Collections.Generic.IReadOnlyList<T>
System.Collections.Generic.IReadOnlyCollection<T>
System.Collections.Generic.IEnumerable<T>
System.Collections.IEnumerable


Enum ConfigItemScope | fcSDK Documentation

Enum ConfigItemScope

Namespace: FChoice.Foundation.DataObjects
Assembly: fcSDK.dll
Syntax
public enum ConfigItemScope

Fields

Name | Description
Global |
Person |
Workgroup |


Enum ConfigItemValueType | fcSDK Documentation

Enum ConfigItemValueType

Namespace: FChoice.Foundation.DataObjects
Assembly: fcSDK.dll
Syntax
public enum ConfigItemValueType

Fields

Name | Description
All |
Double |
Integer |
String |
Unknown |


Class DataObject | fcSDK Documentation

Class DataObject

Inheritance
System.Object
DataObject
ClarifyDataObject
ConfigItem
RestrictionGroup
Implements
IDataObject
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.DataObjects
Assembly: fcSDK.dll
Syntax
public abstract class DataObject : IDataObject

Constructors

DataObject(DataRow)

Declaration
protected DataObject(DataRow row)
Parameters
Type | Name | Description
System.Data.DataRow | row |

DataObject(DataRow, String)

Declaration
protected DataObject(DataRow row, string idColumName)
Parameters
Type | Name | Description
System.Data.DataRow | row |
System.String | idColumName |

DataObject(Object, String)

Declaration
protected DataObject(object newId, string idName)
Parameters
Type | Name | Description
System.Object | newId |
System.String | idName |

DataObject(Object[])

Declaration
protected DataObject(object[] fieldData)
Parameters
Type | Name | Description
System.Object[] | fieldData |

DataObject(Object[], String)

Declaration
protected DataObject(object[] fieldData, string idColName)
Parameters
Type | Name | Description
System.Object[] | fieldData |
System.String | idColName |

DataObject(XmlElement, String)

Declaration
protected DataObject(XmlElement elm, string idAttributeName)
Parameters
Type | Name | Description
System.Xml.XmlElement | elm |
System.String | idAttributeName |

Properties

ColumnMap

Declaration
public IDictionary ColumnMap { get; }
Property Value
Type | Description
System.Collections.IDictionary |

FieldValues

Declaration
public object[] FieldValues { get; }
Property Value
Type | Description
System.Object[] |

UniqueID

Declaration
public object UniqueID { get; }
Property Value
Type | Description
System.Object |

Methods

ContainsColumn(String)

Declaration
public bool ContainsColumn(string columnName)
Parameters
Type | Name | Description
System.String | columnName |
Returns
Type | Description
System.Boolean |

GetFieldValue(Int32)

Declaration
public object GetFieldValue(int ordinal)
Parameters
Type | Name | Description
System.Int32 | ordinal |
Returns
Type | Description
System.Object |

GetFieldValue(String)

Declaration
public object GetFieldValue(string colName)
Parameters
Type | Name | Description
System.String | colName |
Returns
Type | Description
System.Object |

GetSafeBooleanFieldValue(String)

Declaration
public bool GetSafeBooleanFieldValue(string columnName)
Parameters
Type | Name | Description
System.String | columnName |
Returns
Type | Description
System.Boolean |

GetSafeBooleanFieldValue(String, Dictionary<String, ColumnInfo>, Object[])

Declaration
public static bool GetSafeBooleanFieldValue(string columnName, Dictionary<string, ColumnInfo> columnMap, object[] values)
Parameters
Type | Name | Description
System.String | columnName |
System.Collections.Generic.Dictionary<System.String, ColumnInfo> | columnMap |
System.Object[] | values |
Returns
Type | Description
System.Boolean |

GetSafeDoubleFieldValue(String)

Declaration
public double GetSafeDoubleFieldValue(string columnName)
Parameters
Type | Name | Description
System.String | columnName |
Returns
Type | Description
System.Double |

GetSafeDoubleFieldValue(String, Dictionary<String, ColumnInfo>, Object[])

Declaration
public static double GetSafeDoubleFieldValue(string columnName, Dictionary<string, ColumnInfo> columnMap, object[] values)
Parameters
Type | Name | Description
System.String | columnName |
System.Collections.Generic.Dictionary<System.String, ColumnInfo> | columnMap |
System.Object[] | values |
Returns
Type | Description
System.Double |

GetSafeInt32FieldValue(String)

Declaration
public int GetSafeInt32FieldValue(string colName)
Parameters
Type | Name | Description
System.String | colName |
Returns
Type | Description
System.Int32 |

GetSafeInt32FieldValue(String, Dictionary<String, ColumnInfo>, Object[])

Declaration
public static int GetSafeInt32FieldValue(string columnName, Dictionary<string, ColumnInfo> columnMap, object[] values)
Parameters
Type | Name | Description
System.String | columnName |
System.Collections.Generic.Dictionary<System.String, ColumnInfo> | columnMap |
System.Object[] | values |
Returns
Type | Description
System.Int32 |

GetSafeString(Object)

Declaration
protected static string GetSafeString(object dataValue)
Parameters
Type | Name | Description
System.Object | dataValue |
Returns
Type | Description
System.String |

GetSafeStringFieldValue(String)

Declaration
public string GetSafeStringFieldValue(string colName)
Parameters
Type | Name | Description
System.String | colName |
Returns
Type | Description
System.String |

SetFieldValue(String, Object)

Declaration
protected void SetFieldValue(string columnName, object value)
Parameters
Type | Name | Description
System.String | columnName |
System.Object | value |

SetUniqueID(Object)

Declaration
protected void SetUniqueID(object value)
Parameters
Type | Name | Description
System.Object | value |

Implements

IDataObject


Class DataObjectCollection<T> | fcSDK Documentation

Class DataObjectCollection<T>

Inheritance
System.Object
System.Collections.Generic.List<T>
DataObjectCollection<T>
CountryCollection
DaylightSavingsCollection
FCTimeZoneCollection
GlobalStringElementCollection
GlobalStringListCollection
HierarchicalStringElementCollection
HierarchicalStringListCollection
StateCollection
SchemaFieldCollectionBase
SchemaRelationCollection
SchemaTableCollection
SchemaViewCollection
SchemaViewFieldInfoCollection
SchemaViewJoinCollection
ConfigItemCollection
RestrictionGroupCollection
Implements
System.Collections.Generic.IList<T>
System.Collections.Generic.ICollection<T>
System.Collections.IList
System.Collections.ICollection
System.Collections.Generic.IReadOnlyList<T>
System.Collections.Generic.IReadOnlyCollection<T>
System.Collections.Generic.IEnumerable<T>
System.Collections.IEnumerable
Inherited Members
System.Collections.Generic.List<T>.System.Collections.IList.get_Item(System.Int32)
System.Collections.Generic.List<T>.System.Collections.IList.set_Item(System.Int32, System.Object)
System.Collections.Generic.List<T>.Add(T)
System.Collections.Generic.List<T>.System.Collections.IList.Add(System.Object)
System.Collections.Generic.List<T>.AddRange(System.Collections.Generic.IEnumerable<T>)
System.Collections.Generic.List<T>.AsReadOnly()
System.Collections.Generic.List<T>.BinarySearch(System.Int32, System.Int32, T, System.Collections.Generic.IComparer<T>)
System.Collections.Generic.List<T>.BinarySearch(T)
System.Collections.Generic.List<T>.BinarySearch(T, System.Collections.Generic.IComparer<T>)
System.Collections.Generic.List<T>.Clear()
System.Collections.Generic.List<T>.Contains(T)
System.Collections.Generic.List<T>.System.Collections.IList.Contains(System.Object)
System.Collections.Generic.List<T>.ConvertAll<TOutput>(System.Converter<T, TOutput>)
System.Collections.Generic.List<T>.CopyTo(T[])
System.Collections.Generic.List<T>.System.Collections.ICollection.CopyTo(System.Array, System.Int32)
System.Collections.Generic.List<T>.CopyTo(System.Int32, T[], System.Int32, System.Int32)
System.Collections.Generic.List<T>.CopyTo(T[], System.Int32)
System.Collections.Generic.List<T>.Exists(System.Predicate<T>)
System.Collections.Generic.List<T>.Find(System.Predicate<T>)
System.Collections.Generic.List<T>.FindAll(System.Predicate<T>)
System.Collections.Generic.List<T>.FindIndex(System.Predicate<T>)
System.Collections.Generic.List<T>.FindIndex(System.Int32, System.Predicate<T>)
System.Collections.Generic.List<T>.FindIndex(System.Int32, System.Int32, System.Predicate<T>)
System.Collections.Generic.List<T>.FindLast(System.Predicate<T>)
System.Collections.Generic.List<T>.FindLastIndex(System.Predicate<T>)
System.Collections.Generic.List<T>.FindLastIndex(System.Int32, System.Predicate<T>)
System.Collections.Generic.List<T>.FindLastIndex(System.Int32, System.Int32, System.Predicate<T>)
System.Collections.Generic.List<T>.ForEach(System.Action<T>)
System.Collections.Generic.List<T>.GetEnumerator()
System.Collections.Generic.List<T>.System.Collections.Generic.IEnumerable<T>.GetEnumerator()
System.Collections.Generic.List<T>.System.Collections.IEnumerable.GetEnumerator()
System.Collections.Generic.List<T>.GetRange(System.Int32, System.Int32)
System.Collections.Generic.List<T>.IndexOf(T)
System.Collections.Generic.List<T>.System.Collections.IList.IndexOf(System.Object)
System.Collections.Generic.List<T>.IndexOf(T, System.Int32)
System.Collections.Generic.List<T>.IndexOf(T, System.Int32, System.Int32)
System.Collections.Generic.List<T>.Insert(System.Int32, T)
System.Collections.Generic.List<T>.System.Collections.IList.Insert(System.Int32, System.Object)
System.Collections.Generic.List<T>.InsertRange(System.Int32, System.Collections.Generic.IEnumerable<T>)
System.Collections.Generic.List<T>.LastIndexOf(T)
System.Collections.Generic.List<T>.LastIndexOf(T, System.Int32)
System.Collections.Generic.List<T>.LastIndexOf(T, System.Int32, System.Int32)
System.Collections.Generic.List<T>.Remove(T)
System.Collections.Generic.List<T>.System.Collections.IList.Remove(System.Object)
System.Collections.Generic.List<T>.RemoveAll(System.Predicate<T>)
System.Collections.Generic.List<T>.RemoveAt(System.Int32)
System.Collections.Generic.List<T>.RemoveRange(System.Int32, System.Int32)
System.Collections.Generic.List<T>.Reverse()
System.Collections.Generic.List<T>.Reverse(System.Int32, System.Int32)
System.Collections.Generic.List<T>.Sort()
System.Collections.Generic.List<T>.Sort(System.Collections.Generic.IComparer<T>)
System.Collections.Generic.List<T>.Sort(System.Int32, System.Int32, System.Collections.Generic.IComparer<T>)
System.Collections.Generic.List<T>.Sort(System.Comparison<T>)
System.Collections.Generic.List<T>.ToArray()
System.Collections.Generic.List<T>.TrimExcess()
System.Collections.Generic.List<T>.TrueForAll(System.Predicate<T>)
System.Collections.Generic.List<T>.Capacity
System.Collections.Generic.List<T>.Count
System.Collections.Generic.List<T>.System.Collections.IList.IsFixedSize
System.Collections.Generic.List<T>.System.Collections.Generic.ICollection<T>.IsReadOnly
System.Collections.Generic.List<T>.System.Collections.IList.IsReadOnly
System.Collections.Generic.List<T>.System.Collections.ICollection.IsSynchronized
System.Collections.Generic.List<T>.System.Collections.ICollection.SyncRoot
System.Collections.Generic.List<T>.Item[System.Int32]
System.Collections.Generic.List<T>.System.Collections.IList.Item[System.Int32]
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.DataObjects
Assembly: fcSDK.dll
Syntax
public abstract class DataObjectCollection<T> : List<T>, IList<T>, ICollection<T>, IList, ICollection, IReadOnlyList<T>, IReadOnlyCollection<T>, IEnumerable<T>, IEnumerable where T : IDataObject
Type Parameters
Name | Description
T |

Constructors

DataObjectCollection()

Declaration
protected DataObjectCollection()

Methods

AddDataObject(T)

Declaration
protected void AddDataObject(T obj)
Parameters
Type | Name | Description
T | obj |

Create(DataRow)

Declaration
protected abstract T Create(DataRow row)
Parameters
Type | Name | Description
System.Data.DataRow | row |
Returns
Type | Description
T |

Create(Object[])

Declaration
protected virtual T Create(object[] fieldData)
Parameters
Type | Name | Description
System.Object[] | fieldData |
Returns
Type | Description
T |

GetItemByIndex(Int32)

Declaration
public T GetItemByIndex(int index)
Parameters
Type | Name | Description
System.Int32 | index |
Returns
Type | Description
T |

Initialize(DataRow[])

Declaration
protected void Initialize(DataRow[] rows)
Parameters
Type | Name | Description
System.Data.DataRow[] | rows |

Initialize(DataTable)

Declaration
protected void Initialize(DataTable table)
Parameters
Type | Name | Description
System.Data.DataTable | table |

Initialize(Object[][])

Declaration
protected void Initialize(object[][] fieldData)
Parameters
Type | Name | Description
System.Object[][] | fieldData |

OnDataObjectAdded(T)

Declaration
protected virtual void OnDataObjectAdded(T obj)
Parameters
Type | Name | Description
T | obj |

Implements

System.Collections.Generic.IList<T>
System.Collections.Generic.ICollection<T>
System.Collections.IList
System.Collections.ICollection
System.Collections.Generic.IReadOnlyList<T>
System.Collections.Generic.IReadOnlyCollection<T>
System.Collections.Generic.IEnumerable<T>
System.Collections.IEnumerable


Class FakeTimeZone | fcSDK Documentation

Class FakeTimeZone

Inheritance
System.Object
DataObject
ClarifyDataObject
FCTimeZone
FakeTimeZone
Implements
IDataObject
ITimeZone
Inherited Members
FCTimeZone.IsDaylightSavingsTime(DateTime)
FCTimeZone.ConvertDate(DateTime, ITimeZone, ITimeZone)
FCTimeZone.ConvertDate(DateTime, ITimeZone)
FCTimeZone.Name
FCTimeZone.IsDefault
FCTimeZone.FullName
FCTimeZone.UtcOffsetSeconds
FCTimeZone.DaylightSavingsPeriods
ClarifyDataObject.GetCommentFieldValue(DataRow)
ClarifyDataObject.CommentFieldName
ClarifyDataObject.ObjectID
DataObject.SetUniqueID(Object)
DataObject.GetFieldValue(String)
DataObject.GetFieldValue(Int32)
DataObject.ContainsColumn(String)
DataObject.GetSafeInt32FieldValue(String)
DataObject.GetSafeInt32FieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeDoubleFieldValue(String)
DataObject.GetSafeDoubleFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeBooleanFieldValue(String)
DataObject.GetSafeBooleanFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeStringFieldValue(String)
DataObject.SetFieldValue(String, Object)
DataObject.GetSafeString(Object)
DataObject.UniqueID
DataObject.FieldValues
DataObject.ColumnMap
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.DataObjects
Assembly: fcSDK.dll
Syntax
public class FakeTimeZone : FCTimeZone, IDataObject, ITimeZone

Implements

IDataObject
ITimeZone


Interface IDataObject | fcSDK Documentation

Interface IDataObject

Namespace: FChoice.Foundation.DataObjects
Assembly: fcSDK.dll
Syntax
public interface IDataObject

Properties

ColumnMap

Declaration
IDictionary ColumnMap { get; }
Property Value
Type | Description
System.Collections.IDictionary |

FieldValues

Declaration
object[] FieldValues { get; }
Property Value
Type | Description
System.Object[] |

UniqueID

Declaration
object UniqueID { get; }
Property Value
Type | Description
System.Object |

Methods

ContainsColumn(String)

Declaration
bool ContainsColumn(string columnName)
Parameters
Type | Name | Description
System.String | columnName |
Returns
Type | Description
System.Boolean |

GetFieldValue(Int32)

Declaration
object GetFieldValue(int ordinal)
Parameters
Type | Name | Description
System.Int32 | ordinal |
Returns
Type | Description
System.Object |

GetFieldValue(String)

Declaration
object GetFieldValue(string colName)
Parameters
Type | Name | Description
System.String | colName |
Returns
Type | Description
System.Object |

GetSafeBooleanFieldValue(String)

Declaration
bool GetSafeBooleanFieldValue(string columnName)
Parameters
Type | Name | Description
System.String | columnName |
Returns
Type | Description
System.Boolean |

GetSafeDoubleFieldValue(String)

Declaration
double GetSafeDoubleFieldValue(string columnName)
Parameters
Type | Name | Description
System.String | columnName |
Returns
Type | Description
System.Double |

GetSafeInt32FieldValue(String)

Declaration
int GetSafeInt32FieldValue(string colName)
Parameters
Type | Name | Description
System.String | colName |
Returns
Type | Description
System.Int32 |

GetSafeStringFieldValue(String)

Declaration
string GetSafeStringFieldValue(string colName)
Parameters
Type | Name | Description
System.String | colName |
Returns
Type | Description
System.String |


Interface ITimeZone | fcSDK Documentation

Interface ITimeZone

Namespace: FChoice.Foundation.DataObjects
Assembly: fcSDK.dll
Syntax
public interface ITimeZone

Properties

FullName

Declaration
string FullName { get; }
Property Value
Type | Description
System.String |

Name

Declaration
string Name { get; }
Property Value
Type | Description
System.String |

UtcOffsetSeconds

Declaration
int UtcOffsetSeconds { get; }
Property Value
Type | Description
System.Int32 |

Methods

IsDaylightSavingsTime(DateTime)

Declaration
bool IsDaylightSavingsTime(DateTime date)
Parameters
Type | Name | Description
System.DateTime | date |
Returns
Type | Description
System.Boolean |


Class RestrictionGroup | fcSDK Documentation

Class RestrictionGroup

Inheritance
System.Object
DataObject
RestrictionGroup
Implements
IDataObject
Inherited Members
DataObject.SetUniqueID(Object)
DataObject.GetFieldValue(String)
DataObject.GetFieldValue(Int32)
DataObject.ContainsColumn(String)
DataObject.GetSafeInt32FieldValue(String)
DataObject.GetSafeInt32FieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeDoubleFieldValue(String)
DataObject.GetSafeDoubleFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeBooleanFieldValue(String)
DataObject.GetSafeBooleanFieldValue(String, Dictionary<String, ColumnInfo>, Object[])
DataObject.GetSafeStringFieldValue(String)
DataObject.SetFieldValue(String, Object)
DataObject.GetSafeString(Object)
DataObject.UniqueID
DataObject.FieldValues
DataObject.ColumnMap
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.DataObjects
Assembly: fcSDK.dll
Syntax
public class RestrictionGroup : DataObject, IDataObject

Properties

Name

Declaration
public string Name { get; }
Property Value
Type | Description
System.String |

Restrictions

Declaration
public string[] Restrictions { get; }
Property Value
Type | Description
System.String[] |

Implements

IDataObject


Class RestrictionGroupCollection | fcSDK Documentation

Class RestrictionGroupCollection

Inheritance
System.Object
System.Collections.Generic.List<RestrictionGroup>
DataObjectCollection<RestrictionGroup>
RestrictionGroupCollection
Implements
System.Collections.Generic.IList<RestrictionGroup>
System.Collections.Generic.ICollection<RestrictionGroup>
System.Collections.IList
System.Collections.ICollection
System.Collections.Generic.IReadOnlyList<RestrictionGroup>
System.Collections.Generic.IReadOnlyCollection<RestrictionGroup>
System.Collections.Generic.IEnumerable<RestrictionGroup>
System.Collections.IEnumerable
Inherited Members
DataObjectCollection<RestrictionGroup>.Initialize(DataTable)
DataObjectCollection<RestrictionGroup>.Initialize(DataRow[])
DataObjectCollection<RestrictionGroup>.Initialize(Object[][])
DataObjectCollection<RestrictionGroup>.AddDataObject(RestrictionGroup)
DataObjectCollection<RestrictionGroup>.OnDataObjectAdded(RestrictionGroup)
DataObjectCollection<RestrictionGroup>.Create(Object[])
DataObjectCollection<RestrictionGroup>.GetItemByIndex(Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.System.Collections.IList.get_Item(System.Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.System.Collections.IList.set_Item(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.Add(FChoice.Foundation.DataObjects.RestrictionGroup)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.System.Collections.IList.Add(System.Object)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.AddRange(System.Collections.Generic.IEnumerable<FChoice.Foundation.DataObjects.RestrictionGroup>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.AsReadOnly()
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.BinarySearch(System.Int32, System.Int32, FChoice.Foundation.DataObjects.RestrictionGroup, System.Collections.Generic.IComparer<FChoice.Foundation.DataObjects.RestrictionGroup>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.BinarySearch(FChoice.Foundation.DataObjects.RestrictionGroup)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.BinarySearch(FChoice.Foundation.DataObjects.RestrictionGroup, System.Collections.Generic.IComparer<FChoice.Foundation.DataObjects.RestrictionGroup>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.Clear()
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.Contains(FChoice.Foundation.DataObjects.RestrictionGroup)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.System.Collections.IList.Contains(System.Object)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.ConvertAll<TOutput>(System.Converter<FChoice.Foundation.DataObjects.RestrictionGroup, TOutput>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.CopyTo(FChoice.Foundation.DataObjects.RestrictionGroup[])
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.System.Collections.ICollection.CopyTo(System.Array, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.CopyTo(System.Int32, FChoice.Foundation.DataObjects.RestrictionGroup[], System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.CopyTo(FChoice.Foundation.DataObjects.RestrictionGroup[], System.Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.Exists(System.Predicate<FChoice.Foundation.DataObjects.RestrictionGroup>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.Find(System.Predicate<FChoice.Foundation.DataObjects.RestrictionGroup>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.FindAll(System.Predicate<FChoice.Foundation.DataObjects.RestrictionGroup>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.FindIndex(System.Predicate<FChoice.Foundation.DataObjects.RestrictionGroup>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.FindIndex(System.Int32, System.Predicate<FChoice.Foundation.DataObjects.RestrictionGroup>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.FindIndex(System.Int32, System.Int32, System.Predicate<FChoice.Foundation.DataObjects.RestrictionGroup>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.FindLast(System.Predicate<FChoice.Foundation.DataObjects.RestrictionGroup>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.FindLastIndex(System.Predicate<FChoice.Foundation.DataObjects.RestrictionGroup>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.FindLastIndex(System.Int32, System.Predicate<FChoice.Foundation.DataObjects.RestrictionGroup>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.FindLastIndex(System.Int32, System.Int32, System.Predicate<FChoice.Foundation.DataObjects.RestrictionGroup>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.ForEach(System.Action<FChoice.Foundation.DataObjects.RestrictionGroup>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.System.Collections.Generic.IEnumerable<FChoice.Foundation.DataObjects.RestrictionGroup>.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.System.Collections.IEnumerable.GetEnumerator()
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.GetRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.IndexOf(FChoice.Foundation.DataObjects.RestrictionGroup)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.System.Collections.IList.IndexOf(System.Object)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.IndexOf(FChoice.Foundation.DataObjects.RestrictionGroup, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.IndexOf(FChoice.Foundation.DataObjects.RestrictionGroup, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.Insert(System.Int32, FChoice.Foundation.DataObjects.RestrictionGroup)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.System.Collections.IList.Insert(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.InsertRange(System.Int32, System.Collections.Generic.IEnumerable<FChoice.Foundation.DataObjects.RestrictionGroup>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.LastIndexOf(FChoice.Foundation.DataObjects.RestrictionGroup)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.LastIndexOf(FChoice.Foundation.DataObjects.RestrictionGroup, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.LastIndexOf(FChoice.Foundation.DataObjects.RestrictionGroup, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.Remove(FChoice.Foundation.DataObjects.RestrictionGroup)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.System.Collections.IList.Remove(System.Object)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.RemoveAll(System.Predicate<FChoice.Foundation.DataObjects.RestrictionGroup>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.RemoveAt(System.Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.RemoveRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.Reverse()
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.Reverse(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.Sort()
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.Sort(System.Collections.Generic.IComparer<FChoice.Foundation.DataObjects.RestrictionGroup>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.Sort(System.Int32, System.Int32, System.Collections.Generic.IComparer<FChoice.Foundation.DataObjects.RestrictionGroup>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.Sort(System.Comparison<FChoice.Foundation.DataObjects.RestrictionGroup>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.ToArray()
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.TrimExcess()
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.TrueForAll(System.Predicate<FChoice.Foundation.DataObjects.RestrictionGroup>)
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.Capacity
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.Count
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.System.Collections.IList.IsFixedSize
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.System.Collections.Generic.ICollection<FChoice.Foundation.DataObjects.RestrictionGroup>.IsReadOnly
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.System.Collections.IList.IsReadOnly
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.System.Collections.ICollection.IsSynchronized
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.System.Collections.ICollection.SyncRoot
System.Collections.Generic.List<FChoice.Foundation.DataObjects.RestrictionGroup>.System.Collections.IList.Item[System.Int32]
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.DataObjects
Assembly: fcSDK.dll
Syntax
public class RestrictionGroupCollection : DataObjectCollection<RestrictionGroup>, IList<RestrictionGroup>, ICollection<RestrictionGroup>, IList, ICollection, IReadOnlyList<RestrictionGroup>, IReadOnlyCollection<RestrictionGroup>, IEnumerable<RestrictionGroup>, IEnumerable

Constructors

RestrictionGroupCollection()

Declaration
public RestrictionGroupCollection()

RestrictionGroupCollection(DataTable)

Declaration
public RestrictionGroupCollection(DataTable table)
Parameters
Type | Name | Description
System.Data.DataTable | table |

Properties

Item[Int32]

Declaration
public RestrictionGroup this[int restrictionId] { get; }
Parameters
Type | Name | Description
System.Int32 | restrictionId |
Property Value
Type | Description
RestrictionGroup |

Item[String]

Declaration
public RestrictionGroup this[string name] { get; }
Parameters
Type | Name | Description
System.String | name |
Property Value
Type | Description
RestrictionGroup |

Methods

Create(DataRow)

Declaration
protected override RestrictionGroup Create(DataRow row)
Parameters
Type | Name | Description
System.Data.DataRow | row |
Returns
Type | Description
RestrictionGroup |
Overrides
FChoice.Foundation.DataObjects.DataObjectCollection<FChoice.Foundation.DataObjects.RestrictionGroup>.Create(System.Data.DataRow)

Implements

System.Collections.Generic.IList<T>
System.Collections.Generic.ICollection<T>
System.Collections.IList
System.Collections.ICollection
System.Collections.Generic.IReadOnlyList<T>
System.Collections.Generic.IReadOnlyCollection<T>
System.Collections.Generic.IEnumerable<T>
System.Collections.IEnumerable


Enum DateOps | fcSDK Documentation

Enum DateOps

Namespace: FChoice.Foundation
Assembly: fcSDK.dll
Syntax
public enum DateOps

Fields

Name | Description
After |
Before |
Equals |
LessThan |
LessThanOrEqual |
MoreThan |
MoreThanOrEqual |
NotEquals |
On |
Today |
Tomorrow |
Yesterday |


Class DictionaryExtensions | fcSDK Documentation

Class DictionaryExtensions

Inheritance
System.Object
DictionaryExtensions
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation
Assembly: fcSDK.dll
Syntax
public static class DictionaryExtensions

Methods

Get<T, V>(IDictionary<T, V>, T)

Declaration
public static V Get<T, V>(this IDictionary<T, V> dictionary, T key)
Parameters
Type | Name | Description
System.Collections.Generic.IDictionary<T, V> | dictionary |
T | key |
Returns
Type | Description
V |
Type Parameters
Name | Description
T |
V |


Namespace FChoice.Foundation.DynamicBinding | fcSDK Documentation

Namespace FChoice.Foundation.DynamicBinding

Classes

DynamicBindingCollection

Interfaces

IDynamicBinding

Back to top © 2022 Dovetail Software, Inc. - All rights reserved.
Clarify, Amdocs, and related products and names are copyright and trademark of Amdocs, Inc.
.NET, Visual Studio.NET, C#, Visual Basic and related products are trademark of Microsoft corporation.


Class DynamicBindingCollection | fcSDK Documentation

Class DynamicBindingCollection

Inheritance
System.Object
System.Collections.ObjectModel.Collection<IDynamicBinding>
DynamicBindingCollection
Implements
System.Collections.Generic.IList<IDynamicBinding>
System.Collections.Generic.ICollection<IDynamicBinding>
System.Collections.IList
System.Collections.ICollection
System.Collections.Generic.IReadOnlyList<IDynamicBinding>
System.Collections.Generic.IReadOnlyCollection<IDynamicBinding>
System.Collections.Generic.IEnumerable<IDynamicBinding>
System.Collections.IEnumerable
Inherited Members
System.Collections.ObjectModel.Collection<FChoice.Foundation.DynamicBinding.IDynamicBinding>.Add(FChoice.Foundation.DynamicBinding.IDynamicBinding)
System.Collections.ObjectModel.Collection<FChoice.Foundation.DynamicBinding.IDynamicBinding>.Clear()
System.Collections.ObjectModel.Collection<FChoice.Foundation.DynamicBinding.IDynamicBinding>.CopyTo(FChoice.Foundation.DynamicBinding.IDynamicBinding[], System.Int32)
System.Collections.ObjectModel.Collection<FChoice.Foundation.DynamicBinding.IDynamicBinding>.Contains(FChoice.Foundation.DynamicBinding.IDynamicBinding)
System.Collections.ObjectModel.Collection<FChoice.Foundation.DynamicBinding.IDynamicBinding>.GetEnumerator()
System.Collections.ObjectModel.Collection<FChoice.Foundation.DynamicBinding.IDynamicBinding>.IndexOf(FChoice.Foundation.DynamicBinding.IDynamicBinding)
System.Collections.ObjectModel.Collection<FChoice.Foundation.DynamicBinding.IDynamicBinding>.Insert(System.Int32, FChoice.Foundation.DynamicBinding.IDynamicBinding)
System.Collections.ObjectModel.Collection<FChoice.Foundation.DynamicBinding.IDynamicBinding>.Remove(FChoice.Foundation.DynamicBinding.IDynamicBinding)
System.Collections.ObjectModel.Collection<FChoice.Foundation.DynamicBinding.IDynamicBinding>.RemoveAt(System.Int32)
System.Collections.ObjectModel.Collection<FChoice.Foundation.DynamicBinding.IDynamicBinding>.ClearItems()
System.Collections.ObjectModel.Collection<FChoice.Foundation.DynamicBinding.IDynamicBinding>.InsertItem(System.Int32, FChoice.Foundation.DynamicBinding.IDynamicBinding)
System.Collections.ObjectModel.Collection<FChoice.Foundation.DynamicBinding.IDynamicBinding>.RemoveItem(System.Int32)
System.Collections.ObjectModel.Collection<FChoice.Foundation.DynamicBinding.IDynamicBinding>.SetItem(System.Int32, FChoice.Foundation.DynamicBinding.IDynamicBinding)
System.Collections.ObjectModel.Collection<FChoice.Foundation.DynamicBinding.IDynamicBinding>.System.Collections.IEnumerable.GetEnumerator()
System.Collections.ObjectModel.Collection<FChoice.Foundation.DynamicBinding.IDynamicBinding>.System.Collections.ICollection.CopyTo(System.Array, System.Int32)
System.Collections.ObjectModel.Collection<FChoice.Foundation.DynamicBinding.IDynamicBinding>.System.Collections.IList.get_Item(System.Int32)
System.Collections.ObjectModel.Collection<FChoice.Foundation.DynamicBinding.IDynamicBinding>.System.Collections.IList.set_Item(System.Int32, System.Object)
System.Collections.ObjectModel.Collection<FChoice.Foundation.DynamicBinding.IDynamicBinding>.System.Collections.IList.Add(System.Object)
System.Collections.ObjectModel.Collection<FChoice.Foundation.DynamicBinding.IDynamicBinding>.System.Collections.IList.Contains(System.Object)
System.Collections.ObjectModel.Collection<FChoice.Foundation.DynamicBinding.IDynamicBinding>.System.Collections.IList.IndexOf(System.Object)
System.Collections.ObjectModel.Collection<FChoice.Foundation.DynamicBinding.IDynamicBinding>.System.Collections.IList.Insert(System.Int32, System.Object)
System.Collections.ObjectModel.Collection<FChoice.Foundation.DynamicBinding.IDynamicBinding>.System.Collections.IList.Remove(System.Object)
System.Collections.ObjectModel.Collection<FChoice.Foundation.DynamicBinding.IDynamicBinding>.Count
System.Collections.ObjectModel.Collection<FChoice.Foundation.DynamicBinding.IDynamicBinding>.Items
System.Collections.ObjectModel.Collection<FChoice.Foundation.DynamicBinding.IDynamicBinding>.Item[System.Int32]
System.Collections.ObjectModel.Collection<FChoice.Foundation.DynamicBinding.IDynamicBinding>.System.Collections.Generic.ICollection<FChoice.Foundation.DynamicBinding.IDynamicBinding>.IsReadOnly
System.Collections.ObjectModel.Collection<FChoice.Foundation.DynamicBinding.IDynamicBinding>.System.Collections.ICollection.IsSynchronized
System.Collections.ObjectModel.Collection<FChoice.Foundation.DynamicBinding.IDynamicBinding>.System.Collections.ICollection.SyncRoot
System.Collections.ObjectModel.Collection<FChoice.Foundation.DynamicBinding.IDynamicBinding>.System.Collections.IList.Item[System.Int32]
System.Collections.ObjectModel.Collection<FChoice.Foundation.DynamicBinding.IDynamicBinding>.System.Collections.IList.IsReadOnly
System.Collections.ObjectModel.Collection<FChoice.Foundation.DynamicBinding.IDynamicBinding>.System.Collections.IList.IsFixedSize
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.DynamicBinding
Assembly: fcSDK.dll
Syntax
public class DynamicBindingCollection : Collection<IDynamicBinding>, IList<IDynamicBinding>, ICollection<IDynamicBinding>, IList, ICollection, IReadOnlyList<IDynamicBinding>, IReadOnlyCollection<IDynamicBinding>, IEnumerable<IDynamicBinding>, IEnumerable

Implements

System.Collections.Generic.IList<T>
System.Collections.Generic.ICollection<T>
System.Collections.IList
System.Collections.ICollection
System.Collections.Generic.IReadOnlyList<T>
System.Collections.Generic.IReadOnlyCollection<T>
System.Collections.Generic.IEnumerable<T>
System.Collections.IEnumerable


Interface IDynamicBinding | fcSDK Documentation

Interface IDynamicBinding

Namespace: FChoice.Foundation.DynamicBinding
Assembly: fcSDK.dll
Syntax
public interface IDynamicBinding

Properties

Processed

Declaration
bool Processed { get; }
Property Value
Type | Description
System.Boolean |

Relation

Declaration
ISchemaRelation Relation { get; }
Property Value
Type | Description
ISchemaRelation |

Methods

ProcessBinding(IDictionary<FCGeneric, IDictionary<Guid, GenericDataRow>>, UpdateQueryBatch)

Declaration
void ProcessBinding(IDictionary<FCGeneric, IDictionary<Guid, GenericDataRow>> changedRows, UpdateQueryBatch batch)
Parameters
Type | Name | Description
System.Collections.Generic.IDictionary<FCGeneric, System.Collections.Generic.IDictionary<System.Guid, GenericDataRow>> | changedRows |
UpdateQueryBatch | batch |


Class ExcludedColumns | fcSDK Documentation

Class ExcludedColumns

Inheritance
System.Object
ExcludedColumns
Inherited Members
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation
Assembly: fcSDK.dll
Syntax
public class ExcludedColumns

Constructors

ExcludedColumns()

Declaration
public ExcludedColumns()

Methods

Exclude(String, String)

Declaration
public void Exclude(string tableName, string column)
Parameters
Type | Name | Description
System.String | tableName |
System.String | column |

IsExcluded(String, String)

Declaration
public bool IsExcluded(string tableName, string column)
Parameters
Type | Name | Description
System.String | tableName |
System.String | column |
Returns
Type | Description
System.Boolean |

ToString()

Declaration
public override string ToString()
Returns
Type | Description
System.String |
Overrides
System.Object.ToString()


Class FCApplication | fcSDK Documentation

Class FCApplication

Inheritance
System.Object
FCApplication
ClarifyApplication
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation
Assembly: fcSDK.dll
Syntax
public abstract class FCApplication

Constructors

FCApplication()

Declaration
protected FCApplication()

Fields

SyncRoot

Declaration
public static readonly object SyncRoot
Field Value
Type | Description
System.Object |

Properties

DatabaseVersion

Declaration
public Version DatabaseVersion { get; }
Property Value
Type | Description
System.Version |

FCAppDataRestrictionsEnabled

Declaration
protected abstract bool FCAppDataRestrictionsEnabled { get; }
Property Value
Type | Description
System.Boolean |

FCAppInstance

Declaration
protected static FCApplication FCAppInstance { get; }
Property Value
Type | Description
FCApplication |

FCAppServerTimeZone

Declaration
protected abstract ITimeZone FCAppServerTimeZone { get; }
Property Value
Type | Description
ITimeZone |

IsInitialized

Declaration
public static bool IsInitialized { get; }
Property Value
Type | Description
System.Boolean |

Username

Declaration
public string Username { get; set; }
Property Value
Type | Description
System.String |

Methods

AddSessionData(FCSessionData)

Declaration
protected void AddSessionData(FCSessionData sess)
Parameters
Type | Name | Description
FCSessionData | sess |

CurrentSessions()

Declaration
public FCSessionSummary[] CurrentSessions()
Returns
Type | Description
FCSessionSummary[] |

Deinitialize()

Declaration
public static void Deinitialize()

FCAppInitialize(CacheBase[], ISchemaCache)

Declaration
protected void FCAppInitialize(CacheBase[] caches, ISchemaCache schemaMaster)
Parameters
Type | Name | Description
CacheBase[] | caches |
ISchemaCache | schemaMaster |

FCAppParseConnectionString(out String, out String)

Declaration
protected NameValueCollection FCAppParseConnectionString(out string username, out string password)
Parameters
Type | Name | Description
System.String | username |
System.String | password |
Returns
Type | Description
System.Collections.Specialized.NameValueCollection |

FCAppParseConnectionString(out String, out String, out String, out String, out String)

Declaration
protected NameValueCollection FCAppParseConnectionString(out string username, out string password, out string usernameKey, out string passwordKey, out string integratedSecurity)
Parameters
Type | Name | Description
System.String | username |
System.String | password |
System.String | usernameKey |
System.String | passwordKey |
System.String | integratedSecurity |
Returns
Type | Description
System.Collections.Specialized.NameValueCollection |

GetSessionData(Guid)

Declaration
protected FCSessionData GetSessionData(Guid sessionID)
Parameters
Type | Name | Description
System.Guid | sessionID |
Returns
Type | Description
FCSessionData |

Log(LogLevel, Exception, String, Object[])

Declaration
public static void Log(LogLevel level, Exception ex, string format, params object[] args)
Parameters
Type | Name | Description
LogLevel | level |
System.Exception | ex |
System.String | format |
System.Object[] | args |

Log(LogLevel, String, Object[])

Declaration
public static void Log(LogLevel level, string format, params object[] args)
Parameters
Type | Name | Description
LogLevel | level |
System.String | format |
System.Object[] | args |

LogDebug(Exception, String, Object[])

Declaration
public static void LogDebug(Exception ex, string format, params object[] args)
Parameters
Type | Name | Description
System.Exception | ex |
System.String | format |
System.Object[] | args |

LogDebug(String, Object[])

Declaration
public static void LogDebug(string format, params object[] args)
Parameters
Type | Name | Description
System.String | format |
System.Object[] | args |

LogError(Exception, String, Object[])

Declaration
public static void LogError(Exception ex, string format, params object[] args)
Parameters
Type | Name | Description
System.Exception | ex |
System.String | format |
System.Object[] | args |

LogError(String, Object[])

Declaration
public static void LogError(string format, params object[] args)
Parameters
Type | Name | Description
System.String | format |
System.Object[] | args |

LogInfo(Exception, String, Object[])

Declaration
public static void LogInfo(Exception ex, string format, params object[] args)
Parameters
Type | Name | Description
System.Exception | ex |
System.String | format |
System.Object[] | args |

LogInfo(String, Object[])

Declaration
public static void LogInfo(string format, params object[] args)
Parameters
Type | Name | Description
System.String | format |
System.Object[] | args |

LogWarn(Exception, String, Object[])

Declaration
public static void LogWarn(Exception ex, string format, params object[] args)
Parameters
Type | Name | Description
System.Exception | ex |
System.String | format |
System.Object[] | args |

LogWarn(String, Object[])

Declaration
public static void LogWarn(string format, params object[] args)
Parameters
Type | Name | Description
System.String | format |
System.Object[] | args |

RemoveSession(FCSession)

Declaration
protected void RemoveSession(FCSession sess)
Parameters
Type | Name | Description
FCSession | sess |

SaveSessionData(FCSessionData)

Declaration
protected void SaveSessionData(FCSessionData sess)
Parameters
Type | Name | Description
FCSessionData | sess |

SetInitializeComplete(Boolean)

Declaration
protected static void SetInitializeComplete(bool complete)
Parameters
Type | Name | Description
System.Boolean | complete |


Class FCGeneric | fcSDK Documentation

Class FCGeneric

Inheritance
System.Object
FCGeneric
ClarifyGeneric
Implements
System.Collections.ICollection
System.Collections.IEnumerable
System.ComponentModel.IListSource
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation
Assembly: fcSDK.dll
Syntax
public abstract class FCGeneric : ICollection, IEnumerable, IListSource

Constructors

FCGeneric(GenericDataSet)

Declaration
protected FCGeneric(GenericDataSet parentDataSet)
Parameters
Type | Name | Description
GenericDataSet | parentDataSet |

FCGeneric(GenericDataSet, FCGeneric, String)

Declaration
protected FCGeneric(GenericDataSet parentDataSet, FCGeneric parent, string relationName)
Parameters
Type | Name | Description
GenericDataSet | parentDataSet |
FCGeneric | parent |
System.String | relationName |

FCGeneric(GenericDataSet, Object, String, String)

Declaration
protected FCGeneric(GenericDataSet parentDataSet, object rootObjId, string rootObjName, string relFromParent)
Parameters
Type | Name | Description
GenericDataSet | parentDataSet |
System.Object | rootObjId |
System.String | rootObjName |
System.String | relFromParent |

FCGeneric(GenericDataSet, String)

Declaration
protected FCGeneric(GenericDataSet parentDataSet, string tableName)
Parameters
Type | Name | Description
GenericDataSet | parentDataSet |
System.String | tableName |

Fields

EXCLUSIVE_REL_TABLEIDFIELDNAME

Declaration
protected const string EXCLUSIVE_REL_TABLEIDFIELDNAME = "FCTableIdentifier"
Field Value
Type | Description
System.String |

FILTER_EQUAL

Declaration
protected const string FILTER_EQUAL = "="
Field Value
Type | Description
System.String |

FILTER_GREATER_THAN

Declaration
protected const string FILTER_GREATER_THAN = ">"
Field Value
Type | Description
System.String |

FILTER_GREATER_THAN_EQUAL

Declaration
protected const string FILTER_GREATER_THAN_EQUAL = ">="
Field Value
Type | Description
System.String |

FILTER_IS_IN

Declaration
protected const string FILTER_IS_IN = "IN"
Field Value
Type | Description
System.String |

FILTER_IS_NOT_IN

Declaration
protected const string FILTER_IS_NOT_IN = "NOT IN"
Field Value
Type | Description
System.String |

FILTER_IS_NOT_NULL

Declaration
protected const string FILTER_IS_NOT_NULL = "IS NOT NULL"
Field Value
Type | Description
System.String |

FILTER_IS_NULL

Declaration
protected const string FILTER_IS_NULL = "IS NULL"
Field Value
Type | Description
System.String |

FILTER_LESS_THAN

Declaration
protected const string FILTER_LESS_THAN = "<"
Field Value
Type | Description
System.String |

FILTER_LESS_THAN_EQUAL

Declaration
protected const string FILTER_LESS_THAN_EQUAL = "<="
Field Value
Type | Description
System.String |

FILTER_LIKE

Declaration
protected const string FILTER_LIKE = "LIKE"
Field Value
Type | Description
System.String |

FILTER_NOT_EQUAL

Declaration
protected const string FILTER_NOT_EQUAL = "<>"
Field Value
Type | Description
System.String |

FILTER_NOT_LIKE

Declaration
protected const string FILTER_NOT_LIKE = "NOT LIKE"
Field Value
Type | Description
System.String |

FILTER_SOUNDS_LIKE

Declaration
protected const string FILTER_SOUNDS_LIKE = "SOUNDSLIKE"
Field Value
Type | Description
System.String |

INCLUDE_MTM_PARENT_FIELDNAME

Declaration
protected const string INCLUDE_MTM_PARENT_FIELDNAME = "mtm_par_objid"
Field Value
Type | Description
System.String |

MAX_DATE

Declaration
public static readonly DateTime MAX_DATE
Field Value
Type | Description
System.DateTime |

MIN_DATE

Declaration
public static readonly DateTime MIN_DATE
Field Value
Type | Description
System.DateTime |

NOW_DATE

Declaration
public static readonly DateTime NOW_DATE
Field Value
Type | Description
System.DateTime |

schemaTable

Declaration
protected ISchemaTableBase schemaTable
Field Value
Type | Description
ISchemaTableBase |

Properties

BaseChildGenerics

Declaration
protected IList<FCGeneric> BaseChildGenerics { get; }
Property Value
Type | Description
System.Collections.Generic.IList<FCGeneric> |

BaseDataSet

Declaration
protected GenericDataSet BaseDataSet { get; }
Property Value
Type | Description
GenericDataSet |

BaseDataTable

Declaration
protected GenericDataTable BaseDataTable { get; set; }
Property Value
Type | Description
GenericDataTable |

BaseIsTraverseFromRoot

Declaration
protected bool BaseIsTraverseFromRoot { get; }
Property Value
Type | Description
System.Boolean |

BaseParentGeneric

Declaration
protected FCGeneric BaseParentGeneric { get; set; }
Property Value
Type | Description
FCGeneric |

BaseParentRelation

Declaration
protected ISchemaRelation BaseParentRelation { get; set; }
Property Value
Type | Description
ISchemaRelation |

BaseResults

Declaration
protected GenericDataTable BaseResults { get; }
Property Value
Type | Description
GenericDataTable |

BaseRootObjectID

Declaration
protected object BaseRootObjectID { get; }
Property Value
Type | Description
System.Object |

BaseRows

Declaration
protected GenericDataRowCollection BaseRows { get; }
Property Value
Type | Description
GenericDataRowCollection |

BaseSchemaTable

Declaration
protected ISchemaTableBase BaseSchemaTable { get; }
Property Value
Type | Description
ISchemaTableBase |

BaseSession

Declaration
protected FCSession BaseSession { get; }
Property Value
Type | Description
FCSession |

BaseSortList

Declaration
protected IList<FCGeneric.FCGenericSort> BaseSortList { get; }
Property Value
Type | Description
System.Collections.Generic.IList<FCGeneric.FCGenericSort> |

Bindings

Declaration
protected DynamicBindingCollection Bindings { get; }
Property Value
Type | Description
DynamicBindingCollection |

ChildGenerics

Declaration
public ICollection<FCGeneric> ChildGenerics { get; }
Property Value
Type | Description
System.Collections.Generic.ICollection<FCGeneric> |

Count

Declaration
public int Count { get; }
Property Value
Type | Description
System.Int32 |

DataFields

Declaration
public DataFieldNameCollection DataFields { get; }
Property Value
Type | Description
DataFieldNameCollection |

DataRestrictionsEnabled

Declaration
public bool DataRestrictionsEnabled { get; set; }
Property Value
Type | Description
System.Boolean |

DataSetTableName

Declaration
protected string DataSetTableName { get; }
Property Value
Type | Description
System.String |

DefaultObjectIdValue

Declaration
protected abstract object DefaultObjectIdValue { get; }
Property Value
Type | Description
System.Object |

DeleteRelationsToUnrelate

Declaration
public RelationNameCollection DeleteRelationsToUnrelate { get; }
Property Value
Type | Description
RelationNameCollection |

Filter

Declaration
public AndFilter Filter { get; }
Property Value
Type | Description
AndFilter |

IncludeRelations

Declaration
public bool IncludeRelations { get; set; }
Property Value
Type | Description
System.Boolean |

IsDistinct

Declaration
public bool IsDistinct { get; set; }
Property Value
Type | Description
System.Boolean |

IsOracleProvider

Declaration
protected static bool IsOracleProvider { get; }
Property Value
Type | Description
System.Boolean |

IsSynchronized

Declaration
public bool IsSynchronized { get; }
Property Value
Type | Description
System.Boolean |

Log

Declaration
protected abstract Logger Log { get; }
Property Value
Type | Description
Logger |

MaximumRows

Declaration
public int MaximumRows { get; set; }
Property Value
Type | Description
System.Int32 |

ObjectIdFieldName

Declaration
protected abstract string ObjectIdFieldName { get; }
Property Value
Type | Description
System.String |

QueryEmptyToNull

Declaration
public bool QueryEmptyToNull { get; set; }
Property Value
Type | Description
System.Boolean |

RawFilter

Declaration
public string RawFilter { get; set; }
Property Value
Type | Description
System.String |

RestrictionGroup

Declaration
public RestrictionGroup RestrictionGroup { get; set; }
Property Value
Type | Description
RestrictionGroup |

SearchableFieldPrefix

Declaration
public abstract string SearchableFieldPrefix { get; }
Property Value
Type | Description
System.String |

SetNullStringsToEmpty

Declaration
public bool SetNullStringsToEmpty { get; set; }
Property Value
Type | Description
System.Boolean |

SyncRoot

Declaration
public object SyncRoot { get; }
Property Value
Type | Description
System.Object |

TableName

Declaration
public string TableName { get; }
Property Value
Type | Description
System.String |

Methods

AddForUpdate(Object)

Declaration
protected GenericDataRow AddForUpdate(object uniqueId)
Parameters
Type | Name | Description
System.Object | uniqueId |
Returns
Type | Description
GenericDataRow |

AppendFilter(String, DateOps, DateTime)

Declaration
public void AppendFilter(string fieldName, DateOps operation, DateTime value)
Parameters
Type | Name | Description
System.String | fieldName |
DateOps | operation |
System.DateTime | value |

AppendFilter(String, NumberOps, Decimal)

Declaration
public void AppendFilter(string fieldName, NumberOps operation, decimal value)
Parameters
Type | Name | Description
System.String | fieldName |
NumberOps | operation |
System.Decimal | value |

AppendFilter(String, NumberOps, Int32)

Declaration
public void AppendFilter(string fieldName, NumberOps operation, int value)
Parameters
Type | Name | Description
System.String | fieldName |
NumberOps | operation |
System.Int32 | value |

AppendFilter(String, StringOps, String)

Declaration
public void AppendFilter(string fieldName, StringOps operation, string value)
Parameters
Type | Name | Description
System.String | fieldName |
StringOps | operation |
System.String | value |

AppendFilter(String, Boolean)

Declaration
public void AppendFilter(string fieldName, bool value)
Parameters
Type | Name | Description
System.String | fieldName |
System.Boolean | value |

AppendFilterBetween(String, Boolean, DateTime, DateTime)

Declaration
public void AppendFilterBetween(string fieldName, bool isBetween, DateTime value1, DateTime value2)
Parameters
Type | Name | Description
System.String | fieldName |
System.Boolean | isBetween |
System.DateTime | value1 |
System.DateTime | value2 |

AppendFilterBetween(String, Boolean, Decimal, Decimal)

Declaration
public void AppendFilterBetween(string fieldName, bool isBetween, decimal value1, decimal value2)
Parameters
Type | Name | Description
System.String | fieldName |
System.Boolean | isBetween |
System.Decimal | value1 |
System.Decimal | value2 |

AppendFilterBetween(String, Boolean, Int32, Int32)

Declaration
public void AppendFilterBetween(string fieldName, bool isBetween, int value1, int value2)
Parameters
Type | Name | Description
System.String | fieldName |
System.Boolean | isBetween |
System.Int32 | value1 |
System.Int32 | value2 |

AppendFilterInList(String, Boolean, DateTime[])

Declaration
public void AppendFilterInList(string fieldName, bool isIn, params DateTime[] list)
Parameters
Type | Name | Description
System.String | fieldName |
System.Boolean | isIn |
System.DateTime[] | list |

AppendFilterInList(String, Boolean, Decimal[])

Declaration
public void AppendFilterInList(string fieldName, bool isIn, params decimal[] list)
Parameters
Type | Name | Description
System.String | fieldName |
System.Boolean | isIn |
System.Decimal[] | list |

AppendFilterInList(String, Boolean, Int32[])

Declaration
public void AppendFilterInList(string fieldName, bool isIn, params int[] list)
Parameters
Type | Name | Description
System.String | fieldName |
System.Boolean | isIn |
System.Int32[] | list |

AppendFilterInList(String, Boolean, String[])

Declaration
public void AppendFilterInList(string fieldName, bool isIn, params string[] list)
Parameters
Type | Name | Description
System.String | fieldName |
System.Boolean | isIn |
System.String[] | list |

AppendFilterIsNull(String, Boolean)

Declaration
public void AppendFilterIsNull(string fieldName, bool isNull)
Parameters
Type | Name | Description
System.String | fieldName |
System.Boolean | isNull |

AppendSort(String, Boolean)

Declaration
public void AppendSort(string fieldName, bool isAscending)
Parameters
Type | Name | Description
System.String | fieldName |
System.Boolean | isAscending |

AppendSort(String, Boolean, Boolean)

Declaration
public void AppendSort(string fieldName, bool isAscending, bool checkField)
Parameters
Type | Name | Description
System.String | fieldName |
System.Boolean | isAscending |
System.Boolean | checkField |

AssignAllObjIDs(IEnumerable<GenericDataRow>)

Declaration
protected void AssignAllObjIDs(IEnumerable<GenericDataRow> rows)
Parameters
Type | Name | Description
System.Collections.Generic.IEnumerable<GenericDataRow> | rows |

AssignObjID(GenericDataRow)

Declaration
public void AssignObjID(GenericDataRow row)
Parameters
Type | Name | Description
GenericDataRow | row |

BaseDeleteById(Object)

Declaration
protected void BaseDeleteById(object uniqueId)
Parameters
Type | Name | Description
System.Object | uniqueId |

BaseTraverseFromParent(FCGeneric, String)

Declaration
protected void BaseTraverseFromParent(FCGeneric parentGeneric, string relationName)
Parameters
Type | Name | Description
FCGeneric | parentGeneric |
System.String | relationName |

BaseTraverseFromRoot(Object, String, String)

Declaration
protected void BaseTraverseFromRoot(object rootObjid, string rootObject, string relFromParent)
Parameters
Type | Name | Description
System.Object | rootObjid |
System.String | rootObject |
System.String | relFromParent |

ChangeRestrictionGroup(String)

Declaration
public void ChangeRestrictionGroup(string groupName)
Parameters
Type | Name | Description
System.String | groupName |

ClearFilters()

Declaration
public void ClearFilters()

ClearRoot()

Declaration
protected void ClearRoot()

ClearSorts()

Declaration
public void ClearSorts()

CloseGeneric()

Declaration
protected void CloseGeneric()

CopyTo(Array, Int32)

Declaration
public void CopyTo(Array array, int index)
Parameters
Type | Name | Description
System.Array | array |
System.Int32 | index |

DeleteAll()

Declaration
public void DeleteAll()

GetEnumerator()

Declaration
public IEnumerator GetEnumerator()
Returns
Type | Description
System.Collections.IEnumerator |

OnMaximumRowsExceeded(Int32, MaximumRowsExceededEventArgs)

Declaration
protected void OnMaximumRowsExceeded(int totalPossibleRows, MaximumRowsExceededEventArgs args)
Parameters
Type | Name | Description
System.Int32 | totalPossibleRows |
MaximumRowsExceededEventArgs | args |

PerformAddNew()

Declaration
protected abstract GenericDataRow PerformAddNew()
Returns
Type | Description
GenericDataRow |

PerformAddToParentGeneric(FCGeneric, ISchemaRelation)

Declaration
protected virtual void PerformAddToParentGeneric(FCGeneric parentGeneric, ISchemaRelation rel)
Parameters
Type | Name | Description
FCGeneric | parentGeneric |
ISchemaRelation | rel |

PerformAssignObjID(GenericDataRow)

Declaration
protected abstract void PerformAssignObjID(GenericDataRow row)
Parameters
Type | Name | Description
GenericDataRow | row |

PerformDeletes(IDictionary<Guid, GenericDataRow>, UpdateQueryBatch)

Declaration
protected abstract void PerformDeletes(IDictionary<Guid, GenericDataRow> rows, UpdateQueryBatch batch)
Parameters
Type | Name | Description
System.Collections.Generic.IDictionary<System.Guid, GenericDataRow> | rows |
UpdateQueryBatch | batch |

PerformSetTableName(String)

Declaration
protected abstract void PerformSetTableName(string value)
Parameters
Type | Name | Description
System.String | value |

PerformUpdate(GenericDataRow, UpdateQueryBatch)

Declaration
protected abstract void PerformUpdate(GenericDataRow row, UpdateQueryBatch batch)
Parameters
Type | Name | Description
GenericDataRow | row |
UpdateQueryBatch | batch |

ProcessBindings(IDictionary<FCGeneric, IDictionary<Guid, GenericDataRow>>, UpdateQueryBatch)

Declaration
protected void ProcessBindings(IDictionary<FCGeneric, IDictionary<Guid, GenericDataRow>> changedRows, UpdateQueryBatch batch)
Parameters
Type | Name | Description
System.Collections.Generic.IDictionary<FCGeneric, System.Collections.Generic.IDictionary<System.Guid, GenericDataRow>> | changedRows |
UpdateQueryBatch | batch |

Query()

Declaration
public abstract void Query()

Query(IDbTransaction)

Declaration
public abstract void Query(IDbTransaction transaction)
Parameters
Type | Name | Description
System.Data.IDbTransaction | transaction |

RelateGeneric(FCGeneric, ISchemaRelation)

Declaration
protected abstract void RelateGeneric(FCGeneric childGeneric, ISchemaRelation rel)
Parameters
Type | Name | Description
FCGeneric | childGeneric |
ISchemaRelation | rel |

SetTableName(String)

Declaration
protected void SetTableName(string value)
Parameters
Type | Name | Description
System.String | value |

SetupDataTable()

Declaration
protected abstract void SetupDataTable()

Traverse(FCGeneric, String)

Declaration
protected void Traverse(FCGeneric parentGeneric, string relationName)
Parameters
Type | Name | Description
FCGeneric | parentGeneric |
System.String | relationName |

UnTraverse()

Declaration
protected void UnTraverse()

Update(GenericDataRow)

Declaration
public void Update(GenericDataRow row)
Parameters
Type | Name | Description
GenericDataRow | row |

Update(GenericDataRow, UpdateQueryBatch)

Declaration
public void Update(GenericDataRow row, UpdateQueryBatch batch)
Parameters
Type | Name | Description
GenericDataRow | row |
UpdateQueryBatch | batch |

Update(GenericDataRow, IDbTransaction)

Declaration
public void Update(GenericDataRow row, IDbTransaction transaction)
Parameters
Type | Name | Description
GenericDataRow | row |
System.Data.IDbTransaction | transaction |

UpdateAll()

Declaration
public void UpdateAll()

UpdateAll(UpdateQueryBatch)

Declaration
public void UpdateAll(UpdateQueryBatch batch)
Parameters
Type | Name | Description
UpdateQueryBatch | batch |

ValidateAddNew()

Declaration
protected void ValidateAddNew()

Events

MaximumRowsExceeded

Declaration
public event MaximumRowsExceededEventHandler MaximumRowsExceeded
Event Type
Type | Description
MaximumRowsExceededEventHandler |

Implements

System.Collections.ICollection
System.Collections.IEnumerable
System.ComponentModel.IListSource


Class FCGeneric.FCFilterType | fcSDK Documentation

Class FCGeneric.FCFilterType

Inheritance
System.Object
FCGeneric.FCFilterType
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation
Assembly: fcSDK.dll
Syntax
protected class FCFilterType

Constructors

FCFilterType(String, String, Object)

Declaration
public FCFilterType(string tFieldName, string tOperation, object tValue)
Parameters
Type | Name | Description
System.String | tFieldName |
System.String | tOperation |
System.Object | tValue |

Properties

FieldName

Declaration
public string FieldName { get; set; }
Property Value
Type | Description
System.String |

FilterValue

Declaration
public object FilterValue { get; set; }
Property Value
Type | Description
System.Object |

Operation

Declaration
public string Operation { get; set; }
Property Value
Type | Description
System.String |


Class FCGeneric.FCGenericSort | fcSDK Documentation

Class FCGeneric.FCGenericSort

Inheritance
System.Object
FCGeneric.FCGenericSort
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation
Assembly: fcSDK.dll
Syntax
protected class FCGenericSort

Constructors

FCGenericSort(String, Boolean, Boolean)

Declaration
public FCGenericSort(string fieldName, bool isAscending, bool isValidated)
Parameters
Type | Name | Description
System.String | fieldName |
System.Boolean | isAscending |
System.Boolean | isValidated |

Properties

FieldName

Declaration
public string FieldName { get; set; }
Property Value
Type | Description
System.String |

IsAscending

Declaration
public bool IsAscending { get; set; }
Property Value
Type | Description
System.Boolean |

IsValidated

Declaration
public bool IsValidated { get; set; }
Property Value
Type | Description
System.Boolean |


Class FCInvalidLoginException | fcSDK Documentation

Class FCInvalidLoginException

Inheritance
System.Object
System.Exception
System.ApplicationException
FCExceptionBase
FoundationException
FCInvalidLoginException
Implements
System.Runtime.InteropServices._Exception
System.Runtime.Serialization.ISerializable
Inherited Members
FCExceptionBase.SetMessageProvider(IErrorMessageProvider)
FCExceptionBase.GetResourceData()
FCExceptionBase.GetErrorMessageFormat(Object, String)
FCExceptionBase.FormatMessage(String, String, Object[])
FCExceptionBase.LoadErrorResourceSet(String)
FCExceptionBase.GetObjectData(SerializationInfo, StreamingContext)
FCExceptionBase.MessageProvider
FCExceptionBase.ErrorCode
FCExceptionBase.ErrorMessageID
FCExceptionBase.Message
System.Exception.GetBaseException()
System.Exception.ToString()
System.Exception.GetType()
System.Exception.Data
System.Exception.InnerException
System.Exception.TargetSite
System.Exception.StackTrace
System.Exception.HelpLink
System.Exception.Source
System.Exception.HResult
System.Exception.SerializeObjectState
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation
Assembly: fcSDK.dll
Syntax
public class FCInvalidLoginException : FoundationException, _Exception, ISerializable

Constructors

FCInvalidLoginException(Int32, String)

Declaration
public FCInvalidLoginException(int errorId, string username)
Parameters
Type | Name | Description
System.Int32 | errorId |
System.String | username |

FCInvalidLoginException(SerializationInfo, StreamingContext)

Declaration
protected FCInvalidLoginException(SerializationInfo info, StreamingContext context)
Parameters
Type | Name | Description
System.Runtime.Serialization.SerializationInfo | info |
System.Runtime.Serialization.StreamingContext | context |

Implements

System.Runtime.InteropServices._Exception
System.Runtime.Serialization.ISerializable


Class FCSession | fcSDK Documentation

Class FCSession

Inheritance
System.Object
FCSession
ClarifySession
Implements
System.IDisposable
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation
Assembly: fcSDK.dll
Syntax
public abstract class FCSession : IDisposable

Constructors

FCSession()

Declaration
protected FCSession()

FCSession(FCSessionData)

Declaration
protected FCSession(FCSessionData data)
Parameters
Type | Name | Description
FCSessionData | data |

FCSession(FCSessionData, String, Int32)

Declaration
protected FCSession(FCSessionData data, string userName, int loginType)
Parameters
Type | Name | Description
FCSessionData | data |
System.String | userName |
System.Int32 | loginType |

FCSession(FCSessionData, String, String, Int32)

Declaration
protected FCSession(FCSessionData data, string userName, string password, int loginType)
Parameters
Type | Name | Description
FCSessionData | data |
System.String | userName |
System.String | password |
System.Int32 | loginType |

Properties

ConfigItems

Declaration
public ConfigItemCollection ConfigItems { get; }
Property Value
Type | Description
ConfigItemCollection |

ConvertTimeZone

Declaration
public bool ConvertTimeZone { get; set; }
Property Value
Type | Description
System.Boolean |

CreationTime

Declaration
public DateTime CreationTime { get; }
Property Value
Type | Description
System.DateTime |

CurrentCulture

Declaration
public CultureInfo CurrentCulture { get; set; }
Property Value
Type | Description
System.Globalization.CultureInfo |

DataRestrictionsEnabled

Declaration
public bool DataRestrictionsEnabled { get; set; }
Property Value
Type | Description
System.Boolean |

DefaultCulture

Declaration
public CultureInfo DefaultCulture { get; }
Property Value
Type | Description
System.Globalization.CultureInfo |

DefaultDistinctGenerics

Declaration
public bool DefaultDistinctGenerics { get; set; }
Property Value
Type | Description
System.Boolean |

DisableDataConversions

Declaration
public bool DisableDataConversions { get; set; }
Property Value
Type | Description
System.Boolean |

IncludeRelations

Declaration
public bool IncludeRelations { get; set; }
Property Value
Type | Description
System.Boolean |

Item[String]

Declaration
public object this[string key] { get; set; }
Parameters
Type | Name | Description
System.String | key |
Property Value
Type | Description
System.Object |

Items

Declaration
public IDictionary Items { get; }
Property Value
Type | Description
System.Collections.IDictionary |

LastLoadTime

Declaration
public DateTime LastLoadTime { get; }
Property Value
Type | Description
System.DateTime |

LocalTimeZone

Declaration
public ITimeZone LocalTimeZone { get; set; }
Property Value
Type | Description
ITimeZone |

Log

Declaration
public Logger Log { get; }
Property Value
Type | Description
Logger |

LoginType

Declaration
public int LoginType { get; }
Property Value
Type | Description
System.Int32 |

MaximumRows

Declaration
public int MaximumRows { get; set; }
Property Value
Type | Description
System.Int32 |

PasswordRequired

Declaration
public bool PasswordRequired { get; }
Property Value
Type | Description
System.Boolean |

QueryEmptyToNull

Declaration
public bool QueryEmptyToNull { get; set; }
Property Value
Type | Description
System.Boolean |

RestrictionGroup

Declaration
public RestrictionGroup RestrictionGroup { get; }
Property Value
Type | Description
RestrictionGroup |

SessionData

Declaration
public FCSessionData SessionData { get; }
Property Value
Type | Description
FCSessionData |

SessionID

Declaration
public Guid SessionID { get; }
Property Value
Type | Description
System.Guid |

SetNullStringsToEmpty

Declaration
public bool SetNullStringsToEmpty { get; set; }
Property Value
Type | Description
System.Boolean |

TimeZoneConversions

Declaration
public ExcludedColumns TimeZoneConversions { get; set; }
Property Value
Type | Description
ExcludedColumns |

TruncateStringFields

Declaration
public bool TruncateStringFields { get; set; }
Property Value
Type | Description
System.Boolean |

UserID

Declaration
public object UserID { get; }
Property Value
Type | Description
System.Object |

UserName

Declaration
public string UserName { get; }
Property Value
Type | Description
System.String |

Methods

_GetNextDataTableId()

Declaration
protected string _GetNextDataTableId()
Returns
Type | Description
System.String |

ChangePassword(String)

Declaration
public void ChangePassword(string newPassword)
Parameters
Type | Name | Description
System.String | newPassword |

ChangeRestrictionGroup(String, Boolean)

Declaration
public virtual void ChangeRestrictionGroup(string newGroupName, bool saveChange)
Parameters
Type | Name | Description
System.String | newGroupName |
System.Boolean | saveChange |

CloseSession()

Declaration
public void CloseSession()

CloseSession(Boolean)

Declaration
protected void CloseSession(bool nullDataReference)
Parameters
Type | Name | Description
System.Boolean | nullDataReference |

ConvertDate(DateTime, ITimeZone, ITimeZone)

Declaration
public virtual DateTime ConvertDate(DateTime date, ITimeZone fromTZ, ITimeZone toTZ)
Parameters
Type | Name | Description
System.DateTime | date |
ITimeZone | fromTZ |
ITimeZone | toTZ |
Returns
Type | Description
System.DateTime |

ConvertDate(DateTime, String, String)

Declaration
public virtual DateTime ConvertDate(DateTime date, string fromTZName, string toTZName)
Parameters
Type | Name | Description
System.DateTime | date |
System.String | fromTZName |
System.String | toTZName |
Returns
Type | Description
System.DateTime |

ConvertFromLocalToServerDate(DateTime)

Declaration
public virtual DateTime ConvertFromLocalToServerDate(DateTime date)
Parameters
Type | Name | Description
System.DateTime | date |
Returns
Type | Description
System.DateTime |

ConvertFromServerToLocalDate(DateTime)

Declaration
public virtual DateTime ConvertFromServerToLocalDate(DateTime date)
Parameters
Type | Name | Description
System.DateTime | date |
Returns
Type | Description
System.DateTime |

Dispose()

Declaration
public virtual void Dispose()

FormatElapsedTime(Double)

Declaration
public virtual string FormatElapsedTime(double elapsedTime)
Parameters
Type | Name | Description
System.Double | elapsedTime |
Returns
Type | Description
System.String |

FormatElapsedTime(Int32)

Declaration
public virtual string FormatElapsedTime(int elapsedTime)
Parameters
Type | Name | Description
System.Int32 | elapsedTime |
Returns
Type | Description
System.String |

FormatElapsedTime(TimeSpan)

Declaration
public virtual string FormatElapsedTime(TimeSpan ts)
Parameters
Type | Name | Description
System.TimeSpan | ts |
Returns
Type | Description
System.String |

GetAssignedPermissions()

Declaration
public virtual string[] GetAssignedPermissions()
Returns
Type | Description
System.String[] |

GetCurrentDate()

Declaration
public virtual DateTime GetCurrentDate()
Returns
Type | Description
System.DateTime |

GetCurrentServerDate()

Declaration
public virtual DateTime GetCurrentServerDate()
Returns
Type | Description
System.DateTime |

GetRestrictionGroupForUser(Object)

Declaration
protected abstract RestrictionGroup GetRestrictionGroupForUser(object UserID)
Parameters
Type | Name | Description
System.Object | UserID |
Returns
Type | Description
RestrictionGroup |

HasPermission(String)

Declaration
public virtual bool HasPermission(string permission)
Parameters
Type | Name | Description
System.String | permission |
Returns
Type | Description
System.Boolean |

InitializeSession(FCSessionData)

Declaration
protected virtual void InitializeSession(FCSessionData data)
Parameters
Type | Name | Description
FCSessionData | data |

LoadSessionDataFromApplicationCache(Guid)

Declaration
protected static FCSessionData LoadSessionDataFromApplicationCache(Guid sessionId)
Parameters
Type | Name | Description
System.Guid | sessionId |
Returns
Type | Description
FCSessionData |

LoginFromApp()

Declaration
protected void LoginFromApp()

LoginInternal(String, String, Int32, Boolean, Boolean, Boolean)

Declaration
protected void LoginInternal(string inUsername, string password, int inLoginType, bool isLoginTypeSpecified, bool passwordRequired, bool cleanupOnError)
Parameters
Type | Name | Description
System.String | inUsername |
System.String | password |
System.Int32 | inLoginType |
System.Boolean | isLoginTypeSpecified |
System.Boolean | passwordRequired |
System.Boolean | cleanupOnError |

PerformChangePassword(String, String, Int32)

Declaration
protected abstract void PerformChangePassword(string username, string newPassword, int LoginType)
Parameters
Type | Name | Description
System.String | username |
System.String | newPassword |
System.Int32 | LoginType |

PerformChangeResGroup(String, Boolean)

Declaration
protected abstract RestrictionGroup PerformChangeResGroup(string newGroup, bool saveToDb)
Parameters
Type | Name | Description
System.String | newGroup |
System.Boolean | saveToDb |
Returns
Type | Description
RestrictionGroup |

PerformConvertDate(DateTime, ITimeZone, ITimeZone)

Declaration
protected abstract DateTime PerformConvertDate(DateTime date, ITimeZone fromTZ, ITimeZone toTZ)
Parameters
Type | Name | Description
System.DateTime | date |
ITimeZone | fromTZ |
ITimeZone | toTZ |
Returns
Type | Description
System.DateTime |

PerformConvertDate(DateTime, String, String)

Declaration
protected abstract DateTime PerformConvertDate(DateTime date, string fromTZName, string toTZName)
Parameters
Type | Name | Description
System.DateTime | date |
System.String | fromTZName |
System.String | toTZName |
Returns
Type | Description
System.DateTime |

PerformLogin(String, Int32)

Declaration
protected abstract object PerformLogin(string inUsername, int inLoginType)
Parameters
Type | Name | Description
System.String | inUsername |
System.Int32 | inLoginType |
Returns
Type | Description
System.Object |

PerformLogin(String, String)

Declaration
protected abstract object PerformLogin(string inUsername, string password)
Parameters
Type | Name | Description
System.String | inUsername |
System.String | password |
Returns
Type | Description
System.Object |

PerformLogin(String, String, Int32)

Declaration
protected abstract object PerformLogin(string inUsername, string password, int inLoginType)
Parameters
Type | Name | Description
System.String | inUsername |
System.String | password |
System.Int32 | inLoginType |
Returns
Type | Description
System.Object |

PerformRefreshContext()

Declaration
protected abstract void PerformRefreshContext()

PerformSetPassword(String, String, Int32)

Declaration
protected abstract void PerformSetPassword(string username, string newPassword, int LoginType)
Parameters
Type | Name | Description
System.String | username |
System.String | newPassword |
System.Int32 | LoginType |

RefreshContext()

Declaration
public virtual void RefreshContext()

RegisterLicenseRequirements(Int32)

Declaration
public void RegisterLicenseRequirements(int productId)
Parameters
Type | Name | Description
System.Int32 | productId |

ResetSessionLoginStatus()

Declaration
protected virtual void ResetSessionLoginStatus()

SaveSession()

Declaration
public void SaveSession()

SetPassword(String, String, Int32)

Declaration
public void SetPassword(string inUsername, string newPass, int LoginType)
Parameters
Type | Name | Description
System.String | inUsername |
System.String | newPass |
System.Int32 | LoginType |

SetupSessionData(FCSessionData)

Declaration
protected abstract void SetupSessionData(FCSessionData data)
Parameters
Type | Name | Description
FCSessionData | data |

ShouldConvertToLocalDate(DateTime, DataColumn)

Declaration
public bool ShouldConvertToLocalDate(DateTime dateTimeValue, DataColumn column)
Parameters
Type | Name | Description
System.DateTime | dateTimeValue |
System.Data.DataColumn | column |
Returns
Type | Description
System.Boolean |

UpdateLastLogin(String)

Declaration
protected abstract void UpdateLastLogin(string inUsername)
Parameters
Type | Name | Description
System.String | inUsername |

Implements

System.IDisposable


Class FCSessionData | fcSDK Documentation

Class FCSessionData

Inheritance
System.Object
FCSessionData
ClarifySessionData
Implements
System.Runtime.Serialization.ISerializable
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation
Assembly: fcSDK.dll
Syntax
public abstract class FCSessionData : ISerializable

Constructors

FCSessionData()

Declaration
protected FCSessionData()

FCSessionData(SerializationInfo, StreamingContext)

Declaration
protected FCSessionData(SerializationInfo info, StreamingContext context)
Parameters
Type | Name | Description
System.Runtime.Serialization.SerializationInfo | info |
System.Runtime.Serialization.StreamingContext | context |

Fields

configItems

Declaration
protected ConfigItemCollection configItems
Field Value
Type | Description
ConfigItemCollection |

convertTimeZone

Declaration
protected bool convertTimeZone
Field Value
Type | Description
System.Boolean |

creationTime

Declaration
protected DateTime creationTime
Field Value
Type | Description
System.DateTime |

currentCulture

Declaration
protected CultureInfo currentCulture
Field Value
Type | Description
System.Globalization.CultureInfo |

curResGroup

Declaration
protected RestrictionGroup curResGroup
Field Value
Type | Description
RestrictionGroup |

DefaultCulture

Declaration
public static readonly CultureInfo DefaultCulture
Field Value
Type | Description
System.Globalization.CultureInfo |

defaultDistinct

Declaration
protected bool defaultDistinct
Field Value
Type | Description
System.Boolean |

disableDataConversion

Declaration
protected bool disableDataConversion
Field Value
Type | Description
System.Boolean |

disableRestrictions

Declaration
protected bool disableRestrictions
Field Value
Type | Description
System.Boolean |

emptyNullStrings

Declaration
protected bool emptyNullStrings
Field Value
Type | Description
System.Boolean |

includeRelations

Declaration
protected bool includeRelations
Field Value
Type | Description
System.Boolean |

isSessionDirty

Declaration
protected bool isSessionDirty
Field Value
Type | Description
System.Boolean |

lastLoadTime

Declaration
protected DateTime lastLoadTime
Field Value
Type | Description
System.DateTime |

localTimeZone

Declaration
protected ITimeZone localTimeZone
Field Value
Type | Description
ITimeZone |

loginTime

Declaration
protected DateTime? loginTime
Field Value
Type | Description
System.Nullable<System.DateTime> |

loginType

Declaration
protected int loginType
Field Value
Type | Description
System.Int32 |

maximumRows

Declaration
protected int maximumRows
Field Value
Type | Description
System.Int32 |

newSession

Declaration
protected bool newSession
Field Value
Type | Description
System.Boolean |

passwordRequired

Declaration
protected bool passwordRequired
Field Value
Type | Description
System.Boolean |

permissions

Declaration
protected IDictionary<string, bool> permissions
Field Value
Type | Description
System.Collections.Generic.IDictionary<System.String, System.Boolean> |

queryEmptyToNull

Declaration
protected bool queryEmptyToNull
Field Value
Type | Description
System.Boolean |

restrictionsEnabled

Declaration
protected bool restrictionsEnabled
Field Value
Type | Description
System.Boolean |

sessionData

Declaration
protected Hashtable sessionData
Field Value
Type | Description
System.Collections.Hashtable |

sessionID

Declaration
protected Guid sessionID
Field Value
Type | Description
System.Guid |

timeZoneConversions

Declaration
protected ExcludedColumns timeZoneConversions
Field Value
Type | Description
ExcludedColumns |

truncateStringFields

Declaration
protected bool truncateStringFields
Field Value
Type | Description
System.Boolean |

userID

Declaration
protected object userID
Field Value
Type | Description
System.Object |

username

Declaration
protected string username
Field Value
Type | Description
System.String |

Properties

ConfigItems

Declaration
public ConfigItemCollection ConfigItems { get; set; }
Property Value
Type | Description
ConfigItemCollection |

ConvertTimeZone

Declaration
public bool ConvertTimeZone { get; set; }
Property Value
Type | Description
System.Boolean |

CreationTime

Declaration
public DateTime CreationTime { get; }
Property Value
Type | Description
System.DateTime |

CurrentCulture

Declaration
public CultureInfo CurrentCulture { get; set; }
Property Value
Type | Description
System.Globalization.CultureInfo |

CurResGroup

Declaration
public RestrictionGroup CurResGroup { get; set; }
Property Value
Type | Description
RestrictionGroup |

DefaultDistinctGenerics

Declaration
public bool DefaultDistinctGenerics { get; set; }
Property Value
Type | Description
System.Boolean |

DisableDataConversion

Declaration
public bool DisableDataConversion { get; set; }
Property Value
Type | Description
System.Boolean |

DisableRestrictions

Declaration
public bool DisableRestrictions { get; set; }
Property Value
Type | Description
System.Boolean |

EmptyNullStrings

Declaration
public bool EmptyNullStrings { get; set; }
Property Value
Type | Description
System.Boolean |

IncludeRelations

Declaration
public bool IncludeRelations { get; set; }
Property Value
Type | Description
System.Boolean |

IsDirty

Declaration
public bool IsDirty { get; set; }
Property Value
Type | Description
System.Boolean |

LastLoadTime

Declaration
public DateTime LastLoadTime { get; set; }
Property Value
Type | Description
System.DateTime |

LocalTimeZone

Declaration
public ITimeZone LocalTimeZone { get; set; }
Property Value
Type | Description
ITimeZone |

LoginTime

Declaration
public DateTime? LoginTime { get; set; }
Property Value
Type | Description
System.Nullable<System.DateTime> |

LoginType

Declaration
public int LoginType { get; set; }
Property Value
Type | Description
System.Int32 |

MaximumRows

Declaration
public int MaximumRows { get; set; }
Property Value
Type | Description
System.Int32 |

NewSession

Declaration
public bool NewSession { get; set; }
Property Value
Type | Description
System.Boolean |

PasswordRequired

Declaration
public bool PasswordRequired { get; set; }
Property Value
Type | Description
System.Boolean |

Permissions

Declaration
public IDictionary<string, bool> Permissions { get; }
Property Value
Type | Description
System.Collections.Generic.IDictionary<System.String, System.Boolean> |

QueryEmptyToNull

Declaration
public bool QueryEmptyToNull { get; set; }
Property Value
Type | Description
System.Boolean |

SessionData

Declaration
public Hashtable SessionData { get; }
Property Value
Type | Description
System.Collections.Hashtable |

SessionID

Declaration
public Guid SessionID { get; set; }
Property Value
Type | Description
System.Guid |

TimeZoneConversions

Declaration
public ExcludedColumns TimeZoneConversions { get; set; }
Property Value
Type | Description
ExcludedColumns |

TruncateStringFields

Declaration
public bool TruncateStringFields { get; set; }
Property Value
Type | Description
System.Boolean |

UserID

Declaration
public object UserID { get; set; }
Property Value
Type | Description
System.Object |

UserName

Declaration
public string UserName { get; set; }
Property Value
Type | Description
System.String |

Methods

CopyTo(FCSessionData)

Declaration
public virtual void CopyTo(FCSessionData newData)
Parameters
Type | Name | Description
FCSessionData | newData |

LoadConfigItems(Object[][])

Declaration
protected abstract ConfigItemCollection LoadConfigItems(object[][] itemValues)
Parameters
Type | Name | Description
System.Object[][] | itemValues |
Returns
Type | Description
ConfigItemCollection |

LoadTimeZone(String)

Declaration
protected abstract ITimeZone LoadTimeZone(string shortTzName)
Parameters
Type | Name | Description
System.String | shortTzName |
Returns
Type | Description
ITimeZone |

SerializeObjectData(SerializationInfo, StreamingContext)

Declaration
protected virtual void SerializeObjectData(SerializationInfo info, StreamingContext context)
Parameters
Type | Name | Description
System.Runtime.Serialization.SerializationInfo | info |
System.Runtime.Serialization.StreamingContext | context |

Explicit Interface Implementations

ISerializable.GetObjectData(SerializationInfo, StreamingContext)

Declaration
void ISerializable.GetObjectData(SerializationInfo info, StreamingContext context)
Parameters
Type | Name | Description
System.Runtime.Serialization.SerializationInfo | info |
System.Runtime.Serialization.StreamingContext | context |

Implements

System.Runtime.Serialization.ISerializable


Class FCSessionSummary | fcSDK Documentation

Class FCSessionSummary

Inheritance
System.Object
FCSessionSummary
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation
Assembly: fcSDK.dll
Syntax
public class FCSessionSummary

Fields

sessionID

Declaration
protected Guid sessionID
Field Value
Type | Description
System.Guid |

Properties

CreationTime

Declaration
public DateTime CreationTime { get; }
Property Value
Type | Description
System.DateTime |

LastLoadTime

Declaration
public DateTime LastLoadTime { get; }
Property Value
Type | Description
System.DateTime |

LoginType

Declaration
public int LoginType { get; }
Property Value
Type | Description
System.Int32 |

SessionID

Declaration
public Guid SessionID { get; }
Property Value
Type | Description
System.Guid |

UserID

Declaration
public object UserID { get; }
Property Value
Type | Description
System.Object |

UserName

Declaration
public string UserName { get; }
Property Value
Type | Description
System.String |


Namespace FChoice.Foundation.Filters | fcSDK Documentation

Namespace FChoice.Foundation.Filters

Classes

AfterFilter

AndFilter

AndManyFilter

BeforeFilter

BetweenFilter

ColumnBasedFilter

ContainsFilter

EndsWithFilter

EqualsFilter

Filter

FilterCollection

FilterExpression

FilterType

IsInFilter

IsNullFilter

LessThanFilter

LessThanOrEqualFilter

LikeFilter

LogicalFilter

MoreThanFilter

MoreThanOrEqualFilter

NotContainsFilter

NotEndsWithFilter

NotLikeFilter

NotStartsWithFilter

OlderThanDaysFilter

OlderThanHoursFilter

OnFilter

OperationFilter

OrFilter

OrManyFilter

SoundsLikeFilter

StartsWithFilter

TodayFilter

TomorrowFilter

WithinDaysFilter

WithinHoursFilter

YesterdayFilter

Back to top © 2022 Dovetail Software, Inc. - All rights reserved.
Clarify, Amdocs, and related products and names are copyright and trademark of Amdocs, Inc.
.NET, Visual Studio.NET, C#, Visual Basic and related products are trademark of Microsoft corporation.


Class AfterFilter | fcSDK Documentation

Class AfterFilter

Inheritance
System.Object
Filter
ColumnBasedFilter
OperationFilter
MoreThanFilter
AfterFilter
Inherited Members
MoreThanFilter.Operator
OperationFilter.PerformValidateFilter(FCSession, FCGeneric)
OperationFilter.PerformRender(FCSession, FCGeneric, SqlHelper)
OperationFilter.FormatOperation(FCGeneric, String, String, SqlHelper, Object)
OperationFilter.Value
ColumnBasedFilter.GetColumnNameForRender(FCGeneric)
ColumnBasedFilter.ColumnName
Filter.ValidateFilter(FCSession, FCGeneric)
Filter.Render(FCSession, FCGeneric, SqlHelper)
Filter.GetActualDateValue(FCSession, Object)
Filter.ConvertDate(FCSession, DateTime, Boolean)
Filter.ValidateDate(DateTime)
Filter.ValidateValidField(FCGeneric, String)
Filter.ValidateValidField(FCGeneric, String, Boolean)
Filter.ValidateIsIntegerField(FCGeneric, String)
Filter.ValidateIsDecimalField(FCGeneric, String)
Filter.ValidateIsDateField(FCGeneric, String)
Filter.ValidateIsStringField(FCGeneric, String)
Filter.SetParameterValue(FCGeneric, SqlHelper, String, String, Object)
Filter.Session
Filter.Generic
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Filters
Assembly: fcSDK.dll
Syntax
public class AfterFilter : MoreThanFilter

Constructors

AfterFilter(String, Filter)

Declaration
protected AfterFilter(string columnName, Filter value)
Parameters
Type | Name | Description
System.String | columnName |
Filter | value |

AfterFilter(String, DateTime)

Declaration
protected AfterFilter(string columnName, DateTime value)
Parameters
Type | Name | Description
System.String | columnName |
System.DateTime | value |

Methods

GetValueForRender(FCSession, FCGeneric, SqlHelper)

Declaration
protected override object GetValueForRender(FCSession sess, FCGeneric gen, SqlHelper dbHelper)
Parameters
Type | Name | Description
FCSession | sess |
FCGeneric | gen |
SqlHelper | dbHelper |
Returns
Type | Description
System.Object |
Overrides
OperationFilter.GetValueForRender(FCSession, FCGeneric, SqlHelper)


Class AndFilter | fcSDK Documentation

Class AndFilter

Inheritance
System.Object
Filter
LogicalFilter
AndFilter
Inherited Members
LogicalFilter.AddFilter(Filter)
LogicalFilter.PerformValidateFilter(FCSession, FCGeneric)
LogicalFilter.PerformRender(FCSession, FCGeneric, SqlHelper)
LogicalFilter.Filters
Filter.ValidateFilter(FCSession, FCGeneric)
Filter.Render(FCSession, FCGeneric, SqlHelper)
Filter.GetActualDateValue(FCSession, Object)
Filter.ConvertDate(FCSession, DateTime, Boolean)
Filter.ValidateDate(DateTime)
Filter.ValidateValidField(FCGeneric, String)
Filter.ValidateValidField(FCGeneric, String, Boolean)
Filter.ValidateIsIntegerField(FCGeneric, String)
Filter.ValidateIsDecimalField(FCGeneric, String)
Filter.ValidateIsDateField(FCGeneric, String)
Filter.ValidateIsStringField(FCGeneric, String)
Filter.SetParameterValue(FCGeneric, SqlHelper, String, String, Object)
Filter.Session
Filter.Generic
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Filters
Assembly: fcSDK.dll
Syntax
public class AndFilter : LogicalFilter

Constructors

AndFilter(Filter, Filter)

Declaration
protected AndFilter(Filter filter1, Filter filter2)
Parameters
Type | Name | Description
Filter | filter1 |
Filter | filter2 |

Properties

Conjunction

Declaration
protected override string Conjunction { get; }
Property Value
Type | Description
System.String |
Overrides
LogicalFilter.Conjunction


Class AndManyFilter | fcSDK Documentation

Class AndManyFilter

Inheritance
System.Object
Filter
LogicalFilter
AndManyFilter
Inherited Members
LogicalFilter.AddFilter(Filter)
LogicalFilter.PerformValidateFilter(FCSession, FCGeneric)
LogicalFilter.PerformRender(FCSession, FCGeneric, SqlHelper)
LogicalFilter.Filters
Filter.ValidateFilter(FCSession, FCGeneric)
Filter.Render(FCSession, FCGeneric, SqlHelper)
Filter.GetActualDateValue(FCSession, Object)
Filter.ConvertDate(FCSession, DateTime, Boolean)
Filter.ValidateDate(DateTime)
Filter.ValidateValidField(FCGeneric, String)
Filter.ValidateValidField(FCGeneric, String, Boolean)
Filter.ValidateIsIntegerField(FCGeneric, String)
Filter.ValidateIsDecimalField(FCGeneric, String)
Filter.ValidateIsDateField(FCGeneric, String)
Filter.ValidateIsStringField(FCGeneric, String)
Filter.SetParameterValue(FCGeneric, SqlHelper, String, String, Object)
Filter.Session
Filter.Generic
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Filters
Assembly: fcSDK.dll
Syntax
public class AndManyFilter : LogicalFilter

Constructors

AndManyFilter(Filter[])

Declaration
protected AndManyFilter(params Filter[] filters)
Parameters
Type | Name | Description
Filter[] | filters |

Properties

Conjunction

Declaration
protected override string Conjunction { get; }
Property Value
Type | Description
System.String |
Overrides
LogicalFilter.Conjunction


Class BeforeFilter | fcSDK Documentation

Class BeforeFilter

Inheritance
System.Object
Filter
ColumnBasedFilter
OperationFilter
LessThanFilter
BeforeFilter
Inherited Members
LessThanFilter.Operator
OperationFilter.PerformValidateFilter(FCSession, FCGeneric)
OperationFilter.PerformRender(FCSession, FCGeneric, SqlHelper)
OperationFilter.FormatOperation(FCGeneric, String, String, SqlHelper, Object)
OperationFilter.Value
ColumnBasedFilter.GetColumnNameForRender(FCGeneric)
ColumnBasedFilter.ColumnName
Filter.ValidateFilter(FCSession, FCGeneric)
Filter.Render(FCSession, FCGeneric, SqlHelper)
Filter.GetActualDateValue(FCSession, Object)
Filter.ConvertDate(FCSession, DateTime, Boolean)
Filter.ValidateDate(DateTime)
Filter.ValidateValidField(FCGeneric, String)
Filter.ValidateValidField(FCGeneric, String, Boolean)
Filter.ValidateIsIntegerField(FCGeneric, String)
Filter.ValidateIsDecimalField(FCGeneric, String)
Filter.ValidateIsDateField(FCGeneric, String)
Filter.ValidateIsStringField(FCGeneric, String)
Filter.SetParameterValue(FCGeneric, SqlHelper, String, String, Object)
Filter.Session
Filter.Generic
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Filters
Assembly: fcSDK.dll
Syntax
public class BeforeFilter : LessThanFilter

Constructors

BeforeFilter(String, Filter)

Declaration
protected BeforeFilter(string columnName, Filter value)
Parameters
Type | Name | Description
System.String | columnName |
Filter | value |

BeforeFilter(String, DateTime)

Declaration
protected BeforeFilter(string columnName, DateTime value)
Parameters
Type | Name | Description
System.String | columnName |
System.DateTime | value |

Methods

GetValueForRender(FCSession, FCGeneric, SqlHelper)

Declaration
protected override object GetValueForRender(FCSession sess, FCGeneric gen, SqlHelper dbHelper)
Parameters
Type | Name | Description
FCSession | sess |
FCGeneric | gen |
SqlHelper | dbHelper |
Returns
Type | Description
System.Object |
Overrides
OperationFilter.GetValueForRender(FCSession, FCGeneric, SqlHelper)


Class BetweenFilter | fcSDK Documentation

Class BetweenFilter

Inheritance
System.Object
Filter
ColumnBasedFilter
BetweenFilter
OnFilter
WithinDaysFilter
WithinHoursFilter
YesterdayFilter
Inherited Members
ColumnBasedFilter.GetColumnNameForRender(FCGeneric)
ColumnBasedFilter.ColumnName
Filter.ValidateFilter(FCSession, FCGeneric)
Filter.Render(FCSession, FCGeneric, SqlHelper)
Filter.GetActualDateValue(FCSession, Object)
Filter.ConvertDate(FCSession, DateTime, Boolean)
Filter.ValidateDate(DateTime)
Filter.ValidateValidField(FCGeneric, String)
Filter.ValidateValidField(FCGeneric, String, Boolean)
Filter.ValidateIsIntegerField(FCGeneric, String)
Filter.ValidateIsDecimalField(FCGeneric, String)
Filter.ValidateIsDateField(FCGeneric, String)
Filter.ValidateIsStringField(FCGeneric, String)
Filter.SetParameterValue(FCGeneric, SqlHelper, String, String, Object)
Filter.Session
Filter.Generic
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Filters
Assembly: fcSDK.dll
Syntax
public class BetweenFilter : ColumnBasedFilter

Constructors

BetweenFilter(String, Boolean, DateTime, Filter)

Declaration
protected BetweenFilter(string columnName, bool isBetween, DateTime value1, Filter value2)
Parameters
Type | Name | Description
System.String | columnName |
System.Boolean | isBetween |
System.DateTime | value1 |
Filter | value2 |

BetweenFilter(String, Boolean, DateTime, DateTime)

Declaration
protected BetweenFilter(string columnName, bool isBetween, DateTime value1, DateTime value2)
Parameters
Type | Name | Description
System.String | columnName |
System.Boolean | isBetween |
System.DateTime | value1 |
System.DateTime | value2 |

BetweenFilter(String, Boolean, Decimal, Filter)

Declaration
protected BetweenFilter(string columnName, bool isBetween, decimal value1, Filter value2)
Parameters
Type | Name | Description
System.String | columnName |
System.Boolean | isBetween |
System.Decimal | value1 |
Filter | value2 |

BetweenFilter(String, Boolean, Decimal, Decimal)

Declaration
protected BetweenFilter(string columnName, bool isBetween, decimal value1, decimal value2)
Parameters
Type | Name | Description
System.String | columnName |
System.Boolean | isBetween |
System.Decimal | value1 |
System.Decimal | value2 |

BetweenFilter(String, Boolean, Int32, Filter)

Declaration
protected BetweenFilter(string columnName, bool isBetween, int value1, Filter value2)
Parameters
Type | Name | Description
System.String | columnName |
System.Boolean | isBetween |
System.Int32 | value1 |
Filter | value2 |

BetweenFilter(String, Boolean, Int32, Int32)

Declaration
protected BetweenFilter(string columnName, bool isBetween, int value1, int value2)
Parameters
Type | Name | Description
System.String | columnName |
System.Boolean | isBetween |
System.Int32 | value1 |
System.Int32 | value2 |

BetweenFilter(String, Boolean, Object, Object)

Declaration
protected BetweenFilter(string columnName, bool isBetween, object value1, object value2)
Parameters
Type | Name | Description
System.String | columnName |
System.Boolean | isBetween |
System.Object | value1 |
System.Object | value2 |

BetweenFilter(String, Boolean, String, Filter)

Declaration
protected BetweenFilter(string columnName, bool isBetween, string value1, Filter value2)
Parameters
Type | Name | Description
System.String | columnName |
System.Boolean | isBetween |
System.String | value1 |
Filter | value2 |

BetweenFilter(String, Boolean, String, String)

Declaration
protected BetweenFilter(string columnName, bool isBetween, string value1, string value2)
Parameters
Type | Name | Description
System.String | columnName |
System.Boolean | isBetween |
System.String | value1 |
System.String | value2 |

Fields

FILTER_BETWEEN

Declaration
protected const string FILTER_BETWEEN = "BETWEEN"
Field Value
Type | Description
System.String |

FILTER_NOT_BETWEEN

Declaration
protected const string FILTER_NOT_BETWEEN = "NOT BETWEEN"
Field Value
Type | Description
System.String |

Properties

IsBetween

Declaration
public bool IsBetween { get; }
Property Value
Type | Description
System.Boolean |

Value1

Declaration
public object Value1 { get; }
Property Value
Type | Description
System.Object |

Value1Present

Declaration
public bool Value1Present { get; }
Property Value
Type | Description
System.Boolean |

Value2

Declaration
public object Value2 { get; }
Property Value
Type | Description
System.Object |

Value2Present

Declaration
public bool Value2Present { get; }
Property Value
Type | Description
System.Boolean |

Methods

GetValue1ForRender(FCSession, FCGeneric, SqlHelper)

Declaration
protected virtual object GetValue1ForRender(FCSession sess, FCGeneric gen, SqlHelper dbHelper)
Parameters
Type | Name | Description
FCSession | sess |
FCGeneric | gen |
SqlHelper | dbHelper |
Returns
Type | Description
System.Object |

GetValue2ForRender(FCSession, FCGeneric, SqlHelper)

Declaration
protected virtual object GetValue2ForRender(FCSession sess, FCGeneric gen, SqlHelper dbHelper)
Parameters
Type | Name | Description
FCSession | sess |
FCGeneric | gen |
SqlHelper | dbHelper |
Returns
Type | Description
System.Object |

PerformRender(FCSession, FCGeneric, SqlHelper)

Declaration
protected override string PerformRender(FCSession sess, FCGeneric gen, SqlHelper dbHelper)
Parameters
Type | Name | Description
FCSession | sess |
FCGeneric | gen |
SqlHelper | dbHelper |
Returns
Type | Description
System.String |
Overrides
Filter.PerformRender(FCSession, FCGeneric, SqlHelper)

PerformValidateFilter(FCSession, FCGeneric)

Declaration
protected override void PerformValidateFilter(FCSession session, FCGeneric gen)
Parameters
Type | Name | Description
FCSession | session |
FCGeneric | gen |
Overrides
Filter.PerformValidateFilter(FCSession, FCGeneric)

ValidateOperand(FCGeneric, Object)

Declaration
protected virtual void ValidateOperand(FCGeneric gen, object value)
Parameters
Type | Name | Description
FCGeneric | gen |
System.Object | value |


Class ColumnBasedFilter | fcSDK Documentation

Class ColumnBasedFilter

Inheritance
System.Object
Filter
ColumnBasedFilter
BetweenFilter
IsInFilter
IsNullFilter
OperationFilter
SoundsLikeFilter
Inherited Members
Filter.ValidateFilter(FCSession, FCGeneric)
Filter.PerformValidateFilter(FCSession, FCGeneric)
Filter.Render(FCSession, FCGeneric, SqlHelper)
Filter.PerformRender(FCSession, FCGeneric, SqlHelper)
Filter.GetActualDateValue(FCSession, Object)
Filter.ConvertDate(FCSession, DateTime, Boolean)
Filter.ValidateDate(DateTime)
Filter.ValidateValidField(FCGeneric, String)
Filter.ValidateValidField(FCGeneric, String, Boolean)
Filter.ValidateIsIntegerField(FCGeneric, String)
Filter.ValidateIsDecimalField(FCGeneric, String)
Filter.ValidateIsDateField(FCGeneric, String)
Filter.ValidateIsStringField(FCGeneric, String)
Filter.SetParameterValue(FCGeneric, SqlHelper, String, String, Object)
Filter.Session
Filter.Generic
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Filters
Assembly: fcSDK.dll
Syntax
public abstract class ColumnBasedFilter : Filter

Constructors

ColumnBasedFilter(String)

Declaration
protected ColumnBasedFilter(string columnName)
Parameters
Type | Name | Description
System.String | columnName |

Properties

ColumnName

Declaration
public string ColumnName { get; }
Property Value
Type | Description
System.String |

Methods

GetColumnNameForRender(FCGeneric)

Declaration
protected string GetColumnNameForRender(FCGeneric gen)
Parameters
Type | Name | Description
FCGeneric | gen |
Returns
Type | Description
System.String |


Class ContainsFilter | fcSDK Documentation

Class ContainsFilter

Inheritance
System.Object
Filter
ColumnBasedFilter
OperationFilter
LikeFilter
ContainsFilter
Inherited Members
LikeFilter.PerformRender(FCSession, FCGeneric, SqlHelper)
LikeFilter.Operator
OperationFilter.PerformValidateFilter(FCSession, FCGeneric)
OperationFilter.FormatOperation(FCGeneric, String, String, SqlHelper, Object)
OperationFilter.Value
ColumnBasedFilter.GetColumnNameForRender(FCGeneric)
ColumnBasedFilter.ColumnName
Filter.ValidateFilter(FCSession, FCGeneric)
Filter.Render(FCSession, FCGeneric, SqlHelper)
Filter.GetActualDateValue(FCSession, Object)
Filter.ConvertDate(FCSession, DateTime, Boolean)
Filter.ValidateDate(DateTime)
Filter.ValidateValidField(FCGeneric, String)
Filter.ValidateValidField(FCGeneric, String, Boolean)
Filter.ValidateIsIntegerField(FCGeneric, String)
Filter.ValidateIsDecimalField(FCGeneric, String)
Filter.ValidateIsDateField(FCGeneric, String)
Filter.ValidateIsStringField(FCGeneric, String)
Filter.SetParameterValue(FCGeneric, SqlHelper, String, String, Object)
Filter.Session
Filter.Generic
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Filters
Assembly: fcSDK.dll
Syntax
public class ContainsFilter : LikeFilter

Constructors

ContainsFilter(String, Filter)

Declaration
protected ContainsFilter(string columnName, Filter value)
Parameters
Type | Name | Description
System.String | columnName |
Filter | value |

ContainsFilter(String, String)

Declaration
protected ContainsFilter(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |

Methods

GetValueForRender(FCSession, FCGeneric, SqlHelper)

Declaration
protected override object GetValueForRender(FCSession sess, FCGeneric gen, SqlHelper dbHelper)
Parameters
Type | Name | Description
FCSession | sess |
FCGeneric | gen |
SqlHelper | dbHelper |
Returns
Type | Description
System.Object |
Overrides
OperationFilter.GetValueForRender(FCSession, FCGeneric, SqlHelper)


Class EndsWithFilter | fcSDK Documentation

Class EndsWithFilter

Inheritance
System.Object
Filter
ColumnBasedFilter
OperationFilter
LikeFilter
EndsWithFilter
Inherited Members
LikeFilter.PerformRender(FCSession, FCGeneric, SqlHelper)
LikeFilter.Operator
OperationFilter.PerformValidateFilter(FCSession, FCGeneric)
OperationFilter.FormatOperation(FCGeneric, String, String, SqlHelper, Object)
OperationFilter.Value
ColumnBasedFilter.GetColumnNameForRender(FCGeneric)
ColumnBasedFilter.ColumnName
Filter.ValidateFilter(FCSession, FCGeneric)
Filter.Render(FCSession, FCGeneric, SqlHelper)
Filter.GetActualDateValue(FCSession, Object)
Filter.ConvertDate(FCSession, DateTime, Boolean)
Filter.ValidateDate(DateTime)
Filter.ValidateValidField(FCGeneric, String)
Filter.ValidateValidField(FCGeneric, String, Boolean)
Filter.ValidateIsIntegerField(FCGeneric, String)
Filter.ValidateIsDecimalField(FCGeneric, String)
Filter.ValidateIsDateField(FCGeneric, String)
Filter.ValidateIsStringField(FCGeneric, String)
Filter.SetParameterValue(FCGeneric, SqlHelper, String, String, Object)
Filter.Session
Filter.Generic
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Filters
Assembly: fcSDK.dll
Syntax
public class EndsWithFilter : LikeFilter

Constructors

EndsWithFilter(String, Filter)

Declaration
protected EndsWithFilter(string columnName, Filter value)
Parameters
Type | Name | Description
System.String | columnName |
Filter | value |

EndsWithFilter(String, String)

Declaration
protected EndsWithFilter(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |

Methods

GetValueForRender(FCSession, FCGeneric, SqlHelper)

Declaration
protected override object GetValueForRender(FCSession sess, FCGeneric gen, SqlHelper dbHelper)
Parameters
Type | Name | Description
FCSession | sess |
FCGeneric | gen |
SqlHelper | dbHelper |
Returns
Type | Description
System.Object |
Overrides
OperationFilter.GetValueForRender(FCSession, FCGeneric, SqlHelper)


Class EqualsFilter | fcSDK Documentation

Class EqualsFilter

Inheritance
System.Object
Filter
ColumnBasedFilter
OperationFilter
EqualsFilter
Inherited Members
OperationFilter.PerformValidateFilter(FCSession, FCGeneric)
OperationFilter.GetValueForRender(FCSession, FCGeneric, SqlHelper)
OperationFilter.FormatOperation(FCGeneric, String, String, SqlHelper, Object)
OperationFilter.Value
ColumnBasedFilter.GetColumnNameForRender(FCGeneric)
ColumnBasedFilter.ColumnName
Filter.ValidateFilter(FCSession, FCGeneric)
Filter.Render(FCSession, FCGeneric, SqlHelper)
Filter.GetActualDateValue(FCSession, Object)
Filter.ConvertDate(FCSession, DateTime, Boolean)
Filter.ValidateDate(DateTime)
Filter.ValidateValidField(FCGeneric, String)
Filter.ValidateValidField(FCGeneric, String, Boolean)
Filter.ValidateIsIntegerField(FCGeneric, String)
Filter.ValidateIsDecimalField(FCGeneric, String)
Filter.ValidateIsDateField(FCGeneric, String)
Filter.ValidateIsStringField(FCGeneric, String)
Filter.SetParameterValue(FCGeneric, SqlHelper, String, String, Object)
Filter.Session
Filter.Generic
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Filters
Assembly: fcSDK.dll
Syntax
public class EqualsFilter : OperationFilter

Constructors

EqualsFilter(Boolean, String, Filter)

Declaration
protected EqualsFilter(bool isEquals, string columnName, Filter value)
Parameters
Type | Name | Description
System.Boolean | isEquals |
System.String | columnName |
Filter | value |

EqualsFilter(Boolean, String, Boolean)

Declaration
protected EqualsFilter(bool isEquals, string columnName, bool value)
Parameters
Type | Name | Description
System.Boolean | isEquals |
System.String | columnName |
System.Boolean | value |

EqualsFilter(Boolean, String, DateTime)

Declaration
protected EqualsFilter(bool isEquals, string columnName, DateTime value)
Parameters
Type | Name | Description
System.Boolean | isEquals |
System.String | columnName |
System.DateTime | value |

EqualsFilter(Boolean, String, Decimal)

Declaration
protected EqualsFilter(bool isEquals, string columnName, decimal value)
Parameters
Type | Name | Description
System.Boolean | isEquals |
System.String | columnName |
System.Decimal | value |

EqualsFilter(Boolean, String, Int32)

Declaration
protected EqualsFilter(bool isEquals, string columnName, int value)
Parameters
Type | Name | Description
System.Boolean | isEquals |
System.String | columnName |
System.Int32 | value |

EqualsFilter(Boolean, String, Object)

Declaration
protected EqualsFilter(bool isEquals, string columnName, object value)
Parameters
Type | Name | Description
System.Boolean | isEquals |
System.String | columnName |
System.Object | value |

EqualsFilter(Boolean, String, String)

Declaration
protected EqualsFilter(bool isEquals, string columnName, string value)
Parameters
Type | Name | Description
System.Boolean | isEquals |
System.String | columnName |
System.String | value |

Fields

isEqualsOp

Declaration
protected bool isEqualsOp
Field Value
Type | Description
System.Boolean |

Properties

Operator

Declaration
public override string Operator { get; }
Property Value
Type | Description
System.String |
Overrides
OperationFilter.Operator

Methods

PerformRender(FCSession, FCGeneric, SqlHelper)

Declaration
protected override string PerformRender(FCSession fcSession, FCGeneric gen, SqlHelper dbHelper)
Parameters
Type | Name | Description
FCSession | fcSession |
FCGeneric | gen |
SqlHelper | dbHelper |
Returns
Type | Description
System.String |
Overrides
OperationFilter.PerformRender(FCSession, FCGeneric, SqlHelper)


Class Filter | fcSDK Documentation

Class Filter

Inheritance
System.Object
Filter
ColumnBasedFilter
LogicalFilter
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Filters
Assembly: fcSDK.dll
Syntax
public abstract class Filter

Constructors

Filter()

Declaration
protected Filter()

Properties

Generic

Declaration
protected FCGeneric Generic { get; }
Property Value
Type | Description
FCGeneric |

Session

Declaration
protected FCSession Session { get; }
Property Value
Type | Description
FCSession |

Methods

ConvertDate(FCSession, DateTime, out Boolean)

Declaration
protected static DateTime ConvertDate(FCSession fcSession, DateTime value, out bool isNowDate)
Parameters
Type | Name | Description
FCSession | fcSession |
System.DateTime | value |
System.Boolean | isNowDate |
Returns
Type | Description
System.DateTime |

GetActualDateValue(FCSession, Object)

Declaration
protected static DateTime GetActualDateValue(FCSession fcSession, object value)
Parameters
Type | Name | Description
FCSession | fcSession |
System.Object | value |
Returns
Type | Description
System.DateTime |

PerformRender(FCSession, FCGeneric, SqlHelper)

Declaration
protected abstract string PerformRender(FCSession fcSession, FCGeneric gen, SqlHelper dbHelper)
Parameters
Type | Name | Description
FCSession | fcSession |
FCGeneric | gen |
SqlHelper | dbHelper |
Returns
Type | Description
System.String |

PerformValidateFilter(FCSession, FCGeneric)

Declaration
protected abstract void PerformValidateFilter(FCSession session, FCGeneric gen)
Parameters
Type | Name | Description
FCSession | session |
FCGeneric | gen |

Render(FCSession, FCGeneric, SqlHelper)

Declaration
public virtual string Render(FCSession fcSession, FCGeneric gen, SqlHelper dbHelper)
Parameters
Type | Name | Description
FCSession | fcSession |
FCGeneric | gen |
SqlHelper | dbHelper |
Returns
Type | Description
System.String |

SetParameterValue(FCGeneric, SqlHelper, String, String, Object)

Declaration
protected static int SetParameterValue(FCGeneric fcGeneric, SqlHelper dbHelper, string paramName, string fieldName, object paramValue)
Parameters
Type | Name | Description
FCGeneric | fcGeneric |
SqlHelper | dbHelper |
System.String | paramName |
System.String | fieldName |
System.Object | paramValue |
Returns
Type | Description
System.Int32 |

ValidateDate(DateTime)

Declaration
protected static void ValidateDate(DateTime dateTime)
Parameters
Type | Name | Description
System.DateTime | dateTime |

ValidateFilter(FCSession, FCGeneric)

Declaration
public virtual void ValidateFilter(FCSession fcSession, FCGeneric gen)
Parameters
Type | Name | Description
FCSession | fcSession |
FCGeneric | gen |

ValidateIsDateField(FCGeneric, String)

Declaration
protected static void ValidateIsDateField(FCGeneric fcGeneric, string fieldName)
Parameters
Type | Name | Description
FCGeneric | fcGeneric |
System.String | fieldName |

ValidateIsDecimalField(FCGeneric, String)

Declaration
protected static void ValidateIsDecimalField(FCGeneric fcGeneric, string fieldName)
Parameters
Type | Name | Description
FCGeneric | fcGeneric |
System.String | fieldName |

ValidateIsIntegerField(FCGeneric, String)

Declaration
protected virtual void ValidateIsIntegerField(FCGeneric fcGeneric, string fieldName)
Parameters
Type | Name | Description
FCGeneric | fcGeneric |
System.String | fieldName |

ValidateIsStringField(FCGeneric, String)

Declaration
protected static void ValidateIsStringField(FCGeneric fcGeneric, string fieldName)
Parameters
Type | Name | Description
FCGeneric | fcGeneric |
System.String | fieldName |

ValidateValidField(FCGeneric, String)

Declaration
protected static void ValidateValidField(FCGeneric fcGeneric, string fieldName)
Parameters
Type | Name | Description
FCGeneric | fcGeneric |
System.String | fieldName |

ValidateValidField(FCGeneric, String, out Boolean)

Declaration
protected static void ValidateValidField(FCGeneric fcGeneric, string fieldName, out bool isRelation)
Parameters
Type | Name | Description
FCGeneric | fcGeneric |
System.String | fieldName |
System.Boolean | isRelation |


Class FilterCollection | fcSDK Documentation

Class FilterCollection

Inheritance
System.Object
System.Collections.ObjectModel.Collection<Filter>
FilterCollection
Implements
System.Collections.Generic.IList<Filter>
System.Collections.Generic.ICollection<Filter>
System.Collections.IList
System.Collections.ICollection
System.Collections.Generic.IReadOnlyList<Filter>
System.Collections.Generic.IReadOnlyCollection<Filter>
System.Collections.Generic.IEnumerable<Filter>
System.Collections.IEnumerable
Inherited Members
System.Collections.ObjectModel.Collection<FChoice.Foundation.Filters.Filter>.Clear()
System.Collections.ObjectModel.Collection<FChoice.Foundation.Filters.Filter>.CopyTo(FChoice.Foundation.Filters.Filter[], System.Int32)
System.Collections.ObjectModel.Collection<FChoice.Foundation.Filters.Filter>.GetEnumerator()
System.Collections.ObjectModel.Collection<FChoice.Foundation.Filters.Filter>.IndexOf(FChoice.Foundation.Filters.Filter)
System.Collections.ObjectModel.Collection<FChoice.Foundation.Filters.Filter>.Insert(System.Int32, FChoice.Foundation.Filters.Filter)
System.Collections.ObjectModel.Collection<FChoice.Foundation.Filters.Filter>.Remove(FChoice.Foundation.Filters.Filter)
System.Collections.ObjectModel.Collection<FChoice.Foundation.Filters.Filter>.RemoveAt(System.Int32)
System.Collections.ObjectModel.Collection<FChoice.Foundation.Filters.Filter>.ClearItems()
System.Collections.ObjectModel.Collection<FChoice.Foundation.Filters.Filter>.InsertItem(System.Int32, FChoice.Foundation.Filters.Filter)
System.Collections.ObjectModel.Collection<FChoice.Foundation.Filters.Filter>.RemoveItem(System.Int32)
System.Collections.ObjectModel.Collection<FChoice.Foundation.Filters.Filter>.SetItem(System.Int32, FChoice.Foundation.Filters.Filter)
System.Collections.ObjectModel.Collection<FChoice.Foundation.Filters.Filter>.System.Collections.IEnumerable.GetEnumerator()
System.Collections.ObjectModel.Collection<FChoice.Foundation.Filters.Filter>.System.Collections.ICollection.CopyTo(System.Array, System.Int32)
System.Collections.ObjectModel.Collection<FChoice.Foundation.Filters.Filter>.System.Collections.IList.get_Item(System.Int32)
System.Collections.ObjectModel.Collection<FChoice.Foundation.Filters.Filter>.System.Collections.IList.set_Item(System.Int32, System.Object)
System.Collections.ObjectModel.Collection<FChoice.Foundation.Filters.Filter>.System.Collections.IList.Add(System.Object)
System.Collections.ObjectModel.Collection<FChoice.Foundation.Filters.Filter>.System.Collections.IList.Contains(System.Object)
System.Collections.ObjectModel.Collection<FChoice.Foundation.Filters.Filter>.System.Collections.IList.IndexOf(System.Object)
System.Collections.ObjectModel.Collection<FChoice.Foundation.Filters.Filter>.System.Collections.IList.Insert(System.Int32, System.Object)
System.Collections.ObjectModel.Collection<FChoice.Foundation.Filters.Filter>.System.Collections.IList.Remove(System.Object)
System.Collections.ObjectModel.Collection<FChoice.Foundation.Filters.Filter>.Count
System.Collections.ObjectModel.Collection<FChoice.Foundation.Filters.Filter>.Items
System.Collections.ObjectModel.Collection<FChoice.Foundation.Filters.Filter>.Item[System.Int32]
System.Collections.ObjectModel.Collection<FChoice.Foundation.Filters.Filter>.System.Collections.Generic.ICollection<FChoice.Foundation.Filters.Filter>.IsReadOnly
System.Collections.ObjectModel.Collection<FChoice.Foundation.Filters.Filter>.System.Collections.ICollection.IsSynchronized
System.Collections.ObjectModel.Collection<FChoice.Foundation.Filters.Filter>.System.Collections.ICollection.SyncRoot
System.Collections.ObjectModel.Collection<FChoice.Foundation.Filters.Filter>.System.Collections.IList.Item[System.Int32]
System.Collections.ObjectModel.Collection<FChoice.Foundation.Filters.Filter>.System.Collections.IList.IsReadOnly
System.Collections.ObjectModel.Collection<FChoice.Foundation.Filters.Filter>.System.Collections.IList.IsFixedSize
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Filters
Assembly: fcSDK.dll
Syntax
public class FilterCollection : Collection<Filter>, IList<Filter>, ICollection<Filter>, IList, ICollection, IReadOnlyList<Filter>, IReadOnlyCollection<Filter>, IEnumerable<Filter>, IEnumerable

Methods

Add(Filter)

Declaration
public Filter Add(Filter filter)
Parameters
Type | Name | Description
Filter | filter |
Returns
Type | Description
Filter |

Contains(Filter)

Declaration
public bool Contains(Filter filter)
Parameters
Type | Name | Description
Filter | filter |
Returns
Type | Description
System.Boolean |

Implements

System.Collections.Generic.IList<T>
System.Collections.Generic.ICollection<T>
System.Collections.IList
System.Collections.ICollection
System.Collections.Generic.IReadOnlyList<T>
System.Collections.Generic.IReadOnlyCollection<T>
System.Collections.Generic.IEnumerable<T>
System.Collections.IEnumerable


Class FilterExpression | fcSDK Documentation

Class FilterExpression

Inheritance
System.Object
FilterExpression
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Filters
Assembly: fcSDK.dll
Syntax
public class FilterExpression

Constructors

FilterExpression()

Declaration
public FilterExpression()

Methods

After(String, DateTime)

Declaration
public AfterFilter After(string columnName, DateTime value)
Parameters
Type | Name | Description
System.String | columnName |
System.DateTime | value |
Returns
Type | Description
AfterFilter |

And(Filter, Filter)

Declaration
public AndFilter And(Filter filter1, Filter filter2)
Parameters
Type | Name | Description
Filter | filter1 |
Filter | filter2 |
Returns
Type | Description
AndFilter |

And(Filter[])

Declaration
public AndManyFilter And(params Filter[] filters)
Parameters
Type | Name | Description
Filter[] | filters |
Returns
Type | Description
AndManyFilter |

Before(String, DateTime)

Declaration
public BeforeFilter Before(string columnName, DateTime value)
Parameters
Type | Name | Description
System.String | columnName |
System.DateTime | value |
Returns
Type | Description
BeforeFilter |

Between(String, DateTime, DateTime)

Declaration
public BetweenFilter Between(string columnName, DateTime value1, DateTime value2)
Parameters
Type | Name | Description
System.String | columnName |
System.DateTime | value1 |
System.DateTime | value2 |
Returns
Type | Description
BetweenFilter |

Between(String, Decimal, Decimal)

Declaration
public BetweenFilter Between(string columnName, decimal value1, decimal value2)
Parameters
Type | Name | Description
System.String | columnName |
System.Decimal | value1 |
System.Decimal | value2 |
Returns
Type | Description
BetweenFilter |

Between(String, Int32, Int32)

Declaration
public BetweenFilter Between(string columnName, int value1, int value2)
Parameters
Type | Name | Description
System.String | columnName |
System.Int32 | value1 |
System.Int32 | value2 |
Returns
Type | Description
BetweenFilter |

Between(String, String, String)

Declaration
public BetweenFilter Between(string columnName, string value1, string value2)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value1 |
System.String | value2 |
Returns
Type | Description
BetweenFilter |

Contains(String, String)

Declaration
public ContainsFilter Contains(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |
Returns
Type | Description
ContainsFilter |

EndsWith(String, String)

Declaration
public EndsWithFilter EndsWith(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |
Returns
Type | Description
EndsWithFilter |

Equals(String, Boolean)

Declaration
public EqualsFilter Equals(string columnName, bool value)
Parameters
Type | Name | Description
System.String | columnName |
System.Boolean | value |
Returns
Type | Description
EqualsFilter |

Equals(String, DateTime)

Declaration
public EqualsFilter Equals(string columnName, DateTime value)
Parameters
Type | Name | Description
System.String | columnName |
System.DateTime | value |
Returns
Type | Description
EqualsFilter |

Equals(String, Decimal)

Declaration
public EqualsFilter Equals(string columnName, decimal value)
Parameters
Type | Name | Description
System.String | columnName |
System.Decimal | value |
Returns
Type | Description
EqualsFilter |

Equals(String, Int32)

Declaration
public EqualsFilter Equals(string columnName, int value)
Parameters
Type | Name | Description
System.String | columnName |
System.Int32 | value |
Returns
Type | Description
EqualsFilter |

Equals(String, String)

Declaration
public EqualsFilter Equals(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |
Returns
Type | Description
EqualsFilter |

IsIn(String, DateTime[])

Declaration
public IsInFilter IsIn(string columnName, params DateTime[] values)
Parameters
Type | Name | Description
System.String | columnName |
System.DateTime[] | values |
Returns
Type | Description
IsInFilter |

IsIn(String, Decimal[])

Declaration
public IsInFilter IsIn(string columnName, params decimal[] values)
Parameters
Type | Name | Description
System.String | columnName |
System.Decimal[] | values |
Returns
Type | Description
IsInFilter |

IsIn(String, Int32[])

Declaration
public IsInFilter IsIn(string columnName, params int[] values)
Parameters
Type | Name | Description
System.String | columnName |
System.Int32[] | values |
Returns
Type | Description
IsInFilter |

IsIn(String, String[])

Declaration
public IsInFilter IsIn(string columnName, params string[] values)
Parameters
Type | Name | Description
System.String | columnName |
System.String[] | values |
Returns
Type | Description
IsInFilter |

IsNotIn(String, DateTime[])

Declaration
public IsInFilter IsNotIn(string columnName, params DateTime[] values)
Parameters
Type | Name | Description
System.String | columnName |
System.DateTime[] | values |
Returns
Type | Description
IsInFilter |

IsNotIn(String, Decimal[])

Declaration
public IsInFilter IsNotIn(string columnName, params decimal[] values)
Parameters
Type | Name | Description
System.String | columnName |
System.Decimal[] | values |
Returns
Type | Description
IsInFilter |

IsNotIn(String, Int32[])

Declaration
public IsInFilter IsNotIn(string columnName, params int[] values)
Parameters
Type | Name | Description
System.String | columnName |
System.Int32[] | values |
Returns
Type | Description
IsInFilter |

IsNotIn(String, String[])

Declaration
public IsInFilter IsNotIn(string columnName, params string[] values)
Parameters
Type | Name | Description
System.String | columnName |
System.String[] | values |
Returns
Type | Description
IsInFilter |

IsNotNull(String)

Declaration
public IsNullFilter IsNotNull(string columnName)
Parameters
Type | Name | Description
System.String | columnName |
Returns
Type | Description
IsNullFilter |

IsNull(String)

Declaration
public IsNullFilter IsNull(string columnName)
Parameters
Type | Name | Description
System.String | columnName |
Returns
Type | Description
IsNullFilter |

LessThan(String, DateTime)

Declaration
public LessThanFilter LessThan(string columnName, DateTime value)
Parameters
Type | Name | Description
System.String | columnName |
System.DateTime | value |
Returns
Type | Description
LessThanFilter |

LessThan(String, Decimal)

Declaration
public LessThanFilter LessThan(string columnName, decimal value)
Parameters
Type | Name | Description
System.String | columnName |
System.Decimal | value |
Returns
Type | Description
LessThanFilter |

LessThan(String, Int32)

Declaration
public LessThanFilter LessThan(string columnName, int value)
Parameters
Type | Name | Description
System.String | columnName |
System.Int32 | value |
Returns
Type | Description
LessThanFilter |

LessThan(String, String)

Declaration
public LessThanFilter LessThan(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |
Returns
Type | Description
LessThanFilter |

LessThanOrEqual(String, DateTime)

Declaration
public Filter LessThanOrEqual(string columnName, DateTime value)
Parameters
Type | Name | Description
System.String | columnName |
System.DateTime | value |
Returns
Type | Description
Filter |

LessThanOrEqual(String, Decimal)

Declaration
public LessThanOrEqualFilter LessThanOrEqual(string columnName, decimal value)
Parameters
Type | Name | Description
System.String | columnName |
System.Decimal | value |
Returns
Type | Description
LessThanOrEqualFilter |

LessThanOrEqual(String, Int32)

Declaration
public LessThanOrEqualFilter LessThanOrEqual(string columnName, int value)
Parameters
Type | Name | Description
System.String | columnName |
System.Int32 | value |
Returns
Type | Description
LessThanOrEqualFilter |

LessThanOrEqual(String, String)

Declaration
public Filter LessThanOrEqual(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |
Returns
Type | Description
Filter |

Like(String, String)

Declaration
public LikeFilter Like(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |
Returns
Type | Description
LikeFilter |

MoreThan(String, DateTime)

Declaration
public MoreThanFilter MoreThan(string columnName, DateTime value)
Parameters
Type | Name | Description
System.String | columnName |
System.DateTime | value |
Returns
Type | Description
MoreThanFilter |

MoreThan(String, Decimal)

Declaration
public MoreThanFilter MoreThan(string columnName, decimal value)
Parameters
Type | Name | Description
System.String | columnName |
System.Decimal | value |
Returns
Type | Description
MoreThanFilter |

MoreThan(String, Int32)

Declaration
public MoreThanFilter MoreThan(string columnName, int value)
Parameters
Type | Name | Description
System.String | columnName |
System.Int32 | value |
Returns
Type | Description
MoreThanFilter |

MoreThan(String, String)

Declaration
public MoreThanFilter MoreThan(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |
Returns
Type | Description
MoreThanFilter |

MoreThanOrEqual(String, DateTime)

Declaration
public MoreThanOrEqualFilter MoreThanOrEqual(string columnName, DateTime value)
Parameters
Type | Name | Description
System.String | columnName |
System.DateTime | value |
Returns
Type | Description
MoreThanOrEqualFilter |

MoreThanOrEqual(String, Decimal)

Declaration
public MoreThanOrEqualFilter MoreThanOrEqual(string columnName, decimal value)
Parameters
Type | Name | Description
System.String | columnName |
System.Decimal | value |
Returns
Type | Description
MoreThanOrEqualFilter |

MoreThanOrEqual(String, Int32)

Declaration
public MoreThanOrEqualFilter MoreThanOrEqual(string columnName, int value)
Parameters
Type | Name | Description
System.String | columnName |
System.Int32 | value |
Returns
Type | Description
MoreThanOrEqualFilter |

MoreThanOrEqual(String, String)

Declaration
public MoreThanOrEqualFilter MoreThanOrEqual(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |
Returns
Type | Description
MoreThanOrEqualFilter |

NotBetween(String, DateTime, DateTime)

Declaration
public BetweenFilter NotBetween(string columnName, DateTime value1, DateTime value2)
Parameters
Type | Name | Description
System.String | columnName |
System.DateTime | value1 |
System.DateTime | value2 |
Returns
Type | Description
BetweenFilter |

NotBetween(String, Decimal, Decimal)

Declaration
public BetweenFilter NotBetween(string columnName, decimal value1, decimal value2)
Parameters
Type | Name | Description
System.String | columnName |
System.Decimal | value1 |
System.Decimal | value2 |
Returns
Type | Description
BetweenFilter |

NotBetween(String, Int32, Int32)

Declaration
public BetweenFilter NotBetween(string columnName, int value1, int value2)
Parameters
Type | Name | Description
System.String | columnName |
System.Int32 | value1 |
System.Int32 | value2 |
Returns
Type | Description
BetweenFilter |

NotBetween(String, String, String)

Declaration
public BetweenFilter NotBetween(string columnName, string value1, string value2)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value1 |
System.String | value2 |
Returns
Type | Description
BetweenFilter |

NotContains(String, String)

Declaration
public NotContainsFilter NotContains(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |
Returns
Type | Description
NotContainsFilter |

NotEndsWith(String, String)

Declaration
public NotEndsWithFilter NotEndsWith(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |
Returns
Type | Description
NotEndsWithFilter |

NotEqual(String, Boolean)

Declaration
public EqualsFilter NotEqual(string columnName, bool value)
Parameters
Type | Name | Description
System.String | columnName |
System.Boolean | value |
Returns
Type | Description
EqualsFilter |

NotEqual(String, DateTime)

Declaration
public Filter NotEqual(string columnName, DateTime value)
Parameters
Type | Name | Description
System.String | columnName |
System.DateTime | value |
Returns
Type | Description
Filter |

NotEqual(String, Decimal)

Declaration
public Filter NotEqual(string columnName, decimal value)
Parameters
Type | Name | Description
System.String | columnName |
System.Decimal | value |
Returns
Type | Description
Filter |

NotEqual(String, Int32)

Declaration
public EqualsFilter NotEqual(string columnName, int value)
Parameters
Type | Name | Description
System.String | columnName |
System.Int32 | value |
Returns
Type | Description
EqualsFilter |

NotEqual(String, String)

Declaration
public Filter NotEqual(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |
Returns
Type | Description
Filter |

NotLike(String, String)

Declaration
public NotLikeFilter NotLike(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |
Returns
Type | Description
NotLikeFilter |

NotStartsWith(String, String)

Declaration
public NotStartsWithFilter NotStartsWith(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |
Returns
Type | Description
NotStartsWithFilter |

OlderThanDays(String, Decimal)

Declaration
public OlderThanDaysFilter OlderThanDays(string columnName, decimal value)
Parameters
Type | Name | Description
System.String | columnName |
System.Decimal | value |
Returns
Type | Description
OlderThanDaysFilter |

OlderThanDays(String, Int32)

Declaration
public OlderThanDaysFilter OlderThanDays(string columnName, int value)
Parameters
Type | Name | Description
System.String | columnName |
System.Int32 | value |
Returns
Type | Description
OlderThanDaysFilter |

OlderThanHours(String, Decimal)

Declaration
public OlderThanHoursFilter OlderThanHours(string columnName, decimal value)
Parameters
Type | Name | Description
System.String | columnName |
System.Decimal | value |
Returns
Type | Description
OlderThanHoursFilter |

OlderThanHours(String, Int32)

Declaration
public OlderThanHoursFilter OlderThanHours(string columnName, int value)
Parameters
Type | Name | Description
System.String | columnName |
System.Int32 | value |
Returns
Type | Description
OlderThanHoursFilter |

On(String, DateTime)

Declaration
public OnFilter On(string columnName, DateTime value)
Parameters
Type | Name | Description
System.String | columnName |
System.DateTime | value |
Returns
Type | Description
OnFilter |

Or(Filter, Filter)

Declaration
public OrFilter Or(Filter filter1, Filter filter2)
Parameters
Type | Name | Description
Filter | filter1 |
Filter | filter2 |
Returns
Type | Description
OrFilter |

Or(Filter[])

Declaration
public OrManyFilter Or(params Filter[] filters)
Parameters
Type | Name | Description
Filter[] | filters |
Returns
Type | Description
OrManyFilter |

SoundsLike(String, String)

Declaration
public SoundsLikeFilter SoundsLike(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |
Returns
Type | Description
SoundsLikeFilter |

StartsWith(String, String)

Declaration
public StartsWithFilter StartsWith(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |
Returns
Type | Description
StartsWithFilter |

Today(String)

Declaration
public TodayFilter Today(string columnName)
Parameters
Type | Name | Description
System.String | columnName |
Returns
Type | Description
TodayFilter |

Tomorrow(String)

Declaration
public TomorrowFilter Tomorrow(string columnName)
Parameters
Type | Name | Description
System.String | columnName |
Returns
Type | Description
TomorrowFilter |

WithinDays(String, Decimal)

Declaration
public WithinDaysFilter WithinDays(string columnName, decimal value)
Parameters
Type | Name | Description
System.String | columnName |
System.Decimal | value |
Returns
Type | Description
WithinDaysFilter |

WithinDays(String, Int32)

Declaration
public WithinDaysFilter WithinDays(string columnName, int value)
Parameters
Type | Name | Description
System.String | columnName |
System.Int32 | value |
Returns
Type | Description
WithinDaysFilter |

WithinHours(String, Decimal)

Declaration
public WithinHoursFilter WithinHours(string columnName, decimal value)
Parameters
Type | Name | Description
System.String | columnName |
System.Decimal | value |
Returns
Type | Description
WithinHoursFilter |

WithinHours(String, Int32)

Declaration
public WithinHoursFilter WithinHours(string columnName, int value)
Parameters
Type | Name | Description
System.String | columnName |
System.Int32 | value |
Returns
Type | Description
WithinHoursFilter |

Yesterday(String)

Declaration
public YesterdayFilter Yesterday(string columnName)
Parameters
Type | Name | Description
System.String | columnName |
Returns
Type | Description
YesterdayFilter |


Class FilterType | fcSDK Documentation

Class FilterType

Inheritance
System.Object
FilterType
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Filters
Assembly: fcSDK.dll
Syntax
public static class FilterType

Methods

After(String, DateTime)

Declaration
public static AfterFilter After(string columnName, DateTime value)
Parameters
Type | Name | Description
System.String | columnName |
System.DateTime | value |
Returns
Type | Description
AfterFilter |

And(Filter, Filter)

Declaration
public static AndFilter And(Filter filter1, Filter filter2)
Parameters
Type | Name | Description
Filter | filter1 |
Filter | filter2 |
Returns
Type | Description
AndFilter |

And(Filter[])

Declaration
public static AndManyFilter And(params Filter[] filters)
Parameters
Type | Name | Description
Filter[] | filters |
Returns
Type | Description
AndManyFilter |

Before(String, DateTime)

Declaration
public static BeforeFilter Before(string columnName, DateTime value)
Parameters
Type | Name | Description
System.String | columnName |
System.DateTime | value |
Returns
Type | Description
BeforeFilter |

Between(String, DateTime, DateTime)

Declaration
public static BetweenFilter Between(string columnName, DateTime value1, DateTime value2)
Parameters
Type | Name | Description
System.String | columnName |
System.DateTime | value1 |
System.DateTime | value2 |
Returns
Type | Description
BetweenFilter |

Between(String, Decimal, Decimal)

Declaration
public static BetweenFilter Between(string columnName, decimal value1, decimal value2)
Parameters
Type | Name | Description
System.String | columnName |
System.Decimal | value1 |
System.Decimal | value2 |
Returns
Type | Description
BetweenFilter |

Between(String, Int32, Int32)

Declaration
public static BetweenFilter Between(string columnName, int value1, int value2)
Parameters
Type | Name | Description
System.String | columnName |
System.Int32 | value1 |
System.Int32 | value2 |
Returns
Type | Description
BetweenFilter |

Between(String, String, String)

Declaration
public static BetweenFilter Between(string columnName, string value1, string value2)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value1 |
System.String | value2 |
Returns
Type | Description
BetweenFilter |

Contains(String, String)

Declaration
public static ContainsFilter Contains(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |
Returns
Type | Description
ContainsFilter |

EndsWith(String, String)

Declaration
public static EndsWithFilter EndsWith(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |
Returns
Type | Description
EndsWithFilter |

Equals(String, Boolean)

Declaration
public static EqualsFilter Equals(string columnName, bool value)
Parameters
Type | Name | Description
System.String | columnName |
System.Boolean | value |
Returns
Type | Description
EqualsFilter |

Equals(String, DateTime)

Declaration
public static EqualsFilter Equals(string columnName, DateTime value)
Parameters
Type | Name | Description
System.String | columnName |
System.DateTime | value |
Returns
Type | Description
EqualsFilter |

Equals(String, Decimal)

Declaration
public static EqualsFilter Equals(string columnName, decimal value)
Parameters
Type | Name | Description
System.String | columnName |
System.Decimal | value |
Returns
Type | Description
EqualsFilter |

Equals(String, Int32)

Declaration
public static EqualsFilter Equals(string columnName, int value)
Parameters
Type | Name | Description
System.String | columnName |
System.Int32 | value |
Returns
Type | Description
EqualsFilter |

Equals(String, String)

Declaration
public static EqualsFilter Equals(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |
Returns
Type | Description
EqualsFilter |

IsIn(String, DateTime[])

Declaration
public static IsInFilter IsIn(string columnName, params DateTime[] values)
Parameters
Type | Name | Description
System.String | columnName |
System.DateTime[] | values |
Returns
Type | Description
IsInFilter |

IsIn(String, Decimal[])

Declaration
public static IsInFilter IsIn(string columnName, params decimal[] values)
Parameters
Type | Name | Description
System.String | columnName |
System.Decimal[] | values |
Returns
Type | Description
IsInFilter |

IsIn(String, Int32[])

Declaration
public static IsInFilter IsIn(string columnName, params int[] values)
Parameters
Type | Name | Description
System.String | columnName |
System.Int32[] | values |
Returns
Type | Description
IsInFilter |

IsIn(String, String[])

Declaration
public static IsInFilter IsIn(string columnName, params string[] values)
Parameters
Type | Name | Description
System.String | columnName |
System.String[] | values |
Returns
Type | Description
IsInFilter |

IsNotIn(String, DateTime[])

Declaration
public static IsInFilter IsNotIn(string columnName, params DateTime[] values)
Parameters
Type | Name | Description
System.String | columnName |
System.DateTime[] | values |
Returns
Type | Description
IsInFilter |

IsNotIn(String, Decimal[])

Declaration
public static IsInFilter IsNotIn(string columnName, params decimal[] values)
Parameters
Type | Name | Description
System.String | columnName |
System.Decimal[] | values |
Returns
Type | Description
IsInFilter |

IsNotIn(String, Int32[])

Declaration
public static IsInFilter IsNotIn(string columnName, params int[] values)
Parameters
Type | Name | Description
System.String | columnName |
System.Int32[] | values |
Returns
Type | Description
IsInFilter |

IsNotIn(String, String[])

Declaration
public static IsInFilter IsNotIn(string columnName, params string[] values)
Parameters
Type | Name | Description
System.String | columnName |
System.String[] | values |
Returns
Type | Description
IsInFilter |

IsNotNull(String)

Declaration
public static IsNullFilter IsNotNull(string columnName)
Parameters
Type | Name | Description
System.String | columnName |
Returns
Type | Description
IsNullFilter |

IsNull(String)

Declaration
public static IsNullFilter IsNull(string columnName)
Parameters
Type | Name | Description
System.String | columnName |
Returns
Type | Description
IsNullFilter |

LessThan(String, DateTime)

Declaration
public static LessThanFilter LessThan(string columnName, DateTime value)
Parameters
Type | Name | Description
System.String | columnName |
System.DateTime | value |
Returns
Type | Description
LessThanFilter |

LessThan(String, Decimal)

Declaration
public static LessThanFilter LessThan(string columnName, decimal value)
Parameters
Type | Name | Description
System.String | columnName |
System.Decimal | value |
Returns
Type | Description
LessThanFilter |

LessThan(String, Int32)

Declaration
public static LessThanFilter LessThan(string columnName, int value)
Parameters
Type | Name | Description
System.String | columnName |
System.Int32 | value |
Returns
Type | Description
LessThanFilter |

LessThan(String, String)

Declaration
public static LessThanFilter LessThan(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |
Returns
Type | Description
LessThanFilter |

LessThanOrEqual(String, DateTime)

Declaration
public static Filter LessThanOrEqual(string columnName, DateTime value)
Parameters
Type | Name | Description
System.String | columnName |
System.DateTime | value |
Returns
Type | Description
Filter |

LessThanOrEqual(String, Decimal)

Declaration
public static LessThanOrEqualFilter LessThanOrEqual(string columnName, decimal value)
Parameters
Type | Name | Description
System.String | columnName |
System.Decimal | value |
Returns
Type | Description
LessThanOrEqualFilter |

LessThanOrEqual(String, Int32)

Declaration
public static LessThanOrEqualFilter LessThanOrEqual(string columnName, int value)
Parameters
Type | Name | Description
System.String | columnName |
System.Int32 | value |
Returns
Type | Description
LessThanOrEqualFilter |

LessThanOrEqual(String, String)

Declaration
public static Filter LessThanOrEqual(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |
Returns
Type | Description
Filter |

Like(String, String)

Declaration
public static LikeFilter Like(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |
Returns
Type | Description
LikeFilter |

MoreThan(String, DateTime)

Declaration
public static MoreThanFilter MoreThan(string columnName, DateTime value)
Parameters
Type | Name | Description
System.String | columnName |
System.DateTime | value |
Returns
Type | Description
MoreThanFilter |

MoreThan(String, Decimal)

Declaration
public static MoreThanFilter MoreThan(string columnName, decimal value)
Parameters
Type | Name | Description
System.String | columnName |
System.Decimal | value |
Returns
Type | Description
MoreThanFilter |

MoreThan(String, Int32)

Declaration
public static MoreThanFilter MoreThan(string columnName, int value)
Parameters
Type | Name | Description
System.String | columnName |
System.Int32 | value |
Returns
Type | Description
MoreThanFilter |

MoreThan(String, String)

Declaration
public static MoreThanFilter MoreThan(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |
Returns
Type | Description
MoreThanFilter |

MoreThanOrEqual(String, DateTime)

Declaration
public static MoreThanOrEqualFilter MoreThanOrEqual(string columnName, DateTime value)
Parameters
Type | Name | Description
System.String | columnName |
System.DateTime | value |
Returns
Type | Description
MoreThanOrEqualFilter |

MoreThanOrEqual(String, Decimal)

Declaration
public static MoreThanOrEqualFilter MoreThanOrEqual(string columnName, decimal value)
Parameters
Type | Name | Description
System.String | columnName |
System.Decimal | value |
Returns
Type | Description
MoreThanOrEqualFilter |

MoreThanOrEqual(String, Int32)

Declaration
public static MoreThanOrEqualFilter MoreThanOrEqual(string columnName, int value)
Parameters
Type | Name | Description
System.String | columnName |
System.Int32 | value |
Returns
Type | Description
MoreThanOrEqualFilter |

MoreThanOrEqual(String, String)

Declaration
public static MoreThanOrEqualFilter MoreThanOrEqual(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |
Returns
Type | Description
MoreThanOrEqualFilter |

NotBetween(String, DateTime, DateTime)

Declaration
public static BetweenFilter NotBetween(string columnName, DateTime value1, DateTime value2)
Parameters
Type | Name | Description
System.String | columnName |
System.DateTime | value1 |
System.DateTime | value2 |
Returns
Type | Description
BetweenFilter |

NotBetween(String, Decimal, Decimal)

Declaration
public static BetweenFilter NotBetween(string columnName, decimal value1, decimal value2)
Parameters
Type | Name | Description
System.String | columnName |
System.Decimal | value1 |
System.Decimal | value2 |
Returns
Type | Description
BetweenFilter |

NotBetween(String, Int32, Int32)

Declaration
public static BetweenFilter NotBetween(string columnName, int value1, int value2)
Parameters
Type | Name | Description
System.String | columnName |
System.Int32 | value1 |
System.Int32 | value2 |
Returns
Type | Description
BetweenFilter |

NotBetween(String, String, String)

Declaration
public static BetweenFilter NotBetween(string columnName, string value1, string value2)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value1 |
System.String | value2 |
Returns
Type | Description
BetweenFilter |

NotContains(String, String)

Declaration
public static NotContainsFilter NotContains(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |
Returns
Type | Description
NotContainsFilter |

NotEndsWith(String, String)

Declaration
public static NotEndsWithFilter NotEndsWith(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |
Returns
Type | Description
NotEndsWithFilter |

NotEqual(String, Boolean)

Declaration
public static EqualsFilter NotEqual(string columnName, bool value)
Parameters
Type | Name | Description
System.String | columnName |
System.Boolean | value |
Returns
Type | Description
EqualsFilter |

NotEqual(String, DateTime)

Declaration
public static Filter NotEqual(string columnName, DateTime value)
Parameters
Type | Name | Description
System.String | columnName |
System.DateTime | value |
Returns
Type | Description
Filter |

NotEqual(String, Decimal)

Declaration
public static Filter NotEqual(string columnName, decimal value)
Parameters
Type | Name | Description
System.String | columnName |
System.Decimal | value |
Returns
Type | Description
Filter |

NotEqual(String, Int32)

Declaration
public static EqualsFilter NotEqual(string columnName, int value)
Parameters
Type | Name | Description
System.String | columnName |
System.Int32 | value |
Returns
Type | Description
EqualsFilter |

NotEqual(String, String)

Declaration
public static Filter NotEqual(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |
Returns
Type | Description
Filter |

NotLike(String, String)

Declaration
public static NotLikeFilter NotLike(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |
Returns
Type | Description
NotLikeFilter |

NotStartsWith(String, String)

Declaration
public static NotStartsWithFilter NotStartsWith(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |
Returns
Type | Description
NotStartsWithFilter |

OlderThanDays(String, Decimal)

Declaration
public static OlderThanDaysFilter OlderThanDays(string columnName, decimal value)
Parameters
Type | Name | Description
System.String | columnName |
System.Decimal | value |
Returns
Type | Description
OlderThanDaysFilter |

OlderThanDays(String, Int32)

Declaration
public static OlderThanDaysFilter OlderThanDays(string columnName, int value)
Parameters
Type | Name | Description
System.String | columnName |
System.Int32 | value |
Returns
Type | Description
OlderThanDaysFilter |

OlderThanHours(String, Decimal)

Declaration
public static OlderThanHoursFilter OlderThanHours(string columnName, decimal value)
Parameters
Type | Name | Description
System.String | columnName |
System.Decimal | value |
Returns
Type | Description
OlderThanHoursFilter |

OlderThanHours(String, Int32)

Declaration
public static OlderThanHoursFilter OlderThanHours(string columnName, int value)
Parameters
Type | Name | Description
System.String | columnName |
System.Int32 | value |
Returns
Type | Description
OlderThanHoursFilter |

On(String, DateTime)

Declaration
public static OnFilter On(string columnName, DateTime value)
Parameters
Type | Name | Description
System.String | columnName |
System.DateTime | value |
Returns
Type | Description
OnFilter |

Or(Filter, Filter)

Declaration
public static OrFilter Or(Filter filter1, Filter filter2)
Parameters
Type | Name | Description
Filter | filter1 |
Filter | filter2 |
Returns
Type | Description
OrFilter |

Or(Filter[])

Declaration
public static OrManyFilter Or(params Filter[] filters)
Parameters
Type | Name | Description
Filter[] | filters |
Returns
Type | Description
OrManyFilter |

SoundsLike(String, String)

Declaration
public static SoundsLikeFilter SoundsLike(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |
Returns
Type | Description
SoundsLikeFilter |

StartsWith(String, String)

Declaration
public static StartsWithFilter StartsWith(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |
Returns
Type | Description
StartsWithFilter |

Today(String)

Declaration
public static TodayFilter Today(string columnName)
Parameters
Type | Name | Description
System.String | columnName |
Returns
Type | Description
TodayFilter |

Tomorrow(String)

Declaration
public static TomorrowFilter Tomorrow(string columnName)
Parameters
Type | Name | Description
System.String | columnName |
Returns
Type | Description
TomorrowFilter |

WithinDays(String, Decimal)

Declaration
public static WithinDaysFilter WithinDays(string columnName, decimal value)
Parameters
Type | Name | Description
System.String | columnName |
System.Decimal | value |
Returns
Type | Description
WithinDaysFilter |

WithinDays(String, Int32)

Declaration
public static WithinDaysFilter WithinDays(string columnName, int value)
Parameters
Type | Name | Description
System.String | columnName |
System.Int32 | value |
Returns
Type | Description
WithinDaysFilter |

WithinHours(String, Decimal)

Declaration
public static WithinHoursFilter WithinHours(string columnName, decimal value)
Parameters
Type | Name | Description
System.String | columnName |
System.Decimal | value |
Returns
Type | Description
WithinHoursFilter |

WithinHours(String, Int32)

Declaration
public static WithinHoursFilter WithinHours(string columnName, int value)
Parameters
Type | Name | Description
System.String | columnName |
System.Int32 | value |
Returns
Type | Description
WithinHoursFilter |

Yesterday(String)

Declaration
public static YesterdayFilter Yesterday(string columnName)
Parameters
Type | Name | Description
System.String | columnName |
Returns
Type | Description
YesterdayFilter |


Class IsInFilter | fcSDK Documentation

Class IsInFilter

Inheritance
System.Object
Filter
ColumnBasedFilter
IsInFilter
Inherited Members
ColumnBasedFilter.GetColumnNameForRender(FCGeneric)
ColumnBasedFilter.ColumnName
Filter.ValidateFilter(FCSession, FCGeneric)
Filter.Render(FCSession, FCGeneric, SqlHelper)
Filter.GetActualDateValue(FCSession, Object)
Filter.ConvertDate(FCSession, DateTime, Boolean)
Filter.ValidateDate(DateTime)
Filter.ValidateValidField(FCGeneric, String)
Filter.ValidateValidField(FCGeneric, String, Boolean)
Filter.ValidateIsIntegerField(FCGeneric, String)
Filter.ValidateIsDecimalField(FCGeneric, String)
Filter.ValidateIsDateField(FCGeneric, String)
Filter.ValidateIsStringField(FCGeneric, String)
Filter.SetParameterValue(FCGeneric, SqlHelper, String, String, Object)
Filter.Session
Filter.Generic
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Filters
Assembly: fcSDK.dll
Syntax
public class IsInFilter : ColumnBasedFilter

Constructors

IsInFilter(String, Boolean, Array)

Declaration
protected IsInFilter(string columnName, bool isInFilter, Array valList)
Parameters
Type | Name | Description
System.String | columnName |
System.Boolean | isInFilter |
System.Array | valList |

IsInFilter(String, Boolean, DateTime[])

Declaration
protected IsInFilter(string columnName, bool isInFilter, DateTime[] inList)
Parameters
Type | Name | Description
System.String | columnName |
System.Boolean | isInFilter |
System.DateTime[] | inList |

IsInFilter(String, Boolean, Decimal[])

Declaration
protected IsInFilter(string columnName, bool isInFilter, decimal[] inList)
Parameters
Type | Name | Description
System.String | columnName |
System.Boolean | isInFilter |
System.Decimal[] | inList |

IsInFilter(String, Boolean, Int32[])

Declaration
protected IsInFilter(string columnName, bool isInFilter, int[] inList)
Parameters
Type | Name | Description
System.String | columnName |
System.Boolean | isInFilter |
System.Int32[] | inList |

IsInFilter(String, Boolean, String[])

Declaration
protected IsInFilter(string columnName, bool isInFilter, string[] inList)
Parameters
Type | Name | Description
System.String | columnName |
System.Boolean | isInFilter |
System.String[] | inList |

Properties

IsIn

Declaration
public bool IsIn { get; }
Property Value
Type | Description
System.Boolean |

ObjectList

Declaration
public Array ObjectList { get; }
Property Value
Type | Description
System.Array |

Methods

IsEmptyStringPresent(Array)

Declaration
protected static bool IsEmptyStringPresent(Array values)
Parameters
Type | Name | Description
System.Array | values |
Returns
Type | Description
System.Boolean |

PerformRender(FCSession, FCGeneric, SqlHelper)

Declaration
protected override string PerformRender(FCSession fcSession, FCGeneric gen, SqlHelper dbHelper)
Parameters
Type | Name | Description
FCSession | fcSession |
FCGeneric | gen |
SqlHelper | dbHelper |
Returns
Type | Description
System.String |
Overrides
Filter.PerformRender(FCSession, FCGeneric, SqlHelper)

PerformValidateFilter(FCSession, FCGeneric)

Declaration
protected override void PerformValidateFilter(FCSession session, FCGeneric gen)
Parameters
Type | Name | Description
FCSession | session |
FCGeneric | gen |
Overrides
Filter.PerformValidateFilter(FCSession, FCGeneric)


Class IsNullFilter | fcSDK Documentation

Class IsNullFilter

Inheritance
System.Object
Filter
ColumnBasedFilter
IsNullFilter
Inherited Members
ColumnBasedFilter.GetColumnNameForRender(FCGeneric)
ColumnBasedFilter.ColumnName
Filter.ValidateFilter(FCSession, FCGeneric)
Filter.Render(FCSession, FCGeneric, SqlHelper)
Filter.GetActualDateValue(FCSession, Object)
Filter.ConvertDate(FCSession, DateTime, Boolean)
Filter.ValidateDate(DateTime)
Filter.ValidateValidField(FCGeneric, String)
Filter.ValidateValidField(FCGeneric, String, Boolean)
Filter.ValidateIsIntegerField(FCGeneric, String)
Filter.ValidateIsDecimalField(FCGeneric, String)
Filter.ValidateIsDateField(FCGeneric, String)
Filter.ValidateIsStringField(FCGeneric, String)
Filter.SetParameterValue(FCGeneric, SqlHelper, String, String, Object)
Filter.Session
Filter.Generic
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Filters
Assembly: fcSDK.dll
Syntax
public class IsNullFilter : ColumnBasedFilter

Constructors

IsNullFilter(String, Boolean)

Declaration
protected IsNullFilter(string columnName, bool isNull)
Parameters
Type | Name | Description
System.String | columnName |
System.Boolean | isNull |

Properties

IsNull

Declaration
public bool IsNull { get; }
Property Value
Type | Description
System.Boolean |

Methods

PerformRender(FCSession, FCGeneric, SqlHelper)

Declaration
protected override string PerformRender(FCSession fcSession, FCGeneric gen, SqlHelper dbHelper)
Parameters
Type | Name | Description
FCSession | fcSession |
FCGeneric | gen |
SqlHelper | dbHelper |
Returns
Type | Description
System.String |
Overrides
Filter.PerformRender(FCSession, FCGeneric, SqlHelper)

PerformValidateFilter(FCSession, FCGeneric)

Declaration
protected override void PerformValidateFilter(FCSession session, FCGeneric gen)
Parameters
Type | Name | Description
FCSession | session |
FCGeneric | gen |
Overrides
Filter.PerformValidateFilter(FCSession, FCGeneric)


Class LessThanFilter | fcSDK Documentation

Class LessThanFilter

Inheritance
System.Object
Filter
ColumnBasedFilter
OperationFilter
LessThanFilter
BeforeFilter
OlderThanDaysFilter
OlderThanHoursFilter
Inherited Members
OperationFilter.PerformValidateFilter(FCSession, FCGeneric)
OperationFilter.GetValueForRender(FCSession, FCGeneric, SqlHelper)
OperationFilter.PerformRender(FCSession, FCGeneric, SqlHelper)
OperationFilter.FormatOperation(FCGeneric, String, String, SqlHelper, Object)
OperationFilter.Value
ColumnBasedFilter.GetColumnNameForRender(FCGeneric)
ColumnBasedFilter.ColumnName
Filter.ValidateFilter(FCSession, FCGeneric)
Filter.Render(FCSession, FCGeneric, SqlHelper)
Filter.GetActualDateValue(FCSession, Object)
Filter.ConvertDate(FCSession, DateTime, Boolean)
Filter.ValidateDate(DateTime)
Filter.ValidateValidField(FCGeneric, String)
Filter.ValidateValidField(FCGeneric, String, Boolean)
Filter.ValidateIsIntegerField(FCGeneric, String)
Filter.ValidateIsDecimalField(FCGeneric, String)
Filter.ValidateIsDateField(FCGeneric, String)
Filter.ValidateIsStringField(FCGeneric, String)
Filter.SetParameterValue(FCGeneric, SqlHelper, String, String, Object)
Filter.Session
Filter.Generic
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Filters
Assembly: fcSDK.dll
Syntax
public class LessThanFilter : OperationFilter

Constructors

LessThanFilter(String, Filter)

Declaration
protected LessThanFilter(string columnName, Filter value)
Parameters
Type | Name | Description
System.String | columnName |
Filter | value |

LessThanFilter(String, DateTime)

Declaration
protected LessThanFilter(string columnName, DateTime value)
Parameters
Type | Name | Description
System.String | columnName |
System.DateTime | value |

LessThanFilter(String, Decimal)

Declaration
protected LessThanFilter(string columnName, decimal value)
Parameters
Type | Name | Description
System.String | columnName |
System.Decimal | value |

LessThanFilter(String, Int32)

Declaration
protected LessThanFilter(string columnName, int value)
Parameters
Type | Name | Description
System.String | columnName |
System.Int32 | value |

LessThanFilter(String, String)

Declaration
protected LessThanFilter(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |

Properties

Operator

Declaration
public override string Operator { get; }
Property Value
Type | Description
System.String |
Overrides
OperationFilter.Operator


Class LessThanOrEqualFilter | fcSDK Documentation

Class LessThanOrEqualFilter

Inheritance
System.Object
Filter
ColumnBasedFilter
OperationFilter
LessThanOrEqualFilter
Inherited Members
OperationFilter.PerformValidateFilter(FCSession, FCGeneric)
OperationFilter.GetValueForRender(FCSession, FCGeneric, SqlHelper)
OperationFilter.PerformRender(FCSession, FCGeneric, SqlHelper)
OperationFilter.FormatOperation(FCGeneric, String, String, SqlHelper, Object)
OperationFilter.Value
ColumnBasedFilter.GetColumnNameForRender(FCGeneric)
ColumnBasedFilter.ColumnName
Filter.ValidateFilter(FCSession, FCGeneric)
Filter.Render(FCSession, FCGeneric, SqlHelper)
Filter.GetActualDateValue(FCSession, Object)
Filter.ConvertDate(FCSession, DateTime, Boolean)
Filter.ValidateDate(DateTime)
Filter.ValidateValidField(FCGeneric, String)
Filter.ValidateValidField(FCGeneric, String, Boolean)
Filter.ValidateIsIntegerField(FCGeneric, String)
Filter.ValidateIsDecimalField(FCGeneric, String)
Filter.ValidateIsDateField(FCGeneric, String)
Filter.ValidateIsStringField(FCGeneric, String)
Filter.SetParameterValue(FCGeneric, SqlHelper, String, String, Object)
Filter.Session
Filter.Generic
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Filters
Assembly: fcSDK.dll
Syntax
public class LessThanOrEqualFilter : OperationFilter

Constructors

LessThanOrEqualFilter(String, Filter)

Declaration
protected LessThanOrEqualFilter(string columnName, Filter value)
Parameters
Type | Name | Description
System.String | columnName |
Filter | value |

LessThanOrEqualFilter(String, DateTime)

Declaration
protected LessThanOrEqualFilter(string columnName, DateTime value)
Parameters
Type | Name | Description
System.String | columnName |
System.DateTime | value |

LessThanOrEqualFilter(String, Decimal)

Declaration
protected LessThanOrEqualFilter(string columnName, decimal value)
Parameters
Type | Name | Description
System.String | columnName |
System.Decimal | value |

LessThanOrEqualFilter(String, Int32)

Declaration
protected LessThanOrEqualFilter(string columnName, int value)
Parameters
Type | Name | Description
System.String | columnName |
System.Int32 | value |

LessThanOrEqualFilter(String, String)

Declaration
protected LessThanOrEqualFilter(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |

Properties

Operator

Declaration
public override string Operator { get; }
Property Value
Type | Description
System.String |
Overrides
OperationFilter.Operator


Class LikeFilter | fcSDK Documentation

Class LikeFilter

Inheritance
System.Object
Filter
ColumnBasedFilter
OperationFilter
LikeFilter
ContainsFilter
EndsWithFilter
NotLikeFilter
StartsWithFilter
Inherited Members
OperationFilter.PerformValidateFilter(FCSession, FCGeneric)
OperationFilter.GetValueForRender(FCSession, FCGeneric, SqlHelper)
OperationFilter.FormatOperation(FCGeneric, String, String, SqlHelper, Object)
OperationFilter.Value
ColumnBasedFilter.GetColumnNameForRender(FCGeneric)
ColumnBasedFilter.ColumnName
Filter.ValidateFilter(FCSession, FCGeneric)
Filter.Render(FCSession, FCGeneric, SqlHelper)
Filter.GetActualDateValue(FCSession, Object)
Filter.ConvertDate(FCSession, DateTime, Boolean)
Filter.ValidateDate(DateTime)
Filter.ValidateValidField(FCGeneric, String)
Filter.ValidateValidField(FCGeneric, String, Boolean)
Filter.ValidateIsIntegerField(FCGeneric, String)
Filter.ValidateIsDecimalField(FCGeneric, String)
Filter.ValidateIsDateField(FCGeneric, String)
Filter.ValidateIsStringField(FCGeneric, String)
Filter.SetParameterValue(FCGeneric, SqlHelper, String, String, Object)
Filter.Session
Filter.Generic
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Filters
Assembly: fcSDK.dll
Syntax
public class LikeFilter : OperationFilter

Constructors

LikeFilter(String, Filter)

Declaration
protected LikeFilter(string columnName, Filter value)
Parameters
Type | Name | Description
System.String | columnName |
Filter | value |

LikeFilter(String, String)

Declaration
protected LikeFilter(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |

Properties

Operator

Declaration
public override string Operator { get; }
Property Value
Type | Description
System.String |
Overrides
OperationFilter.Operator

Methods

PerformRender(FCSession, FCGeneric, SqlHelper)

Declaration
protected override string PerformRender(FCSession fcSession, FCGeneric gen, SqlHelper dbHelper)
Parameters
Type | Name | Description
FCSession | fcSession |
FCGeneric | gen |
SqlHelper | dbHelper |
Returns
Type | Description
System.String |
Overrides
OperationFilter.PerformRender(FCSession, FCGeneric, SqlHelper)


Class LogicalFilter | fcSDK Documentation

Class LogicalFilter

Inheritance
System.Object
Filter
LogicalFilter
AndFilter
AndManyFilter
OrFilter
OrManyFilter
Inherited Members
Filter.ValidateFilter(FCSession, FCGeneric)
Filter.Render(FCSession, FCGeneric, SqlHelper)
Filter.GetActualDateValue(FCSession, Object)
Filter.ConvertDate(FCSession, DateTime, Boolean)
Filter.ValidateDate(DateTime)
Filter.ValidateValidField(FCGeneric, String)
Filter.ValidateValidField(FCGeneric, String, Boolean)
Filter.ValidateIsIntegerField(FCGeneric, String)
Filter.ValidateIsDecimalField(FCGeneric, String)
Filter.ValidateIsDateField(FCGeneric, String)
Filter.ValidateIsStringField(FCGeneric, String)
Filter.SetParameterValue(FCGeneric, SqlHelper, String, String, Object)
Filter.Session
Filter.Generic
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Filters
Assembly: fcSDK.dll
Syntax
public abstract class LogicalFilter : Filter

Constructors

LogicalFilter()

Declaration
protected LogicalFilter()

LogicalFilter(Filter)

Declaration
protected LogicalFilter(Filter filter1)
Parameters
Type | Name | Description
Filter | filter1 |

LogicalFilter(Filter, Filter)

Declaration
protected LogicalFilter(Filter filter1, Filter filter2)
Parameters
Type | Name | Description
Filter | filter1 |
Filter | filter2 |

Properties

Conjunction

Declaration
protected abstract string Conjunction { get; }
Property Value
Type | Description
System.String |

Filters

Declaration
public FilterCollection Filters { get; }
Property Value
Type | Description
FilterCollection |

Methods

AddFilter(Filter)

Declaration
public Filter AddFilter(Filter filter)
Parameters
Type | Name | Description
Filter | filter |
Returns
Type | Description
Filter |

PerformRender(FCSession, FCGeneric, SqlHelper)

Declaration
protected override string PerformRender(FCSession fcSession, FCGeneric gen, SqlHelper dbHelper)
Parameters
Type | Name | Description
FCSession | fcSession |
FCGeneric | gen |
SqlHelper | dbHelper |
Returns
Type | Description
System.String |
Overrides
Filter.PerformRender(FCSession, FCGeneric, SqlHelper)

PerformValidateFilter(FCSession, FCGeneric)

Declaration
protected override void PerformValidateFilter(FCSession session, FCGeneric gen)
Parameters
Type | Name | Description
FCSession | session |
FCGeneric | gen |
Overrides
Filter.PerformValidateFilter(FCSession, FCGeneric)


Class MoreThanFilter | fcSDK Documentation

Class MoreThanFilter

Inheritance
System.Object
Filter
ColumnBasedFilter
OperationFilter
MoreThanFilter
AfterFilter
Inherited Members
OperationFilter.PerformValidateFilter(FCSession, FCGeneric)
OperationFilter.GetValueForRender(FCSession, FCGeneric, SqlHelper)
OperationFilter.PerformRender(FCSession, FCGeneric, SqlHelper)
OperationFilter.FormatOperation(FCGeneric, String, String, SqlHelper, Object)
OperationFilter.Value
ColumnBasedFilter.GetColumnNameForRender(FCGeneric)
ColumnBasedFilter.ColumnName
Filter.ValidateFilter(FCSession, FCGeneric)
Filter.Render(FCSession, FCGeneric, SqlHelper)
Filter.GetActualDateValue(FCSession, Object)
Filter.ConvertDate(FCSession, DateTime, Boolean)
Filter.ValidateDate(DateTime)
Filter.ValidateValidField(FCGeneric, String)
Filter.ValidateValidField(FCGeneric, String, Boolean)
Filter.ValidateIsIntegerField(FCGeneric, String)
Filter.ValidateIsDecimalField(FCGeneric, String)
Filter.ValidateIsDateField(FCGeneric, String)
Filter.ValidateIsStringField(FCGeneric, String)
Filter.SetParameterValue(FCGeneric, SqlHelper, String, String, Object)
Filter.Session
Filter.Generic
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Filters
Assembly: fcSDK.dll
Syntax
public class MoreThanFilter : OperationFilter

Constructors

MoreThanFilter(String, Filter)

Declaration
protected MoreThanFilter(string columnName, Filter value)
Parameters
Type | Name | Description
System.String | columnName |
Filter | value |

MoreThanFilter(String, DateTime)

Declaration
protected MoreThanFilter(string columnName, DateTime value)
Parameters
Type | Name | Description
System.String | columnName |
System.DateTime | value |

MoreThanFilter(String, Decimal)

Declaration
protected MoreThanFilter(string columnName, decimal value)
Parameters
Type | Name | Description
System.String | columnName |
System.Decimal | value |

MoreThanFilter(String, Int32)

Declaration
protected MoreThanFilter(string columnName, int value)
Parameters
Type | Name | Description
System.String | columnName |
System.Int32 | value |

MoreThanFilter(String, String)

Declaration
protected MoreThanFilter(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |

Properties

Operator

Declaration
public override string Operator { get; }
Property Value
Type | Description
System.String |
Overrides
OperationFilter.Operator


Class MoreThanOrEqualFilter | fcSDK Documentation

Class MoreThanOrEqualFilter

Inheritance
System.Object
Filter
ColumnBasedFilter
OperationFilter
MoreThanOrEqualFilter
Inherited Members
OperationFilter.PerformValidateFilter(FCSession, FCGeneric)
OperationFilter.GetValueForRender(FCSession, FCGeneric, SqlHelper)
OperationFilter.PerformRender(FCSession, FCGeneric, SqlHelper)
OperationFilter.FormatOperation(FCGeneric, String, String, SqlHelper, Object)
OperationFilter.Value
ColumnBasedFilter.GetColumnNameForRender(FCGeneric)
ColumnBasedFilter.ColumnName
Filter.ValidateFilter(FCSession, FCGeneric)
Filter.Render(FCSession, FCGeneric, SqlHelper)
Filter.GetActualDateValue(FCSession, Object)
Filter.ConvertDate(FCSession, DateTime, Boolean)
Filter.ValidateDate(DateTime)
Filter.ValidateValidField(FCGeneric, String)
Filter.ValidateValidField(FCGeneric, String, Boolean)
Filter.ValidateIsIntegerField(FCGeneric, String)
Filter.ValidateIsDecimalField(FCGeneric, String)
Filter.ValidateIsDateField(FCGeneric, String)
Filter.ValidateIsStringField(FCGeneric, String)
Filter.SetParameterValue(FCGeneric, SqlHelper, String, String, Object)
Filter.Session
Filter.Generic
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Filters
Assembly: fcSDK.dll
Syntax
public class MoreThanOrEqualFilter : OperationFilter

Constructors

MoreThanOrEqualFilter(String, Filter)

Declaration
protected MoreThanOrEqualFilter(string columnName, Filter value)
Parameters
Type | Name | Description
System.String | columnName |
Filter | value |

MoreThanOrEqualFilter(String, DateTime)

Declaration
protected MoreThanOrEqualFilter(string columnName, DateTime value)
Parameters
Type | Name | Description
System.String | columnName |
System.DateTime | value |

MoreThanOrEqualFilter(String, Decimal)

Declaration
protected MoreThanOrEqualFilter(string columnName, decimal value)
Parameters
Type | Name | Description
System.String | columnName |
System.Decimal | value |

MoreThanOrEqualFilter(String, Int32)

Declaration
protected MoreThanOrEqualFilter(string columnName, int value)
Parameters
Type | Name | Description
System.String | columnName |
System.Int32 | value |

MoreThanOrEqualFilter(String, String)

Declaration
protected MoreThanOrEqualFilter(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |

Properties

Operator

Declaration
public override string Operator { get; }
Property Value
Type | Description
System.String |
Overrides
OperationFilter.Operator


Class NotContainsFilter | fcSDK Documentation

Class NotContainsFilter

Inheritance
System.Object
Filter
ColumnBasedFilter
OperationFilter
LikeFilter
NotLikeFilter
NotContainsFilter
Inherited Members
NotLikeFilter.Operator
LikeFilter.PerformRender(FCSession, FCGeneric, SqlHelper)
OperationFilter.PerformValidateFilter(FCSession, FCGeneric)
OperationFilter.FormatOperation(FCGeneric, String, String, SqlHelper, Object)
OperationFilter.Value
ColumnBasedFilter.GetColumnNameForRender(FCGeneric)
ColumnBasedFilter.ColumnName
Filter.ValidateFilter(FCSession, FCGeneric)
Filter.Render(FCSession, FCGeneric, SqlHelper)
Filter.GetActualDateValue(FCSession, Object)
Filter.ConvertDate(FCSession, DateTime, Boolean)
Filter.ValidateDate(DateTime)
Filter.ValidateValidField(FCGeneric, String)
Filter.ValidateValidField(FCGeneric, String, Boolean)
Filter.ValidateIsIntegerField(FCGeneric, String)
Filter.ValidateIsDecimalField(FCGeneric, String)
Filter.ValidateIsDateField(FCGeneric, String)
Filter.ValidateIsStringField(FCGeneric, String)
Filter.SetParameterValue(FCGeneric, SqlHelper, String, String, Object)
Filter.Session
Filter.Generic
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Filters
Assembly: fcSDK.dll
Syntax
public class NotContainsFilter : NotLikeFilter

Constructors

NotContainsFilter(String, Filter)

Declaration
protected NotContainsFilter(string columnName, Filter value)
Parameters
Type | Name | Description
System.String | columnName |
Filter | value |

NotContainsFilter(String, String)

Declaration
protected NotContainsFilter(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |

Methods

GetValueForRender(FCSession, FCGeneric, SqlHelper)

Declaration
protected override object GetValueForRender(FCSession sess, FCGeneric gen, SqlHelper dbHelper)
Parameters
Type | Name | Description
FCSession | sess |
FCGeneric | gen |
SqlHelper | dbHelper |
Returns
Type | Description
System.Object |
Overrides
OperationFilter.GetValueForRender(FCSession, FCGeneric, SqlHelper)


Class NotEndsWithFilter | fcSDK Documentation

Class NotEndsWithFilter

Inheritance
System.Object
Filter
ColumnBasedFilter
OperationFilter
LikeFilter
NotLikeFilter
NotEndsWithFilter
Inherited Members
NotLikeFilter.Operator
LikeFilter.PerformRender(FCSession, FCGeneric, SqlHelper)
OperationFilter.PerformValidateFilter(FCSession, FCGeneric)
OperationFilter.FormatOperation(FCGeneric, String, String, SqlHelper, Object)
OperationFilter.Value
ColumnBasedFilter.GetColumnNameForRender(FCGeneric)
ColumnBasedFilter.ColumnName
Filter.ValidateFilter(FCSession, FCGeneric)
Filter.Render(FCSession, FCGeneric, SqlHelper)
Filter.GetActualDateValue(FCSession, Object)
Filter.ConvertDate(FCSession, DateTime, Boolean)
Filter.ValidateDate(DateTime)
Filter.ValidateValidField(FCGeneric, String)
Filter.ValidateValidField(FCGeneric, String, Boolean)
Filter.ValidateIsIntegerField(FCGeneric, String)
Filter.ValidateIsDecimalField(FCGeneric, String)
Filter.ValidateIsDateField(FCGeneric, String)
Filter.ValidateIsStringField(FCGeneric, String)
Filter.SetParameterValue(FCGeneric, SqlHelper, String, String, Object)
Filter.Session
Filter.Generic
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Filters
Assembly: fcSDK.dll
Syntax
public class NotEndsWithFilter : NotLikeFilter

Constructors

NotEndsWithFilter(String, Filter)

Declaration
protected NotEndsWithFilter(string columnName, Filter value)
Parameters
Type | Name | Description
System.String | columnName |
Filter | value |

NotEndsWithFilter(String, String)

Declaration
protected NotEndsWithFilter(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |

Methods

GetValueForRender(FCSession, FCGeneric, SqlHelper)

Declaration
protected override object GetValueForRender(FCSession sess, FCGeneric gen, SqlHelper dbHelper)
Parameters
Type | Name | Description
FCSession | sess |
FCGeneric | gen |
SqlHelper | dbHelper |
Returns
Type | Description
System.Object |
Overrides
OperationFilter.GetValueForRender(FCSession, FCGeneric, SqlHelper)


Class NotLikeFilter | fcSDK Documentation

Class NotLikeFilter

Inheritance
System.Object
Filter
ColumnBasedFilter
OperationFilter
LikeFilter
NotLikeFilter
NotContainsFilter
NotEndsWithFilter
NotStartsWithFilter
Inherited Members
LikeFilter.PerformRender(FCSession, FCGeneric, SqlHelper)
OperationFilter.PerformValidateFilter(FCSession, FCGeneric)
OperationFilter.GetValueForRender(FCSession, FCGeneric, SqlHelper)
OperationFilter.FormatOperation(FCGeneric, String, String, SqlHelper, Object)
OperationFilter.Value
ColumnBasedFilter.GetColumnNameForRender(FCGeneric)
ColumnBasedFilter.ColumnName
Filter.ValidateFilter(FCSession, FCGeneric)
Filter.Render(FCSession, FCGeneric, SqlHelper)
Filter.GetActualDateValue(FCSession, Object)
Filter.ConvertDate(FCSession, DateTime, Boolean)
Filter.ValidateDate(DateTime)
Filter.ValidateValidField(FCGeneric, String)
Filter.ValidateValidField(FCGeneric, String, Boolean)
Filter.ValidateIsIntegerField(FCGeneric, String)
Filter.ValidateIsDecimalField(FCGeneric, String)
Filter.ValidateIsDateField(FCGeneric, String)
Filter.ValidateIsStringField(FCGeneric, String)
Filter.SetParameterValue(FCGeneric, SqlHelper, String, String, Object)
Filter.Session
Filter.Generic
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Filters
Assembly: fcSDK.dll
Syntax
public class NotLikeFilter : LikeFilter

Constructors

NotLikeFilter(String, Filter)

Declaration
protected NotLikeFilter(string columnName, Filter value)
Parameters
Type | Name | Description
System.String | columnName |
Filter | value |

NotLikeFilter(String, String)

Declaration
protected NotLikeFilter(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |

Properties

Operator

Declaration
public override string Operator { get; }
Property Value
Type | Description
System.String |
Overrides
LikeFilter.Operator


Class NotStartsWithFilter | fcSDK Documentation

Class NotStartsWithFilter

Inheritance
System.Object
Filter
ColumnBasedFilter
OperationFilter
LikeFilter
NotLikeFilter
NotStartsWithFilter
Inherited Members
NotLikeFilter.Operator
LikeFilter.PerformRender(FCSession, FCGeneric, SqlHelper)
OperationFilter.PerformValidateFilter(FCSession, FCGeneric)
OperationFilter.FormatOperation(FCGeneric, String, String, SqlHelper, Object)
OperationFilter.Value
ColumnBasedFilter.GetColumnNameForRender(FCGeneric)
ColumnBasedFilter.ColumnName
Filter.ValidateFilter(FCSession, FCGeneric)
Filter.Render(FCSession, FCGeneric, SqlHelper)
Filter.GetActualDateValue(FCSession, Object)
Filter.ConvertDate(FCSession, DateTime, Boolean)
Filter.ValidateDate(DateTime)
Filter.ValidateValidField(FCGeneric, String)
Filter.ValidateValidField(FCGeneric, String, Boolean)
Filter.ValidateIsIntegerField(FCGeneric, String)
Filter.ValidateIsDecimalField(FCGeneric, String)
Filter.ValidateIsDateField(FCGeneric, String)
Filter.ValidateIsStringField(FCGeneric, String)
Filter.SetParameterValue(FCGeneric, SqlHelper, String, String, Object)
Filter.Session
Filter.Generic
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Filters
Assembly: fcSDK.dll
Syntax
public class NotStartsWithFilter : NotLikeFilter

Constructors

NotStartsWithFilter(String, Filter)

Declaration
protected NotStartsWithFilter(string columnName, Filter value)
Parameters
Type | Name | Description
System.String | columnName |
Filter | value |

NotStartsWithFilter(String, String)

Declaration
protected NotStartsWithFilter(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |

Methods

GetValueForRender(FCSession, FCGeneric, SqlHelper)

Declaration
protected override object GetValueForRender(FCSession sess, FCGeneric gen, SqlHelper dbHelper)
Parameters
Type | Name | Description
FCSession | sess |
FCGeneric | gen |
SqlHelper | dbHelper |
Returns
Type | Description
System.Object |
Overrides
OperationFilter.GetValueForRender(FCSession, FCGeneric, SqlHelper)


Class OlderThanDaysFilter | fcSDK Documentation

Class OlderThanDaysFilter

Inheritance
System.Object
Filter
ColumnBasedFilter
OperationFilter
LessThanFilter
OlderThanDaysFilter
Inherited Members
LessThanFilter.Operator
OperationFilter.PerformRender(FCSession, FCGeneric, SqlHelper)
OperationFilter.FormatOperation(FCGeneric, String, String, SqlHelper, Object)
OperationFilter.Value
ColumnBasedFilter.GetColumnNameForRender(FCGeneric)
ColumnBasedFilter.ColumnName
Filter.ValidateFilter(FCSession, FCGeneric)
Filter.Render(FCSession, FCGeneric, SqlHelper)
Filter.GetActualDateValue(FCSession, Object)
Filter.ConvertDate(FCSession, DateTime, Boolean)
Filter.ValidateDate(DateTime)
Filter.ValidateValidField(FCGeneric, String)
Filter.ValidateValidField(FCGeneric, String, Boolean)
Filter.ValidateIsIntegerField(FCGeneric, String)
Filter.ValidateIsDecimalField(FCGeneric, String)
Filter.ValidateIsDateField(FCGeneric, String)
Filter.ValidateIsStringField(FCGeneric, String)
Filter.SetParameterValue(FCGeneric, SqlHelper, String, String, Object)
Filter.Session
Filter.Generic
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Filters
Assembly: fcSDK.dll
Syntax
public class OlderThanDaysFilter : LessThanFilter

Constructors

OlderThanDaysFilter(String, Filter)

Declaration
protected OlderThanDaysFilter(string columnName, Filter value)
Parameters
Type | Name | Description
System.String | columnName |
Filter | value |

OlderThanDaysFilter(String, Decimal)

Declaration
protected OlderThanDaysFilter(string columnName, decimal value)
Parameters
Type | Name | Description
System.String | columnName |
System.Decimal | value |

OlderThanDaysFilter(String, Int32)

Declaration
protected OlderThanDaysFilter(string columnName, int value)
Parameters
Type | Name | Description
System.String | columnName |
System.Int32 | value |

Methods

GetValueForRender(FCSession, FCGeneric, SqlHelper)

Declaration
protected override object GetValueForRender(FCSession session, FCGeneric gen, SqlHelper dbHelper)
Parameters
Type | Name | Description
FCSession | session |
FCGeneric | gen |
SqlHelper | dbHelper |
Returns
Type | Description
System.Object |
Overrides
OperationFilter.GetValueForRender(FCSession, FCGeneric, SqlHelper)

PerformValidateFilter(FCSession, FCGeneric)

Declaration
protected override void PerformValidateFilter(FCSession session, FCGeneric gen)
Parameters
Type | Name | Description
FCSession | session |
FCGeneric | gen |
Overrides
OperationFilter.PerformValidateFilter(FCSession, FCGeneric)


Class OlderThanHoursFilter | fcSDK Documentation

Class OlderThanHoursFilter

Inheritance
System.Object
Filter
ColumnBasedFilter
OperationFilter
LessThanFilter
OlderThanHoursFilter
Inherited Members
LessThanFilter.Operator
OperationFilter.PerformRender(FCSession, FCGeneric, SqlHelper)
OperationFilter.FormatOperation(FCGeneric, String, String, SqlHelper, Object)
OperationFilter.Value
ColumnBasedFilter.GetColumnNameForRender(FCGeneric)
ColumnBasedFilter.ColumnName
Filter.ValidateFilter(FCSession, FCGeneric)
Filter.Render(FCSession, FCGeneric, SqlHelper)
Filter.GetActualDateValue(FCSession, Object)
Filter.ConvertDate(FCSession, DateTime, Boolean)
Filter.ValidateDate(DateTime)
Filter.ValidateValidField(FCGeneric, String)
Filter.ValidateValidField(FCGeneric, String, Boolean)
Filter.ValidateIsIntegerField(FCGeneric, String)
Filter.ValidateIsDecimalField(FCGeneric, String)
Filter.ValidateIsDateField(FCGeneric, String)
Filter.ValidateIsStringField(FCGeneric, String)
Filter.SetParameterValue(FCGeneric, SqlHelper, String, String, Object)
Filter.Session
Filter.Generic
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Filters
Assembly: fcSDK.dll
Syntax
public class OlderThanHoursFilter : LessThanFilter

Constructors

OlderThanHoursFilter(String, Filter)

Declaration
protected OlderThanHoursFilter(string columnName, Filter value)
Parameters
Type | Name | Description
System.String | columnName |
Filter | value |

OlderThanHoursFilter(String, Decimal)

Declaration
protected OlderThanHoursFilter(string columnName, decimal value)
Parameters
Type | Name | Description
System.String | columnName |
System.Decimal | value |

OlderThanHoursFilter(String, Int32)

Declaration
protected OlderThanHoursFilter(string columnName, int value)
Parameters
Type | Name | Description
System.String | columnName |
System.Int32 | value |

Methods

GetValueForRender(FCSession, FCGeneric, SqlHelper)

Declaration
protected override object GetValueForRender(FCSession sess, FCGeneric gen, SqlHelper dbHelper)
Parameters
Type | Name | Description
FCSession | sess |
FCGeneric | gen |
SqlHelper | dbHelper |
Returns
Type | Description
System.Object |
Overrides
OperationFilter.GetValueForRender(FCSession, FCGeneric, SqlHelper)

PerformValidateFilter(FCSession, FCGeneric)

Declaration
protected override void PerformValidateFilter(FCSession session, FCGeneric gen)
Parameters
Type | Name | Description
FCSession | session |
FCGeneric | gen |
Overrides
OperationFilter.PerformValidateFilter(FCSession, FCGeneric)


Class OnFilter | fcSDK Documentation

Class OnFilter

Inheritance
System.Object
Filter
ColumnBasedFilter
BetweenFilter
OnFilter
TodayFilter
TomorrowFilter
Inherited Members
BetweenFilter.FILTER_BETWEEN
BetweenFilter.FILTER_NOT_BETWEEN
BetweenFilter.ValidateOperand(FCGeneric, Object)
BetweenFilter.PerformRender(FCSession, FCGeneric, SqlHelper)
BetweenFilter.Value1Present
BetweenFilter.Value2Present
BetweenFilter.Value1
BetweenFilter.Value2
BetweenFilter.IsBetween
ColumnBasedFilter.GetColumnNameForRender(FCGeneric)
ColumnBasedFilter.ColumnName
Filter.ValidateFilter(FCSession, FCGeneric)
Filter.Render(FCSession, FCGeneric, SqlHelper)
Filter.GetActualDateValue(FCSession, Object)
Filter.ConvertDate(FCSession, DateTime, Boolean)
Filter.ValidateDate(DateTime)
Filter.ValidateValidField(FCGeneric, String)
Filter.ValidateValidField(FCGeneric, String, Boolean)
Filter.ValidateIsIntegerField(FCGeneric, String)
Filter.ValidateIsDecimalField(FCGeneric, String)
Filter.ValidateIsDateField(FCGeneric, String)
Filter.ValidateIsStringField(FCGeneric, String)
Filter.SetParameterValue(FCGeneric, SqlHelper, String, String, Object)
Filter.Session
Filter.Generic
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Filters
Assembly: fcSDK.dll
Syntax
public class OnFilter : BetweenFilter

Constructors

OnFilter(String, DateTime)

Declaration
protected OnFilter(string columnName, DateTime value)
Parameters
Type | Name | Description
System.String | columnName |
System.DateTime | value |

Fields

dateValStart

Declaration
protected DateTime dateValStart
Field Value
Type | Description
System.DateTime |

Methods

GetValue1ForRender(FCSession, FCGeneric, SqlHelper)

Declaration
protected override object GetValue1ForRender(FCSession sess, FCGeneric gen, SqlHelper dbHelper)
Parameters
Type | Name | Description
FCSession | sess |
FCGeneric | gen |
SqlHelper | dbHelper |
Returns
Type | Description
System.Object |
Overrides
BetweenFilter.GetValue1ForRender(FCSession, FCGeneric, SqlHelper)

GetValue2ForRender(FCSession, FCGeneric, SqlHelper)

Declaration
protected override object GetValue2ForRender(FCSession sess, FCGeneric gen, SqlHelper dbHelper)
Parameters
Type | Name | Description
FCSession | sess |
FCGeneric | gen |
SqlHelper | dbHelper |
Returns
Type | Description
System.Object |
Overrides
BetweenFilter.GetValue2ForRender(FCSession, FCGeneric, SqlHelper)

PerformValidateFilter(FCSession, FCGeneric)

Declaration
protected override void PerformValidateFilter(FCSession session, FCGeneric gen)
Parameters
Type | Name | Description
FCSession | session |
FCGeneric | gen |
Overrides
BetweenFilter.PerformValidateFilter(FCSession, FCGeneric)


Class OperationFilter | fcSDK Documentation

Class OperationFilter

Inheritance
System.Object
Filter
ColumnBasedFilter
OperationFilter
EqualsFilter
LessThanFilter
LessThanOrEqualFilter
LikeFilter
MoreThanFilter
MoreThanOrEqualFilter
Inherited Members
ColumnBasedFilter.GetColumnNameForRender(FCGeneric)
ColumnBasedFilter.ColumnName
Filter.ValidateFilter(FCSession, FCGeneric)
Filter.Render(FCSession, FCGeneric, SqlHelper)
Filter.GetActualDateValue(FCSession, Object)
Filter.ConvertDate(FCSession, DateTime, Boolean)
Filter.ValidateDate(DateTime)
Filter.ValidateValidField(FCGeneric, String)
Filter.ValidateValidField(FCGeneric, String, Boolean)
Filter.ValidateIsIntegerField(FCGeneric, String)
Filter.ValidateIsDecimalField(FCGeneric, String)
Filter.ValidateIsDateField(FCGeneric, String)
Filter.ValidateIsStringField(FCGeneric, String)
Filter.SetParameterValue(FCGeneric, SqlHelper, String, String, Object)
Filter.Session
Filter.Generic
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Filters
Assembly: fcSDK.dll
Syntax
public abstract class OperationFilter : ColumnBasedFilter

Constructors

OperationFilter(String, DateTime)

Declaration
protected OperationFilter(string columnName, DateTime value)
Parameters
Type | Name | Description
System.String | columnName |
System.DateTime | value |

OperationFilter(String, Decimal)

Declaration
protected OperationFilter(string columnName, decimal value)
Parameters
Type | Name | Description
System.String | columnName |
System.Decimal | value |

OperationFilter(String, Int32)

Declaration
protected OperationFilter(string columnName, int value)
Parameters
Type | Name | Description
System.String | columnName |
System.Int32 | value |

OperationFilter(String, Object)

Declaration
protected OperationFilter(string columnName, object value)
Parameters
Type | Name | Description
System.String | columnName |
System.Object | value |

OperationFilter(String, String)

Declaration
protected OperationFilter(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |

Properties

Operator

Declaration
public abstract string Operator { get; }
Property Value
Type | Description
System.String |

Value

Declaration
public object Value { get; }
Property Value
Type | Description
System.Object |

Methods

FormatOperation(FCGeneric, String, String, SqlHelper, Object)

Declaration
protected virtual string FormatOperation(FCGeneric gen, string columnName, string oper, SqlHelper dbHelper, object value)
Parameters
Type | Name | Description
FCGeneric | gen |
System.String | columnName |
System.String | oper |
SqlHelper | dbHelper |
System.Object | value |
Returns
Type | Description
System.String |

GetValueForRender(FCSession, FCGeneric, SqlHelper)

Declaration
protected virtual object GetValueForRender(FCSession sess, FCGeneric gen, SqlHelper dbHelper)
Parameters
Type | Name | Description
FCSession | sess |
FCGeneric | gen |
SqlHelper | dbHelper |
Returns
Type | Description
System.Object |

PerformRender(FCSession, FCGeneric, SqlHelper)

Declaration
protected override string PerformRender(FCSession fcSession, FCGeneric gen, SqlHelper dbHelper)
Parameters
Type | Name | Description
FCSession | fcSession |
FCGeneric | gen |
SqlHelper | dbHelper |
Returns
Type | Description
System.String |
Overrides
Filter.PerformRender(FCSession, FCGeneric, SqlHelper)

PerformValidateFilter(FCSession, FCGeneric)

Declaration
protected override void PerformValidateFilter(FCSession session, FCGeneric gen)
Parameters
Type | Name | Description
FCSession | session |
FCGeneric | gen |
Overrides
Filter.PerformValidateFilter(FCSession, FCGeneric)


Class OrFilter | fcSDK Documentation

Class OrFilter

Inheritance
System.Object
Filter
LogicalFilter
OrFilter
Inherited Members
LogicalFilter.AddFilter(Filter)
LogicalFilter.PerformValidateFilter(FCSession, FCGeneric)
LogicalFilter.PerformRender(FCSession, FCGeneric, SqlHelper)
LogicalFilter.Filters
Filter.ValidateFilter(FCSession, FCGeneric)
Filter.Render(FCSession, FCGeneric, SqlHelper)
Filter.GetActualDateValue(FCSession, Object)
Filter.ConvertDate(FCSession, DateTime, Boolean)
Filter.ValidateDate(DateTime)
Filter.ValidateValidField(FCGeneric, String)
Filter.ValidateValidField(FCGeneric, String, Boolean)
Filter.ValidateIsIntegerField(FCGeneric, String)
Filter.ValidateIsDecimalField(FCGeneric, String)
Filter.ValidateIsDateField(FCGeneric, String)
Filter.ValidateIsStringField(FCGeneric, String)
Filter.SetParameterValue(FCGeneric, SqlHelper, String, String, Object)
Filter.Session
Filter.Generic
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Filters
Assembly: fcSDK.dll
Syntax
public class OrFilter : LogicalFilter

Constructors

OrFilter(Filter, Filter)

Declaration
protected OrFilter(Filter filter1, Filter filter2)
Parameters
Type | Name | Description
Filter | filter1 |
Filter | filter2 |

Properties

Conjunction

Declaration
protected override string Conjunction { get; }
Property Value
Type | Description
System.String |
Overrides
LogicalFilter.Conjunction


Class OrManyFilter | fcSDK Documentation

Class OrManyFilter

Inheritance
System.Object
Filter
LogicalFilter
OrManyFilter
Inherited Members
LogicalFilter.AddFilter(Filter)
LogicalFilter.PerformValidateFilter(FCSession, FCGeneric)
LogicalFilter.PerformRender(FCSession, FCGeneric, SqlHelper)
LogicalFilter.Filters
Filter.ValidateFilter(FCSession, FCGeneric)
Filter.Render(FCSession, FCGeneric, SqlHelper)
Filter.GetActualDateValue(FCSession, Object)
Filter.ConvertDate(FCSession, DateTime, Boolean)
Filter.ValidateDate(DateTime)
Filter.ValidateValidField(FCGeneric, String)
Filter.ValidateValidField(FCGeneric, String, Boolean)
Filter.ValidateIsIntegerField(FCGeneric, String)
Filter.ValidateIsDecimalField(FCGeneric, String)
Filter.ValidateIsDateField(FCGeneric, String)
Filter.ValidateIsStringField(FCGeneric, String)
Filter.SetParameterValue(FCGeneric, SqlHelper, String, String, Object)
Filter.Session
Filter.Generic
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Filters
Assembly: fcSDK.dll
Syntax
public class OrManyFilter : LogicalFilter

Constructors

OrManyFilter(Filter[])

Declaration
protected OrManyFilter(params Filter[] filters)
Parameters
Type | Name | Description
Filter[] | filters |

Properties

Conjunction

Declaration
protected override string Conjunction { get; }
Property Value
Type | Description
System.String |
Overrides
LogicalFilter.Conjunction


Class SoundsLikeFilter | fcSDK Documentation

Class SoundsLikeFilter

Inheritance
System.Object
Filter
ColumnBasedFilter
SoundsLikeFilter
Inherited Members
ColumnBasedFilter.GetColumnNameForRender(FCGeneric)
ColumnBasedFilter.ColumnName
Filter.ValidateFilter(FCSession, FCGeneric)
Filter.Render(FCSession, FCGeneric, SqlHelper)
Filter.GetActualDateValue(FCSession, Object)
Filter.ConvertDate(FCSession, DateTime, Boolean)
Filter.ValidateDate(DateTime)
Filter.ValidateValidField(FCGeneric, String)
Filter.ValidateValidField(FCGeneric, String, Boolean)
Filter.ValidateIsIntegerField(FCGeneric, String)
Filter.ValidateIsDecimalField(FCGeneric, String)
Filter.ValidateIsDateField(FCGeneric, String)
Filter.ValidateIsStringField(FCGeneric, String)
Filter.SetParameterValue(FCGeneric, SqlHelper, String, String, Object)
Filter.Session
Filter.Generic
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Filters
Assembly: fcSDK.dll
Syntax
public class SoundsLikeFilter : ColumnBasedFilter

Constructors

SoundsLikeFilter(String, String)

Declaration
protected SoundsLikeFilter(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |

Properties

Value

Declaration
public string Value { get; }
Property Value
Type | Description
System.String |

Methods

PerformRender(FCSession, FCGeneric, SqlHelper)

Declaration
protected override string PerformRender(FCSession fcSession, FCGeneric gen, SqlHelper dbHelper)
Parameters
Type | Name | Description
FCSession | fcSession |
FCGeneric | gen |
SqlHelper | dbHelper |
Returns
Type | Description
System.String |
Overrides
Filter.PerformRender(FCSession, FCGeneric, SqlHelper)

PerformValidateFilter(FCSession, FCGeneric)

Declaration
protected override void PerformValidateFilter(FCSession session, FCGeneric gen)
Parameters
Type | Name | Description
FCSession | session |
FCGeneric | gen |
Overrides
Filter.PerformValidateFilter(FCSession, FCGeneric)


Class StartsWithFilter | fcSDK Documentation

Class StartsWithFilter

Inheritance
System.Object
Filter
ColumnBasedFilter
OperationFilter
LikeFilter
StartsWithFilter
Inherited Members
LikeFilter.PerformRender(FCSession, FCGeneric, SqlHelper)
LikeFilter.Operator
OperationFilter.PerformValidateFilter(FCSession, FCGeneric)
OperationFilter.FormatOperation(FCGeneric, String, String, SqlHelper, Object)
OperationFilter.Value
ColumnBasedFilter.GetColumnNameForRender(FCGeneric)
ColumnBasedFilter.ColumnName
Filter.ValidateFilter(FCSession, FCGeneric)
Filter.Render(FCSession, FCGeneric, SqlHelper)
Filter.GetActualDateValue(FCSession, Object)
Filter.ConvertDate(FCSession, DateTime, Boolean)
Filter.ValidateDate(DateTime)
Filter.ValidateValidField(FCGeneric, String)
Filter.ValidateValidField(FCGeneric, String, Boolean)
Filter.ValidateIsIntegerField(FCGeneric, String)
Filter.ValidateIsDecimalField(FCGeneric, String)
Filter.ValidateIsDateField(FCGeneric, String)
Filter.ValidateIsStringField(FCGeneric, String)
Filter.SetParameterValue(FCGeneric, SqlHelper, String, String, Object)
Filter.Session
Filter.Generic
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Filters
Assembly: fcSDK.dll
Syntax
public class StartsWithFilter : LikeFilter

Constructors

StartsWithFilter(String, Filter)

Declaration
protected StartsWithFilter(string columnName, Filter value)
Parameters
Type | Name | Description
System.String | columnName |
Filter | value |

StartsWithFilter(String, String)

Declaration
protected StartsWithFilter(string columnName, string value)
Parameters
Type | Name | Description
System.String | columnName |
System.String | value |

Methods

GetValueForRender(FCSession, FCGeneric, SqlHelper)

Declaration
protected override object GetValueForRender(FCSession sess, FCGeneric gen, SqlHelper dbHelper)
Parameters
Type | Name | Description
FCSession | sess |
FCGeneric | gen |
SqlHelper | dbHelper |
Returns
Type | Description
System.Object |
Overrides
OperationFilter.GetValueForRender(FCSession, FCGeneric, SqlHelper)


Class TodayFilter | fcSDK Documentation

Class TodayFilter

Inheritance
System.Object
Filter
ColumnBasedFilter
BetweenFilter
OnFilter
TodayFilter
Inherited Members
OnFilter.dateValStart
OnFilter.GetValue2ForRender(FCSession, FCGeneric, SqlHelper)
BetweenFilter.FILTER_BETWEEN
BetweenFilter.FILTER_NOT_BETWEEN
BetweenFilter.ValidateOperand(FCGeneric, Object)
BetweenFilter.PerformRender(FCSession, FCGeneric, SqlHelper)
BetweenFilter.Value1Present
BetweenFilter.Value2Present
BetweenFilter.Value1
BetweenFilter.Value2
BetweenFilter.IsBetween
ColumnBasedFilter.GetColumnNameForRender(FCGeneric)
ColumnBasedFilter.ColumnName
Filter.ValidateFilter(FCSession, FCGeneric)
Filter.Render(FCSession, FCGeneric, SqlHelper)
Filter.GetActualDateValue(FCSession, Object)
Filter.ConvertDate(FCSession, DateTime, Boolean)
Filter.ValidateDate(DateTime)
Filter.ValidateValidField(FCGeneric, String)
Filter.ValidateValidField(FCGeneric, String, Boolean)
Filter.ValidateIsIntegerField(FCGeneric, String)
Filter.ValidateIsDecimalField(FCGeneric, String)
Filter.ValidateIsDateField(FCGeneric, String)
Filter.ValidateIsStringField(FCGeneric, String)
Filter.SetParameterValue(FCGeneric, SqlHelper, String, String, Object)
Filter.Session
Filter.Generic
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Filters
Assembly: fcSDK.dll
Syntax
public class TodayFilter : OnFilter

Constructors

TodayFilter(String)

Declaration
protected TodayFilter(string columnName)
Parameters
Type | Name | Description
System.String | columnName |

Methods

GetValue1ForRender(FCSession, FCGeneric, SqlHelper)

Declaration
protected override object GetValue1ForRender(FCSession sess, FCGeneric gen, SqlHelper dbHelper)
Parameters
Type | Name | Description
FCSession | sess |
FCGeneric | gen |
SqlHelper | dbHelper |
Returns
Type | Description
System.Object |
Overrides
OnFilter.GetValue1ForRender(FCSession, FCGeneric, SqlHelper)

PerformValidateFilter(FCSession, FCGeneric)

Declaration
protected override void PerformValidateFilter(FCSession session, FCGeneric gen)
Parameters
Type | Name | Description
FCSession | session |
FCGeneric | gen |
Overrides
OnFilter.PerformValidateFilter(FCSession, FCGeneric)


Class TomorrowFilter | fcSDK Documentation

Class TomorrowFilter

Inheritance
System.Object
Filter
ColumnBasedFilter
BetweenFilter
OnFilter
TomorrowFilter
Inherited Members
OnFilter.dateValStart
OnFilter.GetValue2ForRender(FCSession, FCGeneric, SqlHelper)
BetweenFilter.FILTER_BETWEEN
BetweenFilter.FILTER_NOT_BETWEEN
BetweenFilter.ValidateOperand(FCGeneric, Object)
BetweenFilter.PerformRender(FCSession, FCGeneric, SqlHelper)
BetweenFilter.Value1Present
BetweenFilter.Value2Present
BetweenFilter.Value1
BetweenFilter.Value2
BetweenFilter.IsBetween
ColumnBasedFilter.GetColumnNameForRender(FCGeneric)
ColumnBasedFilter.ColumnName
Filter.ValidateFilter(FCSession, FCGeneric)
Filter.Render(FCSession, FCGeneric, SqlHelper)
Filter.GetActualDateValue(FCSession, Object)
Filter.ConvertDate(FCSession, DateTime, Boolean)
Filter.ValidateDate(DateTime)
Filter.ValidateValidField(FCGeneric, String)
Filter.ValidateValidField(FCGeneric, String, Boolean)
Filter.ValidateIsIntegerField(FCGeneric, String)
Filter.ValidateIsDecimalField(FCGeneric, String)
Filter.ValidateIsDateField(FCGeneric, String)
Filter.ValidateIsStringField(FCGeneric, String)
Filter.SetParameterValue(FCGeneric, SqlHelper, String, String, Object)
Filter.Session
Filter.Generic
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Filters
Assembly: fcSDK.dll
Syntax
public class TomorrowFilter : OnFilter

Constructors

TomorrowFilter(String)

Declaration
protected TomorrowFilter(string columnName)
Parameters
Type | Name | Description
System.String | columnName |

Methods

GetValue1ForRender(FCSession, FCGeneric, SqlHelper)

Declaration
protected override object GetValue1ForRender(FCSession sess, FCGeneric gen, SqlHelper dbHelper)
Parameters
Type | Name | Description
FCSession | sess |
FCGeneric | gen |
SqlHelper | dbHelper |
Returns
Type | Description
System.Object |
Overrides
OnFilter.GetValue1ForRender(FCSession, FCGeneric, SqlHelper)

PerformValidateFilter(FCSession, FCGeneric)

Declaration
protected override void PerformValidateFilter(FCSession session, FCGeneric gen)
Parameters
Type | Name | Description
FCSession | session |
FCGeneric | gen |
Overrides
OnFilter.PerformValidateFilter(FCSession, FCGeneric)


Class WithinDaysFilter | fcSDK Documentation

Class WithinDaysFilter

Inheritance
System.Object
Filter
ColumnBasedFilter
BetweenFilter
WithinDaysFilter
Inherited Members
BetweenFilter.FILTER_BETWEEN
BetweenFilter.FILTER_NOT_BETWEEN
BetweenFilter.ValidateOperand(FCGeneric, Object)
BetweenFilter.PerformRender(FCSession, FCGeneric, SqlHelper)
BetweenFilter.Value1Present
BetweenFilter.Value2Present
BetweenFilter.Value1
BetweenFilter.Value2
BetweenFilter.IsBetween
ColumnBasedFilter.GetColumnNameForRender(FCGeneric)
ColumnBasedFilter.ColumnName
Filter.ValidateFilter(FCSession, FCGeneric)
Filter.Render(FCSession, FCGeneric, SqlHelper)
Filter.GetActualDateValue(FCSession, Object)
Filter.ConvertDate(FCSession, DateTime, Boolean)
Filter.ValidateDate(DateTime)
Filter.ValidateValidField(FCGeneric, String)
Filter.ValidateValidField(FCGeneric, String, Boolean)
Filter.ValidateIsIntegerField(FCGeneric, String)
Filter.ValidateIsDecimalField(FCGeneric, String)
Filter.ValidateIsDateField(FCGeneric, String)
Filter.ValidateIsStringField(FCGeneric, String)
Filter.SetParameterValue(FCGeneric, SqlHelper, String, String, Object)
Filter.Session
Filter.Generic
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Filters
Assembly: fcSDK.dll
Syntax
public class WithinDaysFilter : BetweenFilter

Constructors

WithinDaysFilter(String, Filter)

Declaration
protected WithinDaysFilter(string columnName, Filter value)
Parameters
Type | Name | Description
System.String | columnName |
Filter | value |

WithinDaysFilter(String, Decimal)

Declaration
protected WithinDaysFilter(string columnName, decimal value)
Parameters
Type | Name | Description
System.String | columnName |
System.Decimal | value |

WithinDaysFilter(String, Int32)

Declaration
protected WithinDaysFilter(string columnName, int value)
Parameters
Type | Name | Description
System.String | columnName |
System.Int32 | value |

Methods

GetValue1ForRender(FCSession, FCGeneric, SqlHelper)

Declaration
protected override object GetValue1ForRender(FCSession sess, FCGeneric gen, SqlHelper dbHelper)
Parameters
Type | Name | Description
FCSession | sess |
FCGeneric | gen |
SqlHelper | dbHelper |
Returns
Type | Description
System.Object |
Overrides
BetweenFilter.GetValue1ForRender(FCSession, FCGeneric, SqlHelper)

GetValue2ForRender(FCSession, FCGeneric, SqlHelper)

Declaration
protected override object GetValue2ForRender(FCSession sess, FCGeneric gen, SqlHelper dbHelper)
Parameters
Type | Name | Description
FCSession | sess |
FCGeneric | gen |
SqlHelper | dbHelper |
Returns
Type | Description
System.Object |
Overrides
BetweenFilter.GetValue2ForRender(FCSession, FCGeneric, SqlHelper)

PerformValidateFilter(FCSession, FCGeneric)

Declaration
protected override void PerformValidateFilter(FCSession session, FCGeneric gen)
Parameters
Type | Name | Description
FCSession | session |
FCGeneric | gen |
Overrides
BetweenFilter.PerformValidateFilter(FCSession, FCGeneric)


Class WithinHoursFilter | fcSDK Documentation

Class WithinHoursFilter

Inheritance
System.Object
Filter
ColumnBasedFilter
BetweenFilter
WithinHoursFilter
Inherited Members
BetweenFilter.FILTER_BETWEEN
BetweenFilter.FILTER_NOT_BETWEEN
BetweenFilter.ValidateOperand(FCGeneric, Object)
BetweenFilter.PerformRender(FCSession, FCGeneric, SqlHelper)
BetweenFilter.Value1Present
BetweenFilter.Value2Present
BetweenFilter.Value1
BetweenFilter.Value2
BetweenFilter.IsBetween
ColumnBasedFilter.GetColumnNameForRender(FCGeneric)
ColumnBasedFilter.ColumnName
Filter.ValidateFilter(FCSession, FCGeneric)
Filter.Render(FCSession, FCGeneric, SqlHelper)
Filter.GetActualDateValue(FCSession, Object)
Filter.ConvertDate(FCSession, DateTime, Boolean)
Filter.ValidateDate(DateTime)
Filter.ValidateValidField(FCGeneric, String)
Filter.ValidateValidField(FCGeneric, String, Boolean)
Filter.ValidateIsIntegerField(FCGeneric, String)
Filter.ValidateIsDecimalField(FCGeneric, String)
Filter.ValidateIsDateField(FCGeneric, String)
Filter.ValidateIsStringField(FCGeneric, String)
Filter.SetParameterValue(FCGeneric, SqlHelper, String, String, Object)
Filter.Session
Filter.Generic
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Filters
Assembly: fcSDK.dll
Syntax
public class WithinHoursFilter : BetweenFilter

Constructors

WithinHoursFilter(String, Decimal)

Declaration
protected WithinHoursFilter(string columnName, decimal value)
Parameters
Type | Name | Description
System.String | columnName |
System.Decimal | value |

WithinHoursFilter(String, Int32)

Declaration
protected WithinHoursFilter(string columnName, int value)
Parameters
Type | Name | Description
System.String | columnName |
System.Int32 | value |

Methods

GetValue1ForRender(FCSession, FCGeneric, SqlHelper)

Declaration
protected override object GetValue1ForRender(FCSession sess, FCGeneric gen, SqlHelper dbHelper)
Parameters
Type | Name | Description
FCSession | sess |
FCGeneric | gen |
SqlHelper | dbHelper |
Returns
Type | Description
System.Object |
Overrides
BetweenFilter.GetValue1ForRender(FCSession, FCGeneric, SqlHelper)

GetValue2ForRender(FCSession, FCGeneric, SqlHelper)

Declaration
protected override object GetValue2ForRender(FCSession sess, FCGeneric gen, SqlHelper dbHelper)
Parameters
Type | Name | Description
FCSession | sess |
FCGeneric | gen |
SqlHelper | dbHelper |
Returns
Type | Description
System.Object |
Overrides
BetweenFilter.GetValue2ForRender(FCSession, FCGeneric, SqlHelper)

PerformValidateFilter(FCSession, FCGeneric)

Declaration
protected override void PerformValidateFilter(FCSession session, FCGeneric gen)
Parameters
Type | Name | Description
FCSession | session |
FCGeneric | gen |
Overrides
BetweenFilter.PerformValidateFilter(FCSession, FCGeneric)


Class YesterdayFilter | fcSDK Documentation

Class YesterdayFilter

Inheritance
System.Object
Filter
ColumnBasedFilter
BetweenFilter
YesterdayFilter
Inherited Members
BetweenFilter.FILTER_BETWEEN
BetweenFilter.FILTER_NOT_BETWEEN
BetweenFilter.ValidateOperand(FCGeneric, Object)
BetweenFilter.PerformRender(FCSession, FCGeneric, SqlHelper)
BetweenFilter.Value1Present
BetweenFilter.Value2Present
BetweenFilter.Value1
BetweenFilter.Value2
BetweenFilter.IsBetween
ColumnBasedFilter.GetColumnNameForRender(FCGeneric)
ColumnBasedFilter.ColumnName
Filter.ValidateFilter(FCSession, FCGeneric)
Filter.Render(FCSession, FCGeneric, SqlHelper)
Filter.GetActualDateValue(FCSession, Object)
Filter.ConvertDate(FCSession, DateTime, Boolean)
Filter.ValidateDate(DateTime)
Filter.ValidateValidField(FCGeneric, String)
Filter.ValidateValidField(FCGeneric, String, Boolean)
Filter.ValidateIsIntegerField(FCGeneric, String)
Filter.ValidateIsDecimalField(FCGeneric, String)
Filter.ValidateIsDateField(FCGeneric, String)
Filter.ValidateIsStringField(FCGeneric, String)
Filter.SetParameterValue(FCGeneric, SqlHelper, String, String, Object)
Filter.Session
Filter.Generic
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation.Filters
Assembly: fcSDK.dll
Syntax
public class YesterdayFilter : BetweenFilter

Constructors

YesterdayFilter(String)

Declaration
protected YesterdayFilter(string columnName)
Parameters
Type | Name | Description
System.String | columnName |

Methods

GetValue1ForRender(FCSession, FCGeneric, SqlHelper)

Declaration
protected override object GetValue1ForRender(FCSession sess, FCGeneric gen, SqlHelper dbHelper)
Parameters
Type | Name | Description
FCSession | sess |
FCGeneric | gen |
SqlHelper | dbHelper |
Returns
Type | Description
System.Object |
Overrides
BetweenFilter.GetValue1ForRender(FCSession, FCGeneric, SqlHelper)

GetValue2ForRender(FCSession, FCGeneric, SqlHelper)

Declaration
protected override object GetValue2ForRender(FCSession sess, FCGeneric gen, SqlHelper dbHelper)
Parameters
Type | Name | Description
FCSession | sess |
FCGeneric | gen |
SqlHelper | dbHelper |
Returns
Type | Description
System.Object |
Overrides
BetweenFilter.GetValue2ForRender(FCSession, FCGeneric, SqlHelper)

PerformValidateFilter(FCSession, FCGeneric)

Declaration
protected override void PerformValidateFilter(FCSession session, FCGeneric gen)
Parameters
Type | Name | Description
FCSession | session |
FCGeneric | gen |
Overrides
BetweenFilter.PerformValidateFilter(FCSession, FCGeneric)


Class FoundationException | fcSDK Documentation

Class FoundationException

Inheritance
System.Object
System.Exception
System.ApplicationException
FCExceptionBase
FoundationException
FCInvalidLoginException
GenericException
Implements
System.Runtime.InteropServices._Exception
System.Runtime.Serialization.ISerializable
Inherited Members
FCExceptionBase.SetMessageProvider(IErrorMessageProvider)
FCExceptionBase.GetResourceData()
FCExceptionBase.GetErrorMessageFormat(Object, String)
FCExceptionBase.FormatMessage(String, String, Object[])
FCExceptionBase.LoadErrorResourceSet(String)
FCExceptionBase.GetObjectData(SerializationInfo, StreamingContext)
FCExceptionBase.MessageProvider
FCExceptionBase.ErrorCode
FCExceptionBase.ErrorMessageID
FCExceptionBase.Message
System.Exception.GetBaseException()
System.Exception.ToString()
System.Exception.GetType()
System.Exception.Data
System.Exception.InnerException
System.Exception.TargetSite
System.Exception.StackTrace
System.Exception.HelpLink
System.Exception.Source
System.Exception.HResult
System.Exception.SerializeObjectState
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation
Assembly: fcSDK.dll
Syntax
public class FoundationException : FCExceptionBase, _Exception, ISerializable

Constructors

FoundationException(SerializationInfo, StreamingContext)

Declaration
protected FoundationException(SerializationInfo info, StreamingContext context)
Parameters
Type | Name | Description
System.Runtime.Serialization.SerializationInfo | info |
System.Runtime.Serialization.StreamingContext | context |

Implements

System.Runtime.InteropServices._Exception
System.Runtime.Serialization.ISerializable


Class GenericDataRow | fcSDK Documentation

Class GenericDataRow

Inheritance
System.Object
GenericDataRow
ClarifyDataRow
Namespace: FChoice.Foundation
Assembly: fcSDK.dll
Syntax
public abstract class GenericDataRow : DataRow

Constructors

GenericDataRow(DataRowBuilder)

Declaration
protected GenericDataRow(DataRowBuilder rb)
Parameters
Type | Name | Description
System.Data.DataRowBuilder | rb |

Fields

forcedUpdateCols

Declaration
protected Dictionary<DataColumn, string> forcedUpdateCols
Field Value
Type | Description
System.Collections.Generic.Dictionary<System.Data.DataColumn, System.String> |

isAddForUpdate

Declaration
protected bool isAddForUpdate
Field Value
Type | Description
System.Boolean |

parentGeneric

Declaration
protected FCGeneric parentGeneric
Field Value
Type | Description
FCGeneric |

parentTable

Declaration
protected GenericDataTable parentTable
Field Value
Type | Description
GenericDataTable |

Properties

BaseParentGeneric

Declaration
protected FCGeneric BaseParentGeneric { get; }
Property Value
Type | Description
FCGeneric |

ForcedUpdateColumns

Declaration
public DataColumn[] ForcedUpdateColumns { get; }
Property Value
Type | Description
System.Data.DataColumn[] |

IsAddForUpdate

Declaration
public bool IsAddForUpdate { get; }
Property Value
Type | Description
System.Boolean |

IsNew

Declaration
public bool IsNew { get; }
Property Value
Type | Description
System.Boolean |

Item[DataColumn]

Declaration
public object this[DataColumn column] { get; set; }
Parameters
Type | Name | Description
System.Data.DataColumn | column |
Property Value
Type | Description
System.Object |

Item[DataColumn, DataRowVersion]

Declaration
public object this[DataColumn column, DataRowVersion version] { get; set; }
Parameters
Type | Name | Description
System.Data.DataColumn | column |
System.Data.DataRowVersion | version |
Property Value
Type | Description
System.Object |

Item[Int32]

Declaration
public object this[int index] { get; set; }
Parameters
Type | Name | Description
System.Int32 | index |
Property Value
Type | Description
System.Object |

Item[Int32, DataRowVersion]

Declaration
public object this[int index, DataRowVersion version] { get; }
Parameters
Type | Name | Description
System.Int32 | index |
System.Data.DataRowVersion | version |
Property Value
Type | Description
System.Object |

Item[String]

Declaration
public object this[string columnName] { get; set; }
Parameters
Type | Name | Description
System.String | columnName |
Property Value
Type | Description
System.Object |

Item[String, DataRowVersion]

Declaration
public object this[string columnName, DataRowVersion version] { get; }
Parameters
Type | Name | Description
System.String | columnName |
System.Data.DataRowVersion | version |
Property Value
Type | Description
System.Object |

RowGuid

Declaration
public Guid RowGuid { get; }
Property Value
Type | Description
System.Guid |

UniqueID

Declaration
public object UniqueID { get; }
Property Value
Type | Description
System.Object |

Methods

AreIDsEqual(Object, Object)

Declaration
public static bool AreIDsEqual(object id1, object id2)
Parameters
Type | Name | Description
System.Object | id1 |
System.Object | id2 |
Returns
Type | Description
System.Boolean |

IsForcedUpdateColumn(DataColumn)

Declaration
public bool IsForcedUpdateColumn(DataColumn col)
Parameters
Type | Name | Description
System.Data.DataColumn | col |
Returns
Type | Description
System.Boolean |

ProcessGetColumn(Object, DataColumn)

Declaration
protected abstract object ProcessGetColumn(object obj, DataColumn column)
Parameters
Type | Name | Description
System.Object | obj |
System.Data.DataColumn | column |
Returns
Type | Description
System.Object |

ProcessSetColumn(Object, DataColumn)

Declaration
protected abstract void ProcessSetColumn(object obj, DataColumn column)
Parameters
Type | Name | Description
System.Object | obj |
System.Data.DataColumn | column |

RelateByID(Object, String)

Declaration
public void RelateByID(object uniqueId, string relationName)
Parameters
Type | Name | Description
System.Object | uniqueId |
System.String | relationName |

RelateRecord(GenericDataRow, String)

Declaration
public void RelateRecord(GenericDataRow otherRow, string relationName)
Parameters
Type | Name | Description
GenericDataRow | otherRow |
System.String | relationName |

RelateToIntField(GenericDataRow, String)

Declaration
public void RelateToIntField(GenericDataRow otherRow, string intFieldName)
Parameters
Type | Name | Description
GenericDataRow | otherRow |
System.String | intFieldName |

SetBaseColumn(DataColumn, Object)

Declaration
protected void SetBaseColumn(DataColumn column, object fieldValue)
Parameters
Type | Name | Description
System.Data.DataColumn | column |
System.Object | fieldValue |

Unrelate(GenericDataRow, String)

Declaration
public void Unrelate(GenericDataRow otherRow, string relationName)
Parameters
Type | Name | Description
GenericDataRow | otherRow |
System.String | relationName |

UnrelateFromAll(String)

Declaration
public void UnrelateFromAll(string relationName)
Parameters
Type | Name | Description
System.String | relationName |

Update()

Declaration
public void Update()

Update(UpdateQueryBatch)

Declaration
public void Update(UpdateQueryBatch batch)
Parameters
Type | Name | Description
UpdateQueryBatch | batch |

Update(IDbTransaction)

Declaration
public void Update(IDbTransaction trans)
Parameters
Type | Name | Description
System.Data.IDbTransaction | trans |


Class GenericDataRowCollection | fcSDK Documentation

Class GenericDataRowCollection

Inheritance
System.Object
GenericDataRowCollection
ClarifyRowCollection
Implements
System.Collections.ICollection
System.Collections.IEnumerable
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation
Assembly: fcSDK.dll
Syntax
public abstract class GenericDataRowCollection : ICollection, IEnumerable

Constructors

GenericDataRowCollection(GenericDataTable, DataRowCollection)

Declaration
protected GenericDataRowCollection(GenericDataTable parentTable, DataRowCollection tableBaseRows)
Parameters
Type | Name | Description
GenericDataTable | parentTable |
System.Data.DataRowCollection | tableBaseRows |

Properties

BaseRows

Declaration
protected DataRowCollection BaseRows { get; }
Property Value
Type | Description
System.Data.DataRowCollection |

Count

Declaration
public int Count { get; }
Property Value
Type | Description
System.Int32 |

IsSynchronized

Declaration
public bool IsSynchronized { get; }
Property Value
Type | Description
System.Boolean |

Item[Int32]

Declaration
public GenericDataRow this[int index] { get; }
Parameters
Type | Name | Description
System.Int32 | index |
Property Value
Type | Description
GenericDataRow |

SyncRoot

Declaration
public object SyncRoot { get; }
Property Value
Type | Description
System.Object |

Table

Declaration
public GenericDataTable Table { get; }
Property Value
Type | Description
GenericDataTable |

Methods

Add(GenericDataRow)

Declaration
public void Add(GenericDataRow row)
Parameters
Type | Name | Description
GenericDataRow | row |

Contains(Object)

Declaration
public bool Contains(object key)
Parameters
Type | Name | Description
System.Object | key |
Returns
Type | Description
System.Boolean |

Contains(Object[])

Declaration
public bool Contains(object[] keys)
Parameters
Type | Name | Description
System.Object[] | keys |
Returns
Type | Description
System.Boolean |

CopyTo(Array, Int32)

Declaration
public void CopyTo(Array array, int index)
Parameters
Type | Name | Description
System.Array | array |
System.Int32 | index |

Find(Object)

Declaration
public GenericDataRow Find(object key)
Parameters
Type | Name | Description
System.Object | key |
Returns
Type | Description
GenericDataRow |

Find(Object[])

Declaration
public GenericDataRow Find(object[] keys)
Parameters
Type | Name | Description
System.Object[] | keys |
Returns
Type | Description
GenericDataRow |

GetEnumerator()

Declaration
public IEnumerator GetEnumerator()
Returns
Type | Description
System.Collections.IEnumerator |

Implements

System.Collections.ICollection
System.Collections.IEnumerable


Class GenericDataSet | fcSDK Documentation

Class GenericDataSet

Inheritance
System.Object
GenericDataSet
ClarifyDataSet
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation
Assembly: fcSDK.dll
Syntax
public abstract class GenericDataSet

Constructors

GenericDataSet(FCSession, IComparer)

Declaration
protected GenericDataSet(FCSession sourceSession, IComparer listComparer)
Parameters
Type | Name | Description
FCSession | sourceSession |
System.Collections.IComparer | listComparer |

Properties

DataSet

Declaration
public DataSet DataSet { get; }
Property Value
Type | Description
System.Data.DataSet |

FCSession

Declaration
protected FCSession FCSession { get; }
Property Value
Type | Description
FCSession |

ListComparer

Declaration
protected IComparer ListComparer { get; set; }
Property Value
Type | Description
System.Collections.IComparer |

RestrictionGroup

Declaration
public RestrictionGroup RestrictionGroup { get; set; }
Property Value
Type | Description
RestrictionGroup |

SortGenerics

Declaration
public bool SortGenerics { get; set; }
Property Value
Type | Description
System.Boolean |

UniqueID

Declaration
public Guid UniqueID { get; }
Property Value
Type | Description
System.Guid |

Methods

Query(FCGeneric[])

Declaration
public void Query(params FCGeneric[] generics)
Parameters
Type | Name | Description
FCGeneric[] | generics |

Query(IDbTransaction, FCGeneric[])

Declaration
public void Query(IDbTransaction trans, params FCGeneric[] generics)
Parameters
Type | Name | Description
System.Data.IDbTransaction | trans |
FCGeneric[] | generics |

Update(FCGeneric[])

Declaration
public void Update(params FCGeneric[] generics)
Parameters
Type | Name | Description
FCGeneric[] | generics |

Update(IDbTransaction, FCGeneric[])

Declaration
public void Update(IDbTransaction transaction, params FCGeneric[] generics)
Parameters
Type | Name | Description
System.Data.IDbTransaction | transaction |
FCGeneric[] | generics |


Class GenericDataTable | fcSDK Documentation

Class GenericDataTable

Inheritance
System.Object
GenericDataTable
ClarifyDataTable
Implements
System.Collections.IEnumerable
Namespace: FChoice.Foundation
Assembly: fcSDK.dll
Syntax
public abstract class GenericDataTable : DataTable, IEnumerable

Constructors

GenericDataTable(String)

Declaration
protected GenericDataTable(string tableName)
Parameters
Type | Name | Description
System.String | tableName |

GenericDataTable(String, FCGeneric)

Declaration
protected GenericDataTable(string tableName, FCGeneric generic)
Parameters
Type | Name | Description
System.String | tableName |
FCGeneric | generic |

Properties

BaseRows

Declaration
protected DataRowCollection BaseRows { get; }
Property Value
Type | Description
System.Data.DataRowCollection |

Count

Declaration
public int Count { get; }
Property Value
Type | Description
System.Int32 |

FCGeneric

Declaration
public FCGeneric FCGeneric { get; }
Property Value
Type | Description
FCGeneric |

InnerRows

Declaration
protected virtual GenericDataRowCollection InnerRows { get; set; }
Property Value
Type | Description
GenericDataRowCollection |

IsMtmTable

Declaration
public bool IsMtmTable { get; }
Property Value
Type | Description
System.Boolean |

Item[Int32]

Declaration
public GenericDataRow this[int index] { get; }
Parameters
Type | Name | Description
System.Int32 | index |
Property Value
Type | Description
GenericDataRow |

Rows

Declaration
public GenericDataRowCollection Rows { get; }
Property Value
Type | Description
GenericDataRowCollection |

Methods

CreateRowCollection()

Declaration
protected abstract GenericDataRowCollection CreateRowCollection()
Returns
Type | Description
GenericDataRowCollection |

GetEnumerator()

Declaration
public IEnumerator GetEnumerator()
Returns
Type | Description
System.Collections.IEnumerator |

Implements

System.Collections.IEnumerable


Class GenericException | fcSDK Documentation

Class GenericException

Inheritance
System.Object
System.Exception
System.ApplicationException
FCExceptionBase
FoundationException
GenericException
ClarifyGenericException
Implements
System.Runtime.InteropServices._Exception
System.Runtime.Serialization.ISerializable
Inherited Members
FCExceptionBase.SetMessageProvider(IErrorMessageProvider)
FCExceptionBase.GetResourceData()
FCExceptionBase.GetErrorMessageFormat(Object, String)
FCExceptionBase.FormatMessage(String, String, Object[])
FCExceptionBase.LoadErrorResourceSet(String)
FCExceptionBase.GetObjectData(SerializationInfo, StreamingContext)
FCExceptionBase.MessageProvider
FCExceptionBase.ErrorCode
FCExceptionBase.ErrorMessageID
FCExceptionBase.Message
System.Exception.GetBaseException()
System.Exception.ToString()
System.Exception.GetType()
System.Exception.Data
System.Exception.InnerException
System.Exception.TargetSite
System.Exception.StackTrace
System.Exception.HelpLink
System.Exception.Source
System.Exception.HResult
System.Exception.SerializeObjectState
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation
Assembly: fcSDK.dll
Syntax
public class GenericException : FoundationException, _Exception, ISerializable

Constructors

GenericException(Exception, Int32, String, Object[])

Declaration
protected GenericException(Exception innerEx, int errorId, string messageId, params object[] args)
Parameters
Type | Name | Description
System.Exception | innerEx |
System.Int32 | errorId |
System.String | messageId |
System.Object[] | args |

GenericException(Int32, String, Object[])

Declaration
protected GenericException(int errorId, string messageId, params object[] args)
Parameters
Type | Name | Description
System.Int32 | errorId |
System.String | messageId |
System.Object[] | args |

GenericException(SerializationInfo, StreamingContext)

Declaration
protected GenericException(SerializationInfo info, StreamingContext context)
Parameters
Type | Name | Description
System.Runtime.Serialization.SerializationInfo | info |
System.Runtime.Serialization.StreamingContext | context |

Implements

System.Runtime.InteropServices._Exception
System.Runtime.Serialization.ISerializable


Class MaximumRowsExceededEventArgs | fcSDK Documentation

Class MaximumRowsExceededEventArgs

Inheritance
System.Object
MaximumRowsExceededEventArgs
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation
Assembly: fcSDK.dll
Syntax
public class MaximumRowsExceededEventArgs

Constructors

MaximumRowsExceededEventArgs(Int32, Int32)

Declaration
public MaximumRowsExceededEventArgs(int totalPossibleRows, int maxRowsToReturn)
Parameters
Type | Name | Description
System.Int32 | totalPossibleRows |
System.Int32 | maxRowsToReturn |

Properties

CancelQuery

Declaration
public bool CancelQuery { get; set; }
Property Value
Type | Description
System.Boolean |

RowsToReturn

Declaration
public int RowsToReturn { get; set; }
Property Value
Type | Description
System.Int32 |

TotalPossibleRows

Declaration
public int TotalPossibleRows { get; }
Property Value
Type | Description
System.Int32 |


Delegate MaximumRowsExceededEventHandler | fcSDK Documentation

Delegate MaximumRowsExceededEventHandler

Namespace: FChoice.Foundation
Assembly: fcSDK.dll
Syntax
public delegate void MaximumRowsExceededEventHandler(FCGeneric sender, MaximumRowsExceededEventArgs args);
Parameters
Type | Name | Description
FCGeneric | sender |
MaximumRowsExceededEventArgs | args |

Constructors

MaximumRowsExceededEventHandler(Object, IntPtr)

Declaration
public MaximumRowsExceededEventHandler(object object, IntPtr method)
Parameters
Type | Name | Description
System.Object | object |
System.IntPtr | method |

Methods

BeginInvoke(FCGeneric, MaximumRowsExceededEventArgs, AsyncCallback, Object)

Declaration
public virtual IAsyncResult BeginInvoke(FCGeneric sender, MaximumRowsExceededEventArgs args, AsyncCallback callback, object object)
Parameters
Type | Name | Description
FCGeneric | sender |
MaximumRowsExceededEventArgs | args |
System.AsyncCallback | callback |
System.Object | object |
Returns
Type | Description
System.IAsyncResult |

EndInvoke(IAsyncResult)

Declaration
public virtual void EndInvoke(IAsyncResult result)
Parameters
Type | Name | Description
System.IAsyncResult | result |

Invoke(FCGeneric, MaximumRowsExceededEventArgs)

Declaration
public virtual void Invoke(FCGeneric sender, MaximumRowsExceededEventArgs args)
Parameters
Type | Name | Description
FCGeneric | sender |
MaximumRowsExceededEventArgs | args |


Enum NumberOps | fcSDK Documentation

Enum NumberOps

Namespace: FChoice.Foundation
Assembly: fcSDK.dll
Syntax
public enum NumberOps

Fields

Name | Description
Equals |
LessThan |
LessThanOrEqual |
MoreThan |
MoreThanOrEqual |
NotEquals |
OlderThanDays |
OlderThanHours |
WithinDays |
WithinHours |


Class RelationNameCollection | fcSDK Documentation

Class RelationNameCollection

Inheritance
System.Object
ValidatedNameCollection
RelationNameCollection
Implements
System.Collections.IList
System.Collections.ICollection
System.Collections.IEnumerable
Inherited Members
ValidatedNameCollection.SetList(String)
ValidatedNameCollection.Insert(Int32, String)
ValidatedNameCollection.Remove(String)
ValidatedNameCollection.RemoveAt(Int32)
ValidatedNameCollection.Contains(String)
ValidatedNameCollection.Clear()
ValidatedNameCollection.IndexOf(String)
ValidatedNameCollection.Add(String)
ValidatedNameCollection.AddRange(String[])
ValidatedNameCollection.CopyTo(String[], Int32)
ValidatedNameCollection.ToString()
ValidatedNameCollection.IList.get_Item(Int32)
ValidatedNameCollection.IList.set_Item(Int32, Object)
ValidatedNameCollection.IList.Insert(Int32, Object)
ValidatedNameCollection.IList.Remove(Object)
ValidatedNameCollection.IList.Contains(Object)
ValidatedNameCollection.IList.IndexOf(Object)
ValidatedNameCollection.IList.Add(Object)
ValidatedNameCollection.ICollection.CopyTo(Array, Int32)
ValidatedNameCollection.GetEnumerator()
ValidatedNameCollection.Item[Int32]
ValidatedNameCollection.InnerNames
ValidatedNameCollection.IsReadOnly
ValidatedNameCollection.IsFixedSize
ValidatedNameCollection.IList.Item[Int32]
ValidatedNameCollection.IsSynchronized
ValidatedNameCollection.Count
ValidatedNameCollection.SyncRoot
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation
Assembly: fcSDK.dll
Syntax
public class RelationNameCollection : ValidatedNameCollection, IList, ICollection, IEnumerable

Methods

ValidateName(String)

Declaration
protected override bool ValidateName(string value)
Parameters
Type | Name | Description
System.String | value |
Returns
Type | Description
System.Boolean |
Overrides
ValidatedNameCollection.ValidateName(String)

Implements

System.Collections.IList
System.Collections.ICollection
System.Collections.IEnumerable


Namespace FChoice.Foundation.Schema | fcSDK Documentation

Namespace FChoice.Foundation.Schema

Interfaces

ISchemaCache

ISchemaField

ISchemaFieldCollection

ISchemaRelation

ISchemaRelationCollection

ISchemaTable

ISchemaTableBase

ISchemaTableCollection

ISchemaView

ISchemaViewCollection

ISchemaViewJoin

ISchemaViewJoinCollection

Enums

SchemaRelationCardinality

Back to top © 2022 Dovetail Software, Inc. - All rights reserved.
Clarify, Amdocs, and related products and names are copyright and trademark of Amdocs, Inc.
.NET, Visual Studio.NET, C#, Visual Basic and related products are trademark of Microsoft corporation.


Interface ISchemaCache | fcSDK Documentation

Interface ISchemaCache

Namespace: FChoice.Foundation.Schema
Assembly: fcSDK.dll
Syntax
public interface ISchemaCache

Properties

IsDatabaseUnicode

Declaration
bool IsDatabaseUnicode { get; }
Property Value
Type | Description
System.Boolean |

RestrictionGroups

Declaration
RestrictionGroupCollection RestrictionGroups { get; }
Property Value
Type | Description
RestrictionGroupCollection |

Tables

Declaration
ISchemaTableCollection Tables { get; }
Property Value
Type | Description
ISchemaTableCollection |

Views

Declaration
ISchemaViewCollection Views { get; }
Property Value
Type | Description
ISchemaViewCollection |

Methods

GetChangeDateField(String)

Declaration
ISchemaField GetChangeDateField(string tableName)
Parameters
Type | Name | Description
System.String | tableName |
Returns
Type | Description
ISchemaField |

GetDateFields(String)

Declaration
IEnumerable GetDateFields(string tableName)
Parameters
Type | Name | Description
System.String | tableName |
Returns
Type | Description
System.Collections.IEnumerable |

GetField(String, String)

Declaration
ISchemaField GetField(string objetName, string fieldName)
Parameters
Type | Name | Description
System.String | objetName |
System.String | fieldName |
Returns
Type | Description
ISchemaField |

GetRelation(String, String)

Declaration
ISchemaRelation GetRelation(string tableName, string relationName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | relationName |
Returns
Type | Description
ISchemaRelation |

GetTableName(Int32)

Declaration
string GetTableName(int tableNum)
Parameters
Type | Name | Description
System.Int32 | tableNum |
Returns
Type | Description
System.String |

GetTableNumber(String)

Declaration
int GetTableNumber(string tableName)
Parameters
Type | Name | Description
System.String | tableName |
Returns
Type | Description
System.Int32 |

IsChangeField(String, String)

Declaration
bool IsChangeField(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

IsDateField(String, String)

Declaration
bool IsDateField(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

IsFieldSearchable(String, String)

Declaration
bool IsFieldSearchable(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

IsFieldUnicode(String, String)

Declaration
bool IsFieldUnicode(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

IsIntegerField(String, String)

Declaration
bool IsIntegerField(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

IsNumericField(String, String)

Declaration
bool IsNumericField(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

IsRelationExclusive(String, String)

Declaration
bool IsRelationExclusive(string tableName, string relationName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | relationName |
Returns
Type | Description
System.Boolean |

IsStringField(String, String)

Declaration
bool IsStringField(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

IsStringOrDateField(String, String)

Declaration
bool IsStringOrDateField(string tableName, string fieldName)
Parameters
Type | Name | Description
System.String | tableName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

IsValidField(String, String)

Declaration
bool IsValidField(string objectName, string fieldName)
Parameters
Type | Name | Description
System.String | objectName |
System.String | fieldName |
Returns
Type | Description
System.Boolean |

IsValidRelation(String, String)

Declaration
bool IsValidRelation(string objectName, string relationName)
Parameters
Type | Name | Description
System.String | objectName |
System.String | relationName |
Returns
Type | Description
System.Boolean |

IsValidTable(String)

Declaration
bool IsValidTable(string tableName)
Parameters
Type | Name | Description
System.String | tableName |
Returns
Type | Description
System.Boolean |

IsValidTableOrView(String)

Declaration
bool IsValidTableOrView(string objectName)
Parameters
Type | Name | Description
System.String | objectName |
Returns
Type | Description
System.Boolean |

IsValidView(String)

Declaration
bool IsValidView(string viewName)
Parameters
Type | Name | Description
System.String | viewName |
Returns
Type | Description
System.Boolean |


Interface ISchemaField | fcSDK Documentation

Interface ISchemaField

Namespace: FChoice.Foundation.Schema
Assembly: fcSDK.dll
Syntax
public interface ISchemaField

Properties

CommonType

Declaration
int CommonType { get; }
Property Value
Type | Description
System.Int32 |

DatabaseType

Declaration
int DatabaseType { get; }
Property Value
Type | Description
System.Int32 |

DataType

Declaration
int DataType { get; }
Property Value
Type | Description
System.Int32 |

Default

Declaration
object Default { get; }
Property Value
Type | Description
System.Object |

DefaultString

Declaration
string DefaultString { get; }
Property Value
Type | Description
System.String |

Description

Declaration
string Description { get; }
Property Value
Type | Description
System.String |

Flags

Declaration
object Flags { get; }
Property Value
Type | Description
System.Object |

IsSearchable

Declaration
bool IsSearchable { get; }
Property Value
Type | Description
System.Boolean |

IsUnicode

Declaration
bool IsUnicode { get; }
Property Value
Type | Description
System.Boolean |

Length

Declaration
int Length { get; }
Property Value
Type | Description
System.Int32 |

Name

Declaration
string Name { get; }
Property Value
Type | Description
System.String |

Rank

Declaration
int Rank { get; }
Property Value
Type | Description
System.Int32 |

Methods

IsDate()

Declaration
bool IsDate()
Returns
Type | Description
System.Boolean |

IsInteger()

Declaration
bool IsInteger()
Returns
Type | Description
System.Boolean |

IsNumeric()

Declaration
bool IsNumeric()
Returns
Type | Description
System.Boolean |

IsString()

Declaration
bool IsString()
Returns
Type | Description
System.Boolean |


Interface ISchemaFieldCollection | fcSDK Documentation

Interface ISchemaFieldCollection

Inherited Members
System.Collections.ICollection.CopyTo(System.Array, System.Int32)
System.Collections.ICollection.Count
System.Collections.ICollection.SyncRoot
System.Collections.ICollection.IsSynchronized
System.Collections.IEnumerable.GetEnumerator()
Namespace: FChoice.Foundation.Schema
Assembly: fcSDK.dll
Syntax
public interface ISchemaFieldCollection : ICollection, IEnumerable

Properties

Item[Int32]

Declaration
ISchemaField this[int rank] { get; }
Parameters
Type | Name | Description
System.Int32 | rank |
Property Value
Type | Description
ISchemaField |

Item[String]

Declaration
ISchemaField this[string name] { get; }
Parameters
Type | Name | Description
System.String | name |
Property Value
Type | Description
ISchemaField |


Interface ISchemaRelation | fcSDK Documentation

Interface ISchemaRelation

Namespace: FChoice.Foundation.Schema
Assembly: fcSDK.dll
Syntax
public interface ISchemaRelation

Properties

Cardinality

Declaration
SchemaRelationCardinality Cardinality { get; }
Property Value
Type | Description
SchemaRelationCardinality |

ChildTable

Declaration
ISchemaTable ChildTable { get; }
Property Value
Type | Description
ISchemaTable |

Description

Declaration
string Description { get; }
Property Value
Type | Description
System.String |

ExclusiveObjectIDField

Declaration
ISchemaField ExclusiveObjectIDField { get; }
Property Value
Type | Description
ISchemaField |

ExclusiveTableField

Declaration
ISchemaField ExclusiveTableField { get; }
Property Value
Type | Description
ISchemaField |

Flags

Declaration
object Flags { get; }
Property Value
Type | Description
System.Object |

InverseRelation

Declaration
ISchemaRelation InverseRelation { get; }
Property Value
Type | Description
ISchemaRelation |

IsExclusive

Declaration
bool IsExclusive { get; }
Property Value
Type | Description
System.Boolean |

IsMandatory

Declaration
bool IsMandatory { get; }
Property Value
Type | Description
System.Boolean |

IsMtm

Declaration
bool IsMtm { get; }
Property Value
Type | Description
System.Boolean |

MandatoryObjectID

Declaration
object MandatoryObjectID { get; }
Property Value
Type | Description
System.Object |

MtmTableName

Declaration
string MtmTableName { get; }
Property Value
Type | Description
System.String |

Name

Declaration
string Name { get; }
Property Value
Type | Description
System.String |

ObjectID

Declaration
object ObjectID { get; }
Property Value
Type | Description
System.Object |

ParentTable

Declaration
ISchemaTable ParentTable { get; }
Property Value
Type | Description
ISchemaTable |

Rank

Declaration
int Rank { get; }
Property Value
Type | Description
System.Int32 |

SourceTable

Declaration
ISchemaTable SourceTable { get; }
Property Value
Type | Description
ISchemaTable |

TargetTable

Declaration
ISchemaTable TargetTable { get; }
Property Value
Type | Description
ISchemaTable |


Interface ISchemaRelationCollection | fcSDK Documentation

Interface ISchemaRelationCollection

Inherited Members
System.Collections.ICollection.CopyTo(System.Array, System.Int32)
System.Collections.ICollection.Count
System.Collections.ICollection.SyncRoot
System.Collections.ICollection.IsSynchronized
System.Collections.IEnumerable.GetEnumerator()
Namespace: FChoice.Foundation.Schema
Assembly: fcSDK.dll
Syntax
public interface ISchemaRelationCollection : ICollection, IEnumerable

Properties

Item[String]

Declaration
ISchemaRelation this[string name] { get; }
Parameters
Type | Name | Description
System.String | name |
Property Value
Type | Description
ISchemaRelation |


Interface ISchemaTable | fcSDK Documentation

Interface ISchemaTable

Inherited Members
ISchemaTableBase.ObjectID
ISchemaTableBase.Name
ISchemaTableBase.Number
ISchemaTableBase.Description
ISchemaTableBase.Flags
ISchemaTableBase.Subsystem
ISchemaTableBase.Fields
ISchemaTableBase.IsDataRestricted
Namespace: FChoice.Foundation.Schema
Assembly: fcSDK.dll
Syntax
public interface ISchemaTable : ISchemaTableBase

Properties

Relationships

Declaration
ISchemaRelationCollection Relationships { get; }
Property Value
Type | Description
ISchemaRelationCollection |

Views

Declaration
ISchemaViewCollection Views { get; }
Property Value
Type | Description
ISchemaViewCollection |


Interface ISchemaTableBase | fcSDK Documentation

Interface ISchemaTableBase

Namespace: FChoice.Foundation.Schema
Assembly: fcSDK.dll
Syntax
public interface ISchemaTableBase

Properties

Description

Declaration
string Description { get; }
Property Value
Type | Description
System.String |

Fields

Declaration
ISchemaFieldCollection Fields { get; }
Property Value
Type | Description
ISchemaFieldCollection |

Flags

Declaration
object Flags { get; }
Property Value
Type | Description
System.Object |

IsDataRestricted

Declaration
bool IsDataRestricted { get; }
Property Value
Type | Description
System.Boolean |

Name

Declaration
string Name { get; }
Property Value
Type | Description
System.String |

Number

Declaration
object Number { get; }
Property Value
Type | Description
System.Object |

ObjectID

Declaration
object ObjectID { get; }
Property Value
Type | Description
System.Object |

Subsystem

Declaration
string Subsystem { get; }
Property Value
Type | Description
System.String |


Interface ISchemaTableCollection | fcSDK Documentation

Interface ISchemaTableCollection

Inherited Members
System.Collections.ICollection.CopyTo(System.Array, System.Int32)
System.Collections.ICollection.Count
System.Collections.ICollection.SyncRoot
System.Collections.ICollection.IsSynchronized
System.Collections.IEnumerable.GetEnumerator()
Namespace: FChoice.Foundation.Schema
Assembly: fcSDK.dll
Syntax
public interface ISchemaTableCollection : ICollection, IEnumerable

Properties

Item[Int32]

Declaration
ISchemaTable this[int index] { get; }
Parameters
Type | Name | Description
System.Int32 | index |
Property Value
Type | Description
ISchemaTable |

Item[String]

Declaration
ISchemaTable this[string name] { get; }
Parameters
Type | Name | Description
System.String | name |
Property Value
Type | Description
ISchemaTable |

Methods

GetByNumber(Object)

Declaration
ISchemaTable GetByNumber(object num)
Parameters
Type | Name | Description
System.Object | num |
Returns
Type | Description
ISchemaTable |


Interface ISchemaView | fcSDK Documentation

Interface ISchemaView

Inherited Members
ISchemaTableBase.ObjectID
ISchemaTableBase.Name
ISchemaTableBase.Number
ISchemaTableBase.Description
ISchemaTableBase.Flags
ISchemaTableBase.Subsystem
ISchemaTableBase.Fields
ISchemaTableBase.IsDataRestricted
Namespace: FChoice.Foundation.Schema
Assembly: fcSDK.dll
Syntax
public interface ISchemaView : ISchemaTableBase

Properties

Joins

Declaration
ISchemaViewJoinCollection Joins { get; }
Property Value
Type | Description
ISchemaViewJoinCollection |


Interface ISchemaViewCollection | fcSDK Documentation

Interface ISchemaViewCollection

Inherited Members
System.Collections.ICollection.CopyTo(System.Array, System.Int32)
System.Collections.ICollection.Count
System.Collections.ICollection.SyncRoot
System.Collections.ICollection.IsSynchronized
System.Collections.IEnumerable.GetEnumerator()
Namespace: FChoice.Foundation.Schema
Assembly: fcSDK.dll
Syntax
public interface ISchemaViewCollection : ICollection, IEnumerable

Properties

Item[Int32]

Declaration
ISchemaView this[int number] { get; }
Parameters
Type | Name | Description
System.Int32 | number |
Property Value
Type | Description
ISchemaView |

Item[String]

Declaration
ISchemaView this[string name] { get; }
Parameters
Type | Name | Description
System.String | name |
Property Value
Type | Description
ISchemaView |

Methods

GetByNumber(Object)

Declaration
ISchemaView GetByNumber(object number)
Parameters
Type | Name | Description
System.Object | number |
Returns
Type | Description
ISchemaView |


Interface ISchemaViewJoin | fcSDK Documentation

Interface ISchemaViewJoin

Namespace: FChoice.Foundation.Schema
Assembly: fcSDK.dll
Syntax
public interface ISchemaViewJoin

Properties

Description

Declaration
string Description { get; }
Property Value
Type | Description
System.String |

Flags

Declaration
object Flags { get; }
Property Value
Type | Description
System.Object |

IsPrimaryOuter

Declaration
bool IsPrimaryOuter { get; }
Property Value
Type | Description
System.Boolean |

IsSecondaryOuter

Declaration
bool IsSecondaryOuter { get; }
Property Value
Type | Description
System.Boolean |

PrimaryAlias

Declaration
string PrimaryAlias { get; }
Property Value
Type | Description
System.String |

PrimaryTable

Declaration
ISchemaTable PrimaryTable { get; }
Property Value
Type | Description
ISchemaTable |

SecondaryAlias

Declaration
string SecondaryAlias { get; }
Property Value
Type | Description
System.String |

SecondaryTable

Declaration
ISchemaTable SecondaryTable { get; }
Property Value
Type | Description
ISchemaTable |


Interface ISchemaViewJoinCollection | fcSDK Documentation

Interface ISchemaViewJoinCollection

Inherited Members
System.Collections.ICollection.CopyTo(System.Array, System.Int32)
System.Collections.ICollection.Count
System.Collections.ICollection.SyncRoot
System.Collections.ICollection.IsSynchronized
System.Collections.IEnumerable.GetEnumerator()
Namespace: FChoice.Foundation.Schema
Assembly: fcSDK.dll
Syntax
public interface ISchemaViewJoinCollection : ICollection, IEnumerable


Enum SchemaRelationCardinality | fcSDK Documentation

Enum SchemaRelationCardinality

Namespace: FChoice.Foundation.Schema
Assembly: fcSDK.dll
Syntax
public enum SchemaRelationCardinality

Fields

Name | Description
ManyToMany |
ManyToOne |
OneToMany |
OneToOneForeign |
OneToOnePrimary |


Enum StringOps | fcSDK Documentation

Enum StringOps

Namespace: FChoice.Foundation
Assembly: fcSDK.dll
Syntax
public enum StringOps

Fields

Name | Description
Contains |
EndsWith |
Equals |
LessThan |
LessThanOrEqual |
Like |
MoreThan |
MoreThanOrEqual |
NotContains |
NotEndsWith |
NotEquals |
NotLike |
NotStartsWith |
SoundsLike |
StartsWith |


Class ValidatedNameCollection | fcSDK Documentation

Class ValidatedNameCollection

Inheritance
System.Object
ValidatedNameCollection
DataFieldNameCollection
RelationNameCollection
Implements
System.Collections.IList
System.Collections.ICollection
System.Collections.IEnumerable
Inherited Members
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Foundation
Assembly: fcSDK.dll
Syntax
public abstract class ValidatedNameCollection : IList, ICollection, IEnumerable

Constructors

ValidatedNameCollection()

Declaration
protected ValidatedNameCollection()

Properties

Count

Declaration
public int Count { get; }
Property Value
Type | Description
System.Int32 |

InnerNames

Declaration
protected StringCollection InnerNames { get; }
Property Value
Type | Description
System.Collections.Specialized.StringCollection |

IsFixedSize

Declaration
public bool IsFixedSize { get; }
Property Value
Type | Description
System.Boolean |

IsReadOnly

Declaration
public bool IsReadOnly { get; }
Property Value
Type | Description
System.Boolean |

IsSynchronized

Declaration
public bool IsSynchronized { get; }
Property Value
Type | Description
System.Boolean |

Item[Int32]

Declaration
public virtual string this[int index] { get; set; }
Parameters
Type | Name | Description
System.Int32 | index |
Property Value
Type | Description
System.String |

SyncRoot

Declaration
public object SyncRoot { get; }
Property Value
Type | Description
System.Object |

Methods

Add(String)

Declaration
public virtual int Add(string name)
Parameters
Type | Name | Description
System.String | name |
Returns
Type | Description
System.Int32 |

AddRange(String[])

Declaration
public virtual int[] AddRange(params string[] addNames)
Parameters
Type | Name | Description
System.String[] | addNames |
Returns
Type | Description
System.Int32[] |

Clear()

Declaration
public virtual void Clear()

Contains(String)

Declaration
public virtual bool Contains(string name)
Parameters
Type | Name | Description
System.String | name |
Returns
Type | Description
System.Boolean |

CopyTo(String[], Int32)

Declaration
public virtual void CopyTo(string[] array, int index)
Parameters
Type | Name | Description
System.String[] | array |
System.Int32 | index |

GetEnumerator()

Declaration
public IEnumerator GetEnumerator()
Returns
Type | Description
System.Collections.IEnumerator |

IndexOf(String)

Declaration
public virtual int IndexOf(string name)
Parameters
Type | Name | Description
System.String | name |
Returns
Type | Description
System.Int32 |

Insert(Int32, String)

Declaration
public virtual void Insert(int index, string name)
Parameters
Type | Name | Description
System.Int32 | index |
System.String | name |

Remove(String)

Declaration
public virtual void Remove(string name)
Parameters
Type | Name | Description
System.String | name |

RemoveAt(Int32)

Declaration
public virtual void RemoveAt(int index)
Parameters
Type | Name | Description
System.Int32 | index |

SetList(String)

Declaration
public virtual void SetList(string commaList)
Parameters
Type | Name | Description
System.String | commaList |

ToString()

Declaration
public override string ToString()
Returns
Type | Description
System.String |
Overrides
System.Object.ToString()

ValidateName(String)

Declaration
protected abstract bool ValidateName(string value)
Parameters
Type | Name | Description
System.String | value |
Returns
Type | Description
System.Boolean |

Explicit Interface Implementations

ICollection.CopyTo(Array, Int32)

Declaration
void ICollection.CopyTo(Array array, int index)
Parameters
Type | Name | Description
System.Array | array |
System.Int32 | index |

IList.Add(Object)

Declaration
int IList.Add(object value)
Parameters
Type | Name | Description
System.Object | value |
Returns
Type | Description
System.Int32 |

IList.Contains(Object)

Declaration
bool IList.Contains(object value)
Parameters
Type | Name | Description
System.Object | value |
Returns
Type | Description
System.Boolean |

IList.get_Item(Int32)

Declaration
object IList.get_Item(int index)
Parameters
Type | Name | Description
System.Int32 | index |
Returns
Type | Description
System.Object |

IList.IndexOf(Object)

Declaration
int IList.IndexOf(object value)
Parameters
Type | Name | Description
System.Object | value |
Returns
Type | Description
System.Int32 |

IList.Insert(Int32, Object)

Declaration
void IList.Insert(int index, object value)
Parameters
Type | Name | Description
System.Int32 | index |
System.Object | value |

IList.Item[Int32]

Declaration
object IList.this[] { get; set; }
Parameters
Type | Name | Description
System.Int32 | index |
Returns
Type | Description
System.Object |

IList.Remove(Object)

Declaration
void IList.Remove(object value)
Parameters
Type | Name | Description
System.Object | value |

IList.set_Item(Int32, Object)

Declaration
void IList.set_Item(int index, object value)
Parameters
Type | Name | Description
System.Int32 | index |
System.Object | value |

Implements

System.Collections.IList
System.Collections.ICollection
System.Collections.IEnumerable


Namespace FChoice.Toolkits.Clarify | fcSDK Documentation

Namespace FChoice.Toolkits.Clarify

Classes

AdditionalFields

ClarifyToolkitException

CommunicationAddress

ConstructorIndexAttribute

EmailIn

Location

LocationCollection

PartInfo

PartRequestInfo

PropertyBitValueAttribute

SimplifiedAdditionalField

SimplifiedAdditionalFields

ToolkitBase

ToolkitResult

ToolkitResultPropertyAttribute

Utility

Enums

AdditionalFieldType

BillingFrequency

BillingOption

CaseObjectType

CommunicationAutoExec

CommunicationDeliveryStatus

CommunicationDirection

CommunicationPriority

CommunicationRoleType

CRCondition

EcoItemAppliesTo

LeadSiteType

OpportunityStage

PartAuthorizationLevel

PartRepairType

PartRequestCondition

PartRequestType

PartRevisionStatus

PriceInstanceType

RepairPartDisposition

SiteStatus

SiteType

Back to top © 2022 Dovetail Software, Inc. - All rights reserved.
Clarify, Amdocs, and related products and names are copyright and trademark of Amdocs, Inc.
.NET, Visual Studio.NET, C#, Visual Basic and related products are trademark of Microsoft corporation.


Class AdditionalFields | fcSDK Documentation

Class AdditionalFields

Inheritance
System.Object
AdditionalFields
Implements
System.ICloneable
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class AdditionalFields : ICloneable

Methods

Append(String, AdditionalFieldType, Object)

Declaration
public void Append(string field, AdditionalFieldType fieldType, object val)
Parameters
Type | Name | Description
System.String | field |
AdditionalFieldType | fieldType |
System.Object | val |

Clone()

Declaration
public object Clone()
Returns
Type | Description
System.Object |

Implements

System.ICloneable


Enum AdditionalFieldType | fcSDK Documentation

Enum AdditionalFieldType

Namespace: FChoice.Toolkits.Clarify
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public enum AdditionalFieldType

Fields

Name | Description
Date |
Double |
Long |
String |


Enum BillingFrequency | fcSDK Documentation

Enum BillingFrequency

Namespace: FChoice.Toolkits.Clarify
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public enum BillingFrequency

Fields

Name | Description
Annual |
Monthly |
OneTime |
Quarterly |
SemiAnnual |


Enum BillingOption | fcSDK Documentation

Enum BillingOption

Namespace: FChoice.Toolkits.Clarify
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public enum BillingOption

Fields

Name | Description
InAdvance |
InArrears |


Enum CaseObjectType | fcSDK Documentation

Enum CaseObjectType

Namespace: FChoice.Toolkits.Clarify
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public enum CaseObjectType

Fields

Name | Description
Case |
Subcase |


Class ClarifyToolkitException | fcSDK Documentation

Class ClarifyToolkitException

Inheritance
System.Object
System.Exception
ClarifyToolkitException
Implements
System.Runtime.Serialization.ISerializable
System.Runtime.InteropServices._Exception
Inherited Members
System.Exception.GetBaseException()
System.Exception.ToString()
System.Exception.GetObjectData(System.Runtime.Serialization.SerializationInfo, System.Runtime.Serialization.StreamingContext)
System.Exception.GetType()
System.Exception.Message
System.Exception.Data
System.Exception.InnerException
System.Exception.TargetSite
System.Exception.StackTrace
System.Exception.HelpLink
System.Exception.Source
System.Exception.HResult
System.Exception.SerializeObjectState
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ClarifyToolkitException : Exception, ISerializable, _Exception

Constructors

ClarifyToolkitException(String)

Declaration
public ClarifyToolkitException(string message)
Parameters
Type | Name | Description
System.String | message |

Implements

System.Runtime.Serialization.ISerializable
System.Runtime.InteropServices._Exception


Class CommunicationAddress | fcSDK Documentation

Class CommunicationAddress

Inheritance
System.Object
CommunicationAddress
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CommunicationAddress

Constructors

CommunicationAddress(CommunicationRoleType, String)

Declaration
public CommunicationAddress(CommunicationRoleType communicationRoleType, string emailAddress)
Parameters
Type | Name | Description
CommunicationRoleType | communicationRoleType |
System.String | emailAddress |

Properties

CommunicationRoleType

Declaration
public CommunicationRoleType CommunicationRoleType { get; set; }
Property Value
Type | Description
CommunicationRoleType |

EmailAddress

Declaration
public string EmailAddress { get; set; }
Property Value
Type | Description
System.String |


Enum CommunicationAutoExec | fcSDK Documentation

Enum CommunicationAutoExec

Namespace: FChoice.Toolkits.Clarify
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public enum CommunicationAutoExec

Fields

Name | Description
Automatic |
User |


Enum CommunicationDeliveryStatus | fcSDK Documentation

Enum CommunicationDeliveryStatus

Namespace: FChoice.Toolkits.Clarify
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public enum CommunicationDeliveryStatus

Fields

Name | Description
Bounced |
Draft |
Failed |
Pending |
Received |
Sent |


Enum CommunicationDirection | fcSDK Documentation

Enum CommunicationDirection

Namespace: FChoice.Toolkits.Clarify
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public enum CommunicationDirection

Fields

Name | Description
Both |
Inbound |
Outbound |
Unknown |


Enum CommunicationPriority | fcSDK Documentation

Enum CommunicationPriority

Namespace: FChoice.Toolkits.Clarify
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public enum CommunicationPriority

Fields

Name | Description
High |
Normal |
Urgent |


Enum CommunicationRoleType | fcSDK Documentation

Enum CommunicationRoleType

Namespace: FChoice.Toolkits.Clarify
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public enum CommunicationRoleType

Fields

Name | Description
BCC |
CC |
Recipient |
ReplyTo |
Sender |


Class ConstructorIndexAttribute | fcSDK Documentation

Class ConstructorIndexAttribute

Inheritance
System.Object
System.Attribute
ConstructorIndexAttribute
Implements
System.Runtime.InteropServices._Attribute
Inherited Members
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Boolean)
System.Attribute.IsDefined(System.Reflection.MemberInfo, System.Type)
System.Attribute.IsDefined(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.MemberInfo, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Boolean)
System.Attribute.IsDefined(System.Reflection.ParameterInfo, System.Type)
System.Attribute.IsDefined(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.ParameterInfo, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.Module)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.IsDefined(System.Reflection.Module, System.Type)
System.Attribute.IsDefined(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.Module, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Boolean)
System.Attribute.IsDefined(System.Reflection.Assembly, System.Type)
System.Attribute.IsDefined(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.Assembly, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.Equals(System.Object)
System.Attribute.GetHashCode()
System.Attribute.Match(System.Object)
System.Attribute.IsDefaultAttribute()
System.Attribute.System.Runtime.InteropServices._Attribute.GetTypeInfoCount(System.UInt32)
System.Attribute.System.Runtime.InteropServices._Attribute.GetTypeInfo(System.UInt32, System.UInt32, System.IntPtr)
System.Attribute.System.Runtime.InteropServices._Attribute.GetIDsOfNames(System.Guid, System.IntPtr, System.UInt32, System.UInt32, System.IntPtr)
System.Attribute.System.Runtime.InteropServices._Attribute.Invoke(System.UInt32, System.Guid, System.UInt32, System.Int16, System.IntPtr, System.IntPtr, System.IntPtr, System.IntPtr)
System.Attribute.TypeId
System.Object.ToString()
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
[AttributeUsage(AttributeTargets.Constructor)]
public class ConstructorIndexAttribute : Attribute, _Attribute

Constructors

ConstructorIndexAttribute(Int32)

Declaration
public ConstructorIndexAttribute(int index)
Parameters
Type | Name | Description
System.Int32 | index |

Fields

Index

Declaration
public int Index
Field Value
Type | Description
System.Int32 |

Implements

System.Runtime.InteropServices._Attribute


Namespace FChoice.Toolkits.Clarify.Contracts | fcSDK Documentation

Namespace FChoice.Toolkits.Clarify.Contracts

Classes

AcceptQuoteSetup

AddPOToScheduleSetup

AssignQuoteSetup

ChangeQuoteStatusSetup

ContractsToolkit

ContractsToolkitBase

CreateContractLineItemSetup

CreateContractSetup

CreatePriceInstanceSetup

CreateScheduleSetup

DeleteSitePartSetup

DispatchQuoteSetup

ForwardQuoteSetup

LogContractNoteSetup

MoveQuoteSetup

RejectContractSetup

RejectQuoteSetup

RelateContractItemToSitePartSetup

ReopenContractSetup

UnrelateContractItemFromSitePartSetup

UpdateScheduleSetup

YankQuoteSetup

Back to top © 2022 Dovetail Software, Inc. - All rights reserved.
Clarify, Amdocs, and related products and names are copyright and trademark of Amdocs, Inc.
.NET, Visual Studio.NET, C#, Visual Basic and related products are trademark of Microsoft corporation.


Class AcceptQuoteSetup | fcSDK Documentation

Class AcceptQuoteSetup

Inheritance
System.Object
AcceptQuoteSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Contracts
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class AcceptQuoteSetup

Constructors

AcceptQuoteSetup(String)

Declaration
[ConstructorIndex(0)]
public AcceptQuoteSetup(string quoteIDNum)
Parameters
Type | Name | Description
System.String | quoteIDNum |

Properties

AcceptDate

Declaration
[PropertyBitValue(2)]
public DateTime AcceptDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(16)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

QuoteIDNum

Declaration
[PropertyBitValue(1)]
public string QuoteIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(4)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |


Class AddPOToScheduleSetup | fcSDK Documentation

Class AddPOToScheduleSetup

Inheritance
System.Object
AddPOToScheduleSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Contracts
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class AddPOToScheduleSetup

Constructors

AddPOToScheduleSetup(String, String, String, Decimal)

Declaration
[ConstructorIndex(0)]
public AddPOToScheduleSetup(string contractIDNum, string scheduleIDNum, string poIDNum, decimal poAmount)
Parameters
Type | Name | Description
System.String | contractIDNum |
System.String | scheduleIDNum |
System.String | poIDNum |
System.Decimal | poAmount |

Properties

ContractIDNum

Declaration
[PropertyBitValue(1)]
public string ContractIDNum { get; set; }
Property Value
Type | Description
System.String |

ExpireDate

Declaration
[PropertyBitValue(128)]
public DateTime ExpireDate { get; set; }
Property Value
Type | Description
System.DateTime |

PaymentOption

Declaration
[PropertyBitValue(8)]
public string PaymentOption { get; set; }
Property Value
Type | Description
System.String |

PaymentTerms

Declaration
[PropertyBitValue(16)]
public string PaymentTerms { get; set; }
Property Value
Type | Description
System.String |

POAmount

Declaration
[PropertyBitValue(32)]
public decimal POAmount { get; set; }
Property Value
Type | Description
System.Decimal |

PODate

Declaration
[PropertyBitValue(64)]
public DateTime PODate { get; set; }
Property Value
Type | Description
System.DateTime |

POIDNum

Declaration
[PropertyBitValue(4)]
public string POIDNum { get; set; }
Property Value
Type | Description
System.String |

POStatus

Declaration
[PropertyBitValue(256)]
public string POStatus { get; set; }
Property Value
Type | Description
System.String |

ScheduleIDNum

Declaration
[PropertyBitValue(2)]
public string ScheduleIDNum { get; set; }
Property Value
Type | Description
System.String |


Class AssignQuoteSetup | fcSDK Documentation

Class AssignQuoteSetup

Inheritance
System.Object
AssignQuoteSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Contracts
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class AssignQuoteSetup

Constructors

AssignQuoteSetup(String)

Declaration
[ConstructorIndex(0)]
public AssignQuoteSetup(string quoteIDNum)
Parameters
Type | Name | Description
System.String | quoteIDNum |

Properties

AssignDate

Declaration
[PropertyBitValue(8)]
public DateTime AssignDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

NewUser

Declaration
[PropertyBitValue(2)]
public string NewUser { get; set; }
Property Value
Type | Description
System.String |

QuoteIDNum

Declaration
[PropertyBitValue(1)]
public string QuoteIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(4)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |


Class ChangeQuoteStatusSetup | fcSDK Documentation

Class ChangeQuoteStatusSetup

Inheritance
System.Object
ChangeQuoteStatusSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Contracts
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ChangeQuoteStatusSetup

Constructors

ChangeQuoteStatusSetup(String)

Declaration
[ConstructorIndex(0)]
public ChangeQuoteStatusSetup(string quoteIDNum)
Parameters
Type | Name | Description
System.String | quoteIDNum |

Properties

ChangeDate

Declaration
[PropertyBitValue(4)]
public DateTime ChangeDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

NewStatus

Declaration
[PropertyBitValue(2)]
public string NewStatus { get; set; }
Property Value
Type | Description
System.String |

Notes

Declaration
[PropertyBitValue(8)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

QuoteIDNum

Declaration
[PropertyBitValue(1)]
public string QuoteIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class ContractsToolkit | fcSDK Documentation

Class ContractsToolkit

Inheritance
System.Object
ToolkitBase
ContractsToolkitBase
ContractsToolkit
Inherited Members
ContractsToolkitBase._toolkit
ContractsToolkitBase.ImpersonatorUsername
ToolkitBase.NOW_DATE
ToolkitBase.CompatSession
ToolkitBase.WithTransaction<T>(Func<IDbTransaction, T>)
ToolkitBase.FCApplication
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Contracts
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ContractsToolkit : ContractsToolkitBase

Constructors

ContractsToolkit(ClarifySession)

Declaration
public ContractsToolkit(ClarifySession session)
Parameters
Type | Name | Description
ClarifySession | session |

ContractsToolkit(IFCApplication, IFCSession)

Declaration
public ContractsToolkit(IFCApplication application, IFCSession session)
Parameters
Type | Name | Description
IFCApplication | application |
IFCSession | session |

Methods

AcceptQuote(AcceptQuoteSetup)

Declaration
public ToolkitResult AcceptQuote(AcceptQuoteSetup setupParam)
Parameters
Type | Name | Description
AcceptQuoteSetup | setupParam |
Returns
Type | Description
ToolkitResult |

AcceptQuote(AcceptQuoteSetup, IDbTransaction)

Declaration
public ToolkitResult AcceptQuote(AcceptQuoteSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
AcceptQuoteSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

AcceptQuote(String)

Declaration
public ToolkitResult AcceptQuote(string quoteIDNum)
Parameters
Type | Name | Description
System.String | quoteIDNum |
Returns
Type | Description
ToolkitResult |

AddPOToSchedule(AddPOToScheduleSetup)

Declaration
public ToolkitResult AddPOToSchedule(AddPOToScheduleSetup setupParam)
Parameters
Type | Name | Description
AddPOToScheduleSetup | setupParam |
Returns
Type | Description
ToolkitResult |

AddPOToSchedule(AddPOToScheduleSetup, IDbTransaction)

Declaration
public ToolkitResult AddPOToSchedule(AddPOToScheduleSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
AddPOToScheduleSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

AddPOToSchedule(String, String, String, Decimal)

Declaration
public ToolkitResult AddPOToSchedule(string contractIDNum, string scheduleIDNum, string poIDNum, decimal poAmount)
Parameters
Type | Name | Description
System.String | contractIDNum |
System.String | scheduleIDNum |
System.String | poIDNum |
System.Decimal | poAmount |
Returns
Type | Description
ToolkitResult |

AssignQuote(AssignQuoteSetup)

Declaration
public ToolkitResult AssignQuote(AssignQuoteSetup setupParam)
Parameters
Type | Name | Description
AssignQuoteSetup | setupParam |
Returns
Type | Description
ToolkitResult |

AssignQuote(AssignQuoteSetup, IDbTransaction)

Declaration
public ToolkitResult AssignQuote(AssignQuoteSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
AssignQuoteSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

AssignQuote(String)

Declaration
public ToolkitResult AssignQuote(string quoteIDNum)
Parameters
Type | Name | Description
System.String | quoteIDNum |
Returns
Type | Description
ToolkitResult |

ChangeQuoteStatus(ChangeQuoteStatusSetup)

Declaration
public ToolkitResult ChangeQuoteStatus(ChangeQuoteStatusSetup setupParam)
Parameters
Type | Name | Description
ChangeQuoteStatusSetup | setupParam |
Returns
Type | Description
ToolkitResult |

ChangeQuoteStatus(ChangeQuoteStatusSetup, IDbTransaction)

Declaration
public ToolkitResult ChangeQuoteStatus(ChangeQuoteStatusSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
ChangeQuoteStatusSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

ChangeQuoteStatus(String)

Declaration
public ToolkitResult ChangeQuoteStatus(string quoteIDNum)
Parameters
Type | Name | Description
System.String | quoteIDNum |
Returns
Type | Description
ToolkitResult |

CreateContract(CreateContractSetup)

Declaration
public ToolkitResult CreateContract(CreateContractSetup setupParam)
Parameters
Type | Name | Description
CreateContractSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreateContract(CreateContractSetup, IDbTransaction)

Declaration
public ToolkitResult CreateContract(CreateContractSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateContractSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreateContract(String)

Declaration
public ToolkitResult CreateContract(string title)
Parameters
Type | Name | Description
System.String | title |
Returns
Type | Description
ToolkitResult |

CreateContractLineItem(CreateContractLineItemSetup)

Declaration
public ToolkitResult CreateContractLineItem(CreateContractLineItemSetup setupParam)
Parameters
Type | Name | Description
CreateContractLineItemSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreateContractLineItem(CreateContractLineItemSetup, IDbTransaction)

Declaration
public ToolkitResult CreateContractLineItem(CreateContractLineItemSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateContractLineItemSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreateContractLineItem(String, String, String, String, Int32, String, Int32)

Declaration
public ToolkitResult CreateContractLineItem(string contractIDNum, string partNumber, string partDomain, string partRevision, int quantity, string priceSchedule, int parentLineItemObjid)
Parameters
Type | Name | Description
System.String | contractIDNum |
System.String | partNumber |
System.String | partDomain |
System.String | partRevision |
System.Int32 | quantity |
System.String | priceSchedule |
System.Int32 | parentLineItemObjid |
Returns
Type | Description
ToolkitResult |

CreateContractLineItem(String, String, String, String, String, String, Int32)

Declaration
public ToolkitResult CreateContractLineItem(string contractIDNum, string partNumber, string partDomain, string partRevision, string priceSchedule, string serialNumber, int parentLineItemObjid)
Parameters
Type | Name | Description
System.String | contractIDNum |
System.String | partNumber |
System.String | partDomain |
System.String | partRevision |
System.String | priceSchedule |
System.String | serialNumber |
System.Int32 | parentLineItemObjid |
Returns
Type | Description
ToolkitResult |

CreatePriceInstance(CreatePriceInstanceSetup)

Declaration
public ToolkitResult CreatePriceInstance(CreatePriceInstanceSetup setupParam)
Parameters
Type | Name | Description
CreatePriceInstanceSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreatePriceInstance(CreatePriceInstanceSetup, IDbTransaction)

Declaration
public ToolkitResult CreatePriceInstance(CreatePriceInstanceSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreatePriceInstanceSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreatePriceInstance(String, String, String, String, String, PriceInstanceType, Int32)

Declaration
public ToolkitResult CreatePriceInstance(string partNumber, string partRevision, string partDomain, string supportProgram, string priceProgram, PriceInstanceType priceType, int quantity)
Parameters
Type | Name | Description
System.String | partNumber |
System.String | partRevision |
System.String | partDomain |
System.String | supportProgram |
System.String | priceProgram |
PriceInstanceType | priceType |
System.Int32 | quantity |
Returns
Type | Description
ToolkitResult |

CreateSchedule(CreateScheduleSetup)

Declaration
public ToolkitResult CreateSchedule(CreateScheduleSetup setupParam)
Parameters
Type | Name | Description
CreateScheduleSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreateSchedule(CreateScheduleSetup, IDbTransaction)

Declaration
public ToolkitResult CreateSchedule(CreateScheduleSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateScheduleSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreateSchedule(String)

Declaration
public ToolkitResult CreateSchedule(string contractIDNum)
Parameters
Type | Name | Description
System.String | contractIDNum |
Returns
Type | Description
ToolkitResult |

DeleteSitePart(DeleteSitePartSetup)

Declaration
public ToolkitResult DeleteSitePart(DeleteSitePartSetup setupParam)
Parameters
Type | Name | Description
DeleteSitePartSetup | setupParam |
Returns
Type | Description
ToolkitResult |

DeleteSitePart(DeleteSitePartSetup, IDbTransaction)

Declaration
public ToolkitResult DeleteSitePart(DeleteSitePartSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
DeleteSitePartSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

DeleteSitePart(Int32)

Declaration
public ToolkitResult DeleteSitePart(int sitePartObjid)
Parameters
Type | Name | Description
System.Int32 | sitePartObjid |
Returns
Type | Description
ToolkitResult |

DispatchQuote(DispatchQuoteSetup)

Declaration
public ToolkitResult DispatchQuote(DispatchQuoteSetup setupParam)
Parameters
Type | Name | Description
DispatchQuoteSetup | setupParam |
Returns
Type | Description
ToolkitResult |

DispatchQuote(DispatchQuoteSetup, IDbTransaction)

Declaration
public ToolkitResult DispatchQuote(DispatchQuoteSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
DispatchQuoteSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

DispatchQuote(String, String)

Declaration
public ToolkitResult DispatchQuote(string quoteIDNum, string queue)
Parameters
Type | Name | Description
System.String | quoteIDNum |
System.String | queue |
Returns
Type | Description
ToolkitResult |

ForwardQuote(ForwardQuoteSetup)

Declaration
public ToolkitResult ForwardQuote(ForwardQuoteSetup setupParam)
Parameters
Type | Name | Description
ForwardQuoteSetup | setupParam |
Returns
Type | Description
ToolkitResult |

ForwardQuote(ForwardQuoteSetup, IDbTransaction)

Declaration
public ToolkitResult ForwardQuote(ForwardQuoteSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
ForwardQuoteSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

ForwardQuote(String, String)

Declaration
public ToolkitResult ForwardQuote(string quoteIDNum, string newQueue)
Parameters
Type | Name | Description
System.String | quoteIDNum |
System.String | newQueue |
Returns
Type | Description
ToolkitResult |

LogContractNote(LogContractNoteSetup)

Declaration
public ToolkitResult LogContractNote(LogContractNoteSetup setupParam)
Parameters
Type | Name | Description
LogContractNoteSetup | setupParam |
Returns
Type | Description
ToolkitResult |

LogContractNote(LogContractNoteSetup, IDbTransaction)

Declaration
public ToolkitResult LogContractNote(LogContractNoteSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
LogContractNoteSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

LogContractNote(String, String)

Declaration
public ToolkitResult LogContractNote(string contractIDNum, string notes)
Parameters
Type | Name | Description
System.String | contractIDNum |
System.String | notes |
Returns
Type | Description
ToolkitResult |

MoveQuote(MoveQuoteSetup)

Declaration
public ToolkitResult MoveQuote(MoveQuoteSetup setupParam)
Parameters
Type | Name | Description
MoveQuoteSetup | setupParam |
Returns
Type | Description
ToolkitResult |

MoveQuote(MoveQuoteSetup, IDbTransaction)

Declaration
public ToolkitResult MoveQuote(MoveQuoteSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
MoveQuoteSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

MoveQuote(String, String)

Declaration
public ToolkitResult MoveQuote(string quoteIDNum, string newWipBin)
Parameters
Type | Name | Description
System.String | quoteIDNum |
System.String | newWipBin |
Returns
Type | Description
ToolkitResult |

RejectContract(RejectContractSetup)

Declaration
public ToolkitResult RejectContract(RejectContractSetup setupParam)
Parameters
Type | Name | Description
RejectContractSetup | setupParam |
Returns
Type | Description
ToolkitResult |

RejectContract(RejectContractSetup, IDbTransaction)

Declaration
public ToolkitResult RejectContract(RejectContractSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
RejectContractSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

RejectContract(String)

Declaration
public ToolkitResult RejectContract(string contractIDNum)
Parameters
Type | Name | Description
System.String | contractIDNum |
Returns
Type | Description
ToolkitResult |

RejectQuote(RejectQuoteSetup)

Declaration
public ToolkitResult RejectQuote(RejectQuoteSetup setupParam)
Parameters
Type | Name | Description
RejectQuoteSetup | setupParam |
Returns
Type | Description
ToolkitResult |

RejectQuote(RejectQuoteSetup, IDbTransaction)

Declaration
public ToolkitResult RejectQuote(RejectQuoteSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
RejectQuoteSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

RejectQuote(String)

Declaration
public ToolkitResult RejectQuote(string quoteIDNum)
Parameters
Type | Name | Description
System.String | quoteIDNum |
Returns
Type | Description
ToolkitResult |

RelateContractItemToSitePart(RelateContractItemToSitePartSetup)

Declaration
public ToolkitResult RelateContractItemToSitePart(RelateContractItemToSitePartSetup setupParam)
Parameters
Type | Name | Description
RelateContractItemToSitePartSetup | setupParam |
Returns
Type | Description
ToolkitResult |

RelateContractItemToSitePart(RelateContractItemToSitePartSetup, IDbTransaction)

Declaration
public ToolkitResult RelateContractItemToSitePart(RelateContractItemToSitePartSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
RelateContractItemToSitePartSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

RelateContractItemToSitePart(Int32, String, String, String, String)

Declaration
public ToolkitResult RelateContractItemToSitePart(int contractObjid, string partNumber, string partDomain, string partRevision, string serialNumber)
Parameters
Type | Name | Description
System.Int32 | contractObjid |
System.String | partNumber |
System.String | partDomain |
System.String | partRevision |
System.String | serialNumber |
Returns
Type | Description
ToolkitResult |

ReopenContract(ReopenContractSetup)

Declaration
public ToolkitResult ReopenContract(ReopenContractSetup setupParam)
Parameters
Type | Name | Description
ReopenContractSetup | setupParam |
Returns
Type | Description
ToolkitResult |

ReopenContract(ReopenContractSetup, IDbTransaction)

Declaration
public ToolkitResult ReopenContract(ReopenContractSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
ReopenContractSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

ReopenContract(String, String)

Declaration
public ToolkitResult ReopenContract(string contractIDNum, string status)
Parameters
Type | Name | Description
System.String | contractIDNum |
System.String | status |
Returns
Type | Description
ToolkitResult |

UnrelateContractItemFromSitePart(UnrelateContractItemFromSitePartSetup)

Declaration
public ToolkitResult UnrelateContractItemFromSitePart(UnrelateContractItemFromSitePartSetup setupParam)
Parameters
Type | Name | Description
UnrelateContractItemFromSitePartSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UnrelateContractItemFromSitePart(UnrelateContractItemFromSitePartSetup, IDbTransaction)

Declaration
public ToolkitResult UnrelateContractItemFromSitePart(UnrelateContractItemFromSitePartSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UnrelateContractItemFromSitePartSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UnrelateContractItemFromSitePart(Int32, String, String, String)

Declaration
public ToolkitResult UnrelateContractItemFromSitePart(int contractObjid, string partNumber, string partDomain, string partRevision)
Parameters
Type | Name | Description
System.Int32 | contractObjid |
System.String | partNumber |
System.String | partDomain |
System.String | partRevision |
Returns
Type | Description
ToolkitResult |

UpdateSchedule(UpdateScheduleSetup)

Declaration
public ToolkitResult UpdateSchedule(UpdateScheduleSetup setupParam)
Parameters
Type | Name | Description
UpdateScheduleSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdateSchedule(UpdateScheduleSetup, IDbTransaction)

Declaration
public ToolkitResult UpdateSchedule(UpdateScheduleSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdateScheduleSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UpdateSchedule(String, String)

Declaration
public ToolkitResult UpdateSchedule(string contractIDNum, string scheduleIDNum)
Parameters
Type | Name | Description
System.String | contractIDNum |
System.String | scheduleIDNum |
Returns
Type | Description
ToolkitResult |

YankQuote(YankQuoteSetup)

Declaration
public ToolkitResult YankQuote(YankQuoteSetup setupParam)
Parameters
Type | Name | Description
YankQuoteSetup | setupParam |
Returns
Type | Description
ToolkitResult |

YankQuote(YankQuoteSetup, IDbTransaction)

Declaration
public ToolkitResult YankQuote(YankQuoteSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
YankQuoteSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

YankQuote(String)

Declaration
public ToolkitResult YankQuote(string quoteIDNum)
Parameters
Type | Name | Description
System.String | quoteIDNum |
Returns
Type | Description
ToolkitResult |


Class ContractsToolkitBase | fcSDK Documentation

Class ContractsToolkitBase

Inheritance
System.Object
ToolkitBase
ContractsToolkitBase
ContractsToolkit
Inherited Members
ToolkitBase.NOW_DATE
ToolkitBase.CompatSession
ToolkitBase.WithTransaction<T>(Func<IDbTransaction, T>)
ToolkitBase.FCApplication
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Contracts
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public abstract class ContractsToolkitBase : ToolkitBase

Constructors

ContractsToolkitBase(ClarifySession)

Declaration
public ContractsToolkitBase(ClarifySession sess)
Parameters
Type | Name | Description
ClarifySession | sess |

ContractsToolkitBase(IFCApplication, IFCSession)

Declaration
public ContractsToolkitBase(IFCApplication app, IFCSession sess)
Parameters
Type | Name | Description
IFCApplication | app |
IFCSession | sess |

Fields

_toolkit

Declaration
protected FCCC _toolkit
Field Value
Type | Description
FCCC |

Properties

ImpersonatorUsername

Declaration
public string ImpersonatorUsername { get; set; }
Property Value
Type | Description
System.String |


Class CreateContractLineItemSetup | fcSDK Documentation

Class CreateContractLineItemSetup

Inheritance
System.Object
CreateContractLineItemSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Contracts
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateContractLineItemSetup

Constructors

CreateContractLineItemSetup(String, String, String, String, Int32, String, Int32)

Declaration
[ConstructorIndex(0)]
public CreateContractLineItemSetup(string contractIDNum, string partNumber, string partDomain, string partRevision, int quantity, string priceSchedule, int parentLineItemObjid)
Parameters
Type | Name | Description
System.String | contractIDNum |
System.String | partNumber |
System.String | partDomain |
System.String | partRevision |
System.Int32 | quantity |
System.String | priceSchedule |
System.Int32 | parentLineItemObjid |

CreateContractLineItemSetup(String, String, String, String, String, String, Int32)

Declaration
[ConstructorIndex(1)]
public CreateContractLineItemSetup(string contractIDNum, string partNumber, string partDomain, string partRevision, string priceSchedule, string serialNumber, int parentLineItemObjid)
Parameters
Type | Name | Description
System.String | contractIDNum |
System.String | partNumber |
System.String | partDomain |
System.String | partRevision |
System.String | priceSchedule |
System.String | serialNumber |
System.Int32 | parentLineItemObjid |

Properties

AdditionalFields

Declaration
[PropertyBitValue(1048576)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

AutoInstall

Declaration
[PropertyBitValue(16384)]
public bool AutoInstall { get; set; }
Property Value
Type | Description
System.Boolean |

Comments

Declaration
[PropertyBitValue(32768)]
public string Comments { get; set; }
Property Value
Type | Description
System.String |

ContractIDNum

Declaration
[PropertyBitValue(1)]
public string ContractIDNum { get; set; }
Property Value
Type | Description
System.String |

CreateDate

Declaration
[PropertyBitValue(4)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

EndDate

Declaration
[PropertyBitValue(16)]
public DateTime EndDate { get; set; }
Property Value
Type | Description
System.DateTime |

IsTaxable

Declaration
[PropertyBitValue(8192)]
public bool IsTaxable { get; set; }
Property Value
Type | Description
System.Boolean |

OverridePrice

Declaration
[PropertyBitValue(1024)]
public double OverridePrice { get; set; }
Property Value
Type | Description
System.Double |

ParentLineItemObjid

Declaration
[PropertyBitValue(262144)]
public int ParentLineItemObjid { get; set; }
Property Value
Type | Description
System.Int32 |

PartDomain

Declaration
[PropertyBitValue(64)]
public string PartDomain { get; set; }
Property Value
Type | Description
System.String |

PartNumber

Declaration
[PropertyBitValue(32)]
public string PartNumber { get; set; }
Property Value
Type | Description
System.String |

PartRevision

Declaration
[PropertyBitValue(128)]
public string PartRevision { get; set; }
Property Value
Type | Description
System.String |

POIDNum

Declaration
[PropertyBitValue(524288)]
public string POIDNum { get; set; }
Property Value
Type | Description
System.String |

PriceSchedule

Declaration
[PropertyBitValue(512)]
public string PriceSchedule { get; set; }
Property Value
Type | Description
System.String |

Quantity

Declaration
[PropertyBitValue(256)]
public int Quantity { get; set; }
Property Value
Type | Description
System.Int32 |

QuotedSiteIDNum

Declaration
[PropertyBitValue(65536)]
public string QuotedSiteIDNum { get; set; }
Property Value
Type | Description
System.String |

SerialNumber

Declaration
[PropertyBitValue(4096)]
public string SerialNumber { get; set; }
Property Value
Type | Description
System.String |

ServicedAtSiteIDNum

Declaration
[PropertyBitValue(131072)]
public string ServicedAtSiteIDNum { get; set; }
Property Value
Type | Description
System.String |

StartDate

Declaration
[PropertyBitValue(8)]
public DateTime StartDate { get; set; }
Property Value
Type | Description
System.DateTime |

UnitsUsed

Declaration
[PropertyBitValue(2048)]
public double UnitsUsed { get; set; }
Property Value
Type | Description
System.Double |

UserName

Declaration
[PropertyBitValue(2)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class CreateContractSetup | fcSDK Documentation

Class CreateContractSetup

Inheritance
System.Object
CreateContractSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Contracts
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateContractSetup

Constructors

CreateContractSetup(String)

Declaration
[ConstructorIndex(0)]
public CreateContractSetup(string title)
Parameters
Type | Name | Description
System.String | title |

Properties

AccountIDNum

Declaration
[PropertyBitValue(8)]
public string AccountIDNum { get; set; }
Property Value
Type | Description
System.String |

AccountName

Declaration
[PropertyBitValue(16)]
public string AccountName { get; set; }
Property Value
Type | Description
System.String |

AdditionalFields

Declaration
[PropertyBitValue(33554432)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

AdminUserName

Declaration
[PropertyBitValue(4096)]
public string AdminUserName { get; set; }
Property Value
Type | Description
System.String |

BillToSiteIDNum

Declaration
[PropertyBitValue(8192)]
public string BillToSiteIDNum { get; set; }
Property Value
Type | Description
System.String |

ContactFirstName

Declaration
[PropertyBitValue(32)]
public string ContactFirstName { get; set; }
Property Value
Type | Description
System.String |

ContactLastName

Declaration
[PropertyBitValue(64)]
public string ContactLastName { get; set; }
Property Value
Type | Description
System.String |

ContactPhone

Declaration
[PropertyBitValue(128)]
public string ContactPhone { get; set; }
Property Value
Type | Description
System.String |

ContractIDNum

Declaration
[PropertyBitValue(1)]
public string ContractIDNum { get; set; }
Property Value
Type | Description
System.String |

ContractType

Declaration
[PropertyBitValue(256)]
public string ContractType { get; set; }
Property Value
Type | Description
System.String |

CreateDate

Declaration
[PropertyBitValue(4)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

DefaultExpirationDate

Declaration
[PropertyBitValue(262144)]
public DateTime DefaultExpirationDate { get; set; }
Property Value
Type | Description
System.DateTime |

DefaultStartDate

Declaration
[PropertyBitValue(131072)]
public DateTime DefaultStartDate { get; set; }
Property Value
Type | Description
System.DateTime |

ExpireDate

Declaration
[PropertyBitValue(65536)]
public DateTime ExpireDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(16777216)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

IsEvergreen

Declaration
[PropertyBitValue(4194304)]
public bool IsEvergreen { get; set; }
Property Value
Type | Description
System.Boolean |

IsWarranty

Declaration
[PropertyBitValue(2097152)]
public bool IsWarranty { get; set; }
Property Value
Type | Description
System.Boolean |

PriceProgram

Declaration
[PropertyBitValue(1024)]
public string PriceProgram { get; set; }
Property Value
Type | Description
System.String |

Queue

Declaration
[PropertyBitValue(1048576)]
public string Queue { get; set; }
Property Value
Type | Description
System.String |

RenewPriorDays

Declaration
[PropertyBitValue(8388608)]
public int RenewPriorDays { get; set; }
Property Value
Type | Description
System.Int32 |

ShipToSiteIDNum

Declaration
[PropertyBitValue(16384)]
public string ShipToSiteIDNum { get; set; }
Property Value
Type | Description
System.String |

StartDate

Declaration
[PropertyBitValue(32768)]
public DateTime StartDate { get; set; }
Property Value
Type | Description
System.DateTime |

Status

Declaration
[PropertyBitValue(2048)]
public string Status { get; set; }
Property Value
Type | Description
System.String |

Terms

Declaration
[PropertyBitValue(512)]
public string Terms { get; set; }
Property Value
Type | Description
System.String |

Title

Declaration
[PropertyBitValue(2)]
public string Title { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(524288)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class CreatePriceInstanceSetup | fcSDK Documentation

Class CreatePriceInstanceSetup

Inheritance
System.Object
CreatePriceInstanceSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Contracts
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreatePriceInstanceSetup

Constructors

CreatePriceInstanceSetup(String, String, String, String, String, PriceInstanceType, Int32)

Declaration
[ConstructorIndex(0)]
public CreatePriceInstanceSetup(string partNumber, string partRevision, string partDomain, string supportProgram, string priceProgram, PriceInstanceType priceType, int quantity)
Parameters
Type | Name | Description
System.String | partNumber |
System.String | partRevision |
System.String | partDomain |
System.String | supportProgram |
System.String | priceProgram |
PriceInstanceType | priceType |
System.Int32 | quantity |

Properties

AdditionalFields

Declaration
[PropertyBitValue(1024)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

EffectiveDate

Declaration
[PropertyBitValue(256)]
public DateTime EffectiveDate { get; set; }
Property Value
Type | Description
System.DateTime |

ExpireDate

Declaration
[PropertyBitValue(512)]
public DateTime ExpireDate { get; set; }
Property Value
Type | Description
System.DateTime |

PartDomain

Declaration
[PropertyBitValue(4)]
public string PartDomain { get; set; }
Property Value
Type | Description
System.String |

PartNumber

Declaration
[PropertyBitValue(1)]
public string PartNumber { get; set; }
Property Value
Type | Description
System.String |

PartRevision

Declaration
[PropertyBitValue(2)]
public string PartRevision { get; set; }
Property Value
Type | Description
System.String |

Price

Declaration
[PropertyBitValue(128)]
public double Price { get; set; }
Property Value
Type | Description
System.Double |

PriceProgram

Declaration
[PropertyBitValue(16)]
public string PriceProgram { get; set; }
Property Value
Type | Description
System.String |

PriceType

Declaration
[PropertyBitValue(32)]
public PriceInstanceType PriceType { get; set; }
Property Value
Type | Description
PriceInstanceType |

Quantity

Declaration
[PropertyBitValue(64)]
public int Quantity { get; set; }
Property Value
Type | Description
System.Int32 |

SupportProgram

Declaration
[PropertyBitValue(8)]
public string SupportProgram { get; set; }
Property Value
Type | Description
System.String |


Class CreateScheduleSetup | fcSDK Documentation

Class CreateScheduleSetup

Inheritance
System.Object
CreateScheduleSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Contracts
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateScheduleSetup

Constructors

CreateScheduleSetup(String)

Declaration
[ConstructorIndex(0)]
public CreateScheduleSetup(string contractIDNum)
Parameters
Type | Name | Description
System.String | contractIDNum |

Properties

AdditionalFields

Declaration
[PropertyBitValue(8192)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

BillingATTN

Declaration
[PropertyBitValue(16)]
public string BillingATTN { get; set; }
Property Value
Type | Description
System.String |

BillingFrequency

Declaration
[PropertyBitValue(128)]
public BillingFrequency BillingFrequency { get; set; }
Property Value
Type | Description
BillingFrequency |

BillingOption

Declaration
[PropertyBitValue(256)]
public BillingOption BillingOption { get; set; }
Property Value
Type | Description
BillingOption |

BillingPeriodStartDate

Declaration
[PropertyBitValue(512)]
public DateTime BillingPeriodStartDate { get; set; }
Property Value
Type | Description
System.DateTime |

BillSiteIDNum

Declaration
[PropertyBitValue(8)]
public string BillSiteIDNum { get; set; }
Property Value
Type | Description
System.String |

ChargeEndDate

Declaration
[PropertyBitValue(4096)]
public DateTime ChargeEndDate { get; set; }
Property Value
Type | Description
System.DateTime |

ChargeStartDate

Declaration
[PropertyBitValue(2048)]
public DateTime ChargeStartDate { get; set; }
Property Value
Type | Description
System.DateTime |

ContractIDNum

Declaration
[PropertyBitValue(1)]
public string ContractIDNum { get; set; }
Property Value
Type | Description
System.String |

FirstBillingDate

Declaration
[PropertyBitValue(1024)]
public DateTime FirstBillingDate { get; set; }
Property Value
Type | Description
System.DateTime |

PriceProgram

Declaration
[PropertyBitValue(64)]
public string PriceProgram { get; set; }
Property Value
Type | Description
System.String |

ScheduleIDNum

Declaration
[PropertyBitValue(4)]
public string ScheduleIDNum { get; set; }
Property Value
Type | Description
System.String |

ShipToSiteIDNum

Declaration
[PropertyBitValue(32)]
public string ShipToSiteIDNum { get; set; }
Property Value
Type | Description
System.String |


Class DeleteSitePartSetup | fcSDK Documentation

Class DeleteSitePartSetup

Inheritance
System.Object
DeleteSitePartSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Contracts
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class DeleteSitePartSetup

Constructors

DeleteSitePartSetup(Int32)

Declaration
[ConstructorIndex(0)]
public DeleteSitePartSetup(int sitePartObjid)
Parameters
Type | Name | Description
System.Int32 | sitePartObjid |

Properties

SitePartObjid

Declaration
[PropertyBitValue(1)]
public int SitePartObjid { get; set; }
Property Value
Type | Description
System.Int32 |


Class DispatchQuoteSetup | fcSDK Documentation

Class DispatchQuoteSetup

Inheritance
System.Object
DispatchQuoteSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Contracts
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class DispatchQuoteSetup

Constructors

DispatchQuoteSetup(String, String)

Declaration
[ConstructorIndex(0)]
public DispatchQuoteSetup(string quoteIDNum, string queue)
Parameters
Type | Name | Description
System.String | quoteIDNum |
System.String | queue |

Properties

DispatchDate

Declaration
[PropertyBitValue(4)]
public DateTime DispatchDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(16)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

Queue

Declaration
[PropertyBitValue(2)]
public string Queue { get; set; }
Property Value
Type | Description
System.String |

QuoteIDNum

Declaration
[PropertyBitValue(1)]
public string QuoteIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class ForwardQuoteSetup | fcSDK Documentation

Class ForwardQuoteSetup

Inheritance
System.Object
ForwardQuoteSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Contracts
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ForwardQuoteSetup

Constructors

ForwardQuoteSetup(String, String)

Declaration
[ConstructorIndex(0)]
public ForwardQuoteSetup(string quoteIDNum, string newQueue)
Parameters
Type | Name | Description
System.String | quoteIDNum |
System.String | newQueue |

Properties

ForwardDate

Declaration
[PropertyBitValue(4)]
public DateTime ForwardDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

NewQueue

Declaration
[PropertyBitValue(2)]
public string NewQueue { get; set; }
Property Value
Type | Description
System.String |

Notes

Declaration
[PropertyBitValue(8)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

QuoteIDNum

Declaration
[PropertyBitValue(1)]
public string QuoteIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class LogContractNoteSetup | fcSDK Documentation

Class LogContractNoteSetup

Inheritance
System.Object
LogContractNoteSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Contracts
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LogContractNoteSetup

Constructors

LogContractNoteSetup(String, String)

Declaration
[ConstructorIndex(0)]
public LogContractNoteSetup(string contractIDNum, string notes)
Parameters
Type | Name | Description
System.String | contractIDNum |
System.String | notes |

Properties

ActionType

Declaration
[PropertyBitValue(2)]
public string ActionType { get; set; }
Property Value
Type | Description
System.String |

AdditionalFields

Declaration
[PropertyBitValue(128)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

ContractIDNum

Declaration
[PropertyBitValue(1)]
public string ContractIDNum { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(64)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

InternalUseOnlyNotes

Declaration
[PropertyBitValue(8)]
public string InternalUseOnlyNotes { get; set; }
Property Value
Type | Description
System.String |

LogDate

Declaration
[PropertyBitValue(16)]
public DateTime LogDate { get; set; }
Property Value
Type | Description
System.DateTime |

Notes

Declaration
[PropertyBitValue(4)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(32)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class MoveQuoteSetup | fcSDK Documentation

Class MoveQuoteSetup

Inheritance
System.Object
MoveQuoteSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Contracts
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class MoveQuoteSetup

Constructors

MoveQuoteSetup(String, String)

Declaration
[ConstructorIndex(0)]
public MoveQuoteSetup(string quoteIDNum, string newWipBin)
Parameters
Type | Name | Description
System.String | quoteIDNum |
System.String | newWipBin |

Properties

NewWipBin

Declaration
[PropertyBitValue(2)]
public string NewWipBin { get; set; }
Property Value
Type | Description
System.String |

QuoteIDNum

Declaration
[PropertyBitValue(1)]
public string QuoteIDNum { get; set; }
Property Value
Type | Description
System.String |


Class RejectContractSetup | fcSDK Documentation

Class RejectContractSetup

Inheritance
System.Object
RejectContractSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Contracts
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class RejectContractSetup

Constructors

RejectContractSetup(String)

Declaration
[ConstructorIndex(0)]
public RejectContractSetup(string contractIDNum)
Parameters
Type | Name | Description
System.String | contractIDNum |

Properties

ContractIDNum

Declaration
[PropertyBitValue(1)]
public string ContractIDNum { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

Notes

Declaration
[PropertyBitValue(4)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

RejectDate

Declaration
[PropertyBitValue(16)]
public DateTime RejectDate { get; set; }
Property Value
Type | Description
System.DateTime |

Status

Declaration
[PropertyBitValue(2)]
public string Status { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class RejectQuoteSetup | fcSDK Documentation

Class RejectQuoteSetup

Inheritance
System.Object
RejectQuoteSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Contracts
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class RejectQuoteSetup

Constructors

RejectQuoteSetup(String)

Declaration
[ConstructorIndex(0)]
public RejectQuoteSetup(string quoteIDNum)
Parameters
Type | Name | Description
System.String | quoteIDNum |

Properties

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

Notes

Declaration
[PropertyBitValue(8)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

QuoteIDNum

Declaration
[PropertyBitValue(1)]
public string QuoteIDNum { get; set; }
Property Value
Type | Description
System.String |

RejectDate

Declaration
[PropertyBitValue(2)]
public DateTime RejectDate { get; set; }
Property Value
Type | Description
System.DateTime |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(4)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |


Class RelateContractItemToSitePartSetup | fcSDK Documentation

Class RelateContractItemToSitePartSetup

Inheritance
System.Object
RelateContractItemToSitePartSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Contracts
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class RelateContractItemToSitePartSetup

Constructors

RelateContractItemToSitePartSetup(Int32, String, String, String, String)

Declaration
[ConstructorIndex(0)]
public RelateContractItemToSitePartSetup(int contractObjid, string partNumber, string partDomain, string partRevision, string serialNumber)
Parameters
Type | Name | Description
System.Int32 | contractObjid |
System.String | partNumber |
System.String | partDomain |
System.String | partRevision |
System.String | serialNumber |

Properties

ContractObjid

Declaration
[PropertyBitValue(1)]
public int ContractObjid { get; set; }
Property Value
Type | Description
System.Int32 |

PartDomain

Declaration
[PropertyBitValue(4)]
public string PartDomain { get; set; }
Property Value
Type | Description
System.String |

PartNumber

Declaration
[PropertyBitValue(2)]
public string PartNumber { get; set; }
Property Value
Type | Description
System.String |

PartRevision

Declaration
[PropertyBitValue(8)]
public string PartRevision { get; set; }
Property Value
Type | Description
System.String |

SerialNumber

Declaration
[PropertyBitValue(16)]
public string SerialNumber { get; set; }
Property Value
Type | Description
System.String |


Class ReopenContractSetup | fcSDK Documentation

Class ReopenContractSetup

Inheritance
System.Object
ReopenContractSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Contracts
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ReopenContractSetup

Constructors

ReopenContractSetup(String, String)

Declaration
[ConstructorIndex(0)]
public ReopenContractSetup(string contractIDNum, string status)
Parameters
Type | Name | Description
System.String | contractIDNum |
System.String | status |

Properties

ContractIDNum

Declaration
[PropertyBitValue(1)]
public string ContractIDNum { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

ReopenDate

Declaration
[PropertyBitValue(8)]
public DateTime ReopenDate { get; set; }
Property Value
Type | Description
System.DateTime |

Status

Declaration
[PropertyBitValue(4)]
public string Status { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(2)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |


Class UnrelateContractItemFromSitePartSetup | fcSDK Documentation

Class UnrelateContractItemFromSitePartSetup

Inheritance
System.Object
UnrelateContractItemFromSitePartSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Contracts
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UnrelateContractItemFromSitePartSetup

Constructors

UnrelateContractItemFromSitePartSetup(Int32, String, String, String)

Declaration
[ConstructorIndex(0)]
public UnrelateContractItemFromSitePartSetup(int contractObjid, string partNumber, string partDomain, string partRevision)
Parameters
Type | Name | Description
System.Int32 | contractObjid |
System.String | partNumber |
System.String | partDomain |
System.String | partRevision |

Properties

ContractObjid

Declaration
[PropertyBitValue(1)]
public int ContractObjid { get; set; }
Property Value
Type | Description
System.Int32 |

PartDomain

Declaration
[PropertyBitValue(4)]
public string PartDomain { get; set; }
Property Value
Type | Description
System.String |

PartNumber

Declaration
[PropertyBitValue(2)]
public string PartNumber { get; set; }
Property Value
Type | Description
System.String |

PartRevision

Declaration
[PropertyBitValue(8)]
public string PartRevision { get; set; }
Property Value
Type | Description
System.String |


Class UpdateScheduleSetup | fcSDK Documentation

Class UpdateScheduleSetup

Inheritance
System.Object
UpdateScheduleSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Contracts
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdateScheduleSetup

Constructors

UpdateScheduleSetup(String, String)

Declaration
[ConstructorIndex(0)]
public UpdateScheduleSetup(string contractIDNum, string scheduleIDNum)
Parameters
Type | Name | Description
System.String | contractIDNum |
System.String | scheduleIDNum |

Properties

AdditionalFields

Declaration
[PropertyBitValue(8192)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

BillingATTN

Declaration
[PropertyBitValue(16)]
public string BillingATTN { get; set; }
Property Value
Type | Description
System.String |

BillingFrequency

Declaration
[PropertyBitValue(128)]
public BillingFrequency BillingFrequency { get; set; }
Property Value
Type | Description
BillingFrequency |

BillingOption

Declaration
[PropertyBitValue(256)]
public BillingOption BillingOption { get; set; }
Property Value
Type | Description
BillingOption |

BillingPeriodStartDate

Declaration
[PropertyBitValue(512)]
public DateTime BillingPeriodStartDate { get; set; }
Property Value
Type | Description
System.DateTime |

BillSiteIDNum

Declaration
[PropertyBitValue(8)]
public string BillSiteIDNum { get; set; }
Property Value
Type | Description
System.String |

ChargeEndDate

Declaration
[PropertyBitValue(4096)]
public DateTime ChargeEndDate { get; set; }
Property Value
Type | Description
System.DateTime |

ChargeStartDate

Declaration
[PropertyBitValue(2048)]
public DateTime ChargeStartDate { get; set; }
Property Value
Type | Description
System.DateTime |

ContractIDNum

Declaration
[PropertyBitValue(1)]
public string ContractIDNum { get; set; }
Property Value
Type | Description
System.String |

FirstBillingDate

Declaration
[PropertyBitValue(1024)]
public DateTime FirstBillingDate { get; set; }
Property Value
Type | Description
System.DateTime |

PriceProgram

Declaration
[PropertyBitValue(64)]
public string PriceProgram { get; set; }
Property Value
Type | Description
System.String |

ScheduleIDNum

Declaration
[PropertyBitValue(4)]
public string ScheduleIDNum { get; set; }
Property Value
Type | Description
System.String |

ShipToSiteIDNum

Declaration
[PropertyBitValue(32)]
public string ShipToSiteIDNum { get; set; }
Property Value
Type | Description
System.String |


Class YankQuoteSetup | fcSDK Documentation

Class YankQuoteSetup

Inheritance
System.Object
YankQuoteSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Contracts
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class YankQuoteSetup

Constructors

YankQuoteSetup(String)

Declaration
[ConstructorIndex(0)]
public YankQuoteSetup(string quoteIDNum)
Parameters
Type | Name | Description
System.String | quoteIDNum |

Properties

GenerateTimeBombs

Declaration
[PropertyBitValue(16)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

QuoteIDNum

Declaration
[PropertyBitValue(1)]
public string QuoteIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(2)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |

YankDate

Declaration
[PropertyBitValue(4)]
public DateTime YankDate { get; set; }
Property Value
Type | Description
System.DateTime |


Enum CRCondition | fcSDK Documentation

Enum CRCondition

Namespace: FChoice.Toolkits.Clarify
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public enum CRCondition

Fields

Name | Description
Closed |
Closed_Duplicate |
Fixed |
Open |


Namespace FChoice.Toolkits.Clarify.DepotRepair | fcSDK Documentation

Namespace FChoice.Toolkits.Clarify.DepotRepair

Classes

ApplyEcoSetup

CreateDepotRepairLaborSetup

CreateDepotRepairMaterialSetup

CreateEcoHeaderSetup

CreateEcoItemSetup

CreateEcoLaborDetailSetup

CreateEcoMaterialDetailSetup

DeleteDepotRepairLaborSetup

DeleteDepotRepairMaterialSetup

DeleteEcoDetailSetup

DeleteEcoItemSetup

DepotRepairToolkit

DepotRepairToolkitBase

UpdateDepotRepairLaborSetup

UpdateDepotRepairMaterialSetup

UpdateEcoItemSetup

UpdateEcoLaborDetailSetup

UpdateEcoMaterialDetailSetup

Back to top © 2022 Dovetail Software, Inc. - All rights reserved.
Clarify, Amdocs, and related products and names are copyright and trademark of Amdocs, Inc.
.NET, Visual Studio.NET, C#, Visual Basic and related products are trademark of Microsoft corporation.


Class ApplyEcoSetup | fcSDK Documentation

Class ApplyEcoSetup

Inheritance
System.Object
ApplyEcoSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.DepotRepair
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ApplyEcoSetup

Constructors

ApplyEcoSetup(Int32, String)

Declaration
[ConstructorIndex(0)]
public ApplyEcoSetup(int demandDetailObjid, string ecoHeaderIDNum)
Parameters
Type | Name | Description
System.Int32 | demandDetailObjid |
System.String | ecoHeaderIDNum |

Properties

CreateDate

Declaration
[PropertyBitValue(8)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

DemandDetailObjid

Declaration
[PropertyBitValue(1)]
public int DemandDetailObjid { get; set; }
Property Value
Type | Description
System.Int32 |

EcoHeaderIDNum

Declaration
[PropertyBitValue(2)]
public string EcoHeaderIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(4)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class CreateDepotRepairLaborSetup | fcSDK Documentation

Class CreateDepotRepairLaborSetup

Inheritance
System.Object
CreateDepotRepairLaborSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.DepotRepair
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateDepotRepairLaborSetup

Constructors

CreateDepotRepairLaborSetup(Int32, DateTime, TimeSpan)

Declaration
[ConstructorIndex(0)]
public CreateDepotRepairLaborSetup(int demandDetailObjid, DateTime startDate, TimeSpan duration)
Parameters
Type | Name | Description
System.Int32 | demandDetailObjid |
System.DateTime | startDate |
System.TimeSpan | duration |

Properties

BillTo

Declaration
[PropertyBitValue(32)]
public string BillTo { get; set; }
Property Value
Type | Description
System.String |

CreateDate

Declaration
[PropertyBitValue(512)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

DemandDetailObjid

Declaration
[PropertyBitValue(1)]
public int DemandDetailObjid { get; set; }
Property Value
Type | Description
System.Int32 |

Duration

Declaration
[PropertyBitValue(8)]
public TimeSpan Duration { get; set; }
Property Value
Type | Description
System.TimeSpan |

IsBillable

Declaration
[PropertyBitValue(16)]
public bool IsBillable { get; set; }
Property Value
Type | Description
System.Boolean |

LaborRate

Declaration
[PropertyBitValue(128)]
public double LaborRate { get; set; }
Property Value
Type | Description
System.Double |

LaborType

Declaration
[PropertyBitValue(2)]
public string LaborType { get; set; }
Property Value
Type | Description
System.String |

StartDate

Declaration
[PropertyBitValue(4)]
public DateTime StartDate { get; set; }
Property Value
Type | Description
System.DateTime |

UserName

Declaration
[PropertyBitValue(256)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WorkCenter

Declaration
[PropertyBitValue(64)]
public string WorkCenter { get; set; }
Property Value
Type | Description
System.String |


Class CreateDepotRepairMaterialSetup | fcSDK Documentation

Class CreateDepotRepairMaterialSetup

Inheritance
System.Object
CreateDepotRepairMaterialSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.DepotRepair
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateDepotRepairMaterialSetup

Constructors

CreateDepotRepairMaterialSetup(Int32, Int32, RepairPartDisposition)

Declaration
[ConstructorIndex(0)]
public CreateDepotRepairMaterialSetup(int demandDetailObjid, int partRevisionObjid, RepairPartDisposition disposition)
Parameters
Type | Name | Description
System.Int32 | demandDetailObjid |
System.Int32 | partRevisionObjid |
RepairPartDisposition | disposition |

Properties

BillTo

Declaration
[PropertyBitValue(32)]
public string BillTo { get; set; }
Property Value
Type | Description
System.String |

CreateDate

Declaration
[PropertyBitValue(4096)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

DemandDetailObjid

Declaration
[PropertyBitValue(1)]
public int DemandDetailObjid { get; set; }
Property Value
Type | Description
System.Int32 |

Disposition

Declaration
[PropertyBitValue(128)]
public RepairPartDisposition Disposition { get; set; }
Property Value
Type | Description
RepairPartDisposition |

FailureCode

Declaration
[PropertyBitValue(4)]
public string FailureCode { get; set; }
Property Value
Type | Description
System.String |

IsBillable

Declaration
[PropertyBitValue(16)]
public bool IsBillable { get; set; }
Property Value
Type | Description
System.Boolean |

Notes

Declaration
[PropertyBitValue(512)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

PartRevisionObjid

Declaration
[PropertyBitValue(8)]
public int PartRevisionObjid { get; set; }
Property Value
Type | Description
System.Int32 |

ReferenceDesignator

Declaration
[PropertyBitValue(256)]
public string ReferenceDesignator { get; set; }
Property Value
Type | Description
System.String |

RepairCode

Declaration
[PropertyBitValue(2)]
public string RepairCode { get; set; }
Property Value
Type | Description
System.String |

TransactionID

Declaration
[PropertyBitValue(1024)]
public string TransactionID { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(2048)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WorkCenter

Declaration
[PropertyBitValue(64)]
public string WorkCenter { get; set; }
Property Value
Type | Description
System.String |


Class CreateEcoHeaderSetup | fcSDK Documentation

Class CreateEcoHeaderSetup

Inheritance
System.Object
CreateEcoHeaderSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.DepotRepair
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateEcoHeaderSetup

Constructors

CreateEcoHeaderSetup(DateTime, DateTime)

Declaration
[ConstructorIndex(0)]
public CreateEcoHeaderSetup(DateTime startDate, DateTime endDate)
Parameters
Type | Name | Description
System.DateTime | startDate |
System.DateTime | endDate |

Properties

CreateDate

Declaration
[PropertyBitValue(4)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

Description

Declaration
[PropertyBitValue(128)]
public string Description { get; set; }
Property Value
Type | Description
System.String |

EcoTitle

Declaration
[PropertyBitValue(1)]
public string EcoTitle { get; set; }
Property Value
Type | Description
System.String |

EcoType

Declaration
[PropertyBitValue(2)]
public string EcoType { get; set; }
Property Value
Type | Description
System.String |

EffectType

Declaration
[PropertyBitValue(8)]
public string EffectType { get; set; }
Property Value
Type | Description
System.String |

EndDate

Declaration
[PropertyBitValue(32)]
public DateTime EndDate { get; set; }
Property Value
Type | Description
System.DateTime |

StartDate

Declaration
[PropertyBitValue(16)]
public DateTime StartDate { get; set; }
Property Value
Type | Description
System.DateTime |

Status

Declaration
[PropertyBitValue(64)]
public string Status { get; set; }
Property Value
Type | Description
System.String |


Class CreateEcoItemSetup | fcSDK Documentation

Class CreateEcoItemSetup

Inheritance
System.Object
CreateEcoItemSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.DepotRepair
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateEcoItemSetup

Constructors

CreateEcoItemSetup(EcoItemAppliesTo, Boolean, String, Int32, Int32)

Declaration
[ConstructorIndex(0)]
public CreateEcoItemSetup(EcoItemAppliesTo appliesTo, bool isActive, string ecoHeaderIDNum, int applyPartRevisionObjid, int resultPartRevisionObjid)
Parameters
Type | Name | Description
EcoItemAppliesTo | appliesTo |
System.Boolean | isActive |
System.String | ecoHeaderIDNum |
System.Int32 | applyPartRevisionObjid |
System.Int32 | resultPartRevisionObjid |

Properties

AppliesTo

Declaration
[PropertyBitValue(1)]
public EcoItemAppliesTo AppliesTo { get; set; }
Property Value
Type | Description
EcoItemAppliesTo |

ApplyPartRevisionObjid

Declaration
[PropertyBitValue(8)]
public int ApplyPartRevisionObjid { get; set; }
Property Value
Type | Description
System.Int32 |

EcoHeaderIDNum

Declaration
[PropertyBitValue(4)]
public string EcoHeaderIDNum { get; set; }
Property Value
Type | Description
System.String |

IsActive

Declaration
[PropertyBitValue(2)]
public bool IsActive { get; set; }
Property Value
Type | Description
System.Boolean |

ResultPartRevisionObjid

Declaration
[PropertyBitValue(16)]
public int ResultPartRevisionObjid { get; set; }
Property Value
Type | Description
System.Int32 |


Class CreateEcoLaborDetailSetup | fcSDK Documentation

Class CreateEcoLaborDetailSetup

Inheritance
System.Object
CreateEcoLaborDetailSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.DepotRepair
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateEcoLaborDetailSetup

Constructors

CreateEcoLaborDetailSetup(Boolean, TimeSpan, String)

Declaration
[ConstructorIndex(0)]
public CreateEcoLaborDetailSetup(bool isRequired, TimeSpan elapsedTime, string ecoHeaderIDNum)
Parameters
Type | Name | Description
System.Boolean | isRequired |
System.TimeSpan | elapsedTime |
System.String | ecoHeaderIDNum |

Properties

Description

Declaration
[PropertyBitValue(64)]
public string Description { get; set; }
Property Value
Type | Description
System.String |

EcoHeaderIDNum

Declaration
[PropertyBitValue(128)]
public string EcoHeaderIDNum { get; set; }
Property Value
Type | Description
System.String |

ElapsedTime

Declaration
[PropertyBitValue(16)]
public TimeSpan ElapsedTime { get; set; }
Property Value
Type | Description
System.TimeSpan |

IsRequired

Declaration
[PropertyBitValue(2)]
public bool IsRequired { get; set; }
Property Value
Type | Description
System.Boolean |

LaborType

Declaration
[PropertyBitValue(8)]
public string LaborType { get; set; }
Property Value
Type | Description
System.String |

PartRevisionObjid

Declaration
[PropertyBitValue(256)]
public int PartRevisionObjid { get; set; }
Property Value
Type | Description
System.Int32 |

Status

Declaration
[PropertyBitValue(4)]
public string Status { get; set; }
Property Value
Type | Description
System.String |


Class CreateEcoMaterialDetailSetup | fcSDK Documentation

Class CreateEcoMaterialDetailSetup

Inheritance
System.Object
CreateEcoMaterialDetailSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.DepotRepair
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateEcoMaterialDetailSetup

Constructors

CreateEcoMaterialDetailSetup(Boolean, String, Int32)

Declaration
[ConstructorIndex(0)]
public CreateEcoMaterialDetailSetup(bool isRequired, string ecoHeaderIDNum, int partRevisionObjid)
Parameters
Type | Name | Description
System.Boolean | isRequired |
System.String | ecoHeaderIDNum |
System.Int32 | partRevisionObjid |

Properties

Description

Declaration
[PropertyBitValue(64)]
public string Description { get; set; }
Property Value
Type | Description
System.String |

EcoHeaderIDNum

Declaration
[PropertyBitValue(128)]
public string EcoHeaderIDNum { get; set; }
Property Value
Type | Description
System.String |

IsRequired

Declaration
[PropertyBitValue(2)]
public bool IsRequired { get; set; }
Property Value
Type | Description
System.Boolean |

Location

Declaration
[PropertyBitValue(32)]
public string Location { get; set; }
Property Value
Type | Description
System.String |

PartRevisionObjid

Declaration
[PropertyBitValue(256)]
public int PartRevisionObjid { get; set; }
Property Value
Type | Description
System.Int32 |

Status

Declaration
[PropertyBitValue(4)]
public string Status { get; set; }
Property Value
Type | Description
System.String |


Class DeleteDepotRepairLaborSetup | fcSDK Documentation

Class DeleteDepotRepairLaborSetup

Inheritance
System.Object
DeleteDepotRepairLaborSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.DepotRepair
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class DeleteDepotRepairLaborSetup

Constructors

DeleteDepotRepairLaborSetup(Int32)

Declaration
[ConstructorIndex(0)]
public DeleteDepotRepairLaborSetup(int timeLogObjid)
Parameters
Type | Name | Description
System.Int32 | timeLogObjid |

Properties

CreateDate

Declaration
[PropertyBitValue(2)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

TimeLogObjid

Declaration
[PropertyBitValue(1)]
public int TimeLogObjid { get; set; }
Property Value
Type | Description
System.Int32 |


Class DeleteDepotRepairMaterialSetup | fcSDK Documentation

Class DeleteDepotRepairMaterialSetup

Inheritance
System.Object
DeleteDepotRepairMaterialSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.DepotRepair
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class DeleteDepotRepairMaterialSetup

Constructors

DeleteDepotRepairMaterialSetup(Int32)

Declaration
[ConstructorIndex(0)]
public DeleteDepotRepairMaterialSetup(int materialLogObjid)
Parameters
Type | Name | Description
System.Int32 | materialLogObjid |

Properties

CreateDate

Declaration
[PropertyBitValue(2)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

MaterialLogObjid

Declaration
[PropertyBitValue(1)]
public int MaterialLogObjid { get; set; }
Property Value
Type | Description
System.Int32 |


Class DeleteEcoDetailSetup | fcSDK Documentation

Class DeleteEcoDetailSetup

Inheritance
System.Object
DeleteEcoDetailSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.DepotRepair
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class DeleteEcoDetailSetup

Constructors

DeleteEcoDetailSetup(Int32)

Declaration
[ConstructorIndex(0)]
public DeleteEcoDetailSetup(int ecoDetailObjid)
Parameters
Type | Name | Description
System.Int32 | ecoDetailObjid |

Properties

EcoDetailObjid

Declaration
[PropertyBitValue(1)]
public int EcoDetailObjid { get; set; }
Property Value
Type | Description
System.Int32 |


Class DeleteEcoItemSetup | fcSDK Documentation

Class DeleteEcoItemSetup

Inheritance
System.Object
DeleteEcoItemSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.DepotRepair
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class DeleteEcoItemSetup

Constructors

DeleteEcoItemSetup(Int32)

Declaration
[ConstructorIndex(0)]
public DeleteEcoItemSetup(int ecoItemObjid)
Parameters
Type | Name | Description
System.Int32 | ecoItemObjid |

Properties

EcoItemObjid

Declaration
[PropertyBitValue(1)]
public int EcoItemObjid { get; set; }
Property Value
Type | Description
System.Int32 |


Class DepotRepairToolkit | fcSDK Documentation

Class DepotRepairToolkit

Inheritance
System.Object
ToolkitBase
DepotRepairToolkitBase
DepotRepairToolkit
Inherited Members
DepotRepairToolkitBase._toolkit
DepotRepairToolkitBase.ImpersonatorUsername
ToolkitBase.NOW_DATE
ToolkitBase.CompatSession
ToolkitBase.WithTransaction<T>(Func<IDbTransaction, T>)
ToolkitBase.FCApplication
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.DepotRepair
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class DepotRepairToolkit : DepotRepairToolkitBase

Constructors

DepotRepairToolkit(ClarifySession)

Declaration
public DepotRepairToolkit(ClarifySession session)
Parameters
Type | Name | Description
ClarifySession | session |

DepotRepairToolkit(IFCApplication, IFCSession)

Declaration
public DepotRepairToolkit(IFCApplication application, IFCSession session)
Parameters
Type | Name | Description
IFCApplication | application |
IFCSession | session |

Methods

ApplyEco(ApplyEcoSetup)

Declaration
public ToolkitResult ApplyEco(ApplyEcoSetup setupParam)
Parameters
Type | Name | Description
ApplyEcoSetup | setupParam |
Returns
Type | Description
ToolkitResult |

ApplyEco(ApplyEcoSetup, IDbTransaction)

Declaration
public ToolkitResult ApplyEco(ApplyEcoSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
ApplyEcoSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

ApplyEco(Int32, String)

Declaration
public ToolkitResult ApplyEco(int demandDetailObjid, string ecoHeaderIDNum)
Parameters
Type | Name | Description
System.Int32 | demandDetailObjid |
System.String | ecoHeaderIDNum |
Returns
Type | Description
ToolkitResult |

CreateDepotRepairLabor(CreateDepotRepairLaborSetup)

Declaration
public ToolkitResult CreateDepotRepairLabor(CreateDepotRepairLaborSetup setupParam)
Parameters
Type | Name | Description
CreateDepotRepairLaborSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreateDepotRepairLabor(CreateDepotRepairLaborSetup, IDbTransaction)

Declaration
public ToolkitResult CreateDepotRepairLabor(CreateDepotRepairLaborSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateDepotRepairLaborSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreateDepotRepairLabor(Int32, DateTime, TimeSpan)

Declaration
public ToolkitResult CreateDepotRepairLabor(int demandDetailObjid, DateTime startDate, TimeSpan duration)
Parameters
Type | Name | Description
System.Int32 | demandDetailObjid |
System.DateTime | startDate |
System.TimeSpan | duration |
Returns
Type | Description
ToolkitResult |

CreateDepotRepairMaterial(CreateDepotRepairMaterialSetup)

Declaration
public ToolkitResult CreateDepotRepairMaterial(CreateDepotRepairMaterialSetup setupParam)
Parameters
Type | Name | Description
CreateDepotRepairMaterialSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreateDepotRepairMaterial(CreateDepotRepairMaterialSetup, IDbTransaction)

Declaration
public ToolkitResult CreateDepotRepairMaterial(CreateDepotRepairMaterialSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateDepotRepairMaterialSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreateDepotRepairMaterial(Int32, Int32, RepairPartDisposition)

Declaration
public ToolkitResult CreateDepotRepairMaterial(int demandDetailObjid, int partRevisionObjid, RepairPartDisposition disposition)
Parameters
Type | Name | Description
System.Int32 | demandDetailObjid |
System.Int32 | partRevisionObjid |
RepairPartDisposition | disposition |
Returns
Type | Description
ToolkitResult |

CreateEcoHeader(CreateEcoHeaderSetup)

Declaration
public ToolkitResult CreateEcoHeader(CreateEcoHeaderSetup setupParam)
Parameters
Type | Name | Description
CreateEcoHeaderSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreateEcoHeader(CreateEcoHeaderSetup, IDbTransaction)

Declaration
public ToolkitResult CreateEcoHeader(CreateEcoHeaderSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateEcoHeaderSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreateEcoHeader(DateTime, DateTime)

Declaration
public ToolkitResult CreateEcoHeader(DateTime startDate, DateTime endDate)
Parameters
Type | Name | Description
System.DateTime | startDate |
System.DateTime | endDate |
Returns
Type | Description
ToolkitResult |

CreateEcoItem(CreateEcoItemSetup)

Declaration
public ToolkitResult CreateEcoItem(CreateEcoItemSetup setupParam)
Parameters
Type | Name | Description
CreateEcoItemSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreateEcoItem(CreateEcoItemSetup, IDbTransaction)

Declaration
public ToolkitResult CreateEcoItem(CreateEcoItemSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateEcoItemSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreateEcoItem(EcoItemAppliesTo, Boolean, String, Int32, Int32)

Declaration
public ToolkitResult CreateEcoItem(EcoItemAppliesTo appliesTo, bool isActive, string ecoHeaderIDNum, int applyPartRevisionObjid, int resultPartRevisionObjid)
Parameters
Type | Name | Description
EcoItemAppliesTo | appliesTo |
System.Boolean | isActive |
System.String | ecoHeaderIDNum |
System.Int32 | applyPartRevisionObjid |
System.Int32 | resultPartRevisionObjid |
Returns
Type | Description
ToolkitResult |

CreateEcoLaborDetail(CreateEcoLaborDetailSetup)

Declaration
public ToolkitResult CreateEcoLaborDetail(CreateEcoLaborDetailSetup setupParam)
Parameters
Type | Name | Description
CreateEcoLaborDetailSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreateEcoLaborDetail(CreateEcoLaborDetailSetup, IDbTransaction)

Declaration
public ToolkitResult CreateEcoLaborDetail(CreateEcoLaborDetailSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateEcoLaborDetailSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreateEcoLaborDetail(Boolean, TimeSpan, String)

Declaration
public ToolkitResult CreateEcoLaborDetail(bool isRequired, TimeSpan elapsedTime, string ecoHeaderIDNum)
Parameters
Type | Name | Description
System.Boolean | isRequired |
System.TimeSpan | elapsedTime |
System.String | ecoHeaderIDNum |
Returns
Type | Description
ToolkitResult |

CreateEcoMaterialDetail(CreateEcoMaterialDetailSetup)

Declaration
public ToolkitResult CreateEcoMaterialDetail(CreateEcoMaterialDetailSetup setupParam)
Parameters
Type | Name | Description
CreateEcoMaterialDetailSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreateEcoMaterialDetail(CreateEcoMaterialDetailSetup, IDbTransaction)

Declaration
public ToolkitResult CreateEcoMaterialDetail(CreateEcoMaterialDetailSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateEcoMaterialDetailSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreateEcoMaterialDetail(Boolean, String, Int32)

Declaration
public ToolkitResult CreateEcoMaterialDetail(bool isRequired, string ecoHeaderIDNum, int partRevisionObjid)
Parameters
Type | Name | Description
System.Boolean | isRequired |
System.String | ecoHeaderIDNum |
System.Int32 | partRevisionObjid |
Returns
Type | Description
ToolkitResult |

DeleteDepotRepairLabor(DeleteDepotRepairLaborSetup)

Declaration
public ToolkitResult DeleteDepotRepairLabor(DeleteDepotRepairLaborSetup setupParam)
Parameters
Type | Name | Description
DeleteDepotRepairLaborSetup | setupParam |
Returns
Type | Description
ToolkitResult |

DeleteDepotRepairLabor(DeleteDepotRepairLaborSetup, IDbTransaction)

Declaration
public ToolkitResult DeleteDepotRepairLabor(DeleteDepotRepairLaborSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
DeleteDepotRepairLaborSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

DeleteDepotRepairLabor(Int32)

Declaration
public ToolkitResult DeleteDepotRepairLabor(int timeLogObjid)
Parameters
Type | Name | Description
System.Int32 | timeLogObjid |
Returns
Type | Description
ToolkitResult |

DeleteDepotRepairMaterial(DeleteDepotRepairMaterialSetup)

Declaration
public ToolkitResult DeleteDepotRepairMaterial(DeleteDepotRepairMaterialSetup setupParam)
Parameters
Type | Name | Description
DeleteDepotRepairMaterialSetup | setupParam |
Returns
Type | Description
ToolkitResult |

DeleteDepotRepairMaterial(DeleteDepotRepairMaterialSetup, IDbTransaction)

Declaration
public ToolkitResult DeleteDepotRepairMaterial(DeleteDepotRepairMaterialSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
DeleteDepotRepairMaterialSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

DeleteDepotRepairMaterial(Int32)

Declaration
public ToolkitResult DeleteDepotRepairMaterial(int materialLogObjid)
Parameters
Type | Name | Description
System.Int32 | materialLogObjid |
Returns
Type | Description
ToolkitResult |

DeleteEcoDetail(DeleteEcoDetailSetup)

Declaration
public ToolkitResult DeleteEcoDetail(DeleteEcoDetailSetup setupParam)
Parameters
Type | Name | Description
DeleteEcoDetailSetup | setupParam |
Returns
Type | Description
ToolkitResult |

DeleteEcoDetail(DeleteEcoDetailSetup, IDbTransaction)

Declaration
public ToolkitResult DeleteEcoDetail(DeleteEcoDetailSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
DeleteEcoDetailSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

DeleteEcoDetail(Int32)

Declaration
public ToolkitResult DeleteEcoDetail(int ecoDetailObjid)
Parameters
Type | Name | Description
System.Int32 | ecoDetailObjid |
Returns
Type | Description
ToolkitResult |

DeleteEcoItem(DeleteEcoItemSetup)

Declaration
public ToolkitResult DeleteEcoItem(DeleteEcoItemSetup setupParam)
Parameters
Type | Name | Description
DeleteEcoItemSetup | setupParam |
Returns
Type | Description
ToolkitResult |

DeleteEcoItem(DeleteEcoItemSetup, IDbTransaction)

Declaration
public ToolkitResult DeleteEcoItem(DeleteEcoItemSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
DeleteEcoItemSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

DeleteEcoItem(Int32)

Declaration
public ToolkitResult DeleteEcoItem(int ecoItemObjid)
Parameters
Type | Name | Description
System.Int32 | ecoItemObjid |
Returns
Type | Description
ToolkitResult |

UpdateDepotRepairLabor(UpdateDepotRepairLaborSetup)

Declaration
public ToolkitResult UpdateDepotRepairLabor(UpdateDepotRepairLaborSetup setupParam)
Parameters
Type | Name | Description
UpdateDepotRepairLaborSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdateDepotRepairLabor(UpdateDepotRepairLaborSetup, IDbTransaction)

Declaration
public ToolkitResult UpdateDepotRepairLabor(UpdateDepotRepairLaborSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdateDepotRepairLaborSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UpdateDepotRepairMaterial(UpdateDepotRepairMaterialSetup)

Declaration
public ToolkitResult UpdateDepotRepairMaterial(UpdateDepotRepairMaterialSetup setupParam)
Parameters
Type | Name | Description
UpdateDepotRepairMaterialSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdateDepotRepairMaterial(UpdateDepotRepairMaterialSetup, IDbTransaction)

Declaration
public ToolkitResult UpdateDepotRepairMaterial(UpdateDepotRepairMaterialSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdateDepotRepairMaterialSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UpdateDepotRepairMaterial(Int32, RepairPartDisposition)

Declaration
public ToolkitResult UpdateDepotRepairMaterial(int materialLogObjid, RepairPartDisposition disposition)
Parameters
Type | Name | Description
System.Int32 | materialLogObjid |
RepairPartDisposition | disposition |
Returns
Type | Description
ToolkitResult |

UpdateEcoItem(UpdateEcoItemSetup)

Declaration
public ToolkitResult UpdateEcoItem(UpdateEcoItemSetup setupParam)
Parameters
Type | Name | Description
UpdateEcoItemSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdateEcoItem(UpdateEcoItemSetup, IDbTransaction)

Declaration
public ToolkitResult UpdateEcoItem(UpdateEcoItemSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdateEcoItemSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UpdateEcoItem(Int32, Boolean, String)

Declaration
public ToolkitResult UpdateEcoItem(int ecoItemObjid, bool isActive, string ecoHeaderIDNum)
Parameters
Type | Name | Description
System.Int32 | ecoItemObjid |
System.Boolean | isActive |
System.String | ecoHeaderIDNum |
Returns
Type | Description
ToolkitResult |

UpdateEcoLaborDetail(UpdateEcoLaborDetailSetup)

Declaration
public ToolkitResult UpdateEcoLaborDetail(UpdateEcoLaborDetailSetup setupParam)
Parameters
Type | Name | Description
UpdateEcoLaborDetailSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdateEcoLaborDetail(UpdateEcoLaborDetailSetup, IDbTransaction)

Declaration
public ToolkitResult UpdateEcoLaborDetail(UpdateEcoLaborDetailSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdateEcoLaborDetailSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UpdateEcoMaterialDetail(UpdateEcoMaterialDetailSetup)

Declaration
public ToolkitResult UpdateEcoMaterialDetail(UpdateEcoMaterialDetailSetup setupParam)
Parameters
Type | Name | Description
UpdateEcoMaterialDetailSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdateEcoMaterialDetail(UpdateEcoMaterialDetailSetup, IDbTransaction)

Declaration
public ToolkitResult UpdateEcoMaterialDetail(UpdateEcoMaterialDetailSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdateEcoMaterialDetailSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UpdateEcoMaterialDetail(Int32, Int32)

Declaration
public ToolkitResult UpdateEcoMaterialDetail(int ecoDetailObjid, int partRevisionObjid)
Parameters
Type | Name | Description
System.Int32 | ecoDetailObjid |
System.Int32 | partRevisionObjid |
Returns
Type | Description
ToolkitResult |


Class DepotRepairToolkitBase | fcSDK Documentation

Class DepotRepairToolkitBase

Inheritance
System.Object
ToolkitBase
DepotRepairToolkitBase
DepotRepairToolkit
Inherited Members
ToolkitBase.NOW_DATE
ToolkitBase.CompatSession
ToolkitBase.WithTransaction<T>(Func<IDbTransaction, T>)
ToolkitBase.FCApplication
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.DepotRepair
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public abstract class DepotRepairToolkitBase : ToolkitBase

Constructors

DepotRepairToolkitBase(ClarifySession)

Declaration
public DepotRepairToolkitBase(ClarifySession sess)
Parameters
Type | Name | Description
ClarifySession | sess |

DepotRepairToolkitBase(IFCApplication, IFCSession)

Declaration
public DepotRepairToolkitBase(IFCApplication app, IFCSession sess)
Parameters
Type | Name | Description
IFCApplication | app |
IFCSession | sess |

Fields

_toolkit

Declaration
protected FCDR _toolkit
Field Value
Type | Description
FCDR |

Properties

ImpersonatorUsername

Declaration
public string ImpersonatorUsername { get; set; }
Property Value
Type | Description
System.String |


Class UpdateDepotRepairLaborSetup | fcSDK Documentation

Class UpdateDepotRepairLaborSetup

Inheritance
System.Object
UpdateDepotRepairLaborSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.DepotRepair
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdateDepotRepairLaborSetup

Constructors

UpdateDepotRepairLaborSetup(Int32)

Declaration
[ConstructorIndex(0)]
public UpdateDepotRepairLaborSetup(int timeLogObjid)
Parameters
Type | Name | Description
System.Int32 | timeLogObjid |

Properties

BillTo

Declaration
[PropertyBitValue(32)]
public string BillTo { get; set; }
Property Value
Type | Description
System.String |

CreateDate

Declaration
[PropertyBitValue(512)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

Duration

Declaration
[PropertyBitValue(8)]
public TimeSpan Duration { get; set; }
Property Value
Type | Description
System.TimeSpan |

IsBillable

Declaration
[PropertyBitValue(16)]
public bool IsBillable { get; set; }
Property Value
Type | Description
System.Boolean |

LaborRate

Declaration
[PropertyBitValue(128)]
public double LaborRate { get; set; }
Property Value
Type | Description
System.Double |

LaborType

Declaration
[PropertyBitValue(2)]
public string LaborType { get; set; }
Property Value
Type | Description
System.String |

StartDate

Declaration
[PropertyBitValue(4)]
public DateTime StartDate { get; set; }
Property Value
Type | Description
System.DateTime |

TimeLogObjid

Declaration
[PropertyBitValue(1)]
public int TimeLogObjid { get; set; }
Property Value
Type | Description
System.Int32 |

UserName

Declaration
[PropertyBitValue(256)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WorkCenter

Declaration
[PropertyBitValue(64)]
public string WorkCenter { get; set; }
Property Value
Type | Description
System.String |


Class UpdateDepotRepairMaterialSetup | fcSDK Documentation

Class UpdateDepotRepairMaterialSetup

Inheritance
System.Object
UpdateDepotRepairMaterialSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.DepotRepair
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdateDepotRepairMaterialSetup

Constructors

UpdateDepotRepairMaterialSetup(Int32, RepairPartDisposition)

Declaration
[ConstructorIndex(0)]
public UpdateDepotRepairMaterialSetup(int materialLogObjid, RepairPartDisposition disposition)
Parameters
Type | Name | Description
System.Int32 | materialLogObjid |
RepairPartDisposition | disposition |

Properties

BillTo

Declaration
[PropertyBitValue(32)]
public string BillTo { get; set; }
Property Value
Type | Description
System.String |

CreateDate

Declaration
[PropertyBitValue(4096)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

Disposition

Declaration
[PropertyBitValue(128)]
public RepairPartDisposition Disposition { get; set; }
Property Value
Type | Description
RepairPartDisposition |

FailureCode

Declaration
[PropertyBitValue(4)]
public string FailureCode { get; set; }
Property Value
Type | Description
System.String |

IsBillable

Declaration
[PropertyBitValue(16)]
public bool IsBillable { get; set; }
Property Value
Type | Description
System.Boolean |

MaterialLogObjid

Declaration
[PropertyBitValue(1)]
public int MaterialLogObjid { get; set; }
Property Value
Type | Description
System.Int32 |

Notes

Declaration
[PropertyBitValue(512)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

PartRevisionObjid

Declaration
[PropertyBitValue(8)]
public int PartRevisionObjid { get; set; }
Property Value
Type | Description
System.Int32 |

ReferenceDesignator

Declaration
[PropertyBitValue(256)]
public string ReferenceDesignator { get; set; }
Property Value
Type | Description
System.String |

RepairCode

Declaration
[PropertyBitValue(2)]
public string RepairCode { get; set; }
Property Value
Type | Description
System.String |

TransactionID

Declaration
[PropertyBitValue(1024)]
public string TransactionID { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(2048)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WorkCenter

Declaration
[PropertyBitValue(64)]
public string WorkCenter { get; set; }
Property Value
Type | Description
System.String |


Class UpdateEcoItemSetup | fcSDK Documentation

Class UpdateEcoItemSetup

Inheritance
System.Object
UpdateEcoItemSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.DepotRepair
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdateEcoItemSetup

Constructors

UpdateEcoItemSetup(Int32, Boolean, String)

Declaration
[ConstructorIndex(0)]
public UpdateEcoItemSetup(int ecoItemObjid, bool isActive, string ecoHeaderIDNum)
Parameters
Type | Name | Description
System.Int32 | ecoItemObjid |
System.Boolean | isActive |
System.String | ecoHeaderIDNum |

Properties

AppliesTo

Declaration
[PropertyBitValue(2)]
public EcoItemAppliesTo AppliesTo { get; set; }
Property Value
Type | Description
EcoItemAppliesTo |

ApplyPartRevisionObjid

Declaration
[PropertyBitValue(16)]
public int ApplyPartRevisionObjid { get; set; }
Property Value
Type | Description
System.Int32 |

EcoHeaderIDNum

Declaration
[PropertyBitValue(8)]
public string EcoHeaderIDNum { get; set; }
Property Value
Type | Description
System.String |

EcoItemObjid

Declaration
[PropertyBitValue(1)]
public int EcoItemObjid { get; set; }
Property Value
Type | Description
System.Int32 |

IsActive

Declaration
[PropertyBitValue(4)]
public bool IsActive { get; set; }
Property Value
Type | Description
System.Boolean |

ResultPartRevisionObjid

Declaration
[PropertyBitValue(32)]
public int ResultPartRevisionObjid { get; set; }
Property Value
Type | Description
System.Int32 |


Class UpdateEcoLaborDetailSetup | fcSDK Documentation

Class UpdateEcoLaborDetailSetup

Inheritance
System.Object
UpdateEcoLaborDetailSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.DepotRepair
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdateEcoLaborDetailSetup

Constructors

UpdateEcoLaborDetailSetup(Int32)

Declaration
[ConstructorIndex(0)]
public UpdateEcoLaborDetailSetup(int ecoDetailObjid)
Parameters
Type | Name | Description
System.Int32 | ecoDetailObjid |

Properties

Description

Declaration
[PropertyBitValue(128)]
public string Description { get; set; }
Property Value
Type | Description
System.String |

EcoDetailObjid

Declaration
[PropertyBitValue(1)]
public int EcoDetailObjid { get; set; }
Property Value
Type | Description
System.Int32 |

EcoHeaderIDNum

Declaration
[PropertyBitValue(256)]
public string EcoHeaderIDNum { get; set; }
Property Value
Type | Description
System.String |

ElapsedTime

Declaration
[PropertyBitValue(32)]
public TimeSpan ElapsedTime { get; set; }
Property Value
Type | Description
System.TimeSpan |

IsRequired

Declaration
[PropertyBitValue(4)]
public bool IsRequired { get; set; }
Property Value
Type | Description
System.Boolean |

LaborType

Declaration
[PropertyBitValue(16)]
public string LaborType { get; set; }
Property Value
Type | Description
System.String |

Status

Declaration
[PropertyBitValue(8)]
public string Status { get; set; }
Property Value
Type | Description
System.String |


Class UpdateEcoMaterialDetailSetup | fcSDK Documentation

Class UpdateEcoMaterialDetailSetup

Inheritance
System.Object
UpdateEcoMaterialDetailSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.DepotRepair
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdateEcoMaterialDetailSetup

Constructors

UpdateEcoMaterialDetailSetup(Int32, Int32)

Declaration
[ConstructorIndex(0)]
public UpdateEcoMaterialDetailSetup(int ecoDetailObjid, int partRevisionObjid)
Parameters
Type | Name | Description
System.Int32 | ecoDetailObjid |
System.Int32 | partRevisionObjid |

Properties

Description

Declaration
[PropertyBitValue(128)]
public string Description { get; set; }
Property Value
Type | Description
System.String |

EcoDetailObjid

Declaration
[PropertyBitValue(1)]
public int EcoDetailObjid { get; set; }
Property Value
Type | Description
System.Int32 |

EcoHeaderIDNum

Declaration
[PropertyBitValue(256)]
public string EcoHeaderIDNum { get; set; }
Property Value
Type | Description
System.String |

ElapsedTime

Declaration
[PropertyBitValue(32)]
public TimeSpan ElapsedTime { get; set; }
Property Value
Type | Description
System.TimeSpan |

IsRequired

Declaration
[PropertyBitValue(4)]
public bool IsRequired { get; set; }
Property Value
Type | Description
System.Boolean |

Location

Declaration
[PropertyBitValue(64)]
public string Location { get; set; }
Property Value
Type | Description
System.String |

PartRevisionObjid

Declaration
[PropertyBitValue(512)]
public int PartRevisionObjid { get; set; }
Property Value
Type | Description
System.Int32 |

Status

Declaration
[PropertyBitValue(8)]
public string Status { get; set; }
Property Value
Type | Description
System.String |


Enum EcoItemAppliesTo | fcSDK Documentation

Enum EcoItemAppliesTo

Namespace: FChoice.Toolkits.Clarify
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public enum EcoItemAppliesTo

Fields

Name | Description
EcoHeader |
PartRevision |


Class EmailIn | fcSDK Documentation

Class EmailIn

Inheritance
System.Object
EmailIn
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class EmailIn

Constructors

EmailIn()

Declaration
public EmailIn()


Namespace FChoice.Toolkits.Clarify.FieldOps | fcSDK Documentation

Namespace FChoice.Toolkits.Clarify.FieldOps

Classes

AddServiceInterruptionResult

AddServiceInterruptionSetup

CreateAppointmentResult

CreateAppointmentSetup

CreateExpenseLogResult

CreateExpenseLogSetup

CreateOnsiteLogSetup

CreateTimeLogResult

CreateTimeLogSetup

DeinstallSitePartSetup

DeleteAppointmentSetup

DeleteExpenseLogSetup

DeleteOnsiteLogSetup

DeleteServiceInterruptionSetup

DeleteTimeLogSetup

DispatchFieldEngineerSetup

FieldOpsToolkit

FieldOpsToolkitBase

InstallSitePartSetup

LogPartsUsedConsumeSetup

LogPartsUsedExchangeSetup

LogPartsUsedInstallSetup

LogPartsUsedRemoveSetup

LogPartsUsedUpgradeSetup

MoveSitePartToBinSetup

MoveSitePartToPartSetup

MoveSitePartToSiteSetup

PartTransferResult

PartTransferSetup

ReinstallSitePartSetup

StageInventoryToolkit

UpdateAppointmentSetup

UpdateExpenseLogSetup

UpdateServiceInterruptionSetup

UpdateSitePartSetup

UpdateTimeLogSetup

Back to top © 2022 Dovetail Software, Inc. - All rights reserved.
Clarify, Amdocs, and related products and names are copyright and trademark of Amdocs, Inc.
.NET, Visual Studio.NET, C#, Visual Basic and related products are trademark of Microsoft corporation.


Class AddServiceInterruptionResult | fcSDK Documentation

Class AddServiceInterruptionResult

Inheritance
System.Object
ToolkitResult
AddServiceInterruptionResult
Inherited Members
ToolkitResult._ReturnCode
ToolkitResult._IDNum
ToolkitResult._Objid
ToolkitResult.ReturnCode
ToolkitResult.IDNum
ToolkitResult.Objid
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.FieldOps
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class AddServiceInterruptionResult : ToolkitResult

Constructors

AddServiceInterruptionResult()

Declaration
public AddServiceInterruptionResult()

Properties

ScheduleObjid

Declaration
public int ScheduleObjid { get; set; }
Property Value
Type | Description
System.Int32 |


Class AddServiceInterruptionSetup | fcSDK Documentation

Class AddServiceInterruptionSetup

Inheritance
System.Object
AddServiceInterruptionSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.FieldOps
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class AddServiceInterruptionSetup

Constructors

AddServiceInterruptionSetup(String)

Declaration
[ConstructorIndex(0)]
public AddServiceInterruptionSetup(string caseIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |

Properties

CaseIDNum

Declaration
[PropertyBitValue(1)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

CreateDate

Declaration
[PropertyBitValue(512)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

Description

Declaration
[PropertyBitValue(4)]
public string Description { get; set; }
Property Value
Type | Description
System.String |

Duration

Declaration
[PropertyBitValue(32)]
public TimeSpan Duration { get; set; }
Property Value
Type | Description
System.TimeSpan |

EndDate

Declaration
[PropertyBitValue(16)]
public DateTime EndDate { get; set; }
Property Value
Type | Description
System.DateTime |

ServiceClass

Declaration
[PropertyBitValue(64)]
public string ServiceClass { get; set; }
Property Value
Type | Description
System.String |

ServiceType

Declaration
[PropertyBitValue(128)]
public string ServiceType { get; set; }
Property Value
Type | Description
System.String |

SitePartObjid

Declaration
[PropertyBitValue(2)]
public int SitePartObjid { get; set; }
Property Value
Type | Description
System.Int32 |

StartDate

Declaration
[PropertyBitValue(8)]
public DateTime StartDate { get; set; }
Property Value
Type | Description
System.DateTime |

UserName

Declaration
[PropertyBitValue(256)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class CreateAppointmentResult | fcSDK Documentation

Class CreateAppointmentResult

Inheritance
System.Object
ToolkitResult
CreateAppointmentResult
Inherited Members
ToolkitResult._ReturnCode
ToolkitResult._IDNum
ToolkitResult._Objid
ToolkitResult.ReturnCode
ToolkitResult.IDNum
ToolkitResult.Objid
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.FieldOps
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateAppointmentResult : ToolkitResult

Constructors

CreateAppointmentResult()

Declaration
public CreateAppointmentResult()

Properties

ScheduleObjid

Declaration
public int ScheduleObjid { get; set; }
Property Value
Type | Description
System.Int32 |


Class CreateAppointmentSetup | fcSDK Documentation

Class CreateAppointmentSetup

Inheritance
System.Object
CreateAppointmentSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.FieldOps
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateAppointmentSetup

Constructors

CreateAppointmentSetup(DateTime, DateTime)

Declaration
[ConstructorIndex(0)]
public CreateAppointmentSetup(DateTime startDate, DateTime endDate)
Parameters
Type | Name | Description
System.DateTime | startDate |
System.DateTime | endDate |

CreateAppointmentSetup(DateTime, TimeSpan)

Declaration
[ConstructorIndex(1)]
public CreateAppointmentSetup(DateTime startDate, TimeSpan duration)
Parameters
Type | Name | Description
System.DateTime | startDate |
System.TimeSpan | duration |

CreateAppointmentSetup(TimeSpan, DateTime)

Declaration
[ConstructorIndex(2)]
public CreateAppointmentSetup(TimeSpan duration, DateTime endDate)
Parameters
Type | Name | Description
System.TimeSpan | duration |
System.DateTime | endDate |

Properties

AppointmentClass

Declaration
[PropertyBitValue(256)]
public string AppointmentClass { get; set; }
Property Value
Type | Description
System.String |

AppointmentType

Declaration
[PropertyBitValue(512)]
public string AppointmentType { get; set; }
Property Value
Type | Description
System.String |

CaseIDNum

Declaration
[PropertyBitValue(1024)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

CellText

Declaration
[PropertyBitValue(16)]
public string CellText { get; set; }
Property Value
Type | Description
System.String |

CreateDate

Declaration
[PropertyBitValue(4096)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

Description

Declaration
[PropertyBitValue(1)]
public string Description { get; set; }
Property Value
Type | Description
System.String |

Duration

Declaration
[PropertyBitValue(8)]
public TimeSpan Duration { get; set; }
Property Value
Type | Description
System.TimeSpan |

EmployeeFirstName

Declaration
[PropertyBitValue(32)]
public string EmployeeFirstName { get; set; }
Property Value
Type | Description
System.String |

EmployeeLastName

Declaration
[PropertyBitValue(64)]
public string EmployeeLastName { get; set; }
Property Value
Type | Description
System.String |

EndDate

Declaration
[PropertyBitValue(4)]
public DateTime EndDate { get; set; }
Property Value
Type | Description
System.DateTime |

SitePartObjid

Declaration
[PropertyBitValue(128)]
public int SitePartObjid { get; set; }
Property Value
Type | Description
System.Int32 |

StartDate

Declaration
[PropertyBitValue(2)]
public DateTime StartDate { get; set; }
Property Value
Type | Description
System.DateTime |

UserName

Declaration
[PropertyBitValue(2048)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class CreateExpenseLogResult | fcSDK Documentation

Class CreateExpenseLogResult

Inheritance
System.Object
ToolkitResult
CreateExpenseLogResult
Inherited Members
ToolkitResult._ReturnCode
ToolkitResult._IDNum
ToolkitResult._Objid
ToolkitResult.ReturnCode
ToolkitResult.IDNum
ToolkitResult.Objid
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.FieldOps
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateExpenseLogResult : ToolkitResult

Constructors

CreateExpenseLogResult()

Declaration
public CreateExpenseLogResult()

Properties

OnsiteLogObjid

Declaration
public int OnsiteLogObjid { get; set; }
Property Value
Type | Description
System.Int32 |


Class CreateExpenseLogSetup | fcSDK Documentation

Class CreateExpenseLogSetup

Inheritance
System.Object
CreateExpenseLogSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.FieldOps
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateExpenseLogSetup

Constructors

CreateExpenseLogSetup(Int32)

Declaration
[ConstructorIndex(0)]
public CreateExpenseLogSetup(int onsiteLogObjid)
Parameters
Type | Name | Description
System.Int32 | onsiteLogObjid |

Properties

BillTo

Declaration
[PropertyBitValue(1024)]
public string BillTo { get; set; }
Property Value
Type | Description
System.String |

CaseIDNum

Declaration
[PropertyBitValue(2)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

CreateDate

Declaration
[PropertyBitValue(4)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

ExpenseType

Declaration
[PropertyBitValue(64)]
public string ExpenseType { get; set; }
Property Value
Type | Description
System.String |

IsBillable

Declaration
[PropertyBitValue(512)]
public bool IsBillable { get; set; }
Property Value
Type | Description
System.Boolean |

Notes

Declaration
[PropertyBitValue(8)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

OnsiteLogObjid

Declaration
[PropertyBitValue(1)]
public int OnsiteLogObjid { get; set; }
Property Value
Type | Description
System.Int32 |

PerformedByUserName

Declaration
[PropertyBitValue(16)]
public string PerformedByUserName { get; set; }
Property Value
Type | Description
System.String |

Quantity

Declaration
[PropertyBitValue(128)]
public double Quantity { get; set; }
Property Value
Type | Description
System.Double |

Rate

Declaration
[PropertyBitValue(256)]
public double Rate { get; set; }
Property Value
Type | Description
System.Double |

Resolution

Declaration
[PropertyBitValue(2048)]
public string Resolution { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(32)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class CreateOnsiteLogSetup | fcSDK Documentation

Class CreateOnsiteLogSetup

Inheritance
System.Object
CreateOnsiteLogSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.FieldOps
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateOnsiteLogSetup

Constructors

CreateOnsiteLogSetup(CaseObjectType, String)

Declaration
[ConstructorIndex(0)]
public CreateOnsiteLogSetup(CaseObjectType objectType, string objectIDNum)
Parameters
Type | Name | Description
CaseObjectType | objectType |
System.String | objectIDNum |

Properties

CreateDate

Declaration
[PropertyBitValue(4)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

LastModifiedDate

Declaration
[PropertyBitValue(8)]
public DateTime LastModifiedDate { get; set; }
Property Value
Type | Description
System.DateTime |

Notes

Declaration
[PropertyBitValue(16)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

ObjectIDNum

Declaration
[PropertyBitValue(2)]
public string ObjectIDNum { get; set; }
Property Value
Type | Description
System.String |

ObjectType

Declaration
[PropertyBitValue(1)]
public CaseObjectType ObjectType { get; set; }
Property Value
Type | Description
CaseObjectType |

PerformedByUserName

Declaration
[PropertyBitValue(128)]
public string PerformedByUserName { get; set; }
Property Value
Type | Description
System.String |

Resolution

Declaration
[PropertyBitValue(32)]
public string Resolution { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(64)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class CreateTimeLogResult | fcSDK Documentation

Class CreateTimeLogResult

Inheritance
System.Object
ToolkitResult
CreateTimeLogResult
Inherited Members
ToolkitResult._ReturnCode
ToolkitResult._IDNum
ToolkitResult._Objid
ToolkitResult.ReturnCode
ToolkitResult.IDNum
ToolkitResult.Objid
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.FieldOps
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateTimeLogResult : ToolkitResult

Constructors

CreateTimeLogResult()

Declaration
public CreateTimeLogResult()

Properties

OnsiteLogObjid

Declaration
public int OnsiteLogObjid { get; set; }
Property Value
Type | Description
System.Int32 |


Class CreateTimeLogSetup | fcSDK Documentation

Class CreateTimeLogSetup

Inheritance
System.Object
CreateTimeLogSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.FieldOps
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateTimeLogSetup

Constructors

CreateTimeLogSetup(Int32, DateTime, TimeSpan)

Declaration
[ConstructorIndex(0)]
public CreateTimeLogSetup(int onsiteLogObjid, DateTime startDate, TimeSpan duration)
Parameters
Type | Name | Description
System.Int32 | onsiteLogObjid |
System.DateTime | startDate |
System.TimeSpan | duration |

Properties

BillTo

Declaration
[PropertyBitValue(1024)]
public string BillTo { get; set; }
Property Value
Type | Description
System.String |

CaseIDNum

Declaration
[PropertyBitValue(2)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

CreateDate

Declaration
[PropertyBitValue(4)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

Duration

Declaration
[PropertyBitValue(256)]
public TimeSpan Duration { get; set; }
Property Value
Type | Description
System.TimeSpan |

IsBillable

Declaration
[PropertyBitValue(512)]
public bool IsBillable { get; set; }
Property Value
Type | Description
System.Boolean |

Notes

Declaration
[PropertyBitValue(8)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

OnsiteLogObjid

Declaration
[PropertyBitValue(1)]
public int OnsiteLogObjid { get; set; }
Property Value
Type | Description
System.Int32 |

PerformedByUserName

Declaration
[PropertyBitValue(16)]
public string PerformedByUserName { get; set; }
Property Value
Type | Description
System.String |

Resolution

Declaration
[PropertyBitValue(4096)]
public string Resolution { get; set; }
Property Value
Type | Description
System.String |

StartDate

Declaration
[PropertyBitValue(128)]
public DateTime StartDate { get; set; }
Property Value
Type | Description
System.DateTime |

TimeType

Declaration
[PropertyBitValue(64)]
public string TimeType { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(32)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WorkCenter

Declaration
[PropertyBitValue(2048)]
public string WorkCenter { get; set; }
Property Value
Type | Description
System.String |


Class DeinstallSitePartSetup | fcSDK Documentation

Class DeinstallSitePartSetup

Inheritance
System.Object
DeinstallSitePartSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.FieldOps
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class DeinstallSitePartSetup

Constructors

DeinstallSitePartSetup(Int32)

Declaration
[ConstructorIndex(0)]
public DeinstallSitePartSetup(int sitePartObjid)
Parameters
Type | Name | Description
System.Int32 | sitePartObjid |

Properties

DeinstallDate

Declaration
[PropertyBitValue(4)]
public DateTime DeinstallDate { get; set; }
Property Value
Type | Description
System.DateTime |

SitePartObjid

Declaration
[PropertyBitValue(1)]
public int SitePartObjid { get; set; }
Property Value
Type | Description
System.Int32 |

UseRemove

Declaration
[PropertyBitValue(8)]
public bool UseRemove { get; set; }
Property Value
Type | Description
System.Boolean |

UserName

Declaration
[PropertyBitValue(2)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class DeleteAppointmentSetup | fcSDK Documentation

Class DeleteAppointmentSetup

Inheritance
System.Object
DeleteAppointmentSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.FieldOps
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class DeleteAppointmentSetup

Constructors

DeleteAppointmentSetup(Int32)

Declaration
[ConstructorIndex(0)]
public DeleteAppointmentSetup(int appointmentObjid)
Parameters
Type | Name | Description
System.Int32 | appointmentObjid |

Properties

AppointmentObjid

Declaration
[PropertyBitValue(1)]
public int AppointmentObjid { get; set; }
Property Value
Type | Description
System.Int32 |

CreateDate

Declaration
[PropertyBitValue(4)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

UserName

Declaration
[PropertyBitValue(2)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class DeleteExpenseLogSetup | fcSDK Documentation

Class DeleteExpenseLogSetup

Inheritance
System.Object
DeleteExpenseLogSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.FieldOps
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class DeleteExpenseLogSetup

Constructors

DeleteExpenseLogSetup(Int32)

Declaration
[ConstructorIndex(0)]
public DeleteExpenseLogSetup(int expenseLogObjid)
Parameters
Type | Name | Description
System.Int32 | expenseLogObjid |

Properties

ExpenseLogObjid

Declaration
[PropertyBitValue(1)]
public int ExpenseLogObjid { get; set; }
Property Value
Type | Description
System.Int32 |

LastModifiedDate

Declaration
[PropertyBitValue(2)]
public DateTime LastModifiedDate { get; set; }
Property Value
Type | Description
System.DateTime |

UserName

Declaration
[PropertyBitValue(4)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class DeleteOnsiteLogSetup | fcSDK Documentation

Class DeleteOnsiteLogSetup

Inheritance
System.Object
DeleteOnsiteLogSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.FieldOps
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class DeleteOnsiteLogSetup

Constructors

DeleteOnsiteLogSetup(Int32)

Declaration
[ConstructorIndex(0)]
public DeleteOnsiteLogSetup(int onsiteLogObjid)
Parameters
Type | Name | Description
System.Int32 | onsiteLogObjid |

Properties

NoteDate

Declaration
[PropertyBitValue(2)]
public DateTime NoteDate { get; set; }
Property Value
Type | Description
System.DateTime |

OnsiteLogObjid

Declaration
[PropertyBitValue(1)]
public int OnsiteLogObjid { get; set; }
Property Value
Type | Description
System.Int32 |

UserName

Declaration
[PropertyBitValue(4)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class DeleteServiceInterruptionSetup | fcSDK Documentation

Class DeleteServiceInterruptionSetup

Inheritance
System.Object
DeleteServiceInterruptionSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.FieldOps
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class DeleteServiceInterruptionSetup

Constructors

DeleteServiceInterruptionSetup(Int32)

Declaration
[ConstructorIndex(0)]
public DeleteServiceInterruptionSetup(int appointmentObjid)
Parameters
Type | Name | Description
System.Int32 | appointmentObjid |

Properties

AppointmentObjid

Declaration
[PropertyBitValue(1)]
public int AppointmentObjid { get; set; }
Property Value
Type | Description
System.Int32 |

CreateDate

Declaration
[PropertyBitValue(4)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

UserName

Declaration
[PropertyBitValue(2)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class DeleteTimeLogSetup | fcSDK Documentation

Class DeleteTimeLogSetup

Inheritance
System.Object
DeleteTimeLogSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.FieldOps
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class DeleteTimeLogSetup

Constructors

DeleteTimeLogSetup(Int32)

Declaration
[ConstructorIndex(0)]
public DeleteTimeLogSetup(int timeLogObjid)
Parameters
Type | Name | Description
System.Int32 | timeLogObjid |

Properties

LastModifiedDate

Declaration
[PropertyBitValue(2)]
public DateTime LastModifiedDate { get; set; }
Property Value
Type | Description
System.DateTime |

TimeLogObjid

Declaration
[PropertyBitValue(1)]
public int TimeLogObjid { get; set; }
Property Value
Type | Description
System.Int32 |

UserName

Declaration
[PropertyBitValue(4)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class DispatchFieldEngineerSetup | fcSDK Documentation

Class DispatchFieldEngineerSetup

Inheritance
System.Object
DispatchFieldEngineerSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.FieldOps
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class DispatchFieldEngineerSetup

Constructors

DispatchFieldEngineerSetup(String)

Declaration
[ConstructorIndex(0)]
public DispatchFieldEngineerSetup(string caseIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |

Properties

Address1

Declaration
[PropertyBitValue(512)]
public string Address1 { get; set; }
Property Value
Type | Description
System.String |

Address2

Declaration
[PropertyBitValue(1024)]
public string Address2 { get; set; }
Property Value
Type | Description
System.String |

AlternatePhone

Declaration
[PropertyBitValue(32768)]
public string AlternatePhone { get; set; }
Property Value
Type | Description
System.String |

AppointmentConfirmed

Declaration
[PropertyBitValue(2097152)]
public int AppointmentConfirmed { get; set; }
Property Value
Type | Description
System.Int32 |

AppointmentDate

Declaration
[PropertyBitValue(16)]
public DateTime AppointmentDate { get; set; }
Property Value
Type | Description
System.DateTime |

CaseIDNum

Declaration
[PropertyBitValue(1)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

CellText

Declaration
[PropertyBitValue(4194304)]
public string CellText { get; set; }
Property Value
Type | Description
System.String |

City

Declaration
[PropertyBitValue(2048)]
public string City { get; set; }
Property Value
Type | Description
System.String |

ContactFirstName

Declaration
[PropertyBitValue(128)]
public string ContactFirstName { get; set; }
Property Value
Type | Description
System.String |

ContactLastName

Declaration
[PropertyBitValue(256)]
public string ContactLastName { get; set; }
Property Value
Type | Description
System.String |

Description

Declaration
[PropertyBitValue(64)]
public string Description { get; set; }
Property Value
Type | Description
System.String |

DispatchDate

Declaration
[PropertyBitValue(4)]
public DateTime DispatchDate { get; set; }
Property Value
Type | Description
System.DateTime |

Duration

Declaration
[PropertyBitValue(32)]
public TimeSpan Duration { get; set; }
Property Value
Type | Description
System.TimeSpan |

GenerateTimeBombs

Declaration
[PropertyBitValue(33554432)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

MainPhone

Declaration
[PropertyBitValue(16384)]
public string MainPhone { get; set; }
Property Value
Type | Description
System.String |

Notes

Declaration
[PropertyBitValue(524288)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

PaymentMethod

Declaration
[PropertyBitValue(131072)]
public string PaymentMethod { get; set; }
Property Value
Type | Description
System.String |

Proxy

Declaration
[PropertyBitValue(8388608)]
public string Proxy { get; set; }
Property Value
Type | Description
System.String |

ReferenceNumber

Declaration
[PropertyBitValue(262144)]
public string ReferenceNumber { get; set; }
Property Value
Type | Description
System.String |

RequestedETADate

Declaration
[PropertyBitValue(1048576)]
public DateTime RequestedETADate { get; set; }
Property Value
Type | Description
System.DateTime |

SiteIDNum

Declaration
[PropertyBitValue(65536)]
public string SiteIDNum { get; set; }
Property Value
Type | Description
System.String |

State

Declaration
[PropertyBitValue(4096)]
public string State { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(2)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WorkOrder

Declaration
[PropertyBitValue(8)]
public string WorkOrder { get; set; }
Property Value
Type | Description
System.String |

ZipCode

Declaration
[PropertyBitValue(8192)]
public string ZipCode { get; set; }
Property Value
Type | Description
System.String |


Class FieldOpsToolkit | fcSDK Documentation

Class FieldOpsToolkit

Inheritance
System.Object
ToolkitBase
FieldOpsToolkitBase
FieldOpsToolkit
Inherited Members
FieldOpsToolkitBase._toolkit
FieldOpsToolkitBase.ImpersonatorUsername
ToolkitBase.NOW_DATE
ToolkitBase.CompatSession
ToolkitBase.WithTransaction<T>(Func<IDbTransaction, T>)
ToolkitBase.FCApplication
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.FieldOps
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class FieldOpsToolkit : FieldOpsToolkitBase

Constructors

FieldOpsToolkit(ClarifySession)

Declaration
public FieldOpsToolkit(ClarifySession session)
Parameters
Type | Name | Description
ClarifySession | session |

FieldOpsToolkit(IFCApplication, IFCSession)

Declaration
public FieldOpsToolkit(IFCApplication application, IFCSession session)
Parameters
Type | Name | Description
IFCApplication | application |
IFCSession | session |

Methods

AddServiceInterruption(AddServiceInterruptionSetup)

Declaration
public AddServiceInterruptionResult AddServiceInterruption(AddServiceInterruptionSetup setupParam)
Parameters
Type | Name | Description
AddServiceInterruptionSetup | setupParam |
Returns
Type | Description
AddServiceInterruptionResult |

AddServiceInterruption(AddServiceInterruptionSetup, IDbTransaction)

Declaration
public AddServiceInterruptionResult AddServiceInterruption(AddServiceInterruptionSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
AddServiceInterruptionSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
AddServiceInterruptionResult |

AddServiceInterruption(String)

Declaration
public AddServiceInterruptionResult AddServiceInterruption(string caseIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |
Returns
Type | Description
AddServiceInterruptionResult |

CreateAppointment(CreateAppointmentSetup)

Declaration
public CreateAppointmentResult CreateAppointment(CreateAppointmentSetup setupParam)
Parameters
Type | Name | Description
CreateAppointmentSetup | setupParam |
Returns
Type | Description
CreateAppointmentResult |

CreateAppointment(CreateAppointmentSetup, IDbTransaction)

Declaration
public CreateAppointmentResult CreateAppointment(CreateAppointmentSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateAppointmentSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
CreateAppointmentResult |

CreateAppointment(DateTime, DateTime)

Declaration
public CreateAppointmentResult CreateAppointment(DateTime startDate, DateTime endDate)
Parameters
Type | Name | Description
System.DateTime | startDate |
System.DateTime | endDate |
Returns
Type | Description
CreateAppointmentResult |

CreateAppointment(DateTime, TimeSpan)

Declaration
public CreateAppointmentResult CreateAppointment(DateTime startDate, TimeSpan duration)
Parameters
Type | Name | Description
System.DateTime | startDate |
System.TimeSpan | duration |
Returns
Type | Description
CreateAppointmentResult |

CreateAppointment(TimeSpan, DateTime)

Declaration
public CreateAppointmentResult CreateAppointment(TimeSpan duration, DateTime endDate)
Parameters
Type | Name | Description
System.TimeSpan | duration |
System.DateTime | endDate |
Returns
Type | Description
CreateAppointmentResult |

CreateExpenseLog(CreateExpenseLogSetup)

Declaration
public CreateExpenseLogResult CreateExpenseLog(CreateExpenseLogSetup setupParam)
Parameters
Type | Name | Description
CreateExpenseLogSetup | setupParam |
Returns
Type | Description
CreateExpenseLogResult |

CreateExpenseLog(CreateExpenseLogSetup, IDbTransaction)

Declaration
public CreateExpenseLogResult CreateExpenseLog(CreateExpenseLogSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateExpenseLogSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
CreateExpenseLogResult |

CreateExpenseLog(Int32)

Declaration
public CreateExpenseLogResult CreateExpenseLog(int onsiteLogObjid)
Parameters
Type | Name | Description
System.Int32 | onsiteLogObjid |
Returns
Type | Description
CreateExpenseLogResult |

CreateOnsiteLog(CaseObjectType, String)

Declaration
public ToolkitResult CreateOnsiteLog(CaseObjectType objectType, string objectIDNum)
Parameters
Type | Name | Description
CaseObjectType | objectType |
System.String | objectIDNum |
Returns
Type | Description
ToolkitResult |

CreateOnsiteLog(CreateOnsiteLogSetup)

Declaration
public ToolkitResult CreateOnsiteLog(CreateOnsiteLogSetup setupParam)
Parameters
Type | Name | Description
CreateOnsiteLogSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreateOnsiteLog(CreateOnsiteLogSetup, IDbTransaction)

Declaration
public ToolkitResult CreateOnsiteLog(CreateOnsiteLogSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateOnsiteLogSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreateTimeLog(CreateTimeLogSetup)

Declaration
public CreateTimeLogResult CreateTimeLog(CreateTimeLogSetup setupParam)
Parameters
Type | Name | Description
CreateTimeLogSetup | setupParam |
Returns
Type | Description
CreateTimeLogResult |

CreateTimeLog(CreateTimeLogSetup, IDbTransaction)

Declaration
public CreateTimeLogResult CreateTimeLog(CreateTimeLogSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateTimeLogSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
CreateTimeLogResult |

CreateTimeLog(Int32, DateTime, TimeSpan)

Declaration
public CreateTimeLogResult CreateTimeLog(int onsiteLogObjid, DateTime startDate, TimeSpan duration)
Parameters
Type | Name | Description
System.Int32 | onsiteLogObjid |
System.DateTime | startDate |
System.TimeSpan | duration |
Returns
Type | Description
CreateTimeLogResult |

DeinstallSitePart(DeinstallSitePartSetup)

Declaration
public ToolkitResult DeinstallSitePart(DeinstallSitePartSetup setupParam)
Parameters
Type | Name | Description
DeinstallSitePartSetup | setupParam |
Returns
Type | Description
ToolkitResult |

DeinstallSitePart(DeinstallSitePartSetup, IDbTransaction)

Declaration
public ToolkitResult DeinstallSitePart(DeinstallSitePartSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
DeinstallSitePartSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

DeinstallSitePart(Int32)

Declaration
public ToolkitResult DeinstallSitePart(int sitePartObjid)
Parameters
Type | Name | Description
System.Int32 | sitePartObjid |
Returns
Type | Description
ToolkitResult |

DeleteAppointment(DeleteAppointmentSetup)

Declaration
public ToolkitResult DeleteAppointment(DeleteAppointmentSetup setupParam)
Parameters
Type | Name | Description
DeleteAppointmentSetup | setupParam |
Returns
Type | Description
ToolkitResult |

DeleteAppointment(DeleteAppointmentSetup, IDbTransaction)

Declaration
public ToolkitResult DeleteAppointment(DeleteAppointmentSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
DeleteAppointmentSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

DeleteAppointment(Int32)

Declaration
public ToolkitResult DeleteAppointment(int appointmentObjid)
Parameters
Type | Name | Description
System.Int32 | appointmentObjid |
Returns
Type | Description
ToolkitResult |

DeleteExpenseLog(DeleteExpenseLogSetup)

Declaration
public ToolkitResult DeleteExpenseLog(DeleteExpenseLogSetup setupParam)
Parameters
Type | Name | Description
DeleteExpenseLogSetup | setupParam |
Returns
Type | Description
ToolkitResult |

DeleteExpenseLog(DeleteExpenseLogSetup, IDbTransaction)

Declaration
public ToolkitResult DeleteExpenseLog(DeleteExpenseLogSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
DeleteExpenseLogSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

DeleteExpenseLog(Int32)

Declaration
public ToolkitResult DeleteExpenseLog(int expenseLogObjid)
Parameters
Type | Name | Description
System.Int32 | expenseLogObjid |
Returns
Type | Description
ToolkitResult |

DeleteOnsiteLog(DeleteOnsiteLogSetup)

Declaration
public ToolkitResult DeleteOnsiteLog(DeleteOnsiteLogSetup setupParam)
Parameters
Type | Name | Description
DeleteOnsiteLogSetup | setupParam |
Returns
Type | Description
ToolkitResult |

DeleteOnsiteLog(DeleteOnsiteLogSetup, IDbTransaction)

Declaration
public ToolkitResult DeleteOnsiteLog(DeleteOnsiteLogSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
DeleteOnsiteLogSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

DeleteOnsiteLog(Int32)

Declaration
public ToolkitResult DeleteOnsiteLog(int onsiteLogObjid)
Parameters
Type | Name | Description
System.Int32 | onsiteLogObjid |
Returns
Type | Description
ToolkitResult |

DeleteServiceInterruption(DeleteServiceInterruptionSetup)

Declaration
public ToolkitResult DeleteServiceInterruption(DeleteServiceInterruptionSetup setupParam)
Parameters
Type | Name | Description
DeleteServiceInterruptionSetup | setupParam |
Returns
Type | Description
ToolkitResult |

DeleteServiceInterruption(DeleteServiceInterruptionSetup, IDbTransaction)

Declaration
public ToolkitResult DeleteServiceInterruption(DeleteServiceInterruptionSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
DeleteServiceInterruptionSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

DeleteServiceInterruption(Int32)

Declaration
public ToolkitResult DeleteServiceInterruption(int appointmentObjid)
Parameters
Type | Name | Description
System.Int32 | appointmentObjid |
Returns
Type | Description
ToolkitResult |

DeleteTimeLog(DeleteTimeLogSetup)

Declaration
public ToolkitResult DeleteTimeLog(DeleteTimeLogSetup setupParam)
Parameters
Type | Name | Description
DeleteTimeLogSetup | setupParam |
Returns
Type | Description
ToolkitResult |

DeleteTimeLog(DeleteTimeLogSetup, IDbTransaction)

Declaration
public ToolkitResult DeleteTimeLog(DeleteTimeLogSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
DeleteTimeLogSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

DeleteTimeLog(Int32)

Declaration
public ToolkitResult DeleteTimeLog(int timeLogObjid)
Parameters
Type | Name | Description
System.Int32 | timeLogObjid |
Returns
Type | Description
ToolkitResult |

DispatchFieldEngineer(DispatchFieldEngineerSetup)

Declaration
public ToolkitResult DispatchFieldEngineer(DispatchFieldEngineerSetup setupParam)
Parameters
Type | Name | Description
DispatchFieldEngineerSetup | setupParam |
Returns
Type | Description
ToolkitResult |

DispatchFieldEngineer(DispatchFieldEngineerSetup, IDbTransaction)

Declaration
public ToolkitResult DispatchFieldEngineer(DispatchFieldEngineerSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
DispatchFieldEngineerSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

DispatchFieldEngineer(String)

Declaration
public ToolkitResult DispatchFieldEngineer(string caseIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |
Returns
Type | Description
ToolkitResult |

InstallSitePart(InstallSitePartSetup)

Declaration
public ToolkitResult InstallSitePart(InstallSitePartSetup setupParam)
Parameters
Type | Name | Description
InstallSitePartSetup | setupParam |
Returns
Type | Description
ToolkitResult |

InstallSitePart(InstallSitePartSetup, IDbTransaction)

Declaration
public ToolkitResult InstallSitePart(InstallSitePartSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
InstallSitePartSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

InstallSitePart(String, String, String, String, Int32)

Declaration
public ToolkitResult InstallSitePart(string siteIDNum, string partNumber, string partrevision, string partdomain, int quantity)
Parameters
Type | Name | Description
System.String | siteIDNum |
System.String | partNumber |
System.String | partrevision |
System.String | partdomain |
System.Int32 | quantity |
Returns
Type | Description
ToolkitResult |

InstallSitePart(String, String, String, String, String)

Declaration
public ToolkitResult InstallSitePart(string siteIDNum, string partNumber, string partrevision, string partdomain, string serialNumber)
Parameters
Type | Name | Description
System.String | siteIDNum |
System.String | partNumber |
System.String | partrevision |
System.String | partdomain |
System.String | serialNumber |
Returns
Type | Description
ToolkitResult |

LogPartsUsedConsume(LogPartsUsedConsumeSetup)

Declaration
public ToolkitResult LogPartsUsedConsume(LogPartsUsedConsumeSetup setupParam)
Parameters
Type | Name | Description
LogPartsUsedConsumeSetup | setupParam |
Returns
Type | Description
ToolkitResult |

LogPartsUsedConsume(LogPartsUsedConsumeSetup, IDbTransaction)

Declaration
public ToolkitResult LogPartsUsedConsume(LogPartsUsedConsumeSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
LogPartsUsedConsumeSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

LogPartsUsedConsume(String, String, String, String, Int32)

Declaration
public ToolkitResult LogPartsUsedConsume(string partRequestDetailIDNum, string installPartNumber, string installPartRevision, string installPartDomain, int installQuantity)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String | installPartNumber |
System.String | installPartRevision |
System.String | installPartDomain |
System.Int32 | installQuantity |
Returns
Type | Description
ToolkitResult |

LogPartsUsedConsume(String, String, String, String, String)

Declaration
public ToolkitResult LogPartsUsedConsume(string partRequestDetailIDNum, string installPartNumber, string installPartRevision, string installPartDomain, string installSerialNumber)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String | installPartNumber |
System.String | installPartRevision |
System.String | installPartDomain |
System.String | installSerialNumber |
Returns
Type | Description
ToolkitResult |

LogPartsUsedConsume(String, String, String, String, String, Int32)

Declaration
public ToolkitResult LogPartsUsedConsume(string partRequestDetailIDNum, string caseIDNum, string installPartNumber, string installPartRevision, string installPartDomain, int installQuantity)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String | caseIDNum |
System.String | installPartNumber |
System.String | installPartRevision |
System.String | installPartDomain |
System.Int32 | installQuantity |
Returns
Type | Description
ToolkitResult |

LogPartsUsedConsume(String, String, String, String, String, String)

Declaration
public ToolkitResult LogPartsUsedConsume(string partRequestDetailIDNum, string caseIDNum, string installPartNumber, string installPartRevision, string installPartDomain, string installSerialNumber)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String | caseIDNum |
System.String | installPartNumber |
System.String | installPartRevision |
System.String | installPartDomain |
System.String | installSerialNumber |
Returns
Type | Description
ToolkitResult |

LogPartsUsedExchange(LogPartsUsedExchangeSetup)

Declaration
public ToolkitResult LogPartsUsedExchange(LogPartsUsedExchangeSetup setupParam)
Parameters
Type | Name | Description
LogPartsUsedExchangeSetup | setupParam |
Returns
Type | Description
ToolkitResult |

LogPartsUsedExchange(LogPartsUsedExchangeSetup, IDbTransaction)

Declaration
public ToolkitResult LogPartsUsedExchange(LogPartsUsedExchangeSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
LogPartsUsedExchangeSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

LogPartsUsedExchange(String, Int32, String, String, String, Int32)

Declaration
public ToolkitResult LogPartsUsedExchange(string partRequestDetailIDNum, int removeSitePartObjid, string installPartNumber, string installPartRevision, string installPartDomain, int installQuantity)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.Int32 | removeSitePartObjid |
System.String | installPartNumber |
System.String | installPartRevision |
System.String | installPartDomain |
System.Int32 | installQuantity |
Returns
Type | Description
ToolkitResult |

LogPartsUsedExchange(String, Int32, String, String, String, String)

Declaration
public ToolkitResult LogPartsUsedExchange(string partRequestDetailIDNum, int removeSitePartObjid, string installPartNumber, string installPartRevision, string installPartDomain, string installSerialNumber)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.Int32 | removeSitePartObjid |
System.String | installPartNumber |
System.String | installPartRevision |
System.String | installPartDomain |
System.String | installSerialNumber |
Returns
Type | Description
ToolkitResult |

LogPartsUsedExchange(String, String, Int32, String, String, String, Int32)

Declaration
public ToolkitResult LogPartsUsedExchange(string partRequestDetailIDNum, string caseIDNum, int removeSitePartObjid, string installPartNumber, string installPartRevision, string installPartDomain, int installQuantity)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String | caseIDNum |
System.Int32 | removeSitePartObjid |
System.String | installPartNumber |
System.String | installPartRevision |
System.String | installPartDomain |
System.Int32 | installQuantity |
Returns
Type | Description
ToolkitResult |

LogPartsUsedExchange(String, String, Int32, String, String, String, String)

Declaration
public ToolkitResult LogPartsUsedExchange(string partRequestDetailIDNum, string caseIDNum, int removeSitePartObjid, string installPartNumber, string installPartRevision, string installPartDomain, string installSerialNumber)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String | caseIDNum |
System.Int32 | removeSitePartObjid |
System.String | installPartNumber |
System.String | installPartRevision |
System.String | installPartDomain |
System.String | installSerialNumber |
Returns
Type | Description
ToolkitResult |

LogPartsUsedInstall(LogPartsUsedInstallSetup)

Declaration
public ToolkitResult LogPartsUsedInstall(LogPartsUsedInstallSetup setupParam)
Parameters
Type | Name | Description
LogPartsUsedInstallSetup | setupParam |
Returns
Type | Description
ToolkitResult |

LogPartsUsedInstall(LogPartsUsedInstallSetup, IDbTransaction)

Declaration
public ToolkitResult LogPartsUsedInstall(LogPartsUsedInstallSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
LogPartsUsedInstallSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

LogPartsUsedInstall(String, String, String, String, Int32)

Declaration
public ToolkitResult LogPartsUsedInstall(string partRequestDetailIDNum, string installPartNumber, string installPartRevision, string installPartDomain, int installQuantity)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String | installPartNumber |
System.String | installPartRevision |
System.String | installPartDomain |
System.Int32 | installQuantity |
Returns
Type | Description
ToolkitResult |

LogPartsUsedInstall(String, String, String, String, String)

Declaration
public ToolkitResult LogPartsUsedInstall(string partRequestDetailIDNum, string installPartNumber, string installPartRevision, string installPartDomain, string installSerialNumber)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String | installPartNumber |
System.String | installPartRevision |
System.String | installPartDomain |
System.String | installSerialNumber |
Returns
Type | Description
ToolkitResult |

LogPartsUsedInstall(String, String, String, String, String, Int32)

Declaration
public ToolkitResult LogPartsUsedInstall(string partRequestDetailIDNum, string caseIDNum, string installPartNumber, string installPartRevision, string installPartDomain, int installQuantity)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String | caseIDNum |
System.String | installPartNumber |
System.String | installPartRevision |
System.String | installPartDomain |
System.Int32 | installQuantity |
Returns
Type | Description
ToolkitResult |

LogPartsUsedInstall(String, String, String, String, String, String)

Declaration
public ToolkitResult LogPartsUsedInstall(string partRequestDetailIDNum, string caseIDNum, string installPartNumber, string installPartRevision, string installPartDomain, string installSerialNumber)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String | caseIDNum |
System.String | installPartNumber |
System.String | installPartRevision |
System.String | installPartDomain |
System.String | installSerialNumber |
Returns
Type | Description
ToolkitResult |

LogPartsUsedRemove(LogPartsUsedRemoveSetup)

Declaration
public ToolkitResult LogPartsUsedRemove(LogPartsUsedRemoveSetup setupParam)
Parameters
Type | Name | Description
LogPartsUsedRemoveSetup | setupParam |
Returns
Type | Description
ToolkitResult |

LogPartsUsedRemove(LogPartsUsedRemoveSetup, IDbTransaction)

Declaration
public ToolkitResult LogPartsUsedRemove(LogPartsUsedRemoveSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
LogPartsUsedRemoveSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

LogPartsUsedRemove(String, Int32)

Declaration
public ToolkitResult LogPartsUsedRemove(string partRequestDetailIDNum, int removeSitePartObjid)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.Int32 | removeSitePartObjid |
Returns
Type | Description
ToolkitResult |

LogPartsUsedRemove(String, String, Int32)

Declaration
public ToolkitResult LogPartsUsedRemove(string partRequestDetailIDNum, string caseIDNum, int removeSitePartObjid)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String | caseIDNum |
System.Int32 | removeSitePartObjid |
Returns
Type | Description
ToolkitResult |

LogPartsUsedUpgrade(LogPartsUsedUpgradeSetup)

Declaration
public ToolkitResult LogPartsUsedUpgrade(LogPartsUsedUpgradeSetup setupParam)
Parameters
Type | Name | Description
LogPartsUsedUpgradeSetup | setupParam |
Returns
Type | Description
ToolkitResult |

LogPartsUsedUpgrade(LogPartsUsedUpgradeSetup, IDbTransaction)

Declaration
public ToolkitResult LogPartsUsedUpgrade(LogPartsUsedUpgradeSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
LogPartsUsedUpgradeSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

LogPartsUsedUpgrade(String, Int32, String, String, String, Int32)

Declaration
public ToolkitResult LogPartsUsedUpgrade(string partRequestDetailIDNum, int removeSitePartObjid, string installPartNumber, string installPartRevision, string installPartDomain, int installQuantity)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.Int32 | removeSitePartObjid |
System.String | installPartNumber |
System.String | installPartRevision |
System.String | installPartDomain |
System.Int32 | installQuantity |
Returns
Type | Description
ToolkitResult |

LogPartsUsedUpgrade(String, Int32, String, String, String, String)

Declaration
public ToolkitResult LogPartsUsedUpgrade(string partRequestDetailIDNum, int removeSitePartObjid, string installPartNumber, string installPartRevision, string installPartDomain, string installSerialNumber)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.Int32 | removeSitePartObjid |
System.String | installPartNumber |
System.String | installPartRevision |
System.String | installPartDomain |
System.String | installSerialNumber |
Returns
Type | Description
ToolkitResult |

LogPartsUsedUpgrade(String, String, Int32, String, String, String, Int32)

Declaration
public ToolkitResult LogPartsUsedUpgrade(string partRequestDetailIDNum, string caseIDNum, int removeSitePartObjid, string installPartNumber, string installPartRevision, string installPartDomain, int installQuantity)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String | caseIDNum |
System.Int32 | removeSitePartObjid |
System.String | installPartNumber |
System.String | installPartRevision |
System.String | installPartDomain |
System.Int32 | installQuantity |
Returns
Type | Description
ToolkitResult |

LogPartsUsedUpgrade(String, String, Int32, String, String, String, String)

Declaration
public ToolkitResult LogPartsUsedUpgrade(string partRequestDetailIDNum, string caseIDNum, int removeSitePartObjid, string installPartNumber, string installPartRevision, string installPartDomain, string installSerialNumber)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String | caseIDNum |
System.Int32 | removeSitePartObjid |
System.String | installPartNumber |
System.String | installPartRevision |
System.String | installPartDomain |
System.String | installSerialNumber |
Returns
Type | Description
ToolkitResult |

MoveSitePartToBin(MoveSitePartToBinSetup)

Declaration
public ToolkitResult MoveSitePartToBin(MoveSitePartToBinSetup setupParam)
Parameters
Type | Name | Description
MoveSitePartToBinSetup | setupParam |
Returns
Type | Description
ToolkitResult |

MoveSitePartToBin(MoveSitePartToBinSetup, IDbTransaction)

Declaration
public ToolkitResult MoveSitePartToBin(MoveSitePartToBinSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
MoveSitePartToBinSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

MoveSitePartToBin(Int32, Int32)

Declaration
public ToolkitResult MoveSitePartToBin(int sitePartObjid, int parentBinObjid)
Parameters
Type | Name | Description
System.Int32 | sitePartObjid |
System.Int32 | parentBinObjid |
Returns
Type | Description
ToolkitResult |

MoveSitePartToPart(MoveSitePartToPartSetup)

Declaration
public ToolkitResult MoveSitePartToPart(MoveSitePartToPartSetup setupParam)
Parameters
Type | Name | Description
MoveSitePartToPartSetup | setupParam |
Returns
Type | Description
ToolkitResult |

MoveSitePartToPart(MoveSitePartToPartSetup, IDbTransaction)

Declaration
public ToolkitResult MoveSitePartToPart(MoveSitePartToPartSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
MoveSitePartToPartSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

MoveSitePartToPart(Int32, Int32)

Declaration
public ToolkitResult MoveSitePartToPart(int sitePartObjid, int parentSitePartObjid)
Parameters
Type | Name | Description
System.Int32 | sitePartObjid |
System.Int32 | parentSitePartObjid |
Returns
Type | Description
ToolkitResult |

MoveSitePartToSite(MoveSitePartToSiteSetup)

Declaration
public ToolkitResult MoveSitePartToSite(MoveSitePartToSiteSetup setupParam)
Parameters
Type | Name | Description
MoveSitePartToSiteSetup | setupParam |
Returns
Type | Description
ToolkitResult |

MoveSitePartToSite(MoveSitePartToSiteSetup, IDbTransaction)

Declaration
public ToolkitResult MoveSitePartToSite(MoveSitePartToSiteSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
MoveSitePartToSiteSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

MoveSitePartToSite(Int32, String)

Declaration
public ToolkitResult MoveSitePartToSite(int sitePartObjid, string siteIDNum)
Parameters
Type | Name | Description
System.Int32 | sitePartObjid |
System.String | siteIDNum |
Returns
Type | Description
ToolkitResult |

PartTransfer(PartTransferSetup)

Declaration
public PartTransferResult PartTransfer(PartTransferSetup setupParam)
Parameters
Type | Name | Description
PartTransferSetup | setupParam |
Returns
Type | Description
PartTransferResult |

PartTransfer(PartTransferSetup, IDbTransaction)

Declaration
public PartTransferResult PartTransfer(PartTransferSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
PartTransferSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
PartTransferResult |

PartTransfer(String, String, String, Int32, Location, Location)

Declaration
public PartTransferResult PartTransfer(string partNumber, string partRevision, string partDomain, int quantity, Location fromlocation, Location tolocation)
Parameters
Type | Name | Description
System.String | partNumber |
System.String | partRevision |
System.String | partDomain |
System.Int32 | quantity |
Location | fromlocation |
Location | tolocation |
Returns
Type | Description
PartTransferResult |

PartTransfer(String, String, String, String, Location, Location)

Declaration
public PartTransferResult PartTransfer(string partNumber, string partRevision, string partDomain, string serialNumber, Location fromlocation, Location tolocation)
Parameters
Type | Name | Description
System.String | partNumber |
System.String | partRevision |
System.String | partDomain |
System.String | serialNumber |
Location | fromlocation |
Location | tolocation |
Returns
Type | Description
PartTransferResult |

ReinstallSitePart(ReinstallSitePartSetup)

Declaration
public ToolkitResult ReinstallSitePart(ReinstallSitePartSetup setupParam)
Parameters
Type | Name | Description
ReinstallSitePartSetup | setupParam |
Returns
Type | Description
ToolkitResult |

ReinstallSitePart(ReinstallSitePartSetup, IDbTransaction)

Declaration
public ToolkitResult ReinstallSitePart(ReinstallSitePartSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
ReinstallSitePartSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

ReinstallSitePart(Int32, String)

Declaration
public ToolkitResult ReinstallSitePart(int sitePartObjid, string siteIDNum)
Parameters
Type | Name | Description
System.Int32 | sitePartObjid |
System.String | siteIDNum |
Returns
Type | Description
ToolkitResult |

UpdateAppointment(UpdateAppointmentSetup)

Declaration
public ToolkitResult UpdateAppointment(UpdateAppointmentSetup setupParam)
Parameters
Type | Name | Description
UpdateAppointmentSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdateAppointment(UpdateAppointmentSetup, IDbTransaction)

Declaration
public ToolkitResult UpdateAppointment(UpdateAppointmentSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdateAppointmentSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UpdateExpenseLog(UpdateExpenseLogSetup)

Declaration
public ToolkitResult UpdateExpenseLog(UpdateExpenseLogSetup setupParam)
Parameters
Type | Name | Description
UpdateExpenseLogSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdateExpenseLog(UpdateExpenseLogSetup, IDbTransaction)

Declaration
public ToolkitResult UpdateExpenseLog(UpdateExpenseLogSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdateExpenseLogSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UpdateExpenseLog(Int32, Double, Double)

Declaration
public ToolkitResult UpdateExpenseLog(int expenseLogObjid, double quantity, double rate)
Parameters
Type | Name | Description
System.Int32 | expenseLogObjid |
System.Double | quantity |
System.Double | rate |
Returns
Type | Description
ToolkitResult |

UpdateServiceInterruption(UpdateServiceInterruptionSetup)

Declaration
public ToolkitResult UpdateServiceInterruption(UpdateServiceInterruptionSetup setupParam)
Parameters
Type | Name | Description
UpdateServiceInterruptionSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdateServiceInterruption(UpdateServiceInterruptionSetup, IDbTransaction)

Declaration
public ToolkitResult UpdateServiceInterruption(UpdateServiceInterruptionSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdateServiceInterruptionSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UpdateSitePart(UpdateSitePartSetup)

Declaration
public ToolkitResult UpdateSitePart(UpdateSitePartSetup setupParam)
Parameters
Type | Name | Description
UpdateSitePartSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdateSitePart(UpdateSitePartSetup, IDbTransaction)

Declaration
public ToolkitResult UpdateSitePart(UpdateSitePartSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdateSitePartSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UpdateTimeLog(UpdateTimeLogSetup)

Declaration
public ToolkitResult UpdateTimeLog(UpdateTimeLogSetup setupParam)
Parameters
Type | Name | Description
UpdateTimeLogSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdateTimeLog(UpdateTimeLogSetup, IDbTransaction)

Declaration
public ToolkitResult UpdateTimeLog(UpdateTimeLogSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdateTimeLogSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |


Class FieldOpsToolkitBase | fcSDK Documentation

Class FieldOpsToolkitBase

Inheritance
System.Object
ToolkitBase
FieldOpsToolkitBase
FieldOpsToolkit
Inherited Members
ToolkitBase.NOW_DATE
ToolkitBase.CompatSession
ToolkitBase.WithTransaction<T>(Func<IDbTransaction, T>)
ToolkitBase.FCApplication
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.FieldOps
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public abstract class FieldOpsToolkitBase : ToolkitBase

Constructors

FieldOpsToolkitBase(ClarifySession)

Declaration
public FieldOpsToolkitBase(ClarifySession sess)
Parameters
Type | Name | Description
ClarifySession | sess |

FieldOpsToolkitBase(IFCApplication, IFCSession)

Declaration
public FieldOpsToolkitBase(IFCApplication app, IFCSession sess)
Parameters
Type | Name | Description
IFCApplication | app |
IFCSession | sess |

Fields

_toolkit

Declaration
protected FCFO _toolkit
Field Value
Type | Description
FCFO |

Properties

ImpersonatorUsername

Declaration
public string ImpersonatorUsername { get; set; }
Property Value
Type | Description
System.String |


Class InstallSitePartSetup | fcSDK Documentation

Class InstallSitePartSetup

Inheritance
System.Object
InstallSitePartSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.FieldOps
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class InstallSitePartSetup

Constructors

InstallSitePartSetup(String, String, String, String, Int32)

Declaration
[ConstructorIndex(0)]
public InstallSitePartSetup(string siteIDNum, string partNumber, string partrevision, string partdomain, int quantity)
Parameters
Type | Name | Description
System.String | siteIDNum |
System.String | partNumber |
System.String | partrevision |
System.String | partdomain |
System.Int32 | quantity |

InstallSitePartSetup(String, String, String, String, String)

Declaration
[ConstructorIndex(1)]
public InstallSitePartSetup(string siteIDNum, string partNumber, string partrevision, string partdomain, string serialNumber)
Parameters
Type | Name | Description
System.String | siteIDNum |
System.String | partNumber |
System.String | partrevision |
System.String | partdomain |
System.String | serialNumber |

Properties

AddActivityLog

Declaration
[PropertyBitValue(32768)]
public bool AddActivityLog { get; set; }
Property Value
Type | Description
System.Boolean |

AdditionalFields

Declaration
[PropertyBitValue(65536)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

Comments

Declaration
[PropertyBitValue(512)]
public string Comments { get; set; }
Property Value
Type | Description
System.String |

InstallDate

Declaration
[PropertyBitValue(8192)]
public DateTime InstallDate { get; set; }
Property Value
Type | Description
System.DateTime |

InstanceName

Declaration
[PropertyBitValue(256)]
public string InstanceName { get; set; }
Property Value
Type | Description
System.String |

InvoiceNumber

Declaration
[PropertyBitValue(2048)]
public string InvoiceNumber { get; set; }
Property Value
Type | Description
System.String |

ParentBinObjid

Declaration
[PropertyBitValue(64)]
public int ParentBinObjid { get; set; }
Property Value
Type | Description
System.Int32 |

ParentSitePartObjid

Declaration
[PropertyBitValue(128)]
public int ParentSitePartObjid { get; set; }
Property Value
Type | Description
System.Int32 |

PartDomain

Declaration
[PropertyBitValue(8)]
public string PartDomain { get; set; }
Property Value
Type | Description
System.String |

PartNumber

Declaration
[PropertyBitValue(2)]
public string PartNumber { get; set; }
Property Value
Type | Description
System.String |

PartRevision

Declaration
[PropertyBitValue(4)]
public string PartRevision { get; set; }
Property Value
Type | Description
System.String |

PartStatus

Declaration
[PropertyBitValue(1024)]
public string PartStatus { get; set; }
Property Value
Type | Description
System.String |

Quantity

Declaration
[PropertyBitValue(16)]
public int Quantity { get; set; }
Property Value
Type | Description
System.Int32 |

SerialNumber

Declaration
[PropertyBitValue(32)]
public string SerialNumber { get; set; }
Property Value
Type | Description
System.String |

ShipDate

Declaration
[PropertyBitValue(16384)]
public DateTime ShipDate { get; set; }
Property Value
Type | Description
System.DateTime |

SiteIDNum

Declaration
[PropertyBitValue(1)]
public string SiteIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(4096)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class LogPartsUsedConsumeSetup | fcSDK Documentation

Class LogPartsUsedConsumeSetup

Inheritance
System.Object
LogPartsUsedConsumeSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.FieldOps
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LogPartsUsedConsumeSetup

Constructors

LogPartsUsedConsumeSetup(String, String, String, String, Int32)

Declaration
[ConstructorIndex(1)]
public LogPartsUsedConsumeSetup(string partRequestDetailIDNum, string installPartNumber, string installPartRevision, string installPartDomain, int installQuantity)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String | installPartNumber |
System.String | installPartRevision |
System.String | installPartDomain |
System.Int32 | installQuantity |

LogPartsUsedConsumeSetup(String, String, String, String, String)

Declaration
[ConstructorIndex(0)]
public LogPartsUsedConsumeSetup(string partRequestDetailIDNum, string installPartNumber, string installPartRevision, string installPartDomain, string installSerialNumber)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String | installPartNumber |
System.String | installPartRevision |
System.String | installPartDomain |
System.String | installSerialNumber |

LogPartsUsedConsumeSetup(String, String, String, String, String, Int32)

Declaration
[ConstructorIndex(3)]
public LogPartsUsedConsumeSetup(string partRequestDetailIDNum, string caseIDNum, string installPartNumber, string installPartRevision, string installPartDomain, int installQuantity)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String | caseIDNum |
System.String | installPartNumber |
System.String | installPartRevision |
System.String | installPartDomain |
System.Int32 | installQuantity |

LogPartsUsedConsumeSetup(String, String, String, String, String, String)

Declaration
[ConstructorIndex(2)]
public LogPartsUsedConsumeSetup(string partRequestDetailIDNum, string caseIDNum, string installPartNumber, string installPartRevision, string installPartDomain, string installSerialNumber)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String | caseIDNum |
System.String | installPartNumber |
System.String | installPartRevision |
System.String | installPartDomain |
System.String | installSerialNumber |

Properties

AllowMove

Declaration
[PropertyBitValue(8388608)]
public bool AllowMove { get; set; }
Property Value
Type | Description
System.Boolean |

CaseIDNum

Declaration
[PropertyBitValue(2)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

EngineerUserName

Declaration
[PropertyBitValue(2097152)]
public string EngineerUserName { get; set; }
Property Value
Type | Description
System.String |

FromBin

Declaration
[PropertyBitValue(262144)]
public string FromBin { get; set; }
Property Value
Type | Description
System.String |

FromContainer

Declaration
[PropertyBitValue(524288)]
public string FromContainer { get; set; }
Property Value
Type | Description
System.String |

FromGood

Declaration
[PropertyBitValue(1048576)]
public bool FromGood { get; set; }
Property Value
Type | Description
System.Boolean |

FromLocation

Declaration
[PropertyBitValue(131072)]
public string FromLocation { get; set; }
Property Value
Type | Description
System.String |

InstallAtSite

Declaration
[PropertyBitValue(16)]
public bool InstallAtSite { get; set; }
Property Value
Type | Description
System.Boolean |

InstallPartDomain

Declaration
[PropertyBitValue(8192)]
public string InstallPartDomain { get; set; }
Property Value
Type | Description
System.String |

InstallPartNumber

Declaration
[PropertyBitValue(2048)]
public string InstallPartNumber { get; set; }
Property Value
Type | Description
System.String |

InstallPartRevision

Declaration
[PropertyBitValue(4096)]
public string InstallPartRevision { get; set; }
Property Value
Type | Description
System.String |

InstallPrice

Declaration
[PropertyBitValue(65536)]
public string InstallPrice { get; set; }
Property Value
Type | Description
System.String |

InstallQuantity

Declaration
[PropertyBitValue(32768)]
public int InstallQuantity { get; set; }
Property Value
Type | Description
System.Int32 |

InstallSerialNumber

Declaration
[PropertyBitValue(16384)]
public string InstallSerialNumber { get; set; }
Property Value
Type | Description
System.String |

LogDate

Declaration
[PropertyBitValue(16777216)]
public DateTime LogDate { get; set; }
Property Value
Type | Description
System.DateTime |

ParentSitePartObjid

Declaration
[PropertyBitValue(8)]
public int ParentSitePartObjid { get; set; }
Property Value
Type | Description
System.Int32 |

PartRequestDetailIDNum

Declaration
[PropertyBitValue(1)]
public string PartRequestDetailIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(4194304)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class LogPartsUsedExchangeSetup | fcSDK Documentation

Class LogPartsUsedExchangeSetup

Inheritance
System.Object
LogPartsUsedExchangeSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.FieldOps
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LogPartsUsedExchangeSetup

Constructors

LogPartsUsedExchangeSetup(String, Int32, String, String, String, Int32)

Declaration
[ConstructorIndex(1)]
public LogPartsUsedExchangeSetup(string partRequestDetailIDNum, int removeSitePartObjid, string installPartNumber, string installPartRevision, string installPartDomain, int installQuantity)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.Int32 | removeSitePartObjid |
System.String | installPartNumber |
System.String | installPartRevision |
System.String | installPartDomain |
System.Int32 | installQuantity |

LogPartsUsedExchangeSetup(String, Int32, String, String, String, String)

Declaration
[ConstructorIndex(0)]
public LogPartsUsedExchangeSetup(string partRequestDetailIDNum, int removeSitePartObjid, string installPartNumber, string installPartRevision, string installPartDomain, string installSerialNumber)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.Int32 | removeSitePartObjid |
System.String | installPartNumber |
System.String | installPartRevision |
System.String | installPartDomain |
System.String | installSerialNumber |

LogPartsUsedExchangeSetup(String, String, Int32, String, String, String, Int32)

Declaration
[ConstructorIndex(3)]
public LogPartsUsedExchangeSetup(string partRequestDetailIDNum, string caseIDNum, int removeSitePartObjid, string installPartNumber, string installPartRevision, string installPartDomain, int installQuantity)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String | caseIDNum |
System.Int32 | removeSitePartObjid |
System.String | installPartNumber |
System.String | installPartRevision |
System.String | installPartDomain |
System.Int32 | installQuantity |

LogPartsUsedExchangeSetup(String, String, Int32, String, String, String, String)

Declaration
[ConstructorIndex(2)]
public LogPartsUsedExchangeSetup(string partRequestDetailIDNum, string caseIDNum, int removeSitePartObjid, string installPartNumber, string installPartRevision, string installPartDomain, string installSerialNumber)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String | caseIDNum |
System.Int32 | removeSitePartObjid |
System.String | installPartNumber |
System.String | installPartRevision |
System.String | installPartDomain |
System.String | installSerialNumber |

Properties

AllowMove

Declaration
[PropertyBitValue(8388608)]
public bool AllowMove { get; set; }
Property Value
Type | Description
System.Boolean |

CaseIDNum

Declaration
[PropertyBitValue(2)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

EngineerUserName

Declaration
[PropertyBitValue(2097152)]
public string EngineerUserName { get; set; }
Property Value
Type | Description
System.String |

FailureCode

Declaration
[PropertyBitValue(1024)]
public string FailureCode { get; set; }
Property Value
Type | Description
System.String |

FromBin

Declaration
[PropertyBitValue(262144)]
public string FromBin { get; set; }
Property Value
Type | Description
System.String |

FromContainer

Declaration
[PropertyBitValue(524288)]
public string FromContainer { get; set; }
Property Value
Type | Description
System.String |

FromGood

Declaration
[PropertyBitValue(1048576)]
public bool FromGood { get; set; }
Property Value
Type | Description
System.Boolean |

FromLocation

Declaration
[PropertyBitValue(131072)]
public string FromLocation { get; set; }
Property Value
Type | Description
System.String |

InstallAtSite

Declaration
[PropertyBitValue(16)]
public bool InstallAtSite { get; set; }
Property Value
Type | Description
System.Boolean |

InstallPartDomain

Declaration
[PropertyBitValue(8192)]
public string InstallPartDomain { get; set; }
Property Value
Type | Description
System.String |

InstallPartNumber

Declaration
[PropertyBitValue(2048)]
public string InstallPartNumber { get; set; }
Property Value
Type | Description
System.String |

InstallPartRevision

Declaration
[PropertyBitValue(4096)]
public string InstallPartRevision { get; set; }
Property Value
Type | Description
System.String |

InstallPrice

Declaration
[PropertyBitValue(65536)]
public string InstallPrice { get; set; }
Property Value
Type | Description
System.String |

InstallQuantity

Declaration
[PropertyBitValue(32768)]
public int InstallQuantity { get; set; }
Property Value
Type | Description
System.Int32 |

InstallSerialNumber

Declaration
[PropertyBitValue(16384)]
public string InstallSerialNumber { get; set; }
Property Value
Type | Description
System.String |

LogDate

Declaration
[PropertyBitValue(16777216)]
public DateTime LogDate { get; set; }
Property Value
Type | Description
System.DateTime |

ParentSitePartObjid

Declaration
[PropertyBitValue(8)]
public int ParentSitePartObjid { get; set; }
Property Value
Type | Description
System.Int32 |

PartRequestDetailIDNum

Declaration
[PropertyBitValue(1)]
public string PartRequestDetailIDNum { get; set; }
Property Value
Type | Description
System.String |

RemoveSitePartObjid

Declaration
[PropertyBitValue(32)]
public int RemoveSitePartObjid { get; set; }
Property Value
Type | Description
System.Int32 |

ToBin

Declaration
[PropertyBitValue(128)]
public string ToBin { get; set; }
Property Value
Type | Description
System.String |

ToContainer

Declaration
[PropertyBitValue(256)]
public string ToContainer { get; set; }
Property Value
Type | Description
System.String |

ToGood

Declaration
[PropertyBitValue(512)]
public bool ToGood { get; set; }
Property Value
Type | Description
System.Boolean |

ToLocation

Declaration
[PropertyBitValue(64)]
public string ToLocation { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(4194304)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class LogPartsUsedInstallSetup | fcSDK Documentation

Class LogPartsUsedInstallSetup

Inheritance
System.Object
LogPartsUsedInstallSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.FieldOps
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LogPartsUsedInstallSetup

Constructors

LogPartsUsedInstallSetup(String, String, String, String, Int32)

Declaration
[ConstructorIndex(1)]
public LogPartsUsedInstallSetup(string partRequestDetailIDNum, string installPartNumber, string installPartRevision, string installPartDomain, int installQuantity)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String | installPartNumber |
System.String | installPartRevision |
System.String | installPartDomain |
System.Int32 | installQuantity |

LogPartsUsedInstallSetup(String, String, String, String, String)

Declaration
[ConstructorIndex(0)]
public LogPartsUsedInstallSetup(string partRequestDetailIDNum, string installPartNumber, string installPartRevision, string installPartDomain, string installSerialNumber)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String | installPartNumber |
System.String | installPartRevision |
System.String | installPartDomain |
System.String | installSerialNumber |

LogPartsUsedInstallSetup(String, String, String, String, String, Int32)

Declaration
[ConstructorIndex(3)]
public LogPartsUsedInstallSetup(string partRequestDetailIDNum, string caseIDNum, string installPartNumber, string installPartRevision, string installPartDomain, int installQuantity)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String | caseIDNum |
System.String | installPartNumber |
System.String | installPartRevision |
System.String | installPartDomain |
System.Int32 | installQuantity |

LogPartsUsedInstallSetup(String, String, String, String, String, String)

Declaration
[ConstructorIndex(2)]
public LogPartsUsedInstallSetup(string partRequestDetailIDNum, string caseIDNum, string installPartNumber, string installPartRevision, string installPartDomain, string installSerialNumber)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String | caseIDNum |
System.String | installPartNumber |
System.String | installPartRevision |
System.String | installPartDomain |
System.String | installSerialNumber |

Properties

AllowMove

Declaration
[PropertyBitValue(8388608)]
public bool AllowMove { get; set; }
Property Value
Type | Description
System.Boolean |

CaseIDNum

Declaration
[PropertyBitValue(2)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

EngineerUserName

Declaration
[PropertyBitValue(2097152)]
public string EngineerUserName { get; set; }
Property Value
Type | Description
System.String |

FromBin

Declaration
[PropertyBitValue(262144)]
public string FromBin { get; set; }
Property Value
Type | Description
System.String |

FromContainer

Declaration
[PropertyBitValue(524288)]
public string FromContainer { get; set; }
Property Value
Type | Description
System.String |

FromGood

Declaration
[PropertyBitValue(1048576)]
public bool FromGood { get; set; }
Property Value
Type | Description
System.Boolean |

FromLocation

Declaration
[PropertyBitValue(131072)]
public string FromLocation { get; set; }
Property Value
Type | Description
System.String |

InstallAtSite

Declaration
[PropertyBitValue(16)]
public bool InstallAtSite { get; set; }
Property Value
Type | Description
System.Boolean |

InstallPartDomain

Declaration
[PropertyBitValue(8192)]
public string InstallPartDomain { get; set; }
Property Value
Type | Description
System.String |

InstallPartNumber

Declaration
[PropertyBitValue(2048)]
public string InstallPartNumber { get; set; }
Property Value
Type | Description
System.String |

InstallPartRevision

Declaration
[PropertyBitValue(4096)]
public string InstallPartRevision { get; set; }
Property Value
Type | Description
System.String |

InstallPrice

Declaration
[PropertyBitValue(65536)]
public string InstallPrice { get; set; }
Property Value
Type | Description
System.String |

InstallQuantity

Declaration
[PropertyBitValue(32768)]
public int InstallQuantity { get; set; }
Property Value
Type | Description
System.Int32 |

InstallSerialNumber

Declaration
[PropertyBitValue(16384)]
public string InstallSerialNumber { get; set; }
Property Value
Type | Description
System.String |

LogDate

Declaration
[PropertyBitValue(16777216)]
public DateTime LogDate { get; set; }
Property Value
Type | Description
System.DateTime |

ParentSitePartObjid

Declaration
[PropertyBitValue(8)]
public int ParentSitePartObjid { get; set; }
Property Value
Type | Description
System.Int32 |

PartRequestDetailIDNum

Declaration
[PropertyBitValue(1)]
public string PartRequestDetailIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(4194304)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class LogPartsUsedRemoveSetup | fcSDK Documentation

Class LogPartsUsedRemoveSetup

Inheritance
System.Object
LogPartsUsedRemoveSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.FieldOps
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LogPartsUsedRemoveSetup

Constructors

LogPartsUsedRemoveSetup(String, Int32)

Declaration
[ConstructorIndex(0)]
public LogPartsUsedRemoveSetup(string partRequestDetailIDNum, int removeSitePartObjid)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.Int32 | removeSitePartObjid |

LogPartsUsedRemoveSetup(String, String, Int32)

Declaration
[ConstructorIndex(1)]
public LogPartsUsedRemoveSetup(string partRequestDetailIDNum, string caseIDNum, int removeSitePartObjid)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String | caseIDNum |
System.Int32 | removeSitePartObjid |

Properties

AllowMove

Declaration
[PropertyBitValue(8388608)]
public bool AllowMove { get; set; }
Property Value
Type | Description
System.Boolean |

CaseIDNum

Declaration
[PropertyBitValue(2)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

EngineerUserName

Declaration
[PropertyBitValue(2097152)]
public string EngineerUserName { get; set; }
Property Value
Type | Description
System.String |

FailureCode

Declaration
[PropertyBitValue(1024)]
public string FailureCode { get; set; }
Property Value
Type | Description
System.String |

InstallAtSite

Declaration
[PropertyBitValue(16)]
[Obsolete("This property has no effect", false)]
public bool InstallAtSite { get; set; }
Property Value
Type | Description
System.Boolean |

LogDate

Declaration
[PropertyBitValue(16777216)]
public DateTime LogDate { get; set; }
Property Value
Type | Description
System.DateTime |

ParentSitePartObjid

Declaration
[PropertyBitValue(8)]
public int ParentSitePartObjid { get; set; }
Property Value
Type | Description
System.Int32 |

PartRequestDetailIDNum

Declaration
[PropertyBitValue(1)]
public string PartRequestDetailIDNum { get; set; }
Property Value
Type | Description
System.String |

RemoveQuantity

Declaration
[PropertyBitValue(32768)]
public int RemoveQuantity { get; set; }
Property Value
Type | Description
System.Int32 |

RemoveSitePartObjid

Declaration
[PropertyBitValue(32)]
public int RemoveSitePartObjid { get; set; }
Property Value
Type | Description
System.Int32 |

ToBin

Declaration
[PropertyBitValue(128)]
public string ToBin { get; set; }
Property Value
Type | Description
System.String |

ToContainer

Declaration
[PropertyBitValue(256)]
public string ToContainer { get; set; }
Property Value
Type | Description
System.String |

ToGood

Declaration
[PropertyBitValue(512)]
public bool ToGood { get; set; }
Property Value
Type | Description
System.Boolean |

ToLocation

Declaration
[PropertyBitValue(64)]
public string ToLocation { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(4194304)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class LogPartsUsedUpgradeSetup | fcSDK Documentation

Class LogPartsUsedUpgradeSetup

Inheritance
System.Object
LogPartsUsedUpgradeSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.FieldOps
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LogPartsUsedUpgradeSetup

Constructors

LogPartsUsedUpgradeSetup(String, Int32, String, String, String, Int32)

Declaration
[ConstructorIndex(1)]
public LogPartsUsedUpgradeSetup(string partRequestDetailIDNum, int removeSitePartObjid, string installPartNumber, string installPartRevision, string installPartDomain, int installQuantity)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.Int32 | removeSitePartObjid |
System.String | installPartNumber |
System.String | installPartRevision |
System.String | installPartDomain |
System.Int32 | installQuantity |

LogPartsUsedUpgradeSetup(String, Int32, String, String, String, String)

Declaration
[ConstructorIndex(0)]
public LogPartsUsedUpgradeSetup(string partRequestDetailIDNum, int removeSitePartObjid, string installPartNumber, string installPartRevision, string installPartDomain, string installSerialNumber)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.Int32 | removeSitePartObjid |
System.String | installPartNumber |
System.String | installPartRevision |
System.String | installPartDomain |
System.String | installSerialNumber |

LogPartsUsedUpgradeSetup(String, String, Int32, String, String, String, Int32)

Declaration
[ConstructorIndex(3)]
public LogPartsUsedUpgradeSetup(string partRequestDetailIDNum, string caseIDNum, int removeSitePartObjid, string installPartNumber, string installPartRevision, string installPartDomain, int installQuantity)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String | caseIDNum |
System.Int32 | removeSitePartObjid |
System.String | installPartNumber |
System.String | installPartRevision |
System.String | installPartDomain |
System.Int32 | installQuantity |

LogPartsUsedUpgradeSetup(String, String, Int32, String, String, String, String)

Declaration
[ConstructorIndex(2)]
public LogPartsUsedUpgradeSetup(string partRequestDetailIDNum, string caseIDNum, int removeSitePartObjid, string installPartNumber, string installPartRevision, string installPartDomain, string installSerialNumber)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String | caseIDNum |
System.Int32 | removeSitePartObjid |
System.String | installPartNumber |
System.String | installPartRevision |
System.String | installPartDomain |
System.String | installSerialNumber |

Properties

AllowMove

Declaration
[PropertyBitValue(8388608)]
public bool AllowMove { get; set; }
Property Value
Type | Description
System.Boolean |

CaseIDNum

Declaration
[PropertyBitValue(2)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

EngineerUserName

Declaration
[PropertyBitValue(2097152)]
public string EngineerUserName { get; set; }
Property Value
Type | Description
System.String |

FailureCode

Declaration
[PropertyBitValue(1024)]
public string FailureCode { get; set; }
Property Value
Type | Description
System.String |

FromBin

Declaration
[PropertyBitValue(262144)]
public string FromBin { get; set; }
Property Value
Type | Description
System.String |

FromContainer

Declaration
[PropertyBitValue(524288)]
public string FromContainer { get; set; }
Property Value
Type | Description
System.String |

FromGood

Declaration
[PropertyBitValue(1048576)]
public bool FromGood { get; set; }
Property Value
Type | Description
System.Boolean |

FromLocation

Declaration
[PropertyBitValue(131072)]
public string FromLocation { get; set; }
Property Value
Type | Description
System.String |

InstallAtSite

Declaration
[PropertyBitValue(16)]
public bool InstallAtSite { get; set; }
Property Value
Type | Description
System.Boolean |

InstallPartDomain

Declaration
[PropertyBitValue(8192)]
public string InstallPartDomain { get; set; }
Property Value
Type | Description
System.String |

InstallPartNumber

Declaration
[PropertyBitValue(2048)]
public string InstallPartNumber { get; set; }
Property Value
Type | Description
System.String |

InstallPartRevision

Declaration
[PropertyBitValue(4096)]
public string InstallPartRevision { get; set; }
Property Value
Type | Description
System.String |

InstallPrice

Declaration
[PropertyBitValue(65536)]
public string InstallPrice { get; set; }
Property Value
Type | Description
System.String |

InstallQuantity

Declaration
[PropertyBitValue(32768)]
public int InstallQuantity { get; set; }
Property Value
Type | Description
System.Int32 |

InstallSerialNumber

Declaration
[PropertyBitValue(16384)]
public string InstallSerialNumber { get; set; }
Property Value
Type | Description
System.String |

LogDate

Declaration
[PropertyBitValue(16777216)]
public DateTime LogDate { get; set; }
Property Value
Type | Description
System.DateTime |

ParentSitePartObjid

Declaration
[PropertyBitValue(8)]
public int ParentSitePartObjid { get; set; }
Property Value
Type | Description
System.Int32 |

PartRequestDetailIDNum

Declaration
[PropertyBitValue(1)]
public string PartRequestDetailIDNum { get; set; }
Property Value
Type | Description
System.String |

RemoveSitePartObjid

Declaration
[PropertyBitValue(32)]
public int RemoveSitePartObjid { get; set; }
Property Value
Type | Description
System.Int32 |

ToBin

Declaration
[PropertyBitValue(128)]
public string ToBin { get; set; }
Property Value
Type | Description
System.String |

ToContainer

Declaration
[PropertyBitValue(256)]
public string ToContainer { get; set; }
Property Value
Type | Description
System.String |

ToGood

Declaration
[PropertyBitValue(512)]
public bool ToGood { get; set; }
Property Value
Type | Description
System.Boolean |

ToLocation

Declaration
[PropertyBitValue(64)]
public string ToLocation { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(4194304)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class MoveSitePartToBinSetup | fcSDK Documentation

Class MoveSitePartToBinSetup

Inheritance
System.Object
MoveSitePartToBinSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.FieldOps
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class MoveSitePartToBinSetup

Constructors

MoveSitePartToBinSetup(Int32, Int32)

Declaration
[ConstructorIndex(0)]
public MoveSitePartToBinSetup(int sitePartObjid, int parentBinObjid)
Parameters
Type | Name | Description
System.Int32 | sitePartObjid |
System.Int32 | parentBinObjid |

Properties

AddActivityLog

Declaration
[PropertyBitValue(32)]
public bool AddActivityLog { get; set; }
Property Value
Type | Description
System.Boolean |

InstallAndMove

Declaration
[PropertyBitValue(128)]
public bool InstallAndMove { get; set; }
Property Value
Type | Description
System.Boolean |

MoveDate

Declaration
[PropertyBitValue(2)]
public DateTime MoveDate { get; set; }
Property Value
Type | Description
System.DateTime |

ParentBinObjid

Declaration
[PropertyBitValue(16)]
public int ParentBinObjid { get; set; }
Property Value
Type | Description
System.Int32 |

SitePartObjid

Declaration
[PropertyBitValue(1)]
public int SitePartObjid { get; set; }
Property Value
Type | Description
System.Int32 |

UserName

Declaration
[PropertyBitValue(64)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class MoveSitePartToPartSetup | fcSDK Documentation

Class MoveSitePartToPartSetup

Inheritance
System.Object
MoveSitePartToPartSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.FieldOps
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class MoveSitePartToPartSetup

Constructors

MoveSitePartToPartSetup(Int32, Int32)

Declaration
[ConstructorIndex(0)]
public MoveSitePartToPartSetup(int sitePartObjid, int parentSitePartObjid)
Parameters
Type | Name | Description
System.Int32 | sitePartObjid |
System.Int32 | parentSitePartObjid |

Properties

AddActivityLog

Declaration
[PropertyBitValue(32)]
public bool AddActivityLog { get; set; }
Property Value
Type | Description
System.Boolean |

InstallAndMove

Declaration
[PropertyBitValue(128)]
public bool InstallAndMove { get; set; }
Property Value
Type | Description
System.Boolean |

MoveDate

Declaration
[PropertyBitValue(2)]
public DateTime MoveDate { get; set; }
Property Value
Type | Description
System.DateTime |

ParentSitePartObjid

Declaration
[PropertyBitValue(4)]
public int ParentSitePartObjid { get; set; }
Property Value
Type | Description
System.Int32 |

SitePartObjid

Declaration
[PropertyBitValue(1)]
public int SitePartObjid { get; set; }
Property Value
Type | Description
System.Int32 |

UserName

Declaration
[PropertyBitValue(64)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class MoveSitePartToSiteSetup | fcSDK Documentation

Class MoveSitePartToSiteSetup

Inheritance
System.Object
MoveSitePartToSiteSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.FieldOps
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class MoveSitePartToSiteSetup

Constructors

MoveSitePartToSiteSetup(Int32, String)

Declaration
[ConstructorIndex(0)]
public MoveSitePartToSiteSetup(int sitePartObjid, string siteIDNum)
Parameters
Type | Name | Description
System.Int32 | sitePartObjid |
System.String | siteIDNum |

Properties

AddActivityLog

Declaration
[PropertyBitValue(32)]
public bool AddActivityLog { get; set; }
Property Value
Type | Description
System.Boolean |

InstallAndMove

Declaration
[PropertyBitValue(128)]
public bool InstallAndMove { get; set; }
Property Value
Type | Description
System.Boolean |

MoveDate

Declaration
[PropertyBitValue(2)]
public DateTime MoveDate { get; set; }
Property Value
Type | Description
System.DateTime |

SiteIDNum

Declaration
[PropertyBitValue(8)]
public string SiteIDNum { get; set; }
Property Value
Type | Description
System.String |

SitePartObjid

Declaration
[PropertyBitValue(1)]
public int SitePartObjid { get; set; }
Property Value
Type | Description
System.Int32 |

UserName

Declaration
[PropertyBitValue(64)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class PartTransferResult | fcSDK Documentation

Class PartTransferResult

Inheritance
System.Object
ToolkitResult
PartTransferResult
Inherited Members
ToolkitResult._ReturnCode
ToolkitResult._IDNum
ToolkitResult._Objid
ToolkitResult.ReturnCode
ToolkitResult.IDNum
ToolkitResult.Objid
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.FieldOps
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class PartTransferResult : ToolkitResult

Constructors

PartTransferResult()

Declaration
public PartTransferResult()

Properties

StandardCost

Declaration
public decimal StandardCost { get; set; }
Property Value
Type | Description
System.Decimal |

TransactionIDNum

Declaration
public string TransactionIDNum { get; set; }
Property Value
Type | Description
System.String |


Class PartTransferSetup | fcSDK Documentation

Class PartTransferSetup

Inheritance
System.Object
PartTransferSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.FieldOps
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class PartTransferSetup

Constructors

PartTransferSetup(String, String, String, Int32, Location, Location)

Declaration
[ConstructorIndex(0)]
public PartTransferSetup(string partNumber, string partRevision, string partDomain, int quantity, Location fromlocation, Location tolocation)
Parameters
Type | Name | Description
System.String | partNumber |
System.String | partRevision |
System.String | partDomain |
System.Int32 | quantity |
Location | fromlocation |
Location | tolocation |

PartTransferSetup(String, String, String, String, Location, Location)

Declaration
[ConstructorIndex(1)]
public PartTransferSetup(string partNumber, string partRevision, string partDomain, string serialNumber, Location fromlocation, Location tolocation)
Parameters
Type | Name | Description
System.String | partNumber |
System.String | partRevision |
System.String | partDomain |
System.String | serialNumber |
Location | fromlocation |
Location | tolocation |

Properties

FromGood

Declaration
[PropertyBitValue(256)]
public bool FromGood { get; set; }
Property Value
Type | Description
System.Boolean |

FromLocation

Declaration
[PropertyBitValue(8388608)]
public Location FromLocation { get; set; }
Property Value
Type | Description
Location |

GenerateTimeBombs

Declaration
[PropertyBitValue(131072)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

Notes

Declaration
[PropertyBitValue(65536)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

PartDomain

Declaration
[PropertyBitValue(4)]
public string PartDomain { get; set; }
Property Value
Type | Description
System.String |

PartNumber

Declaration
[PropertyBitValue(1)]
public string PartNumber { get; set; }
Property Value
Type | Description
System.String |

PartRevision

Declaration
[PropertyBitValue(2)]
public string PartRevision { get; set; }
Property Value
Type | Description
System.String |

Quantity

Declaration
[PropertyBitValue(8)]
public int Quantity { get; set; }
Property Value
Type | Description
System.Int32 |

ReferenceIDNum

Declaration
[PropertyBitValue(32768)]
public string ReferenceIDNum { get; set; }
Property Value
Type | Description
System.String |

SerialNumber

Declaration
[PropertyBitValue(16)]
public string SerialNumber { get; set; }
Property Value
Type | Description
System.String |

ToGood

Declaration
[PropertyBitValue(4096)]
public bool ToGood { get; set; }
Property Value
Type | Description
System.Boolean |

ToLocation

Declaration
[PropertyBitValue(16777216)]
public Location ToLocation { get; set; }
Property Value
Type | Description
Location |

TransferDate

Declaration
[PropertyBitValue(16384)]
public DateTime TransferDate { get; set; }
Property Value
Type | Description
System.DateTime |

UserName

Declaration
[PropertyBitValue(8192)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class ReinstallSitePartSetup | fcSDK Documentation

Class ReinstallSitePartSetup

Inheritance
System.Object
ReinstallSitePartSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.FieldOps
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ReinstallSitePartSetup

Constructors

ReinstallSitePartSetup(Int32, String)

Declaration
[ConstructorIndex(0)]
public ReinstallSitePartSetup(int sitePartObjid, string siteIDNum)
Parameters
Type | Name | Description
System.Int32 | sitePartObjid |
System.String | siteIDNum |

Properties

AddActivityLog

Declaration
[PropertyBitValue(64)]
public bool AddActivityLog { get; set; }
Property Value
Type | Description
System.Boolean |

ParentBinObjid

Declaration
[PropertyBitValue(4)]
public int ParentBinObjid { get; set; }
Property Value
Type | Description
System.Int32 |

ParentSitePartObjid

Declaration
[PropertyBitValue(8)]
public int ParentSitePartObjid { get; set; }
Property Value
Type | Description
System.Int32 |

ReinstallDate

Declaration
[PropertyBitValue(32)]
public DateTime ReinstallDate { get; set; }
Property Value
Type | Description
System.DateTime |

SiteIDNum

Declaration
[PropertyBitValue(2)]
public string SiteIDNum { get; set; }
Property Value
Type | Description
System.String |

SitePartObjid

Declaration
[PropertyBitValue(1)]
public int SitePartObjid { get; set; }
Property Value
Type | Description
System.Int32 |

UseInstall

Declaration
[PropertyBitValue(128)]
public bool UseInstall { get; set; }
Property Value
Type | Description
System.Boolean |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class StageInventoryToolkit | fcSDK Documentation

Class StageInventoryToolkit

Inheritance
System.Object
StageInventoryToolkit
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.FieldOps
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class StageInventoryToolkit

Constructors

StageInventoryToolkit(ClarifySession)

Declaration
public StageInventoryToolkit(ClarifySession clarifySession)
Parameters
Type | Name | Description
ClarifySession | clarifySession |

Fields

StagedFrom

Declaration
public static readonly int StagedFrom
Field Value
Type | Description
System.Int32 |

StagedTo

Declaration
public static readonly int StagedTo
Field Value
Type | Description
System.Int32 |

Methods

StageInstallForInventoryBin(Int32, String, String, Int32)

Declaration
public void StageInstallForInventoryBin(int partUsedObjid, string locationName, string locationBinName, int stagedAs)
Parameters
Type | Name | Description
System.Int32 | partUsedObjid |
System.String | locationName |
System.String | locationBinName |
System.Int32 | stagedAs |


Class UpdateAppointmentSetup | fcSDK Documentation

Class UpdateAppointmentSetup

Inheritance
System.Object
UpdateAppointmentSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.FieldOps
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdateAppointmentSetup

Constructors

UpdateAppointmentSetup(Int32)

Declaration
[ConstructorIndex(0)]
public UpdateAppointmentSetup(int appointmentObjid)
Parameters
Type | Name | Description
System.Int32 | appointmentObjid |

Properties

AppointmentClass

Declaration
[PropertyBitValue(64)]
public string AppointmentClass { get; set; }
Property Value
Type | Description
System.String |

AppointmentObjid

Declaration
[PropertyBitValue(1)]
public int AppointmentObjid { get; set; }
Property Value
Type | Description
System.Int32 |

AppointmentType

Declaration
[PropertyBitValue(128)]
public string AppointmentType { get; set; }
Property Value
Type | Description
System.String |

CellText

Declaration
[PropertyBitValue(32)]
public string CellText { get; set; }
Property Value
Type | Description
System.String |

CreateDate

Declaration
[PropertyBitValue(512)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

Description

Declaration
[PropertyBitValue(16)]
public string Description { get; set; }
Property Value
Type | Description
System.String |

Duration

Declaration
[PropertyBitValue(8)]
public TimeSpan Duration { get; set; }
Property Value
Type | Description
System.TimeSpan |

EndDate

Declaration
[PropertyBitValue(4)]
public DateTime EndDate { get; set; }
Property Value
Type | Description
System.DateTime |

StartDate

Declaration
[PropertyBitValue(2)]
public DateTime StartDate { get; set; }
Property Value
Type | Description
System.DateTime |

UserName

Declaration
[PropertyBitValue(256)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class UpdateExpenseLogSetup | fcSDK Documentation

Class UpdateExpenseLogSetup

Inheritance
System.Object
UpdateExpenseLogSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.FieldOps
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdateExpenseLogSetup

Constructors

UpdateExpenseLogSetup(Int32, Double, Double)

Declaration
[ConstructorIndex(0)]
public UpdateExpenseLogSetup(int expenseLogObjid, double quantity, double rate)
Parameters
Type | Name | Description
System.Int32 | expenseLogObjid |
System.Double | quantity |
System.Double | rate |

Properties

BillTo

Declaration
[PropertyBitValue(512)]
public string BillTo { get; set; }
Property Value
Type | Description
System.String |

CreateDate

Declaration
[PropertyBitValue(2)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

ExpenseLogObjid

Declaration
[PropertyBitValue(1)]
public int ExpenseLogObjid { get; set; }
Property Value
Type | Description
System.Int32 |

ExpenseType

Declaration
[PropertyBitValue(32)]
public string ExpenseType { get; set; }
Property Value
Type | Description
System.String |

IsBillable

Declaration
[PropertyBitValue(256)]
public bool IsBillable { get; set; }
Property Value
Type | Description
System.Boolean |

Notes

Declaration
[PropertyBitValue(8)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

PerformedByUserName

Declaration
[PropertyBitValue(4)]
public string PerformedByUserName { get; set; }
Property Value
Type | Description
System.String |

Quantity

Declaration
[PropertyBitValue(64)]
public double Quantity { get; set; }
Property Value
Type | Description
System.Double |

Rate

Declaration
[PropertyBitValue(128)]
public double Rate { get; set; }
Property Value
Type | Description
System.Double |

Resolution

Declaration
[PropertyBitValue(1024)]
public string Resolution { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class UpdateServiceInterruptionSetup | fcSDK Documentation

Class UpdateServiceInterruptionSetup

Inheritance
System.Object
UpdateServiceInterruptionSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.FieldOps
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdateServiceInterruptionSetup

Constructors

UpdateServiceInterruptionSetup(Int32)

Declaration
[ConstructorIndex(0)]
public UpdateServiceInterruptionSetup(int appointmentObjid)
Parameters
Type | Name | Description
System.Int32 | appointmentObjid |

Properties

AppointmentObjid

Declaration
[PropertyBitValue(1)]
public int AppointmentObjid { get; set; }
Property Value
Type | Description
System.Int32 |

CreateDate

Declaration
[PropertyBitValue(256)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

Description

Declaration
[PropertyBitValue(2)]
public string Description { get; set; }
Property Value
Type | Description
System.String |

Duration

Declaration
[PropertyBitValue(16)]
public TimeSpan Duration { get; set; }
Property Value
Type | Description
System.TimeSpan |

EndDate

Declaration
[PropertyBitValue(8)]
public DateTime EndDate { get; set; }
Property Value
Type | Description
System.DateTime |

ServiceClass

Declaration
[PropertyBitValue(32)]
public string ServiceClass { get; set; }
Property Value
Type | Description
System.String |

ServiceType

Declaration
[PropertyBitValue(64)]
public string ServiceType { get; set; }
Property Value
Type | Description
System.String |

StartDate

Declaration
[PropertyBitValue(4)]
public DateTime StartDate { get; set; }
Property Value
Type | Description
System.DateTime |

UserName

Declaration
[PropertyBitValue(128)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class UpdateSitePartSetup | fcSDK Documentation

Class UpdateSitePartSetup

Inheritance
System.Object
UpdateSitePartSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.FieldOps
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdateSitePartSetup

Constructors

UpdateSitePartSetup(Int32)

Declaration
[ConstructorIndex(0)]
public UpdateSitePartSetup(int sitePartObjid)
Parameters
Type | Name | Description
System.Int32 | sitePartObjid |

Properties

AddActivityLog

Declaration
[PropertyBitValue(8192)]
public bool AddActivityLog { get; set; }
Property Value
Type | Description
System.Boolean |

AdditionalFields

Declaration
[PropertyBitValue(16384)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

Comments

Declaration
[PropertyBitValue(512)]
public string Comments { get; set; }
Property Value
Type | Description
System.String |

InstallDate

Declaration
[PropertyBitValue(32)]
public DateTime InstallDate { get; set; }
Property Value
Type | Description
System.DateTime |

InstanceName

Declaration
[PropertyBitValue(2)]
public string InstanceName { get; set; }
Property Value
Type | Description
System.String |

InvoiceNumber

Declaration
[PropertyBitValue(8)]
public string InvoiceNumber { get; set; }
Property Value
Type | Description
System.String |

PartRevision

Declaration
[PropertyBitValue(4096)]
public string PartRevision { get; set; }
Property Value
Type | Description
System.String |

PartStatus

Declaration
[PropertyBitValue(256)]
public string PartStatus { get; set; }
Property Value
Type | Description
System.String |

Quantity

Declaration
[PropertyBitValue(128)]
public int Quantity { get; set; }
Property Value
Type | Description
System.Int32 |

SerialNumber

Declaration
[PropertyBitValue(4)]
public string SerialNumber { get; set; }
Property Value
Type | Description
System.String |

ServiceEndDate

Declaration
[PropertyBitValue(1024)]
public DateTime ServiceEndDate { get; set; }
Property Value
Type | Description
System.DateTime |

ShipDate

Declaration
[PropertyBitValue(16)]
public DateTime ShipDate { get; set; }
Property Value
Type | Description
System.DateTime |

SitePartObjid

Declaration
[PropertyBitValue(1)]
public int SitePartObjid { get; set; }
Property Value
Type | Description
System.Int32 |

UserName

Declaration
[PropertyBitValue(2048)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WarrantyDate

Declaration
[PropertyBitValue(64)]
public DateTime WarrantyDate { get; set; }
Property Value
Type | Description
System.DateTime |


Class UpdateTimeLogSetup | fcSDK Documentation

Class UpdateTimeLogSetup

Inheritance
System.Object
UpdateTimeLogSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.FieldOps
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdateTimeLogSetup

Constructors

UpdateTimeLogSetup(Int32)

Declaration
[ConstructorIndex(0)]
public UpdateTimeLogSetup(int timeLogObjid)
Parameters
Type | Name | Description
System.Int32 | timeLogObjid |

Properties

BillTo

Declaration
[PropertyBitValue(512)]
public string BillTo { get; set; }
Property Value
Type | Description
System.String |

CreateDate

Declaration
[PropertyBitValue(2)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

Duration

Declaration
[PropertyBitValue(128)]
public TimeSpan Duration { get; set; }
Property Value
Type | Description
System.TimeSpan |

IsBillable

Declaration
[PropertyBitValue(256)]
public bool IsBillable { get; set; }
Property Value
Type | Description
System.Boolean |

Notes

Declaration
[PropertyBitValue(8)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

PerformedByUserName

Declaration
[PropertyBitValue(4)]
public string PerformedByUserName { get; set; }
Property Value
Type | Description
System.String |

Resolution

Declaration
[PropertyBitValue(2048)]
public string Resolution { get; set; }
Property Value
Type | Description
System.String |

StartTime

Declaration
[PropertyBitValue(64)]
public DateTime StartTime { get; set; }
Property Value
Type | Description
System.DateTime |

TimeLogObjid

Declaration
[PropertyBitValue(1)]
public int TimeLogObjid { get; set; }
Property Value
Type | Description
System.Int32 |

TimeType

Declaration
[PropertyBitValue(32)]
public string TimeType { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WorkCenter

Declaration
[PropertyBitValue(1024)]
public string WorkCenter { get; set; }
Property Value
Type | Description
System.String |


Namespace FChoice.Toolkits.Clarify.Interfaces | fcSDK Documentation

Namespace FChoice.Toolkits.Clarify.Interfaces

Classes

AcceptSolutionSetup

AddContactToContractSetup

AddEmployeeToAccountSetup

AddSitePartToContractSetup

AddSiteToAccountSetup

AddSiteToContractSetup

AddUserToQueueSetup

AddWorkaroundSetup

AssignSolutionSetup

CreateAccountSetup

CreateAddressSetup

CreateBOMSetup

CreateChannelSetup

CreateCommunicationSetup

CreateContactSetup

CreateContractSetup

CreateCountrySetup

CreateDialogueSetup

CreateEmployeeResult

CreateEmployeeSetup

CreateInteractionSetup

CreatePartRevisionSetup

CreatePartSetup

CreatePriceInstanceSetup

CreateProductBinSetup

CreateQueueSetup

CreateSiteSetup

CreateSolutionResult

CreateSolutionSetup

CreateStateSetup

CreateTimeZoneSetup

CreateWipBinSetup

DeinstallSitePartSetup

DeleteProductBinSetup

DispatchSolutionSetup

ForwardSolutionSetup

InstallSitePartToBinSetup

InstallSitePartToPartSetup

InstallSitePartToSiteSetup

InterfacesToolkit

InterfacesToolkitBase

LinkCaseToWorkaroundSetup

LinkCRToSolutionSetup

MoveSitePartToBinSetup

MoveSitePartToPartSetup

MoveSitePartToSiteSetup

MoveSolutionSetup

ReinstallSitePartToBinSetup

ReinstallSitePartToPartSetup

ReinstallSitePartToSiteSetup

RejectSolutionSetup

RemoveContactFromContractSetup

RemoveEmployeeFromAccountSetup

RemoveSiteFromAccountSetup

RemoveSiteFromContractSetup

RemoveSitePartFromContractSetup

ReopenDialogueSetup

UnlinkCaseFromWorkaroundSetup

UnlinkCRFromSolutionSetup

UpdateAccountSetup

UpdateAddressSetup

UpdateCommunicationSetup

UpdateContactByObjidSetup

UpdateContactSetup

UpdateContractSetup

UpdateDialogueSetup

UpdatePartRevisionSetup

UpdatePartSetup

UpdatePriceInstanceSetup

UpdateProductBinSetup

UpdateQueueSetup

UpdateSiteByObjidSetup

UpdateSitePartSetup

UpdateSiteSetup

UpdateWipBinSetup

YankSolutionSetup

Back to top © 2022 Dovetail Software, Inc. - All rights reserved.
Clarify, Amdocs, and related products and names are copyright and trademark of Amdocs, Inc.
.NET, Visual Studio.NET, C#, Visual Basic and related products are trademark of Microsoft corporation.


Class AcceptSolutionSetup | fcSDK Documentation

Class AcceptSolutionSetup

Inheritance
System.Object
AcceptSolutionSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class AcceptSolutionSetup

Constructors

AcceptSolutionSetup(String)

Declaration
[ConstructorIndex(0)]
public AcceptSolutionSetup(string solutionIDNum)
Parameters
Type | Name | Description
System.String | solutionIDNum |

Properties

AcceptDate

Declaration
[PropertyBitValue(2)]
public DateTime AcceptDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(16)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

SolutionIDNum

Declaration
[PropertyBitValue(1)]
public string SolutionIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(4)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |


Class AddContactToContractSetup | fcSDK Documentation

Class AddContactToContractSetup

Inheritance
System.Object
AddContactToContractSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class AddContactToContractSetup

Constructors

AddContactToContractSetup(String, String, String, String, String)

Declaration
[ConstructorIndex(0)]
public AddContactToContractSetup(string contractIDNum, string contactFirstName, string contactLastName, string contactPhone, string siteIDNum)
Parameters
Type | Name | Description
System.String | contractIDNum |
System.String | contactFirstName |
System.String | contactLastName |
System.String | contactPhone |
System.String | siteIDNum |

Properties

ContactFirstName

Declaration
[PropertyBitValue(2)]
public string ContactFirstName { get; set; }
Property Value
Type | Description
System.String |

ContactLastName

Declaration
[PropertyBitValue(4)]
public string ContactLastName { get; set; }
Property Value
Type | Description
System.String |

ContactPhone

Declaration
[PropertyBitValue(8)]
public string ContactPhone { get; set; }
Property Value
Type | Description
System.String |

ContractIDNum

Declaration
[PropertyBitValue(1)]
public string ContractIDNum { get; set; }
Property Value
Type | Description
System.String |

SiteIDNum

Declaration
[PropertyBitValue(16)]
public string SiteIDNum { get; set; }
Property Value
Type | Description
System.String |


Class AddEmployeeToAccountSetup | fcSDK Documentation

Class AddEmployeeToAccountSetup

Inheritance
System.Object
AddEmployeeToAccountSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class AddEmployeeToAccountSetup

Constructors

AddEmployeeToAccountSetup(String, String)

Declaration
[ConstructorIndex(0)]
public AddEmployeeToAccountSetup(string userName, string accountIDNum)
Parameters
Type | Name | Description
System.String | userName |
System.String | accountIDNum |

Properties

AccountIDNum

Declaration
[PropertyBitValue(2)]
public string AccountIDNum { get; set; }
Property Value
Type | Description
System.String |

RoleName

Declaration
[PropertyBitValue(4)]
public string RoleName { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(1)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class AddSitePartToContractSetup | fcSDK Documentation

Class AddSitePartToContractSetup

Inheritance
System.Object
AddSitePartToContractSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class AddSitePartToContractSetup

Constructors

AddSitePartToContractSetup(String, String, Int32)

Declaration
[ConstructorIndex(0)]
public AddSitePartToContractSetup(string contractIDNum, string siteIDNum, int sitePartObjid)
Parameters
Type | Name | Description
System.String | contractIDNum |
System.String | siteIDNum |
System.Int32 | sitePartObjid |

Properties

ContractIDNum

Declaration
[PropertyBitValue(1)]
public string ContractIDNum { get; set; }
Property Value
Type | Description
System.String |

SiteIDNum

Declaration
[PropertyBitValue(2)]
public string SiteIDNum { get; set; }
Property Value
Type | Description
System.String |

SitePartObjid

Declaration
[PropertyBitValue(4)]
public int SitePartObjid { get; set; }
Property Value
Type | Description
System.Int32 |


Class AddSiteToAccountSetup | fcSDK Documentation

Class AddSiteToAccountSetup

Inheritance
System.Object
AddSiteToAccountSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class AddSiteToAccountSetup

Constructors

AddSiteToAccountSetup(String, String, String)

Declaration
[ConstructorIndex(0)]
public AddSiteToAccountSetup(string siteIDNum, string accountIDNum, string roleName)
Parameters
Type | Name | Description
System.String | siteIDNum |
System.String | accountIDNum |
System.String | roleName |

Properties

AccountIDNum

Declaration
[PropertyBitValue(2)]
public string AccountIDNum { get; set; }
Property Value
Type | Description
System.String |

RoleName

Declaration
[PropertyBitValue(4)]
public string RoleName { get; set; }
Property Value
Type | Description
System.String |

SiteIDNum

Declaration
[PropertyBitValue(1)]
public string SiteIDNum { get; set; }
Property Value
Type | Description
System.String |


Class AddSiteToContractSetup | fcSDK Documentation

Class AddSiteToContractSetup

Inheritance
System.Object
AddSiteToContractSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class AddSiteToContractSetup

Constructors

AddSiteToContractSetup(String, String)

Declaration
[ConstructorIndex(0)]
public AddSiteToContractSetup(string contractIDNum, string siteIDNum)
Parameters
Type | Name | Description
System.String | contractIDNum |
System.String | siteIDNum |

Properties

ContractIDNum

Declaration
[PropertyBitValue(1)]
public string ContractIDNum { get; set; }
Property Value
Type | Description
System.String |

SiteIDNum

Declaration
[PropertyBitValue(2)]
public string SiteIDNum { get; set; }
Property Value
Type | Description
System.String |


Class AddUserToQueueSetup | fcSDK Documentation

Class AddUserToQueueSetup

Inheritance
System.Object
AddUserToQueueSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class AddUserToQueueSetup

Constructors

AddUserToQueueSetup(String, String)

Declaration
[ConstructorIndex(0)]
public AddUserToQueueSetup(string queue, string userName)
Parameters
Type | Name | Description
System.String | queue |
System.String | userName |

Properties

IsSupervisor

Declaration
[PropertyBitValue(4)]
public bool IsSupervisor { get; set; }
Property Value
Type | Description
System.Boolean |

Queue

Declaration
[PropertyBitValue(1)]
public string Queue { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(2)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class AddWorkaroundSetup | fcSDK Documentation

Class AddWorkaroundSetup

Inheritance
System.Object
AddWorkaroundSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class AddWorkaroundSetup

Constructors

AddWorkaroundSetup(Int32, String)

Declaration
[ConstructorIndex(1)]
public AddWorkaroundSetup(int solutionObjid, string workaround)
Parameters
Type | Name | Description
System.Int32 | solutionObjid |
System.String | workaround |

AddWorkaroundSetup(String, String)

Declaration
[ConstructorIndex(0)]
public AddWorkaroundSetup(string solutionIDNum, string workaround)
Parameters
Type | Name | Description
System.String | solutionIDNum |
System.String | workaround |

Properties

AdditionalFields

Declaration
[PropertyBitValue(64)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

CreateDate

Declaration
[PropertyBitValue(16)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

IsPublic

Declaration
[PropertyBitValue(8)]
public bool IsPublic { get; set; }
Property Value
Type | Description
System.Boolean |

ResolutionCode

Declaration
[PropertyBitValue(32)]
public string ResolutionCode { get; set; }
Property Value
Type | Description
System.String |

SolutionIDNum

Declaration
[PropertyBitValue(1)]
public string SolutionIDNum { get; set; }
Property Value
Type | Description
System.String |

SolutionObjid

Declaration
[PropertyBitValue(2)]
public int SolutionObjid { get; set; }
Property Value
Type | Description
System.Int32 |

Workaround

Declaration
[PropertyBitValue(4)]
public string Workaround { get; set; }
Property Value
Type | Description
System.String |


Class AssignSolutionSetup | fcSDK Documentation

Class AssignSolutionSetup

Inheritance
System.Object
AssignSolutionSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class AssignSolutionSetup

Constructors

AssignSolutionSetup(String)

Declaration
[ConstructorIndex(0)]
public AssignSolutionSetup(string solutionIDNum)
Parameters
Type | Name | Description
System.String | solutionIDNum |

Properties

AssignDate

Declaration
[PropertyBitValue(8)]
public DateTime AssignDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

NewUser

Declaration
[PropertyBitValue(2)]
public string NewUser { get; set; }
Property Value
Type | Description
System.String |

SolutionIDNum

Declaration
[PropertyBitValue(1)]
public string SolutionIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(4)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |


Class CreateAccountSetup | fcSDK Documentation

Class CreateAccountSetup

Inheritance
System.Object
CreateAccountSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateAccountSetup

Constructors

CreateAccountSetup()

Declaration
[ConstructorIndex(0)]
public CreateAccountSetup()

Properties

AccountName

Declaration
[PropertyBitValue(1)]
public string AccountName { get; set; }
Property Value
Type | Description
System.String |

AccountType

Declaration
[PropertyBitValue(32)]
public string AccountType { get; set; }
Property Value
Type | Description
System.String |

AdditionalFields

Declaration
[PropertyBitValue(65536)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

CreateDate

Declaration
[PropertyBitValue(8192)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

Description

Declaration
[PropertyBitValue(2)]
public string Description { get; set; }
Property Value
Type | Description
System.String |

Fax

Declaration
[PropertyBitValue(1024)]
public string Fax { get; set; }
Property Value
Type | Description
System.String |

FiscalYear

Declaration
[PropertyBitValue(16)]
public string FiscalYear { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(16384)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

Ownership

Declaration
[PropertyBitValue(256)]
public string Ownership { get; set; }
Property Value
Type | Description
System.String |

Phone

Declaration
[PropertyBitValue(512)]
public string Phone { get; set; }
Property Value
Type | Description
System.String |

Revenue

Declaration
[PropertyBitValue(128)]
public string Revenue { get; set; }
Property Value
Type | Description
System.String |

Size

Declaration
[PropertyBitValue(64)]
public string Size { get; set; }
Property Value
Type | Description
System.String |

Stock

Declaration
[PropertyBitValue(8)]
public string Stock { get; set; }
Property Value
Type | Description
System.String |

Territory

Declaration
[PropertyBitValue(4)]
public string Territory { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(4096)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WebSite

Declaration
[PropertyBitValue(2048)]
public string WebSite { get; set; }
Property Value
Type | Description
System.String |


Class CreateAddressSetup | fcSDK Documentation

Class CreateAddressSetup

Inheritance
System.Object
CreateAddressSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateAddressSetup

Constructors

CreateAddressSetup(String, String, String, String, String, String)

Declaration
[ConstructorIndex(0)]
public CreateAddressSetup(string address1, string city, string state, string zipCode, string country, string timeZone)
Parameters
Type | Name | Description
System.String | address1 |
System.String | city |
System.String | state |
System.String | zipCode |
System.String | country |
System.String | timeZone |

Properties

AdditionalFields

Declaration
[PropertyBitValue(256)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

Address1

Declaration
[PropertyBitValue(1)]
public string Address1 { get; set; }
Property Value
Type | Description
System.String |

Address2

Declaration
[PropertyBitValue(2)]
public string Address2 { get; set; }
Property Value
Type | Description
System.String |

City

Declaration
[PropertyBitValue(4)]
public string City { get; set; }
Property Value
Type | Description
System.String |

Country

Declaration
[PropertyBitValue(64)]
public string Country { get; set; }
Property Value
Type | Description
System.String |

IsShortState

Declaration
[PropertyBitValue(16)]
public bool IsShortState { get; set; }
Property Value
Type | Description
System.Boolean |

State

Declaration
[PropertyBitValue(8)]
public string State { get; set; }
Property Value
Type | Description
System.String |

TimeZone

Declaration
[PropertyBitValue(128)]
public string TimeZone { get; set; }
Property Value
Type | Description
System.String |

ZipCode

Declaration
[PropertyBitValue(32)]
public string ZipCode { get; set; }
Property Value
Type | Description
System.String |


Class CreateBOMSetup | fcSDK Documentation

Class CreateBOMSetup

Inheritance
System.Object
CreateBOMSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateBOMSetup

Constructors

CreateBOMSetup(String, String, String, String, String, String, Int32)

Declaration
[ConstructorIndex(0)]
public CreateBOMSetup(string parentPartNumber, string parentPartDomain, string parentPartRevision, string childPartNumber, string childPartDomain, string childPartRevision, int quantity)
Parameters
Type | Name | Description
System.String | parentPartNumber |
System.String | parentPartDomain |
System.String | parentPartRevision |
System.String | childPartNumber |
System.String | childPartDomain |
System.String | childPartRevision |
System.Int32 | quantity |

Properties

ChildPartDomain

Declaration
[PropertyBitValue(16)]
public string ChildPartDomain { get; set; }
Property Value
Type | Description
System.String |

ChildPartNumber

Declaration
[PropertyBitValue(8)]
public string ChildPartNumber { get; set; }
Property Value
Type | Description
System.String |

ChildPartRevision

Declaration
[PropertyBitValue(32)]
public string ChildPartRevision { get; set; }
Property Value
Type | Description
System.String |

ParentPartDomain

Declaration
[PropertyBitValue(2)]
public string ParentPartDomain { get; set; }
Property Value
Type | Description
System.String |

ParentPartNumber

Declaration
[PropertyBitValue(1)]
public string ParentPartNumber { get; set; }
Property Value
Type | Description
System.String |

ParentPartRevision

Declaration
[PropertyBitValue(4)]
public string ParentPartRevision { get; set; }
Property Value
Type | Description
System.String |

Quantity

Declaration
[PropertyBitValue(64)]
public int Quantity { get; set; }
Property Value
Type | Description
System.Int32 |


Class CreateChannelSetup | fcSDK Documentation

Class CreateChannelSetup

Inheritance
System.Object
CreateChannelSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateChannelSetup

Constructors

CreateChannelSetup(Int32, String)

Declaration
public CreateChannelSetup(int mediumObjid, string designation)
Parameters
Type | Name | Description
System.Int32 | mediumObjid |
System.String | designation |

Properties

AdditionalFields

Declaration
public SimplifiedAdditionalFields AdditionalFields { get; }
Property Value
Type | Description
SimplifiedAdditionalFields |

AllowInbound

Declaration
public bool AllowInbound { get; set; }
Property Value
Type | Description
System.Boolean |

AllowOutbound

Declaration
public bool AllowOutbound { get; set; }
Property Value
Type | Description
System.Boolean |

Description

Declaration
public string Description { get; set; }
Property Value
Type | Description
System.String |

Designation

Declaration
public string Designation { get; set; }
Property Value
Type | Description
System.String |

IsActive

Declaration
public bool IsActive { get; set; }
Property Value
Type | Description
System.Boolean |

Location

Declaration
public string Location { get; set; }
Property Value
Type | Description
System.String |

MediumObjid

Declaration
public int MediumObjid { get; set; }
Property Value
Type | Description
System.Int32 |

Title

Declaration
public string Title { get; set; }
Property Value
Type | Description
System.String |


Class CreateCommunicationSetup | fcSDK Documentation

Class CreateCommunicationSetup

Inheritance
System.Object
CreateCommunicationSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateCommunicationSetup

Constructors

CreateCommunicationSetup(String, String, Int32, String, String[])

Declaration
public CreateCommunicationSetup(string dialogueIdNumber, string title, int channelObjid, string sender, string[] recipients)
Parameters
Type | Name | Description
System.String | dialogueIdNumber |
System.String | title |
System.Int32 | channelObjid |
System.String | sender |
System.String[] | recipients |

Properties

AdditionalFields

Declaration
public SimplifiedAdditionalFields AdditionalFields { get; }
Property Value
Type | Description
SimplifiedAdditionalFields |

AutoExec

Declaration
public CommunicationAutoExec AutoExec { get; set; }
Property Value
Type | Description
CommunicationAutoExec |

BCCRecipients

Declaration
public string[] BCCRecipients { get; set; }
Property Value
Type | Description
System.String[] |

CCRecipients

Declaration
public string[] CCRecipients { get; set; }
Property Value
Type | Description
System.String[] |

ChannelObjid

Declaration
public int ChannelObjid { get; set; }
Property Value
Type | Description
System.Int32 |

Created

Declaration
public DateTime Created { get; set; }
Property Value
Type | Description
System.DateTime |

DeliveryStatus

Declaration
public CommunicationDeliveryStatus DeliveryStatus { get; set; }
Property Value
Type | Description
CommunicationDeliveryStatus |

DialogIDNumber

Declaration
public string DialogIDNumber { get; set; }
Property Value
Type | Description
System.String |

Direction

Declaration
public CommunicationDirection Direction { get; set; }
Property Value
Type | Description
CommunicationDirection |

GenerateTimeBombs

Declaration
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

Message

Declaration
public string Message { get; set; }
Property Value
Type | Description
System.String |

MessageId

Declaration
public string MessageId { get; set; }
Property Value
Type | Description
System.String |

MessageSent

Declaration
public DateTime MessageSent { get; set; }
Property Value
Type | Description
System.DateTime |

Priority

Declaration
public CommunicationPriority Priority { get; set; }
Property Value
Type | Description
CommunicationPriority |

Recipients

Declaration
public string[] Recipients { get; set; }
Property Value
Type | Description
System.String[] |

ReplyTo

Declaration
public string ReplyTo { get; set; }
Property Value
Type | Description
System.String |

Sender

Declaration
public string Sender { get; set; }
Property Value
Type | Description
System.String |

Title

Declaration
public string Title { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class CreateContactSetup | fcSDK Documentation

Class CreateContactSetup

Inheritance
System.Object
CreateContactSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateContactSetup

Constructors

CreateContactSetup(String, String, String, String)

Declaration
[ConstructorIndex(0)]
public CreateContactSetup(string firstName, string lastName, string phone, string siteIDNum)
Parameters
Type | Name | Description
System.String | firstName |
System.String | lastName |
System.String | phone |
System.String | siteIDNum |

Properties

AdditionalFields

Declaration
[PropertyBitValue(2048)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

Email

Declaration
[PropertyBitValue(64)]
public string Email { get; set; }
Property Value
Type | Description
System.String |

Fax

Declaration
[PropertyBitValue(32)]
public string Fax { get; set; }
Property Value
Type | Description
System.String |

FirstName

Declaration
[PropertyBitValue(1)]
public string FirstName { get; set; }
Property Value
Type | Description
System.String |

Hours

Declaration
[PropertyBitValue(512)]
public string Hours { get; set; }
Property Value
Type | Description
System.String |

LastName

Declaration
[PropertyBitValue(2)]
public string LastName { get; set; }
Property Value
Type | Description
System.String |

MailStop

Declaration
[PropertyBitValue(128)]
public string MailStop { get; set; }
Property Value
Type | Description
System.String |

Phone

Declaration
[PropertyBitValue(4)]
public string Phone { get; set; }
Property Value
Type | Description
System.String |

RoleName

Declaration
[PropertyBitValue(16)]
public string RoleName { get; set; }
Property Value
Type | Description
System.String |

Salutation

Declaration
[PropertyBitValue(1024)]
public string Salutation { get; set; }
Property Value
Type | Description
System.String |

SiteIDNum

Declaration
[PropertyBitValue(8)]
public string SiteIDNum { get; set; }
Property Value
Type | Description
System.String |

Title

Declaration
[PropertyBitValue(256)]
public string Title { get; set; }
Property Value
Type | Description
System.String |


Class CreateContractSetup | fcSDK Documentation

Class CreateContractSetup

Inheritance
System.Object
CreateContractSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateContractSetup

Constructors

CreateContractSetup()

Declaration
[ConstructorIndex(0)]
public CreateContractSetup()

Properties

AdditionalFields

Declaration
[PropertyBitValue(65536)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

BusinessHoursForPM

Declaration
[PropertyBitValue(128)]
public string BusinessHoursForPM { get; set; }
Property Value
Type | Description
System.String |

ContractType

Declaration
[PropertyBitValue(2)]
public string ContractType { get; set; }
Property Value
Type | Description
System.String |

ExpireDate

Declaration
[PropertyBitValue(512)]
public DateTime ExpireDate { get; set; }
Property Value
Type | Description
System.DateTime |

Notes

Declaration
[PropertyBitValue(32768)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

OnsiteResponseDuration

Declaration
[PropertyBitValue(64)]
public TimeSpan OnsiteResponseDuration { get; set; }
Property Value
Type | Description
System.TimeSpan |

PayOptions

Declaration
[PropertyBitValue(16)]
public string PayOptions { get; set; }
Property Value
Type | Description
System.String |

PhoneResponseDuration

Declaration
[PropertyBitValue(32)]
public TimeSpan PhoneResponseDuration { get; set; }
Property Value
Type | Description
System.TimeSpan |

PONumber

Declaration
[PropertyBitValue(8)]
public string PONumber { get; set; }
Property Value
Type | Description
System.String |

StartDate

Declaration
[PropertyBitValue(256)]
public DateTime StartDate { get; set; }
Property Value
Type | Description
System.DateTime |

Status

Declaration
[PropertyBitValue(4)]
public string Status { get; set; }
Property Value
Type | Description
System.String |

UnitsAvailable

Declaration
[PropertyBitValue(8192)]
public double UnitsAvailable { get; set; }
Property Value
Type | Description
System.Double |

UnitsPurchased

Declaration
[PropertyBitValue(2048)]
public double UnitsPurchased { get; set; }
Property Value
Type | Description
System.Double |

UnitsUsed

Declaration
[PropertyBitValue(4096)]
public double UnitsUsed { get; set; }
Property Value
Type | Description
System.Double |

UnitType

Declaration
[PropertyBitValue(1024)]
public string UnitType { get; set; }
Property Value
Type | Description
System.String |

UseSpecialConsiderations

Declaration
[PropertyBitValue(16384)]
public bool UseSpecialConsiderations { get; set; }
Property Value
Type | Description
System.Boolean |


Class CreateCountrySetup | fcSDK Documentation

Class CreateCountrySetup

Inheritance
System.Object
CreateCountrySetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateCountrySetup

Constructors

CreateCountrySetup(String, Int32)

Declaration
[ConstructorIndex(0)]
public CreateCountrySetup(string country, int countryCode)
Parameters
Type | Name | Description
System.String | country |
System.Int32 | countryCode |

Properties

Country

Declaration
[PropertyBitValue(1)]
public string Country { get; set; }
Property Value
Type | Description
System.String |

CountryCode

Declaration
[PropertyBitValue(2)]
public int CountryCode { get; set; }
Property Value
Type | Description
System.Int32 |

Currency

Declaration
[PropertyBitValue(4)]
public string Currency { get; set; }
Property Value
Type | Description
System.String |

CurrencyConversionRate

Declaration
[PropertyBitValue(32)]
public double CurrencyConversionRate { get; set; }
Property Value
Type | Description
System.Double |

CurrencyDescription

Declaration
[PropertyBitValue(16)]
public string CurrencyDescription { get; set; }
Property Value
Type | Description
System.String |

CurrencyISOCode

Declaration
[PropertyBitValue(64)]
public string CurrencyISOCode { get; set; }
Property Value
Type | Description
System.String |

CurrencySymbol

Declaration
[PropertyBitValue(8)]
public string CurrencySymbol { get; set; }
Property Value
Type | Description
System.String |


Class CreateDialogueSetup | fcSDK Documentation

Class CreateDialogueSetup

Inheritance
System.Object
CreateDialogueSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateDialogueSetup

Constructors

CreateDialogueSetup()

Declaration
public CreateDialogueSetup()

Properties

AdditionalFields

Declaration
public SimplifiedAdditionalFields AdditionalFields { get; }
Property Value
Type | Description
SimplifiedAdditionalFields |

Created

Declaration
public DateTime Created { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

Priority

Declaration
public string Priority { get; set; }
Property Value
Type | Description
System.String |

Status

Declaration
public string Status { get; set; }
Property Value
Type | Description
System.String |

Title

Declaration
public string Title { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class CreateEmployeeResult | fcSDK Documentation

Class CreateEmployeeResult

Inheritance
System.Object
ToolkitResult
CreateEmployeeResult
Inherited Members
ToolkitResult._ReturnCode
ToolkitResult._IDNum
ToolkitResult._Objid
ToolkitResult.ReturnCode
ToolkitResult.IDNum
ToolkitResult.Objid
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateEmployeeResult : ToolkitResult

Constructors

CreateEmployeeResult()

Declaration
public CreateEmployeeResult()

Properties

EmployeeObjid

Declaration
public int EmployeeObjid { get; set; }
Property Value
Type | Description
System.Int32 |

UserObjid

Declaration
public int UserObjid { get; set; }
Property Value
Type | Description
System.Int32 |


Class CreateEmployeeSetup | fcSDK Documentation

Class CreateEmployeeSetup

Inheritance
System.Object
CreateEmployeeSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateEmployeeSetup

Constructors

CreateEmployeeSetup(String, String, String, String, String, String, String)

Declaration
[ConstructorIndex(0)]
public CreateEmployeeSetup(string firstName, string lastName, string loginName, string password, string siteIDNum, string email, string onlinePrivilegeClass)
Parameters
Type | Name | Description
System.String | firstName |
System.String | lastName |
System.String | loginName |
System.String | password |
System.String | siteIDNum |
System.String | email |
System.String | onlinePrivilegeClass |

Properties

AdditionalFields

Declaration
[PropertyBitValue(1073741824)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

AfterBusinessHoursHigh

Declaration
[PropertyBitValue(8388608)]
public string AfterBusinessHoursHigh { get; set; }
Property Value
Type | Description
System.String |

AfterBusinessHoursLow

Declaration
[PropertyBitValue(33554432)]
public string AfterBusinessHoursLow { get; set; }
Property Value
Type | Description
System.String |

AfterBusinessHoursMed

Declaration
[PropertyBitValue(16777216)]
public string AfterBusinessHoursMed { get; set; }
Property Value
Type | Description
System.String |

AllowProxy

Declaration
[PropertyBitValue(4096)]
public bool AllowProxy { get; set; }
Property Value
Type | Description
System.Boolean |

DefaultTablespace

Declaration
[PropertyBitValue(268435456)]
public string DefaultTablespace { get; set; }
Property Value
Type | Description
System.String |

DefaultWipBinTitle

Declaration
[PropertyBitValue(67108864)]
public string DefaultWipBinTitle { get; set; }
Property Value
Type | Description
System.String |

Email

Declaration
[PropertyBitValue(32)]
public string Email { get; set; }
Property Value
Type | Description
System.String |

EmployeeIdentifier

Declaration
[PropertyBitValue(1024)]
public string EmployeeIdentifier { get; set; }
Property Value
Type | Description
System.String |

FirstName

Declaration
[PropertyBitValue(1)]
public string FirstName { get; set; }
Property Value
Type | Description
System.String |

IsActive

Declaration
[PropertyBitValue(2048)]
public bool IsActive { get; set; }
Property Value
Type | Description
System.Boolean |

IsFieldEngineer

Declaration
[PropertyBitValue(524288)]
public bool IsFieldEngineer { get; set; }
Property Value
Type | Description
System.Boolean |

IsSupervisor

Declaration
[PropertyBitValue(262144)]
public bool IsSupervisor { get; set; }
Property Value
Type | Description
System.Boolean |

LaborRate

Declaration
[PropertyBitValue(131072)]
public double LaborRate { get; set; }
Property Value
Type | Description
System.Double |

LastName

Declaration
[PropertyBitValue(2)]
public string LastName { get; set; }
Property Value
Type | Description
System.String |

LoginName

Declaration
[PropertyBitValue(4)]
public string LoginName { get; set; }
Property Value
Type | Description
System.String |

NormalBusinessHoursHigh

Declaration
[PropertyBitValue(1048576)]
public string NormalBusinessHoursHigh { get; set; }
Property Value
Type | Description
System.String |

NormalBusinessHoursLow

Declaration
[PropertyBitValue(4194304)]
public string NormalBusinessHoursLow { get; set; }
Property Value
Type | Description
System.String |

NormalBusinessHoursMed

Declaration
[PropertyBitValue(2097152)]
public string NormalBusinessHoursMed { get; set; }
Property Value
Type | Description
System.String |

OfflinePrivilegeClass

Declaration
[PropertyBitValue(512)]
public string OfflinePrivilegeClass { get; set; }
Property Value
Type | Description
System.String |

OnlinePrivilegeClass

Declaration
[PropertyBitValue(256)]
public string OnlinePrivilegeClass { get; set; }
Property Value
Type | Description
System.String |

Pager

Declaration
[PropertyBitValue(128)]
public string Pager { get; set; }
Property Value
Type | Description
System.String |

Password

Declaration
[PropertyBitValue(8)]
public string Password { get; set; }
Property Value
Type | Description
System.String |

Phone

Declaration
[PropertyBitValue(64)]
public string Phone { get; set; }
Property Value
Type | Description
System.String |

ResourceConfig

Declaration
[PropertyBitValue(134217728)]
public string ResourceConfig { get; set; }
Property Value
Type | Description
System.String |

SiteIDNum

Declaration
[PropertyBitValue(16)]
public string SiteIDNum { get; set; }
Property Value
Type | Description
System.String |

StartDate

Declaration
[PropertyBitValue(8192)]
public DateTime StartDate { get; set; }
Property Value
Type | Description
System.DateTime |

Supervisor

Declaration
[PropertyBitValue(16384)]
public string Supervisor { get; set; }
Property Value
Type | Description
System.String |

TempTablespace

Declaration
[PropertyBitValue(536870912)]
public string TempTablespace { get; set; }
Property Value
Type | Description
System.String |

UseDatabaseLogins

Declaration
public bool UseDatabaseLogins { get; set; }
Property Value
Type | Description
System.Boolean |

WorkGroup

Declaration
[PropertyBitValue(32768)]
public string WorkGroup { get; set; }
Property Value
Type | Description
System.String |

WorkGroupStartDate

Declaration
[PropertyBitValue(65536)]
public DateTime WorkGroupStartDate { get; set; }
Property Value
Type | Description
System.DateTime |


Class CreateInteractionSetup | fcSDK Documentation

Class CreateInteractionSetup

Inheritance
System.Object
CreateInteractionSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateInteractionSetup

Constructors

CreateInteractionSetup(String, String, String, TimeSpan)

Declaration
[ConstructorIndex(0)]
public CreateInteractionSetup(string contactFirstName, string contactLastName, string contactPhone, TimeSpan duration)
Parameters
Type | Name | Description
System.String | contactFirstName |
System.String | contactLastName |
System.String | contactPhone |
System.TimeSpan | duration |

Properties

AdditionalFields

Declaration
[PropertyBitValue(8388608)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

ContactFirstName

Declaration
[PropertyBitValue(4)]
public string ContactFirstName { get; set; }
Property Value
Type | Description
System.String |

ContactLastName

Declaration
[PropertyBitValue(8)]
public string ContactLastName { get; set; }
Property Value
Type | Description
System.String |

ContactPhone

Declaration
[PropertyBitValue(16)]
public string ContactPhone { get; set; }
Property Value
Type | Description
System.String |

Direction

Declaration
[PropertyBitValue(512)]
public string Direction { get; set; }
Property Value
Type | Description
System.String |

Duration

Declaration
[PropertyBitValue(262144)]
public TimeSpan Duration { get; set; }
Property Value
Type | Description
System.TimeSpan |

EnteredDuration

Declaration
[PropertyBitValue(1048576)]
public TimeSpan EnteredDuration { get; set; }
Property Value
Type | Description
System.TimeSpan |

FeeBased

Declaration
[PropertyBitValue(16384)]
public bool FeeBased { get; set; }
Property Value
Type | Description
System.Boolean |

GenerateTimeBombs

Declaration
[PropertyBitValue(4194304)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

InteractionType

Declaration
[PropertyBitValue(1024)]
public string InteractionType { get; set; }
Property Value
Type | Description
System.String |

IsDoneInOne

Declaration
[PropertyBitValue(4096)]
public bool IsDoneInOne { get; set; }
Property Value
Type | Description
System.Boolean |

LeadSource

Declaration
[PropertyBitValue(65536)]
public string LeadSource { get; set; }
Property Value
Type | Description
System.String |

Notes

Declaration
[PropertyBitValue(2)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

Origin

Declaration
[PropertyBitValue(2048)]
public string Origin { get; set; }
Property Value
Type | Description
System.String |

PayOption

Declaration
[PropertyBitValue(32768)]
public string PayOption { get; set; }
Property Value
Type | Description
System.String |

ProductName

Declaration
[PropertyBitValue(256)]
public string ProductName { get; set; }
Property Value
Type | Description
System.String |

Reason1

Declaration
[PropertyBitValue(64)]
public string Reason1 { get; set; }
Property Value
Type | Description
System.String |

Reason2

Declaration
[PropertyBitValue(128)]
public string Reason2 { get; set; }
Property Value
Type | Description
System.String |

Result

Declaration
[PropertyBitValue(8192)]
public string Result { get; set; }
Property Value
Type | Description
System.String |

StartDate

Declaration
[PropertyBitValue(131072)]
public DateTime StartDate { get; set; }
Property Value
Type | Description
System.DateTime |

Title

Declaration
[PropertyBitValue(1)]
public string Title { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(2097152)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WaitDuration

Declaration
[PropertyBitValue(524288)]
public TimeSpan WaitDuration { get; set; }
Property Value
Type | Description
System.TimeSpan |

ZipCode

Declaration
[PropertyBitValue(32)]
public string ZipCode { get; set; }
Property Value
Type | Description
System.String |


Class CreatePartRevisionSetup | fcSDK Documentation

Class CreatePartRevisionSetup

Inheritance
System.Object
CreatePartRevisionSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreatePartRevisionSetup

Constructors

CreatePartRevisionSetup(String, String, String)

Declaration
[ConstructorIndex(0)]
public CreatePartRevisionSetup(string partNumber, string partDomain, string partRevision)
Parameters
Type | Name | Description
System.String | partNumber |
System.String | partDomain |
System.String | partRevision |

Properties

PartDomain

Declaration
[PropertyBitValue(2)]
public string PartDomain { get; set; }
Property Value
Type | Description
System.String |

PartNumber

Declaration
[PropertyBitValue(1)]
public string PartNumber { get; set; }
Property Value
Type | Description
System.String |

PartRevision

Declaration
[PropertyBitValue(4)]
public string PartRevision { get; set; }
Property Value
Type | Description
System.String |

ReplaceDate

Declaration
[PropertyBitValue(64)]
public DateTime ReplaceDate { get; set; }
Property Value
Type | Description
System.DateTime |

ReplacePartDomain

Declaration
[PropertyBitValue(16)]
public string ReplacePartDomain { get; set; }
Property Value
Type | Description
System.String |

ReplacePartNumber

Declaration
[PropertyBitValue(8)]
public string ReplacePartNumber { get; set; }
Property Value
Type | Description
System.String |

ReplacePartRevision

Declaration
[PropertyBitValue(32)]
public string ReplacePartRevision { get; set; }
Property Value
Type | Description
System.String |

Status

Declaration
[PropertyBitValue(128)]
public PartRevisionStatus Status { get; set; }
Property Value
Type | Description
PartRevisionStatus |


Class CreatePartSetup | fcSDK Documentation

Class CreatePartSetup

Inheritance
System.Object
CreatePartSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreatePartSetup

Constructors

CreatePartSetup(String, String, Int32, PartRepairType)

Declaration
[ConstructorIndex(0)]
public CreatePartSetup(string partNumber, string partDomain, int warrantyDays, PartRepairType repairType)
Parameters
Type | Name | Description
System.String | partNumber |
System.String | partDomain |
System.Int32 | warrantyDays |
PartRepairType | repairType |

Properties

AdditionalFields

Declaration
[PropertyBitValue(32768)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

Description

Declaration
[PropertyBitValue(8)]
public string Description { get; set; }
Property Value
Type | Description
System.String |

Dimension

Declaration
[PropertyBitValue(8192)]
public string Dimension { get; set; }
Property Value
Type | Description
System.String |

Family

Declaration
[PropertyBitValue(256)]
public string Family { get; set; }
Property Value
Type | Description
System.String |

Line

Declaration
[PropertyBitValue(512)]
public string Line { get; set; }
Property Value
Type | Description
System.String |

ModelNumber

Declaration
[PropertyBitValue(16)]
public string ModelNumber { get; set; }
Property Value
Type | Description
System.String |

Notes

Declaration
[PropertyBitValue(4)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

PartClass

Declaration
[PropertyBitValue(16384)]
public string PartClass { get; set; }
Property Value
Type | Description
System.String |

PartDomain

Declaration
[PropertyBitValue(2)]
public string PartDomain { get; set; }
Property Value
Type | Description
System.String |

PartNumber

Declaration
[PropertyBitValue(1)]
public string PartNumber { get; set; }
Property Value
Type | Description
System.String |

PartType

Declaration
[PropertyBitValue(2048)]
public string PartType { get; set; }
Property Value
Type | Description
System.String |

RepairType

Declaration
[PropertyBitValue(1024)]
public PartRepairType RepairType { get; set; }
Property Value
Type | Description
PartRepairType |

UnitMeasure

Declaration
[PropertyBitValue(128)]
public string UnitMeasure { get; set; }
Property Value
Type | Description
System.String |

WarrantyDays

Declaration
[PropertyBitValue(32)]
public int WarrantyDays { get; set; }
Property Value
Type | Description
System.Int32 |

WarrantyStartOnShipment

Declaration
[PropertyBitValue(64)]
public bool WarrantyStartOnShipment { get; set; }
Property Value
Type | Description
System.Boolean |

Weight

Declaration
[PropertyBitValue(4096)]
public string Weight { get; set; }
Property Value
Type | Description
System.String |


Class CreatePriceInstanceSetup | fcSDK Documentation

Class CreatePriceInstanceSetup

Inheritance
System.Object
CreatePriceInstanceSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreatePriceInstanceSetup

Constructors

CreatePriceInstanceSetup(String, String, String, String, PriceInstanceType, Int32, Decimal)

Declaration
[ConstructorIndex(0)]
public CreatePriceInstanceSetup(string partNumber, string partDomain, string partRevision, string priceProgram, PriceInstanceType priceType, int pricedQuantity, decimal price)
Parameters
Type | Name | Description
System.String | partNumber |
System.String | partDomain |
System.String | partRevision |
System.String | priceProgram |
PriceInstanceType | priceType |
System.Int32 | pricedQuantity |
System.Decimal | price |

Properties

EndDate

Declaration
[PropertyBitValue(256)]
public DateTime EndDate { get; set; }
Property Value
Type | Description
System.DateTime |

PartDomain

Declaration
[PropertyBitValue(2)]
public string PartDomain { get; set; }
Property Value
Type | Description
System.String |

PartNumber

Declaration
[PropertyBitValue(1)]
public string PartNumber { get; set; }
Property Value
Type | Description
System.String |

PartRevision

Declaration
[PropertyBitValue(4)]
public string PartRevision { get; set; }
Property Value
Type | Description
System.String |

Price

Declaration
[PropertyBitValue(64)]
public decimal Price { get; set; }
Property Value
Type | Description
System.Decimal |

PricedQuantity

Declaration
[PropertyBitValue(32)]
public int PricedQuantity { get; set; }
Property Value
Type | Description
System.Int32 |

PriceProgram

Declaration
[PropertyBitValue(8)]
public string PriceProgram { get; set; }
Property Value
Type | Description
System.String |

PriceType

Declaration
[PropertyBitValue(16)]
public PriceInstanceType PriceType { get; set; }
Property Value
Type | Description
PriceInstanceType |

StartDate

Declaration
[PropertyBitValue(128)]
public DateTime StartDate { get; set; }
Property Value
Type | Description
System.DateTime |


Class CreateProductBinSetup | fcSDK Documentation

Class CreateProductBinSetup

Inheritance
System.Object
CreateProductBinSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateProductBinSetup

Constructors

CreateProductBinSetup(String, String)

Declaration
[ConstructorIndex(0)]
public CreateProductBinSetup(string binName, string siteIDNum)
Parameters
Type | Name | Description
System.String | binName |
System.String | siteIDNum |

Properties

BinName

Declaration
[PropertyBitValue(1)]
public string BinName { get; set; }
Property Value
Type | Description
System.String |

CreateDate

Declaration
[PropertyBitValue(128)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

Description

Declaration
[PropertyBitValue(8)]
public string Description { get; set; }
Property Value
Type | Description
System.String |

ParentBinObjid

Declaration
[PropertyBitValue(4)]
public int ParentBinObjid { get; set; }
Property Value
Type | Description
System.Int32 |

PrimarySupportEmployeeObjid

Declaration
[PropertyBitValue(16)]
public int PrimarySupportEmployeeObjid { get; set; }
Property Value
Type | Description
System.Int32 |

SecondarySupportEmployeeObjid

Declaration
[PropertyBitValue(32)]
public int SecondarySupportEmployeeObjid { get; set; }
Property Value
Type | Description
System.Int32 |

SiteIDNum

Declaration
[PropertyBitValue(2)]
public string SiteIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(64)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class CreateQueueSetup | fcSDK Documentation

Class CreateQueueSetup

Inheritance
System.Object
CreateQueueSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateQueueSetup

Constructors

CreateQueueSetup(String, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)

Declaration
[ConstructorIndex(0)]
public CreateQueueSetup(string title, bool allowCR, bool allowCase, bool allowContract, bool allowDialogue, bool allowDemandDetail, bool allowJob, bool allowOpportunity, bool allowSolution, bool allowSubcase, bool allowActionItem)
Parameters
Type | Name | Description
System.String | title |
System.Boolean | allowCR |
System.Boolean | allowCase |
System.Boolean | allowContract |
System.Boolean | allowDialogue |
System.Boolean | allowDemandDetail |
System.Boolean | allowJob |
System.Boolean | allowOpportunity |
System.Boolean | allowSolution |
System.Boolean | allowSubcase |
System.Boolean | allowActionItem |

Properties

AllowActionItem

Declaration
[PropertyBitValue(4096)]
public bool AllowActionItem { get; set; }
Property Value
Type | Description
System.Boolean |

AllowCase

Declaration
[PropertyBitValue(16)]
public bool AllowCase { get; set; }
Property Value
Type | Description
System.Boolean |

AllowContract

Declaration
[PropertyBitValue(32)]
public bool AllowContract { get; set; }
Property Value
Type | Description
System.Boolean |

AllowCR

Declaration
[PropertyBitValue(8)]
public bool AllowCR { get; set; }
Property Value
Type | Description
System.Boolean |

AllowDemandDetail

Declaration
[PropertyBitValue(128)]
public bool AllowDemandDetail { get; set; }
Property Value
Type | Description
System.Boolean |

AllowDialogue

Declaration
[PropertyBitValue(64)]
public bool AllowDialogue { get; set; }
Property Value
Type | Description
System.Boolean |

AllowJob

Declaration
[PropertyBitValue(256)]
public bool AllowJob { get; set; }
Property Value
Type | Description
System.Boolean |

AllowOpportunity

Declaration
[PropertyBitValue(512)]
public bool AllowOpportunity { get; set; }
Property Value
Type | Description
System.Boolean |

AllowSolution

Declaration
[PropertyBitValue(1024)]
public bool AllowSolution { get; set; }
Property Value
Type | Description
System.Boolean |

AllowSubcase

Declaration
[PropertyBitValue(2048)]
public bool AllowSubcase { get; set; }
Property Value
Type | Description
System.Boolean |

Description

Declaration
[PropertyBitValue(4)]
public string Description { get; set; }
Property Value
Type | Description
System.String |

IsPersonal

Declaration
[PropertyBitValue(2)]
public bool IsPersonal { get; set; }
Property Value
Type | Description
System.Boolean |

Supervisor

Declaration
[PropertyBitValue(8192)]
public string Supervisor { get; set; }
Property Value
Type | Description
System.String |

Title

Declaration
[PropertyBitValue(1)]
public string Title { get; set; }
Property Value
Type | Description
System.String |


Class CreateSiteSetup | fcSDK Documentation

Class CreateSiteSetup

Inheritance
System.Object
CreateSiteSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateSiteSetup

Constructors

CreateSiteSetup(SiteType, SiteStatus, Int32)

Declaration
[ConstructorIndex(0)]
public CreateSiteSetup(SiteType siteType, SiteStatus status, int primaryAddressObjid)
Parameters
Type | Name | Description
SiteType | siteType |
SiteStatus | status |
System.Int32 | primaryAddressObjid |

Properties

AccountIDNum

Declaration
[PropertyBitValue(16)]
public string AccountIDNum { get; set; }
Property Value
Type | Description
System.String |

AdditionalFields

Declaration
[PropertyBitValue(131072)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

BillingAddressObjid

Declaration
[PropertyBitValue(4096)]
public int BillingAddressObjid { get; set; }
Property Value
Type | Description
System.Int32 |

District

Declaration
[PropertyBitValue(128)]
public string District { get; set; }
Property Value
Type | Description
System.String |

IndustryType

Declaration
[PropertyBitValue(256)]
public string IndustryType { get; set; }
Property Value
Type | Description
System.String |

ParentSiteIDNum

Declaration
[PropertyBitValue(8192)]
public string ParentSiteIDNum { get; set; }
Property Value
Type | Description
System.String |

PrimaryAddressObjid

Declaration
[PropertyBitValue(1024)]
public int PrimaryAddressObjid { get; set; }
Property Value
Type | Description
System.Int32 |

PrimarySupportEmployeeObjid

Declaration
[PropertyBitValue(32768)]
public int PrimarySupportEmployeeObjid { get; set; }
Property Value
Type | Description
System.Int32 |

PrimaryUse

Declaration
[PropertyBitValue(512)]
public string PrimaryUse { get; set; }
Property Value
Type | Description
System.String |

Region

Declaration
[PropertyBitValue(64)]
public string Region { get; set; }
Property Value
Type | Description
System.String |

SecondarySupportEmployeeObjid

Declaration
[PropertyBitValue(65536)]
public int SecondarySupportEmployeeObjid { get; set; }
Property Value
Type | Description
System.Int32 |

ShippingAddressObjid

Declaration
[PropertyBitValue(2048)]
public int ShippingAddressObjid { get; set; }
Property Value
Type | Description
System.Int32 |

SiteIDNum

Declaration
[PropertyBitValue(2)]
public string SiteIDNum { get; set; }
Property Value
Type | Description
System.String |

SiteName

Declaration
[PropertyBitValue(4)]
public string SiteName { get; set; }
Property Value
Type | Description
System.String |

SiteType

Declaration
[PropertyBitValue(8)]
public SiteType SiteType { get; set; }
Property Value
Type | Description
SiteType |

Status

Declaration
[PropertyBitValue(32)]
public SiteStatus Status { get; set; }
Property Value
Type | Description
SiteStatus |

SupportOfficeSiteIDNum

Declaration
[PropertyBitValue(16384)]
public string SupportOfficeSiteIDNum { get; set; }
Property Value
Type | Description
System.String |


Class CreateSolutionResult | fcSDK Documentation

Class CreateSolutionResult

Inheritance
System.Object
ToolkitResult
CreateSolutionResult
Inherited Members
ToolkitResult._ReturnCode
ToolkitResult._IDNum
ToolkitResult._Objid
ToolkitResult.ReturnCode
ToolkitResult.IDNum
ToolkitResult.Objid
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateSolutionResult : ToolkitResult

Constructors

CreateSolutionResult()

Declaration
public CreateSolutionResult()

Properties

WorkaroundObjid

Declaration
public int WorkaroundObjid { get; set; }
Property Value
Type | Description
System.Int32 |


Class CreateSolutionSetup | fcSDK Documentation

Class CreateSolutionSetup

Inheritance
System.Object
CreateSolutionSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateSolutionSetup

Constructors

CreateSolutionSetup()

Declaration
[ConstructorIndex(0)]
public CreateSolutionSetup()

Properties

AdditionalFields

Declaration
[PropertyBitValue(512)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

CreateDate

Declaration
[PropertyBitValue(64)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

Description

Declaration
[PropertyBitValue(2)]
public string Description { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(256)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

IsPublic

Declaration
[PropertyBitValue(8)]
public bool IsPublic { get; set; }
Property Value
Type | Description
System.Boolean |

Queue

Declaration
[PropertyBitValue(32)]
public string Queue { get; set; }
Property Value
Type | Description
System.String |

ResolutionCode

Declaration
[PropertyBitValue(16)]
public string ResolutionCode { get; set; }
Property Value
Type | Description
System.String |

Title

Declaration
[PropertyBitValue(1)]
public string Title { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(128)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

Workaround

Declaration
[PropertyBitValue(4)]
public string Workaround { get; set; }
Property Value
Type | Description
System.String |


Class CreateStateSetup | fcSDK Documentation

Class CreateStateSetup

Inheritance
System.Object
CreateStateSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateStateSetup

Constructors

CreateStateSetup(String, String, String)

Declaration
[ConstructorIndex(0)]
public CreateStateSetup(string state, string fullName, string country)
Parameters
Type | Name | Description
System.String | state |
System.String | fullName |
System.String | country |

Properties

Country

Declaration
[PropertyBitValue(8)]
public string Country { get; set; }
Property Value
Type | Description
System.String |

FullName

Declaration
[PropertyBitValue(2)]
public string FullName { get; set; }
Property Value
Type | Description
System.String |

IsDefault

Declaration
[PropertyBitValue(4)]
public bool IsDefault { get; set; }
Property Value
Type | Description
System.Boolean |

State

Declaration
[PropertyBitValue(1)]
public string State { get; set; }
Property Value
Type | Description
System.String |


Class CreateTimeZoneSetup | fcSDK Documentation

Class CreateTimeZoneSetup

Inheritance
System.Object
CreateTimeZoneSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateTimeZoneSetup

Constructors

CreateTimeZoneSetup(String, String, String)

Declaration
[ConstructorIndex(0)]
public CreateTimeZoneSetup(string timeZone, string fullName, string country)
Parameters
Type | Name | Description
System.String | timeZone |
System.String | fullName |
System.String | country |

Properties

Country

Declaration
[PropertyBitValue(4)]
public string Country { get; set; }
Property Value
Type | Description
System.String |

FullName

Declaration
[PropertyBitValue(2)]
public string FullName { get; set; }
Property Value
Type | Description
System.String |

GMTDifference

Declaration
[PropertyBitValue(8)]
public int GMTDifference { get; set; }
Property Value
Type | Description
System.Int32 |

TimeZone

Declaration
[PropertyBitValue(1)]
public string TimeZone { get; set; }
Property Value
Type | Description
System.String |


Class CreateWipBinSetup | fcSDK Documentation

Class CreateWipBinSetup

Inheritance
System.Object
CreateWipBinSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateWipBinSetup

Constructors

CreateWipBinSetup(String)

Declaration
[ConstructorIndex(0)]
public CreateWipBinSetup(string title)
Parameters
Type | Name | Description
System.String | title |

Properties

Description

Declaration
[PropertyBitValue(4)]
public string Description { get; set; }
Property Value
Type | Description
System.String |

IsDefaultBin

Declaration
[PropertyBitValue(16)]
public bool IsDefaultBin { get; set; }
Property Value
Type | Description
System.Boolean |

Title

Declaration
[PropertyBitValue(1)]
public string Title { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class DeinstallSitePartSetup | fcSDK Documentation

Class DeinstallSitePartSetup

Inheritance
System.Object
DeinstallSitePartSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class DeinstallSitePartSetup

Constructors

DeinstallSitePartSetup(Int32)

Declaration
[ConstructorIndex(0)]
public DeinstallSitePartSetup(int sitePartObjid)
Parameters
Type | Name | Description
System.Int32 | sitePartObjid |

Properties

DeinstallDate

Declaration
[PropertyBitValue(4)]
public DateTime DeinstallDate { get; set; }
Property Value
Type | Description
System.DateTime |

SitePartObjid

Declaration
[PropertyBitValue(1)]
public int SitePartObjid { get; set; }
Property Value
Type | Description
System.Int32 |

UseRemove

Declaration
[PropertyBitValue(8)]
public bool UseRemove { get; set; }
Property Value
Type | Description
System.Boolean |

UserName

Declaration
[PropertyBitValue(2)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class DeleteProductBinSetup | fcSDK Documentation

Class DeleteProductBinSetup

Inheritance
System.Object
DeleteProductBinSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class DeleteProductBinSetup

Constructors

DeleteProductBinSetup(Int32)

Declaration
[ConstructorIndex(0)]
public DeleteProductBinSetup(int binObjid)
Parameters
Type | Name | Description
System.Int32 | binObjid |

Properties

BinObjid

Declaration
[PropertyBitValue(1)]
public int BinObjid { get; set; }
Property Value
Type | Description
System.Int32 |

DeleteDate

Declaration
[PropertyBitValue(4)]
public DateTime DeleteDate { get; set; }
Property Value
Type | Description
System.DateTime |

UserName

Declaration
[PropertyBitValue(2)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class DispatchSolutionSetup | fcSDK Documentation

Class DispatchSolutionSetup

Inheritance
System.Object
DispatchSolutionSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class DispatchSolutionSetup

Constructors

DispatchSolutionSetup(String, String)

Declaration
[ConstructorIndex(0)]
public DispatchSolutionSetup(string solutionIDNum, string queue)
Parameters
Type | Name | Description
System.String | solutionIDNum |
System.String | queue |

Properties

DispatchDate

Declaration
[PropertyBitValue(4)]
public DateTime DispatchDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(16)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

Queue

Declaration
[PropertyBitValue(2)]
public string Queue { get; set; }
Property Value
Type | Description
System.String |

SolutionIDNum

Declaration
[PropertyBitValue(1)]
public string SolutionIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class ForwardSolutionSetup | fcSDK Documentation

Class ForwardSolutionSetup

Inheritance
System.Object
ForwardSolutionSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ForwardSolutionSetup

Constructors

ForwardSolutionSetup(String, String)

Declaration
[ConstructorIndex(0)]
public ForwardSolutionSetup(string solutionIDNum, string newQueue)
Parameters
Type | Name | Description
System.String | solutionIDNum |
System.String | newQueue |

Properties

ForwardDate

Declaration
[PropertyBitValue(4)]
public DateTime ForwardDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

NewQueue

Declaration
[PropertyBitValue(2)]
public string NewQueue { get; set; }
Property Value
Type | Description
System.String |

Notes

Declaration
[PropertyBitValue(8)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

SolutionIDNum

Declaration
[PropertyBitValue(1)]
public string SolutionIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class InstallSitePartToBinSetup | fcSDK Documentation

Class InstallSitePartToBinSetup

Inheritance
System.Object
InstallSitePartToBinSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class InstallSitePartToBinSetup

Constructors

InstallSitePartToBinSetup(String, Int32, String, String, String, Int32)

Declaration
[ConstructorIndex(0)]
public InstallSitePartToBinSetup(string siteIDNum, int parentBinObjid, string partNumber, string partRevision, string partDomain, int quantity)
Parameters
Type | Name | Description
System.String | siteIDNum |
System.Int32 | parentBinObjid |
System.String | partNumber |
System.String | partRevision |
System.String | partDomain |
System.Int32 | quantity |

InstallSitePartToBinSetup(String, String, String, String, String)

Declaration
[ConstructorIndex(1)]
public InstallSitePartToBinSetup(string siteIDNum, string partNumber, string partRevision, string partDomain, string serialNumber)
Parameters
Type | Name | Description
System.String | siteIDNum |
System.String | partNumber |
System.String | partRevision |
System.String | partDomain |
System.String | serialNumber |

Properties

AddActivityLog

Declaration
[PropertyBitValue(32768)]
public bool AddActivityLog { get; set; }
Property Value
Type | Description
System.Boolean |

AdditionalFields

Declaration
[PropertyBitValue(65536)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

Comments

Declaration
[PropertyBitValue(512)]
public string Comments { get; set; }
Property Value
Type | Description
System.String |

InstallDate

Declaration
[PropertyBitValue(8192)]
public DateTime InstallDate { get; set; }
Property Value
Type | Description
System.DateTime |

InstanceName

Declaration
[PropertyBitValue(256)]
public string InstanceName { get; set; }
Property Value
Type | Description
System.String |

InvoiceNumber

Declaration
[PropertyBitValue(2048)]
public string InvoiceNumber { get; set; }
Property Value
Type | Description
System.String |

ParentBinObjid

Declaration
[PropertyBitValue(64)]
public int ParentBinObjid { get; set; }
Property Value
Type | Description
System.Int32 |

PartDomain

Declaration
[PropertyBitValue(8)]
public string PartDomain { get; set; }
Property Value
Type | Description
System.String |

PartNumber

Declaration
[PropertyBitValue(2)]
public string PartNumber { get; set; }
Property Value
Type | Description
System.String |

PartRevision

Declaration
[PropertyBitValue(4)]
public string PartRevision { get; set; }
Property Value
Type | Description
System.String |

PartStatus

Declaration
[PropertyBitValue(1024)]
public string PartStatus { get; set; }
Property Value
Type | Description
System.String |

Quantity

Declaration
[PropertyBitValue(16)]
public int Quantity { get; set; }
Property Value
Type | Description
System.Int32 |

SerialNumber

Declaration
[PropertyBitValue(32)]
public string SerialNumber { get; set; }
Property Value
Type | Description
System.String |

ShipDate

Declaration
[PropertyBitValue(16384)]
public DateTime ShipDate { get; set; }
Property Value
Type | Description
System.DateTime |

SiteIDNum

Declaration
[PropertyBitValue(1)]
public string SiteIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(4096)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class InstallSitePartToPartSetup | fcSDK Documentation

Class InstallSitePartToPartSetup

Inheritance
System.Object
InstallSitePartToPartSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class InstallSitePartToPartSetup

Constructors

InstallSitePartToPartSetup(String, Int32, String, String, String, Int32)

Declaration
[ConstructorIndex(0)]
public InstallSitePartToPartSetup(string siteIDNum, int parentSitePartObjid, string partNumber, string partRevision, string partDomain, int quantity)
Parameters
Type | Name | Description
System.String | siteIDNum |
System.Int32 | parentSitePartObjid |
System.String | partNumber |
System.String | partRevision |
System.String | partDomain |
System.Int32 | quantity |

InstallSitePartToPartSetup(String, String, String, String, String)

Declaration
[ConstructorIndex(1)]
public InstallSitePartToPartSetup(string siteIDNum, string partNumber, string partRevision, string partDomain, string serialNumber)
Parameters
Type | Name | Description
System.String | siteIDNum |
System.String | partNumber |
System.String | partRevision |
System.String | partDomain |
System.String | serialNumber |

Properties

AddActivityLog

Declaration
[PropertyBitValue(32768)]
public bool AddActivityLog { get; set; }
Property Value
Type | Description
System.Boolean |

AdditionalFields

Declaration
[PropertyBitValue(65536)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

Comments

Declaration
[PropertyBitValue(512)]
public string Comments { get; set; }
Property Value
Type | Description
System.String |

InstallDate

Declaration
[PropertyBitValue(8192)]
public DateTime InstallDate { get; set; }
Property Value
Type | Description
System.DateTime |

InstanceName

Declaration
[PropertyBitValue(256)]
public string InstanceName { get; set; }
Property Value
Type | Description
System.String |

InvoiceNumber

Declaration
[PropertyBitValue(2048)]
public string InvoiceNumber { get; set; }
Property Value
Type | Description
System.String |

ParentSitePartObjid

Declaration
[PropertyBitValue(128)]
public int ParentSitePartObjid { get; set; }
Property Value
Type | Description
System.Int32 |

PartDomain

Declaration
[PropertyBitValue(8)]
public string PartDomain { get; set; }
Property Value
Type | Description
System.String |

PartNumber

Declaration
[PropertyBitValue(2)]
public string PartNumber { get; set; }
Property Value
Type | Description
System.String |

PartRevision

Declaration
[PropertyBitValue(4)]
public string PartRevision { get; set; }
Property Value
Type | Description
System.String |

PartStatus

Declaration
[PropertyBitValue(1024)]
public string PartStatus { get; set; }
Property Value
Type | Description
System.String |

Quantity

Declaration
[PropertyBitValue(16)]
public int Quantity { get; set; }
Property Value
Type | Description
System.Int32 |

SerialNumber

Declaration
[PropertyBitValue(32)]
public string SerialNumber { get; set; }
Property Value
Type | Description
System.String |

ShipDate

Declaration
[PropertyBitValue(16384)]
public DateTime ShipDate { get; set; }
Property Value
Type | Description
System.DateTime |

SiteIDNum

Declaration
[PropertyBitValue(1)]
public string SiteIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(4096)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class InstallSitePartToSiteSetup | fcSDK Documentation

Class InstallSitePartToSiteSetup

Inheritance
System.Object
InstallSitePartToSiteSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class InstallSitePartToSiteSetup

Constructors

InstallSitePartToSiteSetup(String, String, String, String, Int32)

Declaration
[ConstructorIndex(0)]
public InstallSitePartToSiteSetup(string siteIDNum, string partNumber, string partRevision, string partDomain, int quantity)
Parameters
Type | Name | Description
System.String | siteIDNum |
System.String | partNumber |
System.String | partRevision |
System.String | partDomain |
System.Int32 | quantity |

InstallSitePartToSiteSetup(String, String, String, String, String)

Declaration
[ConstructorIndex(1)]
public InstallSitePartToSiteSetup(string siteIDNum, string partNumber, string partRevision, string partDomain, string serialNumber)
Parameters
Type | Name | Description
System.String | siteIDNum |
System.String | partNumber |
System.String | partRevision |
System.String | partDomain |
System.String | serialNumber |

Properties

AddActivityLog

Declaration
[PropertyBitValue(32768)]
public bool AddActivityLog { get; set; }
Property Value
Type | Description
System.Boolean |

AdditionalFields

Declaration
[PropertyBitValue(65536)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

Comments

Declaration
[PropertyBitValue(512)]
public string Comments { get; set; }
Property Value
Type | Description
System.String |

InstallDate

Declaration
[PropertyBitValue(8192)]
public DateTime InstallDate { get; set; }
Property Value
Type | Description
System.DateTime |

InstanceName

Declaration
[PropertyBitValue(256)]
public string InstanceName { get; set; }
Property Value
Type | Description
System.String |

InvoiceNumber

Declaration
[PropertyBitValue(2048)]
public string InvoiceNumber { get; set; }
Property Value
Type | Description
System.String |

PartDomain

Declaration
[PropertyBitValue(8)]
public string PartDomain { get; set; }
Property Value
Type | Description
System.String |

PartNumber

Declaration
[PropertyBitValue(2)]
public string PartNumber { get; set; }
Property Value
Type | Description
System.String |

PartRevision

Declaration
[PropertyBitValue(4)]
public string PartRevision { get; set; }
Property Value
Type | Description
System.String |

PartStatus

Declaration
[PropertyBitValue(1024)]
public string PartStatus { get; set; }
Property Value
Type | Description
System.String |

Quantity

Declaration
[PropertyBitValue(16)]
public int Quantity { get; set; }
Property Value
Type | Description
System.Int32 |

SerialNumber

Declaration
[PropertyBitValue(32)]
public string SerialNumber { get; set; }
Property Value
Type | Description
System.String |

ShipDate

Declaration
[PropertyBitValue(16384)]
public DateTime ShipDate { get; set; }
Property Value
Type | Description
System.DateTime |

SiteIDNum

Declaration
[PropertyBitValue(1)]
public string SiteIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(4096)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class InterfacesToolkit | fcSDK Documentation

Class InterfacesToolkit

Inheritance
System.Object
ToolkitBase
InterfacesToolkitBase
InterfacesToolkit
Inherited Members
InterfacesToolkitBase._toolkit
InterfacesToolkitBase.AllowDuplicateContact
InterfacesToolkitBase.UseDatabaseLogins
InterfacesToolkitBase.ImpersonatorUsername
ToolkitBase.NOW_DATE
ToolkitBase.CompatSession
ToolkitBase.WithTransaction<T>(Func<IDbTransaction, T>)
ToolkitBase.FCApplication
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class InterfacesToolkit : InterfacesToolkitBase

Constructors

InterfacesToolkit(ClarifySession)

Declaration
public InterfacesToolkit(ClarifySession session)
Parameters
Type | Name | Description
ClarifySession | session |

InterfacesToolkit(IFCApplication, IFCSession)

Declaration
public InterfacesToolkit(IFCApplication application, IFCSession session)
Parameters
Type | Name | Description
IFCApplication | application |
IFCSession | session |

Fields

CreateCommunicationActivityCode

Declaration
public static readonly int CreateCommunicationActivityCode
Field Value
Type | Description
System.Int32 |

CreateDialogueActivityCode

Declaration
public static readonly int CreateDialogueActivityCode
Field Value
Type | Description
System.Int32 |

DeliveryConfirmedActivityCode

Declaration
public static readonly int DeliveryConfirmedActivityCode
Field Value
Type | Description
System.Int32 |

DeliveryFailedActivityCode

Declaration
public static readonly int DeliveryFailedActivityCode
Field Value
Type | Description
System.Int32 |

DeliveryPendingActivityCode

Declaration
public static readonly int DeliveryPendingActivityCode
Field Value
Type | Description
System.Int32 |

Methods

AcceptSolution(AcceptSolutionSetup)

Declaration
public ToolkitResult AcceptSolution(AcceptSolutionSetup setupParam)
Parameters
Type | Name | Description
AcceptSolutionSetup | setupParam |
Returns
Type | Description
ToolkitResult |

AcceptSolution(AcceptSolutionSetup, IDbTransaction)

Declaration
public ToolkitResult AcceptSolution(AcceptSolutionSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
AcceptSolutionSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

AcceptSolution(String)

Declaration
public ToolkitResult AcceptSolution(string solutionIDNum)
Parameters
Type | Name | Description
System.String | solutionIDNum |
Returns
Type | Description
ToolkitResult |

AddContactToContract(AddContactToContractSetup)

Declaration
public ToolkitResult AddContactToContract(AddContactToContractSetup setupParam)
Parameters
Type | Name | Description
AddContactToContractSetup | setupParam |
Returns
Type | Description
ToolkitResult |

AddContactToContract(AddContactToContractSetup, IDbTransaction)

Declaration
public ToolkitResult AddContactToContract(AddContactToContractSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
AddContactToContractSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

AddContactToContract(String, String, String, String, String)

Declaration
public ToolkitResult AddContactToContract(string contractIDNum, string contactFirstName, string contactLastName, string contactPhone, string siteIDNum)
Parameters
Type | Name | Description
System.String | contractIDNum |
System.String | contactFirstName |
System.String | contactLastName |
System.String | contactPhone |
System.String | siteIDNum |
Returns
Type | Description
ToolkitResult |

AddEmployeeToAccount(AddEmployeeToAccountSetup)

Declaration
public ToolkitResult AddEmployeeToAccount(AddEmployeeToAccountSetup setupParam)
Parameters
Type | Name | Description
AddEmployeeToAccountSetup | setupParam |
Returns
Type | Description
ToolkitResult |

AddEmployeeToAccount(AddEmployeeToAccountSetup, IDbTransaction)

Declaration
public ToolkitResult AddEmployeeToAccount(AddEmployeeToAccountSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
AddEmployeeToAccountSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

AddEmployeeToAccount(String, String)

Declaration
public ToolkitResult AddEmployeeToAccount(string userName, string accountIDNum)
Parameters
Type | Name | Description
System.String | userName |
System.String | accountIDNum |
Returns
Type | Description
ToolkitResult |

AddSitePartToContract(AddSitePartToContractSetup)

Declaration
public ToolkitResult AddSitePartToContract(AddSitePartToContractSetup setupParam)
Parameters
Type | Name | Description
AddSitePartToContractSetup | setupParam |
Returns
Type | Description
ToolkitResult |

AddSitePartToContract(AddSitePartToContractSetup, IDbTransaction)

Declaration
public ToolkitResult AddSitePartToContract(AddSitePartToContractSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
AddSitePartToContractSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

AddSitePartToContract(String, String, Int32)

Declaration
public ToolkitResult AddSitePartToContract(string contractIDNum, string siteIDNum, int sitePartObjid)
Parameters
Type | Name | Description
System.String | contractIDNum |
System.String | siteIDNum |
System.Int32 | sitePartObjid |
Returns
Type | Description
ToolkitResult |

AddSiteToAccount(AddSiteToAccountSetup)

Declaration
public ToolkitResult AddSiteToAccount(AddSiteToAccountSetup setupParam)
Parameters
Type | Name | Description
AddSiteToAccountSetup | setupParam |
Returns
Type | Description
ToolkitResult |

AddSiteToAccount(AddSiteToAccountSetup, IDbTransaction)

Declaration
public ToolkitResult AddSiteToAccount(AddSiteToAccountSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
AddSiteToAccountSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

AddSiteToAccount(String, String, String)

Declaration
public ToolkitResult AddSiteToAccount(string siteIDNum, string accountIDNum, string roleName)
Parameters
Type | Name | Description
System.String | siteIDNum |
System.String | accountIDNum |
System.String | roleName |
Returns
Type | Description
ToolkitResult |

AddSiteToContract(AddSiteToContractSetup)

Declaration
public ToolkitResult AddSiteToContract(AddSiteToContractSetup setupParam)
Parameters
Type | Name | Description
AddSiteToContractSetup | setupParam |
Returns
Type | Description
ToolkitResult |

AddSiteToContract(AddSiteToContractSetup, IDbTransaction)

Declaration
public ToolkitResult AddSiteToContract(AddSiteToContractSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
AddSiteToContractSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

AddSiteToContract(String, String)

Declaration
public ToolkitResult AddSiteToContract(string contractIDNum, string siteIDNum)
Parameters
Type | Name | Description
System.String | contractIDNum |
System.String | siteIDNum |
Returns
Type | Description
ToolkitResult |

AddUserToQueue(AddUserToQueueSetup)

Declaration
public ToolkitResult AddUserToQueue(AddUserToQueueSetup setupParam)
Parameters
Type | Name | Description
AddUserToQueueSetup | setupParam |
Returns
Type | Description
ToolkitResult |

AddUserToQueue(AddUserToQueueSetup, IDbTransaction)

Declaration
public ToolkitResult AddUserToQueue(AddUserToQueueSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
AddUserToQueueSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

AddUserToQueue(String, String)

Declaration
public ToolkitResult AddUserToQueue(string queue, string userName)
Parameters
Type | Name | Description
System.String | queue |
System.String | userName |
Returns
Type | Description
ToolkitResult |

AddWorkaround(AddWorkaroundSetup)

Declaration
public ToolkitResult AddWorkaround(AddWorkaroundSetup setupParam)
Parameters
Type | Name | Description
AddWorkaroundSetup | setupParam |
Returns
Type | Description
ToolkitResult |

AddWorkaround(AddWorkaroundSetup, IDbTransaction)

Declaration
public ToolkitResult AddWorkaround(AddWorkaroundSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
AddWorkaroundSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

AddWorkaround(Int32, String)

Declaration
public ToolkitResult AddWorkaround(int solutionObjid, string workaround)
Parameters
Type | Name | Description
System.Int32 | solutionObjid |
System.String | workaround |
Returns
Type | Description
ToolkitResult |

AddWorkaround(String, String)

Declaration
public ToolkitResult AddWorkaround(string solutionIDNum, string workaround)
Parameters
Type | Name | Description
System.String | solutionIDNum |
System.String | workaround |
Returns
Type | Description
ToolkitResult |

AssignSolution(AssignSolutionSetup)

Declaration
public ToolkitResult AssignSolution(AssignSolutionSetup setupParam)
Parameters
Type | Name | Description
AssignSolutionSetup | setupParam |
Returns
Type | Description
ToolkitResult |

AssignSolution(AssignSolutionSetup, IDbTransaction)

Declaration
public ToolkitResult AssignSolution(AssignSolutionSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
AssignSolutionSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

AssignSolution(String)

Declaration
public ToolkitResult AssignSolution(string solutionIDNum)
Parameters
Type | Name | Description
System.String | solutionIDNum |
Returns
Type | Description
ToolkitResult |

CreateAccount()

Declaration
public ToolkitResult CreateAccount()
Returns
Type | Description
ToolkitResult |

CreateAccount(CreateAccountSetup)

Declaration
public ToolkitResult CreateAccount(CreateAccountSetup setupParam)
Parameters
Type | Name | Description
CreateAccountSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreateAccount(CreateAccountSetup, IDbTransaction)

Declaration
public ToolkitResult CreateAccount(CreateAccountSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateAccountSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreateAddress(CreateAddressSetup)

Declaration
public ToolkitResult CreateAddress(CreateAddressSetup setupParam)
Parameters
Type | Name | Description
CreateAddressSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreateAddress(CreateAddressSetup, IDbTransaction)

Declaration
public ToolkitResult CreateAddress(CreateAddressSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateAddressSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreateAddress(String, String, String, String, String, String)

Declaration
public ToolkitResult CreateAddress(string address1, string city, string state, string zipCode, string country, string timeZone)
Parameters
Type | Name | Description
System.String | address1 |
System.String | city |
System.String | state |
System.String | zipCode |
System.String | country |
System.String | timeZone |
Returns
Type | Description
ToolkitResult |

CreateBOM(CreateBOMSetup)

Declaration
public ToolkitResult CreateBOM(CreateBOMSetup setupParam)
Parameters
Type | Name | Description
CreateBOMSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreateBOM(CreateBOMSetup, IDbTransaction)

Declaration
public ToolkitResult CreateBOM(CreateBOMSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateBOMSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreateBOM(String, String, String, String, String, String, Int32)

Declaration
public ToolkitResult CreateBOM(string parentPartNumber, string parentPartDomain, string parentPartRevision, string childPartNumber, string childPartDomain, string childPartRevision, int quantity)
Parameters
Type | Name | Description
System.String | parentPartNumber |
System.String | parentPartDomain |
System.String | parentPartRevision |
System.String | childPartNumber |
System.String | childPartDomain |
System.String | childPartRevision |
System.Int32 | quantity |
Returns
Type | Description
ToolkitResult |

CreateChannel(CreateChannelSetup)

Declaration
public ToolkitResult CreateChannel(CreateChannelSetup setup)
Parameters
Type | Name | Description
CreateChannelSetup | setup |
Returns
Type | Description
ToolkitResult |

CreateChannel(CreateChannelSetup, IDbTransaction)

Declaration
public ToolkitResult CreateChannel(CreateChannelSetup setup, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateChannelSetup | setup |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreateCommunication(CreateCommunicationSetup)

Declaration
public ToolkitResult CreateCommunication(CreateCommunicationSetup setup)
Parameters
Type | Name | Description
CreateCommunicationSetup | setup |
Returns
Type | Description
ToolkitResult |

CreateCommunication(CreateCommunicationSetup, IDbTransaction)

Declaration
public ToolkitResult CreateCommunication(CreateCommunicationSetup setup, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateCommunicationSetup | setup |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreateContact(CreateContactSetup)

Declaration
public ToolkitResult CreateContact(CreateContactSetup setupParam)
Parameters
Type | Name | Description
CreateContactSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreateContact(CreateContactSetup, IDbTransaction)

Declaration
public ToolkitResult CreateContact(CreateContactSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateContactSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreateContact(String, String, String, String)

Declaration
public ToolkitResult CreateContact(string firstName, string lastName, string phone, string siteIDNum)
Parameters
Type | Name | Description
System.String | firstName |
System.String | lastName |
System.String | phone |
System.String | siteIDNum |
Returns
Type | Description
ToolkitResult |

CreateContract()

Declaration
public ToolkitResult CreateContract()
Returns
Type | Description
ToolkitResult |

CreateContract(CreateContractSetup)

Declaration
public ToolkitResult CreateContract(CreateContractSetup setupParam)
Parameters
Type | Name | Description
CreateContractSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreateContract(CreateContractSetup, IDbTransaction)

Declaration
public ToolkitResult CreateContract(CreateContractSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateContractSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreateCountry(CreateCountrySetup)

Declaration
public ToolkitResult CreateCountry(CreateCountrySetup setupParam)
Parameters
Type | Name | Description
CreateCountrySetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreateCountry(CreateCountrySetup, IDbTransaction)

Declaration
public ToolkitResult CreateCountry(CreateCountrySetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateCountrySetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreateCountry(String, Int32)

Declaration
public ToolkitResult CreateCountry(string country, int countryCode)
Parameters
Type | Name | Description
System.String | country |
System.Int32 | countryCode |
Returns
Type | Description
ToolkitResult |

CreateDialogue()

Declaration
public ToolkitResult CreateDialogue()
Returns
Type | Description
ToolkitResult |

CreateDialogue(CreateDialogueSetup)

Declaration
public ToolkitResult CreateDialogue(CreateDialogueSetup createDialogueSetup)
Parameters
Type | Name | Description
CreateDialogueSetup | createDialogueSetup |
Returns
Type | Description
ToolkitResult |

CreateDialogue(CreateDialogueSetup, IDbTransaction)

Declaration
public ToolkitResult CreateDialogue(CreateDialogueSetup setup, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateDialogueSetup | setup |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreateEmployee(CreateEmployeeSetup)

Declaration
public CreateEmployeeResult CreateEmployee(CreateEmployeeSetup setupParam)
Parameters
Type | Name | Description
CreateEmployeeSetup | setupParam |
Returns
Type | Description
CreateEmployeeResult |

CreateEmployee(CreateEmployeeSetup, IDbTransaction)

Declaration
public CreateEmployeeResult CreateEmployee(CreateEmployeeSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateEmployeeSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
CreateEmployeeResult |

CreateEmployee(String, String, String, String, String, String, String)

Declaration
public CreateEmployeeResult CreateEmployee(string firstName, string lastName, string loginName, string password, string siteIDNum, string email, string onlinePrivilegeClass)
Parameters
Type | Name | Description
System.String | firstName |
System.String | lastName |
System.String | loginName |
System.String | password |
System.String | siteIDNum |
System.String | email |
System.String | onlinePrivilegeClass |
Returns
Type | Description
CreateEmployeeResult |

CreateInteraction(CreateInteractionSetup)

Declaration
public ToolkitResult CreateInteraction(CreateInteractionSetup setupParam)
Parameters
Type | Name | Description
CreateInteractionSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreateInteraction(CreateInteractionSetup, IDbTransaction)

Declaration
public ToolkitResult CreateInteraction(CreateInteractionSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateInteractionSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreateInteraction(String, String, String, TimeSpan)

Declaration
public ToolkitResult CreateInteraction(string contactFirstName, string contactLastName, string contactPhone, TimeSpan duration)
Parameters
Type | Name | Description
System.String | contactFirstName |
System.String | contactLastName |
System.String | contactPhone |
System.TimeSpan | duration |
Returns
Type | Description
ToolkitResult |

CreatePart(CreatePartSetup)

Declaration
public ToolkitResult CreatePart(CreatePartSetup setupParam)
Parameters
Type | Name | Description
CreatePartSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreatePart(CreatePartSetup, IDbTransaction)

Declaration
public ToolkitResult CreatePart(CreatePartSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreatePartSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreatePart(String, String, Int32, PartRepairType)

Declaration
public ToolkitResult CreatePart(string partNumber, string partDomain, int warrantyDays, PartRepairType repairType)
Parameters
Type | Name | Description
System.String | partNumber |
System.String | partDomain |
System.Int32 | warrantyDays |
PartRepairType | repairType |
Returns
Type | Description
ToolkitResult |

CreatePartRevision(CreatePartRevisionSetup)

Declaration
public ToolkitResult CreatePartRevision(CreatePartRevisionSetup setupParam)
Parameters
Type | Name | Description
CreatePartRevisionSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreatePartRevision(CreatePartRevisionSetup, IDbTransaction)

Declaration
public ToolkitResult CreatePartRevision(CreatePartRevisionSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreatePartRevisionSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreatePartRevision(String, String, String)

Declaration
public ToolkitResult CreatePartRevision(string partNumber, string partDomain, string partRevision)
Parameters
Type | Name | Description
System.String | partNumber |
System.String | partDomain |
System.String | partRevision |
Returns
Type | Description
ToolkitResult |

CreatePriceInstance(CreatePriceInstanceSetup)

Declaration
public ToolkitResult CreatePriceInstance(CreatePriceInstanceSetup setupParam)
Parameters
Type | Name | Description
CreatePriceInstanceSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreatePriceInstance(CreatePriceInstanceSetup, IDbTransaction)

Declaration
public ToolkitResult CreatePriceInstance(CreatePriceInstanceSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreatePriceInstanceSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreatePriceInstance(String, String, String, String, PriceInstanceType, Int32, Decimal)

Declaration
public ToolkitResult CreatePriceInstance(string partNumber, string partDomain, string partRevision, string priceProgram, PriceInstanceType priceType, int pricedQuantity, decimal price)
Parameters
Type | Name | Description
System.String | partNumber |
System.String | partDomain |
System.String | partRevision |
System.String | priceProgram |
PriceInstanceType | priceType |
System.Int32 | pricedQuantity |
System.Decimal | price |
Returns
Type | Description
ToolkitResult |

CreateProductBin(CreateProductBinSetup)

Declaration
public ToolkitResult CreateProductBin(CreateProductBinSetup setupParam)
Parameters
Type | Name | Description
CreateProductBinSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreateProductBin(CreateProductBinSetup, IDbTransaction)

Declaration
public ToolkitResult CreateProductBin(CreateProductBinSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateProductBinSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreateProductBin(String, String)

Declaration
public ToolkitResult CreateProductBin(string binName, string siteIDNum)
Parameters
Type | Name | Description
System.String | binName |
System.String | siteIDNum |
Returns
Type | Description
ToolkitResult |

CreateQueue(CreateQueueSetup)

Declaration
public ToolkitResult CreateQueue(CreateQueueSetup setupParam)
Parameters
Type | Name | Description
CreateQueueSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreateQueue(CreateQueueSetup, IDbTransaction)

Declaration
public ToolkitResult CreateQueue(CreateQueueSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateQueueSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreateQueue(String, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)

Declaration
public ToolkitResult CreateQueue(string title, bool allowCR, bool allowCase, bool allowContract, bool allowDialogue, bool allowDemandDetail, bool allowJob, bool allowOpportunity, bool allowSolution, bool allowSubcase, bool allowActionItem)
Parameters
Type | Name | Description
System.String | title |
System.Boolean | allowCR |
System.Boolean | allowCase |
System.Boolean | allowContract |
System.Boolean | allowDialogue |
System.Boolean | allowDemandDetail |
System.Boolean | allowJob |
System.Boolean | allowOpportunity |
System.Boolean | allowSolution |
System.Boolean | allowSubcase |
System.Boolean | allowActionItem |
Returns
Type | Description
ToolkitResult |

CreateSite(CreateSiteSetup)

Declaration
public ToolkitResult CreateSite(CreateSiteSetup setupParam)
Parameters
Type | Name | Description
CreateSiteSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreateSite(CreateSiteSetup, IDbTransaction)

Declaration
public ToolkitResult CreateSite(CreateSiteSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateSiteSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreateSite(SiteType, SiteStatus, Int32)

Declaration
public ToolkitResult CreateSite(SiteType siteType, SiteStatus status, int primaryAddressObjid)
Parameters
Type | Name | Description
SiteType | siteType |
SiteStatus | status |
System.Int32 | primaryAddressObjid |
Returns
Type | Description
ToolkitResult |

CreateSolution()

Declaration
public CreateSolutionResult CreateSolution()
Returns
Type | Description
CreateSolutionResult |

CreateSolution(CreateSolutionSetup)

Declaration
public CreateSolutionResult CreateSolution(CreateSolutionSetup setupParam)
Parameters
Type | Name | Description
CreateSolutionSetup | setupParam |
Returns
Type | Description
CreateSolutionResult |

CreateSolution(CreateSolutionSetup, IDbTransaction)

Declaration
public CreateSolutionResult CreateSolution(CreateSolutionSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateSolutionSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
CreateSolutionResult |

CreateState(CreateStateSetup)

Declaration
public ToolkitResult CreateState(CreateStateSetup setupParam)
Parameters
Type | Name | Description
CreateStateSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreateState(CreateStateSetup, IDbTransaction)

Declaration
public ToolkitResult CreateState(CreateStateSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateStateSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreateState(String, String, String)

Declaration
public ToolkitResult CreateState(string state, string fullName, string country)
Parameters
Type | Name | Description
System.String | state |
System.String | fullName |
System.String | country |
Returns
Type | Description
ToolkitResult |

CreateTimeZone(CreateTimeZoneSetup)

Declaration
public ToolkitResult CreateTimeZone(CreateTimeZoneSetup setupParam)
Parameters
Type | Name | Description
CreateTimeZoneSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreateTimeZone(CreateTimeZoneSetup, IDbTransaction)

Declaration
public ToolkitResult CreateTimeZone(CreateTimeZoneSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateTimeZoneSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreateTimeZone(String, String, String)

Declaration
public ToolkitResult CreateTimeZone(string timeZone, string fullName, string country)
Parameters
Type | Name | Description
System.String | timeZone |
System.String | fullName |
System.String | country |
Returns
Type | Description
ToolkitResult |

CreateWipBin(CreateWipBinSetup)

Declaration
public ToolkitResult CreateWipBin(CreateWipBinSetup setupParam)
Parameters
Type | Name | Description
CreateWipBinSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreateWipBin(CreateWipBinSetup, IDbTransaction)

Declaration
public ToolkitResult CreateWipBin(CreateWipBinSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateWipBinSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreateWipBin(String)

Declaration
public ToolkitResult CreateWipBin(string title)
Parameters
Type | Name | Description
System.String | title |
Returns
Type | Description
ToolkitResult |

DeinstallSitePart(DeinstallSitePartSetup)

Declaration
public ToolkitResult DeinstallSitePart(DeinstallSitePartSetup setupParam)
Parameters
Type | Name | Description
DeinstallSitePartSetup | setupParam |
Returns
Type | Description
ToolkitResult |

DeinstallSitePart(DeinstallSitePartSetup, IDbTransaction)

Declaration
public ToolkitResult DeinstallSitePart(DeinstallSitePartSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
DeinstallSitePartSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

DeinstallSitePart(Int32)

Declaration
public ToolkitResult DeinstallSitePart(int sitePartObjid)
Parameters
Type | Name | Description
System.Int32 | sitePartObjid |
Returns
Type | Description
ToolkitResult |

DeleteProductBin(DeleteProductBinSetup)

Declaration
public ToolkitResult DeleteProductBin(DeleteProductBinSetup setupParam)
Parameters
Type | Name | Description
DeleteProductBinSetup | setupParam |
Returns
Type | Description
ToolkitResult |

DeleteProductBin(DeleteProductBinSetup, IDbTransaction)

Declaration
public ToolkitResult DeleteProductBin(DeleteProductBinSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
DeleteProductBinSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

DeleteProductBin(Int32)

Declaration
public ToolkitResult DeleteProductBin(int binObjid)
Parameters
Type | Name | Description
System.Int32 | binObjid |
Returns
Type | Description
ToolkitResult |

DispatchSolution(DispatchSolutionSetup)

Declaration
public ToolkitResult DispatchSolution(DispatchSolutionSetup setupParam)
Parameters
Type | Name | Description
DispatchSolutionSetup | setupParam |
Returns
Type | Description
ToolkitResult |

DispatchSolution(DispatchSolutionSetup, IDbTransaction)

Declaration
public ToolkitResult DispatchSolution(DispatchSolutionSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
DispatchSolutionSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

DispatchSolution(String, String)

Declaration
public ToolkitResult DispatchSolution(string solutionIDNum, string queue)
Parameters
Type | Name | Description
System.String | solutionIDNum |
System.String | queue |
Returns
Type | Description
ToolkitResult |

ForwardSolution(ForwardSolutionSetup)

Declaration
public ToolkitResult ForwardSolution(ForwardSolutionSetup setupParam)
Parameters
Type | Name | Description
ForwardSolutionSetup | setupParam |
Returns
Type | Description
ToolkitResult |

ForwardSolution(ForwardSolutionSetup, IDbTransaction)

Declaration
public ToolkitResult ForwardSolution(ForwardSolutionSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
ForwardSolutionSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

ForwardSolution(String, String)

Declaration
public ToolkitResult ForwardSolution(string solutionIDNum, string newQueue)
Parameters
Type | Name | Description
System.String | solutionIDNum |
System.String | newQueue |
Returns
Type | Description
ToolkitResult |

InstallSitePartToBin(InstallSitePartToBinSetup)

Declaration
public ToolkitResult InstallSitePartToBin(InstallSitePartToBinSetup setupParam)
Parameters
Type | Name | Description
InstallSitePartToBinSetup | setupParam |
Returns
Type | Description
ToolkitResult |

InstallSitePartToBin(InstallSitePartToBinSetup, IDbTransaction)

Declaration
public ToolkitResult InstallSitePartToBin(InstallSitePartToBinSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
InstallSitePartToBinSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

InstallSitePartToBin(String, Int32, String, String, String, Int32)

Declaration
public ToolkitResult InstallSitePartToBin(string siteIDNum, int parentBinObjid, string partNumber, string partRevision, string partDomain, int quantity)
Parameters
Type | Name | Description
System.String | siteIDNum |
System.Int32 | parentBinObjid |
System.String | partNumber |
System.String | partRevision |
System.String | partDomain |
System.Int32 | quantity |
Returns
Type | Description
ToolkitResult |

InstallSitePartToBin(String, String, String, String, String)

Declaration
public ToolkitResult InstallSitePartToBin(string siteIDNum, string partNumber, string partRevision, string partDomain, string serialNumber)
Parameters
Type | Name | Description
System.String | siteIDNum |
System.String | partNumber |
System.String | partRevision |
System.String | partDomain |
System.String | serialNumber |
Returns
Type | Description
ToolkitResult |

InstallSitePartToPart(InstallSitePartToPartSetup)

Declaration
public ToolkitResult InstallSitePartToPart(InstallSitePartToPartSetup setupParam)
Parameters
Type | Name | Description
InstallSitePartToPartSetup | setupParam |
Returns
Type | Description
ToolkitResult |

InstallSitePartToPart(InstallSitePartToPartSetup, IDbTransaction)

Declaration
public ToolkitResult InstallSitePartToPart(InstallSitePartToPartSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
InstallSitePartToPartSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

InstallSitePartToPart(String, Int32, String, String, String, Int32)

Declaration
public ToolkitResult InstallSitePartToPart(string siteIDNum, int parentSitePartObjid, string partNumber, string partRevision, string partDomain, int quantity)
Parameters
Type | Name | Description
System.String | siteIDNum |
System.Int32 | parentSitePartObjid |
System.String | partNumber |
System.String | partRevision |
System.String | partDomain |
System.Int32 | quantity |
Returns
Type | Description
ToolkitResult |

InstallSitePartToPart(String, String, String, String, String)

Declaration
public ToolkitResult InstallSitePartToPart(string siteIDNum, string partNumber, string partRevision, string partDomain, string serialNumber)
Parameters
Type | Name | Description
System.String | siteIDNum |
System.String | partNumber |
System.String | partRevision |
System.String | partDomain |
System.String | serialNumber |
Returns
Type | Description
ToolkitResult |

InstallSitePartToSite(InstallSitePartToSiteSetup)

Declaration
public ToolkitResult InstallSitePartToSite(InstallSitePartToSiteSetup setupParam)
Parameters
Type | Name | Description
InstallSitePartToSiteSetup | setupParam |
Returns
Type | Description
ToolkitResult |

InstallSitePartToSite(InstallSitePartToSiteSetup, IDbTransaction)

Declaration
public ToolkitResult InstallSitePartToSite(InstallSitePartToSiteSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
InstallSitePartToSiteSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

InstallSitePartToSite(String, String, String, String, Int32)

Declaration
public ToolkitResult InstallSitePartToSite(string siteIDNum, string partNumber, string partRevision, string partDomain, int quantity)
Parameters
Type | Name | Description
System.String | siteIDNum |
System.String | partNumber |
System.String | partRevision |
System.String | partDomain |
System.Int32 | quantity |
Returns
Type | Description
ToolkitResult |

InstallSitePartToSite(String, String, String, String, String)

Declaration
public ToolkitResult InstallSitePartToSite(string siteIDNum, string partNumber, string partRevision, string partDomain, string serialNumber)
Parameters
Type | Name | Description
System.String | siteIDNum |
System.String | partNumber |
System.String | partRevision |
System.String | partDomain |
System.String | serialNumber |
Returns
Type | Description
ToolkitResult |

LinkCaseToWorkaround(LinkCaseToWorkaroundSetup)

Declaration
public ToolkitResult LinkCaseToWorkaround(LinkCaseToWorkaroundSetup setupParam)
Parameters
Type | Name | Description
LinkCaseToWorkaroundSetup | setupParam |
Returns
Type | Description
ToolkitResult |

LinkCaseToWorkaround(LinkCaseToWorkaroundSetup, IDbTransaction)

Declaration
public ToolkitResult LinkCaseToWorkaround(LinkCaseToWorkaroundSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
LinkCaseToWorkaroundSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

LinkCaseToWorkaround(String, Int32)

Declaration
public ToolkitResult LinkCaseToWorkaround(string caseIDNum, int workaroundObjid)
Parameters
Type | Name | Description
System.String | caseIDNum |
System.Int32 | workaroundObjid |
Returns
Type | Description
ToolkitResult |

LinkCRToSolution(LinkCRToSolutionSetup)

Declaration
public ToolkitResult LinkCRToSolution(LinkCRToSolutionSetup setupParam)
Parameters
Type | Name | Description
LinkCRToSolutionSetup | setupParam |
Returns
Type | Description
ToolkitResult |

LinkCRToSolution(LinkCRToSolutionSetup, IDbTransaction)

Declaration
public ToolkitResult LinkCRToSolution(LinkCRToSolutionSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
LinkCRToSolutionSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

LinkCRToSolution(String, String)

Declaration
public ToolkitResult LinkCRToSolution(string crIDNum, string solutionIDNum)
Parameters
Type | Name | Description
System.String | crIDNum |
System.String | solutionIDNum |
Returns
Type | Description
ToolkitResult |

MoveSitePartToBin(MoveSitePartToBinSetup)

Declaration
public ToolkitResult MoveSitePartToBin(MoveSitePartToBinSetup setupParam)
Parameters
Type | Name | Description
MoveSitePartToBinSetup | setupParam |
Returns
Type | Description
ToolkitResult |

MoveSitePartToBin(MoveSitePartToBinSetup, IDbTransaction)

Declaration
public ToolkitResult MoveSitePartToBin(MoveSitePartToBinSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
MoveSitePartToBinSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

MoveSitePartToBin(Int32, Int32)

Declaration
public ToolkitResult MoveSitePartToBin(int sitePartObjid, int parentBinObjid)
Parameters
Type | Name | Description
System.Int32 | sitePartObjid |
System.Int32 | parentBinObjid |
Returns
Type | Description
ToolkitResult |

MoveSitePartToPart(MoveSitePartToPartSetup)

Declaration
public ToolkitResult MoveSitePartToPart(MoveSitePartToPartSetup setupParam)
Parameters
Type | Name | Description
MoveSitePartToPartSetup | setupParam |
Returns
Type | Description
ToolkitResult |

MoveSitePartToPart(MoveSitePartToPartSetup, IDbTransaction)

Declaration
public ToolkitResult MoveSitePartToPart(MoveSitePartToPartSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
MoveSitePartToPartSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

MoveSitePartToPart(Int32, Int32)

Declaration
public ToolkitResult MoveSitePartToPart(int sitePartObjid, int parentSitePartObjid)
Parameters
Type | Name | Description
System.Int32 | sitePartObjid |
System.Int32 | parentSitePartObjid |
Returns
Type | Description
ToolkitResult |

MoveSitePartToSite(MoveSitePartToSiteSetup)

Declaration
public ToolkitResult MoveSitePartToSite(MoveSitePartToSiteSetup setupParam)
Parameters
Type | Name | Description
MoveSitePartToSiteSetup | setupParam |
Returns
Type | Description
ToolkitResult |

MoveSitePartToSite(MoveSitePartToSiteSetup, IDbTransaction)

Declaration
public ToolkitResult MoveSitePartToSite(MoveSitePartToSiteSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
MoveSitePartToSiteSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

MoveSitePartToSite(Int32, String)

Declaration
public ToolkitResult MoveSitePartToSite(int sitePartObjid, string parentSiteIDNum)
Parameters
Type | Name | Description
System.Int32 | sitePartObjid |
System.String | parentSiteIDNum |
Returns
Type | Description
ToolkitResult |

MoveSolution(MoveSolutionSetup)

Declaration
public ToolkitResult MoveSolution(MoveSolutionSetup setupParam)
Parameters
Type | Name | Description
MoveSolutionSetup | setupParam |
Returns
Type | Description
ToolkitResult |

MoveSolution(MoveSolutionSetup, IDbTransaction)

Declaration
public ToolkitResult MoveSolution(MoveSolutionSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
MoveSolutionSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

MoveSolution(String, String)

Declaration
public ToolkitResult MoveSolution(string solutionIDNum, string newWipBin)
Parameters
Type | Name | Description
System.String | solutionIDNum |
System.String | newWipBin |
Returns
Type | Description
ToolkitResult |

ReinstallSitePartToBin(ReinstallSitePartToBinSetup)

Declaration
public ToolkitResult ReinstallSitePartToBin(ReinstallSitePartToBinSetup setupParam)
Parameters
Type | Name | Description
ReinstallSitePartToBinSetup | setupParam |
Returns
Type | Description
ToolkitResult |

ReinstallSitePartToBin(ReinstallSitePartToBinSetup, IDbTransaction)

Declaration
public ToolkitResult ReinstallSitePartToBin(ReinstallSitePartToBinSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
ReinstallSitePartToBinSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

ReinstallSitePartToBin(Int32, String, Int32)

Declaration
public ToolkitResult ReinstallSitePartToBin(int sitePartObjid, string siteIDNum, int parentBinObjid)
Parameters
Type | Name | Description
System.Int32 | sitePartObjid |
System.String | siteIDNum |
System.Int32 | parentBinObjid |
Returns
Type | Description
ToolkitResult |

ReinstallSitePartToPart(ReinstallSitePartToPartSetup)

Declaration
public ToolkitResult ReinstallSitePartToPart(ReinstallSitePartToPartSetup setupParam)
Parameters
Type | Name | Description
ReinstallSitePartToPartSetup | setupParam |
Returns
Type | Description
ToolkitResult |

ReinstallSitePartToPart(ReinstallSitePartToPartSetup, IDbTransaction)

Declaration
public ToolkitResult ReinstallSitePartToPart(ReinstallSitePartToPartSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
ReinstallSitePartToPartSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

ReinstallSitePartToPart(Int32, String, Int32)

Declaration
public ToolkitResult ReinstallSitePartToPart(int sitePartObjid, string siteIDNum, int parentSitePartObjid)
Parameters
Type | Name | Description
System.Int32 | sitePartObjid |
System.String | siteIDNum |
System.Int32 | parentSitePartObjid |
Returns
Type | Description
ToolkitResult |

ReinstallSitePartToSite(ReinstallSitePartToSiteSetup)

Declaration
public ToolkitResult ReinstallSitePartToSite(ReinstallSitePartToSiteSetup setupParam)
Parameters
Type | Name | Description
ReinstallSitePartToSiteSetup | setupParam |
Returns
Type | Description
ToolkitResult |

ReinstallSitePartToSite(ReinstallSitePartToSiteSetup, IDbTransaction)

Declaration
public ToolkitResult ReinstallSitePartToSite(ReinstallSitePartToSiteSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
ReinstallSitePartToSiteSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

ReinstallSitePartToSite(Int32, String)

Declaration
public ToolkitResult ReinstallSitePartToSite(int sitePartObjid, string siteIDNum)
Parameters
Type | Name | Description
System.Int32 | sitePartObjid |
System.String | siteIDNum |
Returns
Type | Description
ToolkitResult |

RejectSolution(RejectSolutionSetup)

Declaration
public ToolkitResult RejectSolution(RejectSolutionSetup setupParam)
Parameters
Type | Name | Description
RejectSolutionSetup | setupParam |
Returns
Type | Description
ToolkitResult |

RejectSolution(RejectSolutionSetup, IDbTransaction)

Declaration
public ToolkitResult RejectSolution(RejectSolutionSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
RejectSolutionSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

RejectSolution(String)

Declaration
public ToolkitResult RejectSolution(string solutionIDNum)
Parameters
Type | Name | Description
System.String | solutionIDNum |
Returns
Type | Description
ToolkitResult |

RemoveContactFromContract(RemoveContactFromContractSetup)

Declaration
public ToolkitResult RemoveContactFromContract(RemoveContactFromContractSetup setupParam)
Parameters
Type | Name | Description
RemoveContactFromContractSetup | setupParam |
Returns
Type | Description
ToolkitResult |

RemoveContactFromContract(RemoveContactFromContractSetup, IDbTransaction)

Declaration
public ToolkitResult RemoveContactFromContract(RemoveContactFromContractSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
RemoveContactFromContractSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

RemoveContactFromContract(String, Int32)

Declaration
public ToolkitResult RemoveContactFromContract(string contractIDNum, int contactObjid)
Parameters
Type | Name | Description
System.String | contractIDNum |
System.Int32 | contactObjid |
Returns
Type | Description
ToolkitResult |

RemoveEmployeeFromAccount(RemoveEmployeeFromAccountSetup)

Declaration
public ToolkitResult RemoveEmployeeFromAccount(RemoveEmployeeFromAccountSetup setupParam)
Parameters
Type | Name | Description
RemoveEmployeeFromAccountSetup | setupParam |
Returns
Type | Description
ToolkitResult |

RemoveEmployeeFromAccount(RemoveEmployeeFromAccountSetup, IDbTransaction)

Declaration
public ToolkitResult RemoveEmployeeFromAccount(RemoveEmployeeFromAccountSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
RemoveEmployeeFromAccountSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

RemoveEmployeeFromAccount(String, String, String)

Declaration
public ToolkitResult RemoveEmployeeFromAccount(string userName, string accountIDNum, string roleName)
Parameters
Type | Name | Description
System.String | userName |
System.String | accountIDNum |
System.String | roleName |
Returns
Type | Description
ToolkitResult |

RemoveSiteFromAccount(RemoveSiteFromAccountSetup)

Declaration
public ToolkitResult RemoveSiteFromAccount(RemoveSiteFromAccountSetup setupParam)
Parameters
Type | Name | Description
RemoveSiteFromAccountSetup | setupParam |
Returns
Type | Description
ToolkitResult |

RemoveSiteFromAccount(RemoveSiteFromAccountSetup, IDbTransaction)

Declaration
public ToolkitResult RemoveSiteFromAccount(RemoveSiteFromAccountSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
RemoveSiteFromAccountSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

RemoveSiteFromAccount(String, String, String)

Declaration
public ToolkitResult RemoveSiteFromAccount(string siteIDNum, string accountIDNum, string roleName)
Parameters
Type | Name | Description
System.String | siteIDNum |
System.String | accountIDNum |
System.String | roleName |
Returns
Type | Description
ToolkitResult |

RemoveSiteFromContract(RemoveSiteFromContractSetup)

Declaration
public ToolkitResult RemoveSiteFromContract(RemoveSiteFromContractSetup setupParam)
Parameters
Type | Name | Description
RemoveSiteFromContractSetup | setupParam |
Returns
Type | Description
ToolkitResult |

RemoveSiteFromContract(RemoveSiteFromContractSetup, IDbTransaction)

Declaration
public ToolkitResult RemoveSiteFromContract(RemoveSiteFromContractSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
RemoveSiteFromContractSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

RemoveSiteFromContract(String, String)

Declaration
public ToolkitResult RemoveSiteFromContract(string contractIDNum, string siteIDNum)
Parameters
Type | Name | Description
System.String | contractIDNum |
System.String | siteIDNum |
Returns
Type | Description
ToolkitResult |

RemoveSitePartFromContract(RemoveSitePartFromContractSetup)

Declaration
public ToolkitResult RemoveSitePartFromContract(RemoveSitePartFromContractSetup setupParam)
Parameters
Type | Name | Description
RemoveSitePartFromContractSetup | setupParam |
Returns
Type | Description
ToolkitResult |

RemoveSitePartFromContract(RemoveSitePartFromContractSetup, IDbTransaction)

Declaration
public ToolkitResult RemoveSitePartFromContract(RemoveSitePartFromContractSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
RemoveSitePartFromContractSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

RemoveSitePartFromContract(String, Int32)

Declaration
public ToolkitResult RemoveSitePartFromContract(string contractIDNum, int sitePartObjid)
Parameters
Type | Name | Description
System.String | contractIDNum |
System.Int32 | sitePartObjid |
Returns
Type | Description
ToolkitResult |

ReopenDialogue(ReopenDialogueSetup)

Declaration
public ToolkitResult ReopenDialogue(ReopenDialogueSetup reopenDialogueSetup)
Parameters
Type | Name | Description
ReopenDialogueSetup | reopenDialogueSetup |
Returns
Type | Description
ToolkitResult |

ReopenDialogue(ReopenDialogueSetup, IDbTransaction)

Declaration
public ToolkitResult ReopenDialogue(ReopenDialogueSetup setup, IDbTransaction transaction)
Parameters
Type | Name | Description
ReopenDialogueSetup | setup |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

ReopenDialogue(String)

Declaration
public ToolkitResult ReopenDialogue(string idNumber)
Parameters
Type | Name | Description
System.String | idNumber |
Returns
Type | Description
ToolkitResult |

UnlinkCaseFromWorkaround(UnlinkCaseFromWorkaroundSetup)

Declaration
public ToolkitResult UnlinkCaseFromWorkaround(UnlinkCaseFromWorkaroundSetup setupParam)
Parameters
Type | Name | Description
UnlinkCaseFromWorkaroundSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UnlinkCaseFromWorkaround(UnlinkCaseFromWorkaroundSetup, IDbTransaction)

Declaration
public ToolkitResult UnlinkCaseFromWorkaround(UnlinkCaseFromWorkaroundSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UnlinkCaseFromWorkaroundSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UnlinkCaseFromWorkaround(String)

Declaration
public ToolkitResult UnlinkCaseFromWorkaround(string caseIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |
Returns
Type | Description
ToolkitResult |

UnlinkCRFromSolution(UnlinkCRFromSolutionSetup)

Declaration
public ToolkitResult UnlinkCRFromSolution(UnlinkCRFromSolutionSetup setupParam)
Parameters
Type | Name | Description
UnlinkCRFromSolutionSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UnlinkCRFromSolution(UnlinkCRFromSolutionSetup, IDbTransaction)

Declaration
public ToolkitResult UnlinkCRFromSolution(UnlinkCRFromSolutionSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UnlinkCRFromSolutionSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UnlinkCRFromSolution(String, String)

Declaration
public ToolkitResult UnlinkCRFromSolution(string crIDNum, string solutionIDNum)
Parameters
Type | Name | Description
System.String | crIDNum |
System.String | solutionIDNum |
Returns
Type | Description
ToolkitResult |

UpdateAccount(UpdateAccountSetup)

Declaration
public ToolkitResult UpdateAccount(UpdateAccountSetup setupParam)
Parameters
Type | Name | Description
UpdateAccountSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdateAccount(UpdateAccountSetup, IDbTransaction)

Declaration
public ToolkitResult UpdateAccount(UpdateAccountSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdateAccountSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UpdateAddress(UpdateAddressSetup)

Declaration
public ToolkitResult UpdateAddress(UpdateAddressSetup setupParam)
Parameters
Type | Name | Description
UpdateAddressSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdateAddress(UpdateAddressSetup, IDbTransaction)

Declaration
public ToolkitResult UpdateAddress(UpdateAddressSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdateAddressSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UpdateCommunication(UpdateCommunicationSetup)

Declaration
public ToolkitResult UpdateCommunication(UpdateCommunicationSetup updateCommunicationSetup)
Parameters
Type | Name | Description
UpdateCommunicationSetup | updateCommunicationSetup |
Returns
Type | Description
ToolkitResult |

UpdateCommunication(UpdateCommunicationSetup, IDbTransaction)

Declaration
public ToolkitResult UpdateCommunication(UpdateCommunicationSetup setup, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdateCommunicationSetup | setup |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UpdateContact(UpdateContactSetup)

Declaration
public ToolkitResult UpdateContact(UpdateContactSetup setupParam)
Parameters
Type | Name | Description
UpdateContactSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdateContact(UpdateContactSetup, IDbTransaction)

Declaration
public ToolkitResult UpdateContact(UpdateContactSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdateContactSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UpdateContact(String, String, String, String, String)

Declaration
public ToolkitResult UpdateContact(string firstName, string lastName, string phone, string siteIDNum, string roleName)
Parameters
Type | Name | Description
System.String | firstName |
System.String | lastName |
System.String | phone |
System.String | siteIDNum |
System.String | roleName |
Returns
Type | Description
ToolkitResult |

UpdateContactByObjid(UpdateContactByObjidSetup)

Declaration
public ToolkitResult UpdateContactByObjid(UpdateContactByObjidSetup setupParam)
Parameters
Type | Name | Description
UpdateContactByObjidSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdateContactByObjid(UpdateContactByObjidSetup, IDbTransaction)

Declaration
public ToolkitResult UpdateContactByObjid(UpdateContactByObjidSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdateContactByObjidSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UpdateContract(UpdateContractSetup)

Declaration
public ToolkitResult UpdateContract(UpdateContractSetup setupParam)
Parameters
Type | Name | Description
UpdateContractSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdateContract(UpdateContractSetup, IDbTransaction)

Declaration
public ToolkitResult UpdateContract(UpdateContractSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdateContractSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UpdateDialogue(UpdateDialogueSetup)

Declaration
public ToolkitResult UpdateDialogue(UpdateDialogueSetup updateDialogueSetup)
Parameters
Type | Name | Description
UpdateDialogueSetup | updateDialogueSetup |
Returns
Type | Description
ToolkitResult |

UpdateDialogue(UpdateDialogueSetup, IDbTransaction)

Declaration
public ToolkitResult UpdateDialogue(UpdateDialogueSetup setup, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdateDialogueSetup | setup |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UpdateDialogue(String, String, String)

Declaration
public ToolkitResult UpdateDialogue(string idNumber, string newTitle, string newPriority)
Parameters
Type | Name | Description
System.String | idNumber |
System.String | newTitle |
System.String | newPriority |
Returns
Type | Description
ToolkitResult |

UpdatePart(UpdatePartSetup)

Declaration
public ToolkitResult UpdatePart(UpdatePartSetup setupParam)
Parameters
Type | Name | Description
UpdatePartSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdatePart(UpdatePartSetup, IDbTransaction)

Declaration
public ToolkitResult UpdatePart(UpdatePartSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdatePartSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UpdatePart(String, String, Int32)

Declaration
public ToolkitResult UpdatePart(string partNumber, string partDomain, int warrantyDays)
Parameters
Type | Name | Description
System.String | partNumber |
System.String | partDomain |
System.Int32 | warrantyDays |
Returns
Type | Description
ToolkitResult |

UpdatePartRevision(UpdatePartRevisionSetup)

Declaration
public ToolkitResult UpdatePartRevision(UpdatePartRevisionSetup setupParam)
Parameters
Type | Name | Description
UpdatePartRevisionSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdatePartRevision(UpdatePartRevisionSetup, IDbTransaction)

Declaration
public ToolkitResult UpdatePartRevision(UpdatePartRevisionSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdatePartRevisionSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UpdatePartRevision(String, String, String)

Declaration
public ToolkitResult UpdatePartRevision(string partNumber, string partDomain, string partRevision)
Parameters
Type | Name | Description
System.String | partNumber |
System.String | partDomain |
System.String | partRevision |
Returns
Type | Description
ToolkitResult |

UpdatePriceInstance(UpdatePriceInstanceSetup)

Declaration
public ToolkitResult UpdatePriceInstance(UpdatePriceInstanceSetup setupParam)
Parameters
Type | Name | Description
UpdatePriceInstanceSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdatePriceInstance(UpdatePriceInstanceSetup, IDbTransaction)

Declaration
public ToolkitResult UpdatePriceInstance(UpdatePriceInstanceSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdatePriceInstanceSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UpdatePriceInstance(String, String, String, String, Int32, Decimal, DateTime)

Declaration
public ToolkitResult UpdatePriceInstance(string partNumber, string partDomain, string partRevision, string priceProgram, int pricedQuantity, decimal price, DateTime updateDate)
Parameters
Type | Name | Description
System.String | partNumber |
System.String | partDomain |
System.String | partRevision |
System.String | priceProgram |
System.Int32 | pricedQuantity |
System.Decimal | price |
System.DateTime | updateDate |
Returns
Type | Description
ToolkitResult |

UpdateProductBin(UpdateProductBinSetup)

Declaration
public ToolkitResult UpdateProductBin(UpdateProductBinSetup setupParam)
Parameters
Type | Name | Description
UpdateProductBinSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdateProductBin(UpdateProductBinSetup, IDbTransaction)

Declaration
public ToolkitResult UpdateProductBin(UpdateProductBinSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdateProductBinSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UpdateQueue(UpdateQueueSetup)

Declaration
public ToolkitResult UpdateQueue(UpdateQueueSetup setupParam)
Parameters
Type | Name | Description
UpdateQueueSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdateQueue(UpdateQueueSetup, IDbTransaction)

Declaration
public ToolkitResult UpdateQueue(UpdateQueueSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdateQueueSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UpdateSite(UpdateSiteSetup)

Declaration
public ToolkitResult UpdateSite(UpdateSiteSetup setupParam)
Parameters
Type | Name | Description
UpdateSiteSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdateSite(UpdateSiteSetup, IDbTransaction)

Declaration
public ToolkitResult UpdateSite(UpdateSiteSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdateSiteSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UpdateSiteByObjid(UpdateSiteByObjidSetup)

Declaration
public ToolkitResult UpdateSiteByObjid(UpdateSiteByObjidSetup setupParam)
Parameters
Type | Name | Description
UpdateSiteByObjidSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdateSiteByObjid(UpdateSiteByObjidSetup, IDbTransaction)

Declaration
public ToolkitResult UpdateSiteByObjid(UpdateSiteByObjidSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdateSiteByObjidSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UpdateSitePart(UpdateSitePartSetup)

Declaration
public ToolkitResult UpdateSitePart(UpdateSitePartSetup setupParam)
Parameters
Type | Name | Description
UpdateSitePartSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdateSitePart(UpdateSitePartSetup, IDbTransaction)

Declaration
public ToolkitResult UpdateSitePart(UpdateSitePartSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdateSitePartSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UpdateSitePart(Int32, Int32)

Declaration
public ToolkitResult UpdateSitePart(int sitePartObjid, int quantity)
Parameters
Type | Name | Description
System.Int32 | sitePartObjid |
System.Int32 | quantity |
Returns
Type | Description
ToolkitResult |

UpdateSitePart(Int32, String)

Declaration
public ToolkitResult UpdateSitePart(int sitePartObjid, string serialNumber)
Parameters
Type | Name | Description
System.Int32 | sitePartObjid |
System.String | serialNumber |
Returns
Type | Description
ToolkitResult |

UpdateWipBin(UpdateWipBinSetup)

Declaration
public ToolkitResult UpdateWipBin(UpdateWipBinSetup setupParam)
Parameters
Type | Name | Description
UpdateWipBinSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdateWipBin(UpdateWipBinSetup, IDbTransaction)

Declaration
public ToolkitResult UpdateWipBin(UpdateWipBinSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdateWipBinSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

YankSolution(YankSolutionSetup)

Declaration
public ToolkitResult YankSolution(YankSolutionSetup setupParam)
Parameters
Type | Name | Description
YankSolutionSetup | setupParam |
Returns
Type | Description
ToolkitResult |

YankSolution(YankSolutionSetup, IDbTransaction)

Declaration
public ToolkitResult YankSolution(YankSolutionSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
YankSolutionSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

YankSolution(String)

Declaration
public ToolkitResult YankSolution(string solutionIDNum)
Parameters
Type | Name | Description
System.String | solutionIDNum |
Returns
Type | Description
ToolkitResult |


Class InterfacesToolkitBase | fcSDK Documentation

Class InterfacesToolkitBase

Inheritance
System.Object
ToolkitBase
InterfacesToolkitBase
InterfacesToolkit
Inherited Members
ToolkitBase.NOW_DATE
ToolkitBase.CompatSession
ToolkitBase.WithTransaction<T>(Func<IDbTransaction, T>)
ToolkitBase.FCApplication
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public abstract class InterfacesToolkitBase : ToolkitBase

Constructors

InterfacesToolkitBase(ClarifySession)

Declaration
public InterfacesToolkitBase(ClarifySession sess)
Parameters
Type | Name | Description
ClarifySession | sess |

InterfacesToolkitBase(IFCApplication, IFCSession)

Declaration
public InterfacesToolkitBase(IFCApplication app, IFCSession sess)
Parameters
Type | Name | Description
IFCApplication | app |
IFCSession | sess |

Fields

_toolkit

Declaration
protected FCINTER _toolkit
Field Value
Type | Description
FCINTER |

Properties

AllowDuplicateContact

Declaration
public bool AllowDuplicateContact { get; set; }
Property Value
Type | Description
System.Boolean |

ImpersonatorUsername

Declaration
public string ImpersonatorUsername { get; set; }
Property Value
Type | Description
System.String |

UseDatabaseLogins

Declaration
public bool UseDatabaseLogins { get; set; }
Property Value
Type | Description
System.Boolean |


Class LinkCaseToWorkaroundSetup | fcSDK Documentation

Class LinkCaseToWorkaroundSetup

Inheritance
System.Object
LinkCaseToWorkaroundSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LinkCaseToWorkaroundSetup

Constructors

LinkCaseToWorkaroundSetup(String, Int32)

Declaration
[ConstructorIndex(0)]
public LinkCaseToWorkaroundSetup(string caseIDNum, int workaroundObjid)
Parameters
Type | Name | Description
System.String | caseIDNum |
System.Int32 | workaroundObjid |

Properties

CaseIDNum

Declaration
[PropertyBitValue(1)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(16)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

LinkDate

Declaration
[PropertyBitValue(4)]
public DateTime LinkDate { get; set; }
Property Value
Type | Description
System.DateTime |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WorkaroundObjid

Declaration
[PropertyBitValue(2)]
public int WorkaroundObjid { get; set; }
Property Value
Type | Description
System.Int32 |


Class LinkCRToSolutionSetup | fcSDK Documentation

Class LinkCRToSolutionSetup

Inheritance
System.Object
LinkCRToSolutionSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LinkCRToSolutionSetup

Constructors

LinkCRToSolutionSetup(String, String)

Declaration
[ConstructorIndex(0)]
public LinkCRToSolutionSetup(string crIDNum, string solutionIDNum)
Parameters
Type | Name | Description
System.String | crIDNum |
System.String | solutionIDNum |

Properties

CRIDNum

Declaration
[PropertyBitValue(1)]
public string CRIDNum { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(16)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

LinkDate

Declaration
[PropertyBitValue(4)]
public DateTime LinkDate { get; set; }
Property Value
Type | Description
System.DateTime |

SolutionIDNum

Declaration
[PropertyBitValue(2)]
public string SolutionIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class MoveSitePartToBinSetup | fcSDK Documentation

Class MoveSitePartToBinSetup

Inheritance
System.Object
MoveSitePartToBinSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class MoveSitePartToBinSetup

Constructors

MoveSitePartToBinSetup(Int32, Int32)

Declaration
[ConstructorIndex(0)]
public MoveSitePartToBinSetup(int sitePartObjid, int parentBinObjid)
Parameters
Type | Name | Description
System.Int32 | sitePartObjid |
System.Int32 | parentBinObjid |

Properties

AddActivityLog

Declaration
[PropertyBitValue(32)]
public bool AddActivityLog { get; set; }
Property Value
Type | Description
System.Boolean |

InstallAndMove

Declaration
[PropertyBitValue(128)]
public bool InstallAndMove { get; set; }
Property Value
Type | Description
System.Boolean |

MoveDate

Declaration
[PropertyBitValue(2)]
public DateTime MoveDate { get; set; }
Property Value
Type | Description
System.DateTime |

ParentBinObjid

Declaration
[PropertyBitValue(16)]
public int ParentBinObjid { get; set; }
Property Value
Type | Description
System.Int32 |

SitePartObjid

Declaration
[PropertyBitValue(1)]
public int SitePartObjid { get; set; }
Property Value
Type | Description
System.Int32 |

UserName

Declaration
[PropertyBitValue(64)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class MoveSitePartToPartSetup | fcSDK Documentation

Class MoveSitePartToPartSetup

Inheritance
System.Object
MoveSitePartToPartSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class MoveSitePartToPartSetup

Constructors

MoveSitePartToPartSetup(Int32, Int32)

Declaration
[ConstructorIndex(0)]
public MoveSitePartToPartSetup(int sitePartObjid, int parentSitePartObjid)
Parameters
Type | Name | Description
System.Int32 | sitePartObjid |
System.Int32 | parentSitePartObjid |

Properties

AddActivityLog

Declaration
[PropertyBitValue(32)]
public bool AddActivityLog { get; set; }
Property Value
Type | Description
System.Boolean |

InstallAndMove

Declaration
[PropertyBitValue(128)]
public bool InstallAndMove { get; set; }
Property Value
Type | Description
System.Boolean |

MoveDate

Declaration
[PropertyBitValue(2)]
public DateTime MoveDate { get; set; }
Property Value
Type | Description
System.DateTime |

ParentSitePartObjid

Declaration
[PropertyBitValue(4)]
public int ParentSitePartObjid { get; set; }
Property Value
Type | Description
System.Int32 |

SitePartObjid

Declaration
[PropertyBitValue(1)]
public int SitePartObjid { get; set; }
Property Value
Type | Description
System.Int32 |

UserName

Declaration
[PropertyBitValue(64)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class MoveSitePartToSiteSetup | fcSDK Documentation

Class MoveSitePartToSiteSetup

Inheritance
System.Object
MoveSitePartToSiteSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class MoveSitePartToSiteSetup

Constructors

MoveSitePartToSiteSetup(Int32, String)

Declaration
[ConstructorIndex(0)]
public MoveSitePartToSiteSetup(int sitePartObjid, string parentSiteIDNum)
Parameters
Type | Name | Description
System.Int32 | sitePartObjid |
System.String | parentSiteIDNum |

Properties

AddActivityLog

Declaration
[PropertyBitValue(32)]
public bool AddActivityLog { get; set; }
Property Value
Type | Description
System.Boolean |

InstallAndMove

Declaration
[PropertyBitValue(128)]
public bool InstallAndMove { get; set; }
Property Value
Type | Description
System.Boolean |

MoveDate

Declaration
[PropertyBitValue(2)]
public DateTime MoveDate { get; set; }
Property Value
Type | Description
System.DateTime |

ParentSiteIDNum

Declaration
[PropertyBitValue(8)]
public string ParentSiteIDNum { get; set; }
Property Value
Type | Description
System.String |

SitePartObjid

Declaration
[PropertyBitValue(1)]
public int SitePartObjid { get; set; }
Property Value
Type | Description
System.Int32 |

UserName

Declaration
[PropertyBitValue(64)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class MoveSolutionSetup | fcSDK Documentation

Class MoveSolutionSetup

Inheritance
System.Object
MoveSolutionSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class MoveSolutionSetup

Constructors

MoveSolutionSetup(String, String)

Declaration
[ConstructorIndex(0)]
public MoveSolutionSetup(string solutionIDNum, string newWipBin)
Parameters
Type | Name | Description
System.String | solutionIDNum |
System.String | newWipBin |

Properties

NewWipBin

Declaration
[PropertyBitValue(2)]
public string NewWipBin { get; set; }
Property Value
Type | Description
System.String |

SolutionIDNum

Declaration
[PropertyBitValue(1)]
public string SolutionIDNum { get; set; }
Property Value
Type | Description
System.String |


Class ReinstallSitePartToBinSetup | fcSDK Documentation

Class ReinstallSitePartToBinSetup

Inheritance
System.Object
ReinstallSitePartToBinSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ReinstallSitePartToBinSetup

Constructors

ReinstallSitePartToBinSetup(Int32, String, Int32)

Declaration
[ConstructorIndex(0)]
public ReinstallSitePartToBinSetup(int sitePartObjid, string siteIDNum, int parentBinObjid)
Parameters
Type | Name | Description
System.Int32 | sitePartObjid |
System.String | siteIDNum |
System.Int32 | parentBinObjid |

Properties

AddActivityLog

Declaration
[PropertyBitValue(64)]
public bool AddActivityLog { get; set; }
Property Value
Type | Description
System.Boolean |

ParentBinObjid

Declaration
[PropertyBitValue(4)]
public int ParentBinObjid { get; set; }
Property Value
Type | Description
System.Int32 |

ReinstallDate

Declaration
[PropertyBitValue(32)]
public DateTime ReinstallDate { get; set; }
Property Value
Type | Description
System.DateTime |

SiteIDNum

Declaration
[PropertyBitValue(2)]
public string SiteIDNum { get; set; }
Property Value
Type | Description
System.String |

SitePartObjid

Declaration
[PropertyBitValue(1)]
public int SitePartObjid { get; set; }
Property Value
Type | Description
System.Int32 |

UseInstall

Declaration
[PropertyBitValue(128)]
public bool UseInstall { get; set; }
Property Value
Type | Description
System.Boolean |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class ReinstallSitePartToPartSetup | fcSDK Documentation

Class ReinstallSitePartToPartSetup

Inheritance
System.Object
ReinstallSitePartToPartSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ReinstallSitePartToPartSetup

Constructors

ReinstallSitePartToPartSetup(Int32, String, Int32)

Declaration
[ConstructorIndex(0)]
public ReinstallSitePartToPartSetup(int sitePartObjid, string siteIDNum, int parentSitePartObjid)
Parameters
Type | Name | Description
System.Int32 | sitePartObjid |
System.String | siteIDNum |
System.Int32 | parentSitePartObjid |

Properties

AddActivityLog

Declaration
[PropertyBitValue(64)]
public bool AddActivityLog { get; set; }
Property Value
Type | Description
System.Boolean |

ParentSitePartObjid

Declaration
[PropertyBitValue(8)]
public int ParentSitePartObjid { get; set; }
Property Value
Type | Description
System.Int32 |

ReinstallDate

Declaration
[PropertyBitValue(32)]
public DateTime ReinstallDate { get; set; }
Property Value
Type | Description
System.DateTime |

SiteIDNum

Declaration
[PropertyBitValue(2)]
public string SiteIDNum { get; set; }
Property Value
Type | Description
System.String |

SitePartObjid

Declaration
[PropertyBitValue(1)]
public int SitePartObjid { get; set; }
Property Value
Type | Description
System.Int32 |

UseInstall

Declaration
[PropertyBitValue(128)]
public bool UseInstall { get; set; }
Property Value
Type | Description
System.Boolean |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class ReinstallSitePartToSiteSetup | fcSDK Documentation

Class ReinstallSitePartToSiteSetup

Inheritance
System.Object
ReinstallSitePartToSiteSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ReinstallSitePartToSiteSetup

Constructors

ReinstallSitePartToSiteSetup(Int32, String)

Declaration
[ConstructorIndex(0)]
public ReinstallSitePartToSiteSetup(int sitePartObjid, string siteIDNum)
Parameters
Type | Name | Description
System.Int32 | sitePartObjid |
System.String | siteIDNum |

Properties

AddActivityLog

Declaration
[PropertyBitValue(64)]
public bool AddActivityLog { get; set; }
Property Value
Type | Description
System.Boolean |

ReinstallDate

Declaration
[PropertyBitValue(32)]
public DateTime ReinstallDate { get; set; }
Property Value
Type | Description
System.DateTime |

SiteIDNum

Declaration
[PropertyBitValue(2)]
public string SiteIDNum { get; set; }
Property Value
Type | Description
System.String |

SitePartObjid

Declaration
[PropertyBitValue(1)]
public int SitePartObjid { get; set; }
Property Value
Type | Description
System.Int32 |

UseInstall

Declaration
[PropertyBitValue(128)]
public bool UseInstall { get; set; }
Property Value
Type | Description
System.Boolean |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class RejectSolutionSetup | fcSDK Documentation

Class RejectSolutionSetup

Inheritance
System.Object
RejectSolutionSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class RejectSolutionSetup

Constructors

RejectSolutionSetup(String)

Declaration
[ConstructorIndex(0)]
public RejectSolutionSetup(string solutionIDNum)
Parameters
Type | Name | Description
System.String | solutionIDNum |

Properties

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

Notes

Declaration
[PropertyBitValue(8)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

RejectDate

Declaration
[PropertyBitValue(2)]
public DateTime RejectDate { get; set; }
Property Value
Type | Description
System.DateTime |

SolutionIDNum

Declaration
[PropertyBitValue(1)]
public string SolutionIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(4)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |


Class RemoveContactFromContractSetup | fcSDK Documentation

Class RemoveContactFromContractSetup

Inheritance
System.Object
RemoveContactFromContractSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class RemoveContactFromContractSetup

Constructors

RemoveContactFromContractSetup(String, Int32)

Declaration
[ConstructorIndex(0)]
public RemoveContactFromContractSetup(string contractIDNum, int contactObjid)
Parameters
Type | Name | Description
System.String | contractIDNum |
System.Int32 | contactObjid |

Properties

ContactObjid

Declaration
[PropertyBitValue(2)]
public int ContactObjid { get; set; }
Property Value
Type | Description
System.Int32 |

ContractIDNum

Declaration
[PropertyBitValue(1)]
public string ContractIDNum { get; set; }
Property Value
Type | Description
System.String |


Class RemoveEmployeeFromAccountSetup | fcSDK Documentation

Class RemoveEmployeeFromAccountSetup

Inheritance
System.Object
RemoveEmployeeFromAccountSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class RemoveEmployeeFromAccountSetup

Constructors

RemoveEmployeeFromAccountSetup(String, String, String)

Declaration
[ConstructorIndex(0)]
public RemoveEmployeeFromAccountSetup(string userName, string accountIDNum, string roleName)
Parameters
Type | Name | Description
System.String | userName |
System.String | accountIDNum |
System.String | roleName |

Properties

AccountIDNum

Declaration
[PropertyBitValue(2)]
public string AccountIDNum { get; set; }
Property Value
Type | Description
System.String |

RoleName

Declaration
[PropertyBitValue(4)]
public string RoleName { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(1)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class RemoveSiteFromAccountSetup | fcSDK Documentation

Class RemoveSiteFromAccountSetup

Inheritance
System.Object
RemoveSiteFromAccountSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class RemoveSiteFromAccountSetup

Constructors

RemoveSiteFromAccountSetup(String, String, String)

Declaration
[ConstructorIndex(0)]
public RemoveSiteFromAccountSetup(string siteIDNum, string accountIDNum, string roleName)
Parameters
Type | Name | Description
System.String | siteIDNum |
System.String | accountIDNum |
System.String | roleName |

Properties

AccountIDNum

Declaration
[PropertyBitValue(2)]
public string AccountIDNum { get; set; }
Property Value
Type | Description
System.String |

RoleName

Declaration
[PropertyBitValue(4)]
public string RoleName { get; set; }
Property Value
Type | Description
System.String |

SiteIDNum

Declaration
[PropertyBitValue(1)]
public string SiteIDNum { get; set; }
Property Value
Type | Description
System.String |


Class RemoveSiteFromContractSetup | fcSDK Documentation

Class RemoveSiteFromContractSetup

Inheritance
System.Object
RemoveSiteFromContractSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class RemoveSiteFromContractSetup

Constructors

RemoveSiteFromContractSetup(String, String)

Declaration
[ConstructorIndex(0)]
public RemoveSiteFromContractSetup(string contractIDNum, string siteIDNum)
Parameters
Type | Name | Description
System.String | contractIDNum |
System.String | siteIDNum |

Properties

ContractIDNum

Declaration
[PropertyBitValue(1)]
public string ContractIDNum { get; set; }
Property Value
Type | Description
System.String |

SiteIDNum

Declaration
[PropertyBitValue(2)]
public string SiteIDNum { get; set; }
Property Value
Type | Description
System.String |


Class RemoveSitePartFromContractSetup | fcSDK Documentation

Class RemoveSitePartFromContractSetup

Inheritance
System.Object
RemoveSitePartFromContractSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class RemoveSitePartFromContractSetup

Constructors

RemoveSitePartFromContractSetup(String, Int32)

Declaration
[ConstructorIndex(0)]
public RemoveSitePartFromContractSetup(string contractIDNum, int sitePartObjid)
Parameters
Type | Name | Description
System.String | contractIDNum |
System.Int32 | sitePartObjid |

Properties

ContractIDNum

Declaration
[PropertyBitValue(1)]
public string ContractIDNum { get; set; }
Property Value
Type | Description
System.String |

SitePartObjid

Declaration
[PropertyBitValue(2)]
public int SitePartObjid { get; set; }
Property Value
Type | Description
System.Int32 |


Class ReopenDialogueSetup | fcSDK Documentation

Class ReopenDialogueSetup

Inheritance
System.Object
ReopenDialogueSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ReopenDialogueSetup

Constructors

ReopenDialogueSetup(String)

Declaration
public ReopenDialogueSetup(string idNumber)
Parameters
Type | Name | Description
System.String | idNumber |

Properties

AdditionalFields

Declaration
public SimplifiedAdditionalFields AdditionalFields { get; }
Property Value
Type | Description
SimplifiedAdditionalFields |

GenerateTimeBombs

Declaration
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

IDNumber

Declaration
public string IDNumber { get; set; }
Property Value
Type | Description
System.String |

Reopened

Declaration
public DateTime Reopened { get; set; }
Property Value
Type | Description
System.DateTime |

Status

Declaration
public string Status { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class UnlinkCaseFromWorkaroundSetup | fcSDK Documentation

Class UnlinkCaseFromWorkaroundSetup

Inheritance
System.Object
UnlinkCaseFromWorkaroundSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UnlinkCaseFromWorkaroundSetup

Constructors

UnlinkCaseFromWorkaroundSetup(String)

Declaration
[ConstructorIndex(0)]
public UnlinkCaseFromWorkaroundSetup(string caseIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |

Properties

CaseIDNum

Declaration
[PropertyBitValue(1)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(8)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

UnlinkDate

Declaration
[PropertyBitValue(2)]
public DateTime UnlinkDate { get; set; }
Property Value
Type | Description
System.DateTime |

UserName

Declaration
[PropertyBitValue(4)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class UnlinkCRFromSolutionSetup | fcSDK Documentation

Class UnlinkCRFromSolutionSetup

Inheritance
System.Object
UnlinkCRFromSolutionSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UnlinkCRFromSolutionSetup

Constructors

UnlinkCRFromSolutionSetup(String, String)

Declaration
[ConstructorIndex(0)]
public UnlinkCRFromSolutionSetup(string crIDNum, string solutionIDNum)
Parameters
Type | Name | Description
System.String | crIDNum |
System.String | solutionIDNum |

Properties

CRIDNum

Declaration
[PropertyBitValue(1)]
public string CRIDNum { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(16)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

SolutionIDNum

Declaration
[PropertyBitValue(2)]
public string SolutionIDNum { get; set; }
Property Value
Type | Description
System.String |

UnlinkDate

Declaration
[PropertyBitValue(4)]
public DateTime UnlinkDate { get; set; }
Property Value
Type | Description
System.DateTime |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class UpdateAccountSetup | fcSDK Documentation

Class UpdateAccountSetup

Inheritance
System.Object
UpdateAccountSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdateAccountSetup

Constructors

UpdateAccountSetup(String)

Declaration
[ConstructorIndex(0)]
public UpdateAccountSetup(string accountIDNum)
Parameters
Type | Name | Description
System.String | accountIDNum |

Properties

AccountIDNum

Declaration
[PropertyBitValue(32768)]
public string AccountIDNum { get; set; }
Property Value
Type | Description
System.String |

AccountName

Declaration
[PropertyBitValue(1)]
public string AccountName { get; set; }
Property Value
Type | Description
System.String |

AccountType

Declaration
[PropertyBitValue(32)]
public string AccountType { get; set; }
Property Value
Type | Description
System.String |

AdditionalFields

Declaration
[PropertyBitValue(65536)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

CreateDate

Declaration
[PropertyBitValue(8192)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

Description

Declaration
[PropertyBitValue(2)]
public string Description { get; set; }
Property Value
Type | Description
System.String |

Fax

Declaration
[PropertyBitValue(1024)]
public string Fax { get; set; }
Property Value
Type | Description
System.String |

FiscalYear

Declaration
[PropertyBitValue(16)]
public string FiscalYear { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(16384)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

Ownership

Declaration
[PropertyBitValue(256)]
public string Ownership { get; set; }
Property Value
Type | Description
System.String |

Phone

Declaration
[PropertyBitValue(512)]
public string Phone { get; set; }
Property Value
Type | Description
System.String |

Revenue

Declaration
[PropertyBitValue(128)]
public string Revenue { get; set; }
Property Value
Type | Description
System.String |

Size

Declaration
[PropertyBitValue(64)]
public string Size { get; set; }
Property Value
Type | Description
System.String |

Stock

Declaration
[PropertyBitValue(8)]
public string Stock { get; set; }
Property Value
Type | Description
System.String |

Territory

Declaration
[PropertyBitValue(4)]
public string Territory { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(4096)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WebSite

Declaration
[PropertyBitValue(2048)]
public string WebSite { get; set; }
Property Value
Type | Description
System.String |


Class UpdateAddressSetup | fcSDK Documentation

Class UpdateAddressSetup

Inheritance
System.Object
UpdateAddressSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdateAddressSetup

Constructors

UpdateAddressSetup(Int32)

Declaration
[ConstructorIndex(0)]
public UpdateAddressSetup(int addressObjid)
Parameters
Type | Name | Description
System.Int32 | addressObjid |

Properties

AdditionalFields

Declaration
[PropertyBitValue(512)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

Address1

Declaration
[PropertyBitValue(2)]
public string Address1 { get; set; }
Property Value
Type | Description
System.String |

Address2

Declaration
[PropertyBitValue(4)]
public string Address2 { get; set; }
Property Value
Type | Description
System.String |

AddressObjid

Declaration
[PropertyBitValue(1)]
public int AddressObjid { get; set; }
Property Value
Type | Description
System.Int32 |

City

Declaration
[PropertyBitValue(8)]
public string City { get; set; }
Property Value
Type | Description
System.String |

Country

Declaration
[PropertyBitValue(128)]
public string Country { get; set; }
Property Value
Type | Description
System.String |

IsShortState

Declaration
[PropertyBitValue(32)]
public bool IsShortState { get; set; }
Property Value
Type | Description
System.Boolean |

State

Declaration
[PropertyBitValue(16)]
public string State { get; set; }
Property Value
Type | Description
System.String |

TimeZone

Declaration
[PropertyBitValue(256)]
public string TimeZone { get; set; }
Property Value
Type | Description
System.String |

ZipCode

Declaration
[PropertyBitValue(64)]
public string ZipCode { get; set; }
Property Value
Type | Description
System.String |


Class UpdateCommunicationSetup | fcSDK Documentation

Class UpdateCommunicationSetup

Inheritance
System.Object
UpdateCommunicationSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdateCommunicationSetup

Constructors

UpdateCommunicationSetup(Int32)

Declaration
public UpdateCommunicationSetup(int communicationObjid)
Parameters
Type | Name | Description
System.Int32 | communicationObjid |

Properties

AdditionalFields

Declaration
public SimplifiedAdditionalFields AdditionalFields { get; }
Property Value
Type | Description
SimplifiedAdditionalFields |

AutoExec

Declaration
public CommunicationAutoExec? AutoExec { get; set; }
Property Value
Type | Description
System.Nullable<CommunicationAutoExec> |

BCCRecipients

Declaration
public string[] BCCRecipients { get; set; }
Property Value
Type | Description
System.String[] |

CCRecipients

Declaration
public string[] CCRecipients { get; set; }
Property Value
Type | Description
System.String[] |

ChannelObjid

Declaration
public int? ChannelObjid { get; set; }
Property Value
Type | Description
System.Nullable<System.Int32> |

CommunicationObjid

Declaration
public int CommunicationObjid { get; set; }
Property Value
Type | Description
System.Int32 |

DeliveryStatus

Declaration
public CommunicationDeliveryStatus? DeliveryStatus { get; set; }
Property Value
Type | Description
System.Nullable<CommunicationDeliveryStatus> |

Direction

Declaration
public CommunicationDirection? Direction { get; set; }
Property Value
Type | Description
System.Nullable<CommunicationDirection> |

GenerateTimeBombs

Declaration
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

Message

Declaration
public string Message { get; set; }
Property Value
Type | Description
System.String |

MessageId

Declaration
public string MessageId { get; set; }
Property Value
Type | Description
System.String |

MessageSent

Declaration
public DateTime MessageSent { get; set; }
Property Value
Type | Description
System.DateTime |

Priority

Declaration
public CommunicationPriority? Priority { get; set; }
Property Value
Type | Description
System.Nullable<CommunicationPriority> |

Recipients

Declaration
public string[] Recipients { get; set; }
Property Value
Type | Description
System.String[] |

ReplyTo

Declaration
public string ReplyTo { get; set; }
Property Value
Type | Description
System.String |

Sender

Declaration
public string Sender { get; set; }
Property Value
Type | Description
System.String |

Title

Declaration
public string Title { get; set; }
Property Value
Type | Description
System.String |

Updated

Declaration
public DateTime Updated { get; set; }
Property Value
Type | Description
System.DateTime |

UserName

Declaration
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class UpdateContactByObjidSetup | fcSDK Documentation

Class UpdateContactByObjidSetup

Inheritance
System.Object
UpdateContactByObjidSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdateContactByObjidSetup

Constructors

UpdateContactByObjidSetup(Int32)

Declaration
[ConstructorIndex(0)]
public UpdateContactByObjidSetup(int contactObjid)
Parameters
Type | Name | Description
System.Int32 | contactObjid |

Properties

AdditionalFields

Declaration
[PropertyBitValue(131072)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

ContactObjid

Declaration
[PropertyBitValue(1)]
public int ContactObjid { get; set; }
Property Value
Type | Description
System.Int32 |

Email

Declaration
[PropertyBitValue(128)]
public string Email { get; set; }
Property Value
Type | Description
System.String |

Fax

Declaration
[PropertyBitValue(64)]
public string Fax { get; set; }
Property Value
Type | Description
System.String |

FirstName

Declaration
[PropertyBitValue(2)]
public string FirstName { get; set; }
Property Value
Type | Description
System.String |

Hours

Declaration
[PropertyBitValue(1024)]
public string Hours { get; set; }
Property Value
Type | Description
System.String |

LastName

Declaration
[PropertyBitValue(4)]
public string LastName { get; set; }
Property Value
Type | Description
System.String |

MailStop

Declaration
[PropertyBitValue(256)]
public string MailStop { get; set; }
Property Value
Type | Description
System.String |

NewFirstName

Declaration
[PropertyBitValue(4096)]
public string NewFirstName { get; set; }
Property Value
Type | Description
System.String |

NewLastName

Declaration
[PropertyBitValue(8192)]
public string NewLastName { get; set; }
Property Value
Type | Description
System.String |

NewPhone

Declaration
[PropertyBitValue(16384)]
public string NewPhone { get; set; }
Property Value
Type | Description
System.String |

NewPrimaryRole

Declaration
[PropertyBitValue(65536)]
public string NewPrimaryRole { get; set; }
Property Value
Type | Description
System.String |

NewPrimarySiteIDNum

Declaration
[PropertyBitValue(32768)]
public string NewPrimarySiteIDNum { get; set; }
Property Value
Type | Description
System.String |

Phone

Declaration
[PropertyBitValue(8)]
public string Phone { get; set; }
Property Value
Type | Description
System.String |

RoleName

Declaration
[PropertyBitValue(32)]
public string RoleName { get; set; }
Property Value
Type | Description
System.String |

Salutation

Declaration
[PropertyBitValue(2048)]
public string Salutation { get; set; }
Property Value
Type | Description
System.String |

SiteIDNum

Declaration
[PropertyBitValue(16)]
public string SiteIDNum { get; set; }
Property Value
Type | Description
System.String |

Title

Declaration
[PropertyBitValue(512)]
public string Title { get; set; }
Property Value
Type | Description
System.String |


Class UpdateContactSetup | fcSDK Documentation

Class UpdateContactSetup

Inheritance
System.Object
UpdateContactSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdateContactSetup

Constructors

UpdateContactSetup(String, String, String, String, String)

Declaration
[ConstructorIndex(0)]
public UpdateContactSetup(string firstName, string lastName, string phone, string siteIDNum, string roleName)
Parameters
Type | Name | Description
System.String | firstName |
System.String | lastName |
System.String | phone |
System.String | siteIDNum |
System.String | roleName |

Properties

AdditionalFields

Declaration
[PropertyBitValue(131072)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

Email

Declaration
[PropertyBitValue(64)]
public string Email { get; set; }
Property Value
Type | Description
System.String |

Fax

Declaration
[PropertyBitValue(32)]
public string Fax { get; set; }
Property Value
Type | Description
System.String |

FirstName

Declaration
[PropertyBitValue(1)]
public string FirstName { get; set; }
Property Value
Type | Description
System.String |

Hours

Declaration
[PropertyBitValue(512)]
public string Hours { get; set; }
Property Value
Type | Description
System.String |

LastName

Declaration
[PropertyBitValue(2)]
public string LastName { get; set; }
Property Value
Type | Description
System.String |

MailStop

Declaration
[PropertyBitValue(128)]
public string MailStop { get; set; }
Property Value
Type | Description
System.String |

NewFirstName

Declaration
[PropertyBitValue(2048)]
public string NewFirstName { get; set; }
Property Value
Type | Description
System.String |

NewLastName

Declaration
[PropertyBitValue(4096)]
public string NewLastName { get; set; }
Property Value
Type | Description
System.String |

NewPhone

Declaration
[PropertyBitValue(8192)]
public string NewPhone { get; set; }
Property Value
Type | Description
System.String |

NewPrimaryRole

Declaration
[PropertyBitValue(32768)]
public string NewPrimaryRole { get; set; }
Property Value
Type | Description
System.String |

NewPrimarySiteIDNum

Declaration
[PropertyBitValue(16384)]
public string NewPrimarySiteIDNum { get; set; }
Property Value
Type | Description
System.String |

Phone

Declaration
[PropertyBitValue(4)]
public string Phone { get; set; }
Property Value
Type | Description
System.String |

RoleName

Declaration
[PropertyBitValue(16)]
public string RoleName { get; set; }
Property Value
Type | Description
System.String |

Salutation

Declaration
[PropertyBitValue(1024)]
public string Salutation { get; set; }
Property Value
Type | Description
System.String |

SiteIDNum

Declaration
[PropertyBitValue(8)]
public string SiteIDNum { get; set; }
Property Value
Type | Description
System.String |

Title

Declaration
[PropertyBitValue(256)]
public string Title { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(65536)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class UpdateContractSetup | fcSDK Documentation

Class UpdateContractSetup

Inheritance
System.Object
UpdateContractSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdateContractSetup

Constructors

UpdateContractSetup(String)

Declaration
[ConstructorIndex(0)]
public UpdateContractSetup(string contractIDNum)
Parameters
Type | Name | Description
System.String | contractIDNum |

Properties

AdditionalFields

Declaration
[PropertyBitValue(65536)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

BusinessHoursForPM

Declaration
[PropertyBitValue(128)]
public string BusinessHoursForPM { get; set; }
Property Value
Type | Description
System.String |

ContractIDNum

Declaration
[PropertyBitValue(1)]
public string ContractIDNum { get; set; }
Property Value
Type | Description
System.String |

ContractType

Declaration
[PropertyBitValue(2)]
public string ContractType { get; set; }
Property Value
Type | Description
System.String |

ExpireDate

Declaration
[PropertyBitValue(512)]
public DateTime ExpireDate { get; set; }
Property Value
Type | Description
System.DateTime |

Notes

Declaration
[PropertyBitValue(32768)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

OnsiteResponseDuration

Declaration
[PropertyBitValue(64)]
public TimeSpan OnsiteResponseDuration { get; set; }
Property Value
Type | Description
System.TimeSpan |

PayOptions

Declaration
[PropertyBitValue(16)]
public string PayOptions { get; set; }
Property Value
Type | Description
System.String |

PhoneResponseDuration

Declaration
[PropertyBitValue(32)]
public TimeSpan PhoneResponseDuration { get; set; }
Property Value
Type | Description
System.TimeSpan |

PONumber

Declaration
[PropertyBitValue(8)]
public string PONumber { get; set; }
Property Value
Type | Description
System.String |

StartDate

Declaration
[PropertyBitValue(256)]
public DateTime StartDate { get; set; }
Property Value
Type | Description
System.DateTime |

Status

Declaration
[PropertyBitValue(4)]
public string Status { get; set; }
Property Value
Type | Description
System.String |

UnitsAvailable

Declaration
[PropertyBitValue(8192)]
public double UnitsAvailable { get; set; }
Property Value
Type | Description
System.Double |

UnitsPurchased

Declaration
[PropertyBitValue(2048)]
public double UnitsPurchased { get; set; }
Property Value
Type | Description
System.Double |

UnitsUsed

Declaration
[PropertyBitValue(4096)]
public double UnitsUsed { get; set; }
Property Value
Type | Description
System.Double |

UnitType

Declaration
[PropertyBitValue(1024)]
public string UnitType { get; set; }
Property Value
Type | Description
System.String |

UseSpecialConsiderations

Declaration
[PropertyBitValue(16384)]
public bool UseSpecialConsiderations { get; set; }
Property Value
Type | Description
System.Boolean |


Class UpdateDialogueSetup | fcSDK Documentation

Class UpdateDialogueSetup

Inheritance
System.Object
UpdateDialogueSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdateDialogueSetup

Constructors

UpdateDialogueSetup(String)

Declaration
public UpdateDialogueSetup(string idNumber)
Parameters
Type | Name | Description
System.String | idNumber |

Properties

AdditionalFields

Declaration
public SimplifiedAdditionalFields AdditionalFields { get; }
Property Value
Type | Description
SimplifiedAdditionalFields |

GenerateTimeBombs

Declaration
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

IDNumber

Declaration
public string IDNumber { get; set; }
Property Value
Type | Description
System.String |

Priority

Declaration
public string Priority { get; set; }
Property Value
Type | Description
System.String |

Title

Declaration
public string Title { get; set; }
Property Value
Type | Description
System.String |

Updated

Declaration
public DateTime Updated { get; set; }
Property Value
Type | Description
System.DateTime |

UserName

Declaration
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class UpdatePartRevisionSetup | fcSDK Documentation

Class UpdatePartRevisionSetup

Inheritance
System.Object
UpdatePartRevisionSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdatePartRevisionSetup

Constructors

UpdatePartRevisionSetup(String, String, String)

Declaration
[ConstructorIndex(0)]
public UpdatePartRevisionSetup(string partNumber, string partDomain, string partRevision)
Parameters
Type | Name | Description
System.String | partNumber |
System.String | partDomain |
System.String | partRevision |

Properties

NewPartRevision

Declaration
[PropertyBitValue(512)]
public string NewPartRevision { get; set; }
Property Value
Type | Description
System.String |

PartDomain

Declaration
[PropertyBitValue(2)]
public string PartDomain { get; set; }
Property Value
Type | Description
System.String |

PartNumber

Declaration
[PropertyBitValue(1)]
public string PartNumber { get; set; }
Property Value
Type | Description
System.String |

PartRevision

Declaration
[PropertyBitValue(4)]
public string PartRevision { get; set; }
Property Value
Type | Description
System.String |

ReplaceDate

Declaration
[PropertyBitValue(64)]
public DateTime ReplaceDate { get; set; }
Property Value
Type | Description
System.DateTime |

ReplacePartDomain

Declaration
[PropertyBitValue(16)]
public string ReplacePartDomain { get; set; }
Property Value
Type | Description
System.String |

ReplacePartNumber

Declaration
[PropertyBitValue(8)]
public string ReplacePartNumber { get; set; }
Property Value
Type | Description
System.String |

ReplacePartRevision

Declaration
[PropertyBitValue(32)]
public string ReplacePartRevision { get; set; }
Property Value
Type | Description
System.String |

Status

Declaration
[PropertyBitValue(128)]
public PartRevisionStatus Status { get; set; }
Property Value
Type | Description
PartRevisionStatus |


Class UpdatePartSetup | fcSDK Documentation

Class UpdatePartSetup

Inheritance
System.Object
UpdatePartSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdatePartSetup

Constructors

UpdatePartSetup(String, String, Int32)

Declaration
[ConstructorIndex(0)]
public UpdatePartSetup(string partNumber, string partDomain, int warrantyDays)
Parameters
Type | Name | Description
System.String | partNumber |
System.String | partDomain |
System.Int32 | warrantyDays |

Properties

AdditionalFields

Declaration
[PropertyBitValue(32768)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

Description

Declaration
[PropertyBitValue(8)]
public string Description { get; set; }
Property Value
Type | Description
System.String |

Dimension

Declaration
[PropertyBitValue(8192)]
public string Dimension { get; set; }
Property Value
Type | Description
System.String |

Family

Declaration
[PropertyBitValue(256)]
public string Family { get; set; }
Property Value
Type | Description
System.String |

Line

Declaration
[PropertyBitValue(512)]
public string Line { get; set; }
Property Value
Type | Description
System.String |

ModelNumber

Declaration
[PropertyBitValue(16)]
public string ModelNumber { get; set; }
Property Value
Type | Description
System.String |

Notes

Declaration
[PropertyBitValue(4)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

PartClass

Declaration
[PropertyBitValue(16384)]
public string PartClass { get; set; }
Property Value
Type | Description
System.String |

PartDomain

Declaration
[PropertyBitValue(2)]
public string PartDomain { get; set; }
Property Value
Type | Description
System.String |

PartNumber

Declaration
[PropertyBitValue(1)]
public string PartNumber { get; set; }
Property Value
Type | Description
System.String |

PartType

Declaration
[PropertyBitValue(2048)]
public string PartType { get; set; }
Property Value
Type | Description
System.String |

RepairType

Declaration
[PropertyBitValue(1024)]
public PartRepairType RepairType { get; set; }
Property Value
Type | Description
PartRepairType |

UnitMeasure

Declaration
[PropertyBitValue(128)]
public string UnitMeasure { get; set; }
Property Value
Type | Description
System.String |

WarrantyDays

Declaration
[PropertyBitValue(32)]
public int WarrantyDays { get; set; }
Property Value
Type | Description
System.Int32 |

WarrantyStartOnShipment

Declaration
[PropertyBitValue(64)]
public bool WarrantyStartOnShipment { get; set; }
Property Value
Type | Description
System.Boolean |

Weight

Declaration
[PropertyBitValue(4096)]
public string Weight { get; set; }
Property Value
Type | Description
System.String |


Class UpdatePriceInstanceSetup | fcSDK Documentation

Class UpdatePriceInstanceSetup

Inheritance
System.Object
UpdatePriceInstanceSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdatePriceInstanceSetup

Constructors

UpdatePriceInstanceSetup(String, String, String, String, Int32, Decimal, DateTime)

Declaration
[ConstructorIndex(0)]
public UpdatePriceInstanceSetup(string partNumber, string partDomain, string partRevision, string priceProgram, int pricedQuantity, decimal price, DateTime updateDate)
Parameters
Type | Name | Description
System.String | partNumber |
System.String | partDomain |
System.String | partRevision |
System.String | priceProgram |
System.Int32 | pricedQuantity |
System.Decimal | price |
System.DateTime | updateDate |

Properties

PartDomain

Declaration
[PropertyBitValue(2)]
public string PartDomain { get; set; }
Property Value
Type | Description
System.String |

PartNumber

Declaration
[PropertyBitValue(1)]
public string PartNumber { get; set; }
Property Value
Type | Description
System.String |

PartRevision

Declaration
[PropertyBitValue(4)]
public string PartRevision { get; set; }
Property Value
Type | Description
System.String |

Price

Declaration
[PropertyBitValue(32)]
public decimal Price { get; set; }
Property Value
Type | Description
System.Decimal |

PricedQuantity

Declaration
[PropertyBitValue(16)]
public int PricedQuantity { get; set; }
Property Value
Type | Description
System.Int32 |

PriceProgram

Declaration
[PropertyBitValue(8)]
public string PriceProgram { get; set; }
Property Value
Type | Description
System.String |

UpdateDate

Declaration
[PropertyBitValue(64)]
public DateTime UpdateDate { get; set; }
Property Value
Type | Description
System.DateTime |


Class UpdateProductBinSetup | fcSDK Documentation

Class UpdateProductBinSetup

Inheritance
System.Object
UpdateProductBinSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdateProductBinSetup

Constructors

UpdateProductBinSetup(Int32)

Declaration
[ConstructorIndex(0)]
public UpdateProductBinSetup(int binObjid)
Parameters
Type | Name | Description
System.Int32 | binObjid |

Properties

BinName

Declaration
[PropertyBitValue(2)]
public string BinName { get; set; }
Property Value
Type | Description
System.String |

BinObjid

Declaration
[PropertyBitValue(1)]
public int BinObjid { get; set; }
Property Value
Type | Description
System.Int32 |

Description

Declaration
[PropertyBitValue(4)]
public string Description { get; set; }
Property Value
Type | Description
System.String |

PrimarySupportEmployeeObjid

Declaration
[PropertyBitValue(8)]
public int PrimarySupportEmployeeObjid { get; set; }
Property Value
Type | Description
System.Int32 |

SecondarySupportEmployeeObjid

Declaration
[PropertyBitValue(16)]
public int SecondarySupportEmployeeObjid { get; set; }
Property Value
Type | Description
System.Int32 |

UpdateDate

Declaration
[PropertyBitValue(64)]
public DateTime UpdateDate { get; set; }
Property Value
Type | Description
System.DateTime |

UserName

Declaration
[PropertyBitValue(32)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class UpdateQueueSetup | fcSDK Documentation

Class UpdateQueueSetup

Inheritance
System.Object
UpdateQueueSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdateQueueSetup

Constructors

UpdateQueueSetup(String)

Declaration
[ConstructorIndex(0)]
public UpdateQueueSetup(string title)
Parameters
Type | Name | Description
System.String | title |

Properties

AllowActionItem

Declaration
[PropertyBitValue(4096)]
public bool AllowActionItem { get; set; }
Property Value
Type | Description
System.Boolean |

AllowCase

Declaration
[PropertyBitValue(16)]
public bool AllowCase { get; set; }
Property Value
Type | Description
System.Boolean |

AllowContract

Declaration
[PropertyBitValue(32)]
public bool AllowContract { get; set; }
Property Value
Type | Description
System.Boolean |

AllowCR

Declaration
[PropertyBitValue(8)]
public bool AllowCR { get; set; }
Property Value
Type | Description
System.Boolean |

AllowDemandDetail

Declaration
[PropertyBitValue(128)]
public bool AllowDemandDetail { get; set; }
Property Value
Type | Description
System.Boolean |

AllowDialogue

Declaration
[PropertyBitValue(64)]
public bool AllowDialogue { get; set; }
Property Value
Type | Description
System.Boolean |

AllowJob

Declaration
[PropertyBitValue(256)]
public bool AllowJob { get; set; }
Property Value
Type | Description
System.Boolean |

AllowOpportunity

Declaration
[PropertyBitValue(512)]
public bool AllowOpportunity { get; set; }
Property Value
Type | Description
System.Boolean |

AllowSolution

Declaration
[PropertyBitValue(1024)]
public bool AllowSolution { get; set; }
Property Value
Type | Description
System.Boolean |

AllowSubcase

Declaration
[PropertyBitValue(2048)]
public bool AllowSubcase { get; set; }
Property Value
Type | Description
System.Boolean |

Description

Declaration
[PropertyBitValue(4)]
public string Description { get; set; }
Property Value
Type | Description
System.String |

IsPersonal

Declaration
[PropertyBitValue(2)]
public bool IsPersonal { get; set; }
Property Value
Type | Description
System.Boolean |

NewTitle

Declaration
[PropertyBitValue(16384)]
public string NewTitle { get; set; }
Property Value
Type | Description
System.String |

Supervisor

Declaration
[PropertyBitValue(8192)]
public string Supervisor { get; set; }
Property Value
Type | Description
System.String |

Title

Declaration
[PropertyBitValue(1)]
public string Title { get; set; }
Property Value
Type | Description
System.String |


Class UpdateSiteByObjidSetup | fcSDK Documentation

Class UpdateSiteByObjidSetup

Inheritance
System.Object
UpdateSiteByObjidSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdateSiteByObjidSetup

Constructors

UpdateSiteByObjidSetup(Int32)

Declaration
[ConstructorIndex(0)]
public UpdateSiteByObjidSetup(int siteObjid)
Parameters
Type | Name | Description
System.Int32 | siteObjid |

Properties

AccountIDNum

Declaration
[PropertyBitValue(16)]
public string AccountIDNum { get; set; }
Property Value
Type | Description
System.String |

AdditionalFields

Declaration
[PropertyBitValue(131072)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

BillingAddressObjid

Declaration
[PropertyBitValue(4096)]
public int BillingAddressObjid { get; set; }
Property Value
Type | Description
System.Int32 |

District

Declaration
[PropertyBitValue(128)]
public string District { get; set; }
Property Value
Type | Description
System.String |

IndustryType

Declaration
[PropertyBitValue(256)]
public string IndustryType { get; set; }
Property Value
Type | Description
System.String |

ParentSiteIDNum

Declaration
[PropertyBitValue(8192)]
public string ParentSiteIDNum { get; set; }
Property Value
Type | Description
System.String |

PrimaryAddressObjid

Declaration
[PropertyBitValue(1024)]
public int PrimaryAddressObjid { get; set; }
Property Value
Type | Description
System.Int32 |

PrimarySupportEmployeeObjid

Declaration
[PropertyBitValue(32768)]
public int PrimarySupportEmployeeObjid { get; set; }
Property Value
Type | Description
System.Int32 |

PrimaryUse

Declaration
[PropertyBitValue(512)]
public string PrimaryUse { get; set; }
Property Value
Type | Description
System.String |

Region

Declaration
[PropertyBitValue(64)]
public string Region { get; set; }
Property Value
Type | Description
System.String |

SecondarySupportEmployeeObjid

Declaration
[PropertyBitValue(65536)]
public int SecondarySupportEmployeeObjid { get; set; }
Property Value
Type | Description
System.Int32 |

ShippingAddressObjid

Declaration
[PropertyBitValue(2048)]
public int ShippingAddressObjid { get; set; }
Property Value
Type | Description
System.Int32 |

SiteName

Declaration
[PropertyBitValue(4)]
public string SiteName { get; set; }
Property Value
Type | Description
System.String |

SiteObjid

Declaration
[PropertyBitValue(1)]
public int SiteObjid { get; set; }
Property Value
Type | Description
System.Int32 |

SiteType

Declaration
[PropertyBitValue(8)]
public SiteType SiteType { get; set; }
Property Value
Type | Description
SiteType |

Status

Declaration
[PropertyBitValue(32)]
public SiteStatus Status { get; set; }
Property Value
Type | Description
SiteStatus |

SupportOfficeSiteIDNum

Declaration
[PropertyBitValue(16384)]
public string SupportOfficeSiteIDNum { get; set; }
Property Value
Type | Description
System.String |


Class UpdateSitePartSetup | fcSDK Documentation

Class UpdateSitePartSetup

Inheritance
System.Object
UpdateSitePartSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdateSitePartSetup

Constructors

UpdateSitePartSetup(Int32, Int32)

Declaration
[ConstructorIndex(0)]
public UpdateSitePartSetup(int sitePartObjid, int quantity)
Parameters
Type | Name | Description
System.Int32 | sitePartObjid |
System.Int32 | quantity |

UpdateSitePartSetup(Int32, String)

Declaration
[ConstructorIndex(1)]
public UpdateSitePartSetup(int sitePartObjid, string serialNumber)
Parameters
Type | Name | Description
System.Int32 | sitePartObjid |
System.String | serialNumber |

Properties

AddActivityLog

Declaration
[PropertyBitValue(8192)]
public bool AddActivityLog { get; set; }
Property Value
Type | Description
System.Boolean |

AdditionalFields

Declaration
[PropertyBitValue(16384)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

Comments

Declaration
[PropertyBitValue(512)]
public string Comments { get; set; }
Property Value
Type | Description
System.String |

InstallDate

Declaration
[PropertyBitValue(32)]
public DateTime InstallDate { get; set; }
Property Value
Type | Description
System.DateTime |

InstanceName

Declaration
[PropertyBitValue(2)]
public string InstanceName { get; set; }
Property Value
Type | Description
System.String |

InvoiceNumber

Declaration
[PropertyBitValue(8)]
public string InvoiceNumber { get; set; }
Property Value
Type | Description
System.String |

PartRevision

Declaration
[PropertyBitValue(4096)]
public string PartRevision { get; set; }
Property Value
Type | Description
System.String |

PartStatus

Declaration
[PropertyBitValue(256)]
public string PartStatus { get; set; }
Property Value
Type | Description
System.String |

Quantity

Declaration
[PropertyBitValue(128)]
public int Quantity { get; set; }
Property Value
Type | Description
System.Int32 |

SerialNumber

Declaration
[PropertyBitValue(4)]
public string SerialNumber { get; set; }
Property Value
Type | Description
System.String |

ServiceEndDate

Declaration
[PropertyBitValue(1024)]
public DateTime ServiceEndDate { get; set; }
Property Value
Type | Description
System.DateTime |

ShipDate

Declaration
[PropertyBitValue(16)]
public DateTime ShipDate { get; set; }
Property Value
Type | Description
System.DateTime |

SitePartObjid

Declaration
[PropertyBitValue(1)]
public int SitePartObjid { get; set; }
Property Value
Type | Description
System.Int32 |

UserName

Declaration
[PropertyBitValue(2048)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WarrantyDate

Declaration
[PropertyBitValue(64)]
public DateTime WarrantyDate { get; set; }
Property Value
Type | Description
System.DateTime |


Class UpdateSiteSetup | fcSDK Documentation

Class UpdateSiteSetup

Inheritance
System.Object
UpdateSiteSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdateSiteSetup

Constructors

UpdateSiteSetup(String)

Declaration
[ConstructorIndex(0)]
public UpdateSiteSetup(string siteIDNum)
Parameters
Type | Name | Description
System.String | siteIDNum |

Properties

AccountIDNum

Declaration
[PropertyBitValue(16)]
public string AccountIDNum { get; set; }
Property Value
Type | Description
System.String |

AdditionalFields

Declaration
[PropertyBitValue(131072)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

BillingAddressObjid

Declaration
[PropertyBitValue(4096)]
public int BillingAddressObjid { get; set; }
Property Value
Type | Description
System.Int32 |

District

Declaration
[PropertyBitValue(128)]
public string District { get; set; }
Property Value
Type | Description
System.String |

IndustryType

Declaration
[PropertyBitValue(256)]
public string IndustryType { get; set; }
Property Value
Type | Description
System.String |

ParentSiteIDNum

Declaration
[PropertyBitValue(8192)]
public string ParentSiteIDNum { get; set; }
Property Value
Type | Description
System.String |

PrimaryAddressObjid

Declaration
[PropertyBitValue(1024)]
public int PrimaryAddressObjid { get; set; }
Property Value
Type | Description
System.Int32 |

PrimarySupportEmployeeObjid

Declaration
[PropertyBitValue(32768)]
public int PrimarySupportEmployeeObjid { get; set; }
Property Value
Type | Description
System.Int32 |

PrimaryUse

Declaration
[PropertyBitValue(512)]
public string PrimaryUse { get; set; }
Property Value
Type | Description
System.String |

Region

Declaration
[PropertyBitValue(64)]
public string Region { get; set; }
Property Value
Type | Description
System.String |

SecondarySupportEmployeeObjid

Declaration
[PropertyBitValue(65536)]
public int SecondarySupportEmployeeObjid { get; set; }
Property Value
Type | Description
System.Int32 |

ShippingAddressObjid

Declaration
[PropertyBitValue(2048)]
public int ShippingAddressObjid { get; set; }
Property Value
Type | Description
System.Int32 |

SiteIDNum

Declaration
[PropertyBitValue(2)]
public string SiteIDNum { get; set; }
Property Value
Type | Description
System.String |

SiteName

Declaration
[PropertyBitValue(4)]
public string SiteName { get; set; }
Property Value
Type | Description
System.String |

SiteType

Declaration
[PropertyBitValue(8)]
public SiteType SiteType { get; set; }
Property Value
Type | Description
SiteType |

Status

Declaration
[PropertyBitValue(32)]
public SiteStatus Status { get; set; }
Property Value
Type | Description
SiteStatus |

SupportOfficeSiteIDNum

Declaration
[PropertyBitValue(16384)]
public string SupportOfficeSiteIDNum { get; set; }
Property Value
Type | Description
System.String |


Class UpdateWipBinSetup | fcSDK Documentation

Class UpdateWipBinSetup

Inheritance
System.Object
UpdateWipBinSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdateWipBinSetup

Constructors

UpdateWipBinSetup(String)

Declaration
[ConstructorIndex(0)]
public UpdateWipBinSetup(string title)
Parameters
Type | Name | Description
System.String | title |

Properties

Description

Declaration
[PropertyBitValue(4)]
public string Description { get; set; }
Property Value
Type | Description
System.String |

IsDefaultBin

Declaration
[PropertyBitValue(16)]
public bool IsDefaultBin { get; set; }
Property Value
Type | Description
System.Boolean |

NewTitle

Declaration
[PropertyBitValue(2)]
public string NewTitle { get; set; }
Property Value
Type | Description
System.String |

Title

Declaration
[PropertyBitValue(1)]
public string Title { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class YankSolutionSetup | fcSDK Documentation

Class YankSolutionSetup

Inheritance
System.Object
YankSolutionSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Interfaces
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class YankSolutionSetup

Constructors

YankSolutionSetup(String)

Declaration
[ConstructorIndex(0)]
public YankSolutionSetup(string solutionIDNum)
Parameters
Type | Name | Description
System.String | solutionIDNum |

Properties

GenerateTimeBombs

Declaration
[PropertyBitValue(16)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

SolutionIDNum

Declaration
[PropertyBitValue(1)]
public string SolutionIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(2)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |

YankDate

Declaration
[PropertyBitValue(4)]
public DateTime YankDate { get; set; }
Property Value
Type | Description
System.DateTime |


Enum LeadSiteType | fcSDK Documentation

Enum LeadSiteType

Namespace: FChoice.Toolkits.Clarify
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public enum LeadSiteType

Fields

Name | Description
Business |
Individual |


Class Location | fcSDK Documentation

Class Location

Inheritance
System.Object
Location
Inherited Members
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class Location

Constructors

Location()

Declaration
public Location()

Location(String)

Declaration
public Location(string locationName)
Parameters
Type | Name | Description
System.String | locationName |

Location(String, Boolean)

Declaration
public Location(string locationName, bool isPrimaryBinSuggestion)
Parameters
Type | Name | Description
System.String | locationName |
System.Boolean | isPrimaryBinSuggestion |

Location(String, String)

Declaration
public Location(string locationName, string binName)
Parameters
Type | Name | Description
System.String | locationName |
System.String | binName |

Location(String, String, String)

Declaration
public Location(string locationName, string containerName, string containerIDNum)
Parameters
Type | Name | Description
System.String | locationName |
System.String | containerName |
System.String | containerIDNum |

Fields

EMPTY

Declaration
public static readonly Location EMPTY
Field Value
Type | Description
Location |

PRIMARY_BIN_SUGGESTION_NAME

Declaration
public const string PRIMARY_BIN_SUGGESTION_NAME = "PRIM_BIN_REC"
Field Value
Type | Description
System.String |

Properties

BinName

Declaration
public string BinName { get; set; }
Property Value
Type | Description
System.String |

ContainerIDNum

Declaration
public string ContainerIDNum { get; set; }
Property Value
Type | Description
System.String |

IsPrimaryBinSuggestion

Declaration
public bool IsPrimaryBinSuggestion { get; set; }
Property Value
Type | Description
System.Boolean |

LocationName

Declaration
public string LocationName { get; set; }
Property Value
Type | Description
System.String |

Methods

ToString()

Declaration
public override string ToString()
Returns
Type | Description
System.String |
Overrides
System.Object.ToString()


Class LocationCollection | fcSDK Documentation

Class LocationCollection

Inheritance
System.Object
System.Collections.ObjectModel.Collection<Location>
LocationCollection
Implements
System.Collections.Generic.IList<Location>
System.Collections.Generic.ICollection<Location>
System.Collections.IList
System.Collections.ICollection
System.Collections.Generic.IReadOnlyList<Location>
System.Collections.Generic.IReadOnlyCollection<Location>
System.Collections.Generic.IEnumerable<Location>
System.Collections.IEnumerable
Inherited Members
System.Collections.ObjectModel.Collection<FChoice.Toolkits.Clarify.Location>.Clear()
System.Collections.ObjectModel.Collection<FChoice.Toolkits.Clarify.Location>.CopyTo(FChoice.Toolkits.Clarify.Location[], System.Int32)
System.Collections.ObjectModel.Collection<FChoice.Toolkits.Clarify.Location>.Contains(FChoice.Toolkits.Clarify.Location)
System.Collections.ObjectModel.Collection<FChoice.Toolkits.Clarify.Location>.GetEnumerator()
System.Collections.ObjectModel.Collection<FChoice.Toolkits.Clarify.Location>.IndexOf(FChoice.Toolkits.Clarify.Location)
System.Collections.ObjectModel.Collection<FChoice.Toolkits.Clarify.Location>.Insert(System.Int32, FChoice.Toolkits.Clarify.Location)
System.Collections.ObjectModel.Collection<FChoice.Toolkits.Clarify.Location>.Remove(FChoice.Toolkits.Clarify.Location)
System.Collections.ObjectModel.Collection<FChoice.Toolkits.Clarify.Location>.RemoveAt(System.Int32)
System.Collections.ObjectModel.Collection<FChoice.Toolkits.Clarify.Location>.InsertItem(System.Int32, FChoice.Toolkits.Clarify.Location)
System.Collections.ObjectModel.Collection<FChoice.Toolkits.Clarify.Location>.RemoveItem(System.Int32)
System.Collections.ObjectModel.Collection<FChoice.Toolkits.Clarify.Location>.SetItem(System.Int32, FChoice.Toolkits.Clarify.Location)
System.Collections.ObjectModel.Collection<FChoice.Toolkits.Clarify.Location>.System.Collections.IEnumerable.GetEnumerator()
System.Collections.ObjectModel.Collection<FChoice.Toolkits.Clarify.Location>.System.Collections.ICollection.CopyTo(System.Array, System.Int32)
System.Collections.ObjectModel.Collection<FChoice.Toolkits.Clarify.Location>.System.Collections.IList.get_Item(System.Int32)
System.Collections.ObjectModel.Collection<FChoice.Toolkits.Clarify.Location>.System.Collections.IList.set_Item(System.Int32, System.Object)
System.Collections.ObjectModel.Collection<FChoice.Toolkits.Clarify.Location>.System.Collections.IList.Add(System.Object)
System.Collections.ObjectModel.Collection<FChoice.Toolkits.Clarify.Location>.System.Collections.IList.Contains(System.Object)
System.Collections.ObjectModel.Collection<FChoice.Toolkits.Clarify.Location>.System.Collections.IList.IndexOf(System.Object)
System.Collections.ObjectModel.Collection<FChoice.Toolkits.Clarify.Location>.System.Collections.IList.Insert(System.Int32, System.Object)
System.Collections.ObjectModel.Collection<FChoice.Toolkits.Clarify.Location>.System.Collections.IList.Remove(System.Object)
System.Collections.ObjectModel.Collection<FChoice.Toolkits.Clarify.Location>.Count
System.Collections.ObjectModel.Collection<FChoice.Toolkits.Clarify.Location>.Items
System.Collections.ObjectModel.Collection<FChoice.Toolkits.Clarify.Location>.Item[System.Int32]
System.Collections.ObjectModel.Collection<FChoice.Toolkits.Clarify.Location>.System.Collections.Generic.ICollection<FChoice.Toolkits.Clarify.Location>.IsReadOnly
System.Collections.ObjectModel.Collection<FChoice.Toolkits.Clarify.Location>.System.Collections.ICollection.IsSynchronized
System.Collections.ObjectModel.Collection<FChoice.Toolkits.Clarify.Location>.System.Collections.ICollection.SyncRoot
System.Collections.ObjectModel.Collection<FChoice.Toolkits.Clarify.Location>.System.Collections.IList.Item[System.Int32]
System.Collections.ObjectModel.Collection<FChoice.Toolkits.Clarify.Location>.System.Collections.IList.IsReadOnly
System.Collections.ObjectModel.Collection<FChoice.Toolkits.Clarify.Location>.System.Collections.IList.IsFixedSize
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LocationCollection : Collection<Location>, IList<Location>, ICollection<Location>, IList, ICollection, IReadOnlyList<Location>, IReadOnlyCollection<Location>, IEnumerable<Location>, IEnumerable

Properties

IsDirty

Declaration
public bool IsDirty { get; }
Property Value
Type | Description
System.Boolean |

Methods

Add(Location)

Declaration
public void Add(Location loc)
Parameters
Type | Name | Description
Location | loc |

Add(String)

Declaration
public void Add(string location)
Parameters
Type | Name | Description
System.String | location |

Add(String, String)

Declaration
public void Add(string location, string binName)
Parameters
Type | Name | Description
System.String | location |
System.String | binName |

Add(String, String, String)

Declaration
public void Add(string location, string binName, string containerID)
Parameters
Type | Name | Description
System.String | location |
System.String | binName |
System.String | containerID |

ClearItems()

Declaration
protected override void ClearItems()
Overrides
System.Collections.ObjectModel.Collection<FChoice.Toolkits.Clarify.Location>.ClearItems()

ToLegacyString()

Declaration
public string ToLegacyString()
Returns
Type | Description
System.String |

Implements

System.Collections.Generic.IList<T>
System.Collections.Generic.ICollection<T>
System.Collections.IList
System.Collections.ICollection
System.Collections.Generic.IReadOnlyList<T>
System.Collections.Generic.IReadOnlyCollection<T>
System.Collections.Generic.IEnumerable<T>
System.Collections.IEnumerable


Namespace FChoice.Toolkits.Clarify.Logistics | fcSDK Documentation

Namespace FChoice.Toolkits.Clarify.Logistics

Classes

AcceptPartRequestSetup

AddAlternatePartSetup

AddGLAccountSetup

AddInventoryBinSetup

AddInventoryLocationSetup

AddLocationServicingSiteSetup

AssignPartRequestSetup

BackorderPartRequestSetup

ChangePartRequestStatusSetup

ClosePartRequestSetup

CreateContainerSetup

CreatePartRequestDetailResult

CreatePartRequestDetailSetup

CreatePartRequestHeaderCaseSetup

CreatePartRequestHeaderSetup

CreatePartRequestHeaderSubcaseSetup

CreateSubContainerSetup

DeleteAlternatePartSetup

DeleteLocationServicingSiteSetup

DispatchPartRequestSetup

ForwardPartRequestSetup

FulfillPartRequestSetup

GetAlternatePartsResult

GetAlternatePartsSetup

GetLocationsServicingSiteResult

GetLocationsServicingSiteSetup

LogisticsToolkit

LogisticsToolkitBase

MovePartRequestSetup

OpenContainerSetup

PartTransferResult

PartTransferSetup

PickResult

PickSetup

ReceivePartRequestSetup

RejectPartRequestSetup

ReopenPartRequestSetup

SealContainerSetup

SetLogisticsTransitionSetup

SetPartStockingLevelSetup

ShipSetup

UnpickSetup

UpdateGLAccountSetup

UpdateInventoryBinSetup

UpdateInventoryLocationSetup

UpdateLocationServicingSiteSetup

UpdatePartRequestDetailSetup

UpdatePartRequestHeaderSetup

UpdatePartStockingLevelSetup

YankPartRequestSetup

Back to top © 2022 Dovetail Software, Inc. - All rights reserved.
Clarify, Amdocs, and related products and names are copyright and trademark of Amdocs, Inc.
.NET, Visual Studio.NET, C#, Visual Basic and related products are trademark of Microsoft corporation.


Class AcceptPartRequestSetup | fcSDK Documentation

Class AcceptPartRequestSetup

Inheritance
System.Object
AcceptPartRequestSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class AcceptPartRequestSetup

Constructors

AcceptPartRequestSetup(String)

Declaration
[ConstructorIndex(0)]
public AcceptPartRequestSetup(string partRequestDetailIDNum)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |

Properties

AcceptDate

Declaration
[PropertyBitValue(2)]
public DateTime AcceptDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(16)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

PartRequestDetailIDNum

Declaration
[PropertyBitValue(1)]
public string PartRequestDetailIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(4)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |


Class AddAlternatePartSetup | fcSDK Documentation

Class AddAlternatePartSetup

Inheritance
System.Object
AddAlternatePartSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class AddAlternatePartSetup

Constructors

AddAlternatePartSetup(String, String, String, String, String, String)

Declaration
[ConstructorIndex(0)]
public AddAlternatePartSetup(string partNumber, string partRevision, string partDomain, string alternatePartNumber, string alternatePartRevision, string alternatePartDomain)
Parameters
Type | Name | Description
System.String | partNumber |
System.String | partRevision |
System.String | partDomain |
System.String | alternatePartNumber |
System.String | alternatePartRevision |
System.String | alternatePartDomain |

Properties

AlternatePartDomain

Declaration
[PropertyBitValue(32)]
public string AlternatePartDomain { get; set; }
Property Value
Type | Description
System.String |

AlternatePartNumber

Declaration
[PropertyBitValue(8)]
public string AlternatePartNumber { get; set; }
Property Value
Type | Description
System.String |

AlternatePartRevision

Declaration
[PropertyBitValue(16)]
public string AlternatePartRevision { get; set; }
Property Value
Type | Description
System.String |

IsReciprocal

Declaration
[PropertyBitValue(64)]
public bool IsReciprocal { get; set; }
Property Value
Type | Description
System.Boolean |

PartDomain

Declaration
[PropertyBitValue(4)]
public string PartDomain { get; set; }
Property Value
Type | Description
System.String |

PartNumber

Declaration
[PropertyBitValue(1)]
public string PartNumber { get; set; }
Property Value
Type | Description
System.String |

PartRevision

Declaration
[PropertyBitValue(2)]
public string PartRevision { get; set; }
Property Value
Type | Description
System.String |


Class AddGLAccountSetup | fcSDK Documentation

Class AddGLAccountSetup

Inheritance
System.Object
AddGLAccountSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class AddGLAccountSetup

Constructors

AddGLAccountSetup(String, String)

Declaration
[ConstructorIndex(0)]
public AddGLAccountSetup(string accountName, string siteIDNum)
Parameters
Type | Name | Description
System.String | accountName |
System.String | siteIDNum |

Properties

AccountName

Declaration
[PropertyBitValue(1)]
public string AccountName { get; set; }
Property Value
Type | Description
System.String |

AccountNumber

Declaration
[PropertyBitValue(8)]
public string AccountNumber { get; set; }
Property Value
Type | Description
System.String |

AccountType

Declaration
[PropertyBitValue(2)]
public string AccountType { get; set; }
Property Value
Type | Description
System.String |

Description

Declaration
[PropertyBitValue(4)]
public string Description { get; set; }
Property Value
Type | Description
System.String |

IsActive

Declaration
[PropertyBitValue(32)]
public bool IsActive { get; set; }
Property Value
Type | Description
System.Boolean |

IsCompany

Declaration
[PropertyBitValue(64)]
public bool IsCompany { get; set; }
Property Value
Type | Description
System.Boolean |

IsExpenseGLAccount

Declaration
[PropertyBitValue(16)]
public bool IsExpenseGLAccount { get; set; }
Property Value
Type | Description
System.Boolean |

SiteIDNum

Declaration
[PropertyBitValue(128)]
public string SiteIDNum { get; set; }
Property Value
Type | Description
System.String |


Class AddInventoryBinSetup | fcSDK Documentation

Class AddInventoryBinSetup

Inheritance
System.Object
AddInventoryBinSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class AddInventoryBinSetup

Constructors

AddInventoryBinSetup(Location)

Declaration
[ConstructorIndex(0)]
public AddInventoryBinSetup(Location location)
Parameters
Type | Name | Description
Location | location |

Properties

IsActive

Declaration
[PropertyBitValue(4)]
public bool IsActive { get; set; }
Property Value
Type | Description
System.Boolean |

Location

Declaration
[PropertyBitValue(8)]
public Location Location { get; set; }
Property Value
Type | Description
Location |


Class AddInventoryLocationSetup | fcSDK Documentation

Class AddInventoryLocationSetup

Inheritance
System.Object
AddInventoryLocationSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class AddInventoryLocationSetup

Constructors

AddInventoryLocationSetup(String, String, String, PartAuthorizationLevel)

Declaration
[ConstructorIndex(0)]
public AddInventoryLocationSetup(string locationName, string capitalGLAccount, string siteIDNum, PartAuthorizationLevel partAuthorizationLevel)
Parameters
Type | Name | Description
System.String | locationName |
System.String | capitalGLAccount |
System.String | siteIDNum |
PartAuthorizationLevel | partAuthorizationLevel |

Properties

AccountType

Declaration
[PropertyBitValue(2)]
public string AccountType { get; set; }
Property Value
Type | Description
System.String |

CapitalGLAccount

Declaration
[PropertyBitValue(16)]
public string CapitalGLAccount { get; set; }
Property Value
Type | Description
System.String |

Description

Declaration
[PropertyBitValue(4)]
public string Description { get; set; }
Property Value
Type | Description
System.String |

IsActive

Declaration
[PropertyBitValue(32)]
public bool IsActive { get; set; }
Property Value
Type | Description
System.Boolean |

IsCompany

Declaration
[PropertyBitValue(64)]
public bool IsCompany { get; set; }
Property Value
Type | Description
System.Boolean |

LocationName

Declaration
[PropertyBitValue(1)]
public string LocationName { get; set; }
Property Value
Type | Description
System.String |

PartAuthorizationLevel

Declaration
[PropertyBitValue(256)]
public PartAuthorizationLevel PartAuthorizationLevel { get; set; }
Property Value
Type | Description
PartAuthorizationLevel |

ReportsToLocation

Declaration
[PropertyBitValue(8)]
public string ReportsToLocation { get; set; }
Property Value
Type | Description
System.String |

SiteIDNum

Declaration
[PropertyBitValue(128)]
public string SiteIDNum { get; set; }
Property Value
Type | Description
System.String |


Class AddLocationServicingSiteSetup | fcSDK Documentation

Class AddLocationServicingSiteSetup

Inheritance
System.Object
AddLocationServicingSiteSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class AddLocationServicingSiteSetup

Constructors

AddLocationServicingSiteSetup(String, String, Int16)

Declaration
[ConstructorIndex(0)]
public AddLocationServicingSiteSetup(string siteIDNum, string locationName, short locationRank)
Parameters
Type | Name | Description
System.String | siteIDNum |
System.String | locationName |
System.Int16 | locationRank |

Properties

IsActive

Declaration
[PropertyBitValue(4)]
public bool IsActive { get; set; }
Property Value
Type | Description
System.Boolean |

LocationName

Declaration
[PropertyBitValue(2)]
public string LocationName { get; set; }
Property Value
Type | Description
System.String |

LocationRank

Declaration
[PropertyBitValue(8)]
public short LocationRank { get; set; }
Property Value
Type | Description
System.Int16 |

SiteIDNum

Declaration
[PropertyBitValue(1)]
public string SiteIDNum { get; set; }
Property Value
Type | Description
System.String |


Class AssignPartRequestSetup | fcSDK Documentation

Class AssignPartRequestSetup

Inheritance
System.Object
AssignPartRequestSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class AssignPartRequestSetup

Constructors

AssignPartRequestSetup(String)

Declaration
[ConstructorIndex(0)]
public AssignPartRequestSetup(string partRequestDetailIDNum)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |

Properties

AssignDate

Declaration
[PropertyBitValue(8)]
public DateTime AssignDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

NewUser

Declaration
[PropertyBitValue(2)]
public string NewUser { get; set; }
Property Value
Type | Description
System.String |

PartRequestDetailIDNum

Declaration
[PropertyBitValue(1)]
public string PartRequestDetailIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(4)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |


Class BackorderPartRequestSetup | fcSDK Documentation

Class BackorderPartRequestSetup

Inheritance
System.Object
BackorderPartRequestSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class BackorderPartRequestSetup

Constructors

BackorderPartRequestSetup(String, DateTime, Boolean, Int32)

Declaration
[ConstructorIndex(2)]
public BackorderPartRequestSetup(string partRequestDetailIDNum, DateTime expectedDate, bool useTransitions, int quantity)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.DateTime | expectedDate |
System.Boolean | useTransitions |
System.Int32 | quantity |

BackorderPartRequestSetup(String, DateTime, Boolean, String)

Declaration
[ConstructorIndex(3)]
public BackorderPartRequestSetup(string partRequestDetailIDNum, DateTime expectedDate, bool useTransitions, string serialNumber)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.DateTime | expectedDate |
System.Boolean | useTransitions |
System.String | serialNumber |

BackorderPartRequestSetup(String, DateTime, Int32)

Declaration
[ConstructorIndex(0)]
public BackorderPartRequestSetup(string partRequestDetailIDNum, DateTime expectedDate, int quantity)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.DateTime | expectedDate |
System.Int32 | quantity |

BackorderPartRequestSetup(String, DateTime, String)

Declaration
[ConstructorIndex(1)]
public BackorderPartRequestSetup(string partRequestDetailIDNum, DateTime expectedDate, string serialNumber)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.DateTime | expectedDate |
System.String | serialNumber |

Properties

ExpectedDate

Declaration
[PropertyBitValue(8192)]
public DateTime ExpectedDate { get; set; }
Property Value
Type | Description
System.DateTime |

FromGood

Declaration
[PropertyBitValue(64)]
public bool FromGood { get; set; }
Property Value
Type | Description
System.Boolean |

FromLocation

Declaration
[PropertyBitValue(524288)]
public Location FromLocation { get; set; }
Property Value
Type | Description
Location |

GenerateTimeBombs

Declaration
[PropertyBitValue(65536)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

NewStatus

Declaration
[PropertyBitValue(4096)]
public string NewStatus { get; set; }
Property Value
Type | Description
System.String |

PartRequestDetailIDNum

Declaration
[PropertyBitValue(1)]
public string PartRequestDetailIDNum { get; set; }
Property Value
Type | Description
System.String |

Quantity

Declaration
[PropertyBitValue(4)]
public int Quantity { get; set; }
Property Value
Type | Description
System.Int32 |

SerialNumber

Declaration
[PropertyBitValue(2048)]
public string SerialNumber { get; set; }
Property Value
Type | Description
System.String |

ToGood

Declaration
[PropertyBitValue(1024)]
public bool ToGood { get; set; }
Property Value
Type | Description
System.Boolean |

ToLocation

Declaration
[PropertyBitValue(262144)]
public Location ToLocation { get; set; }
Property Value
Type | Description
Location |

UserName

Declaration
[PropertyBitValue(16384)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

UseTransitions

Declaration
[PropertyBitValue(131072)]
public bool UseTransitions { get; set; }
Property Value
Type | Description
System.Boolean |


Class ChangePartRequestStatusSetup | fcSDK Documentation

Class ChangePartRequestStatusSetup

Inheritance
System.Object
ChangePartRequestStatusSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ChangePartRequestStatusSetup

Constructors

ChangePartRequestStatusSetup(String)

Declaration
[ConstructorIndex(0)]
public ChangePartRequestStatusSetup(string partRequestDetailIDNum)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |

Properties

ChangeDate

Declaration
[PropertyBitValue(4)]
public DateTime ChangeDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

NewStatus

Declaration
[PropertyBitValue(2)]
public string NewStatus { get; set; }
Property Value
Type | Description
System.String |

Notes

Declaration
[PropertyBitValue(8)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

PartRequestDetailIDNum

Declaration
[PropertyBitValue(1)]
public string PartRequestDetailIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class ClosePartRequestSetup | fcSDK Documentation

Class ClosePartRequestSetup

Inheritance
System.Object
ClosePartRequestSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ClosePartRequestSetup

Constructors

ClosePartRequestSetup(String)

Declaration
[ConstructorIndex(0)]
public ClosePartRequestSetup(string partRequestDetailIDNum)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |

Properties

CloseDate

Declaration
[PropertyBitValue(4)]
public DateTime CloseDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(16)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

NewStatus

Declaration
[PropertyBitValue(2)]
public string NewStatus { get; set; }
Property Value
Type | Description
System.String |

PartRequestDetailIDNum

Declaration
[PropertyBitValue(1)]
public string PartRequestDetailIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class CreateContainerSetup | fcSDK Documentation

Class CreateContainerSetup

Inheritance
System.Object
CreateContainerSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateContainerSetup

Constructors

CreateContainerSetup(String, String)

Declaration
[ConstructorIndex(0)]
public CreateContainerSetup(string containerName, string locationName)
Parameters
Type | Name | Description
System.String | containerName |
System.String | locationName |

Properties

BinName

Declaration
[PropertyBitValue(4)]
public string BinName { get; set; }
Property Value
Type | Description
System.String |

ContainerName

Declaration
[PropertyBitValue(1)]
public string ContainerName { get; set; }
Property Value
Type | Description
System.String |

LocationName

Declaration
[PropertyBitValue(2)]
public string LocationName { get; set; }
Property Value
Type | Description
System.String |


Class CreatePartRequestDetailResult | fcSDK Documentation

Class CreatePartRequestDetailResult

Inheritance
System.Object
ToolkitResult
CreatePartRequestDetailResult
Inherited Members
ToolkitResult._ReturnCode
ToolkitResult._IDNum
ToolkitResult._Objid
ToolkitResult.ReturnCode
ToolkitResult.IDNum
ToolkitResult.Objid
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreatePartRequestDetailResult : ToolkitResult

Constructors

CreatePartRequestDetailResult()

Declaration
public CreatePartRequestDetailResult()

Properties

DetailNumber

Declaration
public string DetailNumber { get; set; }
Property Value
Type | Description
System.String |


Class CreatePartRequestDetailSetup | fcSDK Documentation

Class CreatePartRequestDetailSetup

Inheritance
System.Object
CreatePartRequestDetailSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreatePartRequestDetailSetup

Constructors

CreatePartRequestDetailSetup(String, Int32, Int32)

Declaration
[ConstructorIndex(1)]
public CreatePartRequestDetailSetup(string partRequestHeaderIDNum, int quantity, int sitePartObjid)
Parameters
Type | Name | Description
System.String | partRequestHeaderIDNum |
System.Int32 | quantity |
System.Int32 | sitePartObjid |

CreatePartRequestDetailSetup(String, String, Int32)

Declaration
[ConstructorIndex(3)]
public CreatePartRequestDetailSetup(string partRequestHeaderIDNum, string serialNumber, int sitePartObjid)
Parameters
Type | Name | Description
System.String | partRequestHeaderIDNum |
System.String | serialNumber |
System.Int32 | sitePartObjid |

CreatePartRequestDetailSetup(String, String, String, String, Int32)

Declaration
[ConstructorIndex(0)]
public CreatePartRequestDetailSetup(string partRequestHeaderIDNum, string partNumber, string partDomain, string partRevision, int quantity)
Parameters
Type | Name | Description
System.String | partRequestHeaderIDNum |
System.String | partNumber |
System.String | partDomain |
System.String | partRevision |
System.Int32 | quantity |

CreatePartRequestDetailSetup(String, String, String, String, String)

Declaration
[ConstructorIndex(2)]
public CreatePartRequestDetailSetup(string partRequestHeaderIDNum, string partNumber, string partDomain, string partRevision, string serialNumber)
Parameters
Type | Name | Description
System.String | partRequestHeaderIDNum |
System.String | partNumber |
System.String | partDomain |
System.String | partRevision |
System.String | serialNumber |

Properties

AdditionalFields

Declaration
[PropertyBitValue(2097152)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

CarrierName

Declaration
[PropertyBitValue(4096)]
public string CarrierName { get; set; }
Property Value
Type | Description
System.String |

ContractItemObjid

Declaration
[PropertyBitValue(1048576)]
public int ContractItemObjid { get; set; }
Property Value
Type | Description
System.Int32 |

CreateDate

Declaration
[PropertyBitValue(131072)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

DetailType

Declaration
[PropertyBitValue(512)]
public string DetailType { get; set; }
Property Value
Type | Description
System.String |

DueDate

Declaration
[PropertyBitValue(262144)]
public DateTime DueDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(524288)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

HasWarranty

Declaration
[PropertyBitValue(16384)]
public bool HasWarranty { get; set; }
Property Value
Type | Description
System.Boolean |

Notes

Declaration
[PropertyBitValue(32768)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

PartDomain

Declaration
[PropertyBitValue(8)]
public string PartDomain { get; set; }
Property Value
Type | Description
System.String |

PartNumber

Declaration
[PropertyBitValue(4)]
public string PartNumber { get; set; }
Property Value
Type | Description
System.String |

PartRequestHeaderIDNum

Declaration
[PropertyBitValue(1)]
public string PartRequestHeaderIDNum { get; set; }
Property Value
Type | Description
System.String |

PartRevision

Declaration
[PropertyBitValue(16)]
public string PartRevision { get; set; }
Property Value
Type | Description
System.String |

Priority

Declaration
[PropertyBitValue(1024)]
public string Priority { get; set; }
Property Value
Type | Description
System.String |

Quantity

Declaration
[PropertyBitValue(64)]
public int Quantity { get; set; }
Property Value
Type | Description
System.Int32 |

Queue

Declaration
[PropertyBitValue(2)]
public string Queue { get; set; }
Property Value
Type | Description
System.String |

SerialNumber

Declaration
[PropertyBitValue(32)]
public string SerialNumber { get; set; }
Property Value
Type | Description
System.String |

ShippingMethod

Declaration
[PropertyBitValue(2048)]
public string ShippingMethod { get; set; }
Property Value
Type | Description
System.String |

SitePartObjid

Declaration
[PropertyBitValue(128)]
public int SitePartObjid { get; set; }
Property Value
Type | Description
System.Int32 |

Status

Declaration
[PropertyBitValue(65536)]
public string Status { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(8192)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class CreatePartRequestHeaderCaseSetup | fcSDK Documentation

Class CreatePartRequestHeaderCaseSetup

Inheritance
System.Object
CreatePartRequestHeaderCaseSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreatePartRequestHeaderCaseSetup

Constructors

CreatePartRequestHeaderCaseSetup(String, String, String, String, String)

Declaration
[ConstructorIndex(0)]
public CreatePartRequestHeaderCaseSetup(string contactFirstName, string contactLastName, string contactPhone, string shipToSiteIDNum, string caseIDNum)
Parameters
Type | Name | Description
System.String | contactFirstName |
System.String | contactLastName |
System.String | contactPhone |
System.String | shipToSiteIDNum |
System.String | caseIDNum |

Properties

AdditionalFields

Declaration
[PropertyBitValue(8192)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

BillSiteIDNum

Declaration
[PropertyBitValue(16)]
public string BillSiteIDNum { get; set; }
Property Value
Type | Description
System.String |

CaseIDNum

Declaration
[PropertyBitValue(32)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

ContactFirstName

Declaration
[PropertyBitValue(1)]
public string ContactFirstName { get; set; }
Property Value
Type | Description
System.String |

ContactLastName

Declaration
[PropertyBitValue(2)]
public string ContactLastName { get; set; }
Property Value
Type | Description
System.String |

ContactPhone

Declaration
[PropertyBitValue(4)]
public string ContactPhone { get; set; }
Property Value
Type | Description
System.String |

ContractObjid

Declaration
[PropertyBitValue(4096)]
public int ContractObjid { get; set; }
Property Value
Type | Description
System.Int32 |

CreateDate

Declaration
[PropertyBitValue(2048)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

Notes

Declaration
[PropertyBitValue(1024)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

PaymentMethod

Declaration
[PropertyBitValue(64)]
public string PaymentMethod { get; set; }
Property Value
Type | Description
System.String |

PaymentTerms

Declaration
[PropertyBitValue(128)]
public string PaymentTerms { get; set; }
Property Value
Type | Description
System.String |

Priority

Declaration
[PropertyBitValue(256)]
public string Priority { get; set; }
Property Value
Type | Description
System.String |

ShipToSiteIDNum

Declaration
[PropertyBitValue(8)]
public string ShipToSiteIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(512)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class CreatePartRequestHeaderSetup | fcSDK Documentation

Class CreatePartRequestHeaderSetup

Inheritance
System.Object
CreatePartRequestHeaderSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreatePartRequestHeaderSetup

Constructors

CreatePartRequestHeaderSetup(String, String, String, String)

Declaration
[ConstructorIndex(0)]
public CreatePartRequestHeaderSetup(string contactFirstName, string contactLastName, string contactPhone, string shipToSiteIDNum)
Parameters
Type | Name | Description
System.String | contactFirstName |
System.String | contactLastName |
System.String | contactPhone |
System.String | shipToSiteIDNum |

Properties

AdditionalFields

Declaration
[PropertyBitValue(8192)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

BillSiteIDNum

Declaration
[PropertyBitValue(16)]
public string BillSiteIDNum { get; set; }
Property Value
Type | Description
System.String |

CaseIDNum

Declaration
[PropertyBitValue(32)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

ContactFirstName

Declaration
[PropertyBitValue(1)]
public string ContactFirstName { get; set; }
Property Value
Type | Description
System.String |

ContactLastName

Declaration
[PropertyBitValue(2)]
public string ContactLastName { get; set; }
Property Value
Type | Description
System.String |

ContactPhone

Declaration
[PropertyBitValue(4)]
public string ContactPhone { get; set; }
Property Value
Type | Description
System.String |

ContractObjid

Declaration
[PropertyBitValue(4096)]
public int ContractObjid { get; set; }
Property Value
Type | Description
System.Int32 |

CreateDate

Declaration
[PropertyBitValue(2048)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

Notes

Declaration
[PropertyBitValue(1024)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

PaymentMethod

Declaration
[PropertyBitValue(64)]
public string PaymentMethod { get; set; }
Property Value
Type | Description
System.String |

PaymentTerms

Declaration
[PropertyBitValue(128)]
public string PaymentTerms { get; set; }
Property Value
Type | Description
System.String |

Priority

Declaration
[PropertyBitValue(256)]
public string Priority { get; set; }
Property Value
Type | Description
System.String |

ShipToSiteIDNum

Declaration
[PropertyBitValue(8)]
public string ShipToSiteIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(512)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class CreatePartRequestHeaderSubcaseSetup | fcSDK Documentation

Class CreatePartRequestHeaderSubcaseSetup

Inheritance
System.Object
CreatePartRequestHeaderSubcaseSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreatePartRequestHeaderSubcaseSetup

Constructors

CreatePartRequestHeaderSubcaseSetup(String, String, String, String, String)

Declaration
[ConstructorIndex(0)]
public CreatePartRequestHeaderSubcaseSetup(string contactFirstName, string contactLastName, string contactPhone, string shipToSiteIDNum, string caseIDNum)
Parameters
Type | Name | Description
System.String | contactFirstName |
System.String | contactLastName |
System.String | contactPhone |
System.String | shipToSiteIDNum |
System.String | caseIDNum |

Properties

AdditionalFields

Declaration
[PropertyBitValue(8192)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

BillSiteIDNum

Declaration
[PropertyBitValue(16)]
public string BillSiteIDNum { get; set; }
Property Value
Type | Description
System.String |

CaseIDNum

Declaration
[PropertyBitValue(32)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

ContactFirstName

Declaration
[PropertyBitValue(1)]
public string ContactFirstName { get; set; }
Property Value
Type | Description
System.String |

ContactLastName

Declaration
[PropertyBitValue(2)]
public string ContactLastName { get; set; }
Property Value
Type | Description
System.String |

ContactPhone

Declaration
[PropertyBitValue(4)]
public string ContactPhone { get; set; }
Property Value
Type | Description
System.String |

ContractObjid

Declaration
[PropertyBitValue(4096)]
public int ContractObjid { get; set; }
Property Value
Type | Description
System.Int32 |

CreateDate

Declaration
[PropertyBitValue(2048)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

Notes

Declaration
[PropertyBitValue(1024)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

PaymentMethod

Declaration
[PropertyBitValue(64)]
public string PaymentMethod { get; set; }
Property Value
Type | Description
System.String |

PaymentTerms

Declaration
[PropertyBitValue(128)]
public string PaymentTerms { get; set; }
Property Value
Type | Description
System.String |

Priority

Declaration
[PropertyBitValue(256)]
public string Priority { get; set; }
Property Value
Type | Description
System.String |

ShipToSiteIDNum

Declaration
[PropertyBitValue(8)]
public string ShipToSiteIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(512)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class CreateSubContainerSetup | fcSDK Documentation

Class CreateSubContainerSetup

Inheritance
System.Object
CreateSubContainerSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateSubContainerSetup

Constructors

CreateSubContainerSetup(String, String)

Declaration
[ConstructorIndex(0)]
public CreateSubContainerSetup(string containerName, string parentContainerName)
Parameters
Type | Name | Description
System.String | containerName |
System.String | parentContainerName |

Properties

ContainerName

Declaration
[PropertyBitValue(1)]
public string ContainerName { get; set; }
Property Value
Type | Description
System.String |

ParentContainerName

Declaration
[PropertyBitValue(8)]
public string ParentContainerName { get; set; }
Property Value
Type | Description
System.String |


Class DeleteAlternatePartSetup | fcSDK Documentation

Class DeleteAlternatePartSetup

Inheritance
System.Object
DeleteAlternatePartSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class DeleteAlternatePartSetup

Constructors

DeleteAlternatePartSetup(String, String, String, String, String, String)

Declaration
[ConstructorIndex(0)]
public DeleteAlternatePartSetup(string partNumber, string partRevision, string partDomain, string alternatePartNumber, string alternatePartRevision, string alternatePartDomain)
Parameters
Type | Name | Description
System.String | partNumber |
System.String | partRevision |
System.String | partDomain |
System.String | alternatePartNumber |
System.String | alternatePartRevision |
System.String | alternatePartDomain |

Properties

AlternatePartDomain

Declaration
[PropertyBitValue(32)]
public string AlternatePartDomain { get; set; }
Property Value
Type | Description
System.String |

AlternatePartNumber

Declaration
[PropertyBitValue(8)]
public string AlternatePartNumber { get; set; }
Property Value
Type | Description
System.String |

AlternatePartRevision

Declaration
[PropertyBitValue(16)]
public string AlternatePartRevision { get; set; }
Property Value
Type | Description
System.String |

PartDomain

Declaration
[PropertyBitValue(4)]
public string PartDomain { get; set; }
Property Value
Type | Description
System.String |

PartNumber

Declaration
[PropertyBitValue(1)]
public string PartNumber { get; set; }
Property Value
Type | Description
System.String |

PartRevision

Declaration
[PropertyBitValue(2)]
public string PartRevision { get; set; }
Property Value
Type | Description
System.String |


Class DeleteLocationServicingSiteSetup | fcSDK Documentation

Class DeleteLocationServicingSiteSetup

Inheritance
System.Object
DeleteLocationServicingSiteSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class DeleteLocationServicingSiteSetup

Constructors

DeleteLocationServicingSiteSetup(String, String)

Declaration
[ConstructorIndex(0)]
public DeleteLocationServicingSiteSetup(string siteIDNum, string locationName)
Parameters
Type | Name | Description
System.String | siteIDNum |
System.String | locationName |

Properties

LocationName

Declaration
[PropertyBitValue(2)]
public string LocationName { get; set; }
Property Value
Type | Description
System.String |

SiteIDNum

Declaration
[PropertyBitValue(1)]
public string SiteIDNum { get; set; }
Property Value
Type | Description
System.String |


Class DispatchPartRequestSetup | fcSDK Documentation

Class DispatchPartRequestSetup

Inheritance
System.Object
DispatchPartRequestSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class DispatchPartRequestSetup

Constructors

DispatchPartRequestSetup(String, String)

Declaration
[ConstructorIndex(0)]
public DispatchPartRequestSetup(string partRequestDetailIDNum, string queue)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String | queue |

Properties

DispatchDate

Declaration
[PropertyBitValue(4)]
public DateTime DispatchDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(16)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

PartRequestDetailIDNum

Declaration
[PropertyBitValue(1)]
public string PartRequestDetailIDNum { get; set; }
Property Value
Type | Description
System.String |

Queue

Declaration
[PropertyBitValue(2)]
public string Queue { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class ForwardPartRequestSetup | fcSDK Documentation

Class ForwardPartRequestSetup

Inheritance
System.Object
ForwardPartRequestSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ForwardPartRequestSetup

Constructors

ForwardPartRequestSetup(String, String)

Declaration
[ConstructorIndex(0)]
public ForwardPartRequestSetup(string partRequestDetailIDNum, string newQueue)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String | newQueue |

Properties

ForwardDate

Declaration
[PropertyBitValue(4)]
public DateTime ForwardDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

NewQueue

Declaration
[PropertyBitValue(2)]
public string NewQueue { get; set; }
Property Value
Type | Description
System.String |

Notes

Declaration
[PropertyBitValue(8)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

PartRequestDetailIDNum

Declaration
[PropertyBitValue(1)]
public string PartRequestDetailIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class FulfillPartRequestSetup | fcSDK Documentation

Class FulfillPartRequestSetup

Inheritance
System.Object
FulfillPartRequestSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class FulfillPartRequestSetup

Constructors

FulfillPartRequestSetup(String, Boolean, Int32)

Declaration
[ConstructorIndex(2)]
public FulfillPartRequestSetup(string partRequestDetailIDNum, bool useTransitions, int quantity)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.Boolean | useTransitions |
System.Int32 | quantity |

FulfillPartRequestSetup(String, Boolean, String)

Declaration
[ConstructorIndex(3)]
public FulfillPartRequestSetup(string partRequestDetailIDNum, bool useTransitions, string serialNumber)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.Boolean | useTransitions |
System.String | serialNumber |

FulfillPartRequestSetup(String, Int32)

Declaration
[ConstructorIndex(0)]
public FulfillPartRequestSetup(string partRequestDetailIDNum, int quantity)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.Int32 | quantity |

FulfillPartRequestSetup(String, String)

Declaration
[ConstructorIndex(1)]
public FulfillPartRequestSetup(string partRequestDetailIDNum, string serialNumber)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String | serialNumber |

Properties

FromGood

Declaration
[PropertyBitValue(64)]
public bool FromGood { get; set; }
Property Value
Type | Description
System.Boolean |

FromLocation

Declaration
[PropertyBitValue(524288)]
public Location FromLocation { get; set; }
Property Value
Type | Description
Location |

FulfillDate

Declaration
[PropertyBitValue(32768)]
public DateTime FulfillDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(65536)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

NewStatus

Declaration
[PropertyBitValue(4096)]
public string NewStatus { get; set; }
Property Value
Type | Description
System.String |

PartRequestDetailIDNum

Declaration
[PropertyBitValue(1)]
public string PartRequestDetailIDNum { get; set; }
Property Value
Type | Description
System.String |

Quantity

Declaration
[PropertyBitValue(4)]
public int Quantity { get; set; }
Property Value
Type | Description
System.Int32 |

SerialNumber

Declaration
[PropertyBitValue(2048)]
public string SerialNumber { get; set; }
Property Value
Type | Description
System.String |

ToGood

Declaration
[PropertyBitValue(1024)]
public bool ToGood { get; set; }
Property Value
Type | Description
System.Boolean |

ToLocation

Declaration
[PropertyBitValue(262144)]
public Location ToLocation { get; set; }
Property Value
Type | Description
Location |

UserName

Declaration
[PropertyBitValue(16384)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

UseTransitions

Declaration
[PropertyBitValue(131072)]
public bool UseTransitions { get; set; }
Property Value
Type | Description
System.Boolean |


Class GetAlternatePartsResult | fcSDK Documentation

Class GetAlternatePartsResult

Inheritance
System.Object
ToolkitResult
GetAlternatePartsResult
Inherited Members
ToolkitResult._ReturnCode
ToolkitResult._IDNum
ToolkitResult._Objid
ToolkitResult.ReturnCode
ToolkitResult.IDNum
ToolkitResult.Objid
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class GetAlternatePartsResult : ToolkitResult

Constructors

GetAlternatePartsResult()

Declaration
public GetAlternatePartsResult()

Properties

AlternatePartList

Declaration
public int[] AlternatePartList { get; set; }
Property Value
Type | Description
System.Int32[] |


Class GetAlternatePartsSetup | fcSDK Documentation

Class GetAlternatePartsSetup

Inheritance
System.Object
GetAlternatePartsSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class GetAlternatePartsSetup

Constructors

GetAlternatePartsSetup(String, String, String)

Declaration
[ConstructorIndex(0)]
public GetAlternatePartsSetup(string partNumber, string partDomain, string partRevision)
Parameters
Type | Name | Description
System.String | partNumber |
System.String | partDomain |
System.String | partRevision |

Properties

PartDomain

Declaration
[PropertyBitValue(2)]
public string PartDomain { get; set; }
Property Value
Type | Description
System.String |

PartNumber

Declaration
[PropertyBitValue(1)]
public string PartNumber { get; set; }
Property Value
Type | Description
System.String |

PartRevision

Declaration
[PropertyBitValue(4)]
public string PartRevision { get; set; }
Property Value
Type | Description
System.String |


Class GetLocationsServicingSiteResult | fcSDK Documentation

Class GetLocationsServicingSiteResult

Inheritance
System.Object
ToolkitResult
GetLocationsServicingSiteResult
Inherited Members
ToolkitResult._ReturnCode
ToolkitResult._IDNum
ToolkitResult._Objid
ToolkitResult.ReturnCode
ToolkitResult.IDNum
ToolkitResult.Objid
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class GetLocationsServicingSiteResult : ToolkitResult

Constructors

GetLocationsServicingSiteResult()

Declaration
public GetLocationsServicingSiteResult()

Properties

InventoryLocationObjidList

Declaration
public int[] InventoryLocationObjidList { get; set; }
Property Value
Type | Description
System.Int32[] |


Class GetLocationsServicingSiteSetup | fcSDK Documentation

Class GetLocationsServicingSiteSetup

Inheritance
System.Object
GetLocationsServicingSiteSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class GetLocationsServicingSiteSetup

Constructors

GetLocationsServicingSiteSetup(String)

Declaration
[ConstructorIndex(0)]
public GetLocationsServicingSiteSetup(string siteIDNum)
Parameters
Type | Name | Description
System.String | siteIDNum |

Properties

SiteIDNum

Declaration
[PropertyBitValue(1)]
public string SiteIDNum { get; set; }
Property Value
Type | Description
System.String |


Class LogisticsToolkit | fcSDK Documentation

Class LogisticsToolkit

Inheritance
System.Object
ToolkitBase
LogisticsToolkitBase
LogisticsToolkit
Inherited Members
LogisticsToolkitBase._toolkit
LogisticsToolkitBase.ImpersonatorUsername
ToolkitBase.NOW_DATE
ToolkitBase.CompatSession
ToolkitBase.WithTransaction<T>(Func<IDbTransaction, T>)
ToolkitBase.FCApplication
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LogisticsToolkit : LogisticsToolkitBase

Constructors

LogisticsToolkit(ClarifySession)

Declaration
public LogisticsToolkit(ClarifySession session)
Parameters
Type | Name | Description
ClarifySession | session |

LogisticsToolkit(IFCApplication, IFCSession)

Declaration
public LogisticsToolkit(IFCApplication application, IFCSession session)
Parameters
Type | Name | Description
IFCApplication | application |
IFCSession | session |

Methods

AcceptPartRequest(AcceptPartRequestSetup)

Declaration
public ToolkitResult AcceptPartRequest(AcceptPartRequestSetup setupParam)
Parameters
Type | Name | Description
AcceptPartRequestSetup | setupParam |
Returns
Type | Description
ToolkitResult |

AcceptPartRequest(AcceptPartRequestSetup, IDbTransaction)

Declaration
public ToolkitResult AcceptPartRequest(AcceptPartRequestSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
AcceptPartRequestSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

AcceptPartRequest(String)

Declaration
public ToolkitResult AcceptPartRequest(string partRequestDetailIDNum)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
Returns
Type | Description
ToolkitResult |

AddAlternatePart(AddAlternatePartSetup)

Declaration
public ToolkitResult AddAlternatePart(AddAlternatePartSetup setupParam)
Parameters
Type | Name | Description
AddAlternatePartSetup | setupParam |
Returns
Type | Description
ToolkitResult |

AddAlternatePart(AddAlternatePartSetup, IDbTransaction)

Declaration
public ToolkitResult AddAlternatePart(AddAlternatePartSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
AddAlternatePartSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

AddAlternatePart(String, String, String, String, String, String)

Declaration
public ToolkitResult AddAlternatePart(string partNumber, string partRevision, string partDomain, string alternatePartNumber, string alternatePartRevision, string alternatePartDomain)
Parameters
Type | Name | Description
System.String | partNumber |
System.String | partRevision |
System.String | partDomain |
System.String | alternatePartNumber |
System.String | alternatePartRevision |
System.String | alternatePartDomain |
Returns
Type | Description
ToolkitResult |

AddGLAccount(AddGLAccountSetup)

Declaration
public ToolkitResult AddGLAccount(AddGLAccountSetup setupParam)
Parameters
Type | Name | Description
AddGLAccountSetup | setupParam |
Returns
Type | Description
ToolkitResult |

AddGLAccount(AddGLAccountSetup, IDbTransaction)

Declaration
public ToolkitResult AddGLAccount(AddGLAccountSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
AddGLAccountSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

AddGLAccount(String, String)

Declaration
public ToolkitResult AddGLAccount(string accountName, string siteIDNum)
Parameters
Type | Name | Description
System.String | accountName |
System.String | siteIDNum |
Returns
Type | Description
ToolkitResult |

AddInventoryBin(Location)

Declaration
public ToolkitResult AddInventoryBin(Location location)
Parameters
Type | Name | Description
Location | location |
Returns
Type | Description
ToolkitResult |

AddInventoryBin(AddInventoryBinSetup)

Declaration
public ToolkitResult AddInventoryBin(AddInventoryBinSetup setupParam)
Parameters
Type | Name | Description
AddInventoryBinSetup | setupParam |
Returns
Type | Description
ToolkitResult |

AddInventoryBin(AddInventoryBinSetup, IDbTransaction)

Declaration
public ToolkitResult AddInventoryBin(AddInventoryBinSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
AddInventoryBinSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

AddInventoryLocation(AddInventoryLocationSetup)

Declaration
public ToolkitResult AddInventoryLocation(AddInventoryLocationSetup setupParam)
Parameters
Type | Name | Description
AddInventoryLocationSetup | setupParam |
Returns
Type | Description
ToolkitResult |

AddInventoryLocation(AddInventoryLocationSetup, IDbTransaction)

Declaration
public ToolkitResult AddInventoryLocation(AddInventoryLocationSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
AddInventoryLocationSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

AddInventoryLocation(String, String, String, PartAuthorizationLevel)

Declaration
public ToolkitResult AddInventoryLocation(string locationName, string capitalGLAccount, string siteIDNum, PartAuthorizationLevel partAuthorizationLevel)
Parameters
Type | Name | Description
System.String | locationName |
System.String | capitalGLAccount |
System.String | siteIDNum |
PartAuthorizationLevel | partAuthorizationLevel |
Returns
Type | Description
ToolkitResult |

AddLocationServicingSite(AddLocationServicingSiteSetup)

Declaration
public ToolkitResult AddLocationServicingSite(AddLocationServicingSiteSetup setupParam)
Parameters
Type | Name | Description
AddLocationServicingSiteSetup | setupParam |
Returns
Type | Description
ToolkitResult |

AddLocationServicingSite(AddLocationServicingSiteSetup, IDbTransaction)

Declaration
public ToolkitResult AddLocationServicingSite(AddLocationServicingSiteSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
AddLocationServicingSiteSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

AddLocationServicingSite(String, String, Int16)

Declaration
public ToolkitResult AddLocationServicingSite(string siteIDNum, string locationName, short locationRank)
Parameters
Type | Name | Description
System.String | siteIDNum |
System.String | locationName |
System.Int16 | locationRank |
Returns
Type | Description
ToolkitResult |

AssignPartRequest(AssignPartRequestSetup)

Declaration
public ToolkitResult AssignPartRequest(AssignPartRequestSetup setupParam)
Parameters
Type | Name | Description
AssignPartRequestSetup | setupParam |
Returns
Type | Description
ToolkitResult |

AssignPartRequest(AssignPartRequestSetup, IDbTransaction)

Declaration
public ToolkitResult AssignPartRequest(AssignPartRequestSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
AssignPartRequestSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

AssignPartRequest(String)

Declaration
public ToolkitResult AssignPartRequest(string partRequestDetailIDNum)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
Returns
Type | Description
ToolkitResult |

BackorderPartRequest(BackorderPartRequestSetup)

Declaration
public ToolkitResult BackorderPartRequest(BackorderPartRequestSetup setupParam)
Parameters
Type | Name | Description
BackorderPartRequestSetup | setupParam |
Returns
Type | Description
ToolkitResult |

BackorderPartRequest(BackorderPartRequestSetup, IDbTransaction)

Declaration
public ToolkitResult BackorderPartRequest(BackorderPartRequestSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
BackorderPartRequestSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

BackorderPartRequest(String, DateTime, Boolean, Int32)

Declaration
public ToolkitResult BackorderPartRequest(string partRequestDetailIDNum, DateTime expectedDate, bool useTransitions, int quantity)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.DateTime | expectedDate |
System.Boolean | useTransitions |
System.Int32 | quantity |
Returns
Type | Description
ToolkitResult |

BackorderPartRequest(String, DateTime, Boolean, String)

Declaration
public ToolkitResult BackorderPartRequest(string partRequestDetailIDNum, DateTime expectedDate, bool useTransitions, string serialNumber)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.DateTime | expectedDate |
System.Boolean | useTransitions |
System.String | serialNumber |
Returns
Type | Description
ToolkitResult |

BackorderPartRequest(String, DateTime, Int32)

Declaration
public ToolkitResult BackorderPartRequest(string partRequestDetailIDNum, DateTime expectedDate, int quantity)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.DateTime | expectedDate |
System.Int32 | quantity |
Returns
Type | Description
ToolkitResult |

BackorderPartRequest(String, DateTime, String)

Declaration
public ToolkitResult BackorderPartRequest(string partRequestDetailIDNum, DateTime expectedDate, string serialNumber)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.DateTime | expectedDate |
System.String | serialNumber |
Returns
Type | Description
ToolkitResult |

ChangePartRequestStatus(ChangePartRequestStatusSetup)

Declaration
public ToolkitResult ChangePartRequestStatus(ChangePartRequestStatusSetup setupParam)
Parameters
Type | Name | Description
ChangePartRequestStatusSetup | setupParam |
Returns
Type | Description
ToolkitResult |

ChangePartRequestStatus(ChangePartRequestStatusSetup, IDbTransaction)

Declaration
public ToolkitResult ChangePartRequestStatus(ChangePartRequestStatusSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
ChangePartRequestStatusSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

ChangePartRequestStatus(String)

Declaration
public ToolkitResult ChangePartRequestStatus(string partRequestDetailIDNum)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
Returns
Type | Description
ToolkitResult |

ClosePartRequest(ClosePartRequestSetup)

Declaration
public ToolkitResult ClosePartRequest(ClosePartRequestSetup setupParam)
Parameters
Type | Name | Description
ClosePartRequestSetup | setupParam |
Returns
Type | Description
ToolkitResult |

ClosePartRequest(ClosePartRequestSetup, IDbTransaction)

Declaration
public ToolkitResult ClosePartRequest(ClosePartRequestSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
ClosePartRequestSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

ClosePartRequest(String)

Declaration
public ToolkitResult ClosePartRequest(string partRequestDetailIDNum)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
Returns
Type | Description
ToolkitResult |

CreateContainer(CreateContainerSetup)

Declaration
public ToolkitResult CreateContainer(CreateContainerSetup setupParam)
Parameters
Type | Name | Description
CreateContainerSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreateContainer(CreateContainerSetup, IDbTransaction)

Declaration
public ToolkitResult CreateContainer(CreateContainerSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateContainerSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreateContainer(String, String)

Declaration
public ToolkitResult CreateContainer(string containerName, string locationName)
Parameters
Type | Name | Description
System.String | containerName |
System.String | locationName |
Returns
Type | Description
ToolkitResult |

CreatePartRequestDetail(CreatePartRequestDetailSetup)

Declaration
public CreatePartRequestDetailResult CreatePartRequestDetail(CreatePartRequestDetailSetup setupParam)
Parameters
Type | Name | Description
CreatePartRequestDetailSetup | setupParam |
Returns
Type | Description
CreatePartRequestDetailResult |

CreatePartRequestDetail(CreatePartRequestDetailSetup, IDbTransaction)

Declaration
public CreatePartRequestDetailResult CreatePartRequestDetail(CreatePartRequestDetailSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreatePartRequestDetailSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
CreatePartRequestDetailResult |

CreatePartRequestDetail(String, Int32, Int32)

Declaration
public CreatePartRequestDetailResult CreatePartRequestDetail(string partRequestHeaderIDNum, int quantity, int sitePartObjid)
Parameters
Type | Name | Description
System.String | partRequestHeaderIDNum |
System.Int32 | quantity |
System.Int32 | sitePartObjid |
Returns
Type | Description
CreatePartRequestDetailResult |

CreatePartRequestDetail(String, String, Int32)

Declaration
public CreatePartRequestDetailResult CreatePartRequestDetail(string partRequestHeaderIDNum, string serialNumber, int sitePartObjid)
Parameters
Type | Name | Description
System.String | partRequestHeaderIDNum |
System.String | serialNumber |
System.Int32 | sitePartObjid |
Returns
Type | Description
CreatePartRequestDetailResult |

CreatePartRequestDetail(String, String, String, String, Int32)

Declaration
public CreatePartRequestDetailResult CreatePartRequestDetail(string partRequestHeaderIDNum, string partNumber, string partDomain, string partRevision, int quantity)
Parameters
Type | Name | Description
System.String | partRequestHeaderIDNum |
System.String | partNumber |
System.String | partDomain |
System.String | partRevision |
System.Int32 | quantity |
Returns
Type | Description
CreatePartRequestDetailResult |

CreatePartRequestDetail(String, String, String, String, String)

Declaration
public CreatePartRequestDetailResult CreatePartRequestDetail(string partRequestHeaderIDNum, string partNumber, string partDomain, string partRevision, string serialNumber)
Parameters
Type | Name | Description
System.String | partRequestHeaderIDNum |
System.String | partNumber |
System.String | partDomain |
System.String | partRevision |
System.String | serialNumber |
Returns
Type | Description
CreatePartRequestDetailResult |

CreatePartRequestHeader(CreatePartRequestHeaderSetup)

Declaration
public ToolkitResult CreatePartRequestHeader(CreatePartRequestHeaderSetup setupParam)
Parameters
Type | Name | Description
CreatePartRequestHeaderSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreatePartRequestHeader(CreatePartRequestHeaderSetup, IDbTransaction)

Declaration
public ToolkitResult CreatePartRequestHeader(CreatePartRequestHeaderSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreatePartRequestHeaderSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreatePartRequestHeader(String, String, String, String)

Declaration
public ToolkitResult CreatePartRequestHeader(string contactFirstName, string contactLastName, string contactPhone, string shipToSiteIDNum)
Parameters
Type | Name | Description
System.String | contactFirstName |
System.String | contactLastName |
System.String | contactPhone |
System.String | shipToSiteIDNum |
Returns
Type | Description
ToolkitResult |

CreatePartRequestHeaderCase(CreatePartRequestHeaderCaseSetup)

Declaration
public ToolkitResult CreatePartRequestHeaderCase(CreatePartRequestHeaderCaseSetup setupParam)
Parameters
Type | Name | Description
CreatePartRequestHeaderCaseSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreatePartRequestHeaderCase(CreatePartRequestHeaderCaseSetup, IDbTransaction)

Declaration
public ToolkitResult CreatePartRequestHeaderCase(CreatePartRequestHeaderCaseSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreatePartRequestHeaderCaseSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreatePartRequestHeaderCase(String, String, String, String, String)

Declaration
public ToolkitResult CreatePartRequestHeaderCase(string contactFirstName, string contactLastName, string contactPhone, string shipToSiteIDNum, string caseIDNum)
Parameters
Type | Name | Description
System.String | contactFirstName |
System.String | contactLastName |
System.String | contactPhone |
System.String | shipToSiteIDNum |
System.String | caseIDNum |
Returns
Type | Description
ToolkitResult |

CreatePartRequestHeaderSubcase(CreatePartRequestHeaderSubcaseSetup)

Declaration
public ToolkitResult CreatePartRequestHeaderSubcase(CreatePartRequestHeaderSubcaseSetup setupParam)
Parameters
Type | Name | Description
CreatePartRequestHeaderSubcaseSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreatePartRequestHeaderSubcase(CreatePartRequestHeaderSubcaseSetup, IDbTransaction)

Declaration
public ToolkitResult CreatePartRequestHeaderSubcase(CreatePartRequestHeaderSubcaseSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreatePartRequestHeaderSubcaseSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreatePartRequestHeaderSubcase(String, String, String, String, String)

Declaration
public ToolkitResult CreatePartRequestHeaderSubcase(string contactFirstName, string contactLastName, string contactPhone, string shipToSiteIDNum, string caseIDNum)
Parameters
Type | Name | Description
System.String | contactFirstName |
System.String | contactLastName |
System.String | contactPhone |
System.String | shipToSiteIDNum |
System.String | caseIDNum |
Returns
Type | Description
ToolkitResult |

CreateSubContainer(CreateSubContainerSetup)

Declaration
public ToolkitResult CreateSubContainer(CreateSubContainerSetup setupParam)
Parameters
Type | Name | Description
CreateSubContainerSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreateSubContainer(CreateSubContainerSetup, IDbTransaction)

Declaration
public ToolkitResult CreateSubContainer(CreateSubContainerSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateSubContainerSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreateSubContainer(String, String)

Declaration
public ToolkitResult CreateSubContainer(string containerName, string parentContainerName)
Parameters
Type | Name | Description
System.String | containerName |
System.String | parentContainerName |
Returns
Type | Description
ToolkitResult |

DeleteAlternatePart(DeleteAlternatePartSetup)

Declaration
public ToolkitResult DeleteAlternatePart(DeleteAlternatePartSetup setupParam)
Parameters
Type | Name | Description
DeleteAlternatePartSetup | setupParam |
Returns
Type | Description
ToolkitResult |

DeleteAlternatePart(DeleteAlternatePartSetup, IDbTransaction)

Declaration
public ToolkitResult DeleteAlternatePart(DeleteAlternatePartSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
DeleteAlternatePartSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

DeleteAlternatePart(String, String, String, String, String, String)

Declaration
public ToolkitResult DeleteAlternatePart(string partNumber, string partRevision, string partDomain, string alternatePartNumber, string alternatePartRevision, string alternatePartDomain)
Parameters
Type | Name | Description
System.String | partNumber |
System.String | partRevision |
System.String | partDomain |
System.String | alternatePartNumber |
System.String | alternatePartRevision |
System.String | alternatePartDomain |
Returns
Type | Description
ToolkitResult |

DeleteLocationServicingSite(DeleteLocationServicingSiteSetup)

Declaration
public ToolkitResult DeleteLocationServicingSite(DeleteLocationServicingSiteSetup setupParam)
Parameters
Type | Name | Description
DeleteLocationServicingSiteSetup | setupParam |
Returns
Type | Description
ToolkitResult |

DeleteLocationServicingSite(DeleteLocationServicingSiteSetup, IDbTransaction)

Declaration
public ToolkitResult DeleteLocationServicingSite(DeleteLocationServicingSiteSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
DeleteLocationServicingSiteSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

DeleteLocationServicingSite(String, String)

Declaration
public ToolkitResult DeleteLocationServicingSite(string siteIDNum, string locationName)
Parameters
Type | Name | Description
System.String | siteIDNum |
System.String | locationName |
Returns
Type | Description
ToolkitResult |

DispatchPartRequest(DispatchPartRequestSetup)

Declaration
public ToolkitResult DispatchPartRequest(DispatchPartRequestSetup setupParam)
Parameters
Type | Name | Description
DispatchPartRequestSetup | setupParam |
Returns
Type | Description
ToolkitResult |

DispatchPartRequest(DispatchPartRequestSetup, IDbTransaction)

Declaration
public ToolkitResult DispatchPartRequest(DispatchPartRequestSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
DispatchPartRequestSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

DispatchPartRequest(String, String)

Declaration
public ToolkitResult DispatchPartRequest(string partRequestDetailIDNum, string queue)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String | queue |
Returns
Type | Description
ToolkitResult |

ForwardPartRequest(ForwardPartRequestSetup)

Declaration
public ToolkitResult ForwardPartRequest(ForwardPartRequestSetup setupParam)
Parameters
Type | Name | Description
ForwardPartRequestSetup | setupParam |
Returns
Type | Description
ToolkitResult |

ForwardPartRequest(ForwardPartRequestSetup, IDbTransaction)

Declaration
public ToolkitResult ForwardPartRequest(ForwardPartRequestSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
ForwardPartRequestSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

ForwardPartRequest(String, String)

Declaration
public ToolkitResult ForwardPartRequest(string partRequestDetailIDNum, string newQueue)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String | newQueue |
Returns
Type | Description
ToolkitResult |

FulfillPartRequest(FulfillPartRequestSetup)

Declaration
public ToolkitResult FulfillPartRequest(FulfillPartRequestSetup setupParam)
Parameters
Type | Name | Description
FulfillPartRequestSetup | setupParam |
Returns
Type | Description
ToolkitResult |

FulfillPartRequest(FulfillPartRequestSetup, IDbTransaction)

Declaration
public ToolkitResult FulfillPartRequest(FulfillPartRequestSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
FulfillPartRequestSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

FulfillPartRequest(String, Boolean, Int32)

Declaration
public ToolkitResult FulfillPartRequest(string partRequestDetailIDNum, bool useTransitions, int quantity)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.Boolean | useTransitions |
System.Int32 | quantity |
Returns
Type | Description
ToolkitResult |

FulfillPartRequest(String, Boolean, String)

Declaration
public ToolkitResult FulfillPartRequest(string partRequestDetailIDNum, bool useTransitions, string serialNumber)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.Boolean | useTransitions |
System.String | serialNumber |
Returns
Type | Description
ToolkitResult |

FulfillPartRequest(String, Int32)

Declaration
public ToolkitResult FulfillPartRequest(string partRequestDetailIDNum, int quantity)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.Int32 | quantity |
Returns
Type | Description
ToolkitResult |

FulfillPartRequest(String, String)

Declaration
public ToolkitResult FulfillPartRequest(string partRequestDetailIDNum, string serialNumber)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String | serialNumber |
Returns
Type | Description
ToolkitResult |

GetAlternateParts(GetAlternatePartsSetup)

Declaration
public GetAlternatePartsResult GetAlternateParts(GetAlternatePartsSetup setupParam)
Parameters
Type | Name | Description
GetAlternatePartsSetup | setupParam |
Returns
Type | Description
GetAlternatePartsResult |

GetAlternateParts(GetAlternatePartsSetup, IDbTransaction)

Declaration
public GetAlternatePartsResult GetAlternateParts(GetAlternatePartsSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
GetAlternatePartsSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
GetAlternatePartsResult |

GetAlternateParts(String, String, String)

Declaration
public GetAlternatePartsResult GetAlternateParts(string partNumber, string partDomain, string partRevision)
Parameters
Type | Name | Description
System.String | partNumber |
System.String | partDomain |
System.String | partRevision |
Returns
Type | Description
GetAlternatePartsResult |

GetLocationsServicingSite(GetLocationsServicingSiteSetup)

Declaration
public GetLocationsServicingSiteResult GetLocationsServicingSite(GetLocationsServicingSiteSetup setupParam)
Parameters
Type | Name | Description
GetLocationsServicingSiteSetup | setupParam |
Returns
Type | Description
GetLocationsServicingSiteResult |

GetLocationsServicingSite(GetLocationsServicingSiteSetup, IDbTransaction)

Declaration
public GetLocationsServicingSiteResult GetLocationsServicingSite(GetLocationsServicingSiteSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
GetLocationsServicingSiteSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
GetLocationsServicingSiteResult |

GetLocationsServicingSite(String)

Declaration
public GetLocationsServicingSiteResult GetLocationsServicingSite(string siteIDNum)
Parameters
Type | Name | Description
System.String | siteIDNum |
Returns
Type | Description
GetLocationsServicingSiteResult |

MovePartRequest(MovePartRequestSetup)

Declaration
public ToolkitResult MovePartRequest(MovePartRequestSetup setupParam)
Parameters
Type | Name | Description
MovePartRequestSetup | setupParam |
Returns
Type | Description
ToolkitResult |

MovePartRequest(MovePartRequestSetup, IDbTransaction)

Declaration
public ToolkitResult MovePartRequest(MovePartRequestSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
MovePartRequestSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

MovePartRequest(String, String)

Declaration
public ToolkitResult MovePartRequest(string partRequestDetailIDNum, string newWipBin)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String | newWipBin |
Returns
Type | Description
ToolkitResult |

OpenContainer(OpenContainerSetup)

Declaration
public ToolkitResult OpenContainer(OpenContainerSetup setupParam)
Parameters
Type | Name | Description
OpenContainerSetup | setupParam |
Returns
Type | Description
ToolkitResult |

OpenContainer(OpenContainerSetup, IDbTransaction)

Declaration
public ToolkitResult OpenContainer(OpenContainerSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
OpenContainerSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

OpenContainer(String)

Declaration
public ToolkitResult OpenContainer(string containerName)
Parameters
Type | Name | Description
System.String | containerName |
Returns
Type | Description
ToolkitResult |

PartTransfer(PartTransferSetup)

Declaration
public PartTransferResult PartTransfer(PartTransferSetup setupParam)
Parameters
Type | Name | Description
PartTransferSetup | setupParam |
Returns
Type | Description
PartTransferResult |

PartTransfer(PartTransferSetup, IDbTransaction)

Declaration
public PartTransferResult PartTransfer(PartTransferSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
PartTransferSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
PartTransferResult |

PartTransfer(String, String, String, Int32, Location, Location)

Declaration
public PartTransferResult PartTransfer(string partNumber, string partRevision, string partDomain, int quantity, Location fromlocation, Location tolocation)
Parameters
Type | Name | Description
System.String | partNumber |
System.String | partRevision |
System.String | partDomain |
System.Int32 | quantity |
Location | fromlocation |
Location | tolocation |
Returns
Type | Description
PartTransferResult |

PartTransfer(String, String, String, String, Location, Location)

Declaration
public PartTransferResult PartTransfer(string partNumber, string partRevision, string partDomain, string serialNumber, Location fromlocation, Location tolocation)
Parameters
Type | Name | Description
System.String | partNumber |
System.String | partRevision |
System.String | partDomain |
System.String | serialNumber |
Location | fromlocation |
Location | tolocation |
Returns
Type | Description
PartTransferResult |

Pick(PickSetup)

Declaration
public PickResult Pick(PickSetup setupParam)
Parameters
Type | Name | Description
PickSetup | setupParam |
Returns
Type | Description
PickResult |

Pick(PickSetup, IDbTransaction)

Declaration
public PickResult Pick(PickSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
PickSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
PickResult |

Pick(String)

Declaration
public PickResult Pick(string partRequestDetailIDNum)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
Returns
Type | Description
PickResult |

Pick(String, Boolean)

Declaration
public PickResult Pick(string partRequestDetailIDNum, bool useTransitions)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.Boolean | useTransitions |
Returns
Type | Description
PickResult |

Pick(String, Boolean, String[])

Declaration
public PickResult Pick(string partRequestDetailIDNum, bool useTransitions, params string[] serialNumbers)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.Boolean | useTransitions |
System.String[] | serialNumbers |
Returns
Type | Description
PickResult |

Pick(String, String[])

Declaration
public PickResult Pick(string partRequestDetailIDNum, params string[] serialNumbers)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String[] | serialNumbers |
Returns
Type | Description
PickResult |

ReceivePartRequest(ReceivePartRequestSetup)

Declaration
public ToolkitResult ReceivePartRequest(ReceivePartRequestSetup setupParam)
Parameters
Type | Name | Description
ReceivePartRequestSetup | setupParam |
Returns
Type | Description
ToolkitResult |

ReceivePartRequest(ReceivePartRequestSetup, IDbTransaction)

Declaration
public ToolkitResult ReceivePartRequest(ReceivePartRequestSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
ReceivePartRequestSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

ReceivePartRequest(String, Int32, Location)

Declaration
public ToolkitResult ReceivePartRequest(string partRequestDetailIDNum, int quantity, Location toLocation)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.Int32 | quantity |
Location | toLocation |
Returns
Type | Description
ToolkitResult |

ReceivePartRequest(String, Int32, Location, Boolean)

Declaration
public ToolkitResult ReceivePartRequest(string partRequestDetailIDNum, int quantity, Location toLocation, bool useTransitions)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.Int32 | quantity |
Location | toLocation |
System.Boolean | useTransitions |
Returns
Type | Description
ToolkitResult |

ReceivePartRequest(String, String, Location)

Declaration
public ToolkitResult ReceivePartRequest(string partRequestDetailIDNum, string serialNumber, Location toLocation)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String | serialNumber |
Location | toLocation |
Returns
Type | Description
ToolkitResult |

ReceivePartRequest(String, String, Location, Boolean)

Declaration
public ToolkitResult ReceivePartRequest(string partRequestDetailIDNum, string serialNumber, Location toLocation, bool useTransitions)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String | serialNumber |
Location | toLocation |
System.Boolean | useTransitions |
Returns
Type | Description
ToolkitResult |

RejectPartRequest(RejectPartRequestSetup)

Declaration
public ToolkitResult RejectPartRequest(RejectPartRequestSetup setupParam)
Parameters
Type | Name | Description
RejectPartRequestSetup | setupParam |
Returns
Type | Description
ToolkitResult |

RejectPartRequest(RejectPartRequestSetup, IDbTransaction)

Declaration
public ToolkitResult RejectPartRequest(RejectPartRequestSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
RejectPartRequestSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

RejectPartRequest(String)

Declaration
public ToolkitResult RejectPartRequest(string partRequestDetailIDNum)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
Returns
Type | Description
ToolkitResult |

ReopenPartRequest(ReopenPartRequestSetup)

Declaration
public ToolkitResult ReopenPartRequest(ReopenPartRequestSetup setupParam)
Parameters
Type | Name | Description
ReopenPartRequestSetup | setupParam |
Returns
Type | Description
ToolkitResult |

ReopenPartRequest(ReopenPartRequestSetup, IDbTransaction)

Declaration
public ToolkitResult ReopenPartRequest(ReopenPartRequestSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
ReopenPartRequestSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

ReopenPartRequest(String)

Declaration
public ToolkitResult ReopenPartRequest(string partRequestDetailIDNum)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
Returns
Type | Description
ToolkitResult |

SealContainer(SealContainerSetup)

Declaration
public ToolkitResult SealContainer(SealContainerSetup setupParam)
Parameters
Type | Name | Description
SealContainerSetup | setupParam |
Returns
Type | Description
ToolkitResult |

SealContainer(SealContainerSetup, IDbTransaction)

Declaration
public ToolkitResult SealContainer(SealContainerSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
SealContainerSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

SealContainer(String)

Declaration
public ToolkitResult SealContainer(string containerName)
Parameters
Type | Name | Description
System.String | containerName |
Returns
Type | Description
ToolkitResult |

SetLogisticsTransition(SetLogisticsTransitionSetup)

Declaration
public ToolkitResult SetLogisticsTransition(SetLogisticsTransitionSetup setupParam)
Parameters
Type | Name | Description
SetLogisticsTransitionSetup | setupParam |
Returns
Type | Description
ToolkitResult |

SetLogisticsTransition(SetLogisticsTransitionSetup, IDbTransaction)

Declaration
public ToolkitResult SetLogisticsTransition(SetLogisticsTransitionSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
SetLogisticsTransitionSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

SetLogisticsTransition(PartRequestType, PartRequestCondition, PartRequestCondition, String[])

Declaration
public ToolkitResult SetLogisticsTransition(PartRequestType partRequestType, PartRequestCondition startCondition, PartRequestCondition endCondition, params string[] privilegeClasses)
Parameters
Type | Name | Description
PartRequestType | partRequestType |
PartRequestCondition | startCondition |
PartRequestCondition | endCondition |
System.String[] | privilegeClasses |
Returns
Type | Description
ToolkitResult |

SetPartStockingLevel(Location, String, String, String, String, Int16, Int16, Int16, Int16)

Declaration
public ToolkitResult SetPartStockingLevel(Location location, string queue, string partNumber, string partRevision, string partDomain, short partMinimum, short partMaximum, short partReorderLevel, short partReorderQuantity)
Parameters
Type | Name | Description
Location | location |
System.String | queue |
System.String | partNumber |
System.String | partRevision |
System.String | partDomain |
System.Int16 | partMinimum |
System.Int16 | partMaximum |
System.Int16 | partReorderLevel |
System.Int16 | partReorderQuantity |
Returns
Type | Description
ToolkitResult |

SetPartStockingLevel(SetPartStockingLevelSetup)

Declaration
public ToolkitResult SetPartStockingLevel(SetPartStockingLevelSetup setupParam)
Parameters
Type | Name | Description
SetPartStockingLevelSetup | setupParam |
Returns
Type | Description
ToolkitResult |

SetPartStockingLevel(SetPartStockingLevelSetup, IDbTransaction)

Declaration
public ToolkitResult SetPartStockingLevel(SetPartStockingLevelSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
SetPartStockingLevelSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

Ship(ShipSetup)

Declaration
public ToolkitResult Ship(ShipSetup setupParam)
Parameters
Type | Name | Description
ShipSetup | setupParam |
Returns
Type | Description
ToolkitResult |

Ship(ShipSetup, IDbTransaction)

Declaration
public ToolkitResult Ship(ShipSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
ShipSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

Ship(String)

Declaration
public ToolkitResult Ship(string partRequestDetailIDNum)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
Returns
Type | Description
ToolkitResult |

Unpick(UnpickSetup)

Declaration
public ToolkitResult Unpick(UnpickSetup setupParam)
Parameters
Type | Name | Description
UnpickSetup | setupParam |
Returns
Type | Description
ToolkitResult |

Unpick(UnpickSetup, IDbTransaction)

Declaration
public ToolkitResult Unpick(UnpickSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UnpickSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

Unpick(String, Location)

Declaration
public ToolkitResult Unpick(string partRequestDetailIDNum, Location location)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
Location | location |
Returns
Type | Description
ToolkitResult |

Unpick(String, Location, Boolean)

Declaration
public ToolkitResult Unpick(string partRequestDetailIDNum, Location location, bool useTransitions)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
Location | location |
System.Boolean | useTransitions |
Returns
Type | Description
ToolkitResult |

Unpick(String, Location, Boolean, String[])

Declaration
public ToolkitResult Unpick(string partRequestDetailIDNum, Location location, bool useTransitions, params string[] serialNumbers)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
Location | location |
System.Boolean | useTransitions |
System.String[] | serialNumbers |
Returns
Type | Description
ToolkitResult |

Unpick(String, Location, String[])

Declaration
public ToolkitResult Unpick(string partRequestDetailIDNum, Location location, params string[] serialNumbers)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
Location | location |
System.String[] | serialNumbers |
Returns
Type | Description
ToolkitResult |

UpdateGLAccount(UpdateGLAccountSetup)

Declaration
public ToolkitResult UpdateGLAccount(UpdateGLAccountSetup setupParam)
Parameters
Type | Name | Description
UpdateGLAccountSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdateGLAccount(UpdateGLAccountSetup, IDbTransaction)

Declaration
public ToolkitResult UpdateGLAccount(UpdateGLAccountSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdateGLAccountSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UpdateGLAccount(String, String)

Declaration
public ToolkitResult UpdateGLAccount(string currentName, string siteIDNum)
Parameters
Type | Name | Description
System.String | currentName |
System.String | siteIDNum |
Returns
Type | Description
ToolkitResult |

UpdateInventoryBin(Location, String)

Declaration
public ToolkitResult UpdateInventoryBin(Location currentLocation, string newBinName)
Parameters
Type | Name | Description
Location | currentLocation |
System.String | newBinName |
Returns
Type | Description
ToolkitResult |

UpdateInventoryBin(UpdateInventoryBinSetup)

Declaration
public ToolkitResult UpdateInventoryBin(UpdateInventoryBinSetup setupParam)
Parameters
Type | Name | Description
UpdateInventoryBinSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdateInventoryBin(UpdateInventoryBinSetup, IDbTransaction)

Declaration
public ToolkitResult UpdateInventoryBin(UpdateInventoryBinSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdateInventoryBinSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UpdateInventoryLocation(UpdateInventoryLocationSetup)

Declaration
public ToolkitResult UpdateInventoryLocation(UpdateInventoryLocationSetup setupParam)
Parameters
Type | Name | Description
UpdateInventoryLocationSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdateInventoryLocation(UpdateInventoryLocationSetup, IDbTransaction)

Declaration
public ToolkitResult UpdateInventoryLocation(UpdateInventoryLocationSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdateInventoryLocationSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UpdateLocationServicingSite(UpdateLocationServicingSiteSetup)

Declaration
public ToolkitResult UpdateLocationServicingSite(UpdateLocationServicingSiteSetup setupParam)
Parameters
Type | Name | Description
UpdateLocationServicingSiteSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdateLocationServicingSite(UpdateLocationServicingSiteSetup, IDbTransaction)

Declaration
public ToolkitResult UpdateLocationServicingSite(UpdateLocationServicingSiteSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdateLocationServicingSiteSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UpdateLocationServicingSite(String, String, Int16)

Declaration
public ToolkitResult UpdateLocationServicingSite(string siteIDNum, string locationName, short locationRank)
Parameters
Type | Name | Description
System.String | siteIDNum |
System.String | locationName |
System.Int16 | locationRank |
Returns
Type | Description
ToolkitResult |

UpdatePartRequestDetail(UpdatePartRequestDetailSetup)

Declaration
public ToolkitResult UpdatePartRequestDetail(UpdatePartRequestDetailSetup setupParam)
Parameters
Type | Name | Description
UpdatePartRequestDetailSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdatePartRequestDetail(UpdatePartRequestDetailSetup, IDbTransaction)

Declaration
public ToolkitResult UpdatePartRequestDetail(UpdatePartRequestDetailSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdatePartRequestDetailSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UpdatePartRequestHeader(UpdatePartRequestHeaderSetup)

Declaration
public ToolkitResult UpdatePartRequestHeader(UpdatePartRequestHeaderSetup setupParam)
Parameters
Type | Name | Description
UpdatePartRequestHeaderSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdatePartRequestHeader(UpdatePartRequestHeaderSetup, IDbTransaction)

Declaration
public ToolkitResult UpdatePartRequestHeader(UpdatePartRequestHeaderSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdatePartRequestHeaderSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UpdatePartStockingLevel(Location, String, String, String, String)

Declaration
public ToolkitResult UpdatePartStockingLevel(Location currentLocation, string queue, string partNumber, string partRevision, string partDomain)
Parameters
Type | Name | Description
Location | currentLocation |
System.String | queue |
System.String | partNumber |
System.String | partRevision |
System.String | partDomain |
Returns
Type | Description
ToolkitResult |

UpdatePartStockingLevel(UpdatePartStockingLevelSetup)

Declaration
public ToolkitResult UpdatePartStockingLevel(UpdatePartStockingLevelSetup setupParam)
Parameters
Type | Name | Description
UpdatePartStockingLevelSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdatePartStockingLevel(UpdatePartStockingLevelSetup, IDbTransaction)

Declaration
public ToolkitResult UpdatePartStockingLevel(UpdatePartStockingLevelSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdatePartStockingLevelSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

YankPartRequest(YankPartRequestSetup)

Declaration
public ToolkitResult YankPartRequest(YankPartRequestSetup setupParam)
Parameters
Type | Name | Description
YankPartRequestSetup | setupParam |
Returns
Type | Description
ToolkitResult |

YankPartRequest(YankPartRequestSetup, IDbTransaction)

Declaration
public ToolkitResult YankPartRequest(YankPartRequestSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
YankPartRequestSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

YankPartRequest(String)

Declaration
public ToolkitResult YankPartRequest(string partRequestDetailIDNum)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
Returns
Type | Description
ToolkitResult |


Class LogisticsToolkitBase | fcSDK Documentation

Class LogisticsToolkitBase

Inheritance
System.Object
ToolkitBase
LogisticsToolkitBase
LogisticsToolkit
Inherited Members
ToolkitBase.NOW_DATE
ToolkitBase.CompatSession
ToolkitBase.WithTransaction<T>(Func<IDbTransaction, T>)
ToolkitBase.FCApplication
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public abstract class LogisticsToolkitBase : ToolkitBase

Constructors

LogisticsToolkitBase(ClarifySession)

Declaration
public LogisticsToolkitBase(ClarifySession sess)
Parameters
Type | Name | Description
ClarifySession | sess |

LogisticsToolkitBase(IFCApplication, IFCSession)

Declaration
public LogisticsToolkitBase(IFCApplication app, IFCSession sess)
Parameters
Type | Name | Description
IFCApplication | app |
IFCSession | sess |

Fields

_toolkit

Declaration
protected FCCL _toolkit
Field Value
Type | Description
FCCL |

Properties

ImpersonatorUsername

Declaration
public string ImpersonatorUsername { get; set; }
Property Value
Type | Description
System.String |


Class MovePartRequestSetup | fcSDK Documentation

Class MovePartRequestSetup

Inheritance
System.Object
MovePartRequestSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class MovePartRequestSetup

Constructors

MovePartRequestSetup(String, String)

Declaration
[ConstructorIndex(0)]
public MovePartRequestSetup(string partRequestDetailIDNum, string newWipBin)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String | newWipBin |

Properties

NewWipBin

Declaration
[PropertyBitValue(2)]
public string NewWipBin { get; set; }
Property Value
Type | Description
System.String |

PartRequestDetailIDNum

Declaration
[PropertyBitValue(1)]
public string PartRequestDetailIDNum { get; set; }
Property Value
Type | Description
System.String |


Class OpenContainerSetup | fcSDK Documentation

Class OpenContainerSetup

Inheritance
System.Object
OpenContainerSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class OpenContainerSetup

Constructors

OpenContainerSetup(String)

Declaration
[ConstructorIndex(0)]
public OpenContainerSetup(string containerName)
Parameters
Type | Name | Description
System.String | containerName |

Properties

ContainerName

Declaration
[PropertyBitValue(1)]
public string ContainerName { get; set; }
Property Value
Type | Description
System.String |


Class PartTransferResult | fcSDK Documentation

Class PartTransferResult

Inheritance
System.Object
ToolkitResult
PartTransferResult
Inherited Members
ToolkitResult._ReturnCode
ToolkitResult._IDNum
ToolkitResult._Objid
ToolkitResult.ReturnCode
ToolkitResult.IDNum
ToolkitResult.Objid
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class PartTransferResult : ToolkitResult

Constructors

PartTransferResult()

Declaration
public PartTransferResult()

Properties

StandardCost

Declaration
public decimal StandardCost { get; set; }
Property Value
Type | Description
System.Decimal |

TransactionIDNum

Declaration
public string TransactionIDNum { get; set; }
Property Value
Type | Description
System.String |


Class PartTransferSetup | fcSDK Documentation

Class PartTransferSetup

Inheritance
System.Object
PartTransferSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class PartTransferSetup

Constructors

PartTransferSetup(String, String, String, Int32, Location, Location)

Declaration
[ConstructorIndex(0)]
public PartTransferSetup(string partNumber, string partRevision, string partDomain, int quantity, Location fromlocation, Location tolocation)
Parameters
Type | Name | Description
System.String | partNumber |
System.String | partRevision |
System.String | partDomain |
System.Int32 | quantity |
Location | fromlocation |
Location | tolocation |

PartTransferSetup(String, String, String, String, Location, Location)

Declaration
[ConstructorIndex(1)]
public PartTransferSetup(string partNumber, string partRevision, string partDomain, string serialNumber, Location fromlocation, Location tolocation)
Parameters
Type | Name | Description
System.String | partNumber |
System.String | partRevision |
System.String | partDomain |
System.String | serialNumber |
Location | fromlocation |
Location | tolocation |

Properties

FromGood

Declaration
[PropertyBitValue(256)]
public bool FromGood { get; set; }
Property Value
Type | Description
System.Boolean |

FromLocation

Declaration
[PropertyBitValue(16777216)]
public Location FromLocation { get; set; }
Property Value
Type | Description
Location |

GenerateTimeBombs

Declaration
[PropertyBitValue(131072)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

Notes

Declaration
[PropertyBitValue(65536)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

PartDomain

Declaration
[PropertyBitValue(4)]
public string PartDomain { get; set; }
Property Value
Type | Description
System.String |

PartNumber

Declaration
[PropertyBitValue(1)]
public string PartNumber { get; set; }
Property Value
Type | Description
System.String |

PartRevision

Declaration
[PropertyBitValue(2)]
public string PartRevision { get; set; }
Property Value
Type | Description
System.String |

Quantity

Declaration
[PropertyBitValue(8)]
public int Quantity { get; set; }
Property Value
Type | Description
System.Int32 |

ReferenceIDNum

Declaration
[PropertyBitValue(32768)]
public string ReferenceIDNum { get; set; }
Property Value
Type | Description
System.String |

SerialNumber

Declaration
[PropertyBitValue(16)]
public string SerialNumber { get; set; }
Property Value
Type | Description
System.String |

ToGood

Declaration
[PropertyBitValue(4096)]
public bool ToGood { get; set; }
Property Value
Type | Description
System.Boolean |

ToLocation

Declaration
[PropertyBitValue(8388608)]
public Location ToLocation { get; set; }
Property Value
Type | Description
Location |

TransferDate

Declaration
[PropertyBitValue(16384)]
public DateTime TransferDate { get; set; }
Property Value
Type | Description
System.DateTime |

UserName

Declaration
[PropertyBitValue(8192)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class PickResult | fcSDK Documentation

Class PickResult

Inheritance
System.Object
ToolkitResult
PickResult
Inherited Members
ToolkitResult._ReturnCode
ToolkitResult._IDNum
ToolkitResult._Objid
ToolkitResult.ReturnCode
ToolkitResult.IDNum
ToolkitResult.Objid
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class PickResult : ToolkitResult

Constructors

PickResult()

Declaration
public PickResult()

Properties

TotalPicked

Declaration
public int TotalPicked { get; set; }
Property Value
Type | Description
System.Int32 |


Class PickSetup | fcSDK Documentation

Class PickSetup

Inheritance
System.Object
PickSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class PickSetup

Constructors

PickSetup(String)

Declaration
[ConstructorIndex(0)]
public PickSetup(string partRequestDetailIDNum)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |

PickSetup(String, Boolean)

Declaration
[ConstructorIndex(2)]
public PickSetup(string partRequestDetailIDNum, bool useTransitions)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.Boolean | useTransitions |

PickSetup(String, Boolean, String[])

Declaration
[ConstructorIndex(3)]
public PickSetup(string partRequestDetailIDNum, bool useTransitions, params string[] serialNumbers)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.Boolean | useTransitions |
System.String[] | serialNumbers |

PickSetup(String, String[])

Declaration
[ConstructorIndex(1)]
public PickSetup(string partRequestDetailIDNum, params string[] serialNumbers)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String[] | serialNumbers |

Properties

GenerateTimeBombs

Declaration
[PropertyBitValue(256)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

Locations

Declaration
[PropertyBitValue(2)]
public LocationCollection Locations { get; }
Property Value
Type | Description
LocationCollection |

NewStatus

Declaration
[PropertyBitValue(32)]
public string NewStatus { get; set; }
Property Value
Type | Description
System.String |

PartRequestDetailIDNum

Declaration
[PropertyBitValue(1)]
public string PartRequestDetailIDNum { get; set; }
Property Value
Type | Description
System.String |

PickDate

Declaration
[PropertyBitValue(16)]
public DateTime PickDate { get; set; }
Property Value
Type | Description
System.DateTime |

SerialNumbers

Declaration
[PropertyBitValue(64)]
public string[] SerialNumbers { get; set; }
Property Value
Type | Description
System.String[] |

UseGood

Declaration
[PropertyBitValue(4)]
public bool UseGood { get; set; }
Property Value
Type | Description
System.Boolean |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

UseTransitions

Declaration
[PropertyBitValue(128)]
public bool UseTransitions { get; set; }
Property Value
Type | Description
System.Boolean |


Class ReceivePartRequestSetup | fcSDK Documentation

Class ReceivePartRequestSetup

Inheritance
System.Object
ReceivePartRequestSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ReceivePartRequestSetup

Constructors

ReceivePartRequestSetup(String, Int32, Location)

Declaration
[ConstructorIndex(0)]
public ReceivePartRequestSetup(string partRequestDetailIDNum, int quantity, Location toLocation)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.Int32 | quantity |
Location | toLocation |

ReceivePartRequestSetup(String, Int32, Location, Boolean)

Declaration
[ConstructorIndex(2)]
public ReceivePartRequestSetup(string partRequestDetailIDNum, int quantity, Location toLocation, bool useTransitions)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.Int32 | quantity |
Location | toLocation |
System.Boolean | useTransitions |

ReceivePartRequestSetup(String, String, Location)

Declaration
[ConstructorIndex(1)]
public ReceivePartRequestSetup(string partRequestDetailIDNum, string serialNumber, Location toLocation)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String | serialNumber |
Location | toLocation |

ReceivePartRequestSetup(String, String, Location, Boolean)

Declaration
[ConstructorIndex(3)]
public ReceivePartRequestSetup(string partRequestDetailIDNum, string serialNumber, Location toLocation, bool useTransitions)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
System.String | serialNumber |
Location | toLocation |
System.Boolean | useTransitions |

Properties

AutoClose

Declaration
[PropertyBitValue(524288)]
public bool AutoClose { get; set; }
Property Value
Type | Description
System.Boolean |

CarrierName

Declaration
[PropertyBitValue(4096)]
public string CarrierName { get; set; }
Property Value
Type | Description
System.String |

FromGood

Declaration
[PropertyBitValue(16)]
public bool FromGood { get; set; }
Property Value
Type | Description
System.Boolean |

FromLocation

Declaration
[PropertyBitValue(8388608)]
public Location FromLocation { get; set; }
Property Value
Type | Description
Location |

GenerateTimeBombs

Declaration
[PropertyBitValue(2097152)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

NotProperlyPacked

Declaration
[PropertyBitValue(32768)]
public bool NotProperlyPacked { get; set; }
Property Value
Type | Description
System.Boolean |

PartRequestDetailIDNum

Declaration
[PropertyBitValue(1)]
public string PartRequestDetailIDNum { get; set; }
Property Value
Type | Description
System.String |

PossibleDamage

Declaration
[PropertyBitValue(16384)]
public bool PossibleDamage { get; set; }
Property Value
Type | Description
System.Boolean |

Quantity

Declaration
[PropertyBitValue(512)]
public int Quantity { get; set; }
Property Value
Type | Description
System.Int32 |

ReceiveDate

Declaration
[PropertyBitValue(262144)]
public DateTime ReceiveDate { get; set; }
Property Value
Type | Description
System.DateTime |

RouteToTest

Declaration
[PropertyBitValue(65536)]
public bool RouteToTest { get; set; }
Property Value
Type | Description
System.Boolean |

SerialNumber

Declaration
[PropertyBitValue(1024)]
public string SerialNumber { get; set; }
Property Value
Type | Description
System.String |

Status

Declaration
[PropertyBitValue(2048)]
public string Status { get; set; }
Property Value
Type | Description
System.String |

ToGood

Declaration
[PropertyBitValue(256)]
public bool ToGood { get; set; }
Property Value
Type | Description
System.Boolean |

ToLocation

Declaration
[PropertyBitValue(4194304)]
public Location ToLocation { get; set; }
Property Value
Type | Description
Location |

UserName

Declaration
[PropertyBitValue(131072)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

UseTransitions

Declaration
[PropertyBitValue(1048576)]
public bool UseTransitions { get; set; }
Property Value
Type | Description
System.Boolean |

WaybillName

Declaration
[PropertyBitValue(8192)]
public string WaybillName { get; set; }
Property Value
Type | Description
System.String |


Class RejectPartRequestSetup | fcSDK Documentation

Class RejectPartRequestSetup

Inheritance
System.Object
RejectPartRequestSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class RejectPartRequestSetup

Constructors

RejectPartRequestSetup(String)

Declaration
[ConstructorIndex(0)]
public RejectPartRequestSetup(string partRequestDetailIDNum)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |

Properties

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

Notes

Declaration
[PropertyBitValue(8)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

PartRequestDetailIDNum

Declaration
[PropertyBitValue(1)]
public string PartRequestDetailIDNum { get; set; }
Property Value
Type | Description
System.String |

RejectDate

Declaration
[PropertyBitValue(2)]
public DateTime RejectDate { get; set; }
Property Value
Type | Description
System.DateTime |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(4)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |


Class ReopenPartRequestSetup | fcSDK Documentation

Class ReopenPartRequestSetup

Inheritance
System.Object
ReopenPartRequestSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ReopenPartRequestSetup

Constructors

ReopenPartRequestSetup(String)

Declaration
[ConstructorIndex(0)]
public ReopenPartRequestSetup(string partRequestDetailIDNum)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |

Properties

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

NewStatus

Declaration
[PropertyBitValue(2)]
public string NewStatus { get; set; }
Property Value
Type | Description
System.String |

PartRequestDetailIDNum

Declaration
[PropertyBitValue(1)]
public string PartRequestDetailIDNum { get; set; }
Property Value
Type | Description
System.String |

ReopenDate

Declaration
[PropertyBitValue(8)]
public DateTime ReopenDate { get; set; }
Property Value
Type | Description
System.DateTime |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(4)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |


Class SealContainerSetup | fcSDK Documentation

Class SealContainerSetup

Inheritance
System.Object
SealContainerSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class SealContainerSetup

Constructors

SealContainerSetup(String)

Declaration
[ConstructorIndex(0)]
public SealContainerSetup(string containerName)
Parameters
Type | Name | Description
System.String | containerName |

Properties

ContainerName

Declaration
[PropertyBitValue(1)]
public string ContainerName { get; set; }
Property Value
Type | Description
System.String |


Class SetLogisticsTransitionSetup | fcSDK Documentation

Class SetLogisticsTransitionSetup

Inheritance
System.Object
SetLogisticsTransitionSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class SetLogisticsTransitionSetup

Constructors

SetLogisticsTransitionSetup(PartRequestType, PartRequestCondition, PartRequestCondition, String[])

Declaration
[ConstructorIndex(0)]
public SetLogisticsTransitionSetup(PartRequestType partRequestType, PartRequestCondition startCondition, PartRequestCondition endCondition, params string[] privilegeClasses)
Parameters
Type | Name | Description
PartRequestType | partRequestType |
PartRequestCondition | startCondition |
PartRequestCondition | endCondition |
System.String[] | privilegeClasses |

Properties

EndCondition

Declaration
[PropertyBitValue(4)]
public PartRequestCondition EndCondition { get; set; }
Property Value
Type | Description
PartRequestCondition |

PartRequestType

Declaration
[PropertyBitValue(1)]
public PartRequestType PartRequestType { get; set; }
Property Value
Type | Description
PartRequestType |

PrivilegeClasses

Declaration
[PropertyBitValue(8)]
public string[] PrivilegeClasses { get; set; }
Property Value
Type | Description
System.String[] |

StartCondition

Declaration
[PropertyBitValue(2)]
public PartRequestCondition StartCondition { get; set; }
Property Value
Type | Description
PartRequestCondition |


Class SetPartStockingLevelSetup | fcSDK Documentation

Class SetPartStockingLevelSetup

Inheritance
System.Object
SetPartStockingLevelSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class SetPartStockingLevelSetup

Constructors

SetPartStockingLevelSetup(Location, String, String, String, String, Int16, Int16, Int16, Int16)

Declaration
[ConstructorIndex(0)]
public SetPartStockingLevelSetup(Location location, string queue, string partNumber, string partRevision, string partDomain, short partMinimum, short partMaximum, short partReorderLevel, short partReorderQuantity)
Parameters
Type | Name | Description
Location | location |
System.String | queue |
System.String | partNumber |
System.String | partRevision |
System.String | partDomain |
System.Int16 | partMinimum |
System.Int16 | partMaximum |
System.Int16 | partReorderLevel |
System.Int16 | partReorderQuantity |

Properties

IsActive

Declaration
[PropertyBitValue(1024)]
public bool IsActive { get; set; }
Property Value
Type | Description
System.Boolean |

Location

Declaration
[PropertyBitValue(2048)]
public Location Location { get; set; }
Property Value
Type | Description
Location |

PartDomain

Declaration
[PropertyBitValue(32)]
public string PartDomain { get; set; }
Property Value
Type | Description
System.String |

PartMaximum

Declaration
[PropertyBitValue(128)]
public short PartMaximum { get; set; }
Property Value
Type | Description
System.Int16 |

PartMinimum

Declaration
[PropertyBitValue(64)]
public short PartMinimum { get; set; }
Property Value
Type | Description
System.Int16 |

PartNumber

Declaration
[PropertyBitValue(8)]
public string PartNumber { get; set; }
Property Value
Type | Description
System.String |

PartReorderLevel

Declaration
[PropertyBitValue(256)]
public short PartReorderLevel { get; set; }
Property Value
Type | Description
System.Int16 |

PartReorderQuantity

Declaration
[PropertyBitValue(512)]
public short PartReorderQuantity { get; set; }
Property Value
Type | Description
System.Int16 |

PartRevision

Declaration
[PropertyBitValue(16)]
public string PartRevision { get; set; }
Property Value
Type | Description
System.String |

Queue

Declaration
[PropertyBitValue(4)]
public string Queue { get; set; }
Property Value
Type | Description
System.String |


Class ShipSetup | fcSDK Documentation

Class ShipSetup

Inheritance
System.Object
ShipSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ShipSetup

Constructors

ShipSetup(String)

Declaration
[ConstructorIndex(0)]
public ShipSetup(string partRequestDetailIDNum)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |

Properties

Address1

Declaration
[PropertyBitValue(4)]
public string Address1 { get; set; }
Property Value
Type | Description
System.String |

Address2

Declaration
[PropertyBitValue(8)]
public string Address2 { get; set; }
Property Value
Type | Description
System.String |

CarrierName

Declaration
[PropertyBitValue(131072)]
public string CarrierName { get; set; }
Property Value
Type | Description
System.String |

City

Declaration
[PropertyBitValue(16)]
public string City { get; set; }
Property Value
Type | Description
System.String |

ContactFirstName

Declaration
[PropertyBitValue(256)]
public string ContactFirstName { get; set; }
Property Value
Type | Description
System.String |

ContactLastName

Declaration
[PropertyBitValue(512)]
public string ContactLastName { get; set; }
Property Value
Type | Description
System.String |

Country

Declaration
[PropertyBitValue(128)]
public string Country { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(262144)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

PackingList

Declaration
[PropertyBitValue(2048)]
public string PackingList { get; set; }
Property Value
Type | Description
System.String |

PartRequestDetailIDNum

Declaration
[PropertyBitValue(1)]
public string PartRequestDetailIDNum { get; set; }
Property Value
Type | Description
System.String |

PieceCount

Declaration
[PropertyBitValue(4096)]
public int PieceCount { get; set; }
Property Value
Type | Description
System.Int32 |

ShipDate

Declaration
[PropertyBitValue(32768)]
public DateTime ShipDate { get; set; }
Property Value
Type | Description
System.DateTime |

SiteName

Declaration
[PropertyBitValue(2)]
public string SiteName { get; set; }
Property Value
Type | Description
System.String |

State

Declaration
[PropertyBitValue(32)]
public string State { get; set; }
Property Value
Type | Description
System.String |

Status

Declaration
[PropertyBitValue(16384)]
public string Status { get; set; }
Property Value
Type | Description
System.String |

TotalWeight

Declaration
[PropertyBitValue(8192)]
public double TotalWeight { get; set; }
Property Value
Type | Description
System.Double |

UserName

Declaration
[PropertyBitValue(65536)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WaybillName

Declaration
[PropertyBitValue(1024)]
public string WaybillName { get; set; }
Property Value
Type | Description
System.String |

ZipCode

Declaration
[PropertyBitValue(64)]
public string ZipCode { get; set; }
Property Value
Type | Description
System.String |


Class UnpickSetup | fcSDK Documentation

Class UnpickSetup

Inheritance
System.Object
UnpickSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UnpickSetup

Constructors

UnpickSetup(String, Location)

Declaration
[ConstructorIndex(0)]
public UnpickSetup(string partRequestDetailIDNum, Location location)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
Location | location |

UnpickSetup(String, Location, Boolean)

Declaration
[ConstructorIndex(2)]
public UnpickSetup(string partRequestDetailIDNum, Location location, bool useTransitions)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
Location | location |
System.Boolean | useTransitions |

UnpickSetup(String, Location, Boolean, String[])

Declaration
[ConstructorIndex(3)]
public UnpickSetup(string partRequestDetailIDNum, Location location, bool useTransitions, params string[] serialNumbers)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
Location | location |
System.Boolean | useTransitions |
System.String[] | serialNumbers |

UnpickSetup(String, Location, String[])

Declaration
[ConstructorIndex(1)]
public UnpickSetup(string partRequestDetailIDNum, Location location, params string[] serialNumbers)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |
Location | location |
System.String[] | serialNumbers |

Properties

GenerateTimeBombs

Declaration
[PropertyBitValue(512)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

Location

Declaration
[PropertyBitValue(1024)]
public Location Location { get; set; }
Property Value
Type | Description
Location |

PartRequestDetailIDNum

Declaration
[PropertyBitValue(1)]
public string PartRequestDetailIDNum { get; set; }
Property Value
Type | Description
System.String |

SerialNumbers

Declaration
[PropertyBitValue(128)]
public string[] SerialNumbers { get; set; }
Property Value
Type | Description
System.String[] |

UnpickDate

Declaration
[PropertyBitValue(64)]
public DateTime UnpickDate { get; set; }
Property Value
Type | Description
System.DateTime |

UseGood

Declaration
[PropertyBitValue(16)]
public bool UseGood { get; set; }
Property Value
Type | Description
System.Boolean |

UserName

Declaration
[PropertyBitValue(32)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

UseTransitions

Declaration
[PropertyBitValue(256)]
public bool UseTransitions { get; set; }
Property Value
Type | Description
System.Boolean |


Class UpdateGLAccountSetup | fcSDK Documentation

Class UpdateGLAccountSetup

Inheritance
System.Object
UpdateGLAccountSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdateGLAccountSetup

Constructors

UpdateGLAccountSetup(String, String)

Declaration
[ConstructorIndex(0)]
public UpdateGLAccountSetup(string currentName, string siteIDNum)
Parameters
Type | Name | Description
System.String | currentName |
System.String | siteIDNum |

Properties

AccountNumber

Declaration
[PropertyBitValue(16)]
public string AccountNumber { get; set; }
Property Value
Type | Description
System.String |

AccountType

Declaration
[PropertyBitValue(4)]
public string AccountType { get; set; }
Property Value
Type | Description
System.String |

CurrentName

Declaration
[PropertyBitValue(1)]
public string CurrentName { get; set; }
Property Value
Type | Description
System.String |

Description

Declaration
[PropertyBitValue(8)]
public string Description { get; set; }
Property Value
Type | Description
System.String |

IsActive

Declaration
[PropertyBitValue(64)]
public bool IsActive { get; set; }
Property Value
Type | Description
System.Boolean |

IsCompany

Declaration
[PropertyBitValue(128)]
public bool IsCompany { get; set; }
Property Value
Type | Description
System.Boolean |

IsExpenseGLAccount

Declaration
[PropertyBitValue(32)]
public bool IsExpenseGLAccount { get; set; }
Property Value
Type | Description
System.Boolean |

NewName

Declaration
[PropertyBitValue(2)]
public string NewName { get; set; }
Property Value
Type | Description
System.String |

SiteIDNum

Declaration
[PropertyBitValue(256)]
public string SiteIDNum { get; set; }
Property Value
Type | Description
System.String |


Class UpdateInventoryBinSetup | fcSDK Documentation

Class UpdateInventoryBinSetup

Inheritance
System.Object
UpdateInventoryBinSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdateInventoryBinSetup

Constructors

UpdateInventoryBinSetup(Location, String)

Declaration
[ConstructorIndex(0)]
public UpdateInventoryBinSetup(Location currentLocation, string newBinName)
Parameters
Type | Name | Description
Location | currentLocation |
System.String | newBinName |

Properties

CurrentLocation

Declaration
[PropertyBitValue(16)]
public Location CurrentLocation { get; set; }
Property Value
Type | Description
Location |

IsActive

Declaration
[PropertyBitValue(8)]
public bool IsActive { get; set; }
Property Value
Type | Description
System.Boolean |

NewBinName

Declaration
[PropertyBitValue(2)]
public string NewBinName { get; set; }
Property Value
Type | Description
System.String |


Class UpdateInventoryLocationSetup | fcSDK Documentation

Class UpdateInventoryLocationSetup

Inheritance
System.Object
UpdateInventoryLocationSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdateInventoryLocationSetup

Constructors

UpdateInventoryLocationSetup(String)

Declaration
[ConstructorIndex(0)]
public UpdateInventoryLocationSetup(string currentName)
Parameters
Type | Name | Description
System.String | currentName |

Properties

AccountType

Declaration
[PropertyBitValue(4)]
public string AccountType { get; set; }
Property Value
Type | Description
System.String |

CapitalGLAccount

Declaration
[PropertyBitValue(32)]
public string CapitalGLAccount { get; set; }
Property Value
Type | Description
System.String |

CurrentName

Declaration
[PropertyBitValue(1)]
public string CurrentName { get; set; }
Property Value
Type | Description
System.String |

Description

Declaration
[PropertyBitValue(8)]
public string Description { get; set; }
Property Value
Type | Description
System.String |

IsActive

Declaration
[PropertyBitValue(64)]
public bool IsActive { get; set; }
Property Value
Type | Description
System.Boolean |

IsCompany

Declaration
[PropertyBitValue(128)]
public bool IsCompany { get; set; }
Property Value
Type | Description
System.Boolean |

NewName

Declaration
[PropertyBitValue(2)]
public string NewName { get; set; }
Property Value
Type | Description
System.String |

PartAuthorizationLevel

Declaration
[PropertyBitValue(512)]
public PartAuthorizationLevel PartAuthorizationLevel { get; set; }
Property Value
Type | Description
PartAuthorizationLevel |

ReportsToLocation

Declaration
[PropertyBitValue(16)]
public string ReportsToLocation { get; set; }
Property Value
Type | Description
System.String |

SiteIDNum

Declaration
[PropertyBitValue(256)]
public string SiteIDNum { get; set; }
Property Value
Type | Description
System.String |


Class UpdateLocationServicingSiteSetup | fcSDK Documentation

Class UpdateLocationServicingSiteSetup

Inheritance
System.Object
UpdateLocationServicingSiteSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdateLocationServicingSiteSetup

Constructors

UpdateLocationServicingSiteSetup(String, String, Int16)

Declaration
[ConstructorIndex(0)]
public UpdateLocationServicingSiteSetup(string siteIDNum, string locationName, short locationRank)
Parameters
Type | Name | Description
System.String | siteIDNum |
System.String | locationName |
System.Int16 | locationRank |

Properties

LocationName

Declaration
[PropertyBitValue(2)]
public string LocationName { get; set; }
Property Value
Type | Description
System.String |

LocationRank

Declaration
[PropertyBitValue(4)]
public short LocationRank { get; set; }
Property Value
Type | Description
System.Int16 |

SiteIDNum

Declaration
[PropertyBitValue(1)]
public string SiteIDNum { get; set; }
Property Value
Type | Description
System.String |


Class UpdatePartRequestDetailSetup | fcSDK Documentation

Class UpdatePartRequestDetailSetup

Inheritance
System.Object
UpdatePartRequestDetailSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdatePartRequestDetailSetup

Constructors

UpdatePartRequestDetailSetup(String)

Declaration
[ConstructorIndex(0)]
public UpdatePartRequestDetailSetup(string partRequestDetailIDNum)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |

Properties

AdditionalFields

Declaration
[PropertyBitValue(16384)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

CarrierName

Declaration
[PropertyBitValue(1024)]
public string CarrierName { get; set; }
Property Value
Type | Description
System.String |

DetailType

Declaration
[PropertyBitValue(128)]
public string DetailType { get; set; }
Property Value
Type | Description
System.String |

HasWarranty

Declaration
[PropertyBitValue(2048)]
public bool HasWarranty { get; set; }
Property Value
Type | Description
System.Boolean |

Notes

Declaration
[PropertyBitValue(4096)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

PartDomain

Declaration
[PropertyBitValue(4)]
public string PartDomain { get; set; }
Property Value
Type | Description
System.String |

PartNumber

Declaration
[PropertyBitValue(2)]
public string PartNumber { get; set; }
Property Value
Type | Description
System.String |

PartRequestDetailIDNum

Declaration
[PropertyBitValue(1)]
public string PartRequestDetailIDNum { get; set; }
Property Value
Type | Description
System.String |

PartRevision

Declaration
[PropertyBitValue(8)]
public string PartRevision { get; set; }
Property Value
Type | Description
System.String |

Priority

Declaration
[PropertyBitValue(256)]
public string Priority { get; set; }
Property Value
Type | Description
System.String |

Quantity

Declaration
[PropertyBitValue(32)]
public int Quantity { get; set; }
Property Value
Type | Description
System.Int32 |

SerialNumber

Declaration
[PropertyBitValue(16)]
public string SerialNumber { get; set; }
Property Value
Type | Description
System.String |

ShippingMethod

Declaration
[PropertyBitValue(512)]
public string ShippingMethod { get; set; }
Property Value
Type | Description
System.String |

SitePartObjid

Declaration
[PropertyBitValue(64)]
public int SitePartObjid { get; set; }
Property Value
Type | Description
System.Int32 |

Status

Declaration
[PropertyBitValue(8192)]
public string Status { get; set; }
Property Value
Type | Description
System.String |


Class UpdatePartRequestHeaderSetup | fcSDK Documentation

Class UpdatePartRequestHeaderSetup

Inheritance
System.Object
UpdatePartRequestHeaderSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdatePartRequestHeaderSetup

Constructors

UpdatePartRequestHeaderSetup(String)

Declaration
[ConstructorIndex(0)]
public UpdatePartRequestHeaderSetup(string partRequestHeaderIDNum)
Parameters
Type | Name | Description
System.String | partRequestHeaderIDNum |

Properties

AdditionalFields

Declaration
[PropertyBitValue(2048)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

BillSiteIDNum

Declaration
[PropertyBitValue(32)]
public string BillSiteIDNum { get; set; }
Property Value
Type | Description
System.String |

CaseIDNum

Declaration
[PropertyBitValue(64)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

ContactFirstName

Declaration
[PropertyBitValue(2)]
public string ContactFirstName { get; set; }
Property Value
Type | Description
System.String |

ContactLastName

Declaration
[PropertyBitValue(4)]
public string ContactLastName { get; set; }
Property Value
Type | Description
System.String |

ContactPhone

Declaration
[PropertyBitValue(8)]
public string ContactPhone { get; set; }
Property Value
Type | Description
System.String |

Notes

Declaration
[PropertyBitValue(1024)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

PartRequestHeaderIDNum

Declaration
[PropertyBitValue(1)]
public string PartRequestHeaderIDNum { get; set; }
Property Value
Type | Description
System.String |

PaymentMethod

Declaration
[PropertyBitValue(128)]
public string PaymentMethod { get; set; }
Property Value
Type | Description
System.String |

PaymentTerms

Declaration
[PropertyBitValue(256)]
public string PaymentTerms { get; set; }
Property Value
Type | Description
System.String |

Priority

Declaration
[PropertyBitValue(512)]
public string Priority { get; set; }
Property Value
Type | Description
System.String |

ShipToSiteIDNum

Declaration
[PropertyBitValue(16)]
public string ShipToSiteIDNum { get; set; }
Property Value
Type | Description
System.String |


Class UpdatePartStockingLevelSetup | fcSDK Documentation

Class UpdatePartStockingLevelSetup

Inheritance
System.Object
UpdatePartStockingLevelSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdatePartStockingLevelSetup

Constructors

UpdatePartStockingLevelSetup(Location, String, String, String, String)

Declaration
[ConstructorIndex(0)]
public UpdatePartStockingLevelSetup(Location currentLocation, string queue, string partNumber, string partRevision, string partDomain)
Parameters
Type | Name | Description
Location | currentLocation |
System.String | queue |
System.String | partNumber |
System.String | partRevision |
System.String | partDomain |

Properties

CurrentLocation

Declaration
[PropertyBitValue(8192)]
public Location CurrentLocation { get; set; }
Property Value
Type | Description
Location |

IsActive

Declaration
[PropertyBitValue(4096)]
public bool IsActive { get; set; }
Property Value
Type | Description
System.Boolean |

PartDomain

Declaration
[PropertyBitValue(128)]
public string PartDomain { get; set; }
Property Value
Type | Description
System.String |

PartMaximum

Declaration
[PropertyBitValue(512)]
public short PartMaximum { get; set; }
Property Value
Type | Description
System.Int16 |

PartMinimum

Declaration
[PropertyBitValue(256)]
public short PartMinimum { get; set; }
Property Value
Type | Description
System.Int16 |

PartNumber

Declaration
[PropertyBitValue(32)]
public string PartNumber { get; set; }
Property Value
Type | Description
System.String |

PartReorderLevel

Declaration
[PropertyBitValue(1024)]
public short PartReorderLevel { get; set; }
Property Value
Type | Description
System.Int16 |

PartReorderQuantity

Declaration
[PropertyBitValue(2048)]
public short PartReorderQuantity { get; set; }
Property Value
Type | Description
System.Int16 |

PartRevision

Declaration
[PropertyBitValue(64)]
public string PartRevision { get; set; }
Property Value
Type | Description
System.String |

Queue

Declaration
[PropertyBitValue(8)]
public string Queue { get; set; }
Property Value
Type | Description
System.String |

ToBinName

Declaration
[PropertyBitValue(2)]
public string ToBinName { get; set; }
Property Value
Type | Description
System.String |

ToQueue

Declaration
[PropertyBitValue(16)]
public string ToQueue { get; set; }
Property Value
Type | Description
System.String |


Class YankPartRequestSetup | fcSDK Documentation

Class YankPartRequestSetup

Inheritance
System.Object
YankPartRequestSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Logistics
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class YankPartRequestSetup

Constructors

YankPartRequestSetup(String)

Declaration
[ConstructorIndex(0)]
public YankPartRequestSetup(string partRequestDetailIDNum)
Parameters
Type | Name | Description
System.String | partRequestDetailIDNum |

Properties

GenerateTimeBombs

Declaration
[PropertyBitValue(16)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

PartRequestDetailIDNum

Declaration
[PropertyBitValue(1)]
public string PartRequestDetailIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(2)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |

YankDate

Declaration
[PropertyBitValue(4)]
public DateTime YankDate { get; set; }
Property Value
Type | Description
System.DateTime |


Enum OpportunityStage | fcSDK Documentation

Enum OpportunityStage

Namespace: FChoice.Toolkits.Clarify
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public enum OpportunityStage

Fields

Name | Description
Lead |
Lose |
Opportunity |
Win |


Enum PartAuthorizationLevel | fcSDK Documentation

Enum PartAuthorizationLevel

Namespace: FChoice.Toolkits.Clarify
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public enum PartAuthorizationLevel

Fields

Name | Description
All |
AuthorizedPartsOnly |
None |


Class PartInfo | fcSDK Documentation

Class PartInfo

Inheritance
System.Object
PartInfo
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class PartInfo

Constructors

PartInfo()

Declaration
public PartInfo()

Fields

modSetupResult

Declaration
public ToolkitResult modSetupResult
Field Value
Type | Description
ToolkitResult |

PartDomain

Declaration
public string PartDomain
Field Value
Type | Description
System.String |

PartNotes

Declaration
public string PartNotes
Field Value
Type | Description
System.String |

PartNumber

Declaration
public string PartNumber
Field Value
Type | Description
System.String |

PartRevision

Declaration
public string PartRevision
Field Value
Type | Description
System.String |

partSetupResult

Declaration
public ToolkitResult partSetupResult
Field Value
Type | Description
ToolkitResult |

Price

Declaration
public decimal Price
Field Value
Type | Description
System.Decimal |

PriceProgram

Declaration
public string PriceProgram
Field Value
Type | Description
System.String |

priceSetupResult

Declaration
public ToolkitResult priceSetupResult
Field Value
Type | Description
ToolkitResult |

PriceType

Declaration
public PriceInstanceType PriceType
Field Value
Type | Description
PriceInstanceType |

Quantity

Declaration
public int Quantity
Field Value
Type | Description
System.Int32 |

RepairType

Declaration
public PartRepairType RepairType
Field Value
Type | Description
PartRepairType |


Enum PartRepairType | fcSDK Documentation

Enum PartRepairType

Namespace: FChoice.Toolkits.Clarify
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public enum PartRepairType

Fields

Name | Description
Expendable |
Repairable |


Enum PartRequestCondition | fcSDK Documentation

Enum PartRequestCondition

Namespace: FChoice.Toolkits.Clarify
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public enum PartRequestCondition

Fields

Name | Description
Backordered |
Fulfilled |
InRepair |
PartUsed |
Picked |
Received |
RequestClosed |
RequestOpen |
RequestReopened |
Shipped |
Unpicked |
UpdateInventory |


Class PartRequestInfo | fcSDK Documentation

Class PartRequestInfo

Inheritance
System.Object
PartRequestInfo
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class PartRequestInfo

Constructors

PartRequestInfo()

Declaration
public PartRequestInfo()

Fields

ContactFirstName

Declaration
public string ContactFirstName
Field Value
Type | Description
System.String |

ContactLastName

Declaration
public string ContactLastName
Field Value
Type | Description
System.String |

ContactPhone

Declaration
public string ContactPhone
Field Value
Type | Description
System.String |

ContactResult

Declaration
public ToolkitResult ContactResult
Field Value
Type | Description
ToolkitResult |

PartDomain

Declaration
public string PartDomain
Field Value
Type | Description
System.String |

PartNumber

Declaration
public string PartNumber
Field Value
Type | Description
System.String |

PartQuantity

Declaration
public int PartQuantity
Field Value
Type | Description
System.Int32 |

PartRequestDetailResult

Declaration
public ToolkitResult PartRequestDetailResult
Field Value
Type | Description
ToolkitResult |

PartRequestHeaderResult

Declaration
public ToolkitResult PartRequestHeaderResult
Field Value
Type | Description
ToolkitResult |

PartRevision

Declaration
public string PartRevision
Field Value
Type | Description
System.String |

PartRevisionResult

Declaration
public ToolkitResult PartRevisionResult
Field Value
Type | Description
ToolkitResult |

SiteResult

Declaration
public ToolkitResult SiteResult
Field Value
Type | Description
ToolkitResult |


Enum PartRequestType | fcSDK Documentation

Enum PartRequestType

Namespace: FChoice.Toolkits.Clarify
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public enum PartRequestType

Fields

Name | Description
AdvanceExchange |
DepotRepair |
Order |
PleaseSpecify |
Replenishment |
ReturnForCredit |


Enum PartRevisionStatus | fcSDK Documentation

Enum PartRevisionStatus

Namespace: FChoice.Toolkits.Clarify
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public enum PartRevisionStatus

Fields

Name | Description
Active |
Inactive |
Obsolete |


Enum PriceInstanceType | fcSDK Documentation

Enum PriceInstanceType

Namespace: FChoice.Toolkits.Clarify
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public enum PriceInstanceType

Fields

Name | Description
Fixed |
PercentOfOptionList |
PercentOfProduct |


Class PropertyBitValueAttribute | fcSDK Documentation

Class PropertyBitValueAttribute

Inheritance
System.Object
System.Attribute
PropertyBitValueAttribute
Implements
System.Runtime.InteropServices._Attribute
Inherited Members
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Boolean)
System.Attribute.IsDefined(System.Reflection.MemberInfo, System.Type)
System.Attribute.IsDefined(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.MemberInfo, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Boolean)
System.Attribute.IsDefined(System.Reflection.ParameterInfo, System.Type)
System.Attribute.IsDefined(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.ParameterInfo, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.Module)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.IsDefined(System.Reflection.Module, System.Type)
System.Attribute.IsDefined(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.Module, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Boolean)
System.Attribute.IsDefined(System.Reflection.Assembly, System.Type)
System.Attribute.IsDefined(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.Assembly, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.Equals(System.Object)
System.Attribute.GetHashCode()
System.Attribute.Match(System.Object)
System.Attribute.IsDefaultAttribute()
System.Attribute.System.Runtime.InteropServices._Attribute.GetTypeInfoCount(System.UInt32)
System.Attribute.System.Runtime.InteropServices._Attribute.GetTypeInfo(System.UInt32, System.UInt32, System.IntPtr)
System.Attribute.System.Runtime.InteropServices._Attribute.GetIDsOfNames(System.Guid, System.IntPtr, System.UInt32, System.UInt32, System.IntPtr)
System.Attribute.System.Runtime.InteropServices._Attribute.Invoke(System.UInt32, System.Guid, System.UInt32, System.Int16, System.IntPtr, System.IntPtr, System.IntPtr, System.IntPtr)
System.Attribute.TypeId
System.Object.ToString()
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
[AttributeUsage(AttributeTargets.Property)]
public class PropertyBitValueAttribute : Attribute, _Attribute

Constructors

PropertyBitValueAttribute(Int32)

Declaration
public PropertyBitValueAttribute(int val)
Parameters
Type | Name | Description
System.Int32 | val |

Fields

Value

Declaration
public int Value
Field Value
Type | Description
System.Int32 |

Implements

System.Runtime.InteropServices._Attribute


Namespace FChoice.Toolkits.Clarify.Quality | fcSDK Documentation

Namespace FChoice.Toolkits.Clarify.Quality

Classes

AcceptCRSetup

AddModuleToCRSetup

AssignCRSetup

ChangeCRStatusSetup

CheckClearQualityTransitionSetup

CloseCRSetup

CreateCRSetup

DispatchCRSetup

DuplicateCRSetup

FixCRSetup

FixFailedSetup

ForwardCRSetup

LogCREmailSetup

LogCRNoteSetup

MoveCRSetup

QualityToolkit

QualityToolkit.LogCREmailInSetup

QualityToolkitBase

RejectCRSetup

ReopenCRSetup

ReplicateCRSetup

UpdateCRSetup

YankCRSetup

Back to top © 2022 Dovetail Software, Inc. - All rights reserved.
Clarify, Amdocs, and related products and names are copyright and trademark of Amdocs, Inc.
.NET, Visual Studio.NET, C#, Visual Basic and related products are trademark of Microsoft corporation.


Class AcceptCRSetup | fcSDK Documentation

Class AcceptCRSetup

Inheritance
System.Object
AcceptCRSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Quality
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class AcceptCRSetup

Constructors

AcceptCRSetup(String)

Declaration
[ConstructorIndex(0)]
public AcceptCRSetup(string cridnum)
Parameters
Type | Name | Description
System.String | cridnum |

Properties

AcceptDate

Declaration
[PropertyBitValue(2)]
public DateTime AcceptDate { get; set; }
Property Value
Type | Description
System.DateTime |

CRIDNum

Declaration
[PropertyBitValue(1)]
public string CRIDNum { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(16)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(4)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |


Class AddModuleToCRSetup | fcSDK Documentation

Class AddModuleToCRSetup

Inheritance
System.Object
AddModuleToCRSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Quality
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class AddModuleToCRSetup

Constructors

AddModuleToCRSetup(Int32, String)

Declaration
[ConstructorIndex(0)]
public AddModuleToCRSetup(int fixObjid, string fileName)
Parameters
Type | Name | Description
System.Int32 | fixObjid |
System.String | fileName |

Properties

FileName

Declaration
[PropertyBitValue(2)]
public string FileName { get; set; }
Property Value
Type | Description
System.String |

FileRevision

Declaration
[PropertyBitValue(4)]
public string FileRevision { get; set; }
Property Value
Type | Description
System.String |

FixObjid

Declaration
[PropertyBitValue(1)]
public int FixObjid { get; set; }
Property Value
Type | Description
System.Int32 |


Class AssignCRSetup | fcSDK Documentation

Class AssignCRSetup

Inheritance
System.Object
AssignCRSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Quality
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class AssignCRSetup

Constructors

AssignCRSetup(String)

Declaration
[ConstructorIndex(0)]
public AssignCRSetup(string cridnum)
Parameters
Type | Name | Description
System.String | cridnum |

Properties

AssignDate

Declaration
[PropertyBitValue(8)]
public DateTime AssignDate { get; set; }
Property Value
Type | Description
System.DateTime |

CRIDNum

Declaration
[PropertyBitValue(1)]
public string CRIDNum { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

NewUser

Declaration
[PropertyBitValue(2)]
public string NewUser { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(4)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |


Class ChangeCRStatusSetup | fcSDK Documentation

Class ChangeCRStatusSetup

Inheritance
System.Object
ChangeCRStatusSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Quality
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ChangeCRStatusSetup

Constructors

ChangeCRStatusSetup(String)

Declaration
[ConstructorIndex(0)]
public ChangeCRStatusSetup(string crIDNum)
Parameters
Type | Name | Description
System.String | crIDNum |

Properties

ChangeDate

Declaration
[PropertyBitValue(4)]
public DateTime ChangeDate { get; set; }
Property Value
Type | Description
System.DateTime |

CRIDNum

Declaration
[PropertyBitValue(1)]
public string CRIDNum { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

NewStatus

Declaration
[PropertyBitValue(2)]
public string NewStatus { get; set; }
Property Value
Type | Description
System.String |

Notes

Declaration
[PropertyBitValue(8)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class CheckClearQualityTransitionSetup | fcSDK Documentation

Class CheckClearQualityTransitionSetup

Inheritance
System.Object
CheckClearQualityTransitionSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Quality
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CheckClearQualityTransitionSetup

Constructors

CheckClearQualityTransitionSetup(String, String, String, String, String)

Declaration
[ConstructorIndex(0)]
public CheckClearQualityTransitionSetup(string oldCondition, string oldStatus, string newCondition, string newStatus, string userName)
Parameters
Type | Name | Description
System.String | oldCondition |
System.String | oldStatus |
System.String | newCondition |
System.String | newStatus |
System.String | userName |

Properties

NewCondition

Declaration
[PropertyBitValue(4)]
public string NewCondition { get; set; }
Property Value
Type | Description
System.String |

NewStatus

Declaration
[PropertyBitValue(8)]
public string NewStatus { get; set; }
Property Value
Type | Description
System.String |

OldCondition

Declaration
[PropertyBitValue(1)]
public string OldCondition { get; set; }
Property Value
Type | Description
System.String |

OldStatus

Declaration
[PropertyBitValue(2)]
public string OldStatus { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class CloseCRSetup | fcSDK Documentation

Class CloseCRSetup

Inheritance
System.Object
CloseCRSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Quality
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CloseCRSetup

Constructors

CloseCRSetup(String)

Declaration
[ConstructorIndex(0)]
public CloseCRSetup(string crIDNum)
Parameters
Type | Name | Description
System.String | crIDNum |

Properties

AdditionalFields

Declaration
[PropertyBitValue(256)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

CloseDate

Declaration
[PropertyBitValue(64)]
public DateTime CloseDate { get; set; }
Property Value
Type | Description
System.DateTime |

CRIDNum

Declaration
[PropertyBitValue(1)]
public string CRIDNum { get; set; }
Property Value
Type | Description
System.String |

FixedInRelease

Declaration
[PropertyBitValue(16)]
public string FixedInRelease { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(128)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

Notes

Declaration
[PropertyBitValue(4)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

Status

Declaration
[PropertyBitValue(2)]
public string Status { get; set; }
Property Value
Type | Description
System.String |

TestCase

Declaration
[PropertyBitValue(8)]
public string TestCase { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(32)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class CreateCRSetup | fcSDK Documentation

Class CreateCRSetup

Inheritance
System.Object
CreateCRSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Quality
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateCRSetup

Constructors

CreateCRSetup(String, String, String)

Declaration
[ConstructorIndex(0)]
public CreateCRSetup(string partNumber, string partRevision, string partDomain)
Parameters
Type | Name | Description
System.String | partNumber |
System.String | partRevision |
System.String | partDomain |

Properties

AdditionalFields

Declaration
[PropertyBitValue(2097152)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

CRClass

Declaration
[PropertyBitValue(4096)]
public string CRClass { get; set; }
Property Value
Type | Description
System.String |

CreateDate

Declaration
[PropertyBitValue(524288)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

CRType

Declaration
[PropertyBitValue(64)]
public string CRType { get; set; }
Property Value
Type | Description
System.String |

Description

Declaration
[PropertyBitValue(32)]
public string Description { get; set; }
Property Value
Type | Description
System.String |

FixedIn

Declaration
[PropertyBitValue(32768)]
public string FixedIn { get; set; }
Property Value
Type | Description
System.String |

FoundOnCPU

Declaration
[PropertyBitValue(512)]
public string FoundOnCPU { get; set; }
Property Value
Type | Description
System.String |

Frequency

Declaration
[PropertyBitValue(256)]
public string Frequency { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(1048576)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

IntroductionPhase

Declaration
[PropertyBitValue(8192)]
public string IntroductionPhase { get; set; }
Property Value
Type | Description
System.String |

Memory

Declaration
[PropertyBitValue(2048)]
public string Memory { get; set; }
Property Value
Type | Description
System.String |

OperatingSystem

Declaration
[PropertyBitValue(1024)]
public string OperatingSystem { get; set; }
Property Value
Type | Description
System.String |

PartDomain

Declaration
[PropertyBitValue(4)]
public string PartDomain { get; set; }
Property Value
Type | Description
System.String |

PartNumber

Declaration
[PropertyBitValue(1)]
public string PartNumber { get; set; }
Property Value
Type | Description
System.String |

PartRevision

Declaration
[PropertyBitValue(2)]
public string PartRevision { get; set; }
Property Value
Type | Description
System.String |

Priority

Declaration
[PropertyBitValue(128)]
public string Priority { get; set; }
Property Value
Type | Description
System.String |

Queue

Declaration
[PropertyBitValue(131072)]
public string Queue { get; set; }
Property Value
Type | Description
System.String |

Status

Declaration
[PropertyBitValue(16)]
public string Status { get; set; }
Property Value
Type | Description
System.String |

TestClass

Declaration
[PropertyBitValue(16384)]
public string TestClass { get; set; }
Property Value
Type | Description
System.String |

Title

Declaration
[PropertyBitValue(8)]
public string Title { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(262144)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

VerificationTest

Declaration
[PropertyBitValue(65536)]
public string VerificationTest { get; set; }
Property Value
Type | Description
System.String |


Class DispatchCRSetup | fcSDK Documentation

Class DispatchCRSetup

Inheritance
System.Object
DispatchCRSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Quality
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class DispatchCRSetup

Constructors

DispatchCRSetup(String, String)

Declaration
[ConstructorIndex(0)]
public DispatchCRSetup(string cridnum, string queue)
Parameters
Type | Name | Description
System.String | cridnum |
System.String | queue |

Properties

CRIDNum

Declaration
[PropertyBitValue(1)]
public string CRIDNum { get; set; }
Property Value
Type | Description
System.String |

DispatchDate

Declaration
[PropertyBitValue(4)]
public DateTime DispatchDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(16)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

Queue

Declaration
[PropertyBitValue(2)]
public string Queue { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class DuplicateCRSetup | fcSDK Documentation

Class DuplicateCRSetup

Inheritance
System.Object
DuplicateCRSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Quality
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class DuplicateCRSetup

Constructors

DuplicateCRSetup(String, String)

Declaration
[ConstructorIndex(0)]
public DuplicateCRSetup(string crIDNum, string masterCRIDNum)
Parameters
Type | Name | Description
System.String | crIDNum |
System.String | masterCRIDNum |

Properties

CloseDate

Declaration
[PropertyBitValue(16)]
public DateTime CloseDate { get; set; }
Property Value
Type | Description
System.DateTime |

CRIDNum

Declaration
[PropertyBitValue(1)]
public string CRIDNum { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

MasterCRIDNum

Declaration
[PropertyBitValue(4)]
public string MasterCRIDNum { get; set; }
Property Value
Type | Description
System.String |

Status

Declaration
[PropertyBitValue(2)]
public string Status { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class FixCRSetup | fcSDK Documentation

Class FixCRSetup

Inheritance
System.Object
FixCRSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Quality
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class FixCRSetup

Constructors

FixCRSetup(String)

Declaration
[ConstructorIndex(0)]
public FixCRSetup(string crIDNum)
Parameters
Type | Name | Description
System.String | crIDNum |

Properties

AdditionalFields

Declaration
[PropertyBitValue(64)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

CRIDNum

Declaration
[PropertyBitValue(1)]
public string CRIDNum { get; set; }
Property Value
Type | Description
System.String |

FixDate

Declaration
[PropertyBitValue(16)]
public DateTime FixDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

Notes

Declaration
[PropertyBitValue(4)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

Status

Declaration
[PropertyBitValue(2)]
public string Status { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class FixFailedSetup | fcSDK Documentation

Class FixFailedSetup

Inheritance
System.Object
FixFailedSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Quality
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class FixFailedSetup

Constructors

FixFailedSetup(String)

Declaration
[ConstructorIndex(0)]
public FixFailedSetup(string crIDNum)
Parameters
Type | Name | Description
System.String | crIDNum |

Properties

AdditionalFields

Declaration
[PropertyBitValue(256)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

CRIDNum

Declaration
[PropertyBitValue(1)]
public string CRIDNum { get; set; }
Property Value
Type | Description
System.String |

FailedDate

Declaration
[PropertyBitValue(64)]
public DateTime FailedDate { get; set; }
Property Value
Type | Description
System.DateTime |

FixedInRelease

Declaration
[PropertyBitValue(16)]
public string FixedInRelease { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(128)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

Notes

Declaration
[PropertyBitValue(4)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

Status

Declaration
[PropertyBitValue(2)]
public string Status { get; set; }
Property Value
Type | Description
System.String |

TestCase

Declaration
[PropertyBitValue(8)]
public string TestCase { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(32)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class ForwardCRSetup | fcSDK Documentation

Class ForwardCRSetup

Inheritance
System.Object
ForwardCRSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Quality
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ForwardCRSetup

Constructors

ForwardCRSetup(String, String)

Declaration
[ConstructorIndex(0)]
public ForwardCRSetup(string cridnum, string newQueue)
Parameters
Type | Name | Description
System.String | cridnum |
System.String | newQueue |

Properties

CRIDNum

Declaration
[PropertyBitValue(1)]
public string CRIDNum { get; set; }
Property Value
Type | Description
System.String |

ForwardDate

Declaration
[PropertyBitValue(4)]
public DateTime ForwardDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

NewQueue

Declaration
[PropertyBitValue(2)]
public string NewQueue { get; set; }
Property Value
Type | Description
System.String |

Notes

Declaration
[PropertyBitValue(8)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class LogCREmailSetup | fcSDK Documentation

Class LogCREmailSetup

Inheritance
System.Object
LogCREmailSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Quality
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LogCREmailSetup

Constructors

LogCREmailSetup(String)

Declaration
[ConstructorIndex(0)]
public LogCREmailSetup(string crIDNum)
Parameters
Type | Name | Description
System.String | crIDNum |

Properties

AdditionalFields

Declaration
[PropertyBitValue(256)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

CCList

Declaration
[PropertyBitValue(16)]
public string CCList { get; set; }
Property Value
Type | Description
System.String |

CRIDNum

Declaration
[PropertyBitValue(1)]
public string CRIDNum { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(64)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

LogDate

Declaration
[PropertyBitValue(2)]
public DateTime LogDate { get; set; }
Property Value
Type | Description
System.DateTime |

Message

Declaration
[PropertyBitValue(4)]
public string Message { get; set; }
Property Value
Type | Description
System.String |

Recipient

Declaration
[PropertyBitValue(8)]
public string Recipient { get; set; }
Property Value
Type | Description
System.String |

SendEmail

Declaration
[PropertyBitValue(128)]
public bool SendEmail { get; set; }
Property Value
Type | Description
System.Boolean |

UserName

Declaration
[PropertyBitValue(32)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class LogCRNoteSetup | fcSDK Documentation

Class LogCRNoteSetup

Inheritance
System.Object
LogCRNoteSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Quality
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LogCRNoteSetup

Constructors

LogCRNoteSetup(String)

Declaration
[ConstructorIndex(0)]
public LogCRNoteSetup(string crIDNum)
Parameters
Type | Name | Description
System.String | crIDNum |

Properties

AdditionalFields

Declaration
[PropertyBitValue(64)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

CRIDNum

Declaration
[PropertyBitValue(1)]
public string CRIDNum { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

InternalUseOnlyNotes

Declaration
[PropertyBitValue(4)]
public string InternalUseOnlyNotes { get; set; }
Property Value
Type | Description
System.String |

LogDate

Declaration
[PropertyBitValue(8)]
public DateTime LogDate { get; set; }
Property Value
Type | Description
System.DateTime |

Notes

Declaration
[PropertyBitValue(2)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class MoveCRSetup | fcSDK Documentation

Class MoveCRSetup

Inheritance
System.Object
MoveCRSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Quality
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class MoveCRSetup

Constructors

MoveCRSetup(String, String)

Declaration
[ConstructorIndex(0)]
public MoveCRSetup(string cridnum, string newWipBin)
Parameters
Type | Name | Description
System.String | cridnum |
System.String | newWipBin |

Properties

CRIDNum

Declaration
[PropertyBitValue(1)]
public string CRIDNum { get; set; }
Property Value
Type | Description
System.String |

NewWipBin

Declaration
[PropertyBitValue(2)]
public string NewWipBin { get; set; }
Property Value
Type | Description
System.String |


Class QualityToolkit | fcSDK Documentation

Class QualityToolkit

Inheritance
System.Object
ToolkitBase
QualityToolkitBase
QualityToolkit
Inherited Members
QualityToolkitBase._toolkit
QualityToolkitBase.ImpersonatorUsername
ToolkitBase.NOW_DATE
ToolkitBase.CompatSession
ToolkitBase.WithTransaction<T>(Func<IDbTransaction, T>)
ToolkitBase.FCApplication
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Quality
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class QualityToolkit : QualityToolkitBase

Constructors

QualityToolkit(ClarifySession)

Declaration
public QualityToolkit(ClarifySession session)
Parameters
Type | Name | Description
ClarifySession | session |

QualityToolkit(IFCApplication, IFCSession)

Declaration
public QualityToolkit(IFCApplication application, IFCSession session)
Parameters
Type | Name | Description
IFCApplication | application |
IFCSession | session |

Properties

ApplicationClock

Declaration
public IApplicationClock ApplicationClock { get; set; }
Property Value
Type | Description
IApplicationClock |

Methods

AcceptCR(AcceptCRSetup)

Declaration
public ToolkitResult AcceptCR(AcceptCRSetup setupParam)
Parameters
Type | Name | Description
AcceptCRSetup | setupParam |
Returns
Type | Description
ToolkitResult |

AcceptCR(AcceptCRSetup, IDbTransaction)

Declaration
public ToolkitResult AcceptCR(AcceptCRSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
AcceptCRSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

AcceptCR(String)

Declaration
public ToolkitResult AcceptCR(string cridnum)
Parameters
Type | Name | Description
System.String | cridnum |
Returns
Type | Description
ToolkitResult |

AddModuleToCR(AddModuleToCRSetup)

Declaration
public ToolkitResult AddModuleToCR(AddModuleToCRSetup setupParam)
Parameters
Type | Name | Description
AddModuleToCRSetup | setupParam |
Returns
Type | Description
ToolkitResult |

AddModuleToCR(AddModuleToCRSetup, IDbTransaction)

Declaration
public ToolkitResult AddModuleToCR(AddModuleToCRSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
AddModuleToCRSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

AddModuleToCR(Int32, String)

Declaration
public ToolkitResult AddModuleToCR(int fixObjid, string fileName)
Parameters
Type | Name | Description
System.Int32 | fixObjid |
System.String | fileName |
Returns
Type | Description
ToolkitResult |

AppendHistoryToCR(String, String)

Declaration
public void AppendHistoryToCR(string idNumber, string stringToAppendToHistory)
Parameters
Type | Name | Description
System.String | idNumber |
System.String | stringToAppendToHistory |

AppendHistoryToCR(String, String, IDbTransaction)

Declaration
public void AppendHistoryToCR(string idNumber, string stringToAppendToHistory, IDbTransaction dbTransaction)
Parameters
Type | Name | Description
System.String | idNumber |
System.String | stringToAppendToHistory |
System.Data.IDbTransaction | dbTransaction |

AssignCR(AssignCRSetup)

Declaration
public ToolkitResult AssignCR(AssignCRSetup setupParam)
Parameters
Type | Name | Description
AssignCRSetup | setupParam |
Returns
Type | Description
ToolkitResult |

AssignCR(AssignCRSetup, IDbTransaction)

Declaration
public ToolkitResult AssignCR(AssignCRSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
AssignCRSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

AssignCR(String)

Declaration
public ToolkitResult AssignCR(string cridnum)
Parameters
Type | Name | Description
System.String | cridnum |
Returns
Type | Description
ToolkitResult |

ChangeCRStatus(ChangeCRStatusSetup)

Declaration
public ToolkitResult ChangeCRStatus(ChangeCRStatusSetup setupParam)
Parameters
Type | Name | Description
ChangeCRStatusSetup | setupParam |
Returns
Type | Description
ToolkitResult |

ChangeCRStatus(ChangeCRStatusSetup, IDbTransaction)

Declaration
public ToolkitResult ChangeCRStatus(ChangeCRStatusSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
ChangeCRStatusSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

ChangeCRStatus(String)

Declaration
public ToolkitResult ChangeCRStatus(string crIDNum)
Parameters
Type | Name | Description
System.String | crIDNum |
Returns
Type | Description
ToolkitResult |

CheckClearQualityTransition(CheckClearQualityTransitionSetup)

Declaration
public ToolkitResult CheckClearQualityTransition(CheckClearQualityTransitionSetup setupParam)
Parameters
Type | Name | Description
CheckClearQualityTransitionSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CheckClearQualityTransition(CheckClearQualityTransitionSetup, IDbTransaction)

Declaration
public ToolkitResult CheckClearQualityTransition(CheckClearQualityTransitionSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CheckClearQualityTransitionSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CheckClearQualityTransition(String, String, String, String, String)

Declaration
public ToolkitResult CheckClearQualityTransition(string oldCondition, string oldStatus, string newCondition, string newStatus, string userName)
Parameters
Type | Name | Description
System.String | oldCondition |
System.String | oldStatus |
System.String | newCondition |
System.String | newStatus |
System.String | userName |
Returns
Type | Description
ToolkitResult |

CloseCR(CloseCRSetup)

Declaration
public ToolkitResult CloseCR(CloseCRSetup setupParam)
Parameters
Type | Name | Description
CloseCRSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CloseCR(CloseCRSetup, IDbTransaction)

Declaration
public ToolkitResult CloseCR(CloseCRSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CloseCRSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CloseCR(String)

Declaration
public ToolkitResult CloseCR(string crIDNum)
Parameters
Type | Name | Description
System.String | crIDNum |
Returns
Type | Description
ToolkitResult |

CreateCR(CreateCRSetup)

Declaration
public ToolkitResult CreateCR(CreateCRSetup setupParam)
Parameters
Type | Name | Description
CreateCRSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreateCR(CreateCRSetup, IDbTransaction)

Declaration
public ToolkitResult CreateCR(CreateCRSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateCRSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreateCR(String, String, String)

Declaration
public ToolkitResult CreateCR(string partNumber, string partRevision, string partDomain)
Parameters
Type | Name | Description
System.String | partNumber |
System.String | partRevision |
System.String | partDomain |
Returns
Type | Description
ToolkitResult |

DispatchCR(DispatchCRSetup)

Declaration
public ToolkitResult DispatchCR(DispatchCRSetup setupParam)
Parameters
Type | Name | Description
DispatchCRSetup | setupParam |
Returns
Type | Description
ToolkitResult |

DispatchCR(DispatchCRSetup, IDbTransaction)

Declaration
public ToolkitResult DispatchCR(DispatchCRSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
DispatchCRSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

DispatchCR(String, String)

Declaration
public ToolkitResult DispatchCR(string cridnum, string queue)
Parameters
Type | Name | Description
System.String | cridnum |
System.String | queue |
Returns
Type | Description
ToolkitResult |

DuplicateCR(DuplicateCRSetup)

Declaration
public ToolkitResult DuplicateCR(DuplicateCRSetup setupParam)
Parameters
Type | Name | Description
DuplicateCRSetup | setupParam |
Returns
Type | Description
ToolkitResult |

DuplicateCR(DuplicateCRSetup, IDbTransaction)

Declaration
public ToolkitResult DuplicateCR(DuplicateCRSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
DuplicateCRSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

DuplicateCR(String, String)

Declaration
public ToolkitResult DuplicateCR(string crIDNum, string masterCRIDNum)
Parameters
Type | Name | Description
System.String | crIDNum |
System.String | masterCRIDNum |
Returns
Type | Description
ToolkitResult |

FixCR(FixCRSetup)

Declaration
public ToolkitResult FixCR(FixCRSetup setupParam)
Parameters
Type | Name | Description
FixCRSetup | setupParam |
Returns
Type | Description
ToolkitResult |

FixCR(FixCRSetup, IDbTransaction)

Declaration
public ToolkitResult FixCR(FixCRSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
FixCRSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

FixCR(String)

Declaration
public ToolkitResult FixCR(string crIDNum)
Parameters
Type | Name | Description
System.String | crIDNum |
Returns
Type | Description
ToolkitResult |

FixFailed(FixFailedSetup)

Declaration
public ToolkitResult FixFailed(FixFailedSetup setupParam)
Parameters
Type | Name | Description
FixFailedSetup | setupParam |
Returns
Type | Description
ToolkitResult |

FixFailed(FixFailedSetup, IDbTransaction)

Declaration
public ToolkitResult FixFailed(FixFailedSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
FixFailedSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

FixFailed(String)

Declaration
public ToolkitResult FixFailed(string crIDNum)
Parameters
Type | Name | Description
System.String | crIDNum |
Returns
Type | Description
ToolkitResult |

ForwardCR(ForwardCRSetup)

Declaration
public ToolkitResult ForwardCR(ForwardCRSetup setupParam)
Parameters
Type | Name | Description
ForwardCRSetup | setupParam |
Returns
Type | Description
ToolkitResult |

ForwardCR(ForwardCRSetup, IDbTransaction)

Declaration
public ToolkitResult ForwardCR(ForwardCRSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
ForwardCRSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

ForwardCR(String, String)

Declaration
public ToolkitResult ForwardCR(string cridnum, string newQueue)
Parameters
Type | Name | Description
System.String | cridnum |
System.String | newQueue |
Returns
Type | Description
ToolkitResult |

LogCREmail(LogCREmailSetup)

Declaration
public ToolkitResult LogCREmail(LogCREmailSetup setupParam)
Parameters
Type | Name | Description
LogCREmailSetup | setupParam |
Returns
Type | Description
ToolkitResult |

LogCREmail(LogCREmailSetup, IDbTransaction)

Declaration
public ToolkitResult LogCREmail(LogCREmailSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
LogCREmailSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

LogCREmail(String)

Declaration
public ToolkitResult LogCREmail(string crIDNum)
Parameters
Type | Name | Description
System.String | crIDNum |
Returns
Type | Description
ToolkitResult |

LogCREmailIn(QualityToolkit.LogCREmailInSetup)

Declaration
public ToolkitResult LogCREmailIn(QualityToolkit.LogCREmailInSetup setup)
Parameters
Type | Name | Description
QualityToolkit.LogCREmailInSetup | setup |
Returns
Type | Description
ToolkitResult |

LogCREmailIn(QualityToolkit.LogCREmailInSetup, IDbTransaction)

Declaration
public ToolkitResult LogCREmailIn(QualityToolkit.LogCREmailInSetup setup, IDbTransaction transaction)
Parameters
Type | Name | Description
QualityToolkit.LogCREmailInSetup | setup |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

LogCRNote(LogCRNoteSetup)

Declaration
public ToolkitResult LogCRNote(LogCRNoteSetup setupParam)
Parameters
Type | Name | Description
LogCRNoteSetup | setupParam |
Returns
Type | Description
ToolkitResult |

LogCRNote(LogCRNoteSetup, IDbTransaction)

Declaration
public ToolkitResult LogCRNote(LogCRNoteSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
LogCRNoteSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

LogCRNote(String)

Declaration
public ToolkitResult LogCRNote(string crIDNum)
Parameters
Type | Name | Description
System.String | crIDNum |
Returns
Type | Description
ToolkitResult |

MoveCR(MoveCRSetup)

Declaration
public ToolkitResult MoveCR(MoveCRSetup setupParam)
Parameters
Type | Name | Description
MoveCRSetup | setupParam |
Returns
Type | Description
ToolkitResult |

MoveCR(MoveCRSetup, IDbTransaction)

Declaration
public ToolkitResult MoveCR(MoveCRSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
MoveCRSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

MoveCR(String, String)

Declaration
public ToolkitResult MoveCR(string cridnum, string newWipBin)
Parameters
Type | Name | Description
System.String | cridnum |
System.String | newWipBin |
Returns
Type | Description
ToolkitResult |

RejectCR(RejectCRSetup)

Declaration
public ToolkitResult RejectCR(RejectCRSetup setupParam)
Parameters
Type | Name | Description
RejectCRSetup | setupParam |
Returns
Type | Description
ToolkitResult |

RejectCR(RejectCRSetup, IDbTransaction)

Declaration
public ToolkitResult RejectCR(RejectCRSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
RejectCRSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

RejectCR(String)

Declaration
public ToolkitResult RejectCR(string cridnum)
Parameters
Type | Name | Description
System.String | cridnum |
Returns
Type | Description
ToolkitResult |

ReopenCR(ReopenCRSetup)

Declaration
public ToolkitResult ReopenCR(ReopenCRSetup setupParam)
Parameters
Type | Name | Description
ReopenCRSetup | setupParam |
Returns
Type | Description
ToolkitResult |

ReopenCR(ReopenCRSetup, IDbTransaction)

Declaration
public ToolkitResult ReopenCR(ReopenCRSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
ReopenCRSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

ReopenCR(String)

Declaration
public ToolkitResult ReopenCR(string crIDNum)
Parameters
Type | Name | Description
System.String | crIDNum |
Returns
Type | Description
ToolkitResult |

ReplicateCR(ReplicateCRSetup)

Declaration
public ToolkitResult ReplicateCR(ReplicateCRSetup setupParam)
Parameters
Type | Name | Description
ReplicateCRSetup | setupParam |
Returns
Type | Description
ToolkitResult |

ReplicateCR(ReplicateCRSetup, IDbTransaction)

Declaration
public ToolkitResult ReplicateCR(ReplicateCRSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
ReplicateCRSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

ReplicateCR(String)

Declaration
public ToolkitResult ReplicateCR(string crIDNum)
Parameters
Type | Name | Description
System.String | crIDNum |
Returns
Type | Description
ToolkitResult |

UpdateCR(UpdateCRSetup)

Declaration
public ToolkitResult UpdateCR(UpdateCRSetup setupParam)
Parameters
Type | Name | Description
UpdateCRSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdateCR(UpdateCRSetup, IDbTransaction)

Declaration
public ToolkitResult UpdateCR(UpdateCRSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdateCRSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

YankCR(YankCRSetup)

Declaration
public ToolkitResult YankCR(YankCRSetup setupParam)
Parameters
Type | Name | Description
YankCRSetup | setupParam |
Returns
Type | Description
ToolkitResult |

YankCR(YankCRSetup, IDbTransaction)

Declaration
public ToolkitResult YankCR(YankCRSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
YankCRSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

YankCR(String)

Declaration
public ToolkitResult YankCR(string cridnum)
Parameters
Type | Name | Description
System.String | cridnum |
Returns
Type | Description
ToolkitResult |


Class QualityToolkit.LogCREmailInSetup | fcSDK Documentation

Class QualityToolkit.LogCREmailInSetup

Inheritance
System.Object
LogEmailInSetup
QualityToolkit.LogCREmailInSetup
Inherited Members
LogEmailInSetup.IDNumber
LogEmailInSetup.LogDate
LogEmailInSetup.Message
LogEmailInSetup.Recipient
LogEmailInSetup.Sender
LogEmailInSetup.Subject
LogEmailInSetup.CCList
LogEmailInSetup.UserName
LogEmailInSetup.GenerateTimeBombs
LogEmailInSetup.AdditionalFields
LogEmailInSetup.MailLogActionType
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Quality
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LogCREmailInSetup : LogEmailInSetup

Constructors

LogCREmailInSetup(String, String, String, String)

Declaration
public LogCREmailInSetup(string crIDNum, string sender, string recipient, string message)
Parameters
Type | Name | Description
System.String | crIDNum |
System.String | sender |
System.String | recipient |
System.String | message |


Class QualityToolkitBase | fcSDK Documentation

Class QualityToolkitBase

Inheritance
System.Object
ToolkitBase
QualityToolkitBase
QualityToolkit
Inherited Members
ToolkitBase.NOW_DATE
ToolkitBase.CompatSession
ToolkitBase.WithTransaction<T>(Func<IDbTransaction, T>)
ToolkitBase.FCApplication
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Quality
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public abstract class QualityToolkitBase : ToolkitBase

Constructors

QualityToolkitBase(ClarifySession)

Declaration
public QualityToolkitBase(ClarifySession sess)
Parameters
Type | Name | Description
ClarifySession | sess |

QualityToolkitBase(IFCApplication, IFCSession)

Declaration
public QualityToolkitBase(IFCApplication app, IFCSession sess)
Parameters
Type | Name | Description
IFCApplication | app |
IFCSession | sess |

Fields

_toolkit

Declaration
protected FCCQ _toolkit
Field Value
Type | Description
FCCQ |

Properties

ImpersonatorUsername

Declaration
public string ImpersonatorUsername { get; set; }
Property Value
Type | Description
System.String |


Class RejectCRSetup | fcSDK Documentation

Class RejectCRSetup

Inheritance
System.Object
RejectCRSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Quality
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class RejectCRSetup

Constructors

RejectCRSetup(String)

Declaration
[ConstructorIndex(0)]
public RejectCRSetup(string cridnum)
Parameters
Type | Name | Description
System.String | cridnum |

Properties

CRIDNum

Declaration
[PropertyBitValue(1)]
public string CRIDNum { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

Notes

Declaration
[PropertyBitValue(8)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

RejectDate

Declaration
[PropertyBitValue(2)]
public DateTime RejectDate { get; set; }
Property Value
Type | Description
System.DateTime |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(4)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |


Class ReopenCRSetup | fcSDK Documentation

Class ReopenCRSetup

Inheritance
System.Object
ReopenCRSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Quality
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ReopenCRSetup

Constructors

ReopenCRSetup(String)

Declaration
[ConstructorIndex(0)]
public ReopenCRSetup(string crIDNum)
Parameters
Type | Name | Description
System.String | crIDNum |

Properties

CRIDNum

Declaration
[PropertyBitValue(1)]
public string CRIDNum { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

ReopenDate

Declaration
[PropertyBitValue(16)]
public DateTime ReopenDate { get; set; }
Property Value
Type | Description
System.DateTime |

Status

Declaration
[PropertyBitValue(2)]
public string Status { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(4)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |


Class ReplicateCRSetup | fcSDK Documentation

Class ReplicateCRSetup

Inheritance
System.Object
ReplicateCRSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Quality
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ReplicateCRSetup

Constructors

ReplicateCRSetup(String)

Declaration
[ConstructorIndex(0)]
public ReplicateCRSetup(string crIDNum)
Parameters
Type | Name | Description
System.String | crIDNum |

Properties

CRIDNum

Declaration
[PropertyBitValue(1)]
public string CRIDNum { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(8)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

ReplicatedDate

Declaration
[PropertyBitValue(4)]
public DateTime ReplicatedDate { get; set; }
Property Value
Type | Description
System.DateTime |

UserName

Declaration
[PropertyBitValue(2)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class UpdateCRSetup | fcSDK Documentation

Class UpdateCRSetup

Inheritance
System.Object
UpdateCRSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Quality
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdateCRSetup

Constructors

UpdateCRSetup(String)

Declaration
[ConstructorIndex(0)]
public UpdateCRSetup(string crIDNum)
Parameters
Type | Name | Description
System.String | crIDNum |

Properties

AdditionalFields

Declaration
[PropertyBitValue(262144)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

CRClass

Declaration
[PropertyBitValue(2048)]
public string CRClass { get; set; }
Property Value
Type | Description
System.String |

CRIDNum

Declaration
[PropertyBitValue(1)]
public string CRIDNum { get; set; }
Property Value
Type | Description
System.String |

CRType

Declaration
[PropertyBitValue(32)]
public string CRType { get; set; }
Property Value
Type | Description
System.String |

FixedIn

Declaration
[PropertyBitValue(16384)]
public string FixedIn { get; set; }
Property Value
Type | Description
System.String |

FoundOnCPU

Declaration
[PropertyBitValue(256)]
public string FoundOnCPU { get; set; }
Property Value
Type | Description
System.String |

Frequency

Declaration
[PropertyBitValue(128)]
public string Frequency { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(131072)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

IntroductionPhase

Declaration
[PropertyBitValue(4096)]
public string IntroductionPhase { get; set; }
Property Value
Type | Description
System.String |

Memory

Declaration
[PropertyBitValue(1024)]
public string Memory { get; set; }
Property Value
Type | Description
System.String |

OperatingSystem

Declaration
[PropertyBitValue(512)]
public string OperatingSystem { get; set; }
Property Value
Type | Description
System.String |

PartDomain

Declaration
[PropertyBitValue(8)]
public string PartDomain { get; set; }
Property Value
Type | Description
System.String |

PartNumber

Declaration
[PropertyBitValue(2)]
public string PartNumber { get; set; }
Property Value
Type | Description
System.String |

PartRevision

Declaration
[PropertyBitValue(4)]
public string PartRevision { get; set; }
Property Value
Type | Description
System.String |

Priority

Declaration
[PropertyBitValue(64)]
public string Priority { get; set; }
Property Value
Type | Description
System.String |

TestClass

Declaration
[PropertyBitValue(8192)]
public string TestClass { get; set; }
Property Value
Type | Description
System.String |

Title

Declaration
[PropertyBitValue(16)]
public string Title { get; set; }
Property Value
Type | Description
System.String |

UpdateDate

Declaration
[PropertyBitValue(65536)]
public DateTime UpdateDate { get; set; }
Property Value
Type | Description
System.DateTime |

UserName

Declaration
[PropertyBitValue(32768)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class YankCRSetup | fcSDK Documentation

Class YankCRSetup

Inheritance
System.Object
YankCRSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Quality
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class YankCRSetup

Constructors

YankCRSetup(String)

Declaration
[ConstructorIndex(0)]
public YankCRSetup(string cridnum)
Parameters
Type | Name | Description
System.String | cridnum |

Properties

CRIDNum

Declaration
[PropertyBitValue(1)]
public string CRIDNum { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(16)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(2)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |

YankDate

Declaration
[PropertyBitValue(4)]
public DateTime YankDate { get; set; }
Property Value
Type | Description
System.DateTime |


Enum RepairPartDisposition | fcSDK Documentation

Enum RepairPartDisposition

Namespace: FChoice.Toolkits.Clarify
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public enum RepairPartDisposition

Fields

Name | Description
Reference |
Removed |
Used |


Namespace FChoice.Toolkits.Clarify.Sales | fcSDK Documentation

Namespace FChoice.Toolkits.Clarify.Sales

Classes

AcceptActionItemSetup

AcceptOpportunitySetup

AcceptQuoteSetup

AssignActionItemSetup

AssignLeadSetup

AssignOpportunitySetup

AssignQuoteSetup

ChangeActionItemConditionSetup

ChangeActionItemStatusSetup

ChangeOpportunityStageSetup

ChangeOpportunityStatusSetup

ChangeQuoteStatusSetup

CloseOpportunitySetup

CreateActionItemSetup

CreateLeadSetup

CreateOpportunitySetup

CreateQuoteLineItemSetup

CreateQuoteSetup

DispatchActionItemSetup

DispatchOpportunitySetup

DispatchQuoteSetup

ForwardActionItemSetup

ForwardOpportunitySetup

ForwardQuoteSetup

LogActionItemEmailInSetup

LogLeadNoteSetup

LogLeadPhoneSetup

MoveActionItemSetup

MoveOpportunitySetup

MoveQuoteSetup

RejectActionItemSetup

RejectOpportunitySetup

RejectQuoteSetup

ReopenOpportunitySetup

SalesToolkit

SalesToolkitBase

UpdateActionItemSetup

UpdateLeadSetup

UpdateOpportunitySetup

YankActionItemSetup

YankOpportunitySetup

YankQuoteSetup

Back to top © 2022 Dovetail Software, Inc. - All rights reserved.
Clarify, Amdocs, and related products and names are copyright and trademark of Amdocs, Inc.
.NET, Visual Studio.NET, C#, Visual Basic and related products are trademark of Microsoft corporation.


Class AcceptActionItemSetup | fcSDK Documentation

Class AcceptActionItemSetup

Inheritance
System.Object
AcceptActionItemSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class AcceptActionItemSetup

Constructors

AcceptActionItemSetup(String)

Declaration
[ConstructorIndex(0)]
public AcceptActionItemSetup(string actionItemIDNum)
Parameters
Type | Name | Description
System.String | actionItemIDNum |

Properties

AcceptDate

Declaration
[PropertyBitValue(2)]
public DateTime AcceptDate { get; set; }
Property Value
Type | Description
System.DateTime |

ActionItemIDNum

Declaration
[PropertyBitValue(1)]
public string ActionItemIDNum { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(16)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(4)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |


Class AcceptOpportunitySetup | fcSDK Documentation

Class AcceptOpportunitySetup

Inheritance
System.Object
AcceptOpportunitySetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class AcceptOpportunitySetup

Constructors

AcceptOpportunitySetup(String)

Declaration
[ConstructorIndex(0)]
public AcceptOpportunitySetup(string opportunityIDNum)
Parameters
Type | Name | Description
System.String | opportunityIDNum |

Properties

AcceptDate

Declaration
[PropertyBitValue(2)]
public DateTime AcceptDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(16)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

OpportunityIDNum

Declaration
[PropertyBitValue(1)]
public string OpportunityIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(4)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |


Class AcceptQuoteSetup | fcSDK Documentation

Class AcceptQuoteSetup

Inheritance
System.Object
AcceptQuoteSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class AcceptQuoteSetup

Constructors

AcceptQuoteSetup(String)

Declaration
[ConstructorIndex(0)]
public AcceptQuoteSetup(string quoteIDNum)
Parameters
Type | Name | Description
System.String | quoteIDNum |

Properties

AcceptDate

Declaration
[PropertyBitValue(2)]
public DateTime AcceptDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(16)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

QuoteIDNum

Declaration
[PropertyBitValue(1)]
public string QuoteIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(4)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |


Class AssignActionItemSetup | fcSDK Documentation

Class AssignActionItemSetup

Inheritance
System.Object
AssignActionItemSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class AssignActionItemSetup

Constructors

AssignActionItemSetup(String)

Declaration
[ConstructorIndex(0)]
public AssignActionItemSetup(string actionItemIDNum)
Parameters
Type | Name | Description
System.String | actionItemIDNum |

Properties

ActionItemIDNum

Declaration
[PropertyBitValue(1)]
public string ActionItemIDNum { get; set; }
Property Value
Type | Description
System.String |

AssignDate

Declaration
[PropertyBitValue(8)]
public DateTime AssignDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

NewUser

Declaration
[PropertyBitValue(2)]
public string NewUser { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(4)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |


Class AssignLeadSetup | fcSDK Documentation

Class AssignLeadSetup

Inheritance
System.Object
AssignLeadSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class AssignLeadSetup

Constructors

AssignLeadSetup(Int32, String)

Declaration
[ConstructorIndex(0)]
public AssignLeadSetup(int leadObjid, string newOwner)
Parameters
Type | Name | Description
System.Int32 | leadObjid |
System.String | newOwner |

Properties

AssignDate

Declaration
[PropertyBitValue(4)]
public DateTime AssignDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(8)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

LeadObjid

Declaration
[PropertyBitValue(1)]
public int LeadObjid { get; set; }
Property Value
Type | Description
System.Int32 |

NewOwner

Declaration
[PropertyBitValue(2)]
public string NewOwner { get; set; }
Property Value
Type | Description
System.String |


Class AssignOpportunitySetup | fcSDK Documentation

Class AssignOpportunitySetup

Inheritance
System.Object
AssignOpportunitySetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class AssignOpportunitySetup

Constructors

AssignOpportunitySetup(String)

Declaration
[ConstructorIndex(0)]
public AssignOpportunitySetup(string opportunityIDNum)
Parameters
Type | Name | Description
System.String | opportunityIDNum |

Properties

AssignDate

Declaration
[PropertyBitValue(8)]
public DateTime AssignDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

NewUser

Declaration
[PropertyBitValue(2)]
public string NewUser { get; set; }
Property Value
Type | Description
System.String |

OpportunityIDNum

Declaration
[PropertyBitValue(1)]
public string OpportunityIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(4)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |


Class AssignQuoteSetup | fcSDK Documentation

Class AssignQuoteSetup

Inheritance
System.Object
AssignQuoteSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class AssignQuoteSetup

Constructors

AssignQuoteSetup(String)

Declaration
[ConstructorIndex(0)]
public AssignQuoteSetup(string quoteIDNum)
Parameters
Type | Name | Description
System.String | quoteIDNum |

Properties

AssignDate

Declaration
[PropertyBitValue(8)]
public DateTime AssignDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

NewUser

Declaration
[PropertyBitValue(2)]
public string NewUser { get; set; }
Property Value
Type | Description
System.String |

QuoteIDNum

Declaration
[PropertyBitValue(1)]
public string QuoteIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(4)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |


Class ChangeActionItemConditionSetup | fcSDK Documentation

Class ChangeActionItemConditionSetup

Inheritance
System.Object
ChangeActionItemConditionSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ChangeActionItemConditionSetup

Constructors

ChangeActionItemConditionSetup(String, String)

Declaration
[ConstructorIndex(0)]
public ChangeActionItemConditionSetup(string actionItemIDNum, string newcondition)
Parameters
Type | Name | Description
System.String | actionItemIDNum |
System.String | newcondition |

Properties

ActionItemIDNum

Declaration
[PropertyBitValue(1)]
public string ActionItemIDNum { get; set; }
Property Value
Type | Description
System.String |

ChangeDate

Declaration
[PropertyBitValue(16)]
public DateTime ChangeDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

NewCondition

Declaration
[PropertyBitValue(2)]
public string NewCondition { get; set; }
Property Value
Type | Description
System.String |

NewStatus

Declaration
[PropertyBitValue(4)]
public string NewStatus { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class ChangeActionItemStatusSetup | fcSDK Documentation

Class ChangeActionItemStatusSetup

Inheritance
System.Object
ChangeActionItemStatusSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ChangeActionItemStatusSetup

Constructors

ChangeActionItemStatusSetup(String)

Declaration
[ConstructorIndex(0)]
public ChangeActionItemStatusSetup(string actionItemIDNum)
Parameters
Type | Name | Description
System.String | actionItemIDNum |

Properties

ActionItemIDNum

Declaration
[PropertyBitValue(1)]
public string ActionItemIDNum { get; set; }
Property Value
Type | Description
System.String |

ChangeDate

Declaration
[PropertyBitValue(4)]
public DateTime ChangeDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

NewStatus

Declaration
[PropertyBitValue(2)]
public string NewStatus { get; set; }
Property Value
Type | Description
System.String |

Notes

Declaration
[PropertyBitValue(8)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class ChangeOpportunityStageSetup | fcSDK Documentation

Class ChangeOpportunityStageSetup

Inheritance
System.Object
ChangeOpportunityStageSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ChangeOpportunityStageSetup

Constructors

ChangeOpportunityStageSetup(String, OpportunityStage)

Declaration
[ConstructorIndex(0)]
public ChangeOpportunityStageSetup(string opportunityIDNum, OpportunityStage stage)
Parameters
Type | Name | Description
System.String | opportunityIDNum |
OpportunityStage | stage |

Properties

ChangeDate

Declaration
[PropertyBitValue(16)]
public DateTime ChangeDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

NewStatus

Declaration
[PropertyBitValue(2)]
public string NewStatus { get; set; }
Property Value
Type | Description
System.String |

Notes

Declaration
[PropertyBitValue(4)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

OpportunityIDNum

Declaration
[PropertyBitValue(1)]
public string OpportunityIDNum { get; set; }
Property Value
Type | Description
System.String |

Stage

Declaration
[PropertyBitValue(64)]
public OpportunityStage Stage { get; set; }
Property Value
Type | Description
OpportunityStage |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class ChangeOpportunityStatusSetup | fcSDK Documentation

Class ChangeOpportunityStatusSetup

Inheritance
System.Object
ChangeOpportunityStatusSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ChangeOpportunityStatusSetup

Constructors

ChangeOpportunityStatusSetup(String)

Declaration
[ConstructorIndex(0)]
public ChangeOpportunityStatusSetup(string opportunityIDNum)
Parameters
Type | Name | Description
System.String | opportunityIDNum |

Properties

ChangeDate

Declaration
[PropertyBitValue(4)]
public DateTime ChangeDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

NewStatus

Declaration
[PropertyBitValue(2)]
public string NewStatus { get; set; }
Property Value
Type | Description
System.String |

Notes

Declaration
[PropertyBitValue(8)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

OpportunityIDNum

Declaration
[PropertyBitValue(1)]
public string OpportunityIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class ChangeQuoteStatusSetup | fcSDK Documentation

Class ChangeQuoteStatusSetup

Inheritance
System.Object
ChangeQuoteStatusSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ChangeQuoteStatusSetup

Constructors

ChangeQuoteStatusSetup(String)

Declaration
[ConstructorIndex(0)]
public ChangeQuoteStatusSetup(string quoteIDNum)
Parameters
Type | Name | Description
System.String | quoteIDNum |

Properties

ChangeDate

Declaration
[PropertyBitValue(4)]
public DateTime ChangeDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

NewStatus

Declaration
[PropertyBitValue(2)]
public string NewStatus { get; set; }
Property Value
Type | Description
System.String |

Notes

Declaration
[PropertyBitValue(8)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

QuoteIDNum

Declaration
[PropertyBitValue(1)]
public string QuoteIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class CloseOpportunitySetup | fcSDK Documentation

Class CloseOpportunitySetup

Inheritance
System.Object
CloseOpportunitySetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CloseOpportunitySetup

Constructors

CloseOpportunitySetup(String)

Declaration
[ConstructorIndex(0)]
public CloseOpportunitySetup(string opportunityIDNum)
Parameters
Type | Name | Description
System.String | opportunityIDNum |

Properties

CloseDate

Declaration
[PropertyBitValue(4)]
public DateTime CloseDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(16)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

OpportunityIDNum

Declaration
[PropertyBitValue(1)]
public string OpportunityIDNum { get; set; }
Property Value
Type | Description
System.String |

Status

Declaration
[PropertyBitValue(2)]
public string Status { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class CreateActionItemSetup | fcSDK Documentation

Class CreateActionItemSetup

Inheritance
System.Object
CreateActionItemSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateActionItemSetup

Constructors

CreateActionItemSetup()

Declaration
[ConstructorIndex(0)]
public CreateActionItemSetup()

Properties

AccountName

Declaration
[PropertyBitValue(32)]
public string AccountName { get; set; }
Property Value
Type | Description
System.String |

AdditionalFields

Declaration
[PropertyBitValue(262144)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

CompleteDate

Declaration
[PropertyBitValue(8192)]
public DateTime CompleteDate { get; set; }
Property Value
Type | Description
System.DateTime |

ContactFirstName

Declaration
[PropertyBitValue(4)]
public string ContactFirstName { get; set; }
Property Value
Type | Description
System.String |

ContactLastName

Declaration
[PropertyBitValue(8)]
public string ContactLastName { get; set; }
Property Value
Type | Description
System.String |

ContactPhone

Declaration
[PropertyBitValue(16)]
public string ContactPhone { get; set; }
Property Value
Type | Description
System.String |

CreateDate

Declaration
[PropertyBitValue(32768)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

DueDate

Declaration
[PropertyBitValue(4096)]
public DateTime DueDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(131072)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

LeadFirstName

Declaration
[PropertyBitValue(64)]
public string LeadFirstName { get; set; }
Property Value
Type | Description
System.String |

LeadLastName

Declaration
[PropertyBitValue(128)]
public string LeadLastName { get; set; }
Property Value
Type | Description
System.String |

Notes

Declaration
[PropertyBitValue(2)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

OpportunityIDNum

Declaration
[PropertyBitValue(256)]
public string OpportunityIDNum { get; set; }
Property Value
Type | Description
System.String |

Priority

Declaration
[PropertyBitValue(1024)]
public string Priority { get; set; }
Property Value
Type | Description
System.String |

StartDate

Declaration
[PropertyBitValue(2048)]
public DateTime StartDate { get; set; }
Property Value
Type | Description
System.DateTime |

Status

Declaration
[PropertyBitValue(16384)]
public string Status { get; set; }
Property Value
Type | Description
System.String |

TaskType

Declaration
[PropertyBitValue(512)]
public string TaskType { get; set; }
Property Value
Type | Description
System.String |

Title

Declaration
[PropertyBitValue(1)]
public string Title { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(65536)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class CreateLeadSetup | fcSDK Documentation

Class CreateLeadSetup

Inheritance
System.Object
CreateLeadSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateLeadSetup

Constructors

CreateLeadSetup(String, String, String, LeadSiteType, String)

Declaration
[ConstructorIndex(0)]
public CreateLeadSetup(string state, string country, string timeZone, LeadSiteType siteType, string leadSource)
Parameters
Type | Name | Description
System.String | state |
System.String | country |
System.String | timeZone |
LeadSiteType | siteType |
System.String | leadSource |

Properties

AdditionalFields

Declaration
[PropertyBitValue(8388608)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

Address

Declaration
[PropertyBitValue(32)]
public string Address { get; set; }
Property Value
Type | Description
System.String |

Address2

Declaration
[PropertyBitValue(64)]
public string Address2 { get; set; }
Property Value
Type | Description
System.String |

City

Declaration
[PropertyBitValue(128)]
public string City { get; set; }
Property Value
Type | Description
System.String |

CompanyName

Declaration
[PropertyBitValue(16384)]
public string CompanyName { get; set; }
Property Value
Type | Description
System.String |

ContactFirstName

Declaration
[PropertyBitValue(2)]
public string ContactFirstName { get; set; }
Property Value
Type | Description
System.String |

ContactLastName

Declaration
[PropertyBitValue(4)]
public string ContactLastName { get; set; }
Property Value
Type | Description
System.String |

ContactPhone

Declaration
[PropertyBitValue(8)]
public string ContactPhone { get; set; }
Property Value
Type | Description
System.String |

ContactRole

Declaration
[PropertyBitValue(262144)]
public string ContactRole { get; set; }
Property Value
Type | Description
System.String |

Country

Declaration
[PropertyBitValue(1024)]
public string Country { get; set; }
Property Value
Type | Description
System.String |

CreateDate

Declaration
[PropertyBitValue(2097152)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

Email

Declaration
[PropertyBitValue(4096)]
public string Email { get; set; }
Property Value
Type | Description
System.String |

Fax

Declaration
[PropertyBitValue(16)]
public string Fax { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(4194304)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

LeadObjid

Declaration
[PropertyBitValue(1)]
public int LeadObjid { get; set; }
Property Value
Type | Description
System.Int32 |

LeadSource

Declaration
[PropertyBitValue(524288)]
public string LeadSource { get; set; }
Property Value
Type | Description
System.String |

PostalCode

Declaration
[PropertyBitValue(512)]
public string PostalCode { get; set; }
Property Value
Type | Description
System.String |

Rating

Declaration
[PropertyBitValue(131072)]
public string Rating { get; set; }
Property Value
Type | Description
System.String |

SiteName

Declaration
[PropertyBitValue(32768)]
public string SiteName { get; set; }
Property Value
Type | Description
System.String |

SiteType

Declaration
[PropertyBitValue(65536)]
public LeadSiteType SiteType { get; set; }
Property Value
Type | Description
LeadSiteType |

State

Declaration
[PropertyBitValue(256)]
public string State { get; set; }
Property Value
Type | Description
System.String |

TimeZone

Declaration
[PropertyBitValue(2048)]
public string TimeZone { get; set; }
Property Value
Type | Description
System.String |

Title

Declaration
[PropertyBitValue(8192)]
public string Title { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(1048576)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class CreateOpportunitySetup | fcSDK Documentation

Class CreateOpportunitySetup

Inheritance
System.Object
CreateOpportunitySetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateOpportunitySetup

Constructors

CreateOpportunitySetup(String, String, Single)

Declaration
[ConstructorIndex(0)]
public CreateOpportunitySetup(string opportunityName, string salesStage, float probability)
Parameters
Type | Name | Description
System.String | opportunityName |
System.String | salesStage |
System.Single | probability |

Properties

AccountIDNum

Declaration
[PropertyBitValue(2)]
public string AccountIDNum { get; set; }
Property Value
Type | Description
System.String |

AdditionalFields

Declaration
[PropertyBitValue(65536)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

Amount

Declaration
[PropertyBitValue(64)]
public decimal Amount { get; set; }
Property Value
Type | Description
System.Decimal |

CloseDate

Declaration
[PropertyBitValue(128)]
public DateTime CloseDate { get; set; }
Property Value
Type | Description
System.DateTime |

ContactFirstName

Declaration
[PropertyBitValue(4)]
public string ContactFirstName { get; set; }
Property Value
Type | Description
System.String |

ContactLastName

Declaration
[PropertyBitValue(8)]
public string ContactLastName { get; set; }
Property Value
Type | Description
System.String |

ContactPhone

Declaration
[PropertyBitValue(16)]
public string ContactPhone { get; set; }
Property Value
Type | Description
System.String |

CreateDate

Declaration
[PropertyBitValue(16384)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

Currency

Declaration
[PropertyBitValue(1024)]
public string Currency { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(32768)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

LeadSource

Declaration
[PropertyBitValue(512)]
public string LeadSource { get; set; }
Property Value
Type | Description
System.String |

OpportunityName

Declaration
[PropertyBitValue(1)]
public string OpportunityName { get; set; }
Property Value
Type | Description
System.String |

Probability

Declaration
[PropertyBitValue(2048)]
public float Probability { get; set; }
Property Value
Type | Description
System.Single |

Process

Declaration
[PropertyBitValue(4096)]
public string Process { get; set; }
Property Value
Type | Description
System.String |

SalesStage

Declaration
[PropertyBitValue(256)]
public string SalesStage { get; set; }
Property Value
Type | Description
System.String |

Territory

Declaration
[PropertyBitValue(32)]
public string Territory { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(8192)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class CreateQuoteLineItemSetup | fcSDK Documentation

Class CreateQuoteLineItemSetup

Inheritance
System.Object
CreateQuoteLineItemSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateQuoteLineItemSetup

Constructors

CreateQuoteLineItemSetup(String, String, String, String, Int32, String, Int32)

Declaration
[ConstructorIndex(0)]
public CreateQuoteLineItemSetup(string contractIDNum, string partNumber, string partDomain, string partRevision, int quantity, string priceSchedule, int parentLineItemObjid)
Parameters
Type | Name | Description
System.String | contractIDNum |
System.String | partNumber |
System.String | partDomain |
System.String | partRevision |
System.Int32 | quantity |
System.String | priceSchedule |
System.Int32 | parentLineItemObjid |

CreateQuoteLineItemSetup(String, String, String, String, String, String, Int32)

Declaration
[ConstructorIndex(1)]
public CreateQuoteLineItemSetup(string contractIDNum, string partNumber, string partDomain, string partRevision, string priceSchedule, string serialNumber, int parentLineItemObjid)
Parameters
Type | Name | Description
System.String | contractIDNum |
System.String | partNumber |
System.String | partDomain |
System.String | partRevision |
System.String | priceSchedule |
System.String | serialNumber |
System.Int32 | parentLineItemObjid |

Properties

AdditionalFields

Declaration
[PropertyBitValue(1048576)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

AutoInstall

Declaration
[PropertyBitValue(16384)]
public bool AutoInstall { get; set; }
Property Value
Type | Description
System.Boolean |

Comments

Declaration
[PropertyBitValue(32768)]
public string Comments { get; set; }
Property Value
Type | Description
System.String |

ContractIDNum

Declaration
[PropertyBitValue(1)]
public string ContractIDNum { get; set; }
Property Value
Type | Description
System.String |

CreateDate

Declaration
[PropertyBitValue(4)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

EndDate

Declaration
[PropertyBitValue(16)]
public DateTime EndDate { get; set; }
Property Value
Type | Description
System.DateTime |

IsTaxable

Declaration
[PropertyBitValue(8192)]
public bool IsTaxable { get; set; }
Property Value
Type | Description
System.Boolean |

OverridePrice

Declaration
[PropertyBitValue(1024)]
public double OverridePrice { get; set; }
Property Value
Type | Description
System.Double |

ParentLineItemObjid

Declaration
[PropertyBitValue(262144)]
public int ParentLineItemObjid { get; set; }
Property Value
Type | Description
System.Int32 |

PartDomain

Declaration
[PropertyBitValue(64)]
public string PartDomain { get; set; }
Property Value
Type | Description
System.String |

PartNumber

Declaration
[PropertyBitValue(32)]
public string PartNumber { get; set; }
Property Value
Type | Description
System.String |

PartRevision

Declaration
[PropertyBitValue(128)]
public string PartRevision { get; set; }
Property Value
Type | Description
System.String |

POIDNum

Declaration
[PropertyBitValue(524288)]
public string POIDNum { get; set; }
Property Value
Type | Description
System.String |

PriceSchedule

Declaration
[PropertyBitValue(512)]
public string PriceSchedule { get; set; }
Property Value
Type | Description
System.String |

Quantity

Declaration
[PropertyBitValue(256)]
public int Quantity { get; set; }
Property Value
Type | Description
System.Int32 |

QuotedSiteIDNum

Declaration
[PropertyBitValue(65536)]
public string QuotedSiteIDNum { get; set; }
Property Value
Type | Description
System.String |

SerialNumber

Declaration
[PropertyBitValue(4096)]
public string SerialNumber { get; set; }
Property Value
Type | Description
System.String |

ServicedAtSiteIDNum

Declaration
[PropertyBitValue(131072)]
public string ServicedAtSiteIDNum { get; set; }
Property Value
Type | Description
System.String |

StartDate

Declaration
[PropertyBitValue(8)]
public DateTime StartDate { get; set; }
Property Value
Type | Description
System.DateTime |

UnitsUsed

Declaration
[PropertyBitValue(2048)]
public double UnitsUsed { get; set; }
Property Value
Type | Description
System.Double |

UserName

Declaration
[PropertyBitValue(2)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class CreateQuoteSetup | fcSDK Documentation

Class CreateQuoteSetup

Inheritance
System.Object
CreateQuoteSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateQuoteSetup

Constructors

CreateQuoteSetup(String)

Declaration
[ConstructorIndex(0)]
public CreateQuoteSetup(string quoteTitle)
Parameters
Type | Name | Description
System.String | quoteTitle |

Properties

AccountIDNum

Declaration
[PropertyBitValue(2)]
public string AccountIDNum { get; set; }
Property Value
Type | Description
System.String |

AdditionalFields

Declaration
[PropertyBitValue(262144)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

AdminUserName

Declaration
[PropertyBitValue(8192)]
public string AdminUserName { get; set; }
Property Value
Type | Description
System.String |

BillToSiteIDNum

Declaration
[PropertyBitValue(256)]
public string BillToSiteIDNum { get; set; }
Property Value
Type | Description
System.String |

ContactFirstName

Declaration
[PropertyBitValue(16)]
public string ContactFirstName { get; set; }
Property Value
Type | Description
System.String |

ContactLastName

Declaration
[PropertyBitValue(32)]
public string ContactLastName { get; set; }
Property Value
Type | Description
System.String |

ContactPhone

Declaration
[PropertyBitValue(64)]
public string ContactPhone { get; set; }
Property Value
Type | Description
System.String |

CreateDate

Declaration
[PropertyBitValue(16384)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

Currency

Declaration
[PropertyBitValue(1024)]
public string Currency { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(131072)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

OpportunityIDNum

Declaration
[PropertyBitValue(8)]
public string OpportunityIDNum { get; set; }
Property Value
Type | Description
System.String |

PriceProgram

Declaration
[PropertyBitValue(2048)]
public string PriceProgram { get; set; }
Property Value
Type | Description
System.String |

Queue

Declaration
[PropertyBitValue(4096)]
public string Queue { get; set; }
Property Value
Type | Description
System.String |

QuoteLengthInDays

Declaration
[PropertyBitValue(65536)]
public short QuoteLengthInDays { get; set; }
Property Value
Type | Description
System.Int16 |

QuoteTitle

Declaration
[PropertyBitValue(1)]
public string QuoteTitle { get; set; }
Property Value
Type | Description
System.String |

ShipToSiteIDNum

Declaration
[PropertyBitValue(512)]
public string ShipToSiteIDNum { get; set; }
Property Value
Type | Description
System.String |

SiteIDNum

Declaration
[PropertyBitValue(4)]
public string SiteIDNum { get; set; }
Property Value
Type | Description
System.String |

Status

Declaration
[PropertyBitValue(128)]
public string Status { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(32768)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class DispatchActionItemSetup | fcSDK Documentation

Class DispatchActionItemSetup

Inheritance
System.Object
DispatchActionItemSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class DispatchActionItemSetup

Constructors

DispatchActionItemSetup(String, String)

Declaration
[ConstructorIndex(0)]
public DispatchActionItemSetup(string actionItemIDNum, string queue)
Parameters
Type | Name | Description
System.String | actionItemIDNum |
System.String | queue |

Properties

ActionItemIDNum

Declaration
[PropertyBitValue(1)]
public string ActionItemIDNum { get; set; }
Property Value
Type | Description
System.String |

DispatchDate

Declaration
[PropertyBitValue(4)]
public DateTime DispatchDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(16)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

Queue

Declaration
[PropertyBitValue(2)]
public string Queue { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class DispatchOpportunitySetup | fcSDK Documentation

Class DispatchOpportunitySetup

Inheritance
System.Object
DispatchOpportunitySetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class DispatchOpportunitySetup

Constructors

DispatchOpportunitySetup(String, String)

Declaration
[ConstructorIndex(0)]
public DispatchOpportunitySetup(string opportunityIDNum, string queue)
Parameters
Type | Name | Description
System.String | opportunityIDNum |
System.String | queue |

Properties

DispatchDate

Declaration
[PropertyBitValue(4)]
public DateTime DispatchDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(16)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

OpportunityIDNum

Declaration
[PropertyBitValue(1)]
public string OpportunityIDNum { get; set; }
Property Value
Type | Description
System.String |

Queue

Declaration
[PropertyBitValue(2)]
public string Queue { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class DispatchQuoteSetup | fcSDK Documentation

Class DispatchQuoteSetup

Inheritance
System.Object
DispatchQuoteSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class DispatchQuoteSetup

Constructors

DispatchQuoteSetup(String, String)

Declaration
[ConstructorIndex(0)]
public DispatchQuoteSetup(string quoteIDNum, string queue)
Parameters
Type | Name | Description
System.String | quoteIDNum |
System.String | queue |

Properties

DispatchDate

Declaration
[PropertyBitValue(4)]
public DateTime DispatchDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(16)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

Queue

Declaration
[PropertyBitValue(2)]
public string Queue { get; set; }
Property Value
Type | Description
System.String |

QuoteIDNum

Declaration
[PropertyBitValue(1)]
public string QuoteIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class ForwardActionItemSetup | fcSDK Documentation

Class ForwardActionItemSetup

Inheritance
System.Object
ForwardActionItemSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ForwardActionItemSetup

Constructors

ForwardActionItemSetup(String, String)

Declaration
[ConstructorIndex(0)]
public ForwardActionItemSetup(string actionItemIDNum, string newQueue)
Parameters
Type | Name | Description
System.String | actionItemIDNum |
System.String | newQueue |

Properties

ActionItemIDNum

Declaration
[PropertyBitValue(1)]
public string ActionItemIDNum { get; set; }
Property Value
Type | Description
System.String |

ForwardDate

Declaration
[PropertyBitValue(4)]
public DateTime ForwardDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

NewQueue

Declaration
[PropertyBitValue(2)]
public string NewQueue { get; set; }
Property Value
Type | Description
System.String |

Notes

Declaration
[PropertyBitValue(8)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class ForwardOpportunitySetup | fcSDK Documentation

Class ForwardOpportunitySetup

Inheritance
System.Object
ForwardOpportunitySetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ForwardOpportunitySetup

Constructors

ForwardOpportunitySetup(String, String)

Declaration
[ConstructorIndex(0)]
public ForwardOpportunitySetup(string opportunityIDNum, string newQueue)
Parameters
Type | Name | Description
System.String | opportunityIDNum |
System.String | newQueue |

Properties

ForwardDate

Declaration
[PropertyBitValue(4)]
public DateTime ForwardDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

NewQueue

Declaration
[PropertyBitValue(2)]
public string NewQueue { get; set; }
Property Value
Type | Description
System.String |

Notes

Declaration
[PropertyBitValue(8)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

OpportunityIDNum

Declaration
[PropertyBitValue(1)]
public string OpportunityIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class ForwardQuoteSetup | fcSDK Documentation

Class ForwardQuoteSetup

Inheritance
System.Object
ForwardQuoteSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ForwardQuoteSetup

Constructors

ForwardQuoteSetup(String, String)

Declaration
[ConstructorIndex(0)]
public ForwardQuoteSetup(string quoteIDNum, string newQueue)
Parameters
Type | Name | Description
System.String | quoteIDNum |
System.String | newQueue |

Properties

ForwardDate

Declaration
[PropertyBitValue(4)]
public DateTime ForwardDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

NewQueue

Declaration
[PropertyBitValue(2)]
public string NewQueue { get; set; }
Property Value
Type | Description
System.String |

Notes

Declaration
[PropertyBitValue(8)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

QuoteIDNum

Declaration
[PropertyBitValue(1)]
public string QuoteIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class LogActionItemEmailInSetup | fcSDK Documentation

Class LogActionItemEmailInSetup

Inheritance
System.Object
LogEmailInSetup
LogActionItemEmailInSetup
Inherited Members
LogEmailInSetup.IDNumber
LogEmailInSetup.LogDate
LogEmailInSetup.Message
LogEmailInSetup.Recipient
LogEmailInSetup.Sender
LogEmailInSetup.Subject
LogEmailInSetup.CCList
LogEmailInSetup.UserName
LogEmailInSetup.GenerateTimeBombs
LogEmailInSetup.AdditionalFields
LogEmailInSetup.MailLogActionType
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LogActionItemEmailInSetup : LogEmailInSetup

Constructors

LogActionItemEmailInSetup(String, String, String, String)

Declaration
public LogActionItemEmailInSetup(string taskId, string sender, string recipient, string message)
Parameters
Type | Name | Description
System.String | taskId |
System.String | sender |
System.String | recipient |
System.String | message |


Class LogLeadNoteSetup | fcSDK Documentation

Class LogLeadNoteSetup

Inheritance
System.Object
LogLeadNoteSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LogLeadNoteSetup

Constructors

LogLeadNoteSetup(Int32)

Declaration
[ConstructorIndex(0)]
public LogLeadNoteSetup(int leadObjid)
Parameters
Type | Name | Description
System.Int32 | leadObjid |

Properties

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

InternalUseOnlyNotes

Declaration
[PropertyBitValue(4)]
public string InternalUseOnlyNotes { get; set; }
Property Value
Type | Description
System.String |

LeadObjid

Declaration
[PropertyBitValue(1)]
public int LeadObjid { get; set; }
Property Value
Type | Description
System.Int32 |

LogDate

Declaration
[PropertyBitValue(8)]
public DateTime LogDate { get; set; }
Property Value
Type | Description
System.DateTime |

Notes

Declaration
[PropertyBitValue(2)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class LogLeadPhoneSetup | fcSDK Documentation

Class LogLeadPhoneSetup

Inheritance
System.Object
LogLeadPhoneSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LogLeadPhoneSetup

Constructors

LogLeadPhoneSetup(Int32, String, String, String, TimeSpan)

Declaration
[ConstructorIndex(0)]
public LogLeadPhoneSetup(int leadObjid, string contactFirstName, string contactLastName, string contactPhone, TimeSpan duration)
Parameters
Type | Name | Description
System.Int32 | leadObjid |
System.String | contactFirstName |
System.String | contactLastName |
System.String | contactPhone |
System.TimeSpan | duration |

Properties

ActionType

Declaration
[PropertyBitValue(64)]
public string ActionType { get; set; }
Property Value
Type | Description
System.String |

ContactFirstName

Declaration
[PropertyBitValue(8)]
public string ContactFirstName { get; set; }
Property Value
Type | Description
System.String |

ContactLastName

Declaration
[PropertyBitValue(16)]
public string ContactLastName { get; set; }
Property Value
Type | Description
System.String |

ContactPhone

Declaration
[PropertyBitValue(32)]
public string ContactPhone { get; set; }
Property Value
Type | Description
System.String |

Duration

Declaration
[PropertyBitValue(256)]
public TimeSpan Duration { get; set; }
Property Value
Type | Description
System.TimeSpan |

GenerateTimeBombs

Declaration
[PropertyBitValue(1024)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

InternalUseOnlyNotes

Declaration
[PropertyBitValue(4)]
public string InternalUseOnlyNotes { get; set; }
Property Value
Type | Description
System.String |

LeadObjid

Declaration
[PropertyBitValue(1)]
public int LeadObjid { get; set; }
Property Value
Type | Description
System.Int32 |

LogDate

Declaration
[PropertyBitValue(128)]
public DateTime LogDate { get; set; }
Property Value
Type | Description
System.DateTime |

Notes

Declaration
[PropertyBitValue(2)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(512)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class MoveActionItemSetup | fcSDK Documentation

Class MoveActionItemSetup

Inheritance
System.Object
MoveActionItemSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class MoveActionItemSetup

Constructors

MoveActionItemSetup(String, String)

Declaration
[ConstructorIndex(0)]
public MoveActionItemSetup(string actionItemIDNum, string newWipBin)
Parameters
Type | Name | Description
System.String | actionItemIDNum |
System.String | newWipBin |

Properties

ActionItemIDNum

Declaration
[PropertyBitValue(1)]
public string ActionItemIDNum { get; set; }
Property Value
Type | Description
System.String |

NewWipBin

Declaration
[PropertyBitValue(2)]
public string NewWipBin { get; set; }
Property Value
Type | Description
System.String |


Class MoveOpportunitySetup | fcSDK Documentation

Class MoveOpportunitySetup

Inheritance
System.Object
MoveOpportunitySetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class MoveOpportunitySetup

Constructors

MoveOpportunitySetup(String, String)

Declaration
[ConstructorIndex(0)]
public MoveOpportunitySetup(string opportunityIDNum, string newWipBin)
Parameters
Type | Name | Description
System.String | opportunityIDNum |
System.String | newWipBin |

Properties

NewWipBin

Declaration
[PropertyBitValue(2)]
public string NewWipBin { get; set; }
Property Value
Type | Description
System.String |

OpportunityIDNum

Declaration
[PropertyBitValue(1)]
public string OpportunityIDNum { get; set; }
Property Value
Type | Description
System.String |


Class MoveQuoteSetup | fcSDK Documentation

Class MoveQuoteSetup

Inheritance
System.Object
MoveQuoteSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class MoveQuoteSetup

Constructors

MoveQuoteSetup(String, String)

Declaration
[ConstructorIndex(0)]
public MoveQuoteSetup(string quoteIDNum, string newWipBin)
Parameters
Type | Name | Description
System.String | quoteIDNum |
System.String | newWipBin |

Properties

NewWipBin

Declaration
[PropertyBitValue(2)]
public string NewWipBin { get; set; }
Property Value
Type | Description
System.String |

QuoteIDNum

Declaration
[PropertyBitValue(1)]
public string QuoteIDNum { get; set; }
Property Value
Type | Description
System.String |


Class RejectActionItemSetup | fcSDK Documentation

Class RejectActionItemSetup

Inheritance
System.Object
RejectActionItemSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class RejectActionItemSetup

Constructors

RejectActionItemSetup(String)

Declaration
[ConstructorIndex(0)]
public RejectActionItemSetup(string actionItemIDNum)
Parameters
Type | Name | Description
System.String | actionItemIDNum |

Properties

ActionItemIDNum

Declaration
[PropertyBitValue(1)]
public string ActionItemIDNum { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

Notes

Declaration
[PropertyBitValue(8)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

RejectDate

Declaration
[PropertyBitValue(2)]
public DateTime RejectDate { get; set; }
Property Value
Type | Description
System.DateTime |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(4)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |


Class RejectOpportunitySetup | fcSDK Documentation

Class RejectOpportunitySetup

Inheritance
System.Object
RejectOpportunitySetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class RejectOpportunitySetup

Constructors

RejectOpportunitySetup(String)

Declaration
[ConstructorIndex(0)]
public RejectOpportunitySetup(string opportunityIDNum)
Parameters
Type | Name | Description
System.String | opportunityIDNum |

Properties

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

Notes

Declaration
[PropertyBitValue(8)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

OpportunityIDNum

Declaration
[PropertyBitValue(1)]
public string OpportunityIDNum { get; set; }
Property Value
Type | Description
System.String |

RejectDate

Declaration
[PropertyBitValue(2)]
public DateTime RejectDate { get; set; }
Property Value
Type | Description
System.DateTime |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(4)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |


Class RejectQuoteSetup | fcSDK Documentation

Class RejectQuoteSetup

Inheritance
System.Object
RejectQuoteSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class RejectQuoteSetup

Constructors

RejectQuoteSetup(String)

Declaration
[ConstructorIndex(0)]
public RejectQuoteSetup(string quoteIDNum)
Parameters
Type | Name | Description
System.String | quoteIDNum |

Properties

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

Notes

Declaration
[PropertyBitValue(8)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

QuoteIDNum

Declaration
[PropertyBitValue(1)]
public string QuoteIDNum { get; set; }
Property Value
Type | Description
System.String |

RejectDate

Declaration
[PropertyBitValue(2)]
public DateTime RejectDate { get; set; }
Property Value
Type | Description
System.DateTime |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(4)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |


Class ReopenOpportunitySetup | fcSDK Documentation

Class ReopenOpportunitySetup

Inheritance
System.Object
ReopenOpportunitySetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ReopenOpportunitySetup

Constructors

ReopenOpportunitySetup(String)

Declaration
[ConstructorIndex(0)]
public ReopenOpportunitySetup(string opportunityIDNum)
Parameters
Type | Name | Description
System.String | opportunityIDNum |

Properties

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

OpportunityIDNum

Declaration
[PropertyBitValue(1)]
public string OpportunityIDNum { get; set; }
Property Value
Type | Description
System.String |

ReopenDate

Declaration
[PropertyBitValue(8)]
public DateTime ReopenDate { get; set; }
Property Value
Type | Description
System.DateTime |

Status

Declaration
[PropertyBitValue(2)]
public string Status { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(4)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |


Class SalesToolkit | fcSDK Documentation

Class SalesToolkit

Inheritance
System.Object
ToolkitBase
SalesToolkitBase
SalesToolkit
Inherited Members
SalesToolkitBase._toolkit
SalesToolkitBase.ChangeOpportunityStage(String, OpportunityStage)
SalesToolkitBase.ChangeOpportunityStage(ChangeOpportunityStageSetup)
SalesToolkitBase.ImpersonatorUsername
ToolkitBase.NOW_DATE
ToolkitBase.CompatSession
ToolkitBase.WithTransaction<T>(Func<IDbTransaction, T>)
ToolkitBase.FCApplication
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class SalesToolkit : SalesToolkitBase

Constructors

SalesToolkit(ClarifySession)

Declaration
public SalesToolkit(ClarifySession session)
Parameters
Type | Name | Description
ClarifySession | session |

SalesToolkit(IFCApplication, IFCSession)

Declaration
public SalesToolkit(IFCApplication application, IFCSession session)
Parameters
Type | Name | Description
IFCApplication | application |
IFCSession | session |

Properties

ApplicationClock

Declaration
public IApplicationClock ApplicationClock { get; set; }
Property Value
Type | Description
IApplicationClock |

Methods

AcceptActionItem(AcceptActionItemSetup)

Declaration
public ToolkitResult AcceptActionItem(AcceptActionItemSetup setupParam)
Parameters
Type | Name | Description
AcceptActionItemSetup | setupParam |
Returns
Type | Description
ToolkitResult |

AcceptActionItem(AcceptActionItemSetup, IDbTransaction)

Declaration
public ToolkitResult AcceptActionItem(AcceptActionItemSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
AcceptActionItemSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

AcceptActionItem(String)

Declaration
public ToolkitResult AcceptActionItem(string actionItemIDNum)
Parameters
Type | Name | Description
System.String | actionItemIDNum |
Returns
Type | Description
ToolkitResult |

AcceptOpportunity(AcceptOpportunitySetup)

Declaration
public ToolkitResult AcceptOpportunity(AcceptOpportunitySetup setupParam)
Parameters
Type | Name | Description
AcceptOpportunitySetup | setupParam |
Returns
Type | Description
ToolkitResult |

AcceptOpportunity(AcceptOpportunitySetup, IDbTransaction)

Declaration
public ToolkitResult AcceptOpportunity(AcceptOpportunitySetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
AcceptOpportunitySetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

AcceptOpportunity(String)

Declaration
public ToolkitResult AcceptOpportunity(string opportunityIDNum)
Parameters
Type | Name | Description
System.String | opportunityIDNum |
Returns
Type | Description
ToolkitResult |

AcceptQuote(AcceptQuoteSetup)

Declaration
public ToolkitResult AcceptQuote(AcceptQuoteSetup setupParam)
Parameters
Type | Name | Description
AcceptQuoteSetup | setupParam |
Returns
Type | Description
ToolkitResult |

AcceptQuote(AcceptQuoteSetup, IDbTransaction)

Declaration
public ToolkitResult AcceptQuote(AcceptQuoteSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
AcceptQuoteSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

AcceptQuote(String)

Declaration
public ToolkitResult AcceptQuote(string quoteIDNum)
Parameters
Type | Name | Description
System.String | quoteIDNum |
Returns
Type | Description
ToolkitResult |

AssignActionItem(AssignActionItemSetup)

Declaration
public ToolkitResult AssignActionItem(AssignActionItemSetup setupParam)
Parameters
Type | Name | Description
AssignActionItemSetup | setupParam |
Returns
Type | Description
ToolkitResult |

AssignActionItem(AssignActionItemSetup, IDbTransaction)

Declaration
public ToolkitResult AssignActionItem(AssignActionItemSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
AssignActionItemSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

AssignActionItem(String)

Declaration
public ToolkitResult AssignActionItem(string actionItemIDNum)
Parameters
Type | Name | Description
System.String | actionItemIDNum |
Returns
Type | Description
ToolkitResult |

AssignLead(AssignLeadSetup)

Declaration
public ToolkitResult AssignLead(AssignLeadSetup setupParam)
Parameters
Type | Name | Description
AssignLeadSetup | setupParam |
Returns
Type | Description
ToolkitResult |

AssignLead(AssignLeadSetup, IDbTransaction)

Declaration
public ToolkitResult AssignLead(AssignLeadSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
AssignLeadSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

AssignLead(Int32, String)

Declaration
public ToolkitResult AssignLead(int leadObjid, string newOwner)
Parameters
Type | Name | Description
System.Int32 | leadObjid |
System.String | newOwner |
Returns
Type | Description
ToolkitResult |

AssignOpportunity(AssignOpportunitySetup)

Declaration
public ToolkitResult AssignOpportunity(AssignOpportunitySetup setupParam)
Parameters
Type | Name | Description
AssignOpportunitySetup | setupParam |
Returns
Type | Description
ToolkitResult |

AssignOpportunity(AssignOpportunitySetup, IDbTransaction)

Declaration
public ToolkitResult AssignOpportunity(AssignOpportunitySetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
AssignOpportunitySetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

AssignOpportunity(String)

Declaration
public ToolkitResult AssignOpportunity(string opportunityIDNum)
Parameters
Type | Name | Description
System.String | opportunityIDNum |
Returns
Type | Description
ToolkitResult |

AssignQuote(AssignQuoteSetup)

Declaration
public ToolkitResult AssignQuote(AssignQuoteSetup setupParam)
Parameters
Type | Name | Description
AssignQuoteSetup | setupParam |
Returns
Type | Description
ToolkitResult |

AssignQuote(AssignQuoteSetup, IDbTransaction)

Declaration
public ToolkitResult AssignQuote(AssignQuoteSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
AssignQuoteSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

AssignQuote(String)

Declaration
public ToolkitResult AssignQuote(string quoteIDNum)
Parameters
Type | Name | Description
System.String | quoteIDNum |
Returns
Type | Description
ToolkitResult |

ChangeActionItemCondition(ChangeActionItemConditionSetup)

Declaration
public ToolkitResult ChangeActionItemCondition(ChangeActionItemConditionSetup setupParam)
Parameters
Type | Name | Description
ChangeActionItemConditionSetup | setupParam |
Returns
Type | Description
ToolkitResult |

ChangeActionItemCondition(ChangeActionItemConditionSetup, IDbTransaction)

Declaration
public ToolkitResult ChangeActionItemCondition(ChangeActionItemConditionSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
ChangeActionItemConditionSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

ChangeActionItemCondition(String, String)

Declaration
public ToolkitResult ChangeActionItemCondition(string actionItemIDNum, string newcondition)
Parameters
Type | Name | Description
System.String | actionItemIDNum |
System.String | newcondition |
Returns
Type | Description
ToolkitResult |

ChangeActionItemStatus(ChangeActionItemStatusSetup)

Declaration
public ToolkitResult ChangeActionItemStatus(ChangeActionItemStatusSetup setupParam)
Parameters
Type | Name | Description
ChangeActionItemStatusSetup | setupParam |
Returns
Type | Description
ToolkitResult |

ChangeActionItemStatus(ChangeActionItemStatusSetup, IDbTransaction)

Declaration
public ToolkitResult ChangeActionItemStatus(ChangeActionItemStatusSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
ChangeActionItemStatusSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

ChangeActionItemStatus(String)

Declaration
public ToolkitResult ChangeActionItemStatus(string actionItemIDNum)
Parameters
Type | Name | Description
System.String | actionItemIDNum |
Returns
Type | Description
ToolkitResult |

ChangeOpportunityStatus(ChangeOpportunityStatusSetup)

Declaration
public ToolkitResult ChangeOpportunityStatus(ChangeOpportunityStatusSetup setupParam)
Parameters
Type | Name | Description
ChangeOpportunityStatusSetup | setupParam |
Returns
Type | Description
ToolkitResult |

ChangeOpportunityStatus(ChangeOpportunityStatusSetup, IDbTransaction)

Declaration
public ToolkitResult ChangeOpportunityStatus(ChangeOpportunityStatusSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
ChangeOpportunityStatusSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

ChangeOpportunityStatus(String)

Declaration
public ToolkitResult ChangeOpportunityStatus(string opportunityIDNum)
Parameters
Type | Name | Description
System.String | opportunityIDNum |
Returns
Type | Description
ToolkitResult |

ChangeQuoteStatus(ChangeQuoteStatusSetup)

Declaration
public ToolkitResult ChangeQuoteStatus(ChangeQuoteStatusSetup setupParam)
Parameters
Type | Name | Description
ChangeQuoteStatusSetup | setupParam |
Returns
Type | Description
ToolkitResult |

ChangeQuoteStatus(ChangeQuoteStatusSetup, IDbTransaction)

Declaration
public ToolkitResult ChangeQuoteStatus(ChangeQuoteStatusSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
ChangeQuoteStatusSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

ChangeQuoteStatus(String)

Declaration
public ToolkitResult ChangeQuoteStatus(string quoteIDNum)
Parameters
Type | Name | Description
System.String | quoteIDNum |
Returns
Type | Description
ToolkitResult |

CloseOpportunity(CloseOpportunitySetup)

Declaration
public ToolkitResult CloseOpportunity(CloseOpportunitySetup setupParam)
Parameters
Type | Name | Description
CloseOpportunitySetup | setupParam |
Returns
Type | Description
ToolkitResult |

CloseOpportunity(CloseOpportunitySetup, IDbTransaction)

Declaration
public ToolkitResult CloseOpportunity(CloseOpportunitySetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CloseOpportunitySetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CloseOpportunity(String)

Declaration
public ToolkitResult CloseOpportunity(string opportunityIDNum)
Parameters
Type | Name | Description
System.String | opportunityIDNum |
Returns
Type | Description
ToolkitResult |

CreateActionItem()

Declaration
public ToolkitResult CreateActionItem()
Returns
Type | Description
ToolkitResult |

CreateActionItem(CreateActionItemSetup)

Declaration
public ToolkitResult CreateActionItem(CreateActionItemSetup setupParam)
Parameters
Type | Name | Description
CreateActionItemSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreateActionItem(CreateActionItemSetup, IDbTransaction)

Declaration
public ToolkitResult CreateActionItem(CreateActionItemSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateActionItemSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreateLead(CreateLeadSetup)

Declaration
public ToolkitResult CreateLead(CreateLeadSetup setupParam)
Parameters
Type | Name | Description
CreateLeadSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreateLead(CreateLeadSetup, IDbTransaction)

Declaration
public ToolkitResult CreateLead(CreateLeadSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateLeadSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreateLead(String, String, String, LeadSiteType, String)

Declaration
public ToolkitResult CreateLead(string state, string country, string timeZone, LeadSiteType siteType, string leadSource)
Parameters
Type | Name | Description
System.String | state |
System.String | country |
System.String | timeZone |
LeadSiteType | siteType |
System.String | leadSource |
Returns
Type | Description
ToolkitResult |

CreateOpportunity(CreateOpportunitySetup)

Declaration
public ToolkitResult CreateOpportunity(CreateOpportunitySetup setupParam)
Parameters
Type | Name | Description
CreateOpportunitySetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreateOpportunity(CreateOpportunitySetup, IDbTransaction)

Declaration
public ToolkitResult CreateOpportunity(CreateOpportunitySetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateOpportunitySetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreateOpportunity(String, String, Single)

Declaration
public ToolkitResult CreateOpportunity(string opportunityName, string salesStage, float probability)
Parameters
Type | Name | Description
System.String | opportunityName |
System.String | salesStage |
System.Single | probability |
Returns
Type | Description
ToolkitResult |

CreateQuote(CreateQuoteSetup)

Declaration
public ToolkitResult CreateQuote(CreateQuoteSetup setupParam)
Parameters
Type | Name | Description
CreateQuoteSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreateQuote(CreateQuoteSetup, IDbTransaction)

Declaration
public ToolkitResult CreateQuote(CreateQuoteSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateQuoteSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreateQuote(String)

Declaration
public ToolkitResult CreateQuote(string quoteTitle)
Parameters
Type | Name | Description
System.String | quoteTitle |
Returns
Type | Description
ToolkitResult |

CreateQuoteLineItem(CreateQuoteLineItemSetup)

Declaration
public ToolkitResult CreateQuoteLineItem(CreateQuoteLineItemSetup setupParam)
Parameters
Type | Name | Description
CreateQuoteLineItemSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreateQuoteLineItem(CreateQuoteLineItemSetup, IDbTransaction)

Declaration
public ToolkitResult CreateQuoteLineItem(CreateQuoteLineItemSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateQuoteLineItemSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreateQuoteLineItem(String, String, String, String, Int32, String, Int32)

Declaration
public ToolkitResult CreateQuoteLineItem(string contractIDNum, string partNumber, string partDomain, string partRevision, int quantity, string priceSchedule, int parentLineItemObjid)
Parameters
Type | Name | Description
System.String | contractIDNum |
System.String | partNumber |
System.String | partDomain |
System.String | partRevision |
System.Int32 | quantity |
System.String | priceSchedule |
System.Int32 | parentLineItemObjid |
Returns
Type | Description
ToolkitResult |

CreateQuoteLineItem(String, String, String, String, String, String, Int32)

Declaration
public ToolkitResult CreateQuoteLineItem(string contractIDNum, string partNumber, string partDomain, string partRevision, string priceSchedule, string serialNumber, int parentLineItemObjid)
Parameters
Type | Name | Description
System.String | contractIDNum |
System.String | partNumber |
System.String | partDomain |
System.String | partRevision |
System.String | priceSchedule |
System.String | serialNumber |
System.Int32 | parentLineItemObjid |
Returns
Type | Description
ToolkitResult |

DispatchActionItem(DispatchActionItemSetup)

Declaration
public ToolkitResult DispatchActionItem(DispatchActionItemSetup setupParam)
Parameters
Type | Name | Description
DispatchActionItemSetup | setupParam |
Returns
Type | Description
ToolkitResult |

DispatchActionItem(DispatchActionItemSetup, IDbTransaction)

Declaration
public ToolkitResult DispatchActionItem(DispatchActionItemSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
DispatchActionItemSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

DispatchActionItem(String, String)

Declaration
public ToolkitResult DispatchActionItem(string actionItemIDNum, string queue)
Parameters
Type | Name | Description
System.String | actionItemIDNum |
System.String | queue |
Returns
Type | Description
ToolkitResult |

DispatchOpportunity(DispatchOpportunitySetup)

Declaration
public ToolkitResult DispatchOpportunity(DispatchOpportunitySetup setupParam)
Parameters
Type | Name | Description
DispatchOpportunitySetup | setupParam |
Returns
Type | Description
ToolkitResult |

DispatchOpportunity(DispatchOpportunitySetup, IDbTransaction)

Declaration
public ToolkitResult DispatchOpportunity(DispatchOpportunitySetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
DispatchOpportunitySetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

DispatchOpportunity(String, String)

Declaration
public ToolkitResult DispatchOpportunity(string opportunityIDNum, string queue)
Parameters
Type | Name | Description
System.String | opportunityIDNum |
System.String | queue |
Returns
Type | Description
ToolkitResult |

DispatchQuote(DispatchQuoteSetup)

Declaration
public ToolkitResult DispatchQuote(DispatchQuoteSetup setupParam)
Parameters
Type | Name | Description
DispatchQuoteSetup | setupParam |
Returns
Type | Description
ToolkitResult |

DispatchQuote(DispatchQuoteSetup, IDbTransaction)

Declaration
public ToolkitResult DispatchQuote(DispatchQuoteSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
DispatchQuoteSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

DispatchQuote(String, String)

Declaration
public ToolkitResult DispatchQuote(string quoteIDNum, string queue)
Parameters
Type | Name | Description
System.String | quoteIDNum |
System.String | queue |
Returns
Type | Description
ToolkitResult |

ForwardActionItem(ForwardActionItemSetup)

Declaration
public ToolkitResult ForwardActionItem(ForwardActionItemSetup setupParam)
Parameters
Type | Name | Description
ForwardActionItemSetup | setupParam |
Returns
Type | Description
ToolkitResult |

ForwardActionItem(ForwardActionItemSetup, IDbTransaction)

Declaration
public ToolkitResult ForwardActionItem(ForwardActionItemSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
ForwardActionItemSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

ForwardActionItem(String, String)

Declaration
public ToolkitResult ForwardActionItem(string actionItemIDNum, string newQueue)
Parameters
Type | Name | Description
System.String | actionItemIDNum |
System.String | newQueue |
Returns
Type | Description
ToolkitResult |

ForwardOpportunity(ForwardOpportunitySetup)

Declaration
public ToolkitResult ForwardOpportunity(ForwardOpportunitySetup setupParam)
Parameters
Type | Name | Description
ForwardOpportunitySetup | setupParam |
Returns
Type | Description
ToolkitResult |

ForwardOpportunity(ForwardOpportunitySetup, IDbTransaction)

Declaration
public ToolkitResult ForwardOpportunity(ForwardOpportunitySetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
ForwardOpportunitySetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

ForwardOpportunity(String, String)

Declaration
public ToolkitResult ForwardOpportunity(string opportunityIDNum, string newQueue)
Parameters
Type | Name | Description
System.String | opportunityIDNum |
System.String | newQueue |
Returns
Type | Description
ToolkitResult |

ForwardQuote(ForwardQuoteSetup)

Declaration
public ToolkitResult ForwardQuote(ForwardQuoteSetup setupParam)
Parameters
Type | Name | Description
ForwardQuoteSetup | setupParam |
Returns
Type | Description
ToolkitResult |

ForwardQuote(ForwardQuoteSetup, IDbTransaction)

Declaration
public ToolkitResult ForwardQuote(ForwardQuoteSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
ForwardQuoteSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

ForwardQuote(String, String)

Declaration
public ToolkitResult ForwardQuote(string quoteIDNum, string newQueue)
Parameters
Type | Name | Description
System.String | quoteIDNum |
System.String | newQueue |
Returns
Type | Description
ToolkitResult |

LogActionItemEmailIn(LogActionItemEmailInSetup)

Declaration
public ToolkitResult LogActionItemEmailIn(LogActionItemEmailInSetup setup)
Parameters
Type | Name | Description
LogActionItemEmailInSetup | setup |
Returns
Type | Description
ToolkitResult |

LogActionItemEmailIn(LogActionItemEmailInSetup, IDbTransaction)

Declaration
public ToolkitResult LogActionItemEmailIn(LogActionItemEmailInSetup setup, IDbTransaction transaction)
Parameters
Type | Name | Description
LogActionItemEmailInSetup | setup |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

LogLeadNote(LogLeadNoteSetup)

Declaration
public ToolkitResult LogLeadNote(LogLeadNoteSetup setupParam)
Parameters
Type | Name | Description
LogLeadNoteSetup | setupParam |
Returns
Type | Description
ToolkitResult |

LogLeadNote(LogLeadNoteSetup, IDbTransaction)

Declaration
public ToolkitResult LogLeadNote(LogLeadNoteSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
LogLeadNoteSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

LogLeadNote(Int32)

Declaration
public ToolkitResult LogLeadNote(int leadObjid)
Parameters
Type | Name | Description
System.Int32 | leadObjid |
Returns
Type | Description
ToolkitResult |

LogLeadPhone(LogLeadPhoneSetup)

Declaration
public ToolkitResult LogLeadPhone(LogLeadPhoneSetup setupParam)
Parameters
Type | Name | Description
LogLeadPhoneSetup | setupParam |
Returns
Type | Description
ToolkitResult |

LogLeadPhone(LogLeadPhoneSetup, IDbTransaction)

Declaration
public ToolkitResult LogLeadPhone(LogLeadPhoneSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
LogLeadPhoneSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

LogLeadPhone(Int32, String, String, String, TimeSpan)

Declaration
public ToolkitResult LogLeadPhone(int leadObjid, string contactFirstName, string contactLastName, string contactPhone, TimeSpan duration)
Parameters
Type | Name | Description
System.Int32 | leadObjid |
System.String | contactFirstName |
System.String | contactLastName |
System.String | contactPhone |
System.TimeSpan | duration |
Returns
Type | Description
ToolkitResult |

MoveActionItem(MoveActionItemSetup)

Declaration
public ToolkitResult MoveActionItem(MoveActionItemSetup setupParam)
Parameters
Type | Name | Description
MoveActionItemSetup | setupParam |
Returns
Type | Description
ToolkitResult |

MoveActionItem(MoveActionItemSetup, IDbTransaction)

Declaration
public ToolkitResult MoveActionItem(MoveActionItemSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
MoveActionItemSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

MoveActionItem(String, String)

Declaration
public ToolkitResult MoveActionItem(string actionItemIDNum, string newWipBin)
Parameters
Type | Name | Description
System.String | actionItemIDNum |
System.String | newWipBin |
Returns
Type | Description
ToolkitResult |

MoveOpportunity(MoveOpportunitySetup)

Declaration
public ToolkitResult MoveOpportunity(MoveOpportunitySetup setupParam)
Parameters
Type | Name | Description
MoveOpportunitySetup | setupParam |
Returns
Type | Description
ToolkitResult |

MoveOpportunity(MoveOpportunitySetup, IDbTransaction)

Declaration
public ToolkitResult MoveOpportunity(MoveOpportunitySetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
MoveOpportunitySetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

MoveOpportunity(String, String)

Declaration
public ToolkitResult MoveOpportunity(string opportunityIDNum, string newWipBin)
Parameters
Type | Name | Description
System.String | opportunityIDNum |
System.String | newWipBin |
Returns
Type | Description
ToolkitResult |

MoveQuote(MoveQuoteSetup)

Declaration
public ToolkitResult MoveQuote(MoveQuoteSetup setupParam)
Parameters
Type | Name | Description
MoveQuoteSetup | setupParam |
Returns
Type | Description
ToolkitResult |

MoveQuote(MoveQuoteSetup, IDbTransaction)

Declaration
public ToolkitResult MoveQuote(MoveQuoteSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
MoveQuoteSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

MoveQuote(String, String)

Declaration
public ToolkitResult MoveQuote(string quoteIDNum, string newWipBin)
Parameters
Type | Name | Description
System.String | quoteIDNum |
System.String | newWipBin |
Returns
Type | Description
ToolkitResult |

RejectActionItem(RejectActionItemSetup)

Declaration
public ToolkitResult RejectActionItem(RejectActionItemSetup setupParam)
Parameters
Type | Name | Description
RejectActionItemSetup | setupParam |
Returns
Type | Description
ToolkitResult |

RejectActionItem(RejectActionItemSetup, IDbTransaction)

Declaration
public ToolkitResult RejectActionItem(RejectActionItemSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
RejectActionItemSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

RejectActionItem(String)

Declaration
public ToolkitResult RejectActionItem(string actionItemIDNum)
Parameters
Type | Name | Description
System.String | actionItemIDNum |
Returns
Type | Description
ToolkitResult |

RejectOpportunity(RejectOpportunitySetup)

Declaration
public ToolkitResult RejectOpportunity(RejectOpportunitySetup setupParam)
Parameters
Type | Name | Description
RejectOpportunitySetup | setupParam |
Returns
Type | Description
ToolkitResult |

RejectOpportunity(RejectOpportunitySetup, IDbTransaction)

Declaration
public ToolkitResult RejectOpportunity(RejectOpportunitySetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
RejectOpportunitySetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

RejectOpportunity(String)

Declaration
public ToolkitResult RejectOpportunity(string opportunityIDNum)
Parameters
Type | Name | Description
System.String | opportunityIDNum |
Returns
Type | Description
ToolkitResult |

RejectQuote(RejectQuoteSetup)

Declaration
public ToolkitResult RejectQuote(RejectQuoteSetup setupParam)
Parameters
Type | Name | Description
RejectQuoteSetup | setupParam |
Returns
Type | Description
ToolkitResult |

RejectQuote(RejectQuoteSetup, IDbTransaction)

Declaration
public ToolkitResult RejectQuote(RejectQuoteSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
RejectQuoteSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

RejectQuote(String)

Declaration
public ToolkitResult RejectQuote(string quoteIDNum)
Parameters
Type | Name | Description
System.String | quoteIDNum |
Returns
Type | Description
ToolkitResult |

ReopenOpportunity(ReopenOpportunitySetup)

Declaration
public ToolkitResult ReopenOpportunity(ReopenOpportunitySetup setupParam)
Parameters
Type | Name | Description
ReopenOpportunitySetup | setupParam |
Returns
Type | Description
ToolkitResult |

ReopenOpportunity(ReopenOpportunitySetup, IDbTransaction)

Declaration
public ToolkitResult ReopenOpportunity(ReopenOpportunitySetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
ReopenOpportunitySetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

ReopenOpportunity(String)

Declaration
public ToolkitResult ReopenOpportunity(string opportunityIDNum)
Parameters
Type | Name | Description
System.String | opportunityIDNum |
Returns
Type | Description
ToolkitResult |

UpdateActionItem(UpdateActionItemSetup)

Declaration
public ToolkitResult UpdateActionItem(UpdateActionItemSetup setupParam)
Parameters
Type | Name | Description
UpdateActionItemSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdateActionItem(UpdateActionItemSetup, IDbTransaction)

Declaration
public ToolkitResult UpdateActionItem(UpdateActionItemSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdateActionItemSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UpdateLead(UpdateLeadSetup)

Declaration
public ToolkitResult UpdateLead(UpdateLeadSetup setupParam)
Parameters
Type | Name | Description
UpdateLeadSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdateLead(UpdateLeadSetup, IDbTransaction)

Declaration
public ToolkitResult UpdateLead(UpdateLeadSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdateLeadSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UpdateOpportunity(UpdateOpportunitySetup)

Declaration
public ToolkitResult UpdateOpportunity(UpdateOpportunitySetup setupParam)
Parameters
Type | Name | Description
UpdateOpportunitySetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdateOpportunity(UpdateOpportunitySetup, IDbTransaction)

Declaration
public ToolkitResult UpdateOpportunity(UpdateOpportunitySetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdateOpportunitySetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

YankActionItem(YankActionItemSetup)

Declaration
public ToolkitResult YankActionItem(YankActionItemSetup setupParam)
Parameters
Type | Name | Description
YankActionItemSetup | setupParam |
Returns
Type | Description
ToolkitResult |

YankActionItem(YankActionItemSetup, IDbTransaction)

Declaration
public ToolkitResult YankActionItem(YankActionItemSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
YankActionItemSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

YankActionItem(String)

Declaration
public ToolkitResult YankActionItem(string actionItemIDNum)
Parameters
Type | Name | Description
System.String | actionItemIDNum |
Returns
Type | Description
ToolkitResult |

YankOpportunity(YankOpportunitySetup)

Declaration
public ToolkitResult YankOpportunity(YankOpportunitySetup setupParam)
Parameters
Type | Name | Description
YankOpportunitySetup | setupParam |
Returns
Type | Description
ToolkitResult |

YankOpportunity(YankOpportunitySetup, IDbTransaction)

Declaration
public ToolkitResult YankOpportunity(YankOpportunitySetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
YankOpportunitySetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

YankOpportunity(String)

Declaration
public ToolkitResult YankOpportunity(string opportunityIDNum)
Parameters
Type | Name | Description
System.String | opportunityIDNum |
Returns
Type | Description
ToolkitResult |

YankQuote(YankQuoteSetup)

Declaration
public ToolkitResult YankQuote(YankQuoteSetup setupParam)
Parameters
Type | Name | Description
YankQuoteSetup | setupParam |
Returns
Type | Description
ToolkitResult |

YankQuote(YankQuoteSetup, IDbTransaction)

Declaration
public ToolkitResult YankQuote(YankQuoteSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
YankQuoteSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

YankQuote(String)

Declaration
public ToolkitResult YankQuote(string quoteIDNum)
Parameters
Type | Name | Description
System.String | quoteIDNum |
Returns
Type | Description
ToolkitResult |


Class SalesToolkitBase | fcSDK Documentation

Class SalesToolkitBase

Inheritance
System.Object
ToolkitBase
SalesToolkitBase
SalesToolkit
Inherited Members
ToolkitBase.NOW_DATE
ToolkitBase.CompatSession
ToolkitBase.WithTransaction<T>(Func<IDbTransaction, T>)
ToolkitBase.FCApplication
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public abstract class SalesToolkitBase : ToolkitBase

Constructors

SalesToolkitBase(ClarifySession)

Declaration
public SalesToolkitBase(ClarifySession sess)
Parameters
Type | Name | Description
ClarifySession | sess |

SalesToolkitBase(IFCApplication, IFCSession)

Declaration
public SalesToolkitBase(IFCApplication app, IFCSession sess)
Parameters
Type | Name | Description
IFCApplication | app |
IFCSession | sess |

Fields

_toolkit

Declaration
protected FCSFA _toolkit
Field Value
Type | Description
FCSFA |

Properties

ImpersonatorUsername

Declaration
public string ImpersonatorUsername { get; set; }
Property Value
Type | Description
System.String |

Methods

ChangeOpportunityStage(ChangeOpportunityStageSetup)

Declaration
public ToolkitResult ChangeOpportunityStage(ChangeOpportunityStageSetup setupParam)
Parameters
Type | Name | Description
ChangeOpportunityStageSetup | setupParam |
Returns
Type | Description
ToolkitResult |

ChangeOpportunityStage(String, OpportunityStage)

Declaration
public ToolkitResult ChangeOpportunityStage(string opportunityIDNum, OpportunityStage stage)
Parameters
Type | Name | Description
System.String | opportunityIDNum |
OpportunityStage | stage |
Returns
Type | Description
ToolkitResult |


Class UpdateActionItemSetup | fcSDK Documentation

Class UpdateActionItemSetup

Inheritance
System.Object
UpdateActionItemSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdateActionItemSetup

Constructors

UpdateActionItemSetup(String)

Declaration
[ConstructorIndex(0)]
public UpdateActionItemSetup(string actionItemIDNum)
Parameters
Type | Name | Description
System.String | actionItemIDNum |

Properties

AccountName

Declaration
[PropertyBitValue(64)]
public string AccountName { get; set; }
Property Value
Type | Description
System.String |

ActionItemIDNum

Declaration
[PropertyBitValue(1)]
public string ActionItemIDNum { get; set; }
Property Value
Type | Description
System.String |

AdditionalFields

Declaration
[PropertyBitValue(131072)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

CompleteDate

Declaration
[PropertyBitValue(16384)]
public DateTime CompleteDate { get; set; }
Property Value
Type | Description
System.DateTime |

ContactFirstName

Declaration
[PropertyBitValue(8)]
public string ContactFirstName { get; set; }
Property Value
Type | Description
System.String |

ContactLastName

Declaration
[PropertyBitValue(16)]
public string ContactLastName { get; set; }
Property Value
Type | Description
System.String |

ContactPhone

Declaration
[PropertyBitValue(32)]
public string ContactPhone { get; set; }
Property Value
Type | Description
System.String |

DueDate

Declaration
[PropertyBitValue(8192)]
public DateTime DueDate { get; set; }
Property Value
Type | Description
System.DateTime |

LeadFirstName

Declaration
[PropertyBitValue(128)]
public string LeadFirstName { get; set; }
Property Value
Type | Description
System.String |

LeadLastName

Declaration
[PropertyBitValue(256)]
public string LeadLastName { get; set; }
Property Value
Type | Description
System.String |

Notes

Declaration
[PropertyBitValue(4)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

OpportunityIDNum

Declaration
[PropertyBitValue(512)]
public string OpportunityIDNum { get; set; }
Property Value
Type | Description
System.String |

Priority

Declaration
[PropertyBitValue(2048)]
public string Priority { get; set; }
Property Value
Type | Description
System.String |

StartDate

Declaration
[PropertyBitValue(4096)]
public DateTime StartDate { get; set; }
Property Value
Type | Description
System.DateTime |

Status

Declaration
[PropertyBitValue(32768)]
public string Status { get; set; }
Property Value
Type | Description
System.String |

TaskType

Declaration
[PropertyBitValue(1024)]
public string TaskType { get; set; }
Property Value
Type | Description
System.String |

Title

Declaration
[PropertyBitValue(2)]
public string Title { get; set; }
Property Value
Type | Description
System.String |

UpdateDate

Declaration
[PropertyBitValue(65536)]
public DateTime UpdateDate { get; set; }
Property Value
Type | Description
System.DateTime |


Class UpdateLeadSetup | fcSDK Documentation

Class UpdateLeadSetup

Inheritance
System.Object
UpdateLeadSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdateLeadSetup

Constructors

UpdateLeadSetup(Int32)

Declaration
[ConstructorIndex(0)]
public UpdateLeadSetup(int leadObjid)
Parameters
Type | Name | Description
System.Int32 | leadObjid |

Properties

AdditionalFields

Declaration
[PropertyBitValue(8388608)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

Address

Declaration
[PropertyBitValue(32)]
public string Address { get; set; }
Property Value
Type | Description
System.String |

Address2

Declaration
[PropertyBitValue(64)]
public string Address2 { get; set; }
Property Value
Type | Description
System.String |

City

Declaration
[PropertyBitValue(128)]
public string City { get; set; }
Property Value
Type | Description
System.String |

CompanyName

Declaration
[PropertyBitValue(16384)]
public string CompanyName { get; set; }
Property Value
Type | Description
System.String |

ContactFirstName

Declaration
[PropertyBitValue(2)]
public string ContactFirstName { get; set; }
Property Value
Type | Description
System.String |

ContactLastName

Declaration
[PropertyBitValue(4)]
public string ContactLastName { get; set; }
Property Value
Type | Description
System.String |

ContactPhone

Declaration
[PropertyBitValue(8)]
public string ContactPhone { get; set; }
Property Value
Type | Description
System.String |

ContactRole

Declaration
[PropertyBitValue(262144)]
public string ContactRole { get; set; }
Property Value
Type | Description
System.String |

Country

Declaration
[PropertyBitValue(1024)]
public string Country { get; set; }
Property Value
Type | Description
System.String |

CreateDate

Declaration
[PropertyBitValue(2097152)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

Email

Declaration
[PropertyBitValue(4096)]
public string Email { get; set; }
Property Value
Type | Description
System.String |

Fax

Declaration
[PropertyBitValue(16)]
public string Fax { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(4194304)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

LeadObjid

Declaration
[PropertyBitValue(1)]
public int LeadObjid { get; set; }
Property Value
Type | Description
System.Int32 |

LeadSource

Declaration
[PropertyBitValue(524288)]
public string LeadSource { get; set; }
Property Value
Type | Description
System.String |

PostalCode

Declaration
[PropertyBitValue(512)]
public string PostalCode { get; set; }
Property Value
Type | Description
System.String |

Rating

Declaration
[PropertyBitValue(131072)]
public string Rating { get; set; }
Property Value
Type | Description
System.String |

SiteName

Declaration
[PropertyBitValue(32768)]
public string SiteName { get; set; }
Property Value
Type | Description
System.String |

SiteType

Declaration
[PropertyBitValue(65536)]
public LeadSiteType SiteType { get; set; }
Property Value
Type | Description
LeadSiteType |

State

Declaration
[PropertyBitValue(256)]
public string State { get; set; }
Property Value
Type | Description
System.String |

TimeZone

Declaration
[PropertyBitValue(2048)]
public string TimeZone { get; set; }
Property Value
Type | Description
System.String |

Title

Declaration
[PropertyBitValue(8192)]
public string Title { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(1048576)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class UpdateOpportunitySetup | fcSDK Documentation

Class UpdateOpportunitySetup

Inheritance
System.Object
UpdateOpportunitySetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdateOpportunitySetup

Constructors

UpdateOpportunitySetup(String)

Declaration
[ConstructorIndex(0)]
public UpdateOpportunitySetup(string opportunityIDNum)
Parameters
Type | Name | Description
System.String | opportunityIDNum |

Properties

AccountIDNum

Declaration
[PropertyBitValue(4)]
public string AccountIDNum { get; set; }
Property Value
Type | Description
System.String |

AdditionalFields

Declaration
[PropertyBitValue(65536)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

Amount

Declaration
[PropertyBitValue(128)]
public decimal Amount { get; set; }
Property Value
Type | Description
System.Decimal |

CloseDate

Declaration
[PropertyBitValue(256)]
public DateTime CloseDate { get; set; }
Property Value
Type | Description
System.DateTime |

ContactFirstName

Declaration
[PropertyBitValue(8)]
public string ContactFirstName { get; set; }
Property Value
Type | Description
System.String |

ContactLastName

Declaration
[PropertyBitValue(16)]
public string ContactLastName { get; set; }
Property Value
Type | Description
System.String |

ContactPhone

Declaration
[PropertyBitValue(32)]
public string ContactPhone { get; set; }
Property Value
Type | Description
System.String |

Currency

Declaration
[PropertyBitValue(1024)]
public string Currency { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(32768)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

LeadSource

Declaration
[PropertyBitValue(512)]
public string LeadSource { get; set; }
Property Value
Type | Description
System.String |

OpportunityIDNum

Declaration
[PropertyBitValue(1)]
public string OpportunityIDNum { get; set; }
Property Value
Type | Description
System.String |

OpportunityName

Declaration
[PropertyBitValue(2)]
public string OpportunityName { get; set; }
Property Value
Type | Description
System.String |

Probability

Declaration
[PropertyBitValue(2048)]
public float Probability { get; set; }
Property Value
Type | Description
System.Single |

Process

Declaration
[PropertyBitValue(4096)]
public string Process { get; set; }
Property Value
Type | Description
System.String |

Territory

Declaration
[PropertyBitValue(64)]
public string Territory { get; set; }
Property Value
Type | Description
System.String |

UpdateDate

Declaration
[PropertyBitValue(8192)]
public DateTime UpdateDate { get; set; }
Property Value
Type | Description
System.DateTime |

UserName

Declaration
[PropertyBitValue(16384)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class YankActionItemSetup | fcSDK Documentation

Class YankActionItemSetup

Inheritance
System.Object
YankActionItemSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class YankActionItemSetup

Constructors

YankActionItemSetup(String)

Declaration
[ConstructorIndex(0)]
public YankActionItemSetup(string actionItemIDNum)
Parameters
Type | Name | Description
System.String | actionItemIDNum |

Properties

ActionItemIDNum

Declaration
[PropertyBitValue(1)]
public string ActionItemIDNum { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(16)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(2)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |

YankDate

Declaration
[PropertyBitValue(4)]
public DateTime YankDate { get; set; }
Property Value
Type | Description
System.DateTime |


Class YankOpportunitySetup | fcSDK Documentation

Class YankOpportunitySetup

Inheritance
System.Object
YankOpportunitySetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class YankOpportunitySetup

Constructors

YankOpportunitySetup(String)

Declaration
[ConstructorIndex(0)]
public YankOpportunitySetup(string opportunityIDNum)
Parameters
Type | Name | Description
System.String | opportunityIDNum |

Properties

GenerateTimeBombs

Declaration
[PropertyBitValue(16)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

OpportunityIDNum

Declaration
[PropertyBitValue(1)]
public string OpportunityIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(2)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |

YankDate

Declaration
[PropertyBitValue(4)]
public DateTime YankDate { get; set; }
Property Value
Type | Description
System.DateTime |


Class YankQuoteSetup | fcSDK Documentation

Class YankQuoteSetup

Inheritance
System.Object
YankQuoteSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Sales
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class YankQuoteSetup

Constructors

YankQuoteSetup(String)

Declaration
[ConstructorIndex(0)]
public YankQuoteSetup(string quoteIDNum)
Parameters
Type | Name | Description
System.String | quoteIDNum |

Properties

GenerateTimeBombs

Declaration
[PropertyBitValue(16)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

QuoteIDNum

Declaration
[PropertyBitValue(1)]
public string QuoteIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(2)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |

YankDate

Declaration
[PropertyBitValue(4)]
public DateTime YankDate { get; set; }
Property Value
Type | Description
System.DateTime |


Class SimplifiedAdditionalField | fcSDK Documentation

Class SimplifiedAdditionalField

Inheritance
System.Object
SimplifiedAdditionalField
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class SimplifiedAdditionalField

Constructors

SimplifiedAdditionalField(String, Object)

Declaration
public SimplifiedAdditionalField(string fieldName, object fieldValue)
Parameters
Type | Name | Description
System.String | fieldName |
System.Object | fieldValue |

Properties

FieldName

Declaration
public string FieldName { get; }
Property Value
Type | Description
System.String |

FieldValue

Declaration
public object FieldValue { get; }
Property Value
Type | Description
System.Object |


Class SimplifiedAdditionalFields | fcSDK Documentation

Class SimplifiedAdditionalFields

Inheritance
System.Object
System.Collections.Generic.List<SimplifiedAdditionalField>
SimplifiedAdditionalFields
Implements
System.Collections.Generic.IList<SimplifiedAdditionalField>
System.Collections.Generic.ICollection<SimplifiedAdditionalField>
System.Collections.IList
System.Collections.ICollection
System.Collections.Generic.IReadOnlyList<SimplifiedAdditionalField>
System.Collections.Generic.IReadOnlyCollection<SimplifiedAdditionalField>
System.Collections.Generic.IEnumerable<SimplifiedAdditionalField>
System.Collections.IEnumerable
Inherited Members
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.System.Collections.IList.get_Item(System.Int32)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.System.Collections.IList.set_Item(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.Add(FChoice.Toolkits.Clarify.SimplifiedAdditionalField)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.System.Collections.IList.Add(System.Object)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.AddRange(System.Collections.Generic.IEnumerable<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.AsReadOnly()
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.BinarySearch(System.Int32, System.Int32, FChoice.Toolkits.Clarify.SimplifiedAdditionalField, System.Collections.Generic.IComparer<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.BinarySearch(FChoice.Toolkits.Clarify.SimplifiedAdditionalField)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.BinarySearch(FChoice.Toolkits.Clarify.SimplifiedAdditionalField, System.Collections.Generic.IComparer<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.Clear()
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.Contains(FChoice.Toolkits.Clarify.SimplifiedAdditionalField)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.System.Collections.IList.Contains(System.Object)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.ConvertAll<TOutput>(System.Converter<FChoice.Toolkits.Clarify.SimplifiedAdditionalField, TOutput>)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.CopyTo(FChoice.Toolkits.Clarify.SimplifiedAdditionalField[])
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.System.Collections.ICollection.CopyTo(System.Array, System.Int32)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.CopyTo(System.Int32, FChoice.Toolkits.Clarify.SimplifiedAdditionalField[], System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.CopyTo(FChoice.Toolkits.Clarify.SimplifiedAdditionalField[], System.Int32)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.Exists(System.Predicate<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.Find(System.Predicate<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.FindAll(System.Predicate<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.FindIndex(System.Predicate<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.FindIndex(System.Int32, System.Predicate<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.FindIndex(System.Int32, System.Int32, System.Predicate<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.FindLast(System.Predicate<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.FindLastIndex(System.Predicate<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.FindLastIndex(System.Int32, System.Predicate<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.FindLastIndex(System.Int32, System.Int32, System.Predicate<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.ForEach(System.Action<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.GetEnumerator()
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.System.Collections.Generic.IEnumerable<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.GetEnumerator()
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.System.Collections.IEnumerable.GetEnumerator()
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.GetRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.IndexOf(FChoice.Toolkits.Clarify.SimplifiedAdditionalField)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.System.Collections.IList.IndexOf(System.Object)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.IndexOf(FChoice.Toolkits.Clarify.SimplifiedAdditionalField, System.Int32)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.IndexOf(FChoice.Toolkits.Clarify.SimplifiedAdditionalField, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.Insert(System.Int32, FChoice.Toolkits.Clarify.SimplifiedAdditionalField)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.System.Collections.IList.Insert(System.Int32, System.Object)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.InsertRange(System.Int32, System.Collections.Generic.IEnumerable<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.LastIndexOf(FChoice.Toolkits.Clarify.SimplifiedAdditionalField)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.LastIndexOf(FChoice.Toolkits.Clarify.SimplifiedAdditionalField, System.Int32)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.LastIndexOf(FChoice.Toolkits.Clarify.SimplifiedAdditionalField, System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.Remove(FChoice.Toolkits.Clarify.SimplifiedAdditionalField)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.System.Collections.IList.Remove(System.Object)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.RemoveAll(System.Predicate<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.RemoveAt(System.Int32)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.RemoveRange(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.Reverse()
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.Reverse(System.Int32, System.Int32)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.Sort()
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.Sort(System.Collections.Generic.IComparer<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.Sort(System.Int32, System.Int32, System.Collections.Generic.IComparer<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.Sort(System.Comparison<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.ToArray()
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.TrimExcess()
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.TrueForAll(System.Predicate<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>)
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.Capacity
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.Count
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.System.Collections.IList.IsFixedSize
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.System.Collections.Generic.ICollection<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.IsReadOnly
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.System.Collections.IList.IsReadOnly
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.System.Collections.ICollection.IsSynchronized
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.System.Collections.ICollection.SyncRoot
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.Item[System.Int32]
System.Collections.Generic.List<FChoice.Toolkits.Clarify.SimplifiedAdditionalField>.System.Collections.IList.Item[System.Int32]
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class SimplifiedAdditionalFields : List<SimplifiedAdditionalField>, IList<SimplifiedAdditionalField>, ICollection<SimplifiedAdditionalField>, IList, ICollection, IReadOnlyList<SimplifiedAdditionalField>, IReadOnlyCollection<SimplifiedAdditionalField>, IEnumerable<SimplifiedAdditionalField>, IEnumerable

Constructors

SimplifiedAdditionalFields()

Declaration
public SimplifiedAdditionalFields()

Methods

Add(String, Object)

Declaration
public SimplifiedAdditionalField Add(string fieldName, object fieldValue)
Parameters
Type | Name | Description
System.String | fieldName |
System.Object | fieldValue |
Returns
Type | Description
SimplifiedAdditionalField |

Implements

System.Collections.Generic.IList<T>
System.Collections.Generic.ICollection<T>
System.Collections.IList
System.Collections.ICollection
System.Collections.Generic.IReadOnlyList<T>
System.Collections.Generic.IReadOnlyCollection<T>
System.Collections.Generic.IEnumerable<T>
System.Collections.IEnumerable


Enum SiteStatus | fcSDK Documentation

Enum SiteStatus

Namespace: FChoice.Toolkits.Clarify
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public enum SiteStatus

Fields

Name | Description
Active |
Inactive |
Obsolete |


Enum SiteType | fcSDK Documentation

Enum SiteType

Namespace: FChoice.Toolkits.Clarify
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public enum SiteType

Fields

Name | Description
Customer |
Individual |
Internal |
Reseller |
Vendor |


Namespace FChoice.Toolkits.Clarify.Support | fcSDK Documentation

Namespace FChoice.Toolkits.Clarify.Support

Classes

AcceptCaseSetup

AcceptSubcaseSetup

AssignCaseSetup

AssignSubcaseSetup

CaseTimeAndExpenses

ChangeCaseContactSetup

ChangeCaseSiteSetup

ChangeCaseStatusSetup

ChangeSubcaseStatusSetup

ClarifyApplicationClock

CloseCaseSetup

CloseSubcaseSetup

CompatibilityApplicationClock

CreateCaseObjidSetup

CreateCaseSetup

CreateSubcaseSetup

DispatchCaseSetup

DispatchSubcaseSetup

ForwardCaseSetup

ForwardSubcaseSetup

FulfillCommitmentSetup

GetCaseTimeAndExpensesResult

GetCaseTimeAndExpensesSetup

GetSubcaseTimeAndExpensesResult

GetSubcaseTimeAndExpensesSetup

InitialResponseSetup

LogCaseCommitmentSetup

LogCaseEmailInSetup

LogCaseEmailResult

LogCaseEmailSetup

LogCaseInternalNoteSetup

LogCaseInternalPhoneSetup

LogCaseNoteResult

LogCaseNoteSetup

LogCasePhoneResult

LogCasePhoneSetup

LogCaseResearchResult

LogCaseResearchSetup

LogEmailInSetup

LogSubcaseCommitmentSetup

LogSubCaseEmailInSetup

LogSubcaseEmailResult

LogSubcaseEmailSetup

LogSubcaseInternalNoteSetup

LogSubcaseInternalPhoneSetup

LogSubcaseNoteResult

LogSubcaseNoteSetup

LogSubcasePhoneResult

LogSubcasePhoneSetup

LogSubcaseResearchResult

LogSubcaseResearchSetup

MoveCaseSetup

MoveSubcaseSetup

RejectCaseSetup

RejectSubcaseSetup

RelateCaseToParentCaseSetup

ReopenCaseSetup

ReopenSubcaseSetup

SubcaseTimeAndExpenses

SupportToolkit

SupportToolkitBase

UnrelateCaseFromParentCaseSetup

UpdateCaseCommitmentSetup

UpdateCaseSetup

UpdateSubcaseCommitmentSetup

UpdateSubcaseSetup

YankCaseSetup

YankSubcaseSetup

Interfaces

IApplicationClock

Back to top © 2022 Dovetail Software, Inc. - All rights reserved.
Clarify, Amdocs, and related products and names are copyright and trademark of Amdocs, Inc.
.NET, Visual Studio.NET, C#, Visual Basic and related products are trademark of Microsoft corporation.


Class AcceptCaseSetup | fcSDK Documentation

Class AcceptCaseSetup

Inheritance
System.Object
AcceptCaseSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class AcceptCaseSetup

Constructors

AcceptCaseSetup(String)

Declaration
[ConstructorIndex(0)]
public AcceptCaseSetup(string caseIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |

Properties

AcceptDate

Declaration
[PropertyBitValue(2)]
public DateTime AcceptDate { get; set; }
Property Value
Type | Description
System.DateTime |

CaseIDNum

Declaration
[PropertyBitValue(1)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(16)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(4)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |


Class AcceptSubcaseSetup | fcSDK Documentation

Class AcceptSubcaseSetup

Inheritance
System.Object
AcceptSubcaseSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class AcceptSubcaseSetup

Constructors

AcceptSubcaseSetup(String)

Declaration
[ConstructorIndex(0)]
public AcceptSubcaseSetup(string subcaseIDNum)
Parameters
Type | Name | Description
System.String | subcaseIDNum |

Properties

AcceptDate

Declaration
[PropertyBitValue(2)]
public DateTime AcceptDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(16)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

SubcaseIDNum

Declaration
[PropertyBitValue(1)]
public string SubcaseIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(4)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |


Class AssignCaseSetup | fcSDK Documentation

Class AssignCaseSetup

Inheritance
System.Object
AssignCaseSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class AssignCaseSetup

Constructors

AssignCaseSetup(String)

Declaration
[ConstructorIndex(0)]
public AssignCaseSetup(string caseIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |

Properties

AssignDate

Declaration
[PropertyBitValue(8)]
public DateTime AssignDate { get; set; }
Property Value
Type | Description
System.DateTime |

CaseIDNum

Declaration
[PropertyBitValue(1)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

NewUser

Declaration
[PropertyBitValue(2)]
public string NewUser { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(4)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |


Class AssignSubcaseSetup | fcSDK Documentation

Class AssignSubcaseSetup

Inheritance
System.Object
AssignSubcaseSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class AssignSubcaseSetup

Constructors

AssignSubcaseSetup(String)

Declaration
[ConstructorIndex(0)]
public AssignSubcaseSetup(string subcaseIDNum)
Parameters
Type | Name | Description
System.String | subcaseIDNum |

Properties

AssignDate

Declaration
[PropertyBitValue(8)]
public DateTime AssignDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

NewUser

Declaration
[PropertyBitValue(2)]
public string NewUser { get; set; }
Property Value
Type | Description
System.String |

SubcaseIDNum

Declaration
[PropertyBitValue(1)]
public string SubcaseIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(4)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |


Class CaseTimeAndExpenses | fcSDK Documentation

Class CaseTimeAndExpenses

Inheritance
System.Object
CaseTimeAndExpenses
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CaseTimeAndExpenses

Constructors

CaseTimeAndExpenses()

Declaration
public CaseTimeAndExpenses()

Fields

EMPTY

Declaration
public static readonly CaseTimeAndExpenses EMPTY
Field Value
Type | Description
CaseTimeAndExpenses |

Properties

CaseActualPhoneTime

Declaration
public TimeSpan CaseActualPhoneTime { get; set; }
Property Value
Type | Description
System.TimeSpan |

CaseActualResearchTime

Declaration
public TimeSpan CaseActualResearchTime { get; set; }
Property Value
Type | Description
System.TimeSpan |

CaseBillableExpenses

Declaration
public decimal CaseBillableExpenses { get; set; }
Property Value
Type | Description
System.Decimal |

CaseBillableTime

Declaration
public TimeSpan CaseBillableTime { get; set; }
Property Value
Type | Description
System.TimeSpan |

CaseNonBillableExpenses

Declaration
public decimal CaseNonBillableExpenses { get; set; }
Property Value
Type | Description
System.Decimal |

CaseNonBillableTime

Declaration
public TimeSpan CaseNonBillableTime { get; set; }
Property Value
Type | Description
System.TimeSpan |

CasePhoneTime

Declaration
public TimeSpan CasePhoneTime { get; set; }
Property Value
Type | Description
System.TimeSpan |

CaseResearchTime

Declaration
public TimeSpan CaseResearchTime { get; set; }
Property Value
Type | Description
System.TimeSpan |

TotalActualPhoneTime

Declaration
public TimeSpan TotalActualPhoneTime { get; set; }
Property Value
Type | Description
System.TimeSpan |

TotalActualResearchTime

Declaration
public TimeSpan TotalActualResearchTime { get; set; }
Property Value
Type | Description
System.TimeSpan |

TotalBillableExpenses

Declaration
public decimal TotalBillableExpenses { get; set; }
Property Value
Type | Description
System.Decimal |

TotalBillableTime

Declaration
public TimeSpan TotalBillableTime { get; set; }
Property Value
Type | Description
System.TimeSpan |

TotalNonBillableExpenses

Declaration
public decimal TotalNonBillableExpenses { get; set; }
Property Value
Type | Description
System.Decimal |

TotalNonBillableTime

Declaration
public TimeSpan TotalNonBillableTime { get; set; }
Property Value
Type | Description
System.TimeSpan |

TotalPhoneTime

Declaration
public TimeSpan TotalPhoneTime { get; set; }
Property Value
Type | Description
System.TimeSpan |

TotalResearchTime

Declaration
public TimeSpan TotalResearchTime { get; set; }
Property Value
Type | Description
System.TimeSpan |


Class ChangeCaseContactSetup | fcSDK Documentation

Class ChangeCaseContactSetup

Inheritance
System.Object
ChangeCaseContactSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ChangeCaseContactSetup

Constructors

ChangeCaseContactSetup(String, String, String, String)

Declaration
[ConstructorIndex(0)]
public ChangeCaseContactSetup(string caseIDNum, string contactFirstName, string contactLastName, string contactPhone)
Parameters
Type | Name | Description
System.String | caseIDNum |
System.String | contactFirstName |
System.String | contactLastName |
System.String | contactPhone |

Properties

CaseIDNum

Declaration
[PropertyBitValue(1)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

ChangeDate

Declaration
[PropertyBitValue(32)]
public DateTime ChangeDate { get; set; }
Property Value
Type | Description
System.DateTime |

ContactFirstName

Declaration
[PropertyBitValue(2)]
public string ContactFirstName { get; set; }
Property Value
Type | Description
System.String |

ContactLastName

Declaration
[PropertyBitValue(4)]
public string ContactLastName { get; set; }
Property Value
Type | Description
System.String |

ContactPhone

Declaration
[PropertyBitValue(8)]
public string ContactPhone { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(128)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

OnlyOpen

Declaration
[PropertyBitValue(256)]
public bool OnlyOpen { get; set; }
Property Value
Type | Description
System.Boolean |

SiteIDNum

Declaration
[PropertyBitValue(16)]
public string SiteIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(64)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class ChangeCaseSiteSetup | fcSDK Documentation

Class ChangeCaseSiteSetup

Inheritance
System.Object
ChangeCaseSiteSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ChangeCaseSiteSetup

Constructors

ChangeCaseSiteSetup(String, String)

Declaration
[ConstructorIndex(0)]
public ChangeCaseSiteSetup(string caseIDNum, string siteIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |
System.String | siteIDNum |

Properties

CaseIDNum

Declaration
[PropertyBitValue(1)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

ChangeDate

Declaration
[PropertyBitValue(32)]
public DateTime ChangeDate { get; set; }
Property Value
Type | Description
System.DateTime |

ContactFirstName

Declaration
[PropertyBitValue(2)]
public string ContactFirstName { get; set; }
Property Value
Type | Description
System.String |

ContactLastName

Declaration
[PropertyBitValue(4)]
public string ContactLastName { get; set; }
Property Value
Type | Description
System.String |

ContactPhone

Declaration
[PropertyBitValue(8)]
public string ContactPhone { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(128)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

OnlyOpen

Declaration
[PropertyBitValue(256)]
public bool OnlyOpen { get; set; }
Property Value
Type | Description
System.Boolean |

SiteIDNum

Declaration
[PropertyBitValue(16)]
public string SiteIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(64)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class ChangeCaseStatusSetup | fcSDK Documentation

Class ChangeCaseStatusSetup

Inheritance
System.Object
ChangeCaseStatusSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ChangeCaseStatusSetup

Constructors

ChangeCaseStatusSetup(String)

Declaration
[ConstructorIndex(0)]
public ChangeCaseStatusSetup(string caseIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |

Properties

CaseIDNum

Declaration
[PropertyBitValue(1)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

ChangeDate

Declaration
[PropertyBitValue(4)]
public DateTime ChangeDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

NewStatus

Declaration
[PropertyBitValue(2)]
public string NewStatus { get; set; }
Property Value
Type | Description
System.String |

Notes

Declaration
[PropertyBitValue(8)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class ChangeSubcaseStatusSetup | fcSDK Documentation

Class ChangeSubcaseStatusSetup

Inheritance
System.Object
ChangeSubcaseStatusSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ChangeSubcaseStatusSetup

Constructors

ChangeSubcaseStatusSetup(String)

Declaration
[ConstructorIndex(0)]
public ChangeSubcaseStatusSetup(string subcaseIDNum)
Parameters
Type | Name | Description
System.String | subcaseIDNum |

Properties

ChangeDate

Declaration
[PropertyBitValue(4)]
public DateTime ChangeDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

NewStatus

Declaration
[PropertyBitValue(2)]
public string NewStatus { get; set; }
Property Value
Type | Description
System.String |

Notes

Declaration
[PropertyBitValue(8)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

SubcaseIDNum

Declaration
[PropertyBitValue(1)]
public string SubcaseIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class ClarifyApplicationClock | fcSDK Documentation

Class ClarifyApplicationClock

Inheritance
System.Object
ClarifyApplicationClock
Implements
IApplicationClock
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ClarifyApplicationClock : IApplicationClock

Constructors

ClarifyApplicationClock(ClarifySession)

Declaration
public ClarifyApplicationClock(ClarifySession clarifySession)
Parameters
Type | Name | Description
ClarifySession | clarifySession |

Properties

Now

Declaration
public DateTime Now { get; }
Property Value
Type | Description
System.DateTime |

Implements

IApplicationClock


Class CloseCaseSetup | fcSDK Documentation

Class CloseCaseSetup

Inheritance
System.Object
CloseCaseSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CloseCaseSetup

Constructors

CloseCaseSetup(String)

Declaration
[ConstructorIndex(0)]
public CloseCaseSetup(string caseIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |

Properties

AdditionalFields

Declaration
[PropertyBitValue(512)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

CaseIDNum

Declaration
[PropertyBitValue(1)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

CaseTimeAndExpenses

Declaration
[PropertyBitValue(128)]
public CaseTimeAndExpenses CaseTimeAndExpenses { get; set; }
Property Value
Type | Description
CaseTimeAndExpenses |

CloseDate

Declaration
[PropertyBitValue(32)]
public DateTime CloseDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(256)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

Resolution

Declaration
[PropertyBitValue(4)]
public string Resolution { get; set; }
Property Value
Type | Description
System.String |

Status

Declaration
[PropertyBitValue(2)]
public string Status { get; set; }
Property Value
Type | Description
System.String |

Summary

Declaration
[PropertyBitValue(8)]
public string Summary { get; set; }
Property Value
Type | Description
System.String |

UnitsUsed

Declaration
[PropertyBitValue(64)]
public double UnitsUsed { get; set; }
Property Value
Type | Description
System.Double |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class CloseSubcaseSetup | fcSDK Documentation

Class CloseSubcaseSetup

Inheritance
System.Object
CloseSubcaseSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CloseSubcaseSetup

Constructors

CloseSubcaseSetup(String)

Declaration
[ConstructorIndex(0)]
public CloseSubcaseSetup(string subcaseIDNum)
Parameters
Type | Name | Description
System.String | subcaseIDNum |

Properties

AdditionalFields

Declaration
[PropertyBitValue(128)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

CloseDate

Declaration
[PropertyBitValue(32)]
public DateTime CloseDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(64)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

Resolution

Declaration
[PropertyBitValue(4)]
public string Resolution { get; set; }
Property Value
Type | Description
System.String |

Status

Declaration
[PropertyBitValue(2)]
public string Status { get; set; }
Property Value
Type | Description
System.String |

SubcaseIDNum

Declaration
[PropertyBitValue(1)]
public string SubcaseIDNum { get; set; }
Property Value
Type | Description
System.String |

Summary

Declaration
[PropertyBitValue(8)]
public string Summary { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class CompatibilityApplicationClock | fcSDK Documentation

Class CompatibilityApplicationClock

Inheritance
System.Object
CompatibilityApplicationClock
Implements
IApplicationClock
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CompatibilityApplicationClock : IApplicationClock

Constructors

CompatibilityApplicationClock(IFCSession)

Declaration
public CompatibilityApplicationClock(IFCSession session)
Parameters
Type | Name | Description
IFCSession | session |

Properties

Now

Declaration
public DateTime Now { get; }
Property Value
Type | Description
System.DateTime |

Implements

IApplicationClock


Class CreateCaseObjidSetup | fcSDK Documentation

Class CreateCaseObjidSetup

Inheritance
System.Object
CreateCaseObjidSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateCaseObjidSetup

Constructors

CreateCaseObjidSetup()

Declaration
[ConstructorIndex(0)]
public CreateCaseObjidSetup()

Properties

AdditionalFields

Declaration
[PropertyBitValue(1048576)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

AddressObjid

Declaration
[PropertyBitValue(524288)]
public int AddressObjid { get; set; }
Property Value
Type | Description
System.Int32 |

CaseType

Declaration
[PropertyBitValue(32)]
public string CaseType { get; set; }
Property Value
Type | Description
System.String |

ContactFirstName

Declaration
[PropertyBitValue(1)]
public string ContactFirstName { get; set; }
Property Value
Type | Description
System.String |

ContactLastName

Declaration
[PropertyBitValue(2)]
public string ContactLastName { get; set; }
Property Value
Type | Description
System.String |

ContactObjid

Declaration
[PropertyBitValue(32768)]
public int ContactObjid { get; set; }
Property Value
Type | Description
System.Int32 |

ContactPhone

Declaration
[PropertyBitValue(4)]
public string ContactPhone { get; set; }
Property Value
Type | Description
System.String |

ContractObjid

Declaration
[PropertyBitValue(262144)]
public int ContractObjid { get; set; }
Property Value
Type | Description
System.Int32 |

CreateDate

Declaration
[PropertyBitValue(2048)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(16384)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

PartRevisionObjid

Declaration
[PropertyBitValue(131072)]
public int PartRevisionObjid { get; set; }
Property Value
Type | Description
System.Int32 |

PhoneEndDate

Declaration
[PropertyBitValue(4096)]
public DateTime PhoneEndDate { get; set; }
Property Value
Type | Description
System.DateTime |

PhoneLogNotes

Declaration
[PropertyBitValue(512)]
public string PhoneLogNotes { get; set; }
Property Value
Type | Description
System.String |

Priority

Declaration
[PropertyBitValue(64)]
public string Priority { get; set; }
Property Value
Type | Description
System.String |

Queue

Declaration
[PropertyBitValue(1024)]
public string Queue { get; set; }
Property Value
Type | Description
System.String |

Serverity

Declaration
[PropertyBitValue(128)]
public string Serverity { get; set; }
Property Value
Type | Description
System.String |

SiteObjid

Declaration
[PropertyBitValue(65536)]
public int SiteObjid { get; set; }
Property Value
Type | Description
System.Int32 |

SitePartObjid

Declaration
[PropertyBitValue(8)]
public int SitePartObjid { get; set; }
Property Value
Type | Description
System.Int32 |

Status

Declaration
[PropertyBitValue(256)]
public string Status { get; set; }
Property Value
Type | Description
System.String |

Title

Declaration
[PropertyBitValue(16)]
public string Title { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(8192)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class CreateCaseSetup | fcSDK Documentation

Class CreateCaseSetup

Inheritance
System.Object
CreateCaseSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateCaseSetup

Constructors

CreateCaseSetup(String, String, String, String)

Declaration
[ConstructorIndex(0)]
public CreateCaseSetup(string siteIDNum, string contactFirstName, string contactLastName, string contactPhone)
Parameters
Type | Name | Description
System.String | siteIDNum |
System.String | contactFirstName |
System.String | contactLastName |
System.String | contactPhone |

Properties

AdditionalFields

Declaration
[PropertyBitValue(2097152)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

CaseType

Declaration
[PropertyBitValue(2048)]
public string CaseType { get; set; }
Property Value
Type | Description
System.String |

ContactFirstName

Declaration
[PropertyBitValue(2)]
public string ContactFirstName { get; set; }
Property Value
Type | Description
System.String |

ContactLastName

Declaration
[PropertyBitValue(4)]
public string ContactLastName { get; set; }
Property Value
Type | Description
System.String |

ContactPhone

Declaration
[PropertyBitValue(8)]
public string ContactPhone { get; set; }
Property Value
Type | Description
System.String |

ContractIDNum

Declaration
[PropertyBitValue(512)]
public string ContractIDNum { get; set; }
Property Value
Type | Description
System.String |

CreateDate

Declaration
[PropertyBitValue(131072)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(1048576)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

PartDomain

Declaration
[PropertyBitValue(64)]
public string PartDomain { get; set; }
Property Value
Type | Description
System.String |

PartNumber

Declaration
[PropertyBitValue(16)]
public string PartNumber { get; set; }
Property Value
Type | Description
System.String |

PartRevision

Declaration
[PropertyBitValue(32)]
public string PartRevision { get; set; }
Property Value
Type | Description
System.String |

PhoneEndDate

Declaration
[PropertyBitValue(262144)]
public DateTime PhoneEndDate { get; set; }
Property Value
Type | Description
System.DateTime |

PhoneLogNotes

Declaration
[PropertyBitValue(32768)]
public string PhoneLogNotes { get; set; }
Property Value
Type | Description
System.String |

Priority

Declaration
[PropertyBitValue(4096)]
public string Priority { get; set; }
Property Value
Type | Description
System.String |

Queue

Declaration
[PropertyBitValue(65536)]
public string Queue { get; set; }
Property Value
Type | Description
System.String |

SerialNumber

Declaration
[PropertyBitValue(128)]
public string SerialNumber { get; set; }
Property Value
Type | Description
System.String |

Severity

Declaration
[PropertyBitValue(8192)]
public string Severity { get; set; }
Property Value
Type | Description
System.String |

SiteIDNum

Declaration
[PropertyBitValue(1)]
public string SiteIDNum { get; set; }
Property Value
Type | Description
System.String |

SitePartObjid

Declaration
[PropertyBitValue(256)]
public int SitePartObjid { get; set; }
Property Value
Type | Description
System.Int32 |

Status

Declaration
[PropertyBitValue(16384)]
public string Status { get; set; }
Property Value
Type | Description
System.String |

Title

Declaration
[PropertyBitValue(1024)]
public string Title { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(524288)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class CreateSubcaseSetup | fcSDK Documentation

Class CreateSubcaseSetup

Inheritance
System.Object
CreateSubcaseSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class CreateSubcaseSetup

Constructors

CreateSubcaseSetup(String)

Declaration
[ConstructorIndex(0)]
public CreateSubcaseSetup(string caseIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |

Properties

AdditionalFields

Declaration
[PropertyBitValue(8192)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

CaseIDNum

Declaration
[PropertyBitValue(1)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

CreateDate

Declaration
[PropertyBitValue(256)]
public DateTime CreateDate { get; set; }
Property Value
Type | Description
System.DateTime |

DueDate

Declaration
[PropertyBitValue(512)]
public DateTime DueDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(4096)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

IsGeneral

Declaration
[PropertyBitValue(4)]
public bool IsGeneral { get; set; }
Property Value
Type | Description
System.Boolean |

Notes

Declaration
[PropertyBitValue(64)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

Priority

Declaration
[PropertyBitValue(8)]
public string Priority { get; set; }
Property Value
Type | Description
System.String |

PriorWarning

Declaration
[PropertyBitValue(1024)]
public TimeSpan PriorWarning { get; set; }
Property Value
Type | Description
System.TimeSpan |

Queue

Declaration
[PropertyBitValue(128)]
public string Queue { get; set; }
Property Value
Type | Description
System.String |

Severity

Declaration
[PropertyBitValue(16)]
public string Severity { get; set; }
Property Value
Type | Description
System.String |

Status

Declaration
[PropertyBitValue(32)]
public string Status { get; set; }
Property Value
Type | Description
System.String |

Title

Declaration
[PropertyBitValue(2)]
public string Title { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(2048)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class DispatchCaseSetup | fcSDK Documentation

Class DispatchCaseSetup

Inheritance
System.Object
DispatchCaseSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class DispatchCaseSetup

Constructors

DispatchCaseSetup(String, String)

Declaration
[ConstructorIndex(0)]
public DispatchCaseSetup(string caseIDNum, string queue)
Parameters
Type | Name | Description
System.String | caseIDNum |
System.String | queue |

Properties

CaseIDNum

Declaration
[PropertyBitValue(1)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

DispatchDate

Declaration
[PropertyBitValue(4)]
public DateTime DispatchDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(16)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

Queue

Declaration
[PropertyBitValue(2)]
public string Queue { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class DispatchSubcaseSetup | fcSDK Documentation

Class DispatchSubcaseSetup

Inheritance
System.Object
DispatchSubcaseSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class DispatchSubcaseSetup

Constructors

DispatchSubcaseSetup(String, String)

Declaration
[ConstructorIndex(0)]
public DispatchSubcaseSetup(string subcaseIDNum, string queue)
Parameters
Type | Name | Description
System.String | subcaseIDNum |
System.String | queue |

Properties

DispatchDate

Declaration
[PropertyBitValue(4)]
public DateTime DispatchDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(16)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

Queue

Declaration
[PropertyBitValue(2)]
public string Queue { get; set; }
Property Value
Type | Description
System.String |

SubcaseIDNum

Declaration
[PropertyBitValue(1)]
public string SubcaseIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class ForwardCaseSetup | fcSDK Documentation

Class ForwardCaseSetup

Inheritance
System.Object
ForwardCaseSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ForwardCaseSetup

Constructors

ForwardCaseSetup(String, String)

Declaration
[ConstructorIndex(0)]
public ForwardCaseSetup(string caseIDNum, string newQueue)
Parameters
Type | Name | Description
System.String | caseIDNum |
System.String | newQueue |

Properties

CaseIDNum

Declaration
[PropertyBitValue(1)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

ForwardDate

Declaration
[PropertyBitValue(4)]
public DateTime ForwardDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

NewQueue

Declaration
[PropertyBitValue(2)]
public string NewQueue { get; set; }
Property Value
Type | Description
System.String |

Notes

Declaration
[PropertyBitValue(8)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class ForwardSubcaseSetup | fcSDK Documentation

Class ForwardSubcaseSetup

Inheritance
System.Object
ForwardSubcaseSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ForwardSubcaseSetup

Constructors

ForwardSubcaseSetup(String, String)

Declaration
[ConstructorIndex(0)]
public ForwardSubcaseSetup(string subcaseIDNum, string newQueue)
Parameters
Type | Name | Description
System.String | subcaseIDNum |
System.String | newQueue |

Properties

ForwardDate

Declaration
[PropertyBitValue(4)]
public DateTime ForwardDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

NewQueue

Declaration
[PropertyBitValue(2)]
public string NewQueue { get; set; }
Property Value
Type | Description
System.String |

Notes

Declaration
[PropertyBitValue(8)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

SubcaseIDNum

Declaration
[PropertyBitValue(1)]
public string SubcaseIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class FulfillCommitmentSetup | fcSDK Documentation

Class FulfillCommitmentSetup

Inheritance
System.Object
FulfillCommitmentSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class FulfillCommitmentSetup

Constructors

FulfillCommitmentSetup(Int32)

Declaration
[ConstructorIndex(0)]
public FulfillCommitmentSetup(int logObjid)
Parameters
Type | Name | Description
System.Int32 | logObjid |

Properties

FulfillDate

Declaration
[PropertyBitValue(2)]
public DateTime FulfillDate { get; set; }
Property Value
Type | Description
System.DateTime |

GenerateTimeBombs

Declaration
[PropertyBitValue(8)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

LogObjid

Declaration
[PropertyBitValue(1)]
public int LogObjid { get; set; }
Property Value
Type | Description
System.Int32 |

UserName

Declaration
[PropertyBitValue(4)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class GetCaseTimeAndExpensesResult | fcSDK Documentation

Class GetCaseTimeAndExpensesResult

Inheritance
System.Object
ToolkitResult
GetCaseTimeAndExpensesResult
Inherited Members
ToolkitResult._ReturnCode
ToolkitResult._IDNum
ToolkitResult._Objid
ToolkitResult.ReturnCode
ToolkitResult.IDNum
ToolkitResult.Objid
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class GetCaseTimeAndExpensesResult : ToolkitResult

Constructors

GetCaseTimeAndExpensesResult()

Declaration
public GetCaseTimeAndExpensesResult()

Properties

CaseTimeAndExpenses

Declaration
public CaseTimeAndExpenses CaseTimeAndExpenses { get; set; }
Property Value
Type | Description
CaseTimeAndExpenses |


Class GetCaseTimeAndExpensesSetup | fcSDK Documentation

Class GetCaseTimeAndExpensesSetup

Inheritance
System.Object
GetCaseTimeAndExpensesSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class GetCaseTimeAndExpensesSetup

Constructors

GetCaseTimeAndExpensesSetup(String)

Declaration
[ConstructorIndex(0)]
public GetCaseTimeAndExpensesSetup(string caseIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |

Properties

CaseIDNum

Declaration
[PropertyBitValue(1)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |


Class GetSubcaseTimeAndExpensesResult | fcSDK Documentation

Class GetSubcaseTimeAndExpensesResult

Inheritance
System.Object
ToolkitResult
GetSubcaseTimeAndExpensesResult
Inherited Members
ToolkitResult._ReturnCode
ToolkitResult._IDNum
ToolkitResult._Objid
ToolkitResult.ReturnCode
ToolkitResult.IDNum
ToolkitResult.Objid
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class GetSubcaseTimeAndExpensesResult : ToolkitResult

Constructors

GetSubcaseTimeAndExpensesResult()

Declaration
public GetSubcaseTimeAndExpensesResult()

Properties

SubcaseTimeAndExpenses

Declaration
public SubcaseTimeAndExpenses SubcaseTimeAndExpenses { get; set; }
Property Value
Type | Description
SubcaseTimeAndExpenses |


Class GetSubcaseTimeAndExpensesSetup | fcSDK Documentation

Class GetSubcaseTimeAndExpensesSetup

Inheritance
System.Object
GetSubcaseTimeAndExpensesSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class GetSubcaseTimeAndExpensesSetup

Constructors

GetSubcaseTimeAndExpensesSetup(String)

Declaration
[ConstructorIndex(0)]
public GetSubcaseTimeAndExpensesSetup(string subcaseIDNum)
Parameters
Type | Name | Description
System.String | subcaseIDNum |

Properties

SubcaseIDNum

Declaration
[PropertyBitValue(1)]
public string SubcaseIDNum { get; set; }
Property Value
Type | Description
System.String |


Interface IApplicationClock | fcSDK Documentation

Interface IApplicationClock

Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public interface IApplicationClock

Properties

Now

Declaration
DateTime Now { get; }
Property Value
Type | Description
System.DateTime |


Class InitialResponseSetup | fcSDK Documentation

Class InitialResponseSetup

Inheritance
System.Object
InitialResponseSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class InitialResponseSetup

Constructors

InitialResponseSetup(String)

Declaration
[ConstructorIndex(0)]
public InitialResponseSetup(string caseIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |

Properties

CaseIDNum

Declaration
[PropertyBitValue(1)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(16)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

IsVIAPhone

Declaration
[PropertyBitValue(8)]
public bool IsVIAPhone { get; set; }
Property Value
Type | Description
System.Boolean |

ResponseDate

Declaration
[PropertyBitValue(2)]
public DateTime ResponseDate { get; set; }
Property Value
Type | Description
System.DateTime |

UserName

Declaration
[PropertyBitValue(4)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class LogCaseCommitmentSetup | fcSDK Documentation

Class LogCaseCommitmentSetup

Inheritance
System.Object
LogCaseCommitmentSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LogCaseCommitmentSetup

Constructors

LogCaseCommitmentSetup(String, String, TimeSpan, String, String, String)

Declaration
[ConstructorIndex(0)]
public LogCaseCommitmentSetup(string caseIDNum, string title, TimeSpan priorWarning, string contactFirstName, string contactLastName, string contactPhone)
Parameters
Type | Name | Description
System.String | caseIDNum |
System.String | title |
System.TimeSpan | priorWarning |
System.String | contactFirstName |
System.String | contactLastName |
System.String | contactPhone |

Properties

ActionType

Declaration
[PropertyBitValue(4)]
public string ActionType { get; set; }
Property Value
Type | Description
System.String |

AdditionalFields

Declaration
[PropertyBitValue(16384)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

CaseIDNum

Declaration
[PropertyBitValue(1)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

CommitmentDate

Declaration
[PropertyBitValue(16)]
public DateTime CommitmentDate { get; set; }
Property Value
Type | Description
System.DateTime |

ContactFirstName

Declaration
[PropertyBitValue(128)]
public string ContactFirstName { get; set; }
Property Value
Type | Description
System.String |

ContactLastName

Declaration
[PropertyBitValue(256)]
public string ContactLastName { get; set; }
Property Value
Type | Description
System.String |

ContactPhone

Declaration
[PropertyBitValue(512)]
public string ContactPhone { get; set; }
Property Value
Type | Description
System.String |

GenerateCommitmentEmail

Declaration
[PropertyBitValue(8192)]
public bool GenerateCommitmentEmail { get; set; }
Property Value
Type | Description
System.Boolean |

GenerateTimeBombs

Declaration
[PropertyBitValue(4096)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

IsMadeToCustomer

Declaration
[PropertyBitValue(64)]
public bool IsMadeToCustomer { get; set; }
Property Value
Type | Description
System.Boolean |

LogDate

Declaration
[PropertyBitValue(8)]
public DateTime LogDate { get; set; }
Property Value
Type | Description
System.DateTime |

Notes

Declaration
[PropertyBitValue(1024)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

PriorWarning

Declaration
[PropertyBitValue(32)]
public TimeSpan PriorWarning { get; set; }
Property Value
Type | Description
System.TimeSpan |

Title

Declaration
[PropertyBitValue(2)]
public string Title { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(2048)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class LogCaseEmailInSetup | fcSDK Documentation

Class LogCaseEmailInSetup

Inheritance
System.Object
LogEmailInSetup
LogCaseEmailInSetup
Inherited Members
LogEmailInSetup.IDNumber
LogEmailInSetup.LogDate
LogEmailInSetup.Message
LogEmailInSetup.Recipient
LogEmailInSetup.Sender
LogEmailInSetup.Subject
LogEmailInSetup.CCList
LogEmailInSetup.UserName
LogEmailInSetup.GenerateTimeBombs
LogEmailInSetup.AdditionalFields
LogEmailInSetup.MailLogActionType
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LogCaseEmailInSetup : LogEmailInSetup

Constructors

LogCaseEmailInSetup(String, String, String, String)

Declaration
public LogCaseEmailInSetup(string caseIDNum, string sender, string recipient, string message)
Parameters
Type | Name | Description
System.String | caseIDNum |
System.String | sender |
System.String | recipient |
System.String | message |


Class LogCaseEmailResult | fcSDK Documentation

Class LogCaseEmailResult

Inheritance
System.Object
ToolkitResult
LogCaseEmailResult
Inherited Members
ToolkitResult._ReturnCode
ToolkitResult._IDNum
ToolkitResult._Objid
ToolkitResult.ReturnCode
ToolkitResult.IDNum
ToolkitResult.Objid
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LogCaseEmailResult : ToolkitResult

Constructors

LogCaseEmailResult()

Declaration
public LogCaseEmailResult()

Properties

CommitmentObjid

Declaration
public int CommitmentObjid { get; set; }
Property Value
Type | Description
System.Int32 |

StatusChangeObjid

Declaration
public int StatusChangeObjid { get; set; }
Property Value
Type | Description
System.Int32 |


Class LogCaseEmailSetup | fcSDK Documentation

Class LogCaseEmailSetup

Inheritance
System.Object
LogCaseEmailSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LogCaseEmailSetup

Constructors

LogCaseEmailSetup(String)

Declaration
[ConstructorIndex(0)]
public LogCaseEmailSetup(string caseIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |

Properties

ActionType

Declaration
[PropertyBitValue(2)]
public string ActionType { get; set; }
Property Value
Type | Description
System.String |

AdditionalFields

Declaration
[PropertyBitValue(131072)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

CaseIDNum

Declaration
[PropertyBitValue(1)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

CCList

Declaration
[PropertyBitValue(32)]
public string CCList { get; set; }
Property Value
Type | Description
System.String |

CommitmentActionType

Declaration
[PropertyBitValue(8192)]
public string CommitmentActionType { get; set; }
Property Value
Type | Description
System.String |

CommitmentContactObjid

Declaration
[PropertyBitValue(16384)]
public int CommitmentContactObjid { get; set; }
Property Value
Type | Description
System.Int32 |

CommitmentDueDate

Declaration
[PropertyBitValue(1024)]
public DateTime CommitmentDueDate { get; set; }
Property Value
Type | Description
System.DateTime |

CommitmentNotes

Declaration
[PropertyBitValue(512)]
public string CommitmentNotes { get; set; }
Property Value
Type | Description
System.String |

CommitmentPriorWarning

Declaration
[PropertyBitValue(2048)]
public TimeSpan CommitmentPriorWarning { get; set; }
Property Value
Type | Description
System.TimeSpan |

CommitmentTitle

Declaration
[PropertyBitValue(256)]
public string CommitmentTitle { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(32768)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

IsCommitmentToCustomer

Declaration
[PropertyBitValue(4096)]
public bool IsCommitmentToCustomer { get; set; }
Property Value
Type | Description
System.Boolean |

LogDate

Declaration
[PropertyBitValue(4)]
public DateTime LogDate { get; set; }
Property Value
Type | Description
System.DateTime |

Message

Declaration
[PropertyBitValue(8)]
public string Message { get; set; }
Property Value
Type | Description
System.String |

NewStatus

Declaration
[PropertyBitValue(128)]
public string NewStatus { get; set; }
Property Value
Type | Description
System.String |

Recipient

Declaration
[PropertyBitValue(16)]
public string Recipient { get; set; }
Property Value
Type | Description
System.String |

SendEmail

Declaration
[PropertyBitValue(65536)]
public bool SendEmail { get; set; }
Property Value
Type | Description
System.Boolean |

UserName

Declaration
[PropertyBitValue(64)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class LogCaseInternalNoteSetup | fcSDK Documentation

Class LogCaseInternalNoteSetup

Inheritance
System.Object
LogCaseInternalNoteSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LogCaseInternalNoteSetup

Constructors

LogCaseInternalNoteSetup(String)

Declaration
[ConstructorIndex(0)]
public LogCaseInternalNoteSetup(string caseIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |

Properties

ActionType

Declaration
[PropertyBitValue(2)]
public string ActionType { get; set; }
Property Value
Type | Description
System.String |

AdditionalFields

Declaration
[PropertyBitValue(8192)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

CaseIDNum

Declaration
[PropertyBitValue(1)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

CommitmentDueDate

Declaration
[PropertyBitValue(512)]
public DateTime CommitmentDueDate { get; set; }
Property Value
Type | Description
System.DateTime |

CommitmentNotes

Declaration
[PropertyBitValue(256)]
public string CommitmentNotes { get; set; }
Property Value
Type | Description
System.String |

CommitmentPriorWarning

Declaration
[PropertyBitValue(1024)]
public TimeSpan CommitmentPriorWarning { get; set; }
Property Value
Type | Description
System.TimeSpan |

CommitmentTitle

Declaration
[PropertyBitValue(128)]
public string CommitmentTitle { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(4096)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

IsCommitmentToCustomer

Declaration
[PropertyBitValue(2048)]
public bool IsCommitmentToCustomer { get; set; }
Property Value
Type | Description
System.Boolean |

LogDate

Declaration
[PropertyBitValue(16)]
public DateTime LogDate { get; set; }
Property Value
Type | Description
System.DateTime |

NewStatus

Declaration
[PropertyBitValue(64)]
public string NewStatus { get; set; }
Property Value
Type | Description
System.String |

Notes

Declaration
[PropertyBitValue(4)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(32)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class LogCaseInternalPhoneSetup | fcSDK Documentation

Class LogCaseInternalPhoneSetup

Inheritance
System.Object
LogCaseInternalPhoneSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LogCaseInternalPhoneSetup

Constructors

LogCaseInternalPhoneSetup(String, String, String, String)

Declaration
[ConstructorIndex(0)]
public LogCaseInternalPhoneSetup(string caseIDNum, string contactFirstName, string contactLastName, string contactPhone)
Parameters
Type | Name | Description
System.String | caseIDNum |
System.String | contactFirstName |
System.String | contactLastName |
System.String | contactPhone |

Properties

ActionType

Declaration
[PropertyBitValue(16)]
public string ActionType { get; set; }
Property Value
Type | Description
System.String |

AdditionalFields

Declaration
[PropertyBitValue(131072)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

CaseIDNum

Declaration
[PropertyBitValue(1)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

CommitmentDueDate

Declaration
[PropertyBitValue(8192)]
public DateTime CommitmentDueDate { get; set; }
Property Value
Type | Description
System.DateTime |

CommitmentNotes

Declaration
[PropertyBitValue(4096)]
public string CommitmentNotes { get; set; }
Property Value
Type | Description
System.String |

CommitmentPriorWarning

Declaration
[PropertyBitValue(16384)]
public TimeSpan CommitmentPriorWarning { get; set; }
Property Value
Type | Description
System.TimeSpan |

CommitmentTitle

Declaration
[PropertyBitValue(2048)]
public string CommitmentTitle { get; set; }
Property Value
Type | Description
System.String |

ContactFirstName

Declaration
[PropertyBitValue(2)]
public string ContactFirstName { get; set; }
Property Value
Type | Description
System.String |

ContactLastName

Declaration
[PropertyBitValue(4)]
public string ContactLastName { get; set; }
Property Value
Type | Description
System.String |

ContactPhone

Declaration
[PropertyBitValue(8)]
public string ContactPhone { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(65536)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

IsCommitmentToCustomer

Declaration
[PropertyBitValue(32768)]
public bool IsCommitmentToCustomer { get; set; }
Property Value
Type | Description
System.Boolean |

LogDate

Declaration
[PropertyBitValue(128)]
public DateTime LogDate { get; set; }
Property Value
Type | Description
System.DateTime |

LogEndDate

Declaration
[PropertyBitValue(256)]
public DateTime LogEndDate { get; set; }
Property Value
Type | Description
System.DateTime |

NewStatus

Declaration
[PropertyBitValue(1024)]
public string NewStatus { get; set; }
Property Value
Type | Description
System.String |

Notes

Declaration
[PropertyBitValue(32)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(512)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class LogCaseNoteResult | fcSDK Documentation

Class LogCaseNoteResult

Inheritance
System.Object
ToolkitResult
LogCaseNoteResult
Inherited Members
ToolkitResult._ReturnCode
ToolkitResult._IDNum
ToolkitResult._Objid
ToolkitResult.ReturnCode
ToolkitResult.IDNum
ToolkitResult.Objid
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LogCaseNoteResult : ToolkitResult

Constructors

LogCaseNoteResult()

Declaration
public LogCaseNoteResult()

Properties

CommitmentObjid

Declaration
public int CommitmentObjid { get; set; }
Property Value
Type | Description
System.Int32 |

StatusChangeObjid

Declaration
public int StatusChangeObjid { get; set; }
Property Value
Type | Description
System.Int32 |


Class LogCaseNoteSetup | fcSDK Documentation

Class LogCaseNoteSetup

Inheritance
System.Object
LogCaseNoteSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LogCaseNoteSetup

Constructors

LogCaseNoteSetup(String)

Declaration
[ConstructorIndex(0)]
public LogCaseNoteSetup(string caseIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |

Properties

ActionType

Declaration
[PropertyBitValue(2)]
public string ActionType { get; set; }
Property Value
Type | Description
System.String |

AdditionalFields

Declaration
[PropertyBitValue(8192)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

CaseIDNum

Declaration
[PropertyBitValue(1)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

CommitmentDueDate

Declaration
[PropertyBitValue(512)]
public DateTime CommitmentDueDate { get; set; }
Property Value
Type | Description
System.DateTime |

CommitmentNotes

Declaration
[PropertyBitValue(256)]
public string CommitmentNotes { get; set; }
Property Value
Type | Description
System.String |

CommitmentPriorWarning

Declaration
[PropertyBitValue(1024)]
public TimeSpan CommitmentPriorWarning { get; set; }
Property Value
Type | Description
System.TimeSpan |

CommitmentTitle

Declaration
[PropertyBitValue(128)]
public string CommitmentTitle { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(4096)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

InternalUseOnlyNotes

Declaration
[PropertyBitValue(8)]
public string InternalUseOnlyNotes { get; set; }
Property Value
Type | Description
System.String |

IsCommitmentToCustomer

Declaration
[PropertyBitValue(2048)]
public bool IsCommitmentToCustomer { get; set; }
Property Value
Type | Description
System.Boolean |

LogDate

Declaration
[PropertyBitValue(16)]
public DateTime LogDate { get; set; }
Property Value
Type | Description
System.DateTime |

NewStatus

Declaration
[PropertyBitValue(64)]
public string NewStatus { get; set; }
Property Value
Type | Description
System.String |

Notes

Declaration
[PropertyBitValue(4)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(32)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class LogCasePhoneResult | fcSDK Documentation

Class LogCasePhoneResult

Inheritance
System.Object
ToolkitResult
LogCasePhoneResult
Inherited Members
ToolkitResult._ReturnCode
ToolkitResult._IDNum
ToolkitResult._Objid
ToolkitResult.ReturnCode
ToolkitResult.IDNum
ToolkitResult.Objid
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LogCasePhoneResult : ToolkitResult

Constructors

LogCasePhoneResult()

Declaration
public LogCasePhoneResult()

Properties

CommitmentObjid

Declaration
public int CommitmentObjid { get; set; }
Property Value
Type | Description
System.Int32 |

StatusChangeObjid

Declaration
public int StatusChangeObjid { get; set; }
Property Value
Type | Description
System.Int32 |


Class LogCasePhoneSetup | fcSDK Documentation

Class LogCasePhoneSetup

Inheritance
System.Object
LogCasePhoneSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LogCasePhoneSetup

Constructors

LogCasePhoneSetup(String, String, String, String)

Declaration
[ConstructorIndex(0)]
public LogCasePhoneSetup(string caseIDNum, string contactFirstName, string contactLastName, string contactPhone)
Parameters
Type | Name | Description
System.String | caseIDNum |
System.String | contactFirstName |
System.String | contactLastName |
System.String | contactPhone |

Properties

ActionType

Declaration
[PropertyBitValue(16)]
public string ActionType { get; set; }
Property Value
Type | Description
System.String |

AdditionalFields

Declaration
[PropertyBitValue(131072)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

CaseIDNum

Declaration
[PropertyBitValue(1)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

CommitmentDueDate

Declaration
[PropertyBitValue(8192)]
public DateTime CommitmentDueDate { get; set; }
Property Value
Type | Description
System.DateTime |

CommitmentNotes

Declaration
[PropertyBitValue(4096)]
public string CommitmentNotes { get; set; }
Property Value
Type | Description
System.String |

CommitmentPriorWarning

Declaration
[PropertyBitValue(16384)]
public TimeSpan CommitmentPriorWarning { get; set; }
Property Value
Type | Description
System.TimeSpan |

CommitmentTitle

Declaration
[PropertyBitValue(2048)]
public string CommitmentTitle { get; set; }
Property Value
Type | Description
System.String |

ContactFirstName

Declaration
[PropertyBitValue(2)]
public string ContactFirstName { get; set; }
Property Value
Type | Description
System.String |

ContactLastName

Declaration
[PropertyBitValue(4)]
public string ContactLastName { get; set; }
Property Value
Type | Description
System.String |

ContactPhone

Declaration
[PropertyBitValue(8)]
public string ContactPhone { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(65536)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

InternalUseOnlyNotes

Declaration
[PropertyBitValue(64)]
public string InternalUseOnlyNotes { get; set; }
Property Value
Type | Description
System.String |

IsCommitmentToCustomer

Declaration
[PropertyBitValue(32768)]
public bool IsCommitmentToCustomer { get; set; }
Property Value
Type | Description
System.Boolean |

LogDate

Declaration
[PropertyBitValue(128)]
public DateTime LogDate { get; set; }
Property Value
Type | Description
System.DateTime |

LogEndDate

Declaration
[PropertyBitValue(256)]
public DateTime LogEndDate { get; set; }
Property Value
Type | Description
System.DateTime |

NewStatus

Declaration
[PropertyBitValue(1024)]
public string NewStatus { get; set; }
Property Value
Type | Description
System.String |

Notes

Declaration
[PropertyBitValue(32)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(512)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class LogCaseResearchResult | fcSDK Documentation

Class LogCaseResearchResult

Inheritance
System.Object
ToolkitResult
LogCaseResearchResult
Inherited Members
ToolkitResult._ReturnCode
ToolkitResult._IDNum
ToolkitResult._Objid
ToolkitResult.ReturnCode
ToolkitResult.IDNum
ToolkitResult.Objid
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LogCaseResearchResult : ToolkitResult

Constructors

LogCaseResearchResult()

Declaration
public LogCaseResearchResult()

Properties

CommitmentObjid

Declaration
public int CommitmentObjid { get; set; }
Property Value
Type | Description
System.Int32 |

StatusChangeObjid

Declaration
public int StatusChangeObjid { get; set; }
Property Value
Type | Description
System.Int32 |


Class LogCaseResearchSetup | fcSDK Documentation

Class LogCaseResearchSetup

Inheritance
System.Object
LogCaseResearchSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LogCaseResearchSetup

Constructors

LogCaseResearchSetup(String, TimeSpan)

Declaration
[ConstructorIndex(0)]
public LogCaseResearchSetup(string caseIDNum, TimeSpan researchDuration)
Parameters
Type | Name | Description
System.String | caseIDNum |
System.TimeSpan | researchDuration |

Properties

ActionType

Declaration
[PropertyBitValue(2)]
public string ActionType { get; set; }
Property Value
Type | Description
System.String |

AdditionalFields

Declaration
[PropertyBitValue(16384)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

CaseIDNum

Declaration
[PropertyBitValue(1)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

CommitmentDueDate

Declaration
[PropertyBitValue(1024)]
public DateTime CommitmentDueDate { get; set; }
Property Value
Type | Description
System.DateTime |

CommitmentNotes

Declaration
[PropertyBitValue(512)]
public string CommitmentNotes { get; set; }
Property Value
Type | Description
System.String |

CommitmentPriorWarning

Declaration
[PropertyBitValue(2048)]
public TimeSpan CommitmentPriorWarning { get; set; }
Property Value
Type | Description
System.TimeSpan |

CommitmentTitle

Declaration
[PropertyBitValue(256)]
public string CommitmentTitle { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(8192)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

InternalUseOnlyNotes

Declaration
[PropertyBitValue(8)]
public string InternalUseOnlyNotes { get; set; }
Property Value
Type | Description
System.String |

IsCommitmentToCustomer

Declaration
[PropertyBitValue(4096)]
public bool IsCommitmentToCustomer { get; set; }
Property Value
Type | Description
System.Boolean |

LogDate

Declaration
[PropertyBitValue(16)]
public DateTime LogDate { get; set; }
Property Value
Type | Description
System.DateTime |

NewStatus

Declaration
[PropertyBitValue(128)]
public string NewStatus { get; set; }
Property Value
Type | Description
System.String |

Notes

Declaration
[PropertyBitValue(4)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

ResearchDuration

Declaration
[PropertyBitValue(32)]
public TimeSpan ResearchDuration { get; set; }
Property Value
Type | Description
System.TimeSpan |

UserName

Declaration
[PropertyBitValue(64)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class LogEmailInSetup | fcSDK Documentation

Class LogEmailInSetup

Inheritance
System.Object
LogEmailInSetup
QualityToolkit.LogCREmailInSetup
LogActionItemEmailInSetup
LogCaseEmailInSetup
LogSubCaseEmailInSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public abstract class LogEmailInSetup

Constructors

LogEmailInSetup(String, String, String, String)

Declaration
protected LogEmailInSetup(string idNumber, string sender, string recipient, string message)
Parameters
Type | Name | Description
System.String | idNumber |
System.String | sender |
System.String | recipient |
System.String | message |

Properties

AdditionalFields

Declaration
public SimplifiedAdditionalFields AdditionalFields { get; }
Property Value
Type | Description
SimplifiedAdditionalFields |

CCList

Declaration
public string CCList { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

IDNumber

Declaration
public string IDNumber { get; set; }
Property Value
Type | Description
System.String |

LogDate

Declaration
public DateTime? LogDate { get; set; }
Property Value
Type | Description
System.Nullable<System.DateTime> |

MailLogActionType

Declaration
public string MailLogActionType { get; set; }
Property Value
Type | Description
System.String |

Message

Declaration
public string Message { get; set; }
Property Value
Type | Description
System.String |

Recipient

Declaration
public string Recipient { get; set; }
Property Value
Type | Description
System.String |

Sender

Declaration
public string Sender { get; set; }
Property Value
Type | Description
System.String |

Subject

Declaration
public string Subject { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class LogSubcaseCommitmentSetup | fcSDK Documentation

Class LogSubcaseCommitmentSetup

Inheritance
System.Object
LogSubcaseCommitmentSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LogSubcaseCommitmentSetup

Constructors

LogSubcaseCommitmentSetup(String, String, TimeSpan, String, String, String)

Declaration
[ConstructorIndex(0)]
public LogSubcaseCommitmentSetup(string subcaseIDNum, string title, TimeSpan priorWarning, string contactFirstName, string contactLastName, string contactPhone)
Parameters
Type | Name | Description
System.String | subcaseIDNum |
System.String | title |
System.TimeSpan | priorWarning |
System.String | contactFirstName |
System.String | contactLastName |
System.String | contactPhone |

Properties

ActionType

Declaration
[PropertyBitValue(4)]
public string ActionType { get; set; }
Property Value
Type | Description
System.String |

AdditionalFields

Declaration
[PropertyBitValue(16384)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

CommitmentDate

Declaration
[PropertyBitValue(16)]
public DateTime CommitmentDate { get; set; }
Property Value
Type | Description
System.DateTime |

ContactFirstName

Declaration
[PropertyBitValue(128)]
public string ContactFirstName { get; set; }
Property Value
Type | Description
System.String |

ContactLastName

Declaration
[PropertyBitValue(256)]
public string ContactLastName { get; set; }
Property Value
Type | Description
System.String |

ContactPhone

Declaration
[PropertyBitValue(512)]
public string ContactPhone { get; set; }
Property Value
Type | Description
System.String |

GenerateCommitmentEmail

Declaration
[PropertyBitValue(8192)]
public bool GenerateCommitmentEmail { get; set; }
Property Value
Type | Description
System.Boolean |

GenerateTimeBombs

Declaration
[PropertyBitValue(4096)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

IsMadeToCustomer

Declaration
[PropertyBitValue(64)]
public bool IsMadeToCustomer { get; set; }
Property Value
Type | Description
System.Boolean |

LogDate

Declaration
[PropertyBitValue(8)]
public DateTime LogDate { get; set; }
Property Value
Type | Description
System.DateTime |

Notes

Declaration
[PropertyBitValue(1024)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

PriorWarning

Declaration
[PropertyBitValue(32)]
public TimeSpan PriorWarning { get; set; }
Property Value
Type | Description
System.TimeSpan |

SubcaseIDNum

Declaration
[PropertyBitValue(1)]
public string SubcaseIDNum { get; set; }
Property Value
Type | Description
System.String |

Title

Declaration
[PropertyBitValue(2)]
public string Title { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(2048)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class LogSubCaseEmailInSetup | fcSDK Documentation

Class LogSubCaseEmailInSetup

Inheritance
System.Object
LogEmailInSetup
LogSubCaseEmailInSetup
Inherited Members
LogEmailInSetup.IDNumber
LogEmailInSetup.LogDate
LogEmailInSetup.Message
LogEmailInSetup.Recipient
LogEmailInSetup.Sender
LogEmailInSetup.Subject
LogEmailInSetup.CCList
LogEmailInSetup.UserName
LogEmailInSetup.GenerateTimeBombs
LogEmailInSetup.AdditionalFields
LogEmailInSetup.MailLogActionType
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LogSubCaseEmailInSetup : LogEmailInSetup

Constructors

LogSubCaseEmailInSetup(String, String, String, String)

Declaration
public LogSubCaseEmailInSetup(string subcaseIDNum, string sender, string recipient, string message)
Parameters
Type | Name | Description
System.String | subcaseIDNum |
System.String | sender |
System.String | recipient |
System.String | message |


Class LogSubcaseEmailResult | fcSDK Documentation

Class LogSubcaseEmailResult

Inheritance
System.Object
ToolkitResult
LogSubcaseEmailResult
Inherited Members
ToolkitResult._ReturnCode
ToolkitResult._IDNum
ToolkitResult._Objid
ToolkitResult.ReturnCode
ToolkitResult.IDNum
ToolkitResult.Objid
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LogSubcaseEmailResult : ToolkitResult

Constructors

LogSubcaseEmailResult()

Declaration
public LogSubcaseEmailResult()

Properties

CommitmentObjid

Declaration
public int CommitmentObjid { get; set; }
Property Value
Type | Description
System.Int32 |

StatusChangeObjid

Declaration
public int StatusChangeObjid { get; set; }
Property Value
Type | Description
System.Int32 |


Class LogSubcaseEmailSetup | fcSDK Documentation

Class LogSubcaseEmailSetup

Inheritance
System.Object
LogSubcaseEmailSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LogSubcaseEmailSetup

Constructors

LogSubcaseEmailSetup(String)

Declaration
[ConstructorIndex(0)]
public LogSubcaseEmailSetup(string subcaseIDNum)
Parameters
Type | Name | Description
System.String | subcaseIDNum |

Properties

ActionType

Declaration
[PropertyBitValue(2)]
public string ActionType { get; set; }
Property Value
Type | Description
System.String |

AdditionalFields

Declaration
[PropertyBitValue(131072)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

CCList

Declaration
[PropertyBitValue(32)]
public string CCList { get; set; }
Property Value
Type | Description
System.String |

CommitmentActionType

Declaration
[PropertyBitValue(8192)]
public string CommitmentActionType { get; set; }
Property Value
Type | Description
System.String |

CommitmentContactObjid

Declaration
[PropertyBitValue(16384)]
public int CommitmentContactObjid { get; set; }
Property Value
Type | Description
System.Int32 |

CommitmentDueDate

Declaration
[PropertyBitValue(1024)]
public DateTime CommitmentDueDate { get; set; }
Property Value
Type | Description
System.DateTime |

CommitmentNotes

Declaration
[PropertyBitValue(512)]
public string CommitmentNotes { get; set; }
Property Value
Type | Description
System.String |

CommitmentPriorWarning

Declaration
[PropertyBitValue(2048)]
public TimeSpan CommitmentPriorWarning { get; set; }
Property Value
Type | Description
System.TimeSpan |

CommitmentTitle

Declaration
[PropertyBitValue(256)]
public string CommitmentTitle { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(32768)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

IsCommitmentToCustomer

Declaration
[PropertyBitValue(4096)]
public bool IsCommitmentToCustomer { get; set; }
Property Value
Type | Description
System.Boolean |

LogDate

Declaration
[PropertyBitValue(4)]
public DateTime LogDate { get; set; }
Property Value
Type | Description
System.DateTime |

Message

Declaration
[PropertyBitValue(8)]
public string Message { get; set; }
Property Value
Type | Description
System.String |

NewStatus

Declaration
[PropertyBitValue(128)]
public string NewStatus { get; set; }
Property Value
Type | Description
System.String |

Recipient

Declaration
[PropertyBitValue(16)]
public string Recipient { get; set; }
Property Value
Type | Description
System.String |

SendEmail

Declaration
[PropertyBitValue(65536)]
public bool SendEmail { get; set; }
Property Value
Type | Description
System.Boolean |

SubcaseIDNum

Declaration
[PropertyBitValue(1)]
public string SubcaseIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(64)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class LogSubcaseInternalNoteSetup | fcSDK Documentation

Class LogSubcaseInternalNoteSetup

Inheritance
System.Object
LogSubcaseInternalNoteSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LogSubcaseInternalNoteSetup

Constructors

LogSubcaseInternalNoteSetup(String)

Declaration
[ConstructorIndex(0)]
public LogSubcaseInternalNoteSetup(string subcaseIDNum)
Parameters
Type | Name | Description
System.String | subcaseIDNum |

Properties

ActionType

Declaration
[PropertyBitValue(2)]
public string ActionType { get; set; }
Property Value
Type | Description
System.String |

AdditionalFields

Declaration
[PropertyBitValue(8192)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

CommitmentDueDate

Declaration
[PropertyBitValue(512)]
public DateTime CommitmentDueDate { get; set; }
Property Value
Type | Description
System.DateTime |

CommitmentNotes

Declaration
[PropertyBitValue(256)]
public string CommitmentNotes { get; set; }
Property Value
Type | Description
System.String |

CommitmentPriorWarning

Declaration
[PropertyBitValue(1024)]
public TimeSpan CommitmentPriorWarning { get; set; }
Property Value
Type | Description
System.TimeSpan |

CommitmentTitle

Declaration
[PropertyBitValue(128)]
public string CommitmentTitle { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(4096)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

IsCommitmentToCustomer

Declaration
[PropertyBitValue(2048)]
public bool IsCommitmentToCustomer { get; set; }
Property Value
Type | Description
System.Boolean |

LogDate

Declaration
[PropertyBitValue(16)]
public DateTime LogDate { get; set; }
Property Value
Type | Description
System.DateTime |

NewStatus

Declaration
[PropertyBitValue(64)]
public string NewStatus { get; set; }
Property Value
Type | Description
System.String |

Notes

Declaration
[PropertyBitValue(4)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

SubcaseIDNum

Declaration
[PropertyBitValue(1)]
public string SubcaseIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(32)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class LogSubcaseInternalPhoneSetup | fcSDK Documentation

Class LogSubcaseInternalPhoneSetup

Inheritance
System.Object
LogSubcaseInternalPhoneSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LogSubcaseInternalPhoneSetup

Constructors

LogSubcaseInternalPhoneSetup(String, String, String, String)

Declaration
[ConstructorIndex(0)]
public LogSubcaseInternalPhoneSetup(string subcaseIDNum, string contactFirstName, string contactLastName, string contactPhone)
Parameters
Type | Name | Description
System.String | subcaseIDNum |
System.String | contactFirstName |
System.String | contactLastName |
System.String | contactPhone |

Properties

ActionType

Declaration
[PropertyBitValue(16)]
public string ActionType { get; set; }
Property Value
Type | Description
System.String |

AdditionalFields

Declaration
[PropertyBitValue(131072)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

CommitmentDueDate

Declaration
[PropertyBitValue(8192)]
public DateTime CommitmentDueDate { get; set; }
Property Value
Type | Description
System.DateTime |

CommitmentNotes

Declaration
[PropertyBitValue(4096)]
public string CommitmentNotes { get; set; }
Property Value
Type | Description
System.String |

CommitmentPriorWarning

Declaration
[PropertyBitValue(16384)]
public TimeSpan CommitmentPriorWarning { get; set; }
Property Value
Type | Description
System.TimeSpan |

CommitmentTitle

Declaration
[PropertyBitValue(2048)]
public string CommitmentTitle { get; set; }
Property Value
Type | Description
System.String |

ContactFirstName

Declaration
[PropertyBitValue(2)]
public string ContactFirstName { get; set; }
Property Value
Type | Description
System.String |

ContactLastName

Declaration
[PropertyBitValue(4)]
public string ContactLastName { get; set; }
Property Value
Type | Description
System.String |

ContactPhone

Declaration
[PropertyBitValue(8)]
public string ContactPhone { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(65536)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

IsCommitmentToCustomer

Declaration
[PropertyBitValue(32768)]
public bool IsCommitmentToCustomer { get; set; }
Property Value
Type | Description
System.Boolean |

LogDate

Declaration
[PropertyBitValue(128)]
public DateTime LogDate { get; set; }
Property Value
Type | Description
System.DateTime |

LogEndDate

Declaration
[PropertyBitValue(256)]
public DateTime LogEndDate { get; set; }
Property Value
Type | Description
System.DateTime |

NewStatus

Declaration
[PropertyBitValue(1024)]
public string NewStatus { get; set; }
Property Value
Type | Description
System.String |

Notes

Declaration
[PropertyBitValue(32)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

SubcaseIDNum

Declaration
[PropertyBitValue(1)]
public string SubcaseIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(512)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class LogSubcaseNoteResult | fcSDK Documentation

Class LogSubcaseNoteResult

Inheritance
System.Object
ToolkitResult
LogSubcaseNoteResult
Inherited Members
ToolkitResult._ReturnCode
ToolkitResult._IDNum
ToolkitResult._Objid
ToolkitResult.ReturnCode
ToolkitResult.IDNum
ToolkitResult.Objid
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LogSubcaseNoteResult : ToolkitResult

Constructors

LogSubcaseNoteResult()

Declaration
public LogSubcaseNoteResult()

Properties

CommitmentObjid

Declaration
public int CommitmentObjid { get; set; }
Property Value
Type | Description
System.Int32 |

StatusChangeObjid

Declaration
public int StatusChangeObjid { get; set; }
Property Value
Type | Description
System.Int32 |


Class LogSubcaseNoteSetup | fcSDK Documentation

Class LogSubcaseNoteSetup

Inheritance
System.Object
LogSubcaseNoteSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LogSubcaseNoteSetup

Constructors

LogSubcaseNoteSetup(String)

Declaration
[ConstructorIndex(0)]
public LogSubcaseNoteSetup(string subcaseIDNum)
Parameters
Type | Name | Description
System.String | subcaseIDNum |

Properties

ActionType

Declaration
[PropertyBitValue(2)]
public string ActionType { get; set; }
Property Value
Type | Description
System.String |

AdditionalFields

Declaration
[PropertyBitValue(8192)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

CommitmentDueDate

Declaration
[PropertyBitValue(512)]
public DateTime CommitmentDueDate { get; set; }
Property Value
Type | Description
System.DateTime |

CommitmentNotes

Declaration
[PropertyBitValue(256)]
public string CommitmentNotes { get; set; }
Property Value
Type | Description
System.String |

CommitmentPriorWarning

Declaration
[PropertyBitValue(1024)]
public TimeSpan CommitmentPriorWarning { get; set; }
Property Value
Type | Description
System.TimeSpan |

CommitmentTitle

Declaration
[PropertyBitValue(128)]
public string CommitmentTitle { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(4096)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

InternalUseOnlyNotes

Declaration
[PropertyBitValue(8)]
public string InternalUseOnlyNotes { get; set; }
Property Value
Type | Description
System.String |

IsCommitmentToCustomer

Declaration
[PropertyBitValue(2048)]
public bool IsCommitmentToCustomer { get; set; }
Property Value
Type | Description
System.Boolean |

LogDate

Declaration
[PropertyBitValue(16)]
public DateTime LogDate { get; set; }
Property Value
Type | Description
System.DateTime |

NewStatus

Declaration
[PropertyBitValue(64)]
public string NewStatus { get; set; }
Property Value
Type | Description
System.String |

Notes

Declaration
[PropertyBitValue(4)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

SubcaseIDNum

Declaration
[PropertyBitValue(1)]
public string SubcaseIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(32)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class LogSubcasePhoneResult | fcSDK Documentation

Class LogSubcasePhoneResult

Inheritance
System.Object
ToolkitResult
LogSubcasePhoneResult
Inherited Members
ToolkitResult._ReturnCode
ToolkitResult._IDNum
ToolkitResult._Objid
ToolkitResult.ReturnCode
ToolkitResult.IDNum
ToolkitResult.Objid
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LogSubcasePhoneResult : ToolkitResult

Constructors

LogSubcasePhoneResult()

Declaration
public LogSubcasePhoneResult()

Properties

CommitmentObjid

Declaration
public int CommitmentObjid { get; set; }
Property Value
Type | Description
System.Int32 |

StatusChangeObjid

Declaration
public int StatusChangeObjid { get; set; }
Property Value
Type | Description
System.Int32 |


Class LogSubcasePhoneSetup | fcSDK Documentation

Class LogSubcasePhoneSetup

Inheritance
System.Object
LogSubcasePhoneSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LogSubcasePhoneSetup

Constructors

LogSubcasePhoneSetup(String, String, String, String)

Declaration
[ConstructorIndex(0)]
public LogSubcasePhoneSetup(string subcaseIDNum, string contactFirstName, string contactLastName, string contactPhone)
Parameters
Type | Name | Description
System.String | subcaseIDNum |
System.String | contactFirstName |
System.String | contactLastName |
System.String | contactPhone |

Properties

ActionType

Declaration
[PropertyBitValue(16)]
public string ActionType { get; set; }
Property Value
Type | Description
System.String |

AdditionalFields

Declaration
[PropertyBitValue(131072)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

CommitmentDueDate

Declaration
[PropertyBitValue(8192)]
public DateTime CommitmentDueDate { get; set; }
Property Value
Type | Description
System.DateTime |

CommitmentNotes

Declaration
[PropertyBitValue(4096)]
public string CommitmentNotes { get; set; }
Property Value
Type | Description
System.String |

CommitmentPriorWarning

Declaration
[PropertyBitValue(16384)]
public TimeSpan CommitmentPriorWarning { get; set; }
Property Value
Type | Description
System.TimeSpan |

CommitmentTitle

Declaration
[PropertyBitValue(2048)]
public string CommitmentTitle { get; set; }
Property Value
Type | Description
System.String |

ContactFirstName

Declaration
[PropertyBitValue(2)]
public string ContactFirstName { get; set; }
Property Value
Type | Description
System.String |

ContactLastName

Declaration
[PropertyBitValue(4)]
public string ContactLastName { get; set; }
Property Value
Type | Description
System.String |

ContactPhone

Declaration
[PropertyBitValue(8)]
public string ContactPhone { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(65536)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

InternalUseOnlyNotes

Declaration
[PropertyBitValue(64)]
public string InternalUseOnlyNotes { get; set; }
Property Value
Type | Description
System.String |

IsCommitmentToCustomer

Declaration
[PropertyBitValue(32768)]
public bool IsCommitmentToCustomer { get; set; }
Property Value
Type | Description
System.Boolean |

LogDate

Declaration
[PropertyBitValue(128)]
public DateTime LogDate { get; set; }
Property Value
Type | Description
System.DateTime |

LogEndDate

Declaration
[PropertyBitValue(256)]
public DateTime LogEndDate { get; set; }
Property Value
Type | Description
System.DateTime |

NewStatus

Declaration
[PropertyBitValue(1024)]
public string NewStatus { get; set; }
Property Value
Type | Description
System.String |

Notes

Declaration
[PropertyBitValue(32)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

SubcaseIDNum

Declaration
[PropertyBitValue(1)]
public string SubcaseIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(512)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class LogSubcaseResearchResult | fcSDK Documentation

Class LogSubcaseResearchResult

Inheritance
System.Object
ToolkitResult
LogSubcaseResearchResult
Inherited Members
ToolkitResult._ReturnCode
ToolkitResult._IDNum
ToolkitResult._Objid
ToolkitResult.ReturnCode
ToolkitResult.IDNum
ToolkitResult.Objid
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LogSubcaseResearchResult : ToolkitResult

Constructors

LogSubcaseResearchResult()

Declaration
public LogSubcaseResearchResult()

Properties

CommitmentObjid

Declaration
public int CommitmentObjid { get; set; }
Property Value
Type | Description
System.Int32 |

StatusChangeObjid

Declaration
public int StatusChangeObjid { get; set; }
Property Value
Type | Description
System.Int32 |


Class LogSubcaseResearchSetup | fcSDK Documentation

Class LogSubcaseResearchSetup

Inheritance
System.Object
LogSubcaseResearchSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class LogSubcaseResearchSetup

Constructors

LogSubcaseResearchSetup(String, TimeSpan)

Declaration
[ConstructorIndex(0)]
public LogSubcaseResearchSetup(string subcaseIDNum, TimeSpan researchDuration)
Parameters
Type | Name | Description
System.String | subcaseIDNum |
System.TimeSpan | researchDuration |

Properties

ActionType

Declaration
[PropertyBitValue(2)]
public string ActionType { get; set; }
Property Value
Type | Description
System.String |

AdditionalFields

Declaration
[PropertyBitValue(16384)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

CommitmentDueDate

Declaration
[PropertyBitValue(1024)]
public DateTime CommitmentDueDate { get; set; }
Property Value
Type | Description
System.DateTime |

CommitmentNotes

Declaration
[PropertyBitValue(512)]
public string CommitmentNotes { get; set; }
Property Value
Type | Description
System.String |

CommitmentPriorWarning

Declaration
[PropertyBitValue(2048)]
public TimeSpan CommitmentPriorWarning { get; set; }
Property Value
Type | Description
System.TimeSpan |

CommitmentTitle

Declaration
[PropertyBitValue(256)]
public string CommitmentTitle { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(8192)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

InternalUseOnlyNotes

Declaration
[PropertyBitValue(8)]
public string InternalUseOnlyNotes { get; set; }
Property Value
Type | Description
System.String |

IsCommitmentToCustomer

Declaration
[PropertyBitValue(4096)]
public bool IsCommitmentToCustomer { get; set; }
Property Value
Type | Description
System.Boolean |

LogDate

Declaration
[PropertyBitValue(16)]
public DateTime LogDate { get; set; }
Property Value
Type | Description
System.DateTime |

NewStatus

Declaration
[PropertyBitValue(128)]
public string NewStatus { get; set; }
Property Value
Type | Description
System.String |

Notes

Declaration
[PropertyBitValue(4)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

ResearchDuration

Declaration
[PropertyBitValue(32)]
public TimeSpan ResearchDuration { get; set; }
Property Value
Type | Description
System.TimeSpan |

SubcaseIDNum

Declaration
[PropertyBitValue(1)]
public string SubcaseIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(64)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class MoveCaseSetup | fcSDK Documentation

Class MoveCaseSetup

Inheritance
System.Object
MoveCaseSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class MoveCaseSetup

Constructors

MoveCaseSetup(String, String)

Declaration
[ConstructorIndex(0)]
public MoveCaseSetup(string caseIDNum, string newWipBin)
Parameters
Type | Name | Description
System.String | caseIDNum |
System.String | newWipBin |

Properties

CaseIDNum

Declaration
[PropertyBitValue(1)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

NewWipBin

Declaration
[PropertyBitValue(2)]
public string NewWipBin { get; set; }
Property Value
Type | Description
System.String |


Class MoveSubcaseSetup | fcSDK Documentation

Class MoveSubcaseSetup

Inheritance
System.Object
MoveSubcaseSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class MoveSubcaseSetup

Constructors

MoveSubcaseSetup(String, String)

Declaration
[ConstructorIndex(0)]
public MoveSubcaseSetup(string subcaseIDNum, string newWipBin)
Parameters
Type | Name | Description
System.String | subcaseIDNum |
System.String | newWipBin |

Properties

NewWipBin

Declaration
[PropertyBitValue(2)]
public string NewWipBin { get; set; }
Property Value
Type | Description
System.String |

SubcaseIDNum

Declaration
[PropertyBitValue(1)]
public string SubcaseIDNum { get; set; }
Property Value
Type | Description
System.String |


Class RejectCaseSetup | fcSDK Documentation

Class RejectCaseSetup

Inheritance
System.Object
RejectCaseSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class RejectCaseSetup

Constructors

RejectCaseSetup(String)

Declaration
[ConstructorIndex(0)]
public RejectCaseSetup(string caseIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |

Properties

CaseIDNum

Declaration
[PropertyBitValue(1)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

Notes

Declaration
[PropertyBitValue(8)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

RejectDate

Declaration
[PropertyBitValue(2)]
public DateTime RejectDate { get; set; }
Property Value
Type | Description
System.DateTime |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(4)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |


Class RejectSubcaseSetup | fcSDK Documentation

Class RejectSubcaseSetup

Inheritance
System.Object
RejectSubcaseSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class RejectSubcaseSetup

Constructors

RejectSubcaseSetup(String)

Declaration
[ConstructorIndex(0)]
public RejectSubcaseSetup(string subcaseIDNum)
Parameters
Type | Name | Description
System.String | subcaseIDNum |

Properties

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

Notes

Declaration
[PropertyBitValue(8)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

RejectDate

Declaration
[PropertyBitValue(2)]
public DateTime RejectDate { get; set; }
Property Value
Type | Description
System.DateTime |

SubcaseIDNum

Declaration
[PropertyBitValue(1)]
public string SubcaseIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(4)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |


Class RelateCaseToParentCaseSetup | fcSDK Documentation

Class RelateCaseToParentCaseSetup

Inheritance
System.Object
RelateCaseToParentCaseSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class RelateCaseToParentCaseSetup

Constructors

RelateCaseToParentCaseSetup(String, String)

Declaration
[ConstructorIndex(0)]
public RelateCaseToParentCaseSetup(string caseIDNum, string parentCaseIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |
System.String | parentCaseIDNum |

Properties

CaseIDNum

Declaration
[PropertyBitValue(1)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

ParentCaseIDNum

Declaration
[PropertyBitValue(2)]
public string ParentCaseIDNum { get; set; }
Property Value
Type | Description
System.String |


Class ReopenCaseSetup | fcSDK Documentation

Class ReopenCaseSetup

Inheritance
System.Object
ReopenCaseSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ReopenCaseSetup

Constructors

ReopenCaseSetup(String)

Declaration
[ConstructorIndex(0)]
public ReopenCaseSetup(string caseIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |

Properties

CaseIDNum

Declaration
[PropertyBitValue(1)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

ReopenDate

Declaration
[PropertyBitValue(8)]
public DateTime ReopenDate { get; set; }
Property Value
Type | Description
System.DateTime |

Status

Declaration
[PropertyBitValue(4)]
public string Status { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(2)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |


Class ReopenSubcaseSetup | fcSDK Documentation

Class ReopenSubcaseSetup

Inheritance
System.Object
ReopenSubcaseSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ReopenSubcaseSetup

Constructors

ReopenSubcaseSetup(String)

Declaration
[ConstructorIndex(0)]
public ReopenSubcaseSetup(string subcaseIDNum)
Parameters
Type | Name | Description
System.String | subcaseIDNum |

Properties

GenerateTimeBombs

Declaration
[PropertyBitValue(32)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

ReopenDate

Declaration
[PropertyBitValue(8)]
public DateTime ReopenDate { get; set; }
Property Value
Type | Description
System.DateTime |

Status

Declaration
[PropertyBitValue(4)]
public string Status { get; set; }
Property Value
Type | Description
System.String |

SubcaseIDNum

Declaration
[PropertyBitValue(1)]
public string SubcaseIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(2)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |


Class SubcaseTimeAndExpenses | fcSDK Documentation

Class SubcaseTimeAndExpenses

Inheritance
System.Object
SubcaseTimeAndExpenses
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class SubcaseTimeAndExpenses

Constructors

SubcaseTimeAndExpenses()

Declaration
public SubcaseTimeAndExpenses()

Properties

CapturedPhoneTime

Declaration
public TimeSpan CapturedPhoneTime { get; set; }
Property Value
Type | Description
System.TimeSpan |

CapturedResearchTime

Declaration
public TimeSpan CapturedResearchTime { get; set; }
Property Value
Type | Description
System.TimeSpan |

TotalBillableExpenses

Declaration
public decimal TotalBillableExpenses { get; set; }
Property Value
Type | Description
System.Decimal |

TotalBillableTime

Declaration
public TimeSpan TotalBillableTime { get; set; }
Property Value
Type | Description
System.TimeSpan |

TotalNonBillableExpenses

Declaration
public decimal TotalNonBillableExpenses { get; set; }
Property Value
Type | Description
System.Decimal |

TotalNonBillableTime

Declaration
public TimeSpan TotalNonBillableTime { get; set; }
Property Value
Type | Description
System.TimeSpan |


Class SupportToolkit | fcSDK Documentation

Class SupportToolkit

Inheritance
System.Object
ToolkitBase
SupportToolkitBase
SupportToolkit
Inherited Members
SupportToolkitBase._toolkit
SupportToolkitBase.UseDenormalizedCaseTypeLevels
SupportToolkitBase.ImpersonatorUsername
ToolkitBase.NOW_DATE
ToolkitBase.CompatSession
ToolkitBase.WithTransaction<T>(Func<IDbTransaction, T>)
ToolkitBase.FCApplication
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class SupportToolkit : SupportToolkitBase

Constructors

SupportToolkit(ClarifySession)

Declaration
public SupportToolkit(ClarifySession session)
Parameters
Type | Name | Description
ClarifySession | session |

SupportToolkit(IFCApplication, IFCSession)

Declaration
public SupportToolkit(IFCApplication application, IFCSession session)
Parameters
Type | Name | Description
IFCApplication | application |
IFCSession | session |

Fields

IsInternalLogIndicator

Declaration
public static string IsInternalLogIndicator
Field Value
Type | Description
System.String |

Properties

ApplicationClock

Declaration
public IApplicationClock ApplicationClock { get; set; }
Property Value
Type | Description
IApplicationClock |

Methods

AcceptCase(AcceptCaseSetup)

Declaration
public ToolkitResult AcceptCase(AcceptCaseSetup setupParam)
Parameters
Type | Name | Description
AcceptCaseSetup | setupParam |
Returns
Type | Description
ToolkitResult |

AcceptCase(AcceptCaseSetup, IDbTransaction)

Declaration
public ToolkitResult AcceptCase(AcceptCaseSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
AcceptCaseSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

AcceptCase(String)

Declaration
public ToolkitResult AcceptCase(string caseIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |
Returns
Type | Description
ToolkitResult |

AcceptSubcase(AcceptSubcaseSetup)

Declaration
public ToolkitResult AcceptSubcase(AcceptSubcaseSetup setupParam)
Parameters
Type | Name | Description
AcceptSubcaseSetup | setupParam |
Returns
Type | Description
ToolkitResult |

AcceptSubcase(AcceptSubcaseSetup, IDbTransaction)

Declaration
public ToolkitResult AcceptSubcase(AcceptSubcaseSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
AcceptSubcaseSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

AcceptSubcase(String)

Declaration
public ToolkitResult AcceptSubcase(string subcaseIDNum)
Parameters
Type | Name | Description
System.String | subcaseIDNum |
Returns
Type | Description
ToolkitResult |

AppendHistoryToCase(String, String)

Declaration
public void AppendHistoryToCase(string caseIdNumber, string stringToAppendToHistory)
Parameters
Type | Name | Description
System.String | caseIdNumber |
System.String | stringToAppendToHistory |

AppendHistoryToCase(String, String, IDbTransaction)

Declaration
public void AppendHistoryToCase(string caseIdNumber, string stringToAppendToHistory, IDbTransaction dbTransaction)
Parameters
Type | Name | Description
System.String | caseIdNumber |
System.String | stringToAppendToHistory |
System.Data.IDbTransaction | dbTransaction |

AppendHistoryToSubCase(String, String)

Declaration
public void AppendHistoryToSubCase(string subCaseIdNumber, string stringToAppendToHistory)
Parameters
Type | Name | Description
System.String | subCaseIdNumber |
System.String | stringToAppendToHistory |

AppendHistoryToSubCase(String, String, IDbTransaction)

Declaration
public void AppendHistoryToSubCase(string subCaseIdNumber, string stringToAppendToHistory, IDbTransaction dbTransaction)
Parameters
Type | Name | Description
System.String | subCaseIdNumber |
System.String | stringToAppendToHistory |
System.Data.IDbTransaction | dbTransaction |

AssignCase(AssignCaseSetup)

Declaration
public ToolkitResult AssignCase(AssignCaseSetup setupParam)
Parameters
Type | Name | Description
AssignCaseSetup | setupParam |
Returns
Type | Description
ToolkitResult |

AssignCase(AssignCaseSetup, IDbTransaction)

Declaration
public ToolkitResult AssignCase(AssignCaseSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
AssignCaseSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

AssignCase(String)

Declaration
public ToolkitResult AssignCase(string caseIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |
Returns
Type | Description
ToolkitResult |

AssignSubcase(AssignSubcaseSetup)

Declaration
public ToolkitResult AssignSubcase(AssignSubcaseSetup setupParam)
Parameters
Type | Name | Description
AssignSubcaseSetup | setupParam |
Returns
Type | Description
ToolkitResult |

AssignSubcase(AssignSubcaseSetup, IDbTransaction)

Declaration
public ToolkitResult AssignSubcase(AssignSubcaseSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
AssignSubcaseSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

AssignSubcase(String)

Declaration
public ToolkitResult AssignSubcase(string subcaseIDNum)
Parameters
Type | Name | Description
System.String | subcaseIDNum |
Returns
Type | Description
ToolkitResult |

ChangeCaseContact(ChangeCaseContactSetup)

Declaration
public ToolkitResult ChangeCaseContact(ChangeCaseContactSetup setupParam)
Parameters
Type | Name | Description
ChangeCaseContactSetup | setupParam |
Returns
Type | Description
ToolkitResult |

ChangeCaseContact(ChangeCaseContactSetup, IDbTransaction)

Declaration
public ToolkitResult ChangeCaseContact(ChangeCaseContactSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
ChangeCaseContactSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

ChangeCaseContact(String, String, String, String)

Declaration
public ToolkitResult ChangeCaseContact(string caseIDNum, string contactFirstName, string contactLastName, string contactPhone)
Parameters
Type | Name | Description
System.String | caseIDNum |
System.String | contactFirstName |
System.String | contactLastName |
System.String | contactPhone |
Returns
Type | Description
ToolkitResult |

ChangeCaseSite(ChangeCaseSiteSetup)

Declaration
public ToolkitResult ChangeCaseSite(ChangeCaseSiteSetup setupParam)
Parameters
Type | Name | Description
ChangeCaseSiteSetup | setupParam |
Returns
Type | Description
ToolkitResult |

ChangeCaseSite(ChangeCaseSiteSetup, IDbTransaction)

Declaration
public ToolkitResult ChangeCaseSite(ChangeCaseSiteSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
ChangeCaseSiteSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

ChangeCaseSite(String, String)

Declaration
public ToolkitResult ChangeCaseSite(string caseIDNum, string siteIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |
System.String | siteIDNum |
Returns
Type | Description
ToolkitResult |

ChangeCaseStatus(ChangeCaseStatusSetup)

Declaration
public ToolkitResult ChangeCaseStatus(ChangeCaseStatusSetup setupParam)
Parameters
Type | Name | Description
ChangeCaseStatusSetup | setupParam |
Returns
Type | Description
ToolkitResult |

ChangeCaseStatus(ChangeCaseStatusSetup, IDbTransaction)

Declaration
public ToolkitResult ChangeCaseStatus(ChangeCaseStatusSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
ChangeCaseStatusSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

ChangeCaseStatus(String)

Declaration
public ToolkitResult ChangeCaseStatus(string caseIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |
Returns
Type | Description
ToolkitResult |

ChangeSubcaseStatus(ChangeSubcaseStatusSetup)

Declaration
public ToolkitResult ChangeSubcaseStatus(ChangeSubcaseStatusSetup setupParam)
Parameters
Type | Name | Description
ChangeSubcaseStatusSetup | setupParam |
Returns
Type | Description
ToolkitResult |

ChangeSubcaseStatus(ChangeSubcaseStatusSetup, IDbTransaction)

Declaration
public ToolkitResult ChangeSubcaseStatus(ChangeSubcaseStatusSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
ChangeSubcaseStatusSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

ChangeSubcaseStatus(String)

Declaration
public ToolkitResult ChangeSubcaseStatus(string subcaseIDNum)
Parameters
Type | Name | Description
System.String | subcaseIDNum |
Returns
Type | Description
ToolkitResult |

CloseCase(CloseCaseSetup)

Declaration
public ToolkitResult CloseCase(CloseCaseSetup setupParam)
Parameters
Type | Name | Description
CloseCaseSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CloseCase(CloseCaseSetup, IDbTransaction)

Declaration
public ToolkitResult CloseCase(CloseCaseSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CloseCaseSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CloseCase(String)

Declaration
public ToolkitResult CloseCase(string caseIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |
Returns
Type | Description
ToolkitResult |

CloseSubcase(CloseSubcaseSetup)

Declaration
public ToolkitResult CloseSubcase(CloseSubcaseSetup setupParam)
Parameters
Type | Name | Description
CloseSubcaseSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CloseSubcase(CloseSubcaseSetup, IDbTransaction)

Declaration
public ToolkitResult CloseSubcase(CloseSubcaseSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CloseSubcaseSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CloseSubcase(String)

Declaration
public ToolkitResult CloseSubcase(string subcaseIDNum)
Parameters
Type | Name | Description
System.String | subcaseIDNum |
Returns
Type | Description
ToolkitResult |

CreateCase(CreateCaseSetup)

Declaration
public ToolkitResult CreateCase(CreateCaseSetup setupParam)
Parameters
Type | Name | Description
CreateCaseSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreateCase(CreateCaseSetup, IDbTransaction)

Declaration
public ToolkitResult CreateCase(CreateCaseSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateCaseSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreateCase(String, String, String, String)

Declaration
public ToolkitResult CreateCase(string siteIDNum, string contactFirstName, string contactLastName, string contactPhone)
Parameters
Type | Name | Description
System.String | siteIDNum |
System.String | contactFirstName |
System.String | contactLastName |
System.String | contactPhone |
Returns
Type | Description
ToolkitResult |

CreateCaseObjid()

Declaration
public ToolkitResult CreateCaseObjid()
Returns
Type | Description
ToolkitResult |

CreateCaseObjid(CreateCaseObjidSetup)

Declaration
public ToolkitResult CreateCaseObjid(CreateCaseObjidSetup setupParam)
Parameters
Type | Name | Description
CreateCaseObjidSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreateCaseObjid(CreateCaseObjidSetup, IDbTransaction)

Declaration
public ToolkitResult CreateCaseObjid(CreateCaseObjidSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateCaseObjidSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreateSubcase(CreateSubcaseSetup)

Declaration
public ToolkitResult CreateSubcase(CreateSubcaseSetup setupParam)
Parameters
Type | Name | Description
CreateSubcaseSetup | setupParam |
Returns
Type | Description
ToolkitResult |

CreateSubcase(CreateSubcaseSetup, IDbTransaction)

Declaration
public ToolkitResult CreateSubcase(CreateSubcaseSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
CreateSubcaseSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

CreateSubcase(String)

Declaration
public ToolkitResult CreateSubcase(string caseIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |
Returns
Type | Description
ToolkitResult |

DispatchCase(DispatchCaseSetup)

Declaration
public ToolkitResult DispatchCase(DispatchCaseSetup setupParam)
Parameters
Type | Name | Description
DispatchCaseSetup | setupParam |
Returns
Type | Description
ToolkitResult |

DispatchCase(DispatchCaseSetup, IDbTransaction)

Declaration
public ToolkitResult DispatchCase(DispatchCaseSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
DispatchCaseSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

DispatchCase(String, String)

Declaration
public ToolkitResult DispatchCase(string caseIDNum, string queue)
Parameters
Type | Name | Description
System.String | caseIDNum |
System.String | queue |
Returns
Type | Description
ToolkitResult |

DispatchSubcase(DispatchSubcaseSetup)

Declaration
public ToolkitResult DispatchSubcase(DispatchSubcaseSetup setupParam)
Parameters
Type | Name | Description
DispatchSubcaseSetup | setupParam |
Returns
Type | Description
ToolkitResult |

DispatchSubcase(DispatchSubcaseSetup, IDbTransaction)

Declaration
public ToolkitResult DispatchSubcase(DispatchSubcaseSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
DispatchSubcaseSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

DispatchSubcase(String, String)

Declaration
public ToolkitResult DispatchSubcase(string subcaseIDNum, string queue)
Parameters
Type | Name | Description
System.String | subcaseIDNum |
System.String | queue |
Returns
Type | Description
ToolkitResult |

ForwardCase(ForwardCaseSetup)

Declaration
public ToolkitResult ForwardCase(ForwardCaseSetup setupParam)
Parameters
Type | Name | Description
ForwardCaseSetup | setupParam |
Returns
Type | Description
ToolkitResult |

ForwardCase(ForwardCaseSetup, IDbTransaction)

Declaration
public ToolkitResult ForwardCase(ForwardCaseSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
ForwardCaseSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

ForwardCase(String, String)

Declaration
public ToolkitResult ForwardCase(string caseIDNum, string newQueue)
Parameters
Type | Name | Description
System.String | caseIDNum |
System.String | newQueue |
Returns
Type | Description
ToolkitResult |

ForwardSubcase(ForwardSubcaseSetup)

Declaration
public ToolkitResult ForwardSubcase(ForwardSubcaseSetup setupParam)
Parameters
Type | Name | Description
ForwardSubcaseSetup | setupParam |
Returns
Type | Description
ToolkitResult |

ForwardSubcase(ForwardSubcaseSetup, IDbTransaction)

Declaration
public ToolkitResult ForwardSubcase(ForwardSubcaseSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
ForwardSubcaseSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

ForwardSubcase(String, String)

Declaration
public ToolkitResult ForwardSubcase(string subcaseIDNum, string newQueue)
Parameters
Type | Name | Description
System.String | subcaseIDNum |
System.String | newQueue |
Returns
Type | Description
ToolkitResult |

FulfillCommitment(FulfillCommitmentSetup)

Declaration
public ToolkitResult FulfillCommitment(FulfillCommitmentSetup setupParam)
Parameters
Type | Name | Description
FulfillCommitmentSetup | setupParam |
Returns
Type | Description
ToolkitResult |

FulfillCommitment(FulfillCommitmentSetup, IDbTransaction)

Declaration
public ToolkitResult FulfillCommitment(FulfillCommitmentSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
FulfillCommitmentSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

FulfillCommitment(Int32)

Declaration
public ToolkitResult FulfillCommitment(int logObjid)
Parameters
Type | Name | Description
System.Int32 | logObjid |
Returns
Type | Description
ToolkitResult |

GetCaseTimeAndExpenses(GetCaseTimeAndExpensesSetup)

Declaration
public GetCaseTimeAndExpensesResult GetCaseTimeAndExpenses(GetCaseTimeAndExpensesSetup setupParam)
Parameters
Type | Name | Description
GetCaseTimeAndExpensesSetup | setupParam |
Returns
Type | Description
GetCaseTimeAndExpensesResult |

GetCaseTimeAndExpenses(GetCaseTimeAndExpensesSetup, IDbTransaction)

Declaration
public GetCaseTimeAndExpensesResult GetCaseTimeAndExpenses(GetCaseTimeAndExpensesSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
GetCaseTimeAndExpensesSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
GetCaseTimeAndExpensesResult |

GetCaseTimeAndExpenses(String)

Declaration
public GetCaseTimeAndExpensesResult GetCaseTimeAndExpenses(string caseIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |
Returns
Type | Description
GetCaseTimeAndExpensesResult |

GetSubcaseTimeAndExpenses(GetSubcaseTimeAndExpensesSetup)

Declaration
public GetSubcaseTimeAndExpensesResult GetSubcaseTimeAndExpenses(GetSubcaseTimeAndExpensesSetup setupParam)
Parameters
Type | Name | Description
GetSubcaseTimeAndExpensesSetup | setupParam |
Returns
Type | Description
GetSubcaseTimeAndExpensesResult |

GetSubcaseTimeAndExpenses(GetSubcaseTimeAndExpensesSetup, IDbTransaction)

Declaration
public GetSubcaseTimeAndExpensesResult GetSubcaseTimeAndExpenses(GetSubcaseTimeAndExpensesSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
GetSubcaseTimeAndExpensesSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
GetSubcaseTimeAndExpensesResult |

GetSubcaseTimeAndExpenses(String)

Declaration
public GetSubcaseTimeAndExpensesResult GetSubcaseTimeAndExpenses(string subcaseIDNum)
Parameters
Type | Name | Description
System.String | subcaseIDNum |
Returns
Type | Description
GetSubcaseTimeAndExpensesResult |

InitialResponse(InitialResponseSetup)

Declaration
public ToolkitResult InitialResponse(InitialResponseSetup setupParam)
Parameters
Type | Name | Description
InitialResponseSetup | setupParam |
Returns
Type | Description
ToolkitResult |

InitialResponse(InitialResponseSetup, IDbTransaction)

Declaration
public ToolkitResult InitialResponse(InitialResponseSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
InitialResponseSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

InitialResponse(String)

Declaration
public ToolkitResult InitialResponse(string caseIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |
Returns
Type | Description
ToolkitResult |

LogCaseCommitment(LogCaseCommitmentSetup)

Declaration
public ToolkitResult LogCaseCommitment(LogCaseCommitmentSetup setupParam)
Parameters
Type | Name | Description
LogCaseCommitmentSetup | setupParam |
Returns
Type | Description
ToolkitResult |

LogCaseCommitment(LogCaseCommitmentSetup, IDbTransaction)

Declaration
public ToolkitResult LogCaseCommitment(LogCaseCommitmentSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
LogCaseCommitmentSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

LogCaseCommitment(String, String, TimeSpan, String, String, String)

Declaration
public ToolkitResult LogCaseCommitment(string caseIDNum, string title, TimeSpan priorWarning, string contactFirstName, string contactLastName, string contactPhone)
Parameters
Type | Name | Description
System.String | caseIDNum |
System.String | title |
System.TimeSpan | priorWarning |
System.String | contactFirstName |
System.String | contactLastName |
System.String | contactPhone |
Returns
Type | Description
ToolkitResult |

LogCaseEmail(LogCaseEmailSetup)

Declaration
public LogCaseEmailResult LogCaseEmail(LogCaseEmailSetup setupParam)
Parameters
Type | Name | Description
LogCaseEmailSetup | setupParam |
Returns
Type | Description
LogCaseEmailResult |

LogCaseEmail(LogCaseEmailSetup, IDbTransaction)

Declaration
public LogCaseEmailResult LogCaseEmail(LogCaseEmailSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
LogCaseEmailSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
LogCaseEmailResult |

LogCaseEmail(String)

Declaration
public LogCaseEmailResult LogCaseEmail(string caseIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |
Returns
Type | Description
LogCaseEmailResult |

LogCaseEmailIn(LogCaseEmailInSetup)

Declaration
public ToolkitResult LogCaseEmailIn(LogCaseEmailInSetup setup)
Parameters
Type | Name | Description
LogCaseEmailInSetup | setup |
Returns
Type | Description
ToolkitResult |

LogCaseEmailIn(LogCaseEmailInSetup, IDbTransaction)

Declaration
public ToolkitResult LogCaseEmailIn(LogCaseEmailInSetup setup, IDbTransaction transaction)
Parameters
Type | Name | Description
LogCaseEmailInSetup | setup |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

LogCaseInternalNote(LogCaseInternalNoteSetup)

Declaration
public LogCaseNoteResult LogCaseInternalNote(LogCaseInternalNoteSetup setupParam)
Parameters
Type | Name | Description
LogCaseInternalNoteSetup | setupParam |
Returns
Type | Description
LogCaseNoteResult |

LogCaseInternalNote(LogCaseInternalNoteSetup, IDbTransaction)

Declaration
public LogCaseNoteResult LogCaseInternalNote(LogCaseInternalNoteSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
LogCaseInternalNoteSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
LogCaseNoteResult |

LogCaseInternalNote(String)

Declaration
public LogCaseNoteResult LogCaseInternalNote(string caseIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |
Returns
Type | Description
LogCaseNoteResult |

LogCaseInternalPhone(LogCaseInternalPhoneSetup)

Declaration
public LogCasePhoneResult LogCaseInternalPhone(LogCaseInternalPhoneSetup setupParam)
Parameters
Type | Name | Description
LogCaseInternalPhoneSetup | setupParam |
Returns
Type | Description
LogCasePhoneResult |

LogCaseInternalPhone(LogCaseInternalPhoneSetup, IDbTransaction)

Declaration
public LogCasePhoneResult LogCaseInternalPhone(LogCaseInternalPhoneSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
LogCaseInternalPhoneSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
LogCasePhoneResult |

LogCaseInternalPhone(String, String, String, String)

Declaration
public LogCasePhoneResult LogCaseInternalPhone(string caseIDNum, string contactFirstName, string contactLastName, string contactPhone)
Parameters
Type | Name | Description
System.String | caseIDNum |
System.String | contactFirstName |
System.String | contactLastName |
System.String | contactPhone |
Returns
Type | Description
LogCasePhoneResult |

LogCaseNote(LogCaseNoteSetup)

Declaration
public LogCaseNoteResult LogCaseNote(LogCaseNoteSetup setupParam)
Parameters
Type | Name | Description
LogCaseNoteSetup | setupParam |
Returns
Type | Description
LogCaseNoteResult |

LogCaseNote(LogCaseNoteSetup, IDbTransaction)

Declaration
public LogCaseNoteResult LogCaseNote(LogCaseNoteSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
LogCaseNoteSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
LogCaseNoteResult |

LogCaseNote(String)

Declaration
public LogCaseNoteResult LogCaseNote(string caseIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |
Returns
Type | Description
LogCaseNoteResult |

LogCasePhone(LogCasePhoneSetup)

Declaration
public LogCasePhoneResult LogCasePhone(LogCasePhoneSetup setupParam)
Parameters
Type | Name | Description
LogCasePhoneSetup | setupParam |
Returns
Type | Description
LogCasePhoneResult |

LogCasePhone(LogCasePhoneSetup, IDbTransaction)

Declaration
public LogCasePhoneResult LogCasePhone(LogCasePhoneSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
LogCasePhoneSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
LogCasePhoneResult |

LogCasePhone(String, String, String, String)

Declaration
public LogCasePhoneResult LogCasePhone(string caseIDNum, string contactFirstName, string contactLastName, string contactPhone)
Parameters
Type | Name | Description
System.String | caseIDNum |
System.String | contactFirstName |
System.String | contactLastName |
System.String | contactPhone |
Returns
Type | Description
LogCasePhoneResult |

LogCaseResearch(LogCaseResearchSetup)

Declaration
public LogCaseResearchResult LogCaseResearch(LogCaseResearchSetup setupParam)
Parameters
Type | Name | Description
LogCaseResearchSetup | setupParam |
Returns
Type | Description
LogCaseResearchResult |

LogCaseResearch(LogCaseResearchSetup, IDbTransaction)

Declaration
public LogCaseResearchResult LogCaseResearch(LogCaseResearchSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
LogCaseResearchSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
LogCaseResearchResult |

LogCaseResearch(String, TimeSpan)

Declaration
public LogCaseResearchResult LogCaseResearch(string caseIDNum, TimeSpan researchDuration)
Parameters
Type | Name | Description
System.String | caseIDNum |
System.TimeSpan | researchDuration |
Returns
Type | Description
LogCaseResearchResult |

LogSubcaseCommitment(LogSubcaseCommitmentSetup)

Declaration
public ToolkitResult LogSubcaseCommitment(LogSubcaseCommitmentSetup setupParam)
Parameters
Type | Name | Description
LogSubcaseCommitmentSetup | setupParam |
Returns
Type | Description
ToolkitResult |

LogSubcaseCommitment(LogSubcaseCommitmentSetup, IDbTransaction)

Declaration
public ToolkitResult LogSubcaseCommitment(LogSubcaseCommitmentSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
LogSubcaseCommitmentSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

LogSubcaseCommitment(String, String, TimeSpan, String, String, String)

Declaration
public ToolkitResult LogSubcaseCommitment(string subcaseIDNum, string title, TimeSpan priorWarning, string contactFirstName, string contactLastName, string contactPhone)
Parameters
Type | Name | Description
System.String | subcaseIDNum |
System.String | title |
System.TimeSpan | priorWarning |
System.String | contactFirstName |
System.String | contactLastName |
System.String | contactPhone |
Returns
Type | Description
ToolkitResult |

LogSubcaseEmail(LogSubcaseEmailSetup)

Declaration
public LogSubcaseEmailResult LogSubcaseEmail(LogSubcaseEmailSetup setupParam)
Parameters
Type | Name | Description
LogSubcaseEmailSetup | setupParam |
Returns
Type | Description
LogSubcaseEmailResult |

LogSubcaseEmail(LogSubcaseEmailSetup, IDbTransaction)

Declaration
public LogSubcaseEmailResult LogSubcaseEmail(LogSubcaseEmailSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
LogSubcaseEmailSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
LogSubcaseEmailResult |

LogSubcaseEmail(String)

Declaration
public LogSubcaseEmailResult LogSubcaseEmail(string subcaseIDNum)
Parameters
Type | Name | Description
System.String | subcaseIDNum |
Returns
Type | Description
LogSubcaseEmailResult |

LogSubCaseEmailIn(LogSubCaseEmailInSetup)

Declaration
public ToolkitResult LogSubCaseEmailIn(LogSubCaseEmailInSetup setup)
Parameters
Type | Name | Description
LogSubCaseEmailInSetup | setup |
Returns
Type | Description
ToolkitResult |

LogSubCaseEmailIn(LogSubCaseEmailInSetup, IDbTransaction)

Declaration
public ToolkitResult LogSubCaseEmailIn(LogSubCaseEmailInSetup setup, IDbTransaction transaction)
Parameters
Type | Name | Description
LogSubCaseEmailInSetup | setup |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

LogSubcaseInternalNote(LogSubcaseInternalNoteSetup)

Declaration
public LogSubcaseNoteResult LogSubcaseInternalNote(LogSubcaseInternalNoteSetup setupParam)
Parameters
Type | Name | Description
LogSubcaseInternalNoteSetup | setupParam |
Returns
Type | Description
LogSubcaseNoteResult |

LogSubcaseInternalNote(LogSubcaseInternalNoteSetup, IDbTransaction)

Declaration
public LogSubcaseNoteResult LogSubcaseInternalNote(LogSubcaseInternalNoteSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
LogSubcaseInternalNoteSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
LogSubcaseNoteResult |

LogSubcaseInternalNote(String)

Declaration
public LogSubcaseNoteResult LogSubcaseInternalNote(string subcaseIDNum)
Parameters
Type | Name | Description
System.String | subcaseIDNum |
Returns
Type | Description
LogSubcaseNoteResult |

LogSubcaseInternalPhone(LogSubcaseInternalPhoneSetup)

Declaration
public LogSubcasePhoneResult LogSubcaseInternalPhone(LogSubcaseInternalPhoneSetup setupParam)
Parameters
Type | Name | Description
LogSubcaseInternalPhoneSetup | setupParam |
Returns
Type | Description
LogSubcasePhoneResult |

LogSubcaseInternalPhone(LogSubcaseInternalPhoneSetup, IDbTransaction)

Declaration
public LogSubcasePhoneResult LogSubcaseInternalPhone(LogSubcaseInternalPhoneSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
LogSubcaseInternalPhoneSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
LogSubcasePhoneResult |

LogSubcaseInternalPhone(String, String, String, String)

Declaration
public LogSubcasePhoneResult LogSubcaseInternalPhone(string subcaseIDNum, string contactFirstName, string contactLastName, string contactPhone)
Parameters
Type | Name | Description
System.String | subcaseIDNum |
System.String | contactFirstName |
System.String | contactLastName |
System.String | contactPhone |
Returns
Type | Description
LogSubcasePhoneResult |

LogSubcaseNote(LogSubcaseNoteSetup)

Declaration
public LogSubcaseNoteResult LogSubcaseNote(LogSubcaseNoteSetup setupParam)
Parameters
Type | Name | Description
LogSubcaseNoteSetup | setupParam |
Returns
Type | Description
LogSubcaseNoteResult |

LogSubcaseNote(LogSubcaseNoteSetup, IDbTransaction)

Declaration
public LogSubcaseNoteResult LogSubcaseNote(LogSubcaseNoteSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
LogSubcaseNoteSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
LogSubcaseNoteResult |

LogSubcaseNote(String)

Declaration
public LogSubcaseNoteResult LogSubcaseNote(string subcaseIDNum)
Parameters
Type | Name | Description
System.String | subcaseIDNum |
Returns
Type | Description
LogSubcaseNoteResult |

LogSubcasePhone(LogSubcasePhoneSetup)

Declaration
public LogSubcasePhoneResult LogSubcasePhone(LogSubcasePhoneSetup setupParam)
Parameters
Type | Name | Description
LogSubcasePhoneSetup | setupParam |
Returns
Type | Description
LogSubcasePhoneResult |

LogSubcasePhone(LogSubcasePhoneSetup, IDbTransaction)

Declaration
public LogSubcasePhoneResult LogSubcasePhone(LogSubcasePhoneSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
LogSubcasePhoneSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
LogSubcasePhoneResult |

LogSubcasePhone(String, String, String, String)

Declaration
public LogSubcasePhoneResult LogSubcasePhone(string subcaseIDNum, string contactFirstName, string contactLastName, string contactPhone)
Parameters
Type | Name | Description
System.String | subcaseIDNum |
System.String | contactFirstName |
System.String | contactLastName |
System.String | contactPhone |
Returns
Type | Description
LogSubcasePhoneResult |

LogSubcaseResearch(LogSubcaseResearchSetup)

Declaration
public LogSubcaseResearchResult LogSubcaseResearch(LogSubcaseResearchSetup setupParam)
Parameters
Type | Name | Description
LogSubcaseResearchSetup | setupParam |
Returns
Type | Description
LogSubcaseResearchResult |

LogSubcaseResearch(LogSubcaseResearchSetup, IDbTransaction)

Declaration
public LogSubcaseResearchResult LogSubcaseResearch(LogSubcaseResearchSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
LogSubcaseResearchSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
LogSubcaseResearchResult |

LogSubcaseResearch(String, TimeSpan)

Declaration
public LogSubcaseResearchResult LogSubcaseResearch(string subcaseIDNum, TimeSpan researchDuration)
Parameters
Type | Name | Description
System.String | subcaseIDNum |
System.TimeSpan | researchDuration |
Returns
Type | Description
LogSubcaseResearchResult |

MoveCase(MoveCaseSetup)

Declaration
public ToolkitResult MoveCase(MoveCaseSetup setupParam)
Parameters
Type | Name | Description
MoveCaseSetup | setupParam |
Returns
Type | Description
ToolkitResult |

MoveCase(MoveCaseSetup, IDbTransaction)

Declaration
public ToolkitResult MoveCase(MoveCaseSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
MoveCaseSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

MoveCase(String, String)

Declaration
public ToolkitResult MoveCase(string caseIDNum, string newWipBin)
Parameters
Type | Name | Description
System.String | caseIDNum |
System.String | newWipBin |
Returns
Type | Description
ToolkitResult |

MoveSubcase(MoveSubcaseSetup)

Declaration
public ToolkitResult MoveSubcase(MoveSubcaseSetup setupParam)
Parameters
Type | Name | Description
MoveSubcaseSetup | setupParam |
Returns
Type | Description
ToolkitResult |

MoveSubcase(MoveSubcaseSetup, IDbTransaction)

Declaration
public ToolkitResult MoveSubcase(MoveSubcaseSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
MoveSubcaseSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

MoveSubcase(String, String)

Declaration
public ToolkitResult MoveSubcase(string subcaseIDNum, string newWipBin)
Parameters
Type | Name | Description
System.String | subcaseIDNum |
System.String | newWipBin |
Returns
Type | Description
ToolkitResult |

RejectCase(RejectCaseSetup)

Declaration
public ToolkitResult RejectCase(RejectCaseSetup setupParam)
Parameters
Type | Name | Description
RejectCaseSetup | setupParam |
Returns
Type | Description
ToolkitResult |

RejectCase(RejectCaseSetup, IDbTransaction)

Declaration
public ToolkitResult RejectCase(RejectCaseSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
RejectCaseSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

RejectCase(String)

Declaration
public ToolkitResult RejectCase(string caseIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |
Returns
Type | Description
ToolkitResult |

RejectSubcase(RejectSubcaseSetup)

Declaration
public ToolkitResult RejectSubcase(RejectSubcaseSetup setupParam)
Parameters
Type | Name | Description
RejectSubcaseSetup | setupParam |
Returns
Type | Description
ToolkitResult |

RejectSubcase(RejectSubcaseSetup, IDbTransaction)

Declaration
public ToolkitResult RejectSubcase(RejectSubcaseSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
RejectSubcaseSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

RejectSubcase(String)

Declaration
public ToolkitResult RejectSubcase(string subcaseIDNum)
Parameters
Type | Name | Description
System.String | subcaseIDNum |
Returns
Type | Description
ToolkitResult |

RelateCaseToParentCase(RelateCaseToParentCaseSetup)

Declaration
public ToolkitResult RelateCaseToParentCase(RelateCaseToParentCaseSetup setupParam)
Parameters
Type | Name | Description
RelateCaseToParentCaseSetup | setupParam |
Returns
Type | Description
ToolkitResult |

RelateCaseToParentCase(RelateCaseToParentCaseSetup, IDbTransaction)

Declaration
public ToolkitResult RelateCaseToParentCase(RelateCaseToParentCaseSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
RelateCaseToParentCaseSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

RelateCaseToParentCase(String, String)

Declaration
public ToolkitResult RelateCaseToParentCase(string caseIDNum, string parentCaseIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |
System.String | parentCaseIDNum |
Returns
Type | Description
ToolkitResult |

ReopenCase(ReopenCaseSetup)

Declaration
public ToolkitResult ReopenCase(ReopenCaseSetup setupParam)
Parameters
Type | Name | Description
ReopenCaseSetup | setupParam |
Returns
Type | Description
ToolkitResult |

ReopenCase(ReopenCaseSetup, IDbTransaction)

Declaration
public ToolkitResult ReopenCase(ReopenCaseSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
ReopenCaseSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

ReopenCase(String)

Declaration
public ToolkitResult ReopenCase(string caseIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |
Returns
Type | Description
ToolkitResult |

ReopenSubcase(ReopenSubcaseSetup)

Declaration
public ToolkitResult ReopenSubcase(ReopenSubcaseSetup setupParam)
Parameters
Type | Name | Description
ReopenSubcaseSetup | setupParam |
Returns
Type | Description
ToolkitResult |

ReopenSubcase(ReopenSubcaseSetup, IDbTransaction)

Declaration
public ToolkitResult ReopenSubcase(ReopenSubcaseSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
ReopenSubcaseSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

ReopenSubcase(String)

Declaration
public ToolkitResult ReopenSubcase(string subcaseIDNum)
Parameters
Type | Name | Description
System.String | subcaseIDNum |
Returns
Type | Description
ToolkitResult |

UnrelateCaseFromParentCase(UnrelateCaseFromParentCaseSetup)

Declaration
public ToolkitResult UnrelateCaseFromParentCase(UnrelateCaseFromParentCaseSetup setupParam)
Parameters
Type | Name | Description
UnrelateCaseFromParentCaseSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UnrelateCaseFromParentCase(UnrelateCaseFromParentCaseSetup, IDbTransaction)

Declaration
public ToolkitResult UnrelateCaseFromParentCase(UnrelateCaseFromParentCaseSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UnrelateCaseFromParentCaseSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UnrelateCaseFromParentCase(String)

Declaration
public ToolkitResult UnrelateCaseFromParentCase(string caseIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |
Returns
Type | Description
ToolkitResult |

UpdateCase(UpdateCaseSetup)

Declaration
public ToolkitResult UpdateCase(UpdateCaseSetup setupParam)
Parameters
Type | Name | Description
UpdateCaseSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdateCase(UpdateCaseSetup, IDbTransaction)

Declaration
public ToolkitResult UpdateCase(UpdateCaseSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdateCaseSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UpdateCaseCommitment(UpdateCaseCommitmentSetup)

Declaration
public ToolkitResult UpdateCaseCommitment(UpdateCaseCommitmentSetup setupParam)
Parameters
Type | Name | Description
UpdateCaseCommitmentSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdateCaseCommitment(UpdateCaseCommitmentSetup, IDbTransaction)

Declaration
public ToolkitResult UpdateCaseCommitment(UpdateCaseCommitmentSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdateCaseCommitmentSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UpdateCaseCommitment(String, DateTime, Int32)

Declaration
public ToolkitResult UpdateCaseCommitment(string caseIDNum, DateTime commitmentDate, int commitmentObjid)
Parameters
Type | Name | Description
System.String | caseIDNum |
System.DateTime | commitmentDate |
System.Int32 | commitmentObjid |
Returns
Type | Description
ToolkitResult |

UpdateSubcase(UpdateSubcaseSetup)

Declaration
public ToolkitResult UpdateSubcase(UpdateSubcaseSetup setupParam)
Parameters
Type | Name | Description
UpdateSubcaseSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdateSubcase(UpdateSubcaseSetup, IDbTransaction)

Declaration
public ToolkitResult UpdateSubcase(UpdateSubcaseSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdateSubcaseSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UpdateSubcaseCommitment(UpdateSubcaseCommitmentSetup)

Declaration
public ToolkitResult UpdateSubcaseCommitment(UpdateSubcaseCommitmentSetup setupParam)
Parameters
Type | Name | Description
UpdateSubcaseCommitmentSetup | setupParam |
Returns
Type | Description
ToolkitResult |

UpdateSubcaseCommitment(UpdateSubcaseCommitmentSetup, IDbTransaction)

Declaration
public ToolkitResult UpdateSubcaseCommitment(UpdateSubcaseCommitmentSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
UpdateSubcaseCommitmentSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

UpdateSubcaseCommitment(String, DateTime, Int32)

Declaration
public ToolkitResult UpdateSubcaseCommitment(string subcaseIDNum, DateTime commitmentDate, int commitmentObjid)
Parameters
Type | Name | Description
System.String | subcaseIDNum |
System.DateTime | commitmentDate |
System.Int32 | commitmentObjid |
Returns
Type | Description
ToolkitResult |

YankCase(YankCaseSetup)

Declaration
public ToolkitResult YankCase(YankCaseSetup setupParam)
Parameters
Type | Name | Description
YankCaseSetup | setupParam |
Returns
Type | Description
ToolkitResult |

YankCase(YankCaseSetup, IDbTransaction)

Declaration
public ToolkitResult YankCase(YankCaseSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
YankCaseSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

YankCase(String)

Declaration
public ToolkitResult YankCase(string caseIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |
Returns
Type | Description
ToolkitResult |

YankSubcase(YankSubcaseSetup)

Declaration
public ToolkitResult YankSubcase(YankSubcaseSetup setupParam)
Parameters
Type | Name | Description
YankSubcaseSetup | setupParam |
Returns
Type | Description
ToolkitResult |

YankSubcase(YankSubcaseSetup, IDbTransaction)

Declaration
public ToolkitResult YankSubcase(YankSubcaseSetup setupParam, IDbTransaction transaction)
Parameters
Type | Name | Description
YankSubcaseSetup | setupParam |
System.Data.IDbTransaction | transaction |
Returns
Type | Description
ToolkitResult |

YankSubcase(String)

Declaration
public ToolkitResult YankSubcase(string subcaseIDNum)
Parameters
Type | Name | Description
System.String | subcaseIDNum |
Returns
Type | Description
ToolkitResult |


Class SupportToolkitBase | fcSDK Documentation

Class SupportToolkitBase

Inheritance
System.Object
ToolkitBase
SupportToolkitBase
SupportToolkit
Inherited Members
ToolkitBase.NOW_DATE
ToolkitBase.CompatSession
ToolkitBase.WithTransaction<T>(Func<IDbTransaction, T>)
ToolkitBase.FCApplication
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public abstract class SupportToolkitBase : ToolkitBase

Constructors

SupportToolkitBase(ClarifySession)

Declaration
public SupportToolkitBase(ClarifySession sess)
Parameters
Type | Name | Description
ClarifySession | sess |

SupportToolkitBase(IFCApplication, IFCSession)

Declaration
public SupportToolkitBase(IFCApplication app, IFCSession sess)
Parameters
Type | Name | Description
IFCApplication | app |
IFCSession | sess |

Fields

_toolkit

Declaration
protected FCCS _toolkit
Field Value
Type | Description
FCCS |

Properties

ImpersonatorUsername

Declaration
public string ImpersonatorUsername { get; set; }
Property Value
Type | Description
System.String |

UseDenormalizedCaseTypeLevels

Declaration
public bool UseDenormalizedCaseTypeLevels { get; set; }
Property Value
Type | Description
System.Boolean |


Class UnrelateCaseFromParentCaseSetup | fcSDK Documentation

Class UnrelateCaseFromParentCaseSetup

Inheritance
System.Object
UnrelateCaseFromParentCaseSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UnrelateCaseFromParentCaseSetup

Constructors

UnrelateCaseFromParentCaseSetup(String)

Declaration
[ConstructorIndex(0)]
public UnrelateCaseFromParentCaseSetup(string caseIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |

Properties

CaseIDNum

Declaration
[PropertyBitValue(1)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |


Class UpdateCaseCommitmentSetup | fcSDK Documentation

Class UpdateCaseCommitmentSetup

Inheritance
System.Object
UpdateCaseCommitmentSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdateCaseCommitmentSetup

Constructors

UpdateCaseCommitmentSetup(String, DateTime, Int32)

Declaration
[ConstructorIndex(0)]
public UpdateCaseCommitmentSetup(string caseIDNum, DateTime commitmentDate, int commitmentObjid)
Parameters
Type | Name | Description
System.String | caseIDNum |
System.DateTime | commitmentDate |
System.Int32 | commitmentObjid |

Properties

ActionType

Declaration
[PropertyBitValue(4)]
public string ActionType { get; set; }
Property Value
Type | Description
System.String |

AdditionalFields

Declaration
[PropertyBitValue(16384)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

CaseIDNum

Declaration
[PropertyBitValue(1)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

CommitmentDate

Declaration
[PropertyBitValue(8)]
public DateTime CommitmentDate { get; set; }
Property Value
Type | Description
System.DateTime |

CommitmentObjid

Declaration
[PropertyBitValue(16)]
public int CommitmentObjid { get; set; }
Property Value
Type | Description
System.Int32 |

ContactFirstName

Declaration
[PropertyBitValue(128)]
public string ContactFirstName { get; set; }
Property Value
Type | Description
System.String |

ContactLastName

Declaration
[PropertyBitValue(256)]
public string ContactLastName { get; set; }
Property Value
Type | Description
System.String |

ContactPhone

Declaration
[PropertyBitValue(512)]
public string ContactPhone { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(8192)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

IsMadeToCustomer

Declaration
[PropertyBitValue(64)]
public bool IsMadeToCustomer { get; set; }
Property Value
Type | Description
System.Boolean |

Notes

Declaration
[PropertyBitValue(1024)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

PriorWarning

Declaration
[PropertyBitValue(32)]
public TimeSpan PriorWarning { get; set; }
Property Value
Type | Description
System.TimeSpan |

Title

Declaration
[PropertyBitValue(2)]
public string Title { get; set; }
Property Value
Type | Description
System.String |

UpdateDate

Declaration
[PropertyBitValue(2048)]
public DateTime UpdateDate { get; set; }
Property Value
Type | Description
System.DateTime |

UserName

Declaration
[PropertyBitValue(4096)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class UpdateCaseSetup | fcSDK Documentation

Class UpdateCaseSetup

Inheritance
System.Object
UpdateCaseSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdateCaseSetup

Constructors

UpdateCaseSetup(String)

Declaration
[ConstructorIndex(0)]
public UpdateCaseSetup(string caseIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |

Properties

AdditionalFields

Declaration
[PropertyBitValue(32768)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

CaseIDNum

Declaration
[PropertyBitValue(1)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

CaseType

Declaration
[PropertyBitValue(8)]
public string CaseType { get; set; }
Property Value
Type | Description
System.String |

ClearContractRelation

Declaration
[PropertyBitValue(8192)]
public bool ClearContractRelation { get; set; }
Property Value
Type | Description
System.Boolean |

ClearPartRevisionRelation

Declaration
[PropertyBitValue(16384)]
public bool ClearPartRevisionRelation { get; set; }
Property Value
Type | Description
System.Boolean |

ClearSitePartRelation

Declaration
[PropertyBitValue(4096)]
public bool ClearSitePartRelation { get; set; }
Property Value
Type | Description
System.Boolean |

ContractObjid

Declaration
[PropertyBitValue(2048)]
public int ContractObjid { get; set; }
Property Value
Type | Description
System.Int32 |

GenerateTimeBombs

Declaration
[PropertyBitValue(128)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

OnlyOpen

Declaration
[PropertyBitValue(65536)]
public bool OnlyOpen { get; set; }
Property Value
Type | Description
System.Boolean |

OnlyOwner

Declaration
[PropertyBitValue(64)]
public bool OnlyOwner { get; set; }
Property Value
Type | Description
System.Boolean |

PartRevisionObjid

Declaration
[PropertyBitValue(512)]
public int PartRevisionObjid { get; set; }
Property Value
Type | Description
System.Int32 |

Priority

Declaration
[PropertyBitValue(2)]
public string Priority { get; set; }
Property Value
Type | Description
System.String |

Severity

Declaration
[PropertyBitValue(4)]
public string Severity { get; set; }
Property Value
Type | Description
System.String |

SitePartObjid

Declaration
[PropertyBitValue(1024)]
public int SitePartObjid { get; set; }
Property Value
Type | Description
System.Int32 |

Title

Declaration
[PropertyBitValue(256)]
public string Title { get; set; }
Property Value
Type | Description
System.String |

UpdateDate

Declaration
[PropertyBitValue(32)]
public DateTime UpdateDate { get; set; }
Property Value
Type | Description
System.DateTime |

UserName

Declaration
[PropertyBitValue(16)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class UpdateSubcaseCommitmentSetup | fcSDK Documentation

Class UpdateSubcaseCommitmentSetup

Inheritance
System.Object
UpdateSubcaseCommitmentSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdateSubcaseCommitmentSetup

Constructors

UpdateSubcaseCommitmentSetup(String, DateTime, Int32)

Declaration
[ConstructorIndex(0)]
public UpdateSubcaseCommitmentSetup(string subcaseIDNum, DateTime commitmentDate, int commitmentObjid)
Parameters
Type | Name | Description
System.String | subcaseIDNum |
System.DateTime | commitmentDate |
System.Int32 | commitmentObjid |

Properties

ActionType

Declaration
[PropertyBitValue(4)]
public string ActionType { get; set; }
Property Value
Type | Description
System.String |

AdditionalFields

Declaration
[PropertyBitValue(16384)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

CommitmentDate

Declaration
[PropertyBitValue(8)]
public DateTime CommitmentDate { get; set; }
Property Value
Type | Description
System.DateTime |

CommitmentObjid

Declaration
[PropertyBitValue(16)]
public int CommitmentObjid { get; set; }
Property Value
Type | Description
System.Int32 |

ContactFirstName

Declaration
[PropertyBitValue(128)]
public string ContactFirstName { get; set; }
Property Value
Type | Description
System.String |

ContactLastName

Declaration
[PropertyBitValue(256)]
public string ContactLastName { get; set; }
Property Value
Type | Description
System.String |

ContactPhone

Declaration
[PropertyBitValue(512)]
public string ContactPhone { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(8192)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

IsMadeToCustomer

Declaration
[PropertyBitValue(64)]
public bool IsMadeToCustomer { get; set; }
Property Value
Type | Description
System.Boolean |

Notes

Declaration
[PropertyBitValue(1024)]
public string Notes { get; set; }
Property Value
Type | Description
System.String |

PriorWarning

Declaration
[PropertyBitValue(32)]
public TimeSpan PriorWarning { get; set; }
Property Value
Type | Description
System.TimeSpan |

SubcaseIDNum

Declaration
[PropertyBitValue(1)]
public string SubcaseIDNum { get; set; }
Property Value
Type | Description
System.String |

Title

Declaration
[PropertyBitValue(2)]
public string Title { get; set; }
Property Value
Type | Description
System.String |

UpdateDate

Declaration
[PropertyBitValue(2048)]
public DateTime UpdateDate { get; set; }
Property Value
Type | Description
System.DateTime |

UserName

Declaration
[PropertyBitValue(4096)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class UpdateSubcaseSetup | fcSDK Documentation

Class UpdateSubcaseSetup

Inheritance
System.Object
UpdateSubcaseSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class UpdateSubcaseSetup

Constructors

UpdateSubcaseSetup(String)

Declaration
[ConstructorIndex(0)]
public UpdateSubcaseSetup(string subcaseIDNum)
Parameters
Type | Name | Description
System.String | subcaseIDNum |

Properties

AdditionalFields

Declaration
[PropertyBitValue(128)]
public AdditionalFields AdditionalFields { get; }
Property Value
Type | Description
AdditionalFields |

GenerateTimeBombs

Declaration
[PropertyBitValue(64)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

OnlyOpen

Declaration
[PropertyBitValue(256)]
public bool OnlyOpen { get; set; }
Property Value
Type | Description
System.Boolean |

OnlyOwner

Declaration
[PropertyBitValue(32)]
public bool OnlyOwner { get; set; }
Property Value
Type | Description
System.Boolean |

Priority

Declaration
[PropertyBitValue(2)]
public string Priority { get; set; }
Property Value
Type | Description
System.String |

Severity

Declaration
[PropertyBitValue(4)]
public string Severity { get; set; }
Property Value
Type | Description
System.String |

SubcaseIDNum

Declaration
[PropertyBitValue(1)]
public string SubcaseIDNum { get; set; }
Property Value
Type | Description
System.String |

UpdateDate

Declaration
[PropertyBitValue(16)]
public DateTime UpdateDate { get; set; }
Property Value
Type | Description
System.DateTime |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |


Class YankCaseSetup | fcSDK Documentation

Class YankCaseSetup

Inheritance
System.Object
YankCaseSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class YankCaseSetup

Constructors

YankCaseSetup(String)

Declaration
[ConstructorIndex(0)]
public YankCaseSetup(string caseIDNum)
Parameters
Type | Name | Description
System.String | caseIDNum |

Properties

CaseIDNum

Declaration
[PropertyBitValue(1)]
public string CaseIDNum { get; set; }
Property Value
Type | Description
System.String |

GenerateTimeBombs

Declaration
[PropertyBitValue(16)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(2)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |

YankDate

Declaration
[PropertyBitValue(4)]
public DateTime YankDate { get; set; }
Property Value
Type | Description
System.DateTime |


Class YankSubcaseSetup | fcSDK Documentation

Class YankSubcaseSetup

Inheritance
System.Object
YankSubcaseSetup
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify.Support
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class YankSubcaseSetup

Constructors

YankSubcaseSetup(String)

Declaration
[ConstructorIndex(0)]
public YankSubcaseSetup(string subcaseIDNum)
Parameters
Type | Name | Description
System.String | subcaseIDNum |

Properties

GenerateTimeBombs

Declaration
[PropertyBitValue(16)]
public bool GenerateTimeBombs { get; set; }
Property Value
Type | Description
System.Boolean |

SubcaseIDNum

Declaration
[PropertyBitValue(1)]
public string SubcaseIDNum { get; set; }
Property Value
Type | Description
System.String |

UserName

Declaration
[PropertyBitValue(8)]
public string UserName { get; set; }
Property Value
Type | Description
System.String |

WipBin

Declaration
[PropertyBitValue(2)]
public string WipBin { get; set; }
Property Value
Type | Description
System.String |

YankDate

Declaration
[PropertyBitValue(4)]
public DateTime YankDate { get; set; }
Property Value
Type | Description
System.DateTime |


Class ToolkitBase | fcSDK Documentation

Class ToolkitBase

Inheritance
System.Object
ToolkitBase
ContractsToolkitBase
DepotRepairToolkitBase
FieldOpsToolkitBase
InterfacesToolkitBase
LogisticsToolkitBase
QualityToolkitBase
SalesToolkitBase
SupportToolkitBase
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public abstract class ToolkitBase

Constructors

ToolkitBase(ClarifySession)

Declaration
public ToolkitBase(ClarifySession clarifySession)
Parameters
Type | Name | Description
ClarifySession | clarifySession |

ToolkitBase(IFCApplication, IFCSession)

Declaration
public ToolkitBase(IFCApplication application, IFCSession session)
Parameters
Type | Name | Description
IFCApplication | application |
IFCSession | session |

Fields

CompatSession

Declaration
protected FCSession CompatSession
Field Value
Type | Description
FCSession |

NOW_DATE

Declaration
public static readonly DateTime NOW_DATE
Field Value
Type | Description
System.DateTime |

Properties

FCApplication

Declaration
protected static FCApplication FCApplication { get; }
Property Value
Type | Description
FCApplication |

Methods

WithTransaction<T>(Func<IDbTransaction, T>)

Declaration
protected T WithTransaction<T>(Func<IDbTransaction, T> action)
Parameters
Type | Name | Description
System.Func<System.Data.IDbTransaction, T> | action |
Returns
Type | Description
T |
Type Parameters
Name | Description
T |


Class ToolkitResult | fcSDK Documentation

Class ToolkitResult

Inheritance
System.Object
ToolkitResult
AddServiceInterruptionResult
CreateAppointmentResult
CreateExpenseLogResult
CreateTimeLogResult
PartTransferResult
CreateEmployeeResult
CreateSolutionResult
CreatePartRequestDetailResult
GetAlternatePartsResult
GetLocationsServicingSiteResult
PartTransferResult
PickResult
GetCaseTimeAndExpensesResult
GetSubcaseTimeAndExpensesResult
LogCaseEmailResult
LogCaseNoteResult
LogCasePhoneResult
LogCaseResearchResult
LogSubcaseEmailResult
LogSubcaseNoteResult
LogSubcasePhoneResult
LogSubcaseResearchResult
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class ToolkitResult

Constructors

ToolkitResult()

Declaration
public ToolkitResult()

ToolkitResult(Int16, IToolkit)

Declaration
public ToolkitResult(short retCode, IToolkit toolkit)
Parameters
Type | Name | Description
System.Int16 | retCode |
IToolkit | toolkit |

ToolkitResult(String, Int32)

Declaration
public ToolkitResult(string IDNum, int objid)
Parameters
Type | Name | Description
System.String | IDNum |
System.Int32 | objid |

Fields

_IDNum

Declaration
protected string _IDNum
Field Value
Type | Description
System.String |

_Objid

Declaration
protected int _Objid
Field Value
Type | Description
System.Int32 |

_ReturnCode

Declaration
protected short _ReturnCode
Field Value
Type | Description
System.Int16 |

Properties

IDNum

Declaration
public string IDNum { get; set; }
Property Value
Type | Description
System.String |

Objid

Declaration
public int Objid { get; set; }
Property Value
Type | Description
System.Int32 |

ReturnCode

Declaration
public short ReturnCode { get; set; }
Property Value
Type | Description
System.Int16 |


Class ToolkitResultPropertyAttribute | fcSDK Documentation

Class ToolkitResultPropertyAttribute

Inheritance
System.Object
System.Attribute
ToolkitResultPropertyAttribute
Implements
System.Runtime.InteropServices._Attribute
Inherited Members
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo)
System.Attribute.GetCustomAttributes(System.Reflection.MemberInfo, System.Boolean)
System.Attribute.IsDefined(System.Reflection.MemberInfo, System.Type)
System.Attribute.IsDefined(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.MemberInfo, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.MemberInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.ParameterInfo, System.Boolean)
System.Attribute.IsDefined(System.Reflection.ParameterInfo, System.Type)
System.Attribute.IsDefined(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.ParameterInfo, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.ParameterInfo, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.Module)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.IsDefined(System.Reflection.Module, System.Type)
System.Attribute.IsDefined(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.Module, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.Module, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Type)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly)
System.Attribute.GetCustomAttributes(System.Reflection.Assembly, System.Boolean)
System.Attribute.IsDefined(System.Reflection.Assembly, System.Type)
System.Attribute.IsDefined(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.GetCustomAttribute(System.Reflection.Assembly, System.Type)
System.Attribute.GetCustomAttribute(System.Reflection.Assembly, System.Type, System.Boolean)
System.Attribute.Equals(System.Object)
System.Attribute.GetHashCode()
System.Attribute.Match(System.Object)
System.Attribute.IsDefaultAttribute()
System.Attribute.System.Runtime.InteropServices._Attribute.GetTypeInfoCount(System.UInt32)
System.Attribute.System.Runtime.InteropServices._Attribute.GetTypeInfo(System.UInt32, System.UInt32, System.IntPtr)
System.Attribute.System.Runtime.InteropServices._Attribute.GetIDsOfNames(System.Guid, System.IntPtr, System.UInt32, System.UInt32, System.IntPtr)
System.Attribute.System.Runtime.InteropServices._Attribute.Invoke(System.UInt32, System.Guid, System.UInt32, System.Int16, System.IntPtr, System.IntPtr, System.IntPtr, System.IntPtr)
System.Attribute.TypeId
System.Object.ToString()
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
[AttributeUsage(AttributeTargets.Method, AllowMultiple = true)]
public class ToolkitResultPropertyAttribute : Attribute, _Attribute

Constructors

ToolkitResultPropertyAttribute(String, String)

Declaration
public ToolkitResultPropertyAttribute(string propertyName, string docSummary)
Parameters
Type | Name | Description
System.String | propertyName |
System.String | docSummary |

Properties

DocSummary

Declaration
public string DocSummary { get; }
Property Value
Type | Description
System.String |

PropertyName

Declaration
public string PropertyName { get; }
Property Value
Type | Description
System.String |

Implements

System.Runtime.InteropServices._Attribute


Class Utility | fcSDK Documentation

Class Utility

Inheritance
System.Object
Utility
Inherited Members
System.Object.ToString()
System.Object.Equals(System.Object)
System.Object.Equals(System.Object, System.Object)
System.Object.ReferenceEquals(System.Object, System.Object)
System.Object.GetHashCode()
System.Object.GetType()
System.Object.MemberwiseClone()
Namespace: FChoice.Toolkits.Clarify
Assembly: FChoice.Toolkits.Clarify.dll
Syntax
public class Utility

Methods

AddExpenseGL(LogisticsToolkit, FCSession, String, String)

Declaration
public static void AddExpenseGL(LogisticsToolkit logisticsToolkit, FCSession session, string accountName, string siteIDNum)
Parameters
Type | Name | Description
LogisticsToolkit | logisticsToolkit |
FCSession | session |
System.String | accountName |
System.String | siteIDNum |


.Net API Reference | fcSDK Documentation

.Net API Reference

Back to top © 2022 Dovetail Software, Inc. - All rights reserved.
Clarify, Amdocs, and related products and names are copyright and trademark of Amdocs, Inc.
.NET, Visual Studio.NET, C#, Visual Basic and related products are trademark of Microsoft corporation.


Articles | fcSDK Documentation

Articles

Back to top © 2022 Dovetail Software, Inc. - All rights reserved.
Clarify, Amdocs, and related products and names are copyright and trademark of Amdocs, Inc.
.NET, Visual Studio.NET, C#, Visual Basic and related products are trademark of Microsoft corporation.


FCFL/FCFL.NET Type Library Changes | fcSDK Documentation

FCFL/FCFL.NET Type Library Changes

TypeLib ID

(appears in Add Reference dialog in VB6)

FCFL | FCFL.Net compatibility
First Choice Foundation Library | First Choice Foundation For Clarify Compatibility Library

TypeLib ID

FCFL | FCFL.Net compatibility
5D9470B1-D520-41BC-BDA7-E57A25D37085 | D0F70B26-F359-44AC-B0AE-20AAD0847D13


FChoice.Common Assembly | fcSDK Documentation

FChoice.Common Assembly

The FChoice.Common assembly contains classes that provide basic services such as configuration, logging, error management, and data access to First Choice .NET-based products.

Namespaces

Namespace | Description
FChoice.Common | The FChoice.Common namespace provides configuration, logging, and error management services to First Choice .NET-based products.
FChoice.Common.Data | The FChoice.Common.Data namespace provides data access services to First Choice .NET-based products.
FChoice.Common.Licensing | First Choice Software Licensing
FChoice.Common.State |

Remarks

The FChoice.Common.Data namespace is largely intended to be used by First Choice .NET products only. While public for your convenience, usage of any of these classes directly (except for Configuration or Logging) is discouraged.


CommonException Class Methods | fcSDK Documentation

CommonException Class Methods

For a list of all members of this type, see CommonException members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Assert | Assert it used internally by First Choice products to ensure that internal state and data is consistent with expected norms.
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | Sets the SerializationInfo object with the parameter name and additional exception information. (Inherited from FChoice.Common.FCExceptionBase)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)

Reference

CommonException Class
FChoice.Common Namespace


CommonException Class Properties | fcSDK Documentation

CommonException Class Properties

For a list of all members of this type, see CommonException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorCode | Gets the unique error code for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | ErrorMessageID | Gets the message identifier for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)

Reference

CommonException Class
FChoice.Common Namespace


ConfigValues Class Fields | fcSDK Documentation

ConfigValues Class Fields

For a list of all members of this type, see ConfigValues members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | CACHE_FILE_PATH |
static (Shared in Visual Basic) | CONNECT_STRING | The key to the FCConfiguration collection which contains the configured database connection string.
static (Shared in Visual Basic) | DB_TYPE | The key to the FCConfiguration collection which contains the configured database provider type.
static (Shared in Visual Basic) | DBPROVIDER_CONFIGFILE |
static (Shared in Visual Basic) | ENABLE_BATCH | The key to the FCConfiguration collection which contains the configured switch for enabling or disabling database query batching.
static (Shared in Visual Basic) | LOG_CONFIG_FILE_PATH |
static (Shared in Visual Basic) | NO_CACHE_FILE | The key to the FCConfiguration collection which contains the configured switch which controls whether First Choice applications will cache application data.
static (Shared in Visual Basic) | PERF_ENABLED |
static (Shared in Visual Basic) | PERF_INSTANCE_NAME |
static (Shared in Visual Basic) | SQL_BIG_QUERY_COUNT_THRESHOLD |
static (Shared in Visual Basic) | SQL_BIG_QUERY_TIME_THRESHOLD |
static (Shared in Visual Basic) | SQL_COMMAND_TIMEOUT |
static (Shared in Visual Basic) | STATEMANAGER_CONFIGFILE |

Reference

ConfigValues Class
FChoice.Common Namespace


ConfigValues Class Methods | fcSDK Documentation

ConfigValues Class Methods

For a list of all members of this type, see ConfigValues members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetConditionalString | Overloaded.
static (Shared in Visual Basic) | GetOptBool | Overloaded.
static (Shared in Visual Basic) | GetOptInt32 | Overloaded.
static (Shared in Visual Basic) | GetOptString | Overloaded.
static (Shared in Visual Basic) | GetReqString | Overloaded.
static (Shared in Visual Basic) | VerifyPositive |

Reference

ConfigValues Class
FChoice.Common Namespace


DataAccessSectionHandler Class Methods | fcSDK Documentation

DataAccessSectionHandler Class Methods

For a list of all members of this type, see DataAccessSectionHandler members.

Public Methods

 | Name | Description
Public Method | Create | Creates a new configuration handler and adds it to the section handler collection.

Reference

DataAccessSectionHandler Class
FChoice.Common.Data Namespace
DbProvider Class
DbProviderFactory Class


DataParameterCollection Class Methods | fcSDK Documentation

DataParameterCollection Class Methods

For a list of all members of this type, see DataParameterCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Adds a parameter to this collection for use as a bind variable in the SQL statement.
Public Method | Clear | Removes all parameters from this collection.
Public Method | Clone | Creates a new collection using the same parameters.
Public Method | Contains | Determines whether or not this collection contains the specified parameter.
Public Method | CopyTo | Overloaded. Copies the parameters in this collection to the specified collection.
Public Method | DeepClone | Performs a deep clone of the entire collection and clones (not just a reference copy) each individual parameter
Public Method | GetEnumerator | Returns an enumerator for the entire collection
Public Method | IndexOf | Returns the index at which this object exists in the collection.
Public Method | Insert | Inserts the parameter at the specified index in the collection.
Public Method | Remove | Overloaded. Removes a parameter with the specified name from the collection.
Public Method | RemoveAt | Removes the parameter at the specified index from the collection.

Reference

DataParameterCollection Class FChoice.Common.Data Namespace


DataParameterCollection Class Properties | fcSDK Documentation

DataParameterCollection Class Properties

For a list of all members of this type, see DataParameterCollection members.

Public Properties

 | Name | Description
Public Property | Count | Retrieves the number of parameters actually contained in the DataParameterCollection.
Public Property | IsFixedSize | Retrieves a value indicating whether or not this collection has a fixed size.
Public Property | IsReadOnly | Retrieves a value indicating whether this collection is read-only.
Public Property | IsSynchronized | Retrieves a value indicating whether access to the DataParameterCollection is synchronized (thread-safe).
Public Property | Item | Overloaded. Gets or sets the IDbDataParameter associated with the specific name in the collection.
Public Property | Parameters | Retrieves a collection of the IDbDataParameter objects in this collection.
Public Property | SyncRoot | Gets an object that can be used to synchronize access to this instance of the DataParameterCollection.

Reference

DataParameterCollection Class
FChoice.Common.Data Namespace


DataSetSurrogate Class Methods | fcSDK Documentation

DataSetSurrogate Class Methods

For a list of all members of this type, see DataSetSurrogate members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ReadBinary | Reads a DataSet from a binary stream
static (Shared in Visual Basic) | WriteBinary | Writes a DataSet to a binary stream

Reference

DataSetSurrogate Class
FChoice.Common.Data Namespace


DbProvider Class Methods | fcSDK Documentation

DbProvider Class Methods

For a list of all members of this type, see DbProvider members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ConstructConnectionString | Constructs a valid ADO.NET-compliant connection string from the supplied key/value pairs.
Public Method | CreateCommand |
Public Method | CreateConnectionString | Creates a basic connection string from the basic common required elements according the rules of the specific database type
Public Method | CreateParameter | Creates a new IDbDataParameter of the specific underlying type for this database provider type (i.e. SqlHelper for MSSQL, etc)
Public Method | FormatDateLiteral | Converts a DateTime value to a string according to the specific format of the underlying database type
Public Method | GetAdapter | Overloaded. Gets a database type-specific DbDataAdapter instance for this provider type (i.e. SqlDataAdapter for MSSQL) without any options set yet.
Public Method | GetAsStatement | Qualifies a column or table alias according to this provider's database type's rules regarding use of the AS keyword
Public Method | GetBitwiseAndStatement | Formats a bitwise AND statement according to the language features of the underlying database type
Public Method | GetConnection | Overloaded. Gets an IDbConnection object instance of the correct type for the underlying database (i.e. SqlConnection for MSSQL) that is prepared to connect to the specified database using the default connection string specified in the application configuration file.
Public Method | GetDateStatement | Gets a SQL statement fragment for the database-specific syntax of retrieving the current date (i.e. SYSDATE on Oracle or GETDATE() on MSSQL).
Public Method | GetDBDate | Executes a statement against the database to retrieve the current date/time on the database
Public Method | GetDbVersion | Overloaded. Executes a statement against the database to retrieve the database software's version number
Public Method | GetParameterNamePrefix | Gets the prefix used by the underlying database type for parameters in a parameterized query
static (Shared in Visual Basic) | ParseConnectionString | Parses a connection string into name-value pairs
Public Method | PrepareParameter | Prepares a parameter for the specified type of query according to the rules of the underlying database type
Public Method | PrepareSQLStatement | Prepares and formats a SQL statement according to the rules of the underlying database type
Public Method | RemoveParameterNamePrefix | Removes, if necessary, the parameter name prefix on a given parameter name
Public Method | SetDatabaseParameterTypeForClobText |
Public Method | TestConnection | Overloaded. Executes a test to connect to the database using the default connection string
Public Method | ValidateConnectionParams | Validates the supplied connection parameters against the rules of the underlying provider

Reference

DbProvider Class
FChoice.Common.Data Namespace


DbProvider Class Properties | fcSDK Documentation

DbProvider Class Properties

For a list of all members of this type, see DbProvider members.

Public Properties

 | Name | Description
Public Property | CanBatchQueries | Specifies whether the underlying database type for this provider can support multiple SQL statements per database round-trip
Public Property | ConnectionString | Gets or sets the connection string this provider will use for database connections
Public Property | MaxInListItems | Gets the maximum number of items the underlying database type supports in an IN() or NOT IN() SQL clause
Public Property | ProviderName | A general provider type or key to classify this provider
Public Property | RequiresDbNameParameter | Gets whether or not this provider requires the "dbname" argument for the CreateConnectionString Method
Public Property | TypeMapper | This property is intended for future use and is not currently used.

Reference

DbProvider Class
FChoice.Common.Data Namespace


DbProviderFactory Class Fields | fcSDK Documentation

DbProviderFactory Class Fields

For a list of all members of this type, see DbProviderFactory members.

Public Fields

 | Name | Description
Public Field | CONFIGURATION_SECTION_NAME | The name of the configuration section that DbProviderFactory expects in the application configuration file
Public Field | MSSQL_PROVIDER_NAME | The default provider name of MSSQL-based data providers
Public Field | ODPNET_PROVIDER_NAME |
Public Field | ORACLE_PROVIDER_NAME | The default provider name of Oracle-based data providers

Reference

DbProviderFactory Class
FChoice.Common.Data Namespace


DbProviderFactory Class Methods | fcSDK Documentation

DbProviderFactory Class Methods

For a list of all members of this type, see DbProviderFactory members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ConfigureProviders | Overloaded.
static (Shared in Visual Basic) | CreateProvider | Overloaded. Creates a new instance of a DbProvider object from the default configured provider
static (Shared in Visual Basic) | IsOracle |
Public Method | IsValidProvider | Gets whether or not the specified alias or name is a valid alias/name for a configured or intrinsic data access provider

Reference

DbProviderFactory Class
FChoice.Common.Data Namespace


DbProviderFactory Class Properties | fcSDK Documentation

DbProviderFactory Class Properties

For a list of all members of this type, see DbProviderFactory members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Provider | Gets a reference to the default configured DbProvider instance
static (Shared in Visual Basic) | ProviderNames | Gets the list of available provider names/alias that can be used for displaying to the user or as an argument for the CreateProvider method.

Reference

DbProviderFactory Class
FChoice.Common.Data Namespace


FCTypes Class Fields | fcSDK Documentation

FCTypes Class Fields

For a list of all members of this type, see FCTypes members.

Public Fields

 | Name | Description
Public Field | Date |
Public Field | DateNumber |
Public Field | Decimal |
Public Field | DecimalNumber |
Public Field | Float |
Public Field | FloatNumber |
Public Field | Guid |
Public Field | GuidNumber |
Public Field | LongInt |
Public Field | LongIntNumber |
Public Field | NText |
Public Field | NTextNumber |
Public Field | NVarchar |
Public Field | NVarcharNumber |
Public Field | Text |
Public Field | TextNumber |
Public Field | TinyInt |
Public Field | TinyIntNumber |
Public Field | Varchar |
Public Field | VarcharNumber |

Reference

FCTypes Class
FChoice.Common.Data Namespace


IDbExtension Interface Methods | fcSDK Documentation

IDbExtension Interface Methods

For a list of all members of this type, see IDbExtension members.

Public Methods

 | Name | Description
Method | Initialize | Initialize is called by the DbProvider when loading extensions. This method allows extensions to have a chance to perform initialization and start-up tasks.

Reference

IDbExtension Interface
FChoice.Common.Data Namespace


ODPOracleProvider Class Methods | fcSDK Documentation

ODPOracleProvider Class Methods

For a list of all members of this type, see ODPOracleProvider members.

Public Methods

 | Name | Description
Public Method | AreLargeTextFieldsClobs | (Inherited from FChoice.Common.Data.OracleProviderBase)
Public Method | CreateCommand | Overridden.
Public Method | CreateConnectionString | (Inherited from FChoice.Common.Data.OracleProviderBase)
Public Method | CreateParameter | Overridden.
Public Method | FormatDateLiteral | (Inherited from FChoice.Common.Data.OracleProviderBase)
Public Method | GetAdapter | Overloaded. Overridden.
Public Method | GetAsStatement | (Inherited from FChoice.Common.Data.OracleProviderBase)
Public Method | GetBitwiseAndStatement | (Inherited from FChoice.Common.Data.OracleProviderBase)
Public Method | GetConnection | Overloaded. Overridden.
Public Method | GetDateStatement | (Inherited from FChoice.Common.Data.OracleProviderBase)
Public Method | GetDBDate | (Inherited from FChoice.Common.Data.OracleProviderBase)
Public Method | GetDbVersion | Overloaded. (Inherited from FChoice.Common.Data.DbProvider)
Public Method | GetParameterNamePrefix | (Inherited from FChoice.Common.Data.OracleProviderBase)
Public Method | PrepareParameter | (Inherited from FChoice.Common.Data.OracleProviderBase)
Public Method | PrepareSQLStatement | (Inherited from FChoice.Common.Data.OracleProviderBase)
Public Method | RemoveParameterNamePrefix | (Inherited from FChoice.Common.Data.OracleProviderBase)
Public Method | SetDatabaseParameterTypeForClobText | Overridden.
Public Method | TestConnection | Overloaded. (Inherited from FChoice.Common.Data.DbProvider)
Public Method | ValidateConnectionParams | (Inherited from FChoice.Common.Data.OracleProviderBase)

Reference

ODPOracleProvider Class
FChoice.Common.Data Namespace


ODPOracleProvider Class Properties | fcSDK Documentation

ODPOracleProvider Class Properties

For a list of all members of this type, see ODPOracleProvider members.

Public Properties

 | Name | Description
Public Property | CanBatchQueries | Specifies whether the underlying database type for this provider can support multiple SQL statements per database round-trip (Inherited from FChoice.Common.Data.DbProvider)
Public Property | ConnectionString | Gets or sets the connection string this provider will use for database connections (Inherited from FChoice.Common.Data.DbProvider)
Public Property | MaxInListItems | (Inherited from FChoice.Common.Data.OracleProviderBase)
Public Property | ProviderName | (Inherited from FChoice.Common.Data.OracleProviderBase)
Public Property | RequiresDbNameParameter | (Inherited from FChoice.Common.Data.OracleProviderBase)
Public Property | TypeMapper | (Inherited from FChoice.Common.Data.OracleProviderBase)

Reference

ODPOracleProvider Class
FChoice.Common.Data Namespace


OleDbDataProviderBase Class Methods | fcSDK Documentation

OleDbDataProviderBase Class Methods

For a list of all members of this type, see OleDbDataProviderBase members.

Public Methods

 | Name | Description
Public Method | CreateCommand | (Inherited from FChoice.Common.Data.DbProvider)
Public Method | CreateConnectionString | Overridden.
Public Method | CreateParameter | Overridden.
Public Method | FormatDateLiteral | Converts a DateTime value to a string according to the specific format of the underlying database type (Inherited from FChoice.Common.Data.DbProvider)
Public Method | GetAdapter | Overloaded. Overridden.
Public Method | GetAsStatement | Qualifies a column or table alias according to this provider's database type's rules regarding use of the AS keyword (Inherited from FChoice.Common.Data.DbProvider)
Public Method | GetBitwiseAndStatement | Overridden.
Public Method | GetConnection | Overloaded. Overridden.
Public Method | GetDateStatement | Gets a SQL statement fragment for the database-specific syntax of retrieving the current date (i.e. SYSDATE on Oracle or GETDATE() on MSSQL). (Inherited from FChoice.Common.Data.DbProvider)
Public Method | GetDBDate | Executes a statement against the database to retrieve the current date/time on the database (Inherited from FChoice.Common.Data.DbProvider)
Public Method | GetDbVersion | Overloaded. (Inherited from FChoice.Common.Data.DbProvider)
Public Method | GetParameterNamePrefix | Overridden.
Public Method | PrepareParameter | Prepares a parameter for the specified type of query according to the rules of the underlying database type (Inherited from FChoice.Common.Data.DbProvider)
Public Method | PrepareSQLStatement | Overridden.
Public Method | RemoveParameterNamePrefix | Overridden.
Public Method | SetDatabaseParameterTypeForClobText | (Inherited from FChoice.Common.Data.DbProvider)
Public Method | TestConnection | Overloaded. (Inherited from FChoice.Common.Data.DbProvider)
Public Method | ValidateConnectionParams | Overridden.

Reference

OleDbDataProviderBase Class
FChoice.Common.Data Namespace


OleDbDataProviderBase Class Properties | fcSDK Documentation

OleDbDataProviderBase Class Properties

For a list of all members of this type, see OleDbDataProviderBase members.

Public Properties

 | Name | Description
Public Property | CanBatchQueries | Specifies whether the underlying database type for this provider can support multiple SQL statements per database round-trip (Inherited from FChoice.Common.Data.DbProvider)
Public Property | ConnectionString | Gets or sets the connection string this provider will use for database connections (Inherited from FChoice.Common.Data.DbProvider)
Public Property | MaxInListItems | Gets the maximum number of items the underlying database type supports in an IN() or NOT IN() SQL clause (Inherited from FChoice.Common.Data.DbProvider)
Public Property | ProviderName | A general provider type or key to classify this provider (Inherited from FChoice.Common.Data.DbProvider)
Public Property | RequiresDbNameParameter | Gets whether or not this provider requires the "dbname" argument for the CreateConnectionString Method (Inherited from FChoice.Common.Data.DbProvider)
Public Property | TypeMapper | This property is intended for future use and is not currently used. (Inherited from FChoice.Common.Data.DbProvider)

Reference

OleDbDataProviderBase Class
FChoice.Common.Data Namespace


OracleProviderBase Class Methods | fcSDK Documentation

OracleProviderBase Class Methods

For a list of all members of this type, see OracleProviderBase members.

Public Methods

 | Name | Description
Public Method | AreLargeTextFieldsClobs |
Public Method | CreateCommand | (Inherited from FChoice.Common.Data.DbProvider)
Public Method | CreateConnectionString | Overridden.
Public Method | CreateParameter | Overridden.
Public Method | FormatDateLiteral | Overridden.
Public Method | GetAdapter | Overloaded. Overridden.
Public Method | GetAsStatement | Overridden.
Public Method | GetBitwiseAndStatement | Overridden.
Public Method | GetConnection | Overloaded. Overridden.
Public Method | GetDateStatement | Overridden.
Public Method | GetDBDate | Overridden.
Public Method | GetDbVersion | Overloaded. (Inherited from FChoice.Common.Data.DbProvider)
static (Shared in Visual Basic) | GetNlsFormat | Executes a query to retrieve the database user's configured NLS format
Public Method | GetParameterNamePrefix | Overridden.
Public Method | PrepareParameter | Overridden.
Public Method | PrepareSQLStatement | Overridden.
Public Method | RemoveParameterNamePrefix | Overridden.
Public Method | SetDatabaseParameterTypeForClobText | (Inherited from FChoice.Common.Data.DbProvider)
Public Method | TestConnection | Overloaded. (Inherited from FChoice.Common.Data.DbProvider)
Public Method | ValidateConnectionParams | Overridden.

Reference

OracleProviderBase Class
FChoice.Common.Data Namespace


OracleProviderBase Class Properties | fcSDK Documentation

OracleProviderBase Class Properties

For a list of all members of this type, see OracleProviderBase members.

Public Properties

 | Name | Description
Public Property | CanBatchQueries | Specifies whether the underlying database type for this provider can support multiple SQL statements per database round-trip (Inherited from FChoice.Common.Data.DbProvider)
Public Property | ConnectionString | Gets or sets the connection string this provider will use for database connections (Inherited from FChoice.Common.Data.DbProvider)
Public Property | MaxInListItems | Overridden.
Public Property | ProviderName | Overridden.
Public Property | RequiresDbNameParameter | Overridden.
Public Property | TypeMapper | Overridden.

Reference

OracleProviderBase Class
FChoice.Common.Data Namespace


SqlHelper Class Fields | fcSDK Documentation

SqlHelper Class Fields

For a list of all members of this type, see SqlHelper members.

Public Fields

 | Name | Description
Public Field | IN_LIST_TOKEN |

Reference

SqlHelper Class
FChoice.Common.Data Namespace


SqlHelper Class Methods | fcSDK Documentation

SqlHelper Class Methods

For a list of all members of this type, see SqlHelper members.

Public Methods

 | Name | Description
Public Method | ExecuteDataSet | Overloaded. Executes the the SQL specified in the CommandText Property against the database using the provider specified in the DataProvider Property and returns the results as a DataSet
Public Method | ExecuteDataSetInList | Executes a specially formatted SQL statement specified in the CommandText Property
Public Method | ExecuteNonQuery | Overloaded.
Public Method | ExecuteNonQueryInList |
Public Method | ExecuteReader | Overloaded.
Public Method | ExecuteReaderInList |
Public Method | ExecuteScalar | Overloaded.
Public Method | ExecuteScalarInList |
Public Method | FillDataSet | Overloaded.
Public Method | FillDataSetInList | Overloaded.
static (Shared in Visual Basic) | FillDataSetRaw | Overloaded.
static (Shared in Visual Basic) | GetTableAsDataSet | Overloaded.
Public Method | PrepareInListStatement | Overloaded.
Public Method | PrepareIntegerListStatement |

Reference

SqlHelper Class
FChoice.Common.Data Namespace


SqlHelper Class Properties | fcSDK Documentation

SqlHelper Class Properties

For a list of all members of this type, see SqlHelper members.

Public Properties

 | Name | Description
Public Property | CommandText |
Public Property | CommandType |
Public Property | Connection |
Public Property | DataProvider |
static (Shared in Visual Basic) | Log |
Public Property | Parameters |
Public Property | Transaction |

Reference

SqlHelper Class
FChoice.Common.Data Namespace


TypeMapper Class Methods | fcSDK Documentation

TypeMapper Class Methods

For a list of all members of this type, see TypeMapper members.

Public Methods

 | Name | Description
Public Method | MapDbNameToDbNumber |
Public Method | MapDbNameToFCName |
Public Method | MapDbNameToFCNumber |
Public Method | MapDbNumberToDbName |
Public Method | MapDbNumberToFCName |
Public Method | MapDbNumberToFCNumber |
Public Method | MapFCNameToDbName |
Public Method | MapFCNameToDbNumber |
static (Shared in Visual Basic) | MapFCNameToFCNumber |
Public Method | MapFCNumberToDbName |
Public Method | MapFCNumberToDbNumber |
static (Shared in Visual Basic) | MapFCNumberToFCName |
Public Method | MapTypeToDbType |

Reference

TypeMapper Class
FChoice.Common.Data Namespace


UpdateQueryBatch Class Methods | fcSDK Documentation

UpdateQueryBatch Class Methods

For a list of all members of this type, see UpdateQueryBatch members.

Public Methods

 | Name | Description
Public Method | AddStatement | Adds an unprepared SQL statement (with the {n} and {DATE} parameters still present) to the list of statements to execute during the batch or executes it immediately if batching is not available or disabled
Public Method | Execute | Executes the batch if the provider supports statement batching, or nothing if it doesn't
Public Method | GetUniqueParamName | Gets a unique parameter name among all the parameters for all the queries in this batch based off a suggested base name

Reference

UpdateQueryBatch Class
FChoice.Common.Data Namespace


UpdateQueryBatch Class Properties | fcSDK Documentation

UpdateQueryBatch Class Properties

For a list of all members of this type, see UpdateQueryBatch members.

Public Properties

 | Name | Description
Public Property | CommandText | Gets the current command text that will be executed when the Execute Method is called
Public Property | Parameters | Gets the collection of all parameters for all queries to be executed by this batch
Public Property | Provider | Gets the provider that this batch is using
Public Property | SqlHelper | Gets the instance of a SqlHelper class that is used by this batch to manage parameters and execute statements
Public Property | Transaction | Gets the transaction specified when this UpdateQueryBatch instance was created

Reference

UpdateQueryBatch Class
FChoice.Common.Data Namespace


| fcSDK Documentation

 FChoice.Common.Data Namespace #### Inheritance Hierarchy

FChoice.Common.Data Namespace #### Inheritance Hierarchy

Inheritance Hierarchy

System.Object
FChoice.Common.Data.DataAccessSectionHandler
FChoice.Common.Data.DataParameterCollection
FChoice.Common.Data.DataSetSurrogate
FChoice.Common.Data.DbProvider
FChoice.Common.Data.MsSqlProvider
FChoice.Common.Data.OleDbDataProviderBase
FChoice.Common.Data.OracleProviderBase
FChoice.Common.Data.ODPOracleProvider
FChoice.Common.Data.OracleProvider
FChoice.Common.Data.DbProviderFactory
FChoice.Common.Data.FCTypes
FChoice.Common.Data.SqlHelper
FChoice.Common.Data.TypeMapper
FChoice.Common.Data.MsSqlTypeMapper
FChoice.Common.Data.OracleTypeMapper
FChoice.Common.Data.UpdateQueryBatch

Reference

FChoice.Common Assembly


DataProtector Class Methods | fcSDK Documentation

DataProtector Class Methods

For a list of all members of this type, see DataProtector members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Decrypt | Overloaded. Decrypts a byte array of data into a new byte array of unencrypted data
static (Shared in Visual Basic) | DecryptString | Overloaded. Decrypts data which was encoded into a string using the Base64 encoding scheme
static (Shared in Visual Basic) | Encrypt | Overloaded. Encrypts a byte array
static (Shared in Visual Basic) | EncryptString | Overloaded. Encrypts a string and returns a Base64-encoded string representing the encrypted output

Reference

DataProtector Class
FChoice.Common Namespace


FCArgumentException Class Methods | fcSDK Documentation

FCArgumentException Class Methods

For a list of all members of this type, see FCArgumentException members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | CheckIndexBounds | Used to verify that an indexer property get on a collection object contains an index that is within the bounds of collection.
static (Shared in Visual Basic) | CheckIsEmpty | Checks whether or not the supplied string value is null (Nothing in Visual Basic) or empty (trimmed length equals zero).
static (Shared in Visual Basic) | CheckIsNull | Checks to see whether the given parameter is null (Nothing in Visual Basic).
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | Sets the SerializationInfo object with the parameter name and additional exception information. (Inherited from FChoice.Common.FCExceptionBase)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)

Reference

FCArgumentException Class
FChoice.Common Namespace


FCArgumentException Class Properties | fcSDK Documentation

FCArgumentException Class Properties

For a list of all members of this type, see FCArgumentException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorCode | Gets the unique error code for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | ErrorMessageID | Gets the message identifier for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)

Reference

FCArgumentException Class
FChoice.Common Namespace


FCConfiguration Class Methods | fcSDK Documentation

FCConfiguration Class Methods

For a list of all members of this type, see FCConfiguration members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | LoadEnvironmentSettings | Overloaded. Retrieves the current configuration values or loads new ones if no current ones are available.
static (Shared in Visual Basic) | ParseFcEnvFile | Provided for legacy compatibility support, this method will parse an FC.ENV-style configuration file from the specified file path.

Reference

FCConfiguration Class
FChoice.Common Namespace


FCConfiguration Class Properties | fcSDK Documentation

FCConfiguration Class Properties

For a list of all members of this type, see FCConfiguration members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Current | Gets or sets the current configuration settings or null if none are currently configured.
static (Shared in Visual Basic) | DataProtectionEntropy |

Reference

FCConfiguration Class
FChoice.Common Namespace


FCExceptionBase Class Methods | fcSDK Documentation

FCExceptionBase Class Methods

For a list of all members of this type, see FCExceptionBase members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | Overridden. Sets the SerializationInfo object with the parameter name and additional exception information.
Public Method | GetType | (Inherited from System.Exception)
static (Shared in Visual Basic) | SetMessageProvider | Sets the IErrorMessageProvider that FCExceptionBase will use for loading custom exception error message strings for localization or customization.
Public Method | ToString | (Inherited from System.Exception)

Reference

FCExceptionBase Class
FChoice.Common Namespace


FCExceptionBase Class Properties | fcSDK Documentation

FCExceptionBase Class Properties

For a list of all members of this type, see FCExceptionBase members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorCode | Gets the unique error code for this exception.
Public Property | ErrorMessageID | Gets the message identifier for this exception.
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | Overridden. Gets a message that describes the current exception.
static (Shared in Visual Basic) | MessageProvider | Gets the custom IErrorMessageProvider if one is specified.
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)

Reference

FCExceptionBase Class
FChoice.Common Namespace


FCInvalidConfigurationException Class Methods | fcSDK Documentation

FCInvalidConfigurationException Class Methods

For a list of all members of this type, see FCInvalidConfigurationException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | Sets the SerializationInfo object with the parameter name and additional exception information. (Inherited from FChoice.Common.FCExceptionBase)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)

Reference

FCInvalidConfigurationException Class
FChoice.Common Namespace


FCInvalidConfigurationException Class Properties | fcSDK Documentation

FCInvalidConfigurationException Class Properties

For a list of all members of this type, see FCInvalidConfigurationException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorCode | Gets the unique error code for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | ErrorMessageID | Gets the message identifier for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)

Reference

FCInvalidConfigurationException Class
FChoice.Common Namespace


FCLicenseException Class Methods | fcSDK Documentation

FCLicenseException Class Methods

For a list of all members of this type, see FCLicenseException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
static (Shared in Visual Basic) | GetLicenseLoadError | This method is intended to be used internally by First Choice .NET products.
Public Method | GetObjectData | Sets the SerializationInfo object with the parameter name and additional exception information. (Inherited from FChoice.Common.FCExceptionBase)
static (Shared in Visual Basic) | GetProductLicenseError | This method is intended to be used internally by First Choice .NET products.
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)

Reference

FCLicenseException Class
FChoice.Common Namespace


FCLicenseException Class Properties | fcSDK Documentation

FCLicenseException Class Properties

For a list of all members of this type, see FCLicenseException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorCode | Gets the unique error code for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | ErrorMessageID | Gets the message identifier for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)

Reference

FCLicenseException Class
FChoice.Common Namespace


IErrorMessageProvider Interface Methods | fcSDK Documentation

IErrorMessageProvider Interface Methods

For a list of all members of this type, see IErrorMessageProvider members.

Public Methods

 | Name | Description
Method | GetMessageFormat | Called by FCExceptionBase Class when a specific error message string resource is required.

Reference

IErrorMessageProvider Interface
FChoice.Common Namespace


InvalidLoggingConfigException Class Methods | fcSDK Documentation

InvalidLoggingConfigException Class Methods

For a list of all members of this type, see InvalidLoggingConfigException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | Sets the SerializationInfo object with the parameter name and additional exception information. (Inherited from FChoice.Common.FCExceptionBase)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)

Reference

InvalidLoggingConfigException Class
FChoice.Common Namespace


InvalidLoggingConfigException Class Properties | fcSDK Documentation

InvalidLoggingConfigException Class Properties

For a list of all members of this type, see InvalidLoggingConfigException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorCode | Gets the unique error code for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | ErrorMessageID | Gets the message identifier for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)

Reference

InvalidLoggingConfigException Class
FChoice.Common Namespace


ILicenseInfo Interface Properties | fcSDK Documentation

ILicenseInfo Interface Properties

For a list of all members of this type, see ILicenseInfo members.

Public Properties

 | Name | Description
Property | ExpirationDate |
Property | GraceEventLimit |
Property | GraceEventsRemaining |
Property | GraceLicensesRemaining |
Property | GraceLoginLimit |
Property | GraceTimeSpan |
Property | ProductId |
Property | UserLicenseLimit |
Property | UserLicensesRemaining |
Property | UserRestriction |

Reference

ILicenseInfo Interface
FChoice.Common.Licensing Namespace


ILicenseTool Interface Methods | fcSDK Documentation

ILicenseTool Interface Methods

For a list of all members of this type, see ILicenseTool members.

Public Methods

 | Name | Description
Method | GraceEventInfo | Returns details of the current state of GraceEvents for a given license
Method | LogGraceEvent | Logs the occurrence of a grace event.
Method | RetrieveLicenses |
Method | ValidateLockdownData | Validates lock down data.

Reference

ILicenseTool Interface
FChoice.Common.Licensing Namespace


LicenseCollection Class Methods | fcSDK Documentation

LicenseCollection Class Methods

For a list of all members of this type, see LicenseCollection members.

Public Methods

 | Name | Description
Public Method | Clear | (Inherited from System.Collections.CollectionBase)
Public Method | GetEnumerator | (Inherited from System.Collections.CollectionBase)
Public Method | RemoveAt | (Inherited from System.Collections.CollectionBase)

Reference

LicenseCollection Class
FChoice.Common.Licensing Namespace


LicenseCollection Class Properties | fcSDK Documentation

LicenseCollection Class Properties

For a list of all members of this type, see LicenseCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)

Reference

LicenseCollection Class
FChoice.Common.Licensing Namespace


LicenseInfo Class Properties | fcSDK Documentation

LicenseInfo Class Properties

For a list of all members of this type, see LicenseInfo members.

Public Properties

 | Name | Description
Public Property | ExpirationDate |
Public Property | GraceEventLimit |
Public Property | GraceEventsRemaining |
Public Property | GraceLicensesRemaining |
Public Property | GraceLoginLimit |
Public Property | GraceTimeSpan |
Public Property | ProductId |
Public Property | UserLicenseLimit |
Public Property | UserLicensesRemaining |
Public Property | UserRestriction |

Reference

LicenseInfo Class
FChoice.Common.Licensing Namespace


LicenseManager Class Methods | fcSDK Documentation

LicenseManager Class Methods

For a list of all members of this type, see LicenseManager members.

Public Methods

 | Name | Description
Public Method | GetAllLicenseInformation |
Public Method | GetAllLicenseInformationXml |
Public Method | GetLicenseInformation |
static (Shared in Visual Basic) | Initialize | Overloaded. License Manager is initialized automatically during application initialization.
Public Method | RefreshLicensing |
Public Method | ReleaseLicenses |
Public Method | ReserveLicense | Overloaded.
Public Method | VerifyLicense |

Reference

LicenseManager Class
FChoice.Common.Licensing Namespace


LicenseManager Class Properties | fcSDK Documentation

LicenseManager Class Properties

For a list of all members of this type, see LicenseManager members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Instance | Since this class is a Singleton you must use this property to call instance methods.
static (Shared in Visual Basic) | IsInitialized | True if the singleton has been initialized.

Reference

LicenseManager Class
FChoice.Common.Licensing Namespace


XmlClarifyLicenseTool Class Methods | fcSDK Documentation

XmlClarifyLicenseTool Class Methods

For a list of all members of this type, see XmlClarifyLicenseTool members.

Public Methods

 | Name | Description
Public Method | GraceEventInfo |
Public Method | LogGraceEvent |
Public Method | RetrieveLicenses |
Public Method | ValidateLockdownData |

Reference

XmlClarifyLicenseTool Class
FChoice.Common.Licensing Namespace


XmlClarifyLicenseTool Class Properties | fcSDK Documentation

XmlClarifyLicenseTool Class Properties

For a list of all members of this type, see XmlClarifyLicenseTool members.

Public Properties

 | Name | Description
Public Property | XmlFilePath |

Reference

XmlClarifyLicenseTool Class
FChoice.Common.Licensing Namespace


XmlLicenseTool Class Methods | fcSDK Documentation

XmlLicenseTool Class Methods

For a list of all members of this type, see XmlLicenseTool members.

Public Methods

 | Name | Description
Public Method | GraceEventInfo |
Public Method | LogGraceEvent |
Public Method | RetrieveLicenses |
Public Method | ValidateLockdownData |

Reference

XmlLicenseTool Class
FChoice.Common.Licensing Namespace


XmlLicenseTool Class Properties | fcSDK Documentation

XmlLicenseTool Class Properties

For a list of all members of this type, see XmlLicenseTool members.

Public Properties

 | Name | Description
Public Property | XmlFilePath |

Reference

XmlLicenseTool Class
FChoice.Common.Licensing Namespace


| fcSDK Documentation

 FChoice.Common.Licensing Namespace #### Inheritance Hierarchy

FChoice.Common.Licensing Namespace #### Inheritance Hierarchy

Inheritance Hierarchy

System.Object
FChoice.Common.Licensing.LicenseInfo
FChoice.Common.Licensing.LicenseManager
FChoice.Common.Licensing.XmlClarifyLicenseTool
FChoice.Common.Licensing.XmlLicenseTool
System.Collections.CollectionBase
FChoice.Common.Licensing.LicenseCollection

Reference

FChoice.Common Assembly


Logger Class Methods | fcSDK Documentation

Logger Class Methods

For a list of all members of this type, see Logger members.

Public Methods

 | Name | Description
Public Method | Log | Overloaded. Writes a log entry with the specified level (if logging for that level is enabled).
Public Method | LogDebug | Overloaded. Writes a DEBUG-level log entry if DEBUG-level logging is enabled.
Public Method | LogError | Overloaded. Writes a ERROR-level log entry if ERROR-level logging is enabled.
Public Method | LogInfo | Overloaded. Writes a INFO-level log entry if INFO-level logging is enabled.
Public Method | LogWarn | Overloaded. Writes a WARN-level log entry if WARN-level logging is enabled.

Reference

Logger Class
FChoice.Common Namespace


Logger Class Properties | fcSDK Documentation

Logger Class Properties

For a list of all members of this type, see Logger members.

Public Properties

 | Name | Description
Public Property | IsDebugEnabled |
Public Property | IsErrorEnabled |
Public Property | IsFatalEnabled |
Public Property | IsInfoEnabled |
Public Property | IsWarnEnabled |

Reference

Logger Class
FChoice.Common Namespace


LogManager Class Fields | fcSDK Documentation

LogManager Class Fields

For a list of all members of this type, see LogManager members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | SyncRoot | Gets an object that can be used to synchronize access to LogManager.

Reference

LogManager Class
FChoice.Common Namespace


LogManager Class Methods | fcSDK Documentation

LogManager Class Methods

For a list of all members of this type, see LogManager members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | AddAppenderToLogger | Overloaded. Links a given appender to the specified .NET type-identified logger.
static (Shared in Visual Basic) | AddAppenderToRoot | Adds an already-prepared appender to the root level (affecting all loggers).
static (Shared in Visual Basic) | AddLogFileAppender | Creates a new rolling log file appender and adds it to the configuration for use elsewhere.
static (Shared in Visual Basic) | FindFile |
static (Shared in Visual Basic) | GetLogger | Overloaded. Retrieves a logger for the given type name.
static (Shared in Visual Basic) | Initialize | Initializes the LogManager.
static (Shared in Visual Basic) | Reconfigure |
static (Shared in Visual Basic) | ResetConfiguration | Resets the log configuration and configuration file back to defaults (root level set to INFO with no appenders).
static (Shared in Visual Basic) | SetLoggerLevel | Overloaded. Changes a specific logger's (specified by type) logging level.
static (Shared in Visual Basic) | SetRootLoggerLevel | Changes the root's logging level (affecting all loggers)
static (Shared in Visual Basic) | SetThreadContextValue | Sets a context variable for this thread.

Reference

LogManager Class
FChoice.Common Namespace


LogManager Class Properties | fcSDK Documentation

LogManager Class Properties

For a list of all members of this type, see LogManager members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Instance | Gets the singleton instance of LogManager.
static (Shared in Visual Basic) | IsInitialized | Gets whether or not LogManager has been properly initialized.
static (Shared in Visual Basic) | LogConfigFilePath | Gets or sets the full path to the file LogManager should attempt to use to configure itself.

Reference

LogManager Class
FChoice.Common Namespace


Reconfigure Method | fcSDK Documentation

Reconfigure Method

Overload List

Overload | Description
Reconfigure | Causes LogManager to flush it's configuration and reload it new from the configuration file.

Remarks

It is necessary to call this method after the configuration has been changed either outside of the application or using the log management methods such as AddAppenderToLogger, AddAppenderToRoot, and AddLogFileAppender.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogManager Class LogManager Members


PerfManager Class Methods | fcSDK Documentation

PerfManager Class Methods

For a list of all members of this type, see PerfManager members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | DeInitialize |
Public Method | GetCounter |
static (Shared in Visual Basic) | GetPerfDurationSecs | Returns the number of seconds that have elapsed since a specified time
static (Shared in Visual Basic) | GetPerfTimer | Gets the current value of the high-resolution performance counter
static (Shared in Visual Basic) | Initialize | Allows PerfManager to initialize itself by creating a new PerfMon instance name and preparing all the PerformanceCounter instances

Reference

PerfManager Class
FChoice.Common Namespace


PerfManager Class Properties | fcSDK Documentation

PerfManager Class Properties

For a list of all members of this type, see PerfManager members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | Instance | Retreives a reference to the singleton instance of PerfManager
Public Property | InstanceName | Gets the instance name for this application as it will appear in the PerfMon utility
static (Shared in Visual Basic) | IsEnabled |
static (Shared in Visual Basic) | IsInitialized |

Reference

PerfManager Class
FChoice.Common Namespace


IStateManager Interface Methods | fcSDK Documentation

IStateManager Interface Methods

For a list of all members of this type, see IStateManager members.

Public Methods

 | Name | Description
Method | GetApplicationStates | Overloaded.
Method | InitializeManager |
Method | InitializeState |
Method | IsStateExpired |
Method | LoadState | Overloaded.
Method | RemoveExpiredStates |
Method | RemoveState |
Method | ResetTimeout |
Method | SaveState | Overloaded.

Reference

IStateManager Interface
FChoice.Common.State Namespace


IStateManager Interface Properties | fcSDK Documentation

IStateManager Interface Properties

For a list of all members of this type, see IStateManager members.

Public Properties

 | Name | Description
Property | ApplicationName |
Property | IsStateSerialized |
Property | StateTimeout |

Reference

IStateManager Interface
FChoice.Common.State Namespace


MemoryStateManager Class Methods | fcSDK Documentation

MemoryStateManager Class Methods

For a list of all members of this type, see MemoryStateManager members.

Public Methods

 | Name | Description
Public Method | GetApplicationStates | Overloaded.
Public Method | InitializeManager |
Public Method | InitializeState |
Public Method | IsStateExpired |
Public Method | LoadState |
Public Method | RemoveExpiredStates |
Public Method | RemoveState |
Public Method | ResetTimeout |
Public Method | SaveState | Overloaded.

Reference

MemoryStateManager Class
FChoice.Common.State Namespace


MemoryStateManager Class Properties | fcSDK Documentation

MemoryStateManager Class Properties

For a list of all members of this type, see MemoryStateManager members.

Public Properties

 | Name | Description
Public Property | ApplicationName |
Public Property | IsStateSerialized |
Public Property | StateTimeout |

Reference

MemoryStateManager Class
FChoice.Common.State Namespace


MsSqlStateManager Class Methods | fcSDK Documentation

MsSqlStateManager Class Methods

For a list of all members of this type, see MsSqlStateManager members.

Public Methods

 | Name | Description
Public Method | GetApplicationStates | Overloaded. (Inherited from FChoice.Common.State.RemoteStateManager)
Public Method | GetCurrentStates | Overridden.
Public Method | InitializeManager | (Inherited from FChoice.Common.State.RemoteStateManager)
Public Method | InitializeState | Overridden.
Public Method | IsStateExpired | Overridden.
Public Method | LoadState | Overloaded. Overridden.
Public Method | RemoveExpiredStates | Overridden.
Public Method | RemoveState | Overridden.
Public Method | ResetTimeout | Overridden.
Public Method | SaveState | Overloaded. Overridden.

Reference

MsSqlStateManager Class
FChoice.Common.State Namespace


MsSqlStateManager Class Properties | fcSDK Documentation

MsSqlStateManager Class Properties

For a list of all members of this type, see MsSqlStateManager members.

Public Properties

 | Name | Description
Public Property | ApplicationName | (Inherited from FChoice.Common.State.RemoteStateManager)
Public Property | ConnectionString | (Inherited from FChoice.Common.State.RemoteStateManager)
Public Property | IsStateSerialized | (Inherited from FChoice.Common.State.RemoteStateManager)
Public Property | Provider | (Inherited from FChoice.Common.State.RemoteStateManager)
Public Property | StateTimeout | (Inherited from FChoice.Common.State.RemoteStateManager)

Reference

MsSqlStateManager Class
FChoice.Common.State Namespace


OracleStateManager Class Methods | fcSDK Documentation

OracleStateManager Class Methods

For a list of all members of this type, see OracleStateManager members.

Public Methods

 | Name | Description
Public Method | GetApplicationStates | Overloaded. (Inherited from FChoice.Common.State.RemoteStateManager)
Public Method | GetCurrentStates | Overridden.
Public Method | InitializeManager | (Inherited from FChoice.Common.State.RemoteStateManager)
Public Method | InitializeState | Overridden.
Public Method | IsStateExpired | Overridden.
Public Method | LoadState | Overloaded. Overridden.
Public Method | RemoveExpiredStates | Overridden.
Public Method | RemoveState | Overridden.
Public Method | ResetTimeout | Overridden.
Public Method | SaveState | Overloaded. Overridden.

Reference

OracleStateManager Class
FChoice.Common.State Namespace


OracleStateManager Class Properties | fcSDK Documentation

OracleStateManager Class Properties

For a list of all members of this type, see OracleStateManager members.

Public Properties

 | Name | Description
Public Property | ApplicationName | (Inherited from FChoice.Common.State.RemoteStateManager)
Public Property | ConnectionString | (Inherited from FChoice.Common.State.RemoteStateManager)
Public Property | IsStateSerialized | (Inherited from FChoice.Common.State.RemoteStateManager)
Public Property | Provider | (Inherited from FChoice.Common.State.RemoteStateManager)
Public Property | StateTimeout | (Inherited from FChoice.Common.State.RemoteStateManager)

Reference

OracleStateManager Class
FChoice.Common.State Namespace


RemoteStateManager Class Methods | fcSDK Documentation

RemoteStateManager Class Methods

For a list of all members of this type, see RemoteStateManager members.

Public Methods

 | Name | Description
Public Method | GetApplicationStates | Overloaded.
Public Method | GetCurrentStates |
Public Method | InitializeManager |
Public Method | InitializeState |
Public Method | IsStateExpired |
Public Method | LoadState | Overloaded.
Public Method | RemoveExpiredStates |
Public Method | RemoveState |
Public Method | ResetTimeout |
Public Method | SaveState | Overloaded.

Reference

RemoteStateManager Class
FChoice.Common.State Namespace


RemoteStateManager Class Properties | fcSDK Documentation

RemoteStateManager Class Properties

For a list of all members of this type, see RemoteStateManager members.

Public Properties

 | Name | Description
Public Property | ApplicationName |
Public Property | ConnectionString |
Public Property | IsStateSerialized |
Public Property | Provider |
Public Property | StateTimeout |

Reference

RemoteStateManager Class
FChoice.Common.State Namespace


StateManager Class Fields | fcSDK Documentation

StateManager Class Fields

For a list of all members of this type, see StateManager members.

Public Fields

 | Name | Description
Public Field | CONFIGURATION_SECTION_NAME |
Public Field | DEFAULT_APPLICATION_NAME |
static (Shared in Visual Basic) | SyncRoot |

Reference

StateManager Class
FChoice.Common.State Namespace


StateManager Class Methods | fcSDK Documentation

StateManager Class Methods

For a list of all members of this type, see StateManager members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetApplicationStates | Overloaded.
static (Shared in Visual Basic) | Initialize |
static (Shared in Visual Basic) | InitializeState |
static (Shared in Visual Basic) | IsStateExpired |
static (Shared in Visual Basic) | LoadState | Overloaded.
static (Shared in Visual Basic) | RemoveExpiredStates |
static (Shared in Visual Basic) | RemoveState |
static (Shared in Visual Basic) | ResetTimeout |
static (Shared in Visual Basic) | SaveState | Overloaded.

Reference

StateManager Class
FChoice.Common.State Namespace


StateManager Class Properties | fcSDK Documentation

StateManager Class Properties

For a list of all members of this type, see StateManager members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | ApplicationName |
static (Shared in Visual Basic) | IsStateSerialized |
static (Shared in Visual Basic) | StateTimeout |

Reference

StateManager Class
FChoice.Common.State Namespace


StateManagerException Class Methods | fcSDK Documentation

StateManagerException Class Methods

For a list of all members of this type, see StateManagerException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | Sets the SerializationInfo object with the parameter name and additional exception information. (Inherited from FChoice.Common.FCExceptionBase)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)

Reference

StateManagerException Class
FChoice.Common.State Namespace


StateManagerException Class Properties | fcSDK Documentation

StateManagerException Class Properties

For a list of all members of this type, see StateManagerException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorCode | Gets the unique error code for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | ErrorMessageID | Gets the message identifier for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)

Reference

StateManagerException Class
FChoice.Common.State Namespace


StateManagerSectionHandler Class Methods | fcSDK Documentation

StateManagerSectionHandler Class Methods

For a list of all members of this type, see StateManagerSectionHandler members.

Public Methods

 | Name | Description
Public Method | Create |

Reference

StateManagerSectionHandler Class
FChoice.Common.State Namespace


FChoice.Common.State Namespace #### Inheritance Hierarchy | fcSDK Documentation

FChoice.Common.State Namespace #### Inheritance Hierarchy

Inheritance Hierarchy

System.Object
FChoice.Common.State.MemoryStateManager
FChoice.Common.State.RemoteStateManager
FChoice.Common.State.MsSqlStateManager
FChoice.Common.State.OracleStateManager
FChoice.Common.State.StateManager
FChoice.Common.State.StateManagerSectionHandler
System.Exception
System.ApplicationException
FChoice.Common.FCExceptionBase
FChoice.Common.State.StateManagerException

Reference

FChoice.Common Assembly


StringUtil Class Methods | fcSDK Documentation

StringUtil Class Methods

For a list of all members of this type, see StringUtil members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | AreEqual | Overloaded.
static (Shared in Visual Basic) | IsNonEmptyString |
static (Shared in Visual Basic) | StartsWith | Overloaded.

Reference

StringUtil Class
FChoice.Common Namespace


FChoice.Common Namespace #### Inheritance Hierarchy | fcSDK Documentation

FChoice.Common Namespace #### Inheritance Hierarchy

Inheritance Hierarchy

System.Object
FChoice.Common.ConfigValues
FChoice.Common.DataProtector
FChoice.Common.FCConfiguration
FChoice.Common.Logger
FChoice.Common.LogManager
FChoice.Common.PerfManager
FChoice.Common.StringUtil
System.Exception
System.ApplicationException
FChoice.Common.FCExceptionBase
FChoice.Common.CommonException
FChoice.Common.FCArgumentException
FChoice.Common.FCInvalidConfigurationException
FChoice.Common.FCLicenseException
FChoice.Common.InvalidLoggingConfigException
FChoice.Common.State.StateManagerException

Reference

FChoice.Common Assembly


FChoice.Foundation.Clarify.Compatibility Assembly | fcSDK Documentation

FChoice.Foundation.Clarify.Compatibility Assembly

Namespaces

Namespace | Description
FChoice.Foundation.Clarify.Compatibility |


AdoField Class Properties | fcSDK Documentation

AdoField Class Properties

For a list of all members of this type, see AdoField members.

Public Properties

 | Name | Description
Public Property | DataType |
Public Property | Length |
Public Property | Name |

Reference

AdoField Class
FChoice.Foundation.Clarify.Compatibility Namespace


AdoFieldInformationProvider Class Fields | fcSDK Documentation

AdoFieldInformationProvider Class Fields

For a list of all members of this type, see AdoFieldInformationProvider members.

Public Fields

 | Name | Description
Public Field | MaximumFieldSizeForSortableAdoStringFields |

Reference

AdoFieldInformationProvider Class
FChoice.Foundation.Clarify.Compatibility Namespace


AdoFieldInformationProvider Class Methods | fcSDK Documentation

AdoFieldInformationProvider Class Methods

For a list of all members of this type, see AdoFieldInformationProvider members.

Public Methods

 | Name | Description
Public Method | GetAdoFieldInformation |

Reference

AdoFieldInformationProvider Class
FChoice.Foundation.Clarify.Compatibility Namespace


CompatibilityException Class Methods | fcSDK Documentation

CompatibilityException Class Methods

For a list of all members of this type, see CompatibilityException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | Sets the SerializationInfo object with the parameter name and additional exception information. (Inherited from FChoice.Common.FCExceptionBase)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)

Reference

CompatibilityException Class
FChoice.Foundation.Clarify.Compatibility Namespace


CompatibilityException Class Properties | fcSDK Documentation

CompatibilityException Class Properties

For a list of all members of this type, see CompatibilityException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorCode | Gets the unique error code for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | ErrorMessageID | Gets the message identifier for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)

Reference

CompatibilityException Class
FChoice.Foundation.Clarify.Compatibility Namespace


FCApplication Class Fields | fcSDK Documentation

FCApplication Class Fields

For a list of all members of this type, see FCApplication members.

Public Fields

 | Name | Description
Public Field | LOGDIRNAME |
Public Field | LOGFILENAME |
Public Field | SQLLOGFILENAME |

Reference

FCApplication Class
FChoice.Foundation.Clarify.Compatibility Namespace


FCApplication Class Methods | fcSDK Documentation

FCApplication Class Methods

For a list of all members of this type, see FCApplication members.

Public Methods

 | Name | Description
Public Method | build_mtm_name |
Public Method | CreateSession |
Public Method | CurrentSessions |
Public Method | EncryptClarifyPassword |
Public Method | EncryptDBPassword |
Public Method | FileExists |
Public Method | FindString |
Public Method | get_change_date_field |
Public Method | get_dt_fields |
Public Method | get_fields_types_lens |
Public Method | GetADPObjects |
Public Method | GetCountryList |
Public Method | GetCountryObjid |
Public Method | GetDefaultCountry |
Public Method | GetDefaultCountryObjId |
Public Method | GetDefaultState |
Public Method | GetDefaultStateObjid |
Public Method | GetDefaultTimeZone |
Public Method | GetDefaultTimeZoneObjid |
Public Method | GetFullStateObjid |
Public Method | GetGbstDefault |
Public Method | GetGbstDefaultObjid |
Public Method | GetGbstElmById |
Public Method | GetGbstElmObjid |
Public Method | GetGbstElmRankObjid |
Public Method | GetGbstList |
Public Method | GetHgbstElmDefault |
Public Method | GetHgbstElmDefaultObjid |
Public Method | GetHgbstElmObjId |
Public Method | GetHgbstList |
Public Method | GetLocalizedGbstDefault |
Public Method | GetLocalizedGbstElmById |
Public Method | GetRelationData |
Public Method | GetResClauses |
Public Method | GetResClausesStr |
Public Method | GetResTbl |
Public Method | GetServerTimeZoneOffset |
Public Method | GetShortTimeZoneObjId |
Public Method | GetStateObjid |
Public Method | GetStates |
Public Method | GetTableFields |
Public Method | GetTableID |
Public Method | GetTableName |
Public Method | GetTableRels |
Public Method | GetTablesAndViews |
Public Method | GetTimeZoneList |
Public Method | GetTimeZoneObjid |
Public Method | GetTimeZoneOffset |
Public Method | GetTimeZonesInCountry |
Public Method | Initialize |
Public Method | InitializeFull |
Public Method | InitializeWithParams |
Public Method | is_it_a_field |
Public Method | is_it_a_table |
Public Method | is_it_change_field |
Public Method | is_it_date_field |
Public Method | is_it_int_field |
Public Method | is_it_searchable |
Public Method | is_it_string_fld |
Public Method | is_it_unicode |
Public Method | is_rel_exclusive |
Public Method | is_rel_mandatory |
Public Method | IsCountry |
Public Method | IsFullState |
Public Method | IsInGbstLst |
Public Method | IsInHgbstList |
Public Method | IsOnDST |
Public Method | IsState |
Public Method | IsTimeZone |
Public Method | IsTimeZoneInCountry |
Public Method | Log |
Public Method | LogEx |
Public Method | RankIsInGbstLst |
Public Method | SetServerTimeZoneToMachineTimeZone |
Public Method | sprintf |
Public Method | UpdateCache |
Public Method | UpdateSchemaCache |
Public Method | ValidateEncryptedPassword |

Reference

FCApplication Class
FChoice.Foundation.Clarify.Compatibility Namespace


FCApplication Class Properties | fcSDK Documentation

FCApplication Class Properties

For a list of all members of this type, see FCApplication members.

Public Properties

 | Name | Description
Public Property | base_objid |
Public Property | clarify_ver |
Public Property | ConnectionString |
Public Property | ConvertTimeZone |
Public Property | DataProtectorEntropy |
Public Property | db_name |
Public Property | db_type |
Public Property | GetMachineTimeZone |
Public Property | IsDBTraveler |
Public Property | IsDBUnicode |
Public Property | IsFcflNet |
Public Property | LicenseExpirationDate |
Public Property | LoggingConfigFilePath |
Public Property | Midnight |
Public Property | schema_rev |
Public Property | ServerTimeZone |
Public Property | site_id |
Public Property | TruncateStringFields |
Public Property | WorkingDirectory |

Reference

FCApplication Class
FChoice.Foundation.Clarify.Compatibility Namespace


GetGbstList Method (FCApplication) | fcSDK Documentation

GetGbstList Method (FCApplication)

Overload List

Overload | Description
GetGbstList |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCApplication Class
FCApplication Members


FCBulk Class Methods | fcSDK Documentation

FCBulk Class Methods

For a list of all members of this type, see FCBulk members.

Public Methods

 | Name | Description
Public Method | AddGeneric |
Public Method | ChangeGenericsOrdering |
Public Method | GenericCount |
Public Method | NewEnum |
Public Method | Query |
Public Method | RemoveAllGenerics |
Public Method | RemoveGeneric |
Public Method | Update |
Public Method | UpdateAll |

Reference

FCBulk Class
FChoice.Foundation.Clarify.Compatibility Namespace


FCBulk Class Properties | fcSDK Documentation

FCBulk Class Properties

For a list of all members of this type, see FCBulk members.

Public Properties

 | Name | Description
Public Property | BulkID |
Public Property | Name |
Public Property | NoSorting |

Reference

FCBulk Class
FChoice.Foundation.Clarify.Compatibility Namespace


FCGeneric Class Methods | fcSDK Documentation

FCGeneric Class Methods

For a list of all members of this type, see FCGeneric members.

Public Methods

 | Name | Description
Public Method | AddForUpdate |
Public Method | AddNew |
Public Method | AppendFilter |
Public Method | AppendSort |
Public Method | AssignAllObjids |
Public Method | AssignObjid |
Public Method | ClearRoot |
Public Method | CloseGeneric |
Public Method | copy |
Public Method | Count |
Public Method | Delete |
Public Method | DeleteAll |
Public Method | Duplicate |
Public Method | get_Fields |
Public Method | GetField |
Public Method | GetFieldValue |
Public Method | let_Fields |
Public Method | MoveFirst |
Public Method | MoveFirstAbsolute |
Public Method | MoveLast |
Public Method | MoveLastAbsolute |
Public Method | MoveNext |
Public Method | MoveNextAbsolute |
Public Method | MovePrevious |
Public Method | MovePreviousAbsolute |
Public Method | MoveRelative |
Public Method | Query |
Public Method | RelateByID |
Public Method | RelateIntFldByID |
Public Method | RelateIntFldToRecord |
Public Method | RelateRecords |
Public Method | set_Fields |
Public Method | SimpleQuery |
Public Method | TotalCount |
Public Method | TraverseFromParent |
Public Method | TraverseFromRoot |
Public Method | UnRelateAll |
Public Method | UnRelateRecordFromAll |
Public Method | UnRelateRecords |
Public Method | Untraverse |
Public Method | Update |
Public Method | UpdateAll |

Reference

FCGeneric Class
FChoice.Foundation.Clarify.Compatibility Namespace


FCGeneric Class Properties | fcSDK Documentation

FCGeneric Class Properties

For a list of all members of this type, see FCGeneric members.

Public Properties

 | Name | Description
Public Property | BOF |
Public Property | Bulk |
Public Property | BulkName |
Public Property | child_objects |
Public Property | DataFields |
Public Property | DbObjectName |
Public Property | DbObjectNum |
Public Property | DelRelList |
Public Property | Distinct |
Public Property | EOF |
Public Property | ErrorOnQueryTooBig |
Public Property | Filter |
Public Property | GenericId |
Public Property | Id |
Public Property | IncludeRelations |
Public Property | Item |
Public Property | MaxRecords |
Public Property | NoRes |
Public Property | ParentBO |
Public Property | ParentRelation |
Public Property | Position |
Public Property | QueryEmptyToNull |
Public Property | records |
Public Property | rel_from_parent |
Public Property | rel_to_parent |
Public Property | rel_type |
Public Property | rowLimit |
Public Property | rowsReturned |
Public Property | SetNullStringsToEmpty |
Public Property | SortOrder |

Reference

FCGeneric Class
FChoice.Foundation.Clarify.Compatibility Namespace


FCList Class Methods | fcSDK Documentation

FCList Class Methods

For a list of all members of this type, see FCList members.

Public Methods

 | Name | Description
Public Method | AppendItem |
Public Method | AppendSingleItem |
Public Method | Clear |
Public Method | Contains |
Public Method | FindFirstindex |
Public Method | GetItemByIndex |
Public Method | ItemByIndex |
Public Method | Sort |

Reference

FCList Class
FChoice.Foundation.Clarify.Compatibility Namespace


FCList Class Properties | fcSDK Documentation

FCList Class Properties

For a list of all members of this type, see FCList members.

Public Properties

 | Name | Description
Public Property | AllowDuplicates |
Public Property | Count |
Public Property | ItemType |
Public Property | Sorted |

Reference

FCList Class
FChoice.Foundation.Clarify.Compatibility Namespace


FCNotLoggedInException Class Methods | fcSDK Documentation

FCNotLoggedInException Class Methods

For a list of all members of this type, see FCNotLoggedInException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | Sets the SerializationInfo object with the parameter name and additional exception information. (Inherited from FChoice.Common.FCExceptionBase)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)

Reference

FCNotLoggedInException Class
FChoice.Foundation.Clarify.Compatibility Namespace


FCNotLoggedInException Class Properties | fcSDK Documentation

FCNotLoggedInException Class Properties

For a list of all members of this type, see FCNotLoggedInException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorCode | Gets the unique error code for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | ErrorMessageID | Gets the message identifier for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)

Reference

FCNotLoggedInException Class
FChoice.Foundation.Clarify.Compatibility Namespace


FCNotLoggedInException Constructor | fcSDK Documentation

FCNotLoggedInException Constructor

Overload List

Overload | Description
FCNotLoggedInException Constructor |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCNotLoggedInException Class
FCNotLoggedInException Members


FCSession Class Methods | fcSDK Documentation

FCSession Class Methods

For a list of all members of this type, see FCSession members.

Public Methods

 | Name | Description
Public Method | accept_object |
Public Method | active_connection |
Public Method | AddAttachment |
Public Method | AppendFilter |
Public Method | assign_object |
Public Method | auto_dest |
Public Method | AutoDest |
Public Method | build_hist |
Public Method | build_lists |
Public Method | BuildUserVersionProc |
Public Method | change_obj_status |
Public Method | ChangePassword |
Public Method | ChangeResGroup |
Public Method | check_cl_trans |
Public Method | CloseAllGenerics |
Public Method | CloseGenerics |
Public Method | CloseSession |
Public Method | CommitTransaction |
Public Method | ConvertDate |
Public Method | ConvertFromLocalToServerTZ |
Public Method | ConvertFromServerToLocalTZ |
Public Method | create_act_entry | Overloaded.
Public Method | create_time_bomb | Overloaded.
Public Method | createBulk |
Public Method | CreateGeneric |
Public Method | CreateSqlExec |
Public Method | dispatch_object |
Public Method | Dispose |
Public Method | error_handler | Overloaded.
Public Method | ExecuteSQL |
Public Method | ExecuteSQLNoReturn |
Public Method | format_time |
Public Method | forward_object |
Public Method | FreeConnection |
Public Method | get_item |
Public Method | get_next_sn |
Public Method | GetColor |
Public Method | GetConfigItem |
Public Method | GetCurrentDate |
Public Method | GetCurrentServerDate |
Public Method | GetItem |
Public Method | GetNextNumScheme |
Public Method | GetNextSubcaseID | Overloaded.
Public Method | GetNumGenerics |
Public Method | GetObjid |
Public Method | GetUserVersion |
Public Method | Init_Object |
Public Method | IsUnicode |
Public Method | ItemCount |
Public Method | LoadColors |
Public Method | LoadUserVersions |
Public Method | Log |
Public Method | LogEx |
Public Method | Login |
Public Method | LoginFromFCApp |
Public Method | Logout |
Public Method | move_object |
Public Method | NewEnum |
Public Method | RefreshContext |
Public Method | RegisterLicenseRequirements |
Public Method | reject_object |
Public Method | RemoveAllGenericsInABulk |
Public Method | RollbackTransaction |
Public Method | SaveSession |
Public Method | set_item |
Public Method | SetNullStringToEmpty |
Public Method | SetPassword |
Public Method | SimpleQuery |
Public Method | single_quotify |
Public Method | sprintf |
Public Method | StartTransaction |
Public Method | TraverseFromParent |
Public Method | turn_off |
Public Method | use_list |
Public Method | yank_object |

Reference

FCSession Class
FChoice.Foundation.Clarify.Compatibility Namespace


FCSession Class Properties | fcSDK Documentation

FCSession Class Properties

For a list of all members of this type, see FCSession members.

Public Properties

 | Name | Description
Public Property | ad_auto |
Public Property | ad_list |
Public Property | BulkCollection |
Public Property | ConvertTimeZone |
Public Property | cur_res |
Public Property | CurrentCulture |
Public Property | CurrentNetTransaction |
Public Property | DbHelper |
Public Property | Distinct |
Public Property | ErrorMessage |
Public Property | ErrorNumber |
Public Property | ErrorSource |
Public Property | hist_change |
Public Property | IncludeRelations |
Public Property | IsInTransaction |
Public Property | IsLoggedIn |
Public Property | Item |
Public Property | LocalTimeZone |
Public Property | LocalTimeZoneOffset |
Public Property | LoginTime |
Public Property | NoRes |
Public Property | num_ad |
Public Property | PasswordRequired |
Public Property | QueryEmptyToNull |
Public Property | RESEnabled |
Public Property | rowLimit |
Public Property | SessionID |
Public Property | SetNullStringsToEmpty |
Public Property | ThrowErrors |
Public Property | TruncateStringFields |
Public Property | UpdateTime |

Reference

FCSession Class
FChoice.Foundation.Clarify.Compatibility Namespace


Dispose Method (FCSession) | fcSDK Documentation

Dispose Method (FCSession)

Overload List

Overload | Description
Dispose |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


FCSqlExec Class Methods | fcSDK Documentation

FCSqlExec Class Methods

For a list of all members of this type, see FCSqlExec members.

Public Methods

 | Name | Description
Public Method | AddSqlParameter |
Public Method | CloseConnection |
Public Method | Execute |
Public Method | ExecuteReturnRows |
Public Method | FreeConnection |
Public Method | OpenConnection |

Reference

FCSqlExec Class
FChoice.Foundation.Clarify.Compatibility Namespace


FCSqlExec Class Properties | fcSDK Documentation

FCSqlExec Class Properties

For a list of all members of this type, see FCSqlExec members.

Public Properties

 | Name | Description
Public Property | CurrentConnection |
Public Property | Records |
Public Property | StayConnected |

Reference

FCSqlExec Class
FChoice.Foundation.Clarify.Compatibility Namespace


IFCApplication Interface Methods | fcSDK Documentation

IFCApplication Interface Methods

For a list of all members of this type, see IFCApplication members.

Public Methods

 | Name | Description
Method | build_mtm_name |
Method | CreateSession |
Method | CurrentSessions |
Method | EncryptClarifyPassword |
Method | EncryptDBPassword |
Method | FileExists |
Method | FindString |
Method | get_change_date_field |
Method | get_dt_fields |
Method | get_fields_types_lens |
Method | GetADPObjects |
Method | GetCountryList |
Method | GetCountryObjid |
Method | GetDefaultCountry |
Method | GetDefaultCountryObjId |
Method | GetDefaultState |
Method | GetDefaultStateObjid |
Method | GetDefaultTimeZone |
Method | GetDefaultTimeZoneObjid |
Method | GetFullStateObjid |
Method | GetGbstDefault |
Method | GetGbstDefaultObjid |
Method | GetGbstElmById |
Method | GetGbstElmObjid |
Method | GetGbstElmRankObjid |
Method | GetGbstList |
Method | GetHgbstElmDefault |
Method | GetHgbstElmDefaultObjid |
Method | GetHgbstElmObjId |
Method | GetHgbstList |
Method | GetLocalizedGbstDefault |
Method | GetLocalizedGbstElmById |
Method | GetRelationData |
Method | GetResClauses |
Method | GetResClausesStr |
Method | GetResTbl |
Method | GetServerTimeZoneOffset |
Method | GetShortTimeZoneObjId |
Method | GetStateObjid |
Method | GetStates |
Method | GetTableFields |
Method | GetTableID |
Method | GetTableName |
Method | GetTableRels |
Method | GetTablesAndViews |
Method | GetTimeZoneList |
Method | GetTimeZoneObjid |
Method | GetTimeZoneOffset |
Method | GetTimeZonesInCountry |
Method | Initialize |
Method | InitializeFull |
Method | is_it_a_field |
Method | is_it_a_table |
Method | is_it_change_field |
Method | is_it_date_field |
Method | is_it_int_field |
Method | is_it_searchable |
Method | is_it_string_fld |
Method | is_it_unicode |
Method | is_rel_exclusive |
Method | is_rel_mandatory |
Method | IsCountry |
Method | IsFullState |
Method | IsInGbstLst |
Method | IsInHgbstList |
Method | IsOnDST |
Method | IsState |
Method | IsTimeZone |
Method | IsTimeZoneInCountry |
Method | Log |
Method | LogEx |
Method | RankIsInGbstLst |
Method | SetServerTimeZoneToMachineTimeZone |
Method | sprintf |
Method | UpdateCache |
Method | UpdateSchemaCache |
Method | ValidateEncryptedPassword |

Reference

IFCApplication Interface
FChoice.Foundation.Clarify.Compatibility Namespace


IFCApplication Interface Properties | fcSDK Documentation

IFCApplication Interface Properties

For a list of all members of this type, see IFCApplication members.

Public Properties

 | Name | Description
Property | base_objid |
Property | clarify_ver |
Property | ConnectionString |
Property | ConvertTimeZone |
Property | DataProtectorEntropy |
Property | db_name |
Property | db_type |
Property | GetMachineTimeZone |
Property | IsDBTraveler |
Property | IsDBUnicode |
Property | IsFcflNet |
Property | LicenseExpirationDate |
Property | LoggingConfigFilePath |
Property | Midnight |
Property | schema_rev |
Property | ServerTimeZone |
Property | site_id |
Property | TruncateStringFields |
Property | WorkingDirectory |

Reference

IFCApplication Interface
FChoice.Foundation.Clarify.Compatibility Namespace


IFCBulk Interface Methods | fcSDK Documentation

IFCBulk Interface Methods

For a list of all members of this type, see IFCBulk members.

Public Methods

 | Name | Description
Method | AddGeneric |
Method | ChangeGenericsOrdering |
Method | NewEnum |
Method | Query |
Method | RemoveAllGenerics |
Method | RemoveGeneric |
Method | Update |
Method | UpdateAll |

Reference

IFCBulk Interface
FChoice.Foundation.Clarify.Compatibility Namespace


IFCBulk Interface Properties | fcSDK Documentation

IFCBulk Interface Properties

For a list of all members of this type, see IFCBulk members.

Public Properties

 | Name | Description
Property | BulkID |
Property | Name |
Property | NoSorting |

Reference

IFCBulk Interface
FChoice.Foundation.Clarify.Compatibility Namespace


IFCGeneric Interface Methods | fcSDK Documentation

IFCGeneric Interface Methods

For a list of all members of this type, see IFCGeneric members.

Public Methods

 | Name | Description
Method | AddForUpdate |
Method | AddNew |
Method | AppendFilter |
Method | AppendSort |
Method | AssignAllObjids |
Method | AssignObjid |
Method | ClearRoot |
Method | CloseGeneric |
Method | copy |
Method | Count |
Method | Delete |
Method | DeleteAll |
Method | Duplicate |
Method | get_Fields |
Method | GetField |
Method | GetFieldValue |
Method | MoveFirst |
Method | MoveFirstAbsolute |
Method | MoveLast |
Method | MoveLastAbsolute |
Method | MoveNext |
Method | MoveNextAbsolute |
Method | MovePrevious |
Method | MovePreviousAbsolute |
Method | MoveRelative |
Method | Query |
Method | RelateByID |
Method | RelateIntFldByID |
Method | RelateIntFldToRecord |
Method | RelateRecords |
Method | set_Fields |
Method | SimpleQuery |
Method | TotalCount |
Method | TraverseFromParent |
Method | TraverseFromRoot |
Method | UnRelateAll |
Method | UnRelateRecordFromAll |
Method | UnRelateRecords |
Method | Untraverse |
Method | Update |
Method | UpdateAll |

Reference

IFCGeneric Interface
FChoice.Foundation.Clarify.Compatibility Namespace


IFCGeneric Interface Properties | fcSDK Documentation

IFCGeneric Interface Properties

For a list of all members of this type, see IFCGeneric members.

Public Properties

 | Name | Description
Property | BOF |
Property | Bulk |
Property | BulkName |
Property | child_objects |
Property | DataFields |
Property | DbObjectName |
Property | DbObjectNum |
Property | DelRelList |
Property | Distinct |
Property | EOF |
Property | ErrorOnQueryTooBig |
Property | Filter |
Property | GenericId |
Property | Id |
Property | IncludeRelations |
Property | Item |
Property | MaxRecords |
Property | NoRes |
Property | ParentBO |
Property | ParentRelation |
Property | Position |
Property | QueryEmptyToNull |
Property | records |
Property | rel_from_parent |
Property | rel_to_parent |
Property | rel_type |
Property | rowLimit |
Property | rowsReturned |
Property | SetNullStringsToEmpty |
Property | SortOrder |

Reference

IFCGeneric Interface
FChoice.Foundation.Clarify.Compatibility Namespace


IFCList Interface Methods | fcSDK Documentation

IFCList Interface Methods

For a list of all members of this type, see IFCList members.

Public Methods

 | Name | Description
Method | AppendItem |
Method | AppendSingleItem |
Method | Clear |
Method | Contains |
Method | FindFirstindex |
Method | GetItemByIndex |
Method | ItemByIndex |
Method | Sort |

Reference

IFCList Interface
FChoice.Foundation.Clarify.Compatibility Namespace


IFCList Interface Properties | fcSDK Documentation

IFCList Interface Properties

For a list of all members of this type, see IFCList members.

Public Properties

 | Name | Description
Property | AllowDuplicates |
Property | Count |
Property | ItemType |
Property | Sorted |

Reference

IFCList Interface
FChoice.Foundation.Clarify.Compatibility Namespace


IFCSession Interface Methods | fcSDK Documentation

IFCSession Interface Methods

For a list of all members of this type, see IFCSession members.

Public Methods

 | Name | Description
Method | accept_object |
Method | active_connection |
Method | AddAttachment |
Method | AppendFilter |
Method | assign_object |
Method | auto_dest |
Method | AutoDest |
Method | build_hist |
Method | build_lists |
Method | BuildUserVersionProc |
Method | change_obj_status |
Method | ChangePassword |
Method | ChangeResGroup |
Method | check_cl_trans |
Method | CloseAllGenerics |
Method | CloseGenerics |
Method | CloseSession |
Method | CommitTransaction |
Method | ConvertDate |
Method | ConvertFromLocalToServerTZ |
Method | ConvertFromServerToLocalTZ |
Method | create_act_entry | Overloaded.
Method | create_time_bomb | Overloaded.
Method | createBulk |
Method | CreateGeneric |
Method | CreateSqlExec |
Method | dispatch_object |
Method | error_handler | Overloaded.
Method | ExecuteSQL |
Method | ExecuteSQLNoReturn |
Method | format_time |
Method | forward_object |
Method | FreeConnection |
Method | get_item |
Method | get_next_sn |
Method | GetColor |
Method | GetConfigItem |
Method | GetCurrentDate |
Method | GetCurrentServerDate |
Method | GetItem |
Method | GetNextNumScheme |
Method | GetNextSubcaseID |
Method | GetNumGenerics |
Method | GetObjid |
Method | GetUserVersion |
Method | Init_Object |
Method | IsUnicode |
Method | ItemCount |
Method | LoadColors |
Method | LoadUserVersions |
Method | Log |
Method | LogEx |
Method | Login |
Method | LoginFromFCApp |
Method | Logout |
Method | move_object |
Method | NewEnum |
Method | RefreshContext |
Method | reject_object |
Method | RemoveAllGenericsInABulk |
Method | RollbackTransaction |
Method | SaveSession |
Method | set_item |
Method | SetNullStringToEmpty |
Method | SetPassword |
Method | SimpleQuery |
Method | single_quotify |
Method | sprintf |
Method | StartTransaction |
Method | TraverseFromParent |
Method | turn_off |
Method | use_list |
Method | yank_object |

Reference

IFCSession Interface
FChoice.Foundation.Clarify.Compatibility Namespace


IFCSession Interface Properties | fcSDK Documentation

IFCSession Interface Properties

For a list of all members of this type, see IFCSession members.

Public Properties

 | Name | Description
Property | ad_auto |
Property | ad_list |
Property | BulkCollection |
Property | ConvertTimeZone |
Property | cur_res |
Property | CurrentCulture |
Property | Distinct |
Property | ErrorMessage |
Property | ErrorNumber |
Property | ErrorSource |
Property | hist_change |
Property | IncludeRelations |
Property | IsInTransaction |
Property | IsLoggedIn |
Property | Item |
Property | LocalTimeZone |
Property | LocalTimeZoneOffset |
Property | LoginTime |
Property | NoRes |
Property | num_ad |
Property | PasswordRequired |
Property | QueryEmptyToNull |
Property | RESEnabled |
Property | rowLimit |
Property | SessionID |
Property | SetNullStringsToEmpty |
Property | ThrowErrors |
Property | TruncateStringFields |
Property | UpdateTime |

Reference

IFCSession Interface
FChoice.Foundation.Clarify.Compatibility Namespace


IFCSqlExec Interface Methods | fcSDK Documentation

IFCSqlExec Interface Methods

For a list of all members of this type, see IFCSqlExec members.

Public Methods

 | Name | Description
Method | AddSqlParameter |
Method | CloseConnection |
Method | Execute |
Method | ExecuteReturnRows |
Method | FreeConnection |
Method | OpenConnection |

Reference

IFCSqlExec Interface
FChoice.Foundation.Clarify.Compatibility Namespace


IFCSqlExec Interface Properties | fcSDK Documentation

IFCSqlExec Interface Properties

For a list of all members of this type, see IFCSqlExec members.

Public Properties

 | Name | Description
Property | Records |
Property | StayConnected |

Reference

IFCSqlExec Interface
FChoice.Foundation.Clarify.Compatibility Namespace


IMockAdoField Interface Methods | fcSDK Documentation

IMockAdoField Interface Methods

For a list of all members of this type, see IMockAdoField members.

Public Methods

 | Name | Description
Method | get_Value |
Method | set_Value |

Reference

IMockAdoField Interface
FChoice.Foundation.Clarify.Compatibility Namespace


IMockAdoField Interface Properties | fcSDK Documentation

IMockAdoField Interface Properties

For a list of all members of this type, see IMockAdoField members.

Public Properties

 | Name | Description
Property | DefinedSize |
Property | Name |
Property | NetValue |
Property | Type |

Reference

IMockAdoField Interface
FChoice.Foundation.Clarify.Compatibility Namespace


IMockCollection Interface Methods | fcSDK Documentation

IMockCollection Interface Methods

IMockCollection Interface Methods

For a list of all members of this type, see IMockCollection members.

Public Methods

 | Name | Description
Method | _NewEnum |
Method | Add |
Method | Count |
Method | Item |
Method | Remove |

Reference

IMockCollection Interface
FChoice.Foundation.Clarify.Compatibility Namespace


MockAdoField Class Methods | fcSDK Documentation

MockAdoField Class Methods

For a list of all members of this type, see MockAdoField members.

Public Methods

 | Name | Description
Public Method | get_Value |
Public Method | set_Value |

Reference

MockAdoField Class
FChoice.Foundation.Clarify.Compatibility Namespace


MockAdoField Class Properties | fcSDK Documentation

MockAdoField Class Properties

For a list of all members of this type, see MockAdoField members.

Public Properties

 | Name | Description
Public Property | DefinedSize |
Public Property | Name |
Public Property | NetValue |
Public Property | Type |

Reference

MockAdoField Class
FChoice.Foundation.Clarify.Compatibility Namespace


MockCollection Class Methods | fcSDK Documentation

MockCollection Class Methods

For a list of all members of this type, see MockCollection members.

Public Methods

 | Name | Description
Public Method | _NewEnum |
Public Method | Add |
Public Method | Count |
Public Method | Item |
Public Method | Remove |

Reference

MockCollection Class
FChoice.Foundation.Clarify.Compatibility Namespace


FChoice.Foundation.Clarify.Compatibility Namespace #### Inheritance Hierarchy | fcSDK Documentation

FChoice.Foundation.Clarify.Compatibility Namespace #### Inheritance Hierarchy

Inheritance Hierarchy

System.Object
FChoice.Foundation.Clarify.Compatibility.AdoField
FChoice.Foundation.Clarify.Compatibility.AdoFieldInformationProvider
FChoice.Foundation.Clarify.Compatibility.FCApplication
FChoice.Foundation.Clarify.Compatibility.FCBulk
FChoice.Foundation.Clarify.Compatibility.FCGeneric
FChoice.Foundation.Clarify.Compatibility.FCList
FChoice.Foundation.Clarify.Compatibility.FCSession
FChoice.Foundation.Clarify.Compatibility.FCSqlExec
FChoice.Foundation.Clarify.Compatibility.MockAdoField
FChoice.Foundation.Clarify.Compatibility.MockCollection
System.Exception
System.ApplicationException
FChoice.Common.FCExceptionBase
FChoice.Foundation.Clarify.Compatibility.CompatibilityException
FChoice.Foundation.Clarify.Compatibility.FCNotLoggedInException

Reference

FChoice.Foundation.Clarify.Compatibility Assembly


FChoice.Toolkits.Clarify Assembly | fcSDK Documentation

FChoice.Toolkits.Clarify Assembly

Namespaces

| Namespace | Description | | --- | --- | | FChoice.Toolkits.Clarify | Root namespace for all the API Toolkit functionality contained in the fcSDK. Shared objects such as ToolkitResult and AdditionalFields are contained in this namespace. For more information about a particular toolkit, please consult its individual namespace. | | FChoice.Toolkits.Clarify.Contracts | Provides APIs to allow you to modify ClearContracts objects, including contracts, schedules, and line items. Methods on the ContractsToolkit object allow you to create contracts, schedules, and line items as well as basic operations such as modify, dispatch, accept, reject, assign, yank, move, change status, log notes, reopen and more. | | FChoice.Toolkits.Clarify.DepotRepair | Provides APIs to allow you to modify Logistics Depot Repair objects such as Engineering Change Orders (ECOs), labor, and material costs. Methods on the DepotRepairToolkit object allow you to create, modify, and delete ECO headers and details, apply ECOs, create and modify labor records, and create/modify material records, and more. | | FChoice.Toolkits.Clarify.FieldOps | Provides APIs to allow you to modify Logistics Field Operations objects such as Time and Expense Logs, Dispatch Field Engineer Request, and Log Parts Used. Methods on the FieldOpsToolkit object allow you to create, modify, and delete time, expense, and on-site logs, handle Dispatch FE records, fully use the Log Parts Used functionality (including installing/deinstalling/moving site_parts, and affecting inventory), schedule appointments, and more. | | FChoice.Toolkits.Clarify.Interfaces | Provides APIs to allow you to modify common Clarify objects such as Contacts, Sites, Addresses, Solutions, Contracts, Parts, and more. Methods on the InterfacesToolkit object allow you to create, modify, dispatch, accept, reject, assign, yank, and move, among many others operations. | | FChoice.Toolkits.Clarify.Logistics | Provides APIs for ClearLogistics Spares Manager and Order Operations. Methods on the LogisticsToolkit allow you to fully manipulate part requests with operations such as create, modify, close, perform work flow (dispatch, assign, etc), change status, and note logging. In addition, there are also methods for all warehouse operations such as pick, unpick, fulfill, ship, receive, transfer, and more. | | FChoice.Toolkits.Clarify.Quality | Provides APIs to allow you to modify the basic ClearQuality object: the Change Request.

These APIs can be used in custom web pages, the Clarify thick-client GUI, or in interfaces.

Functions are provided to allow you to create, modify, close, dispatch, accept, reject, assign, yank, move, change status, log notes, reopen, fix, and more.

| | FChoice.Toolkits.Clarify.Sales |

This toolkit provides functions to allow you to emulate the Clarify ClearSales module.

Functions included allow you to modify aspects of Quotes, Action Items, Opportunities, and Leads.

| | FChoice.Toolkits.Clarify.Support |

Provides APIs to allow you to modify basic ClearSupport objects such as Case and Subcase.

These APIs can be used in custom web pages, the Clarify thick-client GUI, or in interfaces.

Functions are provided to allow you to create, modify, close, dispatch, accept, reject, assign, yank, move, change status, log notes, reopen, and more.

|


AdditionalFields Class Methods | fcSDK Documentation

AdditionalFields Class Methods

For a list of all members of this type, see AdditionalFields members.

Public Methods

 | Name | Description
Public Method | Append | Adds a field to be updated during the API invocation.
Public Method | Clone | This method is used internally and not meant to be used by end users.

Reference

AdditionalFields Class
FChoice.Toolkits.Clarify Namespace


ClarifyToolkitException Class Methods | fcSDK Documentation

ClarifyToolkitException Class Methods

For a list of all members of this type, see ClarifyToolkitException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | (Inherited from System.Exception)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)

Reference

ClarifyToolkitException Class
FChoice.Toolkits.Clarify Namespace


ClarifyToolkitException Class Properties | fcSDK Documentation

ClarifyToolkitException Class Properties

For a list of all members of this type, see ClarifyToolkitException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | (Inherited from System.Exception)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)

Reference

ClarifyToolkitException Class
FChoice.Toolkits.Clarify Namespace


CommunicationAddress Class Properties | fcSDK Documentation

CommunicationAddress Class Properties

For a list of all members of this type, see CommunicationAddress members.

Public Properties

 | Name | Description
Public Property | CommunicationRoleType |
Public Property | EmailAddress |

Reference

CommunicationAddress Class
FChoice.Toolkits.Clarify Namespace


ConstructorIndexAttribute Class Fields | fcSDK Documentation

ConstructorIndexAttribute Class Fields

For a list of all members of this type, see ConstructorIndexAttribute members.

Public Fields

 | Name | Description
Public Field | Index |

Reference

ConstructorIndexAttribute Class
FChoice.Toolkits.Clarify Namespace


ConstructorIndexAttribute Class Methods | fcSDK Documentation

ConstructorIndexAttribute Class Methods

For a list of all members of this type, see ConstructorIndexAttribute members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)

Reference

ConstructorIndexAttribute Class
FChoice.Toolkits.Clarify Namespace


ConstructorIndexAttribute Class Properties | fcSDK Documentation

ConstructorIndexAttribute Class Properties

For a list of all members of this type, see ConstructorIndexAttribute members.

Public Properties

 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)

Reference

ConstructorIndexAttribute Class
FChoice.Toolkits.Clarify Namespace


AcceptQuoteSetup Class Properties | fcSDK Documentation

AcceptQuoteSetup Class Properties

For a list of all members of this type, see AcceptQuoteSetup members.

Public Properties

 | Name | Description
Public Property | AcceptDate | DateTime the Quote was accepted. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | QuoteIDNum | Quote Identifier.
Public Property | UserName | The user who has accepted the Quote. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Quote. If not set, the UserName's default is used.

Reference

AcceptQuoteSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
AcceptQuote(AcceptQuoteSetup) Method


AddPOToScheduleSetup Class Properties | fcSDK Documentation

AddPOToScheduleSetup Class Properties

For a list of all members of this type, see AddPOToScheduleSetup members.

Public Properties

 | Name | Description
Public Property | ContractIDNum | Contract Identifier.
Public Property | ExpireDate | The DateTime the Purchase Order will expire. If not set, the current time is used.
Public Property | PaymentOption | Element from the 'Payment Method' application list. If not set, the default list value is used.
Public Property | PaymentTerms | Element from the 'Contract Pay Terms' application list. If not set, the default list value is used.
Public Property | POAmount | The amount of the Purchase Order.
Public Property | PODate | The DateTime the Purchase Order will expire. If not set, the current time is used.
Public Property | POIDNum | Purchase Order Identifier.
Public Property | POStatus | Element from the 'PO Status' application list. If not set, the default list value is used.
Public Property | ScheduleIDNum | Schedule Identifier.

Reference

AddPOToScheduleSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
AddPOToSchedule(AddPOToScheduleSetup) Method


AssignQuoteSetup Class Properties | fcSDK Documentation

AssignQuoteSetup Class Properties

For a list of all members of this type, see AssignQuoteSetup members.

Public Properties

 | Name | Description
Public Property | AssignDate | DateTime the Quote was assigned. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewUser | The new user to which the Quote is to be assigned.
Public Property | QuoteIDNum | Quote Identifier.
Public Property | UserName | The user who has assigned the Quote. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Quote. If not set, the UserName's default is used.

Reference

AssignQuoteSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
AssignQuote(AssignQuoteSetup) Method


ChangeQuoteStatusSetup Class Properties | fcSDK Documentation

ChangeQuoteStatusSetup Class Properties

For a list of all members of this type, see ChangeQuoteStatusSetup members.

Public Properties

 | Name | Description
Public Property | ChangeDate | The DateTime the Quote Status was changed. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewStatus | Element from the 'Quote Status' application list. If not set, the default list value is used.
Public Property | Notes | Notes about the Quote Status change.
Public Property | QuoteIDNum | Quote Identifier.
Public Property | UserName | The username of the user who is changing the Quote status. If not set, the Toolkit session user is used.

Reference

ChangeQuoteStatusSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
ChangeQuoteStatus(ChangeQuoteStatusSetup) Method


ContractsToolkit Class Methods | fcSDK Documentation

ContractsToolkit Class Methods

For a list of all members of this type, see ContractsToolkit members.

Public Methods

 | Name | Description
Public Method | AcceptQuote | Overloaded. Accept the specified Quote from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.
Public Method | AddPOToSchedule | Overloaded. Used to add purchase orders to schedules of contracts. This overload takes a set of required parameters for the API.
Public Method | AssignQuote | Overloaded. Assign the Quote to a new user. This overload takes a set of required parameters for the API.
Public Method | ChangeQuoteStatus | Overloaded. Causes the specified quote to have its status changed. This overload takes a set of required parameters for the API.
Public Method | CreateContract | Overloaded. Used to create a new contract. This overload takes a set of required parameters for the API.
Public Method | CreateContractLineItem | Overloaded. Used to create quote/contract line items. This overload takes a set of required parameters for the API.
Public Method | CreatePriceInstance | Overloaded. Used to create a new price instance for a support program. This overload takes a set of required parameters for the API.
Public Method | CreateSchedule | Overloaded. Used to create a contract schedule. This overload takes a set of required parameters for the API.
Public Method | DeleteSitePart | Overloaded. Used to delete a site_part in Clarify, and then unrelate the site_part from all other related records. This overload takes a set of required parameters for the API.
Public Method | DispatchQuote | Overloaded. Dispatch the Quote to the specified queue. This overload takes a set of required parameters for the API.
Public Method | ForwardQuote | Overloaded. Reject-forward the Quote from one queue to another. This overload takes a set of required parameters for the API.
Public Method | LogContractNote | Overloaded. Causes a note log to be created and added to the specified contract. This overload takes a set of required parameters for the API.
Public Method | MoveQuote | Overloaded. Move the Quote from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
Public Method | RejectContract | Overloaded. Reject the Contract from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.
Public Method | RejectQuote | Overloaded. Reject the Quote from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.
Public Method | RelateContractItemToSitePart | Overloaded. Used to relate (or unrelate) a Site Part from a contract line item. This overload takes a set of required parameters for the API.
Public Method | ReopenContract | Overloaded. Causes the specified contract to be reopened. This overload takes a set of required parameters for the API.
Public Method | UnrelateContractItemFromSitePart | Overloaded. Used to unrelate a Site Part from a contract line item. This overload takes a set of required parameters for the API.
Public Method | UpdateSchedule | Overloaded. Used to update a contract schedule. This overload takes a set of required parameters for the API.
Public Method | YankQuote | Overloaded. Yank the Quote from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.

Reference

ContractsToolkit Class
FChoice.Toolkits.Clarify.Contracts Namespace


ContractsToolkit Class Properties | fcSDK Documentation

ContractsToolkit Class Properties

For a list of all members of this type, see ContractsToolkit members.

Public Properties

 | Name | Description
Public Property | ImpersonatorUsername | (Inherited from FChoice.Toolkits.Clarify.Contracts.ContractsToolkitBase)

Reference

ContractsToolkit Class
FChoice.Toolkits.Clarify.Contracts Namespace


ContractsToolkitBase Class Properties | fcSDK Documentation

ContractsToolkitBase Class Properties

For a list of all members of this type, see ContractsToolkitBase members.

Public Properties

 | Name | Description
Public Property | ImpersonatorUsername |

Reference

ContractsToolkitBase Class
FChoice.Toolkits.Clarify.Contracts Namespace


CreateContractLineItemSetup Class Properties | fcSDK Documentation

CreateContractLineItemSetup Class Properties

For a list of all members of this type, see CreateContractLineItemSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | AutoInstall | Specifies whether to install the Line Item.
Public Property | Comments | Comments about the Line Item.
Public Property | ContractIDNum | Contract Identifier.
Public Property | CreateDate | The DateTime the Line Item was created. If not set, the current time is used.
Public Property | EndDate | The end DateTime for the Line Item. If not set, the CreateDate plus 1 year is used.
Public Property | IsTaxable | Indicates if the Line Item is taxable (true) or not (false).
Public Property | OverridePrice | If supplied, this is the per-unit price. If not set, price is taken from the price schedule.
Public Property | ParentLineItemObjid | The objid of the parent Line Item.
Public Property | PartDomain | The domain of the part for the Line Item.
Public Property | PartNumber | The part number for the Line Item.
Public Property | PartRevision | The revision of the part for the Line Item.
Public Property | POIDNum | Purchase Order Identifier.
Public Property | PriceSchedule | Name of the schedule from the Contract to put the Line Item on.
Public Property | Quantity | The quantity of the part for the Line Item.
Public Property | QuotedSiteIDNum | Site Identifier for the AutoInstall of this Line Item.
Public Property | SerialNumber | The serial number of the part for the Line Item.
Public Property | ServicedAtSiteIDNum | Site Identifier for servicing this Line Item.
Public Property | StartDate | The start DateTime for the Line Item. If not set, the CreateDate is used.
Public Property | UnitsUsed | The number of units used for the Line Item.
Public Property | UserName | The username of the user who is creating the Line Item. If not set, the Toolkit session user is used.

Reference

CreateContractLineItemSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
CreateContractLineItem(CreateContractLineItemSetup) Method


CreateContractSetup Class Properties | fcSDK Documentation

CreateContractSetup Class Properties

For a list of all members of this type, see CreateContractSetup members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AccountIDNum | Account Identifier. | | Public Property | AccountName | Name of the Account that the Contract is related to. | | Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation. | | Public Property | AdminUserName | The username of the Administrator of the Contract. If not set, the Toolkit session user is used. | | Public Property | BillToSiteIDNum | Site Identifier for the billing of this Contract. If not set, no relation is added. | | Public Property | ContactFirstName | Contact's first name. | | Public Property | ContactLastName | Contact's last name. | | Public Property | ContactPhone | Contact's phone number. | | Public Property | ContractIDNum | Contract Identifier. | | Public Property | ContractType | Element from the 'Contract Type' user list. If not set, the default list value is used. | | Public Property | CreateDate | The DateTime the Contract was created. If not set, the current time is used. | | Public Property | DefaultExpirationDate | The default expiration DateTime for the Contract. If not set, the current time is used. | | Public Property | DefaultStartDate | The default starting DateTime for the Contract. If not set, the current time is used. | | Public Property | ExpireDate | The expiration DateTime for the Contract. If not set, the current time is used. | | Public Property | GenerateTimeBombs | Specifies if timebombs should be created. | | Public Property | IsEvergreen | Indicates that the Contract can be identified in queries or reports as being eligible for renewal (true) or not (false). | | Public Property | IsWarranty | Flag to set the contract line items' default start state to one day past the end of the part's warranty period (true) or not (false).

| | Public Property | PriceProgram | The title of the Price Program for this Contract. If not set, then "US Std Price List" will be used. | | Public Property | Queue | The title of the queue to dispatch the new Contract to. | | Public Property | RenewPriorDays | The number of days to renew the Contract before the ExpireDate. | | Public Property | ShipToSiteIDNum | Site Identifier for the shipment of this Contract. If not set, no relation is added. | | Public Property | StartDate | The starting DateTime for the Contract. If not set, the current time is used. | | Public Property | Status | Element from the 'Quote' application list. If not set, the default list value is used. | | Public Property | Terms | Element from the 'Terms and Conditions' user list. If not set, the default list value is used. | | Public Property | Title | The title of the Contract. | | Public Property | UserName | The username of the user who is creating the Contract. If not set, the Toolkit session user is used. |

Reference

CreateContractSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
CreateContract(CreateContractSetup) Method


CreatePriceInstanceSetup Class Properties | fcSDK Documentation

CreatePriceInstanceSetup Class Properties

For a list of all members of this type, see CreatePriceInstanceSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | EffectiveDate | The starting DateTime for the Price Instance. If not set, the starting date from the Price Program is used.
Public Property | ExpireDate | The ending DateTime for the Price Instance. If not set, the ending date from the Price Program is used.
Public Property | PartDomain | The domain of the part for the Price Instance.
Public Property | PartNumber | The nuber of the part for the Price Instance.
Public Property | PartRevision | The revision of the part for the Price Instance.
Public Property | Price | The price of the part for the Price Instance.
Public Property | PriceProgram | The title of the Price Program for this Price Instance. If blank then "US Std Price List" will be used.
Public Property | PriceType | The price type for the Price Instance.
Public Property | Quantity | The quantity of the part for the Price Instance. If not set, it will default to a zero price quantity.
Public Property | SupportProgram | The support program for which this Price Instance is being created.

Reference

CreatePriceInstanceSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
CreatePriceInstance(CreatePriceInstanceSetup) Method


CreateScheduleSetup Class Properties | fcSDK Documentation

CreateScheduleSetup Class Properties

For a list of all members of this type, see CreateScheduleSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | BillingATTN | The name of the Attention person at billing site.
Public Property | BillingFrequency | How often will this Schedule induce billing?
Public Property | BillingOption | For any Billing Frequency except "One Time," select whether the customer is billed in advance or after the fact.
Public Property | BillingPeriodStartDate | The billing period starting DateTime for the Schedule. If not set, the current time is used.
Public Property | BillSiteIDNum | Site Identifier for the billing of this Schedule.
Public Property | ChargeEndDate | The charging end DateTime for the Schedule. If not set, the current time is used.
Public Property | ChargeStartDate | The charging start DateTime for the Schedule. If not set, the current time is used.
Public Property | ContractIDNum | Contract Identifier.
Public Property | FirstBillingDate | The first billing DateTime for the Schedule. If not set, the current time is used.
Public Property | PriceProgram | The title of the Price Program for this Schedule. If blank then "US Std Price List" will be used.
Public Property | ScheduleIDNum | Schedule Identifier.
Public Property | ShipToSiteIDNum | Site Identifier for the shipment of this Schedule.

Reference

CreateScheduleSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
CreateSchedule(CreateScheduleSetup) Method


DeleteSitePartSetup Class Properties | fcSDK Documentation

DeleteSitePartSetup Class Properties

For a list of all members of this type, see DeleteSitePartSetup members.

Public Properties

 | Name | Description
Public Property | SitePartObjid | The objid of the Site Part to be deleted.

Reference

DeleteSitePartSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
DeleteSitePart(DeleteSitePartSetup) Method


DispatchQuoteSetup Class Properties | fcSDK Documentation

DispatchQuoteSetup Class Properties

For a list of all members of this type, see DispatchQuoteSetup members.

Public Properties

 | Name | Description
Public Property | DispatchDate | DateTime the Quote was dispatched. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Queue | The queue into which the Quote is to be dispatched.
Public Property | QuoteIDNum | Quote Identifier.
Public Property | UserName | The user who has dispatched the Quote. If not set, the Toolkit session user is used.

Reference

DispatchQuoteSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
DispatchQuote(DispatchQuoteSetup) Method


ForwardQuoteSetup Class Properties | fcSDK Documentation

ForwardQuoteSetup Class Properties

For a list of all members of this type, see ForwardQuoteSetup members.

Public Properties

 | Name | Description
Public Property | ForwardDate | DateTime the Quote was forwarded. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewQueue | The new queue into which the Quote is to be forwarded.
Public Property | Notes | The reason the Quote was rejected from the queue into which it was dispatched.
Public Property | QuoteIDNum | Quote Identifier.
Public Property | UserName | The user who has forwarded the Quote. If not set, the Toolkit session user is used.

Reference

ForwardQuoteSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
ForwardQuote(ForwardQuoteSetup) Method


LogContractNoteSetup Class Properties | fcSDK Documentation

LogContractNoteSetup Class Properties

For a list of all members of this type, see LogContractNoteSetup members.

Public Properties

 | Name | Description
Public Property | ActionType | Element from the 'Note Log Action Type' application list. If not set, the default list value is used.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | ContractIDNum | Contract Identifier.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | InternalUseOnlyNotes | Notes designated for Internal Use Only.
Public Property | LogDate | The DateTime the Contract Note was logged. If not set, the current time is used.
Public Property | Notes | The notes being logged to the Contract.
Public Property | UserName | The user who is logging the Contract Note. If not set, the Toolkit session user is used.

Reference

LogContractNoteSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
LogContractNote(LogContractNoteSetup) Method


MoveQuoteSetup Class Properties | fcSDK Documentation

MoveQuoteSetup Class Properties

For a list of all members of this type, see MoveQuoteSetup members.

Public Properties

 | Name | Description
Public Property | NewWipBin | The new WipBin into which the Quote is to be moved.
Public Property | QuoteIDNum | Quote Identifier.

Reference

MoveQuoteSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
MoveQuote(MoveQuoteSetup) Method


RejectContractSetup Class Properties | fcSDK Documentation

RejectContractSetup Class Properties

For a list of all members of this type, see RejectContractSetup members.

Public Properties

 | Name | Description
Public Property | ContractIDNum | Contract Identifier.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Notes | The reason the Contract was rejected from the queue into which it was dispatched.
Public Property | RejectDate | DateTime the Contract was rejected. If not set, the current time is used.
Public Property | Status | Element from the 'Contract Status' application list. If not set, the default list value is used.
Public Property | UserName | The user who has rejected the Contract. If not set, the Toolkit session user is used.

Reference

RejectContractSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
RejectContract(RejectContractSetup) Method


RejectQuoteSetup Class Properties | fcSDK Documentation

RejectQuoteSetup Class Properties

For a list of all members of this type, see RejectQuoteSetup members.

Public Properties

 | Name | Description
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Notes | The reason the Quote was rejected from the queue into which it was dispatched.
Public Property | QuoteIDNum | Quote Identifier.
Public Property | RejectDate | DateTime the Quote was rejected. If not set, the current time is used.
Public Property | UserName | The user who has rejected the Quote. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Quote. If not set, the UserName's default is used.

Reference

RejectQuoteSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
RejectQuote(RejectQuoteSetup) Method


RelateContractItemToSitePartSetup Class Properties | fcSDK Documentation

RelateContractItemToSitePartSetup Class Properties

For a list of all members of this type, see RelateContractItemToSitePartSetup members.

Public Properties

 | Name | Description
Public Property | ContractObjid | The objid of the Contract for this Line Item.
Public Property | PartDomain | The domain of the part for the Line Item.
Public Property | PartNumber | The number of the part for the Line Item.
Public Property | PartRevision | The revision of the part for the Line Item.
Public Property | SerialNumber | The serial number of the site part for thie Line Item.

Reference

RelateContractItemToSitePartSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
RelateContractItemToSitePart(RelateContractItemToSitePartSetup) Method


ReopenContractSetup Class Properties | fcSDK Documentation

ReopenContractSetup Class Properties

For a list of all members of this type, see ReopenContractSetup members.

Public Properties

 | Name | Description
Public Property | ContractIDNum | Contract Identifier.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | ReopenDate | The DateTime the Contract was reopened. If not set, the current time is used.
Public Property | Status | Element from the 'Quote Status' application list. If not set, the default status for the Active Contract condition is used.
Public Property | UserName | The user who is reopening the Contract. If not set, the Toolkit session user is used.
Public Property | WipBin | The WipBin to place the Contract in. If not set, the contract is placed in the user’s default WipBin.

Reference

ReopenContractSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
ReopenContract(ReopenContractSetup) Method


UnrelateContractItemFromSitePartSetup Class Properties | fcSDK Documentation

UnrelateContractItemFromSitePartSetup Class Properties

For a list of all members of this type, see UnrelateContractItemFromSitePartSetup members.

Public Properties

 | Name | Description
Public Property | ContractObjid | The objid of the Contract for this Line Item.
Public Property | PartDomain | The domain of the part for the Line Item.
Public Property | PartNumber | The part number for the Line Item.
Public Property | PartRevision | The revision of the part for the Line Item.

Reference

UnrelateContractItemFromSitePartSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
UnrelateContractItemFromSitePart(UnrelateContractItemFromSitePartSetup) Method


UpdateScheduleSetup Class Properties | fcSDK Documentation

UpdateScheduleSetup Class Properties

For a list of all members of this type, see UpdateScheduleSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | BillingATTN | Specifies the to who's attention the billing is direct.
Public Property | BillingFrequency | Specifies how often will this Schedule induce billing.
Public Property | BillingOption | For any Billing Frequency except "OneTime," select whether the customer is billed in advance or after the fact.
Public Property | BillingPeriodStartDate | The billing period starting DateTime for the Schedule. If not set no change is made.
Public Property | BillSiteIDNum | Site Identifier for the billing of this Schedule.
Public Property | ChargeEndDate | The charging end DateTime for the Schedule. If not set, no change is made.
Public Property | ChargeStartDate | The charging start DateTime for the Schedule. If not set, no change is made.
Public Property | ContractIDNum | Contract Identifier.
Public Property | FirstBillingDate | The first billing DateTime for the Schedule. If not set, no change is made.
Public Property | PriceProgram | The title of the Price Program for this Schedule. If not set, then the value is not changed.
Public Property | ScheduleIDNum | Schedule Identifier.
Public Property | ShipToSiteIDNum | Site Identifier for the shipment of this Schedule.

Reference

UpdateScheduleSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
UpdateSchedule(UpdateScheduleSetup) Method


YankQuoteSetup Class Properties | fcSDK Documentation

YankQuoteSetup Class Properties

For a list of all members of this type, see YankQuoteSetup members.

Public Properties

 | Name | Description
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | QuoteIDNum | Quote Identifier.
Public Property | UserName | The user who has yanked the Quote. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Quote. If not set, the UserName's default is used.
Public Property | YankDate | DateTime the Quote was yanked. If not set, the current time is used.

Reference

YankQuoteSetup Class
FChoice.Toolkits.Clarify.Contracts Namespace
YankQuote(YankQuoteSetup) Method


FChoice.Toolkits.Clarify.Contracts Namespace #### Inheritance Hierarchy | fcSDK Documentation

FChoice.Toolkits.Clarify.Contracts Namespace #### Inheritance Hierarchy

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Contracts.AcceptQuoteSetup
FChoice.Toolkits.Clarify.Contracts.AddPOToScheduleSetup
FChoice.Toolkits.Clarify.Contracts.AssignQuoteSetup
FChoice.Toolkits.Clarify.Contracts.ChangeQuoteStatusSetup
FChoice.Toolkits.Clarify.Contracts.CreateContractLineItemSetup
FChoice.Toolkits.Clarify.Contracts.CreateContractSetup
FChoice.Toolkits.Clarify.Contracts.CreatePriceInstanceSetup
FChoice.Toolkits.Clarify.Contracts.CreateScheduleSetup
FChoice.Toolkits.Clarify.Contracts.DeleteSitePartSetup
FChoice.Toolkits.Clarify.Contracts.DispatchQuoteSetup
FChoice.Toolkits.Clarify.Contracts.ForwardQuoteSetup
FChoice.Toolkits.Clarify.Contracts.LogContractNoteSetup
FChoice.Toolkits.Clarify.Contracts.MoveQuoteSetup
FChoice.Toolkits.Clarify.Contracts.RejectContractSetup
FChoice.Toolkits.Clarify.Contracts.RejectQuoteSetup
FChoice.Toolkits.Clarify.Contracts.RelateContractItemToSitePartSetup
FChoice.Toolkits.Clarify.Contracts.ReopenContractSetup
FChoice.Toolkits.Clarify.Contracts.UnrelateContractItemFromSitePartSetup
FChoice.Toolkits.Clarify.Contracts.UpdateScheduleSetup
FChoice.Toolkits.Clarify.Contracts.YankQuoteSetup
FChoice.Toolkits.Clarify.ToolkitBase
FChoice.Toolkits.Clarify.Contracts.ContractsToolkitBase
FChoice.Toolkits.Clarify.Contracts.ContractsToolkit

Reference

FChoice.Toolkits.Clarify Assembly


ApplyEcoSetup Class Properties | fcSDK Documentation

ApplyEcoSetup Class Properties

For a list of all members of this type, see ApplyEcoSetup members.

Public Properties

 | Name | Description
Public Property | CreateDate | The DateTime the ECO is applied. If not set, the current time is used.
Public Property | DemandDetailObjid | Objid of the related Part Request Detail
Public Property | EcoHeaderIDNum | Identifier of the ECO header
Public Property | UserName | The user applying the ECO. If not set, the Toolkit session user is used.

Reference

ApplyEcoSetup Class
FChoice.Toolkits.Clarify.DepotRepair Namespace
ApplyEco(ApplyEcoSetup) Method


CreateDepotRepairLaborSetup Class Properties | fcSDK Documentation

CreateDepotRepairLaborSetup Class Properties

For a list of all members of this type, see CreateDepotRepairLaborSetup members.

Public Properties

 | Name | Description
Public Property | BillTo | Element from the 'BILL_TO_LABOR' application list. If not set, the default list value is used.
Public Property | CreateDate | The DateTime the Labor entry is created. If not set, the current time is used.
Public Property | DemandDetailObjid | Objid of the related Part Request Detail
Public Property | Duration | Length of time required to do the work, in seconds
Public Property | IsBillable | Indicates whether labor is billable.
Public Property | LaborRate | This is the labor rate for the employee performing the labor
Public Property | LaborType | Element from the 'Labor Type' application list. If not set, the default list value is used.
Public Property | StartDate | The DateTime the Labor began. If not set, the current time is used.
Public Property | UserName | The user creating the Labor entry. If not set, the Toolkit session user is used.
Public Property | WorkCenter | Indicates where labor was performed

Reference

CreateDepotRepairLaborSetup Class
FChoice.Toolkits.Clarify.DepotRepair Namespace
CreateDepotRepairLabor(CreateDepotRepairLaborSetup) Method


CreateDepotRepairMaterialSetup Class Properties | fcSDK Documentation

CreateDepotRepairMaterialSetup Class Properties

For a list of all members of this type, see CreateDepotRepairMaterialSetup members.

Public Properties

 | Name | Description
Public Property | BillTo | Element from the 'BILL_TO_MATERIAL' application list. If not set, the default list value is used.
Public Property | CreateDate | The DateTime the Material entry is created. If not set, the current time is used.
Public Property | DemandDetailObjid | Objid of the related Part Request Detail
Public Property | Disposition | Indicates how the material relates to the depot repair part.
Public Property | FailureCode | Element from the 'Failure Code' application list. If not set, the default list value is used.
Public Property | IsBillable | Indicates whether material is billable.
Public Property | Notes | Description area for the material usage activity.
Public Property | PartRevisionObjid | The objid of the part revision of the material that was put in use.
Public Property | ReferenceDesignator | Describes a reference location or designation for the part.
Public Property | RepairCode | Element from the 'Repair Type' application list. If not set, the default list value is used.
Public Property | TransactionID | Indicates the id of the GL transaction associated with this material usage
Public Property | UserName | The user creating the Material entry. If not set the Toolkit session user is used.
Public Property | WorkCenter | Indicates where material was used

Reference

CreateDepotRepairMaterialSetup Class
FChoice.Toolkits.Clarify.DepotRepair Namespace
CreateDepotRepairMaterial(CreateDepotRepairMaterialSetup) Method


CreateEcoHeaderSetup Class Properties | fcSDK Documentation

CreateEcoHeaderSetup Class Properties

For a list of all members of this type, see CreateEcoHeaderSetup members.

Public Properties

 | Name | Description
Public Property | CreateDate | The DateTime the ECO header is created. If not set, the current time is used.
Public Property | Description | The text description of the ECO header.
Public Property | EcoTitle | The title of the new ECO header
Public Property | EcoType | Element from the 'ECO Type' application list. If not set, the default list value is used.
Public Property | EffectType | Element from the 'ECO Effect Type' application list. If not set, the default list value is used.
Public Property | EndDate | The DateTime the ECO header becomes obsolete. If not set, the current time is used.
Public Property | StartDate | The DateTime the ECO header goes into effect. If not set, the current time is used.
Public Property | Status | Element from the 'ECO Status' application list. If not set, the default list value is used.

Reference

CreateEcoHeaderSetup Class
FChoice.Toolkits.Clarify.DepotRepair Namespace
CreateEcoHeader(CreateEcoHeaderSetup) Method


CreateEcoItemSetup Class Properties | fcSDK Documentation

CreateEcoItemSetup Class Properties

For a list of all members of this type, see CreateEcoItemSetup members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AppliesTo | This must be either 5148 to apply the ECO item to an ECO header, or 329 to apply the ECO item to a part revision.

| | Public Property | ApplyPartRevisionObjid | The objid of part revision affected by the ECO, or 0 for no change. | | Public Property | EcoHeaderIDNum | Identifier of the ECO header | | Public Property | IsActive | Is the ECO item active (true) or inactive (false) | | Public Property | ResultPartRevisionObjid | The objid of resulting part revision after applying the ECO, or 0 for no change. |

Reference

CreateEcoItemSetup Class
FChoice.Toolkits.Clarify.DepotRepair Namespace
CreateEcoItem(CreateEcoItemSetup) Method


CreateEcoLaborDetailSetup Class Properties | fcSDK Documentation

CreateEcoLaborDetailSetup Class Properties

For a list of all members of this type, see CreateEcoLaborDetailSetup members.

Public Properties

 | Name | Description
Public Property | Description | Description of the ECO labor detail
Public Property | EcoHeaderIDNum | Identifier of the ECO header
Public Property | ElapsedTime | Estimated amount of time required to perform the work in seconds.
Public Property | IsRequired | Indicates if this detail is required (true) or not (false)
Public Property | LaborType | Element from the 'Labor Type' application list. If not set, the default list value is used.
Public Property | PartRevisionObjid | The objid of the part revision of the material that was put in use.
Public Property | Status | Element from the 'ECO Status' application list. If not set, the default list value is used.

Reference

CreateEcoLaborDetailSetup Class
FChoice.Toolkits.Clarify.DepotRepair Namespace
CreateEcoLaborDetail(CreateEcoLaborDetailSetup) Method


CreateEcoMaterialDetailSetup Class Properties | fcSDK Documentation

CreateEcoMaterialDetailSetup Class Properties

For a list of all members of this type, see CreateEcoMaterialDetailSetup members.

Public Properties

 | Name | Description
Public Property | Description | Description of the ECO material detail
Public Property | EcoHeaderIDNum | Identifier of the ECO header
Public Property | IsRequired | Indicates if this detail is required (true) or not (false)
Public Property | Location | Indicates the location where the material belongs.
Public Property | PartRevisionObjid | The objid of the part revision of the material that was put in use.
Public Property | Status | Element from the 'ECO Status' application list. If not set, the default list value is used.

Reference

CreateEcoMaterialDetailSetup Class
FChoice.Toolkits.Clarify.DepotRepair Namespace
CreateEcoMaterialDetail(CreateEcoMaterialDetailSetup) Method


DeleteDepotRepairLaborSetup Class Properties | fcSDK Documentation

DeleteDepotRepairLaborSetup Class Properties

For a list of all members of this type, see DeleteDepotRepairLaborSetup members.

Public Properties

 | Name | Description
Public Property | CreateDate | The DateTime the Labor entry is removed. If not set, the current time is used.
Public Property | TimeLogObjid | The objid of the time log object to be deleted

Reference

DeleteDepotRepairLaborSetup Class
FChoice.Toolkits.Clarify.DepotRepair Namespace
DeleteDepotRepairLabor(DeleteDepotRepairLaborSetup) Method


DeleteDepotRepairMaterialSetup Class Properties | fcSDK Documentation

DeleteDepotRepairMaterialSetup Class Properties

For a list of all members of this type, see DeleteDepotRepairMaterialSetup members.

Public Properties

 | Name | Description
Public Property | CreateDate | The DateTime the Material entry is removed. If not set, the current time is used.
Public Property | MaterialLogObjid | The objid of the material log object to be deleted

Reference

DeleteDepotRepairMaterialSetup Class
FChoice.Toolkits.Clarify.DepotRepair Namespace
DeleteDepotRepairMaterial(DeleteDepotRepairMaterialSetup) Method


DeleteEcoDetailSetup Class Properties | fcSDK Documentation

DeleteEcoDetailSetup Class Properties

For a list of all members of this type, see DeleteEcoDetailSetup members.

Public Properties

 | Name | Description
Public Property | EcoDetailObjid | The objid of the ECO detail object to be deleted

Reference

DeleteEcoDetailSetup Class
FChoice.Toolkits.Clarify.DepotRepair Namespace
DeleteEcoDetail(DeleteEcoDetailSetup) Method


DeleteEcoItemSetup Class Properties | fcSDK Documentation

DeleteEcoItemSetup Class Properties

For a list of all members of this type, see DeleteEcoItemSetup members.

Public Properties

 | Name | Description
Public Property | EcoItemObjid | The objid of the ECO item object to be deleted

Reference

DeleteEcoItemSetup Class
FChoice.Toolkits.Clarify.DepotRepair Namespace
DeleteEcoItem(DeleteEcoItemSetup) Method


DepotRepairToolkit Class Methods | fcSDK Documentation

DepotRepairToolkit Class Methods

For a list of all members of this type, see DepotRepairToolkit members.

Public Methods

 | Name | Description
Public Method | ApplyEco | Overloaded. Apply an ECO to a Part Request Detail. This overload takes a set of required parameters for the API.
Public Method | CreateDepotRepairLabor | Overloaded. Create a Depot Repair Labor to be performed on a Part. This overload takes a set of required parameters for the API.
Public Method | CreateDepotRepairMaterial | Overloaded. Create a Depot Repair Material to be logged against a Part. This overload takes a set of required parameters for the API.
Public Method | CreateEcoHeader | Overloaded. Create an Engineering Change Order (ECO) Header. This overload takes a set of required parameters for the API.
Public Method | CreateEcoItem | Overloaded. Create an Engineering Change Order (ECO) Item. This overload takes a set of required parameters for the API.
Public Method | CreateEcoLaborDetail | Overloaded. Add a Labor Detail to a ECO Header. This overload takes a set of required parameters for the API.
Public Method | CreateEcoMaterialDetail | Overloaded. Add a Material Usage Detail to an ECO Header. This overload takes a set of required parameters for the API.
Public Method | DeleteDepotRepairLabor | Overloaded. Delete a Depot Repair Part. This overload takes a set of required parameters for the API.
Public Method | DeleteDepotRepairMaterial | Overloaded. Delete a Depot Repair Material. This overload takes a set of required parameters for the API.
Public Method | DeleteEcoDetail | Overloaded. Delete an ECO Detail. This overload takes a set of required parameters for the API.
Public Method | DeleteEcoItem | Overloaded. Delete an ECO Item. This overload takes a set of required parameters for the API.
Public Method | UpdateDepotRepairLabor | Overloaded. Update a Depot Repair Labor. This overload takes a setup object.
Public Method | UpdateDepotRepairMaterial | Overloaded. Update a Depot Repair Material. This overload takes a set of required parameters for the API.
Public Method | UpdateEcoItem | Overloaded. Update an ECO Item. This overload takes a set of required parameters for the API.
Public Method | UpdateEcoLaborDetail | Overloaded. Update an ECO Labor Detail. This overload takes a setup object.
Public Method | UpdateEcoMaterialDetail | Overloaded. Update an ECO Material Detail. This overload takes a set of required parameters for the API.

Reference

DepotRepairToolkit Class
FChoice.Toolkits.Clarify.DepotRepair Namespace


DepotRepairToolkit Class Properties | fcSDK Documentation

DepotRepairToolkit Class Properties

For a list of all members of this type, see DepotRepairToolkit members.

Public Properties

 | Name | Description
Public Property | ImpersonatorUsername | (Inherited from FChoice.Toolkits.Clarify.DepotRepair.DepotRepairToolkitBase)

Reference

DepotRepairToolkit Class
FChoice.Toolkits.Clarify.DepotRepair Namespace


DepotRepairToolkitBase Class Properties | fcSDK Documentation

DepotRepairToolkitBase Class Properties

For a list of all members of this type, see DepotRepairToolkitBase members.

Public Properties

 | Name | Description
Public Property | ImpersonatorUsername |

Reference

DepotRepairToolkitBase Class
FChoice.Toolkits.Clarify.DepotRepair Namespace


UpdateDepotRepairLaborSetup Class Properties | fcSDK Documentation

UpdateDepotRepairLaborSetup Class Properties

For a list of all members of this type, see UpdateDepotRepairLaborSetup members.

Public Properties

 | Name | Description
Public Property | BillTo | Indicates who is billed for the labor. Will use default if not supplied.
Public Property | CreateDate | The DateTime the Labor entry is updated. If not set, the current time is used.
Public Property | Duration | Length of time required to do the work, in seconds
Public Property | IsBillable | Indicates whether labor is billable.
Public Property | LaborRate | This is the labor rate for the employee performing the labor
Public Property | LaborType | Element from the 'Labor Type' application list. If not set, the default list value is used.
Public Property | StartDate | The DateTime the Labor began. If not set, the current time is used.
Public Property | TimeLogObjid | The objid of the time log object to be updated
Public Property | UserName | The user updating the Labor entry. If not set, the Toolkit session user is used.
Public Property | WorkCenter | Indicates where labor was performed

Reference

UpdateDepotRepairLaborSetup Class
FChoice.Toolkits.Clarify.DepotRepair Namespace
UpdateDepotRepairLabor(UpdateDepotRepairLaborSetup) Method


UpdateDepotRepairMaterialSetup Class Properties | fcSDK Documentation

UpdateDepotRepairMaterialSetup Class Properties

For a list of all members of this type, see UpdateDepotRepairMaterialSetup members.

Public Properties

 | Name | Description
Public Property | BillTo | Indicates who is billed for the material. Will use default if not supplied.
Public Property | CreateDate | The DateTime the Material entry is updated. If not set the current time is used.
Public Property | Disposition | Indicates how the material relates to the depot repair part.
Public Property | FailureCode | Element from the 'Failure Code' application list. If not set, the default list value is used.
Public Property | IsBillable | Indicates whether material is billable.
Public Property | MaterialLogObjid | The objid of the material log object to be updated
Public Property | Notes | Description area for the material usage activity.
Public Property | PartRevisionObjid | The objid of the part revision of the material that was put in use.
Public Property | ReferenceDesignator | Describes a reference location or designation for the part.
Public Property | RepairCode | Element from the 'Repair Type' application list. If not set, the default list value is used.
Public Property | TransactionID | Indicates the id of the GL transaction associated with this material usage
Public Property | UserName | The user updating the Material entry. If not set, the Toolkit session user is used.
Public Property | WorkCenter | Indicates where material was used

Reference

UpdateDepotRepairMaterialSetup Class
FChoice.Toolkits.Clarify.DepotRepair Namespace
UpdateDepotRepairMaterial(UpdateDepotRepairMaterialSetup) Method


UpdateEcoItemSetup Class Properties | fcSDK Documentation

UpdateEcoItemSetup Class Properties

For a list of all members of this type, see UpdateEcoItemSetup members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AppliesTo | This must be either 5148 to apply the ECO item to an ECO header, or 329 to apply the ECO item to a part revision.

| | Public Property | ApplyPartRevisionObjid | The objid of part revision affected by the ECO, or 0 for no change. | | Public Property | EcoHeaderIDNum | Identifier of the ECO header | | Public Property | EcoItemObjid | The objid of the ECO item object to be updated | | Public Property | IsActive | Is the ECO item active (true) or inactive (false) | | Public Property | ResultPartRevisionObjid | The objid of resulting part revision after applying the ECO, or 0 for no change. |

Reference

UpdateEcoItemSetup Class
FChoice.Toolkits.Clarify.DepotRepair Namespace
UpdateEcoItem(UpdateEcoItemSetup) Method


UpdateEcoLaborDetailSetup Class Properties | fcSDK Documentation

UpdateEcoLaborDetailSetup Class Properties

For a list of all members of this type, see UpdateEcoLaborDetailSetup members.

Public Properties

 | Name | Description
Public Property | Description | Description of the ECO labor detail
Public Property | EcoDetailObjid | The objid of the ECO detail object to be updated
Public Property | EcoHeaderIDNum | Identifier of the ECO header
Public Property | ElapsedTime | Estimated amount of time, in seconds, required to perform the work.
Public Property | IsRequired | Indicates if this detail is required (true) or not (false)
Public Property | LaborType | Element from the 'Labor Type' application list. If not set, the default list value is used.
Public Property | Status | Element from the 'ECO Status' application list. If not set, the default list value is used.

Reference

UpdateEcoLaborDetailSetup Class
FChoice.Toolkits.Clarify.DepotRepair Namespace
UpdateEcoLaborDetail(UpdateEcoLaborDetailSetup) Method


UpdateEcoMaterialDetailSetup Class Properties | fcSDK Documentation

UpdateEcoMaterialDetailSetup Class Properties

For a list of all members of this type, see UpdateEcoMaterialDetailSetup members.

Public Properties

 | Name | Description
Public Property | Description | Description of the ECO material detail
Public Property | EcoDetailObjid | The objid of the ECO detail object to be updated
Public Property | EcoHeaderIDNum | Identifier of the ECO header
Public Property | ElapsedTime | Estimated amount of time required to perform the work in seconds.
Public Property | IsRequired | Indicates if this detail is required (true) or not (false)
Public Property | Location | Indicates the location where the material belongs.
Public Property | PartRevisionObjid | The objid of the part revision of the material that was put in use.
Public Property | Status | Element from the 'ECO Status' application list. If not set, the default list value is used.

Reference

UpdateEcoMaterialDetailSetup Class
FChoice.Toolkits.Clarify.DepotRepair Namespace
UpdateEcoMaterialDetail(UpdateEcoMaterialDetailSetup) Method


FChoice.Toolkits.Clarify.DepotRepair Namespace #### Inheritance Hierarchy | fcSDK Documentation

FChoice.Toolkits.Clarify.DepotRepair Namespace #### Inheritance Hierarchy

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.DepotRepair.ApplyEcoSetup
FChoice.Toolkits.Clarify.DepotRepair.CreateDepotRepairLaborSetup
FChoice.Toolkits.Clarify.DepotRepair.CreateDepotRepairMaterialSetup
FChoice.Toolkits.Clarify.DepotRepair.CreateEcoHeaderSetup
FChoice.Toolkits.Clarify.DepotRepair.CreateEcoItemSetup
FChoice.Toolkits.Clarify.DepotRepair.CreateEcoLaborDetailSetup
FChoice.Toolkits.Clarify.DepotRepair.CreateEcoMaterialDetailSetup
FChoice.Toolkits.Clarify.DepotRepair.DeleteDepotRepairLaborSetup
FChoice.Toolkits.Clarify.DepotRepair.DeleteDepotRepairMaterialSetup
FChoice.Toolkits.Clarify.DepotRepair.DeleteEcoDetailSetup
FChoice.Toolkits.Clarify.DepotRepair.DeleteEcoItemSetup
FChoice.Toolkits.Clarify.DepotRepair.UpdateDepotRepairLaborSetup
FChoice.Toolkits.Clarify.DepotRepair.UpdateDepotRepairMaterialSetup
FChoice.Toolkits.Clarify.DepotRepair.UpdateEcoItemSetup
FChoice.Toolkits.Clarify.DepotRepair.UpdateEcoLaborDetailSetup
FChoice.Toolkits.Clarify.DepotRepair.UpdateEcoMaterialDetailSetup
FChoice.Toolkits.Clarify.ToolkitBase
FChoice.Toolkits.Clarify.DepotRepair.DepotRepairToolkitBase
FChoice.Toolkits.Clarify.DepotRepair.DepotRepairToolkit

Reference

FChoice.Toolkits.Clarify Assembly


AddServiceInterruptionResult Class Properties | fcSDK Documentation

AddServiceInterruptionResult Class Properties

For a list of all members of this type, see AddServiceInterruptionResult members.

Public Properties

 | Name | Description
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ScheduleObjid | The Objid of the Schedule.

Reference

AddServiceInterruptionResult Class
FChoice.Toolkits.Clarify.FieldOps Namespace


AddServiceInterruptionResult Constructor | fcSDK Documentation

AddServiceInterruptionResult Constructor

Overload List

Overload | Description
AddServiceInterruptionResult Constructor |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

AddServiceInterruptionResult Class
AddServiceInterruptionResult Members


AddServiceInterruptionSetup Class Properties | fcSDK Documentation

AddServiceInterruptionSetup Class Properties

For a list of all members of this type, see AddServiceInterruptionSetup members.

Public Properties

 | Name | Description
Public Property | CaseIDNum | The identifier of the Case with which this Service Interuption is associated
Public Property | CreateDate | The DateTime the Service Interput was created. If not set, the current time is used.
Public Property | Description | The description of the Service Interuption.
Public Property | Duration | The length (in seconds) of the Service Interuption. If not specified, it is calculated from the start and end times.
Public Property | EndDate | The DateTime the Service Interuption ends. If not set, the start time and duration is used to calculate the end time.
Public Property | ServiceClass | Element from the 'Installed Prod Sched Class' application list. If not set the default list value is used.
Public Property | ServiceType | Element from the 'Employee Sched Type' application list. If not set the default list value is used.
Public Property | SitePartObjid | The Objid of the Site Part if a part is being serviced.
Public Property | StartDate | The DateTime the Service Interuption starts. If not set, the current time is used.
Public Property | UserName | The user who is adding the Service Interuption. If not set, the session user is used.

Reference

AddServiceInterruptionSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
AddServiceInterruption(AddServiceInterruptionSetup) Method


CreateAppointmentResult Class Properties | fcSDK Documentation

CreateAppointmentResult Class Properties

For a list of all members of this type, see CreateAppointmentResult members.

Public Properties

 | Name | Description
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ScheduleObjid | The Objid of the Schedule.

Reference

CreateAppointmentResult Class
FChoice.Toolkits.Clarify.FieldOps Namespace


CreateAppointmentResult Constructor | fcSDK Documentation

CreateAppointmentResult Constructor

Overload List

Overload | Description
CreateAppointmentResult Constructor |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateAppointmentResult Class
CreateAppointmentResult Members


CreateAppointmentSetup Class Properties | fcSDK Documentation

CreateAppointmentSetup Class Properties

For a list of all members of this type, see CreateAppointmentSetup members.

Public Properties

 | Name | Description
Public Property | AppointmentClass | Element from the 'Employee Sched Class' application list. If not set the default list value is used.
Public Property | AppointmentType | Element from the 'Employee Sched Type' application list. If not set the default list value is used.
Public Property | CaseIDNum | The identifier of the Case with which this Appointment is associated
Public Property | CellText | The short description of the Appointment.
Public Property | CreateDate | The DateTime the Appointment was created. If not set, the current time is used.
Public Property | Description | The description of the Appointment.
Public Property | Duration | The length (in seconds) of the appointment. If not specified, it is calculated from the start and end times.
Public Property | EmployeeFirstName | The first name of the Employee that the Appointment is for.
Public Property | EmployeeLastName | The last name of the Employee that the Appointment is for.
Public Property | EndDate | The DateTime the Appointment ends. If not set, the start time and duration is used to calculate the end time.
Public Property | SitePartObjid | The Objid of the Site Part if the appointment is for a part.
Public Property | StartDate | The DateTime the Appointment starts. If not set, the current time is used.
Public Property | UserName | The user who created the Appointment. If not set, the Toolkit session user is used.

Reference

CreateAppointmentSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
CreateAppointment(CreateAppointmentSetup) Method


CreateExpenseLogResult Class Properties | fcSDK Documentation

CreateExpenseLogResult Class Properties

For a list of all members of this type, see CreateExpenseLogResult members.

Public Properties

 | Name | Description
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | OnsiteLogObjid | The Objid of the OnsiteLog.
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)

Reference

CreateExpenseLogResult Class
FChoice.Toolkits.Clarify.FieldOps Namespace


CreateExpenseLogResult Constructor | fcSDK Documentation

CreateExpenseLogResult Constructor

Overload List

Overload | Description
CreateExpenseLogResult Constructor |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateExpenseLogResult Class
CreateExpenseLogResult Members


CreateExpenseLogSetup Class Properties | fcSDK Documentation

CreateExpenseLogSetup Class Properties

For a list of all members of this type, see CreateExpenseLogSetup members.

Public Properties

 | Name | Description
Public Property | BillTo | Element from the 'Bill To Time' application list. If not set the default list value is used.
Public Property | CaseIDNum | The identifier of the Case with which this Expense Log is associated
Public Property | CreateDate | The DateTime the Expense Log was created. If not set, the current time is used.
Public Property | ExpenseType | Element from the 'Expense Type' application list. If not set the default list value is used.
Public Property | IsBillable | Specifies if the Expense Log is billable.
Public Property | Notes | Notes about the Expense Log.
Public Property | OnsiteLogObjid | The Objid of the Onsite Log that this Expense Log is related to.
Public Property | PerformedByUserName | The user who is performed the action specified by the Expense Log. If not set, the session user is used.
Public Property | Quantity | The number of units that are being applied to the Onsite Log.
Public Property | Rate | The billing rate per unit. If no rate is specified, the labor rate of the performing employee is used.
Public Property | Resolution | Element from the 'Resolution' application list. If not set the default list value is used.
Public Property | UserName | The user who created the Expense Log. If not set, the Toolkit session user is used.

Reference

CreateExpenseLogSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
CreateExpenseLog(CreateExpenseLogSetup) Method


CreateOnsiteLogSetup Class Properties | fcSDK Documentation

CreateOnsiteLogSetup Class Properties

For a list of all members of this type, see CreateOnsiteLogSetup members.

Public Properties

 | Name | Description
Public Property | CreateDate | The DateTime the Onsite Log was created. If not set, the current time is used.
Public Property | LastModifiedDate | The DateTime the Onsite Log was modified. If not set, the current time is used.
Public Property | Notes | Notes about the Onsite Log.
Public Property | ObjectIDNum | Specifies the Id Number of this Onsite Log's Case or Subcase.
Public Property | ObjectType | Specifies whether this Onsite Log is tied to a Case or Subcase.
Public Property | PerformedByUserName | The user who is performed the action specified by the Onsite Log. If not set, the session user is used.
Public Property | Resolution | Element from the 'Resolution' application list. If not set the default list value is used.
Public Property | UserName | The user who created the Onsite Log. If not set, the Toolkit session user is used.

Reference

CreateOnsiteLogSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
CreateOnsiteLog(CreateOnsiteLogSetup) Method


CreateTimeLogResult Class Properties | fcSDK Documentation

CreateTimeLogResult Class Properties

For a list of all members of this type, see CreateTimeLogResult members.

Public Properties

 | Name | Description
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | OnsiteLogObjid | The Objid of the OnsiteLog.
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)

Reference

CreateTimeLogResult Class
FChoice.Toolkits.Clarify.FieldOps Namespace


CreateTimeLogResult Constructor | fcSDK Documentation

CreateTimeLogResult Constructor

Overload List

Overload | Description
CreateTimeLogResult Constructor |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateTimeLogResult Class
CreateTimeLogResult Members


CreateTimeLogSetup Class Properties | fcSDK Documentation

CreateTimeLogSetup Class Properties

For a list of all members of this type, see CreateTimeLogSetup members.

Public Properties

 | Name | Description
Public Property | BillTo | Element from the 'Bill To Time' application list. If not set the default list value is used.
Public Property | CaseIDNum | The identifier of the Case with which this Time Log is associated
Public Property | CreateDate | The DateTime the Time Log was created. If not set, the current time is used.
Public Property | Duration | The length (in seconds) of the Time Log. If not specified, it is calculated from the start and end times.
Public Property | IsBillable | Specifies if the Time Log is billable.
Public Property | Notes | Notes about the Time Log.
Public Property | OnsiteLogObjid | The Objid of the Onsite Log that this Time Log is related to.
Public Property | PerformedByUserName | The user who is performed the action specified by the Time Log. If not set, the session user is used.
Public Property | Resolution | Element from the 'Resolution' application list. If not set the default list value is used.
Public Property | StartDate | The DateTime the Time Log starts. If not set, the current time is used.
Public Property | TimeType | Element from the 'Time Type' application list. If not set the default list value is used.
Public Property | UserName | The user who created the Time Log. If not set, the Toolkit session user is used.
Public Property | WorkCenter | Element from the 'Work Center' application list. If not set the default list value is used.

Reference

CreateTimeLogSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
CreateTimeLog(CreateTimeLogSetup) Method


DeinstallSitePartSetup Class Properties | fcSDK Documentation

DeinstallSitePartSetup Class Properties

For a list of all members of this type, see DeinstallSitePartSetup members.

Public Properties

 | Name | Description
Public Property | DeinstallDate | The DateTime the Site Part was deinstalled. If not set, the current time is used.
Public Property | SitePartObjid | The Objid of the Site Part being deinstalled.
Public Property | UseRemove | Specifies if activity entry records should be set to "Remove" (true) or "De-Installed" (false).
Public Property | UserName | The user who deinstalled the Site Part. If not set, the Toolkit session user is used.

Reference

DeinstallSitePartSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
DeinstallSitePart(DeinstallSitePartSetup) Method


DeleteAppointmentSetup Class Properties | fcSDK Documentation

DeleteAppointmentSetup Class Properties

For a list of all members of this type, see DeleteAppointmentSetup members.

Public Properties

 | Name | Description
Public Property | AppointmentObjid | The Objid of the Appointment being deleted.
Public Property | CreateDate | The DateTime the Appointment was deleted. If not set, the current time is used.
Public Property | UserName | The user who deleted the Appointment. If not set, the Toolkit session user is used.

Reference

DeleteAppointmentSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
DeleteAppointment(DeleteAppointmentSetup) Method


DeleteExpenseLogSetup Class Properties | fcSDK Documentation

DeleteExpenseLogSetup Class Properties

For a list of all members of this type, see DeleteExpenseLogSetup members.

Public Properties

 | Name | Description
Public Property | ExpenseLogObjid | The Objid of the Expense Log being deleted.
Public Property | LastModifiedDate | The DateTime the Expense Log was deleted. If not set, the current time is used.
Public Property | UserName | The user who deleted the Expense Log. If not set, the Toolkit session user is used.

Reference

DeleteExpenseLogSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
DeleteExpenseLog(DeleteExpenseLogSetup) Method


DeleteOnsiteLogSetup Class Properties | fcSDK Documentation

DeleteOnsiteLogSetup Class Properties

For a list of all members of this type, see DeleteOnsiteLogSetup members.

Public Properties

 | Name | Description
Public Property | NoteDate | The DateTime the Onsite Log was deleted. If not set, the current time is used.
Public Property | OnsiteLogObjid | The Objid of the Onsite Log being deleted.
Public Property | UserName | The user who deleted the Onsite Log. If not set, the Toolkit session user is used.

Reference

DeleteOnsiteLogSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
DeleteOnsiteLog(DeleteOnsiteLogSetup) Method


DeleteServiceInterruptionSetup Class Properties | fcSDK Documentation

DeleteServiceInterruptionSetup Class Properties

For a list of all members of this type, see DeleteServiceInterruptionSetup members.

Public Properties

 | Name | Description
Public Property | AppointmentObjid | The Objid of the Service Interuption being deleted.
Public Property | CreateDate | The DateTime the Service Interuption was deleted. If not set, the current time is used.
Public Property | UserName | The user who is deleting the Service Interuption. If not set, the session user is used.

Reference

DeleteServiceInterruptionSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
DeleteServiceInterruption(DeleteServiceInterruptionSetup) Method


DeleteTimeLogSetup Class Properties | fcSDK Documentation

DeleteTimeLogSetup Class Properties

For a list of all members of this type, see DeleteTimeLogSetup members.

Public Properties

 | Name | Description
Public Property | LastModifiedDate | The DateTime the Time Log was deleted. If not set, the current time is used.
Public Property | TimeLogObjid | The Objid of the Time Log being deleted.
Public Property | UserName | The user who deleted the Time Log. If not set, the Toolkit session user is used.

Reference

DeleteTimeLogSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
DeleteTimeLog(DeleteTimeLogSetup) Method


DispatchFieldEngineerSetup Class Properties | fcSDK Documentation

DispatchFieldEngineerSetup Class Properties

For a list of all members of this type, see DispatchFieldEngineerSetup members.

Public Properties

 | Name | Description
Public Property | Address1 | The address used to overide the default site address.
Public Property | Address2 | The secondary address used to overide the default site secondary address.
Public Property | AlternatePhone | The alternate phone used to overide the contact alternate phone.
Public Property | AppointmentConfirmed | Indicates if the Appointment confirmed.
Public Property | AppointmentDate | The DateTime of the Appointment. If not set, the current time is used.
Public Property | CaseIDNum | The identifier of the Case with which this Dispatch FE is associated
Public Property | CellText | The short description of the Appointment.
Public Property | City | The city used to overide the default site alternate city.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | Description | The description of the Dispatch FE. If left blank, it is set to the title of the Case or Subcase.
Public Property | DispatchDate | DateTime the FieldEngineer was dispatched. If not set, the current time is used.
Public Property | Duration | The length (in seconds) of the FE appointment. If not specified, it is calculated from the start and end times.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | MainPhone | The main phone used to overide the contact main phone.
Public Property | Notes | The reason the FieldEngineer was rejected from the queue into which it was dispatched.
Public Property | PaymentMethod | Element from the 'Payment Method' application list. If not set the default list value is used.
Public Property | Proxy | Specifies the proxy to use for the activity entry record.
Public Property | ReferenceNumber | The reference number for the work order.
Public Property | RequestedETADate | The DateTime of the Field Engineer arrival at the site. If not set, the current time is used.
Public Property | SiteIDNum | The Site Id of the site to respond to if the case/subcase site is different.
Public Property | State | The state used to overide the default site alternate state.
Public Property | UserName | The user who has dispatched the FieldEngineer. If not set, the Toolkit session user is used.
Public Property | WorkOrder | The Id Number of the work order. If blank, "." is used.
Public Property | ZipCode | The zipcode used to overide the default site alternate zipcode.

Reference

DispatchFieldEngineerSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
DispatchFieldEngineer(DispatchFieldEngineerSetup) Method


FieldOpsToolkit Class Methods | fcSDK Documentation

FieldOpsToolkit Class Methods

For a list of all members of this type, see FieldOpsToolkit members.

Public Methods

 | Name | Description
Public Method | AddServiceInterruption | Overloaded. Adds a service interruption (and creates an appointment record). This overload takes a setup object and a database transaction.
Public Method | CreateAppointment | Overloaded. Used to create a new appointment. This overload takes a setup object and a database transaction.
Public Method | CreateExpenseLog | Overloaded. Used to create a new expense log that is related to an onsite log. This overload takes a setup object and a database transaction.
Public Method | CreateOnsiteLog | Overloaded. Used to create an onsite log that is related to a case or subcase. This overload takes a setup object and a database transaction.
Public Method | CreateTimeLog | Overloaded. Used to create a time log that is related to an onsite log. This overload takes a setup object and a database transaction.
Public Method | DeinstallSitePart | Overloaded. Used to de-install a site part (and the sub-parts installed underneath it) from a site. This overload takes a setup object and a database transaction.
Public Method | DeleteAppointment | Overloaded. Used to delete an existing appointment. This overload takes a setup object and a database transaction.
Public Method | DeleteExpenseLog | Overloaded. Used to delete an existing expense log. This overload takes a setup object and a database transaction.
Public Method | DeleteOnsiteLog | Overloaded. Used to delete an existing onsite log. This overload takes a setup object and a database transaction.
Public Method | DeleteServiceInterruption | Overloaded. Used to delete an existing service interuption (appointment). This overload takes a setup object and a database transaction.
Public Method | DeleteTimeLog | Overloaded. This API deletes an existing time log. This overload takes a setup object and a database transaction.
Public Method | DispatchFieldEngineer | Overloaded. Dispatch the FieldEngineer to the specified queue. This overload takes a set of required parameters for the API.
Public Method | InstallSitePart | Overloaded. Used to install a site part. This overload takes a setup object and a database transaction.
Public Method | LogPartsUsedConsume | Overloaded. Used to consume an existing site part or an inventory part. This overload takes a setup object and a database transaction.
Public Method | LogPartsUsedExchange | Overloaded. Used to replace an existing site part with a new site part. This overload takes a setup object and a database transaction.
Public Method | LogPartsUsedInstall | Overloaded. Used to install a new site part. This overload takes a setup object and a database transaction.
Public Method | LogPartsUsedRemove | Overloaded. Used to remove an existing site part. This overload takes a setup object and a database transaction.
Public Method | LogPartsUsedUpgrade | Overloaded. Used to upgrade an existing site part with a new site part. This overload takes a setup object and a database transaction.
Public Method | MoveSitePartToBin | Overloaded. Move the SitePartToBin from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
Public Method | MoveSitePartToPart | Overloaded. Move the SitePartToPart from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
Public Method | MoveSitePartToSite | Overloaded. Move the SitePartToSite from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
Public Method | PartTransfer | Overloaded. Initializes a new instance of the PartTransferSetup class. This overload takes a set of required parameters for the API.
Public Method | ReinstallSitePart | Overloaded. Used to re-install a site part (and the sub-parts installed underneath it) that have been deinstalled from a site. This overload takes a setup object and a database transaction.
Public Method | UpdateAppointment | Overloaded. Used to modify an existing appointment. This overload takes a setup object and a database transaction.
Public Method | UpdateExpenseLog | Overloaded. Used to modify an existing expense log. This overload takes a setup object and a database transaction.
Public Method | UpdateServiceInterruption | Overloaded. Used to modify an existing service interruption (appointment). This overload takes a setup object and a database transaction.
Public Method | UpdateSitePart | Overloaded. Used to modify an existing site part. This overload takes a setup object and a database transaction.
Public Method | UpdateTimeLog | Overloaded. Used to modify an existing time log. This overload takes a setup object and a database transaction.

Reference

FieldOpsToolkit Class
FChoice.Toolkits.Clarify.FieldOps Namespace


FieldOpsToolkit Class Properties | fcSDK Documentation

FieldOpsToolkit Class Properties

For a list of all members of this type, see FieldOpsToolkit members.

Public Properties

 | Name | Description
Public Property | ImpersonatorUsername | (Inherited from FChoice.Toolkits.Clarify.FieldOps.FieldOpsToolkitBase)

Reference

FieldOpsToolkit Class
FChoice.Toolkits.Clarify.FieldOps Namespace


FieldOpsToolkitBase Class Properties | fcSDK Documentation

FieldOpsToolkitBase Class Properties

For a list of all members of this type, see FieldOpsToolkitBase members.

Public Properties

 | Name | Description
Public Property | ImpersonatorUsername |

Reference

FieldOpsToolkitBase Class
FChoice.Toolkits.Clarify.FieldOps Namespace


InstallSitePartSetup Class Properties | fcSDK Documentation

InstallSitePartSetup Class Properties

For a list of all members of this type, see InstallSitePartSetup members.

Public Properties

 | Name | Description
Public Property | AddActivityLog | Specifies if activity entry records should be created.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | Comments | Comments about the Site Part installation.
Public Property | InstallDate | The DateTime the Site Part was installed. If not set, the current time is used.
Public Property | InstanceName | Instance Name of the Site Part
Public Property | InvoiceNumber | The Invoice Number for the Site Part.
Public Property | ParentBinObjid | The Objid of the Parent Site Bin where the Site Part is being installed.
Public Property | ParentSitePartObjid | The Objid of the Parent Site Part where the Site Part is being installed.
Public Property | PartDomain | Part Domain of the Site Part
Public Property | PartNumber | Part Number of the Site Part
Public Property | PartRevision | Part Revision of the Site Part
Public Property | PartStatus | Element from the 'Part Status' application list. If not set the default list value is used.
Public Property | Quantity | The Quantity of the Site Part being installed.
Public Property | SerialNumber | Serial Number of the Site Part
Public Property | ShipDate | The DateTime the Site Part was shipped. If not set, the current time is used.
Public Property | SiteIDNum | The Site Id of the Parent Site where the Site Part is being installed.
Public Property | UserName | The user who installed the Site Part. If not set, the Toolkit session user is used.

Reference

InstallSitePartSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
InstallSitePart(InstallSitePartSetup) Method


LogPartsUsedConsumeSetup Class Properties | fcSDK Documentation

LogPartsUsedConsumeSetup Class Properties

For a list of all members of this type, see LogPartsUsedConsumeSetup members.

Public Properties

 | Name | Description
Public Property | AllowMove | Indicates if a serialized part is to be moved if it already exists as an active Site Part
Public Property | CaseIDNum | The identifier of the Case with which this Part Usage is associated
Public Property | EngineerUserName | The user who has performed the Part usage. If not set, the Toolkit session user is used.
Public Property | FromBin | Inventory bin from which the part is being transferred
Public Property | FromContainer | Inventory container from which the part is being transferred
Public Property | FromGood | Specifies whether the part is being transferred from good stock (true) or bad stock (false)
Public Property | FromLocation | Inventory location from which the part is being transferred
Public Property | InstallAtSite | Indicates if the Part should be installed at the top-level of the Site
Public Property | InstallPartDomain | The Part Domain of the part being installed
Public Property | InstallPartNumber | The Part Number of the part being installed
Public Property | InstallPartRevision | The Part Revision of the part being installed
Public Property | InstallPrice | The Price of the part being installed
Public Property | InstallQuantity | The Quantity of the part being installed
Public Property | InstallSerialNumber | The Serial Number of the part being installed
Public Property | LogDate | The DateTime the Part Usage occurred. If not set, the current time is used.
Public Property | ParentSitePartObjid | The Objid of the Parent Site Part where the part is being installed.
Public Property | PartRequestDetailIDNum | The Id Number of the related Part Request Detail (if any)
Public Property | UserName | The user who has logged the Part usage. If not set, the Toolkit session user is used.

Reference

LogPartsUsedConsumeSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
LogPartsUsedConsume(LogPartsUsedConsumeSetup) Method


LogPartsUsedExchangeSetup Class Properties | fcSDK Documentation

LogPartsUsedExchangeSetup Class Properties

For a list of all members of this type, see LogPartsUsedExchangeSetup members.

Public Properties

 | Name | Description
Public Property | AllowMove | Indicates if a serialized part is to be moved if it already exists as an active Site Part
Public Property | CaseIDNum | The identifier of the Case with which this Part Usage is associated
Public Property | EngineerUserName | The user who has performed the Part usage. If not set, the Toolkit session user is used.
Public Property | FailureCode | Element from the 'Failure Code' application list. If not set the default list value is used.
Public Property | FromBin | Inventory bin from which the part is being transferred
Public Property | FromContainer | Inventory container from which the part is being transferred
Public Property | FromGood | Specifies whether the part is being transferred from good stock (true) or bad stock (false)
Public Property | FromLocation | Inventory location from which the part is being transferred
Public Property | InstallAtSite | Indicates if the Part should be installed at the top-level of the Site
Public Property | InstallPartDomain | The Part Domain of the part being installed
Public Property | InstallPartNumber | The Part Number of the part being installed
Public Property | InstallPartRevision | The Part Revision of the part being installed
Public Property | InstallPrice | The Price of the part being installed
Public Property | InstallQuantity | The Quantity of the part being installed
Public Property | InstallSerialNumber | The Serial Number of the part being installed
Public Property | LogDate | The DateTime the Part Usage occurred. If not set, the current time is used.
Public Property | ParentSitePartObjid | The Objid of the Parent Site Part where the part is being installed.
Public Property | PartRequestDetailIDNum | The Id Number of the related Part Request Detail (if any)
Public Property | RemoveSitePartObjid | The Objid of the Site Part being removed.
Public Property | ToBin | Inventory bin into which the part is being transferred
Public Property | ToContainer | Inventory container into which the part is being transferred
Public Property | ToGood | Specifies whether the part is being transferred resulting in good stock (true) or bad stock (false)
Public Property | ToLocation | Inventory location into which the part is being transferred
Public Property | UserName | The user who has logged the Part usage. If not set, the Toolkit session user is used.

Reference

LogPartsUsedExchangeSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
LogPartsUsedExchange(LogPartsUsedExchangeSetup) Method


LogPartsUsedInstallSetup Class Properties | fcSDK Documentation

LogPartsUsedInstallSetup Class Properties

For a list of all members of this type, see LogPartsUsedInstallSetup members.

Public Properties

 | Name | Description
Public Property | AllowMove | Indicates if a serialized part is to be moved if it already exists as an active Site Part
Public Property | CaseIDNum | The identifier of the Case with which this Part Usage is associated
Public Property | EngineerUserName | The user who has performed the Part usage. If not set, the Toolkit session user is used.
Public Property | FromBin | Inventory bin from which the part is being transferred
Public Property | FromContainer | Inventory container from which the part is being transferred
Public Property | FromGood | Specifies whether the part is being transferred from good stock (true) or bad stock (false)
Public Property | FromLocation | Inventory location from which the part is being transferred
Public Property | InstallAtSite | Indicates if the Part should be installed at the top-level of the Site
Public Property | InstallPartDomain | The Part Domain of the part being installed
Public Property | InstallPartNumber | The Part Number of the part being installed
Public Property | InstallPartRevision | The Part Revision of the part being installed
Public Property | InstallPrice | The Price of the part being installed
Public Property | InstallQuantity | The Quantity of the part being installed
Public Property | InstallSerialNumber | The Serial Number of the part being installed
Public Property | LogDate | The DateTime the Part Usage occurred. If not set, the current time is used.
Public Property | ParentSitePartObjid | The Objid of the Parent Site Part where the part is being installed.
Public Property | PartRequestDetailIDNum | The Id Number of the related Part Request Detail (if any)
Public Property | UserName | The user who has logged the Part usage. If not set, the Toolkit session user is used.

Reference

LogPartsUsedInstallSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
LogPartsUsedInstall(LogPartsUsedInstallSetup) Method


LogPartsUsedRemoveSetup Class Properties | fcSDK Documentation

LogPartsUsedRemoveSetup Class Properties

For a list of all members of this type, see LogPartsUsedRemoveSetup members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AllowMove | Indicates if a serialized part is to be moved if it already exists as an active Site Part | | Public Property | CaseIDNum | The identifier of the Case with which this Part Usage is associated | | Public Property | EngineerUserName | The user who has performed the Part usage. If not set, the Toolkit session user is used. | | Public Property | FailureCode | Element from the 'Failure Code' application list. If not set the default list value is used. | | Public Property | InstallAtSite | Indicates if the Part should be installed at the top-level of the Site

| | Public Property | LogDate | The DateTime the Part Usage occurred. If not set, the current time is used. | | Public Property | ParentSitePartObjid | The Objid of the Parent Site Part where the part is being installed. | | Public Property | PartRequestDetailIDNum | The Id Number of the related Part Request Detail (if any) | | Public Property | RemoveQuantity | The quantity of parts to be removed. If not set, then the entire quantity will be removed. | | Public Property | RemoveSitePartObjid | The Objid of the Site Part being removed. | | Public Property | ToBin | Inventory bin into which the part is being transferred | | Public Property | ToContainer | Inventory container into which the part is being transferred | | Public Property | ToGood | Specifies whether the part is being transferred resulting in good stock (true) or bad stock (false) | | Public Property | ToLocation | Inventory location into which the part is being transferred | | Public Property | UserName | The user who has logged the Part usage. If not set, the Toolkit session user is used. |

Reference

LogPartsUsedRemoveSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
LogPartsUsedRemove(LogPartsUsedRemoveSetup) Method


LogPartsUsedUpgradeSetup Class Properties | fcSDK Documentation

LogPartsUsedUpgradeSetup Class Properties

For a list of all members of this type, see LogPartsUsedUpgradeSetup members.

Public Properties

 | Name | Description
Public Property | AllowMove | Indicates if a serialized part is to be moved if it already exists as an active Site Part
Public Property | CaseIDNum | The identifier of the Case with which this Part Usage is associated
Public Property | EngineerUserName | The user who has performed the Part usage. If not set, the Toolkit session user is used.
Public Property | FailureCode | Element from the 'Failure Code' application list. If not set the default list value is used.
Public Property | FromBin | Inventory bin from which the part is being transferred
Public Property | FromContainer | Inventory container from which the part is being transferred
Public Property | FromGood | Specifies whether the part is being transferred from good stock (true) or bad stock (false)
Public Property | FromLocation | Inventory location from which the part is being transferred
Public Property | InstallAtSite | Indicates if the Part should be installed at the top-level of the Site
Public Property | InstallPartDomain | The Part Domain of the part being installed
Public Property | InstallPartNumber | The Part Number of the part being installed
Public Property | InstallPartRevision | The Part Revision of the part being installed
Public Property | InstallPrice | The Price of the part being installed
Public Property | InstallQuantity | The Quantity of the part being installed
Public Property | InstallSerialNumber | The Serial Number of the part being installed
Public Property | LogDate | The DateTime the Part Usage occurred. If not set, the current time is used.
Public Property | ParentSitePartObjid | The Objid of the Parent Site Part where the part is being installed.
Public Property | PartRequestDetailIDNum | The Id Number of the related Part Request Detail (if any)
Public Property | RemoveSitePartObjid | The Objid of the Site Part being removed.
Public Property | ToBin | Inventory bin into which the part is being transferred
Public Property | ToContainer | Inventory container into which the part is being transferred
Public Property | ToGood | Specifies whether the part is being transferred resulting in good stock (true) or bad stock (false)
Public Property | ToLocation | Inventory location into which the part is being transferred
Public Property | UserName | The user who has logged the Part usage. If not set, the Toolkit session user is used.

Reference

LogPartsUsedUpgradeSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
LogPartsUsedUpgrade(LogPartsUsedUpgradeSetup) Method


MoveSitePartToBinSetup Class Properties | fcSDK Documentation

MoveSitePartToBinSetup Class Properties

For a list of all members of this type, see MoveSitePartToBinSetup members.

Public Properties

 | Name | Description
Public Property | AddActivityLog | Specifies if activity entry records should be created.
Public Property | InstallAndMove | Specifies if activity entry records should be set to "Install (Move)" (true) or "Move" (false).
Public Property | MoveDate | DateTime the SitePartToBin was moved. If not set, the current time is used.
Public Property | ParentBinObjid | The Objid of the Parent Site Bin where the Site Part is being moved.
Public Property | SitePartObjid | The Objid of the Site Part being moved.
Public Property | UserName | The user who has moved the SitePartToBin. If not set, the Toolkit session user is used.

Reference

MoveSitePartToBinSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
MoveSitePartToBin(MoveSitePartToBinSetup) Method


MoveSitePartToPartSetup Class Properties | fcSDK Documentation

MoveSitePartToPartSetup Class Properties

For a list of all members of this type, see MoveSitePartToPartSetup members.

Public Properties

 | Name | Description
Public Property | AddActivityLog | Specifies if activity entry records should be created.
Public Property | InstallAndMove | Specifies if activity entry records should be set to "Install (Move)" (true) or "Move" (false).
Public Property | MoveDate | DateTime the SitePartToPart was moved. If not set, the current time is used.
Public Property | ParentSitePartObjid | The Objid of the Parent Site where the Site Part is being moved.
Public Property | SitePartObjid | The Objid of the Site Part being moved.
Public Property | UserName | The user who has moved the SitePartToPart. If not set, the Toolkit session user is used.

Reference

MoveSitePartToPartSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
MoveSitePartToPart(MoveSitePartToPartSetup) Method


MoveSitePartToSiteSetup Class Properties | fcSDK Documentation

MoveSitePartToSiteSetup Class Properties

For a list of all members of this type, see MoveSitePartToSiteSetup members.

Public Properties

 | Name | Description
Public Property | AddActivityLog | Specifies if activity entry records should be created.
Public Property | InstallAndMove | Specifies if activity entry records should be set to "Install (Move)" (true) or "Move" (false).
Public Property | MoveDate | DateTime the SitePartToSite was moved. If not set, the current time is used.
Public Property | SiteIDNum | The Site Id of the Site where the Site Part is being moved.
Public Property | SitePartObjid | The Objid of the Site Part being moved.
Public Property | UserName | The user who has moved the SitePartToSite. If not set, the Toolkit session user is used.

Reference

MoveSitePartToSiteSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
MoveSitePartToSite(MoveSitePartToSiteSetup) Method


PartTransferResult Class Properties | fcSDK Documentation

PartTransferResult Class Properties

For a list of all members of this type, see PartTransferResult members.

Public Properties

 | Name | Description
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | StandardCost | Part Transfer Standard Cost.
Public Property | TransactionIDNum | Part Transfer Transaction Identifier.

Reference

PartTransferResult Class
FChoice.Toolkits.Clarify.FieldOps Namespace


PartTransferResult Constructor | fcSDK Documentation

PartTransferResult Constructor

Overload List

Overload | Description
PartTransferResult Constructor |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PartTransferResult Class
PartTransferResult Members


PartTransferSetup Class Properties | fcSDK Documentation

PartTransferSetup Class Properties

For a list of all members of this type, see PartTransferSetup members.

Public Properties

 | Name | Description
Public Property | FromGood | Specifies whether the part is being transferred from good stock (true) or bad stock (false)
Public Property | FromLocation | Inventory location (or expense GL) and bin from which to transfer the part
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Notes | Notes about the Part Transfer
Public Property | PartDomain | Part domain for the Part Request
Public Property | PartNumber | Part number for the Part Request
Public Property | PartRevision | Part revision for the Part Request
Public Property | Quantity | The number of parts being transferred
Public Property | ReferenceIDNum | Optional reference number for this part transfer
Public Property | SerialNumber | The serial number of the part being transferred
Public Property | ToGood | Specifies whether the part is being transferred resulting in good stock (true) or bad stock (false)
Public Property | ToLocation | Inventory location and bin (or GL account) into which the part is being transferred.
Public Property | TransferDate | The DateTime the Part Transfer occurred. If not set, the current time is used.
Public Property | UserName | The user who is transferring the Part. If not set, the session user is used.

Reference

PartTransferSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
PartTransfer(PartTransferSetup) Method


ReinstallSitePartSetup Class Properties | fcSDK Documentation

ReinstallSitePartSetup Class Properties

For a list of all members of this type, see ReinstallSitePartSetup members.

Public Properties

 | Name | Description
Public Property | AddActivityLog | Specifies if activity entry records should be created.
Public Property | ParentBinObjid | The Objid of the Parent Site Bin where the Site Part is being moved.
Public Property | ParentSitePartObjid | The Objid of the Parent Site Part where the Site Part is being moved.
Public Property | ReinstallDate | The DateTime the Site Part was reinstalled. If not set, the current time is used.
Public Property | SiteIDNum | The Site Id of the Site where the Site Part is being moved.
Public Property | SitePartObjid | The Objid of the Site Part being reinstalled.
Public Property | UseInstall | Specifies if activity entry records should be set to "Install" (true) or "Re-Installed" (false).
Public Property | UserName | The user who is reinstalling the Site Part. If not set, the session user is used.

Reference

ReinstallSitePartSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
ReinstallSitePart(ReinstallSitePartSetup) Method


StageInventoryToolkit Class Fields | fcSDK Documentation

StageInventoryToolkit Class Fields

For a list of all members of this type, see StageInventoryToolkit members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | StagedFrom |
static (Shared in Visual Basic) | StagedTo |

Reference

StageInventoryToolkit Class
FChoice.Toolkits.Clarify.FieldOps Namespace


StageInventoryToolkit Class Methods | fcSDK Documentation

StageInventoryToolkit Class Methods

For a list of all members of this type, see StageInventoryToolkit members.

Public Methods

 | Name | Description
Public Method | StageInstallForInventoryBin |

Reference

StageInventoryToolkit Class
FChoice.Toolkits.Clarify.FieldOps Namespace


UpdateAppointmentSetup Class Properties | fcSDK Documentation

UpdateAppointmentSetup Class Properties

For a list of all members of this type, see UpdateAppointmentSetup members.

Public Properties

 | Name | Description
Public Property | AppointmentClass | Element from the 'Employee Sched Class' application list. If not set the default list value is used.
Public Property | AppointmentObjid | The Objid of the Appointment being modified.
Public Property | AppointmentType | Element from the 'Employee Sched Type' application list. If not set the default list value is used.
Public Property | CellText | The short description of the Appointment.
Public Property | CreateDate | The DateTime the Appointment was modified. If not set, the current time is used.
Public Property | Description | The description of the Appointment.
Public Property | Duration | The length (in seconds) of the Appointment. If not specified, it is calculated from the start and end times.
Public Property | EndDate | The DateTime the Appointment ends. If not set, the start time and duration is used to calculate the end time.
Public Property | StartDate | The DateTime the Appointment starts. If not set, the current time is used.
Public Property | UserName | The user who is updating the Appointment. If not set, the session user is used.

Reference

UpdateAppointmentSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
UpdateAppointment(UpdateAppointmentSetup) Method


UpdateExpenseLogSetup Class Properties | fcSDK Documentation

UpdateExpenseLogSetup Class Properties

For a list of all members of this type, see UpdateExpenseLogSetup members.

Public Properties

 | Name | Description
Public Property | BillTo | Element from the 'Bill To Time' application list. If not set the default list value is used.
Public Property | CreateDate | The DateTime the Expense Log was modified. If not set, the current time is used.
Public Property | ExpenseLogObjid | The Objid of the Expense Log being modified.
Public Property | ExpenseType | Element from the 'Expense Type' application list. If not set the default list value is used.
Public Property | IsBillable | Specifies if the Expense Log is billable.
Public Property | Notes | Notes that will update the notes field on the onsite log
Public Property | PerformedByUserName | The user who is performed the action specified by the Expense Log. If not set, the session user is used.
Public Property | Quantity | The number of units that are being applied to the Onsite Log.
Public Property | Rate | The billing rate per unit. If no rate is specified, the labor rate of the performing employee is used.
Public Property | Resolution | Element from the 'Resolution' application list. If not set the default list value is used.
Public Property | UserName | The user who is updating the Expense Log. If not set, the session user is used.

Reference

UpdateExpenseLogSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
UpdateExpenseLog(UpdateExpenseLogSetup) Method


UpdateServiceInterruptionSetup Class Properties | fcSDK Documentation

UpdateServiceInterruptionSetup Class Properties

For a list of all members of this type, see UpdateServiceInterruptionSetup members.

Public Properties

 | Name | Description
Public Property | AppointmentObjid | The Objid of the Appointment being modified.
Public Property | CreateDate | The DateTime the Service Interuption was modified. If not set, the current time is used.
Public Property | Description | The description of the Service Interuption.
Public Property | Duration | The length (in seconds) of the Service Interuption. If not specified, it is calculated from the start and end times.
Public Property | EndDate | The DateTime the Service Interuption ends. If not set, the start time and duration is used to calculate the end time.
Public Property | ServiceClass | Element from the 'Installed Prod Sched Class' application list. If not set the default list value is used.
Public Property | ServiceType | Element from the 'Employee Sched Type' application list. If not set the default list value is used.
Public Property | StartDate | The DateTime the Service Interuption starts. If not set, the current time is used.
Public Property | UserName | The user who is updating the Service Interuption. If not set, the session user is used.

Reference

UpdateServiceInterruptionSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
UpdateServiceInterruption(UpdateServiceInterruptionSetup) Method


UpdateSitePartSetup Class Properties | fcSDK Documentation

UpdateSitePartSetup Class Properties

For a list of all members of this type, see UpdateSitePartSetup members.

Public Properties

 | Name | Description
Public Property | AddActivityLog | Specifies if activity entry records should be created.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | Comments | Comments for the Site Part
Public Property | InstallDate | The DateTime the Site Part was installed. If not set, the current time is used.
Public Property | InstanceName | Instance Name of the Site Part
Public Property | InvoiceNumber | The Invoice Number for the Site Part
Public Property | PartRevision | Part Revision of the Site Part
Public Property | PartStatus | The Part Status for the Site Part
Public Property | Quantity | The Quantity of the Site Part
Public Property | SerialNumber | Serial Number of the Site Part
Public Property | ServiceEndDate | The DateTime the Service ends for the Site Part.
Public Property | ShipDate | The DateTime the shipping occurs for the Site Part.
Public Property | SitePartObjid | The Objid of the Site Part being modified.
Public Property | UserName | The user who is updating the Site Part. If not set, the session user is used.
Public Property | WarrantyDate | The DateTime the warranty begins for the Site Part.

Reference

UpdateSitePartSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
UpdateSitePart(UpdateSitePartSetup) Method


UpdateTimeLogSetup Class Properties | fcSDK Documentation

UpdateTimeLogSetup Class Properties

For a list of all members of this type, see UpdateTimeLogSetup members.

Public Properties

 | Name | Description
Public Property | BillTo | Element from the 'Bill To Time' application list. If not set the default list value is used.
Public Property | CreateDate | The DateTime the Time Log was modified. If not set, the current time is used.The DateTime the Time Log starts. If not set, the current time is used.
Public Property | Duration | The length (in seconds) of the Time Log. If not specified, it is calculated from the start and end times.
Public Property | IsBillable | Specifies if the Time Log is billable.
Public Property | Notes | Notes that will update the notes field on the onsite log
Public Property | PerformedByUserName | The user who is performed the action specified by the Time Log. If not set, the session user is used.
Public Property | Resolution | Element from the 'Resolution' application list. If not set the default list value is used.
Public Property | StartTime |
Public Property | TimeLogObjid | The Objid of the Time Log being modified.
Public Property | TimeType | Element from the 'Time Type' application list. If not set the default list value is used.
Public Property | UserName | The user who is updating the Time Log. If not set, the session user is used.
Public Property | WorkCenter | Element from the 'Work Center' application list. If not set the default list value is used.

Reference

UpdateTimeLogSetup Class
FChoice.Toolkits.Clarify.FieldOps Namespace
UpdateTimeLog(UpdateTimeLogSetup) Method


FChoice.Toolkits.Clarify.FieldOps Namespace #### Inheritance Hierarchy | fcSDK Documentation

FChoice.Toolkits.Clarify.FieldOps Namespace #### Inheritance Hierarchy

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.FieldOps.AddServiceInterruptionSetup
FChoice.Toolkits.Clarify.FieldOps.CreateAppointmentSetup
FChoice.Toolkits.Clarify.FieldOps.CreateExpenseLogSetup
FChoice.Toolkits.Clarify.FieldOps.CreateOnsiteLogSetup
FChoice.Toolkits.Clarify.FieldOps.CreateTimeLogSetup
FChoice.Toolkits.Clarify.FieldOps.DeinstallSitePartSetup
FChoice.Toolkits.Clarify.FieldOps.DeleteAppointmentSetup
FChoice.Toolkits.Clarify.FieldOps.DeleteExpenseLogSetup
FChoice.Toolkits.Clarify.FieldOps.DeleteOnsiteLogSetup
FChoice.Toolkits.Clarify.FieldOps.DeleteServiceInterruptionSetup
FChoice.Toolkits.Clarify.FieldOps.DeleteTimeLogSetup
FChoice.Toolkits.Clarify.FieldOps.DispatchFieldEngineerSetup
FChoice.Toolkits.Clarify.FieldOps.InstallSitePartSetup
FChoice.Toolkits.Clarify.FieldOps.LogPartsUsedConsumeSetup
FChoice.Toolkits.Clarify.FieldOps.LogPartsUsedExchangeSetup
FChoice.Toolkits.Clarify.FieldOps.LogPartsUsedInstallSetup
FChoice.Toolkits.Clarify.FieldOps.LogPartsUsedRemoveSetup
FChoice.Toolkits.Clarify.FieldOps.LogPartsUsedUpgradeSetup
FChoice.Toolkits.Clarify.FieldOps.MoveSitePartToBinSetup
FChoice.Toolkits.Clarify.FieldOps.MoveSitePartToPartSetup
FChoice.Toolkits.Clarify.FieldOps.MoveSitePartToSiteSetup
FChoice.Toolkits.Clarify.FieldOps.PartTransferSetup
FChoice.Toolkits.Clarify.FieldOps.ReinstallSitePartSetup
FChoice.Toolkits.Clarify.FieldOps.StageInventoryToolkit
FChoice.Toolkits.Clarify.FieldOps.UpdateAppointmentSetup
FChoice.Toolkits.Clarify.FieldOps.UpdateExpenseLogSetup
FChoice.Toolkits.Clarify.FieldOps.UpdateServiceInterruptionSetup
FChoice.Toolkits.Clarify.FieldOps.UpdateSitePartSetup
FChoice.Toolkits.Clarify.FieldOps.UpdateTimeLogSetup
FChoice.Toolkits.Clarify.ToolkitBase
FChoice.Toolkits.Clarify.FieldOps.FieldOpsToolkitBase
FChoice.Toolkits.Clarify.FieldOps.FieldOpsToolkit
FChoice.Toolkits.Clarify.ToolkitResult
FChoice.Toolkits.Clarify.FieldOps.AddServiceInterruptionResult
FChoice.Toolkits.Clarify.FieldOps.CreateAppointmentResult
FChoice.Toolkits.Clarify.FieldOps.CreateExpenseLogResult
FChoice.Toolkits.Clarify.FieldOps.CreateTimeLogResult
FChoice.Toolkits.Clarify.FieldOps.PartTransferResult

Reference

FChoice.Toolkits.Clarify Assembly


AcceptSolutionSetup Class Properties | fcSDK Documentation

AcceptSolutionSetup Class Properties

For a list of all members of this type, see AcceptSolutionSetup members.

Public Properties

 | Name | Description
Public Property | AcceptDate | DateTime the Solution was accepted. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | SolutionIDNum | Solution Identifier.
Public Property | UserName | The user who has accepted the Solution. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Solution. If not set, the UserName's default is used.

Reference

AcceptSolutionSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
AcceptSolution(AcceptSolutionSetup) Method


AddContactToContractSetup Class Properties | fcSDK Documentation

AddContactToContractSetup Class Properties

For a list of all members of this type, see AddContactToContractSetup members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | ContactFirstName | Contact's first name. | | Public Property | ContactLastName | Contact's last name. | | Public Property | ContactPhone | Contact's phone number. | | Public Property | ContractIDNum | Identifies to which Contract the Contact will be added.

| | Public Property | SiteIDNum | Identifies the Site where the added Contact is located. |

Reference

AddContactToContractSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
AddContactToContract(AddContactToContractSetup) Method


AddEmployeeToAccountSetup Class Properties | fcSDK Documentation

AddEmployeeToAccountSetup Class Properties

For a list of all members of this type, see AddEmployeeToAccountSetup members.

Public Properties

 | Name | Description
Public Property | AccountIDNum | Identifier of the Account the Employee is being added to .
Public Property | RoleName | Role for User in the Account .
Public Property | UserName | Username of the Account team member .

Reference

AddEmployeeToAccountSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
AddEmployeeToAccount(AddEmployeeToAccountSetup) Method


AddSitePartToContractSetup Class Properties | fcSDK Documentation

AddSitePartToContractSetup Class Properties

For a list of all members of this type, see AddSitePartToContractSetup members.

Public Properties

 | Name | Description
Public Property | ContractIDNum | Contract Identifier.
Public Property | SiteIDNum | Identifier of site where the site part is located.
Public Property | SitePartObjid | Objid of the SitePart to be added.

Reference

AddSitePartToContractSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
AddSitePartToContract(AddSitePartToContractSetup) Method


AddSiteToAccountSetup Class Properties | fcSDK Documentation

AddSiteToAccountSetup Class Properties

For a list of all members of this type, see AddSiteToAccountSetup members.

Public Properties

 | Name | Description
Public Property | AccountIDNum | The identifier of the Account to which the site will be added.
Public Property | RoleName | Name of the Site Role the Site will play for the Account.
Public Property | SiteIDNum | Site Identifier of site to be added.

Reference

AddSiteToAccountSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
AddSiteToAccount(AddSiteToAccountSetup) Method


AddSiteToContractSetup Class Properties | fcSDK Documentation

AddSiteToContractSetup Class Properties

For a list of all members of this type, see AddSiteToContractSetup members.

Public Properties

 | Name | Description
Public Property | ContractIDNum | Identifier of the Contract to which the Site will be added.
Public Property | SiteIDNum | Identifier of the Site to add to the Contract.

Reference

AddSiteToContractSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
AddSiteToContract(AddSiteToContractSetup) Method


AddUserToQueueSetup Class Properties | fcSDK Documentation

AddUserToQueueSetup Class Properties

For a list of all members of this type, see AddUserToQueueSetup members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | IsSupervisor | Is the User a Queue supervisor? | | Public Property | Queue | Name of the Queue to which the User will be added.

| | Public Property | UserName | Username of the user being added to the Queue. |

Reference

AddUserToQueueSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
AddUserToQueue(AddUserToQueueSetup) Method


AddWorkaroundSetup Class Properties | fcSDK Documentation

AddWorkaroundSetup Class Properties

For a list of all members of this type, see AddWorkaroundSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CreateDate | DateTime the Workaround was created. If not set, the current time is used.
Public Property | IsPublic | Is Workaround public?
Public Property | ResolutionCode | Element from the 'Resolution Code' application list. If not set, the default list value is used.
Public Property | SolutionIDNum | Identifier of the Solution to receive the Workaround.
Public Property | SolutionObjid | Objid of the Solution to receive the Workaround.
Public Property | Workaround | Text of the Workaround.

Reference

AddWorkaroundSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
AddWorkaround(AddWorkaroundSetup) Method


AssignSolutionSetup Class Properties | fcSDK Documentation

AssignSolutionSetup Class Properties

For a list of all members of this type, see AssignSolutionSetup members.

Public Properties

 | Name | Description
Public Property | AssignDate | DateTime the Solution was assigned. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewUser | The new user to which the Solution is to be assigned.
Public Property | SolutionIDNum | Solution Identifier.
Public Property | UserName | The user who has assigned the Solution. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Solution. If not set, the UserName's default is used.

Reference

AssignSolutionSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
AssignSolution(AssignSolutionSetup) Method


CreateAccountSetup Class Properties | fcSDK Documentation

CreateAccountSetup Class Properties

For a list of all members of this type, see CreateAccountSetup members.

Public Properties

 | Name | Description
Public Property | AccountName | Name of the Account.
Public Property | AccountType | Element from the 'Company Type' user defined list. If not set, the default list value is used.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CreateDate | DateTime the Account was created. If not set, the current time is used.
Public Property | Description | Account description.
Public Property | Fax | FAX number for the account.
Public Property | FiscalYear | Fiscal year the account was started.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Ownership | Element from the 'Company Ownership' user defined list. If not set, the default list value is used.
Public Property | Phone | Main phone number for the Account.
Public Property | Revenue | Element from the 'Company Revenue' user defined list. If not set, the default list value is used.
Public Property | Size | Element from the 'Company Size' user defined list. If not set, the default list value is used.
Public Property | Stock | Stock symbol for the Account.
Public Property | Territory | Territory of the Account.
Public Property | UserName | The User creating the Account.
Public Property | WebSite | URL of the web site for the Account.

Reference

CreateAccountSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateAccount(CreateAccountSetup) Method


CreateAddressSetup Class Properties | fcSDK Documentation

CreateAddressSetup Class Properties

For a list of all members of this type, see CreateAddressSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | Address1 | Address Line 1.
Public Property | Address2 | Address Line 2.
Public Property | City | Address City.
Public Property | Country | Address Country
Public Property | IsShortState | Is the State property abbreviated or is it the full name of the State.
Public Property | State | Address State.
Public Property | TimeZone | Address Timezone.
Public Property | ZipCode | Address Zipcode.

Reference

CreateAddressSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateAddress(CreateAddressSetup) Method


CreateBOMSetup Class Properties | fcSDK Documentation

CreateBOMSetup Class Properties

For a list of all members of this type, see CreateBOMSetup members.

Public Properties

 | Name | Description
Public Property | ChildPartDomain | Domain of the child part
Public Property | ChildPartNumber | Child Part Number
Public Property | ChildPartRevision | Child Part Revision
Public Property | ParentPartDomain | Parent Part Domain
Public Property | ParentPartNumber | Parent Part Number
Public Property | ParentPartRevision | Parent Part Revision
Public Property | Quantity | How many of the Child Part Revisions are in the Parent Part Revision.

Reference

CreateBOMSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateBOM(CreateBOMSetup) Method


CreateChannelSetup Class Properties | fcSDK Documentation

CreateChannelSetup Class Properties

For a list of all members of this type, see CreateChannelSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields |
Public Property | AllowInbound |
Public Property | AllowOutbound |
Public Property | Description |
Public Property | Designation |
Public Property | IsActive |
Public Property | Location |
Public Property | MediumObjid |
Public Property | Title |

Reference

CreateChannelSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace


CreateCommunicationSetup Class Properties | fcSDK Documentation

CreateCommunicationSetup Class Properties

For a list of all members of this type, see CreateCommunicationSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | AutoExec | Indicator for user or automatic execution (CommunicationAutoExec).
Public Property | BCCRecipients | Array of addresses for BCC Recipients.
Public Property | CCRecipients | Array of addresses for CC Recipients.
Public Property | ChannelObjid |
Public Property | Created | The date and time that the communication was created.
Public Property | DeliveryStatus | The delivery status of the communication (CommunicationDeliveryStatus).
Public Property | DialogIDNumber | The ID of the parent dialogue.
Public Property | Direction | The direction of the message (CommunicationDirection).
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Message | The body text of the communication.
Public Property | MessageId | The ID of the message for the communication.
Public Property | MessageSent | The date and time that the communication was sent.
Public Property | Priority | The Priority of the communication.
Public Property | Recipients | Array of Recipient addresses (usually email addresses).
Public Property | ReplyTo | ReplyTo address (usually email address)
Public Property | Sender | Sender's address (usually email address)
Public Property | Title | The title or subject line of the communication.
Public Property | UserName | The Login Name of user creating the communication.

Reference

CreateCommunicationSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace


CreateContactSetup Class Properties | fcSDK Documentation

CreateContactSetup Class Properties

For a list of all members of this type, see CreateContactSetup members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation. | | Public Property | Email | Contact email address | | Public Property | Fax | Contact fax number | | Public Property | FirstName | Contact first name | | Public Property | Hours | Job hours for the contact | | Public Property | LastName | Contact last name | | Public Property | MailStop | Mail stop for Contact | | Public Property | Phone | Phone number for the contact | | Public Property | RoleName | Element from the 'Contact Role' application list. If not set, the default list value is used. | | Public Property | Salutation | Salutation for the Contact | | Public Property | SiteIDNum | Identifier of the site for the contact role to create.

| | Public Property | Title | Job title for the Contact |

Reference

CreateContactSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateContact(CreateContactSetup) Method


CreateContractSetup Class Properties | fcSDK Documentation

CreateContractSetup Class Properties

For a list of all members of this type, see CreateContractSetup members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation. | | Public Property | BusinessHoursForPM | Specific hours when preventive maintainence is allowed. | | Public Property | ContractType | Element from the 'Contract Type' user defined list. If not set, the default list value is used. | | Public Property | ExpireDate | Contract expiration date

| | Public Property | Notes | Notes concerning the contract | | Public Property | OnsiteResponseDuration |

The maximum amount of time allowed by the Contract for a field engineer to arrive onsite.

| | Public Property | PayOptions | Method of payment for the Contract | | Public Property | PhoneResponseDuration |

The maximum amount of time allowed by the Contract for a customer service representative to contact the customer by telephone.

| | Public Property | PONumber | Purchase Order number | | Public Property | StartDate | Contract starting date | | Public Property | Status | Element from the 'Contract Status' user defined list. If not set, the default list value is used. | | Public Property | UnitsAvailable | Number of units currently available for use | | Public Property | UnitsPurchased | Number of units purchased | | Public Property | UnitsUsed | Number of units used | | Public Property | UnitType | The type of units the object is delivered in | | Public Property | UseSpecialConsiderations | Does Contract have special considerations? |

Reference

CreateContractSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateContract(CreateContractSetup) Method


CreateCountrySetup Class Properties | fcSDK Documentation

CreateCountrySetup Class Properties

For a list of all members of this type, see CreateCountrySetup members.

Public Properties

 | Name | Description
Public Property | Country | Name of the Country being created
Public Property | CountryCode | Telephone country code for the Country
Public Property | Currency | Name of the Currency used by the Country
Public Property | CurrencyConversionRate | Conversion rate for the currency
Public Property | CurrencyDescription | Currency description
Public Property | CurrencyISOCode | International Standards Organization code for the Country's currency
Public Property | CurrencySymbol | Currency Symbol

Reference

CreateCountrySetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateCountry(CreateCountrySetup) Method


CreateDialogueSetup Class Properties | fcSDK Documentation

CreateDialogueSetup Class Properties

For a list of all members of this type, see CreateDialogueSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | Created | The date and time that the dialogue was created.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Priority | The Priority of the dialogue.
Public Property | Status | The initial status of the dialogue.
Public Property | Title | The title of the dialogue.
Public Property | UserName | The Login Name of user creating the dialogue.

Reference

CreateDialogueSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace


CreateEmployeeResult Class Properties | fcSDK Documentation

CreateEmployeeResult Class Properties

For a list of all members of this type, see CreateEmployeeResult members.

Public Properties

 | Name | Description
Public Property | EmployeeObjid | Objid of the Employee record created.
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | UserObjid | Objid of the User record created.

Reference

CreateEmployeeResult Class
FChoice.Toolkits.Clarify.Interfaces Namespace


CreateEmployeeResult Constructor | fcSDK Documentation

CreateEmployeeResult Constructor

Overload List

Overload | Description
CreateEmployeeResult Constructor |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateEmployeeResult Class
CreateEmployeeResult Members


CreateEmployeeSetup Class Properties | fcSDK Documentation

CreateEmployeeSetup Class Properties

For a list of all members of this type, see CreateEmployeeSetup members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation. | | Public Property | AfterBusinessHoursHigh | Preference for high priority notifications after business hours | | Public Property | AfterBusinessHoursLow | Preference for low priority notifications after business hours | | Public Property | AfterBusinessHoursMed | Preference for medium priority notifications after business hours | | Public Property | AllowProxy | Allow proxy use? | | Public Property | DefaultTablespace | Default Oracle Tablespace for the user | | Public Property | DefaultWipBinTitle | Title of the employee's default WipBin | | Public Property | Email | Employee's email address | | Public Property | EmployeeIdentifier | Employee Identifier | | Public Property | FirstName | Employee first name | | Public Property | IsActive | Is the Employee currently active? | | Public Property | IsFieldEngineer | Is Employee a field engineer? | | Public Property | IsSupervisor | Is Employee a supervisor?

| | Public Property | LaborRate | Employee's labor rate | | Public Property | LastName | Employee last name | | Public Property | LoginName | Employee login name | | Public Property | NormalBusinessHoursHigh | Preference for high priority notifications during normal business hours | | Public Property | NormalBusinessHoursLow | Preference for low priority notifications during normal business hours | | Public Property | NormalBusinessHoursMed | Preference for medium priority notifications during normal business hours | | Public Property | OfflinePrivilegeClass | Offline privilege class | | Public Property | OnlinePrivilegeClass | Online privilege class | | Public Property | Pager | Employee pager number | | Public Property | Password | Employee password | | Public Property | Phone | Employee phone number | | Public Property | ResourceConfig | The resource config that the Employee should be placed in | | Public Property | SiteIDNum | Identifier of the Site where the Employee is located. | | Public Property | StartDate | Employee start date | | Public Property | Supervisor | Employee's supervisor | | Public Property | TempTablespace | Temporary Oracle Tablespace for the user | | Public Property | UseDatabaseLogins | | | Public Property | WorkGroup | Element from the 'Workgroup' user defined list. If not set, the default list value is used. | | Public Property | WorkGroupStartDate | Date that the Employee started in the Workgroup |

Reference

CreateEmployeeSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateEmployee(CreateEmployeeSetup) Method


CreateInteractionSetup Class Properties | fcSDK Documentation

CreateInteractionSetup Class Properties

For a list of all members of this type, see CreateInteractionSetup members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation. | | Public Property | ContactFirstName | Contact's first name. | | Public Property | ContactLastName | Contact's last name. | | Public Property | ContactPhone | Contact's phone number. | | Public Property | Direction | Element from the 'Interaction Direction' user defined list. If not set, the default list value is used. | | Public Property | Duration | Duration of the Interaction

| | Public Property | EnteredDuration | Entered Interaction duration | | Public Property | FeeBased | Is the Interaction fee based? | | Public Property | GenerateTimeBombs | Specifies if timebombs should be created. | | Public Property | InteractionType | Element from the 'Interaction Type' user defined list. If not set, the default list value is used. | | Public Property | IsDoneInOne | Is the Interaction done-in-one? | | Public Property | LeadSource | Name of the person that provided the lead | | Public Property | Notes | Interaction Notes | | Public Property | Origin | Element from the 'Interaction Origin' user defined list. If not set, the default list value is used. | | Public Property | PayOption | Element from the 'Interaction Pay Option' user defined list. If not set, the default list value is used. | | Public Property | ProductName | Element from the 'Interaction Product' user defined list. If not set, the default list value is used. | | Public Property | Reason1 | Element from the 'Interaction Reason_1' user defined list. If not set, the default list value is used. | | Public Property | Reason2 | Element from the 'Interaction Reason_2' user defined list. If not set, the default list value is used. | | Public Property | Result | Element from the 'Interaction Result Code' user defined list. If not set, the default list value is used. | | Public Property | StartDate | DateTime Interaction began | | Public Property | Title | Title of the Interaction | | Public Property | UserName | User performing the Interaction | | Public Property | WaitDuration | Wait time for the Interaction | | Public Property | ZipCode | Contact zipcode |

Reference

CreateInteractionSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateInteraction(CreateInteractionSetup) Method


CreatePartRevisionSetup Class Properties | fcSDK Documentation

CreatePartRevisionSetup Class Properties

For a list of all members of this type, see CreatePartRevisionSetup members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | PartDomain | Domain of the part | | Public Property | PartNumber | Part number of the part | | Public Property | PartRevision | Revision to create | | Public Property | ReplaceDate | DateTime this part replaced the previous one. | | Public Property | ReplacePartDomain | Previous domain this PartRevision replaces.

| | Public Property | ReplacePartNumber |

Previous part number this PartRevision replaces.

| | Public Property | ReplacePartRevision |

Previous revision this PartRevision replaces.

| | Public Property | Status | The status of the Part Revision. |

Reference

CreatePartRevisionSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
CreatePartRevision(CreatePartRevisionSetup) Method


CreatePartSetup Class Properties | fcSDK Documentation

CreatePartSetup Class Properties

For a list of all members of this type, see CreatePartSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | Description | Description of the part
Public Property | Dimension | Dimensions of the part
Public Property | Family | Level 1 Element from the 'Family' user defined list. If not set, the default list value is used.
Public Property | Line | Level 2 Element from the 'Family' user defined list. If not set, the default list value is used.
Public Property | ModelNumber | Model number of the part
Public Property | Notes | Notes about the part
Public Property | PartClass | Part class for the part to create.
Public Property | PartDomain | Domain for the part to create.
Public Property | PartNumber | Part Number for the part to create.
Public Property | PartType | Element from the 'Part Type' user defined list. If not set, the default list value is used.
Public Property | RepairType | Type of repair. One of "Repairable" or "Expendable"
Public Property | UnitMeasure | Unit of measure for the part
Public Property | WarrantyDays | Number of warranty days for the part
Public Property | WarrantyStartOnShipment | Does the warranty start on shipment?
Public Property | Weight | Unit weight of the part

Reference

CreatePartSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
CreatePart(CreatePartSetup) Method


CreatePriceInstanceSetup Class Properties | fcSDK Documentation

CreatePriceInstanceSetup Class Properties

For a list of all members of this type, see CreatePriceInstanceSetup members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | EndDate | End date of the price instance, If not set, the end date of the price program is used. | | Public Property | PartDomain | Domain of the part | | Public Property | PartNumber | Part number to price

| | Public Property | PartRevision |

Revision to price

| | Public Property | Price | Price of the part | | Public Property | PricedQuantity | How many units in this price instance. | | Public Property | PriceProgram | Domain of the part | | Public Property | PriceType | The type of price being created. | | Public Property | StartDate | Start date of the price instance, If not set, the start date of the price program is used. |

Reference

CreatePriceInstanceSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
CreatePriceInstance(CreatePriceInstanceSetup) Method


CreateProductBinSetup Class Properties | fcSDK Documentation

CreateProductBinSetup Class Properties

For a list of all members of this type, see CreateProductBinSetup members.

Public Properties

 | Name | Description
Public Property | BinName | Name of the bin to create
Public Property | CreateDate | Date the bin was created. If not set, the current time is used.
Public Property | Description | Bin description
Public Property | ParentBinObjid | Set this value if you wish the new Bin to be a child of this Parent Bin.
Public Property | PrimarySupportEmployeeObjid | Objid of the primary support Employee.
Public Property | SecondarySupportEmployeeObjid | Objid of the secondary support Employee.
Public Property | SiteIDNum | Identifier of the site where the bin is created
Public Property | UserName | User creating the bin. If not set, the default is the session user.

Reference

CreateProductBinSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateProductBin(CreateProductBinSetup) Method


CreateQueueSetup Class Properties | fcSDK Documentation

CreateQueueSetup Class Properties

For a list of all members of this type, see CreateQueueSetup members.

Public Properties

 | Name | Description
Public Property | AllowActionItem | Should Queue allow Action Items
Public Property | AllowCase | Should Queue allow Cases
Public Property | AllowContract | Should Queue allow Contracts
Public Property | AllowCR | Should Queue allow CRs
Public Property | AllowDemandDetail | Should Queue allow Demand Details
Public Property | AllowDialogue | Should Queue allow Dialogs
Public Property | AllowJob | Should Queue allow Jobs
Public Property | AllowOpportunity | Should Queue allow Opportunities
Public Property | AllowSolution | Should Queue allow Solutions
Public Property | AllowSubcase | Should Queue allow Subcases
Public Property | Description | Queue description
Public Property | IsPersonal | Is this a personal Queue?
Public Property | Supervisor | Username of the supervisor of the Queue
Public Property | Title | Title of the Queue

Reference

CreateQueueSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateQueue(CreateQueueSetup) Method


CreateSiteSetup Class Properties | fcSDK Documentation

CreateSiteSetup Class Properties

For a list of all members of this type, see CreateSiteSetup members.

Public Properties

 | Name | Description
Public Property | AccountIDNum | Identifier of the Account this site belongs to. If not set, the default Account is used.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | BillingAddressObjid | Billing Address of the site. If not set, the primary address is used.
Public Property | District | District of the Site
Public Property | IndustryType | Element from the 'Industry Type' user defined list. If not set, the default list value is used.
Public Property | ParentSiteIDNum | Identifier for the parent Site of the Site being created.
Public Property | PrimaryAddressObjid | Primary Address of the site
Public Property | PrimarySupportEmployeeObjid | Objid of the primary support Employee.
Public Property | PrimaryUse | Element from the 'Primary Use' user defined list. If not set, the default list value is used.
Public Property | Region | Region for the Site
Public Property | SecondarySupportEmployeeObjid | Objid of the secondary support Employee.
Public Property | ShippingAddressObjid | Shipping Address of the site. If not set, the primary address is used.
Public Property | SiteIDNum | Identifier for the site being created. If not set, a unique identifier will be created automatically.
Public Property | SiteName | Name of the Site
Public Property | SiteType | Type of the site
Public Property | Status | Site status
Public Property | SupportOfficeSiteIDNum | Identifier of the site where the support office is located

Reference

CreateSiteSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateSite(CreateSiteSetup) Method


CreateSolutionResult Class Properties | fcSDK Documentation

CreateSolutionResult Class Properties

For a list of all members of this type, see CreateSolutionResult members.

Public Properties

 | Name | Description
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | WorkaroundObjid | Objid of the Workaround that is created along with the Solution

Reference

CreateSolutionResult Class
FChoice.Toolkits.Clarify.Interfaces Namespace


CreateSolutionResult Constructor | fcSDK Documentation

CreateSolutionResult Constructor

Overload List

Overload | Description
CreateSolutionResult Constructor |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreateSolutionResult Class
CreateSolutionResult Members


CreateSolutionSetup Class Properties | fcSDK Documentation

CreateSolutionSetup Class Properties

For a list of all members of this type, see CreateSolutionSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CreateDate | DateTime the Solution was created. If not set, the current time is used.
Public Property | Description | The problem description of the Solution
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | IsPublic | Is the Solution public?
Public Property | Queue | Name of the Queue into which the Solution will be dispatched. If not set, the Solution is not dispatched.
Public Property | ResolutionCode | Element from the 'Resolution Code' application list. If not set, the default list value is used.
Public Property | Title | Title of the Solution
Public Property | UserName | User creating the Solution. If not set, the default is the session user.
Public Property | Workaround | Text of the first Workaround for the Solution.

Reference

CreateSolutionSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateSolution(CreateSolutionSetup) Method


CreateStateSetup Class Properties | fcSDK Documentation

CreateStateSetup Class Properties

For a list of all members of this type, see CreateStateSetup members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | Country | Name of the Country the State will belong to.

| | Public Property | FullName | Full name of the State | | Public Property | IsDefault | Is this the default State for the country? | | Public Property | State | State name |

Reference

CreateStateSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateState(CreateStateSetup) Method


CreateTimeZoneSetup Class Properties | fcSDK Documentation

CreateTimeZoneSetup Class Properties

For a list of all members of this type, see CreateTimeZoneSetup members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | Country | Name of the Country the Timezone will belong to.

| | Public Property | FullName | Fullname of the Timezone | | Public Property | GMTDifference | Seconds between the Timezone being created and Greenwich Mean Time (GMT) | | Public Property | TimeZone | Timezone name |

Reference

CreateTimeZoneSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateTimeZone(CreateTimeZoneSetup) Method


CreateWipBinSetup Class Properties | fcSDK Documentation

CreateWipBinSetup Class Properties

For a list of all members of this type, see CreateWipBinSetup members.

Public Properties

 | Name | Description
Public Property | Description | WipBin description
Public Property | IsDefaultBin | Is the WipBin the user's default?
Public Property | Title | Title of the WipBin
Public Property | UserName | User the WipBin is being created for.

Reference

CreateWipBinSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
CreateWipBin(CreateWipBinSetup) Method


DeinstallSitePartSetup Class Properties | fcSDK Documentation

DeinstallSitePartSetup Class Properties

For a list of all members of this type, see DeinstallSitePartSetup members.

Public Properties

 | Name | Description
Public Property | DeinstallDate | DateTime the Site Part was de-instaled
Public Property | SitePartObjid | ObjId of the Site Part to de-install
Public Property | UseRemove | Is this a remove (true) or de-Install (false) activity?
Public Property | UserName | User that performed the de-install.

Reference

DeinstallSitePartSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
DeinstallSitePart(DeinstallSitePartSetup) Method


DeleteProductBinSetup Class Properties | fcSDK Documentation

DeleteProductBinSetup Class Properties

For a list of all members of this type, see DeleteProductBinSetup members.

Public Properties

 | Name | Description
Public Property | BinObjid | Objid of the Bin to delete
Public Property | DeleteDate | DateTime the Bin was deleted. If not set, the current time is used.
Public Property | UserName | User who deleted the Bin. If not set, the session user is used.

Reference

DeleteProductBinSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
DeleteProductBin(DeleteProductBinSetup) Method


DispatchSolutionSetup Class Properties | fcSDK Documentation

DispatchSolutionSetup Class Properties

For a list of all members of this type, see DispatchSolutionSetup members.

Public Properties

 | Name | Description
Public Property | DispatchDate | DateTime the Solution was dispatched. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Queue | The queue into which the Solution is to be dispatched.
Public Property | SolutionIDNum | Solution Identifier.
Public Property | UserName | The user who has dispatched the Solution. If not set, the Toolkit session user is used.

Reference

DispatchSolutionSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
DispatchSolution(DispatchSolutionSetup) Method


ForwardSolutionSetup Class Properties | fcSDK Documentation

ForwardSolutionSetup Class Properties

For a list of all members of this type, see ForwardSolutionSetup members.

Public Properties

 | Name | Description
Public Property | ForwardDate | DateTime the Solution was forwarded. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewQueue | The new queue into which the Solution is to be forwarded.
Public Property | Notes | The reason the Solution was rejected from the queue into which it was dispatched.
Public Property | SolutionIDNum | Solution Identifier.
Public Property | UserName | The user who has forwarded the Solution. If not set, the Toolkit session user is used.

Reference

ForwardSolutionSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
ForwardSolution(ForwardSolutionSetup) Method


InstallSitePartToBinSetup Class Properties | fcSDK Documentation

InstallSitePartToBinSetup Class Properties

For a list of all members of this type, see InstallSitePartToBinSetup members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AddActivityLog | Should an activity log be created? | | Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation. | | Public Property | Comments | Comment for the Site Part installation | | Public Property | InstallDate | DateTime the Site Part was installed. If not set, the current time is used. | | Public Property | InstanceName | The instance name for the Site Part. | | Public Property | InvoiceNumber | Invoice number | | Public Property | ParentBinObjid | Objid of the parent Bin this Part will be installed under | | Public Property | PartDomain | Domain of the part to install | | Public Property | PartNumber | Part Number of the part to install | | Public Property | PartRevision | Part Revision of the part to install | | Public Property | PartStatus | Element from the 'Part_Status' user defined list. If not set, the default list value is used. | | Public Property | Quantity | The number of units to install | | Public Property | SerialNumber | Serial number of the part installed | | Public Property | ShipDate | DateTime the part was shipped. If not set, the | | Public Property | SiteIDNum | Identifier of the Site where the part will be installed.

| | Public Property | UserName | User who performed the install. If not set, the session user is used. |

Reference

InstallSitePartToBinSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
InstallSitePartToBin(InstallSitePartToBinSetup) Method


InstallSitePartToPartSetup Class Properties | fcSDK Documentation

InstallSitePartToPartSetup Class Properties

For a list of all members of this type, see InstallSitePartToPartSetup members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AddActivityLog | Should an activity log be created? | | Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation. | | Public Property | Comments | Comment for the Site Part installation | | Public Property | InstallDate | DateTime the Site Part was installed. If not set, the current time is used. | | Public Property | InstanceName | The instance name for the Site Part. | | Public Property | InvoiceNumber | Invoice number | | Public Property | ParentSitePartObjid | Objid of the parent Site Part this Part will be installed under. | | Public Property | PartDomain | Domain of the part to install | | Public Property | PartNumber | Part Number of the part to install | | Public Property | PartRevision | Part Revision of the part to install | | Public Property | PartStatus | Element from the 'Part_Status' user defined list. If not set, the default list value is used. | | Public Property | Quantity | The number of units to install | | Public Property | SerialNumber | Serial number of the part installed | | Public Property | ShipDate | DateTime the part was shipped. If not set, the | | Public Property | SiteIDNum | Identifier of the Site where the part will be installed.

| | Public Property | UserName | User who performed the install. If not set, the session user is used. |

Reference

InstallSitePartToPartSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
InstallSitePartToPart(InstallSitePartToPartSetup) Method


InstallSitePartToSiteSetup Class Properties | fcSDK Documentation

InstallSitePartToSiteSetup Class Properties

For a list of all members of this type, see InstallSitePartToSiteSetup members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AddActivityLog | Should an activity log be created? | | Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation. | | Public Property | Comments | Comment for the Site Part installation | | Public Property | InstallDate | DateTime the Site Part was installed. If not set, the current time is used. | | Public Property | InstanceName | The instance name for the Site Part. | | Public Property | InvoiceNumber | Invoice number | | Public Property | PartDomain | Domain of the part to install | | Public Property | PartNumber | Part Number of the part to install | | Public Property | PartRevision | Part Revision of the part to install | | Public Property | PartStatus | Element from the 'Part_Status' user defined list. If not set, the default list value is used. | | Public Property | Quantity | The number of units to install | | Public Property | SerialNumber | Serial number of the part installed | | Public Property | ShipDate | DateTime the part was shipped. If not set, the current time is used. | | Public Property | SiteIDNum | Identifier of the Site where the part will be installed.

| | Public Property | UserName | User who performed the install. If not set, the session user is used. |

Reference

InstallSitePartToSiteSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
InstallSitePartToSite(InstallSitePartToSiteSetup) Method


InterfacesToolkit Class Fields | fcSDK Documentation

InterfacesToolkit Class Fields

For a list of all members of this type, see InterfacesToolkit members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | CreateCommunicationActivityCode | Activity code used for act_entry logs generated when creating a communication.
static (Shared in Visual Basic) | CreateDialogueActivityCode | Activity code used for act_entry logs generated when creating a dialogue.
static (Shared in Visual Basic) | DeliveryConfirmedActivityCode |
static (Shared in Visual Basic) | DeliveryFailedActivityCode |
static (Shared in Visual Basic) | DeliveryPendingActivityCode |

Reference

InterfacesToolkit Class
FChoice.Toolkits.Clarify.Interfaces Namespace


InterfacesToolkit Class Methods | fcSDK Documentation

InterfacesToolkit Class Methods

For a list of all members of this type, see InterfacesToolkit members.

Public Methods

 | Name | Description
Public Method | AcceptSolution | Overloaded. Accept the specified Solution from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.
Public Method | AddContactToContract | Overloaded. Adds a Contact to an existing Contract. This overload takes a set of required parameters for the API.
Public Method | AddEmployeeToAccount | Overloaded. Add an Employee as a team member to an Account with a specified role. This overload takes a set of required parameters for the API.
Public Method | AddSitePartToContract | Overloaded. Adds a Site Part to an existing contract.
Public Method | AddSiteToAccount | Overloaded. Adds a Site to an existing Account specifying the Site's role in the account. This overload takes a set of required parameters for the API.
Public Method | AddSiteToContract | Overloaded. Adds a site to an existing Contract. This overload takes a set of required parameters for the API.
Public Method | AddUserToQueue | Overloaded. Add a User to a Queue. This overload takes a set of required parameters for the API.
Public Method | AddWorkaround | Overloaded. Add a new Workaround to an existing Solution. This overload takes a set of required parameters for the API.
Public Method | AssignSolution | Overloaded. Assign the Solution to a new user. This overload takes a set of required parameters for the API.
Public Method | CreateAccount | Overloaded. Create Account (business org) This overload takes a set of required parameters for the API.
Public Method | CreateAddress | Overloaded. Creates a new Address. This overload takes a set of required parameters for the API.
Public Method | CreateBOM | Overloaded. Creates a Bill Of Materials (BOM) for a Part Revision. This overload takes a set of required parameters for the API.
Public Method | CreateChannel | Overloaded.
Public Method | CreateCommunication | Overloaded. Creates a new Communication.
Public Method | CreateContact | Overloaded. Creates a Contact. This overload takes a setup object.
Public Method | CreateContract | Overloaded. Creates a Contract. This overload takes a set of required parameters for the API.
Public Method | CreateCountry | Overloaded. Creates a Country. This overload takes a set of required parameters for the API.
Public Method | CreateDialogue | Overloaded. Creates a new Dialogue.
Public Method | CreateEmployee | Overloaded. Create an Employee in Clarify This overload takes a set of required parameters for the API.
Public Method | CreateInteraction | Overloaded. Creates an Interaction in Clarify. This overload takes a set of required parameters for the API.
Public Method | CreatePart | Overloaded. Create a Part. This overload takes a set of required parameters for the API.
Public Method | CreatePartRevision | Overloaded. Create a Part Revision (mod_level) This overload takes a set of required parameters for the API.
Public Method | CreatePriceInstance | Overloaded. Creates a Price Instance. This overload takes a set of required parameters for the API.
Public Method | CreateProductBin | Overloaded. Create a Product Bin This overload takes a set of required parameters for the API.
Public Method | CreateQueue | Overloaded. Create a Queue. This overload takes a set of required parameters for the API.
Public Method | CreateSite | Overloaded. Create a Site. This overload takes a set of required parameters for the API.
Public Method | CreateSolution | Overloaded. Create a Solution. This overload takes a set of required parameters for the API.
Public Method | CreateState | Overloaded. Create a State (Provence) and relate it to an existing Country. This overload takes a set of required parameters for the API.
Public Method | CreateTimeZone | Overloaded. Creates a Time Zone and relates it to an existing Country. This overload takes a set of required parameters for the API.
Public Method | CreateWipBin | Overloaded. Create a WipBin. This overload takes a set of required parameters for the API.
Public Method | DeinstallSitePart | Overloaded. DeInstall a Site Part. This overload takes a set of required parameters for the API.
Public Method | DeleteProductBin | Overloaded. Delete a Product Bin. This overload takes a set of required parameters for the API.
Public Method | DispatchSolution | Overloaded. Dispatch the Solution to the specified queue. This overload takes a set of required parameters for the API.
Public Method | ForwardSolution | Overloaded. Reject-forward the Solution from one queue to another. This overload takes a set of required parameters for the API.
Public Method | InstallSitePartToBin | Overloaded. Install a Site Part under a Product Bin. This overload takes a set of required parameters for the API.
Public Method | InstallSitePartToPart | Overloaded. Install a Site Part under another Site Part. This overload takes a set of required parameters for the API.
Public Method | InstallSitePartToSite | Overloaded. Install a Site Part under a Site. This overload takes a set of required parameters for the API.
Public Method | LinkCaseToWorkaround | Overloaded. Link a Case to a Workaround. This overload takes a set of required parameters for the API.
Public Method | LinkCRToSolution | Overloaded. Link a CR to a Solution. This overload takes a set of required parameters for the API.
Public Method | MoveSitePartToBin | Overloaded. Move the SitePartToBin from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
Public Method | MoveSitePartToPart | Overloaded. Move the SitePartToPart from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
Public Method | MoveSitePartToSite | Overloaded. Move the SitePartToSite from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
Public Method | MoveSolution | Overloaded. Move the Solution from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
Public Method | ReinstallSitePartToBin | Overloaded. Re-Install a Site Part under a Product Bin. This overload takes a set of required parameters for the API.
Public Method | ReinstallSitePartToPart | Overloaded. Re-Install a Site Part under another Site Part. This overload takes a set of required parameters for the API.
Public Method | ReinstallSitePartToSite | Overloaded. Re-Install a Site Part under a Site. This overload takes a set of required parameters for the API.
Public Method | RejectSolution | Overloaded. Reject the Solution from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.
Public Method | RemoveContactFromContract | Overloaded.
Public Method | RemoveEmployeeFromAccount | Overloaded. Remove an Employee from an Account. This overload takes a set of required parameters for the API.
Public Method | RemoveSiteFromAccount | Overloaded. Remove a Site from an Account. This overload takes a set of required parameters for the API.
Public Method | RemoveSiteFromContract | Overloaded.
Public Method | RemoveSitePartFromContract | Overloaded.
Public Method | ReopenDialogue | Overloaded.
Public Method | UnlinkCaseFromWorkaround | Overloaded. Unlink Case from Workaround. This overload takes a set of required parameters for the API.
Public Method | UnlinkCRFromSolution | Overloaded. Unlink CR from Solution. This overload takes a set of required parameters for the API.
Public Method | UpdateAccount | Overloaded. Update an Account. This overload takes a setup object.
Public Method | UpdateAddress | Overloaded. Update an Address. This overload takes a setup object.
Public Method | UpdateCommunication | Overloaded. Update a Communication.
Public Method | UpdateContact | Overloaded. Update a Contact. This overload takes a set of required parameters for the API.
Public Method | UpdateContactByObjid | Overloaded.
Public Method | UpdateContract | Overloaded. Update a Contract. This overload takes a setup object.
Public Method | UpdateDialogue | Overloaded. Update a Dialogue.
Public Method | UpdatePart | Overloaded. Update a Part. This overload takes a set of required parameters for the API.
Public Method | UpdatePartRevision | Overloaded. Update a Part Revision (mod_level) This overload takes a set of required parameters for the API.
Public Method | UpdatePriceInstance | Overloaded. Update Price Instance. This overload takes a set of required parameters for the API.
Public Method | UpdateProductBin | Overloaded. Update a Product Bin. This overload takes a setup object.
Public Method | UpdateQueue | Overloaded. Update a Queue. This overload takes a setup object.
Public Method | UpdateSite | Overloaded. Update a Site. This overload takes a setup object.
Public Method | UpdateSiteByObjid | Overloaded. Update Site identified by Objid. This overload takes a setup object.
Public Method | UpdateSitePart | Overloaded. Update a Site Part This overload takes a set of required parameters for the API.
Public Method | UpdateWipBin | Overloaded. Update a WipBin. This overload takes a setup object.
Public Method | YankSolution | Overloaded. Yank the Solution from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.

Reference

InterfacesToolkit Class
FChoice.Toolkits.Clarify.Interfaces Namespace


InterfacesToolkit Class Properties | fcSDK Documentation

InterfacesToolkit Class Properties

For a list of all members of this type, see InterfacesToolkit members.

Public Properties

 | Name | Description
Public Property | AllowDuplicateContact | Should the CreateContact or UpdateContact methods allow the creation or update of a Contact with the same first name, last name, telephone number as another Contact in the system. (Inherited from FChoice.Toolkits.Clarify.Interfaces.InterfacesToolkitBase)
Public Property | ImpersonatorUsername | (Inherited from FChoice.Toolkits.Clarify.Interfaces.InterfacesToolkitBase)
Public Property | UseDatabaseLogins | (Inherited from FChoice.Toolkits.Clarify.Interfaces.InterfacesToolkitBase)

Reference

InterfacesToolkit Class
FChoice.Toolkits.Clarify.Interfaces Namespace


InterfacesToolkitBase Class Properties | fcSDK Documentation

InterfacesToolkitBase Class Properties

For a list of all members of this type, see InterfacesToolkitBase members.

Public Properties

 | Name | Description
Public Property | AllowDuplicateContact | Should the CreateContact or UpdateContact methods allow the creation or update of a Contact with the same first name, last name, telephone number as another Contact in the system.
Public Property | ImpersonatorUsername |
Public Property | UseDatabaseLogins |

Reference

InterfacesToolkitBase Class
FChoice.Toolkits.Clarify.Interfaces Namespace


LinkCaseToWorkaroundSetup Class Properties | fcSDK Documentation

LinkCaseToWorkaroundSetup Class Properties

For a list of all members of this type, see LinkCaseToWorkaroundSetup members.

Public Properties

 | Name | Description
Public Property | CaseIDNum | Identifier of the Case to link to a Workaround
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | LinkDate | DateTime the link was made. If not set, the current time is used.
Public Property | UserName | User that linked the Case to the Workaround. If not set, the session user is used.
Public Property | WorkaroundObjid | Objid of the Workaround the Case will be linked to

Reference

LinkCaseToWorkaroundSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
LinkCaseToWorkaround(LinkCaseToWorkaroundSetup) Method


LinkCRToSolutionSetup Class Properties | fcSDK Documentation

LinkCRToSolutionSetup Class Properties

For a list of all members of this type, see LinkCRToSolutionSetup members.

Public Properties

 | Name | Description
Public Property | CRIDNum | Identifier of the CR to link to the Solution
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | LinkDate | DateTime the link was made. If not set, the current time is used.
Public Property | SolutionIDNum | Identifier of the Solution to link to the CR
Public Property | UserName | User that linked the CR to the Solution. If not set, the session user is used.

Reference

LinkCRToSolutionSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
LinkCRToSolution(LinkCRToSolutionSetup) Method


MoveSitePartToBinSetup Class Properties | fcSDK Documentation

MoveSitePartToBinSetup Class Properties

For a list of all members of this type, see MoveSitePartToBinSetup members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AddActivityLog | Should an activity log be created for the move? | | Public Property | InstallAndMove | If AddActivityLog is true. Should the activity be listed as an Install/Move (true) or just a Move (false)

| | Public Property | MoveDate | DateTime the SitePartToBin was moved. If not set, the current time is used. | | Public Property | ParentBinObjid | Objid of the Bin to place the Site Part into | | Public Property | SitePartObjid |

Objid of the Site Part to be moved

| | Public Property | UserName | The user who has moved the SitePartToBin. If not set, the Toolkit session user is used. |

Reference

MoveSitePartToBinSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
MoveSitePartToBin(MoveSitePartToBinSetup) Method


MoveSitePartToPartSetup Class Properties | fcSDK Documentation

MoveSitePartToPartSetup Class Properties

For a list of all members of this type, see MoveSitePartToPartSetup members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AddActivityLog | Should an activity log be created for the move? | | Public Property | InstallAndMove | If AddActivityLog is true. Should the activity be listed as an Install/Move (true) or just a Move (false)

| | Public Property | MoveDate | DateTime the SitePartToPart was moved. If not set, the current time is used. | | Public Property | ParentSitePartObjid | Objid of the parent Site Part this Site Part will be placed into | | Public Property | SitePartObjid |

Objid of the Site Part to be moved

| | Public Property | UserName | The user who has moved the SitePartToPart. If not set, the Toolkit session user is used. |

Reference

MoveSitePartToPartSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
MoveSitePartToPart(MoveSitePartToPartSetup) Method


MoveSitePartToSiteSetup Class Properties | fcSDK Documentation

MoveSitePartToSiteSetup Class Properties

For a list of all members of this type, see MoveSitePartToSiteSetup members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AddActivityLog | Should an activity log be created for the move? | | Public Property | InstallAndMove | If AddActivityLog is true. Should the activity be listed as an Install/Move (true) or just a Move (false)

| | Public Property | MoveDate | DateTime the SitePartToSite was moved. If not set, the current time is used. | | Public Property | ParentSiteIDNum |

Identifier of the parent Site the Site Part is being moved under

| | Public Property | SitePartObjid |

Objid of the Site Part to be moved

| | Public Property | UserName | The user who has moved the SitePartToSite. If not set, the Toolkit session user is used. |

Reference

MoveSitePartToSiteSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
MoveSitePartToSite(MoveSitePartToSiteSetup) Method


MoveSolutionSetup Class Properties | fcSDK Documentation

MoveSolutionSetup Class Properties

For a list of all members of this type, see MoveSolutionSetup members.

Public Properties

 | Name | Description
Public Property | NewWipBin | The new WipBin into which the Solution is to be moved.
Public Property | SolutionIDNum | Solution Identifier.

Reference

MoveSolutionSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
MoveSolution(MoveSolutionSetup) Method


ReinstallSitePartToBinSetup Class Properties | fcSDK Documentation

ReinstallSitePartToBinSetup Class Properties

For a list of all members of this type, see ReinstallSitePartToBinSetup members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AddActivityLog | Should an activity log be created for the re-installation? | | Public Property | ParentBinObjid | Objid of the parent Bin this Part will be re-installed under. | | Public Property | ReinstallDate | DateTime the Site Part was re-installed. If not set, the current time is used. | | Public Property | SiteIDNum | Identifier of the Site where the Site Part will be re-installed | | Public Property | SitePartObjid | Objid of the Site Part being re-installed | | Public Property | UseInstall | If AddActivityLog is true. Should the activity be listed as an Install (true) or just a Re-Installed (false)

| | Public Property | UserName | User that re-installed the Site Part. If not set, the session user is used. |

Reference

ReinstallSitePartToBinSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
ReinstallSitePartToBin(ReinstallSitePartToBinSetup) Method


ReinstallSitePartToPartSetup Class Properties | fcSDK Documentation

ReinstallSitePartToPartSetup Class Properties

For a list of all members of this type, see ReinstallSitePartToPartSetup members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AddActivityLog | Should an activity log be created for the re-installation? | | Public Property | ParentSitePartObjid | Objid of the parent Site Part this Part will be re-installed under. | | Public Property | ReinstallDate | DateTime the Site Part was re-installed. If not set, the current time is used. | | Public Property | SiteIDNum | Identifier of the Site where the Site Part will be re-installed | | Public Property | SitePartObjid | Objid of the Site Part being re-installed | | Public Property | UseInstall | If AddActivityLog is true. Should the activity be listed as an Install (true) or just a Re-Installed (false)

| | Public Property | UserName | User that re-installed the Site Part. If not set, the session user is used. |

Reference

ReinstallSitePartToPartSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
ReinstallSitePartToPart(ReinstallSitePartToPartSetup) Method


ReinstallSitePartToSiteSetup Class Properties | fcSDK Documentation

ReinstallSitePartToSiteSetup Class Properties

For a list of all members of this type, see ReinstallSitePartToSiteSetup members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AddActivityLog | Should an activity log be created for the re-installation? | | Public Property | ReinstallDate | DateTime the Site Part was re-installed. If not set, the current time is used. | | Public Property | SiteIDNum | Identifier of the Site where the Site Part will be re-installed | | Public Property | SitePartObjid | Objid of the Site Part being re-installed | | Public Property | UseInstall | If AddActivityLog is true. Should the activity be listed as an Install (true) or just a Re-Installed (false)

| | Public Property | UserName | User that re-installed the Site Part. If not set, the session user is used. |

Reference

ReinstallSitePartToSiteSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
ReinstallSitePartToSite(ReinstallSitePartToSiteSetup) Method


RejectSolutionSetup Class Properties | fcSDK Documentation

RejectSolutionSetup Class Properties

For a list of all members of this type, see RejectSolutionSetup members.

Public Properties

 | Name | Description
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Notes | The reason the Solution was rejected from the queue into which it was dispatched.
Public Property | RejectDate | DateTime the Solution was rejected. If not set, the current time is used.
Public Property | SolutionIDNum | Solution Identifier.
Public Property | UserName | The user who has rejected the Solution. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Solution. If not set, the UserName's default is used.

Reference

RejectSolutionSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
RejectSolution(RejectSolutionSetup) Method


RemoveContactFromContractSetup Class Properties | fcSDK Documentation

RemoveContactFromContractSetup Class Properties

For a list of all members of this type, see RemoveContactFromContractSetup members.

Public Properties

 | Name | Description
Public Property | ContactObjid |
Public Property | ContractIDNum |

Reference

RemoveContactFromContractSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace


RemoveEmployeeFromAccountSetup Class Properties | fcSDK Documentation

RemoveEmployeeFromAccountSetup Class Properties

For a list of all members of this type, see RemoveEmployeeFromAccountSetup members.

Public Properties

 | Name | Description
Public Property | AccountIDNum | Identifier for the Account the Employee will be removed from.
Public Property | RoleName | Employee Role to be removing from the Account
Public Property | UserName | Username of the Employee to be removed from the Account.

Reference

RemoveEmployeeFromAccountSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
RemoveEmployeeFromAccount(RemoveEmployeeFromAccountSetup) Method


RemoveSiteFromAccountSetup Class Properties | fcSDK Documentation

RemoveSiteFromAccountSetup Class Properties

For a list of all members of this type, see RemoveSiteFromAccountSetup members.

Public Properties

 | Name | Description
Public Property | AccountIDNum | Identifier for the Account the Site will be removed from.
Public Property | RoleName | Name of the Site's role being removed from the Account
Public Property | SiteIDNum | Identifier of the Site being removed from the Account

Reference

RemoveSiteFromAccountSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
RemoveSiteFromAccount(RemoveSiteFromAccountSetup) Method


RemoveSiteFromContractSetup Class Properties | fcSDK Documentation

RemoveSiteFromContractSetup Class Properties

For a list of all members of this type, see RemoveSiteFromContractSetup members.

Public Properties

 | Name | Description
Public Property | ContractIDNum |
Public Property | SiteIDNum |

Reference

RemoveSiteFromContractSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace


RemoveSitePartFromContractSetup Class Properties | fcSDK Documentation

RemoveSitePartFromContractSetup Class Properties

For a list of all members of this type, see RemoveSitePartFromContractSetup members.

Public Properties

 | Name | Description
Public Property | ContractIDNum |
Public Property | SitePartObjid |

Reference

RemoveSitePartFromContractSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace


ReopenDialogueSetup Class Properties | fcSDK Documentation

ReopenDialogueSetup Class Properties

For a list of all members of this type, see ReopenDialogueSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields |
Public Property | GenerateTimeBombs |
Public Property | IDNumber |
Public Property | Reopened |
Public Property | Status |
Public Property | UserName |

Reference

ReopenDialogueSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace


UnlinkCaseFromWorkaroundSetup Class Properties | fcSDK Documentation

UnlinkCaseFromWorkaroundSetup Class Properties

For a list of all members of this type, see UnlinkCaseFromWorkaroundSetup members.

Public Properties

 | Name | Description
Public Property | CaseIDNum | Identifier of the Case to unlink from the Workaround
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | UnlinkDate | DateTime the unlinking was done. If not set, the current time is used.
Public Property | UserName | User that unlinked the Case from the Workaround. If not set, the session user is used.

Reference

UnlinkCaseFromWorkaroundSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
UnlinkCaseFromWorkaround(UnlinkCaseFromWorkaroundSetup) Method


UnlinkCRFromSolutionSetup Class Properties | fcSDK Documentation

UnlinkCRFromSolutionSetup Class Properties

For a list of all members of this type, see UnlinkCRFromSolutionSetup members.

Public Properties

 | Name | Description
Public Property | CRIDNum | Identifier of the CR to unlink from the Solution
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | SolutionIDNum | Identifier of the Solution to unlink from the CR
Public Property | UnlinkDate | DateTime the unlinking was done. If not set, the current time is used.
Public Property | UserName | User that unlinked the CR from the Solution. If not set, the session user is used.

Reference

UnlinkCRFromSolutionSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
UnlinkCRFromSolution(UnlinkCRFromSolutionSetup) Method


UpdateAccountSetup Class Properties | fcSDK Documentation

UpdateAccountSetup Class Properties

For a list of all members of this type, see UpdateAccountSetup members.

Public Properties

 | Name | Description
Public Property | AccountIDNum | Identifier of the Account being updated
Public Property | AccountName | Name of the Account
Public Property | AccountType | Element from the 'Company Type' user defined list. If not set, the default list value is used.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CreateDate | DateTime the Account was created. If not set, the current time is used.
Public Property | Description | Account description
Public Property | Fax | FAX number for the account
Public Property | FiscalYear | Fiscal year the account was started.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Ownership | Element from the 'Company Ownership' user defined list. If not set, the default list value is used.
Public Property | Phone | Main phone number for the Account
Public Property | Revenue | Element from the 'Company Revenue' user defined list. If not set, the default list value is used.
Public Property | Size | Element from the 'Company Size' user defined list. If not set, the default list value is used.
Public Property | Stock | Stock symbol
Public Property | Territory | Territory of the Account.
Public Property | UserName | User creating the Account
Public Property | WebSite | URL of the Account's web site.

Reference

UpdateAccountSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdateAccount(UpdateAccountSetup) Method


UpdateAddressSetup Class Properties | fcSDK Documentation

UpdateAddressSetup Class Properties

For a list of all members of this type, see UpdateAddressSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | Address1 | Address Line 1
Public Property | Address2 | Address Line 2
Public Property | AddressObjid | Objid of the Address to be updated
Public Property | City | Address City
Public Property | Country | Address Country
Public Property | IsShortState | Is the State property abbreviated or is it the full name of the State
Public Property | State | Address State
Public Property | TimeZone | Address Timezone
Public Property | ZipCode | Address Zipcode

Reference

UpdateAddressSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdateAddress(UpdateAddressSetup) Method


UpdateCommunicationSetup Class Properties | fcSDK Documentation

UpdateCommunicationSetup Class Properties

For a list of all members of this type, see UpdateCommunicationSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | AutoExec | Indicator for user or automatic execution (CommunicationAutoExec).
Public Property | BCCRecipients | Array of addresses for BCC Recipients.
Public Property | CCRecipients | Array of addresses for CC Recipients.
Public Property | ChannelObjid |
Public Property | CommunicationObjid | The unique identifier for the communication to update.
Public Property | DeliveryStatus | The delivery status of the communication (CommunicationDeliveryStatus).
Public Property | Direction | The direction of the message (CommunicationDirection).
Public Property | GenerateTimeBombs |
Public Property | Message | The body text of the communication.
Public Property | MessageId | The ID of the message for the communication.
Public Property | MessageSent | The date and time that the communication was sent.
Public Property | Priority | The Priority of the communication.
Public Property | Recipients | Array of Recipient addresses (usually email addresses).
Public Property | ReplyTo | ReplyTo address (usually email address)
Public Property | Sender | Sender's address (usually email address)
Public Property | Title | The title or subject line of the communication.
Public Property | Updated | The date and time that the communication was updated.
Public Property | UserName |

Reference

UpdateCommunicationSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace


UpdateContactByObjidSetup Class Properties | fcSDK Documentation

UpdateContactByObjidSetup Class Properties

For a list of all members of this type, see UpdateContactByObjidSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields |
Public Property | ContactObjid |
Public Property | Email |
Public Property | Fax |
Public Property | FirstName |
Public Property | Hours |
Public Property | LastName |
Public Property | MailStop |
Public Property | NewFirstName |
Public Property | NewLastName |
Public Property | NewPhone |
Public Property | NewPrimaryRole |
Public Property | NewPrimarySiteIDNum |
Public Property | Phone |
Public Property | RoleName |
Public Property | Salutation |
Public Property | SiteIDNum |
Public Property | Title |

Reference

UpdateContactByObjidSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace


UpdateContactSetup Class Properties | fcSDK Documentation

UpdateContactSetup Class Properties

For a list of all members of this type, see UpdateContactSetup members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation. | | Public Property | Email | Contact email address | | Public Property | Fax | Contact fax number | | Public Property | FirstName | Contact's first name | | Public Property | Hours | Job hours for the contact | | Public Property | LastName | Contact's last name | | Public Property | MailStop | Mail stop for Contact | | Public Property | NewFirstName | Contact's new first name. | | Public Property | NewLastName | Contact's new last name. | | Public Property | NewPhone | Contact's new telephone number. | | Public Property | NewPrimaryRole | New contact role. Element from the 'Contact Role' application list. If not set the default list value is used. | | Public Property | NewPrimarySiteIDNum | Identifier of the new site for the contact role.

| | Public Property | Phone | Contact's telephone number | | Public Property | RoleName | Current role for the Contact at their site. Element from the 'Contact Role' application list. If not set, the default list value is used. | | Public Property | Salutation | Salutation for the Contact | | Public Property | SiteIDNum |

Identifier of the contact's current site.

| | Public Property | Title | Job title for the Contact | | Public Property | UserName | |

Reference

UpdateContactSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdateContact(UpdateContactSetup) Method


UpdateContractSetup Class Properties | fcSDK Documentation

UpdateContractSetup Class Properties

For a list of all members of this type, see UpdateContractSetup members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation. | | Public Property | BusinessHoursForPM | Specific hours when preventive maintainence is allowed | | Public Property | ContractIDNum | Identifier of the Contract to update | | Public Property | ContractType | Element from the 'Contract Type' user defined list. If not set, the default list value is used. | | Public Property | ExpireDate | Contract expiration date

| | Public Property | Notes | Notes concerning the contract | | Public Property | OnsiteResponseDuration |

The maximum amount of time allowed by the Contract for a field engineer to arrive onsite

| | Public Property | PayOptions | Method of payment for the Contract | | Public Property | PhoneResponseDuration | The maximum amount of time allowed by the Contract for a customer service representative to contact the customer by telephone | | Public Property | PONumber | Purchase Order number | | Public Property | StartDate | Contract starting date | | Public Property | Status | Element from the 'Contract Status' user defined list. If not set, the default list value is used. | | Public Property | UnitsAvailable | Number of units currently available for use | | Public Property | UnitsPurchased | Number of units purchased | | Public Property | UnitsUsed | Number of units used | | Public Property | UnitType | The type of units the object is delivered in | | Public Property | UseSpecialConsiderations | Does Contract have special considerations? |

Reference

UpdateContractSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdateContract(UpdateContractSetup) Method


UpdateDialogueSetup Class Properties | fcSDK Documentation

UpdateDialogueSetup Class Properties

For a list of all members of this type, see UpdateDialogueSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | IDNumber | The ID NUmber of the dialogue.
Public Property | Priority | The Priority of the dialogue.
Public Property | Title | The title of the dialogue.
Public Property | Updated | The date and time that the communication was updated.
Public Property | UserName |

Reference

UpdateDialogueSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace


UpdatePartRevisionSetup Class Properties | fcSDK Documentation

UpdatePartRevisionSetup Class Properties

For a list of all members of this type, see UpdatePartRevisionSetup members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | NewPartRevision | This will be the new revision for this PartRevision. | | Public Property | PartDomain | Domain of the part | | Public Property | PartNumber | Part number of the part | | Public Property | PartRevision | Revision to create | | Public Property | ReplaceDate | DateTime this part replaced the previous one. | | Public Property | ReplacePartDomain | Previous domain this PartRevision replaces.

| | Public Property | ReplacePartNumber |

Previous part number this PartRevision replaces.

| | Public Property | ReplacePartRevision |

Previous revision this PartRevision replaces.

| | Public Property | Status | The status of the revision. |

Reference

UpdatePartRevisionSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdatePartRevision(UpdatePartRevisionSetup) Method


UpdatePartSetup Class Properties | fcSDK Documentation

UpdatePartSetup Class Properties

For a list of all members of this type, see UpdatePartSetup members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation. | | Public Property | Description | Description of the part | | Public Property | Dimension | Dimensions of the part | | Public Property | Family | Level 1 Element from the 'Family' user defined list. If not set, the default list value is used. | | Public Property | Line | Level 2 Element from the 'Family' user defined list. If not set, the default list value is used. | | Public Property | ModelNumber | Model number of the part | | Public Property | Notes | Notes about the part | | Public Property | PartClass | Part class for the part to update. | | Public Property | PartDomain | Domain for the part to update. | | Public Property | PartNumber | Part number for the part to update

| | Public Property | PartType | Element from the 'Part Type' user defined list. If not set, the default list value is used. | | Public Property | RepairType | Type of repair. One of "Repairable" or "Expendable" | | Public Property | UnitMeasure | Unit of measure for the part | | Public Property | WarrantyDays | Number of warranty days for the part | | Public Property | WarrantyStartOnShipment | Does the warranty start on shipment? | | Public Property | Weight | Unit weight of the part |

Reference

UpdatePartSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdatePart(UpdatePartSetup) Method


UpdatePriceInstanceSetup Class Properties | fcSDK Documentation

UpdatePriceInstanceSetup Class Properties

For a list of all members of this type, see UpdatePriceInstanceSetup members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | PartDomain | Domain of the part | | Public Property | PartNumber | Part number to price

| | Public Property | PartRevision |

Revision to price

| | Public Property | Price | Price of the part | | Public Property | PricedQuantity | How many units in this price instance. | | Public Property | PriceProgram | Name of the price program | | Public Property | UpdateDate | Date when the Price was updated, any Date between the start and end date is valid. |

Reference

UpdatePriceInstanceSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdatePriceInstance(UpdatePriceInstanceSetup) Method


UpdateProductBinSetup Class Properties | fcSDK Documentation

UpdateProductBinSetup Class Properties

For a list of all members of this type, see UpdateProductBinSetup members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | BinName | Name of the bin to create | | Public Property | BinObjid | Objid of the Bin to be updated

| | Public Property | Description | Bin description | | Public Property | PrimarySupportEmployeeObjid | Objid of the primary support Employee. | | Public Property | SecondarySupportEmployeeObjid | Objid of the secondary support Employee. | | Public Property | UpdateDate | Date when the Bin was updated | | Public Property | UserName | User creating the bin. If not set, the default is the session user. |

Reference

UpdateProductBinSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdateProductBin(UpdateProductBinSetup) Method


UpdateQueueSetup Class Properties | fcSDK Documentation

UpdateQueueSetup Class Properties

For a list of all members of this type, see UpdateQueueSetup members.

Public Properties

 | Name | Description
Public Property | AllowActionItem | Should Queue allow Action Items
Public Property | AllowCase | Should Queue allow Cases
Public Property | AllowContract | Should Queue allow Contracts
Public Property | AllowCR | Should Queue allow CRs
Public Property | AllowDemandDetail | Should Queue allow Demand Details
Public Property | AllowDialogue | Should Queue allow Dialogs
Public Property | AllowJob | Should Queue allow Jobs
Public Property | AllowOpportunity | Should Queue allow Opportunities
Public Property | AllowSolution | Should Queue allow Solutions
Public Property | AllowSubcase | Should Queue allow Subcases
Public Property | Description | Queue description
Public Property | IsPersonal | Is this a personal Queue?
Public Property | NewTitle | New title of the Queue
Public Property | Supervisor | Username of the supervisor of the Queue
Public Property | Title | Title of the Queue

Reference

UpdateQueueSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdateQueue(UpdateQueueSetup) Method


UpdateSiteByObjidSetup Class Properties | fcSDK Documentation

UpdateSiteByObjidSetup Class Properties

For a list of all members of this type, see UpdateSiteByObjidSetup members.

Public Properties

 | Name | Description
Public Property | AccountIDNum | Identifier of the Account this site belongs to. If not set, the default Account is used.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | BillingAddressObjid | Billing Address of the site. If not set, the primary address is used.
Public Property | District | District of the Site
Public Property | IndustryType | Element from the 'Industry Type' user defined list. If not set, the default list value is used.
Public Property | ParentSiteIDNum | Identifier for the parent Site of the Site being created.
Public Property | PrimaryAddressObjid | Primary Address of the site.
Public Property | PrimarySupportEmployeeObjid | Objid of the primary support Employee.
Public Property | PrimaryUse | Element from the 'Primary Use' user defined list. If not set, the default list value is used.
Public Property | Region | Region for the Site
Public Property | SecondarySupportEmployeeObjid | Objid of the secondary support Employee.
Public Property | ShippingAddressObjid | Shipping Address of the site. If not set, the primary address is used.
Public Property | SiteName | Name of the Site
Public Property | SiteObjid | Objid of the Site being updated
Public Property | SiteType | Type of the site
Public Property | Status | Site status
Public Property | SupportOfficeSiteIDNum | Identifier of the site where the support office is located

Reference

UpdateSiteByObjidSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdateSiteByObjid(UpdateSiteByObjidSetup) Method


UpdateSitePartSetup Class Properties | fcSDK Documentation

UpdateSitePartSetup Class Properties

For a list of all members of this type, see UpdateSitePartSetup members.

Public Properties

 | Name | Description
Public Property | AddActivityLog | Should an activity log be created?
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | Comments | Comments for the Site Part
Public Property | InstallDate | DateTime the Site Part was installed.
Public Property | InstanceName | The instance name for the Site Part.
Public Property | InvoiceNumber | Invoice number
Public Property | PartRevision | Part Revision of the part installed
Public Property | PartStatus | Element from the 'Part_Status' user defined list. If not set, the default list value is used.
Public Property | Quantity | The number of units installed
Public Property | SerialNumber | Serial number of the Site Part
Public Property | ServiceEndDate | DateTime the service ends.
Public Property | ShipDate | DateTime the part was shipped.
Public Property | SitePartObjid | Objid of the Site Part to be updated
Public Property | UserName | User who performed the update. If not set, the session user is used.
Public Property | WarrantyDate | DateTime the warranty expires.

Reference

UpdateSitePartSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdateSitePart(UpdateSitePartSetup) Method


UpdateSiteSetup Class Properties | fcSDK Documentation

UpdateSiteSetup Class Properties

For a list of all members of this type, see UpdateSiteSetup members.

Public Properties

 | Name | Description
Public Property | AccountIDNum | Identifier of the Account this site belongs to. If not set, the default Account is used.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | BillingAddressObjid | Billing Address of the site. If not set, the primary address is used.
Public Property | District | District of the Site
Public Property | IndustryType | Element from the 'Industry Type' user defined list. If not set, the default list value is used.
Public Property | ParentSiteIDNum | Identifier for the parent Site of the Site being created.
Public Property | PrimaryAddressObjid | Primary Address of the site.
Public Property | PrimarySupportEmployeeObjid | Objid of the primary support Employee.
Public Property | PrimaryUse | Element from the 'Primary Use' user defined list. If not set, the default list value is used.
Public Property | Region | Region for the Site
Public Property | SecondarySupportEmployeeObjid | Objid of the secondary support Employee.
Public Property | ShippingAddressObjid | Shipping Address of the site. If not set, the primary address is used.
Public Property | SiteIDNum | Identifier for the site being updated.
Public Property | SiteName | Name of the Site
Public Property | SiteType | Type of the site
Public Property | Status | Site status
Public Property | SupportOfficeSiteIDNum | Identifier of the site where the support office is located

Reference

UpdateSiteSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdateSite(UpdateSiteSetup) Method


UpdateWipBinSetup Class Properties | fcSDK Documentation

UpdateWipBinSetup Class Properties

For a list of all members of this type, see UpdateWipBinSetup members.

Public Properties

 | Name | Description
Public Property | Description | WipBin description
Public Property | IsDefaultBin | Is the WipBin the user's default?
Public Property | NewTitle | New title for the WipBin
Public Property | Title | Title of the WipBin being updated
Public Property | UserName | User the WipBin belongs to

Reference

UpdateWipBinSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
UpdateWipBin(UpdateWipBinSetup) Method


YankSolutionSetup Class Properties | fcSDK Documentation

YankSolutionSetup Class Properties

For a list of all members of this type, see YankSolutionSetup members.

Public Properties

 | Name | Description
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | SolutionIDNum | Solution Identifier.
Public Property | UserName | The user who has yanked the Solution. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Solution. If not set, the UserName's default is used.
Public Property | YankDate | DateTime the Solution was yanked. If not set, the current time is used.

Reference

YankSolutionSetup Class
FChoice.Toolkits.Clarify.Interfaces Namespace
YankSolution(YankSolutionSetup) Method


FChoice.Toolkits.Clarify.Interfaces Namespace #### Inheritance Hierarchy | fcSDK Documentation

FChoice.Toolkits.Clarify.Interfaces Namespace #### Inheritance Hierarchy

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Interfaces.AcceptSolutionSetup
FChoice.Toolkits.Clarify.Interfaces.AddContactToContractSetup
FChoice.Toolkits.Clarify.Interfaces.AddEmployeeToAccountSetup
FChoice.Toolkits.Clarify.Interfaces.AddSitePartToContractSetup
FChoice.Toolkits.Clarify.Interfaces.AddSiteToAccountSetup
FChoice.Toolkits.Clarify.Interfaces.AddSiteToContractSetup
FChoice.Toolkits.Clarify.Interfaces.AddUserToQueueSetup
FChoice.Toolkits.Clarify.Interfaces.AddWorkaroundSetup
FChoice.Toolkits.Clarify.Interfaces.AssignSolutionSetup
FChoice.Toolkits.Clarify.Interfaces.CreateAccountSetup
FChoice.Toolkits.Clarify.Interfaces.CreateAddressSetup
FChoice.Toolkits.Clarify.Interfaces.CreateBOMSetup
FChoice.Toolkits.Clarify.Interfaces.CreateChannelSetup
FChoice.Toolkits.Clarify.Interfaces.CreateCommunicationSetup
FChoice.Toolkits.Clarify.Interfaces.CreateContactSetup
FChoice.Toolkits.Clarify.Interfaces.CreateContractSetup
FChoice.Toolkits.Clarify.Interfaces.CreateCountrySetup
FChoice.Toolkits.Clarify.Interfaces.CreateDialogueSetup
FChoice.Toolkits.Clarify.Interfaces.CreateEmployeeSetup
FChoice.Toolkits.Clarify.Interfaces.CreateInteractionSetup
FChoice.Toolkits.Clarify.Interfaces.CreatePartRevisionSetup
FChoice.Toolkits.Clarify.Interfaces.CreatePartSetup
FChoice.Toolkits.Clarify.Interfaces.CreatePriceInstanceSetup
FChoice.Toolkits.Clarify.Interfaces.CreateProductBinSetup
FChoice.Toolkits.Clarify.Interfaces.CreateQueueSetup
FChoice.Toolkits.Clarify.Interfaces.CreateSiteSetup
FChoice.Toolkits.Clarify.Interfaces.CreateSolutionSetup
FChoice.Toolkits.Clarify.Interfaces.CreateStateSetup
FChoice.Toolkits.Clarify.Interfaces.CreateTimeZoneSetup
FChoice.Toolkits.Clarify.Interfaces.CreateWipBinSetup
FChoice.Toolkits.Clarify.Interfaces.DeinstallSitePartSetup
FChoice.Toolkits.Clarify.Interfaces.DeleteProductBinSetup
FChoice.Toolkits.Clarify.Interfaces.DispatchSolutionSetup
FChoice.Toolkits.Clarify.Interfaces.ForwardSolutionSetup
FChoice.Toolkits.Clarify.Interfaces.InstallSitePartToBinSetup
FChoice.Toolkits.Clarify.Interfaces.InstallSitePartToPartSetup
FChoice.Toolkits.Clarify.Interfaces.InstallSitePartToSiteSetup
FChoice.Toolkits.Clarify.Interfaces.LinkCaseToWorkaroundSetup
FChoice.Toolkits.Clarify.Interfaces.LinkCRToSolutionSetup
FChoice.Toolkits.Clarify.Interfaces.MoveSitePartToBinSetup
FChoice.Toolkits.Clarify.Interfaces.MoveSitePartToPartSetup
FChoice.Toolkits.Clarify.Interfaces.MoveSitePartToSiteSetup
FChoice.Toolkits.Clarify.Interfaces.MoveSolutionSetup
FChoice.Toolkits.Clarify.Interfaces.ReinstallSitePartToBinSetup
FChoice.Toolkits.Clarify.Interfaces.ReinstallSitePartToPartSetup
FChoice.Toolkits.Clarify.Interfaces.ReinstallSitePartToSiteSetup
FChoice.Toolkits.Clarify.Interfaces.RejectSolutionSetup
FChoice.Toolkits.Clarify.Interfaces.RemoveContactFromContractSetup
FChoice.Toolkits.Clarify.Interfaces.RemoveEmployeeFromAccountSetup
FChoice.Toolkits.Clarify.Interfaces.RemoveSiteFromAccountSetup
FChoice.Toolkits.Clarify.Interfaces.RemoveSiteFromContractSetup
FChoice.Toolkits.Clarify.Interfaces.RemoveSitePartFromContractSetup
FChoice.Toolkits.Clarify.Interfaces.ReopenDialogueSetup
FChoice.Toolkits.Clarify.Interfaces.UnlinkCaseFromWorkaroundSetup
FChoice.Toolkits.Clarify.Interfaces.UnlinkCRFromSolutionSetup
FChoice.Toolkits.Clarify.Interfaces.UpdateAccountSetup
FChoice.Toolkits.Clarify.Interfaces.UpdateAddressSetup
FChoice.Toolkits.Clarify.Interfaces.UpdateCommunicationSetup
FChoice.Toolkits.Clarify.Interfaces.UpdateContactByObjidSetup
FChoice.Toolkits.Clarify.Interfaces.UpdateContactSetup
FChoice.Toolkits.Clarify.Interfaces.UpdateContractSetup
FChoice.Toolkits.Clarify.Interfaces.UpdateDialogueSetup
FChoice.Toolkits.Clarify.Interfaces.UpdatePartRevisionSetup
FChoice.Toolkits.Clarify.Interfaces.UpdatePartSetup
FChoice.Toolkits.Clarify.Interfaces.UpdatePriceInstanceSetup
FChoice.Toolkits.Clarify.Interfaces.UpdateProductBinSetup
FChoice.Toolkits.Clarify.Interfaces.UpdateQueueSetup
FChoice.Toolkits.Clarify.Interfaces.UpdateSiteByObjidSetup
FChoice.Toolkits.Clarify.Interfaces.UpdateSitePartSetup
FChoice.Toolkits.Clarify.Interfaces.UpdateSiteSetup
FChoice.Toolkits.Clarify.Interfaces.UpdateWipBinSetup
FChoice.Toolkits.Clarify.Interfaces.YankSolutionSetup
FChoice.Toolkits.Clarify.ToolkitBase
FChoice.Toolkits.Clarify.Interfaces.InterfacesToolkitBase
FChoice.Toolkits.Clarify.Interfaces.InterfacesToolkit
FChoice.Toolkits.Clarify.ToolkitResult
FChoice.Toolkits.Clarify.Interfaces.CreateEmployeeResult
FChoice.Toolkits.Clarify.Interfaces.CreateSolutionResult

Reference

FChoice.Toolkits.Clarify Assembly


Location Class Fields | fcSDK Documentation

Location Class Fields

For a list of all members of this type, see Location members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | EMPTY |
Public Field | PRIMARY_BIN_SUGGESTION_NAME |

Reference

Location Class
FChoice.Toolkits.Clarify Namespace


Location Class Methods | fcSDK Documentation

Location Class Methods

For a list of all members of this type, see Location members.

Public Methods

 | Name | Description
Public Method | ToString |

Reference

Location Class
FChoice.Toolkits.Clarify Namespace


Location Class Properties | fcSDK Documentation

Location Class Properties

For a list of all members of this type, see Location members.

Public Properties

 | Name | Description
Public Property | BinName |
Public Property | ContainerIDNum |
Public Property | IsPrimaryBinSuggestion |
Public Property | LocationName |

Reference

Location Class
FChoice.Toolkits.Clarify Namespace


LocationCollection Class Methods | fcSDK Documentation

LocationCollection Class Methods

For a list of all members of this type, see LocationCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | ToLegacyString |

Reference

LocationCollection Class
FChoice.Toolkits.Clarify Namespace


LocationCollection Class Properties | fcSDK Documentation

LocationCollection Class Properties

For a list of all members of this type, see LocationCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection)
Public Property | IsDirty |
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection)

Reference

LocationCollection Class
FChoice.Toolkits.Clarify Namespace


AcceptPartRequestSetup Class Properties | fcSDK Documentation

AcceptPartRequestSetup Class Properties

For a list of all members of this type, see AcceptPartRequestSetup members.

Public Properties

 | Name | Description
Public Property | AcceptDate | DateTime the PartRequest was accepted. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | PartRequestDetailIDNum | Part Request Detail Identifier
Public Property | UserName | The user who has accepted the PartRequest. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the PartRequest. If not set, the UserName's default is used.

Reference

AcceptPartRequestSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitAcceptPartRequest(AcceptPartRequestSetup)


AddAlternatePartSetup Class Properties | fcSDK Documentation

AddAlternatePartSetup Class Properties

For a list of all members of this type, see AddAlternatePartSetup members.

Public Properties

 | Name | Description
Public Property | AlternatePartDomain | The Alternate Part domain
Public Property | AlternatePartNumber | The Alternate Part number
Public Property | AlternatePartRevision | The Alternate Part revision
Public Property | IsReciprocal | Specifies whether (true) or not (false) the first part/rev should be made an alternate of the second part
Public Property | PartDomain | The Part domain
Public Property | PartNumber | The Part number
Public Property | PartRevision | The Part revision

Reference

AddAlternatePartSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitAddAlternatePart(AddAlternatePartSetup)


AddGLAccountSetup Class Properties | fcSDK Documentation

AddGLAccountSetup Class Properties

For a list of all members of this type, see AddGLAccountSetup members.

Public Properties

 | Name | Description
Public Property | AccountName | Name of the General Ledger account
Public Property | AccountNumber | The number for the General Ledger account
Public Property | AccountType | Element from the 'Location Type' user list. If not set the default list value is used.
Public Property | Description | Description of the account
Public Property | IsActive | Specifies whether this account is active (true) or inactive (false)
Public Property | IsCompany | Specifies whether this account is company owned (true) or customer owned (false)
Public Property | IsExpenseGLAccount | Specifies whether this is an expense account (true) or a GL account (false)
Public Property | SiteIDNum | The identifier of the Site with which the account is to be associated

Reference

AddGLAccountSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitAddGLAccount(AddGLAccountSetup)


AddInventoryBinSetup Class Properties | fcSDK Documentation

AddInventoryBinSetup Class Properties

For a list of all members of this type, see AddInventoryBinSetup members.

Public Properties

 | Name | Description
Public Property | IsActive | Specifies whether this inventory bin is active (true) or inactive (false)
Public Property | Location | A reference to a Location object which specifies the name of the bin to create and the name of the location in which to create it

Reference

AddInventoryBinSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitAddInventoryBin(AddInventoryBinSetup)


AddInventoryLocationSetup Class Properties | fcSDK Documentation

AddInventoryLocationSetup Class Properties

For a list of all members of this type, see AddInventoryLocationSetup members.

Public Properties

 | Name | Description
Public Property | AccountType | Element from the 'Location Type' user list. If not set the default list value is used.
Public Property | CapitalGLAccount | The name of the Capital GL account with which this inventory location is to be associated
Public Property | Description | Description of the inventory location
Public Property | IsActive | Specifies whether this inventory location is active (true) or inactive (false)
Public Property | IsCompany | Specifies whether this account is company owned (true) or customer owned (false)
Public Property | LocationName | Name of the inventory location to add
Public Property | PartAuthorizationLevel | The part authorization level for this inventory location
Public Property | ReportsToLocation | Name of the inventory location to which this new inventory location reports
Public Property | SiteIDNum | The identifier of the Site with which the inventory location is to be associated

Reference

AddInventoryLocationSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitAddInventoryLocation(AddInventoryLocationSetup)


AddLocationServicingSiteSetup Class Properties | fcSDK Documentation

AddLocationServicingSiteSetup Class Properties

For a list of all members of this type, see AddLocationServicingSiteSetup members.

Public Properties

 | Name | Description
Public Property | IsActive | Specifies whether this inventory location is active (true) or inactive (false)
Public Property | LocationName | The name of the location that will be servicing the Site
Public Property | LocationRank | The rank of this inventory location at the associated site
Public Property | SiteIDNum | The identifier of the Site that the inventory location is servicing

Reference

AddLocationServicingSiteSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitAddLocationServicingSite(AddLocationServicingSiteSetup)


AssignPartRequestSetup Class Properties | fcSDK Documentation

AssignPartRequestSetup Class Properties

For a list of all members of this type, see AssignPartRequestSetup members.

Public Properties

 | Name | Description
Public Property | AssignDate | DateTime the PartRequest was assigned. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewUser | The new user to which the PartRequest is to be assigned.
Public Property | PartRequestDetailIDNum | Part Request Detail Identifier
Public Property | UserName | The user who has assigned the PartRequest. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the PartRequest. If not set, the UserName's default is used.

Reference

AssignPartRequestSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitAssignPartRequest(AssignPartRequestSetup)


BackorderPartRequestSetup Class Properties | fcSDK Documentation

BackorderPartRequestSetup Class Properties

For a list of all members of this type, see BackorderPartRequestSetup members.

Public Properties

 | Name | Description
Public Property | ExpectedDate | The DateTime the Part Request backordered parts are expected to arrive. If not set, the current time is used.
Public Property | FromGood | Specifies whether the backordered inventory is from good stock (true) or bad stock (false)
Public Property | FromLocation | The inventory location containing the parts used to backorder this Part Request
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewStatus | The new status for the Part Request for the backordered condition. If not set, the default status is used.
Public Property | PartRequestDetailIDNum | Part Request Detail Identifier
Public Property | Quantity | The number of parts being backordered for this Part Request
Public Property | SerialNumber | The serial number of the part used to backorder this Part Request
Public Property | ToGood | Specifies whether the backordered inventory is going to good stock (true) or bad stock (false)
Public Property | ToLocation | The destination inventory location for the parts used to backorder this Part Request
Public Property | UserName | The user who is backordering the Part Request. If not set, the session user is used.
Public Property | UseTransitions | Specifies whether or not logistics transitions will be checked and the condition/status of the part request detail will be changed during the backorder operation

Reference

BackorderPartRequestSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitBackorderPartRequest(BackorderPartRequestSetup)


ChangePartRequestStatusSetup Class Properties | fcSDK Documentation

ChangePartRequestStatusSetup Class Properties

For a list of all members of this type, see ChangePartRequestStatusSetup members.

Public Properties

 | Name | Description
Public Property | ChangeDate | The DateTime the Part Request status was changed. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewStatus | The new status for the Part Request for the current condition. If not set, the default status is used.
Public Property | Notes | Notes about the status change for the Part Request
Public Property | PartRequestDetailIDNum | Part Request Detail Identifier
Public Property | UserName | The user who is changing the status of the Part Request. If not set, the session user is used.

Reference

ChangePartRequestStatusSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitChangePartRequestStatus(ChangePartRequestStatusSetup)


ClosePartRequestSetup Class Properties | fcSDK Documentation

ClosePartRequestSetup Class Properties

For a list of all members of this type, see ClosePartRequestSetup members.

Public Properties

 | Name | Description
Public Property | CloseDate | The DateTime the Part Request was closed. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewStatus | The new status for the Part Request from the Closed condition. If not set, the default status is used.
Public Property | PartRequestDetailIDNum | Part Request Detail Identifier
Public Property | UserName | The user who is closing the Part Request. If not set, the session user is used.

Reference

ClosePartRequestSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitClosePartRequest(ClosePartRequestSetup)


CreateContainerSetup Class Properties | fcSDK Documentation

CreateContainerSetup Class Properties

For a list of all members of this type, see CreateContainerSetup members.

Public Properties

 | Name | Description
Public Property | BinName |
Public Property | ContainerName |
Public Property | LocationName |

Reference

CreateContainerSetup Class
FChoice.Toolkits.Clarify.Logistics Namespace


CreatePartRequestDetailResult Class Properties | fcSDK Documentation

CreatePartRequestDetailResult Class Properties

For a list of all members of this type, see CreatePartRequestDetailResult members.

Public Properties

 | Name | Description
Public Property | DetailNumber | Detail Number.
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)

Reference

CreatePartRequestDetailResult Class
FChoice.Toolkits.Clarify.Logistics Namespace


CreatePartRequestDetailResult Constructor | fcSDK Documentation

CreatePartRequestDetailResult Constructor

Overload List

Overload | Description
CreatePartRequestDetailResult Constructor |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CreatePartRequestDetailResult Class
CreatePartRequestDetailResult Members


CreatePartRequestDetailSetup Class Properties | fcSDK Documentation

CreatePartRequestDetailSetup Class Properties

For a list of all members of this type, see CreatePartRequestDetailSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CarrierName | Element from the 'Carrier' application list. If not set the default list value is used.
Public Property | ContractItemObjid | Objid of contract line item with which to link this Part Request -- see remarks for special usage
Public Property | CreateDate | The DateTime the Part Request was created. If not set, the current time is used.
Public Property | DetailType | Element from the 'RMA Type' application list. If not set the default list value is used.
Public Property | DueDate | The DateTime the Part Request is due. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | HasWarranty | Specifies whether this Part Request Detail is under warranty (true) or not (false)
Public Property | Notes | Notes about the Part Request Detail creation
Public Property | PartDomain | The Part Request domain
Public Property | PartNumber | The Part Request number
Public Property | PartRequestHeaderIDNum | Parent Part Request Header Identifier
Public Property | PartRevision | The Part Request revision
Public Property | Priority | Element from the 'Request Priority' application list. If not set the default list value is used.
Public Property | Quantity | The number of parts requested
Public Property | Queue | The name of the Queue to dispatch this Part Request to when created. If blank, the Part Request is not dispatched automatically.
Public Property | SerialNumber | The serial number of the Site Part specified for this Part Request
Public Property | ShippingMethod | Element from the 'Ship Via' application list. If not set the default list value is used.
Public Property | SitePartObjid | The Objid of the Site Part to which this Part Request will be linked.
Public Property | Status | The new status for the Part Request for the Open condition. If not set, the default status is used.
Public Property | UserName | The user creating the Part Request Detail. If not set, the session user is used.

Reference

CreatePartRequestDetailSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitCreatePartRequestDetail(CreatePartRequestDetailSetup)


CreatePartRequestHeaderCaseSetup Class Properties | fcSDK Documentation

CreatePartRequestHeaderCaseSetup Class Properties

For a list of all members of this type, see CreatePartRequestHeaderCaseSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | BillSiteIDNum | Identifier of the Site where the Part Request should be billed
Public Property | CaseIDNum | The identifier of the Case with which this Part Request is associated
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | ContractObjid | Objid of contract with which to link this Part Request -- see remarks for special usage
Public Property | CreateDate | The DateTime the Part Request was created. If not set, the current time is used.
Public Property | Notes | Notes about the Part Request Header creation
Public Property | PaymentMethod | Element from the 'Payment Method' application list. If not set the default list value is used.
Public Property | PaymentTerms | Element from the 'Payment Terms' application list. If not set the default list value is used.
Public Property | Priority | Element from the 'Request Priority' application list. If not set the default list value is used.
Public Property | ShipToSiteIDNum | Identifier of the Site where this Part Request is being shipped
Public Property | UserName | The user who is creating the Part Request. If not set, the session user is used.

Reference

CreatePartRequestHeaderCaseSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitCreatePartRequestHeaderCase(CreatePartRequestHeaderCaseSetup)


CreatePartRequestHeaderSetup Class Properties | fcSDK Documentation

CreatePartRequestHeaderSetup Class Properties

For a list of all members of this type, see CreatePartRequestHeaderSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | BillSiteIDNum | Identifier of the Site where this Part Request should be billed
Public Property | CaseIDNum | Identifier of the Case with which this Part Request is associated
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | ContractObjid | Objid of contract with which to link this Part Request -- see remarks for special usage
Public Property | CreateDate | The DateTime the Part Request was created. If not set, the current time is used.
Public Property | Notes | Notes about the Part Request Header creation
Public Property | PaymentMethod | Element from the 'Payment Method' application list. If not set the default list value is used.
Public Property | PaymentTerms | Element from the 'Payment Terms' application list. If not set the default list value is used.
Public Property | Priority | Element from the 'Request Priority' application list. If not set the default list value is used.
Public Property | ShipToSiteIDNum | Identifier of the Site where this Part Request should be shipped
Public Property | UserName | The user who creates the Part Request. If not set, the session user is used.

Reference

CreatePartRequestHeaderSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitCreatePartRequestHeader(CreatePartRequestHeaderSetup)


CreatePartRequestHeaderSubcaseSetup Class Properties | fcSDK Documentation

CreatePartRequestHeaderSubcaseSetup Class Properties

For a list of all members of this type, see CreatePartRequestHeaderSubcaseSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | BillSiteIDNum | Identifier of the Site where this Part Request should be billed
Public Property | CaseIDNum | Identifier of the Subcase with which this Part Request is associated
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | ContractObjid | Objid of contract with which to link this Part Request -- see remarks for special usage
Public Property | CreateDate | The DateTime the Part Request was created. If not set, the current time is used.
Public Property | Notes | Notes about the Part Request Header creation
Public Property | PaymentMethod | Element from the 'Payment Method' application list. If not set the default list value is used.
Public Property | PaymentTerms | Element from the 'Payment Terms' application list. If not set the default list value is used.
Public Property | Priority | Element from the 'Request Priority' application list. If not set the default list value is used.
Public Property | ShipToSiteIDNum | Identifier of the site where this Part Request should be shipped
Public Property | UserName | The user who creates the Part Request. If not set, the session user is used.

Reference

CreatePartRequestHeaderSubcaseSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitCreatePartRequestHeaderSubcase(CreatePartRequestHeaderSubcaseSetup)


CreateSubContainerSetup Class Properties | fcSDK Documentation

CreateSubContainerSetup Class Properties

For a list of all members of this type, see CreateSubContainerSetup members.

Public Properties

 | Name | Description
Public Property | ContainerName |
Public Property | ParentContainerName |

Reference

CreateSubContainerSetup Class
FChoice.Toolkits.Clarify.Logistics Namespace


DeleteAlternatePartSetup Class Properties | fcSDK Documentation

DeleteAlternatePartSetup Class Properties

For a list of all members of this type, see DeleteAlternatePartSetup members.

Public Properties

 | Name | Description
Public Property | AlternatePartDomain | The Alternate Part domain
Public Property | AlternatePartNumber | The Alternate Part number
Public Property | AlternatePartRevision | The Alternate Part revision
Public Property | PartDomain | The Part domain
Public Property | PartNumber | The Part number
Public Property | PartRevision | The Part revision

Reference

DeleteAlternatePartSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitDeleteAlternatePart(DeleteAlternatePartSetup)


DeleteLocationServicingSiteSetup Class Properties | fcSDK Documentation

DeleteLocationServicingSiteSetup Class Properties

For a list of all members of this type, see DeleteLocationServicingSiteSetup members.

Public Properties

 | Name | Description
Public Property | LocationName | The inventory location being removed
Public Property | SiteIDNum | Identifier of the Site that the inventory location was servicing

Reference

DeleteLocationServicingSiteSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitDeleteLocationServicingSite(DeleteLocationServicingSiteSetup)


DispatchPartRequestSetup Class Properties | fcSDK Documentation

DispatchPartRequestSetup Class Properties

For a list of all members of this type, see DispatchPartRequestSetup members.

Public Properties

 | Name | Description
Public Property | DispatchDate | DateTime the PartRequest was dispatched. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | PartRequestDetailIDNum | Part Request Detail Identifier
Public Property | Queue | The queue into which the PartRequest is to be dispatched.
Public Property | UserName | The user who has dispatched the PartRequest. If not set, the Toolkit session user is used.

Reference

DispatchPartRequestSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitDispatchPartRequest(DispatchPartRequestSetup)


ForwardPartRequestSetup Class Properties | fcSDK Documentation

ForwardPartRequestSetup Class Properties

For a list of all members of this type, see ForwardPartRequestSetup members.

Public Properties

 | Name | Description
Public Property | ForwardDate | DateTime the PartRequest was forwarded. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewQueue | The new queue into which the PartRequest is to be forwarded.
Public Property | Notes | The reason the PartRequest was rejected from the queue into which it was dispatched.
Public Property | PartRequestDetailIDNum | Part Request Detail Identifier
Public Property | UserName | The user who has forwarded the PartRequest. If not set, the Toolkit session user is used.

Reference

ForwardPartRequestSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitForwardPartRequest(ForwardPartRequestSetup)


FulfillPartRequestSetup Class Properties | fcSDK Documentation

FulfillPartRequestSetup Class Properties

For a list of all members of this type, see FulfillPartRequestSetup members.

Public Properties

 | Name | Description
Public Property | FromGood | Specifies whether the fulfilled inventory is from good stock (true) or bad stock (false)
Public Property | FromLocation | The inventory location and bin containing the parts used to fulfill this Part Request
Public Property | FulfillDate | The DateTime the Part Request is fulfilled. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewStatus | The new status for the Part Request for the Fulfilled condition. If not set, the default status is used.
Public Property | PartRequestDetailIDNum | Part Request Detail Identifier
Public Property | Quantity | The number of parts being fulfilled for this Part Request
Public Property | SerialNumber | The serial number of the part used to fulfill this Part Request
Public Property | ToGood | Specifies whether the fulfilled inventory is going to good stock (true) or bad stock (false)
Public Property | ToLocation | The destination inventory location and bin for the parts used to fulfill this Part Request
Public Property | UserName | The user who is fulfilling the Part Request. If not set, the session user is used.
Public Property | UseTransitions | Specifies whether or not logistics transitions will be checked and the condition/status of the part request detail will be changed during the fulfill operation

Reference

FulfillPartRequestSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitFulfillPartRequest(FulfillPartRequestSetup)


GetAlternatePartsResult Class Properties | fcSDK Documentation

GetAlternatePartsResult Class Properties

For a list of all members of this type, see GetAlternatePartsResult members.

Public Properties

 | Name | Description
Public Property | AlternatePartList | An array of Alternate Part objid's.
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)

Reference

GetAlternatePartsResult Class
FChoice.Toolkits.Clarify.Logistics Namespace


GetAlternatePartsResult Constructor | fcSDK Documentation

GetAlternatePartsResult Constructor

Overload List

Overload | Description
GetAlternatePartsResult Constructor |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GetAlternatePartsResult Class
GetAlternatePartsResult Members


GetAlternatePartsSetup Class Properties | fcSDK Documentation

GetAlternatePartsSetup Class Properties

For a list of all members of this type, see GetAlternatePartsSetup members.

Public Properties

 | Name | Description
Public Property | PartDomain | The Part domain
Public Property | PartNumber | The Part number
Public Property | PartRevision | The Part revision

Reference

GetAlternatePartsSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitGetAlternateParts(GetAlternatePartsSetup)


GetLocationsServicingSiteResult Class Properties | fcSDK Documentation

GetLocationsServicingSiteResult Class Properties

For a list of all members of this type, see GetLocationsServicingSiteResult members.

Public Properties

 | Name | Description
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | InventoryLocationObjidList | An array of Inventory Location objid's.
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)

Reference

GetLocationsServicingSiteResult Class
FChoice.Toolkits.Clarify.Logistics Namespace


GetLocationsServicingSiteResult Constructor | fcSDK Documentation

GetLocationsServicingSiteResult Constructor

Overload List

Overload | Description
GetLocationsServicingSiteResult Constructor |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GetLocationsServicingSiteResult Class
GetLocationsServicingSiteResult Members


GetLocationsServicingSiteSetup Class Properties | fcSDK Documentation

GetLocationsServicingSiteSetup Class Properties

For a list of all members of this type, see GetLocationsServicingSiteSetup members.

Public Properties

 | Name | Description
Public Property | SiteIDNum | Identifier of the Site that the inventory locations are servicing

Reference

GetLocationsServicingSiteSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitGetLocationsServicingSite(GetLocationsServicingSiteSetup)


LogisticsToolkit Class Methods | fcSDK Documentation

LogisticsToolkit Class Methods

For a list of all members of this type, see LogisticsToolkit members.

Public Methods

| | Name | Description | | --- | --- | --- | | Public Method | AcceptPartRequest | Overloaded. Accept the specified PartRequest from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API. | | Public Method | AddAlternatePart | Overloaded. Causes the second part/revision listed to become an alternate part of the first one listed. This overload takes a set of required parameters for the API. | | Public Method | AddGLAccount | Overloaded. Used to add expense and capital GL accounts to Clarify. This overload takes a set of required parameters for the API. | | Public Method | AddInventoryBin | Overloaded. Used to add inventory bins to existing locations. This overload takes a set of required parameters for the API. | | Public Method | AddInventoryLocation | Overloaded. Used to add inventory locations to the system.

This overload takes a set of required parameters for the API. | | Public Method | AddLocationServicingSite | Overloaded. Used to relate sites to the inventory locations that service them. This overload takes a set of required parameters for the API. | | Public Method | AssignPartRequest | Overloaded. Assign the PartRequest to a new user. This overload takes a set of required parameters for the API. | | Public Method | BackorderPartRequest | Overloaded. Allows for the backordering of inventory parts for a part request. This overload takes a set of required parameters for the API. | | Public Method | ChangePartRequestStatus | Overloaded. Causes the specified part request to have a status change from one status to another status – always in the same condition. This overload takes a set of required parameters for the API. | | Public Method | ClosePartRequest | Overloaded. Causes the specified part request to be closed. This overload takes a set of required parameters for the API. | | Public Method | CreateContainer | Overloaded. | | Public Method | CreatePartRequestDetail | Overloaded.

Used to create a new part request detail.

This overload takes a set of required parameters for the API. | | Public Method | CreatePartRequestHeader | Overloaded.

Used to create a new part request header.

This overload takes a set of required parameters for the API. | | Public Method | CreatePartRequestHeaderCase | Overloaded.

Used to create a new part request header against a case.

This overload takes a set of required parameters for the API. | | Public Method | CreatePartRequestHeaderSubcase | Overloaded.

Used to create a new part request header against a subcase.

This overload takes a set of required parameters for the API. | | Public Method | CreateSubContainer | Overloaded. | | Public Method | DeleteAlternatePart | Overloaded. Causes the second part/revision listed to be removed as an alternate part for the first. This overload takes a set of required parameters for the API. | | Public Method | DeleteLocationServicingSite | Overloaded. Used to remove the relationship between a site and a location servicing it. This overload takes a set of required parameters for the API. | | Public Method | DispatchPartRequest | Overloaded. Dispatch the PartRequest to the specified queue. This overload takes a set of required parameters for the API. | | Public Method | ForwardPartRequest | Overloaded. Reject-forward the PartRequest from one queue to another. This overload takes a set of required parameters for the API. | | Public Method | FulfillPartRequest | Overloaded. Allows for the fulfilling of inventory parts for a part request. This overload takes a set of required parameters for the API. | | Public Method | GetAlternateParts | Overloaded. Builds a list of the alternate parts (table_partnum_view) for the specified part and revision, and returns an array of part Objids This overload takes a set of required parameters for the API. | | Public Method | GetLocationsServicingSite | Overloaded. Returns a list of the locations (in the proper order) servicing this site. This overload takes a set of required parameters for the API. | | Public Method | MovePartRequest | Overloaded. Move the PartRequest from one WipBin to another WipBin. This overload takes a set of required parameters for the API. | | Public Method | OpenContainer | Overloaded. | | Public Method | PartTransfer | Overloaded.

Allows parts to be transferred independent of a part request to fix order errors, correct inventory variances, move parts from one inventory location (or account) to another (without having to relate that movement to a part request), and scrap parts out of inventory.

This overload takes a set of required parameters for the API. | | Public Method | Pick | Overloaded.

Allows for multiple pick actions to occur against a part request.

This overload takes a set of required parameters for the API. | | Public Method | ReceivePartRequest | Overloaded.

Causes the specified part request to have units received against it.

This overload takes a set of required parameters for the API. | | Public Method | RejectPartRequest | Overloaded. Reject the PartRequest from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API. | | Public Method | ReopenPartRequest | Overloaded.

Causes the specified part request to be reopened.

This overload takes a set of required parameters for the API. | | Public Method | SealContainer | Overloaded. | | Public Method | SetLogisticsTransition | Overloaded. Allows you to create or modify Logistics Transitions in the database. This overload takes a set of required parameters for the API. | | Public Method | SetPartStockingLevel | Overloaded. Creates a part restocking authorization level. This overload takes a set of required parameters for the API. | | Public Method | Ship | Overloaded.

Causes the specified part request to be shipped.

This overload takes a set of required parameters for the API. | | Public Method | Unpick | Overloaded.

Allows for the unpicking (unreserving) of inventory parts for a part request.

This overload takes a set of required parameters for the API. | | Public Method | UpdateGLAccount | Overloaded. Used to modify existing GL accounts. This overload takes a set of required parameters for the API. | | Public Method | UpdateInventoryBin | Overloaded. Used to modify the name or the active flag of an existing bin. This overload takes a set of required parameters for the API. | | Public Method | UpdateInventoryLocation | Overloaded.

Used to modify inventory locations in the system.

This overload takes a setup object. | | Public Method | UpdateLocationServicingSite | Overloaded. Used to change the order of the locations servicing a site. This overload takes a set of required parameters for the API. | | Public Method | UpdatePartRequestDetail | Overloaded.

Allow for the updating of part request details.

This overload takes a setup object. | | Public Method | UpdatePartRequestHeader | Overloaded.

Allow for the updating of part request headers.

This overload takes a setup object. | | Public Method | UpdatePartStockingLevel | Overloaded. Updates an existing part restocking authorization level. This overload takes a set of required parameters for the API. | | Public Method | YankPartRequest | Overloaded. Yank the PartRequest from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API. |

Reference

LogisticsToolkit Class
FChoice.Toolkits.Clarify.Logistics Namespace


LogisticsToolkit Class Properties | fcSDK Documentation

LogisticsToolkit Class Properties

For a list of all members of this type, see LogisticsToolkit members.

Public Properties

 | Name | Description
Public Property | ImpersonatorUsername | (Inherited from FChoice.Toolkits.Clarify.Logistics.LogisticsToolkitBase)

Reference

LogisticsToolkit Class
FChoice.Toolkits.Clarify.Logistics Namespace


LogisticsToolkitBase Class Properties | fcSDK Documentation

LogisticsToolkitBase Class Properties

For a list of all members of this type, see LogisticsToolkitBase members.

Public Properties

 | Name | Description
Public Property | ImpersonatorUsername |

Reference

LogisticsToolkitBase Class
FChoice.Toolkits.Clarify.Logistics Namespace


MovePartRequestSetup Class Properties | fcSDK Documentation

MovePartRequestSetup Class Properties

For a list of all members of this type, see MovePartRequestSetup members.

Public Properties

 | Name | Description
Public Property | NewWipBin | The new WipBin into which the PartRequest is to be moved.
Public Property | PartRequestDetailIDNum | Part Request Detail Identifier

Reference

MovePartRequestSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitMovePartRequest(MovePartRequestSetup)


OpenContainerSetup Class Properties | fcSDK Documentation

OpenContainerSetup Class Properties

For a list of all members of this type, see OpenContainerSetup members.

Public Properties

 | Name | Description
Public Property | ContainerName |

Reference

OpenContainerSetup Class
FChoice.Toolkits.Clarify.Logistics Namespace


PartTransferResult Class Properties | fcSDK Documentation

PartTransferResult Class Properties

For a list of all members of this type, see PartTransferResult members.

Public Properties

 | Name | Description
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | StandardCost | Part Transfer Standard Cost.
Public Property | TransactionIDNum | Part Transfer Transaction Identifier.

Reference

PartTransferResult Class
FChoice.Toolkits.Clarify.Logistics Namespace


PartTransferSetup Class Properties | fcSDK Documentation

PartTransferSetup Class Properties

For a list of all members of this type, see PartTransferSetup members.

Public Properties

 | Name | Description
Public Property | FromGood | Specifies whether the part is being transferred from good stock (true) or bad stock (false)
Public Property | FromLocation | Inventory location (or expense GL) and bin from which to transfer the part
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Notes | Notes about the Part Transfer
Public Property | PartDomain | Part domain for the Part Request
Public Property | PartNumber | Part number for the Part Request
Public Property | PartRevision | Part revision for the Part Request
Public Property | Quantity | The number of parts being transferred
Public Property | ReferenceIDNum | Optional reference number for this part transfer
Public Property | SerialNumber | The serial number of the part being transferred
Public Property | ToGood | Specifies whether the part is being transferred resulting in good stock (true) or bad stock (false)
Public Property | ToLocation | Inventory location and bin (or GL account) into which the part is being transferred
Public Property | TransferDate | The DateTime the Parts are transferred. If not set, the current time is used.
Public Property | UserName | The user who is transferring the Part. If not set, the session user is used.

Reference

PartTransferSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitPartTransfer(PartTransferSetup)


PickResult Class Properties | fcSDK Documentation

PickResult Class Properties

For a list of all members of this type, see PickResult members.

Public Properties

 | Name | Description
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | TotalPicked | The total number of parts picked.

Reference

PickResult Class
FChoice.Toolkits.Clarify.Logistics Namespace


PickResult Constructor | fcSDK Documentation

PickResult Constructor

Overload List

Overload | Description
PickResult Constructor |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

PickResult Class
PickResult Members


PickSetup Class Properties | fcSDK Documentation

PickSetup Class Properties

For a list of all members of this type, see PickSetup members.

Public Properties

 | Name | Description
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Locations | Specifies the inventory locations which will be searched in order to find the parts to pick for this Part Request.
Public Property | NewStatus | The new status for the Part Request for the Picked condition. If not set, the default status is used.
Public Property | PartRequestDetailIDNum | Part Request Detail Identifier
Public Property | PickDate | The DateTime the Part Request is picked. If not set, the current time is used.
Public Property | SerialNumbers | The serial number(s) of the part(s) to pick (hard pick)
Public Property | UseGood | Specifies wheterh the picked inventory is from good stock (true) or bad stock (false)
Public Property | UserName | The user who is picking the Part Request. If not set, the session user is used.
Public Property | UseTransitions | Specifies whether or not to check logistics transitions and change the condition/status of the Part Request Detail during the Pick operation

Reference

PickSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitPick(PickSetup)


ReceivePartRequestSetup Class Properties | fcSDK Documentation

ReceivePartRequestSetup Class Properties

For a list of all members of this type, see ReceivePartRequestSetup members.

Public Properties

 | Name | Description
Public Property | AutoClose | Specifies whether the Part Request should be closed if all of the inventory for this Part Request is received (or an overage). If it is already closed, and no other details exist for the header, this parameter specifies whether the Part Request Header should be closed as well.
Public Property | CarrierName | Element from the 'Carrier' application list. If not set the default list value is used.
Public Property | FromGood | Specifies whether the received inventory from is good stock (true) or bad stock (false)
Public Property | FromLocation | Inventory location (or expense GL) from which to receive.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NotProperlyPacked | Specifies whether the received inventory is (true) or is not (false) properly packed
Public Property | PartRequestDetailIDNum | Part Request Detail Identifier
Public Property | PossibleDamage | Specifies whether the received inventory is possibly damaged (true) or not (false)
Public Property | Quantity | The number of parts being received for this Part Request
Public Property | ReceiveDate | The DateTime the Part Request is received. If not set, the current time is used.
Public Property | RouteToTest | Specifies whether the received stock should be routed to test (true) or not (false)
Public Property | SerialNumber | The serial number of the part being Received for this Part Request
Public Property | Status | The new status for the Part Request for the Received condition. If not set, the default status is used.
Public Property | ToGood | Specifies whether the received inventory is being received as good stock (true) or bad stock (false)
Public Property | ToLocation | Inventory location (or expense GL) into which the stock will be received
Public Property | UserName | The user who is receiving the Part Request. If not set, the Toolkit session user is used.
Public Property | UseTransitions | Specifies whether or not to change the Part Request condition
Public Property | WaybillName | Waybill information for this Part Request receipt

Reference

ReceivePartRequestSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitReceivePartRequest(ReceivePartRequestSetup)


RejectPartRequestSetup Class Properties | fcSDK Documentation

RejectPartRequestSetup Class Properties

For a list of all members of this type, see RejectPartRequestSetup members.

Public Properties

 | Name | Description
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Notes | The reason the PartRequest was rejected from the queue into which it was dispatched.
Public Property | PartRequestDetailIDNum | Part Request Detail Identifier
Public Property | RejectDate | DateTime the PartRequest was rejected. If not set, the current time is used.
Public Property | UserName | The user who has rejected the PartRequest. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the PartRequest. If not set, the UserName's default is used.

Reference

RejectPartRequestSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitRejectPartRequest(RejectPartRequestSetup)


ReopenPartRequestSetup Class Properties | fcSDK Documentation

ReopenPartRequestSetup Class Properties

For a list of all members of this type, see ReopenPartRequestSetup members.

Public Properties

 | Name | Description
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewStatus | The new status for the Part Request for the Reopened condition. If not set, the default status is used.
Public Property | PartRequestDetailIDNum | Part Request Detail Identifier
Public Property | ReopenDate | The DateTime the Part Request is reopened. If not set, the current time is used.
Public Property | UserName | The user who is reopening the Part Request. If not set, the session user is used.
Public Property | WipBin | The WipBin in which to place the Part Request when it is reopened. If not specified, the default WipBin for the session user is used.

Reference

ReopenPartRequestSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitReopenPartRequest(ReopenPartRequestSetup)


SealContainerSetup Class Properties | fcSDK Documentation

SealContainerSetup Class Properties

For a list of all members of this type, see SealContainerSetup members.

Public Properties

 | Name | Description
Public Property | ContainerName |

Reference

SealContainerSetup Class
FChoice.Toolkits.Clarify.Logistics Namespace


SetLogisticsTransitionSetup Class Properties | fcSDK Documentation

SetLogisticsTransitionSetup Class Properties

For a list of all members of this type, see SetLogisticsTransitionSetup members.

Public Properties

 | Name | Description
Public Property | EndCondition | Ending condition of the Part Request for this transition
Public Property | PartRequestType | Type of Part Request that this transition applies to
Public Property | PrivilegeClasses | An array of Strings which are the names of the privilege classes allowed to perform this transition
Public Property | StartCondition | Starting condition of the Part Request for this transition

Reference

SetLogisticsTransitionSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitSetLogisticsTransition(SetLogisticsTransitionSetup)


SetPartStockingLevelSetup Class Properties | fcSDK Documentation

SetPartStockingLevelSetup Class Properties

For a list of all members of this type, see SetPartStockingLevelSetup members.

Public Properties

 | Name | Description
Public Property | IsActive | Specifies whether this restocking entry is active (true) or inactive (false)
Public Property | Location | The names of the restocking location/bin
Public Property | PartDomain | Part domain of the Part
Public Property | PartMaximum | Maximum quantity of parts allowed in this inventory location
Public Property | PartMinimum | Minimum quantity of parts allowed in this inventory location
Public Property | PartNumber | Part number for the Part
Public Property | PartReorderLevel | The quantity of parts that will trigger a reorder Part Request to be created for this inventory location
Public Property | PartReorderQuantity | Quantity of parts to be reordered for this inventory location when reorder level is reached
Public Property | PartRevision | Part revision of the Part
Public Property | Queue | The queue to which the reorder part request will be dispatched

Reference

SetPartStockingLevelSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitSetPartStockingLevel(SetPartStockingLevelSetup)


ShipSetup Class Properties | fcSDK Documentation

ShipSetup Class Properties

For a list of all members of this type, see ShipSetup members.

Public Properties

 | Name | Description
Public Property | Address1 | Address of the site where this Part Request will be shipped
Public Property | Address2 | Other address information for the site where this Part Request will be shipped
Public Property | CarrierName |
The site name of the shipment's carrier. The default will be the dummy site (objid of -2). |  |
Public Property | City | City of the site where this Part Request will be shipped
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | Country | Country of the site where this Part Request will be shipped
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | PackingList | Packing list information for the shipment
Public Property | PartRequestDetailIDNum | Part Request Detail Identifier
Public Property | PieceCount | The number of pieces being shipped for this Part Request
Public Property | ShipDate | The DateTime the Part Request is shipped. If not set, the current time is used.
Public Property | SiteName | Name of the site where this Part Request will be shipped
Public Property | State | State of the Site where this Part Request will be shipped
Public Property | Status | The new status for the Part Request for the Shipped condition. If not set, the default status is used.
Public Property | TotalWeight | Total weight of the pieces being shipped for this Part Request
Public Property | UserName | The user who is shipping the Part Request. If not set, the session user is used.
Public Property | WaybillName | Waybill information for this Part Request shipment
Public Property | ZipCode | Zipcode of the site where this Part Request will be shipped

Reference

ShipSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitShip(ShipSetup)


UnpickSetup Class Properties | fcSDK Documentation

UnpickSetup Class Properties

For a list of all members of this type, see UnpickSetup members.

Public Properties

 | Name | Description
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Location | The inventory location to unpick the part from for this Part Request
Public Property | PartRequestDetailIDNum | Part Request Detail Identifier
Public Property | SerialNumbers | The serial number(s) of the part(s) to unpick (hard unpick)
Public Property | UnpickDate | The DateTime the Part Request is unpicked. If not set, the current time is used.
Public Property | UseGood | Specifies whether the unpicked inventory is from good stock (true) or bad stock (false)
Public Property | UserName | The user who is unpicking the Part Request. If not set, the session user is used.
Public Property | UseTransitions | Specifies whether or not to check logistics transitions and change the condition/status of the Part Request Detail during the Unpick operation

Reference

UnpickSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitUnpick(UnpickSetup)


UpdateGLAccountSetup Class Properties | fcSDK Documentation

UpdateGLAccountSetup Class Properties

For a list of all members of this type, see UpdateGLAccountSetup members.

Public Properties

 | Name | Description
Public Property | AccountNumber | Optional number for the General Ledger account
Public Property | AccountType | Element from the 'Location Type' user list. If not set the default list value is used.
Public Property | CurrentName | Current name of the account
Public Property | Description | Description of the account
Public Property | IsActive | Specifies whether this account is active (true) or inactive (false)
Public Property | IsCompany | Specifies whether this account is company owned (true) or customer owned (false)
Public Property | IsExpenseGLAccount | Specifies whether this is an expense account (true) or a GL account (false)
Public Property | NewName | New name of the account
Public Property | SiteIDNum | Identifier of the Site with which the account is associated

Reference

UpdateGLAccountSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitUpdateGLAccount(UpdateGLAccountSetup)


UpdateInventoryBinSetup Class Properties | fcSDK Documentation

UpdateInventoryBinSetup Class Properties

For a list of all members of this type, see UpdateInventoryBinSetup members.

Public Properties

 | Name | Description
Public Property | CurrentLocation | The inventory location and bin to update
Public Property | IsActive | Specifies whether this inventory bin is active (true) or inactive (false)
Public Property | NewBinName | New name of the inventory bin

Reference

UpdateInventoryBinSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitUpdateInventoryBin(UpdateInventoryBinSetup)


UpdateInventoryLocationSetup Class Properties | fcSDK Documentation

UpdateInventoryLocationSetup Class Properties

For a list of all members of this type, see UpdateInventoryLocationSetup members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AccountType | Element from the 'Location Type' user list. If not set the default list value is used. | | Public Property | CapitalGLAccount | The name of the Capital GL account with which this inventory location is associated

| | Public Property | CurrentName | Current name of the inventory location | | Public Property | Description | Description of the inventory location | | Public Property | IsActive | Specifies whether this inventory location is active (true) or inactive (false) | | Public Property | IsCompany | Specifies whether this account is company owned (true) or customer owned (false) | | Public Property | NewName | New name of the inventory location | | Public Property | PartAuthorizationLevel | The part authorization level for this inventory location. | | Public Property | ReportsToLocation | Name of the inventory location to which this new inventory location reports | | Public Property | SiteIDNum | Identifier of the site with which this inventory location is associated |

Reference

UpdateInventoryLocationSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitUpdateInventoryLocation(UpdateInventoryLocationSetup)


UpdateLocationServicingSiteSetup Class Properties | fcSDK Documentation

UpdateLocationServicingSiteSetup Class Properties

For a list of all members of this type, see UpdateLocationServicingSiteSetup members.

Public Properties

 | Name | Description
Public Property | LocationName | Name of the inventory location
Public Property | LocationRank | The rank of this inventory location at the associated site
Public Property | SiteIDNum | Identifier of the Site that the inventory location is servicing

Reference

UpdateLocationServicingSiteSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitUpdateLocationServicingSite(UpdateLocationServicingSiteSetup)


UpdatePartRequestDetailSetup Class Properties | fcSDK Documentation

UpdatePartRequestDetailSetup Class Properties

For a list of all members of this type, see UpdatePartRequestDetailSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CarrierName | Element from the 'Carrier' application list. If not set the default list value is used.
Public Property | DetailType | Element from the 'RMA Type' application list. If not set the default list value is used.
Public Property | HasWarranty | Specifies whether this Part Request Detail is under warranty (true) or not (false)
Public Property | Notes | Notes about the Part Request Detail update
Public Property | PartDomain | Part domain for the Part
Public Property | PartNumber | Part number for the Part
Public Property | PartRequestDetailIDNum | Part Request Detail Identifier
Public Property | PartRevision | Part revision for the Part
Public Property | Priority | Element from the 'Request Priority' application list. If not set the default list value is used.
Public Property | Quantity | The number of parts for this Part Request
Public Property | SerialNumber | The serial number of the part specified for this Part Request
Public Property | ShippingMethod | Element from the 'Ship Via' application list. If not set the default list value is used.
Public Property | SitePartObjid | The Objid of the Site Part specified for this Part Request
Public Property | Status | The new status for the Part Request for the current condition. If not set, the default status is used.

Reference

UpdatePartRequestDetailSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitUpdatePartRequestDetail(UpdatePartRequestDetailSetup)


UpdatePartRequestHeaderSetup Class Properties | fcSDK Documentation

UpdatePartRequestHeaderSetup Class Properties

For a list of all members of this type, see UpdatePartRequestHeaderSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | BillSiteIDNum | Identifier of the Site where this Part Request should be billed
Public Property | CaseIDNum | Identifier of the Case with which this Part Request Header is associated.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | Notes | Notes about the Part Request Header update
Public Property | PartRequestHeaderIDNum | Part Request Header Identifier
Public Property | PaymentMethod | Element from the 'Payment Method' application list. If not set the default list value is used.
Public Property | PaymentTerms | Element from the 'Payment Terms' application list. If not set the default list value is used.
Public Property | Priority | Element from the 'Request Priority' application list. If not set the default list value is used.
Public Property | ShipToSiteIDNum | Identifier of the Site where this Part Request should be shipped

Reference

UpdatePartRequestHeaderSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitUpdatePartRequestHeader(UpdatePartRequestHeaderSetup)


UpdatePartStockingLevelSetup Class Properties | fcSDK Documentation

UpdatePartStockingLevelSetup Class Properties

For a list of all members of this type, see UpdatePartStockingLevelSetup members.

Public Properties

 | Name | Description
Public Property | CurrentLocation | The location and bin used for restocking
Public Property | IsActive | Specifies whether this restocking is entry active (true) or inactive (false)
Public Property | PartDomain | Part domain for the Part
Public Property | PartMaximum | Maximum quantity of parts allowed in this inventory location
Public Property | PartMinimum | Minimum quantity of parts allowed in this inventory location
Public Property | PartNumber | Part number for the Part
Public Property | PartReorderLevel | The quantity of parts that will trigger a reorder Part Request to be created for this inventory location
Public Property | PartReorderQuantity | Quantity of parts to be reordered for this inventory location when reorder level is reached
Public Property | PartRevision | Part revision for the Part
Public Property | Queue | The queue to which the reorder part request will be dispatched
Public Property | ToBinName | The name of the bin to which the record will be moved. If not set or blank, no move occurs.
Public Property | ToQueue | The new name of the queue to which the reorder part request will be dispatched

Reference

UpdatePartStockingLevelSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitUpdatePartStockingLevel(UpdatePartStockingLevelSetup)


YankPartRequestSetup Class Properties | fcSDK Documentation

YankPartRequestSetup Class Properties

For a list of all members of this type, see YankPartRequestSetup members.

Public Properties

 | Name | Description
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | PartRequestDetailIDNum | Part Request Detail Identifier
Public Property | UserName | The user who has yanked the PartRequest. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the PartRequest. If not set, the UserName's default is used.
Public Property | YankDate | DateTime the PartRequest was yanked. If not set, the current time is used.

Reference

YankPartRequestSetup Class FChoice.Toolkits.Clarify.Logistics Namespace FChoice.Toolkits.ClarifyFChoice.Toolkits.Clarify.Logistics.LogisticsToolkitYankPartRequest(YankPartRequestSetup)


FChoice.Toolkits.Clarify.Logistics Namespace #### Inheritance Hierarchy | fcSDK Documentation

FChoice.Toolkits.Clarify.Logistics Namespace #### Inheritance Hierarchy

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Logistics.AcceptPartRequestSetup
FChoice.Toolkits.Clarify.Logistics.AddAlternatePartSetup
FChoice.Toolkits.Clarify.Logistics.AddGLAccountSetup
FChoice.Toolkits.Clarify.Logistics.AddInventoryBinSetup
FChoice.Toolkits.Clarify.Logistics.AddInventoryLocationSetup
FChoice.Toolkits.Clarify.Logistics.AddLocationServicingSiteSetup
FChoice.Toolkits.Clarify.Logistics.AssignPartRequestSetup
FChoice.Toolkits.Clarify.Logistics.BackorderPartRequestSetup
FChoice.Toolkits.Clarify.Logistics.ChangePartRequestStatusSetup
FChoice.Toolkits.Clarify.Logistics.ClosePartRequestSetup
FChoice.Toolkits.Clarify.Logistics.CreateContainerSetup
FChoice.Toolkits.Clarify.Logistics.CreatePartRequestDetailSetup
FChoice.Toolkits.Clarify.Logistics.CreatePartRequestHeaderCaseSetup
FChoice.Toolkits.Clarify.Logistics.CreatePartRequestHeaderSetup
FChoice.Toolkits.Clarify.Logistics.CreatePartRequestHeaderSubcaseSetup
FChoice.Toolkits.Clarify.Logistics.CreateSubContainerSetup
FChoice.Toolkits.Clarify.Logistics.DeleteAlternatePartSetup
FChoice.Toolkits.Clarify.Logistics.DeleteLocationServicingSiteSetup
FChoice.Toolkits.Clarify.Logistics.DispatchPartRequestSetup
FChoice.Toolkits.Clarify.Logistics.ForwardPartRequestSetup
FChoice.Toolkits.Clarify.Logistics.FulfillPartRequestSetup
FChoice.Toolkits.Clarify.Logistics.GetAlternatePartsSetup
FChoice.Toolkits.Clarify.Logistics.GetLocationsServicingSiteSetup
FChoice.Toolkits.Clarify.Logistics.MovePartRequestSetup
FChoice.Toolkits.Clarify.Logistics.OpenContainerSetup
FChoice.Toolkits.Clarify.Logistics.PartTransferSetup
FChoice.Toolkits.Clarify.Logistics.PickSetup
FChoice.Toolkits.Clarify.Logistics.ReceivePartRequestSetup
FChoice.Toolkits.Clarify.Logistics.RejectPartRequestSetup
FChoice.Toolkits.Clarify.Logistics.ReopenPartRequestSetup
FChoice.Toolkits.Clarify.Logistics.SealContainerSetup
FChoice.Toolkits.Clarify.Logistics.SetLogisticsTransitionSetup
FChoice.Toolkits.Clarify.Logistics.SetPartStockingLevelSetup
FChoice.Toolkits.Clarify.Logistics.ShipSetup
FChoice.Toolkits.Clarify.Logistics.UnpickSetup
FChoice.Toolkits.Clarify.Logistics.UpdateGLAccountSetup
FChoice.Toolkits.Clarify.Logistics.UpdateInventoryBinSetup
FChoice.Toolkits.Clarify.Logistics.UpdateInventoryLocationSetup
FChoice.Toolkits.Clarify.Logistics.UpdateLocationServicingSiteSetup
FChoice.Toolkits.Clarify.Logistics.UpdatePartRequestDetailSetup
FChoice.Toolkits.Clarify.Logistics.UpdatePartRequestHeaderSetup
FChoice.Toolkits.Clarify.Logistics.UpdatePartStockingLevelSetup
FChoice.Toolkits.Clarify.Logistics.YankPartRequestSetup
FChoice.Toolkits.Clarify.ToolkitBase
FChoice.Toolkits.Clarify.Logistics.LogisticsToolkitBase
FChoice.Toolkits.Clarify.Logistics.LogisticsToolkit
FChoice.Toolkits.Clarify.ToolkitResult
FChoice.Toolkits.Clarify.Logistics.CreatePartRequestDetailResult
FChoice.Toolkits.Clarify.Logistics.GetAlternatePartsResult
FChoice.Toolkits.Clarify.Logistics.GetLocationsServicingSiteResult
FChoice.Toolkits.Clarify.Logistics.PartTransferResult
FChoice.Toolkits.Clarify.Logistics.PickResult

Reference

FChoice.Toolkits.Clarify Assembly


PartInfo Class Fields | fcSDK Documentation

PartInfo Class Fields

For a list of all members of this type, see PartInfo members.

Public Fields

 | Name | Description
Public Field | modSetupResult |
Public Field | PartDomain |
Public Field | PartNotes |
Public Field | PartNumber |
Public Field | PartRevision |
Public Field | partSetupResult |
Public Field | Price |
Public Field | PriceProgram |
Public Field | priceSetupResult |
Public Field | PriceType |
Public Field | Quantity |
Public Field | RepairType |

Reference

PartInfo Class
FChoice.Toolkits.Clarify Namespace


PartRequestInfo Class Fields | fcSDK Documentation

PartRequestInfo Class Fields

For a list of all members of this type, see PartRequestInfo members.

Public Fields

 | Name | Description
Public Field | ContactFirstName |
Public Field | ContactLastName |
Public Field | ContactPhone |
Public Field | ContactResult |
Public Field | PartDomain |
Public Field | PartNumber |
Public Field | PartQuantity |
Public Field | PartRequestDetailResult |
Public Field | PartRequestHeaderResult |
Public Field | PartRevision |
Public Field | PartRevisionResult |
Public Field | SiteResult |

Reference

PartRequestInfo Class
FChoice.Toolkits.Clarify Namespace


PropertyBitValueAttribute Class Fields | fcSDK Documentation

PropertyBitValueAttribute Class Fields

For a list of all members of this type, see PropertyBitValueAttribute members.

Public Fields

 | Name | Description
Public Field | Value |

Reference

PropertyBitValueAttribute Class
FChoice.Toolkits.Clarify Namespace


PropertyBitValueAttribute Class Methods | fcSDK Documentation

PropertyBitValueAttribute Class Methods

For a list of all members of this type, see PropertyBitValueAttribute members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)

Reference

PropertyBitValueAttribute Class
FChoice.Toolkits.Clarify Namespace


PropertyBitValueAttribute Class Properties | fcSDK Documentation

PropertyBitValueAttribute Class Properties

For a list of all members of this type, see PropertyBitValueAttribute members.

Public Properties

 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)

Reference

PropertyBitValueAttribute Class
FChoice.Toolkits.Clarify Namespace


AcceptCRSetup Class Properties | fcSDK Documentation

AcceptCRSetup Class Properties

For a list of all members of this type, see AcceptCRSetup members.

Public Properties

 | Name | Description
Public Property | AcceptDate | DateTime the CR was accepted. If not set, the current time is used.
Public Property | CRIDNum | CR Identifier.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | UserName | The user who has accepted the CR. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the CR. If not set, the UserName's default is used.

Reference

AcceptCRSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
AcceptCR(AcceptCRSetup) Method


AddModuleToCRSetup Class Properties | fcSDK Documentation

AddModuleToCRSetup Class Properties

For a list of all members of this type, see AddModuleToCRSetup members.

Public Properties

 | Name | Description
Public Property | FileName | Name of the file related to the fix.
Public Property | FileRevision | Revision information for the file related to the fix.
Public Property | FixObjid | Objid of the Fixed CR.

Reference

AddModuleToCRSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
AddModuleToCR(AddModuleToCRSetup) Method


AssignCRSetup Class Properties | fcSDK Documentation

AssignCRSetup Class Properties

For a list of all members of this type, see AssignCRSetup members.

Public Properties

 | Name | Description
Public Property | AssignDate | DateTime the CR was assigned. If not set, the current time is used.
Public Property | CRIDNum | CR Identifier.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewUser | The new user to which the CR is to be assigned.
Public Property | UserName | The user who has assigned the CR. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the CR. If not set, the UserName's default is used.

Reference

AssignCRSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
AssignCR(AssignCRSetup) Method


ChangeCRStatusSetup Class Properties | fcSDK Documentation

ChangeCRStatusSetup Class Properties

For a list of all members of this type, see ChangeCRStatusSetup members.

Public Properties

 | Name | Description
Public Property | ChangeDate | DateTime the CR status was changed. If not set, the current date time is used.
Public Property | CRIDNum | Change Request Identifier
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewStatus | The new status for the Change Request. If not set, the default status is used.
Public Property | Notes | Notes about the status change for the Change Request.
Public Property | UserName | The user changing CR status. If not set, the session user is used.

Reference

ChangeCRStatusSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
ChangeCRStatus(ChangeCRStatusSetup) Method


CheckClearQualityTransitionSetup Class Properties | fcSDK Documentation

CheckClearQualityTransitionSetup Class Properties

For a list of all members of this type, see CheckClearQualityTransitionSetup members.

Public Properties

 | Name | Description
Public Property | NewCondition | The new condition for the Change Request.
Public Property | NewStatus | The new status for the Change Request.
Public Property | OldCondition | The current condition of the Change Request.
Public Property | OldStatus | The current status of the Change Request.
Public Property | UserName | The user checking the transition. If not set, the session user is used.

Reference

CheckClearQualityTransitionSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
CheckClearQualityTransition(CheckClearQualityTransitionSetup) Method


CloseCRSetup Class Properties | fcSDK Documentation

CloseCRSetup Class Properties

For a list of all members of this type, see CloseCRSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CloseDate | When Change Request was closed. If not set, the current date time is used.
Public Property | CRIDNum | Change Request Identifier
Public Property | FixedInRelease | Release information for the closure
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Notes | Notes about the closing of the Change Request.
Public Property | Status | The closed condition status for the Change Request. If not set, the default closed condition status is used.
Public Property | TestCase | Test case name for the Change Request closing
Public Property | UserName | The user closing the CR. If not set, the session user is used.

Reference

CloseCRSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
CloseCR(CloseCRSetup) Method


CreateCRSetup Class Properties | fcSDK Documentation

CreateCRSetup Class Properties

For a list of all members of this type, see CreateCRSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CRClass | Element from the 'CR Class' application list. If not set the default list value is used.
Public Property | CreateDate | When Change Request was created. If not set, the current date time is used.
Public Property | CRType | Element from the 'CR Type' application list. If not set, the default list value is used.
Public Property | Description | Notes about the Change Request. If not set, no notes are logged.
Public Property | FixedIn | Element from the 'Fix Release' application list. If not set, the default list value is used.
Public Property | FoundOnCPU | Element from level 1 of the 'CR_DESC' user-defined list. If not set, the default list value is used.
Public Property | Frequency | Element from the 'CR Reproducible' application list. If not set, the default list value is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | IntroductionPhase | Element from the 'CR Domain' application list. If not set, the default list value is used.
Public Property | Memory | Element from level 3 of the 'CR_DESC' user-defined list. If not set the default list value is used.
Public Property | OperatingSystem | Element from level 2 of the 'CR_DESC' user-defined list. If not set the default list value is used.
Public Property | PartDomain | Part domain of part for the Change Request
Public Property | PartNumber | Part number of part for the Change Request
Public Property | PartRevision | Part revision of part for the Change Request
Public Property | Priority | Element from the 'CR Priority' application list. If not set, the default list value is used.
Public Property | Queue | Queue where the CR will be dispatched.
Public Property | Status | The initial open condition status for the Change Request. If not set, the default open condition status is used.
Public Property | TestClass | Element from the 'CR Class' application list. If not set, the default list value is used.
Public Property | Title | The title of the Change Request
Public Property | UserName | The user creating the CR. If not set, the session user is used.
Public Property | VerificationTest | List of verification tests for the Change Request

Reference

CreateCRSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
CreateCR(CreateCRSetup) Method


DispatchCRSetup Class Properties | fcSDK Documentation

DispatchCRSetup Class Properties

For a list of all members of this type, see DispatchCRSetup members.

Public Properties

 | Name | Description
Public Property | CRIDNum | CR Identifier.
Public Property | DispatchDate | DateTime the CR was dispatched. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Queue | The queue into which the CR is to be dispatched.
Public Property | UserName | The user who has dispatched the CR. If not set, the Toolkit session user is used.

Reference

DispatchCRSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
DispatchCR(DispatchCRSetup) Method


DuplicateCRSetup Class Properties | fcSDK Documentation

DuplicateCRSetup Class Properties

For a list of all members of this type, see DuplicateCRSetup members.

Public Properties

 | Name | Description
Public Property | CloseDate | DateTime the CR was closed. If not set, the current date time is used.
Public Property | CRIDNum | Identifier of the CR being marked as a duplicate.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | MasterCRIDNum | Identifier of the 'master' CR this CR duplicates.
Public Property | Status | The new status for the duplicate Change Request. If not set, the default status is used.
Public Property | UserName | The user duplicating the CR. If not set, the session user is used.

Reference

DuplicateCRSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
DuplicateCR(DuplicateCRSetup) Method


FixCRSetup Class Properties | fcSDK Documentation

FixCRSetup Class Properties

For a list of all members of this type, see FixCRSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CRIDNum | Identifier of the CR being set to Fixed.
Public Property | FixDate | DateTime the CR was marked Fixed. If not set, the current date time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Notes | Notes about the CR's the Fix.
Public Property | Status | The new status for the Change Request. If not set, the default status is used.
Public Property | UserName | The user fixing the CR. If not set, the session user is used.

Reference

FixCRSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
FixCR(FixCRSetup) Method


FixFailedSetup Class Properties | fcSDK Documentation

FixFailedSetup Class Properties

For a list of all members of this type, see FixFailedSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CRIDNum | Identifier of the CR being marked as FixFailed.
Public Property | FailedDate | DateTime the CR was maked as FixFailed. If not set, the current date time is used.
Public Property | FixedInRelease | Release information related to the Fixed CR being Failed.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Notes | Notes about the CR being markd FixFailed.
Public Property | Status | The new status for the Change Request. If not set, the default status is used.
Public Property | TestCase | Name of the test case related to the CR Fix being marked as Failed
Public Property | UserName | The user failing the CR. If not set, the session user is used.

Reference

FixFailedSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
FixFailed(FixFailedSetup) Method


ForwardCRSetup Class Properties | fcSDK Documentation

ForwardCRSetup Class Properties

For a list of all members of this type, see ForwardCRSetup members.

Public Properties

 | Name | Description
Public Property | CRIDNum | CR Identifier.
Public Property | ForwardDate | DateTime the CR was forwarded. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewQueue | The new queue into which the CR is to be forwarded.
Public Property | Notes | The reason the CR was rejected from the queue into which it was dispatched.
Public Property | UserName | The user who has forwarded the CR. If not set, the Toolkit session user is used.

Reference

ForwardCRSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
ForwardCR(ForwardCRSetup) Method


LogCREmailSetup Class Properties | fcSDK Documentation

LogCREmailSetup Class Properties

For a list of all members of this type, see LogCREmailSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CCList | Additional recipients to be included on the carbon copy (CC) of the email.
Public Property | CRIDNum | Identifier of the CR being logged.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | LogDate | DateTime the CR was logged. If not set, the current date time is used.
Public Property | Message | The text (body) of the email message included in the log.
Public Property | Recipient | The email address of the intended recipient of the email log.
Public Property | SendEmail | Should this email be sent from rulemanager?
Public Property | UserName | The user logging an email for the CR. If not set, the session user is used.

Reference

LogCREmailSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
LogCREmail(LogCREmailSetup) Method


LogCRNoteSetup Class Properties | fcSDK Documentation

LogCRNoteSetup Class Properties

For a list of all members of this type, see LogCRNoteSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CRIDNum | Identifier of the CR being logged.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | InternalUseOnlyNotes | Notes concerning the CR to log that are for internal use only.
Public Property | LogDate | DateTime the CR was logged. If not set, the current date time is used.
Public Property | Notes | Notes concerning the CR to log.
Public Property | UserName | The user logging a note for the CR. If not set, the session user is used.

Reference

LogCRNoteSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
LogCRNote(LogCRNoteSetup) Method


MoveCRSetup Class Properties | fcSDK Documentation

MoveCRSetup Class Properties

For a list of all members of this type, see MoveCRSetup members.

Public Properties

 | Name | Description
Public Property | CRIDNum | CR Identifier.
Public Property | NewWipBin | The new WipBin into which the CR is to be moved.

Reference

MoveCRSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
MoveCR(MoveCRSetup) Method


QualityToolkit.LogCREmailInSetup Class Properties | fcSDK Documentation

QualityToolkit.LogCREmailInSetup Class Properties

For a list of all members of this type, see QualityToolkit.LogCREmailInSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | CCList | Email addresses of persons CC'd on the email being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | GenerateTimeBombs | Specifies if timebombs should be created. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | IDNumber | Identifier of the Case against which the email in is being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | LogDate | DateTime the log was created. If not set, the current time is used (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | MailLogActionType | Element from the 'Mail Log Action Type' user defined list. If not set, the default list value is used. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | Message | Body of the email being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | Recipient | Email address of the recipients of the email being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | Sender | Email address of the sender of the email being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | Subject | (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | UserName | User who created the log. If not set, the session user is used. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)

Reference

QualityToolkit.LogCREmailInSetup Class
FChoice.Toolkits.Clarify.Quality Namespace


QualityToolkit Class Methods | fcSDK Documentation

QualityToolkit Class Methods

For a list of all members of this type, see QualityToolkit members.

Public Methods

 | Name | Description
Public Method | AcceptCR | Overloaded. Accept the specified CR from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.
Public Method | AddModuleToCR | Overloaded. Adding a file Module to a Fixed CR. This overload takes a set of required parameters for the API.
Public Method | AppendHistoryToCR | Overloaded.
Public Method | AssignCR | Overloaded. Assign the CR to a new user. This overload takes a set of required parameters for the API.
Public Method | ChangeCRStatus | Overloaded. Change the status of a CR. This overload takes a set of required parameters for the API.
Public Method | CheckClearQualityTransition | Overloaded. Determine if a user can change status from an old condition/status to a new condition/status. This overload takes a set of required parameters for the API.
Public Method | CloseCR | Overloaded. Close a CR. This overload takes a set of required parameters for the API.
Public Method | CreateCR | Overloaded. Create a new Change Request (CR). This overload takes a set of required parameters for the API.
Public Method | DispatchCR | Overloaded. Dispatch the CR to the specified queue. This overload takes a set of required parameters for the API.
Public Method | DuplicateCR | Overloaded. Mark a CR as duplicate of another 'master' CR. This overload takes a set of required parameters for the API.
Public Method | FixCR | Overloaded. Change the condition of a CR to Fixed. This overload takes a set of required parameters for the API.
Public Method | FixFailed | Overloaded. Change the condition of a Change Request from Fixed to Open. This overload takes a set of required parameters for the API.
Public Method | ForwardCR | Overloaded. Reject-forward the CR from one queue to another. This overload takes a set of required parameters for the API.
Public Method | LogCREmail | Overloaded. Used to create a email log for a CR. This overload takes a set of required parameters for the API.
Public Method | LogCREmailIn | Overloaded.
Public Method | LogCRNote | Overloaded. Used to create a note log against a CR. This overload takes a set of required parameters for the API.
Public Method | MoveCR | Overloaded. Move the CR from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
Public Method | RejectCR | Overloaded. Reject the CR from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.
Public Method | ReopenCR | Overloaded. Reopen a CR. This overload takes a set of required parameters for the API.
Public Method | ReplicateCR | Overloaded. Replicate a CR. This overload takes a set of required parameters for the API.
Public Method | UpdateCR | Overloaded. Update an existing CR. This overload takes a setup object.
Public Method | YankCR | Overloaded. Yank the CR from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.

Reference

QualityToolkit Class
FChoice.Toolkits.Clarify.Quality Namespace


QualityToolkit Class Properties | fcSDK Documentation

QualityToolkit Class Properties

For a list of all members of this type, see QualityToolkit members.

Public Properties

 | Name | Description
Public Property | ApplicationClock |
Public Property | ImpersonatorUsername | (Inherited from FChoice.Toolkits.Clarify.Quality.QualityToolkitBase)

Reference

QualityToolkit Class
FChoice.Toolkits.Clarify.Quality Namespace


QualityToolkitBase Class Properties | fcSDK Documentation

QualityToolkitBase Class Properties

For a list of all members of this type, see QualityToolkitBase members.

Public Properties

 | Name | Description
Public Property | ImpersonatorUsername |

Reference

QualityToolkitBase Class
FChoice.Toolkits.Clarify.Quality Namespace


RejectCRSetup Class Properties | fcSDK Documentation

RejectCRSetup Class Properties

For a list of all members of this type, see RejectCRSetup members.

Public Properties

 | Name | Description
Public Property | CRIDNum | CR Identifier.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Notes | The reason the CR was rejected from the queue into which it was dispatched.
Public Property | RejectDate | DateTime the CR was rejected. If not set, the current time is used.
Public Property | UserName | The user who has rejected the CR. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the CR. If not set, the UserName's default is used.

Reference

RejectCRSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
RejectCR(RejectCRSetup) Method


ReopenCRSetup Class Properties | fcSDK Documentation

ReopenCRSetup Class Properties

For a list of all members of this type, see ReopenCRSetup members.

Public Properties

 | Name | Description
Public Property | CRIDNum | Identifier of the CR being reopened.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | ReopenDate | DateTime the CR was reopened. If not set, the current date time is used.
Public Property | Status | The new status for the Change Request. If not set, the default status is used.
Public Property | UserName | The user reopening the CR. If not set, the session user is used.
Public Property | WipBin | Wipbin of the user to place the reopened CR. If not set, the UserName's default is used.

Reference

ReopenCRSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
ReopenCR(ReopenCRSetup) Method


ReplicateCRSetup Class Properties | fcSDK Documentation

ReplicateCRSetup Class Properties

For a list of all members of this type, see ReplicateCRSetup members.

Public Properties

 | Name | Description
Public Property | CRIDNum | Identifier of the CR being replicated.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | ReplicatedDate | DateTime the CR was replicated. If not set, the current date time is used.
Public Property | UserName | The user replicating the CR. If not set, the session user is used.

Reference

ReplicateCRSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
ReplicateCR(ReplicateCRSetup) Method


UpdateCRSetup Class Properties | fcSDK Documentation

UpdateCRSetup Class Properties

For a list of all members of this type, see UpdateCRSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CRClass | Element from the 'CR Class' application list. If not set, the default list value is used.
Public Property | CRIDNum | Identifier of the CR being updated.
Public Property | CRType | Element from the 'CR Type' application list. If not set, the default list value is used.
Public Property | FixedIn | Element from the 'Fix Release' application list. If not set, the default list value is used.
Public Property | FoundOnCPU | Element from level 1 of the 'CR_DESC' user-defined list. If not set, the default list value is used.
Public Property | Frequency | Element from the 'CR Reproducible' application list. If not set, the default list value is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | IntroductionPhase | Element from the 'CR Domain' application list. If not set, the default list value is used.
Public Property | Memory | Element from level 3 of the 'CR_DESC' user-defined list. If not set the default list value is used.
Public Property | OperatingSystem | Element from level 2 of the 'CR_DESC' user-defined list. If not set the default list value is used.
Public Property | PartDomain | Part Domain of a Part related to the CR.
Public Property | PartNumber | Part Number of a Part related to the CR.
Public Property | PartRevision | Part Revision of a Part related to the CR.
Public Property | Priority | Element from the 'CR Priority' application list. If not set, the default list value is used.
Public Property | TestClass | Element from the 'CR Class' application list. If not set, the default list value is used.
Public Property | Title | Title of the CR.
Public Property | UpdateDate | DateTime the CR was updated. If not set, the current date time is used.
Public Property | UserName | The user updating the CR. If not set, the session user is used.

Reference

UpdateCRSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
UpdateCR(UpdateCRSetup) Method


YankCRSetup Class Properties | fcSDK Documentation

YankCRSetup Class Properties

For a list of all members of this type, see YankCRSetup members.

Public Properties

 | Name | Description
Public Property | CRIDNum | CR Identifier.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | UserName | The user who has yanked the CR. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the CR. If not set, the UserName's default is used.
Public Property | YankDate | DateTime the CR was yanked. If not set, the current time is used.

Reference

YankCRSetup Class
FChoice.Toolkits.Clarify.Quality Namespace
YankCR(YankCRSetup) Method


FChoice.Toolkits.Clarify.Quality Namespace #### Inheritance Hierarchy | fcSDK Documentation

FChoice.Toolkits.Clarify.Quality Namespace #### Inheritance Hierarchy

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Quality.AcceptCRSetup
FChoice.Toolkits.Clarify.Quality.AddModuleToCRSetup
FChoice.Toolkits.Clarify.Quality.AssignCRSetup
FChoice.Toolkits.Clarify.Quality.ChangeCRStatusSetup
FChoice.Toolkits.Clarify.Quality.CheckClearQualityTransitionSetup
FChoice.Toolkits.Clarify.Quality.CloseCRSetup
FChoice.Toolkits.Clarify.Quality.CreateCRSetup
FChoice.Toolkits.Clarify.Quality.DispatchCRSetup
FChoice.Toolkits.Clarify.Quality.DuplicateCRSetup
FChoice.Toolkits.Clarify.Quality.FixCRSetup
FChoice.Toolkits.Clarify.Quality.FixFailedSetup
FChoice.Toolkits.Clarify.Quality.ForwardCRSetup
FChoice.Toolkits.Clarify.Quality.LogCREmailSetup
FChoice.Toolkits.Clarify.Quality.LogCRNoteSetup
FChoice.Toolkits.Clarify.Quality.MoveCRSetup
FChoice.Toolkits.Clarify.Quality.RejectCRSetup
FChoice.Toolkits.Clarify.Quality.ReopenCRSetup
FChoice.Toolkits.Clarify.Quality.ReplicateCRSetup
FChoice.Toolkits.Clarify.Quality.UpdateCRSetup
FChoice.Toolkits.Clarify.Quality.YankCRSetup
FChoice.Toolkits.Clarify.Support.LogEmailInSetup
FChoice.Toolkits.Clarify.Quality.QualityToolkit.LogCREmailInSetup
FChoice.Toolkits.Clarify.ToolkitBase
FChoice.Toolkits.Clarify.Quality.QualityToolkitBase
FChoice.Toolkits.Clarify.Quality.QualityToolkit

Reference

FChoice.Toolkits.Clarify Assembly


AcceptActionItemSetup Class Properties | fcSDK Documentation

AcceptActionItemSetup Class Properties

For a list of all members of this type, see AcceptActionItemSetup members.

Public Properties

 | Name | Description
Public Property | AcceptDate | DateTime the ActionItem was accepted. If not set, the current time is used.
Public Property | ActionItemIDNum | ActionItem Identifier.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | UserName | The user who has accepted the ActionItem. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the ActionItem. If not set, the UserName's default is used.

Reference

AcceptActionItemSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
AcceptActionItem(AcceptActionItemSetup) Method


AcceptOpportunitySetup Class Properties | fcSDK Documentation

AcceptOpportunitySetup Class Properties

For a list of all members of this type, see AcceptOpportunitySetup members.

Public Properties

 | Name | Description
Public Property | AcceptDate | DateTime the Opportunity was accepted. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | OpportunityIDNum | Opportunity Identifier.
Public Property | UserName | The user who has accepted the Opportunity. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Opportunity. If not set, the UserName's default is used.

Reference

AcceptOpportunitySetup Class
FChoice.Toolkits.Clarify.Sales Namespace
AcceptOpportunity(AcceptOpportunitySetup) Method


AcceptQuoteSetup Class Properties | fcSDK Documentation

AcceptQuoteSetup Class Properties

For a list of all members of this type, see AcceptQuoteSetup members.

Public Properties

 | Name | Description
Public Property | AcceptDate | DateTime the Quote was accepted. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | QuoteIDNum | Quote Identifier.
Public Property | UserName | The user who has accepted the Quote. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Quote. If not set, the UserName's default is used.

Reference

AcceptQuoteSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
AcceptQuote(AcceptQuoteSetup) Method


AssignActionItemSetup Class Properties | fcSDK Documentation

AssignActionItemSetup Class Properties

For a list of all members of this type, see AssignActionItemSetup members.

Public Properties

 | Name | Description
Public Property | ActionItemIDNum | ActionItem Identifier.
Public Property | AssignDate | DateTime the ActionItem was assigned. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewUser | The new user to which the ActionItem is to be assigned.
Public Property | UserName | The user who has assigned the ActionItem. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the ActionItem. If not set, the UserName's default is used.

Reference

AssignActionItemSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
AssignActionItem(AssignActionItemSetup) Method


AssignLeadSetup Class Properties | fcSDK Documentation

AssignLeadSetup Class Properties

For a list of all members of this type, see AssignLeadSetup members.

Public Properties

 | Name | Description
Public Property | AssignDate | DateTime the Lead was assigned. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | LeadObjid | The objid of the lead being assigned.
Public Property | NewOwner | The new user which the lead is assigned to.

Reference

AssignLeadSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
AssignLead(AssignLeadSetup) Method


AssignOpportunitySetup Class Properties | fcSDK Documentation

AssignOpportunitySetup Class Properties

For a list of all members of this type, see AssignOpportunitySetup members.

Public Properties

 | Name | Description
Public Property | AssignDate | DateTime the Opportunity was assigned. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewUser | The new user to which the Opportunity is to be assigned.
Public Property | OpportunityIDNum | Opportunity Identifier.
Public Property | UserName | The user who has assigned the Opportunity. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Opportunity. If not set, the UserName's default is used.

Reference

AssignOpportunitySetup Class
FChoice.Toolkits.Clarify.Sales Namespace
AssignOpportunity(AssignOpportunitySetup) Method


AssignQuoteSetup Class Properties | fcSDK Documentation

AssignQuoteSetup Class Properties

For a list of all members of this type, see AssignQuoteSetup members.

Public Properties

 | Name | Description
Public Property | AssignDate | DateTime the Quote was assigned. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewUser | The new user to which the Quote is to be assigned.
Public Property | QuoteIDNum | Quote Identifier.
Public Property | UserName | The user who has assigned the Quote. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Quote. If not set, the UserName's default is used.

Reference

AssignQuoteSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
AssignQuote(AssignQuoteSetup) Method


ChangeActionItemConditionSetup Class Properties | fcSDK Documentation

ChangeActionItemConditionSetup Class Properties

For a list of all members of this type, see ChangeActionItemConditionSetup members.

Public Properties

 | Name | Description
Public Property | ActionItemIDNum | Action Item Identifier.
Public Property | ChangeDate | The DateTime the Action Item condition was changed. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewCondition | The new condition for the Action Item
Public Property | NewStatus | Element from the 'Open Action Item' application list. If not set, the default list value is used.
Public Property | UserName | The user who is changing the action item condition. If not set, the Toolkit session user is used.

Reference

ChangeActionItemConditionSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
ChangeActionItemCondition(ChangeActionItemConditionSetup) Method


ChangeActionItemStatusSetup Class Properties | fcSDK Documentation

ChangeActionItemStatusSetup Class Properties

For a list of all members of this type, see ChangeActionItemStatusSetup members.

Public Properties

 | Name | Description
Public Property | ActionItemIDNum | Action Item Identifier.
Public Property | ChangeDate | The DateTime the Action Item status was changed. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewStatus | Element from the 'Open Action Item' application list. If not set, the default list value is used.
Public Property | Notes | Notes about the Action Item status change.
Public Property | UserName | The user who is changing the action item status. If not set, the Toolkit session user is used.

Reference

ChangeActionItemStatusSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
ChangeActionItemStatus(ChangeActionItemStatusSetup) Method


ChangeOpportunityStageSetup Class Properties | fcSDK Documentation

ChangeOpportunityStageSetup Class Properties

For a list of all members of this type, see ChangeOpportunityStageSetup members.

Public Properties

 | Name | Description
Public Property | ChangeDate | The DateTime the Opportunity stage was changed. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewStatus | Element from the 'Open Opportunity' application list. If not set, the default list value is used.
Public Property | Notes | Notes about the Opportunity stage change.
Public Property | OpportunityIDNum | Opportunity Identifier.
Public Property | Stage | The new sales stage for the Opportunity.
Public Property | UserName | The user who is changing the opportunity stage. If not set, the Toolkit session user is used.

Reference

ChangeOpportunityStageSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
ChangeOpportunityStage(ChangeOpportunityStageSetup) Method


ChangeOpportunityStatusSetup Class Properties | fcSDK Documentation

ChangeOpportunityStatusSetup Class Properties

For a list of all members of this type, see ChangeOpportunityStatusSetup members.

Public Properties

 | Name | Description
Public Property | ChangeDate | The DateTime the Opportunity status was changed. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewStatus | Element from the 'Open Opportunity' application list. If not set, the default list value is used.
Public Property | Notes | Notes about the Opportunity status change.
Public Property | OpportunityIDNum | Opportunity Identifier.
Public Property | UserName | The user who is changing the opportunity status. If not set, the Toolkit session user is used.

Reference

ChangeOpportunityStatusSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
ChangeOpportunityStatus(ChangeOpportunityStatusSetup) Method


ChangeQuoteStatusSetup Class Properties | fcSDK Documentation

ChangeQuoteStatusSetup Class Properties

For a list of all members of this type, see ChangeQuoteStatusSetup members.

Public Properties

 | Name | Description
Public Property | ChangeDate | The DateTime the Quote status was changed. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewStatus | Element from the 'SFA Quote' application list. If not set, the default list value is used.
Public Property | Notes | Notes about the Quote status change.
Public Property | QuoteIDNum | Quote Identifier.
Public Property | UserName | The user who is changing the quote status. If not set, the Toolkit session user is used.

Reference

ChangeQuoteStatusSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
ChangeQuoteStatus(ChangeQuoteStatusSetup) Method


CloseOpportunitySetup Class Properties | fcSDK Documentation

CloseOpportunitySetup Class Properties

For a list of all members of this type, see CloseOpportunitySetup members.

Public Properties

 | Name | Description
Public Property | CloseDate | The DateTime the Opportunity was closed. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | OpportunityIDNum | Opportunity Identifier.
Public Property | Status | Element from the 'Closed Opportunity' application list. If not set, the default list value is used.
Public Property | UserName | The user who is closing the opportunity. If not set, the Toolkit session user is used.

Reference

CloseOpportunitySetup Class
FChoice.Toolkits.Clarify.Sales Namespace
CloseOpportunity(CloseOpportunitySetup) Method


CreateActionItemSetup Class Properties | fcSDK Documentation

CreateActionItemSetup Class Properties

For a list of all members of this type, see CreateActionItemSetup members.

Public Properties

 | Name | Description
Public Property | AccountName | Name of the account to relate to the action item.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CompleteDate | The DateTime the Action Item is to be completed. If not set, it will be set to one week after the start date.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | CreateDate | The DateTime the Action Item was created. If not set, the current time is used.
Public Property | DueDate | The DateTime the Action Item is due. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | LeadFirstName | First name of the lead for the action item.
Public Property | LeadLastName | Last name of the lead for the action item.
Public Property | Notes | Notes about the Action Item creation.
Public Property | OpportunityIDNum | Opportunity Identifier.
Public Property | Priority | Element from the 'Task Priority' application list. If not set, the default list value is used.
Public Property | StartDate | The DateTime the Action Item is to be started. If not set, the current time is used.
Public Property | Status | Element from the 'Open Action Item' application list. If not set, the default list value is used.
Public Property | TaskType | Element from the 'Task Type' application list. If not set, the default list value is used.
Public Property | Title | Title of the Action Item.
Public Property | UserName | The user who is creating the action item. If not set, the Toolkit session user is used.

Reference

CreateActionItemSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
CreateActionItem(CreateActionItemSetup) Method


CreateLeadSetup Class Properties | fcSDK Documentation

CreateLeadSetup Class Properties

For a list of all members of this type, see CreateLeadSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | Address | Address for the lead.
Public Property | Address2 | Secondary address line for the lead.
Public Property | City | City for the lead.
Public Property | CompanyName | Company name for the lead.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | ContactRole | Element from the 'Contact Role' user list. If not set, the default list value is used.
Public Property | Country | Country for the lead.
Public Property | CreateDate | The DateTime the Lead was created. If not set, the current time is used.
Public Property | Email | Email address for the lead.
Public Property | Fax | Fax number for the lead.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | LeadObjid | The objid of the lead.
Public Property | LeadSource | Name of the lead source.
Public Property | PostalCode | Postal code for the lead.
Public Property | Rating | Element from the 'Lead Status' application list. If not set, the default list value is used.
Public Property | SiteName | The name of the site for the lead.
Public Property | SiteType | The type of the site for the lead.
Public Property | State | State for the lead.
Public Property | TimeZone | Time zone for the lead.
Public Property | Title | Title for the lead.
Public Property | UserName | The user who is creating the lead. If not set, the Toolkit session user is used.

Reference

CreateLeadSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
CreateLead(CreateLeadSetup) Method


CreateOpportunitySetup Class Properties | fcSDK Documentation

CreateOpportunitySetup Class Properties

For a list of all members of this type, see CreateOpportunitySetup members.

Public Properties

 | Name | Description
Public Property | AccountIDNum | Account Identifier.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | Amount | Oppoertunity amount.
Public Property | CloseDate | The DateTime the Opportunity was closed. If not set, the current time is used.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | CreateDate | The DateTime the Opportunity was created. If not set, the current time is used.
Public Property | Currency | Name of the currency for the Opportunity.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | LeadSource | Lead source for the opportunity.
Public Property | OpportunityName | The name of the Opportunity.
Public Property | Probability | Probability of opportunity close.
Public Property | Process | The process for the Opportunity. If not set, the default process is used.
Public Property | SalesStage | Sales stage for the opportunity.
Public Property | Territory | Name of the territory for the Opportunity.
Public Property | UserName | The user who is creating the opportunity. If not set, the Toolkit session user is used.

Reference

CreateOpportunitySetup Class
FChoice.Toolkits.Clarify.Sales Namespace
CreateOpportunity(CreateOpportunitySetup) Method


CreateQuoteLineItemSetup Class Properties | fcSDK Documentation

CreateQuoteLineItemSetup Class Properties

For a list of all members of this type, see CreateQuoteLineItemSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | AutoInstall | Indicator to install the Line Item.
Public Property | Comments | Comments about this line item.
Public Property | ContractIDNum | Quote/Contract Identifier.
Public Property | CreateDate | The DateTime the Quote Line Item was created. If not set, the current time is used.
Public Property | EndDate | The DateTime the Quote Line Item ends. If not set, the current time is used.
Public Property | IsTaxable | Specifies if this line item taxable (true) or not (false).
Public Property | OverridePrice | This is the per-unit price for this line item. If not set, price from the price schedule is used
Public Property | ParentLineItemObjid | The objid of the parent line item.
Public Property | PartDomain | The domain of the part for this line item.
Public Property | PartNumber | The part number for this line item.
Public Property | PartRevision | The revision of the part for this line item.
Public Property | POIDNum | Purchase Order Identifier.
Public Property | PriceSchedule | The name of the Price Schedule for this line item.
Public Property | Quantity | The number of units for this line item.
Public Property | QuotedSiteIDNum | Site Identifier for auto-install process.
Public Property | SerialNumber | For a serialized part, the serial number referenced by this line item.
Public Property | ServicedAtSiteIDNum | Site Identifier for servicing the line item.
Public Property | StartDate | The DateTime the Quote Line Item starts. If not set, the current time is used.
Public Property | UnitsUsed | The number of units used for this line item.
Public Property | UserName | The user who is creating the line item. If not set, the Toolkit session user is used.

Reference

CreateQuoteLineItemSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
CreateQuoteLineItem(CreateQuoteLineItemSetup) Method


CreateQuoteSetup Class Properties | fcSDK Documentation

CreateQuoteSetup Class Properties

For a list of all members of this type, see CreateQuoteSetup members.

Public Properties

 | Name | Description
Public Property | AccountIDNum | Account Identifier.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | AdminUserName | Administrator login. If not set, the current user is used.
Public Property | BillToSiteIDNum | Site Identifier for the site being billed in the Quote.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | CreateDate | The DateTime the Quote was created. If not set, the current time is used.
Public Property | Currency | Name of the currency for the Quote.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | OpportunityIDNum | Opportunity Identifier.
Public Property | PriceProgram | Name of the price program for the Quote.
Public Property | Queue | The queue to dispatch the Quote to. If not set, no dispatch takes place.
Public Property | QuoteLengthInDays | The number of days the Quote is valid.
Public Property | QuoteTitle | The title of the Quote.
Public Property | ShipToSiteIDNum | Site Identifier for the site being shipped to in the Quote.
Public Property | SiteIDNum | Site Identifier.
Public Property | Status | Element from the 'SFA Quote' application list. If not set, the default list value is used.
Public Property | UserName | The user who is creating the quote. If not set, the Toolkit session user is used.

Reference

CreateQuoteSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
CreateQuote(CreateQuoteSetup) Method


DispatchActionItemSetup Class Properties | fcSDK Documentation

DispatchActionItemSetup Class Properties

For a list of all members of this type, see DispatchActionItemSetup members.

Public Properties

 | Name | Description
Public Property | ActionItemIDNum | ActionItem Identifier.
Public Property | DispatchDate | DateTime the ActionItem was dispatched. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Queue | The queue into which the ActionItem is to be dispatched.
Public Property | UserName | The user who has dispatched the ActionItem. If not set, the Toolkit session user is used.

Reference

DispatchActionItemSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
DispatchActionItem(DispatchActionItemSetup) Method


DispatchOpportunitySetup Class Properties | fcSDK Documentation

DispatchOpportunitySetup Class Properties

For a list of all members of this type, see DispatchOpportunitySetup members.

Public Properties

 | Name | Description
Public Property | DispatchDate | DateTime the Opportunity was dispatched. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | OpportunityIDNum | Opportunity Identifier.
Public Property | Queue | The queue into which the Opportunity is to be dispatched.
Public Property | UserName | The user who has dispatched the Opportunity. If not set, the Toolkit session user is used.

Reference

DispatchOpportunitySetup Class
FChoice.Toolkits.Clarify.Sales Namespace
DispatchOpportunity(DispatchOpportunitySetup) Method


DispatchQuoteSetup Class Properties | fcSDK Documentation

DispatchQuoteSetup Class Properties

For a list of all members of this type, see DispatchQuoteSetup members.

Public Properties

 | Name | Description
Public Property | DispatchDate | DateTime the Quote was dispatched. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Queue | The queue into which the Quote is to be dispatched.
Public Property | QuoteIDNum | Quote Identifier.
Public Property | UserName | The user who has dispatched the Quote. If not set, the Toolkit session user is used.

Reference

DispatchQuoteSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
DispatchQuote(DispatchQuoteSetup) Method


ForwardActionItemSetup Class Properties | fcSDK Documentation

ForwardActionItemSetup Class Properties

For a list of all members of this type, see ForwardActionItemSetup members.

Public Properties

 | Name | Description
Public Property | ActionItemIDNum | ActionItem Identifier.
Public Property | ForwardDate | DateTime the ActionItem was forwarded. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewQueue | The new queue into which the ActionItem is to be forwarded.
Public Property | Notes | The reason the ActionItem was rejected from the queue into which it was dispatched.
Public Property | UserName | The user who has forwarded the ActionItem. If not set, the Toolkit session user is used.

Reference

ForwardActionItemSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
ForwardActionItem(ForwardActionItemSetup) Method


ForwardOpportunitySetup Class Properties | fcSDK Documentation

ForwardOpportunitySetup Class Properties

For a list of all members of this type, see ForwardOpportunitySetup members.

Public Properties

 | Name | Description
Public Property | ForwardDate | DateTime the Opportunity was forwarded. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewQueue | The new queue into which the Opportunity is to be forwarded.
Public Property | Notes | The reason the Opportunity was rejected from the queue into which it was dispatched.
Public Property | OpportunityIDNum | Opportunity Identifier.
Public Property | UserName | The user who has forwarded the Opportunity. If not set, the Toolkit session user is used.

Reference

ForwardOpportunitySetup Class
FChoice.Toolkits.Clarify.Sales Namespace
ForwardOpportunity(ForwardOpportunitySetup) Method


ForwardQuoteSetup Class Properties | fcSDK Documentation

ForwardQuoteSetup Class Properties

For a list of all members of this type, see ForwardQuoteSetup members.

Public Properties

 | Name | Description
Public Property | ForwardDate | DateTime the Quote was forwarded. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewQueue | The new queue into which the Quote is to be forwarded.
Public Property | Notes | The reason the Quote was rejected from the queue into which it was dispatched.
Public Property | QuoteIDNum | Quote Identifier.
Public Property | UserName | The user who has forwarded the Quote. If not set, the Toolkit session user is used.

Reference

ForwardQuoteSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
ForwardQuote(ForwardQuoteSetup) Method


LogActionItemEmailInSetup Class Properties | fcSDK Documentation

LogActionItemEmailInSetup Class Properties

For a list of all members of this type, see LogActionItemEmailInSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | CCList | Email addresses of persons CC'd on the email being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | GenerateTimeBombs | Specifies if timebombs should be created. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | IDNumber | Identifier of the Case against which the email in is being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | LogDate | DateTime the log was created. If not set, the current time is used (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | MailLogActionType | Element from the 'Mail Log Action Type' user defined list. If not set, the default list value is used. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | Message | Body of the email being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | Recipient | Email address of the recipients of the email being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | Sender | Email address of the sender of the email being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | Subject | (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | UserName | User who created the log. If not set, the session user is used. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)

Reference

LogActionItemEmailInSetup Class
FChoice.Toolkits.Clarify.Sales Namespace


LogLeadNoteSetup Class Properties | fcSDK Documentation

LogLeadNoteSetup Class Properties

For a list of all members of this type, see LogLeadNoteSetup members.

Public Properties

 | Name | Description
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | InternalUseOnlyNotes | Notes to be added as Internal Use Only notes on the Lead Note Log.
Public Property | LeadObjid | The objid of the lead for the note log.
Public Property | LogDate | The DateTime the Lead Note was logged. If not set, the current time is used.
Public Property | Notes | Notes about the Lead Note logging.
Public Property | UserName | The user who is logging the note. If not set, the Toolkit session user is used.

Reference

LogLeadNoteSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
LogLeadNote(LogLeadNoteSetup) Method


LogLeadPhoneSetup Class Properties | fcSDK Documentation

LogLeadPhoneSetup Class Properties

For a list of all members of this type, see LogLeadPhoneSetup members.

Public Properties

 | Name | Description
Public Property | ActionType | Element from the 'Phone Log Action Type' user list. If not set, the default list value is used.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | Duration | Time that the phone call lasted.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | InternalUseOnlyNotes | Notes to be added as Internal Use Only notes on the Lead Phone Log.
Public Property | LeadObjid | The objid of the lead for the phone log.
Public Property | LogDate | The DateTime the Lead Phone Note was logged. If not set, the current time is used.
Public Property | Notes | Notes about the Lead Phone Note logging.
Public Property | UserName | The user who is logging the phone call. If not set, the Toolkit session user is used.

Reference

LogLeadPhoneSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
LogLeadPhone(LogLeadPhoneSetup) Method


MoveActionItemSetup Class Properties | fcSDK Documentation

MoveActionItemSetup Class Properties

For a list of all members of this type, see MoveActionItemSetup members.

Public Properties

 | Name | Description
Public Property | ActionItemIDNum | ActionItem Identifier.
Public Property | NewWipBin | The new WipBin into which the ActionItem is to be moved.

Reference

MoveActionItemSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
MoveActionItem(MoveActionItemSetup) Method


MoveOpportunitySetup Class Properties | fcSDK Documentation

MoveOpportunitySetup Class Properties

For a list of all members of this type, see MoveOpportunitySetup members.

Public Properties

 | Name | Description
Public Property | NewWipBin | The new WipBin into which the Opportunity is to be moved.
Public Property | OpportunityIDNum | Opportunity Identifier.

Reference

MoveOpportunitySetup Class
FChoice.Toolkits.Clarify.Sales Namespace
MoveOpportunity(MoveOpportunitySetup) Method


MoveQuoteSetup Class Properties | fcSDK Documentation

MoveQuoteSetup Class Properties

For a list of all members of this type, see MoveQuoteSetup members.

Public Properties

 | Name | Description
Public Property | NewWipBin | The new WipBin into which the Quote is to be moved.
Public Property | QuoteIDNum | Quote Identifier.

Reference

MoveQuoteSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
MoveQuote(MoveQuoteSetup) Method


RejectActionItemSetup Class Properties | fcSDK Documentation

RejectActionItemSetup Class Properties

For a list of all members of this type, see RejectActionItemSetup members.

Public Properties

 | Name | Description
Public Property | ActionItemIDNum | ActionItem Identifier.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Notes | The reason the ActionItem was rejected from the queue into which it was dispatched.
Public Property | RejectDate | DateTime the ActionItem was rejected. If not set, the current time is used.
Public Property | UserName | The user who has rejected the ActionItem. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the ActionItem. If not set, the UserName's default is used.

Reference

RejectActionItemSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
RejectActionItem(RejectActionItemSetup) Method


RejectOpportunitySetup Class Properties | fcSDK Documentation

RejectOpportunitySetup Class Properties

For a list of all members of this type, see RejectOpportunitySetup members.

Public Properties

 | Name | Description
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Notes | The reason the Opportunity was rejected from the queue into which it was dispatched.
Public Property | OpportunityIDNum | Opportunity Identifier.
Public Property | RejectDate | DateTime the Opportunity was rejected. If not set, the current time is used.
Public Property | UserName | The user who has rejected the Opportunity. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Opportunity. If not set, the UserName's default is used.

Reference

RejectOpportunitySetup Class
FChoice.Toolkits.Clarify.Sales Namespace
RejectOpportunity(RejectOpportunitySetup) Method


RejectQuoteSetup Class Properties | fcSDK Documentation

RejectQuoteSetup Class Properties

For a list of all members of this type, see RejectQuoteSetup members.

Public Properties

 | Name | Description
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Notes | The reason the Quote was rejected from the queue into which it was dispatched.
Public Property | QuoteIDNum | Quote Identifier.
Public Property | RejectDate | DateTime the Quote was rejected. If not set, the current time is used.
Public Property | UserName | The user who has rejected the Quote. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Quote. If not set, the UserName's default is used.

Reference

RejectQuoteSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
RejectQuote(RejectQuoteSetup) Method


ReopenOpportunitySetup Class Properties | fcSDK Documentation

ReopenOpportunitySetup Class Properties

For a list of all members of this type, see ReopenOpportunitySetup members.

Public Properties

 | Name | Description
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | OpportunityIDNum | Opportunity Identifier.
Public Property | ReopenDate | The DateTime the Opportunity was reopened. If not set, the current time is used.
Public Property | Status | Element from the 'Open Action Item' application list. If not set, the default list value is used.
Public Property | UserName | The user who is reopening the opportunity. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin to place the Opportunity in. It not set the current user's default is used.

Reference

ReopenOpportunitySetup Class
FChoice.Toolkits.Clarify.Sales Namespace
ReopenOpportunity(ReopenOpportunitySetup) Method


SalesToolkit Class Methods | fcSDK Documentation

SalesToolkit Class Methods

For a list of all members of this type, see SalesToolkit members.

Public Methods

 | Name | Description
Public Method | AcceptActionItem | Overloaded. Accept the specified ActionItem from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.
Public Method | AcceptOpportunity | Overloaded. Accept the specified Opportunity from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.
Public Method | AcceptQuote | Overloaded. Accept the specified Quote from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.
Public Method | AssignActionItem | Overloaded. Assign the ActionItem to a new user. This overload takes a set of required parameters for the API.
Public Method | AssignLead | Overloaded. Assign the Lead to a new user. This overload takes a set of required parameters for the API.
Public Method | AssignOpportunity | Overloaded. Assign the Opportunity to a new user. This overload takes a set of required parameters for the API.
Public Method | AssignQuote | Overloaded. Assign the Quote to a new user. This overload takes a set of required parameters for the API.
Public Method | ChangeActionItemCondition | Overloaded. Used to change the condition and (optionally) a status for the specified Action Item. This overload takes a set of required parameters for the API.
Public Method | ChangeActionItemStatus | Overloaded. Cause the specified Action Item to have its status changed. This overload takes a set of required parameters for the API.
Public Method | ChangeOpportunityStage | Overloaded. (Inherited from FChoice.Toolkits.Clarify.Sales.SalesToolkitBase)
Public Method | ChangeOpportunityStatus | Overloaded. Cause the specified Opportunity to have its status changed. This overload takes a set of required parameters for the API.
Public Method | ChangeQuoteStatus | Overloaded. Cause the specified Quote to have its status changed. This overload takes a set of required parameters for the API.
Public Method | CloseOpportunity | Overloaded. Closes the Opportunity. This overload takes a set of required parameters for the API.
Public Method | CreateActionItem | Overloaded. Creates a new Action Item. This overload takes a set of required parameters for the API.
Public Method | CreateLead | Overloaded. Used to create a new Lead. This overload takes a set of required parameters for the API.
Public Method | CreateOpportunity | Overloaded. Used to create a new Opportunity. This overload takes a set of required parameters for the API.
Public Method | CreateQuote | Overloaded. Used to create a new Quote. This overload takes a set of required parameters for the API.
Public Method | CreateQuoteLineItem | Overloaded. Used to create a Quote/Contract line item. This overload takes a set of required parameters for the API.
Public Method | DispatchActionItem | Overloaded. Dispatch the ActionItem to the specified queue. This overload takes a set of required parameters for the API.
Public Method | DispatchOpportunity | Overloaded. Dispatch the Opportunity to the specified queue. This overload takes a set of required parameters for the API.
Public Method | DispatchQuote | Overloaded. Dispatch the Quote to the specified queue. This overload takes a set of required parameters for the API.
Public Method | ForwardActionItem | Overloaded. Reject-forward the ActionItem from one queue to another. This overload takes a set of required parameters for the API.
Public Method | ForwardOpportunity | Overloaded. Reject-forward the Opportunity from one queue to another. This overload takes a set of required parameters for the API.
Public Method | ForwardQuote | Overloaded. Reject-forward the Quote from one queue to another. This overload takes a set of required parameters for the API.
Public Method | LogActionItemEmailIn | Overloaded.
Public Method | LogLeadNote | Overloaded. Log a note for a Lead. This overload takes a set of required parameters for the API.
Public Method | LogLeadPhone | Overloaded. Log a phone call for a Lead. This overload takes a set of required parameters for the API.
Public Method | MoveActionItem | Overloaded. Move the ActionItem from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
Public Method | MoveOpportunity | Overloaded. Move the Opportunity from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
Public Method | MoveQuote | Overloaded. Move the Quote from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
Public Method | RejectActionItem | Overloaded. Reject the ActionItem from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.
Public Method | RejectOpportunity | Overloaded. Reject the Opportunity from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.
Public Method | RejectQuote | Overloaded. Reject the Quote from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.
Public Method | ReopenOpportunity | Overloaded. Causes the specified Opportunity to be reopened. This overload takes a set of required parameters for the API.
Public Method | UpdateActionItem | Overloaded. Update an existing Action Item. This overload takes a setup object.
Public Method | UpdateLead | Overloaded. Used to update a Lead. This overload takes a setup object.
Public Method | UpdateOpportunity | Overloaded. Update an Opportunity. This overload takes a setup object.
Public Method | YankActionItem | Overloaded. Yank the ActionItem from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.
Public Method | YankOpportunity | Overloaded. Yank the Opportunity from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.
Public Method | YankQuote | Overloaded. Yank the Quote from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.

Reference

SalesToolkit Class
FChoice.Toolkits.Clarify.Sales Namespace


SalesToolkit Class Properties | fcSDK Documentation

SalesToolkit Class Properties

For a list of all members of this type, see SalesToolkit members.

Public Properties

 | Name | Description
Public Property | ApplicationClock |
Public Property | ImpersonatorUsername | (Inherited from FChoice.Toolkits.Clarify.Sales.SalesToolkitBase)

Reference

SalesToolkit Class
FChoice.Toolkits.Clarify.Sales Namespace


SalesToolkitBase Class Methods | fcSDK Documentation

SalesToolkitBase Class Methods

For a list of all members of this type, see SalesToolkitBase members.

Public Methods

 | Name | Description
Public Method | ChangeOpportunityStage | Overloaded.

Reference

SalesToolkitBase Class
FChoice.Toolkits.Clarify.Sales Namespace


SalesToolkitBase Class Properties | fcSDK Documentation

SalesToolkitBase Class Properties

For a list of all members of this type, see SalesToolkitBase members.

Public Properties

 | Name | Description
Public Property | ImpersonatorUsername |

Reference

SalesToolkitBase Class
FChoice.Toolkits.Clarify.Sales Namespace


UpdateActionItemSetup Class Properties | fcSDK Documentation

UpdateActionItemSetup Class Properties

For a list of all members of this type, see UpdateActionItemSetup members.

Public Properties

 | Name | Description
Public Property | AccountName | Name of the account to relate to the action item.
Public Property | ActionItemIDNum | ActionItem Identifier.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CompleteDate | The DateTime the Action Item was completed. If not set, the current time is used.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | DueDate | The DateTime the Action Item was due. If not set, the current time is used.
Public Property | LeadFirstName | First name of the lead for the action item.
Public Property | LeadLastName | Last name of the lead for the action item.
Public Property | Notes | Action Item notes.
Public Property | OpportunityIDNum | Oppertunity Identifier.
Public Property | Priority | Element from the 'Task Priority' application list. If not set, the default list value is used.
Public Property | StartDate | The DateTime the Action Item was started. If not set, the current time is used.
Public Property | Status | Element from the 'Open Action Item' application list. If not set, the default list value is used.
Public Property | TaskType | Element from the 'Task Type' application list. If not set, the default list value is used.
Public Property | Title | Action Item title.
Public Property | UpdateDate | The DateTime the Action Item was updated. If not set, the current time is used.

Reference

UpdateActionItemSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
UpdateActionItem(UpdateActionItemSetup) Method


UpdateLeadSetup Class Properties | fcSDK Documentation

UpdateLeadSetup Class Properties

For a list of all members of this type, see UpdateLeadSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | Address | Address for the lead.
Public Property | Address2 | Secondary address line for the lead.
Public Property | City | City for the lead.
Public Property | CompanyName | Company name for the lead.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | ContactRole | Element from the 'Contact Role' user list. If not set, the default list value is used.
Public Property | Country | Country for the lead.
Public Property | CreateDate | The DateTime the Lead was created. If not set, the current time is used.
Public Property | Email | Email address for the lead.
Public Property | Fax | Fax number for the lead.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | LeadObjid | The objid of the lead being updated.
Public Property | LeadSource | Name of the lead source for this lead.
Public Property | PostalCode | Postal code for the lead.
Public Property | Rating | Element from the 'Lead Status' application list. If not set, the default list value is used.
Public Property | SiteName | The name of the site for the lead.
Public Property | SiteType | The type of the site for the lead.
Public Property | State | State for the lead.
Public Property | TimeZone | Time Zone for the lead.
Public Property | Title | Title for the lead.
Public Property | UserName | The user who is updating the lead. If not set, the Toolkit session user is used.

Reference

UpdateLeadSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
UpdateLead(UpdateLeadSetup) Method


UpdateOpportunitySetup Class Properties | fcSDK Documentation

UpdateOpportunitySetup Class Properties

For a list of all members of this type, see UpdateOpportunitySetup members.

Public Properties

 | Name | Description
Public Property | AccountIDNum | Account Identifier.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | Amount | The amount for the Opportunity.
Public Property | CloseDate | The DateTime the Opportunity was closed. If not set, the current time is used.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | Currency | Name of the currency for the Opportunity.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | LeadSource | Lead source for the opportunity.
Public Property | OpportunityIDNum | Opportunity Identifier.
Public Property | OpportunityName | The name of the Opportunity.
Public Property | Probability | The probability for the Opportunity.
Public Property | Process | The process for the Opportunity.
Public Property | Territory | Name of the territory for the Opportunity.
Public Property | UpdateDate | The DateTime the Opportunity was updated. If not set, the current time is used.
Public Property | UserName | The user who is updating the opportunity. If not set, the Toolkit session user is used.

Reference

UpdateOpportunitySetup Class
FChoice.Toolkits.Clarify.Sales Namespace
UpdateOpportunity(UpdateOpportunitySetup) Method


YankActionItemSetup Class Properties | fcSDK Documentation

YankActionItemSetup Class Properties

For a list of all members of this type, see YankActionItemSetup members.

Public Properties

 | Name | Description
Public Property | ActionItemIDNum | ActionItem Identifier.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | UserName | The user who has yanked the ActionItem. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the ActionItem. If not set, the UserName's default is used.
Public Property | YankDate | DateTime the ActionItem was yanked. If not set, the current time is used.

Reference

YankActionItemSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
YankActionItem(YankActionItemSetup) Method


YankOpportunitySetup Class Properties | fcSDK Documentation

YankOpportunitySetup Class Properties

For a list of all members of this type, see YankOpportunitySetup members.

Public Properties

 | Name | Description
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | OpportunityIDNum | Opportunity Identifier.
Public Property | UserName | The user who has yanked the Opportunity. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Opportunity. If not set, the UserName's default is used.
Public Property | YankDate | DateTime the Opportunity was yanked. If not set, the current time is used.

Reference

YankOpportunitySetup Class
FChoice.Toolkits.Clarify.Sales Namespace
YankOpportunity(YankOpportunitySetup) Method


YankQuoteSetup Class Properties | fcSDK Documentation

YankQuoteSetup Class Properties

For a list of all members of this type, see YankQuoteSetup members.

Public Properties

 | Name | Description
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | QuoteIDNum | Quote Identifier.
Public Property | UserName | The user who has yanked the Quote. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Quote. If not set, the UserName's default is used.
Public Property | YankDate | DateTime the Quote was yanked. If not set, the current time is used.

Reference

YankQuoteSetup Class
FChoice.Toolkits.Clarify.Sales Namespace
YankQuote(YankQuoteSetup) Method


FChoice.Toolkits.Clarify.Sales Namespace #### Inheritance Hierarchy | fcSDK Documentation

FChoice.Toolkits.Clarify.Sales Namespace #### Inheritance Hierarchy

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Sales.AcceptActionItemSetup
FChoice.Toolkits.Clarify.Sales.AcceptOpportunitySetup
FChoice.Toolkits.Clarify.Sales.AcceptQuoteSetup
FChoice.Toolkits.Clarify.Sales.AssignActionItemSetup
FChoice.Toolkits.Clarify.Sales.AssignLeadSetup
FChoice.Toolkits.Clarify.Sales.AssignOpportunitySetup
FChoice.Toolkits.Clarify.Sales.AssignQuoteSetup
FChoice.Toolkits.Clarify.Sales.ChangeActionItemConditionSetup
FChoice.Toolkits.Clarify.Sales.ChangeActionItemStatusSetup
FChoice.Toolkits.Clarify.Sales.ChangeOpportunityStageSetup
FChoice.Toolkits.Clarify.Sales.ChangeOpportunityStatusSetup
FChoice.Toolkits.Clarify.Sales.ChangeQuoteStatusSetup
FChoice.Toolkits.Clarify.Sales.CloseOpportunitySetup
FChoice.Toolkits.Clarify.Sales.CreateActionItemSetup
FChoice.Toolkits.Clarify.Sales.CreateLeadSetup
FChoice.Toolkits.Clarify.Sales.CreateOpportunitySetup
FChoice.Toolkits.Clarify.Sales.CreateQuoteLineItemSetup
FChoice.Toolkits.Clarify.Sales.CreateQuoteSetup
FChoice.Toolkits.Clarify.Sales.DispatchActionItemSetup
FChoice.Toolkits.Clarify.Sales.DispatchOpportunitySetup
FChoice.Toolkits.Clarify.Sales.DispatchQuoteSetup
FChoice.Toolkits.Clarify.Sales.ForwardActionItemSetup
FChoice.Toolkits.Clarify.Sales.ForwardOpportunitySetup
FChoice.Toolkits.Clarify.Sales.ForwardQuoteSetup
FChoice.Toolkits.Clarify.Sales.LogLeadNoteSetup
FChoice.Toolkits.Clarify.Sales.LogLeadPhoneSetup
FChoice.Toolkits.Clarify.Sales.MoveActionItemSetup
FChoice.Toolkits.Clarify.Sales.MoveOpportunitySetup
FChoice.Toolkits.Clarify.Sales.MoveQuoteSetup
FChoice.Toolkits.Clarify.Sales.RejectActionItemSetup
FChoice.Toolkits.Clarify.Sales.RejectOpportunitySetup
FChoice.Toolkits.Clarify.Sales.RejectQuoteSetup
FChoice.Toolkits.Clarify.Sales.ReopenOpportunitySetup
FChoice.Toolkits.Clarify.Sales.UpdateActionItemSetup
FChoice.Toolkits.Clarify.Sales.UpdateLeadSetup
FChoice.Toolkits.Clarify.Sales.UpdateOpportunitySetup
FChoice.Toolkits.Clarify.Sales.YankActionItemSetup
FChoice.Toolkits.Clarify.Sales.YankOpportunitySetup
FChoice.Toolkits.Clarify.Sales.YankQuoteSetup
FChoice.Toolkits.Clarify.Support.LogEmailInSetup
FChoice.Toolkits.Clarify.Sales.LogActionItemEmailInSetup
FChoice.Toolkits.Clarify.ToolkitBase
FChoice.Toolkits.Clarify.Sales.SalesToolkitBase
FChoice.Toolkits.Clarify.Sales.SalesToolkit

Reference

FChoice.Toolkits.Clarify Assembly


SimplifiedAdditionalField Class Properties | fcSDK Documentation

SimplifiedAdditionalField Class Properties

For a list of all members of this type, see SimplifiedAdditionalField members.

Public Properties

 | Name | Description
Public Property | FieldName |
Public Property | FieldValue |

Reference

SimplifiedAdditionalField Class
FChoice.Toolkits.Clarify Namespace


SimplifiedAdditionalFields Class Methods | fcSDK Documentation

SimplifiedAdditionalFields Class Methods

For a list of all members of this type, see SimplifiedAdditionalFields members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

SimplifiedAdditionalFields Class
FChoice.Toolkits.Clarify Namespace


SimplifiedAdditionalFields Class Properties | fcSDK Documentation

SimplifiedAdditionalFields Class Properties

For a list of all members of this type, see SimplifiedAdditionalFields members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | Item | (Inherited from System.Collections.Generic.List)

Reference

SimplifiedAdditionalFields Class
FChoice.Toolkits.Clarify Namespace


AcceptCaseSetup Class Properties | fcSDK Documentation

AcceptCaseSetup Class Properties

For a list of all members of this type, see AcceptCaseSetup members.

Public Properties

 | Name | Description
Public Property | AcceptDate | DateTime the Case was accepted. If not set, the current time is used.
Public Property | CaseIDNum | Case Identifier.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | UserName | The user who has accepted the Case. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Case. If not set, the UserName's default is used.

Reference

AcceptCaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
AcceptCase(AcceptCaseSetup) Method


AcceptSubcaseSetup Class Properties | fcSDK Documentation

AcceptSubcaseSetup Class Properties

For a list of all members of this type, see AcceptSubcaseSetup members.

Public Properties

 | Name | Description
Public Property | AcceptDate | DateTime the Subcase was accepted. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | SubcaseIDNum | Subcase Identifier.
Public Property | UserName | The user who has accepted the Subcase. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Subcase. If not set, the UserName's default is used.

Reference

AcceptSubcaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
AcceptSubcase(AcceptSubcaseSetup) Method


AssignCaseSetup Class Properties | fcSDK Documentation

AssignCaseSetup Class Properties

For a list of all members of this type, see AssignCaseSetup members.

Public Properties

 | Name | Description
Public Property | AssignDate | DateTime the Case was assigned. If not set, the current time is used.
Public Property | CaseIDNum | Case Identifier.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewUser | The new user to which the Case is to be assigned.
Public Property | UserName | The user who has assigned the Case. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Case. If not set, the UserName's default is used.

Reference

AssignCaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
AssignCase(AssignCaseSetup) Method


AssignSubcaseSetup Class Properties | fcSDK Documentation

AssignSubcaseSetup Class Properties

For a list of all members of this type, see AssignSubcaseSetup members.

Public Properties

 | Name | Description
Public Property | AssignDate | DateTime the Subcase was assigned. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewUser | The new user to which the Subcase is to be assigned.
Public Property | SubcaseIDNum | Subcase Identifier.
Public Property | UserName | The user who has assigned the Subcase. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Subcase. If not set, the UserName's default is used.

Reference

AssignSubcaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
AssignSubcase(AssignSubcaseSetup) Method


CaseTimeAndExpenses Class Fields | fcSDK Documentation

CaseTimeAndExpenses Class Fields

For a list of all members of this type, see CaseTimeAndExpenses members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | EMPTY | Retrieves an instance of a CaseTimeAndExpenses object that can be used to specify "none specified" when setting the CloseSums on the CloseCaseSetup object

Reference

CaseTimeAndExpenses Class
FChoice.Toolkits.Clarify.Support Namespace


CaseTimeAndExpenses Class Properties | fcSDK Documentation

CaseTimeAndExpenses Class Properties

For a list of all members of this type, see CaseTimeAndExpenses members.

Public Properties

 | Name | Description
Public Property | CaseActualPhoneTime | Actual phone time for the Case
Public Property | CaseActualResearchTime | Actual research time for the Case
Public Property | CaseBillableExpenses | Captured billable expenses (Case time logs only)
Public Property | CaseBillableTime | Captured billable time (Case time logs only)
Public Property | CaseNonBillableExpenses | Captured non-billable expenses (Case time logs only)
Public Property | CaseNonBillableTime | Captured non-billable time (Case time logs only)
Public Property | CasePhoneTime | Captured phone time (Case phone logs only)
Public Property | CaseResearchTime | Captured research time (Case research logs only)
Public Property | TotalActualPhoneTime | Actual phone time (closed subcase only)
Public Property | TotalActualResearchTime | Actual research time (closed subcase only)
Public Property | TotalBillableExpenses | Total billable expenses (closed Subcase and Case expense logs)
Public Property | TotalBillableTime | Total billable time (closed Subcase and Case time logs)
Public Property | TotalNonBillableExpenses | Total billable expenses (closed Subcase and Case expense logs)
Public Property | TotalNonBillableTime | Total non-billable time (closed Subcase and Case time logs)
Public Property | TotalPhoneTime | Total phone time (closed Subcase and phone log for the Case)
Public Property | TotalResearchTime | Total research time (closed Subcase and research logs for the Case)

Reference

CaseTimeAndExpenses Class
FChoice.Toolkits.Clarify.Support Namespace


CaseTimeAndExpenses Constructor | fcSDK Documentation

CaseTimeAndExpenses Constructor

Overload List

Overload | Description
CaseTimeAndExpenses Constructor |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

CaseTimeAndExpenses Class
CaseTimeAndExpenses Members


ChangeCaseContactSetup Class Properties | fcSDK Documentation

ChangeCaseContactSetup Class Properties

For a list of all members of this type, see ChangeCaseContactSetup members.

Public Properties

 | Name | Description
Public Property | CaseIDNum | Case Identifier.
Public Property | ChangeDate | DateTime the change was made. If not set, the current time is used.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | OnlyOpen | The OnlyOpen property, which defaults to true, is checked before updating the case contact.
Public Property | SiteIDNum |
Public Property | UserName | The User who changed the Case. If not set, the session user is used.

Reference

ChangeCaseContactSetup Class
FChoice.Toolkits.Clarify.Support Namespace
ChangeCaseContact(ChangeCaseContactSetup) Method


ChangeCaseSiteSetup Class Properties | fcSDK Documentation

ChangeCaseSiteSetup Class Properties

For a list of all members of this type, see ChangeCaseSiteSetup members.

Public Properties

 | Name | Description
Public Property | CaseIDNum | Case Identifier.
Public Property | ChangeDate | DateTime the change was made. If not set, the current time is used.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | OnlyOpen | The OnlyOpen property, which defaults to true, is checked before updating the case site.
Public Property | SiteIDNum | Site Identifier.
Public Property | UserName | The User who changed the Case. If not set, the session user is used.

Reference

ChangeCaseSiteSetup Class
FChoice.Toolkits.Clarify.Support Namespace
ChangeCaseSite(ChangeCaseSiteSetup) Method


ChangeCaseStatusSetup Class Properties | fcSDK Documentation

ChangeCaseStatusSetup Class Properties

For a list of all members of this type, see ChangeCaseStatusSetup members.

Public Properties

 | Name | Description
Public Property | CaseIDNum | Case Identifier.
Public Property | ChangeDate | DateTime the change was made. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewStatus | The new status for the Case.
Public Property | Notes | Notes for the status change.
Public Property | UserName | The User who changed the Case. If not set, the session user is used.

Reference

ChangeCaseStatusSetup Class
FChoice.Toolkits.Clarify.Support Namespace
ChangeCaseStatus(ChangeCaseStatusSetup) Method


ChangeSubcaseStatusSetup Class Properties | fcSDK Documentation

ChangeSubcaseStatusSetup Class Properties

For a list of all members of this type, see ChangeSubcaseStatusSetup members.

Public Properties

 | Name | Description
Public Property | ChangeDate | DateTime the change was made. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewStatus | The new status for the Case.
Public Property | Notes | Notes for the status change.
Public Property | SubcaseIDNum | Subcase Identifier.
Public Property | UserName | The User who changed the Subcase. If not set, the session user is used.

Reference

ChangeSubcaseStatusSetup Class
FChoice.Toolkits.Clarify.Support Namespace
ChangeSubcaseStatus(ChangeSubcaseStatusSetup) Method


ClarifyApplicationClock Class Properties | fcSDK Documentation

ClarifyApplicationClock Class Properties

For a list of all members of this type, see ClarifyApplicationClock members.

Public Properties

 | Name | Description
Public Property | Now |

Reference

ClarifyApplicationClock Class
FChoice.Toolkits.Clarify.Support Namespace


CloseCaseSetup Class Properties | fcSDK Documentation

CloseCaseSetup Class Properties

For a list of all members of this type, see CloseCaseSetup members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation. | | Public Property | CaseIDNum | Identifier of the Case being closed. | | Public Property | CaseTimeAndExpenses | Object containing sums information for the case closing. | | Public Property | CloseDate | DateTime the Case was closed. If not set, the current time is used. | | Public Property | GenerateTimeBombs | Specifies if timebombs should be created. | | Public Property | Resolution | Element from the 'Resolution Code' application defined list. If not set, the default list value is used.

| | Public Property | Status | Element from the 'Closed' application defined list. If not set, the default list value is used. | | Public Property | Summary | Summary information about the closure. | | Public Property | UnitsUsed | The number of units to charge against the contract for the Case. If the Case has no contract, this field must be 0. | | Public Property | UserName | The User who closed the Case. If not set, the session user is used. |

Reference

CloseCaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
CloseCase(CloseCaseSetup) Method


CloseSums Property | fcSDK Documentation

CloseSums Property

This property is obsolete.


CloseSubcaseSetup Class Properties | fcSDK Documentation

CloseSubcaseSetup Class Properties

For a list of all members of this type, see CloseSubcaseSetup members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation. | | Public Property | CloseDate | DateTime the Subcase was closed. If not set, the current time is used. | | Public Property | GenerateTimeBombs | Specifies if timebombs should be created. | | Public Property | Resolution | Element from the 'Resolution Code' application defined list. If not set, the default list value is used.

| | Public Property | Status | Element from the 'Closed' application defined list. If not set, the default list value is used. | | Public Property | SubcaseIDNum | Subcase Identifier. | | Public Property | Summary | Information about the closure. | | Public Property | UserName | The User who closed the Subcase. If not set, the session user is used. |

Reference

CloseSubcaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
CloseSubcase(CloseSubcaseSetup) Method


CompatibilityApplicationClock Class Properties | fcSDK Documentation

CompatibilityApplicationClock Class Properties

For a list of all members of this type, see CompatibilityApplicationClock members.

Public Properties

 | Name | Description
Public Property | Now |

Reference

CompatibilityApplicationClock Class
FChoice.Toolkits.Clarify.Support Namespace


CreateCaseObjidSetup Class Properties | fcSDK Documentation

CreateCaseObjidSetup Class Properties

For a list of all members of this type, see CreateCaseObjidSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | AddressObjid | Address Objid.
Public Property | CaseType | Element from the 'Case Type' application defined list. If not set, the default list value is used.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactObjid | Contact Objid that represents the contact for the Case.
Public Property | ContactPhone | Contact's phone number.
Public Property | ContractObjid | Contract Objid for the Case. If not set, there is no contract.
Public Property | CreateDate | DateTime the Case was created. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | PartRevisionObjid | Revision Objid of the Case part or SitePart.
Public Property | PhoneEndDate | If there is a phone log, this is the DateTime that the call ended. If not set, the Case creation time is used.
Public Property | PhoneLogNotes | Phone notes for the Case.
Public Property | Priority | Element from the 'Response Priority Code' application defined list. If not set, the default list value is used.
Public Property | Queue | Name of the queue to dispatch the Case to. If not set, the Case is not initially dispatched.
Public Property | Serverity | Element from the 'Problem Severity Level' application defined list. If not set, the default list value is used.
Public Property | SiteObjid | Site Objid to which Site reported the Case.
Public Property | SitePartObjid | Objid of SitePart for the Case.
Public Property | Status | Initial status. Element from the 'Open' application defined list. If not set, the default list value is used.
Public Property | Title | Title for the Case.
Public Property | UserName | The User who created the Case. If not set, the session user is used.

Reference

CreateCaseObjidSetup Class
FChoice.Toolkits.Clarify.Support Namespace
CreateCaseObjid(CreateCaseObjidSetup) Method


CreateCaseSetup Class Properties | fcSDK Documentation

CreateCaseSetup Class Properties

For a list of all members of this type, see CreateCaseSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CaseType | Element from the 'Case Type' application defined list. If not set, the default list value is used.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | ContractIDNum | Contract Identifier for the Case. If not set, no Contract is related to the Case.
Public Property | CreateDate | DateTime the Case was created. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | PartDomain | Part Domain of the Case part or SitePart.
Public Property | PartNumber | Part Number of the Case part or SitePart.
Public Property | PartRevision | Revision of the Case part or SitePart.
Public Property | PhoneEndDate | If there is a phone log, this is the DateTime that the call ended. If not set, the Case creation time is used.
Public Property | PhoneLogNotes | Phone notes for the Case.
Public Property | Priority | Element from the 'Response Priority Code' application defined list. If not set, the default list value is used.
Public Property | Queue | Name of the queue to dispatch the Case to. If not set, the Case is not initially dispatched.
Public Property | SerialNumber | Serial number of the SitePart for the Case (if there is one).
Public Property | Severity | Element from the 'Problem Severity Level' application defined list. If not set, the default list value is used.
Public Property | SiteIDNum | Site Identifier to which Site reported the Case.
Public Property | SitePartObjid | Objid of SitePart for the Case.
Public Property | Status | Initial status. Element from the 'Open' application defined list. If not set, the default list value is used.
Public Property | Title | Title for the Case.
Public Property | UserName | The User who created the Case. If not set, the session user is used.

Reference

CreateCaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
CreateCase(CreateCaseSetup) Method


CreateSubcaseSetup Class Properties | fcSDK Documentation

CreateSubcaseSetup Class Properties

For a list of all members of this type, see CreateSubcaseSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CaseIDNum | Case Identifier of the parent Case.
Public Property | CreateDate | DateTime the Subcase was created. If not set, the current time is used.
Public Property | DueDate | DateTime for when the commitment for Subcase is due. If not set, the Subcase creation time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | IsGeneral | Specifies if this is a general Subcase (True), or administrative (False).
Public Property | Notes | Subcase notes.
Public Property | Priority | Element from the 'Response Priority Code' application defined list. If not set, the default list value is used.
Public Property | PriorWarning | The length of time prior to the due date that a warning should be issued.
Public Property | Queue | Name of the queue to dispatch the Subcase to. If not set, the Subcase is not initially dispatched.
Public Property | Severity | Element from the 'Problem Severity Level' application defined list. If not set, the default list value is used.
Public Property | Status | Initial status. Element from the 'Open' application defined list. If not set, the default list value is used.
Public Property | Title | Title for the Case.
Public Property | UserName | The User who created the Subcase. If not set, the session user is used.

Reference

CreateSubcaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
CreateSubcase(CreateSubcaseSetup) Method


DispatchCaseSetup Class Properties | fcSDK Documentation

DispatchCaseSetup Class Properties

For a list of all members of this type, see DispatchCaseSetup members.

Public Properties

 | Name | Description
Public Property | CaseIDNum | Case Identifier.
Public Property | DispatchDate | DateTime the Case was dispatched. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Queue | The queue into which the Case is to be dispatched.
Public Property | UserName | The user who has dispatched the Case. If not set, the Toolkit session user is used.

Reference

DispatchCaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
DispatchCase(DispatchCaseSetup) Method


DispatchSubcaseSetup Class Properties | fcSDK Documentation

DispatchSubcaseSetup Class Properties

For a list of all members of this type, see DispatchSubcaseSetup members.

Public Properties

 | Name | Description
Public Property | DispatchDate | DateTime the Subcase was dispatched. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Queue | The queue into which the Subcase is to be dispatched.
Public Property | SubcaseIDNum | Subcase Identifier.
Public Property | UserName | The user who has dispatched the Subcase. If not set, the Toolkit session user is used.

Reference

DispatchSubcaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
DispatchSubcase(DispatchSubcaseSetup) Method


ForwardCaseSetup Class Properties | fcSDK Documentation

ForwardCaseSetup Class Properties

For a list of all members of this type, see ForwardCaseSetup members.

Public Properties

 | Name | Description
Public Property | CaseIDNum | Case Identifier.
Public Property | ForwardDate | DateTime the Case was forwarded. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewQueue | The new queue into which the Case is to be forwarded.
Public Property | Notes | The reason the Case was rejected from the queue into which it was dispatched.
Public Property | UserName | The user who has forwarded the Case. If not set, the Toolkit session user is used.

Reference

ForwardCaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
ForwardCase(ForwardCaseSetup) Method


ForwardSubcaseSetup Class Properties | fcSDK Documentation

ForwardSubcaseSetup Class Properties

For a list of all members of this type, see ForwardSubcaseSetup members.

Public Properties

 | Name | Description
Public Property | ForwardDate | DateTime the Subcase was forwarded. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | NewQueue | The new queue into which the Subcase is to be forwarded.
Public Property | Notes | The reason the Subcase was rejected from the queue into which it was dispatched.
Public Property | SubcaseIDNum | Subcase Identifier.
Public Property | UserName | The user who has forwarded the Subcase. If not set, the Toolkit session user is used.

Reference

ForwardSubcaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
ForwardSubcase(ForwardSubcaseSetup) Method


FulfillCommitmentSetup Class Properties | fcSDK Documentation

FulfillCommitmentSetup Class Properties

For a list of all members of this type, see FulfillCommitmentSetup members.

Public Properties

 | Name | Description
Public Property | FulfillDate | DateTime the Commitment was fulfilled. If not set, the current time is used.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | LogObjid | Log Objid of the log to be fulfilled.
Public Property | UserName | The User who fulfilled the Commitment. If not set, the session user is used.

Reference

FulfillCommitmentSetup Class
FChoice.Toolkits.Clarify.Support Namespace
FulfillCommitment(FulfillCommitmentSetup) Method


GetCaseTimeAndExpensesResult Class Properties | fcSDK Documentation

GetCaseTimeAndExpensesResult Class Properties

For a list of all members of this type, see GetCaseTimeAndExpensesResult members.

Public Properties

 | Name | Description
Public Property | CaseTimeAndExpenses | Contains the sums and totals of time and expenses calculated before closing a Case.
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)

Reference

GetCaseTimeAndExpensesResult Class
FChoice.Toolkits.Clarify.Support Namespace


GetCaseTimeAndExpensesResult Constructor | fcSDK Documentation

GetCaseTimeAndExpensesResult Constructor

Overload List

Overload | Description
GetCaseTimeAndExpensesResult Constructor |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GetCaseTimeAndExpensesResult Class
GetCaseTimeAndExpensesResult Members


GetCaseTimeAndExpensesSetup Class Properties | fcSDK Documentation

GetCaseTimeAndExpensesSetup Class Properties

For a list of all members of this type, see GetCaseTimeAndExpensesSetup members.

Public Properties

 | Name | Description
Public Property | CaseIDNum | Case Identifier.

Reference

GetCaseTimeAndExpensesSetup Class
FChoice.Toolkits.Clarify.Support Namespace
GetCaseTimeAndExpenses(GetCaseTimeAndExpensesSetup) Method


GetSubcaseTimeAndExpensesResult Class Properties | fcSDK Documentation

GetSubcaseTimeAndExpensesResult Class Properties

For a list of all members of this type, see GetSubcaseTimeAndExpensesResult members.

Public Properties

 | Name | Description
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | SubcaseTimeAndExpenses | Contains the sums and totals calculated before closing a Case.

Reference

GetSubcaseTimeAndExpensesResult Class
FChoice.Toolkits.Clarify.Support Namespace


GetSubcaseTimeAndExpensesResult Constructor | fcSDK Documentation

GetSubcaseTimeAndExpensesResult Constructor

Overload List

Overload | Description
GetSubcaseTimeAndExpensesResult Constructor |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GetSubcaseTimeAndExpensesResult Class
GetSubcaseTimeAndExpensesResult Members


GetSubcaseTimeAndExpensesSetup Class Properties | fcSDK Documentation

GetSubcaseTimeAndExpensesSetup Class Properties

For a list of all members of this type, see GetSubcaseTimeAndExpensesSetup members.

Public Properties

 | Name | Description
Public Property | SubcaseIDNum | Subcase Identifier.

Reference

GetSubcaseTimeAndExpensesSetup Class
FChoice.Toolkits.Clarify.Support Namespace
GetSubcaseTimeAndExpenses(GetSubcaseTimeAndExpensesSetup) Method


IApplicationClock Interface Properties | fcSDK Documentation

IApplicationClock Interface Properties

For a list of all members of this type, see IApplicationClock members.

Public Properties

 | Name | Description
Property | Now |

Reference

IApplicationClock Interface
FChoice.Toolkits.Clarify.Support Namespace


InitialResponseSetup Class Properties | fcSDK Documentation

InitialResponseSetup Class Properties

For a list of all members of this type, see InitialResponseSetup members.

Public Properties

 | Name | Description
Public Property | CaseIDNum | Case Identifier.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | IsVIAPhone | Was the Response made via phone.
Public Property | ResponseDate | DateTime the response was made. If not set, the current time is used.
Public Property | UserName | The User who made the response. If not set, the session user is used.

Reference

InitialResponseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
InitialResponse(InitialResponseSetup) Method


LogCaseCommitmentSetup Class Properties | fcSDK Documentation

LogCaseCommitmentSetup Class Properties

For a list of all members of this type, see LogCaseCommitmentSetup members.

Public Properties

 | Name | Description
Public Property | ActionType | Element from the 'Commitment Log Action Type' user defined list. If not set, the default list value is used.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CaseIDNum | Identifier of the Case against which the Committment is being logged.
Public Property | CommitmentDate | DateTime of when the commitment is due. If not set, the LogDate is used.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | GenerateCommitmentEmail | Should the Commitment generate email notifications for the commitment time and prior warning time.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | IsMadeToCustomer | Was the Commitment made to a customer.
Public Property | LogDate | DateTime the log was created. If not set, the current time is used.
Public Property | Notes | Additional notes for the log.
Public Property | PriorWarning | How long before the Commitment expires will the owner will be warned. If not set, no prior warning is given.
Public Property | Title | Title of the commitment.
Public Property | UserName | The User who created the log. If not set, the session user is used.

Reference

LogCaseCommitmentSetup Class
FChoice.Toolkits.Clarify.Support Namespace
LogCaseCommitment(LogCaseCommitmentSetup) Method


LogCaseEmailInSetup Class Properties | fcSDK Documentation

LogCaseEmailInSetup Class Properties

For a list of all members of this type, see LogCaseEmailInSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | CCList | Email addresses of persons CC'd on the email being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | GenerateTimeBombs | Specifies if timebombs should be created. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | IDNumber | Identifier of the Case against which the email in is being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | LogDate | DateTime the log was created. If not set, the current time is used. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | MailLogActionType | Element from the 'Mail Log Action Type' user defined list. If not set, the default list value is used. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | Message | Body of the email being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | Recipient | Email address of the recipients of the email being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | Sender | Email address of the sender of the email being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | Subject | (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | UserName | User who created the log. If not set, the session user is used. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)

Reference

LogCaseEmailInSetup Class
FChoice.Toolkits.Clarify.Support Namespace


LogCaseEmailResult Class Properties | fcSDK Documentation

LogCaseEmailResult Class Properties

For a list of all members of this type, see LogCaseEmailResult members.

Public Properties

 | Name | Description
Public Property | CommitmentObjid | The Objid of the Commitment.
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | StatusChangeObjid | The Objid of the StatusChange.

Reference

LogCaseEmailResult Class
FChoice.Toolkits.Clarify.Support Namespace


LogCaseEmailResult Constructor | fcSDK Documentation

LogCaseEmailResult Constructor

Overload List

Overload | Description
LogCaseEmailResult Constructor |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseEmailResult Class
LogCaseEmailResult Members


LogCaseEmailSetup Class Properties | fcSDK Documentation

LogCaseEmailSetup Class Properties

For a list of all members of this type, see LogCaseEmailSetup members.

Public Properties

 | Name | Description
Public Property | ActionType | Element from the 'Mail Log Action Type' user defined list. If not set, the default list value is used.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CaseIDNum | Identifier of the Case against which the email is being logged.
Public Property | CCList | List of cc recipients for the email.
Public Property | CommitmentActionType | Element from the 'Commitment Log Action Type' user defined list. If not set, the default list value is used.
Public Property | CommitmentContactObjid | Commitment Objid for the contact of the commitment. If not set, the contact for the Case is used.
Public Property | CommitmentDueDate | The DateTime of when the commitment is due. If not set, the LogDate is used.
Public Property | CommitmentNotes | Notes for the commitment if one is being generated.
Public Property | CommitmentPriorWarning | The length of time preceding the commitment expiration in which the owner will be warned. If not set, no prior warning is given.
Public Property | CommitmentTitle | Title of the commitment.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | IsCommitmentToCustomer | Was the Commitment made to a customer.
Public Property | LogDate | DateTime the log was created. If not set, the current time is used.
Public Property | Message | Email message.
Public Property | NewStatus | New status for the Case.
Public Property | Recipient | List of email addresses the email is sent to.
Public Property | SendEmail | Specifies if a timebomb be added to Clarify that will cause Rule Manager (if running) to send the email.
Public Property | UserName | User who created the log. If not set, the session user is used.

Reference

LogCaseEmailSetup Class
FChoice.Toolkits.Clarify.Support Namespace
LogCaseEmail(LogCaseEmailSetup) Method


LogCaseInternalNoteSetup Class Properties | fcSDK Documentation

LogCaseInternalNoteSetup Class Properties

For a list of all members of this type, see LogCaseInternalNoteSetup members.

Public Properties

 | Name | Description
Public Property | ActionType |
Public Property | AdditionalFields |
Public Property | CaseIDNum |
Public Property | CommitmentDueDate |
Public Property | CommitmentNotes |
Public Property | CommitmentPriorWarning |
Public Property | CommitmentTitle |
Public Property | GenerateTimeBombs |
Public Property | IsCommitmentToCustomer |
Public Property | LogDate |
Public Property | NewStatus |
Public Property | Notes |
Public Property | UserName |

Reference

LogCaseInternalNoteSetup Class
FChoice.Toolkits.Clarify.Support Namespace


LogCaseInternalPhoneSetup Class Properties | fcSDK Documentation

LogCaseInternalPhoneSetup Class Properties

For a list of all members of this type, see LogCaseInternalPhoneSetup members.

Public Properties

 | Name | Description
Public Property | ActionType |
Public Property | AdditionalFields |
Public Property | CaseIDNum |
Public Property | CommitmentDueDate |
Public Property | CommitmentNotes |
Public Property | CommitmentPriorWarning |
Public Property | CommitmentTitle |
Public Property | ContactFirstName |
Public Property | ContactLastName |
Public Property | ContactPhone |
Public Property | GenerateTimeBombs |
Public Property | IsCommitmentToCustomer |
Public Property | LogDate |
Public Property | LogEndDate |
Public Property | NewStatus |
Public Property | Notes |
Public Property | UserName |

Reference

LogCaseInternalPhoneSetup Class
FChoice.Toolkits.Clarify.Support Namespace


LogCaseNoteResult Class Properties | fcSDK Documentation

LogCaseNoteResult Class Properties

For a list of all members of this type, see LogCaseNoteResult members.

Public Properties

 | Name | Description
Public Property | CommitmentObjid | The Objid of the Commitment.
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | StatusChangeObjid | The Objid of the StatusChange.

Reference

LogCaseNoteResult Class
FChoice.Toolkits.Clarify.Support Namespace


LogCaseNoteResult Constructor | fcSDK Documentation

LogCaseNoteResult Constructor

Overload List

Overload | Description
LogCaseNoteResult Constructor |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseNoteResult Class
LogCaseNoteResult Members


LogCaseNoteSetup Class Properties | fcSDK Documentation

LogCaseNoteSetup Class Properties

For a list of all members of this type, see LogCaseNoteSetup members.

Public Properties

 | Name | Description
Public Property | ActionType | Element from the 'Note Log Action Type' user defined list. If not set, the default list value is used.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CaseIDNum | Identifier of the Case against which the note is being logged.
Public Property | CommitmentDueDate | DateTime when the commitment is due. If not set, the LogDate is used.
Public Property | CommitmentNotes | Notes for the commitment if one is being generated.
Public Property | CommitmentPriorWarning | How long before the Commitment expires will the owner will be warned. If not set, no prior warning is given.
Public Property | CommitmentTitle | Title of the commitment.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | InternalUseOnlyNotes | Notes for internal use only.
Public Property | IsCommitmentToCustomer | Was the Commitment made to a customer.
Public Property | LogDate | DateTime the log was created. If not set, the current time is used.
Public Property | NewStatus | New status for the Case.
Public Property | Notes | Notes to be logged to the Case.
Public Property | UserName | User who created the log. If not set, the session user is used.

Reference

LogCaseNoteSetup Class
FChoice.Toolkits.Clarify.Support Namespace
LogCaseNote(LogCaseNoteSetup) Method


LogCasePhoneResult Class Properties | fcSDK Documentation

LogCasePhoneResult Class Properties

For a list of all members of this type, see LogCasePhoneResult members.

Public Properties

 | Name | Description
Public Property | CommitmentObjid | The Objid of the Commitment.
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | StatusChangeObjid | The Objid of the StatusChange.

Reference

LogCasePhoneResult Class
FChoice.Toolkits.Clarify.Support Namespace


LogCasePhoneResult Constructor | fcSDK Documentation

LogCasePhoneResult Constructor

Overload List

Overload | Description
LogCasePhoneResult Constructor |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCasePhoneResult Class
LogCasePhoneResult Members


LogCasePhoneSetup Class Properties | fcSDK Documentation

LogCasePhoneSetup Class Properties

For a list of all members of this type, see LogCasePhoneSetup members.

Public Properties

 | Name | Description
Public Property | ActionType | Element from the 'Phone Log Action Type' user defined list. If not set, the default list value is used.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CaseIDNum | Identifier of the Case against which the phone note is being logged.
Public Property | CommitmentDueDate | The DateTime of when the commitment is due. If not set, the LogDate is used.
Public Property | CommitmentNotes | Notes for the commitment if one is being generated.
Public Property | CommitmentPriorWarning | The length of time preceding the commitment expiration in which the owner will be warned. If not set, no prior warning is given.
Public Property | CommitmentTitle | Title of the commitment.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | InternalUseOnlyNotes | Notes for internal use only.
Public Property | IsCommitmentToCustomer | Specifies if the commitment is to the customer (True) or by the customer (False).
Public Property | LogDate | DateTime the log was created. If not set, the current time is used.
Public Property | LogEndDate | DateTime of the end of the phone call. If not set, the LogDate is used.
Public Property | NewStatus | New status for the Case.
Public Property | Notes | Notes to be logged to the Case.
Public Property | UserName | User who created the log. If not set, the session user is used.

Reference

LogCasePhoneSetup Class
FChoice.Toolkits.Clarify.Support Namespace
LogCasePhone(LogCasePhoneSetup) Method


LogCaseResearchResult Class Properties | fcSDK Documentation

LogCaseResearchResult Class Properties

For a list of all members of this type, see LogCaseResearchResult members.

Public Properties

 | Name | Description
Public Property | CommitmentObjid | The Objid of the Commitment.
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | StatusChangeObjid | The Objid of the StatusChange.

Reference

LogCaseResearchResult Class
FChoice.Toolkits.Clarify.Support Namespace


LogCaseResearchResult Constructor | fcSDK Documentation

LogCaseResearchResult Constructor

Overload List

Overload | Description
LogCaseResearchResult Constructor |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogCaseResearchResult Class
LogCaseResearchResult Members


LogCaseResearchSetup Class Properties | fcSDK Documentation

LogCaseResearchSetup Class Properties

For a list of all members of this type, see LogCaseResearchSetup members.

Public Properties

 | Name | Description
Public Property | ActionType | Element from the 'Research Log Action Type' user defined list. If not set, the default list value is used.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CaseIDNum | Identifier of the Case against which the research note is being logged.
Public Property | CommitmentDueDate | The DateTime of when the commitment is due. If not set, the LogDate is used.
Public Property | CommitmentNotes | Notes for the commitment if one is being generated.
Public Property | CommitmentPriorWarning | The length of time preceding the commitment expiration in which the owner will be warned. If not set, no prior warning is given.
Public Property | CommitmentTitle | Title of the commitment.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | InternalUseOnlyNotes | Notes for internal use only.
Public Property | IsCommitmentToCustomer | Specifies if the commitment is to the customer (True) or by the customer (False).
Public Property | LogDate | DateTime the log was created. If not set, the current time is used.
Public Property | NewStatus | New status for the Case.
Public Property | Notes | Notes to be logged to the Case.
Public Property | ResearchDuration | The length of time for research.
Public Property | UserName | User who created the log. If not set, the session user is used.

Reference

LogCaseResearchSetup Class
FChoice.Toolkits.Clarify.Support Namespace
LogCaseResearch(LogCaseResearchSetup) Method


LogEmailInSetup Class Properties | fcSDK Documentation

LogEmailInSetup Class Properties

For a list of all members of this type, see LogEmailInSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CCList | Email addresses of persons CC'd on the email being logged.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | IDNumber | Identifier of the Case against which the email in is being logged.
Public Property | LogDate | DateTime the log was created. If not set, the current time is used
Public Property | MailLogActionType | Element from the 'Mail Log Action Type' user defined list. If not set, the default list value is used.
Public Property | Message | Body of the email being logged.
Public Property | Recipient | Email address of the recipients of the email being logged.
Public Property | Sender | Email address of the sender of the email being logged.
Public Property | Subject |
Public Property | UserName | User who created the log. If not set, the session user is used.

Reference

LogEmailInSetup Class
FChoice.Toolkits.Clarify.Support Namespace


LogSubcaseCommitmentSetup Class Properties | fcSDK Documentation

LogSubcaseCommitmentSetup Class Properties

For a list of all members of this type, see LogSubcaseCommitmentSetup members.

Public Properties

 | Name | Description
Public Property | ActionType | Element from the 'Commitment Log Action Type' user defined list. If not set, the default list value is used.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CommitmentDate | DateTime when the commitment is due. If not set, the LogDate is used.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | GenerateCommitmentEmail | Specifies if the API should add the email notifications for the commitment time and prior warning time.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | IsMadeToCustomer | Specifies if the commitment is to the customer (True) or by the customer (False).
Public Property | LogDate | DateTime the log was created. If not set, the current time is used.
Public Property | Notes | Additional notes for the log.
Public Property | PriorWarning | The length of time preceding the commitment expiration in which the owner will be warned. If not set, no prior warning is given.
Public Property | SubcaseIDNum | Identifier of the Subcase against which the commitment is being logged.
Public Property | Title | Title of the commitment.
Public Property | UserName | User who created the log. If not set, the session user is used.

Reference

LogSubcaseCommitmentSetup Class
FChoice.Toolkits.Clarify.Support Namespace
LogSubcaseCommitment(LogSubcaseCommitmentSetup) Method


LogSubCaseEmailInSetup Class Properties | fcSDK Documentation

LogSubCaseEmailInSetup Class Properties

For a list of all members of this type, see LogSubCaseEmailInSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Element from the 'Mail Log Action Type' user defined list. If not set, the default list value is used. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | CCList | Email addresses of persons CC'd on the email being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | GenerateTimeBombs | Specifies if timebombs should be created. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | IDNumber | Identifier of the Case against which the email in is being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | LogDate | DateTime the log was created. If not set, the current time is used (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | MailLogActionType | Element from the 'Mail Log Action Type' user defined list. If not set, the default list value is used. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | Message | Body of the email being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | Recipient | Recipient of the email being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | Sender | Sender of the email being logged. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | Subject | (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)
Public Property | UserName | User who created the log. If not set, the session user is used. (Inherited from FChoice.Toolkits.Clarify.Support.LogEmailInSetup)

Reference

LogSubCaseEmailInSetup Class
FChoice.Toolkits.Clarify.Support Namespace


LogSubcaseEmailResult Class Properties | fcSDK Documentation

LogSubcaseEmailResult Class Properties

For a list of all members of this type, see LogSubcaseEmailResult members.

Public Properties

 | Name | Description
Public Property | CommitmentObjid | The Objid of the Commitment.
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | StatusChangeObjid | The Objid of the StatusChange.

Reference

LogSubcaseEmailResult Class
FChoice.Toolkits.Clarify.Support Namespace


LogSubcaseEmailResult Constructor | fcSDK Documentation

LogSubcaseEmailResult Constructor

Overload List

Overload | Description
LogSubcaseEmailResult Constructor |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseEmailResult Class
LogSubcaseEmailResult Members


LogSubcaseEmailSetup Class Properties | fcSDK Documentation

LogSubcaseEmailSetup Class Properties

For a list of all members of this type, see LogSubcaseEmailSetup members.

Public Properties

 | Name | Description
Public Property | ActionType | Element from the 'Mail Log Action Type' user defined list. If not set, the default list value is used.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CCList | List of cc recipients for the email.
Public Property | CommitmentActionType | Element from the 'Commitment Log Action Type' user defined list. If not set, the default list value is used.
Public Property | CommitmentContactObjid | Commitment Objid for the contact of the commitment. If not set, the contact for the Case is used.
Public Property | CommitmentDueDate | The DateTime of when the commitment is due. If not set, the LogDate is used.
Public Property | CommitmentNotes | Notes for the commitment if one is being generated.
Public Property | CommitmentPriorWarning | The length of time preceding the commitment expiration in which the owner will be warned. If not set, no prior warning is given.
Public Property | CommitmentTitle | Title of the commitment.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | IsCommitmentToCustomer | Specifies if the commitment is to the customer (True) or by the customer (False).
Public Property | LogDate | DateTime the log was created. If not set, the current time is used.
Public Property | Message | Email message.
Public Property | NewStatus | New status for the Subcase.
Public Property | Recipient | List of email addresses the email is sent to.
Public Property | SendEmail | Specifies if a timebomb be added to Clarify that will cause Rule Manager (if running) to send the email.
Public Property | SubcaseIDNum | Identifier of the Subcase against which the email is being logged.
Public Property | UserName | User who created the log. If not set, the session user is used.

Reference

LogSubcaseEmailSetup Class
FChoice.Toolkits.Clarify.Support Namespace
LogSubcaseEmail(LogSubcaseEmailSetup) Method


LogSubcaseInternalNoteSetup Class Properties | fcSDK Documentation

LogSubcaseInternalNoteSetup Class Properties

For a list of all members of this type, see LogSubcaseInternalNoteSetup members.

Public Properties

 | Name | Description
Public Property | ActionType |
Public Property | AdditionalFields |
Public Property | CommitmentDueDate |
Public Property | CommitmentNotes |
Public Property | CommitmentPriorWarning |
Public Property | CommitmentTitle |
Public Property | GenerateTimeBombs |
Public Property | IsCommitmentToCustomer |
Public Property | LogDate |
Public Property | NewStatus |
Public Property | Notes |
Public Property | SubcaseIDNum |
Public Property | UserName |

Reference

LogSubcaseInternalNoteSetup Class
FChoice.Toolkits.Clarify.Support Namespace


LogSubcaseInternalPhoneSetup Class Properties | fcSDK Documentation

LogSubcaseInternalPhoneSetup Class Properties

For a list of all members of this type, see LogSubcaseInternalPhoneSetup members.

Public Properties

 | Name | Description
Public Property | ActionType |
Public Property | AdditionalFields |
Public Property | CommitmentDueDate |
Public Property | CommitmentNotes |
Public Property | CommitmentPriorWarning |
Public Property | CommitmentTitle |
Public Property | ContactFirstName |
Public Property | ContactLastName |
Public Property | ContactPhone |
Public Property | GenerateTimeBombs |
Public Property | IsCommitmentToCustomer |
Public Property | LogDate |
Public Property | LogEndDate |
Public Property | NewStatus |
Public Property | Notes |
Public Property | SubcaseIDNum |
Public Property | UserName |

Reference

LogSubcaseInternalPhoneSetup Class
FChoice.Toolkits.Clarify.Support Namespace


LogSubcaseNoteResult Class Properties | fcSDK Documentation

LogSubcaseNoteResult Class Properties

For a list of all members of this type, see LogSubcaseNoteResult members.

Public Properties

 | Name | Description
Public Property | CommitmentObjid | The Objid of the Commitment.
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | StatusChangeObjid | The Objid of the StatusChange.

Reference

LogSubcaseNoteResult Class
FChoice.Toolkits.Clarify.Support Namespace


LogSubcaseNoteResult Constructor | fcSDK Documentation

LogSubcaseNoteResult Constructor

Overload List

Overload | Description
LogSubcaseNoteResult Constructor |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseNoteResult Class
LogSubcaseNoteResult Members


LogSubcaseNoteSetup Class Properties | fcSDK Documentation

LogSubcaseNoteSetup Class Properties

For a list of all members of this type, see LogSubcaseNoteSetup members.

Public Properties

 | Name | Description
Public Property | ActionType | Element from the 'Note Log Action Type' user defined list. If not set, the default list value is used.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CommitmentDueDate | The DateTime of when the commitment is due. If not set, the LogDate is used.
Public Property | CommitmentNotes | Notes for the commitment if one is being generated.
Public Property | CommitmentPriorWarning | The length of time preceding the commitment expiration in which the owner will be warned. If not set, no prior warning is given.
Public Property | CommitmentTitle | Title of the commitment.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | InternalUseOnlyNotes | Notes for internal use only.
Public Property | IsCommitmentToCustomer | Specifies if the commitment is to the customer (True) or by the customer (False).
Public Property | LogDate | DateTime the log was created. If not set, the current time is used.
Public Property | NewStatus | New status for the Subcase.
Public Property | Notes | Notes to be logged to the Subcase.
Public Property | SubcaseIDNum | Identifier of the Subcase against which the note is being logged.
Public Property | UserName | User who created the log. If not set, the session user is used.

Reference

LogSubcaseNoteSetup Class
FChoice.Toolkits.Clarify.Support Namespace
LogSubcaseNote(LogSubcaseNoteSetup) Method


LogSubcasePhoneResult Class Properties | fcSDK Documentation

LogSubcasePhoneResult Class Properties

For a list of all members of this type, see LogSubcasePhoneResult members.

Public Properties

 | Name | Description
Public Property | CommitmentObjid | The Objid of the Commitment.
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | StatusChangeObjid | The Objid of the StatusChange.

Reference

LogSubcasePhoneResult Class
FChoice.Toolkits.Clarify.Support Namespace


LogSubcasePhoneResult Constructor | fcSDK Documentation

LogSubcasePhoneResult Constructor

Overload List

Overload | Description
LogSubcasePhoneResult Constructor |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcasePhoneResult Class
LogSubcasePhoneResult Members


LogSubcasePhoneSetup Class Properties | fcSDK Documentation

LogSubcasePhoneSetup Class Properties

For a list of all members of this type, see LogSubcasePhoneSetup members.

Public Properties

 | Name | Description
Public Property | ActionType | Element from the 'Phone Log Action Type' user defined list. If not set, the default list value is used.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CommitmentDueDate | The DateTime of when the commitment is due. If not set, the LogDate is used.
Public Property | CommitmentNotes | Notes for the commitment if one is being generated.
Public Property | CommitmentPriorWarning | The length of time preceding the commitment expiration in which the owner will be warned. If not set, no prior warning is given.
Public Property | CommitmentTitle | Title of the commitment.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | InternalUseOnlyNotes | Notes for internal use only.
Public Property | IsCommitmentToCustomer | Specifies if the commitment is to the customer (True) or by the customer (False).
Public Property | LogDate | DateTime the log was created. If not set, the current time is used.
Public Property | LogEndDate | The DateTime of the end of the phone call. If not set, the LogDate is used.
Public Property | NewStatus | New status for the Subcase.
Public Property | Notes | Notes to be logged to the Case.
Public Property | SubcaseIDNum | Identifier of the Subcase against which the phone note is being logged.
Public Property | UserName | User who created the log. If not set, the session user is used.

Reference

LogSubcasePhoneSetup Class
FChoice.Toolkits.Clarify.Support Namespace
LogSubcasePhone(LogSubcasePhoneSetup) Method


LogSubcaseResearchResult Class Properties | fcSDK Documentation

LogSubcaseResearchResult Class Properties

For a list of all members of this type, see LogSubcaseResearchResult members.

Public Properties

 | Name | Description
Public Property | CommitmentObjid | The Objid of the Commitment.
Public Property | IDNum | Identifier of the object modified by the API invocation. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | Objid | Objid of the object modified by the API invocation (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | ReturnCode | Return code of the API call. (Inherited from FChoice.Toolkits.Clarify.ToolkitResult)
Public Property | StatusChangeObjid | The Objid of the StatusChange.

Reference

LogSubcaseResearchResult Class
FChoice.Toolkits.Clarify.Support Namespace


LogSubcaseResearchResult Constructor | fcSDK Documentation

LogSubcaseResearchResult Constructor

Overload List

Overload | Description
LogSubcaseResearchResult Constructor |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

LogSubcaseResearchResult Class
LogSubcaseResearchResult Members


LogSubcaseResearchSetup Class Properties | fcSDK Documentation

LogSubcaseResearchSetup Class Properties

For a list of all members of this type, see LogSubcaseResearchSetup members.

Public Properties

 | Name | Description
Public Property | ActionType | Element from the 'Research Log Action Type' user defined list. If not set, the default list value is used.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CommitmentDueDate | The DateTime of when the commitment is due. If not set, the LogDate is used.
Public Property | CommitmentNotes | Notes for the commitment if one is being generated.
Public Property | CommitmentPriorWarning | The length of time preceding the commitment expiration in which the owner will be warned. If not set, no prior warning is given.
Public Property | CommitmentTitle | Title of the commitment.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | InternalUseOnlyNotes | Notes for internal use only.
Public Property | IsCommitmentToCustomer | Specifies if the commitment is to the customer (True) or by the customer (False).
Public Property | LogDate | DateTime the log was created. If not set, the current time is used.
Public Property | NewStatus | New status for the Subcase.
Public Property | Notes | Notes to be logged to the Subcase.
Public Property | ResearchDuration | The length of time for research.
Public Property | SubcaseIDNum | Identifier of the Subcase against which the research note is being logged.
Public Property | UserName | User who created the log. If not set, the session user is used.

Reference

LogSubcaseResearchSetup Class
FChoice.Toolkits.Clarify.Support Namespace
LogSubcaseResearch(LogSubcaseResearchSetup) Method


MoveCaseSetup Class Properties | fcSDK Documentation

MoveCaseSetup Class Properties

For a list of all members of this type, see MoveCaseSetup members.

Public Properties

 | Name | Description
Public Property | CaseIDNum | Case Identifier.
Public Property | NewWipBin | The new WipBin into which the Case is to be moved.

Reference

MoveCaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
MoveCase(MoveCaseSetup) Method


MoveSubcaseSetup Class Properties | fcSDK Documentation

MoveSubcaseSetup Class Properties

For a list of all members of this type, see MoveSubcaseSetup members.

Public Properties

 | Name | Description
Public Property | NewWipBin | The new WipBin into which the Subcase is to be moved.
Public Property | SubcaseIDNum | Subcase Identifier.

Reference

MoveSubcaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
MoveSubcase(MoveSubcaseSetup) Method


RejectCaseSetup Class Properties | fcSDK Documentation

RejectCaseSetup Class Properties

For a list of all members of this type, see RejectCaseSetup members.

Public Properties

 | Name | Description
Public Property | CaseIDNum | Case Identifier.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Notes | The reason the Case was rejected from the queue into which it was dispatched.
Public Property | RejectDate | DateTime the Case was rejected. If not set, the current time is used.
Public Property | UserName | The user who has rejected the Case. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Case. If not set, the UserName's default is used.

Reference

RejectCaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
RejectCase(RejectCaseSetup) Method


RejectSubcaseSetup Class Properties | fcSDK Documentation

RejectSubcaseSetup Class Properties

For a list of all members of this type, see RejectSubcaseSetup members.

Public Properties

 | Name | Description
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | Notes | The reason the Subcase was rejected from the queue into which it was dispatched.
Public Property | RejectDate | DateTime the Subcase was rejected. If not set, the current time is used.
Public Property | SubcaseIDNum | Subcase Identifier.
Public Property | UserName | The user who has rejected the Subcase. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Subcase. If not set, the UserName's default is used.

Reference

RejectSubcaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
RejectSubcase(RejectSubcaseSetup) Method


RelateCaseToParentCaseSetup Class Properties | fcSDK Documentation

RelateCaseToParentCaseSetup Class Properties

For a list of all members of this type, see RelateCaseToParentCaseSetup members.

Public Properties

 | Name | Description
Public Property | CaseIDNum | Identifier of the child Case in the relation.
Public Property | ParentCaseIDNum | Identifier of a oarent Case in the relation.

Reference

RelateCaseToParentCaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
RelateCaseToParentCase(RelateCaseToParentCaseSetup) Method


ReopenCaseSetup Class Properties | fcSDK Documentation

ReopenCaseSetup Class Properties

For a list of all members of this type, see ReopenCaseSetup members.

Public Properties

 | Name | Description
Public Property | CaseIDNum | Identifier of the Case being reopened.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | ReopenDate | DateTime the Case was reopened. If not set, the current time is used.
Public Property | Status | New status for the Case. If not set, the default status for 'Open' condition is used.
Public Property | UserName | User who reopened the Case. If not set, the session user is used.
Public Property | WipBin | WipBin to place the Case in. If not set, the users default WibBin is used.

Reference

ReopenCaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
ReopenCase(ReopenCaseSetup) Method


ReopenSubcaseSetup Class Properties | fcSDK Documentation

ReopenSubcaseSetup Class Properties

For a list of all members of this type, see ReopenSubcaseSetup members.

Public Properties

 | Name | Description
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | ReopenDate | DateTime the Subcase was Reopen. If not set, the current time is used.
Public Property | Status | New status for the Subcase. If not set, the default status for Open Condition is used.
Public Property | SubcaseIDNum | Identifier of the Subcase being reopened.
Public Property | UserName | The User who rejected the Subcase. If not set, the session user is used.
Public Property | WipBin | WipBin to place the Subcase in. If not set, the users default WibBin is used.

Reference

ReopenSubcaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
ReopenSubcase(ReopenSubcaseSetup) Method


SubcaseTimeAndExpenses Class Properties | fcSDK Documentation

SubcaseTimeAndExpenses Class Properties

For a list of all members of this type, see SubcaseTimeAndExpenses members.

Public Properties

 | Name | Description
Public Property | CapturedPhoneTime | Captured phone time.
Public Property | CapturedResearchTime | Captured research time.
Public Property | TotalBillableExpenses | Captured billable expenses.
Public Property | TotalBillableTime | Captured billable time.
Public Property | TotalNonBillableExpenses | Captured non-billable expenses.
Public Property | TotalNonBillableTime | Captured non-billable time.

Reference

SubcaseTimeAndExpenses Class
FChoice.Toolkits.Clarify.Support Namespace


SubcaseTimeAndExpenses Constructor | fcSDK Documentation

SubcaseTimeAndExpenses Constructor

Overload List

Overload | Description
SubcaseTimeAndExpenses Constructor |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

SubcaseTimeAndExpenses Class
SubcaseTimeAndExpenses Members


SupportToolkit Class Fields | fcSDK Documentation

SupportToolkit Class Fields

For a list of all members of this type, see SupportToolkit members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | IsInternalLogIndicator |

Reference

SupportToolkit Class
FChoice.Toolkits.Clarify.Support Namespace


SupportToolkit Class Methods | fcSDK Documentation

SupportToolkit Class Methods

For a list of all members of this type, see SupportToolkit members.

Public Methods

 | Name | Description
Public Method | AcceptCase | Overloaded. Accept the specified Case from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.
Public Method | AcceptSubcase | Overloaded. Accept the specified Subcase from the queue in which it is currently dispatched. This overload takes a set of required parameters for the API.
Public Method | AppendHistoryToCase | Overloaded. Append
Public Method | AppendHistoryToSubCase | Overloaded. Append text to a Subcase and Case's history.
Public Method | AssignCase | Overloaded. Assign the Case to a new user. This overload takes a set of required parameters for the API.
Public Method | AssignSubcase | Overloaded. Assign the Subcase to a new user. This overload takes a set of required parameters for the API.
Public Method | ChangeCaseContact | Overloaded. Changes the contact for a Case. This overload takes a set of required parameters for the API.
Public Method | ChangeCaseSite | Overloaded. Changes the Site of a Case. This overload takes a set of required parameters for the API.
Public Method | ChangeCaseStatus | Overloaded. Changes the status of a Case. This overload takes a set of required parameters for the API.
Public Method | ChangeSubcaseStatus | Overloaded. Changes the status of a Subcase. This overload takes a set of required parameters for the API.
Public Method | CloseCase | Overloaded. Closes the specified Case that is currently open. This overload takes a set of required parameters for the API.
Public Method | CloseSubcase | Overloaded. Closes the specified Subcase. This overload takes a set of required parameters for the API.
Public Method | CreateCase | Overloaded. Creates a new Case. This overload takes a set of required parameters for the API.
Public Method | CreateCaseObjid | Overloaded. Creates a new Case by using know Objids of dependencies to keep from making additional database round trips to look up the Objids. This overload takes a set of required parameters for the API.
Public Method | CreateSubcase | Overloaded. Creates a new Subcase. This overload takes a set of required parameters for the API.
Public Method | DispatchCase | Overloaded. Dispatch the Case to the specified queue. This overload takes a set of required parameters for the API.
Public Method | DispatchSubcase | Overloaded. Dispatch the Subcase to the specified queue. This overload takes a set of required parameters for the API.
Public Method | ForwardCase | Overloaded. Reject-forward the Case from one queue to another. This overload takes a set of required parameters for the API.
Public Method | ForwardSubcase | Overloaded. Reject-forward the Subcase from one queue to another. This overload takes a set of required parameters for the API.
Public Method | FulfillCommitment | Overloaded. Fulfills a previously unfulfilled commitment. This overload takes a set of required parameters for the API.
Public Method | GetCaseTimeAndExpenses | Overloaded. Captures all the summed times (such as phone log time, billable and non-billable expense, etc) for a Case about to be closed. This overload takes a set of required parameters for the API.
Public Method | GetSubcaseTimeAndExpenses | Overloaded. Captures all the summed times (such as phone log time, billable and non-billable expense, etc) for a Subcase about to be closed. This overload takes a set of required parameters for the API.
Public Method | InitialResponse | Overloaded. Marks the initial response to a Case. This overload takes a set of required parameters for the API.
Public Method | LogCaseCommitment | Overloaded. Creates a commitment against a Case. This overload takes a set of required parameters for the API.
Public Method | LogCaseEmail | Overloaded. Creates an email log against a Case. This overload takes a set of required parameters for the API.
Public Method | LogCaseEmailIn | Overloaded. Creates an email in log against a Case.
Public Method | LogCaseInternalNote | Overloaded.
Public Method | LogCaseInternalPhone | Overloaded.
Public Method | LogCaseNote | Overloaded. Creates a note log against a Case. This overload takes a set of required parameters for the API.
Public Method | LogCasePhone | Overloaded. Creates a phone log against a Case. This overload takes a set of required parameters for the API.
Public Method | LogCaseResearch | Overloaded. Creates a research log against a Case. This overload takes a set of required parameters for the API.
Public Method | LogSubcaseCommitment | Overloaded. Creates a commitment against a Subcase. This overload takes a set of required parameters for the API.
Public Method | LogSubcaseEmail | Overloaded. Creates an email log against a Subcase. This overload takes a set of required parameters for the API.
Public Method | LogSubCaseEmailIn | Overloaded. Creates an email in log against a Subcase.
Public Method | LogSubcaseInternalNote | Overloaded.
Public Method | LogSubcaseInternalPhone | Overloaded.
Public Method | LogSubcaseNote | Overloaded. Creates a note log against a Subcase. This overload takes a set of required parameters for the API.
Public Method | LogSubcasePhone | Overloaded. Creates a phone log against a Subcase. This overload takes a set of required parameters for the API.
Public Method | LogSubcaseResearch | Overloaded. Creates a research log against a Subcase. This overload takes a set of required parameters for the API.
Public Method | MoveCase | Overloaded. Move the Case from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
Public Method | MoveSubcase | Overloaded. Move the Subcase from one WipBin to another WipBin. This overload takes a set of required parameters for the API.
Public Method | RejectCase | Overloaded. Reject the Case from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.
Public Method | RejectSubcase | Overloaded. Reject the Subcase from the queue in which it currently resides, and return it to the owner. This overload takes a set of required parameters for the API.
Public Method | RelateCaseToParentCase | Overloaded. Relates a Case to a specified parent Case. This overload takes a set of required parameters for the API.
Public Method | ReopenCase | Overloaded. Reopens the specified Case. This overload takes a set of required parameters for the API.
Public Method | ReopenSubcase | Overloaded. Reopens the specified Subcase. This overload takes a set of required parameters for the API.
Public Method | UnrelateCaseFromParentCase | Overloaded. Unrelates the specified Case from the current parent Case. This overload takes a set of required parameters for the API.
Public Method | UpdateCase | Overloaded. Updates an existing Case. This overload takes a setup object.
Public Method | UpdateCaseCommitment | Overloaded. Updates a commitment against a Case. This overload takes a set of required parameters for the API.
Public Method | UpdateSubcase | Overloaded. Updates an existing Subcase. This overload takes a setup object.
Public Method | UpdateSubcaseCommitment | Overloaded. Updates a commitment against a Subcase. This overload takes a set of required parameters for the API.
Public Method | YankCase | Overloaded. Yank the Case from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.
Public Method | YankSubcase | Overloaded. Yank the Subcase from its current location to a new owner's WipBin. This overload takes a set of required parameters for the API.

Reference

SupportToolkit Class
FChoice.Toolkits.Clarify.Support Namespace


SupportToolkit Class Properties | fcSDK Documentation

SupportToolkit Class Properties

For a list of all members of this type, see SupportToolkit members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | ApplicationClock | Exposed only for testability of certain APIs.

| | Public Property | ImpersonatorUsername | (Inherited from FChoice.Toolkits.Clarify.Support.SupportToolkitBase) | | Public Property | UseDenormalizedCaseTypeLevels | (Inherited from FChoice.Toolkits.Clarify.Support.SupportToolkitBase) |

Reference

SupportToolkit Class
FChoice.Toolkits.Clarify.Support Namespace


SupportToolkitBase Class Properties | fcSDK Documentation

SupportToolkitBase Class Properties

For a list of all members of this type, see SupportToolkitBase members.

Public Properties

 | Name | Description
Public Property | ImpersonatorUsername |
Public Property | UseDenormalizedCaseTypeLevels |

Reference

SupportToolkitBase Class
FChoice.Toolkits.Clarify.Support Namespace


UnrelateCaseFromParentCaseSetup Class Properties | fcSDK Documentation

UnrelateCaseFromParentCaseSetup Class Properties

For a list of all members of this type, see UnrelateCaseFromParentCaseSetup members.

Public Properties

 | Name | Description
Public Property | CaseIDNum | Identifier of the Case being unrelated from its parent Case.

Reference

UnrelateCaseFromParentCaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
UnrelateCaseFromParentCase(UnrelateCaseFromParentCaseSetup) Method


UpdateCaseCommitmentSetup Class Properties | fcSDK Documentation

UpdateCaseCommitmentSetup Class Properties

For a list of all members of this type, see UpdateCaseCommitmentSetup members.

Public Properties

 | Name | Description
Public Property | ActionType | Element from the 'Commitment Log Action Type' user defined list. If not set, the default list value is used.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CaseIDNum | Identifier of the Case.
Public Property | CommitmentDate | DateTime of when the commitment is due.
Public Property | CommitmentObjid | Objid of the commitment to update.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | IsMadeToCustomer | Was the Commitment made to a customer.
Public Property | Notes | Additional notes for the commitment.
Public Property | PriorWarning | How long before the Commitment expires will the owner will be warned.
Public Property | Title | Title of the commitment.
Public Property | UpdateDate | DateTime the Commitment was updated. If not set, the current time is used.
Public Property | UserName | User who updating the Commitment. If not set, the session user is used.

Reference

UpdateCaseCommitmentSetup Class
FChoice.Toolkits.Clarify.Support Namespace
UpdateCaseCommitment(UpdateCaseCommitmentSetup) Method


UpdateCaseSetup Class Properties | fcSDK Documentation

UpdateCaseSetup Class Properties

For a list of all members of this type, see UpdateCaseSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CaseIDNum | Identifier of the Case being updated.
Public Property | CaseType | Element from the 'Case Type' application defined list. If not set, no change is made.
Public Property | ClearContractRelation | If true the Contract will be unrelated from the Case.
Public Property | ClearPartRevisionRelation | If true the Part Revision will be unrelated from the Case.
Public Property | ClearSitePartRelation | If true the Site Part will be unrelated from the Case.
Public Property | ContractObjid | Objid of the Contract for the Case. If not set, no change is made.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | OnlyOpen | The OnlyOpen property, which defaults to true, is checked before updating the case.
Public Property | OnlyOwner | Specifies if only the owner should be allow to modify the Case.
Public Property | PartRevisionObjid | Objid of the Part Revision for the Case. If not set, no change is made.
Public Property | Priority | Element from the 'Response Priority Code' application defined list. If not set, the default list value is used.
Public Property | Severity | Element from the 'Problem Severity Level' application defined list. If not set, the default list value is used.
Public Property | SitePartObjid | Objid of the Part Revision for the Case. If not set, no change is made.
Public Property | Title | Title for the Case.
Public Property | UpdateDate | DateTime the Case was updated. If not set, the current time is used.
Public Property | UserName | User who updating the Case. If not set, the session user is used.

Reference

UpdateCaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
UpdateCase(UpdateCaseSetup) Method


UpdateSubcaseCommitmentSetup Class Properties | fcSDK Documentation

UpdateSubcaseCommitmentSetup Class Properties

For a list of all members of this type, see UpdateSubcaseCommitmentSetup members.

Public Properties

 | Name | Description
Public Property | ActionType | Element from the 'Commitment Log Action Type' user defined list. If not set, the default list value is used.
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | CommitmentDate | DateTime of when the commitment is due.
Public Property | CommitmentObjid | Objid of the commitment to update.
Public Property | ContactFirstName | Contact's first name.
Public Property | ContactLastName | Contact's last name.
Public Property | ContactPhone | Contact's phone number.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | IsMadeToCustomer | Was the Commitment made to a customer.
Public Property | Notes | Additional notes for the commitment.
Public Property | PriorWarning | How long before the Commitment expires will the owner will be warned.
Public Property | SubcaseIDNum | Subcase Identifier.
Public Property | Title | Title of the commitment.
Public Property | UpdateDate | DateTime the Commitment was updated. If not set, the current time is used.
Public Property | UserName | User who updated the Commitment. If not set, the session user is used.

Reference

UpdateSubcaseCommitmentSetup Class
FChoice.Toolkits.Clarify.Support Namespace
UpdateSubcaseCommitment(UpdateSubcaseCommitmentSetup) Method


UpdateSubcaseSetup Class Properties | fcSDK Documentation

UpdateSubcaseSetup Class Properties

For a list of all members of this type, see UpdateSubcaseSetup members.

Public Properties

 | Name | Description
Public Property | AdditionalFields | Allows the specification of additional fields to be updated as part of API invocation.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | OnlyOpen | The OnlyOpen property, which defaults to true, is checked before updating the subcase.
Public Property | OnlyOwner | Specifies if only the owner should be allow to modify the Subcase.
Public Property | Priority | Element from the 'Response Priority Code' application defined list. If not set, the default list value is used.
Public Property | Severity | Element from the 'Problem Severity Level' application defined list. If not set, the default list value is used.
Public Property | SubcaseIDNum | Subcase Identifier.
Public Property | UpdateDate | DateTime the Subcase was updated. If not set, the current time is used.
Public Property | UserName | User who updated the Subcase. If not set, the session user is used.

Reference

UpdateSubcaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
UpdateSubcase(UpdateSubcaseSetup) Method


YankCaseSetup Class Properties | fcSDK Documentation

YankCaseSetup Class Properties

For a list of all members of this type, see YankCaseSetup members.

Public Properties

 | Name | Description
Public Property | CaseIDNum | Case Identifier.
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | UserName | The user who has yanked the Case. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Case. If not set, the UserName's default is used.
Public Property | YankDate | DateTime the Case was yanked. If not set, the current time is used.

Reference

YankCaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
YankCase(YankCaseSetup) Method


YankSubcaseSetup Class Properties | fcSDK Documentation

YankSubcaseSetup Class Properties

For a list of all members of this type, see YankSubcaseSetup members.

Public Properties

 | Name | Description
Public Property | GenerateTimeBombs | Specifies if timebombs should be created.
Public Property | SubcaseIDNum | Subcase Identifier.
Public Property | UserName | The user who has yanked the Subcase. If not set, the Toolkit session user is used.
Public Property | WipBin | User's WipBin in which to place the Subcase. If not set, the UserName's default is used.
Public Property | YankDate | DateTime the Subcase was yanked. If not set, the current time is used.

Reference

YankSubcaseSetup Class
FChoice.Toolkits.Clarify.Support Namespace
YankSubcase(YankSubcaseSetup) Method


FChoice.Toolkits.Clarify.Support Namespace #### Inheritance Hierarchy | fcSDK Documentation

FChoice.Toolkits.Clarify.Support Namespace #### Inheritance Hierarchy

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.Support.AcceptCaseSetup
FChoice.Toolkits.Clarify.Support.AcceptSubcaseSetup
FChoice.Toolkits.Clarify.Support.AssignCaseSetup
FChoice.Toolkits.Clarify.Support.AssignSubcaseSetup
FChoice.Toolkits.Clarify.Support.CaseTimeAndExpenses
FChoice.Toolkits.Clarify.Support.ChangeCaseContactSetup
FChoice.Toolkits.Clarify.Support.ChangeCaseSiteSetup
FChoice.Toolkits.Clarify.Support.ChangeCaseStatusSetup
FChoice.Toolkits.Clarify.Support.ChangeSubcaseStatusSetup
FChoice.Toolkits.Clarify.Support.ClarifyApplicationClock
FChoice.Toolkits.Clarify.Support.CloseCaseSetup
FChoice.Toolkits.Clarify.Support.CloseSubcaseSetup
FChoice.Toolkits.Clarify.Support.CompatibilityApplicationClock
FChoice.Toolkits.Clarify.Support.CreateCaseObjidSetup
FChoice.Toolkits.Clarify.Support.CreateCaseSetup
FChoice.Toolkits.Clarify.Support.CreateSubcaseSetup
FChoice.Toolkits.Clarify.Support.DispatchCaseSetup
FChoice.Toolkits.Clarify.Support.DispatchSubcaseSetup
FChoice.Toolkits.Clarify.Support.ForwardCaseSetup
FChoice.Toolkits.Clarify.Support.ForwardSubcaseSetup
FChoice.Toolkits.Clarify.Support.FulfillCommitmentSetup
FChoice.Toolkits.Clarify.Support.GetCaseTimeAndExpensesSetup
FChoice.Toolkits.Clarify.Support.GetSubcaseTimeAndExpensesSetup
FChoice.Toolkits.Clarify.Support.InitialResponseSetup
FChoice.Toolkits.Clarify.Support.LogCaseCommitmentSetup
FChoice.Toolkits.Clarify.Support.LogCaseEmailSetup
FChoice.Toolkits.Clarify.Support.LogCaseInternalNoteSetup
FChoice.Toolkits.Clarify.Support.LogCaseInternalPhoneSetup
FChoice.Toolkits.Clarify.Support.LogCaseNoteSetup
FChoice.Toolkits.Clarify.Support.LogCasePhoneSetup
FChoice.Toolkits.Clarify.Support.LogCaseResearchSetup
FChoice.Toolkits.Clarify.Support.LogEmailInSetup
FChoice.Toolkits.Clarify.Quality.QualityToolkit.LogCREmailInSetup
FChoice.Toolkits.Clarify.Sales.LogActionItemEmailInSetup
FChoice.Toolkits.Clarify.Support.LogCaseEmailInSetup
FChoice.Toolkits.Clarify.Support.LogSubCaseEmailInSetup
FChoice.Toolkits.Clarify.Support.LogSubcaseCommitmentSetup
FChoice.Toolkits.Clarify.Support.LogSubcaseEmailSetup
FChoice.Toolkits.Clarify.Support.LogSubcaseInternalNoteSetup
FChoice.Toolkits.Clarify.Support.LogSubcaseInternalPhoneSetup
FChoice.Toolkits.Clarify.Support.LogSubcaseNoteSetup
FChoice.Toolkits.Clarify.Support.LogSubcasePhoneSetup
FChoice.Toolkits.Clarify.Support.LogSubcaseResearchSetup
FChoice.Toolkits.Clarify.Support.MoveCaseSetup
FChoice.Toolkits.Clarify.Support.MoveSubcaseSetup
FChoice.Toolkits.Clarify.Support.RejectCaseSetup
FChoice.Toolkits.Clarify.Support.RejectSubcaseSetup
FChoice.Toolkits.Clarify.Support.RelateCaseToParentCaseSetup
FChoice.Toolkits.Clarify.Support.ReopenCaseSetup
FChoice.Toolkits.Clarify.Support.ReopenSubcaseSetup
FChoice.Toolkits.Clarify.Support.SubcaseTimeAndExpenses
FChoice.Toolkits.Clarify.Support.UnrelateCaseFromParentCaseSetup
FChoice.Toolkits.Clarify.Support.UpdateCaseCommitmentSetup
FChoice.Toolkits.Clarify.Support.UpdateCaseSetup
FChoice.Toolkits.Clarify.Support.UpdateSubcaseCommitmentSetup
FChoice.Toolkits.Clarify.Support.UpdateSubcaseSetup
FChoice.Toolkits.Clarify.Support.YankCaseSetup
FChoice.Toolkits.Clarify.Support.YankSubcaseSetup
FChoice.Toolkits.Clarify.ToolkitBase
FChoice.Toolkits.Clarify.Support.SupportToolkitBase
FChoice.Toolkits.Clarify.Support.SupportToolkit
FChoice.Toolkits.Clarify.ToolkitResult
FChoice.Toolkits.Clarify.Support.GetCaseTimeAndExpensesResult
FChoice.Toolkits.Clarify.Support.GetSubcaseTimeAndExpensesResult
FChoice.Toolkits.Clarify.Support.LogCaseEmailResult
FChoice.Toolkits.Clarify.Support.LogCaseNoteResult
FChoice.Toolkits.Clarify.Support.LogCasePhoneResult
FChoice.Toolkits.Clarify.Support.LogCaseResearchResult
FChoice.Toolkits.Clarify.Support.LogSubcaseEmailResult
FChoice.Toolkits.Clarify.Support.LogSubcaseNoteResult
FChoice.Toolkits.Clarify.Support.LogSubcasePhoneResult
FChoice.Toolkits.Clarify.Support.LogSubcaseResearchResult

Reference

FChoice.Toolkits.Clarify Assembly


ToolkitBase Class Fields | fcSDK Documentation

ToolkitBase Class Fields

For a list of all members of this type, see ToolkitBase members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | NOW_DATE | Date constant that tells FCFL.NET to use the database's current DateTime.

Reference

ToolkitBase Class
FChoice.Toolkits.Clarify Namespace


ToolkitResult Class Properties | fcSDK Documentation

ToolkitResult Class Properties

For a list of all members of this type, see ToolkitResult members.

Public Properties

 | Name | Description
Public Property | IDNum | Identifier of the object modified by the API invocation.
Public Property | Objid | Objid of the object modified by the API invocation
Public Property | ReturnCode | Return code of the API call.

Reference

ToolkitResult Class
FChoice.Toolkits.Clarify Namespace


ToolkitResultPropertyAttribute Class Methods | fcSDK Documentation

ToolkitResultPropertyAttribute Class Methods

For a list of all members of this type, see ToolkitResultPropertyAttribute members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)

Reference

ToolkitResultPropertyAttribute Class
FChoice.Toolkits.Clarify Namespace


ToolkitResultPropertyAttribute Class Properties | fcSDK Documentation

ToolkitResultPropertyAttribute Class Properties

For a list of all members of this type, see ToolkitResultPropertyAttribute members.

Public Properties

 | Name | Description
Public Property | DocSummary |
Public Property | PropertyName |
Public Property | TypeId | (Inherited from System.Attribute)

Reference

ToolkitResultPropertyAttribute Class
FChoice.Toolkits.Clarify Namespace


Utility Class Methods | fcSDK Documentation

Utility Class Methods

For a list of all members of this type, see Utility members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | AddExpenseGL |

Reference

Utility Class
FChoice.Toolkits.Clarify Namespace


FChoice.Toolkits.Clarify Namespace #### Inheritance Hierarchy | fcSDK Documentation

FChoice.Toolkits.Clarify Namespace #### Inheritance Hierarchy

Inheritance Hierarchy

System.Object
FChoice.Toolkits.Clarify.AdditionalFields
FChoice.Toolkits.Clarify.CommunicationAddress
FChoice.Toolkits.Clarify.EmailIn
FChoice.Toolkits.Clarify.Location
FChoice.Toolkits.Clarify.PartInfo
FChoice.Toolkits.Clarify.PartRequestInfo
FChoice.Toolkits.Clarify.SimplifiedAdditionalField
FChoice.Toolkits.Clarify.ToolkitBase
FChoice.Toolkits.Clarify.Contracts.ContractsToolkitBase
FChoice.Toolkits.Clarify.Contracts.ContractsToolkit
FChoice.Toolkits.Clarify.DepotRepair.DepotRepairToolkitBase
FChoice.Toolkits.Clarify.DepotRepair.DepotRepairToolkit
FChoice.Toolkits.Clarify.FieldOps.FieldOpsToolkitBase
FChoice.Toolkits.Clarify.FieldOps.FieldOpsToolkit
FChoice.Toolkits.Clarify.Interfaces.InterfacesToolkitBase
FChoice.Toolkits.Clarify.Interfaces.InterfacesToolkit
FChoice.Toolkits.Clarify.Logistics.LogisticsToolkitBase
FChoice.Toolkits.Clarify.Logistics.LogisticsToolkit
FChoice.Toolkits.Clarify.Quality.QualityToolkitBase
FChoice.Toolkits.Clarify.Quality.QualityToolkit
FChoice.Toolkits.Clarify.Sales.SalesToolkitBase
FChoice.Toolkits.Clarify.Sales.SalesToolkit
FChoice.Toolkits.Clarify.Support.SupportToolkitBase
FChoice.Toolkits.Clarify.Support.SupportToolkit
FChoice.Toolkits.Clarify.ToolkitResult
FChoice.Toolkits.Clarify.FieldOps.AddServiceInterruptionResult
FChoice.Toolkits.Clarify.FieldOps.CreateAppointmentResult
FChoice.Toolkits.Clarify.FieldOps.CreateExpenseLogResult
FChoice.Toolkits.Clarify.FieldOps.CreateTimeLogResult
FChoice.Toolkits.Clarify.FieldOps.PartTransferResult
FChoice.Toolkits.Clarify.Interfaces.CreateEmployeeResult
FChoice.Toolkits.Clarify.Interfaces.CreateSolutionResult
FChoice.Toolkits.Clarify.Logistics.CreatePartRequestDetailResult
FChoice.Toolkits.Clarify.Logistics.GetAlternatePartsResult
FChoice.Toolkits.Clarify.Logistics.GetLocationsServicingSiteResult
FChoice.Toolkits.Clarify.Logistics.PartTransferResult
FChoice.Toolkits.Clarify.Logistics.PickResult
FChoice.Toolkits.Clarify.Support.GetCaseTimeAndExpensesResult
FChoice.Toolkits.Clarify.Support.GetSubcaseTimeAndExpensesResult
FChoice.Toolkits.Clarify.Support.LogCaseEmailResult
FChoice.Toolkits.Clarify.Support.LogCaseNoteResult
FChoice.Toolkits.Clarify.Support.LogCasePhoneResult
FChoice.Toolkits.Clarify.Support.LogCaseResearchResult
FChoice.Toolkits.Clarify.Support.LogSubcaseEmailResult
FChoice.Toolkits.Clarify.Support.LogSubcaseNoteResult
FChoice.Toolkits.Clarify.Support.LogSubcasePhoneResult
FChoice.Toolkits.Clarify.Support.LogSubcaseResearchResult
FChoice.Toolkits.Clarify.Utility
System.Attribute
FChoice.Toolkits.Clarify.ConstructorIndexAttribute
FChoice.Toolkits.Clarify.PropertyBitValueAttribute
FChoice.Toolkits.Clarify.ToolkitResultPropertyAttribute
System.Collections.Generic.List
FChoice.Toolkits.Clarify.SimplifiedAdditionalFields
System.Collections.ObjectModel.Collection
FChoice.Toolkits.Clarify.LocationCollection
System.Exception
FChoice.Toolkits.Clarify.ClarifyToolkitException

Reference

FChoice.Toolkits.Clarify Assembly


fcSDK Assembly | fcSDK Documentation

fcSDK Assembly

Namespaces

Namespace | Description
(Global) |
FChoice.Foundation | Base implementation of core CRM capabilities.
FChoice.Foundation.Clarify | The FChoice.Foundation.Clarify namespace provides the main classes for data and application access to Clarify systems. The FChoice.Foundation.Clarify assembly contains classes that provide low-level access to Clarify database systems. FChoice.Foundation.Clarify is part of the First Choice FCFL.NET product.
FChoice.Foundation.Clarify.Attributes |
FChoice.Foundation.Clarify.AutoDest | The FChoice.Foundation.Clarify.AutoDest namespace provides Auto Destination rule processing support which is used frequently within the Clarify system.
FChoice.Foundation.Clarify.DataObjects | The FChoice.Foundation.Clarify.DataObjects namespace contains classes which represent commonly used objects in the Clarify system such as user-defined lists, countries/states/timezones, and localized strings.
FChoice.Foundation.Clarify.Schema | The FChoice.Foundation.Clarify.Schema namespace contains classes which allow object-oriented access to the Clarify system Schema (ADP) objects.
FChoice.Foundation.Clarify.Workflow |
FChoice.Foundation.DataObjects | Collections and support classes that wrap access to database tables.
FChoice.Foundation.DynamicBinding | Support for updating relations between objects that require information that is not yet loaded or available.
FChoice.Foundation.Filters |
FChoice.Foundation.Schema | Interfaces used to access Schema metadata.


(Global) Namespace #### Inheritance Hierarchy | fcSDK Documentation

(Global) Namespace #### Inheritance Hierarchy

Inheritance Hierarchy

System.Object

Reference

fcSDK Assembly


CacheBase Class Events | fcSDK Documentation

CacheBase Class Events

For a list of all members of this type, see CacheBase members.

Public Events

 | Name | Description
Public Event | AnyCacheUpdated |
Public Event | CacheUpdated |

Reference

CacheBase Class
FChoice.Foundation Namespace


CacheBase Class Methods | fcSDK Documentation

CacheBase Class Methods

For a list of all members of this type, see CacheBase members.

Public Methods

 | Name | Description
Public Method | UpdateCache |

Reference

CacheBase Class
FChoice.Foundation Namespace


| fcSDK Documentation

CacheBase Class Properties

For a list of all members of this type, see CacheBase members.

Public Properties

 | Name | Description
Public Property | CacheSetName |
Public Property | CacheType |

Reference

CacheBase Class
FChoice.Foundation Namespace


CacheManager Class Events | fcSDK Documentation

CacheManager Class Events

For a list of all members of this type, see CacheManager members.

Public Events

 | Name | Description
Public Event | CacheLoaded |
Public Event | CachesUpdated |

Reference

CacheManager Class
FChoice.Foundation Namespace


CacheManager Class Fields | fcSDK Documentation

CacheManager Class Fields

For a list of all members of this type, see CacheManager members.

Public Fields

 | Name | Description
Public Field | FC_CACHE_PATH_SUFFIX |

Reference

CacheManager Class
FChoice.Foundation Namespace


CacheManager Class Methods | fcSDK Documentation

CacheManager Class Methods

For a list of all members of this type, see CacheManager members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | AddCache |
static (Shared in Visual Basic) | GetCache |
static (Shared in Visual Basic) | UpdateCaches |

Reference

CacheManager Class
FChoice.Foundation Namespace


CacheManager Class Properties | fcSDK Documentation

CacheManager Class Properties

For a list of all members of this type, see CacheManager members.

Public Properties

 | Name | Description
static (Shared in Visual Basic) | CacheFilePath |
static (Shared in Visual Basic) | ConnectionStringHashValue |
static (Shared in Visual Basic) | IsInitialized |
static (Shared in Visual Basic) | SchemaCache |

Reference

CacheManager Class
FChoice.Foundation Namespace


AltNameAttribute Class Fields | fcSDK Documentation

AltNameAttribute Class Fields

For a list of all members of this type, see AltNameAttribute members.

Public Fields

 | Name | Description
Public Field | AltName |

Reference

AltNameAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


AltNameAttribute Class Methods | fcSDK Documentation

AltNameAttribute Class Methods

For a list of all members of this type, see AltNameAttribute members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)

Reference

AltNameAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


AltNameAttribute Class Properties | fcSDK Documentation

AltNameAttribute Class Properties

For a list of all members of this type, see AltNameAttribute members.

Public Properties

 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)

Reference

AltNameAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


AltTypeAttribute Class Fields | fcSDK Documentation

AltTypeAttribute Class Fields

For a list of all members of this type, see AltTypeAttribute members.

Public Fields

 | Name | Description
Public Field | AltType |
Public Field | ConversionExpression |

Reference

AltTypeAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


AltTypeAttribute Class Methods | fcSDK Documentation

AltTypeAttribute Class Methods

For a list of all members of this type, see AltTypeAttribute members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)

Reference

AltTypeAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


AltTypeAttribute Class Properties | fcSDK Documentation

AltTypeAttribute Class Properties

For a list of all members of this type, see AltTypeAttribute members.

Public Properties

 | Name | Description
Public Property | Method |
Public Property | TypeId | (Inherited from System.Attribute)

Reference

AltTypeAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


CheckIsNullAttribute Class Fields | fcSDK Documentation

CheckIsNullAttribute Class Fields

For a list of all members of this type, see CheckIsNullAttribute members.

Public Fields

 | Name | Description
Public Field | ErrorNumber |

Reference

CheckIsNullAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


CheckIsNullAttribute Class Methods | fcSDK Documentation

CheckIsNullAttribute Class Methods

For a list of all members of this type, see CheckIsNullAttribute members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)

Reference

CheckIsNullAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


CheckIsNullAttribute Class Properties | fcSDK Documentation

CheckIsNullAttribute Class Properties

For a list of all members of this type, see CheckIsNullAttribute members.

Public Properties

 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)

Reference

CheckIsNullAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


FacadePropertyAttribute Class Methods | fcSDK Documentation

FacadePropertyAttribute Class Methods

For a list of all members of this type, see FacadePropertyAttribute members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | GetParameterIndex |
Public Method | HasConstructorIndex |
Public Method | HasConstructorParameterPair |
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)

Reference

FacadePropertyAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


FacadePropertyAttribute Class Properties | fcSDK Documentation

FacadePropertyAttribute Class Properties

For a list of all members of this type, see FacadePropertyAttribute members.

Public Properties

 | Name | Description
Public Property | CheckIsNullErrorNumber |
Public Property | DefaultValue |
Public Property | IsParamArray |
Public Property | MethodName |
Public Property | PropertyName |
Public Property | PropertyType |
Public Property | ReadOnly |
Public Property | Required |
Public Property | SetupExpression |
Public Property | TypeId | (Inherited from System.Attribute)

Reference

FacadePropertyAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


FacadeVoidAttribute Class Fields | fcSDK Documentation

FacadeVoidAttribute Class Fields

For a list of all members of this type, see FacadeVoidAttribute members.

Public Fields

 | Name | Description
Public Field | IsVoid |

Reference

FacadeVoidAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


FacadeVoidAttribute Class Methods | fcSDK Documentation

FacadeVoidAttribute Class Methods

For a list of all members of this type, see FacadeVoidAttribute members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)

Reference

FacadeVoidAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


FacadeVoidAttribute Class Properties | fcSDK Documentation

FacadeVoidAttribute Class Properties

For a list of all members of this type, see FacadeVoidAttribute members.

Public Properties

 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)

Reference

FacadeVoidAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


OutputPropertyAttribute Class Methods | fcSDK Documentation

OutputPropertyAttribute Class Methods

For a list of all members of this type, see OutputPropertyAttribute members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)

Reference

OutputPropertyAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


OutputPropertyAttribute Class Properties | fcSDK Documentation

OutputPropertyAttribute Class Properties

For a list of all members of this type, see OutputPropertyAttribute members.

Public Properties

 | Name | Description
Public Property | DocSummary |
Public Property | FacadeDefaultValue |
Public Property | FacadePropertyName |
Public Property | FacadeType |
Public Property | MethodName |
Public Property | PropertyName |
Public Property | TypeConversionExpression |
Public Property | TypeId | (Inherited from System.Attribute)

Reference

OutputPropertyAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


ParameterDefaultValueAttribute Class Fields | fcSDK Documentation

ParameterDefaultValueAttribute Class Fields

For a list of all members of this type, see ParameterDefaultValueAttribute members.

Public Fields

 | Name | Description
Public Field | method |
Public Field | parameterDefaultValue |

Reference

ParameterDefaultValueAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


ParameterDefaultValueAttribute Class Methods | fcSDK Documentation

ParameterDefaultValueAttribute Class Methods

For a list of all members of this type, see ParameterDefaultValueAttribute members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)

Reference

ParameterDefaultValueAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


ParameterDefaultValueAttribute Class Properties | fcSDK Documentation

ParameterDefaultValueAttribute Class Properties

For a list of all members of this type, see ParameterDefaultValueAttribute members.

Public Properties

 | Name | Description
Public Property | Method |
Public Property | ParameterDefaultValue |
Public Property | TypeId | (Inherited from System.Attribute)

Reference

ParameterDefaultValueAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


ParameterReadOnlyAttribute Class Methods | fcSDK Documentation

ParameterReadOnlyAttribute Class Methods

For a list of all members of this type, see ParameterReadOnlyAttribute members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)

Reference

ParameterReadOnlyAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


ParameterReadOnlyAttribute Class Properties | fcSDK Documentation

ParameterReadOnlyAttribute Class Properties

For a list of all members of this type, see ParameterReadOnlyAttribute members.

Public Properties

 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)

Reference

ParameterReadOnlyAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


ParameterRequiredAttribute Class Fields | fcSDK Documentation

ParameterRequiredAttribute Class Fields

For a list of all members of this type, see ParameterRequiredAttribute members.

Public Fields

 | Name | Description
Public Field | constructorIndex |
Public Field | isParamArray |
Public Field | positionIndex |

Reference

ParameterRequiredAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


ParameterRequiredAttribute Class Methods | fcSDK Documentation

ParameterRequiredAttribute Class Methods

For a list of all members of this type, see ParameterRequiredAttribute members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)

Reference

ParameterRequiredAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


ParameterRequiredAttribute Class Properties | fcSDK Documentation

ParameterRequiredAttribute Class Properties

For a list of all members of this type, see ParameterRequiredAttribute members.

Public Properties

 | Name | Description
Public Property | ConstructorIndex |
Public Property | IsParamArray |
Public Property | IsRequired |
Public Property | Method |
Public Property | PositionIndex |
Public Property | TypeId | (Inherited from System.Attribute)

Reference

ParameterRequiredAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


ParameterVoidAttribute Class Fields | fcSDK Documentation

ParameterVoidAttribute Class Fields

For a list of all members of this type, see ParameterVoidAttribute members.

Public Fields

 | Name | Description
Public Field | isVoid |
Public Field | method |

Reference

ParameterVoidAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


ParameterVoidAttribute Class Methods | fcSDK Documentation

ParameterVoidAttribute Class Methods

For a list of all members of this type, see ParameterVoidAttribute members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)

Reference

ParameterVoidAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


ParameterVoidAttribute Class Properties | fcSDK Documentation

ParameterVoidAttribute Class Properties

For a list of all members of this type, see ParameterVoidAttribute members.

Public Properties

 | Name | Description
Public Property | IsVoid |
Public Property | Method |
Public Property | TypeId | (Inherited from System.Attribute)

Reference

ParameterVoidAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


SplitMethodAttribute Class Methods | fcSDK Documentation

SplitMethodAttribute Class Methods

For a list of all members of this type, see SplitMethodAttribute members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)

Reference

SplitMethodAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


SplitMethodAttribute Class Properties | fcSDK Documentation

SplitMethodAttribute Class Properties

For a list of all members of this type, see SplitMethodAttribute members.

Public Properties

 | Name | Description
Public Property | MethodName |
Public Property | NumOfConstructors |
Public Property | TypeId | (Inherited from System.Attribute)

Reference

SplitMethodAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


ToolkitVisibleAttribute Class Fields | fcSDK Documentation

ToolkitVisibleAttribute Class Fields

For a list of all members of this type, see ToolkitVisibleAttribute members.

Public Fields

 | Name | Description
Public Field | IsVisible |

Reference

ToolkitVisibleAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


ToolkitVisibleAttribute Class Methods | fcSDK Documentation

ToolkitVisibleAttribute Class Methods

For a list of all members of this type, see ToolkitVisibleAttribute members.

Public Methods

 | Name | Description
Public Method | Equals | (Inherited from System.Attribute)
Public Method | GetHashCode | (Inherited from System.Attribute)
Public Method | IsDefaultAttribute | (Inherited from System.Attribute)
Public Method | Match | (Inherited from System.Attribute)

Reference

ToolkitVisibleAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


ToolkitVisibleAttribute Class Properties | fcSDK Documentation

ToolkitVisibleAttribute Class Properties

For a list of all members of this type, see ToolkitVisibleAttribute members.

Public Properties

 | Name | Description
Public Property | TypeId | (Inherited from System.Attribute)

Reference

ToolkitVisibleAttribute Class
FChoice.Foundation.Clarify.Attributes Namespace


FChoice.Foundation.Clarify.Attributes Namespace #### Inheritance Hierarchy | fcSDK Documentation

FChoice.Foundation.Clarify.Attributes Namespace #### Inheritance Hierarchy

Inheritance Hierarchy

System.Object
System.Attribute
FChoice.Foundation.Clarify.Attributes.AltNameAttribute
FChoice.Foundation.Clarify.Attributes.AltTypeAttribute
FChoice.Foundation.Clarify.Attributes.CheckIsNullAttribute
FChoice.Foundation.Clarify.Attributes.FacadePropertyAttribute
FChoice.Foundation.Clarify.Attributes.FacadeVoidAttribute
FChoice.Foundation.Clarify.Attributes.OutputPropertyAttribute
FChoice.Foundation.Clarify.Attributes.ParameterDefaultValueAttribute
FChoice.Foundation.Clarify.Attributes.ParameterReadOnlyAttribute
FChoice.Foundation.Clarify.Attributes.ParameterRequiredAttribute
FChoice.Foundation.Clarify.Attributes.ParameterVoidAttribute
FChoice.Foundation.Clarify.Attributes.SplitMethodAttribute
FChoice.Foundation.Clarify.Attributes.ToolkitVisibleAttribute

Reference

fcSDK Assembly


AutoDestRule Class Methods | fcSDK Documentation

AutoDestRule Class Methods

For a list of all members of this type, see AutoDestRule members.

Public Methods

 | Name | Description
Public Method | EvaluateRule | Overloaded.
static (Shared in Visual Basic) | RetrieveRule |
static (Shared in Visual Basic) | RunRule | Overloaded.

Reference

AutoDestRule Class
FChoice.Foundation.Clarify.AutoDest Namespace


AutoDestRule Class Properties | fcSDK Documentation

AutoDestRule Class Properties

For a list of all members of this type, see AutoDestRule members.

Public Properties

 | Name | Description
Public Property | IsAutoDispatch |
Public Property | Operation |
Public Property | RootTable |
Public Property | RuleText |
Public Property | SuccessfulRuleClause |

Reference

AutoDestRule Class
FChoice.Foundation.Clarify.AutoDest Namespace


FChoice.Foundation.Clarify.AutoDest Namespace #### Inheritance Hierarchy | fcSDK Documentation

FChoice.Foundation.Clarify.AutoDest Namespace #### Inheritance Hierarchy

Inheritance Hierarchy

System.Object
FChoice.Foundation.Clarify.AutoDest.AutoDestRule

Reference

fcSDK Assembly


ClarifyApplication Class Events | fcSDK Documentation

ClarifyApplication Class Events

For a list of all members of this type, see ClarifyApplication members.

Public Events

 | Name | Description
Public Event | InitializeStatusChange | Event fired during Initialization, relaying information about the current status of the initialization process.

Reference

ClarifyApplication Class
FChoice.Foundation.Clarify Namespace


ClarifyApplication Class Methods | fcSDK Documentation

ClarifyApplication Class Methods

For a list of all members of this type, see ClarifyApplication members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | BeginInitialize | Begins an asynchronous ClarifyApplication initialization.
Public Method | CreateSession | Overloaded. Creates a new ClarifySession and logs in using the username and password for the application.
Public Method | CurrentSessions | Provides a view into the FCApplication's currently running sessions. (Inherited from FChoice.Foundation.FCApplication)
Public Method | EncryptClarifyPassword | Generates a string using the same obfuscation algorithm that is compatible with the Clarify Thin Client.
Public Method | EncryptDBPassword | Obfuscates a database password using the Clarify DB password obfuscation algorithm.
static (Shared in Visual Basic) | EndInitialize | Ends an asynchronous ClarifyApplication initialization.
Public Method | GetMtmTableName | Returns the name of the physical MTM table for a given MTM relationship using the Clarify MTM naming conventions
Public Method | GetObjID | Gets the next objid for the given table
static (Shared in Visual Basic) | GetObjIdsFromFCStoredProcedure |
Public Method | GetSession | Retrieves an ClarifySession previously created by CreateSession.
static (Shared in Visual Basic) | Initialize | Overloaded. Initializes ClarifyApplication using the application configuration.
Public Method | IsSessionValid |
static (Shared in Visual Basic) | ValidateEncryptedPassword |

Reference

ClarifyApplication Class
FChoice.Foundation.Clarify Namespace


ClarifyApplication Class Properties | fcSDK Documentation

ClarifyApplication Class Properties

For a list of all members of this type, see ClarifyApplication members.

Public Properties

 | Name | Description
Public Property | ClarifyVersion | Gets a string which describes the version of Clarify that ClarifyApplication is currently running against.
Public Property | ConfigItemCache | Gets a reference to the ConfigItemCache for accessing Clarify config items.
Public Property | ConfigItems | Returns a dictionary that contains Clarify config item key/value pairs
Public Property | Configuration | Collection of application parameters being used by the application object.
Public Property | ConvertTimeZone | Gets or sets whether or not to perform time zone conversions when operating with date/time values
Public Property | DatabaseVersion | (Inherited from FChoice.Foundation.FCApplication)
Public Property | DataRestrictionsEnabled | Gets whether or not First Choice Data Restriction technology is enabled for this Clarify database.
Public Property | DBUserName | Name of the database user the application object is using to connect to the database.
static (Shared in Visual Basic) | Instance | Returns the singleton instance of ClarifyApplication if initialized.
Public Property | IsDbUnicode | Gets whether or not any columns in the Clarify database are flagged as supporting Unicode characters.
Public Property | IsTravelerEnabled | Gets whether or not the Clarify Traveler product is installed and enabled for this database.
Public Property | ListCache | Gets a reference to the ListCache which provides access to Clarify user defined and global lists
Public Property | LocaleCache | Gets a reference to the LocaleCache which provides access to city/state/country/time zone information.
Public Property | SchemaCache | Gets a reference to the SchemaCache which provides access to the Clarify ADP schema information
Public Property | ServerTimeZone | Timezone being used by the application.
Public Property | StringCache | Gets a reference to the StringCache which provides access to the Clarify string DB table and First Choice FCStrings
Public Property | TruncateStringFields | Gets or sets whether or not to truncate string values if they are too large for the field or throw an error

Reference

ClarifyApplication Class
FChoice.Foundation.Clarify Namespace


ClarifyAuthenticationResult Class Properties | fcSDK Documentation

ClarifyAuthenticationResult Class Properties

For a list of all members of this type, see ClarifyAuthenticationResult members.

Public Properties

 | Name | Description
Public Property | PasswordUsed |
Public Property | Success |

Reference

ClarifyAuthenticationResult Class
FChoice.Foundation.Clarify Namespace


ClarifyAuthenticationService Class Methods | fcSDK Documentation

ClarifyAuthenticationService Class Methods

For a list of all members of this type, see ClarifyAuthenticationService members.

Public Methods

 | Name | Description
Public Method | AuthenticateUser |
static (Shared in Visual Basic) | ReconstructConnectString |

Reference

ClarifyAuthenticationService Class
FChoice.Foundation.Clarify Namespace


ClarifyCacheBase Class Events | fcSDK Documentation

ClarifyCacheBase Class Events

For a list of all members of this type, see ClarifyCacheBase members.

Public Events

 | Name | Description
Public Event | CacheUpdated | (Inherited from FChoice.Foundation.CacheBase)

Reference

ClarifyCacheBase Class
FChoice.Foundation.Clarify Namespace


ClarifyCacheBase Class Methods | fcSDK Documentation

ClarifyCacheBase Class Methods

For a list of all members of this type, see ClarifyCacheBase members.

Public Methods

 | Name | Description
Public Method | UpdateCache | (Inherited from FChoice.Foundation.CacheBase)

Reference

ClarifyCacheBase Class
FChoice.Foundation.Clarify Namespace


ClarifyCacheBase Class Properties | fcSDK Documentation

ClarifyCacheBase Class Properties

For a list of all members of this type, see ClarifyCacheBase members.

Public Properties

 | Name | Description
Public Property | CacheSetName | (Inherited from FChoice.Foundation.CacheBase)
Public Property | CacheType | (Inherited from FChoice.Foundation.CacheBase)

Reference

ClarifyCacheBase Class
FChoice.Foundation.Clarify Namespace


ClarifyDataRow Class Methods | fcSDK Documentation

ClarifyDataRow Class Methods

For a list of all members of this type, see ClarifyDataRow members.

Public Methods

 | Name | Description
Public Method | AcceptChanges | (Inherited from System.Data.DataRow)
Public Method | BeginEdit | (Inherited from System.Data.DataRow)
Public Method | CancelEdit | (Inherited from System.Data.DataRow)
Public Method | ClearErrors | (Inherited from System.Data.DataRow)
Public Method | Delete | (Inherited from System.Data.DataRow)
Public Method | EndEdit | (Inherited from System.Data.DataRow)
Public Method | GetChildRows | Overloaded. (Inherited from System.Data.DataRow)
Public Method | GetColumnError | Overloaded. (Inherited from System.Data.DataRow)
Public Method | GetColumnsInError | (Inherited from System.Data.DataRow)
Public Method | GetParentRow | Overloaded. (Inherited from System.Data.DataRow)
Public Method | GetParentRows | Overloaded. (Inherited from System.Data.DataRow)
Public Method | HasVersion | (Inherited from System.Data.DataRow)
Public Method | IsForcedUpdateColumn | (Inherited from FChoice.Foundation.GenericDataRow)
Public Method | IsNull | Overloaded. (Inherited from System.Data.DataRow)
Public Method | RejectChanges | (Inherited from System.Data.DataRow)
Public Method | RelateByID | Relate a unique identifier to this GenericDataRow via a SchemaRelation name. (Inherited from FChoice.Foundation.GenericDataRow)
Public Method | RelatedRows |
Public Method | RelateRecord | Relate a given row to this GenericDataRow via a SchemaRelation name. (Inherited from FChoice.Foundation.GenericDataRow)
Public Method | RelateToIntField | Relate a given row's identifier to an Integer field present on this GenericDataRow. (Inherited from FChoice.Foundation.GenericDataRow)
Public Method | SetAdded | (Inherited from System.Data.DataRow)
Public Method | SetColumnError | Overloaded. (Inherited from System.Data.DataRow)
Public Method | SetModified | (Inherited from System.Data.DataRow)
Public Method | SetParentRow | Overloaded. (Inherited from System.Data.DataRow)
Public Method | Unrelate | UnRelate this GenericDataRow from a single row related to it via the given relation name. (Inherited from FChoice.Foundation.GenericDataRow)
Public Method | UnrelateFromAll | UnRelate this GenericDataRow from all other rows related to it via the given relation name. (Inherited from FChoice.Foundation.GenericDataRow)
Public Method | Update | Overloaded. Commits the row to the database. See FCGeneric's Update for details. (Inherited from FChoice.Foundation.GenericDataRow)

Reference

ClarifyDataRow Class
FChoice.Foundation.Clarify Namespace


ClarifyDataRow Class Properties | fcSDK Documentation

ClarifyDataRow Class Properties

For a list of all members of this type, see ClarifyDataRow members.

Public Properties

 | Name | Description
Public Property | ForcedUpdateColumns | (Inherited from FChoice.Foundation.GenericDataRow)
Public Property | HasErrors | (Inherited from System.Data.DataRow)
Public Property | IsAddForUpdate | Gets a value indicating whether this GenericDataRow was added via AddForUpdate. (Inherited from FChoice.Foundation.GenericDataRow)
Public Property | IsNew | Gets a value indicating whether the current GenericDataRow was added and not yet committed. (Inherited from FChoice.Foundation.GenericDataRow)
Public Property | Item | Overloaded. (Inherited from FChoice.Foundation.GenericDataRow)
Public Property | ItemArray | (Inherited from System.Data.DataRow)
Public Property | ParentGeneric |
Public Property | RowError | (Inherited from System.Data.DataRow)
Public Property | RowGuid | Unique row identifier (Inherited from FChoice.Foundation.GenericDataRow)
Public Property | RowState | (Inherited from System.Data.DataRow)
Public Property | Table |
Public Property | UniqueID | Returns Unique Identifier of this row in the database. (Inherited from FChoice.Foundation.GenericDataRow)

Reference

ClarifyDataRow Class
FChoice.Foundation.Clarify Namespace


ClarifyDataSet Class Methods | fcSDK Documentation

ClarifyDataSet Class Methods

For a list of all members of this type, see ClarifyDataSet members.

Public Methods

 | Name | Description
Public Method | CreateGeneric | Overloaded. Creates a new ClarifyGeneric based on the specified table or view name
Public Method | Query | Overloaded. (Inherited from FChoice.Foundation.GenericDataSet)
Public Method | Update | Overloaded. (Inherited from FChoice.Foundation.GenericDataSet)

Reference

ClarifyDataSet Class
FChoice.Foundation.Clarify Namespace


ClarifyDataSet Class Properties | fcSDK Documentation

ClarifyDataSet Class Properties

For a list of all members of this type, see ClarifyDataSet members.

Public Properties

 | Name | Description
Public Property | DataSet | (Inherited from FChoice.Foundation.GenericDataSet)
Public Property | RestrictionGroup | (Inherited from FChoice.Foundation.GenericDataSet)
Public Property | Session |
Public Property | SortGenerics | (Inherited from FChoice.Foundation.GenericDataSet)
Public Property | UniqueID | (Inherited from FChoice.Foundation.GenericDataSet)

Reference

ClarifyDataSet Class
FChoice.Foundation.Clarify Namespace


ClarifyDataTable Class Events | fcSDK Documentation

ClarifyDataTable Class Events

For a list of all members of this type, see ClarifyDataTable members.

Public Events

 | Name | Description
Public Event | ColumnChanged | (Inherited from System.Data.DataTable)
Public Event | ColumnChanging | (Inherited from System.Data.DataTable)
Public Event | Disposed | (Inherited from System.ComponentModel.MarshalByValueComponent)
Public Event | Initialized | (Inherited from System.Data.DataTable)
Public Event | RowChanged | (Inherited from System.Data.DataTable)
Public Event | RowChanging | (Inherited from System.Data.DataTable)
Public Event | RowDeleted | (Inherited from System.Data.DataTable)
Public Event | RowDeleting | (Inherited from System.Data.DataTable)
Public Event | TableCleared | (Inherited from System.Data.DataTable)
Public Event | TableClearing | (Inherited from System.Data.DataTable)
Public Event | TableNewRow | (Inherited from System.Data.DataTable)

Reference

ClarifyDataTable Class
FChoice.Foundation.Clarify Namespace


ClarifyDataTable Class Methods | fcSDK Documentation

ClarifyDataTable Class Methods

For a list of all members of this type, see ClarifyDataTable members.

Public Methods

 | Name | Description
Public Method | AcceptChanges | (Inherited from System.Data.DataTable)
Public Method | BeginInit | (Inherited from System.Data.DataTable)
Public Method | BeginLoadData | (Inherited from System.Data.DataTable)
Public Method | Clear | (Inherited from System.Data.DataTable)
Public Method | Clone | (Inherited from System.Data.DataTable)
Public Method | Compute | (Inherited from System.Data.DataTable)
Public Method | Copy | (Inherited from System.Data.DataTable)
Public Method | CreateDataReader | (Inherited from System.Data.DataTable)
Public Method | Dispose | (Inherited from System.ComponentModel.MarshalByValueComponent)
Public Method | EndInit | (Inherited from System.Data.DataTable)
Public Method | EndLoadData | (Inherited from System.Data.DataTable)
Public Method | GetChanges | (Inherited from System.Data.DataTable)
Public Method | GetEnumerator | Returns an enumerator that can iterate through the GenericDataTable. (Inherited from FChoice.Foundation.GenericDataTable)
Public Method | GetErrors | (Inherited from System.Data.DataTable)
Public Method | GetObjectData | (Inherited from System.Data.DataTable)
Public Method | GetService | (Inherited from System.ComponentModel.MarshalByValueComponent)
Public Method | ImportRow | (Inherited from System.Data.DataTable)
Public Method | Load | Overloaded. (Inherited from System.Data.DataTable)
Public Method | LoadDataRow | Overloaded. (Inherited from System.Data.DataTable)
Public Method | Merge | Overloaded. (Inherited from System.Data.DataTable)
Public Method | NewRow | (Inherited from System.Data.DataTable)
Public Method | ReadXml | Overloaded. (Inherited from System.Data.DataTable)
Public Method | ReadXmlSchema | Overloaded. (Inherited from System.Data.DataTable)
Public Method | RejectChanges | (Inherited from System.Data.DataTable)
Public Method | Reset | (Inherited from System.Data.DataTable)
Public Method | Select | Overloaded. (Inherited from System.Data.DataTable)
Public Method | ToString | (Inherited from System.Data.DataTable)
Public Method | WriteXml | Overloaded. (Inherited from System.Data.DataTable)
Public Method | WriteXmlSchema | Overloaded. (Inherited from System.Data.DataTable)

Reference

ClarifyDataTable Class
FChoice.Foundation.Clarify Namespace


ClarifyDataTable Class Properties | fcSDK Documentation

ClarifyDataTable Class Properties

For a list of all members of this type, see ClarifyDataTable members.

Public Properties

 | Name | Description
Public Property | CaseSensitive | (Inherited from System.Data.DataTable)
Public Property | ChildRelations | (Inherited from System.Data.DataTable)
Public Property | Columns | (Inherited from System.Data.DataTable)
Public Property | Constraints | (Inherited from System.Data.DataTable)
Public Property | Container | (Inherited from System.ComponentModel.MarshalByValueComponent)
Public Property | Count | Number of GenericDataRows currently in the table. (Inherited from FChoice.Foundation.GenericDataTable)
Public Property | DataSet | (Inherited from System.Data.DataTable)
Public Property | DefaultView | (Inherited from System.Data.DataTable)
Public Property | DesignMode | (Inherited from System.ComponentModel.MarshalByValueComponent)
Public Property | DisplayExpression | (Inherited from System.Data.DataTable)
Public Property | ExtendedProperties | (Inherited from System.Data.DataTable)
Public Property | FCGeneric | (Inherited from FChoice.Foundation.GenericDataTable)
Public Property | Generic |
Public Property | HasErrors | (Inherited from System.Data.DataTable)
Public Property | IsInitialized | (Inherited from System.Data.DataTable)
Public Property | IsMtmTable | Is this table an Many To Many mapping table? (Inherited from FChoice.Foundation.GenericDataTable)
Public Property | Item |
Public Property | Locale | (Inherited from System.Data.DataTable)
Public Property | MinimumCapacity | (Inherited from System.Data.DataTable)
Public Property | Namespace | (Inherited from System.Data.DataTable)
Public Property | ParentRelations | (Inherited from System.Data.DataTable)
Public Property | Prefix | (Inherited from System.Data.DataTable)
Public Property | PrimaryKey | (Inherited from System.Data.DataTable)
Public Property | RemotingFormat | (Inherited from System.Data.DataTable)
Public Property | Rows |
Public Property | Site | (Inherited from System.Data.DataTable)
Public Property | TableName | (Inherited from System.Data.DataTable)

Reference

ClarifyDataTable Class
FChoice.Foundation.Clarify Namespace


Rows Property (ClarifyDataTable) | fcSDK Documentation

Rows Property (ClarifyDataTable)

Overload List

Overload | Description
Rows |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyDataTable Class
ClarifyDataTable Members


ClarifyException Class Methods | fcSDK Documentation

ClarifyException Class Methods

For a list of all members of this type, see ClarifyException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | Sets the SerializationInfo object with the parameter name and additional exception information. (Inherited from FChoice.Common.FCExceptionBase)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)

Reference

ClarifyException Class
FChoice.Foundation.Clarify Namespace


ClarifyException Class Properties | fcSDK Documentation

ClarifyException Class Properties

For a list of all members of this type, see ClarifyException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorCode | Gets the unique error code for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | ErrorMessageID | Gets the message identifier for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)

Reference

ClarifyException Class
FChoice.Foundation.Clarify Namespace


ClarifyGeneric Class Events | fcSDK Documentation

ClarifyGeneric Class Events

For a list of all members of this type, see ClarifyGeneric members.

Public Events

 | Name | Description
Public Event | MaximumRowsExceeded | This event is fired when the MaximumRows property is set and a Query operation has returned too many rows. (Inherited from FChoice.Foundation.FCGeneric)

Reference

ClarifyGeneric Class
FChoice.Foundation.Clarify Namespace


ClarifyGeneric Class Fields | fcSDK Documentation

ClarifyGeneric Class Fields

For a list of all members of this type, see ClarifyGeneric members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | GuidColumnName |

Reference

ClarifyGeneric Class
FChoice.Foundation.Clarify Namespace


ClarifyGeneric Class Methods | fcSDK Documentation

ClarifyGeneric Class Methods

For a list of all members of this type, see ClarifyGeneric members.

Public Methods

| | Name | Description | | --- | --- | --- | | Public Method | AddForUpdate | Creates a new row in the ClarifyGeneric with the specified objId which will be used to update an existing row in the database rather than inserting a new one.

| | Public Method | AddNew | Overloaded. Adds a new row and schedules it for creation in the database when Update is called | | Public Method | AppendFilter | Overloaded. Adds a filter to constrain the results of an FCGeneric Query against a numeric DataField. (Inherited from FChoice.Foundation.FCGeneric) | | Public Method | AppendFilterBetween | Overloaded. Adds a specialized filter to constrain the results of an FCGeneric Query to be between two Integer values. (Inherited from FChoice.Foundation.FCGeneric) | | Public Method | AppendFilterInList | Overloaded. Adds a filter to constrain the results of an FCGeneric Query against a list of possible Integer values**.** (Inherited from FChoice.Foundation.FCGeneric) | | Public Method | AppendFilterIsNull | Adds a filter to constrain the results of an FCGeneric Query against NULL or NOT NULL fields. (Inherited from FChoice.Foundation.FCGeneric) | | Public Method | AppendSort | Overloaded. (Inherited from FChoice.Foundation.FCGeneric) | | Public Method | AssignAllObjIDs | | | Public Method | AssignObjID | (Inherited from FChoice.Foundation.FCGeneric) | | Public Method | ChangeRestrictionGroup | Change the Data Restriction Group of this generic instance overriding the Session default. This method is a helper for when you only know the name of the restriction group. (Inherited from FChoice.Foundation.FCGeneric) | | Public Method | ClearFilters | Clears all filters that have been appended to this generic. (Inherited from FChoice.Foundation.FCGeneric) | | Public Method | ClearSorts | Clears all sort operations that have been appended to this generic. (Inherited from FChoice.Foundation.FCGeneric) | | Public Method | CopyTo | Copies all the rows of the current FCGeneric into to a one-dimensional Array. (Inherited from FChoice.Foundation.FCGeneric) | | Public Method | DeleteAll | Delete all rows present in this FCGeneric. (Inherited from FChoice.Foundation.FCGeneric) | | Public Method | DeleteById | Deletes the row in the table with the specified objid | | Public Method | GetEnumerator | Returns an IEnumerator for the FCGeneric. (Inherited from FChoice.Foundation.FCGeneric) | | Public Method | Query | Overloaded. Overridden. Causes the generic object to query the database table or view using the optionally specified data fields, filters, and sort orders | | Public Method | Traverse | Creates a child generic that is related to this generic through the specified relation | | Public Method | TraverseFromParent | Makes this generic a child that is related to the specified parent generic through the specified relation | | Public Method | TraverseFromRoot | | | Public Method | Update | Overloaded. Updates changes to a single GenericDataRow (Inherited from FChoice.Foundation.FCGeneric) | | Public Method | UpdateAll | Overloaded. Updates all modified rows of the FCGeneric. (Inherited from FChoice.Foundation.FCGeneric) |

Reference

ClarifyGeneric Class
FChoice.Foundation.Clarify Namespace


ClarifyGeneric Class Properties | fcSDK Documentation

ClarifyGeneric Class Properties

For a list of all members of this type, see ClarifyGeneric members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | ChildGenerics | Gets an IDictionary of associated child generics keyed by their relation from the parent (Inherited from FChoice.Foundation.FCGeneric) | | Public Property | Count | Returns the number of rows currently populated by the Query or AddNew methods. (Inherited from FChoice.Foundation.FCGeneric) | | Public Property | DataFields | Collection of data fields that will be returned when Query is invoked. If no fields are selected all fields are returned. (Inherited from FChoice.Foundation.FCGeneric) | | Public Property | DataRestrictionsEnabled | Sets whether or not this FCGeneric will have the DataRestrictions feature enabled if available.

(Inherited from FChoice.Foundation.FCGeneric) | | Public Property | DataSet | | | Public Property | DeleteRelationsToUnrelate | (Inherited from FChoice.Foundation.FCGeneric) | | Public Property | Filter | This is the root filter used to constrain rows returned during Query operations. Initially there are no filters present with filters being added using the AddFilter method. (Inherited from FChoice.Foundation.FCGeneric) | | Public Property | IncludeRelations | Queries will retrieve all relation fields for the Generic (Inherited from FChoice.Foundation.FCGeneric) | | Public Property | IsDistinct | Is this a Generic that should query for only discinct rows. (Inherited from FChoice.Foundation.FCGeneric) | | Public Property | IsSynchronized | Gets a value indicating whether access to the FCGeneric is synchronized (thread-safe). (Inherited from FChoice.Foundation.FCGeneric) | | Public Property | Item | Gets the ClarifyDataRow at the specified index in this ClarifyGeneric | | Public Property | MaximumRows | Controls the maximum number of rows to be returned by the Genric Query. (Inherited from FChoice.Foundation.FCGeneric) | | Public Property | ParentGeneric | Gets a reference to the parent ClarifyGeneric if this generic is a child | | Public Property | ParentRelation | Gets a reference to the ISchemaRelation schema object which represents the relation used to traverse from the ParentGeneric | | Public Property | QueryEmptyToNull |

Sets whether or not this FCGeneric will convert filters on empty strings into filters on Queries that check IS NULL or IS NOT NULL.

(Inherited from FChoice.Foundation.FCGeneric) | | Public Property | RawFilter |

Sets an optional WHERE clause constraint. (WARNING: See remarks for potential security implications)

(Inherited from FChoice.Foundation.FCGeneric) | | Public Property | RestrictionGroup | Override the Session Data Restriction Group of this Generic. The ChangeRestrictionGroup method is available as a helper. (Inherited from FChoice.Foundation.FCGeneric) | | Public Property | Rows | Gets a reference to the ClarifyRowCollection which contains all the rows queried for this generic | | Public Property | SchemaTable | | | Public Property | SearchableFieldPrefix | Overridden. | | Public Property | Session | Gets a reference to the parent ClarifySession of this generic. | | Public Property | SetNullStringsToEmpty | Sets whether or not this FCGeneric will convert a null reference (Nothing in Visual Basic) to empty strings. (Inherited from FChoice.Foundation.FCGeneric) | | Public Property | SyncRoot | Gets an object that can be used to synchronize access to the FCGeneric. (Inherited from FChoice.Foundation.FCGeneric) | | Public Property | TableName | Returns the name of the database table this FCGeneric is based on. (Inherited from FChoice.Foundation.FCGeneric) |

Reference

ClarifyGeneric Class
FChoice.Foundation.Clarify Namespace


ClarifyGenericException Class Methods | fcSDK Documentation

ClarifyGenericException Class Methods

For a list of all members of this type, see ClarifyGenericException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | Sets the SerializationInfo object with the parameter name and additional exception information. (Inherited from FChoice.Common.FCExceptionBase)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)

Reference

ClarifyGenericException Class
FChoice.Foundation.Clarify Namespace


ClarifyGenericException Class Properties | fcSDK Documentation

ClarifyGenericException Class Properties

For a list of all members of this type, see ClarifyGenericException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorCode | Gets the unique error code for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | ErrorMessageID | Gets the message identifier for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)

Reference

ClarifyGenericException Class
FChoice.Foundation.Clarify Namespace


AddForUpdate Method (ClarifyGeneric) | fcSDK Documentation

AddForUpdate Method (ClarifyGeneric)

Creates a new row in the ClarifyGeneric with the specified objId which will be used to update an existing row in the database rather than inserting a new one.

Creates a new row in the ClarifyGeneric with the specified ObjId which will be used to update an existing row in the database rather than inserting a new one.

Overload List

| Overload | Description | | --- | --- | | AddForUpdate | Creates a new row in the ClarifyGeneric with the specified objId which will be used to update an existing row in the database rather than inserting a new one.

|

Remarks

Use this method when you know the objid of an object in the database and making a database query to retrieve the row would be inefficient. Use the GenericDataRow returned to update the generic. When you are finished calling one of the Update methods on the FCGeneric or GenericDataRow will commit the changes to the database.

Note: The UniqueId must be a legal identifier for the Table the Generic belongs to.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyGeneric Class
ClarifyGeneric Members


AssignAllObjIDs Method (ClarifyGeneric) | fcSDK Documentation

AssignAllObjIDs Method (ClarifyGeneric)

Overload List

Overload | Description
AssignAllObjIDs |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyGeneric Class
ClarifyGeneric Members


Traverse Method | fcSDK Documentation

Traverse Method

fcSDK Documentation

Traverse Method

Creates a child generic that is related to this generic through the specified relation

Creates a child generic that is related to this generic through the specified relation

Overload List

Overload | Description
Traverse | Creates a child generic that is related to this generic through the specified relation

Remarks

The new child generic is related and linked to the parent. When the parent is queried or updated, the new generic will be queried or updated as well.

To retrieve the related rows for a given row in either generic after a query, call the RelatedRows method on that row and pass in the opposite generic (see example).

Example

This example shows how to traverse several generics into a hierarchy, query the parent and then iterate through the rows and display the results of the query.

// Create a dataset
ClarifyDataSet dataSet = new ClarifyDataSet(session);

// Get all cases, activity logs, and contact.
ClarifyGeneric gCase = dataSet.CreateGeneric("case");

ClarifyGeneric gAct = gCase.Traverse("case_act2act_entry");

ClarifyGeneric gContact = gCase.Traverse("case_reporter2contact");

// Now query the data
gCase.Query();

// Display return data to the console. First the case, then all
// activity logs then the one contact for the case
foreach( ClarifyDataRow caseRow in gCase )
{
    Console.WriteLine("Case ID: {0}", caseRow\["id_number"\]);

    // Show each act entry
    foreach( ClarifyDataRow actRow in caseRow.RelatedRows(gAct) )
    {
        Console.WriteLine("  Activity: {0}", actRow\["objid"\]);
    }

    // Show each contact
    foreach( ClarifyDataRow conRow in caseRow.RelatedRows(gContact) )
    {
        Console.WriteLine("  Contact: {0} {1}", conRow\["first_name"\], conRow\["last_name"\]);
    }
}

' Create a dataset
Dim dataSet As New ClarifyDataSet(session)

' Get all cases, activity logs, and contact.
Dim gCase As ClarifyGeneric = dataSet.CreateGeneric("case")

Dim gAct As ClarifyGeneric = gCase.Traverse("case_act2act_entry")

Dim gContact As ClarifyGeneric = gCase.Traverse("case_reporter2contact")

' Now query the data
gCase.Query()

' Display return data to the console. First the case, then all
' activity logs then the one contact for the case
For Each caseRow As ClarifyDataRow In gCase

    Console.WriteLine("Case ID: {0}", caseRow("id_number"))

    ' Show each act entry
    For Each actRow As ClarifyDataRow In caseRow.RelatedRows(gAct)
        Console.WriteLine("  Activity: {0}", actRow("objid"))
    Next

    ' Show each contact
    For Each conRow As ClarifyDataRow In caseRow.RelatedRows(gContact)
        Console.WriteLine("  Contact: {0} {1}", conRow("first_name"), conRow("last_name"))
    Next
Next

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

ClarifyGeneric Class
ClarifyGeneric Members


ClarifyRowCollection Class Methods | fcSDK Documentation

ClarifyRowCollection Class Methods

For a list of all members of this type, see ClarifyRowCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds the specified GenericDataRow to the collection. (Inherited from FChoice.Foundation.GenericDataRowCollection)
Public Method | Contains | Overloaded. Test if one ore more GenericDataRows are already in the collection. (Inherited from FChoice.Foundation.GenericDataRowCollection)
Public Method | CopyTo | Copies all the elements of the current GenericDataRowCollection to a one-dimensional Array, starting at the specified index. (Inherited from FChoice.Foundation.GenericDataRowCollection)
Public Method | Find | Overloaded. Gets the row containing the specified primary key values. (Inherited from FChoice.Foundation.GenericDataRowCollection)
Public Method | GetEnumerator | Gets an IEnumerator for the collection. (Inherited from FChoice.Foundation.GenericDataRowCollection)

Reference

ClarifyRowCollection Class
FChoice.Foundation.Clarify Namespace


ClarifyRowCollection Class Properties | fcSDK Documentation

ClarifyRowCollection Class Properties

For a list of all members of this type, see ClarifyRowCollection members.

Public Properties

 | Name | Description
Public Property | Count | Gets the total number of elements in a collection. (Inherited from FChoice.Foundation.GenericDataRowCollection)
Public Property | IsSynchronized | Gets a value indicating whether the GenericDataRowCollection is synchronized. (Inherited from FChoice.Foundation.GenericDataRowCollection)
Public Property | Item |
Public Property | SyncRoot | Gets an object that can be used to synchronize the collection. (Inherited from FChoice.Foundation.GenericDataRowCollection)
Public Property | Table |

Reference

ClarifyRowCollection Class
FChoice.Foundation.Clarify Namespace


ClarifySession Class Methods | fcSDK Documentation

ClarifySession Class Methods

For a list of all members of this type, see ClarifySession members.

Public Methods

| | Name | Description | | --- | --- | --- | | Public Method static (Shared in Visual Basic) | AuthenticateContact | | | Public Method | ChangePassword | Change the password for the session user. (Inherited from FChoice.Foundation.FCSession) | | Public Method | ChangeRestrictionGroup | Changes the RestrictionGroup the session is currently using. The change can be made permanent. (Inherited from FChoice.Foundation.FCSession) | | Public Method | ChangeUserConfigItem | Overloaded. | | Public Method | CloseSession | Remove the session from FCApplication and any Licenses it may be holding. (Inherited from FChoice.Foundation.FCSession) | | Public Method | ConvertDate | Overloaded. Converts a DateTime from one TimeZone to another. (Inherited from FChoice.Foundation.FCSession) | | Public Method | ConvertFromLocalToServerDate | Converts a DateTime from the session timezone to the server timezone. (Inherited from FChoice.Foundation.FCSession) | | Public Method | ConvertFromServerToLocalDate | Converts a DateTime from the server timezone to the session timezone.

(Inherited from FChoice.Foundation.FCSession) | | Public Method | Dispose | (Inherited from FChoice.Foundation.FCSession) | | Public Method | FormatElapsedTime | Overloaded. Formats an numeric value in seconds into a string "DDD HH MMM" where: D=Days, H=Hours, M=Minutes (Inherited from FChoice.Foundation.FCSession) | | Public Method | GetAssignedPermissions | (Inherited from FChoice.Foundation.FCSession) | | Public Method | GetCurrentDate | Retrieves the DateTime of the CRM database. (Inherited from FChoice.Foundation.FCSession) | | Public Method | GetCurrentServerDate | Retrieves the DateTime of the CRM database. (Inherited from FChoice.Foundation.FCSession) | | Public Method | GetNextNumScheme | Overloaded. | | Public Method | HasPermission | (Inherited from FChoice.Foundation.FCSession) | | Public Method | RefreshContext | Refresh the session information for the logged-in user. (Inherited from FChoice.Foundation.FCSession) | | Public Method | RegisterLicenseRequirements | (Inherited from FChoice.Foundation.FCSession) | | Public Method | SaveSession | (Inherited from FChoice.Foundation.FCSession) | | Public Method static (Shared in Visual Basic) | SetContactUserPassword | | | Public Method | SetPassword | Change a user's password (Inherited from FChoice.Foundation.FCSession) |

Reference

ClarifySession Class
FChoice.Foundation.Clarify Namespace


ClarifySession Class Properties | fcSDK Documentation

ClarifySession Class Properties

For a list of all members of this type, see ClarifySession members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | ConfigItems | | | Public Property | ConvertTimeZone | Sets whether or not any DateTimes will be translated to and from ServerTimeZone and LocalTimeZone. Default value is false. (Inherited from FChoice.Foundation.FCSession) | | Public Property | CreationTime | Timestamp when the session was created. (Inherited from FChoice.Foundation.FCSession) | | Public Property | CurrentCulture | Returns the Culture being used by the session. (Inherited from FChoice.Foundation.FCSession) | | Public Property | DataRestrictionsEnabled | (Inherited from FChoice.Foundation.FCSession) | | Public Property | DefaultCulture | Returns the default Culture being used by the session. (Inherited from FChoice.Foundation.FCSession) | | Public Property | DefaultDistinctGenerics | Sets whether or not newly created generic objects will have IsDistinct set to include all relation data fields during Queries.

(Inherited from FChoice.Foundation.FCSession) | | Public Property | DisableDataConversions | Sets whether data conversions happen when GenericDataRow fields are modified. (Inherited from FChoice.Foundation.FCSession) | | Public Property | IncludeRelations | Sets whether or not newly created generic objects will include all relation data fields during Queries. (Inherited from FChoice.Foundation.FCSession) | | Public Property | Item | Get or set session data indexed by specified key. (Inherited from FChoice.Foundation.FCSession) | | Public Property | Items | (Inherited from FChoice.Foundation.FCSession) | | Public Property | LastLoadTime | Timestamp when the session was last loaded via FCApplication.GetSession (Inherited from FChoice.Foundation.FCSession) | | Public Property | LocalTimeZone | The TimeZone being used by the session. (Inherited from FChoice.Foundation.FCSession) | | Public Property | Log | Returns a Logger useful for logging application events or errors to the logging system. (Inherited from FChoice.Foundation.FCSession) | | Public Property | LoginType | | | Public Property | MaximumRows | (Inherited from FChoice.Foundation.FCSession) | | Public Property | PasswordRequired | Gets whether or not a password was used when CreateSession was called. (Inherited from FChoice.Foundation.FCSession) | | Public Property | QueryEmptyToNull |

Sets whether or not new newly created generic objects convert filters on empty strings into filters on Queries that check Is NULL or IS NOT NULL.

(Inherited from FChoice.Foundation.FCSession) | | Public Property | RestrictionGroup | Returns the data restriction group being used by the session. (Inherited from FChoice.Foundation.FCSession) | | Public Property | SessionData | (Inherited from FChoice.Foundation.FCSession) | | Public Property | SessionID |

Returns the session's unique identifier.

(Inherited from FChoice.Foundation.FCSession) | | Public Property | SetNullStringsToEmpty | Sets whether or not newly created generic objects will convert a null reference (Nothing in Visual Basic) to empty strings. (Inherited from FChoice.Foundation.FCSession) | | Public Property | TruncateStringFields | Sets whether or not newly created generic objects will truncate string fields if they are too long. (Inherited from FChoice.Foundation.FCSession) | | Public Property | UserID | Returns the unique identifier for the session's logged-in user. (Inherited from FChoice.Foundation.FCSession) | | Public Property | UserName | Returns the login name for the session's logged-in user. (Inherited from FChoice.Foundation.FCSession) |

Reference

ClarifySession Class
FChoice.Foundation.Clarify Namespace


ClarifySessionData Class Methods | fcSDK Documentation

ClarifySessionData Class Methods

For a list of all members of this type, see ClarifySessionData members.

Public Methods

 | Name | Description
Public Method | CopyTo | Overridden.

Reference

ClarifySessionData Class
FChoice.Foundation.Clarify Namespace


ClarifySessionData Class Properties | fcSDK Documentation

ClarifySessionData Class Properties

For a list of all members of this type, see ClarifySessionData members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | ConfigItems | Collection of CRM session configuration items. (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | ConvertTimeZone | Session option: Gets whether or not any DateTimes will be translated to and from ServerTimeZone and LocalTimeZone. Default value is false. (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | CreationTime | Timestamp when the session was created. (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | CurrentCulture | The Culture being used by the session. (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | CurResGroup | The restriction group being used by the session. (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | DefaultDistinctGenerics | Session option which makes Generics have IsDistinct enable by default. (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | DisableDataConversion | Session option which disables data conversions when values are set for GenericDataRow fields. (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | DisableRestrictions | Returns whether or not the DataRestrictions feature is enabled or disabled. (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | EmptyNullStrings | Session option that cues Generics to make Null fields be empty strings. Specifically for Oracle. (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | IncludeRelations | Session option that cues Generics to include all relation data fields during Queries (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | IsDirty | (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | LastLoadTime | Timestamp when the session was last loaded via GetSession (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | LocalTimeZone | The TimeZone being used by the session. (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | LoginTime | (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | LoginType | User login type (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | MaximumRows | (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | NewSession | (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | PasswordRequired | Session option denoting whether a password was used to create a session. (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | Permissions | (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | PrivatePassword | | | Public Property | QueryEmptyToNull | Session option that cues Generics to convert filters on empty strings into filters on Queries that check Is NULL or IS NOT NULL. (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | SessionData | CRM configurable session data populates this property during CreateSession (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | SessionID | A session's unique identifier.

(Inherited from FChoice.Foundation.FCSessionData) | | Public Property | TruncateStringFields | Session option that cues Generics to truncate strings that exceed database field lengths when assigned to a GenericDataRow (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | UserID | UniqueID of the user that created the Session. (Inherited from FChoice.Foundation.FCSessionData) | | Public Property | UserName | Name of the user that created the Session. (Inherited from FChoice.Foundation.FCSessionData) |

Reference

ClarifySessionData Class
FChoice.Foundation.Clarify Namespace


ConfigItemCache Class Events | fcSDK Documentation

ConfigItemCache Class Events

For a list of all members of this type, see ConfigItemCache members.

Public Events

 | Name | Description
Public Event | CacheUpdated | (Inherited from FChoice.Foundation.CacheBase)

Reference

ConfigItemCache Class
FChoice.Foundation.Clarify Namespace


ConfigItemCache Class Methods | fcSDK Documentation

ConfigItemCache Class Methods

For a list of all members of this type, see ConfigItemCache members.

Public Methods

 | Name | Description
Public Method | UpdateCache | (Inherited from FChoice.Foundation.CacheBase)

Reference

ConfigItemCache Class
FChoice.Foundation.Clarify Namespace


ConfigItemCache Class Properties | fcSDK Documentation

ConfigItemCache Class Properties

For a list of all members of this type, see ConfigItemCache members.

Public Properties

 | Name | Description
Public Property | CacheSetName | Overridden.
Public Property | CacheType | Overridden.
Public Property | ConfigItems | Gets the collection of global config items
Public Property | Item |

Reference

ConfigItemCache Class
FChoice.Foundation.Clarify Namespace


ConfigurationHelper Class Fields | fcSDK Documentation

ConfigurationHelper Class Fields

For a list of all members of this type, see ConfigurationHelper members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | IsClarifyClassicClientLineReturnCompatible |
static (Shared in Visual Basic) | IsOracleAscii7bit |
static (Shared in Visual Basic) | RemoveDateTimeMilliseconds |

Reference

ConfigurationHelper Class
FChoice.Foundation.Clarify Namespace


DatabaseParameterFactory Class Fields | fcSDK Documentation

DatabaseParameterFactory Class Fields

For a list of all members of this type, see DatabaseParameterFactory members.

Public Fields

 | Name | Description
Public Field | EnableSettingStringParameterTypeAndSize |

Reference

DatabaseParameterFactory Class
FChoice.Foundation.Clarify Namespace


DatabaseParameterFactory Class Methods | fcSDK Documentation

DatabaseParameterFactory Class Methods

For a list of all members of this type, see DatabaseParameterFactory members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | ConfigureStringDatabaseParameter |
Public Method | Create | Overloaded.
Public Method | ShouldStringParameterTypeAndSizeBeSet |

Reference

DatabaseParameterFactory Class
FChoice.Foundation.Clarify Namespace


ClarifyConfigItem Class Methods | fcSDK Documentation

ClarifyConfigItem Class Methods

For a list of all members of this type, see ClarifyConfigItem members.

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

ClarifyConfigItem Class
FChoice.Foundation.Clarify.DataObjects Namespace


ClarifyConfigItem Class Properties | fcSDK Documentation

ClarifyConfigItem Class Properties

For a list of all members of this type, see ClarifyConfigItem members.

Public Properties

 | Name | Description
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | DateValue | (Inherited from FChoice.Foundation.DataObjects.ConfigItem)
Public Property | DecimalValue | (Inherited from FChoice.Foundation.DataObjects.ConfigItem)
Public Property | Description | (Inherited from FChoice.Foundation.DataObjects.ConfigItem)
Public Property | DoubleValue | (Inherited from FChoice.Foundation.DataObjects.ConfigItem)
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | IntegerValue | (Inherited from FChoice.Foundation.DataObjects.ConfigItem)
Public Property | LastModTime |
Public Property | LongValue | (Inherited from FChoice.Foundation.DataObjects.ConfigItem)
Public Property | Name | (Inherited from FChoice.Foundation.DataObjects.ConfigItem)
Public Property | Scope | (Inherited from FChoice.Foundation.DataObjects.ConfigItem)
Public Property | StringValue | (Inherited from FChoice.Foundation.DataObjects.ConfigItem)
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | ValueType | (Inherited from FChoice.Foundation.DataObjects.ConfigItem)
Public Property | ValueTypeRaw | (Inherited from FChoice.Foundation.DataObjects.ConfigItem)

Reference

ClarifyConfigItem Class
FChoice.Foundation.Clarify.DataObjects Namespace


ClarifyConfigItemCollection Class Methods | fcSDK Documentation

ClarifyConfigItemCollection Class Methods

For a list of all members of this type, see ClarifyConfigItemCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex | (Inherited from FChoice.Foundation.DataObjects.DataObjectCollection)
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

ClarifyConfigItemCollection Class
FChoice.Foundation.Clarify.DataObjects Namespace


ClarifyConfigItemCollection Class Properties | fcSDK Documentation

ClarifyConfigItemCollection Class Properties

For a list of all members of this type, see ClarifyConfigItemCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | Item | Overloaded.

Reference

ClarifyConfigItemCollection Class
FChoice.Foundation.Clarify.DataObjects Namespace


ClarifyDataObject Class Methods | fcSDK Documentation

ClarifyDataObject Class Methods

For a list of all members of this type, see ClarifyDataObject members.

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

ClarifyDataObject Class
FChoice.Foundation.Clarify.DataObjects Namespace


ClarifyDataObject Class Properties | fcSDK Documentation

ClarifyDataObject Class Properties

For a list of all members of this type, see ClarifyDataObject members.

Public Properties

 | Name | Description
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
static (Shared in Visual Basic) | CommentFieldName |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | ObjectID |
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

ClarifyDataObject Class
FChoice.Foundation.Clarify.DataObjects Namespace


Country Class Methods | fcSDK Documentation

Country Class Methods

For a list of all members of this type, see Country members.

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

Country Class
FChoice.Foundation.Clarify.DataObjects Namespace


Country Class Properties | fcSDK Documentation

Country Class Properties

For a list of all members of this type, see Country members.

Public Properties

 | Name | Description
Public Property | Code |
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | DefaultState |
Public Property | DefaultTimeZone |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | IsDefault |
Public Property | Name |
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | States |
Public Property | TimeZones |
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

Country Class
FChoice.Foundation.Clarify.DataObjects Namespace


CountryCollection Class Methods | fcSDK Documentation

CountryCollection Class Methods

For a list of all members of this type, see CountryCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex | (Inherited from FChoice.Foundation.DataObjects.DataObjectCollection)
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

CountryCollection Class
FChoice.Foundation.Clarify.DataObjects Namespace


CountryCollection Class Properties | fcSDK Documentation

CountryCollection Class Properties

For a list of all members of this type, see CountryCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | DefaultCountry |
Public Property | Item |

Reference

CountryCollection Class
FChoice.Foundation.Clarify.DataObjects Namespace


DaylightSavingsCollection Class Methods | fcSDK Documentation

DaylightSavingsCollection Class Methods

For a list of all members of this type, see DaylightSavingsCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex | (Inherited from FChoice.Foundation.DataObjects.DataObjectCollection)
Public Method | GetPeriod |
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

DaylightSavingsCollection Class
FChoice.Foundation.Clarify.DataObjects Namespace


DaylightSavingsCollection Class Properties | fcSDK Documentation

DaylightSavingsCollection Class Properties

For a list of all members of this type, see DaylightSavingsCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | Item | (Inherited from System.Collections.Generic.List)

Reference

DaylightSavingsCollection Class
FChoice.Foundation.Clarify.DataObjects Namespace


DaylightSavingsPeriod Class Methods | fcSDK Documentation

DaylightSavingsPeriod Class Methods

For a list of all members of this type, see DaylightSavingsPeriod members.

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | Intersects |
Public Method | IsDateInRange |

Reference

DaylightSavingsPeriod Class
FChoice.Foundation.Clarify.DataObjects Namespace


DaylightSavingsPeriod Class Properties | fcSDK Documentation

DaylightSavingsPeriod Class Properties

For a list of all members of this type, see DaylightSavingsPeriod members.

Public Properties

 | Name | Description
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | EndDate |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | StartDate |
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

DaylightSavingsPeriod Class
FChoice.Foundation.Clarify.DataObjects Namespace


FCString Class Methods | fcSDK Documentation

FCString Class Methods

For a list of all members of this type, see FCString members.

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
static (Shared in Visual Basic) | GetCultureForCultureName |
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

FCString Class
FChoice.Foundation.Clarify.DataObjects Namespace


FCString Class Properties | fcSDK Documentation

FCString Class Properties

For a list of all members of this type, see FCString members.

Public Properties

 | Name | Description
Public Property | Application |
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Culture |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | IDKey |
Public Property | LocaleName |
Public Property | NameKey |
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | StringID |
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Value |

Reference

FCString Class
FChoice.Foundation.Clarify.DataObjects Namespace


FCTimeZone Class Methods | fcSDK Documentation

FCTimeZone Class Methods

For a list of all members of this type, see FCTimeZone members.

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
static (Shared in Visual Basic) | ConvertDate | Overloaded.
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | IsDaylightSavingsTime |

Reference

FCTimeZone Class
FChoice.Foundation.Clarify.DataObjects Namespace


FCTimeZone Class Properties | fcSDK Documentation

FCTimeZone Class Properties

For a list of all members of this type, see FCTimeZone members.

Public Properties

 | Name | Description
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | DaylightSavingsPeriods |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | FullName |
Public Property | IsDefault |
Public Property | Name |
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | UtcOffsetSeconds |

Reference

FCTimeZone Class
FChoice.Foundation.Clarify.DataObjects Namespace


FCTimeZoneCollection Class Methods | fcSDK Documentation

FCTimeZoneCollection Class Methods

For a list of all members of this type, see FCTimeZoneCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | Overloaded.
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex | (Inherited from FChoice.Foundation.DataObjects.DataObjectCollection)
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

FCTimeZoneCollection Class
FChoice.Foundation.Clarify.DataObjects Namespace


FCTimeZoneCollection Class Properties | fcSDK Documentation

FCTimeZoneCollection Class Properties

For a list of all members of this type, see FCTimeZoneCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | DefaultTimeZone |
Public Property | Item |

Reference

FCTimeZoneCollection Class
FChoice.Foundation.Clarify.DataObjects Namespace


GlobalStringElement Class Methods | fcSDK Documentation

GlobalStringElement Class Methods

For a list of all members of this type, see GlobalStringElement members.

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetLocalizedTitle |
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

GlobalStringElement Class
FChoice.Foundation.Clarify.DataObjects Namespace


GlobalStringElement Class Properties | fcSDK Documentation

GlobalStringElement Class Properties

For a list of all members of this type, see GlobalStringElement members.

Public Properties

 | Name | Description
Public Property | AdditionalInfo |
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Description |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | LocalizedTitle |
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | Rank |
Public Property | State |
Public Property | Title |
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

GlobalStringElement Class
FChoice.Foundation.Clarify.DataObjects Namespace


GlobalStringElementCollection Class Methods | fcSDK Documentation

GlobalStringElementCollection Class Methods

For a list of all members of this type, see GlobalStringElementCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddElement |
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetElementByObjectId |
Public Method | GetElementByRank |
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex | (Inherited from FChoice.Foundation.DataObjects.DataObjectCollection)
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

GlobalStringElementCollection Class
FChoice.Foundation.Clarify.DataObjects Namespace


GlobalStringElementCollection Class Properties | fcSDK Documentation

GlobalStringElementCollection Class Properties

For a list of all members of this type, see GlobalStringElementCollection members.

Public Properties

 | Name | Description
Public Property | ActiveElements |
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | DefaultElement |
Public Property | InactiveElements |
Public Property | Item |

Reference

GlobalStringElementCollection Class
FChoice.Foundation.Clarify.DataObjects Namespace


GlobalStringList Class Methods | fcSDK Documentation

GlobalStringList Class Methods

For a list of all members of this type, see GlobalStringList members.

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

GlobalStringList Class
FChoice.Foundation.Clarify.DataObjects Namespace


GlobalStringList Class Properties | fcSDK Documentation

GlobalStringList Class Properties

For a list of all members of this type, see GlobalStringList members.

Public Properties

 | Name | Description
Public Property | ActiveElements |
Public Property | AdditionalInfo |
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | DefaultElement |
Public Property | Elements |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | InactiveElements |
Public Property | ListID |
Public Property | LocaleID |
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | Title |
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

GlobalStringList Class
FChoice.Foundation.Clarify.DataObjects Namespace


GlobalStringListCollection Class Methods | fcSDK Documentation

GlobalStringListCollection Class Methods

For a list of all members of this type, see GlobalStringListCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex | (Inherited from FChoice.Foundation.DataObjects.DataObjectCollection)
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

GlobalStringListCollection Class
FChoice.Foundation.Clarify.DataObjects Namespace


GlobalStringListCollection Class Properties | fcSDK Documentation

GlobalStringListCollection Class Properties

For a list of all members of this type, see GlobalStringListCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | Item |

Reference

GlobalStringListCollection Class
FChoice.Foundation.Clarify.DataObjects Namespace


HierarchicalStringElement Class Fields | fcSDK Documentation

HierarchicalStringElement Class Fields

For a list of all members of this type, see HierarchicalStringElement members.

Public Fields

 | Name | Description
Public Field | ACTIVE_STATE |
Public Field | DEFAULT_STATE |
Public Field | INACTIVE_STATE |

Reference

HierarchicalStringElement Class
FChoice.Foundation.Clarify.DataObjects Namespace


HierarchicalStringElement Class Methods | fcSDK Documentation

HierarchicalStringElement Class Methods

For a list of all members of this type, see HierarchicalStringElement members.

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetLocalizedTitle |
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

HierarchicalStringElement Class
FChoice.Foundation.Clarify.DataObjects Namespace


HierarchicalStringElement Class Properties | fcSDK Documentation

HierarchicalStringElement Class Properties

For a list of all members of this type, see HierarchicalStringElement members.

Public Properties

 | Name | Description
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Elements |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | IsActive |
Public Property | IsDefault |
Public Property | LocalizedTitle |
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | Rank |
Public Property | State |
Public Property | Title |
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

HierarchicalStringElement Class
FChoice.Foundation.Clarify.DataObjects Namespace


HierarchicalStringElementCollection Class Methods | fcSDK Documentation

HierarchicalStringElementCollection Class Methods

For a list of all members of this type, see HierarchicalStringElementCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetByObjID |
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex | (Inherited from FChoice.Foundation.DataObjects.DataObjectCollection)
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

HierarchicalStringElementCollection Class
FChoice.Foundation.Clarify.DataObjects Namespace


HierarchicalStringElementCollection Class Properties | fcSDK Documentation

HierarchicalStringElementCollection Class Properties

For a list of all members of this type, see HierarchicalStringElementCollection members.

Public Properties

 | Name | Description
Public Property | ActiveElements |
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | DefaultElement |
Public Property | Item |

Reference

HierarchicalStringElementCollection Class
FChoice.Foundation.Clarify.DataObjects Namespace


HierarchicalStringList Class Methods | fcSDK Documentation

HierarchicalStringList Class Methods

For a list of all members of this type, see HierarchicalStringList members.

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

HierarchicalStringList Class
FChoice.Foundation.Clarify.DataObjects Namespace


HierarchicalStringList Class Properties | fcSDK Documentation

HierarchicalStringList Class Properties

For a list of all members of this type, see HierarchicalStringList members.

Public Properties

 | Name | Description
Public Property | ActiveElements |
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Description |
Public Property | Elements |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | InactiveElements |
Public Property | ListID |
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | Title |
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

HierarchicalStringList Class
FChoice.Foundation.Clarify.DataObjects Namespace


HierarchicalStringListCollection Class Methods | fcSDK Documentation

HierarchicalStringListCollection Class Methods

For a list of all members of this type, see HierarchicalStringListCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex | (Inherited from FChoice.Foundation.DataObjects.DataObjectCollection)
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

HierarchicalStringListCollection Class
FChoice.Foundation.Clarify.DataObjects Namespace


HierarchicalStringListCollection Class Properties | fcSDK Documentation

HierarchicalStringListCollection Class Properties

For a list of all members of this type, see HierarchicalStringListCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | Item |

Reference

HierarchicalStringListCollection Class
FChoice.Foundation.Clarify.DataObjects Namespace


HierarchicalStringShow Class Methods | fcSDK Documentation

HierarchicalStringShow Class Methods

For a list of all members of this type, see HierarchicalStringShow members.

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

HierarchicalStringShow Class
FChoice.Foundation.Clarify.DataObjects Namespace


HierarchicalStringShow Class Properties | fcSDK Documentation

HierarchicalStringShow Class Properties

For a list of all members of this type, see HierarchicalStringShow members.

Public Properties

 | Name | Description
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | DefaultElement |
Public Property | Elements |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | LastModifiedTime |
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | Title |
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

HierarchicalStringShow Class
FChoice.Foundation.Clarify.DataObjects Namespace


IGlobalStringElement Interface Methods | fcSDK Documentation

IGlobalStringElement Interface Methods

For a list of all members of this type, see IGlobalStringElement members.

Public Methods

 | Name | Description
Method | GetLocalizedTitle |

Reference

IGlobalStringElement Interface
FChoice.Foundation.Clarify.DataObjects Namespace


IGlobalStringElement Interface Properties | fcSDK Documentation

IGlobalStringElement Interface Properties

For a list of all members of this type, see IGlobalStringElement members.

Public Properties

 | Name | Description
Property | AdditionalInfo |
Property | Description |
Property | LocalizedTitle |
Property | ObjectID |
Property | Rank |
Property | State |
Property | Title |

Reference

IGlobalStringElement Interface
FChoice.Foundation.Clarify.DataObjects Namespace


IGlobalStringElementCollection Interface Methods | fcSDK Documentation

IGlobalStringElementCollection Interface Methods

For a list of all members of this type, see IGlobalStringElementCollection members.

Public Methods

 | Name | Description
Method | AddElement |
Method | AddRange |
Method | AsReadOnly |
Method | BinarySearch | Overloaded.
Method | CopyTo | Overloaded.
Method | Exists |
Method | Find |
Method | FindAll |
Method | FindIndex | Overloaded.
Method | FindLast |
Method | FindLastIndex | Overloaded.
Method | ForEach |
Method | GetElementByObjectId |
Method | GetElementByRank |
Method | GetItemByIndex |
Method | GetRange |
Method | IndexOf | Overloaded.
Method | InsertRange |
Method | LastIndexOf | Overloaded.
Method | RemoveAll |
Method | RemoveRange |
Method | Reverse | Overloaded.
Method | Sort | Overloaded.
Method | ToArray |
Method | TrimExcess |
Method | TrueForAll |

Reference

IGlobalStringElementCollection Interface
FChoice.Foundation.Clarify.DataObjects Namespace


IGlobalStringElementCollection Interface Properties | fcSDK Documentation

IGlobalStringElementCollection Interface Properties

For a list of all members of this type, see IGlobalStringElementCollection members.

Public Properties

 | Name | Description
Property | ActiveElements |
Property | Capacity |
Property | DefaultElement |
Property | InactiveElements |
Property | Item |

Reference

IGlobalStringElementCollection Interface
FChoice.Foundation.Clarify.DataObjects Namespace


IGlobalStringList Interface Properties | fcSDK Documentation

IGlobalStringList Interface Properties

For a list of all members of this type, see IGlobalStringList members.

Public Properties

 | Name | Description
Property | ActiveElements |
Property | AdditionalInfo |
Property | DefaultElement |
Property | Elements |
Property | InactiveElements |
Property | ListID |
Property | LocaleID |
Property | ObjectID |
Property | Title |

Reference

IGlobalStringList Interface
FChoice.Foundation.Clarify.DataObjects Namespace


IGlobalStringListCollection Interface Methods | fcSDK Documentation

IGlobalStringListCollection Interface Methods

For a list of all members of this type, see IGlobalStringListCollection members.

Public Methods

 | Name | Description
Method | AddRange |
Method | AsReadOnly |
Method | BinarySearch | Overloaded.
Method | CopyTo | Overloaded.
Method | Exists |
Method | Find |
Method | FindAll |
Method | FindIndex | Overloaded.
Method | FindLast |
Method | FindLastIndex | Overloaded.
Method | ForEach |
Method | GetItemByIndex |
Method | GetRange |
Method | IndexOf | Overloaded.
Method | Insert |
Method | InsertRange |
Method | LastIndexOf | Overloaded.
Method | RemoveAll |
Method | RemoveAt |
Method | RemoveRange |
Method | Reverse | Overloaded.
Method | Sort | Overloaded.
Method | ToArray |
Method | TrimExcess |
Method | TrueForAll |

Reference

IGlobalStringListCollection Interface
FChoice.Foundation.Clarify.DataObjects Namespace


IGlobalStringListCollection Interface Properties | fcSDK Documentation

IGlobalStringListCollection Interface Properties

For a list of all members of this type, see IGlobalStringListCollection members.

Public Properties

 | Name | Description
Property | Capacity |
Property | Item | Overloaded.

Reference

IGlobalStringListCollection Interface
FChoice.Foundation.Clarify.DataObjects Namespace


IHierarchicalStringElement Interface Methods | fcSDK Documentation

IHierarchicalStringElement Interface Methods

For a list of all members of this type, see IHierarchicalStringElement members.

Public Methods

 | Name | Description
Method | GetLocalizedTitle |

Reference

IHierarchicalStringElement Interface
FChoice.Foundation.Clarify.DataObjects Namespace


IHierarchicalStringElement Interface Properties | fcSDK Documentation

IHierarchicalStringElement Interface Properties

For a list of all members of this type, see IHierarchicalStringElement members.

Public Properties

 | Name | Description
Property | Elements |
Property | IsActive |
Property | IsDefault |
Property | LocalizedTitle |
Property | ObjectID |
Property | Rank |
Property | State |
Property | Title |

Reference

IHierarchicalStringElement Interface
FChoice.Foundation.Clarify.DataObjects Namespace


IHierarchicalStringElementCollection Interface Methods | fcSDK Documentation

IHierarchicalStringElementCollection Interface Methods

For a list of all members of this type, see IHierarchicalStringElementCollection members.

Public Methods

 | Name | Description
Method | AddRange |
Method | AsReadOnly |
Method | BinarySearch | Overloaded.
Method | CopyTo | Overloaded.
Method | Exists |
Method | Find |
Method | FindAll |
Method | FindIndex | Overloaded.
Method | FindLast |
Method | FindLastIndex | Overloaded.
Method | ForEach |
Method | GetByObjID |
Method | GetItemByIndex |
Method | GetRange |
Method | IndexOf | Overloaded.
Method | InsertRange |
Method | LastIndexOf | Overloaded.
Method | RemoveAll |
Method | RemoveRange |
Method | Reverse | Overloaded.
Method | Sort | Overloaded.
Method | ToArray |
Method | TrimExcess |
Method | TrueForAll |

Reference

IHierarchicalStringElementCollection Interface
FChoice.Foundation.Clarify.DataObjects Namespace


IHierarchicalStringElementCollection Interface Properties | fcSDK Documentation

IHierarchicalStringElementCollection Interface Properties

For a list of all members of this type, see IHierarchicalStringElementCollection members.

Public Properties

 | Name | Description
Property | ActiveElements |
Property | Capacity |
Property | DefaultElement |
Property | Item |

Reference

IHierarchicalStringElementCollection Interface
FChoice.Foundation.Clarify.DataObjects Namespace


IHierarchicalStringList Interface Properties | fcSDK Documentation

IHierarchicalStringList Interface Properties

For a list of all members of this type, see IHierarchicalStringList members.

Public Properties

 | Name | Description
Property | ActiveElements |
Property | Description |
Property | Elements |
Property | InactiveElements |
Property | ListID |
Property | ObjectID |
Property | Title |

Reference

IHierarchicalStringList Interface
FChoice.Foundation.Clarify.DataObjects Namespace


IHierarchicalStringListCollection Interface Methods | fcSDK Documentation

IHierarchicalStringListCollection Interface Methods

For a list of all members of this type, see IHierarchicalStringListCollection members.

Public Methods

 | Name | Description
Method | AddRange |
Method | AsReadOnly |
Method | BinarySearch | Overloaded.
Method | CopyTo | Overloaded.
Method | Exists |
Method | Find |
Method | FindAll |
Method | FindIndex | Overloaded.
Method | FindLast |
Method | FindLastIndex | Overloaded.
Method | ForEach |
Method | GetItemByIndex |
Method | GetRange |
Method | IndexOf | Overloaded.
Method | InsertRange |
Method | LastIndexOf | Overloaded.
Method | RemoveAll |
Method | RemoveRange |
Method | Reverse | Overloaded.
Method | Sort | Overloaded.
Method | ToArray |
Method | TrimExcess |
Method | TrueForAll |

Reference

IHierarchicalStringListCollection Interface
FChoice.Foundation.Clarify.DataObjects Namespace


IHierarchicalStringListCollection Interface Properties | fcSDK Documentation

IHierarchicalStringListCollection Interface Properties

For a list of all members of this type, see IHierarchicalStringListCollection members.

Public Properties

 | Name | Description
Property | Capacity |
Property | Item |

Reference

IHierarchicalStringListCollection Interface
FChoice.Foundation.Clarify.DataObjects Namespace


LocalizedString Class Methods | fcSDK Documentation

LocalizedString Class Methods

For a list of all members of this type, see LocalizedString members.

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

LocalizedString Class
FChoice.Foundation.Clarify.DataObjects Namespace


LocalizedString Class Properties | fcSDK Documentation

LocalizedString Class Properties

For a list of all members of this type, see LocalizedString members.

Public Properties

 | Name | Description
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Culture |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | IDKey |
Public Property | LocaleID |
Public Property | Name |
Public Property | NameKey |
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | StringID |
Public Property | StringType |
Public Property | TranslateIndicator |
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Value |

Reference

LocalizedString Class
FChoice.Foundation.Clarify.DataObjects Namespace


StateCollection Class Methods | fcSDK Documentation

StateCollection Class Methods

For a list of all members of this type, see StateCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex | (Inherited from FChoice.Foundation.DataObjects.DataObjectCollection)
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

StateCollection Class
FChoice.Foundation.Clarify.DataObjects Namespace


StateCollection Class Properties | fcSDK Documentation

StateCollection Class Properties

For a list of all members of this type, see StateCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | DefaultState |
Public Property | Item |

Reference

StateCollection Class
FChoice.Foundation.Clarify.DataObjects Namespace


StateProvince Class Methods | fcSDK Documentation

StateProvince Class Methods

For a list of all members of this type, see StateProvince members.

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

StateProvince Class
FChoice.Foundation.Clarify.DataObjects Namespace


StateProvince Class Properties | fcSDK Documentation

StateProvince Class Properties

For a list of all members of this type, see StateProvince members.

Public Properties

 | Name | Description
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | DisplayOrder |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | FullName |
Public Property | IsDefault |
Public Property | Name |
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

StateProvince Class
FChoice.Foundation.Clarify.DataObjects Namespace


FChoice.Foundation.Clarify.DataObjects Namespace #### Inheritance Hierarchy | fcSDK Documentation

FChoice.Foundation.Clarify.DataObjects Namespace #### Inheritance Hierarchy

Inheritance Hierarchy

System.Object
FChoice.Foundation.DataObjects.DataObject
FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject
FChoice.Foundation.Clarify.DataObjects.Country
FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod
FChoice.Foundation.Clarify.DataObjects.FCString
FChoice.Foundation.Clarify.DataObjects.FCTimeZone
FChoice.Foundation.DataObjects.FakeTimeZone
FChoice.Foundation.Clarify.DataObjects.GlobalStringElement
FChoice.Foundation.Clarify.DataObjects.GlobalStringList
FChoice.Foundation.Clarify.DataObjects.HierarchicalStringElement
FChoice.Foundation.Clarify.DataObjects.HierarchicalStringList
FChoice.Foundation.Clarify.DataObjects.HierarchicalStringShow
FChoice.Foundation.Clarify.DataObjects.LocalizedString
FChoice.Foundation.Clarify.DataObjects.StateProvince
FChoice.Foundation.Clarify.Schema.SchemaFieldBase
FChoice.Foundation.Clarify.Schema.SchemaTableField
FChoice.Foundation.Clarify.Schema.SchemaViewField
FChoice.Foundation.Clarify.Schema.SchemaRelation
FChoice.Foundation.Clarify.Schema.SchemaTableBase
FChoice.Foundation.Clarify.Schema.SchemaTable
FChoice.Foundation.Clarify.Schema.SchemaView
FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo
FChoice.Foundation.Clarify.Schema.SchemaViewJoin
FChoice.Foundation.DataObjects.ConfigItem
FChoice.Foundation.Clarify.DataObjects.ClarifyConfigItem
System.Collections.Generic.List
FChoice.Foundation.DataObjects.DataObjectCollection
FChoice.Foundation.Clarify.DataObjects.CountryCollection
FChoice.Foundation.Clarify.DataObjects.DaylightSavingsCollection
FChoice.Foundation.Clarify.DataObjects.FCTimeZoneCollection
FChoice.Foundation.Clarify.DataObjects.GlobalStringElementCollection
FChoice.Foundation.Clarify.DataObjects.GlobalStringListCollection
FChoice.Foundation.Clarify.DataObjects.HierarchicalStringElementCollection
FChoice.Foundation.Clarify.DataObjects.HierarchicalStringListCollection
FChoice.Foundation.Clarify.DataObjects.StateCollection
FChoice.Foundation.DataObjects.ConfigItemCollection
FChoice.Foundation.Clarify.DataObjects.ClarifyConfigItemCollection

Reference

fcSDK Assembly


IClarifyApplication Interface Methods | fcSDK Documentation

IClarifyApplication Interface Methods

For a list of all members of this type, see IClarifyApplication members.

Public Methods

 | Name | Description
Method | CreateSession | Overloaded.
Method | CurrentSessions |
Method | EncryptClarifyPassword |
Method | EncryptDBPassword |
Method | GetMtmTableName |
Method | GetObjID |
Method | GetSession |
Method | IsSessionValid |

Reference

IClarifyApplication Interface
FChoice.Foundation.Clarify Namespace


IClarifyApplication Interface Properties | fcSDK Documentation

IClarifyApplication Interface Properties

For a list of all members of this type, see IClarifyApplication members.

Public Properties

 | Name | Description
Property | ClarifyVersion |
Property | ConfigItemCache |
Property | ConfigItems |
Property | Configuration |
Property | ConvertTimeZone |
Property | DatabaseVersion |
Property | DataRestrictionsEnabled |
Property | DBUserName |
Property | IsDbUnicode |
Property | IsTravelerEnabled |
Property | ListCache |
Property | LocaleCache |
Property | SchemaCache |
Property | ServerTimeZone |
Property | StringCache |
Property | TruncateStringFields |

Reference

IClarifyApplication Interface
FChoice.Foundation.Clarify Namespace


IListCache Interface Events | fcSDK Documentation

IListCache Interface Events

For a list of all members of this type, see IListCache members.

Public Events

 | Name | Description
Event | CacheUpdated |

Reference

IListCache Interface
FChoice.Foundation.Clarify Namespace


IListCache Interface Methods | fcSDK Documentation

IListCache Interface Methods

For a list of all members of this type, see IListCache members.

Public Methods

 | Name | Description
Method | GetGbstDefault |
Method | GetGbstDefaultObjID |
Method | GetGbstElmByID |
Method | GetGbstElmObjID |
Method | GetGbstElmRankObjID |
Method | GetGbstList |
Method | GetGbstListElements |
Method | GetHgbstElmDefault |
Method | GetHgbstElmDefaultElement | Overloaded.
Method | GetHgbstElmDefaultObjID | Overloaded.
Method | GetHgbstElmObjID | Overloaded.
Method | GetHgbstList | Overloaded.
Method | IsInGbstList |
Method | IsInHgbstList | Overloaded.
Method | RankIsInGbstList |
Method | TryGetHgbstList | Overloaded.
Method | UpdateCache |

Reference

IListCache Interface
FChoice.Foundation.Clarify Namespace


IListCache Interface Properties | fcSDK Documentation

IListCache Interface Properties

For a list of all members of this type, see IListCache members.

Public Properties

 | Name | Description
Property | CacheSetName |
Property | CacheType |
Property | GlobalStrings |
Property | HierarchicalStrings |

Reference

IListCache Interface
FChoice.Foundation.Clarify Namespace


ILocaleCache Interface Events | fcSDK Documentation

ILocaleCache Interface Events

For a list of all members of this type, see ILocaleCache members.

Public Events

 | Name | Description
Event | CacheUpdated |

Reference

ILocaleCache Interface
FChoice.Foundation.Clarify Namespace


ILocaleCache Interface Methods | fcSDK Documentation

ILocaleCache Interface Methods

For a list of all members of this type, see ILocaleCache members.

Public Methods

 | Name | Description
Method | GetCountryObjID |
Method | GetDefaultCountry |
Method | GetDefaultCountryObjID |
Method | GetDefaultState | Overloaded.
Method | GetDefaultStateObjID |
Method | GetDefaultTimeZone |
Method | GetDefaultTimeZoneObjID |
Method | GetFullStateObjID |
Method | GetServerTimeZoneOffset |
Method | GetShortTimeZoneObjID |
Method | GetStateObjID |
Method | GetStates | Overloaded.
Method | GetTimeZoneObjID |
Method | GetTimeZoneOffset |
Method | GetTimeZonesInCountry |
Method | IsCountry |
Method | IsFullState |
Method | IsOnDST |
Method | IsState | Overloaded.
Method | IsTimeZone |
Method | IsTimeZoneInCountry | Overloaded.
Method | SetServerTimeZoneToMachineTimeZone |
Method | UpdateCache |

Reference

ILocaleCache Interface
FChoice.Foundation.Clarify Namespace


ILocaleCache Interface Properties | fcSDK Documentation

ILocaleCache Interface Properties

For a list of all members of this type, see ILocaleCache members.

Public Properties

 | Name | Description
Property | CacheSetName |
Property | CacheType |
Property | Countries |
Property | DefaultTimeZone |
Property | ServerTimeZone |
Property | TimeZones |

Reference

ILocaleCache Interface
FChoice.Foundation.Clarify Namespace


IStringCache Interface Events | fcSDK Documentation

IStringCache Interface Events

For a list of all members of this type, see IStringCache members.

Public Events

 | Name | Description
Event | CacheUpdated |

Reference

IStringCache Interface
FChoice.Foundation.Clarify Namespace


IStringCache Interface Methods | fcSDK Documentation

IStringCache Interface Methods

For a list of all members of this type, see IStringCache members.

Public Methods

 | Name | Description
Method | FindFCString | Overloaded.
Method | FindFCStringObject | Overloaded.
Method | FindString | Overloaded.
Method | SupportedLocales |
Method | UpdateCache |

Reference

IStringCache Interface
FChoice.Foundation.Clarify Namespace


IStringCache Interface Properties | fcSDK Documentation

IStringCache Interface Properties

For a list of all members of this type, see IStringCache members.

Public Properties

 | Name | Description
Property | CacheSetName |
Property | CacheType |

Reference

IStringCache Interface
FChoice.Foundation.Clarify Namespace


ListCache Class Events | fcSDK Documentation

ListCache Class Events

For a list of all members of this type, see ListCache members.

Public Events

 | Name | Description
Public Event | CacheUpdated | (Inherited from FChoice.Foundation.CacheBase)

Reference

ListCache Class
FChoice.Foundation.Clarify Namespace


ListCache Class Methods | fcSDK Documentation

ListCache Class Methods

For a list of all members of this type, see ListCache members.

Public Methods

 | Name | Description
Public Method | GetGbstDefault | Gets the default string value for a given application pop-up list.
Public Method | GetGbstDefaultObjID | Gets the objid of the default element for a given application pop-up list.
Public Method | GetGbstElmByID | Gets the value of an element with the specified objid in the specified application pop-up list
Public Method | GetGbstElmObjID | Gets the objid of the specified element in the specified application pop-up list
Public Method | GetGbstElmRankObjID | Gets the objid of the specified element by rank in the specified application pop-up list
Public Method | GetGbstList | Gets a reference to a GlobalStringList object representing an application pop-up list in the database
Public Method | GetGbstListElements |
Public Method | GetHgbstElmDefault | Gets the title of the default element for the given level in a user-defined list (HGBST).
Public Method | GetHgbstElmDefaultElement | Overloaded. Gets a reference to an HierarchicalStringElement object which represents an element at the specified level in the specified list
Public Method | GetHgbstElmDefaultObjID | Overloaded. Gets the objid of the default element for the given level in a user-defined list (HGBST).
Public Method | GetHgbstElmObjID | Overloaded. Gets the objid of an element at a specific level in a user-defined list (HGBST)
Public Method | GetHgbstList | Overloaded. Gets a reference to a HierarchicalStringElementCollection collection of list elements at the specified level in the given user-defined list
Public Method | IsInGbstList | Gets whether or not the specified element value exists in a given application pop-up list
Public Method | IsInHgbstList | Overloaded. Gets whether or not an element with the specified title exists in a given application pop-up list
Public Method | RankIsInGbstList | Gets whether or not an element with the specified rank exists in an application pop-up list
Public Method | TryGetHgbstList | Overloaded.
Public Method | UpdateCache | (Inherited from FChoice.Foundation.CacheBase)

Reference

ListCache Class
FChoice.Foundation.Clarify Namespace


ListCache Class Properties | fcSDK Documentation

ListCache Class Properties

For a list of all members of this type, see ListCache members.

Public Properties

 | Name | Description
Public Property | CacheSetName | Overridden.
Public Property | CacheType | Overridden.
Public Property | GlobalStrings | Gets a reference to the GlobalStringListCollection cache of all application pop-up lists in the database
Public Property | HierarchicalStrings | Gets a reference to the HierarchicalStringListCollection cache of all user-defined lists in the database

Reference

ListCache Class
FChoice.Foundation.Clarify Namespace


LocaleCache Class Events | fcSDK Documentation

LocaleCache Class Events

For a list of all members of this type, see LocaleCache members.

Public Events

 | Name | Description
Public Event | CacheUpdated | (Inherited from FChoice.Foundation.CacheBase)

Reference

LocaleCache Class
FChoice.Foundation.Clarify Namespace


LocaleCache Class Methods | fcSDK Documentation

LocaleCache Class Methods

For a list of all members of this type, see LocaleCache members.

Public Methods

 | Name | Description
Public Method | GetCountryObjID |
Public Method | GetDefaultCountry |
Public Method | GetDefaultCountryObjID |
Public Method | GetDefaultState | Overloaded.
Public Method | GetDefaultStateObjID |
Public Method | GetDefaultTimeZone |
Public Method | GetDefaultTimeZoneObjID |
Public Method | GetFullStateObjID |
Public Method | GetServerTimeZoneOffset |
Public Method | GetShortTimeZoneObjID |
Public Method | GetStateObjID |
Public Method | GetStates | Overloaded.
Public Method | GetTimeZoneObjID |
Public Method | GetTimeZoneOffset |
Public Method | GetTimeZonesInCountry |
Public Method | IsCountry |
Public Method | IsFullState |
Public Method | IsOnDST |
Public Method | IsState | Overloaded.
Public Method | IsTimeZone |
Public Method | IsTimeZoneInCountry | Overloaded.
Public Method | SetServerTimeZoneToMachineTimeZone |
Public Method | UpdateCache | (Inherited from FChoice.Foundation.CacheBase)

Reference

LocaleCache Class
FChoice.Foundation.Clarify Namespace


LocaleCache Class Properties | fcSDK Documentation

LocaleCache Class Properties

For a list of all members of this type, see LocaleCache members.

Public Properties

 | Name | Description
Public Property | CacheSetName | Overridden.
Public Property | CacheType | Overridden.
Public Property | Countries |
Public Property | DefaultTimeZone |
Public Property | ServerTimeZone |
Public Property | TimeZones |

Reference

LocaleCache Class
FChoice.Foundation.Clarify Namespace


RestrictionClause Class Properties | fcSDK Documentation

RestrictionClause Class Properties

For a list of all members of this type, see RestrictionClause members.

Public Properties

 | Name | Description
Public Property | Clause |
Public Property | FieldName |
Public Property | TableName |

Reference

RestrictionClause Class
FChoice.Foundation.Clarify.Schema Namespace


SchemaFieldBase Class Methods | fcSDK Documentation

SchemaFieldBase Class Methods

For a list of all members of this type, see SchemaFieldBase members.

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | IsDate |
Public Method | IsInteger |
Public Method | IsNumeric |
Public Method | IsString |

Reference

SchemaFieldBase Class
FChoice.Foundation.Clarify.Schema Namespace


SchemaFieldBase Class Properties | fcSDK Documentation

SchemaFieldBase Class Properties

For a list of all members of this type, see SchemaFieldBase members.

Public Properties

 | Name | Description
Public Property | ArraySize |
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | CommonType |
Public Property | DatabaseType |
Public Property | DecimalPrecision |
Public Property | DecimalScale |
Public Property | Default |
Public Property | DefaultString |
Public Property | FCFlags |
Public Property | FieldDefault |
Public Property | FieldDefaultString |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Flags |
Public Property | GenFieldID |
Public Property | IsSearchable |
Public Property | IsUnicode |
Public Property | Name |
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | ObjectType |
Public Property | Parent |
Public Property | ParentTypeID |
Public Property | SpecificFieldID |
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

SchemaFieldBase Class
FChoice.Foundation.Clarify.Schema Namespace


SchemaFieldCollectionBase Class Methods | fcSDK Documentation

SchemaFieldCollectionBase Class Methods

For a list of all members of this type, see SchemaFieldCollectionBase members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex | (Inherited from FChoice.Foundation.DataObjects.DataObjectCollection)
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

SchemaFieldCollectionBase Class
FChoice.Foundation.Clarify.Schema Namespace


SchemaFieldCollectionBase Class Properties | fcSDK Documentation

SchemaFieldCollectionBase Class Properties

For a list of all members of this type, see SchemaFieldCollectionBase members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | Item |

Reference

SchemaFieldCollectionBase Class
FChoice.Foundation.Clarify.Schema Namespace


SchemaRelation Class Fields | fcSDK Documentation

SchemaRelation Class Fields

For a list of all members of this type, see SchemaRelation members.

Public Fields

 | Name | Description
Public Field | MANDATORY_REL_OBJID |

Reference

SchemaRelation Class
FChoice.Foundation.Clarify.Schema Namespace


SchemaRelation Class Methods | fcSDK Documentation

SchemaRelation Class Methods

For a list of all members of this type, see SchemaRelation members.

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

SchemaRelation Class
FChoice.Foundation.Clarify.Schema Namespace


SchemaRelation Class Properties | fcSDK Documentation

SchemaRelation Class Properties

For a list of all members of this type, see SchemaRelation members.

Public Properties

 | Name | Description
Public Property | Cardinality |
Public Property | ChildTable |
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Comments |
Public Property | ExclusiveSet |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Flags |
Public Property | FocusFieldName |
Public Property | GenericRelationID |
Public Property | InverseRelation |
Public Property | InverseRelationName |
Public Property | IsExclusive |
Public Property | IsMandatory |
Public Property | IsMtm |
Public Property | MandatoryObjectID |
Public Property | MtmTableName |
Public Property | Name |
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | ParentTable |
Public Property | ParentTypeID |
Public Property | RelationFlags |
Public Property | RelationPhysicalName |
Public Property | SourceTable |
Public Property | SpecificRelationID |
Public Property | TargetName |
Public Property | TargetTable |
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

SchemaRelation Class
FChoice.Foundation.Clarify.Schema Namespace


SchemaRelationCollection Class Methods | fcSDK Documentation

SchemaRelationCollection Class Methods

For a list of all members of this type, see SchemaRelationCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex | (Inherited from FChoice.Foundation.DataObjects.DataObjectCollection)
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

SchemaRelationCollection Class
FChoice.Foundation.Clarify.Schema Namespace


SchemaRelationCollection Class Properties | fcSDK Documentation

SchemaRelationCollection Class Properties

For a list of all members of this type, see SchemaRelationCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | Item |
Public Property | OtmOtofAndMtmRelations |

Reference

SchemaRelationCollection Class
FChoice.Foundation.Clarify.Schema Namespace


SchemaTable Class Methods | fcSDK Documentation

SchemaTable Class Methods

For a list of all members of this type, see SchemaTable members.

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

SchemaTable Class
FChoice.Foundation.Clarify.Schema Namespace


SchemaTable Class Properties | fcSDK Documentation

SchemaTable Class Properties

For a list of all members of this type, see SchemaTable members.

Public Properties

 | Name | Description
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Comments | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaTableBase)
Public Property | Fields |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Flags | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaTableBase)
Public Property | IsDataRestricted | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaTableBase)
Public Property | IsUnicode | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaTableBase)
Public Property | Name | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaTableBase)
Public Property | ObjectGroup | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaTableBase)
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | Relationships |
Public Property | RestrictedFields | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaTableBase)
Public Property | RestrictionClauses | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaTableBase)
Public Property | TypeID | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaTableBase)
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Views |

Reference

SchemaTable Class
FChoice.Foundation.Clarify.Schema Namespace


SchemaTableBase Class Methods | fcSDK Documentation

SchemaTableBase Class Methods

For a list of all members of this type, see SchemaTableBase members.

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

SchemaTableBase Class
FChoice.Foundation.Clarify.Schema Namespace


SchemaTableBase Class Properties | fcSDK Documentation

SchemaTableBase Class Properties

For a list of all members of this type, see SchemaTableBase members.

Public Properties

 | Name | Description
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Comments |
Public Property | Fields |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Flags |
Public Property | IsDataRestricted |
Public Property | IsUnicode |
Public Property | Name |
Public Property | ObjectGroup |
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | RestrictedFields |
Public Property | RestrictionClauses |
Public Property | TypeID |
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

SchemaTableBase Class
FChoice.Foundation.Clarify.Schema Namespace


SchemaTableCollection Class Methods | fcSDK Documentation

SchemaTableCollection Class Methods

For a list of all members of this type, see SchemaTableCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetByNumber |
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex | (Inherited from FChoice.Foundation.DataObjects.DataObjectCollection)
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

SchemaTableCollection Class
FChoice.Foundation.Clarify.Schema Namespace


SchemaTableCollection Class Properties | fcSDK Documentation

SchemaTableCollection Class Properties

For a list of all members of this type, see SchemaTableCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | Item |

Reference

SchemaTableCollection Class
FChoice.Foundation.Clarify.Schema Namespace


SchemaTableField Class Methods | fcSDK Documentation

SchemaTableField Class Methods

For a list of all members of this type, see SchemaTableField members.

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | IsDate | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Method | IsInteger | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Method | IsNumeric | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Method | IsString | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)

Reference

SchemaTableField Class
FChoice.Foundation.Clarify.Schema Namespace


SchemaTableField Class Properties | fcSDK Documentation

SchemaTableField Class Properties

For a list of all members of this type, see SchemaTableField members.

Public Properties

 | Name | Description
Public Property | ArraySize | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | CommonType | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | DatabaseType | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | DecimalPrecision | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | DecimalScale | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | Default | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | DefaultString | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | FCFlags | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | FieldDefault | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | FieldDefaultString | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Flags | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | GenFieldID | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | IsSearchable | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | IsUnicode | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | Name | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | ObjectType | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | Parent | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | ParentTypeID | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | SpecificFieldID | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | Table |
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | ViewFieldInfos |

Reference

SchemaTableField Class
FChoice.Foundation.Clarify.Schema Namespace


SchemaTableFieldCollection Class Methods | fcSDK Documentation

SchemaTableFieldCollection Class Methods

For a list of all members of this type, see SchemaTableFieldCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex | (Inherited from FChoice.Foundation.DataObjects.DataObjectCollection)
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

SchemaTableFieldCollection Class
FChoice.Foundation.Clarify.Schema Namespace


SchemaTableFieldCollection Class Properties | fcSDK Documentation

SchemaTableFieldCollection Class Properties

For a list of all members of this type, see SchemaTableFieldCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | Item | Overloaded.

Reference

SchemaTableFieldCollection Class
FChoice.Foundation.Clarify.Schema Namespace


SchemaView Class Methods | fcSDK Documentation

SchemaView Class Methods

For a list of all members of this type, see SchemaView members.

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

SchemaView Class
FChoice.Foundation.Clarify.Schema Namespace


SchemaView Class Properties | fcSDK Documentation

SchemaView Class Properties

For a list of all members of this type, see SchemaView members.

Public Properties

 | Name | Description
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Comments | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaTableBase)
Public Property | Fields |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Flags | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaTableBase)
Public Property | IsDataRestricted | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaTableBase)
Public Property | IsSqlView |
Public Property | IsUnicode | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaTableBase)
Public Property | Joins |
Public Property | Name | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaTableBase)
Public Property | ObjectGroup | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaTableBase)
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | RestrictedFields | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaTableBase)
Public Property | RestrictionClauses | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaTableBase)
Public Property | TypeID | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaTableBase)
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

SchemaView Class
FChoice.Foundation.Clarify.Schema Namespace


SchemaViewCollection Class Methods | fcSDK Documentation

SchemaViewCollection Class Methods

For a list of all members of this type, see SchemaViewCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetByNumber |
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex | (Inherited from FChoice.Foundation.DataObjects.DataObjectCollection)
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

SchemaViewCollection Class
FChoice.Foundation.Clarify.Schema Namespace


SchemaViewCollection Class Properties | fcSDK Documentation

SchemaViewCollection Class Properties

For a list of all members of this type, see SchemaViewCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | Item |

Reference

SchemaViewCollection Class
FChoice.Foundation.Clarify.Schema Namespace


SchemaViewField Class Methods | fcSDK Documentation

SchemaViewField Class Methods

For a list of all members of this type, see SchemaViewField members.

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | IsDate | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Method | IsInteger | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Method | IsNumeric | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Method | IsString | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)

Reference

SchemaViewField Class
FChoice.Foundation.Clarify.Schema Namespace


SchemaViewField Class Properties | fcSDK Documentation

SchemaViewField Class Properties

For a list of all members of this type, see SchemaViewField members.

Public Properties

 | Name | Description
Public Property | ArraySize | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | CommonType | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | DatabaseType | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | DecimalPrecision | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | DecimalScale | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | Default | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | DefaultString | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | FCFlags | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | FieldDefault | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | FieldDefaultString | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | FieldInfo |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Flags | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | GenFieldID | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | IsSearchable | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | IsUnicode | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | Name | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | ObjectType | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | Parent | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | ParentTypeID | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | SpecificFieldID | (Inherited from FChoice.Foundation.Clarify.Schema.SchemaFieldBase)
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | View |

Reference

SchemaViewField Class
FChoice.Foundation.Clarify.Schema Namespace


SchemaViewFieldCollection Class Methods | fcSDK Documentation

SchemaViewFieldCollection Class Methods

For a list of all members of this type, see SchemaViewFieldCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex | (Inherited from FChoice.Foundation.DataObjects.DataObjectCollection)
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

SchemaViewFieldCollection Class
FChoice.Foundation.Clarify.Schema Namespace


SchemaViewFieldCollection Class Properties | fcSDK Documentation

SchemaViewFieldCollection Class Properties

For a list of all members of this type, see SchemaViewFieldCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | Item | Overloaded.

Reference

SchemaViewFieldCollection Class
FChoice.Foundation.Clarify.Schema Namespace


SchemaViewFieldInfo Class Methods | fcSDK Documentation

SchemaViewFieldInfo Class Methods

For a list of all members of this type, see SchemaViewFieldInfo members.

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

SchemaViewFieldInfo Class
FChoice.Foundation.Clarify.Schema Namespace


SchemaViewFieldInfo Class Properties | fcSDK Documentation

SchemaViewFieldInfo Class Properties

For a list of all members of this type, see SchemaViewFieldInfo members.

Public Properties

 | Name | Description
Public Property | Alias |
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Comments |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Flags |
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | TableField |
Public Property | TableFieldID |
Public Property | TableTypeID |
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | ViewField |
Public Property | ViewID |

Reference

SchemaViewFieldInfo Class
FChoice.Foundation.Clarify.Schema Namespace


SchemaViewFieldInfoCollection Class Methods | fcSDK Documentation

SchemaViewFieldInfoCollection Class Methods

For a list of all members of this type, see SchemaViewFieldInfoCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
static (Shared in Visual Basic) | CreateViewFieldInfoKey |
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex | (Inherited from FChoice.Foundation.DataObjects.DataObjectCollection)
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | GetViewFieldInfoByID |
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

SchemaViewFieldInfoCollection Class
FChoice.Foundation.Clarify.Schema Namespace


SchemaViewFieldInfoCollection Class Properties | fcSDK Documentation

SchemaViewFieldInfoCollection Class Properties

For a list of all members of this type, see SchemaViewFieldInfoCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | Item | (Inherited from System.Collections.Generic.List)

Reference

SchemaViewFieldInfoCollection Class
FChoice.Foundation.Clarify.Schema Namespace


SchemaViewJoin Class Methods | fcSDK Documentation

SchemaViewJoin Class Methods

For a list of all members of this type, see SchemaViewJoin members.

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

SchemaViewJoin Class
FChoice.Foundation.Clarify.Schema Namespace


SchemaViewJoin Class Properties | fcSDK Documentation

SchemaViewJoin Class Properties

For a list of all members of this type, see SchemaViewJoin members.

Public Properties

 | Name | Description
Public Property | BaseRelation |
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Comments |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Flags |
Public Property | JoinFlag |
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | PrimaryAlias |
Public Property | SecondaryAlias |
Public Property | SpecificRelationID |
Public Property | TableID |
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

SchemaViewJoin Class
FChoice.Foundation.Clarify.Schema Namespace


SchemaViewJoinCollection Class Methods | fcSDK Documentation

SchemaViewJoinCollection Class Methods

For a list of all members of this type, see SchemaViewJoinCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex | (Inherited from FChoice.Foundation.DataObjects.DataObjectCollection)
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

SchemaViewJoinCollection Class
FChoice.Foundation.Clarify.Schema Namespace


SchemaViewJoinCollection Class Properties | fcSDK Documentation

SchemaViewJoinCollection Class Properties

For a list of all members of this type, see SchemaViewJoinCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | Item | (Inherited from System.Collections.Generic.List)

Reference

SchemaViewJoinCollection Class
FChoice.Foundation.Clarify.Schema Namespace


FChoice.Foundation.Clarify.Schema Namespace #### Inheritance Hierarchy | fcSDK Documentation

FChoice.Foundation.Clarify.Schema Namespace #### Inheritance Hierarchy

Inheritance Hierarchy

System.Object
FChoice.Foundation.Clarify.Schema.RestrictionClause
FChoice.Foundation.DataObjects.DataObject
FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject
FChoice.Foundation.Clarify.Schema.SchemaFieldBase
FChoice.Foundation.Clarify.Schema.SchemaTableField
FChoice.Foundation.Clarify.Schema.SchemaViewField
FChoice.Foundation.Clarify.Schema.SchemaRelation
FChoice.Foundation.Clarify.Schema.SchemaTableBase
FChoice.Foundation.Clarify.Schema.SchemaTable
FChoice.Foundation.Clarify.Schema.SchemaView
FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo
FChoice.Foundation.Clarify.Schema.SchemaViewJoin
System.Collections.Generic.List
FChoice.Foundation.DataObjects.DataObjectCollection
FChoice.Foundation.Clarify.Schema.SchemaFieldCollectionBase
FChoice.Foundation.Clarify.Schema.SchemaTableFieldCollection
FChoice.Foundation.Clarify.Schema.SchemaViewFieldCollection
FChoice.Foundation.Clarify.Schema.SchemaRelationCollection
FChoice.Foundation.Clarify.Schema.SchemaTableCollection
FChoice.Foundation.Clarify.Schema.SchemaViewCollection
FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfoCollection
FChoice.Foundation.Clarify.Schema.SchemaViewJoinCollection

Reference

fcSDK Assembly


SchemaCache Class Events | fcSDK Documentation

SchemaCache Class Events

For a list of all members of this type, see SchemaCache members.

Public Events

 | Name | Description
Public Event | CacheUpdated | (Inherited from FChoice.Foundation.CacheBase)
Public Event | SchemaLoadStatusChanged |

Reference

SchemaCache Class
FChoice.Foundation.Clarify Namespace


SchemaCache Class Fields | fcSDK Documentation

SchemaCache Class Fields

For a list of all members of this type, see SchemaCache members.

Public Fields

 | Name | Description
Public Field | Amdocs65 |
Public Field | Amdocs75 |
Public Field | CLARIFY_10 |
Public Field | CLARIFY_11 |
Public Field | CLARIFY_115 |
Public Field | CLARIFY_12 |
Public Field | CLARIFY_125 |
Public Field | CLARIFY_13 |
Public Field | CLARIFY_4 |
Public Field | CLARIFY_45 |
Public Field | CLARIFY_5 |
Public Field | CLARIFY_6 |
Public Field | CLARIFY_6X |
Public Field | CLARIFY_7 |
Public Field | CLARIFY_8 |
Public Field | CLARIFY_9 |
Public Field | CLARIFY_CFO98 |

Reference

SchemaCache Class
FChoice.Foundation.Clarify Namespace


SchemaCache Class Methods | fcSDK Documentation

SchemaCache Class Methods

For a list of all members of this type, see SchemaCache members.

Public Methods

 | Name | Description
Public Method | GetChangeDateField |
Public Method | GetDateFields |
Public Method | GetField |
Public Method | GetRelation |
Public Method | GetTableField |
Public Method | GetTableID |
Public Method | GetTableName |
Public Method | GetTableOrView |
Public Method | GetTableOrViewByID |
Public Method | GetTableOrViewID |
Public Method | GetTypeForSchemaType | Overloaded.
Public Method | GetViewField |
Public Method | GetViewID |
Public Method | IsChangeField |
Public Method | IsDateField |
Public Method | IsFieldSearchable |
Public Method | IsFieldUnicode |
Public Method | IsIntegerField |
Public Method | IsNumericField |
Public Method | IsRelationExclusive |
Public Method | IsRelationMandatory |
Public Method | IsStringField |
Public Method | IsStringOrDateField |
Public Method | IsValidField | Overloaded.
Public Method | IsValidRelation |
Public Method | IsValidTable |
Public Method | IsValidTableOrView | Overloaded.
Public Method | IsValidView |
Public Method | TryGetField |
Public Method | TryIsFieldSearchable |
Public Method | TryIsStringField |
Public Method | UpdateCache | Overridden.

Reference

SchemaCache Class
FChoice.Foundation.Clarify Namespace


SchemaCache Class Properties | fcSDK Documentation

SchemaCache Class Properties

For a list of all members of this type, see SchemaCache members.

Public Properties

 | Name | Description
Public Property | CacheSetName | Overridden.
Public Property | CacheType | Overridden.
Public Property | CustomSchemaDate |
Public Property | DatabaseName |
Public Property | DataRestrictionsEnabled |
Public Property | Flags |
Public Property | IsDatabaseUnicode |
Public Property | LastModifiedDate |
Public Property | RestrictionGroups |
Public Property | SchemaRevision |
Public Property | SiteID |
Public Property | Tables |
Public Property | VendorSchemaDate |
Public Property | Views |

Reference

SchemaCache Class
FChoice.Foundation.Clarify Namespace


SchemaCacheHelper Class Methods | fcSDK Documentation

SchemaCacheHelper Class Methods

For a list of all members of this type, see SchemaCacheHelper members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | DoesColumnExist |
static (Shared in Visual Basic) | DoesMsSqlColumnExist |
static (Shared in Visual Basic) | DoesOracleColumnExist |

Reference

SchemaCacheHelper Class
FChoice.Foundation.Clarify Namespace


StringCache Class Events | fcSDK Documentation

StringCache Class Events

For a list of all members of this type, see StringCache members.

Public Events

 | Name | Description
Public Event | CacheUpdated | (Inherited from FChoice.Foundation.CacheBase)

Reference

StringCache Class
FChoice.Foundation.Clarify Namespace


StringCache Class Methods | fcSDK Documentation

StringCache Class Methods

For a list of all members of this type, see StringCache members.

Public Methods

 | Name | Description
Public Method | FindFCString | Overloaded.
Public Method | FindFCStringObject | Overloaded.
Public Method | FindString | Overloaded.
Public Method | SupportedLocales | Returns list of supported locales. Each fc_string has a locale, so all distinct locales are returned by this method.
Public Method | UpdateCache | (Inherited from FChoice.Foundation.CacheBase)

Reference

StringCache Class
FChoice.Foundation.Clarify Namespace


StringCache Class Properties | fcSDK Documentation

StringCache Class Properties

For a list of all members of this type, see StringCache members.

Public Properties

 | Name | Description
Public Property | CacheSetName | Overridden.
Public Property | CacheType | Overridden.

Reference

StringCache Class
FChoice.Foundation.Clarify Namespace


WorkflowException Class Methods | fcSDK Documentation

WorkflowException Class Methods

For a list of all members of this type, see WorkflowException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | Sets the SerializationInfo object with the parameter name and additional exception information. (Inherited from FChoice.Common.FCExceptionBase)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)

Reference

WorkflowException Class
FChoice.Foundation.Clarify.Workflow Namespace


WorkflowException Class Properties | fcSDK Documentation

WorkflowException Class Properties

For a list of all members of this type, see WorkflowException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorCode | Gets the unique error code for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | ErrorMessageID | Gets the message identifier for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)

Reference

WorkflowException Class
FChoice.Foundation.Clarify.Workflow Namespace


WorkFlowInfo Class Properties | fcSDK Documentation

WorkFlowInfo Class Properties

For a list of all members of this type, see WorkFlowInfo members.

Public Properties

 | Name | Description
Public Property | ActivityDate |
Public Property | ActivityRelation |
Public Property | ConditionRelation |
Public Property | DatabaseTable |
Public Property | EmployeeID |
Public Property | GenerateTimeBomb |
Public Property | HistoryFieldName |
Public Property | IDFieldName |
Public Property | IDNum |
Public Property | IsAllowedCheckFieldName |
Public Property | IsApplicationUser |
Public Property | IsSessionUser |
Public Property | IsWipBinDefault |
Public Property | NewStatus |
Public Property | NewUserID |
Public Property | NewUserName |
Public Property | ObjectName |
Public Property | OldRejectRelation |
Public Property | OldStatusRelation |
Public Property | OwnerRelation |
Public Property | PreviousQueueRelation |
Public Property | QueueId |
Public Property | QueueName |
Public Property | QueueRelation |
Public Property | RejectRelation |
Public Property | StatusCode |
Public Property | StatusRelation |
Public Property | UseParticipantActEntryModel |
Public Property | UserID |
Public Property | UserName |
Public Property | WipBin |
Public Property | WipBinID |
Public Property | WipBinRelation |

Reference

WorkFlowInfo Class
FChoice.Foundation.Clarify.Workflow Namespace


WorkflowManager Class Fields | fcSDK Documentation

WorkflowManager Class Fields

For a list of all members of this type, see WorkflowManager members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | EndOfHistoryMagicText |
Public Field | ImpersonatorUserName |

Reference

WorkflowManager Class
FChoice.Foundation.Clarify.Workflow Namespace


WorkflowManager Class Methods | fcSDK Documentation

WorkflowManager Class Methods

For a list of all members of this type, see WorkflowManager members.

Public Methods

 | Name | Description
Public Method | Accept |
Public Method | Assign |
static (Shared in Visual Basic) | BuildClarifyHistory |
Public Method | ChangeStatus |
Public Method | CreateActivityEntryRow |
Public Method | CreateActivityLogEntry |
Public Method | CreateAttachmentRecord | Overloaded.
Public Method | CreateCasePhoneLogActivityEntry |
Public Method | CreateParticipantActivityEntry |
Public Method | CreateTimeBomb | Overloaded.
Public Method | Dispatch |
Public Method | Forward |
Public Method | GetAttachmentFilePath |
Public Method | GetNextFileName |
Public Method | GetNextFileNameIgnoringExistence |
Public Method | GetWipDetails |
Public Method | IsFilenameAlreadyInUseOnTheWorkflowObject |
static (Shared in Visual Basic) | MakeFullHistoryDirty |
static (Shared in Visual Basic) | MapObjectNameToTableID |
static (Shared in Visual Basic) | MapTimeBombActionToFlag |
Public Method | Move |
Public Method | Reject |
Public Method | Yank |

Reference

WorkflowManager Class
FChoice.Foundation.Clarify.Workflow Namespace


CreateActivityLogEntry Method | fcSDK Documentation

CreateActivityLogEntry Method

Overload List

Overload | Description
CreateActivityLogEntry |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

WorkflowManager Class
WorkflowManager Members


FChoice.Foundation.Clarify.Workflow Namespace #### Inheritance Hierarchy | fcSDK Documentation

FChoice.Foundation.Clarify.Workflow Namespace #### Inheritance Hierarchy

Inheritance Hierarchy

System.Object
FChoice.Foundation.Clarify.Workflow.WorkFlowInfo
FChoice.Foundation.Clarify.Workflow.WorkflowManager
System.Exception
System.ApplicationException
FChoice.Common.FCExceptionBase
FChoice.Foundation.Clarify.Workflow.WorkflowException

Reference

fcSDK Assembly


WorkflowObjectInfo Class Methods | fcSDK Documentation

WorkflowObjectInfo Class Methods

For a list of all members of this type, see WorkflowObjectInfo members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | AddToCache | Overloaded.
static (Shared in Visual Basic) | CreateCustomQueueableObjectInfo |
static (Shared in Visual Basic) | GetObjectInfo |
static (Shared in Visual Basic) | GetQueueableObjectInfo | Overloaded.
static (Shared in Visual Basic) | ObjectTypeExists |

Reference

WorkflowObjectInfo Class
FChoice.Foundation.Clarify Namespace


WorkflowObjectInfo Class Properties | fcSDK Documentation

WorkflowObjectInfo Class Properties

For a list of all members of this type, see WorkflowObjectInfo members.

Public Properties

 | Name | Description
Public Property | ActivityRelation |
Public Property | AttachmentRelation |
Public Property | ConditionRelation |
Public Property | DatabaseTable |
Public Property | HasIDFieldName |
Public Property | HistoryFieldName |
Public Property | IDFieldName |
Public Property | IsAllowedCheckFieldName |
Public Property | IsQueueableObject |
Public Property | ObjectName |
Public Property | OldRejectRelation |
Public Property | OldStatusRelation |
Public Property | OwnerRelation |
Public Property | ParentRelation |
Public Property | PreviousQueueRelation |
Public Property | QueueRelation |
Public Property | RejectRelation |
Public Property | StatusCode |
Public Property | StatusRelation |
Public Property | TimeStampFieldName |
Public Property | UseParticipantActEntryModel |
Public Property | WipBinRelation |

Reference

WorkflowObjectInfo Class
FChoice.Foundation.Clarify Namespace


FChoice.Foundation.Clarify Namespace #### Inheritance Hierarchy | fcSDK Documentation

FChoice.Foundation.Clarify Namespace #### Inheritance Hierarchy

Inheritance Hierarchy

System.Object
FChoice.Foundation.CacheBase
FChoice.Foundation.Clarify.ClarifyCacheBase
FChoice.Foundation.Clarify.ConfigItemCache
FChoice.Foundation.Clarify.ListCache
FChoice.Foundation.Clarify.LocaleCache
FChoice.Foundation.Clarify.SchemaCache
FChoice.Foundation.Clarify.StringCache
FChoice.Foundation.Clarify.ClarifyAuthenticationResult
FChoice.Foundation.Clarify.ClarifyAuthenticationService
FChoice.Foundation.Clarify.ConfigurationHelper
FChoice.Foundation.Clarify.DatabaseParameterFactory
FChoice.Foundation.Clarify.SchemaCacheHelper
FChoice.Foundation.Clarify.WorkflowObjectInfo
FChoice.Foundation.FCApplication
FChoice.Foundation.Clarify.ClarifyApplication
FChoice.Foundation.FCGeneric
FChoice.Foundation.Clarify.ClarifyGeneric
FChoice.Foundation.FCSession
FChoice.Foundation.Clarify.ClarifySession
FChoice.Foundation.FCSessionData
FChoice.Foundation.Clarify.ClarifySessionData
FChoice.Foundation.GenericDataRowCollection
FChoice.Foundation.Clarify.ClarifyRowCollection
FChoice.Foundation.GenericDataSet
FChoice.Foundation.Clarify.ClarifyDataSet
System.ComponentModel.MarshalByValueComponent
System.Data.DataTable
FChoice.Foundation.GenericDataTable
FChoice.Foundation.Clarify.ClarifyDataTable
System.Data.DataRow
FChoice.Foundation.GenericDataRow
FChoice.Foundation.Clarify.ClarifyDataRow
System.Exception
System.ApplicationException
FChoice.Common.FCExceptionBase
FChoice.Foundation.Clarify.ClarifyException
FChoice.Foundation.FoundationException
FChoice.Foundation.GenericException
FChoice.Foundation.Clarify.ClarifyGenericException

Reference

fcSDK Assembly


CustomCache Class Events | fcSDK Documentation

CustomCache Class Events

For a list of all members of this type, see CustomCache members.

Public Events

 | Name | Description
Public Event | CacheUpdated | (Inherited from FChoice.Foundation.CacheBase)

Reference

CustomCache Class
FChoice.Foundation Namespace


CustomCache Class Methods | fcSDK Documentation

CustomCache Class Methods

For a list of all members of this type, see CustomCache members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetInstance |
Public Method | UpdateCache | (Inherited from FChoice.Foundation.CacheBase)

Reference

CustomCache Class
FChoice.Foundation Namespace


CustomCache Class Properties | fcSDK Documentation

CustomCache Class Properties

For a list of all members of this type, see CustomCache members.

Public Properties

 | Name | Description
Public Property | CacheSetName | Overridden.
Public Property | CacheType | Overridden.
Public Property | Data |

Reference

CustomCache Class
FChoice.Foundation Namespace


DataFieldNameCollection Class Methods | fcSDK Documentation

DataFieldNameCollection Class Methods

For a list of all members of this type, see DataFieldNameCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | AddRange | Overridden.
Public Method | Clear | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | Contains | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | CopyTo | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | GetEnumerator | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | IndexOf | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | Insert | Overridden.
Public Method | Remove | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | RemoveAt | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | SetList | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | ToString | (Inherited from FChoice.Foundation.ValidatedNameCollection)

Reference

DataFieldNameCollection Class
FChoice.Foundation Namespace


DataFieldNameCollection Class Properties | fcSDK Documentation

DataFieldNameCollection Class Properties

For a list of all members of this type, see DataFieldNameCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Property | IsFixedSize | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Property | IsReadOnly | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Property | IsSynchronized | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Property | Item | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Property | SyncRoot | (Inherited from FChoice.Foundation.ValidatedNameCollection)

Reference

DataFieldNameCollection Class
FChoice.Foundation Namespace


ColumnInfo Class Methods | fcSDK Documentation

ColumnInfo Class Methods

For a list of all members of this type, see ColumnInfo members.

Public Methods

 | Name | Description
Public Method | CompareTo |

Reference

ColumnInfo Class
FChoice.Foundation.DataObjects Namespace


ColumnInfo Class Properties | fcSDK Documentation

ColumnInfo Class Properties

For a list of all members of this type, see ColumnInfo members.

Public Properties

 | Name | Description
Public Property | DataType |
Public Property | DefaultValue |
Public Property | MaxLength |
Public Property | Name |
Public Property | Ordinal |
Public Property | TableName |

Reference

ColumnInfo Class
FChoice.Foundation.DataObjects Namespace


ConfigItem Class Methods | fcSDK Documentation

ConfigItem Class Methods

For a list of all members of this type, see ConfigItem members.

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

ConfigItem Class
FChoice.Foundation.DataObjects Namespace


ConfigItem Class Properties | fcSDK Documentation

ConfigItem Class Properties

For a list of all members of this type, see ConfigItem members.

Public Properties

 | Name | Description
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | DateValue |
Public Property | DecimalValue |
Public Property | Description |
Public Property | DoubleValue |
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | IntegerValue |
Public Property | LongValue |
Public Property | Name |
Public Property | Scope |
Public Property | StringValue |
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | ValueType |
Public Property | ValueTypeRaw |

Reference

ConfigItem Class
FChoice.Foundation.DataObjects Namespace


ConfigItemCollection Class Methods | fcSDK Documentation

ConfigItemCollection Class Methods

For a list of all members of this type, see ConfigItemCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex | (Inherited from FChoice.Foundation.DataObjects.DataObjectCollection)
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

ConfigItemCollection Class
FChoice.Foundation.DataObjects Namespace


ConfigItemCollection Class Properties | fcSDK Documentation

ConfigItemCollection Class Properties

For a list of all members of this type, see ConfigItemCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | Item |

Reference

ConfigItemCollection Class
FChoice.Foundation.DataObjects Namespace


DataObject Class Methods | fcSDK Documentation

DataObject Class Methods

For a list of all members of this type, see DataObject members.

Public Methods

 | Name | Description
Public Method | ContainsColumn |
Public Method | GetFieldValue | Overloaded.
Public Method | GetSafeBooleanFieldValue | Overloaded.
Public Method | GetSafeDoubleFieldValue | Overloaded.
Public Method | GetSafeInt32FieldValue | Overloaded.
Public Method | GetSafeStringFieldValue |

Reference

DataObject Class
FChoice.Foundation.DataObjects Namespace


DataObject Class Properties | fcSDK Documentation

DataObject Class Properties

For a list of all members of this type, see DataObject members.

Public Properties

 | Name | Description
Public Property | ColumnMap |
Public Property | FieldValues |
Public Property | UniqueID |

Reference

DataObject Class
FChoice.Foundation.DataObjects Namespace


DataObjectCollection Class Methods | fcSDK Documentation

DataObjectCollection Class Methods

For a list of all members of this type, see DataObjectCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex |
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

DataObjectCollection Class
FChoice.Foundation.DataObjects Namespace


DataObjectCollection Class Properties | fcSDK Documentation

DataObjectCollection Class Properties

For a list of all members of this type, see DataObjectCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | Item | (Inherited from System.Collections.Generic.List)

Reference

DataObjectCollection Class
FChoice.Foundation.DataObjects Namespace


FakeTimeZone Class Methods | fcSDK Documentation

FakeTimeZone Class Methods

For a list of all members of this type, see FakeTimeZone members.

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | ConvertDate | (Inherited from FChoice.Foundation.Clarify.DataObjects.FCTimeZone)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | IsDaylightSavingsTime | (Inherited from FChoice.Foundation.Clarify.DataObjects.FCTimeZone)

Reference

FakeTimeZone Class
FChoice.Foundation.DataObjects Namespace


FakeTimeZone Class Properties | fcSDK Documentation

FakeTimeZone Class Properties

For a list of all members of this type, see FakeTimeZone members.

Public Properties

 | Name | Description
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | DaylightSavingsPeriods | (Inherited from FChoice.Foundation.Clarify.DataObjects.FCTimeZone)
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | FullName | (Inherited from FChoice.Foundation.Clarify.DataObjects.FCTimeZone)
Public Property | IsDefault | (Inherited from FChoice.Foundation.Clarify.DataObjects.FCTimeZone)
Public Property | Name | (Inherited from FChoice.Foundation.Clarify.DataObjects.FCTimeZone)
Public Property | ObjectID | (Inherited from FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject)
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | UtcOffsetSeconds | (Inherited from FChoice.Foundation.Clarify.DataObjects.FCTimeZone)

Reference

FakeTimeZone Class
FChoice.Foundation.DataObjects Namespace


IDataObject Interface Methods | fcSDK Documentation

IDataObject Interface Methods

For a list of all members of this type, see IDataObject members.

Public Methods

 | Name | Description
Method | ContainsColumn |
Method | GetFieldValue | Overloaded.
Method | GetSafeBooleanFieldValue |
Method | GetSafeDoubleFieldValue |
Method | GetSafeInt32FieldValue |
Method | GetSafeStringFieldValue |

Reference

IDataObject Interface
FChoice.Foundation.DataObjects Namespace


IDataObject Interface Properties | fcSDK Documentation

IDataObject Interface Properties

For a list of all members of this type, see IDataObject members.

Public Properties

 | Name | Description
Property | ColumnMap |
Property | FieldValues |
Property | UniqueID |

Reference

IDataObject Interface
FChoice.Foundation.DataObjects Namespace


ITimeZone Interface Methods | fcSDK Documentation

ITimeZone Interface Methods

For a list of all members of this type, see ITimeZone members.

Public Methods

 | Name | Description
Method | IsDaylightSavingsTime |

Reference

ITimeZone Interface
FChoice.Foundation.DataObjects Namespace


ITimeZone Interface Properties | fcSDK Documentation

ITimeZone Interface Properties

For a list of all members of this type, see ITimeZone members.

Public Properties

 | Name | Description
Property | FullName |
Property | Name |
Property | UtcOffsetSeconds |

Reference

ITimeZone Interface
FChoice.Foundation.DataObjects Namespace


RestrictionGroup Class Methods | fcSDK Documentation

RestrictionGroup Class Methods

For a list of all members of this type, see RestrictionGroup members.

Public Methods

 | Name | Description
Public Method | ContainsColumn | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetFieldValue | Overloaded. (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeBooleanFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeDoubleFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeInt32FieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Method | GetSafeStringFieldValue | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

RestrictionGroup Class
FChoice.Foundation.DataObjects Namespace


RestrictionGroup Class Properties | fcSDK Documentation

RestrictionGroup Class Properties

For a list of all members of this type, see RestrictionGroup members.

Public Properties

 | Name | Description
Public Property | ColumnMap | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | FieldValues | (Inherited from FChoice.Foundation.DataObjects.DataObject)
Public Property | Name |
Public Property | Restrictions |
Public Property | UniqueID | (Inherited from FChoice.Foundation.DataObjects.DataObject)

Reference

RestrictionGroup Class
FChoice.Foundation.DataObjects Namespace


RestrictionGroupCollection Class Methods | fcSDK Documentation

RestrictionGroupCollection Class Methods

For a list of all members of this type, see RestrictionGroupCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List)
Public Method | AddRange | (Inherited from System.Collections.Generic.List)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Clear | (Inherited from System.Collections.Generic.List)
Public Method | Contains | (Inherited from System.Collections.Generic.List)
Public Method | ConvertAll | (Inherited from System.Collections.Generic.List)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Exists | (Inherited from System.Collections.Generic.List)
Public Method | Find | (Inherited from System.Collections.Generic.List)
Public Method | FindAll | (Inherited from System.Collections.Generic.List)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | FindLast | (Inherited from System.Collections.Generic.List)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ForEach | (Inherited from System.Collections.Generic.List)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List)
Public Method | GetItemByIndex | (Inherited from FChoice.Foundation.DataObjects.DataObjectCollection)
Public Method | GetRange | (Inherited from System.Collections.Generic.List)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Insert | (Inherited from System.Collections.Generic.List)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Remove | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List)
Public Method | ToArray | (Inherited from System.Collections.Generic.List)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List)

Reference

RestrictionGroupCollection Class
FChoice.Foundation.DataObjects Namespace


RestrictionGroupCollection Class Properties | fcSDK Documentation

RestrictionGroupCollection Class Properties

For a list of all members of this type, see RestrictionGroupCollection members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List)
Public Property | Count | (Inherited from System.Collections.Generic.List)
Public Property | Item |

Reference

RestrictionGroupCollection Class
FChoice.Foundation.DataObjects Namespace


FChoice.Foundation.DataObjects Namespace #### Inheritance Hierarchy | fcSDK Documentation

FChoice.Foundation.DataObjects Namespace #### Inheritance Hierarchy

Inheritance Hierarchy

System.Object
FChoice.Foundation.DataObjects.ColumnInfo
FChoice.Foundation.DataObjects.DataObject
FChoice.Foundation.Clarify.DataObjects.ClarifyDataObject
FChoice.Foundation.Clarify.DataObjects.Country
FChoice.Foundation.Clarify.DataObjects.DaylightSavingsPeriod
FChoice.Foundation.Clarify.DataObjects.FCString
FChoice.Foundation.Clarify.DataObjects.FCTimeZone
FChoice.Foundation.DataObjects.FakeTimeZone
FChoice.Foundation.Clarify.DataObjects.GlobalStringElement
FChoice.Foundation.Clarify.DataObjects.GlobalStringList
FChoice.Foundation.Clarify.DataObjects.HierarchicalStringElement
FChoice.Foundation.Clarify.DataObjects.HierarchicalStringList
FChoice.Foundation.Clarify.DataObjects.HierarchicalStringShow
FChoice.Foundation.Clarify.DataObjects.LocalizedString
FChoice.Foundation.Clarify.DataObjects.StateProvince
FChoice.Foundation.Clarify.Schema.SchemaFieldBase
FChoice.Foundation.Clarify.Schema.SchemaTableField
FChoice.Foundation.Clarify.Schema.SchemaViewField
FChoice.Foundation.Clarify.Schema.SchemaRelation
FChoice.Foundation.Clarify.Schema.SchemaTableBase
FChoice.Foundation.Clarify.Schema.SchemaTable
FChoice.Foundation.Clarify.Schema.SchemaView
FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfo
FChoice.Foundation.Clarify.Schema.SchemaViewJoin
FChoice.Foundation.DataObjects.ConfigItem
FChoice.Foundation.Clarify.DataObjects.ClarifyConfigItem
FChoice.Foundation.DataObjects.RestrictionGroup
System.Collections.Generic.List
FChoice.Foundation.DataObjects.DataObjectCollection
FChoice.Foundation.Clarify.DataObjects.CountryCollection
FChoice.Foundation.Clarify.DataObjects.DaylightSavingsCollection
FChoice.Foundation.Clarify.DataObjects.FCTimeZoneCollection
FChoice.Foundation.Clarify.DataObjects.GlobalStringElementCollection
FChoice.Foundation.Clarify.DataObjects.GlobalStringListCollection
FChoice.Foundation.Clarify.DataObjects.HierarchicalStringElementCollection
FChoice.Foundation.Clarify.DataObjects.HierarchicalStringListCollection
FChoice.Foundation.Clarify.DataObjects.StateCollection
FChoice.Foundation.Clarify.Schema.SchemaFieldCollectionBase
FChoice.Foundation.Clarify.Schema.SchemaTableFieldCollection
FChoice.Foundation.Clarify.Schema.SchemaViewFieldCollection
FChoice.Foundation.Clarify.Schema.SchemaRelationCollection
FChoice.Foundation.Clarify.Schema.SchemaTableCollection
FChoice.Foundation.Clarify.Schema.SchemaViewCollection
FChoice.Foundation.Clarify.Schema.SchemaViewFieldInfoCollection
FChoice.Foundation.Clarify.Schema.SchemaViewJoinCollection
FChoice.Foundation.DataObjects.ConfigItemCollection
FChoice.Foundation.Clarify.DataObjects.ClarifyConfigItemCollection
FChoice.Foundation.DataObjects.RestrictionGroupCollection

Reference

fcSDK Assembly


DictionaryExtensions Class Methods | fcSDK Documentation

DictionaryExtensions Class Methods

For a list of all members of this type, see DictionaryExtensions members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | Get<T,V> |

Reference

DictionaryExtensions Class
FChoice.Foundation Namespace


DynamicBindingCollection Class Methods | fcSDK Documentation

DynamicBindingCollection Class Methods

For a list of all members of this type, see DynamicBindingCollection members.

Public Methods

 | Name | Description
Public Method | Add(IDynamicBinding) | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | Remove(IDynamicBinding) | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection)

Reference

DynamicBindingCollection Class
FChoice.Foundation.DynamicBinding Namespace


DynamicBindingCollection Class Properties | fcSDK Documentation

DynamicBindingCollection Class Properties

For a list of all members of this type, see DynamicBindingCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection)

Reference

DynamicBindingCollection Class
FChoice.Foundation.DynamicBinding Namespace


Add Method (DynamicBindingCollection) | fcSDK Documentation

Add Method (DynamicBindingCollection)

Overload List

Overload | Description
Add(IDynamicBinding) | (Inherited from System.Collections.ObjectModel.Collection)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DynamicBindingCollection Class
DynamicBindingCollection Members


Remove Method (DynamicBindingCollection) | fcSDK Documentation

Remove Method (DynamicBindingCollection)

Overload List

Overload | Description
Remove(IDynamicBinding) | (Inherited from System.Collections.ObjectModel.Collection)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

DynamicBindingCollection Class
DynamicBindingCollection Members


IDynamicBinding Interface Methods | fcSDK Documentation

IDynamicBinding Interface Methods

For a list of all members of this type, see IDynamicBinding members.

Public Methods

 | Name | Description
Method | ProcessBinding |

Reference

IDynamicBinding Interface
FChoice.Foundation.DynamicBinding Namespace


IDynamicBinding Interface Properties | fcSDK Documentation

IDynamicBinding Interface Properties

For a list of all members of this type, see IDynamicBinding members.

Public Properties

 | Name | Description
Property | Processed |
Property | Relation |

Reference

IDynamicBinding Interface
FChoice.Foundation.DynamicBinding Namespace


FChoice.Foundation.DynamicBinding Namespace #### Inheritance Hierarchy | fcSDK Documentation

FChoice.Foundation.DynamicBinding Namespace #### Inheritance Hierarchy

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection
FChoice.Foundation.DynamicBinding.DynamicBindingCollection

Reference

fcSDK Assembly


FCApplication Class Fields | fcSDK Documentation

FCApplication Class Fields

For a list of all members of this type, see FCApplication members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | SyncRoot |

Reference

FCApplication Class
FChoice.Foundation Namespace


FCApplication Class Methods | fcSDK Documentation

FCApplication Class Methods

For a list of all members of this type, see FCApplication members.

Public Methods

 | Name | Description
Public Method | CurrentSessions | Provides a view into the FCApplication's currently running sessions.
static (Shared in Visual Basic) | Deinitialize | Unloads the FCApplication singleton from the current AppDomain.
static (Shared in Visual Basic) | Log | Overloaded.
static (Shared in Visual Basic) | LogDebug | Overloaded.
static (Shared in Visual Basic) | LogError | Overloaded.
static (Shared in Visual Basic) | LogInfo | Overloaded.
static (Shared in Visual Basic) | LogWarn | Overloaded.

Reference

FCApplication Class
FChoice.Foundation Namespace


FCApplication Class Properties | fcSDK Documentation

FCApplication Class Properties

For a list of all members of this type, see FCApplication members.

Public Properties

 | Name | Description
Public Property | DatabaseVersion |
static (Shared in Visual Basic) | IsInitialized |

Reference

FCApplication Class
FChoice.Foundation Namespace


FCGeneric Class Events | fcSDK Documentation

FCGeneric Class Events

For a list of all members of this type, see FCGeneric members.

Public Events

 | Name | Description
Public Event | MaximumRowsExceeded | This event is fired when the MaximumRows property is set and a Query operation has returned too many rows.

Reference

FCGeneric Class
FChoice.Foundation Namespace


FCGeneric Class Fields | fcSDK Documentation

FCGeneric Class Fields

For a list of all members of this type, see FCGeneric members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | MAX_DATE | Maximum possible date that is allowed to be entered for a date field.
static (Shared in Visual Basic) | MIN_DATE | Minimum possible date that is allowed to be entered for a date field.
static (Shared in Visual Basic) | NOW_DATE | When date fields are set to this value the current server datetime will be entered instead.

Reference

FCGeneric Class
FChoice.Foundation Namespace


FCGeneric Class Methods | fcSDK Documentation

FCGeneric Class Methods

For a list of all members of this type, see FCGeneric members.

Public Methods

 | Name | Description
Public Method | AppendFilter | Overloaded. Adds a filter to constrain the results of an FCGeneric Query against a numeric DataField.
Public Method | AppendFilterBetween | Overloaded. Adds a specialized filter to constrain the results of an FCGeneric Query to be between two Integer values.
Public Method | AppendFilterInList | Overloaded. Adds a filter to constrain the results of an FCGeneric Query against a list of possible Integer values**.**
Public Method | AppendFilterIsNull | Adds a filter to constrain the results of an FCGeneric Query against NULL or NOT NULL fields.
Public Method | AppendSort | Overloaded. Adds a field by which the results of an FCGeneric Query will be sorted.
Public Method | AssignObjID |
Public Method | ChangeRestrictionGroup | Change the Data Restriction Group of this generic instance overriding the Session default. This method is a helper for when you only know the name of the restriction group.
Public Method | ClearFilters | Clears all filters that have been appended to this generic.
Public Method | ClearSorts | Clears all sort operations that have been appended to this generic.
Public Method | CopyTo | Copies all the rows of the current FCGeneric into to a one-dimensional Array.
Public Method | DeleteAll | Delete all rows present in this FCGeneric.
Public Method | GetEnumerator | Returns an IEnumerator for the FCGeneric.
Public Method | Query | Overloaded. Causes the generic object to query the database table or view using the optionally specified data fields, filters, and sort orders
Public Method | Update | Overloaded. Updates changes to a single GenericDataRow
Public Method | UpdateAll | Overloaded. Updates all modified rows of the FCGeneric.

Reference

FCGeneric Class
FChoice.Foundation Namespace


FCGeneric Class Properties | fcSDK Documentation

FCGeneric Class Properties

For a list of all members of this type, see FCGeneric members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | ChildGenerics | Returns a dictionary (keyed by parent to child relation name) of child generics belonging to this FCGeneric. | | Public Property | Count | Returns the number of rows currently populated by the Query or AddNew methods. | | Public Property | DataFields | Collection of data fields that will be returned when Query is invoked. If no fields are selected all fields are returned. | | Public Property | DataRestrictionsEnabled | Sets whether or not this FCGeneric will have the DataRestrictions feature enabled if available.

| | Public Property | DeleteRelationsToUnrelate | | | Public Property | Filter | This is the root filter used to constrain rows returned during Query operations. Initially there are no filters present with filters being added using the AddFilter method. | | Public Property | IncludeRelations | Queries will retrieve all relation fields for the Generic | | Public Property | IsDistinct | Is this a Generic that should query for only discinct rows. | | Public Property | IsSynchronized | Gets a value indicating whether access to the FCGeneric is synchronized (thread-safe). | | Public Property | MaximumRows | Controls the maximum number of rows to be returned by the Genric Query. | | Public Property | QueryEmptyToNull |

Sets whether or not this FCGeneric will convert filters on empty strings into filters on Queries that check IS NULL or IS NOT NULL.

| | Public Property | RawFilter |

Sets an optional WHERE clause constraint. (WARNING: See remarks for potential security implications)

| | Public Property | RestrictionGroup | Override the Session Data Restriction Group of this Generic. The ChangeRestrictionGroup method is available as a helper. | | Public Property | SearchableFieldPrefix | | | Public Property | SetNullStringsToEmpty | Sets whether or not this FCGeneric will convert a null reference (Nothing in Visual Basic) to empty strings. | | Public Property | SyncRoot | Gets an object that can be used to synchronize access to the FCGeneric. | | Public Property | TableName | Returns the name of the database table this FCGeneric is based on. |

Reference

FCGeneric Class
FChoice.Foundation Namespace


FCInvalidLoginException Class Methods | fcSDK Documentation

FCInvalidLoginException Class Methods

For a list of all members of this type, see FCInvalidLoginException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | Sets the SerializationInfo object with the parameter name and additional exception information. (Inherited from FChoice.Common.FCExceptionBase)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)

Reference

FCInvalidLoginException Class
FChoice.Foundation Namespace


FCInvalidLoginException Class Properties | fcSDK Documentation

FCInvalidLoginException Class Properties

For a list of all members of this type, see FCInvalidLoginException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorCode | Gets the unique error code for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | ErrorMessageID | Gets the message identifier for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)

Reference

FCInvalidLoginException Class
FChoice.Foundation Namespace


FCInvalidLoginException Constructor | fcSDK Documentation

FCInvalidLoginException Constructor

Overload List

Overload | Description
FCInvalidLoginException Constructor |

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCInvalidLoginException Class
FCInvalidLoginException Members


FCSession Class Methods | fcSDK Documentation

FCSession Class Methods

For a list of all members of this type, see FCSession members.

Public Methods

| | Name | Description | | --- | --- | --- | | Public Method | ChangePassword | Change the password for the session user. | | Public Method | ChangeRestrictionGroup | Changes the RestrictionGroup the session is currently using. The change can be made permanent. | | Public Method | CloseSession | | | Public Method | ConvertDate | Overloaded. Converts a DateTime from one TimeZone to another. | | Public Method | ConvertFromLocalToServerDate | Converts a DateTime from the session timezone to the server timezone. | | Public Method | ConvertFromServerToLocalDate | Converts a DateTime from the server timezone to the session timezone.

| | Public Method | Dispose | | | Public Method | FormatElapsedTime | Overloaded. Formats an numeric value in seconds into a string "DDD HH MMM" where: D=Days, H=Hours, M=Minutes | | Public Method | GetAssignedPermissions | | | Public Method | GetCurrentDate | Retrieves the DateTime of the CRM database. | | Public Method | GetCurrentServerDate | Retrieves the DateTime of the CRM database. | | Public Method | HasPermission | | | Public Method | RefreshContext | Refresh the session information for the logged-in user. | | Public Method | RegisterLicenseRequirements | | | Public Method | SaveSession | | | Public Method | SetPassword | Change a user's password |

Reference

FCSession Class
FChoice.Foundation Namespace


FCSession Class Properties | fcSDK Documentation

FCSession Class Properties

For a list of all members of this type, see FCSession members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | ConfigItems | Collection of CRM session configuration items. | | Public Property | ConvertTimeZone | Sets whether or not any DateTimes will be translated to and from ServerTimeZone and LocalTimeZone. Default value is false. | | Public Property | CreationTime | Timestamp when the session was created. | | Public Property | CurrentCulture | Returns the Culture being used by the session. | | Public Property | DataRestrictionsEnabled | | | Public Property | DefaultCulture | Returns the default Culture being used by the session. | | Public Property | DefaultDistinctGenerics | Sets whether or not newly created generic objects will have IsDistinct set to include all relation data fields during Queries.

| | Public Property | DisableDataConversions | Sets whether data conversions happen when GenericDataRow fields are modified. | | Public Property | IncludeRelations | Sets whether or not newly created generic objects will include all relation data fields during Queries. | | Public Property | Item | Get or set session data indexed by specified key. | | Public Property | Items | | | Public Property | LastLoadTime | Timestamp when the session was last loaded via FCApplication.GetSession | | Public Property | LocalTimeZone | The TimeZone being used by the session. | | Public Property | Log | Returns a Logger useful for logging application events or errors to the logging system. | | Public Property | LoginType | Returns the login type of the logged-in user. | | Public Property | MaximumRows | | | Public Property | PasswordRequired | Gets whether or not a password was used when CreateSession was called. | | Public Property | QueryEmptyToNull |

Sets whether or not new newly created generic objects convert filters on empty strings into filters on Queries that check Is NULL or IS NOT NULL.

| | Public Property | RestrictionGroup | Returns the data restriction group being used by the session. | | Public Property | SessionData | | | Public Property | SessionID |

Returns the session's unique identifier.

| | Public Property | SetNullStringsToEmpty | Sets whether or not newly created generic objects will convert a null reference (Nothing in Visual Basic) to empty strings. | | Public Property | TruncateStringFields | Sets whether or not newly created generic objects will truncate string fields if they are too long. | | Public Property | UserID | Returns the unique identifier for the session's logged-in user. | | Public Property | UserName | Returns the login name for the session's logged-in user. |

Reference

FCSession Class
FChoice.Foundation Namespace


FCSessionData Class Fields | fcSDK Documentation

FCSessionData Class Fields

For a list of all members of this type, see FCSessionData members.

Public Fields

 | Name | Description
static (Shared in Visual Basic) | DefaultCulture | Default culture of the user session.

Reference

FCSessionData Class
FChoice.Foundation Namespace


FCSessionData Class Methods | fcSDK Documentation

FCSessionData Class Methods

For a list of all members of this type, see FCSessionData members.

Public Methods

 | Name | Description
Public Method | CopyTo |

Reference

FCSessionData Class
FChoice.Foundation Namespace


FCSessionData Class Properties | fcSDK Documentation

FCSessionData Class Properties

For a list of all members of this type, see FCSessionData members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | ConfigItems | Collection of CRM session configuration items. | | Public Property | ConvertTimeZone | Session option: Gets whether or not any DateTimes will be translated to and from ServerTimeZone and LocalTimeZone. Default value is false. | | Public Property | CreationTime | Timestamp when the session was created. | | Public Property | CurrentCulture | The Culture being used by the session. | | Public Property | CurResGroup | The restriction group being used by the session. | | Public Property | DefaultDistinctGenerics | Session option which makes Generics have IsDistinct enable by default. | | Public Property | DisableDataConversion | Session option which disables data conversions when values are set for GenericDataRow fields. | | Public Property | DisableRestrictions | Returns whether or not the DataRestrictions feature is enabled or disabled. | | Public Property | EmptyNullStrings | Session option that cues Generics to make Null fields be empty strings. Specifically for Oracle. | | Public Property | IncludeRelations | Session option that cues Generics to include all relation data fields during Queries | | Public Property | IsDirty | | | Public Property | LastLoadTime | Timestamp when the session was last loaded via GetSession | | Public Property | LocalTimeZone | The TimeZone being used by the session. | | Public Property | LoginTime | | | Public Property | LoginType | User login type | | Public Property | MaximumRows | | | Public Property | NewSession | | | Public Property | PasswordRequired | Session option denoting whether a password was used to create a session. | | Public Property | Permissions | | | Public Property | QueryEmptyToNull | Session option that cues Generics to convert filters on empty strings into filters on Queries that check Is NULL or IS NOT NULL. | | Public Property | SessionData | CRM configurable session data populates this property during CreateSession | | Public Property | SessionID | A session's unique identifier.

| | Public Property | TruncateStringFields | Session option that cues Generics to truncate strings that exceed database field lengths when assigned to a GenericDataRow | | Public Property | UserID | UniqueID of the user that created the Session. | | Public Property | UserName | Name of the user that created the Session. |

Reference

FCSessionData Class
FChoice.Foundation Namespace


FCSessionSummary Class Properties | fcSDK Documentation

FCSessionSummary Class Properties

For a list of all members of this type, see FCSessionSummary members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | CreationTime | Timestamp when the session was created. | | Public Property | LastLoadTime | Timestamp when the session was last loaded via FCApplication.GetSession | | Public Property | LoginType | | | Public Property | SessionID | Returns the session's unique identifier.

| | Public Property | UserID | Returns the unique identifier for the session's logged-in user. | | Public Property | UserName | Returns the login name for the session's logged-in user. |

Reference

FCSessionSummary Class
FChoice.Foundation Namespace


CloseSession Method (FCSession) | fcSDK Documentation

CloseSession Method (FCSession)

Remove the session from FCApplication and any Licenses it may be holding.

Overload List

Overload | Description
CloseSession |

Remarks

FCApplication.CreateSession creates a session and keeps a reference to it so that it may be later retrieved via SessionID. FCApplication keeps a reference to help reduce the overhead of authentication and retrieval of possibly extensive session data. Thus it is important for long running applications to call this method when they are finished with the session object.

Any Licenses that have been obtained by the session are released when the session is closed.

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

FCSession Class
FCSession Members


AfterFilter Class Methods | fcSDK Documentation

AfterFilter Class Methods

For a list of all members of this type, see AfterFilter members.

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

AfterFilter Class
FChoice.Foundation.Filters Namespace


AfterFilter Class Properties | fcSDK Documentation

AfterFilter Class Properties

For a list of all members of this type, see AfterFilter members.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | Operator | (Inherited from FChoice.Foundation.Filters.MoreThanFilter)
Public Property | Value | (Inherited from FChoice.Foundation.Filters.OperationFilter)

Reference

AfterFilter Class
FChoice.Foundation.Filters Namespace


AndFilter Class Methods | fcSDK Documentation

AndFilter Class Methods

For a list of all members of this type, see AndFilter members.

Public Methods

 | Name | Description
Public Method | AddFilter | This method is called to add a filter to a logical grouping (Inherited from FChoice.Foundation.Filters.LogicalFilter)
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

AndFilter Class
FChoice.Foundation.Filters Namespace


AndFilter Class Properties | fcSDK Documentation

AndFilter Class Properties

For a list of all members of this type, see AndFilter members.

Public Properties

 | Name | Description
Public Property | Filters | Collection of Filters that belong to this logical grouping. (Inherited from FChoice.Foundation.Filters.LogicalFilter)

Reference

AndFilter Class
FChoice.Foundation.Filters Namespace


AndManyFilter Class Methods | fcSDK Documentation

AndManyFilter Class Methods

For a list of all members of this type, see AndManyFilter members.

Public Methods

 | Name | Description
Public Method | AddFilter | This method is called to add a filter to a logical grouping (Inherited from FChoice.Foundation.Filters.LogicalFilter)
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

AndManyFilter Class
FChoice.Foundation.Filters Namespace


AndManyFilter Class Properties | fcSDK Documentation

AndManyFilter Class Properties

For a list of all members of this type, see AndManyFilter members.

Public Properties

 | Name | Description
Public Property | Filters | Collection of Filters that belong to this logical grouping. (Inherited from FChoice.Foundation.Filters.LogicalFilter)

Reference

AndManyFilter Class
FChoice.Foundation.Filters Namespace


BeforeFilter Class Methods | fcSDK Documentation

BeforeFilter Class Methods

For a list of all members of this type, see BeforeFilter members.

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

BeforeFilter Class
FChoice.Foundation.Filters Namespace


BeforeFilter Class Properties | fcSDK Documentation

BeforeFilter Class Properties

For a list of all members of this type, see BeforeFilter members.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | Operator | (Inherited from FChoice.Foundation.Filters.LessThanFilter)
Public Property | Value | (Inherited from FChoice.Foundation.Filters.OperationFilter)

Reference

BeforeFilter Class
FChoice.Foundation.Filters Namespace


BetweenFilter Class Methods | fcSDK Documentation

BetweenFilter Class Methods

For a list of all members of this type, see BetweenFilter members.

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

BetweenFilter Class
FChoice.Foundation.Filters Namespace


BetweenFilter Class Properties | fcSDK Documentation

BetweenFilter Class Properties

For a list of all members of this type, see BetweenFilter members.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | IsBetween |
Public Property | Value1 |
Public Property | Value1Present |
Public Property | Value2 |
Public Property | Value2Present |

Reference

BetweenFilter Class
FChoice.Foundation.Filters Namespace


ColumnBasedFilter Class Methods | fcSDK Documentation

ColumnBasedFilter Class Methods

For a list of all members of this type, see ColumnBasedFilter members.

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

ColumnBasedFilter Class
FChoice.Foundation.Filters Namespace


ColumnBasedFilter Class Properties | fcSDK Documentation

ColumnBasedFilter Class Properties

For a list of all members of this type, see ColumnBasedFilter members.

Public Properties

 | Name | Description
Public Property | ColumnName |

Reference

ColumnBasedFilter Class
FChoice.Foundation.Filters Namespace


ContainsFilter Class Methods | fcSDK Documentation

ContainsFilter Class Methods

For a list of all members of this type, see ContainsFilter members.

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

ContainsFilter Class
FChoice.Foundation.Filters Namespace


ContainsFilter Class Properties | fcSDK Documentation

ContainsFilter Class Properties

For a list of all members of this type, see ContainsFilter members.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | Operator | (Inherited from FChoice.Foundation.Filters.LikeFilter)
Public Property | Value | (Inherited from FChoice.Foundation.Filters.OperationFilter)

Reference

ContainsFilter Class
FChoice.Foundation.Filters Namespace


EndsWithFilter Class Methods | fcSDK Documentation

EndsWithFilter Class Methods

For a list of all members of this type, see EndsWithFilter members.

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

EndsWithFilter Class
FChoice.Foundation.Filters Namespace


EndsWithFilter Class Properties | fcSDK Documentation

EndsWithFilter Class Properties

For a list of all members of this type, see EndsWithFilter members.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | Operator | (Inherited from FChoice.Foundation.Filters.LikeFilter)
Public Property | Value | (Inherited from FChoice.Foundation.Filters.OperationFilter)

Reference

EndsWithFilter Class
FChoice.Foundation.Filters Namespace


EqualsFilter Class Methods | fcSDK Documentation

EqualsFilter Class Methods

For a list of all members of this type, see EqualsFilter members.

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

EqualsFilter Class
FChoice.Foundation.Filters Namespace


EqualsFilter Class Properties | fcSDK Documentation

EqualsFilter Class Properties

For a list of all members of this type, see EqualsFilter members.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | Operator | Overridden.
Public Property | Value | (Inherited from FChoice.Foundation.Filters.OperationFilter)

Reference

EqualsFilter Class
FChoice.Foundation.Filters Namespace


Filter Class Methods | fcSDK Documentation

Filter Class Methods

For a list of all members of this type, see Filter members.

Public Methods

 | Name | Description
Public Method | Render |
Public Method | ValidateFilter |

Reference

Filter Class
FChoice.Foundation.Filters Namespace


FilterCollection Class Methods | fcSDK Documentation

FilterCollection Class Methods

For a list of all members of this type, see FilterCollection members.

Public Methods

 | Name | Description
Public Method | Add |
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | Contains |
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection)

Reference

FilterCollection Class
FChoice.Foundation.Filters Namespace


FilterCollection Class Properties | fcSDK Documentation

FilterCollection Class Properties

For a list of all members of this type, see FilterCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection)

Reference

FilterCollection Class
FChoice.Foundation.Filters Namespace


FilterExpression Class Methods | fcSDK Documentation

FilterExpression Class Methods

For a list of all members of this type, see FilterExpression members.

Public Methods

 | Name | Description
Public Method | After |
Public Method | And | Overloaded.
Public Method | Before |
Public Method | Between | Overloaded.
Public Method | Contains |
Public Method | EndsWith |
Public Method | Equals | Overloaded.
Public Method | IsIn | Overloaded.
Public Method | IsNotIn | Overloaded.
Public Method | IsNotNull |
Public Method | IsNull |
Public Method | LessThan | Overloaded.
Public Method | LessThanOrEqual | Overloaded.
Public Method | Like |
Public Method | MoreThan | Overloaded.
Public Method | MoreThanOrEqual | Overloaded.
Public Method | NotBetween | Overloaded.
Public Method | NotContains |
Public Method | NotEndsWith |
Public Method | NotEqual | Overloaded.
Public Method | NotLike |
Public Method | NotStartsWith |
Public Method | OlderThanDays | Overloaded.
Public Method | OlderThanHours | Overloaded.
Public Method | On |
Public Method | Or | Overloaded.
Public Method | SoundsLike |
Public Method | StartsWith |
Public Method | Today |
Public Method | Tomorrow |
Public Method | WithinDays | Overloaded.
Public Method | WithinHours | Overloaded.
Public Method | Yesterday |

Reference

FilterExpression Class
FChoice.Foundation.Filters Namespace


FilterType Class Methods | fcSDK Documentation

FilterType Class Methods

For a list of all members of this type, see FilterType members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | After | Filter field on dates coming after the input to this filter
static (Shared in Visual Basic) | And | Overloaded. Logical filter allowing 2 or more AND (inclusive) filters.
static (Shared in Visual Basic) | Before | Filter field on dates coming before the input to this filter
static (Shared in Visual Basic) | Between | Overloaded.
static (Shared in Visual Basic) | Contains | Filter field on strings that contain the input to this filter
static (Shared in Visual Basic) | EndsWith | Filter on strings that end with the input to this filter
static (Shared in Visual Basic) | Equals | Overloaded.
static (Shared in Visual Basic) | IsIn | Overloaded.
static (Shared in Visual Basic) | IsNotIn | Overloaded.
static (Shared in Visual Basic) | IsNotNull | Filter on fields that are not null
static (Shared in Visual Basic) | IsNull | Filter on fields that are null
static (Shared in Visual Basic) | LessThan | Overloaded.
static (Shared in Visual Basic) | LessThanOrEqual | Overloaded.
static (Shared in Visual Basic) | Like | Filter field on strings that are like the filter input
static (Shared in Visual Basic) | MoreThan | Overloaded.
static (Shared in Visual Basic) | MoreThanOrEqual | Overloaded.
static (Shared in Visual Basic) | NotBetween | Overloaded.
static (Shared in Visual Basic) | NotContains | Filter field on strings that do not contain the input to this filter
static (Shared in Visual Basic) | NotEndsWith | Filter field on strings that do end with the input to this filter
static (Shared in Visual Basic) | NotEqual | Overloaded.
static (Shared in Visual Basic) | NotLike | Filter field on strings that are not like the filter input
static (Shared in Visual Basic) | NotStartsWith | Filter field on strings that do start with the input to this filter
static (Shared in Visual Basic) | OlderThanDays | Overloaded.
static (Shared in Visual Basic) | OlderThanHours | Overloaded.
static (Shared in Visual Basic) | On | Filter field on dates occuring on the the input to this filter
static (Shared in Visual Basic) | Or | Overloaded. Logical filter allowing 2 or more OR (exclusive) filters.
static (Shared in Visual Basic) | SoundsLike | Filter field on strings sound like the input to this filter
static (Shared in Visual Basic) | StartsWith | Filter field on strings that start with the input to this filter
static (Shared in Visual Basic) | Today | Filter field on today's date
static (Shared in Visual Basic) | Tomorrow | Filter field on tomorrow's date
static (Shared in Visual Basic) | WithinDays | Overloaded.
static (Shared in Visual Basic) | WithinHours | Overloaded.
static (Shared in Visual Basic) | Yesterday | Filter field on yesterday's date

Reference

FilterType Class
FChoice.Foundation.Filters Namespace


IsInFilter Class Methods | fcSDK Documentation

IsInFilter Class Methods

For a list of all members of this type, see IsInFilter members.

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

IsInFilter Class
FChoice.Foundation.Filters Namespace


IsInFilter Class Properties | fcSDK Documentation

IsInFilter Class Properties

For a list of all members of this type, see IsInFilter members.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | IsIn |
Public Property | ObjectList |

Reference

IsInFilter Class
FChoice.Foundation.Filters Namespace


IsNullFilter Class Methods | fcSDK Documentation

IsNullFilter Class Methods

For a list of all members of this type, see IsNullFilter members.

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

IsNullFilter Class
FChoice.Foundation.Filters Namespace


IsNullFilter Class Properties | fcSDK Documentation

IsNullFilter Class Properties

For a list of all members of this type, see IsNullFilter members.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | IsNull |

Reference

IsNullFilter Class
FChoice.Foundation.Filters Namespace


LessThanFilter Class Methods | fcSDK Documentation

LessThanFilter Class Methods

For a list of all members of this type, see LessThanFilter members.

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

LessThanFilter Class
FChoice.Foundation.Filters Namespace


LessThanFilter Class Properties | fcSDK Documentation

LessThanFilter Class Properties

For a list of all members of this type, see LessThanFilter members.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | Operator | Overridden.
Public Property | Value | (Inherited from FChoice.Foundation.Filters.OperationFilter)

Reference

LessThanFilter Class
FChoice.Foundation.Filters Namespace


LessThanOrEqualFilter Class Methods | fcSDK Documentation

LessThanOrEqualFilter Class Methods

For a list of all members of this type, see LessThanOrEqualFilter members.

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

LessThanOrEqualFilter Class
FChoice.Foundation.Filters Namespace


LessThanOrEqualFilter Class Properties | fcSDK Documentation

LessThanOrEqualFilter Class Properties

For a list of all members of this type, see LessThanOrEqualFilter members.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | Operator | Overridden.
Public Property | Value | (Inherited from FChoice.Foundation.Filters.OperationFilter)

Reference

LessThanOrEqualFilter Class
FChoice.Foundation.Filters Namespace


LikeFilter Class Methods | fcSDK Documentation

LikeFilter Class Methods

For a list of all members of this type, see LikeFilter members.

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

LikeFilter Class
FChoice.Foundation.Filters Namespace


LikeFilter Class Properties | fcSDK Documentation

LikeFilter Class Properties

For a list of all members of this type, see LikeFilter members.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | Operator | Overridden.
Public Property | Value | (Inherited from FChoice.Foundation.Filters.OperationFilter)

Reference

LikeFilter Class
FChoice.Foundation.Filters Namespace


LogicalFilter Class Methods | fcSDK Documentation

LogicalFilter Class Methods

For a list of all members of this type, see LogicalFilter members.

Public Methods

 | Name | Description
Public Method | AddFilter | This method is called to add a filter to a logical grouping
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

LogicalFilter Class
FChoice.Foundation.Filters Namespace


LogicalFilter Class Properties | fcSDK Documentation

LogicalFilter Class Properties

For a list of all members of this type, see LogicalFilter members.

Public Properties

 | Name | Description
Public Property | Filters | Collection of Filters that belong to this logical grouping.

Reference

LogicalFilter Class
FChoice.Foundation.Filters Namespace


MoreThanFilter Class Methods | fcSDK Documentation

MoreThanFilter Class Methods

For a list of all members of this type, see MoreThanFilter members.

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

MoreThanFilter Class
FChoice.Foundation.Filters Namespace


MoreThanFilter Class Properties | fcSDK Documentation

MoreThanFilter Class Properties

For a list of all members of this type, see MoreThanFilter members.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | Operator | Overridden.
Public Property | Value | (Inherited from FChoice.Foundation.Filters.OperationFilter)

Reference

MoreThanFilter Class
FChoice.Foundation.Filters Namespace


MoreThanOrEqualFilter Class Methods | fcSDK Documentation

MoreThanOrEqualFilter Class Methods

For a list of all members of this type, see MoreThanOrEqualFilter members.

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

MoreThanOrEqualFilter Class
FChoice.Foundation.Filters Namespace


MoreThanOrEqualFilter Class Properties | fcSDK Documentation

MoreThanOrEqualFilter Class Properties

For a list of all members of this type, see MoreThanOrEqualFilter members.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | Operator | Overridden.
Public Property | Value | (Inherited from FChoice.Foundation.Filters.OperationFilter)

Reference

MoreThanOrEqualFilter Class
FChoice.Foundation.Filters Namespace


NotContainsFilter Class Methods | fcSDK Documentation

NotContainsFilter Class Methods

For a list of all members of this type, see NotContainsFilter members.

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

NotContainsFilter Class
FChoice.Foundation.Filters Namespace


NotContainsFilter Class Properties | fcSDK Documentation

NotContainsFilter Class Properties

For a list of all members of this type, see NotContainsFilter members.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | Operator | (Inherited from FChoice.Foundation.Filters.NotLikeFilter)
Public Property | Value | (Inherited from FChoice.Foundation.Filters.OperationFilter)

Reference

NotContainsFilter Class
FChoice.Foundation.Filters Namespace


NotEndsWithFilter Class Methods | fcSDK Documentation

NotEndsWithFilter Class Methods

For a list of all members of this type, see NotEndsWithFilter members.

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

NotEndsWithFilter Class
FChoice.Foundation.Filters Namespace


NotEndsWithFilter Class Properties | fcSDK Documentation

NotEndsWithFilter Class Properties

For a list of all members of this type, see NotEndsWithFilter members.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | Operator | (Inherited from FChoice.Foundation.Filters.NotLikeFilter)
Public Property | Value | (Inherited from FChoice.Foundation.Filters.OperationFilter)

Reference

NotEndsWithFilter Class
FChoice.Foundation.Filters Namespace


NotLikeFilter Class Methods | fcSDK Documentation

NotLikeFilter Class Methods

For a list of all members of this type, see NotLikeFilter members.

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

NotLikeFilter Class
FChoice.Foundation.Filters Namespace


NotLikeFilter Class Properties | fcSDK Documentation

NotLikeFilter Class Properties

For a list of all members of this type, see NotLikeFilter members.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | Operator | Overridden.
Public Property | Value | (Inherited from FChoice.Foundation.Filters.OperationFilter)

Reference

NotLikeFilter Class
FChoice.Foundation.Filters Namespace


NotStartsWithFilter Class Methods | fcSDK Documentation

NotStartsWithFilter Class Methods

For a list of all members of this type, see NotStartsWithFilter members.

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

NotStartsWithFilter Class
FChoice.Foundation.Filters Namespace


NotStartsWithFilter Class Properties | fcSDK Documentation

NotStartsWithFilter Class Properties

For a list of all members of this type, see NotStartsWithFilter members.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | Operator | (Inherited from FChoice.Foundation.Filters.NotLikeFilter)
Public Property | Value | (Inherited from FChoice.Foundation.Filters.OperationFilter)

Reference

NotStartsWithFilter Class
FChoice.Foundation.Filters Namespace


OlderThanDaysFilter Class Methods | fcSDK Documentation

OlderThanDaysFilter Class Methods

For a list of all members of this type, see OlderThanDaysFilter members.

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

OlderThanDaysFilter Class
FChoice.Foundation.Filters Namespace


OlderThanDaysFilter Class Properties | fcSDK Documentation

OlderThanDaysFilter Class Properties

For a list of all members of this type, see OlderThanDaysFilter members.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | Operator | (Inherited from FChoice.Foundation.Filters.LessThanFilter)
Public Property | Value | (Inherited from FChoice.Foundation.Filters.OperationFilter)

Reference

OlderThanDaysFilter Class
FChoice.Foundation.Filters Namespace


OlderThanHoursFilter Class Methods | fcSDK Documentation

OlderThanHoursFilter Class Methods

For a list of all members of this type, see OlderThanHoursFilter members.

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

OlderThanHoursFilter Class
FChoice.Foundation.Filters Namespace


OlderThanHoursFilter Class Properties | fcSDK Documentation

OlderThanHoursFilter Class Properties

For a list of all members of this type, see OlderThanHoursFilter members.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | Operator | (Inherited from FChoice.Foundation.Filters.LessThanFilter)
Public Property | Value | (Inherited from FChoice.Foundation.Filters.OperationFilter)

Reference

OlderThanHoursFilter Class
FChoice.Foundation.Filters Namespace


OnFilter Class Methods | fcSDK Documentation

OnFilter Class Methods

For a list of all members of this type, see OnFilter members.

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

OnFilter Class
FChoice.Foundation.Filters Namespace


OnFilter Class Properties | fcSDK Documentation

OnFilter Class Properties

For a list of all members of this type, see OnFilter members.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | IsBetween | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value1 | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value1Present | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value2 | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value2Present | (Inherited from FChoice.Foundation.Filters.BetweenFilter)

Reference

OnFilter Class
FChoice.Foundation.Filters Namespace


OperationFilter Class Methods | fcSDK Documentation

OperationFilter Class Methods

For a list of all members of this type, see OperationFilter members.

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

OperationFilter Class
FChoice.Foundation.Filters Namespace


OperationFilter Class Properties | fcSDK Documentation

OperationFilter Class Properties

For a list of all members of this type, see OperationFilter members.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | Operator |
Public Property | Value |

Reference

OperationFilter Class
FChoice.Foundation.Filters Namespace


OrFilter Class Methods | fcSDK Documentation

OrFilter Class Methods

For a list of all members of this type, see OrFilter members.

Public Methods

 | Name | Description
Public Method | AddFilter | This method is called to add a filter to a logical grouping (Inherited from FChoice.Foundation.Filters.LogicalFilter)
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

OrFilter Class
FChoice.Foundation.Filters Namespace


OrFilter Class Properties | fcSDK Documentation

OrFilter Class Properties

For a list of all members of this type, see OrFilter members.

Public Properties

 | Name | Description
Public Property | Filters | Collection of Filters that belong to this logical grouping. (Inherited from FChoice.Foundation.Filters.LogicalFilter)

Reference

OrFilter Class
FChoice.Foundation.Filters Namespace


OrManyFilter Class Methods | fcSDK Documentation

OrManyFilter Class Methods

For a list of all members of this type, see OrManyFilter members.

Public Methods

 | Name | Description
Public Method | AddFilter | This method is called to add a filter to a logical grouping (Inherited from FChoice.Foundation.Filters.LogicalFilter)
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

OrManyFilter Class
FChoice.Foundation.Filters Namespace


OrManyFilter Class Properties | fcSDK Documentation

OrManyFilter Class Properties

For a list of all members of this type, see OrManyFilter members.

Public Properties

 | Name | Description
Public Property | Filters | Collection of Filters that belong to this logical grouping. (Inherited from FChoice.Foundation.Filters.LogicalFilter)

Reference

OrManyFilter Class
FChoice.Foundation.Filters Namespace


SoundsLikeFilter Class Methods | fcSDK Documentation

SoundsLikeFilter Class Methods

For a list of all members of this type, see SoundsLikeFilter members.

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

SoundsLikeFilter Class
FChoice.Foundation.Filters Namespace


SoundsLikeFilter Class Properties | fcSDK Documentation

SoundsLikeFilter Class Properties

For a list of all members of this type, see SoundsLikeFilter members.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | Value |

Reference

SoundsLikeFilter Class
FChoice.Foundation.Filters Namespace


StartsWithFilter Class Methods | fcSDK Documentation

StartsWithFilter Class Methods

For a list of all members of this type, see StartsWithFilter members.

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

StartsWithFilter Class
FChoice.Foundation.Filters Namespace


StartsWithFilter Class Properties | fcSDK Documentation

StartsWithFilter Class Properties

For a list of all members of this type, see StartsWithFilter members.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | Operator | (Inherited from FChoice.Foundation.Filters.LikeFilter)
Public Property | Value | (Inherited from FChoice.Foundation.Filters.OperationFilter)

Reference

StartsWithFilter Class
FChoice.Foundation.Filters Namespace


TodayFilter Class Methods | fcSDK Documentation

TodayFilter Class Methods

For a list of all members of this type, see TodayFilter members.

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

TodayFilter Class
FChoice.Foundation.Filters Namespace


TodayFilter Class Properties | fcSDK Documentation

TodayFilter Class Properties

For a list of all members of this type, see TodayFilter members.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | IsBetween | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value1 | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value1Present | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value2 | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value2Present | (Inherited from FChoice.Foundation.Filters.BetweenFilter)

Reference

TodayFilter Class
FChoice.Foundation.Filters Namespace


TomorrowFilter Class Methods | fcSDK Documentation

TomorrowFilter Class Methods

For a list of all members of this type, see TomorrowFilter members.

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

TomorrowFilter Class
FChoice.Foundation.Filters Namespace


TomorrowFilter Class Properties | fcSDK Documentation

TomorrowFilter Class Properties

For a list of all members of this type, see TomorrowFilter members.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | IsBetween | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value1 | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value1Present | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value2 | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value2Present | (Inherited from FChoice.Foundation.Filters.BetweenFilter)

Reference

TomorrowFilter Class
FChoice.Foundation.Filters Namespace


WithinDaysFilter Class Methods | fcSDK Documentation

WithinDaysFilter Class Methods

For a list of all members of this type, see WithinDaysFilter members.

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

WithinDaysFilter Class
FChoice.Foundation.Filters Namespace


WithinDaysFilter Class Properties | fcSDK Documentation

WithinDaysFilter Class Properties

For a list of all members of this type, see WithinDaysFilter members.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | IsBetween | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value1 | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value1Present | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value2 | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value2Present | (Inherited from FChoice.Foundation.Filters.BetweenFilter)

Reference

WithinDaysFilter Class
FChoice.Foundation.Filters Namespace


WithinHoursFilter Class Methods | fcSDK Documentation

WithinHoursFilter Class Methods

For a list of all members of this type, see WithinHoursFilter members.

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

WithinHoursFilter Class
FChoice.Foundation.Filters Namespace


WithinHoursFilter Class Properties | fcSDK Documentation

WithinHoursFilter Class Properties

For a list of all members of this type, see WithinHoursFilter members.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | IsBetween | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value1 | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value1Present | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value2 | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value2Present | (Inherited from FChoice.Foundation.Filters.BetweenFilter)

Reference

WithinHoursFilter Class
FChoice.Foundation.Filters Namespace


YesterdayFilter Class Methods | fcSDK Documentation

YesterdayFilter Class Methods

For a list of all members of this type, see YesterdayFilter members.

Public Methods

 | Name | Description
Public Method | Render | (Inherited from FChoice.Foundation.Filters.Filter)
Public Method | ValidateFilter | (Inherited from FChoice.Foundation.Filters.Filter)

Reference

YesterdayFilter Class
FChoice.Foundation.Filters Namespace


YesterdayFilter Class Properties | fcSDK Documentation

YesterdayFilter Class Properties

For a list of all members of this type, see YesterdayFilter members.

Public Properties

 | Name | Description
Public Property | ColumnName | (Inherited from FChoice.Foundation.Filters.ColumnBasedFilter)
Public Property | IsBetween | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value1 | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value1Present | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value2 | (Inherited from FChoice.Foundation.Filters.BetweenFilter)
Public Property | Value2Present | (Inherited from FChoice.Foundation.Filters.BetweenFilter)

Reference

YesterdayFilter Class
FChoice.Foundation.Filters Namespace


FChoice.Foundation.Filters Namespace #### Inheritance Hierarchy | fcSDK Documentation

FChoice.Foundation.Filters Namespace #### Inheritance Hierarchy

Inheritance Hierarchy

System.Object
FChoice.Foundation.Filters.Filter
FChoice.Foundation.Filters.ColumnBasedFilter
FChoice.Foundation.Filters.BetweenFilter
FChoice.Foundation.Filters.OnFilter
FChoice.Foundation.Filters.TodayFilter
FChoice.Foundation.Filters.TomorrowFilter
FChoice.Foundation.Filters.WithinDaysFilter
FChoice.Foundation.Filters.WithinHoursFilter
FChoice.Foundation.Filters.YesterdayFilter
FChoice.Foundation.Filters.IsInFilter
FChoice.Foundation.Filters.IsNullFilter
FChoice.Foundation.Filters.OperationFilter
FChoice.Foundation.Filters.EqualsFilter
FChoice.Foundation.Filters.LessThanFilter
FChoice.Foundation.Filters.BeforeFilter
FChoice.Foundation.Filters.OlderThanDaysFilter
FChoice.Foundation.Filters.OlderThanHoursFilter
FChoice.Foundation.Filters.LessThanOrEqualFilter
FChoice.Foundation.Filters.LikeFilter
FChoice.Foundation.Filters.ContainsFilter
FChoice.Foundation.Filters.EndsWithFilter
FChoice.Foundation.Filters.NotLikeFilter
FChoice.Foundation.Filters.NotContainsFilter
FChoice.Foundation.Filters.NotEndsWithFilter
FChoice.Foundation.Filters.NotStartsWithFilter
FChoice.Foundation.Filters.StartsWithFilter
FChoice.Foundation.Filters.MoreThanFilter
FChoice.Foundation.Filters.AfterFilter
FChoice.Foundation.Filters.MoreThanOrEqualFilter
FChoice.Foundation.Filters.SoundsLikeFilter
FChoice.Foundation.Filters.LogicalFilter
FChoice.Foundation.Filters.AndFilter
FChoice.Foundation.Filters.AndManyFilter
FChoice.Foundation.Filters.OrFilter
FChoice.Foundation.Filters.OrManyFilter
FChoice.Foundation.Filters.FilterExpression
FChoice.Foundation.Filters.FilterType
System.Collections.ObjectModel.Collection
FChoice.Foundation.Filters.FilterCollection

Reference

fcSDK Assembly


FoundationException Class Methods | fcSDK Documentation

FoundationException Class Methods

For a list of all members of this type, see FoundationException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | Sets the SerializationInfo object with the parameter name and additional exception information. (Inherited from FChoice.Common.FCExceptionBase)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)

Reference

FoundationException Class
FChoice.Foundation Namespace


FoundationException Class Properties | fcSDK Documentation

FoundationException Class Properties

For a list of all members of this type, see FoundationException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorCode | Gets the unique error code for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | ErrorMessageID | Gets the message identifier for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)

Reference

FoundationException Class
FChoice.Foundation Namespace


GenericDataRow Class Methods | fcSDK Documentation

GenericDataRow Class Methods

For a list of all members of this type, see GenericDataRow members.

Public Methods

 | Name | Description
Public Method | AcceptChanges | (Inherited from System.Data.DataRow)
static (Shared in Visual Basic) | AreIDsEqual | Used to compare the UniqueIDs of two GenericDataRows.
Public Method | BeginEdit | (Inherited from System.Data.DataRow)
Public Method | CancelEdit | (Inherited from System.Data.DataRow)
Public Method | ClearErrors | (Inherited from System.Data.DataRow)
Public Method | Delete | (Inherited from System.Data.DataRow)
Public Method | EndEdit | (Inherited from System.Data.DataRow)
Public Method | GetChildRows | Overloaded. (Inherited from System.Data.DataRow)
Public Method | GetColumnError | Overloaded. (Inherited from System.Data.DataRow)
Public Method | GetColumnsInError | (Inherited from System.Data.DataRow)
Public Method | GetParentRow | Overloaded. (Inherited from System.Data.DataRow)
Public Method | GetParentRows | Overloaded. (Inherited from System.Data.DataRow)
Public Method | HasVersion | (Inherited from System.Data.DataRow)
Public Method | IsForcedUpdateColumn |
Public Method | IsNull | Overloaded. (Inherited from System.Data.DataRow)
Public Method | RejectChanges | (Inherited from System.Data.DataRow)
Public Method | RelateByID | Relate a unique identifier to this GenericDataRow via a SchemaRelation name.
Public Method | RelateRecord | Relate a given row to this GenericDataRow via a SchemaRelation name.
Public Method | RelateToIntField | Relate a given row's identifier to an Integer field present on this GenericDataRow.
Public Method | SetAdded | (Inherited from System.Data.DataRow)
Public Method | SetColumnError | Overloaded. (Inherited from System.Data.DataRow)
Public Method | SetModified | (Inherited from System.Data.DataRow)
Public Method | SetParentRow | Overloaded. (Inherited from System.Data.DataRow)
Public Method | Unrelate | UnRelate this GenericDataRow from a single row related to it via the given relation name.
Public Method | UnrelateFromAll | UnRelate this GenericDataRow from all other rows related to it via the given relation name.
Public Method | Update | Overloaded. Commits the row to the database. See FCGeneric's Update for details.

Reference

GenericDataRow Class
FChoice.Foundation Namespace


GenericDataRow Class Properties | fcSDK Documentation

GenericDataRow Class Properties

For a list of all members of this type, see GenericDataRow members.

Public Properties

 | Name | Description
Public Property | ForcedUpdateColumns |
Public Property | HasErrors | (Inherited from System.Data.DataRow)
Public Property | IsAddForUpdate | Gets a value indicating whether this GenericDataRow was added via AddForUpdate.
Public Property | IsNew | Gets a value indicating whether the current GenericDataRow was added and not yet committed.
Public Property | Item |
Public Property | ItemArray | (Inherited from System.Data.DataRow)
Public Property | RowError | (Inherited from System.Data.DataRow)
Public Property | RowGuid | Unique row identifier
Public Property | RowState | (Inherited from System.Data.DataRow)
Public Property | Table | (Inherited from System.Data.DataRow)
Public Property | UniqueID | Returns Unique Identifier of this row in the database.

Reference

GenericDataRow Class
FChoice.Foundation Namespace


GenericDataRowCollection Class Methods | fcSDK Documentation

GenericDataRowCollection Class Methods

For a list of all members of this type, see GenericDataRowCollection members.

Public Methods

 | Name | Description
Public Method | Add | Adds the specified GenericDataRow to the collection.
Public Method | Contains | Overloaded. Test if one ore more GenericDataRows are already in the collection.
Public Method | CopyTo | Copies all the elements of the current GenericDataRowCollection to a one-dimensional Array, starting at the specified index.
Public Method | Find | Overloaded. Gets the row containing the specified primary key values.
Public Method | GetEnumerator | Gets an IEnumerator for the collection.

Reference

GenericDataRowCollection Class
FChoice.Foundation Namespace


GenericDataRowCollection Class Properties | fcSDK Documentation

GenericDataRowCollection Class Properties

For a list of all members of this type, see GenericDataRowCollection members.

Public Properties

| | Name | Description | | --- | --- | --- | | Public Property | Count | Gets the total number of elements in a collection. | | Public Property | IsSynchronized | Gets a value indicating whether the GenericDataRowCollection is synchronized. | | Public Property | Item | Gets the row at the specified index.

[C#] In C#, this property is the indexer for the GenericDataRowCollection class.

| | Public Property | SyncRoot | Gets an object that can be used to synchronize the collection. | | Public Property | Table | Reference to the GenericDataTable this collection belongs to. |

Reference

GenericDataRowCollection Class
FChoice.Foundation Namespace


GenericDataSet Class Methods | fcSDK Documentation

GenericDataSet Class Methods

For a list of all members of this type, see GenericDataSet members.

Public Methods

 | Name | Description
Public Method | Query | Overloaded.
Public Method | Update | Overloaded.

Reference

GenericDataSet Class
FChoice.Foundation Namespace


GenericDataSet Class Properties | fcSDK Documentation

GenericDataSet Class Properties

For a list of all members of this type, see GenericDataSet members.

Public Properties

 | Name | Description
Public Property | DataSet |
Public Property | RestrictionGroup |
Public Property | SortGenerics |
Public Property | UniqueID |

Reference

GenericDataSet Class
FChoice.Foundation Namespace


GenericDataTable Class Events | fcSDK Documentation

GenericDataTable Class Events

For a list of all members of this type, see GenericDataTable members.

Public Events

 | Name | Description
Public Event | ColumnChanged | (Inherited from System.Data.DataTable)
Public Event | ColumnChanging | (Inherited from System.Data.DataTable)
Public Event | Disposed | (Inherited from System.ComponentModel.MarshalByValueComponent)
Public Event | Initialized | (Inherited from System.Data.DataTable)
Public Event | RowChanged | (Inherited from System.Data.DataTable)
Public Event | RowChanging | (Inherited from System.Data.DataTable)
Public Event | RowDeleted | (Inherited from System.Data.DataTable)
Public Event | RowDeleting | (Inherited from System.Data.DataTable)
Public Event | TableCleared | (Inherited from System.Data.DataTable)
Public Event | TableClearing | (Inherited from System.Data.DataTable)
Public Event | TableNewRow | (Inherited from System.Data.DataTable)

Reference

GenericDataTable Class
FChoice.Foundation Namespace


GenericDataTable Class Methods | fcSDK Documentation

GenericDataTable Class Methods

For a list of all members of this type, see GenericDataTable members.

Public Methods

 | Name | Description
Public Method | AcceptChanges | (Inherited from System.Data.DataTable)
Public Method | BeginInit | (Inherited from System.Data.DataTable)
Public Method | BeginLoadData | (Inherited from System.Data.DataTable)
Public Method | Clear | (Inherited from System.Data.DataTable)
Public Method | Clone | (Inherited from System.Data.DataTable)
Public Method | Compute | (Inherited from System.Data.DataTable)
Public Method | Copy | (Inherited from System.Data.DataTable)
Public Method | CreateDataReader | (Inherited from System.Data.DataTable)
Public Method | Dispose | (Inherited from System.ComponentModel.MarshalByValueComponent)
Public Method | EndInit | (Inherited from System.Data.DataTable)
Public Method | EndLoadData | (Inherited from System.Data.DataTable)
Public Method | GetChanges() | (Inherited from System.Data.DataTable)
Public Method | GetEnumerator | Returns an enumerator that can iterate through the GenericDataTable.
Public Method | GetErrors | (Inherited from System.Data.DataTable)
Public Method | GetObjectData | (Inherited from System.Data.DataTable)
Public Method | GetService | (Inherited from System.ComponentModel.MarshalByValueComponent)
Public Method | ImportRow | (Inherited from System.Data.DataTable)
Public Method | Load | Overloaded. (Inherited from System.Data.DataTable)
Public Method | LoadDataRow | Overloaded. (Inherited from System.Data.DataTable)
Public Method | Merge | Overloaded. (Inherited from System.Data.DataTable)
Public Method | NewRow | (Inherited from System.Data.DataTable)
Public Method | ReadXml | Overloaded. (Inherited from System.Data.DataTable)
Public Method | ReadXmlSchema | Overloaded. (Inherited from System.Data.DataTable)
Public Method | RejectChanges | (Inherited from System.Data.DataTable)
Public Method | Reset | (Inherited from System.Data.DataTable)
Public Method | Select | Overloaded. (Inherited from System.Data.DataTable)
Public Method | ToString | (Inherited from System.Data.DataTable)
Public Method | WriteXml | Overloaded. (Inherited from System.Data.DataTable)
Public Method | WriteXmlSchema | Overloaded. (Inherited from System.Data.DataTable)

Reference

GenericDataTable Class
FChoice.Foundation Namespace


GenericDataTable Class Properties | fcSDK Documentation

GenericDataTable Class Properties

For a list of all members of this type, see GenericDataTable members.

Public Properties

 | Name | Description
Public Property | CaseSensitive | (Inherited from System.Data.DataTable)
Public Property | ChildRelations | (Inherited from System.Data.DataTable)
Public Property | Columns | (Inherited from System.Data.DataTable)
Public Property | Constraints | (Inherited from System.Data.DataTable)
Public Property | Container | (Inherited from System.ComponentModel.MarshalByValueComponent)
Public Property | Count | Number of GenericDataRows currently in the table.
Public Property | DataSet | (Inherited from System.Data.DataTable)
Public Property | DefaultView | (Inherited from System.Data.DataTable)
Public Property | DesignMode | (Inherited from System.ComponentModel.MarshalByValueComponent)
Public Property | DisplayExpression | (Inherited from System.Data.DataTable)
Public Property | ExtendedProperties | (Inherited from System.Data.DataTable)
Public Property | FCGeneric |
Public Property | HasErrors | (Inherited from System.Data.DataTable)
Public Property | IsInitialized | (Inherited from System.Data.DataTable)
Public Property | IsMtmTable | Is this table an Many To Many mapping table?
Public Property | Item | Returns the row found at the given index.
Public Property | Locale | (Inherited from System.Data.DataTable)
Public Property | MinimumCapacity | (Inherited from System.Data.DataTable)
Public Property | Namespace | (Inherited from System.Data.DataTable)
Public Property | ParentRelations | (Inherited from System.Data.DataTable)
Public Property | Prefix | (Inherited from System.Data.DataTable)
Public Property | PrimaryKey | (Inherited from System.Data.DataTable)
Public Property | RemotingFormat | (Inherited from System.Data.DataTable)
Public Property | Rows |
Public Property | Site | (Inherited from System.Data.DataTable)
Public Property | TableName | (Inherited from System.Data.DataTable)

Reference

GenericDataTable Class
FChoice.Foundation Namespace


GetChanges Method | fcSDK Documentation

GetChanges Method

Overload List

Overload | Description
GetChanges() | (Inherited from System.Data.DataTable)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server family

Reference

GenericDataTable Class
GenericDataTable Members


GenericException Class Methods | fcSDK Documentation

GenericException Class Methods

For a list of all members of this type, see GenericException members.

Public Methods

 | Name | Description
Public Method | GetBaseException | (Inherited from System.Exception)
Public Method | GetObjectData | Sets the SerializationInfo object with the parameter name and additional exception information. (Inherited from FChoice.Common.FCExceptionBase)
Public Method | GetType | (Inherited from System.Exception)
Public Method | ToString | (Inherited from System.Exception)

Reference

GenericException Class
FChoice.Foundation Namespace


GenericException Class Properties | fcSDK Documentation

GenericException Class Properties

For a list of all members of this type, see GenericException members.

Public Properties

 | Name | Description
Public Property | Data | (Inherited from System.Exception)
Public Property | ErrorCode | Gets the unique error code for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | ErrorMessageID | Gets the message identifier for this exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | HelpLink | (Inherited from System.Exception)
Public Property | HResult | (Inherited from System.Exception)
Public Property | InnerException | (Inherited from System.Exception)
Public Property | Message | Gets a message that describes the current exception. (Inherited from FChoice.Common.FCExceptionBase)
Public Property | Source | (Inherited from System.Exception)
Public Property | StackTrace | (Inherited from System.Exception)
Public Property | TargetSite | (Inherited from System.Exception)

Reference

GenericException Class
FChoice.Foundation Namespace


MaximumRowsExceededEventArgs Class Properties | fcSDK Documentation

MaximumRowsExceededEventArgs Class Properties

For a list of all members of this type, see MaximumRowsExceededEventArgs members.

Public Properties

 | Name | Description
Public Property | CancelQuery | When set to true the query will be canceled.
Public Property | RowsToReturn | This value will control the number of rows to be returned from a large query.
Public Property | TotalPossibleRows | Readonly count of rows to be returned by the large query that caused this event.

Reference

MaximumRowsExceededEventArgs Class
FChoice.Foundation Namespace


RelationNameCollection Class Methods | fcSDK Documentation

RelationNameCollection Class Methods

For a list of all members of this type, see RelationNameCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | AddRange | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | Clear | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | Contains | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | CopyTo | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | GetEnumerator | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | IndexOf | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | Insert | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | Remove | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | RemoveAt | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | SetList | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Method | ToString | (Inherited from FChoice.Foundation.ValidatedNameCollection)

Reference

RelationNameCollection Class
FChoice.Foundation Namespace


RelationNameCollection Class Properties | fcSDK Documentation

RelationNameCollection Class Properties

For a list of all members of this type, see RelationNameCollection members.

Public Properties

 | Name | Description
Public Property | Count | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Property | IsFixedSize | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Property | IsReadOnly | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Property | IsSynchronized | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Property | Item | (Inherited from FChoice.Foundation.ValidatedNameCollection)
Public Property | SyncRoot | (Inherited from FChoice.Foundation.ValidatedNameCollection)

Reference

RelationNameCollection Class
FChoice.Foundation Namespace


ISchemaCache Interface Methods | fcSDK Documentation

ISchemaCache Interface Methods

For a list of all members of this type, see ISchemaCache members.

Public Methods

 | Name | Description
Method | GetChangeDateField |
Method | GetDateFields |
Method | GetField |
Method | GetRelation |
Method | GetTableName |
Method | GetTableNumber |
Method | IsChangeField |
Method | IsDateField |
Method | IsFieldSearchable |
Method | IsFieldUnicode |
Method | IsIntegerField |
Method | IsNumericField |
Method | IsRelationExclusive |
Method | IsStringField |
Method | IsStringOrDateField |
Method | IsValidField |
Method | IsValidRelation |
Method | IsValidTable |
Method | IsValidTableOrView |
Method | IsValidView |

Reference

ISchemaCache Interface
FChoice.Foundation.Schema Namespace


ISchemaCache Interface Properties | fcSDK Documentation

ISchemaCache Interface Properties

For a list of all members of this type, see ISchemaCache members.

Public Properties

 | Name | Description
Property | IsDatabaseUnicode |
Property | RestrictionGroups |
Property | Tables |
Property | Views |

Reference

ISchemaCache Interface
FChoice.Foundation.Schema Namespace


ISchemaField Interface Methods | fcSDK Documentation

ISchemaField Interface Methods

For a list of all members of this type, see ISchemaField members.

Public Methods

 | Name | Description
Method | IsDate |
Method | IsInteger |
Method | IsNumeric |
Method | IsString |

Reference

ISchemaField Interface
FChoice.Foundation.Schema Namespace


ISchemaField Interface Properties | fcSDK Documentation

ISchemaField Interface Properties

For a list of all members of this type, see ISchemaField members.

Public Properties

 | Name | Description
Property | CommonType |
Property | DatabaseType |
Property | DataType |
Property | Default |
Property | DefaultString |
Property | Description |
Property | Flags |
Property | IsSearchable |
Property | IsUnicode |
Property | Length |
Property | Name |
Property | Rank |

Reference

ISchemaField Interface
FChoice.Foundation.Schema Namespace


ISchemaFieldCollection Interface Properties | fcSDK Documentation

ISchemaFieldCollection Interface Properties

For a list of all members of this type, see ISchemaFieldCollection members.

Public Properties

 | Name | Description
Property | Item | Overloaded.

Reference

ISchemaFieldCollection Interface
FChoice.Foundation.Schema Namespace


ISchemaRelation Interface Properties | fcSDK Documentation

ISchemaRelation Interface Properties

For a list of all members of this type, see ISchemaRelation members.

Public Properties

 | Name | Description
Property | Cardinality |
Property | ChildTable |
Property | Description |
Property | ExclusiveObjectIDField |
Property | ExclusiveTableField |
Property | Flags |
Property | InverseRelation |
Property | IsExclusive |
Property | IsMandatory |
Property | IsMtm |
Property | MandatoryObjectID |
Property | MtmTableName |
Property | Name |
Property | ObjectID |
Property | ParentTable |
Property | Rank |
Property | SourceTable |
Property | TargetTable |

Reference

ISchemaRelation Interface
FChoice.Foundation.Schema Namespace


ISchemaRelationCollection Interface Properties | fcSDK Documentation

ISchemaRelationCollection Interface Properties

For a list of all members of this type, see ISchemaRelationCollection members.

Public Properties

 | Name | Description
Property | Item |

Reference

ISchemaRelationCollection Interface
FChoice.Foundation.Schema Namespace


ISchemaTable Interface Properties | fcSDK Documentation

ISchemaTable Interface Properties

For a list of all members of this type, see ISchemaTable members.

Public Properties

 | Name | Description
Property | Relationships |
Property | Views |

Reference

ISchemaTable Interface
FChoice.Foundation.Schema Namespace


ISchemaTableBase Interface Properties | fcSDK Documentation

ISchemaTableBase Interface Properties

For a list of all members of this type, see ISchemaTableBase members.

Public Properties

 | Name | Description
Property | Description |
Property | Fields |
Property | Flags |
Property | IsDataRestricted |
Property | Name |
Property | Number |
Property | ObjectID |
Property | Subsystem |

Reference

ISchemaTableBase Interface
FChoice.Foundation.Schema Namespace


ISchemaTableCollection Interface Methods | fcSDK Documentation

ISchemaTableCollection Interface Methods

For a list of all members of this type, see ISchemaTableCollection members.

Public Methods

 | Name | Description
Method | GetByNumber |

Reference

ISchemaTableCollection Interface
FChoice.Foundation.Schema Namespace


ISchemaTableCollection Interface Properties | fcSDK Documentation

ISchemaTableCollection Interface Properties

For a list of all members of this type, see ISchemaTableCollection members.

Public Properties

 | Name | Description
Property | Item | Overloaded.

Reference

ISchemaTableCollection Interface
FChoice.Foundation.Schema Namespace


ISchemaView Interface Properties | fcSDK Documentation

ISchemaView Interface Properties

For a list of all members of this type, see ISchemaView members.

Public Properties

 | Name | Description
Property | Joins |

Reference

ISchemaView Interface
FChoice.Foundation.Schema Namespace


ISchemaViewCollection Interface Methods | fcSDK Documentation

ISchemaViewCollection Interface Methods

For a list of all members of this type, see ISchemaViewCollection members.

Public Methods

 | Name | Description
Method | GetByNumber |

Reference

ISchemaViewCollection Interface
FChoice.Foundation.Schema Namespace


ISchemaViewCollection Interface Properties | fcSDK Documentation

ISchemaViewCollection Interface Properties

For a list of all members of this type, see ISchemaViewCollection members.

Public Properties

 | Name | Description
Property | Item | Overloaded.

Reference

ISchemaViewCollection Interface
FChoice.Foundation.Schema Namespace


ISchemaViewJoin Interface Properties | fcSDK Documentation

ISchemaViewJoin Interface Properties

For a list of all members of this type, see ISchemaViewJoin members.

Public Properties

 | Name | Description
Property | Description |
Property | Flags |
Property | IsPrimaryOuter |
Property | IsSecondaryOuter |
Property | PrimaryAlias |
Property | PrimaryTable |
Property | SecondaryAlias |
Property | SecondaryTable |

Reference

ISchemaViewJoin Interface
FChoice.Foundation.Schema Namespace


FChoice.Foundation.Schema Namespace #### Inheritance Hierarchy | fcSDK Documentation

FChoice.Foundation.Schema Namespace #### Inheritance Hierarchy

Inheritance Hierarchy

System.Object

Reference

fcSDK Assembly


ValidatedNameCollection Class Methods | fcSDK Documentation

ValidatedNameCollection Class Methods

For a list of all members of this type, see ValidatedNameCollection members.

Public Methods

 | Name | Description
Public Method | Add |
Public Method | AddRange |
Public Method | Clear |
Public Method | Contains |
Public Method | CopyTo |
Public Method | GetEnumerator |
Public Method | IndexOf |
Public Method | Insert |
Public Method | Remove |
Public Method | RemoveAt |
Public Method | SetList |
Public Method | ToString |

Reference

ValidatedNameCollection Class
FChoice.Foundation Namespace


ValidatedNameCollection Class Properties | fcSDK Documentation

ValidatedNameCollection Class Properties

For a list of all members of this type, see ValidatedNameCollection members.

Public Properties

 | Name | Description
Public Property | Count |
Public Property | IsFixedSize |
Public Property | IsReadOnly |
Public Property | IsSynchronized |
Public Property | Item |
Public Property | SyncRoot |

Reference

ValidatedNameCollection Class
FChoice.Foundation Namespace


FChoice.Foundation Namespace #### Inheritance Hierarchy | fcSDK Documentation

FChoice.Foundation Namespace #### Inheritance Hierarchy

Inheritance Hierarchy

System.Object
FChoice.Foundation.CacheBase FChoice.Foundation.Clarify.ClarifyCacheBase
FChoice.Foundation.Clarify.ConfigItemCache
FChoice.Foundation.Clarify.ListCache
FChoice.Foundation.Clarify.LocaleCache
FChoice.Foundation.Clarify.SchemaCache
FChoice.Foundation.Clarify.StringCache
FChoice.Foundation.CustomCache
FChoice.Foundation.CacheManager
FChoice.Foundation.CacheSectionHandler
FChoice.Foundation.DictionaryExtensions
FChoice.Foundation.FCApplication
FChoice.Foundation.Clarify.ClarifyApplication
FChoice.Foundation.FCGeneric
FChoice.Foundation.Clarify.ClarifyGeneric
FChoice.Foundation.FCSession
FChoice.Foundation.Clarify.ClarifySession
FChoice.Foundation.FCSessionData
FChoice.Foundation.Clarify.ClarifySessionData
FChoice.Foundation.FCSessionSummary
FChoice.Foundation.GenericDataRowCollection
FChoice.Foundation.Clarify.ClarifyRowCollection
FChoice.Foundation.GenericDataSet
FChoice.Foundation.Clarify.ClarifyDataSet
FChoice.Foundation.MaximumRowsExceededEventArgs
FChoice.Foundation.ValidatedNameCollection
FChoice.Foundation.DataFieldNameCollection
FChoice.Foundation.RelationNameCollection
System.ComponentModel.MarshalByValueComponent
System.Data.DataTable
FChoice.Foundation.GenericDataTable
FChoice.Foundation.Clarify.ClarifyDataTable
System.Data.DataRow
FChoice.Foundation.GenericDataRow
FChoice.Foundation.Clarify.ClarifyDataRow
System.Exception
System.ApplicationException
FChoice.Common.FCExceptionBase
FChoice.Foundation.FoundationException
FChoice.Foundation.FCInvalidLoginException
FChoice.Foundation.GenericException
FChoice.Foundation.Clarify.ClarifyGenericException

Reference

fcSDK Assembly


API Reference | fcSDK Documentation

API Reference

Back to top © 2022 Dovetail Software, Inc. - All rights reserved.
Clarify, Amdocs, and related products and names are copyright and trademark of Amdocs, Inc.
.NET, Visual Studio.NET, C#, Visual Basic and related products are trademark of Microsoft corporation.


COM Compatibility API Reference | fcSDK Documentation

COM Compatibility API Reference

Back to top © 2022 Dovetail Software, Inc. - All rights reserved.
Clarify, Amdocs, and related products and names are copyright and trademark of Amdocs, Inc.
.NET, Visual Studio.NET, C#, Visual Basic and related products are trademark of Microsoft corporation.


part_transfer | fcSDK Documentation

part_transfer

Public Function part_transfer(ByVal part_num As String, _
                              ByVal mod_level As String, ByVal domain_name As String, _
                              ByVal quantity_num As Long, ByVal serial_num As String, _
                              ByVal from_loc As String, ByVal from_bin As String, _
                              ByVal from_cont As String, ByVal from_good As Boolean, _
                              ByVal to_loc As String, ByVal to_bin As String, _
                              ByVal to_cont As String, ByVal to_good As Boolean, _
                              ByVal user_name As String, ByVal trans_date As String, _
                              ByVal ref_id As String, ByVal note_str As String, _
                              ByVal gen_time_bombs As Boolean, ByVal fifo_flag As Integer, _
                              ByVal update_cost As String, ByVal update_source As String, _
                              ByVal trans_id As String, ByVal std_cost As String) As Integer

Description

This is the FCFL version of the part transfer API. This API emulates the Clarify part transfer mechanism. The part/revision/domain are specified (the part to be transferred). Also specified are the from location/bin and the to location/bin. The quantity and serial number of the parts to be transferred are specified, as are some additional information (reference ID, transfer date, and notes).

As in Clarify, the transfer can be from good or bad stock and can be to good or bad stock. Also, time bombs (for escalation/notification) can be specified, or not.

The API supports containers. If you are transferring into or out of a container, put the container name in the bin name field, and the container number in the cont_num field. If you are not using containers, leave the container number fields blank.

The API supports a primary bin recommendataion. If you have set up a primary bin recommendation, you can set the bin name to: PRIM_BIN_REC, and the API will fill in the proper bin.

The FIFO flag has three possible values:

0 - No FIFO costing used

1 - FIFO costing is used

2 - Use the cost specified in the update_cost field

The update cost field is the cost per unit of the transfer, and is used in two cases: 1) if the preceding field is set to 2, this is the cost of the transfer. 2) If the flag is set = 1, then this is the cost of the transfer, and FIFO records will be created. This is only valid for transfers from Expense GL accounts.

The update source is also used only when the flag = 1 and it is a transfer in from an expense GL. In this case, the update source is the source placed in the FIFO costing record.

Note: If you are transferring (in from an expense GL) using FIFO costs, and don't wish to create a new FIFO record (but rather wish to increment the most recent FIFO record), just leave the update_cost field blank ("").

The final two arguments are output arguments that return the transaction ID of the part transfer, and the standard cost (total) for the transfer.

The API also checks part authorization levels for auto-replenishment, and will automatically work with that engine.

Adding to an existing part transfer:

The part transfer API now has the ability to increase the number of units in a previously transacted part transfer. For example, suppose that a part transfer of 5 units has been made. The transaction ID is '42'. But you realize after the fact that the transfer really was for 8 units. You can create a new part transfer, or, using this feature, you can "fix" the previous part transfer.

To do this, specify (in the trans_id argument), the transaction ID of the previous part transfer. In the quantity field, specify how many units to add to the transfer. The fifo_flag, update_cost, update_source, and gen_time_bomb parameters are also used for the additional units. All other arguments are ignored. The from/to locations and bins, as well as the part number/mod_level are determined from the existing part transfer.

Note: This new feature only works with transfers of quantity tracked parts.

Parameters

Parameter Name | Required? | Description
part_num | Yes | The part number transferred
mod_level | Yes | Revision of the part
domain_name | Yes | The domain of the part
quantity_num | Yes | How many to transfer
serial_num | No | The serial number (if serial tracked) to transfer
from_loc | Yes | The inventory location (or GL account) to transfer from
from_bin | No | The inventory bin to transfer from. If from a container, put the container name in this field. If you want the primary bin suggestion, put PRIM_BIN_REC in this field
from_cont | No | If transferring from a container, put the container number in this field
from_good | Yes | Is the transfer from "good" stock?
to_loc | Yes | The inventory location (or GL account) to transfer to
to_bin | No | The inventory bin to trans to. If to a container, put the container name in this field. If you want the primary bin suggestion, put PRIM_BIN_REC in this field.
to_cont | No | If transferring to a container, put the container number in this field
to_good | Yes | Is the transfer to "good" stock?
user_name | No | Who performed the transfer. If blank, current user is used
trans_date | No | When was transfer performed? If blank, current time is used
ref_id | No | Optional reference ID of transfer
note_str | No | Optional notes about the transfer
gen_time_bombs | Yes | Should time bombs be generated?
fifo_flag | Yes | Should we use FIFO costing? 0 = No, 1 = Yes, 2 = Use the cost in the next field.
update_cost | No | If the fifo_flag = 2, this is the per-unit cost for the transfer. Not commonly used. If the fifo_flag = 1, it is the FIFO cost of the transfer (only valid for transfer in from expense GL).
update_source | No | If the fifo_flag = 1, and this is a transfer in from an expense GL with an update cost specified, this is the source of the FIFO parts.
trans_id | Yes | Output argument with the transaction ID of the part transfer
std_cost | Yes | Output argument with the standard cost of the part transfer

Returns

Value | Meaning
0 | No errors
-1 | To location/bin and from location/bin cannot be the same
-2 | Cannot transfer quantities < 1
-3 | Cannot transfer quantities > 1 if a serial number is specified
-4 | Cannot locate the specified part number
-5 | Part is serial-tracked, but no serial number was specified
-6 | No part revision record found for specified revision
-7 | Cannot find the "from" location
-8 | Cannot find the "from" bin
-9 | Cannot find the "to" location
-10 | Cannot find the "to" bin
-11 | Cannot find the specified user
-12 | The from container is sealed
-13 | The to container is sealed
-14 | No primary bin can be found for the from location
-15 | No primary bin can be found for the to location
-20 | Serial number is found in inventory, but not at the "from" location/bin
-21 | The serialized part cannot be found at the specified from location and the from location is not a GL account that allows a part to be created.
-22 | Cannot find the activity string for TRANSFER with rank = 12300
-23 | Supplied update cost is not numeric
-24 | There are not enough FIFO units available to perform the transfer
-25 | For transfers into inventory (from expense GL), there are no FIFO records available to increment the count
-26 | The serialized transfer is from good/bad stock, but the inventory part is marked as the opposite (bad/good). For example, the transfer is from bad stock, but the part is marked as good.
-27 | The employee record for the specified user cannot be found
-28 | The Part Instance Detail for part '' with serial number '' cannot be found.
-40 | Invalid value for fifo_flag specified.
-41 | You are attempting to add units to an existing part transfer, but the part transfer is for a serialized part
-42 | You are attempting to add units to an existing part transfer, but the supplied transaction ID is not found
ret_string | Output - Returns the transaction id of the part transfer record
ret_num | Output - Returns the standard cost of the transferred part
ret_objid | Output - Returns the objid of the part transfer record

Examples

Transfer 20 units of Accounting 101 from an expense GL account to the primary bin in Austin. All stock is good. Use FIFO costing.

Visual Basic:

Dim ret_int As Integer
Dim trans_id  As String
Dim std_cost  As String

ret_int = fccl.part_transfer("Accounting", "101", "QuantityDomain", 20, _
                  "", "EXPGL", "", "", True, "Austin", _
                  "PRIM_BIN_REC", "", True, "", "", "", "", _
                  True, 1, "", "", "", "")

trans_id = fccl.ret_string
std_cost = CStr(fccl.ret_num)

JavaScript:

var ret_int = fccl.part_transfer("Accounting", "101", "QuantityDomain", 20,
                       "", "EXPGL", "", "", True, "Austin",
                       "PRIM_BIN_REC", "", True, "", "", "", "",
                       True, 1, "", "", "", "");

Transfer MS Word 7.0, serial number 555666 from Austin Bin 2 to San Jose Bin "Receiving". The inventory was good, but is now marked as bad (for Quality Control). Fred did the transfer on July 30th at 5:13 AM. Add notes and a ref ID, and don't generate a time bomb. Don't use FIFO costing.

Visual Basic:

Dim ret_int As Integer
Dim trans_id  As String
Dim std_cost  As String

ret_int = fccl.part_transfer("MS Word", "7.0", "Product", 1, "555666", _
                        "Austin", "Bin 1", "", True, "San Jose", _
                        "Receiving", "", False, "fred", "7/30/2001 5:13:00", _
                        "Ref ID3", "Some notes", False, 0, "", "", "", "")

trans_id = fccl.ret_string
std_cost = CStr(fccl.ret_num)

JavaScript:

var ret_int = fccl.part_transfer("MS Word", "7.0", "Product", 1, "555666",
                        "Austin", "Bin 1", "", True, "San Jose",
                        "Receiving", "", False, "fred", "7/30/2001 5:13:00",
                        "Ref ID3", "Some notes", False, 0, "", "", "", "");

Transfer 15 units of the Notebook part from expense GL 'EXPGL' to Austin Container 44 (name of Fred). The inventory was good, but is now marked as bad (for Quality Control). Fred did the transfer on July 30th at 5:13 AM. Add notes and a ref ID, and don't generate a time bomb. Use FIFO costing, and specify the cost and source.

Visual Basic:

Dim ret_int As Integer
Dim trans_id  As String
Dim std_cost  As String

ret_int = fccl.part_transfer("Notebook", "", "Product", 15, "", _
                        "EXPGL", "", "", True, "Austin", "Fred", "44", _
                        False, "fred", "7/30/2001 5:13:00", "Ref ID3", _
                        "Some notes", False, 1, ".34", "MySource", "", "")

trans_id = fccl.ret_string
std_cost = CStr(fccl.ret_num)

JavaScript:

var ret_int = fccl.part_transfer("Notebook", "", "Product", 15, "",
                    "EXPGL", "", "", True, "Austin", "Fred", "44",
                    False, "fred", "7/30/2001 5:13:00", "Ref ID3",
                    "Some notes", False, 1, ".34", "MySource", "", "");

Add 4 units to part transfer '42'. Generate a time bomb, and use FIFO costing.

Visual Basic:

Dim ret_int As Integer
Dim trans_id  As String
Dim std_cost  As String

trans_id = "42"

ret_int = fccl.part_transfer("", "", "", 4, "", "", "", "", True, "", "", "", _
                        True, "", "", "", "", True, 1, "", "", trans_id, "")

trans_id = fccl.ret_string
std_cost = CStr(fccl.ret_num)

JavaScript:

var ret_int = fccl.part_transfer("", "", "", 4, "", "", "", "", true,
            "", "", "", true, "", "", "", "", true, 1, "", "", trans_id, "");


create_case_objid | fcSDK Documentation

create_case_objid

create_case_objid_list

Public Function create_case_objid(ByVal site_id As String, _
                ByVal f_name As String, ByVal l_name As String, _
                ByVal phone_num As String, ByVal part_num As String, _
                ByVal mod_level As String, ByVal domain_name As String, _
                ByVal serial_no As String, ByVal sp_objid As Long, _
                ByVal contract_id As String, ByVal the_title As String, _
                ByVal case_type As String, ByVal priority_str As String, _
                ByVal severity_str As String, ByVal status_str As String, _
                ByVal phone_log As String, ByVal queue_name As String, _
                ByVal cr_date As String, ByVal phone_end_date As String, _
                ByVal user_name As String, ByVal gen_time_bombs As Boolean, _
                ByVal contact_objid As Integer, ByVal site_objid As Integer,_
                ByVal ml_objid As Integer, ByVal contract_objid As Integer, 				          ByVal addr_objid As Integer,_
                ByVal int_fld1 As String, ByVal int_val1 As Long, _
                ByVal int_fld2 As String, ByVal int_val2 As Long, _
                Byval str_fld1 As String, ByVal str_val1 As String, _
                ByVal str_fld2 As String, ByVal str_val2 As String, _
                ByVal date_fld1 As String, ByVal date_val1 As String) As Integer

Public Function create_case_objid_list(ByVal site_id As String, _
                ByVal f_name As String, ByVal l_name As String, _
                ByVal phone_num As String, ByVal part_num As String, _
                ByVal mod_level As String, ByVal domain_name As String, _
                ByVal serial_no As String, ByVal sp_objid As Long, _
                ByVal contract_id As String, ByVal the_title As String, _
                ByVal case_type As String, ByVal priority_str As String, _
                ByVal severity_str As String, ByVal status_str As String, _
                ByVal phone_log As String, ByVal queue_name As String, _
                ByVal cr_date As String, ByVal phone_end_date As String, _
                ByVal user_name As String, ByVal gen_time_bombs As Boolean, _
                ByVal contact_objid As Integer, ByVal site_objid As Integer,_
                ByVal ml_objid As Integer, ByVal contract_objid As Integer, 				          ByVal addr_objid As Integer,_
                Optional fld_list As Variant, Optional type_list As Variant, _
                Optional val_list As Variant) As Integer

Description

These APIs are used to create new cases. These _objid versions of the create_case APIs allow the objids for contact, site, address, mod_level, and contract to be specified. This allows for improved performance, as the API does have to query to verify this data. However, because the API doesn't validate these objids, it assumes they are correct, so it is important that the caller be sure they are passing in valid objids. Other than that, these APIs function the same was as the create_case APIs.

If successful, these APIs return both the objid and the id_number of the newly-created case. They are returned in the FCCS object variables ret_objid and ret_id_num.

Parameters

Parameter Name | Required? | Description
site_id | Yes | Which site reported the case
first | Yes | First name of contact calling in the case
last | Yes | Last name of contact calling in the case
phone | Yes | Phone number of contact calling in the case
part_num | No | Part number of case part or site_part
mod_level | No | Revision of case part or site_part. If the revision is NULL (Oracle only), still use the empty string ("") to query
domain | No | Domain of case part or site_part
serial_no | No | Serial number of the site_part for the case (if there is one)
sp_objid | No | Objid of site_part for the case (if externally queried)
contract | No | ID of the contract for the case. If left blank, there is no contract
the_title | No | Title for the case. It is suggested that you always have a title
case_type | No | Case type for the case. If left blank, default value is used
priority | No | Priority for the case. If left blank, default value is used
severity | No | Severity for the case. If left blank, default value is used
status | No | Initial status for the case. If left blank, default status is used
phone_log | No | Phone notes for the case
queue_name | No | Name of the queue to dispatch the case to. If left blank, the case is not initially dispatched
cr_date | No | Case creation date. If left blank, current date/time is used
phone_end_date | No | If there is a phone log, this is the date/time that the call ended. If left blank, the case creation time is used
user_name | No | The user who created the case. If left blank, the current user performs the create
gen_time_bombs | Yes | Should a time_bomb be generated (for notifications/business rules). and prior warning time?
contact_objid | No | Objid for the contact
site_objid | No | Objid for the site
ml_objid | No | Objid for the mod_level (part revision)
contract_objid | No | Objid for the contract
addr_objid | No | Objid for the address
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | Cannot find the specified site
-2 | Cannot find the specified contact
-3 | Cannot find the specified part number
-4 | The mod_level is not valid for the specified part
-5 | The serial number specified is not valid for the part/mod_level
-6 | The specified site_part is at another site
-7 | The specified site_part is not found
-10 | The phone log end time is prior to the case creation time
-11 | The phone log text file is not found
-12 | The specified user is not found
-13 | The specified case type is not found
-14 | The specified priority is not found
-15 | The specified severity is not found
-16 | The specified status is not found
-17 | The CREATE activity string is not found
-18 | The PHONE LOG activity string is not found
-19 | The DISPATCH activity string is not found
-20 | The specified Phone Log action type string is not found
-21 | Cannot find a primary address for the specified site
-22 | The specified contract is not found
-23 | The specified queue is not found
-25 | Could not locate an employee record for the specified user

JavaScript Example

Create a new case, specifying the contact and site objid.

var site_id = '';
var first = '';
var last = '';
var phone = '';
var part_num = '';
var mod_level = '';
var domain = '';
var serial_no = '';
var sp_objid = 0;
var contract_id = '';
var title = 'Something interesting goes here';
var case_type = '';
var priority = '';
var severity = '';
var status = '';
var phone_log = '';
var queue = '';
var create_date = '';
var phone_end_date = '';
var user_name = '';
var gen_time_bombs = true;
var contact_objid = 268435499;
var site_objid = 269657432;
var ml_objid = 0;
var contract_objid = 0;
var addr_objid = 0;

var ret_int = fccs.create_case_objid_list(first,last,phone,sp_objid,title, case_type,priority,severity,status,phone_log, queue,create_date,phone_end_date,user_name,gen_time_bombs, contact_objid,site_objid,ml_objid,contract_objid,addr_objid, fld_list,type_list,val_list);


install_sp | fcSDK Documentation

install_sp

install_sp_list

Public Function install_sp(ByVal site_id As String, _
                           ByVal part_num As String, _
                           ByVal mod_level As String, _
                           ByVal domain As String, _
                           ByVal quantity As Long, _
                           ByVal serial_num As String, _
                           ByVal parent_bin_objid As Long, _
                           ByVal parent_sp_objid As Long, _
                           ByVal instance_name As String, _
                           ByVal comment As String, _
                           ByVal part_status As String, _
                           ByVal invoice_no As String, _
                           ByVal user_name As String, _
                           ByVal install_date As String, _
                           ByVal ship_date As String, _
                           ByVal add_activity As Boolean, _
                           ByVal int_fld1 As String, _
                           ByVal int_val1 As Long, _
                           ByVal int_fld2 As String, _
                           ByVal int_val2 As Long, _
                           ByVal str_fld1 As String, _
                           ByVal str_val1 As String, _
                           ByVal str_fld2 As String, _
                           ByVal str_val2 As String, _
                           ByVal date_fld1 As String, _
                           ByVal date_val1 As Long) As Integer

Public Function install_sp_list(ByVal site_id As String, _
                                ByVal part_num As String, _
                                ByVal mod_level As String, _
                                ByVal domain As String, _
                                ByVal quantity As Long, _
                                ByVal serial_num As String, _
                                ByVal parent_bin_objid As Long, _
                                ByVal parent_sp_objid As Long, _
                                ByVal instance_name As String, _
                                ByVal comment As String, _
                                ByVal part_status As String, _
                                ByVal invoice_no As String, _
                                ByVal user_name As String, _
                                ByVal install_date As String, _
                                ByVal ship_date As String, _
                                ByVal add_activity As Boolean, _
                                Optional fld_list As Variant, _
                                Optional type_list As Variant, _
                                Optional val_list As Variant) As Integer

Description

These APIs install site_parts in Clarify. They are very sophisticated and allow virtually any type of install. You must specify a site where the site_part is to be installed, along with the part number, revision and domain for the part. The quantity must be specified. For serial number parts, the serial number is also specified. The part can be installed at the top level of the site, under another site_part or in a bin. An optional instance_name can be specified, as well as the status of the part, a comment, the invoice number, and the install/ship dates. You may determine if activity logs should be added (to the site and to the site_part), and the objid of the top site_part created will be returned.

If the part revision to be installed has a bill of materials (BOM), that BOM will also be installed at the site under the new site_part. If the sub-parts are serial tracked, the APIs will generate the proper new serial numbers for the sub-parts. If the part to be installed is serialized, and the quantity is > 1, the API will generate individual parts for you (sub-parts only).

Other data (such as the warranty end date) is automatically calculated and filled in by the API.

Parameters

Parameter Name | Required? | Description
site_id | Yes | Where to install the site_part
part_num | Yes | The part number to install
mod_level | Yes | The revision of the part
domain | Yes | The domain of the part
quantity | Yes | How many to install
serial_num | No | The serial number of the part to install
parent_bin_objid | No | The objid of the bin to install under. If no bin is to be used, set to 0
parent_sp_objid | No | The objid of the site_part to install under. If this is under a bin, or it is a top-level part, set this argument = 0
instance_name | No | The instance name for the site_part. If this is left blank, the instance_name is generated for you by the API
comment | No | Comment for the site_part
part_status | No | Value from the dropdown list. If left blank, the default value is used
invoice_no | No | The optional invoice number
user_name | No | Who performed the install. If left blank the current user does the install
install_date | No | When was the site_part installed? If blank, current time is used
ship_date | No | When was the site_part shipped? If blank, current time is used
add_activity | Yes | Should activity log entries be generated?
int_fld1, int_fld2 str_fld1, str_fld2 date_fld1 | No | Names of additional fields to write
int_val1, int_val2 str_val1, str_val2 date_val1 | No | Values for the additional fields. These values are only used if the corresponding field name field is filled with a valid field name
fld_list | Yes | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | Yes | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | Yes | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | The specified site_id is not found
-2 | Part number cannot be found from supplied part_num and domain
-3 | The specified part revision (mod_level) does not exist
-4 | The specified user cannot be found
-5 | Cannot find activity string for "Install" rank equal to 3600
-6 | The parent bin specified does not exist
-7 | The parent site_part specified does not exist
-8 | The part_status supplied is not in the dropdown list
-9 | Both a parent bin and a parent site_part were specified. Cannot install under both
-10 | Positive quantity to install not supplied
-11 | A serial number was supplied, and a quantity > 1
-12 | The part is serialized, and a quantity > 1 was given
-13 | This part may only be installed within another part
-14 | This part may only be installed at the site or in a bin
-15 | The domain rules for this part specify no serial number, but a serial number was supplied
-16 | This part has unique serialization (from the domain) that would be violated by the install
-17 | This part is not able to be installed at a site or under another part
-18 | This part may only be installed within another part of specific domain
ret_objid | Output - Returns the objid of the site part

Examples

Install an MS Word 7.0 at the top-level of site "1234". Install it with serial number "xyzzy", and generate activity logs. Install with status "Installed/Good".

Visual Basic:

Dim ret_int As Integer
Dim sp_objid   As Long

ret_int = fcinter.install_sp("1234", "MS Word", "7.0", "Product", 1, "xyzzy", _
     0, 0, "", "", "Installed/Good", "", "", "", "", true)

If ret_int = 0 Then
  sp_objid = fcinter.ret_objid
End If

JavaScript:

var ret_int = fcinter.install_sp("1234", "MS Word", "7.0", "Product", 1,
          "xyzzy", 0, 0, "", "", "Installed/Good", "", "", "", "", true);

if (ret_int == 0){ var sp_objid = fcinter.ret_objid; }

Joe installs a quantity tracked part (30 of them) in a bin at site "444". It was shipped on February 1, and installed a month later. Don't add activity logs. Set two other fields.

Visual Basic:

Dim ret_int As Integer

ret_int = fcinter.install_sp("444", "QuantPart", "", "Quantity", _
            30, "", 268435457, 0, "", "", "", "", "", "3/1/98", _
            "2/1/98", true, "x_my_long", 22, "", 0, _
            "x_my_str_field", "Hello!!", "", "", "","")

JavaScript:

var ret_int = fcinter.install_sp("444", "QuantPart", "", "Quantity",
                30, "", 268435457, 0, "", "", "", "", "", "3/1/98",
                "2/1/98", true, "x_my_long", 22, "", 0,
                "x_my_str_field", "Hello!!", "", "", "","");


modify_sp | fcSDK Documentation

modify_sp

modify_sp_list

Public Function modify_sp(ByVal sp_objid As Long, _
                        ByVal instance_name As String, _
                        ByVal serial_num As String, _
                        ByVal invoice_no As String, _
                        ByVal ship_date As String, _
                        ByVal install_date As String, _
                        ByVal warranty_date As String, _
                        ByVal quantity As Long, _
                        ByVal part_status As String, _
                        ByVal comments As String, _
                        ByVal service_end_dt As String, _
                        ByVal user_name As String, _
                        ByVal mod_level As String, _
                        ByVal add_activity As Boolean, _
                        ByVal int_fld1 As String, _
                        ByVal int_val1 As Long, _
                        ByVal int_fld2 As String, _
                        ByVal int_val2 As Long, _
                        ByVal str_fld1 As String, _
                        ByVal str_val1 As String, _
                        ByVal str_fld2 As String, _
                        ByVal str_val2 As String, _
                        ByVal date_fld1 As String, _
                        ByVal date_val1 As Long) As Integer

Public Function modify_sp_list(ByVal sp_objid As Long, _
             ByVal instance_name As String, _
             ByVal serial_num As String, _
             ByVal invoice_no As String, _
             ByVal ship_date As String, _
             ByVal install_date As String, _
             ByVal warranty_date As String, _
             ByVal quantity As Long, _
             ByVal part_status As String, _
             ByVal comments As String, _
             ByVal service_end_dt As String, _
             ByVal user_name As String, _
             ByVal mod_level As String, _
             ByVal add_activity As Boolean, _
             Optional fld_list As Variant, _
             Optional type_list As Variant, _
             Optional val_list As Variant) As Integer

Description

This API will modify site_parts in Clarify. They allow many site_part fields to be modified. You must specify the site_part to be modified. The quantity must be specified, either as 1 or more. Most of the other fields can be modified as needed, but the site, part, and mod_level can not be changed. You may determine if activity logs should be added (to the site and to the site_part). If a parameter is left blank, no change is made for that field.

Parameters

Parameter Name | Required? | Description
sp_objid | Yes | The site_part to be modified
instance_name | No | The instance name for the site_part. If blank, no change is made. If "#default" is used , the instance_name is generated for you by the API. If "#clear" is specified, the instance name is cleared
serial_num | No | A new serial number. If blank, make no change. If "#clear" is specified, the serial number is cleared
invoice_no | No | A new invoice number. If blank, no change is made. If "#clear" is specified, the field is cleared
ship_date | No | When was the site_part shipped? If blank, no change is made
install_date | No | When was the site_part installed? If blank, no change is made
warranty_date | No | When does the site_part warranty coverage expire? If blank, no change is made
quantity | No | A new installed quantity, must be 0 or more. If set to 0, no change is made in the quantity
part_status | No | New value from the dropdown list. If blank, no change is made. If "#default", the default value of the list is set
comments | No | Comment for the site_part. If blank, no change is made. If set to "#clear", the field is cleared
service_end_dt | No | When does the site_part service period end? If blank, no change is made
user_name | No | User who performed the install. If blank, current user is used
mod_level | No | The new revision of the site_part. This must be a valid mod_level of the part number for the site_part. If blank, no change is made
add_activity | Yes | Should activity log entries be generated for modification?
fld_list | No | List of additional field names to write. List must be present, but does not need to have any items in the list
type_list | No | List of additional field data types to write. List must be present, but does not need to have any items in the list
val_list | No | List of additional field values to write. List must be present, but does not need to have any items in the list

Returns

Value | Meaning
0 | No errors
-1 | No Site Part Specified
-2 | Invalid Part Status Specified
-3 | Site Part Specified not in database
-4 | Mod Level for site_part not in database
-5 | Part Number for mod_level not in database
-6 | Site for site_part not in database
-7 | User Specified not in database
-8 | "Changed Details" gbst_elm record (3900) not in database
-9 | Quantity specified can not be < 1
-10 | Serial number specified, so quantity can't be > 1
-11 | Part Number is serialized, so quantity can't be > 1
-12 | Part Number is not serialized, so serial number is invalid
-13 | Specified Serial Number is already in use
-17 | The new mod_level is not found for the part of the site_part

Examples

Modify site_part 268435460. Change the serial number to "1234.56", and generate activity logs.

Visual Basic:

Dim ret_int    As Integer

ret_int = fcinter.modify_sp(268435460, "", "1234.56", "", _
                    "", "", "", 1, "", "", "", "", "", true)

JavaScript:

var ret_int = fcinter.modify_sp(268435460, "", "1234.56", "",
                    "", "", "", 1, "", "", "", "", "", true);

Joe Shumaker renewed the service coverage for site_part 268435444. Update the service end date to reflect the new coverage. Generate the associated activity logs.

Visual Basic:

Dim ret_int As Integer

ret_int = fcinter.modify_sp(268435444, "", "", "", "", "", "", 1, "", _
                            "", "07/12/2000", "Joe Shumaker", "", true)

JavaScript:

var ret_int = fcinter.modify_sp(268435444, "", "", "", "", "", "", 1, "",
                                "", "07/12/2000", "Joe Shumaker", "", true);


move_sp | fcSDK Documentation

move_sp

Public Function move_sp(ByVal sp_objid As Long, _
                  ByVal move_date As String, ByVal parent_sp_objid As Long, _
                  ByVal site_id As String, ByVal parent_bin_objid As Long, _
                  ByVal add_activity As Boolean, ByVal user_name As String, _
                  ByVal install_and_move As Boolean) As Integer

Description

This API moves an existing site_part from one location to another within the Clarify site configuration. The site part to be moved must be current (not de-installed). The site_part can be moved to one (and only one!) of three places:

To the top-level at a site. Specify the site_id only.

Underneath another part. Specify the parent site_part objid only.

In a product bin. Specify the bin objid only.

Only one of the three locations may be specified. In addition, the API allows for the generation of the three standard activity log entries, and the user performing the move may be specified.

When a site_part is moved, all sub-site_parts underneath it are also moved.

Parameters

Parameter Name | Required? | Description
sp_objid | Yes | The OBJID of the site_part to be moved
move_date | No | The date that the site_part is being moved
parent_sp_objid | No | The OBJID of the site_part under which you wish to move the site_part. Only specified if the site_part is to be moved under another site_part
site_id | No | The site ID of the site to which you will move the site_part. Only specified for moves to the top-level of a site
parent_bin_objid | No | The bin objid to move the site_part to. Only specified if the site_part is to be placed in a bin
add_activity | Yes | Should activity log records be created, or not?
user_name | No | The user who moved the site_part. If left blank, the current user performs the move
install_and_move | Yes | Should the activity be listed as "Install (Move)" (True), or just "Move" (False)?

Returns

Value | Meaning
0 | No errors
-1 | Both a parent_site_part objid and a parent_bin_objid specified
-2 | Both a parent_site_part objid and a site_id specified
-3 | Both a site_id and parent_bin_objid specified
-4 | Cannot find specified user in database
-5 | Site part specified is not found in the database
-6 | Parent site_part specified is not found in the database
-7 | Install site specified is not found in the database
-8 | Parent bin specified is not found in the database
-9 | Cannot find the 'Move'/'Install(Move)' activity string with rank = 3700/11900
-10 | Site_part to be moved is currently de-installed
-11 | Cannot move the part (which is denoted only to be installed under another part) to the top-level of the site or under a bin
-12 | Cannot move the part (which is denoted only to be installed at the site or under a bin) under another part
-13 | No site part OBJID was specified

Examples

Move site_part 268435457 to the top level of site "4". Generate activity logs. Sam performs the move.

Visual Basic:

Dim ret_int As Integer

ret_int = fcfo.move_sp(268435457, 0, "4", 0, True, "sam", False)

JavaScript:

var ret_int = fcfo.move_sp(268435457, 0, "4", 0, true, "sam", false);

Move the same part under site_part 268435555. Don't generate activities, and use the default user.

Visual Basic:

Dim ret_int As Integer

ret_int = fcfo.move_sp(268435457, 268435555, "", 0, False, "", False)

JavaScript:

var ret_int = fcfo.move_sp(268435457, 268435555, "", 0, false, "", false);